HTMLEditorKit.LinkController (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class HTMLEditorKit.LinkController

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.text.html.HTMLEditorKit.LinkController
  • All Implemented Interfaces:
    MouseListener, MouseMotionListener, MouseWheelListener, Serializable, EventListener
    Enclosing class:
    HTMLEditorKit

    public static class HTMLEditorKit.LinkController
extends MouseAdapter
implements MouseMotionListener, Serializable
    Class to watch the associated component and fire hyperlink events on it when appropriate.

    • Constructor Summary

      Constructors
      Constructor and Description
      LinkController()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      protected void activateLink(int pos, JEditorPane editor)
      Calls linkActivated on the associated JEditorPane if the given position represents a link.
      void mouseClicked(MouseEvent e)
      Called for a mouse click event.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.

      • Methods inherited from class java.awt.event.MouseAdapter

        mouseEntered, mouseExited, mousePressed, mouseReleased, mouseWheelMoved

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LinkController

        public LinkController()

    • Method Detail

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        Called for a mouse click event. If the component is read-only (ie a browser) then the clicked event is used to drive an attempt to follow the reference specified by a link.
        Specified by:
        mouseClicked in interface MouseListener
        Overrides:
        mouseClicked in class MouseAdapter
        Parameters:
        e - the mouse event
        See Also:
        MouseListener.mouseClicked(java.awt.event.MouseEvent)

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        Specified by:
        mouseDragged in interface MouseMotionListener
        Overrides:
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        Specified by:
        mouseMoved in interface MouseMotionListener
        Overrides:
        mouseMoved in class MouseAdapter

      • activateLink

        protected void activateLink(int pos,
                            JEditorPane editor)
        Calls linkActivated on the associated JEditorPane if the given position represents a link.

        This is implemented to forward to the method with the same name, but with the following args both == -1.

        Parameters:
        pos - the position
        editor - the editor pane
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HTMLEditorKit.Parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class HTMLEditorKit.Parser

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.Parser
  • Direct Known Subclasses:
    ParserDelegator
    Enclosing class:
    HTMLEditorKit

    public abstract static class HTMLEditorKit.Parser
extends Object
    Interface to be supported by the parser. This enables providing a different parser while reusing some of the implementation provided by this editor kit.

    • Constructor Summary

      Constructors
      Constructor and Description
      Parser()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      Parse the given stream and drive the given callback with the results of the parse.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Parser

        public Parser()

    • Method Detail

      • parse

        public abstract void parse(Reader r,
                           HTMLEditorKit.ParserCallback cb,
                           boolean ignoreCharSet)
                    throws IOException
        Parse the given stream and drive the given callback with the results of the parse. This method should be implemented to be thread-safe.
        Throws:
        IOException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HTMLEditorKit.ParserCallback (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class HTMLEditorKit.ParserCallback

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
  • Direct Known Subclasses:
    HTMLDocument.HTMLReader
    Enclosing class:
    HTMLEditorKit

    public static class HTMLEditorKit.ParserCallback
extends Object
    The result of parsing drives these callback methods. The open and close actions should be balanced. The flush method will be the last method called, to give the receiver a chance to flush any pending data into the document.

    Refer to DocumentParser, the default parser used, for further information on the contents of the AttributeSets, the positions, and other info.

    See Also:
    DocumentParser

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Object IMPLIED
      This is passed as an attribute in the attributeset to indicate the element is implied eg, the string '<>foo<\t>' contains an implied html element and an implied body element.

    • Constructor Summary

      Constructors
      Constructor and Description
      ParserCallback()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      void | flush()
      void | handleComment(char[] data, int pos)
      void handleEndOfLineString(String eol)
      This is invoked after the stream has been parsed, but before flush.
      void | handleEndTag(HTML.Tag t, int pos)
      void | handleError(String errorMsg, int pos)
      void | handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void | handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void | handleText(char[] data, int pos)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • IMPLIED

        public static final Object IMPLIED
        This is passed as an attribute in the attributeset to indicate the element is implied eg, the string '<>foo<\t>' contains an implied html element and an implied body element.
        Since:
        1.3

    • Constructor Detail

      • ParserCallback

        public ParserCallback()

    • Method Detail

      • flush

        public void flush()
           throws BadLocationException
        Throws:
        BadLocationException

      • handleText

        public void handleText(char[] data,
                       int pos)

      • handleComment

        public void handleComment(char[] data,
                          int pos)

      • handleStartTag

        public void handleStartTag(HTML.Tag t,
                           MutableAttributeSet a,
                           int pos)

      • handleEndTag

        public void handleEndTag(HTML.Tag t,
                         int pos)

      • handleSimpleTag

        public void handleSimpleTag(HTML.Tag t,
                            MutableAttributeSet a,
                            int pos)

      • handleError

        public void handleError(String errorMsg,
                        int pos)

      • handleEndOfLineString

        public void handleEndOfLineString(String eol)
        This is invoked after the stream has been parsed, but before flush. eol will be one of \n, \r or \r\n, which ever is encountered the most in parsing the stream.
        Since:
        1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HTMLFrameHyperlinkEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class HTMLFrameHyperlinkEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    FormSubmitEvent

    public class HTMLFrameHyperlinkEvent
extends HyperlinkEvent
    HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.event.HyperlinkEvent

        HyperlinkEvent.EventType

    • Field Summary

      • Fields inherited from class java.util.EventObject

        source

    • Constructor Summary

      Constructors
      Constructor and Description
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
      Creates a new object representing a html frame hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
      Creates a new object representing a hypertext link event.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getTarget()
      returns the target for the link.

      • Methods inherited from class javax.swing.event.HyperlinkEvent

        getDescription, getEventType, getInputEvent, getSourceElement, getURL

      • Methods inherited from class java.util.EventObject

        getSource, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String targetFrame)
        Creates a new object representing a html frame hypertext link event.
        Parameters:
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String desc,
                               String targetFrame)
        Creates a new object representing a hypertext link event.
        Parameters:
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        desc - a description
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               Element sourceElement,
                               String targetFrame)
        Creates a new object representing a hypertext link event.
        Parameters:
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        sourceElement - the element that corresponds to the source of the event
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String desc,
                               Element sourceElement,
                               String targetFrame)
        Creates a new object representing a hypertext link event.
        Parameters:
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        desc - a description
        sourceElement - the element that corresponds to the source of the event
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String desc,
                               Element sourceElement,
                               InputEvent inputEvent,
                               String targetFrame)
        Creates a new object representing a hypertext link event.
        Parameters:
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        desc - a description
        sourceElement - the element that corresponds to the source of the event
        inputEvent - InputEvent that triggered the hyperlink event
        targetFrame - the Frame to display the document in
        Since:
        1.7

    • Method Detail

      • getTarget

        public String getTarget()
        returns the target for the link.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HTMLWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class HTMLWriter

  • java.lang.Object
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter

  • public class HTMLWriter
extends AbstractWriter
    This is a writer for HTMLDocuments.

    • Field Summary

      • Fields inherited from class javax.swing.text.AbstractWriter

        NEWLINE

    • Constructor Summary

      Constructors
      Constructor and Description
      HTMLWriter(Writer w, HTMLDocument doc)
      Creates a new HTMLWriter.
      HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
      Creates a new HTMLWriter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      protected void closeOutUnwantedEmbeddedTags(AttributeSet attr)
      Searches the attribute set and for each tag that is stored in the tag vector.
      protected void comment(Element elem)
      Writes out comments.
      protected void emptyTag(Element elem)
      Writes out all empty elements (all tags that have no corresponding end tag).
      protected void endTag(Element elem)
      Writes out an end tag for the element.
      protected boolean isBlockTag(AttributeSet attr)
      Determines if the HTML.Tag associated with the element is a block tag.
      protected boolean matchNameAttribute(AttributeSet attr, HTML.Tag tag)
      Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.
      protected void output(char[] chars, int start, int length)
      This method is overriden to map any character entities, such as < to &lt;.
      protected void selectContent(AttributeSet attr)
      Writes out the content of the SELECT form element.
      protected void startTag(Element elem)
      Writes out a start tag for the element.
      protected boolean synthesizedElement(Element elem)
      Returns true if the element is a synthesized element.
      protected void text(Element elem)
      Writes out text.
      protected void textAreaContent(AttributeSet attr)
      Writes out text that is contained in a TEXTAREA form element.
      void write()
      Iterates over the Element tree and controls the writing out of all the tags and its attributes.
      protected void writeAttributes(AttributeSet attr)
      Writes out the attribute set.
      protected void writeEmbeddedTags(AttributeSet attr)
      Searches for embedded tags in the AttributeSet and writes them out.
      protected void writeLineSeparator()
      Writes the line separator.
      protected void writeOption(Option option)
      Writes out the content of the Option form element.

      • Methods inherited from class javax.swing.text.AbstractWriter

        decrIndent, getCanWrapLines, getCurrentLineLength, getDocument, getElementIterator, getEndOffset, getIndentLevel, getIndentSpace, getLineLength, getLineSeparator, getStartOffset, getText, getWriter, incrIndent, indent, inRange, isLineEmpty, setCanWrapLines, setCurrentLineLength, setIndentSpace, setLineLength, setLineSeparator, write, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HTMLWriter

        public HTMLWriter(Writer w,
                  HTMLDocument doc)
        Creates a new HTMLWriter.
        Parameters:
        w - a Writer
        doc - an HTMLDocument

      • HTMLWriter

        public HTMLWriter(Writer w,
                  HTMLDocument doc,
                  int pos,
                  int len)
        Creates a new HTMLWriter.
        Parameters:
        w - a Writer
        doc - an HTMLDocument
        pos - the document location from which to fetch the content
        len - the amount to write out

    • Method Detail

      • write

        public void write()
           throws IOException,
                  BadLocationException
        Iterates over the Element tree and controls the writing out of all the tags and its attributes.
        Specified by:
        write in class AbstractWriter
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeAttributes

        protected void writeAttributes(AttributeSet attr)
                        throws IOException
        Writes out the attribute set. Ignores all attributes with a key of type HTML.Tag, attributes with a key of type StyleConstants, and attributes with a key of type HTML.Attribute.ENDTAG.
        Overrides:
        writeAttributes in class AbstractWriter
        Parameters:
        attr - an AttributeSet
        Throws:
        IOException - on any I/O error

      • emptyTag

        protected void emptyTag(Element elem)
                 throws BadLocationException,
                        IOException
        Writes out all empty elements (all tags that have no corresponding end tag).
        Parameters:
        elem - an Element
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • isBlockTag

        protected boolean isBlockTag(AttributeSet attr)
        Determines if the HTML.Tag associated with the element is a block tag.
        Parameters:
        attr - an AttributeSet
        Returns:
        true if tag is block tag, false otherwise.

      • startTag

        protected void startTag(Element elem)
                 throws IOException,
                        BadLocationException
        Writes out a start tag for the element. Ignores all synthesized elements.
        Parameters:
        elem - an Element
        Throws:
        IOException - on any I/O error
        BadLocationException

      • textAreaContent

        protected void textAreaContent(AttributeSet attr)
                        throws BadLocationException,
                               IOException
        Writes out text that is contained in a TEXTAREA form element.
        Parameters:
        attr - an AttributeSet
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • text

        protected void text(Element elem)
             throws BadLocationException,
                    IOException
        Writes out text. If a range is specified when the constructor is invoked, then only the appropriate range of text is written out.
        Overrides:
        text in class AbstractWriter
        Parameters:
        elem - an Element
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • selectContent

        protected void selectContent(AttributeSet attr)
                      throws IOException
        Writes out the content of the SELECT form element.
        Parameters:
        attr - the AttributeSet associated with the form element
        Throws:
        IOException - on any I/O error

      • writeOption

        protected void writeOption(Option option)
                    throws IOException
        Writes out the content of the Option form element.
        Parameters:
        option - an Option
        Throws:
        IOException - on any I/O error

      • endTag

        protected void endTag(Element elem)
               throws IOException
        Writes out an end tag for the element.
        Parameters:
        elem - an Element
        Throws:
        IOException - on any I/O error

      • comment

        protected void comment(Element elem)
                throws BadLocationException,
                       IOException
        Writes out comments.
        Parameters:
        elem - an Element
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • synthesizedElement

        protected boolean synthesizedElement(Element elem)
        Returns true if the element is a synthesized element. Currently we are only testing for the p-implied tag.

      • matchNameAttribute

        protected boolean matchNameAttribute(AttributeSet attr,
                                     HTML.Tag tag)
        Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.

      • writeEmbeddedTags

        protected void writeEmbeddedTags(AttributeSet attr)
                          throws IOException
        Searches for embedded tags in the AttributeSet and writes them out. It also stores these tags in a vector so that when appropriate the corresponding end tags can be written out.
        Throws:
        IOException - on any I/O error

      • closeOutUnwantedEmbeddedTags

        protected void closeOutUnwantedEmbeddedTags(AttributeSet attr)
                                     throws IOException
        Searches the attribute set and for each tag that is stored in the tag vector. If the tag is not found, then the tag is removed from the vector and a corresponding end tag is written out.
        Throws:
        IOException - on any I/O error

      • writeLineSeparator

        protected void writeLineSeparator()
                           throws IOException
        Writes the line separator. This is overriden to make sure we don't replace the newline content in case it is outside normal ascii.
        Overrides:
        writeLineSeparator in class AbstractWriter
        Throws:
        IOException
        Since:
        1.3

      • output

        protected void output(char[] chars,
                      int start,
                      int length)
               throws IOException
        This method is overriden to map any character entities, such as < to &lt;. super.output will be invoked to write the content.
        Overrides:
        output in class AbstractWriter
        Throws:
        IOException
        Since:
        1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ImageView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class ImageView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.html.ImageView
  • All Implemented Interfaces:
    SwingConstants

    public class ImageView
extends View
    View of an Image, intended to support the HTML <IMG> tag. Supports scaling via the HEIGHT and WIDTH attributes of the tag. If the image is unable to be loaded any text specified via the ALT attribute will be rendered.

    While this class has been part of swing for a while now, it is public as of 1.4.

    Since:
    1.4
    See Also:
    IconView

    • Field Summary

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • Constructor Summary

      Constructors
      Constructor and Description
      ImageView(Element elem)
      Creates a new view that represents an IMG element.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Invoked when the Elements attributes have changed.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      String getAltText()
      Returns the text to display if the image can't be loaded.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      Image getImage()
      Returns the image to render.
      URL getImageURL()
      Return a URL for the image source, or null if it could not be determined.
      Icon getLoadingImageIcon()
      Returns the icon to use while in the process of loading the image.
      boolean getLoadsSynchronously()
      Returns true if the image should be loaded when first asked for.
      Icon getNoImageIcon()
      Returns the icon to use if the image couldn't be found.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      protected StyleSheet getStyleSheet()
      Convenience method to get the StyleSheet.
      String getToolTipText(float x, float y, Shape allocation)
      For images the tooltip text comes from text specified with the ALT attribute.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape a)
      Paints the View.
      void setLoadsSynchronously(boolean newValue)
      Sets how the image is loaded.
      void setParent(View parent)
      Establishes the parent view for this view.
      protected void setPropertiesFromAttributes()
      Update any cached values that come from attributes.
      void setSize(float width, float height)
      Sets the size of the view.
      int viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • Methods inherited from class javax.swing.text.View

        append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, updateChildren, updateLayout, viewToModel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ImageView

        public ImageView(Element elem)
        Creates a new view that represents an IMG element.
        Parameters:
        elem - the element to create a view for

    • Method Detail

      • getAltText

        public String getAltText()
        Returns the text to display if the image can't be loaded. This is obtained from the Elements attribute set with the attribute name HTML.Attribute.ALT.

      • getImageURL

        public URL getImageURL()
        Return a URL for the image source, or null if it could not be determined.

      • getNoImageIcon

        public Icon getNoImageIcon()
        Returns the icon to use if the image couldn't be found.

      • getLoadingImageIcon

        public Icon getLoadingImageIcon()
        Returns the icon to use while in the process of loading the image.

      • getImage

        public Image getImage()
        Returns the image to render.

      • setLoadsSynchronously

        public void setLoadsSynchronously(boolean newValue)
        Sets how the image is loaded. If newValue is true, the image we be loaded when first asked for, otherwise it will be loaded asynchronously. The default is to not load synchronously, that is to load the image asynchronously.

      • getLoadsSynchronously

        public boolean getLoadsSynchronously()
        Returns true if the image should be loaded when first asked for.

      • getStyleSheet

        protected StyleSheet getStyleSheet()
        Convenience method to get the StyleSheet.

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        Overrides:
        getAttributes in class View

      • getToolTipText

        public String getToolTipText(float x,
                             float y,
                             Shape allocation)
        For images the tooltip text comes from text specified with the ALT attribute. This is overriden to return getAltText.
        Overrides:
        getToolTipText in class View
        See Also:
        JTextComponent.getToolTipText(java.awt.event.MouseEvent)

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Update any cached values that come from attributes.

      • setParent

        public void setParent(View parent)
        Establishes the parent view for this view. Seize this moment to cache the AWT Container I'm in.
        Overrides:
        setParent in class View
        Parameters:
        parent - the new parent, or null if the view is being removed from a parent

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
        Invoked when the Elements attributes have changed. Recreates the image.
        Overrides:
        changedUpdate in class View
        Parameters:
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        See Also:
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • paint

        public void paint(Graphics g,
                  Shape a)
        Paints the View.
        Specified by:
        paint in class View
        Parameters:
        g - the rendering surface to use
        a - the allocated region to render into
        See Also:
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        Specified by:
        getPreferredSpan in class View
        Parameters:
        axis - may be either X_AXIS or Y_AXIS
        Returns:
        the span the view would like to be rendered into; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        See Also:
        View.getPreferredSpan(int)

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. This is implemented to give the alignment to the bottom of the icon along the y axis, and the default along the x axis.
        Overrides:
        getAlignment in class View
        Parameters:
        axis - may be either X_AXIS or Y_AXIS
        Returns:
        the desired alignment; this should be a value between 0.0 and 1.0 where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin; an alignment of 0.5 would be the center of the view

      • modelToView

        public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        Specified by:
        modelToView in class View
        Parameters:
        pos - the position to convert
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        Returns:
        the bounding box of the given position
        Throws:
        BadLocationException - if the given position does not represent a valid location in the associated document
        See Also:
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        Specified by:
        viewToModel in class View
        Parameters:
        x - the X coordinate
        y - the Y coordinate
        a - the allocated region to render into
        Returns:
        the location within the model that best represents the given point of view
        See Also:
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • setSize

        public void setSize(float width,
                    float height)
        Sets the size of the view. This should cause layout of the view if it has any layout duties.
        Overrides:
        setSize in class View
        Parameters:
        width - the width >= 0
        height - the height >= 0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InlineView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class InlineView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.GlyphView
        • javax.swing.text.LabelView
          • javax.swing.text.html.InlineView
  • All Implemented Interfaces:
    Cloneable, SwingConstants, TabableView

    public class InlineView
extends LabelView
    Displays the inline element styles based upon css attributes.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.text.GlyphView

        GlyphView.GlyphPainter

    • Field Summary

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • Constructor Summary

      Constructors
      Constructor and Description
      InlineView(Element elem)
      Constructs a new view wrapped on an element.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      View breakView(int axis, int offset, float pos, float len)
      Tries to break this view on the given axis.
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      int getBreakWeight(int axis, float pos, float len)
      Determines how attractive a break opportunity in this view is.
      protected StyleSheet | getStyleSheet()
      void insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      protected void setPropertiesFromAttributes()
      Set the cached properties from the attributes.

      • Methods inherited from class javax.swing.text.LabelView

        getBackground, getFont, getFontMetrics, getForeground, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setBackground, setStrikeThrough, setSubscript, setSuperscript, setUnderline

      • Methods inherited from class javax.swing.text.GlyphView

        checkPainter, clone, createFragment, getAlignment, getEndOffset, getGlyphPainter, getMinimumSpan, getNextVisualPositionFrom, getPartialSpan, getPreferredSpan, getStartOffset, getTabbedSpan, getTabExpander, getText, modelToView, paint, setGlyphPainter, viewToModel

      • Methods inherited from class javax.swing.text.View

        append, forwardUpdate, forwardUpdateToView, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.swing.text.TabableView

        getPartialSpan, getTabbedSpan

    • Constructor Detail

      • InlineView

        public InlineView(Element elem)
        Constructs a new view wrapped on an element.
        Parameters:
        elem - the element

    • Method Detail

      • insertUpdate

        public void insertUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for. If either parameter is null, behavior of this method is implementation dependent.
        Overrides:
        insertUpdate in class GlyphView
        Parameters:
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        Since:
        1.5
        See Also:
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for. If either parameter is null, behavior of this method is implementation dependent.
        Overrides:
        removeUpdate in class GlyphView
        Parameters:
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        Since:
        1.5
        See Also:
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        Overrides:
        changedUpdate in class LabelView
        Parameters:
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        See Also:
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        Overrides:
        getAttributes in class View

      • getBreakWeight

        public int getBreakWeight(int axis,
                          float pos,
                          float len)
        Determines how attractive a break opportunity in this view is. This can be used for determining which view is the most attractive to call breakView on in the process of formatting. A view that represents text that has whitespace in it might be more attractive than a view that has no whitespace, for example. The higher the weight, the more attractive the break. A value equal to or lower than BadBreakWeight should not be considered for a break. A value greater than or equal to ForcedBreakWeight should be broken.

        This is implemented to provide the default behavior of returning BadBreakWeight unless the length is greater than the length of the view in which case the entire view represents the fragment. Unless a view has been written to support breaking behavior, it is not attractive to try and break the view. An example of a view that does support breaking is LabelView. An example of a view that uses break weight is ParagraphView.

        Overrides:
        getBreakWeight in class GlyphView
        Parameters:
        axis - may be either View.X_AXIS or View.Y_AXIS
        pos - the potential location of the start of the broken view >= 0. This may be useful for calculating tab positions.
        len - specifies the relative length from pos where a potential break is desired >= 0.
        Returns:
        the weight, which should be a value between ForcedBreakWeight and BadBreakWeight.
        See Also:
        LabelView, ParagraphView, View.BadBreakWeight, View.GoodBreakWeight, View.ExcellentBreakWeight, View.ForcedBreakWeight

      • breakView

        public View breakView(int axis,
                      int offset,
                      float pos,
                      float len)
        Tries to break this view on the given axis. Refer to View.breakView(int, int, float, float) for a complete description of this method.

        Behavior of this method is unspecified in case axis is neither View.X_AXIS nor View.Y_AXIS, and in case offset, pos, or len is null.

        Overrides:
        breakView in class GlyphView
        Parameters:
        axis - may be either View.X_AXIS or View.Y_AXIS
        offset - the location in the document model that a broken fragment would occupy >= 0. This would be the starting offset of the fragment returned
        pos - the position along the axis that the broken view would occupy >= 0. This may be useful for things like tab calculations
        len - specifies the distance along the axis where a potential break is desired >= 0
        Returns:
        the fragment of the view that represents the given span.
        Since:
        1.5
        See Also:
        View.breakView(int, int, float, float)

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Set the cached properties from the attributes.
        Overrides:
        setPropertiesFromAttributes in class LabelView

      • getStyleSheet

        protected StyleSheet getStyleSheet()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ListView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class ListView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
  • All Implemented Interfaces:
    SwingConstants

    public class ListView
extends BlockView
    A view implementation to display an html list

    • Field Summary

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • Constructor Summary

      Constructors
      Constructor and Description
      ListView(Element elem)
      Creates a new view that represents a list element.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      float getAlignment(int axis)
      Calculates the desired shape of the list.
      void paint(Graphics g, Shape allocation)
      Renders using the given rendering surface and area on that surface.
      protected void paintChild(Graphics g, Rectangle alloc, int index)
      Paints one of the children; called by paint().
      protected void setPropertiesFromAttributes()
      Update any cached values that come from attributes.

      • Methods inherited from class javax.swing.text.html.BlockView

        calculateMajorAxisRequirements, calculateMinorAxisRequirements, changedUpdate, getAttributes, getMaximumSpan, getMinimumSpan, getPreferredSpan, getResizeWeight, getStyleSheet, layoutMinorAxis, setParent

      • Methods inherited from class javax.swing.text.BoxView

        baselineLayout, baselineRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, preferenceChanged, replace, setAxis, setSize, viewToModel

      • Methods inherited from class javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets

      • Methods inherited from class javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ListView

        public ListView(Element elem)
        Creates a new view that represents a list element.
        Parameters:
        elem - the element to create a view for

    • Method Detail

      • getAlignment

        public float getAlignment(int axis)
        Calculates the desired shape of the list.
        Overrides:
        getAlignment in class BlockView
        Parameters:
        axis - may be either X_AXIS or Y_AXIS
        Returns:
        the desired span
        See Also:
        View.getPreferredSpan(int)

      • paint

        public void paint(Graphics g,
                  Shape allocation)
        Renders using the given rendering surface and area on that surface.
        Overrides:
        paint in class BlockView
        Parameters:
        g - the rendering surface to use
        allocation - the allocated region to render into
        See Also:
        View.paint(java.awt.Graphics, java.awt.Shape)

      • paintChild

        protected void paintChild(Graphics g,
                          Rectangle alloc,
                          int index)
        Paints one of the children; called by paint(). By default that is all it does, but a subclass can use this to paint things relative to the child.
        Overrides:
        paintChild in class BoxView
        Parameters:
        g - the graphics context
        alloc - the allocated region to render the child into
        index - the index of the child

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Description copied from class: BlockView
        Update any cached values that come from attributes.
        Overrides:
        setPropertiesFromAttributes in class BlockView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MinimalHTMLWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class MinimalHTMLWriter

  • java.lang.Object
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.MinimalHTMLWriter

  • public class MinimalHTMLWriter
extends AbstractWriter
    MinimalHTMLWriter is a fallback writer used by the HTMLEditorKit to write out HTML for a document that is a not produced by the EditorKit. The format for the document is:
     <html>
   <head>
     <style>
        <!-- list of named styles
         p.normal {
            font-family: SansSerif;
            margin-height: 0;
            font-size: 14
         }
        -->
      </style>
   </head>
   <body>
    <p style=normal>
        Bold, italic, and underline attributes
        of the run are emitted as HTML tags.
        The remaining attributes are emitted as
        part of the style attribute of a <span> tag.
        The syntax is similar to inline styles.
    </p>
   </body>
 </html>

    • Field Summary

      • Fields inherited from class javax.swing.text.AbstractWriter

        NEWLINE

    • Constructor Summary

      Constructors
      Constructor and Description
      MinimalHTMLWriter(Writer w, StyledDocument doc)
      Creates a new MinimalHTMLWriter.
      MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
      Creates a new MinimalHTMLWriter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      protected void endFontTag()
      This is no longer used, instead <span> will be written out.
      protected boolean inFontTag()
      Returns true if we are currently in a <font> tag.
      protected boolean isText(Element elem)
      Returns true if the element is a text element.
      protected void startFontTag(String style)
      This is no longer used, instead <span> will be written out.
      protected void text(Element elem)
      Writes out text.
      void write()
      Generates HTML output from a StyledDocument.
      protected void writeAttributes(AttributeSet attr)
      Writes out all the attributes for the following types: StyleConstants.ParagraphConstants, StyleConstants.CharacterConstants, StyleConstants.FontConstants, StyleConstants.ColorConstants.
      protected void writeBody()
      Iterates over the elements in the document and processes elements based on whether they are branch elements or leaf elements.
      protected void writeComponent(Element elem)
      Responsible for handling Component Elements; deliberately unimplemented.
      protected void writeContent(Element elem, boolean needsIndenting)
      Writes out the attribute set in an HTML-compliant manner.
      protected void writeEndParagraph()
      Emits an end tag for a <p> tag.
      protected void writeEndTag(String endTag)
      Writes out an end tag appropriately indented.
      protected void writeHeader()
      Writes out the <head> and <style> tags, and then invokes writeStyles() to write out all the named styles as the content of the <style> tag.
      protected void writeHTMLTags(AttributeSet attr)
      Generates bold <b>, italic <i>, and <u> tags for the text based on its attribute settings.
      protected void writeImage(Element elem)
      Responsible for handling Icon Elements; deliberately unimplemented.
      protected void writeLeaf(Element elem)
      Responsible for writing out other non-text leaf elements.
      protected void writeNonHTMLAttributes(AttributeSet attr)
      Writes out the remaining character-level attributes (attributes other than bold, italic, and underline) in an HTML-compliant way.
      protected void writeStartParagraph(Element elem)
      Emits the start tag for a paragraph.
      protected void writeStartTag(String tag)
      Writes out a start tag appropriately indented.
      protected void writeStyles()
      Writes out all the named styles as the content of the <style> tag.

      • Methods inherited from class javax.swing.text.AbstractWriter

        decrIndent, getCanWrapLines, getCurrentLineLength, getDocument, getElementIterator, getEndOffset, getIndentLevel, getIndentSpace, getLineLength, getLineSeparator, getStartOffset, getText, getWriter, incrIndent, indent, inRange, isLineEmpty, output, setCanWrapLines, setCurrentLineLength, setIndentSpace, setLineLength, setLineSeparator, write, write, write, writeLineSeparator

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MinimalHTMLWriter

        public MinimalHTMLWriter(Writer w,
                         StyledDocument doc)
        Creates a new MinimalHTMLWriter.
        Parameters:
        w - Writer
        doc - StyledDocument

      • MinimalHTMLWriter

        public MinimalHTMLWriter(Writer w,
                         StyledDocument doc,
                         int pos,
                         int len)
        Creates a new MinimalHTMLWriter.
        Parameters:
        w - Writer
        doc - StyledDocument
        pos - The location in the document to fetch the content.
        len - The amount to write out.

    • Method Detail

      • write

        public void write()
           throws IOException,
                  BadLocationException
        Generates HTML output from a StyledDocument.
        Specified by:
        write in class AbstractWriter
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeAttributes

        protected void writeAttributes(AttributeSet attr)
                        throws IOException
        Writes out all the attributes for the following types: StyleConstants.ParagraphConstants, StyleConstants.CharacterConstants, StyleConstants.FontConstants, StyleConstants.ColorConstants. The attribute name and value are separated by a colon. Each pair is separated by a semicolon.
        Overrides:
        writeAttributes in class AbstractWriter
        Parameters:
        attr - an AttributeSet.
        Throws:
        IOException - on any I/O error

      • text

        protected void text(Element elem)
             throws IOException,
                    BadLocationException
        Writes out text.
        Overrides:
        text in class AbstractWriter
        Parameters:
        elem - an Element.
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeStartTag

        protected void writeStartTag(String tag)
                      throws IOException
        Writes out a start tag appropriately indented. Also increments the indent level.
        Throws:
        IOException - on any I/O error

      • writeEndTag

        protected void writeEndTag(String endTag)
                    throws IOException
        Writes out an end tag appropriately indented. Also decrements the indent level.
        Throws:
        IOException - on any I/O error

      • writeHeader

        protected void writeHeader()
                    throws IOException
        Writes out the <head> and <style> tags, and then invokes writeStyles() to write out all the named styles as the content of the <style> tag. The content is surrounded by valid HTML comment markers to ensure that the document is viewable in applications/browsers that do not support the tag.
        Throws:
        IOException - on any I/O error

      • writeStyles

        protected void writeStyles()
                    throws IOException
        Writes out all the named styles as the content of the <style> tag.
        Throws:
        IOException - on any I/O error

      • writeBody

        protected void writeBody()
                  throws IOException,
                         BadLocationException
        Iterates over the elements in the document and processes elements based on whether they are branch elements or leaf elements. This method specially handles leaf elements that are text.
        Throws:
        IOException - on any I/O error
        BadLocationException

      • writeEndParagraph

        protected void writeEndParagraph()
                          throws IOException
        Emits an end tag for a <p> tag. Before writing out the tag, this method ensures that all other tags that have been opened are appropriately closed off.
        Throws:
        IOException - on any I/O error

      • writeStartParagraph

        protected void writeStartParagraph(Element elem)
                            throws IOException
        Emits the start tag for a paragraph. If the paragraph has a named style associated with it, then this method also generates a class attribute for the <p> tag and sets its value to be the name of the style.
        Throws:
        IOException - on any I/O error

      • writeLeaf

        protected void writeLeaf(Element elem)
                  throws IOException
        Responsible for writing out other non-text leaf elements.
        Throws:
        IOException - on any I/O error

      • writeImage

        protected void writeImage(Element elem)
                   throws IOException
        Responsible for handling Icon Elements; deliberately unimplemented. How to implement this method is an issue of policy. For example, if you're generating an <img> tag, how should you represent the src attribute (the location of the image)? In certain cases it could be a URL, in others it could be read from a stream.
        Parameters:
        elem - element of type StyleConstants.IconElementName
        Throws:
        IOException

      • writeComponent

        protected void writeComponent(Element elem)
                       throws IOException
        Responsible for handling Component Elements; deliberately unimplemented. How this method is implemented is a matter of policy.
        Throws:
        IOException

      • isText

        protected boolean isText(Element elem)
        Returns true if the element is a text element.

      • writeContent

        protected void writeContent(Element elem,
                            boolean needsIndenting)
                     throws IOException,
                            BadLocationException
        Writes out the attribute set in an HTML-compliant manner.
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeHTMLTags

        protected void writeHTMLTags(AttributeSet attr)
                      throws IOException
        Generates bold <b>, italic <i>, and <u> tags for the text based on its attribute settings.
        Throws:
        IOException - on any I/O error

      • writeNonHTMLAttributes

        protected void writeNonHTMLAttributes(AttributeSet attr)
                               throws IOException
        Writes out the remaining character-level attributes (attributes other than bold, italic, and underline) in an HTML-compliant way. Given that attributes such as font family and font size have no direct mapping to HTML tags, a <span> tag is generated and its style attribute is set to contain the list of remaining attributes just like inline styles.
        Throws:
        IOException - on any I/O error

      • inFontTag

        protected boolean inFontTag()
        Returns true if we are currently in a <font> tag.

      • endFontTag

        protected void endFontTag()
                   throws IOException
        This is no longer used, instead <span> will be written out.

        Writes out an end tag for the <font> tag.

        Throws:
        IOException - on any I/O error

      • startFontTag

        protected void startFontTag(String style)
                     throws IOException
        This is no longer used, instead <span> will be written out.

        Writes out a start tag for the <font> tag. Because font tags cannot be nested, this method closes out any enclosing font tag before writing out a new start tag.

        Throws:
        IOException - on any I/O error
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class ObjectView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.ComponentView
        • javax.swing.text.html.ObjectView
  • All Implemented Interfaces:
    SwingConstants

    public class ObjectView
extends ComponentView
    Component decorator that implements the view interface for <object> elements.

    This view will try to load the class specified by the classid attribute. If possible, the Classloader used to load the associated Document is used. This would typically be the same as the ClassLoader used to load the EditorKit. If the document's ClassLoader is null, Class.forName is used.

    If the class can successfully be loaded, an attempt will be made to create an instance of it by calling Class.newInstance. An attempt will be made to narrow the instance to type java.awt.Component to display the object.

    This view can also manage a set of parameters with limitations. The parameters to the <object> element are expected to be present on the associated elements attribute set as simple strings. Each bean property will be queried as a key on the AttributeSet, with the expectation that a non-null value (of type String) will be present if there was a parameter specification for the property. Reflection is used to set the parameter. Currently, this is limited to a very simple single parameter of type String.

    A simple example HTML invocation is:

          <object classid="javax.swing.JLabel">
      <param name="text" value="sample text">
      </object>

    • Field Summary

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectView(Element elem)
      Creates a new ObjectView object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      protected Component createComponent()
      Create the component.

      • Methods inherited from class javax.swing.text.ComponentView

        getAlignment, getComponent, getMaximumSpan, getMinimumSpan, getPreferredSpan, modelToView, paint, setParent, viewToModel

      • Methods inherited from class javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectView

        public ObjectView(Element elem)
        Creates a new ObjectView object.
        Parameters:
        elem - the element to decorate

    • Method Detail

      • createComponent

        protected Component createComponent()
        Create the component. The classid is used as a specification of the classname, which we try to load.
        Overrides:
        createComponent in class ComponentView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Option (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class Option

  • java.lang.Object
    • javax.swing.text.html.Option
  • All Implemented Interfaces:
    Serializable

    public class Option
extends Object
implements Serializable
    Value for the ListModel used to represent <option> elements. This is the object installed as items of the DefaultComboBoxModel used to represent the <select> element.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Constructor Summary

      Constructors
      Constructor and Description
      Option(AttributeSet attr)
      Creates a new Option object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      AttributeSet getAttributes()
      Fetch the attributes associated with this option.
      String getLabel()
      Fetch the label associated with the option.
      String getValue()
      Convenience method to return the string associated with the value attribute.
      boolean isSelected()
      Fetches the selection state associated with this option.
      void setLabel(String label)
      Sets the label to be used for the option.
      protected void setSelection(boolean state)
      Sets the selected state.
      String toString()
      String representation is the label.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Option

        public Option(AttributeSet attr)
        Creates a new Option object.
        Parameters:
        attr - the attributes associated with the option element. The attributes are copied to ensure they won't change.

    • Method Detail

      • setLabel

        public void setLabel(String label)
        Sets the label to be used for the option.

      • getLabel

        public String getLabel()
        Fetch the label associated with the option.

      • getAttributes

        public AttributeSet getAttributes()
        Fetch the attributes associated with this option.

      • toString

        public String toString()
        String representation is the label.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.

      • setSelection

        protected void setSelection(boolean state)
        Sets the selected state.

      • isSelected

        public boolean isSelected()
        Fetches the selection state associated with this option.

      • getValue

        public String getValue()
        Convenience method to return the string associated with the value attribute. If the value has not been specified, the label will be returned.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.text.html (Java Platform SE 8 )

javax.swing.text.html

Classes

  • BlockView
  • CSS
  • CSS.Attribute
  • FormSubmitEvent
  • FormView
  • HTML
  • HTML.Attribute
  • HTML.Tag
  • HTML.UnknownTag
  • HTMLDocument
  • HTMLDocument.Iterator
  • HTMLEditorKit
  • HTMLEditorKit.HTMLFactory
  • HTMLEditorKit.HTMLTextAction
  • HTMLEditorKit.InsertHTMLTextAction
  • HTMLEditorKit.LinkController
  • HTMLEditorKit.Parser
  • HTMLEditorKit.ParserCallback
  • HTMLFrameHyperlinkEvent
  • HTMLWriter
  • ImageView
  • InlineView
  • ListView
  • MinimalHTMLWriter
  • ObjectView
  • Option
  • ParagraphView
  • StyleSheet
  • StyleSheet.BoxPainter
  • StyleSheet.ListPainter

Enums

  • FormSubmitEvent.MethodType


javax.swing.text.html (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.swing.text.html

Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

See: Description

  • Class Summary
    Class Description
    BlockView
    A view implementation to display a block (as a box) with CSS specifications.
    CSS
    Defines a set of CSS attributes as a typesafe enumeration.
    CSS.Attribute
    Definitions to be used as a key on AttributeSet's that might hold CSS attributes.
    FormSubmitEvent
    FormSubmitEvent is used to notify interested parties that a form was submitted.
    FormView
    Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
    HTML
    Constants used in the HTMLDocument.
    HTML.Attribute
    Typesafe enumeration representing an HTML attribute.
    HTML.Tag
    Typesafe enumeration for an HTML tag.
    HTML.UnknownTag
    HTMLDocument
    A document that models HTML.
    HTMLDocument.Iterator
    An iterator to iterate over a particular type of tag.
    HTMLEditorKit
    The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.
    HTMLEditorKit.HTMLFactory
    A factory to build views for HTML.
    HTMLEditorKit.HTMLTextAction
    An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
    HTMLEditorKit.InsertHTMLTextAction
    InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
    HTMLEditorKit.LinkController
    Class to watch the associated component and fire hyperlink events on it when appropriate.
    HTMLEditorKit.Parser
    Interface to be supported by the parser.
    HTMLEditorKit.ParserCallback
    The result of parsing drives these callback methods.
    HTMLFrameHyperlinkEvent
    HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
    HTMLWriter
    This is a writer for HTMLDocuments.
    ImageView
    View of an Image, intended to support the HTML <IMG> tag.
    InlineView
    Displays the inline element styles based upon css attributes.
    ListView
    A view implementation to display an html list
    MinimalHTMLWriter
    MinimalHTMLWriter is a fallback writer used by the HTMLEditorKit to write out HTML for a document that is a not produced by the EditorKit.
    ObjectView
    Component decorator that implements the view interface for <object> elements.
    Option
    Value for the ListModel used to represent <option> elements.
    ParagraphView
    Displays the a paragraph, and uses css attributes for its configuration.
    StyleSheet
    Support for defining the visual characteristics of HTML views being rendered.
    StyleSheet.BoxPainter
    Class to carry out some of the duties of CSS formatting.
    StyleSheet.ListPainter
    Class to carry out some of the duties of CSS list formatting.
  • Enum Summary
    Enum Description
    FormSubmitEvent.MethodType
    Represents an HTML form method type.

Package javax.swing.text.html Description

Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Package Specification

  • HTML 3.2 Reference Specification - The HTML specification on which HTMLEditorKit is based.
Since:
1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.text.html Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.swing.text.html

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
        • javax.swing.text.html.HTMLDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.html.HTMLDocument.BlockElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter
      • javax.swing.text.html.MinimalHTMLWriter
    • javax.swing.text.html.CSS (implements java.io.Serializable)
    • javax.swing.text.html.CSS.Attribute
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit (implements javax.accessibility.Accessible)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
    • javax.swing.text.html.HTML
    • javax.swing.text.html.HTML.Attribute
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag (implements java.io.Serializable)
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
    • javax.swing.text.html.HTMLDocument.Iterator
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory (implements javax.swing.text.ViewFactory)
    • javax.swing.text.html.HTMLEditorKit.Parser
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.text.html.FormView.MouseEventListener
      • javax.swing.text.html.HTMLEditorKit.LinkController (implements java.awt.event.MouseMotionListener, java.io.Serializable)
    • javax.swing.text.html.Option (implements java.io.Serializable)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
      • javax.swing.text.html.StyleSheet
    • javax.swing.text.html.StyleSheet.BoxPainter (implements java.io.Serializable)
    • javax.swing.text.html.StyleSheet.ListPainter (implements java.io.Serializable)
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView (implements java.awt.event.ActionListener)
        • javax.swing.text.html.ObjectView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
              • javax.swing.text.html.ParagraphView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
          • javax.swing.text.html.InlineView
      • javax.swing.text.html.ImageView

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.text.html.FormSubmitEvent.MethodType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.swing.text.html (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.swing.text.html

  • Packages that use javax.swing.text.html
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.
  • Classes in javax.swing.text.html used by javax.swing.text.html
    Class and Description
    BlockView
    A view implementation to display a block (as a box) with CSS specifications.
    CSS.Attribute
    Definitions to be used as a key on AttributeSet's that might hold CSS attributes.
    FormSubmitEvent.MethodType
    Represents an HTML form method type.
    HTML.Attribute
    Typesafe enumeration representing an HTML attribute.
    HTML.Tag
    Typesafe enumeration for an HTML tag.
    HTMLDocument
    A document that models HTML.
    HTMLDocument.HTMLReader.BlockAction
    HTMLDocument.HTMLReader.SpecialAction
    HTMLDocument.HTMLReader.TagAction
    An action to be performed in response to parsing a tag.
    HTMLDocument.Iterator
    An iterator to iterate over a particular type of tag.
    HTMLEditorKit
    The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.
    HTMLEditorKit.HTMLTextAction
    An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
    HTMLEditorKit.Parser
    Interface to be supported by the parser.
    HTMLEditorKit.ParserCallback
    The result of parsing drives these callback methods.
    HTMLFrameHyperlinkEvent
    HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
    Option
    Value for the ListModel used to represent <option> elements.
    StyleSheet
    Support for defining the visual characteristics of HTML views being rendered.
    StyleSheet.BoxPainter
    Class to carry out some of the duties of CSS formatting.
    StyleSheet.ListPainter
    Class to carry out some of the duties of CSS list formatting.
  • Classes in javax.swing.text.html used by javax.swing.text.html.parser
    Class and Description
    HTML.Tag
    Typesafe enumeration for an HTML tag.
    HTMLEditorKit.Parser
    Interface to be supported by the parser.
    HTMLEditorKit.ParserCallback
    The result of parsing drives these callback methods.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParagraphView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class ParagraphView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView
              • javax.swing.text.html.ParagraphView
  • All Implemented Interfaces:
    SwingConstants, TabExpander

    public class ParagraphView
extends ParagraphView
    Displays the a paragraph, and uses css attributes for its configuration.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.text.FlowView

        FlowView.FlowStrategy

    • Field Summary

      • Fields inherited from class javax.swing.text.ParagraphView

        firstLineIndent

      • Fields inherited from class javax.swing.text.FlowView

        layoutPool, layoutSpan, strategy

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • Constructor Summary

      Constructors
      Constructor and Description
      ParagraphView(Element elem)
      Constructs a ParagraphView for the given element.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view.
      protected StyleSheet | getStyleSheet()
      boolean isVisible()
      Indicates whether or not this view should be displayed.
      void paint(Graphics g, Shape a)
      Renders using the given rendering surface and area on that surface.
      void setParent(View parent)
      Establishes the parent view for this view.
      protected void setPropertiesFromAttributes()
      Sets up the paragraph from css attributes instead of the values found in StyleConstants (i.e.

      • Methods inherited from class javax.swing.text.ParagraphView

        breakView, changedUpdate, createRow, findOffsetToCharactersInString, flipEastAndWestAtEnds, getAlignment, getBreakWeight, getClosestPositionTo, getFlowSpan, getFlowStart, getLayoutView, getLayoutViewCount, getNextNorthSouthVisualPositionFrom, getPartialSize, getTabBase, getTabSet, nextTabStop, setFirstLineIndent, setJustification, setLineSpacing

      • Methods inherited from class javax.swing.text.FlowView

        getFlowAxis, getViewIndexAtPosition, insertUpdate, layout, loadChildren, removeUpdate

      • Methods inherited from class javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • Methods inherited from class javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets

      • Methods inherited from class javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ParagraphView

        public ParagraphView(Element elem)
        Constructs a ParagraphView for the given element.
        Parameters:
        elem - the element that this view is responsible for

    • Method Detail

      • setParent

        public void setParent(View parent)
        Establishes the parent view for this view. This is guaranteed to be called before any other methods if the parent view is functioning properly.

        This is implemented to forward to the superclass as well as call the setPropertiesFromAttributes method to set the paragraph properties from the css attributes. The call is made at this time to ensure the ability to resolve upward through the parents view attributes.

        Overrides:
        setParent in class FlowView
        Parameters:
        parent - the new parent, or null if the view is being removed from a parent it was previously added to

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        Overrides:
        getAttributes in class View

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Sets up the paragraph from css attributes instead of the values found in StyleConstants (i.e. which are used by the superclass). Since
        Overrides:
        setPropertiesFromAttributes in class ParagraphView

      • getStyleSheet

        protected StyleSheet getStyleSheet()

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                                          SizeRequirements r)
        Calculate the needs for the paragraph along the minor axis.

        If size requirements are explicitly specified for the paragraph, use that requirements. Otherwise, use the requirements of the superclass ParagraphView.

        If the axis parameter is neither View.X_AXIS nor View.Y_AXIS, IllegalArgumentException is thrown. If the r parameter is null, a new SizeRequirements object is created, otherwise the supplied SizeRequirements object is returned.

        Overrides:
        calculateMinorAxisRequirements in class ParagraphView
        Parameters:
        axis - the minor axis
        r - the input SizeRequirements object
        Returns:
        the new or adjusted SizeRequirements object
        Throws:
        IllegalArgumentException - if the axis parameter is invalid
        See Also:
        SizeRequirements

      • isVisible

        public boolean isVisible()
        Indicates whether or not this view should be displayed. If none of the children wish to be displayed and the only visible child is the break that ends the paragraph, the paragraph will not be considered visible. Otherwise, it will be considered visible and return true.
        Overrides:
        isVisible in class View
        Returns:
        true if the paragraph should be displayed

      • paint

        public void paint(Graphics g,
                  Shape a)
        Renders using the given rendering surface and area on that surface. This is implemented to delegate to the superclass after stashing the base coordinate for tab calculations.
        Overrides:
        paint in class ParagraphView
        Parameters:
        g - the rendering surface to use
        a - the allocated region to render into
        See Also:
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view. Returns 0 if the view is not visible, otherwise it calls the superclass method to get the preferred span. axis.
        Overrides:
        getPreferredSpan in class BoxView
        Parameters:
        axis - may be either View.X_AXIS or View.Y_AXIS
        Returns:
        the span the view would like to be rendered into; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        See Also:
        BoxView.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis. Returns 0 if the view is not visible, otherwise it calls the superclass method to get the minimum span.
        Overrides:
        getMinimumSpan in class BoxView
        Parameters:
        axis - may be either View.X_AXIS or View.Y_AXIS
        Returns:
        the minimum span the view can be rendered into
        See Also:
        BoxView.getMinimumSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis. Returns 0 if the view is not visible, otherwise it calls the superclass method ot get the maximum span.
        Overrides:
        getMaximumSpan in class BoxView
        Parameters:
        axis - may be either View.X_AXIS or View.Y_AXIS
        Returns:
        the maximum span the view can be rendered into
        See Also:
        BoxView.getMaximumSpan(int)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StyleSheet.BoxPainter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class StyleSheet.BoxPainter

  • java.lang.Object
    • javax.swing.text.html.StyleSheet.BoxPainter
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    StyleSheet

    public static class StyleSheet.BoxPainter
extends Object
implements Serializable
    Class to carry out some of the duties of CSS formatting. Implementations of this class enable views to present the CSS formatting while not knowing anything about how the CSS values are being cached.

    As a delegate of Views, this object is responsible for the insets of a View and making sure the background is maintained according to the CSS attributes.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      float getInset(int side, View v)
      Fetches the inset needed on a given side to account for the margin, border, and padding.
      void paint(Graphics g, float x, float y, float w, float h, View v)
      Paints the CSS box according to the attributes given.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • getInset

        public float getInset(int side,
                      View v)
        Fetches the inset needed on a given side to account for the margin, border, and padding.
        Parameters:
        side - The size of the box to fetch the inset for. This can be View.TOP, View.LEFT, View.BOTTOM, or View.RIGHT.
        v - the view making the request. This is used to get the AttributeSet, and may be used to resolve percentage arguments.
        Throws:
        IllegalArgumentException - for an invalid direction

      • paint

        public void paint(Graphics g,
                  float x,
                  float y,
                  float w,
                  float h,
                  View v)
        Paints the CSS box according to the attributes given. This should paint the border, padding, and background.
        Parameters:
        g - the rendering surface.
        x - the x coordinate of the allocated area to render into.
        y - the y coordinate of the allocated area to render into.
        w - the width of the allocated area to render into.
        h - the height of the allocated area to render into.
        v - the view making the request. This is used to get the AttributeSet, and may be used to resolve percentage arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StyleSheet (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class StyleSheet

  • java.lang.Object
    • javax.swing.text.StyleContext
      • javax.swing.text.html.StyleSheet
  • All Implemented Interfaces:
    Serializable, AbstractDocument.AttributeContext

    public class StyleSheet
extends StyleContext
    Support for defining the visual characteristics of HTML views being rendered. The StyleSheet is used to translate the HTML model into visual characteristics. This enables views to be customized by a look-and-feel, multiple views over the same model can be rendered differently, etc. This can be thought of as a CSS rule repository. The key for CSS attributes is an object of type CSS.Attribute. The type of the value is up to the StyleSheet implementation, but the toString method is required to return a string representation of CSS value.

    The primary entry point for HTML View implementations to get their attributes is the getViewAttributes method. This should be implemented to establish the desired policy used to associate attributes with the view. Each HTMLEditorKit (i.e. and therefore each associated JEditorPane) can have its own StyleSheet, but by default one sheet will be shared by all of the HTMLEditorKit instances. HTMLDocument instance can also have a StyleSheet, which holds the document-specific CSS specifications.

    In order for Views to store less state and therefore be more lightweight, the StyleSheet can act as a factory for painters that handle some of the rendering tasks. This allows implementations to determine what they want to cache and have the sharing potentially at the level that a selector is common to multiple views. Since the StyleSheet may be used by views over multiple documents and typically the HTML attributes don't effect the selector being used, the potential for sharing is significant.

    The rules are stored as named styles, and other information is stored to translate the context of an element to a rule quickly. The following code fragment will display the named styles, and therefore the CSS rules contained.

   import java.util.*;
   import javax.swing.text.*;
   import javax.swing.text.html.*;

   public class ShowStyles {

       public static void main(String[] args) {
         HTMLEditorKit kit = new HTMLEditorKit();
         HTMLDocument doc = (HTMLDocument) kit.createDefaultDocument();
         StyleSheet styles = doc.getStyleSheet();

         Enumeration rules = styles.getStyleNames();
         while (rules.hasMoreElements()) {
             String name = (String) rules.nextElement();
             Style rule = styles.getStyle(name);
             System.out.println(rule.toString());
         }
         System.exit(0);
       }
   }

    The semantics for when a CSS style should overide visual attributes defined by an element are not well defined. For example, the html <body bgcolor=red> makes the body have a red background. But if the html file also contains the CSS rule body { background: blue } it becomes less clear as to what color the background of the body should be. The current implementation gives visual attributes defined in the element the highest precedence, that is they are always checked before any styles. Therefore, in the previous example the background would have a red color as the body element defines the background color to be red.

    As already mentioned this supports CSS. We don't support the full CSS spec. Refer to the javadoc of the CSS class to see what properties we support. The two major CSS parsing related concepts we do not currently support are pseudo selectors, such as A:link { color: red }, and the important modifier.

    Note: This implementation is currently incomplete. It can be replaced with alternative implementations that are complete. Future versions of this class will provide better CSS support.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  StyleSheet.BoxPainter
      Class to carry out some of the duties of CSS formatting.
      static class  StyleSheet.ListPainter
      Class to carry out some of the duties of CSS list formatting.

      • Nested classes/interfaces inherited from class javax.swing.text.StyleContext

        StyleContext.NamedStyle, StyleContext.SmallAttributeSet

    • Field Summary

      • Fields inherited from class javax.swing.text.StyleContext

        DEFAULT_STYLE

    • Constructor Summary

      Constructors
      Constructor and Description
      StyleSheet()
      Construct a StyleSheet

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      AttributeSet addAttribute(AttributeSet old, Object key, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      void addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      boolean addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      void addRule(String rule)
      Adds a set of rules to the sheet.
      void addStyleSheet(StyleSheet ss)
      Adds the rules from the StyleSheet ss to those of the receiver.
      protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
      Creates a large set of attributes that should trade off space for time.
      protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
      Creates a compact set of attributes that might be shared.
      Color getBackground(AttributeSet a)
      Takes a set of attributes and turn it into a background color specification.
      URL getBase()
      Returns the base.
      StyleSheet.BoxPainter getBoxPainter(AttributeSet a)
      Fetches the box formatter to use for the given set of CSS attributes.
      AttributeSet getDeclaration(String decl)
      Translates a CSS declaration to an AttributeSet that represents the CSS declaration.
      Font getFont(AttributeSet a)
      Fetches the font to use for the given set of attributes.
      Color getForeground(AttributeSet a)
      Takes a set of attributes and turn it into a foreground color specification.
      static int | getIndexOfSize(float pt)
      StyleSheet.ListPainter getListPainter(AttributeSet a)
      Fetches the list formatter to use for the given set of CSS attributes.
      float getPointSize(int index)
      Returns the point size, given a size index.
      float getPointSize(String size)
      Given a string such as "+2", "-2", or "2", returns a point size value.
      Style getRule(HTML.Tag t, Element e)
      Fetches the style to use to render the given type of HTML tag.
      Style getRule(String selector)
      Fetches the rule that best matches the selector given in string form.
      StyleSheet[] getStyleSheets()
      Returns an array of the linked StyleSheets.
      AttributeSet getViewAttributes(View v)
      Fetches a set of attributes to use in the view for displaying.
      void importStyleSheet(URL url)
      Imports a style sheet from url.
      void loadRules(Reader in, URL ref)
      Loads a set of rules that have been specified in terms of CSS1 grammar.
      AttributeSet removeAttribute(AttributeSet old, Object key)
      Removes an attribute from the set.
      AttributeSet removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes.
      AttributeSet removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      void removeStyle(String nm)
      Removes a named style previously added to the document.
      void removeStyleSheet(StyleSheet ss)
      Removes the StyleSheet ss from those of the receiver.
      void setBase(URL base)
      Sets the base.
      void setBaseFontSize(int sz)
      Sets the base font size, with valid values between 1 and 7.
      void setBaseFontSize(String size)
      Sets the base font size from the passed in String.
      Color stringToColor(String string)
      Converts a color string such as "RED" or "#NNNNNN" to a Color.
      AttributeSet translateHTMLToCSS(AttributeSet htmlAttrSet)
      Converts a set of HTML attributes to an equivalent set of CSS attributes.

      • Methods inherited from class javax.swing.text.StyleContext

        addChangeListener, addStyle, getChangeListeners, getCompressionThreshold, getDefaultStyleContext, getEmptySet, getFont, getFontMetrics, getStaticAttribute, getStaticAttributeKey, getStyle, getStyleNames, readAttributes, readAttributeSet, reclaim, registerStaticAttributeKey, removeChangeListener, toString, writeAttributes, writeAttributeSet

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • StyleSheet

        public StyleSheet()
        Construct a StyleSheet

    • Method Detail

      • getRule

        public Style getRule(HTML.Tag t,
                     Element e)
        Fetches the style to use to render the given type of HTML tag. The element given is representing the tag and can be used to determine the nesting for situations where the attributes will differ if nesting inside of elements.
        Parameters:
        t - the type to translate to visual attributes
        e - the element representing the tag; the element can be used to determine the nesting for situations where the attributes will differ if nested inside of other elements
        Returns:
        the set of CSS attributes to use to render the tag

      • getRule

        public Style getRule(String selector)
        Fetches the rule that best matches the selector given in string form. Where selector is a space separated String of the element names. For example, selector might be 'html body tr td''

        The attributes of the returned Style will change as rules are added and removed. That is if you to ask for a rule with a selector "table p" and a new rule was added with a selector of "p" the returned Style would include the new attributes from the rule "p".

      • addRule

        public void addRule(String rule)
        Adds a set of rules to the sheet. The rules are expected to be in valid CSS format. Typically this would be called as a result of parsing a <style> tag.

      • getDeclaration

        public AttributeSet getDeclaration(String decl)
        Translates a CSS declaration to an AttributeSet that represents the CSS declaration. Typically this would be called as a result of encountering an HTML style attribute.

      • loadRules

        public void loadRules(Reader in,
                      URL ref)
               throws IOException
        Loads a set of rules that have been specified in terms of CSS1 grammar. If there are collisions with existing rules, the newly specified rule will win.
        Parameters:
        in - the stream to read the CSS grammar from
        ref - the reference URL. This value represents the location of the stream and may be null. All relative URLs specified in the stream will be based upon this parameter.
        Throws:
        IOException

      • getViewAttributes

        public AttributeSet getViewAttributes(View v)
        Fetches a set of attributes to use in the view for displaying. This is basically a set of attributes that can be used for View.getAttributes.

      • removeStyle

        public void removeStyle(String nm)
        Removes a named style previously added to the document.
        Overrides:
        removeStyle in class StyleContext
        Parameters:
        nm - the name of the style to remove

      • addStyleSheet

        public void addStyleSheet(StyleSheet ss)
        Adds the rules from the StyleSheet ss to those of the receiver. ss's rules will override the rules of any previously added style sheets. An added StyleSheet will never override the rules of the receiving style sheet.
        Since:
        1.3

      • removeStyleSheet

        public void removeStyleSheet(StyleSheet ss)
        Removes the StyleSheet ss from those of the receiver.
        Since:
        1.3

      • getStyleSheets

        public StyleSheet[] getStyleSheets()
        Returns an array of the linked StyleSheets. Will return null if there are no linked StyleSheets.
        Since:
        1.3

      • importStyleSheet

        public void importStyleSheet(URL url)
        Imports a style sheet from url. The resulting rules are directly added to the receiver. If you do not want the rules to become part of the receiver, create a new StyleSheet and use addStyleSheet to link it in.
        Since:
        1.3

      • setBase

        public void setBase(URL base)
        Sets the base. All import statements that are relative, will be relative to base.
        Since:
        1.3

      • getBase

        public URL getBase()
        Returns the base.
        Since:
        1.3

      • addCSSAttribute

        public void addCSSAttribute(MutableAttributeSet attr,
                            CSS.Attribute key,
                            String value)
        Adds a CSS attribute to the given set.
        Since:
        1.3

      • addCSSAttributeFromHTML

        public boolean addCSSAttributeFromHTML(MutableAttributeSet attr,
                                       CSS.Attribute key,
                                       String value)
        Adds a CSS attribute to the given set.
        Since:
        1.3

      • translateHTMLToCSS

        public AttributeSet translateHTMLToCSS(AttributeSet htmlAttrSet)
        Converts a set of HTML attributes to an equivalent set of CSS attributes.
        Parameters:
        htmlAttrSet - AttributeSet containing the HTML attributes.

      • addAttribute

        public AttributeSet addAttribute(AttributeSet old,
                                 Object key,
                                 Object value)
        Adds an attribute to the given set, and returns the new representative set. This is reimplemented to convert StyleConstant attributes to CSS prior to forwarding to the superclass behavior. The StyleConstants attribute has no corresponding CSS entry, the StyleConstants attribute is stored (but will likely be unused).
        Specified by:
        addAttribute in interface AbstractDocument.AttributeContext
        Overrides:
        addAttribute in class StyleContext
        Parameters:
        old - the old attribute set
        key - the non-null attribute key
        value - the attribute value
        Returns:
        the updated attribute set
        See Also:
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • addAttributes

        public AttributeSet addAttributes(AttributeSet old,
                                  AttributeSet attr)
        Adds a set of attributes to the element. If any of these attributes are StyleConstants attributes, they will be converted to CSS prior to forwarding to the superclass behavior.
        Specified by:
        addAttributes in interface AbstractDocument.AttributeContext
        Overrides:
        addAttributes in class StyleContext
        Parameters:
        old - the old attribute set
        attr - the attributes to add
        Returns:
        the updated attribute set
        See Also:
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • removeAttribute

        public AttributeSet removeAttribute(AttributeSet old,
                                    Object key)
        Removes an attribute from the set. If the attribute is a StyleConstants attribute, the request will be converted to a CSS attribute prior to forwarding to the superclass behavior.
        Specified by:
        removeAttribute in interface AbstractDocument.AttributeContext
        Overrides:
        removeAttribute in class StyleContext
        Parameters:
        old - the old set of attributes
        key - the non-null attribute name
        Returns:
        the updated attribute set
        See Also:
        MutableAttributeSet.removeAttribute(java.lang.Object)

      • removeAttributes

        public AttributeSet removeAttributes(AttributeSet old,
                                     Enumeration<?> names)
        Removes a set of attributes for the element. If any of the attributes is a StyleConstants attribute, the request will be converted to a CSS attribute prior to forwarding to the superclass behavior.
        Specified by:
        removeAttributes in interface AbstractDocument.AttributeContext
        Overrides:
        removeAttributes in class StyleContext
        Parameters:
        old - the old attribute set
        names - the attribute names
        Returns:
        the updated attribute set
        See Also:
        MutableAttributeSet.removeAttributes(java.util.Enumeration<?>)

      • removeAttributes

        public AttributeSet removeAttributes(AttributeSet old,
                                     AttributeSet attrs)
        Removes a set of attributes. If any of the attributes is a StyleConstants attribute, the request will be converted to a CSS attribute prior to forwarding to the superclass behavior.
        Specified by:
        removeAttributes in interface AbstractDocument.AttributeContext
        Overrides:
        removeAttributes in class StyleContext
        Parameters:
        old - the old attribute set
        attrs - the attributes
        Returns:
        the updated attribute set
        See Also:
        MutableAttributeSet.removeAttributes(java.util.Enumeration<?>)

      • createSmallAttributeSet

        protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
        Creates a compact set of attributes that might be shared. This is a hook for subclasses that want to alter the behavior of SmallAttributeSet. This can be reimplemented to return an AttributeSet that provides some sort of attribute conversion.
        Overrides:
        createSmallAttributeSet in class StyleContext
        Parameters:
        a - The set of attributes to be represented in the the compact form.

      • createLargeAttributeSet

        protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
        Creates a large set of attributes that should trade off space for time. This set will not be shared. This is a hook for subclasses that want to alter the behavior of the larger attribute storage format (which is SimpleAttributeSet by default). This can be reimplemented to return a MutableAttributeSet that provides some sort of attribute conversion.
        Overrides:
        createLargeAttributeSet in class StyleContext
        Parameters:
        a - The set of attributes to be represented in the the larger form.

      • getFont

        public Font getFont(AttributeSet a)
        Fetches the font to use for the given set of attributes.
        Overrides:
        getFont in class StyleContext
        Parameters:
        a - the attribute set
        Returns:
        the font

      • getForeground

        public Color getForeground(AttributeSet a)
        Takes a set of attributes and turn it into a foreground color specification. This might be used to specify things like brighter, more hue, etc.
        Overrides:
        getForeground in class StyleContext
        Parameters:
        a - the set of attributes
        Returns:
        the color

      • getBackground

        public Color getBackground(AttributeSet a)
        Takes a set of attributes and turn it into a background color specification. This might be used to specify things like brighter, more hue, etc.
        Overrides:
        getBackground in class StyleContext
        Parameters:
        a - the set of attributes
        Returns:
        the color

      • getBoxPainter

        public StyleSheet.BoxPainter getBoxPainter(AttributeSet a)
        Fetches the box formatter to use for the given set of CSS attributes.

      • getListPainter

        public StyleSheet.ListPainter getListPainter(AttributeSet a)
        Fetches the list formatter to use for the given set of CSS attributes.

      • setBaseFontSize

        public void setBaseFontSize(int sz)
        Sets the base font size, with valid values between 1 and 7.

      • setBaseFontSize

        public void setBaseFontSize(String size)
        Sets the base font size from the passed in String. The string can either identify a specific font size, with legal values between 1 and 7, or identify a relative font size such as +1 or -2.

      • getIndexOfSize

        public static int getIndexOfSize(float pt)

      • getPointSize

        public float getPointSize(int index)
        Returns the point size, given a size index.

      • getPointSize

        public float getPointSize(String size)
        Given a string such as "+2", "-2", or "2", returns a point size value.

      • stringToColor

        public Color stringToColor(String string)
        Converts a color string such as "RED" or "#NNNNNN" to a Color. Note: This will only convert the HTML3.2 color strings or a string of length 7; otherwise, it will return null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StyleSheet.ListPainter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html

Class StyleSheet.ListPainter

  • java.lang.Object
    • javax.swing.text.html.StyleSheet.ListPainter
  • All Implemented Interfaces:
    Serializable
    Enclosing class:
    StyleSheet

    public static class StyleSheet.ListPainter
extends Object
implements Serializable
    Class to carry out some of the duties of CSS list formatting. Implementations of this class enable views to present the CSS formatting while not knowing anything about how the CSS values are being cached.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void paint(Graphics g, float x, float y, float w, float h, View v, int item)
      Paints the CSS list decoration according to the attributes given.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • paint

        public void paint(Graphics g,
                  float x,
                  float y,
                  float w,
                  float h,
                  View v,
                  int item)
        Paints the CSS list decoration according to the attributes given.
        Parameters:
        g - the rendering surface.
        x - the x coordinate of the list item allocation
        y - the y coordinate of the list item allocation
        w - the width of the list item allocation
        h - the height of the list item allocation
        v - the allocated area to paint into.
        item - which list item is being painted. This is a number greater than or equal to 0.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.BlockView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.BlockView

  • Packages that use BlockView
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of BlockView in javax.swing.text.html

      Subclasses of BlockView in javax.swing.text.html
      Modifier and Type Class and Description
      class  ListView
      A view implementation to display an html list
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.CSS.Attribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.CSS.Attribute

  • Packages that use CSS.Attribute
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of CSS.Attribute in javax.swing.text.html

      Fields in javax.swing.text.html declared as CSS.Attribute
      Modifier and Type | Field and Description
      static CSS.Attribute | CSS.Attribute.BACKGROUND
      static CSS.Attribute | CSS.Attribute.BACKGROUND_ATTACHMENT
      static CSS.Attribute | CSS.Attribute.BACKGROUND_COLOR
      static CSS.Attribute | CSS.Attribute.BACKGROUND_IMAGE
      static CSS.Attribute | CSS.Attribute.BACKGROUND_POSITION
      static CSS.Attribute | CSS.Attribute.BACKGROUND_REPEAT
      static CSS.Attribute | CSS.Attribute.BORDER
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_TOP
      static CSS.Attribute | CSS.Attribute.BORDER_TOP_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_TOP_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_TOP_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_WIDTH
      static CSS.Attribute | CSS.Attribute.CLEAR
      static CSS.Attribute | CSS.Attribute.COLOR
      static CSS.Attribute | CSS.Attribute.DISPLAY
      static CSS.Attribute | CSS.Attribute.FLOAT
      static CSS.Attribute | CSS.Attribute.FONT
      static CSS.Attribute | CSS.Attribute.FONT_FAMILY
      static CSS.Attribute | CSS.Attribute.FONT_SIZE
      static CSS.Attribute | CSS.Attribute.FONT_STYLE
      static CSS.Attribute | CSS.Attribute.FONT_VARIANT
      static CSS.Attribute | CSS.Attribute.FONT_WEIGHT
      static CSS.Attribute | CSS.Attribute.HEIGHT
      static CSS.Attribute | CSS.Attribute.LETTER_SPACING
      static CSS.Attribute | CSS.Attribute.LINE_HEIGHT
      static CSS.Attribute | CSS.Attribute.LIST_STYLE
      static CSS.Attribute | CSS.Attribute.LIST_STYLE_IMAGE
      static CSS.Attribute | CSS.Attribute.LIST_STYLE_POSITION
      static CSS.Attribute | CSS.Attribute.LIST_STYLE_TYPE
      static CSS.Attribute | CSS.Attribute.MARGIN
      static CSS.Attribute | CSS.Attribute.MARGIN_BOTTOM
      static CSS.Attribute | CSS.Attribute.MARGIN_LEFT
      static CSS.Attribute | CSS.Attribute.MARGIN_RIGHT
      static CSS.Attribute | CSS.Attribute.MARGIN_TOP
      static CSS.Attribute | CSS.Attribute.PADDING
      static CSS.Attribute | CSS.Attribute.PADDING_BOTTOM
      static CSS.Attribute | CSS.Attribute.PADDING_LEFT
      static CSS.Attribute | CSS.Attribute.PADDING_RIGHT
      static CSS.Attribute | CSS.Attribute.PADDING_TOP
      static CSS.Attribute | CSS.Attribute.TEXT_ALIGN
      static CSS.Attribute | CSS.Attribute.TEXT_DECORATION
      static CSS.Attribute | CSS.Attribute.TEXT_INDENT
      static CSS.Attribute | CSS.Attribute.TEXT_TRANSFORM
      static CSS.Attribute | CSS.Attribute.VERTICAL_ALIGN
      static CSS.Attribute | CSS.Attribute.WHITE_SPACE
      static CSS.Attribute | CSS.Attribute.WIDTH
      static CSS.Attribute | CSS.Attribute.WORD_SPACING
      Methods in javax.swing.text.html that return CSS.Attribute
      Modifier and Type Method and Description
      static CSS.Attribute[] CSS.getAllAttributeKeys()
      Return the set of all possible CSS attribute keys.
      static CSS.Attribute CSS.getAttribute(String name)
      Translates a string to a CSS.Attribute object.
      Methods in javax.swing.text.html with parameters of type CSS.Attribute
      Modifier and Type Method and Description
      void StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      boolean StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.CSS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.CSS

No usage of javax.swing.text.html.CSS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.FormSubmitEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.FormSubmitEvent

No usage of javax.swing.text.html.FormSubmitEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.FormSubmitEvent.MethodType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.FormSubmitEvent.MethodType

  • Packages that use FormSubmitEvent.MethodType
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of FormSubmitEvent.MethodType in javax.swing.text.html

      Methods in javax.swing.text.html that return FormSubmitEvent.MethodType
      Modifier and Type Method and Description
      FormSubmitEvent.MethodType FormSubmitEvent.getMethod()
      Gets the form method type.
      static FormSubmitEvent.MethodType FormSubmitEvent.MethodType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FormSubmitEvent.MethodType[] FormSubmitEvent.MethodType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.FormView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.FormView

No usage of javax.swing.text.html.FormView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.FormView.MouseEventListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.FormView.MouseEventListener

No usage of javax.swing.text.html.FormView.MouseEventListener
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTML.Attribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTML.Attribute

  • Packages that use HTML.Attribute
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTML.Attribute in javax.swing.text.html

      Fields in javax.swing.text.html declared as HTML.Attribute
      Modifier and Type | Field and Description
      static HTML.Attribute | HTML.Attribute.ACTION
      static HTML.Attribute | HTML.Attribute.ALIGN
      static HTML.Attribute | HTML.Attribute.ALINK
      static HTML.Attribute | HTML.Attribute.ALT
      static HTML.Attribute | HTML.Attribute.ARCHIVE
      static HTML.Attribute | HTML.Attribute.BACKGROUND
      static HTML.Attribute | HTML.Attribute.BGCOLOR
      static HTML.Attribute | HTML.Attribute.BORDER
      static HTML.Attribute | HTML.Attribute.CELLPADDING
      static HTML.Attribute | HTML.Attribute.CELLSPACING
      static HTML.Attribute | HTML.Attribute.CHECKED
      static HTML.Attribute | HTML.Attribute.CLASS
      static HTML.Attribute | HTML.Attribute.CLASSID
      static HTML.Attribute | HTML.Attribute.CLEAR
      static HTML.Attribute | HTML.Attribute.CODE
      static HTML.Attribute | HTML.Attribute.CODEBASE
      static HTML.Attribute | HTML.Attribute.CODETYPE
      static HTML.Attribute | HTML.Attribute.COLOR
      static HTML.Attribute | HTML.Attribute.COLS
      static HTML.Attribute | HTML.Attribute.COLSPAN
      static HTML.Attribute | HTML.Attribute.COMMENT
      static HTML.Attribute | HTML.Attribute.COMPACT
      static HTML.Attribute | HTML.Attribute.CONTENT
      static HTML.Attribute | HTML.Attribute.COORDS
      static HTML.Attribute | HTML.Attribute.DATA
      static HTML.Attribute | HTML.Attribute.DECLARE
      static HTML.Attribute | HTML.Attribute.DIR
      static HTML.Attribute | HTML.Attribute.DUMMY
      static HTML.Attribute | HTML.Attribute.ENCTYPE
      static HTML.Attribute | HTML.Attribute.ENDTAG
      static HTML.Attribute | HTML.Attribute.FACE
      static HTML.Attribute | HTML.Attribute.FRAMEBORDER
      static HTML.Attribute | HTML.Attribute.HALIGN
      static HTML.Attribute | HTML.Attribute.HEIGHT
      static HTML.Attribute | HTML.Attribute.HREF
      static HTML.Attribute | HTML.Attribute.HSPACE
      static HTML.Attribute | HTML.Attribute.HTTPEQUIV
      static HTML.Attribute | HTML.Attribute.ID
      static HTML.Attribute | HTML.Attribute.ISMAP
      static HTML.Attribute | HTML.Attribute.LANG
      static HTML.Attribute | HTML.Attribute.LANGUAGE
      static HTML.Attribute | HTML.Attribute.LINK
      static HTML.Attribute | HTML.Attribute.LOWSRC
      static HTML.Attribute | HTML.Attribute.MARGINHEIGHT
      static HTML.Attribute | HTML.Attribute.MARGINWIDTH
      static HTML.Attribute | HTML.Attribute.MAXLENGTH
      static HTML.Attribute | HTML.Attribute.METHOD
      static HTML.Attribute | HTML.Attribute.MULTIPLE
      static HTML.Attribute | HTML.Attribute.N
      static HTML.Attribute | HTML.Attribute.NAME
      static HTML.Attribute | HTML.Attribute.NOHREF
      static HTML.Attribute | HTML.Attribute.NORESIZE
      static HTML.Attribute | HTML.Attribute.NOSHADE
      static HTML.Attribute | HTML.Attribute.NOWRAP
      static HTML.Attribute | HTML.Attribute.PROMPT
      static HTML.Attribute | HTML.Attribute.REL
      static HTML.Attribute | HTML.Attribute.REV
      static HTML.Attribute | HTML.Attribute.ROWS
      static HTML.Attribute | HTML.Attribute.ROWSPAN
      static HTML.Attribute | HTML.Attribute.SCROLLING
      static HTML.Attribute | HTML.Attribute.SELECTED
      static HTML.Attribute | HTML.Attribute.SHAPE
      static HTML.Attribute | HTML.Attribute.SHAPES
      static HTML.Attribute | HTML.Attribute.SIZE
      static HTML.Attribute | HTML.Attribute.SRC
      static HTML.Attribute | HTML.Attribute.STANDBY
      static HTML.Attribute | HTML.Attribute.START
      static HTML.Attribute | HTML.Attribute.STYLE
      static HTML.Attribute | HTML.Attribute.TARGET
      static HTML.Attribute | HTML.Attribute.TEXT
      static HTML.Attribute | HTML.Attribute.TITLE
      static HTML.Attribute | HTML.Attribute.TYPE
      static HTML.Attribute | HTML.Attribute.USEMAP
      static HTML.Attribute | HTML.Attribute.VALIGN
      static HTML.Attribute | HTML.Attribute.VALUE
      static HTML.Attribute | HTML.Attribute.VALUETYPE
      static HTML.Attribute | HTML.Attribute.VERSION
      static HTML.Attribute | HTML.Attribute.VLINK
      static HTML.Attribute | HTML.Attribute.VSPACE
      static HTML.Attribute | HTML.Attribute.WIDTH
      Methods in javax.swing.text.html that return HTML.Attribute
      Modifier and Type Method and Description
      static HTML.Attribute[] HTML.getAllAttributeKeys()
      Returns the set of HTML attributes recognized.
      static HTML.Attribute HTML.getAttributeKey(String attName)
      Fetches an attribute constant for a well-known attribute name (i.e.
      Methods in javax.swing.text.html with parameters of type HTML.Attribute
      Modifier and Type Method and Description
      static int HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def)
      Fetches an integer attribute value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTML (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTML

No usage of javax.swing.text.html.HTML
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTML.Tag (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTML.Tag

  • Packages that use HTML.Tag
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of HTML.Tag in javax.swing.text.html

      Subclasses of HTML.Tag in javax.swing.text.html
      Modifier and Type | Class and Description
      static class  | HTML.UnknownTag
      Fields in javax.swing.text.html declared as HTML.Tag
      Modifier and Type | Field and Description
      static HTML.Tag | HTML.Tag.A
      static HTML.Tag | HTML.Tag.ADDRESS
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.addTag
      Tag in HTML to start adding tags from.
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.alternateAddTag
      Alternate tag in HTML to start adding tags from if parentTag is not found and alternateParentTag is found.
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.alternateParentTag
      Alternate Tag to check for in the document if parentTag is not found.
      static HTML.Tag | HTML.Tag.APPLET
      static HTML.Tag | HTML.Tag.AREA
      static HTML.Tag | HTML.Tag.B
      static HTML.Tag | HTML.Tag.BASE
      static HTML.Tag | HTML.Tag.BASEFONT
      static HTML.Tag | HTML.Tag.BIG
      static HTML.Tag | HTML.Tag.BLOCKQUOTE
      static HTML.Tag | HTML.Tag.BODY
      static HTML.Tag | HTML.Tag.BR
      static HTML.Tag | HTML.Tag.CAPTION
      static HTML.Tag | HTML.Tag.CENTER
      static HTML.Tag | HTML.Tag.CITE
      static HTML.Tag | HTML.Tag.CODE
      static HTML.Tag HTML.Tag.COMMENT
      All comments are labeled with this tag.
      static HTML.Tag HTML.Tag.CONTENT
      All text content is labeled with this tag.
      static HTML.Tag | HTML.Tag.DD
      static HTML.Tag | HTML.Tag.DFN
      static HTML.Tag | HTML.Tag.DIR
      static HTML.Tag | HTML.Tag.DIV
      static HTML.Tag | HTML.Tag.DL
      static HTML.Tag | HTML.Tag.DT
      static HTML.Tag | HTML.Tag.EM
      static HTML.Tag | HTML.Tag.FONT
      static HTML.Tag | HTML.Tag.FORM
      static HTML.Tag | HTML.Tag.FRAME
      static HTML.Tag | HTML.Tag.FRAMESET
      static HTML.Tag | HTML.Tag.H1
      static HTML.Tag | HTML.Tag.H2
      static HTML.Tag | HTML.Tag.H3
      static HTML.Tag | HTML.Tag.H4
      static HTML.Tag | HTML.Tag.H5
      static HTML.Tag | HTML.Tag.H6
      static HTML.Tag | HTML.Tag.HEAD
      static HTML.Tag | HTML.Tag.HR
      static HTML.Tag | HTML.Tag.HTML
      static HTML.Tag | HTML.Tag.I
      static HTML.Tag | HTML.Tag.IMG
      static HTML.Tag HTML.Tag.IMPLIED
      All text content must be in a paragraph element.
      static HTML.Tag | HTML.Tag.INPUT
      static HTML.Tag | HTML.Tag.ISINDEX
      static HTML.Tag | HTML.Tag.KBD
      static HTML.Tag | HTML.Tag.LI
      static HTML.Tag | HTML.Tag.LINK
      static HTML.Tag | HTML.Tag.MAP
      static HTML.Tag | HTML.Tag.MENU
      static HTML.Tag | HTML.Tag.META
      static HTML.Tag | HTML.Tag.NOFRAMES
      static HTML.Tag | HTML.Tag.OBJECT
      static HTML.Tag | HTML.Tag.OL
      static HTML.Tag | HTML.Tag.OPTION
      static HTML.Tag | HTML.Tag.P
      static HTML.Tag | HTML.Tag.PARAM
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.parentTag
      Tag to check for in the document.
      static HTML.Tag | HTML.Tag.PRE
      static HTML.Tag | HTML.Tag.S
      static HTML.Tag | HTML.Tag.SAMP
      static HTML.Tag | HTML.Tag.SCRIPT
      static HTML.Tag | HTML.Tag.SELECT
      static HTML.Tag | HTML.Tag.SMALL
      static HTML.Tag | HTML.Tag.SPAN
      static HTML.Tag | HTML.Tag.STRIKE
      static HTML.Tag | HTML.Tag.STRONG
      static HTML.Tag | HTML.Tag.STYLE
      static HTML.Tag | HTML.Tag.SUB
      static HTML.Tag | HTML.Tag.SUP
      static HTML.Tag | HTML.Tag.TABLE
      static HTML.Tag | HTML.Tag.TD
      static HTML.Tag | HTML.Tag.TEXTAREA
      static HTML.Tag | HTML.Tag.TH
      static HTML.Tag | HTML.Tag.TITLE
      static HTML.Tag | HTML.Tag.TR
      static HTML.Tag | HTML.Tag.TT
      static HTML.Tag | HTML.Tag.U
      static HTML.Tag | HTML.Tag.UL
      static HTML.Tag | HTML.Tag.VAR
      Methods in javax.swing.text.html that return HTML.Tag
      Modifier and Type Method and Description
      static HTML.Tag[] HTML.getAllTags()
      Returns the set of actual HTML tags that are recognized by the default HTML reader.
      abstract HTML.Tag HTMLDocument.Iterator.getTag()
      Type of tag this iterator represents.
      static HTML.Tag HTML.getTag(String tagName)
      Fetches a tag constant for a well-known tag name (i.e.
      Methods in javax.swing.text.html with parameters of type HTML.Tag
      Modifier and Type | Method and Description
      protected void HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a)
      Adds content that is basically specified entirely in the attribute set.
      protected void HTMLDocument.HTMLReader.blockClose(HTML.Tag t)
      Adds an instruction to the parse buffer to close out a block element of the given type.
      protected void HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr)
      Adds an instruction to the parse buffer to create a block element with the given attributes.
      protected int HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
      void HTMLDocument.HTMLReader.TagAction.end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void | HTMLDocument.HTMLReader.BlockAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.ParagraphAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.HiddenAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.PreAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.CharacterAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.FormAction.end(HTML.Tag t)
      protected Element HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns the deepest element at offset matching tag.
      HTMLDocument.Iterator HTMLDocument.getIterator(HTML.Tag t)
      Fetches an iterator for the specified HTML tag.
      HTMLEditorKit.ParserCallback HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag)
      Returns the reader for the parser to use to load the document with HTML.
      Style StyleSheet.getRule(HTML.Tag t, Element e)
      Fetches the style to use to render the given type of HTML tag.
      void | HTMLEditorKit.ParserCallback.handleEndTag(HTML.Tag t, int pos)
      void HTMLDocument.HTMLReader.handleEndTag(HTML.Tag t, int pos)
      Callback from the parser.
      void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      Inserts HTML into an existing document.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
      A cover for HTMLEditorKit.insertHTML.
      protected boolean HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag)
      Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.
      protected void HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
      Registers a handler for the given tag.
      void HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.
      void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)
      Constructors in javax.swing.text.html with parameters of type HTML.Tag
      Constructor and Description
      HTMLReader(int offset, int popDepth, int pushDepth, HTML.Tag insertTag)
      InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)
      InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

    • Uses of HTML.Tag in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that return HTML.Tag
      Modifier and Type | Method and Description
      HTML.Tag | TagElement.getHTMLTag()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTML.UnknownTag (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTML.UnknownTag

No usage of javax.swing.text.html.HTML.UnknownTag
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.BlockElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.BlockElement

No usage of javax.swing.text.html.HTMLDocument.BlockElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument

  • Packages that use HTMLDocument
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLDocument
      Modifier and Type | Method and Description
      protected HTMLDocument | HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)
      Methods in javax.swing.text.html with parameters of type HTMLDocument
      Modifier and Type Method and Description
      protected int HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
      protected Element HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns the deepest element at offset matching tag.
      protected Element[] HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset)
      Returns an array of the Elements that contain offset.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      Inserts HTML into an existing document.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
      A cover for HTMLEditorKit.insertHTML.
      Constructors in javax.swing.text.html with parameters of type HTMLDocument
      Constructor and Description
      HTMLWriter(Writer w, HTMLDocument doc)
      Creates a new HTMLWriter.
      HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
      Creates a new HTMLWriter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction

  • Packages that use HTMLDocument.HTMLReader.BlockAction
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.HTMLReader.BlockAction in javax.swing.text.html

      Subclasses of HTMLDocument.HTMLReader.BlockAction in javax.swing.text.html
      Modifier and Type | Class and Description
      class  | HTMLDocument.HTMLReader.ParagraphAction
      class  | HTMLDocument.HTMLReader.PreAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.FormAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader

No usage of javax.swing.text.html.HTMLDocument.HTMLReader
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.PreAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction

  • Packages that use HTMLDocument.HTMLReader.SpecialAction
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.HTMLReader.SpecialAction in javax.swing.text.html

      Subclasses of HTMLDocument.HTMLReader.SpecialAction in javax.swing.text.html
      Modifier and Type Class and Description
      class  HTMLDocument.HTMLReader.FormAction
      Action to support forms by building all of the elements used to represent form controls.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.TagAction

  • Packages that use HTMLDocument.HTMLReader.TagAction
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.HTMLReader.TagAction in javax.swing.text.html

      Subclasses of HTMLDocument.HTMLReader.TagAction in javax.swing.text.html
      Modifier and Type | Class and Description
      class  | HTMLDocument.HTMLReader.BlockAction
      class  | HTMLDocument.HTMLReader.CharacterAction
      class  HTMLDocument.HTMLReader.FormAction
      Action to support forms by building all of the elements used to represent form controls.
      class  | HTMLDocument.HTMLReader.HiddenAction
      class  | HTMLDocument.HTMLReader.IsindexAction
      class  | HTMLDocument.HTMLReader.ParagraphAction
      class  | HTMLDocument.HTMLReader.PreAction
      class  | HTMLDocument.HTMLReader.SpecialAction
      Methods in javax.swing.text.html with parameters of type HTMLDocument.HTMLReader.TagAction
      Modifier and Type Method and Description
      protected void HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
      Registers a handler for the given tag.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.Iterator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.Iterator

  • Packages that use HTMLDocument.Iterator
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.Iterator in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLDocument.Iterator
      Modifier and Type Method and Description
      HTMLDocument.Iterator HTMLDocument.getIterator(HTML.Tag t)
      Fetches an iterator for the specified HTML tag.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLDocument.RunElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLDocument.RunElement

No usage of javax.swing.text.html.HTMLDocument.RunElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit

  • Packages that use HTMLEditorKit
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLEditorKit in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLEditorKit
      Modifier and Type | Method and Description
      protected HTMLEditorKit | HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit.HTMLFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit.HTMLFactory

No usage of javax.swing.text.html.HTMLEditorKit.HTMLFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit.HTMLTextAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit.HTMLTextAction

  • Packages that use HTMLEditorKit.HTMLTextAction
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLEditorKit.HTMLTextAction in javax.swing.text.html

      Subclasses of HTMLEditorKit.HTMLTextAction in javax.swing.text.html
      Modifier and Type Class and Description
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction

No usage of javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit.LinkController (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit.LinkController

No usage of javax.swing.text.html.HTMLEditorKit.LinkController
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit.Parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit.Parser

  • Packages that use HTMLEditorKit.Parser
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of HTMLEditorKit.Parser in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLEditorKit.Parser
      Modifier and Type Method and Description
      protected HTMLEditorKit.Parser HTMLEditorKit.getParser()
      Fetch the parser to use for reading HTML streams.
      HTMLEditorKit.Parser HTMLDocument.getParser()
      Returns the parser that is used when inserting HTML into the existing document.
      Methods in javax.swing.text.html with parameters of type HTMLEditorKit.Parser
      Modifier and Type Method and Description
      void HTMLDocument.setParser(HTMLEditorKit.Parser parser)
      Sets the parser that is used by the methods that insert html into the existing document, such as setInnerHTML, and setOuterHTML.

    • Uses of HTMLEditorKit.Parser in javax.swing.text.html.parser

      Subclasses of HTMLEditorKit.Parser in javax.swing.text.html.parser
      Modifier and Type Class and Description
      class  ParserDelegator
      Responsible for starting up a new DocumentParser each time its parse method is invoked.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLEditorKit.ParserCallback (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLEditorKit.ParserCallback

  • Packages that use HTMLEditorKit.ParserCallback
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of HTMLEditorKit.ParserCallback in javax.swing.text.html

      Subclasses of HTMLEditorKit.ParserCallback in javax.swing.text.html
      Modifier and Type Class and Description
      class  HTMLDocument.HTMLReader
      An HTML reader to load an HTML document with an HTML element structure.
      Methods in javax.swing.text.html that return HTMLEditorKit.ParserCallback
      Modifier and Type Method and Description
      HTMLEditorKit.ParserCallback HTMLDocument.getReader(int pos)
      Fetches the reader for the parser to use when loading the document with HTML.
      HTMLEditorKit.ParserCallback HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag)
      Returns the reader for the parser to use to load the document with HTML.
      Methods in javax.swing.text.html with parameters of type HTMLEditorKit.ParserCallback
      Modifier and Type Method and Description
      abstract void HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      Parse the given stream and drive the given callback with the results of the parse.

    • Uses of HTMLEditorKit.ParserCallback in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser with parameters of type HTMLEditorKit.ParserCallback
      Modifier and Type | Method and Description
      void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
      void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLFrameHyperlinkEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLFrameHyperlinkEvent

  • Packages that use HTMLFrameHyperlinkEvent
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLFrameHyperlinkEvent in javax.swing.text.html

      Subclasses of HTMLFrameHyperlinkEvent in javax.swing.text.html
      Modifier and Type Class and Description
      class  FormSubmitEvent
      FormSubmitEvent is used to notify interested parties that a form was submitted.
      Methods in javax.swing.text.html with parameters of type HTMLFrameHyperlinkEvent
      Modifier and Type Method and Description
      void HTMLDocument.processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
      Processes HyperlinkEvents that are generated by documents in an HTML frame.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.HTMLWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.HTMLWriter

No usage of javax.swing.text.html.HTMLWriter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.ImageView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.ImageView

No usage of javax.swing.text.html.ImageView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.InlineView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.InlineView

No usage of javax.swing.text.html.InlineView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.ListView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.ListView

No usage of javax.swing.text.html.ListView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.MinimalHTMLWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.MinimalHTMLWriter

No usage of javax.swing.text.html.MinimalHTMLWriter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.ObjectView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.ObjectView

No usage of javax.swing.text.html.ObjectView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.Option (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.Option

  • Packages that use Option
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of Option in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Option
      Modifier and Type Method and Description
      protected void HTMLWriter.writeOption(Option option)
      Writes out the content of the Option form element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.ParagraphView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.ParagraphView

No usage of javax.swing.text.html.ParagraphView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.StyleSheet.BoxPainter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.StyleSheet.BoxPainter

  • Packages that use StyleSheet.BoxPainter
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleSheet.BoxPainter in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleSheet.BoxPainter
      Modifier and Type Method and Description
      StyleSheet.BoxPainter StyleSheet.getBoxPainter(AttributeSet a)
      Fetches the box formatter to use for the given set of CSS attributes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.StyleSheet (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.StyleSheet

  • Packages that use StyleSheet
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleSheet in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleSheet
      Modifier and Type | Method and Description
      protected StyleSheet | ParagraphView.getStyleSheet()
      protected StyleSheet | BlockView.getStyleSheet()
      StyleSheet HTMLEditorKit.getStyleSheet()
      Get the set of styles currently being used to render the HTML elements.
      protected StyleSheet | InlineView.getStyleSheet()
      protected StyleSheet ImageView.getStyleSheet()
      Convenience method to get the StyleSheet.
      StyleSheet HTMLDocument.getStyleSheet()
      Fetches the StyleSheet with the document-specific display rules (CSS) that were specified in the HTML document itself.
      StyleSheet[] StyleSheet.getStyleSheets()
      Returns an array of the linked StyleSheets.
      Methods in javax.swing.text.html with parameters of type StyleSheet
      Modifier and Type Method and Description
      void StyleSheet.addStyleSheet(StyleSheet ss)
      Adds the rules from the StyleSheet ss to those of the receiver.
      void StyleSheet.removeStyleSheet(StyleSheet ss)
      Removes the StyleSheet ss from those of the receiver.
      void HTMLEditorKit.setStyleSheet(StyleSheet s)
      Set the set of styles to be used to render the various HTML elements.
      Constructors in javax.swing.text.html with parameters of type StyleSheet
      Constructor and Description
      HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
      Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
      HTMLDocument(StyleSheet styles)
      Constructs an HTML document with the default content storage implementation and the specified style/attribute storage mechanism.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.StyleSheet.ListPainter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.StyleSheet.ListPainter

  • Packages that use StyleSheet.ListPainter
    Package Description
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleSheet.ListPainter in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleSheet.ListPainter
      Modifier and Type Method and Description
      StyleSheet.ListPainter StyleSheet.getListPainter(AttributeSet a)
      Fetches the list formatter to use for the given set of CSS attributes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttributeList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class AttributeList

  • java.lang.Object
    • javax.swing.text.html.parser.AttributeList
  • All Implemented Interfaces:
    Serializable, DTDConstants

    public final class AttributeList
extends Object
implements DTDConstants, Serializable
    This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct. An AttributeList can be obtained from the Element class using the getAttributes() method.

    It is actually an element in a linked list. Use the getNext() method repeatedly to enumerate all the attributes of an element.

    See Also:
    Element

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      int | modifier
      String name
      AttributeList next
      int | type
      String value
      Vector<?> values

      • Fields inherited from interface javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • Constructor Summary

      Constructors
      Constructor and Description
      AttributeList(String name)
      Create an attribute list element.
      AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
      Create an attribute list element.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      int | getModifier()
      String getName()
      AttributeList getNext()
      int | getType()
      String getValue()
      Enumeration<?> getValues()
      static int | name2type(String nm)
      String toString()
      Returns a string representation of the object.
      static String | type2name(int tp)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • name

        public String name

      • type

        public int type

      • values

        public Vector<?> values

      • modifier

        public int modifier

      • value

        public String value

      • next

        public AttributeList next

    • Constructor Detail

      • AttributeList

        public AttributeList(String name)
        Create an attribute list element.

      • AttributeList

        public AttributeList(String name,
                     int type,
                     int modifier,
                     String value,
                     Vector<?> values,
                     AttributeList next)
        Create an attribute list element.

    • Method Detail

      • getName

        public String getName()
        Returns:
        attribute name

      • getType

        public int getType()
        Returns:
        attribute type
        See Also:
        DTDConstants

      • getModifier

        public int getModifier()
        Returns:
        attribute modifier
        See Also:
        DTDConstants

      • getValues

        public Enumeration<?> getValues()
        Returns:
        possible attribute values

      • getValue

        public String getValue()
        Returns:
        default attribute value

      • getNext

        public AttributeList getNext()
        Returns:
        the next attribute in the list

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Overrides:
        toString in class Object
        Returns:
        string representation

      • name2type

        public static int name2type(String nm)

      • type2name

        public static String type2name(int tp)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ContentModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class ContentModel

  • java.lang.Object
    • javax.swing.text.html.parser.ContentModel
  • All Implemented Interfaces:
    Serializable

    public final class ContentModel
extends Object
implements Serializable
    A representation of a content model. A content model is basically a restricted BNF expression. It is restricted in the sense that it must be deterministic. This means that you don't have to represent it as a finite state automaton.

    See Annex H on page 556 of the SGML handbook for more information.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object content
      The content.
      ContentModel next
      The next content model (in a ',', '|' or '&' expression).
      int type
      Type.

    • Constructor Summary

      Constructors
      Constructor and Description
      ContentModel()
      ContentModel(Element content)
      Create a content model for an element.
      ContentModel(int type, ContentModel content)
      Create a content model of a particular type.
      ContentModel(int type, Object content, ContentModel next)
      Create a content model of a particular type.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean empty()
      Return true if the content model could match an empty input stream.
      Element first()
      Return the element that must be next.
      boolean first(Object token)
      Return true if the token could potentially be the first token in the input stream.
      void getElements(Vector<Element> elemVec)
      Update elemVec with the list of elements that are part of the this contentModel.
      String toString()
      Convert to a string.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • type

        public int type
        Type. Either '*', '?', '+', ',', '|', '&'.

      • content

        public Object content
        The content. Either an Element or a ContentModel.

      • next

        public ContentModel next
        The next content model (in a ',', '|' or '&' expression).

    • Constructor Detail

      • ContentModel

        public ContentModel()

      • ContentModel

        public ContentModel(Element content)
        Create a content model for an element.

      • ContentModel

        public ContentModel(int type,
                    ContentModel content)
        Create a content model of a particular type.

      • ContentModel

        public ContentModel(int type,
                    Object content,
                    ContentModel next)
        Create a content model of a particular type.

    • Method Detail

      • empty

        public boolean empty()
        Return true if the content model could match an empty input stream.

      • getElements

        public void getElements(Vector<Element> elemVec)
        Update elemVec with the list of elements that are part of the this contentModel.

      • first

        public boolean first(Object token)
        Return true if the token could potentially be the first token in the input stream.

      • first

        public Element first()
        Return the element that must be next.

      • toString

        public String toString()
        Convert to a string.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentParser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class DocumentParser

  • java.lang.Object
    • javax.swing.text.html.parser.Parser
      • javax.swing.text.html.parser.DocumentParser
  • All Implemented Interfaces:
    DTDConstants

    public class DocumentParser
extends Parser
    A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing). Reads an InputStream of HTML and invokes the appropriate methods in the ParserCallback class. This is the default parser used by HTMLEditorKit to parse HTML url's.

    This will message the callback for all valid tags, as well as tags that are implied but not explicitly specified. For example, the html string (<p>blah) only has a p tag defined. The callback will see the following methods:

    1. handleStartTag(html, ...)
    2. handleStartTag(head, ...)
    3. handleEndTag(head)
    4. handleStartTag(body, ...)
    5. handleStartTag(p, ...)
    6. handleText(...)
    7. handleEndTag(p)
    8. handleEndTag(body)
    9. handleEndTag(html)
    The items in italic are implied, that is, although they were not explicitly specified, to be correct html they should have been present (head isn't necessary, but it is still generated). For tags that are implied, the AttributeSet argument will have a value of Boolean.TRUE for the key HTMLEditorKit.ParserCallback.IMPLIED.

    HTML.Attributes defines a type safe enumeration of html attributes. If an attribute key of a tag is defined in HTML.Attribute, the HTML.Attribute will be used as the key, otherwise a String will be used. For example <p foo=bar class=neat> has two attributes. foo is not defined in HTML.Attribute, where as class is, therefore the AttributeSet will have two values in it, HTML.Attribute.CLASS with a String value of 'neat' and the String key 'foo' with a String value of 'bar'.

    The position argument will indicate the start of the tag, comment or text. Similar to arrays, the first character in the stream has a position of 0. For tags that are implied the position will indicate the location of the next encountered tag. In the first example, the implied start body and html tags will have the same position as the p tag, and the implied end p, html and body tags will all have the same position.

    As html skips whitespace the position for text will be the position of the first valid character, eg in the string '\n\n\nblah' the text 'blah' will have a position of 3, the newlines are skipped.

    For attributes that do not have a value, eg in the html string <foo blah> the attribute blah does not have a value, there are two possible values that will be placed in the AttributeSet's value:

    • If the DTD does not contain an definition for the element, or the definition does not have an explicit value then the value in the AttributeSet will be HTML.NULL_ATTRIBUTE_VALUE.
    • If the DTD contains an explicit value, as in: <!ATTLIST OPTION selected (selected) #IMPLIED> this value from the dtd (in this case selected) will be used.

    Once the stream has been parsed, the callback is notified of the most likely end of line string. The end of line string will be one of \n, \r or \r\n, which ever is encountered the most in parsing the stream.

    • Field Summary

      • Fields inherited from class javax.swing.text.html.parser.Parser

        dtd, strict

      • Fields inherited from interface javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • Constructor Summary

      Constructors
      Constructor and Description
      DocumentParser(DTD dtd)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      protected void handleComment(char[] text)
      Called when an HTML comment is encountered.
      protected void handleEmptyTag(TagElement tag)
      Handle Empty Tag.
      protected void handleEndTag(TagElement tag)
      Handle End Tag.
      protected void handleError(int ln, String errorMsg)
      An error has occurred.
      protected void handleStartTag(TagElement tag)
      Handle Start Tag.
      protected void handleText(char[] data)
      Handle Text.
      void | parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)

      • Methods inherited from class javax.swing.text.html.parser.Parser

        endTag, error, error, error, error, flushAttributes, getAttributes, getCurrentLine, getCurrentPos, handleEOFInComment, handleTitle, makeTag, makeTag, markFirstTime, parse, parseDTDMarkup, parseMarkupDeclarations, startTag

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DocumentParser

        public DocumentParser(DTD dtd)

    • Method Detail

      • parse

        public void parse(Reader in,
                  HTMLEditorKit.ParserCallback callback,
                  boolean ignoreCharSet)
           throws IOException
        Throws:
        IOException

      • handleStartTag

        protected void handleStartTag(TagElement tag)
        Handle Start Tag.
        Overrides:
        handleStartTag in class Parser

      • handleComment

        protected void handleComment(char[] text)
        Description copied from class: Parser
        Called when an HTML comment is encountered.
        Overrides:
        handleComment in class Parser

      • handleEmptyTag

        protected void handleEmptyTag(TagElement tag)
                       throws ChangedCharSetException
        Handle Empty Tag.
        Overrides:
        handleEmptyTag in class Parser
        Throws:
        ChangedCharSetException

      • handleEndTag

        protected void handleEndTag(TagElement tag)
        Handle End Tag.
        Overrides:
        handleEndTag in class Parser

      • handleText

        protected void handleText(char[] data)
        Handle Text.
        Overrides:
        handleText in class Parser

      • handleError

        protected void handleError(int ln,
                           String errorMsg)
        Description copied from class: Parser
        An error has occurred.
        Overrides:
        handleError in class Parser
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DTD (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class DTD

  • java.lang.Object
    • javax.swing.text.html.parser.DTD
  • All Implemented Interfaces:
    DTDConstants

    public class DTD
extends Object
implements DTDConstants
    The representation of an SGML DTD. DTD describes a document syntax and is used in parsing of HTML documents. It contains a list of elements and their attributes as well as a list of entities defined in the DTD.
    See Also:
    Element, AttributeList, ContentModel, Parser

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      Element applet
      Element base
      Element body
      Hashtable<String,Element> elementHash
      Vector<Element> elements
      Hashtable<Object,Entity> entityHash
      static int | FILE_VERSION
      Element head
      Element html
      Element isindex
      Element meta
      String name
      Element p
      Element param
      Element pcdata
      Element title

      • Fields inherited from interface javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DTD(String name)
      Creates a new DTD with the specified name.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      protected AttributeList defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
      Creates and returns an AttributeList.
      protected ContentModel defContentModel(int type, Object obj, ContentModel next)
      Creates and returns a new content model.
      protected Element defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      Entity defEntity(String name, int type, int ch)
      Creates and returns a character Entity.
      protected Entity defEntity(String name, int type, String str)
      Creates and returns an Entity.
      void defineAttributes(String name, AttributeList atts)
      Defines attributes for an Element.
      Element defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Entity defineEntity(String name, int type, char[] data)
      Defines an entity.
      static DTD getDTD(String name)
      Returns a DTD with the specified name.
      Element getElement(int index)
      Gets an element by index.
      Element getElement(String name)
      Gets an element by name.
      Entity getEntity(int ch)
      Gets a character entity.
      Entity getEntity(String name)
      Gets an entity by name.
      String getName()
      Gets the name of the DTD.
      static void | putDTDHash(String name, DTD dtd)
      void read(DataInputStream in)
      Recreates a DTD from an archived format.
      String toString()
      Returns a string representation of this DTD.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • name

        public String name

      • elements

        public Vector<Element> elements

      • elementHash

        public Hashtable<String,Element> elementHash

      • entityHash

        public Hashtable<Object,Entity> entityHash

      • pcdata

        public final Element pcdata

      • html

        public final Element html

      • meta

        public final Element meta

      • base

        public final Element base

      • isindex

        public final Element isindex

      • head

        public final Element head

      • body

        public final Element body

      • applet

        public final Element applet

      • param

        public final Element param

      • p

        public final Element p

      • title

        public final Element title

      • FILE_VERSION

        public static final int FILE_VERSION
        See Also:
        Constant Field Values

    • Constructor Detail

      • DTD

        protected DTD(String name)
        Creates a new DTD with the specified name.
        Parameters:
        name - the name, as a String of the new DTD

    • Method Detail

      • getName

        public String getName()
        Gets the name of the DTD.
        Returns:
        the name of the DTD

      • getEntity

        public Entity getEntity(String name)
        Gets an entity by name.
        Returns:
        the Entity corresponding to the name String

      • getEntity

        public Entity getEntity(int ch)
        Gets a character entity.
        Returns:
        the Entity corresponding to the ch character

      • getElement

        public Element getElement(String name)
        Gets an element by name. A new element is created if the element doesn't exist.
        Parameters:
        name - the requested String
        Returns:
        the Element corresponding to name, which may be newly created

      • getElement

        public Element getElement(int index)
        Gets an element by index.
        Parameters:
        index - the requested index
        Returns:
        the Element corresponding to index

      • defineEntity

        public Entity defineEntity(String name,
                           int type,
                           char[] data)
        Defines an entity. If the Entity specified by name, type, and data exists, it is returned; otherwise a new Entity is created and is returned.
        Parameters:
        name - the name of the Entity as a String
        type - the type of the Entity
        data - the Entity's data
        Returns:
        the Entity requested or a new Entity if not found

      • defineElement

        public Element defineElement(String name,
                             int type,
                             boolean omitStart,
                             boolean omitEnd,
                             ContentModel content,
                             BitSet exclusions,
                             BitSet inclusions,
                             AttributeList atts)
        Returns the Element which matches the specified parameters. If one doesn't exist, a new one is created and returned.
        Parameters:
        name - the name of the Element
        type - the type of the Element
        omitStart - true if start should be omitted
        omitEnd - true if end should be omitted
        content - the ContentModel
        atts - the AttributeList specifying the Element
        Returns:
        the Element specified

      • defineAttributes

        public void defineAttributes(String name,
                             AttributeList atts)
        Defines attributes for an Element.
        Parameters:
        name - the name of the Element
        atts - the AttributeList specifying the Element

      • defEntity

        public Entity defEntity(String name,
                        int type,
                        int ch)
        Creates and returns a character Entity.
        Parameters:
        name - the entity's name
        Returns:
        the new character Entity

      • defEntity

        protected Entity defEntity(String name,
                           int type,
                           String str)
        Creates and returns an Entity.
        Parameters:
        name - the entity's name
        Returns:
        the new Entity

      • defElement

        protected Element defElement(String name,
                             int type,
                             boolean omitStart,
                             boolean omitEnd,
                             ContentModel content,
                             String[] exclusions,
                             String[] inclusions,
                             AttributeList atts)
        Creates and returns an Element.
        Parameters:
        name - the element's name
        Returns:
        the new Element

      • defAttributeList

        protected AttributeList defAttributeList(String name,
                                         int type,
                                         int modifier,
                                         String value,
                                         String values,
                                         AttributeList atts)
        Creates and returns an AttributeList.
        Parameters:
        name - the attribute list's name
        Returns:
        the new AttributeList

      • defContentModel

        protected ContentModel defContentModel(int type,
                                       Object obj,
                                       ContentModel next)
        Creates and returns a new content model.
        Parameters:
        type - the type of the new content model
        Returns:
        the new ContentModel

      • toString

        public String toString()
        Returns a string representation of this DTD.
        Overrides:
        toString in class Object
        Returns:
        the string representation of this DTD

      • putDTDHash

        public static void putDTDHash(String name,
                              DTD dtd)

      • getDTD

        public static DTD getDTD(String name)
                  throws IOException
        Returns a DTD with the specified name. If a DTD with that name doesn't exist, one is created and returned. Any uppercase characters in the name are converted to lowercase.
        Parameters:
        name - the name of the DTD
        Returns:
        the DTD which corresponds to name
        Throws:
        IOException

      • read

        public void read(DataInputStream in)
          throws IOException
        Recreates a DTD from an archived format.
        Parameters:
        in - the DataInputStream to read from
        Throws:
        IOException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DTDConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Interface DTDConstants

  • All Known Implementing Classes:
    AttributeList, DocumentParser, DTD, Element, Entity, Parser

    public interface DTDConstants
    SGML constants used in a DTD. The names of the constants correspond the the equivalent SGML constructs as described in "The SGML Handbook" by Charles F. Goldfarb.
    See Also:
    DTD, Element

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | ANY
      static int | CDATA
      static int | CONREF
      static int | CURRENT
      static int | DEFAULT
      static int | EMPTY
      static int | ENDTAG
      static int | ENTITIES
      static int | ENTITY
      static int | FIXED
      static int | GENERAL
      static int | ID
      static int | IDREF
      static int | IDREFS
      static int | IMPLIED
      static int | MD
      static int | MODEL
      static int | MS
      static int | NAME
      static int | NAMES
      static int | NMTOKEN
      static int | NMTOKENS
      static int | NOTATION
      static int | NUMBER
      static int | NUMBERS
      static int | NUTOKEN
      static int | NUTOKENS
      static int | PARAMETER
      static int | PI
      static int | PUBLIC
      static int | RCDATA
      static int | REQUIRED
      static int | SDATA
      static int | STARTTAG
      static int | SYSTEM

    • Field Detail

      • CDATA

        static final int CDATA
        See Also:
        Constant Field Values

      • ENTITY

        static final int ENTITY
        See Also:
        Constant Field Values

      • ENTITIES

        static final int ENTITIES
        See Also:
        Constant Field Values

      • ID

        static final int ID
        See Also:
        Constant Field Values

      • IDREF

        static final int IDREF
        See Also:
        Constant Field Values

      • IDREFS

        static final int IDREFS
        See Also:
        Constant Field Values

      • NAME

        static final int NAME
        See Also:
        Constant Field Values

      • NAMES

        static final int NAMES
        See Also:
        Constant Field Values

      • NMTOKEN

        static final int NMTOKEN
        See Also:
        Constant Field Values

      • NMTOKENS

        static final int NMTOKENS
        See Also:
        Constant Field Values

      • NOTATION

        static final int NOTATION
        See Also:
        Constant Field Values

      • NUMBER

        static final int NUMBER
        See Also:
        Constant Field Values

      • NUMBERS

        static final int NUMBERS
        See Also:
        Constant Field Values

      • NUTOKEN

        static final int NUTOKEN
        See Also:
        Constant Field Values

      • NUTOKENS

        static final int NUTOKENS
        See Also:
        Constant Field Values

      • RCDATA

        static final int RCDATA
        See Also:
        Constant Field Values

      • EMPTY

        static final int EMPTY
        See Also:
        Constant Field Values

      • MODEL

        static final int MODEL
        See Also:
        Constant Field Values

      • ANY

        static final int ANY
        See Also:
        Constant Field Values

      • FIXED

        static final int FIXED
        See Also:
        Constant Field Values

      • REQUIRED

        static final int REQUIRED
        See Also:
        Constant Field Values

      • CURRENT

        static final int CURRENT
        See Also:
        Constant Field Values

      • CONREF

        static final int CONREF
        See Also:
        Constant Field Values

      • IMPLIED

        static final int IMPLIED
        See Also:
        Constant Field Values

      • PUBLIC

        static final int PUBLIC
        See Also:
        Constant Field Values

      • SDATA

        static final int SDATA
        See Also:
        Constant Field Values

      • PI

        static final int PI
        See Also:
        Constant Field Values

      • STARTTAG

        static final int STARTTAG
        See Also:
        Constant Field Values

      • ENDTAG

        static final int ENDTAG
        See Also:
        Constant Field Values

      • MS

        static final int MS
        See Also:
        Constant Field Values

      • MD

        static final int MD
        See Also:
        Constant Field Values

      • SYSTEM

        static final int SYSTEM
        See Also:
        Constant Field Values

      • GENERAL

        static final int GENERAL
        See Also:
        Constant Field Values

      • DEFAULT

        static final int DEFAULT
        See Also:
        Constant Field Values

      • PARAMETER

        static final int PARAMETER
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Element (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class Element

  • java.lang.Object
    • javax.swing.text.html.parser.Element
  • All Implemented Interfaces:
    Serializable, DTDConstants

    public final class Element
extends Object
implements DTDConstants, Serializable
    An element as described in a DTD using the ELEMENT construct. This is essential the description of a tag. It describes the type, content model, attributes, attribute types etc. It is used to correctly parse a document by the Parser.
    See Also:
    DTD, AttributeList

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      AttributeList atts
      ContentModel content
      Object data
      A field to store user data.
      BitSet exclusions
      BitSet inclusions
      int | index
      String name
      boolean | oEnd
      boolean | oStart
      int | type

      • Fields inherited from interface javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      AttributeList getAttribute(String name)
      Get an attribute by name.
      AttributeList getAttributeByValue(String name)
      Get an attribute by value.
      AttributeList getAttributes()
      Get the attributes.
      ContentModel getContent()
      Get content model
      int getIndex()
      Get index.
      String getName()
      Get the name of the element.
      int getType()
      Get type.
      boolean isEmpty()
      Check if empty
      static int | name2type(String nm)
      boolean omitEnd()
      Return true if the end tag can be omitted.
      boolean omitStart()
      Return true if the start tag can be omitted.
      String toString()
      Convert to a string.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • index

        public int index

      • name

        public String name

      • oStart

        public boolean oStart

      • oEnd

        public boolean oEnd

      • inclusions

        public BitSet inclusions

      • exclusions

        public BitSet exclusions

      • type

        public int type

      • content

        public ContentModel content

      • atts

        public AttributeList atts

      • data

        public Object data
        A field to store user data. Mostly used to store style sheets.

    • Method Detail

      • getName

        public String getName()
        Get the name of the element.

      • omitStart

        public boolean omitStart()
        Return true if the start tag can be omitted.

      • omitEnd

        public boolean omitEnd()
        Return true if the end tag can be omitted.

      • getType

        public int getType()
        Get type.

      • getContent

        public ContentModel getContent()
        Get content model

      • getAttributes

        public AttributeList getAttributes()
        Get the attributes.

      • getIndex

        public int getIndex()
        Get index.

      • isEmpty

        public boolean isEmpty()
        Check if empty

      • toString

        public String toString()
        Convert to a string.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.

      • getAttribute

        public AttributeList getAttribute(String name)
        Get an attribute by name.

      • getAttributeByValue

        public AttributeList getAttributeByValue(String name)
        Get an attribute by value.

      • name2type

        public static int name2type(String nm)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Entity (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class Entity

  • java.lang.Object
    • javax.swing.text.html.parser.Entity
  • All Implemented Interfaces:
    DTDConstants

    public final class Entity
extends Object
implements DTDConstants
    An entity is described in a DTD using the ENTITY construct. It defines the type and value of the the entity.
    See Also:
    DTD

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      char[] | data
      String name
      int | type

      • Fields inherited from interface javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • Constructor Summary

      Constructors
      Constructor and Description
      Entity(String name, int type, char[] data)
      Creates an entity.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      char[] getData()
      Returns the data.
      String getName()
      Gets the name of the entity.
      String getString()
      Returns the data as a String.
      int getType()
      Gets the type of the entity.
      boolean isGeneral()
      Returns true if it is a general entity.
      boolean isParameter()
      Returns true if it is a parameter entity.
      static int name2type(String nm)
      Converts nm string to the corresponding entity type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        public String name

      • type

        public int type

      • data

        public char[] data

    • Constructor Detail

      • Entity

        public Entity(String name,
              int type,
              char[] data)
        Creates an entity.
        Parameters:
        name - the name of the entity
        type - the type of the entity
        data - the char array of data

    • Method Detail

      • getName

        public String getName()
        Gets the name of the entity.
        Returns:
        the name of the entity, as a String

      • getType

        public int getType()
        Gets the type of the entity.
        Returns:
        the type of the entity

      • isParameter

        public boolean isParameter()
        Returns true if it is a parameter entity.
        Returns:
        true if it is a parameter entity

      • isGeneral

        public boolean isGeneral()
        Returns true if it is a general entity.
        Returns:
        true if it is a general entity

      • getData

        public char[] getData()
        Returns the data.
        Returns:
        the data

      • getString

        public String getString()
        Returns the data as a String.
        Returns:
        the data as a String

      • name2type

        public static int name2type(String nm)
        Converts nm string to the corresponding entity type. If the string does not have a corresponding entity type, returns the type corresponding to "CDATA". Valid entity types are: "PUBLIC", "CDATA", "SDATA", "PI", "STARTTAG", "ENDTAG", "MS", "MD", "SYSTEM".
        Parameters:
        nm - the string to be converted
        Returns:
        the corresponding entity type, or the type corresponding to "CDATA", if none exists
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.text.html.parser (Java Platform SE 8 )

javax.swing.text.html.parser

Interfaces

  • DTDConstants

Classes

  • AttributeList
  • ContentModel
  • DocumentParser
  • DTD
  • Element
  • Entity
  • Parser
  • ParserDelegator
  • TagElement


javax.swing.text.html.parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.swing.text.html.parser

Provides the default HTML parser, along with support classes.

See: Description

  • Interface Summary
    Interface Description
    DTDConstants
    SGML constants used in a DTD.
  • Class Summary
    Class Description
    AttributeList
    This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
    ContentModel
    A representation of a content model.
    DocumentParser
    A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
    DTD
    The representation of an SGML DTD.
    Element
    An element as described in a DTD using the ELEMENT construct.
    Entity
    An entity is described in a DTD using the ENTITY construct.
    Parser
    A simple DTD-driven HTML parser.
    ParserDelegator
    Responsible for starting up a new DocumentParser each time its parse method is invoked.
    TagElement
    A generic HTML TagElement class.

Package javax.swing.text.html.parser Description

Provides the default HTML parser, along with support classes. As the stream is parsed, the parser notifies a delegate, which must implement the HTMLEditorKit.ParserCallback interface.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Since:
1.2
See Also:
HTMLEditorKit.ParserCallback
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.text.html.parser Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.swing.text.html.parser

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.text.html.parser.AttributeList (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.swing.text.html.parser.ContentModel (implements java.io.Serializable)
    • javax.swing.text.html.parser.DTD (implements javax.swing.text.html.parser.DTDConstants)
    • javax.swing.text.html.parser.Element (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.swing.text.html.parser.Entity (implements javax.swing.text.html.parser.DTDConstants)
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator (implements java.io.Serializable)
    • javax.swing.text.html.parser.Parser (implements javax.swing.text.html.parser.DTDConstants)
      • javax.swing.text.html.parser.DocumentParser
    • javax.swing.text.html.parser.TagElement

Interface Hierarchy

  • javax.swing.text.html.parser.DTDConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.swing.text.html.parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.swing.text.html.parser

  • Packages that use javax.swing.text.html.parser
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.
  • Classes in javax.swing.text.html.parser used by javax.swing.text.html.parser
    Class and Description
    AttributeList
    This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
    ContentModel
    A representation of a content model.
    DTD
    The representation of an SGML DTD.
    DTDConstants
    SGML constants used in a DTD.
    Element
    An element as described in a DTD using the ELEMENT construct.
    Entity
    An entity is described in a DTD using the ENTITY construct.
    Parser
    A simple DTD-driven HTML parser.
    TagElement
    A generic HTML TagElement class.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class Parser

  • java.lang.Object
    • javax.swing.text.html.parser.Parser
  • All Implemented Interfaces:
    DTDConstants
    Direct Known Subclasses:
    DocumentParser

    public class Parser
extends Object
implements DTDConstants
    A simple DTD-driven HTML parser. The parser reads an HTML file from an InputStream and calls various methods (which should be overridden in a subclass) when tags and data are encountered.

    Unfortunately there are many badly implemented HTML parsers out there, and as a result there are many badly formatted HTML files. This parser attempts to parse most HTML files. This means that the implementation sometimes deviates from the SGML specification in favor of HTML.

    The parser treats \r and \r\n as \n. Newlines after starttags and before end tags are ignored just as specified in the SGML/HTML specification.

    The html spec does not specify how spaces are to be coalesced very well. Specifically, the following scenarios are not discussed (note that a space should be used here, but I am using &nbsp to force the space to be displayed):

    '<b>blah <i> <strike> foo' which can be treated as: '<b>blah <i><strike>foo'

    as well as: '<p><a href="xx"> <em>Using</em></a></p>' which appears to be treated as: '<p><a href="xx"><em>Using</em></a></p>'

    If strict is false, when a tag that breaks flow, (TagElement.breaksFlows) or trailing whitespace is encountered, all whitespace will be ignored until a non whitespace character is encountered. This appears to give behavior closer to the popular browsers.

    See Also:
    DTD, TagElement, SimpleAttributeSet

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected DTD | dtd
      protected boolean strict
      This flag determines whether or not the Parser will be strict in enforcing SGML compatibility.

      • Fields inherited from interface javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • Constructor Summary

      Constructors
      Constructor and Description
      Parser(DTD dtd)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      protected void endTag(boolean omitted)
      Handle an end tag.
      protected void | error(String err)
      protected void | error(String err, String arg1)
      protected void | error(String err, String arg1, String arg2)
      protected void error(String err, String arg1, String arg2, String arg3)
      Invoke the error handler.
      protected void | flushAttributes()
      protected SimpleAttributeSet | getAttributes()
      protected int | getCurrentLine()
      protected int | getCurrentPos()
      protected void handleComment(char[] text)
      Called when an HTML comment is encountered.
      protected void handleEmptyTag(TagElement tag)
      Called when an empty tag is encountered.
      protected void handleEndTag(TagElement tag)
      Called when an end tag is encountered.
      protected void | handleEOFInComment()
      protected void handleError(int ln, String msg)
      An error has occurred.
      protected void handleStartTag(TagElement tag)
      Called when a start tag is encountered.
      protected void handleText(char[] text)
      Called when PCDATA is encountered.
      protected void handleTitle(char[] text)
      Called when an HTML title tag is encountered.
      protected TagElement | makeTag(Element elem)
      protected TagElement makeTag(Element elem, boolean fictional)
      Makes a TagElement.
      protected void markFirstTime(Element elem)
      Marks the first time a tag has been seen in a document
      void parse(Reader in)
      Parse an HTML stream, given a DTD.
      String parseDTDMarkup()
      Parses th Document Declaration Type markup declaration.
      protected boolean parseMarkupDeclarations(StringBuffer strBuff)
      Parse markup declarations.
      protected void startTag(TagElement tag)
      Handle a start tag.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • dtd

        protected DTD dtd

      • strict

        protected boolean strict
        This flag determines whether or not the Parser will be strict in enforcing SGML compatibility. If false, it will be lenient with certain common classes of erroneous HTML constructs. Strict or not, in either case an error will be recorded.

    • Constructor Detail

      • Parser

        public Parser(DTD dtd)

    • Method Detail

      • getCurrentLine

        protected int getCurrentLine()
        Returns:
        the line number of the line currently being parsed

      • makeTag

        protected TagElement makeTag(Element elem,
                             boolean fictional)
        Makes a TagElement.

      • makeTag

        protected TagElement makeTag(Element elem)

      • getAttributes

        protected SimpleAttributeSet getAttributes()

      • flushAttributes

        protected void flushAttributes()

      • handleText

        protected void handleText(char[] text)
        Called when PCDATA is encountered.

      • handleTitle

        protected void handleTitle(char[] text)
        Called when an HTML title tag is encountered.

      • handleComment

        protected void handleComment(char[] text)
        Called when an HTML comment is encountered.

      • handleEOFInComment

        protected void handleEOFInComment()

      • handleEmptyTag

        protected void handleEmptyTag(TagElement tag)
                       throws ChangedCharSetException
        Called when an empty tag is encountered.
        Throws:
        ChangedCharSetException

      • handleStartTag

        protected void handleStartTag(TagElement tag)
        Called when a start tag is encountered.

      • handleEndTag

        protected void handleEndTag(TagElement tag)
        Called when an end tag is encountered.

      • handleError

        protected void handleError(int ln,
                           String msg)
        An error has occurred.

      • error

        protected void error(String err,
                     String arg1,
                     String arg2,
                     String arg3)
        Invoke the error handler.

      • error

        protected void error(String err,
                     String arg1,
                     String arg2)

      • error

        protected void error(String err,
                     String arg1)

      • error

        protected void error(String err)

      • startTag

        protected void startTag(TagElement tag)
                 throws ChangedCharSetException
        Handle a start tag. The new tag is pushed onto the tag stack. The attribute list is checked for required attributes.
        Throws:
        ChangedCharSetException

      • endTag

        protected void endTag(boolean omitted)
        Handle an end tag. The end tag is popped from the tag stack.

      • markFirstTime

        protected void markFirstTime(Element elem)
        Marks the first time a tag has been seen in a document

      • parseDTDMarkup

        public String parseDTDMarkup()
                      throws IOException
        Parses th Document Declaration Type markup declaration. Currently ignores it.
        Throws:
        IOException

      • parseMarkupDeclarations

        protected boolean parseMarkupDeclarations(StringBuffer strBuff)
                                   throws IOException
        Parse markup declarations. Currently only handles the Document Type Declaration markup. Returns true if it is a markup declaration false otherwise.
        Throws:
        IOException

      • parse

        public void parse(Reader in)
           throws IOException
        Parse an HTML stream, given a DTD.
        Throws:
        IOException

      • getCurrentPos

        protected int getCurrentPos()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParserDelegator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class ParserDelegator

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator
  • All Implemented Interfaces:
    Serializable

    public class ParserDelegator
extends HTMLEditorKit.Parser
implements Serializable
    Responsible for starting up a new DocumentParser each time its parse method is invoked. Stores a reference to the dtd.

    • Constructor Summary

      Constructors
      Constructor and Description
      ParserDelegator()

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      protected static DTD | createDTD(DTD dtd, String name)
      void parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      Parse the given stream and drive the given callback with the results of the parse.
      protected static void | setDefaultDTD()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ParserDelegator

        public ParserDelegator()

    • Method Detail

      • setDefaultDTD

        protected static void setDefaultDTD()

      • createDTD

        protected static DTD createDTD(DTD dtd,
                               String name)

      • parse

        public void parse(Reader r,
                  HTMLEditorKit.ParserCallback cb,
                  boolean ignoreCharSet)
           throws IOException
        Description copied from class: HTMLEditorKit.Parser
        Parse the given stream and drive the given callback with the results of the parse. This method should be implemented to be thread-safe.
        Specified by:
        parse in class HTMLEditorKit.Parser
        Throws:
        IOException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TagElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.html.parser

Class TagElement

  • java.lang.Object
    • javax.swing.text.html.parser.TagElement

  • public class TagElement
extends Object
    A generic HTML TagElement class. The methods define how white space is interpreted around the tag.

    • Constructor Summary

      Constructors
      Constructor and Description
      TagElement(Element elem)
      TagElement(Element elem, boolean fictional)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      boolean | breaksFlow()
      boolean | fictional()
      Element getElement()
      HTML.Tag getHTMLTag()
      boolean | isPreformatted()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TagElement

        public TagElement(Element elem)

      • TagElement

        public TagElement(Element elem,
                  boolean fictional)

    • Method Detail

      • breaksFlow

        public boolean breaksFlow()

      • isPreformatted

        public boolean isPreformatted()

      • getElement

        public Element getElement()

      • getHTMLTag

        public HTML.Tag getHTMLTag()

      • fictional

        public boolean fictional()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.AttributeList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.AttributeList

  • Packages that use AttributeList
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of AttributeList in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as AttributeList
      Modifier and Type | Field and Description
      AttributeList | Element.atts
      AttributeList | AttributeList.next
      Methods in javax.swing.text.html.parser that return AttributeList
      Modifier and Type | Method and Description
      protected AttributeList DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
      Creates and returns an AttributeList.
      AttributeList Element.getAttribute(String name)
      Get an attribute by name.
      AttributeList Element.getAttributeByValue(String name)
      Get an attribute by value.
      AttributeList Element.getAttributes()
      Get the attributes.
      AttributeList | AttributeList.getNext()
      Methods in javax.swing.text.html.parser with parameters of type AttributeList
      Modifier and Type Method and Description
      protected AttributeList DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
      Creates and returns an AttributeList.
      protected Element DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      void DTD.defineAttributes(String name, AttributeList atts)
      Defines attributes for an Element.
      Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Constructors in javax.swing.text.html.parser with parameters of type AttributeList
      Constructor and Description
      AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
      Create an attribute list element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.ContentModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.ContentModel

  • Packages that use ContentModel
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of ContentModel in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as ContentModel
      Modifier and Type | Field and Description
      ContentModel | Element.content
      ContentModel ContentModel.next
      The next content model (in a ',', '|' or '&' expression).
      Methods in javax.swing.text.html.parser that return ContentModel
      Modifier and Type Method and Description
      protected ContentModel DTD.defContentModel(int type, Object obj, ContentModel next)
      Creates and returns a new content model.
      ContentModel Element.getContent()
      Get content model
      Methods in javax.swing.text.html.parser with parameters of type ContentModel
      Modifier and Type Method and Description
      protected ContentModel DTD.defContentModel(int type, Object obj, ContentModel next)
      Creates and returns a new content model.
      protected Element DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Constructors in javax.swing.text.html.parser with parameters of type ContentModel
      Constructor and Description
      ContentModel(int type, ContentModel content)
      Create a content model of a particular type.
      ContentModel(int type, Object content, ContentModel next)
      Create a content model of a particular type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.DocumentParser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.DocumentParser

No usage of javax.swing.text.html.parser.DocumentParser
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.DTD (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.DTD

  • Packages that use DTD
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of DTD in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as DTD
      Modifier and Type | Field and Description
      protected DTD | Parser.dtd
      Methods in javax.swing.text.html.parser that return DTD
      Modifier and Type | Method and Description
      protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
      static DTD DTD.getDTD(String name)
      Returns a DTD with the specified name.
      Methods in javax.swing.text.html.parser with parameters of type DTD
      Modifier and Type | Method and Description
      protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
      static void | DTD.putDTDHash(String name, DTD dtd)
      Constructors in javax.swing.text.html.parser with parameters of type DTD
      Constructor and Description
      DocumentParser(DTD dtd)
      Parser(DTD dtd)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.text.html.parser.DTDConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.text.html.parser.DTDConstants

  • Packages that use DTDConstants
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of DTDConstants in javax.swing.text.html.parser

      Classes in javax.swing.text.html.parser that implement DTDConstants
      Modifier and Type Class and Description
      class  AttributeList
      This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
      class  DocumentParser
      A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
      class  DTD
      The representation of an SGML DTD.
      class  Element
      An element as described in a DTD using the ELEMENT construct.
      class  Entity
      An entity is described in a DTD using the ENTITY construct.
      class  Parser
      A simple DTD-driven HTML parser.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.Element (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.Element

  • Packages that use Element
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of Element in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as Element
      Modifier and Type | Field and Description
      Element | DTD.applet
      Element | DTD.base
      Element | DTD.body
      Element | DTD.head
      Element | DTD.html
      Element | DTD.isindex
      Element | DTD.meta
      Element | DTD.p
      Element | DTD.param
      Element | DTD.pcdata
      Element | DTD.title
      Fields in javax.swing.text.html.parser with type parameters of type Element
      Modifier and Type | Field and Description
      Hashtable<String,Element> | DTD.elementHash
      Vector<Element> | DTD.elements
      Methods in javax.swing.text.html.parser that return Element
      Modifier and Type | Method and Description
      protected Element DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Element ContentModel.first()
      Return the element that must be next.
      Element | TagElement.getElement()
      Element DTD.getElement(int index)
      Gets an element by index.
      Element DTD.getElement(String name)
      Gets an element by name.
      Methods in javax.swing.text.html.parser with parameters of type Element
      Modifier and Type | Method and Description
      protected TagElement | Parser.makeTag(Element elem)
      protected TagElement Parser.makeTag(Element elem, boolean fictional)
      Makes a TagElement.
      protected void Parser.markFirstTime(Element elem)
      Marks the first time a tag has been seen in a document
      Method parameters in javax.swing.text.html.parser with type arguments of type Element
      Modifier and Type Method and Description
      void ContentModel.getElements(Vector<Element> elemVec)
      Update elemVec with the list of elements that are part of the this contentModel.
      Constructors in javax.swing.text.html.parser with parameters of type Element
      Constructor and Description
      ContentModel(Element content)
      Create a content model for an element.
      TagElement(Element elem)
      TagElement(Element elem, boolean fictional)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.Entity (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.Entity

  • Packages that use Entity
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of Entity in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser with type parameters of type Entity
      Modifier and Type | Field and Description
      Hashtable<Object,Entity> | DTD.entityHash
      Methods in javax.swing.text.html.parser that return Entity
      Modifier and Type Method and Description
      Entity DTD.defEntity(String name, int type, int ch)
      Creates and returns a character Entity.
      protected Entity DTD.defEntity(String name, int type, String str)
      Creates and returns an Entity.
      Entity DTD.defineEntity(String name, int type, char[] data)
      Defines an entity.
      Entity DTD.getEntity(int ch)
      Gets a character entity.
      Entity DTD.getEntity(String name)
      Gets an entity by name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.Parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.Parser

  • Packages that use Parser
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of Parser in javax.swing.text.html.parser

      Subclasses of Parser in javax.swing.text.html.parser
      Modifier and Type Class and Description
      class  DocumentParser
      A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.ParserDelegator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.ParserDelegator

No usage of javax.swing.text.html.parser.ParserDelegator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.html.parser.TagElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.html.parser.TagElement

  • Packages that use TagElement
    Package Description
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of TagElement in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that return TagElement
      Modifier and Type | Method and Description
      protected TagElement | Parser.makeTag(Element elem)
      protected TagElement Parser.makeTag(Element elem, boolean fictional)
      Makes a TagElement.
      Methods in javax.swing.text.html.parser with parameters of type TagElement
      Modifier and Type Method and Description
      protected void DocumentParser.handleEmptyTag(TagElement tag)
      Handle Empty Tag.
      protected void Parser.handleEmptyTag(TagElement tag)
      Called when an empty tag is encountered.
      protected void DocumentParser.handleEndTag(TagElement tag)
      Handle End Tag.
      protected void Parser.handleEndTag(TagElement tag)
      Called when an end tag is encountered.
      protected void DocumentParser.handleStartTag(TagElement tag)
      Handle Start Tag.
      protected void Parser.handleStartTag(TagElement tag)
      Called when a start tag is encountered.
      protected void Parser.startTag(TagElement tag)
      Handle a start tag.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.text.rtf (Java Platform SE 8 )

javax.swing.text.rtf

Classes

  • RTFEditorKit


javax.swing.text.rtf (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.swing.text.rtf

Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

See: Description

  • Class Summary
    Class Description
    RTFEditorKit
    This is the default implementation of RTF editing functionality.

Package javax.swing.text.rtf Description

Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Since:
1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.text.rtf Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.swing.text.rtf

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.rtf.RTFEditorKit
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.swing.text.rtf (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.swing.text.rtf

No usage of javax.swing.text.rtf
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RTFEditorKit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.text.rtf

Class RTFEditorKit

  • java.lang.Object
    • javax.swing.text.EditorKit
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.rtf.RTFEditorKit
  • All Implemented Interfaces:
    Serializable, Cloneable

    public class RTFEditorKit
extends StyledEditorKit
    This is the default implementation of RTF editing functionality. The RTF support was not written by the Swing team. In the future we hope to improve the support provided.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.text.StyledEditorKit

        StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction

      • Nested classes/interfaces inherited from class javax.swing.text.DefaultEditorKit

        DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction

    • Field Summary

      • Fields inherited from class javax.swing.text.DefaultEditorKit

        backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction

    • Constructor Summary

      Constructors
      Constructor and Description
      RTFEditorKit()
      Constructs an RTFEditorKit.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getContentType()
      Get the MIME type of the data that this kit represents support for.
      void read(InputStream in, Document doc, int pos)
      Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void read(Reader in, Document doc, int pos)
      Insert content from the given stream, which will be treated as plain text.
      void write(OutputStream out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.
      void write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream as plain text.

      • Methods inherited from class javax.swing.text.StyledEditorKit

        clone, createDefaultDocument, createInputAttributes, deinstall, getActions, getCharacterAttributeRun, getInputAttributes, getViewFactory, install

      • Methods inherited from class javax.swing.text.DefaultEditorKit

        createCaret

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RTFEditorKit

        public RTFEditorKit()
        Constructs an RTFEditorKit.

    • Method Detail

      • getContentType

        public String getContentType()
        Get the MIME type of the data that this kit represents support for. This kit supports the type text/rtf.
        Overrides:
        getContentType in class DefaultEditorKit
        Returns:
        the type

      • read

        public void read(InputStream in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
        Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
        Overrides:
        read in class DefaultEditorKit
        Parameters:
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content.
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public void write(OutputStream out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
        Write content from a document to the given stream in a format appropriate for this kind of content handler.
        Overrides:
        write in class DefaultEditorKit
        Parameters:
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content.
        len - The amount to write out.
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • read

        public void read(Reader in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
        Insert content from the given stream, which will be treated as plain text.
        Overrides:
        read in class DefaultEditorKit
        Parameters:
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content.
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public void write(Writer out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
        Write content from a document to the given stream as plain text.
        Overrides:
        write in class DefaultEditorKit
        Parameters:
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content.
        len - The amount to write out.
        Throws:
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.text.rtf.RTFEditorKit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.text.rtf.RTFEditorKit

No usage of javax.swing.text.rtf.RTFEditorKit
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AbstractLayoutCache (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class AbstractLayoutCache

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache
  • All Implemented Interfaces:
    RowMapper
    Direct Known Subclasses:
    FixedHeightLayoutCache, VariableHeightLayoutCache

    public abstract class AbstractLayoutCache
extends Object
implements RowMapper
    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  AbstractLayoutCache.NodeDimensions
      Used by AbstractLayoutCache to determine the size and x origin of a particular node.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected AbstractLayoutCache.NodeDimensions nodeDimensions
      Object responsible for getting the size of a node.
      protected boolean rootVisible
      True if the root node is displayed, false if its children are the highest visible nodes.
      protected int rowHeight
      Height to use for each row.
      protected TreeModel treeModel
      Model providing information.
      protected TreeSelectionModel treeSelectionModel
      Selection model.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractLayoutCache()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Rectangle getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      abstract boolean getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      TreeModel getModel()
      Returns the TreeModel that is providing the data.
      AbstractLayoutCache.NodeDimensions getNodeDimensions()
      Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.
      protected Rectangle getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn)
      Returns, by reference in placeIn, the size needed to represent value.
      abstract TreePath getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath getPathForRow(int row)
      Returns the path for passed in row.
      int getPreferredHeight()
      Returns the preferred height.
      int getPreferredWidth(Rectangle bounds)
      Returns the preferred width for the passed in region.
      abstract int getRowCount()
      Number of rows being displayed.
      abstract int getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      int getRowHeight()
      Returns the height of each row.
      int[] getRowsForPaths(TreePath[] paths)
      Returns the rows that the TreePath instances in path are being displayed at.
      TreeSelectionModel getSelectionModel()
      Returns the model used to maintain the selection.
      abstract int getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      abstract Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      abstract void invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      abstract void invalidateSizes()
      Informs the TreeState that it needs to recalculate all the sizes it is referencing.
      abstract boolean isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      protected boolean isFixedRowHeight()
      Returns true if the height of each row is a fixed size.
      boolean isRootVisible()
      Returns true if the root node of the tree is displayed.
      abstract void setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree and which is therefore responsible for calculating the dimensions of individual nodes.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell.
      void setSelectionModel(TreeSelectionModel newLSM)
      Sets the TreeSelectionModel used to manage the selection to new LSM.
      abstract void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      abstract void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      abstract void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      abstract void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • nodeDimensions

        protected AbstractLayoutCache.NodeDimensions nodeDimensions
        Object responsible for getting the size of a node.

      • treeModel

        protected TreeModel treeModel
        Model providing information.

      • treeSelectionModel

        protected TreeSelectionModel treeSelectionModel
        Selection model.

      • rootVisible

        protected boolean rootVisible
        True if the root node is displayed, false if its children are the highest visible nodes.

      • rowHeight

        protected int rowHeight
        Height to use for each row. If this is <= 0 the renderer will be used to determine the height for each row.

    • Constructor Detail

      • AbstractLayoutCache

        public AbstractLayoutCache()

    • Method Detail

      • setNodeDimensions

        public void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
        Sets the renderer that is responsible for drawing nodes in the tree and which is therefore responsible for calculating the dimensions of individual nodes.
        Parameters:
        nd - a NodeDimensions object

      • getNodeDimensions

        public AbstractLayoutCache.NodeDimensions getNodeDimensions()
        Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.
        Returns:
        the NodeDimensions object

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.
        Parameters:
        newModel - the TreeModel that is to provide the data

      • getModel

        public TreeModel getModel()
        Returns the TreeModel that is providing the data.
        Returns:
        the TreeModel that is providing the data

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.
        Parameters:
        rootVisible - true if the root node of the tree is to be displayed
        See Also:
        rootVisible

      • isRootVisible

        public boolean isRootVisible()
        Returns true if the root node of the tree is displayed.
        Returns:
        true if the root node of the tree is displayed
        See Also:
        rootVisible

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell. If the specified value is less than or equal to zero the current cell renderer is queried for each row's height.
        Parameters:
        rowHeight - the height of each cell, in pixels

      • getRowHeight

        public int getRowHeight()
        Returns the height of each row. If the returned value is less than or equal to 0 the height for each row is determined by the renderer.

      • setSelectionModel

        public void setSelectionModel(TreeSelectionModel newLSM)
        Sets the TreeSelectionModel used to manage the selection to new LSM.
        Parameters:
        newLSM - the new TreeSelectionModel

      • getSelectionModel

        public TreeSelectionModel getSelectionModel()
        Returns the model used to maintain the selection.
        Returns:
        the treeSelectionModel

      • getPreferredHeight

        public int getPreferredHeight()
        Returns the preferred height.
        Returns:
        the preferred height

      • getPreferredWidth

        public int getPreferredWidth(Rectangle bounds)
        Returns the preferred width for the passed in region. The region is defined by the path closest to (bounds.x, bounds.y) and ends at bounds.height + bounds.y. If bounds is null, the preferred width for all the nodes will be returned (and this may be a VERY expensive computation).
        Parameters:
        bounds - the region being queried
        Returns:
        the preferred width for the passed in region

      • isExpanded

        public abstract boolean isExpanded(TreePath path)
        Returns true if the value identified by row is currently expanded.

      • getBounds

        public abstract Rectangle getBounds(TreePath path,
                                    Rectangle placeIn)
        Returns a rectangle giving the bounds needed to draw path.
        Parameters:
        path - a TreePath specifying a node
        placeIn - a Rectangle object giving the available space
        Returns:
        a Rectangle object specifying the space to be used

      • getPathForRow

        public abstract TreePath getPathForRow(int row)
        Returns the path for passed in row. If row is not visible null is returned.
        Parameters:
        row - the row being queried
        Returns:
        the TreePath for the given row

      • getRowForPath

        public abstract int getRowForPath(TreePath path)
        Returns the row that the last item identified in path is visible at. Will return -1 if any of the elements in path are not currently visible.
        Parameters:
        path - the TreePath being queried
        Returns:
        the row where the last item in path is visible or -1 if any elements in path aren't currently visible

      • getPathClosestTo

        public abstract TreePath getPathClosestTo(int x,
                                          int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it'll always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        Parameters:
        x - the horizontal component of the desired location
        y - the vertical component of the desired location
        Returns:
        the TreePath closest to the specified point

      • getVisiblePathsFrom

        public abstract Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
        Returns an Enumerator that increments over the visible paths starting at the passed in location. The ordering of the enumeration is based on how the paths are displayed. The first element of the returned enumeration will be path, unless it isn't visible, in which case null will be returned.
        Parameters:
        path - the starting location for the enumeration
        Returns:
        the Enumerator starting at the desired location

      • getVisibleChildCount

        public abstract int getVisibleChildCount(TreePath path)
        Returns the number of visible children for row.
        Parameters:
        path - the path being queried
        Returns:
        the number of visible children for the specified path

      • setExpandedState

        public abstract void setExpandedState(TreePath path,
                                      boolean isExpanded)
        Marks the path path expanded state to isExpanded.
        Parameters:
        path - the path being expanded or collapsed
        isExpanded - true if the path should be expanded, false otherwise

      • getExpandedState

        public abstract boolean getExpandedState(TreePath path)
        Returns true if the path is expanded, and visible.
        Parameters:
        path - the path being queried
        Returns:
        true if the path is expanded and visible, false otherwise

      • getRowCount

        public abstract int getRowCount()
        Number of rows being displayed.
        Returns:
        the number of rows being displayed

      • invalidateSizes

        public abstract void invalidateSizes()
        Informs the TreeState that it needs to recalculate all the sizes it is referencing.

      • invalidatePathBounds

        public abstract void invalidatePathBounds(TreePath path)
        Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
        Parameters:
        path - the path being updated

      • treeNodesChanged

        public abstract void treeNodesChanged(TreeModelEvent e)

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        e.path() returns the path the parent of the changed node(s).

        e.childIndices() returns the index(es) of the changed node(s).

        Parameters:
        e - the TreeModelEvent

      • treeNodesInserted

        public abstract void treeNodesInserted(TreeModelEvent e)

        Invoked after nodes have been inserted into the tree.

        e.path() returns the parent of the new nodes

        e.childIndices() returns the indices of the new nodes in ascending order.

        Parameters:
        e - the TreeModelEvent

      • treeNodesRemoved

        public abstract void treeNodesRemoved(TreeModelEvent e)

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        e.path() returns the former parent of the deleted nodes.

        e.childIndices() returns the indices the nodes had before they were deleted in ascending order.

        Parameters:
        e - the TreeModelEvent

      • treeStructureChanged

        public abstract void treeStructureChanged(TreeModelEvent e)

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        e.path() holds the path to the node.

        e.childIndices() returns null.

        Parameters:
        e - the TreeModelEvent

      • getRowsForPaths

        public int[] getRowsForPaths(TreePath[] paths)
        Returns the rows that the TreePath instances in path are being displayed at. This method should return an array of the same length as that passed in, and if one of the TreePaths in path is not valid its entry in the array should be set to -1.
        Specified by:
        getRowsForPaths in interface RowMapper
        Parameters:
        paths - the array of TreePaths being queried
        Returns:
        an array of the same length that is passed in containing the rows that each corresponding where each TreePath is displayed; if paths is null, null is returned

      • getNodeDimensions

        protected Rectangle getNodeDimensions(Object value,
                                      int row,
                                      int depth,
                                      boolean expanded,
                                      Rectangle placeIn)
        Returns, by reference in placeIn, the size needed to represent value. If inPlace is null, a newly created Rectangle should be returned, otherwise the value should be placed in inPlace and returned. This will return null if there is no renderer.
        Parameters:
        value - the value to be represented
        row - row being queried
        depth - the depth of the row
        expanded - true if row is expanded, false otherwise
        placeIn - a Rectangle containing the size needed to represent value
        Returns:
        a Rectangle containing the node dimensions, or null if node has no dimension

      • isFixedRowHeight

        protected boolean isFixedRowHeight()
        Returns true if the height of each row is a fixed size.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AbstractLayoutCache.NodeDimensions (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class AbstractLayoutCache.NodeDimensions

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
  • Direct Known Subclasses:
    BasicTreeUI.NodeDimensionsHandler
    Enclosing class:
    AbstractLayoutCache

    public abstract static class AbstractLayoutCache.NodeDimensions
extends Object
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.

    • Constructor Summary

      Constructors
      Constructor and Description
      NodeDimensions()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract Rectangle getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds)
      Returns, by reference in bounds, the size and x origin to place value at.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NodeDimensions

        public NodeDimensions()

    • Method Detail

      • getNodeDimensions

        public abstract Rectangle getNodeDimensions(Object value,
                                            int row,
                                            int depth,
                                            boolean expanded,
                                            Rectangle bounds)
        Returns, by reference in bounds, the size and x origin to place value at. The calling method is responsible for determining the Y location. If bounds is null, a newly created Rectangle should be returned, otherwise the value should be placed in bounds and returned.
        Parameters:
        value - the value to be represented
        row - row being queried
        depth - the depth of the row
        expanded - true if row is expanded, false otherwise
        bounds - a Rectangle containing the size needed to represent value
        Returns:
        a Rectangle containing the node dimensions, or null if node has no dimension
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultMutableTreeNode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultMutableTreeNode

  • java.lang.Object
    • javax.swing.tree.DefaultMutableTreeNode
  • All Implemented Interfaces:
    Serializable, Cloneable, MutableTreeNode, TreeNode
    Direct Known Subclasses:
    JTree.DynamicUtilTreeNode

    public class DefaultMutableTreeNode
extends Object
implements Cloneable, MutableTreeNode, Serializable
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure. For examples of using default mutable tree nodes, see How to Use Trees in The Java Tutorial.

    A tree node may have at most one parent and 0 or more children. DefaultMutableTreeNode provides operations for examining and modifying a node's parent and children and also operations for examining the tree that the node is a part of. A node's tree is the set of all nodes that can be reached by starting at the node and following all the possible links to parents and children. A node with no parent is the root of its tree; a node with no children is a leaf. A tree may consist of many subtrees, each node acting as the root for its own subtree.

    This class provides enumerations for efficiently traversing a tree or subtree in various orders or for following the path between two nodes. A DefaultMutableTreeNode may also hold a reference to a user object, the use of which is left to the user. Asking a DefaultMutableTreeNode for its string representation with toString() returns the string representation of its user object.

    This is not a thread safe class.If you intend to use a DefaultMutableTreeNode (or a tree of TreeNodes) in more than one thread, you need to do your own synchronizing. A good convention to adopt is synchronizing on the root node of a tree.

    While DefaultMutableTreeNode implements the MutableTreeNode interface and will allow you to add in any implementation of MutableTreeNode not all of the methods in DefaultMutableTreeNode will be applicable to all MutableTreeNodes implementations. Especially with some of the enumerations that are provided, using some of these methods assumes the DefaultMutableTreeNode contains only DefaultMutableNode instances. All of the TreeNode/MutableTreeNode methods will behave as defined no matter what implementations are added.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    See Also:
    MutableTreeNode

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean allowsChildren
      true if the node is able to have children
      protected Vector children
      array of children, may be null if this node has no children
      static Enumeration<TreeNode> EMPTY_ENUMERATION
      An enumeration that is always empty.
      protected MutableTreeNode parent
      this node's parent, or null if this node has no parent
      protected Object userObject
      optional user object

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultMutableTreeNode()
      Creates a tree node that has no parent and no children, but which allows children.
      DefaultMutableTreeNode(Object userObject)
      Creates a tree node with no parent, no children, but which allows children, and initializes it with the specified user object.
      DefaultMutableTreeNode(Object userObject, boolean allowsChildren)
      Creates a tree node with no parent, no children, initialized with the specified user object, and that allows children only if specified.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void add(MutableTreeNode newChild)
      Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
      Enumeration breadthFirstEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in breadth-first order.
      Enumeration children()
      Creates and returns a forward-order enumeration of this node's children.
      Object clone()
      Overridden to make clone public.
      Enumeration depthFirstEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in depth-first order.
      boolean getAllowsChildren()
      Returns true if this node is allowed to have children.
      TreeNode getChildAfter(TreeNode aChild)
      Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.
      TreeNode getChildAt(int index)
      Returns the child at the specified index in this node's child array.
      TreeNode getChildBefore(TreeNode aChild)
      Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.
      int getChildCount()
      Returns the number of children of this node.
      int getDepth()
      Returns the depth of the tree rooted at this node -- the longest distance from this node to a leaf.
      TreeNode getFirstChild()
      Returns this node's first child.
      DefaultMutableTreeNode getFirstLeaf()
      Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf.
      int getIndex(TreeNode aChild)
      Returns the index of the specified child in this node's child array.
      TreeNode getLastChild()
      Returns this node's last child.
      DefaultMutableTreeNode getLastLeaf()
      Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf.
      int getLeafCount()
      Returns the total number of leaves that are descendants of this node.
      int getLevel()
      Returns the number of levels above this node -- the distance from the root to this node.
      DefaultMutableTreeNode getNextLeaf()
      Returns the leaf after this node or null if this node is the last leaf in the tree.
      DefaultMutableTreeNode getNextNode()
      Returns the node that follows this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode getNextSibling()
      Returns the next sibling of this node in the parent's children array.
      TreeNode getParent()
      Returns this node's parent or null if this node has no parent.
      TreeNode[] getPath()
      Returns the path from the root, to get to this node.
      protected TreeNode[] getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      DefaultMutableTreeNode getPreviousLeaf()
      Returns the leaf before this node or null if this node is the first leaf in the tree.
      DefaultMutableTreeNode getPreviousNode()
      Returns the node that precedes this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode getPreviousSibling()
      Returns the previous sibling of this node in the parent's children array.
      TreeNode getRoot()
      Returns the root of the tree that contains this node.
      TreeNode getSharedAncestor(DefaultMutableTreeNode aNode)
      Returns the nearest common ancestor to this node and aNode.
      int getSiblingCount()
      Returns the number of siblings of this node.
      Object getUserObject()
      Returns this node's user object.
      Object[] getUserObjectPath()
      Returns the user object path, from the root, to get to this node.
      void insert(MutableTreeNode newChild, int childIndex)
      Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex.
      boolean isLeaf()
      Returns true if this node has no children.
      boolean isNodeAncestor(TreeNode anotherNode)
      Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent.
      boolean isNodeChild(TreeNode aNode)
      Returns true if aNode is a child of this node.
      boolean isNodeDescendant(DefaultMutableTreeNode anotherNode)
      Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children.
      boolean isNodeRelated(DefaultMutableTreeNode aNode)
      Returns true if and only if aNode is in the same tree as this node.
      boolean isNodeSibling(TreeNode anotherNode)
      Returns true if anotherNode is a sibling of (has the same parent as) this node.
      boolean isRoot()
      Returns true if this node is the root of the tree.
      Enumeration pathFromAncestorEnumeration(TreeNode ancestor)
      Creates and returns an enumeration that follows the path from ancestor to this node.
      Enumeration postorderEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in postorder.
      Enumeration preorderEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in preorder.
      void remove(int childIndex)
      Removes the child at the specified index from this node's children and sets that node's parent to null.
      void remove(MutableTreeNode aChild)
      Removes aChild from this node's child array, giving it a null parent.
      void removeAllChildren()
      Removes all of this node's children, setting their parents to null.
      void removeFromParent()
      Removes the subtree rooted at this node from the tree, giving this node a null parent.
      void setAllowsChildren(boolean allows)
      Determines whether or not this node is allowed to have children.
      void setParent(MutableTreeNode newParent)
      Sets this node's parent to newParent but does not change the parent's child array.
      void setUserObject(Object userObject)
      Sets the user object for this node to userObject.
      String toString()
      Returns the result of sending toString() to this node's user object, or the empty string if the node has no user object.

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • EMPTY_ENUMERATION

        public static final Enumeration<TreeNode> EMPTY_ENUMERATION
        An enumeration that is always empty. This is used when an enumeration of a leaf node's children is requested.

      • parent

        protected MutableTreeNode parent
        this node's parent, or null if this node has no parent

      • children

        protected Vector children
        array of children, may be null if this node has no children

      • userObject

        protected transient Object userObject
        optional user object

      • allowsChildren

        protected boolean allowsChildren
        true if the node is able to have children

    • Constructor Detail

      • DefaultMutableTreeNode

        public DefaultMutableTreeNode()
        Creates a tree node that has no parent and no children, but which allows children.

      • DefaultMutableTreeNode

        public DefaultMutableTreeNode(Object userObject)
        Creates a tree node with no parent, no children, but which allows children, and initializes it with the specified user object.
        Parameters:
        userObject - an Object provided by the user that constitutes the node's data

      • DefaultMutableTreeNode

        public DefaultMutableTreeNode(Object userObject,
                              boolean allowsChildren)
        Creates a tree node with no parent, no children, initialized with the specified user object, and that allows children only if specified.
        Parameters:
        userObject - an Object provided by the user that constitutes the node's data
        allowsChildren - if true, the node is allowed to have child nodes -- otherwise, it is always a leaf node

    • Method Detail

      • insert

        public void insert(MutableTreeNode newChild,
                   int childIndex)
        Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex. newChild must not be null and must not be an ancestor of this node.
        Specified by:
        insert in interface MutableTreeNode
        Parameters:
        newChild - the MutableTreeNode to insert under this node
        childIndex - the index in this node's child array where this node is to be inserted
        Throws:
        ArrayIndexOutOfBoundsException - if childIndex is out of bounds
        IllegalArgumentException - if newChild is null or is an ancestor of this node
        IllegalStateException - if this node does not allow children
        See Also:
        isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • remove

        public void remove(int childIndex)
        Removes the child at the specified index from this node's children and sets that node's parent to null. The child node to remove must be a MutableTreeNode.
        Specified by:
        remove in interface MutableTreeNode
        Parameters:
        childIndex - the index in this node's child array of the child to remove
        Throws:
        ArrayIndexOutOfBoundsException - if childIndex is out of bounds

      • setParent

        public void setParent(MutableTreeNode newParent)
        Sets this node's parent to newParent but does not change the parent's child array. This method is called from insert() and remove() to reassign a child's parent, it should not be messaged from anywhere else.
        Specified by:
        setParent in interface MutableTreeNode
        Parameters:
        newParent - this node's new parent

      • getParent

        public TreeNode getParent()
        Returns this node's parent or null if this node has no parent.
        Specified by:
        getParent in interface TreeNode
        Returns:
        this node's parent TreeNode, or null if this node has no parent

      • getChildAt

        public TreeNode getChildAt(int index)
        Returns the child at the specified index in this node's child array.
        Specified by:
        getChildAt in interface TreeNode
        Parameters:
        index - an index into this node's child array
        Returns:
        the TreeNode in this node's child array at the specified index
        Throws:
        ArrayIndexOutOfBoundsException - if index is out of bounds

      • getChildCount

        public int getChildCount()
        Returns the number of children of this node.
        Specified by:
        getChildCount in interface TreeNode
        Returns:
        an int giving the number of children of this node

      • getIndex

        public int getIndex(TreeNode aChild)
        Returns the index of the specified child in this node's child array. If the specified node is not a child of this node, returns -1. This method performs a linear search and is O(n) where n is the number of children.
        Specified by:
        getIndex in interface TreeNode
        Parameters:
        aChild - the TreeNode to search for among this node's children
        Returns:
        an int giving the index of the node in this node's child array, or -1 if the specified node is a not a child of this node
        Throws:
        IllegalArgumentException - if aChild is null

      • children

        public Enumeration children()
        Creates and returns a forward-order enumeration of this node's children. Modifying this node's child array invalidates any child enumerations created before the modification.
        Specified by:
        children in interface TreeNode
        Returns:
        an Enumeration of this node's children

      • setAllowsChildren

        public void setAllowsChildren(boolean allows)
        Determines whether or not this node is allowed to have children. If allows is false, all of this node's children are removed.

        Note: By default, a node allows children.

        Parameters:
        allows - true if this node is allowed to have children

      • getAllowsChildren

        public boolean getAllowsChildren()
        Returns true if this node is allowed to have children.
        Specified by:
        getAllowsChildren in interface TreeNode
        Returns:
        true if this node allows children, else false

      • setUserObject

        public void setUserObject(Object userObject)
        Sets the user object for this node to userObject.
        Specified by:
        setUserObject in interface MutableTreeNode
        Parameters:
        userObject - the Object that constitutes this node's user-specified data
        See Also:
        getUserObject(), toString()

      • getUserObject

        public Object getUserObject()
        Returns this node's user object.
        Returns:
        the Object stored at this node by the user
        See Also:
        setUserObject(java.lang.Object), toString()

      • removeFromParent

        public void removeFromParent()
        Removes the subtree rooted at this node from the tree, giving this node a null parent. Does nothing if this node is the root of its tree.
        Specified by:
        removeFromParent in interface MutableTreeNode

      • remove

        public void remove(MutableTreeNode aChild)
        Removes aChild from this node's child array, giving it a null parent.
        Specified by:
        remove in interface MutableTreeNode
        Parameters:
        aChild - a child of this node to remove
        Throws:
        IllegalArgumentException - if aChild is null or is not a child of this node

      • removeAllChildren

        public void removeAllChildren()
        Removes all of this node's children, setting their parents to null. If this node has no children, this method does nothing.

      • add

        public void add(MutableTreeNode newChild)
        Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
        Parameters:
        newChild - node to add as a child of this node
        Throws:
        IllegalArgumentException - if newChild is null
        IllegalStateException - if this node does not allow children
        See Also:
        insert(javax.swing.tree.MutableTreeNode, int)

      • isNodeAncestor

        public boolean isNodeAncestor(TreeNode anotherNode)
        Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent. (Note that a node is considered an ancestor of itself.) If anotherNode is null, this method returns false. This operation is at worst O(h) where h is the distance from the root to this node.
        Parameters:
        anotherNode - node to test as an ancestor of this node
        Returns:
        true if this node is a descendant of anotherNode
        See Also:
        isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode), getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode)

      • isNodeDescendant

        public boolean isNodeDescendant(DefaultMutableTreeNode anotherNode)
        Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children. Note that a node is considered a descendant of itself. If anotherNode is null, returns false. This operation is at worst O(h) where h is the distance from the root to anotherNode.
        Parameters:
        anotherNode - node to test as descendant of this node
        Returns:
        true if this node is an ancestor of anotherNode
        See Also:
        isNodeAncestor(javax.swing.tree.TreeNode), getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode)

      • getSharedAncestor

        public TreeNode getSharedAncestor(DefaultMutableTreeNode aNode)
        Returns the nearest common ancestor to this node and aNode. Returns null, if no such ancestor exists -- if this node and aNode are in different trees or if aNode is null. A node is considered an ancestor of itself.
        Parameters:
        aNode - node to find common ancestor with
        Returns:
        nearest ancestor common to this node and aNode, or null if none
        See Also:
        isNodeAncestor(javax.swing.tree.TreeNode), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • isNodeRelated

        public boolean isNodeRelated(DefaultMutableTreeNode aNode)
        Returns true if and only if aNode is in the same tree as this node. Returns false if aNode is null.
        Returns:
        true if aNode is in the same tree as this node; false if aNode is null
        See Also:
        getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode), getRoot()

      • getDepth

        public int getDepth()
        Returns the depth of the tree rooted at this node -- the longest distance from this node to a leaf. If this node has no children, returns 0. This operation is much more expensive than getLevel() because it must effectively traverse the entire tree rooted at this node.
        Returns:
        the depth of the tree whose root is this node
        See Also:
        getLevel()

      • getLevel

        public int getLevel()
        Returns the number of levels above this node -- the distance from the root to this node. If this node is the root, returns 0.
        Returns:
        the number of levels above this node
        See Also:
        getDepth()

      • getPath

        public TreeNode[] getPath()
        Returns the path from the root, to get to this node. The last element in the path is this node.
        Returns:
        an array of TreeNode objects giving the path, where the first element in the path is the root and the last element is this node.

      • getPathToRoot

        protected TreeNode[] getPathToRoot(TreeNode aNode,
                                   int depth)
        Builds the parents of node up to and including the root node, where the original node is the last element in the returned array. The length of the returned array gives the node's depth in the tree.
        Parameters:
        aNode - the TreeNode to get the path for
        depth - an int giving the number of steps already taken towards the root (on recursive calls), used to size the returned array
        Returns:
        an array of TreeNodes giving the path from the root to the specified node

      • getUserObjectPath

        public Object[] getUserObjectPath()
        Returns the user object path, from the root, to get to this node. If some of the TreeNodes in the path have null user objects, the returned path will contain nulls.

      • getRoot

        public TreeNode getRoot()
        Returns the root of the tree that contains this node. The root is the ancestor with a null parent.
        Returns:
        the root of the tree that contains this node
        See Also:
        isNodeAncestor(javax.swing.tree.TreeNode)

      • isRoot

        public boolean isRoot()
        Returns true if this node is the root of the tree. The root is the only node in the tree with a null parent; every tree has exactly one root.
        Returns:
        true if this node is the root of its tree

      • getNextNode

        public DefaultMutableTreeNode getNextNode()
        Returns the node that follows this node in a preorder traversal of this node's tree. Returns null if this node is the last node of the traversal. This is an inefficient way to traverse the entire tree; use an enumeration, instead.
        Returns:
        the node that follows this node in a preorder traversal, or null if this node is last
        See Also:
        preorderEnumeration()

      • getPreviousNode

        public DefaultMutableTreeNode getPreviousNode()
        Returns the node that precedes this node in a preorder traversal of this node's tree. Returns null if this node is the first node of the traversal -- the root of the tree. This is an inefficient way to traverse the entire tree; use an enumeration, instead.
        Returns:
        the node that precedes this node in a preorder traversal, or null if this node is the first
        See Also:
        preorderEnumeration()

      • preorderEnumeration

        public Enumeration preorderEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in preorder. The first node returned by the enumeration's nextElement() method is this node.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        Returns:
        an enumeration for traversing the tree in preorder
        See Also:
        postorderEnumeration()

      • postorderEnumeration

        public Enumeration postorderEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in postorder. The first node returned by the enumeration's nextElement() method is the leftmost leaf. This is the same as a depth-first traversal.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        Returns:
        an enumeration for traversing the tree in postorder
        See Also:
        depthFirstEnumeration(), preorderEnumeration()

      • breadthFirstEnumeration

        public Enumeration breadthFirstEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in breadth-first order. The first node returned by the enumeration's nextElement() method is this node.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        Returns:
        an enumeration for traversing the tree in breadth-first order
        See Also:
        depthFirstEnumeration()

      • depthFirstEnumeration

        public Enumeration depthFirstEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in depth-first order. The first node returned by the enumeration's nextElement() method is the leftmost leaf. This is the same as a postorder traversal.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        Returns:
        an enumeration for traversing the tree in depth-first order
        See Also:
        breadthFirstEnumeration(), postorderEnumeration()

      • pathFromAncestorEnumeration

        public Enumeration pathFromAncestorEnumeration(TreeNode ancestor)
        Creates and returns an enumeration that follows the path from ancestor to this node. The enumeration's nextElement() method first returns ancestor, then the child of ancestor that is an ancestor of this node, and so on, and finally returns this node. Creation of the enumeration is O(m) where m is the number of nodes between this node and ancestor, inclusive. Each nextElement() message is O(1).

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        Returns:
        an enumeration for following the path from an ancestor of this node to this one
        Throws:
        IllegalArgumentException - if ancestor is not an ancestor of this node
        See Also:
        isNodeAncestor(javax.swing.tree.TreeNode), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • isNodeChild

        public boolean isNodeChild(TreeNode aNode)
        Returns true if aNode is a child of this node. If aNode is null, this method returns false.
        Returns:
        true if aNode is a child of this node; false if aNode is null

      • getFirstChild

        public TreeNode getFirstChild()
        Returns this node's first child. If this node has no children, throws NoSuchElementException.
        Returns:
        the first child of this node
        Throws:
        NoSuchElementException - if this node has no children

      • getLastChild

        public TreeNode getLastChild()
        Returns this node's last child. If this node has no children, throws NoSuchElementException.
        Returns:
        the last child of this node
        Throws:
        NoSuchElementException - if this node has no children

      • getChildAfter

        public TreeNode getChildAfter(TreeNode aChild)
        Returns the child in this node's child array that immediately follows aChild, which must be a child of this node. If aChild is the last child, returns null. This method performs a linear search of this node's children for aChild and is O(n) where n is the number of children; to traverse the entire array of children, use an enumeration instead.
        Returns:
        the child of this node that immediately follows aChild
        Throws:
        IllegalArgumentException - if aChild is null or is not a child of this node
        See Also:
        children

      • getChildBefore

        public TreeNode getChildBefore(TreeNode aChild)
        Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node. If aChild is the first child, returns null. This method performs a linear search of this node's children for aChild and is O(n) where n is the number of children.
        Returns:
        the child of this node that immediately precedes aChild
        Throws:
        IllegalArgumentException - if aChild is null or is not a child of this node

      • isNodeSibling

        public boolean isNodeSibling(TreeNode anotherNode)
        Returns true if anotherNode is a sibling of (has the same parent as) this node. A node is its own sibling. If anotherNode is null, returns false.
        Parameters:
        anotherNode - node to test as sibling of this node
        Returns:
        true if anotherNode is a sibling of this node

      • getSiblingCount

        public int getSiblingCount()
        Returns the number of siblings of this node. A node is its own sibling (if it has no parent or no siblings, this method returns 1).
        Returns:
        the number of siblings of this node

      • getNextSibling

        public DefaultMutableTreeNode getNextSibling()
        Returns the next sibling of this node in the parent's children array. Returns null if this node has no parent or is the parent's last child. This method performs a linear search that is O(n) where n is the number of children; to traverse the entire array, use the parent's child enumeration instead.
        Returns:
        the sibling of this node that immediately follows this node
        See Also:
        children

      • getPreviousSibling

        public DefaultMutableTreeNode getPreviousSibling()
        Returns the previous sibling of this node in the parent's children array. Returns null if this node has no parent or is the parent's first child. This method performs a linear search that is O(n) where n is the number of children.
        Returns:
        the sibling of this node that immediately precedes this node

      • isLeaf

        public boolean isLeaf()
        Returns true if this node has no children. To distinguish between nodes that have no children and nodes that cannot have children (e.g. to distinguish files from empty directories), use this method in conjunction with getAllowsChildren
        Specified by:
        isLeaf in interface TreeNode
        Returns:
        true if this node has no children
        See Also:
        getAllowsChildren()

      • getFirstLeaf

        public DefaultMutableTreeNode getFirstLeaf()
        Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf. Returns this node if it is a leaf.
        Returns:
        the first leaf in the subtree rooted at this node
        See Also:
        isLeaf(), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • getLastLeaf

        public DefaultMutableTreeNode getLastLeaf()
        Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf. Returns this node if it is a leaf.
        Returns:
        the last leaf in the subtree rooted at this node
        See Also:
        isLeaf(), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • getNextLeaf

        public DefaultMutableTreeNode getNextLeaf()
        Returns the leaf after this node or null if this node is the last leaf in the tree.

        In this implementation of the MutableNode interface, this operation is very inefficient. In order to determine the next node, this method first performs a linear search in the parent's child-list in order to find the current node.

        That implementation makes the operation suitable for short traversals from a known position. But to traverse all of the leaves in the tree, you should use depthFirstEnumeration to enumerate the nodes in the tree and use isLeaf on each node to determine which are leaves.

        Returns:
        returns the next leaf past this node
        See Also:
        depthFirstEnumeration(), isLeaf()

      • getPreviousLeaf

        public DefaultMutableTreeNode getPreviousLeaf()
        Returns the leaf before this node or null if this node is the first leaf in the tree.

        In this implementation of the MutableNode interface, this operation is very inefficient. In order to determine the previous node, this method first performs a linear search in the parent's child-list in order to find the current node.

        That implementation makes the operation suitable for short traversals from a known position. But to traverse all of the leaves in the tree, you should use depthFirstEnumeration to enumerate the nodes in the tree and use isLeaf on each node to determine which are leaves.

        Returns:
        returns the leaf before this node
        See Also:
        depthFirstEnumeration(), isLeaf()

      • getLeafCount

        public int getLeafCount()
        Returns the total number of leaves that are descendants of this node. If this node is a leaf, returns 1. This method is O(n) where n is the number of descendants of this node.
        Returns:
        the number of leaves beneath this node
        See Also:
        isNodeAncestor(javax.swing.tree.TreeNode)

      • toString

        public String toString()
        Returns the result of sending toString() to this node's user object, or the empty string if the node has no user object.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.
        See Also:
        getUserObject()

      • clone

        public Object clone()
        Overridden to make clone public. Returns a shallow copy of this node; the new node has no parent or children and has a reference to the same user object, if any.
        Overrides:
        clone in class Object
        Returns:
        a copy of this node
        See Also:
        Cloneable
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultTreeCellEditor.DefaultTextField (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultTreeCellEditor.DefaultTextField

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JTextField
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
  • All Implemented Interfaces:
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
    Enclosing class:
    DefaultTreeCellEditor

    public class DefaultTreeCellEditor.DefaultTextField
extends JTextField
    TextField used when no editor is supplied. This textfield locks into the border it is constructed with. It also prefers its parents font over its font. And if the renderer is not null and no font has been specified the preferred height is that of the renderer.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.JTextField

        JTextField.AccessibleJTextField

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Border border
      Border to use.

      • Fields inherited from class javax.swing.JTextField

        notifyAction

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultTextField(Border border)
      Constructs a DefaultTreeCellEditor.DefaultTextField object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Border getBorder()
      Overrides JComponent.getBorder to returns the current border.
      Font getFont()
      Gets the font of this component.
      Dimension getPreferredSize()
      Overrides JTextField.getPreferredSize to return the preferred size based on current font, if set, or else use renderer's font.
      void setBorder(Border border)
      Sets the border of this component.

      • Methods inherited from class javax.swing.JTextField

        actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAccessibleContext, getAction, getActionListeners, getActions, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getScrollOffset, getUIClassID, isValidateRoot, paramString, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setDocument, setFont, setHorizontalAlignment, setScrollOffset

      • Methods inherited from class javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write

      • Methods inherited from class javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, hide, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • border

        protected Border border
        Border to use.

    • Constructor Detail

      • DefaultTextField

        public DefaultTextField(Border border)
        Constructs a DefaultTreeCellEditor.DefaultTextField object.
        Parameters:
        border - a Border object
        Since:
        1.4

    • Method Detail

      • setBorder

        public void setBorder(Border border)
        Sets the border of this component.

        This is a bound property.

        Overrides:
        setBorder in class JComponent
        Parameters:
        border - the border to be rendered for this component
        See Also:
        Border, CompoundBorder

      • getBorder

        public Border getBorder()
        Overrides JComponent.getBorder to returns the current border.
        Overrides:
        getBorder in class JComponent
        Returns:
        the border object for this component
        See Also:
        JComponent.setBorder(javax.swing.border.Border)

      • getFont

        public Font getFont()
        Description copied from class: Component
        Gets the font of this component.
        Specified by:
        getFont in interface MenuContainer
        Overrides:
        getFont in class Component
        Returns:
        this component's font; if a font has not been set for this component, the font of its parent is returned
        See Also:
        Component.setFont(java.awt.Font)

      • getPreferredSize

        public Dimension getPreferredSize()
        Overrides JTextField.getPreferredSize to return the preferred size based on current font, if set, or else use renderer's font.
        Overrides:
        getPreferredSize in class JTextField
        Returns:
        a Dimension object containing the preferred size
        See Also:
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultTreeCellEditor.EditorContainer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultTreeCellEditor.EditorContainer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
  • All Implemented Interfaces:
    ImageObserver, MenuContainer, Serializable
    Enclosing class:
    DefaultTreeCellEditor

    public class DefaultTreeCellEditor.EditorContainer
extends Container
    Container responsible for placing the editingComponent.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • Constructor Summary

      Constructors
      Constructor and Description
      EditorContainer()
      Constructs an EditorContainer object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      void doLayout()
      Lays out this Container.
      void | EditorContainer()
      Dimension getPreferredSize()
      Returns the preferred size for the Container.
      void paint(Graphics g)
      Overrides Container.paint to paint the node's icon and use the selection color for the background.

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, revalidate, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EditorContainer

        public EditorContainer()
        Constructs an EditorContainer object.

    • Method Detail

      • EditorContainer

        public void EditorContainer()

      • paint

        public void paint(Graphics g)
        Overrides Container.paint to paint the node's icon and use the selection color for the background.
        Overrides:
        paint in class Container
        Parameters:
        g - the specified Graphics window
        See Also:
        Component.update(Graphics)

      • doLayout

        public void doLayout()
        Lays out this Container. If editing, the editor will be placed at offset in the x direction and 0 for y.
        Overrides:
        doLayout in class Container
        See Also:
        LayoutManager.layoutContainer(java.awt.Container),
Container.setLayout(java.awt.LayoutManager),
Container.validate()

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size for the Container. This will be at least preferred size of the editor plus offset.
        Overrides:
        getPreferredSize in class Container
        Returns:
        a Dimension containing the preferred size for the Container; if editingComponent is null the Dimension returned is 0, 0
        See Also:
        Container.getMinimumSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.preferredLayoutSize(Container),
Component.getPreferredSize()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultTreeCellEditor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultTreeCellEditor

  • java.lang.Object
    • javax.swing.tree.DefaultTreeCellEditor
  • All Implemented Interfaces:
    ActionListener, EventListener, CellEditor, TreeSelectionListener, TreeCellEditor

    public class DefaultTreeCellEditor
extends Object
implements ActionListener, TreeCellEditor, TreeSelectionListener
    A TreeCellEditor. You need to supply an instance of DefaultTreeCellRenderer so that the icons can be obtained. You can optionally supply a TreeCellEditor that will be layed out according to the icon in the DefaultTreeCellRenderer. If you do not supply a TreeCellEditor, a TextField will be used. Editing is started on a triple mouse click, or after a click, pause, click and a delay of 1200 milliseconds.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    See Also:
    JTree

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
      class  DefaultTreeCellEditor.EditorContainer
      Container responsible for placing the editingComponent.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Color borderSelectionColor
      True if the border selection color should be drawn.
      protected boolean canEdit
      As of Java 2 platform v1.4 this field should no longer be used.
      protected Component editingComponent
      Component used in editing, obtained from the editingContainer.
      protected Container editingContainer
      Editing container, will contain the editorComponent.
      protected Icon editingIcon
      Icon to use when editing.
      protected Font font
      Font to paint with, null indicates font of renderer is to be used.
      protected TreePath lastPath
      Last path that was selected.
      protected int lastRow
      Row that was last passed into getTreeCellEditorComponent.
      protected int offset
      Used in editing.
      protected TreeCellEditor realEditor
      Editor handling the editing.
      protected DefaultTreeCellRenderer renderer
      Renderer, used to get border and offsets from.
      protected Timer timer
      Used before starting the editing session.
      protected JTree tree
      JTree instance listening too.

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      void actionPerformed(ActionEvent e)
      Messaged when the timer fires, this will start the editing session.
      void addCellEditorListener(CellEditorListener l)
      Adds the CellEditorListener.
      void cancelCellEditing()
      Messages cancelCellEditing to the realEditor and removes it from this instance.
      protected boolean canEditImmediately(EventObject event)
      Returns true if event is null, or it is a MouseEvent with a click count > 2 and inHitRegion returns true.
      protected Container createContainer()
      Creates the container to manage placement of editingComponent.
      protected TreeCellEditor createTreeCellEditor()
      This is invoked if a TreeCellEditor is not supplied in the constructor.
      protected void | determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Color getBorderSelectionColor()
      Returns the color the border is drawn.
      CellEditorListener[] getCellEditorListeners()
      Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().
      Object getCellEditorValue()
      Returns the value currently being edited.
      Font getFont()
      Gets the font used for editing.
      Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Configures the editor.
      protected boolean inHitRegion(int x, int y)
      Returns true if the passed in location is a valid mouse location to start editing from.
      boolean isCellEditable(EventObject event)
      If the realEditor returns true to this message, prepareForEditing is messaged and true is returned.
      protected void prepareForEditing()
      Invoked just before editing is to start.
      void removeCellEditorListener(CellEditorListener l)
      Removes the previously added CellEditorListener.
      void setBorderSelectionColor(Color newColor)
      Sets the color to use for the border.
      void setFont(Font font)
      Sets the font to edit with.
      protected void setTree(JTree newTree)
      Sets the tree currently editing for.
      boolean shouldSelectCell(EventObject event)
      Messages the realEditor for the return value.
      protected boolean shouldStartEditingTimer(EventObject event)
      Returns true if event is a MouseEvent and the click count is 1.
      protected void startEditingTimer()
      Starts the editing timer.
      boolean stopCellEditing()
      If the realEditor will allow editing to stop, the realEditor is removed and true is returned, otherwise false is returned.
      void valueChanged(TreeSelectionEvent e)
      Resets lastPath.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • realEditor

        protected TreeCellEditor realEditor
        Editor handling the editing.

      • renderer

        protected DefaultTreeCellRenderer renderer
        Renderer, used to get border and offsets from.

      • editingContainer

        protected Container editingContainer
        Editing container, will contain the editorComponent.

      • editingComponent

        protected transient Component editingComponent
        Component used in editing, obtained from the editingContainer.

      • canEdit

        protected boolean canEdit
        As of Java 2 platform v1.4 this field should no longer be used. If you wish to provide similar behavior you should directly override isCellEditable.

      • offset

        protected transient int offset
        Used in editing. Indicates x position to place editingComponent.

      • tree

        protected transient JTree tree
        JTree instance listening too.

      • lastPath

        protected transient TreePath lastPath
        Last path that was selected.

      • timer

        protected transient Timer timer
        Used before starting the editing session.

      • lastRow

        protected transient int lastRow
        Row that was last passed into getTreeCellEditorComponent.

      • borderSelectionColor

        protected Color borderSelectionColor
        True if the border selection color should be drawn.

      • editingIcon

        protected transient Icon editingIcon
        Icon to use when editing.

      • font

        protected Font font
        Font to paint with, null indicates font of renderer is to be used.

    • Constructor Detail

      • DefaultTreeCellEditor

        public DefaultTreeCellEditor(JTree tree,
                             DefaultTreeCellRenderer renderer)
        Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor. (Use this constructor for normal editing.)
        Parameters:
        tree - a JTree object
        renderer - a DefaultTreeCellRenderer object

      • DefaultTreeCellEditor

        public DefaultTreeCellEditor(JTree tree,
                             DefaultTreeCellRenderer renderer,
                             TreeCellEditor editor)
        Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor. (Use this constructor for specialized editing.)
        Parameters:
        tree - a JTree object
        renderer - a DefaultTreeCellRenderer object
        editor - a TreeCellEditor object

    • Method Detail

      • setBorderSelectionColor

        public void setBorderSelectionColor(Color newColor)
        Sets the color to use for the border.
        Parameters:
        newColor - the new border color

      • getBorderSelectionColor

        public Color getBorderSelectionColor()
        Returns the color the border is drawn.
        Returns:
        the border selection color

      • setFont

        public void setFont(Font font)
        Sets the font to edit with. null indicates the renderers font should be used. This will NOT override any font you have set in the editor the receiver was instantiated with. If null for an editor was passed in a default editor will be created that will pick up this font.
        Parameters:
        font - the editing Font
        See Also:
        getFont()

      • getFont

        public Font getFont()
        Gets the font used for editing.
        Returns:
        the editing Font
        See Also:
        setFont(java.awt.Font)

      • getTreeCellEditorComponent

        public Component getTreeCellEditorComponent(JTree tree,
                                            Object value,
                                            boolean isSelected,
                                            boolean expanded,
                                            boolean leaf,
                                            int row)
        Configures the editor. Passed onto the realEditor.
        Specified by:
        getTreeCellEditorComponent in interface TreeCellEditor
        Parameters:
        tree - the JTree that is asking the editor to edit; this parameter can be null
        value - the value of the cell to be edited
        isSelected - true if the cell is to be rendered with selection highlighting
        expanded - true if the node is expanded
        leaf - true if the node is a leaf node
        row - the row index of the node being edited
        Returns:
        the component for editing

      • getCellEditorValue

        public Object getCellEditorValue()
        Returns the value currently being edited.
        Specified by:
        getCellEditorValue in interface CellEditor
        Returns:
        the value currently being edited

      • isCellEditable

        public boolean isCellEditable(EventObject event)
        If the realEditor returns true to this message, prepareForEditing is messaged and true is returned.
        Specified by:
        isCellEditable in interface CellEditor
        Parameters:
        event - the event the editor should use to consider whether to begin editing or not
        Returns:
        true if editing can be started
        See Also:
        CellEditor.shouldSelectCell(java.util.EventObject)

      • shouldSelectCell

        public boolean shouldSelectCell(EventObject event)
        Messages the realEditor for the return value.
        Specified by:
        shouldSelectCell in interface CellEditor
        Parameters:
        event - the event the editor should use to start editing
        Returns:
        true if the editor would like the editing cell to be selected; otherwise returns false
        See Also:
        CellEditor.isCellEditable(java.util.EventObject)

      • stopCellEditing

        public boolean stopCellEditing()
        If the realEditor will allow editing to stop, the realEditor is removed and true is returned, otherwise false is returned.
        Specified by:
        stopCellEditing in interface CellEditor
        Returns:
        true if editing was stopped; false otherwise

      • cancelCellEditing

        public void cancelCellEditing()
        Messages cancelCellEditing to the realEditor and removes it from this instance.
        Specified by:
        cancelCellEditing in interface CellEditor

      • addCellEditorListener

        public void addCellEditorListener(CellEditorListener l)
        Adds the CellEditorListener.
        Specified by:
        addCellEditorListener in interface CellEditor
        Parameters:
        l - the listener to be added

      • removeCellEditorListener

        public void removeCellEditorListener(CellEditorListener l)
        Removes the previously added CellEditorListener.
        Specified by:
        removeCellEditorListener in interface CellEditor
        Parameters:
        l - the listener to be removed

      • getCellEditorListeners

        public CellEditorListener[] getCellEditorListeners()
        Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().
        Returns:
        all of the CellEditorListeners added or an empty array if no listeners have been added
        Since:
        1.4

      • valueChanged

        public void valueChanged(TreeSelectionEvent e)
        Resets lastPath.
        Specified by:
        valueChanged in interface TreeSelectionListener
        Parameters:
        e - the event that characterizes the change.

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Messaged when the timer fires, this will start the editing session.
        Specified by:
        actionPerformed in interface ActionListener

      • setTree

        protected void setTree(JTree newTree)
        Sets the tree currently editing for. This is needed to add a selection listener.
        Parameters:
        newTree - the new tree to be edited

      • shouldStartEditingTimer

        protected boolean shouldStartEditingTimer(EventObject event)
        Returns true if event is a MouseEvent and the click count is 1.
        Parameters:
        event - the event being studied

      • startEditingTimer

        protected void startEditingTimer()
        Starts the editing timer.

      • canEditImmediately

        protected boolean canEditImmediately(EventObject event)
        Returns true if event is null, or it is a MouseEvent with a click count > 2 and inHitRegion returns true.
        Parameters:
        event - the event being studied

      • inHitRegion

        protected boolean inHitRegion(int x,
                              int y)
        Returns true if the passed in location is a valid mouse location to start editing from. This is implemented to return false if x is <= the width of the icon and icon gap displayed by the renderer. In other words this returns true if the user clicks over the text part displayed by the renderer, and false otherwise.
        Parameters:
        x - the x-coordinate of the point
        y - the y-coordinate of the point
        Returns:
        true if the passed in location is a valid mouse location

      • determineOffset

        protected void determineOffset(JTree tree,
                               Object value,
                               boolean isSelected,
                               boolean expanded,
                               boolean leaf,
                               int row)

      • prepareForEditing

        protected void prepareForEditing()
        Invoked just before editing is to start. Will add the editingComponent to the editingContainer.

      • createContainer

        protected Container createContainer()
        Creates the container to manage placement of editingComponent.

      • createTreeCellEditor

        protected TreeCellEditor createTreeCellEditor()
        This is invoked if a TreeCellEditor is not supplied in the constructor. It returns a TextField editor.
        Returns:
        a new TextField editor
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultTreeCellRenderer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultTreeCellRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.tree.DefaultTreeCellRenderer
  • All Implemented Interfaces:
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants, TreeCellRenderer

    public class DefaultTreeCellRenderer
extends JLabel
implements TreeCellRenderer
    Displays an entry in a tree. DefaultTreeCellRenderer is not opaque and unless you subclass paint you should not change this. See How to Use Trees in The Java Tutorial for examples of customizing node display using this class.

    The set of icons and colors used by DefaultTreeCellRenderer can be configured using the various setter methods. The value for each property is initialized from the defaults table. When the look and feel changes (updateUI is invoked), any properties that have a value of type UIResource are refreshed from the defaults table. The following table lists the mapping between DefaultTreeCellRenderer property and defaults table key:

    Property: Key:
    "leafIcon" | "Tree.leafIcon"
    "closedIcon" | "Tree.closedIcon"
    "openIcon" | "Tree.openIcon"
    "textSelectionColor" | "Tree.selectionForeground"
    "textNonSelectionColor" | "Tree.textForeground"
    "backgroundSelectionColor" | "Tree.selectionBackground"
    "backgroundNonSelectionColor" | "Tree.textBackground"
    "borderSelectionColor" | "Tree.selectionBorderColor"

    Implementation Note: This class overrides invalidate, validate, revalidate, repaint, and firePropertyChange solely to improve performance. If not overridden, these frequently called methods would execute code paths that are unnecessary for the default tree cell renderer. If you write your own renderer, take care to weigh the benefits and drawbacks of overriding these methods.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Color backgroundNonSelectionColor
      Color to use for the background when the node isn't selected.
      protected Color backgroundSelectionColor
      Color to use for the background when a node is selected.
      protected Color borderSelectionColor
      Color to use for the focus indicator when the node has focus.
      protected Icon closedIcon
      Icon used to show non-leaf nodes that aren't expanded.
      protected boolean hasFocus
      True if has focus.
      protected Icon leafIcon
      Icon used to show leaf nodes.
      protected Icon openIcon
      Icon used to show non-leaf nodes that are expanded.
      protected boolean selected
      Is the value currently selected.
      protected Color textNonSelectionColor
      Color to use for the foreground for non-selected nodes.
      protected Color textSelectionColor
      Color to use for the foreground for selected nodes.

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        accessibleContext, BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • Fields inherited from interface javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • Fields inherited from interface java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultTreeCellRenderer()
      Creates a DefaultTreeCellRenderer.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, byte oldValue, byte newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, char oldValue, char newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, double oldValue, double newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, float oldValue, float newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, int oldValue, int newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, long oldValue, long newValue)
      Overridden for performance reasons.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, short oldValue, short newValue)
      Overridden for performance reasons.
      Color getBackgroundNonSelectionColor()
      Returns the background color to be used for non selected nodes.
      Color getBackgroundSelectionColor()
      Returns the color to use for the background if node is selected.
      Color getBorderSelectionColor()
      Returns the color the border is drawn.
      Icon getClosedIcon()
      Returns the icon used to represent non-leaf nodes that are not expanded.
      Icon getDefaultClosedIcon()
      Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.
      Icon getDefaultLeafIcon()
      Returns the default icon, for the current laf, that is used to represent leaf nodes.
      Icon getDefaultOpenIcon()
      Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.
      Font getFont()
      Gets the font of this component.
      Icon getLeafIcon()
      Returns the icon used to represent leaf nodes.
      Icon getOpenIcon()
      Returns the icon used to represent non-leaf nodes that are expanded.
      Dimension getPreferredSize()
      Overrides JComponent.getPreferredSize to return slightly wider preferred size value.
      Color getTextNonSelectionColor()
      Returns the color the text is drawn with when the node isn't selected.
      Color getTextSelectionColor()
      Returns the color the text is drawn with when the node is selected.
      Component getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Configures the renderer based on the passed in components.
      void invalidate()
      Overridden for performance reasons.
      void paint(Graphics g)
      Paints the value.
      void repaint()
      Overridden for performance reasons.
      void repaint(long tm, int x, int y, int width, int height)
      Overridden for performance reasons.
      void repaint(Rectangle r)
      Overridden for performance reasons.
      void revalidate()
      Overridden for performance reasons.
      void setBackground(Color color)
      Subclassed to map ColorUIResources to null.
      void setBackgroundNonSelectionColor(Color newColor)
      Sets the background color to be used for non selected nodes.
      void setBackgroundSelectionColor(Color newColor)
      Sets the color to use for the background if node is selected.
      void setBorderSelectionColor(Color newColor)
      Sets the color to use for the border.
      void setClosedIcon(Icon newIcon)
      Sets the icon used to represent non-leaf nodes that are not expanded.
      void setFont(Font font)
      Subclassed to map FontUIResources to null.
      void setLeafIcon(Icon newIcon)
      Sets the icon used to represent leaf nodes.
      void setOpenIcon(Icon newIcon)
      Sets the icon used to represent non-leaf nodes that are expanded.
      void setTextNonSelectionColor(Color newColor)
      Sets the color the text is drawn with when the node isn't selected.
      void setTextSelectionColor(Color newColor)
      Sets the color the text is drawn with when the node is selected.
      void updateUI()
      Resets the UI property to a value from the current look and feel.
      void validate()
      Overridden for performance reasons.

      • Methods inherited from class javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • Methods inherited from class javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, hide, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • Methods inherited from class java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • Methods inherited from class java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • selected

        protected boolean selected
        Is the value currently selected.

      • hasFocus

        protected boolean hasFocus
        True if has focus.

      • closedIcon

        protected transient Icon closedIcon
        Icon used to show non-leaf nodes that aren't expanded.

      • leafIcon

        protected transient Icon leafIcon
        Icon used to show leaf nodes.

      • openIcon

        protected transient Icon openIcon
        Icon used to show non-leaf nodes that are expanded.

      • textSelectionColor

        protected Color textSelectionColor
        Color to use for the foreground for selected nodes.

      • textNonSelectionColor

        protected Color textNonSelectionColor
        Color to use for the foreground for non-selected nodes.

      • backgroundSelectionColor

        protected Color backgroundSelectionColor
        Color to use for the background when a node is selected.

      • backgroundNonSelectionColor

        protected Color backgroundNonSelectionColor
        Color to use for the background when the node isn't selected.

      • borderSelectionColor

        protected Color borderSelectionColor
        Color to use for the focus indicator when the node has focus.

    • Constructor Detail

      • DefaultTreeCellRenderer

        public DefaultTreeCellRenderer()
        Creates a DefaultTreeCellRenderer. Icons and text color are determined from the UIManager.

    • Method Detail

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        Overrides:
        updateUI in class JLabel
        Since:
        1.7
        See Also:
        JComponent.updateUI()

      • getDefaultOpenIcon

        public Icon getDefaultOpenIcon()
        Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.

      • getDefaultClosedIcon

        public Icon getDefaultClosedIcon()
        Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.

      • getDefaultLeafIcon

        public Icon getDefaultLeafIcon()
        Returns the default icon, for the current laf, that is used to represent leaf nodes.

      • setOpenIcon

        public void setOpenIcon(Icon newIcon)
        Sets the icon used to represent non-leaf nodes that are expanded.

      • getOpenIcon

        public Icon getOpenIcon()
        Returns the icon used to represent non-leaf nodes that are expanded.

      • setClosedIcon

        public void setClosedIcon(Icon newIcon)
        Sets the icon used to represent non-leaf nodes that are not expanded.

      • getClosedIcon

        public Icon getClosedIcon()
        Returns the icon used to represent non-leaf nodes that are not expanded.

      • setLeafIcon

        public void setLeafIcon(Icon newIcon)
        Sets the icon used to represent leaf nodes.

      • getLeafIcon

        public Icon getLeafIcon()
        Returns the icon used to represent leaf nodes.

      • setTextSelectionColor

        public void setTextSelectionColor(Color newColor)
        Sets the color the text is drawn with when the node is selected.

      • getTextSelectionColor

        public Color getTextSelectionColor()
        Returns the color the text is drawn with when the node is selected.

      • setTextNonSelectionColor

        public void setTextNonSelectionColor(Color newColor)
        Sets the color the text is drawn with when the node isn't selected.

      • getTextNonSelectionColor

        public Color getTextNonSelectionColor()
        Returns the color the text is drawn with when the node isn't selected.

      • setBackgroundSelectionColor

        public void setBackgroundSelectionColor(Color newColor)
        Sets the color to use for the background if node is selected.

      • getBackgroundSelectionColor

        public Color getBackgroundSelectionColor()
        Returns the color to use for the background if node is selected.

      • setBackgroundNonSelectionColor

        public void setBackgroundNonSelectionColor(Color newColor)
        Sets the background color to be used for non selected nodes.

      • getBackgroundNonSelectionColor

        public Color getBackgroundNonSelectionColor()
        Returns the background color to be used for non selected nodes.

      • setBorderSelectionColor

        public void setBorderSelectionColor(Color newColor)
        Sets the color to use for the border.

      • getBorderSelectionColor

        public Color getBorderSelectionColor()
        Returns the color the border is drawn.

      • setFont

        public void setFont(Font font)
        Subclassed to map FontUIResources to null. If font is null, or a FontUIResource, this has the effect of letting the font of the JTree show through. On the other hand, if font is non-null, and not a FontUIResource, the font becomes font.
        Overrides:
        setFont in class JComponent
        Parameters:
        font - the desired Font for this component
        See Also:
        Component.getFont()

      • getFont

        public Font getFont()
        Gets the font of this component.
        Specified by:
        getFont in interface MenuContainer
        Overrides:
        getFont in class Component
        Returns:
        this component's font; if a font has not been set for this component, the font of its parent is returned
        See Also:
        Component.setFont(java.awt.Font)

      • setBackground

        public void setBackground(Color color)
        Subclassed to map ColorUIResources to null. If color is null, or a ColorUIResource, this has the effect of letting the background color of the JTree show through. On the other hand, if color is non-null, and not a ColorUIResource, the background becomes color.
        Overrides:
        setBackground in class JComponent
        Parameters:
        color - the desired background Color
        See Also:
        Component.getBackground(), JComponent.setOpaque(boolean)

      • getTreeCellRendererComponent

        public Component getTreeCellRendererComponent(JTree tree,
                                              Object value,
                                              boolean sel,
                                              boolean expanded,
                                              boolean leaf,
                                              int row,
                                              boolean hasFocus)
        Configures the renderer based on the passed in components. The value is set from messaging the tree with convertValueToText, which ultimately invokes toString on value. The foreground color is set based on the selection and the icon is set based on the leaf and expanded parameters.
        Specified by:
        getTreeCellRendererComponent in interface TreeCellRenderer
        Returns:
        the Component that the renderer uses to draw the value

      • paint

        public void paint(Graphics g)
        Paints the value. The background is filled based on selected.
        Overrides:
        paint in class JComponent
        Parameters:
        g - the Graphics context in which to paint
        See Also:
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • getPreferredSize

        public Dimension getPreferredSize()
        Overrides JComponent.getPreferredSize to return slightly wider preferred size value.
        Overrides:
        getPreferredSize in class JComponent
        Returns:
        the value of the preferredSize property
        See Also:
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • validate

        public void validate()
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        validate in class Container
        See Also:
        Container.add(java.awt.Component),
Container.invalidate(),
Container.isValidateRoot(),
JComponent.revalidate(),
Container.validateTree()

      • invalidate

        public void invalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        invalidate in class Container
        Since:
        1.5
        See Also:
        Container.validate(), Container.layout(), LayoutManager2

      • revalidate

        public void revalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        revalidate in class JComponent
        See Also:
        Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

      • repaint

        public void repaint(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        repaint in class JComponent
        Parameters:
        tm - this parameter is not used
        x - the x value of the dirty region
        y - the y value of the dirty region
        width - the width of the dirty region
        height - the height of the dirty region
        See Also:
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint(Rectangle r)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        repaint in class JComponent
        Parameters:
        r - a Rectangle containing the dirty region
        See Also:
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint()
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        repaint in class Component
        Since:
        1.5
        See Also:
        Component.update(Graphics)

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class Component
        Parameters:
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               byte oldValue,
                               byte newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class Component
        Parameters:
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a byte)
        newValue - the new value of the property (as a byte)
        See Also:
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               char oldValue,
                               char newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class JComponent
        Parameters:
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a char)
        newValue - the new value of the property (as a char)
        See Also:
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               short oldValue,
                               short newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class Component
        Parameters:
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a short)
        newValue - the old value of the property (as a short)
        See Also:
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               int oldValue,
                               int newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class JComponent
        Parameters:
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               long oldValue,
                               long newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class Component
        Parameters:
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a long)
        newValue - the new value of the property (as a long)
        See Also:
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               float oldValue,
                               float newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class Component
        Parameters:
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a float)
        newValue - the new value of the property (as a float)
        See Also:
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               double oldValue,
                               double newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class Component
        Parameters:
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a double)
        newValue - the new value of the property (as a double)
        See Also:
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        Overrides:
        firePropertyChange in class JComponent
        Parameters:
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultTreeModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultTreeModel

  • java.lang.Object
    • javax.swing.tree.DefaultTreeModel
  • All Implemented Interfaces:
    Serializable, TreeModel

    public class DefaultTreeModel
extends Object
implements Serializable, TreeModel
    A simple tree data model that uses TreeNodes. For further information and examples that use DefaultTreeModel, see How to Use Trees in The Java Tutorial.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean asksAllowsChildren
      Determines how the isLeaf method figures out if a node is a leaf node.
      protected EventListenerList listenerList
      Listeners.
      protected TreeNode root
      Root of the tree.

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultTreeModel(TreeNode root)
      Creates a tree in which any node can have children.
      DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
      Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addTreeModelListener(TreeModelListener l)
      Adds a listener for the TreeModelEvent posted after the tree changes.
      boolean asksAllowsChildren()
      Tells how leaf nodes are determined.
      protected void fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      Object getChild(Object parent, int index)
      Returns the child of parent at index index in the parent's child array.
      int getChildCount(Object parent)
      Returns the number of children of parent.
      int getIndexOfChild(Object parent, Object child)
      Returns the index of child in parent.
      <T extends EventListener>
      T[]             		getListeners(Class<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      TreeNode[] getPathToRoot(TreeNode aNode)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      Object getRoot()
      Returns the root of the tree.
      TreeModelListener[] getTreeModelListeners()
      Returns an array of all the tree model listeners registered on this model.
      void insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index)
      Invoked this to insert newChild at location index in parents children.
      boolean isLeaf(Object node)
      Returns whether the specified node is a leaf node.
      void nodeChanged(TreeNode node)
      Invoke this method after you've changed how node is to be represented in the tree.
      void nodesChanged(TreeNode node, int[] childIndices)
      Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.
      void nodeStructureChanged(TreeNode node)
      Invoke this method if you've totally changed the children of node and its children's children...
      void nodesWereInserted(TreeNode node, int[] childIndices)
      Invoke this method after you've inserted some TreeNodes into node.
      void nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
      Invoke this method after you've removed some TreeNodes from node.
      void reload()
      Invoke this method if you've modified the TreeNodes upon which this model depends.
      void reload(TreeNode node)
      Invoke this method if you've modified the TreeNodes upon which this model depends.
      void removeNodeFromParent(MutableTreeNode node)
      Message this to remove node from its parent.
      void removeTreeModelListener(TreeModelListener l)
      Removes a listener previously added with addTreeModelListener().
      void setAsksAllowsChildren(boolean newValue)
      Sets whether or not to test leafness by asking getAllowsChildren() or isLeaf() to the TreeNodes.
      void setRoot(TreeNode root)
      Sets the root to root.
      void valueForPathChanged(TreePath path, Object newValue)
      This sets the user object of the TreeNode identified by path and posts a node changed.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • root

        protected TreeNode root
        Root of the tree.

      • listenerList

        protected EventListenerList listenerList
        Listeners.

      • asksAllowsChildren

        protected boolean asksAllowsChildren
        Determines how the isLeaf method figures out if a node is a leaf node. If true, a node is a leaf node if it does not allow children. (If it allows children, it is not a leaf node, even if no children are present.) That lets you distinguish between folder nodes and file nodes in a file system, for example.

        If this value is false, then any node which has no children is a leaf node, and any node may acquire children.

        See Also:
        TreeNode.getAllowsChildren(),
TreeModel.isLeaf(java.lang.Object),
setAsksAllowsChildren(boolean)

    • Constructor Detail

      • DefaultTreeModel

        @ConstructorProperties(value="root")
public DefaultTreeModel(TreeNode root)
        Creates a tree in which any node can have children.
        Parameters:
        root - a TreeNode object that is the root of the tree
        See Also:
        DefaultTreeModel(TreeNode, boolean)

      • DefaultTreeModel

        public DefaultTreeModel(TreeNode root,
                        boolean asksAllowsChildren)
        Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.
        Parameters:
        root - a TreeNode object that is the root of the tree
        asksAllowsChildren - a boolean, false if any node can have children, true if each node is asked to see if it can have children
        See Also:
        asksAllowsChildren

    • Method Detail

      • setAsksAllowsChildren

        public void setAsksAllowsChildren(boolean newValue)
        Sets whether or not to test leafness by asking getAllowsChildren() or isLeaf() to the TreeNodes. If newvalue is true, getAllowsChildren() is messaged, otherwise isLeaf() is messaged.

      • asksAllowsChildren

        public boolean asksAllowsChildren()
        Tells how leaf nodes are determined.
        Returns:
        true if only nodes which do not allow children are leaf nodes, false if nodes which have no children (even if allowed) are leaf nodes
        See Also:
        asksAllowsChildren

      • setRoot

        public void setRoot(TreeNode root)
        Sets the root to root. A null root implies the tree is to display nothing, and is legal.

      • getRoot

        public Object getRoot()
        Returns the root of the tree. Returns null only if the tree has no nodes.
        Specified by:
        getRoot in interface TreeModel
        Returns:
        the root of the tree

      • getIndexOfChild

        public int getIndexOfChild(Object parent,
                           Object child)
        Returns the index of child in parent. If either the parent or child is null, returns -1.
        Specified by:
        getIndexOfChild in interface TreeModel
        Parameters:
        parent - a note in the tree, obtained from this data source
        child - the node we are interested in
        Returns:
        the index of the child in the parent, or -1 if either the parent or the child is null

      • getChild

        public Object getChild(Object parent,
                       int index)
        Returns the child of parent at index index in the parent's child array. parent must be a node previously obtained from this data source. This should not return null if index is a valid index for parent (that is index >= 0 && index < getChildCount(parent)).
        Specified by:
        getChild in interface TreeModel
        Parameters:
        parent - a node in the tree, obtained from this data source
        Returns:
        the child of parent at index index

      • getChildCount

        public int getChildCount(Object parent)
        Returns the number of children of parent. Returns 0 if the node is a leaf or if it has no children. parent must be a node previously obtained from this data source.
        Specified by:
        getChildCount in interface TreeModel
        Parameters:
        parent - a node in the tree, obtained from this data source
        Returns:
        the number of children of the node parent

      • isLeaf

        public boolean isLeaf(Object node)
        Returns whether the specified node is a leaf node. The way the test is performed depends on the askAllowsChildren setting.
        Specified by:
        isLeaf in interface TreeModel
        Parameters:
        node - the node to check
        Returns:
        true if the node is a leaf node
        See Also:
        asksAllowsChildren, TreeModel.isLeaf(java.lang.Object)

      • reload

        public void reload()
        Invoke this method if you've modified the TreeNodes upon which this model depends. The model will notify all of its listeners that the model has changed.

      • valueForPathChanged

        public void valueForPathChanged(TreePath path,
                                Object newValue)
        This sets the user object of the TreeNode identified by path and posts a node changed. If you use custom user objects in the TreeModel you're going to need to subclass this and set the user object of the changed node to something meaningful.
        Specified by:
        valueForPathChanged in interface TreeModel
        Parameters:
        path - path to the node that the user has altered
        newValue - the new value from the TreeCellEditor

      • insertNodeInto

        public void insertNodeInto(MutableTreeNode newChild,
                           MutableTreeNode parent,
                           int index)
        Invoked this to insert newChild at location index in parents children. This will then message nodesWereInserted to create the appropriate event. This is the preferred way to add children as it will create the appropriate event.

      • removeNodeFromParent

        public void removeNodeFromParent(MutableTreeNode node)
        Message this to remove node from its parent. This will message nodesWereRemoved to create the appropriate event. This is the preferred way to remove a node as it handles the event creation for you.

      • nodeChanged

        public void nodeChanged(TreeNode node)
        Invoke this method after you've changed how node is to be represented in the tree.

      • reload

        public void reload(TreeNode node)
        Invoke this method if you've modified the TreeNodes upon which this model depends. The model will notify all of its listeners that the model has changed below the given node.
        Parameters:
        node - the node below which the model has changed

      • nodesWereInserted

        public void nodesWereInserted(TreeNode node,
                              int[] childIndices)
        Invoke this method after you've inserted some TreeNodes into node. childIndices should be the index of the new elements and must be sorted in ascending order.

      • nodesWereRemoved

        public void nodesWereRemoved(TreeNode node,
                             int[] childIndices,
                             Object[] removedChildren)
        Invoke this method after you've removed some TreeNodes from node. childIndices should be the index of the removed elements and must be sorted in ascending order. And removedChildren should be the array of the children objects that were removed.

      • nodesChanged

        public void nodesChanged(TreeNode node,
                         int[] childIndices)
        Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.

      • nodeStructureChanged

        public void nodeStructureChanged(TreeNode node)
        Invoke this method if you've totally changed the children of node and its children's children... This will post a treeStructureChanged event.

      • getPathToRoot

        public TreeNode[] getPathToRoot(TreeNode aNode)
        Builds the parents of node up to and including the root node, where the original node is the last element in the returned array. The length of the returned array gives the node's depth in the tree.
        Parameters:
        aNode - the TreeNode to get the path for

      • getPathToRoot

        protected TreeNode[] getPathToRoot(TreeNode aNode,
                                   int depth)
        Builds the parents of node up to and including the root node, where the original node is the last element in the returned array. The length of the returned array gives the node's depth in the tree.
        Parameters:
        aNode - the TreeNode to get the path for
        depth - an int giving the number of steps already taken towards the root (on recursive calls), used to size the returned array
        Returns:
        an array of TreeNodes giving the path from the root to the specified node

      • addTreeModelListener

        public void addTreeModelListener(TreeModelListener l)
        Adds a listener for the TreeModelEvent posted after the tree changes.
        Specified by:
        addTreeModelListener in interface TreeModel
        Parameters:
        l - the listener to add
        See Also:
        removeTreeModelListener(javax.swing.event.TreeModelListener)

      • removeTreeModelListener

        public void removeTreeModelListener(TreeModelListener l)
        Removes a listener previously added with addTreeModelListener().
        Specified by:
        removeTreeModelListener in interface TreeModel
        Parameters:
        l - the listener to remove
        See Also:
        addTreeModelListener(javax.swing.event.TreeModelListener)

      • getTreeModelListeners

        public TreeModelListener[] getTreeModelListeners()
        Returns an array of all the tree model listeners registered on this model.
        Returns:
        all of this model's TreeModelListeners or an empty array if no tree model listeners are currently registered
        Since:
        1.4
        See Also:
        addTreeModelListener(javax.swing.event.TreeModelListener), removeTreeModelListener(javax.swing.event.TreeModelListener)

      • fireTreeNodesChanged

        protected void fireTreeNodesChanged(Object source,
                                    Object[] path,
                                    int[] childIndices,
                                    Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        Parameters:
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent of the nodes that changed; use null to identify the root has changed
        childIndices - the indices of the changed elements
        children - the changed elements

      • fireTreeNodesInserted

        protected void fireTreeNodesInserted(Object source,
                                     Object[] path,
                                     int[] childIndices,
                                     Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        Parameters:
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent the nodes were added to
        childIndices - the indices of the new elements
        children - the new elements

      • fireTreeNodesRemoved

        protected void fireTreeNodesRemoved(Object source,
                                    Object[] path,
                                    int[] childIndices,
                                    Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        Parameters:
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent the nodes were removed from
        childIndices - the indices of the removed elements
        children - the removed elements

      • fireTreeStructureChanged

        protected void fireTreeStructureChanged(Object source,
                                        Object[] path,
                                        int[] childIndices,
                                        Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        Parameters:
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent of the structure that has changed; use null to identify the root has changed
        childIndices - the indices of the affected elements
        children - the affected elements

      • getListeners

        public <T extends EventListener> T[] getListeners(Class<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultTreeModel m for its tree model listeners with the following code:

        TreeModelListener[] tmls = (TreeModelListener[])(m.getListeners(TreeModelListener.class));
        If no such listeners exist, this method returns an empty array.
        Parameters:
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        Returns:
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        Throws:
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        Since:
        1.3
        See Also:
        getTreeModelListeners()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultTreeSelectionModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class DefaultTreeSelectionModel

  • java.lang.Object
    • javax.swing.tree.DefaultTreeSelectionModel
  • All Implemented Interfaces:
    Serializable, Cloneable, TreeSelectionModel
    Direct Known Subclasses:
    JTree.EmptySelectionModel

    public class DefaultTreeSelectionModel
extends Object
implements Cloneable, Serializable, TreeSelectionModel
    Default implementation of TreeSelectionModel. Listeners are notified whenever the paths in the selection change, not the rows. In order to be able to track row changes you may wish to become a listener for expansion events on the tree and test for changes from there.

    resetRowSelection is called from any of the methods that update the selected paths. If you subclass any of these methods to filter what is allowed to be selected, be sure and message resetRowSelection if you do not message super. Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    See Also:
    JTree

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected SwingPropertyChangeSupport changeSupport
      Used to messaged registered listeners.
      protected int leadIndex
      Index of the lead path in selection.
      protected TreePath leadPath
      Last path that was added.
      protected int leadRow
      Lead row.
      protected EventListenerList listenerList
      Event listener list.
      protected DefaultListSelectionModel listSelectionModel
      Handles maintaining the list selection model.
      protected RowMapper rowMapper
      Provides a row for a given path.
      protected TreePath[] selection
      Paths that are currently selected.
      static String SELECTION_MODE_PROPERTY
      Property name for selectionMode.
      protected int selectionMode
      Mode for the selection, will be either SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

      • Fields inherited from interface javax.swing.tree.TreeSelectionModel

        CONTIGUOUS_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION, SINGLE_TREE_SELECTION

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultTreeSelectionModel()
      Creates a new instance of DefaultTreeSelectionModel that is empty, with a selection mode of DISCONTIGUOUS_TREE_SELECTION.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      void addSelectionPath(TreePath path)
      Adds path to the current selection.
      void addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      void addTreeSelectionListener(TreeSelectionListener x)
      Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
      protected boolean arePathsContiguous(TreePath[] paths)
      Returns true if the paths are contiguous, or this object has no RowMapper.
      protected boolean canPathsBeAdded(TreePath[] paths)
      Used to test if a particular set of TreePaths can be added.
      protected boolean canPathsBeRemoved(TreePath[] paths)
      Returns true if the paths can be removed without breaking the continuity of the model.
      void clearSelection()
      Empties the current selection.
      Object clone()
      Returns a clone of this object with the same selection.
      protected void fireValueChanged(TreeSelectionEvent e)
      Notifies all listeners that are registered for tree selection events on this object.
      TreePath getLeadSelectionPath()
      Returns the last path that was added.
      int getLeadSelectionRow()
      Returns the lead selection index.
      <T extends EventListener>
      T[]             		getListeners(Class<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      int getMaxSelectionRow()
      Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.
      int getMinSelectionRow()
      Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the property change listeners registered on this DefaultTreeSelectionModel.
      RowMapper getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      int getSelectionCount()
      Returns the number of paths that are selected.
      int getSelectionMode()
      Returns the selection mode, one of SINGLE_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION or CONTIGUOUS_TREE_SELECTION.
      TreePath getSelectionPath()
      Returns the first path in the selection.
      TreePath[] getSelectionPaths()
      Returns the selection.
      int[] getSelectionRows()
      Returns the selection in terms of rows.
      TreeSelectionListener[] getTreeSelectionListeners()
      Returns an array of all the tree selection listeners registered on this model.
      protected void insureRowContinuity()
      Makes sure the currently selected TreePaths are valid for the current selection mode.
      protected void insureUniqueness()
      This method is obsolete and its implementation is now a noop.
      boolean isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      boolean isRowSelected(int row)
      Returns true if the row identified by row is selected.
      boolean isSelectionEmpty()
      Returns true if the selection is currently empty.
      protected void notifyPathChange(Vector<?> changedPaths, TreePath oldLeadSelection)
      Deprecated.
      As of JDK version 1.7
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void removeSelectionPath(TreePath path)
      Removes path from the selection.
      void removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void removeTreeSelectionListener(TreeSelectionListener x)
      Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
      void resetRowSelection()
      Updates this object's mapping from TreePath to rows.
      void setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
      void setSelectionMode(int mode)
      Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.
      void setSelectionPath(TreePath path)
      Sets the selection to path.
      void setSelectionPaths(TreePath[] pPaths)
      Sets the selection.
      String toString()
      Returns a string that displays and identifies this object's properties.
      protected void updateLeadIndex()
      Updates the leadIndex instance variable.

      • Methods inherited from class java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • SELECTION_MODE_PROPERTY

        public static final String SELECTION_MODE_PROPERTY
        Property name for selectionMode.
        See Also:
        Constant Field Values

      • changeSupport

        protected SwingPropertyChangeSupport changeSupport
        Used to messaged registered listeners.

      • selection

        protected TreePath[] selection
        Paths that are currently selected. Will be null if nothing is currently selected.

      • listenerList

        protected EventListenerList listenerList
        Event listener list.

      • rowMapper

        protected transient RowMapper rowMapper
        Provides a row for a given path.

      • listSelectionModel

        protected DefaultListSelectionModel listSelectionModel
        Handles maintaining the list selection model. The RowMapper is used to map from a TreePath to a row, and the value is then placed here.

      • selectionMode

        protected int selectionMode
        Mode for the selection, will be either SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

      • leadPath

        protected TreePath leadPath
        Last path that was added.

      • leadIndex

        protected int leadIndex
        Index of the lead path in selection.

      • leadRow

        protected int leadRow
        Lead row.

    • Constructor Detail

      • DefaultTreeSelectionModel

        public DefaultTreeSelectionModel()
        Creates a new instance of DefaultTreeSelectionModel that is empty, with a selection mode of DISCONTIGUOUS_TREE_SELECTION.

    • Method Detail

      • setRowMapper

        public void setRowMapper(RowMapper newMapper)
        Sets the RowMapper instance. This instance is used to determine the row for a particular TreePath.
        Specified by:
        setRowMapper in interface TreeSelectionModel

      • getRowMapper

        public RowMapper getRowMapper()
        Returns the RowMapper instance that is able to map a TreePath to a row.
        Specified by:
        getRowMapper in interface TreeSelectionModel

      • setSelectionMode

        public void setSelectionMode(int mode)
        Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION. If mode is not one of the defined value, DISCONTIGUOUS_TREE_SELECTION is assumed.

        This may change the selection if the current selection is not valid for the new mode. For example, if three TreePaths are selected when the mode is changed to SINGLE_TREE_SELECTION, only one TreePath will remain selected. It is up to the particular implementation to decide what TreePath remains selected.

        Setting the mode to something other than the defined types will result in the mode becoming DISCONTIGUOUS_TREE_SELECTION.

        Specified by:
        setSelectionMode in interface TreeSelectionModel

      • getSelectionMode

        public int getSelectionMode()
        Returns the selection mode, one of SINGLE_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION or CONTIGUOUS_TREE_SELECTION.
        Specified by:
        getSelectionMode in interface TreeSelectionModel

      • setSelectionPath

        public void setSelectionPath(TreePath path)
        Sets the selection to path. If this represents a change, then the TreeSelectionListeners are notified. If path is null, this has the same effect as invoking clearSelection.
        Specified by:
        setSelectionPath in interface TreeSelectionModel
        Parameters:
        path - new path to select

      • setSelectionPaths

        public void setSelectionPaths(TreePath[] pPaths)
        Sets the selection. Whether the supplied paths are taken as the new selection depends upon the selection mode. If the supplied array is null, or empty, the selection is cleared. If the selection mode is SINGLE_TREE_SELECTION, only the first path in pPaths is used. If the selection mode is CONTIGUOUS_TREE_SELECTION and the supplied paths are not contiguous, then only the first path in pPaths is used. If the selection mode is DISCONTIGUOUS_TREE_SELECTION, then all paths are used.

        All null paths in pPaths are ignored.

        If this represents a change, all registered TreeSelectionListeners are notified.

        The lead path is set to the last unique path.

        The paths returned from getSelectionPaths are in the same order as those supplied to this method.

        Specified by:
        setSelectionPaths in interface TreeSelectionModel
        Parameters:
        pPaths - the new selection

      • addSelectionPath

        public void addSelectionPath(TreePath path)
        Adds path to the current selection. If path is not currently in the selection the TreeSelectionListeners are notified. This has no effect if path is null.
        Specified by:
        addSelectionPath in interface TreeSelectionModel
        Parameters:
        path - the new path to add to the current selection

      • addSelectionPaths

        public void addSelectionPaths(TreePath[] paths)
        Adds paths to the current selection. If any of the paths in paths are not currently in the selection the TreeSelectionListeners are notified. This has no effect if paths is null.

        The lead path is set to the last element in paths.

        If the selection mode is CONTIGUOUS_TREE_SELECTION, and adding the new paths would make the selection discontiguous. Then two things can result: if the TreePaths in paths are contiguous, then the selection becomes these TreePaths, otherwise the TreePaths aren't contiguous and the selection becomes the first TreePath in paths.

        Specified by:
        addSelectionPaths in interface TreeSelectionModel
        Parameters:
        paths - the new path to add to the current selection

      • removeSelectionPath

        public void removeSelectionPath(TreePath path)
        Removes path from the selection. If path is in the selection The TreeSelectionListeners are notified. This has no effect if path is null.
        Specified by:
        removeSelectionPath in interface TreeSelectionModel
        Parameters:
        path - the path to remove from the selection

      • removeSelectionPaths

        public void removeSelectionPaths(TreePath[] paths)
        Removes paths from the selection. If any of the paths in paths are in the selection the TreeSelectionListeners are notified. This has no effect if paths is null.
        Specified by:
        removeSelectionPaths in interface TreeSelectionModel
        Parameters:
        paths - the paths to remove from the selection

      • getSelectionPath

        public TreePath getSelectionPath()
        Returns the first path in the selection. This is useful if there if only one item currently selected.
        Specified by:
        getSelectionPath in interface TreeSelectionModel

      • getSelectionPaths

        public TreePath[] getSelectionPaths()
        Returns the selection.
        Specified by:
        getSelectionPaths in interface TreeSelectionModel
        Returns:
        the selection

      • getSelectionCount

        public int getSelectionCount()
        Returns the number of paths that are selected.
        Specified by:
        getSelectionCount in interface TreeSelectionModel

      • isPathSelected

        public boolean isPathSelected(TreePath path)
        Returns true if the path, path, is in the current selection.
        Specified by:
        isPathSelected in interface TreeSelectionModel

      • isSelectionEmpty

        public boolean isSelectionEmpty()
        Returns true if the selection is currently empty.
        Specified by:
        isSelectionEmpty in interface TreeSelectionModel

      • clearSelection

        public void clearSelection()
        Empties the current selection. If this represents a change in the current selection, the selection listeners are notified.
        Specified by:
        clearSelection in interface TreeSelectionModel

      • addTreeSelectionListener

        public void addTreeSelectionListener(TreeSelectionListener x)
        Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
        Specified by:
        addTreeSelectionListener in interface TreeSelectionModel
        Parameters:
        x - the new listener to be added

      • removeTreeSelectionListener

        public void removeTreeSelectionListener(TreeSelectionListener x)
        Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
        Specified by:
        removeTreeSelectionListener in interface TreeSelectionModel
        Parameters:
        x - the listener to remove

      • getTreeSelectionListeners

        public TreeSelectionListener[] getTreeSelectionListeners()
        Returns an array of all the tree selection listeners registered on this model.
        Returns:
        all of this model's TreeSelectionListeners or an empty array if no tree selection listeners are currently registered
        Since:
        1.4
        See Also:
        addTreeSelectionListener(javax.swing.event.TreeSelectionListener), removeTreeSelectionListener(javax.swing.event.TreeSelectionListener)

      • fireValueChanged

        protected void fireValueChanged(TreeSelectionEvent e)
        Notifies all listeners that are registered for tree selection events on this object.
        See Also:
        addTreeSelectionListener(javax.swing.event.TreeSelectionListener), EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(Class<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultTreeSelectionModel m for its tree selection listeners with the following code:

        TreeSelectionListener[] tsls = (TreeSelectionListener[])(m.getListeners(TreeSelectionListener.class));
        If no such listeners exist, this method returns an empty array.
        Parameters:
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        Returns:
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        Throws:
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        Since:
        1.3
        See Also:
        getTreeSelectionListeners(), getPropertyChangeListeners()

      • getSelectionRows

        public int[] getSelectionRows()
        Returns the selection in terms of rows. There is not necessarily a one-to-one mapping between the TreePaths returned from getSelectionPaths and this method. In particular, if a TreePath is not viewable (the RowMapper returns -1 for the row corresponding to the TreePath), then the corresponding row is not included in the returned array. For example, if the selection consists of two paths, A and B, with A at row 10, and B not currently viewable, then this method returns an array with the single entry 10.
        Specified by:
        getSelectionRows in interface TreeSelectionModel
        Returns:
        the selection in terms of rows

      • getMinSelectionRow

        public int getMinSelectionRow()
        Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.
        Specified by:
        getMinSelectionRow in interface TreeSelectionModel

      • getMaxSelectionRow

        public int getMaxSelectionRow()
        Returns the largest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.
        Specified by:
        getMaxSelectionRow in interface TreeSelectionModel

      • isRowSelected

        public boolean isRowSelected(int row)
        Returns true if the row identified by row is selected.
        Specified by:
        isRowSelected in interface TreeSelectionModel

      • resetRowSelection

        public void resetRowSelection()
        Updates this object's mapping from TreePath to rows. This should be invoked when the mapping from TreePaths to integers has changed (for example, a node has been expanded).

        You do not normally have to call this, JTree and its associated Listeners will invoke this for you. If you are implementing your own View class, then you will have to invoke this.

        This will invoke insureRowContinuity to make sure the currently selected TreePaths are still valid based on the selection mode.

        Specified by:
        resetRowSelection in interface TreeSelectionModel

      • getLeadSelectionRow

        public int getLeadSelectionRow()
        Returns the lead selection index. That is the last index that was added.
        Specified by:
        getLeadSelectionRow in interface TreeSelectionModel

      • getLeadSelectionPath

        public TreePath getLeadSelectionPath()
        Returns the last path that was added. This may differ from the leadSelectionPath property maintained by the JTree.
        Specified by:
        getLeadSelectionPath in interface TreeSelectionModel

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired when the selection mode changes.

        Specified by:
        addPropertyChangeListener in interface TreeSelectionModel
        Parameters:
        listener - the PropertyChangeListener to be added

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        Specified by:
        removePropertyChangeListener in interface TreeSelectionModel
        Parameters:
        listener - the PropertyChangeListener to be removed

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the property change listeners registered on this DefaultTreeSelectionModel.
        Returns:
        all of this model's PropertyChangeListeners or an empty array if no property change listeners are currently registered
        Since:
        1.4
        See Also:
        addPropertyChangeListener(java.beans.PropertyChangeListener), removePropertyChangeListener(java.beans.PropertyChangeListener)

      • insureRowContinuity

        protected void insureRowContinuity()
        Makes sure the currently selected TreePaths are valid for the current selection mode. If the selection mode is CONTIGUOUS_TREE_SELECTION and a RowMapper exists, this will make sure all the rows are contiguous, that is, when sorted all the rows are in order with no gaps. If the selection isn't contiguous, the selection is reset to contain the first set, when sorted, of contiguous rows.

        If the selection mode is SINGLE_TREE_SELECTION and more than one TreePath is selected, the selection is reset to contain the first path currently selected.

      • arePathsContiguous

        protected boolean arePathsContiguous(TreePath[] paths)
        Returns true if the paths are contiguous, or this object has no RowMapper.

      • canPathsBeAdded

        protected boolean canPathsBeAdded(TreePath[] paths)
        Used to test if a particular set of TreePaths can be added. This will return true if paths is null (or empty), or this object has no RowMapper, or nothing is currently selected, or the selection mode is DISCONTIGUOUS_TREE_SELECTION, or adding the paths to the current selection still results in a contiguous set of TreePaths.

      • canPathsBeRemoved

        protected boolean canPathsBeRemoved(TreePath[] paths)
        Returns true if the paths can be removed without breaking the continuity of the model. This is rather expensive.

      • notifyPathChange

        @Deprecated
protected void notifyPathChange(Vector<?> changedPaths,
                                            TreePath oldLeadSelection)
        Deprecated. As of JDK version 1.7
        Notifies listeners of a change in path. changePaths should contain instances of PathPlaceHolder.

      • updateLeadIndex

        protected void updateLeadIndex()
        Updates the leadIndex instance variable.

      • insureUniqueness

        protected void insureUniqueness()
        This method is obsolete and its implementation is now a noop. It's still called by setSelectionPaths and addSelectionPaths, but only for backwards compatibility.

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        Overrides:
        toString in class Object
        Returns:
        a String representation of this object

      • clone

        public Object clone()
             throws CloneNotSupportedException
        Returns a clone of this object with the same selection. This method does not duplicate selection listeners and property listeners.
        Overrides:
        clone in class Object
        Returns:
        a clone of this instance.
        Throws:
        CloneNotSupportedException - never thrown by instances of this class
        See Also:
        Cloneable
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ExpandVetoException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class ExpandVetoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.swing.tree.ExpandVetoException
  • All Implemented Interfaces:
    Serializable

    public class ExpandVetoException
extends Exception
    Exception used to stop and expand/collapse from happening. See How to Write a Tree-Will-Expand Listener in The Java Tutorial for further information and examples.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected TreeExpansionEvent event
      The event that the exception was created for.

    • Constructor Summary

      Constructors
      Constructor and Description
      ExpandVetoException(TreeExpansionEvent event)
      Constructs an ExpandVetoException object with no message.
      ExpandVetoException(TreeExpansionEvent event, String message)
      Constructs an ExpandVetoException object with the specified message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • event

        protected TreeExpansionEvent event
        The event that the exception was created for.

    • Constructor Detail

      • ExpandVetoException

        public ExpandVetoException(TreeExpansionEvent event)
        Constructs an ExpandVetoException object with no message.
        Parameters:
        event - a TreeExpansionEvent object

      • ExpandVetoException

        public ExpandVetoException(TreeExpansionEvent event,
                           String message)
        Constructs an ExpandVetoException object with the specified message.
        Parameters:
        event - a TreeExpansionEvent object
        message - a String containing the message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FixedHeightLayoutCache (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class FixedHeightLayoutCache

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache
      • javax.swing.tree.FixedHeightLayoutCache
  • All Implemented Interfaces:
    RowMapper

    public class FixedHeightLayoutCache
extends AbstractLayoutCache
    NOTE: This will become more open in a future release.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.tree.AbstractLayoutCache

        AbstractLayoutCache.NodeDimensions

    • Field Summary

      • Fields inherited from class javax.swing.tree.AbstractLayoutCache

        nodeDimensions, rootVisible, rowHeight, treeModel, treeSelectionModel

    • Constructor Summary

      Constructors
      Constructor and Description
      FixedHeightLayoutCache()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Rectangle getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      boolean getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      TreePath getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath getPathForRow(int row)
      Returns the path for passed in row.
      int getRowCount()
      Returns the number of visible rows.
      int getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      int getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      void invalidatePathBounds(TreePath path)
      Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
      void invalidateSizes()
      Informs the TreeState that it needs to recalculate all the sizes it is referencing.
      boolean isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      void setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell.
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • Methods inherited from class javax.swing.tree.AbstractLayoutCache

        getModel, getNodeDimensions, getNodeDimensions, getPreferredHeight, getPreferredWidth, getRowHeight, getRowsForPaths, getSelectionModel, isFixedRowHeight, isRootVisible, setNodeDimensions, setSelectionModel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FixedHeightLayoutCache

        public FixedHeightLayoutCache()

    • Method Detail

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.
        Overrides:
        setModel in class AbstractLayoutCache
        Parameters:
        newModel - the TreeModel that is to provide the data

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.
        Overrides:
        setRootVisible in class AbstractLayoutCache
        Parameters:
        rootVisible - true if the root node of the tree is to be displayed
        See Also:
        AbstractLayoutCache.rootVisible

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell. If rowHeight is less than or equal to 0 this will throw an IllegalArgumentException.
        Overrides:
        setRowHeight in class AbstractLayoutCache
        Parameters:
        rowHeight - the height of each cell, in pixels

      • getRowCount

        public int getRowCount()
        Returns the number of visible rows.
        Specified by:
        getRowCount in class AbstractLayoutCache
        Returns:
        the number of rows being displayed

      • invalidatePathBounds

        public void invalidatePathBounds(TreePath path)
        Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
        Specified by:
        invalidatePathBounds in class AbstractLayoutCache
        Parameters:
        path - the path being updated

      • invalidateSizes

        public void invalidateSizes()
        Informs the TreeState that it needs to recalculate all the sizes it is referencing.
        Specified by:
        invalidateSizes in class AbstractLayoutCache

      • isExpanded

        public boolean isExpanded(TreePath path)
        Returns true if the value identified by row is currently expanded.
        Specified by:
        isExpanded in class AbstractLayoutCache

      • getBounds

        public Rectangle getBounds(TreePath path,
                           Rectangle placeIn)
        Returns a rectangle giving the bounds needed to draw path.
        Specified by:
        getBounds in class AbstractLayoutCache
        Parameters:
        path - a TreePath specifying a node
        placeIn - a Rectangle object giving the available space
        Returns:
        a Rectangle object specifying the space to be used

      • getPathForRow

        public TreePath getPathForRow(int row)
        Returns the path for passed in row. If row is not visible null is returned.
        Specified by:
        getPathForRow in class AbstractLayoutCache
        Parameters:
        row - the row being queried
        Returns:
        the TreePath for the given row

      • getRowForPath

        public int getRowForPath(TreePath path)
        Returns the row that the last item identified in path is visible at. Will return -1 if any of the elements in path are not currently visible.
        Specified by:
        getRowForPath in class AbstractLayoutCache
        Parameters:
        path - the TreePath being queried
        Returns:
        the row where the last item in path is visible or -1 if any elements in path aren't currently visible

      • getPathClosestTo

        public TreePath getPathClosestTo(int x,
                                 int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it'll always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        Specified by:
        getPathClosestTo in class AbstractLayoutCache
        Parameters:
        x - the horizontal component of the desired location
        y - the vertical component of the desired location
        Returns:
        the TreePath closest to the specified point

      • getVisibleChildCount

        public int getVisibleChildCount(TreePath path)
        Returns the number of visible children for row.
        Specified by:
        getVisibleChildCount in class AbstractLayoutCache
        Parameters:
        path - the path being queried
        Returns:
        the number of visible children for the specified path

      • getVisiblePathsFrom

        public Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
        Returns an Enumerator that increments over the visible paths starting at the passed in location. The ordering of the enumeration is based on how the paths are displayed.
        Specified by:
        getVisiblePathsFrom in class AbstractLayoutCache
        Parameters:
        path - the starting location for the enumeration
        Returns:
        the Enumerator starting at the desired location

      • setExpandedState

        public void setExpandedState(TreePath path,
                             boolean isExpanded)
        Marks the path path expanded state to isExpanded.
        Specified by:
        setExpandedState in class AbstractLayoutCache
        Parameters:
        path - the path being expanded or collapsed
        isExpanded - true if the path should be expanded, false otherwise

      • getExpandedState

        public boolean getExpandedState(TreePath path)
        Returns true if the path is expanded, and visible.
        Specified by:
        getExpandedState in class AbstractLayoutCache
        Parameters:
        path - the path being queried
        Returns:
        true if the path is expanded and visible, false otherwise

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        e.path() returns the path the parent of the changed node(s).

        e.childIndices() returns the index(es) of the changed node(s).

        Specified by:
        treeNodesChanged in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)

        Invoked after nodes have been inserted into the tree.

        e.path() returns the parent of the new nodes

        e.childIndices() returns the indices of the new nodes in ascending order.

        Specified by:
        treeNodesInserted in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        e.path() returns the former parent of the deleted nodes.

        e.childIndices() returns the indices the nodes had before they were deleted in ascending order.

        Specified by:
        treeNodesRemoved in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        e.path() holds the path to the node.

        e.childIndices() returns null.

        Specified by:
        treeStructureChanged in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MutableTreeNode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface MutableTreeNode

  • All Superinterfaces:
    TreeNode
    All Known Implementing Classes:
    DefaultMutableTreeNode, JTree.DynamicUtilTreeNode

    public interface MutableTreeNode
extends TreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    See Also:
    DefaultMutableTreeNode, JTree

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void insert(MutableTreeNode child, int index)
      Adds child to the receiver at index.
      void remove(int index)
      Removes the child at index from the receiver.
      void remove(MutableTreeNode node)
      Removes node from the receiver.
      void removeFromParent()
      Removes the receiver from its parent.
      void setParent(MutableTreeNode newParent)
      Sets the parent of the receiver to newParent.
      void setUserObject(Object object)
      Resets the user object of the receiver to object.

      • Methods inherited from interface javax.swing.tree.TreeNode

        children, getAllowsChildren, getChildAt, getChildCount, getIndex, getParent, isLeaf

    • Method Detail

      • insert

        void insert(MutableTreeNode child,
            int index)
        Adds child to the receiver at index. child will be messaged with setParent.

      • remove

        void remove(int index)
        Removes the child at index from the receiver.

      • remove

        void remove(MutableTreeNode node)
        Removes node from the receiver. setParent will be messaged on node.

      • setUserObject

        void setUserObject(Object object)
        Resets the user object of the receiver to object.

      • removeFromParent

        void removeFromParent()
        Removes the receiver from its parent.

      • setParent

        void setParent(MutableTreeNode newParent)
        Sets the parent of the receiver to newParent.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.tree (Java Platform SE 8 )

javax.swing.tree

Interfaces

  • MutableTreeNode
  • RowMapper
  • TreeCellEditor
  • TreeCellRenderer
  • TreeModel
  • TreeNode
  • TreeSelectionModel

Classes

  • AbstractLayoutCache
  • AbstractLayoutCache.NodeDimensions
  • DefaultMutableTreeNode
  • DefaultTreeCellEditor
  • DefaultTreeCellRenderer
  • DefaultTreeModel
  • DefaultTreeSelectionModel
  • FixedHeightLayoutCache
  • TreePath
  • VariableHeightLayoutCache

Exceptions

  • ExpandVetoException


javax.swing.tree (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.swing.tree

Provides classes and interfaces for dealing with javax.swing.JTree.

See: Description

  • Interface Summary
    Interface Description
    MutableTreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • Class Summary
    Class Description
    AbstractLayoutCache
    Warning: Serialized objects of this class will not be compatible with future Swing releases.
    AbstractLayoutCache.NodeDimensions
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.
    DefaultMutableTreeNode
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
    DefaultTreeCellEditor
    A TreeCellEditor.
    DefaultTreeCellRenderer
    Displays an entry in a tree.
    DefaultTreeModel
    A simple tree data model that uses TreeNodes.
    DefaultTreeSelectionModel
    Default implementation of TreeSelectionModel.
    FixedHeightLayoutCache
    NOTE: This will become more open in a future release.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    VariableHeightLayoutCache
    NOTE: This will become more open in a future release.
  • Exception Summary
    Exception Description
    ExpandVetoException
    Exception used to stop and expand/collapse from happening.

Package javax.swing.tree Description

Provides classes and interfaces for dealing with javax.swing.JTree. You use these classes and interfaces if you want control over how trees are constructed, updated, and rendered, as well as how data associated with the tree nodes are viewed and managed.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • How to Use Trees, a section in The Java Tutorial
Since:
1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.tree Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.swing.tree

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache (implements javax.swing.tree.RowMapper)
      • javax.swing.tree.FixedHeightLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.tree.DefaultTreeCellRenderer (implements javax.swing.tree.TreeCellRenderer)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
    • javax.swing.tree.DefaultTreeCellEditor (implements java.awt.event.ActionListener, javax.swing.tree.TreeCellEditor, javax.swing.event.TreeSelectionListener)
    • javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.tree.ExpandVetoException
    • javax.swing.tree.TreePath (implements java.io.Serializable)

Interface Hierarchy

  • javax.swing.CellEditor
    • javax.swing.tree.TreeCellEditor
  • javax.swing.tree.RowMapper
  • javax.swing.tree.TreeCellRenderer
  • javax.swing.tree.TreeModel
  • javax.swing.tree.TreeNode
    • javax.swing.tree.MutableTreeNode
  • javax.swing.tree.TreeSelectionModel
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.swing.tree (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.swing.tree

  • Packages that use javax.swing.tree
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.
  • Classes in javax.swing.tree used by javax.swing
    Class and Description
    DefaultMutableTreeNode
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
    DefaultTreeSelectionModel
    Default implementation of TreeSelectionModel.
    ExpandVetoException
    Exception used to stop and expand/collapse from happening.
    MutableTreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • Classes in javax.swing.tree used by javax.swing.event
    Class and Description
    ExpandVetoException
    Exception used to stop and expand/collapse from happening.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf
    Class and Description
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf.basic
    Class and Description
    AbstractLayoutCache
    Warning: Serialized objects of this class will not be compatible with future Swing releases.
    AbstractLayoutCache.NodeDimensions
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • Classes in javax.swing.tree used by javax.swing.plaf.metal
    Class and Description
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf.multi
    Class and Description
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf.synth
    Class and Description
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.text
    Class and Description
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
  • Classes in javax.swing.tree used by javax.swing.text.html
    Class and Description
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
  • Classes in javax.swing.tree used by javax.swing.tree
    Class and Description
    AbstractLayoutCache
    Warning: Serialized objects of this class will not be compatible with future Swing releases.
    AbstractLayoutCache.NodeDimensions
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.
    DefaultMutableTreeNode
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
    DefaultTreeCellRenderer
    Displays an entry in a tree.
    MutableTreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RowMapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface RowMapper

  • All Known Implementing Classes:
    AbstractLayoutCache, FixedHeightLayoutCache, VariableHeightLayoutCache

    public interface RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int[] getRowsForPaths(TreePath[] path)
      Returns the rows that the TreePath instances in path are being displayed at.

    • Method Detail

      • getRowsForPaths

        int[] getRowsForPaths(TreePath[] path)
        Returns the rows that the TreePath instances in path are being displayed at. The receiver should return an array of the same length as that passed in, and if one of the TreePaths in path is not valid its entry in the array should be set to -1.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TreeCellEditor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface TreeCellEditor

  • All Superinterfaces:
    CellEditor
    All Known Implementing Classes:
    DefaultCellEditor, DefaultTreeCellEditor

    public interface TreeCellEditor
extends CellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    See Also:
    JTree

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Sets an initial value for the editor.

      • Methods inherited from interface javax.swing.CellEditor

        addCellEditorListener, cancelCellEditing, getCellEditorValue, isCellEditable, removeCellEditorListener, shouldSelectCell, stopCellEditing

    • Method Detail

      • getTreeCellEditorComponent

        Component getTreeCellEditorComponent(JTree tree,
                                     Object value,
                                     boolean isSelected,
                                     boolean expanded,
                                     boolean leaf,
                                     int row)
        Sets an initial value for the editor. This will cause the editor to stopEditing and lose any partially edited value if the editor is editing when this method is called.

        Returns the component that should be added to the client's Component hierarchy. Once installed in the client's hierarchy this component will then be able to draw and receive user input.

        Parameters:
        tree - the JTree that is asking the editor to edit; this parameter can be null
        value - the value of the cell to be edited
        isSelected - true if the cell is to be rendered with selection highlighting
        expanded - true if the node is expanded
        leaf - true if the node is a leaf node
        row - the row index of the node being edited
        Returns:
        the component for editing
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TreeCellRenderer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface TreeCellRenderer

  • All Known Implementing Classes:
    DefaultTreeCellRenderer

    public interface TreeCellRenderer
    Defines the requirements for an object that displays a tree node. See How to Use Trees in The Java Tutorial for an example of implementing a tree cell renderer that displays custom icons.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Component getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Sets the value of the current tree cell to value.

    • Method Detail

      • getTreeCellRendererComponent

        Component getTreeCellRendererComponent(JTree tree,
                                       Object value,
                                       boolean selected,
                                       boolean expanded,
                                       boolean leaf,
                                       int row,
                                       boolean hasFocus)
        Sets the value of the current tree cell to value. If selected is true, the cell will be drawn as if selected. If expanded is true the node is currently expanded and if leaf is true the node represents a leaf and if hasFocus is true the node currently has focus. tree is the JTree the receiver is being configured for. Returns the Component that the renderer uses to draw the value.

        The TreeCellRenderer is also responsible for rendering the the cell representing the tree's current DnD drop location if it has one. If this renderer cares about rendering the DnD drop location, it should query the tree directly to see if the given row represents the drop location:

             JTree.DropLocation dropLocation = tree.getDropLocation();
     if (dropLocation != null
             && dropLocation.getChildIndex() == -1
             && tree.getRowForPath(dropLocation.getPath()) == row) {

         // this row represents the current drop location
         // so render it specially, perhaps with a different color
     }
        Returns:
        the Component that the renderer uses to draw the value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TreeModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface TreeModel

  • All Known Implementing Classes:
    DefaultTreeModel

    public interface TreeModel
    The model used by JTree.

    JTree and its related classes make extensive use of TreePaths for identifying nodes in the TreeModel. If a TreeModel returns the same object, as compared by equals, at two different indices under the same parent than the resulting TreePath objects will be considered equal as well. Some implementations may assume that if two TreePaths are equal, they identify the same node. If this condition is not met, painting problems and other oddities may result. In other words, if getChild for a given parent returns the same Object (as determined by equals) problems may result, and it is recommended you avoid doing this.

    Similarly JTree and its related classes place TreePaths in Maps. As such if a node is requested twice, the return values must be equal (using the equals method) and have the same hashCode.

    For further information on tree models, including an example of a custom implementation, see How to Use Trees in The Java Tutorial.

    See Also:
    TreePath

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void addTreeModelListener(TreeModelListener l)
      Adds a listener for the TreeModelEvent posted after the tree changes.
      Object getChild(Object parent, int index)
      Returns the child of parent at index index in the parent's child array.
      int getChildCount(Object parent)
      Returns the number of children of parent.
      int getIndexOfChild(Object parent, Object child)
      Returns the index of child in parent.
      Object getRoot()
      Returns the root of the tree.
      boolean isLeaf(Object node)
      Returns true if node is a leaf.
      void removeTreeModelListener(TreeModelListener l)
      Removes a listener previously added with addTreeModelListener.
      void valueForPathChanged(TreePath path, Object newValue)
      Messaged when the user has altered the value for the item identified by path to newValue.

    • Method Detail

      • getRoot

        Object getRoot()
        Returns the root of the tree. Returns null only if the tree has no nodes.
        Returns:
        the root of the tree

      • getChild

        Object getChild(Object parent,
                int index)
        Returns the child of parent at index index in the parent's child array. parent must be a node previously obtained from this data source. This should not return null if index is a valid index for parent (that is index >= 0 && index < getChildCount(parent)).
        Parameters:
        parent - a node in the tree, obtained from this data source
        Returns:
        the child of parent at index index

      • getChildCount

        int getChildCount(Object parent)
        Returns the number of children of parent. Returns 0 if the node is a leaf or if it has no children. parent must be a node previously obtained from this data source.
        Parameters:
        parent - a node in the tree, obtained from this data source
        Returns:
        the number of children of the node parent

      • isLeaf

        boolean isLeaf(Object node)
        Returns true if node is a leaf. It is possible for this method to return false even if node has no children. A directory in a filesystem, for example, may contain no files; the node representing the directory is not a leaf, but it also has no children.
        Parameters:
        node - a node in the tree, obtained from this data source
        Returns:
        true if node is a leaf

      • valueForPathChanged

        void valueForPathChanged(TreePath path,
                         Object newValue)
        Messaged when the user has altered the value for the item identified by path to newValue. If newValue signifies a truly new value the model should post a treeNodesChanged event.
        Parameters:
        path - path to the node that the user has altered
        newValue - the new value from the TreeCellEditor

      • getIndexOfChild

        int getIndexOfChild(Object parent,
                    Object child)
        Returns the index of child in parent. If either parent or child is null, returns -1. If either parent or child don't belong to this tree model, returns -1.
        Parameters:
        parent - a node in the tree, obtained from this data source
        child - the node we are interested in
        Returns:
        the index of the child in the parent, or -1 if either child or parent are null or don't belong to this tree model

      • addTreeModelListener

        void addTreeModelListener(TreeModelListener l)
        Adds a listener for the TreeModelEvent posted after the tree changes.
        Parameters:
        l - the listener to add
        See Also:
        removeTreeModelListener(javax.swing.event.TreeModelListener)

      • removeTreeModelListener

        void removeTreeModelListener(TreeModelListener l)
        Removes a listener previously added with addTreeModelListener.
        Parameters:
        l - the listener to remove
        See Also:
        addTreeModelListener(javax.swing.event.TreeModelListener)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TreeNode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface TreeNode

  • All Known Subinterfaces:
    MutableTreeNode
    All Known Implementing Classes:
    AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultMutableTreeNode, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, JTree.DynamicUtilTreeNode

    public interface TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.

    Implementations of TreeNode that override equals will typically need to override hashCode as well. Refer to TreeModel for more information. For further information and examples of using tree nodes, see How to Use Tree Nodes in The Java Tutorial.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Enumeration children()
      Returns the children of the receiver as an Enumeration.
      boolean getAllowsChildren()
      Returns true if the receiver allows children.
      TreeNode getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      int getChildCount()
      Returns the number of children TreeNodes the receiver contains.
      int getIndex(TreeNode node)
      Returns the index of node in the receivers children.
      TreeNode getParent()
      Returns the parent TreeNode of the receiver.
      boolean isLeaf()
      Returns true if the receiver is a leaf.

    • Method Detail

      • getChildAt

        TreeNode getChildAt(int childIndex)
        Returns the child TreeNode at index childIndex.

      • getChildCount

        int getChildCount()
        Returns the number of children TreeNodes the receiver contains.

      • getParent

        TreeNode getParent()
        Returns the parent TreeNode of the receiver.

      • getIndex

        int getIndex(TreeNode node)
        Returns the index of node in the receivers children. If the receiver does not contain node, -1 will be returned.

      • getAllowsChildren

        boolean getAllowsChildren()
        Returns true if the receiver allows children.

      • isLeaf

        boolean isLeaf()
        Returns true if the receiver is a leaf.

      • children

        Enumeration children()
        Returns the children of the receiver as an Enumeration.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TreePath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class TreePath

  • java.lang.Object
    • javax.swing.tree.TreePath
  • All Implemented Interfaces:
    Serializable

    public class TreePath
extends Object
implements Serializable
    TreePath represents an array of objects that uniquely identify the path to a node in a tree. The elements of the array are ordered with the root as the first element of the array. For example, a file on the file system is uniquely identified based on the array of parent directories and the name of the file. The path /tmp/foo/bar could be represented by a TreePath as new TreePath(new Object[] {"tmp", "foo", "bar"}).

    TreePath is used extensively by JTree and related classes. For example, JTree represents the selection as an array of TreePaths. When used with JTree, the elements of the path are the objects returned from the TreeModel. When JTree is paired with DefaultTreeModel, the elements of the path are TreeNodes. The following example illustrates extracting the user object from the selection of a JTree:

       DefaultMutableTreeNode root = ...;
   DefaultTreeModel model = new DefaultTreeModel(root);
   JTree tree = new JTree(model);
   ...
   TreePath selectedPath = tree.getSelectionPath();
   DefaultMutableTreeNode selectedNode =
       ((DefaultMutableTreeNode)selectedPath.getLastPathComponent()).
       getUserObject();
    Subclasses typically need override only getLastPathComponent, and getParentPath. As JTree internally creates TreePaths at various points, it's generally not useful to subclass TreePath and use with JTree.

    While TreePath is serializable, a NotSerializableException is thrown if any elements of the path are not serializable.

    For further information and examples of using tree paths, see How to Use Trees in The Java Tutorial.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected TreePath()
      Creates an empty TreePath.
        TreePath(Object lastPathComponent)
      Creates a TreePath containing a single element.
        TreePath(Object[] path)
      Creates a TreePath from an array.
      protected TreePath(Object[] path, int length)
      Creates a TreePath from an array.
      protected TreePath(TreePath parent, Object lastPathComponent)
      Creates a TreePath with the specified parent and element.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean equals(Object o)
      Compares this TreePath to the specified object.
      Object getLastPathComponent()
      Returns the last element of this path.
      TreePath getParentPath()
      Returns the TreePath of the parent.
      Object[] getPath()
      Returns an ordered array of the elements of this TreePath.
      Object getPathComponent(int index)
      Returns the path element at the specified index.
      int getPathCount()
      Returns the number of elements in the path.
      int hashCode()
      Returns the hash code of this TreePath.
      boolean isDescendant(TreePath aTreePath)
      Returns true if aTreePath is a descendant of this TreePath.
      TreePath pathByAddingChild(Object child)
      Returns a new path containing all the elements of this path plus child.
      String toString()
      Returns a string that displays and identifies this object's properties.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TreePath

        @ConstructorProperties(value="path")
public TreePath(Object[] path)
        Creates a TreePath from an array. The array uniquely identifies the path to a node.
        Parameters:
        path - an array of objects representing the path to a node
        Throws:
        IllegalArgumentException - if path is null, empty, or contains a null value

      • TreePath

        public TreePath(Object lastPathComponent)
        Creates a TreePath containing a single element. This is used to construct a TreePath identifying the root.
        Parameters:
        lastPathComponent - the root
        Throws:
        IllegalArgumentException - if lastPathComponent is null
        See Also:
        TreePath(Object[])

      • TreePath

        protected TreePath(TreePath parent,
                   Object lastPathComponent)
        Creates a TreePath with the specified parent and element.
        Parameters:
        parent - the path to the parent, or null to indicate the root
        lastPathComponent - the last path element
        Throws:
        IllegalArgumentException - if lastPathComponent is null

      • TreePath

        protected TreePath(Object[] path,
                   int length)
        Creates a TreePath from an array. The returned TreePath represents the elements of the array from 0 to length - 1.

        This constructor is used internally, and generally not useful outside of subclasses.

        Parameters:
        path - the array to create the TreePath from
        length - identifies the number of elements in path to create the TreePath from
        Throws:
        NullPointerException - if path is null
        ArrayIndexOutOfBoundsException - if length - 1 is outside the range of the array
        IllegalArgumentException - if any of the elements from 0 to length - 1 are null

      • TreePath

        protected TreePath()
        Creates an empty TreePath. This is provided for subclasses that represent paths in a different manner. Subclasses that use this constructor must override getLastPathComponent, and getParentPath.

    • Method Detail

      • getPath

        public Object[] getPath()
        Returns an ordered array of the elements of this TreePath. The first element is the root.
        Returns:
        an array of the elements in this TreePath

      • getLastPathComponent

        public Object getLastPathComponent()
        Returns the last element of this path.
        Returns:
        the last element in the path

      • getPathCount

        public int getPathCount()
        Returns the number of elements in the path.
        Returns:
        the number of elements in the path

      • getPathComponent

        public Object getPathComponent(int index)
        Returns the path element at the specified index.
        Parameters:
        index - the index of the element requested
        Returns:
        the element at the specified index
        Throws:
        IllegalArgumentException - if the index is outside the range of this path

      • equals

        public boolean equals(Object o)
        Compares this TreePath to the specified object. This returns true if o is a TreePath with the exact same elements (as determined by using equals on each element of the path).
        Overrides:
        equals in class Object
        Parameters:
        o - the object to compare
        Returns:
        true if this object is the same as the obj argument; false otherwise.
        See Also:
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code of this TreePath. The hash code of a TreePath is the hash code of the last element in the path.
        Overrides:
        hashCode in class Object
        Returns:
        the hashCode for the object
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • isDescendant

        public boolean isDescendant(TreePath aTreePath)
        Returns true if aTreePath is a descendant of this TreePath. A TreePath P1 is a descendant of a TreePath P2 if P1 contains all of the elements that make up P2's path. For example, if this object has the path [a, b], and aTreePath has the path [a, b, c], then aTreePath is a descendant of this object. However, if aTreePath has the path [a], then it is not a descendant of this object. By this definition a TreePath is always considered a descendant of itself. That is, aTreePath.isDescendant(aTreePath) returns true.
        Parameters:
        aTreePath - the TreePath to check
        Returns:
        true if aTreePath is a descendant of this path

      • pathByAddingChild

        public TreePath pathByAddingChild(Object child)
        Returns a new path containing all the elements of this path plus child. child is the last element of the newly created TreePath.
        Parameters:
        child - the path element to add
        Throws:
        NullPointerException - if child is null

      • getParentPath

        public TreePath getParentPath()
        Returns the TreePath of the parent. A return value of null indicates this is the root node.
        Returns:
        the parent path

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        Overrides:
        toString in class Object
        Returns:
        a String representation of this object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TreeSelectionModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Interface TreeSelectionModel

  • All Known Implementing Classes:
    DefaultTreeSelectionModel, JTree.EmptySelectionModel

    public interface TreeSelectionModel
    This interface represents the current state of the selection for the tree component. For information and examples of using tree selection models, see How to Use Trees in The Java Tutorial.

    The state of the tree selection is characterized by a set of TreePaths, and optionally a set of integers. The mapping from TreePath to integer is done by way of an instance of RowMapper. It is not necessary for a TreeSelectionModel to have a RowMapper to correctly operate, but without a RowMapper getSelectionRows will return null.

    A TreeSelectionModel can be configured to allow only one path (SINGLE_TREE_SELECTION) a number of contiguous paths (CONTIGUOUS_TREE_SELECTION) or a number of discontiguous paths (DISCONTIGUOUS_TREE_SELECTION). A RowMapper is used to determine if TreePaths are contiguous. In the absence of a RowMapper CONTIGUOUS_TREE_SELECTION and DISCONTIGUOUS_TREE_SELECTION behave the same, that is they allow any number of paths to be contained in the TreeSelectionModel.

    For a selection model of CONTIGUOUS_TREE_SELECTION any time the paths are changed (setSelectionPath, addSelectionPath ...) the TreePaths are again checked to make they are contiguous. A check of the TreePaths can also be forced by invoking resetRowSelection. How a set of discontiguous TreePaths is mapped to a contiguous set is left to implementors of this interface to enforce a particular policy.

    Implementations should combine duplicate TreePaths that are added to the selection. For example, the following code

       TreePath[] paths = new TreePath[] { treePath, treePath };
   treeSelectionModel.setSelectionPaths(paths);
    should result in only one path being selected: treePath, and not two copies of treePath.

    The lead TreePath is the last path that was added (or set). The lead row is then the row that corresponds to the TreePath as determined from the RowMapper.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int CONTIGUOUS_TREE_SELECTION
      Selection can only be contiguous.
      static int DISCONTIGUOUS_TREE_SELECTION
      Selection can contain any number of items that are not necessarily contiguous.
      static int SINGLE_TREE_SELECTION
      Selection can only contain one path at a time.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      void addSelectionPath(TreePath path)
      Adds path to the current selection.
      void addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      void addTreeSelectionListener(TreeSelectionListener x)
      Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
      void clearSelection()
      Empties the current selection.
      TreePath getLeadSelectionPath()
      Returns the last path that was added.
      int getLeadSelectionRow()
      Returns the lead selection index.
      int getMaxSelectionRow()
      Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.
      int getMinSelectionRow()
      Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.
      RowMapper getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      int getSelectionCount()
      Returns the number of paths that are selected.
      int getSelectionMode()
      Returns the current selection mode, one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.
      TreePath getSelectionPath()
      Returns the first path in the selection.
      TreePath[] getSelectionPaths()
      Returns the paths in the selection.
      int[] getSelectionRows()
      Returns all of the currently selected rows.
      boolean isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      boolean isRowSelected(int row)
      Returns true if the row identified by row is selected.
      boolean isSelectionEmpty()
      Returns true if the selection is currently empty.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void removeSelectionPath(TreePath path)
      Removes path from the selection.
      void removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void removeTreeSelectionListener(TreeSelectionListener x)
      Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
      void resetRowSelection()
      Updates this object's mapping from TreePaths to rows.
      void setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
      void setSelectionMode(int mode)
      Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.
      void setSelectionPath(TreePath path)
      Sets the selection to path.
      void setSelectionPaths(TreePath[] paths)
      Sets the selection to path.

    • Field Detail

      • SINGLE_TREE_SELECTION

        static final int SINGLE_TREE_SELECTION
        Selection can only contain one path at a time.
        See Also:
        Constant Field Values

      • CONTIGUOUS_TREE_SELECTION

        static final int CONTIGUOUS_TREE_SELECTION
        Selection can only be contiguous. This will only be enforced if a RowMapper instance is provided. That is, if no RowMapper is set this behaves the same as DISCONTIGUOUS_TREE_SELECTION.
        See Also:
        Constant Field Values

      • DISCONTIGUOUS_TREE_SELECTION

        static final int DISCONTIGUOUS_TREE_SELECTION
        Selection can contain any number of items that are not necessarily contiguous.
        See Also:
        Constant Field Values

    • Method Detail

      • setSelectionMode

        void setSelectionMode(int mode)
        Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

        This may change the selection if the current selection is not valid for the new mode. For example, if three TreePaths are selected when the mode is changed to SINGLE_TREE_SELECTION, only one TreePath will remain selected. It is up to the particular implementation to decide what TreePath remains selected.

      • getSelectionMode

        int getSelectionMode()
        Returns the current selection mode, one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

      • setSelectionPath

        void setSelectionPath(TreePath path)
        Sets the selection to path. If this represents a change, then the TreeSelectionListeners are notified. If path is null, this has the same effect as invoking clearSelection.
        Parameters:
        path - new path to select

      • setSelectionPaths

        void setSelectionPaths(TreePath[] paths)
        Sets the selection to path. If this represents a change, then the TreeSelectionListeners are notified. If paths is null, this has the same effect as invoking clearSelection.
        Parameters:
        paths - new selection

      • addSelectionPath

        void addSelectionPath(TreePath path)
        Adds path to the current selection. If path is not currently in the selection the TreeSelectionListeners are notified. This has no effect if path is null.
        Parameters:
        path - the new path to add to the current selection

      • addSelectionPaths

        void addSelectionPaths(TreePath[] paths)
        Adds paths to the current selection. If any of the paths in paths are not currently in the selection the TreeSelectionListeners are notified. This has no effect if paths is null.
        Parameters:
        paths - the new paths to add to the current selection

      • removeSelectionPath

        void removeSelectionPath(TreePath path)
        Removes path from the selection. If path is in the selection The TreeSelectionListeners are notified. This has no effect if path is null.
        Parameters:
        path - the path to remove from the selection

      • removeSelectionPaths

        void removeSelectionPaths(TreePath[] paths)
        Removes paths from the selection. If any of the paths in paths are in the selection, the TreeSelectionListeners are notified. This method has no effect if paths is null.
        Parameters:
        paths - the path to remove from the selection

      • getSelectionPath

        TreePath getSelectionPath()
        Returns the first path in the selection. How first is defined is up to implementors, and may not necessarily be the TreePath with the smallest integer value as determined from the RowMapper.

      • getSelectionPaths

        TreePath[] getSelectionPaths()
        Returns the paths in the selection. This will return null (or an empty array) if nothing is currently selected.

      • getSelectionCount

        int getSelectionCount()
        Returns the number of paths that are selected.

      • isPathSelected

        boolean isPathSelected(TreePath path)
        Returns true if the path, path, is in the current selection.

      • isSelectionEmpty

        boolean isSelectionEmpty()
        Returns true if the selection is currently empty.

      • clearSelection

        void clearSelection()
        Empties the current selection. If this represents a change in the current selection, the selection listeners are notified.

      • setRowMapper

        void setRowMapper(RowMapper newMapper)
        Sets the RowMapper instance. This instance is used to determine the row for a particular TreePath.

      • getRowMapper

        RowMapper getRowMapper()
        Returns the RowMapper instance that is able to map a TreePath to a row.

      • getSelectionRows

        int[] getSelectionRows()
        Returns all of the currently selected rows. This will return null (or an empty array) if there are no selected TreePaths or a RowMapper has not been set.

      • getMinSelectionRow

        int getMinSelectionRow()
        Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.

      • getMaxSelectionRow

        int getMaxSelectionRow()
        Returns the largest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.

      • isRowSelected

        boolean isRowSelected(int row)
        Returns true if the row identified by row is selected.

      • resetRowSelection

        void resetRowSelection()
        Updates this object's mapping from TreePaths to rows. This should be invoked when the mapping from TreePaths to integers has changed (for example, a node has been expanded).

        You do not normally have to call this; JTree and its associated listeners will invoke this for you. If you are implementing your own view class, then you will have to invoke this.

      • getLeadSelectionRow

        int getLeadSelectionRow()
        Returns the lead selection index. That is the last index that was added.

      • getLeadSelectionPath

        TreePath getLeadSelectionPath()
        Returns the last path that was added. This may differ from the leadSelectionPath property maintained by the JTree.

      • addPropertyChangeListener

        void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired when the selection mode changes.

        Parameters:
        listener - the PropertyChangeListener to be added

      • removePropertyChangeListener

        void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        Parameters:
        listener - the PropertyChangeListener to be removed

      • addTreeSelectionListener

        void addTreeSelectionListener(TreeSelectionListener x)
        Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
        Parameters:
        x - the new listener to be added

      • removeTreeSelectionListener

        void removeTreeSelectionListener(TreeSelectionListener x)
        Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
        Parameters:
        x - the listener to remove
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VariableHeightLayoutCache (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.tree

Class VariableHeightLayoutCache

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
  • All Implemented Interfaces:
    RowMapper

    public class VariableHeightLayoutCache
extends AbstractLayoutCache
    NOTE: This will become more open in a future release.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Nested Class Summary

      • Nested classes/interfaces inherited from class javax.swing.tree.AbstractLayoutCache

        AbstractLayoutCache.NodeDimensions

    • Field Summary

      • Fields inherited from class javax.swing.tree.AbstractLayoutCache

        nodeDimensions, rootVisible, rowHeight, treeModel, treeSelectionModel

    • Constructor Summary

      Constructors
      Constructor and Description
      VariableHeightLayoutCache()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Rectangle getBounds(TreePath path, Rectangle placeIn)
      Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.
      boolean getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      TreePath getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath getPathForRow(int row)
      Returns the path for row.
      int getPreferredHeight()
      Returns the preferred height.
      int getPreferredWidth(Rectangle bounds)
      Returns the preferred width and height for the region in visibleRegion.
      int getRowCount()
      Returns the number of visible rows.
      int getRowForPath(TreePath path)
      Returns the row where the last item identified in path is visible.
      int getVisibleChildCount(TreePath path)
      Returns the number of visible children for path.
      Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      void invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      void invalidateSizes()
      Informs the TreeState that it needs to recalculate all the sizes it is referencing.
      boolean isExpanded(TreePath path)
      Returns true if the value identified by path is currently expanded.
      void setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell.
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • Methods inherited from class javax.swing.tree.AbstractLayoutCache

        getModel, getNodeDimensions, getNodeDimensions, getRowHeight, getRowsForPaths, getSelectionModel, isFixedRowHeight, isRootVisible, setSelectionModel

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VariableHeightLayoutCache

        public VariableHeightLayoutCache()

    • Method Detail

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.
        Overrides:
        setModel in class AbstractLayoutCache
        Parameters:
        newModel - the TreeModel that is to provide the data

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.
        Overrides:
        setRootVisible in class AbstractLayoutCache
        Parameters:
        rootVisible - true if the root node of the tree is to be displayed
        See Also:
        AbstractLayoutCache.rootVisible

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell. If the specified value is less than or equal to zero the current cell renderer is queried for each row's height.
        Overrides:
        setRowHeight in class AbstractLayoutCache
        Parameters:
        rowHeight - the height of each cell, in pixels

      • setNodeDimensions

        public void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
        Sets the renderer that is responsible for drawing nodes in the tree.
        Overrides:
        setNodeDimensions in class AbstractLayoutCache
        Parameters:
        nd - the renderer

      • setExpandedState

        public void setExpandedState(TreePath path,
                             boolean isExpanded)
        Marks the path path expanded state to isExpanded.
        Specified by:
        setExpandedState in class AbstractLayoutCache
        Parameters:
        path - the TreePath of interest
        isExpanded - true if the path should be expanded, otherwise false

      • getExpandedState

        public boolean getExpandedState(TreePath path)
        Returns true if the path is expanded, and visible.
        Specified by:
        getExpandedState in class AbstractLayoutCache
        Parameters:
        path - the path being queried
        Returns:
        true if the path is expanded and visible, otherwise false

      • getBounds

        public Rectangle getBounds(TreePath path,
                           Rectangle placeIn)
        Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.
        Specified by:
        getBounds in class AbstractLayoutCache
        Parameters:
        path - the path to be drawn
        placeIn - the bounds of the enclosing rectangle
        Returns:
        the bounds of the enclosing rectangle or null if the node could not be ascertained

      • getPathForRow

        public TreePath getPathForRow(int row)
        Returns the path for row. If row is not visible, null is returned.
        Specified by:
        getPathForRow in class AbstractLayoutCache
        Parameters:
        row - the location of interest
        Returns:
        the path for row, or null if row is not visible

      • getRowForPath

        public int getRowForPath(TreePath path)
        Returns the row where the last item identified in path is visible. Will return -1 if any of the elements in path are not currently visible.
        Specified by:
        getRowForPath in class AbstractLayoutCache
        Parameters:
        path - the TreePath of interest
        Returns:
        the row where the last item in path is visible

      • getRowCount

        public int getRowCount()
        Returns the number of visible rows.
        Specified by:
        getRowCount in class AbstractLayoutCache
        Returns:
        the number of visible rows

      • invalidatePathBounds

        public void invalidatePathBounds(TreePath path)
        Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
        Specified by:
        invalidatePathBounds in class AbstractLayoutCache
        Parameters:
        path - the TreePath which is now invalid

      • getPreferredHeight

        public int getPreferredHeight()
        Returns the preferred height.
        Overrides:
        getPreferredHeight in class AbstractLayoutCache
        Returns:
        the preferred height

      • getPreferredWidth

        public int getPreferredWidth(Rectangle bounds)
        Returns the preferred width and height for the region in visibleRegion.
        Overrides:
        getPreferredWidth in class AbstractLayoutCache
        Parameters:
        bounds - the region being queried
        Returns:
        the preferred width for the passed in region

      • getPathClosestTo

        public TreePath getPathClosestTo(int x,
                                 int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it will always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        Specified by:
        getPathClosestTo in class AbstractLayoutCache
        Parameters:
        x - the x-coordinate
        y - the y-coordinate
        Returns:
        the path to the node that is closest to x, y

      • getVisiblePathsFrom

        public Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
        Returns an Enumerator that increments over the visible paths starting at the passed in location. The ordering of the enumeration is based on how the paths are displayed.
        Specified by:
        getVisiblePathsFrom in class AbstractLayoutCache
        Parameters:
        path - the location in the TreePath to start
        Returns:
        an Enumerator that increments over the visible paths

      • getVisibleChildCount

        public int getVisibleChildCount(TreePath path)
        Returns the number of visible children for path.
        Specified by:
        getVisibleChildCount in class AbstractLayoutCache
        Parameters:
        path - the path being queried
        Returns:
        the number of visible children for path

      • invalidateSizes

        public void invalidateSizes()
        Informs the TreeState that it needs to recalculate all the sizes it is referencing.
        Specified by:
        invalidateSizes in class AbstractLayoutCache

      • isExpanded

        public boolean isExpanded(TreePath path)
        Returns true if the value identified by path is currently expanded.
        Specified by:
        isExpanded in class AbstractLayoutCache
        Returns:
        true if the value identified by path is currently expanded

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)
        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        e.path returns the path the parent of the changed node(s).

        e.childIndices returns the index(es) of the changed node(s).

        Specified by:
        treeNodesChanged in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent of interest

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)
        Invoked after nodes have been inserted into the tree.

        e.path returns the parent of the new nodes.

        e.childIndices returns the indices of the new nodes in ascending order.

        Specified by:
        treeNodesInserted in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent of interest

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)
        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        e.path returns the former parent of the deleted nodes.

        e.childIndices returns the indices the nodes had before they were deleted in ascending order.

        Specified by:
        treeNodesRemoved in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent of interest

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)
        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        e.path holds the path to the node.

        e.childIndices returns null.

        Specified by:
        treeStructureChanged in class AbstractLayoutCache
        Parameters:
        e - the TreeModelEvent of interest
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.AbstractLayoutCache (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.AbstractLayoutCache

  • Packages that use AbstractLayoutCache
    Package Description
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of AbstractLayoutCache in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as AbstractLayoutCache
      Modifier and Type Field and Description
      protected AbstractLayoutCache BasicTreeUI.treeState
      Object responsible for handling sizing and expanded issues.
      Methods in javax.swing.plaf.basic that return AbstractLayoutCache
      Modifier and Type Method and Description
      protected AbstractLayoutCache BasicTreeUI.createLayoutCache()
      Creates the object responsible for managing what is expanded, as well as the size of nodes.

    • Uses of AbstractLayoutCache in javax.swing.tree

      Subclasses of AbstractLayoutCache in javax.swing.tree
      Modifier and Type Class and Description
      class  FixedHeightLayoutCache
      NOTE: This will become more open in a future release.
      class  VariableHeightLayoutCache
      NOTE: This will become more open in a future release.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.AbstractLayoutCache.NodeDimensions (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.AbstractLayoutCache.NodeDimensions

  • Packages that use AbstractLayoutCache.NodeDimensions
    Package Description
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of AbstractLayoutCache.NodeDimensions in javax.swing.plaf.basic

      Subclasses of AbstractLayoutCache.NodeDimensions in javax.swing.plaf.basic
      Modifier and Type Class and Description
      class  BasicTreeUI.NodeDimensionsHandler
      Class responsible for getting size of node, method is forwarded to BasicTreeUI method.
      Fields in javax.swing.plaf.basic declared as AbstractLayoutCache.NodeDimensions
      Modifier and Type Field and Description
      protected AbstractLayoutCache.NodeDimensions BasicTreeUI.nodeDimensions
      Reponsible for telling the TreeState the size needed for a node.
      Methods in javax.swing.plaf.basic that return AbstractLayoutCache.NodeDimensions
      Modifier and Type Method and Description
      protected AbstractLayoutCache.NodeDimensions BasicTreeUI.createNodeDimensions()
      Creates an instance of NodeDimensions that is able to determine the size of a given node in the tree.

    • Uses of AbstractLayoutCache.NodeDimensions in javax.swing.tree

      Fields in javax.swing.tree declared as AbstractLayoutCache.NodeDimensions
      Modifier and Type Field and Description
      protected AbstractLayoutCache.NodeDimensions AbstractLayoutCache.nodeDimensions
      Object responsible for getting the size of a node.
      Methods in javax.swing.tree that return AbstractLayoutCache.NodeDimensions
      Modifier and Type Method and Description
      AbstractLayoutCache.NodeDimensions AbstractLayoutCache.getNodeDimensions()
      Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.
      Methods in javax.swing.tree with parameters of type AbstractLayoutCache.NodeDimensions
      Modifier and Type Method and Description
      void VariableHeightLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree.
      void AbstractLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree and which is therefore responsible for calculating the dimensions of individual nodes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultMutableTreeNode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultMutableTreeNode

  • Packages that use DefaultMutableTreeNode
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of DefaultMutableTreeNode in javax.swing

      Subclasses of DefaultMutableTreeNode in javax.swing
      Modifier and Type Class and Description
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
      Methods in javax.swing with parameters of type DefaultMutableTreeNode
      Modifier and Type Method and Description
      static void JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode parent, Object children)
      Adds to parent all the children in children.

    • Uses of DefaultMutableTreeNode in javax.swing.tree

      Methods in javax.swing.tree that return DefaultMutableTreeNode
      Modifier and Type Method and Description
      DefaultMutableTreeNode DefaultMutableTreeNode.getFirstLeaf()
      Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf.
      DefaultMutableTreeNode DefaultMutableTreeNode.getLastLeaf()
      Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf.
      DefaultMutableTreeNode DefaultMutableTreeNode.getNextLeaf()
      Returns the leaf after this node or null if this node is the last leaf in the tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getNextNode()
      Returns the node that follows this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getNextSibling()
      Returns the next sibling of this node in the parent's children array.
      DefaultMutableTreeNode DefaultMutableTreeNode.getPreviousLeaf()
      Returns the leaf before this node or null if this node is the first leaf in the tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getPreviousNode()
      Returns the node that precedes this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getPreviousSibling()
      Returns the previous sibling of this node in the parent's children array.
      Methods in javax.swing.tree with parameters of type DefaultMutableTreeNode
      Modifier and Type Method and Description
      TreeNode DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode)
      Returns the nearest common ancestor to this node and aNode.
      boolean DefaultMutableTreeNode.isNodeDescendant(DefaultMutableTreeNode anotherNode)
      Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children.
      boolean DefaultMutableTreeNode.isNodeRelated(DefaultMutableTreeNode aNode)
      Returns true if and only if aNode is in the same tree as this node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

No usage of javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultTreeCellEditor.EditorContainer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultTreeCellEditor.EditorContainer

No usage of javax.swing.tree.DefaultTreeCellEditor.EditorContainer
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultTreeCellEditor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultTreeCellEditor

No usage of javax.swing.tree.DefaultTreeCellEditor
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultTreeCellRenderer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultTreeCellRenderer

  • Packages that use DefaultTreeCellRenderer
    Package Description
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of DefaultTreeCellRenderer in javax.swing.tree

      Fields in javax.swing.tree declared as DefaultTreeCellRenderer
      Modifier and Type Field and Description
      protected DefaultTreeCellRenderer DefaultTreeCellEditor.renderer
      Renderer, used to get border and offsets from.
      Constructors in javax.swing.tree with parameters of type DefaultTreeCellRenderer
      Constructor and Description
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultTreeModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultTreeModel

No usage of javax.swing.tree.DefaultTreeModel
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.DefaultTreeSelectionModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.DefaultTreeSelectionModel

  • Packages that use DefaultTreeSelectionModel
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of DefaultTreeSelectionModel in javax.swing

      Subclasses of DefaultTreeSelectionModel in javax.swing
      Modifier and Type Class and Description
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.ExpandVetoException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.ExpandVetoException

  • Packages that use ExpandVetoException
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of ExpandVetoException in javax.swing

      Methods in javax.swing that throw ExpandVetoException
      Modifier and Type Method and Description
      void JTree.fireTreeWillCollapse(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeWillExpand(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.

    • Uses of ExpandVetoException in javax.swing.event

      Methods in javax.swing.event that throw ExpandVetoException
      Modifier and Type Method and Description
      void TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be collapsed.
      void TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be expanded.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.FixedHeightLayoutCache (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.FixedHeightLayoutCache

No usage of javax.swing.tree.FixedHeightLayoutCache
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.MutableTreeNode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.MutableTreeNode

  • Packages that use MutableTreeNode
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of MutableTreeNode in javax.swing

      Classes in javax.swing that implement MutableTreeNode
      Modifier and Type Class and Description
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.

    • Uses of MutableTreeNode in javax.swing.tree

      Classes in javax.swing.tree that implement MutableTreeNode
      Modifier and Type Class and Description
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
      Fields in javax.swing.tree declared as MutableTreeNode
      Modifier and Type Field and Description
      protected MutableTreeNode DefaultMutableTreeNode.parent
      this node's parent, or null if this node has no parent
      Methods in javax.swing.tree with parameters of type MutableTreeNode
      Modifier and Type Method and Description
      void DefaultMutableTreeNode.add(MutableTreeNode newChild)
      Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
      void DefaultMutableTreeNode.insert(MutableTreeNode newChild, int childIndex)
      Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex.
      void MutableTreeNode.insert(MutableTreeNode child, int index)
      Adds child to the receiver at index.
      void DefaultTreeModel.insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index)
      Invoked this to insert newChild at location index in parents children.
      void DefaultMutableTreeNode.remove(MutableTreeNode aChild)
      Removes aChild from this node's child array, giving it a null parent.
      void MutableTreeNode.remove(MutableTreeNode node)
      Removes node from the receiver.
      void DefaultTreeModel.removeNodeFromParent(MutableTreeNode node)
      Message this to remove node from its parent.
      void DefaultMutableTreeNode.setParent(MutableTreeNode newParent)
      Sets this node's parent to newParent but does not change the parent's child array.
      void MutableTreeNode.setParent(MutableTreeNode newParent)
      Sets the parent of the receiver to newParent.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.RowMapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.RowMapper

  • Packages that use RowMapper
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of RowMapper in javax.swing

      Methods in javax.swing with parameters of type RowMapper
      Modifier and Type Method and Description
      void JTree.EmptySelectionModel.setRowMapper(RowMapper mapper)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.

    • Uses of RowMapper in javax.swing.tree

      Classes in javax.swing.tree that implement RowMapper
      Modifier and Type Class and Description
      class  AbstractLayoutCache
      Warning: Serialized objects of this class will not be compatible with future Swing releases.
      class  FixedHeightLayoutCache
      NOTE: This will become more open in a future release.
      class  VariableHeightLayoutCache
      NOTE: This will become more open in a future release.
      Fields in javax.swing.tree declared as RowMapper
      Modifier and Type Field and Description
      protected RowMapper DefaultTreeSelectionModel.rowMapper
      Provides a row for a given path.
      Methods in javax.swing.tree that return RowMapper
      Modifier and Type Method and Description
      RowMapper TreeSelectionModel.getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      RowMapper DefaultTreeSelectionModel.getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      Methods in javax.swing.tree with parameters of type RowMapper
      Modifier and Type Method and Description
      void TreeSelectionModel.setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
      void DefaultTreeSelectionModel.setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.TreeCellEditor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.TreeCellEditor

  • Packages that use TreeCellEditor
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeCellEditor in javax.swing

      Classes in javax.swing that implement TreeCellEditor
      Modifier and Type Class and Description
      class  DefaultCellEditor
      The default editor for table and tree cells.
      Fields in javax.swing declared as TreeCellEditor
      Modifier and Type Field and Description
      protected TreeCellEditor JTree.cellEditor
      Editor for the entries.
      Methods in javax.swing that return TreeCellEditor
      Modifier and Type Method and Description
      TreeCellEditor JTree.getCellEditor()
      Returns the editor used to edit entries in the tree.
      Methods in javax.swing with parameters of type TreeCellEditor
      Modifier and Type Method and Description
      void JTree.setCellEditor(TreeCellEditor cellEditor)
      Sets the cell editor.

    • Uses of TreeCellEditor in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeCellEditor
      Modifier and Type Field and Description
      protected TreeCellEditor BasicTreeUI.cellEditor
      Editor for the tree.
      Methods in javax.swing.plaf.basic that return TreeCellEditor
      Modifier and Type | Method and Description
      protected TreeCellEditor BasicTreeUI.createDefaultCellEditor()
      Creates a default cell editor.
      protected TreeCellEditor | BasicTreeUI.getCellEditor()
      Methods in javax.swing.plaf.basic with parameters of type TreeCellEditor
      Modifier and Type Method and Description
      protected void BasicTreeUI.setCellEditor(TreeCellEditor editor)
      Sets the cell editor.

    • Uses of TreeCellEditor in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return TreeCellEditor
      Modifier and Type Method and Description
      protected TreeCellEditor SynthTreeUI.createDefaultCellEditor()
      Creates a default cell editor.

    • Uses of TreeCellEditor in javax.swing.tree

      Classes in javax.swing.tree that implement TreeCellEditor
      Modifier and Type Class and Description
      class  DefaultTreeCellEditor
      A TreeCellEditor.
      Fields in javax.swing.tree declared as TreeCellEditor
      Modifier and Type Field and Description
      protected TreeCellEditor DefaultTreeCellEditor.realEditor
      Editor handling the editing.
      Methods in javax.swing.tree that return TreeCellEditor
      Modifier and Type Method and Description
      protected TreeCellEditor DefaultTreeCellEditor.createTreeCellEditor()
      This is invoked if a TreeCellEditor is not supplied in the constructor.
      Constructors in javax.swing.tree with parameters of type TreeCellEditor
      Constructor and Description
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.TreeCellRenderer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.TreeCellRenderer

  • Packages that use TreeCellRenderer
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeCellRenderer in javax.swing

      Fields in javax.swing declared as TreeCellRenderer
      Modifier and Type Field and Description
      protected TreeCellRenderer JTree.cellRenderer
      The cell used to draw nodes.
      Methods in javax.swing that return TreeCellRenderer
      Modifier and Type Method and Description
      TreeCellRenderer JTree.getCellRenderer()
      Returns the current TreeCellRenderer that is rendering each cell.
      Methods in javax.swing with parameters of type TreeCellRenderer
      Modifier and Type Method and Description
      void JTree.setCellRenderer(TreeCellRenderer x)
      Sets the TreeCellRenderer that will be used to draw each cell.

    • Uses of TreeCellRenderer in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeCellRenderer
      Modifier and Type Field and Description
      protected TreeCellRenderer BasicTreeUI.currentCellRenderer
      Renderer that is being used to do the actual cell drawing.
      Methods in javax.swing.plaf.basic that return TreeCellRenderer
      Modifier and Type Method and Description
      protected TreeCellRenderer BasicTreeUI.createDefaultCellRenderer()
      Returns the default cell renderer that is used to do the stamping of each node.
      protected TreeCellRenderer BasicTreeUI.getCellRenderer()
      Return currentCellRenderer, which will either be the trees renderer, or defaultCellRenderer, which ever wasn't null.
      Methods in javax.swing.plaf.basic with parameters of type TreeCellRenderer
      Modifier and Type Method and Description
      protected void BasicTreeUI.setCellRenderer(TreeCellRenderer tcr)
      Sets the TreeCellRenderer to tcr.

    • Uses of TreeCellRenderer in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return TreeCellRenderer
      Modifier and Type Method and Description
      protected TreeCellRenderer SynthTreeUI.createDefaultCellRenderer()
      Returns the default cell renderer that is used to do the stamping of each node.

    • Uses of TreeCellRenderer in javax.swing.tree

      Classes in javax.swing.tree that implement TreeCellRenderer
      Modifier and Type Class and Description
      class  DefaultTreeCellRenderer
      Displays an entry in a tree.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.TreeModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.TreeModel

  • Packages that use TreeModel
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeModel in javax.swing

      Fields in javax.swing declared as TreeModel
      Modifier and Type Field and Description
      protected TreeModel JTree.treeModel
      The model that defines the tree displayed by this object.
      Methods in javax.swing that return TreeModel
      Modifier and Type Method and Description
      protected static TreeModel JTree.createTreeModel(Object value)
      Returns a TreeModel wrapping the specified object.
      protected static TreeModel JTree.getDefaultTreeModel()
      Creates and returns a sample TreeModel.
      TreeModel JTree.getModel()
      Returns the TreeModel that is providing the data.
      Methods in javax.swing with parameters of type TreeModel
      Modifier and Type Method and Description
      void JTree.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      Constructors in javax.swing with parameters of type TreeModel
      Constructor and Description
      JTree(TreeModel newModel)
      Returns an instance of JTree which displays the root node -- the tree is created using the specified data model.

    • Uses of TreeModel in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeModel
      Modifier and Type Field and Description
      protected TreeModel BasicTreeUI.treeModel
      Used to determine what to display.
      Methods in javax.swing.plaf.basic that return TreeModel
      Modifier and Type | Method and Description
      protected TreeModel | BasicTreeUI.getModel()
      Methods in javax.swing.plaf.basic with parameters of type TreeModel
      Modifier and Type Method and Description
      protected void BasicTreeUI.setModel(TreeModel model)
      Sets the TreeModel.

    • Uses of TreeModel in javax.swing.tree

      Classes in javax.swing.tree that implement TreeModel
      Modifier and Type Class and Description
      class  DefaultTreeModel
      A simple tree data model that uses TreeNodes.
      Fields in javax.swing.tree declared as TreeModel
      Modifier and Type Field and Description
      protected TreeModel AbstractLayoutCache.treeModel
      Model providing information.
      Methods in javax.swing.tree that return TreeModel
      Modifier and Type Method and Description
      TreeModel AbstractLayoutCache.getModel()
      Returns the TreeModel that is providing the data.
      Methods in javax.swing.tree with parameters of type TreeModel
      Modifier and Type Method and Description
      void VariableHeightLayoutCache.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void FixedHeightLayoutCache.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void AbstractLayoutCache.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.TreeNode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.TreeNode

  • Packages that use TreeNode
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeNode in javax.swing

      Classes in javax.swing that implement TreeNode
      Modifier and Type Class and Description
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
      Methods in javax.swing that return TreeNode
      Modifier and Type Method and Description
      TreeNode JTree.DynamicUtilTreeNode.getChildAt(int index)
      Subclassed to load the children, if necessary.
      Constructors in javax.swing with parameters of type TreeNode
      Constructor and Description
      JTree(TreeNode root)
      Returns a JTree with the specified TreeNode as its root, which displays the root node.
      JTree(TreeNode root, boolean asksAllowsChildren)
      Returns a JTree with the specified TreeNode as its root, which displays the root node and which decides whether a node is a leaf node in the specified manner.

    • Uses of TreeNode in javax.swing.text

      Classes in javax.swing.text that implement TreeNode
      Modifier and Type Class and Description
      class  AbstractDocument.AbstractElement
      Implements the abstract part of an element.
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...
      Methods in javax.swing.text that return TreeNode
      Modifier and Type Method and Description
      TreeNode AbstractDocument.AbstractElement.getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      TreeNode AbstractDocument.AbstractElement.getParent()
      Returns the parent TreeNode of the receiver.
      Methods in javax.swing.text with parameters of type TreeNode
      Modifier and Type Method and Description
      int AbstractDocument.AbstractElement.getIndex(TreeNode node)
      Returns the index of node in the receivers children.

    • Uses of TreeNode in javax.swing.text.html

      Classes in javax.swing.text.html that implement TreeNode
      Modifier and Type Class and Description
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.

    • Uses of TreeNode in javax.swing.tree

      Subinterfaces of TreeNode in javax.swing.tree
      Modifier and Type Interface and Description
      interface  MutableTreeNode
      Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
      Classes in javax.swing.tree that implement TreeNode
      Modifier and Type Class and Description
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
      Fields in javax.swing.tree declared as TreeNode
      Modifier and Type Field and Description
      protected TreeNode DefaultTreeModel.root
      Root of the tree.
      Fields in javax.swing.tree with type parameters of type TreeNode
      Modifier and Type Field and Description
      static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
      An enumeration that is always empty.
      Methods in javax.swing.tree that return TreeNode
      Modifier and Type Method and Description
      TreeNode DefaultMutableTreeNode.getChildAfter(TreeNode aChild)
      Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.
      TreeNode DefaultMutableTreeNode.getChildAt(int index)
      Returns the child at the specified index in this node's child array.
      TreeNode TreeNode.getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      TreeNode DefaultMutableTreeNode.getChildBefore(TreeNode aChild)
      Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.
      TreeNode DefaultMutableTreeNode.getFirstChild()
      Returns this node's first child.
      TreeNode DefaultMutableTreeNode.getLastChild()
      Returns this node's last child.
      TreeNode DefaultMutableTreeNode.getParent()
      Returns this node's parent or null if this node has no parent.
      TreeNode TreeNode.getParent()
      Returns the parent TreeNode of the receiver.
      TreeNode[] DefaultMutableTreeNode.getPath()
      Returns the path from the root, to get to this node.
      TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      TreeNode DefaultMutableTreeNode.getRoot()
      Returns the root of the tree that contains this node.
      TreeNode DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode)
      Returns the nearest common ancestor to this node and aNode.
      Methods in javax.swing.tree with parameters of type TreeNode
      Modifier and Type Method and Description
      TreeNode DefaultMutableTreeNode.getChildAfter(TreeNode aChild)
      Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.
      TreeNode DefaultMutableTreeNode.getChildBefore(TreeNode aChild)
      Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.
      int DefaultMutableTreeNode.getIndex(TreeNode aChild)
      Returns the index of the specified child in this node's child array.
      int TreeNode.getIndex(TreeNode node)
      Returns the index of node in the receivers children.
      TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      boolean DefaultMutableTreeNode.isNodeAncestor(TreeNode anotherNode)
      Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent.
      boolean DefaultMutableTreeNode.isNodeChild(TreeNode aNode)
      Returns true if aNode is a child of this node.
      boolean DefaultMutableTreeNode.isNodeSibling(TreeNode anotherNode)
      Returns true if anotherNode is a sibling of (has the same parent as) this node.
      void DefaultTreeModel.nodeChanged(TreeNode node)
      Invoke this method after you've changed how node is to be represented in the tree.
      void DefaultTreeModel.nodesChanged(TreeNode node, int[] childIndices)
      Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.
      void DefaultTreeModel.nodeStructureChanged(TreeNode node)
      Invoke this method if you've totally changed the children of node and its children's children...
      void DefaultTreeModel.nodesWereInserted(TreeNode node, int[] childIndices)
      Invoke this method after you've inserted some TreeNodes into node.
      void DefaultTreeModel.nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
      Invoke this method after you've removed some TreeNodes from node.
      Enumeration DefaultMutableTreeNode.pathFromAncestorEnumeration(TreeNode ancestor)
      Creates and returns an enumeration that follows the path from ancestor to this node.
      void DefaultTreeModel.reload(TreeNode node)
      Invoke this method if you've modified the TreeNodes upon which this model depends.
      void DefaultTreeModel.setRoot(TreeNode root)
      Sets the root to root.
      Constructors in javax.swing.tree with parameters of type TreeNode
      Constructor and Description
      DefaultTreeModel(TreeNode root)
      Creates a tree in which any node can have children.
      DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
      Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.TreePath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.TreePath

  • Packages that use TreePath
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreePath in javax.swing

      Methods in javax.swing that return TreePath
      Modifier and Type Method and Description
      TreePath JTree.getAnchorSelectionPath()
      Returns the path identified as the anchor.
      TreePath JTree.getClosestPathForLocation(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath JTree.getEditingPath()
      Returns the path to the element that is currently being edited.
      TreePath JTree.getLeadSelectionPath()
      Returns the path identified as the lead.
      TreePath JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias)
      Returns the TreePath to the next tree element that begins with a prefix.
      TreePath JTree.DropLocation.getPath()
      Returns the path where dropped data should be placed in the tree.
      protected TreePath[] JTree.getPathBetweenRows(int index0, int index1)
      Returns the paths (inclusive) between the specified rows.
      TreePath JTree.getPathForLocation(int x, int y)
      Returns the path for the node at the specified location.
      TreePath JTree.getPathForRow(int row)
      Returns the path for the specified row.
      TreePath JTree.getSelectionPath()
      Returns the path to the first selected node.
      TreePath[] JTree.getSelectionPaths()
      Returns the paths of all selected values.
      Methods in javax.swing that return types with arguments of type TreePath
      Modifier and Type Method and Description
      protected Enumeration<TreePath> JTree.getDescendantToggledPaths(TreePath parent)
      Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.
      Enumeration<TreePath> JTree.getExpandedDescendants(TreePath parent)
      Returns an Enumeration of the descendants of the path parent that are currently expanded.
      Methods in javax.swing with parameters of type TreePath
      Modifier and Type Method and Description
      void JTree.addSelectionPath(TreePath path)
      Adds the node identified by the specified TreePath to the current selection.
      void JTree.addSelectionPaths(TreePath[] paths)
      Adds each path in the array of paths to the current selection.
      void JTree.EmptySelectionModel.addSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.collapsePath(TreePath path)
      Ensures that the node identified by the specified path is collapsed and viewable.
      void JTree.expandPath(TreePath path)
      Ensures that the node identified by the specified path is expanded and viewable.
      void JTree.fireTreeCollapsed(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeExpanded(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeWillCollapse(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeWillExpand(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      protected Enumeration<TreePath> JTree.getDescendantToggledPaths(TreePath parent)
      Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.
      Enumeration<TreePath> JTree.getExpandedDescendants(TreePath parent)
      Returns an Enumeration of the descendants of the path parent that are currently expanded.
      Rectangle JTree.getPathBounds(TreePath path)
      Returns the Rectangle that the specified node will be drawn into.
      int JTree.getRowForPath(TreePath path)
      Returns the row that displays the node identified by the specified path.
      boolean JTree.hasBeenExpanded(TreePath path)
      Returns true if the node identified by the path has ever been expanded.
      boolean JTree.isCollapsed(TreePath path)
      Returns true if the value identified by path is currently collapsed, this will return false if any of the values in path are currently not being displayed.
      boolean JTree.isExpanded(TreePath path)
      Returns true if the node identified by the path is currently expanded,
      boolean JTree.isPathEditable(TreePath path)
      Returns isEditable.
      boolean JTree.isPathSelected(TreePath path)
      Returns true if the item identified by the path is currently selected.
      boolean JTree.isVisible(TreePath path)
      Returns true if the value identified by path is currently viewable, which means it is either the root or all of its parents are expanded.
      void JTree.makeVisible(TreePath path)
      Ensures that the node identified by path is currently viewable.
      protected boolean JTree.removeDescendantSelectedPaths(TreePath path, boolean includePath)
      Removes any paths in the selection that are descendants of path.
      void JTree.removeSelectionPath(TreePath path)
      Removes the node identified by the specified path from the current selection.
      void JTree.removeSelectionPaths(TreePath[] paths)
      Removes the nodes identified by the specified paths from the current selection.
      void JTree.EmptySelectionModel.removeSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.scrollPathToVisible(TreePath path)
      Makes sure all the path components in path are expanded (except for the last path component) and scrolls so that the node identified by the path is displayed.
      void JTree.setAnchorSelectionPath(TreePath newPath)
      Sets the path identified as the anchor.
      protected void JTree.setExpandedState(TreePath path, boolean state)
      Sets the expanded state of this JTree.
      void JTree.setLeadSelectionPath(TreePath newPath)
      Sets the path identifies as the lead.
      void JTree.setSelectionPath(TreePath path)
      Selects the node identified by the specified path.
      void JTree.setSelectionPaths(TreePath[] paths)
      Selects the nodes identified by the specified array of paths.
      void JTree.EmptySelectionModel.setSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.startEditingAtPath(TreePath path)
      Selects the node identified by the specified path and initiates editing.
      Method parameters in javax.swing with type arguments of type TreePath
      Modifier and Type Method and Description
      protected void JTree.removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
      Removes any descendants of the TreePaths in toRemove that have been expanded.
      Constructors in javax.swing with parameters of type TreePath
      Constructor and Description
      AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
      Constructs an AccessibleJTreeNode

    • Uses of TreePath in javax.swing.event

      Fields in javax.swing.event declared as TreePath
      Modifier and Type Field and Description
      protected TreePath TreeSelectionEvent.newLeadSelectionPath
      leadSelectionPath after the paths changed, may be null.
      protected TreePath TreeSelectionEvent.oldLeadSelectionPath
      leadSelectionPath before the paths changed, may be null.
      protected TreePath TreeExpansionEvent.path
      Path to the value this event represents.
      protected TreePath TreeModelEvent.path
      Path to the parent of the nodes that have changed.
      protected TreePath[] TreeSelectionEvent.paths
      Paths this event represents.
      Methods in javax.swing.event that return TreePath
      Modifier and Type Method and Description
      TreePath TreeSelectionEvent.getNewLeadSelectionPath()
      Returns the current lead path.
      TreePath TreeSelectionEvent.getOldLeadSelectionPath()
      Returns the path that was previously the lead path.
      TreePath TreeExpansionEvent.getPath()
      Returns the path to the value that has been expanded/collapsed.
      TreePath TreeSelectionEvent.getPath()
      Returns the first path element.
      TreePath[] TreeSelectionEvent.getPaths()
      Returns the paths that have been added or removed from the selection.
      TreePath TreeModelEvent.getTreePath()
      For all events, except treeStructureChanged, returns the parent of the changed nodes.
      Methods in javax.swing.event with parameters of type TreePath
      Modifier and Type Method and Description
      boolean TreeSelectionEvent.isAddedPath(TreePath path)
      Returns whether the specified path was added to the selection.
      Constructors in javax.swing.event with parameters of type TreePath
      Constructor and Description
      TreeExpansionEvent(Object source, TreePath path)
      Constructs a TreeExpansionEvent object.
      TreeModelEvent(Object source, TreePath path)
      Used to create an event when the node structure has changed in some way, identifying the path to the root of the modified subtree as a TreePath object.
      TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
      Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as a TreePath object.
      TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.
      TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.
      TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.

    • Uses of TreePath in javax.swing.plaf

      Methods in javax.swing.plaf that return TreePath
      Modifier and Type Method and Description
      abstract TreePath TreeUI.getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath TreeUI.getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      abstract TreePath TreeUI.getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      Methods in javax.swing.plaf with parameters of type TreePath
      Modifier and Type Method and Description
      abstract Rectangle TreeUI.getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      abstract int TreeUI.getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      abstract void TreeUI.startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.

    • Uses of TreePath in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreePath
      Modifier and Type Field and Description
      protected TreePath BasicTreeUI.editingPath
      Path that is being edited.
      Fields in javax.swing.plaf.basic with type parameters of type TreePath
      Modifier and Type Field and Description
      protected Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
      Used for minimizing the drawing of vertical lines.
      Methods in javax.swing.plaf.basic that return TreePath
      Modifier and Type Method and Description
      TreePath BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath BasicTreeUI.getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      protected TreePath BasicTreeUI.getLastChildPath(TreePath parent)
      Returns a path to the last child of parent.
      TreePath BasicTreeUI.getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      Methods in javax.swing.plaf.basic with parameters of type TreePath
      Modifier and Type Method and Description
      protected void BasicTreeUI.checkForClickInExpandControl(TreePath path, int mouseX, int mouseY)
      If the mouseX and mouseY are in the expand/collapse region of the row, this will toggle the row.
      protected TreePath BasicTreeUI.getLastChildPath(TreePath parent)
      Returns a path to the last child of parent.
      Rectangle BasicTreeUI.getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      int BasicTreeUI.getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      protected void BasicTreeUI.handleExpandControlClick(TreePath path, int mouseX, int mouseY)
      Messaged when the user clicks the particular row, this invokes toggleExpandState.
      protected boolean BasicTreeUI.isLocationInExpandControl(TreePath path, int mouseX, int mouseY)
      Returns true if mouseX and mouseY fall in the area of row that is used to expand/collapse the node and the node at row does not represent a leaf.
      protected void BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the expand (toggle) part of a row.
      protected void BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the horizontal part of the leg.
      protected void BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the renderer part of a row.
      protected void BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      Paints the vertical part of the leg.
      protected void BasicTreeUI.pathWasCollapsed(TreePath path)
      Messaged from the VisibleTreeNode after it has collapsed.
      protected void BasicTreeUI.pathWasExpanded(TreePath path)
      Messaged from the VisibleTreeNode after it has been expanded.
      protected void BasicTreeUI.selectPathForEvent(TreePath path, MouseEvent event)
      Messaged to update the selection based on a MouseEvent over a particular row.
      protected boolean BasicTreeUI.shouldPaintExpandControl(TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Returns true if the expand (toggle) control should be drawn for the specified row.
      protected boolean BasicTreeUI.startEditing(TreePath path, MouseEvent event)
      Will start editing for node if there is a cellEditor and shouldSelectCell returns true.
      void BasicTreeUI.startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.
      protected void BasicTreeUI.toggleExpandState(TreePath path)
      Expands path if it is not expanded, or collapses row if it is expanded.
      protected void BasicTreeUI.updateExpandedDescendants(TreePath path)
      Updates the expanded state of all the descendants of path by getting the expanded descendants from the tree and forwarding to the tree state.

    • Uses of TreePath in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type TreePath
      Modifier and Type | Method and Description
      protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

    • Uses of TreePath in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return TreePath
      Modifier and Type Method and Description
      TreePath MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c)
      Invokes the getClosestPathForLocation method on each UI handled by this object.
      TreePath MultiTreeUI.getEditingPath(JTree a)
      Invokes the getEditingPath method on each UI handled by this object.
      TreePath MultiTreeUI.getPathForRow(JTree a, int b)
      Invokes the getPathForRow method on each UI handled by this object.
      Methods in javax.swing.plaf.multi with parameters of type TreePath
      Modifier and Type Method and Description
      Rectangle MultiTreeUI.getPathBounds(JTree a, TreePath b)
      Invokes the getPathBounds method on each UI handled by this object.
      int MultiTreeUI.getRowForPath(JTree a, TreePath b)
      Invokes the getRowForPath method on each UI handled by this object.
      void MultiTreeUI.startEditingAtPath(JTree a, TreePath b)
      Invokes the startEditingAtPath method on each UI handled by this object.

    • Uses of TreePath in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type TreePath
      Modifier and Type Method and Description
      protected void SynthTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the expand (toggle) part of a row.
      protected void SynthTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the horizontal part of the leg.
      protected void SynthTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      Paints the vertical part of the leg.

    • Uses of TreePath in javax.swing.tree

      Fields in javax.swing.tree declared as TreePath
      Modifier and Type Field and Description
      protected TreePath DefaultTreeCellEditor.lastPath
      Last path that was selected.
      protected TreePath DefaultTreeSelectionModel.leadPath
      Last path that was added.
      protected TreePath[] DefaultTreeSelectionModel.selection
      Paths that are currently selected.
      Methods in javax.swing.tree that return TreePath
      Modifier and Type Method and Description
      TreePath TreeSelectionModel.getLeadSelectionPath()
      Returns the last path that was added.
      TreePath DefaultTreeSelectionModel.getLeadSelectionPath()
      Returns the last path that was added.
      TreePath TreePath.getParentPath()
      Returns the TreePath of the parent.
      TreePath VariableHeightLayoutCache.getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath FixedHeightLayoutCache.getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath AbstractLayoutCache.getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath VariableHeightLayoutCache.getPathForRow(int row)
      Returns the path for row.
      TreePath FixedHeightLayoutCache.getPathForRow(int row)
      Returns the path for passed in row.
      abstract TreePath AbstractLayoutCache.getPathForRow(int row)
      Returns the path for passed in row.
      TreePath TreeSelectionModel.getSelectionPath()
      Returns the first path in the selection.
      TreePath DefaultTreeSelectionModel.getSelectionPath()
      Returns the first path in the selection.
      TreePath[] TreeSelectionModel.getSelectionPaths()
      Returns the paths in the selection.
      TreePath[] DefaultTreeSelectionModel.getSelectionPaths()
      Returns the selection.
      TreePath TreePath.pathByAddingChild(Object child)
      Returns a new path containing all the elements of this path plus child.
      Methods in javax.swing.tree that return types with arguments of type TreePath
      Modifier and Type Method and Description
      Enumeration<TreePath> VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      Enumeration<TreePath> FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      abstract Enumeration<TreePath> AbstractLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      Methods in javax.swing.tree with parameters of type TreePath
      Modifier and Type Method and Description
      void TreeSelectionModel.addSelectionPath(TreePath path)
      Adds path to the current selection.
      void DefaultTreeSelectionModel.addSelectionPath(TreePath path)
      Adds path to the current selection.
      void TreeSelectionModel.addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      void DefaultTreeSelectionModel.addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      protected boolean DefaultTreeSelectionModel.arePathsContiguous(TreePath[] paths)
      Returns true if the paths are contiguous, or this object has no RowMapper.
      protected boolean DefaultTreeSelectionModel.canPathsBeAdded(TreePath[] paths)
      Used to test if a particular set of TreePaths can be added.
      protected boolean DefaultTreeSelectionModel.canPathsBeRemoved(TreePath[] paths)
      Returns true if the paths can be removed without breaking the continuity of the model.
      Rectangle VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn)
      Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.
      Rectangle FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      abstract Rectangle AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      boolean VariableHeightLayoutCache.getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      boolean FixedHeightLayoutCache.getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      abstract boolean AbstractLayoutCache.getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      int VariableHeightLayoutCache.getRowForPath(TreePath path)
      Returns the row where the last item identified in path is visible.
      int FixedHeightLayoutCache.getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      abstract int AbstractLayoutCache.getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      int[] AbstractLayoutCache.getRowsForPaths(TreePath[] paths)
      Returns the rows that the TreePath instances in path are being displayed at.
      int[] RowMapper.getRowsForPaths(TreePath[] path)
      Returns the rows that the TreePath instances in path are being displayed at.
      int VariableHeightLayoutCache.getVisibleChildCount(TreePath path)
      Returns the number of visible children for path.
      int FixedHeightLayoutCache.getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      abstract int AbstractLayoutCache.getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      Enumeration<TreePath> VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      Enumeration<TreePath> FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      abstract Enumeration<TreePath> AbstractLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      void VariableHeightLayoutCache.invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      void FixedHeightLayoutCache.invalidatePathBounds(TreePath path)
      Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
      abstract void AbstractLayoutCache.invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      boolean TreePath.isDescendant(TreePath aTreePath)
      Returns true if aTreePath is a descendant of this TreePath.
      boolean VariableHeightLayoutCache.isExpanded(TreePath path)
      Returns true if the value identified by path is currently expanded.
      boolean FixedHeightLayoutCache.isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      abstract boolean AbstractLayoutCache.isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      boolean TreeSelectionModel.isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      boolean DefaultTreeSelectionModel.isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      protected void DefaultTreeSelectionModel.notifyPathChange(Vector<?> changedPaths, TreePath oldLeadSelection)
      Deprecated.
      As of JDK version 1.7
      void TreeSelectionModel.removeSelectionPath(TreePath path)
      Removes path from the selection.
      void DefaultTreeSelectionModel.removeSelectionPath(TreePath path)
      Removes path from the selection.
      void TreeSelectionModel.removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void DefaultTreeSelectionModel.removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void VariableHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void FixedHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      abstract void AbstractLayoutCache.setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void TreeSelectionModel.setSelectionPath(TreePath path)
      Sets the selection to path.
      void DefaultTreeSelectionModel.setSelectionPath(TreePath path)
      Sets the selection to path.
      void TreeSelectionModel.setSelectionPaths(TreePath[] paths)
      Sets the selection to path.
      void DefaultTreeSelectionModel.setSelectionPaths(TreePath[] pPaths)
      Sets the selection.
      void TreeModel.valueForPathChanged(TreePath path, Object newValue)
      Messaged when the user has altered the value for the item identified by path to newValue.
      void DefaultTreeModel.valueForPathChanged(TreePath path, Object newValue)
      This sets the user object of the TreeNode identified by path and posts a node changed.
      Constructors in javax.swing.tree with parameters of type TreePath
      Constructor and Description
      TreePath(TreePath parent, Object lastPathComponent)
      Creates a TreePath with the specified parent and element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.tree.TreeSelectionModel (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.tree.TreeSelectionModel

  • Packages that use TreeSelectionModel
    Package Description
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeSelectionModel in javax.swing

      Classes in javax.swing that implement TreeSelectionModel
      Modifier and Type Class and Description
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
      Fields in javax.swing declared as TreeSelectionModel
      Modifier and Type Field and Description
      protected TreeSelectionModel JTree.selectionModel
      Models the set of selected nodes in this tree.
      Methods in javax.swing that return TreeSelectionModel
      Modifier and Type Method and Description
      TreeSelectionModel JTree.getSelectionModel()
      Returns the model for selections.
      Methods in javax.swing with parameters of type TreeSelectionModel
      Modifier and Type Method and Description
      void JTree.setSelectionModel(TreeSelectionModel selectionModel)
      Sets the tree's selection model.

    • Uses of TreeSelectionModel in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeSelectionModel
      Modifier and Type Field and Description
      protected TreeSelectionModel BasicTreeUI.treeSelectionModel
      Model maintaining the selection.
      Methods in javax.swing.plaf.basic that return TreeSelectionModel
      Modifier and Type | Method and Description
      protected TreeSelectionModel | BasicTreeUI.getSelectionModel()
      Methods in javax.swing.plaf.basic with parameters of type TreeSelectionModel
      Modifier and Type Method and Description
      protected void BasicTreeUI.setSelectionModel(TreeSelectionModel newLSM)
      Resets the selection model.

    • Uses of TreeSelectionModel in javax.swing.tree

      Classes in javax.swing.tree that implement TreeSelectionModel
      Modifier and Type Class and Description
      class  DefaultTreeSelectionModel
      Default implementation of TreeSelectionModel.
      Fields in javax.swing.tree declared as TreeSelectionModel
      Modifier and Type Field and Description
      protected TreeSelectionModel AbstractLayoutCache.treeSelectionModel
      Selection model.
      Methods in javax.swing.tree that return TreeSelectionModel
      Modifier and Type Method and Description
      TreeSelectionModel AbstractLayoutCache.getSelectionModel()
      Returns the model used to maintain the selection.
      Methods in javax.swing.tree with parameters of type TreeSelectionModel
      Modifier and Type Method and Description
      void AbstractLayoutCache.setSelectionModel(TreeSelectionModel newLSM)
      Sets the TreeSelectionModel used to manage the selection to new LSM.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.tree.VariableHeightLayoutCache (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.tree.VariableHeightLayoutCache

No usage of javax.swing.tree.VariableHeightLayoutCache
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AbstractUndoableEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class AbstractUndoableEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
  • All Implemented Interfaces:
    Serializable, UndoableEdit
    Direct Known Subclasses:
    AbstractDocument.ElementEdit, CompoundEdit, DefaultStyledDocument.AttributeUndoableEdit, StateEdit

    public class AbstractUndoableEdit
extends Object
implements UndoableEdit, Serializable
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected static String RedoName
      String returned by getRedoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used.
      protected static String UndoName
      String returned by getUndoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used.

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractUndoableEdit()
      Creates an AbstractUndoableEdit which defaults hasBeenDone and alive to true.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean addEdit(UndoableEdit anEdit)
      This default implementation returns false.
      boolean canRedo()
      Returns true if this edit is alive and hasBeenDone is false.
      boolean canUndo()
      Returns true if this edit is alive and hasBeenDone is true.
      void die()
      Sets alive to false.
      String getPresentationName()
      This default implementation returns "".
      String getRedoPresentationName()
      Retreives the value from the defaults table with key AbstractUndoableEdit.redoText and returns that value followed by a space, followed by getPresentationName.
      String getUndoPresentationName()
      Retreives the value from the defaults table with key AbstractUndoableEdit.undoText and returns that value followed by a space, followed by getPresentationName.
      boolean isSignificant()
      This default implementation returns true.
      void redo()
      Throws CannotRedoException if canRedo returns false.
      boolean replaceEdit(UndoableEdit anEdit)
      This default implementation returns false.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void undo()
      Throws CannotUndoException if canUndo returns false.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • UndoName

        protected static final String UndoName
        String returned by getUndoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used. This value is now localized and comes from the defaults table with key AbstractUndoableEdit.undoText.
        See Also:
        UIDefaults, Constant Field Values

      • RedoName

        protected static final String RedoName
        String returned by getRedoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used. This value is now localized and comes from the defaults table with key AbstractUndoableEdit.redoText.
        See Also:
        UIDefaults, Constant Field Values

    • Constructor Detail

      • AbstractUndoableEdit

        public AbstractUndoableEdit()
        Creates an AbstractUndoableEdit which defaults hasBeenDone and alive to true.

    • Method Detail

      • die

        public void die()
        Sets alive to false. Note that this is a one way operation; dead edits cannot be resurrected. Sending undo or redo to a dead edit results in an exception being thrown.

        Typically an edit is killed when it is consolidated by another edit's addEdit or replaceEdit method, or when it is dequeued from an UndoManager.

        Specified by:
        die in interface UndoableEdit
        See Also:
        CompoundEdit.die()

      • undo

        public void undo()
          throws CannotUndoException
        Throws CannotUndoException if canUndo returns false. Sets hasBeenDone to false. Subclasses should override to undo the operation represented by this edit. Override should begin with a call to super.
        Specified by:
        undo in interface UndoableEdit
        Throws:
        CannotUndoException - if canUndo returns false
        See Also:
        canUndo()

      • canUndo

        public boolean canUndo()
        Returns true if this edit is alive and hasBeenDone is true.
        Specified by:
        canUndo in interface UndoableEdit
        Returns:
        true if this edit is alive and hasBeenDone is true
        See Also:
        die(),
undo(),
redo()

      • redo

        public void redo()
          throws CannotRedoException
        Throws CannotRedoException if canRedo returns false. Sets hasBeenDone to true. Subclasses should override to redo the operation represented by this edit. Override should begin with a call to super.
        Specified by:
        redo in interface UndoableEdit
        Throws:
        CannotRedoException - if canRedo returns false
        See Also:
        canRedo()

      • canRedo

        public boolean canRedo()
        Returns true if this edit is alive and hasBeenDone is false.
        Specified by:
        canRedo in interface UndoableEdit
        Returns:
        true if this edit is alive and hasBeenDone is false
        See Also:
        die(),
undo(),
redo()

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        This default implementation returns false.
        Specified by:
        addEdit in interface UndoableEdit
        Parameters:
        anEdit - the edit to be added
        Returns:
        false
        See Also:
        UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

      • replaceEdit

        public boolean replaceEdit(UndoableEdit anEdit)
        This default implementation returns false.
        Specified by:
        replaceEdit in interface UndoableEdit
        Parameters:
        anEdit - the edit to replace
        Returns:
        false
        See Also:
        UndoableEdit.replaceEdit(javax.swing.undo.UndoableEdit)

      • isSignificant

        public boolean isSignificant()
        This default implementation returns true.
        Specified by:
        isSignificant in interface UndoableEdit
        Returns:
        true
        See Also:
        UndoableEdit.isSignificant()

      • getPresentationName

        public String getPresentationName()
        This default implementation returns "". Used by getUndoPresentationName and getRedoPresentationName to construct the strings they return. Subclasses should override to return an appropriate description of the operation this edit represents.
        Specified by:
        getPresentationName in interface UndoableEdit
        Returns:
        the empty string ""
        See Also:
        getUndoPresentationName(), getRedoPresentationName()

      • getUndoPresentationName

        public String getUndoPresentationName()
        Retreives the value from the defaults table with key AbstractUndoableEdit.undoText and returns that value followed by a space, followed by getPresentationName. If getPresentationName returns "", then the defaults value is returned alone.
        Specified by:
        getUndoPresentationName in interface UndoableEdit
        Returns:
        the value from the defaults table with key AbstractUndoableEdit.undoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        See Also:
        getPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Retreives the value from the defaults table with key AbstractUndoableEdit.redoText and returns that value followed by a space, followed by getPresentationName. If getPresentationName returns "", then the defaults value is returned alone.
        Specified by:
        getRedoPresentationName in interface UndoableEdit
        Returns:
        the value from the defaults table with key AbstractUndoableEdit.redoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        See Also:
        getPresentationName()

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        Overrides:
        toString in class Object
        Returns:
        a String representation of this object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CannotRedoException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class CannotRedoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotRedoException
  • All Implemented Interfaces:
    Serializable

    public class CannotRedoException
extends RuntimeException
    Thrown when an UndoableEdit is told to redo() and can't.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Constructor Summary

      Constructors
      Constructor and Description
      CannotRedoException()

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CannotRedoException

        public CannotRedoException()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CannotUndoException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class CannotUndoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotUndoException
  • All Implemented Interfaces:
    Serializable

    public class CannotUndoException
extends RuntimeException
    Thrown when an UndoableEdit is told to undo() and can't.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Constructor Summary

      Constructors
      Constructor and Description
      CannotUndoException()

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CannotUndoException

        public CannotUndoException()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CompoundEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class CompoundEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.CompoundEdit
  • All Implemented Interfaces:
    Serializable, UndoableEdit
    Direct Known Subclasses:
    AbstractDocument.DefaultDocumentEvent, UndoManager

    public class CompoundEdit
extends AbstractUndoableEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Vector<UndoableEdit> edits
      The collection of UndoableEdits undone/redone en masse by this CompoundEdit.

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • Constructor Summary

      Constructors
      Constructor and Description
      CompoundEdit()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean addEdit(UndoableEdit anEdit)
      If this edit is inProgress, accepts anEdit and returns true.
      boolean canRedo()
      Returns false if isInProgress or if super returns false.
      boolean canUndo()
      Returns false if isInProgress or if super returns false.
      void die()
      Sends die to each subedit, in the reverse of the order that they were added.
      void end()
      Sets inProgress to false.
      String getPresentationName()
      Returns getPresentationName from the last UndoableEdit added to edits.
      String getRedoPresentationName()
      Returns getRedoPresentationName from the last UndoableEdit added to edits.
      String getUndoPresentationName()
      Returns getUndoPresentationName from the last UndoableEdit added to edits.
      boolean isInProgress()
      Returns true if this edit is in progress--that is, it has not received end.
      boolean isSignificant()
      Returns true if any of the UndoableEdits in edits do.
      protected UndoableEdit lastEdit()
      Returns the last UndoableEdit in edits, or null if edits is empty.
      void redo()
      Sends redo to all contained UndoableEdits in the order in which they were added.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void undo()
      Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.

      • Methods inherited from class javax.swing.undo.AbstractUndoableEdit

        replaceEdit

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • edits

        protected Vector<UndoableEdit> edits
        The collection of UndoableEdits undone/redone en masse by this CompoundEdit.

    • Constructor Detail

      • CompoundEdit

        public CompoundEdit()

    • Method Detail

      • undo

        public void undo()
          throws CannotUndoException
        Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.
        Specified by:
        undo in interface UndoableEdit
        Overrides:
        undo in class AbstractUndoableEdit
        Throws:
        CannotUndoException - if canUndo returns false
        See Also:
        AbstractUndoableEdit.canUndo()

      • redo

        public void redo()
          throws CannotRedoException
        Sends redo to all contained UndoableEdits in the order in which they were added.
        Specified by:
        redo in interface UndoableEdit
        Overrides:
        redo in class AbstractUndoableEdit
        Throws:
        CannotRedoException - if canRedo returns false
        See Also:
        AbstractUndoableEdit.canRedo()

      • lastEdit

        protected UndoableEdit lastEdit()
        Returns the last UndoableEdit in edits, or null if edits is empty.

      • die

        public void die()
        Sends die to each subedit, in the reverse of the order that they were added.
        Specified by:
        die in interface UndoableEdit
        Overrides:
        die in class AbstractUndoableEdit
        See Also:
        die()

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        If this edit is inProgress, accepts anEdit and returns true.

        The last edit added to this CompoundEdit is given a chance to addEdit(anEdit). If it refuses (returns false), anEdit is given a chance to replaceEdit the last edit. If anEdit returns false here, it is added to edits.

        Specified by:
        addEdit in interface UndoableEdit
        Overrides:
        addEdit in class AbstractUndoableEdit
        Parameters:
        anEdit - the edit to be added
        Returns:
        true if the edit is inProgress; otherwise returns false
        See Also:
        UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

      • end

        public void end()
        Sets inProgress to false.
        See Also:
        canUndo(), canRedo()

      • canUndo

        public boolean canUndo()
        Returns false if isInProgress or if super returns false.
        Specified by:
        canUndo in interface UndoableEdit
        Overrides:
        canUndo in class AbstractUndoableEdit
        Returns:
        true if this edit is alive and hasBeenDone is true
        See Also:
        isInProgress()

      • canRedo

        public boolean canRedo()
        Returns false if isInProgress or if super returns false.
        Specified by:
        canRedo in interface UndoableEdit
        Overrides:
        canRedo in class AbstractUndoableEdit
        Returns:
        true if this edit is alive and hasBeenDone is false
        See Also:
        isInProgress()

      • isInProgress

        public boolean isInProgress()
        Returns true if this edit is in progress--that is, it has not received end. This generally means that edits are still being added to it.
        See Also:
        end()

      • isSignificant

        public boolean isSignificant()
        Returns true if any of the UndoableEdits in edits do. Returns false if they all return false.
        Specified by:
        isSignificant in interface UndoableEdit
        Overrides:
        isSignificant in class AbstractUndoableEdit
        Returns:
        true
        See Also:
        UndoableEdit.isSignificant()

      • getPresentationName

        public String getPresentationName()
        Returns getPresentationName from the last UndoableEdit added to edits. If edits is empty, calls super.
        Specified by:
        getPresentationName in interface UndoableEdit
        Overrides:
        getPresentationName in class AbstractUndoableEdit
        Returns:
        the empty string ""
        See Also:
        AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

      • getUndoPresentationName

        public String getUndoPresentationName()
        Returns getUndoPresentationName from the last UndoableEdit added to edits. If edits is empty, calls super.
        Specified by:
        getUndoPresentationName in interface UndoableEdit
        Overrides:
        getUndoPresentationName in class AbstractUndoableEdit
        Returns:
        the value from the defaults table with key AbstractUndoableEdit.undoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        See Also:
        AbstractUndoableEdit.getPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Returns getRedoPresentationName from the last UndoableEdit added to edits. If edits is empty, calls super.
        Specified by:
        getRedoPresentationName in interface UndoableEdit
        Overrides:
        getRedoPresentationName in class AbstractUndoableEdit
        Returns:
        the value from the defaults table with key AbstractUndoableEdit.redoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        See Also:
        AbstractUndoableEdit.getPresentationName()

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        Overrides:
        toString in class AbstractUndoableEdit
        Returns:
        a String representation of this object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.undo (Java Platform SE 8 )

javax.swing.undo

Interfaces

  • StateEditable
  • UndoableEdit

Classes

  • AbstractUndoableEdit
  • CompoundEdit
  • StateEdit
  • UndoableEditSupport
  • UndoManager

Exceptions

  • CannotRedoException
  • CannotUndoException


javax.swing.undo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.swing.undo

Allows developers to provide support for undo/redo in applications such as text editors.

See: Description

  • Interface Summary
    Interface Description
    StateEditable
    StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.
    UndoableEdit
    An UndoableEdit represents an edit.
  • Class Summary
    Class Description
    AbstractUndoableEdit
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
    CompoundEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
    StateEdit
    StateEdit is a general edit for objects that change state.
    UndoableEditSupport
    A support class used for managing UndoableEdit listeners.
    UndoManager
    UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
  • Exception Summary
    Exception Description
    CannotRedoException
    Thrown when an UndoableEdit is told to redo() and can't.
    CannotUndoException
    Thrown when an UndoableEdit is told to undo() and can't.

Package javax.swing.undo Description

Allows developers to provide support for undo/redo in applications such as text editors.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Implementing Undo and Redo, a section in The Java Tutorial
Since:
1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.swing.undo Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.swing.undo

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.undo.CompoundEdit
        • javax.swing.undo.UndoManager (implements javax.swing.event.UndoableEditListener)
      • javax.swing.undo.StateEdit
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotRedoException
          • javax.swing.undo.CannotUndoException
    • javax.swing.undo.UndoableEditSupport

Interface Hierarchy

  • javax.swing.undo.StateEditable
  • javax.swing.undo.UndoableEdit
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.swing.undo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.swing.undo

  • Packages that use javax.swing.undo
    Package Description
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.
  • Classes in javax.swing.undo used by javax.swing.event
    Class and Description
    UndoableEdit
    An UndoableEdit represents an edit.
  • Classes in javax.swing.undo used by javax.swing.text
    Class and Description
    AbstractUndoableEdit
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
    CannotRedoException
    Thrown when an UndoableEdit is told to redo() and can't.
    CannotUndoException
    Thrown when an UndoableEdit is told to undo() and can't.
    CompoundEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
    UndoableEdit
    An UndoableEdit represents an edit.
  • Classes in javax.swing.undo used by javax.swing.undo
    Class and Description
    AbstractUndoableEdit
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
    CannotRedoException
    Thrown when an UndoableEdit is told to redo() and can't.
    CannotUndoException
    Thrown when an UndoableEdit is told to undo() and can't.
    CompoundEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
    StateEditable
    StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.
    UndoableEdit
    An UndoableEdit represents an edit.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StateEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class StateEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.StateEdit
  • All Implemented Interfaces:
    Serializable, UndoableEdit

    public class StateEdit
extends AbstractUndoableEdit

    StateEdit is a general edit for objects that change state. Objects being edited must conform to the StateEditable interface.

    This edit class works by asking an object to store it's state in Hashtables before and after editing occurs. Upon undo or redo the object is told to restore it's state from these Hashtables.

    A state edit is used as follows:
          // Create the edit during the "before" state of the object
      StateEdit newEdit = new StateEdit(myObject);
      // Modify the object
      myObject.someStateModifyingMethod();
      // "end" the edit when you are done modifying the object
      newEdit.end();

    Note that when a StateEdit ends, it removes redundant state from the Hashtables - A state Hashtable is not guaranteed to contain all keys/values placed into it when the state is stored!

    See Also:
    StateEditable

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected StateEditable object
      The object being edited
      protected Hashtable<Object,Object> postState
      The state information after the edit
      protected Hashtable<Object,Object> preState
      The state information prior to the edit
      protected static String | RCSID
      protected String undoRedoName
      The undo/redo presentation name

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • Constructor Summary

      Constructors
      Constructor and Description
      StateEdit(StateEditable anObject)
      Create and return a new StateEdit.
      StateEdit(StateEditable anObject, String name)
      Create and return a new StateEdit with a presentation name.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      void end()
      Gets the post-edit state of the StateEditable object and ends the edit.
      String getPresentationName()
      Gets the presentation name for this edit
      protected void | init(StateEditable anObject, String name)
      void redo()
      Tells the edited object to apply the state after the edit
      protected void removeRedundantState()
      Remove redundant key/values in state hashtables.
      void undo()
      Tells the edited object to apply the state prior to the edit

      • Methods inherited from class javax.swing.undo.AbstractUndoableEdit

        addEdit, canRedo, canUndo, die, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • RCSID

        protected static final String RCSID
        See Also:
        Constant Field Values

      • object

        protected StateEditable object
        The object being edited

      • preState

        protected Hashtable<Object,Object> preState
        The state information prior to the edit

      • postState

        protected Hashtable<Object,Object> postState
        The state information after the edit

      • undoRedoName

        protected String undoRedoName
        The undo/redo presentation name

    • Constructor Detail

      • StateEdit

        public StateEdit(StateEditable anObject)
        Create and return a new StateEdit.
        Parameters:
        anObject - The object to watch for changing state
        See Also:
        StateEdit

      • StateEdit

        public StateEdit(StateEditable anObject,
                 String name)
        Create and return a new StateEdit with a presentation name.
        Parameters:
        anObject - The object to watch for changing state
        name - The presentation name to be used for this edit
        See Also:
        StateEdit

    • Method Detail

      • init

        protected void init(StateEditable anObject,
                    String name)

      • end

        public void end()
        Gets the post-edit state of the StateEditable object and ends the edit.

      • undo

        public void undo()
        Tells the edited object to apply the state prior to the edit
        Specified by:
        undo in interface UndoableEdit
        Overrides:
        undo in class AbstractUndoableEdit
        See Also:
        AbstractUndoableEdit.canUndo()

      • redo

        public void redo()
        Tells the edited object to apply the state after the edit
        Specified by:
        redo in interface UndoableEdit
        Overrides:
        redo in class AbstractUndoableEdit
        See Also:
        AbstractUndoableEdit.canRedo()

      • getPresentationName

        public String getPresentationName()
        Gets the presentation name for this edit
        Specified by:
        getPresentationName in interface UndoableEdit
        Overrides:
        getPresentationName in class AbstractUndoableEdit
        Returns:
        the empty string ""
        See Also:
        AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

      • removeRedundantState

        protected void removeRedundantState()
        Remove redundant key/values in state hashtables.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StateEditable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Interface StateEditable

  • public interface StateEditable
    StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.
    See Also:
    StateEdit

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String RCSID
      Resource ID for this class.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void restoreState(Hashtable<?,?> state)
      Upon receiving this message the receiver should extract any relevant state out of state.
      void storeState(Hashtable<Object,Object> state)
      Upon receiving this message the receiver should place any relevant state into state.

    • Field Detail

      • RCSID

        static final String RCSID
        Resource ID for this class.
        See Also:
        Constant Field Values

    • Method Detail

      • storeState

        void storeState(Hashtable<Object,Object> state)
        Upon receiving this message the receiver should place any relevant state into state.

      • restoreState

        void restoreState(Hashtable<?,?> state)
        Upon receiving this message the receiver should extract any relevant state out of state.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UndoableEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Interface UndoableEdit

  • All Known Implementing Classes:
    AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractUndoableEdit, CompoundEdit, DefaultStyledDocument.AttributeUndoableEdit, StateEdit, UndoManager

    public interface UndoableEdit
    An UndoableEdit represents an edit. The edit may be undone, or if already undone the edit may be redone.

    UndoableEdit is designed to be used with the UndoManager. As UndoableEdits are generated by an UndoableEditListener they are typically added to the UndoManager. When an UndoableEdit is added to an UndoManager the following occurs (assuming end has not been called on the UndoManager):

    1. If the UndoManager contains edits it will call addEdit on the current edit passing in the new edit as the argument. If addEdit returns true the new edit is assumed to have been incorporated into the current edit and the new edit will not be added to the list of current edits. Edits can use addEdit as a way for smaller edits to be incorporated into a larger edit and treated as a single edit.
    2. If addEdit returns false replaceEdit is called on the new edit with the current edit passed in as the argument. This is the inverse of addEdit — if the new edit returns true from replaceEdit, the new edit replaces the current edit.
    The UndoManager makes use of isSignificant to determine how many edits should be undone or redone. The UndoManager will undo or redo all insignificant edits (isSignificant returns false) between the current edit and the last or next significant edit. addEdit and replaceEdit can be used to treat multiple edits as a single edit, returning false from isSignificant allows for treating can be used to have many smaller edits undone or redone at once. Similar functionality can also be done using the addEdit method.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoableEdit.
      boolean canRedo()
      Returns true if this edit may be redone.
      boolean canUndo()
      Returns true if this edit may be undone.
      void die()
      Informs the edit that it should no longer be used.
      String getPresentationName()
      Returns a localized, human-readable description of this edit, suitable for use in a change log, for example.
      String getRedoPresentationName()
      Returns a localized, human-readable description of the redoable form of this edit, suitable for use as a Redo menu item, for example.
      String getUndoPresentationName()
      Returns a localized, human-readable description of the undoable form of this edit, suitable for use as an Undo menu item, for example.
      boolean isSignificant()
      Returns true if this edit is considered significant.
      void redo()
      Re-applies the edit.
      boolean replaceEdit(UndoableEdit anEdit)
      Returns true if this UndoableEdit should replace anEdit.
      void undo()
      Undo the edit.

    • Method Detail

      • undo

        void undo()
   throws CannotUndoException
        Undo the edit.
        Throws:
        CannotUndoException - if this edit can not be undone

      • canUndo

        boolean canUndo()
        Returns true if this edit may be undone.
        Returns:
        true if this edit may be undone

      • redo

        void redo()
   throws CannotRedoException
        Re-applies the edit.
        Throws:
        CannotRedoException - if this edit can not be redone

      • canRedo

        boolean canRedo()
        Returns true if this edit may be redone.
        Returns:
        true if this edit may be redone

      • die

        void die()
        Informs the edit that it should no longer be used. Once an UndoableEdit has been marked as dead it can no longer be undone or redone.

        This is a useful hook for cleaning up state no longer needed once undoing or redoing is impossible--for example, deleting file resources used by objects that can no longer be undeleted. UndoManager calls this before it dequeues edits.

        Note that this is a one-way operation. There is no "un-die" method.

        See Also:
        CompoundEdit.die()

      • addEdit

        boolean addEdit(UndoableEdit anEdit)
        Adds an UndoableEdit to this UndoableEdit. This method can be used to coalesce smaller edits into a larger compound edit. For example, text editors typically allow undo operations to apply to words or sentences. The text editor may choose to generate edits on each key event, but allow those edits to be coalesced into a more user-friendly unit, such as a word. In this case, the UndoableEdit would override addEdit to return true when the edits may be coalesced.

        A return value of true indicates anEdit was incorporated into this edit. A return value of false indicates anEdit may not be incorporated into this edit.

        Typically the receiver is already in the queue of a UndoManager (or other UndoableEditListener), and is being given a chance to incorporate anEdit rather than letting it be added to the queue in turn.

        If true is returned, from now on anEdit must return false from canUndo and canRedo, and must throw the appropriate exception on undo or redo.

        Parameters:
        anEdit - the edit to be added
        Returns:
        true if anEdit may be incorporated into this edit

      • replaceEdit

        boolean replaceEdit(UndoableEdit anEdit)
        Returns true if this UndoableEdit should replace anEdit. This method is used by CompoundEdit and the UndoManager; it is called if anEdit could not be added to the current edit (addEdit returns false).

        This method provides a way for an edit to replace an existing edit.

        This message is the opposite of addEdit--anEdit has typically already been queued in an UndoManager (or other UndoableEditListener), and the receiver is being given a chance to take its place.

        If true is returned, from now on anEdit must return false from canUndo() and canRedo(), and must throw the appropriate exception on undo() or redo().

        Parameters:
        anEdit - the edit that replaces the current edit
        Returns:
        true if this edit should replace anEdit

      • isSignificant

        boolean isSignificant()
        Returns true if this edit is considered significant. A significant edit is typically an edit that should be presented to the user, perhaps on a menu item or tooltip. The UndoManager will undo, or redo, all insignificant edits to the next significant edit.
        Returns:
        true if this edit is significant

      • getPresentationName

        String getPresentationName()
        Returns a localized, human-readable description of this edit, suitable for use in a change log, for example.
        Returns:
        description of this edit

      • getUndoPresentationName

        String getUndoPresentationName()
        Returns a localized, human-readable description of the undoable form of this edit, suitable for use as an Undo menu item, for example. This is typically derived from getPresentationName.
        Returns:
        a description of the undoable form of this edit

      • getRedoPresentationName

        String getRedoPresentationName()
        Returns a localized, human-readable description of the redoable form of this edit, suitable for use as a Redo menu item, for example. This is typically derived from getPresentationName.
        Returns:
        a description of the redoable form of this edit
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UndoableEditSupport (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class UndoableEditSupport

  • java.lang.Object
    • javax.swing.undo.UndoableEditSupport

  • public class UndoableEditSupport
extends Object
    A support class used for managing UndoableEdit listeners.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected CompoundEdit | compoundEdit
      protected Vector<UndoableEditListener> | listeners
      protected Object | realSource
      protected int | updateLevel

    • Constructor Summary

      Constructors
      Constructor and Description
      UndoableEditSupport()
      Constructs an UndoableEditSupport object.
      UndoableEditSupport(Object r)
      Constructs an UndoableEditSupport object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      protected void _postEdit(UndoableEdit e)
      Called only from postEdit and endUpdate.
      void addUndoableEditListener(UndoableEditListener l)
      Registers an UndoableEditListener.
      void | beginUpdate()
      protected CompoundEdit createCompoundEdit()
      Called only from beginUpdate.
      void endUpdate()
      DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
      UndoableEditListener[] getUndoableEditListeners()
      Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().
      int getUpdateLevel()
      Returns the update level value.
      void postEdit(UndoableEdit e)
      DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
      void removeUndoableEditListener(UndoableEditListener l)
      Removes an UndoableEditListener.
      String toString()
      Returns a string that displays and identifies this object's properties.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • updateLevel

        protected int updateLevel

      • compoundEdit

        protected CompoundEdit compoundEdit

      • listeners

        protected Vector<UndoableEditListener> listeners

      • realSource

        protected Object realSource

    • Constructor Detail

      • UndoableEditSupport

        public UndoableEditSupport()
        Constructs an UndoableEditSupport object.

      • UndoableEditSupport

        public UndoableEditSupport(Object r)
        Constructs an UndoableEditSupport object.
        Parameters:
        r - an Object

    • Method Detail

      • addUndoableEditListener

        public void addUndoableEditListener(UndoableEditListener l)
        Registers an UndoableEditListener. The listener is notified whenever an edit occurs which can be undone.
        Parameters:
        l - an UndoableEditListener object
        See Also:
        removeUndoableEditListener(javax.swing.event.UndoableEditListener)

      • removeUndoableEditListener

        public void removeUndoableEditListener(UndoableEditListener l)
        Removes an UndoableEditListener.
        Parameters:
        l - the UndoableEditListener object to be removed
        See Also:
        addUndoableEditListener(javax.swing.event.UndoableEditListener)

      • getUndoableEditListeners

        public UndoableEditListener[] getUndoableEditListeners()
        Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().
        Returns:
        all of the UndoableEditListeners added or an empty array if no listeners have been added
        Since:
        1.4

      • _postEdit

        protected void _postEdit(UndoableEdit e)
        Called only from postEdit and endUpdate. Calls undoableEditHappened in all listeners. No synchronization is performed here, since the two calling methods are synchronized.

      • postEdit

        public void postEdit(UndoableEdit e)
        DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners. It is unwise to call this method from one of its listeners.

      • getUpdateLevel

        public int getUpdateLevel()
        Returns the update level value.
        Returns:
        an integer representing the update level

      • beginUpdate

        public void beginUpdate()

      • createCompoundEdit

        protected CompoundEdit createCompoundEdit()
        Called only from beginUpdate. Exposed here for subclasses' use.

      • endUpdate

        public void endUpdate()
        DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners. It is unwise to call this method from one of its listeners.

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        Overrides:
        toString in class Object
        Returns:
        a String representation of this object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UndoManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.swing.undo

Class UndoManager

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.CompoundEdit
        • javax.swing.undo.UndoManager
  • All Implemented Interfaces:
    Serializable, EventListener, UndoableEditListener, UndoableEdit

    public class UndoManager
extends CompoundEdit
implements UndoableEditListener
    UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits. There are two ways to add edits to an UndoManager. Add the edit directly using the addEdit method, or add the UndoManager to a bean that supports UndoableEditListener. The following examples creates an UndoManager and adds it as an UndoableEditListener to a JTextField:
       UndoManager undoManager = new UndoManager();
   JTextField tf = ...;
   tf.getDocument().addUndoableEditListener(undoManager);

    UndoManager maintains an ordered list of edits and the index of the next edit in that list. The index of the next edit is either the size of the current list of edits, or if undo has been invoked it corresponds to the index of the last significant edit that was undone. When undo is invoked all edits from the index of the next edit to the last significant edit are undone, in reverse order. For example, consider an UndoManager consisting of the following edits: A b c D. Edits with a upper-case letter in bold are significant, those in lower-case and italicized are insignificant.

    Figure 1

    As shown in figure 1, if D was just added, the index of the next edit will be 4. Invoking undo results in invoking undo on D and setting the index of the next edit to 3 (edit c), as shown in the following figure.

    Figure 2

    The last significant edit is A, so that invoking undo again invokes undo on c, b, and A, in that order, setting the index of the next edit to 0, as shown in the following figure.

    Figure 3

    Invoking redo results in invoking redo on all edits between the index of the next edit and the next significant edit (or the end of the list). Continuing with the previous example if redo were invoked, redo would in turn be invoked on A, b and c. In addition the index of the next edit is set to 3 (as shown in figure 2).

    Adding an edit to an UndoManager results in removing all edits from the index of the next edit to the end of the list. Continuing with the previous example, if a new edit, e, is added the edit D is removed from the list (after having die invoked on it). If c is not incorporated by the next edit (c.addEdit(e) returns true), or replaced by it (e.replaceEdit(c) returns true), the new edit is added after c, as shown in the following figure.

    Figure 4

    Once end has been invoked on an UndoManager the superclass behavior is used for all UndoableEdit methods. Refer to CompoundEdit for more details on its behavior.

    Unlike the rest of Swing, this class is thread safe.

    Warning: Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    • Field Summary

      • Fields inherited from class javax.swing.undo.CompoundEdit

        edits

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • Constructor Summary

      Constructors
      Constructor and Description
      UndoManager()
      Creates a new UndoManager.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoManager, if it's possible.
      boolean canRedo()
      Returns true if edits may be redone.
      boolean canUndo()
      Returns true if edits may be undone.
      boolean canUndoOrRedo()
      Returns true if it is possible to invoke undo or redo.
      void discardAllEdits()
      Empties the undo manager sending each edit a die message in the process.
      protected UndoableEdit editToBeRedone()
      Returns the the next significant edit to be redone if redo is invoked.
      protected UndoableEdit editToBeUndone()
      Returns the the next significant edit to be undone if undo is invoked.
      void end()
      Turns this UndoManager into a normal CompoundEdit.
      int getLimit()
      Returns the maximum number of edits this UndoManager holds.
      String getRedoPresentationName()
      Returns a description of the redoable form of this edit.
      String getUndoOrRedoPresentationName()
      Convenience method that returns either getUndoPresentationName or getRedoPresentationName.
      String getUndoPresentationName()
      Returns a description of the undoable form of this edit.
      void redo()
      Redoes the appropriate edits.
      protected void redoTo(UndoableEdit edit)
      Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
      void setLimit(int l)
      Sets the maximum number of edits this UndoManager holds.
      String toString()
      Returns a string that displays and identifies this object's properties.
      protected void trimEdits(int from, int to)
      Removes edits in the specified range.
      protected void trimForLimit()
      Reduces the number of queued edits to a range of size limit, centered on the index of the next edit.
      void undo()
      Undoes the appropriate edits.
      void undoableEditHappened(UndoableEditEvent e)
      An UndoableEditListener method.
      void undoOrRedo()
      Convenience method that invokes one of undo or redo.
      protected void undoTo(UndoableEdit edit)
      Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.

      • Methods inherited from class javax.swing.undo.CompoundEdit

        die, getPresentationName, isInProgress, isSignificant, lastEdit

      • Methods inherited from class javax.swing.undo.AbstractUndoableEdit

        replaceEdit

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UndoManager

        public UndoManager()
        Creates a new UndoManager.

    • Method Detail

      • getLimit

        public int getLimit()
        Returns the maximum number of edits this UndoManager holds. A value less than 0 indicates the number of edits is not limited.
        Returns:
        the maximum number of edits this UndoManager holds
        See Also:
        addEdit(javax.swing.undo.UndoableEdit), setLimit(int)

      • discardAllEdits

        public void discardAllEdits()
        Empties the undo manager sending each edit a die message in the process.
        See Also:
        AbstractUndoableEdit.die()

      • trimForLimit

        protected void trimForLimit()
        Reduces the number of queued edits to a range of size limit, centered on the index of the next edit.

      • trimEdits

        protected void trimEdits(int from,
                         int to)
        Removes edits in the specified range. All edits in the given range (inclusive, and in reverse order) will have die invoked on them and are removed from the list of edits. This has no effect if from > to.
        Parameters:
        from - the minimum index to remove
        to - the maximum index to remove

      • setLimit

        public void setLimit(int l)
        Sets the maximum number of edits this UndoManager holds. A value less than 0 indicates the number of edits is not limited. If edits need to be discarded to shrink the limit, die will be invoked on them in the reverse order they were added. The default is 100.
        Parameters:
        l - the new limit
        Throws:
        RuntimeException - if this UndoManager is not in progress (end has been invoked)
        See Also:
        CompoundEdit.isInProgress(),
end(),
addEdit(javax.swing.undo.UndoableEdit),
getLimit()

      • editToBeUndone

        protected UndoableEdit editToBeUndone()
        Returns the the next significant edit to be undone if undo is invoked. This returns null if there are no edits to be undone.
        Returns:
        the next significant edit to be undone

      • editToBeRedone

        protected UndoableEdit editToBeRedone()
        Returns the the next significant edit to be redone if redo is invoked. This returns null if there are no edits to be redone.
        Returns:
        the next significant edit to be redone

      • undoTo

        protected void undoTo(UndoableEdit edit)
               throws CannotUndoException
        Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
        Throws:
        CannotUndoException - if one of the edits throws CannotUndoException

      • redoTo

        protected void redoTo(UndoableEdit edit)
               throws CannotRedoException
        Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
        Throws:
        CannotRedoException - if one of the edits throws CannotRedoException

      • undoOrRedo

        public void undoOrRedo()
                throws CannotRedoException,
                       CannotUndoException
        Convenience method that invokes one of undo or redo. If any edits have been undone (the index of the next edit is less than the length of the edits list) this invokes redo, otherwise it invokes undo.
        Throws:
        CannotUndoException - if one of the edits throws CannotUndoException
        CannotRedoException - if one of the edits throws CannotRedoException
        See Also:
        canUndoOrRedo(), getUndoOrRedoPresentationName()

      • canUndoOrRedo

        public boolean canUndoOrRedo()
        Returns true if it is possible to invoke undo or redo.
        Returns:
        true if invoking canUndoOrRedo is valid
        See Also:
        undoOrRedo()

      • undo

        public void undo()
          throws CannotUndoException
        Undoes the appropriate edits. If end has been invoked this calls through to the superclass, otherwise this invokes undo on all edits between the index of the next edit and the last significant edit, updating the index of the next edit appropriately.
        Specified by:
        undo in interface UndoableEdit
        Overrides:
        undo in class CompoundEdit
        Throws:
        CannotUndoException - if one of the edits throws CannotUndoException or there are no edits to be undone
        See Also:
        CompoundEdit.end(),
canUndo(),
editToBeUndone()

      • canUndo

        public boolean canUndo()
        Returns true if edits may be undone. If end has been invoked, this returns the value from super. Otherwise this returns true if there are any edits to be undone (editToBeUndone returns non-null).
        Specified by:
        canUndo in interface UndoableEdit
        Overrides:
        canUndo in class CompoundEdit
        Returns:
        true if there are edits to be undone
        See Also:
        CompoundEdit.canUndo(), editToBeUndone()

      • redo

        public void redo()
          throws CannotRedoException
        Redoes the appropriate edits. If end has been invoked this calls through to the superclass. Otherwise this invokes redo on all edits between the index of the next edit and the next significant edit, updating the index of the next edit appropriately.
        Specified by:
        redo in interface UndoableEdit
        Overrides:
        redo in class CompoundEdit
        Throws:
        CannotRedoException - if one of the edits throws CannotRedoException or there are no edits to be redone
        See Also:
        CompoundEdit.end(),
canRedo(),
editToBeRedone()

      • canRedo

        public boolean canRedo()
        Returns true if edits may be redone. If end has been invoked, this returns the value from super. Otherwise, this returns true if there are any edits to be redone (editToBeRedone returns non-null).
        Specified by:
        canRedo in interface UndoableEdit
        Overrides:
        canRedo in class CompoundEdit
        Returns:
        true if there are edits to be redone
        See Also:
        CompoundEdit.canRedo(), editToBeRedone()

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        Adds an UndoableEdit to this UndoManager, if it's possible. This removes all edits from the index of the next edit to the end of the edits list. If end has been invoked the edit is not added and false is returned. If end hasn't been invoked this returns true.
        Specified by:
        addEdit in interface UndoableEdit
        Overrides:
        addEdit in class CompoundEdit
        Parameters:
        anEdit - the edit to be added
        Returns:
        true if anEdit can be incorporated into this edit
        See Also:
        CompoundEdit.end(), CompoundEdit.addEdit(javax.swing.undo.UndoableEdit)

      • end

        public void end()
        Turns this UndoManager into a normal CompoundEdit. This removes all edits that have been undone.
        Overrides:
        end in class CompoundEdit
        See Also:
        CompoundEdit.end()

      • getUndoOrRedoPresentationName

        public String getUndoOrRedoPresentationName()
        Convenience method that returns either getUndoPresentationName or getRedoPresentationName. If the index of the next edit equals the size of the edits list, getUndoPresentationName is returned, otherwise getRedoPresentationName is returned.
        Returns:
        undo or redo name

      • getUndoPresentationName

        public String getUndoPresentationName()
        Returns a description of the undoable form of this edit. If end has been invoked this calls into super. Otherwise if there are edits to be undone, this returns the value from the next significant edit that will be undone. If there are no edits to be undone and end has not been invoked this returns the value from the UIManager property "AbstractUndoableEdit.undoText".
        Specified by:
        getUndoPresentationName in interface UndoableEdit
        Overrides:
        getUndoPresentationName in class CompoundEdit
        Returns:
        a description of the undoable form of this edit
        See Also:
        undo(), CompoundEdit.getUndoPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Returns a description of the redoable form of this edit. If end has been invoked this calls into super. Otherwise if there are edits to be redone, this returns the value from the next significant edit that will be redone. If there are no edits to be redone and end has not been invoked this returns the value from the UIManager property "AbstractUndoableEdit.redoText".
        Specified by:
        getRedoPresentationName in interface UndoableEdit
        Overrides:
        getRedoPresentationName in class CompoundEdit
        Returns:
        a description of the redoable form of this edit
        See Also:
        redo(), CompoundEdit.getRedoPresentationName()

      • undoableEditHappened

        public void undoableEditHappened(UndoableEditEvent e)
        An UndoableEditListener method. This invokes addEdit with e.getEdit().
        Specified by:
        undoableEditHappened in interface UndoableEditListener
        Parameters:
        e - the UndoableEditEvent the UndoableEditEvent will be added from
        See Also:
        addEdit(javax.swing.undo.UndoableEdit)

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        Overrides:
        toString in class CompoundEdit
        Returns:
        a String representation of this object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.AbstractUndoableEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.AbstractUndoableEdit

  • Packages that use AbstractUndoableEdit
    Package Description
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of AbstractUndoableEdit in javax.swing.text

      Subclasses of AbstractUndoableEdit in javax.swing.text
      Modifier and Type Class and Description
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.
      static class  AbstractDocument.ElementEdit
      An implementation of ElementChange that can be added to the document event.
      static class  DefaultStyledDocument.AttributeUndoableEdit
      An UndoableEdit used to remember AttributeSet changes to an Element.

    • Uses of AbstractUndoableEdit in javax.swing.undo

      Subclasses of AbstractUndoableEdit in javax.swing.undo
      Modifier and Type Class and Description
      class  CompoundEdit
      A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
      class  StateEdit
      StateEdit is a general edit for objects that change state.
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.CannotRedoException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.CannotRedoException

  • Packages that use CannotRedoException
    Package Description
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of CannotRedoException in javax.swing.text

      Methods in javax.swing.text that throw CannotRedoException
      Modifier and Type Method and Description
      void DefaultStyledDocument.AttributeUndoableEdit.redo()
      Redoes a change.
      void AbstractDocument.DefaultDocumentEvent.redo()
      Redoes a change.
      void AbstractDocument.ElementEdit.redo()
      Redoes a change.

    • Uses of CannotRedoException in javax.swing.undo

      Methods in javax.swing.undo that throw CannotRedoException
      Modifier and Type Method and Description
      void AbstractUndoableEdit.redo()
      Throws CannotRedoException if canRedo returns false.
      void UndoManager.redo()
      Redoes the appropriate edits.
      void CompoundEdit.redo()
      Sends redo to all contained UndoableEdits in the order in which they were added.
      void UndoableEdit.redo()
      Re-applies the edit.
      protected void UndoManager.redoTo(UndoableEdit edit)
      Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
      void UndoManager.undoOrRedo()
      Convenience method that invokes one of undo or redo.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.CannotUndoException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.CannotUndoException

  • Packages that use CannotUndoException
    Package Description
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of CannotUndoException in javax.swing.text

      Methods in javax.swing.text that throw CannotUndoException
      Modifier and Type Method and Description
      void DefaultStyledDocument.AttributeUndoableEdit.undo()
      Undoes a change.
      void AbstractDocument.DefaultDocumentEvent.undo()
      Undoes a change.
      void AbstractDocument.ElementEdit.undo()
      Undoes a change.

    • Uses of CannotUndoException in javax.swing.undo

      Methods in javax.swing.undo that throw CannotUndoException
      Modifier and Type Method and Description
      void AbstractUndoableEdit.undo()
      Throws CannotUndoException if canUndo returns false.
      void UndoManager.undo()
      Undoes the appropriate edits.
      void CompoundEdit.undo()
      Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.
      void UndoableEdit.undo()
      Undo the edit.
      void UndoManager.undoOrRedo()
      Convenience method that invokes one of undo or redo.
      protected void UndoManager.undoTo(UndoableEdit edit)
      Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.CompoundEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.CompoundEdit

  • Packages that use CompoundEdit
    Package Description
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of CompoundEdit in javax.swing.text

      Subclasses of CompoundEdit in javax.swing.text
      Modifier and Type Class and Description
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.

    • Uses of CompoundEdit in javax.swing.undo

      Subclasses of CompoundEdit in javax.swing.undo
      Modifier and Type Class and Description
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
      Fields in javax.swing.undo declared as CompoundEdit
      Modifier and Type | Field and Description
      protected CompoundEdit | UndoableEditSupport.compoundEdit
      Methods in javax.swing.undo that return CompoundEdit
      Modifier and Type Method and Description
      protected CompoundEdit UndoableEditSupport.createCompoundEdit()
      Called only from beginUpdate.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.StateEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.StateEdit

No usage of javax.swing.undo.StateEdit
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.undo.StateEditable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.undo.StateEditable

  • Packages that use StateEditable
    Package Description
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of StateEditable in javax.swing.undo

      Fields in javax.swing.undo declared as StateEditable
      Modifier and Type Field and Description
      protected StateEditable StateEdit.object
      The object being edited
      Methods in javax.swing.undo with parameters of type StateEditable
      Modifier and Type | Method and Description
      protected void | StateEdit.init(StateEditable anObject, String name)
      Constructors in javax.swing.undo with parameters of type StateEditable
      Constructor and Description
      StateEdit(StateEditable anObject)
      Create and return a new StateEdit.
      StateEdit(StateEditable anObject, String name)
      Create and return a new StateEdit with a presentation name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.swing.undo.UndoableEdit (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.swing.undo.UndoableEdit

  • Packages that use UndoableEdit
    Package Description
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of UndoableEdit in javax.swing.event

      Methods in javax.swing.event that return UndoableEdit
      Modifier and Type Method and Description
      UndoableEdit UndoableEditEvent.getEdit()
      Returns the edit value.
      Constructors in javax.swing.event with parameters of type UndoableEdit
      Constructor and Description
      UndoableEditEvent(Object source, UndoableEdit edit)
      Constructs an UndoableEditEvent object.

    • Uses of UndoableEdit in javax.swing.text

      Classes in javax.swing.text that implement UndoableEdit
      Modifier and Type Class and Description
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.
      static class  AbstractDocument.ElementEdit
      An implementation of ElementChange that can be added to the document event.
      static class  DefaultStyledDocument.AttributeUndoableEdit
      An UndoableEdit used to remember AttributeSet changes to an Element.
      Methods in javax.swing.text that return UndoableEdit
      Modifier and Type Method and Description
      UndoableEdit StringContent.insertString(int where, String str)
      Inserts a string into the content.
      UndoableEdit AbstractDocument.Content.insertString(int where, String str)
      Inserts a string of characters into the sequence.
      UndoableEdit GapContent.insertString(int where, String str)
      Inserts a string into the content.
      UndoableEdit StringContent.remove(int where, int nitems)
      Removes part of the content.
      UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
      Removes some portion of the sequence.
      UndoableEdit GapContent.remove(int where, int nitems)
      Removes part of the content.
      Methods in javax.swing.text with parameters of type UndoableEdit
      Modifier and Type Method and Description
      boolean AbstractDocument.DefaultDocumentEvent.addEdit(UndoableEdit anEdit)
      Adds a document edit.

    • Uses of UndoableEdit in javax.swing.undo

      Classes in javax.swing.undo that implement UndoableEdit
      Modifier and Type Class and Description
      class  AbstractUndoableEdit
      An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
      class  CompoundEdit
      A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
      class  StateEdit
      StateEdit is a general edit for objects that change state.
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
      Fields in javax.swing.undo with type parameters of type UndoableEdit
      Modifier and Type Field and Description
      protected Vector<UndoableEdit> CompoundEdit.edits
      The collection of UndoableEdits undone/redone en masse by this CompoundEdit.
      Methods in javax.swing.undo that return UndoableEdit
      Modifier and Type Method and Description
      protected UndoableEdit UndoManager.editToBeRedone()
      Returns the the next significant edit to be redone if redo is invoked.
      protected UndoableEdit UndoManager.editToBeUndone()
      Returns the the next significant edit to be undone if undo is invoked.
      protected UndoableEdit CompoundEdit.lastEdit()
      Returns the last UndoableEdit in edits, or null if edits is empty.
      Methods in javax.swing.undo with parameters of type UndoableEdit
      Modifier and Type Method and Description
      protected void UndoableEditSupport._postEdit(UndoableEdit e)
      Called only from postEdit and endUpdate.
      boolean AbstractUndoableEdit.addEdit(UndoableEdit anEdit)
      This default implementation returns false.
      boolean UndoManager.addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoManager, if it's possible.
      boolean CompoundEdit.addEdit(UndoableEdit anEdit)
      If this edit is inProgress, accepts anEdit and returns true.
      boolean UndoableEdit.addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoableEdit.
      void UndoableEditSupport.postEdit(UndoableEdit e)
      DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
      protected void UndoManager.redoTo(UndoableEdit edit)
      Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
      boolean AbstractUndoableEdit.replaceEdit(UndoableEdit anEdit)
      This default implementation returns false.
      boolean UndoableEdit.replaceEdit(UndoableEdit anEdit)
      Returns true if this UndoableEdit should replace anEdit.
      protected void UndoManager.undoTo(UndoableEdit edit)
      Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.UndoableEditSupport (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.UndoableEditSupport

No usage of javax.swing.undo.UndoableEditSupport
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.swing.undo.UndoManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.swing.undo.UndoManager

No usage of javax.swing.undo.UndoManager
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.tools (Java Platform SE 8 )

compact3 - javax.tools

Interfaces

  • Diagnostic
  • DiagnosticListener
  • DocumentationTool
  • DocumentationTool.DocumentationTask
  • FileObject
  • JavaCompiler
  • JavaCompiler.CompilationTask
  • JavaFileManager
  • JavaFileManager.Location
  • JavaFileObject
  • OptionChecker
  • StandardJavaFileManager
  • Tool

Classes

  • DiagnosticCollector
  • ForwardingFileObject
  • ForwardingJavaFileManager
  • ForwardingJavaFileObject
  • SimpleJavaFileObject
  • ToolProvider

Enums

  • Diagnostic.Kind
  • DocumentationTool.Location
  • JavaFileObject.Kind
  • StandardLocation


javax.tools (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.tools

Provides interfaces for tools which can be invoked from a program, for example, compilers.

See: Description

  • Interface Summary
    Interface Description
    Diagnostic<S>
    Interface for diagnostics from tools.
    DiagnosticListener<S>
    Interface for receiving diagnostics from tools.
    DocumentationTool
    Interface to invoke Java™ programming language documentation tools from programs.
    DocumentationTool.DocumentationTask
    Interface representing a future for a documentation task.
    FileObject
    File abstraction for tools.
    JavaCompiler
    Interface to invoke Java™ programming language compilers from programs.
    JavaCompiler.CompilationTask
    Interface representing a future for a compilation task.
    JavaFileManager
    File manager for tools operating on Java™ programming language source and class files.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
    OptionChecker
    Interface for recognizing options.
    StandardJavaFileManager
    File manager based on java.io.File.
    Tool
    Common interface for tools that can be invoked from a program.
  • Class Summary
    Class Description
    DiagnosticCollector<S>
    Provides an easy way to collect diagnostics in a list.
    ForwardingFileObject<F extends FileObject>
    Forwards calls to a given file object.
    ForwardingJavaFileManager<M extends JavaFileManager>
    Forwards calls to a given file manager.
    ForwardingJavaFileObject<F extends JavaFileObject>
    Forwards calls to a given file object.
    SimpleJavaFileObject
    Provides simple implementations for most methods in JavaFileObject.
    ToolProvider
    Provides methods for locating tool providers, for example, providers of compilers.
  • Enum Summary
    Enum Description
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    DocumentationTool.Location
    Locations specific to DocumentationTool.
    JavaFileObject.Kind
    Kinds of JavaFileObjects.
    StandardLocation
    Standard locations of file objects.

Package javax.tools Description

Provides interfaces for tools which can be invoked from a program, for example, compilers.

These interfaces and classes are required as part of the Java™ Platform, Standard Edition (Java SE), but there is no requirement to provide any tools implementing them.

Unless explicitly allowed, all methods in this package might throw a NullPointerException if given a null argument or if given a list or collection containing null elements. Similarly, no method may return null unless explicitly allowed.

This package is the home of the Java programming language compiler framework. This framework allows clients of the framework to locate and run compilers from programs. The framework also provides Service Provider Interfaces (SPI) for structured access to diagnostics (DiagnosticListener) as well as a file abstraction for overriding file access (JavaFileManager and JavaFileObject). See JavaCompiler for more details on using the SPI.

There is no requirement for a compiler at runtime. However, if a default compiler is provided, it can be located using the ToolProvider, for example:

JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();

It is possible to provide alternative compilers or tools through the service provider mechanism.

For example, if com.vendor.VendorJavaCompiler is a provider of the JavaCompiler tool then its jar file would contain the file META-INF/services/javax.tools.JavaCompiler. This file would contain the single line:

com.vendor.VendorJavaCompiler

If the jar file is on the class path, VendorJavaCompiler can be located using code like this:

JavaCompiler compiler = ServiceLoader.load(JavaCompiler.class).iterator().next();

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Diagnostic (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface Diagnostic<S>

  • Type Parameters:
    S - the type of source object used by this diagnostic

    public interface Diagnostic<S>
    Interface for diagnostics from tools. A diagnostic usually reports a problem at a specific position in a source file. However, not all diagnostics are associated with a position or a file.

    A position is a zero-based character offset from the beginning of a file. Negative values (except NOPOS) are not valid positions.

    Line and column numbers begin at 1. Negative values (except NOPOS) and 0 are not valid line or column numbers.

    Since:
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  Diagnostic.Kind
      Kinds of diagnostics, for example, error or warning.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static long NOPOS
      Used to signal that no position is available.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getCode()
      Gets a diagnostic code indicating the type of diagnostic.
      long getColumnNumber()
      Gets the column number of the character offset returned by getPosition().
      long getEndPosition()
      Gets the character offset from the beginning of the file associated with this diagnostic that indicates the end of the problem.
      Diagnostic.Kind getKind()
      Gets the kind of this diagnostic, for example, error or warning.
      long getLineNumber()
      Gets the line number of the character offset returned by getPosition().
      String getMessage(Locale locale)
      Gets a localized message for the given locale.
      long getPosition()
      Gets a character offset from the beginning of the source object associated with this diagnostic that indicates the location of the problem.
      S getSource()
      Gets the source object associated with this diagnostic.
      long getStartPosition()
      Gets the character offset from the beginning of the file associated with this diagnostic that indicates the start of the problem.

    • Field Detail

      • NOPOS

        static final long NOPOS
        Used to signal that no position is available.
        See Also:
        Constant Field Values

    • Method Detail

      • getKind

        Diagnostic.Kind getKind()
        Gets the kind of this diagnostic, for example, error or warning.
        Returns:
        the kind of this diagnostic

      • getSource

        S getSource()
        Gets the source object associated with this diagnostic.
        Returns:
        the source object associated with this diagnostic. null if no source object is associated with the diagnostic.

      • getPosition

        long getPosition()
        Gets a character offset from the beginning of the source object associated with this diagnostic that indicates the location of the problem. In addition, the following must be true:

        getStartPostion() <= getPosition()

        getPosition() <= getEndPosition()

        Returns:
        character offset from beginning of source; NOPOS if getSource() would return null or if no location is suitable

      • getStartPosition

        long getStartPosition()
        Gets the character offset from the beginning of the file associated with this diagnostic that indicates the start of the problem.
        Returns:
        offset from beginning of file; NOPOS if and only if getPosition() returns NOPOS

      • getEndPosition

        long getEndPosition()
        Gets the character offset from the beginning of the file associated with this diagnostic that indicates the end of the problem.
        Returns:
        offset from beginning of file; NOPOS if and only if getPosition() returns NOPOS

      • getLineNumber

        long getLineNumber()
        Gets the line number of the character offset returned by getPosition().
        Returns:
        a line number or NOPOS if and only if getPosition() returns NOPOS

      • getColumnNumber

        long getColumnNumber()
        Gets the column number of the character offset returned by getPosition().
        Returns:
        a column number or NOPOS if and only if getPosition() returns NOPOS

      • getCode

        String getCode()
        Gets a diagnostic code indicating the type of diagnostic. The code is implementation-dependent and might be null.
        Returns:
        a diagnostic code

      • getMessage

        String getMessage(Locale locale)
        Gets a localized message for the given locale. The actual message is implementation-dependent. If the locale is null use the default locale.
        Parameters:
        locale - a locale; might be null
        Returns:
        a localized message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Diagnostic.Kind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
compact3
javax.tools

Enum Diagnostic.Kind

  • java.lang.Object
    • java.lang.Enum<Diagnostic.Kind>
      • javax.tools.Diagnostic.Kind
  • All Implemented Interfaces:
    Serializable, Comparable<Diagnostic.Kind>
    Enclosing interface:
    Diagnostic<S>

    public static enum Diagnostic.Kind
extends Enum<Diagnostic.Kind>
    Kinds of diagnostics, for example, error or warning. The kind of a diagnostic can be used to determine how the diagnostic should be presented to the user. For example, errors might be colored red or prefixed with the word "Error", while warnings might be colored yellow or prefixed with the word "Warning". There is no requirement that the Kind should imply any inherent semantic meaning to the message of the diagnostic: for example, a tool might provide an option to report all warnings as errors.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ERROR
      Problem which prevents the tool's normal completion.
      MANDATORY_WARNING
      Problem similar to a warning, but is mandated by the tool's specification.
      NOTE
      Informative message from the tool.
      OTHER
      Diagnostic which does not fit within the other kinds.
      WARNING
      Problem which does not usually prevent the tool from completing normally.

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static Diagnostic.Kind valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Diagnostic.Kind[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ERROR

        public static final Diagnostic.Kind ERROR
        Problem which prevents the tool's normal completion.

      • WARNING

        public static final Diagnostic.Kind WARNING
        Problem which does not usually prevent the tool from completing normally.

      • MANDATORY_WARNING

        public static final Diagnostic.Kind MANDATORY_WARNING
        Problem similar to a warning, but is mandated by the tool's specification. For example, the Java™ Language Specification mandates warnings on certain unchecked operations and the use of deprecated methods.

      • NOTE

        public static final Diagnostic.Kind NOTE
        Informative message from the tool.

      • OTHER

        public static final Diagnostic.Kind OTHER
        Diagnostic which does not fit within the other kinds.

    • Method Detail

      • values

        public static Diagnostic.Kind[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Diagnostic.Kind c : Diagnostic.Kind.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Diagnostic.Kind valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DiagnosticCollector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Class DiagnosticCollector<S>

  • java.lang.Object
    • javax.tools.DiagnosticCollector<S>
  • Type Parameters:
    S - the type of source objects used by diagnostics received by this object
    All Implemented Interfaces:
    DiagnosticListener<S>

    public final class DiagnosticCollector<S>
extends Object
implements DiagnosticListener<S>
    Provides an easy way to collect diagnostics in a list.
    Since:
    1.6

    • Constructor Summary

      Constructors
      Constructor and Description
      DiagnosticCollector()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      List<Diagnostic<? extends S>> getDiagnostics()
      Gets a list view of diagnostics collected by this object.
      void report(Diagnostic<? extends S> diagnostic)
      Invoked when a problem is found.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DiagnosticCollector

        public DiagnosticCollector()

    • Method Detail

      • report

        public void report(Diagnostic<? extends S> diagnostic)
        Description copied from interface: DiagnosticListener
        Invoked when a problem is found.
        Specified by:
        report in interface DiagnosticListener<S>
        Parameters:
        diagnostic - a diagnostic representing the problem that was found

      • getDiagnostics

        public List<Diagnostic<? extends S>> getDiagnostics()
        Gets a list view of diagnostics collected by this object.
        Returns:
        a list view of diagnostics
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DiagnosticListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface DiagnosticListener<S>

  • Type Parameters:
    S - the type of source objects used by diagnostics received by this listener
    All Known Implementing Classes:
    DiagnosticCollector

    public interface DiagnosticListener<S>
    Interface for receiving diagnostics from tools.
    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void report(Diagnostic<? extends S> diagnostic)
      Invoked when a problem is found.

    • Method Detail

      • report

        void report(Diagnostic<? extends S> diagnostic)
        Invoked when a problem is found.
        Parameters:
        diagnostic - a diagnostic representing the problem that was found
        Throws:
        NullPointerException - if the diagnostic argument is null and the implementation cannot handle null arguments
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentationTool.DocumentationTask (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface DocumentationTool.DocumentationTask

  • All Superinterfaces:
    Callable<Boolean>
    Enclosing interface:
    DocumentationTool

    public static interface DocumentationTool.DocumentationTask
extends Callable<Boolean>
    Interface representing a future for a documentation task. The task has not yet started. To start the task, call the call method.

    Before calling the call method, additional aspects of the task can be configured, for example, by calling the setLocale method.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Boolean call()
      Performs this documentation task.
      void setLocale(Locale locale)
      Set the locale to be applied when formatting diagnostics and other localized data.

    • Method Detail

      • setLocale

        void setLocale(Locale locale)
        Set the locale to be applied when formatting diagnostics and other localized data.
        Parameters:
        locale - the locale to apply; null means apply no locale
        Throws:
        IllegalStateException - if the task has started

      • call

        Boolean call()
        Performs this documentation task. The task may only be performed once. Subsequent calls to this method throw IllegalStateException.
        Specified by:
        call in interface Callable<Boolean>
        Returns:
        true if and only all the files were processed without errors; false otherwise
        Throws:
        RuntimeException - if an unrecoverable error occurred in a user-supplied component. The cause will be the error in user code.
        IllegalStateException - if called more than once
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentationTool (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface DocumentationTool

  • All Superinterfaces:
    OptionChecker, Tool

    public interface DocumentationTool
extends Tool, OptionChecker
    Interface to invoke Java™ programming language documentation tools from programs.

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  DocumentationTool.DocumentationTask
      Interface representing a future for a documentation task.
      static class  DocumentationTool.Location
      Locations specific to DocumentationTool.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      DocumentationTool.DocumentationTask getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a documentation task with the given components and arguments.

      • Methods inherited from interface javax.tools.Tool

        getSourceVersions, run

      • Methods inherited from interface javax.tools.OptionChecker

        isSupportedOption

    • Method Detail

      • getTask

        DocumentationTool.DocumentationTask getTask(Writer out,
                                            JavaFileManager fileManager,
                                            DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                            Class<?> docletClass,
                                            Iterable<String> options,
                                            Iterable<? extends JavaFileObject> compilationUnits)
        Creates a future for a documentation task with the given components and arguments. The task might not have completed as described in the DocumentationTask interface.

        If a file manager is provided, it must be able to handle all locations defined in DocumentationTool.Location, as well as StandardLocation.SOURCE_PATH, StandardLocation.CLASS_PATH, and StandardLocation.PLATFORM_CLASS_PATH.

        Parameters:
        out - a Writer for additional output from the tool; use System.err if null
        fileManager - a file manager; if null use the tool's standard filemanager
        diagnosticListener - a diagnostic listener; if null use the tool's default method for reporting diagnostics
        docletClass - a class providing the necessary methods required of a doclet
        options - documentation tool options and doclet options, null means no options
        compilationUnits - the compilation units to compile, null means no compilation units
        Returns:
        an object representing the compilation
        Throws:
        RuntimeException - if an unrecoverable error occurred in a user supplied component. The cause will be the error in user code.
        IllegalArgumentException - if any of the given compilation units are of other kind than source

      • getStandardFileManager

        StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                               Locale locale,
                                               Charset charset)
        Gets a new instance of the standard file manager implementation for this tool. The file manager will use the given diagnostic listener for producing any non-fatal diagnostics. Fatal errors will be signaled with the appropriate exceptions.

        The standard file manager will be automatically reopened if it is accessed after calls to flush or close. The standard file manager must be usable with other tools.

        Parameters:
        diagnosticListener - a diagnostic listener for non-fatal diagnostics; if null use the compiler's default method for reporting diagnostics
        locale - the locale to apply when formatting diagnostics; null means the default locale.
        charset - the character set used for decoding bytes; if null use the platform default
        Returns:
        the standard file manager
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentationTool.Location (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
compact3
javax.tools

Enum DocumentationTool.Location

  • java.lang.Object
    • java.lang.Enum<DocumentationTool.Location>
      • javax.tools.DocumentationTool.Location
  • All Implemented Interfaces:
    Serializable, Comparable<DocumentationTool.Location>, JavaFileManager.Location
    Enclosing interface:
    DocumentationTool

    public static enum DocumentationTool.Location
extends Enum<DocumentationTool.Location>
implements JavaFileManager.Location
    Locations specific to DocumentationTool.
    See Also:
    StandardLocation

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      DOCLET_PATH
      Location to search for doclets.
      DOCUMENTATION_OUTPUT
      Location of new documentation files.
      TAGLET_PATH
      Location to search for taglets.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getName()
      Gets the name of this location.
      boolean isOutputLocation()
      Determines if this is an output location.
      static DocumentationTool.Location valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DocumentationTool.Location[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • DOCUMENTATION_OUTPUT

        public static final DocumentationTool.Location DOCUMENTATION_OUTPUT
        Location of new documentation files.

      • DOCLET_PATH

        public static final DocumentationTool.Location DOCLET_PATH
        Location to search for doclets.

      • TAGLET_PATH

        public static final DocumentationTool.Location TAGLET_PATH
        Location to search for taglets.

    • Method Detail

      • values

        public static DocumentationTool.Location[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (DocumentationTool.Location c : DocumentationTool.Location.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static DocumentationTool.Location valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • getName

        public String getName()
        Description copied from interface: JavaFileManager.Location
        Gets the name of this location.
        Specified by:
        getName in interface JavaFileManager.Location
        Returns:
        a name

      • isOutputLocation

        public boolean isOutputLocation()
        Description copied from interface: JavaFileManager.Location
        Determines if this is an output location. An output location is a location that is conventionally used for output.
        Specified by:
        isOutputLocation in interface JavaFileManager.Location
        Returns:
        true if this is an output location, false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface FileObject

  • All Known Subinterfaces:
    JavaFileObject
    All Known Implementing Classes:
    ForwardingFileObject, ForwardingJavaFileObject, SimpleJavaFileObject

    public interface FileObject
    File abstraction for tools. In this context, file means an abstraction of regular files and other sources of data. For example, a file object can be used to represent regular files, memory cache, or data in databases.

    All methods in this interface might throw a SecurityException if a security exception occurs.

    Unless explicitly allowed, all methods in this interface might throw a NullPointerException if given a null argument.

    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean delete()
      Deletes this file object.
      CharSequence getCharContent(boolean ignoreEncodingErrors)
      Gets the character content of this file object, if available.
      long getLastModified()
      Gets the time this file object was last modified.
      String getName()
      Gets a user-friendly name for this file object.
      InputStream openInputStream()
      Gets an InputStream for this file object.
      OutputStream openOutputStream()
      Gets an OutputStream for this file object.
      Reader openReader(boolean ignoreEncodingErrors)
      Gets a reader for this object.
      Writer openWriter()
      Gets a Writer for this file object.
      URI toUri()
      Returns a URI identifying this file object.

    • Method Detail

      • toUri

        URI toUri()
        Returns a URI identifying this file object.
        Returns:
        a URI

      • getName

        String getName()
        Gets a user-friendly name for this file object. The exact value returned is not specified but implementations should take care to preserve names as given by the user. For example, if the user writes the filename "BobsApp\Test.java" on the command line, this method should return "BobsApp\Test.java" whereas the toUri method might return file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java.
        Returns:
        a user-friendly name

      • openInputStream

        InputStream openInputStream()
                     throws IOException
        Gets an InputStream for this file object.
        Returns:
        an InputStream
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openOutputStream

        OutputStream openOutputStream()
                       throws IOException
        Gets an OutputStream for this file object.
        Returns:
        an OutputStream
        Throws:
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openReader

        Reader openReader(boolean ignoreEncodingErrors)
           throws IOException
        Gets a reader for this object. The returned reader will replace bytes that cannot be decoded with the default translation character. In addition, the reader may report a diagnostic unless ignoreEncodingErrors is true.
        Parameters:
        ignoreEncodingErrors - ignore encoding errors if true
        Returns:
        a Reader
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getCharContent

        CharSequence getCharContent(boolean ignoreEncodingErrors)
                     throws IOException
        Gets the character content of this file object, if available. Any byte that cannot be decoded will be replaced by the default translation character. In addition, a diagnostic may be reported unless ignoreEncodingErrors is true.
        Parameters:
        ignoreEncodingErrors - ignore encoding errors if true
        Returns:
        a CharSequence if available; null otherwise
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • openWriter

        Writer openWriter()
           throws IOException
        Gets a Writer for this file object.
        Returns:
        a Writer
        Throws:
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getLastModified

        long getLastModified()
        Gets the time this file object was last modified. The time is measured in milliseconds since the epoch (00:00:00 GMT, January 1, 1970).
        Returns:
        the time this file object was last modified; or 0 if the file object does not exist, if an I/O error occurred, or if the operation is not supported

      • delete

        boolean delete()
        Deletes this file object. In case of errors, returns false.
        Returns:
        true if and only if this file object is successfully deleted; false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardingFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Class ForwardingFileObject<F extends FileObject>

  • java.lang.Object
    • javax.tools.ForwardingFileObject<F>
  • Type Parameters:
    F - the kind of file object forwarded to by this object
    All Implemented Interfaces:
    FileObject
    Direct Known Subclasses:
    ForwardingJavaFileObject

    public class ForwardingFileObject<F extends FileObject>
extends Object
implements FileObject
    Forwards calls to a given file object. Subclasses of this class might override some of these methods and might also provide additional fields and methods.
    Since:
    1.6

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected F fileObject
      The file object which all methods are delegated to.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ForwardingFileObject(F fileObject)
      Creates a new instance of ForwardingFileObject.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean delete()
      Deletes this file object.
      CharSequence getCharContent(boolean ignoreEncodingErrors)
      Gets the character content of this file object, if available.
      long getLastModified()
      Gets the time this file object was last modified.
      String getName()
      Gets a user-friendly name for this file object.
      InputStream openInputStream()
      Gets an InputStream for this file object.
      OutputStream openOutputStream()
      Gets an OutputStream for this file object.
      Reader openReader(boolean ignoreEncodingErrors)
      Gets a reader for this object.
      Writer openWriter()
      Gets a Writer for this file object.
      URI toUri()
      Returns a URI identifying this file object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • fileObject

        protected final F extends FileObject fileObject
        The file object which all methods are delegated to.

    • Constructor Detail

      • ForwardingFileObject

        protected ForwardingFileObject(F fileObject)
        Creates a new instance of ForwardingFileObject.
        Parameters:
        fileObject - delegate to this file object

    • Method Detail

      • toUri

        public URI toUri()
        Description copied from interface: FileObject
        Returns a URI identifying this file object.
        Specified by:
        toUri in interface FileObject
        Returns:
        a URI

      • getName

        public String getName()
        Description copied from interface: FileObject
        Gets a user-friendly name for this file object. The exact value returned is not specified but implementations should take care to preserve names as given by the user. For example, if the user writes the filename "BobsApp\Test.java" on the command line, this method should return "BobsApp\Test.java" whereas the toUri method might return file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java.
        Specified by:
        getName in interface FileObject
        Returns:
        a user-friendly name

      • openInputStream

        public InputStream openInputStream()
                            throws IOException
        Description copied from interface: FileObject
        Gets an InputStream for this file object.
        Specified by:
        openInputStream in interface FileObject
        Returns:
        an InputStream
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openOutputStream

        public OutputStream openOutputStream()
                              throws IOException
        Description copied from interface: FileObject
        Gets an OutputStream for this file object.
        Specified by:
        openOutputStream in interface FileObject
        Returns:
        an OutputStream
        Throws:
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openReader

        public Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
        Description copied from interface: FileObject
        Gets a reader for this object. The returned reader will replace bytes that cannot be decoded with the default translation character. In addition, the reader may report a diagnostic unless ignoreEncodingErrors is true.
        Specified by:
        openReader in interface FileObject
        Parameters:
        ignoreEncodingErrors - ignore encoding errors if true
        Returns:
        a Reader
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getCharContent

        public CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
        Description copied from interface: FileObject
        Gets the character content of this file object, if available. Any byte that cannot be decoded will be replaced by the default translation character. In addition, a diagnostic may be reported unless ignoreEncodingErrors is true.
        Specified by:
        getCharContent in interface FileObject
        Parameters:
        ignoreEncodingErrors - ignore encoding errors if true
        Returns:
        a CharSequence if available; null otherwise
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • openWriter

        public Writer openWriter()
                  throws IOException
        Description copied from interface: FileObject
        Gets a Writer for this file object.
        Specified by:
        openWriter in interface FileObject
        Returns:
        a Writer
        Throws:
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getLastModified

        public long getLastModified()
        Description copied from interface: FileObject
        Gets the time this file object was last modified. The time is measured in milliseconds since the epoch (00:00:00 GMT, January 1, 1970).
        Specified by:
        getLastModified in interface FileObject
        Returns:
        the time this file object was last modified; or 0 if the file object does not exist, if an I/O error occurred, or if the operation is not supported

      • delete

        public boolean delete()
        Description copied from interface: FileObject
        Deletes this file object. In case of errors, returns false.
        Specified by:
        delete in interface FileObject
        Returns:
        true if and only if this file object is successfully deleted; false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardingJavaFileManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Class ForwardingJavaFileManager<M extends JavaFileManager>

  • java.lang.Object
    • javax.tools.ForwardingJavaFileManager<M>
  • Type Parameters:
    M - the kind of file manager forwarded to by this object
    All Implemented Interfaces:
    Closeable, Flushable, AutoCloseable, JavaFileManager, OptionChecker

    public class ForwardingJavaFileManager<M extends JavaFileManager>
extends Object
implements JavaFileManager
    Forwards calls to a given file manager. Subclasses of this class might override some of these methods and might also provide additional fields and methods.
    Since:
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileManager

        JavaFileManager.Location

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected M fileManager
      The file manager which all methods are delegated to.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ForwardingJavaFileManager(M fileManager)
      Creates a new instance of ForwardingJavaFileManager.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void close()
      Releases any resources opened by this file manager directly or indirectly.
      void flush()
      Flushes any resources opened for output by this file manager directly or indirectly.
      ClassLoader getClassLoader(JavaFileManager.Location location)
      Gets a class loader for loading plug-ins from the given location.
      FileObject getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      JavaFileObject getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      boolean handleOption(String current, Iterator<String> remaining)
      Handles one option.
      boolean hasLocation(JavaFileManager.Location location)
      Determines if a location is known to this file manager.
      String inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      boolean isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same underlying object.
      int isSupportedOption(String option)
      Determines if the given option is supported and if so, the number of arguments the option takes.
      Iterable<JavaFileObject> list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • fileManager

        protected final M extends JavaFileManager fileManager
        The file manager which all methods are delegated to.

    • Constructor Detail

      • ForwardingJavaFileManager

        protected ForwardingJavaFileManager(M fileManager)
        Creates a new instance of ForwardingJavaFileManager.
        Parameters:
        fileManager - delegate to this file manager

    • Method Detail

      • getClassLoader

        public ClassLoader getClassLoader(JavaFileManager.Location location)
        Description copied from interface: JavaFileManager
        Gets a class loader for loading plug-ins from the given location. For example, to load annotation processors, a compiler will request a class loader for the ANNOTATION_PROCESSOR_PATH location.
        Specified by:
        getClassLoader in interface JavaFileManager
        Parameters:
        location - a location
        Returns:
        a class loader for the given location; or null if loading plug-ins from the given location is disabled or if the location is not known
        Throws:
        SecurityException - if a class loader can not be created in the current security context
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • list

        public Iterable<JavaFileObject> list(JavaFileManager.Location location,
                                     String packageName,
                                     Set<JavaFileObject.Kind> kinds,
                                     boolean recurse)
                              throws IOException
        Description copied from interface: JavaFileManager
        Lists all file objects matching the given criteria in the given location. List file objects in "subpackages" if recurse is true.

        Note: even if the given location is unknown to this file manager, it may not return null. Also, an unknown location may not cause an exception.

        Specified by:
        list in interface JavaFileManager
        Parameters:
        location - a location
        packageName - a package name
        kinds - return objects only of these kinds
        recurse - if true include "subpackages"
        Returns:
        an Iterable of file objects matching the given criteria
        Throws:
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • inferBinaryName

        public String inferBinaryName(JavaFileManager.Location location,
                              JavaFileObject file)
        Description copied from interface: JavaFileManager
        Infers a binary name of a file object based on a location. The binary name returned might not be a valid binary name according to The Java™ Language Specification.
        Specified by:
        inferBinaryName in interface JavaFileManager
        Parameters:
        location - a location
        file - a file object
        Returns:
        a binary name or null the file object is not found in the given location
        Throws:
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • isSameFile

        public boolean isSameFile(FileObject a,
                          FileObject b)
        Description copied from interface: JavaFileManager
        Compares two file objects and return true if they represent the same underlying object.
        Specified by:
        isSameFile in interface JavaFileManager
        Parameters:
        a - a file object
        b - a file object
        Returns:
        true if the given file objects represent the same underlying object
        Throws:
        IllegalArgumentException - if either of the arguments were created with another file manager and this file manager does not support foreign file objects

      • handleOption

        public boolean handleOption(String current,
                            Iterator<String> remaining)
        Description copied from interface: JavaFileManager
        Handles one option. If current is an option to this file manager it will consume any arguments to that option from remaining and return true, otherwise return false.
        Specified by:
        handleOption in interface JavaFileManager
        Parameters:
        current - current option
        remaining - remaining options
        Returns:
        true if this option was handled by this file manager, false otherwise
        Throws:
        IllegalArgumentException - if this option to this file manager is used incorrectly
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • hasLocation

        public boolean hasLocation(JavaFileManager.Location location)
        Description copied from interface: JavaFileManager
        Determines if a location is known to this file manager.
        Specified by:
        hasLocation in interface JavaFileManager
        Parameters:
        location - a location
        Returns:
        true if the location is known

      • isSupportedOption

        public int isSupportedOption(String option)
        Description copied from interface: OptionChecker
        Determines if the given option is supported and if so, the number of arguments the option takes.
        Specified by:
        isSupportedOption in interface OptionChecker
        Parameters:
        option - an option
        Returns:
        the number of arguments the given option takes or -1 if the option is not supported

      • getJavaFileForInput

        public JavaFileObject getJavaFileForInput(JavaFileManager.Location location,
                                          String className,
                                          JavaFileObject.Kind kind)
                                   throws IOException
        Description copied from interface: JavaFileManager
        Gets a file object for input representing the specified class of the specified kind in the given location.
        Specified by:
        getJavaFileForInput in interface JavaFileManager
        Parameters:
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or CLASS
        Returns:
        a file object, might return null if the file does not exist
        Throws:
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • getJavaFileForOutput

        public JavaFileObject getJavaFileForOutput(JavaFileManager.Location location,
                                           String className,
                                           JavaFileObject.Kind kind,
                                           FileObject sibling)
                                    throws IOException
        Description copied from interface: JavaFileManager
        Gets a file object for output representing the specified class of the specified kind in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        Specified by:
        getJavaFileForOutput in interface JavaFileManager
        Parameters:
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or CLASS
        sibling - a file object to be used as hint for placement; might be null
        Returns:
        a file object for output
        Throws:
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IllegalStateException - JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • getFileForInput

        public FileObject getFileForInput(JavaFileManager.Location location,
                                  String packageName,
                                  String relativeName)
                           throws IOException
        Description copied from interface: JavaFileManager
        Gets a file object for input representing the specified relative name in the specified package in the given location.

        If the returned object represents a source or class file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name. For example, to locate the properties file "resources/compiler.properties" in the package "com.sun.tools.javac" in the SOURCE_PATH location, this method might be called like so:

        getFileForInput(SOURCE_PATH, "com.sun.tools.javac", "resources/compiler.properties");

        If the call was executed on Windows, with SOURCE_PATH set to "C:\Documents and Settings\UncleBob\src\share\classes", a valid result would be a file object representing the file "C:\Documents and Settings\UncleBob\src\share\classes\com\sun\tools\javac\resources\compiler.properties".

        Specified by:
        getFileForInput in interface JavaFileManager
        Parameters:
        location - a location
        packageName - a package name
        relativeName - a relative name
        Returns:
        a file object, might return null if the file does not exist
        Throws:
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • getFileForOutput

        public FileObject getFileForOutput(JavaFileManager.Location location,
                                   String packageName,
                                   String relativeName,
                                   FileObject sibling)
                            throws IOException
        Description copied from interface: JavaFileManager
        Gets a file object for output representing the specified relative name in the specified package in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        If the returned object represents a source or class file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name or next to the sibling argument. See getFileForInput for an example.

        Specified by:
        getFileForOutput in interface JavaFileManager
        Parameters:
        location - a location
        packageName - a package name
        relativeName - a relative name
        sibling - a file object to be used as hint for placement; might be null
        Returns:
        a file object
        Throws:
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • flush

        public void flush()
           throws IOException
        Description copied from interface: JavaFileManager
        Flushes any resources opened for output by this file manager directly or indirectly. Flushing a closed file manager has no effect.
        Specified by:
        flush in interface Flushable
        Specified by:
        flush in interface JavaFileManager
        Throws:
        IOException - if an I/O error occurred
        See Also:
        JavaFileManager.close()

      • close

        public void close()
           throws IOException
        Description copied from interface: JavaFileManager
        Releases any resources opened by this file manager directly or indirectly. This might render this file manager useless and the effect of subsequent calls to methods on this object or any objects obtained through this object is undefined unless explicitly allowed. However, closing a file manager which has already been closed has no effect.
        Specified by:
        close in interface Closeable
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface JavaFileManager
        Throws:
        IOException - if an I/O error occurred
        See Also:
        JavaFileManager.flush()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardingJavaFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Class ForwardingJavaFileObject<F extends JavaFileObject>

  • java.lang.Object
    • javax.tools.ForwardingFileObject<F>
      • javax.tools.ForwardingJavaFileObject<F>
  • Type Parameters:
    F - the kind of file object forwarded to by this object
    All Implemented Interfaces:
    FileObject, JavaFileObject

    public class ForwardingJavaFileObject<F extends JavaFileObject>
extends ForwardingFileObject<F>
implements JavaFileObject
    Forwards calls to a given file object. Subclasses of this class might override some of these methods and might also provide additional fields and methods.
    Since:
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileObject

        JavaFileObject.Kind

    • Field Summary

      • Fields inherited from class javax.tools.ForwardingFileObject

        fileObject

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ForwardingJavaFileObject(F fileObject)
      Creates a new instance of ForwardingJavaFileObject.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Modifier getAccessLevel()
      Provides a hint about the access level of the class represented by this file object.
      JavaFileObject.Kind getKind()
      Gets the kind of this file object.
      NestingKind getNestingKind()
      Provides a hint about the nesting level of the class represented by this file object.
      boolean isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Checks if this file object is compatible with the specified simple name and kind.

      • Methods inherited from class javax.tools.ForwardingFileObject

        delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.tools.FileObject

        delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

    • Constructor Detail

      • ForwardingJavaFileObject

        protected ForwardingJavaFileObject(F fileObject)
        Creates a new instance of ForwardingJavaFileObject.
        Parameters:
        fileObject - delegate to this file object

    • Method Detail

      • getKind

        public JavaFileObject.Kind getKind()
        Description copied from interface: JavaFileObject
        Gets the kind of this file object.
        Specified by:
        getKind in interface JavaFileObject
        Returns:
        the kind

      • isNameCompatible

        public boolean isNameCompatible(String simpleName,
                                JavaFileObject.Kind kind)
        Description copied from interface: JavaFileObject
        Checks if this file object is compatible with the specified simple name and kind. A simple name is a single identifier (not qualified) as defined in The Java™ Language Specification, section 6.2 "Names and Identifiers".
        Specified by:
        isNameCompatible in interface JavaFileObject
        Parameters:
        simpleName - a simple name of a class
        kind - a kind
        Returns:
        true if this file object is compatible; false otherwise

      • getNestingKind

        public NestingKind getNestingKind()
        Description copied from interface: JavaFileObject
        Provides a hint about the nesting level of the class represented by this file object. This method may return NestingKind.MEMBER to mean NestingKind.LOCAL or NestingKind.ANONYMOUS. If the nesting level is not known or this file object does not represent a class file this method returns null.
        Specified by:
        getNestingKind in interface JavaFileObject
        Returns:
        the nesting kind, or null if the nesting kind is not known

      • getAccessLevel

        public Modifier getAccessLevel()
        Description copied from interface: JavaFileObject
        Provides a hint about the access level of the class represented by this file object. If the access level is not known or if this file object does not represent a class file this method returns null.
        Specified by:
        getAccessLevel in interface JavaFileObject
        Returns:
        the access level
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JavaCompiler.CompilationTask (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface JavaCompiler.CompilationTask

  • All Superinterfaces:
    Callable<Boolean>
    Enclosing interface:
    JavaCompiler

    public static interface JavaCompiler.CompilationTask
extends Callable<Boolean>
    Interface representing a future for a compilation task. The compilation task has not yet started. To start the task, call the call method.

    Before calling the call method, additional aspects of the task can be configured, for example, by calling the setProcessors method.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Boolean call()
      Performs this compilation task.
      void setLocale(Locale locale)
      Set the locale to be applied when formatting diagnostics and other localized data.
      void setProcessors(Iterable<? extends Processor> processors)
      Sets processors (for annotation processing).

    • Method Detail

      • setProcessors

        void setProcessors(Iterable<? extends Processor> processors)
        Sets processors (for annotation processing). This will bypass the normal discovery mechanism.
        Parameters:
        processors - processors (for annotation processing)
        Throws:
        IllegalStateException - if the task has started

      • setLocale

        void setLocale(Locale locale)
        Set the locale to be applied when formatting diagnostics and other localized data.
        Parameters:
        locale - the locale to apply; null means apply no locale
        Throws:
        IllegalStateException - if the task has started

      • call

        Boolean call()
        Performs this compilation task. The compilation may only be performed once. Subsequent calls to this method throw IllegalStateException.
        Specified by:
        call in interface Callable<Boolean>
        Returns:
        true if and only all the files compiled without errors; false otherwise
        Throws:
        RuntimeException - if an unrecoverable error occurred in a user-supplied component. The cause will be the error in user code.
        IllegalStateException - if called more than once
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JavaCompiler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface JavaCompiler

  • All Superinterfaces:
    OptionChecker, Tool

    public interface JavaCompiler
extends Tool, OptionChecker
    Interface to invoke Java™ programming language compilers from programs.

    The compiler might generate diagnostics during compilation (for example, error messages). If a diagnostic listener is provided, the diagnostics will be supplied to the listener. If no listener is provided, the diagnostics will be formatted in an unspecified format and written to the default output, which is System.err unless otherwise specified. Even if a diagnostic listener is supplied, some diagnostics might not fit in a Diagnostic and will be written to the default output.

    A compiler tool has an associated standard file manager, which is the file manager that is native to the tool (or built-in). The standard file manager can be obtained by calling getStandardFileManager.

    A compiler tool must function with any file manager as long as any additional requirements as detailed in the methods below are met. If no file manager is provided, the compiler tool will use a standard file manager such as the one returned by getStandardFileManager.

    An instance implementing this interface must conform to The Java™ Language Specification and generate class files conforming to The Java™ Virtual Machine Specification. The versions of these specifications are defined in the Tool interface. Additionally, an instance of this interface supporting SourceVersion.RELEASE_6 or higher must also support annotation processing.

    The compiler relies on two services: diagnostic listener and file manager. Although most classes and interfaces in this package defines an API for compilers (and tools in general) the interfaces DiagnosticListener, JavaFileManager, FileObject, and JavaFileObject are not intended to be used in applications. Instead these interfaces are intended to be implemented and used to provide customized services for a compiler and thus defines an SPI for compilers.

    There are a number of classes and interfaces in this package which are designed to ease the implementation of the SPI to customize the behavior of a compiler:

    StandardJavaFileManager
    Every compiler which implements this interface provides a standard file manager for operating on regular files. The StandardJavaFileManager interface defines additional methods for creating file objects from regular files.

    The standard file manager serves two purposes:

    • basic building block for customizing how a compiler reads and writes files
    • sharing between multiple compilation tasks

    Reusing a file manager can potentially reduce overhead of scanning the file system and reading jar files. Although there might be no reduction in overhead, a standard file manager must work with multiple sequential compilations making the following example a recommended coding pattern:

           File[] files1 = ... ; // input for first compilation task
       File[] files2 = ... ; // input for second compilation task

       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
       StandardJavaFileManager fileManager = compiler.getStandardFileManager(null, null, null);

        Iterable<? extends JavaFileObject> compilationUnits1 =
           fileManager.getJavaFileObjectsFromFiles(Arrays.asList(files1));
       compiler.getTask(null, fileManager, null, null, null, compilationUnits1).call();

        Iterable<? extends JavaFileObject> compilationUnits2 =
           fileManager.getJavaFileObjects(files2); // use alternative method
       // reuse the same file manager to allow caching of jar files
       compiler.getTask(null, fileManager, null, null, null, compilationUnits2).call();

       fileManager.close();
    DiagnosticCollector
    Used to collect diagnostics in a list, for example:
            Iterable<? extends JavaFileObject> compilationUnits = ...;
       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
        DiagnosticCollector<JavaFileObject> diagnostics = new DiagnosticCollector<JavaFileObject>();
       StandardJavaFileManager fileManager = compiler.getStandardFileManager(diagnostics, null, null);
       compiler.getTask(null, fileManager, diagnostics, null, null, compilationUnits).call();

       for ( Diagnostic<? extends JavaFileObject> diagnostic : diagnostics.getDiagnostics())
           System.out.format("Error on line %d in %s%n",
                             diagnostic.getLineNumber(),
                             diagnostic.getSource().toUri());

       fileManager.close();
    ForwardingJavaFileManager, ForwardingFileObject, and ForwardingJavaFileObject
    Subclassing is not available for overriding the behavior of a standard file manager as it is created by calling a method on a compiler, not by invoking a constructor. Instead forwarding (or delegation) should be used. These classes makes it easy to forward most calls to a given file manager or file object while allowing customizing behavior. For example, consider how to log all calls to JavaFileManager.flush():
           final Logger logger = ...;
        Iterable<? extends JavaFileObject> compilationUnits = ...;
       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
       StandardJavaFileManager stdFileManager = compiler.getStandardFileManager(null, null, null);
       JavaFileManager fileManager = new ForwardingJavaFileManager(stdFileManager) {
           public void flush() throws IOException {
               logger.entering(StandardJavaFileManager.class.getName(), "flush");
               super.flush();
               logger.exiting(StandardJavaFileManager.class.getName(), "flush");
           }
       };
       compiler.getTask(null, fileManager, null, null, null, compilationUnits).call();
    SimpleJavaFileObject
    This class provides a basic file object implementation which can be used as building block for creating file objects. For example, here is how to define a file object which represent source code stored in a string:
           /**
        * A file object used to represent source coming from a string.
         */
       public class JavaSourceFromString extends SimpleJavaFileObject {
           /**
            * The source code of this "file".
             */
           final String code;

           /**
            * Constructs a new JavaSourceFromString.
            *  @param name the name of the compilation unit represented by this file object
            *  @param code the source code for the compilation unit represented by this file object
             */
           JavaSourceFromString(String name, String code) {
               super(URI.create("string:///" + name.replace('.','/') + Kind.SOURCE.extension),
                     Kind.SOURCE);
               this.code = code;
           }

            @Override
           public CharSequence getCharContent(boolean ignoreEncodingErrors) {
               return code;
           }
       }
    Since:
    1.6
    See Also:
    DiagnosticListener, Diagnostic, JavaFileManager

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  JavaCompiler.CompilationTask
      Interface representing a future for a compilation task.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      JavaCompiler.CompilationTask getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.

      • Methods inherited from interface javax.tools.Tool

        getSourceVersions, run

      • Methods inherited from interface javax.tools.OptionChecker

        isSupportedOption

    • Method Detail

      • getTask

        JavaCompiler.CompilationTask getTask(Writer out,
                                     JavaFileManager fileManager,
                                     DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                     Iterable<String> options,
                                     Iterable<String> classes,
                                     Iterable<? extends JavaFileObject> compilationUnits)
        Creates a future for a compilation task with the given components and arguments. The compilation might not have completed as described in the CompilationTask interface.

        If a file manager is provided, it must be able to handle all locations defined in StandardLocation.

        Note that annotation processing can process both the compilation units of source code to be compiled, passed with the compilationUnits parameter, as well as class files, whose names are passed with the classes parameter.

        Parameters:
        out - a Writer for additional output from the compiler; use System.err if null
        fileManager - a file manager; if null use the compiler's standard filemanager
        diagnosticListener - a diagnostic listener; if null use the compiler's default method for reporting diagnostics
        options - compiler options, null means no options
        classes - names of classes to be processed by annotation processing, null means no class names
        compilationUnits - the compilation units to compile, null means no compilation units
        Returns:
        an object representing the compilation
        Throws:
        RuntimeException - if an unrecoverable error occurred in a user supplied component. The cause will be the error in user code.
        IllegalArgumentException - if any of the options are invalid, or if any of the given compilation units are of other kind than source

      • getStandardFileManager

        StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                               Locale locale,
                                               Charset charset)
        Gets a new instance of the standard file manager implementation for this tool. The file manager will use the given diagnostic listener for producing any non-fatal diagnostics. Fatal errors will be signaled with the appropriate exceptions.

        The standard file manager will be automatically reopened if it is accessed after calls to flush or close. The standard file manager must be usable with other tools.

        Parameters:
        diagnosticListener - a diagnostic listener for non-fatal diagnostics; if null use the compiler's default method for reporting diagnostics
        locale - the locale to apply when formatting diagnostics; null means the default locale.
        charset - the character set used for decoding bytes; if null use the platform default
        Returns:
        the standard file manager
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JavaFileManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface JavaFileManager

  • All Superinterfaces:
    AutoCloseable, Closeable, Flushable, OptionChecker
    All Known Subinterfaces:
    StandardJavaFileManager
    All Known Implementing Classes:
    ForwardingJavaFileManager

    public interface JavaFileManager
extends Closeable, Flushable, OptionChecker
    File manager for tools operating on Java™ programming language source and class files. In this context, file means an abstraction of regular files and other sources of data.

    When constructing new JavaFileObjects, the file manager must determine where to create them. For example, if a file manager manages regular files on a file system, it would most likely have a current/working directory to use as default location when creating or finding files. A number of hints can be provided to a file manager as to where to create files. Any file manager might choose to ignore these hints.

    Some methods in this interface use class names. Such class names must be given in the Java Virtual Machine internal form of fully qualified class and interface names. For convenience '.' and '/' are interchangeable. The internal form is defined in chapter four of The Java™ Virtual Machine Specification.

    Discussion: this means that the names "java/lang.package-info", "java/lang/package-info", "java.lang.package-info", are valid and equivalent. Compare to binary name as defined in The Java™ Language Specification, section 13.1 "The Form of a Binary".

    The case of names is significant. All names should be treated as case-sensitive. For example, some file systems have case-insensitive, case-aware file names. File objects representing such files should take care to preserve case by using File.getCanonicalFile() or similar means. If the system is not case-aware, file objects must use other means to preserve case.

    Relative names: some methods in this interface use relative names. A relative name is a non-null, non-empty sequence of path segments separated by '/'. '.' or '..' are invalid path segments. A valid relative name must match the "path-rootless" rule of RFC 3986, section 3.3. Informally, this should be true:

      URI.create(relativeName).normalize().getPath().equals(relativeName)

    All methods in this interface might throw a SecurityException.

    An object of this interface is not required to support multi-threaded access, that is, be synchronized. However, it must support concurrent access to different file objects created by this object.

    Implementation note: a consequence of this requirement is that a trivial implementation of output to a JarOutputStream is not a sufficient implementation. That is, rather than creating a JavaFileObject that returns the JarOutputStream directly, the contents must be cached until closed and then written to the JarOutputStream.

    Unless explicitly allowed, all methods in this interface might throw a NullPointerException if given a null argument.

    Since:
    1.6
    See Also:
    JavaFileObject, FileObject

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  JavaFileManager.Location
      Interface for locations of file objects.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void close()
      Releases any resources opened by this file manager directly or indirectly.
      void flush()
      Flushes any resources opened for output by this file manager directly or indirectly.
      ClassLoader getClassLoader(JavaFileManager.Location location)
      Gets a class loader for loading plug-ins from the given location.
      FileObject getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      JavaFileObject getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      boolean handleOption(String current, Iterator<String> remaining)
      Handles one option.
      boolean hasLocation(JavaFileManager.Location location)
      Determines if a location is known to this file manager.
      String inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      boolean isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same underlying object.
      Iterable<JavaFileObject> list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.

      • Methods inherited from interface javax.tools.OptionChecker

        isSupportedOption

    • Method Detail

      • getClassLoader

        ClassLoader getClassLoader(JavaFileManager.Location location)
        Gets a class loader for loading plug-ins from the given location. For example, to load annotation processors, a compiler will request a class loader for the ANNOTATION_PROCESSOR_PATH location.
        Parameters:
        location - a location
        Returns:
        a class loader for the given location; or null if loading plug-ins from the given location is disabled or if the location is not known
        Throws:
        SecurityException - if a class loader can not be created in the current security context
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • list

        Iterable<JavaFileObject> list(JavaFileManager.Location location,
                              String packageName,
                              Set<JavaFileObject.Kind> kinds,
                              boolean recurse)
                       throws IOException
        Lists all file objects matching the given criteria in the given location. List file objects in "subpackages" if recurse is true.

        Note: even if the given location is unknown to this file manager, it may not return null. Also, an unknown location may not cause an exception.

        Parameters:
        location - a location
        packageName - a package name
        kinds - return objects only of these kinds
        recurse - if true include "subpackages"
        Returns:
        an Iterable of file objects matching the given criteria
        Throws:
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • inferBinaryName

        String inferBinaryName(JavaFileManager.Location location,
                       JavaFileObject file)
        Infers a binary name of a file object based on a location. The binary name returned might not be a valid binary name according to The Java™ Language Specification.
        Parameters:
        location - a location
        file - a file object
        Returns:
        a binary name or null the file object is not found in the given location
        Throws:
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • isSameFile

        boolean isSameFile(FileObject a,
                   FileObject b)
        Compares two file objects and return true if they represent the same underlying object.
        Parameters:
        a - a file object
        b - a file object
        Returns:
        true if the given file objects represent the same underlying object
        Throws:
        IllegalArgumentException - if either of the arguments were created with another file manager and this file manager does not support foreign file objects

      • handleOption

        boolean handleOption(String current,
                     Iterator<String> remaining)
        Handles one option. If current is an option to this file manager it will consume any arguments to that option from remaining and return true, otherwise return false.
        Parameters:
        current - current option
        remaining - remaining options
        Returns:
        true if this option was handled by this file manager, false otherwise
        Throws:
        IllegalArgumentException - if this option to this file manager is used incorrectly
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • hasLocation

        boolean hasLocation(JavaFileManager.Location location)
        Determines if a location is known to this file manager.
        Parameters:
        location - a location
        Returns:
        true if the location is known

      • getJavaFileForInput

        JavaFileObject getJavaFileForInput(JavaFileManager.Location location,
                                   String className,
                                   JavaFileObject.Kind kind)
                            throws IOException
        Gets a file object for input representing the specified class of the specified kind in the given location.
        Parameters:
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or CLASS
        Returns:
        a file object, might return null if the file does not exist
        Throws:
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • getJavaFileForOutput

        JavaFileObject getJavaFileForOutput(JavaFileManager.Location location,
                                    String className,
                                    JavaFileObject.Kind kind,
                                    FileObject sibling)
                             throws IOException
        Gets a file object for output representing the specified class of the specified kind in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        Parameters:
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or CLASS
        sibling - a file object to be used as hint for placement; might be null
        Returns:
        a file object for output
        Throws:
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - close() has been called and this file manager cannot be reopened

      • getFileForInput

        FileObject getFileForInput(JavaFileManager.Location location,
                           String packageName,
                           String relativeName)
                    throws IOException
        Gets a file object for input representing the specified relative name in the specified package in the given location.

        If the returned object represents a source or class file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name. For example, to locate the properties file "resources/compiler.properties" in the package "com.sun.tools.javac" in the SOURCE_PATH location, this method might be called like so:

        getFileForInput(SOURCE_PATH, "com.sun.tools.javac", "resources/compiler.properties");

        If the call was executed on Windows, with SOURCE_PATH set to "C:\Documents and Settings\UncleBob\src\share\classes", a valid result would be a file object representing the file "C:\Documents and Settings\UncleBob\src\share\classes\com\sun\tools\javac\resources\compiler.properties".

        Parameters:
        location - a location
        packageName - a package name
        relativeName - a relative name
        Returns:
        a file object, might return null if the file does not exist
        Throws:
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • getFileForOutput

        FileObject getFileForOutput(JavaFileManager.Location location,
                            String packageName,
                            String relativeName,
                            FileObject sibling)
                     throws IOException
        Gets a file object for output representing the specified relative name in the specified package in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        If the returned object represents a source or class file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name or next to the sibling argument. See getFileForInput for an example.

        Parameters:
        location - a location
        packageName - a package name
        relativeName - a relative name
        sibling - a file object to be used as hint for placement; might be null
        Returns:
        a file object
        Throws:
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • flush

        void flush()
    throws IOException
        Flushes any resources opened for output by this file manager directly or indirectly. Flushing a closed file manager has no effect.
        Specified by:
        flush in interface Flushable
        Throws:
        IOException - if an I/O error occurred
        See Also:
        close()

      • close

        void close()
    throws IOException
        Releases any resources opened by this file manager directly or indirectly. This might render this file manager useless and the effect of subsequent calls to methods on this object or any objects obtained through this object is undefined unless explicitly allowed. However, closing a file manager which has already been closed has no effect.
        Specified by:
        close in interface AutoCloseable
        Specified by:
        close in interface Closeable
        Throws:
        IOException - if an I/O error occurred
        See Also:
        flush()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JavaFileManager.Location (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface JavaFileManager.Location

  • All Known Implementing Classes:
    DocumentationTool.Location, StandardLocation
    Enclosing interface:
    JavaFileManager

    public static interface JavaFileManager.Location
    Interface for locations of file objects. Used by file managers to determine where to place or search for file objects.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getName()
      Gets the name of this location.
      boolean isOutputLocation()
      Determines if this is an output location.

    • Method Detail

      • getName

        String getName()
        Gets the name of this location.
        Returns:
        a name

      • isOutputLocation

        boolean isOutputLocation()
        Determines if this is an output location. An output location is a location that is conventionally used for output.
        Returns:
        true if this is an output location, false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JavaFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface JavaFileObject

  • All Superinterfaces:
    FileObject
    All Known Implementing Classes:
    ForwardingJavaFileObject, SimpleJavaFileObject

    public interface JavaFileObject
extends FileObject
    File abstraction for tools operating on Java™ programming language source and class files.

    All methods in this interface might throw a SecurityException if a security exception occurs.

    Unless explicitly allowed, all methods in this interface might throw a NullPointerException if given a null argument.

    Since:
    1.6
    See Also:
    JavaFileManager

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  JavaFileObject.Kind
      Kinds of JavaFileObjects.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Modifier getAccessLevel()
      Provides a hint about the access level of the class represented by this file object.
      JavaFileObject.Kind getKind()
      Gets the kind of this file object.
      NestingKind getNestingKind()
      Provides a hint about the nesting level of the class represented by this file object.
      boolean isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Checks if this file object is compatible with the specified simple name and kind.

      • Methods inherited from interface javax.tools.FileObject

        delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

    • Method Detail

      • getKind

        JavaFileObject.Kind getKind()
        Gets the kind of this file object.
        Returns:
        the kind

      • isNameCompatible

        boolean isNameCompatible(String simpleName,
                         JavaFileObject.Kind kind)
        Checks if this file object is compatible with the specified simple name and kind. A simple name is a single identifier (not qualified) as defined in The Java™ Language Specification, section 6.2 "Names and Identifiers".
        Parameters:
        simpleName - a simple name of a class
        kind - a kind
        Returns:
        true if this file object is compatible; false otherwise

      • getNestingKind

        NestingKind getNestingKind()
        Provides a hint about the nesting level of the class represented by this file object. This method may return NestingKind.MEMBER to mean NestingKind.LOCAL or NestingKind.ANONYMOUS. If the nesting level is not known or this file object does not represent a class file this method returns null.
        Returns:
        the nesting kind, or null if the nesting kind is not known

      • getAccessLevel

        Modifier getAccessLevel()
        Provides a hint about the access level of the class represented by this file object. If the access level is not known or if this file object does not represent a class file this method returns null.
        Returns:
        the access level
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JavaFileObject.Kind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
compact3
javax.tools

Enum JavaFileObject.Kind

  • java.lang.Object
    • java.lang.Enum<JavaFileObject.Kind>
      • javax.tools.JavaFileObject.Kind
  • All Implemented Interfaces:
    Serializable, Comparable<JavaFileObject.Kind>
    Enclosing interface:
    JavaFileObject

    public static enum JavaFileObject.Kind
extends Enum<JavaFileObject.Kind>
    Kinds of JavaFileObjects.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      CLASS
      Class files for the Java Virtual Machine.
      HTML
      HTML files.
      OTHER
      Any other kind.
      SOURCE
      Source files written in the Java programming language.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String extension
      The extension which (by convention) is normally used for this kind of file object.

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static JavaFileObject.Kind valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JavaFileObject.Kind[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SOURCE

        public static final JavaFileObject.Kind SOURCE
        Source files written in the Java programming language. For example, regular files ending with .java.

      • CLASS

        public static final JavaFileObject.Kind CLASS
        Class files for the Java Virtual Machine. For example, regular files ending with .class.

      • HTML

        public static final JavaFileObject.Kind HTML
        HTML files. For example, regular files ending with .html.

      • OTHER

        public static final JavaFileObject.Kind OTHER
        Any other kind.

    • Field Detail

      • extension

        public final String extension
        The extension which (by convention) is normally used for this kind of file object. If no convention exists, the empty string ("") is used.

    • Method Detail

      • values

        public static JavaFileObject.Kind[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (JavaFileObject.Kind c : JavaFileObject.Kind.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static JavaFileObject.Kind valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OptionChecker (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface OptionChecker

  • All Known Subinterfaces:
    DocumentationTool, JavaCompiler, JavaFileManager, StandardJavaFileManager
    All Known Implementing Classes:
    ForwardingJavaFileManager

    public interface OptionChecker
    Interface for recognizing options.
    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int isSupportedOption(String option)
      Determines if the given option is supported and if so, the number of arguments the option takes.

    • Method Detail

      • isSupportedOption

        int isSupportedOption(String option)
        Determines if the given option is supported and if so, the number of arguments the option takes.
        Parameters:
        option - an option
        Returns:
        the number of arguments the given option takes or -1 if the option is not supported
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.tools (Java Platform SE 8 )

javax.tools

Interfaces

  • Diagnostic
  • DiagnosticListener
  • DocumentationTool
  • DocumentationTool.DocumentationTask
  • FileObject
  • JavaCompiler
  • JavaCompiler.CompilationTask
  • JavaFileManager
  • JavaFileManager.Location
  • JavaFileObject
  • OptionChecker
  • StandardJavaFileManager
  • Tool

Classes

  • DiagnosticCollector
  • ForwardingFileObject
  • ForwardingJavaFileManager
  • ForwardingJavaFileObject
  • SimpleJavaFileObject
  • ToolProvider

Enums

  • Diagnostic.Kind
  • DocumentationTool.Location
  • JavaFileObject.Kind
  • StandardLocation


javax.tools (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.tools

Provides interfaces for tools which can be invoked from a program, for example, compilers.

See: Description

  • Interface Summary
    Interface Description
    Diagnostic<S>
    Interface for diagnostics from tools.
    DiagnosticListener<S>
    Interface for receiving diagnostics from tools.
    DocumentationTool
    Interface to invoke Java™ programming language documentation tools from programs.
    DocumentationTool.DocumentationTask
    Interface representing a future for a documentation task.
    FileObject
    File abstraction for tools.
    JavaCompiler
    Interface to invoke Java™ programming language compilers from programs.
    JavaCompiler.CompilationTask
    Interface representing a future for a compilation task.
    JavaFileManager
    File manager for tools operating on Java™ programming language source and class files.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
    OptionChecker
    Interface for recognizing options.
    StandardJavaFileManager
    File manager based on java.io.File.
    Tool
    Common interface for tools that can be invoked from a program.
  • Class Summary
    Class Description
    DiagnosticCollector<S>
    Provides an easy way to collect diagnostics in a list.
    ForwardingFileObject<F extends FileObject>
    Forwards calls to a given file object.
    ForwardingJavaFileManager<M extends JavaFileManager>
    Forwards calls to a given file manager.
    ForwardingJavaFileObject<F extends JavaFileObject>
    Forwards calls to a given file object.
    SimpleJavaFileObject
    Provides simple implementations for most methods in JavaFileObject.
    ToolProvider
    Provides methods for locating tool providers, for example, providers of compilers.
  • Enum Summary
    Enum Description
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    DocumentationTool.Location
    Locations specific to DocumentationTool.
    JavaFileObject.Kind
    Kinds of JavaFileObjects.
    StandardLocation
    Standard locations of file objects.

Package javax.tools Description

Provides interfaces for tools which can be invoked from a program, for example, compilers.

These interfaces and classes are required as part of the Java™ Platform, Standard Edition (Java SE), but there is no requirement to provide any tools implementing them.

Unless explicitly allowed, all methods in this package might throw a NullPointerException if given a null argument or if given a list or collection containing null elements. Similarly, no method may return null unless explicitly allowed.

This package is the home of the Java programming language compiler framework. This framework allows clients of the framework to locate and run compilers from programs. The framework also provides Service Provider Interfaces (SPI) for structured access to diagnostics (DiagnosticListener) as well as a file abstraction for overriding file access (JavaFileManager and JavaFileObject). See JavaCompiler for more details on using the SPI.

There is no requirement for a compiler at runtime. However, if a default compiler is provided, it can be located using the ToolProvider, for example:

JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();

It is possible to provide alternative compilers or tools through the service provider mechanism.

For example, if com.vendor.VendorJavaCompiler is a provider of the JavaCompiler tool then its jar file would contain the file META-INF/services/javax.tools.JavaCompiler. This file would contain the single line:

com.vendor.VendorJavaCompiler

If the jar file is on the class path, VendorJavaCompiler can be located using code like this:

JavaCompiler compiler = ServiceLoader.load(JavaCompiler.class).iterator().next();

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.tools Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.tools

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.tools.DiagnosticCollector<S> (implements javax.tools.DiagnosticListener<S>)
    • javax.tools.ForwardingFileObject<F> (implements javax.tools.FileObject)
      • javax.tools.ForwardingJavaFileObject<F> (implements javax.tools.JavaFileObject)
    • javax.tools.ForwardingJavaFileManager<M> (implements javax.tools.JavaFileManager)
    • javax.tools.SimpleJavaFileObject (implements javax.tools.JavaFileObject)
    • javax.tools.ToolProvider

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.tools.JavaFileManager (also extends java.io.Flushable, javax.tools.OptionChecker)
        • javax.tools.StandardJavaFileManager
  • java.util.concurrent.Callable<V>
    • javax.tools.DocumentationTool.DocumentationTask
    • javax.tools.JavaCompiler.CompilationTask
  • javax.tools.Diagnostic<S>
  • javax.tools.DiagnosticListener<S>
  • javax.tools.FileObject
    • javax.tools.JavaFileObject
  • java.io.Flushable
    • javax.tools.JavaFileManager (also extends java.io.Closeable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
  • javax.tools.JavaFileManager.Location
  • javax.tools.OptionChecker
    • javax.tools.DocumentationTool (also extends javax.tools.Tool)
    • javax.tools.JavaCompiler (also extends javax.tools.Tool)
    • javax.tools.JavaFileManager (also extends java.io.Closeable, java.io.Flushable)
      • javax.tools.StandardJavaFileManager
  • javax.tools.Tool
    • javax.tools.DocumentationTool (also extends javax.tools.OptionChecker)
    • javax.tools.JavaCompiler (also extends javax.tools.OptionChecker)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.tools.Diagnostic.Kind
      • javax.tools.JavaFileObject.Kind
      • javax.tools.StandardLocation (implements javax.tools.JavaFileManager.Location)
      • javax.tools.DocumentationTool.Location (implements javax.tools.JavaFileManager.Location)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.tools (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.tools

  • Packages that use javax.tools
    Package Description
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.
  • Classes in javax.tools used by javax.annotation.processing
    Class and Description
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    FileObject
    File abstraction for tools.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
  • Classes in javax.tools used by javax.tools
    Class and Description
    Diagnostic
    Interface for diagnostics from tools.
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    DiagnosticListener
    Interface for receiving diagnostics from tools.
    DocumentationTool
    Interface to invoke Java™ programming language documentation tools from programs.
    DocumentationTool.DocumentationTask
    Interface representing a future for a documentation task.
    DocumentationTool.Location
    Locations specific to DocumentationTool.
    FileObject
    File abstraction for tools.
    ForwardingFileObject
    Forwards calls to a given file object.
    JavaCompiler
    Interface to invoke Java™ programming language compilers from programs.
    JavaCompiler.CompilationTask
    Interface representing a future for a compilation task.
    JavaFileManager
    File manager for tools operating on Java™ programming language source and class files.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
    JavaFileObject.Kind
    Kinds of JavaFileObjects.
    OptionChecker
    Interface for recognizing options.
    StandardJavaFileManager
    File manager based on java.io.File.
    StandardLocation
    Standard locations of file objects.
    Tool
    Common interface for tools that can be invoked from a program.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SimpleJavaFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Class SimpleJavaFileObject

  • java.lang.Object
    • javax.tools.SimpleJavaFileObject
  • All Implemented Interfaces:
    FileObject, JavaFileObject

    public class SimpleJavaFileObject
extends Object
implements JavaFileObject
    Provides simple implementations for most methods in JavaFileObject. This class is designed to be subclassed and used as a basis for JavaFileObject implementations. Subclasses can override the implementation and specification of any method of this class as long as the general contract of JavaFileObject is obeyed.
    Since:
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileObject

        JavaFileObject.Kind

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected JavaFileObject.Kind kind
      The kind of this file object.
      protected URI uri
      A URI for this file object.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
      Construct a SimpleJavaFileObject of the given kind and with the given URI.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean delete()
      This implementation does nothing.
      Modifier getAccessLevel()
      This implementation returns null.
      CharSequence getCharContent(boolean ignoreEncodingErrors)
      This implementation always throws UnsupportedOperationException.
      JavaFileObject.Kind getKind()
      Gets the kind of this file object.
      long getLastModified()
      This implementation returns 0L.
      String getName()
      Gets a user-friendly name for this file object.
      NestingKind getNestingKind()
      This implementation returns null.
      boolean isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      This implementation compares the path of its URI to the given simple name.
      InputStream openInputStream()
      This implementation always throws UnsupportedOperationException.
      OutputStream openOutputStream()
      This implementation always throws UnsupportedOperationException.
      Reader openReader(boolean ignoreEncodingErrors)
      Wraps the result of getCharContent(boolean) in a Reader.
      Writer openWriter()
      Wraps the result of openOutputStream in a Writer.
      String toString()
      Returns a string representation of the object.
      URI toUri()
      Returns a URI identifying this file object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • uri

        protected final URI uri
        A URI for this file object.

      • kind

        protected final JavaFileObject.Kind kind
        The kind of this file object.

    • Constructor Detail

      • SimpleJavaFileObject

        protected SimpleJavaFileObject(URI uri,
                               JavaFileObject.Kind kind)
        Construct a SimpleJavaFileObject of the given kind and with the given URI.
        Parameters:
        uri - the URI for this file object
        kind - the kind of this file object

    • Method Detail

      • toUri

        public URI toUri()
        Description copied from interface: FileObject
        Returns a URI identifying this file object.
        Specified by:
        toUri in interface FileObject
        Returns:
        a URI

      • getName

        public String getName()
        Description copied from interface: FileObject
        Gets a user-friendly name for this file object. The exact value returned is not specified but implementations should take care to preserve names as given by the user. For example, if the user writes the filename "BobsApp\Test.java" on the command line, this method should return "BobsApp\Test.java" whereas the toUri method might return file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java.
        Specified by:
        getName in interface FileObject
        Returns:
        a user-friendly name

      • openInputStream

        public InputStream openInputStream()
                            throws IOException
        This implementation always throws UnsupportedOperationException. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        openInputStream in interface FileObject
        Returns:
        an InputStream
        Throws:
        IOException - if an I/O error occurred

      • openOutputStream

        public OutputStream openOutputStream()
                              throws IOException
        This implementation always throws UnsupportedOperationException. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        openOutputStream in interface FileObject
        Returns:
        an OutputStream
        Throws:
        IOException - if an I/O error occurred

      • openReader

        public Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
        Wraps the result of getCharContent(boolean) in a Reader. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        openReader in interface FileObject
        Parameters:
        ignoreEncodingErrors - ignore encoding errors if true
        Returns:
        a Reader wrapping the result of getCharContent
        Throws:
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getCharContent

        public CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
        This implementation always throws UnsupportedOperationException. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        getCharContent in interface FileObject
        Parameters:
        ignoreEncodingErrors - ignore encoding errors if true
        Returns:
        a CharSequence if available; null otherwise
        Throws:
        IOException - if an I/O error occurred

      • openWriter

        public Writer openWriter()
                  throws IOException
        Wraps the result of openOutputStream in a Writer. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        openWriter in interface FileObject
        Returns:
        a Writer wrapping the result of openOutputStream
        Throws:
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getLastModified

        public long getLastModified()
        This implementation returns 0L. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        getLastModified in interface FileObject
        Returns:
        0L

      • delete

        public boolean delete()
        This implementation does nothing. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        Specified by:
        delete in interface FileObject
        Returns:
        false

      • getKind

        public JavaFileObject.Kind getKind()
        Description copied from interface: JavaFileObject
        Gets the kind of this file object.
        Specified by:
        getKind in interface JavaFileObject
        Returns:
        this.kind

      • isNameCompatible

        public boolean isNameCompatible(String simpleName,
                                JavaFileObject.Kind kind)
        This implementation compares the path of its URI to the given simple name. This method returns true if the given kind is equal to the kind of this object, and if the path is equal to simpleName + kind.extension or if it ends with "/" + simpleName + kind.extension.

        This method calls getKind() and toUri() and does not access the fields uri and kind directly.

        Subclasses can change this behavior as long as the contract of JavaFileObject is obeyed.

        Specified by:
        isNameCompatible in interface JavaFileObject
        Parameters:
        simpleName - a simple name of a class
        kind - a kind
        Returns:
        true if this file object is compatible; false otherwise

      • getNestingKind

        public NestingKind getNestingKind()
        This implementation returns null. Subclasses can change this behavior as long as the contract of JavaFileObject is obeyed.
        Specified by:
        getNestingKind in interface JavaFileObject
        Returns:
        the nesting kind, or null if the nesting kind is not known

      • getAccessLevel

        public Modifier getAccessLevel()
        This implementation returns null. Subclasses can change this behavior as long as the contract of JavaFileObject is obeyed.
        Specified by:
        getAccessLevel in interface JavaFileObject
        Returns:
        the access level

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StandardJavaFileManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface StandardJavaFileManager

  • All Superinterfaces:
    AutoCloseable, Closeable, Flushable, JavaFileManager, OptionChecker

    public interface StandardJavaFileManager
extends JavaFileManager
    File manager based on java.io.File. A common way to obtain an instance of this class is using getStandardFileManager, for example:
       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
    DiagnosticCollector<JavaFileObject> diagnostics =
       new  DiagnosticCollector<JavaFileObject>();
   StandardJavaFileManager fm = compiler.getStandardFileManager(diagnostics, null, null);
    This file manager creates file objects representing regular files, zip file entries, or entries in similar file system based containers. Any file object returned from a file manager implementing this interface must observe the following behavior:
    • File names need not be canonical.
    • For file objects representing regular files
      • the method FileObject.delete() is equivalent to File.delete(),
      • the method FileObject.getLastModified() is equivalent to File.lastModified(),
      • the methods FileObject.getCharContent(boolean), FileObject.openInputStream(), and FileObject.openReader(boolean) must succeed if the following would succeed (ignoring encoding issues):
        new FileInputStream(new File(fileObject.toUri()))
      • and the methods FileObject.openOutputStream(), and FileObject.openWriter() must succeed if the following would succeed (ignoring encoding issues):
        new FileOutputStream(new File(fileObject.toUri()))
    • The URI returned from FileObject.toUri()
      • must be absolute (have a schema), and
      • must have a normalized path component which can be resolved without any process-specific context such as the current directory (file names must be absolute).
    According to these rules, the following URIs, for example, are allowed:
    • file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java
    • jar:///C:/Documents%20and%20Settings/UncleBob/lib/vendorA.jar!com/vendora/LibraryClass.class
    Whereas these are not (reason in parentheses):
    • file:BobsApp/Test.java (the file name is relative and depend on the current directory)
    • jar:lib/vendorA.jar!com/vendora/LibraryClass.class (the first half of the path depends on the current directory, whereas the component after ! is legal)
    • Test.java (this URI depends on the current directory and does not have a schema)
    • jar:///C:/Documents%20and%20Settings/UncleBob/BobsApp/../lib/vendorA.jar!com/vendora/LibraryClass.class (the path is not normalized)
    Since:
    1.6

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileManager

        JavaFileManager.Location

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Iterable<? extends JavaFileObject> getJavaFileObjects(File... files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> getJavaFileObjects(String... names)
      Gets file objects representing the given file names.
      Iterable<? extends JavaFileObject> getJavaFileObjectsFromFiles(Iterable<? extends File> files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> getJavaFileObjectsFromStrings(Iterable<String> names)
      Gets file objects representing the given file names.
      Iterable<? extends File> getLocation(JavaFileManager.Location location)
      Gets the path associated with the given location.
      boolean isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
      void setLocation(JavaFileManager.Location location, Iterable<? extends File> path)
      Associates the given path with the given location.

      • Methods inherited from interface javax.tools.JavaFileManager

        close, flush, getClassLoader, getFileForInput, getFileForOutput, getJavaFileForInput, getJavaFileForOutput, handleOption, hasLocation, inferBinaryName, list

      • Methods inherited from interface javax.tools.OptionChecker

        isSupportedOption

    • Method Detail

      • isSameFile

        boolean isSameFile(FileObject a,
                   FileObject b)
        Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
        Specified by:
        isSameFile in interface JavaFileManager
        Parameters:
        a - a file object
        b - a file object
        Returns:
        true if the given file objects represent the same canonical file or zip file entry; false otherwise
        Throws:
        IllegalArgumentException - if either of the arguments were created with another file manager implementation

      • getJavaFileObjectsFromFiles

        Iterable<? extends JavaFileObject> getJavaFileObjectsFromFiles(Iterable<? extends File> files)
        Gets file objects representing the given files.
        Parameters:
        files - a list of files
        Returns:
        a list of file objects
        Throws:
        IllegalArgumentException - if the list of files includes a directory

      • getJavaFileObjects

        Iterable<? extends JavaFileObject> getJavaFileObjects(File... files)
        Gets file objects representing the given files. Convenience method equivalent to:
             getJavaFileObjectsFromFiles(Arrays.asList(files))
        Parameters:
        files - an array of files
        Returns:
        a list of file objects
        Throws:
        IllegalArgumentException - if the array of files includes a directory
        NullPointerException - if the given array contains null elements

      • getJavaFileObjectsFromStrings

        Iterable<? extends JavaFileObject> getJavaFileObjectsFromStrings(Iterable<String> names)
        Gets file objects representing the given file names.
        Parameters:
        names - a list of file names
        Returns:
        a list of file objects
        Throws:
        IllegalArgumentException - if the list of file names includes a directory

      • getJavaFileObjects

        Iterable<? extends JavaFileObject> getJavaFileObjects(String... names)
        Gets file objects representing the given file names. Convenience method equivalent to:
             getJavaFileObjectsFromStrings(Arrays.asList(names))
        Parameters:
        names - a list of file names
        Returns:
        a list of file objects
        Throws:
        IllegalArgumentException - if the array of file names includes a directory
        NullPointerException - if the given array contains null elements

      • setLocation

        void setLocation(JavaFileManager.Location location,
                 Iterable<? extends File> path)
          throws IOException
        Associates the given path with the given location. Any previous value will be discarded.
        Parameters:
        location - a location
        path - a list of files, if null use the default path for this location
        Throws:
        IllegalArgumentException - if location is an output location and path does not contain exactly one element
        IOException - if location is an output location and path does not represent an existing directory
        See Also:
        getLocation(javax.tools.JavaFileManager.Location)

      • getLocation

        Iterable<? extends File> getLocation(JavaFileManager.Location location)
        Gets the path associated with the given location.
        Parameters:
        location - a location
        Returns:
        a list of files or null if this location has no associated path
        See Also:
        setLocation(javax.tools.JavaFileManager.Location, java.lang.Iterable<? extends java.io.File>)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StandardLocation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
compact3
javax.tools

Enum StandardLocation

  • java.lang.Object
    • java.lang.Enum<StandardLocation>
      • javax.tools.StandardLocation
  • All Implemented Interfaces:
    Serializable, Comparable<StandardLocation>, JavaFileManager.Location

    public enum StandardLocation
extends Enum<StandardLocation>
implements JavaFileManager.Location
    Standard locations of file objects.
    Since:
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ANNOTATION_PROCESSOR_PATH
      Location to search for annotation processors.
      CLASS_OUTPUT
      Location of new class files.
      CLASS_PATH
      Location to search for user class files.
      NATIVE_HEADER_OUTPUT
      Location of new native header files.
      PLATFORM_CLASS_PATH
      Location to search for platform classes.
      SOURCE_OUTPUT
      Location of new source files.
      SOURCE_PATH
      Location to search for existing source files.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getName()
      Gets the name of this location.
      boolean isOutputLocation()
      Determines if this is an output location.
      static JavaFileManager.Location locationFor(String name)
      Gets a location object with the given name.
      static StandardLocation valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static StandardLocation[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CLASS_OUTPUT

        public static final StandardLocation CLASS_OUTPUT
        Location of new class files.

      • SOURCE_OUTPUT

        public static final StandardLocation SOURCE_OUTPUT
        Location of new source files.

      • CLASS_PATH

        public static final StandardLocation CLASS_PATH
        Location to search for user class files.

      • SOURCE_PATH

        public static final StandardLocation SOURCE_PATH
        Location to search for existing source files.

      • ANNOTATION_PROCESSOR_PATH

        public static final StandardLocation ANNOTATION_PROCESSOR_PATH
        Location to search for annotation processors.

      • PLATFORM_CLASS_PATH

        public static final StandardLocation PLATFORM_CLASS_PATH
        Location to search for platform classes. Sometimes called the boot class path.

      • NATIVE_HEADER_OUTPUT

        public static final StandardLocation NATIVE_HEADER_OUTPUT
        Location of new native header files.
        Since:
        1.8

    • Method Detail

      • values

        public static StandardLocation[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (StandardLocation c : StandardLocation.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static StandardLocation valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • locationFor

        public static JavaFileManager.Location locationFor(String name)
        Gets a location object with the given name. The following property must hold: locationFor(x) == locationFor(y) if and only if x.equals(y). The returned location will be an output location if and only if name ends with "_OUTPUT".
        Parameters:
        name - a name
        Returns:
        a location

      • getName

        public String getName()
        Description copied from interface: JavaFileManager.Location
        Gets the name of this location.
        Specified by:
        getName in interface JavaFileManager.Location
        Returns:
        a name

      • isOutputLocation

        public boolean isOutputLocation()
        Description copied from interface: JavaFileManager.Location
        Determines if this is an output location. An output location is a location that is conventionally used for output.
        Specified by:
        isOutputLocation in interface JavaFileManager.Location
        Returns:
        true if this is an output location, false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Tool (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Interface Tool

  • All Known Subinterfaces:
    DocumentationTool, JavaCompiler

    public interface Tool
    Common interface for tools that can be invoked from a program. A tool is traditionally a command line program such as a compiler. The set of tools available with a platform is defined by the vendor.

    Tools can be located using ServiceLoader.load(Class).

    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Set<SourceVersion> getSourceVersions()
      Gets the source versions of the Java™ programming language supported by this tool.
      int run(InputStream in, OutputStream out, OutputStream err, String... arguments)
      Run the tool with the given I/O channels and arguments.

    • Method Detail

      • run

        int run(InputStream in,
        OutputStream out,
        OutputStream err,
        String... arguments)
        Run the tool with the given I/O channels and arguments. By convention a tool returns 0 for success and nonzero for errors. Any diagnostics generated will be written to either out or err in some unspecified format.
        Parameters:
        in - "standard" input; use System.in if null
        out - "standard" output; use System.out if null
        err - "standard" error; use System.err if null
        arguments - arguments to pass to the tool
        Returns:
        0 for success; nonzero otherwise
        Throws:
        NullPointerException - if the array of arguments contains any null elements.

      • getSourceVersions

        Set<SourceVersion> getSourceVersions()
        Gets the source versions of the Java™ programming language supported by this tool.
        Returns:
        a set of supported source versions
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ToolProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.tools

Class ToolProvider

  • java.lang.Object
    • javax.tools.ToolProvider

  • public class ToolProvider
extends Object
    Provides methods for locating tool providers, for example, providers of compilers. This class complements the functionality of ServiceLoader.
    Since:
    1.6

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static DocumentationTool getSystemDocumentationTool()
      Gets the Java™ programming language documentation tool provided with this platform.
      static JavaCompiler getSystemJavaCompiler()
      Gets the Java™ programming language compiler provided with this platform.
      static ClassLoader getSystemToolClassLoader()
      Returns the class loader for tools provided with this platform.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • getSystemJavaCompiler

        public static JavaCompiler getSystemJavaCompiler()
        Gets the Java™ programming language compiler provided with this platform.
        Returns:
        the compiler provided with this platform or null if no compiler is provided

      • getSystemDocumentationTool

        public static DocumentationTool getSystemDocumentationTool()
        Gets the Java™ programming language documentation tool provided with this platform.
        Returns:
        the documentation tool provided with this platform or null if no documentation tool is provided

      • getSystemToolClassLoader

        public static ClassLoader getSystemToolClassLoader()
        Returns the class loader for tools provided with this platform. This does not include user-installed tools. Use the service provider mechanism for locating user installed tools.
        Returns:
        the class loader for tools provided with this platform or null if no tools are provided
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.Diagnostic (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.Diagnostic

  • Packages that use Diagnostic
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of Diagnostic in javax.tools

      Methods in javax.tools that return types with arguments of type Diagnostic
      Modifier and Type Method and Description
      List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics()
      Gets a list view of diagnostics collected by this object.
      Methods in javax.tools with parameters of type Diagnostic
      Modifier and Type | Method and Description
      void | DiagnosticCollector.report(Diagnostic<? extends S> diagnostic)
      void DiagnosticListener.report(Diagnostic<? extends S> diagnostic)
      Invoked when a problem is found.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.Diagnostic.Kind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.Diagnostic.Kind

  • Packages that use Diagnostic.Kind
    Package Description
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of Diagnostic.Kind in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type Diagnostic.Kind
      Modifier and Type Method and Description
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg)
      Prints a message of the specified kind.
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e)
      Prints a message of the specified kind at the location of the element.
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a)
      Prints a message of the specified kind at the location of the annotation mirror of the annotated element.
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      Prints a message of the specified kind at the location of the annotation value inside the annotation mirror of the annotated element.

    • Uses of Diagnostic.Kind in javax.tools

      Methods in javax.tools that return Diagnostic.Kind
      Modifier and Type Method and Description
      Diagnostic.Kind Diagnostic.getKind()
      Gets the kind of this diagnostic, for example, error or warning.
      static Diagnostic.Kind Diagnostic.Kind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Diagnostic.Kind[] Diagnostic.Kind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.DiagnosticCollector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.DiagnosticCollector

No usage of javax.tools.DiagnosticCollector
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.DiagnosticListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.DiagnosticListener

  • Packages that use DiagnosticListener
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of DiagnosticListener in javax.tools

      Classes in javax.tools that implement DiagnosticListener
      Modifier and Type Class and Description
      class  DiagnosticCollector<S>
      Provides an easy way to collect diagnostics in a list.
      Methods in javax.tools with parameters of type DiagnosticListener
      Modifier and Type Method and Description
      StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      StandardJavaFileManager DocumentationTool.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      DocumentationTool.DocumentationTask DocumentationTool.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a documentation task with the given components and arguments.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.DocumentationTool.DocumentationTask (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.DocumentationTool.DocumentationTask

  • Packages that use DocumentationTool.DocumentationTask
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of DocumentationTool.DocumentationTask in javax.tools

      Methods in javax.tools that return DocumentationTool.DocumentationTask
      Modifier and Type Method and Description
      DocumentationTool.DocumentationTask DocumentationTool.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a documentation task with the given components and arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.DocumentationTool (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.DocumentationTool

  • Packages that use DocumentationTool
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of DocumentationTool in javax.tools

      Methods in javax.tools that return DocumentationTool
      Modifier and Type Method and Description
      static DocumentationTool ToolProvider.getSystemDocumentationTool()
      Gets the Java™ programming language documentation tool provided with this platform.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.DocumentationTool.Location (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.DocumentationTool.Location

  • Packages that use DocumentationTool.Location
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of DocumentationTool.Location in javax.tools

      Methods in javax.tools that return DocumentationTool.Location
      Modifier and Type Method and Description
      static DocumentationTool.Location DocumentationTool.Location.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DocumentationTool.Location[] DocumentationTool.Location.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.FileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.FileObject

  • Packages that use FileObject
    Package Description
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of FileObject in javax.annotation.processing

      Methods in javax.annotation.processing that return FileObject
      Modifier and Type Method and Description
      FileObject Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements)
      Creates a new auxiliary resource file for writing and returns a file object for it.
      FileObject Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName)
      Returns an object for reading an existing resource.

    • Uses of FileObject in javax.tools

      Classes in javax.tools with type parameters of type FileObject
      Modifier and Type Class and Description
      class  ForwardingFileObject<F extends FileObject>
      Forwards calls to a given file object.
      Subinterfaces of FileObject in javax.tools
      Modifier and Type Interface and Description
      interface  JavaFileObject
      File abstraction for tools operating on Java™ programming language source and class files.
      Classes in javax.tools that implement FileObject
      Modifier and Type Class and Description
      class  ForwardingFileObject<F extends FileObject>
      Forwards calls to a given file object.
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
      class  SimpleJavaFileObject
      Provides simple implementations for most methods in JavaFileObject.
      Fields in javax.tools declared as FileObject
      Modifier and Type Field and Description
      protected F ForwardingFileObject.fileObject
      The file object which all methods are delegated to.
      Methods in javax.tools that return FileObject
      Modifier and Type | Method and Description
      FileObject JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Methods in javax.tools with parameters of type FileObject
      Modifier and Type | Method and Description
      FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      boolean JavaFileManager.isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same underlying object.
      boolean StandardJavaFileManager.isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
      boolean | ForwardingJavaFileManager.isSameFile(FileObject a, FileObject b)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.ForwardingFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.ForwardingFileObject

  • Packages that use ForwardingFileObject
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of ForwardingFileObject in javax.tools

      Subclasses of ForwardingFileObject in javax.tools
      Modifier and Type Class and Description
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.ForwardingJavaFileManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.ForwardingJavaFileManager

No usage of javax.tools.ForwardingJavaFileManager
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.ForwardingJavaFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.ForwardingJavaFileObject

No usage of javax.tools.ForwardingJavaFileObject
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.JavaCompiler.CompilationTask (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.JavaCompiler.CompilationTask

  • Packages that use JavaCompiler.CompilationTask
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaCompiler.CompilationTask in javax.tools

      Methods in javax.tools that return JavaCompiler.CompilationTask
      Modifier and Type Method and Description
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.JavaCompiler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.JavaCompiler

  • Packages that use JavaCompiler
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaCompiler in javax.tools

      Methods in javax.tools that return JavaCompiler
      Modifier and Type Method and Description
      static JavaCompiler ToolProvider.getSystemJavaCompiler()
      Gets the Java™ programming language compiler provided with this platform.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.JavaFileManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.JavaFileManager

  • Packages that use JavaFileManager
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileManager in javax.tools

      Classes in javax.tools with type parameters of type JavaFileManager
      Modifier and Type Class and Description
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      Forwards calls to a given file manager.
      Subinterfaces of JavaFileManager in javax.tools
      Modifier and Type Interface and Description
      interface  StandardJavaFileManager
      File manager based on java.io.File.
      Classes in javax.tools that implement JavaFileManager
      Modifier and Type Class and Description
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      Forwards calls to a given file manager.
      Fields in javax.tools declared as JavaFileManager
      Modifier and Type Field and Description
      protected M ForwardingJavaFileManager.fileManager
      The file manager which all methods are delegated to.
      Methods in javax.tools with parameters of type JavaFileManager
      Modifier and Type Method and Description
      DocumentationTool.DocumentationTask DocumentationTool.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a documentation task with the given components and arguments.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.JavaFileManager.Location (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.JavaFileManager.Location

  • Packages that use JavaFileManager.Location
    Package Description
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileManager.Location in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type JavaFileManager.Location
      Modifier and Type Method and Description
      FileObject Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements)
      Creates a new auxiliary resource file for writing and returns a file object for it.
      FileObject Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName)
      Returns an object for reading an existing resource.

    • Uses of JavaFileManager.Location in javax.tools

      Classes in javax.tools that implement JavaFileManager.Location
      Modifier and Type Class and Description
      static class  DocumentationTool.Location
      Locations specific to DocumentationTool.
      class  StandardLocation
      Standard locations of file objects.
      Methods in javax.tools that return JavaFileManager.Location
      Modifier and Type Method and Description
      static JavaFileManager.Location StandardLocation.locationFor(String name)
      Gets a location object with the given name.
      Methods in javax.tools with parameters of type JavaFileManager.Location
      Modifier and Type | Method and Description
      ClassLoader JavaFileManager.getClassLoader(JavaFileManager.Location location)
      Gets a class loader for loading plug-ins from the given location.
      ClassLoader | ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location location)
      FileObject JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Iterable<? extends File> StandardJavaFileManager.getLocation(JavaFileManager.Location location)
      Gets the path associated with the given location.
      boolean JavaFileManager.hasLocation(JavaFileManager.Location location)
      Determines if a location is known to this file manager.
      boolean | ForwardingJavaFileManager.hasLocation(JavaFileManager.Location location)
      String JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      void StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path)
      Associates the given path with the given location.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.JavaFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.JavaFileObject

  • Packages that use JavaFileObject
    Package Description
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileObject in javax.annotation.processing

      Methods in javax.annotation.processing that return JavaFileObject
      Modifier and Type Method and Description
      JavaFileObject Filer.createClassFile(CharSequence name, Element... originatingElements)
      Creates a new class file, and returns an object to allow writing to it.
      JavaFileObject Filer.createSourceFile(CharSequence name, Element... originatingElements)
      Creates a new source file and returns an object to allow writing to it.

    • Uses of JavaFileObject in javax.tools

      Classes in javax.tools with type parameters of type JavaFileObject
      Modifier and Type Class and Description
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
      Classes in javax.tools that implement JavaFileObject
      Modifier and Type Class and Description
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
      class  SimpleJavaFileObject
      Provides simple implementations for most methods in JavaFileObject.
      Methods in javax.tools that return JavaFileObject
      Modifier and Type | Method and Description
      JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Methods in javax.tools that return types with arguments of type JavaFileObject
      Modifier and Type | Method and Description
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects(File... files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects(String... names)
      Gets file objects representing the given file names.
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names)
      Gets file objects representing the given file names.
      Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Methods in javax.tools with parameters of type JavaFileObject
      Modifier and Type | Method and Description
      String JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Method parameters in javax.tools with type arguments of type JavaFileObject
      Modifier and Type Method and Description
      StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      StandardJavaFileManager DocumentationTool.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      DocumentationTool.DocumentationTask DocumentationTool.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a documentation task with the given components and arguments.
      DocumentationTool.DocumentationTask DocumentationTool.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Class<?> docletClass, Iterable<String> options, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a documentation task with the given components and arguments.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.JavaFileObject.Kind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.JavaFileObject.Kind

  • Packages that use JavaFileObject.Kind
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileObject.Kind in javax.tools

      Fields in javax.tools declared as JavaFileObject.Kind
      Modifier and Type Field and Description
      protected JavaFileObject.Kind SimpleJavaFileObject.kind
      The kind of this file object.
      Methods in javax.tools that return JavaFileObject.Kind
      Modifier and Type | Method and Description
      JavaFileObject.Kind | ForwardingJavaFileObject.getKind()
      JavaFileObject.Kind JavaFileObject.getKind()
      Gets the kind of this file object.
      JavaFileObject.Kind | SimpleJavaFileObject.getKind()
      static JavaFileObject.Kind JavaFileObject.Kind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JavaFileObject.Kind[] JavaFileObject.Kind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.tools with parameters of type JavaFileObject.Kind
      Modifier and Type | Method and Description
      JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      boolean | ForwardingJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      boolean JavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Checks if this file object is compatible with the specified simple name and kind.
      boolean SimpleJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      This implementation compares the path of its URI to the given simple name.
      Method parameters in javax.tools with type arguments of type JavaFileObject.Kind
      Modifier and Type | Method and Description
      Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Constructors in javax.tools with parameters of type JavaFileObject.Kind
      Constructor and Description
      SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
      Construct a SimpleJavaFileObject of the given kind and with the given URI.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.OptionChecker (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.OptionChecker

  • Packages that use OptionChecker
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of OptionChecker in javax.tools

      Subinterfaces of OptionChecker in javax.tools
      Modifier and Type Interface and Description
      interface  DocumentationTool
      Interface to invoke Java™ programming language documentation tools from programs.
      interface  JavaCompiler
      Interface to invoke Java™ programming language compilers from programs.
      interface  JavaFileManager
      File manager for tools operating on Java™ programming language source and class files.
      interface  StandardJavaFileManager
      File manager based on java.io.File.
      Classes in javax.tools that implement OptionChecker
      Modifier and Type Class and Description
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      Forwards calls to a given file manager.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.SimpleJavaFileObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.SimpleJavaFileObject

No usage of javax.tools.SimpleJavaFileObject
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.StandardJavaFileManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.StandardJavaFileManager

  • Packages that use StandardJavaFileManager
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of StandardJavaFileManager in javax.tools

      Methods in javax.tools that return StandardJavaFileManager
      Modifier and Type Method and Description
      StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      StandardJavaFileManager DocumentationTool.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.StandardLocation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.StandardLocation

  • Packages that use StandardLocation
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of StandardLocation in javax.tools

      Methods in javax.tools that return StandardLocation
      Modifier and Type Method and Description
      static StandardLocation StandardLocation.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static StandardLocation[] StandardLocation.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.tools.Tool (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.tools.Tool

  • Packages that use Tool
    Package Description
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of Tool in javax.tools

      Subinterfaces of Tool in javax.tools
      Modifier and Type Interface and Description
      interface  DocumentationTool
      Interface to invoke Java™ programming language documentation tools from programs.
      interface  JavaCompiler
      Interface to invoke Java™ programming language compilers from programs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.tools.ToolProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.tools.ToolProvider

No usage of javax.tools.ToolProvider
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.transaction (Java Platform SE 8 )

compact2 - javax.transaction

Exceptions

  • InvalidTransactionException
  • TransactionRequiredException
  • TransactionRolledbackException


javax.transaction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.transaction

Contains three exceptions thrown by the ORB machinery during unmarshalling.

See: Description

  • Exception Summary
    Exception Description
    InvalidTransactionException
    This exception indicates that the request carried an invalid transaction context.
    TransactionRequiredException
    This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
    TransactionRolledbackException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

Package javax.transaction Description

Contains three exceptions thrown by the ORB machinery during unmarshalling.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.transaction (Java Platform SE 8 )

compact3 - javax.transaction

Exceptions

  • InvalidTransactionException
  • TransactionRequiredException
  • TransactionRolledbackException


javax.transaction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.transaction

Contains three exceptions thrown by the ORB machinery during unmarshalling.

See: Description

  • Exception Summary
    Exception Description
    InvalidTransactionException
    This exception indicates that the request carried an invalid transaction context.
    TransactionRequiredException
    This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
    TransactionRolledbackException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

Package javax.transaction Description

Contains three exceptions thrown by the ORB machinery during unmarshalling.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidTransactionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.transaction

Class InvalidTransactionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
  • All Implemented Interfaces:
    Serializable

    public class InvalidTransactionException
extends RemoteException
    This exception indicates that the request carried an invalid transaction context. For example, this exception could be raised if an error occured when trying to register a resource.
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidTransactionException()
      InvalidTransactionException(String msg)

    • Method Summary

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidTransactionException

        public InvalidTransactionException()

      • InvalidTransactionException

        public InvalidTransactionException(String msg)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.transaction (Java Platform SE 8 )

javax.transaction

Exceptions

  • InvalidTransactionException
  • TransactionRequiredException
  • TransactionRolledbackException


javax.transaction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.transaction

Contains three exceptions thrown by the ORB machinery during unmarshalling.

See: Description

  • Exception Summary
    Exception Description
    InvalidTransactionException
    This exception indicates that the request carried an invalid transaction context.
    TransactionRequiredException
    This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
    TransactionRolledbackException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

Package javax.transaction Description

Contains three exceptions thrown by the ORB machinery during unmarshalling.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.transaction Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.transaction

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.transaction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.transaction

No usage of javax.transaction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransactionRequiredException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.transaction

Class TransactionRequiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.TransactionRequiredException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRequiredException
extends RemoteException
    This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRequiredException()
      TransactionRequiredException(String msg)

    • Method Summary

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRequiredException

        public TransactionRequiredException()

      • TransactionRequiredException

        public TransactionRequiredException(String msg)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransactionRolledbackException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.transaction

Class TransactionRolledbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.TransactionRolledbackException
  • All Implemented Interfaces:
    Serializable

    public class TransactionRolledbackException
extends RemoteException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless
    See Also:
    Serialized Form

    • Field Summary

      • Fields inherited from class java.rmi.RemoteException

        detail

    • Constructor Summary

      Constructors
      Constructor and Description
      TransactionRolledbackException()
      TransactionRolledbackException(String msg)

    • Method Summary

      • Methods inherited from class java.rmi.RemoteException

        getCause, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransactionRolledbackException

        public TransactionRolledbackException()

      • TransactionRolledbackException

        public TransactionRolledbackException(String msg)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.transaction.InvalidTransactionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.transaction.InvalidTransactionException

No usage of javax.transaction.InvalidTransactionException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.transaction.TransactionRequiredException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.transaction.TransactionRequiredException

No usage of javax.transaction.TransactionRequiredException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.transaction.TransactionRolledbackException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.transaction.TransactionRolledbackException

No usage of javax.transaction.TransactionRolledbackException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.transaction.xa (Java Platform SE 8 )

compact2 - javax.transaction.xa

Interfaces

  • XAResource
  • Xid

Exceptions

  • XAException


javax.transaction.xa (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

See: Description

  • Interface Summary
    Interface Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Exception Summary
    Exception Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

Package javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.transaction.xa (Java Platform SE 8 )

compact3 - javax.transaction.xa

Interfaces

  • XAResource
  • Xid

Exceptions

  • XAException


javax.transaction.xa (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

See: Description

  • Interface Summary
    Interface Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Exception Summary
    Exception Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

Package javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.transaction.xa (Java Platform SE 8 )

javax.transaction.xa

Interfaces

  • XAResource
  • Xid

Exceptions

  • XAException


javax.transaction.xa (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

See: Description

  • Interface Summary
    Interface Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Exception Summary
    Exception Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

Package javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.transaction.xa Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.transaction.xa

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.xa.XAException

Interface Hierarchy

  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.transaction.xa (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.transaction.xa

  • Packages that use javax.transaction.xa
    Package Description
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.
  • Classes in javax.transaction.xa used by javax.sql
    Class and Description
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
  • Classes in javax.transaction.xa used by javax.transaction.xa
    Class and Description
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XAException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.transaction.xa

Class XAException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.xa.XAException
  • All Implemented Interfaces:
    Serializable

    public class XAException
extends Exception
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      int errorCode
      The error code with which to create the SystemException.
      static int XA_HEURCOM
      The transaction branch has been heuristically committed.
      static int XA_HEURHAZ
      The transaction branch may have been heuristically completed.
      static int XA_HEURMIX
      The transaction branch has been heuristically committed and rolled back.
      static int XA_HEURRB
      The transaction branch has been heuristically rolled back.
      static int XA_NOMIGRATE
      Resumption must occur where the suspension occurred.
      static int XA_RBBASE
      The inclusive lower bound of the rollback codes.
      static int XA_RBCOMMFAIL
      Indicates that the rollback was caused by a communication failure.
      static int XA_RBDEADLOCK
      A deadlock was detected.
      static int XA_RBEND
      The inclusive upper bound of the rollback error code.
      static int XA_RBINTEGRITY
      A condition that violates the integrity of the resource was detected.
      static int XA_RBOTHER
      The resource manager rolled back the transaction branch for a reason not on this list.
      static int XA_RBPROTO
      A protocol error occurred in the resource manager.
      static int XA_RBROLLBACK
      Indicates that the rollback was caused by an unspecified reason.
      static int XA_RBTIMEOUT
      A transaction branch took too long.
      static int XA_RBTRANSIENT
      May retry the transaction branch.
      static int XA_RDONLY
      The transaction branch was read-only and has been committed.
      static int XA_RETRY
      Routine returned with no effect and may be reissued.
      static int XAER_ASYNC
      There is an asynchronous operation already outstanding.
      static int XAER_DUPID
      The XID already exists.
      static int XAER_INVAL
      Invalid arguments were given.
      static int XAER_NOTA
      The XID is not valid.
      static int XAER_OUTSIDE
      The resource manager is doing work outside a global transaction.
      static int XAER_PROTO
      Routine was invoked in an inproper context.
      static int XAER_RMERR
      A resource manager error has occurred in the transaction branch.
      static int XAER_RMFAIL
      Resource manager is unavailable.

    • Constructor Summary

      Constructors
      Constructor and Description
      XAException()
      Create an XAException.
      XAException(int errcode)
      Create an XAException with a given error code.
      XAException(String s)
      Create an XAException with a given string.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • errorCode

        public int errorCode
        The error code with which to create the SystemException.

      • XA_RBBASE

        public static final int XA_RBBASE
        The inclusive lower bound of the rollback codes.
        See Also:
        Constant Field Values

      • XA_RBROLLBACK

        public static final int XA_RBROLLBACK
        Indicates that the rollback was caused by an unspecified reason.
        See Also:
        Constant Field Values

      • XA_RBCOMMFAIL

        public static final int XA_RBCOMMFAIL
        Indicates that the rollback was caused by a communication failure.
        See Also:
        Constant Field Values

      • XA_RBDEADLOCK

        public static final int XA_RBDEADLOCK
        A deadlock was detected.
        See Also:
        Constant Field Values

      • XA_RBINTEGRITY

        public static final int XA_RBINTEGRITY
        A condition that violates the integrity of the resource was detected.
        See Also:
        Constant Field Values

      • XA_RBOTHER

        public static final int XA_RBOTHER
        The resource manager rolled back the transaction branch for a reason not on this list.
        See Also:
        Constant Field Values

      • XA_RBPROTO

        public static final int XA_RBPROTO
        A protocol error occurred in the resource manager.
        See Also:
        Constant Field Values

      • XA_RBTIMEOUT

        public static final int XA_RBTIMEOUT
        A transaction branch took too long.
        See Also:
        Constant Field Values

      • XA_RBTRANSIENT

        public static final int XA_RBTRANSIENT
        May retry the transaction branch.
        See Also:
        Constant Field Values

      • XA_RBEND

        public static final int XA_RBEND
        The inclusive upper bound of the rollback error code.
        See Also:
        Constant Field Values

      • XA_NOMIGRATE

        public static final int XA_NOMIGRATE
        Resumption must occur where the suspension occurred.
        See Also:
        Constant Field Values

      • XA_HEURHAZ

        public static final int XA_HEURHAZ
        The transaction branch may have been heuristically completed.
        See Also:
        Constant Field Values

      • XA_HEURCOM

        public static final int XA_HEURCOM
        The transaction branch has been heuristically committed.
        See Also:
        Constant Field Values

      • XA_HEURRB

        public static final int XA_HEURRB
        The transaction branch has been heuristically rolled back.
        See Also:
        Constant Field Values

      • XA_HEURMIX

        public static final int XA_HEURMIX
        The transaction branch has been heuristically committed and rolled back.
        See Also:
        Constant Field Values

      • XA_RETRY

        public static final int XA_RETRY
        Routine returned with no effect and may be reissued.
        See Also:
        Constant Field Values

      • XA_RDONLY

        public static final int XA_RDONLY
        The transaction branch was read-only and has been committed.
        See Also:
        Constant Field Values

      • XAER_ASYNC

        public static final int XAER_ASYNC
        There is an asynchronous operation already outstanding.
        See Also:
        Constant Field Values

      • XAER_RMERR

        public static final int XAER_RMERR
        A resource manager error has occurred in the transaction branch.
        See Also:
        Constant Field Values

      • XAER_NOTA

        public static final int XAER_NOTA
        The XID is not valid.
        See Also:
        Constant Field Values

      • XAER_INVAL

        public static final int XAER_INVAL
        Invalid arguments were given.
        See Also:
        Constant Field Values

      • XAER_PROTO

        public static final int XAER_PROTO
        Routine was invoked in an inproper context.
        See Also:
        Constant Field Values

      • XAER_RMFAIL

        public static final int XAER_RMFAIL
        Resource manager is unavailable.
        See Also:
        Constant Field Values

      • XAER_DUPID

        public static final int XAER_DUPID
        The XID already exists.
        See Also:
        Constant Field Values

      • XAER_OUTSIDE

        public static final int XAER_OUTSIDE
        The resource manager is doing work outside a global transaction.
        See Also:
        Constant Field Values

    • Constructor Detail

      • XAException

        public XAException()
        Create an XAException.

      • XAException

        public XAException(String s)
        Create an XAException with a given string.
        Parameters:
        s - The String object containing the exception message.

      • XAException

        public XAException(int errcode)
        Create an XAException with a given error code.
        Parameters:
        errcode - The error code identifying the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XAResource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.transaction.xa

Interface XAResource

  • public interface XAResource

    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).

    The XA interface defines the contract between a Resource Manager and a Transaction Manager in a distributed transaction processing (DTP) environment. A JDBC driver or a JMS provider implements this interface to support the association between a global transaction and a database or message service connection.

    The XAResource interface can be supported by any transactional resource that is intended to be used by application programs in an environment where transactions are controlled by an external transaction manager. An example of such a resource is a database management system. An application may access data through multiple database connections. Each database connection is enlisted with the transaction manager as a transactional resource. The transaction manager obtains an XAResource for each connection participating in a global transaction. The transaction manager uses the start method to associate the global transaction with the resource, and it uses the end method to disassociate the transaction from the resource. The resource manager is responsible for associating the global transaction to all work performed on its data between the start and end method invocations.

    At transaction commit time, the resource managers are informed by the transaction manager to prepare, commit, or rollback a transaction according to the two-phase commit protocol.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int TMENDRSCAN
      Ends a recovery scan.
      static int TMFAIL
      Disassociates the caller and marks the transaction branch rollback-only.
      static int TMJOIN
      Caller is joining existing transaction branch.
      static int TMNOFLAGS
      Use TMNOFLAGS to indicate no flags value is selected.
      static int TMONEPHASE
      Caller is using one-phase optimization.
      static int TMRESUME
      Caller is resuming association with a suspended transaction branch.
      static int TMSTARTRSCAN
      Starts a recovery scan.
      static int TMSUCCESS
      Disassociates caller from a transaction branch.
      static int TMSUSPEND
      Caller is suspending (not ending) its association with a transaction branch.
      static int XA_OK
      The transaction work has been prepared normally.
      static int XA_RDONLY
      The transaction branch has been read-only and has been committed.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int getTransactionTimeout()
      Obtains the current transaction timeout value set for this XAResource instance.
      boolean isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
      int prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      boolean setTransactionTimeout(int seconds)
      Sets the current transaction timeout value for this XAResource instance.
      void start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.

    • Field Detail

      • TMENDRSCAN

        static final int TMENDRSCAN
        Ends a recovery scan.
        See Also:
        Constant Field Values

      • TMFAIL

        static final int TMFAIL
        Disassociates the caller and marks the transaction branch rollback-only.
        See Also:
        Constant Field Values

      • TMJOIN

        static final int TMJOIN
        Caller is joining existing transaction branch.
        See Also:
        Constant Field Values

      • TMNOFLAGS

        static final int TMNOFLAGS
        Use TMNOFLAGS to indicate no flags value is selected.
        See Also:
        Constant Field Values

      • TMONEPHASE

        static final int TMONEPHASE
        Caller is using one-phase optimization.
        See Also:
        Constant Field Values

      • TMRESUME

        static final int TMRESUME
        Caller is resuming association with a suspended transaction branch.
        See Also:
        Constant Field Values

      • TMSTARTRSCAN

        static final int TMSTARTRSCAN
        Starts a recovery scan.
        See Also:
        Constant Field Values

      • TMSUCCESS

        static final int TMSUCCESS
        Disassociates caller from a transaction branch.
        See Also:
        Constant Field Values

      • TMSUSPEND

        static final int TMSUSPEND
        Caller is suspending (not ending) its association with a transaction branch.
        See Also:
        Constant Field Values

      • XA_RDONLY

        static final int XA_RDONLY
        The transaction branch has been read-only and has been committed.
        See Also:
        Constant Field Values

      • XA_OK

        static final int XA_OK
        The transaction work has been prepared normally.
        See Also:
        Constant Field Values

    • Method Detail

      • commit

        void commit(Xid xid,
            boolean onePhase)
     throws XAException
        Commits the global transaction specified by xid.
        Parameters:
        xid - A global transaction identifier
        onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
        Throws:
        XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

        If the resource manager did not commit the transaction and the paramether onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

      • end

        void end(Xid xid,
         int flags)
  throws XAException
        Ends the work performed on behalf of a transaction branch. The resource manager disassociates the XA resource from the transaction branch specified and lets the transaction complete.

        If TMSUSPEND is specified in the flags, the transaction branch is temporarily suspended in an incomplete state. The transaction context is in a suspended state and must be resumed via the start method with TMRESUME specified.

        If TMFAIL is specified, the portion of work has failed. The resource manager may mark the transaction as rollback-only

        If TMSUCCESS is specified, the portion of work has completed successfully.

        Parameters:
        xid - A global transaction identifier that is the same as the identifier used previously in the start method.
        flags - One of TMSUCCESS, TMFAIL, or TMSUSPEND.
        Throws:
        XAException - An error has occurred. Possible XAException values are XAER_RMERR, XAER_RMFAILED, XAER_NOTA, XAER_INVAL, XAER_PROTO, or XA_RB*.

      • forget

        void forget(Xid xid)
     throws XAException
        Tells the resource manager to forget about a heuristically completed transaction branch.
        Parameters:
        xid - A global transaction identifier.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • getTransactionTimeout

        int getTransactionTimeout()
                   throws XAException
        Obtains the current transaction timeout value set for this XAResource instance. If XAResource.setTransactionTimeout was not used prior to invoking this method, the return value is the default timeout set for the resource manager; otherwise, the value used in the previous setTransactionTimeout call is returned.
        Returns:
        the transaction timeout value in seconds.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

      • isSameRM

        boolean isSameRM(XAResource xares)
          throws XAException
        This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
        Parameters:
        xares - An XAResource object whose resource manager instance is to be compared with the resource manager instance of the target object.
        Returns:
        true if it's the same RM instance; otherwise false.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

      • prepare

        int prepare(Xid xid)
     throws XAException
        Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
        Parameters:
        xid - A global transaction identifier.
        Returns:
        A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
        Throws:
        XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • recover

        Xid[] recover(int flag)
       throws XAException
        Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.
        Parameters:
        flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter.
        Returns:
        The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
        Throws:
        XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

      • rollback

        void rollback(Xid xid)
       throws XAException
        Informs the resource manager to roll back work done on behalf of a transaction branch.
        Parameters:
        xid - A global transaction identifier.
        Throws:
        XAException - An error has occurred.

      • setTransactionTimeout

        boolean setTransactionTimeout(int seconds)
                       throws XAException

        Sets the current transaction timeout value for this XAResource instance. Once set, this timeout value is effective until setTransactionTimeout is invoked again with a different value. To reset the timeout value to the default value used by the resource manager, set the value to zero. If the timeout operation is performed successfully, the method returns true; otherwise false. If a resource manager does not support explicitly setting the transaction timeout value, this method returns false.

        Parameters:
        seconds - The transaction timeout value in seconds.
        Returns:
        true if the transaction timeout value is set successfully; otherwise false.
        Throws:
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, or XAER_INVAL.

      • start

        void start(Xid xid,
           int flags)
    throws XAException
        Starts work on behalf of a transaction branch specified in xid. If TMJOIN is specified, the start applies to joining a transaction previously seen by the resource manager. If TMRESUME is specified, the start applies to resuming a suspended transaction specified in the parameter xid. If neither TMJOIN nor TMRESUME is specified and the transaction specified by xid has previously been seen by the resource manager, the resource manager throws the XAException exception with XAER_DUPID error code.
        Parameters:
        xid - A global transaction identifier to be associated with the resource.
        flags - One of TMNOFLAGS, TMJOIN, or TMRESUME.
        Throws:
        XAException - An error has occurred. Possible exceptions are XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_DUPID, XAER_OUTSIDE, XAER_NOTA, XAER_INVAL, or XAER_PROTO.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Xid (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.transaction.xa

Interface Xid

  • public interface Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure. This interface specifies three accessor methods to retrieve a global transaction format ID, global transaction ID, and branch qualifier. The Xid interface is used by the transaction manager and the resource managers. This interface is not visible to the application programs.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int MAXBQUALSIZE
      Maximum number of bytes returned by getBqual.
      static int MAXGTRIDSIZE
      Maximum number of bytes returned by getGtrid.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] getBranchQualifier()
      Obtain the transaction branch identifier part of XID as an array of bytes.
      int getFormatId()
      Obtain the format identifier part of the XID.
      byte[] getGlobalTransactionId()
      Obtain the global transaction identifier part of XID as an array of bytes.

    • Field Detail

      • MAXGTRIDSIZE

        static final int MAXGTRIDSIZE
        Maximum number of bytes returned by getGtrid.
        See Also:
        Constant Field Values

      • MAXBQUALSIZE

        static final int MAXBQUALSIZE
        Maximum number of bytes returned by getBqual.
        See Also:
        Constant Field Values

    • Method Detail

      • getFormatId

        int getFormatId()
        Obtain the format identifier part of the XID.
        Returns:
        Format identifier. O means the OSI CCR format.

      • getGlobalTransactionId

        byte[] getGlobalTransactionId()
        Obtain the global transaction identifier part of XID as an array of bytes.
        Returns:
        Global transaction identifier.

      • getBranchQualifier

        byte[] getBranchQualifier()
        Obtain the transaction branch identifier part of XID as an array of bytes.
        Returns:
        Global transaction identifier.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.transaction.xa.XAException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.transaction.xa.XAException

  • Packages that use XAException
    Package Description
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of XAException in javax.transaction.xa

      Methods in javax.transaction.xa that throw XAException
      Modifier and Type Method and Description
      void XAResource.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XAResource.end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void XAResource.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XAResource.getTransactionTimeout()
      Obtains the current transaction timeout value set for this XAResource instance.
      boolean XAResource.isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
      int XAResource.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] XAResource.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void XAResource.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      boolean XAResource.setTransactionTimeout(int seconds)
      Sets the current transaction timeout value for this XAResource instance.
      void XAResource.start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.transaction.xa.XAResource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.xa.XAResource

  • Packages that use XAResource
    Package Description
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of XAResource in javax.sql

      Methods in javax.sql that return XAResource
      Modifier and Type Method and Description
      XAResource XAConnection.getXAResource()
      Retrieves an XAResource object that the transaction manager will use to manage this XAConnection object's participation in a distributed transaction.

    • Uses of XAResource in javax.transaction.xa

      Methods in javax.transaction.xa with parameters of type XAResource
      Modifier and Type Method and Description
      boolean XAResource.isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.transaction.xa.Xid (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.transaction.xa.Xid

  • Packages that use Xid
    Package Description
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of Xid in javax.transaction.xa

      Methods in javax.transaction.xa that return Xid
      Modifier and Type Method and Description
      Xid[] XAResource.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      Methods in javax.transaction.xa with parameters of type Xid
      Modifier and Type Method and Description
      void XAResource.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XAResource.end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void XAResource.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XAResource.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      void XAResource.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      void XAResource.start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml (Java Platform SE 8 )

compact2 - javax.xml

Classes

  • XMLConstants


javax.xml (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml

  • Class Summary
    Class Description
    XMLConstants
    Utility class to contain basic XML values as constants.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml (Java Platform SE 8 )

compact3 - javax.xml

Classes

  • XMLConstants


javax.xml (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml

  • Class Summary
    Class Description
    XMLConstants
    Utility class to contain basic XML values as constants.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml (Java Platform SE 8 )

javax.xml

Classes

  • XMLConstants


javax.xml (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml

  • Class Summary
    Class Description
    XMLConstants
    Utility class to contain basic XML values as constants.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.XMLConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml

No usage of javax.xml
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml

Class XMLConstants

  • java.lang.Object
    • javax.xml.XMLConstants

  • public final class XMLConstants
extends Object

    Utility class to contain basic XML values as constants.

    Since:
    1.5
    Version:
    $Revision: 1.8 $, $Date: 2010/05/25 16:19:45 $
    See Also:
    Extensible Markup Language (XML) 1.1, Extensible Markup Language (XML) 1.0 (Second Edition), XML 1.0 Second Edition Specification Errata, Namespaces in XML 1.1, Namespaces in XML, Namespaces in XML Errata, XML Schema Part 1: Structures

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ACCESS_EXTERNAL_DTD
      Property: accessExternalDTD
      static String ACCESS_EXTERNAL_SCHEMA
      Property: accessExternalSchema
      static String ACCESS_EXTERNAL_STYLESHEET
      Property: accessExternalStylesheet
      static String DEFAULT_NS_PREFIX
      Prefix to use to represent the default XML Namespace.
      static String FEATURE_SECURE_PROCESSING
      Feature for secure processing.
      static String NULL_NS_URI
      Namespace URI to use to represent that there is no Namespace.
      static String RELAXNG_NS_URI
      RELAX NG Namespace URI.
      static String W3C_XML_SCHEMA_INSTANCE_NS_URI
      W3C XML Schema Instance Namespace URI.
      static String W3C_XML_SCHEMA_NS_URI
      W3C XML Schema Namespace URI.
      static String W3C_XPATH_DATATYPE_NS_URI
      W3C XPath Datatype Namespace URI.
      static String XML_DTD_NS_URI
      XML Document Type Declaration Namespace URI as an arbitrary value.
      static String XML_NS_PREFIX
      The official XML Namespace prefix.
      static String XML_NS_URI
      The official XML Namespace name URI.
      static String XMLNS_ATTRIBUTE
      The official XML attribute used for specifying XML Namespace declarations.
      static String XMLNS_ATTRIBUTE_NS_URI
      The official XML attribute used for specifying XML Namespace declarations, XMLConstants.XMLNS_ATTRIBUTE, Namespace name URI.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • NULL_NS_URI

        public static final String NULL_NS_URI

        Namespace URI to use to represent that there is no Namespace.

        Defined by the Namespace specification to be "".

        See Also:
        Namespaces in XML, 5.2 Namespace Defaulting, Constant Field Values

      • DEFAULT_NS_PREFIX

        public static final String DEFAULT_NS_PREFIX

        Prefix to use to represent the default XML Namespace.

        Defined by the XML specification to be "".

        See Also:
        Namespaces in XML, 3. Qualified Names, Constant Field Values

      • XML_NS_URI

        public static final String XML_NS_URI

        The official XML Namespace name URI.

        Defined by the XML specification to be "http://www.w3.org/XML/1998/namespace".

        See Also:
        Namespaces in XML, 3. Qualified Names, Constant Field Values

      • XML_NS_PREFIX

        public static final String XML_NS_PREFIX

        The official XML Namespace prefix.

        Defined by the XML specification to be "xml".

        See Also:
        Namespaces in XML, 3. Qualified Names<, Constant Field Values

      • XMLNS_ATTRIBUTE_NS_URI

        public static final String XMLNS_ATTRIBUTE_NS_URI

        The official XML attribute used for specifying XML Namespace declarations, XMLConstants.XMLNS_ATTRIBUTE, Namespace name URI.

        Defined by the XML specification to be "http://www.w3.org/2000/xmlns/".

        See Also:
        Namespaces in XML, 3. Qualified Names, Namespaces in XML Errata, Constant Field Values

      • XMLNS_ATTRIBUTE

        public static final String XMLNS_ATTRIBUTE

        The official XML attribute used for specifying XML Namespace declarations.

        It is NOT valid to use as a prefix. Defined by the XML specification to be "xmlns".

        See Also:
        Namespaces in XML, 3. Qualified Names, Constant Field Values

      • W3C_XML_SCHEMA_NS_URI

        public static final String W3C_XML_SCHEMA_NS_URI

        W3C XML Schema Namespace URI.

        Defined to be "http://www.w3.org/2001/XMLSchema".

        See Also:
        XML Schema Part 1: Structures, 2.6 Schema-Related Markup in Documents Being Validated, Constant Field Values

      • W3C_XML_SCHEMA_INSTANCE_NS_URI

        public static final String W3C_XML_SCHEMA_INSTANCE_NS_URI

        W3C XML Schema Instance Namespace URI.

        Defined to be "http://www.w3.org/2001/XMLSchema-instance".

        See Also:
        XML Schema Part 1: Structures, 2.6 Schema-Related Markup in Documents Being Validated, Constant Field Values

      • W3C_XPATH_DATATYPE_NS_URI

        public static final String W3C_XPATH_DATATYPE_NS_URI

        W3C XPath Datatype Namespace URI.

        Defined to be "http://www.w3.org/2003/11/xpath-datatypes".

        See Also:
        XQuery 1.0 and XPath 2.0 Data Model, Constant Field Values

      • XML_DTD_NS_URI

        public static final String XML_DTD_NS_URI

        XML Document Type Declaration Namespace URI as an arbitrary value.

        Since not formally defined by any existing standard, arbitrarily define to be "http://www.w3.org/TR/REC-xml".

        See Also:
        Constant Field Values

      • RELAXNG_NS_URI

        public static final String RELAXNG_NS_URI

        RELAX NG Namespace URI.

        Defined to be "http://relaxng.org/ns/structure/1.0".

        See Also:
        RELAX NG Specification, Constant Field Values

      • FEATURE_SECURE_PROCESSING

        public static final String FEATURE_SECURE_PROCESSING

        Feature for secure processing.

        • true instructs the implementation to process XML securely. This may set limits on XML constructs to avoid conditions such as denial of service attacks.
        • false instructs the implementation to process XML in accordance with the XML specifications ignoring security issues such as limits on XML constructs to avoid conditions such as denial of service attacks.
        See Also:
        Constant Field Values

      • ACCESS_EXTERNAL_DTD

        public static final String ACCESS_EXTERNAL_DTD

        Property: accessExternalDTD

        Restrict access to external DTDs and external Entity References to the protocols specified. If access is denied due to the restriction of this property, a runtime exception that is specific to the context is thrown. In the case of SAXParser for example, SAXException is thrown.

        Value: a list of protocols separated by comma. A protocol is the scheme portion of a URI, or in the case of the JAR protocol, "jar" plus the scheme portion separated by colon. A scheme is defined as:

        scheme = alpha *( alpha | digit | "+" | "-" | "." )
        where alpha = a-z and A-Z.

        And the JAR protocol:
        jar[:scheme]

        Protocols including the keyword "jar" are case-insensitive. Any whitespaces as defined by Character.isSpaceChar(char) in the value will be ignored. Examples of protocols are file, http, jar:file.

        Default value: The default value is implementation specific and therefore not specified. The following options are provided for consideration:

        • an empty string to deny all access to external references;
        • a specific protocol, such as file, to give permission to only the protocol;
        • the keyword "all" to grant permission to all protocols.

        When FEATURE_SECURE_PROCESSING is enabled, it is recommended that implementations restrict external connections by default, though this may cause problems for applications that process XML/XSD/XSL with external references.

        Granting all access: the keyword "all" grants permission to all protocols.

        System Property: The value of this property can be set or overridden by system property javax.xml.accessExternalDTD.

        ${JAVA_HOME}/lib/jaxp.properties: This configuration file is in standard Properties format. If the file exists and the system property is specified, its value will be used to override the default of the property.

        Since:
        1.7
        See Also:
        Constant Field Values

      • ACCESS_EXTERNAL_SCHEMA

        public static final String ACCESS_EXTERNAL_SCHEMA

        Property: accessExternalSchema

        Restrict access to the protocols specified for external reference set by the schemaLocation attribute, Import and Include element. If access is denied due to the restriction of this property, a runtime exception that is specific to the context is thrown. In the case of SchemaFactory for example, org.xml.sax.SAXException is thrown.

        Value: a list of protocols separated by comma. A protocol is the scheme portion of a URI, or in the case of the JAR protocol, "jar" plus the scheme portion separated by colon. A scheme is defined as:

        scheme = alpha *( alpha | digit | "+" | "-" | "." )
        where alpha = a-z and A-Z.

        And the JAR protocol:
        jar[:scheme]

        Protocols including the keyword "jar" are case-insensitive. Any whitespaces as defined by Character.isSpaceChar(char) in the value will be ignored. Examples of protocols are file, http, jar:file.

        Default value: The default value is implementation specific and therefore not specified. The following options are provided for consideration:

        • an empty string to deny all access to external references;
        • a specific protocol, such as file, to give permission to only the protocol;
        • the keyword "all" to grant permission to all protocols.

        When FEATURE_SECURE_PROCESSING is enabled, it is recommended that implementations restrict external connections by default, though this may cause problems for applications that process XML/XSD/XSL with external references.

        Granting all access: the keyword "all" grants permission to all protocols.

        System Property: The value of this property can be set or overridden by system property javax.xml.accessExternalSchema

        ${JAVA_HOME}/lib/jaxp.properties: This configuration file is in standard java.util.Properties format. If the file exists and the system property is specified, its value will be used to override the default of the property.

        Since:
        1.7

        See Also:
        Constant Field Values

      • ACCESS_EXTERNAL_STYLESHEET

        public static final String ACCESS_EXTERNAL_STYLESHEET

        Property: accessExternalStylesheet

        Restrict access to the protocols specified for external references set by the stylesheet processing instruction, Import and Include element, and document function. If access is denied due to the restriction of this property, a runtime exception that is specific to the context is thrown. In the case of constructing new Transformer for example, TransformerConfigurationException will be thrown by the TransformerFactory.

        Value: a list of protocols separated by comma. A protocol is the scheme portion of a URI, or in the case of the JAR protocol, "jar" plus the scheme portion separated by colon. A scheme is defined as:

        scheme = alpha *( alpha | digit | "+" | "-" | "." )
        where alpha = a-z and A-Z.

        And the JAR protocol:
        jar[:scheme]

        Protocols including the keyword "jar" are case-insensitive. Any whitespaces as defined by Character.isSpaceChar(char) in the value will be ignored. Examples of protocols are file, http, jar:file.

        Default value: The default value is implementation specific and therefore not specified. The following options are provided for consideration:

        • an empty string to deny all access to external references;
        • a specific protocol, such as file, to give permission to only the protocol;
        • the keyword "all" to grant permission to all protocols.

        When FEATURE_SECURE_PROCESSING is enabled, it is recommended that implementations restrict external connections by default, though this may cause problems for applications that process XML/XSD/XSL with external references.

        Granting all access: the keyword "all" grants permission to all protocols.

        System Property: The value of this property can be set or overridden by system property javax.xml.accessExternalStylesheet

        ${JAVA_HOME}/lib/jaxp.properties: This configuration file is in standard java.util.Properties format. If the file exists and the system property is specified, its value will be used to override the default of the property.

        Since:
        1.7
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Binder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class Binder<XmlNode>

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>

  • public abstract class Binder<XmlNode>
extends Object
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.

    An instance of this class maintains the association between XML nodes of an infoset preserving view and a JAXB representation of an XML document. Navigation between the two views is provided by the methods getXMLNode(Object) and getJAXBNode(Object).

    Modifications can be made to either the infoset preserving view or the JAXB representation of the document while the other view remains unmodified. The binder is able to synchronize the changes made in the modified view back into the other view using the appropriate Binder update methods, updateXML(Object, Object) or updateJAXB(Object).

    A typical usage scenario is the following:

    • load XML document into an XML infoset representation
    • unmarshal(Object) XML infoset view to JAXB view. (Note to conserve resources, it is possible to only unmarshal a subtree of the XML infoset view to the JAXB view.)
    • application access/updates JAXB view of XML document.
    • updateXML(Object) synchronizes modifications to JAXB view back into the XML infoset view. Update operation preserves as much of original XML infoset as possible (i.e. comments, PI, ...)

    A Binder instance is created using the factory method JAXBContext.createBinder() or JAXBContext.createBinder(Class).

    The template parameter, XmlNode, is the root interface/class for the XML infoset preserving representation. A Binder implementation is required to minimally support an XmlNode value of org.w3c.dom.Node.class. A Binder implementation can support alternative XML infoset preserving representations.

    Since:
    JAXB 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      Binder()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract Object getJAXBNode(XmlNode xmlNode)
      Gets the JAXB object associated with the given XML element.
      abstract Object getProperty(String name)
      Get the particular property in the underlying implementation of Binder.
      abstract Schema getSchema()
      Gets the last Schema object (including null) set by the setSchema(Schema) method.
      abstract XmlNode getXMLNode(Object jaxbObject)
      Gets the XML element associated with the given JAXB object.
      abstract void marshal(Object jaxbObject, XmlNode xmlNode)
      Marshal a JAXB object tree to a new XML document.
      abstract void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      abstract void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Binder.
      abstract void setSchema(Schema schema)
      Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
      abstract Object unmarshal(XmlNode xmlNode)
      Unmarshal XML infoset view to a JAXB object tree.
      abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode, Class<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      abstract Object updateJAXB(XmlNode xmlNode)
      Takes an XML node and updates its associated JAXB object and its descendants.
      abstract XmlNode updateXML(Object jaxbObject)
      Takes an JAXB object and updates its associated XML node and its descendants.
      abstract XmlNode updateXML(Object jaxbObject, XmlNode xmlNode)
      Changes in JAXB object tree are updated in its associated XML parse tree.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Binder

        public Binder()

    • Method Detail

      • unmarshal

        public abstract Object unmarshal(XmlNode xmlNode)
                          throws JAXBException
        Unmarshal XML infoset view to a JAXB object tree.

        This method is similar to Unmarshaller.unmarshal(Node) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

        This method throws UnmarshalException when the Binder's JAXBContext does not have a mapping for the XML element name or the type, specifiable via @xsi:type, of xmlNode to a JAXB mapped class. The method unmarshal(Object, Class) enables an application to specify the JAXB mapped class that the xmlNode should be mapped to.

        Parameters:
        xmlNode - the document/element to unmarshal XML data from.
        Returns:
        the newly created root object of the JAXB object tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
        IllegalArgumentException - If the node parameter is null

      • unmarshal

        public abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode,
                                             Class<T> declaredType)
                                      throws JAXBException
        Unmarshal XML root element by provided declaredType to a JAXB object tree.

        Implements Unmarshal by Declared Type

        This method is similar to Unmarshaller.unmarshal(Node, Class) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

        Parameters:
        xmlNode - the document/element to unmarshal XML data from.
        declaredType - appropriate JAXB mapped class to hold node's XML data.
        Returns:
        JAXB Element representation of node
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
        IllegalArgumentException - If any of the input parameters are null
        Since:
        JAXB2.0

      • marshal

        public abstract void marshal(Object jaxbObject,
                             XmlNode xmlNode)
                      throws JAXBException
        Marshal a JAXB object tree to a new XML document.

        This method is similar to Marshaller.marshal(Object, Node) with the addition of maintaining the association between JAXB objects and the produced XML nodes, enabling future update operations such as updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, the marshalled xml content is validated during this operation.

        Parameters:
        jaxbObject - The content tree to be marshalled.
        xmlNode - The parameter must be a Node that accepts children.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to marshal jaxbObject (or any object reachable from jaxbObject).
        IllegalArgumentException - If any of the method parameters are null

      • getXMLNode

        public abstract XmlNode getXMLNode(Object jaxbObject)
        Gets the XML element associated with the given JAXB object.

        Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

        An association between an XML element and a JAXB object is established by the bind methods and the update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

        Parameters:
        jaxbObject - An instance that is reachable from a prior call to a bind or update method that returned a JAXB object tree.
        Returns:
        null if the specified JAXB object is not known to this Binder, or if it is not associated with an XML element.
        Throws:
        IllegalArgumentException - If the jaxbObject parameter is null

      • getJAXBNode

        public abstract Object getJAXBNode(XmlNode xmlNode)
        Gets the JAXB object associated with the given XML element.

        Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

        An association between an XML element and a JAXB object is established by the unmarshal, marshal and update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

        Returns:
        null if the specified XML node is not known to this Binder, or if it is not associated with a JAXB object.
        Throws:
        IllegalArgumentException - If the node parameter is null

      • updateXML

        public abstract XmlNode updateXML(Object jaxbObject)
                           throws JAXBException
        Takes an JAXB object and updates its associated XML node and its descendants.

        This is a convenience method of:

         updateXML( jaxbObject, getXMLNode(jaxbObject));
        Throws:
        JAXBException - If any unexpected problem occurs updating corresponding XML content.
        IllegalArgumentException - If the jaxbObject parameter is null

      • updateXML

        public abstract XmlNode updateXML(Object jaxbObject,
                                  XmlNode xmlNode)
                           throws JAXBException
        Changes in JAXB object tree are updated in its associated XML parse tree.

        This operation can be thought of as an "in-place" marshalling. The difference is that instead of creating a whole new XML tree, this operation updates an existing tree while trying to preserve the XML as much as possible.

        For example, unknown elements/attributes in XML that were not bound to JAXB will be left untouched (whereas a marshalling operation would create a new tree that doesn't contain any of those.)

        As a side-effect, this operation updates the association between XML nodes and JAXB objects.

        Parameters:
        jaxbObject - root of potentially modified JAXB object tree
        xmlNode - root of update target XML parse tree
        Returns:
        Returns the updated XML node. Typically, this is the same node you passed in as xmlNode, but it maybe a different object, for example when the tag name of the object has changed.
        Throws:
        JAXBException - If any unexpected problem occurs updating corresponding XML content.
        IllegalArgumentException - If any of the input parameters are null

      • updateJAXB

        public abstract Object updateJAXB(XmlNode xmlNode)
                           throws JAXBException
        Takes an XML node and updates its associated JAXB object and its descendants.

        This operation can be thought of as an "in-place" unmarshalling. The difference is that instead of creating a whole new JAXB tree, this operation updates an existing tree, reusing as much JAXB objects as possible.

        As a side-effect, this operation updates the association between XML nodes and JAXB objects.

        Returns:
        Returns the updated JAXB object. Typically, this is the same object that was returned from earlier marshal(Object,Object) or updateJAXB(Object) method invocation, but it maybe a different object, for example when the name of the XML element has changed.
        Throws:
        JAXBException - If any unexpected problem occurs updating corresponding JAXB mapped content.
        IllegalArgumentException - If node parameter is null

      • setSchema

        public abstract void setSchema(Schema schema)
        Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
        Parameters:
        schema - set to null to disable validation.
        See Also:
        Unmarshaller.setSchema(Schema)

      • getSchema

        public abstract Schema getSchema()
        Gets the last Schema object (including null) set by the setSchema(Schema) method.
        Returns:
        the Schema object for validation or null if not present

      • setEventHandler

        public abstract void setEventHandler(ValidationEventHandler handler)
                              throws JAXBException
        Allow an application to register a ValidationEventHandler.

        The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the Binder unmarshal, marshal and update methods.

        Calling this method with a null parameter will cause the Binder to revert back to the default default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        public abstract ValidationEventHandler getEventHandler()
                                                throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • setProperty

        public abstract void setProperty(String name,
                                 Object value)
                          throws PropertyException
        Set the particular property in the underlying implementation of Binder. This method can only be used to set one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        public abstract Object getProperty(String name)
                            throws PropertyException
        Get the particular property in the underlying implementation of Binder. This method can only be used to get one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DataBindingException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class DataBindingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.bind.DataBindingException
  • All Implemented Interfaces:
    Serializable

    public class DataBindingException
extends RuntimeException
    Exception that represents a failure in a JAXB operation.

    This exception differs from JAXBException in that this is an unchecked exception, while JAXBException is a checked exception.

    Since:
    JAXB2.1
    See Also:
    JAXB, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DataBindingException(String message, Throwable cause)
      DataBindingException(Throwable cause)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DataBindingException

        public DataBindingException(String message,
                            Throwable cause)

      • DataBindingException

        public DataBindingException(Throwable cause)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DatatypeConverter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class DatatypeConverter

  • java.lang.Object
    • javax.xml.bind.DatatypeConverter

  • public final class DatatypeConverter
extends Object

    The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype. Customizations can involve writing a parse and print method for parsing and printing lexical representations of a XML schema datatype respectively. However, writing parse and print methods requires knowledge of the lexical representations ( XML Schema Part2: Datatypes specification ) and hence may be difficult to write.

    This class makes it easier to write parse and print methods. It defines static parse and print methods that provide access to a JAXB provider's implementation of parse and print methods. These methods are invoked by custom parse and print methods. For example, the binding of xsd:dateTime to a long can be customized using parse and print methods as follows:

        // Customized parse method
    public long myParseCal( String dateTimeString ) {
        java.util.Calendar cal = DatatypeConverter.parseDateTime(dateTimeString);
        long longval = convert_calendar_to_long(cal); //application specific
        return longval;
    }

    // Customized print method
    public String myPrintCal( Long longval ) {
        java.util.Calendar cal = convert_long_to_calendar(longval) ; //application specific
        String dateTimeString = DatatypeConverter.printDateTime(cal);
        return dateTimeString;
    }

    There is a static parse and print method corresponding to each parse and print method respectively in the DatatypeConverterInterface.

    The static methods defined in the class can also be used to specify a parse or a print method in a javaType binding declaration.

    JAXB Providers are required to call the setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality.

    A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

    Since:
    JAXB1.0
    See Also:
    DatatypeConverterInterface, ParseConversionEvent, PrintConversionEvent

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static String parseAnySimpleType(String lexicalXSDAnySimpleType)
      Return a string containing the lexical representation of the simple type.
      static byte[] parseBase64Binary(String lexicalXSDBase64Binary)
      Converts the string argument into an array of bytes.
      static boolean parseBoolean(String lexicalXSDBoolean)
      Converts the string argument into a boolean value.
      static byte parseByte(String lexicalXSDByte)
      Converts the string argument into a byte value.
      static Calendar parseDate(String lexicalXSDDate)
      Converts the string argument into a Calendar value.
      static Calendar parseDateTime(String lexicalXSDDateTime)
      Converts the string argument into a Calendar value.
      static BigDecimal parseDecimal(String lexicalXSDDecimal)
      Converts the string argument into a BigDecimal value.
      static double parseDouble(String lexicalXSDDouble)
      Converts the string argument into a double value.
      static float parseFloat(String lexicalXSDFloat)
      Converts the string argument into a float value.
      static byte[] parseHexBinary(String lexicalXSDHexBinary)
      Converts the string argument into an array of bytes.
      static int parseInt(String lexicalXSDInt)
      Convert the string argument into an int value.
      static BigInteger parseInteger(String lexicalXSDInteger)
      Convert the string argument into a BigInteger value.
      static long parseLong(String lexicalXSDLong)
      Converts the string argument into a long value.
      static QName parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      static short parseShort(String lexicalXSDShort)
      Converts the string argument into a short value.
      static String parseString(String lexicalXSDString)
      Convert the lexical XSD string argument into a String value.
      static Calendar parseTime(String lexicalXSDTime)
      Converts the string argument into a Calendar value.
      static long parseUnsignedInt(String lexicalXSDUnsignedInt)
      Converts the string argument into a long value.
      static int parseUnsignedShort(String lexicalXSDUnsignedShort)
      Converts the string argument into an int value.
      static String printAnySimpleType(String val)
      Converts a string value into a string.
      static String printBase64Binary(byte[] val)
      Converts an array of bytes into a string.
      static String printBoolean(boolean val)
      Converts a boolean value into a string.
      static String printByte(byte val)
      Converts a byte value into a string.
      static String printDate(Calendar val)
      Converts a Calendar value into a string.
      static String printDateTime(Calendar val)
      Converts a Calendar value into a string.
      static String printDecimal(BigDecimal val)
      Converts a BigDecimal value into a string.
      static String printDouble(double val)
      Converts a double value into a string.
      static String printFloat(float val)
      Converts a float value into a string.
      static String printHexBinary(byte[] val)
      Converts an array of bytes into a string.
      static String printInt(int val)
      Converts an int value into a string.
      static String printInteger(BigInteger val)
      Converts a BigInteger value into a string.
      static String printLong(long val)
      Converts A long value into a string.
      static String printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String printShort(short val)
      Converts a short value into a string.
      static String printString(String val)
      Converts the string argument into a string.
      static String printTime(Calendar val)
      Converts a Calendar value into a string.
      static String printUnsignedInt(long val)
      Converts a long value into a string.
      static String printUnsignedShort(int val)
      Converts an int value into a string.
      static void setDatatypeConverter(DatatypeConverterInterface converter)
      This method is for JAXB provider use only.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • setDatatypeConverter

        public static void setDatatypeConverter(DatatypeConverterInterface converter)
        This method is for JAXB provider use only.

        JAXB Providers are required to call this method at some point before allowing any of the JAXB client marshal or unmarshal operations to occur. This is necessary to configure the datatype converter that should be used to perform the print and parse conversions.

        Calling this api repeatedly will have no effect - the DatatypeConverterInterface instance passed into the first invocation is the one that will be used from then on.

        Parameters:
        converter - an instance of a class that implements the DatatypeConverterInterface class - this parameter must not be null.
        Throws:
        IllegalArgumentException - if the parameter is null
        SecurityException - If the SecurityManager in charge denies the access to set the datatype converter.
        See Also:
        JAXBPermission

      • parseString

        public static String parseString(String lexicalXSDString)

        Convert the lexical XSD string argument into a String value.

        Parameters:
        lexicalXSDString - A string containing a lexical representation of xsd:string.
        Returns:
        A String value represented by the string argument.

      • parseInteger

        public static BigInteger parseInteger(String lexicalXSDInteger)

        Convert the string argument into a BigInteger value.

        Parameters:
        lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
        Returns:
        A BigInteger value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

      • parseInt

        public static int parseInt(String lexicalXSDInt)

        Convert the string argument into an int value.

        Parameters:
        lexicalXSDInt - A string containing a lexical representation of xsd:int.
        Returns:
        A int value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

      • parseLong

        public static long parseLong(String lexicalXSDLong)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDLong - A string containing lexical representation of xsd:long.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

      • parseShort

        public static short parseShort(String lexicalXSDShort)

        Converts the string argument into a short value.

        Parameters:
        lexicalXSDShort - A string containing lexical representation of xsd:short.
        Returns:
        A short value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

      • parseDecimal

        public static BigDecimal parseDecimal(String lexicalXSDDecimal)

        Converts the string argument into a BigDecimal value.

        Parameters:
        lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
        Returns:
        A BigDecimal value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

      • parseFloat

        public static float parseFloat(String lexicalXSDFloat)

        Converts the string argument into a float value.

        Parameters:
        lexicalXSDFloat - A string containing lexical representation of xsd:float.
        Returns:
        A float value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

      • parseDouble

        public static double parseDouble(String lexicalXSDDouble)

        Converts the string argument into a double value.

        Parameters:
        lexicalXSDDouble - A string containing lexical representation of xsd:double.
        Returns:
        A double value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

      • parseBoolean

        public static boolean parseBoolean(String lexicalXSDBoolean)

        Converts the string argument into a boolean value.

        Parameters:
        lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
        Returns:
        A boolean value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

      • parseByte

        public static byte parseByte(String lexicalXSDByte)

        Converts the string argument into a byte value.

        Parameters:
        lexicalXSDByte - A string containing lexical representation of xsd:byte.
        Returns:
        A byte value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

      • parseQName

        public static QName parseQName(String lexicalXSDQName,
                               NamespaceContext nsc)

        Converts the string argument into a byte value.

        String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

        Parameters:
        lexicalXSDQName - A string containing lexical representation of xsd:QName.
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A QName value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

      • parseDateTime

        public static Calendar parseDateTime(String lexicalXSDDateTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
        Returns:
        A Calendar object represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

      • parseBase64Binary

        public static byte[] parseBase64Binary(String lexicalXSDBase64Binary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

      • parseHexBinary

        public static byte[] parseHexBinary(String lexicalXSDHexBinary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

      • parseUnsignedInt

        public static long parseUnsignedInt(String lexicalXSDUnsignedInt)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into a long value.

      • parseUnsignedShort

        public static int parseUnsignedShort(String lexicalXSDUnsignedShort)

        Converts the string argument into an int value.

        Parameters:
        lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
        Returns:
        An int value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into an int value.

      • parseTime

        public static Calendar parseTime(String lexicalXSDTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDTime - A string containing lexical representation of xsd:time.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

      • parseDate

        public static Calendar parseDate(String lexicalXSDDate)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDate - A string containing lexical representation of xsd:Date.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

      • parseAnySimpleType

        public static String parseAnySimpleType(String lexicalXSDAnySimpleType)

        Return a string containing the lexical representation of the simple type.

        Parameters:
        lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
        Returns:
        A string containing the lexical representation of the simple type.

      • printString

        public static String printString(String val)

        Converts the string argument into a string.

        Parameters:
        val - A string value.
        Returns:
        A string containing a lexical representation of xsd:string.

      • printInteger

        public static String printInteger(BigInteger val)

        Converts a BigInteger value into a string.

        Parameters:
        val - A BigInteger value
        Returns:
        A string containing a lexical representation of xsd:integer
        Throws:
        IllegalArgumentException - val is null.

      • printInt

        public static String printInt(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:int

      • printLong

        public static String printLong(long val)

        Converts A long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:long

      • printShort

        public static String printShort(short val)

        Converts a short value into a string.

        Parameters:
        val - A short value
        Returns:
        A string containing a lexical representation of xsd:short

      • printDecimal

        public static String printDecimal(BigDecimal val)

        Converts a BigDecimal value into a string.

        Parameters:
        val - A BigDecimal value
        Returns:
        A string containing a lexical representation of xsd:decimal
        Throws:
        IllegalArgumentException - val is null.

      • printFloat

        public static String printFloat(float val)

        Converts a float value into a string.

        Parameters:
        val - A float value
        Returns:
        A string containing a lexical representation of xsd:float

      • printDouble

        public static String printDouble(double val)

        Converts a double value into a string.

        Parameters:
        val - A double value
        Returns:
        A string containing a lexical representation of xsd:double

      • printBoolean

        public static String printBoolean(boolean val)

        Converts a boolean value into a string.

        Parameters:
        val - A boolean value
        Returns:
        A string containing a lexical representation of xsd:boolean

      • printByte

        public static String printByte(byte val)

        Converts a byte value into a string.

        Parameters:
        val - A byte value
        Returns:
        A string containing a lexical representation of xsd:byte

      • printQName

        public static String printQName(QName val,
                                NamespaceContext nsc)

        Converts a QName instance into a string.

        Parameters:
        val - A QName value
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A string containing a lexical representation of QName
        Throws:
        IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

      • printDateTime

        public static String printDateTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:dateTime
        Throws:
        IllegalArgumentException - if val is null.

      • printBase64Binary

        public static String printBase64Binary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - An array of bytes
        Returns:
        A string containing a lexical representation of xsd:base64Binary
        Throws:
        IllegalArgumentException - if val is null.

      • printHexBinary

        public static String printHexBinary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - An array of bytes
        Returns:
        A string containing a lexical representation of xsd:hexBinary
        Throws:
        IllegalArgumentException - if val is null.

      • printUnsignedInt

        public static String printUnsignedInt(long val)

        Converts a long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:unsignedInt

      • printUnsignedShort

        public static String printUnsignedShort(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:unsignedShort

      • printTime

        public static String printTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:time
        Throws:
        IllegalArgumentException - if val is null.

      • printDate

        public static String printDate(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:date
        Throws:
        IllegalArgumentException - if val is null.

      • printAnySimpleType

        public static String printAnySimpleType(String val)

        Converts a string value into a string.

        Parameters:
        val - A string value
        Returns:
        A string containing a lexical representation of xsd:AnySimpleType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DatatypeConverterInterface (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface DatatypeConverterInterface

  • public interface DatatypeConverterInterface

    The DatatypeConverterInterface is for JAXB provider use only. A JAXB provider must supply a class that implements this interface. JAXB Providers are required to call the DatatypeConverter.setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality. Calling this api repeatedly will have no effect - the DatatypeConverter instance passed into the first invocation is the one that will be used from then on.

    This interface defines the parse and print methods. There is one parse and print method for each XML schema datatype specified in the the default binding Table 5-1 in the JAXB specification.

    The parse and print methods defined here are invoked by the static parse and print methods defined in the DatatypeConverter class.

    A parse method for a XML schema datatype must be capable of converting any lexical representation of the XML schema datatype ( specified by the XML Schema Part2: Datatypes specification into a value in the value space of the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException or a subclass of IllegalArgumentException must be thrown by the method.

    A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

    The prefix xsd: is used to refer to XML schema datatypes XML Schema Part2: Datatypes specification.

    Since:
    JAXB1.0
    See Also:
    DatatypeConverter, ParseConversionEvent, PrintConversionEvent

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String parseAnySimpleType(String lexicalXSDAnySimpleType)
      Return a string containing the lexical representation of the simple type.
      byte[] parseBase64Binary(String lexicalXSDBase64Binary)
      Converts the string argument into an array of bytes.
      boolean parseBoolean(String lexicalXSDBoolean)
      Converts the string argument into a boolean value.
      byte parseByte(String lexicalXSDByte)
      Converts the string argument into a byte value.
      Calendar parseDate(String lexicalXSDDate)
      Converts the string argument into a Calendar value.
      Calendar parseDateTime(String lexicalXSDDateTime)
      Converts the string argument into a Calendar value.
      BigDecimal parseDecimal(String lexicalXSDDecimal)
      Converts the string argument into a BigDecimal value.
      double parseDouble(String lexicalXSDDouble)
      Converts the string argument into a double value.
      float parseFloat(String lexicalXSDFloat)
      Converts the string argument into a float value.
      byte[] parseHexBinary(String lexicalXSDHexBinary)
      Converts the string argument into an array of bytes.
      int parseInt(String lexicalXSDInt)
      Convert the string argument into an int value.
      BigInteger parseInteger(String lexicalXSDInteger)
      Convert the string argument into a BigInteger value.
      long parseLong(String lexicalXSDLong)
      Converts the string argument into a long value.
      QName parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      short parseShort(String lexicalXSDShort)
      Converts the string argument into a short value.
      String parseString(String lexicalXSDString)
      Convert the string argument into a string.
      Calendar parseTime(String lexicalXSDTime)
      Converts the string argument into a Calendar value.
      long parseUnsignedInt(String lexicalXSDUnsignedInt)
      Converts the string argument into a long value.
      int parseUnsignedShort(String lexicalXSDUnsignedShort)
      Converts the string argument into an int value.
      String printAnySimpleType(String val)
      Converts a string value into a string.
      String printBase64Binary(byte[] val)
      Converts an array of bytes into a string.
      String printBoolean(boolean val)
      Converts a boolean value into a string.
      String printByte(byte val)
      Converts a byte value into a string.
      String printDate(Calendar val)
      Converts a Calendar value into a string.
      String printDateTime(Calendar val)
      Converts a Calendar value into a string.
      String printDecimal(BigDecimal val)
      Converts a BigDecimal value into a string.
      String printDouble(double val)
      Converts a double value into a string.
      String printFloat(float val)
      Converts a float value into a string.
      String printHexBinary(byte[] val)
      Converts an array of bytes into a string.
      String printInt(int val)
      Converts an int value into a string.
      String printInteger(BigInteger val)
      Converts a BigInteger value into a string.
      String printLong(long val)
      Converts a long value into a string.
      String printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      String printShort(short val)
      Converts a short value into a string.
      String printString(String val)
      Converts the string argument into a string.
      String printTime(Calendar val)
      Converts a Calendar value into a string.
      String printUnsignedInt(long val)
      Converts a long value into a string.
      String printUnsignedShort(int val)
      Converts an int value into a string.

    • Method Detail

      • parseString

        String parseString(String lexicalXSDString)

        Convert the string argument into a string.

        Parameters:
        lexicalXSDString - A lexical representation of the XML Schema datatype xsd:string
        Returns:
        A string that is the same as the input string.

      • parseInteger

        BigInteger parseInteger(String lexicalXSDInteger)

        Convert the string argument into a BigInteger value.

        Parameters:
        lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
        Returns:
        A BigInteger value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

      • parseInt

        int parseInt(String lexicalXSDInt)

        Convert the string argument into an int value.

        Parameters:
        lexicalXSDInt - A string containing a lexical representation of xsd:int.
        Returns:
        An int value represented byte the string argument.
        Throws:
        NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

      • parseLong

        long parseLong(String lexicalXSDLong)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDLong - A string containing lexical representation of xsd:long.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

      • parseShort

        short parseShort(String lexicalXSDShort)

        Converts the string argument into a short value.

        Parameters:
        lexicalXSDShort - A string containing lexical representation of xsd:short.
        Returns:
        A short value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

      • parseDecimal

        BigDecimal parseDecimal(String lexicalXSDDecimal)

        Converts the string argument into a BigDecimal value.

        Parameters:
        lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
        Returns:
        A BigDecimal value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

      • parseFloat

        float parseFloat(String lexicalXSDFloat)

        Converts the string argument into a float value.

        Parameters:
        lexicalXSDFloat - A string containing lexical representation of xsd:float.
        Returns:
        A float value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

      • parseDouble

        double parseDouble(String lexicalXSDDouble)

        Converts the string argument into a double value.

        Parameters:
        lexicalXSDDouble - A string containing lexical representation of xsd:double.
        Returns:
        A double value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

      • parseBoolean

        boolean parseBoolean(String lexicalXSDBoolean)

        Converts the string argument into a boolean value.

        Parameters:
        lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
        Returns:
        A boolean value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

      • parseByte

        byte parseByte(String lexicalXSDByte)

        Converts the string argument into a byte value.

        Parameters:
        lexicalXSDByte - A string containing lexical representation of xsd:byte.
        Returns:
        A byte value represented by the string argument.
        Throws:
        NumberFormatException - lexicalXSDByte does not contain a parseable byte.
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

      • parseQName

        QName parseQName(String lexicalXSDQName,
                 NamespaceContext nsc)

        Converts the string argument into a QName value.

        String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

        Parameters:
        lexicalXSDQName - A string containing lexical representation of xsd:QName.
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A QName value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

      • parseDateTime

        Calendar parseDateTime(String lexicalXSDDateTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
        Returns:
        A Calendar object represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

      • parseBase64Binary

        byte[] parseBase64Binary(String lexicalXSDBase64Binary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

      • parseHexBinary

        byte[] parseHexBinary(String lexicalXSDHexBinary)

        Converts the string argument into an array of bytes.

        Parameters:
        lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
        Returns:
        An array of bytes represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

      • parseUnsignedInt

        long parseUnsignedInt(String lexicalXSDUnsignedInt)

        Converts the string argument into a long value.

        Parameters:
        lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
        Returns:
        A long value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into a long value.

      • parseUnsignedShort

        int parseUnsignedShort(String lexicalXSDUnsignedShort)

        Converts the string argument into an int value.

        Parameters:
        lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
        Returns:
        An int value represented by the string argument.
        Throws:
        NumberFormatException - if string parameter can not be parsed into an int value.

      • parseTime

        Calendar parseTime(String lexicalXSDTime)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDTime - A string containing lexical representation of xsd:Time.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

      • parseDate

        Calendar parseDate(String lexicalXSDDate)

        Converts the string argument into a Calendar value.

        Parameters:
        lexicalXSDDate - A string containing lexical representation of xsd:Date.
        Returns:
        A Calendar value represented by the string argument.
        Throws:
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

      • parseAnySimpleType

        String parseAnySimpleType(String lexicalXSDAnySimpleType)

        Return a string containing the lexical representation of the simple type.

        Parameters:
        lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
        Returns:
        A string containing the lexical representation of the simple type.

      • printString

        String printString(String val)

        Converts the string argument into a string.

        Parameters:
        val - A string value.
        Returns:
        A string containing a lexical representation of xsd:string

      • printInteger

        String printInteger(BigInteger val)

        Converts a BigInteger value into a string.

        Parameters:
        val - A BigInteger value
        Returns:
        A string containing a lexical representation of xsd:integer
        Throws:
        IllegalArgumentException - val is null.

      • printInt

        String printInt(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:int

      • printLong

        String printLong(long val)

        Converts a long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:long

      • printShort

        String printShort(short val)

        Converts a short value into a string.

        Parameters:
        val - A short value
        Returns:
        A string containing a lexical representation of xsd:short

      • printDecimal

        String printDecimal(BigDecimal val)

        Converts a BigDecimal value into a string.

        Parameters:
        val - A BigDecimal value
        Returns:
        A string containing a lexical representation of xsd:decimal
        Throws:
        IllegalArgumentException - val is null.

      • printFloat

        String printFloat(float val)

        Converts a float value into a string.

        Parameters:
        val - A float value
        Returns:
        A string containing a lexical representation of xsd:float

      • printDouble

        String printDouble(double val)

        Converts a double value into a string.

        Parameters:
        val - A double value
        Returns:
        A string containing a lexical representation of xsd:double

      • printBoolean

        String printBoolean(boolean val)

        Converts a boolean value into a string.

        Parameters:
        val - A boolean value
        Returns:
        A string containing a lexical representation of xsd:boolean

      • printByte

        String printByte(byte val)

        Converts a byte value into a string.

        Parameters:
        val - A byte value
        Returns:
        A string containing a lexical representation of xsd:byte

      • printQName

        String printQName(QName val,
                  NamespaceContext nsc)

        Converts a QName instance into a string.

        Parameters:
        val - A QName value
        nsc - A namespace context for interpreting a prefix within a QName.
        Returns:
        A string containing a lexical representation of QName
        Throws:
        IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

      • printDateTime

        String printDateTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:dateTime
        Throws:
        IllegalArgumentException - if val is null.

      • printBase64Binary

        String printBase64Binary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - an array of bytes
        Returns:
        A string containing a lexical representation of xsd:base64Binary
        Throws:
        IllegalArgumentException - if val is null.

      • printHexBinary

        String printHexBinary(byte[] val)

        Converts an array of bytes into a string.

        Parameters:
        val - an array of bytes
        Returns:
        A string containing a lexical representation of xsd:hexBinary
        Throws:
        IllegalArgumentException - if val is null.

      • printUnsignedInt

        String printUnsignedInt(long val)

        Converts a long value into a string.

        Parameters:
        val - A long value
        Returns:
        A string containing a lexical representation of xsd:unsignedInt

      • printUnsignedShort

        String printUnsignedShort(int val)

        Converts an int value into a string.

        Parameters:
        val - An int value
        Returns:
        A string containing a lexical representation of xsd:unsignedShort

      • printTime

        String printTime(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:time
        Throws:
        IllegalArgumentException - if val is null.

      • printDate

        String printDate(Calendar val)

        Converts a Calendar value into a string.

        Parameters:
        val - A Calendar value
        Returns:
        A string containing a lexical representation of xsd:date
        Throws:
        IllegalArgumentException - if val is null.

      • printAnySimpleType

        String printAnySimpleType(String val)

        Converts a string value into a string.

        Parameters:
        val - A string value
        Returns:
        A string containing a lexical representation of xsd:AnySimpleType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Element (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Element

  • public interface Element
    This is an element marker interface. Under certain circumstances, it is necessary for the binding compiler to generate derived java content classes that implement this interface. In those cases, client applications must supply element instances rather than types of elements. For more detail, see section 5.7 "Element Declaration" and 5.7.1 "Bind to Java Element Interface" of the specification.
    Since:
    JAXB1.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXB (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXB

  • java.lang.Object
    • javax.xml.bind.JAXB

  • public final class JAXB
extends Object
    Class that defines convenience methods for common, simple use of JAXB.

    Methods defined in this class are convenience methods that combine several basic operations in the JAXBContext, Unmarshaller, and Marshaller. They are designed to be the prefered methods for developers new to JAXB. They have the following characterstics:

    1. Generally speaking, the performance is not necessarily optimal. It is expected that people who need to write performance critical code will use the rest of the JAXB API directly.
    2. Errors that happen during the processing is wrapped into DataBindingException (which will have JAXBException as its cause. It is expected that people who prefer the checked exception would use the rest of the JAXB API directly.

    In addition, the unmarshal methods have the following characteristic:

    1. Schema validation is not performed on the input XML. The processing will try to continue even if there are errors in the XML, as much as possible. Only as the last resort, this method fails with DataBindingException.

    Similarly, the marshal methods have the following characteristic:

    1. The processing will try to continue even if the Java object tree does not meet the validity requirement. Only as the last resort, this method fails with DataBindingException.

    All the methods on this class require non-null arguments to all parameters. The unmarshal methods either fail with an exception or return a non-null value.

    Since:
    2.1

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static void marshal(Object jaxbObject, File xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, OutputStream xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, Result xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, String xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, URI xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, URL xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, Writer xml)
      Writes a Java object tree to XML and store it to the specified location.
      static <T> T unmarshal(File xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(InputStream xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(Reader xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(Source xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(String xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(URI xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(URL xml, Class<T> type)
      Reads in a Java object tree from the given XML input.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • unmarshal

        public static <T> T unmarshal(File xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - Reads the entire file as XML.

      • unmarshal

        public static <T> T unmarshal(URL xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The resource pointed by the URL is read in its entirety.

      • unmarshal

        public static <T> T unmarshal(URI xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The URI is turned into URL and then follows the handling of URL.

      • unmarshal

        public static <T> T unmarshal(String xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The string is first interpreted as an absolute URI. If it's not a valid absolute URI, then it's interpreted as a File

      • unmarshal

        public static <T> T unmarshal(InputStream xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The entire stream is read as an XML infoset. Upon a successful completion, the stream will be closed by this method.

      • unmarshal

        public static <T> T unmarshal(Reader xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The character stream is read as an XML infoset. The encoding declaration in the XML will be ignored. Upon a successful completion, the stream will be closed by this method.

      • unmarshal

        public static <T> T unmarshal(Source xml,
                              Class<T> type)
        Reads in a Java object tree from the given XML input.
        Parameters:
        xml - The XML infoset that the Source represents is read.

      • marshal

        public static void marshal(Object jaxbObject,
                           File xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - XML will be written to this file. If it already exists, it will be overwritten.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
                           URL xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the resource pointed by this URL. Note that not all URLs support such operation, and exact semantics depends on the URL implementations. In case of HTTP URLs, this will perform HTTP POST.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
                           URI xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The URI is turned into URL and then follows the handling of URL. See above.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
                           String xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The string is first interpreted as an absolute URI. If it's not a valid absolute URI, then it's interpreted as a File
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
                           OutputStream xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the given OutputStream. Upon a successful completion, the stream will be closed by this method.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
                           Writer xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent as a character stream to the given Writer. Upon a successful completion, the stream will be closed by this method.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
                           Result xml)
        Writes a Java object tree to XML and store it to the specified location.
        Parameters:
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the Result object.
        Throws:
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBContext

  • java.lang.Object
    • javax.xml.bind.JAXBContext

  • public abstract class JAXBContext
extends Object

    The JAXBContext class provides the client's entry point to the JAXB API. It provides an abstraction for managing the XML/Java binding information necessary to implement the JAXB binding framework operations: unmarshal, marshal and validate.

    A client application normally obtains new instances of this class using one of these two styles for newInstance methods, although there are other specialized forms of the method available:

    • JAXBContext.newInstance( "com.acme.foo:com.acme.bar" )
      The JAXBContext instance is initialized from a list of colon separated Java package names. Each java package contains JAXB mapped classes, schema-derived classes and/or user annotated classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS, Section 7.4.1 "Named Packages").
    • JAXBContext.newInstance( com.acme.foo.Foo.class )
      The JAXBContext instance is initialized with class(es) passed as parameter(s) and classes that are statically reachable from these class(es). See newInstance(Class...) for details.

    SPEC REQUIREMENT: the provider must supply an implementation class containing the following method signatures:

     public static JAXBContext createContext( String contextPath, ClassLoader classLoader, Map<String,Object> properties ) throws JAXBException
 public static JAXBContext createContext( Class[] classes, Map<String,Object> properties ) throws JAXBException

    The following JAXB 1.0 requirement is only required for schema to java interface/implementation binding. It does not apply to JAXB annotated classes. JAXB Providers must generate a jaxb.properties file in each package containing schema derived classes. The property file must contain a property named javax.xml.bind.context.factory whose value is the name of the class that implements the createContext APIs.

    The class supplied by the provider does not have to be assignable to javax.xml.bind.JAXBContext, it simply has to provide a class that implements the createContext APIs.

    In addition, the provider must call the DatatypeConverter.setDatatypeConverter api prior to any client invocations of the marshal and unmarshal methods. This is necessary to configure the datatype converter that will be used during these operations.

    Unmarshalling

    The Unmarshaller class provides the client application the ability to convert XML data into a tree of Java content objects. The unmarshal method allows for any global XML element declared in the schema to be unmarshalled as the root of an instance document. Additionally, the unmarshal method allows for an unrecognized root element that has an xsi:type attribute's value that references a type definition declared in the schema to be unmarshalled as the root of an instance document. The JAXBContext object allows the merging of global elements and type definitions across a set of schemas (listed in the contextPath). Since each schema in the schema set can belong to distinct namespaces, the unification of schemas to an unmarshalling context should be namespace independent. This means that a client application is able to unmarshal XML documents that are instances of any of the schemas listed in the contextPath. For example:

            JAXBContext jc = JAXBContext.newInstance( "com.acme.foo:com.acme.bar" );
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) ); // ok
        BarObject barObj = (BarObject)u.unmarshal( new File( "bar.xml" ) ); // ok
        BazObject bazObj = (BazObject)u.unmarshal( new File( "baz.xml" ) ); // error, "com.acme.baz" not in contextPath

    The client application may also generate Java content trees explicitly rather than unmarshalling existing XML data. For all JAXB-annotated value classes, an application can create content using constructors. For schema-derived interface/implementation classes and for the creation of elements that are not bound to a JAXB-annotated class, an application needs to have access and knowledge about each of the schema derived ObjectFactory classes that exist in each of java packages contained in the contextPath. For each schema derived java class, there is a static factory method that produces objects of that type. For example, assume that after compiling a schema, you have a package com.acme.foo that contains a schema derived interface named PurchaseOrder. In order to create objects of that type, the client application would use the factory method like this:

           com.acme.foo.PurchaseOrder po =
           com.acme.foo.ObjectFactory.createPurchaseOrder();

    Once the client application has an instance of the the schema derived object, it can use the mutator methods to set content on it.

    For more information on the generated ObjectFactory classes, see Section 4.2 Java Package of the specification.

    SPEC REQUIREMENT: the provider must generate a class in each package that contains all of the necessary object factory methods for that package named ObjectFactory as well as the static newInstance( javaContentInterface ) method

    Marshalling

    The Marshaller class provides the client application the ability to convert a Java content tree back into XML data. There is no difference between marshalling a content tree that is created manually using the factory methods and marshalling a content tree that is the result an unmarshal operation. Clients can marshal a java content tree back to XML data to a java.io.OutputStream or a java.io.Writer. The marshalling process can alternatively produce SAX2 event streams to a registered ContentHandler or produce a DOM Node object. Client applications have control over the output encoding as well as whether or not to marshal the XML data as a complete document or as a fragment.

    Here is a simple example that unmarshals an XML document and then marshals it back out:

            JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );

        // unmarshal from foo.xml
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) );

        // marshal to System.out
        Marshaller m = jc.createMarshaller();
        m.marshal( fooObj, System.out );

    Validation

    Validation has been changed significantly since JAXB 1.0. The Validator class has been deprecated and made optional. This means that you are advised not to use this class and, in fact, it may not even be available depending on your JAXB provider. JAXB 1.0 client applications that rely on Validator will still work properly when deployed with the JAXB 1.0 runtime system. In JAXB 2.0, the Unmarshaller has included convenince methods that expose the JAXP 1.3 javax.xml.validation framework. Please refer to the Unmarshaller.setSchema(javax.xml.validation.Schema) API for more information.

    JAXB Runtime Binding Framework Compatibility

    The following JAXB 1.0 restriction only applies to binding schema to interfaces/implementation classes. Since this binding does not require a common runtime system, a JAXB client application must not attempt to mix runtime objects (JAXBContext, Marshaller, etc. ) from different providers. This does not mean that the client application isn't portable, it simply means that a client has to use a runtime system provided by the same provider that was used to compile the schema.

    Discovery of JAXB implementation

    When one of the newInstance methods is called, a JAXB implementation is discovered by the following steps.

    1. For each package/class explicitly passed in to the newInstance(java.lang.String) method, in the order they are specified, jaxb.properties file is looked up in its package, by using the associated classloader — this is the owner class loader for a Class argument, and for a package the specified ClassLoader.

      If such a file is discovered, it is loaded as a property file, and the value of the JAXB_CONTEXT_FACTORY key will be assumed to be the provider factory class. This class is then loaded by the associated classloader discussed above.

      This phase of the look up allows some packages to force the use of a certain JAXB implementation. (For example, perhaps the schema compiler has generated some vendor extension in the code.)

    2. If the system property JAXB_CONTEXT_FACTORY exists, then its value is assumed to be the provider factory class. This phase of the look up enables per-JVM override of the JAXB implementation.
    3. Look for /META-INF/services/javax.xml.bind.JAXBContext file in the associated classloader. This file follows the standard service descriptor convention, and if such a file exists, its content is assumed to be the provider factory class. This phase of the look up is for automatic discovery. It allows users to just put a JAXB implementation in a classpath and use it without any furhter configuration.
    4. Finally, if all the steps above fail, then the rest of the look up is unspecified. That said, the recommended behavior is to simply look for some hard-coded platform default JAXB implementation. This phase of the look up is so that JavaSE can have its own JAXB implementation as the last resort.

    Once the provider factory class is discovered, its public static JAXBContext createContext(String,ClassLoader,Map) method (see newInstance(String, ClassLoader, Map) for the parameter semantics.) or public static JAXBContext createContet(Class[],Map) method (see newInstance(Class[], Map) for the parameter semantics) are invoked to create a JAXBContext.

    Since:
    JAXB1.0
    See Also:
    Marshaller, Unmarshaller, 7.4.1 "Named Packages" in Java Language Specification

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXB_CONTEXT_FACTORY
      The name of the property that contains the name of the class capable of creating new JAXBContext objects.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | JAXBContext()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      Binder<Node> createBinder()
      Creates a Binder for W3C DOM.
      <T> Binder<T> createBinder(Class<T> domType)
      Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
      JAXBIntrospector createJAXBIntrospector()
      Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
      abstract Marshaller createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.
      abstract Unmarshaller createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.
      abstract Validator createValidator()
      Deprecated.
      since JAXB2.0
      void generateSchema(SchemaOutputResolver outputResolver)
      Generates the schema documents for this context.
      static JAXBContext newInstance(Class... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(Class[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JAXB_CONTEXT_FACTORY

        public static final String JAXB_CONTEXT_FACTORY
        The name of the property that contains the name of the class capable of creating new JAXBContext objects.
        See Also:
        Constant Field Values

    • Constructor Detail

      • JAXBContext

        protected JAXBContext()

    • Method Detail

      • newInstance

        public static JAXBContext newInstance(String contextPath)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        This is a convenience method to invoke the newInstance(String,ClassLoader) method with the context class loader of the current thread.

        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath

      • newInstance

        public static JAXBContext newInstance(String contextPath,
                                      ClassLoader classLoader)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        The client application must supply a context path which is a list of colon (':', \u003A) separated java package names that contain schema-derived classes and/or fully qualified JAXB-annotated classes. Schema-derived code is registered with the JAXBContext by the ObjectFactory.class generated per package. Alternatively than being listed in the context path, programmer annotated JAXB mapped classes can be listed in a jaxb.index resource file, format described below. Note that a java package can contain both schema-derived classes and user annotated JAXB classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS, Section 7.4.1 "Named Packages").

        Every package listed on the contextPath must meet one or both of the following conditions otherwise a JAXBException will be thrown:

        1. it must contain ObjectFactory.class
        2. it must contain jaxb.index

        Format for jaxb.index

        The file contains a newline-separated list of class names. Space and tab characters, as well as blank lines, are ignored. The comment character is '#' (0x23); on each line all characters following the first comment character are ignored. The file must be encoded in UTF-8. Classes that are reachable, as defined in newInstance(Class...), from the listed classes are also registered with JAXBContext.

        Constraints on class name occuring in a jaxb.index file are:

        • Must not end with ".class".
        • Class names are resolved relative to package containing jaxb.index file. Only classes occuring directly in package containing jaxb.index file are allowed.
        • Fully qualified class names are not allowed. A qualified class name,relative to current package, is only allowed to specify a nested or inner class.

        To maintain compatibility with JAXB 1.0 schema to java interface/implementation binding, enabled by schema customization <jaxb:globalBindings valueClass="false">, the JAXB provider will ensure that each package on the context path has a jaxb.properties file which contains a value for the javax.xml.bind.context.factory property and that all values resolve to the same provider. This requirement does not apply to JAXB annotated classes.

        If there are any global XML element name collisions across the various packages listed on the contextPath, a JAXBException will be thrown.

        Mixing generated interface/impl bindings from multiple JAXB Providers in the same context path may result in a JAXBException being thrown.

        The steps involved in discovering the JAXB implementation is discussed in the class javadoc.

        Parameters:
        contextPath - list of java package names that contain schema derived class and/or java to schema (JAXB-annotated) mapped classes
        classLoader - This class loader will be used to locate the implementation classes.
        Returns:
        a new instance of a JAXBContext
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath

      • newInstance

        public static JAXBContext newInstance(String contextPath,
                                      ClassLoader classLoader,
                                      Map<String,?> properties)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        This is mostly the same as newInstance(String, ClassLoader), but this version allows you to pass in provider-specific properties to configure the instantiation of JAXBContext.

        The interpretation of properties is up to implementations. Implementations should throw JAXBException if it finds properties that it doesn't understand.

        Parameters:
        contextPath - list of java package names that contain schema derived classes
        classLoader - This class loader will be used to locate the implementation classes.
        properties - provider-specific properties. Can be null, which means the same thing as passing in an empty map.
        Returns:
        a new instance of a JAXBContext
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath
        Since:
        JAXB2.0

      • newInstance

        public static JAXBContext newInstance(Class... classesToBeBound)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        The client application must supply a list of classes that the new context object needs to recognize. Not only the new context will recognize all the classes specified, but it will also recognize any classes that are directly/indirectly referenced statically from the specified classes. Subclasses of referenced classes nor @XmlTransient referenced classes are not registered with JAXBContext. For example, in the following Java code, if you do newInstance(Foo.class), the newly created JAXBContext will recognize both Foo and Bar, but not Zot or FooBar:

         class Foo {
      @XmlTransient FooBar c;
      Bar b;
 }
 class Bar { int x; }
 class Zot extends Bar { int y; }
 class FooBar { }
        Therefore, a typical client application only needs to specify the top-level classes, but it needs to be careful.

        Note that for each java package registered with JAXBContext, when the optional package annotations exist, they must be processed. (see JLS, Section 7.4.1 "Named Packages").

        The steps involved in discovering the JAXB implementation is discussed in the class javadoc.

        Parameters:
        classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
        Returns:
        A new instance of a JAXBContext. Always non-null valid object.
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
        1. No JAXB implementation was discovered
        2. Classes use JAXB annotations incorrectly
        3. Classes have colliding annotations (i.e., two classes with the same type name)
        4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
        IllegalArgumentException - if the parameter contains null (i.e., newInstance(null);)
        Since:
        JAXB2.0

      • newInstance

        public static JAXBContext newInstance(Class[] classesToBeBound,
                                      Map<String,?> properties)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        An overloading of newInstance(Class...) to configure 'properties' for this instantiation of JAXBContext.

        The interpretation of properties is up to implementations. Implementations should throw JAXBException if it finds properties that it doesn't understand.

        Parameters:
        classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
        properties - provider-specific properties. Can be null, which means the same thing as passing in an empty map.
        Returns:
        A new instance of a JAXBContext. Always non-null valid object.
        Throws:
        JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
        1. No JAXB implementation was discovered
        2. Classes use JAXB annotations incorrectly
        3. Classes have colliding annotations (i.e., two classes with the same type name)
        4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
        IllegalArgumentException - if the parameter contains null (i.e., newInstance(null,someMap);)
        Since:
        JAXB2.0

      • createUnmarshaller

        public abstract Unmarshaller createUnmarshaller()
                                         throws JAXBException
        Create an Unmarshaller object that can be used to convert XML data into a java content tree.
        Returns:
        an Unmarshaller object
        Throws:
        JAXBException - if an error was encountered while creating the Unmarshaller object

      • createMarshaller

        public abstract Marshaller createMarshaller()
                                     throws JAXBException
        Create a Marshaller object that can be used to convert a java content tree into XML data.
        Returns:
        a Marshaller object
        Throws:
        JAXBException - if an error was encountered while creating the Marshaller object

      • createValidator

        public abstract Validator createValidator()
                                   throws JAXBException
        Deprecated. since JAXB2.0
        Validator has been made optional and deprecated in JAXB 2.0. Please refer to the javadoc for Validator for more detail.

        Create a Validator object that can be used to validate a java content tree against its source schema.

        Returns:
        a Validator object
        Throws:
        JAXBException - if an error was encountered while creating the Validator object

      • createBinder

        public <T> Binder<T> createBinder(Class<T> domType)
        Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
        Parameters:
        domType - select the DOM API to use by passing in its DOM Node class.
        Returns:
        always a new valid Binder object.
        Throws:
        UnsupportedOperationException - if DOM API corresponding to domType is not supported by the implementation.
        Since:
        JAXB2.0

      • createBinder

        public Binder<Node> createBinder()
        Creates a Binder for W3C DOM.
        Returns:
        always a new valid Binder object.
        Since:
        JAXB2.0

      • createJAXBIntrospector

        public JAXBIntrospector createJAXBIntrospector()
        Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
        Returns:
        always return a non-null valid JAXBIntrospector object.
        Throws:
        UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
        Since:
        JAXB2.0

      • generateSchema

        public void generateSchema(SchemaOutputResolver outputResolver)
                    throws IOException
        Generates the schema documents for this context.
        Parameters:
        outputResolver - this object controls the output to which schemas will be sent.
        Throws:
        IOException - if SchemaOutputResolver throws an IOException.
        UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
        Since:
        JAXB 2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBElement.GlobalScope (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBElement.GlobalScope

  • java.lang.Object
    • javax.xml.bind.JAXBElement.GlobalScope
  • Enclosing class:
    JAXBElement<T>

    public static final class JAXBElement.GlobalScope
extends Object
    Designates global scope for an xml element.

    • Constructor Summary

      Constructors
      Constructor and Description
      GlobalScope()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • GlobalScope

        public GlobalScope()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBElement<T>

  • java.lang.Object
    • javax.xml.bind.JAXBElement<T>
  • All Implemented Interfaces:
    Serializable

    public class JAXBElement<T>
extends Object
implements Serializable

    JAXB representation of an Xml Element.

    This class represents information about an Xml Element from both the element declaration within a schema and the element instance value within an xml document with the following properties

    • element's xml tag name
    • value represents the element instance's atttribute(s) and content model
    • element declaration's declaredType (xs:element @type attribute)
    • scope of element declaration
    • boolean nil property. (element instance's xsi:nil attribute)

    The declaredType and scope property are the JAXB class binding for the xml type definition.

    Scope is either JAXBElement.GlobalScope or the Java class representing the complex type definition containing the schema element declaration.

    There is a property constraint that if value is null, then nil must be true. The converse is not true to enable representing a nil element with attribute(s). If nil is true, it is possible that value is non-null so it can hold the value of the attributes associated with a nil element.

    Since:
    JAXB 2.0
    See Also:
    Serialized Form

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  JAXBElement.GlobalScope
      Designates global scope for an xml element.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected Class<T> declaredType
      Java datatype binding for xml element declaration's type.
      protected QName name
      xml element tag name
      protected boolean nil
      true iff the xml element instance has xsi:nil="true".
      protected Class scope
      Scope of xml element declaration representing this xml element instance.
      protected T value
      xml element value.

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
      Construct an xml element instance.
      JAXBElement(QName name, Class<T> declaredType, T value)
      Construct an xml element instance.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Class<T> getDeclaredType()
      Returns the Java binding of the xml element declaration's type attribute.
      QName getName()
      Returns the xml element tag name.
      Class getScope()
      Returns scope of xml element declaration.
      T getValue()
      Return the content model and attribute values for this element.
      boolean isGlobalScope()
      Returns true iff this xml element declaration is global.
      boolean isNil()
      Returns true iff this element instance content model is nil.
      boolean isTypeSubstituted()
      Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
      void setNil(boolean value)
      Set whether this element has nil content.
      void setValue(T t)
      Set the content model and attributes of this xml element.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        protected final QName name
        xml element tag name

      • declaredType

        protected final Class<T> declaredType
        Java datatype binding for xml element declaration's type.

      • scope

        protected final Class scope
        Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

      • value

        protected T value
        xml element value. Represents content model and attributes of an xml element instance.

      • nil

        protected boolean nil
        true iff the xml element instance has xsi:nil="true".

    • Constructor Detail

      • JAXBElement

        public JAXBElement(QName name,
                   Class<T> declaredType,
                   Class scope,
                   T value)

        Construct an xml element instance.

        Parameters:
        name - Java binding of xml element tag name
        declaredType - Java binding of xml element declaration's type
        scope - Java binding of scope of xml element declaration. Passing null is the same as passing GlobalScope.class
        value - Java instance representing xml element's value.
        See Also:
        getScope(), isTypeSubstituted()

      • JAXBElement

        public JAXBElement(QName name,
                   Class<T> declaredType,
                   T value)
        Construct an xml element instance. This is just a convenience method for new JAXBElement(name,declaredType,GlobalScope.class,value)

    • Method Detail

      • getDeclaredType

        public Class<T> getDeclaredType()
        Returns the Java binding of the xml element declaration's type attribute.

      • getName

        public QName getName()
        Returns the xml element tag name.

      • setValue

        public void setValue(T t)

        Set the content model and attributes of this xml element.

        When this property is set to null, isNil() must by true. Details of constraint are described at isNil().

        See Also:
        isTypeSubstituted()

      • getValue

        public T getValue()

        Return the content model and attribute values for this element.

        See isNil() for a description of a property constraint when this value is null

      • getScope

        public Class getScope()
        Returns scope of xml element declaration.
        Returns:
        GlobalScope.class if this element is of global scope.
        See Also:
        isGlobalScope()

      • isNil

        public boolean isNil()

        Returns true iff this element instance content model is nil.

        This property always returns true when getValue() is null. Note that the converse is not true, when this property is true, getValue() can contain a non-null value for attribute(s). It is valid for a nil xml element to have attribute(s).

      • setNil

        public void setNil(boolean value)

        Set whether this element has nil content.

        See Also:
        isNil()

      • isGlobalScope

        public boolean isGlobalScope()
        Returns true iff this xml element declaration is global.

      • isTypeSubstituted

        public boolean isTypeSubstituted()
        Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    MarshalException, PropertyException, UnmarshalException, ValidationException

    public class JAXBException
extends Exception
    This is the root exception class for all JAXB exceptions.
    Since:
    JAXB1.0
    See Also:
    JAXBContext, Marshaller, Unmarshaller, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBException(String message)
      Construct a JAXBException with the specified detail message.
      JAXBException(String message, String errorCode)
      Construct a JAXBException with the specified detail message and vendor specific errorCode.
      JAXBException(String message, String errorCode, Throwable exception)
      Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
      JAXBException(String message, Throwable exception)
      Construct a JAXBException with the specified detail message and linkedException.
      JAXBException(Throwable exception)
      Construct a JAXBException with a linkedException.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.
      String getErrorCode()
      Get the vendor specific error code
      Throwable getLinkedException()
      Get the linked exception
      void printStackTrace()
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
      void printStackTrace(PrintStream s)
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
      void printStackTrace(PrintWriter s)
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
      void setLinkedException(Throwable exception)
      Add a linked Exception.
      String toString()
      Returns a short description of this JAXBException.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JAXBException

        public JAXBException(String message)
        Construct a JAXBException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • JAXBException

        public JAXBException(String message,
                     String errorCode)
        Construct a JAXBException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • JAXBException

        public JAXBException(Throwable exception)
        Construct a JAXBException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • JAXBException

        public JAXBException(String message,
                     Throwable exception)
        Construct a JAXBException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • JAXBException

        public JAXBException(String message,
                     String errorCode,
                     Throwable exception)
        Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

    • Method Detail

      • getErrorCode

        public String getErrorCode()
        Get the vendor specific error code
        Returns:
        a string specifying the vendor specific error code

      • getLinkedException

        public Throwable getLinkedException()
        Get the linked exception
        Returns:
        the linked Exception, null if none exists

      • setLinkedException

        public void setLinkedException(Throwable exception)
        Add a linked Exception.
        Parameters:
        exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

      • toString

        public String toString()
        Returns a short description of this JAXBException.
        Overrides:
        toString in class Throwable
        Returns:
        a string representation of this throwable.

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace()
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output

      • getCause

        public Throwable getCause()
        Description copied from class: Throwable
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)

        This implementation returns the cause that was supplied via one of the constructors requiring a Throwable, or that was set after creation with the Throwable.initCause(Throwable) method. While it is typically unnecessary to override this method, a subclass can override it to return a cause set by some other means. This is appropriate for a "legacy chained throwable" that predates the addition of chained exceptions to Throwable. Note that it is not necessary to override any of the PrintStackTrace methods, all of which invoke the getCause method to determine the cause of a throwable.

        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this throwable or null if the cause is nonexistent or unknown.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBIntrospector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBIntrospector

  • java.lang.Object
    • javax.xml.bind.JAXBIntrospector

  • public abstract class JAXBIntrospector
extends Object
    Provide access to JAXB xml binding data for a JAXB object.

    Intially, the intent of this class is to just conceptualize how a JAXB application developer can access xml binding information, independent if binding model is java to schema or schema to java. Since accessing the XML element name related to a JAXB element is a highly requested feature, demonstrate access to this binding information. The factory method to get a JAXBIntrospector instance is JAXBContext.createJAXBIntrospector().

    Since:
    JAXB2.0
    See Also:
    JAXBContext.createJAXBIntrospector()

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBIntrospector()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract QName getElementName(Object jaxbElement)
      Get xml element qname for jaxbElement.
      static Object getValue(Object jaxbElement)
      Get the element value of a JAXB element.
      abstract boolean isElement(Object object)
      Return true if object represents a JAXB element.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBIntrospector

        public JAXBIntrospector()

    • Method Detail

      • isElement

        public abstract boolean isElement(Object object)

        Return true if object represents a JAXB element.

        Parameter object is a JAXB element for following cases:

        1. It is an instance of javax.xml.bind.JAXBElement.
        2. The class of object is annotated with @XmlRootElement.
        See Also:
        getElementName(Object)

      • getElementName

        public abstract QName getElementName(Object jaxbElement)

        Get xml element qname for jaxbElement.

        Parameters:
        jaxbElement - is an object that isElement(Object) returned true.
        Returns:
        xml element qname associated with jaxbElement; null if jaxbElement is not a JAXB Element.

      • getValue

        public static Object getValue(Object jaxbElement)

        Get the element value of a JAXB element.

        Convenience method to abstract whether working with either a javax.xml.bind.JAXBElement instance or an instance of @XmlRootElement annotated Java class.

        Parameters:
        jaxbElement - object that #isElement(Object) returns true.
        Returns:
        The element value of the jaxbElement.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBPermission (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class JAXBPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.xml.bind.JAXBPermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class JAXBPermission
extends BasicPermission
    This class is for JAXB permissions. A JAXBPermission contains a name (also referred to as a "target name") but no actions list; you either have the named permission or you don't.

    The target name is the name of the JAXB permission (see below).

    The following table lists all the possible JAXBPermission target names, and for each provides a description of what the permission allows and a discussion of the risks of granting code the permission.

    Permission Target Name | What the Permission Allows | Risks of Allowing this Permission
    setDatatypeConverter | Allows the code to set VM-wide DatatypeConverterInterface via the setDatatypeConverter method that all the methods on DatatypeConverter uses. | Malicious code can set DatatypeConverterInterface, which has VM-wide singleton semantics, before a genuine JAXB implementation sets one. This allows malicious code to gain access to objects that it may otherwise not have access to, such as Frame.getFrames() that belongs to another application running in the same JVM.
    Since:
    JAXB 2.2
    See Also:
    BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBPermission(String name)
      Creates a new JAXBPermission with the specified name.

    • Method Summary

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • JAXBPermission

        public JAXBPermission(String name)
        Creates a new JAXBPermission with the specified name.
        Parameters:
        name - The name of the JAXBPermission. As of 2.2 only "setDatatypeConverter" is defined.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class MarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
  • All Implemented Interfaces:
    Serializable

    public class MarshalException
extends JAXBException
    This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.

    The ValidationEventHandler can cause this exception to be thrown during the marshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    Since:
    JAXB1.0
    See Also:
    JAXBException, Marshaller, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MarshalException(String message)
      Construct a MarshalException with the specified detail message.
      MarshalException(String message, String errorCode)
      Construct a MarshalException with the specified detail message and vendor specific errorCode.
      MarshalException(String message, String errorCode, Throwable exception)
      Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
      MarshalException(String message, Throwable exception)
      Construct a MarshalException with the specified detail message and linkedException.
      MarshalException(Throwable exception)
      Construct a MarshalException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MarshalException

        public MarshalException(String message)
        Construct a MarshalException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • MarshalException

        public MarshalException(String message,
                        String errorCode)
        Construct a MarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • MarshalException

        public MarshalException(Throwable exception)
        Construct a MarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • MarshalException

        public MarshalException(String message,
                        Throwable exception)
        Construct a MarshalException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • MarshalException

        public MarshalException(String message,
                        String errorCode,
                        Throwable exception)
        Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Marshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Marshaller

  • All Known Implementing Classes:
    AbstractMarshallerImpl

    public interface Marshaller

    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data. It provides the basic marshalling methods:

    Assume the following setup code for all following code fragments:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object element = u.unmarshal( new File( "foo.xml" ) );
       Marshaller m = jc.createMarshaller();

    Marshalling to a File:

           OutputStream os = new FileOutputStream( "nosferatu.xml" );
       m.marshal( element, os );

    Marshalling to a SAX ContentHandler:

           // assume MyContentHandler instanceof ContentHandler
       m.marshal( element, new MyContentHandler() );

    Marshalling to a DOM Node:

           DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.newDocument();

       m.marshal( element, doc );

    Marshalling to a java.io.OutputStream:

           m.marshal( element, System.out );

    Marshalling to a java.io.Writer:

           m.marshal( element, new PrintWriter( System.out ) );

    Marshalling to a javax.xml.transform.SAXResult:

           // assume MyContentHandler instanceof ContentHandler
       SAXResult result = new SAXResult( new MyContentHandler() );

       m.marshal( element, result );

    Marshalling to a javax.xml.transform.DOMResult:

           DOMResult result = new DOMResult();

       m.marshal( element, result );

    Marshalling to a javax.xml.transform.StreamResult:

           StreamResult result = new StreamResult( System.out );

       m.marshal( element, result );

    Marshalling to a javax.xml.stream.XMLStreamWriter:

           XMLStreamWriter xmlStreamWriter =
           XMLOutputFactory.newInstance().createXMLStreamWriter( ... );

       m.marshal( element, xmlStreamWriter );

    Marshalling to a javax.xml.stream.XMLEventWriter:

           XMLEventWriter xmlEventWriter =
           XMLOutputFactory.newInstance().createXMLEventWriter( ... );

       m.marshal( element, xmlEventWriter );

    Marshalling content tree rooted by a JAXB element

    The first parameter of the overloaded Marshaller.marshal(java.lang.Object, ...) methods must be a JAXB element as computed by JAXBIntrospector.isElement(java.lang.Object); otherwise, a Marshaller.marshal method must throw a MarshalException. There exist two mechanisms to enable marshalling an instance that is not a JAXB element. One method is to wrap the instance as a value of a JAXBElement, and pass the wrapper element as the first parameter to a Marshaller.marshal method. For java to schema binding, it is also possible to simply annotate the instance's class with @XmlRootElement.

    Encoding

    By default, the Marshaller will use UTF-8 encoding when generating XML data to a java.io.OutputStream, or a java.io.Writer. Use the setProperty API to change the output encoding used during these marshal operations. Client applications are expected to supply a valid character encoding name as defined in the W3C XML 1.0 Recommendation and supported by your Java Platform.

    Validation and Well-Formedness

    Client applications are not required to validate the Java content tree prior to calling any of the marshal API's. Furthermore, there is no requirement that the Java content tree be valid with respect to its original schema in order to marshal it back into XML data. Different JAXB Providers will support marshalling invalid Java content trees at varying levels, however all JAXB Providers must be able to marshal a valid content tree back to XML data. A JAXB Provider must throw a MarshalException when it is unable to complete the marshal operation due to invalid content. Some JAXB Providers will fully allow marshalling invalid content, others will fail on the first validation error.

    Even when schema validation is not explictly enabled for the marshal operation, it is possible that certain types of validation events will be detected during the operation. Validation events will be reported to the registered event handler. If the client application has not registered an event handler prior to invoking one of the marshal API's, then events will be delivered to a default event handler which will terminate the marshal operation after encountering the first error or fatal error. Note that for JAXB 2.0 and later versions, DefaultValidationEventHandler is no longer used.

    Supported Properties

    All JAXB Providers are required to support the following set of properties. Some providers may support additional properties.

    jaxb.encoding - value must be a java.lang.String
    The output encoding to use when marshalling the XML data. The Marshaller will use "UTF-8" by default if this property is not specified.
    jaxb.formatted.output - value must be a java.lang.Boolean
    This property controls whether or not the Marshaller will format the resulting XML data with line breaks and indentation. A true value for this property indicates human readable indented xml data, while a false value indicates unformatted xml data. The Marshaller will default to false (unformatted) if this property is not specified.
    jaxb.schemaLocation - value must be a java.lang.String
    This property allows the client application to specify an xsi:schemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
    jaxb.noNamespaceSchemaLocation - value must be a java.lang.String
    This property allows the client application to specify an xsi:noNamespaceSchemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
    jaxb.fragment - value must be a java.lang.Boolean
    This property determines whether or not document level events will be generated by the Marshaller. If the property is not specified, the default is false. This property has different implications depending on which marshal api you are using - when this property is set to true:
    • marshal(Object,ContentHandler) - the Marshaller won't
             invoke ContentHandler.startDocument() and
             ContentHandler.endDocument().
    • marshal(Object,Node) - the property has no effect on this API.
    • marshal(Object,OutputStream) - the Marshaller won't generate an xml declaration.
    • marshal(Object,Writer) - the Marshaller won't generate an xml declaration.
    • marshal(Object,Result) - depends on the kind of Result object, see semantics for Node, ContentHandler, and Stream APIs
    • marshal(Object,XMLEventWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.
    • marshal(Object,XMLStreamWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.

    Marshal Event Callbacks

    "The Marshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during marshalling. 'External listeners' allow for centralized processing of marshal events in one callback method rather than by type event callbacks.

    Class defined event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signatures:

       // Invoked by Marshaller after it has created an instance of this object.
   boolean beforeMarshal(Marshaller);

   // Invoked by Marshaller after it has marshalled all properties of this object.
   void afterMarshal(Marshaller);
    The class defined event callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

    The external listener callback mechanism enables the registration of a Marshaller.Listener instance with a setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods.

    The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Marshaller.Listener.beforeMarshal(Object) and Marshaller.Listener.afterMarshal(Object).

    An event callback method throwing an exception terminates the current marshal process.

    Since:
    JAXB1.0
    See Also:
    JAXBContext, Validator, Unmarshaller

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  Marshaller.Listener

      Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXB_ENCODING
      The name of the property used to specify the output encoding in the marshalled XML data.
      static String JAXB_FORMATTED_OUTPUT
      The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
      static String JAXB_FRAGMENT
      The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
      static String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
      The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
      static String JAXB_SCHEMA_LOCATION
      The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentMarshaller getAttachmentMarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Marshaller.Listener getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Node getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Object getProperty(String name)
      Get the particular property in the underlying implementation of Marshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      void marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void marshal(Object jaxbElement, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      void marshal(Object jaxbElement, Writer writer)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      void marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.
      void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Marshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.

    • Field Detail

      • JAXB_ENCODING

        static final String JAXB_ENCODING
        The name of the property used to specify the output encoding in the marshalled XML data.
        See Also:
        Constant Field Values

      • JAXB_FORMATTED_OUTPUT

        static final String JAXB_FORMATTED_OUTPUT
        The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
        See Also:
        Constant Field Values

      • JAXB_SCHEMA_LOCATION

        static final String JAXB_SCHEMA_LOCATION
        The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.
        See Also:
        Constant Field Values

      • JAXB_NO_NAMESPACE_SCHEMA_LOCATION

        static final String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
        The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
        See Also:
        Constant Field Values

      • JAXB_FRAGMENT

        static final String JAXB_FRAGMENT
        The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
        See Also:
        Constant Field Values

    • Method Detail

      • marshal

        void marshal(Object jaxbElement,
             Result result)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.

        All JAXB Providers must at least support DOMResult, SAXResult, and StreamResult. It can support other derived classes of Result as well.

        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        result - XML will be sent to this Result
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
             OutputStream os)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into an output stream.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        os - XML will be added to this stream.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
             File output)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into a file.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        output - File to be written. If this file already exists, it will be overwritten.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        Since:
        JAXB2.1

      • marshal

        void marshal(Object jaxbElement,
             Writer writer)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into a Writer.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
             ContentHandler handler)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into SAX2 events.
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        handler - XML will be sent to this handler as SAX2 events.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
             Node node)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into a DOM tree.
        Parameters:
        jaxbElement - The content tree to be marshalled.
        node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
             XMLStreamWriter writer)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
        Parameters:
        jaxbElement - The content tree to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        Since:
        JAXB 2.0

      • marshal

        void marshal(Object jaxbElement,
             XMLEventWriter writer)
      throws JAXBException
        Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
        Parameters:
        jaxbElement - The content tree rooted at jaxbElement to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        Since:
        JAXB 2.0

      • getNode

        Node getNode(Object contentTree)
      throws JAXBException
        Get a DOM tree view of the content tree(Optional). If the returned DOM tree is updated, these changes are also visible in the content tree. Use marshal(Object, org.w3c.dom.Node) to force a deep copy of the content tree to a DOM representation.
        Parameters:
        contentTree - - JAXB Java representation of XML content
        Returns:
        the DOM tree view of the contentTree
        Throws:
        UnsupportedOperationException - If the JAXB provider implementation does not support a DOM view of the content tree
        IllegalArgumentException - If any of the method parameters are null
        JAXBException - If any unexpected problem occurs

      • setProperty

        void setProperty(String name,
                 Object value)
          throws PropertyException
        Set the particular property in the underlying implementation of Marshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
            throws PropertyException
        Get the particular property in the underlying implementation of Marshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
              throws JAXBException
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • setAdapter

        void setAdapter(XmlAdapter adapter)
        Associates a configured instance of XmlAdapter with this marshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Throws:
        IllegalArgumentException - if the adapter parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB 2.0
        See Also:
        setAdapter(Class,XmlAdapter)

      • setAdapter

        <A extends XmlAdapter> void setAdapter(Class<A> type,
                                       A adapter)
        Associates a configured instance of XmlAdapter with this marshaller.

        Every marshaller internally maintains a Map<Class,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB 2.0

      • getAdapter

        <A extends XmlAdapter> A getAdapter(Class<A> type)
        Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB 2.0

      • setAttachmentMarshaller

        void setAttachmentMarshaller(AttachmentMarshaller am)

        Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

        Throws:
        IllegalStateException - if attempt to concurrently call this method during a marshal operation.

      • getAttachmentMarshaller

        AttachmentMarshaller getAttachmentMarshaller()

      • setSchema

        void setSchema(Schema schema)
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

        This method allows the caller to validate the marshalled XML as it's marshalled.

        Initially this property is set to null.

        Parameters:
        schema - Schema object to validate marshal operations against or null to disable validation
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • getSchema

        Schema getSchema()
        Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.
        Returns:
        the Schema object being used to perform marshal-time validation or null if not present.
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • setListener

        void setListener(Marshaller.Listener listener)

        Register marshal event callback Marshaller.Listener with this Marshaller.

        There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Parameters:
        listener - an instance of a class that implements Marshaller.Listener
        Since:
        JAXB2.0

      • getListener

        Marshaller.Listener getListener()

        Return Marshaller.Listener registered with this Marshaller.

        Returns:
        registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
        Since:
        JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Marshaller.Listener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class Marshaller.Listener

  • java.lang.Object
    • javax.xml.bind.Marshaller.Listener
  • Enclosing interface:
    Marshaller

    public abstract static class Marshaller.Listener
extends Object

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

    This class enables pre and post processing of each marshalled object. The event callbacks are called when marshalling from an instance that maps to an xml element or complex type definition. The event callbacks are not called when marshalling from an instance of a Java datatype that represents a simple type definition.

    External listener is one of two different mechanisms for defining marshal event callbacks. See Marshal Event Callbacks for an overview.

    Since:
    JAXB2.0
    See Also:
    Marshaller.setListener(Listener), Marshaller.getListener()

    • Constructor Summary

      Constructors
      Constructor and Description
      Listener()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void afterMarshal(Object source)

      Callback method invoked after marshalling source to XML.
      void beforeMarshal(Object source)

      Callback method invoked before marshalling from source to XML.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Listener

        public Listener()

    • Method Detail

      • beforeMarshal

        public void beforeMarshal(Object source)

        Callback method invoked before marshalling from source to XML.

        This method is invoked just before marshalling process starts to marshal source. Note that if the class of source defines its own beforeMarshal method, the class specific callback method is invoked just before this method is invoked.

        Parameters:
        source - instance of JAXB mapped class prior to marshalling from it.

      • afterMarshal

        public void afterMarshal(Object source)

        Callback method invoked after marshalling source to XML.

        This method is invoked after source and all its descendants have been marshalled. Note that if the class of source defines its own afterMarshal method, the class specific callback method is invoked just before this method is invoked.

        Parameters:
        source - instance of JAXB mapped class after marshalling it.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotIdentifiableEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface NotIdentifiableEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    NotIdentifiableEventImpl

    public interface NotIdentifiableEvent
extends ValidationEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    Since:
    JAXB1.0
    See Also:
    Validator, ValidationEventHandler

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Method Summary

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind (Java Platform SE 8 )

javax.xml.bind

Interfaces

  • DatatypeConverterInterface
  • Element
  • Marshaller
  • NotIdentifiableEvent
  • ParseConversionEvent
  • PrintConversionEvent
  • Unmarshaller
  • UnmarshallerHandler
  • ValidationEvent
  • ValidationEventHandler
  • ValidationEventLocator
  • Validator

Classes

  • Binder
  • DatatypeConverter
  • JAXB
  • JAXBContext
  • JAXBElement
  • JAXBElement.GlobalScope
  • JAXBIntrospector
  • JAXBPermission
  • Marshaller.Listener
  • SchemaOutputResolver
  • Unmarshaller.Listener

Exceptions

  • DataBindingException
  • JAXBException
  • MarshalException
  • PropertyException
  • TypeConstraintException
  • UnmarshalException
  • ValidationException


javax.xml.bind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

See: Description

  • Interface Summary
    Interface Description
    DatatypeConverterInterface
    The DatatypeConverterInterface is for JAXB provider use only.
    Element
    This is an element marker interface.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    NotIdentifiableEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    ParseConversionEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    PrintConversionEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    UnmarshallerHandler
    Unmarshaller implemented as SAX ContentHandler.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
    Validator Deprecated
    since JAXB 2.0
  • Class Summary
    Class Description
    Binder<XmlNode>
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
    DatatypeConverter
    The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
    JAXB
    Class that defines convenience methods for common, simple use of JAXB.
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBElement<T>
    JAXB representation of an Xml Element.
    JAXBElement.GlobalScope
    Designates global scope for an xml element.
    JAXBIntrospector
    Provide access to JAXB xml binding data for a JAXB object.
    JAXBPermission
    This class is for JAXB permissions.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    SchemaOutputResolver
    Controls where a JAXB implementation puts the generates schema files.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
  • Exception Summary
    Exception Description
    DataBindingException
    Exception that represents a failure in a JAXB operation.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    MarshalException
    This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    TypeConstraintException
    This exception indicates that a violation of a dynamically checked type constraint was detected.
    UnmarshalException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
    ValidationException
    This exception indicates that an error has occurred while performing a validate operation.

Package javax.xml.bind Description

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

JAXBContext is the client-entry point to the runtime binding framework.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>
    • javax.xml.bind.DatatypeConverter
    • javax.xml.bind.JAXB
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.xml.bind.Marshaller.Listener
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.bind.JAXBPermission
    • javax.xml.bind.SchemaOutputResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • java.lang.RuntimeException
          • javax.xml.bind.DataBindingException
          • javax.xml.bind.TypeConstraintException
    • javax.xml.bind.Unmarshaller.Listener

Interface Hierarchy

  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.xml.bind.DatatypeConverterInterface
  • javax.xml.bind.Element
  • javax.xml.bind.Marshaller
  • javax.xml.bind.Unmarshaller
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.bind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind

  • Packages that use javax.xml.bind
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.bind used by javax.xml.bind
    Class and Description
    Binder
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
    DatatypeConverterInterface
    The DatatypeConverterInterface is for JAXB provider use only.
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBElement
    JAXB representation of an Xml Element.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    JAXBIntrospector
    Provide access to JAXB xml binding data for a JAXB object.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    SchemaOutputResolver
    Controls where a JAXB implementation puts the generates schema files.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
    UnmarshallerHandler
    Unmarshaller implemented as SAX ContentHandler.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
    Validator
    Deprecated.
    since JAXB 2.0
  • Classes in javax.xml.bind used by javax.xml.bind.annotation
    Class and Description
    ValidationEventHandler
    A basic event handler interface for validation errors.
  • Classes in javax.xml.bind used by javax.xml.bind.helpers
    Class and Description
    JAXBElement
    JAXB representation of an Xml Element.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    NotIdentifiableEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    ParseConversionEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    PrintConversionEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    UnmarshalException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
  • Classes in javax.xml.bind used by javax.xml.bind.util
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
  • Classes in javax.xml.bind used by javax.xml.ws
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Classes in javax.xml.bind used by javax.xml.ws.handler.soap
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Classes in javax.xml.bind used by javax.xml.ws.spi
    Class and Description
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParseConversionEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ParseConversionEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    ParseConversionEventImpl

    public interface ParseConversionEvent
extends ValidationEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    Since:
    JAXB1.0
    See Also:
    ValidationEvent, ValidationEventHandler, Unmarshaller

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Method Summary

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PrintConversionEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface PrintConversionEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    PrintConversionEventImpl

    public interface PrintConversionEvent
extends ValidationEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    Since:
    JAXB1.0
    See Also:
    ValidationEvent, ValidationEventHandler, Marshaller

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Method Summary

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PropertyException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class PropertyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.PropertyException
  • All Implemented Interfaces:
    Serializable

    public class PropertyException
extends JAXBException
    This exception indicates that an error was encountered while getting or setting a property.
    Since:
    JAXB1.0
    See Also:
    JAXBContext, Validator, Unmarshaller, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      PropertyException(String message)
      Construct a PropertyException with the specified detail message.
      PropertyException(String name, Object value)
      Construct a PropertyException whose message field is set based on the name of the property and value.toString().
      PropertyException(String message, String errorCode)
      Construct a PropertyException with the specified detail message and vendor specific errorCode.
      PropertyException(String message, String errorCode, Throwable exception)
      Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
      PropertyException(String message, Throwable exception)
      Construct a PropertyException with the specified detail message and linkedException.
      PropertyException(Throwable exception)
      Construct a PropertyException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PropertyException

        public PropertyException(String message)
        Construct a PropertyException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • PropertyException

        public PropertyException(String message,
                         String errorCode)
        Construct a PropertyException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • PropertyException

        public PropertyException(Throwable exception)
        Construct a PropertyException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • PropertyException

        public PropertyException(String message,
                         Throwable exception)
        Construct a PropertyException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • PropertyException

        public PropertyException(String message,
                         String errorCode,
                         Throwable exception)
        Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

      • PropertyException

        public PropertyException(String name,
                         Object value)
        Construct a PropertyException whose message field is set based on the name of the property and value.toString().
        Parameters:
        name - the name of the property related to this exception
        value - the value of the property related to this exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SchemaOutputResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class SchemaOutputResolver

  • java.lang.Object
    • javax.xml.bind.SchemaOutputResolver

  • public abstract class SchemaOutputResolver
extends Object
    Controls where a JAXB implementation puts the generates schema files.

    An implementation of this abstract class has to be provided by the calling application to generate schemas.

    This is a class, not an interface so as to allow future versions to evolve without breaking the compatibility.

    • Constructor Summary

      Constructors
      Constructor and Description
      SchemaOutputResolver()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract Result createOutput(String namespaceUri, String suggestedFileName)
      Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SchemaOutputResolver

        public SchemaOutputResolver()

    • Method Detail

      • createOutput

        public abstract Result createOutput(String namespaceUri,
                                    String suggestedFileName)
                             throws IOException
        Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

        This method is called only once for any given namespace. IOW, all the components in one namespace is always written into the same schema document.

        Parameters:
        namespaceUri - The namespace URI that the schema declares. Can be the empty string, but never be null.
        suggestedFileName - A JAXB implementation generates an unique file name (like "schema1.xsd") for the convenience of the callee. This name can be used for the file name of the schema, or the callee can just ignore this name and come up with its own name. This is just a hint.
        Returns:
        a Result object that encapsulates the actual destination of the schema. If the Result object has a system ID, it must be an absolute system ID. Those system IDs are relativized by the caller and used for <xs:import> statements. If the Result object does not have a system ID, a schema for the namespace URI is generated but it won't be explicitly <xs:import>ed from other schemas. If null is returned, the schema generation for this namespace URI will be skipped.
        Throws:
        IOException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeConstraintException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class TypeConstraintException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.bind.TypeConstraintException
  • All Implemented Interfaces:
    Serializable

    public class TypeConstraintException
extends RuntimeException
    This exception indicates that a violation of a dynamically checked type constraint was detected.

    This exception can be thrown by the generated setter methods of the schema derived Java content classes. However, since fail-fast validation is an optional feature for JAXB Providers to support, not all setter methods will throw this exception when a type constraint is violated.

    If this exception is throw while invoking a fail-fast setter, the value of the property is guaranteed to remain unchanged, as if the setter were never called.

    Since:
    JAXB1.0
    See Also:
    ValidationEvent, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeConstraintException(String message)
      Construct a TypeConstraintException with the specified detail message.
      TypeConstraintException(String message, String errorCode)
      Construct a TypeConstraintException with the specified detail message and vendor specific errorCode.
      TypeConstraintException(String message, String errorCode, Throwable exception)
      Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
      TypeConstraintException(String message, Throwable exception)
      Construct a TypeConstraintException with the specified detail message and linkedException.
      TypeConstraintException(Throwable exception)
      Construct a TypeConstraintException with a linkedException.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getErrorCode()
      Get the vendor specific error code
      Throwable getLinkedException()
      Get the linked exception
      void printStackTrace()
      Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
      void printStackTrace(PrintStream s)
      Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
      void setLinkedException(Throwable exception)
      Add a linked Exception.
      String toString()
      Returns a short description of this TypeConstraintException.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeConstraintException

        public TypeConstraintException(String message)
        Construct a TypeConstraintException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                               String errorCode)
        Construct a TypeConstraintException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • TypeConstraintException

        public TypeConstraintException(Throwable exception)
        Construct a TypeConstraintException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                               Throwable exception)
        Construct a TypeConstraintException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                               String errorCode,
                               Throwable exception)
        Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

    • Method Detail

      • getErrorCode

        public String getErrorCode()
        Get the vendor specific error code
        Returns:
        a string specifying the vendor specific error code

      • getLinkedException

        public Throwable getLinkedException()
        Get the linked exception
        Returns:
        the linked Exception, null if none exists

      • setLinkedException

        public void setLinkedException(Throwable exception)
        Add a linked Exception.
        Parameters:
        exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

      • toString

        public String toString()
        Returns a short description of this TypeConstraintException.
        Overrides:
        toString in class Throwable
        Returns:
        a string representation of this throwable.

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace()
        Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
        Overrides:
        printStackTrace in class Throwable
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnmarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class UnmarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.UnmarshalException
  • All Implemented Interfaces:
    Serializable

    public class UnmarshalException
extends JAXBException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.

    The ValidationEventHandler can cause this exception to be thrown during the unmarshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    Since:
    JAXB1.0
    See Also:
    JAXBException, Unmarshaller, ValidationEventHandler, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      UnmarshalException(String message)
      Construct an UnmarshalException with the specified detail message.
      UnmarshalException(String message, String errorCode)
      Construct an UnmarshalException with the specified detail message and vendor specific errorCode.
      UnmarshalException(String message, String errorCode, Throwable exception)
      Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
      UnmarshalException(String message, Throwable exception)
      Construct an UnmarshalException with the specified detail message and linkedException.
      UnmarshalException(Throwable exception)
      Construct an UnmarshalException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnmarshalException

        public UnmarshalException(String message)
        Construct an UnmarshalException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • UnmarshalException

        public UnmarshalException(String message,
                          String errorCode)
        Construct an UnmarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • UnmarshalException

        public UnmarshalException(Throwable exception)
        Construct an UnmarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • UnmarshalException

        public UnmarshalException(String message,
                          Throwable exception)
        Construct an UnmarshalException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • UnmarshalException

        public UnmarshalException(String message,
                          String errorCode,
                          Throwable exception)
        Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Unmarshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Unmarshaller

  • All Known Implementing Classes:
    AbstractUnmarshallerImpl

    public interface Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled. It provides an overloading of unmarshal methods for many different input kinds.

    Unmarshalling from a File:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( new File( "nosferatu.xml" ) );

    Unmarshalling from an InputStream:

           InputStream is = new FileInputStream( "nosferatu.xml" );
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( is );

    Unmarshalling from a URL:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       URL url = new URL( "http://beaker.east/nosferatu.xml" );
       Object o = u.unmarshal( url );

    Unmarshalling from a StringBuffer using a javax.xml.transform.stream.StreamSource:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       StringBuffer xmlStr = new StringBuffer( "<?xml version="1.0"?>..." );
       Object o = u.unmarshal( new StreamSource( new StringReader( xmlStr.toString() ) ) );

    Unmarshalling from a org.w3c.dom.Node:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));

       Object o = u.unmarshal( doc );

    Unmarshalling from a javax.xml.transform.sax.SAXSource using a client specified validating SAX2.0 parser:

           // configure a validating SAX2.0 parser (Xerces2)
       static final String JAXP_SCHEMA_LANGUAGE =
           "http://java.sun.com/xml/jaxp/properties/schemaLanguage";
       static final String JAXP_SCHEMA_LOCATION =
           "http://java.sun.com/xml/jaxp/properties/schemaSource";
       static final String W3C_XML_SCHEMA =
           "http://www.w3.org/2001/XMLSchema";

       System.setProperty( "javax.xml.parsers.SAXParserFactory",
                           "org.apache.xerces.jaxp.SAXParserFactoryImpl" );

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware(true);
       spf.setValidating(true);
       SAXParser saxParser = spf.newSAXParser();

       try {
           saxParser.setProperty(JAXP_SCHEMA_LANGUAGE, W3C_XML_SCHEMA);
           saxParser.setProperty(JAXP_SCHEMA_LOCATION, "http://....");
       } catch (SAXNotRecognizedException x) {
           // exception handling omitted
       }

       XMLReader xmlReader = saxParser.getXMLReader();
       SAXSource source =
           new SAXSource( xmlReader, new InputSource( "http://..." ) );

       // Setup JAXB to unmarshal
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       ValidationEventCollector vec = new ValidationEventCollector();
       u.setEventHandler( vec );

       // turn off the JAXB provider's default validation mechanism to
       // avoid duplicate validation
       u.setValidating( false )

       // unmarshal
       Object o = u.unmarshal( source );

       // check for events
       if( vec.hasEvents() ) {
          // iterate over events
       }

    Unmarshalling from a StAX XMLStreamReader:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLStreamReader xmlStreamReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLStreamReader( ... );

       Object o = u.unmarshal( xmlStreamReader );

    Unmarshalling from a StAX XMLEventReader:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLEventReader xmlEventReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLEventReader( ... );

       Object o = u.unmarshal( xmlEventReader );

    Unmarshalling XML Data

    Unmarshalling can deserialize XML data that represents either an entire XML document or a subtree of an XML document. Typically, it is sufficient to use the unmarshalling methods described by Unmarshal root element that is declared globally. These unmarshal methods utilize JAXBContext's mapping of global XML element declarations and type definitions to JAXB mapped classes to initiate the unmarshalling of the root element of XML data. When the JAXBContext's mappings are not sufficient to unmarshal the root element of XML data, the application can assist the unmarshalling process by using the unmarshal by declaredType methods. These methods are useful for unmarshalling XML data where the root element corresponds to a local element declaration in the schema.
    An unmarshal method never returns null. If the unmarshal process is unable to unmarshal the root of XML content to a JAXB mapped object, a fatal error is reported that terminates processing by throwing JAXBException.

    Unmarshal a root element that is globally declared

    The unmarshal methods that do not have an declaredType parameter use JAXBContext to unmarshal the root element of an XML data. The JAXBContext instance is the one that was used to create this Unmarshaller. The JAXBContext instance maintains a mapping of globally declared XML element and type definition names to JAXB mapped classes. The unmarshal method checks if JAXBContext has a mapping from the root element's XML name and/or @xsi:type to a JAXB mapped class. If it does, it umarshalls the XML data using the appropriate JAXB mapped class. Note that when the root element name is unknown and the root element has an @xsi:type, the XML data is unmarshalled using that JAXB mapped class as the value of a JAXBElement. When the JAXBContext object does not have a mapping for the root element's name nor its @xsi:type, if it exists, then the unmarshal operation will abort immediately by throwing a UnmarshalException. This exception scenario can be worked around by using the unmarshal by declaredType methods described in the next subsection.

    Unmarshal by Declared Type

    The unmarshal methods with a declaredType parameter enable an application to deserialize a root element of XML data, even when there is no mapping in JAXBContext of the root element's XML name. The unmarshaller unmarshals the root element using the application provided mapping specified as the declaredType parameter. Note that even when the root element's element name is mapped by JAXBContext, the declaredType parameter overrides that mapping for deserializing the root element when using these unmarshal methods. Additionally, when the root element of XML data has an xsi:type attribute and that attribute's value references a type definition that is mapped to a JAXB mapped class by JAXBContext, that the root element's xsi:type attribute takes precedence over the unmarshal methods declaredType parameter. These methods always return a JAXBElement<declaredType> instance. The table below shows how the properties of the returned JAXBElement instance are set.

    Unmarshal By Declared Type returned JAXBElement
    JAXBElement Property | Value
    name | xml element name
    value | instanceof declaredType
    declaredType | unmarshal method declaredType parameter
    scope | null (actual scope is unknown)

    The following is an example of unmarshal by declaredType method.

    Unmarshal by declaredType from a org.w3c.dom.Node:

           Schema fragment for example
       <xs:schema>
          <xs:complexType name="FooType">...<\xs:complexType>
          <!-- global element declaration "PurchaseOrder" -->
          <xs:element name="PurchaseOrder">
              <xs:complexType>
                 <xs:sequence>
                    <!-- local element declaration "foo" -->
                    <xs:element name="foo" type="FooType"/>
                    ...
                 </xs:sequence>
              </xs:complexType>
          </xs:element>
       </xs:schema>

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));
       Element  fooSubtree = ...; // traverse DOM till reach xml element foo, constrained by a
                                  // local element declaration in schema.

       // FooType is the JAXB mapping of the type of local element declaration foo.
       JAXBElement<FooType> foo = u.unmarshal( fooSubtree, FooType.class);

    Support for SAX2.0 Compliant Parsers

    A client application has the ability to select the SAX2.0 compliant parser of their choice. If a SAX parser is not selected, then the JAXB Provider's default parser will be used. Even though the JAXB Provider's default parser is not required to be SAX2.0 compliant, all providers are required to allow a client application to specify their own SAX2.0 parser. Some providers may require the client application to specify the SAX2.0 parser at schema compile time. See unmarshal(Source) for more detail.

    Validation and Well-Formedness

    A client application can enable or disable JAXP 1.3 validation mechanism via the setSchema(javax.xml.validation.Schema) API. Sophisticated clients can specify their own validating SAX 2.0 compliant parser and bypass the JAXP 1.3 validation mechanism using the unmarshal(Source) API.

    Since unmarshalling invalid XML content is defined in JAXB 2.0, the Unmarshaller default validation event handler was made more lenient than in JAXB 1.0. When schema-derived code generated by JAXB 1.0 binding compiler is registered with JAXBContext, the default unmarshal validation handler is DefaultValidationEventHandler and it terminates the marshal operation after encountering either a fatal error or an error. For a JAXB 2.0 client application, there is no explicitly defined default validation handler and the default event handling only terminates the unmarshal operation after encountering a fatal error.

    Supported Properties

    There currently are not any properties required to be supported by all JAXB Providers on Unmarshaller. However, some providers may support their own set of provider specific properties.

    Unmarshal Event Callbacks

    The Unmarshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during unmarshalling. 'External listeners' allow for centralized processing of unmarshal events in one callback method rather than by type event callbacks.

    'Class defined' event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signature:

       // This method is called immediately after the object is created and before the unmarshalling of this
   // object begins. The callback provides an opportunity to initialize JavaBean properties prior to unmarshalling.
   void beforeUnmarshal(Unmarshaller, Object parent);

   //This method is called after all the properties (except IDREF) are unmarshalled for this object,
   //but before this object is set to the parent object.
   void afterUnmarshal(Unmarshaller, Object parent);
    The class defined callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

    The external listener callback mechanism enables the registration of a Unmarshaller.Listener instance with an setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods. The external listener receives events when unmarshalling proces is marshalling to a JAXB element or to JAXB mapped class.

    The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Unmarshaller.Listener.beforeUnmarshal(Object, Object) and Unmarshaller.Listener.afterUnmarshal(Object, Object).

    An event callback method throwing an exception terminates the current unmarshal process.

    Since:
    JAXB1.0
    See Also:
    JAXBContext, Marshaller, Validator

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  Unmarshaller.Listener

      Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentUnmarshaller getAttachmentUnmarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Unmarshaller.Listener getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Object getProperty(String name)
      Get the particular property in the underlying implementation of Unmarshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      UnmarshallerHandler getUnmarshallerHandler()
      Get an unmarshaller handler object that can be used as a component in an XML pipeline.
      boolean isValidating()
      Deprecated.
      since JAXB2.0, please see getSchema()
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
      void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Unmarshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void setValidating(boolean validating)
      Deprecated.
      since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
      Object unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      Object unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Method Detail

      • unmarshal

        Object unmarshal(File f)
          throws JAXBException
        Unmarshal XML data from the specified file and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        f - the file to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the file parameter is null

      • unmarshal

        Object unmarshal(InputStream is)
          throws JAXBException
        Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

        Implements Unmarshal Global Root Element.

        Parameters:
        is - the InputStream to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputStream parameter is null

      • unmarshal

        Object unmarshal(Reader reader)
          throws JAXBException
        Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

        Implements Unmarshal Global Root Element.

        Parameters:
        reader - the Reader to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputStream parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(URL url)
          throws JAXBException
        Unmarshal XML data from the specified URL and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        url - the url to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the URL parameter is null

      • unmarshal

        Object unmarshal(InputSource source)
          throws JAXBException
        Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        source - the input source to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputSource parameter is null

      • unmarshal

        Object unmarshal(Node node)
          throws JAXBException
        Unmarshal global XML data from the specified DOM tree and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Parameters:
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the Node parameter is null
        See Also:
        unmarshal(org.w3c.dom.Node, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(Node node,
                             Class<T> declaredType)
                      throws JAXBException
        Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        Parameters:
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        declaredType - appropriate JAXB mapped class to hold node's XML data.
        Returns:
        JAXB Element representation of node
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(Source source)
          throws JAXBException
        Unmarshal XML data from the specified XML Source and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        SAX 2.0 Parser Pluggability

        A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

        This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

        The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the Source parameter is null
        See Also:
        unmarshal(javax.xml.transform.Source, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(Source source,
                             Class<T> declaredType)
                      throws JAXBException
        Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        See SAX 2.0 Parser Pluggability

        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        declaredType - appropriate JAXB mapped class to hold source's xml root element
        Returns:
        Java content rooted by JAXB Element
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(XMLStreamReader reader)
          throws JAXBException
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the reader parameter is null
        IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
        Since:
        JAXB2.0
        See Also:
        unmarshal(javax.xml.stream.XMLStreamReader, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                             Class<T> declaredType)
                      throws JAXBException
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • unmarshal

        Object unmarshal(XMLEventReader reader)
          throws JAXBException
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        This method is an Unmarshal Global Root method.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the reader parameter is null
        IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
        Since:
        JAXB2.0
        See Also:
        unmarshal(javax.xml.stream.XMLEventReader, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                             Class<T> declaredType)
                      throws JAXBException
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Parameters:
        reader - The parser to be read.
        declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        Since:
        JAXB2.0

      • getUnmarshallerHandler

        UnmarshallerHandler getUnmarshallerHandler()
        Get an unmarshaller handler object that can be used as a component in an XML pipeline.

        The JAXB Provider can return the same handler object for multiple invocations of this method. In other words, this method does not necessarily create a new instance of UnmarshallerHandler. If the application needs to use more than one UnmarshallerHandler, it should create more than one Unmarshaller.

        Returns:
        the unmarshaller handler object
        See Also:
        UnmarshallerHandler

      • setValidating

        void setValidating(boolean validating)
            throws JAXBException
        Deprecated. since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
        Specifies whether or not the default validation mechanism of the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

        This method may only be invoked before or after calling one of the unmarshal methods.

        This method only controls the JAXB Provider's default unmarshal-time validation mechanism - it has no impact on clients that specify their own validating SAX 2.0 compliant parser. Clients that specify their own unmarshal-time validation mechanism may wish to turn off the JAXB Provider's default validation mechanism via this API to avoid "double validation".

        This method is deprecated as of JAXB 2.0 - please use the new setSchema(javax.xml.validation.Schema) API.

        Parameters:
        validating - true if the Unmarshaller should validate during unmarshal, false otherwise
        Throws:
        JAXBException - if an error occurred while enabling or disabling validation at unmarshal time
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

      • isValidating

        boolean isValidating()
              throws JAXBException
        Deprecated. since JAXB2.0, please see getSchema()
        Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

        This API returns the state of the JAXB Provider's default unmarshal-time validation mechanism.

        This method is deprecated as of JAXB 2.0 - please use the new getSchema() API.

        Returns:
        true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
        Throws:
        JAXBException - if an error occurs while retrieving the validating flag
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
              throws JAXBException
        Allow an application to register a ValidationEventHandler.

        The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a ValidationEventHandler before invoking the unmarshal methods, then ValidationEvents will be handled by the default event handler which will terminate the unmarshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Unmarshaller to revert back to the default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • setProperty

        void setProperty(String name,
                 Object value)
          throws PropertyException
        Set the particular property in the underlying implementation of Unmarshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
            throws PropertyException
        Get the particular property in the underlying implementation of Unmarshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null

      • setSchema

        void setSchema(Schema schema)
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

        This method replaces the deprecated setValidating(boolean) API.

        Initially this property is set to null.

        Parameters:
        schema - Schema object to validate unmarshal operations against or null to disable validation
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • getSchema

        Schema getSchema()
        Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

        This method provides replacement functionality for the deprecated isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

        boolean isValidating = u.getSchema()!=null;

        Returns:
        the Schema object being used to perform unmarshal-time validation or null if not present
        Throws:
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        Since:
        JAXB2.0

      • setAdapter

        void setAdapter(XmlAdapter adapter)
        Associates a configured instance of XmlAdapter with this unmarshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Throws:
        IllegalArgumentException - if the adapter parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB2.0
        See Also:
        setAdapter(Class,XmlAdapter)

      • setAdapter

        <A extends XmlAdapter> void setAdapter(Class<A> type,
                                       A adapter)
        Associates a configured instance of XmlAdapter with this unmarshaller.

        Every unmarshaller internally maintains a Map<Class,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB2.0

      • getAdapter

        <A extends XmlAdapter> A getAdapter(Class<A> type)
        Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Throws:
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        Since:
        JAXB2.0

      • setAttachmentUnmarshaller

        void setAttachmentUnmarshaller(AttachmentUnmarshaller au)

        Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

        Unmarshal time validation, enabled via setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

        Throws:
        IllegalStateException - if attempt to concurrently call this method during a unmarshal operation.

      • getAttachmentUnmarshaller

        AttachmentUnmarshaller getAttachmentUnmarshaller()

      • setListener

        void setListener(Unmarshaller.Listener listener)

        Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

        There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Parameters:
        listener - provides unmarshal event callbacks for this Unmarshaller
        Since:
        JAXB2.0

      • getListener

        Unmarshaller.Listener getListener()

        Return Unmarshaller.Listener registered with this Unmarshaller.

        Returns:
        registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
        Since:
        JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Unmarshaller.Listener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class Unmarshaller.Listener

  • java.lang.Object
    • javax.xml.bind.Unmarshaller.Listener
  • Enclosing interface:
    Unmarshaller

    public abstract static class Unmarshaller.Listener
extends Object

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

    This class enables pre and post processing of an instance of a JAXB mapped class as XML data is unmarshalled into it. The event callbacks are called when unmarshalling XML content into a JAXBElement instance or a JAXB mapped class that represents a complex type definition. The event callbacks are not called when unmarshalling to an instance of a Java datatype that represents a simple type definition.

    External listener is one of two different mechanisms for defining unmarshal event callbacks. See Unmarshal Event Callbacks for an overview.

    (@link #setListener(Listener)} (@link #getListener()}

    Since:
    JAXB2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      Listener()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void afterUnmarshal(Object target, Object parent)

      Callback method invoked after unmarshalling XML data into target.
      void beforeUnmarshal(Object target, Object parent)

      Callback method invoked before unmarshalling into target.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Listener

        public Listener()

    • Method Detail

      • beforeUnmarshal

        public void beforeUnmarshal(Object target,
                            Object parent)

        Callback method invoked before unmarshalling into target.

        This method is invoked immediately after target was created and before the unmarshalling of this object begins. Note that if the class of target defines its own beforeUnmarshal method, the class specific callback method is invoked before this method is invoked.

        Parameters:
        target - non-null instance of JAXB mapped class prior to unmarshalling into it.
        parent - instance of JAXB mapped class that will eventually reference target. null when target is root element.

      • afterUnmarshal

        public void afterUnmarshal(Object target,
                           Object parent)

        Callback method invoked after unmarshalling XML data into target.

        This method is invoked after all the properties (except IDREF) are unmarshalled into target, but before target is set into its parent object. Note that if the class of target defines its own afterUnmarshal method, the class specific callback method is invoked before this method is invoked.

        Parameters:
        target - non-null instance of JAXB mapped class prior to unmarshalling into it.
        parent - instance of JAXB mapped class that will reference target. null when target is root element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnmarshallerHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface UnmarshallerHandler

  • All Superinterfaces:
    ContentHandler

    public interface UnmarshallerHandler
extends ContentHandler
    Unmarshaller implemented as SAX ContentHandler.

    Applications can use this interface to use their JAXB provider as a component in an XML pipeline. For example:

           JAXBContext context = JAXBContext.newInstance( "org.acme.foo" );

       Unmarshaller unmarshaller = context.createUnmarshaller();

       UnmarshallerHandler unmarshallerHandler = unmarshaller.getUnmarshallerHandler();

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware( true );

       XMLReader xmlReader = spf.newSAXParser().getXMLReader();
       xmlReader.setContentHandler( unmarshallerHandler );
       xmlReader.parse(new InputSource( new FileInputStream( XML_FILE ) ) );

       MyObject myObject= (MyObject)unmarshallerHandler.getResult();

    This interface is reusable: even if the user fails to unmarshal an object, s/he can still start a new round of unmarshalling.

    Since:
    JAXB1.0
    See Also:
    Unmarshaller.getUnmarshallerHandler()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object getResult()
      Obtains the unmarshalled result.

      • Methods inherited from interface org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • Method Detail

      • getResult

        Object getResult()
          throws JAXBException,
                 IllegalStateException
        Obtains the unmarshalled result. This method can be called only after this handler receives the endDocument SAX event.
        Returns:
        always return a non-null valid object which was unmarshalled.
        Throws:
        IllegalStateException - if this method is called before this handler receives the endDocument event.
        JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ValidationEvent

  • All Known Subinterfaces:
    NotIdentifiableEvent, ParseConversionEvent, PrintConversionEvent
    All Known Implementing Classes:
    NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl, ValidationEventImpl

    public interface ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    Since:
    JAXB1.0
    See Also:
    Validator, ValidationEventHandler

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ERROR
      Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
      static int FATAL_ERROR
      Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
      static int WARNING
      Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Throwable getLinkedException()
      Retrieve the linked exception for this warning/error.
      ValidationEventLocator getLocator()
      Retrieve the locator for this warning/error.
      String getMessage()
      Retrieve the text message for this warning/error.
      int getSeverity()
      Retrieve the severity code for this warning/error.

    • Field Detail

      • WARNING

        static final int WARNING
        Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation
        See Also:
        Constant Field Values

      • ERROR

        static final int ERROR
        Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
        See Also:
        Constant Field Values

      • FATAL_ERROR

        static final int FATAL_ERROR
        Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
        See Also:
        Constant Field Values

    • Method Detail

      • getSeverity

        int getSeverity()
        Retrieve the severity code for this warning/error.

        Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

        Returns:
        the severity code for this warning/error

      • getMessage

        String getMessage()
        Retrieve the text message for this warning/error.
        Returns:
        the text message for this warning/error or null if one wasn't set

      • getLinkedException

        Throwable getLinkedException()
        Retrieve the linked exception for this warning/error.
        Returns:
        the linked exception for this warning/error or null if one wasn't set

      • getLocator

        ValidationEventLocator getLocator()
        Retrieve the locator for this warning/error.
        Returns:
        the locator that indicates where the warning/error occurred
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationEventHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ValidationEventHandler

  • All Known Implementing Classes:
    DefaultValidationEventHandler, ValidationEventCollector

    public interface ValidationEventHandler
    A basic event handler interface for validation errors.

    If an application needs to implement customized event handling, it must implement this interface and then register it with either the Unmarshaller, the Validator, or the Marshaller. The JAXB Provider will then report validation errors and warnings encountered during the unmarshal, marshal, and validate operations to these event handlers.

    If the handleEvent method throws an unchecked runtime exception, the JAXB Provider must treat that as if the method returned false, effectively terminating whatever operation was in progress at the time (unmarshal, validate, or marshal).

    Modifying the Java content tree within your event handler is undefined by the specification and may result in unexpected behaviour.

    Failing to return false from the handleEvent method after encountering a fatal error is undefined by the specification and may result in unexpected behavior.

    Default Event Handler

    See: Validator javadocs
    Since:
    JAXB1.0
    See Also:
    Unmarshaller, Validator, Marshaller, ValidationEvent, ValidationEventCollector

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

    • Method Detail

      • handleEvent

        boolean handleEvent(ValidationEvent event)
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        Parameters:
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        Returns:
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
        Throws:
        IllegalArgumentException - if the event object is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationEventLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface ValidationEventLocator

  • All Known Implementing Classes:
    ValidationEventLocatorImpl

    public interface ValidationEventLocator
    Encapsulate the location of a ValidationEvent.

    The ValidationEventLocator indicates where the ValidationEvent occurred. Different fields will be set depending on the type of validation that was being performed when the error or warning was detected. For example, on-demand validation would produce locators that contained references to objects in the Java content tree while unmarshal-time validation would produce locators containing information appropriate to the source of the XML data (file, url, Node, etc).

    Since:
    JAXB1.0
    See Also:
    Validator, ValidationEvent

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the column number if available
      int getLineNumber()
      Return the line number if available
      Node getNode()
      Return a reference to the DOM Node if available
      Object getObject()
      Return a reference to the object in the Java content tree if available
      int getOffset()
      Return the byte offset if available
      URL getURL()
      Return the name of the XML source as a URL if available

    • Method Detail

      • getURL

        URL getURL()
        Return the name of the XML source as a URL if available
        Returns:
        the name of the XML source as a URL or null if unavailable

      • getOffset

        int getOffset()
        Return the byte offset if available
        Returns:
        the byte offset into the input source or -1 if unavailable

      • getLineNumber

        int getLineNumber()
        Return the line number if available
        Returns:
        the line number or -1 if unavailable

      • getColumnNumber

        int getColumnNumber()
        Return the column number if available
        Returns:
        the column number or -1 if unavailable

      • getObject

        Object getObject()
        Return a reference to the object in the Java content tree if available
        Returns:
        a reference to the object in the Java content tree or null if unavailable

      • getNode

        Node getNode()
        Return a reference to the DOM Node if available
        Returns:
        a reference to the DOM Node or null if unavailable
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Class ValidationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.ValidationException
  • All Implemented Interfaces:
    Serializable

    public class ValidationException
extends JAXBException
    This exception indicates that an error has occurred while performing a validate operation.

    The ValidationEventHandler can cause this exception to be thrown during the validate operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    Since:
    JAXB1.0
    See Also:
    JAXBException, Validator, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationException(String message)
      Construct an ValidationException with the specified detail message.
      ValidationException(String message, String errorCode)
      Construct an ValidationException with the specified detail message and vendor specific errorCode.
      ValidationException(String message, String errorCode, Throwable exception)
      Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
      ValidationException(String message, Throwable exception)
      Construct an ValidationException with the specified detail message and linkedException.
      ValidationException(Throwable exception)
      Construct an ValidationException with a linkedException.

    • Method Summary

      • Methods inherited from class javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationException

        public ValidationException(String message)
        Construct an ValidationException with the specified detail message. The errorCode and linkedException will default to null.
        Parameters:
        message - a description of the exception

      • ValidationException

        public ValidationException(String message,
                           String errorCode)
        Construct an ValidationException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • ValidationException

        public ValidationException(Throwable exception)
        Construct an ValidationException with a linkedException. The detail message and vendor specific errorCode will default to null.
        Parameters:
        exception - the linked exception

      • ValidationException

        public ValidationException(String message,
                           Throwable exception)
        Construct an ValidationException with the specified detail message and linkedException. The errorCode will default to null.
        Parameters:
        message - a description of the exception
        exception - the linked exception

      • ValidationException

        public ValidationException(String message,
                           String errorCode,
                           Throwable exception)
        Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
        Parameters:
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Validator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind

Interface Validator

  • Deprecated.
    since JAXB 2.0

    public interface Validator
    As of JAXB 2.0, this class is deprecated and optional.

    The Validator class is responsible for controlling the validation of content trees during runtime.

    Three Forms of Validation

    Unmarshal-Time Validation
    This form of validation enables a client application to receive information about validation errors and warnings detected while unmarshalling XML data into a Java content tree and is completely orthogonal to the other types of validation. To enable or disable it, see the javadoc for Unmarshaller.setValidating. All JAXB 1.0 Providers are required to support this operation.
    On-Demand Validation
    This form of validation enables a client application to receive information about validation errors and warnings detected in the Java content tree. At any point, client applications can call the Validator.validate method on the Java content tree (or any sub-tree of it). All JAXB 1.0 Providers are required to support this operation.
    Fail-Fast Validation
    This form of validation enables a client application to receive immediate feedback about modifications to the Java content tree that violate type constraints on Java Properties as defined in the specification. JAXB Providers are not required support this type of validation. Of the JAXB Providers that do support this type of validation, some may require you to decide at schema compile time whether or not a client application will be allowed to request fail-fast validation at runtime.

    The Validator class is responsible for managing On-Demand Validation. The Unmarshaller class is responsible for managing Unmarshal-Time Validation during the unmarshal operations. Although there is no formal method of enabling validation during the marshal operations, the Marshaller may detect errors, which will be reported to the ValidationEventHandler registered on it.

    Using the Default EventHandler

    If the client application does not set an event handler on their Validator, Unmarshaller, or Marshaller prior to calling the validate, unmarshal, or marshal methods, then a default event handler will receive notification of any errors or warnings encountered. The default event handler will cause the current operation to halt after encountering the first error or fatal error (but will attempt to continue after receiving warnings).

    Handling Validation Events

    There are three ways to handle events encountered during the unmarshal, validate, and marshal operations:
    Use the default event handler
    The default event handler will be used if you do not specify one via the setEventHandler API's on Validator, Unmarshaller, or Marshaller.
    Implement and register a custom event handler
    Client applications that require sophisticated event processing can implement the ValidationEventHandler interface and register it with the Unmarshaller and/or Validator.
    Use the ValidationEventCollector utility
    For convenience, a specialized event handler is provided that simply collects any ValidationEvent objects created during the unmarshal, validate, and marshal operations and returns them to the client application as a java.util.Collection.

    Validation and Well-Formedness

    Validation events are handled differently depending on how the client application is configured to process them as described in the previous section. However, there are certain cases where a JAXB Provider indicates that it is no longer able to reliably detect and report errors. In these cases, the JAXB Provider will set the severity of the ValidationEvent to FATAL_ERROR to indicate that the unmarshal, validate, or marshal operations should be terminated. The default event handler and ValidationEventCollector utility class must terminate processing after being notified of a fatal error. Client applications that supply their own ValidationEventHandler should also terminate processing after being notified of a fatal error. If not, unexpected behaviour may occur.

    Supported Properties

    There currently are not any properties required to be supported by all JAXB Providers on Validator. However, some providers may support their own set of provider specific properties.

    Since:
    JAXB1.0
    See Also:
    JAXBContext, Unmarshaller, ValidationEventHandler, ValidationEvent, ValidationEventCollector

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      ValidationEventHandler getEventHandler()
      Deprecated.
      since JAXB2.0
      Object getProperty(String name)
      Deprecated.
      since JAXB2.0
      void setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void setProperty(String name, Object value)
      Deprecated.
      since JAXB2.0
      boolean validate(Object subrootObj)
      Deprecated.
      since JAXB2.0
      boolean validateRoot(Object rootObj)
      Deprecated.
      since JAXB2.0

    • Method Detail

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
              throws JAXBException
        Deprecated. since JAXB2.0
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to validate. If the client application does not register a validation event handler before invoking the validate method, then validation events will be handled by the default event handler which will terminate the validate operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Validator to revert back to the default default event handler.

        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                throws JAXBException
        Deprecated. since JAXB2.0
        Return the current event handler or the default event handler if one hasn't been set.
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • validate

        boolean validate(Object subrootObj)
          throws JAXBException
        Deprecated. since JAXB2.0
        Validate the Java content tree starting at subrootObj.

        Client applications can use this method to validate Java content trees on-demand at runtime. This method can be used to validate any arbitrary subtree of the Java content tree. Global constraint checking will not be performed as part of this operation (i.e. ID/IDREF constraints).

        Parameters:
        subrootObj - the obj to begin validation at
        Returns:
        true if the subtree rooted at subrootObj is valid, false otherwise
        Throws:
        JAXBException - if any unexpected problem occurs during validation
        ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at subrootObj
        IllegalArgumentException - If the subrootObj parameter is null

      • validateRoot

        boolean validateRoot(Object rootObj)
              throws JAXBException
        Deprecated. since JAXB2.0
        Validate the Java content tree rooted at rootObj.

        Client applications can use this method to validate Java content trees on-demand at runtime. This method is used to validate an entire Java content tree. Global constraint checking will be performed as part of this operation (i.e. ID/IDREF constraints).

        Parameters:
        rootObj - the root obj to begin validation at
        Returns:
        true if the tree rooted at rootObj is valid, false otherwise
        Throws:
        JAXBException - if any unexpected problem occurs during validation
        ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at rootObj
        IllegalArgumentException - If the rootObj parameter is null

      • setProperty

        void setProperty(String name,
                 Object value)
          throws PropertyException
        Deprecated. since JAXB2.0
        Set the particular property in the underlying implementation of Validator. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
            throws PropertyException
        Deprecated. since JAXB2.0
        Get the particular property in the underlying implementation of Validator. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DomHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Interface DomHandler<ElementT,ResultT extends Result>

  • All Known Implementing Classes:
    W3CDomHandler

    public interface DomHandler<ElementT,ResultT extends Result>
    Converts an element (and its descendants) from/to DOM (or similar) representation.

    Implementations of this interface will be used in conjunction with XmlAnyElement annotation to map an element of XML into a representation of infoset such as W3C DOM.

    Implementations hide how a portion of XML is converted into/from such DOM-like representation, allowing JAXB providers to work with arbitrary such library.

    This interface is intended to be implemented by library writers and consumed by JAXB providers. None of those methods are intended to be called from applications.

    Since:
    JAXB2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ResultT createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      ElementT getElement(ResultT rt)
      Once the portion is sent to the Result.
      Source marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.

    • Method Detail

      • createUnmarshaller

        ResultT createUnmarshaller(ValidationEventHandler errorHandler)
        When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

        A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

        Parameters:
        errorHandler - if any error happens between the invocation of this method and the invocation of getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • getElement

        ElementT getElement(ResultT rt)
        Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

        Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

        Parameters:
        rt - The Result object created by createUnmarshaller(ValidationEventHandler).
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • marshal

        Source marshal(ElementT n,
               ValidationEventHandler errorHandler)
        This method is called when a JAXB provider needs to marshal an element to XML.

        If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

        Parameters:
        errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
        Returns:
        null if there was an error. The error should have been reported to the handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.annotation (Java Platform SE 8 )

javax.xml.bind.annotation

Interfaces

  • DomHandler

Classes

  • W3CDomHandler
  • XmlElement.DEFAULT
  • XmlElementDecl.GLOBAL
  • XmlElementRef.DEFAULT
  • XmlSchemaType.DEFAULT
  • XmlType.DEFAULT

Enums

  • XmlAccessOrder
  • XmlAccessType
  • XmlNsForm

Annotation Types

  • XmlAccessorOrder
  • XmlAccessorType
  • XmlAnyAttribute
  • XmlAnyElement
  • XmlAttachmentRef
  • XmlAttribute
  • XmlElement
  • XmlElementDecl
  • XmlElementRef
  • XmlElementRefs
  • XmlElements
  • XmlElementWrapper
  • XmlEnum
  • XmlEnumValue
  • XmlID
  • XmlIDREF
  • XmlInlineBinaryData
  • XmlList
  • XmlMimeType
  • XmlMixed
  • XmlNs
  • XmlRegistry
  • XmlRootElement
  • XmlSchema
  • XmlSchemaType
  • XmlSchemaTypes
  • XmlSeeAlso
  • XmlTransient
  • XmlType
  • XmlValue


javax.xml.bind.annotation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.annotation

Defines annotations for customizing Java program elements to XML Schema mapping.

See: Description

  • Interface Summary
    Interface Description
    DomHandler<ElementT,ResultT extends Result>
    Converts an element (and its descendants) from/to DOM (or similar) representation.
  • Class Summary
    Class Description
    W3CDomHandler
    DomHandler implementation for W3C DOM (org.w3c.dom package.)
    XmlElement.DEFAULT
    Used in XmlElement.type() to signal that the type be inferred from the signature of the property.
    XmlElementDecl.GLOBAL
    Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.
    XmlElementRef.DEFAULT
    Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.
    XmlSchemaType.DEFAULT
    Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.
    XmlType.DEFAULT
    Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.
  • Enum Summary
    Enum Description
    XmlAccessOrder
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    XmlAccessType
    Used by XmlAccessorType to control serialization of fields or properties.
    XmlNsForm
    Enumeration of XML Schema namespace qualifications.
  • Annotation Types Summary
    Annotation Type Description
    XmlAccessorOrder
    Controls the ordering of fields and properties in a class.
    XmlAccessorType
    Controls whether fields or Javabean properties are serialized by default.
    XmlAnyAttribute
    Maps a JavaBean property to a map of wildcard attributes.
    XmlAnyElement
    Maps a JavaBean property to XML infoset representation and/or JAXB element.
    XmlAttachmentRef
    Marks a field/property that its XML form is a uri reference to mime content.
    XmlAttribute
    Maps a JavaBean property to a XML attribute.
    XmlElement
    Maps a JavaBean property to a XML element derived from property name.
    XmlElementDecl
    Maps a factory method to a XML element.
    XmlElementRef
    Maps a JavaBean property to a XML element derived from property's type.
    XmlElementRefs
    Marks a property that refers to classes with XmlElement or JAXBElement.
    XmlElements
    A container for multiple @XmlElement annotations.
    XmlElementWrapper
    Generates a wrapper element around XML representation.
    XmlEnum
    Maps an enum type Enum to XML representation.
    XmlEnumValue
    Maps an enum constant in Enum type to XML representation.
    XmlID
    Maps a JavaBean property to XML ID.
    XmlIDREF
    Maps a JavaBean property to XML IDREF.
    XmlInlineBinaryData
    Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.
    XmlList
    Used to map a property to a list simple type.
    XmlMimeType
    Associates the MIME type that controls the XML representation of the property.
    XmlMixed
    Annotate a JavaBean multi-valued property to support mixed content.
    XmlNs
    Associates a namespace prefix with a XML namespace URI.
    XmlRegistry
    Marks a class that has XmlElementDecls.
    XmlRootElement
    Maps a class or an enum type to an XML element.
    XmlSchema
    Maps a package name to a XML namespace.
    XmlSchemaType
    Maps a Java type to a simple schema built-in type.
    XmlSchemaTypes
    A container for multiple @XmlSchemaType annotations.
    XmlSeeAlso
    Instructs JAXB to also bind other classes when binding this class.
    XmlTransient
    Prevents the mapping of a JavaBean property/type to XML representation.
    XmlType
    Maps a class or an enum type to a XML Schema type.
    XmlValue
    Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

Package javax.xml.bind.annotation Description

Defines annotations for customizing Java program elements to XML Schema mapping.

Package Specification

The following table shows the JAXB mapping annotations that can be associated with each program element.

Program Element JAXB annotation
Package
XmlAccessorOrder
XmlAccessorType
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlJavaTypeAdapter
XmlJavaTypeAdapters
Class
XmlAccessorOrder
XmlAccessorType
XmlInlineBinaryData
XmlRootElement
XmlType
XmlJavaTypeAdapter
Enum type
XmlEnum
XmlEnumValue (enum constant only)
XmlRootElement
XmlType
XmlJavaTypeAdapter
JavaBean Property/field
XmlElement
XmlElements
XmlElementRef
XmlElementRefs
XmlElementWrapper
XmlAnyElement
XmlAttribute
XmlAnyAttribute
XmlTransient
XmlValue
XmlID
XmlIDREF
XmlList
XmlMixed
XmlMimeType
XmlAttachmentRef
XmlInlineBinaryData
XmlElementDecl (only on method)
XmlJavaTypeAdapter
Parameter
XmlList
XmlAttachmentRef
XmlMimeType
XmlJavaTypeAdapter

Terminology

JavaBean property and field: For the purposes of mapping, there is no semantic difference between a field and a JavaBean property. Thus, an annotation that can be applied to a JavaBean property can always be applied to a field. Hence in the Javadoc documentation, for brevity, the term JavaBean property or property is used to mean either JavaBean property or a field. Where required, both are explicitly mentioned.

top level class: For the purpose of mapping, there is no semantic difference between a top level class and a static nested class. Thus, an annotation that can be applied to a top level class, can always be applied to a nested static class. Hence in the Javadoc documentation, for brevity, the term "top level class" or just class is used to mean either a top level class or a nested static class.

mapping annotation:A JAXB 2.0 defined program annotation based on the JSR 175 programming annotation facility.

Common Usage Constraints

The following usage constraints are defined here since they apply to more than annotation:

  • For a property, a given annotation can be applied to either read or write property but not both.
  • A property name must be different from any other property name in any of the super classes of the class being mapped.
  • A mapped field name or the decapitalized name of a mapped property must be unique within a class.

Notations

Namespace prefixes

The following namespace prefixes are used in the XML Schema fragments in this package.

Prefix | Namespace | Notes
xs | http://www.w3.org/2001/XMLSchema | Namespace of XML Schema namespace
ref | http://ws-i.org/profiles/basic/1.1/xsd | Namespace for swaref schema component
xsi | http://www.w3.org/2001/XMLSchema-instance | XML Schema namespace for instances
Since:
JAXB 2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.annotation Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.annotation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.bind.annotation.XmlType.DEFAULT

Interface Hierarchy

  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>

Annotation Type Hierarchy

  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSeeAlso (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.bind.annotation.XmlAccessOrder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.bind.annotation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.annotation

  • Packages that use javax.xml.bind.annotation
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.bind.annotation used by javax.xml.bind.annotation
    Class and Description
    DomHandler
    Converts an element (and its descendants) from/to DOM (or similar) representation.
    XmlAccessOrder
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    XmlAccessType
    Used by XmlAccessorType to control serialization of fields or properties.
    XmlNsForm
    Enumeration of XML Schema namespace qualifications.
  • Classes in javax.xml.bind.annotation used by javax.xml.ws
    Class and Description
    XmlTransient
    Prevents the mapping of a JavaBean property/type to XML representation.
  • Classes in javax.xml.bind.annotation used by javax.xml.ws.wsaddressing
    Class and Description
    XmlRootElement
    Maps a class or an enum type to an XML element.
    XmlType
    Maps a class or an enum type to a XML Schema type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


W3CDomHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class W3CDomHandler

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler
  • All Implemented Interfaces:
    DomHandler<Element,DOMResult>

    public class W3CDomHandler
extends Object
implements DomHandler<Element,DOMResult>
    DomHandler implementation for W3C DOM (org.w3c.dom package.)
    Since:
    JAXB2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      W3CDomHandler()
      Default constructor.
      W3CDomHandler(DocumentBuilder builder)
      Constructor that allows applications to specify which DOM implementation to be used.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      DocumentBuilder getBuilder()
      Element getElement(DOMResult r)
      Once the portion is sent to the Result.
      Source marshal(Element element, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      void | setBuilder(DocumentBuilder builder)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • W3CDomHandler

        public W3CDomHandler()
        Default constructor. It is up to a JAXB provider to decide which DOM implementation to use or how that is configured.

      • W3CDomHandler

        public W3CDomHandler(DocumentBuilder builder)
        Constructor that allows applications to specify which DOM implementation to be used.
        Parameters:
        builder - must not be null. JAXB uses this DocumentBuilder to create a new element.

    • Method Detail

      • getBuilder

        public DocumentBuilder getBuilder()

      • setBuilder

        public void setBuilder(DocumentBuilder builder)

      • createUnmarshaller

        public DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
        Description copied from interface: DomHandler
        When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

        A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

        Specified by:
        createUnmarshaller in interface DomHandler<Element,DOMResult>
        Parameters:
        errorHandler - if any error happens between the invocation of this method and the invocation of DomHandler.getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • getElement

        public Element getElement(DOMResult r)
        Description copied from interface: DomHandler
        Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

        Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

        Specified by:
        getElement in interface DomHandler<Element,DOMResult>
        Parameters:
        r - The Result object created by DomHandler.createUnmarshaller(ValidationEventHandler).
        Returns:
        null if the operation fails. The error must have been reported to the error handler.

      • marshal

        public Source marshal(Element element,
                      ValidationEventHandler errorHandler)
        Description copied from interface: DomHandler
        This method is called when a JAXB provider needs to marshal an element to XML.

        If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

        Specified by:
        marshal in interface DomHandler<Element,DOMResult>
        errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
        Returns:
        null if there was an error. The error should have been reported to the handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAccessOrder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.bind.annotation

Enum XmlAccessOrder

  • java.lang.Object
    • java.lang.Enum<XmlAccessOrder>
      • javax.xml.bind.annotation.XmlAccessOrder
  • All Implemented Interfaces:
    Serializable, Comparable<XmlAccessOrder>

    public enum XmlAccessOrder
extends Enum<XmlAccessOrder>
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    Since:
    JAXB2.0
    See Also:
    XmlAccessorOrder

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALPHABETICAL
      The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).
      UNDEFINED
      The ordering of fields and properties in a class is undefined.

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static XmlAccessOrder valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessOrder[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNDEFINED

        public static final XmlAccessOrder UNDEFINED
        The ordering of fields and properties in a class is undefined.

      • ALPHABETICAL

        public static final XmlAccessOrder ALPHABETICAL
        The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).

    • Method Detail

      • values

        public static XmlAccessOrder[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlAccessOrder c : XmlAccessOrder.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlAccessOrder valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAccessorOrder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlAccessorOrder

  • @Inherited
 @Retention(value=RUNTIME)
 @Target(value={PACKAGE,TYPE})
public @interface XmlAccessorOrder

    Controls the ordering of fields and properties in a class.

    Usage

    @XmlAccessorOrder annotation can be used with the following program elements:

    • package
    • a top level class

    See "Package Specification" in javax.xml.bind package javadoc for additional common information.

    The effective XmlAccessOrder on a class is determined as follows:

    • If there is a @XmlAccessorOrder on a class, then it is used.
    • Otherwise, if a @XmlAccessorOrder exists on one of its super classes, then it is inherited (by the virtue of Inherited)
    • Otherwise, the @XmlAccessorOrder on the package of the class is used, if it's there.
    • Otherwise XmlAccessOrder.UNDEFINED.

    This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

    Since:
    JAXB2.0
    See Also:
    XmlAccessOrder

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      XmlAccessOrder value

    • Element Detail

      • value

        public abstract XmlAccessOrder value
        Default:
        javax.xml.bind.annotation.XmlAccessOrder.UNDEFINED
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAccessorType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlAccessorType

  • @Inherited
 @Retention(value=RUNTIME)
 @Target(value={PACKAGE,TYPE})
public @interface XmlAccessorType

    Controls whether fields or Javabean properties are serialized by default.

    Usage

    @XmlAccessorType annotation can be used with the following program elements:

    • package
    • a top level class

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    This annotation provides control over the default serialization of properties and fields in a class.

    The annotation @XmlAccessorType on a package applies to all classes in the package. The following inheritance semantics apply:

    • If there is a @XmlAccessorType on a class, then it is used.
    • Otherwise, if a @XmlAccessorType exists on one of its super classes, then it is inherited.
    • Otherwise, the @XmlAccessorType on a package is inherited.

    Defaulting Rules:

    By default, if @XmlAccessorType on a package is absent, then the following package level annotation is assumed.

       @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

    By default, if @XmlAccessorType on a class is absent, and none of its super classes is annotated with @XmlAccessorType, then the following default on the class is assumed:

       @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

    This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorOrder, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

    Since:
    JAXB2.0
    See Also:
    XmlAccessType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      XmlAccessType value
      Specifies whether fields or properties are serialized.

    • Element Detail

      • value

        public abstract XmlAccessType value
        Specifies whether fields or properties are serialized.
        See Also:
        XmlAccessType
        Default:
        javax.xml.bind.annotation.XmlAccessType.PUBLIC_MEMBER
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAccessType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.bind.annotation

Enum XmlAccessType

  • java.lang.Object
    • java.lang.Enum<XmlAccessType>
      • javax.xml.bind.annotation.XmlAccessType
  • All Implemented Interfaces:
    Serializable, Comparable<XmlAccessType>

    public enum XmlAccessType
extends Enum<XmlAccessType>
    Used by XmlAccessorType to control serialization of fields or properties.
    Since:
    JAXB2.0
    See Also:
    XmlAccessorType

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      FIELD
      Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
      NONE
      None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.
      PROPERTY
      Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
      PUBLIC_MEMBER
      Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient.

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static XmlAccessType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PROPERTY

        public static final XmlAccessType PROPERTY
        Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Fields are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

      • FIELD

        public static final XmlAccessType FIELD
        Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Getter/setter pairs are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

      • PUBLIC_MEMBER

        public static final XmlAccessType PUBLIC_MEMBER
        Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient. Fields or getter/setter pairs that are private, protected, or defaulted to package-only access are bound to XML only when they are explicitly annotated by the appropriate JAXB annotations.

      • NONE

        public static final XmlAccessType NONE
        None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.

    • Method Detail

      • values

        public static XmlAccessType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlAccessType c : XmlAccessType.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlAccessType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAnyAttribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlAnyAttribute

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlAnyAttribute

    Maps a JavaBean property to a map of wildcard attributes.

    Usage

    The @XmlAnyAttribute annotation can be used with the following program elements:

    • JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • At most one field or property in a class can be annotated with @XmlAnyAttribute.
    • The type of the property or the field must java.util.Map

    While processing attributes to be unmarshalled into a value class, each attribute that is not statically associated with another JavaBean property, via XmlAttribute, is entered into the wildcard attribute map represented by Map<QName,Object>. The attribute QName is the map's key. The key's value is the String value of the attribute.

    Since:
    JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAnyElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlAnyElement

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlAnyElement
    Maps a JavaBean property to XML infoset representation and/or JAXB element.

    This annotation serves as a "catch-all" property while unmarshalling xml content into a instance of a JAXB annotated class. It typically annotates a multi-valued JavaBean property, but it can occur on single value JavaBean property. During unmarshalling, each xml element that does not match a static @XmlElement or @XmlElementRef annotation for the other JavaBean properties on the class, is added to this "catch-all" property.

    Usages:

     @XmlAnyElement
 public Element[] others;

 // Collection of Element or JAXB elements.
 @XmlAnyElement(lax="true")
 public Object[] others;

 @XmlAnyElement
 private List<Element> nodes;

 @XmlAnyElement
 private Element node;

    Restriction usage constraints

    This annotation is mutually exclusive with XmlElement, XmlAttribute, XmlValue, XmlElements, XmlID, and XmlIDREF.

    There can be only one XmlAnyElement annotated JavaBean property in a class and its super classes.

    Relationship to other annotations

    This annotation can be used with XmlJavaTypeAdapter, so that users can map their own data structure to DOM, which in turn can be composed into XML.

    This annotation can be used with XmlMixed like this:

     // List of java.lang.String or DOM nodes.
 @XmlAnyElement @XmlMixed
 List<Object> others;

    Schema To Java example

    The following schema would produce the following Java class:
     <xs:complexType name="foo">
   <xs:sequence>
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
   </xs:sequence>
 </xs:complexType>

     class Foo {
   int a;
   int b;
   @XmlAnyElement
   List<Element> any;
 }
    It can unmarshal instances like
     <foo xmlns:e="extra">
   <a>1
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3
   <e:other />
   <c>5     // this will be bound to DOM, because the annotation doesn't remember namespaces.
 </foo>
    The following schema would produce the following Java class:
     <xs:complexType name="bar">
   <xs:complexContent>
   <xs:extension base="foo">
     <xs:sequence>
       <xs:element name="c" type="xs:int" />
       <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
     </xs:sequence>
   </xs:extension>
 </xs:complexType>

     class Bar extends Foo {
   int c;
   // Foo.getAny() also represents wildcard content for type definition bar.
 }
    It can unmarshal instances like
     <bar xmlns:e="extra">
   <a>1
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3
   <e:other />
   <c>5     // this now goes to Bar.c
   <e:other />  // this will go to Foo.any
 </bar>

    Using XmlAnyElement with XmlElementRef

    The XmlAnyElement annotation can be used with XmlElementRefs to designate additional elements that can participate in the content tree.

    The following schema would produce the following Java class:

     <xs:complexType name="foo">
   <xs:choice maxOccurs="unbounded" minOccurs="0">
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" />
   </xs:choice>
 </xs:complexType>

     class Foo {
   @XmlAnyElement(lax="true")
   @XmlElementRefs({
     @XmlElementRef(name="a", type="JAXBElement.class")
     @XmlElementRef(name="b", type="JAXBElement.class")
   })
   List<Object> others;
 }

 @XmlRegistry
 class ObjectFactory {
   ...
   @XmlElementDecl(name = "a", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooA( Integer i ) { ... }

   @XmlElementDecl(name = "b", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooB( Integer i ) { ... }
    It can unmarshal instances like
     <foo xmlns:e="extra">
   <a>1     // this will unmarshal to a JAXBElement instance whose value is 1.
   <e:other />  // this will unmarshal to a DOM Element.
   <b>3     // this will unmarshal to a JAXBElement instance whose value is 1.
 </foo>

    W3C XML Schema "lax" wildcard emulation

    The lax element of the annotation enables the emulation of the "lax" wildcard semantics. For example, when the Java source code is annotated like this:
     @XmlRootElement
 class Foo {
   @XmlAnyElement(lax=true)
   public Object[] others;
 }
    then the following document will unmarshal like this:
     <foo>
   <unknown />
   <foo />
 </foo>

 Foo foo = unmarshal();
 // 1 for 'unknown', another for 'foo'
 assert foo.others.length==2;
 // 'unknown' unmarshals to a DOM element
 assert foo.others[0] instanceof Element;
 // because of lax=true, the 'foo' element eagerly
 // unmarshals to a Foo object.
 assert foo.others[1] instanceof Foo;
    Since:
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean lax
      Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.
      Class<? extends DomHandler> value
      Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.

    • Element Detail

      • lax

        public abstract boolean lax
        Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.

        When false

        If false, all the elements that match the property will be unmarshalled to DOM, and the property will only contain DOM elements.

        When true

        If true, when an element matches a property marked with XmlAnyElement is known to JAXBContext (for example, there's a class with XmlRootElement that has the same tag name, or there's XmlElementDecl that has the same tag name), the unmarshaller will eagerly unmarshal this element to the JAXB object, instead of unmarshalling it to DOM. Additionally, if the element is unknown but it has a known xsi:type, the unmarshaller eagerly unmarshals the element to a JAXBElement, with the unknown element name and the JAXBElement value is set to an instance of the JAXB mapping of the known xsi:type.

        As a result, after the unmarshalling, the property can become heterogeneous; it can have both DOM nodes and some JAXB objects at the same time.

        This can be used to emulate the "lax" wildcard semantics of the W3C XML Schema.

        Default:
        false

      • value

        public abstract Class<? extends DomHandler> value
        Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.
        Default:
        javax.xml.bind.annotation.W3CDomHandler.class
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAttachmentRef (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlAttachmentRef

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlAttachmentRef
    Marks a field/property that its XML form is a uri reference to mime content. The mime content is optimally stored out-of-line as an attachment. A field/property must always map to the DataHandler class.

    Usage

     @XmlRootElement
 class Foo {
   @XmlAttachmentRef
   @XmlAttribute
   DataHandler data;

   @XmlAttachmentRef
   @XmlElement
   DataHandler body;
 }
    The above code maps to the following XML:
     <xs:element name="foo" xmlns:ref="http://ws-i.org/profiles/basic/1.1/xsd">
   <xs:complexType>
     <xs:sequence>
       <xs:element name="body" type="ref:swaRef" minOccurs="0" />
     </xs:sequence>
     <xs:attribute name="data" type="ref:swaRef" use="optional" />
   </xs:complexType>
 </xs:element>

    The above binding supports WS-I AP 1.0 WS-I Attachments Profile Version 1.0.

    Since:
    JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAttribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlAttribute

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlAttribute

    Maps a JavaBean property to a XML attribute.

    Usage

    The @XmlAttribute annotation can be used with the following program elements:

    • JavaBean property
    • field

    A static final field is mapped to a XML fixed attribute.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • If type of the field or the property is a collection type, then the collection item type must be mapped to schema simple type.
           // Examples
     @XmlAttribute List<Integer> items; //legal
     @XmlAttribute List<Bar> foo; // illegal if Bar does not map to a schema simple type
    • If the type of the field or the property is a non collection type, then the type of the property or field must map to a simple schema type.
           // Examples
     @XmlAttribute int foo; // legal
     @XmlAttribute Foo foo; // illegal if Foo does not map to a schema simple type
    • This annotation can be used with the following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlJavaTypeAdapter.

    Example 1: Map a JavaBean property to an XML attribute.

         //Example: Code fragment
     public class USPrice {
         @XmlAttribute
         public java.math.BigDecimal getPrice() {...} ;
         public void setPrice(java.math.BigDecimal ) {...};
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="USPrice">
       <xs:sequence>
       </xs:sequence>
       <xs:attribute name="price" type="xs:decimal"/>
     </xs:complexType>

    Example 2: Map a JavaBean property to an XML attribute with anonymous type.

    See Example 7 in @XmlType.

    Example 3: Map a JavaBean collection property to an XML attribute.

         // Example: Code fragment
     class Foo {
         ...
         @XmlAttribute List<Integer> items;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="foo">
       ...
       <xs:attribute name="items">
         <xs:simpleType>
           <xs:list itemType="xs:int"/>
         </xs:simpleType>
     </xs:complexType>
    Since:
    JAXB2.0
    See Also:
    XmlType

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      Name of the XML Schema attribute.
      String namespace
      Specifies the XML target namespace of the XML Schema attribute.
      boolean required
      Specifies if the XML Schema attribute is optional or required.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema attribute. By default, the XML Schema attribute name is derived from the JavaBean property name.
        Default:
        "##default"

      • required

        public abstract boolean required
        Specifies if the XML Schema attribute is optional or required. If true, then the JavaBean property is mapped to a XML Schema attribute that is required. Otherwise it is mapped to a XML Schema attribute that is optional.
        Default:
        false

      • namespace

        public abstract String namespace
        Specifies the XML target namespace of the XML Schema attribute.
        Default:
        "##default"
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElement.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlElement.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElement.DEFAULT
  • Enclosing class:
    XmlElement

    public static final class XmlElement.DEFAULT
extends Object
    Used in XmlElement.type() to signal that the type be inferred from the signature of the property.

    • Constructor Summary

      Constructors
      Constructor and Description
      DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DEFAULT

        public DEFAULT()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlElement

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlElement
    Maps a JavaBean property to a XML element derived from property name.

    Usage

    @XmlElement annotation can be used with the following program elements:

    • a JavaBean property
    • non static, non transient field
    • within XmlElements

    The usage is subject to the following constraints:
    • This annotation can be used with following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlElementWrapper, XmlJavaTypeAdapter
    • if the type of JavaBean property is a collection type of array, an indexed property, or a parameterized list, and this annotation is used with XmlElements then, @XmlElement.type() must be DEFAULT.class since the collection item type is already known.

    A JavaBean property, when annotated with @XmlElement annotation is mapped to a local element in the XML Schema complex type to which the containing class is mapped.

    Example 1: Map a public non static non final field to local element

         //Example: Code fragment
     public class USPrice {
         @XmlElement(name="itemprice")
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="itemprice" type="xs:decimal" minOccurs="0"/>
       </sequence>
     </xs:complexType>

    Example 2: Map a field to a nillable element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="0"/>
       </sequence>
     </xs:complexType>

    Example 3: Map a field to a nillable, required element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true, required=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="1"/>
       </sequence>
     </xs:complexType>

    Example 4: Map a JavaBean property to an XML element with anonymous type.

    See Example 6 in @XmlType.

    Since:
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String defaultValue
      Default value of this element.
      String name
      Name of the XML Schema element.
      String namespace
      XML target namespace of the XML Schema element.
      boolean nillable
      Customize the element declaration to be nillable.
      boolean required
      Customize the element declaration to be required.
      Class type
      The Java class being referenced.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema element.

        If the value is "##default", then element name is derived from the JavaBean property name.

        Default:
        "##default"

      • nillable

        public abstract boolean nillable
        Customize the element declaration to be nillable.

        If nillable() is true, then the JavaBean property is mapped to a XML Schema nillable element declaration.

        Default:
        false

      • required

        public abstract boolean required
        Customize the element declaration to be required.

        If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        Default:
        false

      • namespace

        public abstract String namespace
        XML target namespace of the XML Schema element.

        If the value is "##default", then the namespace is determined as follows:

        1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
        2. Otherwise '' (which produces unqualified element in the default namespace.
        Default:
        "##default"

      • defaultValue

        public abstract String defaultValue
        Default value of this element.

        The

        ''
        value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.
        Default:
        "\u0000"

      • type

        public abstract Class type
        The Java class being referenced.
        Default:
        javax.xml.bind.annotation.XmlElement.DEFAULT.class
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElementDecl.GLOBAL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlElementDecl.GLOBAL

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
  • Enclosing class:
    XmlElementDecl

    public static final class XmlElementDecl.GLOBAL
extends Object
    Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.

    • Constructor Summary

      Constructors
      Constructor and Description
      GLOBAL()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • GLOBAL

        public GLOBAL()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElementDecl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementDecl

  • @Retention(value=RUNTIME)
 @Target(value=METHOD)
public @interface XmlElementDecl
    Maps a factory method to a XML element.

    Usage

    The annotation creates a mapping between an XML schema element declaration and a element factory method that returns a JAXBElement instance representing the element declaration. Typically, the element factory method is generated (and annotated) from a schema into the ObjectFactory class in a Java package that represents the binding of the element declaration's target namespace. Thus, while the annotation syntax allows @XmlElementDecl to be used on any method, semantically its use is restricted to annotation of element factory method. The usage is subject to the following constraints:
    • The class containing the element factory method annotated with @XmlElementDecl must be marked with XmlRegistry.
    • The element factory method must take one parameter assignable to Object.

    Example 1: Annotation on a factory method

         // Example: code fragment
     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="foo")
         JAXBElement<String> createFoo(String s) { ... }
     }

         <!-- XML input -->
       <foo>string

     // Example: code fragment corresponding to XML input
     JAXBElement o =
     (JAXBElement)unmarshaller.unmarshal(aboveDocument);
     // print JAXBElement instance to show values
     System.out.println(o.getName());   // prints  "{}foo"
     System.out.println(o.getValue());  // prints  "string"
     System.out.println(o.getValue().getClass()); // prints "java.lang.String"

     <!-- Example: XML schema definition -->
     <xs:element name="foo" type="xs:string"/>

    Example 2: Element declaration with non local scope

    The following example illustrates the use of scope annotation parameter in binding of element declaration in schema derived code.

    The following example may be replaced in a future revision of this javadoc.

         <!-- Example: XML schema definition -->
     <xs:schema>
       <xs:complexType name="pea">
         <xs:choice maxOccurs="unbounded">
           <xs:element name="foo" type="xs:string"/>
           <xs:element name="bar" type="xs:string"/>
         </xs:choice>
       </xs:complexType>
       <xs:element name="foo" type="xs:int"/>
     </xs:schema>

         // Example: expected default binding
     class Pea {
         @XmlElementRefs({
             @XmlElementRef(name="foo",type=JAXBElement.class)
             @XmlElementRef(name="bar",type=JAXBElement.class)
         })
         List<JAXBElement<String>> fooOrBar;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(scope=Pea.class,name="foo")
         JAXBElement createPeaFoo(String s);

         @XmlElementDecl(scope=Pea.class,name="bar")
         JAXBElement createPeaBar(String s);

         @XmlElementDecl(name="foo")
         JAXBElement createFoo(Integer i);
     }
    Without scope createFoo and createPeaFoo would become ambiguous since both of them map to a XML schema element with the same local name "foo".
    Since:
    JAXB 2.0
    See Also:
    XmlRegistry

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name
      local name of the XML element.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String defaultValue
      Default value of this element.
      String namespace
      namespace name of the XML element.
      Class scope
      scope of the mapping.
      String substitutionHeadName
      XML local name of a substitution group's head element.
      String substitutionHeadNamespace
      namespace name of a substitution group's head XML element.

    • Element Detail

      • name

        public abstract String name
        local name of the XML element.

        Note to reviewers: There is no default name; since the annotation is on a factory method, it is not clear that the method name can be derived from the factory method name.

        See Also:
        namespace()

      • scope

        public abstract Class scope
        scope of the mapping.

        If this is not XmlElementDecl.GLOBAL, then this element declaration mapping is only active within the specified class.

        Default:
        javax.xml.bind.annotation.XmlElementDecl.GLOBAL.class

      • namespace

        public abstract String namespace
        namespace name of the XML element.

        If the value is "##default", then the value is the namespace name for the package of the class containing this factory method.

        See Also:
        name()
        Default:
        "##default"

      • substitutionHeadNamespace

        public abstract String substitutionHeadNamespace
        namespace name of a substitution group's head XML element.

        This specifies the namespace name of the XML element whose local name is specified by substitutionHeadName().

        If susbtitutionHeadName() is "", then this value can only be "##default". But the value is ignored since since this element is not part of susbtitution group when the value of susbstitutionHeadName() is "".

        If susbtitutionHeadName() is not "" and the value is "##default", then the namespace name is the namespace name to which the package of the containing class, marked with XmlRegistry, is mapped.

        If susbtitutionHeadName() is not "" and the value is not "##default", then the value is the namespace name.

        See Also:
        substitutionHeadName()
        Default:
        "##default"

      • substitutionHeadName

        public abstract String substitutionHeadName
        XML local name of a substitution group's head element.

        If the value is "", then this element is not part of any substitution group.

        See Also:
        substitutionHeadNamespace()
        Default:
        ""

      • defaultValue

        public abstract String defaultValue
        Default value of this element.

        The

        ''
        value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.
        Default:
        "\u0000"
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElementRef.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlElementRef.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
  • Enclosing class:
    XmlElementRef

    public static final class XmlElementRef.DEFAULT
extends Object
    Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.

    • Constructor Summary

      Constructors
      Constructor and Description
      DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DEFAULT

        public DEFAULT()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElementRef (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementRef

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlElementRef

    Maps a JavaBean property to a XML element derived from property's type.

    Usage

    @XmlElementRef annotation can be used with a JavaBean property or from within XmlElementRefs

    This annotation dynamically associates an XML element name with the JavaBean property. When a JavaBean property is annotated with XmlElement, the XML element name is statically derived from the JavaBean property name. However, when this annotation is used, the XML element name is derived from the instance of the type of the JavaBean property at runtime.

    XML Schema substitution group support

    XML Schema allows a XML document author to use XML element names that were not statically specified in the content model of a schema using substitution groups. Schema derived code provides support for substitution groups using an element property, (section 5.5.5, "Element Property" of JAXB 2.0 specification). An element property method signature is of the form:
         public void setTerm(JAXBElement);
     public JAXBElement getTerm();

    An element factory method annotated with XmlElementDecl is used to create a JAXBElement instance, containing an XML element name. The presence of @XmlElementRef annotation on an element property indicates that the element name from JAXBElement instance be used instead of deriving an XML element name from the JavaBean property name.

    The usage is subject to the following constraints:

    • If the collection item type (for collection property) or property type (for single valued property) is JAXBElement, then @XmlElementRef}.name() and @XmlElementRef.namespace() must point an element factory method with an @XmlElementDecl annotation in a class annotated with @XmlRegistry (usually ObjectFactory class generated by the schema compiler) :
      • @XmlElementDecl.name() must equal @XmlElementRef.name()
      • @XmlElementDecl.namespace() must equal @XmlElementRef.namespace().
    • If the collection item type (for collection property) or property type (for single valued property) is not JAXBElement, then the type referenced by the property or field must be annotated with XmlRootElement.
    • This annotation can be used with the following annotations: XmlElementWrapper, XmlJavaTypeAdapter.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example 1: Ant Task Example

    The following Java class hierarchy models an Ant build script. An Ant task corresponds to a class in the class hierarchy. The XML element name of an Ant task is indicated by the @XmlRootElement annotation on its corresponding class.
         @XmlRootElement(name="target")
     class Target {
         // The presence of @XmlElementRef indicates that the XML
         // element name will be derived from the @XmlRootElement
         // annotation on the type (for e.g. "jar" for JarTask).
         @XmlElementRef
         List<Task> tasks;
     }

     abstract class Task {
     }

     @XmlRootElement(name="jar")
     class JarTask extends Task {
         ...
     }

     @XmlRootElement(name="javac")
     class JavacTask extends Task {
         ...
     }

     <!-- XML Schema fragment -->
     <xs:element name="target" type="Target">
     <xs:complexType name="Target">
       <xs:sequence>
         <xs:choice maxOccurs="unbounded">
           <xs:element ref="jar">
           <xs:element ref="javac">
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

    Thus the following code fragment:

         Target target = new Target();
     target.tasks.add(new JarTask());
     target.tasks.add(new JavacTask());
     marshal(target);
    will produce the following XML output:
         <target>
       <jar>
         ....
       </jar>
       <javac>
         ....
       </javac>
     </target>

    It is not an error to have a class that extends Task that doesn't have XmlRootElement. But they can't show up in an XML instance (because they don't have XML element names).

    Example 2: XML Schema Susbstitution group support

    The following example shows the annotations for XML Schema substitution groups. The annotations and the ObjectFactory are derived from the schema.

         @XmlElement
     class Math {
         //  The value of type()is
         //  JAXBElement.class , which indicates the XML
         //  element name ObjectFactory - in general a class marked
         //  with @XmlRegistry. (See ObjectFactory below)
         //
         //  The name() is "operator", a pointer to a
         // factory method annotated with a
         //  XmlElementDecl with the name "operator". Since
         //  "operator" is the head of a substitution group that
         //  contains elements "add" and "sub" elements, "operator"
         //  element can be substituted in an instance document by
         //  elements "add" or "sub". At runtime, JAXBElement
         //  instance contains the element name that has been
         //  substituted in the XML document.
         //
         @XmlElementRef(type=JAXBElement.class,name="operator")
         JAXBElement<? extends Operator> term;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="operator")
         JAXBElement<Operator> createOperator(Operator o) {...}
         @XmlElementDecl(name="add",substitutionHeadName="operator")
         JAXBElement<Operator> createAdd(Operator o) {...}
         @XmlElementDecl(name="sub",substitutionHeadName="operator")
         JAXBElement<Operator> createSub(Operator o) {...}
     }

     class Operator {
         ...
     }

    Thus, the following code fragment

         Math m = new Math();
     m.term = new ObjectFactory().createAdd(new Operator());
     marshal(m);
    will produce the following XML output:
         <math>
       <add>...</add>
     </math>
    Since:
    JAXB2.0
    See Also:
    XmlElementRefs

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      String namespace
      This parameter and name() are used to determine the XML element for the JavaBean property.
      boolean required
      Customize the element declaration to be required.
      Class type
      The Java type being referenced.

    • Element Detail

      • type

        public abstract Class type
        The Java type being referenced.

        If the value is DEFAULT.class, the type is inferred from the the type of the JavaBean property.

        Default:
        javax.xml.bind.annotation.XmlElementRef.DEFAULT.class

      • namespace

        public abstract String namespace
        This parameter and name() are used to determine the XML element for the JavaBean property.

        If type() is JAXBElement.class , then namespace() and name() point to a factory method with XmlElementDecl. The XML element name is the element name from the factory method's XmlElementDecl annotation or if an element from its substitution group (of which it is a head element) has been substituted in the XML document, then the element name is from the XmlElementDecl on the substituted element.

        If type() is not JAXBElement.class, then the XML element name is the XML element name statically associated with the type using the annotation XmlRootElement on the type. If the type is not annotated with an XmlElementDecl, then it is an error.

        If type() is not JAXBElement.class, then this value must be "".

        Default:
        ""

      • name

        public abstract String name
        See Also:
        namespace()
        Default:
        "##default"

      • required

        public abstract boolean required
        Customize the element declaration to be required.

        If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        For compatibility with JAXB 2.1, this property defaults to true, despite the fact that XmlElement.required() defaults to false.

        Since:
        2.2
        Default:
        true
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElementRefs (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementRefs

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlElementRefs
    Marks a property that refers to classes with XmlElement or JAXBElement.

    Compared to an element property (property with XmlElement annotation), a reference property has a different substitution semantics. When a sub-class is assigned to a property, an element property produces the same tag name with @xsi:type, whereas a reference property produces a different tag name (the tag name that's on the the sub-class.)

    This annotation can be used with the following annotations: XmlJavaTypeAdapter, XmlElementWrapper.

    Since:
    JAXB2.0
    See Also:
    XmlElementWrapper, XmlElementRef

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlElementRef[] value

    • Element Detail

      • value

        public abstract XmlElementRef[] value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElements (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlElements

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlElements

    A container for multiple @XmlElement annotations. Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlElements as follows:

     @XmlElements({ @XmlElement(...),@XmlElement(...) })

    The @XmlElements annnotation can be used with the following program elements:

    • a JavaBean property
    • non static, non transient field
    This annotation is intended for annotation a JavaBean collection property (e.g. List).

    Usage

    The usage is subject to the following constraints:

    • This annotation can be used with the following annotations: @XmlIDREF, @XmlElementWrapper.
    • If @XmlIDREF is also specified on the JavaBean property, then each @XmlElement.type() must contain a JavaBean property annotated with @XmlID.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example 1: Map to a list of elements

    // Mapped code fragment
    public class Foo {
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
         }
         public List items;
    }

    <!-- XML Representation for a List of {1,2.5}
            XML output is not wrapped using another element -->
    ...
    <A> 1 </A>
    <B> 2.5 </B>
    ...

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:choice minOccurs="0" maxOccurs="unbounded">
          <xs:element name="A" type="xs:int"/>
          <xs:element name="B" type="xs:float"/>
        <xs:choice>
      </xs:sequence>
    </xs:complexType>

    Example 2: Map to a list of elements wrapped with another element

    // Mapped code fragment
    public class Foo {
        @XmlElementWrapper(name="bar")
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
        }
        public List items;
    }

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="xs:int"/>
              <xs:element name="B" type="xs:float"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

    Example 3: Change element name based on type using an adapter.

        class Foo {
       @XmlJavaTypeAdapter(QtoPAdapter.class)
       @XmlElements({
           @XmlElement(name="A",type=PX.class),
           @XmlElement(name="B",type=PY.class)
       })
       Q bar;
    }

    @XmlType abstract class P {...}
    @XmlType(name="PX") class PX extends P {...}
    @XmlType(name="PY") class PY extends P {...}

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="PX"/>
              <xs:element name="B" type="PY"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>
    Since:
    JAXB2.0
    See Also:
    XmlElement, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlElement[] value
      Collection of @XmlElement annotations

    • Element Detail

      • value

        public abstract XmlElement[] value
        Collection of @XmlElement annotations
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlElementWrapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementWrapper

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlElementWrapper
    Generates a wrapper element around XML representation. This is primarily intended to be used to produce a wrapper XML element around collections. The annotation therefore supports two forms of serialization shown below.
        //Example: code fragment
      int[] names;

    // XML Serialization Form 1 (Unwrapped collection)
    <names> ... </names>
    <names> ... </names>

    // XML Serialization Form 2 ( Wrapped collection )
    <wrapperElement>
       <names> value-of-item </names>
       <names> value-of-item </names>
       ....
    </wrapperElement>

    The two serialized XML forms allow a null collection to be represented either by absence or presence of an element with a nillable attribute.

    Usage

    The @XmlElementWrapper annotation can be used with the following program elements:

    • JavaBean property
    • non static, non transient field

    The usage is subject to the following constraints:

    • The property must be a collection property
    • This annotation can be used with the following annotations: XmlElement, XmlElements, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    See Also:
    XmlElement, XmlElements, XmlElementRef, XmlElementRefs

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      Name of the XML wrapper element.
      String namespace
      XML target namespace of the XML wrapper element.
      boolean nillable
      If true, the absence of the collection is represented by using xsi:nil='true'.
      boolean required
      Customize the wrapper element declaration to be required.

    • Element Detail

      • name

        public abstract String name
        Name of the XML wrapper element. By default, the XML wrapper element name is derived from the JavaBean property name.
        Default:
        "##default"

      • namespace

        public abstract String namespace
        XML target namespace of the XML wrapper element.

        If the value is "##default", then the namespace is determined as follows:

        1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
        2. Otherwise "" (which produces unqualified element in the default namespace.
        Default:
        "##default"

      • nillable

        public abstract boolean nillable
        If true, the absence of the collection is represented by using xsi:nil='true'. Otherwise, it is represented by the absence of the element.
        Default:
        false

      • required

        public abstract boolean required
        Customize the wrapper element declaration to be required.

        If required() is true, then the corresponding generated XML schema element declaration will have minOccurs="1", to indicate that the wrapper element is always expected.

        Note that this only affects the schema generation, and not the unmarshalling or marshalling capability. This is simply a mechanism to let users express their application constraints better.

        Since:
        JAXB 2.1
        Default:
        false
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlEnum (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlEnum

  • @Retention(value=RUNTIME)
 @Target(value=TYPE)
public @interface XmlEnum

    Maps an enum type Enum to XML representation.

    This annotation, together with XmlEnumValue provides a mapping of enum type to XML representation.

    Usage

    The @XmlEnum annotation can be used with the following program elements:

    • enum type

    The usage is subject to the following constraints:

    • This annotation can be used the following other annotations: XmlType, XmlRootElement

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information

    An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type to which @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value() .

    Examples: See examples in XmlEnumValue

    Since:
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class<?> value
      Java type that is mapped to a XML simple type.

    • Element Detail

      • value

        public abstract Class<?> value
        Java type that is mapped to a XML simple type.
        Default:
        java.lang.String.class
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlEnumValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlEnumValue

  • @Retention(value=RUNTIME)
 @Target(value=FIELD)
public @interface XmlEnumValue
    Maps an enum constant in Enum type to XML representation.

    Usage

    The @XmlEnumValue annotation can be used with the following program elements:

    • enum constant

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    This annotation, together with XmlEnum provides a mapping of enum type to XML representation.

    An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type specified in @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value()

    In the absence of this annotation, Enum.name() is used as the XML representation.

    Example 1: Map enum constant name -> enumeration facet

         //Example: Code fragment
     @XmlEnum(String.class)
     public enum Card { CLUBS, DIAMONDS, HEARTS, SPADES }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Card">
       <xs:restriction base="xs:string"/>
         <xs:enumeration value="CLUBS"/>
         <xs:enumeration value="DIAMONDS"/>
         <xs:enumeration value="HEARTS"/>
         <xs:enumeration value="SPADES"/>
     </xs:simpleType>

    Example 2: Map enum constant name(value) -> enumeration facet

         //Example: code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Coin {
         @XmlEnumValue("1") PENNY(1),
         @XmlEnumValue("5") NICKEL(5),
         @XmlEnumValue("10") DIME(10),
         @XmlEnumValue("25") QUARTER(25) }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Coin">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="5"/>
         <xs:enumeration value="10"/>
         <xs:enumeration value="25"/>
       </xs:restriction>
     </xs:simpleType>

    Example 3: Map enum constant name -> enumeration facet

         //Code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Code {
         @XmlEnumValue("1") ONE,
         @XmlEnumValue("2") TWO;
     }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Code">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="2"/>
       </xs:restriction>
     </xs:simpleType>
    Since:
    JAXB 2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value

    • Element Detail

      • value

        public abstract String value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlID

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlID

    Maps a JavaBean property to XML ID.

    To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

    Usage

    The @XmlID annotation can be used with the following program elements:
    • a JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • At most one field or property in a class can be annotated with @XmlID.
    • The JavaBean property's type must be java.lang.String.
    • The only other mapping annotations that can be used with @XmlID are:@XmlElement and @XmlAttribute.

    Example: Map a JavaBean property's type to xs:ID

        // Example: code fragment
    public class Customer {
        @XmlAttribute
        @XmlID
        public String getCustomerID();
        public void setCustomerID(String id);
        .... other properties not shown
    }

    <!-- Example: XML Schema fragment -->
    <xs:complexType name="Customer">
      <xs:complexContent>
        <xs:sequence>
          ....
        </xs:sequence>
        <xs:attribute name="customerID" type="xs:ID"/>
      </xs:complexContent>
    </xs:complexType>
    Since:
    JAXB2.0
    See Also:
    XmlIDREF
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlIDREF (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlIDREF

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlIDREF

    Maps a JavaBean property to XML IDREF.

    To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

    Usage

    The @XmlIDREF annotation can be used with the following program elements:
    • a JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:

    • If the type of the field or property is a collection type, then the collection item type must contain a property or field annotated with @XmlID.
    • If the field or property is single valued, then the type of the property or field must contain a property or field annotated with @XmlID.

      Note: If the collection item type or the type of the property (for non collection type) is java.lang.Object, then the instance must contain a property/field annotated with @XmlID attribute.

    • This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlList, and XmlElements.

    Example: Map a JavaBean property to xs:IDREF (i.e. by reference rather than by containment)

   //EXAMPLE: Code fragment
   public class Shipping {
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
       ....
    }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

    Example 2: The following is a complete example of containment versus reference.

        // By default, Customer maps to complex type xs:Customer
    public class Customer {

        // map JavaBean property type to xs:ID
        @XmlID public String getCustomerID();
        public void setCustomerID(String id);

        // .... other properties not shown
    }

   // By default, Invoice maps to a complex type xs:Invoice
   public class Invoice {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);

      // .... other properties not shown here
   }

   // By default, Shipping maps to complex type xs:Shipping
   public class Shipping {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
   }

   // at least one class must reference Customer by containment;
   // Customer instances won't be marshalled.
   @XmlElement(name="CustomerData")
   public class CustomerData {
       // map reference to Customer by containment by default.
       public Customer getCustomer();

       // maps reference to Shipping by containment by default.
       public Shipping getShipping();

       // maps reference to Invoice by containment by default.
       public Invoice getInvoice();
   }

   <!-- XML Schema mapping for above code frament -->

   <xs:complexType name="Invoice">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Customer">
     <xs:complexContent>
       <xs:sequence>
         ....
       </xs:sequence>
       <xs:attribute name="CustomerID" type="xs:ID"/>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="CustomerData">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:Customer"/>
         <xs:element name="shipping" type="xs:Shipping"/>
         <xs:element name="invoice"  type="xs:Invoice"/>
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:element name"customerData" type="xs:CustomerData"/>

   <!-- Instance document conforming to the above XML Schema -->
    <customerData>
       <customer customerID="Alice">
           ....
       </customer>

       <shipping customer="Alice">
           ....
       </shipping>

       <invoice customer="Alice">
           ....
       </invoice>
   </customerData>

    Example 3: Mapping List to repeating element of type IDREF

         // Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElement(name="Alice")
             public List customers;
     }

     <!-- XML schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

    Example 4: Mapping a List to a list of elements of type IDREF.

         //Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElements(
             @XmlElement(name="Alice", type="Customer.class")
              @XmlElement(name="John", type="InternationalCustomer.class")
         public List customers;
     }

     <!-- XML Schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
           <xs:element name="John" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>
    Since:
    JAXB2.0
    See Also:
    XmlID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlInlineBinaryData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlInlineBinaryData

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,TYPE})
public @interface XmlInlineBinaryData
    Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.

    When XOP encoding is enabled as described in AttachmentMarshaller.isXOPPackage(), this annotation disables datatypes such as Image or Source or byte[] that are bound to base64-encoded binary from being considered for XOP encoding. If a JAXB property is annotated with this annotation or if the JAXB property's base type is annotated with this annotation, neither AttachmentMarshaller.addMtomAttachment(DataHandler, String, String) nor AttachmentMarshaller.addMtomAttachment(byte[], int, int, String, String, String) is ever called for the property. The binary data will always be inlined.

    Since:
    JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlList

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlList
    Used to map a property to a list simple type.

    Usage

    The @XmlList annotation can be used with the following program elements:

    • JavaBean property
    • field

    When a collection property is annotated just with @XmlElement, each item in the collection will be wrapped by an element. For example,

     @XmlRootElement
 class Foo {
     @XmlElement
     List<String> data;
 }
    would produce XML like this:
     <foo>
   <data>abc
   <data>def
 </foo>
    @XmlList annotation, on the other hand, allows multiple values to be represented as whitespace-separated tokens in a single element. For example,
     @XmlRootElement
 class Foo {
     @XmlElement
     @XmlList
     List<String> data;
 }
    the above code will produce XML like this:
     <foo>
   <data>abc def
 </foo>

    This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlValue, XmlIDREF.

    • The use of @XmlList with XmlValue while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlValue would.
    • The use of @XmlList with XmlAttribute while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlAttribute would.
    Since:
    JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlMimeType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlMimeType

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlMimeType
    Associates the MIME type that controls the XML representation of the property.

    This annotation is used in conjunction with datatypes such as Image or Source that are bound to base64-encoded binary in XML.

    If a property that has this annotation has a sibling property bound to the xmime:contentType attribute, and if in the instance the property has a value, the value of the attribute takes precedence and that will control the marshalling.

    Since:
    JAXB2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String value
      The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.

    • Element Detail

      • value

        public abstract String value
        The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlMixed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlMixed

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlMixed

    Annotate a JavaBean multi-valued property to support mixed content.

    The usage is subject to the following constraints:

    • can be used with @XmlElementRef, @XmlElementRefs or @XmlAnyElement

    The following can be inserted into @XmlMixed annotated multi-valued property

    • XML text information items are added as values of java.lang.String.
    • Children element information items are added as instances of JAXBElement or instances with a class that is annotated with @XmlRootElement.
    • Unknown content that is not be bound to a JAXB mapped class is inserted as Element. (Assumes property annotated with @XmlAnyElement)
    Below is an example of binding and creation of mixed content.
      <!-- schema fragment having  mixed content -->
  <xs:complexType name="letterBody" mixed="true">
    <xs:sequence>
      <xs:element name="name" type="xs:string"/>
      <xs:element name="quantity" type="xs:positiveInteger"/>
      <xs:element name="productName" type="xs:string"/>
      <!-- etc. -->
    </xs:sequence>
  </xs:complexType>
  <xs:element name="letterBody" type="letterBody"/>

 // Schema-derived Java code:
 // (Only annotations relevant to mixed content are shown below,
 //  others are ommitted.)
 import java.math.BigInteger;
 public class ObjectFactory {
      // element instance factories
      JAXBElement<LetterBody> createLetterBody(LetterBody value);
      JAXBElement<String>     createLetterBodyName(String value);
      JAXBElement<BigInteger> createLetterBodyQuantity(BigInteger value);
      JAXBElement<String>     createLetterBodyProductName(String value);
      // type instance factory
      LetterBody> createLetterBody();
 }

     public class LetterBody {
      // Mixed content can contain instances of Element classes
      // Name, Quantity and ProductName. Text data is represented as
      // java.util.String for text.
      @XmlMixed
      @XmlElementRefs({
              @XmlElementRef(name="productName", type=JAXBElement.class),
              @XmlElementRef(name="quantity", type=JAXBElement.class),
              @XmlElementRef(name="name", type=JAXBElement.class)})
      List getContent(){...}
 }
    The following is an XML instance document with mixed content
     <letterBody>
 Dear Mr.<name>Robert Smith</name>
 Your order of <quantity>1</quantity> <productName>Baby
 Monitor</productName> shipped from our warehouse. ....
 </letterBody>
    that can be constructed using following JAXB API calls.
     LetterBody lb = ObjectFactory.createLetterBody();
 JAXBElement<LetterBody> lbe = ObjectFactory.createLetterBody(lb);
 List gcl = lb.getContent();  //add mixed content to general content property.
 gcl.add("Dear Mr.");  // add text information item as a String.

 // add child element information item
 gcl.add(ObjectFactory.createLetterBodyName("Robert Smith"));
 gcl.add("Your order of "); // add text information item as a String

 // add children element information items
 gcl.add(ObjectFactory.
                      createLetterBodyQuantity(new BigInteger("1")));
 gcl.add(ObjectFactory.createLetterBodyProductName("Baby Monitor"));
 gcl.add("shipped from our warehouse");  // add text information item

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlNs (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlNs

  • @Retention(value=RUNTIME)
 @Target(value={})
public @interface XmlNs

    Associates a namespace prefix with a XML namespace URI.

    Usage

    @XmlNs annotation is intended for use from other program annotations.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example:See XmlSchema annotation type for an example.

    Since:
    JAXB2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String namespaceURI
      Namespace URI
      String prefix
      Namespace prefix

    • Element Detail

      • prefix

        public abstract String prefix
        Namespace prefix

      • namespaceURI

        public abstract String namespaceURI
        Namespace URI
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlNsForm (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.bind.annotation

Enum XmlNsForm

  • java.lang.Object
    • java.lang.Enum<XmlNsForm>
      • javax.xml.bind.annotation.XmlNsForm
  • All Implemented Interfaces:
    Serializable, Comparable<XmlNsForm>

    public enum XmlNsForm
extends Enum<XmlNsForm>
    Enumeration of XML Schema namespace qualifications.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Usage

    The namespace qualification values are used in the annotations defined in this packge. The enumeration values are mapped as follows:

    Enum Value | XML Schema Value
    UNQUALIFIED | unqualified
    QUALIFIED | qualified
    UNSET | namespace qualification attribute is absent from the XML Schema fragment
    Since:
    JAXB2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      QUALIFIED
      UNQUALIFIED
      UNSET

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static XmlNsForm valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlNsForm[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNQUALIFIED

        public static final XmlNsForm UNQUALIFIED

      • QUALIFIED

        public static final XmlNsForm QUALIFIED

      • UNSET

        public static final XmlNsForm UNSET

    • Method Detail

      • values

        public static XmlNsForm[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlNsForm c : XmlNsForm.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlNsForm valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlRegistry (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlRegistry

  • @Retention(value=RUNTIME)
 @Target(value=TYPE)
public @interface XmlRegistry
    Marks a class that has XmlElementDecls.
    Since:
    JAXB 2.0
    See Also:
    XmlElementDecl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlRootElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlRootElement

  • @Retention(value=RUNTIME)
 @Target(value=TYPE)
public @interface XmlRootElement
    Maps a class or an enum type to an XML element.

    Usage

    The @XmlRootElement annotation can be used with the following program elements:

    • a top level class
    • an enum type

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    When a top level class or an enum type is annotated with the @XmlRootElement annotation, then its value is represented as XML element in an XML document.

    This annotation can be used with the following annotations: XmlType, XmlEnum, XmlAccessorType, XmlAccessorOrder.

    Example 1: Associate an element with XML Schema type

         // Example: Code fragment
     @XmlRootElement
     class Point {
        int x;
        int y;
        Point(int _x,int _y) {x=_x;y=_y;}
     }

         //Example: Code fragment corresponding to XML output
     marshal( new Point(3,5), System.out);

         <!-- Example: XML output -->
     <point>
       <x> 3
       <y> 5
     </point>
    The annotation causes an global element declaration to be produced in the schema. The global element declaration is associated with the XML schema type to which the class is mapped.
         <!-- Example: XML schema definition -->
     <xs:element name="point" type="point"/>
     <xs:complexType name="point">
       <xs:sequence>
         <xs:element name="x" type="xs:int"/>
         <xs:element name="y" type="xs:int"/>
       </xs:sequence>
     </xs:complexType>

    Example 2: Orthogonality to type inheritance

    An element declaration annotated on a type is not inherited by its derived types. The following example shows this.

         // Example: Code fragment
     @XmlRootElement
     class Point3D extends Point {
         int z;
         Point3D(int _x,int _y,int _z) {super(_x,_y);z=_z;}
     }

     //Example: Code fragment corresponding to XML output *
     marshal( new Point3D(3,5,0), System.out );

     <!-- Example: XML output -->
     <!-- The element name is point3D not point -->
     <point3D>
       <x>3</x>
       <y>5</y>
       <z>0</z>
     </point3D>

     <!-- Example: XML schema definition -->
     <xs:element name="point3D" type="point3D"/>
     <xs:complexType name="point3D">
       <xs:complexContent>
         <xs:extension base="point">
           <xs:sequence>
             <xs:element name="z" type="xs:int"/>
           </xs:sequence>
         </xs:extension>
       </xs:complexContent>
     </xs:complexType>
    Example 3: Associate a global element with XML Schema type to which the class is mapped.
         //Example: Code fragment
     @XmlRootElement(name="PriceElement")
     public class USPrice {
         @XmlElement
         public java.math.BigDecimal price;
     }

     <!-- Example: XML schema definition -->
     <xs:element name="PriceElement" type="USPrice"/>
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal"/>
       </sequence>
     </xs:complexType>
    Since:
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      local name of the XML element.
      String namespace
      namespace name of the XML element.

    • Element Detail

      • namespace

        public abstract String namespace
        namespace name of the XML element.

        If the value is "##default", then the XML namespace name is derived from the package of the class ( XmlSchema ). If the package is unnamed, then the XML namespace is the default empty namespace.

        Default:
        "##default"

      • name

        public abstract String name
        local name of the XML element.

        If the value is "##default", then the name is derived from the class name.

        Default:
        "##default"
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlSchema (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchema

  • @Retention(value=RUNTIME)
 @Target(value=PACKAGE)
public @interface XmlSchema

    Maps a package name to a XML namespace.

    Usage

    The XmlSchema annotation can be used with the following program elements:

    • package

    This is a package level annotation and follows the recommendations and restrictions contained in JSR 175, section III, "Annotations". Thus the usage is subject to the following constraints and recommendations.

    • There can only be one package declaration as noted in JSR 175, section III, "Annotations".
    • JSR 175 recommends package-info.java for package level annotations. JAXB Providers that follow this recommendation will allow the package level annotations to be defined in package-info.java.

    Example 1: Customize name of XML namespace to which package is mapped.

        @javax.xml.bind.annotation.XmlSchema (
      namespace = "http://www.example.com/MYPO1"
    )

    <!-- XML Schema fragment -->
    <schema
      xmlns=...
      xmlns:po=....
      targetNamespace="http://www.example.com/MYPO1"
    >
    <!-- prefixes generated by default are implementation
            depedenent -->

    Example 2: Customize namespace prefix, namespace URI mapping

        // Package level annotation
    @javax.xml.bind.annotation.XmlSchema (
      xmlns = {
        @javax.xml.bind.annotation.XmlNs(prefix = "po",
                   namespaceURI="http://www.example.com/myPO1"),

        @javax.xml.bind.annotation.XmlNs(prefix="xs",
                   namespaceURI="http://www.w3.org/2001/XMLSchema")
      )
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns:xs="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        targetNamespace="http://www.example.com/PO1">

    Example 3: Customize elementFormDefault

        @javax.xml.bind.annotation.XmlSchema (
      elementFormDefault=XmlNsForm.UNQUALIFIED
      ...
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        elementFormDefault="unqualified">
    Since:
    JAXB2.0

    • Field Summary

      Fields
      Modifier and Type Fields and Description
      static String NO_LOCATION
      The default value of the location() attribute, which indicates that the schema generator will generate components in this namespace.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      XmlNsForm attributeFormDefault
      Namespace qualification for attributes.
      XmlNsForm elementFormDefault
      Namespace qualification for elements.
      String location
      Indicates that this namespace (specified by namespace()) has a schema already available exeternally, available at this location.
      String namespace
      Name of the XML namespace.
      XmlNs[] xmlns
      Customize the namespace URI, prefix associations.

    • Field Detail

      • NO_LOCATION

        public static final String NO_LOCATION
        The default value of the location() attribute, which indicates that the schema generator will generate components in this namespace.

    • Element Detail

      • xmlns

        public abstract XmlNs[] xmlns
        Customize the namespace URI, prefix associations. By default, the namespace prefixes for a XML namespace are generated by a JAXB Provider in an implementation dependent way.
        Default:
        {}

      • namespace

        public abstract String namespace
        Name of the XML namespace.
        Default:
        ""

      • elementFormDefault

        public abstract XmlNsForm elementFormDefault
        Namespace qualification for elements. By default, element default attribute will be absent from the XML Schema fragment.
        Default:
        javax.xml.bind.annotation.XmlNsForm.UNSET

      • attributeFormDefault

        public abstract XmlNsForm attributeFormDefault
        Namespace qualification for attributes. By default, attributesFormDefault will be absent from the XML Schema fragment.
        Default:
        javax.xml.bind.annotation.XmlNsForm.UNSET

      • location

        public abstract String location
        Indicates that this namespace (specified by namespace()) has a schema already available exeternally, available at this location.

        This instructs the JAXB schema generators to simply refer to the pointed schema, as opposed to generating components into the schema. This schema is assumed to match what would be otherwise produced by the schema generator (same element names, same type names...)

        This feature is intended to be used when a set of the Java classes is originally generated from an existing schema, hand-written to match externally defined schema, or the generated schema is modified manually.

        Value could be any absolute URI, like http://example.org/some.xsd. It is also possible to specify the empty string, to indicate that the schema is externally available but the location is unspecified (and thus it's the responsibility of the reader of the generate schema to locate it.) Finally, the default value of this property "##generate" indicates that the schema generator is going to generate components for this namespace (as it did in JAXB 2.0.)

        Multiple XmlSchema annotations on multiple packages are allowed to govern the same namespace(). In such case, all of them must have the same location() values.

        Note to implementor

        More precisely, the value must be either "", "##generate", or a valid lexical representation of xs:anyURI that begins with <scheme>:.

        A schema generator is expected to generate a corresponding <xs:import namespace="..." schemaLocation="..."/> (or no schemaLocation attribute at all if the empty string is specified.) However, the schema generator is allowed to use a different value in the schemaLocation attribute (including not generating such attribute), for example so that the user can specify a local copy of the resource through the command line interface.

        Since:
        JAXB2.1
        Default:
        "##generate"
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlSchemaType.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlSchemaType.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
  • Enclosing class:
    XmlSchemaType

    public static final class XmlSchemaType.DEFAULT
extends Object
    Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.

    • Constructor Summary

      Constructors
      Constructor and Description
      DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DEFAULT

        public DEFAULT()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlSchemaType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchemaType

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,PACKAGE})
public @interface XmlSchemaType
    Maps a Java type to a simple schema built-in type.

    Usage

    @XmlSchemaType annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • package

    @XmlSchemaType annotation defined for Java type applies to all references to the Java type from a property/field. A @XmlSchemaType annotation specified on the property/field overrides the @XmlSchemaType annotation specified at the package level.

    This annotation can be used with the following annotations: XmlElement, XmlAttribute.

    Example 1: Customize mapping of XMLGregorianCalendar on the field.

         //Example: Code fragment
     public class USPrice {
         @XmlElement
         @XmlSchemaType(name="date")
         public XMLGregorianCalendar date;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="date" type="xs:date"/>
       </sequence>
     </xs:complexType>

    Example 2: Customize mapping of XMLGregorianCalendar at package level

         package foo;
     @javax.xml.bind.annotation.XmlSchemaType(
          name="date", type=javax.xml.datatype.XMLGregorianCalendar.class)
     }
    Since:
    JAXB2.0

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      String name

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String namespace
      Class type
      If this annotation is used at the package level, then value of the type() must be specified.

    • Element Detail

      • name

        public abstract String name

      • namespace

        public abstract String namespace
        Default:
        "http://www.w3.org/2001/XMLSchema"

      • type

        public abstract Class type
        If this annotation is used at the package level, then value of the type() must be specified.
        Default:
        javax.xml.bind.annotation.XmlSchemaType.DEFAULT.class
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlSchemaTypes (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchemaTypes

  • @Retention(value=RUNTIME)
 @Target(value=PACKAGE)
public @interface XmlSchemaTypes

    A container for multiple @XmlSchemaType annotations.

    Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlSchemaType annotations as follows:

     @XmlSchemaTypes({ @XmlSchemaType(...), @XmlSchemaType(...) })

    The @XmlSchemaTypes annnotation can be used to define XmlSchemaType for different types at the package level.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    See Also:
    XmlSchemaType

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlSchemaType[] value
      Collection of @XmlSchemaType annotations

    • Element Detail

      • value

        public abstract XmlSchemaType[] value
        Collection of @XmlSchemaType annotations
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlSeeAlso (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlSeeAlso

  • @Target(value=TYPE)
 @Retention(value=RUNTIME)
public @interface XmlSeeAlso
    Instructs JAXB to also bind other classes when binding this class.

    Java makes it impractical/impossible to list all sub-classes of a given class. This often gets in a way of JAXB users, as it JAXB cannot automatically list up the classes that need to be known to JAXBContext.

    For example, with the following class definitions:

     class Animal {}
 class Dog extends Animal {}
 class Cat extends Animal {}

    The user would be required to create JAXBContext as JAXBContext.newInstance(Dog.class,Cat.class) (Animal will be automatically picked up since Dog and Cat refers to it.)

    XmlSeeAlso annotation would allow you to write:

     @XmlSeeAlso({Dog.class,Cat.class})
 class Animal {}
 class Dog extends Animal {}
 class Cat extends Animal {}

    This would allow you to do JAXBContext.newInstance(Animal.class). By the help of this annotation, JAXB implementations will be able to correctly bind Dog and Cat.

    Since:
    JAXB2.1

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class[] value

    • Element Detail

      • value

        public abstract Class[] value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlTransient (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlTransient

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD,TYPE})
public @interface XmlTransient

    Prevents the mapping of a JavaBean property/type to XML representation.

    The @XmlTransient annotation is useful for resolving name collisions between a JavaBean property name and a field name or preventing the mapping of a field/property. A name collision can occur when the decapitalized JavaBean property name and a field name are the same. If the JavaBean property refers to the field, then the name collision can be resolved by preventing the mapping of either the field or the JavaBean property using the @XmlTransient annotation.

    When placed on a class, it indicates that the class shouldn't be mapped to XML by itself. Properties on such class will be mapped to XML along with its derived classes, as if the class is inlined.

    Usage

    The @XmlTransient annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • class

    @XmlTransientis mutually exclusive with all other JAXB defined annotations.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example: Resolve name collision between JavaBean property and field name

       // Example: Code fragment
   public class USAddress {

       // The field name "name" collides with the property name
       // obtained by bean decapitalization of getName() below
       @XmlTransient public String name;

       String getName() {..};
       String setName() {..};
   }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="name" type="xs:string"/>
     </xs:sequence>
   </xs:complexType>
    Since:
    JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlType.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation

Class XmlType.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlType.DEFAULT
  • Enclosing class:
    XmlType

    public static final class XmlType.DEFAULT
extends Object
    Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.

    • Constructor Summary

      Constructors
      Constructor and Description
      DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DEFAULT

        public DEFAULT()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlType

  • @Retention(value=RUNTIME)
 @Target(value=TYPE)
public @interface XmlType

    Maps a class or an enum type to a XML Schema type.

    Usage

    The @XmlType annnotation can be used with the following program elements:

    • a top level class
    • an enum type

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Mapping a Class

    A class maps to a XML Schema type. A class is a data container for values represented by properties and fields. A schema type is a data container for values represented by schema components within a schema type's content model (e.g. model groups, attributes etc).

    To be mapped, a class must either have a public no-arg constructor or a static no-arg factory method. The static factory method can be specified in factoryMethod() and factoryClass() annotation elements. The static factory method or the no-arg constructor is used during unmarshalling to create an instance of this class. If both are present, the static factory method overrides the no-arg constructor.

    A class maps to either a XML Schema complex type or a XML Schema simple type. The XML Schema type is derived based on the mapping of JavaBean properties and fields contained within the class. The schema type to which the class is mapped can either be named or anonymous. A class can be mapped to an anonymous schema type by annotating the class with @XmlType(name="").

    Either a global element, local element or a local attribute can be associated with an anonymous type as follows:

    • global element: A global element of an anonymous type can be derived by annotating the class with @XmlRootElement. See Example 3 below.
    • local element: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the element associated with the anonymous type. See Example 4 below.
    • attribute: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the attribute associated with the anonymous type. See Example 5 below.
    Mapping to XML Schema Complex Type
    • If class is annotated with @XmlType(name="") , it is mapped to an anonymous type otherwise, the class name maps to a complex type name. The XmlName() annotation element can be used to customize the name.
    • Properties and fields that are mapped to elements are mapped to a content model within a complex type. The annotation element propOrder() can be used to customize the content model to be xs:all or xs:sequence. It is used for specifying the order of XML elements in xs:sequence.
    • Properties and fields can be mapped to attributes within the complex type.
    • The targetnamespace of the XML Schema type can be customized using the annotation element namespace().

    Mapping class to XML Schema simple type

    A class can be mapped to a XML Schema simple type using the @XmlValue annotation. For additional details and examples, see @XmlValue annotation type.

    The following table shows the mapping of the class to a XML Schema complex type or simple type. The notational symbols used in the table are:

    • -> : represents a mapping
    • [x]+ : one or more occurances of x
    • [ @XmlValue property ]: JavaBean property annotated with @XmlValue
    • X : don't care
    Target propOrder ClassBody ComplexType SimpleType
    Class {} [property]+ -> elements complexcontent
    xs:all
    Class non empty [property]+ -> elements complexcontent
    xs:sequence
    Class X no property -> element complexcontent
    empty sequence
    Class X 1 [ @XmlValue property] &&
    [property]+ ->attributes     		simplecontent
    Class X 1 [ @XmlValue property ]&&
    no properties -> attribute     		simpletype

    Mapping an enum type

    An enum type maps to a XML schema simple type with enumeration facets. The following annotation elements are ignored since they are not meaningful: propOrder() , factoryMethod() , factoryClass() .

    Usage with other annotations

    This annotation can be used with the following annotations: XmlRootElement, XmlAccessorOrder, XmlAccessorType, XmlEnum. However, XmlAccessorOrder and XmlAccessorType are ignored when this annotation is used on an enum type.

    Example 1: Map a class to a complex type with xs:sequence with a customized ordering of JavaBean properties.

       @XmlType(propOrder={"street", "city" , "state", "zip", "name" })
   public class USAddress {
     String getName() {..};
     void setName(String) {..};

     String getStreet() {..};
     void setStreet(String) {..};

     String getCity() {..};
     void setCity(String) {..};

     String getState() {..};
     void setState(String) {..};

     java.math.BigDecimal getZip() {..};
     void setZip(java.math.BigDecimal) {..};
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="street" type="xs:string"/>
       <xs:element name="city" type="xs:string"/>
       <xs:element name="state" type="xs:string"/>
       <xs:element name="zip" type="xs:decimal"/>
       <xs:element name="name" type="xs:string"/>
     </xs:all>
   </xs:complexType>

    Example 2: Map a class to a complex type with xs:all

     @XmlType(propOrder={})
 public class USAddress { ...}

 <!-- XML Schema mapping for USAddress -->
 <xs:complexType name="USAddress">
   <xs:all>
     <xs:element name="name" type="xs:string"/>
     <xs:element name="street" type="xs:string"/>
     <xs:element name="city" type="xs:string"/>
     <xs:element name="state" type="xs:string"/>
     <xs:element name="zip" type="xs:decimal"/>
   </xs:sequence>
 </xs:complexType>

    Example 3: Map a class to a global element with an anonymous type.

       @XmlRootElement
   @XmlType(name="")
   public class USAddress { ...}

   <!-- XML Schema mapping for USAddress -->
   <xs:element name="USAddress">
     <xs:complexType>
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:element name="street" type="xs:string"/>
         <xs:element name="city" type="xs:string"/>
         <xs:element name="state" type="xs:string"/>
         <xs:element name="zip" type="xs:decimal"/>
       </xs:sequence>
     </xs:complexType>
   </xs:element>

    Example 4: Map a property to a local element with anonmyous type.

       //Example: Code fragment
   public class Invoice {
       USAddress addr;
           ...
       }

   @XmlType(name="")
   public class USAddress { ... }
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="Invoice">
     <xs:sequence>
       <xs:element name="addr">
         <xs:complexType>
           <xs:element name="name", type="xs:string"/>
           <xs:element name="city", type="xs:string"/>
           <xs:element name="city" type="xs:string"/>
           <xs:element name="state" type="xs:string"/>
           <xs:element name="zip" type="xs:decimal"/>
         </xs:complexType>
       ...
     </xs:sequence>
   </xs:complexType>

    Example 5: Map a property to an attribute with anonymous type.

     //Example: Code fragment
     public class Item {
         public String name;
         @XmlAttribute
         public USPrice price;
     }

     // map class to anonymous simple type.
     @XmlType(name="")
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="Item">
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:attribute name="price">
           <xs:simpleType>
             <xs:restriction base="xs:decimal"/>
           </xs:simpleType>
         </xs:attribute>
       </xs:sequence>
     </xs:complexType>

    Example 6: Define a factoryClass and factoryMethod

          @XmlType(name="USAddressType", factoryClass=USAddressFactory.class,
      factoryMethod="getUSAddress")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

      public USAddress(String name, String street, String city,
          String state, int zip) {
          this.name = name;
          this.street = street;
          this.city = city;
          this.state = state;
          this.zip = zip;
      }
  }

  public class USAddressFactory {
      public static USAddress getUSAddress(){
       return new USAddress("Mark Baker", "23 Elm St",
          "Dayton", "OH", 90952);
  }

    Example 7: Define factoryMethod and use the default factoryClass

          @XmlType(name="USAddressType", factoryMethod="getNewInstance")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

          private USAddress() {}

          public static USAddress getNewInstance(){
              return new USAddress();
          }
      }
    Since:
    JAXB2.0
    See Also:
    XmlElement, XmlAttribute, XmlValue, XmlSchema

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class factoryClass
      Class containing a no-arg factory method for creating an instance of this class.
      String factoryMethod
      Name of a no-arg factory method in the class specified in factoryClass factoryClass().
      String name
      Name of the XML Schema type which the class is mapped.
      String namespace
      Name of the target namespace of the XML Schema type.
      String[] propOrder
      Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema type which the class is mapped.
        Default:
        "##default"

      • propOrder

        public abstract String[] propOrder
        Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

        Refer to the table for how the propOrder affects the mapping of class

        The propOrder is a list of names of JavaBean properties in the class. Each name in the list is the name of a Java identifier of the JavaBean property. The order in which JavaBean properties are listed is the order of XML Schema elements to which the JavaBean properties are mapped.

        All of the JavaBean properties being mapped to XML Schema elements must be listed.

        A JavaBean property or field listed in propOrder must not be transient or annotated with @XmlTransient.

        The default ordering of JavaBean properties is determined by @XmlAccessorOrder.

        Default:
        ""

      • namespace

        public abstract String namespace
        Name of the target namespace of the XML Schema type. By default, this is the target namespace to which the package containing the class is mapped.
        Default:
        "##default"

      • factoryClass

        public abstract Class factoryClass
        Class containing a no-arg factory method for creating an instance of this class. The default is this class.

        If factoryClass is DEFAULT.class and factoryMethod is "", then there is no static factory method.

        If factoryClass is DEFAULT.class and factoryMethod is not "", then factoryMethod is the name of a static factory method in this class.

        If factoryClass is not DEFAULT.class, then factoryMethod must not be "" and must be the name of a static factory method specified in factoryClass.

        Default:
        javax.xml.bind.annotation.XmlType.DEFAULT.class

      • factoryMethod

        public abstract String factoryMethod
        Name of a no-arg factory method in the class specified in factoryClass factoryClass().
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation

Annotation Type XmlValue

  • @Retention(value=RUNTIME)
 @Target(value={FIELD,METHOD})
public @interface XmlValue

    Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

    Usage:

    The @XmlValue annotation can be used with the following program elements:

    • a JavaBean property.
    • non static, non transient field.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following usage constraints:
    • At most one field or property can be annotated with the @XmlValue annotation.
    • @XmlValue can be used with the following annotations: XmlList. However this is redundant since XmlList maps a type to a simple schema type that derives by list just as XmlValue would.
    • If the type of the field or property is a collection type, then the collection item type must map to a simple schema type.
    • If the type of the field or property is not a collection type, then the type must map to a XML Schema simple type.

    If the annotated JavaBean property is the sole class member being mapped to XML Schema construct, then the class is mapped to a simple type. If there are additional JavaBean properties (other than the JavaBean property annotated with @XmlValue annotation) that are mapped to XML attributes, then the class is mapped to a complex type with simpleContent.

    Example 1: Map a class to XML Schema simpleType

     // Example 1: Code fragment
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example 1: XML Schema fragment -->
     <xs:simpleType name="USPrice">
       <xs:restriction base="xs:decimal"/>
     </xs:simpleType>

    Example 2: Map a class to XML Schema complexType with with simpleContent.

   // Example 2: Code fragment
   public class InternationalPrice {
       @XmlValue
       public java.math.BigDecimal price;

       @XmlAttribute
       public String currency;
   }

   <!-- Example 2: XML Schema fragment -->
   <xs:complexType name="InternationalPrice">
     <xs:simpleContent>
       <xs:extension base="xs:decimal">
         <xs:attribute name="currency" type="xs:string"/>
       </xs:extension>
     </xs:simpleContent>
   </xs:complexType>

    Since:
    JAXB2.0
    See Also:
    XmlType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CollapsedStringAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class CollapsedStringAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter

  • public class CollapsedStringAdapter
extends XmlAdapter<String,String>
    Built-in XmlAdapter to handle xs:token and its derived types.

    This adapter removes leading and trailing whitespaces, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

    Since:
    JAXB 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      CollapsedStringAdapter()

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      protected static boolean isWhiteSpace(char ch)
      returns true if the specified char is a white space character.
      String marshal(String s)
      No-op.
      String unmarshal(String text)
      Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CollapsedStringAdapter

        public CollapsedStringAdapter()

    • Method Detail

      • unmarshal

        public String unmarshal(String text)
        Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.
        Specified by:
        unmarshal in class XmlAdapter<String,String>
        Parameters:
        text - The value to be converted. Can be null.

      • marshal

        public String marshal(String s)
        No-op. Just return the same string given as the parameter.
        Specified by:
        marshal in class XmlAdapter<String,String>
        Parameters:
        s - The value to be convereted. Can be null.

      • isWhiteSpace

        protected static boolean isWhiteSpace(char ch)
        returns true if the specified char is a white space character.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HexBinaryAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class HexBinaryAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,byte[]>
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter

  • public final class HexBinaryAdapter
extends XmlAdapter<String,byte[]>
    XmlAdapter for xs:hexBinary.

    This XmlAdapter binds byte[] to the hexBinary representation in XML.

    Since:
    JAXB 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      HexBinaryAdapter()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String marshal(byte[] bytes)
      Convert a bound type to a value type.
      byte[] unmarshal(String s)
      Convert a value type to a bound type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HexBinaryAdapter

        public HexBinaryAdapter()

    • Method Detail

      • unmarshal

        public byte[] unmarshal(String s)
        Description copied from class: XmlAdapter
        Convert a value type to a bound type.
        Specified by:
        unmarshal in class XmlAdapter<String,byte[]>
        Parameters:
        s - The value to be converted. Can be null.

      • marshal

        public String marshal(byte[] bytes)
        Description copied from class: XmlAdapter
        Convert a bound type to a value type.
        Specified by:
        marshal in class XmlAdapter<String,byte[]>
        Parameters:
        bytes - The value to be convereted. Can be null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NormalizedStringAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class NormalizedStringAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter

  • public final class NormalizedStringAdapter
extends XmlAdapter<String,String>
    XmlAdapter to handle xs:normalizedString.

    Replaces any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'

    Since:
    JAXB 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      NormalizedStringAdapter()

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      protected static boolean isWhiteSpaceExceptSpace(char ch)
      Returns true if the specified char is a white space character but not 0x20.
      String marshal(String s)
      No-op.
      String unmarshal(String text)
      Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NormalizedStringAdapter

        public NormalizedStringAdapter()

    • Method Detail

      • unmarshal

        public String unmarshal(String text)
        Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'
        Specified by:
        unmarshal in class XmlAdapter<String,String>
        Parameters:
        text - The value to be converted. Can be null.

      • marshal

        public String marshal(String s)
        No-op. Just return the same string given as the parameter.
        Specified by:
        marshal in class XmlAdapter<String,String>
        Parameters:
        s - The value to be convereted. Can be null.

      • isWhiteSpaceExceptSpace

        protected static boolean isWhiteSpaceExceptSpace(char ch)
        Returns true if the specified char is a white space character but not 0x20.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.annotation.adapters (Java Platform SE 8 )

javax.xml.bind.annotation.adapters

Classes

  • CollapsedStringAdapter
  • HexBinaryAdapter
  • NormalizedStringAdapter
  • XmlAdapter
  • XmlJavaTypeAdapter.DEFAULT

Annotation Types

  • XmlJavaTypeAdapter
  • XmlJavaTypeAdapters


javax.xml.bind.annotation.adapters (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.annotation.adapters

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

See: Description

  • Class Summary
    Class Description
    CollapsedStringAdapter
    Built-in XmlAdapter to handle xs:token and its derived types.
    HexBinaryAdapter
    XmlAdapter for xs:hexBinary.
    NormalizedStringAdapter
    XmlAdapter to handle xs:normalizedString.
    XmlAdapter<ValueType,BoundType>
    Adapts a Java type for custom marshaling.
    XmlJavaTypeAdapter.DEFAULT
    Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.
  • Annotation Types Summary
    Annotation Type Description
    XmlJavaTypeAdapter
    Use an adapter that implements XmlAdapter for custom marshaling.
    XmlJavaTypeAdapters
    A container for multiple @XmlJavaTypeAdapter annotations.

Package javax.xml.bind.annotation.adapters Description

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.annotation.adapters Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.annotation.adapters

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

Annotation Type Hierarchy

  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.bind.annotation.adapters (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.annotation.adapters

  • Packages that use javax.xml.bind.annotation.adapters
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation.adapters
    XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind.annotation.adapters
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind.helpers
    Class and Description
    XmlAdapter
    Adapts a Java type for custom marshaling.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class XmlAdapter<ValueType,BoundType>

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
  • Type Parameters:
    BoundType - The type that JAXB doesn't know how to handle. An adapter is written to allow this type to be used as an in-memory representation through the ValueType.
    ValueType - The type that JAXB knows how to handle out of the box.
    Direct Known Subclasses:
    CollapsedStringAdapter, HexBinaryAdapter, NormalizedStringAdapter

    public abstract class XmlAdapter<ValueType,BoundType>
extends Object
    Adapts a Java type for custom marshaling.

    Usage:

    Some Java types do not map naturally to a XML representation, for example HashMap or other non JavaBean classes. Conversely, a XML repsentation may map to a Java type but an application may choose to accesss the XML representation using another Java type. For example, the schema to Java binding rules bind xs:DateTime by default to XmlGregorianCalendar. But an application may desire to bind xs:DateTime to a custom type, MyXmlGregorianCalendar, for example. In both cases, there is a mismatch between bound type , used by an application to access XML content and the value type, that is mapped to an XML representation.

    This abstract class defines methods for adapting a bound type to a value type or vice versa. The methods are invoked by the JAXB binding framework during marshaling and unmarshalling:

    • XmlAdapter.marshal(...): During marshalling, JAXB binding framework invokes XmlAdapter.marshal(..) to adapt a bound type to value type, which is then marshaled to XML representation.
    • XmlAdapter.unmarshal(...): During unmarshalling, JAXB binding framework first unmarshals XML representation to a value type and then invokes XmlAdapter.unmarshal(..) to adapt the value type to a bound type.
    Writing an adapter therefore involves the following steps:
    • Write an adapter that implements this abstract class.
    • Install the adapter using the annotation XmlJavaTypeAdapter

    Example: Customized mapping of HashMap

    The following example illustrates the use of @XmlAdapter and @XmlJavaTypeAdapter to customize the mapping of a HashMap.

    Step 1: Determine the desired XML representation for HashMap.

         <hashmap>
         <entry key="id123">this is a value</entry>
         <entry key="id312">this is another value</entry>
         ...
       </hashmap>

    Step 2: Determine the schema definition that the desired XML representation shown above should follow.

     <xs:complexType name="myHashMapType">
       <xs:sequence>
         <xs:element name="entry" type="myHashMapEntryType"
                        minOccurs = "0" maxOccurs="unbounded"/>
       </xs:sequence>
     </xs:complexType>

     <xs:complexType name="myHashMapEntryType">
       <xs:simpleContent>
         <xs:extension base="xs:string">
           <xs:attribute name="key" type="xs:int"/>
         </xs:extension>
       </xs:simpleContent>
     </xs:complexType>

    Step 3: Write value types that can generate the above schema definition.

         public class MyHashMapType {
         List<MyHashMapEntryType> entry;
     }

     public class MyHashMapEntryType {
         @XmlAttribute
         public Integer key;

         @XmlValue
         public String value;
     }

    Step 4: Write the adapter that adapts the value type, MyHashMapType to a bound type, HashMap, used by the application.

         public final class MyHashMapAdapter extends
                        XmlAdapter<MyHashMapType,HashMap> { ... }

    Step 5: Use the adapter.

         public class Foo {
         @XmlJavaTypeAdapter(MyHashMapAdapter.class)
         HashMap hashmap;
         ...
     }
    The above code fragment will map to the following schema:
         <xs:complexType name="Foo">
       <xs:sequence>
         <xs:element name="hashmap" type="myHashMapType"
       </xs:sequence>
     </xs:complexType>
    Since:
    JAXB 2.0
    See Also:
    XmlJavaTypeAdapter

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected XmlAdapter()
      Do-nothing constructor for the derived classes.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract ValueType marshal(BoundType v)
      Convert a bound type to a value type.
      abstract BoundType unmarshal(ValueType v)
      Convert a value type to a bound type.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XmlAdapter

        protected XmlAdapter()
        Do-nothing constructor for the derived classes.

    • Method Detail

      • unmarshal

        public abstract BoundType unmarshal(ValueType v)
                             throws Exception
        Convert a value type to a bound type.
        Parameters:
        v - The value to be converted. Can be null.
        Throws:
        Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.

      • marshal

        public abstract ValueType marshal(BoundType v)
                           throws Exception
        Convert a bound type to a value type.
        Parameters:
        v - The value to be convereted. Can be null.
        Throws:
        Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlJavaTypeAdapter.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.annotation.adapters

Class XmlJavaTypeAdapter.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
  • Enclosing class:
    XmlJavaTypeAdapter

    public static final class XmlJavaTypeAdapter.DEFAULT
extends Object
    Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.

    • Constructor Summary

      Constructors
      Constructor and Description
      DEFAULT()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DEFAULT

        public DEFAULT()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlJavaTypeAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation.adapters

Annotation Type XmlJavaTypeAdapter

  • @Retention(value=RUNTIME)
 @Target(value={PACKAGE,FIELD,METHOD,TYPE,PARAMETER})
public @interface XmlJavaTypeAdapter
    Use an adapter that implements XmlAdapter for custom marshaling.

    Usage:

    The @XmlJavaTypeAdapter annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • parameter
    • package
    • from within XmlJavaTypeAdapters

    When @XmlJavaTypeAdapter annotation is defined on a class, it applies to all references to the class.

    When @XmlJavaTypeAdapter annotation is defined at the package level it applies to all references from within the package to @XmlJavaTypeAdapter.type().

    When @XmlJavaTypeAdapter annotation is defined on the field, property or parameter, then the annotation applies to the field, property or the parameter only.

    A @XmlJavaTypeAdapter annotation on a field, property or parameter overrides the @XmlJavaTypeAdapter annotation associated with the class being referenced by the field, property or parameter.

    A @XmlJavaTypeAdapter annotation on a class overrides the @XmlJavaTypeAdapter annotation specified at the package level for that class.

    This annotation can be used with the following other annotations: XmlElement, XmlAttribute, XmlElementRef, XmlElementRefs, XmlAnyElement. This can also be used at the package level with the following annotations: XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes.

    Example: See example in XmlAdapter

    Since:
    JAXB2.0
    See Also:
    XmlAdapter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends XmlAdapter> value
      Points to the class that converts a value type to a bound type or vice versa.

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Class type
      If this annotation is used at the package level, then value of the type() must be specified.

    • Element Detail

      • value

        public abstract Class<? extends XmlAdapter> value
        Points to the class that converts a value type to a bound type or vice versa. See XmlAdapter for more details.

      • type

        public abstract Class type
        If this annotation is used at the package level, then value of the type() must be specified.
        Default:
        javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT.class
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XmlJavaTypeAdapters (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.bind.annotation.adapters

Annotation Type XmlJavaTypeAdapters

  • @Retention(value=RUNTIME)
 @Target(value=PACKAGE)
public @interface XmlJavaTypeAdapters

    A container for multiple @XmlJavaTypeAdapter annotations.

    Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlJavaTypeAdapter as follows:

     @XmlJavaTypeAdapters ({ @XmlJavaTypeAdapter(...),@XmlJavaTypeAdapter(...) })

    The @XmlJavaTypeAdapters annnotation is useful for defining XmlJavaTypeAdapter annotations for different types at the package level.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Since:
    JAXB2.0
    See Also:
    XmlJavaTypeAdapter

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      XmlJavaTypeAdapter[] value
      Collection of @XmlJavaTypeAdapter annotations

    • Element Detail

      • value

        public abstract XmlJavaTypeAdapter[] value
        Collection of @XmlJavaTypeAdapter annotations
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.CollapsedStringAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.CollapsedStringAdapter

No usage of javax.xml.bind.annotation.adapters.CollapsedStringAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.HexBinaryAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.HexBinaryAdapter

No usage of javax.xml.bind.annotation.adapters.HexBinaryAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.NormalizedStringAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.NormalizedStringAdapter

No usage of javax.xml.bind.annotation.adapters.NormalizedStringAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.XmlAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlAdapter

  • Packages that use XmlAdapter
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation.adapters
    XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of XmlAdapter in javax.xml.bind

      Methods in javax.xml.bind with type parameters of type XmlAdapter
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		Marshaller.getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      <A extends XmlAdapter>
      A             		Unmarshaller.getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      <A extends XmlAdapter>
      void             		Marshaller.setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      <A extends XmlAdapter>
      void             		Unmarshaller.setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      Methods in javax.xml.bind with parameters of type XmlAdapter
      Modifier and Type Method and Description
      void Marshaller.setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void Unmarshaller.setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.

    • Uses of XmlAdapter in javax.xml.bind.annotation.adapters

      Subclasses of XmlAdapter in javax.xml.bind.annotation.adapters
      Modifier and Type Class and Description
      class  CollapsedStringAdapter
      Built-in XmlAdapter to handle xs:token and its derived types.
      class  HexBinaryAdapter
      XmlAdapter for xs:hexBinary.
      class  NormalizedStringAdapter
      XmlAdapter to handle xs:normalizedString.

    • Uses of XmlAdapter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with type parameters of type XmlAdapter
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		AbstractMarshallerImpl.getAdapter(Class<A> type)
      <A extends XmlAdapter>
      A             		AbstractUnmarshallerImpl.getAdapter(Class<A> type)
      <A extends XmlAdapter>
      void             		AbstractMarshallerImpl.setAdapter(Class<A> type, A adapter)
      <A extends XmlAdapter>
      void             		AbstractUnmarshallerImpl.setAdapter(Class<A> type, A adapter)
      Methods in javax.xml.bind.helpers with parameters of type XmlAdapter
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setAdapter(XmlAdapter adapter)
      void | AbstractUnmarshallerImpl.setAdapter(XmlAdapter adapter)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.annotation.DomHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.annotation.DomHandler

  • Packages that use DomHandler
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of DomHandler in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation that implement DomHandler
      Modifier and Type Class and Description
      class  W3CDomHandler
      DomHandler implementation for W3C DOM (org.w3c.dom package.)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.W3CDomHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.W3CDomHandler

No usage of javax.xml.bind.annotation.W3CDomHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAccessOrder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessOrder

  • Packages that use XmlAccessOrder
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlAccessOrder in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlAccessOrder
      Modifier and Type Method and Description
      static XmlAccessOrder XmlAccessOrder.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessOrder[] XmlAccessOrder.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAccessorOrder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessorOrder

No usage of javax.xml.bind.annotation.XmlAccessorOrder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAccessorType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessorType

No usage of javax.xml.bind.annotation.XmlAccessorType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAccessType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAccessType

  • Packages that use XmlAccessType
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlAccessType in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlAccessType
      Modifier and Type Method and Description
      static XmlAccessType XmlAccessType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessType[] XmlAccessType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAnyAttribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAnyAttribute

No usage of javax.xml.bind.annotation.XmlAnyAttribute
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAnyElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAnyElement

No usage of javax.xml.bind.annotation.XmlAnyElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAttachmentRef (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAttachmentRef

No usage of javax.xml.bind.annotation.XmlAttachmentRef
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlAttribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlAttribute

No usage of javax.xml.bind.annotation.XmlAttribute
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElement.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElement.DEFAULT

No usage of javax.xml.bind.annotation.XmlElement.DEFAULT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElement

No usage of javax.xml.bind.annotation.XmlElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElementDecl.GLOBAL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementDecl.GLOBAL

No usage of javax.xml.bind.annotation.XmlElementDecl.GLOBAL
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElementDecl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementDecl

No usage of javax.xml.bind.annotation.XmlElementDecl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElementRef.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementRef.DEFAULT

No usage of javax.xml.bind.annotation.XmlElementRef.DEFAULT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElementRef (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementRef

No usage of javax.xml.bind.annotation.XmlElementRef
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElementRefs (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementRefs

No usage of javax.xml.bind.annotation.XmlElementRefs
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElements (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElements

No usage of javax.xml.bind.annotation.XmlElements
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlElementWrapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlElementWrapper

No usage of javax.xml.bind.annotation.XmlElementWrapper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlEnum (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlEnum

No usage of javax.xml.bind.annotation.XmlEnum
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlEnumValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlEnumValue

No usage of javax.xml.bind.annotation.XmlEnumValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlID

No usage of javax.xml.bind.annotation.XmlID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlIDREF (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlIDREF

No usage of javax.xml.bind.annotation.XmlIDREF
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlInlineBinaryData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlInlineBinaryData

No usage of javax.xml.bind.annotation.XmlInlineBinaryData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlList

No usage of javax.xml.bind.annotation.XmlList
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlMimeType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlMimeType

No usage of javax.xml.bind.annotation.XmlMimeType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlMixed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlMixed

No usage of javax.xml.bind.annotation.XmlMixed
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlNs (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlNs

No usage of javax.xml.bind.annotation.XmlNs
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlNsForm (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlNsForm

  • Packages that use XmlNsForm
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlNsForm in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlNsForm
      Modifier and Type Method and Description
      static XmlNsForm XmlNsForm.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlNsForm[] XmlNsForm.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlRegistry (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlRegistry

No usage of javax.xml.bind.annotation.XmlRegistry
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlRootElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlRootElement

  • Packages that use XmlRootElement
    Package Description
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of XmlRootElement in javax.xml.ws.wsaddressing

      Classes in javax.xml.ws.wsaddressing with annotations of type XmlRootElement
      Modifier and Type Class and Description
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlSchema (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchema

No usage of javax.xml.bind.annotation.XmlSchema
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlSchemaType.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchemaType.DEFAULT

No usage of javax.xml.bind.annotation.XmlSchemaType.DEFAULT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlSchemaType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchemaType

No usage of javax.xml.bind.annotation.XmlSchemaType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlSchemaTypes (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSchemaTypes

No usage of javax.xml.bind.annotation.XmlSchemaTypes
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlSeeAlso (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlSeeAlso

No usage of javax.xml.bind.annotation.XmlSeeAlso
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlTransient (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlTransient

  • Packages that use XmlTransient
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of XmlTransient in javax.xml.ws

      Classes in javax.xml.ws with annotations of type XmlTransient
      Modifier and Type Class and Description
      class  EndpointReference
      This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlType.DEFAULT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlType.DEFAULT

No usage of javax.xml.bind.annotation.XmlType.DEFAULT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlType

  • Packages that use XmlType
    Package Description
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of XmlType in javax.xml.ws.wsaddressing

      Classes in javax.xml.ws.wsaddressing with annotations of type XmlType
      Modifier and Type Class and Description
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.annotation.XmlValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.annotation.XmlValue

No usage of javax.xml.bind.annotation.XmlValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttachmentMarshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.attachment

Class AttachmentMarshaller

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller

  • public abstract class AttachmentMarshaller
extends Object

    Enable JAXB marshalling to optimize storage of binary data.

    This API enables an efficient cooperative creation of optimized binary data formats between a JAXB marshalling process and a MIME-based package processor. A JAXB implementation marshals the root body of a MIME-based package, delegating the creation of referenceable MIME parts to the MIME-based package processor that implements this abstraction.

    XOP processing is enabled when isXOPPackage() is true. See addMtomAttachment(DataHandler, String, String) for details.

    WS-I Attachment Profile 1.0 is supported by addSwaRefAttachment(DataHandler) being called by the marshaller for each JAXB property related to {http://ws-i.org/profiles/basic/1.1/xsd}swaRef.

    Since:
    JAXB 2.0
    See Also:
    Marshaller.setAttachmentMarshaller(AttachmentMarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0.

    • Constructor Summary

      Constructors
      Constructor and Description
      AttachmentMarshaller()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract String addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
      Consider binary data for optimized binary storage as an attachment.
      abstract String addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
      Consider MIME content data for optimized binary storage as an attachment.
      abstract String addSwaRefAttachment(DataHandler data)
      Add MIME data as an attachment and return attachment's content-id, cid.
      boolean isXOPPackage()
      Read-only property that returns true if JAXB marshaller should enable XOP creation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttachmentMarshaller

        public AttachmentMarshaller()

    • Method Detail

      • addMtomAttachment

        public abstract String addMtomAttachment(DataHandler data,
                                         String elementNamespace,
                                         String elementLocalName)

        Consider MIME content data for optimized binary storage as an attachment.

        This method is called by JAXB marshal process when isXOPPackage() is true, for each element whose datatype is "base64Binary", as described in Step 3 in Creating XOP Packages.

        The method implementor determines whether data shall be attached separately or inlined as base64Binary data. If the implementation chooses to optimize the storage of the binary data as a MIME part, it is responsible for attaching data to the MIME-based package, and then assigning an unique content-id, cid, that identifies the MIME part within the MIME message. This method returns the cid, which enables the JAXB marshaller to marshal a XOP element that refers to that cid in place of marshalling the binary data. When the method returns null, the JAXB marshaller inlines data as base64binary data.

        The caller of this method is required to meet the following constraint. If the element infoset item containing data has the attribute xmime:contentType or if the JAXB property/field representing datais annotated with a known MIME type, data.getContentType() should be set to that MIME type.

        The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

        Parameters:
        data - represents the data to be attached. Must be non-null.
        elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
        elementLocalName - The local name of the element. Always a non-null valid string.
        Returns:
        a valid content-id URI (see RFC 2387) that identifies the attachment containing data. Otherwise, null if the attachment was not added and should instead be inlined in the message.
        See Also:
        XML-binary Optimized Packaging, Describing Media Content of Binary Data in XML

      • addMtomAttachment

        public abstract String addMtomAttachment(byte[] data,
                                         int offset,
                                         int length,
                                         String mimeType,
                                         String elementNamespace,
                                         String elementLocalName)

        Consider binary data for optimized binary storage as an attachment.

        Since content type is not known, the attachment's MIME content type must be set to "application/octet-stream".

        The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

        Parameters:
        data - represents the data to be attached. Must be non-null. The actual data region is specified by (data,offset,length) tuple.
        offset - The offset within the array of the first byte to be read; must be non-negative and no larger than array.length
        length - The number of bytes to be read from the given array; must be non-negative and no larger than array.length
        mimeType - If the data has an associated MIME type known to JAXB, that is passed as this parameter. If none is known, "application/octet-stream". This parameter may never be null.
        elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
        elementLocalName - The local name of the element. Always a non-null valid string.
        Returns:
        content-id URI, cid, to the attachment containing data or null if data should be inlined.
        See Also:
        addMtomAttachment(DataHandler, String, String)

      • isXOPPackage

        public boolean isXOPPackage()

        Read-only property that returns true if JAXB marshaller should enable XOP creation.

        This value must not change during the marshalling process. When this value is true, the addMtomAttachment(...) method is invoked when the appropriate binary datatypes are encountered by the marshal process.

        Marshaller.marshal() must throw IllegalStateException if this value is true and the XML content to be marshalled violates Step 1 in Creating XOP Pacakges http://www.w3.org/TR/2005/REC-xop10-20050125/#creating_xop_packages. "Ensure the Original XML Infoset contains no element information item with a [namespace name] of "http://www.w3.org/2004/08/xop/include" and a [local name] of Include"

        When this method returns true and during the marshal process at least one call to addMtomAttachment(...) returns a content-id, the MIME-based package processor must label the root part with the application/xop+xml media type as described in Step 5 of Creating XOP Pacakges.

        Returns:
        true when MIME context is a XOP Package.

      • addSwaRefAttachment

        public abstract String addSwaRefAttachment(DataHandler data)

        Add MIME data as an attachment and return attachment's content-id, cid.

        This method is called by JAXB marshal process for each element/attribute typed as {http://ws-i.org/profiles/basic/1.1/xsd}swaRef. The MIME-based package processor implementing this method is responsible for attaching the specified data to a MIME attachment, and generating a content-id, cid, that uniquely identifies the attachment within the MIME-based package.

        Caller inserts the returned content-id, cid, into the XML content being marshalled.

        Parameters:
        data - represents the data to be attached. Must be non-null.
        Returns:
        must be a valid URI used as cid. Must satisfy Conformance Requirement R2928 from WS-I Attachments Profile Version 1.0.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttachmentUnmarshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.attachment

Class AttachmentUnmarshaller

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentUnmarshaller

  • public abstract class AttachmentUnmarshaller
extends Object

    Enables JAXB unmarshalling of a root document containing optimized binary data formats.

    This API enables an efficient cooperative processing of optimized binary data formats between a JAXB 2.0 implementation and MIME-based package processor (MTOM/XOP and WS-I AP 1.0). JAXB unmarshals the body of a package, delegating the understanding of the packaging format being used to a MIME-based package processor that implements this abstract class.

    This abstract class identifies if a package requires XOP processing, isXOPPackage() and provides retrieval of binary content stored as attachments by content-id.

    Identifying the content-id, cid, to pass to getAttachment*(String cid)

    • For XOP processing, the infoset representation of the cid is described in step 2a in Section 3.2 Interpreting XOP Packages
    • For WS-I AP 1.0, the cid is identified as an element or attribute of type ref:swaRef specified in Section 4.4 Referencing Attachments from the SOAP Envelope
    Since:
    JAXB 2.0
    See Also:
    Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0., Describing Media Content of Binary Data in XML

    • Constructor Summary

      Constructors
      Constructor and Description
      AttachmentUnmarshaller()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract byte[] getAttachmentAsByteArray(String cid)
      Retrieve the attachment identified by content-id, cid, as a byte[]
      abstract DataHandler getAttachmentAsDataHandler(String cid)
      Lookup MIME content by content-id, cid, and return as a DataHandler.
      boolean isXOPPackage()
      Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttachmentUnmarshaller

        public AttachmentUnmarshaller()

    • Method Detail

      • getAttachmentAsDataHandler

        public abstract DataHandler getAttachmentAsDataHandler(String cid)

        Lookup MIME content by content-id, cid, and return as a DataHandler.

        The returned DataHandler instance must be configured to meet the following required mapping constaint.

        Required Mappings between MIME and Java Types
        MIME Type | Java Type
        DataHandler.getContentType() | instanceof DataHandler.getContent()
        image/gif | java.awt.Image
        image/jpeg | java.awt.Image
        text/xml or application/xml | javax.xml.transform.Source
        Note that it is allowable to support additional mappings.

        Parameters:
        cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
        Returns:
        a DataHandler that represents the MIME attachment.
        Throws:
        IllegalArgumentException - if the attachment for the given cid is not found.

      • getAttachmentAsByteArray

        public abstract byte[] getAttachmentAsByteArray(String cid)

        Retrieve the attachment identified by content-id, cid, as a byte[]

        .
        Parameters:
        cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
        Returns:
        byte[] representation of attachment identified by cid.
        Throws:
        IllegalArgumentException - if the attachment for the given cid is not found.

      • isXOPPackage

        public boolean isXOPPackage()

        Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

        This method returns true when the constraints specified in Identifying XOP Documents are met. This value must not change during the unmarshalling process.

        Returns:
        true when MIME context is a XOP Document.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.attachment (Java Platform SE 8 )

javax.xml.bind.attachment

Classes

  • AttachmentMarshaller
  • AttachmentUnmarshaller


javax.xml.bind.attachment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.attachment

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

See: Description

  • Class Summary
    Class Description
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.

Package javax.xml.bind.attachment Description

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

Soap MTOM[1], XOP([2][3]) and WS-I AP[4] standardize approaches to optimized transmission of binary datatypes as an attachment. To optimally support these standards within a message passing environment, this package enables an integrated solution between a MIME-based package processor and JAXB unmarshall/marshal processes.

Package Specification

  • JAXB Specification

Related Standards

  • [1]SOAP Message Transmission Optimization Mechanism
  • [2]XML-binary Optimized Packaging
  • [3]WS-I Attachments Profile Version 1.0.
  • [4]Describing Media Content of Binary Data in XML
Since:
JAXB 2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.attachment Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.attachment

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.bind.attachment.AttachmentUnmarshaller
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.bind.attachment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.attachment

  • Packages that use javax.xml.bind.attachment
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.attachment used by javax.xml.bind
    Class and Description
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.
  • Classes in javax.xml.bind.attachment used by javax.xml.bind.helpers
    Class and Description
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.attachment.AttachmentMarshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.attachment.AttachmentMarshaller

  • Packages that use AttachmentMarshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of AttachmentMarshaller in javax.xml.bind

      Methods in javax.xml.bind that return AttachmentMarshaller
      Modifier and Type | Method and Description
      AttachmentMarshaller | Marshaller.getAttachmentMarshaller()
      Methods in javax.xml.bind with parameters of type AttachmentMarshaller
      Modifier and Type Method and Description
      void Marshaller.setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.

    • Uses of AttachmentMarshaller in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return AttachmentMarshaller
      Modifier and Type | Method and Description
      AttachmentMarshaller | AbstractMarshallerImpl.getAttachmentMarshaller()
      Methods in javax.xml.bind.helpers with parameters of type AttachmentMarshaller
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setAttachmentMarshaller(AttachmentMarshaller am)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.attachment.AttachmentUnmarshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.attachment.AttachmentUnmarshaller

  • Packages that use AttachmentUnmarshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of AttachmentUnmarshaller in javax.xml.bind

      Methods in javax.xml.bind that return AttachmentUnmarshaller
      Modifier and Type | Method and Description
      AttachmentUnmarshaller | Unmarshaller.getAttachmentUnmarshaller()
      Methods in javax.xml.bind with parameters of type AttachmentUnmarshaller
      Modifier and Type Method and Description
      void Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

    • Uses of AttachmentUnmarshaller in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return AttachmentUnmarshaller
      Modifier and Type | Method and Description
      AttachmentUnmarshaller | AbstractUnmarshallerImpl.getAttachmentUnmarshaller()
      Methods in javax.xml.bind.helpers with parameters of type AttachmentUnmarshaller
      Modifier and Type | Method and Description
      void | AbstractUnmarshallerImpl.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.Binder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.Binder

  • Packages that use Binder
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of Binder in javax.xml.bind

      Methods in javax.xml.bind that return Binder
      Modifier and Type Method and Description
      Binder<Node> JAXBContext.createBinder()
      Creates a Binder for W3C DOM.
      <T> Binder<T> JAXBContext.createBinder(Class<T> domType)
      Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.DataBindingException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.DataBindingException

No usage of javax.xml.bind.DataBindingException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.DatatypeConverter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.DatatypeConverter

No usage of javax.xml.bind.DatatypeConverter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.DatatypeConverterInterface (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.DatatypeConverterInterface

  • Packages that use DatatypeConverterInterface
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of DatatypeConverterInterface in javax.xml.bind

      Methods in javax.xml.bind with parameters of type DatatypeConverterInterface
      Modifier and Type Method and Description
      static void DatatypeConverter.setDatatypeConverter(DatatypeConverterInterface converter)
      This method is for JAXB provider use only.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.Element (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Element

No usage of javax.xml.bind.Element
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXB (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXB

No usage of javax.xml.bind.JAXB
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXBContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBContext

  • Packages that use JAXBContext
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of JAXBContext in javax.xml.bind

      Methods in javax.xml.bind that return JAXBContext
      Modifier and Type Method and Description
      static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.

    • Uses of JAXBContext in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type JAXBContext
      Constructor and Description
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.

    • Uses of JAXBContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type JAXBContext
      Modifier and Type Method and Description
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Object LogicalMessage.getPayload(JAXBContext context)
      Gets the message payload as a JAXB object.
      void LogicalMessage.setPayload(Object payload, JAXBContext context)
      Sets the message payload

    • Uses of JAXBContext in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap with parameters of type JAXBContext
      Modifier and Type Method and Description
      Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.

    • Uses of JAXBContext in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type JAXBContext
      Modifier and Type Method and Description
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXBElement.GlobalScope (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBElement.GlobalScope

No usage of javax.xml.bind.JAXBElement.GlobalScope
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXBElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBElement

  • Packages that use JAXBElement
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of JAXBElement in javax.xml.bind

      Methods in javax.xml.bind that return JAXBElement
      Modifier and Type Method and Description
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract <T> JAXBElement<T> Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of JAXBElement in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return JAXBElement
      Modifier and Type | Method and Description
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXBException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBException

  • Packages that use JAXBException
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of JAXBException in javax.xml.bind

      Subclasses of JAXBException in javax.xml.bind
      Modifier and Type Class and Description
      class  MarshalException
      This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
      class  PropertyException
      This exception indicates that an error was encountered while getting or setting a property.
      class  UnmarshalException
      This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
      class  ValidationException
      This exception indicates that an error has occurred while performing a validate operation.
      Methods in javax.xml.bind that throw JAXBException
      Modifier and Type Method and Description
      abstract Marshaller JAXBContext.createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.
      abstract Unmarshaller JAXBContext.createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.
      abstract Validator JAXBContext.createValidator()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Marshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract ValidationEventHandler Binder.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler Validator.getEventHandler()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Unmarshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Node Marshaller.getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Object UnmarshallerHandler.getResult()
      Obtains the unmarshalled result.
      boolean Unmarshaller.isValidating()
      Deprecated.
      since JAXB2.0, please see Unmarshaller.getSchema()
      void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void Marshaller.marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void Marshaller.marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void Marshaller.marshal(Object jaxbElement, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void Marshaller.marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      void Marshaller.marshal(Object jaxbElement, Writer writer)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      abstract void Binder.marshal(Object jaxbObject, XmlNode xmlNode)
      Marshal a JAXB object tree to a new XML document.
      void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      void Marshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      abstract void Binder.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Validator.setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void Unmarshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Unmarshaller.setValidating(boolean validating)
      Deprecated.
      since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)
      Object Unmarshaller.unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object Unmarshaller.unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object Unmarshaller.unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      Object Unmarshaller.unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object Unmarshaller.unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object Unmarshaller.unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object Unmarshaller.unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object Unmarshaller.unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract Object Binder.unmarshal(XmlNode xmlNode)
      Unmarshal XML infoset view to a JAXB object tree.
      abstract <T> JAXBElement<T> Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      Object Unmarshaller.unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract Object Binder.updateJAXB(XmlNode xmlNode)
      Takes an XML node and updates its associated JAXB object and its descendants.
      abstract XmlNode Binder.updateXML(Object jaxbObject)
      Takes an JAXB object and updates its associated XML node and its descendants.
      abstract XmlNode Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
      Changes in JAXB object tree are updated in its associated XML parse tree.
      boolean Validator.validate(Object subrootObj)
      Deprecated.
      since JAXB2.0
      boolean Validator.validateRoot(Object rootObj)
      Deprecated.
      since JAXB2.0

    • Uses of JAXBException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw JAXBException
      Modifier and Type | Method and Description
      ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
      ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Node AbstractMarshallerImpl.getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      protected XMLReader AbstractUnmarshallerImpl.getXMLReader()
      Obtains a configured XMLReader.
      boolean AbstractUnmarshallerImpl.isValidating()
      Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
      void | AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)
      void | AbstractMarshallerImpl.marshal(Object jaxbElement, File output)
      void | AbstractMarshallerImpl.marshal(Object obj, Node node)
      void | AbstractMarshallerImpl.marshal(Object obj, OutputStream os)
      void | AbstractMarshallerImpl.marshal(Object obj, Writer w)
      void | AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)
      void | AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)
      void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
      void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void AbstractUnmarshallerImpl.setValidating(boolean validating)
      Specifies whether or not the Unmarshaller should validate during unmarshal operations.
      Object | AbstractUnmarshallerImpl.unmarshal(File f)
      Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
      Object | AbstractUnmarshallerImpl.unmarshal(InputStream is)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
      Object | AbstractUnmarshallerImpl.unmarshal(Reader reader)
      Object | AbstractUnmarshallerImpl.unmarshal(Source source)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
      Object | AbstractUnmarshallerImpl.unmarshal(URL url)
      Object | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.
      Object | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

    • Uses of JAXBException in javax.xml.bind.util

      Methods in javax.xml.bind.util that throw JAXBException
      Modifier and Type Method and Description
      Object JAXBResult.getResult()
      Gets the unmarshalled object created by the transformation.
      Constructors in javax.xml.bind.util that throw JAXBException
      Constructor and Description
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXBIntrospector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBIntrospector

  • Packages that use JAXBIntrospector
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of JAXBIntrospector in javax.xml.bind

      Methods in javax.xml.bind that return JAXBIntrospector
      Modifier and Type Method and Description
      JAXBIntrospector JAXBContext.createJAXBIntrospector()
      Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.JAXBPermission (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.JAXBPermission

No usage of javax.xml.bind.JAXBPermission
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.MarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.MarshalException

No usage of javax.xml.bind.MarshalException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.Marshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Marshaller

  • Packages that use Marshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of Marshaller in javax.xml.bind

      Methods in javax.xml.bind that return Marshaller
      Modifier and Type Method and Description
      abstract Marshaller JAXBContext.createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.

    • Uses of Marshaller in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement Marshaller
      Modifier and Type Class and Description
      class  AbstractMarshallerImpl
      Partial default Marshaller implementation.

    • Uses of Marshaller in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type Marshaller
      Constructor and Description
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.Marshaller.Listener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.Marshaller.Listener

  • Packages that use Marshaller.Listener
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of Marshaller.Listener in javax.xml.bind

      Methods in javax.xml.bind that return Marshaller.Listener
      Modifier and Type Method and Description
      Marshaller.Listener Marshaller.getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Methods in javax.xml.bind with parameters of type Marshaller.Listener
      Modifier and Type Method and Description
      void Marshaller.setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.

    • Uses of Marshaller.Listener in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Marshaller.Listener
      Modifier and Type | Method and Description
      Marshaller.Listener | AbstractMarshallerImpl.getListener()
      Methods in javax.xml.bind.helpers with parameters of type Marshaller.Listener
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setListener(Marshaller.Listener listener)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.NotIdentifiableEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.NotIdentifiableEvent

  • Packages that use NotIdentifiableEvent
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of NotIdentifiableEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement NotIdentifiableEvent
      Modifier and Type Class and Description
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.ParseConversionEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ParseConversionEvent

  • Packages that use ParseConversionEvent
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ParseConversionEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ParseConversionEvent
      Modifier and Type Class and Description
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.PrintConversionEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.PrintConversionEvent

  • Packages that use PrintConversionEvent
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of PrintConversionEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement PrintConversionEvent
      Modifier and Type Class and Description
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.PropertyException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.PropertyException

  • Packages that use PropertyException
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of PropertyException in javax.xml.bind

      Methods in javax.xml.bind that throw PropertyException
      Modifier and Type Method and Description
      Object Marshaller.getProperty(String name)
      Get the particular property in the underlying implementation of Marshaller.
      abstract Object Binder.getProperty(String name)
      Get the particular property in the underlying implementation of Binder.
      Object Validator.getProperty(String name)
      Deprecated.
      since JAXB2.0
      Object Unmarshaller.getProperty(String name)
      Get the particular property in the underlying implementation of Unmarshaller.
      void Marshaller.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Marshaller.
      abstract void Binder.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Binder.
      void Validator.setProperty(String name, Object value)
      Deprecated.
      since JAXB2.0
      void Unmarshaller.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Unmarshaller.

    • Uses of PropertyException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw PropertyException
      Modifier and Type Method and Description
      Object AbstractMarshallerImpl.getProperty(String name)
      Default implementation of the getProperty method handles the four defined properties in Marshaller.
      Object AbstractUnmarshallerImpl.getProperty(String name)
      Default implementation of the getProperty method always throws PropertyException since there are no required properties.
      void AbstractMarshallerImpl.setProperty(String name, Object value)
      Default implementation of the setProperty method handles the four defined properties in Marshaller.
      void AbstractUnmarshallerImpl.setProperty(String name, Object value)
      Default implementation of the setProperty method always throws PropertyException since there are no required properties.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.SchemaOutputResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.SchemaOutputResolver

  • Packages that use SchemaOutputResolver
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of SchemaOutputResolver in javax.xml.bind

      Methods in javax.xml.bind with parameters of type SchemaOutputResolver
      Modifier and Type Method and Description
      void JAXBContext.generateSchema(SchemaOutputResolver outputResolver)
      Generates the schema documents for this context.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.TypeConstraintException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.TypeConstraintException

No usage of javax.xml.bind.TypeConstraintException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.UnmarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.UnmarshalException

  • Packages that use UnmarshalException
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of UnmarshalException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return UnmarshalException
      Modifier and Type Method and Description
      protected UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.Unmarshaller (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Unmarshaller

  • Packages that use Unmarshaller
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of Unmarshaller in javax.xml.bind

      Methods in javax.xml.bind that return Unmarshaller
      Modifier and Type Method and Description
      abstract Unmarshaller JAXBContext.createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.

    • Uses of Unmarshaller in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement Unmarshaller
      Modifier and Type Class and Description
      class  AbstractUnmarshallerImpl
      Partial default Unmarshaller implementation.

    • Uses of Unmarshaller in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type Unmarshaller
      Constructor and Description
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.Unmarshaller.Listener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.Unmarshaller.Listener

  • Packages that use Unmarshaller.Listener
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of Unmarshaller.Listener in javax.xml.bind

      Methods in javax.xml.bind that return Unmarshaller.Listener
      Modifier and Type Method and Description
      Unmarshaller.Listener Unmarshaller.getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Methods in javax.xml.bind with parameters of type Unmarshaller.Listener
      Modifier and Type Method and Description
      void Unmarshaller.setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

    • Uses of Unmarshaller.Listener in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Unmarshaller.Listener
      Modifier and Type | Method and Description
      Unmarshaller.Listener | AbstractUnmarshallerImpl.getListener()
      Methods in javax.xml.bind.helpers with parameters of type Unmarshaller.Listener
      Modifier and Type | Method and Description
      void | AbstractUnmarshallerImpl.setListener(Unmarshaller.Listener listener)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.UnmarshallerHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.UnmarshallerHandler

  • Packages that use UnmarshallerHandler
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of UnmarshallerHandler in javax.xml.bind

      Methods in javax.xml.bind that return UnmarshallerHandler
      Modifier and Type Method and Description
      UnmarshallerHandler Unmarshaller.getUnmarshallerHandler()
      Get an unmarshaller handler object that can be used as a component in an XML pipeline.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.ValidationEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ValidationEvent

  • Packages that use ValidationEvent
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of ValidationEvent in javax.xml.bind

      Subinterfaces of ValidationEvent in javax.xml.bind
      Modifier and Type Interface and Description
      interface  NotIdentifiableEvent
      This event indicates that a problem was encountered resolving an ID/IDREF.
      interface  ParseConversionEvent
      This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
      interface  PrintConversionEvent
      This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
      Methods in javax.xml.bind with parameters of type ValidationEvent
      Modifier and Type Method and Description
      boolean ValidationEventHandler.handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

    • Uses of ValidationEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEvent
      Modifier and Type Class and Description
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
      class  ValidationEventImpl
      Default implementation of the ValidationEvent interface.
      Methods in javax.xml.bind.helpers with parameters of type ValidationEvent
      Modifier and Type | Method and Description
      boolean | DefaultValidationEventHandler.handleEvent(ValidationEvent event)

    • Uses of ValidationEvent in javax.xml.bind.util

      Methods in javax.xml.bind.util that return ValidationEvent
      Modifier and Type Method and Description
      ValidationEvent[] ValidationEventCollector.getEvents()
      Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
      Methods in javax.xml.bind.util with parameters of type ValidationEvent
      Modifier and Type | Method and Description
      boolean | ValidationEventCollector.handleEvent(ValidationEvent event)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.ValidationEventHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ValidationEventHandler

  • Packages that use ValidationEventHandler
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of ValidationEventHandler in javax.xml.bind

      Methods in javax.xml.bind that return ValidationEventHandler
      Modifier and Type Method and Description
      ValidationEventHandler Marshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract ValidationEventHandler Binder.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler Validator.getEventHandler()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Unmarshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Methods in javax.xml.bind with parameters of type ValidationEventHandler
      Modifier and Type Method and Description
      void Marshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      abstract void Binder.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Validator.setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void Unmarshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.

    • Uses of ValidationEventHandler in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation with parameters of type ValidationEventHandler
      Modifier and Type | Method and Description
      ResultT DomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      Source DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of ValidationEventHandler in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEventHandler
      Modifier and Type Class and Description
      class  DefaultValidationEventHandler
      JAXB 1.0 only default validation event handler.
      Methods in javax.xml.bind.helpers that return ValidationEventHandler
      Modifier and Type | Method and Description
      ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
      ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Methods in javax.xml.bind.helpers with parameters of type ValidationEventHandler
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
      void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.

    • Uses of ValidationEventHandler in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement ValidationEventHandler
      Modifier and Type Class and Description
      class  ValidationEventCollector
      ValidationEventHandler implementation that collects all events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.ValidationEventLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.ValidationEventLocator

  • Packages that use ValidationEventLocator
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ValidationEventLocator in javax.xml.bind

      Methods in javax.xml.bind that return ValidationEventLocator
      Modifier and Type Method and Description
      ValidationEventLocator ValidationEvent.getLocator()
      Retrieve the locator for this warning/error.

    • Uses of ValidationEventLocator in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEventLocator
      Modifier and Type Class and Description
      class  ValidationEventLocatorImpl
      Default implementation of the ValidationEventLocator interface.
      Methods in javax.xml.bind.helpers that return ValidationEventLocator
      Modifier and Type | Method and Description
      ValidationEventLocator | ValidationEventImpl.getLocator()
      Methods in javax.xml.bind.helpers with parameters of type ValidationEventLocator
      Modifier and Type Method and Description
      void ValidationEventImpl.setLocator(ValidationEventLocator _locator)
      Set the locator object for this event.
      Constructors in javax.xml.bind.helpers with parameters of type ValidationEventLocator
      Constructor and Description
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new NotIdentifiableEventImpl.
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new NotIdentifiableEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ParseConversionEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ParseConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new PrintConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new PrintConversionEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ValidationEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ValidationEventImpl.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.ValidationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.ValidationException

No usage of javax.xml.bind.ValidationException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.bind.Validator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.bind.Validator

  • Packages that use Validator
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of Validator in javax.xml.bind

      Methods in javax.xml.bind that return Validator
      Modifier and Type Method and Description
      abstract Validator JAXBContext.createValidator()
      Deprecated.
      since JAXB2.0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AbstractMarshallerImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class AbstractMarshallerImpl

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl
  • All Implemented Interfaces:
    Marshaller

    public abstract class AbstractMarshallerImpl
extends Object
implements Marshaller
    Partial default Marshaller implementation.

    This class provides a partial default implementation for the Marshaller interface.

    The only methods that a JAXB Provider has to implement are
marshal(Object, javax.xml.transform.Result),
marshal(Object, javax.xml.stream.XMLStreamWriter), and
marshal(Object, javax.xml.stream.XMLEventWriter).

    Since:
    JAXB1.0
    See Also:
    Marshaller

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.bind.Marshaller

        Marshaller.Listener

    • Field Summary

      • Fields inherited from interface javax.xml.bind.Marshaller

        JAXB_ENCODING, JAXB_FORMATTED_OUTPUT, JAXB_FRAGMENT, JAXB_NO_NAMESPACE_SCHEMA_LOCATION, JAXB_SCHEMA_LOCATION

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractMarshallerImpl()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentMarshaller getAttachmentMarshaller()
      protected String getEncoding()
      Convenience method for getting the current output encoding.
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      protected String getJavaEncoding(String encoding)
      Gets the corresponding Java encoding name from an IANA name.
      Marshaller.Listener getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Node getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      protected String getNoNSSchemaLocation()
      Convenience method for getting the current noNamespaceSchemaLocation.
      Object getProperty(String name)
      Default implementation of the getProperty method handles the four defined properties in Marshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      protected String getSchemaLocation()
      Convenience method for getting the current schemaLocation.
      protected boolean isFormattedOutput()
      Convenience method for getting the formatted output flag.
      protected boolean isFragment()
      Convenience method for getting the fragment flag.
      void marshal(Object obj, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void marshal(Object obj, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void marshal(Object obj, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void marshal(Object obj, Writer w)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void marshal(Object obj, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      void marshal(Object obj, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
      protected void setEncoding(String encoding)
      Convenience method for setting the output encoding.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      protected void setFormattedOutput(boolean v)
      Convenience method for setting the formatted output flag.
      protected void setFragment(boolean v)
      Convenience method for setting the fragment flag.
      void setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.
      protected void setNoNSSchemaLocation(String location)
      Convenience method for setting the noNamespaceSchemaLocation.
      void setProperty(String name, Object value)
      Default implementation of the setProperty method handles the four defined properties in Marshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.
      protected void setSchemaLocation(String location)
      Convenience method for setting the schemaLocation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.Marshaller

        marshal

    • Constructor Detail

      • AbstractMarshallerImpl

        public AbstractMarshallerImpl()

    • Method Detail

      • marshal

        public final void marshal(Object obj,
                          OutputStream os)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into an output stream.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The root of content tree to be marshalled.
        os - XML will be added to this stream.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public void marshal(Object jaxbElement,
                    File output)
             throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a file.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        jaxbElement - The root of content tree to be marshalled.
        output - File to be written. If this file already exists, it will be overwritten.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
                          Writer w)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a Writer.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The root of content tree to be marshalled.
        w - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
                          ContentHandler handler)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into SAX2 events.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The root of content tree to be marshalled.
        handler - XML will be sent to this handler as SAX2 events.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
                          Node node)
                   throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a DOM tree.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The content tree to be marshalled.
        node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.

      • getNode

        public Node getNode(Object obj)
             throws JAXBException
        By default, the getNode method is unsupported and throw an UnsupportedOperationException. Implementations that choose to support this method must override this method.
        Specified by:
        getNode in interface Marshaller
        Parameters:
        obj - - JAXB Java representation of XML content
        Returns:
        the DOM tree view of the contentTree
        Throws:
        JAXBException - If any unexpected problem occurs

      • getEncoding

        protected String getEncoding()
        Convenience method for getting the current output encoding.
        Returns:
        the current encoding or "UTF-8" if it hasn't been set.

      • setEncoding

        protected void setEncoding(String encoding)
        Convenience method for setting the output encoding.
        Parameters:
        encoding - a valid encoding as specified in the Marshaller class documentation

      • getSchemaLocation

        protected String getSchemaLocation()
        Convenience method for getting the current schemaLocation.
        Returns:
        the current schemaLocation or null if it hasn't been set

      • setSchemaLocation

        protected void setSchemaLocation(String location)
        Convenience method for setting the schemaLocation.
        Parameters:
        location - the schemaLocation value

      • getNoNSSchemaLocation

        protected String getNoNSSchemaLocation()
        Convenience method for getting the current noNamespaceSchemaLocation.
        Returns:
        the current noNamespaceSchemaLocation or null if it hasn't been set

      • setNoNSSchemaLocation

        protected void setNoNSSchemaLocation(String location)
        Convenience method for setting the noNamespaceSchemaLocation.
        Parameters:
        location - the noNamespaceSchemaLocation value

      • isFormattedOutput

        protected boolean isFormattedOutput()
        Convenience method for getting the formatted output flag.
        Returns:
        the current value of the formatted output flag or false if it hasn't been set.

      • setFormattedOutput

        protected void setFormattedOutput(boolean v)
        Convenience method for setting the formatted output flag.
        Parameters:
        v - value of the formatted output flag.

      • isFragment

        protected boolean isFragment()
        Convenience method for getting the fragment flag.
        Returns:
        the current value of the fragment flag or false if it hasn't been set.

      • setFragment

        protected void setFragment(boolean v)
        Convenience method for setting the fragment flag.
        Parameters:
        v - value of the fragment flag.

      • getJavaEncoding

        protected String getJavaEncoding(String encoding)
                          throws UnsupportedEncodingException
        Gets the corresponding Java encoding name from an IANA name. This method is a helper method for the derived class to convert encoding names.
        Throws:
        UnsupportedEncodingException - If this implementation couldn't find the Java encoding name.

      • setProperty

        public void setProperty(String name,
                        Object value)
                 throws PropertyException
        Default implementation of the setProperty method handles the four defined properties in Marshaller. If a provider needs to handle additional properties, it should override this method in a derived class.
        Specified by:
        setProperty in interface Marshaller
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value

      • getProperty

        public Object getProperty(String name)
                   throws PropertyException
        Default implementation of the getProperty method handles the four defined properties in Marshaller. If a provider needs to support additional provider specific properties, it should override this method in a derived class.
        Specified by:
        getProperty in interface Marshaller
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name

      • getEventHandler

        public ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Description copied from interface: Marshaller
        Return the current event handler or the default event handler if one hasn't been set.
        Specified by:
        getEventHandler in interface Marshaller
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler
        See Also:
        Marshaller.getEventHandler()

      • setEventHandler

        public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Description copied from interface: Marshaller
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

        Specified by:
        setEventHandler in interface Marshaller
        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler
        See Also:
        Marshaller.setEventHandler(ValidationEventHandler)

      • marshal

        public void marshal(Object obj,
                    XMLEventWriter writer)
             throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The content tree rooted at jaxbElement to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public void marshal(Object obj,
                    XMLStreamWriter writer)
             throws JAXBException
        Description copied from interface: Marshaller
        Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
        Specified by:
        marshal in interface Marshaller
        Parameters:
        obj - The content tree to be marshalled.
        writer - XML will be sent to this writer.
        Throws:
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • setSchema

        public void setSchema(Schema schema)
        Description copied from interface: Marshaller
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

        This method allows the caller to validate the marshalled XML as it's marshalled.

        Initially this property is set to null.

        Specified by:
        setSchema in interface Marshaller
        Parameters:
        schema - Schema object to validate marshal operations against or null to disable validation

      • getSchema

        public Schema getSchema()
        Description copied from interface: Marshaller
        Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.
        Specified by:
        getSchema in interface Marshaller
        Returns:
        the Schema object being used to perform marshal-time validation or null if not present.

      • setAdapter

        public void setAdapter(XmlAdapter adapter)
        Description copied from interface: Marshaller
        Associates a configured instance of XmlAdapter with this marshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Specified by:
        setAdapter in interface Marshaller
        See Also:
        Marshaller.setAdapter(Class,XmlAdapter)

      • setAdapter

        public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                              A adapter)
        Description copied from interface: Marshaller
        Associates a configured instance of XmlAdapter with this marshaller.

        Every marshaller internally maintains a Map<Class,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

        Specified by:
        setAdapter in interface Marshaller
        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

      • getAdapter

        public <A extends XmlAdapter> A getAdapter(Class<A> type)
        Description copied from interface: Marshaller
        Gets the adapter associated with the specified type. This is the reverse operation of the Marshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Specified by:
        getAdapter in interface Marshaller

      • setAttachmentMarshaller

        public void setAttachmentMarshaller(AttachmentMarshaller am)
        Description copied from interface: Marshaller

        Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

        Specified by:
        setAttachmentMarshaller in interface Marshaller

      • getAttachmentMarshaller

        public AttachmentMarshaller getAttachmentMarshaller()
        Specified by:
        getAttachmentMarshaller in interface Marshaller

      • setListener

        public void setListener(Marshaller.Listener listener)
        Description copied from interface: Marshaller

        Register marshal event callback Marshaller.Listener with this Marshaller.

        There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Specified by:
        setListener in interface Marshaller
        Parameters:
        listener - an instance of a class that implements Marshaller.Listener

      • getListener

        public Marshaller.Listener getListener()
        Description copied from interface: Marshaller

        Return Marshaller.Listener registered with this Marshaller.

        Specified by:
        getListener in interface Marshaller
        Returns:
        registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AbstractUnmarshallerImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class AbstractUnmarshallerImpl

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl
  • All Implemented Interfaces:
    Unmarshaller

    public abstract class AbstractUnmarshallerImpl
extends Object
implements Unmarshaller
    Partial default Unmarshaller implementation.

    This class provides a partial default implementation for the Unmarshallerinterface.

    A JAXB Provider has to implement five methods (getUnmarshallerHandler, unmarshal(Node), unmarshal(XMLReader,InputSource), unmarshal(XMLStreamReader), and unmarshal(XMLEventReader).

    Since:
    JAXB1.0
    See Also:
    Unmarshaller

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.bind.Unmarshaller

        Unmarshaller.Listener

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean validating
      whether or not the unmarshaller will validate

    • Constructor Summary

      Constructors
      Constructor and Description
      AbstractUnmarshallerImpl()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      protected UnmarshalException createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.
      <A extends XmlAdapter>
      A             		getAdapter(Class<A> type)
      Gets the adapter associated with the specified type.
      AttachmentUnmarshaller getAttachmentUnmarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Unmarshaller.Listener getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Object getProperty(String name)
      Default implementation of the getProperty method always throws PropertyException since there are no required properties.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      protected XMLReader getXMLReader()
      Obtains a configured XMLReader.
      boolean isValidating()
      Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
      <A extends XmlAdapter>
      void             		setAdapter(Class<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
      void setProperty(String name, Object value)
      Default implementation of the setProperty method always throws PropertyException since there are no required properties.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void setValidating(boolean validating)
      Specifies whether or not the Unmarshaller should validate during unmarshal operations.
      Object unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Node node, Class<T> expectedType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Source source, Class<T> expectedType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLEventReader reader, Class<T> expectedType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      protected abstract Object unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.
      Object unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLStreamReader reader, Class<T> expectedType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.Unmarshaller

        getUnmarshallerHandler, unmarshal

    • Field Detail

      • validating

        protected boolean validating
        whether or not the unmarshaller will validate

    • Constructor Detail

      • AbstractUnmarshallerImpl

        public AbstractUnmarshallerImpl()

    • Method Detail

      • getXMLReader

        protected XMLReader getXMLReader()
                          throws JAXBException
        Obtains a configured XMLReader. This method is used when the client-specified SAXSource object doesn't have XMLReader. Unmarshaller is not re-entrant, so we will only use one instance of XMLReader.
        Throws:
        JAXBException

      • unmarshal

        public Object unmarshal(Source source)
                 throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified XML Source and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        SAX 2.0 Parser Pluggability

        A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

        This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

        The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        See Also:
        Unmarshaller.unmarshal(javax.xml.transform.Source, Class)

      • unmarshal

        protected abstract Object unmarshal(XMLReader reader,
                                    InputSource source)
                             throws JAXBException
        Unmarshals an object by using the specified XMLReader and the InputSource. The callee should call the setErrorHandler method of the XMLReader so that errors are passed to the client-specified ValidationEventHandler.
        Throws:
        JAXBException

      • unmarshal

        public final Object unmarshal(InputSource source)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        source - the input source to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(URL url)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified URL and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        url - the url to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(File f)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified file and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        f - the file to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(InputStream is)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        is - the InputStream to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(Reader reader)
                       throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

        Implements Unmarshal Global Root Element.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - the Reader to unmarshal XML data from
        Returns:
        the newly created root object of the java content tree
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • isValidating

        public boolean isValidating()
                     throws JAXBException
        Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

        Note: I named this method isValidating() to stay in-line with JAXP, as opposed to naming it getValidating().

        Specified by:
        isValidating in interface Unmarshaller
        Returns:
        true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
        Throws:
        JAXBException - if an error occurs while retrieving the validating flag

      • setEventHandler

        public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a validation event handler before invoking the unmarshal methods, then all validation events will be silently ignored and may result in unexpected behaviour.

        Specified by:
        setEventHandler in interface Unmarshaller
        Parameters:
        handler - the validation event handler
        Throws:
        JAXBException - if an error was encountered while setting the event handler

      • setValidating

        public void setValidating(boolean validating)
                   throws JAXBException
        Specifies whether or not the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

        This method may only be invoked before or after calling one of the unmarshal methods.

        Specified by:
        setValidating in interface Unmarshaller
        Parameters:
        validating - true if the Unmarshaller should validate during unmarshal, false otherwise
        Throws:
        JAXBException - if an error occurred while enabling or disabling validation at unmarshal time

      • getEventHandler

        public ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        Specified by:
        getEventHandler in interface Unmarshaller
        Returns:
        the current ValidationEventHandler or the default event handler if it hasn't been set
        Throws:
        JAXBException - if an error was encountered while getting the current event handler

      • createUnmarshalException

        protected UnmarshalException createUnmarshalException(SAXException e)
        Creates an UnmarshalException from a SAXException. This is an utility method provided for the derived classes.

        When a provider-implemented ContentHandler wants to throw a JAXBException, it needs to wrap the exception by a SAXException. If the unmarshaller implementation blindly wrap SAXException by JAXBException, such an exception will be a JAXBException wrapped by a SAXException wrapped by another JAXBException. This is silly.

        This method checks the nested exception of SAXException and reduce those excessive wrapping.

        Returns:
        the resulting UnmarshalException

      • setProperty

        public void setProperty(String name,
                        Object value)
                 throws PropertyException
        Default implementation of the setProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.
        Specified by:
        setProperty in interface Unmarshaller
        Parameters:
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        Throws:
        PropertyException - when there is an error processing the given property or value

      • getProperty

        public Object getProperty(String name)
                   throws PropertyException
        Default implementation of the getProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.
        Specified by:
        getProperty in interface Unmarshaller
        Parameters:
        name - the name of the property to retrieve
        Returns:
        the value of the requested property
        Throws:
        PropertyException - when there is an error retrieving the given property or value property name

      • unmarshal

        public Object unmarshal(XMLEventReader reader)
                 throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        This method is an Unmarshal Global Root method.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        See Also:
        Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader, Class)

      • unmarshal

        public Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        Returns:
        the newly created root object of the java content tree.
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        See Also:
        Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader, Class)

      • unmarshal

        public <T> JAXBElement<T> unmarshal(Node node,
                                    Class<T> expectedType)
                             throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        expectedType - appropriate JAXB mapped class to hold node's XML data.
        Returns:
        JAXB Element representation of node
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(Source source,
                                    Class<T> expectedType)
                             throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        See SAX 2.0 Parser Pluggability

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        expectedType - appropriate JAXB mapped class to hold source's xml root element
        Returns:
        Java content rooted by JAXB Element
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                                    Class<T> expectedType)
                             throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                                    Class<T> expectedType)
                             throws JAXBException
        Description copied from interface: Unmarshaller
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        Specified by:
        unmarshal in interface Unmarshaller
        Parameters:
        reader - The parser to be read.
        expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        Returns:
        content tree rooted by JAXB Element representation
        Throws:
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • setSchema

        public void setSchema(Schema schema)
        Description copied from interface: Unmarshaller
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

        This method replaces the deprecated setValidating(boolean) API.

        Initially this property is set to null.

        Specified by:
        setSchema in interface Unmarshaller
        Parameters:
        schema - Schema object to validate unmarshal operations against or null to disable validation

      • getSchema

        public Schema getSchema()
        Description copied from interface: Unmarshaller
        Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

        This method provides replacement functionality for the deprecated Unmarshaller.isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

        boolean isValidating = u.getSchema()!=null;

        Specified by:
        getSchema in interface Unmarshaller
        Returns:
        the Schema object being used to perform unmarshal-time validation or null if not present

      • setAdapter

        public void setAdapter(XmlAdapter adapter)
        Description copied from interface: Unmarshaller
        Associates a configured instance of XmlAdapter with this unmarshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        Specified by:
        setAdapter in interface Unmarshaller
        See Also:
        Unmarshaller.setAdapter(Class,XmlAdapter)

      • setAdapter

        public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                              A adapter)
        Description copied from interface: Unmarshaller
        Associates a configured instance of XmlAdapter with this unmarshaller.

        Every unmarshaller internally maintains a Map<Class,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

        Specified by:
        setAdapter in interface Unmarshaller
        Parameters:
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

      • getAdapter

        public <A extends XmlAdapter> A getAdapter(Class<A> type)
        Description copied from interface: Unmarshaller
        Gets the adapter associated with the specified type. This is the reverse operation of the Unmarshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        Specified by:
        getAdapter in interface Unmarshaller

      • setAttachmentUnmarshaller

        public void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
        Description copied from interface: Unmarshaller

        Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

        Unmarshal time validation, enabled via Unmarshaller.setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

        Specified by:
        setAttachmentUnmarshaller in interface Unmarshaller

      • getAttachmentUnmarshaller

        public AttachmentUnmarshaller getAttachmentUnmarshaller()
        Specified by:
        getAttachmentUnmarshaller in interface Unmarshaller

      • setListener

        public void setListener(Unmarshaller.Listener listener)
        Description copied from interface: Unmarshaller

        Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

        There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        Specified by:
        setListener in interface Unmarshaller
        Parameters:
        listener - provides unmarshal event callbacks for this Unmarshaller

      • getListener

        public Unmarshaller.Listener getListener()
        Description copied from interface: Unmarshaller

        Return Unmarshaller.Listener registered with this Unmarshaller.

        Specified by:
        getListener in interface Unmarshaller
        Returns:
        registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultValidationEventHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class DefaultValidationEventHandler

  • java.lang.Object
    • javax.xml.bind.helpers.DefaultValidationEventHandler
  • All Implemented Interfaces:
    ValidationEventHandler

    public class DefaultValidationEventHandler
extends Object
implements ValidationEventHandler

    JAXB 1.0 only default validation event handler. This is the default handler for all objects created from a JAXBContext that is managing schema-derived code generated by a JAXB 1.0 binding compiler.

    This handler causes the unmarshal and validate operations to fail on the first error or fatal error.

    This handler is not the default handler for JAXB mapped classes following JAXB 2.0 or later versions. Default validation event handling has changed and is specified in Unmarshaller and Marshaller.

    Since:
    JAXB1.0
    See Also:
    Unmarshaller, Validator, ValidationEventHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultValidationEventHandler()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefaultValidationEventHandler

        public DefaultValidationEventHandler()

    • Method Detail

      • handleEvent

        public boolean handleEvent(ValidationEvent event)
        Description copied from interface: ValidationEventHandler
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        Specified by:
        handleEvent in interface ValidationEventHandler
        Parameters:
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        Returns:
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotIdentifiableEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class NotIdentifiableEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.NotIdentifiableEventImpl
  • All Implemented Interfaces:
    NotIdentifiableEvent, ValidationEvent

    public class NotIdentifiableEventImpl
extends ValidationEventImpl
implements NotIdentifiableEvent
    Default implementation of the NotIdentifiableEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    See Also:
    NotIdentifiableEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new NotIdentifiableEventImpl.
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new NotIdentifiableEventImpl.

    • Method Summary

      • Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • Constructor Detail

      • NotIdentifiableEventImpl

        public NotIdentifiableEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
        Create a new NotIdentifiableEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • NotIdentifiableEventImpl

        public NotIdentifiableEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
        Create a new NotIdentifiableEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.helpers (Java Platform SE 8 )

javax.xml.bind.helpers

Classes

  • AbstractMarshallerImpl
  • AbstractUnmarshallerImpl
  • DefaultValidationEventHandler
  • NotIdentifiableEventImpl
  • ParseConversionEventImpl
  • PrintConversionEventImpl
  • ValidationEventImpl
  • ValidationEventLocatorImpl


javax.xml.bind.helpers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.helpers

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

See: Description

  • Class Summary
    Class Description
    AbstractMarshallerImpl
    Partial default Marshaller implementation.
    AbstractUnmarshallerImpl
    Partial default Unmarshaller implementation.
    DefaultValidationEventHandler
    JAXB 1.0 only default validation event handler.
    NotIdentifiableEventImpl
    Default implementation of the NotIdentifiableEvent interface.
    ParseConversionEventImpl
    Default implementation of the ParseConversionEvent interface.
    PrintConversionEventImpl
    Default implementation of the PrintConversionEvent interface.
    ValidationEventImpl
    Default implementation of the ValidationEvent interface.
    ValidationEventLocatorImpl
    Default implementation of the ValidationEventLocator interface.

Package javax.xml.bind.helpers Description

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

JAXB Providers can extend these classes and implement the abstract methods.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.helpers Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.helpers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.bind.helpers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.helpers

  • Packages that use javax.xml.bind.helpers
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.helpers used by javax.xml.bind.helpers
    Class and Description
    ValidationEventImpl
    Default implementation of the ValidationEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParseConversionEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class ParseConversionEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.ParseConversionEventImpl
  • All Implemented Interfaces:
    ParseConversionEvent, ValidationEvent

    public class ParseConversionEventImpl
extends ValidationEventImpl
implements ParseConversionEvent
    Default implementation of the ParseConversionEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    See Also:
    ParseConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ParseConversionEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ParseConversionEventImpl.

    • Method Summary

      • Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • Constructor Detail

      • ParseConversionEventImpl

        public ParseConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
        Create a new ParseConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • ParseConversionEventImpl

        public ParseConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
        Create a new ParseConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PrintConversionEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class PrintConversionEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.PrintConversionEventImpl
  • All Implemented Interfaces:
    PrintConversionEvent, ValidationEvent

    public class PrintConversionEventImpl
extends ValidationEventImpl
implements PrintConversionEvent
    Default implementation of the PrintConversionEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    See Also:
    PrintConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new PrintConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new PrintConversionEventImpl.

    • Method Summary

      • Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • Constructor Detail

      • PrintConversionEventImpl

        public PrintConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
        Create a new PrintConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • PrintConversionEventImpl

        public PrintConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
        Create a new PrintConversionEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class ValidationEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
  • All Implemented Interfaces:
    ValidationEvent
    Direct Known Subclasses:
    NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl

    public class ValidationEventImpl
extends Object
implements ValidationEvent
    Default implementation of the ValidationEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    See Also:
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Field Summary

      • Fields inherited from interface javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ValidationEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ValidationEventImpl.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getLinkedException()
      Retrieve the linked exception for this warning/error.
      ValidationEventLocator getLocator()
      Retrieve the locator for this warning/error.
      String getMessage()
      Retrieve the text message for this warning/error.
      int getSeverity()
      Retrieve the severity code for this warning/error.
      void setLinkedException(Throwable _linkedException)
      Set the linked exception field of this event.
      void setLocator(ValidationEventLocator _locator)
      Set the locator object for this event.
      void setMessage(String _message)
      Set the message field of this event.
      void setSeverity(int _severity)
      Set the severity field of this event.
      String toString()
      Returns a string representation of this object in a format helpful to debugging.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationEventImpl

        public ValidationEventImpl(int _severity,
                           String _message,
                           ValidationEventLocator _locator)
        Create a new ValidationEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • ValidationEventImpl

        public ValidationEventImpl(int _severity,
                           String _message,
                           ValidationEventLocator _locator,
                           Throwable _linkedException)
        Create a new ValidationEventImpl.
        Parameters:
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

    • Method Detail

      • getSeverity

        public int getSeverity()
        Description copied from interface: ValidationEvent
        Retrieve the severity code for this warning/error.

        Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

        Specified by:
        getSeverity in interface ValidationEvent
        Returns:
        the severity code for this warning/error

      • setSeverity

        public void setSeverity(int _severity)
        Set the severity field of this event.
        Parameters:
        _severity - Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR.
        Throws:
        IllegalArgumentException - if an illegal severity field is supplied

      • getMessage

        public String getMessage()
        Description copied from interface: ValidationEvent
        Retrieve the text message for this warning/error.
        Specified by:
        getMessage in interface ValidationEvent
        Returns:
        the text message for this warning/error or null if one wasn't set

      • setMessage

        public void setMessage(String _message)
        Set the message field of this event.
        Parameters:
        _message - String message - may be null.

      • getLinkedException

        public Throwable getLinkedException()
        Description copied from interface: ValidationEvent
        Retrieve the linked exception for this warning/error.
        Specified by:
        getLinkedException in interface ValidationEvent
        Returns:
        the linked exception for this warning/error or null if one wasn't set

      • setLinkedException

        public void setLinkedException(Throwable _linkedException)
        Set the linked exception field of this event.
        Parameters:
        _linkedException - Optional linked exception - may be null.

      • getLocator

        public ValidationEventLocator getLocator()
        Description copied from interface: ValidationEvent
        Retrieve the locator for this warning/error.
        Specified by:
        getLocator in interface ValidationEvent
        Returns:
        the locator that indicates where the warning/error occurred

      • setLocator

        public void setLocator(ValidationEventLocator _locator)
        Set the locator object for this event.
        Parameters:
        _locator - The locator - may be null.

      • toString

        public String toString()
        Returns a string representation of this object in a format helpful to debugging.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.
        See Also:
        Object.equals(Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationEventLocatorImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.helpers

Class ValidationEventLocatorImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventLocatorImpl
  • All Implemented Interfaces:
    ValidationEventLocator

    public class ValidationEventLocatorImpl
extends Object
implements ValidationEventLocator
    Default implementation of the ValidationEventLocator interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEventLocator interface. This class is just provided for a convenience.

    Since:
    JAXB1.0
    See Also:
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationEventLocatorImpl()
      Creates an object with all fields unavailable.
      ValidationEventLocatorImpl(Locator loc)
      Constructs an object from an org.xml.sax.Locator.
      ValidationEventLocatorImpl(Node _node)
      Constructs an object that points to a DOM Node.
      ValidationEventLocatorImpl(Object _object)
      Constructs an object that points to a JAXB content object.
      ValidationEventLocatorImpl(SAXParseException e)
      Constructs an object from the location information of a SAXParseException.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the column number if available
      int getLineNumber()
      Return the line number if available
      Node getNode()
      Return a reference to the DOM Node if available
      Object getObject()
      Return a reference to the object in the Java content tree if available
      int getOffset()
      Return the byte offset if available
      URL getURL()
      Return the name of the XML source as a URL if available
      void setColumnNumber(int _columnNumber)
      Set the columnNumber field on this event locator.
      void setLineNumber(int _lineNumber)
      Set the lineNumber field on this event locator.
      void setNode(Node _node)
      Set the Node field on this event locator.
      void setObject(Object _object)
      Set the Object field on this event locator.
      void setOffset(int _offset)
      Set the offset field on this event locator.
      void setURL(URL _url)
      Set the URL field on this event locator.
      String toString()
      Returns a string representation of this object in a format helpful to debugging.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl()
        Creates an object with all fields unavailable.

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Locator loc)
        Constructs an object from an org.xml.sax.Locator. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.
        Parameters:
        loc - the SAX Locator object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the Locator is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(SAXParseException e)
        Constructs an object from the location information of a SAXParseException. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.
        Parameters:
        e - the SAXParseException object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the SAXParseException is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Node _node)
        Constructs an object that points to a DOM Node. The object's Node becomes available. ColumnNumber, LineNumber, Object, Offset, and URL are not available.
        Parameters:
        _node - the DOM Node object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the Node is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Object _object)
        Constructs an object that points to a JAXB content object. The object's Object becomes available. ColumnNumber, LineNumber, Node, Offset, and URL are not available.
        Parameters:
        _object - the Object that will be used to populate this event locator.
        Throws:
        IllegalArgumentException - if the Object is null

    • Method Detail

      • getURL

        public URL getURL()
        Description copied from interface: ValidationEventLocator
        Return the name of the XML source as a URL if available
        Specified by:
        getURL in interface ValidationEventLocator
        Returns:
        the name of the XML source as a URL or null if unavailable
        See Also:
        ValidationEventLocator.getURL()

      • setURL

        public void setURL(URL _url)
        Set the URL field on this event locator. Null values are allowed.
        Parameters:
        _url - the url

      • getOffset

        public int getOffset()
        Description copied from interface: ValidationEventLocator
        Return the byte offset if available
        Specified by:
        getOffset in interface ValidationEventLocator
        Returns:
        the byte offset into the input source or -1 if unavailable
        See Also:
        ValidationEventLocator.getOffset()

      • setOffset

        public void setOffset(int _offset)
        Set the offset field on this event locator.
        Parameters:
        _offset - the offset

      • getLineNumber

        public int getLineNumber()
        Description copied from interface: ValidationEventLocator
        Return the line number if available
        Specified by:
        getLineNumber in interface ValidationEventLocator
        Returns:
        the line number or -1 if unavailable
        See Also:
        ValidationEventLocator.getLineNumber()

      • setLineNumber

        public void setLineNumber(int _lineNumber)
        Set the lineNumber field on this event locator.
        Parameters:
        _lineNumber - the line number

      • getColumnNumber

        public int getColumnNumber()
        Description copied from interface: ValidationEventLocator
        Return the column number if available
        Specified by:
        getColumnNumber in interface ValidationEventLocator
        Returns:
        the column number or -1 if unavailable
        See Also:
        ValidationEventLocator.getColumnNumber()

      • setColumnNumber

        public void setColumnNumber(int _columnNumber)
        Set the columnNumber field on this event locator.
        Parameters:
        _columnNumber - the column number

      • getObject

        public Object getObject()
        Description copied from interface: ValidationEventLocator
        Return a reference to the object in the Java content tree if available
        Specified by:
        getObject in interface ValidationEventLocator
        Returns:
        a reference to the object in the Java content tree or null if unavailable
        See Also:
        ValidationEventLocator.getObject()

      • setObject

        public void setObject(Object _object)
        Set the Object field on this event locator. Null values are allowed.
        Parameters:
        _object - the java content object

      • getNode

        public Node getNode()
        Description copied from interface: ValidationEventLocator
        Return a reference to the DOM Node if available
        Specified by:
        getNode in interface ValidationEventLocator
        Returns:
        a reference to the DOM Node or null if unavailable
        See Also:
        ValidationEventLocator.getNode()

      • setNode

        public void setNode(Node _node)
        Set the Node field on this event locator. Null values are allowed.
        Parameters:
        _node - the Node

      • toString

        public String toString()
        Returns a string representation of this object in a format helpful to debugging.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.
        See Also:
        Object.equals(Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.AbstractMarshallerImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.AbstractMarshallerImpl

No usage of javax.xml.bind.helpers.AbstractMarshallerImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.AbstractUnmarshallerImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.AbstractUnmarshallerImpl

No usage of javax.xml.bind.helpers.AbstractUnmarshallerImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.DefaultValidationEventHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.DefaultValidationEventHandler

No usage of javax.xml.bind.helpers.DefaultValidationEventHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.NotIdentifiableEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.NotIdentifiableEventImpl

No usage of javax.xml.bind.helpers.NotIdentifiableEventImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.ParseConversionEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.ParseConversionEventImpl

No usage of javax.xml.bind.helpers.ParseConversionEventImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.PrintConversionEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.PrintConversionEventImpl

No usage of javax.xml.bind.helpers.PrintConversionEventImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.ValidationEventImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.ValidationEventImpl

  • Packages that use ValidationEventImpl
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ValidationEventImpl in javax.xml.bind.helpers

      Subclasses of ValidationEventImpl in javax.xml.bind.helpers
      Modifier and Type Class and Description
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.helpers.ValidationEventLocatorImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.helpers.ValidationEventLocatorImpl

No usage of javax.xml.bind.helpers.ValidationEventLocatorImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.util

Class JAXBResult

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult
      • javax.xml.bind.util.JAXBResult
  • All Implemented Interfaces:
    Result

    public class JAXBResult
extends SAXResult
    JAXP Result implementation that unmarshals a JAXB object.

    This utility class is useful to combine JAXB with other Java/XML technologies.

    The following example shows how to use JAXB to unmarshal a document resulting from an XSLT transformation.

           JAXBResult result = new JAXBResult(
         JAXBContext.newInstance("org.acme.foo") );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(new StreamSource("document.xml"),result);

       // obtain the unmarshalled content tree
       Object o = result.getResult();

    The fact that JAXBResult derives from SAXResult is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXResult.

    In particular it shall never attempt to call the setHandler, setLexicalHandler, and setSystemId methods.

    • Field Summary

      • Fields inherited from class javax.xml.transform.sax.SAXResult

        FEATURE

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Object getResult()
      Gets the unmarshalled object created by the transformation.

      • Methods inherited from class javax.xml.transform.sax.SAXResult

        getHandler, getLexicalHandler, getSystemId, setHandler, setLexicalHandler, setSystemId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBResult

        public JAXBResult(JAXBContext context)
           throws JAXBException
        Creates a new instance that uses the specified JAXBContext to unmarshal.
        Parameters:
        context - The JAXBContext that will be used to create the necessary Unmarshaller. This parameter must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBResult or if the context parameter is null.

      • JAXBResult

        public JAXBResult(Unmarshaller _unmarshaller)
           throws JAXBException
        Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

        This JAXBResult object will use the specified Unmarshaller instance. It is the caller's responsibility not to use the same Unmarshaller for other purposes while it is being used by this object.

        The primary purpose of this method is to allow the client to configure Unmarshaller. Unless you know what you are doing, it's easier and safer to pass a JAXBContext.

        Parameters:
        _unmarshaller - the unmarshaller. This parameter must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBResult or the Unmarshaller parameter is null.

    • Method Detail

      • getResult

        public Object getResult()
                 throws JAXBException
        Gets the unmarshalled object created by the transformation.
        Returns:
        Always return a non-null object.
        Throws:
        IllegalStateException - if this method is called before an object is unmarshalled.
        JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


JAXBSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.util

Class JAXBSource

  • java.lang.Object
    • javax.xml.transform.sax.SAXSource
      • javax.xml.bind.util.JAXBSource
  • All Implemented Interfaces:
    Source

    public class JAXBSource
extends SAXSource
    JAXP Source implementation that marshals a JAXB-generated object.

    This utility class is useful to combine JAXB with other Java/XML technologies.

    The following example shows how to use JAXB to marshal a document for transformation by XSLT.

           MyObject o = // get JAXB content tree

       // jaxbContext is a JAXBContext object from which 'o' is created.
       JAXBSource source = new JAXBSource( jaxbContext, o );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(source,new StreamResult(System.out));

    The fact that JAXBSource derives from SAXSource is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXSource. In particular, the setXMLReader and setInputSource methods shall never be called. The XMLReader object obtained by the getXMLReader method shall be used only for parsing the InputSource object returned by the getInputSource method.

    Similarly the InputSource object obtained by the getInputSource method shall be used only for being parsed by the XMLReader object returned by the getXMLReader.

    • Field Summary

      • Fields inherited from class javax.xml.transform.sax.SAXSource

        FEATURE

    • Constructor Summary

      Constructors
      Constructor and Description
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.

    • Method Summary

      • Methods inherited from class javax.xml.transform.sax.SAXSource

        getInputSource, getSystemId, getXMLReader, setInputSource, setSystemId, setXMLReader, sourceToInputSource

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • JAXBSource

        public JAXBSource(JAXBContext context,
                  Object contentObject)
           throws JAXBException
        Creates a new Source for the given content object.
        Parameters:
        context - JAXBContext that was used to create contentObject. This context is used to create a new instance of marshaller and must not be null.
        contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.

      • JAXBSource

        public JAXBSource(Marshaller marshaller,
                  Object contentObject)
           throws JAXBException
        Creates a new Source for the given content object.
        Parameters:
        marshaller - A marshaller instance that will be used to marshal contentObject into XML. This must be created from a JAXBContext that was used to build contentObject and must not be null.
        contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
        Throws:
        JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.util (Java Platform SE 8 )

javax.xml.bind.util

Classes

  • JAXBResult
  • JAXBSource
  • ValidationEventCollector


javax.xml.bind.util (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.bind.util

Useful client utility classes.

See: Description

  • Class Summary
    Class Description
    JAXBResult
    JAXP Result implementation that unmarshals a JAXB object.
    JAXBSource
    JAXP Source implementation that marshals a JAXB-generated object.
    ValidationEventCollector
    ValidationEventHandler implementation that collects all events.

Package javax.xml.bind.util Description

Useful client utility classes.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.bind.util Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.bind.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.bind.util (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.bind.util

No usage of javax.xml.bind.util
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidationEventCollector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.bind.util

Class ValidationEventCollector

  • java.lang.Object
    • javax.xml.bind.util.ValidationEventCollector
  • All Implemented Interfaces:
    ValidationEventHandler

    public class ValidationEventCollector
extends Object
implements ValidationEventHandler
    ValidationEventHandler implementation that collects all events.

    To use this class, create a new instance and pass it to the setEventHandler method of the Validator, Unmarshaller, Marshaller class. After the call to validate or unmarshal completes, call the getEvents method to retrieve all the reported errors and warnings.

    Since:
    JAXB1.0
    See Also:
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • Constructor Summary

      Constructors
      Constructor and Description
      ValidationEventCollector()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      ValidationEvent[] getEvents()
      Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.
      boolean hasEvents()
      Returns true if this event collector contains at least one ValidationEvent.
      void reset()
      Clear all collected errors and warnings.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValidationEventCollector

        public ValidationEventCollector()

    • Method Detail

      • getEvents

        public ValidationEvent[] getEvents()
        Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
        Returns:
        a copy of all the collected errors and warnings or an empty array if there weren't any

      • reset

        public void reset()
        Clear all collected errors and warnings.

      • hasEvents

        public boolean hasEvents()
        Returns true if this event collector contains at least one ValidationEvent.
        Returns:
        true if this event collector contains at least one ValidationEvent, false otherwise

      • handleEvent

        public boolean handleEvent(ValidationEvent event)
        Description copied from interface: ValidationEventHandler
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        Specified by:
        handleEvent in interface ValidationEventHandler
        Parameters:
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        Returns:
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.util.JAXBResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.util.JAXBResult

No usage of javax.xml.bind.util.JAXBResult
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.util.JAXBSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.util.JAXBSource

No usage of javax.xml.bind.util.JAXBSource
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.bind.util.ValidationEventCollector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.bind.util.ValidationEventCollector

No usage of javax.xml.bind.util.ValidationEventCollector
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.XMLConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.XMLConstants

No usage of javax.xml.XMLConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AlgorithmMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface AlgorithmMethod

  • All Known Subinterfaces:
    CanonicalizationMethod, DigestMethod, SignatureMethod, Transform
    All Known Implementing Classes:
    TransformService

    public interface AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications. Subclasses represent specific types of XML security algorithms, such as a Transform.
    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getAlgorithm()
      Returns the algorithm URI of this AlgorithmMethod.
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm parameters of this AlgorithmMethod.

    • Method Detail

      • getAlgorithm

        String getAlgorithm()
        Returns the algorithm URI of this AlgorithmMethod.
        Returns:
        the algorithm URI of this AlgorithmMethod

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm parameters of this AlgorithmMethod.
        Returns:
        the algorithm parameters of this AlgorithmMethod. Returns null if this AlgorithmMethod does not require parameters and they are not specified.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.crypto (Java Platform SE 8 )

compact3 - javax.xml.crypto

Interfaces

  • AlgorithmMethod
  • Data
  • KeySelectorResult
  • NodeSetData
  • URIDereferencer
  • URIReference
  • XMLCryptoContext
  • XMLStructure

Classes

  • KeySelector
  • KeySelector.Purpose
  • OctetStreamData

Exceptions

  • KeySelectorException
  • MarshalException
  • NoSuchMechanismException
  • URIReferenceException


javax.xml.crypto (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.crypto

Common classes for XML cryptography.

See: Description

  • Interface Summary
    Interface Description
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    NodeSetData
    An abstract representation of a Data type containing a node-set.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Class Summary
    Class Description
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    KeySelector.Purpose
    The purpose of the key that is to be selected.
    OctetStreamData
    A representation of a Data type containing an octet stream.
  • Exception Summary
    Exception Description
    KeySelectorException
    Indicates an exceptional condition thrown by a KeySelector.
    MarshalException
    Indicates an exceptional condition that occurred during the XML marshalling or unmarshalling process.
    NoSuchMechanismException
    This exception is thrown when a particular XML mechanism is requested but is not available in the environment.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.

Package javax.xml.crypto Description

Common classes for XML cryptography. This package includes common classes that are used to perform XML cryptographic operations, such as generating an XML signature or encrypting XML data.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Data (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface Data

  • All Known Subinterfaces:
    NodeSetData
    All Known Implementing Classes:
    OctetStreamData

    public interface Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms. The primary purpose of this interface is to group and provide type safety for all Data subtypes.
    Since:
    1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeySelector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class KeySelector

  • java.lang.Object
    • javax.xml.crypto.KeySelector

  • public abstract class KeySelector
extends Object
    A selector that finds and returns a key using the data contained in a KeyInfo object. An example of an implementation of this class is one that searches a KeyStore for trusted keys that match information contained in a KeyInfo.

    Whether or not the returned key is trusted and the mechanisms used to determine that is implementation-specific.

    Since:
    1.6

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  KeySelector.Purpose
      The purpose of the key that is to be selected.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected KeySelector()
      Default no-args constructor; intended for invocation by subclasses only.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract KeySelectorResult select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.
      static KeySelector singletonKeySelector(Key key)
      Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • KeySelector

        protected KeySelector()
        Default no-args constructor; intended for invocation by subclasses only.

    • Method Detail

      • select

        public abstract KeySelectorResult select(KeyInfo keyInfo,
                                         KeySelector.Purpose purpose,
                                         AlgorithmMethod method,
                                         XMLCryptoContext context)
                                  throws KeySelectorException
        Attempts to find a key that satisfies the specified constraints.
        Parameters:
        keyInfo - a KeyInfo (may be null)
        purpose - the key's purpose (KeySelector.Purpose.SIGN, KeySelector.Purpose.VERIFY, KeySelector.Purpose.ENCRYPT, or KeySelector.Purpose.DECRYPT)
        method - the algorithm method that this key is to be used for. Only keys that are compatible with the algorithm and meet the constraints of the specified algorithm should be returned.
        context - an XMLCryptoContext that may contain useful information for finding an appropriate key. If this key selector supports resolving RetrievalMethod types, the context's baseURI and dereferencer parameters (if specified) should be used by the selector to resolve and dereference the URI.
        Returns:
        the result of the key selector
        Throws:
        KeySelectorException - if an exceptional condition occurs while attempting to find a key. Note that an inability to find a key is not considered an exception (null should be returned in that case). However, an error condition (ex: network communications failure) that prevented the KeySelector from finding a potential key should be considered an exception.
        ClassCastException - if the data type of method is not supported by this key selector

      • singletonKeySelector

        public static KeySelector singletonKeySelector(Key key)
        Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.
        Parameters:
        key - the sole key to be stored in the key selector
        Returns:
        a key selector that always selects the specified key
        Throws:
        NullPointerException - if key is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeySelector.Purpose (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class KeySelector.Purpose

  • java.lang.Object
    • javax.xml.crypto.KeySelector.Purpose
  • Enclosing class:
    KeySelector

    public static class KeySelector.Purpose
extends Object
    The purpose of the key that is to be selected.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static KeySelector.Purpose DECRYPT
      A key for decrypting.
      static KeySelector.Purpose ENCRYPT
      A key for encrypting.
      static KeySelector.Purpose SIGN
      A key for signing.
      static KeySelector.Purpose VERIFY
      A key for verifying.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String toString()
      Returns a string representation of this purpose ("sign", "verify", "encrypt", or "decrypt").

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • SIGN

        public static final KeySelector.Purpose SIGN
        A key for signing.

      • VERIFY

        public static final KeySelector.Purpose VERIFY
        A key for verifying.

      • ENCRYPT

        public static final KeySelector.Purpose ENCRYPT
        A key for encrypting.

      • DECRYPT

        public static final KeySelector.Purpose DECRYPT
        A key for decrypting.

    • Method Detail

      • toString

        public String toString()
        Returns a string representation of this purpose ("sign", "verify", "encrypt", or "decrypt").
        Overrides:
        toString in class Object
        Returns:
        a string representation of this purpose
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeySelectorException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class KeySelectorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.KeySelectorException
  • All Implemented Interfaces:
    Serializable

    public class KeySelectorException
extends Exception
    Indicates an exceptional condition thrown by a KeySelector.

    A KeySelectorException can contain a cause: another throwable that caused this KeySelectorException to get thrown.

    Since:
    1.6
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      KeySelectorException()
      Constructs a new KeySelectorException with null as its detail message.
      KeySelectorException(String message)
      Constructs a new KeySelectorException with the specified detail message.
      KeySelectorException(String message, Throwable cause)
      Constructs a new KeySelectorException with the specified detail message and cause.
      KeySelectorException(Throwable cause)
      Constructs a new KeySelectorException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this KeySelectorException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this KeySelectorException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print writer.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • KeySelectorException

        public KeySelectorException()
        Constructs a new KeySelectorException with null as its detail message.

      • KeySelectorException

        public KeySelectorException(String message)
        Constructs a new KeySelectorException with the specified detail message.
        Parameters:
        message - the detail message

      • KeySelectorException

        public KeySelectorException(String message,
                            Throwable cause)
        Constructs a new KeySelectorException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • KeySelectorException

        public KeySelectorException(Throwable cause)
        Constructs a new KeySelectorException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getCause

        public Throwable getCause()
        Returns the cause of this KeySelectorException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this KeySelectorException to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this KeySelectorException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this KeySelectorException, its backtrace and the cause's backtrace to the standard error stream.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print stream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print writer.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeySelectorResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface KeySelectorResult

  • public interface KeySelectorResult
    The result returned by the KeySelector.select method.

    At a minimum, a KeySelectorResult contains the Key selected by the KeySelector. Implementations of this interface may add methods to return implementation or algorithm specific information, such as a chain of certificates or debugging information.

    Since:
    1.6
    See Also:
    KeySelector

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Key getKey()
      Returns the selected key.

    • Method Detail

      • getKey

        Key getKey()
        Returns the selected key.
        Returns:
        the selected key, or null if none can be found
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class MarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.MarshalException
  • All Implemented Interfaces:
    Serializable

    public class MarshalException
extends Exception
    Indicates an exceptional condition that occurred during the XML marshalling or unmarshalling process.

    A MarshalException can contain a cause: another throwable that caused this MarshalException to get thrown.

    Since:
    1.6
    See Also:
    XMLSignature.sign(XMLSignContext), XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      MarshalException()
      Constructs a new MarshalException with null as its detail message.
      MarshalException(String message)
      Constructs a new MarshalException with the specified detail message.
      MarshalException(String message, Throwable cause)
      Constructs a new MarshalException with the specified detail message and cause.
      MarshalException(Throwable cause)
      Constructs a new MarshalException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this MarshalException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this MarshalException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this MarshalException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this MarshalException, its backtrace and the cause's backtrace to the specified print writer.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MarshalException

        public MarshalException()
        Constructs a new MarshalException with null as its detail message.

      • MarshalException

        public MarshalException(String message)
        Constructs a new MarshalException with the specified detail message.
        Parameters:
        message - the detail message

      • MarshalException

        public MarshalException(String message,
                        Throwable cause)
        Constructs a new MarshalException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • MarshalException

        public MarshalException(Throwable cause)
        Constructs a new MarshalException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getCause

        public Throwable getCause()
        Returns the cause of this MarshalException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this MarshalException to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this MarshalException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this MarshalException, its backtrace and the cause's backtrace to the standard error stream.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this MarshalException, its backtrace and the cause's backtrace to the specified print stream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this MarshalException, its backtrace and the cause's backtrace to the specified print writer.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NodeSetData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface NodeSetData

  • All Superinterfaces:
    Data

    public interface NodeSetData
extends Data
    An abstract representation of a Data type containing a node-set. The type (class) and ordering of the nodes contained in the set are not defined by this class; instead that behavior should be defined by NodeSetData subclasses.
    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Iterator iterator()
      Returns a read-only iterator over the nodes contained in this NodeSetData in document order.

    • Method Detail

      • iterator

        Iterator iterator()
        Returns a read-only iterator over the nodes contained in this NodeSetData in document order. Attempts to modify the returned iterator via the remove method throw UnsupportedOperationException.
        Returns:
        an Iterator over the nodes in this NodeSetData in document order
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NoSuchMechanismException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class NoSuchMechanismException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.crypto.NoSuchMechanismException
  • All Implemented Interfaces:
    Serializable

    public class NoSuchMechanismException
extends RuntimeException
    This exception is thrown when a particular XML mechanism is requested but is not available in the environment.

    A NoSuchMechanismException can contain a cause: another throwable that caused this NoSuchMechanismException to get thrown.

    Since:
    1.6
    See Also:
    XMLSignatureFactory.getInstance, KeyInfoFactory.getInstance, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      NoSuchMechanismException()
      Constructs a new NoSuchMechanismException with null as its detail message.
      NoSuchMechanismException(String message)
      Constructs a new NoSuchMechanismException with the specified detail message.
      NoSuchMechanismException(String message, Throwable cause)
      Constructs a new NoSuchMechanismException with the specified detail message and cause.
      NoSuchMechanismException(Throwable cause)
      Constructs a new NoSuchMechanismException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print writer.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoSuchMechanismException

        public NoSuchMechanismException()
        Constructs a new NoSuchMechanismException with null as its detail message.

      • NoSuchMechanismException

        public NoSuchMechanismException(String message)
        Constructs a new NoSuchMechanismException with the specified detail message.
        Parameters:
        message - the detail message

      • NoSuchMechanismException

        public NoSuchMechanismException(String message,
                                Throwable cause)
        Constructs a new NoSuchMechanismException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • NoSuchMechanismException

        public NoSuchMechanismException(Throwable cause)
        Constructs a new NoSuchMechanismException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getCause

        public Throwable getCause()
        Returns the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this NoSuchMechanismException to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the standard error stream.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print stream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print writer.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OctetStreamData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class OctetStreamData

  • java.lang.Object
    • javax.xml.crypto.OctetStreamData
  • All Implemented Interfaces:
    Data

    public class OctetStreamData
extends Object
implements Data
    A representation of a Data type containing an octet stream.
    Since:
    1.6

    • Constructor Summary

      Constructors
      Constructor and Description
      OctetStreamData(InputStream octetStream)
      Creates a new OctetStreamData.
      OctetStreamData(InputStream octetStream, String uri, String mimeType)
      Creates a new OctetStreamData.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getMimeType()
      Returns the MIME type associated with the data object represented by this OctetStreamData.
      InputStream getOctetStream()
      Returns the input stream of this OctetStreamData.
      String getURI()
      Returns the URI String identifying the data object represented by this OctetStreamData.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • OctetStreamData

        public OctetStreamData(InputStream octetStream)
        Creates a new OctetStreamData.
        Parameters:
        octetStream - the input stream containing the octets
        Throws:
        NullPointerException - if octetStream is null

      • OctetStreamData

        public OctetStreamData(InputStream octetStream,
                       String uri,
                       String mimeType)
        Creates a new OctetStreamData.
        Parameters:
        octetStream - the input stream containing the octets
        uri - the URI String identifying the data object (may be null)
        mimeType - the MIME type associated with the data object (may be null)
        Throws:
        NullPointerException - if octetStream is null

    • Method Detail

      • getOctetStream

        public InputStream getOctetStream()
        Returns the input stream of this OctetStreamData.
        Returns:
        the input stream of this OctetStreamData.

      • getURI

        public String getURI()
        Returns the URI String identifying the data object represented by this OctetStreamData.
        Returns:
        the URI String or null if not applicable

      • getMimeType

        public String getMimeType()
        Returns the MIME type associated with the data object represented by this OctetStreamData.
        Returns:
        the MIME type or null if not applicable
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto (Java Platform SE 8 )

javax.xml.crypto

Interfaces

  • AlgorithmMethod
  • Data
  • KeySelectorResult
  • NodeSetData
  • URIDereferencer
  • URIReference
  • XMLCryptoContext
  • XMLStructure

Classes

  • KeySelector
  • KeySelector.Purpose
  • OctetStreamData

Exceptions

  • KeySelectorException
  • MarshalException
  • NoSuchMechanismException
  • URIReferenceException


javax.xml.crypto (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.crypto

Common classes for XML cryptography.

See: Description

  • Interface Summary
    Interface Description
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    NodeSetData
    An abstract representation of a Data type containing a node-set.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Class Summary
    Class Description
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    KeySelector.Purpose
    The purpose of the key that is to be selected.
    OctetStreamData
    A representation of a Data type containing an octet stream.
  • Exception Summary
    Exception Description
    KeySelectorException
    Indicates an exceptional condition thrown by a KeySelector.
    MarshalException
    Indicates an exceptional condition that occurred during the XML marshalling or unmarshalling process.
    NoSuchMechanismException
    This exception is thrown when a particular XML mechanism is requested but is not available in the environment.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.

Package javax.xml.crypto Description

Common classes for XML cryptography. This package includes common classes that are used to perform XML cryptographic operations, such as generating an XML signature or encrypting XML data.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.crypto

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.KeySelector
    • javax.xml.crypto.KeySelector.Purpose
    • javax.xml.crypto.OctetStreamData (implements javax.xml.crypto.Data)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.crypto.KeySelectorException
        • javax.xml.crypto.MarshalException
        • java.lang.RuntimeException
          • javax.xml.crypto.NoSuchMechanismException
        • javax.xml.crypto.URIReferenceException

Interface Hierarchy

  • javax.xml.crypto.AlgorithmMethod
  • javax.xml.crypto.Data
    • javax.xml.crypto.NodeSetData
  • javax.xml.crypto.KeySelectorResult
  • javax.xml.crypto.URIDereferencer
  • javax.xml.crypto.URIReference
  • javax.xml.crypto.XMLCryptoContext
  • javax.xml.crypto.XMLStructure
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.crypto (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.crypto

  • Packages that use javax.xml.crypto
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.
  • Classes in javax.xml.crypto used by javax.xml.crypto
    Class and Description
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    KeySelector.Purpose
    The purpose of the key that is to be selected.
    KeySelectorException
    Indicates an exceptional condition thrown by a KeySelector.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dom
    Class and Description
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig
    Class and Description
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    MarshalException
    Indicates an exceptional condition that occurred during the XML marshalling or unmarshalling process.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig.dom
    Class and Description
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig.keyinfo
    Class and Description
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    MarshalException
    Indicates an exceptional condition that occurred during the XML marshalling or unmarshalling process.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig.spec
    Class and Description
    XMLStructure
    A representation of an XML structure from any namespace.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


URIDereferencer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface URIDereferencer

  • public interface URIDereferencer
    A dereferencer of URIReferences.

    The result of dereferencing a URIReference is either an instance of OctetStreamData or NodeSetData. Unless the URIReference is a same-document reference as defined in section 4.2 of the W3C Recommendation for XML-Signature Syntax and Processing, the result of dereferencing the URIReference MUST be an OctetStreamData.

    Since:
    1.6
    See Also:
    XMLCryptoContext.setURIDereferencer(URIDereferencer), XMLCryptoContext.getURIDereferencer()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Data dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.

    • Method Detail

      • dereference

        Data dereference(URIReference uriReference,
                 XMLCryptoContext context)
          throws URIReferenceException
        Dereferences the specified URIReference and returns the dereferenced data.
        Parameters:
        uriReference - the URIReference
        context - an XMLCryptoContext that may contain additional useful information for dereferencing the URI. This implementation should dereference the specified URIReference against the context's baseURI parameter, if specified.
        Returns:
        the dereferenced data
        Throws:
        NullPointerException - if uriReference or context are null
        URIReferenceException - if an exception occurs while dereferencing the specified uriReference
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


URIReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface URIReference

  • All Known Subinterfaces:
    DOMURIReference, Reference, RetrievalMethod

    public interface URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.

    Note that some subclasses may not have a type attribute and for objects of those types, the getType() method always returns null.

    Since:
    1.6
    See Also:
    URIDereferencer

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getType()
      Returns the type of data referenced by this URI.
      String getURI()
      Returns the URI of the referenced data object.

    • Method Detail

      • getURI

        String getURI()
        Returns the URI of the referenced data object.
        Returns:
        the URI of the data object in RFC 2396 format (may be null if not specified)

      • getType

        String getType()
        Returns the type of data referenced by this URI.
        Returns:
        the type (a URI) of the data object (may be null if not specified)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


URIReferenceException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Class URIReferenceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.URIReferenceException
  • All Implemented Interfaces:
    Serializable

    public class URIReferenceException
extends Exception
    Indicates an exceptional condition thrown while dereferencing a URIReference.

    A URIReferenceException can contain a cause: another throwable that caused this URIReferenceException to get thrown.

    Since:
    1.6
    See Also:
    URIDereferencer.dereference(URIReference, XMLCryptoContext), RetrievalMethod.dereference(XMLCryptoContext), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      URIReferenceException()
      Constructs a new URIReferenceException with null as its detail message.
      URIReferenceException(String message)
      Constructs a new URIReferenceException with the specified detail message.
      URIReferenceException(String message, Throwable cause)
      Constructs a new URIReferenceException with the specified detail message and cause.
      URIReferenceException(String message, Throwable cause, URIReference uriReference)
      Constructs a new URIReferenceException with the specified detail message, cause and URIReference.
      URIReferenceException(Throwable cause)
      Constructs a new URIReferenceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this URIReferenceException or null if the cause is nonexistent or unknown.
      URIReference getURIReference()
      Returns the URIReference that was being dereferenced when the exception was thrown.
      void printStackTrace()
      Prints this URIReferenceException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print writer.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • URIReferenceException

        public URIReferenceException()
        Constructs a new URIReferenceException with null as its detail message.

      • URIReferenceException

        public URIReferenceException(String message)
        Constructs a new URIReferenceException with the specified detail message.
        Parameters:
        message - the detail message

      • URIReferenceException

        public URIReferenceException(String message,
                             Throwable cause)
        Constructs a new URIReferenceException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • URIReferenceException

        public URIReferenceException(String message,
                             Throwable cause,
                             URIReference uriReference)
        Constructs a new URIReferenceException with the specified detail message, cause and URIReference.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        uriReference - the URIReference that was being dereferenced when the error was encountered
        Throws:
        NullPointerException - if uriReference is null

      • URIReferenceException

        public URIReferenceException(Throwable cause)
        Constructs a new URIReferenceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getURIReference

        public URIReference getURIReference()
        Returns the URIReference that was being dereferenced when the exception was thrown.
        Returns:
        the URIReference that was being dereferenced when the exception was thrown, or null if not specified

      • getCause

        public Throwable getCause()
        Returns the cause of this URIReferenceException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this URIReferenceException to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this URIReferenceException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this URIReferenceException, its backtrace and the cause's backtrace to the standard error stream.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print stream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print writer.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLCryptoContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface XMLCryptoContext

  • All Known Subinterfaces:
    XMLSignContext, XMLValidateContext
    All Known Implementing Classes:
    DOMCryptoContext, DOMSignContext, DOMValidateContext

    public interface XMLCryptoContext
    Contains common context information for XML cryptographic operations.

    This interface contains methods for setting and retrieving properties that affect the processing of XML signatures or XML encrypted structures.

    Note that XMLCryptoContext instances can contain information and state specific to the XML cryptographic structure it is used with. The results are unpredictable if an XMLCryptoContext is used with multiple structures (for example, you should not use the same XMLValidateContext instance to validate two different XMLSignature objects).

    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object get(Object key)
      Returns the value to which this context maps the specified key.
      String getBaseURI()
      Returns the base URI.
      String getDefaultNamespacePrefix()
      Returns the default namespace prefix.
      KeySelector getKeySelector()
      Returns the key selector for finding a key.
      String getNamespacePrefix(String namespaceURI, String defaultPrefix)
      Returns the namespace prefix that the specified namespace URI is associated with.
      Object getProperty(String name)
      Returns the value of the specified property.
      URIDereferencer getURIDereferencer()
      Returns a URIDereferencer that is used to dereference URIReferences.
      Object put(Object key, Object value)
      Associates the specified value with the specified key in this context.
      String putNamespacePrefix(String namespaceURI, String prefix)
      Maps the specified namespace URI to the specified prefix.
      void setBaseURI(String baseURI)
      Sets the base URI.
      void setDefaultNamespacePrefix(String defaultPrefix)
      Sets the default namespace prefix.
      void setKeySelector(KeySelector ks)
      Sets the key selector for finding a key.
      Object setProperty(String name, Object value)
      Sets the specified property.
      void setURIDereferencer(URIDereferencer dereferencer)
      Sets a URIDereferencer that is used to dereference URIReferences.

    • Method Detail

      • getBaseURI

        String getBaseURI()
        Returns the base URI.
        Returns:
        the base URI, or null if not specified
        See Also:
        setBaseURI(String)

      • setBaseURI

        void setBaseURI(String baseURI)
        Sets the base URI.
        Parameters:
        baseURI - the base URI, or null to remove current value
        Throws:
        IllegalArgumentException - if baseURI is not RFC 2396 compliant
        See Also:
        getBaseURI()

      • getKeySelector

        KeySelector getKeySelector()
        Returns the key selector for finding a key.
        Returns:
        the key selector, or null if not specified
        See Also:
        setKeySelector(KeySelector)

      • setKeySelector

        void setKeySelector(KeySelector ks)
        Sets the key selector for finding a key.
        Parameters:
        ks - the key selector, or null to remove the current setting
        See Also:
        getKeySelector()

      • getURIDereferencer

        URIDereferencer getURIDereferencer()
        Returns a URIDereferencer that is used to dereference URIReferences.
        Returns:
        the URIDereferencer, or null if not specified
        See Also:
        setURIDereferencer(URIDereferencer)

      • setURIDereferencer

        void setURIDereferencer(URIDereferencer dereferencer)
        Sets a URIDereferencer that is used to dereference URIReferences. The specified URIDereferencer is used in place of an implementation's default URIDereferencer.
        Parameters:
        dereferencer - the URIDereferencer, or null to remove any current setting
        See Also:
        getURIDereferencer()

      • getNamespacePrefix

        String getNamespacePrefix(String namespaceURI,
                          String defaultPrefix)
        Returns the namespace prefix that the specified namespace URI is associated with. Returns the specified default prefix if the specified namespace URI has not been bound to a prefix. To bind a namespace URI to a prefix, call the putNamespacePrefix method.
        Parameters:
        namespaceURI - a namespace URI
        defaultPrefix - the prefix to be returned in the event that the the specified namespace URI has not been bound to a prefix.
        Returns:
        the prefix that is associated with the specified namespace URI, or defaultPrefix if the URI is not registered. If the namespace URI is registered but has no prefix, an empty string ("") is returned.
        Throws:
        NullPointerException - if namespaceURI is null
        See Also:
        putNamespacePrefix(String, String)

      • putNamespacePrefix

        String putNamespacePrefix(String namespaceURI,
                          String prefix)
        Maps the specified namespace URI to the specified prefix. If there is already a prefix associated with the specified namespace URI, the old prefix is replaced by the specified prefix.
        Parameters:
        namespaceURI - a namespace URI
        prefix - a namespace prefix (or null to remove any existing mapping). Specifying the empty string ("") binds no prefix to the namespace URI.
        Returns:
        the previous prefix associated with the specified namespace URI, or null if there was none
        Throws:
        NullPointerException - if namespaceURI is null
        See Also:
        getNamespacePrefix(String, String)

      • getDefaultNamespacePrefix

        String getDefaultNamespacePrefix()
        Returns the default namespace prefix. The default namespace prefix is the prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        Returns:
        the default namespace prefix, or null if none has been set.
        See Also:
        setDefaultNamespacePrefix(String)

      • setDefaultNamespacePrefix

        void setDefaultNamespacePrefix(String defaultPrefix)
        Sets the default namespace prefix. This sets the namespace prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        Parameters:
        defaultPrefix - the default namespace prefix, or null to remove the current setting. Specify the empty string ("") to bind no prefix.
        See Also:
        getDefaultNamespacePrefix()

      • setProperty

        Object setProperty(String name,
                   Object value)
        Sets the specified property.
        Parameters:
        name - the name of the property
        value - the value of the property to be set
        Returns:
        the previous value of the specified property, or null if it did not have a value
        Throws:
        NullPointerException - if name is null
        See Also:
        getProperty(String)

      • getProperty

        Object getProperty(String name)
        Returns the value of the specified property.
        Parameters:
        name - the name of the property
        Returns:
        the current value of the specified property, or null if it does not have a value
        Throws:
        NullPointerException - if name is null
        See Also:
        setProperty(String, Object)

      • get

        Object get(Object key)
        Returns the value to which this context maps the specified key.

        More formally, if this context contains a mapping from a key k to a value v such that (key==null ? k==null : key.equals(k)), then this method returns v; otherwise it returns null. (There can be at most one such mapping.)

        This method is useful for retrieving arbitrary information that is specific to the cryptographic operation that this context is used for.

        Parameters:
        key - the key whose associated value is to be returned
        Returns:
        the value to which this context maps the specified key, or null if there is no mapping for the key
        See Also:
        put(Object, Object)

      • put

        Object put(Object key,
           Object value)
        Associates the specified value with the specified key in this context. If the context previously contained a mapping for this key, the old value is replaced by the specified value.

        This method is useful for storing arbitrary information that is specific to the cryptographic operation that this context is used for.

        Parameters:
        key - key with which the specified value is to be associated with
        value - value to be associated with the specified key
        Returns:
        the previous value associated with the key, or null if there was no mapping for the key
        Throws:
        IllegalArgumentException - if some aspect of this key or value prevents it from being stored in this context
        See Also:
        get(Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLStructure (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto

Interface XMLStructure

  • All Known Subinterfaces:
    CanonicalizationMethod, DigestMethod, KeyInfo, KeyName, KeyValue, Manifest, PGPData, Reference, RetrievalMethod, SignatureMethod, SignatureProperties, SignatureProperty, SignedInfo, Transform, X509Data, X509IssuerSerial, XMLObject, XMLSignature, XMLSignature.SignatureValue
    All Known Implementing Classes:
    DOMStructure, TransformService

    public interface XMLStructure
    A representation of an XML structure from any namespace. The purpose of this interface is to group (and provide type safety for) all representations of XML structures.
    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.

    • Method Detail

      • isFeatureSupported

        boolean isFeatureSupported(String feature)
        Indicates whether a specified feature is supported.
        Parameters:
        feature - the feature name (as an absolute URI)
        Returns:
        true if the specified feature is supported, false otherwise
        Throws:
        NullPointerException - if feature is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.AlgorithmMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.AlgorithmMethod

  • Packages that use AlgorithmMethod
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of AlgorithmMethod in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type AlgorithmMethod
      Modifier and Type Method and Description
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of AlgorithmMethod in javax.xml.crypto.dsig

      Subinterfaces of AlgorithmMethod in javax.xml.crypto.dsig
      Modifier and Type Interface and Description
      interface  CanonicalizationMethod
      A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  DigestMethod
      A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureMethod
      A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Transform
      A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Classes in javax.xml.crypto.dsig that implement AlgorithmMethod
      Modifier and Type Class and Description
      class  TransformService
      A Service Provider Interface for transform and canonicalization algorithms.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.Data (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.Data

  • Packages that use Data
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of Data in javax.xml.crypto

      Subinterfaces of Data in javax.xml.crypto
      Modifier and Type Interface and Description
      interface  NodeSetData
      An abstract representation of a Data type containing a node-set.
      Classes in javax.xml.crypto that implement Data
      Modifier and Type Class and Description
      class  OctetStreamData
      A representation of a Data type containing an octet stream.
      Methods in javax.xml.crypto that return Data
      Modifier and Type Method and Description
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.

    • Uses of Data in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Data
      Modifier and Type Method and Description
      Data Reference.getDereferencedData()
      Returns the dereferenced data, if reference caching is enabled.
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.
      Methods in javax.xml.crypto.dsig with parameters of type Data
      Modifier and Type Method and Description
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.

    • Uses of Data in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return Data
      Modifier and Type Method and Description
      Data RetrievalMethod.dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.KeySelector (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.KeySelector

  • Packages that use KeySelector
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of KeySelector in javax.xml.crypto

      Methods in javax.xml.crypto that return KeySelector
      Modifier and Type Method and Description
      KeySelector XMLCryptoContext.getKeySelector()
      Returns the key selector for finding a key.
      static KeySelector KeySelector.singletonKeySelector(Key key)
      Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.
      Methods in javax.xml.crypto with parameters of type KeySelector
      Modifier and Type Method and Description
      void XMLCryptoContext.setKeySelector(KeySelector ks)
      Sets the key selector for finding a key.

    • Uses of KeySelector in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return KeySelector
      Modifier and Type | Method and Description
      KeySelector | DOMCryptoContext.getKeySelector()
      Methods in javax.xml.crypto.dom with parameters of type KeySelector
      Modifier and Type | Method and Description
      void | DOMCryptoContext.setKeySelector(KeySelector ks)

    • Uses of KeySelector in javax.xml.crypto.dsig.dom

      Constructors in javax.xml.crypto.dsig.dom with parameters of type KeySelector
      Constructor and Description
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.KeySelector.Purpose (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.KeySelector.Purpose

  • Packages that use KeySelector.Purpose
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.

    • Uses of KeySelector.Purpose in javax.xml.crypto

      Fields in javax.xml.crypto declared as KeySelector.Purpose
      Modifier and Type Field and Description
      static KeySelector.Purpose KeySelector.Purpose.DECRYPT
      A key for decrypting.
      static KeySelector.Purpose KeySelector.Purpose.ENCRYPT
      A key for encrypting.
      static KeySelector.Purpose KeySelector.Purpose.SIGN
      A key for signing.
      static KeySelector.Purpose KeySelector.Purpose.VERIFY
      A key for verifying.
      Methods in javax.xml.crypto with parameters of type KeySelector.Purpose
      Modifier and Type Method and Description
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.KeySelectorException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.KeySelectorException

  • Packages that use KeySelectorException
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.

    • Uses of KeySelectorException in javax.xml.crypto

      Methods in javax.xml.crypto that throw KeySelectorException
      Modifier and Type Method and Description
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.KeySelectorResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.KeySelectorResult

  • Packages that use KeySelectorResult
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of KeySelectorResult in javax.xml.crypto

      Methods in javax.xml.crypto that return KeySelectorResult
      Modifier and Type Method and Description
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of KeySelectorResult in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return KeySelectorResult
      Modifier and Type Method and Description
      KeySelectorResult XMLSignature.getKeySelectorResult()
      Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.MarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.MarshalException

  • Packages that use MarshalException
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of MarshalException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw MarshalException
      Modifier and Type Method and Description
      abstract void TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.
      void XMLSignature.sign(XMLSignContext signContext)
      Signs this XMLSignature.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.

    • Uses of MarshalException in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that throw MarshalException
      Modifier and Type Method and Description
      void KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.
      abstract KeyInfo KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.NodeSetData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.NodeSetData

No usage of javax.xml.crypto.NodeSetData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.NoSuchMechanismException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.NoSuchMechanismException

No usage of javax.xml.crypto.NoSuchMechanismException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.OctetStreamData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.OctetStreamData

No usage of javax.xml.crypto.OctetStreamData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.URIDereferencer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.URIDereferencer

  • Packages that use URIDereferencer
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of URIDereferencer in javax.xml.crypto

      Methods in javax.xml.crypto that return URIDereferencer
      Modifier and Type Method and Description
      URIDereferencer XMLCryptoContext.getURIDereferencer()
      Returns a URIDereferencer that is used to dereference URIReferences.
      Methods in javax.xml.crypto with parameters of type URIDereferencer
      Modifier and Type Method and Description
      void XMLCryptoContext.setURIDereferencer(URIDereferencer dereferencer)
      Sets a URIDereferencer that is used to dereference URIReferences.

    • Uses of URIDereferencer in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return URIDereferencer
      Modifier and Type | Method and Description
      URIDereferencer | DOMCryptoContext.getURIDereferencer()
      Methods in javax.xml.crypto.dom with parameters of type URIDereferencer
      Modifier and Type | Method and Description
      void | DOMCryptoContext.setURIDereferencer(URIDereferencer dereferencer)

    • Uses of URIDereferencer in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return URIDereferencer
      Modifier and Type Method and Description
      abstract URIDereferencer XMLSignatureFactory.getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.

    • Uses of URIDereferencer in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return URIDereferencer
      Modifier and Type Method and Description
      abstract URIDereferencer KeyInfoFactory.getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.URIReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.URIReference

  • Packages that use URIReference
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of URIReference in javax.xml.crypto

      Methods in javax.xml.crypto that return URIReference
      Modifier and Type Method and Description
      URIReference URIReferenceException.getURIReference()
      Returns the URIReference that was being dereferenced when the exception was thrown.
      Methods in javax.xml.crypto with parameters of type URIReference
      Modifier and Type Method and Description
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.
      Constructors in javax.xml.crypto with parameters of type URIReference
      Constructor and Description
      URIReferenceException(String message, Throwable cause, URIReference uriReference)
      Constructs a new URIReferenceException with the specified detail message, cause and URIReference.

    • Uses of URIReference in javax.xml.crypto.dom

      Subinterfaces of URIReference in javax.xml.crypto.dom
      Modifier and Type Interface and Description
      interface  DOMURIReference
      A DOM-specific URIReference.

    • Uses of URIReference in javax.xml.crypto.dsig

      Subinterfaces of URIReference in javax.xml.crypto.dsig
      Modifier and Type Interface and Description
      interface  Reference
      A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

    • Uses of URIReference in javax.xml.crypto.dsig.keyinfo

      Subinterfaces of URIReference in javax.xml.crypto.dsig.keyinfo
      Modifier and Type Interface and Description
      interface  RetrievalMethod
      A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.URIReferenceException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.URIReferenceException

  • Packages that use URIReferenceException
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of URIReferenceException in javax.xml.crypto

      Methods in javax.xml.crypto that throw URIReferenceException
      Modifier and Type Method and Description
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.

    • Uses of URIReferenceException in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that throw URIReferenceException
      Modifier and Type Method and Description
      Data RetrievalMethod.dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.XMLCryptoContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.XMLCryptoContext

  • Packages that use XMLCryptoContext
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of XMLCryptoContext in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type XMLCryptoContext
      Modifier and Type Method and Description
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of XMLCryptoContext in javax.xml.crypto.dom

      Classes in javax.xml.crypto.dom that implement XMLCryptoContext
      Modifier and Type Class and Description
      class  DOMCryptoContext
      This class provides a DOM-specific implementation of the XMLCryptoContext interface.

    • Uses of XMLCryptoContext in javax.xml.crypto.dsig

      Subinterfaces of XMLCryptoContext in javax.xml.crypto.dsig
      Modifier and Type Interface and Description
      interface  XMLSignContext
      Contains context information for generating XML Signatures.
      interface  XMLValidateContext
      Contains context information for validating XML Signatures.
      Methods in javax.xml.crypto.dsig with parameters of type XMLCryptoContext
      Modifier and Type Method and Description
      abstract void TransformService.init(XMLStructure parent, XMLCryptoContext context)
      Initializes this TransformService with the specified parameters and document context.
      abstract void TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.

    • Uses of XMLCryptoContext in javax.xml.crypto.dsig.dom

      Classes in javax.xml.crypto.dsig.dom that implement XMLCryptoContext
      Modifier and Type Class and Description
      class  DOMSignContext
      A DOM-specific XMLSignContext.
      class  DOMValidateContext
      A DOM-specific XMLValidateContext.

    • Uses of XMLCryptoContext in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type XMLCryptoContext
      Modifier and Type Method and Description
      Data RetrievalMethod.dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
      void KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.XMLStructure (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.XMLStructure

  • Packages that use XMLStructure
    Package Description
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of XMLStructure in javax.xml.crypto.dom

      Classes in javax.xml.crypto.dom that implement XMLStructure
      Modifier and Type Class and Description
      class  DOMStructure
      A DOM-specific XMLStructure.

    • Uses of XMLStructure in javax.xml.crypto.dsig

      Subinterfaces of XMLStructure in javax.xml.crypto.dsig
      Modifier and Type Interface and Description
      interface  CanonicalizationMethod
      A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  DigestMethod
      A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Manifest
      A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Reference
      A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureMethod
      A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureProperties
      A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureProperty
      A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignedInfo
      An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Transform
      A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  XMLObject
      A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  XMLSignature
      A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      static interface  XMLSignature.SignatureValue
      A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Classes in javax.xml.crypto.dsig that implement XMLStructure
      Modifier and Type Class and Description
      class  TransformService
      A Service Provider Interface for transform and canonicalization algorithms.
      Methods in javax.xml.crypto.dsig with parameters of type XMLStructure
      Modifier and Type Method and Description
      abstract void TransformService.init(XMLStructure parent, XMLCryptoContext context)
      Initializes this TransformService with the specified parameters and document context.
      abstract void TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, XMLStructure params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.

    • Uses of XMLStructure in javax.xml.crypto.dsig.keyinfo

      Subinterfaces of XMLStructure in javax.xml.crypto.dsig.keyinfo
      Modifier and Type Interface and Description
      interface  KeyInfo
      A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  KeyName
      A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  KeyValue
      A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  PGPData
      A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  RetrievalMethod
      A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  X509Data
      A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  X509IssuerSerial
      A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type XMLStructure
      Modifier and Type Method and Description
      void KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.
      abstract KeyInfo KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.

    • Uses of XMLStructure in javax.xml.crypto.dsig.spec

      Methods in javax.xml.crypto.dsig.spec that return XMLStructure
      Modifier and Type Method and Description
      XMLStructure XSLTTransformParameterSpec.getStylesheet()
      Returns the stylesheet.
      Constructors in javax.xml.crypto.dsig.spec with parameters of type XMLStructure
      Constructor and Description
      XSLTTransformParameterSpec(XMLStructure stylesheet)
      Creates an XSLTTransformParameterSpec with the specified stylesheet.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.crypto.dom (Java Platform SE 8 )

compact3 - javax.xml.crypto.dom

Interfaces

  • DOMURIReference

Classes

  • DOMCryptoContext
  • DOMStructure


javax.xml.crypto.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.crypto.dom

DOM-specific classes for the javax.xml.crypto package.

See: Description

  • Interface Summary
    Interface Description
    DOMURIReference
    A DOM-specific URIReference.
  • Class Summary
    Class Description
    DOMCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface.
    DOMStructure
    A DOM-specific XMLStructure.

Package javax.xml.crypto.dom Description

DOM-specific classes for the javax.xml.crypto package. Only users who are using a DOM-based XML cryptographic implementations (ex: XMLSignatureFactory or KeyInfoFactory) should need to make direct use of this package.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMCryptoContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dom

Class DOMCryptoContext

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext
  • All Implemented Interfaces:
    XMLCryptoContext
    Direct Known Subclasses:
    DOMSignContext, DOMValidateContext

    public class DOMCryptoContext
extends Object
implements XMLCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface. It also includes additional methods that are specific to a DOM-based implementation for registering and retrieving elements that contain attributes of type ID.
    Since:
    1.6

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DOMCryptoContext()
      Default constructor.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Object get(Object key)
      This implementation uses an internal HashMap to get the object that the specified key maps to.
      String getBaseURI()
      Returns the base URI.
      String getDefaultNamespacePrefix()
      Returns the default namespace prefix.
      Element getElementById(String idValue)
      Returns the Element with the specified ID attribute value.
      KeySelector getKeySelector()
      Returns the key selector for finding a key.
      String getNamespacePrefix(String namespaceURI, String defaultPrefix)
      This implementation uses an internal HashMap to get the prefix that the specified URI maps to.
      Object getProperty(String name)
      This implementation uses an internal HashMap to get the object that the specified name maps to.
      URIDereferencer getURIDereferencer()
      Returns a URIDereferencer that is used to dereference URIReferences.
      Iterator iterator()
      Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext.
      Object put(Object key, Object value)
      This implementation uses an internal HashMap to map the key to the specified object.
      String putNamespacePrefix(String namespaceURI, String prefix)
      This implementation uses an internal HashMap to map the URI to the specified prefix.
      void setBaseURI(String baseURI)
      Sets the base URI.
      void setDefaultNamespacePrefix(String defaultPrefix)
      Sets the default namespace prefix.
      void setIdAttributeNS(Element element, String namespaceURI, String localName)
      Registers the element's attribute specified by the namespace URI and local name to be of type ID.
      void setKeySelector(KeySelector ks)
      Sets the key selector for finding a key.
      Object setProperty(String name, Object value)
      This implementation uses an internal HashMap to map the name to the specified object.
      void setURIDereferencer(URIDereferencer dereferencer)
      Sets a URIDereferencer that is used to dereference URIReferences.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DOMCryptoContext

        protected DOMCryptoContext()
        Default constructor. (For invocation by subclass constructors).

    • Method Detail

      • getNamespacePrefix

        public String getNamespacePrefix(String namespaceURI,
                                 String defaultPrefix)
        This implementation uses an internal HashMap to get the prefix that the specified URI maps to. It returns the defaultPrefix if it maps to null.
        Specified by:
        getNamespacePrefix in interface XMLCryptoContext
        Parameters:
        namespaceURI - a namespace URI
        defaultPrefix - the prefix to be returned in the event that the the specified namespace URI has not been bound to a prefix.
        Returns:
        the prefix that is associated with the specified namespace URI, or defaultPrefix if the URI is not registered. If the namespace URI is registered but has no prefix, an empty string ("") is returned.
        Throws:
        NullPointerException - if namespaceURI is null
        See Also:
        XMLCryptoContext.putNamespacePrefix(String, String)

      • putNamespacePrefix

        public String putNamespacePrefix(String namespaceURI,
                                 String prefix)
        This implementation uses an internal HashMap to map the URI to the specified prefix.
        Specified by:
        putNamespacePrefix in interface XMLCryptoContext
        Parameters:
        namespaceURI - a namespace URI
        prefix - a namespace prefix (or null to remove any existing mapping). Specifying the empty string ("") binds no prefix to the namespace URI.
        Returns:
        the previous prefix associated with the specified namespace URI, or null if there was none
        Throws:
        NullPointerException - if namespaceURI is null
        See Also:
        XMLCryptoContext.getNamespacePrefix(String, String)

      • getDefaultNamespacePrefix

        public String getDefaultNamespacePrefix()
        Description copied from interface: XMLCryptoContext
        Returns the default namespace prefix. The default namespace prefix is the prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        Specified by:
        getDefaultNamespacePrefix in interface XMLCryptoContext
        Returns:
        the default namespace prefix, or null if none has been set.
        See Also:
        XMLCryptoContext.setDefaultNamespacePrefix(String)

      • setDefaultNamespacePrefix

        public void setDefaultNamespacePrefix(String defaultPrefix)
        Description copied from interface: XMLCryptoContext
        Sets the default namespace prefix. This sets the namespace prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        Specified by:
        setDefaultNamespacePrefix in interface XMLCryptoContext
        Parameters:
        defaultPrefix - the default namespace prefix, or null to remove the current setting. Specify the empty string ("") to bind no prefix.
        See Also:
        XMLCryptoContext.getDefaultNamespacePrefix()

      • getBaseURI

        public String getBaseURI()
        Description copied from interface: XMLCryptoContext
        Returns the base URI.
        Specified by:
        getBaseURI in interface XMLCryptoContext
        Returns:
        the base URI, or null if not specified
        See Also:
        XMLCryptoContext.setBaseURI(String)

      • setBaseURI

        public void setBaseURI(String baseURI)
        Description copied from interface: XMLCryptoContext
        Sets the base URI.
        Specified by:
        setBaseURI in interface XMLCryptoContext
        Parameters:
        baseURI - the base URI, or null to remove current value
        Throws:
        IllegalArgumentException - if baseURI is not RFC 2396 compliant
        See Also:
        XMLCryptoContext.getBaseURI()

      • getURIDereferencer

        public URIDereferencer getURIDereferencer()
        Description copied from interface: XMLCryptoContext
        Returns a URIDereferencer that is used to dereference URIReferences.
        Specified by:
        getURIDereferencer in interface XMLCryptoContext
        Returns:
        the URIDereferencer, or null if not specified
        See Also:
        XMLCryptoContext.setURIDereferencer(URIDereferencer)

      • setURIDereferencer

        public void setURIDereferencer(URIDereferencer dereferencer)
        Description copied from interface: XMLCryptoContext
        Sets a URIDereferencer that is used to dereference URIReferences. The specified URIDereferencer is used in place of an implementation's default URIDereferencer.
        Specified by:
        setURIDereferencer in interface XMLCryptoContext
        Parameters:
        dereferencer - the URIDereferencer, or null to remove any current setting
        See Also:
        XMLCryptoContext.getURIDereferencer()

      • getProperty

        public Object getProperty(String name)
        This implementation uses an internal HashMap to get the object that the specified name maps to.
        Specified by:
        getProperty in interface XMLCryptoContext
        Parameters:
        name - the name of the property
        Returns:
        the current value of the specified property, or null if it does not have a value
        Throws:
        NullPointerException - if name is null
        See Also:
        XMLCryptoContext.setProperty(String, Object)

      • setProperty

        public Object setProperty(String name,
                          Object value)
        This implementation uses an internal HashMap to map the name to the specified object.
        Specified by:
        setProperty in interface XMLCryptoContext
        Parameters:
        name - the name of the property
        value - the value of the property to be set
        Returns:
        the previous value of the specified property, or null if it did not have a value
        Throws:
        NullPointerException - if name is null
        See Also:
        XMLCryptoContext.getProperty(String)

      • getKeySelector

        public KeySelector getKeySelector()
        Description copied from interface: XMLCryptoContext
        Returns the key selector for finding a key.
        Specified by:
        getKeySelector in interface XMLCryptoContext
        Returns:
        the key selector, or null if not specified
        See Also:
        XMLCryptoContext.setKeySelector(KeySelector)

      • setKeySelector

        public void setKeySelector(KeySelector ks)
        Description copied from interface: XMLCryptoContext
        Sets the key selector for finding a key.
        Specified by:
        setKeySelector in interface XMLCryptoContext
        Parameters:
        ks - the key selector, or null to remove the current setting
        See Also:
        XMLCryptoContext.getKeySelector()

      • getElementById

        public Element getElementById(String idValue)
        Returns the Element with the specified ID attribute value.

        This implementation uses an internal HashMap to get the element that the specified attribute value maps to.

        Parameters:
        idValue - the value of the ID
        Returns:
        the Element with the specified ID attribute value, or null if none.
        Throws:
        NullPointerException - if idValue is null
        See Also:
        setIdAttributeNS(org.w3c.dom.Element, java.lang.String, java.lang.String)

      • setIdAttributeNS

        public void setIdAttributeNS(Element element,
                             String namespaceURI,
                             String localName)
        Registers the element's attribute specified by the namespace URI and local name to be of type ID. The attribute must have a non-empty value.

        This implementation uses an internal HashMap to map the attribute's value to the specified element.

        Parameters:
        element - the element
        namespaceURI - the namespace URI of the attribute (specify null if not applicable)
        localName - the local name of the attribute
        Throws:
        IllegalArgumentException - if localName is not an attribute of the specified element or it does not contain a specific value
        NullPointerException - if element or localName is null
        See Also:
        getElementById(java.lang.String)

      • iterator

        public Iterator iterator()
        Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext. Attempts to modify the set via the Iterator.remove() method throw an UnsupportedOperationException. The mappings are returned in no particular order. Each element in the iteration is represented as a Map.Entry. If the DOMCryptoContext is modified while an iteration is in progress, the results of the iteration are undefined.
        Returns:
        a read-only iterator over the set of mappings

      • get

        public Object get(Object key)
        This implementation uses an internal HashMap to get the object that the specified key maps to.
        Specified by:
        get in interface XMLCryptoContext
        Parameters:
        key - the key whose associated value is to be returned
        Returns:
        the value to which this context maps the specified key, or null if there is no mapping for the key
        See Also:
        XMLCryptoContext.put(Object, Object)

      • put

        public Object put(Object key,
                  Object value)
        This implementation uses an internal HashMap to map the key to the specified object.
        Specified by:
        put in interface XMLCryptoContext
        Parameters:
        key - key with which the specified value is to be associated with
        value - value to be associated with the specified key
        Returns:
        the previous value associated with the key, or null if there was no mapping for the key
        Throws:
        IllegalArgumentException - if some aspect of this key or value prevents it from being stored in this context
        See Also:
        XMLCryptoContext.get(Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMStructure (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dom

Class DOMStructure

  • java.lang.Object
    • javax.xml.crypto.dom.DOMStructure
  • All Implemented Interfaces:
    XMLStructure

    public class DOMStructure
extends Object
implements XMLStructure
    A DOM-specific XMLStructure. The purpose of this class is to allow a DOM node to be used to represent extensible content (any elements or mixed content) in XML Signature structures.

    If a sequence of nodes is needed, the node contained in the DOMStructure is the first node of the sequence and successive nodes can be accessed by invoking Node.getNextSibling().

    If the owner document of the DOMStructure is different than the target document of an XMLSignature, the XMLSignature.sign(XMLSignContext) method imports the node into the target document before generating the signature.

    Since:
    1.6

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMStructure(Node node)
      Creates a DOMStructure containing the specified node.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Node getNode()
      Returns the node contained in this DOMStructure.
      boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DOMStructure

        public DOMStructure(Node node)
        Creates a DOMStructure containing the specified node.
        Parameters:
        node - the node
        Throws:
        NullPointerException - if node is null

    • Method Detail

      • getNode

        public Node getNode()
        Returns the node contained in this DOMStructure.
        Returns:
        the node

      • isFeatureSupported

        public boolean isFeatureSupported(String feature)
        Description copied from interface: XMLStructure
        Indicates whether a specified feature is supported.
        Specified by:
        isFeatureSupported in interface XMLStructure
        Parameters:
        feature - the feature name (as an absolute URI)
        Returns:
        true if the specified feature is supported, false otherwise
        Throws:
        NullPointerException - if feature is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMURIReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dom

Interface DOMURIReference

  • All Superinterfaces:
    URIReference

    public interface DOMURIReference
extends URIReference
    A DOM-specific URIReference. The purpose of this class is to provide additional context necessary for resolving XPointer URIs or same-document references.
    Since:
    1.6

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Node getHere()
      Returns the here node.

      • Methods inherited from interface javax.xml.crypto.URIReference

        getType, getURI

    • Method Detail

      • getHere

        Node getHere()
        Returns the here node.
        Returns:
        the attribute or processing instruction node or the parent element of the text node that directly contains the URI
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dom (Java Platform SE 8 )

javax.xml.crypto.dom

Interfaces

  • DOMURIReference

Classes

  • DOMCryptoContext
  • DOMStructure


javax.xml.crypto.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.crypto.dom

DOM-specific classes for the javax.xml.crypto package.

See: Description

  • Interface Summary
    Interface Description
    DOMURIReference
    A DOM-specific URIReference.
  • Class Summary
    Class Description
    DOMCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface.
    DOMStructure
    A DOM-specific XMLStructure.

Package javax.xml.crypto.dom Description

DOM-specific classes for the javax.xml.crypto package. Only users who are using a DOM-based XML cryptographic implementations (ex: XMLSignatureFactory or KeyInfoFactory) should need to make direct use of this package.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dom Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.crypto.dom

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
    • javax.xml.crypto.dom.DOMStructure (implements javax.xml.crypto.XMLStructure)

Interface Hierarchy

  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dom.DOMURIReference
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.crypto.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.crypto.dom

  • Packages that use javax.xml.crypto.dom
    Package Description
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
  • Classes in javax.xml.crypto.dom used by javax.xml.crypto.dsig.dom
    Class and Description
    DOMCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dom.DOMCryptoContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dom.DOMCryptoContext

  • Packages that use DOMCryptoContext
    Package Description
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of DOMCryptoContext in javax.xml.crypto.dsig.dom

      Subclasses of DOMCryptoContext in javax.xml.crypto.dsig.dom
      Modifier and Type Class and Description
      class  DOMSignContext
      A DOM-specific XMLSignContext.
      class  DOMValidateContext
      A DOM-specific XMLValidateContext.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dom.DOMStructure (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dom.DOMStructure

No usage of javax.xml.crypto.dom.DOMStructure
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dom.DOMURIReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dom.DOMURIReference

No usage of javax.xml.crypto.dom.DOMURIReference
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CanonicalizationMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface CanonicalizationMethod

  • All Superinterfaces:
    AlgorithmMethod, Transform, XMLStructure

    public interface CanonicalizationMethod
extends Transform
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>
     <complexType name="CanonicalizationMethodType" mixed="true">
       <sequence>
         <any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
           <!-- (0,unbounded) elements from (1,1) namespace -->
       </sequence>
       <attribute name="Algorithm" type="anyURI" use="required"/>
     </complexType>
    A CanonicalizationMethod instance may be created by invoking the newCanonicalizationMethod method of the XMLSignatureFactory class.
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newCanonicalizationMethod(String, C14NMethodParameterSpec)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String EXCLUSIVE
      The Exclusive Canonical XML (without comments) canonicalization method algorithm URI.
      static String EXCLUSIVE_WITH_COMMENTS
      The Exclusive Canonical XML with comments canonicalization method algorithm URI.
      static String INCLUSIVE
      The Canonical XML (without comments) canonicalization method algorithm URI.
      static String INCLUSIVE_WITH_COMMENTS
      The Canonical XML with comments canonicalization method algorithm URI.

      • Fields inherited from interface javax.xml.crypto.dsig.Transform

        BASE64, ENVELOPED, XPATH, XPATH2, XSLT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters associated with this CanonicalizationMethod.

      • Methods inherited from interface javax.xml.crypto.dsig.Transform

        transform, transform

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

      • Methods inherited from interface javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • Field Detail

      • INCLUSIVE

        static final String INCLUSIVE
        The Canonical XML (without comments) canonicalization method algorithm URI.
        See Also:
        Constant Field Values

      • INCLUSIVE_WITH_COMMENTS

        static final String INCLUSIVE_WITH_COMMENTS
        The Canonical XML with comments canonicalization method algorithm URI.
        See Also:
        Constant Field Values

      • EXCLUSIVE

        static final String EXCLUSIVE
        The Exclusive Canonical XML (without comments) canonicalization method algorithm URI.
        See Also:
        Constant Field Values

      • EXCLUSIVE_WITH_COMMENTS

        static final String EXCLUSIVE_WITH_COMMENTS
        The Exclusive Canonical XML with comments canonicalization method algorithm URI.
        See Also:
        Constant Field Values

    • Method Detail

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters associated with this CanonicalizationMethod.

        The returned parameters can be typecast to a C14NMethodParameterSpec object.

        Specified by:
        getParameterSpec in interface AlgorithmMethod
        Specified by:
        getParameterSpec in interface Transform
        Returns:
        the algorithm-specific input parameters (may be null if not specified)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.crypto.dsig (Java Platform SE 8 )

compact3 - javax.xml.crypto.dsig

Interfaces

  • CanonicalizationMethod
  • DigestMethod
  • Manifest
  • Reference
  • SignatureMethod
  • SignatureProperties
  • SignatureProperty
  • SignedInfo
  • Transform
  • XMLObject
  • XMLSignature
  • XMLSignature.SignatureValue
  • XMLSignContext
  • XMLValidateContext

Classes

  • TransformService
  • XMLSignatureFactory

Exceptions

  • TransformException
  • XMLSignatureException


javax.xml.crypto.dsig (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.crypto.dsig

Classes for generating and validating XML digital signatures.

See: Description

  • Interface Summary
    Interface Description
    CanonicalizationMethod
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    DigestMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Manifest
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Reference
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperties
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperty
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignedInfo
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Transform
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLObject
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature.SignatureValue
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
  • Class Summary
    Class Description
    TransformService
    A Service Provider Interface for transform and canonicalization algorithms.
    XMLSignatureFactory
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.
  • Exception Summary
    Exception Description
    TransformException
    Indicates an exceptional condition that occurred while executing a transform algorithm.
    XMLSignatureException
    Indicates an exceptional condition that occurred during the XML signature generation or validation process.

Package javax.xml.crypto.dsig Description

Classes for generating and validating XML digital signatures. This package includes classes that represent the core elements defined in the W3C XML digital signature specification: XMLSignature, SignedInfo, CanonicalizationMethod, SignatureMethod, Reference, DigestMethod, XMLObject, Manifest, SignatureProperties, and SignatureProperty. KeyInfo types are defined in the javax.xml.crypto.dsig.keyinfo subpackage. XMLSignatureFactory is an abstract factory that creates XMLSignature objects from scratch or from a pre-existing XML representation, such as a DOM node. TransformService is a service provider interface for creating and plugging in implementations of transform and canonicalization algorithms.

Of primary significance in this package is the XMLSignature class, which allows you to sign and validate an XML digital signature.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DigestMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface DigestMethod

  • All Superinterfaces:
    AlgorithmMethod, XMLStructure

    public interface DigestMethod
extends XMLStructure, AlgorithmMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="DigestMethod" type="ds:DigestMethodType"/>
     <complexType name="DigestMethodType" mixed="true">
       <sequence>
         <any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
           <!-- (0,unbounded) elements from (1,1) namespace -->
       </sequence>
       <attribute name="Algorithm" type="anyURI" use="required"/>
     </complexType>
    A DigestMethod instance may be created by invoking the newDigestMethod method of the XMLSignatureFactory class.
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newDigestMethod(String, DigestMethodParameterSpec)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String RIPEMD160
      The RIPEMD-160 digest method algorithm URI.
      static String SHA1
      The SHA1 digest method algorithm URI.
      static String SHA256
      The SHA256 digest method algorithm URI.
      static String SHA512
      The SHA512 digest method algorithm URI.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters associated with this DigestMethod.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

      • Methods inherited from interface javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • Field Detail

      • SHA1

        static final String SHA1
        The SHA1 digest method algorithm URI.
        See Also:
        Constant Field Values

      • SHA256

        static final String SHA256
        The SHA256 digest method algorithm URI.
        See Also:
        Constant Field Values

      • SHA512

        static final String SHA512
        The SHA512 digest method algorithm URI.
        See Also:
        Constant Field Values

      • RIPEMD160

        static final String RIPEMD160
        The RIPEMD-160 digest method algorithm URI.
        See Also:
        Constant Field Values

    • Method Detail

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters associated with this DigestMethod.

        The returned parameters can be typecast to a DigestMethodParameterSpec object.

        Specified by:
        getParameterSpec in interface AlgorithmMethod
        Returns:
        the algorithm-specific parameters (may be null if not specified)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Manifest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface Manifest

  • All Superinterfaces:
    XMLStructure

    public interface Manifest
extends XMLStructure
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

 <element name="Manifest" type="ds:ManifestType"/>
   <complexType name="ManifestType">
     <sequence>
       <element ref="ds:Reference" maxOccurs="unbounded"/>
     </sequence>
     <attribute name="Id" type="ID" use="optional"/>
   </complexType>
    A Manifest instance may be created by invoking one of the newManifest methods of the XMLSignatureFactory class; for example:
       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   List references = Collections.singletonList(factory.newReference
       ("#reference-1", DigestMethod.SHA1));
   Manifest manifest = factory.newManifest(references, "manifest-1");
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newManifest(List), XMLSignatureFactory.newManifest(List, String)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String TYPE
      URI that identifies the Manifest element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getId()
      Returns the Id of this Manifest.
      List getReferences()
      Returns an unmodifiable list of one or more References that are contained in this Manifest.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • TYPE

        static final String TYPE
        URI that identifies the Manifest element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
        See Also:
        Constant Field Values

    • Method Detail

      • getId

        String getId()
        Returns the Id of this Manifest.
        Returns:
        the Id of this Manifest (or null if not specified)

      • getReferences

        List getReferences()
        Returns an unmodifiable list of one or more References that are contained in this Manifest.
        Returns:
        an unmodifiable list of one or more References
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig (Java Platform SE 8 )

javax.xml.crypto.dsig

Interfaces

  • CanonicalizationMethod
  • DigestMethod
  • Manifest
  • Reference
  • SignatureMethod
  • SignatureProperties
  • SignatureProperty
  • SignedInfo
  • Transform
  • XMLObject
  • XMLSignature
  • XMLSignature.SignatureValue
  • XMLSignContext
  • XMLValidateContext

Classes

  • TransformService
  • XMLSignatureFactory

Exceptions

  • TransformException
  • XMLSignatureException


javax.xml.crypto.dsig (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.crypto.dsig

Classes for generating and validating XML digital signatures.

See: Description

  • Interface Summary
    Interface Description
    CanonicalizationMethod
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    DigestMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Manifest
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Reference
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperties
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperty
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignedInfo
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Transform
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLObject
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature.SignatureValue
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
  • Class Summary
    Class Description
    TransformService
    A Service Provider Interface for transform and canonicalization algorithms.
    XMLSignatureFactory
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.
  • Exception Summary
    Exception Description
    TransformException
    Indicates an exceptional condition that occurred while executing a transform algorithm.
    XMLSignatureException
    Indicates an exceptional condition that occurred during the XML signature generation or validation process.

Package javax.xml.crypto.dsig Description

Classes for generating and validating XML digital signatures. This package includes classes that represent the core elements defined in the W3C XML digital signature specification: XMLSignature, SignedInfo, CanonicalizationMethod, SignatureMethod, Reference, DigestMethod, XMLObject, Manifest, SignatureProperties, and SignatureProperty. KeyInfo types are defined in the javax.xml.crypto.dsig.keyinfo subpackage. XMLSignatureFactory is an abstract factory that creates XMLSignature objects from scratch or from a pre-existing XML representation, such as a DOM node. TransformService is a service provider interface for creating and plugging in implementations of transform and canonicalization algorithms.

Of primary significance in this package is the XMLSignature class, which allows you to sign and validate an XML digital signature.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.crypto.dsig

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.crypto.dsig.TransformException
        • javax.xml.crypto.dsig.XMLSignatureException
    • javax.xml.crypto.dsig.TransformService (implements javax.xml.crypto.dsig.Transform)
    • javax.xml.crypto.dsig.XMLSignatureFactory

Interface Hierarchy

  • javax.xml.crypto.AlgorithmMethod
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.XMLStructure)
      • javax.xml.crypto.dsig.CanonicalizationMethod
  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.XMLStructure)
  • javax.xml.crypto.XMLCryptoContext
    • javax.xml.crypto.dsig.XMLSignContext
    • javax.xml.crypto.dsig.XMLValidateContext
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.Manifest
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.SignatureProperties
    • javax.xml.crypto.dsig.SignatureProperty
    • javax.xml.crypto.dsig.SignedInfo
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.AlgorithmMethod)
      • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.XMLObject
    • javax.xml.crypto.dsig.XMLSignature
    • javax.xml.crypto.dsig.XMLSignature.SignatureValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.crypto.dsig (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.crypto.dsig

  • Packages that use javax.xml.crypto.dsig
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
  • Classes in javax.xml.crypto.dsig used by javax.xml.crypto.dsig
    Class and Description
    CanonicalizationMethod
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    DigestMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Manifest
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Reference
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperties
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperty
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignedInfo
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Transform
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    TransformException
    Indicates an exceptional condition that occurred while executing a transform algorithm.
    TransformService
    A Service Provider Interface for transform and canonicalization algorithms.
    XMLObject
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature.SignatureValue
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignatureException
    Indicates an exceptional condition that occurred during the XML signature generation or validation process.
    XMLSignatureFactory
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
  • Classes in javax.xml.crypto.dsig used by javax.xml.crypto.dsig.dom
    Class and Description
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Reference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface Reference

  • All Superinterfaces:
    URIReference, XMLStructure

    public interface Reference
extends URIReference, XMLStructure
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML schema is defined as:
     <element name="Reference" type="ds:ReferenceType"/>
 <complexType name="ReferenceType">
   <sequence>
     <element ref="ds:Transforms" minOccurs="0"/>
     <element ref="ds:DigestMethod"/>
     <element ref="ds:DigestValue"/>
   </sequence>
   <attribute name="Id" type="ID" use="optional"/>
   <attribute name="URI" type="anyURI" use="optional"/>
   <attribute name="Type" type="anyURI" use="optional"/>
 </complexType>

 <element name="DigestValue" type="ds:DigestValueType"/>
 <simpleType name="DigestValueType">
   <restriction base="base64Binary"/>
 </simpleType>

    A Reference instance may be created by invoking one of the newReference methods of the XMLSignatureFactory class; for example:

       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   Reference ref = factory.newReference
     ("http://www.ietf.org/rfc/rfc3275.txt",
      factory.newDigestMethod(DigestMethod.SHA1, null));
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newReference(String, DigestMethod), XMLSignatureFactory.newReference(String, DigestMethod, List, String, String)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] getCalculatedDigestValue()
      Returns the calculated digest value of this Reference after a validation operation.
      Data getDereferencedData()
      Returns the dereferenced data, if reference caching is enabled.
      InputStream getDigestInputStream()
      Returns the pre-digested input stream, if reference caching is enabled.
      DigestMethod getDigestMethod()
      Returns the digest method of this Reference.
      byte[] getDigestValue()
      Returns the digest value of this Reference.
      String getId()
      Returns the optional Id attribute of this Reference, which permits this reference to be referenced from elsewhere.
      List getTransforms()
      Returns an unmodifiable list of Transforms that are contained in this Reference.
      boolean validate(XMLValidateContext validateContext)
      Validates this reference.

      • Methods inherited from interface javax.xml.crypto.URIReference

        getType, getURI

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getTransforms

        List getTransforms()
        Returns an unmodifiable list of Transforms that are contained in this Reference.
        Returns:
        an unmodifiable list of Transforms (may be empty but never null)

      • getDigestMethod

        DigestMethod getDigestMethod()
        Returns the digest method of this Reference.
        Returns:
        the digest method

      • getId

        String getId()
        Returns the optional Id attribute of this Reference, which permits this reference to be referenced from elsewhere.
        Returns:
        the Id attribute (may be null if not specified)

      • getDigestValue

        byte[] getDigestValue()
        Returns the digest value of this Reference.
        Returns:
        the raw digest value, or null if this reference has not been digested yet. Each invocation of this method returns a new clone to protect against subsequent modification.

      • getCalculatedDigestValue

        byte[] getCalculatedDigestValue()
        Returns the calculated digest value of this Reference after a validation operation. This method is useful for debugging if the reference fails to validate.
        Returns:
        the calculated digest value, or null if this reference has not been validated yet. Each invocation of this method returns a new clone to protect against subsequent modification.

      • validate

        boolean validate(XMLValidateContext validateContext)
          throws XMLSignatureException
        Validates this reference. This method verifies the digest of this reference.

        This method only validates the reference the first time it is invoked. On subsequent invocations, it returns a cached result.

        Parameters:
        validateContext - the validating context
        Returns:
        true if this reference was validated successfully; false otherwise
        Throws:
        NullPointerException - if validateContext is null
        XMLSignatureException - if an unexpected exception occurs while validating the reference

      • getDereferencedData

        Data getDereferencedData()
        Returns the dereferenced data, if reference caching is enabled. This is the result of dereferencing the URI of this reference during a validation or generation operation.
        Returns:
        the dereferenced data, or null if reference caching is not enabled or this reference has not been generated or validated

      • getDigestInputStream

        InputStream getDigestInputStream()
        Returns the pre-digested input stream, if reference caching is enabled. This is the input to the digest operation during a validation or signing operation.
        Returns:
        an input stream containing the pre-digested input, or null if reference caching is not enabled or this reference has not been generated or validated
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SignatureMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface SignatureMethod

  • All Superinterfaces:
    AlgorithmMethod, XMLStructure

    public interface SignatureMethod
extends XMLStructure, AlgorithmMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="SignatureMethod" type="ds:SignatureMethodType"/>
     <complexType name="SignatureMethodType" mixed="true">
       <sequence>
         <element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
         <any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
           <!-- (0,unbounded) elements from (1,1) namespace -->
       </sequence>
       <attribute name="Algorithm" type="anyURI" use="required"/>
     </complexType>
    A SignatureMethod instance may be created by invoking the newSignatureMethod method of the XMLSignatureFactory class.
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newSignatureMethod(String, SignatureMethodParameterSpec)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DSA_SHA1
      The DSAwithSHA1 (DSS) signature method algorithm URI.
      static String HMAC_SHA1
      The HMAC-SHA1 MAC signature method algorithm URI
      static String RSA_SHA1
      The RSAwithSHA1 (PKCS #1) signature method algorithm URI.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters of this SignatureMethod.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

      • Methods inherited from interface javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • Field Detail

      • DSA_SHA1

        static final String DSA_SHA1
        The DSAwithSHA1 (DSS) signature method algorithm URI.
        See Also:
        Constant Field Values

      • RSA_SHA1

        static final String RSA_SHA1
        The RSAwithSHA1 (PKCS #1) signature method algorithm URI.
        See Also:
        Constant Field Values

      • HMAC_SHA1

        static final String HMAC_SHA1
        The HMAC-SHA1 MAC signature method algorithm URI
        See Also:
        Constant Field Values

    • Method Detail

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters of this SignatureMethod.

        The returned parameters can be typecast to a SignatureMethodParameterSpec object.

        Specified by:
        getParameterSpec in interface AlgorithmMethod
        Returns:
        the algorithm-specific input parameters of this SignatureMethod (may be null if not specified)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SignatureProperties (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface SignatureProperties

  • All Superinterfaces:
    XMLStructure

    public interface SignatureProperties
extends XMLStructure
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

<element name="SignatureProperties" type="ds:SignaturePropertiesType"/>
   <complexType name="SignaturePropertiesType">
     <sequence>
       <element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
     </sequence>
     <attribute name="Id" type="ID" use="optional"/>
   </complexType>
    A SignatureProperties instance may be created by invoking the newSignatureProperties method of the XMLSignatureFactory class; for example:
       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   SignatureProperties properties =
      factory.newSignatureProperties(props, "signature-properties-1");
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newSignatureProperties(List, String), SignatureProperty

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String TYPE
      URI that identifies the SignatureProperties element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getId()
      Returns the Id of this SignatureProperties.
      List getProperties()
      Returns an unmodifiable list of one or more SignaturePropertys that are contained in this SignatureProperties.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • TYPE

        static final String TYPE
        URI that identifies the SignatureProperties element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
        See Also:
        Constant Field Values

    • Method Detail

      • getId

        String getId()
        Returns the Id of this SignatureProperties.
        Returns:
        the Id of this SignatureProperties (or null if not specified)

      • getProperties

        List getProperties()
        Returns an unmodifiable list of one or more SignaturePropertys that are contained in this SignatureProperties.
        Returns:
        an unmodifiable list of one or more SignaturePropertys
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SignatureProperty (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface SignatureProperty

  • All Superinterfaces:
    XMLStructure

    public interface SignatureProperty
extends XMLStructure
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

<element name="SignatureProperty" type="ds:SignaturePropertyType"/>
   <complexType name="SignaturePropertyType" mixed="true">
     <choice maxOccurs="unbounded">
       <any namespace="##other" processContents="lax"/>
       <!-- (1,1) elements from (1, unbounded) namespaces -->
     </choice>
     <attribute name="Target" type="anyURI" use="required"/>
     <attribute name="Id" type="ID" use="optional"/>
   </complexType>
    A SignatureProperty instance may be created by invoking the newSignatureProperty method of the XMLSignatureFactory class; for example:
       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   SignatureProperty property = factory.newSignatureProperty
      (Collections.singletonList(content), "#Signature-1", "TimeStamp");
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newSignatureProperty(List, String, String), SignatureProperties

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      List getContent()
      Returns an unmodifiable list of one or more XMLStructures that are contained in this SignatureProperty.
      String getId()
      Returns the Id of this SignatureProperty.
      String getTarget()
      Returns the target URI of this SignatureProperty.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getTarget

        String getTarget()
        Returns the target URI of this SignatureProperty.
        Returns:
        the target URI of this SignatureProperty (never null)

      • getId

        String getId()
        Returns the Id of this SignatureProperty.
        Returns:
        the Id of this SignatureProperty (or null if not specified)

      • getContent

        List getContent()
        Returns an unmodifiable list of one or more XMLStructures that are contained in this SignatureProperty. These represent additional information items concerning the generation of the XMLSignature (i.e. date/time stamp or serial numbers of cryptographic hardware used in signature generation).
        Returns:
        an unmodifiable list of one or more XMLStructures
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SignedInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface SignedInfo

  • All Superinterfaces:
    XMLStructure

    public interface SignedInfo
extends XMLStructure
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

 <element name="SignedInfo" type="ds:SignedInfoType"/>
 <complexType name="SignedInfoType">
   <sequence>
     <element ref="ds:CanonicalizationMethod"/>
     <element ref="ds:SignatureMethod"/>
     <element ref="ds:Reference" maxOccurs="unbounded"/>
   </sequence>
   <attribute name="Id" type="ID" use="optional"/>
 </complexType>
    A SignedInfo instance may be created by invoking one of the newSignedInfo methods of the XMLSignatureFactory class.
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newSignedInfo(CanonicalizationMethod, SignatureMethod, List), XMLSignatureFactory.newSignedInfo(CanonicalizationMethod, SignatureMethod, List, String)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      CanonicalizationMethod getCanonicalizationMethod()
      Returns the canonicalization method of this SignedInfo.
      InputStream getCanonicalizedData()
      Returns the canonicalized signed info bytes after a signing or validation operation.
      String getId()
      Returns the optional Id attribute of this SignedInfo.
      List getReferences()
      Returns an unmodifiable list of one or more References.
      SignatureMethod getSignatureMethod()
      Returns the signature method of this SignedInfo.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getCanonicalizationMethod

        CanonicalizationMethod getCanonicalizationMethod()
        Returns the canonicalization method of this SignedInfo.
        Returns:
        the canonicalization method

      • getSignatureMethod

        SignatureMethod getSignatureMethod()
        Returns the signature method of this SignedInfo.
        Returns:
        the signature method

      • getReferences

        List getReferences()
        Returns an unmodifiable list of one or more References.
        Returns:
        an unmodifiable list of one or more References

      • getId

        String getId()
        Returns the optional Id attribute of this SignedInfo.
        Returns:
        the id (may be null if not specified)

      • getCanonicalizedData

        InputStream getCanonicalizedData()
        Returns the canonicalized signed info bytes after a signing or validation operation. This method is useful for debugging.
        Returns:
        an InputStream containing the canonicalized bytes, or null if this SignedInfo has not been signed or validated yet
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Transform (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface Transform

  • All Superinterfaces:
    AlgorithmMethod, XMLStructure
    All Known Subinterfaces:
    CanonicalizationMethod
    All Known Implementing Classes:
    TransformService

    public interface Transform
extends XMLStructure, AlgorithmMethod
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:
     <element name="Transform" type="ds:TransformType"/>
   <complexType name="TransformType" mixed="true">
     <choice minOccurs="0" maxOccurs="unbounded">
       <any namespace="##other" processContents="lax"/>
       <!-- (1,1) elements from (0,unbounded) namespaces -->
       <element name="XPath" type="string"/>
     </choice>
     <attribute name="Algorithm" type="anyURI" use="required"/>
   </complexType>
    A Transform instance may be created by invoking the newTransform method of the XMLSignatureFactory class.
    Since:
    1.6
    See Also:
    XMLSignatureFactory.newTransform(String, TransformParameterSpec)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String BASE64
      The Base64 transform algorithm URI.
      static String ENVELOPED
      The Enveloped Signature transform algorithm URI.
      static String XPATH
      The XPath transform algorithm URI.
      static String XPATH2
      The XPath Filter 2 transform algorithm URI.
      static String XSLT
      The XSLT transform algorithm URI.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters associated with this Transform.
      Data transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

      • Methods inherited from interface javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • Field Detail

      • BASE64

        static final String BASE64
        The Base64 transform algorithm URI.
        See Also:
        Constant Field Values

      • ENVELOPED

        static final String ENVELOPED
        The Enveloped Signature transform algorithm URI.
        See Also:
        Constant Field Values

      • XPATH

        static final String XPATH
        The XPath transform algorithm URI.
        See Also:
        Constant Field Values

      • XPATH2

        static final String XPATH2
        The XPath Filter 2 transform algorithm URI.
        See Also:
        Constant Field Values

      • XSLT

        static final String XSLT
        The XSLT transform algorithm URI.
        See Also:
        Constant Field Values

    • Method Detail

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters associated with this Transform.

        The returned parameters can be typecast to a TransformParameterSpec object.

        Specified by:
        getParameterSpec in interface AlgorithmMethod
        Returns:
        the algorithm-specific input parameters (may be null if not specified)

      • transform

        Data transform(Data data,
               XMLCryptoContext context)
        throws TransformException
        Transforms the specified data using the underlying transform algorithm.
        Parameters:
        data - the data to be transformed
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        Returns:
        the transformed data
        Throws:
        NullPointerException - if data is null
        TransformException - if an error occurs while executing the transform

      • transform

        Data transform(Data data,
               XMLCryptoContext context,
               OutputStream os)
        throws TransformException
        Transforms the specified data using the underlying transform algorithm. If the output of this transform is an OctetStreamData, then this method returns null and the bytes are written to the specified OutputStream. Otherwise, the OutputStream is ignored and the method behaves as if transform(Data, XMLCryptoContext) were invoked.
        Parameters:
        data - the data to be transformed
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        os - the OutputStream that should be used to write the transformed data to
        Returns:
        the transformed data (or null if the data was written to the OutputStream parameter)
        Throws:
        NullPointerException - if data or os is null
        TransformException - if an error occurs while executing the transform
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Class TransformException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.dsig.TransformException
  • All Implemented Interfaces:
    Serializable

    public class TransformException
extends Exception
    Indicates an exceptional condition that occurred while executing a transform algorithm.

    A TransformException can contain a cause: another throwable that caused this TransformException to get thrown.

    Since:
    1.6
    See Also:
    Transform.transform(javax.xml.crypto.Data, javax.xml.crypto.XMLCryptoContext), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransformException()
      Constructs a new TransformException with null as its detail message.
      TransformException(String message)
      Constructs a new TransformException with the specified detail message.
      TransformException(String message, Throwable cause)
      Constructs a new TransformException with the specified detail message and cause.
      TransformException(Throwable cause)
      Constructs a new TransformException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this TransformException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this TransformException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this TransformException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this TransformException, its backtrace and the cause's backtrace to the specified print writer.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransformException

        public TransformException()
        Constructs a new TransformException with null as its detail message.

      • TransformException

        public TransformException(String message)
        Constructs a new TransformException with the specified detail message.
        Parameters:
        message - the detail message

      • TransformException

        public TransformException(String message,
                          Throwable cause)
        Constructs a new TransformException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • TransformException

        public TransformException(Throwable cause)
        Constructs a new TransformException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getCause

        public Throwable getCause()
        Returns the cause of this TransformException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this TransformException to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this TransformException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this TransformException, its backtrace and the cause's backtrace to the standard error stream.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this TransformException, its backtrace and the cause's backtrace to the specified print stream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this TransformException, its backtrace and the cause's backtrace to the specified print writer.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformService (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Class TransformService

  • java.lang.Object
    • javax.xml.crypto.dsig.TransformService
  • All Implemented Interfaces:
    AlgorithmMethod, Transform, XMLStructure

    public abstract class TransformService
extends Object
implements Transform
    A Service Provider Interface for transform and canonicalization algorithms.

    Each instance of TransformService supports a specific transform or canonicalization algorithm and XML mechanism type. To create a TransformService, call one of the static getInstance methods, passing in the algorithm URI and XML mechanism type desired, for example:

    TransformService ts = TransformService.getInstance(Transform.XPATH2, "DOM");

    TransformService implementations are registered and loaded using the Provider mechanism. Each TransformService service provider implementation should include a MechanismType service attribute that identifies the XML mechanism type that it supports. If the attribute is not specified, "DOM" is assumed. For example, a service provider that supports the XPath Filter 2 Transform and DOM mechanism would be specified in the Provider subclass as:

         put("TransformService." + Transform.XPATH2,
         "org.example.XPath2TransformService");
     put("TransformService." + Transform.XPATH2 + " MechanismType", "DOM");
    TransformService implementations that support the DOM mechanism type must abide by the DOM interoperability requirements defined in the DOM Mechanism Requirements section of the API overview. See the Service Providers section of the API overview for a list of standard mechanism types.

    Once a TransformService has been created, it can be used to process Transform or CanonicalizationMethod objects. If the Transform or CanonicalizationMethod exists in XML form (for example, when validating an existing XMLSignature), the init(XMLStructure, XMLCryptoContext) method must be first called to initialize the transform and provide document context (even if there are no parameters). Alternatively, if the Transform or CanonicalizationMethod is being created from scratch, the init(TransformParameterSpec) method is called to initialize the transform with parameters and the marshalParams method is called to marshal the parameters to XML and provide the transform with document context. Finally, the transform method is called to perform the transformation.

    Concurrent Access

    The static methods of this class are guaranteed to be thread-safe. Multiple threads may concurrently invoke the static methods defined in this class with no ill effects.

    However, this is not true for the non-static methods defined by this class. Unless otherwise documented by a specific provider, threads that need to access a single TransformService instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different TransformService instance need not synchronize.

    Since:
    1.6

    • Field Summary

      • Fields inherited from interface javax.xml.crypto.dsig.Transform

        BASE64, ENVELOPED, XPATH, XPATH2, XSLT

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected TransformService()
      Default constructor, for invocation by subclasses.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      String getAlgorithm()
      Returns the URI of the algorithm supported by this TransformService.
      static TransformService getInstance(String algorithm, String mechanismType)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).
      static TransformService getInstance(String algorithm, String mechanismType, Provider provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
      static TransformService getInstance(String algorithm, String mechanismType, String provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
      String getMechanismType()
      Returns the mechanism type supported by this TransformService.
      Provider getProvider()
      Returns the provider of this TransformService.
      abstract void init(TransformParameterSpec params)
      Initializes this TransformService with the specified parameters.
      abstract void init(XMLStructure parent, XMLCryptoContext context)
      Initializes this TransformService with the specified parameters and document context.
      abstract void marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.crypto.dsig.Transform

        getParameterSpec, transform, transform

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Constructor Detail

      • TransformService

        protected TransformService()
        Default constructor, for invocation by subclasses.

    • Method Detail

      • getInstance

        public static TransformService getInstance(String algorithm,
                                           String mechanismType)
                                    throws NoSuchAlgorithmException
        Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).

        This method uses the standard JCA provider lookup mechanism to locate and instantiate a TransformService implementation of the desired algorithm and MechanismType service attribute. It traverses the list of registered security Providers, starting with the most preferred Provider. A new TransformService object from the first Provider that supports the specified algorithm and mechanism type is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Parameters:
        algorithm - the URI of the algorithm
        mechanismType - the type of the XML processing mechanism and representation
        Returns:
        a new TransformService
        Throws:
        NullPointerException - if algorithm or mechanismType is null
        NoSuchAlgorithmException - if no Provider supports a TransformService implementation for the specified algorithm and mechanism type
        See Also:
        Provider

      • getInstance

        public static TransformService getInstance(String algorithm,
                                           String mechanismType,
                                           Provider provider)
                                    throws NoSuchAlgorithmException
        Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider. Note that the specified Provider object does not have to be registered in the provider list.
        Parameters:
        algorithm - the URI of the algorithm
        mechanismType - the type of the XML processing mechanism and representation
        provider - the Provider object
        Returns:
        a new TransformService
        Throws:
        NullPointerException - if provider, algorithm, or mechanismType is null
        NoSuchAlgorithmException - if a TransformService implementation for the specified algorithm and mechanism type is not available from the specified Provider object
        See Also:
        Provider

      • getInstance

        public static TransformService getInstance(String algorithm,
                                           String mechanismType,
                                           String provider)
                                    throws NoSuchAlgorithmException,
                                           NoSuchProviderException
        Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Parameters:
        algorithm - the URI of the algorithm
        mechanismType - the type of the XML processing mechanism and representation
        provider - the string name of the provider
        Returns:
        a new TransformService
        Throws:
        NoSuchProviderException - if the specified provider is not registered in the security provider list
        NullPointerException - if provider, mechanismType, or algorithm is null
        NoSuchAlgorithmException - if a TransformService implementation for the specified algorithm and mechanism type is not available from the specified provider
        See Also:
        Provider

      • getMechanismType

        public final String getMechanismType()
        Returns the mechanism type supported by this TransformService.
        Returns:
        the mechanism type

      • getAlgorithm

        public final String getAlgorithm()
        Returns the URI of the algorithm supported by this TransformService.
        Specified by:
        getAlgorithm in interface AlgorithmMethod
        Returns:
        the algorithm URI

      • getProvider

        public final Provider getProvider()
        Returns the provider of this TransformService.
        Returns:
        the provider

      • init

        public abstract void init(TransformParameterSpec params)
                   throws InvalidAlgorithmParameterException
        Initializes this TransformService with the specified parameters.

        If the parameters exist in XML form, the init(XMLStructure, XMLCryptoContext) method should be used to initialize the TransformService.

        Parameters:
        params - the algorithm parameters (may be null if not required or optional)
        Throws:
        InvalidAlgorithmParameterException - if the specified parameters are invalid for this algorithm

      • marshalParams

        public abstract void marshalParams(XMLStructure parent,
                                   XMLCryptoContext context)
                            throws MarshalException
        Marshals the algorithm-specific parameters. If there are no parameters to be marshalled, this method returns without throwing an exception.
        Parameters:
        parent - a mechanism-specific structure containing the parent node that the marshalled parameters should be appended to
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        Throws:
        ClassCastException - if the type of parent or context is not compatible with this TransformService
        NullPointerException - if parent is null
        MarshalException - if the parameters cannot be marshalled

      • init

        public abstract void init(XMLStructure parent,
                          XMLCryptoContext context)
                   throws InvalidAlgorithmParameterException
        Initializes this TransformService with the specified parameters and document context.
        Parameters:
        parent - a mechanism-specific structure containing the parent structure
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        Throws:
        ClassCastException - if the type of parent or context is not compatible with this TransformService
        NullPointerException - if parent is null
        InvalidAlgorithmParameterException - if the specified parameters are invalid for this algorithm
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface XMLObject

  • All Superinterfaces:
    XMLStructure

    public interface XMLObject
extends XMLStructure
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. An XMLObject may contain any data and may include optional MIME type, ID, and encoding attributes. The XML Schema Definition is defined as:

 <element name="Object" type="ds:ObjectType"/>
 <complexType name="ObjectType" mixed="true">
   <sequence minOccurs="0" maxOccurs="unbounded">
     <any namespace="##any" processContents="lax"/>
   </sequence>
   <attribute name="Id" type="ID" use="optional"/>
   <attribute name="MimeType" type="string" use="optional"/>
   <attribute name="Encoding" type="anyURI" use="optional"/>
 </complexType>
    A XMLObject instance may be created by invoking the newXMLObject method of the XMLSignatureFactory class; for example:
       XMLSignatureFactory fac = XMLSignatureFactory.getInstance("DOM");
   List content = Collections.singletonList(fac.newManifest(references)));
   XMLObject object = factory.newXMLObject(content, "object-1", null, null);

    Note that this class is named XMLObject rather than Object to avoid naming clashes with the existing java.lang.Object class.

    Since:
    1.6
    See Also:
    XMLSignatureFactory.newXMLObject(List, String, String, String)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String TYPE
      URI that identifies the Object element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      List getContent()
      Returns an unmodifiable list of XMLStructures contained in this XMLObject, which represent elements from any namespace.
      String getEncoding()
      Returns the encoding URI of this XMLObject.
      String getId()
      Returns the Id of this XMLObject.
      String getMimeType()
      Returns the mime type of this XMLObject.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • TYPE

        static final String TYPE
        URI that identifies the Object element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
        See Also:
        Constant Field Values

    • Method Detail

      • getContent

        List getContent()
        Returns an unmodifiable list of XMLStructures contained in this XMLObject, which represent elements from any namespace.

        If there is a public subclass representing the type of XMLStructure, it is returned as an instance of that class (ex: a SignatureProperties element would be returned as an instance of SignatureProperties).

        Returns:
        an unmodifiable list of XMLStructures (may be empty but never null)

      • getId

        String getId()
        Returns the Id of this XMLObject.
        Returns:
        the Id (or null if not specified)

      • getMimeType

        String getMimeType()
        Returns the mime type of this XMLObject. The mime type is an optional attribute which describes the data within this XMLObject (independent of its encoding).
        Returns:
        the mime type (or null if not specified)

      • getEncoding

        String getEncoding()
        Returns the encoding URI of this XMLObject. The encoding URI identifies the method by which the object is encoded.
        Returns:
        the encoding URI (or null if not specified)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLSignature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface XMLSignature

  • All Superinterfaces:
    XMLStructure

    public interface XMLSignature
extends XMLStructure
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. This class contains methods for signing and validating XML signatures with behavior as defined by the W3C specification. The XML Schema Definition is defined as:

 <element name="Signature" type="ds:SignatureType"/>
 <complexType name="SignatureType">
    <sequence>
      <element ref="ds:SignedInfo"/>
      <element ref="ds:SignatureValue"/>
      <element ref="ds:KeyInfo" minOccurs="0"/>
      <element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
    </sequence>
    <attribute name="Id" type="ID" use="optional"/>
 </complexType>

    An XMLSignature instance may be created by invoking one of the newXMLSignature methods of the XMLSignatureFactory class.

    If the contents of the underlying document containing the XMLSignature are subsequently modified, the behavior is undefined.

    Note that this class is named XMLSignature rather than Signature to avoid naming clashes with the existing java.security.Signature class.

    Since:
    1.6
    See Also:
    XMLSignatureFactory.newXMLSignature(SignedInfo, KeyInfo), XMLSignatureFactory.newXMLSignature(SignedInfo, KeyInfo, List, String, String)

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static interface  XMLSignature.SignatureValue
      A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String XMLNS
      The XML Namespace URI of the W3C Recommendation for XML-Signature Syntax and Processing.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getId()
      Returns the optional Id of this XMLSignature.
      KeyInfo getKeyInfo()
      Returns the key info of this XMLSignature.
      KeySelectorResult getKeySelectorResult()
      Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.
      List getObjects()
      Returns an unmodifiable list of XMLObjects contained in this XMLSignature.
      XMLSignature.SignatureValue getSignatureValue()
      Returns the signature value of this XMLSignature.
      SignedInfo getSignedInfo()
      Returns the signed info of this XMLSignature.
      void sign(XMLSignContext signContext)
      Signs this XMLSignature.
      boolean validate(XMLValidateContext validateContext)
      Validates the signature according to the core validation processing rules.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • XMLNS

        static final String XMLNS
        The XML Namespace URI of the W3C Recommendation for XML-Signature Syntax and Processing.
        See Also:
        Constant Field Values

    • Method Detail

      • validate

        boolean validate(XMLValidateContext validateContext)
          throws XMLSignatureException
        Validates the signature according to the core validation processing rules. This method validates the signature using the existing state, it does not unmarshal and reinitialize the contents of the XMLSignature using the location information specified in the context.

        This method only validates the signature the first time it is invoked. On subsequent invocations, it returns a cached result.

        Parameters:
        validateContext - the validating context
        Returns:
        true if the signature passed core validation, otherwise false
        Throws:
        ClassCastException - if the type of validateContext is not compatible with this XMLSignature
        NullPointerException - if validateContext is null
        XMLSignatureException - if an unexpected error occurs during validation that prevented the validation operation from completing

      • getKeyInfo

        KeyInfo getKeyInfo()
        Returns the key info of this XMLSignature.
        Returns:
        the key info (may be null if not specified)

      • getSignedInfo

        SignedInfo getSignedInfo()
        Returns the signed info of this XMLSignature.
        Returns:
        the signed info (never null)

      • getObjects

        List getObjects()
        Returns an unmodifiable list of XMLObjects contained in this XMLSignature.
        Returns:
        an unmodifiable list of XMLObjects (may be empty but never null)

      • getId

        String getId()
        Returns the optional Id of this XMLSignature.
        Returns:
        the Id (may be null if not specified)

      • getSignatureValue

        XMLSignature.SignatureValue getSignatureValue()
        Returns the signature value of this XMLSignature.
        Returns:
        the signature value

      • sign

        void sign(XMLSignContext signContext)
   throws MarshalException,
          XMLSignatureException
        Signs this XMLSignature.

        If this method throws an exception, this XMLSignature and the signContext parameter will be left in the state that it was in prior to the invocation.

        Parameters:
        signContext - the signing context
        Throws:
        ClassCastException - if the type of signContext is not compatible with this XMLSignature
        NullPointerException - if signContext is null
        MarshalException - if an exception occurs while marshalling
        XMLSignatureException - if an unexpected exception occurs while generating the signature

      • getKeySelectorResult

        KeySelectorResult getKeySelectorResult()
        Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.
        Returns:
        the key selector result, or null if a key selector has not been specified or this XMLSignature has not been signed or validated
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLSignature.SignatureValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface XMLSignature.SignatureValue

  • All Superinterfaces:
    XMLStructure
    Enclosing interface:
    XMLSignature

    public static interface XMLSignature.SignatureValue
extends XMLStructure
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="SignatureValue" type="ds:SignatureValueType"/>
     <complexType name="SignatureValueType">
       <simpleContent>
         <extension base="base64Binary">
           <attribute name="Id" type="ID" use="optional"/>
         </extension>
       </simpleContent>
     </complexType>

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getId()
      Returns the optional Id attribute of this SignatureValue, which permits this element to be referenced from elsewhere.
      byte[] getValue()
      Returns the signature value of this SignatureValue.
      boolean validate(XMLValidateContext validateContext)
      Validates the signature value.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getId

        String getId()
        Returns the optional Id attribute of this SignatureValue, which permits this element to be referenced from elsewhere.
        Returns:
        the Id attribute (may be null if not specified)

      • getValue

        byte[] getValue()
        Returns the signature value of this SignatureValue.
        Returns:
        the signature value (may be null if the XMLSignature has not been signed yet). Each invocation of this method returns a new clone of the array to prevent subsequent modification.

      • validate

        boolean validate(XMLValidateContext validateContext)
          throws XMLSignatureException
        Validates the signature value. This method performs a cryptographic validation of the signature calculated over the SignedInfo of the XMLSignature.

        This method only validates the signature the first time it is invoked. On subsequent invocations, it returns a cached result.

        Parameters:
        validateContext - the validating context
        Returns:
        true if the signature was validated successfully; false otherwise
        Throws:
        NullPointerException - if validateContext is null
        XMLSignatureException - if an unexpected exception occurs while validating the signature
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLSignatureException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Class XMLSignatureException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.dsig.XMLSignatureException
  • All Implemented Interfaces:
    Serializable

    public class XMLSignatureException
extends Exception
    Indicates an exceptional condition that occurred during the XML signature generation or validation process.

    An XMLSignatureException can contain a cause: another throwable that caused this XMLSignatureException to get thrown.

    Since:
    1.6
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLSignatureException()
      Constructs a new XMLSignatureException with null as its detail message.
      XMLSignatureException(String message)
      Constructs a new XMLSignatureException with the specified detail message.
      XMLSignatureException(String message, Throwable cause)
      Constructs a new XMLSignatureException with the specified detail message and cause.
      XMLSignatureException(Throwable cause)
      Constructs a new XMLSignatureException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this XMLSignatureException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this XMLSignatureException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print writer.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • XMLSignatureException

        public XMLSignatureException()
        Constructs a new XMLSignatureException with null as its detail message.

      • XMLSignatureException

        public XMLSignatureException(String message)
        Constructs a new XMLSignatureException with the specified detail message.
        Parameters:
        message - the detail message

      • XMLSignatureException

        public XMLSignatureException(String message,
                             Throwable cause)
        Constructs a new XMLSignatureException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        Parameters:
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • XMLSignatureException

        public XMLSignatureException(Throwable cause)
        Constructs a new XMLSignatureException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • Method Detail

      • getCause

        public Throwable getCause()
        Returns the cause of this XMLSignatureException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this XMLSignatureException to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this XMLSignatureException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this XMLSignatureException, its backtrace and the cause's backtrace to the standard error stream.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print stream.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print writer.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - PrintWriter to use for output
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLSignatureFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Class XMLSignatureFactory

  • java.lang.Object
    • javax.xml.crypto.dsig.XMLSignatureFactory

  • public abstract class XMLSignatureFactory
extends Object
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.

    XMLSignatureFactory Type

    Each instance of XMLSignatureFactory supports a specific XML mechanism type. To create an XMLSignatureFactory, call one of the static getInstance methods, passing in the XML mechanism type desired, for example:

    XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");

    The objects that this factory produces will be based on DOM and abide by the DOM interoperability requirements as defined in the DOM Mechanism Requirements section of the API overview. See the Service Providers section of the API overview for a list of standard mechanism types.

    XMLSignatureFactory implementations are registered and loaded using the Provider mechanism. For example, a service provider that supports the DOM mechanism would be specified in the Provider subclass as:

         put("XMLSignatureFactory.DOM", "org.example.DOMXMLSignatureFactory");

    An implementation MUST minimally support the default mechanism type: DOM.

    Note that a caller must use the same XMLSignatureFactory instance to create the XMLStructures of a particular XMLSignature that is to be generated. The behavior is undefined if XMLStructures from different providers or different mechanism types are used together.

    Also, the XMLStructures that are created by this factory may contain state specific to the XMLSignature and are not intended to be reusable.

    Creating XMLSignatures from scratch

    Once the XMLSignatureFactory has been created, objects can be instantiated by calling the appropriate method. For example, a Reference instance may be created by invoking one of the newReference methods.

    Unmarshalling XMLSignatures from XML

    Alternatively, an XMLSignature may be created from an existing XML representation by invoking the unmarshalXMLSignature method and passing it a mechanism-specific XMLValidateContext instance containing the XML content:

     DOMValidateContext context = new DOMValidateContext(key, signatureElement);
 XMLSignature signature = factory.unmarshalXMLSignature(context);
    Each XMLSignatureFactory must support the required XMLValidateContext types for that factory type, but may support others. A DOM XMLSignatureFactory must support DOMValidateContext objects.

    Signing and marshalling XMLSignatures to XML

    Each XMLSignature created by the factory can also be marshalled to an XML representation and signed, by invoking the sign method of the XMLSignature object and passing it a mechanism-specific XMLSignContext object containing the signing key and marshalling parameters (see DOMSignContext). For example:
        DOMSignContext context = new DOMSignContext(privateKey, document);
    signature.sign(context);
    Concurrent Access

    The static methods of this class are guaranteed to be thread-safe. Multiple threads may concurrently invoke the static methods defined in this class with no ill effects.

    However, this is not true for the non-static methods defined by this class. Unless otherwise documented by a specific provider, threads that need to access a single XMLSignatureFactory instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different XMLSignatureFactory instance need not synchronize.

    Since:
    1.6

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected XMLSignatureFactory()
      Default constructor, for invocation by subclasses.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      static XMLSignatureFactory getInstance()
      Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").
      static XMLSignatureFactory getInstance(String mechanismType)
      Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static XMLSignatureFactory getInstance(String mechanismType, Provider provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static XMLSignatureFactory getInstance(String mechanismType, String provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      KeyInfoFactory getKeyInfoFactory()
      Returns a KeyInfoFactory that creates KeyInfo objects.
      String getMechanismType()
      Returns the type of the XML processing mechanism and representation supported by this XMLSignatureFactory (ex: "DOM").
      Provider getProvider()
      Returns the provider of this XMLSignatureFactory.
      abstract URIDereferencer getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.
      abstract boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.
      abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm, XMLStructure params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract DigestMethod newDigestMethod(String algorithm, DigestMethodParameterSpec params)
      Creates a DigestMethod for the specified algorithm URI and parameters.
      abstract Manifest newManifest(List references)
      Creates a Manifest containing the specified list of References.
      abstract Manifest newManifest(List references, String id)
      Creates a Manifest containing the specified list of References and optional id.
      abstract Reference newReference(String uri, DigestMethod dm)
      Creates a Reference with the specified URI and digest method.
      abstract Reference newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference newReference(String uri, DigestMethod dm, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
      Creates a Reference with the specified parameters and pre-calculated digest value.
      abstract SignatureMethod newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
      Creates a SignatureMethod for the specified algorithm URI and parameters.
      abstract SignatureProperties newSignatureProperties(List properties, String id)
      Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
      abstract SignatureProperty newSignatureProperty(List content, String target, String id)
      Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
      abstract SignedInfo newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
      abstract Transform newTransform(String algorithm, TransformParameterSpec params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract Transform newTransform(String algorithm, XMLStructure params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract XMLObject newXMLObject(List content, String id, String mimeType, String encoding)
      Creates an XMLObject from the specified parameters.
      abstract XMLSignature newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.
      abstract XMLSignature unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
      abstract XMLSignature unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XMLSignatureFactory

        protected XMLSignatureFactory()
        Default constructor, for invocation by subclasses.

    • Method Detail

      • getInstance

        public static XMLSignatureFactory getInstance(String mechanismType)
        Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate an XMLSignatureFactory implementation of the desired mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new XMLSignatureFactory object from the first Provider that supports the specified mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Parameters:
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        Returns:
        a new XMLSignatureFactory
        Throws:
        NullPointerException - if mechanismType is null
        NoSuchMechanismException - if no Provider supports an XMLSignatureFactory implementation for the specified mechanism
        See Also:
        Provider

      • getInstance

        public static XMLSignatureFactory getInstance(String mechanismType,
                                              Provider provider)
        Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. Note that the specified Provider object does not have to be registered in the provider list.
        Parameters:
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the Provider object
        Returns:
        a new XMLSignatureFactory
        Throws:
        NullPointerException - if provider or mechanismType is null
        NoSuchMechanismException - if an XMLSignatureFactory implementation for the specified mechanism is not available from the specified Provider object
        See Also:
        Provider

      • getInstance

        public static XMLSignatureFactory getInstance(String mechanismType,
                                              String provider)
                                       throws NoSuchProviderException
        Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Parameters:
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the string name of the provider
        Returns:
        a new XMLSignatureFactory
        Throws:
        NoSuchProviderException - if the specified provider is not registered in the security provider list
        NullPointerException - if provider or mechanismType is null
        NoSuchMechanismException - if an XMLSignatureFactory implementation for the specified mechanism is not available from the specified provider
        See Also:
        Provider

      • getInstance

        public static XMLSignatureFactory getInstance()
        Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate an XMLSignatureFactory implementation of the default mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new XMLSignatureFactory object from the first Provider that supports the DOM mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Returns:
        a new XMLSignatureFactory
        Throws:
        NoSuchMechanismException - if no Provider supports an XMLSignatureFactory implementation for the DOM mechanism
        See Also:
        Provider

      • getMechanismType

        public final String getMechanismType()
        Returns the type of the XML processing mechanism and representation supported by this XMLSignatureFactory (ex: "DOM").
        Returns:
        the XML processing mechanism type supported by this XMLSignatureFactory

      • getProvider

        public final Provider getProvider()
        Returns the provider of this XMLSignatureFactory.
        Returns:
        the provider of this XMLSignatureFactory

      • newXMLSignature

        public abstract XMLSignature newXMLSignature(SignedInfo si,
                                             KeyInfo ki)
        Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
        Parameters:
        si - the signed info
        ki - the key info (may be null)
        Returns:
        an XMLSignature
        Throws:
        NullPointerException - if si is null

      • newXMLSignature

        public abstract XMLSignature newXMLSignature(SignedInfo si,
                                             KeyInfo ki,
                                             List objects,
                                             String id,
                                             String signatureValueId)
        Creates an XMLSignature and initializes it with the specified parameters.
        Parameters:
        si - the signed info
        ki - the key info (may be null)
        objects - a list of XMLObjects (may be empty or null)
        id - the Id (may be null)
        signatureValueId - the SignatureValue Id (may be null)
        Returns:
        an XMLSignature
        Throws:
        NullPointerException - if si is null
        ClassCastException - if any of the objects are not of type XMLObject

      • newReference

        public abstract Reference newReference(String uri,
                                       DigestMethod dm)
        Creates a Reference with the specified URI and digest method.
        Parameters:
        uri - the reference URI (may be null)
        dm - the digest method
        Returns:
        a Reference
        Throws:
        IllegalArgumentException - if uri is not RFC 2396 compliant
        NullPointerException - if dm is null

      • newReference

        public abstract Reference newReference(String uri,
                                       DigestMethod dm,
                                       List transforms,
                                       String type,
                                       String id)
        Creates a Reference with the specified parameters.
        Parameters:
        uri - the reference URI (may be null)
        dm - the digest method
        transforms - a list of Transforms. The list is defensively copied to protect against subsequent modification. May be null or empty.
        type - the reference type, as a URI (may be null)
        id - the reference ID (may be null)
        Returns:
        a Reference
        Throws:
        ClassCastException - if any of the transforms are not of type Transform
        IllegalArgumentException - if uri is not RFC 2396 compliant
        NullPointerException - if dm is null

      • newReference

        public abstract Reference newReference(String uri,
                                       DigestMethod dm,
                                       List transforms,
                                       String type,
                                       String id,
                                       byte[] digestValue)
        Creates a Reference with the specified parameters and pre-calculated digest value.

        This method is useful when the digest value of a Reference has been previously computed. See for example, the OASIS-DSS (Digital Signature Services) specification.

        Parameters:
        uri - the reference URI (may be null)
        dm - the digest method
        transforms - a list of Transforms. The list is defensively copied to protect against subsequent modification. May be null or empty.
        type - the reference type, as a URI (may be null)
        id - the reference ID (may be null)
        digestValue - the digest value. The array is cloned to protect against subsequent modification.
        Returns:
        a Reference
        Throws:
        ClassCastException - if any of the transforms are not of type Transform
        IllegalArgumentException - if uri is not RFC 2396 compliant
        NullPointerException - if dm or digestValue is null

      • newReference

        public abstract Reference newReference(String uri,
                                       DigestMethod dm,
                                       List appliedTransforms,
                                       Data result,
                                       List transforms,
                                       String type,
                                       String id)
        Creates a Reference with the specified parameters.

        This method is useful when a list of transforms have already been applied to the Reference. See for example, the OASIS-DSS (Digital Signature Services) specification.

        When an XMLSignature containing this reference is generated, the specified transforms (if non-null) are applied to the specified result. The Transforms element of the resulting Reference element is set to the concatenation of the appliedTransforms and transforms.

        Parameters:
        uri - the reference URI (may be null)
        dm - the digest method
        appliedTransforms - a list of Transforms that have already been applied. The list is defensively copied to protect against subsequent modification. The list must contain at least one entry.
        result - the result of processing the sequence of appliedTransforms
        transforms - a list of Transforms that are to be applied when generating the signature. The list is defensively copied to protect against subsequent modification. May be null or empty.
        type - the reference type, as a URI (may be null)
        id - the reference ID (may be null)
        Returns:
        a Reference
        Throws:
        ClassCastException - if any of the transforms (in either list) are not of type Transform
        IllegalArgumentException - if uri is not RFC 2396 compliant or appliedTransforms is empty
        NullPointerException - if dm, appliedTransforms or result is null

      • newSignedInfo

        public abstract SignedInfo newSignedInfo(CanonicalizationMethod cm,
                                         SignatureMethod sm,
                                         List references)
        Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
        Parameters:
        cm - the canonicalization method
        sm - the signature method
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        Returns:
        a SignedInfo
        Throws:
        ClassCastException - if any of the references are not of type Reference
        IllegalArgumentException - if references is empty
        NullPointerException - if any of the parameters are null

      • newSignedInfo

        public abstract SignedInfo newSignedInfo(CanonicalizationMethod cm,
                                         SignatureMethod sm,
                                         List references,
                                         String id)
        Creates a SignedInfo with the specified parameters.
        Parameters:
        cm - the canonicalization method
        sm - the signature method
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        id - the id (may be null)
        Returns:
        a SignedInfo
        Throws:
        ClassCastException - if any of the references are not of type Reference
        IllegalArgumentException - if references is empty
        NullPointerException - if cm, sm, or references are null

      • newXMLObject

        public abstract XMLObject newXMLObject(List content,
                                       String id,
                                       String mimeType,
                                       String encoding)
        Creates an XMLObject from the specified parameters.
        Parameters:
        content - a list of XMLStructures. The list is defensively copied to protect against subsequent modification. May be null or empty.
        id - the Id (may be null)
        mimeType - the mime type (may be null)
        encoding - the encoding (may be null)
        Returns:
        an XMLObject
        Throws:
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newManifest

        public abstract Manifest newManifest(List references)
        Creates a Manifest containing the specified list of References.
        Parameters:
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        Returns:
        a Manifest
        Throws:
        NullPointerException - if references is null
        IllegalArgumentException - if references is empty
        ClassCastException - if references contains any entries that are not of type Reference

      • newManifest

        public abstract Manifest newManifest(List references,
                                     String id)
        Creates a Manifest containing the specified list of References and optional id.
        Parameters:
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        id - the id (may be null)
        Returns:
        a Manifest
        Throws:
        NullPointerException - if references is null
        IllegalArgumentException - if references is empty
        ClassCastException - if references contains any entries that are not of type Reference

      • newSignatureProperty

        public abstract SignatureProperty newSignatureProperty(List content,
                                                       String target,
                                                       String id)
        Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
        Parameters:
        content - a list of one or more XMLStructures. The list is defensively copied to protect against subsequent modification.
        target - the target URI of the Signature that this property applies to
        id - the id (may be null)
        Returns:
        a SignatureProperty
        Throws:
        NullPointerException - if content or target is null
        IllegalArgumentException - if content is empty
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newSignatureProperties

        public abstract SignatureProperties newSignatureProperties(List properties,
                                                           String id)
        Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
        Parameters:
        properties - a list of one or more SignaturePropertys. The list is defensively copied to protect against subsequent modification.
        id - the id (may be null)
        Returns:
        a SignatureProperties
        Throws:
        NullPointerException - if properties is null
        IllegalArgumentException - if properties is empty
        ClassCastException - if properties contains any entries that are not of type SignatureProperty

      • newDigestMethod

        public abstract DigestMethod newDigestMethod(String algorithm,
                                             DigestMethodParameterSpec params)
                                      throws NoSuchAlgorithmException,
                                             InvalidAlgorithmParameterException
        Creates a DigestMethod for the specified algorithm URI and parameters.
        Parameters:
        algorithm - the URI identifying the digest algorithm
        params - algorithm-specific digest parameters (may be null)
        Returns:
        the DigestMethod
        Throws:
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newSignatureMethod

        public abstract SignatureMethod newSignatureMethod(String algorithm,
                                                   SignatureMethodParameterSpec params)
                                            throws NoSuchAlgorithmException,
                                                   InvalidAlgorithmParameterException
        Creates a SignatureMethod for the specified algorithm URI and parameters.
        Parameters:
        algorithm - the URI identifying the signature algorithm
        params - algorithm-specific signature parameters (may be null)
        Returns:
        the SignatureMethod
        Throws:
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newTransform

        public abstract Transform newTransform(String algorithm,
                                       TransformParameterSpec params)
                                throws NoSuchAlgorithmException,
                                       InvalidAlgorithmParameterException
        Creates a Transform for the specified algorithm URI and parameters.
        Parameters:
        algorithm - the URI identifying the transform algorithm
        params - algorithm-specific transform parameters (may be null)
        Returns:
        the Transform
        Throws:
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newTransform

        public abstract Transform newTransform(String algorithm,
                                       XMLStructure params)
                                throws NoSuchAlgorithmException,
                                       InvalidAlgorithmParameterException
        Creates a Transform for the specified algorithm URI and parameters. The parameters are specified as a mechanism-specific XMLStructure (ex: DOMStructure). This method is useful when the parameters are in XML form or there is no standard class for specifying the parameters.
        Parameters:
        algorithm - the URI identifying the transform algorithm
        params - a mechanism-specific XML structure from which to unmarshal the parameters from (may be null if not required or optional)
        Returns:
        the Transform
        Throws:
        ClassCastException - if the type of params is inappropriate for this XMLSignatureFactory
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newCanonicalizationMethod

        public abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm,
                                                                 C14NMethodParameterSpec params)
                                                          throws NoSuchAlgorithmException,
                                                                 InvalidAlgorithmParameterException
        Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
        Parameters:
        algorithm - the URI identifying the canonicalization algorithm
        params - algorithm-specific canonicalization parameters (may be null)
        Returns:
        the CanonicalizationMethod
        Throws:
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newCanonicalizationMethod

        public abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm,
                                                                 XMLStructure params)
                                                          throws NoSuchAlgorithmException,
                                                                 InvalidAlgorithmParameterException
        Creates a CanonicalizationMethod for the specified algorithm URI and parameters. The parameters are specified as a mechanism-specific XMLStructure (ex: DOMStructure). This method is useful when the parameters are in XML form or there is no standard class for specifying the parameters.
        Parameters:
        algorithm - the URI identifying the canonicalization algorithm
        params - a mechanism-specific XML structure from which to unmarshal the parameters from (may be null if not required or optional)
        Returns:
        the CanonicalizationMethod
        Throws:
        ClassCastException - if the type of params is inappropriate for this XMLSignatureFactory
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • getKeyInfoFactory

        public final KeyInfoFactory getKeyInfoFactory()
        Returns a KeyInfoFactory that creates KeyInfo objects. The returned KeyInfoFactory has the same mechanism type and provider as this XMLSignatureFactory.
        Returns:
        a KeyInfoFactory
        Throws:
        NoSuchMechanismException - if a KeyFactory implementation with the same mechanism type and provider is not available

      • unmarshalXMLSignature

        public abstract XMLSignature unmarshalXMLSignature(XMLValidateContext context)
                                            throws MarshalException
        Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
        Parameters:
        context - a mechanism-specific context from which to unmarshal the signature from
        Returns:
        the XMLSignature
        Throws:
        NullPointerException - if context is null
        ClassCastException - if the type of context is inappropriate for this factory
        MarshalException - if an unrecoverable exception occurs during unmarshalling

      • unmarshalXMLSignature

        public abstract XMLSignature unmarshalXMLSignature(XMLStructure xmlStructure)
                                            throws MarshalException
        Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance. This method is useful if you only want to unmarshal (and not validate) an XMLSignature.
        Parameters:
        xmlStructure - a mechanism-specific XML structure from which to unmarshal the signature from
        Returns:
        the XMLSignature
        Throws:
        NullPointerException - if xmlStructure is null
        ClassCastException - if the type of xmlStructure is inappropriate for this factory
        MarshalException - if an unrecoverable exception occurs during unmarshalling

      • isFeatureSupported

        public abstract boolean isFeatureSupported(String feature)
        Indicates whether a specified feature is supported.
        Parameters:
        feature - the feature name (as an absolute URI)
        Returns:
        true if the specified feature is supported, false otherwise
        Throws:
        NullPointerException - if feature is null

      • getURIDereferencer

        public abstract URIDereferencer getURIDereferencer()
        Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.
        Returns:
        a reference to the default URIDereferencer (never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLSignContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface XMLSignContext

  • All Superinterfaces:
    XMLCryptoContext
    All Known Implementing Classes:
    DOMSignContext

    public interface XMLSignContext
extends XMLCryptoContext
    Contains context information for generating XML Signatures. This interface is primarily intended for type-safety.

    Note that XMLSignContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if an XMLSignContext is used with different signature structures (for example, you should not use the same XMLSignContext instance to sign two different XMLSignature objects).

    Supported Properties

    The following properties can be set using the setProperty method.

    • javax.xml.crypto.dsig.cacheReference: value must be a Boolean. This property controls whether or not the digested Reference objects will cache the dereferenced content and pre-digested input for subsequent retrieval via the Reference.getDereferencedData and Reference.getDigestInputStream methods. The default value if not specified is Boolean.FALSE.
    Since:
    1.6
    See Also:
    XMLSignature.sign(XMLSignContext)

    • Method Summary

      • Methods inherited from interface javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLValidateContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig

Interface XMLValidateContext

  • All Superinterfaces:
    XMLCryptoContext
    All Known Implementing Classes:
    DOMValidateContext

    public interface XMLValidateContext
extends XMLCryptoContext
    Contains context information for validating XML Signatures. This interface is primarily intended for type-safety.

    Note that XMLValidateContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if an XMLValidateContext is used with different signature structures (for example, you should not use the same XMLValidateContext instance to validate two different XMLSignature objects).

    Supported Properties

    The following properties can be set by an application using the setProperty method.

    • javax.xml.crypto.dsig.cacheReference: value must be a Boolean. This property controls whether or not the Reference.validate method will cache the dereferenced content and pre-digested input for subsequent retrieval via the Reference.getDereferencedData and Reference.getDigestInputStream methods. The default value if not specified is Boolean.FALSE.
    Since:
    1.6
    See Also:
    XMLSignature.validate(XMLValidateContext), Reference.validate(XMLValidateContext)

    • Method Summary

      • Methods inherited from interface javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.CanonicalizationMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.CanonicalizationMethod

  • Packages that use CanonicalizationMethod
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of CanonicalizationMethod in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return CanonicalizationMethod
      Modifier and Type Method and Description
      CanonicalizationMethod SignedInfo.getCanonicalizationMethod()
      Returns the canonicalization method of this SignedInfo.
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      Methods in javax.xml.crypto.dsig with parameters of type CanonicalizationMethod
      Modifier and Type Method and Description
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.DigestMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.DigestMethod

  • Packages that use DigestMethod
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of DigestMethod in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return DigestMethod
      Modifier and Type Method and Description
      DigestMethod Reference.getDigestMethod()
      Returns the digest method of this Reference.
      abstract DigestMethod XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
      Creates a DigestMethod for the specified algorithm URI and parameters.
      Methods in javax.xml.crypto.dsig with parameters of type DigestMethod
      Modifier and Type Method and Description
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm)
      Creates a Reference with the specified URI and digest method.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
      Creates a Reference with the specified parameters and pre-calculated digest value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.Manifest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.Manifest

  • Packages that use Manifest
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of Manifest in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Manifest
      Modifier and Type Method and Description
      abstract Manifest XMLSignatureFactory.newManifest(List references)
      Creates a Manifest containing the specified list of References.
      abstract Manifest XMLSignatureFactory.newManifest(List references, String id)
      Creates a Manifest containing the specified list of References and optional id.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.Reference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.Reference

  • Packages that use Reference
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of Reference in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Reference
      Modifier and Type Method and Description
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm)
      Creates a Reference with the specified URI and digest method.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
      Creates a Reference with the specified parameters and pre-calculated digest value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.SignatureMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.SignatureMethod

  • Packages that use SignatureMethod
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignatureMethod in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignatureMethod
      Modifier and Type Method and Description
      SignatureMethod SignedInfo.getSignatureMethod()
      Returns the signature method of this SignedInfo.
      abstract SignatureMethod XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
      Creates a SignatureMethod for the specified algorithm URI and parameters.
      Methods in javax.xml.crypto.dsig with parameters of type SignatureMethod
      Modifier and Type Method and Description
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.SignatureProperties (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.SignatureProperties

  • Packages that use SignatureProperties
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignatureProperties in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignatureProperties
      Modifier and Type Method and Description
      abstract SignatureProperties XMLSignatureFactory.newSignatureProperties(List properties, String id)
      Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.SignatureProperty (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.SignatureProperty

  • Packages that use SignatureProperty
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignatureProperty in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignatureProperty
      Modifier and Type Method and Description
      abstract SignatureProperty XMLSignatureFactory.newSignatureProperty(List content, String target, String id)
      Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.SignedInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.SignedInfo

  • Packages that use SignedInfo
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignedInfo in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignedInfo
      Modifier and Type Method and Description
      SignedInfo XMLSignature.getSignedInfo()
      Returns the signed info of this XMLSignature.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
      Methods in javax.xml.crypto.dsig with parameters of type SignedInfo
      Modifier and Type Method and Description
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.Transform (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.Transform

  • Packages that use Transform
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of Transform in javax.xml.crypto.dsig

      Subinterfaces of Transform in javax.xml.crypto.dsig
      Modifier and Type Interface and Description
      interface  CanonicalizationMethod
      A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Classes in javax.xml.crypto.dsig that implement Transform
      Modifier and Type Class and Description
      class  TransformService
      A Service Provider Interface for transform and canonicalization algorithms.
      Methods in javax.xml.crypto.dsig that return Transform
      Modifier and Type Method and Description
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, XMLStructure params)
      Creates a Transform for the specified algorithm URI and parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.TransformException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.TransformException

  • Packages that use TransformException
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of TransformException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw TransformException
      Modifier and Type Method and Description
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.TransformService (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.TransformService

  • Packages that use TransformService
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of TransformService in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return TransformService
      Modifier and Type Method and Description
      static TransformService TransformService.getInstance(String algorithm, String mechanismType)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).
      static TransformService TransformService.getInstance(String algorithm, String mechanismType, Provider provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
      static TransformService TransformService.getInstance(String algorithm, String mechanismType, String provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.XMLObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.XMLObject

  • Packages that use XMLObject
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLObject in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLObject
      Modifier and Type Method and Description
      abstract XMLObject XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding)
      Creates an XMLObject from the specified parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.XMLSignature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.XMLSignature

  • Packages that use XMLSignature
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignature in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLSignature
      Modifier and Type Method and Description
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.XMLSignature.SignatureValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.XMLSignature.SignatureValue

  • Packages that use XMLSignature.SignatureValue
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignature.SignatureValue in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLSignature.SignatureValue
      Modifier and Type Method and Description
      XMLSignature.SignatureValue XMLSignature.getSignatureValue()
      Returns the signature value of this XMLSignature.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.XMLSignatureException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.XMLSignatureException

  • Packages that use XMLSignatureException
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignatureException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw XMLSignatureException
      Modifier and Type Method and Description
      void XMLSignature.sign(XMLSignContext signContext)
      Signs this XMLSignature.
      boolean XMLSignature.validate(XMLValidateContext validateContext)
      Validates the signature according to the core validation processing rules.
      boolean XMLSignature.SignatureValue.validate(XMLValidateContext validateContext)
      Validates the signature value.
      boolean Reference.validate(XMLValidateContext validateContext)
      Validates this reference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.XMLSignatureFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.XMLSignatureFactory

  • Packages that use XMLSignatureFactory
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignatureFactory in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLSignatureFactory
      Modifier and Type Method and Description
      static XMLSignatureFactory XMLSignatureFactory.getInstance()
      Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").
      static XMLSignatureFactory XMLSignatureFactory.getInstance(String mechanismType)
      Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static XMLSignatureFactory XMLSignatureFactory.getInstance(String mechanismType, Provider provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static XMLSignatureFactory XMLSignatureFactory.getInstance(String mechanismType, String provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.XMLSignContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.XMLSignContext

  • Packages that use XMLSignContext
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of XMLSignContext in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type XMLSignContext
      Modifier and Type Method and Description
      void XMLSignature.sign(XMLSignContext signContext)
      Signs this XMLSignature.

    • Uses of XMLSignContext in javax.xml.crypto.dsig.dom

      Classes in javax.xml.crypto.dsig.dom that implement XMLSignContext
      Modifier and Type Class and Description
      class  DOMSignContext
      A DOM-specific XMLSignContext.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.XMLValidateContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.XMLValidateContext

  • Packages that use XMLValidateContext
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of XMLValidateContext in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type XMLValidateContext
      Modifier and Type Method and Description
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
      boolean XMLSignature.validate(XMLValidateContext validateContext)
      Validates the signature according to the core validation processing rules.
      boolean XMLSignature.SignatureValue.validate(XMLValidateContext validateContext)
      Validates the signature value.
      boolean Reference.validate(XMLValidateContext validateContext)
      Validates this reference.

    • Uses of XMLValidateContext in javax.xml.crypto.dsig.dom

      Classes in javax.xml.crypto.dsig.dom that implement XMLValidateContext
      Modifier and Type Class and Description
      class  DOMValidateContext
      A DOM-specific XMLValidateContext.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.crypto.dsig.dom (Java Platform SE 8 )

compact3 - javax.xml.crypto.dsig.dom

Classes

  • DOMSignContext
  • DOMValidateContext


javax.xml.crypto.dsig.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.crypto.dsig.dom

DOM-specific classes for the javax.xml.crypto.dsig package.

See: Description

  • Class Summary
    Class Description
    DOMSignContext
    A DOM-specific XMLSignContext.
    DOMValidateContext
    A DOM-specific XMLValidateContext.

Package javax.xml.crypto.dsig.dom Description

DOM-specific classes for the javax.xml.crypto.dsig package. Only users who are using a DOM-based XMLSignatureFactory or KeyInfoFactory should need to make direct use of this package.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMSignContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.dom

Class DOMSignContext

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext
      • javax.xml.crypto.dsig.dom.DOMSignContext
  • All Implemented Interfaces:
    XMLSignContext, XMLCryptoContext

    public class DOMSignContext
extends DOMCryptoContext
implements XMLSignContext
    A DOM-specific XMLSignContext. This class contains additional methods to specify the location in a DOM tree where an XMLSignature object is to be marshalled when generating the signature.

    Note that DOMSignContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if a DOMSignContext is used with different signature structures (for example, you should not use the same DOMSignContext instance to sign two different XMLSignature objects).

    Since:
    1.6

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMSignContext(Key signingKey, Node parent)
      Creates a DOMSignContext with the specified signing key and parent node.
      DOMSignContext(Key signingKey, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Node getNextSibling()
      Returns the nextSibling node.
      Node getParent()
      Returns the parent node.
      void setNextSibling(Node nextSibling)
      Sets the next sibling node.
      void setParent(Node parent)
      Sets the parent node.

      • Methods inherited from class javax.xml.crypto.dom.DOMCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getElementById, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, iterator, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setIdAttributeNS, setKeySelector, setProperty, setURIDereferencer

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

    • Constructor Detail

      • DOMSignContext

        public DOMSignContext(Key signingKey,
                      Node parent)
        Creates a DOMSignContext with the specified signing key and parent node. The signing key is stored in a singleton KeySelector that is returned by the getKeySelector method. The marshalled XMLSignature will be added as the last child element of the specified parent node unless a next sibling node is specified by invoking the setNextSibling method.
        Parameters:
        signingKey - the signing key
        parent - the parent node
        Throws:
        NullPointerException - if signingKey or parent is null

      • DOMSignContext

        public DOMSignContext(Key signingKey,
                      Node parent,
                      Node nextSibling)
        Creates a DOMSignContext with the specified signing key, parent and next sibling nodes. The signing key is stored in a singleton KeySelector that is returned by the getKeySelector method. The marshalled XMLSignature will be inserted as a child element of the specified parent node and immediately before the specified next sibling node.
        Parameters:
        signingKey - the signing key
        parent - the parent node
        nextSibling - the next sibling node
        Throws:
        NullPointerException - if signingKey, parent or nextSibling is null

      • DOMSignContext

        public DOMSignContext(KeySelector ks,
                      Node parent)
        Creates a DOMSignContext with the specified key selector and parent node. The marshalled XMLSignature will be added as the last child element of the specified parent node unless a next sibling node is specified by invoking the setNextSibling method.
        Parameters:
        ks - the key selector
        parent - the parent node
        Throws:
        NullPointerException - if ks or parent is null

      • DOMSignContext

        public DOMSignContext(KeySelector ks,
                      Node parent,
                      Node nextSibling)
        Creates a DOMSignContext with the specified key selector, parent and next sibling nodes. The marshalled XMLSignature will be inserted as a child element of the specified parent node and immediately before the specified next sibling node.
        Parameters:
        ks - the key selector
        parent - the parent node
        nextSibling - the next sibling node
        Throws:
        NullPointerException - if ks, parent or nextSibling is null

    • Method Detail

      • setParent

        public void setParent(Node parent)
        Sets the parent node.
        Parameters:
        parent - the parent node. The marshalled XMLSignature will be added as a child element of this node.
        Throws:
        NullPointerException - if parent is null
        See Also:
        getParent()

      • setNextSibling

        public void setNextSibling(Node nextSibling)
        Sets the next sibling node.
        Parameters:
        nextSibling - the next sibling node. The marshalled XMLSignature will be inserted immediately before this node. Specify null to remove the current setting.
        See Also:
        getNextSibling()

      • getParent

        public Node getParent()
        Returns the parent node.
        Returns:
        the parent node (never null)
        See Also:
        setParent(Node)

      • getNextSibling

        public Node getNextSibling()
        Returns the nextSibling node.
        Returns:
        the nextSibling node, or null if not specified.
        See Also:
        setNextSibling(Node)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMValidateContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.dom

Class DOMValidateContext

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext
      • javax.xml.crypto.dsig.dom.DOMValidateContext
  • All Implemented Interfaces:
    XMLValidateContext, XMLCryptoContext

    public class DOMValidateContext
extends DOMCryptoContext
implements XMLValidateContext
    A DOM-specific XMLValidateContext. This class contains additional methods to specify the location in a DOM tree where an XMLSignature is to be unmarshalled and validated from.

    Note that the behavior of an unmarshalled XMLSignature is undefined if the contents of the underlying DOM tree are modified by the caller after the XMLSignature is created.

    Also, note that DOMValidateContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if a DOMValidateContext is used with different signature structures (for example, you should not use the same DOMValidateContext instance to validate two different XMLSignature objects).

    Since:
    1.6
    See Also:
    XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext)

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMValidateContext(Key validatingKey, Node node)
      Creates a DOMValidateContext containing the specified key and node.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Node getNode()
      Returns the node.
      void setNode(Node node)
      Sets the node.

      • Methods inherited from class javax.xml.crypto.dom.DOMCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getElementById, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, iterator, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setIdAttributeNS, setKeySelector, setProperty, setURIDereferencer

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

    • Constructor Detail

      • DOMValidateContext

        public DOMValidateContext(KeySelector ks,
                          Node node)
        Creates a DOMValidateContext containing the specified key selector and node.
        Parameters:
        ks - a key selector for finding a validation key
        node - the node
        Throws:
        NullPointerException - if ks or node is null

      • DOMValidateContext

        public DOMValidateContext(Key validatingKey,
                          Node node)
        Creates a DOMValidateContext containing the specified key and node. The validating key will be stored in a singleton KeySelector that is returned when the getKeySelector method is called.
        Parameters:
        validatingKey - the validating key
        node - the node
        Throws:
        NullPointerException - if validatingKey or node is null

    • Method Detail

      • setNode

        public void setNode(Node node)
        Sets the node.
        Parameters:
        node - the node
        Throws:
        NullPointerException - if node is null
        See Also:
        getNode()

      • getNode

        public Node getNode()
        Returns the node.
        Returns:
        the node (never null)
        See Also:
        setNode(Node)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig.dom (Java Platform SE 8 )

javax.xml.crypto.dsig.dom

Classes

  • DOMSignContext
  • DOMValidateContext


javax.xml.crypto.dsig.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.crypto.dsig.dom

DOM-specific classes for the javax.xml.crypto.dsig package.

See: Description

  • Class Summary
    Class Description
    DOMSignContext
    A DOM-specific XMLSignContext.
    DOMValidateContext
    A DOM-specific XMLValidateContext.

Package javax.xml.crypto.dsig.dom Description

DOM-specific classes for the javax.xml.crypto.dsig package. Only users who are using a DOM-based XMLSignatureFactory or KeyInfoFactory should need to make direct use of this package.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig.dom Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.crypto.dsig.dom

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
      • javax.xml.crypto.dsig.dom.DOMSignContext (implements javax.xml.crypto.dsig.XMLSignContext)
      • javax.xml.crypto.dsig.dom.DOMValidateContext (implements javax.xml.crypto.dsig.XMLValidateContext)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.crypto.dsig.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.crypto.dsig.dom

No usage of javax.xml.crypto.dsig.dom
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.dom.DOMSignContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.dom.DOMSignContext

No usage of javax.xml.crypto.dsig.dom.DOMSignContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.dom.DOMValidateContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.dom.DOMValidateContext

No usage of javax.xml.crypto.dsig.dom.DOMValidateContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.crypto.dsig.keyinfo (Java Platform SE 8 )

compact3 - javax.xml.crypto.dsig.keyinfo

Interfaces

  • KeyInfo
  • KeyName
  • KeyValue
  • PGPData
  • RetrievalMethod
  • X509Data
  • X509IssuerSerial

Classes

  • KeyInfoFactory


javax.xml.crypto.dsig.keyinfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.crypto.dsig.keyinfo

Classes for parsing and processing KeyInfo elements and structures.

See: Description

  • Interface Summary
    Interface Description
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyName
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyValue
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    PGPData
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    RetrievalMethod
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509Data
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509IssuerSerial
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • Class Summary
    Class Description
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.

Package javax.xml.crypto.dsig.keyinfo Description

Classes for parsing and processing KeyInfo elements and structures. KeyInfo is an optional element that enables the recipient(s) to obtain the key needed to validate an XMLSignature. KeyInfo may contain keys, names, certificates and other public key management information, such as in-band key distribution or key agreement data. This package contains classes representing types defined in the W3C specification for XML Signatures, such as KeyName, KeyValue, RetrievalMethod, X509Data, X509IssuerSerial, and PGPData. KeyInfoFactory is an abstract factory that creates KeyInfo objects from scratch.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeyInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface KeyInfo

  • All Superinterfaces:
    XMLStructure

    public interface KeyInfo
extends XMLStructure
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A KeyInfo contains a list of XMLStructures, each of which contain information that enables the recipient(s) to obtain the key needed to validate an XML signature. The XML Schema Definition is defined as:
     <element name="KeyInfo" type="ds:KeyInfoType"/>
 <complexType name="KeyInfoType" mixed="true">
   <choice maxOccurs="unbounded">
     <element ref="ds:KeyName"/>
     <element ref="ds:KeyValue"/>
     <element ref="ds:RetrievalMethod"/>
     <element ref="ds:X509Data"/>
     <element ref="ds:PGPData"/>
     <element ref="ds:SPKIData"/>
     <element ref="ds:MgmtData"/>
     <any processContents="lax" namespace="##other"/>
     <!-- (1,1) elements from (0,unbounded) namespaces -->
   </choice>
   <attribute name="Id" type="ID" use="optional"/>
 </complexType>
    A KeyInfo instance may be created by invoking one of the newKeyInfo methods of the KeyInfoFactory class, and passing it a list of one or more XMLStructures and an optional id parameter; for example:
       KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
   KeyInfo keyInfo = factory.newKeyInfo
      (Collections.singletonList(factory.newKeyName("Alice"), "keyinfo-1"));

    KeyInfo objects can also be marshalled to XML by invoking the marshal method.

    Since:
    1.6
    See Also:
    KeyInfoFactory.newKeyInfo(List), KeyInfoFactory.newKeyInfo(List, String)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      List getContent()
      Returns an unmodifiable list containing the key information.
      String getId()
      Return the optional Id attribute of this KeyInfo, which may be useful for referencing this KeyInfo from other XML structures.
      void marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getContent

        List getContent()
        Returns an unmodifiable list containing the key information. Each entry of the list is an XMLStructure.

        If there is a public subclass representing the type of XMLStructure, it is returned as an instance of that class (ex: an X509Data element would be returned as an instance of X509Data).

        Returns:
        an unmodifiable list of one or more XMLStructures in this KeyInfo. Never returns null or an empty list.

      • getId

        String getId()
        Return the optional Id attribute of this KeyInfo, which may be useful for referencing this KeyInfo from other XML structures.
        Returns:
        the Id attribute of this KeyInfo (may be null if not specified)

      • marshal

        void marshal(XMLStructure parent,
             XMLCryptoContext context)
      throws MarshalException
        Marshals the key info to XML.
        Parameters:
        parent - a mechanism-specific structure containing the parent node that the marshalled key info will be appended to
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        Throws:
        ClassCastException - if the type of parent or context is not compatible with this key info
        MarshalException - if the key info cannot be marshalled
        NullPointerException - if parent is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeyInfoFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Class KeyInfoFactory

  • java.lang.Object
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

  • public abstract class KeyInfoFactory
extends Object
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.

    Each instance of KeyInfoFactory supports a specific XML mechanism type. To create a KeyInfoFactory, call one of the static getInstance methods, passing in the XML mechanism type desired, for example:

    KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");

    The objects that this factory produces will be based on DOM and abide by the DOM interoperability requirements as defined in the DOM Mechanism Requirements section of the API overview. See the Service Providers section of the API overview for a list of standard mechanism types.

    KeyInfoFactory implementations are registered and loaded using the Provider mechanism. For example, a service provider that supports the DOM mechanism would be specified in the Provider subclass as:

         put("KeyInfoFactory.DOM", "org.example.DOMKeyInfoFactory");

    Also, the XMLStructures that are created by this factory may contain state specific to the KeyInfo and are not intended to be reusable.

    An implementation MUST minimally support the default mechanism type: DOM.

    Note that a caller must use the same KeyInfoFactory instance to create the XMLStructures of a particular KeyInfo object. The behavior is undefined if XMLStructures from different providers or different mechanism types are used together.

    Concurrent Access

    The static methods of this class are guaranteed to be thread-safe. Multiple threads may concurrently invoke the static methods defined in this class with no ill effects.

    However, this is not true for the non-static methods defined by this class. Unless otherwise documented by a specific provider, threads that need to access a single KeyInfoFactory instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different KeyInfoFactory instance need not synchronize.

    Since:
    1.6

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected KeyInfoFactory()
      Default constructor, for invocation by subclasses.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      static KeyInfoFactory getInstance()
      Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").
      static KeyInfoFactory getInstance(String mechanismType)
      Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static KeyInfoFactory getInstance(String mechanismType, Provider provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static KeyInfoFactory getInstance(String mechanismType, String provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      String getMechanismType()
      Returns the type of the XML processing mechanism and representation supported by this KeyInfoFactory (ex: "DOM")
      Provider getProvider()
      Returns the provider of this KeyInfoFactory.
      abstract URIDereferencer getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.
      abstract boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.
      abstract KeyInfo newKeyInfo(List content)
      Creates a KeyInfo containing the specified list of key information types.
      abstract KeyInfo newKeyInfo(List content, String id)
      Creates a KeyInfo containing the specified list of key information types and optional id.
      abstract KeyName newKeyName(String name)
      Creates a KeyName from the specified name.
      abstract KeyValue newKeyValue(PublicKey key)
      Creates a KeyValue from the specified public key.
      abstract PGPData newPGPData(byte[] keyId)
      Creates a PGPData from the specified PGP public key identifier.
      abstract PGPData newPGPData(byte[] keyId, byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
      abstract PGPData newPGPData(byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP key material packet and optional list of external elements.
      abstract RetrievalMethod newRetrievalMethod(String uri)
      Creates a RetrievalMethod from the specified URI.
      abstract RetrievalMethod newRetrievalMethod(String uri, String type, List transforms)
      Creates a RetrievalMethod from the specified parameters.
      abstract X509Data newX509Data(List content)
      Creates a X509Data containing the specified list of X.509 content.
      abstract X509IssuerSerial newX509IssuerSerial(String issuerName, BigInteger serialNumber)
      Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
      abstract KeyInfo unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • KeyInfoFactory

        protected KeyInfoFactory()
        Default constructor, for invocation by subclasses.

    • Method Detail

      • getInstance

        public static KeyInfoFactory getInstance(String mechanismType)
        Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate a KeyInfoFactory implementation of the desired mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new KeyInfoFactory object from the first Provider that supports the specified mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Parameters:
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        Returns:
        a new KeyInfoFactory
        Throws:
        NullPointerException - if mechanismType is null
        NoSuchMechanismException - if no Provider supports a KeyInfoFactory implementation for the specified mechanism
        See Also:
        Provider

      • getInstance

        public static KeyInfoFactory getInstance(String mechanismType,
                                         Provider provider)
        Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. Note that the specified Provider object does not have to be registered in the provider list.
        Parameters:
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the Provider object
        Returns:
        a new KeyInfoFactory
        Throws:
        NullPointerException - if mechanismType or provider are null
        NoSuchMechanismException - if a KeyInfoFactory implementation for the specified mechanism is not available from the specified Provider object
        See Also:
        Provider

      • getInstance

        public static KeyInfoFactory getInstance(String mechanismType,
                                         String provider)
                                  throws NoSuchProviderException
        Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Parameters:
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the string name of the provider
        Returns:
        a new KeyInfoFactory
        Throws:
        NoSuchProviderException - if the specified provider is not registered in the security provider list
        NullPointerException - if mechanismType or provider are null
        NoSuchMechanismException - if a KeyInfoFactory implementation for the specified mechanism is not available from the specified provider
        See Also:
        Provider

      • getInstance

        public static KeyInfoFactory getInstance()
        Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate a KeyInfoFactory implementation of the default mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new KeyInfoFactory object from the first Provider that supports the DOM mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        Returns:
        a new KeyInfoFactory
        Throws:
        NoSuchMechanismException - if no Provider supports a KeyInfoFactory implementation for the DOM mechanism
        See Also:
        Provider

      • getMechanismType

        public final String getMechanismType()
        Returns the type of the XML processing mechanism and representation supported by this KeyInfoFactory (ex: "DOM")
        Returns:
        the XML processing mechanism type supported by this KeyInfoFactory

      • getProvider

        public final Provider getProvider()
        Returns the provider of this KeyInfoFactory.
        Returns:
        the provider of this KeyInfoFactory

      • newKeyInfo

        public abstract KeyInfo newKeyInfo(List content)
        Creates a KeyInfo containing the specified list of key information types.
        Parameters:
        content - a list of one or more XMLStructures representing key information types. The list is defensively copied to protect against subsequent modification.
        Returns:
        a KeyInfo
        Throws:
        NullPointerException - if content is null
        IllegalArgumentException - if content is empty
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newKeyInfo

        public abstract KeyInfo newKeyInfo(List content,
                                   String id)
        Creates a KeyInfo containing the specified list of key information types and optional id. The id parameter represents the value of an XML ID attribute and is useful for referencing the KeyInfo from other XML structures.
        Parameters:
        content - a list of one or more XMLStructures representing key information types. The list is defensively copied to protect against subsequent modification.
        id - the value of an XML ID (may be null)
        Returns:
        a KeyInfo
        Throws:
        NullPointerException - if content is null
        IllegalArgumentException - if content is empty
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newKeyName

        public abstract KeyName newKeyName(String name)
        Creates a KeyName from the specified name.
        Parameters:
        name - the name that identifies the key
        Returns:
        a KeyName
        Throws:
        NullPointerException - if name is null

      • newKeyValue

        public abstract KeyValue newKeyValue(PublicKey key)
                              throws KeyException
        Creates a KeyValue from the specified public key.
        Parameters:
        key - the public key
        Returns:
        a KeyValue
        Throws:
        KeyException - if the key's algorithm is not recognized or supported by this KeyInfoFactory
        NullPointerException - if key is null

      • newPGPData

        public abstract PGPData newPGPData(byte[] keyId)
        Creates a PGPData from the specified PGP public key identifier.
        Parameters:
        keyId - a PGP public key identifier as defined in RFC 2440, section 11.2. The array is cloned to protect against subsequent modification.
        Returns:
        a PGPData
        Throws:
        NullPointerException - if keyId is null
        IllegalArgumentException - if the key id is not in the correct format

      • newPGPData

        public abstract PGPData newPGPData(byte[] keyId,
                                   byte[] keyPacket,
                                   List other)
        Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
        Parameters:
        keyId - a PGP public key identifier as defined in RFC 2440, section 11.2. The array is cloned to protect against subsequent modification.
        keyPacket - a PGP key material packet as defined in RFC 2440, section 5.5. The array is cloned to protect against subsequent modification. May be null.
        other - a list of XMLStructures representing elements from an external namespace. The list is defensively copied to protect against subsequent modification. May be null or empty.
        Returns:
        a PGPData
        Throws:
        NullPointerException - if keyId is null
        IllegalArgumentException - if the keyId or keyPacket is not in the correct format. For keyPacket, the format of the packet header is checked and the tag is verified that it is of type key material. The contents and format of the packet body are not checked.
        ClassCastException - if other contains any entries that are not of type XMLStructure

      • newPGPData

        public abstract PGPData newPGPData(byte[] keyPacket,
                                   List other)
        Creates a PGPData from the specified PGP key material packet and optional list of external elements.
        Parameters:
        keyPacket - a PGP key material packet as defined in RFC 2440, section 5.5. The array is cloned to protect against subsequent modification.
        other - a list of XMLStructures representing elements from an external namespace. The list is defensively copied to protect against subsequent modification. May be null or empty.
        Returns:
        a PGPData
        Throws:
        NullPointerException - if keyPacket is null
        IllegalArgumentException - if keyPacket is not in the correct format. For keyPacket, the format of the packet header is checked and the tag is verified that it is of type key material. The contents and format of the packet body are not checked.
        ClassCastException - if other contains any entries that are not of type XMLStructure

      • newRetrievalMethod

        public abstract RetrievalMethod newRetrievalMethod(String uri)
        Creates a RetrievalMethod from the specified URI.
        Parameters:
        uri - the URI that identifies the KeyInfo information to be retrieved
        Returns:
        a RetrievalMethod
        Throws:
        NullPointerException - if uri is null
        IllegalArgumentException - if uri is not RFC 2396 compliant

      • newRetrievalMethod

        public abstract RetrievalMethod newRetrievalMethod(String uri,
                                                   String type,
                                                   List transforms)
        Creates a RetrievalMethod from the specified parameters.
        Parameters:
        uri - the URI that identifies the KeyInfo information to be retrieved
        type - a URI that identifies the type of KeyInfo information to be retrieved (may be null)
        transforms - a list of Transforms. The list is defensively copied to protect against subsequent modification. May be null or empty.
        Returns:
        a RetrievalMethod
        Throws:
        NullPointerException - if uri is null
        IllegalArgumentException - if uri is not RFC 2396 compliant
        ClassCastException - if transforms contains any entries that are not of type Transform

      • newX509Data

        public abstract X509Data newX509Data(List content)
        Creates a X509Data containing the specified list of X.509 content.
        Parameters:
        content - a list of one or more X.509 content types. Valid types are String (subject names), byte[] (subject key ids), X509Certificate, X509CRL, or XMLStructure (X509IssuerSerial objects or elements from an external namespace). Subject names are distinguished names in RFC 2253 String format. Implementations MUST support the attribute type keywords defined in RFC 2253 (CN, L, ST, O, OU, C, STREET, DC and UID). Implementations MAY support additional keywords. The list is defensively copied to protect against subsequent modification.
        Returns:
        a X509Data
        Throws:
        NullPointerException - if content is null
        IllegalArgumentException - if content is empty, or if a subject name is not RFC 2253 compliant or one of the attribute type keywords is not recognized.
        ClassCastException - if content contains any entries that are not of one of the valid types mentioned above

      • newX509IssuerSerial

        public abstract X509IssuerSerial newX509IssuerSerial(String issuerName,
                                                     BigInteger serialNumber)
        Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
        Parameters:
        issuerName - the issuer's distinguished name in RFC 2253 String format. Implementations MUST support the attribute type keywords defined in RFC 2253 (CN, L, ST, O, OU, C, STREET, DC and UID). Implementations MAY support additional keywords.
        serialNumber - the serial number
        Returns:
        an X509IssuerSerial
        Throws:
        NullPointerException - if issuerName or serialNumber are null
        IllegalArgumentException - if the issuer name is not RFC 2253 compliant or one of the attribute type keywords is not recognized.

      • isFeatureSupported

        public abstract boolean isFeatureSupported(String feature)
        Indicates whether a specified feature is supported.
        Parameters:
        feature - the feature name (as an absolute URI)
        Returns:
        true if the specified feature is supported, false otherwise
        Throws:
        NullPointerException - if feature is null

      • getURIDereferencer

        public abstract URIDereferencer getURIDereferencer()
        Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.
        Returns:
        a reference to the default URIDereferencer

      • unmarshalKeyInfo

        public abstract KeyInfo unmarshalKeyInfo(XMLStructure xmlStructure)
                                  throws MarshalException
        Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
        Parameters:
        xmlStructure - a mechanism-specific XML structure from which to unmarshal the keyinfo from
        Returns:
        the KeyInfo
        Throws:
        NullPointerException - if xmlStructure is null
        ClassCastException - if the type of xmlStructure is inappropriate for this factory
        MarshalException - if an unrecoverable exception occurs during unmarshalling
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeyName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface KeyName

  • All Superinterfaces:
    XMLStructure

    public interface KeyName
extends XMLStructure
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A KeyName object contains a string value which may be used by the signer to communicate a key identifier to the recipient. The XML Schema Definition is defined as:
     <element name="KeyName" type="string"/>
    A KeyName instance may be created by invoking the newKeyName method of the KeyInfoFactory class, and passing it a String representing the name of the key; for example:
     KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
 KeyName keyName = factory.newKeyName("Alice");
    Since:
    1.6
    See Also:
    KeyInfoFactory.newKeyName(String)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of this KeyName.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getName

        String getName()
        Returns the name of this KeyName.
        Returns:
        the name of this KeyName (never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


KeyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface KeyValue

  • All Superinterfaces:
    XMLStructure

    public interface KeyValue
extends XMLStructure
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A KeyValue object contains a single public key that may be useful in validating the signature. The XML schema definition is defined as:
        <element name="KeyValue" type="ds:KeyValueType"/>
    <complexType name="KeyValueType" mixed="true">
      <choice>
        <element ref="ds:DSAKeyValue"/>
        <element ref="ds:RSAKeyValue"/>
        <any namespace="##other" processContents="lax"/>
      </choice>
    </complexType>

    <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>
    <complexType name="DSAKeyValueType">
      <sequence>
        <sequence minOccurs="0">
          <element name="P" type="ds:CryptoBinary"/>
          <element name="Q" type="ds:CryptoBinary"/>
        </sequence>
        <element name="G" type="ds:CryptoBinary" minOccurs="0"/>
        <element name="Y" type="ds:CryptoBinary"/>
        <element name="J" type="ds:CryptoBinary" minOccurs="0"/>
        <sequence minOccurs="0">
          <element name="Seed" type="ds:CryptoBinary"/>
          <element name="PgenCounter" type="ds:CryptoBinary"/>
        </sequence>
      </sequence>
    </complexType>

    <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>
    <complexType name="RSAKeyValueType">
      <sequence>
        <element name="Modulus" type="ds:CryptoBinary"/>
        <element name="Exponent" type="ds:CryptoBinary"/>
      </sequence>
    </complexType>
    A KeyValue instance may be created by invoking the newKeyValue method of the KeyInfoFactory class, and passing it a PublicKey representing the value of the public key. Here is an example of creating a KeyValue from a DSAPublicKey of a Certificate stored in a KeyStore:
     KeyStore keyStore = KeyStore.getInstance(KeyStore.getDefaultType());
 PublicKey dsaPublicKey = keyStore.getCertificate("myDSASigningCert").getPublicKey();
 KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
 KeyValue keyValue = factory.newKeyValue(dsaPublicKey);
    This class returns the DSAKeyValue and RSAKeyValue elements as objects of type DSAPublicKey and RSAPublicKey, respectively. Note that not all of the fields in the schema are accessible as parameters of these types.
    Since:
    1.6
    See Also:
    KeyInfoFactory.newKeyValue(PublicKey)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DSA_TYPE
      URI identifying the DSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#DSAKeyValue.
      static String RSA_TYPE
      URI identifying the RSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#RSAKeyValue.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      PublicKey getPublicKey()
      Returns the public key of this KeyValue.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • DSA_TYPE

        static final String DSA_TYPE
        URI identifying the DSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#DSAKeyValue. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote DSAKeyValue structure.
        See Also:
        Constant Field Values

      • RSA_TYPE

        static final String RSA_TYPE
        URI identifying the RSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#RSAKeyValue. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote RSAKeyValue structure.
        See Also:
        Constant Field Values

    • Method Detail

      • getPublicKey

        PublicKey getPublicKey()
                throws KeyException
        Returns the public key of this KeyValue.
        Returns:
        the public key of this KeyValue
        Throws:
        KeyException - if this KeyValue cannot be converted to a PublicKey
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig.keyinfo (Java Platform SE 8 )

javax.xml.crypto.dsig.keyinfo

Interfaces

  • KeyInfo
  • KeyName
  • KeyValue
  • PGPData
  • RetrievalMethod
  • X509Data
  • X509IssuerSerial

Classes

  • KeyInfoFactory


javax.xml.crypto.dsig.keyinfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.crypto.dsig.keyinfo

Classes for parsing and processing KeyInfo elements and structures.

See: Description

  • Interface Summary
    Interface Description
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyName
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyValue
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    PGPData
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    RetrievalMethod
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509Data
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509IssuerSerial
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • Class Summary
    Class Description
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.

Package javax.xml.crypto.dsig.keyinfo Description

Classes for parsing and processing KeyInfo elements and structures. KeyInfo is an optional element that enables the recipient(s) to obtain the key needed to validate an XMLSignature. KeyInfo may contain keys, names, certificates and other public key management information, such as in-band key distribution or key agreement data. This package contains classes representing types defined in the W3C specification for XML Signatures, such as KeyName, KeyValue, RetrievalMethod, X509Data, X509IssuerSerial, and PGPData. KeyInfoFactory is an abstract factory that creates KeyInfo objects from scratch.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig.keyinfo Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.crypto.dsig.keyinfo

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Interface Hierarchy

  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.XMLStructure)
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.keyinfo.KeyInfo
    • javax.xml.crypto.dsig.keyinfo.KeyName
    • javax.xml.crypto.dsig.keyinfo.KeyValue
    • javax.xml.crypto.dsig.keyinfo.PGPData
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.keyinfo.X509Data
    • javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.crypto.dsig.keyinfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.crypto.dsig.keyinfo

  • Packages that use javax.xml.crypto.dsig.keyinfo
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.
  • Classes in javax.xml.crypto.dsig.keyinfo used by javax.xml.crypto
    Class and Description
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • Classes in javax.xml.crypto.dsig.keyinfo used by javax.xml.crypto.dsig
    Class and Description
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.
  • Classes in javax.xml.crypto.dsig.keyinfo used by javax.xml.crypto.dsig.keyinfo
    Class and Description
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.
    KeyName
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyValue
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    PGPData
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    RetrievalMethod
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509Data
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509IssuerSerial
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PGPData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface PGPData

  • All Superinterfaces:
    XMLStructure

    public interface PGPData
extends XMLStructure
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A PGPData object is used to convey information related to PGP public key pairs and signatures on such keys. The XML Schema Definition is defined as:
        <element name="PGPData" type="ds:PGPDataType"/>
    <complexType name="PGPDataType">
      <choice>
        <sequence>
          <element name="PGPKeyID" type="base64Binary"/>
          <element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
          <any namespace="##other" processContents="lax" minOccurs="0"
           maxOccurs="unbounded"/>
        </sequence>
        <sequence>
          <element name="PGPKeyPacket" type="base64Binary"/>
          <any namespace="##other" processContents="lax" minOccurs="0"
           maxOccurs="unbounded"/>
        </sequence>
      </choice>
    </complexType>
    A PGPData instance may be created by invoking one of the newPGPData methods of the KeyInfoFactory class, and passing it byte arrays representing the contents of the PGP public key identifier and/or PGP key material packet, and an optional list of elements from an external namespace.
    Since:
    1.6
    See Also:
    KeyInfoFactory.newPGPData(byte[]),
KeyInfoFactory.newPGPData(byte[], byte[], List),
KeyInfoFactory.newPGPData(byte[], List)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String TYPE
      URI identifying the PGPData KeyInfo type: http://www.w3.org/2000/09/xmldsig#PGPData.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      List getExternalElements()
      Returns an unmodifiable list of XMLStructures representing elements from an external namespace.
      byte[] getKeyId()
      Returns the PGP public key identifier of this PGPData as defined in RFC 2440, section 11.2.
      byte[] getKeyPacket()
      Returns the PGP key material packet of this PGPData as defined in RFC 2440, section 5.5.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • TYPE

        static final String TYPE
        URI identifying the PGPData KeyInfo type: http://www.w3.org/2000/09/xmldsig#PGPData. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote PGPData structure.
        See Also:
        Constant Field Values

    • Method Detail

      • getKeyId

        byte[] getKeyId()
        Returns the PGP public key identifier of this PGPData as defined in RFC 2440, section 11.2.
        Returns:
        the PGP public key identifier (may be null if not specified). Each invocation of this method returns a new clone to protect against subsequent modification.

      • getKeyPacket

        byte[] getKeyPacket()
        Returns the PGP key material packet of this PGPData as defined in RFC 2440, section 5.5.
        Returns:
        the PGP key material packet (may be null if not specified). Each invocation of this method returns a new clone to protect against subsequent modification.

      • getExternalElements

        List getExternalElements()
        Returns an unmodifiable list of XMLStructures representing elements from an external namespace.
        Returns:
        an unmodifiable list of XMLStructures (may be empty, but never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RetrievalMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface RetrievalMethod

  • All Superinterfaces:
    URIReference, XMLStructure

    public interface RetrievalMethod
extends URIReference, XMLStructure
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A RetrievalMethod object is used to convey a reference to KeyInfo information that is stored at another location. The XML schema definition is defined as:
       <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>
   <complexType name="RetrievalMethodType">
     <sequence>
       <element name="Transforms" type="ds:TransformsType" minOccurs="0"/>
     </sequence>
     <attribute name="URI" type="anyURI"/>
     <attribute name="Type" type="anyURI" use="optional"/>
   </complexType>
    A RetrievalMethod instance may be created by invoking one of the newRetrievalMethod methods of the KeyInfoFactory class, and passing it the URI identifying the location of the KeyInfo, an optional type URI identifying the type of KeyInfo, and an optional list of Transforms; for example:
       KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
   RetrievalMethod rm = factory.newRetrievalMethod
      ("#KeyValue-1", KeyValue.DSA_TYPE, Collections.singletonList(Transform.BASE64));
    Since:
    1.6
    See Also:
    KeyInfoFactory.newRetrievalMethod(String), KeyInfoFactory.newRetrievalMethod(String, String, List)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Data dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
      List getTransforms()
      Returns an unmodifiable list of Transforms of this RetrievalMethod.
      String getURI()
      Returns the URI of the referenced KeyInfo information.

      • Methods inherited from interface javax.xml.crypto.URIReference

        getType

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getTransforms

        List getTransforms()
        Returns an unmodifiable list of Transforms of this RetrievalMethod.
        Returns:
        an unmodifiable list of Transform objects (may be empty but never null).

      • getURI

        String getURI()
        Returns the URI of the referenced KeyInfo information.
        Specified by:
        getURI in interface URIReference
        Returns:
        the URI of the referenced KeyInfo information in RFC 2396 format (never null)

      • dereference

        Data dereference(XMLCryptoContext context)
          throws URIReferenceException
        Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
        Parameters:
        context - an XMLCryptoContext that may contain additional useful information for dereferencing the URI. The context's baseURI and dereferencer parameters (if specified) are used to resolve and dereference this RetrievalMethod
        Returns:
        a Data object representing the raw contents of the KeyInfo information referenced by this RetrievalMethod. It is the caller's responsibility to convert the returned data to an appropriate KeyInfo object.
        Throws:
        NullPointerException - if context is null
        URIReferenceException - if there is an error while dereferencing
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


X509Data (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface X509Data

  • All Superinterfaces:
    XMLStructure

    public interface X509Data
extends XMLStructure
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. An X509Data object contains one or more identifers of keys or X.509 certificates (or certificates' identifiers or a revocation list). The XML Schema Definition is defined as:
        <element name="X509Data" type="ds:X509DataType"/>
    <complexType name="X509DataType">
        <sequence maxOccurs="unbounded">
          <choice>
            <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
            <element name="X509SKI" type="base64Binary"/>
            <element name="X509SubjectName" type="string"/>
            <element name="X509Certificate" type="base64Binary"/>
            <element name="X509CRL" type="base64Binary"/>
            <any namespace="##other" processContents="lax"/>
          </choice>
        </sequence>
    </complexType>

    <complexType name="X509IssuerSerialType">
      <sequence>
        <element name="X509IssuerName" type="string"/>
        <element name="X509SerialNumber" type="integer"/>
      </sequence>
    </complexType>
    An X509Data instance may be created by invoking the newX509Data methods of the KeyInfoFactory class and passing it a list of one or more XMLStructures representing X.509 content; for example:
       KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
   X509Data x509Data = factory.newX509Data
       (Collections.singletonList("cn=Alice"));
    Since:
    1.6
    See Also:
    KeyInfoFactory.newX509Data(List)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String RAW_X509_CERTIFICATE_TYPE
      URI identifying the binary (ASN.1 DER) X.509 Certificate KeyInfo type: http://www.w3.org/2000/09/xmldsig#rawX509Certificate.
      static String TYPE
      URI identifying the X509Data KeyInfo type: http://www.w3.org/2000/09/xmldsig#X509Data.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      List getContent()
      Returns an unmodifiable list of the content in this X509Data.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Field Detail

      • TYPE

        static final String TYPE
        URI identifying the X509Data KeyInfo type: http://www.w3.org/2000/09/xmldsig#X509Data. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote X509Data structure.
        See Also:
        Constant Field Values

      • RAW_X509_CERTIFICATE_TYPE

        static final String RAW_X509_CERTIFICATE_TYPE
        URI identifying the binary (ASN.1 DER) X.509 Certificate KeyInfo type: http://www.w3.org/2000/09/xmldsig#rawX509Certificate. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote X509 Certificate.
        See Also:
        Constant Field Values

    • Method Detail

      • getContent

        List getContent()
        Returns an unmodifiable list of the content in this X509Data. Valid types are String (subject names), byte[] (subject key ids), X509Certificate, X509CRL, or XMLStructure (X509IssuerSerial objects or elements from an external namespace).
        Returns:
        an unmodifiable list of the content in this X509Data (never null or empty)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


X509IssuerSerial (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.keyinfo

Interface X509IssuerSerial

  • All Superinterfaces:
    XMLStructure

    public interface X509IssuerSerial
extends XMLStructure
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. An X509IssuerSerial object contains an X.509 issuer distinguished name (DN) and serial number pair. The XML schema definition is defined as:
       <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
   <complexType name="X509IssuerSerialType">
     <sequence>
       <element name="X509IssuerName" type="string"/>
       <element name="X509SerialNumber" type="integer"/>
     </sequence>
   </complexType>
    An X509IssuerSerial instance may be created by invoking the newX509IssuerSerial method of the KeyInfoFactory class, and passing it a String and BigInteger representing the X.500 DN and serial number. Here is an example of creating an X509IssuerSerial from the issuer DN and serial number of an existing X509Certificate:
     KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
 X509IssuerSerial issuer = factory.newX509IssuerSerial
     (cert.getIssuerX500Principal().getName(), cert.getSerialNumber());
    Since:
    1.6
    See Also:
    X509Data.getContent(), KeyInfoFactory.newX509IssuerSerial(String, BigInteger)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getIssuerName()
      Returns the X.500 distinguished name of this X509IssuerSerial in RFC 2253 String format.
      BigInteger getSerialNumber()
      Returns the serial number of this X509IssuerSerial.

      • Methods inherited from interface javax.xml.crypto.XMLStructure

        isFeatureSupported

    • Method Detail

      • getIssuerName

        String getIssuerName()
        Returns the X.500 distinguished name of this X509IssuerSerial in RFC 2253 String format.
        Returns:
        the X.500 distinguished name in RFC 2253 String format (never null)

      • getSerialNumber

        BigInteger getSerialNumber()
        Returns the serial number of this X509IssuerSerial.
        Returns:
        the serial number (never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.KeyInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.KeyInfo

  • Packages that use KeyInfo
    Package Description
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyInfo in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type KeyInfo
      Modifier and Type Method and Description
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of KeyInfo in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return KeyInfo
      Modifier and Type Method and Description
      KeyInfo XMLSignature.getKeyInfo()
      Returns the key info of this XMLSignature.
      Methods in javax.xml.crypto.dsig with parameters of type KeyInfo
      Modifier and Type Method and Description
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.

    • Uses of KeyInfo in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyInfo
      Modifier and Type Method and Description
      abstract KeyInfo KeyInfoFactory.newKeyInfo(List content)
      Creates a KeyInfo containing the specified list of key information types.
      abstract KeyInfo KeyInfoFactory.newKeyInfo(List content, String id)
      Creates a KeyInfo containing the specified list of key information types and optional id.
      abstract KeyInfo KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

  • Packages that use KeyInfoFactory
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyInfoFactory in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return KeyInfoFactory
      Modifier and Type Method and Description
      KeyInfoFactory XMLSignatureFactory.getKeyInfoFactory()
      Returns a KeyInfoFactory that creates KeyInfo objects.

    • Uses of KeyInfoFactory in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyInfoFactory
      Modifier and Type Method and Description
      static KeyInfoFactory KeyInfoFactory.getInstance()
      Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").
      static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType)
      Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, Provider provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, String provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.KeyName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.KeyName

  • Packages that use KeyName
    Package Description
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyName in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyName
      Modifier and Type Method and Description
      abstract KeyName KeyInfoFactory.newKeyName(String name)
      Creates a KeyName from the specified name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.KeyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.KeyValue

  • Packages that use KeyValue
    Package Description
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyValue in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyValue
      Modifier and Type Method and Description
      abstract KeyValue KeyInfoFactory.newKeyValue(PublicKey key)
      Creates a KeyValue from the specified public key.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.PGPData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.PGPData

  • Packages that use PGPData
    Package Description
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of PGPData in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return PGPData
      Modifier and Type Method and Description
      abstract PGPData KeyInfoFactory.newPGPData(byte[] keyId)
      Creates a PGPData from the specified PGP public key identifier.
      abstract PGPData KeyInfoFactory.newPGPData(byte[] keyId, byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
      abstract PGPData KeyInfoFactory.newPGPData(byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP key material packet and optional list of external elements.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.RetrievalMethod

  • Packages that use RetrievalMethod
    Package Description
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of RetrievalMethod in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return RetrievalMethod
      Modifier and Type Method and Description
      abstract RetrievalMethod KeyInfoFactory.newRetrievalMethod(String uri)
      Creates a RetrievalMethod from the specified URI.
      abstract RetrievalMethod KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms)
      Creates a RetrievalMethod from the specified parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.X509Data (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.X509Data

  • Packages that use X509Data
    Package Description
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of X509Data in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return X509Data
      Modifier and Type Method and Description
      abstract X509Data KeyInfoFactory.newX509Data(List content)
      Creates a X509Data containing the specified list of X.509 content.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.keyinfo.X509IssuerSerial (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

  • Packages that use X509IssuerSerial
    Package Description
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of X509IssuerSerial in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return X509IssuerSerial
      Modifier and Type Method and Description
      abstract X509IssuerSerial KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
      Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


C14NMethodParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Interface C14NMethodParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec, TransformParameterSpec
    All Known Implementing Classes:
    ExcC14NParameterSpec

    public interface C14NMethodParameterSpec
extends TransformParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm. The purpose of this interface is to group (and provide type safety for) all canonicalization (C14N) parameter specifications. All canonicalization parameter specifications must implement this interface.
    Since:
    1.6
    See Also:
    CanonicalizationMethod
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.crypto.dsig.spec (Java Platform SE 8 )

compact3 - javax.xml.crypto.dsig.spec

Interfaces

  • C14NMethodParameterSpec
  • DigestMethodParameterSpec
  • SignatureMethodParameterSpec
  • TransformParameterSpec

Classes

  • ExcC14NParameterSpec
  • HMACParameterSpec
  • XPathFilter2ParameterSpec
  • XPathFilterParameterSpec
  • XPathType
  • XPathType.Filter
  • XSLTTransformParameterSpec


javax.xml.crypto.dsig.spec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.crypto.dsig.spec

Parameter classes for XML digital signatures.

See: Description

  • Interface Summary
    Interface Description
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    DigestMethodParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
  • Class Summary
    Class Description
    ExcC14NParameterSpec
    Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
    HMACParameterSpec
    Parameters for the XML Signature HMAC Algorithm.
    XPathFilter2ParameterSpec
    Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
    XPathFilterParameterSpec
    Parameters for the XPath Filtering Transform Algorithm.
    XPathType
    The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:
    XPathType.Filter
    Represents the filter set operation.
    XSLTTransformParameterSpec
    Parameters for the XSLT Transform Algorithm.

Package javax.xml.crypto.dsig.spec Description

Parameter classes for XML digital signatures. This package contains interfaces and classes representing input parameters for the digest, signature, transform, or canonicalization algorithms used in the processing of XML signatures.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing
  • Exclusive XML Canonicalization algorithm: W3C Recommendation
  • XPath Filter 2.0 Transform Algorithm: W3C Recommendation

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DigestMethodParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Interface DigestMethodParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec

    public interface DigestMethodParameterSpec
extends AlgorithmParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm. The purpose of this interface is to group (and provide type safety for) all digest method parameter specifications. All digest method parameter specifications must implement this interface.
    Since:
    1.6
    See Also:
    DigestMethod
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ExcC14NParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class ExcC14NParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec, C14NMethodParameterSpec, TransformParameterSpec

    public final class ExcC14NParameterSpec
extends Object
implements C14NMethodParameterSpec
    Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm. The parameters include an optional inclusive namespace prefix list. The XML Schema Definition of the Exclusive XML Canonicalization parameters is defined as:

 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:ec="http://www.w3.org/2001/10/xml-exc-c14n#"
         targetNamespace="http://www.w3.org/2001/10/xml-exc-c14n#"
         version="0.1" elementFormDefault="qualified">

 <element name="InclusiveNamespaces" type="ec:InclusiveNamespaces"/>
 <complexType name="InclusiveNamespaces">
   <attribute name="PrefixList" type="xsd:string"/>
 </complexType>
 </schema>
    Since:
    1.6
    See Also:
    CanonicalizationMethod

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT
      Indicates the default namespace ("#default").

    • Constructor Summary

      Constructors
      Constructor and Description
      ExcC14NParameterSpec()
      Creates a ExcC14NParameterSpec with an empty prefix list.
      ExcC14NParameterSpec(List prefixList)
      Creates a ExcC14NParameterSpec with the specified list of prefixes.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      List getPrefixList()
      Returns the inclusive namespace prefix list.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • DEFAULT

        public static final String DEFAULT
        Indicates the default namespace ("#default").
        See Also:
        Constant Field Values

    • Constructor Detail

      • ExcC14NParameterSpec

        public ExcC14NParameterSpec()
        Creates a ExcC14NParameterSpec with an empty prefix list.

      • ExcC14NParameterSpec

        public ExcC14NParameterSpec(List prefixList)
        Creates a ExcC14NParameterSpec with the specified list of prefixes. The list is copied to protect against subsequent modification.
        Parameters:
        prefixList - the inclusive namespace prefix list. Each entry in the list is a String that represents a namespace prefix.
        Throws:
        NullPointerException - if prefixList is null
        ClassCastException - if any of the entries in the list are not of type String

    • Method Detail

      • getPrefixList

        public List getPrefixList()
        Returns the inclusive namespace prefix list. Each entry in the list is a String that represents a namespace prefix.

        This implementation returns an unmodifiable list.

        Returns:
        the inclusive namespace prefix list (may be empty but never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HMACParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class HMACParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.HMACParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec, SignatureMethodParameterSpec

    public final class HMACParameterSpec
extends Object
implements SignatureMethodParameterSpec
    Parameters for the XML Signature HMAC Algorithm. The parameters include an optional output length which specifies the MAC truncation length in bits. The resulting HMAC will be truncated to the specified number of bits. If the parameter is not specified, then this implies that all the bits of the hash are to be output. The XML Schema Definition of the HMACOutputLength element is defined as:

 <element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
 <simpleType name="HMACOutputLengthType">
   <restriction base="integer"/>
 </simpleType>
    Since:
    1.6
    See Also:
    SignatureMethod, RFC 2104

    • Constructor Summary

      Constructors
      Constructor and Description
      HMACParameterSpec(int outputLength)
      Creates an HMACParameterSpec with the specified truncation length.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getOutputLength()
      Returns the truncation length.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HMACParameterSpec

        public HMACParameterSpec(int outputLength)
        Creates an HMACParameterSpec with the specified truncation length.
        Parameters:
        outputLength - the truncation length in number of bits

    • Method Detail

      • getOutputLength

        public int getOutputLength()
        Returns the truncation length.
        Returns:
        the truncation length in number of bits
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig.spec (Java Platform SE 8 )

javax.xml.crypto.dsig.spec

Interfaces

  • C14NMethodParameterSpec
  • DigestMethodParameterSpec
  • SignatureMethodParameterSpec
  • TransformParameterSpec

Classes

  • ExcC14NParameterSpec
  • HMACParameterSpec
  • XPathFilter2ParameterSpec
  • XPathFilterParameterSpec
  • XPathType
  • XPathType.Filter
  • XSLTTransformParameterSpec


javax.xml.crypto.dsig.spec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.crypto.dsig.spec

Parameter classes for XML digital signatures.

See: Description

  • Interface Summary
    Interface Description
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    DigestMethodParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
  • Class Summary
    Class Description
    ExcC14NParameterSpec
    Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
    HMACParameterSpec
    Parameters for the XML Signature HMAC Algorithm.
    XPathFilter2ParameterSpec
    Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
    XPathFilterParameterSpec
    Parameters for the XPath Filtering Transform Algorithm.
    XPathType
    The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:
    XPathType.Filter
    Represents the filter set operation.
    XSLTTransformParameterSpec
    Parameters for the XSLT Transform Algorithm.

Package javax.xml.crypto.dsig.spec Description

Parameter classes for XML digital signatures. This package contains interfaces and classes representing input parameters for the digest, signature, transform, or canonicalization algorithms used in the processing of XML signatures.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing
  • Exclusive XML Canonicalization algorithm: W3C Recommendation
  • XPath Filter 2.0 Transform Algorithm: W3C Recommendation

Since:
1.6
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.crypto.dsig.spec Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.crypto.dsig.spec

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (implements javax.xml.crypto.dsig.spec.C14NMethodParameterSpec)
    • javax.xml.crypto.dsig.spec.HMACParameterSpec (implements javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathType
    • javax.xml.crypto.dsig.spec.XPathType.Filter
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)

Interface Hierarchy

  • java.security.spec.AlgorithmParameterSpec
    • javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
    • javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
    • javax.xml.crypto.dsig.spec.TransformParameterSpec
      • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.crypto.dsig.spec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.crypto.dsig.spec

  • Packages that use javax.xml.crypto.dsig.spec
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.
  • Classes in javax.xml.crypto.dsig.spec used by javax.xml.crypto.dsig
    Class and Description
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    DigestMethodParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
  • Classes in javax.xml.crypto.dsig.spec used by javax.xml.crypto.dsig.spec
    Class and Description
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
    XPathType.Filter
    Represents the filter set operation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SignatureMethodParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Interface SignatureMethodParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec
    All Known Implementing Classes:
    HMACParameterSpec

    public interface SignatureMethodParameterSpec
extends AlgorithmParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm. The purpose of this interface is to group (and provide type safety for) all signature method parameter specifications. All signature method parameter specifications must implement this interface.
    Since:
    1.6
    See Also:
    SignatureMethod
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Interface TransformParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec
    All Known Subinterfaces:
    C14NMethodParameterSpec
    All Known Implementing Classes:
    ExcC14NParameterSpec, XPathFilter2ParameterSpec, XPathFilterParameterSpec, XSLTTransformParameterSpec

    public interface TransformParameterSpec
extends AlgorithmParameterSpec
    A specification of algorithm parameters for a Transform algorithm. The purpose of this interface is to group (and provide type safety for) all transform parameter specifications. All transform parameter specifications must implement this interface.
    Since:
    1.6
    See Also:
    Transform
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFilter2ParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class XPathFilter2ParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec, TransformParameterSpec

    public final class XPathFilter2ParameterSpec
extends Object
implements TransformParameterSpec
    Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm. The parameters include a list of one or more XPathType objects.
    Since:
    1.6
    See Also:
    Transform, XPathFilterParameterSpec

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathFilter2ParameterSpec(List xPathList)
      Creates an XPathFilter2ParameterSpec.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      List getXPathList()
      Returns a list of one or more XPathType objects.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XPathFilter2ParameterSpec

        public XPathFilter2ParameterSpec(List xPathList)
        Creates an XPathFilter2ParameterSpec.
        Parameters:
        xPathList - a list of one or more XPathType objects. The list is defensively copied to protect against subsequent modification.
        Throws:
        ClassCastException - if xPathList contains any entries that are not of type XPathType
        IllegalArgumentException - if xPathList is empty
        NullPointerException - if xPathList is null

    • Method Detail

      • getXPathList

        public List getXPathList()
        Returns a list of one or more XPathType objects.

        This implementation returns an unmodifiable list.

        Returns:
        a List of XPathType objects (never null or empty)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFilterParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class XPathFilterParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec, TransformParameterSpec

    public final class XPathFilterParameterSpec
extends Object
implements TransformParameterSpec
    Parameters for the XPath Filtering Transform Algorithm. The parameters include the XPath expression and an optional Map of additional namespace prefix mappings. The XML Schema Definition of the XPath Filtering transform parameters is defined as:

 <element name="XPath" type="string"/>
    Since:
    1.6
    See Also:
    Transform

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathFilterParameterSpec(String xPath)
      Creates an XPathFilterParameterSpec with the specified XPath expression.
      XPathFilterParameterSpec(String xPath, Map namespaceMap)
      Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Map getNamespaceMap()
      Returns a map of namespace prefixes.
      String getXPath()
      Returns the XPath expression to be evaluated.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XPathFilterParameterSpec

        public XPathFilterParameterSpec(String xPath)
        Creates an XPathFilterParameterSpec with the specified XPath expression.
        Parameters:
        xPath - the XPath expression to be evaluated
        Throws:
        NullPointerException - if xPath is null

      • XPathFilterParameterSpec

        public XPathFilterParameterSpec(String xPath,
                                Map namespaceMap)
        Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map. The map is copied to protect against subsequent modification.
        Parameters:
        xPath - the XPath expression to be evaluated
        namespaceMap - the map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.
        Throws:
        NullPointerException - if xPath or namespaceMap are null
        ClassCastException - if any of the map's keys or entries are not of type String

    • Method Detail

      • getXPath

        public String getXPath()
        Returns the XPath expression to be evaluated.
        Returns:
        the XPath expression to be evaluated

      • getNamespaceMap

        public Map getNamespaceMap()
        Returns a map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.

        This implementation returns an unmodifiable map.

        Returns:
        a Map of namespace prefixes to namespace URIs (may be empty, but never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathType.Filter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class XPathType.Filter

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathType.Filter
  • Enclosing class:
    XPathType

    public static class XPathType.Filter
extends Object
    Represents the filter set operation.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static XPathType.Filter INTERSECT
      The intersect filter operation.
      static XPathType.Filter SUBTRACT
      The subtract filter operation.
      static XPathType.Filter UNION
      The union filter operation.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String toString()
      Returns the string form of the operation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • INTERSECT

        public static final XPathType.Filter INTERSECT
        The intersect filter operation.

      • SUBTRACT

        public static final XPathType.Filter SUBTRACT
        The subtract filter operation.

      • UNION

        public static final XPathType.Filter UNION
        The union filter operation.

    • Method Detail

      • toString

        public String toString()
        Returns the string form of the operation.
        Overrides:
        toString in class Object
        Returns:
        the string form of the operation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class XPathType

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathType

  • public class XPathType
extends Object
    The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:

 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:xf="http://www.w3.org/2002/06/xmldsig-filter2"
         targetNamespace="http://www.w3.org/2002/06/xmldsig-filter2"
         version="0.1" elementFormDefault="qualified">

 <element name="XPath"
          type="xf:XPathType"/>

 <complexType name="XPathType">
   <simpleContent>
     <extension base="string">
       <attribute name="Filter">
         <simpleType>
           <restriction base="string">
             <enumeration value="intersect"/>
             <enumeration value="subtract"/>
             <enumeration value="union"/>
           </restriction>
         </simpleType>
       </attribute>
     </extension>
   </simpleContent>
 </complexType>
    Since:
    1.6
    See Also:
    XPathFilter2ParameterSpec

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  XPathType.Filter
      Represents the filter set operation.

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathType(String expression, XPathType.Filter filter)
      Creates an XPathType instance with the specified XPath expression and filter.
      XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
      Creates an XPathType instance with the specified XPath expression, filter, and namespace map.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getExpression()
      Returns the XPath expression to be evaluated.
      XPathType.Filter getFilter()
      Returns the filter operation.
      Map getNamespaceMap()
      Returns a map of namespace prefixes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XPathType

        public XPathType(String expression,
                 XPathType.Filter filter)
        Creates an XPathType instance with the specified XPath expression and filter.
        Parameters:
        expression - the XPath expression to be evaluated
        filter - the filter operation (XPathType.Filter.INTERSECT, XPathType.Filter.SUBTRACT, or XPathType.Filter.UNION)
        Throws:
        NullPointerException - if expression or filter is null

      • XPathType

        public XPathType(String expression,
                 XPathType.Filter filter,
                 Map namespaceMap)
        Creates an XPathType instance with the specified XPath expression, filter, and namespace map. The map is copied to protect against subsequent modification.
        Parameters:
        expression - the XPath expression to be evaluated
        filter - the filter operation (XPathType.Filter.INTERSECT, XPathType.Filter.SUBTRACT, or XPathType.Filter.UNION)
        namespaceMap - the map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.
        Throws:
        NullPointerException - if expression, filter or namespaceMap are null
        ClassCastException - if any of the map's keys or entries are not of type String

    • Method Detail

      • getExpression

        public String getExpression()
        Returns the XPath expression to be evaluated.
        Returns:
        the XPath expression to be evaluated

      • getFilter

        public XPathType.Filter getFilter()
        Returns the filter operation.
        Returns:
        the filter operation

      • getNamespaceMap

        public Map getNamespaceMap()
        Returns a map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.

        This implementation returns an unmodifiable map.

        Returns:
        a Map of namespace prefixes to namespace URIs (may be empty, but never null)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XSLTTransformParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
javax.xml.crypto.dsig.spec

Class XSLTTransformParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
  • All Implemented Interfaces:
    AlgorithmParameterSpec, TransformParameterSpec

    public final class XSLTTransformParameterSpec
extends Object
implements TransformParameterSpec
    Parameters for the XSLT Transform Algorithm. The parameters include a namespace-qualified stylesheet element.

    An XSLTTransformParameterSpec is instantiated with a mechanism-dependent (ex: DOM) stylesheet element. For example:

       DOMStructure stylesheet = new DOMStructure(element)
   XSLTTransformParameterSpec spec = new XSLTransformParameterSpec(stylesheet);
    where element is an Element containing the namespace-qualified stylesheet element.
    Since:
    1.6
    See Also:
    Transform

    • Constructor Summary

      Constructors
      Constructor and Description
      XSLTTransformParameterSpec(XMLStructure stylesheet)
      Creates an XSLTTransformParameterSpec with the specified stylesheet.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      XMLStructure getStylesheet()
      Returns the stylesheet.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XSLTTransformParameterSpec

        public XSLTTransformParameterSpec(XMLStructure stylesheet)
        Creates an XSLTTransformParameterSpec with the specified stylesheet.
        Parameters:
        stylesheet - the XSLT stylesheet to be used
        Throws:
        NullPointerException - if stylesheet is null

    • Method Detail

      • getStylesheet

        public XMLStructure getStylesheet()
        Returns the stylesheet.
        Returns:
        the stylesheet
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.spec.C14NMethodParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.spec.C14NMethodParameterSpec

  • Packages that use C14NMethodParameterSpec
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of C14NMethodParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type C14NMethodParameterSpec
      Modifier and Type Method and Description
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.

    • Uses of C14NMethodParameterSpec in javax.xml.crypto.dsig.spec

      Classes in javax.xml.crypto.dsig.spec that implement C14NMethodParameterSpec
      Modifier and Type Class and Description
      class  ExcC14NParameterSpec
      Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.spec.DigestMethodParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.spec.DigestMethodParameterSpec

  • Packages that use DigestMethodParameterSpec
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of DigestMethodParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type DigestMethodParameterSpec
      Modifier and Type Method and Description
      abstract DigestMethod XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
      Creates a DigestMethod for the specified algorithm URI and parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.ExcC14NParameterSpec

No usage of javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.HMACParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.HMACParameterSpec

No usage of javax.xml.crypto.dsig.spec.HMACParameterSpec
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec

  • Packages that use SignatureMethodParameterSpec
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of SignatureMethodParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type SignatureMethodParameterSpec
      Modifier and Type Method and Description
      abstract SignatureMethod XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
      Creates a SignatureMethod for the specified algorithm URI and parameters.

    • Uses of SignatureMethodParameterSpec in javax.xml.crypto.dsig.spec

      Classes in javax.xml.crypto.dsig.spec that implement SignatureMethodParameterSpec
      Modifier and Type Class and Description
      class  HMACParameterSpec
      Parameters for the XML Signature HMAC Algorithm.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.crypto.dsig.spec.TransformParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.crypto.dsig.spec.TransformParameterSpec

  • Packages that use TransformParameterSpec
    Package Description
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of TransformParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type TransformParameterSpec
      Modifier and Type Method and Description
      abstract void TransformService.init(TransformParameterSpec params)
      Initializes this TransformService with the specified parameters.
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params)
      Creates a Transform for the specified algorithm URI and parameters.

    • Uses of TransformParameterSpec in javax.xml.crypto.dsig.spec

      Subinterfaces of TransformParameterSpec in javax.xml.crypto.dsig.spec
      Modifier and Type Interface and Description
      interface  C14NMethodParameterSpec
      A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
      Classes in javax.xml.crypto.dsig.spec that implement TransformParameterSpec
      Modifier and Type Class and Description
      class  ExcC14NParameterSpec
      Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
      class  XPathFilter2ParameterSpec
      Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
      class  XPathFilterParameterSpec
      Parameters for the XPath Filtering Transform Algorithm.
      class  XSLTTransformParameterSpec
      Parameters for the XSLT Transform Algorithm.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec

No usage of javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

No usage of javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.XPathType.Filter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.XPathType.Filter

  • Packages that use XPathType.Filter
    Package Description
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of XPathType.Filter in javax.xml.crypto.dsig.spec

      Fields in javax.xml.crypto.dsig.spec declared as XPathType.Filter
      Modifier and Type Field and Description
      static XPathType.Filter XPathType.Filter.INTERSECT
      The intersect filter operation.
      static XPathType.Filter XPathType.Filter.SUBTRACT
      The subtract filter operation.
      static XPathType.Filter XPathType.Filter.UNION
      The union filter operation.
      Methods in javax.xml.crypto.dsig.spec that return XPathType.Filter
      Modifier and Type Method and Description
      XPathType.Filter XPathType.getFilter()
      Returns the filter operation.
      Constructors in javax.xml.crypto.dsig.spec with parameters of type XPathType.Filter
      Constructor and Description
      XPathType(String expression, XPathType.Filter filter)
      Creates an XPathType instance with the specified XPath expression and filter.
      XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
      Creates an XPathType instance with the specified XPath expression, filter, and namespace map.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.XPathType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.XPathType

No usage of javax.xml.crypto.dsig.spec.XPathType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec

No usage of javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.datatype (Java Platform SE 8 )

compact2 - javax.xml.datatype

Classes

  • DatatypeConstants
  • DatatypeConstants.Field
  • DatatypeFactory
  • Duration
  • XMLGregorianCalendar

Exceptions

  • DatatypeConfigurationException


javax.xml.datatype (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.datatype

XML/Java Type Mappings.

See: Description

  • Class Summary
    Class Description
    DatatypeConstants
    Utility class to contain basic Datatype values as constants.
    DatatypeConstants.Field
    Type-safe enum class that represents six fields of the Duration class.
    DatatypeFactory
    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
    Duration
    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
    XMLGregorianCalendar
    Representation for W3C XML Schema 1.0 date/time datatypes.
  • Exception Summary
    Exception Description
    DatatypeConfigurationException
    Indicates a serious configuration error.

Package javax.xml.datatype Description

XML/Java Type Mappings.

javax.xml.datatypeAPI provides XML/Java type mappings.

The following XML standards apply:

  • W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
W3C XML Schema Data Type | Java Data Type
xs:date | XMLGregorianCalendar
xs:dateTime | XMLGregorianCalendar
xs:duration | Duration
xs:gDay | XMLGregorianCalendar
xs:gMonth | XMLGregorianCalendar
xs:gMonthDay | XMLGregorianCalendar
xs:gYear | XMLGregorianCalendar
xs:gYearMonth | XMLGregorianCalendar
xs:time | XMLGregorianCalendar
XQuery 1.0 and XPath 2.0 Data Model | Java Data Type
xdt:dayTimeDuration | Duration
xdt:yearMonthDuration | Duration

W3C XML Schema data types that have a "natural" mapping to Java types are defined by JSR 31: Java™ Architecture for XML Binding (JAXB) Specification, Binding XML Schema to Java Representations. JAXB defined mappings for XML Schema built-in data types include:

  • xs:anySimpleType
  • xs:base64Binary
  • xs:boolean
  • xs:byte
  • xs:decimal
  • xs:double
  • xs:float
  • xs:hexBinary
  • xs:int
  • xs:integer
  • xs:long
  • xs:QName
  • xs:short
  • xs:string
  • xs:unsignedByte
  • xs:unsignedInt
  • xs:unsignedShort
  • Author Jeff Suttor
  • See W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
  • Since 1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.datatype (Java Platform SE 8 )

compact3 - javax.xml.datatype

Classes

  • DatatypeConstants
  • DatatypeConstants.Field
  • DatatypeFactory
  • Duration
  • XMLGregorianCalendar

Exceptions

  • DatatypeConfigurationException


javax.xml.datatype (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.datatype

XML/Java Type Mappings.

See: Description

  • Class Summary
    Class Description
    DatatypeConstants
    Utility class to contain basic Datatype values as constants.
    DatatypeConstants.Field
    Type-safe enum class that represents six fields of the Duration class.
    DatatypeFactory
    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
    Duration
    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
    XMLGregorianCalendar
    Representation for W3C XML Schema 1.0 date/time datatypes.
  • Exception Summary
    Exception Description
    DatatypeConfigurationException
    Indicates a serious configuration error.

Package javax.xml.datatype Description

XML/Java Type Mappings.

javax.xml.datatypeAPI provides XML/Java type mappings.

The following XML standards apply:

  • W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
W3C XML Schema Data Type | Java Data Type
xs:date | XMLGregorianCalendar
xs:dateTime | XMLGregorianCalendar
xs:duration | Duration
xs:gDay | XMLGregorianCalendar
xs:gMonth | XMLGregorianCalendar
xs:gMonthDay | XMLGregorianCalendar
xs:gYear | XMLGregorianCalendar
xs:gYearMonth | XMLGregorianCalendar
xs:time | XMLGregorianCalendar
XQuery 1.0 and XPath 2.0 Data Model | Java Data Type
xdt:dayTimeDuration | Duration
xdt:yearMonthDuration | Duration

W3C XML Schema data types that have a "natural" mapping to Java types are defined by JSR 31: Java™ Architecture for XML Binding (JAXB) Specification, Binding XML Schema to Java Representations. JAXB defined mappings for XML Schema built-in data types include:

  • xs:anySimpleType
  • xs:base64Binary
  • xs:boolean
  • xs:byte
  • xs:decimal
  • xs:double
  • xs:float
  • xs:hexBinary
  • xs:int
  • xs:integer
  • xs:long
  • xs:QName
  • xs:short
  • xs:string
  • xs:unsignedByte
  • xs:unsignedInt
  • xs:unsignedShort
  • Author Jeff Suttor
  • See W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
  • Since 1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DatatypeConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.datatype

Class DatatypeConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.datatype.DatatypeConfigurationException
  • All Implemented Interfaces:
    Serializable

    public class DatatypeConfigurationException
extends Exception

    Indicates a serious configuration error.

    Since:
    1.5
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      DatatypeConfigurationException()
      Create a new DatatypeConfigurationException with no specified detail mesage and cause.
      DatatypeConfigurationException(String message)
      Create a new DatatypeConfigurationException with the specified detail message.
      DatatypeConfigurationException(String message, Throwable cause)
      Create a new DatatypeConfigurationException with the specified detail message and cause.
      DatatypeConfigurationException(Throwable cause)
      Create a new DatatypeConfigurationException with the specified cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DatatypeConfigurationException

        public DatatypeConfigurationException()

        Create a new DatatypeConfigurationException with no specified detail mesage and cause.

      • DatatypeConfigurationException

        public DatatypeConfigurationException(String message)

        Create a new DatatypeConfigurationException with the specified detail message.

        Parameters:
        message - The detail message.

      • DatatypeConfigurationException

        public DatatypeConfigurationException(String message,
                                      Throwable cause)

        Create a new DatatypeConfigurationException with the specified detail message and cause.

        Parameters:
        message - The detail message.
        cause - The cause. A null value is permitted, and indicates that the cause is nonexistent or unknown.

      • DatatypeConfigurationException

        public DatatypeConfigurationException(Throwable cause)

        Create a new DatatypeConfigurationException with the specified cause.

        Parameters:
        cause - The cause. A null value is permitted, and indicates that the cause is nonexistent or unknown.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DatatypeConstants.Field (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.datatype

Class DatatypeConstants.Field

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants.Field
  • Enclosing class:
    DatatypeConstants

    public static final class DatatypeConstants.Field
extends Object
    Type-safe enum class that represents six fields of the Duration class.
    Since:
    1.5

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getId()
      Get id of this Field.
      String toString()
      Returns a field name in English.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Method Detail

      • toString

        public String toString()
        Returns a field name in English. This method is intended to be used for debugging/diagnosis and not for display to end-users.
        Overrides:
        toString in class Object
        Returns:
        a non-null valid String constant.

      • getId

        public int getId()

        Get id of this Field.

        Returns:
        Id of field.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DatatypeConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.datatype

Class DatatypeConstants

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants

  • public final class DatatypeConstants
extends Object

    Utility class to contain basic Datatype values as constants.

    Since:
    1.5

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  DatatypeConstants.Field
      Type-safe enum class that represents six fields of the Duration class.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int APRIL
      Value for fourth month of year.
      static int AUGUST
      Value for eighth month of year.
      static QName DATE
      Fully qualified name for W3C XML Schema 1.0 datatype date.
      static QName DATETIME
      Fully qualified name for W3C XML Schema 1.0 datatype dateTime.
      static DatatypeConstants.Field DAYS
      A constant that represents the days field.
      static int DECEMBER
      Value for twelve month of year.
      static QName DURATION
      Fully qualified name for W3C XML Schema datatype duration.
      static QName DURATION_DAYTIME
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.
      static QName DURATION_YEARMONTH
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.
      static int EQUAL
      Comparison result.
      static int FEBRUARY
      Value for second month of year.
      static int FIELD_UNDEFINED
      Designation that an "int" field is not set.
      static QName GDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gDay.
      static QName GMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gMonth.
      static QName GMONTHDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.
      static int GREATER
      Comparison result.
      static QName GYEAR
      Fully qualified name for W3C XML Schema 1.0 datatype gYear.
      static QName GYEARMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.
      static DatatypeConstants.Field HOURS
      A constant that represents the hours field.
      static int INDETERMINATE
      Comparison result.
      static int JANUARY
      Value for first month of year.
      static int JULY
      Value for seventh month of year.
      static int JUNE
      Value for sixth month of year.
      static int LESSER
      Comparison result.
      static int MARCH
      Value for third month of year.
      static int MAX_TIMEZONE_OFFSET
      W3C XML Schema max timezone offset is -14:00.
      static int MAY
      Value for fifth month of year.
      static int MIN_TIMEZONE_OFFSET
      W3C XML Schema min timezone offset is +14:00.
      static DatatypeConstants.Field MINUTES
      A constant that represents the minutes field.
      static DatatypeConstants.Field MONTHS
      A constant that represents the months field.
      static int NOVEMBER
      Value for eleven month of year.
      static int OCTOBER
      Value for tenth month of year.
      static DatatypeConstants.Field SECONDS
      A constant that represents the seconds field.
      static int SEPTEMBER
      Value for ninth month of year.
      static QName TIME
      Fully qualified name for W3C XML Schema 1.0 datatype time.
      static DatatypeConstants.Field YEARS
      A constant that represents the years field.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JANUARY

        public static final int JANUARY
        Value for first month of year.
        See Also:
        Constant Field Values

      • FEBRUARY

        public static final int FEBRUARY
        Value for second month of year.
        See Also:
        Constant Field Values

      • MARCH

        public static final int MARCH
        Value for third month of year.
        See Also:
        Constant Field Values

      • APRIL

        public static final int APRIL
        Value for fourth month of year.
        See Also:
        Constant Field Values

      • MAY

        public static final int MAY
        Value for fifth month of year.
        See Also:
        Constant Field Values

      • JUNE

        public static final int JUNE
        Value for sixth month of year.
        See Also:
        Constant Field Values

      • JULY

        public static final int JULY
        Value for seventh month of year.
        See Also:
        Constant Field Values

      • AUGUST

        public static final int AUGUST
        Value for eighth month of year.
        See Also:
        Constant Field Values

      • SEPTEMBER

        public static final int SEPTEMBER
        Value for ninth month of year.
        See Also:
        Constant Field Values

      • OCTOBER

        public static final int OCTOBER
        Value for tenth month of year.
        See Also:
        Constant Field Values

      • NOVEMBER

        public static final int NOVEMBER
        Value for eleven month of year.
        See Also:
        Constant Field Values

      • DECEMBER

        public static final int DECEMBER
        Value for twelve month of year.
        See Also:
        Constant Field Values

      • LESSER

        public static final int LESSER

        Comparison result.

        See Also:
        Constant Field Values

      • EQUAL

        public static final int EQUAL

        Comparison result.

        See Also:
        Constant Field Values

      • GREATER

        public static final int GREATER

        Comparison result.

        See Also:
        Constant Field Values

      • INDETERMINATE

        public static final int INDETERMINATE

        Comparison result.

        See Also:
        Constant Field Values

      • FIELD_UNDEFINED

        public static final int FIELD_UNDEFINED
        Designation that an "int" field is not set.
        See Also:
        Constant Field Values

      • YEARS

        public static final DatatypeConstants.Field YEARS

        A constant that represents the years field.

      • MONTHS

        public static final DatatypeConstants.Field MONTHS

        A constant that represents the months field.

      • DAYS

        public static final DatatypeConstants.Field DAYS

        A constant that represents the days field.

      • HOURS

        public static final DatatypeConstants.Field HOURS

        A constant that represents the hours field.

      • MINUTES

        public static final DatatypeConstants.Field MINUTES

        A constant that represents the minutes field.

      • SECONDS

        public static final DatatypeConstants.Field SECONDS

        A constant that represents the seconds field.

      • DATETIME

        public static final QName DATETIME

        Fully qualified name for W3C XML Schema 1.0 datatype dateTime.

      • TIME

        public static final QName TIME

        Fully qualified name for W3C XML Schema 1.0 datatype time.

      • DATE

        public static final QName DATE

        Fully qualified name for W3C XML Schema 1.0 datatype date.

      • GYEARMONTH

        public static final QName GYEARMONTH

        Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.

      • GMONTHDAY

        public static final QName GMONTHDAY

        Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.

      • GYEAR

        public static final QName GYEAR

        Fully qualified name for W3C XML Schema 1.0 datatype gYear.

      • GMONTH

        public static final QName GMONTH

        Fully qualified name for W3C XML Schema 1.0 datatype gMonth.

      • GDAY

        public static final QName GDAY

        Fully qualified name for W3C XML Schema 1.0 datatype gDay.

      • DURATION

        public static final QName DURATION

        Fully qualified name for W3C XML Schema datatype duration.

      • DURATION_DAYTIME

        public static final QName DURATION_DAYTIME

        Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.

      • DURATION_YEARMONTH

        public static final QName DURATION_YEARMONTH

        Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.

      • MAX_TIMEZONE_OFFSET

        public static final int MAX_TIMEZONE_OFFSET
        W3C XML Schema max timezone offset is -14:00. Zone offset is in minutes.
        See Also:
        Constant Field Values

      • MIN_TIMEZONE_OFFSET

        public static final int MIN_TIMEZONE_OFFSET
        W3C XML Schema min timezone offset is +14:00. Zone offset is in minutes.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DatatypeFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.datatype

Class DatatypeFactory

  • java.lang.Object
    • javax.xml.datatype.DatatypeFactory

  • public abstract class DatatypeFactory
extends Object

    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.

    A new instance of the DatatypeFactory is created through the newInstance() method that uses the following implementation resolution mechanisms to determine an implementation:

    1. If the system property specified by DATATYPEFACTORY_PROPERTY, "javax.xml.datatype.DatatypeFactory", exists, a class with the name of the property value is instantiated. Any Exception thrown during the instantiation process is wrapped as a DatatypeConfigurationException.
    2. If the file ${JAVA_HOME}/lib/jaxp.properties exists, it is loaded in a Properties Object. The Properties Object is then queried for the property as documented in the prior step and processed as documented in the prior step.
    3. Uses the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
      In case of service configuration error a DatatypeConfigurationException will be thrown.
    4. The final mechanism is to attempt to instantiate the Class specified by DATATYPEFACTORY_IMPLEMENTATION_CLASS. Any Exception thrown during the instantiation process is wrapped as a DatatypeConfigurationException.
    Since:
    1.5
    Version:
    $Revision: 1.13 $, $Date: 2010/03/11 23:10:53 $

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DATATYPEFACTORY_IMPLEMENTATION_CLASS
      Default implementation class name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.
      static String DATATYPEFACTORY_PROPERTY
      Default property name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DatatypeFactory()
      Protected constructor to prevent instaniation outside of package.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Duration newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      Duration newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      abstract Duration newDuration(long durationInMilliSeconds)
      Obtain a new instance of a Duration specifying the Duration as milliseconds.
      abstract Duration newDuration(String lexicalRepresentation)
      Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.
      Duration newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationDayTime(long durationInMilliseconds)
      Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationDayTime(String lexicalRepresentation)
      Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration newDurationYearMonth(boolean isPositive, int year, int month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration newDurationYearMonth(long durationInMilliseconds)
      Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration newDurationYearMonth(String lexicalRepresentation)
      Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      static DatatypeFactory newInstance()
      Obtain a new instance of a DatatypeFactory.
      static DatatypeFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DatatypeFactory from class name.
      abstract XMLGregorianCalendar newXMLGregorianCalendar()
      Create a new instance of an XMLGregorianCalendar.
      abstract XMLGregorianCalendar newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)
      Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes.
      abstract XMLGregorianCalendar newXMLGregorianCalendar(GregorianCalendar cal)
      Create an XMLGregorianCalendar from a GregorianCalendar.
      XMLGregorianCalendar newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone)
      Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.
      abstract XMLGregorianCalendar newXMLGregorianCalendar(String lexicalRepresentation)
      Create a new XMLGregorianCalendar by parsing the String as a lexical representation.
      XMLGregorianCalendar newXMLGregorianCalendarDate(int year, int month, int day, int timezone)
      Create a Java representation of XML Schema builtin datatype date or g*.
      XMLGregorianCalendar newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • DATATYPEFACTORY_PROPERTY

        public static final String DATATYPEFACTORY_PROPERTY

        Default property name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.

        Default value is javax.xml.datatype.DatatypeFactory.

        See Also:
        Constant Field Values

      • DATATYPEFACTORY_IMPLEMENTATION_CLASS

        public static final String DATATYPEFACTORY_IMPLEMENTATION_CLASS

        Default implementation class name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.

        Implementers should specify the name of an appropriate class to be instantiated if no other implementation resolution mechanism succeeds.

        Users should not refer to this field; it is intended only to document a factory implementation detail.

    • Constructor Detail

      • DatatypeFactory

        protected DatatypeFactory()

        Protected constructor to prevent instaniation outside of package.

        Use newInstance() to create a DatatypeFactory.

    • Method Detail

      • newInstance

        public static DatatypeFactory newInstance()
                                   throws DatatypeConfigurationException

        Obtain a new instance of a DatatypeFactory.

        The implementation resolution mechanisms are defined in this Class's documentation.

        Returns:
        New instance of a DatatypeFactory
        Throws:
        DatatypeConfigurationException - If the implementation is not available or cannot be instantiated.
        See Also:
        newInstance(String factoryClassName, ClassLoader classLoader)

      • newInstance

        public static DatatypeFactory newInstance(String factoryClassName,
                                          ClassLoader classLoader)
                                   throws DatatypeConfigurationException

        Obtain a new instance of a DatatypeFactory from class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a DatatypeFactory it can use the factory to configure and obtain datatype instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        Parameters:
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.datatype.DatatypeFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        Returns:
        New instance of a DatatypeFactory
        Throws:
        DatatypeConfigurationException - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        Since:
        1.6
        See Also:
        newInstance()

      • newDuration

        public abstract Duration newDuration(String lexicalRepresentation)

        Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.

        XML Schema Part 2: Datatypes, 3.2.6 duration, defines duration as:

        duration represents a duration of time. The value space of duration is a six-dimensional space where the coordinates designate the Gregorian year, month, day, hour, minute, and second components defined in Section 5.5.3.2 of [ISO 8601], respectively. These components are ordered in their significance by their order of appearance i.e. as year, month, day, hour, minute, and second.

        All six values are set and available from the created Duration

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        Parameters:
        lexicalRepresentation - String representation of a Duration.
        Returns:
        New Duration created from parsing the lexicalRepresentation.
        Throws:
        IllegalArgumentException - If lexicalRepresentation is not a valid representation of a Duration.
        UnsupportedOperationException - If implementation cannot support requested values.
        NullPointerException - if lexicalRepresentation is null.

      • newDuration

        public abstract Duration newDuration(long durationInMilliSeconds)

        Obtain a new instance of a Duration specifying the Duration as milliseconds.

        XML Schema Part 2: Datatypes, 3.2.6 duration, defines duration as:

        duration represents a duration of time. The value space of duration is a six-dimensional space where the coordinates designate the Gregorian year, month, day, hour, minute, and second components defined in Section 5.5.3.2 of [ISO 8601], respectively. These components are ordered in their significance by their order of appearance i.e. as year, month, day, hour, minute, and second.

        All six values are set by computing their values from the specified milliseconds and are available using the get methods of the created Duration. The values conform to and are defined by:

        • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
        • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
        • XMLGregorianCalendar Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation

        The default start instance is defined by GregorianCalendar's use of the start of the epoch: i.e., Calendar.YEAR = 1970, Calendar.MONTH = Calendar.JANUARY, Calendar.DATE = 1, etc. This is important as there are variations in the Gregorian Calendar, e.g. leap years have different days in the month = Calendar.FEBRUARY so the result of Duration.getMonths() and Duration.getDays() can be influenced.

        Parameters:
        durationInMilliSeconds - Duration in milliseconds to create.
        Returns:
        New Duration representing durationInMilliSeconds.

      • newDuration

        public abstract Duration newDuration(boolean isPositive,
                                     BigInteger years,
                                     BigInteger months,
                                     BigInteger days,
                                     BigInteger hours,
                                     BigInteger minutes,
                                     BigDecimal seconds)

        Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        A null value indicates that field is not set.

        Parameters:
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        years - of this Duration
        months - of this Duration
        days - of this Duration
        hours - of this Duration
        minutes - of this Duration
        seconds - of this Duration
        Returns:
        New Duration created from the specified values.
        Throws:
        IllegalArgumentException - If the values are not a valid representation of a Duration: if all the fields (years, months, ...) are null or if any of the fields is negative.
        UnsupportedOperationException - If implementation cannot support requested values.

      • newDuration

        public Duration newDuration(boolean isPositive,
                            int years,
                            int months,
                            int days,
                            int hours,
                            int minutes,
                            int seconds)

        Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        years - of this Duration
        months - of this Duration
        days - of this Duration
        hours - of this Duration
        minutes - of this Duration
        seconds - of this Duration
        Returns:
        New Duration created from the specified values.
        Throws:
        IllegalArgumentException - If the values are not a valid representation of a Duration: if any of the fields is negative.
        See Also:
        newDuration( boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)

      • newDurationDayTime

        public Duration newDurationDayTime(String lexicalRepresentation)

        Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        All four values are set and available from the created Duration

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        Parameters:
        lexicalRepresentation - Lexical representation of a duration.
        Returns:
        New Duration created using the specified lexicalRepresentation.
        Throws:
        IllegalArgumentException - If lexicalRepresentation is not a valid representation of a Duration expressed only in terms of days and time.
        UnsupportedOperationException - If implementation cannot support requested values.
        NullPointerException - If lexicalRepresentation is null.

      • newDurationDayTime

        public Duration newDurationDayTime(long durationInMilliseconds)

        Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        All four values are set by computing their values from the specified milliseconds and are available using the get methods of the created Duration. The values conform to and are defined by:

        • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
        • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
        • XMLGregorianCalendar Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation

        The default start instance is defined by GregorianCalendar's use of the start of the epoch: i.e., Calendar.YEAR = 1970, Calendar.MONTH = Calendar.JANUARY, Calendar.DATE = 1, etc. This is important as there are variations in the Gregorian Calendar, e.g. leap years have different days in the month = Calendar.FEBRUARY so the result of Duration.getDays() can be influenced.

        Any remaining milliseconds after determining the day, hour, minute and second are discarded.

        Parameters:
        durationInMilliseconds - Milliseconds of Duration to create.
        Returns:
        New Duration created with the specified durationInMilliseconds.
        See Also:
        XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration

      • newDurationDayTime

        public Duration newDurationDayTime(boolean isPositive,
                                   BigInteger day,
                                   BigInteger hour,
                                   BigInteger minute,
                                   BigInteger second)

        Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        A null value indicates that field is not set.

        Parameters:
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        day - Day of Duration.
        hour - Hour of Duration.
        minute - Minute of Duration.
        second - Second of Duration.
        Returns:
        New Duration created with the specified day, hour, minute and second.
        Throws:
        IllegalArgumentException - If the values are not a valid representation of a Duration: if all the fields (day, hour, ...) are null or if any of the fields is negative.
        UnsupportedOperationException - If implementation cannot support requested values.

      • newDurationDayTime

        public Duration newDurationDayTime(boolean isPositive,
                                   int day,
                                   int hour,
                                   int minute,
                                   int second)

        Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        day - Day of Duration.
        hour - Hour of Duration.
        minute - Minute of Duration.
        second - Second of Duration.
        Returns:
        New Duration created with the specified day, hour, minute and second.
        Throws:
        IllegalArgumentException - If the values are not a valid representation of a Duration: if any of the fields (day, hour, ...) is negative.

      • newDurationYearMonth

        public Duration newDurationYearMonth(String lexicalRepresentation)

        Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        The datatype xdt:yearMonthDuration is a subtype of xs:duration whose lexical representation contains only year and month components. This datatype resides in the namespace XMLConstants.W3C_XPATH_DATATYPE_NS_URI.

        Both values are set and available from the created Duration

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        Parameters:
        lexicalRepresentation - Lexical representation of a duration.
        Returns:
        New Duration created using the specified lexicalRepresentation.
        Throws:
        IllegalArgumentException - If lexicalRepresentation is not a valid representation of a Duration expressed only in terms of years and months.
        UnsupportedOperationException - If implementation cannot support requested values.
        NullPointerException - If lexicalRepresentation is null.

      • newDurationYearMonth

        public Duration newDurationYearMonth(long durationInMilliseconds)

        Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        The datatype xdt:yearMonthDuration is a subtype of xs:duration whose lexical representation contains only year and month components. This datatype resides in the namespace XMLConstants.W3C_XPATH_DATATYPE_NS_URI.

        Both values are set by computing their values from the specified milliseconds and are available using the get methods of the created Duration. The values conform to and are defined by:

        • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
        • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
        • XMLGregorianCalendar Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation

        The default start instance is defined by GregorianCalendar's use of the start of the epoch: i.e., Calendar.YEAR = 1970, Calendar.MONTH = Calendar.JANUARY, Calendar.DATE = 1, etc. This is important as there are variations in the Gregorian Calendar, e.g. leap years have different days in the month = Calendar.FEBRUARY so the result of Duration.getMonths() can be influenced.

        Any remaining milliseconds after determining the year and month are discarded.

        Parameters:
        durationInMilliseconds - Milliseconds of Duration to create.
        Returns:
        New Duration created using the specified durationInMilliseconds.

      • newDurationYearMonth

        public Duration newDurationYearMonth(boolean isPositive,
                                     BigInteger year,
                                     BigInteger month)

        Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        A null value indicates that field is not set.

        Parameters:
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        year - Year of Duration.
        month - Month of Duration.
        Returns:
        New Duration created using the specified year and month.
        Throws:
        IllegalArgumentException - If the values are not a valid representation of a Duration: if all of the fields (year, month) are null or if any of the fields is negative.
        UnsupportedOperationException - If implementation cannot support requested values.

      • newDurationYearMonth

        public Duration newDurationYearMonth(boolean isPositive,
                                     int year,
                                     int month)

        Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        year - Year of Duration.
        month - Month of Duration.
        Returns:
        New Duration created using the specified year and month.
        Throws:
        IllegalArgumentException - If the values are not a valid representation of a Duration: if any of the fields (year, month) is negative.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar()

        Create a new instance of an XMLGregorianCalendar.

        All date/time datatype fields set to DatatypeConstants.FIELD_UNDEFINED or null.

        Returns:
        New XMLGregorianCalendar with all date/time datatype fields set to DatatypeConstants.FIELD_UNDEFINED or null.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar(String lexicalRepresentation)

        Create a new XMLGregorianCalendar by parsing the String as a lexical representation.

        Parsing the lexical string representation is defined in XML Schema 1.0 Part 2, Section 3.2.[7-14].1, Lexical Representation.

        The string representation may not have any leading and trailing whitespaces.

        The parsing is done field by field so that the following holds for any lexically correct String x:

         newXMLGregorianCalendar(x).toXMLFormat().equals(x)

        Except for the noted lexical/canonical representation mismatches listed in XML Schema 1.0 errata, Section 3.2.7.2.

        Parameters:
        lexicalRepresentation - Lexical representation of one the eight XML Schema date/time datatypes.
        Returns:
        XMLGregorianCalendar created from the lexicalRepresentation.
        Throws:
        IllegalArgumentException - If the lexicalRepresentation is not a valid XMLGregorianCalendar.
        NullPointerException - If lexicalRepresentation is null.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar(GregorianCalendar cal)

        Create an XMLGregorianCalendar from a GregorianCalendar.

        Field by Field Conversion from GregorianCalendar to an XMLGregorianCalendar
        java.util.GregorianCalendar field | javax.xml.datatype.XMLGregorianCalendar field
        ERA == GregorianCalendar.BC ? -YEAR : YEAR | XMLGregorianCalendar.setYear(int year)
        MONTH + 1 | XMLGregorianCalendar.setMonth(int month)
        DAY_OF_MONTH | XMLGregorianCalendar.setDay(int day)
        HOUR_OF_DAY, MINUTE, SECOND, MILLISECOND | XMLGregorianCalendar.setTime(int hour, int minute, int second, BigDecimal fractional)
        (ZONE_OFFSET + DST_OFFSET) / (60*1000)
        (in minutes)         		XMLGregorianCalendar.setTimezone(int offset) *

        *conversion loss of information. It is not possible to represent a java.util.GregorianCalendar daylight savings timezone id in the XML Schema 1.0 date/time datatype representation.

        To compute the return value's TimeZone field,

        • when this.getTimezone() != FIELD_UNDEFINED, create a java.util.TimeZone with a custom timezone id using the this.getTimezone().
        • else use the GregorianCalendar default timezone value for the host is defined as specified by java.util.TimeZone.getDefault().

        Parameters:
        cal - java.util.GregorianCalendar used to create XMLGregorianCalendar
        Returns:
        XMLGregorianCalendar created from java.util.GregorianCalendar
        Throws:
        NullPointerException - If cal is null.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar(BigInteger year,
                                                             int month,
                                                             int day,
                                                             int hour,
                                                             int minute,
                                                             int second,
                                                             BigDecimal fractionalSecond,
                                                             int timezone)

        Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes. Note that year parameter supports arbitrarily large numbers and fractionalSecond has infinite precision.

        A null value indicates that field is not set.

        Parameters:
        year - of XMLGregorianCalendar to be created.
        month - of XMLGregorianCalendar to be created.
        day - of XMLGregorianCalendar to be created.
        hour - of XMLGregorianCalendar to be created.
        minute - of XMLGregorianCalendar to be created.
        second - of XMLGregorianCalendar to be created.
        fractionalSecond - of XMLGregorianCalendar to be created.
        timezone - of XMLGregorianCalendar to be created.
        Returns:
        XMLGregorianCalendar created from specified values.
        Throws:
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().

      • newXMLGregorianCalendar

        public XMLGregorianCalendar newXMLGregorianCalendar(int year,
                                                    int month,
                                                    int day,
                                                    int hour,
                                                    int minute,
                                                    int second,
                                                    int millisecond,
                                                    int timezone)

        Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.

        XMLGregorianCalendar eon and fractionalSecond are set to null

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        year - of XMLGregorianCalendar to be created.
        month - of XMLGregorianCalendar to be created.
        day - of XMLGregorianCalendar to be created.
        hour - of XMLGregorianCalendar to be created.
        minute - of XMLGregorianCalendar to be created.
        second - of XMLGregorianCalendar to be created.
        millisecond - of XMLGregorianCalendar to be created.
        timezone - of XMLGregorianCalendar to be created.
        Returns:
        XMLGregorianCalendar created from specified values.
        Throws:
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().

      • newXMLGregorianCalendarDate

        public XMLGregorianCalendar newXMLGregorianCalendarDate(int year,
                                                        int month,
                                                        int day,
                                                        int timezone)

        Create a Java representation of XML Schema builtin datatype date or g*.

        For example, an instance of gYear can be created invoking this factory with month and day parameters set to DatatypeConstants.FIELD_UNDEFINED.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        year - of XMLGregorianCalendar to be created.
        month - of XMLGregorianCalendar to be created.
        day - of XMLGregorianCalendar to be created.
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        Returns:
        XMLGregorianCalendar created from parameter values.
        Throws:
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        See Also:
        DatatypeConstants.FIELD_UNDEFINED

      • newXMLGregorianCalendarTime

        public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                                        int minutes,
                                                        int seconds,
                                                        int timezone)

        Create a Java instance of XML Schema builtin datatype time.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        hours - number of hours
        minutes - number of minutes
        seconds - number of seconds
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        Returns:
        XMLGregorianCalendar created from parameter values.
        Throws:
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        See Also:
        DatatypeConstants.FIELD_UNDEFINED

      • newXMLGregorianCalendarTime

        public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                                        int minutes,
                                                        int seconds,
                                                        BigDecimal fractionalSecond,
                                                        int timezone)

        Create a Java instance of XML Schema builtin datatype time.

        A null value indicates that field is not set.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        hours - number of hours
        minutes - number of minutes
        seconds - number of seconds
        fractionalSecond - value of null indicates that this optional field is not set.
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        Returns:
        XMLGregorianCalendar created from parameter values.
        Throws:
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        See Also:
        DatatypeConstants.FIELD_UNDEFINED

      • newXMLGregorianCalendarTime

        public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                                        int minutes,
                                                        int seconds,
                                                        int milliseconds,
                                                        int timezone)

        Create a Java instance of XML Schema builtin datatype time.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        Parameters:
        hours - number of hours
        minutes - number of minutes
        seconds - number of seconds
        milliseconds - number of milliseconds
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        Returns:
        XMLGregorianCalendar created from parameter values.
        Throws:
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        See Also:
        DatatypeConstants.FIELD_UNDEFINED
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Duration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.datatype

Class Duration

  • java.lang.Object
    • javax.xml.datatype.Duration

  • public abstract class Duration
extends Object

    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.

    A Duration object represents a period of Gregorian time, which consists of six fields (years, months, days, hours, minutes, and seconds) plus a sign (+/-) field.

    The first five fields have non-negative (>=0) integers or null (which represents that the field is not set), and the seconds field has a non-negative decimal or null. A negative sign indicates a negative duration.

    This class provides a number of methods that make it easy to use for the duration datatype of XML Schema 1.0 with the errata.

    Order relationship

    Duration objects only have partial order, where two values A and B maybe either:

    1. A<B (A is shorter than B)
    2. A>B (A is longer than B)
    3. A==B (A and B are of the same duration)
    4. A<>B (Comparison between A and B is indeterminate)

    For example, 30 days cannot be meaningfully compared to one month. The compare(Duration duration) method implements this relationship.

    See the isLongerThan(Duration) method for details about the order relationship among Duration objects.

    Operations over Duration

    This class provides a set of basic arithmetic operations, such as addition, subtraction and multiplication. Because durations don't have total order, an operation could fail for some combinations of operations. For example, you cannot subtract 15 days from 1 month. See the javadoc of those methods for detailed conditions where this could happen.

    Also, division of a duration by a number is not provided because the Duration class can only deal with finite precision decimal numbers. For example, one cannot represent 1 sec divided by 3.

    However, you could substitute a division by 3 with multiplying by numbers such as 0.3 or 0.333.

    Range of allowed values

    Because some operations of Duration rely on Calendar even though Duration can hold very large or very small values, some of the methods may not work correctly on such Durations. The impacted methods document their dependency on Calendar.

    Since:
    1.5
    See Also:
    XMLGregorianCalendar.add(Duration)

    • Constructor Summary

      Constructors
      Constructor and Description
      Duration()
      Default no-arg constructor.

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Duration add(Duration rhs)
      Computes a new duration whose value is this+rhs.
      abstract void addTo(Calendar calendar)
      Adds this duration to a Calendar object.
      void addTo(Date date)
      Adds this duration to a Date object.
      abstract int compare(Duration duration)
      Partial order relation comparison with this Duration instance.
      boolean equals(Object duration)
      Checks if this duration object has the same duration as another Duration object.
      int getDays()
      Obtains the value of the DAYS field as an integer value, or 0 if not present.
      abstract Number getField(DatatypeConstants.Field field)
      Gets the value of a field.
      int getHours()
      Obtains the value of the HOURS field as an integer value, or 0 if not present.
      int getMinutes()
      Obtains the value of the MINUTES field as an integer value, or 0 if not present.
      int getMonths()
      Obtains the value of the MONTHS field as an integer value, or 0 if not present.
      int getSeconds()
      Obtains the value of the SECONDS field as an integer value, or 0 if not present.
      abstract int getSign()
      Returns the sign of this duration in -1,0, or 1.
      long getTimeInMillis(Calendar startInstant)
      Returns the length of the duration in milli-seconds.
      long getTimeInMillis(Date startInstant)
      Returns the length of the duration in milli-seconds.
      QName getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.
      int getYears()
      Get the years value of this Duration as an int or 0 if not present.
      abstract int hashCode()
      Returns a hash code consistent with the definition of the equals method.
      boolean isLongerThan(Duration duration)
      Checks if this duration object is strictly longer than another Duration object.
      abstract boolean isSet(DatatypeConstants.Field field)
      Checks if a field is set.
      boolean isShorterThan(Duration duration)
      Checks if this duration object is strictly shorter than another Duration object.
      abstract Duration multiply(BigDecimal factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      Duration multiply(int factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      abstract Duration negate()
      Returns a new Duration object whose value is -this.
      abstract Duration normalizeWith(Calendar startTimeInstant)
      Converts the years and months fields into the days field by using a specific time instant as the reference point.
      Duration subtract(Duration rhs)
      Computes a new duration whose value is this-rhs.
      String toString()
      Returns a String representation of this Duration Object.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Duration

        public Duration()
        Default no-arg constructor.

        Note: Always use the DatatypeFactory to construct an instance of Duration. The constructor on this class cannot be guaranteed to produce an object with a consistent state and may be removed in the future.

    • Method Detail

      • getXMLSchemaType

        public QName getXMLSchemaType()

        Return the name of the XML Schema date/time type that this instance maps to. Type is computed based on fields that are set, i.e. isSet(DatatypeConstants.Field field) == true.

        Required fields for XML Schema 1.0 Date/Time Datatypes.
        (timezone is optional for all date/time datatypes)
        Datatype | year | month | day | hour | minute | second
        DatatypeConstants.DURATION | X | X | X | X | X | X
        DatatypeConstants.DURATION_DAYTIME | X | X | X | X
        DatatypeConstants.DURATION_YEARMONTH | X | X
        Returns:
        one of the following constants: DatatypeConstants.DURATION, DatatypeConstants.DURATION_DAYTIME or DatatypeConstants.DURATION_YEARMONTH.
        Throws:
        IllegalStateException - If the combination of set fields does not match one of the XML Schema date/time datatypes.

      • getSign

        public abstract int getSign()
        Returns the sign of this duration in -1,0, or 1.
        Returns:
        -1 if this duration is negative, 0 if the duration is zero, and 1 if the duration is positive.

      • getYears

        public int getYears()

        Get the years value of this Duration as an int or 0 if not present.

        getYears() is a convenience method for getField(DatatypeConstants.YEARS).

        As the return value is an int, an incorrect value will be returned for Durations with years that go beyond the range of an int. Use getField(DatatypeConstants.YEARS) to avoid possible loss of precision.

        Returns:
        If the years field is present, return its value as an int, else return 0.

      • getMonths

        public int getMonths()
        Obtains the value of the MONTHS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the MONTHS field.
        Returns:
        Months of this Duration.

      • getDays

        public int getDays()
        Obtains the value of the DAYS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the DAYS field.
        Returns:
        Days of this Duration.

      • getHours

        public int getHours()
        Obtains the value of the HOURS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the HOURS field.
        Returns:
        Hours of this Duration.

      • getMinutes

        public int getMinutes()
        Obtains the value of the MINUTES field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the MINUTES field.
        Returns:
        Minutes of this Duration.

      • getSeconds

        public int getSeconds()
        Obtains the value of the SECONDS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the SECONDS field.
        Returns:
        seconds in the integer value. The fraction of seconds will be discarded (for example, if the actual value is 2.5, this method returns 2)

      • getTimeInMillis

        public long getTimeInMillis(Calendar startInstant)

        Returns the length of the duration in milli-seconds.

        If the seconds field carries more digits than milli-second order, those will be simply discarded (or in other words, rounded to zero.) For example, for any Calendar value x,

         new Duration("PT10.00099S").getTimeInMills(x) == 10000.
 new Duration("-PT10.00099S").getTimeInMills(x) == -10000.

        Note that this method uses the addTo(Calendar) method, which may work incorrectly with Duration objects with very large values in its fields. See the addTo(Calendar) method for details.

        Parameters:
        startInstant - The length of a month/year varies. The startInstant is used to disambiguate this variance. Specifically, this method returns the difference between startInstant and startInstant+duration
        Returns:
        milliseconds between startInstant and startInstant plus this Duration
        Throws:
        NullPointerException - if startInstant parameter is null.

      • getTimeInMillis

        public long getTimeInMillis(Date startInstant)

        Returns the length of the duration in milli-seconds.

        If the seconds field carries more digits than milli-second order, those will be simply discarded (or in other words, rounded to zero.) For example, for any Date value x,

         new Duration("PT10.00099S").getTimeInMills(x) == 10000.
 new Duration("-PT10.00099S").getTimeInMills(x) == -10000.

        Note that this method uses the addTo(Date) method, which may work incorrectly with Duration objects with very large values in its fields. See the addTo(Date) method for details.

        Parameters:
        startInstant - The length of a month/year varies. The startInstant is used to disambiguate this variance. Specifically, this method returns the difference between startInstant and startInstant+duration.
        Returns:
        milliseconds between startInstant and startInstant plus this Duration
        Throws:
        NullPointerException - If the startInstant parameter is null.
        See Also:
        getTimeInMillis(Calendar)

      • getField

        public abstract Number getField(DatatypeConstants.Field field)
        Gets the value of a field. Fields of a duration object may contain arbitrary large value. Therefore this method is designed to return a Number object. In case of YEARS, MONTHS, DAYS, HOURS, and MINUTES, the returned number will be a non-negative integer. In case of seconds, the returned number may be a non-negative decimal value.
        Parameters:
        field - one of the six Field constants (YEARS,MONTHS,DAYS,HOURS, MINUTES, or SECONDS.)
        Returns:
        If the specified field is present, this method returns a non-null non-negative Number object that represents its value. If it is not present, return null. For YEARS, MONTHS, DAYS, HOURS, and MINUTES, this method returns a BigInteger object. For SECONDS, this method returns a BigDecimal.
        Throws:
        NullPointerException - If the field is null.

      • isSet

        public abstract boolean isSet(DatatypeConstants.Field field)
        Checks if a field is set. A field of a duration object may or may not be present. This method can be used to test if a field is present.
        Parameters:
        field - one of the six Field constants (YEARS,MONTHS,DAYS,HOURS, MINUTES, or SECONDS.)
        Returns:
        true if the field is present. false if not.
        Throws:
        NullPointerException - If the field parameter is null.

      • add

        public abstract Duration add(Duration rhs)

        Computes a new duration whose value is this+rhs.

        For example,

         "1 day" + "-3 days" = "-2 days"
 "1 year" + "1 day" = "1 year and 1 day"
 "-(1 hour,50 minutes)" + "-20 minutes" = "-(1 hours,70 minutes)"
 "15 hours" + "-3 days" = "-(2 days,9 hours)"
 "1 year" + "-1 day" = IllegalStateException

        Since there's no way to meaningfully subtract 1 day from 1 month, there are cases where the operation fails in IllegalStateException.

        Formally, the computation is defined as follows.

        Firstly, we can assume that two Durations to be added are both positive without losing generality (i.e., (-X)+Y=Y-X, X+(-Y)=X-Y, (-X)+(-Y)=-(X+Y))

        Addition of two positive Durations are simply defined as field by field addition where missing fields are treated as 0.

        A field of the resulting Duration will be unset if and only if respective fields of two input Durations are unset.

        Note that lhs.add(rhs) will be always successful if lhs.signum()*rhs.signum()!=-1 or both of them are normalized.

        Parameters:
        rhs - Duration to add to this Duration
        Returns:
        non-null valid Duration object.
        Throws:
        NullPointerException - If the rhs parameter is null.
        IllegalStateException - If two durations cannot be meaningfully added. For example, adding negative one day to one month causes this exception.
        See Also:
        subtract(Duration)

      • addTo

        public abstract void addTo(Calendar calendar)
        Adds this duration to a Calendar object.

        Calls Calendar.add(int,int) in the order of YEARS, MONTHS, DAYS, HOURS, MINUTES, SECONDS, and MILLISECONDS if those fields are present. Because the Calendar class uses int to hold values, there are cases where this method won't work correctly (for example if values of fields exceed the range of int.)

        Also, since this duration class is a Gregorian duration, this method will not work correctly if the given Calendar object is based on some other calendar systems.

        Any fractional parts of this Duration object beyond milliseconds will be simply ignored. For example, if this duration is "P1.23456S", then 1 is added to SECONDS, 234 is added to MILLISECONDS, and the rest will be unused.

        Note that because Calendar.add(int, int) is using int, Duration with values beyond the range of int in its fields will cause overflow/underflow to the given Calendar. XMLGregorianCalendar.add(Duration) provides the same basic operation as this method while avoiding the overflow/underflow issues.

        Parameters:
        calendar - A calendar object whose value will be modified.
        Throws:
        NullPointerException - if the calendar parameter is null.

      • addTo

        public void addTo(Date date)
        Adds this duration to a Date object.

        The given date is first converted into a GregorianCalendar, then the duration is added exactly like the addTo(Calendar) method.

        The updated time instant is then converted back into a Date object and used to update the given Date object.

        This somewhat redundant computation is necessary to unambiguously determine the duration of months and years.

        Parameters:
        date - A date object whose value will be modified.
        Throws:
        NullPointerException - if the date parameter is null.

      • subtract

        public Duration subtract(Duration rhs)

        Computes a new duration whose value is this-rhs.

        For example:

         "1 day" - "-3 days" = "4 days"
 "1 year" - "1 day" = IllegalStateException
 "-(1 hour,50 minutes)" - "-20 minutes" = "-(1hours,30 minutes)"
 "15 hours" - "-3 days" = "3 days and 15 hours"
 "1 year" - "-1 day" = "1 year and 1 day"

        Since there's no way to meaningfully subtract 1 day from 1 month, there are cases where the operation fails in IllegalStateException.

        Formally the computation is defined as follows. First, we can assume that two Durations are both positive without losing generality. (i.e., (-X)-Y=-(X+Y), X-(-Y)=X+Y, (-X)-(-Y)=-(X-Y))

        Then two durations are subtracted field by field. If the sign of any non-zero field F is different from the sign of the most significant field, 1 (if F is negative) or -1 (otherwise) will be borrowed from the next bigger unit of F.

        This process is repeated until all the non-zero fields have the same sign.

        If a borrow occurs in the days field (in other words, if the computation needs to borrow 1 or -1 month to compensate days), then the computation fails by throwing an IllegalStateException.

        Parameters:
        rhs - Duration to subtract from this Duration.
        Returns:
        New Duration created from subtracting rhs from this Duration.
        Throws:
        IllegalStateException - If two durations cannot be meaningfully subtracted. For example, subtracting one day from one month causes this exception.
        NullPointerException - If the rhs parameter is null.
        See Also:
        add(Duration)

      • multiply

        public Duration multiply(int factor)

        Computes a new duration whose value is factor times longer than the value of this duration.

        This method is provided for the convenience. It is functionally equivalent to the following code:

         multiply(new BigDecimal(String.valueOf(factor)))
        Parameters:
        factor - Factor times longer of new Duration to create.
        Returns:
        New Duration that is factortimes longer than this Duration.
        See Also:
        multiply(BigDecimal)

      • multiply

        public abstract Duration multiply(BigDecimal factor)
        Computes a new duration whose value is factor times longer than the value of this duration.

        For example,

         "P1M" (1 month) * "12" = "P12M" (12 months)
 "PT1M" (1 min) * "0.3" = "PT18S" (18 seconds)
 "P1M" (1 month) * "1.5" = IllegalStateException

        Since the Duration class is immutable, this method doesn't change the value of this object. It simply computes a new Duration object and returns it.

        The operation will be performed field by field with the precision of BigDecimal. Since all the fields except seconds are restricted to hold integers, any fraction produced by the computation will be carried down toward the next lower unit. For example, if you multiply "P1D" (1 day) with "0.5", then it will be 0.5 day, which will be carried down to "PT12H" (12 hours). When fractions of month cannot be meaningfully carried down to days, or year to months, this will cause an IllegalStateException to be thrown. For example if you multiple one month by 0.5.

        To avoid IllegalStateException, use the normalizeWith(Calendar) method to remove the years and months fields.

        Parameters:
        factor - to multiply by
        Returns:
        returns a non-null valid Duration object
        Throws:
        IllegalStateException - if operation produces fraction in the months field.
        NullPointerException - if the factor parameter is null.

      • negate

        public abstract Duration negate()
        Returns a new Duration object whose value is -this.

        Since the Duration class is immutable, this method doesn't change the value of this object. It simply computes a new Duration object and returns it.

        Returns:
        always return a non-null valid Duration object.

      • normalizeWith

        public abstract Duration normalizeWith(Calendar startTimeInstant)

        Converts the years and months fields into the days field by using a specific time instant as the reference point.

        For example, duration of one month normalizes to 31 days given the start time instance "July 8th 2003, 17:40:32".

        Formally, the computation is done as follows:

        1. the given Calendar object is cloned
        2. the years, months and days fields will be added to the Calendar object by using the Calendar.add(int,int) method
        3. the difference between the two Calendars in computed in milliseconds and converted to days, if a remainder occurs due to Daylight Savings Time, it is discarded
        4. the computed days, along with the hours, minutes and seconds fields of this duration object is used to construct a new Duration object.

        Note that since the Calendar class uses int to hold the value of year and month, this method may produce an unexpected result if this duration object holds a very large value in the years or months fields.

        Parameters:
        startTimeInstant - Calendar reference point.
        Returns:
        Duration of years and months of this Duration as days.
        Throws:
        NullPointerException - If the startTimeInstant parameter is null.

      • compare

        public abstract int compare(Duration duration)

        Partial order relation comparison with this Duration instance.

        Comparison result must be in accordance with W3C XML Schema 1.0 Part 2, Section 3.2.7.6.2, Order relation on duration.

        Return:

        • DatatypeConstants.LESSER if this Duration is shorter than duration parameter
        • DatatypeConstants.EQUAL if this Duration is equal to duration parameter
        • DatatypeConstants.GREATER if this Duration is longer than duration parameter
        • DatatypeConstants.INDETERMINATE if a conclusive partial order relation cannot be determined
        Parameters:
        duration - to compare
        Returns:
        the relationship between this Durationand duration parameter as DatatypeConstants.LESSER, DatatypeConstants.EQUAL, DatatypeConstants.GREATER or DatatypeConstants.INDETERMINATE.
        Throws:
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        NullPointerException - if duration is null.
        See Also:
        isShorterThan(Duration), isLongerThan(Duration)

      • isLongerThan

        public boolean isLongerThan(Duration duration)

        Checks if this duration object is strictly longer than another Duration object.

        Duration X is "longer" than Y if and only if X>Y as defined in the section 3.2.6.2 of the XML Schema 1.0 specification.

        For example, "P1D" (one day) > "PT12H" (12 hours) and "P2Y" (two years) > "P23M" (23 months).

        Parameters:
        duration - Duration to test this Duration against.
        Returns:
        true if the duration represented by this object is longer than the given duration. false otherwise.
        Throws:
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        NullPointerException - If duration is null.
        See Also:
        isShorterThan(Duration), compare(Duration duration)

      • isShorterThan

        public boolean isShorterThan(Duration duration)

        Checks if this duration object is strictly shorter than another Duration object.

        Parameters:
        duration - Duration to test this Duration against.
        Returns:
        true if duration parameter is shorter than this Duration, else false.
        Throws:
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        NullPointerException - if duration is null.
        See Also:
        isLongerThan(Duration duration), compare(Duration duration)

      • equals

        public boolean equals(Object duration)

        Checks if this duration object has the same duration as another Duration object.

        For example, "P1D" (1 day) is equal to "PT24H" (24 hours).

        Duration X is equal to Y if and only if time instant t+X and t+Y are the same for all the test time instants specified in the section 3.2.6.2 of the XML Schema 1.0 specification.

        Note that there are cases where two Durations are "incomparable" to each other, like one month and 30 days. For example,

         !new Duration("P1M").isShorterThan(new Duration("P30D"))
 !new Duration("P1M").isLongerThan(new Duration("P30D"))
 !new Duration("P1M").equals(new Duration("P30D"))
        Overrides:
        equals in class Object
        Parameters:
        duration - The object to compare this Duration against.
        Returns:
        true if this duration is the same length as duration. false if duration is null, is not a Duration object, or its length is different from this duration.
        Throws:
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        See Also:
        compare(Duration duration)

      • hashCode

        public abstract int hashCode()
        Returns a hash code consistent with the definition of the equals method.
        Overrides:
        hashCode in class Object
        Returns:
        a hash code value for this object.
        See Also:
        Object.hashCode()

      • toString

        public String toString()

        Returns a String representation of this Duration Object.

        The result is formatted according to the XML Schema 1.0 spec and can be always parsed back later into the equivalent Duration Object by DatatypeFactory.newDuration(String lexicalRepresentation).

        Formally, the following holds for any Duration Object x:

         new Duration(x.toString()).equals(x)
        Overrides:
        toString in class Object
        Returns:
        A non-null valid String representation of this Duration.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.datatype (Java Platform SE 8 )

javax.xml.datatype

Classes

  • DatatypeConstants
  • DatatypeConstants.Field
  • DatatypeFactory
  • Duration
  • XMLGregorianCalendar

Exceptions

  • DatatypeConfigurationException


javax.xml.datatype (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.datatype

XML/Java Type Mappings.

See: Description

  • Class Summary
    Class Description
    DatatypeConstants
    Utility class to contain basic Datatype values as constants.
    DatatypeConstants.Field
    Type-safe enum class that represents six fields of the Duration class.
    DatatypeFactory
    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
    Duration
    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
    XMLGregorianCalendar
    Representation for W3C XML Schema 1.0 date/time datatypes.
  • Exception Summary
    Exception Description
    DatatypeConfigurationException
    Indicates a serious configuration error.

Package javax.xml.datatype Description

XML/Java Type Mappings.

javax.xml.datatypeAPI provides XML/Java type mappings.

The following XML standards apply:

  • W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
W3C XML Schema Data Type | Java Data Type
xs:date | XMLGregorianCalendar
xs:dateTime | XMLGregorianCalendar
xs:duration | Duration
xs:gDay | XMLGregorianCalendar
xs:gMonth | XMLGregorianCalendar
xs:gMonthDay | XMLGregorianCalendar
xs:gYear | XMLGregorianCalendar
xs:gYearMonth | XMLGregorianCalendar
xs:time | XMLGregorianCalendar
XQuery 1.0 and XPath 2.0 Data Model | Java Data Type
xdt:dayTimeDuration | Duration
xdt:yearMonthDuration | Duration

W3C XML Schema data types that have a "natural" mapping to Java types are defined by JSR 31: Java™ Architecture for XML Binding (JAXB) Specification, Binding XML Schema to Java Representations. JAXB defined mappings for XML Schema built-in data types include:

  • xs:anySimpleType
  • xs:base64Binary
  • xs:boolean
  • xs:byte
  • xs:decimal
  • xs:double
  • xs:float
  • xs:hexBinary
  • xs:int
  • xs:integer
  • xs:long
  • xs:QName
  • xs:short
  • xs:string
  • xs:unsignedByte
  • xs:unsignedInt
  • xs:unsignedShort
  • Author Jeff Suttor
  • See W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
  • Since 1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.datatype Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.datatype

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants
    • javax.xml.datatype.DatatypeConstants.Field
    • javax.xml.datatype.DatatypeFactory
    • javax.xml.datatype.Duration
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.datatype.DatatypeConfigurationException
    • javax.xml.datatype.XMLGregorianCalendar (implements java.lang.Cloneable)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.datatype (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.datatype

  • Packages that use javax.xml.datatype
    Package Description
    javax.xml.datatype
    XML/Java Type Mappings.
  • Classes in javax.xml.datatype used by javax.xml.datatype
    Class and Description
    DatatypeConfigurationException
    Indicates a serious configuration error.
    DatatypeConstants.Field
    Type-safe enum class that represents six fields of the Duration class.
    DatatypeFactory
    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
    Duration
    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
    XMLGregorianCalendar
    Representation for W3C XML Schema 1.0 date/time datatypes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLGregorianCalendar (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.datatype

Class XMLGregorianCalendar

  • java.lang.Object
    • javax.xml.datatype.XMLGregorianCalendar
  • All Implemented Interfaces:
    Cloneable

    public abstract class XMLGregorianCalendar
extends Object
implements Cloneable

    Representation for W3C XML Schema 1.0 date/time datatypes. Specifically, these date/time datatypes are DatatypeConstants.DATETIME, DatatypeConstants.TIME, DatatypeConstants.DATE, DatatypeConstants.GYEARMONTH, DatatypeConstants.GMONTHDAY, DatatypeConstants.GYEAR, DatatypeConstants.GMONTH, and DatatypeConstants.GDAY defined in the XML Namespace "http://www.w3.org/2001/XMLSchema". These datatypes are normatively defined in W3C XML Schema 1.0 Part 2, Section 3.2.7-14.

    The table below defines the mapping between XML Schema 1.0 date/time datatype fields and this class' fields. It also summarizes the value constraints for the date and time fields defined in W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats.

    Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation
    XML Schema 1.0
    datatype
    field     		Related
    XMLGregorianCalendar
    Accessor(s)     		Value Range
    year getYear() + getEon() or
    getEonAndYear()     		getYear() is a value between -(10^9-1) to (10^9)-1 or DatatypeConstants.FIELD_UNDEFINED.
    getEon() is high order year value in billion of years.
    getEon() has values greater than or equal to (10^9) or less than or equal to -(10^9). A value of null indicates field is undefined.
    Given that XML Schema 1.0 errata states that the year zero will be a valid lexical value in a future version of XML Schema, this class allows the year field to be set to zero. Otherwise, the year field value is handled exactly as described in the errata and [ISO-8601-1988]. Note that W3C XML Schema 1.0 validation does not allow for the year field to have a value of zero.
    month | getMonth() | 1 to 12 or DatatypeConstants.FIELD_UNDEFINED
    day getDay() Independent of month, max range is 1 to 31 or DatatypeConstants.FIELD_UNDEFINED.
    The normative value constraint stated relative to month field's value is in W3C XML Schema 1.0 Part 2, Appendix D.
    hour | getHour() | 0 to 23 or DatatypeConstants.FIELD_UNDEFINED. An hour value of 24 is allowed to be set in the lexical space provided the minute and second field values are zero. However, an hour value of 24 is not allowed in value space and will be transformed to represent the value of the first instance of the following day as per XML Schema Part 2: Datatypes Second Edition, 3.2 Primitive datatypes.
    minute | getMinute() | 0 to 59 or DatatypeConstants.FIELD_UNDEFINED
    second getSecond() + getMillisecond()/1000 or
    getSecond() + getFractionalSecond()     		getSecond() from 0 to 60 or DatatypeConstants.FIELD_UNDEFINED.
    (Note: 60 only allowable for leap second.)
    getFractionalSecond() allows for infinite precision over the range from 0.0 to 1.0 when the getSecond() is defined.
    FractionalSecond is optional and has a value of null when it is undefined.
    getMillisecond() is the convenience millisecond precision of value of getFractionalSecond().
    timezone | getTimezone() | Number of minutes or DatatypeConstants.FIELD_UNDEFINED. Value range from -14 hours (-14 * 60 minutes) to 14 hours (14 * 60 minutes).

    All maximum value space constraints listed for the fields in the table above are checked by factory methods, @{link DatatypeFactory}, setter methods and parse methods of this class. IllegalArgumentException is thrown when a parameter's value is outside the value constraint for the field or if the composite values constitute an invalid XMLGregorianCalendar instance (for example, if the 31st of June is specified).

    The following operations are defined for this class:

    • accessors/mutators for independent date/time fields
    • conversion between this class and W3C XML Schema 1.0 lexical representation, toString(), DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)
    • conversion between this class and GregorianCalendar, toGregorianCalendar(java.util.TimeZone timezone, java.util.Locale aLocale, XMLGregorianCalendar defaults), DatatypeFactory
    • partial order relation comparator method, compare(XMLGregorianCalendar xmlGregorianCalendar)
    • equals(Object) defined relative to compare(XMLGregorianCalendar xmlGregorianCalendar).
    • addition operation with Duration instance as defined in W3C XML Schema 1.0 Part 2, Appendix E, Adding durations to dateTimes.

    Since:
    1.5
    See Also:
    Duration, DatatypeFactory

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLGregorianCalendar()
      Default no-arg constructor.

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract void add(Duration duration)
      Add duration to this instance.
      abstract void clear()
      Unset all fields to undefined.
      abstract Object clone()
      Creates and returns a copy of this object.
      abstract int compare(XMLGregorianCalendar xmlGregorianCalendar)
      Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.
      boolean equals(Object obj)
      Compares this calendar to the specified object.
      abstract int getDay()
      Return day in month or DatatypeConstants.FIELD_UNDEFINED.
      abstract BigInteger getEon()
      Return high order component for XML Schema 1.0 dateTime datatype field for year.
      abstract BigInteger getEonAndYear()
      Return XML Schema 1.0 dateTime datatype field for year.
      abstract BigDecimal getFractionalSecond()
      Return fractional seconds.
      abstract int getHour()
      Return hours or DatatypeConstants.FIELD_UNDEFINED.
      int getMillisecond()
      Return millisecond precision of getFractionalSecond().
      abstract int getMinute()
      Return minutes or DatatypeConstants.FIELD_UNDEFINED.
      abstract int getMonth()
      Return number of month or DatatypeConstants.FIELD_UNDEFINED.
      abstract int getSecond()
      Return seconds or DatatypeConstants.FIELD_UNDEFINED.
      abstract int getTimezone()
      Return timezone offset in minutes or DatatypeConstants.FIELD_UNDEFINED if this optional field is not defined.
      abstract TimeZone getTimeZone(int defaultZoneoffset)
      Returns a java.util.TimeZone for this class.
      abstract QName getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.
      abstract int getYear()
      Return low order component for XML Schema 1.0 dateTime datatype field for year or DatatypeConstants.FIELD_UNDEFINED.
      int hashCode()
      Returns a hash code consistent with the definition of the equals method.
      abstract boolean isValid()
      Validate instance by getXMLSchemaType() constraints.
      abstract XMLGregorianCalendar normalize()
      Normalize this instance to UTC.
      abstract void reset()
      Reset this XMLGregorianCalendar to its original values.
      abstract void setDay(int day)
      Set days in month.
      abstract void setFractionalSecond(BigDecimal fractional)
      Set fractional seconds.
      abstract void setHour(int hour)
      Set hours.
      abstract void setMillisecond(int millisecond)
      Set milliseconds.
      abstract void setMinute(int minute)
      Set minutes.
      abstract void setMonth(int month)
      Set month.
      abstract void setSecond(int second)
      Set seconds.
      void setTime(int hour, int minute, int second)
      Set time as one unit.
      void setTime(int hour, int minute, int second, BigDecimal fractional)
      Set time as one unit, including the optional infinite precision fractional seconds.
      void setTime(int hour, int minute, int second, int millisecond)
      Set time as one unit, including optional milliseconds.
      abstract void setTimezone(int offset)
      Set the number of minutes in the timezone offset.
      abstract void setYear(BigInteger year)
      Set low and high order component of XSD dateTime year field.
      abstract void setYear(int year)
      Set year of XSD dateTime year field.
      abstract GregorianCalendar toGregorianCalendar()
      Convert this XMLGregorianCalendar to a GregorianCalendar.
      abstract GregorianCalendar toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.
      String toString()
      Returns a String representation of this XMLGregorianCalendar Object.
      abstract String toXMLFormat()
      Return the lexical representation of this instance.

      • Methods inherited from class java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • XMLGregorianCalendar

        public XMLGregorianCalendar()
        Default no-arg constructor.

        Note: Always use the DatatypeFactory to construct an instance of XMLGregorianCalendar. The constructor on this class cannot be guaranteed to produce an object with a consistent state and may be removed in the future.

    • Method Detail

      • clear

        public abstract void clear()

        Unset all fields to undefined.

        Set all int fields to DatatypeConstants.FIELD_UNDEFINED and reference fields to null.

      • reset

        public abstract void reset()

        Reset this XMLGregorianCalendar to its original values.

        XMLGregorianCalendar is reset to the same values as when it was created with DatatypeFactory.newXMLGregorianCalendar(), DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation), DatatypeFactory.newXMLGregorianCalendar( BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone), DatatypeFactory.newXMLGregorianCalendar( int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone), DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal), DatatypeFactory.newXMLGregorianCalendarDate( int year, int month, int day, int timezone), DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, int timezone), DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) or DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, int milliseconds, int timezone).

        reset() is designed to allow the reuse of existing XMLGregorianCalendars thus saving resources associated with the creation of new XMLGregorianCalendars.

      • setYear

        public abstract void setYear(BigInteger year)

        Set low and high order component of XSD dateTime year field.

        Unset this field by invoking the setter with a parameter value of null.

        Parameters:
        year - value constraints summarized in year field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if year parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setYear

        public abstract void setYear(int year)

        Set year of XSD dateTime year field.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Note: if the absolute value of the year parameter is less than 10^9, the eon component of the XSD year field is set to null by this method.

        Parameters:
        year - value constraints are summarized in year field of date/time field mapping table. If year is DatatypeConstants.FIELD_UNDEFINED, then eon is set to null.

      • setMonth

        public abstract void setMonth(int month)

        Set month.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        month - value constraints summarized in month field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if month parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setDay

        public abstract void setDay(int day)

        Set days in month.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        day - value constraints summarized in day field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if day parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTimezone

        public abstract void setTimezone(int offset)

        Set the number of minutes in the timezone offset.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        offset - value constraints summarized in timezone field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if offset parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTime

        public void setTime(int hour,
                    int minute,
                    int second)

        Set time as one unit.

        Parameters:
        hour - value constraints are summarized in hour field of date/time field mapping table.
        minute - value constraints are summarized in minute field of date/time field mapping table.
        second - value constraints are summarized in second field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if any parameter is outside value constraints for the field as specified in date/time field mapping table.
        See Also:
        setTime(int, int, int, BigDecimal)

      • setHour

        public abstract void setHour(int hour)

        Set hours.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        hour - value constraints summarized in hour field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if hour parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setMinute

        public abstract void setMinute(int minute)

        Set minutes.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        minute - value constraints summarized in minute field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if minute parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setSecond

        public abstract void setSecond(int second)

        Set seconds.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        second - value constraints summarized in second field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if second parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setMillisecond

        public abstract void setMillisecond(int millisecond)

        Set milliseconds.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Parameters:
        millisecond - value constraints summarized in second field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if millisecond parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setFractionalSecond

        public abstract void setFractionalSecond(BigDecimal fractional)

        Set fractional seconds.

        Unset this field by invoking the setter with a parameter value of null.

        Parameters:
        fractional - value constraints summarized in second field of date/time field mapping table.
        Throws:
        IllegalArgumentException - if fractional parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTime

        public void setTime(int hour,
                    int minute,
                    int second,
                    BigDecimal fractional)

        Set time as one unit, including the optional infinite precision fractional seconds.

        Parameters:
        hour - value constraints are summarized in hour field of date/time field mapping table.
        minute - value constraints are summarized in minute field of date/time field mapping table.
        second - value constraints are summarized in second field of date/time field mapping table.
        fractional - value of null indicates this optional field is not set.
        Throws:
        IllegalArgumentException - if any parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTime

        public void setTime(int hour,
                    int minute,
                    int second,
                    int millisecond)

        Set time as one unit, including optional milliseconds.

        Parameters:
        hour - value constraints are summarized in hour field of date/time field mapping table.
        minute - value constraints are summarized in minute field of date/time field mapping table.
        second - value constraints are summarized in second field of date/time field mapping table.
        millisecond - value of DatatypeConstants.FIELD_UNDEFINED indicates this optional field is not set.
        Throws:
        IllegalArgumentException - if any parameter is outside value constraints for the field as specified in date/time field mapping table.

      • getEon

        public abstract BigInteger getEon()

        Return high order component for XML Schema 1.0 dateTime datatype field for year. null if this optional part of the year field is not defined.

        Value constraints for this value are summarized in year field of date/time field mapping table.

        Returns:
        eon of this XMLGregorianCalendar. The value returned is an integer multiple of 10^9.
        See Also:
        getYear(), getEonAndYear()

      • getYear

        public abstract int getYear()

        Return low order component for XML Schema 1.0 dateTime datatype field for year or DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in year field of date/time field mapping table.

        Returns:
        year of this XMLGregorianCalendar.
        See Also:
        getEon(), getEonAndYear()

      • getEonAndYear

        public abstract BigInteger getEonAndYear()

        Return XML Schema 1.0 dateTime datatype field for year.

        Value constraints for this value are summarized in year field of date/time field mapping table.

        Returns:
        sum of eon and BigInteger.valueOf(year) when both fields are defined. When only year is defined, return it. When both eon and year are not defined, return null.
        See Also:
        getEon(), getYear()

      • getMonth

        public abstract int getMonth()

        Return number of month or DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in month field of date/time field mapping table.

        Returns:
        year of this XMLGregorianCalendar.

      • getDay

        public abstract int getDay()
        Return day in month or DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in day field of date/time field mapping table.

        See Also:
        setDay(int)

      • getTimezone

        public abstract int getTimezone()
        Return timezone offset in minutes or DatatypeConstants.FIELD_UNDEFINED if this optional field is not defined.

        Value constraints for this value are summarized in timezone field of date/time field mapping table.

        See Also:
        setTimezone(int)

      • getHour

        public abstract int getHour()
        Return hours or DatatypeConstants.FIELD_UNDEFINED. Returns DatatypeConstants.FIELD_UNDEFINED if this field is not defined.

        Value constraints for this value are summarized in hour field of date/time field mapping table.

        See Also:
        setTime(int, int, int)

      • getMinute

        public abstract int getMinute()
        Return minutes or DatatypeConstants.FIELD_UNDEFINED.

        Returns DatatypeConstants.FIELD_UNDEFINED if this field is not defined.

        Value constraints for this value are summarized in minute field of date/time field mapping table.

        See Also:
        setTime(int, int, int)

      • getSecond

        public abstract int getSecond()

        Return seconds or DatatypeConstants.FIELD_UNDEFINED.

        Returns DatatypeConstants.FIELD_UNDEFINED if this field is not defined. When this field is not defined, the optional xs:dateTime fractional seconds field, represented by getFractionalSecond() and getMillisecond(), must not be defined.

        Value constraints for this value are summarized in second field of date/time field mapping table.

        Returns:
        Second of this XMLGregorianCalendar.
        See Also:
        getFractionalSecond(),
getMillisecond(),
setTime(int, int, int)

      • getMillisecond

        public int getMillisecond()

        Return millisecond precision of getFractionalSecond().

        This method represents a convenience accessor to infinite precision fractional second value returned by getFractionalSecond(). The returned value is the rounded down to milliseconds value of getFractionalSecond(). When getFractionalSecond() returns null, this method must return DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in second field of date/time field mapping table.

        Returns:
        Millisecond of this XMLGregorianCalendar.
        See Also:
        getFractionalSecond(), setTime(int, int, int)

      • getFractionalSecond

        public abstract BigDecimal getFractionalSecond()

        Return fractional seconds.

        null is returned when this optional field is not defined.

        Value constraints are detailed in second field of date/time field mapping table.

        This optional field can only have a defined value when the xs:dateTime second field, represented by getSecond(), does not return DatatypeConstants.FIELD_UNDEFINED.

        Returns:
        fractional seconds of this XMLGregorianCalendar.
        See Also:
        getSecond(), setTime(int, int, int, BigDecimal)

      • compare

        public abstract int compare(XMLGregorianCalendar xmlGregorianCalendar)

        Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.

        xsd:dateTime datatype field mapping to accessors of this class are defined in date/time field mapping table.

        Parameters:
        xmlGregorianCalendar - Instance of XMLGregorianCalendar to compare
        Returns:
        The relationship between this XMLGregorianCalendar and the specified xmlGregorianCalendar as DatatypeConstants.LESSER, DatatypeConstants.EQUAL, DatatypeConstants.GREATER or DatatypeConstants.INDETERMINATE.
        Throws:
        NullPointerException - if xmlGregorianCalendar is null.

      • normalize

        public abstract XMLGregorianCalendar normalize()

        Normalize this instance to UTC.

        2000-03-04T23:00:00+03:00 normalizes to 2000-03-04T20:00:00Z

        Implements W3C XML Schema Part 2, Section 3.2.7.3 (A).

        Returns:
        this XMLGregorianCalendar normalized to UTC.

      • equals

        public boolean equals(Object obj)

        Compares this calendar to the specified object. The result is true if and only if the argument is not null and is an XMLGregorianCalendar object that represents the same instant in time as this object.

        Overrides:
        equals in class Object
        Parameters:
        obj - to compare.
        Returns:
        true when obj is an instance of XMLGregorianCalendar and compare(XMLGregorianCalendar obj) returns DatatypeConstants.EQUAL, otherwise false.
        See Also:
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns a hash code consistent with the definition of the equals method.

        Overrides:
        hashCode in class Object
        Returns:
        hash code of this object.
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toXMLFormat

        public abstract String toXMLFormat()

        Return the lexical representation of this instance. The format is specified in XML Schema 1.0 Part 2, Section 3.2.[7-14].1, Lexical Representation".

        Specific target lexical representation format is determined by getXMLSchemaType().

        Returns:
        XML, as String, representation of this XMLGregorianCalendar
        Throws:
        IllegalStateException - if the combination of set fields does not match one of the eight defined XML Schema builtin date/time datatypes.

      • getXMLSchemaType

        public abstract QName getXMLSchemaType()

        Return the name of the XML Schema date/time type that this instance maps to. Type is computed based on fields that are set.

        Required fields for XML Schema 1.0 Date/Time Datatypes.
        (timezone is optional for all date/time datatypes)
        Datatype | year | month | day | hour | minute | second
        DatatypeConstants.DATETIME | X | X | X | X | X | X
        DatatypeConstants.DATE | X | X | X
        DatatypeConstants.TIME | X | X | X
        DatatypeConstants.GYEARMONTH | X | X
        DatatypeConstants.GMONTHDAY | X | X
        DatatypeConstants.GYEAR | X
        DatatypeConstants.GMONTH | X
        DatatypeConstants.GDAY | X
        Returns:
        One of the following class constants: DatatypeConstants.DATETIME, DatatypeConstants.TIME, DatatypeConstants.DATE, DatatypeConstants.GYEARMONTH, DatatypeConstants.GMONTHDAY, DatatypeConstants.GYEAR, DatatypeConstants.GMONTH or DatatypeConstants.GDAY.
        Throws:
        IllegalStateException - if the combination of set fields does not match one of the eight defined XML Schema builtin date/time datatypes.

      • toString

        public String toString()

        Returns a String representation of this XMLGregorianCalendar Object.

        The result is a lexical representation generated by toXMLFormat().

        Overrides:
        toString in class Object
        Returns:
        A non-null valid String representation of this XMLGregorianCalendar.
        Throws:
        IllegalStateException - if the combination of set fields does not match one of the eight defined XML Schema builtin date/time datatypes.
        See Also:
        toXMLFormat()

      • isValid

        public abstract boolean isValid()
        Validate instance by getXMLSchemaType() constraints.
        Returns:
        true if data values are valid.

      • add

        public abstract void add(Duration duration)

        Add duration to this instance.

        The computation is specified in XML Schema 1.0 Part 2, Appendix E, Adding durations to dateTimes>. date/time field mapping table defines the mapping from XML Schema 1.0 dateTime fields to this class' representation of those fields.

        Parameters:
        duration - Duration to add to this XMLGregorianCalendar.
        Throws:
        NullPointerException - when duration parameter is null.

      • toGregorianCalendar

        public abstract GregorianCalendar toGregorianCalendar()

        Convert this XMLGregorianCalendar to a GregorianCalendar.

        When this instance has an undefined field, this conversion relies on the java.util.GregorianCalendar default for its corresponding field. A notable difference between XML Schema 1.0 date/time datatypes and java.util.GregorianCalendar is that Timezone value is optional for date/time datatypes and it is a required field for java.util.GregorianCalendar. See javadoc for java.util.TimeZone.getDefault() on how the default is determined. To explicitly specify the TimeZone instance, see toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar).

        Field by Field Conversion from this class to java.util.GregorianCalendar
        java.util.GregorianCalendar field | javax.xml.datatype.XMLGregorianCalendar field
        ERA | getEonAndYear() .signum() < 0 ? GregorianCalendar.BC : GregorianCalendar.AD
        YEAR | getEonAndYear() .abs().intValue()*
        MONTH | getMonth() - DatatypeConstants.JANUARY + Calendar.JANUARY
        DAY_OF_MONTH | getDay()
        HOUR_OF_DAY | getHour()
        MINUTE | getMinute()
        SECOND | getSecond()
        MILLISECOND | get millisecond order from getFractionalSecond() *
        GregorianCalendar.setTimeZone(TimeZone) | getTimezone() formatted into Custom timezone id
        * designates possible loss of precision during the conversion due to source datatype having higher precision than target datatype.

        To ensure consistency in conversion implementations, the new GregorianCalendar should be instantiated in following manner.

        • Using timeZone value as defined above, create a new java.util.GregorianCalendar(timeZone,Locale.getDefault()).
        • Initialize all GregorianCalendar fields by calling Calendar.clear().
        • Obtain a pure Gregorian Calendar by invoking GregorianCalendar.setGregorianChange( new Date(Long.MIN_VALUE)).
        • Its fields ERA, YEAR, MONTH, DAY_OF_MONTH, HOUR_OF_DAY, MINUTE, SECOND and MILLISECOND are set using the method Calendar.set(int,int)

        See Also:
        toGregorianCalendar(java.util.TimeZone, java.util.Locale, XMLGregorianCalendar)

      • toGregorianCalendar

        public abstract GregorianCalendar toGregorianCalendar(TimeZone timezone,
                                                      Locale aLocale,
                                                      XMLGregorianCalendar defaults)

        Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.

        Since XML Schema 1.0 date/time datetypes has no concept of timezone ids or daylight savings timezone ids, this conversion operation allows the user to explicitly specify one with timezone parameter.

        To compute the return value's TimeZone field,

        • when parameter timeZone is non-null, it is the timezone field.
        • else when this.getTimezone() != FIELD_UNDEFINED, create a java.util.TimeZone with a custom timezone id using the this.getTimezone().
        • else when defaults.getTimezone() != FIELD_UNDEFINED, create a java.util.TimeZone with a custom timezone id using defaults.getTimezone().
        • else use the GregorianCalendar default timezone value for the host is defined as specified by java.util.TimeZone.getDefault().

          • To ensure consistency in conversion implementations, the new GregorianCalendar should be instantiated in following manner.

          • Create a new java.util.GregorianCalendar(TimeZone, Locale) with TimeZone set as specified above and the Locale parameter.
          • Initialize all GregorianCalendar fields by calling Calendar.clear()
          • Obtain a pure Gregorian Calendar by invoking GregorianCalendar.setGregorianChange( new Date(Long.MIN_VALUE)).
          • Its fields ERA, YEAR, MONTH, DAY_OF_MONTH, HOUR_OF_DAY, MINUTE, SECOND and MILLISECOND are set using the method Calendar.set(int,int)
        Parameters:
        timezone - provide Timezone. null is a legal value.
        aLocale - provide explicit Locale. Use default GregorianCalendar locale if value is null.
        defaults - provide default field values to use when corresponding field for this instance is FIELD_UNDEFINED or null. If defaultsis null or a field within the specified defaults is undefined, just use java.util.GregorianCalendar defaults.
        Returns:
        a java.util.GregorianCalendar conversion of this instance.

      • getTimeZone

        public abstract TimeZone getTimeZone(int defaultZoneoffset)

        Returns a java.util.TimeZone for this class.

        If timezone field is defined for this instance, returns TimeZone initialized with custom timezone id of zoneoffset. If timezone field is undefined, try the defaultZoneoffset that was passed in. If defaultZoneoffset is FIELD_UNDEFINED, return default timezone for this host. (Same default as java.util.GregorianCalendar).

        Parameters:
        defaultZoneoffset - default zoneoffset if this zoneoffset is DatatypeConstants.FIELD_UNDEFINED.
        Returns:
        TimeZone for this.

      • clone

        public abstract Object clone()

        Creates and returns a copy of this object.

        Overrides:
        clone in class Object
        Returns:
        copy of this Object
        See Also:
        Cloneable
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.datatype.DatatypeConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.datatype.DatatypeConfigurationException

  • Packages that use DatatypeConfigurationException
    Package Description
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of DatatypeConfigurationException in javax.xml.datatype

      Methods in javax.xml.datatype that throw DatatypeConfigurationException
      Modifier and Type Method and Description
      static DatatypeFactory DatatypeFactory.newInstance()
      Obtain a new instance of a DatatypeFactory.
      static DatatypeFactory DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DatatypeFactory from class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.datatype.DatatypeConstants.Field (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.datatype.DatatypeConstants.Field

  • Packages that use DatatypeConstants.Field
    Package Description
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of DatatypeConstants.Field in javax.xml.datatype

      Fields in javax.xml.datatype declared as DatatypeConstants.Field
      Modifier and Type Field and Description
      static DatatypeConstants.Field DatatypeConstants.DAYS
      A constant that represents the days field.
      static DatatypeConstants.Field DatatypeConstants.HOURS
      A constant that represents the hours field.
      static DatatypeConstants.Field DatatypeConstants.MINUTES
      A constant that represents the minutes field.
      static DatatypeConstants.Field DatatypeConstants.MONTHS
      A constant that represents the months field.
      static DatatypeConstants.Field DatatypeConstants.SECONDS
      A constant that represents the seconds field.
      static DatatypeConstants.Field DatatypeConstants.YEARS
      A constant that represents the years field.
      Methods in javax.xml.datatype with parameters of type DatatypeConstants.Field
      Modifier and Type Method and Description
      abstract Number Duration.getField(DatatypeConstants.Field field)
      Gets the value of a field.
      abstract boolean Duration.isSet(DatatypeConstants.Field field)
      Checks if a field is set.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.datatype.DatatypeConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.datatype.DatatypeConstants

No usage of javax.xml.datatype.DatatypeConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.datatype.DatatypeFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.datatype.DatatypeFactory

  • Packages that use DatatypeFactory
    Package Description
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of DatatypeFactory in javax.xml.datatype

      Methods in javax.xml.datatype that return DatatypeFactory
      Modifier and Type Method and Description
      static DatatypeFactory DatatypeFactory.newInstance()
      Obtain a new instance of a DatatypeFactory.
      static DatatypeFactory DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DatatypeFactory from class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.datatype.Duration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.datatype.Duration

  • Packages that use Duration
    Package Description
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of Duration in javax.xml.datatype

      Methods in javax.xml.datatype that return Duration
      Modifier and Type Method and Description
      abstract Duration Duration.add(Duration rhs)
      Computes a new duration whose value is this+rhs.
      abstract Duration Duration.multiply(BigDecimal factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      Duration Duration.multiply(int factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      abstract Duration Duration.negate()
      Returns a new Duration object whose value is -this.
      abstract Duration DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      Duration DatatypeFactory.newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      abstract Duration DatatypeFactory.newDuration(long durationInMilliSeconds)
      Obtain a new instance of a Duration specifying the Duration as milliseconds.
      abstract Duration DatatypeFactory.newDuration(String lexicalRepresentation)
      Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.
      Duration DatatypeFactory.newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationDayTime(long durationInMilliseconds)
      Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationDayTime(String lexicalRepresentation)
      Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration DatatypeFactory.newDurationYearMonth(boolean isPositive, int year, int month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration DatatypeFactory.newDurationYearMonth(long durationInMilliseconds)
      Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration DatatypeFactory.newDurationYearMonth(String lexicalRepresentation)
      Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      abstract Duration Duration.normalizeWith(Calendar startTimeInstant)
      Converts the years and months fields into the days field by using a specific time instant as the reference point.
      Duration Duration.subtract(Duration rhs)
      Computes a new duration whose value is this-rhs.
      Methods in javax.xml.datatype with parameters of type Duration
      Modifier and Type Method and Description
      abstract Duration Duration.add(Duration rhs)
      Computes a new duration whose value is this+rhs.
      abstract void XMLGregorianCalendar.add(Duration duration)
      Add duration to this instance.
      abstract int Duration.compare(Duration duration)
      Partial order relation comparison with this Duration instance.
      boolean Duration.isLongerThan(Duration duration)
      Checks if this duration object is strictly longer than another Duration object.
      boolean Duration.isShorterThan(Duration duration)
      Checks if this duration object is strictly shorter than another Duration object.
      Duration Duration.subtract(Duration rhs)
      Computes a new duration whose value is this-rhs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.datatype.XMLGregorianCalendar (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.datatype.XMLGregorianCalendar

  • Packages that use XMLGregorianCalendar
    Package Description
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of XMLGregorianCalendar in javax.xml.datatype

      Methods in javax.xml.datatype that return XMLGregorianCalendar
      Modifier and Type Method and Description
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar()
      Create a new instance of an XMLGregorianCalendar.
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)
      Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes.
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal)
      Create an XMLGregorianCalendar from a GregorianCalendar.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone)
      Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)
      Create a new XMLGregorianCalendar by parsing the String as a lexical representation.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarDate(int year, int month, int day, int timezone)
      Create a Java representation of XML Schema builtin datatype date or g*.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      abstract XMLGregorianCalendar XMLGregorianCalendar.normalize()
      Normalize this instance to UTC.
      Methods in javax.xml.datatype with parameters of type XMLGregorianCalendar
      Modifier and Type Method and Description
      abstract int XMLGregorianCalendar.compare(XMLGregorianCalendar xmlGregorianCalendar)
      Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.
      abstract GregorianCalendar XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.namespace (Java Platform SE 8 )

compact2 - javax.xml.namespace

Interfaces

  • NamespaceContext

Classes

  • QName


javax.xml.namespace (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.namespace

XML Namespace processing.

See: Description

  • Interface Summary
    Interface Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
  • Class Summary
    Class Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

Package javax.xml.namespace Description

XML Namespace processing.

The following XML standards apply:

  • XML Schema Part2: Datatypes specification
  • Namespaces in XML
  • Namespaces in XML Errata
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.namespace (Java Platform SE 8 )

compact3 - javax.xml.namespace

Interfaces

  • NamespaceContext

Classes

  • QName


javax.xml.namespace (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.namespace

XML Namespace processing.

See: Description

  • Interface Summary
    Interface Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
  • Class Summary
    Class Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

Package javax.xml.namespace Description

XML Namespace processing.

The following XML standards apply:

  • XML Schema Part2: Datatypes specification
  • Namespaces in XML
  • Namespaces in XML Errata
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamespaceContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.namespace

Interface NamespaceContext

  • public interface NamespaceContext

    Interface for read only XML Namespace context processing.

    An XML Namespace has the properties:

    • Namespace URI: Namespace name expressed as a URI to which the prefix is bound
    • prefix: syntactically, this is the part of the attribute name following the XMLConstants.XMLNS_ATTRIBUTE ("xmlns") in the Namespace declaration

    example: <element xmlns:prefix="http://Namespace-name-URI">

    All get*(*) methods operate in the current scope for Namespace URI and prefix resolution.

    Note that a Namespace URI can be bound to multiple prefixes in the current scope. This can occur when multiple XMLConstants.XMLNS_ATTRIBUTE ("xmlns") Namespace declarations occur in the same Start-Tag and refer to the same Namespace URI. e.g.

     <element xmlns:prefix1="http://Namespace-name-URI"
          xmlns:prefix2="http://Namespace-name-URI">
    This can also occur when the same Namespace URI is used in multiple XMLConstants.XMLNS_ATTRIBUTE ("xmlns") Namespace declarations in the logical parent element hierarchy. e.g.
     <parent xmlns:prefix1="http://Namespace-name-URI">
   <child xmlns:prefix2="http://Namespace-name-URI">
     ...
   </child>
 </parent>

    A prefix can only be bound to a single Namespace URI in the current scope.

    Since:
    1.5
    See Also:
    javax.xml.XMLConstants for declarations of common XML values, XML Schema Part2: Datatypes, Namespaces in XML, Namespaces in XML Errata

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getNamespaceURI(String prefix)
      Get Namespace URI bound to a prefix in the current scope.
      String getPrefix(String namespaceURI)
      Get prefix bound to Namespace URI in the current scope.
      Iterator getPrefixes(String namespaceURI)
      Get all prefixes bound to a Namespace URI in the current scope.

    • Method Detail

      • getNamespaceURI

        String getNamespaceURI(String prefix)

        Get Namespace URI bound to a prefix in the current scope.

        When requesting a Namespace URI by prefix, the following table describes the returned Namespace URI value for all possible prefix values:

        getNamespaceURI(prefix) return value for specified prefixes
        prefix parameter | Namespace URI return value
        DEFAULT_NS_PREFIX ("") | default Namespace URI in the current scope or XMLConstants.NULL_NS_URI("") when there is no default Namespace URI in the current scope
        bound prefix | Namespace URI bound to prefix in current scope
        unbound prefix | XMLConstants.NULL_NS_URI("")
        XMLConstants.XML_NS_PREFIX ("xml") | XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace")
        XMLConstants.XMLNS_ATTRIBUTE ("xmlns") | XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/")
        null | IllegalArgumentException is thrown
        Parameters:
        prefix - prefix to look up
        Returns:
        Namespace URI bound to prefix in the current scope
        Throws:
        IllegalArgumentException - When prefix is null

      • getPrefix

        String getPrefix(String namespaceURI)

        Get prefix bound to Namespace URI in the current scope.

        To get all prefixes bound to a Namespace URI in the current scope, use getPrefixes(String namespaceURI).

        When requesting a prefix by Namespace URI, the following table describes the returned prefix value for all Namespace URI values:

        getPrefix(namespaceURI) return value for specified Namespace URIs
        Namespace URI parameter | prefix value returned
        <default Namespace URI> | XMLConstants.DEFAULT_NS_PREFIX ("")
        bound Namespace URI | prefix bound to Namespace URI in the current scope, if multiple prefixes are bound to the Namespace URI in the current scope, a single arbitrary prefix, whose choice is implementation dependent, is returned
        unbound Namespace URI | null
        XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace") | XMLConstants.XML_NS_PREFIX ("xml")
        XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/") | XMLConstants.XMLNS_ATTRIBUTE ("xmlns")
        null | IllegalArgumentException is thrown
        Parameters:
        namespaceURI - URI of Namespace to lookup
        Returns:
        prefix bound to Namespace URI in current context
        Throws:
        IllegalArgumentException - When namespaceURI is null

      • getPrefixes

        Iterator getPrefixes(String namespaceURI)

        Get all prefixes bound to a Namespace URI in the current scope.

        An Iterator over String elements is returned in an arbitrary, implementation dependent, order.

        The Iterator is not modifiable. e.g. the remove() method will throw UnsupportedOperationException.

        When requesting prefixes by Namespace URI, the following table describes the returned prefixes value for all Namespace URI values:

        getPrefixes(namespaceURI) return value for specified Namespace URIs
        Namespace URI parameter | prefixes value returned
        bound Namespace URI, including the <default Namespace URI> | Iterator over prefixes bound to Namespace URI in the current scope in an arbitrary, implementation dependent, order
        unbound Namespace URI | empty Iterator
        XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace") | Iterator with one element set to XMLConstants.XML_NS_PREFIX ("xml")
        XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/") | Iterator with one element set to XMLConstants.XMLNS_ATTRIBUTE ("xmlns")
        null | IllegalArgumentException is thrown
        Parameters:
        namespaceURI - URI of Namespace to lookup
        Returns:
        Iterator for all prefixes bound to the Namespace URI in the current scope
        Throws:
        IllegalArgumentException - When namespaceURI is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.namespace (Java Platform SE 8 )

javax.xml.namespace

Interfaces

  • NamespaceContext

Classes

  • QName


javax.xml.namespace (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.namespace

XML Namespace processing.

See: Description

  • Interface Summary
    Interface Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
  • Class Summary
    Class Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

Package javax.xml.namespace Description

XML Namespace processing.

The following XML standards apply:

  • XML Schema Part2: Datatypes specification
  • Namespaces in XML
  • Namespaces in XML Errata
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.namespace Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.namespace

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.namespace.QName (implements java.io.Serializable)

Interface Hierarchy

  • javax.xml.namespace.NamespaceContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.namespace (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.namespace

  • Packages that use javax.xml.namespace
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.datatype
    XML/Java Type Mappings.
    javax.xml.namespace
    XML Namespace processing.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
  • Classes in javax.xml.namespace used by javax.xml.bind
    Class and Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.datatype
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.namespace
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.soap
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.stream
    Class and Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.stream.events
    Class and Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.stream.util
    Class and Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.handler
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.handler.soap
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.spi
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.wsaddressing
    Class and Description
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.xpath
    Class and Description
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


QName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.namespace

Class QName

  • java.lang.Object
    • javax.xml.namespace.QName
  • All Implemented Interfaces:
    Serializable

    public class QName
extends Object
implements Serializable

    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

    The value of a QName contains a Namespace URI, local part and prefix.

    The prefix is included in QName to retain lexical information when present in an XML input source. The prefix is NOT used in QName.equals(Object) or to compute the QName.hashCode(). Equality and the hash code are defined using only the Namespace URI and local part.

    If not specified, the Namespace URI is set to XMLConstants.NULL_NS_URI. If not specified, the prefix is set to XMLConstants.DEFAULT_NS_PREFIX.

    QName is immutable.

    Since:
    1.5
    Version:
    $Revision: 1.8 $, $Date: 2010/03/18 03:06:17 $
    See Also:
    XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      QName(String localPart)
      QName constructor specifying the local part.
      QName(String namespaceURI, String localPart)
      QName constructor specifying the Namespace URI and local part.
      QName(String namespaceURI, String localPart, String prefix)
      QName constructor specifying the Namespace URI, local part and prefix.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean equals(Object objectToTest)
      Test this QName for equality with another Object.
      String getLocalPart()
      Get the local part of this QName.
      String getNamespaceURI()
      Get the Namespace URI of this QName.
      String getPrefix()
      Get the prefix of this QName.
      int hashCode()
      Generate the hash code for this QName.
      String toString()
      String representation of this QName.
      static QName valueOf(String qNameAsString)
      QName derived from parsing the formatted String.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • QName

        public QName(String namespaceURI,
             String localPart)

        QName constructor specifying the Namespace URI and local part.

        If the Namespace URI is null, it is set to XMLConstants.NULL_NS_URI. This value represents no explicitly defined Namespace as defined by the Namespaces in XML specification. This action preserves compatible behavior with QName 1.0. Explicitly providing the XMLConstants.NULL_NS_URI value is the preferred coding style.

        If the local part is null an IllegalArgumentException is thrown. A local part of "" is allowed to preserve compatible behavior with QName 1.0.

        When using this constructor, the prefix is set to XMLConstants.DEFAULT_NS_PREFIX.

        The Namespace URI is not validated as a URI reference. The local part is not validated as a NCName as specified in Namespaces in XML.

        Parameters:
        namespaceURI - Namespace URI of the QName
        localPart - local part of the QName
        Throws:
        IllegalArgumentException - When localPart is null
        See Also:
        QName(String namespaceURI, String localPart, String prefix)

      • QName

        public QName(String namespaceURI,
             String localPart,
             String prefix)

        QName constructor specifying the Namespace URI, local part and prefix.

        If the Namespace URI is null, it is set to XMLConstants.NULL_NS_URI. This value represents no explicitly defined Namespace as defined by the Namespaces in XML specification. This action preserves compatible behavior with QName 1.0. Explicitly providing the XMLConstants.NULL_NS_URI value is the preferred coding style.

        If the local part is null an IllegalArgumentException is thrown. A local part of "" is allowed to preserve compatible behavior with QName 1.0.

        If the prefix is null, an IllegalArgumentException is thrown. Use XMLConstants.DEFAULT_NS_PREFIX to explicitly indicate that no prefix is present or the prefix is not relevant.

        The Namespace URI is not validated as a URI reference. The local part and prefix are not validated as a NCName as specified in Namespaces in XML.

        Parameters:
        namespaceURI - Namespace URI of the QName
        localPart - local part of the QName
        prefix - prefix of the QName
        Throws:
        IllegalArgumentException - When localPart or prefix is null

      • QName

        public QName(String localPart)

        QName constructor specifying the local part.

        If the local part is null an IllegalArgumentException is thrown. A local part of "" is allowed to preserve compatible behavior with QName 1.0.

        When using this constructor, the Namespace URI is set to XMLConstants.NULL_NS_URI and the prefix is set to XMLConstants.DEFAULT_NS_PREFIX.

        In an XML context, all Element and Attribute names exist in the context of a Namespace. Making this explicit during the construction of a QName helps prevent hard to diagnosis XML validity errors. The constructors QName(String namespaceURI, String localPart) and QName(String namespaceURI, String localPart, String prefix) are preferred.

        The local part is not validated as a NCName as specified in Namespaces in XML.

        Parameters:
        localPart - local part of the QName
        Throws:
        IllegalArgumentException - When localPart is null
        See Also:
        QName(String namespaceURI, String localPart), QName(String namespaceURI, String localPart, String prefix)

    • Method Detail

      • getNamespaceURI

        public String getNamespaceURI()

        Get the Namespace URI of this QName.

        Returns:
        Namespace URI of this QName

      • getLocalPart

        public String getLocalPart()

        Get the local part of this QName.

        Returns:
        local part of this QName

      • getPrefix

        public String getPrefix()

        Get the prefix of this QName.

        The prefix assigned to a QName might NOT be valid in a different context. For example, a QName may be assigned a prefix in the context of parsing a document but that prefix may be invalid in the context of a different document.

        Returns:
        prefix of this QName

      • equals

        public final boolean equals(Object objectToTest)

        Test this QName for equality with another Object.

        If the Object to be tested is not a QName or is null, then this method returns false.

        Two QNames are considered equal if and only if both the Namespace URI and local part are equal. This method uses String.equals() to check equality of the Namespace URI and local part. The prefix is NOT used to determine equality.

        This method satisfies the general contract of Object.equals(Object)

        Overrides:
        equals in class Object
        Parameters:
        objectToTest - the Object to test for equality with this QName
        Returns:
        true if the given Object is equal to this QName else false
        See Also:
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()

        Generate the hash code for this QName.

        The hash code is calculated using both the Namespace URI and the local part of the QName. The prefix is NOT used to calculate the hash code.

        This method satisfies the general contract of Object.hashCode().

        Overrides:
        hashCode in class Object
        Returns:
        hash code for this QName Object
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()

        String representation of this QName.

        The commonly accepted way of representing a QName as a String was defined by James Clark. Although this is not a standard specification, it is in common use, e.g. Transformer.setParameter(String name, Object value). This implementation represents a QName as: "{" + Namespace URI + "}" + local part. If the Namespace URI .equals(XMLConstants.NULL_NS_URI), only the local part is returned. An appropriate use of this method is for debugging or logging for human consumption.

        Note the prefix value is NOT returned as part of the String representation.

        This method satisfies the general contract of Object.toString().

        Overrides:
        toString in class Object
        Returns:
        String representation of this QName

      • valueOf

        public static QName valueOf(String qNameAsString)

        QName derived from parsing the formatted String.

        If the String is null or does not conform to QName.toString() formatting, an IllegalArgumentException is thrown.

        The String MUST be in the form returned by QName.toString().

        The commonly accepted way of representing a QName as a String was defined by James Clark. Although this is not a standard specification, it is in common use, e.g. Transformer.setParameter(String name, Object value). This implementation parses a String formatted as: "{" + Namespace URI + "}" + local part. If the Namespace URI .equals(XMLConstants.NULL_NS_URI), only the local part should be provided.

        The prefix value CANNOT be represented in the String and will be set to XMLConstants.DEFAULT_NS_PREFIX.

        This method does not do full validation of the resulting QName.

        The Namespace URI is not validated as a URI reference. The local part is not validated as a NCName as specified in Namespaces in XML.

        Parameters:
        qNameAsString - String representation of the QName
        Returns:
        QName corresponding to the given String
        Throws:
        IllegalArgumentException - When qNameAsString is null or malformed
        See Also:
        QName.toString()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.namespace.NamespaceContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.namespace.NamespaceContext

  • Packages that use NamespaceContext
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of NamespaceContext in javax.xml.bind

      Methods in javax.xml.bind with parameters of type NamespaceContext
      Modifier and Type Method and Description
      QName DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      static QName DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      String DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String DatatypeConverter.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.

    • Uses of NamespaceContext in javax.xml.stream

      Methods in javax.xml.stream that return NamespaceContext
      Modifier and Type Method and Description
      NamespaceContext XMLStreamReader.getNamespaceContext()
      Returns a read only namespace context for the current position.
      NamespaceContext XMLEventWriter.getNamespaceContext()
      Returns the current namespace context.
      NamespaceContext XMLStreamWriter.getNamespaceContext()
      Returns the current namespace context.
      Methods in javax.xml.stream with parameters of type NamespaceContext
      Modifier and Type Method and Description
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
      Create a new StartElement.
      void XMLEventWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void XMLStreamWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.

    • Uses of NamespaceContext in javax.xml.stream.events

      Methods in javax.xml.stream.events that return NamespaceContext
      Modifier and Type Method and Description
      NamespaceContext StartElement.getNamespaceContext()
      Gets a read-only namespace context.

    • Uses of NamespaceContext in javax.xml.stream.util

      Methods in javax.xml.stream.util that return NamespaceContext
      Modifier and Type | Method and Description
      NamespaceContext | StreamReaderDelegate.getNamespaceContext()

    • Uses of NamespaceContext in javax.xml.xpath

      Methods in javax.xml.xpath that return NamespaceContext
      Modifier and Type Method and Description
      NamespaceContext XPath.getNamespaceContext()
      Return the current namespace context.
      Methods in javax.xml.xpath with parameters of type NamespaceContext
      Modifier and Type Method and Description
      void XPath.setNamespaceContext(NamespaceContext nsContext)
      Establish a namespace context.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.namespace.QName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.namespace.QName

  • Packages that use QName
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.datatype
    XML/Java Type Mappings.
    javax.xml.namespace
    XML Namespace processing.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of QName in javax.xml.bind

      Fields in javax.xml.bind declared as QName
      Modifier and Type Field and Description
      protected QName JAXBElement.name
      xml element tag name
      Methods in javax.xml.bind that return QName
      Modifier and Type Method and Description
      abstract QName JAXBIntrospector.getElementName(Object jaxbElement)
      Get xml element qname for jaxbElement.
      QName JAXBElement.getName()
      Returns the xml element tag name.
      QName DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      static QName DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      Methods in javax.xml.bind with parameters of type QName
      Modifier and Type Method and Description
      String DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String DatatypeConverter.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      Constructors in javax.xml.bind with parameters of type QName
      Constructor and Description
      JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
      Construct an xml element instance.
      JAXBElement(QName name, Class<T> declaredType, T value)
      Construct an xml element instance.

    • Uses of QName in javax.xml.datatype

      Fields in javax.xml.datatype declared as QName
      Modifier and Type Field and Description
      static QName DatatypeConstants.DATE
      Fully qualified name for W3C XML Schema 1.0 datatype date.
      static QName DatatypeConstants.DATETIME
      Fully qualified name for W3C XML Schema 1.0 datatype dateTime.
      static QName DatatypeConstants.DURATION
      Fully qualified name for W3C XML Schema datatype duration.
      static QName DatatypeConstants.DURATION_DAYTIME
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.
      static QName DatatypeConstants.DURATION_YEARMONTH
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.
      static QName DatatypeConstants.GDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gDay.
      static QName DatatypeConstants.GMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gMonth.
      static QName DatatypeConstants.GMONTHDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.
      static QName DatatypeConstants.GYEAR
      Fully qualified name for W3C XML Schema 1.0 datatype gYear.
      static QName DatatypeConstants.GYEARMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.
      static QName DatatypeConstants.TIME
      Fully qualified name for W3C XML Schema 1.0 datatype time.
      Methods in javax.xml.datatype that return QName
      Modifier and Type Method and Description
      QName Duration.getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.
      abstract QName XMLGregorianCalendar.getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.

    • Uses of QName in javax.xml.namespace

      Methods in javax.xml.namespace that return QName
      Modifier and Type Method and Description
      static QName QName.valueOf(String qNameAsString)
      QName derived from parsing the formatted String.

    • Uses of QName in javax.xml.soap

      Fields in javax.xml.soap declared as QName
      Modifier and Type Field and Description
      static QName SOAPConstants.SOAP_DATAENCODINGUNKNOWN_FAULT
      SOAP 1.2 DataEncodingUnknown Fault
      static QName SOAPConstants.SOAP_MUSTUNDERSTAND_FAULT
      SOAP 1.2 MustUnderstand Fault
      static QName SOAPConstants.SOAP_RECEIVER_FAULT
      SOAP 1.2 Receiver Fault
      static QName SOAPConstants.SOAP_SENDER_FAULT
      SOAP 1.2 Sender Fault
      static QName SOAPConstants.SOAP_VERSIONMISMATCH_FAULT
      SOAP 1.2 VersionMismatch Fault
      Methods in javax.xml.soap that return QName
      Modifier and Type Method and Description
      QName SOAPElement.createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      QName SOAPElement.getElementQName()
      Returns the qname of this SOAPElement object.
      QName SOAPFault.getFaultCodeAsQName()
      Gets the fault code for this SOAPFault object as a QName object.
      Methods in javax.xml.soap with parameters of type QName
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      void SOAPFault.appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      String SOAPElement.getAttributeValue(QName qname)
      Returns the value of the attribute with the specified qname.
      Iterator SOAPElement.getChildElements(QName qname)
      Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
      boolean SOAPElement.removeAttribute(QName qname)
      Removes the attribute with the specified qname.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void SOAPFault.setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.

    • Uses of QName in javax.xml.stream

      Methods in javax.xml.stream that return QName
      Modifier and Type Method and Description
      QName XMLStreamReader.getAttributeName(int index)
      Returns the qname of the attribute at the provided index
      QName XMLStreamReader.getName()
      Returns a QName for the current START_ELEMENT or END_ELEMENT event
      Methods in javax.xml.stream with parameters of type QName
      Modifier and Type Method and Description
      abstract Attribute XMLEventFactory.createAttribute(QName name, String value)
      Create a new Attribute
      abstract EndElement XMLEventFactory.createEndElement(QName name, Iterator namespaces)
      Create a new EndElement
      abstract StartElement XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces)
      Create a new StartElement.

    • Uses of QName in javax.xml.stream.events

      Methods in javax.xml.stream.events that return QName
      Modifier and Type Method and Description
      QName Attribute.getName()
      Returns the QName for this attribute
      QName EndElement.getName()
      Get the name of this event
      QName StartElement.getName()
      Get the name of this event
      QName XMLEvent.getSchemaType()
      This method is provided for implementations to provide optional type information about the associated event.
      Methods in javax.xml.stream.events with parameters of type QName
      Modifier and Type Method and Description
      Attribute StartElement.getAttributeByName(QName name)
      Returns the attribute referred to by this name

    • Uses of QName in javax.xml.stream.util

      Methods in javax.xml.stream.util that return QName
      Modifier and Type | Method and Description
      QName | StreamReaderDelegate.getAttributeName(int index)
      QName | StreamReaderDelegate.getName()

    • Uses of QName in javax.xml.ws

      Methods in javax.xml.ws that return QName
      Modifier and Type Method and Description
      QName Service.getServiceName()
      Gets the name of this service.
      Methods in javax.xml.ws that return types with arguments of type QName
      Modifier and Type Method and Description
      Iterator<QName> Service.getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      Methods in javax.xml.ws with parameters of type QName
      Modifier and Type Method and Description
      void Service.addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      static Service Service.create(QName serviceName)
      Creates a Service instance.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(QName portName, Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T Service.getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Constructors in javax.xml.ws with parameters of type QName
      Constructor and Description
      Service(URL wsdlDocumentLocation, QName serviceName)
      Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Uses of QName in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return QName
      Modifier and Type Method and Description
      QName PortInfo.getPortName()
      Gets the qualified name of the WSDL port being accessed.
      QName PortInfo.getServiceName()
      Gets the qualified name of the WSDL service name containing the port being accessed.

    • Uses of QName in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap that return types with arguments of type QName
      Modifier and Type Method and Description
      Set<QName> SOAPHandler.getHeaders()
      Gets the header blocks that can be processed by this Handler instance.
      Methods in javax.xml.ws.handler.soap with parameters of type QName
      Modifier and Type Method and Description
      Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.

    • Uses of QName in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return QName
      Modifier and Type Method and Description
      abstract QName ServiceDelegate.getServiceName()
      Gets the name of this service.
      Methods in javax.xml.ws.spi that return types with arguments of type QName
      Modifier and Type Method and Description
      abstract Iterator<QName> ServiceDelegate.getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      Methods in javax.xml.ws.spi with parameters of type QName
      Modifier and Type Method and Description
      abstract void ServiceDelegate.addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      abstract <T> T ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Method parameters in javax.xml.ws.spi with type arguments of type QName
      Modifier and Type Method and Description
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of QName in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type QName
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.

    • Uses of QName in javax.xml.xpath

      Fields in javax.xml.xpath declared as QName
      Modifier and Type Field and Description
      static QName XPathConstants.BOOLEAN
      The XPath 1.0 boolean data type.
      static QName XPathConstants.NODE
      The XPath 1.0 NodeSet data type.
      static QName XPathConstants.NODESET
      The XPath 1.0 NodeSet data type.
      static QName XPathConstants.NUMBER
      The XPath 1.0 number data type.
      static QName XPathConstants.STRING
      The XPath 1.0 string data type.
      Methods in javax.xml.xpath with parameters of type QName
      Modifier and Type Method and Description
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      Object XPathExpression.evaluate(Object item, QName returnType)
      Evaluate the compiled XPath expression in the specified context and return the result as the specified type.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
      Object XPath.evaluate(String expression, Object item, QName returnType)
      Evaluate an XPath expression in the specified context and return the result as the specified type.
      XPathFunction XPathFunctionResolver.resolveFunction(QName functionName, int arity)
      Find a function in the set of available functions.
      Object XPathVariableResolver.resolveVariable(QName variableName)
      Find a variable in the set of available variables.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.parsers (Java Platform SE 8 )

compact2 - javax.xml.parsers

Classes

  • DocumentBuilder
  • DocumentBuilderFactory
  • SAXParser
  • SAXParserFactory

Exceptions

  • ParserConfigurationException

Errors

  • FactoryConfigurationError


javax.xml.parsers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.parsers

Provides classes allowing the processing of XML documents.

See: Description

  • Class Summary
    Class Description
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
    DocumentBuilderFactory
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    SAXParser
    Defines the API that wraps an XMLReader implementation class.
    SAXParserFactory
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
  • Exception Summary
    Exception Description
    ParserConfigurationException
    Indicates a serious configuration error.
  • Error Summary
    Error Description
    FactoryConfigurationError
    Thrown when a problem with configuration with the Parser Factories exists.

Package javax.xml.parsers Description

Provides classes allowing the processing of XML documents. Two types of plugable parsers are supported:

  • SAX (Simple API for XML)
  • DOM (Document Object Model)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.parsers (Java Platform SE 8 )

compact3 - javax.xml.parsers

Classes

  • DocumentBuilder
  • DocumentBuilderFactory
  • SAXParser
  • SAXParserFactory

Exceptions

  • ParserConfigurationException

Errors

  • FactoryConfigurationError


javax.xml.parsers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.parsers

Provides classes allowing the processing of XML documents.

See: Description

  • Class Summary
    Class Description
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
    DocumentBuilderFactory
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    SAXParser
    Defines the API that wraps an XMLReader implementation class.
    SAXParserFactory
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
  • Exception Summary
    Exception Description
    ParserConfigurationException
    Indicates a serious configuration error.
  • Error Summary
    Error Description
    FactoryConfigurationError
    Thrown when a problem with configuration with the Parser Factories exists.

Package javax.xml.parsers Description

Provides classes allowing the processing of XML documents. Two types of plugable parsers are supported:

  • SAX (Simple API for XML)
  • DOM (Document Object Model)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentBuilder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.parsers

Class DocumentBuilder

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilder

  • public abstract class DocumentBuilder
extends Object
    Defines the API to obtain DOM Document instances from an XML document. Using this class, an application programmer can obtain a Document from XML.

    An instance of this class can be obtained from the DocumentBuilderFactory.newDocumentBuilder() method. Once an instance of this class is obtained, XML can be parsed from a variety of input sources. These input sources are InputStreams, Files, URLs, and SAX InputSources.

    Note that this class reuses several classes from the SAX API. This does not require that the implementor of the underlying DOM implementation use a SAX parser to parse XML document into a Document. It merely requires that the implementation communicate with the application using these existing APIs.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DocumentBuilder()
      Protected constructor

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract DOMImplementation getDOMImplementation()
      Obtain an instance of a DOMImplementation object.
      Schema getSchema()
      Get a reference to the the Schema being used by the XML processor.
      abstract boolean isNamespaceAware()
      Indicates whether or not this parser is configured to understand namespaces.
      abstract boolean isValidating()
      Indicates whether or not this parser is configured to validate XML documents.
      boolean isXIncludeAware()
      Get the XInclude processing mode for this parser.
      abstract Document newDocument()
      Obtain a new instance of a DOM Document object to build a DOM tree with.
      Document parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      abstract Document parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      Document parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.
      void reset()
      Reset this DocumentBuilder to its original configuration.
      abstract void setEntityResolver(EntityResolver er)
      Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.
      abstract void setErrorHandler(ErrorHandler eh)
      Specify the ErrorHandler to be used by the parser.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DocumentBuilder

        protected DocumentBuilder()
        Protected constructor

    • Method Detail

      • reset

        public void reset()

        Reset this DocumentBuilder to its original configuration.

        DocumentBuilder is reset to the same state as when it was created with DocumentBuilderFactory.newDocumentBuilder(). reset() is designed to allow the reuse of existing DocumentBuilders thus saving resources associated with the creation of new DocumentBuilders.

        The reset DocumentBuilder is not guaranteed to have the same EntityResolver or ErrorHandler Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal EntityResolver and ErrorHandler.

        Throws:
        UnsupportedOperationException - When implementation does not override this method.
        Since:
        1.5

      • parse

        public Document parse(InputStream is)
               throws SAXException,
                      IOException
        Parse the content of the given InputStream as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the InputStream is null.
        Parameters:
        is - InputStream containing the content to be parsed.
        Returns:
        Document result of parsing the InputStream
        Throws:
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When is is null
        See Also:
        DocumentHandler

      • parse

        public Document parse(InputStream is,
                      String systemId)
               throws SAXException,
                      IOException
        Parse the content of the given InputStream as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the InputStream is null.
        Parameters:
        is - InputStream containing the content to be parsed.
        systemId - Provide a base for resolving relative URIs.
        Returns:
        A new DOM Document object.
        Throws:
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When is is null
        See Also:
        DocumentHandler

      • parse

        public Document parse(String uri)
               throws SAXException,
                      IOException
        Parse the content of the given URI as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the URI is null null.
        Parameters:
        uri - The location of the content to be parsed.
        Returns:
        A new DOM Document object.
        Throws:
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When uri is null
        See Also:
        DocumentHandler

      • parse

        public Document parse(File f)
               throws SAXException,
                      IOException
        Parse the content of the given file as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the File is null null.
        Parameters:
        f - The file containing the XML to parse.
        Returns:
        A new DOM Document object.
        Throws:
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When f is null
        See Also:
        DocumentHandler

      • parse

        public abstract Document parse(InputSource is)
                        throws SAXException,
                               IOException
        Parse the content of the given input source as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the InputSource is null null.
        Parameters:
        is - InputSource containing the content to be parsed.
        Returns:
        A new DOM Document object.
        Throws:
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When is is null
        See Also:
        DocumentHandler

      • isNamespaceAware

        public abstract boolean isNamespaceAware()
        Indicates whether or not this parser is configured to understand namespaces.
        Returns:
        true if this parser is configured to understand namespaces; false otherwise.

      • isValidating

        public abstract boolean isValidating()
        Indicates whether or not this parser is configured to validate XML documents.
        Returns:
        true if this parser is configured to validate XML documents; false otherwise.

      • setEntityResolver

        public abstract void setEntityResolver(EntityResolver er)
        Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed. Setting this to null will result in the underlying implementation using it's own default implementation and behavior.
        Parameters:
        er - The EntityResolver to be used to resolve entities present in the XML document to be parsed.

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler eh)
        Specify the ErrorHandler to be used by the parser. Setting this to null will result in the underlying implementation using it's own default implementation and behavior.
        Parameters:
        eh - The ErrorHandler to be used by the parser.

      • newDocument

        public abstract Document newDocument()
        Obtain a new instance of a DOM Document object to build a DOM tree with.
        Returns:
        A new instance of a DOM Document object.

      • getDOMImplementation

        public abstract DOMImplementation getDOMImplementation()
        Obtain an instance of a DOMImplementation object.
        Returns:
        A new instance of a DOMImplementation.

      • getSchema

        public Schema getSchema()

        Get a reference to the the Schema being used by the XML processor.

        If no schema is being used, null is returned.

        Returns:
        Schema being used or null if none in use
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get the XInclude processing mode for this parser.

        Returns:
        the return value of the DocumentBuilderFactory.isXIncludeAware() when this parser was created from factory.
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5
        See Also:
        DocumentBuilderFactory.setXIncludeAware(boolean)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentBuilderFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.parsers

Class DocumentBuilderFactory

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilderFactory

  • public abstract class DocumentBuilderFactory
extends Object
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    Version:
    $Revision: 1.9 $, $Date: 2010/05/25 16:19:44 $

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DocumentBuilderFactory()
      Protected constructor to prevent instantiation.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Object getAttribute(String name)
      Allows the user to retrieve specific attributes on the underlying implementation.
      abstract boolean getFeature(String name)
      Get the state of the named feature.
      Schema getSchema()
      Gets the Schema object specified through the setSchema(Schema schema) method.
      boolean isCoalescing()
      Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
      boolean isExpandEntityReferences()
      Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
      boolean isIgnoringComments()
      Indicates whether or not the factory is configured to produce parsers which ignores comments.
      boolean isIgnoringElementContentWhitespace()
      Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
      boolean isNamespaceAware()
      Indicates whether or not the factory is configured to produce parsers which are namespace aware.
      boolean isValidating()
      Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
      boolean isXIncludeAware()
      Get state of XInclude processing.
      abstract DocumentBuilder newDocumentBuilder()
      Creates a new instance of a DocumentBuilder using the currently configured parameters.
      static DocumentBuilderFactory newInstance()
      Obtain a new instance of a DocumentBuilderFactory.
      static DocumentBuilderFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DocumentBuilderFactory from class name.
      abstract void setAttribute(String name, Object value)
      Allows the user to set specific attributes on the underlying implementation.
      void setCoalescing(boolean coalescing)
      Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node.
      void setExpandEntityReferences(boolean expandEntityRef)
      Specifies that the parser produced by this code will expand entity reference nodes.
      abstract void setFeature(String name, boolean value)
      Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.
      void setIgnoringComments(boolean ignoreComments)
      Specifies that the parser produced by this code will ignore comments.
      void setIgnoringElementContentWhitespace(boolean whitespace)
      Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10).
      void setNamespaceAware(boolean awareness)
      Specifies that the parser produced by this code will provide support for XML namespaces.
      void setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.
      void setValidating(boolean validating)
      Specifies that the parser produced by this code will validate documents as they are parsed.
      void setXIncludeAware(boolean state)
      Set state of XInclude processing.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DocumentBuilderFactory

        protected DocumentBuilderFactory()

        Protected constructor to prevent instantiation. Use newInstance().

    • Method Detail

      • newInstance

        public static DocumentBuilderFactory newInstance()
        Obtain a new instance of a DocumentBuilderFactory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the DocumentBuilderFactory implementation class to load:
        • Use the javax.xml.parsers.DocumentBuilderFactory system property.
        • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. The jaxp.properties file is read only once by the JAXP implementation and it's values are then cached for future use. If the file does not exist when the first attempt is made to read from it, no further attempts are made to check for its existence. It is not possible to change the value of any property in jaxp.properties after it has been read for the first time.
        • Uses the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, the system-default implementation is returned.
        Once an application has obtained a reference to a DocumentBuilderFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems loading DocumentBuilders, try:

         java -Djaxp.debug=1 YourProgram ....
        Returns:
        New instance of a DocumentBuilderFactory
        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • newInstance

        public static DocumentBuilderFactory newInstance(String factoryClassName,
                                                 ClassLoader classLoader)

        Obtain a new instance of a DocumentBuilderFactory from class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a DocumentBuilderFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        Parameters:
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.parsers.DocumentBuilderFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        Returns:
        New instance of a DocumentBuilderFactory
        Throws:
        FactoryConfigurationError - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        Since:
        1.6
        See Also:
        newInstance()

      • newDocumentBuilder

        public abstract DocumentBuilder newDocumentBuilder()
                                            throws ParserConfigurationException
        Creates a new instance of a DocumentBuilder using the currently configured parameters.
        Returns:
        A new instance of a DocumentBuilder.
        Throws:
        ParserConfigurationException - if a DocumentBuilder cannot be created which satisfies the configuration requested.

      • setNamespaceAware

        public void setNamespaceAware(boolean awareness)
        Specifies that the parser produced by this code will provide support for XML namespaces. By default the value of this is set to false
        Parameters:
        awareness - true if the parser produced will provide support for XML namespaces; false otherwise.

      • setValidating

        public void setValidating(boolean validating)
        Specifies that the parser produced by this code will validate documents as they are parsed. By default the value of this is set to false.

        Note that "the validation" here means a validating parser as defined in the XML recommendation. In other words, it essentially just controls the DTD validation. (except the legacy two properties defined in JAXP 1.2.)

        To use modern schema languages such as W3C XML Schema or RELAX NG instead of DTD, you can configure your parser to be a non-validating parser by leaving the setValidating(boolean) method false, then use the setSchema(Schema) method to associate a schema to a parser.

        Parameters:
        validating - true if the parser produced will validate documents as they are parsed; false otherwise.

      • setIgnoringElementContentWhitespace

        public void setIgnoringElementContentWhitespace(boolean whitespace)
        Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10). Note that only whitespace which is directly contained within element content that has an element only content model (see XML Rec 3.2.1) will be eliminated. Due to reliance on the content model this setting requires the parser to be in validating mode. By default the value of this is set to false.
        Parameters:
        whitespace - true if the parser created must eliminate whitespace in the element content when parsing XML documents; false otherwise.

      • setExpandEntityReferences

        public void setExpandEntityReferences(boolean expandEntityRef)
        Specifies that the parser produced by this code will expand entity reference nodes. By default the value of this is set to true
        Parameters:
        expandEntityRef - true if the parser produced will expand entity reference nodes; false otherwise.

      • setIgnoringComments

        public void setIgnoringComments(boolean ignoreComments)

        Specifies that the parser produced by this code will ignore comments. By default the value of this is set to false .

        Parameters:
        ignoreComments - boolean value to ignore comments during processing

      • setCoalescing

        public void setCoalescing(boolean coalescing)
        Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node. By default the value of this is set to false
        Parameters:
        coalescing - true if the parser produced will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node; false otherwise.

      • isNamespaceAware

        public boolean isNamespaceAware()
        Indicates whether or not the factory is configured to produce parsers which are namespace aware.
        Returns:
        true if the factory is configured to produce parsers which are namespace aware; false otherwise.

      • isValidating

        public boolean isValidating()
        Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
        Returns:
        true if the factory is configured to produce parsers which validate the XML content during parse; false otherwise.

      • isIgnoringElementContentWhitespace

        public boolean isIgnoringElementContentWhitespace()
        Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
        Returns:
        true if the factory is configured to produce parsers which ignore ignorable whitespace in element content; false otherwise.

      • isExpandEntityReferences

        public boolean isExpandEntityReferences()
        Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
        Returns:
        true if the factory is configured to produce parsers which expand entity reference nodes; false otherwise.

      • isIgnoringComments

        public boolean isIgnoringComments()
        Indicates whether or not the factory is configured to produce parsers which ignores comments.
        Returns:
        true if the factory is configured to produce parsers which ignores comments; false otherwise.

      • isCoalescing

        public boolean isCoalescing()
        Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
        Returns:
        true if the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node; false otherwise.

      • setAttribute

        public abstract void setAttribute(String name,
                                  Object value)
                           throws IllegalArgumentException
        Allows the user to set specific attributes on the underlying implementation.

        All implementations that implement JAXP 1.5 or newer are required to support the XMLConstants.ACCESS_EXTERNAL_DTD and XMLConstants.ACCESS_EXTERNAL_SCHEMA properties.

        • Setting the XMLConstants.ACCESS_EXTERNAL_DTD property restricts the access to external DTDs, external Entity References to the protocols specified by the property. If access is denied during parsing due to the restriction of this property, SAXException will be thrown by the parse methods defined by DocumentBuilder.

          Setting the XMLConstants.ACCESS_EXTERNAL_SCHEMA property restricts the access to external Schema set by the schemaLocation attribute to the protocols specified by the property. If access is denied during parsing due to the restriction of this property, SAXException will be thrown by the parse methods defined by DocumentBuilder.

        Parameters:
        name - The name of the attribute.
        value - The value of the attribute.
        Throws:
        IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

      • getAttribute

        public abstract Object getAttribute(String name)
                             throws IllegalArgumentException
        Allows the user to retrieve specific attributes on the underlying implementation.
        Parameters:
        name - The name of the attribute.
        Returns:
        value The value of the attribute.
        Throws:
        IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

      • setFeature

        public abstract void setFeature(String name,
                                boolean value)
                         throws ParserConfigurationException

        Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.

        Feature names are fully qualified URIs. Implementations may define their own features. A ParserConfigurationException is thrown if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support the feature. It is possible for a DocumentBuilderFactory to expose a feature value but be unable to change its state.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See DocumentBuilder.setErrorHandler(org.xml.sax.ErrorHandler errorHandler).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        Parameters:
        name - Feature name.
        value - Is feature state true or false.
        Throws:
        ParserConfigurationException - if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support this feature.
        NullPointerException - If the name parameter is null.

      • getFeature

        public abstract boolean getFeature(String name)
                            throws ParserConfigurationException

        Get the state of the named feature.

        Feature names are fully qualified URIs. Implementations may define their own features. An ParserConfigurationException is thrown if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support the feature. It is possible for an DocumentBuilderFactory to expose a feature value but be unable to change its state.

        Parameters:
        name - Feature name.
        Returns:
        State of the named feature.
        Throws:
        ParserConfigurationException - if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support this feature.

      • getSchema

        public Schema getSchema()
        Gets the Schema object specified through the setSchema(Schema schema) method.
        Returns:
        the Schema object that was last set through the setSchema(Schema) method, or null if the method was not invoked since a DocumentBuilderFactory is created.
        Throws:
        UnsupportedOperationException - When implementation does not override this method.
        Since:
        1.5

      • setSchema

        public void setSchema(Schema schema)

        Set the Schema to be used by parsers created from this factory.

        When a Schema is non-null, a parser will use a validator created from it to validate documents before it passes information down to the application.

        When errors are found by the validator, the parser is responsible to report them to the user-specified ErrorHandler (or if the error handler is not set, ignore them or throw them), just like any other errors found by the parser itself. In other words, if the user-specified ErrorHandler is set, it must receive those errors, and if not, they must be treated according to the implementation specific default error handling rules.

        A validator may modify the outcome of a parse (for example by adding default values that were missing in documents), and a parser is responsible to make sure that the application will receive modified DOM trees.

        Initialy, null is set as the Schema.

        This processing will take effect even if the isValidating() method returns false.

        It is an error to use the http://java.sun.com/xml/jaxp/properties/schemaSource property and/or the http://java.sun.com/xml/jaxp/properties/schemaLanguage property in conjunction with a Schema object. Such configuration will cause a ParserConfigurationException exception when the newDocumentBuilder() is invoked.

        Note for implmentors

        A parser must be able to work with any Schema implementation. However, parsers and schemas are allowed to use implementation-specific custom mechanisms as long as they yield the result described in the specification.

        Parameters:
        schema - Schema to use or null to remove a schema.
        Throws:
        UnsupportedOperationException - When implementation does not override this method.
        Since:
        1.5

      • setXIncludeAware

        public void setXIncludeAware(boolean state)

        Set state of XInclude processing.

        If XInclude markup is found in the document instance, should it be processed as specified in XML Inclusions (XInclude) Version 1.0.

        XInclude processing defaults to false.

        Parameters:
        state - Set XInclude processing to true or false
        Throws:
        UnsupportedOperationException - When implementation does not override this method.
        Since:
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get state of XInclude processing.

        Returns:
        current state of XInclude processing
        Throws:
        UnsupportedOperationException - When implementation does not override this method.
        Since:
        1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.parsers

Class FactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.parsers.FactoryConfigurationError
  • All Implemented Interfaces:
    Serializable

    public class FactoryConfigurationError
extends Error
    Thrown when a problem with configuration with the Parser Factories exists. This error will typically be thrown when the class of a parser factory specified in the system properties cannot be found or instantiated.
    Version:
    $Revision: 1.7 $, $Date: 2010-11-01 04:36:09 $
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FactoryConfigurationError()
      Create a new FactoryConfigurationError with no detail mesage.
      FactoryConfigurationError(Exception e)
      Create a new FactoryConfigurationError with a given Exception base cause of the error.
      FactoryConfigurationError(Exception e, String msg)
      Create a new FactoryConfigurationError with the given Exception base cause and detail message.
      FactoryConfigurationError(String msg)
      Create a new FactoryConfigurationError with the String specified as an error message.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      use the exception chaining mechanism of JDK1.4
      Exception getException()
      Return the actual exception (if any) that caused this exception to be raised.
      String getMessage()
      Return the message (if any) for this error .

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FactoryConfigurationError

        public FactoryConfigurationError()
        Create a new FactoryConfigurationError with no detail mesage.

      • FactoryConfigurationError

        public FactoryConfigurationError(String msg)
        Create a new FactoryConfigurationError with the String specified as an error message.
        Parameters:
        msg - The error message for the exception.

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e)
        Create a new FactoryConfigurationError with a given Exception base cause of the error.
        Parameters:
        e - The exception to be encapsulated in a FactoryConfigurationError.

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e,
                                 String msg)
        Create a new FactoryConfigurationError with the given Exception base cause and detail message.
        Parameters:
        e - The exception to be encapsulated in a FactoryConfigurationError
        msg - The detail message.

    • Method Detail

      • getMessage

        public String getMessage()
        Return the message (if any) for this error . If there is no message for the exception and there is an encapsulated exception then the message of that exception, if it exists will be returned. Else the name of the encapsulated exception will be returned.
        Overrides:
        getMessage in class Throwable
        Returns:
        The error message.

      • getException

        public Exception getException()
        Return the actual exception (if any) that caused this exception to be raised.
        Returns:
        The encapsulated exception, or null if there is none.

      • getCause

        public Throwable getCause()
        use the exception chaining mechanism of JDK1.4
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this throwable or null if the cause is nonexistent or unknown.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.parsers (Java Platform SE 8 )

javax.xml.parsers

Classes

  • DocumentBuilder
  • DocumentBuilderFactory
  • SAXParser
  • SAXParserFactory

Exceptions

  • ParserConfigurationException

Errors

  • FactoryConfigurationError


javax.xml.parsers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.parsers

Provides classes allowing the processing of XML documents.

See: Description

  • Class Summary
    Class Description
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
    DocumentBuilderFactory
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    SAXParser
    Defines the API that wraps an XMLReader implementation class.
    SAXParserFactory
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
  • Exception Summary
    Exception Description
    ParserConfigurationException
    Indicates a serious configuration error.
  • Error Summary
    Error Description
    FactoryConfigurationError
    Thrown when a problem with configuration with the Parser Factories exists.

Package javax.xml.parsers Description

Provides classes allowing the processing of XML documents. Two types of plugable parsers are supported:

  • SAX (Simple API for XML)
  • DOM (Document Object Model)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.parsers Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.parsers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilder
    • javax.xml.parsers.DocumentBuilderFactory
    • javax.xml.parsers.SAXParser
    • javax.xml.parsers.SAXParserFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.parsers.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.parsers.ParserConfigurationException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.parsers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.parsers

  • Packages that use javax.xml.parsers
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
  • Classes in javax.xml.parsers used by javax.xml.bind.annotation
    Class and Description
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
  • Classes in javax.xml.parsers used by javax.xml.parsers
    Class and Description
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
    DocumentBuilderFactory
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    ParserConfigurationException
    Indicates a serious configuration error.
    SAXParser
    Defines the API that wraps an XMLReader implementation class.
    SAXParserFactory
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParserConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.parsers

Class ParserConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.parsers.ParserConfigurationException
  • All Implemented Interfaces:
    Serializable

    public class ParserConfigurationException
extends Exception
    Indicates a serious configuration error.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ParserConfigurationException()
      Create a new ParserConfigurationException with no detail mesage.
      ParserConfigurationException(String msg)
      Create a new ParserConfigurationException with the String specified as an error message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ParserConfigurationException

        public ParserConfigurationException()
        Create a new ParserConfigurationException with no detail mesage.

      • ParserConfigurationException

        public ParserConfigurationException(String msg)
        Create a new ParserConfigurationException with the String specified as an error message.
        Parameters:
        msg - The error message for the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXParser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.parsers

Class SAXParser

  • java.lang.Object
    • javax.xml.parsers.SAXParser

  • public abstract class SAXParser
extends Object
    Defines the API that wraps an XMLReader implementation class. In JAXP 1.0, this class wrapped the Parser interface, however this interface was replaced by the XMLReader. For ease of transition, this class continues to support the same name and interface as well as supporting new methods. An instance of this class can be obtained from the SAXParserFactory.newSAXParser() method. Once an instance of this class is obtained, XML can be parsed from a variety of input sources. These input sources are InputStreams, Files, URLs, and SAX InputSources.

    This static method creates a new factory instance based on a system property setting or uses the platform default if no property has been defined.

    The system property that controls which Factory implementation to create is named "javax.xml.parsers.SAXParserFactory". This property names a class that is a concrete subclass of this abstract class. If no property is defined, a platform default will be used.

    As the content is parsed by the underlying parser, methods of the given HandlerBase or the DefaultHandler are called.

    Implementors of this class which wrap an underlaying implementation can consider using the ParserAdapter class to initially adapt their SAX1 implementation to work under this revised class.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SAXParser()
      Protected constructor to prevent instaniation.

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Parser getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.
      abstract Object getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      Schema getSchema()
      Get a reference to the the Schema being used by the XML processor.
      abstract XMLReader getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.
      abstract boolean isNamespaceAware()
      Indicates whether or not this parser is configured to understand namespaces.
      abstract boolean isValidating()
      Indicates whether or not this parser is configured to validate XML documents.
      boolean isXIncludeAware()
      Get the XInclude processing mode for this parser.
      void parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      void parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      void parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
      void parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
      void reset()
      Reset this SAXParser to its original configuration.
      abstract void setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SAXParser

        protected SAXParser()

        Protected constructor to prevent instaniation. Use SAXParserFactory.newSAXParser().

    • Method Detail

      • reset

        public void reset()

        Reset this SAXParser to its original configuration.

        SAXParser is reset to the same state as when it was created with SAXParserFactory.newSAXParser(). reset() is designed to allow the reuse of existing SAXParsers thus saving resources associated with the creation of new SAXParsers.

        The reset SAXParser is not guaranteed to have the same Schema Object, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal Schema.

        Throws:
        UnsupportedOperationException - When Implementations do not override this method
        Since:
        1.5

      • parse

        public void parse(InputStream is,
                  HandlerBase hb)
           throws SAXException,
                  IOException

        Parse the content of the given InputStream instance as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0.

        Parameters:
        is - InputStream containing the content to be parsed.
        hb - The SAX HandlerBase to use.
        Throws:
        IllegalArgumentException - If the given InputStream is null.
        SAXException - If parse produces a SAX error.
        IOException - If an IO error occurs interacting with the InputStream.
        See Also:
        DocumentHandler

      • parse

        public void parse(InputStream is,
                  HandlerBase hb,
                  String systemId)
           throws SAXException,
                  IOException

        Parse the content of the given InputStream instance as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0.

        Parameters:
        is - InputStream containing the content to be parsed.
        hb - The SAX HandlerBase to use.
        systemId - The systemId which is needed for resolving relative URIs.
        Throws:
        IllegalArgumentException - If the given InputStream is null.
        IOException - If any IO error occurs interacting with the InputStream.
        SAXException - If any SAX errors occur during processing.
        See Also:
        version of this method instead.

      • parse

        public void parse(InputStream is,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
        Parameters:
        is - InputStream containing the content to be parsed.
        dh - The SAX DefaultHandler to use.
        Throws:
        IllegalArgumentException - If the given InputStream is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • parse

        public void parse(InputStream is,
                  DefaultHandler dh,
                  String systemId)
           throws SAXException,
                  IOException
        Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
        Parameters:
        is - InputStream containing the content to be parsed.
        dh - The SAX DefaultHandler to use.
        systemId - The systemId which is needed for resolving relative URIs.
        Throws:
        IllegalArgumentException - If the given InputStream is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        version of this method instead.

      • parse

        public void parse(String uri,
                  HandlerBase hb)
           throws SAXException,
                  IOException
        Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0
        Parameters:
        uri - The location of the content to be parsed.
        hb - The SAX HandlerBase to use.
        Throws:
        IllegalArgumentException - If the uri is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • parse

        public void parse(String uri,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
        Parameters:
        uri - The location of the content to be parsed.
        dh - The SAX DefaultHandler to use.
        Throws:
        IllegalArgumentException - If the uri is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • parse

        public void parse(File f,
                  HandlerBase hb)
           throws SAXException,
                  IOException
        Parse the content of the file specified as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0
        Parameters:
        f - The file containing the XML to parse
        hb - The SAX HandlerBase to use.
        Throws:
        IllegalArgumentException - If the File object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • parse

        public void parse(File f,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content of the file specified as XML using the specified DefaultHandler.
        Parameters:
        f - The file containing the XML to parse
        dh - The SAX DefaultHandler to use.
        Throws:
        IllegalArgumentException - If the File object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • parse

        public void parse(InputSource is,
                  HandlerBase hb)
           throws SAXException,
                  IOException
        Parse the content given InputSource as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0
        Parameters:
        is - The InputSource containing the content to be parsed.
        hb - The SAX HandlerBase to use.
        Throws:
        IllegalArgumentException - If the InputSource object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • parse

        public void parse(InputSource is,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content given InputSource as XML using the specified DefaultHandler.
        Parameters:
        is - The InputSource containing the content to be parsed.
        dh - The SAX DefaultHandler to use.
        Throws:
        IllegalArgumentException - If the InputSource object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        See Also:
        DocumentHandler

      • getParser

        public abstract Parser getParser()
                          throws SAXException
        Returns the SAX parser that is encapsultated by the implementation of this class.
        Returns:
        The SAX parser that is encapsultated by the implementation of this class.
        Throws:
        SAXException - If any SAX errors occur during processing.

      • getXMLReader

        public abstract XMLReader getXMLReader()
                                throws SAXException
        Returns the XMLReader that is encapsulated by the implementation of this class.
        Returns:
        The XMLReader that is encapsulated by the implementation of this class.
        Throws:
        SAXException - If any SAX errors occur during processing.

      • isNamespaceAware

        public abstract boolean isNamespaceAware()
        Indicates whether or not this parser is configured to understand namespaces.
        Returns:
        true if this parser is configured to understand namespaces; false otherwise.

      • isValidating

        public abstract boolean isValidating()
        Indicates whether or not this parser is configured to validate XML documents.
        Returns:
        true if this parser is configured to validate XML documents; false otherwise.

      • setProperty

        public abstract void setProperty(String name,
                                 Object value)
                          throws SAXNotRecognizedException,
                                 SAXNotSupportedException

        Sets the particular property in the underlying implementation of XMLReader. A list of the core features and properties can be found at http://sax.sourceforge.net/?selected=get-set.

        All implementations that implement JAXP 1.5 or newer are required to support the XMLConstants.ACCESS_EXTERNAL_DTD and XMLConstants.ACCESS_EXTERNAL_SCHEMA properties.

        • Setting the XMLConstants.ACCESS_EXTERNAL_DTD property restricts the access to external DTDs, external Entity References to the protocols specified by the property. If access is denied during parsing due to the restriction of this property, SAXException will be thrown by the parse methods defined by SAXParser.

          Setting the XMLConstants.ACCESS_EXTERNAL_SCHEMA property restricts the access to external Schema set by the schemaLocation attribute to the protocols specified by the property. If access is denied during parsing due to the restriction of this property, SAXException will be thrown by the parse methods defined by the SAXParser.

        Parameters:
        name - The name of the property to be set.
        value - The value of the property to be set.
        Throws:
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        See Also:
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • getProperty

        public abstract Object getProperty(String name)
                            throws SAXNotRecognizedException,
                                   SAXNotSupportedException

        Returns the particular property requested for in the underlying implementation of XMLReader.

        Parameters:
        name - The name of the property to be retrieved.
        Returns:
        Value of the requested property.
        Throws:
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        See Also:
        XMLReader.getProperty(java.lang.String)

      • getSchema

        public Schema getSchema()

        Get a reference to the the Schema being used by the XML processor.

        If no schema is being used, null is returned.

        Returns:
        Schema being used or null if none in use
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get the XInclude processing mode for this parser.

        Returns:
        the return value of the SAXParserFactory.isXIncludeAware() when this parser was created from factory.
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5
        See Also:
        SAXParserFactory.setXIncludeAware(boolean)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXParserFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.parsers

Class SAXParserFactory

  • java.lang.Object
    • javax.xml.parsers.SAXParserFactory

  • public abstract class SAXParserFactory
extends Object
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
    Version:
    $Revision: 1.9 $, $Date: 2010/05/25 16:19:44 $

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SAXParserFactory()
      Protected constructor to force use of newInstance().

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract boolean getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      Schema getSchema()
      Gets the Schema object specified through the setSchema(Schema schema) method.
      boolean isNamespaceAware()
      Indicates whether or not the factory is configured to produce parsers which are namespace aware.
      boolean isValidating()
      Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
      boolean isXIncludeAware()
      Get state of XInclude processing.
      static SAXParserFactory newInstance()
      Obtain a new instance of a SAXParserFactory.
      static SAXParserFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SAXParserFactory from class name.
      abstract SAXParser newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      abstract void setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      void setNamespaceAware(boolean awareness)
      Specifies that the parser produced by this code will provide support for XML namespaces.
      void setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.
      void setValidating(boolean validating)
      Specifies that the parser produced by this code will validate documents as they are parsed.
      void setXIncludeAware(boolean state)
      Set state of XInclude processing.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SAXParserFactory

        protected SAXParserFactory()

        Protected constructor to force use of newInstance().

    • Method Detail

      • newInstance

        public static SAXParserFactory newInstance()
        Obtain a new instance of a SAXParserFactory. This static method creates a new factory instance This method uses the following ordered lookup procedure to determine the SAXParserFactory implementation class to load:
        • Use the javax.xml.parsers.SAXParserFactory system property.
        • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. The jaxp.properties file is read only once by the JAXP implementation and it's values are then cached for future use. If the file does not exist when the first attempt is made to read from it, no further attempts are made to check for its existence. It is not possible to change the value of any property in jaxp.properties after it has been read for the first time.
        • Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise the system-default implementation is returned.
        Once an application has obtained a reference to a SAXParserFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems loading SAXParsers, try:

         java -Djaxp.debug=1 YourProgram ....
        Returns:
        A new instance of a SAXParserFactory.
        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • newInstance

        public static SAXParserFactory newInstance(String factoryClassName,
                                           ClassLoader classLoader)

        Obtain a new instance of a SAXParserFactory from class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a SAXParserFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems, try:

         java -Djaxp.debug=1 YourProgram ....
        Parameters:
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.parsers.SAXParserFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        Returns:
        New instance of a SAXParserFactory
        Throws:
        FactoryConfigurationError - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        Since:
        1.6
        See Also:
        newInstance()

      • newSAXParser

        public abstract SAXParser newSAXParser()
                                throws ParserConfigurationException,
                                       SAXException

        Creates a new instance of a SAXParser using the currently configured factory parameters.

        Returns:
        A new instance of a SAXParser.
        Throws:
        ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
        SAXException - for SAX errors.

      • setNamespaceAware

        public void setNamespaceAware(boolean awareness)
        Specifies that the parser produced by this code will provide support for XML namespaces. By default the value of this is set to false.
        Parameters:
        awareness - true if the parser produced by this code will provide support for XML namespaces; false otherwise.

      • setValidating

        public void setValidating(boolean validating)
        Specifies that the parser produced by this code will validate documents as they are parsed. By default the value of this is set to false.

        Note that "the validation" here means a validating parser as defined in the XML recommendation. In other words, it essentially just controls the DTD validation. (except the legacy two properties defined in JAXP 1.2.)

        To use modern schema languages such as W3C XML Schema or RELAX NG instead of DTD, you can configure your parser to be a non-validating parser by leaving the setValidating(boolean) method false, then use the setSchema(Schema) method to associate a schema to a parser.

        Parameters:
        validating - true if the parser produced by this code will validate documents as they are parsed; false otherwise.

      • isNamespaceAware

        public boolean isNamespaceAware()
        Indicates whether or not the factory is configured to produce parsers which are namespace aware.
        Returns:
        true if the factory is configured to produce parsers which are namespace aware; false otherwise.

      • isValidating

        public boolean isValidating()
        Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
        Returns:
        true if the factory is configured to produce parsers which validate the XML content during parse; false otherwise.

      • setFeature

        public abstract void setFeature(String name,
                                boolean value)
                         throws ParserConfigurationException,
                                SAXNotRecognizedException,
                                SAXNotSupportedException

        Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader. A list of the core features and properties can be found at http://www.saxproject.org/

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include entity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See SAXParser parse methods for handler specification.
        • When the feature is false, the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        Parameters:
        name - The name of the feature to be set.
        value - The value of the feature to be set.
        Throws:
        ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        NullPointerException - If the name parameter is null.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • getFeature

        public abstract boolean getFeature(String name)
                            throws ParserConfigurationException,
                                   SAXNotRecognizedException,
                                   SAXNotSupportedException

        Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.

        Parameters:
        name - The name of the property to be retrieved.
        Returns:
        Value of the requested property.
        Throws:
        ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        See Also:
        XMLReader.getProperty(java.lang.String)

      • getSchema

        public Schema getSchema()
        Gets the Schema object specified through the setSchema(Schema schema) method.
        Returns:
        the Schema object that was last set through the setSchema(Schema) method, or null if the method was not invoked since a SAXParserFactory is created.
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5

      • setSchema

        public void setSchema(Schema schema)

        Set the Schema to be used by parsers created from this factory.

        When a Schema is non-null, a parser will use a validator created from it to validate documents before it passes information down to the application.

        When warnings/errors/fatal errors are found by the validator, the parser must handle them as if those errors were found by the parser itself. In other words, if the user-specified ErrorHandler is set, it must receive those errors, and if not, they must be treated according to the implementation specific default error handling rules.

        A validator may modify the SAX event stream (for example by adding default values that were missing in documents), and a parser is responsible to make sure that the application will receive those modified event stream.

        Initialy, null is set as the Schema.

        This processing will take effect even if the isValidating() method returns false.

        It is an error to use the http://java.sun.com/xml/jaxp/properties/schemaSource property and/or the http://java.sun.com/xml/jaxp/properties/schemaLanguage property in conjunction with a non-null Schema object. Such configuration will cause a SAXException exception when those properties are set on a SAXParser.

        Note for implementors

        A parser must be able to work with any Schema implementation. However, parsers and schemas are allowed to use implementation-specific custom mechanisms as long as they yield the result described in the specification.

        Parameters:
        schema - Schema to use, null to remove a schema.
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5

      • setXIncludeAware

        public void setXIncludeAware(boolean state)

        Set state of XInclude processing.

        If XInclude markup is found in the document instance, should it be processed as specified in XML Inclusions (XInclude) Version 1.0.

        XInclude processing defaults to false.

        Parameters:
        state - Set XInclude processing to true or false
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get state of XInclude processing.

        Returns:
        current state of XInclude processing
        Throws:
        UnsupportedOperationException - When implementation does not override this method
        Since:
        1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.parsers.DocumentBuilder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.parsers.DocumentBuilder

  • Packages that use DocumentBuilder
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of DocumentBuilder in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return DocumentBuilder
      Modifier and Type | Method and Description
      DocumentBuilder | W3CDomHandler.getBuilder()
      Methods in javax.xml.bind.annotation with parameters of type DocumentBuilder
      Modifier and Type | Method and Description
      void | W3CDomHandler.setBuilder(DocumentBuilder builder)
      Constructors in javax.xml.bind.annotation with parameters of type DocumentBuilder
      Constructor and Description
      W3CDomHandler(DocumentBuilder builder)
      Constructor that allows applications to specify which DOM implementation to be used.

    • Uses of DocumentBuilder in javax.xml.parsers

      Methods in javax.xml.parsers that return DocumentBuilder
      Modifier and Type Method and Description
      abstract DocumentBuilder DocumentBuilderFactory.newDocumentBuilder()
      Creates a new instance of a DocumentBuilder using the currently configured parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.parsers.DocumentBuilderFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.parsers.DocumentBuilderFactory

  • Packages that use DocumentBuilderFactory
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of DocumentBuilderFactory in javax.xml.parsers

      Methods in javax.xml.parsers that return DocumentBuilderFactory
      Modifier and Type Method and Description
      static DocumentBuilderFactory DocumentBuilderFactory.newInstance()
      Obtain a new instance of a DocumentBuilderFactory.
      static DocumentBuilderFactory DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DocumentBuilderFactory from class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.parsers.FactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.parsers.FactoryConfigurationError

No usage of javax.xml.parsers.FactoryConfigurationError
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.parsers.ParserConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.parsers.ParserConfigurationException

  • Packages that use ParserConfigurationException
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of ParserConfigurationException in javax.xml.parsers

      Methods in javax.xml.parsers that throw ParserConfigurationException
      Modifier and Type Method and Description
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract boolean DocumentBuilderFactory.getFeature(String name)
      Get the state of the named feature.
      abstract DocumentBuilder DocumentBuilderFactory.newDocumentBuilder()
      Creates a new instance of a DocumentBuilder using the currently configured parameters.
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void DocumentBuilderFactory.setFeature(String name, boolean value)
      Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.parsers.SAXParser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.parsers.SAXParser

  • Packages that use SAXParser
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of SAXParser in javax.xml.parsers

      Methods in javax.xml.parsers that return SAXParser
      Modifier and Type Method and Description
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.parsers.SAXParserFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.parsers.SAXParserFactory

  • Packages that use SAXParserFactory
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of SAXParserFactory in javax.xml.parsers

      Methods in javax.xml.parsers that return SAXParserFactory
      Modifier and Type Method and Description
      static SAXParserFactory SAXParserFactory.newInstance()
      Obtain a new instance of a SAXParserFactory.
      static SAXParserFactory SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SAXParserFactory from class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttachmentPart (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class AttachmentPart

  • java.lang.Object
    • javax.xml.soap.AttachmentPart

  • public abstract class AttachmentPart
extends Object
    A single attachment to a SOAPMessage object. A SOAPMessage object may contain zero, one, or many AttachmentPart objects. Each AttachmentPart object consists of two parts, application-specific content and associated MIME headers. The MIME headers consists of name/value pairs that can be used to identify and describe the content.

    An AttachmentPart object must conform to certain standards.

    1. It must conform to MIME [RFC2045] standards
    2. It MUST contain content
    3. The header portion MUST include the following header:
      • Content-Type
        This header identifies the type of data in the content of an AttachmentPart object and MUST conform to [RFC2045]. The following is an example of a Content-Type header:
               Content-Type:  application/xml
        The following line of code, in which ap is an AttachmentPart object, sets the header shown in the previous example.
               ap.setMimeHeader("Content-Type", "application/xml");

    There are no restrictions on the content portion of an AttachmentPart object. The content may be anything from a simple plain text object to a complex XML document or image file.

    An AttachmentPart object is created with the method SOAPMessage.createAttachmentPart. After setting its MIME headers, the AttachmentPart object is added to the message that created it with the method SOAPMessage.addAttachmentPart.

    The following code fragment, in which m is a SOAPMessage object and contentStringl is a String, creates an instance of AttachmentPart, sets the AttachmentPart object with some content and header information, and adds the AttachmentPart object to the SOAPMessage object.

         AttachmentPart ap1 = m.createAttachmentPart();
     ap1.setContent(contentString1, "text/plain");
     m.addAttachmentPart(ap1);

    The following code fragment creates and adds a second AttachmentPart instance to the same message. jpegData is a binary byte buffer representing the jpeg file.

         AttachmentPart ap2 = m.createAttachmentPart();
     byte[] jpegData =  ...;
     ap2.setContent(new ByteArrayInputStream(jpegData), "image/jpeg");
     m.addAttachmentPart(ap2);

    The getContent method retrieves the contents and header from an AttachmentPart object. Depending on the DataContentHandler objects present, the returned Object can either be a typed Java object corresponding to the MIME type or an InputStream object that contains the content as bytes.

         String content1 = ap1.getContent();
     java.io.InputStream content2 = ap2.getContent();
    The method clearContent removes all the content from an AttachmentPart object but does not affect its header information.
         ap1.clearContent();

    • Constructor Summary

      Constructors
      Constructor and Description
      AttachmentPart()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract void addMimeHeader(String name, String value)
      Adds a MIME header with the specified name and value to this AttachmentPart object.
      abstract void clearContent()
      Clears out the content of this AttachmentPart object.
      abstract Iterator getAllMimeHeaders()
      Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
      abstract InputStream getBase64Content()
      Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
      abstract Object getContent()
      Gets the content of this AttachmentPart object as a Java object.
      String getContentId()
      Gets the value of the MIME header whose name is "Content-ID".
      String getContentLocation()
      Gets the value of the MIME header whose name is "Content-Location".
      String getContentType()
      Gets the value of the MIME header whose name is "Content-Type".
      abstract DataHandler getDataHandler()
      Gets the DataHandler object for this AttachmentPart object.
      abstract Iterator getMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects that match a name in the given array.
      abstract String[] getMimeHeader(String name)
      Gets all the values of the header identified by the given String.
      abstract Iterator getNonMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects whose name does not match a name in the given array.
      abstract InputStream getRawContent()
      Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract byte[] getRawContentBytes()
      Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract int getSize()
      Returns the number of bytes in this AttachmentPart object.
      abstract void removeAllMimeHeaders()
      Removes all the MIME header entries.
      abstract void removeMimeHeader(String header)
      Removes all MIME headers that match the given name.
      abstract void setBase64Content(InputStream content, String contentType)
      Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
      abstract void setContent(Object object, String contentType)
      Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.
      void setContentId(String contentId)
      Sets the MIME header whose name is "Content-ID" with the given value.
      void setContentLocation(String contentLocation)
      Sets the MIME header whose name is "Content-Location" with the given value.
      void setContentType(String contentType)
      Sets the MIME header whose name is "Content-Type" with the given value.
      abstract void setDataHandler(DataHandler dataHandler)
      Sets the given DataHandler object as the data handler for this AttachmentPart object.
      abstract void setMimeHeader(String name, String value)
      Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.
      abstract void setRawContent(InputStream content, String contentType)
      Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
      abstract void setRawContentBytes(byte[] content, int offset, int len, String contentType)
      Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttachmentPart

        public AttachmentPart()

    • Method Detail

      • getSize

        public abstract int getSize()
                     throws SOAPException
        Returns the number of bytes in this AttachmentPart object.
        Returns:
        the size of this AttachmentPart object in bytes or -1 if the size cannot be determined
        Throws:
        SOAPException - if the content of this attachment is corrupted of if there was an exception while trying to determine the size.

      • clearContent

        public abstract void clearContent()
        Clears out the content of this AttachmentPart object. The MIME header portion is left untouched.

      • getContent

        public abstract Object getContent()
                           throws SOAPException
        Gets the content of this AttachmentPart object as a Java object. The type of the returned Java object depends on (1) the DataContentHandler object that is used to interpret the bytes and (2) the Content-Type given in the header.

        For the MIME content types "text/plain", "text/html" and "text/xml", the DataContentHandler object does the conversions to and from the Java types corresponding to the MIME types. For other MIME types,the DataContentHandler object can return an InputStream object that contains the content data as raw bytes.

        A SAAJ-compliant implementation must, as a minimum, return a java.lang.String object corresponding to any content stream with a Content-Type value of text/plain, a javax.xml.transform.stream.StreamSource object corresponding to a content stream with a Content-Type value of text/xml, a java.awt.Image object corresponding to a content stream with a Content-Type value of image/gif or image/jpeg. For those content types that an installed DataContentHandler object does not understand, the DataContentHandler object is required to return a java.io.InputStream object with the raw bytes.

        Returns:
        a Java object with the content of this AttachmentPart object
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error

      • getRawContent

        public abstract InputStream getRawContent()
                                   throws SOAPException
        Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

        Note that reading from the returned InputStream would result in consuming the data in the stream. It is the responsibility of the caller to reset the InputStream appropriately before calling a Subsequent API. If a copy of the raw attachment content is required then the getRawContentBytes() API should be used instead.

        Returns:
        an InputStream from which the raw data contained by the AttachmentPart can be accessed.
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        Since:
        SAAJ 1.3
        See Also:
        getRawContentBytes()

      • getRawContentBytes

        public abstract byte[] getRawContentBytes()
                                   throws SOAPException
        Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
        Returns:
        a byte[] array containing the raw data of the AttachmentPart.
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        Since:
        SAAJ 1.3

      • getBase64Content

        public abstract InputStream getBase64Content()
                                      throws SOAPException
        Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
        Returns:
        an InputStream from which the Base64 encoded AttachmentPart can be read.
        Throws:
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        Since:
        SAAJ 1.3

      • setContent

        public abstract void setContent(Object object,
                                String contentType)
        Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type. The type of the Object should correspond to the value given for the Content-Type. This depends on the particular set of DataContentHandler objects in use.
        Parameters:
        object - the Java object that makes up the content for this attachment part
        contentType - the MIME string that specifies the type of the content
        Throws:
        IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for this content object
        See Also:
        getContent()

      • setRawContent

        public abstract void setRawContent(InputStream content,
                                   String contentType)
                            throws SOAPException
        Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.

        A subsequent call to getSize() may not be an exact measure of the content size.

        Parameters:
        content - the raw data to add to the attachment part
        contentType - the value to set into the Content-Type header
        Throws:
        SOAPException - if an there is an error in setting the content
        NullPointerException - if content is null
        Since:
        SAAJ 1.3

      • setRawContentBytes

        public abstract void setRawContentBytes(byte[] content,
                                        int offset,
                                        int len,
                                        String contentType)
                                 throws SOAPException
        Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
        Parameters:
        content - the raw data to add to the attachment part
        contentType - the value to set into the Content-Type header
        offset - the offset in the byte array of the content
        len - the number of bytes that form the content
        Throws:
        SOAPException - if an there is an error in setting the content or content is null
        Since:
        SAAJ 1.3

      • setBase64Content

        public abstract void setBase64Content(InputStream content,
                                      String contentType)
                               throws SOAPException
        Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.

        A subsequent call to getSize() may not be an exact measure of the content size.

        Parameters:
        content - the base64 encoded data to add to the attachment part
        contentType - the value to set into the Content-Type header
        Throws:
        SOAPException - if an there is an error in setting the content
        NullPointerException - if content is null
        Since:
        SAAJ 1.3

      • getDataHandler

        public abstract DataHandler getDataHandler()
                                    throws SOAPException
        Gets the DataHandler object for this AttachmentPart object.
        Returns:
        the DataHandler object associated with this AttachmentPart object
        Throws:
        SOAPException - if there is no data in this AttachmentPart object

      • setDataHandler

        public abstract void setDataHandler(DataHandler dataHandler)
        Sets the given DataHandler object as the data handler for this AttachmentPart object. Typically, on an incoming message, the data handler is automatically set. When a message is being created and populated with content, the setDataHandler method can be used to get data from various data sources into the message.
        Parameters:
        dataHandler - the DataHandler object to be set
        Throws:
        IllegalArgumentException - if there was a problem with the specified DataHandler object

      • getContentId

        public String getContentId()
        Gets the value of the MIME header whose name is "Content-ID".
        Returns:
        a String giving the value of the "Content-ID" header or null if there is none
        See Also:
        setContentId(java.lang.String)

      • getContentLocation

        public String getContentLocation()
        Gets the value of the MIME header whose name is "Content-Location".
        Returns:
        a String giving the value of the "Content-Location" header or null if there is none

      • getContentType

        public String getContentType()
        Gets the value of the MIME header whose name is "Content-Type".
        Returns:
        a String giving the value of the "Content-Type" header or null if there is none

      • setContentId

        public void setContentId(String contentId)
        Sets the MIME header whose name is "Content-ID" with the given value.
        Parameters:
        contentId - a String giving the value of the "Content-ID" header
        Throws:
        IllegalArgumentException - if there was a problem with the specified contentId value
        See Also:
        getContentId()

      • setContentLocation

        public void setContentLocation(String contentLocation)
        Sets the MIME header whose name is "Content-Location" with the given value.
        Parameters:
        contentLocation - a String giving the value of the "Content-Location" header
        Throws:
        IllegalArgumentException - if there was a problem with the specified content location

      • setContentType

        public void setContentType(String contentType)
        Sets the MIME header whose name is "Content-Type" with the given value.
        Parameters:
        contentType - a String giving the value of the "Content-Type" header
        Throws:
        IllegalArgumentException - if there was a problem with the specified content type

      • removeMimeHeader

        public abstract void removeMimeHeader(String header)
        Removes all MIME headers that match the given name.
        Parameters:
        header - the string name of the MIME header/s to be removed

      • removeAllMimeHeaders

        public abstract void removeAllMimeHeaders()
        Removes all the MIME header entries.

      • getMimeHeader

        public abstract String[] getMimeHeader(String name)
        Gets all the values of the header identified by the given String.
        Parameters:
        name - the name of the header; example: "Content-Type"
        Returns:
        a String array giving the value for the specified header
        See Also:
        setMimeHeader(java.lang.String, java.lang.String)

      • setMimeHeader

        public abstract void setMimeHeader(String name,
                                   String value)
        Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches. This method also removes all matching headers but the first.

        Note that RFC822 headers can only contain US-ASCII characters.

        Parameters:
        name - a String giving the name of the header for which to search
        value - a String giving the value to be set for the header whose name matches the given name
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • addMimeHeader

        public abstract void addMimeHeader(String name,
                                   String value)
        Adds a MIME header with the specified name and value to this AttachmentPart object.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String giving the name of the header to be added
        value - a String giving the value of the header to be added
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • getAllMimeHeaders

        public abstract Iterator getAllMimeHeaders()
        Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
        Returns:
        an Iterator object with all of the Mime headers for this AttachmentPart object

      • getMatchingMimeHeaders

        public abstract Iterator getMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects that match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers to be returned
        Returns:
        all of the MIME headers that match one of the names in the given array as an Iterator object

      • getNonMatchingMimeHeaders

        public abstract Iterator getNonMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects whose name does not match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers not to be returned
        Returns:
        all of the MIME headers in this AttachmentPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Detail (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Detail

  • All Superinterfaces:
    Element, Node, SOAPElement, SOAPFaultElement

    public interface Detail
extends SOAPFaultElement
    A container for DetailEntry objects. DetailEntry objects give detailed error information that is application-specific and related to the SOAPBody object that contains it.

    A Detail object, which is part of a SOAPFault object, can be retrieved using the method SOAPFault.getDetail. The Detail interface provides two methods. One creates a new DetailEntry object and also automatically adds it to the Detail object. The second method gets a list of the DetailEntry objects contained in a Detail object.

    The following code fragment, in which sf is a SOAPFault object, gets its Detail object (d), adds a new DetailEntry object to d, and then gets a list of all the DetailEntry objects in d. The code also creates a Name object to pass to the method addDetailEntry. The variable se, used to create the Name object, is a SOAPEnvelope object.

        Detail d = sf.getDetail();
    Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    d.addDetailEntry(name);
    Iterator it = d.getDetailEntries();

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DetailEntry addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      Iterator getDetailEntries()
      Gets an Iterator over all of the DetailEntrys in this Detail object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addDetailEntry

        DetailEntry addDetailEntry(Name name)
                    throws SOAPException
        Creates a new DetailEntry object with the given name and adds it to this Detail object.
        Parameters:
        name - a Name object identifying the new DetailEntry object
        Throws:
        SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
        See Also:
        addDetailEntry(QName qname)

      • addDetailEntry

        DetailEntry addDetailEntry(QName qname)
                    throws SOAPException
        Creates a new DetailEntry object with the given QName and adds it to this Detail object. This method is the preferred over the one using Name.
        Parameters:
        qname - a QName object identifying the new DetailEntry object
        Throws:
        SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
        Since:
        SAAJ 1.3
        See Also:
        addDetailEntry(Name name)

      • getDetailEntries

        Iterator getDetailEntries()
        Gets an Iterator over all of the DetailEntrys in this Detail object.
        Returns:
        an Iterator object over the DetailEntry objects in this Detail object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DetailEntry (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface DetailEntry

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface DetailEntry
extends SOAPElement
    The content for a Detail object, giving details for a SOAPFault object. A DetailEntry object, which carries information about errors related to the SOAPBody object that contains it, is application-specific.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MessageFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class MessageFactory

  • java.lang.Object
    • javax.xml.soap.MessageFactory

  • public abstract class MessageFactory
extends Object
    A factory for creating SOAPMessage objects.

    A SAAJ client can create a MessageFactory object using the method newInstance, as shown in the following lines of code.

           MessageFactory mf = MessageFactory.newInstance();
       MessageFactory mf12 = MessageFactory.newInstance(SOAPConstants.SOAP_1_2_PROTOCOL);

    All MessageFactory objects, regardless of how they are created, will produce SOAPMessage objects that have the following elements by default:

    • A SOAPPart object
    • A SOAPEnvelope object
    • A SOAPBody object
    • A SOAPHeader object
    In some cases, specialized MessageFactory objects may be obtained that produce messages prepopulated with additional entries in the SOAPHeader object and the SOAPBody object. The content of a new SOAPMessage object depends on which of the two MessageFactory methods is used to create it.
    • createMessage()
      This is the method clients would normally use to create a request message.
    • createMessage(MimeHeaders, java.io.InputStream) -- message has content from the InputStream object and headers from the MimeHeaders object
      This method can be used internally by a service implementation to create a message that is a response to a request.

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageFactory()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract SOAPMessage createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      static MessageFactory newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static MessageFactory newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageFactory

        public MessageFactory()

    • Method Detail

      • newInstance

        public static MessageFactory newInstance()
                                  throws SOAPException
        Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load:
        • Use the javax.xml.soap.MessageFactory system property.
        • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.MessageFactory in jars available to the runtime.
        • Use the SAAJMetaFactory instance to locate the MessageFactory implementation class.
        Returns:
        a new instance of a MessageFactory
        Throws:
        SOAPException - if there was an error in creating the default implementation of the MessageFactory.
        See Also:
        SAAJMetaFactory

      • newInstance

        public static MessageFactory newInstance(String protocol)
                                  throws SOAPException
        Creates a new MessageFactory object that is an instance of the specified implementation. May be a dynamic message factory, a SOAP 1.1 message factory, or a SOAP 1.2 message factory. A dynamic message factory creates messages based on the MIME headers specified as arguments to the createMessage method. This method uses the SAAJMetaFactory to locate the implementation class and create the MessageFactory instance.
        Parameters:
        protocol - a string constant representing the class of the specified message factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
        Returns:
        a new instance of a MessageFactory
        Throws:
        SOAPException - if there was an error in creating the specified implementation of MessageFactory.
        Since:
        SAAJ 1.3
        See Also:
        SAAJMetaFactory

      • createMessage

        public abstract SOAPMessage createMessage()
                                   throws SOAPException
        Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects. Profile-specific message factories can choose to prepopulate the SOAPMessage object with profile-specific headers.

        Content can be added to this message's SOAPPart object, and the message can be sent "as is" when a message containing only a SOAP part is sufficient. Otherwise, the SOAPMessage object needs to create one or more AttachmentPart objects and add them to itself. Any content that is not in XML format must be in an AttachmentPart object.

        Returns:
        a new SOAPMessage object
        Throws:
        SOAPException - if a SOAP error occurs
        UnsupportedOperationException - if the protocol of this MessageFactory instance is DYNAMIC_SOAP_PROTOCOL

      • createMessage

        public abstract SOAPMessage createMessage(MimeHeaders headers,
                                          InputStream in)
                                   throws IOException,
                                          SOAPException
        Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
        Parameters:
        in - the InputStream object that contains the data for a message
        headers - the transport-specific headers passed to the message in a transport-independent fashion for creation of the message
        Returns:
        a new SOAPMessage object containing the data from the given InputStream object
        Throws:
        IOException - if there is a problem in reading data from the input stream
        SOAPException - may be thrown if the message is invalid
        IllegalArgumentException - if the MessageFactory requires one or more MIME headers to be present in the headers parameter and they are missing. MessageFactory implementations for SOAP_1_1_PROTOCOL or SOAP_1_2_PROTOCOL must not throw IllegalArgumentException for this reason.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MimeHeader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class MimeHeader

  • java.lang.Object
    • javax.xml.soap.MimeHeader

  • public class MimeHeader
extends Object
    An object that stores a MIME header name and its value. One or more MimeHeader objects may be contained in a MimeHeaders object.
    See Also:
    MimeHeaders

    • Constructor Summary

      Constructors
      Constructor and Description
      MimeHeader(String name, String value)
      Constructs a MimeHeader object initialized with the given name and value.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of this MimeHeader object.
      String getValue()
      Returns the value of this MimeHeader object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MimeHeader

        public MimeHeader(String name,
                  String value)
        Constructs a MimeHeader object initialized with the given name and value.
        Parameters:
        name - a String giving the name of the header
        value - a String giving the value of the header

    • Method Detail

      • getName

        public String getName()
        Returns the name of this MimeHeader object.
        Returns:
        the name of the header as a String

      • getValue

        public String getValue()
        Returns the value of this MimeHeader object.
        Returns:
        the value of the header as a String
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MimeHeaders (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class MimeHeaders

  • java.lang.Object
    • javax.xml.soap.MimeHeaders

  • public class MimeHeaders
extends Object
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.

    This class is used primarily when an application wants to retrieve specific attachments based on certain MIME headers and values. This class will most likely be used by implementations of AttachmentPart and other MIME dependent parts of the SAAJ API.

    See Also:
    SOAPMessage.getAttachments(), AttachmentPart

    • Constructor Summary

      Constructors
      Constructor and Description
      MimeHeaders()
      Constructs a default MimeHeaders object initialized with an empty Vector object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addHeader(String name, String value)
      Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
      Iterator getAllHeaders()
      Returns all the MimeHeaders in this MimeHeaders object.
      String[] getHeader(String name)
      Returns all of the values for the specified header as an array of String objects.
      Iterator getMatchingHeaders(String[] names)
      Returns all the MimeHeader objects whose name matches a name in the given array of names.
      Iterator getNonMatchingHeaders(String[] names)
      Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
      void removeAllHeaders()
      Removes all the header entries from this MimeHeaders object.
      void removeHeader(String name)
      Remove all MimeHeader objects whose name matches the given name.
      void setHeader(String name, String value)
      Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MimeHeaders

        public MimeHeaders()
        Constructs a default MimeHeaders object initialized with an empty Vector object.

    • Method Detail

      • getHeader

        public String[] getHeader(String name)
        Returns all of the values for the specified header as an array of String objects.
        Parameters:
        name - the name of the header for which values will be returned
        Returns:
        a String array with all of the values for the specified header
        See Also:
        setHeader(java.lang.String, java.lang.String)

      • setHeader

        public void setHeader(String name,
                      String value)
        Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches. This method also removes all matching headers after the first one.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String with the name of the header for which to search
        value - a String with the value that will replace the current value of the specified header
        Throws:
        IllegalArgumentException - if there was a problem in the mime header name or the value being set
        See Also:
        getHeader(java.lang.String)

      • addHeader

        public void addHeader(String name,
                      String value)
        Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String with the name of the header to be added
        value - a String with the value of the header to be added
        Throws:
        IllegalArgumentException - if there was a problem in the mime header name or value being added

      • removeHeader

        public void removeHeader(String name)
        Remove all MimeHeader objects whose name matches the given name.
        Parameters:
        name - a String with the name of the header for which to search

      • removeAllHeaders

        public void removeAllHeaders()
        Removes all the header entries from this MimeHeaders object.

      • getAllHeaders

        public Iterator getAllHeaders()
        Returns all the MimeHeaders in this MimeHeaders object.
        Returns:
        an Iterator object over this MimeHeaders object's list of MimeHeader objects

      • getMatchingHeaders

        public Iterator getMatchingHeaders(String[] names)
        Returns all the MimeHeader objects whose name matches a name in the given array of names.
        Parameters:
        names - an array of String objects with the names for which to search
        Returns:
        an Iterator object over the MimeHeader objects whose name matches one of the names in the given list

      • getNonMatchingHeaders

        public Iterator getNonMatchingHeaders(String[] names)
        Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
        Parameters:
        names - an array of String objects with the names for which to search
        Returns:
        an Iterator object over the MimeHeader objects whose name does not match one of the names in the given list
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Name (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Name

  • public interface Name
    A representation of an XML name. This interface provides methods for getting the local and namespace-qualified names and also for getting the prefix associated with the namespace for the name. It is also possible to get the URI of the namespace.

    The following is an example of a namespace declaration in an element.

       <wombat:GetLastTradePrice xmlns:wombat="http://www.wombat.org/trader">
    ("xmlns" stands for "XML namespace".) The following shows what the methods in the Name interface will return.
    • getQualifiedName will return "prefix:LocalName" = "WOMBAT:GetLastTradePrice"
    • getURI will return "http://www.wombat.org/trader"
    • getLocalName will return "GetLastTracePrice"
    • getPrefix will return "WOMBAT"

    XML namespaces are used to disambiguate SOAP identifiers from application-specific identifiers.

    Name objects are created using the method SOAPEnvelope.createName, which has two versions. One method creates Name objects with a local name, a namespace prefix, and a namespace URI. and the second creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

         Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    The following line of code gives an example of how a Name object can be used. The variable element is a SOAPElement object. This code creates a new SOAPElement object with the given name and adds it to element.
         element.addChildElement(name);

    The Name interface may be deprecated in a future release of SAAJ in favor of javax.xml.namespace.QName

    See Also:
    SOAPEnvelope.createName, SOAPFactory.createName

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getLocalName()
      Gets the local name part of the XML name that this Name object represents.
      String getPrefix()
      Returns the prefix that was specified when this Name object was initialized.
      String getQualifiedName()
      Gets the namespace-qualified name of the XML name that this Name object represents.
      String getURI()
      Returns the URI of the namespace for the XML name that this Name object represents.

    • Method Detail

      • getLocalName

        String getLocalName()
        Gets the local name part of the XML name that this Name object represents.
        Returns:
        a string giving the local name

      • getQualifiedName

        String getQualifiedName()
        Gets the namespace-qualified name of the XML name that this Name object represents.
        Returns:
        the namespace-qualified name as a string

      • getPrefix

        String getPrefix()
        Returns the prefix that was specified when this Name object was initialized. This prefix is associated with the namespace for the XML name that this Name object represents.
        Returns:
        the prefix as a string

      • getURI

        String getURI()
        Returns the URI of the namespace for the XML name that this Name object represents.
        Returns:
        the URI as a string
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Node (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Node

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text

    public interface Node
extends Node
    A representation of a node (element) in an XML document. This interface extnends the standard DOM Node interface with methods for getting and setting the value of a node, for getting and setting the parent of a node, and for removing a node.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void detachNode()
      Removes this Node object from the tree.
      SOAPElement getParentElement()
      Returns the parent element of this Node object.
      String getValue()
      Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
      void recycleNode()
      Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.
      void setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      void setValue(String value)
      If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getValue

        String getValue()
        Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise. If there is an immediate child of this Node that it is a Text node then it's value will be returned. If there is more than one Text node then the value of the first Text Node will be returned. Otherwise null is returned.
        Returns:
        a String with the text of this node if this is a Text node or the text contained by the first immediate child of this Node object that is a Text object if such a child exists; null otherwise.

      • setValue

        void setValue(String value)
        If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node. The value of the immediate child of this node can be set only if, there is one child node and that node is a Text node, or if there are no children in which case a child Text node will be created.
        Throws:
        IllegalStateException - if the node is not a Text node and either has more than one child node or has a child node that is not a Text node.
        Since:
        SAAJ 1.2

      • setParentElement

        void setParentElement(SOAPElement parent)
               throws SOAPException
        Sets the parent of this Node object to the given SOAPElement object.
        Parameters:
        parent - the SOAPElement object to be set as the parent of this Node object
        Throws:
        SOAPException - if there is a problem in setting the parent to the given element
        See Also:
        getParentElement()

      • getParentElement

        SOAPElement getParentElement()
        Returns the parent element of this Node object. This method can throw an UnsupportedOperationException if the tree is not kept in memory.
        Returns:
        the SOAPElement object that is the parent of this Node object or null if this Node object is root
        Throws:
        UnsupportedOperationException - if the whole tree is not kept in memory
        See Also:
        setParentElement(javax.xml.soap.SOAPElement)

      • detachNode

        void detachNode()
        Removes this Node object from the tree.

      • recycleNode

        void recycleNode()
        Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.

        Calling the method recycleNode implies that the method detachNode has been called previously.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.soap (Java Platform SE 8 )

javax.xml.soap

Interfaces

  • Detail
  • DetailEntry
  • Name
  • Node
  • SOAPBody
  • SOAPBodyElement
  • SOAPConstants
  • SOAPElement
  • SOAPEnvelope
  • SOAPFault
  • SOAPFaultElement
  • SOAPHeader
  • SOAPHeaderElement
  • Text

Classes

  • AttachmentPart
  • MessageFactory
  • MimeHeader
  • MimeHeaders
  • SAAJMetaFactory
  • SAAJResult
  • SOAPConnection
  • SOAPConnectionFactory
  • SOAPElementFactory
  • SOAPFactory
  • SOAPMessage
  • SOAPPart

Exceptions

  • SOAPException


javax.xml.soap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.soap

Provides the API for creating and building SOAP messages.

See: Description

  • Interface Summary
    Interface Description
    Detail
    A container for DetailEntry objects.
    DetailEntry
    The content for a Detail object, giving details for a SOAPFault object.
    Name
    A representation of an XML name.
    Node
    A representation of a node (element) in an XML document.
    SOAPBody
    An object that represents the contents of the SOAP body element in a SOAP message.
    SOAPBodyElement
    A SOAPBodyElement object represents the contents in a SOAPBody object.
    SOAPConstants
    The definition of constants pertaining to the SOAP protocol.
    SOAPElement
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
    SOAPEnvelope
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
    SOAPFaultElement
    A representation of the contents in a SOAPFault object.
    SOAPHeader
    A representation of the SOAP header element.
    SOAPHeaderElement
    An object representing the contents in the SOAP header part of the SOAP envelope.
    Text
    A representation of a node whose value is text.
  • Class Summary
    Class Description
    AttachmentPart
    A single attachment to a SOAPMessage object.
    MessageFactory
    A factory for creating SOAPMessage objects.
    MimeHeader
    An object that stores a MIME header name and its value.
    MimeHeaders
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
    SAAJMetaFactory
    The access point for the implementation classes of the factories defined in the SAAJ API.
    SAAJResult
    Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.
    SOAPConnection
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
    SOAPConnectionFactory
    A factory for creating SOAPConnection objects.
    SOAPElementFactory Deprecated
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPMessage
    The root class for all SOAP messages.
    SOAPPart
    The container for the SOAP-specific portion of a SOAPMessage object.
  • Exception Summary
    Exception Description
    SOAPException
    An exception that signals that a SOAP exception has occurred.

Package javax.xml.soap Description

Provides the API for creating and building SOAP messages. This package is defined in the SOAP with Attachments API for JavaTM (SAAJ) 1.3 specification.

The API in the javax.xml.soap package allows you to do the following:

  • create a point-to-point connection to a specified endpoint
  • create a SOAP message
  • create an XML fragment
  • add content to the header of a SOAP message
  • add content to the body of a SOAP message
  • create attachment parts and add content to them
  • access/add/modify parts of a SOAP message
  • create/add/modify SOAP fault information
  • extract content from a SOAP message
  • send a SOAP request-response message

In addition the APIs in the javax.xml.soap package extend their counterparts in the org.w3c.dom package. This means that the SOAPPart of a SOAPMessage is also a DOM Level 2 Document, and can be manipulated as such by applications, tools and libraries that use DOM (see http://www.w3.org/DOM/ for more information). It is important to note that, while it is possible to use DOM APIs to add ordinary DOM nodes to a SAAJ tree, the SAAJ APIs are still required to return SAAJ types when examining or manipulating the tree. In order to accomplish this the SAAJ APIs (specifically SOAPElement.getChildElements()) are allowed to silently replace objects that are incorrectly typed relative to SAAJ requirements with equivalent objects of the required type. These replacements must never cause the logical structure of the tree to change, so from the perspective of the DOM APIs the tree will remain unchanged. However, the physical composition of the tree will have changed so that references to the nodes that were replaced will refer to nodes that are no longer a part of the tree. The SAAJ APIs are not allowed to make these replacements if they are not required so the replacement objects will never subsequently be silently replaced by future calls to the SAAJ API.

What this means in practical terms is that an application that starts to use SAAJ APIs on a tree after manipulating it using DOM APIs must assume that the tree has been translated into an all SAAJ tree and that any references to objects within the tree that were obtained using DOM APIs are no longer valid. Switching from SAAJ APIs to DOM APIs is not allowed to cause invalid references and neither is using SAAJ APIs exclusively. It is only switching from using DOM APIs on a particular SAAJ tree to using SAAJ APIs that causes the risk of invalid references.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.soap Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.soap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.soap.AttachmentPart
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.soap.MessageFactory
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.soap.SOAPException

Interface Hierarchy

  • javax.xml.soap.Name
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • org.w3c.dom.Element
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • javax.xml.soap.SOAPConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.soap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.soap

  • Packages that use javax.xml.soap
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
  • Classes in javax.xml.soap used by javax.xml.soap
    Class and Description
    AttachmentPart
    A single attachment to a SOAPMessage object.
    Detail
    A container for DetailEntry objects.
    DetailEntry
    The content for a Detail object, giving details for a SOAPFault object.
    MessageFactory
    A factory for creating SOAPMessage objects.
    MimeHeaders
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
    Name
    A representation of an XML name.
    Node
    A representation of a node (element) in an XML document.
    SOAPBody
    An object that represents the contents of the SOAP body element in a SOAP message.
    SOAPBodyElement
    A SOAPBodyElement object represents the contents in a SOAPBody object.
    SOAPConnection
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
    SOAPConnectionFactory
    A factory for creating SOAPConnection objects.
    SOAPElement
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
    SOAPElementFactory
    Deprecated.
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    SOAPEnvelope
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
    SOAPException
    An exception that signals that a SOAP exception has occurred.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
    SOAPFaultElement
    A representation of the contents in a SOAPFault object.
    SOAPHeader
    A representation of the SOAP header element.
    SOAPHeaderElement
    An object representing the contents in the SOAP header part of the SOAP envelope.
    SOAPMessage
    The root class for all SOAP messages.
    SOAPPart
    The container for the SOAP-specific portion of a SOAPMessage object.
  • Classes in javax.xml.soap used by javax.xml.ws.handler.soap
    Class and Description
    SOAPMessage
    The root class for all SOAP messages.
  • Classes in javax.xml.soap used by javax.xml.ws.soap
    Class and Description
    MessageFactory
    A factory for creating SOAPMessage objects.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAAJMetaFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SAAJMetaFactory

  • java.lang.Object
    • javax.xml.soap.SAAJMetaFactory

  • public abstract class SAAJMetaFactory
extends Object
    The access point for the implementation classes of the factories defined in the SAAJ API. All of the newInstance methods defined on factories in SAAJ 1.3 defer to instances of this class to do the actual object creation. The implementations of newInstance() methods (in SOAPFactory and MessageFactory) that existed in SAAJ 1.2 have been updated to also delegate to the SAAJMetaFactory when the SAAJ 1.2 defined lookup fails to locate the Factory implementation class name.

    SAAJMetaFactory is a service provider interface. There are no public methods on this class.

    Since:
    SAAJ 1.3

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | SAAJMetaFactory()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      protected abstract MessageFactory newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.
      protected abstract SOAPFactory newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SAAJMetaFactory

        protected SAAJMetaFactory()

    • Method Detail

      • newMessageFactory

        protected abstract MessageFactory newMessageFactory(String protocol)
                                             throws SOAPException
        Creates a MessageFactory object for the given String protocol.
        Parameters:
        protocol - a String indicating the protocol
        Throws:
        SOAPException - if there is an error in creating the MessageFactory
        See Also:
        SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL

      • newSOAPFactory

        protected abstract SOAPFactory newSOAPFactory(String protocol)
                                       throws SOAPException
        Creates a SOAPFactory object for the given String protocol.
        Parameters:
        protocol - a String indicating the protocol
        Throws:
        SOAPException - if there is an error in creating the SOAPFactory
        See Also:
        SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAAJResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SAAJResult

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult
      • javax.xml.soap.SAAJResult
  • All Implemented Interfaces:
    Result

    public class SAAJResult
extends DOMResult
    Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree. These results should be accessed by using the getResult() method. The DOMResult.getNode() method should be avoided in almost all cases.
    Since:
    SAAJ 1.3

    • Field Summary

      • Fields inherited from class javax.xml.transform.dom.DOMResult

        FEATURE

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      SAAJResult()
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
      SAAJResult(SOAPElement rootNode)
      Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
      SAAJResult(SOAPMessage message)
      Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.
      SAAJResult(String protocol)
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Node getResult()

      • Methods inherited from class javax.xml.transform.dom.DOMResult

        getNextSibling, getNode, getSystemId, setNextSibling, setNode, setSystemId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SAAJResult

        public SAAJResult()
           throws SOAPException
        Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.

        This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation, the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

        Throws:
        SOAPException - if there is a problem creating a SOAPMessage
        Since:
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(String protocol)
           throws SOAPException
        Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol. The DYNAMIC_SOAP_PROTOCOL is ambiguous in this context and will cause this constructor to throw an UnsupportedOperationException.

        This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

        Parameters:
        protocol - - the name of the SOAP protocol that the resulting SAAJ tree should support
        Throws:
        SOAPException - if a SOAPMessage supporting the specified protocol cannot be created
        Since:
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(SOAPMessage message)
        Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage. In the normal case these results will be written using DOM APIs and, as a result, the finished SOAPPart will not be guaranteed to be well-formed unless the data used to create it is also well formed. When used in a transformation the validity of the SOAPMessage after the transformation can be guaranteed only by means outside SAAJ specification.
        Parameters:
        message - - the message whose SOAPPart will be populated as a result of some transformation or marshalling operation
        Since:
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(SOAPElement rootNode)
        Creates a SAAJResult that will write the results as a child node of the SOAPElement specified. In the normal case these results will be written using DOM APIs and as a result may invalidate the structure of the SAAJ tree. This kind of SAAJResult should only be used when the validity of the incoming data can be guaranteed by means outside of the SAAJ specification.
        Parameters:
        rootNode - - the root to which the results will be appended
        Since:
        SAAJ 1.3

    • Method Detail

      • getResult

        public Node getResult()
        Returns:
        the resulting Tree that was created under the specified root Node.
        Since:
        SAAJ 1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPBody (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPBody

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPBody
extends SOAPElement
    An object that represents the contents of the SOAP body element in a SOAP message. A SOAP body element consists of XML data that affects the way the application-specific content is processed.

    A SOAPBody object contains SOAPBodyElement objects, which have the content for the SOAP body. A SOAPFault object, which carries status and/or error information, is an example of a SOAPBodyElement object.

    See Also:
    SOAPFault

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      SOAPBodyElement addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPBodyElement addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
      SOAPFault addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      Document extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      SOAPFault getFault()
      Returns the SOAPFault object in this SOAPBody object.
      boolean hasFault()
      Indicates whether a SOAPFault object exists in this SOAPBody object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addFault

        SOAPFault addFault()
            throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have default values set for the mandatory child elements. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        A SOAPBody may contain at most one SOAPFault child element.

        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error

      • addFault

        SOAPFault addFault(Name faultCode,
                   String faultString,
                   Locale locale)
            throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        A SOAPBody may contain at most one SOAPFault child element.

        Parameters:
        faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the Version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.2
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

      • addFault

        SOAPFault addFault(QName faultCode,
                   String faultString,
                   Locale locale)
            throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        A SOAPBody may contain at most one SOAPFault child element.

        Parameters:
        faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use.
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString, Locale locale)

      • addFault

        SOAPFault addFault(Name faultCode,
                   String faultString)
            throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

        A SOAPBody may contain at most one SOAPFault child element.

        Parameters:
        faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.2
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

      • addFault

        SOAPFault addFault(QName faultCode,
                   String faultString)
            throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

        A SOAPBody may contain at most one SOAPFault child element

        Parameters:
        faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        Returns:
        the new SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3
        See Also:
        SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString)

      • hasFault

        boolean hasFault()
        Indicates whether a SOAPFault object exists in this SOAPBody object.
        Returns:
        true if a SOAPFault object exists in this SOAPBody object; false otherwise

      • getFault

        SOAPFault getFault()
        Returns the SOAPFault object in this SOAPBody object.
        Returns:
        the SOAPFault object in this SOAPBody object if present, null otherwise.

      • addBodyElement

        SOAPBodyElement addBodyElement(Name name)
                        throws SOAPException
        Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
        Parameters:
        name - a Name object with the name for the new SOAPBodyElement object
        Returns:
        the new SOAPBodyElement object
        Throws:
        SOAPException - if a SOAP error occurs
        See Also:
        addBodyElement(javax.xml.namespace.QName)

      • addBodyElement

        SOAPBodyElement addBodyElement(QName qname)
                        throws SOAPException
        Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
        Parameters:
        qname - a QName object with the qname for the new SOAPBodyElement object
        Returns:
        the new SOAPBodyElement object
        Throws:
        SOAPException - if a SOAP error occurs
        Since:
        SAAJ 1.3
        See Also:
        addBodyElement(Name)

      • addDocument

        SOAPBodyElement addDocument(Document document)
                     throws SOAPException
        Adds the root node of the DOM Document to this SOAPBody object.

        Calling this method invalidates the document parameter. The client application should discard all references to this Document and its contents upon calling addDocument. The behavior of an application that continues to use such references is undefined.

        Parameters:
        document - the Document object whose root node will be added to this SOAPBody.
        Returns:
        the SOAPBodyElement that represents the root node that was added.
        Throws:
        SOAPException - if the Document cannot be added
        Since:
        SAAJ 1.2

      • extractContentAsDocument

        Document extractContentAsDocument()
                           throws SOAPException
        Creates a new DOM Document and sets the first child of this SOAPBody as it's document element. The child SOAPElement is removed as part of the process.
        Returns:
        the Document representation of the SOAPBody content.
        Throws:
        SOAPException - if there is not exactly one child SOAPElement of the SOAPBody.
        Since:
        SAAJ 1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPBodyElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPBodyElement

  • All Superinterfaces:
    Element, Node, SOAPElement
    All Known Subinterfaces:
    SOAPFault

    public interface SOAPBodyElement
extends SOAPElement
    A SOAPBodyElement object represents the contents in a SOAPBody object. The SOAPFault interface is a SOAPBodyElement object that has been defined.

    A new SOAPBodyElement object can be created and added to a SOAPBody object with the SOAPBody method addBodyElement. In the following line of code, sb is a SOAPBody object, and myName is a Name object.

        SOAPBodyElement sbe = sb.addBodyElement(myName);

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPConnection (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPConnection

  • java.lang.Object
    • javax.xml.soap.SOAPConnection

  • public abstract class SOAPConnection
extends Object
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

    The SOAPConnection class is optional. Some implementations may not implement this interface in which case the call to SOAPConnectionFactory.newInstance() (see below) will throw an UnsupportedOperationException.

    A client can obtain a SOAPConnection object using a SOAPConnectionFactory object as in the following example:

          SOAPConnectionFactory factory = SOAPConnectionFactory.newInstance();
      SOAPConnection con = factory.createConnection();
    A SOAPConnection object can be used to send messages directly to a URL following the request/response paradigm. That is, messages are sent using the method call, which sends the message and then waits until it gets a reply.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPConnection()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract SOAPMessage call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract void close()
      Closes this SOAPConnection object.
      SOAPMessage get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SOAPConnection

        public SOAPConnection()

    • Method Detail

      • call

        public abstract SOAPMessage call(SOAPMessage request,
                                 Object to)
                          throws SOAPException
        Sends the given message to the specified endpoint and blocks until it has returned the response.
        Parameters:
        request - the SOAPMessage object to be sent
        to - an Object that identifies where the message should be sent. It is required to support Objects of type java.lang.String, java.net.URL, and when JAXM is present javax.xml.messaging.URLEndpoint
        Returns:
        the SOAPMessage object that is the response to the message that was sent
        Throws:
        SOAPException - if there is a SOAP error

      • get

        public SOAPMessage get(Object to)
                throws SOAPException
        Gets a message from a specific endpoint and blocks until it receives,
        Parameters:
        to - an Object that identifies where the request should be sent. Objects of type java.lang.String and java.net.URL must be supported.
        Returns:
        the SOAPMessage object that is the response to the get message request
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3

      • close

        public abstract void close()
                    throws SOAPException
        Closes this SOAPConnection object.
        Throws:
        SOAPException - if there is a SOAP error
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPConnectionFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPConnectionFactory

  • java.lang.Object
    • javax.xml.soap.SOAPConnectionFactory

  • public abstract class SOAPConnectionFactory
extends Object
    A factory for creating SOAPConnection objects. Implementation of this class is optional. If SOAPConnectionFactory.newInstance() throws an UnsupportedOperationException then the implementation does not support the SAAJ communication infrastructure. Otherwise SOAPConnection objects can be created by calling createConnection() on the newly created SOAPConnectionFactory object.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPConnectionFactory()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract SOAPConnection createConnection()
      Create a new SOAPConnection.
      static SOAPConnectionFactory newInstance()
      Creates an instance of the default SOAPConnectionFactory object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SOAPConnectionFactory

        public SOAPConnectionFactory()

    • Method Detail

      • newInstance

        public static SOAPConnectionFactory newInstance()
                                         throws SOAPException,
                                                UnsupportedOperationException
        Creates an instance of the default SOAPConnectionFactory object.
        Returns:
        a new instance of a default SOAPConnectionFactory object
        Throws:
        SOAPException - if there was an error creating the SOAPConnectionFactory
        UnsupportedOperationException - if newInstance is not supported.

      • createConnection

        public abstract SOAPConnection createConnection()
                                         throws SOAPException
        Create a new SOAPConnection.
        Returns:
        the new SOAPConnection object.
        Throws:
        SOAPException - if there was an exception creating the SOAPConnection object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPConstants

  • public interface SOAPConstants
    The definition of constants pertaining to the SOAP protocol.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT_SOAP_PROTOCOL
      The default protocol: SOAP 1.1 for backwards compatibility.
      static String DYNAMIC_SOAP_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
      static String SOAP_1_1_CONTENT_TYPE
      The media type of the Content-Type MIME header in SOAP 1.1.
      static String SOAP_1_1_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
      static String SOAP_1_2_CONTENT_TYPE
      The media type of the Content-Type MIME header in SOAP 1.2.
      static String SOAP_1_2_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
      static QName SOAP_DATAENCODINGUNKNOWN_FAULT
      SOAP 1.2 DataEncodingUnknown Fault
      static String SOAP_ENV_PREFIX
      The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
      static QName SOAP_MUSTUNDERSTAND_FAULT
      SOAP 1.2 MustUnderstand Fault
      static QName SOAP_RECEIVER_FAULT
      SOAP 1.2 Receiver Fault
      static QName SOAP_SENDER_FAULT
      SOAP 1.2 Sender Fault
      static QName SOAP_VERSIONMISMATCH_FAULT
      SOAP 1.2 VersionMismatch Fault
      static String URI_NS_SOAP_1_1_ENVELOPE
      The namespace identifier for the SOAP 1.1 envelope.
      static String URI_NS_SOAP_1_2_ENCODING
      The namespace identifier for the SOAP 1.2 encoding.
      static String URI_NS_SOAP_1_2_ENVELOPE
      The namespace identifier for the SOAP 1.2 envelope.
      static String URI_NS_SOAP_ENCODING
      The namespace identifier for the SOAP 1.1 encoding.
      static String URI_NS_SOAP_ENVELOPE
      The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
      static String URI_SOAP_1_2_ROLE_NEXT
      The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
      static String URI_SOAP_1_2_ROLE_NONE
      The URI specifying the role None in SOAP 1.2.
      static String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
      The URI identifying the ultimate receiver of the SOAP 1.2 message.
      static String URI_SOAP_ACTOR_NEXT
      The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

    • Field Detail

      • DYNAMIC_SOAP_PROTOCOL

        static final String DYNAMIC_SOAP_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method. If no Content-Type header is passed then the createMessage may throw an IllegalArgumentException or, in the case of the no argument version of createMessage, an UnsupportedOperationException.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_1_PROTOCOL

        static final String SOAP_1_1_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_2_PROTOCOL

        static final String SOAP_1_2_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • DEFAULT_SOAP_PROTOCOL

        static final String DEFAULT_SOAP_PROTOCOL
        The default protocol: SOAP 1.1 for backwards compatibility.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_NS_SOAP_1_1_ENVELOPE

        static final String URI_NS_SOAP_1_1_ENVELOPE
        The namespace identifier for the SOAP 1.1 envelope.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_NS_SOAP_1_2_ENVELOPE

        static final String URI_NS_SOAP_1_2_ENVELOPE
        The namespace identifier for the SOAP 1.2 envelope.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_NS_SOAP_ENVELOPE

        static final String URI_NS_SOAP_ENVELOPE
        The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
        See Also:
        Constant Field Values

      • URI_NS_SOAP_ENCODING

        static final String URI_NS_SOAP_ENCODING
        The namespace identifier for the SOAP 1.1 encoding. An attribute named encodingStyle in the URI_NS_SOAP_ENVELOPE namespace and set to the value URI_NS_SOAP_ENCODING can be added to an element to indicate that it is encoded using the rules in section 5 of the SOAP 1.1 specification.
        See Also:
        Constant Field Values

      • URI_NS_SOAP_1_2_ENCODING

        static final String URI_NS_SOAP_1_2_ENCODING
        The namespace identifier for the SOAP 1.2 encoding.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_1_CONTENT_TYPE

        static final String SOAP_1_1_CONTENT_TYPE
        The media type of the Content-Type MIME header in SOAP 1.1.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_1_2_CONTENT_TYPE

        static final String SOAP_1_2_CONTENT_TYPE
        The media type of the Content-Type MIME header in SOAP 1.2.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_SOAP_ACTOR_NEXT

        static final String URI_SOAP_ACTOR_NEXT
        The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

        This value can be passed to
SOAPHeader.examineMustUnderstandHeaderElements(String),
SOAPHeader.examineHeaderElements(String) and
SOAPHeader.extractHeaderElements(String)

        See Also:
        Constant Field Values

      • URI_SOAP_1_2_ROLE_NEXT

        static final String URI_SOAP_1_2_ROLE_NEXT
        The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_SOAP_1_2_ROLE_NONE

        static final String URI_SOAP_1_2_ROLE_NONE
        The URI specifying the role None in SOAP 1.2.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER

        static final String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
        The URI identifying the ultimate receiver of the SOAP 1.2 message.
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_ENV_PREFIX

        static final String SOAP_ENV_PREFIX
        The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
        Since:
        SAAJ 1.3
        See Also:
        Constant Field Values

      • SOAP_VERSIONMISMATCH_FAULT

        static final QName SOAP_VERSIONMISMATCH_FAULT
        SOAP 1.2 VersionMismatch Fault
        Since:
        SAAJ 1.3

      • SOAP_MUSTUNDERSTAND_FAULT

        static final QName SOAP_MUSTUNDERSTAND_FAULT
        SOAP 1.2 MustUnderstand Fault
        Since:
        SAAJ 1.3

      • SOAP_DATAENCODINGUNKNOWN_FAULT

        static final QName SOAP_DATAENCODINGUNKNOWN_FAULT
        SOAP 1.2 DataEncodingUnknown Fault
        Since:
        SAAJ 1.3

      • SOAP_SENDER_FAULT

        static final QName SOAP_SENDER_FAULT
        SOAP 1.2 Sender Fault
        Since:
        SAAJ 1.3

      • SOAP_RECEIVER_FAULT

        static final QName SOAP_RECEIVER_FAULT
        SOAP 1.2 Receiver Fault
        Since:
        SAAJ 1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPElement

  • All Superinterfaces:
    Element, Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement

    public interface SOAPElement
extends Node, Element
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification. This interface serves as the base interface for those objects that are specifically prescribed by a SOAP specification.

    Methods in this interface that are required to return SAAJ specific objects may "silently" replace nodes in the tree as required to successfully return objects of the correct type. See getChildElements() and javax.xml.soap for details.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      SOAPElement addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      SOAPElement addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPElement addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      QName createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      Iterator getAllAttributes()
      Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
      Iterator getAllAttributesAsQNames()
      Returns an Iterator over all of the attributes in this SOAPElement as QName objects.
      String getAttributeValue(Name name)
      Returns the value of the attribute with the specified name.
      String getAttributeValue(QName qname)
      Returns the value of the attribute with the specified qname.
      Iterator getChildElements()
      Returns an Iterator over all the immediate child Nodes of this element.
      Iterator getChildElements(Name name)
      Returns an Iterator over all the immediate child Nodes of this element with the specified name.
      Iterator getChildElements(QName qname)
      Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
      Name getElementName()
      Returns the name of this SOAPElement object.
      QName getElementQName()
      Returns the qname of this SOAPElement object.
      String getEncodingStyle()
      Returns the encoding style for this SOAPElement object.
      Iterator getNamespacePrefixes()
      Returns an Iterator over the namespace prefix Strings declared by this element.
      String getNamespaceURI(String prefix)
      Returns the URI of the namespace that has the given prefix.
      Iterator getVisibleNamespacePrefixes()
      Returns an Iterator over the namespace prefix Strings visible to this element.
      boolean removeAttribute(Name name)
      Removes the attribute with the specified name.
      boolean removeAttribute(QName qname)
      Removes the attribute with the specified qname.
      void removeContents()
      Detaches all children of this SOAPElement.
      boolean removeNamespaceDeclaration(String prefix)
      Removes the namespace declaration corresponding to the given prefix.
      SOAPElement setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void setEncodingStyle(String encodingStyle)
      Sets the encoding style for this SOAPElement object to one specified.

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addChildElement

        SOAPElement addChildElement(Name name)
                     throws SOAPException
        Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.

        This method may be deprecated in a future release of SAAJ in favor of addChildElement(javax.xml.namespace.QName)

        Parameters:
        name - a Name object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        addChildElement(javax.xml.namespace.QName)

      • addChildElement

        SOAPElement addChildElement(QName qname)
                     throws SOAPException
        Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object. The namespace, localname and prefix of the new SOAPElement are all taken from the qname argument.
        Parameters:
        qname - a QName object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        Since:
        SAAJ 1.3
        See Also:
        addChildElement(Name)

      • addChildElement

        SOAPElement addChildElement(String localName)
                     throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object. The new SOAPElement inherits any in-scope default namespace.
        Parameters:
        localName - a String giving the local name for the element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(String localName,
                            String prefix)
                     throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - a String giving the namespace prefix for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if the prefix is not valid in the context of this SOAPElement or if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(String localName,
                            String prefix,
                            String uri)
                     throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - a String giving the namespace prefix for the new element
        uri - a String giving the URI of the namespace to which the new element belongs
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(SOAPElement element)
                     throws SOAPException
        Add a SOAPElement as a child of this SOAPElement instance. The SOAPElement is expected to be created by a SOAPFactory. Callers should not rely on the element instance being added as is into the XML tree. Implementations could end up copying the content of the SOAPElement passed into an instance of a different SOAPElement implementation. For instance if addChildElement() is called on a SOAPHeader, element will be copied into an instance of a SOAPHeaderElement.

        The fragment rooted in element is either added as a whole or not at all, if there was an error.

        The fragment rooted in element cannot contain elements named "Envelope", "Header" or "Body" and in the SOAP namespace. Any namespace prefixes present in the fragment should be fully resolved using appropriate namespace declarations within the fragment itself.

        Parameters:
        element - the SOAPElement to be added as a new child
        Returns:
        an instance representing the new SOAP element that was actually added to the tree.
        Throws:
        SOAPException - if there was an error in adding this element as a child

      • removeContents

        void removeContents()
        Detaches all children of this SOAPElement.

        This method is useful for rolling back the construction of partially completed SOAPHeaders and SOAPBodys in preparation for sending a fault when an error condition is detected. It is also useful for recycling portions of a document within a SOAP message.

        Since:
        SAAJ 1.2

      • addTextNode

        SOAPElement addTextNode(String text)
                 throws SOAPException
        Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
        Parameters:
        text - a String object with the textual content to be added
        Returns:
        the SOAPElement object into which the new Text object was inserted
        Throws:
        SOAPException - if there is an error in creating the new Text object or if it is not legal to attach it as a child to this SOAPElement

      • addAttribute

        SOAPElement addAttribute(Name name,
                         String value)
                  throws SOAPException
        Adds an attribute with the specified name and value to this SOAPElement object.
        Parameters:
        name - a Name object with the name of the attribute
        value - a String giving the value of the attribute
        Returns:
        the SOAPElement object into which the attribute was inserted
        Throws:
        SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with Name name on this SOAPElement.
        See Also:
        addAttribute(javax.xml.namespace.QName, String)

      • addAttribute

        SOAPElement addAttribute(QName qname,
                         String value)
                  throws SOAPException
        Adds an attribute with the specified name and value to this SOAPElement object.
        Parameters:
        qname - a QName object with the name of the attribute
        value - a String giving the value of the attribute
        Returns:
        the SOAPElement object into which the attribute was inserted
        Throws:
        SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with QName qname on this SOAPElement.
        Since:
        SAAJ 1.3
        See Also:
        addAttribute(Name, String)

      • addNamespaceDeclaration

        SOAPElement addNamespaceDeclaration(String prefix,
                                    String uri)
                             throws SOAPException
        Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
        Parameters:
        prefix - a String giving the prefix of the namespace
        uri - a String giving the uri of the namespace
        Returns:
        the SOAPElement object into which this namespace declaration was inserted.
        Throws:
        SOAPException - if there is an error in creating the namespace

      • getAttributeValue

        String getAttributeValue(Name name)
        Returns the value of the attribute with the specified name.
        Parameters:
        name - a Name object with the name of the attribute
        Returns:
        a String giving the value of the specified attribute, Null if there is no such attribute
        See Also:
        getAttributeValue(javax.xml.namespace.QName)

      • getAttributeValue

        String getAttributeValue(QName qname)
        Returns the value of the attribute with the specified qname.
        Parameters:
        qname - a QName object with the qname of the attribute
        Returns:
        a String giving the value of the specified attribute, Null if there is no such attribute
        Since:
        SAAJ 1.3
        See Also:
        getAttributeValue(Name)

      • getAllAttributes

        Iterator getAllAttributes()
        Returns an Iterator over all of the attribute Name objects in this SOAPElement object. The iterator can be used to get the attribute names, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.
        Returns:
        an iterator over the names of the attributes
        See Also:
        getAllAttributesAsQNames()

      • getAllAttributesAsQNames

        Iterator getAllAttributesAsQNames()
        Returns an Iterator over all of the attributes in this SOAPElement as QName objects. The iterator can be used to get the attribute QName, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.
        Returns:
        an iterator over the QNames of the attributes
        Since:
        SAAJ 1.3
        See Also:
        getAllAttributes()

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Returns the URI of the namespace that has the given prefix.
        Parameters:
        prefix - a String giving the prefix of the namespace for which to search
        Returns:
        a String with the uri of the namespace that has the given prefix

      • getNamespacePrefixes

        Iterator getNamespacePrefixes()
        Returns an Iterator over the namespace prefix Strings declared by this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.
        Returns:
        an iterator over the namespace prefixes in this SOAPElement object

      • getVisibleNamespacePrefixes

        Iterator getVisibleNamespacePrefixes()
        Returns an Iterator over the namespace prefix Strings visible to this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.
        Returns:
        an iterator over the namespace prefixes are within scope of this SOAPElement object
        Since:
        SAAJ 1.2

      • createQName

        QName createQName(String localName,
                  String prefix)
           throws SOAPException
        Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement. The remaining elements of the new QName are taken directly from the parameters, localName and prefix.
        Parameters:
        localName - a String containing the local part of the name.
        prefix - a String containing the prefix for the name.
        Returns:
        a QName with the specified localName and prefix, and with a namespace that is associated with the prefix in the context of this SOAPElement. This namespace will be the same as the one that would be returned by getNamespaceURI(String) if it were given prefix as it's parameter.
        Throws:
        SOAPException - if the QName cannot be created.
        Since:
        SAAJ 1.3

      • getElementName

        Name getElementName()
        Returns the name of this SOAPElement object.
        Returns:
        a Name object with the name of this SOAPElement object

      • getElementQName

        QName getElementQName()
        Returns the qname of this SOAPElement object.
        Returns:
        a QName object with the qname of this SOAPElement object
        Since:
        SAAJ 1.3
        See Also:
        getElementName()

      • setElementQName

        SOAPElement setElementQName(QName newName)
                     throws SOAPException
        Changes the name of this Element to newName if possible. SOAP Defined elements such as SOAPEnvelope, SOAPHeader, SOAPBody etc. cannot have their names changed using this method. Any attempt to do so will result in a SOAPException being thrown.

        Callers should not rely on the element instance being renamed as is. Implementations could end up copying the content of the SOAPElement to a renamed instance.

        Parameters:
        newName - the new name for the Element.
        Returns:
        The renamed Node
        Throws:
        SOAPException - if changing the name of this Element is not allowed.
        Since:
        SAAJ 1.3

      • removeAttribute

        boolean removeAttribute(Name name)
        Removes the attribute with the specified name.
        Parameters:
        name - the Name object with the name of the attribute to be removed
        Returns:
        true if the attribute was removed successfully; false if it was not
        See Also:
        removeAttribute(javax.xml.namespace.QName)

      • removeAttribute

        boolean removeAttribute(QName qname)
        Removes the attribute with the specified qname.
        Parameters:
        qname - the QName object with the qname of the attribute to be removed
        Returns:
        true if the attribute was removed successfully; false if it was not
        Since:
        SAAJ 1.3
        See Also:
        removeAttribute(Name)

      • removeNamespaceDeclaration

        boolean removeNamespaceDeclaration(String prefix)
        Removes the namespace declaration corresponding to the given prefix.
        Parameters:
        prefix - a String giving the prefix for which to search
        Returns:
        true if the namespace declaration was removed successfully; false if it was not

      • getChildElements

        Iterator getChildElements()
        Returns an Iterator over all the immediate child Nodes of this element. This includes javax.xml.soap.Text objects as well as SOAPElement objects.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        Returns:
        an iterator with the content of this SOAPElement object

      • getChildElements

        Iterator getChildElements(Name name)
        Returns an Iterator over all the immediate child Nodes of this element with the specified name. All of these children will be SOAPElement nodes.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        Parameters:
        name - a Name object with the name of the child elements to be returned
        Returns:
        an Iterator object over all the elements in this SOAPElement object with the specified name
        See Also:
        getChildElements(javax.xml.namespace.QName)

      • getChildElements

        Iterator getChildElements(QName qname)
        Returns an Iterator over all the immediate child Nodes of this element with the specified qname. All of these children will be SOAPElement nodes.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        Parameters:
        qname - a QName object with the qname of the child elements to be returned
        Returns:
        an Iterator object over all the elements in this SOAPElement object with the specified qname
        Since:
        SAAJ 1.3
        See Also:
        getChildElements(Name)

      • setEncodingStyle

        void setEncodingStyle(String encodingStyle)
               throws SOAPException
        Sets the encoding style for this SOAPElement object to one specified.
        Parameters:
        encodingStyle - a String giving the encoding style
        Throws:
        IllegalArgumentException - if there was a problem in the encoding style being set.
        SOAPException - if setting the encodingStyle is invalid for this SOAPElement.
        See Also:
        getEncodingStyle()

      • getEncodingStyle

        String getEncodingStyle()
        Returns the encoding style for this SOAPElement object.
        Returns:
        a String giving the encoding style
        See Also:
        setEncodingStyle(java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPElementFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPElementFactory

  • java.lang.Object
    • javax.xml.soap.SOAPElementFactory
  • Deprecated.
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.

    public class SOAPElementFactory
extends Object
    SOAPElementFactory is a factory for XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeader or SOAPBody or SOAPEnvelope.

    Elements created using this factory do not have the properties of an element that lives inside a SOAP header document. These elements are copied into the XML document tree when they are inserted.

    See Also:
    SOAPFactory

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      SOAPElement create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      static SOAPElementFactory newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • create

        public SOAPElement create(Name name)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
        Create a SOAPElement object initialized with the given Name object.
        Parameters:
        name - a Name object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        SOAPFactory.createElement(javax.xml.soap.Name), SOAPFactory.createElement(javax.xml.namespace.QName)

      • create

        public SOAPElement create(String localName)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
        Create a SOAPElement object initialized with the given local name.
        Parameters:
        localName - a String giving the local name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        SOAPFactory.createElement(java.lang.String)

      • create

        public SOAPElement create(String localName,
                          String prefix,
                          String uri)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
        Create a new SOAPElement object with the given local name, prefix and uri.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - the prefix for this SOAPElement
        uri - a String giving the URI of the namespace to which the new element belongs
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)

      • newInstance

        public static SOAPElementFactory newInstance()
                                      throws SOAPException
        Deprecated.
        Creates a new instance of SOAPElementFactory.
        Returns:
        a new instance of a SOAPElementFactory
        Throws:
        SOAPException - if there was an error creating the default SOAPElementFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPEnvelope (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPEnvelope

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPEnvelope
extends SOAPElement
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object. By default, a SOAPMessage object is created with a SOAPPart object that has a SOAPEnvelope object. The SOAPEnvelope object by default has an empty SOAPBody object and an empty SOAPHeader object. The SOAPBody object is required, and the SOAPHeader object, though optional, is used in the majority of cases. If the SOAPHeader object is not needed, it can be deleted, which is shown later.

    A client can access the SOAPHeader and SOAPBody objects by calling the methods SOAPEnvelope.getHeader and SOAPEnvelope.getBody. The following lines of code use these two methods after starting with the SOAPMessage object message to get the SOAPPart object sp, which is then used to get the SOAPEnvelope object se.

         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPHeader sh = se.getHeader();
     SOAPBody sb = se.getBody();

    It is possible to change the body or header of a SOAPEnvelope object by retrieving the current one, deleting it, and then adding a new body or header. The javax.xml.soap.Node method deleteNode deletes the XML element (node) on which it is called. For example, the following line of code deletes the SOAPBody object that is retrieved by the method getBody.

          se.getBody().detachNode();
    To create a SOAPHeader object to replace the one that was removed, a client uses the method SOAPEnvelope.addHeader, which creates a new header and adds it to the SOAPEnvelope object. Similarly, the method addBody creates a new SOAPBody object and adds it to the SOAPEnvelope object. The following code fragment retrieves the current header, removes it, and adds a new one. Then it retrieves the current body, removes it, and adds a new one.
         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     se.getHeader().detachNode();
     SOAPHeader sh = se.addHeader();
     se.getBody().detachNode();
     SOAPBody sb = se.addBody();
    It is an error to add a SOAPBody or SOAPHeader object if one already exists.

    The SOAPEnvelope interface provides three methods for creating Name objects. One method creates Name objects with a local name, a namespace prefix, and a namesapce URI. The second method creates Name objects with a local name and a namespace prefix, and the third creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

         Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      SOAPBody addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPHeader addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      Name createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      SOAPBody getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      SOAPHeader getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • createName

        Name createName(String localName,
                String prefix,
                String uri)
         throws SOAPException
        Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

        This factory method creates Name objects for use in the SOAP/XML document.

        Parameters:
        localName - a String giving the local name
        prefix - a String giving the prefix of the namespace
        uri - a String giving the URI of the namespace
        Returns:
        a Name object initialized with the given local name, namespace prefix, and namespace URI
        Throws:
        SOAPException - if there is a SOAP error

      • createName

        Name createName(String localName)
         throws SOAPException
        Creates a new Name object initialized with the given local name.

        This factory method creates Name objects for use in the SOAP/XML document.

        Parameters:
        localName - a String giving the local name
        Returns:
        a Name object initialized with the given local name
        Throws:
        SOAPException - if there is a SOAP error

      • getHeader

        SOAPHeader getHeader()
              throws SOAPException
        Returns the SOAPHeader object for this SOAPEnvelope object.

        A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPHeader object. As a result, the method getHeader will always return a SOAPHeader object unless the header has been removed and a new one has not been added.

        Returns:
        the SOAPHeader object or null if there is none
        Throws:
        SOAPException - if there is a problem obtaining the SOAPHeader object

      • getBody

        SOAPBody getBody()
          throws SOAPException
        Returns the SOAPBody object associated with this SOAPEnvelope object.

        A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPBody object. As a result, the method getBody will always return a SOAPBody object unless the body has been removed and a new one has not been added.

        Returns:
        the SOAPBody object for this SOAPEnvelope object or null if there is none
        Throws:
        SOAPException - if there is a problem obtaining the SOAPBody object

      • addHeader

        SOAPHeader addHeader()
              throws SOAPException
        Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.

        It is illegal to add a header when the envelope already contains a header. Therefore, this method should be called only after the existing header has been removed.

        Returns:
        the new SOAPHeader object
        Throws:
        SOAPException - if this SOAPEnvelope object already contains a valid SOAPHeader object

      • addBody

        SOAPBody addBody()
          throws SOAPException
        Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.

        It is illegal to add a body when the envelope already contains a body. Therefore, this method should be called only after the existing body has been removed.

        Returns:
        the new SOAPBody object
        Throws:
        SOAPException - if this SOAPEnvelope object already contains a valid SOAPBody object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.soap.SOAPException
  • All Implemented Interfaces:
    Serializable

    public class SOAPException
extends Exception
    An exception that signals that a SOAP exception has occurred. A SOAPException object may contain a String that gives the reason for the exception, an embedded Throwable object, or both. This class provides methods for retrieving reason messages and for retrieving the embedded Throwable object.

    Typical reasons for throwing a SOAPException object are problems such as difficulty setting a header, not being able to send a message, and not being able to get a connection with the provider. Reasons for embedding a Throwable object include problems such as input/output errors or a parsing problem, such as an error in parsing a header.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPException()
      Constructs a SOAPException object with no reason or embedded Throwable object.
      SOAPException(String reason)
      Constructs a SOAPException object with the given String as the reason for the exception being thrown.
      SOAPException(String reason, Throwable cause)
      Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
      SOAPException(Throwable cause)
      Constructs a SOAPException object initialized with the given Throwable object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the Throwable object embedded in this SOAPException if there is one.
      String getMessage()
      Returns the detail message for this SOAPException object.
      Throwable initCause(Throwable cause)
      Initializes the cause field of this SOAPException object with the given Throwable object.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SOAPException

        public SOAPException()
        Constructs a SOAPException object with no reason or embedded Throwable object.

      • SOAPException

        public SOAPException(String reason)
        Constructs a SOAPException object with the given String as the reason for the exception being thrown.
        Parameters:
        reason - a description of what caused the exception

      • SOAPException

        public SOAPException(String reason,
                     Throwable cause)
        Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
        Parameters:
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this SOAPException object

      • SOAPException

        public SOAPException(Throwable cause)
        Constructs a SOAPException object initialized with the given Throwable object.

    • Method Detail

      • getMessage

        public String getMessage()
        Returns the detail message for this SOAPException object.

        If there is an embedded Throwable object, and if the SOAPException object has no detail message of its own, this method will return the detail message from the embedded Throwable object.

        Overrides:
        getMessage in class Throwable
        Returns:
        the error or warning message for this SOAPException or, if it has none, the message of the embedded Throwable object, if there is one

      • getCause

        public Throwable getCause()
        Returns the Throwable object embedded in this SOAPException if there is one. Otherwise, this method returns null.
        Overrides:
        getCause in class Throwable
        Returns:
        the embedded Throwable object or null if there is none

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause field of this SOAPException object with the given Throwable object.

        This method can be called at most once. It is generally called from within the constructor or immediately after the constructor has returned a new SOAPException object. If this SOAPException object was created with the constructor SOAPException(Throwable) or SOAPException(String,Throwable), meaning that its cause field already has a value, this method cannot be called even once.

        Overrides:
        initCause in class Throwable
        Parameters:
        cause - the Throwable object that caused this SOAPException object to be thrown. The value of this parameter is saved for later retrieval by the getCause() method. A null value is permitted and indicates that the cause is nonexistent or unknown.
        Returns:
        a reference to this SOAPException instance
        Throws:
        IllegalArgumentException - if cause is this Throwable object. (A Throwable object cannot be its own cause.)
        IllegalStateException - if the cause for this SOAPException object has already been initialized
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPFactory

  • java.lang.Object
    • javax.xml.soap.SOAPFactory

  • public abstract class SOAPFactory
extends Object
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree. SOAPFactory can be used to create XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeaderElement or SOAPBodyElement or SOAPEnvelope or other SOAPElement objects. SOAPFactory also has methods to create javax.xml.soap.Detail objects as well as java.xml.soap.Name objects.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPFactory()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Detail createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      SOAPElement createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      abstract SOAPFault createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      abstract Name createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      static SOAPFactory newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPFactory newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SOAPFactory

        public SOAPFactory()

    • Method Detail

      • createElement

        public SOAPElement createElement(Element domElement)
                          throws SOAPException
        Creates a SOAPElement object from an existing DOM Element. If the DOM Element that is passed in as an argument is already a SOAPElement then this method must return it unmodified without any further work. Otherwise, a new SOAPElement is created and a deep copy is made of the domElement argument. The concrete type of the return value will depend on the name of the domElement argument. If any part of the tree rooted in domElement violates SOAP rules, a SOAPException will be thrown.
        Parameters:
        domElement - - the Element to be copied.
        Returns:
        a new SOAPElement that is a copy of domElement.
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        Since:
        SAAJ 1.3

      • createElement

        public abstract SOAPElement createElement(Name name)
                                   throws SOAPException
        Creates a SOAPElement object initialized with the given Name object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        Parameters:
        name - a Name object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        See Also:
        createElement(javax.xml.namespace.QName)

      • createElement

        public SOAPElement createElement(QName qname)
                          throws SOAPException
        Creates a SOAPElement object initialized with the given QName object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        Parameters:
        qname - a QName object with the XML name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object
        Since:
        SAAJ 1.3
        See Also:
        createElement(Name)

      • createElement

        public abstract SOAPElement createElement(String localName)
                                   throws SOAPException
        Creates a SOAPElement object initialized with the given local name.
        Parameters:
        localName - a String giving the local name for the new element
        Returns:
        the new SOAPElement object that was created
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • createElement

        public abstract SOAPElement createElement(String localName,
                                          String prefix,
                                          String uri)
                                   throws SOAPException
        Creates a new SOAPElement object with the given local name, prefix and uri. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        Parameters:
        localName - a String giving the local name for the new element
        prefix - the prefix for this SOAPElement
        uri - a String giving the URI of the namespace to which the new element belongs
        Throws:
        SOAPException - if there is an error in creating the SOAPElement object

      • createDetail

        public abstract Detail createDetail()
                             throws SOAPException
        Creates a new Detail object which serves as a container for DetailEntry objects.

        This factory method creates Detail objects for use in situations where it is not practical to use the SOAPFault abstraction.

        Returns:
        a Detail object
        Throws:
        SOAPException - if there is a SOAP error
        UnsupportedOperationException - if the protocol specified for the SOAPFactory was DYNAMIC_SOAP_PROTOCOL

      • createFault

        public abstract SOAPFault createFault(String reasonText,
                                      QName faultCode)
                               throws SOAPException
        Creates a new SOAPFault object initialized with the given reasonText and faultCode
        Parameters:
        reasonText - the ReasonText/FaultString for the fault
        faultCode - the FaultCode for the fault
        Returns:
        a SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3

      • createFault

        public abstract SOAPFault createFault()
                               throws SOAPException
        Creates a new default SOAPFault object
        Returns:
        a SOAPFault object
        Throws:
        SOAPException - if there is a SOAP error
        Since:
        SAAJ 1.3

      • createName

        public abstract Name createName(String localName,
                                String prefix,
                                String uri)
                         throws SOAPException
        Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

        This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

        Parameters:
        localName - a String giving the local name
        prefix - a String giving the prefix of the namespace
        uri - a String giving the URI of the namespace
        Returns:
        a Name object initialized with the given local name, namespace prefix, and namespace URI
        Throws:
        SOAPException - if there is a SOAP error

      • createName

        public abstract Name createName(String localName)
                         throws SOAPException
        Creates a new Name object initialized with the given local name.

        This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

        Parameters:
        localName - a String giving the local name
        Returns:
        a Name object initialized with the given local name
        Throws:
        SOAPException - if there is a SOAP error

      • newInstance

        public static SOAPFactory newInstance()
                               throws SOAPException
        Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load:
        • Use the javax.xml.soap.SOAPFactory system property.
        • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.SOAPFactory in jars available to the runtime.
        • Use the SAAJMetaFactory instance to locate the SOAPFactory implementation class.
        Returns:
        a new instance of a SOAPFactory
        Throws:
        SOAPException - if there was an error creating the default SOAPFactory
        See Also:
        SAAJMetaFactory

      • newInstance

        public static SOAPFactory newInstance(String protocol)
                               throws SOAPException
        Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
        Parameters:
        protocol - a string constant representing the protocol of the specified SOAP factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
        Returns:
        a new instance of a SOAPFactory
        Throws:
        SOAPException - if there was an error creating the specified SOAPFactory
        Since:
        SAAJ 1.3
        See Also:
        SAAJMetaFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPFault (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPFault

  • All Superinterfaces:
    Element, Node, SOAPBodyElement, SOAPElement

    public interface SOAPFault
extends SOAPBodyElement
    An element in the SOAPBody object that contains error and/or status information. This information may relate to errors in the SOAPMessage object or to problems that are not related to the content in the message itself. Problems not related to the message itself are generally errors in processing, such as the inability to communicate with an upstream server.

    Depending on the protocol specified while creating the MessageFactory instance, a SOAPFault has sub-elements as defined in the SOAP 1.1/SOAP 1.2 specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Detail addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      void addFaultReasonText(String text, Locale locale)
      Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
      void appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      Detail getDetail()
      Returns the optional detail element for this SOAPFault object.
      String getFaultActor()
      Gets the fault actor for this SOAPFault object.
      String getFaultCode()
      Gets the fault code for this SOAPFault object.
      Name getFaultCodeAsName()
      Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
      QName getFaultCodeAsQName()
      Gets the fault code for this SOAPFault object as a QName object.
      String getFaultNode()
      Returns the optional Node element value for this SOAPFault object.
      Iterator getFaultReasonLocales()
      Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
      String getFaultReasonText(Locale locale)
      Returns the Reason Text associated with the given Locale.
      Iterator getFaultReasonTexts()
      Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
      String getFaultRole()
      Returns the optional Role element value for this SOAPFault object.
      String getFaultString()
      Gets the fault string for this SOAPFault object.
      Locale getFaultStringLocale()
      Gets the locale of the fault string for this SOAPFault object.
      Iterator getFaultSubcodes()
      Gets the Subcodes for this SOAPFault as an iterator over QNames.
      boolean hasDetail()
      Returns true if this SOAPFault has a Detail subelement and false otherwise.
      void removeAllFaultSubcodes()
      Removes any Subcodes that may be contained by this SOAPFault.
      void setFaultActor(String faultActor)
      Sets this SOAPFault object with the given fault actor.
      void setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void setFaultCode(String faultCode)
      Sets this SOAPFault object with the give fault code.
      void setFaultNode(String uri)
      Creates or replaces any existing Node element value for this SOAPFault object.
      void setFaultRole(String uri)
      Creates or replaces any existing Role element value for this SOAPFault object.
      void setFaultString(String faultString)
      Sets the fault string for this SOAPFault object to the given string.
      void setFaultString(String faultString, Locale locale)
      Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • setFaultCode

        void setFaultCode(Name faultCodeQName)
           throws SOAPException
        Sets this SOAPFault object with the given fault code.

        Fault codes, which give information about the fault, are defined in the SOAP 1.1 specification. A fault code is mandatory and must be of type Name. This method provides a convenient way to set a fault code. For example,

         SOAPEnvelope se = ...;
 // Create a qualified name in the SOAP namespace with a localName
 // of "Client". Note that prefix parameter is optional and is null
 // here which causes the implementation to use an appropriate prefix.
 Name qname = se.createName("Client", null,
                            SOAPConstants.URI_NS_SOAP_ENVELOPE);
 SOAPFault fault = ...;
 fault.setFaultCode(qname);
        It is preferable to use this method over setFaultCode(String).
        Parameters:
        faultCodeQName - a Name object giving the fault code to be set. It must be namespace qualified.
        Throws:
        SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
        Since:
        SAAJ 1.2
        See Also:
        getFaultCodeAsName()

      • setFaultCode

        void setFaultCode(QName faultCodeQName)
           throws SOAPException
        Sets this SOAPFault object with the given fault code. It is preferable to use this method over setFaultCode(Name).
        Parameters:
        faultCodeQName - a QName object giving the fault code to be set. It must be namespace qualified.
        Throws:
        SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
        Since:
        SAAJ 1.3
        See Also:
        getFaultCodeAsQName(), setFaultCode(Name), getFaultCodeAsQName()

      • setFaultCode

        void setFaultCode(String faultCode)
           throws SOAPException
        Sets this SOAPFault object with the give fault code.

        Fault codes, which given information about the fault, are defined in the SOAP 1.1 specification. This element is mandatory in SOAP 1.1. Because the fault code is required to be a QName it is preferable to use the setFaultCode(Name) form of this method.

        Parameters:
        faultCode - a String giving the fault code to be set. It must be of the form "prefix:localName" where the prefix has been defined in a namespace declaration.
        Throws:
        SOAPException - if there was an error in adding the faultCode to the underlying XML tree.
        See Also:
        setFaultCode(Name), getFaultCode(), SOAPElement.addNamespaceDeclaration(java.lang.String, java.lang.String)

      • getFaultCodeAsName

        Name getFaultCodeAsName()
        Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object. The SOAP 1.1 specification requires the value of the "faultcode" element to be of type QName. This method returns the content of the element as a QName in the form of a SAAJ Name object. This method should be used instead of the getFaultCode method since it allows applications to easily access the namespace name without additional parsing.
        Returns:
        a Name representing the faultcode
        Since:
        SAAJ 1.2
        See Also:
        setFaultCode(Name)

      • getFaultCodeAsQName

        QName getFaultCodeAsQName()
        Gets the fault code for this SOAPFault object as a QName object.
        Returns:
        a QName representing the faultcode
        Since:
        SAAJ 1.3
        See Also:
        setFaultCode(QName)

      • getFaultSubcodes

        Iterator getFaultSubcodes()
        Gets the Subcodes for this SOAPFault as an iterator over QNames.
        Returns:
        an Iterator that accesses a sequence of QNames. This Iterator should not support the optional remove method. The order in which the Subcodes are returned reflects the hierarchy of Subcodes present in the fault from top to bottom.
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        Since:
        SAAJ 1.3

      • removeAllFaultSubcodes

        void removeAllFaultSubcodes()
        Removes any Subcodes that may be contained by this SOAPFault. Subsequent calls to getFaultSubcodes will return an empty iterator until a call to appendFaultSubcode is made.
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        Since:
        SAAJ 1.3

      • appendFaultSubcode

        void appendFaultSubcode(QName subcode)
                 throws SOAPException
        Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault. Subcodes, which were introduced in SOAP 1.2, are represented by a recursive sequence of subelements rooted in the mandatory Code subelement of a SOAP Fault.
        Parameters:
        subcode - a QName containing the Value of the Subcode.
        Throws:
        SOAPException - if there was an error in setting the Subcode
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        Since:
        SAAJ 1.3

      • getFaultCode

        String getFaultCode()
        Gets the fault code for this SOAPFault object.
        Returns:
        a String with the fault code
        See Also:
        getFaultCodeAsName(), setFaultCode(javax.xml.soap.Name)

      • setFaultActor

        void setFaultActor(String faultActor)
            throws SOAPException
        Sets this SOAPFault object with the given fault actor.

        The fault actor is the recipient in the message path who caused the fault to happen.

        If this SOAPFault supports SOAP 1.2 then this call is equivalent to setFaultRole(String)

        Parameters:
        faultActor - a String identifying the actor that caused this SOAPFault object
        Throws:
        SOAPException - if there was an error in adding the faultActor to the underlying XML tree.
        See Also:
        getFaultActor()

      • getFaultActor

        String getFaultActor()
        Gets the fault actor for this SOAPFault object.

        If this SOAPFault supports SOAP 1.2 then this call is equivalent to getFaultRole()

        Returns:
        a String giving the actor in the message path that caused this SOAPFault object
        See Also:
        setFaultActor(java.lang.String)

      • setFaultString

        void setFaultString(String faultString)
             throws SOAPException
        Sets the fault string for this SOAPFault object to the given string.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

              addFaultReasonText(faultString, Locale.getDefault());
        Parameters:
        faultString - a String giving an explanation of the fault
        Throws:
        SOAPException - if there was an error in adding the faultString to the underlying XML tree.
        See Also:
        getFaultString()

      • setFaultString

        void setFaultString(String faultString,
                    Locale locale)
             throws SOAPException
        Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

              addFaultReasonText(faultString, locale);
        Parameters:
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        Throws:
        SOAPException - if there was an error in adding the faultString to the underlying XML tree.
        Since:
        SAAJ 1.2
        See Also:
        getFaultString()

      • getFaultString

        String getFaultString()
        Gets the fault string for this SOAPFault object.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

            String reason = null;
    try {
        reason = (String) getFaultReasonTexts().next();
    } catch (SOAPException e) {}
    return reason;
        Returns:
        a String giving an explanation of the fault
        See Also:
        setFaultString(String), setFaultString(String, Locale)

      • getFaultStringLocale

        Locale getFaultStringLocale()
        Gets the locale of the fault string for this SOAPFault object.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

            Locale locale = null;
    try {
        locale = (Locale) getFaultReasonLocales().next();
    } catch (SOAPException e) {}
    return locale;
        Returns:
        a Locale object indicating the native language of the fault string or null if no locale was specified
        Since:
        SAAJ 1.2
        See Also:
        setFaultString(String, Locale)

      • hasDetail

        boolean hasDetail()
        Returns true if this SOAPFault has a Detail subelement and false otherwise. Equivalent to (getDetail()!=null).
        Returns:
        true if this SOAPFault has a Detail subelement and false otherwise.
        Since:
        SAAJ 1.3

      • getDetail

        Detail getDetail()
        Returns the optional detail element for this SOAPFault object.

        A Detail object carries application-specific error information, the scope of the error information is restricted to faults in the SOAPBodyElement objects if this is a SOAP 1.1 Fault.

        Returns:
        a Detail object with application-specific error information if present, null otherwise

      • addDetail

        Detail addDetail()
          throws SOAPException
        Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.

        It is illegal to add a detail when the fault already contains a detail. Therefore, this method should be called only after the existing detail has been removed.

        Returns:
        the new Detail object
        Throws:
        SOAPException - if this SOAPFault object already contains a valid Detail object

      • getFaultReasonLocales

        Iterator getFaultReasonLocales()
                        throws SOAPException
        Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items. Any of these Locales can be used in a call to getFaultReasonText in order to obtain a localized version of the Reason Text string.
        Returns:
        an Iterator over a sequence of Locale objects for which there are associated Reason Text items.
        Throws:
        SOAPException - if there was an error in retrieving the fault Reason locales.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3

      • getFaultReasonTexts

        Iterator getFaultReasonTexts()
                      throws SOAPException
        Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
        Returns:
        an Iterator over env:Fault/env:Reason/env:Text items.
        Throws:
        SOAPException - if there was an error in retrieving the fault Reason texts.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3

      • getFaultReasonText

        String getFaultReasonText(Locale locale)
                   throws SOAPException
        Returns the Reason Text associated with the given Locale. If more than one such Reason Text exists the first matching Text is returned
        Parameters:
        locale - -- the Locale for which a localized Reason Text is desired
        Returns:
        the Reason Text associated with locale
        Throws:
        SOAPException - if there was an error in retrieving the fault Reason text for the specified locale .
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3
        See Also:
        getFaultString()

      • addFaultReasonText

        void addFaultReasonText(String text,
                        Locale locale)
                 throws SOAPException
        Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale. If a Reason Text item with this xml:lang already exists its text value will be replaced with text. The locale parameter should not be null

        Code sample:

         SOAPFault fault = ...;
 fault.addFaultReasonText("Version Mismatch", Locale.ENGLISH);
        Parameters:
        text - -- reason message string
        locale - -- Locale object representing the locale of the message
        Throws:
        SOAPException - if there was an error in adding the Reason text or the locale passed was null.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        Since:
        SAAJ 1.3

      • getFaultNode

        String getFaultNode()
        Returns the optional Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.
        Returns:
        Content of the env:Fault/env:Node element as a String or null if none
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
        Since:
        SAAJ 1.3

      • setFaultNode

        void setFaultNode(String uri)
           throws SOAPException
        Creates or replaces any existing Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.
        Throws:
        SOAPException - if there was an error in setting the Node for this SOAPFault object.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
        Since:
        SAAJ 1.3

      • getFaultRole

        String getFaultRole()
        Returns the optional Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.
        Returns:
        Content of the env:Fault/env:Role element as a String or null if none
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3

      • setFaultRole

        void setFaultRole(String uri)
           throws SOAPException
        Creates or replaces any existing Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.
        Parameters:
        uri - - the URI of the Role
        Throws:
        SOAPException - if there was an error in setting the Role for this SOAPFault object.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPFaultElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPFaultElement

  • All Superinterfaces:
    Element, Node, SOAPElement
    All Known Subinterfaces:
    Detail

    public interface SOAPFaultElement
extends SOAPElement
    A representation of the contents in a SOAPFault object. The Detail interface is a SOAPFaultElement.

    Content is added to a SOAPFaultElement using the SOAPElement method addTextNode.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPHeader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPHeader

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPHeader
extends SOAPElement
    A representation of the SOAP header element. A SOAP header element consists of XML data that affects the way the application-specific content is processed by the message provider. For example, transaction semantics, authentication information, and so on, can be specified as the content of a SOAPHeader object.

    A SOAPEnvelope object contains an empty SOAPHeader object by default. If the SOAPHeader object, which is optional, is not needed, it can be retrieved and deleted with the following line of code. The variable se is a SOAPEnvelope object.

          se.getHeader().detachNode();
    A SOAPHeader object is created with the SOAPEnvelope method addHeader. This method, which creates a new header and adds it to the envelope, may be called only after the existing header has been removed.
          se.getHeader().detachNode();
      SOAPHeader sh = se.addHeader();

    A SOAPHeader object can have only SOAPHeaderElement objects as its immediate children. The method addHeaderElement creates a new HeaderElement object and adds it to the SOAPHeader object. In the following line of code, the argument to the method addHeaderElement is a Name object that is the name for the new HeaderElement object.

          SOAPHeaderElement shElement = sh.addHeaderElement(name);
    See Also:
    SOAPHeaderElement

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      SOAPHeaderElement addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
      Iterator examineAllHeaderElements()
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
      Iterator examineHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
      Iterator examineMustUnderstandHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
      Iterator extractAllHeaderElements()
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
      Iterator extractHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • addHeaderElement

        SOAPHeaderElement addHeaderElement(Name name)
                            throws SOAPException
        Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
        Parameters:
        name - a Name object with the name of the new SOAPHeaderElement object
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs
        See Also:
        addHeaderElement(javax.xml.namespace.QName)

      • addHeaderElement

        SOAPHeaderElement addHeaderElement(QName qname)
                            throws SOAPException
        Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
        Parameters:
        qname - a QName object with the qname of the new SOAPHeaderElement object
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs
        Since:
        SAAJ 1.3
        See Also:
        addHeaderElement(Name)

      • examineMustUnderstandHeaderElements

        Iterator examineMustUnderstandHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        Parameters:
        actor - a String giving the URI of the actor / role for which to search
        Returns:
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role and are marked as MustUnderstand
        Since:
        SAAJ 1.2
        See Also:
        examineHeaderElements(java.lang.String), extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • examineHeaderElements

        Iterator examineHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor. An actor is a global attribute that indicates the intermediate parties that should process a message before it reaches its ultimate receiver. An actor receives the message and processes it before sending it on to the next actor. The default actor is the ultimate intended recipient for the message, so if no actor attribute is included in a SOAPHeader object, it is sent to the ultimate receiver along with the message body.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        Parameters:
        actor - a String giving the URI of the actor / role for which to search
        Returns:
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
        See Also:
        extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • extractHeaderElements

        Iterator extractHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

        This method allows an actor to process the parts of the SOAPHeader object that apply to it and to remove them before passing the message on to the next actor.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        Parameters:
        actor - a String giving the URI of the actor / role for which to search
        Returns:
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
        See Also:
        examineHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • addNotUnderstoodHeaderElement

        SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
                                         throws SOAPException
        Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object. This operation is supported only by SOAP 1.2.
        Parameters:
        name - a QName object with the name of the SOAPHeaderElement object that was not understood.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        UnsupportedOperationException - if this is a SOAP 1.1 Header.
        Since:
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
                                   throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        Parameters:
        supportedSOAPURIs - an Iterator object with the URIs of SOAP versions supported.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        Since:
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
                                   throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        Parameters:
        supportedSoapUris - an array of the URIs of SOAP versions supported.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        Since:
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
                                   throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        Parameters:
        supportedSoapUri - the URI of SOAP the version that is supported.
        Returns:
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        Throws:
        SOAPException - if a SOAP error occurs.
        Since:
        SAAJ 1.3

      • examineAllHeaderElements

        Iterator examineAllHeaderElements()
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
        Returns:
        an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
        Since:
        SAAJ 1.2
        See Also:
        extractAllHeaderElements()

      • extractAllHeaderElements

        Iterator extractAllHeaderElements()
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
        Returns:
        an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
        Since:
        SAAJ 1.2
        See Also:
        examineAllHeaderElements()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPHeaderElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPHeaderElement

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPHeaderElement
extends SOAPElement
    An object representing the contents in the SOAP header part of the SOAP envelope. The immediate children of a SOAPHeader object can be represented only as SOAPHeaderElement objects.

    A SOAPHeaderElement object can have other SOAPElement objects as its children.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getActor()
      Returns the uri of the actor attribute of this SOAPHeaderElement.
      boolean getMustUnderstand()
      Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
      boolean getRelay()
      Returns the boolean value of the relay attribute for this SOAPHeaderElement
      String getRole()
      Returns the value of the Role attribute of this SOAPHeaderElement.
      void setActor(String actorURI)
      Sets the actor associated with this SOAPHeaderElement object to the specified actor.
      void setMustUnderstand(boolean mustUnderstand)
      Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.
      void setRelay(boolean relay)
      Sets the relay attribute for this SOAPHeaderElement to be either true or false.
      void setRole(String uri)
      Sets the Role associated with this SOAPHeaderElement object to the specified Role.

      • Methods inherited from interface javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • setActor

        void setActor(String actorURI)
        Sets the actor associated with this SOAPHeaderElement object to the specified actor. The default value of an actor is: SOAPConstants.URI_SOAP_ACTOR_NEXT

        If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to setRole(String)

        Parameters:
        actorURI - a String giving the URI of the actor to set
        Throws:
        IllegalArgumentException - if there is a problem in setting the actor.
        See Also:
        getActor()

      • setRole

        void setRole(String uri)
      throws SOAPException
        Sets the Role associated with this SOAPHeaderElement object to the specified Role.
        Parameters:
        uri - - the URI of the Role
        Throws:
        SOAPException - if there is an error in setting the role
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3

      • getActor

        String getActor()
        Returns the uri of the actor attribute of this SOAPHeaderElement.

        If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to getRole()

        Returns:
        a String giving the URI of the actor
        See Also:
        setActor(java.lang.String)

      • getRole

        String getRole()
        Returns the value of the Role attribute of this SOAPHeaderElement.
        Returns:
        a String giving the URI of the Role
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        Since:
        SAAJ 1.3

      • setMustUnderstand

        void setMustUnderstand(boolean mustUnderstand)
        Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.

        If the mustUnderstand attribute is on, the actor who receives the SOAPHeaderElement must process it correctly. This ensures, for example, that if the SOAPHeaderElement object modifies the message, that the message is being modified correctly.

        Parameters:
        mustUnderstand - true to set the mustUnderstand attribute to true; false to set it to false
        Throws:
        IllegalArgumentException - if there is a problem in setting the mustUnderstand attribute
        See Also:
        getMustUnderstand(), setRelay(boolean)

      • getMustUnderstand

        boolean getMustUnderstand()
        Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
        Returns:
        true if the mustUnderstand attribute of this SOAPHeaderElement object is turned on; false otherwise

      • setRelay

        void setRelay(boolean relay)
       throws SOAPException
        Sets the relay attribute for this SOAPHeaderElement to be either true or false.

        The SOAP relay attribute is set to true to indicate that the SOAP header block must be relayed by any node that is targeted by the header block but not actually process it. This attribute is ignored on header blocks whose mustUnderstand attribute is set to true or that are targeted at the ultimate reciever (which is the default). The default value of this attribute is false.

        Parameters:
        relay - the new value of the relay attribute
        Throws:
        SOAPException - if there is a problem in setting the relay attribute.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
        Since:
        SAAJ 1.3
        See Also:
        setMustUnderstand(boolean), getRelay()

      • getRelay

        boolean getRelay()
        Returns the boolean value of the relay attribute for this SOAPHeaderElement
        Returns:
        true if the relay attribute is turned on; false otherwise
        Throws:
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
        Since:
        SAAJ 1.3
        See Also:
        getMustUnderstand(), setRelay(boolean)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPMessage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPMessage

  • java.lang.Object
    • javax.xml.soap.SOAPMessage

  • public abstract class SOAPMessage
extends Object
    The root class for all SOAP messages. As transmitted on the "wire", a SOAP message is an XML document or a MIME message whose first body part is an XML/SOAP document.

    A SOAPMessage object consists of a SOAP part and optionally one or more attachment parts. The SOAP part for a SOAPMessage object is a SOAPPart object, which contains information used for message routing and identification, and which can contain application-specific content. All data in the SOAP Part of a message must be in XML format.

    A new SOAPMessage object contains the following by default:

    • A SOAPPart object
    • A SOAPEnvelope object
    • A SOAPBody object
    • A SOAPHeader object
    The SOAP part of a message can be retrieved by calling the method SOAPMessage.getSOAPPart(). The SOAPEnvelope object is retrieved from the SOAPPart object, and the SOAPEnvelope object is used to retrieve the SOAPBody and SOAPHeader objects.
         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPBody sb = se.getBody();
     SOAPHeader sh = se.getHeader();

    In addition to the mandatory SOAPPart object, a SOAPMessage object may contain zero or more AttachmentPart objects, each of which contains application-specific data. The SOAPMessage interface provides methods for creating AttachmentPart objects and also for adding them to a SOAPMessage object. A party that has received a SOAPMessage object can examine its contents by retrieving individual attachment parts.

    Unlike the rest of a SOAP message, an attachment is not required to be in XML format and can therefore be anything from simple text to an image file. Consequently, any message content that is not in XML format must be in an AttachmentPart object.

    A MessageFactory object may create SOAPMessage objects with behavior that is specialized to a particular implementation or application of SAAJ. For instance, a MessageFactory object may produce SOAPMessage objects that conform to a particular Profile such as ebXML. In this case a MessageFactory object might produce SOAPMessage objects that are initialized with ebXML headers.

    In order to ensure backward source compatibility, methods that are added to this class after version 1.1 of the SAAJ specification are all concrete instead of abstract and they all have default implementations. Unless otherwise noted in the JavaDocs for those methods the default implementations simply throw an UnsupportedOperationException and the SAAJ implementation code must override them with methods that provide the specified behavior. Legacy client code does not have this restriction, however, so long as there is no claim made that it conforms to some later version of the specification than it was originally written for. A legacy class that extends the SOAPMessage class can be compiled and/or run against succeeding versions of the SAAJ API without modification. If such a class was correctly implemented then it will continue to behave correctly relative to the version of the specification against which it was written.

    See Also:
    MessageFactory, AttachmentPart

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CHARACTER_SET_ENCODING
      Specifies the character type encoding for the SOAP Message.
      static String WRITE_XML_DECLARATION
      Specifies whether the SOAP Message will contain an XML declaration when it is sent.

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPMessage()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract void addAttachmentPart(AttachmentPart AttachmentPart)
      Adds the given AttachmentPart object to this SOAPMessage object.
      abstract int countAttachments()
      Gets a count of the number of attachments in this message.
      abstract AttachmentPart createAttachmentPart()
      Creates a new empty AttachmentPart object.
      AttachmentPart createAttachmentPart(DataHandler dataHandler)
      Creates an AttachmentPart object and populates it using the given DataHandler object.
      AttachmentPart createAttachmentPart(Object content, String contentType)
      Creates an AttachmentPart object and populates it with the specified data of the specified content type.
      abstract AttachmentPart getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      abstract Iterator getAttachments()
      Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
      abstract Iterator getAttachments(MimeHeaders headers)
      Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
      abstract String getContentDescription()
      Retrieves a description of this SOAPMessage object's content.
      abstract MimeHeaders getMimeHeaders()
      Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
      Object getProperty(String property)
      Retrieves value of the specified property.
      SOAPBody getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
      SOAPHeader getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
      abstract SOAPPart getSOAPPart()
      Gets the SOAP part of this SOAPMessage object.
      abstract void removeAllAttachments()
      Removes all AttachmentPart objects that have been added to this SOAPMessage object.
      abstract void removeAttachments(MimeHeaders headers)
      Removes all the AttachmentPart objects that have header entries that match the specified headers.
      abstract void saveChanges()
      Updates this SOAPMessage object with all the changes that have been made to it.
      abstract boolean saveRequired()
      Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
      abstract void setContentDescription(String description)
      Sets the description of this SOAPMessage object's content with the given description.
      void setProperty(String property, Object value)
      Associates the specified value with the specified property.
      abstract void writeTo(OutputStream out)
      Writes this SOAPMessage object to the given output stream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • CHARACTER_SET_ENCODING

        public static final String CHARACTER_SET_ENCODING
        Specifies the character type encoding for the SOAP Message. Valid values include "utf-8" and "utf-16". See vendor documentation for additional supported values. The default is "utf-8".
        Since:
        SAAJ 1.2
        See Also:
        SOAPMessage.setProperty, Constant Field Values

      • WRITE_XML_DECLARATION

        public static final String WRITE_XML_DECLARATION
        Specifies whether the SOAP Message will contain an XML declaration when it is sent. The only valid values are "true" and "false". The default is "false".
        Since:
        SAAJ 1.2
        See Also:
        SOAPMessage.setProperty, Constant Field Values

    • Constructor Detail

      • SOAPMessage

        public SOAPMessage()

    • Method Detail

      • setContentDescription

        public abstract void setContentDescription(String description)
        Sets the description of this SOAPMessage object's content with the given description.
        Parameters:
        description - a String describing the content of this message
        See Also:
        getContentDescription()

      • getContentDescription

        public abstract String getContentDescription()
        Retrieves a description of this SOAPMessage object's content.
        Returns:
        a String describing the content of this message or null if no description has been set
        See Also:
        setContentDescription(java.lang.String)

      • getSOAPPart

        public abstract SOAPPart getSOAPPart()
        Gets the SOAP part of this SOAPMessage object.

        SOAPMessage object contains one or more attachments, the SOAP Part must be the first MIME body part in the message.

        Returns:
        the SOAPPart object for this SOAPMessage object

      • getSOAPBody

        public SOAPBody getSOAPBody()
                     throws SOAPException
        Gets the SOAP Body contained in this SOAPMessage object.

        Returns:
        the SOAPBody object contained by this SOAPMessage object
        Throws:
        SOAPException - if the SOAP Body does not exist or cannot be retrieved
        Since:
        SAAJ 1.2

      • getSOAPHeader

        public SOAPHeader getSOAPHeader()
                         throws SOAPException
        Gets the SOAP Header contained in this SOAPMessage object.

        Returns:
        the SOAPHeader object contained by this SOAPMessage object
        Throws:
        SOAPException - if the SOAP Header does not exist or cannot be retrieved
        Since:
        SAAJ 1.2

      • removeAllAttachments

        public abstract void removeAllAttachments()
        Removes all AttachmentPart objects that have been added to this SOAPMessage object.

        This method does not touch the SOAP part.

      • countAttachments

        public abstract int countAttachments()
        Gets a count of the number of attachments in this message. This count does not include the SOAP part.
        Returns:
        the number of AttachmentPart objects that are part of this SOAPMessage object

      • getAttachments

        public abstract Iterator getAttachments()
        Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
        Returns:
        an iterator over all the attachments in this message

      • getAttachments

        public abstract Iterator getAttachments(MimeHeaders headers)
        Retrieves all the AttachmentPart objects that have header entries that match the specified headers. Note that a returned attachment could have headers in addition to those specified.
        Parameters:
        headers - a MimeHeaders object containing the MIME headers for which to search
        Returns:
        an iterator over all attachments that have a header that matches one of the given headers

      • removeAttachments

        public abstract void removeAttachments(MimeHeaders headers)
        Removes all the AttachmentPart objects that have header entries that match the specified headers. Note that the removed attachment could have headers in addition to those specified.
        Parameters:
        headers - a MimeHeaders object containing the MIME headers for which to search
        Since:
        SAAJ 1.3

      • getAttachment

        public abstract AttachmentPart getAttachment(SOAPElement element)
                                      throws SOAPException
        Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists. References can be made via an href attribute as described in SOAP Messages with Attachments, or via a single Text child node containing a URI as described in the WS-I Attachments Profile 1.0 for elements of schema type ref:swaRef. These two mechanisms must be supported. The support for references via href attribute also implies that this method should also be supported on an element that is an xop:Include element ( XOP). other reference mechanisms may be supported by individual implementations of this standard. Contact your vendor for details.
        Parameters:
        element - The SOAPElement containing the reference to an Attachment
        Returns:
        the referenced AttachmentPart or null if no such AttachmentPart exists or no reference can be found in this SOAPElement.
        Throws:
        SOAPException - if there is an error in the attempt to access the attachment
        Since:
        SAAJ 1.3

      • addAttachmentPart

        public abstract void addAttachmentPart(AttachmentPart AttachmentPart)
        Adds the given AttachmentPart object to this SOAPMessage object. An AttachmentPart object must be created before it can be added to a message.
        Parameters:
        AttachmentPart - an AttachmentPart object that is to become part of this SOAPMessage object
        Throws:
        IllegalArgumentException

      • createAttachmentPart

        public abstract AttachmentPart createAttachmentPart()
        Creates a new empty AttachmentPart object. Note that the method addAttachmentPart must be called with this new AttachmentPart object as the parameter in order for it to become an attachment to this SOAPMessage object.
        Returns:
        a new AttachmentPart object that can be populated and added to this SOAPMessage object

      • createAttachmentPart

        public AttachmentPart createAttachmentPart(DataHandler dataHandler)
        Creates an AttachmentPart object and populates it using the given DataHandler object.
        Parameters:
        dataHandler - the javax.activation.DataHandler object that will generate the content for this SOAPMessage object
        Returns:
        a new AttachmentPart object that contains data generated by the given DataHandler object
        Throws:
        IllegalArgumentException - if there was a problem with the specified DataHandler object
        See Also:
        DataHandler, DataContentHandler

      • getMimeHeaders

        public abstract MimeHeaders getMimeHeaders()
        Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
        Returns:
        a MimeHeaders object containing the MimeHeader objects

      • createAttachmentPart

        public AttachmentPart createAttachmentPart(Object content,
                                           String contentType)
        Creates an AttachmentPart object and populates it with the specified data of the specified content type. The type of the Object should correspond to the value given for the Content-Type.
        Parameters:
        content - an Object containing the content for the AttachmentPart object to be created
        contentType - a String object giving the type of content; examples are "text/xml", "text/plain", and "image/jpeg"
        Returns:
        a new AttachmentPart object that contains the given data
        Throws:
        IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for the given content object
        See Also:
        DataHandler, DataContentHandler

      • saveChanges

        public abstract void saveChanges()
                          throws SOAPException
        Updates this SOAPMessage object with all the changes that have been made to it. This method is called automatically when writeTo(OutputStream) is called. However, if changes are made to a message that was received or to one that has already been sent, the method saveChanges needs to be called explicitly in order to save the changes. The method saveChanges also generates any changes that can be read back (for example, a MessageId in profiles that support a message id). All MIME headers in a message that is created for sending purposes are guaranteed to have valid values only after saveChanges has been called.

        In addition, this method marks the point at which the data from all constituent AttachmentPart objects are pulled into the message.

        Throws:
        SOAPException - if there was a problem saving changes to this message.
        SOAPException

      • saveRequired

        public abstract boolean saveRequired()
        Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
        Returns:
        true if saveChanges needs to be called; false otherwise.

      • writeTo

        public abstract void writeTo(OutputStream out)
                      throws SOAPException,
                             IOException
        Writes this SOAPMessage object to the given output stream. The externalization format is as defined by the SOAP 1.1 with Attachments specification.

        If there are no attachments, just an XML stream is written out. For those messages that have attachments, writeTo writes a MIME-encoded byte stream.

        Note that this method does not write the transport-specific MIME Headers of the Message

        Parameters:
        out - the OutputStream object to which this SOAPMessage object will be written
        Throws:
        IOException - if an I/O error occurs
        SOAPException - if there was a problem in externalizing this SOAP message

      • setProperty

        public void setProperty(String property,
                        Object value)
                 throws SOAPException
        Associates the specified value with the specified property. If there was already a value associated with this property, the old value is replaced.

        The valid property names include WRITE_XML_DECLARATION and CHARACTER_SET_ENCODING. All of these standard SAAJ properties are prefixed by "javax.xml.soap". Vendors may also add implementation specific properties. These properties must be prefixed with package names that are unique to the vendor.

        Setting the property WRITE_XML_DECLARATION to "true" will cause an XML Declaration to be written out at the start of the SOAP message. The default value of "false" suppresses this declaration.

        The property CHARACTER_SET_ENCODING defaults to the value "utf-8" which causes the SOAP message to be encoded using UTF-8. Setting CHARACTER_SET_ENCODING to "utf-16" causes the SOAP message to be encoded using UTF-16.

        Some implementations may allow encodings in addition to UTF-8 and UTF-16. Refer to your vendor's documentation for details.

        Parameters:
        property - the property with which the specified value is to be associated.
        value - the value to be associated with the specified property
        Throws:
        SOAPException - if the property name is not recognized.
        Since:
        SAAJ 1.2

      • getProperty

        public Object getProperty(String property)
                   throws SOAPException
        Retrieves value of the specified property.
        Parameters:
        property - the name of the property to retrieve
        Returns:
        the value associated with the named property or null if no such property exists.
        Throws:
        SOAPException - if the property name is not recognized.
        Since:
        SAAJ 1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPPart (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Class SOAPPart

  • java.lang.Object
    • javax.xml.soap.SOAPPart
  • All Implemented Interfaces:
    Document, Node

    public abstract class SOAPPart
extends Object
implements Document, Node
    The container for the SOAP-specific portion of a SOAPMessage object. All messages are required to have a SOAP part, so when a SOAPMessage object is created, it will automatically have a SOAPPart object.

    A SOAPPart object is a MIME part and has the MIME headers Content-Id, Content-Location, and Content-Type. Because the value of Content-Type must be "text/xml", a SOAPPart object automatically has a MIME header of Content-Type with its value set to "text/xml". The value must be "text/xml" because content in the SOAP part of a message must be in XML format. Content that is not of type "text/xml" must be in an AttachmentPart object rather than in the SOAPPart object.

    When a message is sent, its SOAP part must have the MIME header Content-Type set to "text/xml". Or, from the other perspective, the SOAP part of any message that is received must have the MIME header Content-Type with a value of "text/xml".

    A client can access the SOAPPart object of a SOAPMessage object by calling the method SOAPMessage.getSOAPPart. The following line of code, in which message is a SOAPMessage object, retrieves the SOAP part of a message.

       SOAPPart soapPart = message.getSOAPPart();

    A SOAPPart object contains a SOAPEnvelope object, which in turn contains a SOAPBody object and a SOAPHeader object. The SOAPPart method getEnvelope can be used to retrieve the SOAPEnvelope object.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPPart()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract void addMimeHeader(String name, String value)
      Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
      abstract Iterator getAllMimeHeaders()
      Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
      abstract Source getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      String getContentId()
      Retrieves the value of the MIME header whose name is "Content-Id".
      String getContentLocation()
      Retrieves the value of the MIME header whose name is "Content-Location".
      abstract SOAPEnvelope getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
      abstract Iterator getMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects that match a name in the given array.
      abstract String[] getMimeHeader(String name)
      Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
      abstract Iterator getNonMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects whose name does not match a name in the given array.
      abstract void removeAllMimeHeaders()
      Removes all the MimeHeader objects for this SOAPEnvelope object.
      abstract void removeMimeHeader(String header)
      Removes all MIME headers that match the given name.
      abstract void setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.
      void setContentId(String contentId)
      Sets the value of the MIME header named "Content-Id" to the given String.
      void setContentLocation(String contentLocation)
      Sets the value of the MIME header "Content-Location" to the given String.
      abstract void setMimeHeader(String name, String value)
      Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.w3c.dom.Document

        adoptNode, createAttribute, createAttributeNS, createCDATASection, createComment, createDocumentFragment, createElement, createElementNS, createEntityReference, createProcessingInstruction, createTextNode, getDoctype, getDocumentElement, getDocumentURI, getDomConfig, getElementById, getElementsByTagName, getElementsByTagNameNS, getImplementation, getInputEncoding, getStrictErrorChecking, getXmlEncoding, getXmlStandalone, getXmlVersion, importNode, normalizeDocument, renameNode, setDocumentURI, setStrictErrorChecking, setXmlStandalone, setXmlVersion

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Constructor Detail

      • SOAPPart

        public SOAPPart()

    • Method Detail

      • getEnvelope

        public abstract SOAPEnvelope getEnvelope()
                                  throws SOAPException
        Gets the SOAPEnvelope object associated with this SOAPPart object. Once the SOAP envelope is obtained, it can be used to get its contents.
        Returns:
        the SOAPEnvelope object for this SOAPPart object
        Throws:
        SOAPException - if there is a SOAP error

      • getContentId

        public String getContentId()
        Retrieves the value of the MIME header whose name is "Content-Id".
        Returns:
        a String giving the value of the MIME header named "Content-Id"
        See Also:
        setContentId(java.lang.String)

      • getContentLocation

        public String getContentLocation()
        Retrieves the value of the MIME header whose name is "Content-Location".
        Returns:
        a String giving the value of the MIME header whose name is "Content-Location"
        See Also:
        setContentLocation(java.lang.String)

      • setContentId

        public void setContentId(String contentId)
        Sets the value of the MIME header named "Content-Id" to the given String.
        Parameters:
        contentId - a String giving the value of the MIME header "Content-Id"
        Throws:
        IllegalArgumentException - if there is a problem in setting the content id
        See Also:
        getContentId()

      • setContentLocation

        public void setContentLocation(String contentLocation)
        Sets the value of the MIME header "Content-Location" to the given String.
        Parameters:
        contentLocation - a String giving the value of the MIME header "Content-Location"
        Throws:
        IllegalArgumentException - if there is a problem in setting the content location.
        See Also:
        getContentLocation()

      • removeMimeHeader

        public abstract void removeMimeHeader(String header)
        Removes all MIME headers that match the given name.
        Parameters:
        header - a String giving the name of the MIME header(s) to be removed

      • removeAllMimeHeaders

        public abstract void removeAllMimeHeaders()
        Removes all the MimeHeader objects for this SOAPEnvelope object.

      • getMimeHeader

        public abstract String[] getMimeHeader(String name)
        Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
        Parameters:
        name - the name of the header; example: "Content-Type"
        Returns:
        a String array giving all the values for the specified header
        See Also:
        setMimeHeader(java.lang.String, java.lang.String)

      • setMimeHeader

        public abstract void setMimeHeader(String name,
                                   String value)
        Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match. If there is a match, this method clears all existing values for the first header that matches and sets the given value instead. If more than one header has the given name, this method removes all of the matching headers after the first one.

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String giving the header name for which to search
        value - a String giving the value to be set. This value will be substituted for the current value(s) of the first header that is a match if there is one. If there is no match, this value will be the value for a new MimeHeader object.
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value
        See Also:
        getMimeHeader(java.lang.String)

      • addMimeHeader

        public abstract void addMimeHeader(String name,
                                   String value)
        Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object. If a MimeHeader with the specified name already exists, this method adds the specified value to the already existing value(s).

        Note that RFC822 headers can contain only US-ASCII characters.

        Parameters:
        name - a String giving the header name
        value - a String giving the value to be set or added
        Throws:
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • getAllMimeHeaders

        public abstract Iterator getAllMimeHeaders()
        Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
        Returns:
        an Iterator object with all of the Mime headers for this SOAPPart object

      • getMatchingMimeHeaders

        public abstract Iterator getMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects that match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers to be returned
        Returns:
        all of the MIME headers that match one of the names in the given array, returned as an Iterator object

      • getNonMatchingMimeHeaders

        public abstract Iterator getNonMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects whose name does not match a name in the given array.
        Parameters:
        names - a String array with the name(s) of the MIME headers not to be returned
        Returns:
        all of the MIME headers in this SOAPPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.

      • setContent

        public abstract void setContent(Source source)
                         throws SOAPException
        Sets the content of the SOAPEnvelope object with the data from the given Source object. This Source must contain a valid SOAP document.
        Parameters:
        source - the javax.xml.transform.Source object with the data to be set
        Throws:
        SOAPException - if there is a problem in setting the source
        See Also:
        getContent()

      • getContent

        public abstract Source getContent()
                           throws SOAPException
        Returns the content of the SOAPEnvelope as a JAXP Source object.
        Returns:
        the content as a javax.xml.transform.Source object
        Throws:
        SOAPException - if the implementation cannot convert the specified Source object
        See Also:
        setContent(javax.xml.transform.Source)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Text (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.soap

Interface Text

  • All Superinterfaces:
    CharacterData, Node, Text

    public interface Text
extends Node, Text
    A representation of a node whose value is text. A Text object may represent text that is content or text that is a comment.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean isComment()
      Retrieves whether this Text object represents a comment.

      • Methods inherited from interface javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • Methods inherited from interface org.w3c.dom.Text

        getWholeText, isElementContentWhitespace, replaceWholeText, splitText

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • isComment

        boolean isComment()
        Retrieves whether this Text object represents a comment.
        Returns:
        true if this Text object is a comment; false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.AttachmentPart (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.AttachmentPart

  • Packages that use AttachmentPart
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of AttachmentPart in javax.xml.soap

      Methods in javax.xml.soap that return AttachmentPart
      Modifier and Type Method and Description
      abstract AttachmentPart SOAPMessage.createAttachmentPart()
      Creates a new empty AttachmentPart object.
      AttachmentPart SOAPMessage.createAttachmentPart(DataHandler dataHandler)
      Creates an AttachmentPart object and populates it using the given DataHandler object.
      AttachmentPart SOAPMessage.createAttachmentPart(Object content, String contentType)
      Creates an AttachmentPart object and populates it with the specified data of the specified content type.
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      Methods in javax.xml.soap with parameters of type AttachmentPart
      Modifier and Type Method and Description
      abstract void SOAPMessage.addAttachmentPart(AttachmentPart AttachmentPart)
      Adds the given AttachmentPart object to this SOAPMessage object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.Detail (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Detail

  • Packages that use Detail
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Detail in javax.xml.soap

      Methods in javax.xml.soap that return Detail
      Modifier and Type Method and Description
      Detail SOAPFault.addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      abstract Detail SOAPFactory.createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      Detail SOAPFault.getDetail()
      Returns the optional detail element for this SOAPFault object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.DetailEntry (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.DetailEntry

  • Packages that use DetailEntry
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of DetailEntry in javax.xml.soap

      Methods in javax.xml.soap that return DetailEntry
      Modifier and Type Method and Description
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.MessageFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.MessageFactory

  • Packages that use MessageFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of MessageFactory in javax.xml.soap

      Methods in javax.xml.soap that return MessageFactory
      Modifier and Type Method and Description
      static MessageFactory MessageFactory.newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static MessageFactory MessageFactory.newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.
      protected abstract MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.

    • Uses of MessageFactory in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return MessageFactory
      Modifier and Type Method and Description
      MessageFactory SOAPBinding.getMessageFactory()
      Gets the SAAJ MessageFactory instance used by this SOAP binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.MimeHeader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.MimeHeader

No usage of javax.xml.soap.MimeHeader
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.MimeHeaders (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.MimeHeaders

  • Packages that use MimeHeaders
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of MimeHeaders in javax.xml.soap

      Methods in javax.xml.soap that return MimeHeaders
      Modifier and Type Method and Description
      abstract MimeHeaders SOAPMessage.getMimeHeaders()
      Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
      Methods in javax.xml.soap with parameters of type MimeHeaders
      Modifier and Type Method and Description
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      abstract Iterator SOAPMessage.getAttachments(MimeHeaders headers)
      Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
      abstract void SOAPMessage.removeAttachments(MimeHeaders headers)
      Removes all the AttachmentPart objects that have header entries that match the specified headers.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.Name (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Name

  • Packages that use Name
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Name in javax.xml.soap

      Methods in javax.xml.soap that return Name
      Modifier and Type Method and Description
      Name SOAPEnvelope.createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name SOAPFactory.createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name SOAPEnvelope.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      abstract Name SOAPFactory.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPElement.getElementName()
      Returns the name of this SOAPElement object.
      Name SOAPFault.getFaultCodeAsName()
      Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
      Methods in javax.xml.soap with parameters of type Name
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      String SOAPElement.getAttributeValue(Name name)
      Returns the value of the attribute with the specified name.
      Iterator SOAPElement.getChildElements(Name name)
      Returns an Iterator over all the immediate child Nodes of this element with the specified name.
      boolean SOAPElement.removeAttribute(Name name)
      Removes the attribute with the specified name.
      void SOAPFault.setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.Node (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Node

  • Packages that use Node
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Node in javax.xml.soap

      Subinterfaces of Node in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      interface  Text
      A representation of a node whose value is text.
      Methods in javax.xml.soap that return Node
      Modifier and Type | Method and Description
      Node | SAAJResult.getResult()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SAAJMetaFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SAAJMetaFactory

No usage of javax.xml.soap.SAAJMetaFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SAAJResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SAAJResult

No usage of javax.xml.soap.SAAJResult
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPBody (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPBody

  • Packages that use SOAPBody
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPBody in javax.xml.soap

      Methods in javax.xml.soap that return SOAPBody
      Modifier and Type Method and Description
      SOAPBody SOAPEnvelope.addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPBody SOAPEnvelope.getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      SOAPBody SOAPMessage.getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPBodyElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPBodyElement

  • Packages that use SOAPBodyElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPBodyElement in javax.xml.soap

      Subinterfaces of SOAPBodyElement in javax.xml.soap
      Modifier and Type Interface and Description
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      Methods in javax.xml.soap that return SOAPBodyElement
      Modifier and Type Method and Description
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPConnection (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPConnection

  • Packages that use SOAPConnection
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPConnection in javax.xml.soap

      Methods in javax.xml.soap that return SOAPConnection
      Modifier and Type Method and Description
      abstract SOAPConnection SOAPConnectionFactory.createConnection()
      Create a new SOAPConnection.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPConnectionFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPConnectionFactory

  • Packages that use SOAPConnectionFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPConnectionFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPConnectionFactory
      Modifier and Type Method and Description
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
      Creates an instance of the default SOAPConnectionFactory object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPConstants

No usage of javax.xml.soap.SOAPConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPElement

  • Packages that use SOAPElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPElement in javax.xml.soap

      Subinterfaces of SOAPElement in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Methods in javax.xml.soap that return SOAPElement
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement SOAPElement.addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPElement SOAPElement.addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement SOAPElementFactory.create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement SOAPFactory.createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      SOAPElement Node.getParentElement()
      Returns the parent element of this Node object.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      Methods in javax.xml.soap with parameters of type SOAPElement
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      void Node.setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      Constructors in javax.xml.soap with parameters of type SOAPElement
      Constructor and Description
      SAAJResult(SOAPElement rootNode)
      Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPElementFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPElementFactory

  • Packages that use SOAPElementFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPElementFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPElementFactory
      Modifier and Type Method and Description
      static SOAPElementFactory SOAPElementFactory.newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPEnvelope (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPEnvelope

  • Packages that use SOAPEnvelope
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPEnvelope in javax.xml.soap

      Methods in javax.xml.soap that return SOAPEnvelope
      Modifier and Type Method and Description
      abstract SOAPEnvelope SOAPPart.getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPException

  • Packages that use SOAPException
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPException in javax.xml.soap

      Methods in javax.xml.soap that throw SOAPException
      Modifier and Type Method and Description
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBody SOAPEnvelope.addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement SOAPElement.addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      Detail SOAPFault.addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
      SOAPFault SOAPBody.addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      void SOAPFault.addFaultReasonText(String text, Locale locale)
      Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
      SOAPHeader SOAPEnvelope.addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPElement SOAPElement.addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
      void SOAPFault.appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract void SOAPConnection.close()
      Closes this SOAPConnection object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement SOAPElementFactory.create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      abstract SOAPConnection SOAPConnectionFactory.createConnection()
      Create a new SOAPConnection.
      abstract Detail SOAPFactory.createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement SOAPFactory.createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      abstract SOAPFault SOAPFactory.createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      abstract SOAPMessage MessageFactory.createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      Name SOAPEnvelope.createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name SOAPFactory.createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name SOAPEnvelope.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      abstract Name SOAPFactory.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      QName SOAPElement.createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      Document SOAPBody.extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      SOAPMessage SOAPConnection.get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      abstract InputStream AttachmentPart.getBase64Content()
      Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
      SOAPBody SOAPEnvelope.getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      abstract Source SOAPPart.getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      abstract Object AttachmentPart.getContent()
      Gets the content of this AttachmentPart object as a Java object.
      abstract DataHandler AttachmentPart.getDataHandler()
      Gets the DataHandler object for this AttachmentPart object.
      abstract SOAPEnvelope SOAPPart.getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
      Iterator SOAPFault.getFaultReasonLocales()
      Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
      String SOAPFault.getFaultReasonText(Locale locale)
      Returns the Reason Text associated with the given Locale.
      Iterator SOAPFault.getFaultReasonTexts()
      Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
      SOAPHeader SOAPEnvelope.getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.
      Object SOAPMessage.getProperty(String property)
      Retrieves value of the specified property.
      abstract InputStream AttachmentPart.getRawContent()
      Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract byte[] AttachmentPart.getRawContentBytes()
      Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract int AttachmentPart.getSize()
      Returns the number of bytes in this AttachmentPart object.
      SOAPBody SOAPMessage.getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
      SOAPHeader SOAPMessage.getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
      static SOAPElementFactory SOAPElementFactory.newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
      Creates an instance of the default SOAPConnectionFactory object.
      static MessageFactory MessageFactory.newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static SOAPFactory SOAPFactory.newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static MessageFactory MessageFactory.newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.
      static SOAPFactory SOAPFactory.newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
      protected abstract MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.
      protected abstract SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.
      abstract void SOAPMessage.saveChanges()
      Updates this SOAPMessage object with all the changes that have been made to it.
      abstract void AttachmentPart.setBase64Content(InputStream content, String contentType)
      Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
      abstract void SOAPPart.setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void SOAPElement.setEncodingStyle(String encodingStyle)
      Sets the encoding style for this SOAPElement object to one specified.
      void SOAPFault.setFaultActor(String faultActor)
      Sets this SOAPFault object with the given fault actor.
      void SOAPFault.setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void SOAPFault.setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void SOAPFault.setFaultCode(String faultCode)
      Sets this SOAPFault object with the give fault code.
      void SOAPFault.setFaultNode(String uri)
      Creates or replaces any existing Node element value for this SOAPFault object.
      void SOAPFault.setFaultRole(String uri)
      Creates or replaces any existing Role element value for this SOAPFault object.
      void SOAPFault.setFaultString(String faultString)
      Sets the fault string for this SOAPFault object to the given string.
      void SOAPFault.setFaultString(String faultString, Locale locale)
      Sets the fault string for this SOAPFault object to the given string and localized to the given locale.
      void Node.setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      void SOAPMessage.setProperty(String property, Object value)
      Associates the specified value with the specified property.
      abstract void AttachmentPart.setRawContent(InputStream content, String contentType)
      Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
      abstract void AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
      Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
      void SOAPHeaderElement.setRelay(boolean relay)
      Sets the relay attribute for this SOAPHeaderElement to be either true or false.
      void SOAPHeaderElement.setRole(String uri)
      Sets the Role associated with this SOAPHeaderElement object to the specified Role.
      abstract void SOAPMessage.writeTo(OutputStream out)
      Writes this SOAPMessage object to the given output stream.
      Constructors in javax.xml.soap that throw SOAPException
      Constructor and Description
      SAAJResult()
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
      SAAJResult(String protocol)
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPFactory

  • Packages that use SOAPFactory
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of SOAPFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPFactory
      Modifier and Type Method and Description
      static SOAPFactory SOAPFactory.newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPFactory SOAPFactory.newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
      protected abstract SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.

    • Uses of SOAPFactory in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return SOAPFactory
      Modifier and Type Method and Description
      SOAPFactory SOAPBinding.getSOAPFactory()
      Gets the SAAJ SOAPFactory instance used by this SOAP binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPFault (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPFault

  • Packages that use SOAPFault
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of SOAPFault in javax.xml.soap

      Methods in javax.xml.soap that return SOAPFault
      Modifier and Type Method and Description
      SOAPFault SOAPBody.addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      abstract SOAPFault SOAPFactory.createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      SOAPFault SOAPBody.getFault()
      Returns the SOAPFault object in this SOAPBody object.

    • Uses of SOAPFault in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return SOAPFault
      Modifier and Type Method and Description
      SOAPFault SOAPFaultException.getFault()
      Gets the embedded SOAPFault instance.
      Constructors in javax.xml.ws.soap with parameters of type SOAPFault
      Constructor and Description
      SOAPFaultException(SOAPFault fault)
      Constructor for SOAPFaultException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPFaultElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPFaultElement

  • Packages that use SOAPFaultElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPFaultElement in javax.xml.soap

      Subinterfaces of SOAPFaultElement in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPHeader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPHeader

  • Packages that use SOAPHeader
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPHeader in javax.xml.soap

      Methods in javax.xml.soap that return SOAPHeader
      Modifier and Type Method and Description
      SOAPHeader SOAPEnvelope.addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeader SOAPEnvelope.getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeader SOAPMessage.getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.SOAPHeaderElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.SOAPHeaderElement

  • Packages that use SOAPHeaderElement
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPHeaderElement in javax.xml.soap

      Methods in javax.xml.soap that return SOAPHeaderElement
      Modifier and Type Method and Description
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPMessage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPMessage

  • Packages that use SOAPMessage
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of SOAPMessage in javax.xml.soap

      Methods in javax.xml.soap that return SOAPMessage
      Modifier and Type Method and Description
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract SOAPMessage MessageFactory.createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      SOAPMessage SOAPConnection.get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,
      Methods in javax.xml.soap with parameters of type SOAPMessage
      Modifier and Type Method and Description
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      Constructors in javax.xml.soap with parameters of type SOAPMessage
      Constructor and Description
      SAAJResult(SOAPMessage message)
      Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.

    • Uses of SOAPMessage in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap that return SOAPMessage
      Modifier and Type Method and Description
      SOAPMessage SOAPMessageContext.getMessage()
      Gets the SOAPMessage from this message context.
      Methods in javax.xml.ws.handler.soap with parameters of type SOAPMessage
      Modifier and Type Method and Description
      void SOAPMessageContext.setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.soap.SOAPPart (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.soap.SOAPPart

  • Packages that use SOAPPart
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPPart in javax.xml.soap

      Methods in javax.xml.soap that return SOAPPart
      Modifier and Type Method and Description
      abstract SOAPPart SOAPMessage.getSOAPPart()
      Gets the SOAP part of this SOAPMessage object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.soap.Text (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.soap.Text

No usage of javax.xml.soap.Text
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.stream (Java Platform SE 8 )

compact2 - javax.xml.stream

Interfaces

  • EventFilter
  • Location
  • StreamFilter
  • XMLEventReader
  • XMLEventWriter
  • XMLReporter
  • XMLResolver
  • XMLStreamConstants
  • XMLStreamReader
  • XMLStreamWriter

Classes

  • XMLEventFactory
  • XMLInputFactory
  • XMLOutputFactory

Exceptions

  • XMLStreamException

Errors

  • FactoryConfigurationError


javax.xml.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.stream

  • Interface Summary
    Interface Description
    EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    Location
    Provides information on the location of an event.
    StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLReporter
    This interface is used to report non-fatal errors.
    XMLResolver
    This interface is used to resolve resources during an XML parse.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Class Summary
    Class Description
    XMLEventFactory
    This interface defines a utility class for creating instances of XMLEvents
    XMLInputFactory
    Defines an abstract implementation of a factory for getting streams.
    XMLOutputFactory
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
  • Exception Summary
    Exception Description
    XMLStreamException
    The base exception for unexpected processing errors.
  • Error Summary
    Error Description
    FactoryConfigurationError
    An error class for reporting factory configuration errors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.stream (Java Platform SE 8 )

compact3 - javax.xml.stream

Interfaces

  • EventFilter
  • Location
  • StreamFilter
  • XMLEventReader
  • XMLEventWriter
  • XMLReporter
  • XMLResolver
  • XMLStreamConstants
  • XMLStreamReader
  • XMLStreamWriter

Classes

  • XMLEventFactory
  • XMLInputFactory
  • XMLOutputFactory

Exceptions

  • XMLStreamException

Errors

  • FactoryConfigurationError


javax.xml.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.stream

  • Interface Summary
    Interface Description
    EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    Location
    Provides information on the location of an event.
    StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLReporter
    This interface is used to report non-fatal errors.
    XMLResolver
    This interface is used to resolve resources during an XML parse.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Class Summary
    Class Description
    XMLEventFactory
    This interface defines a utility class for creating instances of XMLEvents
    XMLInputFactory
    Defines an abstract implementation of a factory for getting streams.
    XMLOutputFactory
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
  • Exception Summary
    Exception Description
    XMLStreamException
    The base exception for unexpected processing errors.
  • Error Summary
    Error Description
    FactoryConfigurationError
    An error class for reporting factory configuration errors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EventFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface EventFilter

  • public interface EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    Since:
    1.6
    Version:
    1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean accept(XMLEvent event)
      Tests whether this event is part of this stream.

    • Method Detail

      • accept

        boolean accept(XMLEvent event)
        Tests whether this event is part of this stream. This method will return true if this filter accepts this event and false otherwise.
        Parameters:
        event - the event to test
        Returns:
        true if this filter accepts this event, false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Class FactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
  • All Implemented Interfaces:
    Serializable

    public class FactoryConfigurationError
extends Error
    An error class for reporting factory configuration errors.
    Since:
    1.6
    Version:
    1.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      FactoryConfigurationError()
      Default constructor
      FactoryConfigurationError(Exception e)
      Construct an exception with a nested inner exception
      FactoryConfigurationError(Exception e, String msg)
      Construct an exception with a nested inner exception and a message
      FactoryConfigurationError(String msg)
      Construct an exception with associated message
      FactoryConfigurationError(String msg, Exception e)
      Construct an exception with a nested inner exception and a message

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      use the exception chaining mechanism of JDK1.4
      Exception getException()
      Return the nested exception (if any)
      String getMessage()
      Report the message associated with this error

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FactoryConfigurationError

        public FactoryConfigurationError()
        Default constructor

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e)
        Construct an exception with a nested inner exception
        Parameters:
        e - the exception to nest

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e,
                                 String msg)
        Construct an exception with a nested inner exception and a message
        Parameters:
        e - the exception to nest
        msg - the message to report

      • FactoryConfigurationError

        public FactoryConfigurationError(String msg,
                                 Exception e)
        Construct an exception with a nested inner exception and a message
        Parameters:
        msg - the message to report
        e - the exception to nest

      • FactoryConfigurationError

        public FactoryConfigurationError(String msg)
        Construct an exception with associated message
        Parameters:
        msg - the message to report

    • Method Detail

      • getException

        public Exception getException()
        Return the nested exception (if any)
        Returns:
        the nested exception or null

      • getCause

        public Throwable getCause()
        use the exception chaining mechanism of JDK1.4
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this throwable or null if the cause is nonexistent or unknown.

      • getMessage

        public String getMessage()
        Report the message associated with this error
        Overrides:
        getMessage in class Throwable
        Returns:
        the string value of the message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Location (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface Location

  • public interface Location
    Provides information on the location of an event. All the information provided by a Location is optional. For example an application may only report line numbers.
    Since:
    1.6
    Version:
    1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getCharacterOffset()
      Return the byte or character offset into the input source this location is pointing to.
      int getColumnNumber()
      Return the column number where the current event ends, returns -1 if none is available.
      int getLineNumber()
      Return the line number where the current event ends, returns -1 if none is available.
      String getPublicId()
      Returns the public ID of the XML
      String getSystemId()
      Returns the system ID of the XML

    • Method Detail

      • getLineNumber

        int getLineNumber()
        Return the line number where the current event ends, returns -1 if none is available.
        Returns:
        the current line number

      • getColumnNumber

        int getColumnNumber()
        Return the column number where the current event ends, returns -1 if none is available.
        Returns:
        the current column number

      • getCharacterOffset

        int getCharacterOffset()
        Return the byte or character offset into the input source this location is pointing to. If the input source is a file or a byte stream then this is the byte offset into that stream, but if the input source is a character media then the offset is the character offset. Returns -1 if there is no offset available.
        Returns:
        the current offset

      • getPublicId

        String getPublicId()
        Returns the public ID of the XML
        Returns:
        the public ID, or null if not available

      • getSystemId

        String getSystemId()
        Returns the system ID of the XML
        Returns:
        the system ID, or null if not available
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.stream (Java Platform SE 8 )

javax.xml.stream

Interfaces

  • EventFilter
  • Location
  • StreamFilter
  • XMLEventReader
  • XMLEventWriter
  • XMLReporter
  • XMLResolver
  • XMLStreamConstants
  • XMLStreamReader
  • XMLStreamWriter

Classes

  • XMLEventFactory
  • XMLInputFactory
  • XMLOutputFactory

Exceptions

  • XMLStreamException

Errors

  • FactoryConfigurationError


javax.xml.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.stream

  • Interface Summary
    Interface Description
    EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    Location
    Provides information on the location of an event.
    StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLReporter
    This interface is used to report non-fatal errors.
    XMLResolver
    This interface is used to resolve resources during an XML parse.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Class Summary
    Class Description
    XMLEventFactory
    This interface defines a utility class for creating instances of XMLEvents
    XMLInputFactory
    Defines an abstract implementation of a factory for getting streams.
    XMLOutputFactory
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
  • Exception Summary
    Exception Description
    XMLStreamException
    The base exception for unexpected processing errors.
  • Error Summary
    Error Description
    FactoryConfigurationError
    An error class for reporting factory configuration errors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.stream Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.stream

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.stream.XMLStreamException
    • javax.xml.stream.XMLEventFactory
    • javax.xml.stream.XMLInputFactory
    • javax.xml.stream.XMLOutputFactory

Interface Hierarchy

  • javax.xml.stream.EventFilter
  • java.util.Iterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.xml.stream.Location
  • javax.xml.stream.StreamFilter
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.stream

  • Packages that use javax.xml.stream
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
  • Classes in javax.xml.stream used by javax.xml.bind
    Class and Description
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Classes in javax.xml.stream used by javax.xml.bind.helpers
    Class and Description
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Classes in javax.xml.stream used by javax.xml.stream
    Class and Description
    EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    FactoryConfigurationError
    An error class for reporting factory configuration errors.
    Location
    Provides information on the location of an event.
    StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    XMLEventFactory
    This interface defines a utility class for creating instances of XMLEvents
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLInputFactory
    Defines an abstract implementation of a factory for getting streams.
    XMLOutputFactory
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
    XMLReporter
    This interface is used to report non-fatal errors.
    XMLResolver
    This interface is used to resolve resources during an XML parse.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamException
    The base exception for unexpected processing errors.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Classes in javax.xml.stream used by javax.xml.stream.events
    Class and Description
    Location
    Provides information on the location of an event.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamException
    The base exception for unexpected processing errors.
  • Classes in javax.xml.stream used by javax.xml.stream.util
    Class and Description
    Location
    Provides information on the location of an event.
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamException
    The base exception for unexpected processing errors.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
  • Classes in javax.xml.stream used by javax.xml.transform.stax
    Class and Description
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLStreamException
    The base exception for unexpected processing errors.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StreamFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface StreamFilter

  • public interface StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    Since:
    1.6
    Version:
    1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean accept(XMLStreamReader reader)
      Tests whether the current state is part of this stream.

    • Method Detail

      • accept

        boolean accept(XMLStreamReader reader)
        Tests whether the current state is part of this stream. This method will return true if this filter accepts this event and false otherwise. The method should not change the state of the reader when accepting a state.
        Parameters:
        reader - the event to test
        Returns:
        true if this filter accepts this event, false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLEventFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Class XMLEventFactory

  • java.lang.Object
    • javax.xml.stream.XMLEventFactory

  • public abstract class XMLEventFactory
extends Object
    This interface defines a utility class for creating instances of XMLEvents
    Since:
    1.6
    Version:
    1.2
    See Also:
    StartElement, EndElement, ProcessingInstruction, Comment, Characters, StartDocument, EndDocument, DTD

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | XMLEventFactory()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      abstract Attribute createAttribute(QName name, String value)
      Create a new Attribute
      abstract Attribute createAttribute(String localName, String value)
      Create a new Attribute
      abstract Attribute createAttribute(String prefix, String namespaceURI, String localName, String value)
      Create a new Attribute
      abstract Characters createCData(String content)
      Create a Characters event with the CData flag set to true
      abstract Characters createCharacters(String content)
      Create a Characters event, this method does not check if the content is all whitespace.
      abstract Comment createComment(String text)
      Create a comment
      abstract DTD createDTD(String dtd)
      Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
      abstract EndDocument createEndDocument()
      Creates a new instance of an EndDocument event
      abstract EndElement createEndElement(QName name, Iterator namespaces)
      Create a new EndElement
      abstract EndElement createEndElement(String prefix, String namespaceUri, String localName)
      Create a new EndElement
      abstract EndElement createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces)
      Create a new EndElement
      abstract EntityReference createEntityReference(String name, EntityDeclaration declaration)
      Creates a new instance of a EntityReference event
      abstract Characters createIgnorableSpace(String content)
      Create an ignorable space
      abstract Namespace createNamespace(String namespaceURI)
      Create a new default Namespace
      abstract Namespace createNamespace(String prefix, String namespaceUri)
      Create a new Namespace
      abstract ProcessingInstruction createProcessingInstruction(String target, String data)
      Create a processing instruction
      abstract Characters createSpace(String content)
      Create a Characters event with the isSpace flag set to true
      abstract StartDocument createStartDocument()
      Creates a new instance of a StartDocument event
      abstract StartDocument createStartDocument(String encoding)
      Creates a new instance of a StartDocument event
      abstract StartDocument createStartDocument(String encoding, String version)
      Creates a new instance of a StartDocument event
      abstract StartDocument createStartDocument(String encoding, String version, boolean standalone)
      Creates a new instance of a StartDocument event
      abstract StartElement createStartElement(QName name, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement createStartElement(String prefix, String namespaceUri, String localName)
      Create a new StartElement.
      abstract StartElement createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
      Create a new StartElement.
      static XMLEventFactory newFactory()
      Create a new instance of the factory.
      static XMLEventFactory newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLEventFactory newInstance()
      Creates a new instance of the factory in exactly the same manner as the newFactory() method.
      static XMLEventFactory newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      abstract void setLocation(Location location)
      This method allows setting of the Location on each event that is created by this factory.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XMLEventFactory

        protected XMLEventFactory()

    • Method Detail

      • newInstance

        public static XMLEventFactory newInstance()
                                   throws FactoryConfigurationError
        Creates a new instance of the factory in exactly the same manner as the newFactory() method.
        Throws:
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLEventFactory newFactory()
                                  throws FactoryConfigurationError
        Create a new instance of the factory.

        This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLEventFactory implementation class to load:

        • Use the javax.xml.stream.XMLEventFactory system property.
        • Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, the system-default implementation is returned.

        Once an application has obtained a reference to a XMLEventFactory it can use the factory to configure and obtain stream instances.

        Note that this is a new method that replaces the deprecated newInstance() method. No changes in behavior are defined by this replacement method relative to the deprecated method.

        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • newInstance

        public static XMLEventFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Deprecated. This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
        Create a new instance of the factory
        Parameters:
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        Returns:
        the factory implementation
        Throws:
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLEventFactory newFactory(String factoryId,
                                         ClassLoader classLoader)
                                  throws FactoryConfigurationError
        Create a new instance of the factory. If the classLoader argument is null, then the ContextClassLoader is used.

        This method uses the following ordered lookup procedure to determine the XMLEventFactory implementation class to load:

        • Use the value of the system property identified by factoryId.
        • Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the given factoryId.
        • If factoryId is "javax.xml.stream.XMLEventFactory", use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the specified ClassLoader. If classLoader is null, the default loading mechanism will apply: That is, the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, throws a FactoryConfigurationError.

        Note that this is a new method that replaces the deprecated newInstance(String factoryId, ClassLoader classLoader) method. No changes in behavior are defined by this replacement method relative to the deprecated method.

        API Note:
        The parameter factoryId defined here is inconsistent with that of other JAXP factories where the first parameter is fully qualified factory class name that provides implementation of the factory.
        Parameters:
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        Returns:
        the factory implementation
        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • setLocation

        public abstract void setLocation(Location location)
        This method allows setting of the Location on each event that is created by this factory. The values are copied by value into the events created by this factory. To reset the location information set the location to null.
        Parameters:
        location - the location to set on each event created

      • createAttribute

        public abstract Attribute createAttribute(String prefix,
                                          String namespaceURI,
                                          String localName,
                                          String value)
        Create a new Attribute
        Parameters:
        prefix - the prefix of this attribute, may not be null
        namespaceURI - the attribute value is set to this value, may not be null
        localName - the local name of the XML name of the attribute, localName cannot be null
        value - the attribute value to set, may not be null
        Returns:
        the Attribute with specified values

      • createAttribute

        public abstract Attribute createAttribute(String localName,
                                          String value)
        Create a new Attribute
        Parameters:
        localName - the local name of the XML name of the attribute, localName cannot be null
        value - the attribute value to set, may not be null
        Returns:
        the Attribute with specified values

      • createAttribute

        public abstract Attribute createAttribute(QName name,
                                          String value)
        Create a new Attribute
        Parameters:
        name - the qualified name of the attribute, may not be null
        value - the attribute value to set, may not be null
        Returns:
        the Attribute with specified values

      • createNamespace

        public abstract Namespace createNamespace(String namespaceURI)
        Create a new default Namespace
        Parameters:
        namespaceURI - the default namespace uri
        Returns:
        the Namespace with the specified value

      • createNamespace

        public abstract Namespace createNamespace(String prefix,
                                          String namespaceUri)
        Create a new Namespace
        Parameters:
        prefix - the prefix of this namespace, may not be null
        namespaceUri - the attribute value is set to this value, may not be null
        Returns:
        the Namespace with the specified values

      • createStartElement

        public abstract StartElement createStartElement(QName name,
                                                Iterator attributes,
                                                Iterator namespaces)
        Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.
        Parameters:
        name - the qualified name of the attribute, may not be null
        attributes - an optional unordered set of objects that implement Attribute to add to the new StartElement, may be null
        namespaces - an optional unordered set of objects that implement Namespace to add to the new StartElement, may be null
        Returns:
        an instance of the requested StartElement

      • createStartElement

        public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName)
        Create a new StartElement. This defaults the NamespaceContext to an empty NamespaceContext. Querying this event for its namespaces or attributes will result in an empty iterator being returned.
        Parameters:
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        Returns:
        an instance of the requested StartElement

      • createStartElement

        public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName,
                                                Iterator attributes,
                                                Iterator namespaces)
        Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.
        Parameters:
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        attributes - an unordered set of objects that implement Attribute to add to the new StartElement
        namespaces - an unordered set of objects that implement Namespace to add to the new StartElement
        Returns:
        an instance of the requested StartElement

      • createStartElement

        public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName,
                                                Iterator attributes,
                                                Iterator namespaces,
                                                NamespaceContext context)
        Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.
        Parameters:
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        attributes - an unordered set of objects that implement Attribute to add to the new StartElement, may be null
        namespaces - an unordered set of objects that implement Namespace to add to the new StartElement, may be null
        context - the namespace context of this element
        Returns:
        an instance of the requested StartElement

      • createEndElement

        public abstract EndElement createEndElement(QName name,
                                            Iterator namespaces)
        Create a new EndElement
        Parameters:
        name - the qualified name of the EndElement
        namespaces - an optional unordered set of objects that implement Namespace that have gone out of scope, may be null
        Returns:
        an instance of the requested EndElement

      • createEndElement

        public abstract EndElement createEndElement(String prefix,
                                            String namespaceUri,
                                            String localName)
        Create a new EndElement
        Parameters:
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        Returns:
        an instance of the requested EndElement

      • createEndElement

        public abstract EndElement createEndElement(String prefix,
                                            String namespaceUri,
                                            String localName,
                                            Iterator namespaces)
        Create a new EndElement
        Parameters:
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        namespaces - an unordered set of objects that implement Namespace that have gone out of scope, may be null
        Returns:
        an instance of the requested EndElement

      • createCharacters

        public abstract Characters createCharacters(String content)
        Create a Characters event, this method does not check if the content is all whitespace. To create a space event use #createSpace(String)
        Parameters:
        content - the string to create
        Returns:
        a Characters event

      • createCData

        public abstract Characters createCData(String content)
        Create a Characters event with the CData flag set to true
        Parameters:
        content - the string to create
        Returns:
        a Characters event

      • createSpace

        public abstract Characters createSpace(String content)
        Create a Characters event with the isSpace flag set to true
        Parameters:
        content - the content of the space to create
        Returns:
        a Characters event

      • createIgnorableSpace

        public abstract Characters createIgnorableSpace(String content)
        Create an ignorable space
        Parameters:
        content - the space to create
        Returns:
        a Characters event

      • createStartDocument

        public abstract StartDocument createStartDocument()
        Creates a new instance of a StartDocument event
        Returns:
        a StartDocument event

      • createStartDocument

        public abstract StartDocument createStartDocument(String encoding,
                                                  String version,
                                                  boolean standalone)
        Creates a new instance of a StartDocument event
        Parameters:
        encoding - the encoding style
        version - the XML version
        standalone - the status of standalone may be set to "true" or "false"
        Returns:
        a StartDocument event

      • createStartDocument

        public abstract StartDocument createStartDocument(String encoding,
                                                  String version)
        Creates a new instance of a StartDocument event
        Parameters:
        encoding - the encoding style
        version - the XML version
        Returns:
        a StartDocument event

      • createStartDocument

        public abstract StartDocument createStartDocument(String encoding)
        Creates a new instance of a StartDocument event
        Parameters:
        encoding - the encoding style
        Returns:
        a StartDocument event

      • createEndDocument

        public abstract EndDocument createEndDocument()
        Creates a new instance of an EndDocument event
        Returns:
        an EndDocument event

      • createEntityReference

        public abstract EntityReference createEntityReference(String name,
                                                      EntityDeclaration declaration)
        Creates a new instance of a EntityReference event
        Parameters:
        name - The name of the reference
        declaration - the declaration for the event
        Returns:
        an EntityReference event

      • createComment

        public abstract Comment createComment(String text)
        Create a comment
        Parameters:
        text - The text of the comment a Comment event

      • createProcessingInstruction

        public abstract ProcessingInstruction createProcessingInstruction(String target,
                                                                  String data)
        Create a processing instruction
        Parameters:
        target - The target of the processing instruction
        data - The text of the processing instruction
        Returns:
        a ProcessingInstruction event

      • createDTD

        public abstract DTD createDTD(String dtd)
        Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
        Parameters:
        dtd - the text of the document type definition
        Returns:
        a DTD event
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLEventReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLEventReader

  • All Superinterfaces:
    Iterator
    All Known Implementing Classes:
    EventReaderDelegate

    public interface XMLEventReader
extends Iterator
    This is the top level interface for parsing XML Events. It provides the ability to peek at the next event and returns configuration information through the property interface.
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLInputFactory, XMLEventWriter

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void close()
      Frees any resources associated with this Reader.
      String getElementText()
      Reads the content of a text-only element.
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      boolean hasNext()
      Check if there are more events.
      XMLEvent nextEvent()
      Get the next XMLEvent
      XMLEvent nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent peek()
      Check the next XMLEvent without reading it from the stream.

      • Methods inherited from interface java.util.Iterator

        forEachRemaining, next, remove

    • Method Detail

      • nextEvent

        XMLEvent nextEvent()
            throws XMLStreamException
        Get the next XMLEvent
        Throws:
        XMLStreamException - if there is an error with the underlying XML.
        NoSuchElementException - iteration has no more elements.
        See Also:
        XMLEvent

      • hasNext

        boolean hasNext()
        Check if there are more events. Returns true if there are more events and false otherwise.
        Specified by:
        hasNext in interface Iterator
        Returns:
        true if the event reader has more events, false otherwise

      • peek

        XMLEvent peek()
       throws XMLStreamException
        Check the next XMLEvent without reading it from the stream. Returns null if the stream is at EOF or has no more XMLEvents. A call to peek() will be equal to the next return of next().
        Throws:
        XMLStreamException
        See Also:
        XMLEvent

      • getElementText

        String getElementText()
               throws XMLStreamException
        Reads the content of a text-only element. Precondition: the current event is START_ELEMENT. Postcondition: The current event is the corresponding END_ELEMENT.
        Throws:
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • nextTag

        XMLEvent nextTag()
          throws XMLStreamException
        Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached. If anything other than space characters are encountered, an exception is thrown. This method should be used when processing element-only content because the parser is not able to recognize ignorable whitespace if the DTD is missing or not interpreted.
        Throws:
        XMLStreamException - if anything other than space characters are encountered

      • getProperty

        Object getProperty(String name)
            throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        Parameters:
        name - The name of the property
        Returns:
        The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported

      • close

        void close()
    throws XMLStreamException
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        Throws:
        XMLStreamException - if there are errors freeing associated resources
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLEventWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLEventWriter

  • All Superinterfaces:
    XMLEventConsumer

    public interface XMLEventWriter
extends XMLEventConsumer
    This is the top level interface for writing XML documents. Instances of this interface are not required to validate the form of the XML.
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLEventReader, XMLEvent, Characters, ProcessingInstruction, StartElement, EndElement

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add(XMLEvent event)
      Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
      void add(XMLEventReader reader)
      Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
      void close()
      Frees any resources associated with this stream
      void flush()
      Writes any cached events to the underlying output mechanism
      NamespaceContext getNamespaceContext()
      Returns the current namespace context.
      String getPrefix(String uri)
      Gets the prefix the uri is bound to
      void setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.

    • Method Detail

      • flush

        void flush()
    throws XMLStreamException
        Writes any cached events to the underlying output mechanism
        Throws:
        XMLStreamException

      • close

        void close()
    throws XMLStreamException
        Frees any resources associated with this stream
        Throws:
        XMLStreamException

      • add

        void add(XMLEvent event)
  throws XMLStreamException
        Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
        Required and optional fields for events added to the writer
        Event Type | Required Fields | Optional Fields | Required Behavior
        START_ELEMENT | QName name | namespaces , attributes | A START_ELEMENT will be written by writing the name, namespaces, and attributes of the event in XML 1.0 valid syntax for START_ELEMENTs. The name is written by looking up the prefix for the namespace uri. The writer can be configured to respect prefixes of QNames. If the writer is respecting prefixes it must use the prefix set on the QName. The default behavior is to lookup the value for the prefix on the EventWriter's internal namespace context. Each attribute (if any) is written using the behavior specified in the attribute section of this table. Each namespace (if any) is written using the behavior specified in the namespace section of this table.
        END_ELEMENT | Qname name | None | A well formed END_ELEMENT tag is written. The name is written by looking up the prefix for the namespace uri. The writer can be configured to respect prefixes of QNames. If the writer is respecting prefixes it must use the prefix set on the QName. The default behavior is to lookup the value for the prefix on the EventWriter's internal namespace context. If the END_ELEMENT name does not match the START_ELEMENT name an XMLStreamException is thrown.
        ATTRIBUTE | QName name , String value | QName type | An attribute is written using the same algorithm to find the lexical form as used in START_ELEMENT. The default is to use double quotes to wrap attribute values and to escape any double quotes found in the value. The type value is ignored.
        NAMESPACE | String prefix, String namespaceURI, boolean isDefaultNamespaceDeclaration | None | A namespace declaration is written. If the namespace is a default namespace declaration (isDefault is true) then xmlns="$namespaceURI" is written and the prefix is optional. If isDefault is false, the prefix must be declared and the writer must prepend xmlns to the prefix and write out a standard prefix declaration.
        PROCESSING_INSTRUCTION | None | String target, String data | The data does not need to be present and may be null. Target is required and many not be null. The writer will write data section directly after the target, enclosed in appropriate XML 1.0 syntax
        COMMENT | None | String comment | If the comment is present (not null) it is written, otherwise an an empty comment is written
        START_DOCUMENT | None | String encoding , boolean standalone, String version | A START_DOCUMENT event is not required to be written to the stream. If present the attributes are written inside the appropriate XML declaration syntax
        END_DOCUMENT | None | None | Nothing is written to the output
        DTD | String DocumentTypeDefinition | None | The DocumentTypeDefinition is written to the output
        Specified by:
        add in interface XMLEventConsumer
        Parameters:
        event - the event to be added
        Throws:
        XMLStreamException

      • add

        void add(XMLEventReader reader)
  throws XMLStreamException
        Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
        Parameters:
        reader - the event stream to add to the output
        Throws:
        XMLStreamException

      • getPrefix

        String getPrefix(String uri)
          throws XMLStreamException
        Gets the prefix the uri is bound to
        Parameters:
        uri - the uri to look up
        Throws:
        XMLStreamException

      • setPrefix

        void setPrefix(String prefix,
               String uri)
        throws XMLStreamException
        Sets the prefix the uri is bound to. This prefix is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the prefix is bound in the root scope.
        Parameters:
        prefix - the prefix to bind to the uri
        uri - the uri to bind to the prefix
        Throws:
        XMLStreamException

      • setDefaultNamespace

        void setDefaultNamespace(String uri)
                  throws XMLStreamException
        Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the uri is bound in the root scope.
        Parameters:
        uri - the uri to bind to the default namespace
        Throws:
        XMLStreamException

      • setNamespaceContext

        void setNamespaceContext(NamespaceContext context)
                  throws XMLStreamException
        Sets the current namespace context for prefix and uri bindings. This context becomes the root namespace context for writing and will replace the current root namespace context. Subsequent calls to setPrefix and setDefaultNamespace will bind namespaces using the context passed to the method as the root context for resolving namespaces.
        Parameters:
        context - the namespace context to use for this writer
        Throws:
        XMLStreamException

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Returns the current namespace context.
        Returns:
        the current namespace context
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLInputFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Class XMLInputFactory

  • java.lang.Object
    • javax.xml.stream.XMLInputFactory

  • public abstract class XMLInputFactory
extends Object
    Defines an abstract implementation of a factory for getting streams. The following table defines the standard properties of this specification. Each property varies in the level of support required by each implementation. The level of support required is described in the 'Required' column.
    Configuration parameters
    Property Name | Behavior | Return type | Default Value | Required
    javax.xml.stream.isValidating | Turns on/off implementation specific DTD validation | Boolean | False | No
    javax.xml.stream.isNamespaceAware | Turns on/off namespace processing for XML 1.0 support | Boolean | True | True (required) / False (optional)
    javax.xml.stream.isCoalescing | Requires the processor to coalesce adjacent character data | Boolean | False | Yes
    javax.xml.stream.isReplacingEntityReferences | replace internal entity references with their replacement text and report them as characters | Boolean | True | Yes
    javax.xml.stream.isSupportingExternalEntities | Resolve external parsed entities | Boolean | Unspecified | Yes
    javax.xml.stream.supportDTD | Use this property to request processors that do not support DTDs | Boolean | True | Yes
    javax.xml.stream.reporter | sets/gets the impl of the XMLReporter | javax.xml.stream.XMLReporter | Null | Yes
    javax.xml.stream.resolver | sets/gets the impl of the XMLResolver interface | javax.xml.stream.XMLResolver | Null | Yes
    javax.xml.stream.allocator | sets/gets the impl of the XMLEventAllocator interface | javax.xml.stream.util.XMLEventAllocator | Null | Yes
    Since:
    1.6
    Version:
    1.2
    See Also:
    XMLOutputFactory, XMLEventReader, XMLStreamReader, EventFilter, XMLReporter, XMLResolver, XMLEventAllocator

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ALLOCATOR
      The property used to set/get the implementation of the allocator
      static String IS_COALESCING
      The property that requires the parser to coalesce adjacent character data sections
      static String IS_NAMESPACE_AWARE
      The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
      static String IS_REPLACING_ENTITY_REFERENCES
      Requires the parser to replace internal entity references with their replacement text and report them as characters
      static String IS_SUPPORTING_EXTERNAL_ENTITIES
      The property that requires the parser to resolve external parsed entities
      static String IS_VALIDATING
      The property used to turn on/off implementation specific validation
      static String REPORTER
      The property used to set/get the implementation of the XMLReporter interface
      static String RESOLVER
      The property used to set/get the implementation of the XMLResolver
      static String SUPPORT_DTD
      The property that requires the parser to support DTDs

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | XMLInputFactory()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      abstract XMLEventReader createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
      abstract XMLStreamReader createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLEventReader createXMLEventReader(InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader createXMLEventReader(InputStream stream, String encoding)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader createXMLEventReader(Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLEventReader createXMLEventReader(String systemId, InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader createXMLEventReader(String systemId, Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.
      abstract XMLStreamReader createXMLStreamReader(InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader createXMLStreamReader(InputStream stream, String encoding)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader createXMLStreamReader(Reader reader)
      Create a new XMLStreamReader from a reader
      abstract XMLStreamReader createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.
      abstract XMLStreamReader createXMLStreamReader(String systemId, InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader createXMLStreamReader(String systemId, Reader reader)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLEventAllocator getEventAllocator()
      Gets the allocator used by streams created with this factory
      abstract Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      abstract XMLReporter getXMLReporter()
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      abstract XMLResolver getXMLResolver()
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      abstract boolean isPropertySupported(String name)
      Query the set of properties that this factory supports.
      static XMLInputFactory newFactory()
      Create a new instance of the factory.
      static XMLInputFactory newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLInputFactory newInstance()
      Creates a new instance of the factory in exactly the same manner as the newFactory() method.
      static XMLInputFactory newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      abstract void setEventAllocator(XMLEventAllocator allocator)
      Set a user defined event allocator for events
      abstract void setProperty(String name, Object value)
      Allows the user to set specific feature/property on the underlying implementation.
      abstract void setXMLReporter(XMLReporter reporter)
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      abstract void setXMLResolver(XMLResolver resolver)
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • IS_NAMESPACE_AWARE

        public static final String IS_NAMESPACE_AWARE
        The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
        See Also:
        Constant Field Values

      • IS_VALIDATING

        public static final String IS_VALIDATING
        The property used to turn on/off implementation specific validation
        See Also:
        Constant Field Values

      • IS_COALESCING

        public static final String IS_COALESCING
        The property that requires the parser to coalesce adjacent character data sections
        See Also:
        Constant Field Values

      • IS_REPLACING_ENTITY_REFERENCES

        public static final String IS_REPLACING_ENTITY_REFERENCES
        Requires the parser to replace internal entity references with their replacement text and report them as characters
        See Also:
        Constant Field Values

      • IS_SUPPORTING_EXTERNAL_ENTITIES

        public static final String IS_SUPPORTING_EXTERNAL_ENTITIES
        The property that requires the parser to resolve external parsed entities
        See Also:
        Constant Field Values

      • SUPPORT_DTD

        public static final String SUPPORT_DTD
        The property that requires the parser to support DTDs
        See Also:
        Constant Field Values

      • REPORTER

        public static final String REPORTER
        The property used to set/get the implementation of the XMLReporter interface
        See Also:
        Constant Field Values

      • RESOLVER

        public static final String RESOLVER
        The property used to set/get the implementation of the XMLResolver
        See Also:
        Constant Field Values

      • ALLOCATOR

        public static final String ALLOCATOR
        The property used to set/get the implementation of the allocator
        See Also:
        Constant Field Values

    • Constructor Detail

      • XMLInputFactory

        protected XMLInputFactory()

    • Method Detail

      • newInstance

        public static XMLInputFactory newInstance()
                                   throws FactoryConfigurationError
        Creates a new instance of the factory in exactly the same manner as the newFactory() method.
        Throws:
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLInputFactory newFactory()
                                  throws FactoryConfigurationError
        Create a new instance of the factory.

        This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLInputFactory implementation class to load:

        • Use the javax.xml.stream.XMLInputFactory system property.
        • Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, the system-default implementation is returned.

        Once an application has obtained a reference to a XMLInputFactory it can use the factory to configure and obtain stream instances.

        Note that this is a new method that replaces the deprecated newInstance() method. No changes in behavior are defined by this replacement method relative to the deprecated method.

        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • newInstance

        public static XMLInputFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Deprecated. This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
        Create a new instance of the factory
        Parameters:
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        Returns:
        the factory implementation
        Throws:
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLInputFactory newFactory(String factoryId,
                                         ClassLoader classLoader)
                                  throws FactoryConfigurationError
        Create a new instance of the factory. If the classLoader argument is null, then the ContextClassLoader is used.

        This method uses the following ordered lookup procedure to determine the XMLInputFactory implementation class to load:

        • Use the value of the system property identified by factoryId.
        • Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the given factoryId.
        • If factoryId is "javax.xml.stream.XMLInputFactory", use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the specified ClassLoader. If classLoader is null, the default loading mechanism will apply: That is, the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, throws a FactoryConfigurationError.

        Note that this is a new method that replaces the deprecated newInstance(String factoryId, ClassLoader classLoader) method. No changes in behavior are defined by this replacement method relative to the deprecated method.

        API Note:
        The parameter factoryId defined here is inconsistent with that of other JAXP factories where the first parameter is fully qualified factory class name that provides implementation of the factory.
        Parameters:
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        Returns:
        the factory implementation
        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(Reader reader)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a reader
        Parameters:
        reader - the XML data to read from
        Throws:
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(Source source)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a JAXP source. This method is optional.
        Parameters:
        source - the source to read from
        Throws:
        UnsupportedOperationException - if this method is not supported by this XMLInputFactory
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(InputStream stream)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        Parameters:
        stream - the InputStream to read from
        Throws:
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(InputStream stream,
                                                      String encoding)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        Parameters:
        stream - the InputStream to read from
        encoding - the character encoding of the stream
        Throws:
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                                      InputStream stream)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        Parameters:
        systemId - the system ID of the stream
        stream - the InputStream to read from
        Throws:
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                                      Reader reader)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        Parameters:
        systemId - the system ID of the stream
        reader - the InputStream to read from
        Throws:
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(Reader reader)
                                             throws XMLStreamException
        Create a new XMLEventReader from a reader
        Parameters:
        reader - the XML data to read from
        Throws:
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(String systemId,
                                                    Reader reader)
                                             throws XMLStreamException
        Create a new XMLEventReader from a reader
        Parameters:
        systemId - the system ID of the input
        reader - the XML data to read from
        Throws:
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(XMLStreamReader reader)
                                             throws XMLStreamException
        Create a new XMLEventReader from an XMLStreamReader. After being used to construct the XMLEventReader instance returned from this method the XMLStreamReader must not be used.
        Parameters:
        reader - the XMLStreamReader to read from (may not be modified)
        Returns:
        a new XMLEventReader
        Throws:
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(Source source)
                                             throws XMLStreamException
        Create a new XMLEventReader from a JAXP source. Support of this method is optional.
        Parameters:
        source - the source to read from
        Throws:
        UnsupportedOperationException - if this method is not supported by this XMLInputFactory
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(InputStream stream)
                                             throws XMLStreamException
        Create a new XMLEventReader from a java.io.InputStream
        Parameters:
        stream - the InputStream to read from
        Throws:
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(InputStream stream,
                                                    String encoding)
                                             throws XMLStreamException
        Create a new XMLEventReader from a java.io.InputStream
        Parameters:
        stream - the InputStream to read from
        encoding - the character encoding of the stream
        Throws:
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(String systemId,
                                                    InputStream stream)
                                             throws XMLStreamException
        Create a new XMLEventReader from a java.io.InputStream
        Parameters:
        systemId - the system ID of the stream
        stream - the InputStream to read from
        Throws:
        XMLStreamException

      • createFilteredReader

        public abstract XMLStreamReader createFilteredReader(XMLStreamReader reader,
                                                     StreamFilter filter)
                                              throws XMLStreamException
        Create a filtered reader that wraps the filter around the reader
        Parameters:
        reader - the reader to filter
        filter - the filter to apply to the reader
        Throws:
        XMLStreamException

      • createFilteredReader

        public abstract XMLEventReader createFilteredReader(XMLEventReader reader,
                                                    EventFilter filter)
                                             throws XMLStreamException
        Create a filtered event reader that wraps the filter around the event reader
        Parameters:
        reader - the event reader to wrap
        filter - the filter to apply to the event reader
        Throws:
        XMLStreamException

      • getXMLResolver

        public abstract XMLResolver getXMLResolver()
        The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

      • setXMLResolver

        public abstract void setXMLResolver(XMLResolver resolver)
        The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
        Parameters:
        resolver - the resolver to use to resolve references

      • getXMLReporter

        public abstract XMLReporter getXMLReporter()
        The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

      • setXMLReporter

        public abstract void setXMLReporter(XMLReporter reporter)
        The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
        Parameters:
        reporter - the resolver to use to report non fatal errors

      • setProperty

        public abstract void setProperty(String name,
                                 Object value)
                          throws IllegalArgumentException
        Allows the user to set specific feature/property on the underlying implementation. The underlying implementation is not required to support every setting of every property in the specification and may use IllegalArgumentException to signal that an unsupported property may not be set with the specified value.

        All implementations that implement JAXP 1.5 or newer are required to support the XMLConstants.ACCESS_EXTERNAL_DTD property.

        • Access to external DTDs, external Entity References is restricted to the protocols specified by the property. If access is denied during parsing due to the restriction of this property, XMLStreamException will be thrown by the XMLStreamReader.next() or XMLEventReader.nextEvent() method.

        Parameters:
        name - The name of the property (may not be null)
        value - The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported

      • getProperty

        public abstract Object getProperty(String name)
                            throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        Parameters:
        name - The name of the property (may not be null)
        Returns:
        The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported

      • isPropertySupported

        public abstract boolean isPropertySupported(String name)
        Query the set of properties that this factory supports.
        Parameters:
        name - The name of the property (may not be null)
        Returns:
        true if the property is supported and false otherwise

      • setEventAllocator

        public abstract void setEventAllocator(XMLEventAllocator allocator)
        Set a user defined event allocator for events
        Parameters:
        allocator - the user defined allocator

      • getEventAllocator

        public abstract XMLEventAllocator getEventAllocator()
        Gets the allocator used by streams created with this factory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLOutputFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Class XMLOutputFactory

  • java.lang.Object
    • javax.xml.stream.XMLOutputFactory

  • public abstract class XMLOutputFactory
extends Object
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters. The following table defines the standard properties of this specification. Each property varies in the level of support required by each implementation. The level of support required is described in the 'Required' column.
    Configuration parameters
    Property Name | Behavior | Return type | Default Value | Required
    javax.xml.stream.isRepairingNamespaces | defaults prefixes on the output side | Boolean | False | Yes

    The following paragraphs describe the namespace and prefix repair algorithm:

    The property can be set with the following code line: setProperty("javax.xml.stream.isRepairingNamespaces",new Boolean(true|false));

    This property specifies that the writer default namespace prefix declarations. The default value is false.

    If a writer isRepairingNamespaces it will create a namespace declaration on the current StartElement for any attribute that does not currently have a namespace declaration in scope. If the StartElement has a uri but no prefix specified a prefix will be assigned, if the prefix has not been declared in a parent of the current StartElement it will be declared on the current StartElement. If the defaultNamespace is bound and in scope and the default namespace matches the URI of the attribute or StartElement QName no prefix will be assigned.

    If an element or attribute name has a prefix, but is not bound to any namespace URI, then the prefix will be removed during serialization.

    If element and/or attribute names in the same start or empty-element tag are bound to different namespace URIs and are using the same prefix then the element or the first occurring attribute retains the original prefix and the following attributes have their prefixes replaced with a new prefix that is bound to the namespace URIs of those attributes.

    If an element or attribute name uses a prefix that is bound to a different URI than that inherited from the namespace context of the parent of that element and there is no namespace declaration in the context of the current element then such a namespace declaration is added.

    If an element or attribute name is bound to a prefix and there is a namespace declaration that binds that prefix to a different URI then that namespace declaration is either removed if the correct mapping is inherited from the parent context of that element, or changed to the namespace URI of the element or attribute using that prefix.

    Since:
    1.6
    Version:
    1.2
    See Also:
    XMLInputFactory, XMLEventWriter, XMLStreamWriter

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String IS_REPAIRING_NAMESPACES
      Property used to set prefix defaulting on the output side

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | XMLOutputFactory()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      abstract XMLEventWriter createXMLEventWriter(OutputStream stream)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter createXMLEventWriter(OutputStream stream, String encoding)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLEventWriter createXMLEventWriter(Writer stream)
      Create a new XMLEventWriter that writes to a writer
      abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream, String encoding)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.
      abstract XMLStreamWriter createXMLStreamWriter(Writer stream)
      Create a new XMLStreamWriter that writes to a writer
      abstract Object getProperty(String name)
      Get a feature/property on the underlying implementation
      abstract boolean isPropertySupported(String name)
      Query the set of properties that this factory supports.
      static XMLOutputFactory newFactory()
      Create a new instance of the factory.
      static XMLOutputFactory newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLOutputFactory newInstance()
      Creates a new instance of the factory in exactly the same manner as the newFactory() method.
      static XMLInputFactory newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method newFactory(java.lang.String, java.lang.ClassLoader) instead.
      abstract void setProperty(String name, Object value)
      Allows the user to set specific features/properties on the underlying implementation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • IS_REPAIRING_NAMESPACES

        public static final String IS_REPAIRING_NAMESPACES
        Property used to set prefix defaulting on the output side
        See Also:
        Constant Field Values

    • Constructor Detail

      • XMLOutputFactory

        protected XMLOutputFactory()

    • Method Detail

      • newInstance

        public static XMLOutputFactory newInstance()
                                    throws FactoryConfigurationError
        Creates a new instance of the factory in exactly the same manner as the newFactory() method.
        Throws:
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLOutputFactory newFactory()
                                   throws FactoryConfigurationError
        Create a new instance of the factory.

        This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLOutputFactory implementation class to load:

        • Use the javax.xml.stream.XMLOutputFactory system property.
        • Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, the system-default implementation is returned.

          • Once an application has obtained a reference to a XMLOutputFactory it can use the factory to configure and obtain stream instances.

          Note that this is a new method that replaces the deprecated newInstance() method. No changes in behavior are defined by this replacement method relative to the deprecated method.

        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • newInstance

        public static XMLInputFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Deprecated. This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method newFactory(java.lang.String, java.lang.ClassLoader) instead.
        Create a new instance of the factory.
        Parameters:
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        Returns:
        the factory implementation
        Throws:
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLOutputFactory newFactory(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Create a new instance of the factory. If the classLoader argument is null, then the ContextClassLoader is used.

        This method uses the following ordered lookup procedure to determine the XMLOutputFactory implementation class to load:

        • Use the value of the system property identified by factoryId.
        • Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the given factoryId.
        • If factoryId is "javax.xml.stream.XMLOutputFactory", use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the specified ClassLoader. If classLoader is null, the default loading mechanism will apply: That is, the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, throws a FactoryConfigurationError.
        API Note:
        The parameter factoryId defined here is inconsistent with that of other JAXP factories where the first parameter is fully qualified factory class name that provides implementation of the factory.

        Note that this is a new method that replaces the deprecated newInstance(String factoryId, ClassLoader classLoader) method. The original method was incorrectly defined to return XMLInputFactory.

        Parameters:
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        Returns:
        the factory implementation
        Throws:
        FactoryConfigurationError - in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(Writer stream)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a writer
        Parameters:
        stream - the writer to write to
        Throws:
        XMLStreamException

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a stream
        Parameters:
        stream - the stream to write to
        Throws:
        XMLStreamException

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream,
                                                      String encoding)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a stream
        Parameters:
        stream - the stream to write to
        encoding - the encoding to use
        Throws:
        XMLStreamException

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(Result result)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a JAXP result. This method is optional.
        Parameters:
        result - the result to write to
        Throws:
        UnsupportedOperationException - if this method is not supported by this XMLOutputFactory
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(Result result)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a JAXP result. This method is optional.
        Parameters:
        result - the result to write to
        Throws:
        UnsupportedOperationException - if this method is not supported by this XMLOutputFactory
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(OutputStream stream)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a stream
        Parameters:
        stream - the stream to write to
        Throws:
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(OutputStream stream,
                                                    String encoding)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a stream
        Parameters:
        stream - the stream to write to
        encoding - the encoding to use
        Throws:
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(Writer stream)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a writer
        Parameters:
        stream - the stream to write to
        Throws:
        XMLStreamException

      • setProperty

        public abstract void setProperty(String name,
                                 Object value)
                          throws IllegalArgumentException
        Allows the user to set specific features/properties on the underlying implementation.
        Parameters:
        name - The name of the property
        value - The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported

      • getProperty

        public abstract Object getProperty(String name)
                            throws IllegalArgumentException
        Get a feature/property on the underlying implementation
        Parameters:
        name - The name of the property
        Returns:
        The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported

      • isPropertySupported

        public abstract boolean isPropertySupported(String name)
        Query the set of properties that this factory supports.
        Parameters:
        name - The name of the property (may not be null)
        Returns:
        true if the property is supported and false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLReporter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLReporter

  • public interface XMLReporter
    This interface is used to report non-fatal errors. Only warnings should be echoed through this interface.
    Since:
    1.6
    Version:
    1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void report(String message, String errorType, Object relatedInformation, Location location)
      Report the desired message in an application specific format.

    • Method Detail

      • report

        void report(String message,
            String errorType,
            Object relatedInformation,
            Location location)
     throws XMLStreamException
        Report the desired message in an application specific format. Only warnings and non-fatal errors should be reported through this interface. Fatal errors should be thrown as XMLStreamException.
        Parameters:
        message - the error message
        errorType - an implementation defined error type
        relatedInformation - information related to the error, if available
        location - the location of the error, if available
        Throws:
        XMLStreamException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLResolver

  • public interface XMLResolver
    This interface is used to resolve resources during an XML parse. If an application wishes to perform custom entity resolution it must register an instance of this interface with the XMLInputFactory using the setXMLResolver method.
    Since:
    1.6
    Version:
    1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object resolveEntity(String publicID, String systemID, String baseURI, String namespace)
      Retrieves a resource.

    • Method Detail

      • resolveEntity

        Object resolveEntity(String publicID,
                     String systemID,
                     String baseURI,
                     String namespace)
              throws XMLStreamException
        Retrieves a resource. This resource can be of the following three return types: (1) java.io.InputStream (2) javax.xml.stream.XMLStreamReader (3) java.xml.stream.XMLEventReader. If this method returns null the processor will attempt to resolve the entity using its default mechanism.
        Parameters:
        publicID - The public identifier of the external entity being referenced, or null if none was supplied.
        systemID - The system identifier of the external entity being referenced.
        baseURI - Absolute base URI associated with systemId.
        namespace - The namespace of the entity to resolve.
        Returns:
        The resource requested or null.
        Throws:
        XMLStreamException - if there was a failure attempting to resolve the resource.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLStreamConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLStreamConstants

  • All Known Subinterfaces:
    Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement, XMLEvent, XMLStreamReader
    All Known Implementing Classes:
    StreamReaderDelegate

    public interface XMLStreamConstants
    This interface declares the constants used in this API. Numbers in the range 0 to 256 are reserved for the specification, user defined events must use event codes outside that range.
    Since:
    1.6

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ATTRIBUTE
      Indicates an event is an attribute
      static int CDATA
      Indicates an event is a CDATA section
      static int CHARACTERS
      Indicates an event is characters
      static int COMMENT
      Indicates an event is a comment
      static int DTD
      Indicates an event is a DTD
      static int END_DOCUMENT
      Indicates an event is an end document
      static int END_ELEMENT
      Indicates an event is an end element
      static int ENTITY_DECLARATION
      Indicates a Entity Declaration
      static int ENTITY_REFERENCE
      Indicates an event is an entity reference
      static int NAMESPACE
      Indicates the event is a namespace declaration
      static int NOTATION_DECLARATION
      Indicates a Notation
      static int PROCESSING_INSTRUCTION
      Indicates an event is a processing instruction
      static int SPACE
      The characters are white space (see [XML], 2.10 "White Space Handling").
      static int START_DOCUMENT
      Indicates an event is a start document
      static int START_ELEMENT
      Indicates an event is a start element

    • Field Detail

      • START_ELEMENT

        static final int START_ELEMENT
        Indicates an event is a start element
        See Also:
        StartElement, Constant Field Values

      • END_ELEMENT

        static final int END_ELEMENT
        Indicates an event is an end element
        See Also:
        EndElement, Constant Field Values

      • PROCESSING_INSTRUCTION

        static final int PROCESSING_INSTRUCTION
        Indicates an event is a processing instruction
        See Also:
        ProcessingInstruction, Constant Field Values

      • CHARACTERS

        static final int CHARACTERS
        Indicates an event is characters
        See Also:
        Characters, Constant Field Values

      • COMMENT

        static final int COMMENT
        Indicates an event is a comment
        See Also:
        Comment, Constant Field Values

      • SPACE

        static final int SPACE
        The characters are white space (see [XML], 2.10 "White Space Handling"). Events are only reported as SPACE if they are ignorable white space. Otherwise they are reported as CHARACTERS.
        See Also:
        Characters, Constant Field Values

      • START_DOCUMENT

        static final int START_DOCUMENT
        Indicates an event is a start document
        See Also:
        StartDocument, Constant Field Values

      • END_DOCUMENT

        static final int END_DOCUMENT
        Indicates an event is an end document
        See Also:
        EndDocument, Constant Field Values

      • ENTITY_REFERENCE

        static final int ENTITY_REFERENCE
        Indicates an event is an entity reference
        See Also:
        EntityReference, Constant Field Values

      • ATTRIBUTE

        static final int ATTRIBUTE
        Indicates an event is an attribute
        See Also:
        Attribute, Constant Field Values

      • DTD

        static final int DTD
        Indicates an event is a DTD
        See Also:
        DTD, Constant Field Values

      • CDATA

        static final int CDATA
        Indicates an event is a CDATA section
        See Also:
        Characters, Constant Field Values

      • NAMESPACE

        static final int NAMESPACE
        Indicates the event is a namespace declaration
        See Also:
        Namespace, Constant Field Values

      • NOTATION_DECLARATION

        static final int NOTATION_DECLARATION
        Indicates a Notation
        See Also:
        NotationDeclaration, Constant Field Values

      • ENTITY_DECLARATION

        static final int ENTITY_DECLARATION
        Indicates a Entity Declaration
        See Also:
        NotationDeclaration, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLStreamException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Class XMLStreamException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.stream.XMLStreamException
  • All Implemented Interfaces:
    Serializable

    public class XMLStreamException
extends Exception
    The base exception for unexpected processing errors. This Exception class is used to report well-formedness errors as well as unexpected processing conditions.
    Since:
    1.6
    Version:
    1.0
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected Location | location
      protected Throwable | nested

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLStreamException()
      Default constructor
      XMLStreamException(String msg)
      Construct an exception with the assocated message.
      XMLStreamException(String msg, Location location)
      Construct an exception with the assocated message, exception and location.
      XMLStreamException(String msg, Location location, Throwable th)
      Construct an exception with the assocated message, exception and location.
      XMLStreamException(String msg, Throwable th)
      Construct an exception with the assocated message and exception
      XMLStreamException(Throwable th)
      Construct an exception with the assocated exception

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Location getLocation()
      Gets the location of the exception
      Throwable getNestedException()
      Gets the nested exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • nested

        protected Throwable nested

      • location

        protected Location location

    • Constructor Detail

      • XMLStreamException

        public XMLStreamException()
        Default constructor

      • XMLStreamException

        public XMLStreamException(String msg)
        Construct an exception with the assocated message.
        Parameters:
        msg - the message to report

      • XMLStreamException

        public XMLStreamException(Throwable th)
        Construct an exception with the assocated exception
        Parameters:
        th - a nested exception

      • XMLStreamException

        public XMLStreamException(String msg,
                          Throwable th)
        Construct an exception with the assocated message and exception
        Parameters:
        th - a nested exception
        msg - the message to report

      • XMLStreamException

        public XMLStreamException(String msg,
                          Location location,
                          Throwable th)
        Construct an exception with the assocated message, exception and location.
        Parameters:
        th - a nested exception
        msg - the message to report
        location - the location of the error

      • XMLStreamException

        public XMLStreamException(String msg,
                          Location location)
        Construct an exception with the assocated message, exception and location.
        Parameters:
        msg - the message to report
        location - the location of the error

    • Method Detail

      • getNestedException

        public Throwable getNestedException()
        Gets the nested exception.
        Returns:
        Nested exception

      • getLocation

        public Location getLocation()
        Gets the location of the exception
        Returns:
        the location of the exception, may be null if none is available
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLStreamReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLStreamReader

  • All Superinterfaces:
    XMLStreamConstants
    All Known Implementing Classes:
    StreamReaderDelegate

    public interface XMLStreamReader
extends XMLStreamConstants
    The XMLStreamReader interface allows forward, read-only access to XML. It is designed to be the lowest level and most efficient way to read XML data.

    The XMLStreamReader is designed to iterate over XML using next() and hasNext(). The data can be accessed using methods such as getEventType(), getNamespaceURI(), getLocalName() and getText();

    The next() method causes the reader to read the next parse event. The next() method returns an integer which identifies the type of event just read.

    The event type can be determined using getEventType().

    Parsing events are defined as the XML Declaration, a DTD, start tag, character data, white space, end tag, comment, or processing instruction. An attribute or namespace event may be encountered at the root level of a document as the result of a query operation.

    For XML 1.0 compliance an XML processor must pass the identifiers of declared unparsed entities, notation declarations and their associated identifiers to the application. This information is provided through the property API on this interface. The following two properties allow access to this information: javax.xml.stream.notations and javax.xml.stream.entities. When the current event is a DTD the following call will return a list of Notations List l = (List) getProperty("javax.xml.stream.notations"); The following call will return a list of entity declarations: List l = (List) getProperty("javax.xml.stream.entities"); These properties can only be accessed during a DTD event and are defined to return null if the information is not available.

    The following table describes which methods are valid in what state. If a method is called in an invalid state the method will throw a java.lang.IllegalStateException.

    Valid methods for each state
    Event Type | Valid Methods
    All States | getProperty(), hasNext(), require(), close(), getNamespaceURI(), isStartElement(), isEndElement(), isCharacters(), isWhiteSpace(), getNamespaceContext(), getEventType(),getLocation(), hasText(), hasName()
    START_ELEMENT | next(), getName(), getLocalName(), hasName(), getPrefix(), getAttributeXXX(), isAttributeSpecified(), getNamespaceXXX(), getElementText(), nextTag()
    ATTRIBUTE | next(), nextTag() getAttributeXXX(), isAttributeSpecified(),
    NAMESPACE | next(), nextTag() getNamespaceXXX()
    END_ELEMENT | next(), getName(), getLocalName(), hasName(), getPrefix(), getNamespaceXXX(), nextTag()
    CHARACTERS | next(), getTextXXX(), nextTag()
    CDATA | next(), getTextXXX(), nextTag()
    COMMENT | next(), getTextXXX(), nextTag()
    SPACE | next(), getTextXXX(), nextTag()
    START_DOCUMENT | next(), getEncoding(), getVersion(), isStandalone(), standaloneSet(), getCharacterEncodingScheme(), nextTag()
    END_DOCUMENT | close()
    PROCESSING_INSTRUCTION | next(), getPITarget(), getPIData(), nextTag()
    ENTITY_REFERENCE | next(), getLocalName(), getText(), nextTag()
    DTD | next(), getText(), nextTag()
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLEvent, XMLInputFactory, XMLStreamWriter

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void close()
      Frees any resources associated with this Reader.
      int getAttributeCount()
      Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
      String getAttributeLocalName(int index)
      Returns the localName of the attribute at the provided index
      QName getAttributeName(int index)
      Returns the qname of the attribute at the provided index
      String getAttributeNamespace(int index)
      Returns the namespace of the attribute at the provided index
      String getAttributePrefix(int index)
      Returns the prefix of this attribute at the provided index
      String getAttributeType(int index)
      Returns the XML type of the attribute at the provided index
      String getAttributeValue(int index)
      Returns the value of the attribute at the index
      String getAttributeValue(String namespaceURI, String localName)
      Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
      String getCharacterEncodingScheme()
      Returns the character encoding declared on the xml declaration Returns null if none was declared
      String getElementText()
      Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
      String getEncoding()
      Return input encoding if known or null if unknown.
      int getEventType()
      Returns an integer code that indicates the type of the event the cursor is pointing to.
      String getLocalName()
      Returns the (local) name of the current event.
      Location getLocation()
      Return the current location of the processor.
      QName getName()
      Returns a QName for the current START_ELEMENT or END_ELEMENT event
      NamespaceContext getNamespaceContext()
      Returns a read only namespace context for the current position.
      int getNamespaceCount()
      Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
      String getNamespacePrefix(int index)
      Returns the prefix for the namespace declared at the index.
      String getNamespaceURI()
      If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
      String getNamespaceURI(int index)
      Returns the uri for the namespace declared at the index.
      String getNamespaceURI(String prefix)
      Return the uri for the given prefix.
      String getPIData()
      Get the data section of a processing instruction
      String getPITarget()
      Get the target of a processing instruction
      String getPrefix()
      Returns the prefix of the current event or null if the event does not have a prefix
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      String getText()
      Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
      char[] getTextCharacters()
      Returns an array which contains the characters from this event.
      int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
      int getTextLength()
      Returns the length of the sequence of characters for this Text event within the text character array.
      int getTextStart()
      Returns the offset into the text character array where the first character (of this text event) is stored.
      String getVersion()
      Get the xml version declared on the xml declaration Returns null if none was declared
      boolean hasName()
      returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
      boolean hasNext()
      Returns true if there are more parsing events and false if there are no more events.
      boolean hasText()
      Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
      boolean isAttributeSpecified(int index)
      Returns a boolean which indicates if this attribute was created by default
      boolean isCharacters()
      Returns true if the cursor points to a character data event
      boolean isEndElement()
      Returns true if the cursor points to an end tag (otherwise false)
      boolean isStandalone()
      Get the standalone declaration from the xml declaration
      boolean isStartElement()
      Returns true if the cursor points to a start tag (otherwise false)
      boolean isWhiteSpace()
      Returns true if the cursor points to a character data event that consists of all whitespace
      int next()
      Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
      int nextTag()
      Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
      void require(int type, String namespaceURI, String localName)
      Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
      boolean standaloneSet()
      Checks if standalone was set in the document

    • Method Detail

      • getProperty

        Object getProperty(String name)
            throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        Parameters:
        name - The name of the property, may not be null
        Returns:
        The value of the property
        Throws:
        IllegalArgumentException - if name is null

      • next

        int next()
  throws XMLStreamException
        Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks. If the property javax.xml.stream.isCoalescing is set to true element content must be coalesced and only one CHARACTERS event must be returned for contiguous element content or CDATA Sections. By default entity references must be expanded and reported transparently to the application. An exception will be thrown if an entity reference cannot be expanded. If element content is empty (i.e. content is "") then no CHARACTERS event will be reported.

        Given the following XML:
        <foo><!--description-->content text<![CDATA[<greeting>Hello</greeting>]]>other content</foo>
        The behavior of calling next() when being on foo will be:
        1- the comment (COMMENT)
        2- then the characters section (CHARACTERS)
        3- then the CDATA section (another CHARACTERS)
        4- then the next characters section (another CHARACTERS)
        5- then the END_ELEMENT

        NOTE: empty element (such as <tag/>) will be reported with two separate events: START_ELEMENT, END_ELEMENT - This preserves parsing equivalency of empty element to <tag></tag>. This method will throw an IllegalStateException if it is called after hasNext() returns false.

        Returns:
        the integer code corresponding to the current parse event
        Throws:
        NoSuchElementException - if this is called when hasNext() returns false
        XMLStreamException - if there is an error processing the underlying XML source
        See Also:
        XMLEvent

      • require

        void require(int type,
             String namespaceURI,
             String localName)
      throws XMLStreamException
        Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event. If the namespaceURI is null it is not checked for equality, if the localName is null it is not checked for equality.
        Parameters:
        type - the event type
        namespaceURI - the uri of the event, may be null
        localName - the localName of the event, may be null
        Throws:
        XMLStreamException - if the required values are not matched.

      • getElementText

        String getElementText()
               throws XMLStreamException
        Reads the content of a text-only element, an exception is thrown if this is not a text-only element. Regardless of value of javax.xml.stream.isCoalescing this method always returns coalesced content.
        Precondition: the current event is START_ELEMENT.
        Postcondition: the current event is the corresponding END_ELEMENT.
        The method does the following (implementations are free to optimized but must do equivalent processing):
         if(getEventType() != XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "parser must be on START_ELEMENT to read next text", getLocation());
 }
 int eventType = next();
 StringBuffer content = new StringBuffer();
 while(eventType != XMLStreamConstants.END_ELEMENT ) {
 if(eventType == XMLStreamConstants.CHARACTERS
 || eventType == XMLStreamConstants.CDATA
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.ENTITY_REFERENCE) {
 buf.append(getText());
 } else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT) {
 // skipping
 } else if(eventType == XMLStreamConstants.END_DOCUMENT) {
 throw new XMLStreamException(
 "unexpected end of document when reading element text content", this);
 } else if(eventType == XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "element text content may not contain START_ELEMENT", getLocation());
 } else {
 throw new XMLStreamException(
 "Unexpected event type "+eventType, getLocation());
 }
 eventType = next();
 }
 return buf.toString();
        Throws:
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • nextTag

        int nextTag()
     throws XMLStreamException
        Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached. If other than white space characters, COMMENT, PROCESSING_INSTRUCTION, START_ELEMENT, END_ELEMENT are encountered, an exception is thrown. This method should be used when processing element-only content seperated by white space.
        Precondition: none
        Postcondition: the current event is START_ELEMENT or END_ELEMENT and cursor may have moved over any whitespace event.
        Essentially it does the following (implementations are free to optimized but must do equivalent processing):
         int eventType = next();
 while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
 || (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
 // skip whitespace
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT
 ) {
 eventType = next();
 }
 if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
 throw new String XMLStreamException("expected start or end tag", getLocation());
 }
 return eventType;
        Returns:
        the event type of the element read (START_ELEMENT or END_ELEMENT)
        Throws:
        XMLStreamException - if the current event is not white space, PROCESSING_INSTRUCTION, START_ELEMENT or END_ELEMENT
        NoSuchElementException - if this is called when hasNext() returns false

      • hasNext

        boolean hasNext()
         throws XMLStreamException
        Returns true if there are more parsing events and false if there are no more events. This method will return false if the current state of the XMLStreamReader is END_DOCUMENT
        Returns:
        true if there are more events, false otherwise
        Throws:
        XMLStreamException - if there is a fatal error detecting the next state

      • close

        void close()
    throws XMLStreamException
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        Throws:
        XMLStreamException - if there are errors freeing associated resources

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Return the uri for the given prefix. The uri returned depends on the current state of the processor.

        NOTE:The 'xml' prefix is bound as defined in Namespaces in XML specification to "http://www.w3.org/XML/1998/namespace".

        NOTE: The 'xmlns' prefix must be resolved to following namespace http://www.w3.org/2000/xmlns/

        Parameters:
        prefix - The prefix to lookup, may not be null
        Returns:
        the uri bound to the given prefix or null if it is not bound
        Throws:
        IllegalArgumentException - if the prefix is null

      • isStartElement

        boolean isStartElement()
        Returns true if the cursor points to a start tag (otherwise false)
        Returns:
        true if the cursor points to a start tag, false otherwise

      • isEndElement

        boolean isEndElement()
        Returns true if the cursor points to an end tag (otherwise false)
        Returns:
        true if the cursor points to an end tag, false otherwise

      • isCharacters

        boolean isCharacters()
        Returns true if the cursor points to a character data event
        Returns:
        true if the cursor points to character data, false otherwise

      • isWhiteSpace

        boolean isWhiteSpace()
        Returns true if the cursor points to a character data event that consists of all whitespace
        Returns:
        true if the cursor points to all whitespace, false otherwise

      • getAttributeValue

        String getAttributeValue(String namespaceURI,
                         String localName)
        Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
        Parameters:
        namespaceURI - the namespace of the attribute
        localName - the local name of the attribute, cannot be null
        Returns:
        returns the value of the attribute , returns null if not found
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeCount

        int getAttributeCount()
        Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE. This count excludes namespace definitions. Attribute indices are zero-based.
        Returns:
        returns the number of attributes
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeName

        QName getAttributeName(int index)
        Returns the qname of the attribute at the provided index
        Parameters:
        index - the position of the attribute
        Returns:
        the QName of the attribute
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeNamespace

        String getAttributeNamespace(int index)
        Returns the namespace of the attribute at the provided index
        Parameters:
        index - the position of the attribute
        Returns:
        the namespace URI (can be null)
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeLocalName

        String getAttributeLocalName(int index)
        Returns the localName of the attribute at the provided index
        Parameters:
        index - the position of the attribute
        Returns:
        the localName of the attribute
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributePrefix

        String getAttributePrefix(int index)
        Returns the prefix of this attribute at the provided index
        Parameters:
        index - the position of the attribute
        Returns:
        the prefix of the attribute
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeType

        String getAttributeType(int index)
        Returns the XML type of the attribute at the provided index
        Parameters:
        index - the position of the attribute
        Returns:
        the XML type of the attribute
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeValue

        String getAttributeValue(int index)
        Returns the value of the attribute at the index
        Parameters:
        index - the position of the attribute
        Returns:
        the attribute value
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • isAttributeSpecified

        boolean isAttributeSpecified(int index)
        Returns a boolean which indicates if this attribute was created by default
        Parameters:
        index - the position of the attribute
        Returns:
        true if this is a default attribute
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getNamespaceCount

        int getNamespaceCount()
        Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE. On an END_ELEMENT the count is of the namespaces that are about to go out of scope. This is the equivalent of the information reported by SAX callback for an end element event.
        Returns:
        returns the number of namespace declarations on this specific element
        Throws:
        IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

      • getNamespacePrefix

        String getNamespacePrefix(int index)
        Returns the prefix for the namespace declared at the index. Returns null if this is the default namespace declaration
        Parameters:
        index - the position of the namespace declaration
        Returns:
        returns the namespace prefix
        Throws:
        IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

      • getNamespaceURI

        String getNamespaceURI(int index)
        Returns the uri for the namespace declared at the index.
        Parameters:
        index - the position of the namespace declaration
        Returns:
        returns the namespace uri
        Throws:
        IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Returns a read only namespace context for the current position. The context is transient and only valid until a call to next() changes the state of the reader.
        Returns:
        return a namespace context

      • getEventType

        int getEventType()
        Returns an integer code that indicates the type of the event the cursor is pointing to.

      • getText

        String getText()
        Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD. If an ENTITY_REFERENCE has been resolved, any character data will be reported as CHARACTERS events.
        Returns:
        the current text or null
        Throws:
        IllegalStateException - if this state is not a valid text state.

      • getTextCharacters

        char[] getTextCharacters()
        Returns an array which contains the characters from this event. This array should be treated as read-only and transient. I.e. the array will contain the text characters until the XMLStreamReader moves on to the next event. Attempts to hold onto the character array beyond that time or modify the contents of the array are breaches of the contract for this interface.
        Returns:
        the current text or an empty array
        Throws:
        IllegalStateException - if this state is not a valid text state.

      • getTextCharacters

        int getTextCharacters(int sourceStart,
                      char[] target,
                      int targetStart,
                      int length)
               throws XMLStreamException
        Gets the the text associated with a CHARACTERS, SPACE or CDATA event. Text starting a "sourceStart" is copied into "target" starting at "targetStart". Up to "length" characters are copied. The number of characters actually copied is returned. The "sourceStart" argument must be greater or equal to 0 and less than or equal to the number of characters associated with the event. Usually, one requests text starting at a "sourceStart" of 0. If the number of characters actually copied is less than the "length", then there is no more text. Otherwise, subsequent calls need to be made until all text has been retrieved. For example: int length = 1024; char[] myBuffer = new char[ length ]; for ( int sourceStart = 0 ; ; sourceStart += length ) { int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length ); if (nCopied < length) break; } XMLStreamException may be thrown if there are any XML errors in the underlying source. The "targetStart" argument must be greater than or equal to 0 and less than the length of "target", Length must be greater than 0 and "targetStart + length" must be less than or equal to length of "target".
        Parameters:
        sourceStart - the index of the first character in the source array to copy
        target - the destination array
        targetStart - the start offset in the target array
        length - the number of characters to copy
        Returns:
        the number of characters actually copied
        Throws:
        XMLStreamException - if the underlying XML source is not well-formed
        IndexOutOfBoundsException - if targetStart < 0 or > than the length of target
        IndexOutOfBoundsException - if length < 0 or targetStart + length > length of target
        UnsupportedOperationException - if this method is not supported
        NullPointerException - is if target is null

      • getTextStart

        int getTextStart()
        Returns the offset into the text character array where the first character (of this text event) is stored.
        Throws:
        IllegalStateException - if this state is not a valid text state.

      • getTextLength

        int getTextLength()
        Returns the length of the sequence of characters for this Text event within the text character array.
        Throws:
        IllegalStateException - if this state is not a valid text state.

      • getEncoding

        String getEncoding()
        Return input encoding if known or null if unknown.
        Returns:
        the encoding of this instance or null

      • hasText

        boolean hasText()
        Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE

      • getLocation

        Location getLocation()
        Return the current location of the processor. If the Location is unknown the processor should return an implementation of Location that returns -1 for the location and null for the publicId and systemId. The location information is only valid until next() is called.

      • getName

        QName getName()
        Returns a QName for the current START_ELEMENT or END_ELEMENT event
        Returns:
        the QName for the current START_ELEMENT or END_ELEMENT event
        Throws:
        IllegalStateException - if this is not a START_ELEMENT or END_ELEMENT

      • getLocalName

        String getLocalName()
        Returns the (local) name of the current event. For START_ELEMENT or END_ELEMENT returns the (local) name of the current element. For ENTITY_REFERENCE it returns entity name. The current event must be START_ELEMENT or END_ELEMENT, or ENTITY_REFERENCE
        Returns:
        the localName
        Throws:
        IllegalStateException - if this not a START_ELEMENT, END_ELEMENT or ENTITY_REFERENCE

      • hasName

        boolean hasName()
        returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise

      • getNamespaceURI

        String getNamespaceURI()
        If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace. Returns null if the event does not have a prefix.
        Returns:
        the URI bound to this elements prefix, the default namespace, or null

      • getPrefix

        String getPrefix()
        Returns the prefix of the current event or null if the event does not have a prefix
        Returns:
        the prefix or null

      • getVersion

        String getVersion()
        Get the xml version declared on the xml declaration Returns null if none was declared
        Returns:
        the XML version or null

      • isStandalone

        boolean isStandalone()
        Get the standalone declaration from the xml declaration
        Returns:
        true if this is standalone, or false otherwise

      • standaloneSet

        boolean standaloneSet()
        Checks if standalone was set in the document
        Returns:
        true if standalone was set in the document, or false otherwise

      • getCharacterEncodingScheme

        String getCharacterEncodingScheme()
        Returns the character encoding declared on the xml declaration Returns null if none was declared
        Returns:
        the encoding declared in the document or null

      • getPITarget

        String getPITarget()
        Get the target of a processing instruction
        Returns:
        the target or null

      • getPIData

        String getPIData()
        Get the data section of a processing instruction
        Returns:
        the data or null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLStreamWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream

Interface XMLStreamWriter

  • public interface XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML. The XMLStreamWriter does not perform well formedness checking on its input. However the writeCharacters method is required to escape & , < and > For attribute values the writeAttribute method will escape the above characters plus " to ensure that all character content and attribute values are well formed. Each NAMESPACE and ATTRIBUTE must be individually written.
    XML Namespaces, javax.xml.stream.isRepairingNamespaces and write method behaviour
    Method | isRepairingNamespaces == true | isRepairingNamespaces == false
    namespaceURI bound | namespaceURI unbound | namespaceURI bound | namespaceURI unbound
    writeAttribute(namespaceURI, localName, value) | prefix:localName="value" [1] | xmlns:{generated}="namespaceURI" {generated}:localName="value" | prefix:localName="value" [1] | XMLStreamException
    writeAttribute(prefix, namespaceURI, localName, value) bound to same prefix:
    prefix:localName="value" [1]

    bound to different prefix:
    xmlns:{generated}="namespaceURI" {generated}:localName="value"     		xmlns:prefix="namespaceURI" prefix:localName="value" [3] bound to same prefix:
    prefix:localName="value" [1][2]

    bound to different prefix:
    XMLStreamException[2]     		xmlns:prefix="namespaceURI" prefix:localName="value" [2][5]
    writeStartElement(namespaceURI, localName)

    writeEmptyElement(namespaceURI, localName)     		<prefix:localName> [1] <{generated}:localName xmlns:{generated}="namespaceURI"> <prefix:localName> [1] XMLStreamException
    writeStartElement(prefix, localName, namespaceURI)

    writeEmptyElement(prefix, localName, namespaceURI)     		bound to same prefix:
    <prefix:localName> [1]

    bound to different prefix:
    <{generated}:localName xmlns:{generated}="namespaceURI">     		<prefix:localName xmlns:prefix="namespaceURI"> [4] bound to same prefix:
    <prefix:localName> [1]

    bound to different prefix:
    XMLStreamException     		<prefix:localName>
    Notes:
    • [1] if namespaceURI == default Namespace URI, then no prefix is written
    • [2] if prefix == "" || null && namespaceURI == "", then no prefix or Namespace declaration is generated or written
    • [3] if prefix == "" || null, then a prefix is randomly generated
    • [4] if prefix == "" || null, then it is treated as the default Namespace and no prefix is generated or written, an xmlns declaration is generated and written if the namespaceURI is unbound
    • [5] if prefix == "" || null, then it is treated as an invalid attempt to define the default Namespace and an XMLStreamException is thrown
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLOutputFactory, XMLStreamReader

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void close()
      Close this writer and free any resources associated with the writer.
      void flush()
      Write any cached data to the underlying output mechanism.
      NamespaceContext getNamespaceContext()
      Returns the current namespace context.
      String getPrefix(String uri)
      Gets the prefix the uri is bound to
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      void setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.
      void writeAttribute(String localName, String value)
      Writes an attribute to the output stream without a prefix.
      void writeAttribute(String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void writeAttribute(String prefix, String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void writeCData(String data)
      Writes a CData section
      void writeCharacters(char[] text, int start, int len)
      Write text to the output
      void writeCharacters(String text)
      Write text to the output
      void writeComment(String data)
      Writes an xml comment with the data enclosed
      void writeDefaultNamespace(String namespaceURI)
      Writes the default namespace to the stream
      void writeDTD(String dtd)
      Write a DTD section.
      void writeEmptyElement(String localName)
      Writes an empty element tag to the output
      void writeEmptyElement(String namespaceURI, String localName)
      Writes an empty element tag to the output
      void writeEmptyElement(String prefix, String localName, String namespaceURI)
      Writes an empty element tag to the output
      void writeEndDocument()
      Closes any start tags and writes corresponding end tags.
      void writeEndElement()
      Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
      void writeEntityRef(String name)
      Writes an entity reference
      void writeNamespace(String prefix, String namespaceURI)
      Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
      void writeProcessingInstruction(String target)
      Writes a processing instruction
      void writeProcessingInstruction(String target, String data)
      Writes a processing instruction
      void writeStartDocument()
      Write the XML Declaration.
      void writeStartDocument(String version)
      Write the XML Declaration.
      void writeStartDocument(String encoding, String version)
      Write the XML Declaration.
      void writeStartElement(String localName)
      Writes a start tag to the output.
      void writeStartElement(String namespaceURI, String localName)
      Writes a start tag to the output
      void writeStartElement(String prefix, String localName, String namespaceURI)
      Writes a start tag to the output

    • Method Detail

      • writeStartElement

        void writeStartElement(String localName)
                throws XMLStreamException
        Writes a start tag to the output. All writeStartElement methods open a new scope in the internal namespace context. Writing the corresponding EndElement causes the scope to be closed.
        Parameters:
        localName - local name of the tag, may not be null
        Throws:
        XMLStreamException

      • writeStartElement

        void writeStartElement(String namespaceURI,
                       String localName)
                throws XMLStreamException
        Writes a start tag to the output
        Parameters:
        namespaceURI - the namespaceURI of the prefix to use, may not be null
        localName - local name of the tag, may not be null
        Throws:
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeStartElement

        void writeStartElement(String prefix,
                       String localName,
                       String namespaceURI)
                throws XMLStreamException
        Writes a start tag to the output
        Parameters:
        localName - local name of the tag, may not be null
        prefix - the prefix of the tag, may not be null
        namespaceURI - the uri to bind the prefix to, may not be null
        Throws:
        XMLStreamException

      • writeEmptyElement

        void writeEmptyElement(String namespaceURI,
                       String localName)
                throws XMLStreamException
        Writes an empty element tag to the output
        Parameters:
        namespaceURI - the uri to bind the tag to, may not be null
        localName - local name of the tag, may not be null
        Throws:
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeEmptyElement

        void writeEmptyElement(String prefix,
                       String localName,
                       String namespaceURI)
                throws XMLStreamException
        Writes an empty element tag to the output
        Parameters:
        prefix - the prefix of the tag, may not be null
        localName - local name of the tag, may not be null
        namespaceURI - the uri to bind the tag to, may not be null
        Throws:
        XMLStreamException

      • writeEmptyElement

        void writeEmptyElement(String localName)
                throws XMLStreamException
        Writes an empty element tag to the output
        Parameters:
        localName - local name of the tag, may not be null
        Throws:
        XMLStreamException

      • writeEndElement

        void writeEndElement()
              throws XMLStreamException
        Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
        Throws:
        XMLStreamException

      • writeEndDocument

        void writeEndDocument()
               throws XMLStreamException
        Closes any start tags and writes corresponding end tags.
        Throws:
        XMLStreamException

      • close

        void close()
    throws XMLStreamException
        Close this writer and free any resources associated with the writer. This must not close the underlying output stream.
        Throws:
        XMLStreamException

      • flush

        void flush()
    throws XMLStreamException
        Write any cached data to the underlying output mechanism.
        Throws:
        XMLStreamException

      • writeAttribute

        void writeAttribute(String localName,
                    String value)
             throws XMLStreamException
        Writes an attribute to the output stream without a prefix.
        Parameters:
        localName - the local name of the attribute
        value - the value of the attribute
        Throws:
        IllegalStateException - if the current state does not allow Attribute writing
        XMLStreamException

      • writeAttribute

        void writeAttribute(String prefix,
                    String namespaceURI,
                    String localName,
                    String value)
             throws XMLStreamException
        Writes an attribute to the output stream
        Parameters:
        prefix - the prefix for this attribute
        namespaceURI - the uri of the prefix for this attribute
        localName - the local name of the attribute
        value - the value of the attribute
        Throws:
        IllegalStateException - if the current state does not allow Attribute writing
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeAttribute

        void writeAttribute(String namespaceURI,
                    String localName,
                    String value)
             throws XMLStreamException
        Writes an attribute to the output stream
        Parameters:
        namespaceURI - the uri of the prefix for this attribute
        localName - the local name of the attribute
        value - the value of the attribute
        Throws:
        IllegalStateException - if the current state does not allow Attribute writing
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeNamespace

        void writeNamespace(String prefix,
                    String namespaceURI)
             throws XMLStreamException
        Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
        Parameters:
        prefix - the prefix to bind this namespace to
        namespaceURI - the uri to bind the prefix to
        Throws:
        IllegalStateException - if the current state does not allow Namespace writing
        XMLStreamException

      • writeDefaultNamespace

        void writeDefaultNamespace(String namespaceURI)
                    throws XMLStreamException
        Writes the default namespace to the stream
        Parameters:
        namespaceURI - the uri to bind the default namespace to
        Throws:
        IllegalStateException - if the current state does not allow Namespace writing
        XMLStreamException

      • writeComment

        void writeComment(String data)
           throws XMLStreamException
        Writes an xml comment with the data enclosed
        Parameters:
        data - the data contained in the comment, may be null
        Throws:
        XMLStreamException

      • writeProcessingInstruction

        void writeProcessingInstruction(String target)
                         throws XMLStreamException
        Writes a processing instruction
        Parameters:
        target - the target of the processing instruction, may not be null
        Throws:
        XMLStreamException

      • writeProcessingInstruction

        void writeProcessingInstruction(String target,
                                String data)
                         throws XMLStreamException
        Writes a processing instruction
        Parameters:
        target - the target of the processing instruction, may not be null
        data - the data contained in the processing instruction, may not be null
        Throws:
        XMLStreamException

      • writeCData

        void writeCData(String data)
         throws XMLStreamException
        Writes a CData section
        Parameters:
        data - the data contained in the CData Section, may not be null
        Throws:
        XMLStreamException

      • writeDTD

        void writeDTD(String dtd)
       throws XMLStreamException
        Write a DTD section. This string represents the entire doctypedecl production from the XML 1.0 specification.
        Parameters:
        dtd - the DTD to be written
        Throws:
        XMLStreamException

      • writeEntityRef

        void writeEntityRef(String name)
             throws XMLStreamException
        Writes an entity reference
        Parameters:
        name - the name of the entity
        Throws:
        XMLStreamException

      • writeStartDocument

        void writeStartDocument()
                 throws XMLStreamException
        Write the XML Declaration. Defaults the XML version to 1.0, and the encoding to utf-8
        Throws:
        XMLStreamException

      • writeStartDocument

        void writeStartDocument(String version)
                 throws XMLStreamException
        Write the XML Declaration. Defaults the XML version to 1.0
        Parameters:
        version - version of the xml document
        Throws:
        XMLStreamException

      • writeStartDocument

        void writeStartDocument(String encoding,
                        String version)
                 throws XMLStreamException
        Write the XML Declaration. Note that the encoding parameter does not set the actual encoding of the underlying output. That must be set when the instance of the XMLStreamWriter is created using the XMLOutputFactory
        Parameters:
        encoding - encoding of the xml declaration
        version - version of the xml document
        Throws:
        XMLStreamException - If given encoding does not match encoding of the underlying stream

      • writeCharacters

        void writeCharacters(String text)
              throws XMLStreamException
        Write text to the output
        Parameters:
        text - the value to write
        Throws:
        XMLStreamException

      • writeCharacters

        void writeCharacters(char[] text,
                     int start,
                     int len)
              throws XMLStreamException
        Write text to the output
        Parameters:
        text - the value to write
        start - the starting position in the array
        len - the number of characters to write
        Throws:
        XMLStreamException

      • getPrefix

        String getPrefix(String uri)
          throws XMLStreamException
        Gets the prefix the uri is bound to
        Returns:
        the prefix or null
        Throws:
        XMLStreamException

      • setPrefix

        void setPrefix(String prefix,
               String uri)
        throws XMLStreamException
        Sets the prefix the uri is bound to. This prefix is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the prefix is bound in the root scope.
        Parameters:
        prefix - the prefix to bind to the uri, may not be null
        uri - the uri to bind to the prefix, may be null
        Throws:
        XMLStreamException

      • setDefaultNamespace

        void setDefaultNamespace(String uri)
                  throws XMLStreamException
        Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the uri is bound in the root scope.
        Parameters:
        uri - the uri to bind to the default namespace, may be null
        Throws:
        XMLStreamException

      • setNamespaceContext

        void setNamespaceContext(NamespaceContext context)
                  throws XMLStreamException
        Sets the current namespace context for prefix and uri bindings. This context becomes the root namespace context for writing and will replace the current root namespace context. Subsequent calls to setPrefix and setDefaultNamespace will bind namespaces using the context passed to the method as the root context for resolving namespaces. This method may only be called once at the start of the document. It does not cause the namespaces to be declared. If a namespace URI to prefix mapping is found in the namespace context it is treated as declared and the prefix may be used by the StreamWriter.
        Parameters:
        context - the namespace context to use for this writer, may not be null
        Throws:
        XMLStreamException

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Returns the current namespace context.
        Returns:
        the current NamespaceContext

      • getProperty

        Object getProperty(String name)
            throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        Parameters:
        name - The name of the property, may not be null
        Returns:
        The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported
        NullPointerException - if the name is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.EventFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.EventFilter

  • Packages that use EventFilter
    Package Description
    javax.xml.stream

    • Uses of EventFilter in javax.xml.stream

      Methods in javax.xml.stream with parameters of type EventFilter
      Modifier and Type Method and Description
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.FactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.FactoryConfigurationError

  • Packages that use FactoryConfigurationError
    Package Description
    javax.xml.stream

    • Uses of FactoryConfigurationError in javax.xml.stream

      Methods in javax.xml.stream that throw FactoryConfigurationError
      Modifier and Type Method and Description
      static XMLInputFactory XMLInputFactory.newFactory()
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newFactory()
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newFactory()
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newInstance()
      Creates a new instance of the factory in exactly the same manner as the XMLInputFactory.newFactory() method.
      static XMLEventFactory XMLEventFactory.newInstance()
      Creates a new instance of the factory in exactly the same manner as the XMLEventFactory.newFactory() method.
      static XMLOutputFactory XMLOutputFactory.newInstance()
      Creates a new instance of the factory in exactly the same manner as the XMLOutputFactory.newFactory() method.
      static XMLInputFactory XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      static XMLEventFactory XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      static XMLInputFactory XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) instead.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.Location (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.Location

  • Packages that use Location
    Package Description
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util

    • Uses of Location in javax.xml.stream

      Fields in javax.xml.stream declared as Location
      Modifier and Type | Field and Description
      protected Location | XMLStreamException.location
      Methods in javax.xml.stream that return Location
      Modifier and Type Method and Description
      Location XMLStreamReader.getLocation()
      Return the current location of the processor.
      Location XMLStreamException.getLocation()
      Gets the location of the exception
      Methods in javax.xml.stream with parameters of type Location
      Modifier and Type Method and Description
      void XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
      Report the desired message in an application specific format.
      abstract void XMLEventFactory.setLocation(Location location)
      This method allows setting of the Location on each event that is created by this factory.
      Constructors in javax.xml.stream with parameters of type Location
      Constructor and Description
      XMLStreamException(String msg, Location location)
      Construct an exception with the assocated message, exception and location.
      XMLStreamException(String msg, Location location, Throwable th)
      Construct an exception with the assocated message, exception and location.

    • Uses of Location in javax.xml.stream.events

      Methods in javax.xml.stream.events that return Location
      Modifier and Type Method and Description
      Location XMLEvent.getLocation()
      Return the location of this event.

    • Uses of Location in javax.xml.stream.util

      Methods in javax.xml.stream.util that return Location
      Modifier and Type | Method and Description
      Location | StreamReaderDelegate.getLocation()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.StreamFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.StreamFilter

  • Packages that use StreamFilter
    Package Description
    javax.xml.stream

    • Uses of StreamFilter in javax.xml.stream

      Methods in javax.xml.stream with parameters of type StreamFilter
      Modifier and Type Method and Description
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.XMLEventFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.XMLEventFactory

  • Packages that use XMLEventFactory
    Package Description
    javax.xml.stream

    • Uses of XMLEventFactory in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventFactory
      Modifier and Type Method and Description
      static XMLEventFactory XMLEventFactory.newFactory()
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newInstance()
      Creates a new instance of the factory in exactly the same manner as the newFactory() method.
      static XMLEventFactory XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLEventReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLEventReader

  • Packages that use XMLEventReader
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLEventReader in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLEventReader
      Modifier and Type Method and Description
      Object Unmarshaller.unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of XMLEventReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLEventReader
      Modifier and Type | Method and Description
      Object | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)

    • Uses of XMLEventReader in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventReader
      Modifier and Type Method and Description
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.
      Methods in javax.xml.stream with parameters of type XMLEventReader
      Modifier and Type Method and Description
      void XMLEventWriter.add(XMLEventReader reader)
      Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader

    • Uses of XMLEventReader in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement XMLEventReader
      Modifier and Type Class and Description
      class  EventReaderDelegate
      This is the base class for deriving an XMLEventReader filter.
      Methods in javax.xml.stream.util that return XMLEventReader
      Modifier and Type Method and Description
      XMLEventReader EventReaderDelegate.getParent()
      Get the parent of this instance.
      Methods in javax.xml.stream.util with parameters of type XMLEventReader
      Modifier and Type Method and Description
      void EventReaderDelegate.setParent(XMLEventReader reader)
      Set the parent of this instance.
      Constructors in javax.xml.stream.util with parameters of type XMLEventReader
      Constructor and Description
      EventReaderDelegate(XMLEventReader reader)
      Construct an filter with the specified parent.

    • Uses of XMLEventReader in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLEventReader
      Modifier and Type Method and Description
      XMLEventReader StAXSource.getXMLEventReader()
      Get the XMLEventReader used by this StAXSource.
      Constructors in javax.xml.transform.stax with parameters of type XMLEventReader
      Constructor and Description
      StAXSource(XMLEventReader xmlEventReader)
      Creates a new instance of a StAXSource by supplying an XMLEventReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLEventWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLEventWriter

  • Packages that use XMLEventWriter
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLEventWriter in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLEventWriter
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.

    • Uses of XMLEventWriter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLEventWriter
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)

    • Uses of XMLEventWriter in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventWriter
      Modifier and Type Method and Description
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Writer stream)
      Create a new XMLEventWriter that writes to a writer

    • Uses of XMLEventWriter in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLEventWriter
      Modifier and Type Method and Description
      XMLEventWriter StAXResult.getXMLEventWriter()
      Get the XMLEventWriter used by this StAXResult.
      Constructors in javax.xml.transform.stax with parameters of type XMLEventWriter
      Constructor and Description
      StAXResult(XMLEventWriter xmlEventWriter)
      Creates a new instance of a StAXResult by supplying an XMLEventWriter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.XMLInputFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.XMLInputFactory

  • Packages that use XMLInputFactory
    Package Description
    javax.xml.stream

    • Uses of XMLInputFactory in javax.xml.stream

      Methods in javax.xml.stream that return XMLInputFactory
      Modifier and Type Method and Description
      static XMLInputFactory XMLInputFactory.newFactory()
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newInstance()
      Creates a new instance of the factory in exactly the same manner as the newFactory() method.
      static XMLInputFactory XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      static XMLInputFactory XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) instead.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.XMLOutputFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.XMLOutputFactory

  • Packages that use XMLOutputFactory
    Package Description
    javax.xml.stream

    • Uses of XMLOutputFactory in javax.xml.stream

      Methods in javax.xml.stream that return XMLOutputFactory
      Modifier and Type Method and Description
      static XMLOutputFactory XMLOutputFactory.newFactory()
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newInstance()
      Creates a new instance of the factory in exactly the same manner as the newFactory() method.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLReporter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLReporter

  • Packages that use XMLReporter
    Package Description
    javax.xml.stream

    • Uses of XMLReporter in javax.xml.stream

      Methods in javax.xml.stream that return XMLReporter
      Modifier and Type Method and Description
      abstract XMLReporter XMLInputFactory.getXMLReporter()
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      Methods in javax.xml.stream with parameters of type XMLReporter
      Modifier and Type Method and Description
      abstract void XMLInputFactory.setXMLReporter(XMLReporter reporter)
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLResolver

  • Packages that use XMLResolver
    Package Description
    javax.xml.stream

    • Uses of XMLResolver in javax.xml.stream

      Methods in javax.xml.stream that return XMLResolver
      Modifier and Type Method and Description
      abstract XMLResolver XMLInputFactory.getXMLResolver()
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      Methods in javax.xml.stream with parameters of type XMLResolver
      Modifier and Type Method and Description
      abstract void XMLInputFactory.setXMLResolver(XMLResolver resolver)
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLStreamConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLStreamConstants

  • Packages that use XMLStreamConstants
    Package Description
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util

    • Uses of XMLStreamConstants in javax.xml.stream

      Subinterfaces of XMLStreamConstants in javax.xml.stream
      Modifier and Type Interface and Description
      interface  XMLStreamReader
      The XMLStreamReader interface allows forward, read-only access to XML.

    • Uses of XMLStreamConstants in javax.xml.stream.events

      Subinterfaces of XMLStreamConstants in javax.xml.stream.events
      Modifier and Type Interface and Description
      interface  Attribute
      An interface that contains information about an attribute.
      interface  Characters
      This describes the interface to Characters events.
      interface  Comment
      An interface for comment events
      interface  DTD
      This is the top level interface for events dealing with DTDs
      interface  EndDocument
      A marker interface for the end of the document
      interface  EndElement
      An interface for the end element event.
      interface  EntityDeclaration
      An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
      interface  EntityReference
      An interface for handling Entity events.
      interface  Namespace
      An interface that contains information about a namespace.
      interface  NotationDeclaration
      An interface for handling Notation Declarations Receive notification of a notation declaration event.
      interface  ProcessingInstruction
      An interface that describes the data found in processing instructions
      interface  StartDocument
      An interface for the start document event
      interface  StartElement
      The StartElement interface provides access to information about start elements.
      interface  XMLEvent
      This is the base event interface for handling markup events.

    • Uses of XMLStreamConstants in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement XMLStreamConstants
      Modifier and Type Class and Description
      class  StreamReaderDelegate
      This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.XMLStreamException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.XMLStreamException

  • Packages that use XMLStreamException
    Package Description
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLStreamException in javax.xml.stream

      Methods in javax.xml.stream that throw XMLStreamException
      Modifier and Type Method and Description
      void XMLEventWriter.add(XMLEvent event)
      Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
      void XMLEventWriter.add(XMLEventReader reader)
      Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
      void XMLEventReader.close()
      Frees any resources associated with this Reader.
      void XMLStreamReader.close()
      Frees any resources associated with this Reader.
      void XMLEventWriter.close()
      Frees any resources associated with this stream
      void XMLStreamWriter.close()
      Close this writer and free any resources associated with the writer.
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Writer stream)
      Create a new XMLEventWriter that writes to a writer
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Reader reader)
      Create a new XMLStreamReader from a reader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Writer stream)
      Create a new XMLStreamWriter that writes to a writer
      void XMLEventWriter.flush()
      Writes any cached events to the underlying output mechanism
      void XMLStreamWriter.flush()
      Write any cached data to the underlying output mechanism.
      String XMLEventReader.getElementText()
      Reads the content of a text-only element.
      String XMLStreamReader.getElementText()
      Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
      String XMLEventWriter.getPrefix(String uri)
      Gets the prefix the uri is bound to
      String XMLStreamWriter.getPrefix(String uri)
      Gets the prefix the uri is bound to
      int XMLStreamReader.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
      boolean XMLStreamReader.hasNext()
      Returns true if there are more parsing events and false if there are no more events.
      int XMLStreamReader.next()
      Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
      XMLEvent XMLEventReader.nextEvent()
      Get the next XMLEvent
      XMLEvent XMLEventReader.nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      int XMLStreamReader.nextTag()
      Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent XMLEventReader.peek()
      Check the next XMLEvent without reading it from the stream.
      void XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
      Report the desired message in an application specific format.
      void XMLStreamReader.require(int type, String namespaceURI, String localName)
      Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
      Object XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
      Retrieves a resource.
      void XMLEventWriter.setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void XMLStreamWriter.setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void XMLEventWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void XMLStreamWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void XMLEventWriter.setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.
      void XMLStreamWriter.setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.
      void XMLStreamWriter.writeAttribute(String localName, String value)
      Writes an attribute to the output stream without a prefix.
      void XMLStreamWriter.writeAttribute(String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void XMLStreamWriter.writeAttribute(String prefix, String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void XMLStreamWriter.writeCData(String data)
      Writes a CData section
      void XMLStreamWriter.writeCharacters(char[] text, int start, int len)
      Write text to the output
      void XMLStreamWriter.writeCharacters(String text)
      Write text to the output
      void XMLStreamWriter.writeComment(String data)
      Writes an xml comment with the data enclosed
      void XMLStreamWriter.writeDefaultNamespace(String namespaceURI)
      Writes the default namespace to the stream
      void XMLStreamWriter.writeDTD(String dtd)
      Write a DTD section.
      void XMLStreamWriter.writeEmptyElement(String localName)
      Writes an empty element tag to the output
      void XMLStreamWriter.writeEmptyElement(String namespaceURI, String localName)
      Writes an empty element tag to the output
      void XMLStreamWriter.writeEmptyElement(String prefix, String localName, String namespaceURI)
      Writes an empty element tag to the output
      void XMLStreamWriter.writeEndDocument()
      Closes any start tags and writes corresponding end tags.
      void XMLStreamWriter.writeEndElement()
      Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
      void XMLStreamWriter.writeEntityRef(String name)
      Writes an entity reference
      void XMLStreamWriter.writeNamespace(String prefix, String namespaceURI)
      Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
      void XMLStreamWriter.writeProcessingInstruction(String target)
      Writes a processing instruction
      void XMLStreamWriter.writeProcessingInstruction(String target, String data)
      Writes a processing instruction
      void XMLStreamWriter.writeStartDocument()
      Write the XML Declaration.
      void XMLStreamWriter.writeStartDocument(String version)
      Write the XML Declaration.
      void XMLStreamWriter.writeStartDocument(String encoding, String version)
      Write the XML Declaration.
      void XMLStreamWriter.writeStartElement(String localName)
      Writes a start tag to the output.
      void XMLStreamWriter.writeStartElement(String namespaceURI, String localName)
      Writes a start tag to the output
      void XMLStreamWriter.writeStartElement(String prefix, String localName, String namespaceURI)
      Writes a start tag to the output

    • Uses of XMLStreamException in javax.xml.stream.events

      Methods in javax.xml.stream.events that throw XMLStreamException
      Modifier and Type Method and Description
      void XMLEvent.writeAsEncodedUnicode(Writer writer)
      This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters.

    • Uses of XMLStreamException in javax.xml.stream.util

      Methods in javax.xml.stream.util that throw XMLStreamException
      Modifier and Type | Method and Description
      void XMLEventConsumer.add(XMLEvent event)
      This method adds an event to the consumer.
      XMLEvent XMLEventAllocator.allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
      void | StreamReaderDelegate.close()
      void | EventReaderDelegate.close()
      String | StreamReaderDelegate.getElementText()
      String | EventReaderDelegate.getElementText()
      int | StreamReaderDelegate.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      boolean | StreamReaderDelegate.hasNext()
      int | StreamReaderDelegate.next()
      XMLEvent | EventReaderDelegate.nextEvent()
      int | StreamReaderDelegate.nextTag()
      XMLEvent | EventReaderDelegate.nextTag()
      XMLEvent | EventReaderDelegate.peek()
      void | StreamReaderDelegate.require(int type, String namespaceURI, String localName)

    • Uses of XMLStreamException in javax.xml.transform.stax

      Constructors in javax.xml.transform.stax that throw XMLStreamException
      Constructor and Description
      StAXSource(XMLEventReader xmlEventReader)
      Creates a new instance of a StAXSource by supplying an XMLEventReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLStreamReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLStreamReader

  • Packages that use XMLStreamReader
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLStreamReader in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLStreamReader
      Modifier and Type Method and Description
      Object Unmarshaller.unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of XMLStreamReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLStreamReader
      Modifier and Type | Method and Description
      Object | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

    • Uses of XMLStreamReader in javax.xml.stream

      Methods in javax.xml.stream that return XMLStreamReader
      Modifier and Type Method and Description
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Reader reader)
      Create a new XMLStreamReader from a reader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
      Create a new XMLStreamReader from a java.io.InputStream
      Methods in javax.xml.stream with parameters of type XMLStreamReader
      Modifier and Type Method and Description
      boolean StreamFilter.accept(XMLStreamReader reader)
      Tests whether the current state is part of this stream.
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.

    • Uses of XMLStreamReader in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement XMLStreamReader
      Modifier and Type Class and Description
      class  StreamReaderDelegate
      This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
      Methods in javax.xml.stream.util that return XMLStreamReader
      Modifier and Type Method and Description
      XMLStreamReader StreamReaderDelegate.getParent()
      Get the parent of this instance.
      Methods in javax.xml.stream.util with parameters of type XMLStreamReader
      Modifier and Type Method and Description
      XMLEvent XMLEventAllocator.allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
      void StreamReaderDelegate.setParent(XMLStreamReader reader)
      Set the parent of this instance.
      Constructors in javax.xml.stream.util with parameters of type XMLStreamReader
      Constructor and Description
      StreamReaderDelegate(XMLStreamReader reader)
      Construct an filter with the specified parent.

    • Uses of XMLStreamReader in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLStreamReader
      Modifier and Type Method and Description
      XMLStreamReader StAXSource.getXMLStreamReader()
      Get the XMLStreamReader used by this StAXSource.
      Constructors in javax.xml.transform.stax with parameters of type XMLStreamReader
      Constructor and Description
      StAXSource(XMLStreamReader xmlStreamReader)
      Creates a new instance of a StAXSource by supplying an XMLStreamReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.XMLStreamWriter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.XMLStreamWriter

  • Packages that use XMLStreamWriter
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLStreamWriter in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLStreamWriter
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.

    • Uses of XMLStreamWriter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLStreamWriter
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)

    • Uses of XMLStreamWriter in javax.xml.stream

      Methods in javax.xml.stream that return XMLStreamWriter
      Modifier and Type Method and Description
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Writer stream)
      Create a new XMLStreamWriter that writes to a writer

    • Uses of XMLStreamWriter in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLStreamWriter
      Modifier and Type Method and Description
      XMLStreamWriter StAXResult.getXMLStreamWriter()
      Get the XMLStreamWriter used by this StAXResult.
      Constructors in javax.xml.transform.stax with parameters of type XMLStreamWriter
      Constructor and Description
      StAXResult(XMLStreamWriter xmlStreamWriter)
      Creates a new instance of a StAXResult by supplying an XMLStreamWriter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Attribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface Attribute

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants
    All Known Subinterfaces:
    Namespace

    public interface Attribute
extends XMLEvent
    An interface that contains information about an attribute. Attributes are reported as a set of events accessible from a StartElement. Other applications may report Attributes as first-order events, for example as the results of an XPath expression.
    Since:
    1.6
    Version:
    1.0
    See Also:
    StartElement

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getDTDType()
      Gets the type of this attribute, default is the String "CDATA"
      QName getName()
      Returns the QName for this attribute
      String getValue()
      Gets the normalized value of this attribute
      boolean isSpecified()
      A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getName

        QName getName()
        Returns the QName for this attribute

      • getValue

        String getValue()
        Gets the normalized value of this attribute

      • getDTDType

        String getDTDType()
        Gets the type of this attribute, default is the String "CDATA"
        Returns:
        the type as a String, default is "CDATA"

      • isSpecified

        boolean isSpecified()
        A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.
        Returns:
        returns true if this was specified in the start element
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Characters (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface Characters

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface Characters
extends XMLEvent
    This describes the interface to Characters events. All text events get reported as Characters events. Content, CData and whitespace are all reported as Characters events. IgnorableWhitespace, in most cases, will be set to false unless an element declaration of element content is present for the current element.
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getData()
      Get the character data of this event
      boolean isCData()
      Returns true if this is a CData section.
      boolean isIgnorableWhiteSpace()
      Return true if this is ignorableWhiteSpace.
      boolean isWhiteSpace()
      Returns true if this set of Characters is all whitespace.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getData

        String getData()
        Get the character data of this event

      • isWhiteSpace

        boolean isWhiteSpace()
        Returns true if this set of Characters is all whitespace. Whitespace inside a document is reported as CHARACTERS. This method allows checking of CHARACTERS events to see if they are composed of only whitespace characters

      • isCData

        boolean isCData()
        Returns true if this is a CData section. If this event is CData its event type will be CDATA If javax.xml.stream.isCoalescing is set to true CDATA Sections that are surrounded by non CDATA characters will be reported as a single Characters event. This method will return false in this case.

      • isIgnorableWhiteSpace

        boolean isIgnorableWhiteSpace()
        Return true if this is ignorableWhiteSpace. If this event is ignorableWhiteSpace its event type will be SPACE.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Comment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface Comment

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface Comment
extends XMLEvent
    An interface for comment events
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getText()
      Return the string data of the comment, returns empty string if it does not exist

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getText

        String getText()
        Return the string data of the comment, returns empty string if it does not exist
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.stream.events (Java Platform SE 8 )

compact2 - javax.xml.stream.events

Interfaces

  • Attribute
  • Characters
  • Comment
  • DTD
  • EndDocument
  • EndElement
  • EntityDeclaration
  • EntityReference
  • Namespace
  • NotationDeclaration
  • ProcessingInstruction
  • StartDocument
  • StartElement
  • XMLEvent


javax.xml.stream.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.stream.events

  • Interface Summary
    Interface Description
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    Comment
    An interface for comment events
    DTD
    This is the top level interface for events dealing with DTDs
    EndDocument
    A marker interface for the end of the document
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    EntityReference
    An interface for handling Entity events.
    Namespace
    An interface that contains information about a namespace.
    NotationDeclaration
    An interface for handling Notation Declarations Receive notification of a notation declaration event.
    ProcessingInstruction
    An interface that describes the data found in processing instructions
    StartDocument
    An interface for the start document event
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.stream.events (Java Platform SE 8 )

compact3 - javax.xml.stream.events

Interfaces

  • Attribute
  • Characters
  • Comment
  • DTD
  • EndDocument
  • EndElement
  • EntityDeclaration
  • EntityReference
  • Namespace
  • NotationDeclaration
  • ProcessingInstruction
  • StartDocument
  • StartElement
  • XMLEvent


javax.xml.stream.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.stream.events

  • Interface Summary
    Interface Description
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    Comment
    An interface for comment events
    DTD
    This is the top level interface for events dealing with DTDs
    EndDocument
    A marker interface for the end of the document
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    EntityReference
    An interface for handling Entity events.
    Namespace
    An interface that contains information about a namespace.
    NotationDeclaration
    An interface for handling Notation Declarations Receive notification of a notation declaration event.
    ProcessingInstruction
    An interface that describes the data found in processing instructions
    StartDocument
    An interface for the start document event
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DTD (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface DTD

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface DTD
extends XMLEvent
    This is the top level interface for events dealing with DTDs
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getDocumentTypeDeclaration()
      Returns the entire Document Type Declaration as a string, including the internal DTD subset.
      List getEntities()
      Return a List containing the general entities, both external and internal, declared in the DTD.
      List getNotations()
      Return a List containing the notations declared in the DTD.
      Object getProcessedDTD()
      Returns an implementation defined representation of the DTD.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getDocumentTypeDeclaration

        String getDocumentTypeDeclaration()
        Returns the entire Document Type Declaration as a string, including the internal DTD subset. This may be null if there is not an internal subset. If it is not null it must return the entire Document Type Declaration which matches the doctypedecl production in the XML 1.0 specification

      • getProcessedDTD

        Object getProcessedDTD()
        Returns an implementation defined representation of the DTD. This method may return null if no representation is available.

      • getNotations

        List getNotations()
        Return a List containing the notations declared in the DTD. This list must contain NotationDeclaration events.
        Returns:
        an unordered list of NotationDeclaration events
        See Also:
        NotationDeclaration

      • getEntities

        List getEntities()
        Return a List containing the general entities, both external and internal, declared in the DTD. This list must contain EntityDeclaration events.
        Returns:
        an unordered list of EntityDeclaration events
        See Also:
        EntityDeclaration
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EndDocument (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface EndDocument

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EndDocument
extends XMLEvent
    A marker interface for the end of the document
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EndElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface EndElement

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EndElement
extends XMLEvent
    An interface for the end element event. An EndElement is reported for each End Tag in the document.
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLEvent

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      QName getName()
      Get the name of this event
      Iterator getNamespaces()
      Returns an Iterator of namespaces that have gone out of scope.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getName

        QName getName()
        Get the name of this event
        Returns:
        the qualified name of this event

      • getNamespaces

        Iterator getNamespaces()
        Returns an Iterator of namespaces that have gone out of scope. Returns an empty iterator if no namespaces have gone out of scope.
        Returns:
        an Iterator over Namespace interfaces, or an empty iterator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EntityDeclaration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface EntityDeclaration

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EntityDeclaration
extends XMLEvent
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getBaseURI()
      Get the base URI for this reference or null if this information is not available
      String getName()
      The entity's name
      String getNotationName()
      The name of the associated notation.
      String getPublicId()
      The entity's public identifier, or null if none was given
      String getReplacementText()
      The replacement text of the entity.
      String getSystemId()
      The entity's system identifier.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getPublicId

        String getPublicId()
        The entity's public identifier, or null if none was given
        Returns:
        the public ID for this declaration or null

      • getSystemId

        String getSystemId()
        The entity's system identifier.
        Returns:
        the system ID for this declaration or null

      • getName

        String getName()
        The entity's name
        Returns:
        the name, may not be null

      • getNotationName

        String getNotationName()
        The name of the associated notation.
        Returns:
        the notation name

      • getReplacementText

        String getReplacementText()
        The replacement text of the entity. This method will only return non-null if this is an internal entity.
        Returns:
        null or the replacment text

      • getBaseURI

        String getBaseURI()
        Get the base URI for this reference or null if this information is not available
        Returns:
        the base URI or null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EntityReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface EntityReference

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EntityReference
extends XMLEvent
    An interface for handling Entity events. This event reports entities that have not been resolved and reports their replacement text unprocessed (if available). This event will be reported if javax.xml.stream.isReplacingEntityReferences is set to false. If javax.xml.stream.isReplacingEntityReferences is set to true entity references will be resolved transparently. Entities are handled in two possible ways: (1) If javax.xml.stream.isReplacingEntityReferences is set to true all entity references are resolved and reported as markup transparently. (2) If javax.xml.stream.isReplacingEntityReferences is set to false Entity references are reported as an EntityReference Event.
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      EntityDeclaration getDeclaration()
      Return the declaration of this entity.
      String getName()
      The name of the entity

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getDeclaration

        EntityDeclaration getDeclaration()
        Return the declaration of this entity.

      • getName

        String getName()
        The name of the entity
        Returns:
        the entity's name, may not be null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Namespace (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface Namespace

  • All Superinterfaces:
    Attribute, XMLEvent, XMLStreamConstants

    public interface Namespace
extends Attribute
    An interface that contains information about a namespace. Namespaces are accessed from a StartElement.
    Since:
    1.6
    Version:
    1.0
    See Also:
    StartElement

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getNamespaceURI()
      Gets the uri bound to the prefix of this namespace
      String getPrefix()
      Gets the prefix, returns "" if this is a default namespace declaration.
      boolean isDefaultNamespaceDeclaration()
      returns true if this attribute declares the default namespace

      • Methods inherited from interface javax.xml.stream.events.Attribute

        getDTDType, getName, getValue, isSpecified

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getPrefix

        String getPrefix()
        Gets the prefix, returns "" if this is a default namespace declaration.

      • getNamespaceURI

        String getNamespaceURI()
        Gets the uri bound to the prefix of this namespace

      • isDefaultNamespaceDeclaration

        boolean isDefaultNamespaceDeclaration()
        returns true if this attribute declares the default namespace
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotationDeclaration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface NotationDeclaration

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface NotationDeclaration
extends XMLEvent
    An interface for handling Notation Declarations Receive notification of a notation declaration event. It is up to the application to record the notation for later reference, At least one of publicId and systemId must be non-null. There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getName()
      The notation name.
      String getPublicId()
      The notation's public identifier, or null if none was given.
      String getSystemId()
      The notation's system identifier, or null if none was given.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getName

        String getName()
        The notation name.

      • getPublicId

        String getPublicId()
        The notation's public identifier, or null if none was given.

      • getSystemId

        String getSystemId()
        The notation's system identifier, or null if none was given.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.stream.events (Java Platform SE 8 )

javax.xml.stream.events

Interfaces

  • Attribute
  • Characters
  • Comment
  • DTD
  • EndDocument
  • EndElement
  • EntityDeclaration
  • EntityReference
  • Namespace
  • NotationDeclaration
  • ProcessingInstruction
  • StartDocument
  • StartElement
  • XMLEvent


javax.xml.stream.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.stream.events

  • Interface Summary
    Interface Description
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    Comment
    An interface for comment events
    DTD
    This is the top level interface for events dealing with DTDs
    EndDocument
    A marker interface for the end of the document
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    EntityReference
    An interface for handling Entity events.
    Namespace
    An interface that contains information about a namespace.
    NotationDeclaration
    An interface for handling Notation Declarations Receive notification of a notation declaration event.
    ProcessingInstruction
    An interface that describes the data found in processing instructions
    StartDocument
    An interface for the start document event
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.stream.events Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.stream.events

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.stream.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.stream.events

  • Packages that use javax.xml.stream.events
    Package Description
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
  • Classes in javax.xml.stream.events used by javax.xml.stream
    Class and Description
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    Comment
    An interface for comment events
    DTD
    This is the top level interface for events dealing with DTDs
    EndDocument
    A marker interface for the end of the document
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    EntityReference
    An interface for handling Entity events.
    Namespace
    An interface that contains information about a namespace.
    ProcessingInstruction
    An interface that describes the data found in processing instructions
    StartDocument
    An interface for the start document event
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
  • Classes in javax.xml.stream.events used by javax.xml.stream.events
    Class and Description
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
  • Classes in javax.xml.stream.events used by javax.xml.stream.util
    Class and Description
    XMLEvent
    This is the base event interface for handling markup events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ProcessingInstruction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface ProcessingInstruction

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface ProcessingInstruction
extends XMLEvent
    An interface that describes the data found in processing instructions
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getData()
      The data section of the processing instruction
      String getTarget()
      The target section of the processing instruction

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getTarget

        String getTarget()
        The target section of the processing instruction
        Returns:
        the String value of the PI or null

      • getData

        String getData()
        The data section of the processing instruction
        Returns:
        the String value of the PI's data or null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StartDocument (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface StartDocument

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface StartDocument
extends XMLEvent
    An interface for the start document event
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean encodingSet()
      Returns true if CharacterEncodingScheme was set in the encoding declaration of the document
      String getCharacterEncodingScheme()
      Returns the encoding style of the XML data
      String getSystemId()
      Returns the system ID of the XML data
      String getVersion()
      Returns the version of XML of this XML stream
      boolean isStandalone()
      Returns if this XML is standalone
      boolean standaloneSet()
      Returns true if the standalone attribute was set in the encoding declaration of the document.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getSystemId

        String getSystemId()
        Returns the system ID of the XML data
        Returns:
        the system ID, defaults to ""

      • getCharacterEncodingScheme

        String getCharacterEncodingScheme()
        Returns the encoding style of the XML data
        Returns:
        the character encoding, defaults to "UTF-8"

      • encodingSet

        boolean encodingSet()
        Returns true if CharacterEncodingScheme was set in the encoding declaration of the document

      • isStandalone

        boolean isStandalone()
        Returns if this XML is standalone
        Returns:
        the standalone state of XML, defaults to "no"

      • standaloneSet

        boolean standaloneSet()
        Returns true if the standalone attribute was set in the encoding declaration of the document.

      • getVersion

        String getVersion()
        Returns the version of XML of this XML stream
        Returns:
        the version of XML, defaults to "1.0"
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StartElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface StartElement

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface StartElement
extends XMLEvent
    The StartElement interface provides access to information about start elements. A StartElement is reported for each Start Tag in the document.
    Since:
    1.6
    Version:
    1.0

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Attribute getAttributeByName(QName name)
      Returns the attribute referred to by this name
      Iterator getAttributes()
      Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes.
      QName getName()
      Get the name of this event
      NamespaceContext getNamespaceContext()
      Gets a read-only namespace context.
      Iterator getNamespaces()
      Returns an Iterator of namespaces declared on this element.
      String getNamespaceURI(String prefix)
      Gets the value that the prefix is bound to in the context of this element.

      • Methods inherited from interface javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • Method Detail

      • getName

        QName getName()
        Get the name of this event
        Returns:
        the qualified name of this event

      • getAttributes

        Iterator getAttributes()
        Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes. The iterator must contain only implementations of the javax.xml.stream.Attribute interface. Attributes are fundamentally unordered and may not be reported in any order.
        Returns:
        a readonly Iterator over Attribute interfaces, or an empty iterator

      • getNamespaces

        Iterator getNamespaces()
        Returns an Iterator of namespaces declared on this element. This Iterator does not contain previously declared namespaces unless they appear on the current START_ELEMENT. Therefore this list may contain redeclared namespaces and duplicate namespace declarations. Use the getNamespaceContext() method to get the current context of namespace declarations.

        The iterator must contain only implementations of the javax.xml.stream.Namespace interface.

        A Namespace isA Attribute. One can iterate over a list of namespaces as a list of attributes. However this method returns only the list of namespaces declared on this START_ELEMENT and does not include the attributes declared on this START_ELEMENT. Returns an empty iterator if there are no namespaces.

        Returns:
        a readonly Iterator over Namespace interfaces, or an empty iterator

      • getAttributeByName

        Attribute getAttributeByName(QName name)
        Returns the attribute referred to by this name
        Parameters:
        name - the qname of the desired name
        Returns:
        the attribute corresponding to the name value or null

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Gets a read-only namespace context. If no context is available this method will return an empty namespace context. The NamespaceContext contains information about all namespaces in scope for this StartElement.
        Returns:
        the current namespace context

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Gets the value that the prefix is bound to in the context of this element. Returns null if the prefix is not bound in this context
        Parameters:
        prefix - the prefix to lookup
        Returns:
        the uri bound to the prefix or null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.events

Interface XMLEvent

  • All Superinterfaces:
    XMLStreamConstants
    All Known Subinterfaces:
    Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement

    public interface XMLEvent
extends XMLStreamConstants
    This is the base event interface for handling markup events. Events are value objects that are used to communicate the XML 1.0 InfoSet to the Application. Events may be cached and referenced after the parse has completed.
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLEventReader, Characters, ProcessingInstruction, StartElement, EndElement, StartDocument, EndDocument, EntityReference, EntityDeclaration, NotationDeclaration

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Characters asCharacters()
      Returns this event as Characters, may result in a class cast exception if this event is not Characters.
      EndElement asEndElement()
      Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
      StartElement asStartElement()
      Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
      int getEventType()
      Returns an integer code for this event.
      Location getLocation()
      Return the location of this event.
      QName getSchemaType()
      This method is provided for implementations to provide optional type information about the associated event.
      boolean isAttribute()
      A utility function to check if this event is an Attribute.
      boolean isCharacters()
      A utility function to check if this event is Characters.
      boolean isEndDocument()
      A utility function to check if this event is an EndDocument.
      boolean isEndElement()
      A utility function to check if this event is a EndElement.
      boolean isEntityReference()
      A utility function to check if this event is an EntityReference.
      boolean isNamespace()
      A utility function to check if this event is a Namespace.
      boolean isProcessingInstruction()
      A utility function to check if this event is a ProcessingInstruction.
      boolean isStartDocument()
      A utility function to check if this event is a StartDocument.
      boolean isStartElement()
      A utility function to check if this event is a StartElement.
      void writeAsEncodedUnicode(Writer writer)
      This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters.

    • Method Detail

      • getEventType

        int getEventType()
        Returns an integer code for this event.
        See Also:
        XMLStreamConstants.START_ELEMENT, XMLStreamConstants.END_ELEMENT, XMLStreamConstants.CHARACTERS, XMLStreamConstants.ATTRIBUTE, XMLStreamConstants.NAMESPACE, XMLStreamConstants.PROCESSING_INSTRUCTION, XMLStreamConstants.COMMENT, XMLStreamConstants.START_DOCUMENT, XMLStreamConstants.END_DOCUMENT, XMLStreamConstants.DTD

      • getLocation

        Location getLocation()
        Return the location of this event. The Location returned from this method is non-volatile and will retain its information.
        See Also:
        Location

      • isStartElement

        boolean isStartElement()
        A utility function to check if this event is a StartElement.
        See Also:
        StartElement

      • isAttribute

        boolean isAttribute()
        A utility function to check if this event is an Attribute.
        See Also:
        Attribute

      • isNamespace

        boolean isNamespace()
        A utility function to check if this event is a Namespace.
        See Also:
        Namespace

      • isEndElement

        boolean isEndElement()
        A utility function to check if this event is a EndElement.
        See Also:
        EndElement

      • isEntityReference

        boolean isEntityReference()
        A utility function to check if this event is an EntityReference.
        See Also:
        EntityReference

      • isProcessingInstruction

        boolean isProcessingInstruction()
        A utility function to check if this event is a ProcessingInstruction.
        See Also:
        ProcessingInstruction

      • isCharacters

        boolean isCharacters()
        A utility function to check if this event is Characters.
        See Also:
        Characters

      • isStartDocument

        boolean isStartDocument()
        A utility function to check if this event is a StartDocument.
        See Also:
        StartDocument

      • isEndDocument

        boolean isEndDocument()
        A utility function to check if this event is an EndDocument.
        See Also:
        EndDocument

      • asStartElement

        StartElement asStartElement()
        Returns this event as a start element event, may result in a class cast exception if this event is not a start element.

      • asEndElement

        EndElement asEndElement()
        Returns this event as an end element event, may result in a class cast exception if this event is not a end element.

      • asCharacters

        Characters asCharacters()
        Returns this event as Characters, may result in a class cast exception if this event is not Characters.

      • getSchemaType

        QName getSchemaType()
        This method is provided for implementations to provide optional type information about the associated event. It is optional and will return null if no information is available.

      • writeAsEncodedUnicode

        void writeAsEncodedUnicode(Writer writer)
                    throws XMLStreamException
        This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters. No indentation or whitespace should be outputted. Any user defined event type SHALL have this method called when being written to on an output stream. Built in Event types MUST implement this method, but implementations MAY choose not call these methods for optimizations reasons when writing out built in Events to an output stream. The output generated MUST be equivalent in terms of the infoset expressed.
        Parameters:
        writer - The writer that will output the data
        Throws:
        XMLStreamException - if there is a fatal error writing the event
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.Attribute (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.Attribute

  • Packages that use Attribute
    Package Description
    javax.xml.stream
    javax.xml.stream.events

    • Uses of Attribute in javax.xml.stream

      Methods in javax.xml.stream that return Attribute
      Modifier and Type Method and Description
      abstract Attribute XMLEventFactory.createAttribute(QName name, String value)
      Create a new Attribute
      abstract Attribute XMLEventFactory.createAttribute(String localName, String value)
      Create a new Attribute
      abstract Attribute XMLEventFactory.createAttribute(String prefix, String namespaceURI, String localName, String value)
      Create a new Attribute

    • Uses of Attribute in javax.xml.stream.events

      Subinterfaces of Attribute in javax.xml.stream.events
      Modifier and Type Interface and Description
      interface  Namespace
      An interface that contains information about a namespace.
      Methods in javax.xml.stream.events that return Attribute
      Modifier and Type Method and Description
      Attribute StartElement.getAttributeByName(QName name)
      Returns the attribute referred to by this name
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.Characters (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.Characters

  • Packages that use Characters
    Package Description
    javax.xml.stream
    javax.xml.stream.events

    • Uses of Characters in javax.xml.stream

      Methods in javax.xml.stream that return Characters
      Modifier and Type Method and Description
      abstract Characters XMLEventFactory.createCData(String content)
      Create a Characters event with the CData flag set to true
      abstract Characters XMLEventFactory.createCharacters(String content)
      Create a Characters event, this method does not check if the content is all whitespace.
      abstract Characters XMLEventFactory.createIgnorableSpace(String content)
      Create an ignorable space
      abstract Characters XMLEventFactory.createSpace(String content)
      Create a Characters event with the isSpace flag set to true

    • Uses of Characters in javax.xml.stream.events

      Methods in javax.xml.stream.events that return Characters
      Modifier and Type Method and Description
      Characters XMLEvent.asCharacters()
      Returns this event as Characters, may result in a class cast exception if this event is not Characters.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.Comment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.Comment

  • Packages that use Comment
    Package Description
    javax.xml.stream

    • Uses of Comment in javax.xml.stream

      Methods in javax.xml.stream that return Comment
      Modifier and Type Method and Description
      abstract Comment XMLEventFactory.createComment(String text)
      Create a comment
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.DTD (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.DTD

  • Packages that use DTD
    Package Description
    javax.xml.stream

    • Uses of DTD in javax.xml.stream

      Methods in javax.xml.stream that return DTD
      Modifier and Type Method and Description
      abstract DTD XMLEventFactory.createDTD(String dtd)
      Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.EndDocument (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.EndDocument

  • Packages that use EndDocument
    Package Description
    javax.xml.stream

    • Uses of EndDocument in javax.xml.stream

      Methods in javax.xml.stream that return EndDocument
      Modifier and Type Method and Description
      abstract EndDocument XMLEventFactory.createEndDocument()
      Creates a new instance of an EndDocument event
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.EndElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.EndElement

  • Packages that use EndElement
    Package Description
    javax.xml.stream
    javax.xml.stream.events

    • Uses of EndElement in javax.xml.stream

      Methods in javax.xml.stream that return EndElement
      Modifier and Type Method and Description
      abstract EndElement XMLEventFactory.createEndElement(QName name, Iterator namespaces)
      Create a new EndElement
      abstract EndElement XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName)
      Create a new EndElement
      abstract EndElement XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces)
      Create a new EndElement

    • Uses of EndElement in javax.xml.stream.events

      Methods in javax.xml.stream.events that return EndElement
      Modifier and Type Method and Description
      EndElement XMLEvent.asEndElement()
      Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.EntityDeclaration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.EntityDeclaration

  • Packages that use EntityDeclaration
    Package Description
    javax.xml.stream
    javax.xml.stream.events

    • Uses of EntityDeclaration in javax.xml.stream

      Methods in javax.xml.stream with parameters of type EntityDeclaration
      Modifier and Type Method and Description
      abstract EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
      Creates a new instance of a EntityReference event

    • Uses of EntityDeclaration in javax.xml.stream.events

      Methods in javax.xml.stream.events that return EntityDeclaration
      Modifier and Type Method and Description
      EntityDeclaration EntityReference.getDeclaration()
      Return the declaration of this entity.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.EntityReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.EntityReference

  • Packages that use EntityReference
    Package Description
    javax.xml.stream

    • Uses of EntityReference in javax.xml.stream

      Methods in javax.xml.stream that return EntityReference
      Modifier and Type Method and Description
      abstract EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
      Creates a new instance of a EntityReference event
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.Namespace (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.Namespace

  • Packages that use Namespace
    Package Description
    javax.xml.stream

    • Uses of Namespace in javax.xml.stream

      Methods in javax.xml.stream that return Namespace
      Modifier and Type Method and Description
      abstract Namespace XMLEventFactory.createNamespace(String namespaceURI)
      Create a new default Namespace
      abstract Namespace XMLEventFactory.createNamespace(String prefix, String namespaceUri)
      Create a new Namespace
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.NotationDeclaration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.NotationDeclaration

No usage of javax.xml.stream.events.NotationDeclaration
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.ProcessingInstruction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.ProcessingInstruction

  • Packages that use ProcessingInstruction
    Package Description
    javax.xml.stream

    • Uses of ProcessingInstruction in javax.xml.stream

      Methods in javax.xml.stream that return ProcessingInstruction
      Modifier and Type Method and Description
      abstract ProcessingInstruction XMLEventFactory.createProcessingInstruction(String target, String data)
      Create a processing instruction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.StartDocument (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.StartDocument

  • Packages that use StartDocument
    Package Description
    javax.xml.stream

    • Uses of StartDocument in javax.xml.stream

      Methods in javax.xml.stream that return StartDocument
      Modifier and Type Method and Description
      abstract StartDocument XMLEventFactory.createStartDocument()
      Creates a new instance of a StartDocument event
      abstract StartDocument XMLEventFactory.createStartDocument(String encoding)
      Creates a new instance of a StartDocument event
      abstract StartDocument XMLEventFactory.createStartDocument(String encoding, String version)
      Creates a new instance of a StartDocument event
      abstract StartDocument XMLEventFactory.createStartDocument(String encoding, String version, boolean standalone)
      Creates a new instance of a StartDocument event
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.StartElement (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.StartElement

  • Packages that use StartElement
    Package Description
    javax.xml.stream
    javax.xml.stream.events

    • Uses of StartElement in javax.xml.stream

      Methods in javax.xml.stream that return StartElement
      Modifier and Type Method and Description
      abstract StartElement XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName)
      Create a new StartElement.
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
      Create a new StartElement.

    • Uses of StartElement in javax.xml.stream.events

      Methods in javax.xml.stream.events that return StartElement
      Modifier and Type Method and Description
      StartElement XMLEvent.asStartElement()
      Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.events.XMLEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.events.XMLEvent

  • Packages that use XMLEvent
    Package Description
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util

    • Uses of XMLEvent in javax.xml.stream

      Methods in javax.xml.stream that return XMLEvent
      Modifier and Type Method and Description
      XMLEvent XMLEventReader.nextEvent()
      Get the next XMLEvent
      XMLEvent XMLEventReader.nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent XMLEventReader.peek()
      Check the next XMLEvent without reading it from the stream.
      Methods in javax.xml.stream with parameters of type XMLEvent
      Modifier and Type Method and Description
      boolean EventFilter.accept(XMLEvent event)
      Tests whether this event is part of this stream.
      void XMLEventWriter.add(XMLEvent event)
      Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.

    • Uses of XMLEvent in javax.xml.stream.events

      Subinterfaces of XMLEvent in javax.xml.stream.events
      Modifier and Type Interface and Description
      interface  Attribute
      An interface that contains information about an attribute.
      interface  Characters
      This describes the interface to Characters events.
      interface  Comment
      An interface for comment events
      interface  DTD
      This is the top level interface for events dealing with DTDs
      interface  EndDocument
      A marker interface for the end of the document
      interface  EndElement
      An interface for the end element event.
      interface  EntityDeclaration
      An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
      interface  EntityReference
      An interface for handling Entity events.
      interface  Namespace
      An interface that contains information about a namespace.
      interface  NotationDeclaration
      An interface for handling Notation Declarations Receive notification of a notation declaration event.
      interface  ProcessingInstruction
      An interface that describes the data found in processing instructions
      interface  StartDocument
      An interface for the start document event
      interface  StartElement
      The StartElement interface provides access to information about start elements.

    • Uses of XMLEvent in javax.xml.stream.util

      Methods in javax.xml.stream.util that return XMLEvent
      Modifier and Type | Method and Description
      XMLEvent XMLEventAllocator.allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      XMLEvent | EventReaderDelegate.nextEvent()
      XMLEvent | EventReaderDelegate.nextTag()
      XMLEvent | EventReaderDelegate.peek()
      Methods in javax.xml.stream.util with parameters of type XMLEvent
      Modifier and Type Method and Description
      void XMLEventConsumer.add(XMLEvent event)
      This method adds an event to the consumer.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.stream.util (Java Platform SE 8 )

compact2 - javax.xml.stream.util

Interfaces

  • XMLEventAllocator
  • XMLEventConsumer

Classes

  • EventReaderDelegate
  • StreamReaderDelegate


javax.xml.stream.util (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.stream.util

  • Interface Summary
    Interface Description
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • Class Summary
    Class Description
    EventReaderDelegate
    This is the base class for deriving an XMLEventReader filter.
    StreamReaderDelegate
    This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.stream.util (Java Platform SE 8 )

compact3 - javax.xml.stream.util

Interfaces

  • XMLEventAllocator
  • XMLEventConsumer

Classes

  • EventReaderDelegate
  • StreamReaderDelegate


javax.xml.stream.util (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.stream.util

  • Interface Summary
    Interface Description
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • Class Summary
    Class Description
    EventReaderDelegate
    This is the base class for deriving an XMLEventReader filter.
    StreamReaderDelegate
    This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EventReaderDelegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.util

Class EventReaderDelegate

  • java.lang.Object
    • javax.xml.stream.util.EventReaderDelegate
  • All Implemented Interfaces:
    Iterator, XMLEventReader

    public class EventReaderDelegate
extends Object
implements XMLEventReader
    This is the base class for deriving an XMLEventReader filter. This class is designed to sit between an XMLEventReader and an application's XMLEventReader. By default each method does nothing but call the corresponding method on the parent interface.
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLEventReader, StreamReaderDelegate

    • Constructor Summary

      Constructors
      Constructor and Description
      EventReaderDelegate()
      Construct an empty filter with no parent.
      EventReaderDelegate(XMLEventReader reader)
      Construct an filter with the specified parent.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void close()
      Frees any resources associated with this Reader.
      String getElementText()
      Reads the content of a text-only element.
      XMLEventReader getParent()
      Get the parent of this instance.
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      boolean hasNext()
      Check if there are more events.
      Object next()
      Returns the next element in the iteration.
      XMLEvent nextEvent()
      Get the next XMLEvent
      XMLEvent nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent peek()
      Check the next XMLEvent without reading it from the stream.
      void remove()
      Removes from the underlying collection the last element returned by this iterator (optional operation).
      void setParent(XMLEventReader reader)
      Set the parent of this instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface java.util.Iterator

        forEachRemaining

    • Constructor Detail

      • EventReaderDelegate

        public EventReaderDelegate()
        Construct an empty filter with no parent.

      • EventReaderDelegate

        public EventReaderDelegate(XMLEventReader reader)
        Construct an filter with the specified parent.
        Parameters:
        reader - the parent

    • Method Detail

      • setParent

        public void setParent(XMLEventReader reader)
        Set the parent of this instance.
        Parameters:
        reader - the new parent

      • getParent

        public XMLEventReader getParent()
        Get the parent of this instance.
        Returns:
        the parent or null if none is set

      • nextEvent

        public XMLEvent nextEvent()
                   throws XMLStreamException
        Description copied from interface: XMLEventReader
        Get the next XMLEvent
        Specified by:
        nextEvent in interface XMLEventReader
        Throws:
        XMLStreamException - if there is an error with the underlying XML.
        See Also:
        XMLEvent

      • next

        public Object next()
        Description copied from interface: Iterator
        Returns the next element in the iteration.
        Specified by:
        next in interface Iterator
        Returns:
        the next element in the iteration

      • hasNext

        public boolean hasNext()
        Description copied from interface: XMLEventReader
        Check if there are more events. Returns true if there are more events and false otherwise.
        Specified by:
        hasNext in interface Iterator
        Specified by:
        hasNext in interface XMLEventReader
        Returns:
        true if the event reader has more events, false otherwise

      • peek

        public XMLEvent peek()
              throws XMLStreamException
        Description copied from interface: XMLEventReader
        Check the next XMLEvent without reading it from the stream. Returns null if the stream is at EOF or has no more XMLEvents. A call to peek() will be equal to the next return of next().
        Specified by:
        peek in interface XMLEventReader
        Throws:
        XMLStreamException
        See Also:
        XMLEvent

      • close

        public void close()
           throws XMLStreamException
        Description copied from interface: XMLEventReader
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        Specified by:
        close in interface XMLEventReader
        Throws:
        XMLStreamException - if there are errors freeing associated resources

      • getElementText

        public String getElementText()
                      throws XMLStreamException
        Description copied from interface: XMLEventReader
        Reads the content of a text-only element. Precondition: the current event is START_ELEMENT. Postcondition: The current event is the corresponding END_ELEMENT.
        Specified by:
        getElementText in interface XMLEventReader
        Throws:
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • nextTag

        public XMLEvent nextTag()
                 throws XMLStreamException
        Description copied from interface: XMLEventReader
        Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached. If anything other than space characters are encountered, an exception is thrown. This method should be used when processing element-only content because the parser is not able to recognize ignorable whitespace if the DTD is missing or not interpreted.
        Specified by:
        nextTag in interface XMLEventReader
        Throws:
        XMLStreamException - if anything other than space characters are encountered

      • getProperty

        public Object getProperty(String name)
                   throws IllegalArgumentException
        Description copied from interface: XMLEventReader
        Get the value of a feature/property from the underlying implementation
        Specified by:
        getProperty in interface XMLEventReader
        Parameters:
        name - The name of the property
        Returns:
        The value of the property
        Throws:
        IllegalArgumentException - if the property is not supported

      • remove

        public void remove()
        Description copied from interface: Iterator
        Removes from the underlying collection the last element returned by this iterator (optional operation). This method can be called only once per call to Iterator.next(). The behavior of an iterator is unspecified if the underlying collection is modified while the iteration is in progress in any way other than by calling this method.
        Specified by:
        remove in interface Iterator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.stream.util (Java Platform SE 8 )

javax.xml.stream.util

Interfaces

  • XMLEventAllocator
  • XMLEventConsumer

Classes

  • EventReaderDelegate
  • StreamReaderDelegate


javax.xml.stream.util (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.stream.util

  • Interface Summary
    Interface Description
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • Class Summary
    Class Description
    EventReaderDelegate
    This is the base class for deriving an XMLEventReader filter.
    StreamReaderDelegate
    This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.stream.util Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.stream.util

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)

Interface Hierarchy

  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.stream.util (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.stream.util

  • Packages that use javax.xml.stream.util
    Package Description
    javax.xml.stream
    javax.xml.stream.util
  • Classes in javax.xml.stream.util used by javax.xml.stream
    Class and Description
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • Classes in javax.xml.stream.util used by javax.xml.stream.util
    Class and Description
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StreamReaderDelegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.util

Class StreamReaderDelegate

  • java.lang.Object
    • javax.xml.stream.util.StreamReaderDelegate
  • All Implemented Interfaces:
    XMLStreamConstants, XMLStreamReader

    public class StreamReaderDelegate
extends Object
implements XMLStreamReader
    This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader. By default each method does nothing but call the corresponding method on the parent interface.
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLStreamReader, EventReaderDelegate

    • Field Summary

      • Fields inherited from interface javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • Constructor Summary

      Constructors
      Constructor and Description
      StreamReaderDelegate()
      Construct an empty filter with no parent.
      StreamReaderDelegate(XMLStreamReader reader)
      Construct an filter with the specified parent.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void close()
      Frees any resources associated with this Reader.
      int getAttributeCount()
      Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
      String getAttributeLocalName(int index)
      Returns the localName of the attribute at the provided index
      QName getAttributeName(int index)
      Returns the qname of the attribute at the provided index
      String getAttributeNamespace(int index)
      Returns the namespace of the attribute at the provided index
      String getAttributePrefix(int index)
      Returns the prefix of this attribute at the provided index
      String getAttributeType(int index)
      Returns the XML type of the attribute at the provided index
      String getAttributeValue(int index)
      Returns the value of the attribute at the index
      String getAttributeValue(String namespaceUri, String localName)
      Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
      String getCharacterEncodingScheme()
      Returns the character encoding declared on the xml declaration Returns null if none was declared
      String getElementText()
      Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
      String getEncoding()
      Return input encoding if known or null if unknown.
      int getEventType()
      Returns an integer code that indicates the type of the event the cursor is pointing to.
      String getLocalName()
      Returns the (local) name of the current event.
      Location getLocation()
      Return the current location of the processor.
      QName getName()
      Returns a QName for the current START_ELEMENT or END_ELEMENT event
      NamespaceContext getNamespaceContext()
      Returns a read only namespace context for the current position.
      int getNamespaceCount()
      Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
      String getNamespacePrefix(int index)
      Returns the prefix for the namespace declared at the index.
      String getNamespaceURI()
      If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
      String getNamespaceURI(int index)
      Returns the uri for the namespace declared at the index.
      String getNamespaceURI(String prefix)
      Return the uri for the given prefix.
      XMLStreamReader getParent()
      Get the parent of this instance.
      String getPIData()
      Get the data section of a processing instruction
      String getPITarget()
      Get the target of a processing instruction
      String getPrefix()
      Returns the prefix of the current event or null if the event does not have a prefix
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      String getText()
      Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
      char[] getTextCharacters()
      Returns an array which contains the characters from this event.
      int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
      int getTextLength()
      Returns the length of the sequence of characters for this Text event within the text character array.
      int getTextStart()
      Returns the offset into the text character array where the first character (of this text event) is stored.
      String getVersion()
      Get the xml version declared on the xml declaration Returns null if none was declared
      boolean hasName()
      returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
      boolean hasNext()
      Returns true if there are more parsing events and false if there are no more events.
      boolean hasText()
      Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
      boolean isAttributeSpecified(int index)
      Returns a boolean which indicates if this attribute was created by default
      boolean isCharacters()
      Returns true if the cursor points to a character data event
      boolean isEndElement()
      Returns true if the cursor points to an end tag (otherwise false)
      boolean isStandalone()
      Get the standalone declaration from the xml declaration
      boolean isStartElement()
      Returns true if the cursor points to a start tag (otherwise false)
      boolean isWhiteSpace()
      Returns true if the cursor points to a character data event that consists of all whitespace
      int next()
      Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
      int nextTag()
      Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
      void require(int type, String namespaceURI, String localName)
      Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
      void setParent(XMLStreamReader reader)
      Set the parent of this instance.
      boolean standaloneSet()
      Checks if standalone was set in the document

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StreamReaderDelegate

        public StreamReaderDelegate()
        Construct an empty filter with no parent.

      • StreamReaderDelegate

        public StreamReaderDelegate(XMLStreamReader reader)
        Construct an filter with the specified parent.
        Parameters:
        reader - the parent

    • Method Detail

      • setParent

        public void setParent(XMLStreamReader reader)
        Set the parent of this instance.
        Parameters:
        reader - the new parent

      • getParent

        public XMLStreamReader getParent()
        Get the parent of this instance.
        Returns:
        the parent or null if none is set

      • next

        public int next()
         throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks. If the property javax.xml.stream.isCoalescing is set to true element content must be coalesced and only one CHARACTERS event must be returned for contiguous element content or CDATA Sections. By default entity references must be expanded and reported transparently to the application. An exception will be thrown if an entity reference cannot be expanded. If element content is empty (i.e. content is "") then no CHARACTERS event will be reported.

        Given the following XML:
        <foo><!--description-->content text<![CDATA[<greeting>Hello</greeting>]]>other content</foo>
        The behavior of calling next() when being on foo will be:
        1- the comment (COMMENT)
        2- then the characters section (CHARACTERS)
        3- then the CDATA section (another CHARACTERS)
        4- then the next characters section (another CHARACTERS)
        5- then the END_ELEMENT

        NOTE: empty element (such as <tag/>) will be reported with two separate events: START_ELEMENT, END_ELEMENT - This preserves parsing equivalency of empty element to <tag></tag>. This method will throw an IllegalStateException if it is called after hasNext() returns false.

        Specified by:
        next in interface XMLStreamReader
        Returns:
        the integer code corresponding to the current parse event
        Throws:
        XMLStreamException - if there is an error processing the underlying XML source
        See Also:
        XMLEvent

      • nextTag

        public int nextTag()
            throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached. If other than white space characters, COMMENT, PROCESSING_INSTRUCTION, START_ELEMENT, END_ELEMENT are encountered, an exception is thrown. This method should be used when processing element-only content seperated by white space.
        Precondition: none
        Postcondition: the current event is START_ELEMENT or END_ELEMENT and cursor may have moved over any whitespace event.
        Essentially it does the following (implementations are free to optimized but must do equivalent processing):
         int eventType = next();
 while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
 || (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
 // skip whitespace
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT
 ) {
 eventType = next();
 }
 if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
 throw new String XMLStreamException("expected start or end tag", getLocation());
 }
 return eventType;
        Specified by:
        nextTag in interface XMLStreamReader
        Returns:
        the event type of the element read (START_ELEMENT or END_ELEMENT)
        Throws:
        XMLStreamException - if the current event is not white space, PROCESSING_INSTRUCTION, START_ELEMENT or END_ELEMENT

      • getElementText

        public String getElementText()
                      throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Reads the content of a text-only element, an exception is thrown if this is not a text-only element. Regardless of value of javax.xml.stream.isCoalescing this method always returns coalesced content.
        Precondition: the current event is START_ELEMENT.
        Postcondition: the current event is the corresponding END_ELEMENT.
        The method does the following (implementations are free to optimized but must do equivalent processing):
         if(getEventType() != XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "parser must be on START_ELEMENT to read next text", getLocation());
 }
 int eventType = next();
 StringBuffer content = new StringBuffer();
 while(eventType != XMLStreamConstants.END_ELEMENT ) {
 if(eventType == XMLStreamConstants.CHARACTERS
 || eventType == XMLStreamConstants.CDATA
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.ENTITY_REFERENCE) {
 buf.append(getText());
 } else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT) {
 // skipping
 } else if(eventType == XMLStreamConstants.END_DOCUMENT) {
 throw new XMLStreamException(
 "unexpected end of document when reading element text content", this);
 } else if(eventType == XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "element text content may not contain START_ELEMENT", getLocation());
 } else {
 throw new XMLStreamException(
 "Unexpected event type "+eventType, getLocation());
 }
 eventType = next();
 }
 return buf.toString();
        Specified by:
        getElementText in interface XMLStreamReader
        Throws:
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • require

        public void require(int type,
                    String namespaceURI,
                    String localName)
             throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event. If the namespaceURI is null it is not checked for equality, if the localName is null it is not checked for equality.
        Specified by:
        require in interface XMLStreamReader
        Parameters:
        type - the event type
        namespaceURI - the uri of the event, may be null
        localName - the localName of the event, may be null
        Throws:
        XMLStreamException - if the required values are not matched.

      • hasNext

        public boolean hasNext()
                throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Returns true if there are more parsing events and false if there are no more events. This method will return false if the current state of the XMLStreamReader is END_DOCUMENT
        Specified by:
        hasNext in interface XMLStreamReader
        Returns:
        true if there are more events, false otherwise
        Throws:
        XMLStreamException - if there is a fatal error detecting the next state

      • close

        public void close()
           throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        Specified by:
        close in interface XMLStreamReader
        Throws:
        XMLStreamException - if there are errors freeing associated resources

      • getNamespaceURI

        public String getNamespaceURI(String prefix)
        Description copied from interface: XMLStreamReader
        Return the uri for the given prefix. The uri returned depends on the current state of the processor.

        NOTE:The 'xml' prefix is bound as defined in Namespaces in XML specification to "http://www.w3.org/XML/1998/namespace".

        NOTE: The 'xmlns' prefix must be resolved to following namespace http://www.w3.org/2000/xmlns/

        Specified by:
        getNamespaceURI in interface XMLStreamReader
        Parameters:
        prefix - The prefix to lookup, may not be null
        Returns:
        the uri bound to the given prefix or null if it is not bound

      • getNamespaceContext

        public NamespaceContext getNamespaceContext()
        Description copied from interface: XMLStreamReader
        Returns a read only namespace context for the current position. The context is transient and only valid until a call to next() changes the state of the reader.
        Specified by:
        getNamespaceContext in interface XMLStreamReader
        Returns:
        return a namespace context

      • isStartElement

        public boolean isStartElement()
        Description copied from interface: XMLStreamReader
        Returns true if the cursor points to a start tag (otherwise false)
        Specified by:
        isStartElement in interface XMLStreamReader
        Returns:
        true if the cursor points to a start tag, false otherwise

      • isEndElement

        public boolean isEndElement()
        Description copied from interface: XMLStreamReader
        Returns true if the cursor points to an end tag (otherwise false)
        Specified by:
        isEndElement in interface XMLStreamReader
        Returns:
        true if the cursor points to an end tag, false otherwise

      • isCharacters

        public boolean isCharacters()
        Description copied from interface: XMLStreamReader
        Returns true if the cursor points to a character data event
        Specified by:
        isCharacters in interface XMLStreamReader
        Returns:
        true if the cursor points to character data, false otherwise

      • isWhiteSpace

        public boolean isWhiteSpace()
        Description copied from interface: XMLStreamReader
        Returns true if the cursor points to a character data event that consists of all whitespace
        Specified by:
        isWhiteSpace in interface XMLStreamReader
        Returns:
        true if the cursor points to all whitespace, false otherwise

      • getAttributeValue

        public String getAttributeValue(String namespaceUri,
                                String localName)
        Description copied from interface: XMLStreamReader
        Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
        Specified by:
        getAttributeValue in interface XMLStreamReader
        Parameters:
        namespaceUri - the namespace of the attribute
        localName - the local name of the attribute, cannot be null
        Returns:
        returns the value of the attribute , returns null if not found

      • getAttributeCount

        public int getAttributeCount()
        Description copied from interface: XMLStreamReader
        Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE. This count excludes namespace definitions. Attribute indices are zero-based.
        Specified by:
        getAttributeCount in interface XMLStreamReader
        Returns:
        returns the number of attributes

      • getAttributeName

        public QName getAttributeName(int index)
        Description copied from interface: XMLStreamReader
        Returns the qname of the attribute at the provided index
        Specified by:
        getAttributeName in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        the QName of the attribute

      • getAttributePrefix

        public String getAttributePrefix(int index)
        Description copied from interface: XMLStreamReader
        Returns the prefix of this attribute at the provided index
        Specified by:
        getAttributePrefix in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        the prefix of the attribute

      • getAttributeNamespace

        public String getAttributeNamespace(int index)
        Description copied from interface: XMLStreamReader
        Returns the namespace of the attribute at the provided index
        Specified by:
        getAttributeNamespace in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        the namespace URI (can be null)

      • getAttributeLocalName

        public String getAttributeLocalName(int index)
        Description copied from interface: XMLStreamReader
        Returns the localName of the attribute at the provided index
        Specified by:
        getAttributeLocalName in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        the localName of the attribute

      • getAttributeType

        public String getAttributeType(int index)
        Description copied from interface: XMLStreamReader
        Returns the XML type of the attribute at the provided index
        Specified by:
        getAttributeType in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        the XML type of the attribute

      • getAttributeValue

        public String getAttributeValue(int index)
        Description copied from interface: XMLStreamReader
        Returns the value of the attribute at the index
        Specified by:
        getAttributeValue in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        the attribute value

      • isAttributeSpecified

        public boolean isAttributeSpecified(int index)
        Description copied from interface: XMLStreamReader
        Returns a boolean which indicates if this attribute was created by default
        Specified by:
        isAttributeSpecified in interface XMLStreamReader
        Parameters:
        index - the position of the attribute
        Returns:
        true if this is a default attribute

      • getNamespaceCount

        public int getNamespaceCount()
        Description copied from interface: XMLStreamReader
        Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE. On an END_ELEMENT the count is of the namespaces that are about to go out of scope. This is the equivalent of the information reported by SAX callback for an end element event.
        Specified by:
        getNamespaceCount in interface XMLStreamReader
        Returns:
        returns the number of namespace declarations on this specific element

      • getNamespacePrefix

        public String getNamespacePrefix(int index)
        Description copied from interface: XMLStreamReader
        Returns the prefix for the namespace declared at the index. Returns null if this is the default namespace declaration
        Specified by:
        getNamespacePrefix in interface XMLStreamReader
        Parameters:
        index - the position of the namespace declaration
        Returns:
        returns the namespace prefix

      • getNamespaceURI

        public String getNamespaceURI(int index)
        Description copied from interface: XMLStreamReader
        Returns the uri for the namespace declared at the index.
        Specified by:
        getNamespaceURI in interface XMLStreamReader
        Parameters:
        index - the position of the namespace declaration
        Returns:
        returns the namespace uri

      • getEventType

        public int getEventType()
        Description copied from interface: XMLStreamReader
        Returns an integer code that indicates the type of the event the cursor is pointing to.
        Specified by:
        getEventType in interface XMLStreamReader

      • getText

        public String getText()
        Description copied from interface: XMLStreamReader
        Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD. If an ENTITY_REFERENCE has been resolved, any character data will be reported as CHARACTERS events.
        Specified by:
        getText in interface XMLStreamReader
        Returns:
        the current text or null

      • getTextCharacters

        public int getTextCharacters(int sourceStart,
                             char[] target,
                             int targetStart,
                             int length)
                      throws XMLStreamException
        Description copied from interface: XMLStreamReader
        Gets the the text associated with a CHARACTERS, SPACE or CDATA event. Text starting a "sourceStart" is copied into "target" starting at "targetStart". Up to "length" characters are copied. The number of characters actually copied is returned. The "sourceStart" argument must be greater or equal to 0 and less than or equal to the number of characters associated with the event. Usually, one requests text starting at a "sourceStart" of 0. If the number of characters actually copied is less than the "length", then there is no more text. Otherwise, subsequent calls need to be made until all text has been retrieved. For example: int length = 1024; char[] myBuffer = new char[ length ]; for ( int sourceStart = 0 ; ; sourceStart += length ) { int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length ); if (nCopied < length) break; } XMLStreamException may be thrown if there are any XML errors in the underlying source. The "targetStart" argument must be greater than or equal to 0 and less than the length of "target", Length must be greater than 0 and "targetStart + length" must be less than or equal to length of "target".
        Specified by:
        getTextCharacters in interface XMLStreamReader
        Parameters:
        sourceStart - the index of the first character in the source array to copy
        target - the destination array
        targetStart - the start offset in the target array
        length - the number of characters to copy
        Returns:
        the number of characters actually copied
        Throws:
        XMLStreamException - if the underlying XML source is not well-formed

      • getTextCharacters

        public char[] getTextCharacters()
        Description copied from interface: XMLStreamReader
        Returns an array which contains the characters from this event. This array should be treated as read-only and transient. I.e. the array will contain the text characters until the XMLStreamReader moves on to the next event. Attempts to hold onto the character array beyond that time or modify the contents of the array are breaches of the contract for this interface.
        Specified by:
        getTextCharacters in interface XMLStreamReader
        Returns:
        the current text or an empty array

      • getTextStart

        public int getTextStart()
        Description copied from interface: XMLStreamReader
        Returns the offset into the text character array where the first character (of this text event) is stored.
        Specified by:
        getTextStart in interface XMLStreamReader

      • getTextLength

        public int getTextLength()
        Description copied from interface: XMLStreamReader
        Returns the length of the sequence of characters for this Text event within the text character array.
        Specified by:
        getTextLength in interface XMLStreamReader

      • getEncoding

        public String getEncoding()
        Description copied from interface: XMLStreamReader
        Return input encoding if known or null if unknown.
        Specified by:
        getEncoding in interface XMLStreamReader
        Returns:
        the encoding of this instance or null

      • hasText

        public boolean hasText()
        Description copied from interface: XMLStreamReader
        Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
        Specified by:
        hasText in interface XMLStreamReader

      • getLocation

        public Location getLocation()
        Description copied from interface: XMLStreamReader
        Return the current location of the processor. If the Location is unknown the processor should return an implementation of Location that returns -1 for the location and null for the publicId and systemId. The location information is only valid until next() is called.
        Specified by:
        getLocation in interface XMLStreamReader

      • getName

        public QName getName()
        Description copied from interface: XMLStreamReader
        Returns a QName for the current START_ELEMENT or END_ELEMENT event
        Specified by:
        getName in interface XMLStreamReader
        Returns:
        the QName for the current START_ELEMENT or END_ELEMENT event

      • getLocalName

        public String getLocalName()
        Description copied from interface: XMLStreamReader
        Returns the (local) name of the current event. For START_ELEMENT or END_ELEMENT returns the (local) name of the current element. For ENTITY_REFERENCE it returns entity name. The current event must be START_ELEMENT or END_ELEMENT, or ENTITY_REFERENCE
        Specified by:
        getLocalName in interface XMLStreamReader
        Returns:
        the localName

      • hasName

        public boolean hasName()
        Description copied from interface: XMLStreamReader
        returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
        Specified by:
        hasName in interface XMLStreamReader

      • getNamespaceURI

        public String getNamespaceURI()
        Description copied from interface: XMLStreamReader
        If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace. Returns null if the event does not have a prefix.
        Specified by:
        getNamespaceURI in interface XMLStreamReader
        Returns:
        the URI bound to this elements prefix, the default namespace, or null

      • getPrefix

        public String getPrefix()
        Description copied from interface: XMLStreamReader
        Returns the prefix of the current event or null if the event does not have a prefix
        Specified by:
        getPrefix in interface XMLStreamReader
        Returns:
        the prefix or null

      • getVersion

        public String getVersion()
        Description copied from interface: XMLStreamReader
        Get the xml version declared on the xml declaration Returns null if none was declared
        Specified by:
        getVersion in interface XMLStreamReader
        Returns:
        the XML version or null

      • isStandalone

        public boolean isStandalone()
        Description copied from interface: XMLStreamReader
        Get the standalone declaration from the xml declaration
        Specified by:
        isStandalone in interface XMLStreamReader
        Returns:
        true if this is standalone, or false otherwise

      • standaloneSet

        public boolean standaloneSet()
        Description copied from interface: XMLStreamReader
        Checks if standalone was set in the document
        Specified by:
        standaloneSet in interface XMLStreamReader
        Returns:
        true if standalone was set in the document, or false otherwise

      • getCharacterEncodingScheme

        public String getCharacterEncodingScheme()
        Description copied from interface: XMLStreamReader
        Returns the character encoding declared on the xml declaration Returns null if none was declared
        Specified by:
        getCharacterEncodingScheme in interface XMLStreamReader
        Returns:
        the encoding declared in the document or null

      • getPITarget

        public String getPITarget()
        Description copied from interface: XMLStreamReader
        Get the target of a processing instruction
        Specified by:
        getPITarget in interface XMLStreamReader
        Returns:
        the target or null

      • getPIData

        public String getPIData()
        Description copied from interface: XMLStreamReader
        Get the data section of a processing instruction
        Specified by:
        getPIData in interface XMLStreamReader
        Returns:
        the data or null

      • getProperty

        public Object getProperty(String name)
        Description copied from interface: XMLStreamReader
        Get the value of a feature/property from the underlying implementation
        Specified by:
        getProperty in interface XMLStreamReader
        Parameters:
        name - The name of the property, may not be null
        Returns:
        The value of the property
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLEventAllocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.util

Interface XMLEventAllocator

  • public interface XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader. An implementation is not required to use the XMLEventFactory implementation but this is recommended. The XMLEventAllocator can be set on an XMLInputFactory using the property "javax.xml.stream.allocator"
    Since:
    1.6
    Version:
    1.0
    See Also:
    XMLInputFactory, XMLEventFactory

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      XMLEvent allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      void allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
      XMLEventAllocator newInstance()
      This method creates an instance of the XMLEventAllocator.

    • Method Detail

      • newInstance

        XMLEventAllocator newInstance()
        This method creates an instance of the XMLEventAllocator. This allows the XMLInputFactory to allocate a new instance per reader.

      • allocate

        XMLEvent allocate(XMLStreamReader reader)
           throws XMLStreamException
        This method allocates an event given the current state of the XMLStreamReader. If this XMLEventAllocator does not have a one-to-one mapping between reader states and events this method will return null. This method must not modify the state of the XMLStreamReader.
        Parameters:
        reader - The XMLStreamReader to allocate from
        Returns:
        the event corresponding to the current reader state
        Throws:
        XMLStreamException

      • allocate

        void allocate(XMLStreamReader reader,
              XMLEventConsumer consumer)
       throws XMLStreamException
        This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in. This method can be used to expand or contract reader states into event states. This method may modify the state of the XMLStreamReader.
        Parameters:
        reader - The XMLStreamReader to allocate from
        consumer - The XMLEventConsumer to add to.
        Throws:
        XMLStreamException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLEventConsumer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.stream.util

Interface XMLEventConsumer

  • All Known Subinterfaces:
    XMLEventWriter

    public interface XMLEventConsumer
    This interface defines an event consumer interface. The contract of the of a consumer is to accept the event. This interface can be used to mark an object as able to receive events. Add may be called several times in immediate succession so a consumer must be able to cache events it hasn't processed yet.
    Since:
    1.6
    Version:
    1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add(XMLEvent event)
      This method adds an event to the consumer.

    • Method Detail

      • add

        void add(XMLEvent event)
  throws XMLStreamException
        This method adds an event to the consumer. Calling this method invalidates the event parameter. The client application should discard all references to this event upon calling add. The behavior of an application that continues to use such references is undefined.
        Parameters:
        event - the event to add, may not be null
        Throws:
        XMLStreamException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.util.EventReaderDelegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.util.EventReaderDelegate

No usage of javax.xml.stream.util.EventReaderDelegate
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.stream.util.StreamReaderDelegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.stream.util.StreamReaderDelegate

No usage of javax.xml.stream.util.StreamReaderDelegate
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.util.XMLEventAllocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.util.XMLEventAllocator

  • Packages that use XMLEventAllocator
    Package Description
    javax.xml.stream
    javax.xml.stream.util

    • Uses of XMLEventAllocator in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventAllocator
      Modifier and Type Method and Description
      abstract XMLEventAllocator XMLInputFactory.getEventAllocator()
      Gets the allocator used by streams created with this factory
      Methods in javax.xml.stream with parameters of type XMLEventAllocator
      Modifier and Type Method and Description
      abstract void XMLInputFactory.setEventAllocator(XMLEventAllocator allocator)
      Set a user defined event allocator for events

    • Uses of XMLEventAllocator in javax.xml.stream.util

      Methods in javax.xml.stream.util that return XMLEventAllocator
      Modifier and Type Method and Description
      XMLEventAllocator XMLEventAllocator.newInstance()
      This method creates an instance of the XMLEventAllocator.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.stream.util.XMLEventConsumer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.stream.util.XMLEventConsumer

  • Packages that use XMLEventConsumer
    Package Description
    javax.xml.stream
    javax.xml.stream.util

    • Uses of XMLEventConsumer in javax.xml.stream

      Subinterfaces of XMLEventConsumer in javax.xml.stream
      Modifier and Type Interface and Description
      interface  XMLEventWriter
      This is the top level interface for writing XML documents.

    • Uses of XMLEventConsumer in javax.xml.stream.util

      Methods in javax.xml.stream.util with parameters of type XMLEventConsumer
      Modifier and Type Method and Description
      void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.transform (Java Platform SE 8 )

compact2 - javax.xml.transform

Interfaces

  • ErrorListener
  • Result
  • Source
  • SourceLocator
  • Templates
  • URIResolver

Classes

  • OutputKeys
  • Transformer
  • TransformerFactory

Exceptions

  • TransformerConfigurationException
  • TransformerException

Errors

  • TransformerFactoryConfigurationError


javax.xml.transform (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.transform

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

See: Description

  • Interface Summary
    Interface Description
    ErrorListener
    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    URIResolver
    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
  • Class Summary
    Class Description
    OutputKeys
    Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
  • Exception Summary
    Exception Description
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerException
    This class specifies an exceptional condition that occured during the transformation process.
  • Error Summary
    Error Description
    TransformerFactoryConfigurationError
    Thrown when a problem with configuration with the Transformer Factories exists.

Package javax.xml.transform Description

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result. These interfaces have no dependencies on SAX or the DOM standard, and try to make as few assumptions as possible about the details of the source and result of a transformation. It achieves this by defining Source and Result interfaces.

To define concrete classes for the user, the API defines specializations of the interfaces found at the root level. These interfaces are found in javax.xml.transform.sax, javax.xml.transform.dom, and javax.xml.transform.stream.

Creating Objects

The API allows a concrete TransformerFactory object to be created from the static function TransformerFactory.newInstance().

Specification of Inputs and Outputs

This API defines two interface objects called Source and Result. In order to pass Source and Result objects to the interfaces, concrete classes must be used. Three concrete representations are defined for each of these objects: StreamSource and StreamResult, SAXSource and SAXResult, and DOMSource and DOMResult. Each of these objects defines a FEATURE string (which is i the form of a URL), which can be passed into TransformerFactory.getFeature(java.lang.String) to see if the given type of Source or Result object is supported. For instance, to test if a DOMSource and a StreamResult is supported, you can apply the following test.

TransformerFactory tfactory = TransformerFactory.newInstance();
if (tfactory.getFeature(DOMSource.FEATURE) && tfactory.getFeature(StreamResult.FEATURE)) {
...
}

Qualified Name Representation

Namespaces present something of a problem area when dealing with XML objects. Qualified Names appear in XML markup as prefixed names. But the prefixes themselves do not hold identity. Rather, it is the URIs that they contextually map to that hold the identity. Therefore, when passing a Qualified Name like "xyz:foo" among Java programs, one must provide a means to map "xyz" to a namespace.

One solution has been to create a "QName" object that holds the namespace URI, as well as the prefix and local name, but this is not always an optimal solution, as when, for example, you want to use unique strings as keys in a dictionary object. Not having a string representation also makes it difficult to specify a namespaced identity outside the context of an XML document.

In order to pass namespaced values to transformations, for instance when setting a property or a parameter on a Transformer object, this specification defines that a String "qname" object parameter be passed as two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the qname has a null URI, then the String object only contains the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the Qualified Name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that the prefix is lost.

Result Tree Serialization

Serialization of the result tree to a stream can be controlled with the Transformer.setOutputProperties(java.util.Properties) and the Transformer.setOutputProperty(java.lang.String, java.lang.String) methods. These properties only apply to stream results, they have no effect when the result is a DOM tree or SAX event stream.

Strings that match the XSLT specification for xsl:output attributes can be referenced from the OutputKeys class. Other strings can be specified as well. If the transformer does not recognize an output key, a IllegalArgumentException is thrown, unless the key name is namespace qualified. Output key names that are namespace qualified are always allowed, although they may be ignored by some implementations.

If all that is desired is the simple identity transformation of a source to a result, then TransformerFactory provides a TransformerFactory.newTransformer() method with no arguments. This method creates a Transformer that effectively copies the source to the result. This method may be used to create a DOM from SAX events or to create an XML or HTML stream from a DOM or SAX events.

Exceptions and Error Reporting

The transformation API throw three types of specialized exceptions. A TransformerFactoryConfigurationError is parallel to the FactoryConfigurationError, and is thrown when a configuration problem with the TransformerFactory exists. This error will typically be thrown when the transformation factory class specified with the "javax.xml.transform.TransformerFactory" system property cannot be found or instantiated.

A TransformerConfigurationException may be thrown if for any reason a Transformer can not be created. A TransformerConfigurationException may be thrown if there is a syntax error in the transformation instructions, for example when TransformerFactory.newTransformer(javax.xml.transform.Source) is called.

TransformerException is a general exception that occurs during the course of a transformation. A transformer exception may wrap another exception, and if any of the TransformerException.printStackTrace() methods are called on it, it will produce a list of stack dumps, starting from the most recent. The transformer exception also provides a SourceLocator object which indicates where in the source tree or transformation instructions the error occurred. TransformerException.getMessageAndLocation() may be called to get an error message with location info, and TransformerException.getLocationAsString() may be called to get just the location string.

Transformation warnings and errors are sent to an ErrorListener, at which point the application may decide to report the error or warning, and may decide to throw an Exception for a non-fatal error. The ErrorListener may be set via TransformerFactory.setErrorListener(javax.xml.transform.ErrorListener) for reporting errors that have to do with syntax errors in the transformation instructions, or via Transformer.setErrorListener(javax.xml.transform.ErrorListener) to report errors that occur during the transformation. The ErrorListener on both objects will always be valid and non-null, whether set by the application or a default implementation provided by the processor. The default implementation provided by the processor will report all warnings and errors to System.err and does not throw any Exceptions. Applications are strongly encouraged to register and use ErrorListeners that insure proper behavior for warnings and errors.

Resolution of URIs within a transformation

The API provides a way for URIs referenced from within the stylesheet instructions or within the transformation to be resolved by the calling application. This can be done by creating a class that implements the URIResolver interface, with its one method, URIResolver.resolve(java.lang.String, java.lang.String), and use this class to set the URI resolution for the transformation instructions or transformation with TransformerFactory.setURIResolver(javax.xml.transform.URIResolver) or Transformer.setURIResolver(javax.xml.transform.URIResolver). The URIResolver.resolve method takes two String arguments, the URI found in the stylesheet instructions or built as part of the transformation process, and the base URI against which the first argument will be made absolute if the absolute URI is required. The returned Source object must be usable by the transformer, as specified in its implemented features.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.transform (Java Platform SE 8 )

compact3 - javax.xml.transform

Interfaces

  • ErrorListener
  • Result
  • Source
  • SourceLocator
  • Templates
  • URIResolver

Classes

  • OutputKeys
  • Transformer
  • TransformerFactory

Exceptions

  • TransformerConfigurationException
  • TransformerException

Errors

  • TransformerFactoryConfigurationError


javax.xml.transform (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.transform

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

See: Description

  • Interface Summary
    Interface Description
    ErrorListener
    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    URIResolver
    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
  • Class Summary
    Class Description
    OutputKeys
    Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
  • Exception Summary
    Exception Description
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerException
    This class specifies an exceptional condition that occured during the transformation process.
  • Error Summary
    Error Description
    TransformerFactoryConfigurationError
    Thrown when a problem with configuration with the Transformer Factories exists.

Package javax.xml.transform Description

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result. These interfaces have no dependencies on SAX or the DOM standard, and try to make as few assumptions as possible about the details of the source and result of a transformation. It achieves this by defining Source and Result interfaces.

To define concrete classes for the user, the API defines specializations of the interfaces found at the root level. These interfaces are found in javax.xml.transform.sax, javax.xml.transform.dom, and javax.xml.transform.stream.

Creating Objects

The API allows a concrete TransformerFactory object to be created from the static function TransformerFactory.newInstance().

Specification of Inputs and Outputs

This API defines two interface objects called Source and Result. In order to pass Source and Result objects to the interfaces, concrete classes must be used. Three concrete representations are defined for each of these objects: StreamSource and StreamResult, SAXSource and SAXResult, and DOMSource and DOMResult. Each of these objects defines a FEATURE string (which is i the form of a URL), which can be passed into TransformerFactory.getFeature(java.lang.String) to see if the given type of Source or Result object is supported. For instance, to test if a DOMSource and a StreamResult is supported, you can apply the following test.

TransformerFactory tfactory = TransformerFactory.newInstance();
if (tfactory.getFeature(DOMSource.FEATURE) && tfactory.getFeature(StreamResult.FEATURE)) {
...
}

Qualified Name Representation

Namespaces present something of a problem area when dealing with XML objects. Qualified Names appear in XML markup as prefixed names. But the prefixes themselves do not hold identity. Rather, it is the URIs that they contextually map to that hold the identity. Therefore, when passing a Qualified Name like "xyz:foo" among Java programs, one must provide a means to map "xyz" to a namespace.

One solution has been to create a "QName" object that holds the namespace URI, as well as the prefix and local name, but this is not always an optimal solution, as when, for example, you want to use unique strings as keys in a dictionary object. Not having a string representation also makes it difficult to specify a namespaced identity outside the context of an XML document.

In order to pass namespaced values to transformations, for instance when setting a property or a parameter on a Transformer object, this specification defines that a String "qname" object parameter be passed as two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the qname has a null URI, then the String object only contains the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the Qualified Name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that the prefix is lost.

Result Tree Serialization

Serialization of the result tree to a stream can be controlled with the Transformer.setOutputProperties(java.util.Properties) and the Transformer.setOutputProperty(java.lang.String, java.lang.String) methods. These properties only apply to stream results, they have no effect when the result is a DOM tree or SAX event stream.

Strings that match the XSLT specification for xsl:output attributes can be referenced from the OutputKeys class. Other strings can be specified as well. If the transformer does not recognize an output key, a IllegalArgumentException is thrown, unless the key name is namespace qualified. Output key names that are namespace qualified are always allowed, although they may be ignored by some implementations.

If all that is desired is the simple identity transformation of a source to a result, then TransformerFactory provides a TransformerFactory.newTransformer() method with no arguments. This method creates a Transformer that effectively copies the source to the result. This method may be used to create a DOM from SAX events or to create an XML or HTML stream from a DOM or SAX events.

Exceptions and Error Reporting

The transformation API throw three types of specialized exceptions. A TransformerFactoryConfigurationError is parallel to the FactoryConfigurationError, and is thrown when a configuration problem with the TransformerFactory exists. This error will typically be thrown when the transformation factory class specified with the "javax.xml.transform.TransformerFactory" system property cannot be found or instantiated.

A TransformerConfigurationException may be thrown if for any reason a Transformer can not be created. A TransformerConfigurationException may be thrown if there is a syntax error in the transformation instructions, for example when TransformerFactory.newTransformer(javax.xml.transform.Source) is called.

TransformerException is a general exception that occurs during the course of a transformation. A transformer exception may wrap another exception, and if any of the TransformerException.printStackTrace() methods are called on it, it will produce a list of stack dumps, starting from the most recent. The transformer exception also provides a SourceLocator object which indicates where in the source tree or transformation instructions the error occurred. TransformerException.getMessageAndLocation() may be called to get an error message with location info, and TransformerException.getLocationAsString() may be called to get just the location string.

Transformation warnings and errors are sent to an ErrorListener, at which point the application may decide to report the error or warning, and may decide to throw an Exception for a non-fatal error. The ErrorListener may be set via TransformerFactory.setErrorListener(javax.xml.transform.ErrorListener) for reporting errors that have to do with syntax errors in the transformation instructions, or via Transformer.setErrorListener(javax.xml.transform.ErrorListener) to report errors that occur during the transformation. The ErrorListener on both objects will always be valid and non-null, whether set by the application or a default implementation provided by the processor. The default implementation provided by the processor will report all warnings and errors to System.err and does not throw any Exceptions. Applications are strongly encouraged to register and use ErrorListeners that insure proper behavior for warnings and errors.

Resolution of URIs within a transformation

The API provides a way for URIs referenced from within the stylesheet instructions or within the transformation to be resolved by the calling application. This can be done by creating a class that implements the URIResolver interface, with its one method, URIResolver.resolve(java.lang.String, java.lang.String), and use this class to set the URI resolution for the transformation instructions or transformation with TransformerFactory.setURIResolver(javax.xml.transform.URIResolver) or Transformer.setURIResolver(javax.xml.transform.URIResolver). The URIResolver.resolve method takes two String arguments, the URI found in the stylesheet instructions or built as part of the transformation process, and the base URI against which the first argument will be made absolute if the absolute URI is required. The returned Source object must be usable by the transformer, as specified in its implemented features.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ErrorListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Interface ErrorListener

  • public interface ErrorListener

    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer. The Transformer then reports all errors and warnings through this interface.

    If an application does not register its own custom ErrorListener, the default ErrorListener is used which reports all warnings and errors to System.err and does not throw any Exceptions. Applications are strongly encouraged to register and use ErrorListeners that insure proper behavior for warnings and errors.

    For transformation errors, a Transformer must use this interface instead of throwing an Exception: it is up to the application to decide whether to throw an Exception for different types of errors and warnings. Note however that the Transformer is not required to continue with the transformation after a call to fatalError(TransformerException exception).

    Transformers may use this mechanism to report XML parsing errors as well as transformation errors.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void error(TransformerException exception)
      Receive notification of a recoverable error.
      void fatalError(TransformerException exception)
      Receive notification of a non-recoverable error.
      void warning(TransformerException exception)
      Receive notification of a warning.

    • Method Detail

      • warning

        void warning(TransformerException exception)
      throws TransformerException
        Receive notification of a warning.

        Transformer can use this method to report conditions that are not errors or fatal errors. The default behaviour is to take no action.

        After invoking this method, the Transformer must continue with the transformation. It should still be possible for the application to process the document through to the end.

        Parameters:
        exception - The warning information encapsulated in a transformer exception.
        Throws:
        TransformerException - if the application chooses to discontinue the transformation.
        See Also:
        TransformerException

      • error

        void error(TransformerException exception)
    throws TransformerException
        Receive notification of a recoverable error.

        The transformer must continue to try and provide normal transformation after invoking this method. It should still be possible for the application to process the document through to the end if no other errors are encountered.

        Parameters:
        exception - The error information encapsulated in a transformer exception.
        Throws:
        TransformerException - if the application chooses to discontinue the transformation.
        See Also:
        TransformerException

      • fatalError

        void fatalError(TransformerException exception)
         throws TransformerException

        Receive notification of a non-recoverable error.

        The processor may choose to continue, but will not normally proceed to a successful completion.

        The method should throw an exception if it is unable to process the error, or if it wishes execution to terminate immediately. The processor will not necessarily honor this request.

        Parameters:
        exception - The error information encapsulated in a TransformerException.
        Throws:
        TransformerException - if the application chooses to discontinue the transformation.
        See Also:
        TransformerException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OutputKeys (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Class OutputKeys

  • java.lang.Object
    • javax.xml.transform.OutputKeys

  • public class OutputKeys
extends Object
    Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.

    All the fields in this class are read-only.

    See Also:
    section 16 of the XSL Transformations (XSLT) W3C Recommendation

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String CDATA_SECTION_ELEMENTS
      cdata-section-elements = expanded names.
      static String DOCTYPE_PUBLIC
      doctype-public = string.
      static String DOCTYPE_SYSTEM
      doctype-system = string.
      static String ENCODING
      encoding = string.
      static String INDENT
      indent = "yes" | "no".
      static String MEDIA_TYPE
      media-type = string.
      static String METHOD
      method = "xml" | "html" | "text" | expanded name.
      static String OMIT_XML_DECLARATION
      omit-xml-declaration = "yes" | "no".
      static String STANDALONE
      standalone = "yes" | "no".
      static String VERSION
      version = nmtoken.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • METHOD

        public static final String METHOD
        method = "xml" | "html" | "text" | expanded name.

        The value of the method property identifies the overall method that should be used for outputting the result tree. Other non-namespaced values may be used, such as "xhtml", but, if accepted, the handling of such values is implementation defined. If any of the method values are not accepted and are not namespace qualified, then Transformer.setOutputProperty(java.lang.String, java.lang.String) or Transformer.setOutputProperties(java.util.Properties) will throw a IllegalArgumentException.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • VERSION

        public static final String VERSION
        version = nmtoken.

        version specifies the version of the output method.

        When the output method is "xml", the version value specifies the version of XML to be used for outputting the result tree. The default value for the xml output method is 1.0. When the output method is "html", the version value indicates the version of the HTML. The default value for the xml output method is 4.0, which specifies that the result should be output as HTML conforming to the HTML 4.0 Recommendation [HTML]. If the output method is "text", the version property is ignored.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • ENCODING

        public static final String ENCODING
        encoding = string.

        encoding specifies the preferred character encoding that the Transformer should use to encode sequences of characters as sequences of bytes. The value of the encoding property should be treated case-insensitively. The value must only contain characters in the range #x21 to #x7E (i.e., printable ASCII characters). The value should either be a charset registered with the Internet Assigned Numbers Authority [IANA], [RFC2278] or start with X-.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • OMIT_XML_DECLARATION

        public static final String OMIT_XML_DECLARATION
        omit-xml-declaration = "yes" | "no".

        omit-xml-declaration specifies whether the XSLT processor should output an XML declaration; the value must be yes or no.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • STANDALONE

        public static final String STANDALONE
        standalone = "yes" | "no".

        standalone specifies whether the Transformer should output a standalone document declaration; the value must be yes or no.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • DOCTYPE_PUBLIC

        public static final String DOCTYPE_PUBLIC
        doctype-public = string.

        See the documentation for the DOCTYPE_SYSTEM property for a description of what the value of the key should be.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • DOCTYPE_SYSTEM

        public static final String DOCTYPE_SYSTEM
        doctype-system = string.

        doctype-system specifies the system identifier to be used in the document type declaration.

        If the doctype-system property is specified, the xml output method should output a document type declaration immediately before the first element. The name following <!DOCTYPE should be the name of the first element. If doctype-public property is also specified, then the xml output method should output PUBLIC followed by the public identifier and then the system identifier; otherwise, it should output SYSTEM followed by the system identifier. The internal subset should be empty. The value of the doctype-public property should be ignored unless the doctype-system property is specified.

        If the doctype-public or doctype-system properties are specified, then the html output method should output a document type declaration immediately before the first element. The name following <!DOCTYPE should be HTML or html. If the doctype-public property is specified, then the output method should output PUBLIC followed by the specified public identifier; if the doctype-system property is also specified, it should also output the specified system identifier following the public identifier. If the doctype-system property is specified but the doctype-public property is not specified, then the output method should output SYSTEM followed by the specified system identifier.

        doctype-system specifies the system identifier to be used in the document type declaration.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • CDATA_SECTION_ELEMENTS

        public static final String CDATA_SECTION_ELEMENTS
        cdata-section-elements = expanded names.

        cdata-section-elements specifies a whitespace delimited list of the names of elements whose text node children should be output using CDATA sections. Note that these names must use the format described in the section Qualfied Name Representation in javax.xml.transform.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation., Constant Field Values

      • INDENT

        public static final String INDENT
        indent = "yes" | "no".

        indent specifies whether the Transformer may add additional whitespace when outputting the result tree; the value must be yes or no.

        See Also:
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • MEDIA_TYPE

        public static final String MEDIA_TYPE
        media-type = string.

        media-type specifies the media type (MIME content type) of the data that results from outputting the result tree. The charset parameter should not be specified explicitly; instead, when the top-level media type is text, a charset parameter should be added according to the character encoding actually used by the output method.

        See Also:
        s ection 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform (Java Platform SE 8 )

javax.xml.transform

Interfaces

  • ErrorListener
  • Result
  • Source
  • SourceLocator
  • Templates
  • URIResolver

Classes

  • OutputKeys
  • Transformer
  • TransformerFactory

Exceptions

  • TransformerConfigurationException
  • TransformerException

Errors

  • TransformerFactoryConfigurationError


javax.xml.transform (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.transform

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

See: Description

  • Interface Summary
    Interface Description
    ErrorListener
    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    URIResolver
    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
  • Class Summary
    Class Description
    OutputKeys
    Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
  • Exception Summary
    Exception Description
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerException
    This class specifies an exceptional condition that occured during the transformation process.
  • Error Summary
    Error Description
    TransformerFactoryConfigurationError
    Thrown when a problem with configuration with the Transformer Factories exists.

Package javax.xml.transform Description

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result. These interfaces have no dependencies on SAX or the DOM standard, and try to make as few assumptions as possible about the details of the source and result of a transformation. It achieves this by defining Source and Result interfaces.

To define concrete classes for the user, the API defines specializations of the interfaces found at the root level. These interfaces are found in javax.xml.transform.sax, javax.xml.transform.dom, and javax.xml.transform.stream.

Creating Objects

The API allows a concrete TransformerFactory object to be created from the static function TransformerFactory.newInstance().

Specification of Inputs and Outputs

This API defines two interface objects called Source and Result. In order to pass Source and Result objects to the interfaces, concrete classes must be used. Three concrete representations are defined for each of these objects: StreamSource and StreamResult, SAXSource and SAXResult, and DOMSource and DOMResult. Each of these objects defines a FEATURE string (which is i the form of a URL), which can be passed into TransformerFactory.getFeature(java.lang.String) to see if the given type of Source or Result object is supported. For instance, to test if a DOMSource and a StreamResult is supported, you can apply the following test.

TransformerFactory tfactory = TransformerFactory.newInstance();
if (tfactory.getFeature(DOMSource.FEATURE) && tfactory.getFeature(StreamResult.FEATURE)) {
...
}

Qualified Name Representation

Namespaces present something of a problem area when dealing with XML objects. Qualified Names appear in XML markup as prefixed names. But the prefixes themselves do not hold identity. Rather, it is the URIs that they contextually map to that hold the identity. Therefore, when passing a Qualified Name like "xyz:foo" among Java programs, one must provide a means to map "xyz" to a namespace.

One solution has been to create a "QName" object that holds the namespace URI, as well as the prefix and local name, but this is not always an optimal solution, as when, for example, you want to use unique strings as keys in a dictionary object. Not having a string representation also makes it difficult to specify a namespaced identity outside the context of an XML document.

In order to pass namespaced values to transformations, for instance when setting a property or a parameter on a Transformer object, this specification defines that a String "qname" object parameter be passed as two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the qname has a null URI, then the String object only contains the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the Qualified Name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that the prefix is lost.

Result Tree Serialization

Serialization of the result tree to a stream can be controlled with the Transformer.setOutputProperties(java.util.Properties) and the Transformer.setOutputProperty(java.lang.String, java.lang.String) methods. These properties only apply to stream results, they have no effect when the result is a DOM tree or SAX event stream.

Strings that match the XSLT specification for xsl:output attributes can be referenced from the OutputKeys class. Other strings can be specified as well. If the transformer does not recognize an output key, a IllegalArgumentException is thrown, unless the key name is namespace qualified. Output key names that are namespace qualified are always allowed, although they may be ignored by some implementations.

If all that is desired is the simple identity transformation of a source to a result, then TransformerFactory provides a TransformerFactory.newTransformer() method with no arguments. This method creates a Transformer that effectively copies the source to the result. This method may be used to create a DOM from SAX events or to create an XML or HTML stream from a DOM or SAX events.

Exceptions and Error Reporting

The transformation API throw three types of specialized exceptions. A TransformerFactoryConfigurationError is parallel to the FactoryConfigurationError, and is thrown when a configuration problem with the TransformerFactory exists. This error will typically be thrown when the transformation factory class specified with the "javax.xml.transform.TransformerFactory" system property cannot be found or instantiated.

A TransformerConfigurationException may be thrown if for any reason a Transformer can not be created. A TransformerConfigurationException may be thrown if there is a syntax error in the transformation instructions, for example when TransformerFactory.newTransformer(javax.xml.transform.Source) is called.

TransformerException is a general exception that occurs during the course of a transformation. A transformer exception may wrap another exception, and if any of the TransformerException.printStackTrace() methods are called on it, it will produce a list of stack dumps, starting from the most recent. The transformer exception also provides a SourceLocator object which indicates where in the source tree or transformation instructions the error occurred. TransformerException.getMessageAndLocation() may be called to get an error message with location info, and TransformerException.getLocationAsString() may be called to get just the location string.

Transformation warnings and errors are sent to an ErrorListener, at which point the application may decide to report the error or warning, and may decide to throw an Exception for a non-fatal error. The ErrorListener may be set via TransformerFactory.setErrorListener(javax.xml.transform.ErrorListener) for reporting errors that have to do with syntax errors in the transformation instructions, or via Transformer.setErrorListener(javax.xml.transform.ErrorListener) to report errors that occur during the transformation. The ErrorListener on both objects will always be valid and non-null, whether set by the application or a default implementation provided by the processor. The default implementation provided by the processor will report all warnings and errors to System.err and does not throw any Exceptions. Applications are strongly encouraged to register and use ErrorListeners that insure proper behavior for warnings and errors.

Resolution of URIs within a transformation

The API provides a way for URIs referenced from within the stylesheet instructions or within the transformation to be resolved by the calling application. This can be done by creating a class that implements the URIResolver interface, with its one method, URIResolver.resolve(java.lang.String, java.lang.String), and use this class to set the URI resolution for the transformation instructions or transformation with TransformerFactory.setURIResolver(javax.xml.transform.URIResolver) or Transformer.setURIResolver(javax.xml.transform.URIResolver). The URIResolver.resolve method takes two String arguments, the URI found in the stylesheet instructions or built as part of the transformation process, and the base URI against which the first argument will be made absolute if the absolute URI is required. The returned Source object must be usable by the transformer, as specified in its implemented features.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.transform

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.OutputKeys
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.transform.TransformerFactoryConfigurationError
      • java.lang.Exception
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
    • javax.xml.transform.Transformer
    • javax.xml.transform.TransformerFactory

Interface Hierarchy

  • javax.xml.transform.ErrorListener
  • javax.xml.transform.Result
  • javax.xml.transform.Source
  • javax.xml.transform.SourceLocator
  • javax.xml.transform.Templates
  • javax.xml.transform.URIResolver
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.transform (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.transform

  • Packages that use javax.xml.transform
    Package Description
    java.sql
    Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
    javax.xml.transform.stream
    This package implements stream- and URI- specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.transform used by java.sql
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind.annotation
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind.helpers
    Class and Description
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind.util
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.soap
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.stream
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.transform
    Class and Description
    ErrorListener
    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerException
    This class specifies an exceptional condition that occured during the transformation process.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
    TransformerFactoryConfigurationError
    Thrown when a problem with configuration with the Transformer Factories exists.
    URIResolver
    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
  • Classes in javax.xml.transform used by javax.xml.transform.dom
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
  • Classes in javax.xml.transform used by javax.xml.transform.sax
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
  • Classes in javax.xml.transform used by javax.xml.transform.stax
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.transform.stream
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.validation
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.ws
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.ws.spi
    Class and Description
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.ws.wsaddressing
    Class and Description
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Result (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Interface Result

  • All Known Implementing Classes:
    DOMResult, JAXBResult, SAAJResult, SAXResult, StAXResult, StreamResult

    public interface Result

    An object that implements this interface contains the information needed to build a transformation result tree.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PI_DISABLE_OUTPUT_ESCAPING
      The name of the processing instruction that is sent if the result tree disables output escaping.
      static String PI_ENABLE_OUTPUT_ESCAPING
      The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setSystemId(String systemId)
      Set the system identifier for this Result.

    • Field Detail

      • PI_DISABLE_OUTPUT_ESCAPING

        static final String PI_DISABLE_OUTPUT_ESCAPING
        The name of the processing instruction that is sent if the result tree disables output escaping.

        Normally, result tree serialization escapes & and < (and possibly other characters) when outputting text nodes. This ensures that the output is well-formed XML. However, it is sometimes convenient to be able to produce output that is almost, but not quite well-formed XML; for example, the output may include ill-formed sections that will be transformed into well-formed XML by a subsequent non-XML aware process. If a processing instruction is sent with this name, serialization should be output without any escaping.

        Result DOM trees may also have PI_DISABLE_OUTPUT_ESCAPING and PI_ENABLE_OUTPUT_ESCAPING inserted into the tree.

        See Also:
        disable-output-escaping in XSLT Specification, Constant Field Values

      • PI_ENABLE_OUTPUT_ESCAPING

        static final String PI_ENABLE_OUTPUT_ESCAPING
        The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.
        See Also:
        disable-output-escaping in XSLT Specification, Constant Field Values

    • Method Detail

      • setSystemId

        void setSystemId(String systemId)
        Set the system identifier for this Result.

        If the Result is not to be written to a file, the system identifier is optional. The application may still want to provide one, however, for use in error messages and warnings, or to resolve relative output identifiers.

        Parameters:
        systemId - The system identifier as a URI string.

      • getSystemId

        String getSystemId()
        Get the system identifier that was set with setSystemId.
        Returns:
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Source (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Interface Source

  • All Known Implementing Classes:
    DOMSource, JAXBSource, SAXSource, StAXSource, StreamSource

    public interface Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setSystemId(String systemId)
      Set the system identifier for this Source.

    • Method Detail

      • setSystemId

        void setSystemId(String systemId)
        Set the system identifier for this Source.

        The system identifier is optional if the source does not get its data from a URL, but it may still be useful to provide one. The application can use a system identifier, for example, to resolve relative URIs and to include in error messages and warnings.

        Parameters:
        systemId - The system identifier as a URL string.

      • getSystemId

        String getSystemId()
        Get the system identifier that was set with setSystemId.
        Returns:
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SourceLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Interface SourceLocator

  • All Known Subinterfaces:
    DOMLocator

    public interface SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the character position where the current document event ends.
      int getLineNumber()
      Return the line number where the current document event ends.
      String getPublicId()
      Return the public identifier for the current document event.
      String getSystemId()
      Return the system identifier for the current document event.

    • Method Detail

      • getPublicId

        String getPublicId()
        Return the public identifier for the current document event.

        The return value is the public identifier of the document entity or of the external parsed entity in which the markup that triggered the event appears.

        Returns:
        A string containing the public identifier, or null if none is available.
        See Also:
        getSystemId()

      • getSystemId

        String getSystemId()
        Return the system identifier for the current document event.

        The return value is the system identifier of the document entity or of the external parsed entity in which the markup that triggered the event appears.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Returns:
        A string containing the system identifier, or null if none is available.
        See Also:
        getPublicId()

      • getLineNumber

        int getLineNumber()
        Return the line number where the current document event ends.

        Warning: The return value from the method is intended only as an approximation for the sake of error reporting; it is not intended to provide sufficient information to edit the character content of the original XML document.

        The return value is an approximation of the line number in the document entity or external parsed entity where the markup that triggered the event appears.

        Returns:
        The line number, or -1 if none is available.
        See Also:
        getColumnNumber()

      • getColumnNumber

        int getColumnNumber()
        Return the character position where the current document event ends.

        Warning: The return value from the method is intended only as an approximation for the sake of error reporting; it is not intended to provide sufficient information to edit the character content of the original XML document.

        The return value is an approximation of the column number in the document entity or external parsed entity where the markup that triggered the event appears.

        Returns:
        The column number, or -1 if none is available.
        See Also:
        getLineNumber()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Templates (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Interface Templates

  • public interface Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.

    Templates must be threadsafe for a given instance over multiple threads running concurrently, and may be used multiple times in a given session.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Properties getOutputProperties()
      Get the properties corresponding to the effective xsl:output element.
      Transformer newTransformer()
      Create a new transformation context for this Templates object.

    • Method Detail

      • newTransformer

        Transformer newTransformer()
                    throws TransformerConfigurationException
        Create a new transformation context for this Templates object.
        Returns:
        A valid non-null instance of a Transformer.
        Throws:
        TransformerConfigurationException - if a Transformer can not be created.

      • getOutputProperties

        Properties getOutputProperties()
        Get the properties corresponding to the effective xsl:output element. The object returned will be a clone of the internal values. Accordingly, it can be mutated without mutating the Templates object, and then handed in to Transformer.setOutputProperties(java.util.Properties).

        The properties returned should contain properties set by the stylesheet, and these properties are "defaulted" by default properties specified by section 16 of the XSL Transformations (XSLT) W3C Recommendation. The properties that were specifically set by the stylesheet should be in the base Properties list, while the XSLT default properties that were not specifically set should be in the "default" Properties list. Thus, getOutputProperties().getProperty(String key) will obtain any property in that was set by the stylesheet, or the default properties, while getOutputProperties().get(String key) will only retrieve properties that were explicitly set in the stylesheet.

        For XSLT, Attribute Value Templates attribute values will be returned unexpanded (since there is no context at this point). The namespace prefixes inside Attribute Value Templates will be unexpanded, so that they remain valid XPath values.

        Returns:
        A Properties object, never null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Transformer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Class Transformer

  • java.lang.Object
    • javax.xml.transform.Transformer

  • public abstract class Transformer
extends Object
    An instance of this abstract class can transform a source tree into a result tree.

    An instance of this class can be obtained with the TransformerFactory.newTransformer method. This instance may then be used to process XML from a variety of sources and write the transformation output to a variety of sinks.

    An object of this class may not be used in multiple threads running concurrently. Different Transformers may be used concurrently by different threads.

    A Transformer may be used multiple times. Parameters and output properties are preserved across transformations.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Transformer()
      Default constructor is protected on purpose.

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract void clearParameters()
      Clear all parameters set with setParameter.
      abstract ErrorListener getErrorListener()
      Get the error event handler in effect for the transformation.
      abstract Properties getOutputProperties()
      Get a copy of the output properties for the transformation.
      abstract String getOutputProperty(String name)
      Get an output property that is in effect for the transformer.
      abstract Object getParameter(String name)
      Get a parameter that was explicitly set with setParameter.
      abstract URIResolver getURIResolver()
      Get an object that will be used to resolve URIs used in document().
      void reset()
      Reset this Transformer to its original configuration.
      abstract void setErrorListener(ErrorListener listener)
      Set the error event listener in effect for the transformation.
      abstract void setOutputProperties(Properties oformat)
      Set the output properties for the transformation.
      abstract void setOutputProperty(String name, String value)
      Set an output property that will be in effect for the transformation.
      abstract void setParameter(String name, Object value)
      Add a parameter for the transformation.
      abstract void setURIResolver(URIResolver resolver)
      Set an object that will be used to resolve URIs used in document().
      abstract void transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Transformer

        protected Transformer()
        Default constructor is protected on purpose.

    • Method Detail

      • reset

        public void reset()

        Reset this Transformer to its original configuration.

        Transformer is reset to the same state as when it was created with TransformerFactory.newTransformer(), TransformerFactory.newTransformer(Source source) or Templates.newTransformer(). reset() is designed to allow the reuse of existing Transformers thus saving resources associated with the creation of new Transformers.

        The reset Transformer is not guaranteed to have the same URIResolver or ErrorListener Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal URIResolver and ErrorListener.

        Throws:
        UnsupportedOperationException - When implementation does not override this method.
        Since:
        1.5

      • transform

        public abstract void transform(Source xmlSource,
                               Result outputTarget)
                        throws TransformerException

        Transform the XML Source to a Result. Specific transformation behavior is determined by the settings of the TransformerFactory in effect when the Transformer was instantiated and any modifications made to the Transformer instance.

        An empty Source is represented as an empty document as constructed by DocumentBuilder.newDocument(). The result of transforming an empty Source depends on the transformation behavior; it is not always an empty Result.

        Parameters:
        xmlSource - The XML input to transform.
        outputTarget - The Result of transforming the xmlSource.
        Throws:
        TransformerException - If an unrecoverable error occurs during the course of the transformation.

      • setParameter

        public abstract void setParameter(String name,
                                  Object value)
        Add a parameter for the transformation.

        Pass a qualified name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

        For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

        Parameters:
        name - The name of the parameter, which may begin with a namespace URI in curly braces ({}).
        value - The value object. This can be any valid Java object. It is up to the processor to provide the proper object coersion or to simply pass the object on for use in an extension.
        Throws:
        NullPointerException - If value is null.

      • getParameter

        public abstract Object getParameter(String name)
        Get a parameter that was explicitly set with setParameter.

        This method does not return a default parameter value, which cannot be determined until the node context is evaluated during the transformation process.

        Parameters:
        name - of Object to get
        Returns:
        A parameter that has been set with setParameter.

      • clearParameters

        public abstract void clearParameters()
        Clear all parameters set with setParameter.

      • setURIResolver

        public abstract void setURIResolver(URIResolver resolver)
        Set an object that will be used to resolve URIs used in document().

        If the resolver argument is null, the URIResolver value will be cleared and the transformer will no longer have a resolver.

        Parameters:
        resolver - An object that implements the URIResolver interface, or null.

      • getURIResolver

        public abstract URIResolver getURIResolver()
        Get an object that will be used to resolve URIs used in document().
        Returns:
        An object that implements the URIResolver interface, or null.

      • setOutputProperties

        public abstract void setOutputProperties(Properties oformat)
        Set the output properties for the transformation. These properties will override properties set in the Templates with xsl:output.

        If argument to this function is null, any properties previously set are removed, and the value will revert to the value defined in the templates object.

        Pass a qualified property key name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

        For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

        An IllegalArgumentException is thrown if any of the argument keys are not recognized and are not namespace qualified.
        Parameters:
        oformat - A set of output properties that will be used to override any of the same properties in affect for the transformation.
        Throws:
        IllegalArgumentException - When keys are not recognized and are not namespace qualified.
        See Also:
        OutputKeys, Properties

      • getOutputProperties

        public abstract Properties getOutputProperties()

        Get a copy of the output properties for the transformation.

        The properties returned should contain properties set by the user, and properties set by the stylesheet, and these properties are "defaulted" by default properties specified by section 16 of the XSL Transformations (XSLT) W3C Recommendation. The properties that were specifically set by the user or the stylesheet should be in the base Properties list, while the XSLT default properties that were not specifically set should be the default Properties list. Thus, getOutputProperties().getProperty(String key) will obtain any property in that was set by setOutputProperty(java.lang.String, java.lang.String), setOutputProperties(java.util.Properties), in the stylesheet, or the default properties, while getOutputProperties().get(String key) will only retrieve properties that were explicitly set by setOutputProperty(java.lang.String, java.lang.String), setOutputProperties(java.util.Properties), or in the stylesheet.

        Note that mutation of the Properties object returned will not effect the properties that the transformer contains.

        If any of the argument keys are not recognized and are not namespace qualified, the property will be ignored and not returned. In other words the behaviour is not orthogonal with setOutputProperties.

        Returns:
        A copy of the set of output properties in effect for the next transformation.
        See Also:
        OutputKeys, Properties, XSL Transformations (XSLT) Version 1.0

      • setOutputProperty

        public abstract void setOutputProperty(String name,
                                       String value)
                                throws IllegalArgumentException
        Set an output property that will be in effect for the transformation.

        Pass a qualified property name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

        For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

        The Properties object that was passed to setOutputProperties(java.util.Properties) won't be effected by calling this method.

        Parameters:
        name - A non-null String that specifies an output property name, which may be namespace qualified.
        value - The non-null string value of the output property.
        Throws:
        IllegalArgumentException - If the property is not supported, and is not qualified with a namespace.
        See Also:
        OutputKeys

      • getOutputProperty

        public abstract String getOutputProperty(String name)
                                  throws IllegalArgumentException

        Get an output property that is in effect for the transformer.

        If a property has been set using setOutputProperty(java.lang.String, java.lang.String), that value will be returned. Otherwise, if a property is explicitly specified in the stylesheet, that value will be returned. If the value of the property has been defaulted, that is, if no value has been set explicitly either with setOutputProperty(java.lang.String, java.lang.String) or in the stylesheet, the result may vary depending on implementation and input stylesheet.

        Parameters:
        name - A non-null String that specifies an output property name, which may be namespace qualified.
        Returns:
        The string value of the output property, or null if no property was found.
        Throws:
        IllegalArgumentException - If the property is not supported.
        See Also:
        OutputKeys

      • setErrorListener

        public abstract void setErrorListener(ErrorListener listener)
                               throws IllegalArgumentException
        Set the error event listener in effect for the transformation.
        Parameters:
        listener - The new error listener.
        Throws:
        IllegalArgumentException - if listener is null.

      • getErrorListener

        public abstract ErrorListener getErrorListener()
        Get the error event handler in effect for the transformation. Implementations must provide a default error listener.
        Returns:
        The current error handler, which should never be null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformerConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Class TransformerConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
  • All Implemented Interfaces:
    Serializable

    public class TransformerConfigurationException
extends TransformerException
    Indicates a serious configuration error.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransformerConfigurationException()
      Create a new TransformerConfigurationException with no detail mesage.
      TransformerConfigurationException(String msg)
      Create a new TransformerConfigurationException with the String specified as an error message.
      TransformerConfigurationException(String message, SourceLocator locator)
      Create a new TransformerConfigurationException from a message and a Locator.
      TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerConfigurationException.
      TransformerConfigurationException(String msg, Throwable e)
      Create a new TransformerConfigurationException with the given Exception base cause and detail message.
      TransformerConfigurationException(Throwable e)
      Create a new TransformerConfigurationException with a given Exception base cause of the error.

    • Method Summary

      • Methods inherited from class javax.xml.transform.TransformerException

        getCause, getException, getLocationAsString, getLocator, getMessageAndLocation, initCause, printStackTrace, printStackTrace, printStackTrace, setLocator

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransformerConfigurationException

        public TransformerConfigurationException()
        Create a new TransformerConfigurationException with no detail mesage.

      • TransformerConfigurationException

        public TransformerConfigurationException(String msg)
        Create a new TransformerConfigurationException with the String specified as an error message.
        Parameters:
        msg - The error message for the exception.

      • TransformerConfigurationException

        public TransformerConfigurationException(Throwable e)
        Create a new TransformerConfigurationException with a given Exception base cause of the error.
        Parameters:
        e - The exception to be encapsulated in a TransformerConfigurationException.

      • TransformerConfigurationException

        public TransformerConfigurationException(String msg,
                                         Throwable e)
        Create a new TransformerConfigurationException with the given Exception base cause and detail message.
        Parameters:
        e - The exception to be encapsulated in a TransformerConfigurationException
        msg - The detail message.

      • TransformerConfigurationException

        public TransformerConfigurationException(String message,
                                         SourceLocator locator)
        Create a new TransformerConfigurationException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a DocumentHandler callback.

        Parameters:
        message - The error or warning message.
        locator - The locator object for the error or warning.

      • TransformerConfigurationException

        public TransformerConfigurationException(String message,
                                         SourceLocator locator,
                                         Throwable e)
        Wrap an existing exception in a TransformerConfigurationException.
        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning.
        e - Any exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformerException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Class TransformerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.transform.TransformerException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    TransformerConfigurationException

    public class TransformerException
extends Exception
    This class specifies an exceptional condition that occured during the transformation process.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransformerException(String message)
      Create a new TransformerException.
      TransformerException(String message, SourceLocator locator)
      Create a new TransformerException from a message and a Locator.
      TransformerException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerException.
      TransformerException(String message, Throwable e)
      Wrap an existing exception in a TransformerException.
      TransformerException(Throwable e)
      Create a new TransformerException wrapping an existing exception.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.
      Throwable getException()
      This method retrieves an exception that this exception wraps.
      String getLocationAsString()
      Get the location information as a string.
      SourceLocator getLocator()
      Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
      String getMessageAndLocation()
      Get the error message with location information appended.
      Throwable initCause(Throwable cause)
      Initializes the cause of this throwable to the specified value.
      void printStackTrace()
      Print the the trace of methods from where the error originated.
      void printStackTrace(PrintStream s)
      Print the the trace of methods from where the error originated.
      void printStackTrace(PrintWriter s)
      Print the the trace of methods from where the error originated.
      void setLocator(SourceLocator location)
      Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransformerException

        public TransformerException(String message)
        Create a new TransformerException.
        Parameters:
        message - The error or warning message.

      • TransformerException

        public TransformerException(Throwable e)
        Create a new TransformerException wrapping an existing exception.
        Parameters:
        e - The exception to be wrapped.

      • TransformerException

        public TransformerException(String message,
                            Throwable e)
        Wrap an existing exception in a TransformerException.

        This is used for throwing processor exceptions before the processing has started.

        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        e - Any exception

      • TransformerException

        public TransformerException(String message,
                            SourceLocator locator)
        Create a new TransformerException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a DocumentHandler callback.

        Parameters:
        message - The error or warning message.
        locator - The locator object for the error or warning.

      • TransformerException

        public TransformerException(String message,
                            SourceLocator locator,
                            Throwable e)
        Wrap an existing exception in a TransformerException.
        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning.
        e - Any exception

    • Method Detail

      • getLocator

        public SourceLocator getLocator()
        Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
        Returns:
        A SourceLocator object, or null if none was specified.

      • setLocator

        public void setLocator(SourceLocator location)
        Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.
        Parameters:
        location - A SourceLocator object, or null to clear the location.

      • getException

        public Throwable getException()
        This method retrieves an exception that this exception wraps.
        Returns:
        An Throwable object, or null.
        See Also:
        getCause()

      • getCause

        public Throwable getCause()
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this throwable or null if the cause is nonexistent or unknown.

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

        This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with TransformerException(Throwable) or TransformerException(String,Throwable), this method cannot be called even once.

        Overrides:
        initCause in class Throwable
        Parameters:
        cause - the cause (which is saved for later retrieval by the getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        Returns:
        a reference to this Throwable instance.
        Throws:
        IllegalArgumentException - if cause is this throwable. (A throwable cannot be its own cause.)
        IllegalStateException - if this throwable was created with TransformerException(Throwable) or TransformerException(String,Throwable), or this method has already been called on this throwable.

      • getMessageAndLocation

        public String getMessageAndLocation()
        Get the error message with location information appended.
        Returns:
        A String representing the error message with location information appended.

      • getLocationAsString

        public String getLocationAsString()
        Get the location information as a string.
        Returns:
        A string with location info, or null if there is no location information.

      • printStackTrace

        public void printStackTrace()
        Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.
        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - The stream where the dump will be sent to.

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.
        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - The writer where the dump will be sent to.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformerFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Class TransformerFactory

  • java.lang.Object
    • javax.xml.transform.TransformerFactory
  • Direct Known Subclasses:
    SAXTransformerFactory

    public abstract class TransformerFactory
extends Object

    A TransformerFactory instance can be used to create Transformer and Templates objects.

    The system property that determines which Factory implementation to create is named "javax.xml.transform.TransformerFactory". This property names a concrete subclass of the TransformerFactory abstract class. If the property is not defined, a platform default is be used.

    Since:
    1.5

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected TransformerFactory()
      Default constructor is protected on purpose.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Source getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      abstract Object getAttribute(String name)
      Allows the user to retrieve specific attributes on the underlying implementation.
      abstract ErrorListener getErrorListener()
      Get the error event handler for the TransformerFactory.
      abstract boolean getFeature(String name)
      Look up the value of a feature.
      abstract URIResolver getURIResolver()
      Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
      static TransformerFactory newInstance()
      Obtain a new instance of a TransformerFactory.
      static TransformerFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a TransformerFactory from factory class name.
      abstract Templates newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.
      abstract Transformer newTransformer()
      Create a new Transformer that performs a copy of the Source to the Result.
      abstract Transformer newTransformer(Source source)
      Process the Source into a Transformer Object.
      abstract void setAttribute(String name, Object value)
      Allows the user to set specific attributes on the underlying implementation.
      abstract void setErrorListener(ErrorListener listener)
      Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.
      abstract void setFeature(String name, boolean value)
      Set a feature for this TransformerFactory and Transformers or Templates created by this factory.
      abstract void setURIResolver(URIResolver resolver)
      Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TransformerFactory

        protected TransformerFactory()
        Default constructor is protected on purpose.

    • Method Detail

      • newInstance

        public static TransformerFactory newInstance()
                                      throws TransformerFactoryConfigurationError

        Obtain a new instance of a TransformerFactory. This static method creates a new factory instance.

        This method uses the following ordered lookup procedure to determine the TransformerFactory implementation class to load:

        • Use the javax.xml.transform.TransformerFactory system property.
        • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
          The jaxp.properties file is read only once by the JAXP implementation and it's values are then cached for future use. If the file does not exist when the first attempt is made to read from it, no further attempts are made to check for its existence. It is not possible to change the value of any property in jaxp.properties after it has been read for the first time.
        • Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
        • Otherwise, the system-default implementation is returned.

        Once an application has obtained a reference to a TransformerFactory it can use the factory to configure and obtain transformer instances.

        Returns:
        new TransformerFactory instance, never null.
        Throws:
        TransformerFactoryConfigurationError - Thrown in case of service configuration error or if the implementation is not available or cannot be instantiated.

      • newInstance

        public static TransformerFactory newInstance(String factoryClassName,
                                             ClassLoader classLoader)
                                      throws TransformerFactoryConfigurationError

        Obtain a new instance of a TransformerFactory from factory class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a TransformerFactory it can use the factory to configure and obtain transformer instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        Parameters:
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.transform.TransformerFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        Returns:
        new TransformerFactory instance, never null.
        Throws:
        TransformerFactoryConfigurationError - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        Since:
        1.6
        See Also:
        newInstance()

      • newTransformer

        public abstract Transformer newTransformer(Source source)
                                    throws TransformerConfigurationException

        Process the Source into a Transformer Object. The Source is an XSLT document that conforms to XSL Transformations (XSLT) Version 1.0. Care must be taken not to use this Transformer in multiple Threads running concurrently. Different TransformerFactories can be used concurrently by different Threads.

        Parameters:
        source - Source of XSLT document used to create Transformer. Examples of XML Sources include DOMSource, SAXSource, and StreamSource.
        Returns:
        A Transformer object that may be used to perform a transformation in a single Thread, never null.
        Throws:
        TransformerConfigurationException - Thrown if there are errors when parsing the Source or it is not possible to create a Transformer instance.
        See Also:
        XSL Transformations (XSLT) Version 1.0

      • newTransformer

        public abstract Transformer newTransformer()
                                    throws TransformerConfigurationException

        Create a new Transformer that performs a copy of the Source to the Result. i.e. the "identity transform".

        Returns:
        A Transformer object that may be used to perform a transformation in a single thread, never null.
        Throws:
        TransformerConfigurationException - When it is not possible to create a Transformer instance.

      • newTemplates

        public abstract Templates newTemplates(Source source)
                                throws TransformerConfigurationException
        Process the Source into a Templates object, which is a a compiled representation of the source. This Templates object may then be used concurrently across multiple threads. Creating a Templates object allows the TransformerFactory to do detailed performance optimization of transformation instructions, without penalizing runtime transformation.
        Parameters:
        source - An object that holds a URL, input stream, etc.
        Returns:
        A Templates object capable of being used for transformation purposes, never null.
        Throws:
        TransformerConfigurationException - When parsing to construct the Templates object fails.

      • getAssociatedStylesheet

        public abstract Source getAssociatedStylesheet(Source source,
                                               String media,
                                               String title,
                                               String charset)
                                        throws TransformerConfigurationException

        Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria. Note that it is possible to return several stylesheets, in which case they are applied as if they were a list of imports or cascades in a single stylesheet.

        Parameters:
        source - The XML source document.
        media - The media attribute to be matched. May be null, in which case the prefered templates will be used (i.e. alternate = no).
        title - The value of the title attribute to match. May be null.
        charset - The value of the charset attribute to match. May be null.
        Returns:
        A Source Object suitable for passing to the TransformerFactory.
        Throws:
        TransformerConfigurationException - An Exception is thrown if an error occurings during parsing of the source.
        See Also:
        Associating Style Sheets with XML documents Version 1.0

      • setURIResolver

        public abstract void setURIResolver(URIResolver resolver)
        Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
        Parameters:
        resolver - An object that implements the URIResolver interface, or null.

      • getURIResolver

        public abstract URIResolver getURIResolver()
        Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
        Returns:
        The URIResolver that was set with setURIResolver.

      • setFeature

        public abstract void setFeature(String name,
                                boolean value)
                         throws TransformerConfigurationException

        Set a feature for this TransformerFactory and Transformers or Templates created by this factory.

        Feature names are fully qualified URIs. Implementations may define their own features. An TransformerConfigurationException is thrown if this TransformerFactory or the Transformers or Templates it creates cannot support the feature. It is possible for an TransformerFactory to expose a feature value but be unable to change its state.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits and behave in a secure fashion as defined by the implementation. Examples include resolving user defined style sheets and functions. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorListener.fatalError(TransformerException exception). See setErrorListener(ErrorListener listener).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        Parameters:
        name - Feature name.
        value - Is feature state true or false.
        Throws:
        TransformerConfigurationException - if this TransformerFactory or the Transformers or Templates it creates cannot support this feature.
        NullPointerException - If the name parameter is null.

      • getFeature

        public abstract boolean getFeature(String name)
        Look up the value of a feature.

        Feature names are fully qualified URIs. Implementations may define their own features. false is returned if this TransformerFactory or the Transformers or Templates it creates cannot support the feature. It is possible for an TransformerFactory to expose a feature value but be unable to change its state.

        Parameters:
        name - Feature name.
        Returns:
        The current state of the feature, true or false.
        Throws:
        NullPointerException - If the name parameter is null.

      • setAttribute

        public abstract void setAttribute(String name,
                                  Object value)
        Allows the user to set specific attributes on the underlying implementation. An attribute in this context is defined to be an option that the implementation provides. An IllegalArgumentException is thrown if the underlying implementation doesn't recognize the attribute.

        All implementations that implement JAXP 1.5 or newer are required to support the XMLConstants.ACCESS_EXTERNAL_DTD and XMLConstants.ACCESS_EXTERNAL_STYLESHEET properties.

        • Access to external DTDs in the source file is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_DTD property. If access is denied during transformation due to the restriction of this property, TransformerException will be thrown by Transformer.transform(Source, Result).

          Access to external DTDs in the stylesheet is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_DTD property. If access is denied during the creation of a new transformer due to the restriction of this property, TransformerConfigurationException will be thrown by the newTransformer(Source) method.

          Access to external reference set by the stylesheet processing instruction, Import and Include element is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_STYLESHEET property. If access is denied during the creation of a new transformer due to the restriction of this property, TransformerConfigurationException will be thrown by the newTransformer(Source) method.

          Access to external document through XSLT document function is restricted to the protocols specified by the property. If access is denied during the transformation due to the restriction of this property, TransformerException will be thrown by the Transformer.transform(Source, Result) method.

        Parameters:
        name - The name of the attribute.
        value - The value of the attribute.
        Throws:
        IllegalArgumentException - When implementation does not recognize the attribute.

      • getAttribute

        public abstract Object getAttribute(String name)
        Allows the user to retrieve specific attributes on the underlying implementation. An IllegalArgumentException is thrown if the underlying implementation doesn't recognize the attribute.
        Parameters:
        name - The name of the attribute.
        Returns:
        value The value of the attribute.
        Throws:
        IllegalArgumentException - When implementation does not recognize the attribute.

      • setErrorListener

        public abstract void setErrorListener(ErrorListener listener)
        Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself. An IllegalArgumentException is thrown if the ErrorListener listener is null.
        Parameters:
        listener - The new error listener.
        Throws:
        IllegalArgumentException - When listener is null

      • getErrorListener

        public abstract ErrorListener getErrorListener()
        Get the error event handler for the TransformerFactory.
        Returns:
        The current error handler, which should never be null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformerFactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Class TransformerFactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.transform.TransformerFactoryConfigurationError
  • All Implemented Interfaces:
    Serializable

    public class TransformerFactoryConfigurationError
extends Error
    Thrown when a problem with configuration with the Transformer Factories exists. This error will typically be thrown when the class of a transformation factory specified in the system properties cannot be found or instantiated.
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      TransformerFactoryConfigurationError()
      Create a new TransformerFactoryConfigurationError with no detail mesage.
      TransformerFactoryConfigurationError(Exception e)
      Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.
      TransformerFactoryConfigurationError(Exception e, String msg)
      Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.
      TransformerFactoryConfigurationError(String msg)
      Create a new TransformerFactoryConfigurationError with the String specified as an error message.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      use the exception chaining mechanism of JDK1.4
      Exception getException()
      Return the actual exception (if any) that caused this exception to be raised.
      String getMessage()
      Return the message (if any) for this error .

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError()
        Create a new TransformerFactoryConfigurationError with no detail mesage.

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError(String msg)
        Create a new TransformerFactoryConfigurationError with the String specified as an error message.
        Parameters:
        msg - The error message for the exception.

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError(Exception e)
        Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.
        Parameters:
        e - The exception to be encapsulated in a TransformerFactoryConfigurationError.

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError(Exception e,
                                            String msg)
        Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.
        Parameters:
        e - The exception to be encapsulated in a TransformerFactoryConfigurationError
        msg - The detail message.

    • Method Detail

      • getMessage

        public String getMessage()
        Return the message (if any) for this error . If there is no message for the exception and there is an encapsulated exception then the message of that exception will be returned.
        Overrides:
        getMessage in class Throwable
        Returns:
        The error message.

      • getException

        public Exception getException()
        Return the actual exception (if any) that caused this exception to be raised.
        Returns:
        The encapsulated exception, or null if there is none.

      • getCause

        public Throwable getCause()
        use the exception chaining mechanism of JDK1.4
        Overrides:
        getCause in class Throwable
        Returns:
        the cause of this throwable or null if the cause is nonexistent or unknown.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


URIResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform

Interface URIResolver

  • public interface URIResolver

    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Source resolve(String href, String base)
      Called by the processor when it encounters an xsl:include, xsl:import, or document() function.

    • Method Detail

      • resolve

        Source resolve(String href,
               String base)
        throws TransformerException
        Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
        Parameters:
        href - An href attribute, which may be relative or absolute.
        base - The base URI against which the first argument will be made absolute if the absolute URI is required.
        Returns:
        A Source object, or null if the href cannot be resolved, and the processor should try to resolve the URI itself.
        Throws:
        TransformerException - if an error occurs when trying to resolve the URI.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.ErrorListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.ErrorListener

  • Packages that use ErrorListener
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of ErrorListener in javax.xml.transform

      Methods in javax.xml.transform that return ErrorListener
      Modifier and Type Method and Description
      abstract ErrorListener TransformerFactory.getErrorListener()
      Get the error event handler for the TransformerFactory.
      abstract ErrorListener Transformer.getErrorListener()
      Get the error event handler in effect for the transformation.
      Methods in javax.xml.transform with parameters of type ErrorListener
      Modifier and Type Method and Description
      abstract void TransformerFactory.setErrorListener(ErrorListener listener)
      Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.
      abstract void Transformer.setErrorListener(ErrorListener listener)
      Set the error event listener in effect for the transformation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.OutputKeys (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.OutputKeys

No usage of javax.xml.transform.OutputKeys
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.Result (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.Result

  • Packages that use Result
    Package Description
    java.sql
    Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
    javax.xml.transform.stream
    This package implements stream- and URI- specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of Result in java.sql

      Methods in java.sql with type parameters of type Result
      Modifier and Type Method and Description
      <T extends Result>
      T             		SQLXML.setResult(Class<T> resultClass)
      Returns a Result for setting the XML value designated by this SQLXML instance.

    • Uses of Result in javax.xml.bind

      Methods in javax.xml.bind that return Result
      Modifier and Type Method and Description
      abstract Result SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName)
      Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.
      Methods in javax.xml.bind with parameters of type Result
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      static void JAXB.marshal(Object jaxbObject, Result xml)
      Writes a Java object tree to XML and store it to the specified location.

    • Uses of Result in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation with type parameters of type Result
      Modifier and Type Interface and Description
      interface  DomHandler<ElementT,ResultT extends Result>
      Converts an element (and its descendants) from/to DOM (or similar) representation.

    • Uses of Result in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement Result
      Modifier and Type Class and Description
      class  JAXBResult
      JAXP Result implementation that unmarshals a JAXB object.

    • Uses of Result in javax.xml.soap

      Classes in javax.xml.soap that implement Result
      Modifier and Type Class and Description
      class  SAAJResult
      Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.

    • Uses of Result in javax.xml.stream

      Methods in javax.xml.stream with parameters of type Result
      Modifier and Type Method and Description
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.

    • Uses of Result in javax.xml.transform

      Methods in javax.xml.transform with parameters of type Result
      Modifier and Type Method and Description
      abstract void Transformer.transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.

    • Uses of Result in javax.xml.transform.dom

      Classes in javax.xml.transform.dom that implement Result
      Modifier and Type Class and Description
      class  DOMResult
      Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.

    • Uses of Result in javax.xml.transform.sax

      Classes in javax.xml.transform.sax that implement Result
      Modifier and Type Class and Description
      class  SAXResult
      Acts as an holder for a transformation Result.
      Methods in javax.xml.transform.sax with parameters of type Result
      Modifier and Type Method and Description
      void TransformerHandler.setResult(Result result)
      Set the Result associated with this TransformerHandler to be used for the transformation.

    • Uses of Result in javax.xml.transform.stax

      Classes in javax.xml.transform.stax that implement Result
      Modifier and Type Class and Description
      class  StAXResult
      Acts as a holder for an XML Result in the form of a StAX writer,i.e.

    • Uses of Result in javax.xml.transform.stream

      Classes in javax.xml.transform.stream that implement Result
      Modifier and Type Class and Description
      class  StreamResult
      Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.

    • Uses of Result in javax.xml.validation

      Methods in javax.xml.validation with parameters of type Result
      Modifier and Type Method and Description
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of Result in javax.xml.ws

      Methods in javax.xml.ws with parameters of type Result
      Modifier and Type Method and Description
      abstract void EndpointReference.writeTo(Result result)
      write this EndpointReference to the specified infoset format

    • Uses of Result in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type Result
      Modifier and Type Method and Description
      void W3CEndpointReference.writeTo(Result result)
      write this EndpointReference to the specified infoset format
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.Source (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.Source

  • Packages that use Source
    Package Description
    java.sql
    Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
    javax.xml.transform.stream
    This package implements stream- and URI- specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of Source in java.sql

      Methods in java.sql with type parameters of type Source
      Modifier and Type Method and Description
      <T extends Source>
      T             		SQLXML.getSource(Class<T> sourceClass)
      Returns a Source for reading the XML value designated by this SQLXML instance.

    • Uses of Source in javax.xml.bind

      Methods in javax.xml.bind with parameters of type Source
      Modifier and Type Method and Description
      Object Unmarshaller.unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      static <T> T JAXB.unmarshal(Source xml, Class<T> type)
      Reads in a Java object tree from the given XML input.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, Class<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

    • Uses of Source in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return Source
      Modifier and Type | Method and Description
      Source DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of Source in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type Source
      Modifier and Type | Method and Description
      Object | AbstractUnmarshallerImpl.unmarshal(Source source)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)

    • Uses of Source in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement Source
      Modifier and Type Class and Description
      class  JAXBSource
      JAXP Source implementation that marshals a JAXB-generated object.

    • Uses of Source in javax.xml.soap

      Methods in javax.xml.soap that return Source
      Modifier and Type Method and Description
      abstract Source SOAPPart.getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      Methods in javax.xml.soap with parameters of type Source
      Modifier and Type Method and Description
      abstract void SOAPPart.setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.

    • Uses of Source in javax.xml.stream

      Methods in javax.xml.stream with parameters of type Source
      Modifier and Type Method and Description
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.

    • Uses of Source in javax.xml.transform

      Methods in javax.xml.transform that return Source
      Modifier and Type Method and Description
      abstract Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      Source URIResolver.resolve(String href, String base)
      Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
      Methods in javax.xml.transform with parameters of type Source
      Modifier and Type Method and Description
      abstract Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      abstract Templates TransformerFactory.newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.
      abstract Transformer TransformerFactory.newTransformer(Source source)
      Process the Source into a Transformer Object.
      abstract void Transformer.transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.

    • Uses of Source in javax.xml.transform.dom

      Classes in javax.xml.transform.dom that implement Source
      Modifier and Type Class and Description
      class  DOMSource
      Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

    • Uses of Source in javax.xml.transform.sax

      Classes in javax.xml.transform.sax that implement Source
      Modifier and Type Class and Description
      class  SAXSource
      Acts as an holder for SAX-style Source.
      Methods in javax.xml.transform.sax with parameters of type Source
      Modifier and Type Method and Description
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      static InputSource SAXSource.sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.

    • Uses of Source in javax.xml.transform.stax

      Classes in javax.xml.transform.stax that implement Source
      Modifier and Type Class and Description
      class  StAXSource
      Acts as a holder for an XML Source in the form of a StAX reader,i.e.

    • Uses of Source in javax.xml.transform.stream

      Classes in javax.xml.transform.stream that implement Source
      Modifier and Type Class and Description
      class  StreamSource
      Acts as an holder for a transformation Source in the form of a stream of XML markup.

    • Uses of Source in javax.xml.validation

      Methods in javax.xml.validation with parameters of type Source
      Modifier and Type Method and Description
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      void Validator.validate(Source source)
      Validates the specified input.
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of Source in javax.xml.ws

      Methods in javax.xml.ws that return Source
      Modifier and Type Method and Description
      Source LogicalMessage.getPayload()
      Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
      Methods in javax.xml.ws that return types with arguments of type Source
      Modifier and Type Method and Description
      abstract List<Source> Endpoint.getMetadata()
      Returns a list of metadata documents for the service.
      Methods in javax.xml.ws with parameters of type Source
      Modifier and Type Method and Description
      static EndpointReference EndpointReference.readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      void LogicalMessage.setPayload(Source payload)
      Sets the message payload
      Method parameters in javax.xml.ws with type arguments of type Source
      Modifier and Type Method and Description
      abstract void Endpoint.setMetadata(List<Source> metadata)
      Sets the metadata for this endpoint.

    • Uses of Source in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Source
      Modifier and Type Method and Description
      abstract EndpointReference Provider.readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.

    • Uses of Source in javax.xml.ws.wsaddressing

      Constructors in javax.xml.ws.wsaddressing with parameters of type Source
      Constructor and Description
      W3CEndpointReference(Source source)
      Creates an EPR from infoset representation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.SourceLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.SourceLocator

  • Packages that use SourceLocator
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.

    • Uses of SourceLocator in javax.xml.transform

      Methods in javax.xml.transform that return SourceLocator
      Modifier and Type Method and Description
      SourceLocator TransformerException.getLocator()
      Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
      Methods in javax.xml.transform with parameters of type SourceLocator
      Modifier and Type Method and Description
      void TransformerException.setLocator(SourceLocator location)
      Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.
      Constructors in javax.xml.transform with parameters of type SourceLocator
      Constructor and Description
      TransformerConfigurationException(String message, SourceLocator locator)
      Create a new TransformerConfigurationException from a message and a Locator.
      TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerConfigurationException.
      TransformerException(String message, SourceLocator locator)
      Create a new TransformerException from a message and a Locator.
      TransformerException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerException.

    • Uses of SourceLocator in javax.xml.transform.dom

      Subinterfaces of SourceLocator in javax.xml.transform.dom
      Modifier and Type Interface and Description
      interface  DOMLocator
      Indicates the position of a node in a source DOM, intended primarily for error reporting.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.Templates (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.Templates

  • Packages that use Templates
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of Templates in javax.xml.transform

      Methods in javax.xml.transform that return Templates
      Modifier and Type Method and Description
      abstract Templates TransformerFactory.newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.

    • Uses of Templates in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return Templates
      Modifier and Type Method and Description
      Templates TemplatesHandler.getTemplates()
      When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
      Methods in javax.xml.transform.sax with parameters of type Templates
      Modifier and Type Method and Description
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.Transformer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.Transformer

  • Packages that use Transformer
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of Transformer in javax.xml.transform

      Methods in javax.xml.transform that return Transformer
      Modifier and Type Method and Description
      abstract Transformer TransformerFactory.newTransformer()
      Create a new Transformer that performs a copy of the Source to the Result.
      Transformer Templates.newTransformer()
      Create a new transformation context for this Templates object.
      abstract Transformer TransformerFactory.newTransformer(Source source)
      Process the Source into a Transformer Object.

    • Uses of Transformer in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return Transformer
      Modifier and Type Method and Description
      Transformer TransformerHandler.getTransformer()
      Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.TransformerConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.TransformerConfigurationException

  • Packages that use TransformerConfigurationException
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TransformerConfigurationException in javax.xml.transform

      Methods in javax.xml.transform that throw TransformerConfigurationException
      Modifier and Type Method and Description
      abstract Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      abstract Templates TransformerFactory.newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.
      abstract Transformer TransformerFactory.newTransformer()
      Create a new Transformer that performs a copy of the Source to the Result.
      Transformer Templates.newTransformer()
      Create a new transformation context for this Templates object.
      abstract Transformer TransformerFactory.newTransformer(Source source)
      Process the Source into a Transformer Object.
      abstract void TransformerFactory.setFeature(String name, boolean value)
      Set a feature for this TransformerFactory and Transformers or Templates created by this factory.

    • Uses of TransformerConfigurationException in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that throw TransformerConfigurationException
      Modifier and Type Method and Description
      abstract TemplatesHandler SAXTransformerFactory.newTemplatesHandler()
      Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler()
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.TransformerException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.TransformerException

  • Packages that use TransformerException
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of TransformerException in javax.xml.transform

      Subclasses of TransformerException in javax.xml.transform
      Modifier and Type Class and Description
      class  TransformerConfigurationException
      Indicates a serious configuration error.
      Methods in javax.xml.transform with parameters of type TransformerException
      Modifier and Type Method and Description
      void ErrorListener.error(TransformerException exception)
      Receive notification of a recoverable error.
      void ErrorListener.fatalError(TransformerException exception)
      Receive notification of a non-recoverable error.
      void ErrorListener.warning(TransformerException exception)
      Receive notification of a warning.
      Methods in javax.xml.transform that throw TransformerException
      Modifier and Type Method and Description
      void ErrorListener.error(TransformerException exception)
      Receive notification of a recoverable error.
      void ErrorListener.fatalError(TransformerException exception)
      Receive notification of a non-recoverable error.
      Source URIResolver.resolve(String href, String base)
      Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
      abstract void Transformer.transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.
      void ErrorListener.warning(TransformerException exception)
      Receive notification of a warning.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.TransformerFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.TransformerFactory

  • Packages that use TransformerFactory
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TransformerFactory in javax.xml.transform

      Methods in javax.xml.transform that return TransformerFactory
      Modifier and Type Method and Description
      static TransformerFactory TransformerFactory.newInstance()
      Obtain a new instance of a TransformerFactory.
      static TransformerFactory TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a TransformerFactory from factory class name.

    • Uses of TransformerFactory in javax.xml.transform.sax

      Subclasses of TransformerFactory in javax.xml.transform.sax
      Modifier and Type Class and Description
      class  SAXTransformerFactory
      This class extends TransformerFactory to provide SAX-specific factory methods.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.TransformerFactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.TransformerFactoryConfigurationError

  • Packages that use TransformerFactoryConfigurationError
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of TransformerFactoryConfigurationError in javax.xml.transform

      Methods in javax.xml.transform that throw TransformerFactoryConfigurationError
      Modifier and Type Method and Description
      static TransformerFactory TransformerFactory.newInstance()
      Obtain a new instance of a TransformerFactory.
      static TransformerFactory TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a TransformerFactory from factory class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.URIResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.URIResolver

  • Packages that use URIResolver
    Package Description
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of URIResolver in javax.xml.transform

      Methods in javax.xml.transform that return URIResolver
      Modifier and Type Method and Description
      abstract URIResolver TransformerFactory.getURIResolver()
      Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
      abstract URIResolver Transformer.getURIResolver()
      Get an object that will be used to resolve URIs used in document().
      Methods in javax.xml.transform with parameters of type URIResolver
      Modifier and Type Method and Description
      abstract void TransformerFactory.setURIResolver(URIResolver resolver)
      Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
      abstract void Transformer.setURIResolver(URIResolver resolver)
      Set an object that will be used to resolve URIs used in document().
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.transform.dom (Java Platform SE 8 )

compact2 - javax.xml.transform.dom

Interfaces

  • DOMLocator

Classes

  • DOMResult
  • DOMSource


javax.xml.transform.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.transform.dom

This package implements DOM-specific transformation APIs.

See: Description

  • Interface Summary
    Interface Description
    DOMLocator
    Indicates the position of a node in a source DOM, intended primarily for error reporting.
  • Class Summary
    Class Description
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
    DOMSource
    Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

Package javax.xml.transform.dom Description

This package implements DOM-specific transformation APIs.

The DOMSource class allows the client of the implementation of this API to specify a DOM Node as the source of the input tree. The model of how the Transformer deals with the DOM tree in terms of mismatches with the XSLT data model or other data models is beyond the scope of this document. Any of the nodes derived from Node are legal input.

The DOMResult class allows a Node to be specified to which result DOM nodes will be appended. If an output node is not specified, the transformer will use DocumentBuilder.newDocument() to create an output Document node. If a node is specified, it should be one of the following: Document, Element, or DocumentFragment. Specification of any other node type is implementation dependent and undefined by this API. If the result is a Document, the output of the transformation must have a single element root to set as the document element.

The DOMLocator node may be passed to TransformerException objects, and retrieved by trying to cast the result of the TransformerException.getLocator() method. The implementation has no responsibility to use a DOMLocator instead of a SourceLocator (though line numbers and the like do not make much sense for a DOM), so the result of getLocator must always be tested with an instanceof.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.transform.dom (Java Platform SE 8 )

compact3 - javax.xml.transform.dom

Interfaces

  • DOMLocator

Classes

  • DOMResult
  • DOMSource


javax.xml.transform.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.transform.dom

This package implements DOM-specific transformation APIs.

See: Description

  • Interface Summary
    Interface Description
    DOMLocator
    Indicates the position of a node in a source DOM, intended primarily for error reporting.
  • Class Summary
    Class Description
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
    DOMSource
    Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

Package javax.xml.transform.dom Description

This package implements DOM-specific transformation APIs.

The DOMSource class allows the client of the implementation of this API to specify a DOM Node as the source of the input tree. The model of how the Transformer deals with the DOM tree in terms of mismatches with the XSLT data model or other data models is beyond the scope of this document. Any of the nodes derived from Node are legal input.

The DOMResult class allows a Node to be specified to which result DOM nodes will be appended. If an output node is not specified, the transformer will use DocumentBuilder.newDocument() to create an output Document node. If a node is specified, it should be one of the following: Document, Element, or DocumentFragment. Specification of any other node type is implementation dependent and undefined by this API. If the result is a Document, the output of the transformation must have a single element root to set as the document element.

The DOMLocator node may be passed to TransformerException objects, and retrieved by trying to cast the result of the TransformerException.getLocator() method. The implementation has no responsibility to use a DOMLocator instead of a SourceLocator (though line numbers and the like do not make much sense for a DOM), so the result of getLocator must always be tested with an instanceof.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.dom

Interface DOMLocator

  • All Superinterfaces:
    SourceLocator

    public interface DOMLocator
extends SourceLocator
    Indicates the position of a node in a source DOM, intended primarily for error reporting. To use a DOMLocator, the receiver of an error must downcast the SourceLocator object returned by an exception. A Transformer may use this object for purposes other than error reporting, for instance, to indicate the source node that originated a result node.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Node getOriginatingNode()
      Return the node where the event occurred.

      • Methods inherited from interface javax.xml.transform.SourceLocator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • Method Detail

      • getOriginatingNode

        Node getOriginatingNode()
        Return the node where the event occurred.
        Returns:
        The node that is the location for the event.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.dom

Class DOMResult

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult
  • All Implemented Interfaces:
    Result
    Direct Known Subclasses:
    SAAJResult

    public class DOMResult
extends Object
implements Result

    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.

    If no output DOM source is set, the transformation will create a Document node as the holder for the result of the transformation, which may be retrieved with getNode().

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMResult()
      Zero-argument default constructor.
      DOMResult(Node node)
      Use a DOM node to create a new output target.
      DOMResult(Node node, Node nextSibling)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
      DOMResult(Node node, Node nextSibling, String systemId)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
      DOMResult(Node node, String systemId)
      Use a DOM node to create a new output target with the specified System ID.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Node getNextSibling()
      Get the child node before which the result nodes will be inserted.
      Node getNode()
      Get the node that will contain the result DOM tree.
      String getSystemId()
      Get the System Identifier.
      void setNextSibling(Node nextSibling)
      Set the child node before which the result nodes will be inserted.
      void setNode(Node node)
      Set the node that will contain the result DOM tree.
      void setSystemId(String systemId)
      Set the systemId that may be used in association with the node.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE

        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

        See Also:
        Constant Field Values

    • Constructor Detail

      • DOMResult

        public DOMResult()

        Zero-argument default constructor.

        node, siblingNode and systemId will be set to null.

      • DOMResult

        public DOMResult(Node node)

        Use a DOM node to create a new output target.

        In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        siblingNode and systemId will be set to null.

        Parameters:
        node - The DOM node that will contain the result tree.

      • DOMResult

        public DOMResult(Node node,
                 String systemId)

        Use a DOM node to create a new output target with the specified System ID.

        In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        siblingNode will be set to null.

        Parameters:
        node - The DOM node that will contain the result tree.
        systemId - The system identifier which may be used in association with this node.

      • DOMResult

        public DOMResult(Node node,
                 Node nextSibling)

        Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.

        In practice, node and nextSibling should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        Use nextSibling to specify the child node where the result nodes should be inserted before. If nextSibling is not a sibling of node, then an IllegalArgumentException is thrown. If node is null and nextSibling is not null, then an IllegalArgumentException is thrown. If nextSibling is null, then the behavior is the same as calling DOMResult(Node node), i.e. append the result nodes as the last child of the specified node.

        systemId will be set to null.

        Parameters:
        node - The DOM node that will contain the result tree.
        nextSibling - The child node where the result nodes should be inserted before.
        Throws:
        IllegalArgumentException - If nextSibling is not a sibling of node or node is null and nextSibling is not null.
        Since:
        1.5

      • DOMResult

        public DOMResult(Node node,
                 Node nextSibling,
                 String systemId)

        Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.

        In practice, node and nextSibling should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        Use nextSibling to specify the child node where the result nodes should be inserted before. If nextSibling is not a sibling of node, then an IllegalArgumentException is thrown. If node is null and nextSibling is not null, then an IllegalArgumentException is thrown. If nextSibling is null, then the behavior is the same as calling DOMResult(Node node, String systemId), i.e. append the result nodes as the last child of the specified node and use the specified System ID.

        Parameters:
        node - The DOM node that will contain the result tree.
        nextSibling - The child node where the result nodes should be inserted before.
        systemId - The system identifier which may be used in association with this node.
        Throws:
        IllegalArgumentException - If nextSibling is not a sibling of node or node is null and nextSibling is not null.
        Since:
        1.5

    • Method Detail

      • setNode

        public void setNode(Node node)

        Set the node that will contain the result DOM tree.

        In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        An IllegalStateException is thrown if nextSibling is not null and node is not a parent of nextSibling. An IllegalStateException is thrown if node is null and nextSibling is not null.

        Parameters:
        node - The node to which the transformation will be appended.
        Throws:
        IllegalStateException - If nextSibling is not null and nextSibling is not a child of node or node is null and nextSibling is not null.

      • getNode

        public Node getNode()

        Get the node that will contain the result DOM tree.

        If no node was set via DOMResult(Node node), DOMResult(Node node, String systeId), DOMResult(Node node, Node nextSibling), DOMResult(Node node, Node nextSibling, String systemId) or setNode(Node node), then the node will be set by the transformation, and may be obtained from this method once the transformation is complete. Calling this method before the transformation will return null.

        Returns:
        The node to which the transformation will be appended.

      • setNextSibling

        public void setNextSibling(Node nextSibling)

        Set the child node before which the result nodes will be inserted.

        Use nextSibling to specify the child node before which the result nodes should be inserted. If nextSibling is not a descendant of node, then an IllegalArgumentException is thrown. If node is null and nextSibling is not null, then an IllegalStateException is thrown. If nextSibling is null, then the behavior is the same as calling DOMResult(Node node), i.e. append the result nodes as the last child of the specified node.

        Parameters:
        nextSibling - The child node before which the result nodes will be inserted.
        Throws:
        IllegalArgumentException - If nextSibling is not a descendant of node.
        IllegalStateException - If node is null and nextSibling is not null.
        Since:
        1.5

      • getNextSibling

        public Node getNextSibling()

        Get the child node before which the result nodes will be inserted.

        If no node was set via DOMResult(Node node, Node nextSibling), DOMResult(Node node, Node nextSibling, String systemId) or setNextSibling(Node nextSibling), then null will be returned.

        Returns:
        The child node before which the result nodes will be inserted.
        Since:
        1.5

      • setSystemId

        public void setSystemId(String systemId)

        Set the systemId that may be used in association with the node.

        Specified by:
        setSystemId in interface Result
        Parameters:
        systemId - The system identifier as a URI string.

      • getSystemId

        public String getSystemId()

        Get the System Identifier.

        If no System ID was set via DOMResult(Node node, String systemId), DOMResult(Node node, Node nextSibling, String systemId) or setSystemId(String systemId), then null will be returned.

        Specified by:
        getSystemId in interface Result
        Returns:
        The system identifier.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.dom

Class DOMSource

  • java.lang.Object
    • javax.xml.transform.dom.DOMSource
  • All Implemented Interfaces:
    Source

    public class DOMSource
extends Object
implements Source

    Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

    Note that XSLT requires namespace support. Attempting to transform a DOM that was not contructed with a namespace-aware parser may result in errors. Parsers can be made namespace aware by calling DocumentBuilderFactory.setNamespaceAware(boolean awareness).

    See Also:
    Document Object Model (DOM) Level 2 Specification

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMSource()
      Zero-argument default constructor.
      DOMSource(Node n)
      Create a new input source with a DOM node.
      DOMSource(Node node, String systemID)
      Create a new input source with a DOM node, and with the system ID also passed in as the base URI.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Node getNode()
      Get the node that represents a Source DOM tree.
      String getSystemId()
      Get the base ID (URL or system ID) from where URLs will be resolved.
      void setNode(Node node)
      Set the node that will represents a Source DOM tree.
      void setSystemId(String systemID)
      Set the base ID (URL or system ID) from where URLs will be resolved.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • DOMSource

        public DOMSource()

        Zero-argument default constructor. If this constructor is used, and no DOM source is set using setNode(Node node) , then the Transformer will create an empty source Document using DocumentBuilder.newDocument().

        See Also:
        Transformer.transform(Source xmlSource, Result outputTarget)

      • DOMSource

        public DOMSource(Node n)
        Create a new input source with a DOM node. The operation will be applied to the subtree rooted at this node. In XSLT, a "/" pattern still means the root of the tree (not the subtree), and the evaluation of global variables and parameters is done from the root node also.
        Parameters:
        n - The DOM node that will contain the Source tree.

      • DOMSource

        public DOMSource(Node node,
                 String systemID)
        Create a new input source with a DOM node, and with the system ID also passed in as the base URI.
        Parameters:
        node - The DOM node that will contain the Source tree.
        systemID - Specifies the base URI associated with node.

    • Method Detail

      • setNode

        public void setNode(Node node)
        Set the node that will represents a Source DOM tree.
        Parameters:
        node - The node that is to be transformed.

      • getNode

        public Node getNode()
        Get the node that represents a Source DOM tree.
        Returns:
        The node that is to be transformed.

      • setSystemId

        public void setSystemId(String systemID)
        Set the base ID (URL or system ID) from where URLs will be resolved.
        Specified by:
        setSystemId in interface Source
        Parameters:
        systemID - Base URL for this DOM tree.

      • getSystemId

        public String getSystemId()
        Get the base ID (URL or system ID) from where URLs will be resolved.
        Specified by:
        getSystemId in interface Source
        Returns:
        Base URL for this DOM tree.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.dom (Java Platform SE 8 )

javax.xml.transform.dom

Interfaces

  • DOMLocator

Classes

  • DOMResult
  • DOMSource


javax.xml.transform.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.transform.dom

This package implements DOM-specific transformation APIs.

See: Description

  • Interface Summary
    Interface Description
    DOMLocator
    Indicates the position of a node in a source DOM, intended primarily for error reporting.
  • Class Summary
    Class Description
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
    DOMSource
    Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

Package javax.xml.transform.dom Description

This package implements DOM-specific transformation APIs.

The DOMSource class allows the client of the implementation of this API to specify a DOM Node as the source of the input tree. The model of how the Transformer deals with the DOM tree in terms of mismatches with the XSLT data model or other data models is beyond the scope of this document. Any of the nodes derived from Node are legal input.

The DOMResult class allows a Node to be specified to which result DOM nodes will be appended. If an output node is not specified, the transformer will use DocumentBuilder.newDocument() to create an output Document node. If a node is specified, it should be one of the following: Document, Element, or DocumentFragment. Specification of any other node type is implementation dependent and undefined by this API. If the result is a Document, the output of the transformation must have a single element root to set as the document element.

The DOMLocator node may be passed to TransformerException objects, and retrieved by trying to cast the result of the TransformerException.getLocator() method. The implementation has no responsibility to use a DOMLocator instead of a SourceLocator (though line numbers and the like do not make much sense for a DOM), so the result of getLocator must always be tested with an instanceof.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.dom Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.transform.dom

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
    • javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)

Interface Hierarchy

  • javax.xml.transform.SourceLocator
    • javax.xml.transform.dom.DOMLocator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.transform.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.transform.dom

  • Packages that use javax.xml.transform.dom
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
  • Classes in javax.xml.transform.dom used by javax.xml.bind.annotation
    Class and Description
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
  • Classes in javax.xml.transform.dom used by javax.xml.soap
    Class and Description
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.dom.DOMLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.dom.DOMLocator

No usage of javax.xml.transform.dom.DOMLocator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.dom.DOMResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.dom.DOMResult

  • Packages that use DOMResult
    Package Description
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of DOMResult in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return DOMResult
      Modifier and Type | Method and Description
      DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      Methods in javax.xml.bind.annotation with parameters of type DOMResult
      Modifier and Type | Method and Description
      Element | W3CDomHandler.getElement(DOMResult r)

    • Uses of DOMResult in javax.xml.soap

      Subclasses of DOMResult in javax.xml.soap
      Modifier and Type Class and Description
      class  SAAJResult
      Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.dom.DOMSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.dom.DOMSource

No usage of javax.xml.transform.dom.DOMSource
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.transform.sax (Java Platform SE 8 )

compact2 - javax.xml.transform.sax

Interfaces

  • TemplatesHandler
  • TransformerHandler

Classes

  • SAXResult
  • SAXSource
  • SAXTransformerFactory


javax.xml.transform.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.transform.sax

This package implements SAX2-specific transformation APIs.

See: Description

  • Interface Summary
    Interface Description
    TemplatesHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
    TransformerHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
  • Class Summary
    Class Description
    SAXResult
    Acts as an holder for a transformation Result.
    SAXSource
    Acts as an holder for SAX-style Source.
    SAXTransformerFactory
    This class extends TransformerFactory to provide SAX-specific factory methods.

Package javax.xml.transform.sax Description

This package implements SAX2-specific transformation APIs. It provides classes which allow input from ContentHandler events, and also classes that produce org.xml.sax.ContentHandler events. It also provides methods to set the input source as an XMLReader, or to use a InputSource as the source. It also allows the creation of a XMLFilter, which enables transformations to "pull" from other transformations, and lets the transformer to be used polymorphically as an XMLReader.

The SAXSource class allows the setting of an XMLReader to be used for "pulling" parse events, and an InputSource that may be used to specify the SAX source.

The SAXResult class allows the setting of a ContentHandler to be the receiver of SAX2 events from the transformation.

The SAXTransformerFactory extends TransformerFactory to provide factory methods for creating TemplatesHandler, TransformerHandler, and XMLReader instances.

To obtain a SAXTransformerFactory, the caller must cast the TransformerFactory instance returned from TransformerFactory.newInstance().

The TransformerHandler interface allows a transformation to be created from SAX2 parse events, which is a "push" model rather than the "pull" model that normally occurs for a transformation. Normal parse events are received through the ContentHandler interface, lexical events such as startCDATA and endCDATA are received through the LexicalHandler interface, and events that signal the start or end of disabling output escaping are received via ContentHandler.processingInstruction(java.lang.String, java.lang.String), with the target parameter being Result.PI_DISABLE_OUTPUT_ESCAPING and Result.PI_ENABLE_OUTPUT_ESCAPING. If parameters, output properties, or other features need to be set on the Transformer handler, a Transformer reference will need to be obtained from TransformerHandler.getTransformer(), and the methods invoked from that reference.

The TemplatesHandler interface allows the creation of Templates objects from SAX2 parse events. Once the ContentHandler events are complete, the Templates object may be obtained from TemplatesHandler.getTemplates(). Note that TemplatesHandler.setSystemId(java.lang.String) should normally be called in order to establish a base system ID from which relative URLs may be resolved.

The SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source) method allows the creation of a XMLFilter, which encapsulates the SAX2 notion of a "pull" transformation. The following illustrates several transformations chained together. Each filter points to a parent XMLReader, and the final transformation is caused by invoking XMLReader.parse(org.xml.sax.InputSource) on the final reader in the chain.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.transform.sax (Java Platform SE 8 )

compact3 - javax.xml.transform.sax

Interfaces

  • TemplatesHandler
  • TransformerHandler

Classes

  • SAXResult
  • SAXSource
  • SAXTransformerFactory


javax.xml.transform.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.transform.sax

This package implements SAX2-specific transformation APIs.

See: Description

  • Interface Summary
    Interface Description
    TemplatesHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
    TransformerHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
  • Class Summary
    Class Description
    SAXResult
    Acts as an holder for a transformation Result.
    SAXSource
    Acts as an holder for SAX-style Source.
    SAXTransformerFactory
    This class extends TransformerFactory to provide SAX-specific factory methods.

Package javax.xml.transform.sax Description

This package implements SAX2-specific transformation APIs. It provides classes which allow input from ContentHandler events, and also classes that produce org.xml.sax.ContentHandler events. It also provides methods to set the input source as an XMLReader, or to use a InputSource as the source. It also allows the creation of a XMLFilter, which enables transformations to "pull" from other transformations, and lets the transformer to be used polymorphically as an XMLReader.

The SAXSource class allows the setting of an XMLReader to be used for "pulling" parse events, and an InputSource that may be used to specify the SAX source.

The SAXResult class allows the setting of a ContentHandler to be the receiver of SAX2 events from the transformation.

The SAXTransformerFactory extends TransformerFactory to provide factory methods for creating TemplatesHandler, TransformerHandler, and XMLReader instances.

To obtain a SAXTransformerFactory, the caller must cast the TransformerFactory instance returned from TransformerFactory.newInstance().

The TransformerHandler interface allows a transformation to be created from SAX2 parse events, which is a "push" model rather than the "pull" model that normally occurs for a transformation. Normal parse events are received through the ContentHandler interface, lexical events such as startCDATA and endCDATA are received through the LexicalHandler interface, and events that signal the start or end of disabling output escaping are received via ContentHandler.processingInstruction(java.lang.String, java.lang.String), with the target parameter being Result.PI_DISABLE_OUTPUT_ESCAPING and Result.PI_ENABLE_OUTPUT_ESCAPING. If parameters, output properties, or other features need to be set on the Transformer handler, a Transformer reference will need to be obtained from TransformerHandler.getTransformer(), and the methods invoked from that reference.

The TemplatesHandler interface allows the creation of Templates objects from SAX2 parse events. Once the ContentHandler events are complete, the Templates object may be obtained from TemplatesHandler.getTemplates(). Note that TemplatesHandler.setSystemId(java.lang.String) should normally be called in order to establish a base system ID from which relative URLs may be resolved.

The SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source) method allows the creation of a XMLFilter, which encapsulates the SAX2 notion of a "pull" transformation. The following illustrates several transformations chained together. Each filter points to a parent XMLReader, and the final transformation is caused by invoking XMLReader.parse(org.xml.sax.InputSource) on the final reader in the chain.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.sax (Java Platform SE 8 )

javax.xml.transform.sax

Interfaces

  • TemplatesHandler
  • TransformerHandler

Classes

  • SAXResult
  • SAXSource
  • SAXTransformerFactory


javax.xml.transform.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.transform.sax

This package implements SAX2-specific transformation APIs.

See: Description

  • Interface Summary
    Interface Description
    TemplatesHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
    TransformerHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
  • Class Summary
    Class Description
    SAXResult
    Acts as an holder for a transformation Result.
    SAXSource
    Acts as an holder for SAX-style Source.
    SAXTransformerFactory
    This class extends TransformerFactory to provide SAX-specific factory methods.

Package javax.xml.transform.sax Description

This package implements SAX2-specific transformation APIs. It provides classes which allow input from ContentHandler events, and also classes that produce org.xml.sax.ContentHandler events. It also provides methods to set the input source as an XMLReader, or to use a InputSource as the source. It also allows the creation of a XMLFilter, which enables transformations to "pull" from other transformations, and lets the transformer to be used polymorphically as an XMLReader.

The SAXSource class allows the setting of an XMLReader to be used for "pulling" parse events, and an InputSource that may be used to specify the SAX source.

The SAXResult class allows the setting of a ContentHandler to be the receiver of SAX2 events from the transformation.

The SAXTransformerFactory extends TransformerFactory to provide factory methods for creating TemplatesHandler, TransformerHandler, and XMLReader instances.

To obtain a SAXTransformerFactory, the caller must cast the TransformerFactory instance returned from TransformerFactory.newInstance().

The TransformerHandler interface allows a transformation to be created from SAX2 parse events, which is a "push" model rather than the "pull" model that normally occurs for a transformation. Normal parse events are received through the ContentHandler interface, lexical events such as startCDATA and endCDATA are received through the LexicalHandler interface, and events that signal the start or end of disabling output escaping are received via ContentHandler.processingInstruction(java.lang.String, java.lang.String), with the target parameter being Result.PI_DISABLE_OUTPUT_ESCAPING and Result.PI_ENABLE_OUTPUT_ESCAPING. If parameters, output properties, or other features need to be set on the Transformer handler, a Transformer reference will need to be obtained from TransformerHandler.getTransformer(), and the methods invoked from that reference.

The TemplatesHandler interface allows the creation of Templates objects from SAX2 parse events. Once the ContentHandler events are complete, the Templates object may be obtained from TemplatesHandler.getTemplates(). Note that TemplatesHandler.setSystemId(java.lang.String) should normally be called in order to establish a base system ID from which relative URLs may be resolved.

The SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source) method allows the creation of a XMLFilter, which encapsulates the SAX2 notion of a "pull" transformation. The following illustrates several transformations chained together. Each filter points to a parent XMLReader, and the final transformation is caused by invoking XMLReader.parse(org.xml.sax.InputSource) on the final reader in the chain.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.sax Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.transform.sax

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory

Interface Hierarchy

  • org.xml.sax.ContentHandler
    • javax.xml.transform.sax.TemplatesHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
  • org.xml.sax.DTDHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • org.xml.sax.ext.LexicalHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.transform.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.transform.sax

  • Packages that use javax.xml.transform.sax
    Package Description
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
  • Classes in javax.xml.transform.sax used by javax.xml.bind.util
    Class and Description
    SAXResult
    Acts as an holder for a transformation Result.
    SAXSource
    Acts as an holder for SAX-style Source.
  • Classes in javax.xml.transform.sax used by javax.xml.transform.sax
    Class and Description
    TemplatesHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
    TransformerHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.sax

Class SAXResult

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult
  • All Implemented Interfaces:
    Result
    Direct Known Subclasses:
    JAXBResult

    public class SAXResult
extends Object
implements Result

    Acts as an holder for a transformation Result.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXResult()
      Zero-argument default constructor.
      SAXResult(ContentHandler handler)
      Create a SAXResult that targets a SAX2 ContentHandler.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      ContentHandler getHandler()
      Get the ContentHandler that is the Result.
      LexicalHandler getLexicalHandler()
      Get a SAX2 LexicalHandler for the output.
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setHandler(ContentHandler handler)
      Set the target to be a SAX2 ContentHandler.
      void setLexicalHandler(LexicalHandler handler)
      Set the SAX2 LexicalHandler for the output.
      void setSystemId(String systemId)
      Method setSystemId Set the systemID that may be used in association with the ContentHandler.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • SAXResult

        public SAXResult()
        Zero-argument default constructor.

      • SAXResult

        public SAXResult(ContentHandler handler)
        Create a SAXResult that targets a SAX2 ContentHandler.
        Parameters:
        handler - Must be a non-null ContentHandler reference.

    • Method Detail

      • setHandler

        public void setHandler(ContentHandler handler)
        Set the target to be a SAX2 ContentHandler.
        Parameters:
        handler - Must be a non-null ContentHandler reference.

      • getHandler

        public ContentHandler getHandler()
        Get the ContentHandler that is the Result.
        Returns:
        The ContentHandler that is to be transformation output.

      • setLexicalHandler

        public void setLexicalHandler(LexicalHandler handler)
        Set the SAX2 LexicalHandler for the output.

        This is needed to handle XML comments and the like. If the lexical handler is not set, an attempt should be made by the transformer to cast the ContentHandler to a LexicalHandler.

        Parameters:
        handler - A non-null LexicalHandler for handling lexical parse events.

      • getLexicalHandler

        public LexicalHandler getLexicalHandler()
        Get a SAX2 LexicalHandler for the output.
        Returns:
        A LexicalHandler, or null.

      • setSystemId

        public void setSystemId(String systemId)
        Method setSystemId Set the systemID that may be used in association with the ContentHandler.
        Specified by:
        setSystemId in interface Result
        Parameters:
        systemId - The system identifier as a URI string.

      • getSystemId

        public String getSystemId()
        Get the system identifier that was set with setSystemId.
        Specified by:
        getSystemId in interface Result
        Returns:
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.sax

Class SAXSource

  • java.lang.Object
    • javax.xml.transform.sax.SAXSource
  • All Implemented Interfaces:
    Source
    Direct Known Subclasses:
    JAXBSource

    public class SAXSource
extends Object
implements Source

    Acts as an holder for SAX-style Source.

    Note that XSLT requires namespace support. Attempting to transform an input source that is not generated with a namespace-aware parser may result in errors. Parsers can be made namespace aware by calling the SAXParserFactory.setNamespaceAware(boolean awareness) method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXSource()
      Zero-argument default constructor.
      SAXSource(InputSource inputSource)
      Create a SAXSource, using a SAX InputSource.
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      InputSource getInputSource()
      Get the SAX InputSource to be used for the Source.
      String getSystemId()
      Get the base ID (URI or system ID) from where URIs will be resolved.
      XMLReader getXMLReader()
      Get the XMLReader to be used for the Source.
      void setInputSource(InputSource inputSource)
      Set the SAX InputSource to be used for the Source.
      void setSystemId(String systemId)
      Set the system identifier for this Source.
      void setXMLReader(XMLReader reader)
      Set the XMLReader to be used for the Source.
      static InputSource sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • SAXSource

        public SAXSource()

        Zero-argument default constructor. If this constructor is used, and no SAX source is set using setInputSource(InputSource inputSource) , then the Transformer will create an empty source InputSource using new InputSource().

        See Also:
        Transformer.transform(Source xmlSource, Result outputTarget)

      • SAXSource

        public SAXSource(XMLReader reader,
                 InputSource inputSource)
        Create a SAXSource, using an XMLReader and a SAX InputSource. The Transformer or SAXTransformerFactory will set itself to be the reader's ContentHandler, and then will call reader.parse(inputSource).
        Parameters:
        reader - An XMLReader to be used for the parse.
        inputSource - A SAX input source reference that must be non-null and that will be passed to the reader parse method.

      • SAXSource

        public SAXSource(InputSource inputSource)
        Create a SAXSource, using a SAX InputSource. The Transformer or SAXTransformerFactory creates a reader via XMLReaderFactory (if setXMLReader is not used), sets itself as the reader's ContentHandler, and calls reader.parse(inputSource).
        Parameters:
        inputSource - An input source reference that must be non-null and that will be passed to the parse method of the reader.

    • Method Detail

      • setXMLReader

        public void setXMLReader(XMLReader reader)
        Set the XMLReader to be used for the Source.
        Parameters:
        reader - A valid XMLReader or XMLFilter reference.

      • getXMLReader

        public XMLReader getXMLReader()
        Get the XMLReader to be used for the Source.
        Returns:
        A valid XMLReader or XMLFilter reference, or null.

      • setInputSource

        public void setInputSource(InputSource inputSource)
        Set the SAX InputSource to be used for the Source.
        Parameters:
        inputSource - A valid InputSource reference.

      • getInputSource

        public InputSource getInputSource()
        Get the SAX InputSource to be used for the Source.
        Returns:
        A valid InputSource reference, or null.

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this Source. If an input source has already been set, it will set the system ID or that input source, otherwise it will create a new input source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if no byte stream or character stream is specified).

        Specified by:
        setSystemId in interface Source
        Parameters:
        systemId - The system identifier as a URI string.

      • getSystemId

        public String getSystemId()

        Get the base ID (URI or system ID) from where URIs will be resolved.

        Specified by:
        getSystemId in interface Source
        Returns:
        Base URL for the Source, or null.

      • sourceToInputSource

        public static InputSource sourceToInputSource(Source source)
        Attempt to obtain a SAX InputSource object from a Source object.
        Parameters:
        source - Must be a non-null Source reference.
        Returns:
        An InputSource, or null if Source can not be converted.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXTransformerFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.sax

Class SAXTransformerFactory

  • java.lang.Object
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory

  • public abstract class SAXTransformerFactory
extends TransformerFactory
    This class extends TransformerFactory to provide SAX-specific factory methods. It provides two types of ContentHandlers, one for creating Transformers, the other for creating Templates objects.

    If an application wants to set the ErrorHandler or EntityResolver for an XMLReader used during a transformation, it should use a URIResolver to return the SAXSource which provides (with getXMLReader) a reference to the XMLReader.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
      static String FEATURE_XMLFILTER
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the newXMLFilter(Source src) and newXMLFilter(Templates templates) methods are supported.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SAXTransformerFactory()
      The default constructor is protected on purpose.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract TemplatesHandler newTemplatesHandler()
      Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
      abstract TransformerHandler newTransformerHandler()
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
      abstract TransformerHandler newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract TransformerHandler newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
      abstract XMLFilter newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..

      • Methods inherited from class javax.xml.transform.TransformerFactory

        getAssociatedStylesheet, getAttribute, getErrorListener, getFeature, getURIResolver, newInstance, newInstance, newTemplates, newTransformer, newTransformer, setAttribute, setErrorListener, setFeature, setURIResolver

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
        See Also:
        Constant Field Values

      • FEATURE_XMLFILTER

        public static final String FEATURE_XMLFILTER
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the newXMLFilter(Source src) and newXMLFilter(Templates templates) methods are supported.
        See Also:
        Constant Field Values

    • Constructor Detail

      • SAXTransformerFactory

        protected SAXTransformerFactory()
        The default constructor is protected on purpose.

    • Method Detail

      • newTransformerHandler

        public abstract TransformerHandler newTransformerHandler(Source src)
                                                  throws TransformerConfigurationException
        Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
        Parameters:
        src - The Source of the transformation instructions.
        Returns:
        TransformerHandler ready to transform SAX events.
        Throws:
        TransformerConfigurationException - If for some reason the TransformerHandler can not be created.

      • newTransformerHandler

        public abstract TransformerHandler newTransformerHandler(Templates templates)
                                                  throws TransformerConfigurationException
        Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
        Parameters:
        templates - The compiled transformation instructions.
        Returns:
        TransformerHandler ready to transform SAX events.
        Throws:
        TransformerConfigurationException - If for some reason the TransformerHandler can not be created.

      • newTransformerHandler

        public abstract TransformerHandler newTransformerHandler()
                                                  throws TransformerConfigurationException
        Get a TransformerHandler object that can process SAX ContentHandler events into a Result. The transformation is defined as an identity (or copy) transformation, for example to copy a series of SAX parse events into a DOM tree.
        Returns:
        A non-null reference to a TransformerHandler, that may be used as a ContentHandler for SAX parse events.
        Throws:
        TransformerConfigurationException - If for some reason the TransformerHandler cannot be created.

      • newTemplatesHandler

        public abstract TemplatesHandler newTemplatesHandler()
                                              throws TransformerConfigurationException
        Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
        Returns:
        A non-null reference to a TransformerHandler, that may be used as a ContentHandler for SAX parse events.
        Throws:
        TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.

      • newXMLFilter

        public abstract XMLFilter newXMLFilter(Source src)
                                throws TransformerConfigurationException
        Create an XMLFilter that uses the given Source as the transformation instructions.
        Parameters:
        src - The Source of the transformation instructions.
        Returns:
        An XMLFilter object, or null if this feature is not supported.
        Throws:
        TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.

      • newXMLFilter

        public abstract XMLFilter newXMLFilter(Templates templates)
                                throws TransformerConfigurationException
        Create an XMLFilter, based on the Templates argument..
        Parameters:
        templates - The compiled transformation instructions.
        Returns:
        An XMLFilter object, or null if this feature is not supported.
        Throws:
        TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TemplatesHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.sax

Interface TemplatesHandler

  • All Superinterfaces:
    ContentHandler

    public interface TemplatesHandler
extends ContentHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.

    Note that TemplatesHandler does not need to implement LexicalHandler.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getSystemId()
      Get the base ID (URI or system ID) from where relative URLs will be resolved.
      Templates getTemplates()
      When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
      void setSystemId(String systemID)
      Set the base ID (URI or system ID) for the Templates object created by this builder.

      • Methods inherited from interface org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • Method Detail

      • getTemplates

        Templates getTemplates()
        When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
        Returns:
        The Templates object that was created during the SAX event process, or null if no Templates object has been created.

      • setSystemId

        void setSystemId(String systemID)
        Set the base ID (URI or system ID) for the Templates object created by this builder. This must be set in order to resolve relative URIs in the stylesheet. This must be called before the startDocument event.
        Parameters:
        systemID - Base URI for this stylesheet.

      • getSystemId

        String getSystemId()
        Get the base ID (URI or system ID) from where relative URLs will be resolved.
        Returns:
        The systemID that was set with setSystemId(java.lang.String).
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransformerHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.sax

Interface TransformerHandler

  • All Superinterfaces:
    ContentHandler, DTDHandler, LexicalHandler

    public interface TransformerHandler
extends ContentHandler, LexicalHandler, DTDHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getSystemId()
      Get the base ID (URI or system ID) from where relative URLs will be resolved.
      Transformer getTransformer()
      Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.
      void setResult(Result result)
      Set the Result associated with this TransformerHandler to be used for the transformation.
      void setSystemId(String systemID)
      Set the base ID (URI or system ID) from where relative URLs will be resolved.

      • Methods inherited from interface org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

      • Methods inherited from interface org.xml.sax.ext.LexicalHandler

        comment, endCDATA, endDTD, endEntity, startCDATA, startDTD, startEntity

      • Methods inherited from interface org.xml.sax.DTDHandler

        notationDecl, unparsedEntityDecl

    • Method Detail

      • setResult

        void setResult(Result result)
        throws IllegalArgumentException

        Set the Result associated with this TransformerHandler to be used for the transformation.

        Parameters:
        result - A Result instance, should not be null.
        Throws:
        IllegalArgumentException - if result is invalid for some reason.

      • setSystemId

        void setSystemId(String systemID)
        Set the base ID (URI or system ID) from where relative URLs will be resolved.
        Parameters:
        systemID - Base URI for the source tree.

      • getSystemId

        String getSystemId()
        Get the base ID (URI or system ID) from where relative URLs will be resolved.
        Returns:
        The systemID that was set with setSystemId(java.lang.String).

      • getTransformer

        Transformer getTransformer()

        Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.

        Returns:
        Transformer associated with this TransformerHandler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.sax.SAXResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.sax.SAXResult

  • Packages that use SAXResult
    Package Description
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of SAXResult in javax.xml.bind.util

      Subclasses of SAXResult in javax.xml.bind.util
      Modifier and Type Class and Description
      class  JAXBResult
      JAXP Result implementation that unmarshals a JAXB object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.sax.SAXSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.sax.SAXSource

  • Packages that use SAXSource
    Package Description
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of SAXSource in javax.xml.bind.util

      Subclasses of SAXSource in javax.xml.bind.util
      Modifier and Type Class and Description
      class  JAXBSource
      JAXP Source implementation that marshals a JAXB-generated object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.sax.SAXTransformerFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.sax.SAXTransformerFactory

No usage of javax.xml.transform.sax.SAXTransformerFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.sax.TemplatesHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.sax.TemplatesHandler

  • Packages that use TemplatesHandler
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TemplatesHandler in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return TemplatesHandler
      Modifier and Type Method and Description
      abstract TemplatesHandler SAXTransformerFactory.newTemplatesHandler()
      Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.transform.sax.TransformerHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.transform.sax.TransformerHandler

  • Packages that use TransformerHandler
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TransformerHandler in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return TransformerHandler
      Modifier and Type Method and Description
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler()
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.transform.stax (Java Platform SE 8 )

compact2 - javax.xml.transform.stax

Classes

  • StAXResult
  • StAXSource


javax.xml.transform.stax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.transform.stax

Provides for StAX-specific transformation APIs.

See: Description

  • Class Summary
    Class Description
    StAXResult
    Acts as a holder for an XML Result in the form of a StAX writer,i.e.
    StAXSource
    Acts as a holder for an XML Source in the form of a StAX reader,i.e.

Package javax.xml.transform.stax Description

Provides for StAX-specific transformation APIs. TODO: better description(s).

Package Specification

  • JSR 173: Streaming API for XML

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:

  • TODO: Refer to non-spec documentation
  • @see XMLStreamReader
  • @see XMLEventReader

Since:
1.6

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.transform.stax (Java Platform SE 8 )

compact3 - javax.xml.transform.stax

Classes

  • StAXResult
  • StAXSource


javax.xml.transform.stax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.transform.stax

Provides for StAX-specific transformation APIs.

See: Description

  • Class Summary
    Class Description
    StAXResult
    Acts as a holder for an XML Result in the form of a StAX writer,i.e.
    StAXSource
    Acts as a holder for an XML Source in the form of a StAX reader,i.e.

Package javax.xml.transform.stax Description

Provides for StAX-specific transformation APIs. TODO: better description(s).

Package Specification

  • JSR 173: Streaming API for XML

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:

  • TODO: Refer to non-spec documentation
  • @see XMLStreamReader
  • @see XMLEventReader

Since:
1.6

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.stax (Java Platform SE 8 )

javax.xml.transform.stax

Classes

  • StAXResult
  • StAXSource


javax.xml.transform.stax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.transform.stax

Provides for StAX-specific transformation APIs.

See: Description

  • Class Summary
    Class Description
    StAXResult
    Acts as a holder for an XML Result in the form of a StAX writer,i.e.
    StAXSource
    Acts as a holder for an XML Source in the form of a StAX reader,i.e.

Package javax.xml.transform.stax Description

Provides for StAX-specific transformation APIs. TODO: better description(s).

Package Specification

  • JSR 173: Streaming API for XML

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:

  • TODO: Refer to non-spec documentation
  • @see XMLStreamReader
  • @see XMLEventReader

Since:
1.6

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.stax Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.transform.stax

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.stax.StAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stax.StAXSource (implements javax.xml.transform.Source)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.transform.stax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.transform.stax

No usage of javax.xml.transform.stax
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StAXResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.stax

Class StAXResult

  • java.lang.Object
    • javax.xml.transform.stax.StAXResult
  • All Implemented Interfaces:
    Result

    public class StAXResult
extends Object
implements Result

    Acts as a holder for an XML Result in the form of a StAX writer,i.e. XMLStreamWriter or XMLEventWriter. StAXResult can be used in all cases that accept a Result, e.g. Transformer, Validator which accept Result as input.

    Since:
    1.6
    See Also:
    JSR 173: Streaming API for XML, XMLStreamWriter, XMLEventWriter

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      StAXResult(XMLEventWriter xmlEventWriter)
      Creates a new instance of a StAXResult by supplying an XMLEventWriter.
      StAXResult(XMLStreamWriter xmlStreamWriter)
      Creates a new instance of a StAXResult by supplying an XMLStreamWriter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getSystemId()
      The returned system identifier is always null.
      XMLEventWriter getXMLEventWriter()
      Get the XMLEventWriter used by this StAXResult.
      XMLStreamWriter getXMLStreamWriter()
      Get the XMLStreamWriter used by this StAXResult.
      void setSystemId(String systemId)
      In the context of a StAXResult, it is not appropriate to explicitly set the system identifier.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Result output of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • StAXResult

        public StAXResult(XMLEventWriter xmlEventWriter)

        Creates a new instance of a StAXResult by supplying an XMLEventWriter.

        XMLEventWriter must be a non-null reference.

        Parameters:
        xmlEventWriter - XMLEventWriter used to create this StAXResult.
        Throws:
        IllegalArgumentException - If xmlEventWriter == null.

      • StAXResult

        public StAXResult(XMLStreamWriter xmlStreamWriter)

        Creates a new instance of a StAXResult by supplying an XMLStreamWriter.

        XMLStreamWriter must be a non-null reference.

        Parameters:
        xmlStreamWriter - XMLStreamWriter used to create this StAXResult.
        Throws:
        IllegalArgumentException - If xmlStreamWriter == null.

    • Method Detail

      • getXMLEventWriter

        public XMLEventWriter getXMLEventWriter()

        Get the XMLEventWriter used by this StAXResult.

        XMLEventWriter will be null if this StAXResult was created with a XMLStreamWriter.

        Returns:
        XMLEventWriter used by this StAXResult.

      • getXMLStreamWriter

        public XMLStreamWriter getXMLStreamWriter()

        Get the XMLStreamWriter used by this StAXResult.

        XMLStreamWriter will be null if this StAXResult was created with a XMLEventWriter.

        Returns:
        XMLStreamWriter used by this StAXResult.

      • setSystemId

        public void setSystemId(String systemId)

        In the context of a StAXResult, it is not appropriate to explicitly set the system identifier. The XMLEventWriter or XMLStreamWriter used to construct this StAXResult determines the system identifier of the XML result.

        An UnsupportedOperationException is always thrown by this method.

        Specified by:
        setSystemId in interface Result
        Parameters:
        systemId - Ignored.
        Throws:
        UnsupportedOperationException - Is always thrown by this method.

      • getSystemId

        public String getSystemId()

        The returned system identifier is always null.

        Specified by:
        getSystemId in interface Result
        Returns:
        The returned system identifier is always null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StAXSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.stax

Class StAXSource

  • java.lang.Object
    • javax.xml.transform.stax.StAXSource
  • All Implemented Interfaces:
    Source

    public class StAXSource
extends Object
implements Source

    Acts as a holder for an XML Source in the form of a StAX reader,i.e. XMLStreamReader or XMLEventReader. StAXSource can be used in all cases that accept a Source, e.g. Transformer, Validator which accept Source as input.

    StAXSources are consumed during processing and are not reusable.

    Since:
    1.6
    See Also:
    JSR 173: Streaming API for XML, XMLStreamReader, XMLEventReader

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • Constructor Summary

      Constructors
      Constructor and Description
      StAXSource(XMLEventReader xmlEventReader)
      Creates a new instance of a StAXSource by supplying an XMLEventReader.
      StAXSource(XMLStreamReader xmlStreamReader)
      Creates a new instance of a StAXSource by supplying an XMLStreamReader.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getSystemId()
      Get the system identifier used by this StAXSource.
      XMLEventReader getXMLEventReader()
      Get the XMLEventReader used by this StAXSource.
      XMLStreamReader getXMLStreamReader()
      Get the XMLStreamReader used by this StAXSource.
      void setSystemId(String systemId)
      In the context of a StAXSource, it is not appropriate to explicitly set the system identifier.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • StAXSource

        public StAXSource(XMLEventReader xmlEventReader)
           throws XMLStreamException

        Creates a new instance of a StAXSource by supplying an XMLEventReader.

        XMLEventReader must be a non-null reference.

        XMLEventReader must be in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

        Parameters:
        xmlEventReader - XMLEventReader used to create this StAXSource.
        Throws:
        XMLStreamException - If xmlEventReader access throws an Exception.
        IllegalArgumentException - If xmlEventReader == null.
        IllegalStateException - If xmlEventReader is not in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

      • StAXSource

        public StAXSource(XMLStreamReader xmlStreamReader)

        Creates a new instance of a StAXSource by supplying an XMLStreamReader.

        XMLStreamReader must be a non-null reference.

        XMLStreamReader must be in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

        Parameters:
        xmlStreamReader - XMLStreamReader used to create this StAXSource.
        Throws:
        IllegalArgumentException - If xmlStreamReader == null.
        IllegalStateException - If xmlStreamReader is not in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

    • Method Detail

      • getXMLEventReader

        public XMLEventReader getXMLEventReader()

        Get the XMLEventReader used by this StAXSource.

        XMLEventReader will be null. if this StAXSource was created with a XMLStreamReader.

        Returns:
        XMLEventReader used by this StAXSource.

      • getXMLStreamReader

        public XMLStreamReader getXMLStreamReader()

        Get the XMLStreamReader used by this StAXSource.

        XMLStreamReader will be null if this StAXSource was created with a XMLEventReader.

        Returns:
        XMLStreamReader used by this StAXSource.

      • setSystemId

        public void setSystemId(String systemId)

        In the context of a StAXSource, it is not appropriate to explicitly set the system identifier. The XMLStreamReader or XMLEventReader used to construct this StAXSource determines the system identifier of the XML source.

        An UnsupportedOperationException is always thrown by this method.

        Specified by:
        setSystemId in interface Source
        Parameters:
        systemId - Ignored.
        Throws:
        UnsupportedOperationException - Is always thrown by this method.

      • getSystemId

        public String getSystemId()

        Get the system identifier used by this StAXSource.

        The XMLStreamReader or XMLEventReader used to construct this StAXSource is queried to determine the system identifier of the XML source.

        The system identifier may be null or an empty "" String.

        Specified by:
        getSystemId in interface Source
        Returns:
        System identifier used by this StAXSource.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.stax.StAXResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.stax.StAXResult

No usage of javax.xml.transform.stax.StAXResult
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.stax.StAXSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.stax.StAXSource

No usage of javax.xml.transform.stax.StAXSource
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.transform.stream (Java Platform SE 8 )

compact2 - javax.xml.transform.stream

Classes

  • StreamResult
  • StreamSource


javax.xml.transform.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.transform.stream

This package implements stream- and URI- specific transformation APIs.

See: Description

  • Class Summary
    Class Description
    StreamResult
    Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.
    StreamSource
    Acts as an holder for a transformation Source in the form of a stream of XML markup.

Package javax.xml.transform.stream Description

This package implements stream- and URI- specific transformation APIs.

The StreamSource class provides methods for specifying InputStream input, Reader input, and URL input in the form of strings. Even if an input stream or reader is specified as the source, StreamSource.setSystemId(java.lang.String) should still be called, so that the transformer can know from where it should resolve relative URIs. The public identifier is always optional: if the application writer includes one, it will be provided as part of the SourceLocator information.

The StreamResult class provides methods for specifying OutputStream, Writer, or an output system ID, as the output of the transformation result.

Normally streams should be used rather than readers or writers, for both the Source and Result, since readers and writers already have the encoding established to and from the internal Unicode format. However, there are times when it is useful to write to a character stream, such as when using a StringWriter in order to write to a String, or in the case of reading source XML from a StringReader.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.transform.stream (Java Platform SE 8 )

compact3 - javax.xml.transform.stream

Classes

  • StreamResult
  • StreamSource


javax.xml.transform.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.transform.stream

This package implements stream- and URI- specific transformation APIs.

See: Description

  • Class Summary
    Class Description
    StreamResult
    Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.
    StreamSource
    Acts as an holder for a transformation Source in the form of a stream of XML markup.

Package javax.xml.transform.stream Description

This package implements stream- and URI- specific transformation APIs.

The StreamSource class provides methods for specifying InputStream input, Reader input, and URL input in the form of strings. Even if an input stream or reader is specified as the source, StreamSource.setSystemId(java.lang.String) should still be called, so that the transformer can know from where it should resolve relative URIs. The public identifier is always optional: if the application writer includes one, it will be provided as part of the SourceLocator information.

The StreamResult class provides methods for specifying OutputStream, Writer, or an output system ID, as the output of the transformation result.

Normally streams should be used rather than readers or writers, for both the Source and Result, since readers and writers already have the encoding established to and from the internal Unicode format. However, there are times when it is useful to write to a character stream, such as when using a StringWriter in order to write to a String, or in the case of reading source XML from a StringReader.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.stream (Java Platform SE 8 )

javax.xml.transform.stream

Classes

  • StreamResult
  • StreamSource


javax.xml.transform.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.transform.stream

This package implements stream- and URI- specific transformation APIs.

See: Description

  • Class Summary
    Class Description
    StreamResult
    Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.
    StreamSource
    Acts as an holder for a transformation Source in the form of a stream of XML markup.

Package javax.xml.transform.stream Description

This package implements stream- and URI- specific transformation APIs.

The StreamSource class provides methods for specifying InputStream input, Reader input, and URL input in the form of strings. Even if an input stream or reader is specified as the source, StreamSource.setSystemId(java.lang.String) should still be called, so that the transformer can know from where it should resolve relative URIs. The public identifier is always optional: if the application writer includes one, it will be provided as part of the SourceLocator information.

The StreamResult class provides methods for specifying OutputStream, Writer, or an output system ID, as the output of the transformation result.

Normally streams should be used rather than readers or writers, for both the Source and Result, since readers and writers already have the encoding established to and from the internal Unicode format. However, there are times when it is useful to write to a character stream, such as when using a StringWriter in order to write to a String, or in the case of reading source XML from a StringReader.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.transform.stream Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.transform.stream

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.transform.stream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.transform.stream

No usage of javax.xml.transform.stream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StreamResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.stream

Class StreamResult

  • java.lang.Object
    • javax.xml.transform.stream.StreamResult
  • All Implemented Interfaces:
    Result

    public class StreamResult
extends Object
implements Result

    Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • Fields inherited from interface javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • Constructor Summary

      Constructors
      Constructor and Description
      StreamResult()
      Zero-argument default constructor.
      StreamResult(File f)
      Construct a StreamResult from a File.
      StreamResult(OutputStream outputStream)
      Construct a StreamResult from a byte stream.
      StreamResult(String systemId)
      Construct a StreamResult from a URL.
      StreamResult(Writer writer)
      Construct a StreamResult from a character stream.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      OutputStream getOutputStream()
      Get the byte stream that was set with setOutputStream.
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      Writer getWriter()
      Get the character stream that was set with setWriter.
      void setOutputStream(OutputStream outputStream)
      Set the ByteStream that is to be written to.
      void setSystemId(File f)
      Set the system ID from a File reference.
      void setSystemId(String systemId)
      Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).
      void setWriter(Writer writer)
      Set the writer that is to receive the result.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • StreamResult

        public StreamResult()
        Zero-argument default constructor.

      • StreamResult

        public StreamResult(OutputStream outputStream)
        Construct a StreamResult from a byte stream. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding.
        Parameters:
        outputStream - A valid OutputStream reference.

      • StreamResult

        public StreamResult(Writer writer)
        Construct a StreamResult from a character stream. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding. However, there are times when it is useful to write to a character stream, such as when using a StringWriter.
        Parameters:
        writer - A valid Writer reference.

      • StreamResult

        public StreamResult(String systemId)
        Construct a StreamResult from a URL.
        Parameters:
        systemId - Must be a String that conforms to the URI syntax.

      • StreamResult

        public StreamResult(File f)
        Construct a StreamResult from a File.
        Parameters:
        f - Must a non-null File reference.

    • Method Detail

      • setOutputStream

        public void setOutputStream(OutputStream outputStream)
        Set the ByteStream that is to be written to. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding.
        Parameters:
        outputStream - A valid OutputStream reference.

      • getOutputStream

        public OutputStream getOutputStream()
        Get the byte stream that was set with setOutputStream.
        Returns:
        The byte stream that was set with setOutputStream, or null if setOutputStream or the ByteStream constructor was not called.

      • setWriter

        public void setWriter(Writer writer)
        Set the writer that is to receive the result. Normally, a stream should be used rather than a writer, so that the transformer may use instructions contained in the transformation instructions to control the encoding. However, there are times when it is useful to write to a writer, such as when using a StringWriter.
        Parameters:
        writer - A valid Writer reference.

      • getWriter

        public Writer getWriter()
        Get the character stream that was set with setWriter.
        Returns:
        The character stream that was set with setWriter, or null if setWriter or the Writer constructor was not called.

      • setSystemId

        public void setSystemId(String systemId)
        Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).
        Specified by:
        setSystemId in interface Result
        Parameters:
        systemId - The system identifier as a URI string.

      • setSystemId

        public void setSystemId(File f)

        Set the system ID from a File reference.

        Parameters:
        f - Must a non-null File reference.

      • getSystemId

        public String getSystemId()
        Get the system identifier that was set with setSystemId.
        Specified by:
        getSystemId in interface Result
        Returns:
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StreamSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.transform.stream

Class StreamSource

  • java.lang.Object
    • javax.xml.transform.stream.StreamSource
  • All Implemented Interfaces:
    Source

    public class StreamSource
extends Object
implements Source

    Acts as an holder for a transformation Source in the form of a stream of XML markup.

    Note: Due to their internal use of either a Reader or InputStream instance, StreamSource instances may only be used once.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • Constructor Summary

      Constructors
      Constructor and Description
      StreamSource()
      Zero-argument default constructor.
      StreamSource(File f)
      Construct a StreamSource from a File.
      StreamSource(InputStream inputStream)
      Construct a StreamSource from a byte stream.
      StreamSource(InputStream inputStream, String systemId)
      Construct a StreamSource from a byte stream.
      StreamSource(Reader reader)
      Construct a StreamSource from a character reader.
      StreamSource(Reader reader, String systemId)
      Construct a StreamSource from a character reader.
      StreamSource(String systemId)
      Construct a StreamSource from a URL.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      InputStream getInputStream()
      Get the byte stream that was set with setByteStream.
      String getPublicId()
      Get the public identifier that was set with setPublicId.
      Reader getReader()
      Get the character stream that was set with setReader.
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setInputStream(InputStream inputStream)
      Set the byte stream to be used as input.
      void setPublicId(String publicId)
      Set the public identifier for this Source.
      void setReader(Reader reader)
      Set the input to be a character reader.
      void setSystemId(File f)
      Set the system ID from a File reference.
      void setSystemId(String systemId)
      Set the system identifier for this Source.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        See Also:
        Constant Field Values

    • Constructor Detail

      • StreamSource

        public StreamSource()

        Zero-argument default constructor. If this constructor is used, and no Stream source is set using setInputStream(java.io.InputStream inputStream) or setReader(java.io.Reader reader), then the Transformer will create an empty source InputStream using new InputStream().

        See Also:
        Transformer.transform(Source xmlSource, Result outputTarget)

      • StreamSource

        public StreamSource(InputStream inputStream)
        Construct a StreamSource from a byte stream. Normally, a stream should be used rather than a reader, so the XML parser can resolve character encoding specified by the XML declaration.

        If this constructor is used to process a stylesheet, normally setSystemId should also be called, so that relative URI references can be resolved.

        Parameters:
        inputStream - A valid InputStream reference to an XML stream.

      • StreamSource

        public StreamSource(InputStream inputStream,
                    String systemId)
        Construct a StreamSource from a byte stream. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration.

        This constructor allows the systemID to be set in addition to the input stream, which allows relative URIs to be processed.

        Parameters:
        inputStream - A valid InputStream reference to an XML stream.
        systemId - Must be a String that conforms to the URI syntax.

      • StreamSource

        public StreamSource(Reader reader)
        Construct a StreamSource from a character reader. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.
        Parameters:
        reader - A valid Reader reference to an XML character stream.

      • StreamSource

        public StreamSource(Reader reader,
                    String systemId)
        Construct a StreamSource from a character reader. Normally, a stream should be used rather than a reader, so that the XML parser may resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.
        Parameters:
        reader - A valid Reader reference to an XML character stream.
        systemId - Must be a String that conforms to the URI syntax.

      • StreamSource

        public StreamSource(String systemId)
        Construct a StreamSource from a URL.
        Parameters:
        systemId - Must be a String that conforms to the URI syntax.

      • StreamSource

        public StreamSource(File f)
        Construct a StreamSource from a File.
        Parameters:
        f - Must a non-null File reference.

    • Method Detail

      • setInputStream

        public void setInputStream(InputStream inputStream)
        Set the byte stream to be used as input. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration.

        If this Source object is used to process a stylesheet, normally setSystemId should also be called, so that relative URL references can be resolved.

        Parameters:
        inputStream - A valid InputStream reference to an XML stream.

      • getInputStream

        public InputStream getInputStream()
        Get the byte stream that was set with setByteStream.
        Returns:
        The byte stream that was set with setByteStream, or null if setByteStream or the ByteStream constructor was not called.

      • setReader

        public void setReader(Reader reader)
        Set the input to be a character reader. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.
        Parameters:
        reader - A valid Reader reference to an XML CharacterStream.

      • getReader

        public Reader getReader()
        Get the character stream that was set with setReader.
        Returns:
        The character stream that was set with setReader, or null if setReader or the Reader constructor was not called.

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this Source.

        The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

        Parameters:
        publicId - The public identifier as a string.

      • getPublicId

        public String getPublicId()
        Get the public identifier that was set with setPublicId.
        Returns:
        The public identifier that was set with setPublicId, or null if setPublicId was not called.

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this Source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

        Specified by:
        setSystemId in interface Source
        Parameters:
        systemId - The system identifier as a URL string.

      • getSystemId

        public String getSystemId()
        Get the system identifier that was set with setSystemId.
        Specified by:
        getSystemId in interface Source
        Returns:
        The system identifier that was set with setSystemId, or null if setSystemId was not called.

      • setSystemId

        public void setSystemId(File f)
        Set the system ID from a File reference.
        Parameters:
        f - Must a non-null File reference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.stream.StreamResult (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.stream.StreamResult

No usage of javax.xml.transform.stream.StreamResult
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.transform.stream.StreamSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.transform.stream.StreamSource

No usage of javax.xml.transform.stream.StreamSource
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.validation (Java Platform SE 8 )

compact2 - javax.xml.validation

Classes

  • Schema
  • SchemaFactory
  • SchemaFactoryLoader
  • TypeInfoProvider
  • Validator
  • ValidatorHandler

Errors

  • SchemaFactoryConfigurationError


javax.xml.validation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.validation

This package provides an API for validation of XML documents.

See: Description

  • Class Summary
    Class Description
    Schema
    Immutable in-memory representation of grammar.
    SchemaFactory
    Factory that creates Schema objects. Entry-point to the validation API.
    SchemaFactoryLoader
    Factory that creates SchemaFactory.
    TypeInfoProvider
    This class provides access to the type information determined by ValidatorHandler.
    Validator
    A processor that checks an XML document against Schema.
    ValidatorHandler
    Streaming validator that works on SAX stream.
  • Error Summary
    Error Description
    SchemaFactoryConfigurationError
    Thrown when a problem with configuration with the Schema Factories exists.

Package javax.xml.validation Description

This package provides an API for validation of XML documents. Validation is the process of verifying that an XML document is an instance of a specified XML schema. An XML schema defines the content model (also called a grammar or vocabulary) that its instance documents will represent.

There are a number of popular technologies available for creating an XML schema. Some of the most popular include:

  • Document Type Definition (DTD) - XML's built-in schema language.
  • W3C XML Schema (WXS) - an object-oriented XML schema language. WXS also provides a type system for constraining the character data of an XML document. WXS is maintained by the World Wide Web Consortium (W3C) and is a W3C Recommendation (that is, a ratified W3C standard specification).
  • RELAX NG (RNG) - a pattern-based, user-friendly XML schema language. RNG schemas may also use types to constrain XML character data. RNG is maintained by the Organization for the Advancement of Structured Information Standards (OASIS) and is both an OASIS and an ISO (International Organization for Standardization) standard.
  • Schematron - a rules-based XML schema language. Whereas DTD, WXS, and RNG are designed to express the structure of a content model, Schematron is designed to enforce individual rules that are difficult or impossible to express with other schema languages. Schematron is intended to supplement a schema written in structural schema language such as the aforementioned. Schematron is in the process of becoming an ISO standard.

Previous versions of JAXP supported validation as a feature of an XML parser, represented by either a SAXParser or DocumentBuilder instance.

The JAXP validation API decouples the validation of an instance document from the parsing of an XML document. This is advantageous for several reasons, some of which are:

  • Support for additional schema langauges. As of JDK 1.5, the two most popular JAXP parser implementations, Crimson and Xerces, only support a subset of the available XML schema languages. The Validation API provides a standard mechanism through which applications may take of advantage of specialization validation libraries which support additional schema languages.
  • Easy runtime coupling of an XML instance and schema. Specifying the location of a schema to use for validation with JAXP parsers can be confusing. The Validation API makes this process simple (see example below).

Usage example. The following example demonstrates validating an XML document with the Validation API (for readability, some exception handling is not shown):

    // parse an XML document into a DOM tree
    DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
    Document document = parser.parse(new File("instance.xml"));

    // create a SchemaFactory capable of understanding WXS schemas
    SchemaFactory factory = SchemaFactory.newInstance(XMLConstants.W3C_XML_SCHEMA_NS_URI);

    // load a WXS schema, represented by a Schema instance
    Source schemaFile = new StreamSource(new File("mySchema.xsd"));
    Schema schema = factory.newSchema(schemaFile);

    // create a Validator instance, which can be used to validate an instance document
    Validator validator = schema.newValidator();

    // validate the DOM tree
    try {
        validator.validate(new DOMSource(document));
    } catch (SAXException e) {
        // instance document is invalid!
    }

The JAXP parsing API has been integrated with the Validation API. Applications may create a Schema with the validation API and associate it with a DocumentBuilderFactory or a SAXParserFactory instance by using the DocumentBuilderFactory.setSchema(Schema) and SAXParserFactory.setSchema(Schema) methods. You should not both set a schema and call setValidating(true) on a parser factory. The former technique will cause parsers to use the new validation API; the latter will cause parsers to use their own internal validation facilities. Turning on both of these options simultaneously will cause either redundant behavior or error conditions.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.validation (Java Platform SE 8 )

compact3 - javax.xml.validation

Classes

  • Schema
  • SchemaFactory
  • SchemaFactoryLoader
  • TypeInfoProvider
  • Validator
  • ValidatorHandler

Errors

  • SchemaFactoryConfigurationError


javax.xml.validation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.validation

This package provides an API for validation of XML documents.

See: Description

  • Class Summary
    Class Description
    Schema
    Immutable in-memory representation of grammar.
    SchemaFactory
    Factory that creates Schema objects. Entry-point to the validation API.
    SchemaFactoryLoader
    Factory that creates SchemaFactory.
    TypeInfoProvider
    This class provides access to the type information determined by ValidatorHandler.
    Validator
    A processor that checks an XML document against Schema.
    ValidatorHandler
    Streaming validator that works on SAX stream.
  • Error Summary
    Error Description
    SchemaFactoryConfigurationError
    Thrown when a problem with configuration with the Schema Factories exists.

Package javax.xml.validation Description

This package provides an API for validation of XML documents. Validation is the process of verifying that an XML document is an instance of a specified XML schema. An XML schema defines the content model (also called a grammar or vocabulary) that its instance documents will represent.

There are a number of popular technologies available for creating an XML schema. Some of the most popular include:

  • Document Type Definition (DTD) - XML's built-in schema language.
  • W3C XML Schema (WXS) - an object-oriented XML schema language. WXS also provides a type system for constraining the character data of an XML document. WXS is maintained by the World Wide Web Consortium (W3C) and is a W3C Recommendation (that is, a ratified W3C standard specification).
  • RELAX NG (RNG) - a pattern-based, user-friendly XML schema language. RNG schemas may also use types to constrain XML character data. RNG is maintained by the Organization for the Advancement of Structured Information Standards (OASIS) and is both an OASIS and an ISO (International Organization for Standardization) standard.
  • Schematron - a rules-based XML schema language. Whereas DTD, WXS, and RNG are designed to express the structure of a content model, Schematron is designed to enforce individual rules that are difficult or impossible to express with other schema languages. Schematron is intended to supplement a schema written in structural schema language such as the aforementioned. Schematron is in the process of becoming an ISO standard.

Previous versions of JAXP supported validation as a feature of an XML parser, represented by either a SAXParser or DocumentBuilder instance.

The JAXP validation API decouples the validation of an instance document from the parsing of an XML document. This is advantageous for several reasons, some of which are:

  • Support for additional schema langauges. As of JDK 1.5, the two most popular JAXP parser implementations, Crimson and Xerces, only support a subset of the available XML schema languages. The Validation API provides a standard mechanism through which applications may take of advantage of specialization validation libraries which support additional schema languages.
  • Easy runtime coupling of an XML instance and schema. Specifying the location of a schema to use for validation with JAXP parsers can be confusing. The Validation API makes this process simple (see example below).

Usage example. The following example demonstrates validating an XML document with the Validation API (for readability, some exception handling is not shown):

    // parse an XML document into a DOM tree
    DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
    Document document = parser.parse(new File("instance.xml"));

    // create a SchemaFactory capable of understanding WXS schemas
    SchemaFactory factory = SchemaFactory.newInstance(XMLConstants.W3C_XML_SCHEMA_NS_URI);

    // load a WXS schema, represented by a Schema instance
    Source schemaFile = new StreamSource(new File("mySchema.xsd"));
    Schema schema = factory.newSchema(schemaFile);

    // create a Validator instance, which can be used to validate an instance document
    Validator validator = schema.newValidator();

    // validate the DOM tree
    try {
        validator.validate(new DOMSource(document));
    } catch (SAXException e) {
        // instance document is invalid!
    }

The JAXP parsing API has been integrated with the Validation API. Applications may create a Schema with the validation API and associate it with a DocumentBuilderFactory or a SAXParserFactory instance by using the DocumentBuilderFactory.setSchema(Schema) and SAXParserFactory.setSchema(Schema) methods. You should not both set a schema and call setValidating(true) on a parser factory. The former technique will cause parsers to use the new validation API; the latter will cause parsers to use their own internal validation facilities. Turning on both of these options simultaneously will cause either redundant behavior or error conditions.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.validation (Java Platform SE 8 )

javax.xml.validation

Classes

  • Schema
  • SchemaFactory
  • SchemaFactoryLoader
  • TypeInfoProvider
  • Validator
  • ValidatorHandler

Errors

  • SchemaFactoryConfigurationError


javax.xml.validation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.validation

This package provides an API for validation of XML documents.

See: Description

  • Class Summary
    Class Description
    Schema
    Immutable in-memory representation of grammar.
    SchemaFactory
    Factory that creates Schema objects. Entry-point to the validation API.
    SchemaFactoryLoader
    Factory that creates SchemaFactory.
    TypeInfoProvider
    This class provides access to the type information determined by ValidatorHandler.
    Validator
    A processor that checks an XML document against Schema.
    ValidatorHandler
    Streaming validator that works on SAX stream.
  • Error Summary
    Error Description
    SchemaFactoryConfigurationError
    Thrown when a problem with configuration with the Schema Factories exists.

Package javax.xml.validation Description

This package provides an API for validation of XML documents. Validation is the process of verifying that an XML document is an instance of a specified XML schema. An XML schema defines the content model (also called a grammar or vocabulary) that its instance documents will represent.

There are a number of popular technologies available for creating an XML schema. Some of the most popular include:

  • Document Type Definition (DTD) - XML's built-in schema language.
  • W3C XML Schema (WXS) - an object-oriented XML schema language. WXS also provides a type system for constraining the character data of an XML document. WXS is maintained by the World Wide Web Consortium (W3C) and is a W3C Recommendation (that is, a ratified W3C standard specification).
  • RELAX NG (RNG) - a pattern-based, user-friendly XML schema language. RNG schemas may also use types to constrain XML character data. RNG is maintained by the Organization for the Advancement of Structured Information Standards (OASIS) and is both an OASIS and an ISO (International Organization for Standardization) standard.
  • Schematron - a rules-based XML schema language. Whereas DTD, WXS, and RNG are designed to express the structure of a content model, Schematron is designed to enforce individual rules that are difficult or impossible to express with other schema languages. Schematron is intended to supplement a schema written in structural schema language such as the aforementioned. Schematron is in the process of becoming an ISO standard.

Previous versions of JAXP supported validation as a feature of an XML parser, represented by either a SAXParser or DocumentBuilder instance.

The JAXP validation API decouples the validation of an instance document from the parsing of an XML document. This is advantageous for several reasons, some of which are:

  • Support for additional schema langauges. As of JDK 1.5, the two most popular JAXP parser implementations, Crimson and Xerces, only support a subset of the available XML schema languages. The Validation API provides a standard mechanism through which applications may take of advantage of specialization validation libraries which support additional schema languages.
  • Easy runtime coupling of an XML instance and schema. Specifying the location of a schema to use for validation with JAXP parsers can be confusing. The Validation API makes this process simple (see example below).

Usage example. The following example demonstrates validating an XML document with the Validation API (for readability, some exception handling is not shown):

    // parse an XML document into a DOM tree
    DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
    Document document = parser.parse(new File("instance.xml"));

    // create a SchemaFactory capable of understanding WXS schemas
    SchemaFactory factory = SchemaFactory.newInstance(XMLConstants.W3C_XML_SCHEMA_NS_URI);

    // load a WXS schema, represented by a Schema instance
    Source schemaFile = new StreamSource(new File("mySchema.xsd"));
    Schema schema = factory.newSchema(schemaFile);

    // create a Validator instance, which can be used to validate an instance document
    Validator validator = schema.newValidator();

    // validate the DOM tree
    try {
        validator.validate(new DOMSource(document));
    } catch (SAXException e) {
        // instance document is invalid!
    }

The JAXP parsing API has been integrated with the Validation API. Applications may create a Schema with the validation API and associate it with a DocumentBuilderFactory or a SAXParserFactory instance by using the DocumentBuilderFactory.setSchema(Schema) and SAXParserFactory.setSchema(Schema) methods. You should not both set a schema and call setValidating(true) on a parser factory. The former technique will cause parsers to use the new validation API; the latter will cause parsers to use their own internal validation facilities. Turning on both of these options simultaneously will cause either redundant behavior or error conditions.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.validation Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.validation

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.validation.Schema
    • javax.xml.validation.SchemaFactory
    • javax.xml.validation.SchemaFactoryLoader
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.validation.SchemaFactoryConfigurationError
    • javax.xml.validation.TypeInfoProvider
    • javax.xml.validation.Validator
    • javax.xml.validation.ValidatorHandler (implements org.xml.sax.ContentHandler)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.validation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.validation

  • Packages that use javax.xml.validation
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
  • Classes in javax.xml.validation used by javax.xml.bind
    Class and Description
    Schema
    Immutable in-memory representation of grammar.
  • Classes in javax.xml.validation used by javax.xml.bind.helpers
    Class and Description
    Schema
    Immutable in-memory representation of grammar.
  • Classes in javax.xml.validation used by javax.xml.parsers
    Class and Description
    Schema
    Immutable in-memory representation of grammar.
  • Classes in javax.xml.validation used by javax.xml.validation
    Class and Description
    Schema
    Immutable in-memory representation of grammar.
    SchemaFactory
    Factory that creates Schema objects. Entry-point to the validation API.
    TypeInfoProvider
    This class provides access to the type information determined by ValidatorHandler.
    Validator
    A processor that checks an XML document against Schema.
    ValidatorHandler
    Streaming validator that works on SAX stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Schema (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class Schema

  • java.lang.Object
    • javax.xml.validation.Schema

  • public abstract class Schema
extends Object
    Immutable in-memory representation of grammar.

    This object represents a set of constraints that can be checked/ enforced against an XML document.

    A Schema object is thread safe and applications are encouraged to share it across many parsers in many threads.

    A Schema object is immutable in the sense that it shouldn't change the set of constraints once it is created. In other words, if an application validates the same document twice against the same Schema, it must always produce the same result.

    A Schema object is usually created from SchemaFactory.

    Two kinds of validators can be created from a Schema object. One is Validator, which provides highly-level validation operations that cover typical use cases. The other is ValidatorHandler, which works on top of SAX for better modularity.

    This specification does not refine the Object.equals(java.lang.Object) method. In other words, if you parse the same schema twice, you may still get !schemaA.equals(schemaB).

    Since:
    1.5
    See Also:
    XML Schema Part 1: Structures, Extensible Markup Language (XML) 1.1, Extensible Markup Language (XML) 1.0 (Second Edition)

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Schema()
      Constructor for the derived class.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract Validator newValidator()
      Creates a new Validator for this Schema.
      abstract ValidatorHandler newValidatorHandler()
      Creates a new ValidatorHandler for this Schema.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Schema

        protected Schema()
        Constructor for the derived class.

        The constructor does nothing.

    • Method Detail

      • newValidator

        public abstract Validator newValidator()
        Creates a new Validator for this Schema.

        A validator enforces/checks the set of constraints this object represents.

        Implementors should assure that the properties set on the SchemaFactory that created this Schema are also set on the Validator constructed.

        Returns:
        Always return a non-null valid object.

      • newValidatorHandler

        public abstract ValidatorHandler newValidatorHandler()
        Creates a new ValidatorHandler for this Schema.

        Implementors should assure that the properties set on the SchemaFactory that created this Schema are also set on the ValidatorHandler constructed.

        Returns:
        Always return a non-null valid object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SchemaFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class SchemaFactory

  • java.lang.Object
    • javax.xml.validation.SchemaFactory

  • public abstract class SchemaFactory
extends Object
    Factory that creates Schema objects. Entry-point to the validation API.

    SchemaFactory is a schema compiler. It reads external representations of schemas and prepares them for validation.

    The SchemaFactory class is not thread-safe. In other words, it is the application's responsibility to ensure that at most one thread is using a SchemaFactory object at any given moment. Implementations are encouraged to mark methods as synchronized to protect themselves from broken clients.

    SchemaFactory is not re-entrant. While one of the newSchema methods is being invoked, applications may not attempt to recursively invoke the newSchema method, even from the same thread.

    Schema Language

    This spec uses a namespace URI to designate a schema language. The following table shows the values defined by this specification.

    To be compliant with the spec, the implementation is only required to support W3C XML Schema 1.0. However, if it chooses to support other schema languages listed here, it must conform to the relevant behaviors described in this spec.

    Schema languages not listed here are expected to introduce their own URIs to represent themselves. The SchemaFactory class is capable of locating other implementations for other schema languages at run-time.

    Note that because the XML DTD is strongly tied to the parsing process and has a significant effect on the parsing process, it is impossible to define the DTD validation as a process independent from parsing. For this reason, this specification does not define the semantics for the XML DTD. This doesn't prohibit implementors from implementing it in a way they see fit, but users are warned that any DTD validation implemented on this interface necessarily deviate from the XML DTD semantics as defined in the XML 1.0.

    value | language
    XMLConstants.W3C_XML_SCHEMA_NS_URI ("http://www.w3.org/2001/XMLSchema") | W3C XML Schema 1.0
    XMLConstants.RELAXNG_NS_URI ("http://relaxng.org/ns/structure/1.0") | RELAX NG 1.0
    Since:
    1.5

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SchemaFactory()
      Constructor for derived classes.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract ErrorHandler getErrorHandler()
      Gets the current ErrorHandler set to this SchemaFactory.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      abstract LSResourceResolver getResourceResolver()
      Gets the current LSResourceResolver set to this SchemaFactory.
      abstract boolean isSchemaLanguageSupported(String schemaLanguage)
      Is specified schema supported by this SchemaFactory?
      static SchemaFactory newInstance(String schemaLanguage)
      Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.
      static SchemaFactory newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SchemaFactory from class name.
      abstract Schema newSchema()
      Creates a special Schema object.
      Schema newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
      abstract void setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.
      void setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void setProperty(String name, Object object)
      Set the value of a property.
      abstract void setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution when parsing schemas.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SchemaFactory

        protected SchemaFactory()

        Constructor for derived classes.

        The constructor does nothing.

        Derived classes must create SchemaFactory objects that have null ErrorHandler and null LSResourceResolver.

    • Method Detail

      • newInstance

        public static SchemaFactory newInstance(String schemaLanguage)

        Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.

        To find a SchemaFactory object for a given schema language, this method looks the following places in the following order where "the class loader" refers to the context class loader:

        1. If the system property "javax.xml.validation.SchemaFactory:schemaLanguage" is present (where schemaLanguage is the parameter to this method), then its value is read as a class name. The method will try to create a new instance of this class by using the class loader, and returns it if it is successfully created.
        2. $java.home/lib/jaxp.properties is read and the value associated with the key being the system property above is looked for. If present, the value is processed just like above.
        3. Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
          Each potential service provider is required to implement the method isSchemaLanguageSupported(String schemaLanguage).
          The first service provider found that supports the specified schema language is returned.
          In case of ServiceConfigurationError a SchemaFactoryConfigurationError will be thrown.
        4. Platform default SchemaFactory is located in a implementation specific way. There must be a platform default SchemaFactory for W3C XML Schema.

        If everything fails, IllegalArgumentException will be thrown.

        Tip for Trouble-shooting:

        See Properties.load(java.io.InputStream) for exactly how a property file is parsed. In particular, colons ':' need to be escaped in a property file, so make sure schema language URIs are properly escaped in it. For example:

         http\://www.w3.org/2001/XMLSchema=org.acme.foo.XSSchemaFactory
        Parameters:
        schemaLanguage - Specifies the schema language which the returned SchemaFactory will understand. See the list of available schema languages for the possible values.
        Returns:
        New instance of a SchemaFactory
        Throws:
        IllegalArgumentException - If no implementation of the schema language is available.
        NullPointerException - If the schemaLanguage parameter is null.
        SchemaFactoryConfigurationError - If a configuration error is encountered.
        See Also:
        newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)

      • newInstance

        public static SchemaFactory newInstance(String schemaLanguage,
                                        String factoryClassName,
                                        ClassLoader classLoader)

        Obtain a new instance of a SchemaFactory from class name. SchemaFactory is returned if specified factory class name supports the specified schema language. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        Parameters:
        schemaLanguage - Specifies the schema language which the returned SchemaFactory will understand. See the list of available schema languages for the possible values.
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.validation.SchemaFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        Returns:
        New instance of a SchemaFactory
        Throws:
        IllegalArgumentException - if factoryClassName is null, or the factory class cannot be loaded, instantiated or doesn't support the schema language specified in schemLanguage parameter.
        NullPointerException - If the schemaLanguage parameter is null.
        Since:
        1.6
        See Also:
        newInstance(String schemaLanguage)

      • isSchemaLanguageSupported

        public abstract boolean isSchemaLanguageSupported(String schemaLanguage)

        Is specified schema supported by this SchemaFactory?

        Parameters:
        schemaLanguage - Specifies the schema language which the returned SchemaFactory will understand. schemaLanguage must specify a valid schema language.
        Returns:
        true if SchemaFactory supports schemaLanguage, else false.
        Throws:
        NullPointerException - If schemaLanguage is null.
        IllegalArgumentException - If schemaLanguage.length() == 0 or schemaLanguage does not specify a valid schema language.

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for a SchemaFactory to recognize a feature name but temporarily be unable to return its value.

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        Parameters:
        name - The feature name, which is a non-null fully-qualified URI.
        Returns:
        The current value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the SchemaFactory recognizes the feature name but cannot determine its value at this time.
        NullPointerException - If name is null.
        See Also:
        setFeature(String, boolean)

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException

        Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.

        Implementors and developers should pay particular attention to how the special Schema object returned by newSchema() is processed. In some cases, for example, when the SchemaFactory and the class actually loading the schema come from different implementations, it may not be possible for SchemaFactory features to be inherited automatically. Developers should make sure that features, such as secure processing, are explicitly set in both places.

        The feature name is any fully-qualified URI. It is possible for a SchemaFactory to expose a feature value but to be unable to change the current value.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See setErrorHandler(ErrorHandler errorHandler).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        Parameters:
        name - The feature name, which is a non-null fully-qualified URI.
        value - The requested value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the SchemaFactory recognizes the feature name but cannot set the requested value.
        NullPointerException - If name is null.
        See Also:
        getFeature(String)

      • setProperty

        public void setProperty(String name,
                        Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for a SchemaFactory to recognize a property name but to be unable to change the current value.

        All implementations that implement JAXP 1.5 or newer are required to support the XMLConstants.ACCESS_EXTERNAL_DTD and XMLConstants.ACCESS_EXTERNAL_SCHEMA properties.

        • Access to external DTDs in Schema files is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_DTD property. If access is denied during the creation of new Schema due to the restriction of this property, SAXException will be thrown by the newSchema(Source) or newSchema(File) or newSchema(URL) or or newSchema(Source[]) method.

          Access to external DTDs in xml source files is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_DTD property. If access is denied during validation due to the restriction of this property, SAXException will be thrown by the Validator.validate(Source) or Validator.validate(Source, Result) method.

          Access to external reference set by the schemaLocation attribute is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_SCHEMA property. If access is denied during validation due to the restriction of this property, SAXException will be thrown by the Validator.validate(Source) or Validator.validate(Source, Result) method.

          Access to external reference set by the Import and Include element is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_SCHEMA property. If access is denied during the creation of new Schema due to the restriction of this property, SAXException will be thrown by the newSchema(Source) or newSchema(File) or newSchema(URL) or newSchema(Source[]) method.

        Parameters:
        name - The property name, which is a non-null fully-qualified URI.
        object - The requested value for the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the SchemaFactory recognizes the property name but cannot set the requested value.
        NullPointerException - If name is null.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for a SchemaFactory to recognize a property name but temporarily be unable to return its value.

        SchemaFactorys are not required to recognize any specific property names.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        Parameters:
        name - The property name, which is a non-null fully-qualified URI.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        NullPointerException - If name is null.
        See Also:
        setProperty(String, Object)

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler errorHandler)
        Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.

        Error handler can be used to customize the error handling process during schema parsing. When an ErrorHandler is set, errors found during the parsing of schemas will be first sent to the ErrorHandler.

        The error handler can abort the parsing of a schema immediately by throwing SAXException from the handler. Or for example it can print an error to the screen and try to continue the processing by returning normally from the ErrorHandler

        If any Throwable (or instances of its derived classes) is thrown from an ErrorHandler, the caller of the newSchema method will be thrown the same Throwable object.

        SchemaFactory is not allowed to throw SAXException without first reporting it to ErrorHandler.

        Applications can call this method even during a Schema is being parsed.

        When the ErrorHandler is null, the implementation will behave as if the following ErrorHandler is set:

         class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

        When a new SchemaFactory object is created, initially this field is set to null. This field will NOT be inherited to Schemas, Validators, or ValidatorHandlers that are created from this SchemaFactory.

        Parameters:
        errorHandler - A new error handler to be set. This parameter can be null.

      • getErrorHandler

        public abstract ErrorHandler getErrorHandler()
        Gets the current ErrorHandler set to this SchemaFactory.
        Returns:
        This method returns the object that was last set through the setErrorHandler(ErrorHandler) method, or null if that method has never been called since this SchemaFactory has created.
        See Also:
        setErrorHandler(ErrorHandler)

      • setResourceResolver

        public abstract void setResourceResolver(LSResourceResolver resourceResolver)
        Sets the LSResourceResolver to customize resource resolution when parsing schemas.

        SchemaFactory uses a LSResourceResolver when it needs to locate external resources while parsing schemas, although exactly what constitutes "locating external resources" is up to each schema language. For example, for W3C XML Schema, this includes files <include>d or <import>ed, and DTD referenced from schema files, etc.

        Applications can call this method even during a Schema is being parsed.

        When the LSResourceResolver is null, the implementation will behave as if the following LSResourceResolver is set:

         class DumbDOMResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

        If a LSResourceResolver throws a RuntimeException (or instances of its derived classes), then the SchemaFactory will abort the parsing and the caller of the newSchema method will receive the same RuntimeException.

        When a new SchemaFactory object is created, initially this field is set to null. This field will NOT be inherited to Schemas, Validators, or ValidatorHandlers that are created from this SchemaFactory.

        Parameters:
        resourceResolver - A new resource resolver to be set. This parameter can be null.

      • getResourceResolver

        public abstract LSResourceResolver getResourceResolver()
        Gets the current LSResourceResolver set to this SchemaFactory.
        Returns:
        This method returns the object that was last set through the setResourceResolver(LSResourceResolver) method, or null if that method has never been called since this SchemaFactory has created.
        See Also:
        setErrorHandler(ErrorHandler)

      • newSchema

        public Schema newSchema(Source schema)
                 throws SAXException

        Parses the specified source as a schema and returns it as a schema.

        This is a convenience method for newSchema(Source[] schemas).

        Parameters:
        schema - Source that represents a schema.
        Returns:
        New Schema from parsing schema.
        Throws:
        SAXException - If a SAX error occurs during parsing.
        NullPointerException - if schema is null.

      • newSchema

        public Schema newSchema(File schema)
                 throws SAXException

        Parses the specified File as a schema and returns it as a Schema.

        This is a convenience method for newSchema(Source schema).

        Parameters:
        schema - File that represents a schema.
        Returns:
        New Schema from parsing schema.
        Throws:
        SAXException - If a SAX error occurs during parsing.
        NullPointerException - if schema is null.

      • newSchema

        public Schema newSchema(URL schema)
                 throws SAXException

        Parses the specified URL as a schema and returns it as a Schema.

        This is a convenience method for newSchema(Source schema).

        Parameters:
        schema - URL that represents a schema.
        Returns:
        New Schema from parsing schema.
        Throws:
        SAXException - If a SAX error occurs during parsing.
        NullPointerException - if schema is null.

      • newSchema

        public abstract Schema newSchema(Source[] schemas)
                          throws SAXException
        Parses the specified source(s) as a schema and returns it as a schema.

        The callee will read all the Sources and combine them into a single schema. The exact semantics of the combination depends on the schema language that this SchemaFactory object is created for.

        When an ErrorHandler is set, the callee will report all the errors found in sources to the handler. If the handler throws an exception, it will abort the schema compilation and the same exception will be thrown from this method. Also, after an error is reported to a handler, the callee is allowed to abort the further processing by throwing it. If an error handler is not set, the callee will throw the first error it finds in the sources.

        W3C XML Schema 1.0

        The resulting schema contains components from the specified sources. The same result would be achieved if all these sources were imported, using appropriate values for schemaLocation and namespace, into a single schema document with a different targetNamespace and no components of its own, if the import elements were given in the same order as the sources. Section 4.2.3 of the XML Schema recommendation describes the options processors have in this regard. While a processor should be consistent in its treatment of JAXP schema sources and XML Schema imports, the behaviour between JAXP-compliant parsers may vary; in particular, parsers may choose to ignore all but the first <import> for a given namespace, regardless of information provided in schemaLocation.

        If the parsed set of schemas includes error(s) as specified in the section 5.1 of the XML Schema spec, then the error must be reported to the ErrorHandler.

        RELAX NG

        For RELAX NG, this method must throw UnsupportedOperationException if schemas.length!=1.

        Parameters:
        schemas - inputs to be parsed. SchemaFactory is required to recognize SAXSource, StreamSource, StAXSource, and DOMSource. Input schemas must be XML documents or XML elements and must not be null. For backwards compatibility, the results of passing anything other than a document or element are implementation-dependent. Implementations must either recognize and process the input or thrown an IllegalArgumentException.
        Returns:
        Always return a non-null valid Schema object. Note that when an error has been reported, there is no guarantee that the returned Schema object is meaningful.
        Throws:
        SAXException - If an error is found during processing the specified inputs. When an ErrorHandler is set, errors are reported to there first. See setErrorHandler(ErrorHandler).
        NullPointerException - If the schemas parameter itself is null or any item in the array is null.
        IllegalArgumentException - If any item in the array is not recognized by this method.
        UnsupportedOperationException - If the schema language doesn't support this operation.

      • newSchema

        public abstract Schema newSchema()
                          throws SAXException
        Creates a special Schema object.

        The exact semantics of the returned Schema object depend on the schema language for which this SchemaFactory is created.

        Also, implementations are allowed to use implementation-specific property/feature to alter the semantics of this method.

        Implementors and developers should pay particular attention to how the features set on this SchemaFactory are processed by this special Schema. In some cases, for example, when the SchemaFactory and the class actually loading the schema come from different implementations, it may not be possible for SchemaFactory features to be inherited automatically. Developers should make sure that features, such as secure processing, are explicitly set in both places.

        W3C XML Schema 1.0

        For XML Schema, this method creates a Schema object that performs validation by using location hints specified in documents.

        The returned Schema object assumes that if documents refer to the same URL in the schema location hints, they will always resolve to the same schema document. This asusmption allows implementations to reuse parsed results of schema documents so that multiple validations against the same schema will run faster.

        Note that the use of schema location hints introduces a vulnerability to denial-of-service attacks.

        RELAX NG

        RELAX NG does not support this operation.

        Returns:
        Always return non-null valid Schema object.
        Throws:
        UnsupportedOperationException - If this operation is not supported by the callee.
        SAXException - If this operation is supported but failed for some reason.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SchemaFactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class SchemaFactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.validation.SchemaFactoryConfigurationError
  • All Implemented Interfaces:
    Serializable

    public final class SchemaFactoryConfigurationError
extends Error
    Thrown when a problem with configuration with the Schema Factories exists. This error will typically be thrown when the class of a schema factory specified in the system properties cannot be found or instantiated.
    Since:
    1.8
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SchemaFactoryConfigurationError()
      Create a new SchemaFactoryConfigurationError with no detail message.
      SchemaFactoryConfigurationError(String message)
      Create a new SchemaFactoryConfigurationError with the String specified as an error message.
      SchemaFactoryConfigurationError(String message, Throwable cause)
      Create a new SchemaFactoryConfigurationError with the given Throwable base cause and detail message.
      SchemaFactoryConfigurationError(Throwable cause)
      Create a new SchemaFactoryConfigurationError with the given Throwable base cause.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SchemaFactoryConfigurationError

        public SchemaFactoryConfigurationError()
        Create a new SchemaFactoryConfigurationError with no detail message.

      • SchemaFactoryConfigurationError

        public SchemaFactoryConfigurationError(String message)
        Create a new SchemaFactoryConfigurationError with the String specified as an error message.
        Parameters:
        message - The error message for the exception.

      • SchemaFactoryConfigurationError

        public SchemaFactoryConfigurationError(Throwable cause)
        Create a new SchemaFactoryConfigurationError with the given Throwable base cause.
        Parameters:
        cause - The exception or error to be encapsulated in a SchemaFactoryConfigurationError.

      • SchemaFactoryConfigurationError

        public SchemaFactoryConfigurationError(String message,
                                       Throwable cause)
        Create a new SchemaFactoryConfigurationError with the given Throwable base cause and detail message.
        Parameters:
        cause - The exception or error to be encapsulated in a SchemaFactoryConfigurationError.
        message - The detail message.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SchemaFactoryLoader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class SchemaFactoryLoader

  • java.lang.Object
    • javax.xml.validation.SchemaFactoryLoader

  • public abstract class SchemaFactoryLoader
extends Object

    Factory that creates SchemaFactory.

    DO NOT USE THIS CLASS

    This class was introduced as a part of an early proposal during the JSR-206 standardization process. The proposal was eventually abandoned but this class accidentally remained in the source tree, and made its way into the final version.

    This class does not participate in any JAXP 1.3 or JAXP 1.4 processing. It must not be used by users or JAXP implementations.

    Since:
    1.5

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SchemaFactoryLoader()
      A do-nothing constructor.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract SchemaFactory newFactory(String schemaLanguage)
      Creates a new SchemaFactory object for the specified schema language.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SchemaFactoryLoader

        protected SchemaFactoryLoader()
        A do-nothing constructor.

    • Method Detail

      • newFactory

        public abstract SchemaFactory newFactory(String schemaLanguage)
        Creates a new SchemaFactory object for the specified schema language.
        Parameters:
        schemaLanguage - See the list of available schema languages.
        Returns:
        null if the callee fails to create one.
        Throws:
        NullPointerException - If the schemaLanguage parameter is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeInfoProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class TypeInfoProvider

  • java.lang.Object
    • javax.xml.validation.TypeInfoProvider

  • public abstract class TypeInfoProvider
extends Object
    This class provides access to the type information determined by ValidatorHandler.

    Some schema languages, such as W3C XML Schema, encourages a validator to report the "type" it assigns to each attribute/element. Those applications who wish to access this type information can invoke methods defined on this "interface" to access such type information.

    Implementation of this "interface" can be obtained through the ValidatorHandler.getTypeInfoProvider() method.

    Since:
    1.5
    See Also:
    TypeInfo

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected TypeInfoProvider()
      Constructor for the derived class.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract TypeInfo getAttributeTypeInfo(int index)
      Returns the immutable TypeInfo object for the specified attribute of the current element.
      abstract TypeInfo getElementTypeInfo()
      Returns the immutable TypeInfo object for the current element.
      abstract boolean isIdAttribute(int index)
      Returns true if the specified attribute is determined to be ID.
      abstract boolean isSpecified(int index)
      Returns false if the attribute was added by the validator.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TypeInfoProvider

        protected TypeInfoProvider()
        Constructor for the derived class.

        The constructor does nothing.

    • Method Detail

      • getElementTypeInfo

        public abstract TypeInfo getElementTypeInfo()

        Returns the immutable TypeInfo object for the current element.

        The method may only be called by the startElement event or the endElement event of the ContentHandler that the application sets to the ValidatorHandler.

        When W3C XML Schema validation is being performed, in the case where an element has a union type, the TypeInfo returned by a call to getElementTypeInfo() from the startElement event will be the union type. The TypeInfo returned by a call from the endElement event will be the actual member type used to validate the element.

        Returns:
        An immutable TypeInfo object that represents the type of the current element. Note that the caller can keep references to the obtained TypeInfo longer than the callback scope. Otherwise, this method returns null if the validator is unable to determine the type of the current element for some reason (for example, if the validator is recovering from an earlier error.)
        Throws:
        IllegalStateException - If this method is called from other ContentHandler methods.

      • getAttributeTypeInfo

        public abstract TypeInfo getAttributeTypeInfo(int index)
        Returns the immutable TypeInfo object for the specified attribute of the current element.

        The method may only be called by the startElement event of the ContentHandler that the application sets to the ValidatorHandler.

        Parameters:
        index - The index of the attribute. The same index for the Attributes object passed to the startElement callback.
        Returns:
        An immutable TypeInfo object that represents the type of the specified attribute. Note that the caller can keep references to the obtained TypeInfo longer than the callback scope. Otherwise, this method returns null if the validator is unable to determine the type.
        Throws:
        IndexOutOfBoundsException - If the index is invalid.
        IllegalStateException - If this method is called from other ContentHandler methods.

      • isIdAttribute

        public abstract boolean isIdAttribute(int index)
        Returns true if the specified attribute is determined to be ID.

        Exacly how an attribute is "determined to be ID" is up to the schema language. In case of W3C XML Schema, this means that the actual type of the attribute is the built-in ID type or its derived type.

        A DocumentBuilder uses this information to properly implement Attr.isId().

        The method may only be called by the startElement event of the ContentHandler that the application sets to the ValidatorHandler.

        Parameters:
        index - The index of the attribute. The same index for the Attributes object passed to the startElement callback.
        Returns:
        true if the type of the specified attribute is ID.
        Throws:
        IndexOutOfBoundsException - If the index is invalid.
        IllegalStateException - If this method is called from other ContentHandler methods.

      • isSpecified

        public abstract boolean isSpecified(int index)
        Returns false if the attribute was added by the validator.

        This method provides information necessary for a DocumentBuilder to determine what the DOM tree should return from the Attr.getSpecified() method.

        The method may only be called by the startElement event of the ContentHandler that the application sets to the ValidatorHandler.

        A general guideline for validators is to return true if the attribute was originally present in the pipeline, and false if it was added by the validator.

        Parameters:
        index - The index of the attribute. The same index for the Attributes object passed to the startElement callback.
        Returns:
        true if the attribute was present before the validator processes input. false if the attribute was added by the validator.
        Throws:
        IndexOutOfBoundsException - If the index is invalid.
        IllegalStateException - If this method is called from other ContentHandler methods.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Validator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class Validator

  • java.lang.Object
    • javax.xml.validation.Validator

  • public abstract class Validator
extends Object

    A processor that checks an XML document against Schema.

    A validator object is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one Validator object is not used from more than one thread at any given time, and while the validate method is invoked, applications may not recursively call the validate method.

    Since:
    1.5

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Validator()
      Constructor for derived classes.

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract ErrorHandler getErrorHandler()
      Gets the current ErrorHandler set to this Validator.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      abstract LSResourceResolver getResourceResolver()
      Gets the current LSResourceResolver set to this Validator.
      abstract void reset()
      Reset this Validator to its original configuration.
      abstract void setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validate method invocation.
      void setFeature(String name, boolean value)
      Set the value of a feature flag.
      void setProperty(String name, Object object)
      Set the value of a property.
      abstract void setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      void validate(Source source)
      Validates the specified input.
      abstract void validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Validator

        protected Validator()
        Constructor for derived classes.

        The constructor does nothing.

        Derived classes must create Validator objects that have null ErrorHandler and null LSResourceResolver.

    • Method Detail

      • reset

        public abstract void reset()

        Reset this Validator to its original configuration.

        Validator is reset to the same state as when it was created with Schema.newValidator(). reset() is designed to allow the reuse of existing Validators thus saving resources associated with the creation of new Validators.

        The reset Validator is not guaranteed to have the same LSResourceResolver or ErrorHandler Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal LSResourceResolver and ErrorHandler.

      • validate

        public void validate(Source source)
              throws SAXException,
                     IOException
        Validates the specified input.

        This is just a convenience method for validate(Source source, Result result) with result of null.

        Parameters:
        source - XML to be validated. Must be an XML document or XML element and must not be null. For backwards compatibility, the results of attempting to validate anything other than a document or element are implementation-dependent. Implementations must either recognize and process the input or throw an IllegalArgumentException.
        Throws:
        IllegalArgumentException - If the Source is an XML artifact that the implementation cannot validate (for example, a processing instruction).
        SAXException - If the ErrorHandler throws a SAXException or if a fatal error is found and the ErrorHandler returns normally.
        IOException - If the validator is processing a SAXSource and the underlying XMLReader throws an IOException.
        NullPointerException - If source is null.
        See Also:
        validate(Source source, Result result)

      • validate

        public abstract void validate(Source source,
                              Result result)
                       throws SAXException,
                              IOException

        Validates the specified input and send the augmented validation result to the specified output.

        This method places the following restrictions on the types of the Source/Result accepted.

        Source / Result Accepted
        StreamSource SAXSource DOMSource StAXSource
        null | OK | OK | OK | OK
        StreamResult | OK | IllegalArgumentException | IllegalArgumentException | IllegalArgumentException
        SAXResult | IllegalArgumentException | OK | IllegalArgumentException | IllegalArgumentException
        DOMResult | IllegalArgumentException | IllegalArgumentException | OK | IllegalArgumentException
        StAXResult | IllegalArgumentException | IllegalArgumentException | IllegalArgumentException | OK

        To validate one Source into another kind of Result, use the identity transformer (see TransformerFactory.newTransformer()).

        Errors found during the validation is sent to the specified ErrorHandler.

        If a document is valid, or if a document contains some errors but none of them were fatal and the ErrorHandler didn't throw any exception, then the method returns normally.

        Parameters:
        source - XML to be validated. Must be an XML document or XML element and must not be null. For backwards compatibility, the results of attempting to validate anything other than a document or element are implementation-dependent. Implementations must either recognize and process the input or throw an IllegalArgumentException.
        result - The Result object that receives (possibly augmented) XML. This parameter can be null if the caller is not interested in it. Note that when a DOMResult is used, a validator might just pass the same DOM node from DOMSource to DOMResult (in which case source.getNode()==result.getNode()), it might copy the entire DOM tree, or it might alter the node given by the source.
        Throws:
        IllegalArgumentException - If the Result type doesn't match the Source type of if the Source is an XML artifact that the implementation cannot validate (for example, a processing instruction).
        SAXException - If the ErrorHandler throws a SAXException or if a fatal error is found and the ErrorHandler returns normally.
        IOException - If the validator is processing a SAXSource and the underlying XMLReader throws an IOException.
        NullPointerException - If the source parameter is null.
        See Also:
        validate(Source source)

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler errorHandler)
        Sets the ErrorHandler to receive errors encountered during the validate method invocation.

        Error handler can be used to customize the error handling process during a validation. When an ErrorHandler is set, errors found during the validation will be first sent to the ErrorHandler.

        The error handler can abort further validation immediately by throwing SAXException from the handler. Or for example it can print an error to the screen and try to continue the validation by returning normally from the ErrorHandler

        If any Throwable is thrown from an ErrorHandler, the caller of the validate method will be thrown the same Throwable object.

        Validator is not allowed to throw SAXException without first reporting it to ErrorHandler.

        When the ErrorHandler is null, the implementation will behave as if the following ErrorHandler is set:

         class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

        When a new Validator object is created, initially this field is set to null.

        Parameters:
        errorHandler - A new error handler to be set. This parameter can be null.

      • getErrorHandler

        public abstract ErrorHandler getErrorHandler()
        Gets the current ErrorHandler set to this Validator.
        Returns:
        This method returns the object that was last set through the setErrorHandler(ErrorHandler) method, or null if that method has never been called since this Validator has created.
        See Also:
        setErrorHandler(ErrorHandler)

      • setResourceResolver

        public abstract void setResourceResolver(LSResourceResolver resourceResolver)
        Sets the LSResourceResolver to customize resource resolution while in a validation episode.

        Validator uses a LSResourceResolver when it needs to locate external resources while a validation, although exactly what constitutes "locating external resources" is up to each schema language.

        When the LSResourceResolver is null, the implementation will behave as if the following LSResourceResolver is set:

         class DumbLSResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

        If a LSResourceResolver throws a RuntimeException (or instances of its derived classes), then the Validator will abort the parsing and the caller of the validate method will receive the same RuntimeException.

        When a new Validator object is created, initially this field is set to null.

        Parameters:
        resourceResolver - A new resource resolver to be set. This parameter can be null.

      • getResourceResolver

        public abstract LSResourceResolver getResourceResolver()
        Gets the current LSResourceResolver set to this Validator.
        Returns:
        This method returns the object that was last set through the setResourceResolver(LSResourceResolver) method, or null if that method has never been called since this Validator has created.
        See Also:
        setErrorHandler(ErrorHandler)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for a Validator to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a validation.

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        Parameters:
        name - The feature name, which is a non-null fully-qualified URI.
        Returns:
        The current value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the Validator recognizes the feature name but cannot determine its value at this time.
        NullPointerException - When the name parameter is null.
        See Also:
        setFeature(String, boolean)

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set the value of a feature flag.

        Feature can be used to control the way a Validator parses schemas, although Validators are not required to recognize any specific feature names.

        The feature name is any fully-qualified URI. It is possible for a Validator to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        Parameters:
        name - The feature name, which is a non-null fully-qualified URI.
        value - The requested value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the Validator recognizes the feature name but cannot set the requested value.
        NullPointerException - When the name parameter is null.
        See Also:
        getFeature(String)

      • setProperty

        public void setProperty(String name,
                        Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for a Validator to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        All implementations that implement JAXP 1.5 or newer are required to support the XMLConstants.ACCESS_EXTERNAL_DTD and XMLConstants.ACCESS_EXTERNAL_SCHEMA properties.

        • Access to external DTDs in source or Schema file is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_DTD property. If access is denied during validation due to the restriction of this property, SAXException will be thrown by the validate(Source) method.

          Access to external reference set by the schemaLocation attribute is restricted to the protocols specified by the XMLConstants.ACCESS_EXTERNAL_SCHEMA property. If access is denied during validation due to the restriction of this property, SAXException will be thrown by the validate(Source) method.

        Parameters:
        name - The property name, which is a non-null fully-qualified URI.
        object - The requested value for the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the Validator recognizes the property name but cannot set the requested value.
        NullPointerException - When the name parameter is null.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for a Validator to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a validation.

        Validators are not required to recognize any specific property names.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        Parameters:
        name - The property name, which is a non-null fully-qualified URI.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        NullPointerException - When the name parameter is null.
        See Also:
        setProperty(String, Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValidatorHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.validation

Class ValidatorHandler

  • java.lang.Object
    • javax.xml.validation.ValidatorHandler
  • All Implemented Interfaces:
    ContentHandler

    public abstract class ValidatorHandler
extends Object
implements ContentHandler
    Streaming validator that works on SAX stream.

    A ValidatorHandler object is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one ValidatorHandler object is not used from more than one thread at any given time.

    ValidatorHandler checks if the SAX events follow the set of constraints described in the associated Schema, and additionally it may modify the SAX events (for example by adding default values, etc.)

    ValidatorHandler extends from ContentHandler, but it refines the underlying ContentHandler in the following way:

    1. startElement/endElement events must receive non-null String for uri, localName, and qname, even though SAX allows some of them to be null. Similarly, the user-specified ContentHandler will receive non-null Strings for all three parameters.
    2. Applications must ensure that ValidatorHandler's ContentHandler.startPrefixMapping(String,String) and ContentHandler.endPrefixMapping(String) are invoked properly. Similarly, the user-specified ContentHandler will receive startPrefixMapping/endPrefixMapping events. If the ValidatorHandler introduces additional namespace bindings, the user-specified ContentHandler will receive additional startPrefixMapping/endPrefixMapping events.
    3. Attributes for the ContentHandler.startElement(String,String,String,Attributes) method may or may not include xmlns* attributes.

    A ValidatorHandler is automatically reset every time the startDocument method is invoked.

    Recognized Properties and Features

    This spec defines the following feature that must be recognized by all ValidatorHandler implementations.

    http://xml.org/sax/features/namespace-prefixes

    This feature controls how a ValidatorHandler introduces namespace bindings that were not present in the original SAX event stream. When this feature is set to true, it must make sure that the user's ContentHandler will see the corresponding xmlns* attribute in the Attributes object of the ContentHandler.startElement(String,String,String,Attributes) callback. Otherwise, xmlns* attributes must not be added to Attributes that's passed to the user-specified ContentHandler.

    (Note that regardless of this switch, namespace bindings are always notified to applications through ContentHandler.startPrefixMapping(String,String) and ContentHandler.endPrefixMapping(String) methods of the ContentHandler specified by the user.)

    Note that this feature does NOT affect the way a ValidatorHandler receives SAX events. It merely changes the way it augments SAX events.

    This feature is set to false by default.

    Since:
    1.5

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected ValidatorHandler()
      Constructor for derived classes.

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract ContentHandler getContentHandler()
      Gets the ContentHandler which receives the augmented validation result.
      abstract ErrorHandler getErrorHandler()
      Gets the current ErrorHandler set to this ValidatorHandler.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      abstract LSResourceResolver getResourceResolver()
      Gets the current LSResourceResolver set to this ValidatorHandler.
      abstract TypeInfoProvider getTypeInfoProvider()
      Obtains the TypeInfoProvider implementation of this ValidatorHandler.
      abstract void setContentHandler(ContentHandler receiver)
      Sets the ContentHandler which receives the augmented validation result.
      abstract void setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validation.
      void setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void setProperty(String name, Object object)
      Set the value of a property.
      abstract void setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • Constructor Detail

      • ValidatorHandler

        protected ValidatorHandler()

        Constructor for derived classes.

        The constructor does nothing.

        Derived classes must create ValidatorHandler objects that have null ErrorHandler and null LSResourceResolver.

    • Method Detail

      • setContentHandler

        public abstract void setContentHandler(ContentHandler receiver)
        Sets the ContentHandler which receives the augmented validation result.

        When a ContentHandler is specified, a ValidatorHandler will work as a filter and basically copy the incoming events to the specified ContentHandler.

        In doing so, a ValidatorHandler may modify the events, for example by adding defaulted attributes.

        A ValidatorHandler may buffer events to certain extent, but to allow ValidatorHandler to be used by a parser, the following requirement has to be met.

        1. When ContentHandler.startElement(String, String, String, Attributes), ContentHandler.endElement(String, String, String), ContentHandler.startDocument(), or ContentHandler.endDocument() are invoked on a ValidatorHandler, the same method on the user-specified ContentHandler must be invoked for the same event before the callback returns.
        2. ValidatorHandler may not introduce new elements that were not present in the input.
        3. ValidatorHandler may not remove attributes that were present in the input.

        When a callback method on the specified ContentHandler throws an exception, the same exception object must be thrown from the ValidatorHandler. The ErrorHandler should not be notified of such an exception.

        This method can be called even during a middle of a validation.

        Parameters:
        receiver - A ContentHandler or a null value.

      • getContentHandler

        public abstract ContentHandler getContentHandler()
        Gets the ContentHandler which receives the augmented validation result.
        Returns:
        This method returns the object that was last set through the getContentHandler() method, or null if that method has never been called since this ValidatorHandler has created.
        See Also:
        setContentHandler(ContentHandler)

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler errorHandler)
        Sets the ErrorHandler to receive errors encountered during the validation.

        Error handler can be used to customize the error handling process during a validation. When an ErrorHandler is set, errors found during the validation will be first sent to the ErrorHandler.

        The error handler can abort further validation immediately by throwing SAXException from the handler. Or for example it can print an error to the screen and try to continue the validation by returning normally from the ErrorHandler

        If any Throwable is thrown from an ErrorHandler, the same Throwable object will be thrown toward the root of the call stack.

        ValidatorHandler is not allowed to throw SAXException without first reporting it to ErrorHandler.

        When the ErrorHandler is null, the implementation will behave as if the following ErrorHandler is set:

         class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

        When a new ValidatorHandler object is created, initially this field is set to null.

        Parameters:
        errorHandler - A new error handler to be set. This parameter can be null.

      • getErrorHandler

        public abstract ErrorHandler getErrorHandler()
        Gets the current ErrorHandler set to this ValidatorHandler.
        Returns:
        This method returns the object that was last set through the setErrorHandler(ErrorHandler) method, or null if that method has never been called since this ValidatorHandler has created.
        See Also:
        setErrorHandler(ErrorHandler)

      • setResourceResolver

        public abstract void setResourceResolver(LSResourceResolver resourceResolver)
        Sets the LSResourceResolver to customize resource resolution while in a validation episode.

        ValidatorHandler uses a LSResourceResolver when it needs to locate external resources while a validation, although exactly what constitutes "locating external resources" is up to each schema language.

        When the LSResourceResolver is null, the implementation will behave as if the following LSResourceResolver is set:

         class DumbLSResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

        If a LSResourceResolver throws a RuntimeException (or instances of its derived classes), then the ValidatorHandler will abort the parsing and the caller of the validate method will receive the same RuntimeException.

        When a new ValidatorHandler object is created, initially this field is set to null.

        Parameters:
        resourceResolver - A new resource resolver to be set. This parameter can be null.

      • getResourceResolver

        public abstract LSResourceResolver getResourceResolver()
        Gets the current LSResourceResolver set to this ValidatorHandler.
        Returns:
        This method returns the object that was last set through the setResourceResolver(LSResourceResolver) method, or null if that method has never been called since this ValidatorHandler has created.
        See Also:
        setErrorHandler(ErrorHandler)

      • getTypeInfoProvider

        public abstract TypeInfoProvider getTypeInfoProvider()
        Obtains the TypeInfoProvider implementation of this ValidatorHandler.

        The obtained TypeInfoProvider can be queried during a parse to access the type information determined by the validator.

        Some schema languages do not define the notion of type, for those languages, this method may not be supported. However, to be compliant with this specification, implementations for W3C XML Schema 1.0 must support this operation.

        Returns:
        null if the validator / schema language does not support the notion of TypeInfo. Otherwise a non-null valid TypeInfoProvider.

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for a ValidatorHandler to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a validation.

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        Parameters:
        name - The feature name, which is a non-null fully-qualified URI.
        Returns:
        The current value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the ValidatorHandler recognizes the feature name but cannot determine its value at this time.
        NullPointerException - When name is null.
        See Also:
        setFeature(String, boolean)

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException

        Set a feature for this ValidatorHandler.

        Feature can be used to control the way a ValidatorHandler parses schemas. The feature name is any fully-qualified URI. It is possible for a SchemaFactory to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See setErrorHandler(ErrorHandler errorHandler).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        Parameters:
        name - The feature name, which is a non-null fully-qualified URI.
        value - The requested value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the ValidatorHandler recognizes the feature name but cannot set the requested value.
        NullPointerException - When name is null.
        See Also:
        getFeature(String)

      • setProperty

        public void setProperty(String name,
                        Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for a ValidatorHandler to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        ValidatorHandlers are not required to recognize setting any specific property names.

        Parameters:
        name - The property name, which is a non-null fully-qualified URI.
        object - The requested value for the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the ValidatorHandler recognizes the property name but cannot set the requested value.
        NullPointerException - When name is null.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for a ValidatorHandler to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a validation.

        ValidatorHandlers are not required to recognize any specific property names.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        Parameters:
        name - The property name, which is a non-null fully-qualified URI.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        NullPointerException - When name is null.
        See Also:
        setProperty(String, Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.Schema (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.Schema

  • Packages that use Schema
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of Schema in javax.xml.bind

      Methods in javax.xml.bind that return Schema
      Modifier and Type Method and Description
      Schema Marshaller.getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      abstract Schema Binder.getSchema()
      Gets the last Schema object (including null) set by the Binder.setSchema(Schema) method.
      Schema Unmarshaller.getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      Methods in javax.xml.bind with parameters of type Schema
      Modifier and Type Method and Description
      void Marshaller.setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.
      abstract void Binder.setSchema(Schema schema)
      Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
      void Unmarshaller.setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.

    • Uses of Schema in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Schema
      Modifier and Type | Method and Description
      Schema | AbstractMarshallerImpl.getSchema()
      Schema | AbstractUnmarshallerImpl.getSchema()
      Methods in javax.xml.bind.helpers with parameters of type Schema
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.setSchema(Schema schema)
      void | AbstractUnmarshallerImpl.setSchema(Schema schema)

    • Uses of Schema in javax.xml.parsers

      Methods in javax.xml.parsers that return Schema
      Modifier and Type Method and Description
      Schema DocumentBuilder.getSchema()
      Get a reference to the the Schema being used by the XML processor.
      Schema SAXParserFactory.getSchema()
      Gets the Schema object specified through the SAXParserFactory.setSchema(Schema schema) method.
      Schema DocumentBuilderFactory.getSchema()
      Gets the Schema object specified through the DocumentBuilderFactory.setSchema(Schema schema) method.
      Schema SAXParser.getSchema()
      Get a reference to the the Schema being used by the XML processor.
      Methods in javax.xml.parsers with parameters of type Schema
      Modifier and Type Method and Description
      void SAXParserFactory.setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.
      void DocumentBuilderFactory.setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.

    • Uses of Schema in javax.xml.validation

      Methods in javax.xml.validation that return Schema
      Modifier and Type Method and Description
      abstract Schema SchemaFactory.newSchema()
      Creates a special Schema object.
      Schema SchemaFactory.newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema SchemaFactory.newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.SchemaFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.SchemaFactory

  • Packages that use SchemaFactory
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of SchemaFactory in javax.xml.validation

      Methods in javax.xml.validation that return SchemaFactory
      Modifier and Type Method and Description
      abstract SchemaFactory SchemaFactoryLoader.newFactory(String schemaLanguage)
      Creates a new SchemaFactory object for the specified schema language.
      static SchemaFactory SchemaFactory.newInstance(String schemaLanguage)
      Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.
      static SchemaFactory SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SchemaFactory from class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.SchemaFactoryConfigurationError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.SchemaFactoryConfigurationError

No usage of javax.xml.validation.SchemaFactoryConfigurationError
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.SchemaFactoryLoader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.SchemaFactoryLoader

No usage of javax.xml.validation.SchemaFactoryLoader
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.TypeInfoProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.TypeInfoProvider

  • Packages that use TypeInfoProvider
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of TypeInfoProvider in javax.xml.validation

      Methods in javax.xml.validation that return TypeInfoProvider
      Modifier and Type Method and Description
      abstract TypeInfoProvider ValidatorHandler.getTypeInfoProvider()
      Obtains the TypeInfoProvider implementation of this ValidatorHandler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.Validator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.Validator

  • Packages that use Validator
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of Validator in javax.xml.validation

      Methods in javax.xml.validation that return Validator
      Modifier and Type Method and Description
      abstract Validator Schema.newValidator()
      Creates a new Validator for this Schema.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.validation.ValidatorHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.validation.ValidatorHandler

  • Packages that use ValidatorHandler
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of ValidatorHandler in javax.xml.validation

      Methods in javax.xml.validation that return ValidatorHandler
      Modifier and Type Method and Description
      abstract ValidatorHandler Schema.newValidatorHandler()
      Creates a new ValidatorHandler for this Schema.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Action (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type Action

  • @Documented
 @Retention(value=RUNTIME)
 @Target(value=METHOD)
public @interface Action
    The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.

    This annotation can be specified on each method of a service endpoint interface. For such a method, the mapped operation in the generated WSDL's wsam:Action attribute on the WSDL input, output and fault messages of the WSDL operation is based upon which attributes of the Action annotation have been specified. For the exact computation of wsam:Action values for the messages, refer to the algorithm in the JAX-WS specification.

    Example 1: Specify explicit values for Action message addressing property for input and output messages.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         input="http://example.com/inputAction",
         output="http://example.com/outputAction")
     public int addNumbers(int number1, int number2) {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         <input message="tns:AddNumbersInput" name="foo"
           wsam:Action="http://example.com/inputAction"/>
         <output message="tns:AddNumbersOutput" name="bar"
           wsam:Action="http://example.com/outputAction"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 2: Specify explicit value for Action message addressing property for only the input message. The wsam:Action values for the WSDL output message are computed using the algorithm in the JAX-WS specification.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(input="http://example.com/inputAction")
     public int addNumbers(int number1, int number2) {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         <input message="tns:AddNumbersInput" name="foo"
           wsam:Action="http://example.com/inputAction" />
         <output message="tns:AddNumbersOutput" name="bar"
           wsam:Action="http://example.com/numbers/AddNumbersPortType/AddNumbersResponse"/>
       </operation>
     </portType>
     ...
   </definitions>
    It is legitimate to specify an explicit value for Action message addressing property for output message only. In this case, wsam:Action value for the WSDL input message is computed using the algorithm in the JAX-WS specification.

    Example 3: See FaultAction annotation for an example of how to specify an explicit value for Action message addressing property for the fault message.

    Since:
    JAX-WS 2.1
    See Also:
    FaultAction

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      FaultAction[] fault
      Explicit value of the WS-Addressing Action message addressing property for the fault message(s) of the operation.
      String input
      Explicit value of the WS-Addressing Action message addressing property for the input message of the operation.
      String output
      Explicit value of the WS-Addressing Action message addressing property for the output message of the operation.

    • Element Detail

      • input

        public abstract String input
        Explicit value of the WS-Addressing Action message addressing property for the input message of the operation.
        Default:
        ""

      • output

        public abstract String output
        Explicit value of the WS-Addressing Action message addressing property for the output message of the operation.
        Default:
        ""

      • fault

        public abstract FaultAction[] fault
        Explicit value of the WS-Addressing Action message addressing property for the fault message(s) of the operation. Each exception that is mapped to a fault and requires an explicit WS-Addressing Action message addressing property, needs to be specified as a value in this property using FaultAction annotation.
        Default:
        {}
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AsyncHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface AsyncHandler<T>

  • public interface AsyncHandler<T>
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void handleResponse(Response<T> res)
      Called when the response to an asynchronous operation is available.

    • Method Detail

      • handleResponse

        void handleResponse(Response<T> res)
        Called when the response to an asynchronous operation is available.
        Parameters:
        res - The response to the operation invocation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Binding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Binding

  • All Known Subinterfaces:
    HTTPBinding, SOAPBinding

    public interface Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getBindingID()
      Get the URI for this binding instance.
      List<Handler> getHandlerChain()
      Gets a copy of the handler chain for a protocol binding instance.
      void setHandlerChain(List<Handler> chain)
      Sets the handler chain for the protocol binding instance.

    • Method Detail

      • getHandlerChain

        List<Handler> getHandlerChain()
        Gets a copy of the handler chain for a protocol binding instance. If the returned chain is modified a call to setHandlerChain is required to configure the binding instance with the new chain.
        Returns:
        java.util.List<Handler> Handler chain

      • setHandlerChain

        void setHandlerChain(List<Handler> chain)
        Sets the handler chain for the protocol binding instance.
        Parameters:
        chain - A List of handler configuration entries
        Throws:
        WebServiceException - On an error in the configuration of the handler chain
        UnsupportedOperationException - If this operation is not supported. This may be done to avoid any overriding of a pre-configured handler chain.

      • getBindingID

        String getBindingID()
        Get the URI for this binding instance.
        Returns:
        String The binding identifier for the port. Never returns null
        Since:
        JAX-WS 2.1
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface BindingProvider

  • All Known Subinterfaces:
    Dispatch<T>

    public interface BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Since:
    JAX-WS 2.0
    See Also:
    Binding

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ENDPOINT_ADDRESS_PROPERTY
      Standard property: Target service endpoint address.
      static String PASSWORD_PROPERTY
      Standard property: Password for authentication.
      static String SESSION_MAINTAIN_PROPERTY
      Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
      static String SOAPACTION_URI_PROPERTY
      Standard property for SOAPAction.
      static String SOAPACTION_USE_PROPERTY
      Standard property for SOAPAction.
      static String USERNAME_PROPERTY
      Standard property: User name for authentication.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Binding getBinding()
      Get the Binding for this binding provider.
      EndpointReference getEndpointReference()
      Returns the EndpointReference associated with this BindingProvider instance.
      <T extends EndpointReference>
      T             		getEndpointReference(Class<T> clazz)
      Returns the EndpointReference associated with this BindingProvider instance.
      Map<String,Object> getRequestContext()
      Get the context that is used to initialize the message context for request messages.
      Map<String,Object> getResponseContext()
      Get the context that resulted from processing a response message.

    • Field Detail

      • USERNAME_PROPERTY

        static final String USERNAME_PROPERTY
        Standard property: User name for authentication.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • PASSWORD_PROPERTY

        static final String PASSWORD_PROPERTY
        Standard property: Password for authentication.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • ENDPOINT_ADDRESS_PROPERTY

        static final String ENDPOINT_ADDRESS_PROPERTY
        Standard property: Target service endpoint address. The URI scheme for the endpoint address specification MUST correspond to the protocol/transport binding for the binding in use.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SESSION_MAINTAIN_PROPERTY

        static final String SESSION_MAINTAIN_PROPERTY
        Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

      • SOAPACTION_USE_PROPERTY

        static final String SOAPACTION_USE_PROPERTY
        Standard property for SOAPAction. This boolean property indicates whether or not the value of the javax.xml.ws.soap.http.soapaction.uri property is used for the value of the SOAPAction. The default value of this property is false indicating that the javax.xml.ws.soap.http.soapaction.uri property is not used for the value of the SOAPAction, however, if WS-Addressing is enabled, the default value is true.

        Type: java.lang.Boolean

        See Also:
        Constant Field Values

      • SOAPACTION_URI_PROPERTY

        static final String SOAPACTION_URI_PROPERTY
        Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.ws.soap.http.soapaction.use property is set to true. If WS-Addressing is enabled, this value will also be used for the value of the WS-Addressing Action header. If this property is not set, the default SOAPAction and WS-Addressing Action will be sent.

        Type: java.lang.String

        See Also:
        Constant Field Values

    • Method Detail

      • getRequestContext

        Map<String,Object> getRequestContext()
        Get the context that is used to initialize the message context for request messages. Modifications to the request context do not affect the message context of either synchronous or asynchronous operations that have already been started.
        Returns:
        The context that is used in processing request messages.

      • getResponseContext

        Map<String,Object> getResponseContext()
        Get the context that resulted from processing a response message. The returned context is for the most recently completed synchronous operation. Subsequent synchronous operation invocations overwrite the response context. Asynchronous operations return their response context via the Response interface.
        Returns:
        The context that resulted from processing the latest response messages.

      • getBinding

        Binding getBinding()
        Get the Binding for this binding provider.
        Returns:
        The Binding for this binding provider.

      • getEndpointReference

        EndpointReference getEndpointReference()
        Returns the EndpointReference associated with this BindingProvider instance.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        Returns:
        EndpointReference of the target endpoint associated with this BindingProvider instance.
        Throws:
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1
        See Also:
        W3CEndpointReference

      • getEndpointReference

        <T extends EndpointReference> T getEndpointReference(Class<T> clazz)
        Returns the EndpointReference associated with this BindingProvider instance. The instance returned will be of type clazz.
        Parameters:
        clazz - Specifies the type of EndpointReference that MUST be returned.
        Returns:
        EndpointReference of the target endpoint associated with this BindingProvider instance. MUST be of type clazz.
        Throws:
        WebServiceException - If the Class clazz is not supported by this implementation.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type BindingType

  • @Target(value=TYPE)
 @Retention(value=RUNTIME)
 @Documented
public @interface BindingType
    The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.

    This annotation may be overriden programmatically or via deployment descriptors, depending on the platform in use.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      A binding identifier (a URI).

    • Element Detail

      • value

        public abstract String value
        A binding identifier (a URI). If not specified, the default is the SOAP 1.1 / HTTP binding.

        See the SOAPBinding and HTTPBinding for the definition of the standard binding identifiers.

        See Also:
        Binding, SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Dispatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Dispatch<T>

  • All Superinterfaces:
    BindingProvider

    public interface Dispatch<T>
extends BindingProvider
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations. The javax.xml.ws.Service class acts as a factory for the creation of Dispatch instances.
    Since:
    JAX-WS 2.0

    • Field Summary

      • Fields inherited from interface javax.xml.ws.BindingProvider

        ENDPOINT_ADDRESS_PROPERTY, PASSWORD_PROPERTY, SESSION_MAINTAIN_PROPERTY, SOAPACTION_URI_PROPERTY, SOAPACTION_USE_PROPERTY, USERNAME_PROPERTY

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      T invoke(T msg)
      Invoke a service operation synchronously.
      Response<T> invokeAsync(T msg)
      Invoke a service operation asynchronously.
      Future<?> invokeAsync(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
      void invokeOneWay(T msg)
      Invokes a service operation using the one-way interaction mode.

      • Methods inherited from interface javax.xml.ws.BindingProvider

        getBinding, getEndpointReference, getEndpointReference, getRequestContext, getResponseContext

    • Method Detail

      • invoke

        T invoke(T msg)
        Invoke a service operation synchronously. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.
        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        Returns:
        The response message or message payload to the operation invocation.
        Throws:
        WebServiceException - If a fault occurs during communication with the service
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeAsync

        Response<T> invokeAsync(T msg)
        Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are obtained by polling the returned Response.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        Returns:
        The response message or message payload to the operation invocation.
        Throws:
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeAsync

        Future<?> invokeAsync(T msg,
                      AsyncHandler<T> handler)
        Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are communicated to the client via the passed in handler.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        handler - The handler object that will receive the response to the operation invocation.
        Returns:
        A Future object that may be used to check the status of the operation invocation. This object MUST NOT be used to try to obtain the results of the operation - the object returned from Future<?>.get() is implementation dependent and any use of it will result in non-portable behaviour.
        Throws:
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeOneWay

        void invokeOneWay(T msg)
        Invokes a service operation using the one-way interaction mode. The operation invocation is logically non-blocking, subject to the capabilities of the underlying protocol, no results are returned. When the protocol in use is SOAP/HTTP, this method MUST block until an HTTP response code has been received or an error occurs.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        Parameters:
        msg - An object that will form the message or payload of the message used to invoke the operation.
        Throws:
        WebServiceException - If there is any error in the configuration of the Dispatch instance or if an error occurs during the invocation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Endpoint (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class Endpoint

  • java.lang.Object
    • javax.xml.ws.Endpoint

  • public abstract class Endpoint
extends Object
    A Web service endpoint.

    Endpoints are created using the static methods defined in this class. An endpoint is always tied to one Binding and one implementor, both set at endpoint creation time.

    An endpoint is either in a published or an unpublished state. The publish methods can be used to start publishing an endpoint, at which point it starts accepting incoming requests. Conversely, the stop method can be used to stop accepting incoming requests and take the endpoint down. Once stopped, an endpoint cannot be published again.

    An Executor may be set on the endpoint in order to gain better control over the threads used to dispatch incoming requests. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the endpoint.

    Handler chains can be set using the contained Binding.

    An endpoint may have a list of metadata documents, such as WSDL and XMLSchema documents, bound to it. At publishing time, the JAX-WS implementation will try to reuse as much of that metadata as possible instead of generating new ones based on the annotations present on the implementor.

    Since:
    JAX-WS 2.0
    See Also:
    Binding, BindingType, SOAPBinding, Executor

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String WSDL_PORT
      Standard property: name of WSDL port.
      static String WSDL_SERVICE
      Standard property: name of WSDL service.

    • Constructor Summary

      Constructors
      Constructor and Description
      Endpoint()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      static Endpoint create(Object implementor)
      Creates an endpoint with the specified implementor object.
      static Endpoint create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Endpoint create(String bindingId, Object implementor)
      Creates an endpoint with the specified binding type and implementor object.
      static Endpoint create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      abstract Binding getBinding()
      Returns the binding for this endpoint.
      abstract <T extends EndpointReference>
      T             		getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      abstract EndpointReference getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      abstract Executor getExecutor()
      Returns the executor for this Endpointinstance.
      abstract Object getImplementor()
      Returns the implementation object for this endpoint.
      abstract List<Source> getMetadata()
      Returns a list of metadata documents for the service.
      abstract Map<String,Object> getProperties()
      Returns the property bag for this Endpoint instance.
      abstract boolean isPublished()
      Returns true if the endpoint is in the published state.
      void publish(HttpContext serverContext)
      Publishes this endpoint at the provided server context.
      abstract void publish(Object serverContext)
      Publishes this endpoint at the provided server context.
      abstract void publish(String address)
      Publishes this endpoint at the given address.
      static Endpoint publish(String address, Object implementor)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      static Endpoint publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      void setEndpointContext(EndpointContext ctxt)
      By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.
      abstract void setExecutor(Executor executor)
      Sets the executor for this Endpoint instance.
      abstract void setMetadata(List<Source> metadata)
      Sets the metadata for this endpoint.
      abstract void setProperties(Map<String,Object> properties)
      Sets the property bag for this Endpoint instance.
      abstract void stop()
      Stops publishing this endpoint.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • WSDL_SERVICE

        public static final String WSDL_SERVICE
        Standard property: name of WSDL service.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_PORT

        public static final String WSDL_PORT
        Standard property: name of WSDL port.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

    • Constructor Detail

      • Endpoint

        public Endpoint()

    • Method Detail

      • create

        public static Endpoint create(Object implementor)
        Creates an endpoint with the specified implementor object. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        implementor - The endpoint implementor.
        Returns:
        The newly created endpoint.

      • create

        public static Endpoint create(Object implementor,
                              WebServiceFeature... features)
        Creates an endpoint with the specified implementor object and web service features. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • create

        public static Endpoint create(String bindingId,
                              Object implementor)
        Creates an endpoint with the specified binding type and implementor object.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
        implementor - The endpoint implementor.
        Returns:
        The newly created endpoint.

      • create

        public static Endpoint create(String bindingId,
                              Object implementor,
                              WebServiceFeature... features)
        Creates an endpoint with the specified binding type, implementor object, and web service features.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        Parameters:
        bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • getBinding

        public abstract Binding getBinding()
        Returns the binding for this endpoint.
        Returns:
        The binding for this endpoint

      • getImplementor

        public abstract Object getImplementor()
        Returns the implementation object for this endpoint.
        Returns:
        The implementor for this endpoint

      • publish

        public abstract void publish(String address)
        Publishes this endpoint at the given address. The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the publish(Object) method instead.
        Parameters:
        address - A URI specifying the address to use. The address MUST be compatible with the binding specified at the time the endpoint was created.
        Throws:
        IllegalArgumentException - If the provided address URI is not usable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public static Endpoint publish(String address,
                               Object implementor)
        Creates and publishes an endpoint for the specified implementor object at the given address.

        The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the create(String,Object) and publish(Object) methods instead.

        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - The endpoint implementor.
        Returns:
        The newly created endpoint.
        Throws:
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public static Endpoint publish(String address,
                               Object implementor,
                               WebServiceFeature... features)
        Creates and publishes an endpoint for the specified implementor object at the given address. The created endpoint is configured with the web service features.

        The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the create(String,Object) and publish(Object) methods instead.

        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Throws:
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.
        Since:
        JAX-WS 2.2

      • publish

        public abstract void publish(Object serverContext)
        Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it MUST be compatible with the endpoint's binding.
        Parameters:
        serverContext - An object representing a server context to be used for publishing the endpoint.
        Throws:
        IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public void publish(HttpContext serverContext)
        Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it MUST be compatible with the endpoint's binding.

        This is meant for container developers to publish the the endpoints portably and not intended for the end developers.

        Parameters:
        serverContext - An object representing a server context to be used for publishing the endpoint.
        Throws:
        IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.
        Since:
        JAX-WS 2.2

      • stop

        public abstract void stop()
        Stops publishing this endpoint. If the endpoint is not in a published state, this method has no effect.

      • isPublished

        public abstract boolean isPublished()
        Returns true if the endpoint is in the published state.
        Returns:
        true if the endpoint is in the published state.

      • getMetadata

        public abstract List<Source> getMetadata()
        Returns a list of metadata documents for the service.
        Returns:
        List<javax.xml.transform.Source> A list of metadata documents for the service

      • setMetadata

        public abstract void setMetadata(List<Source> metadata)
        Sets the metadata for this endpoint.
        Parameters:
        metadata - A list of XML document sources containing metadata information for the endpoint (e.g. WSDL or XML Schema documents)
        Throws:
        IllegalStateException - If the endpoint has already been published.

      • getExecutor

        public abstract Executor getExecutor()
        Returns the executor for this Endpointinstance. The executor is used to dispatch an incoming request to the implementor object.
        Returns:
        The java.util.concurrent.Executor to be used to dispatch a request.
        See Also:
        Executor

      • setExecutor

        public abstract void setExecutor(Executor executor)
        Sets the executor for this Endpoint instance. The executor is used to dispatch an incoming request to the implementor object. If this Endpoint is published using the publish(Object) method and the specified server context defines its own threading behavior, the executor may be ignored.
        Parameters:
        executor - The java.util.concurrent.Executor to be used to dispatch a request.
        Throws:
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        See Also:
        Executor

      • getProperties

        public abstract Map<String,Object> getProperties()
        Returns the property bag for this Endpoint instance.
        Returns:
        Map<String,Object> The property bag associated with this instance.

      • setProperties

        public abstract void setProperties(Map<String,Object> properties)
        Sets the property bag for this Endpoint instance.
        Parameters:
        properties - The property bag associated with this instance.

      • getEndpointReference

        public abstract EndpointReference getEndpointReference(Element... referenceParameters)
        Returns the EndpointReference associated with this Endpoint instance.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        Parameters:
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of this Endpoint instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        WebServiceException - If any error in the creation of the EndpointReference or if the Endpoint is not in the published state.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1
        See Also:
        W3CEndpointReference

      • getEndpointReference

        public abstract <T extends EndpointReference> T getEndpointReference(Class<T> clazz,
                                                                     Element... referenceParameters)
        Returns the EndpointReference associated with this Endpoint instance.
        Parameters:
        clazz - Specifies the type of EndpointReference that MUST be returned.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of type clazz of this Endpoint instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        WebServiceException - If any error in the creation of the EndpointReference or if the Endpoint is not in the published state or if the clazz is not a supported EndpointReference type.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        Since:
        JAX-WS 2.1

      • setEndpointContext

        public void setEndpointContext(EndpointContext ctxt)
        By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application. If multiple endpoints share different ports of a WSDL, then the multiple port addresses are patched when the WSDL is accessed.

        This needs to be set before publishing the endpoints.

        Parameters:
        ctxt - that is shared for multiple endpoints
        Throws:
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        Since:
        JAX-WS 2.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EndpointContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class EndpointContext

  • java.lang.Object
    • javax.xml.ws.EndpointContext

  • public abstract class EndpointContext
extends Object
    EndpointContext allows multiple endpoints in an application to share any information. For example, servlet application's war may contain multiple endpoints and these endpoints can get addresses of each other by sharing this context. If multiple endpoints share different ports of a WSDL, then the multiple port addresses can be patched when the WSDL is accessed. It also allows all endpoints to share any other runtime information.

    This needs to be set by using Endpoint.setEndpointContext(javax.xml.ws.EndpointContext) before Endpoint.publish(java.lang.String) methods.

    Since:
    JAX-WS 2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      EndpointContext()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract Set<Endpoint> getEndpoints()
      This gives list of endpoints in an application.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • EndpointContext

        public EndpointContext()

    • Method Detail

      • getEndpoints

        public abstract Set<Endpoint> getEndpoints()
        This gives list of endpoints in an application. For e.g in servlet container, a war file may contain multiple endpoints. In case of http, these endpoints are hosted on the same http server.
        Returns:
        list of all endpoints in an application
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EndpointReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class EndpointReference

  • java.lang.Object
    • javax.xml.ws.EndpointReference
  • Direct Known Subclasses:
    W3CEndpointReference

    public abstract class EndpointReference
extends Object
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint. See Web Services Addressing 1.0 - Core for more information on WS-Addressing EndpointReferences.

    This class is immutable as the typical web service developer need not be concerned with its contents. The web service developer should use this class strictly as a mechanism to reference a remote web service endpoint. See the Service APIs that clients can use to that utilize an EndpointReference. See the Endpoint, and BindingProvider APIs on how EndpointReferences can be created for published endpoints.

    Concrete implementations of this class will represent an EndpointReference for a particular version of Addressing. For example the W3CEndpointReference is for use with W3C Web Services Addressing 1.0 - Core Recommendation. If JAX-WS implementors need to support different versions of addressing, they should write their own EndpointReference subclass for that version. This will allow a JAX-WS implementation to create a vendor specific EndpointReferences that the vendor can use to flag a different version of addressing.

    Web service developers that wish to pass or return EndpointReference in Java methods in an SEI should use concrete instances of an EndpointReference such as the W3CEndpointReference. This way the schema mapped from the SEI will be more descriptive of the type of endpoint reference being passed.

    JAX-WS implementors are expected to extract the XML infoset from an EndpointReferece using the writeTo(javax.xml.transform.Result) method.

    JAXB will bind this class to xs:anyType. If a better binding is desired, web services developers should use a concrete subclass such as W3CEndpointReference.

    Since:
    JAX-WS 2.1
    See Also:
    W3CEndpointReference, Service

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | EndpointReference()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      <T> T getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static EndpointReference readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      String toString()
      Displays EPR infoset for debugging convenience.
      abstract void writeTo(Result result)
      write this EndpointReference to the specified infoset format

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • EndpointReference

        protected EndpointReference()

    • Method Detail

      • readFrom

        public static EndpointReference readFrom(Source eprInfoset)
        Factory method to read an EndpointReference from the infoset contained in eprInfoset. This method delegates to the vendor specific implementation of the Provider.readEndpointReference(javax.xml.transform.Source) method.
        Parameters:
        eprInfoset - The EndpointReference infoset to be unmarshalled
        Returns:
        the EndpointReference unmarshalled from eprInfoset never null
        Throws:
        WebServiceException - if an error occurs while creating the EndpointReference from the eprInfoset
        IllegalArgumentException - if the null eprInfoset value is given.

      • writeTo

        public abstract void writeTo(Result result)
        write this EndpointReference to the specified infoset format
        Parameters:
        result - for writing infoset
        Throws:
        WebServiceException - if there is an error writing the EndpointReference to the specified result.
        IllegalArgumentException - If the null result value is given.

      • getPort

        public <T> T getPort(Class<T> serviceEndpointInterface,
                     WebServiceFeature... features)
        The getPort method returns a proxy. If there are any reference parameters in the EndpointReference instance, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. The EndpointReference instance specifies the endpoint that will be invoked by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL Metadata from this EndpointReference or from annotations on the serviceEndpointInterface. For this method to successfully return a proxy, WSDL metadata MUST be available and the EndpointReference instance MUST contain an implementation understood serviceName metadata.

        Because this port is not created from a Service object, handlers will not automatically be configured, and the HandlerResolver and Executor cannot be get or set for this port. The BindingProvider().getBinding().setHandlerChain() method can be used to manually configure handlers for this port.

        Parameters:
        serviceEndpointInterface - Service endpoint interface
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If this endpointReference is invalid
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        See Also:
        Proxy, WebServiceFeature

      • toString

        public String toString()
        Displays EPR infoset for debugging convenience.
        Overrides:
        toString in class Object
        Returns:
        a string representation of the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FaultAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type FaultAction

  • @Documented
 @Retention(value=RUNTIME)
 @Target(value=METHOD)
public @interface FaultAction
    The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.

    The wsam:Action attribute value in the fault message in the generated WSDL operation mapped for className class is equal to the corresponding value in the FaultAction. For the exact computation of wsam:Action values for the fault messages, refer to the algorithm in the JAX-WS specification.

    Example 1: Specify explicit values for Action message addressing property for the input, output and fault message if the Java method throws only one service specific exception.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         fault = {
             @FaultAction(className=AddNumbersException.class, value="http://example.com/faultAction")
         })
     public int addNumbers(int number1, int number2)
         throws AddNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:AddNumbersException" name="AddNumbersException"
           wsam:Action="http://example.com/faultAction"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 2: Here is an example that shows if the explicit value for Action message addressing property for the service specific exception is not present.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     public int addNumbers(int number1, int number2)
         throws AddNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:addNumbersFault" name="InvalidNumbers"
           wsam:Action="http://example.com/numbers/AddNumbersPortType/AddNumbers/Fault/AddNumbersException"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 3: Here is an example that shows how to specify explicit values for Action message addressing property if the Java method throws more than one service specific exception.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         fault = {
             @FaultAction(className=AddNumbersException.class, value="http://example.com/addFaultAction"),
             @FaultAction(className=TooBigNumbersException.class, value="http://example.com/toobigFaultAction")
         })
     public int addNumbers(int number1, int number2)
         throws AddNumbersException, TooBigNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:addNumbersFault" name="AddNumbersException"
           wsam:Action="http://example.com/addFaultAction"/>
         <fault message="tns:tooBigNumbersFault" name="TooBigNumbersException"
           wsam:Action="http://example.com/toobigFaultAction"/>
       </operation>
     </portType>
     ...
   </definitions>
    Since:
    JAX-WS 2.1

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends Exception> className
      Name of the exception class

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String value
      Value of WS-Addressing Action message addressing property for the exception

    • Element Detail

      • className

        public abstract Class<? extends Exception> className
        Name of the exception class

      • value

        public abstract String value
        Value of WS-Addressing Action message addressing property for the exception
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Holder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class Holder<T>

  • java.lang.Object
    • javax.xml.ws.Holder<T>
  • All Implemented Interfaces:
    Serializable

    public final class Holder<T>
extends Object
implements Serializable
    Holds a value of type T.
    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      T value
      The value contained in the holder.

    • Constructor Summary

      Constructors
      Constructor and Description
      Holder()
      Creates a new holder with a null value.
      Holder(T value)
      Create a new holder with the specified value.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public T value
        The value contained in the holder.

    • Constructor Detail

      • Holder

        public Holder()
        Creates a new holder with a null value.

      • Holder

        public Holder(T value)
        Create a new holder with the specified value.
        Parameters:
        value - The value to be stored in the holder.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LogicalMessage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface LogicalMessage

  • public interface LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Source getPayload()
      Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
      Object getPayload(JAXBContext context)
      Gets the message payload as a JAXB object.
      void setPayload(Object payload, JAXBContext context)
      Sets the message payload
      void setPayload(Source payload)
      Sets the message payload

    • Method Detail

      • getPayload

        Source getPayload()
        Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

        If the returned Source is an instance of DOMSource, then modifications to the encapsulated DOM tree change the message payload in-place, there is no need to susequently call setPayload. Other types of Source provide only read access to the message payload.

        Returns:
        The contained message payload; returns null if no payload is present in this message.

      • setPayload

        void setPayload(Source payload)
        Sets the message payload
        Parameters:
        payload - message payload
        Throws:
        WebServiceException - If any error during the setting of the payload in this message
        UnsupportedOperationException - If this operation is not supported

      • getPayload

        Object getPayload(JAXBContext context)
        Gets the message payload as a JAXB object. Note that there is no connection between the returned object and the message payload, changes to the payload require calling setPayload.
        Parameters:
        context - The JAXBContext that should be used to unmarshall the message payload
        Returns:
        The contained message payload; returns null if no payload is present in this message
        Throws:
        WebServiceException - If an error occurs when using a supplied JAXBContext to unmarshall the payload. The cause of the WebServiceException is the original JAXBException.

      • setPayload

        void setPayload(Object payload,
                JAXBContext context)
        Sets the message payload
        Parameters:
        payload - message payload
        context - The JAXBContext that should be used to marshall the payload
        Throws:
        UnsupportedOperationException - If this operation is not supported
        WebServiceException - If an error occurs when using the supplied JAXBContext to marshall the payload. The cause of the WebServiceException is the original JAXBException.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws (Java Platform SE 8 )

javax.xml.ws

Interfaces

  • AsyncHandler
  • Binding
  • BindingProvider
  • Dispatch
  • LogicalMessage
  • Provider
  • Response
  • WebServiceContext

Classes

  • Endpoint
  • EndpointContext
  • EndpointReference
  • Holder
  • RespectBindingFeature
  • Service
  • WebServiceFeature
  • WebServicePermission

Enums

  • Service.Mode

Exceptions

  • ProtocolException
  • WebServiceException

Annotation Types

  • Action
  • BindingType
  • FaultAction
  • RequestWrapper
  • RespectBinding
  • ResponseWrapper
  • ServiceMode
  • WebEndpoint
  • WebFault
  • WebServiceClient
  • WebServiceProvider
  • WebServiceRef
  • WebServiceRefs


javax.xml.ws (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws

This package contains the core JAX-WS APIs.

See: Description

  • Interface Summary
    Interface Description
    AsyncHandler<T>
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Dispatch<T>
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
    Provider<T>
    Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.
    Response<T>
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
    WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
  • Class Summary
    Class Description
    Endpoint
    A Web service endpoint.
    EndpointContext
    EndpointContext allows multiple endpoints in an application to share any information.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Holder<T>
    Holds a value of type T.
    RespectBindingFeature
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
    Service
    Service objects provide the client view of a Web service.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
    WebServicePermission
    This class defines web service permissions.
  • Enum Summary
    Enum Description
    Service.Mode
    The orientation of a dynamic client or service.
  • Exception Summary
    Exception Description
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
  • Annotation Types Summary
    Annotation Type Description
    Action
    The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.
    BindingType
    The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
    FaultAction
    The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.
    RequestWrapper
    Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime.
    RespectBinding
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
    ResponseWrapper
    Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime.
    ServiceMode
    Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
    WebEndpoint
    Used to annotate the getPortName() methods of a generated service interface.
    WebFault
    Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
    WebServiceClient
    Used to annotate a generated service interface.
    WebServiceProvider
    Used to annotate a Provider implementation class.
    WebServiceRef
    The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it.
    WebServiceRefs
    The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

Package javax.xml.ws Description

This package contains the core JAX-WS APIs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.Endpoint
    • javax.xml.ws.EndpointContext
    • javax.xml.ws.EndpointReference
    • javax.xml.ws.Holder<T> (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.ws.WebServicePermission
    • javax.xml.ws.Service
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.RespectBindingFeature

Interface Hierarchy

  • javax.xml.ws.AsyncHandler<T>
  • javax.xml.ws.Binding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.xml.ws.LogicalMessage
  • javax.xml.ws.Provider<T>
  • javax.xml.ws.WebServiceContext

Annotation Type Hierarchy

  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.FaultAction (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RespectBinding (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.Action (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.Service.Mode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws

  • Packages that use javax.xml.ws
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.ws used by javax.xml.ws
    Class and Description
    AsyncHandler
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Dispatch
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    Endpoint
    A Web service endpoint.
    EndpointContext
    EndpointContext allows multiple endpoints in an application to share any information.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Response
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
    Service
    Service objects provide the client view of a Web service.
    Service.Mode
    The orientation of a dynamic client or service.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.handler
    Class and Description
    LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
  • Classes in javax.xml.ws used by javax.xml.ws.http
    Class and Description
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
  • Classes in javax.xml.ws used by javax.xml.ws.soap
    Class and Description
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.spi
    Class and Description
    Dispatch
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    Endpoint
    A Web service endpoint.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Service
    Service objects provide the client view of a Web service.
    Service.Mode
    The orientation of a dynamic client or service.
    WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.wsaddressing
    Class and Description
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ProtocolException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class ProtocolException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    HTTPException, SOAPFaultException

    public class ProtocolException
extends WebServiceException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding. Subclasses are used to communicate protocol level fault information to clients and may be used on the server to control the protocol specific fault representation.
    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      ProtocolException()
      Constructs a new protocol exception with null as its detail message.
      ProtocolException(String message)
      Constructs a new protocol exception with the specified detail message.
      ProtocolException(String message, Throwable cause)
      Constructs a new runtime exception with the specified detail message and cause.
      ProtocolException(Throwable cause)
      Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ProtocolException

        public ProtocolException()
        Constructs a new protocol exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

      • ProtocolException

        public ProtocolException(String message)
        Constructs a new protocol exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        Parameters:
        message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.

      • ProtocolException

        public ProtocolException(String message,
                         Throwable cause)
        Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.
        Parameters:
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ProtocolException

        public ProtocolException(Throwable cause)
        Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
        Parameters:
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Provider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Provider<T>

  • public interface Provider<T>

    Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.

    Implementations are required to support Provider<Source>, Provider<SOAPMessage> and Provider<DataSource>, depending on the binding in use and the service mode.

    The ServiceMode annotation can be used to control whether the Provider instance will receive entire protocol messages or just message payloads.

    Since:
    JAX-WS 2.0
    See Also:
    Source, SOAPMessage, ServiceMode

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      T invoke(T request)
      Invokes an operation occording to the contents of the request message.

    • Method Detail

      • invoke

        T invoke(T request)
        Invokes an operation occording to the contents of the request message.
        Parameters:
        request - The request message or message payload.
        Returns:
        The response message or message payload. May be null if there is no response.
        Throws:
        WebServiceException - If there is an error processing request. The cause of the WebServiceException may be set to a subclass of ProtocolException to control the protocol level representation of the exception.
        See Also:
        MessageContext, ProtocolException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RequestWrapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type RequestWrapper

  • @Target(value=METHOD)
 @Retention(value=RUNTIME)
 @Documented
public @interface RequestWrapper
    Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime. The default value of the localName is the operationName, as defined in WebMethod annotation and the targetNamespace is the target namespace of the SEI.

    When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String className
      Request wrapper bean name.
      String localName
      Element's local name.
      String partName
      wsdl:part name for the wrapper part
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • localName

        public abstract String localName
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • className

        public abstract String className
        Request wrapper bean name.
        Default:
        ""

      • partName

        public abstract String partName
        wsdl:part name for the wrapper part
        Since:
        JAX-WS 2.2
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RespectBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type RespectBinding

  • @Target(value={TYPE,METHOD,FIELD})
 @Retention(value=RUNTIME)
 @Documented
 @WebServiceFeatureAnnotation(id="javax.xml.ws.RespectBindingFeature",
                             bean=RespectBindingFeature.class)
public @interface RespectBinding
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

    This annotation MUST only be used in conjunction the javax.jws.WebService, WebServiceProvider, WebServiceRef annotations. When used with the javax.jws.WebService annotation this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the RespectBinding annotation.

    This annotation's behaviour is defined by the corresponding feature RespectBindingFeature.

    Since:
    JAX-WS 2.1
    See Also:
    RespectBindingFeature

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled.
        Default:
        true
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RespectBindingFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class RespectBindingFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.RespectBindingFeature

  • public final class RespectBindingFeature
extends WebServiceFeature
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime. This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    This feature is only useful with web services that have an associated WSDL. Enabling this feature requires that a JAX-WS implementation inspect the wsdl:binding for an endpoint at runtime to make sure that all wsdl:extensions that have the required attribute set to true are understood and are being used.

    The following describes the affects of this feature with respect to be enabled or disabled:

    • ENABLED: In this Mode, a JAX-WS runtime MUST assure that all required wsdl:binding extensions(including policies) are either understood and used by the runtime, or explicitly disabled by the web service application. A web service can disable a particular extension if there is a corresponding WebServiceFeature or annotation. Similarly, a web service client can disable particular extension using the corresponding WebServiceFeature while creating a proxy or Dispatch instance. The runtime MUST also make sure that binding of SEI parameters/return values respect the wsdl:binding. With this feature enabled, if a required (wsdl:required="true") wsdl:binding extension is in the WSDL and it is not supported by a JAX-WS runtime and it has not been explicitly turned off by the web service developer, then that JAX-WS runtime MUST behave appropriately based on whether it is on the client or server:
      • Client: runtime MUST throw a WebServiceException no sooner than when one of the methods above is invoked but no later than the first invocation of an endpoint operation.
      • Server: throw a WebServiceException and the endpoint MUST fail to deploy
    • DISABLED: In this Mode, an implementation may choose whether to inspect the wsdl:binding or not and to what degree the wsdl:binding will be inspected. For example, one implementation may choose to behave as if this feature is enabled, another implementation may only choose to verify the SEI's parameter/return type bindings.
    Since:
    JAX-WS 2.1
    See Also:
    AddressingFeature

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      Constant value identifying the RespectBindingFeature

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • Constructor Summary

      Constructors
      Constructor and Description
      RespectBindingFeature()
      Creates an RespectBindingFeature.
      RespectBindingFeature(boolean enabled)
      Creates an RespectBindingFeature

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getID()
      Get the unique identifier for this WebServiceFeature.

      • Methods inherited from class javax.xml.ws.WebServiceFeature

        isEnabled

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        Constant value identifying the RespectBindingFeature
        See Also:
        Constant Field Values

    • Constructor Detail

      • RespectBindingFeature

        public RespectBindingFeature()
        Creates an RespectBindingFeature. The instance created will be enabled.

      • RespectBindingFeature

        public RespectBindingFeature(boolean enabled)
        Creates an RespectBindingFeature
        Parameters:
        enabled - specifies whether this feature should be enabled or not.

    • Method Detail

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        Specified by:
        getID in class WebServiceFeature
        Returns:
        the unique identifier for this feature.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Response (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface Response<T>

  • All Superinterfaces:
    Future<T>

    public interface Response<T>
extends Future<T>
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.

    For asynchronous operation invocations it provides additional methods to check the status of the request. The get(...) methods may throw the standard set of exceptions and their cause may be a RemoteException or a WebServiceException that represents the error that occured during the asynchronous method invocation.

    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Map<String,Object> getContext()
      Gets the contained response context.

      • Methods inherited from interface java.util.concurrent.Future

        cancel, get, get, isCancelled, isDone

    • Method Detail

      • getContext

        Map<String,Object> getContext()
        Gets the contained response context.
        Returns:
        The contained response context. May be null if a response is not yet available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ResponseWrapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type ResponseWrapper

  • @Target(value=METHOD)
 @Retention(value=RUNTIME)
 @Documented
public @interface ResponseWrapper
    Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime. The default value of the localName is the operationName as defined in WebMethod annotation appended with Response and the targetNamespace is the target namespace of the SEI.

    When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String className
      Response wrapper bean name.
      String localName
      Element's local name.
      String partName
      wsdl:part name for the wrapper part
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • localName

        public abstract String localName
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • className

        public abstract String className
        Response wrapper bean name.
        Default:
        ""

      • partName

        public abstract String partName
        wsdl:part name for the wrapper part
        Since:
        JAX-WS 2.2
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Service (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class Service

  • java.lang.Object
    • javax.xml.ws.Service

  • public class Service
extends Object
    Service objects provide the client view of a Web service.

    Service acts as a factory of the following:

    • Proxies for a target service endpoint.
    • Instances of Dispatch for dynamic message-oriented invocation of a remote operation.

    The ports available on a service can be enumerated using the getPorts method. Alternatively, you can pass a service endpoint interface to the unary getPort method and let the runtime select a compatible port.

    Handler chains for all the objects created by a Service can be set by means of a HandlerResolver.

    An Executor may be set on the service in order to gain better control over the threads used to dispatch asynchronous callbacks. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the service.

    Since:
    JAX-WS 2.0
    See Also:
    Provider, HandlerResolver, Executor

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  Service.Mode
      The orientation of a dynamic client or service.

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | Service(URL wsdlDocumentLocation, QName serviceName)
      protected | Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      static Service create(QName serviceName)
      Creates a Service instance.
      static Service create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Executor getExecutor()
      Returns the executor for this Serviceinstance.
      HandlerResolver getHandlerResolver()
      Returns the configured handler resolver.
      <T> T getPort(Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T getPort(QName portName, Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Iterator<QName> getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      QName getServiceName()
      Gets the name of this service.
      URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.
      void setExecutor(Executor executor)
      Sets the executor for this Service instance.
      void setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Service

        protected Service(URL wsdlDocumentLocation,
                  QName serviceName)

      • Service

        protected Service(URL wsdlDocumentLocation,
                  QName serviceName,
                  WebServiceFeature... features)

    • Method Detail

      • getPort

        public <T> T getPort(QName portName,
                     Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description.
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy instance.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface or portName is specified.
        See Also:
        Proxy, InvocationHandler

      • getPort

        public <T> T getPort(QName portName,
                     Class<T> serviceEndpointInterface,
                     WebServiceFeature... features)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description.
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy instance.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface or portName is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Proxy, InvocationHandler, WebServiceFeature

      • getPort

        public <T> T getPort(Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface.
        Returns:
        Object instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface is specified.

      • getPort

        public <T> T getPort(Class<T> serviceEndpointInterface,
                     WebServiceFeature... features)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        WebServiceFeature

      • getPort

        public <T> T getPort(EndpointReference endpointReference,
                     Class<T> serviceEndpointInterface,
                     WebServiceFeature... features)
        The getPort method returns a proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference metadata also has a WSDL, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. The returned proxy should not be reconfigured by the client. If this Service instance has a known proxy port that matches the information contained in the WSDL, then that proxy is returned, otherwise a WebServiceException is thrown.

        Calling this method has the same behavior as the following

         port = service.getPort(portName, serviceEndpointInterface);
        where the portName is retrieved from the metadata of the endpointReference or from the serviceEndpointInterface and the WSDL associated with this Service instance.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName of this Service instance.
        • If a portName cannot be extracted from the WSDL or endpointReference metadata.
        • If an invalid endpointReference is specified.
        • If an invalid serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1

      • addPort

        public void addPort(QName portName,
                    String bindingId,
                    String endpointAddress)
        Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.
        Parameters:
        portName - Qualified name for the target service endpoint.
        bindingId - A String identifier of a binding.
        endpointAddress - Address of the target service endpoint as a URI.
        Throws:
        WebServiceException - If any error in the creation of the port.
        See Also:
        SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

      • createDispatch

        public <T> Dispatch<T> createDispatch(QName portName,
                                      Class<T> type,
                                      Service.Mode mode)
        Creates a Dispatch instance for use with objects of the client's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source, javax.xml.soap.SOAPMessage and javax.activation.DataSource, depending on the binding in use.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object.
        See Also:
        Source, SOAPMessage

      • createDispatch

        public <T> Dispatch<T> createDispatch(QName portName,
                                      Class<T> type,
                                      Service.Mode mode,
                                      WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the client's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public <T> Dispatch<T> createDispatch(EndpointReference endpointReference,
                                      Class<T> type,
                                      Service.Mode mode,
                                      WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the client's choosing. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behaves the same as calling

         dispatch = service.createDispatch(portName, type, mode, features);
        where the portName is retrieved from the WSDL or EndpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public Dispatch<Object> createDispatch(QName portName,
                                       JAXBContext context,
                                       Service.Mode mode)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object.
        See Also:
        JAXBContext

      • createDispatch

        public Dispatch<Object> createDispatch(QName portName,
                                       JAXBContext context,
                                       Service.Mode mode,
                                       WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance.
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • createDispatch

        public Dispatch<Object> createDispatch(EndpointReference endpointReference,
                                       JAXBContext context,
                                       Service.Mode mode,
                                       WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behavies the same as calling

         dispatch = service.createDispatch(portName, context, mode, features);
        where the portName is retrieved from the WSDL or endpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • getServiceName

        public QName getServiceName()
        Gets the name of this service.
        Returns:
        Qualified name of this service

      • getPorts

        public Iterator<QName> getPorts()
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        Returns:
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName.
        Throws:
        WebServiceException - If this Service class does not have access to the required WSDL metadata.

      • getWSDLDocumentLocation

        public URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        Returns:
        URL for the location of the WSDL document for this service.

      • getHandlerResolver

        public HandlerResolver getHandlerResolver()
        Returns the configured handler resolver.
        Returns:
        HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

      • setHandlerResolver

        public void setHandlerResolver(HandlerResolver handlerResolver)
        Sets the HandlerResolver for this Service instance.

        The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

        Parameters:
        handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
        See Also:
        HandlerResolver

      • getExecutor

        public Executor getExecutor()
        Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.
        Returns:
        The java.util.concurrent.Executor to be used to invoke a callback.
        See Also:
        Executor

      • setExecutor

        public void setExecutor(Executor executor)
        Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.
        Parameters:
        executor - The java.util.concurrent.Executor to be used to invoke a callback.
        Throws:
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        See Also:
        Executor

      • create

        public static Service create(URL wsdlDocumentLocation,
                             QName serviceName)
        Creates a Service instance. The specified WSDL document location and service qualified name MUST uniquely identify a wsdl:service element.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        Throws:
        WebServiceException - If any error in creation of the specified service.

      • create

        public static Service create(URL wsdlDocumentLocation,
                             QName serviceName,
                             WebServiceFeature... features)
        Creates a Service instance. The created instance is configured with the web service features. The specified WSDL document location and service qualified name MUST uniquely identify a wsdl:service element.
        Parameters:
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        Throws:
        WebServiceException - If any error in creation of the specified service.
        Since:
        JAX-WS 2.2

      • create

        public static Service create(QName serviceName)
        Creates a Service instance.
        Parameters:
        serviceName - QName for the service
        Throws:
        WebServiceException - If any error in creation of the specified service

      • create

        public static Service create(QName serviceName,
                             WebServiceFeature... features)
        Creates a Service instance. The created instance is configured with the web service features.
        Parameters:
        serviceName - QName for the service
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        Throws:
        WebServiceException - If any error in creation of the specified service
        Since:
        JAX-WS 2.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Service.Mode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.ws

Enum Service.Mode

  • java.lang.Object
    • java.lang.Enum<Service.Mode>
      • javax.xml.ws.Service.Mode
  • All Implemented Interfaces:
    Serializable, Comparable<Service.Mode>
    Enclosing class:
    Service

    public static enum Service.Mode
extends Enum<Service.Mode>
    The orientation of a dynamic client or service. MESSAGE provides access to entire protocol message, PAYLOAD to protocol message payload only.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      MESSAGE
      PAYLOAD

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static Service.Mode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Service.Mode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MESSAGE

        public static final Service.Mode MESSAGE

      • PAYLOAD

        public static final Service.Mode PAYLOAD

    • Method Detail

      • values

        public static Service.Mode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Service.Mode c : Service.Mode.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Service.Mode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceMode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type ServiceMode

  • @Target(value=TYPE)
 @Retention(value=RUNTIME)
 @Inherited
 @Documented
public @interface ServiceMode
    Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      Service.Mode value
      Service mode.

    • Element Detail

      • value

        public abstract Service.Mode value
        Service mode. PAYLOAD indicates that the Provider implementation wishes to work with protocol message payloads only. MESSAGE indicates that the Provider implementation wishes to work with entire protocol messages.
        Default:
        javax.xml.ws.Service.Mode.PAYLOAD
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebEndpoint (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type WebEndpoint

  • @Target(value=METHOD)
 @Retention(value=RUNTIME)
 @Documented
public @interface WebEndpoint
    Used to annotate the getPortName() methods of a generated service interface.

    The information specified in this annotation is sufficient to uniquely identify a wsdl:port element inside a wsdl:service. The latter is determined based on the value of the WebServiceClient annotation on the generated service interface itself.

    Since:
    JAX-WS 2.0
    See Also:
    WebServiceClient

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      The local name of the endpoint.

    • Element Detail

      • name

        public abstract String name
        The local name of the endpoint.
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebFault (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type WebFault

  • @Target(value=TYPE)
 @Retention(value=RUNTIME)
 @Documented
public @interface WebFault
    Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String faultBean
      Fault bean name.
      String messageName
      wsdl:Message's name.
      String name
      Element's local name.
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • name

        public abstract String name
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • faultBean

        public abstract String faultBean
        Fault bean name.
        Default:
        ""

      • messageName

        public abstract String messageName
        wsdl:Message's name. Default name is the exception's class name.
        Since:
        JAX-WS 2.2
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceClient (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type WebServiceClient

  • @Target(value=TYPE)
 @Retention(value=RUNTIME)
 @Documented
public @interface WebServiceClient
    Used to annotate a generated service interface.

    The information specified in this annotation is sufficient to uniquely identify a wsdl:service element inside a WSDL document. This wsdl:service element represents the Web service for which the generated service interface provides a client view.

    Since:
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String name
      The local name of the Web service.
      String targetNamespace
      The namespace for the Web service.
      String wsdlLocation
      The location of the WSDL document for the service (a URL).

    • Element Detail

      • name

        public abstract String name
        The local name of the Web service.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        The namespace for the Web service.
        Default:
        ""

      • wsdlLocation

        public abstract String wsdlLocation
        The location of the WSDL document for the service (a URL).
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Interface WebServiceContext

  • public interface WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served. Typically a WebServiceContext is injected into an endpoint implementation class using the Resource annotation.
    Since:
    JAX-WS 2.0
    See Also:
    Resource

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      <T extends EndpointReference>
      T             		getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      EndpointReference getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      MessageContext getMessageContext()
      Returns the MessageContext for the request being served at the time this method is called.
      Principal getUserPrincipal()
      Returns the Principal that identifies the sender of the request currently being serviced.
      boolean isUserInRole(String role)
      Returns a boolean indicating whether the authenticated user is included in the specified logical role.

    • Method Detail

      • getMessageContext

        MessageContext getMessageContext()
        Returns the MessageContext for the request being served at the time this method is called. Only properties with APPLICATION scope will be visible to the application.
        Returns:
        MessageContext The message context.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        See Also:
        MessageContext, MessageContext.Scope, IllegalStateException

      • getUserPrincipal

        Principal getUserPrincipal()
        Returns the Principal that identifies the sender of the request currently being serviced. If the sender has not been authenticated, the method returns null.
        Returns:
        Principal The principal object.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        See Also:
        Principal, IllegalStateException

      • isUserInRole

        boolean isUserInRole(String role)
        Returns a boolean indicating whether the authenticated user is included in the specified logical role. If the user has not been authenticated, the method returns false.
        Parameters:
        role - A String specifying the name of the role
        Returns:
        a boolean indicating whether the sender of the request belongs to a given role
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.

      • getEndpointReference

        EndpointReference getEndpointReference(Element... referenceParameters)
        Returns the EndpointReference for this endpoint.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        Parameters:
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of the endpoint associated with this WebServiceContext. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        Since:
        JAX-WS 2.1
        See Also:
        W3CEndpointReference

      • getEndpointReference

        <T extends EndpointReference> T getEndpointReference(Class<T> clazz,
                                                     Element... referenceParameters)
        Returns the EndpointReference associated with this endpoint.
        Parameters:
        clazz - The type of EndpointReference that MUST be returned.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        EndpointReference of type clazz of the endpoint associated with this WebServiceContext instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        Throws:
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        WebServiceException - If the clazz type of EndpointReference is not supported.
        Since:
        JAX-WS 2.1
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class WebServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ProtocolException

    public class WebServiceException
extends RuntimeException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebServiceException()
      Constructs a new exception with null as its detail message.
      WebServiceException(String message)
      Constructs a new exception with the specified detail message.
      WebServiceException(String message, Throwable cause)
      Constructs a new exception with the specified detail message and cause.
      WebServiceException(Throwable cause)
      Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebServiceException

        public WebServiceException()
        Constructs a new exception with null as its detail message. The cause is not initialized.

      • WebServiceException

        public WebServiceException(String message)
        Constructs a new exception with the specified detail message. The cause is not initialized.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method

      • WebServiceException

        public WebServiceException(String message,
                           Throwable cause)
        Constructs a new exception with the specified detail message and cause.
        Parameters:
        message - The detail message which is later retrieved using the getMessage method
        cause - The cause which is saved for the later retrieval throw by the getCause method

      • WebServiceException

        public WebServiceException(Throwable cause)
        Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        Parameters:
        cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class WebServiceFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
  • Direct Known Subclasses:
    AddressingFeature, MTOMFeature, RespectBindingFeature

    public abstract class WebServiceFeature
extends Object
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.

    The JAX-WS specification will define some standard features and JAX-WS implementors are free to define additional features if necessary. Vendor specific features may not be portable so caution should be used when using them. Each Feature definition MUST define a public static final String ID that can be used in the Feature annotation to refer to the feature. This ID MUST be unique across all features of all vendors. When defining a vendor specific feature ID, use a vendor specific namespace in the ID string.

    Since:
    2.1
    See Also:
    RespectBindingFeature, AddressingFeature, MTOMFeature

    • Field Summary

      Fields
      Modifier and Type Field and Description
      protected boolean enabled
      Specifies if the feature is enabled or disabled

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | WebServiceFeature()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract String getID()
      Get the unique identifier for this WebServiceFeature.
      boolean isEnabled()
      Returns true if this feature is enabled.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • enabled

        protected boolean enabled
        Specifies if the feature is enabled or disabled

    • Constructor Detail

      • WebServiceFeature

        protected WebServiceFeature()

    • Method Detail

      • getID

        public abstract String getID()
        Get the unique identifier for this WebServiceFeature.
        Returns:
        the unique identifier for this feature.

      • isEnabled

        public boolean isEnabled()
        Returns true if this feature is enabled.
        Returns:
        true if and only if the feature is enabled .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServicePermission (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws

Class WebServicePermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.xml.ws.WebServicePermission
  • All Implemented Interfaces:
    Serializable, Guard

    public final class WebServicePermission
extends BasicPermission
    This class defines web service permissions.

    Web service Permissions are identified by name (also referred to as a "target name") alone. There are no actions associated with them.

    The following permission target name is defined:

    publishEndpoint

    The publishEndpoint permission allows publishing a web service endpoint using the publish methods defined by the javax.xml.ws.Endpoint class.

    Granting publishEndpoint allows the application to be exposed as a network service. Depending on the security of the runtime and the security of the application, this may introduce a security hole that is remotely exploitable.

    See Also:
    Endpoint, BasicPermission, Permission, Permissions, SecurityManager, SocketPermission, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      WebServicePermission(String name)
      Creates a new permission with the specified name.
      WebServicePermission(String name, String actions)
      Creates a new permission with the specified name and actions.

    • Method Summary

      • Methods inherited from class java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • Methods inherited from class java.security.Permission

        checkGuard, getName, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WebServicePermission

        public WebServicePermission(String name)
        Creates a new permission with the specified name.
        Parameters:
        name - the name of the WebServicePermission

      • WebServicePermission

        public WebServicePermission(String name,
                            String actions)
        Creates a new permission with the specified name and actions. The actions parameter is currently unused and it should be null.
        Parameters:
        name - the name of the WebServicePermission
        actions - should be null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type WebServiceProvider

  • @Target(value=TYPE)
 @Retention(value=RUNTIME)
 @Documented
public @interface WebServiceProvider
    Used to annotate a Provider implementation class.
    Since:
    JAX-WS 2.0
    See Also:
    Provider

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String portName
      Port name.
      String serviceName
      Service name.
      String targetNamespace
      Target namespace for the service
      String wsdlLocation
      Location of the WSDL description for the service.

    • Element Detail

      • wsdlLocation

        public abstract String wsdlLocation
        Location of the WSDL description for the service.
        Default:
        ""

      • serviceName

        public abstract String serviceName
        Service name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Target namespace for the service
        Default:
        ""

      • portName

        public abstract String portName
        Port name.
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceRef (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type WebServiceRef

  • @Target(value={TYPE,METHOD,FIELD})
 @Retention(value=RUNTIME)
 @Documented
public @interface WebServiceRef
    The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it. It can be used to inject both service and proxy instances. These injected references are not thread safe. If the references are accessed by multiple threads, usual synchronization techinques can be used to support multiple threads.

    Web service references are resources in the Java EE 5 sense. The annotations (for example, Addressing) annotated with meta-annotation WebServiceFeatureAnnotation can be used in conjunction with WebServiceRef. The created reference MUST be configured with annotation's web service feature.

    For example, in the code below, the injected StockQuoteProvider proxy MUST have WS-Addressing enabled as specifed by the Addressing annotation.

    public class MyClient {
       @Addressing
       @WebServiceRef(StockQuoteService.class)
       private StockQuoteProvider stockQuoteProvider;
       ...
    }

    If a JAX-WS implementation encounters an unsupported or unrecognized annotation annotated with the WebServiceFeatureAnnotation that is specified with WebServiceRef, an ERROR MUST be given.

    Since:
    JAX-WS 2.0
    See Also:
    Resource, WebServiceFeatureAnnotation

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      String lookup
      A portable JNDI lookup name that resolves to the target web service reference.
      String mappedName
      A product specific name that this resource should be mapped to.
      String name
      The JNDI name of the resource.
      Class<?> type
      The Java type of the resource.
      Class<? extends Service> value
      The service class, alwiays a type extending javax.xml.ws.Service.
      String wsdlLocation
      A URL pointing to the WSDL document for the web service.

    • Element Detail

      • name

        public abstract String name
        The JNDI name of the resource. For field annotations, the default is the field name. For method annotations, the default is the JavaBeans property name corresponding to the method. For class annotations, there is no default and this MUST be specified. The JNDI name can be absolute(with any logical namespace) or relative to JNDI java:comp/env namespace.
        Default:
        ""

      • type

        public abstract Class<?> type
        The Java type of the resource. For field annotations, the default is the type of the field. For method annotations, the default is the type of the JavaBeans property. For class annotations, there is no default and this MUST be specified.
        Default:
        java.lang.Object.class

      • mappedName

        public abstract String mappedName
        A product specific name that this resource should be mapped to. The name of this resource, as defined by the name element or defaulted, is a name that is local to the application component using the resource. (When a relative JNDI name is specified, then it's a name in the JNDI java:comp/env namespace.) Many application servers provide a way to map these local names to names of resources known to the application server. This mapped name is often a global JNDI name, but may be a name of any form.

        Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

        Default:
        ""

      • value

        public abstract Class<? extends Service> value
        The service class, alwiays a type extending javax.xml.ws.Service. This element MUST be specified whenever the type of the reference is a service endpoint interface.
        Default:
        javax.xml.ws.Service.class

      • wsdlLocation

        public abstract String wsdlLocation
        A URL pointing to the WSDL document for the web service. If not specified, the WSDL location specified by annotations on the resource type is used instead.
        Default:
        ""

      • lookup

        public abstract String lookup
        A portable JNDI lookup name that resolves to the target web service reference.
        Since:
        JAX-WS 2.2
        Default:
        ""
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceRefs (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws

Annotation Type WebServiceRefs

  • @Documented
 @Retention(value=RUNTIME)
 @Target(value=TYPE)
public @interface WebServiceRefs
    The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

    It can be used to inject both service and proxy instances. These injected references are not thread safe. If the references are accessed by multiple threads, usual synchronization techniques can be used to support multiple threads.

    There is no way to associate web service features with the injected instances. If an instance needs to be configured with web service features, use @WebServiceRef to inject the resource along with its features.

    Example: The StockQuoteProvider proxy instance, and the StockQuoteService service instance are injected using @WebServiceRefs.

    @WebServiceRefs({@WebServiceRef(name="service/stockquoteservice", value=StockQuoteService.class),
                     @WebServiceRef(name="service/stockquoteprovider", type=StockQuoteProvider.class, value=StockQuoteService.class})
    public class MyClient {
        void init() {
            Context ic = new InitialContext();
            StockQuoteService service = (StockQuoteService) ic.lookup("java:comp/env/service/stockquoteservice");
            StockQuoteProvider port = (StockQuoteProvider) ic.lookup("java:comp/env/service/stockquoteprovider");
            ...
       }
       ...
    }
    Since:
    2.0
    See Also:
    WebServiceRef

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      WebServiceRef[] value
      Array used for multiple web service reference declarations.

    • Element Detail

      • value

        public abstract WebServiceRef[] value
        Array used for multiple web service reference declarations.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.Action (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Action

No usage of javax.xml.ws.Action
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.AsyncHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.AsyncHandler

  • Packages that use AsyncHandler
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of AsyncHandler in javax.xml.ws

      Methods in javax.xml.ws with parameters of type AsyncHandler
      Modifier and Type Method and Description
      Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.Binding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Binding

  • Packages that use Binding
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of Binding in javax.xml.ws

      Methods in javax.xml.ws that return Binding
      Modifier and Type Method and Description
      abstract Binding Endpoint.getBinding()
      Returns the binding for this endpoint.
      Binding BindingProvider.getBinding()
      Get the Binding for this binding provider.

    • Uses of Binding in javax.xml.ws.http

      Subinterfaces of Binding in javax.xml.ws.http
      Modifier and Type Interface and Description
      interface  HTTPBinding
      The HTTPBinding interface is an abstraction for the XML/HTTP binding.

    • Uses of Binding in javax.xml.ws.soap

      Subinterfaces of Binding in javax.xml.ws.soap
      Modifier and Type Interface and Description
      interface  SOAPBinding
      The SOAPBinding interface is an abstraction for the SOAP binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.BindingProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.BindingProvider

  • Packages that use BindingProvider
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of BindingProvider in javax.xml.ws

      Subinterfaces of BindingProvider in javax.xml.ws
      Modifier and Type Interface and Description
      interface  Dispatch<T>
      The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.BindingType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.BindingType

No usage of javax.xml.ws.BindingType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.Dispatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Dispatch

  • Packages that use Dispatch
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Dispatch in javax.xml.ws

      Methods in javax.xml.ws that return Dispatch
      Modifier and Type Method and Description
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.

    • Uses of Dispatch in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Dispatch
      Modifier and Type Method and Description
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.Endpoint (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Endpoint

  • Packages that use Endpoint
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Endpoint in javax.xml.ws

      Methods in javax.xml.ws that return Endpoint
      Modifier and Type Method and Description
      static Endpoint Endpoint.create(Object implementor)
      Creates an endpoint with the specified implementor object.
      static Endpoint Endpoint.create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Endpoint Endpoint.create(String bindingId, Object implementor)
      Creates an endpoint with the specified binding type and implementor object.
      static Endpoint Endpoint.create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      static Endpoint Endpoint.publish(String address, Object implementor)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      static Endpoint Endpoint.publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      Methods in javax.xml.ws that return types with arguments of type Endpoint
      Modifier and Type Method and Description
      abstract Set<Endpoint> EndpointContext.getEndpoints()
      This gives list of endpoints in an application.

    • Uses of Endpoint in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Endpoint
      Modifier and Type Method and Description
      abstract Endpoint Provider.createAndPublishEndpoint(String address, Object implementor)
      Creates and publishes an endpoint object with the specified address and implementation object.
      Endpoint Provider.createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      Endpoint Provider.createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      abstract Endpoint Provider.createEndpoint(String bindingId, Object implementor)
      Creates an endpoint object with the provided binding and implementation object.
      Endpoint Provider.createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.EndpointContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.EndpointContext

  • Packages that use EndpointContext
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of EndpointContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type EndpointContext
      Modifier and Type Method and Description
      void Endpoint.setEndpointContext(EndpointContext ctxt)
      By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.EndpointReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.EndpointReference

  • Packages that use EndpointReference
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of EndpointReference in javax.xml.ws

      Methods in javax.xml.ws with type parameters of type EndpointReference
      Modifier and Type Method and Description
      <T extends EndpointReference>
      T             		BindingProvider.getEndpointReference(Class<T> clazz)
      Returns the EndpointReference associated with this BindingProvider instance.
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      Methods in javax.xml.ws that return EndpointReference
      Modifier and Type Method and Description
      EndpointReference BindingProvider.getEndpointReference()
      Returns the EndpointReference associated with this BindingProvider instance.
      EndpointReference WebServiceContext.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      abstract EndpointReference Endpoint.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      static EndpointReference EndpointReference.readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      Methods in javax.xml.ws with parameters of type EndpointReference
      Modifier and Type Method and Description
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.

    • Uses of EndpointReference in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return EndpointReference
      Modifier and Type Method and Description
      abstract EndpointReference Provider.readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.
      Methods in javax.xml.ws.spi with parameters of type EndpointReference
      Modifier and Type Method and Description
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> T ServiceDelegate.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T Provider.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.

    • Uses of EndpointReference in javax.xml.ws.wsaddressing

      Subclasses of EndpointReference in javax.xml.ws.wsaddressing
      Modifier and Type Class and Description
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.FaultAction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.FaultAction

No usage of javax.xml.ws.FaultAction
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.Holder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Holder

No usage of javax.xml.ws.Holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.LogicalMessage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.LogicalMessage

  • Packages that use LogicalMessage
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of LogicalMessage in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return LogicalMessage
      Modifier and Type Method and Description
      LogicalMessage LogicalMessageContext.getMessage()
      Gets the message from this message context
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.ProtocolException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.ProtocolException

  • Packages that use ProtocolException
    Package Description
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of ProtocolException in javax.xml.ws.http

      Subclasses of ProtocolException in javax.xml.ws.http
      Modifier and Type Class and Description
      class  HTTPException
      The HTTPException exception represents a XML/HTTP fault.

    • Uses of ProtocolException in javax.xml.ws.soap

      Subclasses of ProtocolException in javax.xml.ws.soap
      Modifier and Type Class and Description
      class  SOAPFaultException
      The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.Provider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Provider

No usage of javax.xml.ws.Provider
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.RequestWrapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.RequestWrapper

No usage of javax.xml.ws.RequestWrapper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.RespectBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.RespectBinding

No usage of javax.xml.ws.RespectBinding
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.RespectBindingFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.RespectBindingFeature

No usage of javax.xml.ws.RespectBindingFeature
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.Response (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.Response

  • Packages that use Response
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of Response in javax.xml.ws

      Methods in javax.xml.ws that return Response
      Modifier and Type Method and Description
      Response<T> Dispatch.invokeAsync(T msg)
      Invoke a service operation asynchronously.
      Methods in javax.xml.ws with parameters of type Response
      Modifier and Type Method and Description
      void AsyncHandler.handleResponse(Response<T> res)
      Called when the response to an asynchronous operation is available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.ResponseWrapper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.ResponseWrapper

No usage of javax.xml.ws.ResponseWrapper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.Service (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Service

  • Packages that use Service
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Service in javax.xml.ws

      Methods in javax.xml.ws that return Service
      Modifier and Type Method and Description
      static Service Service.create(QName serviceName)
      Creates a Service instance.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.

    • Uses of Service in javax.xml.ws.spi

      Method parameters in javax.xml.ws.spi with type arguments of type Service
      Modifier and Type Method and Description
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.Service.Mode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.Service.Mode

  • Packages that use Service.Mode
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Service.Mode in javax.xml.ws

      Methods in javax.xml.ws that return Service.Mode
      Modifier and Type Method and Description
      static Service.Mode Service.Mode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Service.Mode[] Service.Mode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.xml.ws with parameters of type Service.Mode
      Modifier and Type Method and Description
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.

    • Uses of Service.Mode in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Service.Mode
      Modifier and Type Method and Description
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.ServiceMode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.ServiceMode

No usage of javax.xml.ws.ServiceMode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebEndpoint (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebEndpoint

No usage of javax.xml.ws.WebEndpoint
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebFault (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebFault

No usage of javax.xml.ws.WebFault
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServiceClient (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceClient

No usage of javax.xml.ws.WebServiceClient
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.WebServiceContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.WebServiceContext

  • Packages that use WebServiceContext
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of WebServiceContext in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type WebServiceContext
      Modifier and Type Method and Description
      abstract void Invoker.inject(WebServiceContext webServiceContext)
      JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServiceException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceException

  • Packages that use WebServiceException
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of WebServiceException in javax.xml.ws

      Subclasses of WebServiceException in javax.xml.ws
      Modifier and Type Class and Description
      class  ProtocolException
      The ProtocolException class is a base class for exceptions related to a specific protocol binding.

    • Uses of WebServiceException in javax.xml.ws.http

      Subclasses of WebServiceException in javax.xml.ws.http
      Modifier and Type Class and Description
      class  HTTPException
      The HTTPException exception represents a XML/HTTP fault.

    • Uses of WebServiceException in javax.xml.ws.soap

      Subclasses of WebServiceException in javax.xml.ws.soap
      Modifier and Type Class and Description
      class  SOAPFaultException
      The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServiceFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceFeature

  • Packages that use WebServiceFeature
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of WebServiceFeature in javax.xml.ws

      Subclasses of WebServiceFeature in javax.xml.ws
      Modifier and Type Class and Description
      class  RespectBindingFeature
      This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
      Methods in javax.xml.ws with parameters of type WebServiceFeature
      Modifier and Type Method and Description
      static Endpoint Endpoint.create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Endpoint Endpoint.create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T EndpointReference.getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T Service.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T Service.getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static Endpoint Endpoint.publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      Constructors in javax.xml.ws with parameters of type WebServiceFeature
      Constructor and Description
      Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Uses of WebServiceFeature in javax.xml.ws.soap

      Subclasses of WebServiceFeature in javax.xml.ws.soap
      Modifier and Type Class and Description
      class  AddressingFeature
      AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
      class  MTOMFeature
      This feature represents the use of MTOM with a web service.

    • Uses of WebServiceFeature in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type WebServiceFeature
      Modifier and Type Method and Description
      Endpoint Provider.createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Endpoint Provider.createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      Endpoint Provider.createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract <T> T ServiceDelegate.getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T Provider.getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServicePermission (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServicePermission

No usage of javax.xml.ws.WebServicePermission
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServiceProvider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceProvider

No usage of javax.xml.ws.WebServiceProvider
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServiceRef (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceRef

No usage of javax.xml.ws.WebServiceRef
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.WebServiceRefs (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.WebServiceRefs

No usage of javax.xml.ws.WebServiceRefs
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Handler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface Handler<C extends MessageContext>

  • All Known Subinterfaces:
    LogicalHandler<C>, SOAPHandler<T>

    public interface Handler<C extends MessageContext>
    The Handler interface is the base interface for JAX-WS handlers.
    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void close(MessageContext context)
      Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime dispatching a message, fault or exception.
      boolean handleFault(C context)
      The handleFault method is invoked for fault message processing.
      boolean handleMessage(C context)
      The handleMessage method is invoked for normal processing of inbound and outbound messages.

    • Method Detail

      • handleMessage

        boolean handleMessage(C context)
        The handleMessage method is invoked for normal processing of inbound and outbound messages. Refer to the description of the handler framework in the JAX-WS specification for full details.
        Parameters:
        context - the message context.
        Returns:
        An indication of whether handler processing should continue for the current message
        • Return true to continue processing.
        • Return false to block processing.
        Throws:
        RuntimeException - Causes the JAX-WS runtime to cease handler processing and generate a fault.
        ProtocolException - Causes the JAX-WS runtime to switch to fault message processing.

      • handleFault

        boolean handleFault(C context)
        The handleFault method is invoked for fault message processing. Refer to the description of the handler framework in the JAX-WS specification for full details.
        Parameters:
        context - the message context
        Returns:
        An indication of whether handler fault processing should continue for the current message
        • Return true to continue processing.
        • Return false to block processing.
        Throws:
        RuntimeException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.
        ProtocolException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.

      • close

        void close(MessageContext context)
        Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime dispatching a message, fault or exception. Refer to the description of the handler framework in the JAX-WS specification for full details.
        Parameters:
        context - the message context
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HandlerResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface HandlerResolver

  • public interface HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.

    A HandlerResolver may be set on a Service using the setHandlerResolver method.

    When the runtime invokes a HandlerResolver, it will pass it a PortInfo object containing information about the port that the proxy/dispatch object will be accessing.

    Since:
    JAX-WS 2.0
    See Also:
    Service.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      List<Handler> getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.

    • Method Detail

      • getHandlerChain

        List<Handler> getHandlerChain(PortInfo portInfo)
        Gets the handler chain for the specified port.
        Parameters:
        portInfo - Contains information about the port being accessed.
        Returns:
        java.util.List<Handler> chain
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LogicalHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface LogicalHandler<C extends LogicalMessageContext>

  • All Superinterfaces:
    Handler<C>

    public interface LogicalHandler<C extends LogicalMessageContext>
extends Handler<C>
    The LogicalHandler extends Handler to provide typesafety for the message context parameter.
    Since:
    JAX-WS 2.0

    • Method Summary

      • Methods inherited from interface javax.xml.ws.handler.Handler

        close, handleFault, handleMessage
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LogicalMessageContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface LogicalMessageContext

  • All Superinterfaces:
    Map<String,Object>, MessageContext

    public interface LogicalMessageContext
extends MessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    Since:
    JAX-WS 2.0

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext

        MessageContext.Scope

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from interface javax.xml.ws.handler.MessageContext

        HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, REFERENCE_PARAMETERS, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LogicalMessage getMessage()
      Gets the message from this message context

      • Methods inherited from interface javax.xml.ws.handler.MessageContext

        getScope, setScope

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

    • Method Detail

      • getMessage

        LogicalMessage getMessage()
        Gets the message from this message context
        Returns:
        The contained message; returns null if no message is present in this message context
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MessageContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface MessageContext

  • All Superinterfaces:
    Map<String,Object>
    All Known Subinterfaces:
    LogicalMessageContext, SOAPMessageContext

    public interface MessageContext
extends Map<String,Object>
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

    The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

    Since:
    JAX-WS 2.0

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  MessageContext.Scope
      Property scope.

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String HTTP_REQUEST_HEADERS
      Standard property: HTTP request headers.
      static String HTTP_REQUEST_METHOD
      Standard property: HTTP request method.
      static String HTTP_RESPONSE_CODE
      Standard property: HTTP response status code.
      static String HTTP_RESPONSE_HEADERS
      Standard property: HTTP response headers.
      static String INBOUND_MESSAGE_ATTACHMENTS
      Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
      static String MESSAGE_OUTBOUND_PROPERTY
      Standard property: message direction, true for outbound messages, false for inbound.
      static String OUTBOUND_MESSAGE_ATTACHMENTS
      Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.
      static String PATH_INFO
      Standard property: Request Path Info
      static String QUERY_STRING
      Standard property: Query string for request.
      static String REFERENCE_PARAMETERS
      Standard property: WS Addressing Reference Parameters.
      static String SERVLET_CONTEXT
      Standard property: servlet context object.
      static String SERVLET_REQUEST
      Standard property: servlet request object.
      static String SERVLET_RESPONSE
      Standard property: servlet response object.
      static String WSDL_DESCRIPTION
      Standard property: input source for WSDL document.
      static String WSDL_INTERFACE
      Standard property: name of wsdl interface (2.0) or port type (1.1).
      static String WSDL_OPERATION
      Standard property: name of WSDL operation.
      static String WSDL_PORT
      Standard property: name of WSDL port.
      static String WSDL_SERVICE
      Standard property: name of WSDL service.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      MessageContext.Scope getScope(String name)
      Gets the scope of a property.
      void setScope(String name, MessageContext.Scope scope)
      Sets the scope of a property.

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

    • Field Detail

      • MESSAGE_OUTBOUND_PROPERTY

        static final String MESSAGE_OUTBOUND_PROPERTY
        Standard property: message direction, true for outbound messages, false for inbound.

        Type: boolean

        See Also:
        Constant Field Values

      • INBOUND_MESSAGE_ATTACHMENTS

        static final String INBOUND_MESSAGE_ATTACHMENTS
        Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.

        Type: java.util.Map<String,DataHandler>

        See Also:
        Constant Field Values

      • OUTBOUND_MESSAGE_ATTACHMENTS

        static final String OUTBOUND_MESSAGE_ATTACHMENTS
        Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.

        Type: java.util.Map<String,DataHandler>

        See Also:
        Constant Field Values

      • WSDL_DESCRIPTION

        static final String WSDL_DESCRIPTION
        Standard property: input source for WSDL document.

        Type: org.xml.sax.InputSource

        See Also:
        Constant Field Values

      • WSDL_SERVICE

        static final String WSDL_SERVICE
        Standard property: name of WSDL service.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_PORT

        static final String WSDL_PORT
        Standard property: name of WSDL port.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_INTERFACE

        static final String WSDL_INTERFACE
        Standard property: name of wsdl interface (2.0) or port type (1.1).

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • WSDL_OPERATION

        static final String WSDL_OPERATION
        Standard property: name of WSDL operation.

        Type: javax.xml.namespace.QName

        See Also:
        Constant Field Values

      • HTTP_RESPONSE_CODE

        static final String HTTP_RESPONSE_CODE
        Standard property: HTTP response status code.

        Type: java.lang.Integer

        See Also:
        Constant Field Values

      • HTTP_REQUEST_HEADERS

        static final String HTTP_REQUEST_HEADERS
        Standard property: HTTP request headers.

        Type: java.util.Map<java.lang.String, java.util.List<java.lang.String>>

        See Also:
        Constant Field Values

      • HTTP_RESPONSE_HEADERS

        static final String HTTP_RESPONSE_HEADERS
        Standard property: HTTP response headers.

        Type: java.util.Map<java.lang.String, java.util.List<java.lang.String>>

        See Also:
        Constant Field Values

      • HTTP_REQUEST_METHOD

        static final String HTTP_REQUEST_METHOD
        Standard property: HTTP request method.

        Type: java.lang.String

        See Also:
        Constant Field Values

      • SERVLET_REQUEST

        static final String SERVLET_REQUEST
        Standard property: servlet request object.

        Type: javax.servlet.http.HttpServletRequest

        See Also:
        Constant Field Values

      • SERVLET_RESPONSE

        static final String SERVLET_RESPONSE
        Standard property: servlet response object.

        Type: javax.servlet.http.HttpServletResponse

        See Also:
        Constant Field Values

      • SERVLET_CONTEXT

        static final String SERVLET_CONTEXT
        Standard property: servlet context object.

        Type: javax.servlet.ServletContext

        See Also:
        Constant Field Values

      • QUERY_STRING

        static final String QUERY_STRING
        Standard property: Query string for request.

        Type: String

        See Also:
        Constant Field Values

      • PATH_INFO

        static final String PATH_INFO
        Standard property: Request Path Info

        Type: String

        See Also:
        Constant Field Values

      • REFERENCE_PARAMETERS

        static final String REFERENCE_PARAMETERS
        Standard property: WS Addressing Reference Parameters. The list MUST include all SOAP headers marked with the wsa:IsReferenceParameter="true" attribute.

        Type: List<Element>

        Since:
        JAX-WS 2.1
        See Also:
        Constant Field Values

    • Method Detail

      • setScope

        void setScope(String name,
              MessageContext.Scope scope)
        Sets the scope of a property.
        Parameters:
        name - Name of the property associated with the MessageContext
        scope - Desired scope of the property
        Throws:
        IllegalArgumentException - if an illegal property name is specified

      • getScope

        MessageContext.Scope getScope(String name)
        Gets the scope of a property.
        Parameters:
        name - Name of the property
        Returns:
        Scope of the property
        Throws:
        IllegalArgumentException - if a non-existant property name is specified
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MessageContext.Scope (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.ws.handler

Enum MessageContext.Scope

  • java.lang.Object
    • java.lang.Enum<MessageContext.Scope>
      • javax.xml.ws.handler.MessageContext.Scope
  • All Implemented Interfaces:
    Serializable, Comparable<MessageContext.Scope>
    Enclosing interface:
    MessageContext

    public static enum MessageContext.Scope
extends Enum<MessageContext.Scope>
    Property scope. Properties scoped as APPLICATION are visible to handlers, client applications and service endpoints; properties scoped as HANDLER are only normally visible to handlers.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      APPLICATION
      HANDLER

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static MessageContext.Scope valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MessageContext.Scope[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • APPLICATION

        public static final MessageContext.Scope APPLICATION

      • HANDLER

        public static final MessageContext.Scope HANDLER

    • Method Detail

      • values

        public static MessageContext.Scope[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (MessageContext.Scope c : MessageContext.Scope.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static MessageContext.Scope valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.handler (Java Platform SE 8 )

javax.xml.ws.handler

Interfaces

  • Handler
  • HandlerResolver
  • LogicalHandler
  • LogicalMessageContext
  • MessageContext
  • PortInfo

Enums

  • MessageContext.Scope


javax.xml.ws.handler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.handler

This package defines APIs for message handlers.

See: Description

  • Interface Summary
    Interface Description
    Handler<C extends MessageContext>
    The Handler interface is the base interface for JAX-WS handlers.
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
    LogicalHandler<C extends LogicalMessageContext>
    The LogicalHandler extends Handler to provide typesafety for the message context parameter.
    LogicalMessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
    PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
  • Enum Summary
    Enum Description
    MessageContext.Scope
    Property scope.

Package javax.xml.ws.handler Description

This package defines APIs for message handlers.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.handler Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.handler

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
  • javax.xml.ws.handler.HandlerResolver
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
  • javax.xml.ws.handler.PortInfo

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.handler.MessageContext.Scope
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.handler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.handler

  • Packages that use javax.xml.ws.handler
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.ws.handler used by javax.xml.ws
    Class and Description
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.handler
    Class and Description
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    LogicalMessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
    MessageContext.Scope
    Property scope.
    PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.handler.soap
    Class and Description
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.spi
    Class and Description
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PortInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler

Interface PortInfo

  • public interface PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.

    This interface is never implemented by an application, only by a JAX-WS implementation.

    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getBindingID()
      Gets the URI identifying the binding used by the port being accessed.
      QName getPortName()
      Gets the qualified name of the WSDL port being accessed.
      QName getServiceName()
      Gets the qualified name of the WSDL service name containing the port being accessed.

    • Method Detail

      • getServiceName

        QName getServiceName()
        Gets the qualified name of the WSDL service name containing the port being accessed.
        Returns:
        javax.xml.namespace.QName The qualified name of the WSDL service.

      • getPortName

        QName getPortName()
        Gets the qualified name of the WSDL port being accessed.
        Returns:
        javax.xml.namespace.QName The qualified name of the WSDL port.

      • getBindingID

        String getBindingID()
        Gets the URI identifying the binding used by the port being accessed.
        Returns:
        String The binding identifier for the port.
        See Also:
        Binding
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.Handler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.Handler

  • Packages that use Handler
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of Handler in javax.xml.ws

      Methods in javax.xml.ws that return types with arguments of type Handler
      Modifier and Type Method and Description
      List<Handler> Binding.getHandlerChain()
      Gets a copy of the handler chain for a protocol binding instance.
      Method parameters in javax.xml.ws with type arguments of type Handler
      Modifier and Type Method and Description
      void Binding.setHandlerChain(List<Handler> chain)
      Sets the handler chain for the protocol binding instance.

    • Uses of Handler in javax.xml.ws.handler

      Subinterfaces of Handler in javax.xml.ws.handler
      Modifier and Type Interface and Description
      interface  LogicalHandler<C extends LogicalMessageContext>
      The LogicalHandler extends Handler to provide typesafety for the message context parameter.
      Methods in javax.xml.ws.handler that return types with arguments of type Handler
      Modifier and Type Method and Description
      List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.

    • Uses of Handler in javax.xml.ws.handler.soap

      Subinterfaces of Handler in javax.xml.ws.handler.soap
      Modifier and Type Interface and Description
      interface  SOAPHandler<T extends SOAPMessageContext>
      The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.HandlerResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.HandlerResolver

  • Packages that use HandlerResolver
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of HandlerResolver in javax.xml.ws

      Methods in javax.xml.ws that return HandlerResolver
      Modifier and Type Method and Description
      HandlerResolver Service.getHandlerResolver()
      Returns the configured handler resolver.
      Methods in javax.xml.ws with parameters of type HandlerResolver
      Modifier and Type Method and Description
      void Service.setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

    • Uses of HandlerResolver in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return HandlerResolver
      Modifier and Type Method and Description
      abstract HandlerResolver ServiceDelegate.getHandlerResolver()
      Returns the configured handler resolver.
      Methods in javax.xml.ws.spi with parameters of type HandlerResolver
      Modifier and Type Method and Description
      abstract void ServiceDelegate.setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.LogicalHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.LogicalHandler

No usage of javax.xml.ws.handler.LogicalHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.LogicalMessageContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.LogicalMessageContext

  • Packages that use LogicalMessageContext
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of LogicalMessageContext in javax.xml.ws.handler

      Classes in javax.xml.ws.handler with type parameters of type LogicalMessageContext
      Modifier and Type Interface and Description
      interface  LogicalHandler<C extends LogicalMessageContext>
      The LogicalHandler extends Handler to provide typesafety for the message context parameter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.MessageContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.MessageContext

  • Packages that use MessageContext
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of MessageContext in javax.xml.ws

      Methods in javax.xml.ws that return MessageContext
      Modifier and Type Method and Description
      MessageContext WebServiceContext.getMessageContext()
      Returns the MessageContext for the request being served at the time this method is called.

    • Uses of MessageContext in javax.xml.ws.handler

      Classes in javax.xml.ws.handler with type parameters of type MessageContext
      Modifier and Type Interface and Description
      interface  Handler<C extends MessageContext>
      The Handler interface is the base interface for JAX-WS handlers.
      Subinterfaces of MessageContext in javax.xml.ws.handler
      Modifier and Type Interface and Description
      interface  LogicalMessageContext
      The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
      Methods in javax.xml.ws.handler with parameters of type MessageContext
      Modifier and Type Method and Description
      void Handler.close(MessageContext context)
      Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime dispatching a message, fault or exception.

    • Uses of MessageContext in javax.xml.ws.handler.soap

      Subinterfaces of MessageContext in javax.xml.ws.handler.soap
      Modifier and Type Interface and Description
      interface  SOAPMessageContext
      The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.handler.MessageContext.Scope (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.handler.MessageContext.Scope

  • Packages that use MessageContext.Scope
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of MessageContext.Scope in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return MessageContext.Scope
      Modifier and Type Method and Description
      MessageContext.Scope MessageContext.getScope(String name)
      Gets the scope of a property.
      static MessageContext.Scope MessageContext.Scope.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MessageContext.Scope[] MessageContext.Scope.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.xml.ws.handler with parameters of type MessageContext.Scope
      Modifier and Type Method and Description
      void MessageContext.setScope(String name, MessageContext.Scope scope)
      Sets the scope of a property.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.PortInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.PortInfo

  • Packages that use PortInfo
    Package Description
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of PortInfo in javax.xml.ws.handler

      Methods in javax.xml.ws.handler with parameters of type PortInfo
      Modifier and Type Method and Description
      List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.handler.soap (Java Platform SE 8 )

javax.xml.ws.handler.soap

Interfaces

  • SOAPHandler
  • SOAPMessageContext


javax.xml.ws.handler.soap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.handler.soap

This package defines APIs for SOAP message handlers.

See: Description

  • Interface Summary
    Interface Description
    SOAPHandler<T extends SOAPMessageContext>
    The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
    SOAPMessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.

Package javax.xml.ws.handler.soap Description

This package defines APIs for SOAP message handlers.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.handler.soap Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.handler.soap

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.handler.soap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.handler.soap

  • Packages that use javax.xml.ws.handler.soap
    Package Description
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
  • Classes in javax.xml.ws.handler.soap used by javax.xml.ws.handler.soap
    Class and Description
    SOAPMessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler.soap

Interface SOAPHandler<T extends SOAPMessageContext>

  • All Superinterfaces:
    Handler<T>

    public interface SOAPHandler<T extends SOAPMessageContext>
extends Handler<T>
    The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
    Since:
    JAX-WS 2.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Set<QName> getHeaders()
      Gets the header blocks that can be processed by this Handler instance.

      • Methods inherited from interface javax.xml.ws.handler.Handler

        close, handleFault, handleMessage

    • Method Detail

      • getHeaders

        Set<QName> getHeaders()
        Gets the header blocks that can be processed by this Handler instance.
        Returns:
        Set of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPMessageContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.handler.soap

Interface SOAPMessageContext

  • All Superinterfaces:
    Map<String,Object>, MessageContext

    public interface SOAPMessageContext
extends MessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.
    Since:
    JAX-WS 2.0
    See Also:
    SOAPMessage

    • Nested Class Summary

      • Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext

        MessageContext.Scope

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • Field Summary

      • Fields inherited from interface javax.xml.ws.handler.MessageContext

        HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, REFERENCE_PARAMETERS, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object[] getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.
      SOAPMessage getMessage()
      Gets the SOAPMessage from this message context.
      Set<String> getRoles()
      Gets the SOAP actor roles associated with an execution of the handler chain.
      void setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context

      • Methods inherited from interface javax.xml.ws.handler.MessageContext

        getScope, setScope

      • Methods inherited from interface java.util.Map

        clear, compute, computeIfAbsent, computeIfPresent, containsKey, containsValue, entrySet, equals, forEach, get, getOrDefault, hashCode, isEmpty, keySet, merge, put, putAll, putIfAbsent, remove, remove, replace, replace, replaceAll, size, values

    • Method Detail

      • getMessage

        SOAPMessage getMessage()
        Gets the SOAPMessage from this message context. Modifications to the returned SOAPMessage change the message in-place, there is no need to subsequently call setMessage.
        Returns:
        Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

      • setMessage

        void setMessage(SOAPMessage message)
        Sets the SOAPMessage in this message context
        Parameters:
        message - SOAP message
        Throws:
        WebServiceException - If any error during the setting of the SOAPMessage in this message context
        UnsupportedOperationException - If this operation is not supported

      • getHeaders

        Object[] getHeaders(QName header,
                    JAXBContext context,
                    boolean allRoles)
        Gets headers that have a particular qualified name from the message in the message context. Note that a SOAP message can contain multiple headers with the same qualified name.
        Parameters:
        header - The XML qualified name of the SOAP header(s).
        context - The JAXBContext that should be used to unmarshall the header
        allRoles - If true then returns headers for all SOAP roles, if false then only returns headers targetted at the roles currently being played by this SOAP node, see getRoles.
        Returns:
        An array of unmarshalled headers; returns an empty array if no message is present in this message context or no headers match the supplied qualified name.
        Throws:
        WebServiceException - If an error occurs when using the supplied JAXBContext to unmarshall. The cause of the WebServiceException is the original JAXBException.

      • getRoles

        Set<String> getRoles()
        Gets the SOAP actor roles associated with an execution of the handler chain. Note that SOAP actor roles apply to the SOAP node and are managed using SOAPBinding.setRoles(java.util.Set<java.lang.String>) and SOAPBinding.getRoles(). Handler instances in the handler chain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the handler chain.
        Returns:
        Array of String for SOAP actor roles
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.soap.SOAPHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.soap.SOAPHandler

No usage of javax.xml.ws.handler.soap.SOAPHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.handler.soap.SOAPMessageContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.handler.soap.SOAPMessageContext

  • Packages that use SOAPMessageContext
    Package Description
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of SOAPMessageContext in javax.xml.ws.handler.soap

      Classes in javax.xml.ws.handler.soap with type parameters of type SOAPMessageContext
      Modifier and Type Interface and Description
      interface  SOAPHandler<T extends SOAPMessageContext>
      The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HTTPBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.http

Interface HTTPBinding

  • All Superinterfaces:
    Binding

    public interface HTTPBinding
extends Binding
    The HTTPBinding interface is an abstraction for the XML/HTTP binding.
    Since:
    JAX-WS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String HTTP_BINDING
      A constant representing the identity of the XML/HTTP binding.

    • Method Summary

      • Methods inherited from interface javax.xml.ws.Binding

        getBindingID, getHandlerChain, setHandlerChain

    • Field Detail

      • HTTP_BINDING

        static final String HTTP_BINDING
        A constant representing the identity of the XML/HTTP binding.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HTTPException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.http

Class HTTPException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
  • All Implemented Interfaces:
    Serializable

    public class HTTPException
extends ProtocolException
    The HTTPException exception represents a XML/HTTP fault.

    Since there is no standard format for faults or exceptions in XML/HTTP messaging, only the HTTP status code is captured.

    Since:
    JAX-WS 2.0
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      HTTPException(int statusCode)
      Constructor for the HTTPException

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getStatusCode()
      Gets the HTTP status code.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • HTTPException

        public HTTPException(int statusCode)
        Constructor for the HTTPException
        Parameters:
        statusCode - int for the HTTP status code

    • Method Detail

      • getStatusCode

        public int getStatusCode()
        Gets the HTTP status code.
        Returns:
        HTTP status code
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.http (Java Platform SE 8 )

javax.xml.ws.http

Interfaces

  • HTTPBinding

Exceptions

  • HTTPException


javax.xml.ws.http (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.http

This package defines APIs specific to the HTTP binding.

See: Description

  • Interface Summary
    Interface Description
    HTTPBinding
    The HTTPBinding interface is an abstraction for the XML/HTTP binding.
  • Exception Summary
    Exception Description
    HTTPException
    The HTTPException exception represents a XML/HTTP fault.

Package javax.xml.ws.http Description

This package defines APIs specific to the HTTP binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.http Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.http

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.http (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.http

No usage of javax.xml.ws.http
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.http.HTTPBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.http.HTTPBinding

No usage of javax.xml.ws.http.HTTPBinding
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.http.HTTPException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.http.HTTPException

No usage of javax.xml.ws.http.HTTPException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Addressing (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws.soap

Annotation Type Addressing

  • @Target(value={TYPE,METHOD,FIELD})
 @Retention(value=RUNTIME)
 @Documented
 @WebServiceFeatureAnnotation(id="http://www.w3.org/2005/08/addressing/module",
                             bean=AddressingFeature.class)
public @interface Addressing
    This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding. Using this annotation with any other binding is undefined.

    This annotation MUST only be used in conjunction with the WebService, WebServiceProvider, and WebServiceRef annotations. When used with a javax.jws.WebService annotation, this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the Addressing annotation.

    This annotation's behaviour is defined by the corresponding feature AddressingFeature.

    Since:
    JAX-WS 2.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.
      boolean required
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.
      AddressingFeature.Responses responses
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled. If enabled, it means the endpoint supports WS-Addressing but does not require its use. Corresponding 3.1.1 Addressing Assertion must be generated in the generated WSDL.
        Default:
        true

      • required

        public abstract boolean required
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, the endpoint requires WS-Addressing and WS-Addressing headers MUST be present on incoming messages. A corresponding 3.1.1 Addressing Assertion must be generated in the WSDL.
        Default:
        false

      • responses

        public abstract AddressingFeature.Responses responses
        If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all.

        AddressingFeature.Responses.ALL supports all response types and this is the default value.

        AddressingFeature.Responses.ANONYMOUS requires the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

        AddressingFeature.Responses.NON_ANONYMOUS requires the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

        Since:
        JAX-WS 2.2
        Default:
        javax.xml.ws.soap.AddressingFeature.Responses.ALL
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AddressingFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Class AddressingFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature

  • public final class AddressingFeature
extends WebServiceFeature
    AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding. Using this feature with any other binding is undefined.

    This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    The following describes the effects of this feature with respect to be enabled or disabled:

    • ENABLED: In this Mode, WS-Addressing will be enabled. It means the endpoint supports WS-Addressing but does not require its use. A sender could send messages with WS-Addressing headers or without WS-Addressing headers. But a receiver MUST consume both types of messages.
    • DISABLED: In this Mode, WS-Addressing will be disabled. At runtime, WS-Addressing headers MUST NOT be used by a sender or receiver.

    If the feature is enabled, the required property determines whether the endpoint requires WS-Addressing. If it is set true, WS-Addressing headers MUST be present on incoming and outgoing messages. By default the required property is false.

    If the web service developer has not explicitly enabled this feature, WSDL's wsam:Addressing policy assertion is used to find the use of WS-Addressing. By using the feature explicitly, an application overrides WSDL's indication of the use of WS-Addressing. In some cases, this is really required. For example, if an application has implemented WS-Addressing itself, it can use this feature to disable addressing. That means a JAX-WS implementation doesn't consume or produce WS-Addressing headers.

    If addressing is enabled, a corresponding wsam:Addressing policy assertion must be generated in the WSDL as per 3.1 WS-Policy Assertions

    Example 1: Possible Policy Assertion in the generated WSDL for @Addressing

       <wsam:Addressing wsp:Optional="true">
     <wsp:Policy/>
   </wsam:Addressing>

    Example 2: Possible Policy Assertion in the generated WSDL for @Addressing(required=true)

       <wsam:Addressing>
     <wsp:Policy/>
   </wsam:Addressing>

    Example 3: Possible Policy Assertion in the generated WSDL for @Addressing(required=true, responses=Responses.ANONYMOUS)

       <wsam:Addressing>
      <wsp:Policy>
        <wsam:AnonymousResponses/>
      </wsp:Policy>
   </wsam:Addressing>

    See Web Services Addressing - Core, Web Services Addressing 1.0 - SOAP Binding, and Web Services Addressing 1.0 - Metadata for more information on WS-Addressing.

    Since:
    JAX-WS 2.1
    See Also:
    Addressing

    • Nested Class Summary

      Nested Classes
      Modifier and Type Class and Description
      static class  AddressingFeature.Responses
      If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      Constant value identifying the AddressingFeature
      protected boolean required
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • Constructor Summary

      Constructors
      Constructor and Description
      AddressingFeature()
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled)
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled, boolean required)
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled, boolean required, AddressingFeature.Responses responses)
      Creates and configures an AddressingFeature with the use of addressing requirements.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getID()
      Get the unique identifier for this WebServiceFeature.
      AddressingFeature.Responses getResponses()
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.
      boolean isRequired()
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

      • Methods inherited from class javax.xml.ws.WebServiceFeature

        isEnabled

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        Constant value identifying the AddressingFeature
        See Also:
        Constant Field Values

      • required

        protected boolean required
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, WS-Addressing headers MUST be present on incoming and outgoing messages.

    • Constructor Detail

      • AddressingFeature

        public AddressingFeature()
        Creates and configures an AddressingFeature with the use of addressing requirements. The created feature enables ws-addressing i.e. supports ws-addressing but doesn't require its use. It is also configured to accept all the response types.

      • AddressingFeature

        public AddressingFeature(boolean enabled)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled is true, it enables ws-addressing i.e. supports ws-addressing but doesn't require its use. It also configures to accept all the response types.
        Parameters:
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use

      • AddressingFeature

        public AddressingFeature(boolean enabled,
                         boolean required)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled and required are true, it enables ws-addressing and requires its use. It also configures to accept all the response types.
        Parameters:
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use
        required - true means requires the use of ws-addressing .

      • AddressingFeature

        public AddressingFeature(boolean enabled,
                         boolean required,
                         AddressingFeature.Responses responses)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled and required are true, it enables ws-addressing and requires its use. Also, the response types can be configured using responses parameter.
        Parameters:
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use
        required - true means requires the use of ws-addressing .
        responses - specifies what type of responses are required
        Since:
        JAX-WS 2.2

    • Method Detail

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        Specified by:
        getID in class WebServiceFeature
        Returns:
        the unique identifier for this feature.

      • isRequired

        public boolean isRequired()
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, WS-Addressing headers MUST be present on incoming and outgoing messages.
        Returns:
        the current required value

      • getResponses

        public AddressingFeature.Responses getResponses()
        If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.

        Returns:
        AddressingFeature.Responses.ALL when endpoint supports all types of responses, AddressingFeature.Responses.ANONYMOUS when endpoint requires the use of only anonymous responses, AddressingFeature.Responses.NON_ANONYMOUS when endpoint requires the use of only non-anonymous responses
        Since:
        JAX-WS 2.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AddressingFeature.Responses (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method
javax.xml.ws.soap

Enum AddressingFeature.Responses

  • java.lang.Object
    • java.lang.Enum<AddressingFeature.Responses>
      • javax.xml.ws.soap.AddressingFeature.Responses
  • All Implemented Interfaces:
    Serializable, Comparable<AddressingFeature.Responses>
    Enclosing class:
    AddressingFeature

    public static enum AddressingFeature.Responses
extends Enum<AddressingFeature.Responses>
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

    ALL supports all response types and this is the default value.

    ANONYMOUS requires the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

    NON_ANONYMOUS requires the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

    Since:
    JAX-WS 2.2

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALL
      Supports all response types and this is the default
      ANONYMOUS
      Specifies the use of only anonymous responses.
      NON_ANONYMOUS
      Specifies the use of only non-anonymous responses.

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static AddressingFeature.Responses valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AddressingFeature.Responses[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • Methods inherited from class java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • Methods inherited from class java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ANONYMOUS

        public static final AddressingFeature.Responses ANONYMOUS
        Specifies the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

      • NON_ANONYMOUS

        public static final AddressingFeature.Responses NON_ANONYMOUS
        Specifies the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

      • ALL

        public static final AddressingFeature.Responses ALL
        Supports all response types and this is the default

    • Method Detail

      • values

        public static AddressingFeature.Responses[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (AddressingFeature.Responses c : AddressingFeature.Responses.values())
    System.out.println(c);
        Returns:
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static AddressingFeature.Responses valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        Parameters:
        name - the name of the enum constant to be returned.
        Returns:
        the enum constant with the specified name
        Throws:
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Enum Constants |
  • Field |
  • Method
  • Detail:
  • Enum Constants |
  • Field |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MTOM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws.soap

Annotation Type MTOM

  • @Target(value={TYPE,METHOD,FIELD})
 @Retention(value=RUNTIME)
 @Documented
 @WebServiceFeatureAnnotation(id="http://www.w3.org/2004/08/soap/features/http-optimization",
                             bean=MTOMFeature.class)
public @interface MTOM
    This feature represents the use of MTOM with a web service.

    This annotation MUST only be used in conjunction the javax.jws.WebService, WebServiceProvider, WebServiceRef annotations. When used with the javax.jws.WebService annotation this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the MTOM annotation.

    This annotation's behaviour is defined by the corresponding feature MTOMFeature.

    Since:
    JAX-WS 2.1

    • Optional Element Summary

      Optional Elements
      Modifier and Type Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.
      int threshold
      Property for MTOM threshold value.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled.
        Default:
        true

      • threshold

        public abstract int threshold
        Property for MTOM threshold value. When MTOM is enabled, binary data above this size in bytes will be XOP encoded or sent as attachment. The value of this property MUST always be >= 0. Default value is 0.
        Default:
        0
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MTOMFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Class MTOMFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.MTOMFeature

  • public final class MTOMFeature
extends WebServiceFeature
    This feature represents the use of MTOM with a web service. This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    The following describes the affects of this feature with respect to being enabled or disabled:

    • ENABLED: In this Mode, MTOM will be enabled. A receiver MUST accept both a non-optimized and an optimized message, and a sender MAY send an optimized message, or a non-optimized message. The heuristics used by a sender to determine whether to use optimization or not are implementation-specific.
    • DISABLED: In this Mode, MTOM will be disabled

    The threshold property can be used to set the threshold value used to determine when binary data should be XOP encoded.

    Since:
    JAX-WS 2.1

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String ID
      Constant value identifying the MTOMFeature
      protected int threshold
      Property for MTOM threshold value.

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • Constructor Summary

      Constructors
      Constructor and Description
      MTOMFeature()
      Create an MTOMFeature.
      MTOMFeature(boolean enabled)
      Creates an MTOMFeature.
      MTOMFeature(boolean enabled, int threshold)
      Creates an MTOMFeature.
      MTOMFeature(int threshold)
      Creates an MTOMFeature.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getID()
      Get the unique identifier for this WebServiceFeature.
      int getThreshold()
      Gets the threshold value used to determine when binary data should be sent as an attachment.

      • Methods inherited from class javax.xml.ws.WebServiceFeature

        isEnabled

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • ID

        public static final String ID
        Constant value identifying the MTOMFeature
        See Also:
        Constant Field Values

      • threshold

        protected int threshold
        Property for MTOM threshold value. This property serves as a hint when MTOM is enabled, binary data above this size in bytes SHOULD be sent as attachment. The value of this property MUST always be >= 0. Default value is 0.

    • Constructor Detail

      • MTOMFeature

        public MTOMFeature()
        Create an MTOMFeature. The instance created will be enabled.

      • MTOMFeature

        public MTOMFeature(boolean enabled)
        Creates an MTOMFeature.
        Parameters:
        enabled - specifies if this feature should be enabled or not

      • MTOMFeature

        public MTOMFeature(int threshold)
        Creates an MTOMFeature. The instance created will be enabled.
        Parameters:
        threshold - the size in bytes that binary data SHOULD be before being sent as an attachment.
        Throws:
        WebServiceException - if threshold is < 0

      • MTOMFeature

        public MTOMFeature(boolean enabled,
                   int threshold)
        Creates an MTOMFeature.
        Parameters:
        enabled - specifies if this feature should be enabled or not
        threshold - the size in bytes that binary data SHOULD be before being sent as an attachment.
        Throws:
        WebServiceException - if threshold is < 0

    • Method Detail

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        Specified by:
        getID in class WebServiceFeature
        Returns:
        the unique identifier for this feature.

      • getThreshold

        public int getThreshold()
        Gets the threshold value used to determine when binary data should be sent as an attachment.
        Returns:
        the current threshold size in bytes
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.soap (Java Platform SE 8 )

javax.xml.ws.soap

Interfaces

  • SOAPBinding

Classes

  • AddressingFeature
  • MTOMFeature

Enums

  • AddressingFeature.Responses

Exceptions

  • SOAPFaultException

Annotation Types

  • Addressing
  • MTOM


javax.xml.ws.soap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.soap

This package defines APIs specific to the SOAP binding.

See: Description

  • Interface Summary
    Interface Description
    SOAPBinding
    The SOAPBinding interface is an abstraction for the SOAP binding.
  • Class Summary
    Class Description
    AddressingFeature
    AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
    MTOMFeature
    This feature represents the use of MTOM with a web service.
  • Enum Summary
    Enum Description
    AddressingFeature.Responses
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
  • Exception Summary
    Exception Description
    SOAPFaultException
    The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • Annotation Types Summary
    Annotation Type Description
    Addressing
    This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
    MTOM
    This feature represents the use of MTOM with a web service.

Package javax.xml.ws.soap Description

This package defines APIs specific to the SOAP binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.soap Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.soap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature
      • javax.xml.ws.soap.MTOMFeature

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.soap.SOAPBinding

Annotation Type Hierarchy

  • javax.xml.ws.soap.Addressing (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.MTOM (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.soap.AddressingFeature.Responses
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.soap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.soap

  • Packages that use javax.xml.ws.soap
    Package Description
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
  • Classes in javax.xml.ws.soap used by javax.xml.ws.soap
    Class and Description
    AddressingFeature.Responses
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Interface SOAPBinding

  • All Superinterfaces:
    Binding

    public interface SOAPBinding
extends Binding
    The SOAPBinding interface is an abstraction for the SOAP binding.
    Since:
    JAX-WS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String SOAP11HTTP_BINDING
      A constant representing the identity of the SOAP 1.1 over HTTP binding.
      static String SOAP11HTTP_MTOM_BINDING
      A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
      static String SOAP12HTTP_BINDING
      A constant representing the identity of the SOAP 1.2 over HTTP binding.
      static String SOAP12HTTP_MTOM_BINDING
      A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      MessageFactory getMessageFactory()
      Gets the SAAJ MessageFactory instance used by this SOAP binding.
      Set<String> getRoles()
      Gets the roles played by the SOAP binding instance.
      SOAPFactory getSOAPFactory()
      Gets the SAAJ SOAPFactory instance used by this SOAP binding.
      boolean isMTOMEnabled()
      Returns true if the use of MTOM is enabled.
      void setMTOMEnabled(boolean flag)
      Enables or disables use of MTOM.
      void setRoles(Set<String> roles)
      Sets the roles played by the SOAP binding instance.

      • Methods inherited from interface javax.xml.ws.Binding

        getBindingID, getHandlerChain, setHandlerChain

    • Field Detail

      • SOAP11HTTP_BINDING

        static final String SOAP11HTTP_BINDING
        A constant representing the identity of the SOAP 1.1 over HTTP binding.
        See Also:
        Constant Field Values

      • SOAP12HTTP_BINDING

        static final String SOAP12HTTP_BINDING
        A constant representing the identity of the SOAP 1.2 over HTTP binding.
        See Also:
        Constant Field Values

      • SOAP11HTTP_MTOM_BINDING

        static final String SOAP11HTTP_MTOM_BINDING
        A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
        See Also:
        Constant Field Values

      • SOAP12HTTP_MTOM_BINDING

        static final String SOAP12HTTP_MTOM_BINDING
        A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.
        See Also:
        Constant Field Values

    • Method Detail

      • getRoles

        Set<String> getRoles()
        Gets the roles played by the SOAP binding instance.
        Returns:
        Set<String> The set of roles played by the binding instance.

      • setRoles

        void setRoles(Set<String> roles)
        Sets the roles played by the SOAP binding instance.
        Parameters:
        roles - The set of roles played by the binding instance.
        Throws:
        WebServiceException - On an error in the configuration of the list of roles.

      • isMTOMEnabled

        boolean isMTOMEnabled()
        Returns true if the use of MTOM is enabled.
        Returns:
        true if and only if the use of MTOM is enabled.

      • setMTOMEnabled

        void setMTOMEnabled(boolean flag)
        Enables or disables use of MTOM.
        Parameters:
        flag - A boolean specifying whether the use of MTOM should be enabled or disabled.
        Throws:
        WebServiceException - If the specified setting is not supported by this binding instance.

      • getSOAPFactory

        SOAPFactory getSOAPFactory()
        Gets the SAAJ SOAPFactory instance used by this SOAP binding.
        Returns:
        SOAPFactory instance used by this SOAP binding.

      • getMessageFactory

        MessageFactory getMessageFactory()
        Gets the SAAJ MessageFactory instance used by this SOAP binding.
        Returns:
        MessageFactory instance used by this SOAP binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SOAPFaultException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.soap

Class SOAPFaultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException
  • All Implemented Interfaces:
    Serializable

    public class SOAPFaultException
extends ProtocolException
    The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

    A SOAPFaultException wraps a SAAJ SOAPFault that manages the SOAP-specific representation of faults. The createFault method of javax.xml.soap.SOAPFactory may be used to create an instance of javax.xml.soap.SOAPFault for use with the constructor. SOAPBinding contains an accessor for the SOAPFactory used by the binding instance.

    Note that the value of getFault is the only part of the exception used when searializing a SOAP fault.

    Refer to the SOAP specification for a complete description of SOAP faults.

    Since:
    JAX-WS 2.0
    See Also:
    SOAPFault, SOAPBinding.getSOAPFactory(), ProtocolException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SOAPFaultException(SOAPFault fault)
      Constructor for SOAPFaultException

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      SOAPFault getFault()
      Gets the embedded SOAPFault instance.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SOAPFaultException

        public SOAPFaultException(SOAPFault fault)
        Constructor for SOAPFaultException
        Parameters:
        fault - SOAPFault representing the fault
        See Also:
        SOAPFactory.createFault(java.lang.String, javax.xml.namespace.QName)

    • Method Detail

      • getFault

        public SOAPFault getFault()
        Gets the embedded SOAPFault instance.
        Returns:
        javax.xml.soap.SOAPFault SOAP fault element
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.soap.Addressing (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.Addressing

No usage of javax.xml.ws.soap.Addressing
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.soap.AddressingFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.AddressingFeature

No usage of javax.xml.ws.soap.AddressingFeature
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.soap.AddressingFeature.Responses (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.AddressingFeature.Responses

  • Packages that use AddressingFeature.Responses
    Package Description
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of AddressingFeature.Responses in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return AddressingFeature.Responses
      Modifier and Type Method and Description
      AddressingFeature.Responses AddressingFeature.getResponses()
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.
      static AddressingFeature.Responses AddressingFeature.Responses.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AddressingFeature.Responses[] AddressingFeature.Responses.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.xml.ws.soap with parameters of type AddressingFeature.Responses
      Constructor and Description
      AddressingFeature(boolean enabled, boolean required, AddressingFeature.Responses responses)
      Creates and configures an AddressingFeature with the use of addressing requirements.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.soap.MTOM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.MTOM

No usage of javax.xml.ws.soap.MTOM
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.soap.MTOMFeature (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.MTOMFeature

No usage of javax.xml.ws.soap.MTOMFeature
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.ws.soap.SOAPBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.ws.soap.SOAPBinding

No usage of javax.xml.ws.soap.SOAPBinding
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.soap.SOAPFaultException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.soap.SOAPFaultException

No usage of javax.xml.ws.soap.SOAPFaultException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Invoker (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi

Class Invoker

  • java.lang.Object
    • javax.xml.ws.spi.Invoker

  • public abstract class Invoker
extends Object
    Invoker hides the detail of calling into application endpoint implementation. Container hands over an implementation of Invoker to JAX-WS runtime, and jax-ws runtime calls invoke(java.lang.reflect.Method, java.lang.Object...) for a web service invocation. Finally, Invoker does the actual invocation of web service on endpoint instance. Container also injects the provided WebServiceContext and takes care of invoking javax.annotation.PostConstruct methods, if present, on the endpoint implementation.
    Since:
    JAX-WS 2.2
    See Also:
    Provider.createEndpoint(String, Class, Invoker, WebServiceFeature...)

    • Constructor Summary

      Constructors
      Constructor and Description
      Invoker()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void inject(WebServiceContext webServiceContext)
      JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
      abstract Object invoke(Method m, Object... args)
      JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Invoker

        public Invoker()

    • Method Detail

      • inject

        public abstract void inject(WebServiceContext webServiceContext)
                     throws IllegalAccessException,
                            IllegalArgumentException,
                            InvocationTargetException
        JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance. The WebServiceContext object uses thread-local information to return the correct information during the actual endpoint invocation regardless of how many threads are concurrently being used to serve requests.
        Parameters:
        webServiceContext - a holder for MessageContext
        Throws:
        IllegalAccessException - if the injection done by reflection API throws this exception
        IllegalArgumentException - if the injection done by reflection API throws this exception
        InvocationTargetException - if the injection done by reflection API throws this exception

      • invoke

        public abstract Object invoke(Method m,
                              Object... args)
                       throws IllegalAccessException,
                              IllegalArgumentException,
                              InvocationTargetException
        JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance. The injected WebServiceContext.getMessageContext() gives the correct information for this invocation.
        Parameters:
        m - Method to be invoked on the service
        args - Method arguments
        Returns:
        return value of the method
        Throws:
        IllegalAccessException - if the invocation done by reflection API throws this exception
        IllegalArgumentException - if the invocation done by reflection API throws this exception
        InvocationTargetException - if the invocation done by reflection API throws this exception
        See Also:
        Method.invoke(java.lang.Object, java.lang.Object...)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.spi (Java Platform SE 8 )

javax.xml.ws.spi

Classes

  • Invoker
  • Provider
  • ServiceDelegate

Annotation Types

  • WebServiceFeatureAnnotation


javax.xml.ws.spi (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.spi

This package defines SPIs for JAX-WS.

See: Description

  • Class Summary
    Class Description
    Invoker
    Invoker hides the detail of calling into application endpoint implementation.
    Provider
    Service provider for ServiceDelegate and Endpoint objects.
    ServiceDelegate
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.
  • Annotation Types Summary
    Annotation Type Description
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.

Package javax.xml.ws.spi Description

This package defines SPIs for JAX-WS.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.spi Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.spi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.Invoker
    • javax.xml.ws.spi.Provider
    • javax.xml.ws.spi.ServiceDelegate

Annotation Type Hierarchy

  • javax.xml.ws.spi.WebServiceFeatureAnnotation (implements java.lang.annotation.Annotation)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.spi (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.spi

  • Packages that use javax.xml.ws.spi
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.ws.spi used by javax.xml.ws
    Class and Description
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.
  • Classes in javax.xml.ws.spi used by javax.xml.ws.soap
    Class and Description
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.
  • Classes in javax.xml.ws.spi used by javax.xml.ws.spi
    Class and Description
    Invoker
    Invoker hides the detail of calling into application endpoint implementation.
    Provider
    Service provider for ServiceDelegate and Endpoint objects.
    ServiceDelegate
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Provider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi

Class Provider

  • java.lang.Object
    • javax.xml.ws.spi.Provider

  • public abstract class Provider
extends Object
    Service provider for ServiceDelegate and Endpoint objects.

    Since:
    JAX-WS 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String JAXWSPROVIDER_PROPERTY
      A constant representing the property used to lookup the name of a Provider implementation class.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected Provider()
      Creates a new instance of Provider

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Endpoint createAndPublishEndpoint(String address, Object implementor)
      Creates and publishes an endpoint object with the specified address and implementation object.
      Endpoint createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      Endpoint createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      abstract Endpoint createEndpoint(String bindingId, Object implementor)
      Creates an endpoint object with the provided binding and implementation object.
      Endpoint createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
      abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract W3CEndpointReference createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      abstract <T> T getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static Provider provider()
      Creates a new provider object.
      abstract EndpointReference readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • JAXWSPROVIDER_PROPERTY

        public static final String JAXWSPROVIDER_PROPERTY
        A constant representing the property used to lookup the name of a Provider implementation class.
        See Also:
        Constant Field Values

    • Constructor Detail

      • Provider

        protected Provider()
        Creates a new instance of Provider

    • Method Detail

      • provider

        public static Provider provider()
        Creates a new provider object.

        The algorithm used to locate the provider subclass to use consists of the following steps:

        • If a resource with the name of META-INF/services/javax.xml.ws.spi.Provider exists, then its first line, if present, is used as the UTF-8 encoded name of the implementation class.
        • If the $java.home/lib/jaxws.properties file exists and it is readable by the java.util.Properties.load(InputStream) method and it contains an entry whose key is javax.xml.ws.spi.Provider, then the value of that entry is used as the name of the implementation class.
        • If a system property with the name javax.xml.ws.spi.Provider is defined, then its value is used as the name of the implementation class.
        • Finally, a default implementation class name is used.

      • createServiceDelegate

        public abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                                      QName serviceName,
                                                      Class<? extends Service> serviceClass)
        Creates a service delegate object.

        Parameters:
        wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
        serviceName - The qualified name of the service.
        serviceClass - The service class, which MUST be either javax.xml.ws.Service or a subclass thereof.
        Returns:
        The newly created service delegate.

      • createServiceDelegate

        public ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                             QName serviceName,
                                             Class<? extends Service> serviceClass,
                                             WebServiceFeature... features)
        Creates a service delegate object.

        Parameters:
        wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
        serviceName - The qualified name of the service.
        serviceClass - The service class, which MUST be either javax.xml.ws.Service or a subclass thereof.
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        Returns:
        The newly created service delegate.
        Since:
        JAX-WS 2.2

      • createEndpoint

        public abstract Endpoint createEndpoint(String bindingId,
                                        Object implementor)
        Creates an endpoint object with the provided binding and implementation object.
        Parameters:
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        Returns:
        The newly created endpoint.

      • createAndPublishEndpoint

        public abstract Endpoint createAndPublishEndpoint(String address,
                                                  Object implementor)
        Creates and publishes an endpoint object with the specified address and implementation object.
        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        Returns:
        The newly created endpoint.

      • readEndpointReference

        public abstract EndpointReference readEndpointReference(Source eprInfoset)
        read an EndpointReference from the infoset contained in eprInfoset.
        Parameters:
        eprInfoset - infoset for EndpointReference
        Returns:
        the EndpointReference unmarshalled from eprInfoset. This method never returns null.
        Throws:
        WebServiceException - If there is an error creating the EndpointReference from the specified eprInfoset.
        NullPointerException - If the null eprInfoset value is given.
        Since:
        JAX-WS 2.1

      • getPort

        public abstract <T> T getPort(EndpointReference endpointReference,
                              Class<T> serviceEndpointInterface,
                              WebServiceFeature... features)
        The getPort method returns a proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL metadata of the serviceEndpointInterface and the EndpointReference. For this method to successfully return a proxy, WSDL metadata MUST be available and the endpointReference MUST contain an implementation understood serviceName metadata.
        Parameters:
        endpointReference - the EndpointReference that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method}
        • If this endpointReference is illegal
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        WebServiceFeature

      • createW3CEndpointReference

        public abstract W3CEndpointReference createW3CEndpointReference(String address,
                                                                QName serviceName,
                                                                QName portName,
                                                                List<Element> metadata,
                                                                String wsdlDocumentLocation,
                                                                List<Element> referenceParameters)
        Factory method to create a W3CEndpointReference.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. To do so the address property can be provided or this method can automatically determine the address of an endpoint that is published by the same Java EE application and is identified by the serviceName and portName propeties. If the address is null and the serviceName and portName do not identify an endpoint published by the same Java EE application, a javax.lang.IllegalStateException MUST be thrown.

        Parameters:
        address - Specifies the address of the target endpoint
        serviceName - Qualified name of the service in the WSDL.
        portName - Qualified name of the endpoint in the WSDL.
        metadata - A list of elements that should be added to the W3CEndpointReference instances wsa:metadata element.
        wsdlDocumentLocation - URL for the WSDL document location for the service.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        Returns:
        the W3CEndpointReference created from serviceName, portName, metadata, wsdlDocumentLocation and referenceParameters. This method never returns null.
        Throws:
        IllegalStateException -
        • If the address, serviceName and portName are all null.
        • If the serviceName service is null and the portName is NOT null.
        • If the address property is null and the serviceName and portName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceNameis NOT null and is not present in the specified WSDL.
        • If the portName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
        Since:
        JAX-WS 2.1

      • createW3CEndpointReference

        public W3CEndpointReference createW3CEndpointReference(String address,
                                                       QName interfaceName,
                                                       QName serviceName,
                                                       QName portName,
                                                       List<Element> metadata,
                                                       String wsdlDocumentLocation,
                                                       List<Element> referenceParameters,
                                                       List<Element> elements,
                                                       Map<QName,String> attributes)
        Factory method to create a W3CEndpointReference. Using this method, a W3CEndpointReference instance can be created with extension elements, and attributes. Provider implementations must override the default implementation.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. To do so the address property can be provided or this method can automatically determine the address of an endpoint that is published by the same Java EE application and is identified by the serviceName and portName propeties. If the address is null and the serviceName and portName do not identify an endpoint published by the same Java EE application, a javax.lang.IllegalStateException MUST be thrown.

        Parameters:
        address - Specifies the address of the target endpoint
        interfaceName - the wsam:InterfaceName element in the wsa:Metadata element.
        serviceName - Qualified name of the service in the WSDL.
        portName - Qualified name of the endpoint in the WSDL.
        metadata - A list of elements that should be added to the W3CEndpointReference instances wsa:metadata element.
        wsdlDocumentLocation - URL for the WSDL document location for the service.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        elements - extension elements to be associated with the returned EndpointReference instance.
        attributes - extension attributes to be associated with the returned EndpointReference instance.
        Returns:
        the W3CEndpointReference created from serviceName, portName, metadata, wsdlDocumentLocation and referenceParameters. This method never returns null.
        Throws:
        IllegalStateException -
        • If the address, serviceName and portName are all null.
        • If the serviceName service is null and the portName is NOT null.
        • If the address property is null and the serviceName and portName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceNameis NOT null and is not present in the specified WSDL.
        • If the portName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        • If the wsdlDocumentLocation is NOT null but wsdli:wsdlLocation's namespace name cannot be got from the available metadata.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
        Since:
        JAX-WS 2.2

      • createAndPublishEndpoint

        public Endpoint createAndPublishEndpoint(String address,
                                         Object implementor,
                                         WebServiceFeature... features)
        Creates and publishes an endpoint object with the specified address, implementation object and web service features. Provider implementations must override the default implementation.
        Parameters:
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • createEndpoint

        public Endpoint createEndpoint(String bindingId,
                               Object implementor,
                               WebServiceFeature... features)
        Creates an endpoint object with the provided binding, implementation object and web service features. Provider implementations must override the default implementation.
        Parameters:
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2

      • createEndpoint

        public Endpoint createEndpoint(String bindingId,
                               Class<?> implementorClass,
                               Invoker invoker,
                               WebServiceFeature... features)
        Creates an endpoint object with the provided binding, implementation class, invoker and web service features. Containers typically use this to create Endpoint objects. Provider implementations must override the default implementation.
        Parameters:
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP). Can be null.
        implementorClass - A service implementation class that MUST be annotated with all the necessary Web service annotations.
        invoker - that does the actual invocation on the service instance.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        Returns:
        The newly created endpoint.
        Since:
        JAX-WS 2.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceDelegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi

Class ServiceDelegate

  • java.lang.Object
    • javax.xml.ws.spi.ServiceDelegate

  • public abstract class ServiceDelegate
extends Object
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

    Every Service object has its own delegate, created using the Provider.createServiceDelegate(java.net.URL, javax.xml.namespace.QName, java.lang.Class<? extends javax.xml.ws.Service>) method. A Service object delegates all of its instance methods to its delegate.

    Since:
    JAX-WS 2.0
    See Also:
    Service, Provider

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ServiceDelegate()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      abstract <T> Dispatch<T> createDispatch(EndpointReference endpointReference, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> createDispatch(QName portName, Class<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Executor getExecutor()
      Returns the executor for this Serviceinstance.
      abstract HandlerResolver getHandlerResolver()
      Returns the configured handler resolver.
      abstract <T> T getPort(Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T getPort(Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T getPort(EndpointReference endpointReference, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T getPort(QName portName, Class<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T getPort(QName portName, Class<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract Iterator<QName> getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      abstract QName getServiceName()
      Gets the name of this service.
      abstract URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.
      abstract void setExecutor(Executor executor)
      Sets the executor for this Service instance.
      abstract void setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceDelegate

        protected ServiceDelegate()

    • Method Detail

      • getPort

        public abstract <T> T getPort(QName portName,
                              Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface or portName is specified
        See Also:
        Proxy, InvocationHandler

      • getPort

        public abstract <T> T getPort(QName portName,
                              Class<T> serviceEndpointInterface,
                              WebServiceFeature... features)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        Parameters:
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or instance
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface
        Throws:
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface or portName is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Proxy, InvocationHandler, WebServiceFeature

      • getPort

        public abstract <T> T getPort(EndpointReference endpointReference,
                              Class<T> serviceEndpointInterface,
                              WebServiceFeature... features)
        The getPort method returns a proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference metadata also has a WSDL, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. The returned proxy should not be reconfigured by the client. If this Service instance has a known proxy port that matches the information contained in the WSDL, then that proxy is returned, otherwise a WebServiceException is thrown.

        Calling this method has the same behavior as the following

         port = service.getPort(portName, serviceEndpointInterface);
        where the portName is retrieved from the metadata of the endpointReference or from the serviceEndpointInterface and the WSDL associated with this Service instance.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object Proxy instance that supports the specified service endpoint interface.
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName of this Service instance.
        • If a portName cannot be extracted from the WSDL or endpointReference metadata.
        • If an invalid endpointReference is specified.
        • If an invalid serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1

      • getPort

        public abstract <T> T getPort(Class<T> serviceEndpointInterface)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface
        Returns:
        Object instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface is specified

      • getPort

        public abstract <T> T getPort(Class<T> serviceEndpointInterface,
                              WebServiceFeature... features)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        Parameters:
        serviceEndpointInterface - Service endpoint interface
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Object instance that supports the specified service endpoint interface
        Throws:
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        WebServiceFeature

      • addPort

        public abstract void addPort(QName portName,
                             String bindingId,
                             String endpointAddress)
        Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.
        Parameters:
        portName - Qualified name for the target service endpoint
        bindingId - A URI identifier of a binding.
        endpointAddress - Address of the target service endpoint as a URI
        Throws:
        WebServiceException - If any error in the creation of the port
        See Also:
        SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(QName portName,
                                               Class<T> type,
                                               Service.Mode mode)
        Creates a Dispatch instance for use with objects of the user's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object
        See Also:
        Source, SOAPMessage

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(QName portName,
                                               Class<T> type,
                                               Service.Mode mode,
                                               WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the user's choosing.
        Parameters:
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(EndpointReference endpointReference,
                                               Class<T> type,
                                               Service.Mode mode,
                                               WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the user's choosing. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behaves the same as calling

         dispatch = service.createDispatch(portName, type, mode, features);
        where the portName is retrieved from the WSDL or EndpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public abstract Dispatch<Object> createDispatch(QName portName,
                                                JAXBContext context,
                                                Service.Mode mode)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object
        See Also:
        JAXBContext

      • createDispatch

        public abstract Dispatch<Object> createDispatch(QName portName,
                                                JAXBContext context,
                                                Service.Mode mode,
                                                WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects.
        Parameters:
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • createDispatch

        public abstract Dispatch<Object> createDispatch(EndpointReference endpointReference,
                                                JAXBContext context,
                                                Service.Mode mode,
                                                WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behavies the same as calling

         dispatch = service.createDispatch(portName, context, mode, features);
        where the portName is retrieved from the WSDL or endpointReference metadata.
        Parameters:
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        Returns:
        Dispatch instance
        Throws:
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • if a feature is enabled that is not compatible with this port or is unsupported.
        Since:
        JAX-WS 2.1
        See Also:
        JAXBContext, WebServiceFeature

      • getServiceName

        public abstract QName getServiceName()
        Gets the name of this service.
        Returns:
        Qualified name of this service

      • getPorts

        public abstract Iterator<QName> getPorts()
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        Returns:
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName
        Throws:
        WebServiceException - If this Service class does not have access to the required WSDL metadata

      • getWSDLDocumentLocation

        public abstract URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        Returns:
        URL for the location of the WSDL document for this service

      • getHandlerResolver

        public abstract HandlerResolver getHandlerResolver()
        Returns the configured handler resolver.
        Returns:
        HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

      • setHandlerResolver

        public abstract void setHandlerResolver(HandlerResolver handlerResolver)
        Sets the HandlerResolver for this Service instance.

        The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

        Parameters:
        handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
        See Also:
        HandlerResolver

      • getExecutor

        public abstract Executor getExecutor()
        Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.
        Returns:
        The java.util.concurrent.Executor to be used to invoke a callback.
        See Also:
        Executor

      • setExecutor

        public abstract void setExecutor(Executor executor)
        Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.
        Parameters:
        executor - The java.util.concurrent.Executor to be used to invoke a callback.
        Throws:
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        See Also:
        Executor
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WebServiceFeatureAnnotation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element
javax.xml.ws.spi

Annotation Type WebServiceFeatureAnnotation

  • @Target(value=ANNOTATION_TYPE)
 @Retention(value=RUNTIME)
 @Documented
public @interface WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.

    Each WebServiceFeature annotation annotated with this annotation MUST contain an enabled property of type boolean with a default value of true.

    JAX-WS defines the following WebServiceFeature annotations (Addressing, MTOM, RespectBinding), however, an implementation may define vendors specific annotations for other features.

    Annotations annotated with WebServiceFeatureAnnotation MUST have the same @Target of WebServiceRef annotation, so that the resulting feature annotation can be used in conjunction with the WebServiceRef annotation if necessary.

    If a JAX-WS implementation encounters an annotation annotated with the WebServiceFeatureAnnotation that it does not recognize/support an error MUST be given.

    Since:
    JAX-WS 2.1
    See Also:
    Addressing, MTOM, RespectBinding

    • Required Element Summary

      Required Elements
      Modifier and Type Required Element and Description
      Class<? extends WebServiceFeature> bean
      The WebServiceFeature bean that is associated with the WebServiceFeature annotation
      String id
      Unique identifier for the WebServiceFeature.

    • Element Detail

      • id

        public abstract String id
        Unique identifier for the WebServiceFeature. This identifier MUST be unique across all implementations of JAX-WS.

      • bean

        public abstract Class<? extends WebServiceFeature> bean
        The WebServiceFeature bean that is associated with the WebServiceFeature annotation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Field |
  • Required |
  • Optional
  • Detail:
  • Field |
  • Element

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.Invoker (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.Invoker

  • Packages that use Invoker
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Invoker in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Invoker
      Modifier and Type Method and Description
      Endpoint Provider.createEndpoint(String bindingId, Class<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.Provider (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.Provider

  • Packages that use Provider
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Provider in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Provider
      Modifier and Type Method and Description
      static Provider Provider.provider()
      Creates a new provider object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.ServiceDelegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.ServiceDelegate

  • Packages that use ServiceDelegate
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of ServiceDelegate in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return ServiceDelegate
      Modifier and Type Method and Description
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.WebServiceFeatureAnnotation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.WebServiceFeatureAnnotation

  • Packages that use WebServiceFeatureAnnotation
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of WebServiceFeatureAnnotation in javax.xml.ws

      Classes in javax.xml.ws with annotations of type WebServiceFeatureAnnotation
      Modifier and Type Class and Description
      interface  RespectBinding
      This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

    • Uses of WebServiceFeatureAnnotation in javax.xml.ws.soap

      Classes in javax.xml.ws.soap with annotations of type WebServiceFeatureAnnotation
      Modifier and Type Class and Description
      interface  Addressing
      This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
      interface  MTOM
      This feature represents the use of MTOM with a web service.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HttpContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi.http

Class HttpContext

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpContext

  • public abstract class HttpContext
extends Object
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.

    Container provides the implementation for this and it matches web service requests to corresponding HttpContext objects.

    Since:
    JAX-WS 2.2

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected HttpHandler | handler

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpContext()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Object getAttribute(String name)
      Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.
      abstract Set<String> getAttributeNames()
      Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.
      abstract String getPath()
      Returns the path for this context.
      void setHandler(HttpHandler handler)
      JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • handler

        protected HttpHandler handler

    • Constructor Detail

      • HttpContext

        public HttpContext()

    • Method Detail

      • setHandler

        public void setHandler(HttpHandler handler)
        JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context. Container or its extensions use this handler to process the requests.
        Parameters:
        handler - the handler to set for this context

      • getPath

        public abstract String getPath()
        Returns the path for this context. This path uniquely identifies an endpoint inside an application and the path is relative to application's context path. Container should give this path based on how it matches request URIs to this HttpContext object.

        For servlet container, this is typically a url-pattern for an endpoint.

        Endpoint's address for this context can be computed as follows:

          HttpExchange exch = ...;
  String endpointAddress =
      exch.getScheme() + "://"
      + exch.getLocalAddress().getHostName()
      + ":" + exch.getLocalAddress().getPort()
      + exch.getContextPath() + getPath();
        Returns:
        this context's path

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.
        Parameters:
        name - attribute name
        Returns:
        attribute value

      • getAttributeNames

        public abstract Set<String> getAttributeNames()
        Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.
        Returns:
        set of all attribute names
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HttpExchange (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi.http

Class HttpExchange

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpExchange

  • public abstract class HttpExchange
extends Object
    This class encapsulates a HTTP request received and a response to be generated in one exchange. It provides methods for examining the request from the client, and for building and sending the response.

    A HttpExchange must be closed to free or reuse underlying resources. The effect of failing to close an exchange is undefined.

    Since:
    JAX-WS 2.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String REQUEST_CIPHER_SUITE
      Standard property: cipher suite value when the request is received over HTTPS
      static String REQUEST_KEY_SIZE
      Standard property: bit size of the algorithm when the request is received over HTTPS
      static String REQUEST_X509CERTIFICATE
      Standard property: A SSL certificate, if any, associated with the request

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpExchange()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void addResponseHeader(String name, String value)
      Adds a response header with the given name and value.
      abstract void close()
      This must be called to end an exchange.
      abstract Object getAttribute(String name)
      Returns an attribute that is associated with this HttpExchange.
      abstract Set<String> getAttributeNames()
      Gives all the attribute names that are associated with this HttpExchange.
      abstract String getContextPath()
      Returns the context path of all the endpoints in an application.
      abstract HttpContext getHttpContext()
      Returns a HttpContext for this exchange.
      abstract InetSocketAddress getLocalAddress()
      Returns the unresolved local address on which the request was received.
      abstract String getPathInfo()
      Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.
      abstract String getProtocol()
      Returns the protocol string from the request in the form protocol/majorVersion.minorVersion.
      abstract String getQueryString()
      Returns the query string that is contained in the request URI after the path.
      abstract InetSocketAddress getRemoteAddress()
      Returns the unresolved address of the remote entity invoking this request.
      abstract InputStream getRequestBody()
      Returns a stream from which the request body can be read.
      abstract String getRequestHeader(String name)
      Returns the value of the specified request header.
      abstract Map<String,List<String>> getRequestHeaders()
      Returns an immutable Map containing the HTTP headers that were included with this request.
      abstract String getRequestMethod()
      Get the HTTP request method
      abstract String getRequestURI()
      Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request.
      abstract OutputStream getResponseBody()
      Returns a stream to which the response body must be written.
      abstract Map<String,List<String>> getResponseHeaders()
      Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.
      abstract String getScheme()
      Returns the name of the scheme used to make this request, for example: http, or https.
      abstract Principal getUserPrincipal()
      Returns the Principal that represents the authenticated user for this HttpExchange.
      abstract boolean isUserInRole(String role)
      Indicates whether an authenticated user is included in the specified logical "role".
      abstract void setStatus(int status)
      Sets the HTTP status code for the response.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • REQUEST_CIPHER_SUITE

        public static final String REQUEST_CIPHER_SUITE
        Standard property: cipher suite value when the request is received over HTTPS

        Type: String

        See Also:
        Constant Field Values

      • REQUEST_KEY_SIZE

        public static final String REQUEST_KEY_SIZE
        Standard property: bit size of the algorithm when the request is received over HTTPS

        Type: Integer

        See Also:
        Constant Field Values

      • REQUEST_X509CERTIFICATE

        public static final String REQUEST_X509CERTIFICATE
        Standard property: A SSL certificate, if any, associated with the request

        Type: java.security.cert.X509Certificate[] The order of this array is defined as being in ascending order of trust. The first certificate in the chain is the one set by the client, the next is the one used to authenticate the first, and so on.

        See Also:
        Constant Field Values

    • Constructor Detail

      • HttpExchange

        public HttpExchange()

    • Method Detail

      • getRequestHeaders

        public abstract Map<String,List<String>> getRequestHeaders()
        Returns an immutable Map containing the HTTP headers that were included with this request. The keys in this Map will be the header names, while the values will be a List of Strings containing each value that was included (either for a header that was listed several times, or one that accepts a comma-delimited list of values on a single line). In either of these cases, the values for the header name will be presented in the order that they were included in the request.

        The keys in Map are case-insensitive.

        Returns:
        an immutable Map which can be used to access request headers

      • getRequestHeader

        public abstract String getRequestHeader(String name)
        Returns the value of the specified request header. If the request did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first header in the request. The header name is case-insensitive. This is a convienence method to get a header (instead of using the getRequestHeaders()).
        Parameters:
        name - the name of the request header
        Returns:
        returns the value of the requested header, or null if the request does not have a header of that name

      • getResponseHeaders

        public abstract Map<String,List<String>> getResponseHeaders()
        Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response. The keys in the Map will be the header names, while the values must be a List of Strings containing each value that should be included multiple times (in the order that they should be included).

        The keys in Map are case-insensitive.

        Returns:
        a mutable Map which can be used to set response headers.

      • addResponseHeader

        public abstract void addResponseHeader(String name,
                                       String value)
        Adds a response header with the given name and value. This method allows a response header to have multiple values. This is a convenience method to add a response header(instead of using the getResponseHeaders()).
        Parameters:
        name - the name of the header
        value - the additional header value. If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        See Also:
        getResponseHeaders()

      • getRequestURI

        public abstract String getRequestURI()
        Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request. Container doesn't decode this string.
        Returns:
        the request URI

      • getContextPath

        public abstract String getContextPath()
        Returns the context path of all the endpoints in an application. This path is the portion of the request URI that indicates the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. If this method returns "", the request is for default context. The container does not decode this string.

        Context path is used in computing the endpoint address. See HttpContext.getPath()

        Returns:
        context path of all the endpoints in an application
        See Also:
        HttpContext.getPath()

      • getRequestMethod

        public abstract String getRequestMethod()
        Get the HTTP request method
        Returns:
        the request method

      • getHttpContext

        public abstract HttpContext getHttpContext()
        Returns a HttpContext for this exchange. Container matches the request with the associated Endpoint's HttpContext
        Returns:
        the HttpContext for this exchange

      • close

        public abstract void close()
                    throws IOException
        This must be called to end an exchange. Container takes care of closing request and response streams. This must be called so that the container can free or reuse underlying resources.
        Throws:
        IOException - if any i/o error

      • getRequestBody

        public abstract InputStream getRequestBody()
                                    throws IOException
        Returns a stream from which the request body can be read. Multiple calls to this method will return the same stream.
        Returns:
        the stream from which the request body can be read.
        Throws:
        IOException - if any i/o error during request processing

      • getResponseBody

        public abstract OutputStream getResponseBody()
                                      throws IOException
        Returns a stream to which the response body must be written. setStatus(int)) must be called prior to calling this method. Multiple calls to this method (for the same exchange) will return the same stream.
        Returns:
        the stream to which the response body is written
        Throws:
        IOException - if any i/o error during response processing

      • setStatus

        public abstract void setStatus(int status)
        Sets the HTTP status code for the response.

        This method must be called prior to calling getResponseBody().

        Parameters:
        status - the response code to send
        See Also:
        getResponseBody()

      • getRemoteAddress

        public abstract InetSocketAddress getRemoteAddress()
        Returns the unresolved address of the remote entity invoking this request.
        Returns:
        the InetSocketAddress of the caller

      • getLocalAddress

        public abstract InetSocketAddress getLocalAddress()
        Returns the unresolved local address on which the request was received.
        Returns:
        the InetSocketAddress of the local interface

      • getProtocol

        public abstract String getProtocol()
        Returns the protocol string from the request in the form protocol/majorVersion.minorVersion. For example, "HTTP/1.1"
        Returns:
        the protocol string from the request

      • getScheme

        public abstract String getScheme()
        Returns the name of the scheme used to make this request, for example: http, or https.
        Returns:
        name of the scheme used to make this request

      • getPathInfo

        public abstract String getPathInfo()
        Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.

        This can be used for MessageContext.PATH_INFO

        Returns:
        decoded extra path information of web service. It is the path that comes after the web service path but before the query string in the request URI null if there is no extra path in the request URI

      • getQueryString

        public abstract String getQueryString()
        Returns the query string that is contained in the request URI after the path.

        This can be used for MessageContext.QUERY_STRING

        Returns:
        undecoded query string of request URI, or null if the request URI doesn't have one

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns an attribute that is associated with this HttpExchange. JAX-WS handlers and endpoints may then access the attribute via MessageContext.

        Servlet containers must expose MessageContext.SERVLET_CONTEXT, MessageContext.SERVLET_REQUEST, and MessageContext.SERVLET_RESPONSE as attributes.

        If the request has been received by the container using HTTPS, the following information must be exposed as attributes. These attributes are REQUEST_CIPHER_SUITE, and REQUEST_KEY_SIZE. If there is a SSL certificate associated with the request, it must be exposed using REQUEST_X509CERTIFICATE

        Parameters:
        name - attribute name
        Returns:
        the attribute value, or null if the attribute doesn't exist

      • getAttributeNames

        public abstract Set<String> getAttributeNames()
        Gives all the attribute names that are associated with this HttpExchange.
        Returns:
        set of all attribute names
        See Also:
        getAttribute(String)

      • getUserPrincipal

        public abstract Principal getUserPrincipal()
        Returns the Principal that represents the authenticated user for this HttpExchange.
        Returns:
        Principal for an authenticated user, or null if not authenticated

      • isUserInRole

        public abstract boolean isUserInRole(String role)
        Indicates whether an authenticated user is included in the specified logical "role".
        Parameters:
        role - specifies the name of the role
        Returns:
        true if the user making this request belongs to a given role
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HttpHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.spi.http

Class HttpHandler

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpHandler

  • public abstract class HttpHandler
extends Object
    A handler which is invoked to process HTTP requests.

    JAX-WS runtime provides the implementation for this and sets it using HttpContext.setHandler(HttpHandler) during Endpoint.publish(HttpContext)

    Since:
    JAX-WS 2.2

    • Constructor Summary

      Constructors
      Constructor and Description
      HttpHandler()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void handle(HttpExchange exchange)
      Handles a given request and generates an appropriate response.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HttpHandler

        public HttpHandler()

    • Method Detail

      • handle

        public abstract void handle(HttpExchange exchange)
                     throws IOException
        Handles a given request and generates an appropriate response. See HttpExchange for a description of the steps involved in handling an exchange. Container invokes this method when it receives an incoming request.
        Parameters:
        exchange - the exchange containing the request from the client and used to send the response
        Throws:
        IOException - when an I/O error happens during request handling
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.spi.http (Java Platform SE 8 )

javax.xml.ws.spi.http

Classes

  • HttpContext
  • HttpExchange
  • HttpHandler


javax.xml.ws.spi.http (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.spi.http

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

See: Description

  • Class Summary
    Class Description
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
    HttpExchange
    This class encapsulates a HTTP request received and a response to be generated in one exchange.
    HttpHandler
    A handler which is invoked to process HTTP requests.

Package javax.xml.ws.spi.http Description

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g. servlet containers). This SPI is not for end developers but provides a way for the container developers to deploy JAX-WS services portably.

The portable deployment is done as below:

  1. Container creates Endpoint objects for an application. The necessary information to create Endpoint objects may be got from web service deployment descriptor files.
  2. Container needs to create HttpContext objects for the deployment. For example, a HttpContext could be created using servlet configuration(for e.g url-pattern) for the web service in servlet container case.
  3. Then publishes all the endpoints using Endpoint.publish(HttpContext). During publish(), JAX-WS runtime registers a HttpHandler callback to handle incoming requests or HttpExchange objects. The HttpExchange object encapsulates a HTTP request and a response.
  Container                               JAX-WS runtime
  ---------                               --------------
  1. Creates Invoker1, ... InvokerN
  2. Provider.createEndpoint(...)     --> 3. creates Endpoint1
     configures Endpoint1
     ...
  4. Provider.createEndpoint(...)     --> 5. creates EndpointN
     configures EndpointN
  6. Creates ApplicationContext
  7. creates HttpContext1, ... HttpContextN
  8. Endpoint1.publish(HttpContext1)  --> 9. creates HttpHandler1
                                          HttpContext1.setHandler(HttpHandler1)
     ...
 10. EndpointN.publish(HttpContextN)  --> 11. creates HttpHandlerN
                                         HttpContextN.setHandler(HttpHandlerN)
The request processing is done as below(for every request):
  Container                               JAX-WS runtime
  ---------                               --------------
  1. Creates a HttpExchange
  2. Gets handler from HttpContext
  3. HttpHandler.handle(HttpExchange) --> 4. reads request from HttpExchange
                                      <-- 5. Calls Invoker
  6. Invokes the actual instance
                                          7. Writes the response to HttpExchange

The portable undeployment is done as below:

  Container
  ---------
  1. @preDestroy on instances
  2. Endpoint1.stop()
  ...
  3. EndpointN.stop()
Since:
JAX-WS 2.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.spi.http Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.spi.http

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpContext
    • javax.xml.ws.spi.http.HttpExchange
    • javax.xml.ws.spi.http.HttpHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.spi.http (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.spi.http

  • Packages that use javax.xml.ws.spi.http
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.
  • Classes in javax.xml.ws.spi.http used by javax.xml.ws
    Class and Description
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
  • Classes in javax.xml.ws.spi.http used by javax.xml.ws.spi.http
    Class and Description
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
    HttpExchange
    This class encapsulates a HTTP request received and a response to be generated in one exchange.
    HttpHandler
    A handler which is invoked to process HTTP requests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.http.HttpContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.http.HttpContext

  • Packages that use HttpContext
    Package Description
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type HttpContext
      Modifier and Type Method and Description
      void Endpoint.publish(HttpContext serverContext)
      Publishes this endpoint at the provided server context.

    • Uses of HttpContext in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return HttpContext
      Modifier and Type Method and Description
      abstract HttpContext HttpExchange.getHttpContext()
      Returns a HttpContext for this exchange.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.http.HttpExchange (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.http.HttpExchange

  • Packages that use HttpExchange
    Package Description
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpExchange in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http with parameters of type HttpExchange
      Modifier and Type Method and Description
      abstract void HttpHandler.handle(HttpExchange exchange)
      Handles a given request and generates an appropriate response.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.spi.http.HttpHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.spi.http.HttpHandler

  • Packages that use HttpHandler
    Package Description
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpHandler in javax.xml.ws.spi.http

      Fields in javax.xml.ws.spi.http declared as HttpHandler
      Modifier and Type | Field and Description
      protected HttpHandler | HttpContext.handler
      Methods in javax.xml.ws.spi.http with parameters of type HttpHandler
      Modifier and Type Method and Description
      void HttpContext.setHandler(HttpHandler handler)
      JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.wsaddressing (Java Platform SE 8 )

javax.xml.ws.wsaddressing

Classes

  • W3CEndpointReference
  • W3CEndpointReferenceBuilder


javax.xml.ws.wsaddressing (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.ws.wsaddressing

This package defines APIs related to WS-Addressing.

See: Description

  • Class Summary
    Class Description
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
    W3CEndpointReferenceBuilder
    This class is used to build W3CEndpointReference instances.

Package javax.xml.ws.wsaddressing Description

This package defines APIs related to WS-Addressing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.ws.wsaddressing Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.ws.wsaddressing

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.ws.wsaddressing (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.ws.wsaddressing

  • Packages that use javax.xml.ws.wsaddressing
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.ws.wsaddressing used by javax.xml.ws.spi
    Class and Description
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • Classes in javax.xml.ws.wsaddressing used by javax.xml.ws.wsaddressing
    Class and Description
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
    W3CEndpointReferenceBuilder
    This class is used to build W3CEndpointReference instances.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


W3CEndpointReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.wsaddressing

Class W3CEndpointReference

  • java.lang.Object
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference

  • public final class W3CEndpointReference
extends EndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.

    Developers should use this class in their SEIs if they want to pass/return endpoint references that represent the W3C WS-Addressing recommendation.

    JAXB will use the JAXB annotations and bind this class to XML infoset that is consistent with that defined by WS-Addressing. See WS-Addressing for more information on WS-Addressing EndpointReferences.

    Since:
    JAX-WS 2.1

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      protected static String | NS

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | W3CEndpointReference()
        W3CEndpointReference(Source source)
      Creates an EPR from infoset representation

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void writeTo(Result result)
      write this EndpointReference to the specified infoset format

      • Methods inherited from class javax.xml.ws.EndpointReference

        getPort, readFrom, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • NS

        protected static final String NS
        See Also:
        Constant Field Values

    • Constructor Detail

      • W3CEndpointReference

        protected W3CEndpointReference()

      • W3CEndpointReference

        public W3CEndpointReference(Source source)
        Creates an EPR from infoset representation
        Parameters:
        source - A source object containing valid XmlInfoset instance consistent with the W3C WS-Addressing Core recommendation.
        Throws:
        WebServiceException - If the source does NOT contain a valid W3C WS-Addressing EndpointReference.
        NullPointerException - If the null source value is given

    • Method Detail

      • writeTo

        public void writeTo(Result result)
        write this EndpointReference to the specified infoset format
        Specified by:
        writeTo in class EndpointReference
        Parameters:
        result - for writing infoset
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


W3CEndpointReferenceBuilder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.xml.ws.wsaddressing

Class W3CEndpointReferenceBuilder

  • java.lang.Object
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

  • public final class W3CEndpointReferenceBuilder
extends Object
    This class is used to build W3CEndpointReference instances. The intended use of this clsss is for an application component, for example a factory component, to create an W3CEndpointReference for a web service endpoint published by the same Java EE application. It can also be used to create W3CEndpointReferences for an Java SE based endpoint by providing the address property.

    When creating a W3CEndpointReference for an endpoint that is not published by the same Java EE application, the address property MUST be specified.

    When creating a W3CEndpointReference for an endpoint published by the same Java EE application, the address property MAY be null but then the serviceName and endpointName MUST specify an endpoint published by the same Java EE application.

    When the wsdlDocumentLocation is specified it MUST refer to a valid WSDL document and the serviceName and endpointName (if specified) MUST match a service and port in the WSDL document.

    Since:
    JAX-WS 2.1

    • Constructor Summary

      Constructors
      Constructor and Description
      W3CEndpointReferenceBuilder()
      Creates a new W3CEndpointReferenceBuilder instance.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder address(String address)
      Sets the address to the W3CEndpointReference instance's wsa:Address.
      W3CEndpointReferenceBuilder attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReference build()
      Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
      W3CEndpointReferenceBuilder element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
      W3CEndpointReferenceBuilder serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder wsdlDocumentLocation(String wsdlDocumentLocation)
      Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • W3CEndpointReferenceBuilder

        public W3CEndpointReferenceBuilder()
        Creates a new W3CEndpointReferenceBuilder instance.

    • Method Detail

      • address

        public W3CEndpointReferenceBuilder address(String address)
        Sets the address to the W3CEndpointReference instance's wsa:Address.

        The address MUST be set to a non-null value when building a W3CEndpointReference for a web service endpoint that is not published by the same Java EE application or when running on Java SE.

        Parameters:
        address - The address of the endpoint to be targeted by the returned W3CEndpointReference.
        Returns:
        A W3CEndpointReferenceBuilder instance with the address set to the wsa:Address.

      • interfaceName

        public W3CEndpointReferenceBuilder interfaceName(QName interfaceName)
        Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element. See 2.1 Referencing WSDL Metadata from an EPR for more details.
        Parameters:
        interfaceName - The port type name of the endpoint to be targeted by the returned W3CEndpointReference.
        Returns:
        A W3CEndpointReferenceBuilder instance with the interfaceName as wsam:InterfaceName element added to the wsa:Metadata element

      • serviceName

        public W3CEndpointReferenceBuilder serviceName(QName serviceName)
        Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element. See 2.1 Referencing WSDL Metadata from an EPR for more details.
        Parameters:
        serviceName - The service name of the endpoint to be targeted by the returned W3CEndpointReference. This property may also be used with the endpointName (portName) property to lookup the address of a web service endpoint that is published by the same Java EE application.
        Returns:
        A W3CEndpointReferenceBuilder instance with the serviceName as wsam:ServiceName element added to the wsa:Metadata element

      • endpointName

        public W3CEndpointReferenceBuilder endpointName(QName endpointName)
        Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element. This method can only be called after the serviceName method has been called.

        See 2.1 Referencing WSDL Metadata from an EPR for more details.

        Parameters:
        endpointName - The name of the endpoint to be targeted by the returned W3CEndpointReference. The endpointName (portName) property may also be used with the serviceName property to lookup the address of a web service endpoint published by the same Java EE application.
        Returns:
        A W3CEndpointReferenceBuilder instance with the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
        Throws:
        IllegalStateException, - if the serviceName has not been set.
        IllegalArgumentException, - if the endpointName's Namespace URI doesn't match serviceName's Namespace URI

      • wsdlDocumentLocation

        public W3CEndpointReferenceBuilder wsdlDocumentLocation(String wsdlDocumentLocation)
        Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation. The namespace name for the wsdli:wsdlLocation's value can be taken from the WSDL itself.

        See 2.1 Referencing WSDL Metadata from an EPR for more details.

        Parameters:
        wsdlDocumentLocation - The location of the WSDL document to be referenced in the wsa:Metadata of the W3CEndpointReference.
        Returns:
        A W3CEndpointReferenceBuilder instance with the wsdlDocumentLocation that is to be referenced.

      • referenceParameter

        public W3CEndpointReferenceBuilder referenceParameter(Element referenceParameter)
        Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
        Parameters:
        referenceParameter - The element to be added to the wsa:ReferenceParameters element.
        Returns:
        A W3CEndpointReferenceBuilder instance with the referenceParameter added to the wsa:ReferenceParameters element.
        Throws:
        IllegalArgumentException - if referenceParameter is null.

      • metadata

        public W3CEndpointReferenceBuilder metadata(Element metadataElement)
        Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
        Parameters:
        metadataElement - The element to be added to the wsa:Metadata element.
        Returns:
        A W3CEndpointReferenceBuilder instance with the metadataElement added to the wsa:Metadata element.
        Throws:
        IllegalArgumentException - if metadataElement is null.

      • element

        public W3CEndpointReferenceBuilder element(Element element)
        Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
        Parameters:
        element - The extension element to be added to the W3CEndpointReference
        Returns:
        A W3CEndpointReferenceBuilder instance with the extension element added to the W3CEndpointReference instance.
        Throws:
        IllegalArgumentException - if element is null.
        Since:
        JAX-WS 2.2

      • attribute

        public W3CEndpointReferenceBuilder attribute(QName name,
                                             String value)
        Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
        Parameters:
        name - The name of the extension attribute to be added to the W3CEndpointReference
        value - extension attribute value
        Returns:
        A W3CEndpointReferenceBuilder instance with the extension attribute added to the W3CEndpointReference instance.
        Throws:
        IllegalArgumentException - if name or value is null.
        Since:
        JAX-WS 2.2

      • build

        public W3CEndpointReference build()
        Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. This method can automatically determine the address of an endpoint published by the same Java EE application that is identified by the serviceName and endpointName properties. If the address is null and the serviceName and endpointName do not identify an endpoint published by the same Java EE application, a java.lang.IllegalStateException MUST be thrown.

        Returns:
        W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance. This method never returns null.
        Throws:
        IllegalStateException -
        • If the address, serviceName and endpointName are all null.
        • If the serviceName service is null and the endpointName is NOT null.
        • If the address property is null and the serviceName and endpointName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceName is NOT null and is not present in the specified WSDL.
        • If the endpointName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.wsaddressing.W3CEndpointReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.wsaddressing.W3CEndpointReference

  • Packages that use W3CEndpointReference
    Package Description
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of W3CEndpointReference in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return W3CEndpointReference
      Modifier and Type Method and Description
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of W3CEndpointReference in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing that return W3CEndpointReference
      Modifier and Type Method and Description
      W3CEndpointReference W3CEndpointReferenceBuilder.build()
      Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

  • Packages that use W3CEndpointReferenceBuilder
    Package Description
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of W3CEndpointReferenceBuilder in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing that return W3CEndpointReferenceBuilder
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.address(String address)
      Sets the address to the W3CEndpointReference instance's wsa:Address.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.wsdlDocumentLocation(String wsdlDocumentLocation)
      Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - javax.xml.xpath (Java Platform SE 8 )

compact2 - javax.xml.xpath

Interfaces

  • XPath
  • XPathExpression
  • XPathFunction
  • XPathFunctionResolver
  • XPathVariableResolver

Classes

  • XPathConstants
  • XPathFactory

Exceptions

  • XPathException
  • XPathExpressionException
  • XPathFactoryConfigurationException
  • XPathFunctionException


javax.xml.xpath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package javax.xml.xpath

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

See: Description

  • Interface Summary
    Interface Description
    XPath
    XPath provides access to the XPath evaluation environment and expressions.
    XPathExpression
    XPathExpression provides access to compiled XPath expressions.
    XPathFunction
    XPathFunction provides access to XPath functions.
    XPathFunctionResolver
    XPathFunctionResolver provides access to the set of user defined XPathFunctions.
    XPathVariableResolver
    XPathVariableResolver provides access to the set of user defined XPath variables.
  • Class Summary
    Class Description
    XPathConstants
    XPath constants.
    XPathFactory
    An XPathFactory instance can be used to create XPath objects.
  • Exception Summary
    Exception Description
    XPathException
    XPathException represents a generic XPath exception.
    XPathExpressionException
    XPathExpressionException represents an error in an XPath expression.
    XPathFactoryConfigurationException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
    XPathFunctionException
    XPathFunctionException represents an error with an XPath function.

Package javax.xml.xpath Description

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

The following XML standards apply:

  • XML Path Language (XPath) Version 1.0

XPath Overview

The XPath language provides a simple, concise syntax for selecting nodes from an XML document. XPath also provides rules for converting a node in an XML document object model (DOM) tree to a boolean, double, or string value. XPath is a W3C-defined language and an official W3C recommendation; the W3C hosts the XML Path Language (XPath) Version 1.0 specification.

XPath started in life in 1999 as a supplement to the XSLT and XPointer languages, but has more recently become popular as a stand-alone language, as a single XPath expression can be used to replace many lines of DOM API code.

XPath Expressions

An XPath expression is composed of a location path and one or more optional predicates. Expressions may also include XPath variables.

The following is an example of a simple XPath expression:

/foo/bar

This example would select the <bar> element in an XML document such as the following:

<foo>
<bar/>
</foo>

The expression /foo/bar is an example of a location path. While XPath location paths resemble Unix-style file system paths, an important distinction is that XPath expressions return all nodes that match the expression. Thus, all three <bar> elements in the following document would be selected by the /foo/bar expression:

<foo>
<bar/>
<bar/>
<bar/>
</foo>

A special location path operator, //, selects nodes at any depth in an XML document. The following example selects all <bar> elements regardless of their location in a document:

//bar

A wildcard operator, *, causes all element nodes to be selected. The following example selects all children elements of a <foo> element:

/foo/*

In addition to element nodes, XPath location paths may also address attribute nodes, text nodes, comment nodes, and processing instruction nodes. The following table gives examples of location paths for each of these node types:

Location Path | Description
/foo/bar/@id | Selects the attribute id of the <bar> element
/foo/bar/text() | Selects the text nodes of the <bar> element. No distinction is made between escaped and non-escaped character data.
/foo/bar/comment() | Selects all comment nodes contained in the <bar> element.
/foo/bar/processing-instruction() | Selects all processing-instruction nodes contained in the <bar> element.

Predicates allow for refining the nodes selected by an XPath location path. Predicates are of the form [expression]. The following example selects all <foo> elements that contain an include attribute with the value of true:

//foo[@include='true']

Predicates may be appended to each other to further refine an expression, such as:

//foo[@include='true'][@mode='bar']

Using the XPath API

The following example demonstrates using the XPath API to select one or more nodes from an XML document:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
InputSource inputSource = new InputSource("widgets.xml");
NodeList nodes = (NodeList) xpath.evaluate(expression, inputSource, XPathConstants.NODESET);

XPath Expressions and Types

While XPath expressions select nodes in the XML document, the XPath API allows the selected nodes to be coalesced into one of the following other data types:

  • Boolean
  • Number
  • String

The desired return type is specified by a QName parameter in method call used to evaluate the expression, which is either a call to XPathExpression.evalute(...) or to one of the XPath.evaluate(...) convenience methods. The allowed QName values are specified as constants in the XPathConstants class; they are:

  • XPathConstants.NODESET
  • XPathConstants.NODE
  • XPathConstants.STRING
  • XPathConstants.BOOLEAN
  • XPathConstants.NUMBER

When a Boolean return type is requested, Boolean.TRUE is returned if one or more nodes were selected; otherwise, Boolean.FALSE is returned.

The String return type is a convenience for retrieving the character data from a text node, attribute node, comment node, or processing-instruction node. When used on an element node, the value of the child text nodes is returned.

The Number return type attempts to coalesce the text of a node to a double data type.

XPath Context

XPath location paths may be relative to a particular node in the document, known as the context. Consider the following XML document:

<widgets>
<widget>
<manufacturer/>
<dimensions/>
</widget>
</widgets>

The <widget> element can be selected with the following XPath API code:

// parse the XML as a W3C Document
DocumentBuilder builder = DocumentBuilderFactory.newInstance().newDocumentBuilder();
Document document = builder.parse(new File("/widgets.xml"));

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
Node widgetNode = (Node) xpath.evaluate(expression, document, XPathConstants.NODE);

With a reference to the <widget> element, a relative XPath expression can now written to select the <manufacturer> child element:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "manufacturer";
Node manufacturerNode = (Node) xpath.evaluate(expression, widgetNode, XPathConstants.NODE);
  • Author Ben Galbraith
  • Author Norman Walsh
  • Author Jeff Suttor
  • See XML Path Language (XPath) Version 1.0
  • Since 1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - javax.xml.xpath (Java Platform SE 8 )

compact3 - javax.xml.xpath

Interfaces

  • XPath
  • XPathExpression
  • XPathFunction
  • XPathFunctionResolver
  • XPathVariableResolver

Classes

  • XPathConstants
  • XPathFactory

Exceptions

  • XPathException
  • XPathExpressionException
  • XPathFactoryConfigurationException
  • XPathFunctionException


javax.xml.xpath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package javax.xml.xpath

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

See: Description

  • Interface Summary
    Interface Description
    XPath
    XPath provides access to the XPath evaluation environment and expressions.
    XPathExpression
    XPathExpression provides access to compiled XPath expressions.
    XPathFunction
    XPathFunction provides access to XPath functions.
    XPathFunctionResolver
    XPathFunctionResolver provides access to the set of user defined XPathFunctions.
    XPathVariableResolver
    XPathVariableResolver provides access to the set of user defined XPath variables.
  • Class Summary
    Class Description
    XPathConstants
    XPath constants.
    XPathFactory
    An XPathFactory instance can be used to create XPath objects.
  • Exception Summary
    Exception Description
    XPathException
    XPathException represents a generic XPath exception.
    XPathExpressionException
    XPathExpressionException represents an error in an XPath expression.
    XPathFactoryConfigurationException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
    XPathFunctionException
    XPathFunctionException represents an error with an XPath function.

Package javax.xml.xpath Description

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

The following XML standards apply:

  • XML Path Language (XPath) Version 1.0

XPath Overview

The XPath language provides a simple, concise syntax for selecting nodes from an XML document. XPath also provides rules for converting a node in an XML document object model (DOM) tree to a boolean, double, or string value. XPath is a W3C-defined language and an official W3C recommendation; the W3C hosts the XML Path Language (XPath) Version 1.0 specification.

XPath started in life in 1999 as a supplement to the XSLT and XPointer languages, but has more recently become popular as a stand-alone language, as a single XPath expression can be used to replace many lines of DOM API code.

XPath Expressions

An XPath expression is composed of a location path and one or more optional predicates. Expressions may also include XPath variables.

The following is an example of a simple XPath expression:

/foo/bar

This example would select the <bar> element in an XML document such as the following:

<foo>
<bar/>
</foo>

The expression /foo/bar is an example of a location path. While XPath location paths resemble Unix-style file system paths, an important distinction is that XPath expressions return all nodes that match the expression. Thus, all three <bar> elements in the following document would be selected by the /foo/bar expression:

<foo>
<bar/>
<bar/>
<bar/>
</foo>

A special location path operator, //, selects nodes at any depth in an XML document. The following example selects all <bar> elements regardless of their location in a document:

//bar

A wildcard operator, *, causes all element nodes to be selected. The following example selects all children elements of a <foo> element:

/foo/*

In addition to element nodes, XPath location paths may also address attribute nodes, text nodes, comment nodes, and processing instruction nodes. The following table gives examples of location paths for each of these node types:

Location Path | Description
/foo/bar/@id | Selects the attribute id of the <bar> element
/foo/bar/text() | Selects the text nodes of the <bar> element. No distinction is made between escaped and non-escaped character data.
/foo/bar/comment() | Selects all comment nodes contained in the <bar> element.
/foo/bar/processing-instruction() | Selects all processing-instruction nodes contained in the <bar> element.

Predicates allow for refining the nodes selected by an XPath location path. Predicates are of the form [expression]. The following example selects all <foo> elements that contain an include attribute with the value of true:

//foo[@include='true']

Predicates may be appended to each other to further refine an expression, such as:

//foo[@include='true'][@mode='bar']

Using the XPath API

The following example demonstrates using the XPath API to select one or more nodes from an XML document:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
InputSource inputSource = new InputSource("widgets.xml");
NodeList nodes = (NodeList) xpath.evaluate(expression, inputSource, XPathConstants.NODESET);

XPath Expressions and Types

While XPath expressions select nodes in the XML document, the XPath API allows the selected nodes to be coalesced into one of the following other data types:

  • Boolean
  • Number
  • String

The desired return type is specified by a QName parameter in method call used to evaluate the expression, which is either a call to XPathExpression.evalute(...) or to one of the XPath.evaluate(...) convenience methods. The allowed QName values are specified as constants in the XPathConstants class; they are:

  • XPathConstants.NODESET
  • XPathConstants.NODE
  • XPathConstants.STRING
  • XPathConstants.BOOLEAN
  • XPathConstants.NUMBER

When a Boolean return type is requested, Boolean.TRUE is returned if one or more nodes were selected; otherwise, Boolean.FALSE is returned.

The String return type is a convenience for retrieving the character data from a text node, attribute node, comment node, or processing-instruction node. When used on an element node, the value of the child text nodes is returned.

The Number return type attempts to coalesce the text of a node to a double data type.

XPath Context

XPath location paths may be relative to a particular node in the document, known as the context. Consider the following XML document:

<widgets>
<widget>
<manufacturer/>
<dimensions/>
</widget>
</widgets>

The <widget> element can be selected with the following XPath API code:

// parse the XML as a W3C Document
DocumentBuilder builder = DocumentBuilderFactory.newInstance().newDocumentBuilder();
Document document = builder.parse(new File("/widgets.xml"));

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
Node widgetNode = (Node) xpath.evaluate(expression, document, XPathConstants.NODE);

With a reference to the <widget> element, a relative XPath expression can now written to select the <manufacturer> child element:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "manufacturer";
Node manufacturerNode = (Node) xpath.evaluate(expression, widgetNode, XPathConstants.NODE);
  • Author Ben Galbraith
  • Author Norman Walsh
  • Author Jeff Suttor
  • See XML Path Language (XPath) Version 1.0
  • Since 1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.xpath (Java Platform SE 8 )

javax.xml.xpath

Interfaces

  • XPath
  • XPathExpression
  • XPathFunction
  • XPathFunctionResolver
  • XPathVariableResolver

Classes

  • XPathConstants
  • XPathFactory

Exceptions

  • XPathException
  • XPathExpressionException
  • XPathFactoryConfigurationException
  • XPathFunctionException


javax.xml.xpath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package javax.xml.xpath

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

See: Description

  • Interface Summary
    Interface Description
    XPath
    XPath provides access to the XPath evaluation environment and expressions.
    XPathExpression
    XPathExpression provides access to compiled XPath expressions.
    XPathFunction
    XPathFunction provides access to XPath functions.
    XPathFunctionResolver
    XPathFunctionResolver provides access to the set of user defined XPathFunctions.
    XPathVariableResolver
    XPathVariableResolver provides access to the set of user defined XPath variables.
  • Class Summary
    Class Description
    XPathConstants
    XPath constants.
    XPathFactory
    An XPathFactory instance can be used to create XPath objects.
  • Exception Summary
    Exception Description
    XPathException
    XPathException represents a generic XPath exception.
    XPathExpressionException
    XPathExpressionException represents an error in an XPath expression.
    XPathFactoryConfigurationException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
    XPathFunctionException
    XPathFunctionException represents an error with an XPath function.

Package javax.xml.xpath Description

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

The following XML standards apply:

  • XML Path Language (XPath) Version 1.0

XPath Overview

The XPath language provides a simple, concise syntax for selecting nodes from an XML document. XPath also provides rules for converting a node in an XML document object model (DOM) tree to a boolean, double, or string value. XPath is a W3C-defined language and an official W3C recommendation; the W3C hosts the XML Path Language (XPath) Version 1.0 specification.

XPath started in life in 1999 as a supplement to the XSLT and XPointer languages, but has more recently become popular as a stand-alone language, as a single XPath expression can be used to replace many lines of DOM API code.

XPath Expressions

An XPath expression is composed of a location path and one or more optional predicates. Expressions may also include XPath variables.

The following is an example of a simple XPath expression:

/foo/bar

This example would select the <bar> element in an XML document such as the following:

<foo>
<bar/>
</foo>

The expression /foo/bar is an example of a location path. While XPath location paths resemble Unix-style file system paths, an important distinction is that XPath expressions return all nodes that match the expression. Thus, all three <bar> elements in the following document would be selected by the /foo/bar expression:

<foo>
<bar/>
<bar/>
<bar/>
</foo>

A special location path operator, //, selects nodes at any depth in an XML document. The following example selects all <bar> elements regardless of their location in a document:

//bar

A wildcard operator, *, causes all element nodes to be selected. The following example selects all children elements of a <foo> element:

/foo/*

In addition to element nodes, XPath location paths may also address attribute nodes, text nodes, comment nodes, and processing instruction nodes. The following table gives examples of location paths for each of these node types:

Location Path | Description
/foo/bar/@id | Selects the attribute id of the <bar> element
/foo/bar/text() | Selects the text nodes of the <bar> element. No distinction is made between escaped and non-escaped character data.
/foo/bar/comment() | Selects all comment nodes contained in the <bar> element.
/foo/bar/processing-instruction() | Selects all processing-instruction nodes contained in the <bar> element.

Predicates allow for refining the nodes selected by an XPath location path. Predicates are of the form [expression]. The following example selects all <foo> elements that contain an include attribute with the value of true:

//foo[@include='true']

Predicates may be appended to each other to further refine an expression, such as:

//foo[@include='true'][@mode='bar']

Using the XPath API

The following example demonstrates using the XPath API to select one or more nodes from an XML document:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
InputSource inputSource = new InputSource("widgets.xml");
NodeList nodes = (NodeList) xpath.evaluate(expression, inputSource, XPathConstants.NODESET);

XPath Expressions and Types

While XPath expressions select nodes in the XML document, the XPath API allows the selected nodes to be coalesced into one of the following other data types:

  • Boolean
  • Number
  • String

The desired return type is specified by a QName parameter in method call used to evaluate the expression, which is either a call to XPathExpression.evalute(...) or to one of the XPath.evaluate(...) convenience methods. The allowed QName values are specified as constants in the XPathConstants class; they are:

  • XPathConstants.NODESET
  • XPathConstants.NODE
  • XPathConstants.STRING
  • XPathConstants.BOOLEAN
  • XPathConstants.NUMBER

When a Boolean return type is requested, Boolean.TRUE is returned if one or more nodes were selected; otherwise, Boolean.FALSE is returned.

The String return type is a convenience for retrieving the character data from a text node, attribute node, comment node, or processing-instruction node. When used on an element node, the value of the child text nodes is returned.

The Number return type attempts to coalesce the text of a node to a double data type.

XPath Context

XPath location paths may be relative to a particular node in the document, known as the context. Consider the following XML document:

<widgets>
<widget>
<manufacturer/>
<dimensions/>
</widget>
</widgets>

The <widget> element can be selected with the following XPath API code:

// parse the XML as a W3C Document
DocumentBuilder builder = DocumentBuilderFactory.newInstance().newDocumentBuilder();
Document document = builder.parse(new File("/widgets.xml"));

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
Node widgetNode = (Node) xpath.evaluate(expression, document, XPathConstants.NODE);

With a reference to the <widget> element, a relative XPath expression can now written to select the <manufacturer> child element:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "manufacturer";
Node manufacturerNode = (Node) xpath.evaluate(expression, widgetNode, XPathConstants.NODE);
  • Author Ben Galbraith
  • Author Norman Walsh
  • Author Jeff Suttor
  • See XML Path Language (XPath) Version 1.0
  • Since 1.5
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


javax.xml.xpath Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package javax.xml.xpath

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
          • javax.xml.xpath.XPathFactoryConfigurationException
    • javax.xml.xpath.XPathConstants
    • javax.xml.xpath.XPathFactory

Interface Hierarchy

  • javax.xml.xpath.XPath
  • javax.xml.xpath.XPathExpression
  • javax.xml.xpath.XPathFunction
  • javax.xml.xpath.XPathFunctionResolver
  • javax.xml.xpath.XPathVariableResolver
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package javax.xml.xpath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
javax.xml.xpath

  • Packages that use javax.xml.xpath
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
  • Classes in javax.xml.xpath used by javax.xml.xpath
    Class and Description
    XPath
    XPath provides access to the XPath evaluation environment and expressions.
    XPathException
    XPathException represents a generic XPath exception.
    XPathExpression
    XPathExpression provides access to compiled XPath expressions.
    XPathExpressionException
    XPathExpressionException represents an error in an XPath expression.
    XPathFactory
    An XPathFactory instance can be used to create XPath objects.
    XPathFactoryConfigurationException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
    XPathFunction
    XPathFunction provides access to XPath functions.
    XPathFunctionException
    XPathFunctionException represents an error with an XPath function.
    XPathFunctionResolver
    XPathFunctionResolver provides access to the set of user defined XPathFunctions.
    XPathVariableResolver
    XPathVariableResolver provides access to the set of user defined XPath variables.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Interface XPath

  • public interface XPath

    XPath provides access to the XPath evaluation environment and expressions.

    Evaluation of XPath Expressions.
    context | If a request is made to evaluate the expression in the absence of a context item, an empty document node will be used for the context. For the purposes of evaluating XPath expressions, a DocumentFragment is treated like a Document node.
    variables If the expression contains a variable reference, its value will be found through the XPathVariableResolver set with setXPathVariableResolver(XPathVariableResolver resolver). An XPathExpressionException is raised if the variable resolver is undefined or the resolver returns null for the variable. The value of a variable must be immutable through the course of any single evaluation.
    functions If the expression contains a function reference, the function will be found through the XPathFunctionResolver set with setXPathFunctionResolver(XPathFunctionResolver resolver). An XPathExpressionException is raised if the function resolver is undefined or the function resolver returns null for the function.
    QNames | QNames in the expression are resolved against the XPath namespace context set with setNamespaceContext(NamespaceContext nsContext).
    result This result of evaluating an expression is converted to an instance of the desired return type. Valid return types are defined in XPathConstants. Conversion to the return type follows XPath conversion rules.

    An XPath object is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one XPath object is not used from more than one thread at any given time, and while the evaluate method is invoked, applications may not recursively call the evaluate method.

    Since:
    1.5
    See Also:
    XML Path Language (XPath) Version 1.0

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      XPathExpression compile(String expression)
      Compile an XPath expression for later evaluation.
      String evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
      String evaluate(String expression, Object item)
      Evaluate an XPath expression in the specified context and return the result as a String.
      Object evaluate(String expression, Object item, QName returnType)
      Evaluate an XPath expression in the specified context and return the result as the specified type.
      NamespaceContext getNamespaceContext()
      Return the current namespace context.
      XPathFunctionResolver getXPathFunctionResolver()
      Return the current function resolver.
      XPathVariableResolver getXPathVariableResolver()
      Return the current variable resolver.
      void reset()
      Reset this XPath to its original configuration.
      void setNamespaceContext(NamespaceContext nsContext)
      Establish a namespace context.
      void setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a function resolver.
      void setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a variable resolver.

    • Method Detail

      • reset

        void reset()

        Reset this XPath to its original configuration.

        XPath is reset to the same state as when it was created with XPathFactory.newXPath(). reset() is designed to allow the reuse of existing XPaths thus saving resources associated with the creation of new XPaths.

        The reset XPath is not guaranteed to have the same XPathFunctionResolver, XPathVariableResolver or NamespaceContext Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal XPathFunctionResolver, XPathVariableResolver and NamespaceContext.

      • setXPathVariableResolver

        void setXPathVariableResolver(XPathVariableResolver resolver)

        Establish a variable resolver.

        A NullPointerException is thrown if resolver is null.

        Parameters:
        resolver - Variable resolver.
        Throws:
        NullPointerException - If resolver is null.

      • getXPathVariableResolver

        XPathVariableResolver getXPathVariableResolver()

        Return the current variable resolver.

        null is returned in no variable resolver is in effect.

        Returns:
        Current variable resolver.

      • setXPathFunctionResolver

        void setXPathFunctionResolver(XPathFunctionResolver resolver)

        Establish a function resolver.

        A NullPointerException is thrown if resolver is null.

        Parameters:
        resolver - XPath function resolver.
        Throws:
        NullPointerException - If resolver is null.

      • getXPathFunctionResolver

        XPathFunctionResolver getXPathFunctionResolver()

        Return the current function resolver.

        null is returned in no function resolver is in effect.

        Returns:
        Current function resolver.

      • setNamespaceContext

        void setNamespaceContext(NamespaceContext nsContext)

        Establish a namespace context.

        A NullPointerException is thrown if nsContext is null.

        Parameters:
        nsContext - Namespace context to use.
        Throws:
        NullPointerException - If nsContext is null.

      • getNamespaceContext

        NamespaceContext getNamespaceContext()

        Return the current namespace context.

        null is returned in no namespace context is in effect.

        Returns:
        Current Namespace context.

      • compile

        XPathExpression compile(String expression)
                 throws XPathExpressionException

        Compile an XPath expression for later evaluation.

        If expression contains any XPathFunctions, they must be available via the XPathFunctionResolver. An XPathExpressionException will be thrown if the XPathFunction cannot be resovled with the XPathFunctionResolver.

        If expression contains any variables, the XPathVariableResolver in effect at compile time will be used to resolve them.

        If expression is null, a NullPointerException is thrown.

        Parameters:
        expression - The XPath expression.
        Returns:
        Compiled XPath expression.
        Throws:
        XPathExpressionException - If expression cannot be compiled.
        NullPointerException - If expression is null.

      • evaluate

        Object evaluate(String expression,
                Object item,
                QName returnType)
         throws XPathExpressionException

        Evaluate an XPath expression in the specified context and return the result as the specified type.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants ( NUMBER, STRING, BOOLEAN, NODE or NODESET) then an IllegalArgumentException is thrown.

        If a null value is provided for item, an empty document will be used for the context. If expression or returnType is null, then a NullPointerException is thrown.

        Parameters:
        expression - The XPath expression.
        item - The starting context (a node, for example).
        returnType - The desired return type.
        Returns:
        Result of evaluating an XPath expression as an Object of returnType.
        Throws:
        XPathExpressionException - If expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If expression or returnType is null.

      • evaluate

        String evaluate(String expression,
                Object item)
         throws XPathExpressionException

        Evaluate an XPath expression in the specified context and return the result as a String.

        This method calls evaluate(String expression, Object item, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If a null value is provided for item, an empty document will be used for the context. If expression is null, then a NullPointerException is thrown.

        Parameters:
        expression - The XPath expression.
        item - The starting context (a node, for example).
        Returns:
        The String that is the result of evaluating the expression and converting the result to a String.
        Throws:
        XPathExpressionException - If expression cannot be evaluated.
        NullPointerException - If expression is null.

      • evaluate

        Object evaluate(String expression,
                InputSource source,
                QName returnType)
         throws XPathExpressionException

        Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.

        This method builds a data model for the InputSource and calls evaluate(String expression, Object item, QName returnType) on the resulting document object.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants, then an IllegalArgumentException is thrown.

        If expression, source or returnType is null, then a NullPointerException is thrown.

        Parameters:
        expression - The XPath expression.
        source - The input source of the document to evaluate over.
        returnType - The desired return type.
        Returns:
        The Object that encapsulates the result of evaluating the expression.
        Throws:
        XPathExpressionException - If expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If expression, source or returnType is null.

      • evaluate

        String evaluate(String expression,
                InputSource source)
         throws XPathExpressionException

        Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.

        This method calls evaluate(String expression, InputSource source, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If expression or source is null, then a NullPointerException is thrown.

        Parameters:
        expression - The XPath expression.
        source - The InputSource of the document to evaluate over.
        Returns:
        The String that is the result of evaluating the expression and converting the result to a String.
        Throws:
        XPathExpressionException - If expression cannot be evaluated.
        NullPointerException - If expression or source is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Class XPathConstants

  • java.lang.Object
    • javax.xml.xpath.XPathConstants

  • public class XPathConstants
extends Object

    XPath constants.

    Since:
    1.5
    See Also:
    XML Path Language (XPath) Version 1.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static QName BOOLEAN
      The XPath 1.0 boolean data type.
      static String DOM_OBJECT_MODEL
      The URI for the DOM object model, "http://java.sun.com/jaxp/xpath/dom".
      static QName NODE
      The XPath 1.0 NodeSet data type.
      static QName NODESET
      The XPath 1.0 NodeSet data type.
      static QName NUMBER
      The XPath 1.0 number data type.
      static QName STRING
      The XPath 1.0 string data type.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • NUMBER

        public static final QName NUMBER

        The XPath 1.0 number data type.

        Maps to Java Double.

      • STRING

        public static final QName STRING

        The XPath 1.0 string data type.

        Maps to Java String.

      • BOOLEAN

        public static final QName BOOLEAN

        The XPath 1.0 boolean data type.

        Maps to Java Boolean.

      • NODESET

        public static final QName NODESET

        The XPath 1.0 NodeSet data type.

        Maps to Java NodeList.

      • NODE

        public static final QName NODE

        The XPath 1.0 NodeSet data type.

        Maps to Java Node.

      • DOM_OBJECT_MODEL

        public static final String DOM_OBJECT_MODEL

        The URI for the DOM object model, "http://java.sun.com/jaxp/xpath/dom".

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Class XPathException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    XPathExpressionException, XPathFactoryConfigurationException

    public class XPathException
extends Exception
    XPathException represents a generic XPath exception.

    Since:
    1.5
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathException(String message)
      Constructs a new XPathException with the specified detail message.
      XPathException(Throwable cause)
      Constructs a new XPathException with the specified cause.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Get the cause of this XPathException.
      void printStackTrace()
      Print stack trace to System.err.
      void printStackTrace(PrintStream s)
      Print stack trace to specified PrintStream.
      void printStackTrace(PrintWriter s)
      Print stack trace to specified PrintWriter.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • XPathException

        public XPathException(String message)

        Constructs a new XPathException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        Parameters:
        message - The detail message.
        Throws:
        NullPointerException - When message is null.

      • XPathException

        public XPathException(Throwable cause)

        Constructs a new XPathException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        Parameters:
        cause - The cause.
        Throws:
        NullPointerException - if cause is null.

    • Method Detail

      • getCause

        public Throwable getCause()

        Get the cause of this XPathException.

        Overrides:
        getCause in class Throwable
        Returns:
        Cause of this XPathException.

      • printStackTrace

        public void printStackTrace(PrintStream s)

        Print stack trace to specified PrintStream.

        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - Print stack trace to this PrintStream.

      • printStackTrace

        public void printStackTrace()

        Print stack trace to System.err.

        Overrides:
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintWriter s)

        Print stack trace to specified PrintWriter.

        Overrides:
        printStackTrace in class Throwable
        Parameters:
        s - Print stack trace to this PrintWriter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathExpression (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Interface XPathExpression

  • public interface XPathExpression

    XPathExpression provides access to compiled XPath expressions.

    Evaluation of XPath Expressions.
    context | If a request is made to evaluate the expression in the absence of a context item, an empty document node will be used for the context. For the purposes of evaluating XPath expressions, a DocumentFragment is treated like a Document node.
    variables If the expression contains a variable reference, its value will be found through the XPathVariableResolver. An XPathExpressionException is raised if the variable resolver is undefined or the resolver returns null for the variable. The value of a variable must be immutable through the course of any single evaluation.
    functions If the expression contains a function reference, the function will be found through the XPathFunctionResolver. An XPathExpressionException is raised if the function resolver is undefined or the function resolver returns null for the function.
    QNames | QNames in the expression are resolved against the XPath namespace context.
    result This result of evaluating an expression is converted to an instance of the desired return type. Valid return types are defined in XPathConstants. Conversion to the return type follows XPath conversion rules.

    An XPath expression is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one XPathExpression object is not used from more than one thread at any given time, and while the evaluate method is invoked, applications may not recursively call the evaluate method.

    Since:
    1.5
    See Also:
    XML Path Language (XPath) Version 1.0, Expressions

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String evaluate(Object item)
      Evaluate the compiled XPath expression in the specified context and return the result as a String.
      Object evaluate(Object item, QName returnType)
      Evaluate the compiled XPath expression in the specified context and return the result as the specified type.

    • Method Detail

      • evaluate

        Object evaluate(Object item,
                QName returnType)
         throws XPathExpressionException

        Evaluate the compiled XPath expression in the specified context and return the result as the specified type.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants, then an IllegalArgumentException is thrown.

        If a null value is provided for item, an empty document will be used for the context. If returnType is null, then a NullPointerException is thrown.

        Parameters:
        item - The starting context (a node, for example).
        returnType - The desired return type.
        Returns:
        The Object that is the result of evaluating the expression and converting the result to returnType.
        Throws:
        XPathExpressionException - If the expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If returnType is null.

      • evaluate

        String evaluate(Object item)
         throws XPathExpressionException

        Evaluate the compiled XPath expression in the specified context and return the result as a String.

        This method calls evaluate(Object item, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If a null value is provided for item, an empty document will be used for the context.

        Parameters:
        item - The starting context (a node, for example).
        Returns:
        The String that is the result of evaluating the expression and converting the result to a String.
        Throws:
        XPathExpressionException - If the expression cannot be evaluated.

      • evaluate

        Object evaluate(InputSource source,
                QName returnType)
         throws XPathExpressionException

        Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.

        This method builds a data model for the InputSource and calls evaluate(Object item, QName returnType) on the resulting document object.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants, then an IllegalArgumentException is thrown.

        If source or returnType is null, then a NullPointerException is thrown.

        Parameters:
        source - The InputSource of the document to evaluate over.
        returnType - The desired return type.
        Returns:
        The Object that is the result of evaluating the expression and converting the result to returnType.
        Throws:
        XPathExpressionException - If the expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If source or returnType is null.

      • evaluate

        String evaluate(InputSource source)
         throws XPathExpressionException

        Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.

        This method calls evaluate(InputSource source, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If source is null, then a NullPointerException is thrown.

        Parameters:
        source - The InputSource of the document to evaluate over.
        Returns:
        The String that is the result of evaluating the expression and converting the result to a String.
        Throws:
        XPathExpressionException - If the expression cannot be evaluated.
        NullPointerException - If source is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathExpressionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Class XPathExpressionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    XPathFunctionException

    public class XPathExpressionException
extends XPathException
    XPathExpressionException represents an error in an XPath expression.

    Since:
    1.5
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathExpressionException(String message)
      Constructs a new XPathExpressionException with the specified detail message.
      XPathExpressionException(Throwable cause)
      Constructs a new XPathExpressionException with the specified cause.

    • Method Summary

      • Methods inherited from class javax.xml.xpath.XPathException

        getCause, printStackTrace, printStackTrace, printStackTrace

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • XPathExpressionException

        public XPathExpressionException(String message)

        Constructs a new XPathExpressionException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        Parameters:
        message - The detail message.
        Throws:
        NullPointerException - When message is null.

      • XPathExpressionException

        public XPathExpressionException(Throwable cause)

        Constructs a new XPathExpressionException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        Parameters:
        cause - The cause.
        Throws:
        NullPointerException - if cause is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Class XPathFactory

  • java.lang.Object
    • javax.xml.xpath.XPathFactory

  • public abstract class XPathFactory
extends Object

    An XPathFactory instance can be used to create XPath objects.

    See newInstance(String uri) for lookup mechanism.

    The XPathFactory class is not thread-safe. In other words, it is the application's responsibility to ensure that at most one thread is using a XPathFactory object at any given moment. Implementations are encouraged to mark methods as synchronized to protect themselves from broken clients.

    XPathFactory is not re-entrant. While one of the newInstance methods is being invoked, applications may not attempt to recursively invoke a newInstance method, even from the same thread.

    Since:
    1.5

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String DEFAULT_OBJECT_MODEL_URI
      Default Object Model URI.
      static String DEFAULT_PROPERTY_NAME
      The default property name according to the JAXP spec.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected XPathFactory()
      Protected constructor as newInstance() or newInstance(String uri) or newInstance(String uri, String factoryClassName, ClassLoader classLoader) should be used to create a new instance of an XPathFactory.

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract boolean getFeature(String name)
      Get the state of the named feature.
      abstract boolean isObjectModelSupported(String objectModel)
      Is specified object model supported by this XPathFactory?
      static XPathFactory newInstance()
      Get a new XPathFactory instance using the default object model, DEFAULT_OBJECT_MODEL_URI, the W3C DOM.
      static XPathFactory newInstance(String uri)
      Get a new XPathFactory instance using the specified object model.
      static XPathFactory newInstance(String uri, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a XPathFactory from a factory class name.
      abstract XPath newXPath()
      Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.
      abstract void setFeature(String name, boolean value)
      Set a feature for this XPathFactory and XPaths created by this factory.
      abstract void setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a default function resolver.
      abstract void setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a default variable resolver.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • DEFAULT_PROPERTY_NAME

        public static final String DEFAULT_PROPERTY_NAME

        The default property name according to the JAXP spec.

        See Also:
        Constant Field Values

      • DEFAULT_OBJECT_MODEL_URI

        public static final String DEFAULT_OBJECT_MODEL_URI

        Default Object Model URI.

        See Also:
        Constant Field Values

    • Constructor Detail

      • XPathFactory

        protected XPathFactory()

        Protected constructor as newInstance() or newInstance(String uri) or newInstance(String uri, String factoryClassName, ClassLoader classLoader) should be used to create a new instance of an XPathFactory.

    • Method Detail

      • newInstance

        public static XPathFactory newInstance()

        Get a new XPathFactory instance using the default object model, DEFAULT_OBJECT_MODEL_URI, the W3C DOM.

        This method is functionally equivalent to:

           newInstance(DEFAULT_OBJECT_MODEL_URI)

        Since the implementation for the W3C DOM is always available, this method will never fail.

        Returns:
        Instance of an XPathFactory.
        Throws:
        RuntimeException - When there is a failure in creating an XPathFactory for the default object model.

      • newInstance

        public static XPathFactory newInstance(String uri)
                                throws XPathFactoryConfigurationException

        Get a new XPathFactory instance using the specified object model.

        To find a XPathFactory object, this method looks the following places in the following order where "the class loader" refers to the context class loader:

        1. If the system property DEFAULT_PROPERTY_NAME + ":uri" is present, where uri is the parameter to this method, then its value is read as a class name. The method will try to create a new instance of this class by using the class loader, and returns it if it is successfully created.
        2. ${java.home}/lib/jaxp.properties is read and the value associated with the key being the system property above is looked for. If present, the value is processed just like above.
        3. Use the service-provider loading facilities, defined by the ServiceLoader class, to attempt to locate and load an implementation of the service using the default loading mechanism: the service-provider loading facility will use the current thread's context class loader to attempt to load the service. If the context class loader is null, the system class loader will be used.
          Each potential service provider is required to implement the method isObjectModelSupported(String objectModel). The first service provider found that supports the specified object model is returned.
          In case of ServiceConfigurationError an XPathFactoryConfigurationException will be thrown.
        4. Platform default XPathFactory is located in a platform specific way. There must be a platform default XPathFactory for the W3C DOM, i.e. DEFAULT_OBJECT_MODEL_URI.

        If everything fails, an XPathFactoryConfigurationException will be thrown.

        Tip for Trouble-shooting:

        See Properties.load(java.io.InputStream) for exactly how a property file is parsed. In particular, colons ':' need to be escaped in a property file, so make sure the URIs are properly escaped in it. For example:

           http\://java.sun.com/jaxp/xpath/dom=org.acme.DomXPathFactory
        Parameters:
        uri - Identifies the underlying object model. The specification only defines the URI DEFAULT_OBJECT_MODEL_URI, http://java.sun.com/jaxp/xpath/dom for the W3C DOM, the org.w3c.dom package, and implementations are free to introduce other URIs for other object models.
        Returns:
        Instance of an XPathFactory.
        Throws:
        XPathFactoryConfigurationException - If the specified object model is unavailable, or if there is a configuration error.
        NullPointerException - If uri is null.
        IllegalArgumentException - If uri is null or uri.length() == 0.

      • newInstance

        public static XPathFactory newInstance(String uri,
                                       String factoryClassName,
                                       ClassLoader classLoader)
                                throws XPathFactoryConfigurationException

        Obtain a new instance of a XPathFactory from a factory class name. XPathFactory is returned if specified factory class supports the specified object model. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        Parameters:
        uri - Identifies the underlying object model. The specification only defines the URI DEFAULT_OBJECT_MODEL_URI,http://java.sun.com/jaxp/xpath/dom for the W3C DOM, the org.w3c.dom package, and implementations are free to introduce other URIs for other object models.
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.xpath.XPathFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        Returns:
        New instance of a XPathFactory
        Throws:
        XPathFactoryConfigurationException - if factoryClassName is null, or the factory class cannot be loaded, instantiated or the factory class does not support the object model specified in the uri parameter.
        NullPointerException - If uri is null.
        IllegalArgumentException - If uri is null or uri.length() == 0.
        Since:
        1.6
        See Also:
        newInstance(), newInstance(String uri)

      • isObjectModelSupported

        public abstract boolean isObjectModelSupported(String objectModel)

        Is specified object model supported by this XPathFactory?

        Parameters:
        objectModel - Specifies the object model which the returned XPathFactory will understand.
        Returns:
        true if XPathFactory supports objectModel, else false.
        Throws:
        NullPointerException - If objectModel is null.
        IllegalArgumentException - If objectModel.length() == 0.

      • setFeature

        public abstract void setFeature(String name,
                                boolean value)
                         throws XPathFactoryConfigurationException

        Set a feature for this XPathFactory and XPaths created by this factory.

        Feature names are fully qualified URIs. Implementations may define their own features. An XPathFactoryConfigurationException is thrown if this XPathFactory or the XPaths it creates cannot support the feature. It is possible for an XPathFactory to expose a feature value but be unable to change its state.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is true, any reference to an external function is an error. Under these conditions, the implementation must not call the XPathFunctionResolver and must throw an XPathFunctionException.

        Parameters:
        name - Feature name.
        value - Is feature state true or false.
        Throws:
        XPathFactoryConfigurationException - if this XPathFactory or the XPaths it creates cannot support this feature.
        NullPointerException - if name is null.

      • getFeature

        public abstract boolean getFeature(String name)
                            throws XPathFactoryConfigurationException

        Get the state of the named feature.

        Feature names are fully qualified URIs. Implementations may define their own features. An XPathFactoryConfigurationException is thrown if this XPathFactory or the XPaths it creates cannot support the feature. It is possible for an XPathFactory to expose a feature value but be unable to change its state.

        Parameters:
        name - Feature name.
        Returns:
        State of the named feature.
        Throws:
        XPathFactoryConfigurationException - if this XPathFactory or the XPaths it creates cannot support this feature.
        NullPointerException - if name is null.

      • setXPathVariableResolver

        public abstract void setXPathVariableResolver(XPathVariableResolver resolver)

        Establish a default variable resolver.

        Any XPath objects constructed from this factory will use the specified resolver by default.

        A NullPointerException is thrown if resolver is null.

        Parameters:
        resolver - Variable resolver.
        Throws:
        NullPointerException - If resolver is null.

      • setXPathFunctionResolver

        public abstract void setXPathFunctionResolver(XPathFunctionResolver resolver)

        Establish a default function resolver.

        Any XPath objects constructed from this factory will use the specified resolver by default.

        A NullPointerException is thrown if resolver is null.

        Parameters:
        resolver - XPath function resolver.
        Throws:
        NullPointerException - If resolver is null.

      • newXPath

        public abstract XPath newXPath()

        Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.

        Returns:
        New instance of an XPath.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFactoryConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Class XPathFactoryConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathFactoryConfigurationException
  • All Implemented Interfaces:
    Serializable

    public class XPathFactoryConfigurationException
extends XPathException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.

    Since:
    1.5
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathFactoryConfigurationException(String message)
      Constructs a new XPathFactoryConfigurationException with the specified detail message.
      XPathFactoryConfigurationException(Throwable cause)
      Constructs a new XPathFactoryConfigurationException with the specified cause.

    • Method Summary

      • Methods inherited from class javax.xml.xpath.XPathException

        getCause, printStackTrace, printStackTrace, printStackTrace

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • XPathFactoryConfigurationException

        public XPathFactoryConfigurationException(String message)

        Constructs a new XPathFactoryConfigurationException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        Parameters:
        message - The detail message.
        Throws:
        NullPointerException - When message is null.

      • XPathFactoryConfigurationException

        public XPathFactoryConfigurationException(Throwable cause)

        Constructs a new XPathFactoryConfigurationException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        Parameters:
        cause - The cause.
        Throws:
        NullPointerException - if cause is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFunction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Interface XPathFunction

  • public interface XPathFunction

    XPathFunction provides access to XPath functions.

    Functions are identified by QName and arity in XPath.

    Since:
    1.5

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object evaluate(List args)
      Evaluate the function with the specified arguments.

    • Method Detail

      • evaluate

        Object evaluate(List args)
         throws XPathFunctionException

        Evaluate the function with the specified arguments.

        To the greatest extent possible, side-effects should be avoided in the definition of extension functions. The implementation evaluating an XPath expression is under no obligation to call extension functions in any particular order or any particular number of times.

        Parameters:
        args - The arguments, null is a valid value.
        Returns:
        The result of evaluating the XPath function as an Object.
        Throws:
        XPathFunctionException - If args cannot be evaluated with this XPath function.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFunctionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Class XPathFunctionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
  • All Implemented Interfaces:
    Serializable

    public class XPathFunctionException
extends XPathExpressionException
    XPathFunctionException represents an error with an XPath function.

    Since:
    1.5
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      XPathFunctionException(String message)
      Constructs a new XPathFunctionException with the specified detail message.
      XPathFunctionException(Throwable cause)
      Constructs a new XPathFunctionException with the specified cause.

    • Method Summary

      • Methods inherited from class javax.xml.xpath.XPathException

        getCause, printStackTrace, printStackTrace, printStackTrace

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • XPathFunctionException

        public XPathFunctionException(String message)

        Constructs a new XPathFunctionException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        Parameters:
        message - The detail message.
        Throws:
        NullPointerException - When message is null.

      • XPathFunctionException

        public XPathFunctionException(Throwable cause)

        Constructs a new XPathFunctionException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        Parameters:
        cause - The cause.
        Throws:
        NullPointerException - if cause is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathFunctionResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Interface XPathFunctionResolver

  • public interface XPathFunctionResolver

    XPathFunctionResolver provides access to the set of user defined XPathFunctions.

    XPath functions are resolved by name and arity. The resolver is not needed for XPath built-in functions and the resolver cannot be used to override those functions.

    In particular, the resolver is only called for functions in an another namespace (functions with an explicit prefix). This means that you cannot use the XPathFunctionResolver to implement specifications like XML-Signature Syntax and Processing which extend the function library of XPath 1.0 in the same namespace. This is a consequence of the design of the resolver.

    If you wish to implement additional built-in functions, you will have to extend the underlying implementation directly.

    Since:
    1.5
    See Also:
    XML Path Language (XPath) Version 1.0, Core Function Library

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      XPathFunction resolveFunction(QName functionName, int arity)
      Find a function in the set of available functions.

    • Method Detail

      • resolveFunction

        XPathFunction resolveFunction(QName functionName,
                              int arity)

        Find a function in the set of available functions.

        If functionName or arity is null, then a NullPointerException is thrown.

        Parameters:
        functionName - The function name.
        arity - The number of arguments that the returned function must accept.
        Returns:
        The function or null if no function named functionName with arity arguments exists.
        Throws:
        NullPointerException - If functionName or arity is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XPathVariableResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
javax.xml.xpath

Interface XPathVariableResolver

  • public interface XPathVariableResolver

    XPathVariableResolver provides access to the set of user defined XPath variables.

    The XPathVariableResolver and the XPath evaluator must adhere to a contract that cannot be directly enforced by the API. Although variables may be mutable, that is, an application may wish to evaluate the same XPath expression more than once with different variable values, in the course of evaluating any single XPath expression, a variable's value must not change.

    Since:
    1.5

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object resolveVariable(QName variableName)
      Find a variable in the set of available variables.

    • Method Detail

      • resolveVariable

        Object resolveVariable(QName variableName)

        Find a variable in the set of available variables.

        If variableName is null, then a NullPointerException is thrown.

        Parameters:
        variableName - The QName of the variable name.
        Returns:
        The variables value, or null if no variable named variableName exists. The value returned must be of a type appropriate for the underlying object model.
        Throws:
        NullPointerException - If variableName is null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.xpath.XPath (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.xpath.XPath

  • Packages that use XPath
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPath in javax.xml.xpath

      Methods in javax.xml.xpath that return XPath
      Modifier and Type Method and Description
      abstract XPath XPathFactory.newXPath()
      Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.xpath.XPathConstants (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.xpath.XPathConstants

No usage of javax.xml.xpath.XPathConstants
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.xpath.XPathException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.xpath.XPathException

  • Packages that use XPathException
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathException in javax.xml.xpath

      Subclasses of XPathException in javax.xml.xpath
      Modifier and Type Class and Description
      class  XPathExpressionException
      XPathExpressionException represents an error in an XPath expression.
      class  XPathFactoryConfigurationException
      XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
      class  XPathFunctionException
      XPathFunctionException represents an error with an XPath function.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.xpath.XPathExpression (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.xpath.XPathExpression

  • Packages that use XPathExpression
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathExpression in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathExpression
      Modifier and Type Method and Description
      XPathExpression XPath.compile(String expression)
      Compile an XPath expression for later evaluation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.xpath.XPathExpressionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.xpath.XPathExpressionException

  • Packages that use XPathExpressionException
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathExpressionException in javax.xml.xpath

      Subclasses of XPathExpressionException in javax.xml.xpath
      Modifier and Type Class and Description
      class  XPathFunctionException
      XPathFunctionException represents an error with an XPath function.
      Methods in javax.xml.xpath that throw XPathExpressionException
      Modifier and Type Method and Description
      XPathExpression XPath.compile(String expression)
      Compile an XPath expression for later evaluation.
      String XPathExpression.evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPathExpression.evaluate(Object item)
      Evaluate the compiled XPath expression in the specified context and return the result as a String.
      Object XPathExpression.evaluate(Object item, QName returnType)
      Evaluate the compiled XPath expression in the specified context and return the result as the specified type.
      String XPath.evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPath.evaluate(String expression, Object item)
      Evaluate an XPath expression in the specified context and return the result as a String.
      Object XPath.evaluate(String expression, Object item, QName returnType)
      Evaluate an XPath expression in the specified context and return the result as the specified type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.xpath.XPathFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.xpath.XPathFactory

  • Packages that use XPathFactory
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFactory in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathFactory
      Modifier and Type Method and Description
      static XPathFactory XPathFactory.newInstance()
      Get a new XPathFactory instance using the default object model, DEFAULT_OBJECT_MODEL_URI, the W3C DOM.
      static XPathFactory XPathFactory.newInstance(String uri)
      Get a new XPathFactory instance using the specified object model.
      static XPathFactory XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a XPathFactory from a factory class name.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.xpath.XPathFactoryConfigurationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.xpath.XPathFactoryConfigurationException

  • Packages that use XPathFactoryConfigurationException
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFactoryConfigurationException in javax.xml.xpath

      Methods in javax.xml.xpath that throw XPathFactoryConfigurationException
      Modifier and Type Method and Description
      abstract boolean XPathFactory.getFeature(String name)
      Get the state of the named feature.
      static XPathFactory XPathFactory.newInstance(String uri)
      Get a new XPathFactory instance using the specified object model.
      static XPathFactory XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a XPathFactory from a factory class name.
      abstract void XPathFactory.setFeature(String name, boolean value)
      Set a feature for this XPathFactory and XPaths created by this factory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.xpath.XPathFunction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.xpath.XPathFunction

  • Packages that use XPathFunction
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFunction in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathFunction
      Modifier and Type Method and Description
      XPathFunction XPathFunctionResolver.resolveFunction(QName functionName, int arity)
      Find a function in the set of available functions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.xml.xpath.XPathFunctionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.xml.xpath.XPathFunctionException

  • Packages that use XPathFunctionException
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFunctionException in javax.xml.xpath

      Methods in javax.xml.xpath that throw XPathFunctionException
      Modifier and Type Method and Description
      Object XPathFunction.evaluate(List args)
      Evaluate the function with the specified arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.xpath.XPathFunctionResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.xpath.XPathFunctionResolver

  • Packages that use XPathFunctionResolver
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFunctionResolver in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathFunctionResolver
      Modifier and Type Method and Description
      XPathFunctionResolver XPath.getXPathFunctionResolver()
      Return the current function resolver.
      Methods in javax.xml.xpath with parameters of type XPathFunctionResolver
      Modifier and Type Method and Description
      void XPath.setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a function resolver.
      abstract void XPathFactory.setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a default function resolver.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface javax.xml.xpath.XPathVariableResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
javax.xml.xpath.XPathVariableResolver

  • Packages that use XPathVariableResolver
    Package Description
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathVariableResolver in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathVariableResolver
      Modifier and Type Method and Description
      XPathVariableResolver XPath.getXPathVariableResolver()
      Return the current variable resolver.
      Methods in javax.xml.xpath with parameters of type XPathVariableResolver
      Modifier and Type Method and Description
      void XPath.setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a variable resolver.
      abstract void XPathFactory.setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a default variable resolver.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ChannelBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Class ChannelBinding

  • java.lang.Object
    • org.ietf.jgss.ChannelBinding

  • public class ChannelBinding
extends Object
    This class encapsulates the concept of caller-provided channel binding information. Channel bindings are used to strengthen the quality with which peer entity authentication is provided during context establishment. They enable the GSS-API callers to bind the establishment of the security context to relevant characteristics like addresses or to application specific data.

    The caller initiating the security context must determine the appropriate channel binding values to set in the GSSContext object. The acceptor must provide an identical binding in order to validate that received tokens possess correct channel-related characteristics.

    Use of channel bindings is optional in GSS-API. ChannelBinding can be set for the GSSContext using the setChannelBinding method before the first call to initSecContext or acceptSecContext has been performed. Unless the setChannelBinding method has been used to set the ChannelBinding for a GSSContext object, null ChannelBinding will be assumed.

    Conceptually, the GSS-API concatenates the initiator and acceptor address information, and the application supplied byte array to form an octet string. The mechanism calculates a MIC over this octet string and binds the MIC to the context establishment token emitted by initSecContext method of the GSSContext interface. The same bindings are set by the context acceptor for its GSSContext object and during processing of the acceptSecContext method a MIC is calculated in the same way. The calculated MIC is compared with that found in the token, and if the MICs differ, accept will throw a GSSException with the major code set to BAD_BINDINGS, and the context will not be established. Some mechanisms may include the actual channel binding data in the token (rather than just a MIC); applications should therefore not use confidential data as channel-binding components.

    Individual mechanisms may impose additional constraints on addresses that may appear in channel bindings. For example, a mechanism may verify that the initiator address field of the channel binding contains the correct network address of the host system. Portable applications should therefore ensure that they either provide correct information for the address fields, or omit setting of the addressing information.

    Since:
    1.4

    • Constructor Summary

      Constructors
      Constructor and Description
      ChannelBinding(byte[] appData)
      Creates a ChannelBinding object without any addressing information.
      ChannelBinding(InetAddress initAddr, InetAddress acceptAddr, byte[] appData)
      Create a ChannelBinding object with user supplied address information and data.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean equals(Object obj)
      Compares two instances of ChannelBinding.
      InetAddress getAcceptorAddress()
      Get the acceptor's address for this channel binding.
      byte[] getApplicationData()
      Get the application specified data for this channel binding.
      InetAddress getInitiatorAddress()
      Get the initiator's address for this channel binding.
      int hashCode()
      Returns a hashcode value for this ChannelBinding object.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ChannelBinding

        public ChannelBinding(InetAddress initAddr,
                      InetAddress acceptAddr,
                      byte[] appData)
        Create a ChannelBinding object with user supplied address information and data. null values can be used for any fields which the application does not want to specify.
        Parameters:
        initAddr - the address of the context initiator. null value can be supplied to indicate that the application does not want to set this value.
        acceptAddr - the address of the context acceptor. null value can be supplied to indicate that the application does not want to set this value.
        appData - application supplied data to be used as part of the channel bindings. null value can be supplied to indicate that the application does not want to set this value.

      • ChannelBinding

        public ChannelBinding(byte[] appData)
        Creates a ChannelBinding object without any addressing information.
        Parameters:
        appData - application supplied data to be used as part of the channel bindings.

    • Method Detail

      • getInitiatorAddress

        public InetAddress getInitiatorAddress()
        Get the initiator's address for this channel binding.
        Returns:
        the initiator's address. null is returned if the address has not been set.

      • getAcceptorAddress

        public InetAddress getAcceptorAddress()
        Get the acceptor's address for this channel binding.
        Returns:
        the acceptor's address. null is returned if the address has not been set.

      • getApplicationData

        public byte[] getApplicationData()
        Get the application specified data for this channel binding.
        Returns:
        the application data being used as part of the ChannelBinding. null is returned if no application data has been specified for the channel binding.

      • equals

        public boolean equals(Object obj)
        Compares two instances of ChannelBinding.
        Overrides:
        equals in class Object
        Parameters:
        obj - another ChannelBinding to compare this one with
        Returns:
        true if the two ChannelBinding's contain the same values for the initiator and acceptor addresses and the application data.
        See Also:
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hashcode value for this ChannelBinding object.
        Overrides:
        hashCode in class Object
        Returns:
        a hashCode value
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.ietf.jgss (Java Platform SE 8 )

compact3 - org.ietf.jgss

Interfaces

  • GSSContext
  • GSSCredential
  • GSSName

Classes

  • ChannelBinding
  • GSSManager
  • MessageProp
  • Oid

Exceptions

  • GSSException


org.ietf.jgss (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.ietf.jgss

This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

See: Description

  • Interface Summary
    Interface Description
    GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context.
    GSSCredential
    This interface encapsulates the GSS-API credentials for an entity.
    GSSName
    This interface encapsulates a single GSS-API principal entity.
  • Class Summary
    Class Description
    ChannelBinding
    This class encapsulates the concept of caller-provided channel binding information.
    GSSManager
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.
    MessageProp
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.
    Oid
    This class represents Universal Object Identifiers (Oids) and their associated operations.
  • Exception Summary
    Exception Description
    GSSException
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.

Package org.ietf.jgss Description

This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API. The security mechanisms that an application can chose to use are identified with unique object identifiers. One example of such a mechanism is the Kerberos v5 GSS-API mechanism (object identifier 1.2.840.113554.1.2.2). This mechanism is available through the default instance of the GSSManager class.

The GSS-API is defined in a language independent way in RFC 2743. The Java language bindings are defined in RFC 2853

An application starts out by instantiating a GSSManager which then serves as a factory for a security context. An application can use specific principal names and credentials that are also created using the GSSManager; or it can instantiate a context with system defaults. It then goes through a context establishment loop. Once a context is established with the peer, authentication is complete. Data protection such as integrity and confidentiality can then be obtained from this context.

The GSS-API does not perform any communication with the peer. It merely produces tokens that the application must somehow transport to the other end.

Credential Acquisition

The GSS-API itself does not dictate how an underlying mechanism obtains the credentials that are needed for authentication. It is assumed that prior to calling the GSS-API, these credentials are obtained and stored in a location that the mechanism provider is aware of. However, the default model in the Java platform will be that mechanism providers must obtain credentials only from the private or public credential sets associated with the Subject in the current access control context. The Kerberos v5 mechanism will search for the required INITIATE and ACCEPT credentials (KerberosTicket and KerberosKey) in the private credential set where as some other mechanism might look in the public set or in both. If the desired credential is not present in the appropriate sets of the current Subject, the GSS-API call must fail.

This model has the advantage that credential management is simple and predictable from the applications point of view. An application, given the right permissions, can purge the credentials in the Subject or renew them using standard Java API's. If it purged the credentials, it would be sure that the JGSS mechanism would fail, or if it renewed a time based credential it would be sure that a JGSS mechanism would succeed.

This model does require that a JAAS login be performed in order to authenticate and populate a Subject that the JGSS mechanism can later utilize. However, applications have the ability to relax this restriction by means of a system property: javax.security.auth.useSubjectCredsOnly. By default this system property will be assumed to be true (even when it is unset) indicating that providers must only use the credentials that are present in the current Subject. However, if this property is explicitly set to false by the application, then it indicates that the provider is free to use any credentials cache of its choice. Such a credential cache might be a disk cache, an in-memory cache, or even just the current Subject itself.

Related Documentation

For an online tutorial on using Java GSS-API, please see Introduction to JAAS and Java GSS-API.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


GSSContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Interface GSSContext

  • public interface GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context. Security contexts are established between peers using locally acquired credentials. Multiple contexts may exist simultaneously between a pair of peers, using the same or different set of credentials. GSS-API functions in a manner independent of the underlying transport protocol and depends on its calling application to transport the tokens that are generated by the security context between the peers.

    If the caller instantiates the context using the default GSSManager instance, then the Kerberos v5 GSS-API mechanism is guaranteed to be available for context establishment. This mechanism is identified by the Oid "1.2.840.113554.1.2.2" and is defined in RFC 1964.

    Before the context establishment phase is initiated, the context initiator may request specific characteristics desired of the established context. Not all underlying mechanisms support all characteristics that a caller might desire. After the context is established, the caller can check the actual characteristics and services offered by that context by means of various query methods. When using the Kerberos v5 GSS-API mechanism offered by the default GSSManager instance, all optional services will be available locally. They are mutual authentication, credential delegation, confidentiality and integrity protection, and per-message replay detection and sequencing. Note that in the GSS-API, message integrity is a prerequisite for message confidentiality.

    The context establishment occurs in a loop where the initiator calls initSecContext and the acceptor calls acceptSecContext until the context is established. While in this loop the initSecContext and acceptSecContext methods produce tokens that the application sends over to the peer. The peer passes any such token as input to its acceptSecContext or initSecContext as the case may be.

    During the context establishment phase, the isProtReady method may be called to determine if the context can be used for the per-message operations of wrap and getMIC. This allows applications to use per-message operations on contexts which aren't yet fully established.

    After the context has been established or the isProtReady method returns true, the query routines can be invoked to determine the actual characteristics and services of the established context. The application can also start using the per-message methods of wrap and getMIC to obtain cryptographic operations on application supplied data.

    When the context is no longer needed, the application should call dispose to release any system resources the context may be using.

    A security context typically maintains sequencing and replay detection information about the tokens it processes. Therefore, the sequence in which any tokens are presented to this context for processing can be important. Also note that none of the methods in this interface are synchronized. Therefore, it is not advisable to share a GSSContext among several threads unless some application level synchronization is in place.

    Finally, different mechanism providers might place different security restrictions on using GSS-API contexts. These will be documented by the mechanism provider. The application will need to ensure that it has the appropriate permissions if such checks are made in the mechanism layer.

    The example code presented below demonstrates the usage of the GSSContext interface for the initiating peer. Different operations on the GSSContext object are presented, including: object instantiation, setting of desired flags, context establishment, query of actual context flags, per-message operations on application data, and finally context deletion.

        // Create a context using default credentials
    // and the implementation specific default mechanism
    GSSManager manager ...
    GSSName targetName ...
    GSSContext context = manager.createContext(targetName, null, null,
                                           GSSContext.INDEFINITE_LIFETIME);

    // set desired context options prior to context establishment
    context.requestConf(true);
    context.requestMutualAuth(true);
    context.requestReplayDet(true);
    context.requestSequenceDet(true);

    // establish a context between peers

    byte []inToken = new byte[0];

    // Loop while there still is a token to be processed

    while (!context.isEstablished()) {

        byte[] outToken
            = context.initSecContext(inToken, 0, inToken.length);

        // send the output token if generated
        if (outToken != null)
            sendToken(outToken);

        if (!context.isEstablished()) {
            inToken = readToken();
    }

     // display context information
     System.out.println("Remaining lifetime in seconds = "
                                          + context.getLifetime());
     System.out.println("Context mechanism = " + context.getMech());
     System.out.println("Initiator = " + context.getSrcName());
     System.out.println("Acceptor = " + context.getTargName());

     if (context.getConfState())
             System.out.println("Confidentiality (i.e., privacy) is available");

     if (context.getIntegState())
             System.out.println("Integrity is available");

     // perform wrap on an application supplied message, appMsg,
     // using QOP = 0, and requesting privacy service
     byte [] appMsg ...

     MessageProp mProp = new MessageProp(0, true);

     byte []tok = context.wrap(appMsg, 0, appMsg.length, mProp);

     sendToken(tok);

     // release the local-end of the context
     context.dispose();
    Since:
    1.4

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int DEFAULT_LIFETIME
      A lifetime constant representing the default context lifetime.
      static int INDEFINITE_LIFETIME
      A lifetime constant representing indefinite context lifetime.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] acceptSecContext(byte[] inToken, int offset, int len)
      Called by the context acceptor upon receiving a token from the peer.
      void acceptSecContext(InputStream inStream, OutputStream outStream)
      Called by the context acceptor to process a token from the peer using streams.
      void dispose()
      Releases any system resources and cryptographic information stored in the context object and invalidates the context.
      byte[] export()
      Exports this context so that another process may import it..
      boolean getAnonymityState()
      Determines if the context initiator is anonymously authenticated to the context acceptor.
      boolean getConfState()
      Determines if data confidentiality is available over the context.
      boolean getCredDelegState()
      Determines if credential delegation is enabled on this context.
      GSSCredential getDelegCred()
      Obtains the credentials delegated by the context initiator to the context acceptor.
      boolean getIntegState()
      Determines if data integrity is available over the context.
      int getLifetime()
      Determines what the remaining lifetime for this context is.
      Oid getMech()
      Determines what mechanism is being used for this context.
      byte[] getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp)
      Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.
      void getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.
      boolean getMutualAuthState()
      Determines if mutual authentication is enabled on this context.
      boolean getReplayDetState()
      Determines if replay detection is enabled for the per-message security services from this context.
      boolean getSequenceDetState()
      Determines if sequence checking is enabled for the per-message security services from this context.
      GSSName getSrcName()
      Returns the name of the context initiator.
      GSSName getTargName()
      Returns the name of the context acceptor.
      int getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize)
      Used to determine limits on the size of the message that can be passed to wrap.
      byte[] initSecContext(byte[] inputBuf, int offset, int len)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method.
      int initSecContext(InputStream inStream, OutputStream outStream)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams.
      boolean isEstablished()
      Used during context establishment to determine the state of the context.
      boolean isInitiator()
      Determines if this is the context initiator.
      boolean isProtReady()
      Determines if the context is ready for per message operations to be used over it.
      boolean isTransferable()
      Determines if the context is transferable to other processes through the use of the export method.
      void requestAnonymity(boolean state)
      Requests that the initiator's identity not be disclosed to the acceptor.
      void requestConf(boolean state)
      Requests that data confidentiality be enabled for the wrap method.
      void requestCredDeleg(boolean state)
      Requests that the initiator's credentials be delegated to the acceptor during context establishment.
      void requestInteg(boolean state)
      Requests that data integrity be enabled for the wrap and getMICmethods.
      void requestLifetime(int lifetime)
      Requests a lifetime in seconds for the context.
      void requestMutualAuth(boolean state)
      Requests that mutual authentication be done during context establishment.
      void requestReplayDet(boolean state)
      Requests that replay detection be enabled for the per-message security services after context establishment.
      void requestSequenceDet(boolean state)
      Requests that sequence checking be enabled for the per-message security services after context establishment.
      void setChannelBinding(ChannelBinding cb)
      Sets the channel bindings to be used during context establishment.
      byte[] unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Used to process tokens generated by the wrap method on the other side of the context.
      void unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to process tokens generated by the wrap method on the other side of the context.
      void verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp)
      Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
      void verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
      byte[] wrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Applies per-message security services over the established security context.
      void wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Applies per-message security services over the established security context using streams.

    • Field Detail

      • DEFAULT_LIFETIME

        static final int DEFAULT_LIFETIME
        A lifetime constant representing the default context lifetime. This value is set to 0.
        See Also:
        Constant Field Values

      • INDEFINITE_LIFETIME

        static final int INDEFINITE_LIFETIME
        A lifetime constant representing indefinite context lifetime. This value must is set to the maximum integer value in Java - Integer.MAX_VALUE.
        See Also:
        Constant Field Values

    • Method Detail

      • initSecContext

        byte[] initSecContext(byte[] inputBuf,
                      int offset,
                      int len)
               throws GSSException
        Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method. This method may return an output token which the application will need to send to the peer for processing by its acceptSecContext method. The application can call isEstablished to determine if the context establishment phase is complete on this side of the context. A return value of false from isEstablished indicates that more tokens are expected to be supplied to initSecContext. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that the initSecContext method return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        Some mechanism providers might require that the caller be granted permission to initiate a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        Parameters:
        inputBuf - token generated by the peer. This parameter is ignored on the first call since no token has been received from the peer.
        offset - the offset within the inputBuf where the token begins.
        len - the length of the token.
        Returns:
        a byte[] containing the token to be sent to the peer. null indicates that no token is generated.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_NAMETYPE, GSSException.BAD_MECH, GSSException.FAILURE

      • initSecContext

        int initSecContext(InputStream inStream,
                   OutputStream outStream)
            throws GSSException
        Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams. This method may write an output token to the OutpuStream, which the application will need to send to the peer for processing by its acceptSecContext call. Typically, the application would ensure this by calling the flush method on an OutputStream that encapsulates the connection between the two peers. The application can determine if a token is written to the OutputStream from the return value of this method. A return value of 0 indicates that no token was written. The application can call isEstablished to determine if the context establishment phase is complete on this side of the context. A return value of false from isEstablished indicates that more tokens are expected to be supplied to initSecContext. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that the initSecContext method return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        The GSS-API authentication tokens contain a definitive start and end. This method will attempt to read one of these tokens per invocation, and may block on the stream if only part of the token is available. In all other respects this method is equivalent to the byte array based initSecContext.

        Some mechanism providers might require that the caller be granted permission to initiate a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        The following example code demonstrates how this method might be used:

             InputStream is ...
     OutputStream os ...
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {

         context.initSecContext(is, os);

         // send output token if generated
         os.flush();
     }
        Parameters:
        inStream - an InputStream that contains the token generated by the peer. This parameter is ignored on the first call since no token has been or will be received from the peer at that point.
        outStream - an OutputStream where the output token will be written. During the final stage of context establishment, there may be no bytes written.
        Returns:
        the number of bytes written to the OutputStream as part of the token to be sent to the peer. A value of 0 indicates that no token needs to be sent.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_NAMETYPE, GSSException.BAD_MECH, GSSException.FAILURE

      • acceptSecContext

        byte[] acceptSecContext(byte[] inToken,
                        int offset,
                        int len)
                 throws GSSException
        Called by the context acceptor upon receiving a token from the peer. This method may return an output token which the application will need to send to the peer for further processing by its initSecContext call.

        The application can call isEstablished to determine if the context establishment phase is complete for this peer. A return value of false from isEstablished indicates that more tokens are expected to be supplied to this method. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that acceptSecContext return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        Some mechanism providers might require that the caller be granted permission to accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        The following example code demonstrates how this method might be used:

             byte[] inToken;
     byte[] outToken;
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {
         inToken = readToken();
         outToken = context.acceptSecContext(inToken, 0,
                                             inToken.length);
         // send output token if generated
         if (outToken != null)
             sendToken(outToken);
     }
        Parameters:
        inToken - token generated by the peer.
        offset - the offset within the inToken where the token begins.
        len - the length of the token.
        Returns:
        a byte[] containing the token to be sent to the peer. null indicates that no token is generated.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_MECH, GSSException.FAILURE

      • acceptSecContext

        void acceptSecContext(InputStream inStream,
                      OutputStream outStream)
               throws GSSException
        Called by the context acceptor to process a token from the peer using streams. It may write an output token to the OutputStream, which the application will need to send to the peer for processing by its initSecContext method. Typically, the application would ensure this by calling the flush method on an OutputStream that encapsulates the connection between the two peers. The application can call isEstablished to determine if the context establishment phase is complete on this side of the context. A return value of false from isEstablished indicates that more tokens are expected to be supplied to acceptSecContext. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that acceptSecContext return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        The GSS-API authentication tokens contain a definitive start and end. This method will attempt to read one of these tokens per invocation, and may block on the stream if only part of the token is available. In all other respects this method is equivalent to the byte array based acceptSecContext.

        Some mechanism providers might require that the caller be granted permission to accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        The following example code demonstrates how this method might be used:

             InputStream is ...
     OutputStream os ...
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {

         context.acceptSecContext(is, os);

         // send output token if generated
         os.flush();
     }
        Parameters:
        inStream - an InputStream that contains the token generated by the peer.
        outStream - an OutputStream where the output token will be written. During the final stage of context establishment, there may be no bytes written.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_MECH, GSSException.FAILURE

      • isEstablished

        boolean isEstablished()
        Used during context establishment to determine the state of the context.
        Returns:
        true if this is a fully established context on the caller's side and no more tokens are needed from the peer.

      • dispose

        void dispose()
      throws GSSException
        Releases any system resources and cryptographic information stored in the context object and invalidates the context.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getWrapSizeLimit

        int getWrapSizeLimit(int qop,
                     boolean confReq,
                     int maxTokenSize)
              throws GSSException
        Used to determine limits on the size of the message that can be passed to wrap. Returns the maximum message size that, if presented to the wrap method with the same confReq and qop parameters, will result in an output token containing no more than maxTokenSize bytes.

        This call is intended for use by applications that communicate over protocols that impose a maximum message size. It enables the application to fragment messages prior to applying protection.

        GSS-API implementations are recommended but not required to detect invalid QOP values when getWrapSizeLimit is called. This routine guarantees only a maximum message size, not the availability of specific QOP values for message protection.

        Parameters:
        qop - the level of protection wrap will be asked to provide.
        confReq - true if wrap will be asked to provide privacy, false otherwise.
        maxTokenSize - the desired maximum size of the token emitted by wrap.
        Returns:
        the maximum size of the input token for the given output token size
        Throws:
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • wrap

        byte[] wrap(byte[] inBuf,
            int offset,
            int len,
            MessageProp msgProp)
     throws GSSException
        Applies per-message security services over the established security context. The method will return a token with the application supplied data and a cryptographic MIC over it. The data may be encrypted if confidentiality (privacy) was requested.

        The MessageProp object is instantiated by the application and used to specify a QOP value which selects cryptographic algorithms, and a privacy service to optionally encrypt the message. The underlying mechanism that is used in the call may not be able to provide the privacy service. It sets the actual privacy service that it does provide in this MessageProp object which the caller should then query upon return. If the mechanism is not able to provide the requested QOP, it throws a GSSException with the BAD_QOP code.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping of zero-length messages.

        The application will be responsible for sending the token to the peer.

        Parameters:
        inBuf - application data to be protected.
        offset - the offset within the inBuf where the data begins.
        len - the length of the data
        msgProp - instance of MessageProp that is used by the application to set the desired QOP and privacy state. Set the desired QOP to 0 to request the default QOP. Upon return from this method, this object will contain the the actual privacy state that was applied to the message by the underlying mechanism.
        Returns:
        a byte[] containing the token to be sent to the peer.
        Throws:
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • wrap

        void wrap(InputStream inStream,
          OutputStream outStream,
          MessageProp msgProp)
   throws GSSException
        Applies per-message security services over the established security context using streams. The method will return a token with the application supplied data and a cryptographic MIC over it. The data may be encrypted if confidentiality (privacy) was requested. This method is equivalent to the byte array based wrap method.

        The application will be responsible for sending the token to the peer. Typically, the application would ensure this by calling the flush method on an OutputStream that encapsulates the connection between the two peers.

        The MessageProp object is instantiated by the application and used to specify a QOP value which selects cryptographic algorithms, and a privacy service to optionally encrypt the message. The underlying mechanism that is used in the call may not be able to provide the privacy service. It sets the actual privacy service that it does provide in this MessageProp object which the caller should then query upon return. If the mechanism is not able to provide the requested QOP, it throws a GSSException with the BAD_QOP code.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping of zero-length messages.

        Parameters:
        inStream - an InputStream containing the application data to be protected. All of the data that is available in inStream is used.
        outStream - an OutputStream to write the protected message to.
        msgProp - instance of MessageProp that is used by the application to set the desired QOP and privacy state. Set the desired QOP to 0 to request the default QOP. Upon return from this method, this object will contain the the actual privacy state that was applied to the message by the underlying mechanism.
        Throws:
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • unwrap

        byte[] unwrap(byte[] inBuf,
              int offset,
              int len,
              MessageProp msgProp)
       throws GSSException
        Used to process tokens generated by the wrap method on the other side of the context. The method will return the message supplied by the peer application to its wrap call, while at the same time verifying the embedded MIC for that message.

        The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP, whether confidentiality was applied to the message, and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping and unwrapping of zero-length messages.

        Parameters:
        inBuf - a byte array containing the wrap token received from peer.
        offset - the offset where the token begins.
        len - the length of the token
        msgProp - upon return from the method, this object will contain the applied QOP, the privacy state of the message, and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        Returns:
        a byte[] containing the message unwrapped from the input token.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.CONTEXT_EXPIRED, GSSException.FAILURE

      • unwrap

        void unwrap(InputStream inStream,
            OutputStream outStream,
            MessageProp msgProp)
     throws GSSException
        Uses streams to process tokens generated by the wrap method on the other side of the context. The method will return the message supplied by the peer application to its wrap call, while at the same time verifying the embedded MIC for that message.

        The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP, whether confidentiality was applied to the message, and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping and unwrapping of zero-length messages.

        The format of the input token that this method reads is defined in the specification for the underlying mechanism that will be used. This method will attempt to read one of these tokens per invocation. If the mechanism token contains a definitive start and end this method may block on the InputStream if only part of the token is available. If the start and end of the token are not definitive then the method will attempt to treat all available bytes as part of the token.

        Other than the possible blocking behavior described above, this method is equivalent to the byte array based unwrap method.

        Parameters:
        inStream - an InputStream that contains the wrap token generated by the peer.
        outStream - an OutputStream to write the application message to.
        msgProp - upon return from the method, this object will contain the applied QOP, the privacy state of the message, and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.CONTEXT_EXPIRED, GSSException.FAILURE

      • getMIC

        byte[] getMIC(byte[] inMsg,
              int offset,
              int len,
              MessageProp msgProp)
       throws GSSException
        Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application. Unlike wrap, which encapsulates the user message in the returned token, only the message MIC is returned in the output token.

        Note that privacy can only be applied through the wrap call.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support derivation of MICs from zero-length messages.

        Parameters:
        inMsg - the message to generate the MIC over.
        offset - offset within the inMsg where the message begins.
        len - the length of the message
        msgProp - an instance of MessageProp that is used by the application to set the desired QOP. Set the desired QOP to 0 in msgProp to request the default QOP. Alternatively pass in null for msgProp to request the default QOP.
        Returns:
        a byte[] containing the token to be sent to the peer.
        Throws:
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • getMIC

        void getMIC(InputStream inStream,
            OutputStream outStream,
            MessageProp msgProp)
     throws GSSException
        Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application. Unlike wrap, which encapsulates the user message in the returned token, only the message MIC is produced in the output token. This method is equivalent to the byte array based getMIC method. Note that privacy can only be applied through the wrap call.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support derivation of MICs from zero-length messages.

        Parameters:
        inStream - an InputStream containing the message to generate the MIC over. All of the data that is available in inStream is used.
        outStream - an OutputStream to write the output token to.
        msgProp - an instance of MessageProp that is used by the application to set the desired QOP. Set the desired QOP to 0 in msgProp to request the default QOP. Alternatively pass in null for msgProp to request the default QOP.
        Throws:
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • verifyMIC

        void verifyMIC(byte[] inToken,
               int tokOffset,
               int tokLen,
               byte[] inMsg,
               int msgOffset,
               int msgLen,
               MessageProp msgProp)
        throws GSSException
        Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.

        The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP indicating the strength of protection that was applied to the message and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support the calculation and verification of MICs over zero-length messages.

        Parameters:
        inToken - the token generated by peer's getMIC method.
        tokOffset - the offset within the inToken where the token begins.
        tokLen - the length of the token.
        inMsg - the application message to verify the cryptographic MIC over.
        msgOffset - the offset in inMsg where the message begins.
        msgLen - the length of the message.
        msgProp - upon return from the method, this object will contain the applied QOP and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN GSSException.BAD_MIC GSSException.CONTEXT_EXPIRED GSSException.FAILURE

      • verifyMIC

        void verifyMIC(InputStream tokStream,
               InputStream msgStream,
               MessageProp msgProp)
        throws GSSException
        Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message. This method is equivalent to the byte array based verifyMIC method. The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP indicating the strength of protection that was applied to the message and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support the calculation and verification of MICs over zero-length messages.

        The format of the input token that this method reads is defined in the specification for the underlying mechanism that will be used. This method will attempt to read one of these tokens per invocation. If the mechanism token contains a definitive start and end this method may block on the InputStream if only part of the token is available. If the start and end of the token are not definitive then the method will attempt to treat all available bytes as part of the token.

        Other than the possible blocking behavior described above, this method is equivalent to the byte array based verifyMIC method.

        Parameters:
        tokStream - an InputStream containing the token generated by the peer's getMIC method.
        msgStream - an InputStream containing the application message to verify the cryptographic MIC over. All of the data that is available in msgStream is used.
        msgProp - upon return from the method, this object will contain the applied QOP and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        Throws:
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN GSSException.BAD_MIC GSSException.CONTEXT_EXPIRED GSSException.FAILURE

      • export

        byte[] export()
       throws GSSException
        Exports this context so that another process may import it.. Provided to support the sharing of work between multiple processes. This routine will typically be used by the context-acceptor, in an application where a single process receives incoming connection requests and accepts security contexts over them, then passes the established context to one or more other processes for message exchange.

        This method deactivates the security context and creates an interprocess token which, when passed to GSSManager.createContext in another process, will re-activate the context in the second process. Only a single instantiation of a given context may be active at any one time; a subsequent attempt by a context exporter to access the exported security context will fail.

        The implementation may constrain the set of processes by which the interprocess token may be imported, either as a function of local security policy, or as a result of implementation decisions. For example, some implementations may constrain contexts to be passed only between processes that run under the same account, or which are part of the same process group.

        The interprocess token may contain security-sensitive information (for example cryptographic keys). While mechanisms are encouraged to either avoid placing such sensitive information within interprocess tokens, or to encrypt the token before returning it to the application, in a typical GSS-API implementation this may not be possible. Thus the application must take care to protect the interprocess token, and ensure that any process to which the token is transferred is trustworthy.

        Implementations are not required to support the inter-process transfer of security contexts. Calling the isTransferable method will indicate if the context object is transferable.

        Calling this method on a context that is not exportable will result in this exception being thrown with the error code GSSException.UNAVAILABLE.

        Returns:
        a byte[] containing the exported context
        Throws:
        GSSException - containing the following major error codes: GSSException.UNAVAILABLE, GSSException.CONTEXT_EXPIRED, GSSException.NO_CONTEXT, GSSException.FAILURE
        See Also:
        GSSManager.createContext(byte[])

      • requestMutualAuth

        void requestMutualAuth(boolean state)
                throws GSSException
        Requests that mutual authentication be done during context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext.

        Not all mechanisms support mutual authentication and some mechanisms might require mutual authentication even if the application doesn't. Therefore, the application should check to see if the request was honored with the getMutualAuthState method.

        Parameters:
        state - a boolean value indicating whether mutual authentication should be used or not.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getMutualAuthState()

      • requestReplayDet

        void requestReplayDet(boolean state)
               throws GSSException
        Requests that replay detection be enabled for the per-message security services after context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. During context establishment replay detection is not an option and is a function of the underlying mechanism's capabilities.

        Not all mechanisms support replay detection and some mechanisms might require replay detection even if the application doesn't. Therefore, the application should check to see if the request was honored with the getReplayDetState method. If replay detection is enabled then the MessageProp.isDuplicateToken and MessageProp.isOldToken methods will return valid results for the MessageProp object that is passed in to the unwrap method or the verifyMIC method.

        Parameters:
        state - a boolean value indicating whether replay detection should be enabled over the established context or not.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getReplayDetState()

      • requestSequenceDet

        void requestSequenceDet(boolean state)
                 throws GSSException
        Requests that sequence checking be enabled for the per-message security services after context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. During context establishment sequence checking is not an option and is a function of the underlying mechanism's capabilities.

        Not all mechanisms support sequence checking and some mechanisms might require sequence checking even if the application doesn't. Therefore, the application should check to see if the request was honored with the getSequenceDetState method. If sequence checking is enabled then the MessageProp.isDuplicateToken, MessageProp.isOldToken, MessageProp.isUnseqToken, and MessageProp.isGapToken methods will return valid results for the MessageProp object that is passed in to the unwrap method or the verifyMIC method.

        Parameters:
        state - a boolean value indicating whether sequence checking should be enabled over the established context or not.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getSequenceDetState()

      • requestCredDeleg

        void requestCredDeleg(boolean state)
               throws GSSException
        Requests that the initiator's credentials be delegated to the acceptor during context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support credential delegation. Therefore, an application that desires delegation should check to see if the request was honored with the getCredDelegState method. If the application indicates that delegation must not be used, then the mechanism will honor the request and delegation will not occur. This is an exception to the general rule that a mechanism may enable a service even if it is not requested.

        Parameters:
        state - a boolean value indicating whether the credentials should be delegated or not.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getCredDelegState()

      • requestAnonymity

        void requestAnonymity(boolean state)
               throws GSSException
        Requests that the initiator's identity not be disclosed to the acceptor. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support anonymity for the initiator. Therefore, the application should check to see if the request was honored with the getAnonymityState method.

        Parameters:
        state - a boolean value indicating if the initiator should be authenticated to the acceptor as an anonymous principal.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getAnonymityState()

      • requestConf

        void requestConf(boolean state)
          throws GSSException
        Requests that data confidentiality be enabled for the wrap method. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support confidentiality and other mechanisms might enable it even if the application doesn't request it. The application may check to see if the request was honored with the getConfState method. If confidentiality is enabled, only then will the mechanism honor a request for privacy in the MessageProp object that is passed in to the wrap method.

        Enabling confidentiality will also automatically enable integrity.

        Parameters:
        state - a boolean value indicating whether confidentiality should be enabled or not.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getConfState(), getIntegState(), requestInteg(boolean), MessageProp

      • requestInteg

        void requestInteg(boolean state)
           throws GSSException
        Requests that data integrity be enabled for the wrap and getMICmethods. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support integrity and other mechanisms might enable it even if the application doesn't request it. The application may check to see if the request was honored with the getIntegState method.

        Disabling integrity will also automatically disable confidentiality.

        Parameters:
        state - a boolean value indicating whether integrity should be enabled or not.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getIntegState()

      • requestLifetime

        void requestLifetime(int lifetime)
              throws GSSException
        Requests a lifetime in seconds for the context. This method can only be called on the context initiator's side and it has to be done prior to the first call to initSecContext.

        The actual lifetime of the context will depend on the capabilities of the underlying mechanism and the application should call the getLifetime method to determine this.

        Parameters:
        lifetime - the desired context lifetime in seconds. Use INDEFINITE_LIFETIME to request an indefinite lifetime and DEFAULT_LIFETIME to request a default lifetime.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getLifetime()

      • setChannelBinding

        void setChannelBinding(ChannelBinding cb)
                throws GSSException
        Sets the channel bindings to be used during context establishment. This method can be called on both the context initiator's and the context acceptor's side, but it must be called before context establishment begins. This means that an initiator must call it before the first call to initSecContext and the acceptor must call it before the first call to acceptSecContext.
        Parameters:
        cb - the channel bindings to use.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getCredDelegState

        boolean getCredDelegState()
        Determines if credential delegation is enabled on this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. Note that if an initiator requests that delegation not be allowed the requestCredDeleg method will honor that request and this method will return false on the initiator's side from that point onwards.

        Returns:
        true if delegation is enabled, false otherwise.
        See Also:
        requestCredDeleg(boolean)

      • getMutualAuthState

        boolean getMutualAuthState()
        Determines if mutual authentication is enabled on this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. An initiator that requests mutual authentication can call this method after context completion and dispose the context if its request was not honored.

        Returns:
        true if mutual authentication is enabled, false otherwise.
        See Also:
        requestMutualAuth(boolean)

      • getReplayDetState

        boolean getReplayDetState()
        Determines if replay detection is enabled for the per-message security services from this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. An initiator that requests replay detection can call this method after context completion and dispose the context if its request was not honored.

        Returns:
        true if replay detection is enabled, false otherwise.
        See Also:
        requestReplayDet(boolean)

      • getSequenceDetState

        boolean getSequenceDetState()
        Determines if sequence checking is enabled for the per-message security services from this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. An initiator that requests sequence checking can call this method after context completion and dispose the context if its request was not honored.

        Returns:
        true if sequence checking is enabled, false otherwise.
        See Also:
        requestSequenceDet(boolean)

      • getAnonymityState

        boolean getAnonymityState()
        Determines if the context initiator is anonymously authenticated to the context acceptor. It can be called by both the context initiator and the context acceptor, and at any time. On the initiator side, a call to this method determines if the identity of the initiator has been disclosed in any of the context establishment tokens that might have been generated thus far by initSecContext. An initiator that absolutely must be authenticated anonymously should call this method after each call to initSecContext to determine if the generated token should be sent to the peer or the context aborted. On the acceptor side, a call to this method determines if any of the tokens processed by acceptSecContext thus far have divulged the identity of the initiator.

        Returns:
        true if the context initiator is still anonymous, false otherwise.
        See Also:
        requestAnonymity(boolean)

      • isTransferable

        boolean isTransferable()
                throws GSSException
        Determines if the context is transferable to other processes through the use of the export method. This call is only valid on fully established contexts.
        Returns:
        true if this context can be exported, false otherwise.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • isProtReady

        boolean isProtReady()
        Determines if the context is ready for per message operations to be used over it. Some mechanisms may allow the usage of the per-message operations before the context is fully established.
        Returns:
        true if methods like wrap, unwrap, getMIC, and verifyMIC can be used with this context at the current stage of context establishment, false otherwise.

      • getConfState

        boolean getConfState()
        Determines if data confidentiality is available over the context. This method can be called by both the context initiator and the context acceptor, but only after one of isProtReady or isEstablished return true. If this method returns true, so will getIntegState

        Returns:
        true if confidentiality services are available, false otherwise.
        See Also:
        requestConf(boolean)

      • getIntegState

        boolean getIntegState()
        Determines if data integrity is available over the context. This method can be called by both the context initiator and the context acceptor, but only after one of isProtReady or isEstablished return true. This method will always return true if getConfState returns true.

        Returns:
        true if integrity services are available, false otherwise.
        See Also:
        requestInteg(boolean)

      • getLifetime

        int getLifetime()
        Determines what the remaining lifetime for this context is. It can be called by both the context initiator and the context acceptor, but for a definitive answer it should be called only after isEstablished returns true.

        Returns:
        the remaining lifetime in seconds
        See Also:
        requestLifetime(int)

      • getSrcName

        GSSName getSrcName()
            throws GSSException
        Returns the name of the context initiator. This call is valid only after one of isProtReady or isEstablished return true.
        Returns:
        a GSSName that is an MN containing the name of the context initiator.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        GSSName

      • getTargName

        GSSName getTargName()
             throws GSSException
        Returns the name of the context acceptor. This call is valid only after one of isProtReady or isEstablished return true.
        Returns:
        a GSSName that is an MN containing the name of the context acceptor.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getMech

        Oid getMech()
     throws GSSException
        Determines what mechanism is being used for this context. This method may be called before the context is fully established, but the mechanism returned may change on successive calls in the negotiated mechanism case.
        Returns:
        the Oid of the mechanism being used
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getDelegCred

        GSSCredential getDelegCred()
                    throws GSSException
        Obtains the credentials delegated by the context initiator to the context acceptor. It should be called only on the context acceptor's side, and once the context is fully established. The caller can use the method getCredDelegState to determine if there are any delegated credentials.
        Returns:
        a GSSCredential containing the initiator's delegated credentials, or null is no credentials were delegated.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • isInitiator

        boolean isInitiator()
             throws GSSException
        Determines if this is the context initiator. This can be called on both the context initiator's and context acceptor's side.
        Returns:
        true if this is the context initiator, false if it is the context acceptor.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


GSSCredential (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Interface GSSCredential

  • All Superinterfaces:
    Cloneable

    public interface GSSCredential
extends Cloneable
    This interface encapsulates the GSS-API credentials for an entity. A credential contains all the necessary cryptographic information to enable the creation of a context on behalf of the entity that it represents. It may contain multiple, distinct, mechanism specific credential elements, each containing information for a specific security mechanism, but all referring to the same entity. A credential may be used to perform context initiation, acceptance, or both.

    Credentials are instantiated using one of the createCredential methods in the GSSManager class. GSS-API credential creation is not intended to provide a "login to the network" function, as such a function would involve the creation of new credentials rather than merely acquiring a handle to existing credentials. The section on credential acquisition in the package level description describes how existing credentials are acquired in the Java platform. GSS-API implementations must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled.

    Applications will create a credential object passing the desired parameters. The application can then use the query methods to obtain specific information about the instantiated credential object. When the credential is no longer needed, the application should call the dispose method to release any resources held by the credential object and to destroy any cryptographically sensitive information.

    This example code demonstrates the creation of a GSSCredential implementation for a specific entity, querying of its fields, and its release when it is no longer needed:

        GSSManager manager = GSSManager.getInstance();

    // start by creating a name object for the entity
    GSSName name = manager.createName("myusername", GSSName.NT_USER_NAME);

    // now acquire credentials for the entity
    GSSCredential cred = manager.createCredential(name,
                    GSSCredential.ACCEPT_ONLY);

    // display credential information - name, remaining lifetime,
    // and the mechanisms it has been acquired over
    System.out.println(cred.getName().toString());
    System.out.println(cred.getRemainingLifetime());

    Oid [] mechs = cred.getMechs();
    if (mechs != null) {
            for (int i = 0; i < mechs.length; i++)
                    System.out.println(mechs[i].toString());
    }

    // release system resources held by the credential
    cred.dispose();
    Since:
    1.4
    See Also:
    GSSManager.createCredential(int),
GSSManager.createCredential(GSSName, int, Oid, int),
GSSManager.createCredential(GSSName, int, Oid[], int),
dispose()

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ACCEPT_ONLY
      Credential usage flag requesting that it be usable for context acceptance only.
      static int DEFAULT_LIFETIME
      A lifetime constant representing the default credential lifetime.
      static int INDEFINITE_LIFETIME
      A lifetime constant representing indefinite credential lifetime.
      static int INITIATE_AND_ACCEPT
      Credential usage flag requesting that it be usable for both context initiation and acceptance.
      static int INITIATE_ONLY
      Credential usage flag requesting that it be usable for context initiation only.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      void dispose()
      Releases any sensitive information that the GSSCredential object may be containing.
      boolean equals(Object another)
      Tests if this GSSCredential asserts the same entity as the supplied object.
      Oid[] getMechs()
      Returns a list of mechanisms supported by this credential.
      GSSName getName()
      Retrieves the name of the entity that the credential asserts.
      GSSName getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      int getRemainingAcceptLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.
      int getRemainingInitLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.
      int getRemainingLifetime()
      Returns the remaining lifetime in seconds for a credential.
      int getUsage()
      Returns the credential usage mode.
      int getUsage(Oid mech)
      Returns the credential usage mode for a specific mechanism.
      int hashCode()
      Returns a hashcode value for this GSSCredential.

    • Field Detail

      • INITIATE_AND_ACCEPT

        static final int INITIATE_AND_ACCEPT
        Credential usage flag requesting that it be usable for both context initiation and acceptance.
        See Also:
        Constant Field Values

      • INITIATE_ONLY

        static final int INITIATE_ONLY
        Credential usage flag requesting that it be usable for context initiation only.
        See Also:
        Constant Field Values

      • ACCEPT_ONLY

        static final int ACCEPT_ONLY
        Credential usage flag requesting that it be usable for context acceptance only.
        See Also:
        Constant Field Values

      • DEFAULT_LIFETIME

        static final int DEFAULT_LIFETIME
        A lifetime constant representing the default credential lifetime. This value it set to 0.
        See Also:
        Constant Field Values

      • INDEFINITE_LIFETIME

        static final int INDEFINITE_LIFETIME
        A lifetime constant representing indefinite credential lifetime. This value must is set to the maximum integer value in Java - Integer.MAX_VALUE.
        See Also:
        Constant Field Values

    • Method Detail

      • dispose

        void dispose()
      throws GSSException
        Releases any sensitive information that the GSSCredential object may be containing. Applications should call this method as soon as the credential is no longer needed to minimize the time any sensitive information is maintained.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getName

        GSSName getName()
         throws GSSException
        Retrieves the name of the entity that the credential asserts.
        Returns:
        a GSSName representing the entity
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getName

        GSSName getName(Oid mech)
         throws GSSException
        Retrieves a Mechanism Name of the entity that the credential asserts. This is equivalent to calling canonicalize on the value returned by the other form of getName.
        Parameters:
        mech - the Oid of the mechanism for which the Mechanism Name should be returned.
        Returns:
        a GSSName representing the entity canonicalized for the desired mechanism
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getRemainingLifetime

        int getRemainingLifetime()
                  throws GSSException
        Returns the remaining lifetime in seconds for a credential. The remaining lifetime is the minimum lifetime amongst all of the underlying mechanism specific credential elements.
        Returns:
        the minimum remaining lifetime in seconds for this credential. A return value of INDEFINITE_LIFETIME indicates that the credential does not expire. A return value of 0 indicates that the credential is already expired.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE
        See Also:
        getRemainingInitLifetime(Oid), getRemainingAcceptLifetime(Oid)

      • getRemainingInitLifetime

        int getRemainingInitLifetime(Oid mech)
                      throws GSSException
        Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism. This method queries the initiator credential element that belongs to the specified mechanism.
        Parameters:
        mech - the Oid of the mechanism whose initiator credential element should be queried.
        Returns:
        the number of seconds remaining in the life of this credential element. A return value of INDEFINITE_LIFETIME indicates that the credential element does not expire. A return value of 0 indicates that the credential element is already expired.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getRemainingAcceptLifetime

        int getRemainingAcceptLifetime(Oid mech)
                        throws GSSException
        Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism. This method queries the acceptor credential element that belongs to the specified mechanism.
        Parameters:
        mech - the Oid of the mechanism whose acceptor credential element should be queried.
        Returns:
        the number of seconds remaining in the life of this credential element. A return value of INDEFINITE_LIFETIME indicates that the credential element does not expire. A return value of 0 indicates that the credential element is already expired.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getUsage

        int getUsage()
      throws GSSException
        Returns the credential usage mode. In other words, it tells us if this credential can be used for initiating or accepting security contexts. It does not tell us which mechanism(s) has to be used in order to do so. It is expected that an application will allow the GSS-API to pick a default mechanism after calling this method.
        Returns:
        The return value will be one of INITIATE_ONLY, ACCEPT_ONLY, and INITIATE_AND_ACCEPT.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getUsage

        int getUsage(Oid mech)
      throws GSSException
        Returns the credential usage mode for a specific mechanism. In other words, it tells us if this credential can be used for initiating or accepting security contexts with a given underlying mechanism.
        Parameters:
        mech - the Oid of the mechanism whose credentials usage mode is to be determined.
        Returns:
        The return value will be one of INITIATE_ONLY, ACCEPT_ONLY, and INITIATE_AND_ACCEPT.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getMechs

        Oid[] getMechs()
        throws GSSException
        Returns a list of mechanisms supported by this credential. It does not tell us which ones can be used to initiate contexts and which ones can be used to accept contexts. The application must call the getUsage method with each of the returned Oid's to determine the possible modes of usage.
        Returns:
        an array of Oid's corresponding to the supported mechanisms.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • add

        void add(GSSName name,
         int initLifetime,
         int acceptLifetime,
         Oid mech,
         int usage)
  throws GSSException
        Adds a mechanism specific credential-element to an existing credential. This method allows the construction of credentials, one mechanism at a time.

        This routine is envisioned to be used mainly by context acceptors during the creation of acceptor credentials which are to be used with a variety of clients using different security mechanisms.

        This routine adds the new credential element "in-place". To add the element in a new credential, first call clone to obtain a copy of this credential, then call its add method.

        As always, GSS-API implementations must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. Non-default values for initLifetime and acceptLifetime cannot always be honored by the underlying mechanisms, thus callers should be prepared to call getRemainingInitLifetime and getRemainingAcceptLifetime on the credential.

        Parameters:
        name - the name of the principal for whom this credential is to be acquired. Use null to specify the default principal.
        initLifetime - the number of seconds that the credential element should remain valid for initiating of security contexts. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime for this. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime for this.
        acceptLifetime - the number of seconds that the credential element should remain valid for accepting security contexts. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime for this. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime for this.
        mech - the mechanism over which the credential is to be acquired.
        usage - the usage mode that this credential element should add to the credential. The value of this parameter must be one of: INITIATE_AND_ACCEPT, ACCEPT_ONLY, and INITIATE_ONLY.
        Throws:
        GSSException - containing the following major error codes: GSSException.DUPLICATE_ELEMENT, GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.FAILURE

      • equals

        boolean equals(Object another)
        Tests if this GSSCredential asserts the same entity as the supplied object. The two credentials must be acquired over the same mechanisms and must refer to the same principal.
        Overrides:
        equals in class Object
        Parameters:
        another - another GSSCredential for comparison to this one
        Returns:
        true if the two GSSCredentials assert the same entity; false otherwise.
        See Also:
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns a hashcode value for this GSSCredential.
        Overrides:
        hashCode in class Object
        Returns:
        a hashCode value
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


GSSException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Class GSSException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.ietf.jgss.GSSException
  • All Implemented Interfaces:
    Serializable

    public class GSSException
extends Exception
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error. It may contain both the major and the minor GSS-API status codes. Major error codes are those defined at the GSS-API level in this class. Minor error codes are mechanism specific error codes that can provide additional information. The underlying mechanism implementation is responsible for setting appropriate minor status codes when throwing this exception. Aside from delivering the numeric error codes to the caller, this class performs the mapping from their numeric values to textual representations.

    Since:
    1.4
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int BAD_BINDINGS
      Channel bindings mismatch.
      static int BAD_MECH
      Unsupported mechanism requested.
      static int BAD_MIC
      Token had invalid integrity check.
      static int BAD_NAME
      Invalid name provided.
      static int BAD_NAMETYPE
      Name of unsupported type provided.
      static int BAD_QOP
      Unsupported QOP value.
      static int BAD_STATUS
      Invalid status code.
      static int CONTEXT_EXPIRED
      Security context expired.
      static int CREDENTIALS_EXPIRED
      Expired credentials.
      static int DEFECTIVE_CREDENTIAL
      Defective credentials.
      static int DEFECTIVE_TOKEN
      Defective token.
      static int DUPLICATE_ELEMENT
      Duplicate credential element requested.
      static int DUPLICATE_TOKEN
      The token was a duplicate of an earlier token.
      static int FAILURE
      General failure, unspecified at GSS-API level.
      static int GAP_TOKEN
      An expected per-message token was not received.
      static int NAME_NOT_MN
      Name contains multi-mechanism elements.
      static int NO_CONTEXT
      Invalid security context.
      static int NO_CRED
      Invalid credentials.
      static int OLD_TOKEN
      The token's validity period has expired.
      static int UNAUTHORIZED
      Operation unauthorized.
      static int UNAVAILABLE
      Operation unavailable.
      static int UNSEQ_TOKEN
      A later token has already been processed.

    • Constructor Summary

      Constructors
      Constructor and Description
      GSSException(int majorCode)
      Creates a GSSException object with a specified major code.
      GSSException(int majorCode, int minorCode, String minorString)
      Creates a GSSException object with the specified major code, minor code, and minor code textual explanation.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getMajor()
      Returns the GSS-API level major error code for the problem causing this exception to be thrown.
      String getMajorString()
      Returns a string explaining the GSS-API level major error code in this exception.
      String getMessage()
      Returns a textual representation of both the major and the minor status codes.
      int getMinor()
      Returns the mechanism level error code for the problem causing this exception to be thrown.
      String getMinorString()
      Returns a string explaining the mechanism specific error code.
      void setMinor(int minorCode, String message)
      Used by the exception thrower to set the mechanism level minor error code and its string explanation.
      String toString()
      Returns a textual representation of both the major and the minor status codes.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • BAD_BINDINGS

        public static final int BAD_BINDINGS
        Channel bindings mismatch.
        See Also:
        Constant Field Values

      • BAD_MECH

        public static final int BAD_MECH
        Unsupported mechanism requested.
        See Also:
        Constant Field Values

      • BAD_NAME

        public static final int BAD_NAME
        Invalid name provided.
        See Also:
        Constant Field Values

      • BAD_NAMETYPE

        public static final int BAD_NAMETYPE
        Name of unsupported type provided.
        See Also:
        Constant Field Values

      • BAD_STATUS

        public static final int BAD_STATUS
        Invalid status code.
        See Also:
        Constant Field Values

      • BAD_MIC

        public static final int BAD_MIC
        Token had invalid integrity check.
        See Also:
        Constant Field Values

      • CONTEXT_EXPIRED

        public static final int CONTEXT_EXPIRED
        Security context expired.
        See Also:
        Constant Field Values

      • CREDENTIALS_EXPIRED

        public static final int CREDENTIALS_EXPIRED
        Expired credentials.
        See Also:
        Constant Field Values

      • DEFECTIVE_CREDENTIAL

        public static final int DEFECTIVE_CREDENTIAL
        Defective credentials.
        See Also:
        Constant Field Values

      • DEFECTIVE_TOKEN

        public static final int DEFECTIVE_TOKEN
        Defective token.
        See Also:
        Constant Field Values

      • FAILURE

        public static final int FAILURE
        General failure, unspecified at GSS-API level.
        See Also:
        Constant Field Values

      • NO_CONTEXT

        public static final int NO_CONTEXT
        Invalid security context.
        See Also:
        Constant Field Values

      • NO_CRED

        public static final int NO_CRED
        Invalid credentials.
        See Also:
        Constant Field Values

      • BAD_QOP

        public static final int BAD_QOP
        Unsupported QOP value.
        See Also:
        Constant Field Values

      • UNAUTHORIZED

        public static final int UNAUTHORIZED
        Operation unauthorized.
        See Also:
        Constant Field Values

      • UNAVAILABLE

        public static final int UNAVAILABLE
        Operation unavailable.
        See Also:
        Constant Field Values

      • DUPLICATE_ELEMENT

        public static final int DUPLICATE_ELEMENT
        Duplicate credential element requested.
        See Also:
        Constant Field Values

      • NAME_NOT_MN

        public static final int NAME_NOT_MN
        Name contains multi-mechanism elements.
        See Also:
        Constant Field Values

      • DUPLICATE_TOKEN

        public static final int DUPLICATE_TOKEN
        The token was a duplicate of an earlier token. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        See Also:
        Constant Field Values

      • OLD_TOKEN

        public static final int OLD_TOKEN
        The token's validity period has expired. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        See Also:
        Constant Field Values

      • UNSEQ_TOKEN

        public static final int UNSEQ_TOKEN
        A later token has already been processed. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        See Also:
        Constant Field Values

      • GAP_TOKEN

        public static final int GAP_TOKEN
        An expected per-message token was not received. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        See Also:
        Constant Field Values

    • Constructor Detail

      • GSSException

        public GSSException(int majorCode)
        Creates a GSSException object with a specified major code.
        Parameters:
        majorCode - the The GSS error code for the problem causing this exception to be thrown.

      • GSSException

        public GSSException(int majorCode,
                    int minorCode,
                    String minorString)
        Creates a GSSException object with the specified major code, minor code, and minor code textual explanation. This constructor is to be used when the exception is originating from the underlying mechanism level. It allows the setting of both the GSS code and the mechanism code.
        Parameters:
        majorCode - the GSS error code for the problem causing this exception to be thrown.
        minorCode - the mechanism level error code for the problem causing this exception to be thrown.
        minorString - the textual explanation of the mechanism error code.

    • Method Detail

      • getMajor

        public int getMajor()
        Returns the GSS-API level major error code for the problem causing this exception to be thrown. Major error codes are defined at the mechanism independent GSS-API level in this class. Mechanism specific error codes that might provide more information are set as the minor error code.
        Returns:
        int the GSS-API level major error code causing this exception
        See Also:
        getMajorString(),
getMinor(),
getMinorString()

      • getMinor

        public int getMinor()
        Returns the mechanism level error code for the problem causing this exception to be thrown. The minor code is set by the underlying mechanism.
        Returns:
        int the mechanism error code; 0 indicates that it has not been set.
        See Also:
        getMinorString(), setMinor(int, java.lang.String)

      • getMajorString

        public String getMajorString()
        Returns a string explaining the GSS-API level major error code in this exception.
        Returns:
        String explanation string for the major error code
        See Also:
        getMajor(), toString()

      • getMinorString

        public String getMinorString()
        Returns a string explaining the mechanism specific error code. If the minor status code is 0, then no mechanism level error details will be available.
        Returns:
        String a textual explanation of mechanism error code
        See Also:
        getMinor(),
getMajorString(),
toString()

      • setMinor

        public void setMinor(int minorCode,
                     String message)
        Used by the exception thrower to set the mechanism level minor error code and its string explanation. This is used by mechanism providers to indicate error details.
        Parameters:
        minorCode - the mechanism specific error code
        message - textual explanation of the mechanism error code
        See Also:
        getMinor()

      • toString

        public String toString()
        Returns a textual representation of both the major and the minor status codes.
        Overrides:
        toString in class Throwable
        Returns:
        a String with the error descriptions

      • getMessage

        public String getMessage()
        Returns a textual representation of both the major and the minor status codes.
        Overrides:
        getMessage in class Throwable
        Returns:
        a String with the error descriptions
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


GSSManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Class GSSManager

  • java.lang.Object
    • org.ietf.jgss.GSSManager

  • public abstract class GSSManager
extends Object
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported. It can create instances of classes implementing the following three GSS-API interfaces: GSSName, GSSCredential, and GSSContext. It also has methods to query for the list of available mechanisms and the nametypes that each mechanism supports.

    An instance of the default GSSManager subclass may be obtained through the static method getInstance, but applications are free to instantiate other subclasses of GSSManager. The default GSSManager instance will support the Kerberos v5 GSS-API mechanism in addition to any others. This mechanism is identified by the Oid "1.2.840.113554.1.2.2" and is defined in RFC 1964.

    A subclass extending the GSSManager abstract class may be implemented as a modular provider based layer that utilizes some well known service provider specification. The GSSManager API allows the application to set provider preferences on such an implementation. These methods also allow the implementation to throw a well-defined exception in case provider based configuration is not supported. Applications that expect to be portable should be aware of this and recover cleanly by catching the exception.

    It is envisioned that there will be three most common ways in which providers will be used:

    1. The application does not care about what provider is used (the default case).
    2. The application wants a particular provider to be used preferentially, either for a particular mechanism or all the time, irrespective of mechanism.
    3. The application wants to use the locally configured providers as far as possible but if support is missing for one or more mechanisms then it wants to fall back on its own provider.

    The GSSManager class has two methods that enable these modes of usage: addProviderAtFront and addProviderAtEnd. These methods have the effect of creating an ordered list of <provider, oid> pairs where each pair indicates a preference of provider for a given oid.

    It is important to note that there are certain interactions between the different GSS-API objects that are created by a GSSManager, where the provider that is used for a particular mechanism might need to be consistent across all objects. For instance, if a GSSCredential contains elements from a provider p for a mechanism m, it should generally be passed in to a GSSContext that will use provider p for the mechanism m. A simple rule of thumb that will maximize portability is that objects created from different GSSManager's should not be mixed, and if possible, a different GSSManager instance should be created if the application wants to invoke the addProviderAtFront method on a GSSManager that has already created an object.

    Here is some sample code showing how the GSSManager might be used:

         GSSManager manager = GSSManager.getInstance();

     Oid krb5Mechanism = new Oid("1.2.840.113554.1.2.2");
     Oid krb5PrincipalNameType = new Oid("1.2.840.113554.1.2.2.1");

     // Identify who the client wishes to be
     GSSName userName = manager.createName("duke", GSSName.NT_USER_NAME);

     // Identify the name of the server. This uses a Kerberos specific
     // name format.
     GSSName serverName = manager.createName("nfs/foo.sun.com",
                                             krb5PrincipalNameType);

     // Acquire credentials for the user
     GSSCredential userCreds = manager.createCredential(userName,
                                             GSSCredential.DEFAULT_LIFETIME,
                                             krb5Mechanism,
                                             GSSCredential.INITIATE_ONLY);

     // Instantiate and initialize a security context that will be
     // established with the server
     GSSContext context = manager.createContext(serverName,
                                                krb5Mechanism,
                                                userCreds,
                                                GSSContext.DEFAULT_LIFETIME);

    The server side might use the following variation of this source:

         // Acquire credentials for the server
     GSSCredential serverCreds = manager.createCredential(serverName,
                                             GSSCredential.DEFAULT_LIFETIME,
                                             krb5Mechanism,
                                             GSSCredential.ACCEPT_ONLY);

     // Instantiate and initialize a security context that will
     // wait for an establishment request token from the client
     GSSContext context = manager.createContext(serverCreds);
    Since:
    1.4
    See Also:
    GSSName, GSSCredential, GSSContext

    • Constructor Summary

      Constructors
      Constructor and Description
      GSSManager()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract void addProviderAtEnd(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
      abstract void addProviderAtFront(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
      abstract GSSContext createContext(byte[] interProcessToken)
      Factory method for creating a previously exported context.
      abstract GSSContext createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSCredential createCredential(int usage)
      Factory method for acquiring default credentials.
      abstract GSSName createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      static GSSManager getInstance()
      Returns the default GSSManager implementation.
      abstract Oid[] getMechs()
      Returns a list of mechanisms that are available to GSS-API callers through this GSSManager.
      abstract Oid[] getMechsForName(Oid nameType)
      Returns a list of mechanisms that support the indicated name type.
      abstract Oid[] getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • GSSManager

        public GSSManager()

    • Method Detail

      • getInstance

        public static GSSManager getInstance()
        Returns the default GSSManager implementation.
        Returns:
        a GSSManager implementation

      • getMechs

        public abstract Oid[] getMechs()
        Returns a list of mechanisms that are available to GSS-API callers through this GSSManager. The default GSSManager obtained from the getInstance() method includes the Oid "1.2.840.113554.1.2.2" in its list. This Oid identifies the Kerberos v5 GSS-API mechanism that is defined in RFC 1964.
        Returns:
        an array of Oid objects corresponding to the mechanisms that are available. A null value is returned when no mechanism are available (an example of this would be when mechanism are dynamically configured, and currently no mechanisms are installed).

      • getNamesForMech

        public abstract Oid[] getNamesForMech(Oid mech)
                               throws GSSException
        Returns then name types supported by the indicated mechanism.

        The default GSSManager instance includes support for the Kerberos v5 mechanism. When this mechanism ("1.2.840.113554.1.2.2") is indicated, the returned list will contain at least the following nametypes: GSSName.NT_HOSTBASED_SERVICE, GSSName.NT_EXPORT_NAME, and the Kerberos v5 specific Oid "1.2.840.113554.1.2.2.1". The namespace for the Oid "1.2.840.113554.1.2.2.1" is defined in RFC 1964.

        Parameters:
        mech - the Oid of the mechanism to query
        Returns:
        an array of Oid objects corresponding to the name types that the mechanism supports.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH GSSException.FAILURE
        See Also:
        getMechsForName(Oid)

      • getMechsForName

        public abstract Oid[] getMechsForName(Oid nameType)
        Returns a list of mechanisms that support the indicated name type.

        The Kerberos v5 mechanism ("1.2.840.113554.1.2.2") will always be returned in this list when the indicated nametype is one of GSSName.NT_HOSTBASED_SERVICE, GSSName.NT_EXPORT_NAME, or "1.2.840.113554.1.2.2.1".

        Parameters:
        nameType - the Oid of the name type to look for
        Returns:
        an array of Oid objects corresponding to the mechanisms that support the specified name type. null is returned when no mechanisms are found to support the specified name type.
        See Also:
        getNamesForMech(Oid)

      • createName

        public abstract GSSName createName(String nameStr,
                                   Oid nameType)
                            throws GSSException
        Factory method to convert a string name from the specified namespace to a GSSName object. In general, the GSSName object created will contain multiple representations of the name, one for each mechanism that is supported; two examples that are exceptions to this are when the namespace type parameter indicates NT_EXPORT_NAME or when the GSS-API implementation is not multi-mechanism. It is not recommended to use this method with a NT_EXPORT_NAME type because representing a previously exported name consisting of arbitrary bytes as a String might cause problems with character encoding schemes. In such cases it is recommended that the bytes be passed in directly to the overloaded form of this method createName.
        Parameters:
        nameStr - the string representing a printable form of the name to create.
        nameType - the Oid specifying the namespace of the printable name supplied. null can be used to specify that a mechanism specific default printable syntax should be assumed by each mechanism that examines nameStr. It is not advisable to use the nametype NT_EXPORT_NAME with this method.
        Returns:
        a GSSName representing the indicated principal
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        See Also:
        GSSName, GSSName.NT_EXPORT_NAME

      • createName

        public abstract GSSName createName(byte[] name,
                                   Oid nameType)
                            throws GSSException
        Factory method to convert a byte array containing a name from the specified namespace to a GSSName object. In general, the GSSName object created will contain multiple representations of the name, one for each mechanism that is supported; two examples that are exceptions to this are when the namespace type parameter indicates NT_EXPORT_NAME or when the GSS-API implementation is not multi-mechanism. The bytes that are passed in are interpreted by each underlying mechanism according to some encoding scheme of its choice for the given nametype.
        Parameters:
        name - the byte array containing the name to create
        nameType - the Oid specifying the namespace of the name supplied in the byte array. null can be used to specify that a mechanism specific default syntax should be assumed by each mechanism that examines the byte array.
        Returns:
        a GSSName representing the indicated principal
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        See Also:
        GSSName, GSSName.NT_EXPORT_NAME

      • createName

        public abstract GSSName createName(String nameStr,
                                   Oid nameType,
                                   Oid mech)
                            throws GSSException
        Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism. In other words, this method is a utility that does the equivalent of two steps: the createName and then also the GSSName.canonicalize.
        Parameters:
        nameStr - the string representing a printable form of the name to create.
        nameType - the Oid specifying the namespace of the printable name supplied. null can be used to specify that a mechanism specific default printable syntax should be assumed by each mechanism that examines nameStr. It is not advisable to use the nametype NT_EXPORT_NAME with this method.
        mech - Oid specifying the mechanism for which the name should be canonicalized
        Returns:
        a GSSName representing the indicated principal
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        See Also:
        GSSName.canonicalize(Oid), GSSName.NT_EXPORT_NAME

      • createName

        public abstract GSSName createName(byte[] name,
                                   Oid nameType,
                                   Oid mech)
                            throws GSSException
        Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism. In other words, this method is a utility that does the equivalent of two steps: the createName and then also GSSName.canonicalize.
        Parameters:
        name - the byte array containing the name to create
        nameType - the Oid specifying the namespace of the name supplied in the byte array. null can be used to specify that a mechanism specific default syntax should be assumed by each mechanism that examines the byte array.
        mech - Oid specifying the mechanism for which the name should be canonicalized
        Returns:
        a GSSName representing the indicated principal
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        See Also:
        GSSName.canonicalize(Oid), GSSName.NT_EXPORT_NAME

      • createCredential

        public abstract GSSCredential createCredential(int usage)
                                        throws GSSException
        Factory method for acquiring default credentials. This will cause the GSS-API to use system specific defaults for the set of mechanisms, name, and lifetime.

        GSS-API mechanism providers must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. The kinds of permissions needed by different mechanism providers will be documented on a per-mechanism basis. A failed permission check might cause a SecurityException to be thrown from this method.

        Parameters:
        usage - The intended usage for this credential object. The value of this parameter must be one of: GSSCredential.INITIATE_AND_ACCEPT, GSSCredential.ACCEPT_ONLY, and GSSCredential.INITIATE_ONLY.
        Returns:
        a GSSCredential of the requested type.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.CREDENTIALS_EXPIRED, GSSException.NO_CRED, GSSException.FAILURE
        See Also:
        GSSCredential

      • createCredential

        public abstract GSSCredential createCredential(GSSName name,
                                               int lifetime,
                                               Oid mech,
                                               int usage)
                                        throws GSSException
        Factory method for acquiring a single mechanism credential.

        GSS-API mechanism providers must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. The kinds of permissions needed by different mechanism providers will be documented on a per-mechanism basis. A failed permission check might cause a SecurityException to be thrown from this method.

        Non-default values for lifetime cannot always be honored by the underlying mechanisms, thus applications should be prepared to call getRemainingLifetime on the returned credential.

        Parameters:
        name - the name of the principal for whom this credential is to be acquired. Use null to specify the default principal.
        lifetime - The number of seconds that credentials should remain valid. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime.
        mech - the Oid of the desired mechanism. Use (Oid) null to request the default mechanism.
        usage - The intended usage for this credential object. The value of this parameter must be one of: GSSCredential.INITIATE_AND_ACCEPT, GSSCredential.ACCEPT_ONLY, and GSSCredential.INITIATE_ONLY.
        Returns:
        a GSSCredential of the requested type.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.CREDENTIALS_EXPIRED, GSSException.NO_CRED, GSSException.FAILURE
        See Also:
        GSSCredential

      • createCredential

        public abstract GSSCredential createCredential(GSSName name,
                                               int lifetime,
                                               Oid[] mechs,
                                               int usage)
                                        throws GSSException
        Factory method for acquiring credentials over a set of mechanisms. This method attempts to acquire credentials for each of the mechanisms specified in the array called mechs. To determine the list of mechanisms for which the acquisition of credentials succeeded, the caller should use the GSSCredential.getMechs method.

        GSS-API mechanism providers must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. The kinds of permissions needed by different mechanism providers will be documented on a per-mechanism basis. A failed permission check might cause a SecurityException to be thrown from this method.

        Non-default values for lifetime cannot always be honored by the underlying mechanisms, thus applications should be prepared to call getRemainingLifetime on the returned credential.

        Parameters:
        name - the name of the principal for whom this credential is to be acquired. Use null to specify the default principal.
        lifetime - The number of seconds that credentials should remain valid. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime.
        mechs - an array of Oid's indicating the mechanisms over which the credential is to be acquired. Use (Oid[]) null for requesting a system specific default set of mechanisms.
        usage - The intended usage for this credential object. The value of this parameter must be one of: GSSCredential.INITIATE_AND_ACCEPT, GSSCredential.ACCEPT_ONLY, and GSSCredential.INITIATE_ONLY.
        Returns:
        a GSSCredential of the requested type.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.CREDENTIALS_EXPIRED, GSSException.NO_CRED, GSSException.FAILURE
        See Also:
        GSSCredential

      • createContext

        public abstract GSSContext createContext(GSSName peer,
                                         Oid mech,
                                         GSSCredential myCred,
                                         int lifetime)
                                  throws GSSException
        Factory method for creating a context on the initiator's side. Some mechanism providers might require that the caller be granted permission to initiate a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        Non-default values for lifetime cannot always be honored by the underlying mechanism, thus applications should be prepared to call getLifetime on the returned context.

        Parameters:
        peer - the name of the target peer.
        mech - the Oid of the desired mechanism. Use null to request the default mechanism.
        myCred - the credentials of the initiator. Use null to act as the default initiator principal.
        lifetime - the lifetime, in seconds, requested for the context. Use GSSContext.INDEFINITE_LIFETIME to request that the context have the maximum permitted lifetime. Use GSSContext.DEFAULT_LIFETIME to request a default lifetime for the context.
        Returns:
        an unestablished GSSContext
        Throws:
        GSSException - containing the following major error codes: GSSException.NO_CRED GSSException.CREDENTIALS_EXPIRED GSSException.BAD_NAMETYPE GSSException.BAD_MECH GSSException.FAILURE
        See Also:
        GSSContext

      • createContext

        public abstract GSSContext createContext(GSSCredential myCred)
                                  throws GSSException
        Factory method for creating a context on the acceptor' side. The context's properties will be determined from the input token supplied to the accept method. Some mechanism providers might require that the caller be granted permission to accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.
        Parameters:
        myCred - the credentials for the acceptor. Use null to act as a default acceptor principal.
        Returns:
        an unestablished GSSContext
        Throws:
        GSSException - containing the following major error codes: GSSException.NO_CRED GSSException.CREDENTIALS_EXPIRED GSSException.BAD_MECH GSSException.FAILURE
        See Also:
        GSSContext

      • createContext

        public abstract GSSContext createContext(byte[] interProcessToken)
                                  throws GSSException
        Factory method for creating a previously exported context. The context properties will be determined from the input token and cannot be modified through the set methods.

        Implementations are not required to support the inter-process transfer of security contexts. Before exporting a context, calling the GSSContext.isTransferable will indicate if the context is transferable. Calling this method in an implementation that does not support it will result in a GSSException with the error code GSSException.UNAVAILABLE. Some mechanism providers might require that the caller be granted permission to initiate or accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        Parameters:
        interProcessToken - the token previously emitted from the export method.
        Returns:
        the previously established GSSContext
        Throws:
        GSSException - containing the following major error codes: GSSException.NO_CONTEXT, GSSException.DEFECTIVE_TOKEN, GSSException.UNAVAILABLE, GSSException.UNAUTHORIZED, GSSException.FAILURE
        See Also:
        GSSContext

      • addProviderAtFront

        public abstract void addProviderAtFront(Provider p,
                                        Oid mech)
                                 throws GSSException
        This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism. When a value of null is used instead of an Oid for the mechanism, the GSSManager must use the indicated provider ahead of all others no matter what the mechanism is. Only when the indicated provider does not support the needed mechanism should the GSSManager move on to a different provider.

        Calling this method repeatedly preserves the older settings but lowers them in preference thus forming an ordered list of provider and Oid pairs that grows at the top.

        Calling addProviderAtFront with a null Oid will remove all previous preferences that were set for this provider in the GSSManager instance. Calling addProviderAtFront with a non-null Oid will remove any previous preference that was set using this mechanism and this provider together.

        If the GSSManager implementation does not support an SPI with a pluggable provider architecture it should throw a GSSException with the status code GSSException.UNAVAILABLE to indicate that the operation is unavailable.

        Suppose an application desired that the provider A always be checked first when any mechanism is needed, it would call:

                 GSSManager mgr = GSSManager.getInstance();
         // mgr may at this point have its own pre-configured list
         // of provider preferences. The following will prepend to
         // any such list:

         mgr.addProviderAtFront(A, null);
        Now if it also desired that the mechanism of Oid m1 always be obtained from the provider B before the previously set A was checked, it would call:

                 mgr.addProviderAtFront(B, m1);
        The GSSManager would then first check with B if m1 was needed. In case B did not provide support for m1, the GSSManager would continue on to check with A. If any mechanism m2 is needed where m2 is different from m1 then the GSSManager would skip B and check with A directly.

        Suppose at a later time the following call is made to the same GSSManager instance:

                 mgr.addProviderAtFront(B, null)
        then the previous setting with the pair (B, m1) is subsumed by this and should be removed. Effectively the list of preferences now becomes {(B, null), (A, null), ... //followed by the pre-configured list.

        Please note, however, that the following call:

                 mgr.addProviderAtFront(A, m3)
        does not subsume the previous setting of (A, null) and the list will effectively become {(A, m3), (B, null), (A, null), ...}
        Parameters:
        p - the provider instance that should be used whenever support is needed for mech.
        mech - the mechanism for which the provider is being set
        Throws:
        GSSException - containing the following major error codes: GSSException.UNAVAILABLE, GSSException.FAILURE

      • addProviderAtEnd

        public abstract void addProviderAtEnd(Provider p,
                                      Oid mech)
                               throws GSSException
        This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism. When a value of null is used instead of an Oid for the mechanism, the GSSManager must use the indicated provider for any mechanism.

        Calling this method repeatedly preserves the older settings but raises them above newer ones in preference thus forming an ordered list of providers and Oid pairs that grows at the bottom. Thus the older provider settings will be utilized first before this one is.

        If there are any previously existing preferences that conflict with the preference being set here, then the GSSManager should ignore this request.

        If the GSSManager implementation does not support an SPI with a pluggable provider architecture it should throw a GSSException with the status code GSSException.UNAVAILABLE to indicate that the operation is unavailable.

        Suppose an application desired that when a mechanism of Oid m1 is needed the system default providers always be checked first, and only when they do not support m1 should a provider A be checked. It would then make the call:

                 GSSManager mgr = GSSManager.getInstance();
         mgr.addProviderAtEnd(A, m1);
        Now, if it also desired that for all mechanisms the provider B be checked after all configured providers have been checked, it would then call:

                 mgr.addProviderAtEnd(B, null);
        Effectively the list of preferences now becomes {..., (A, m1), (B, null)}.

        Suppose at a later time the following call is made to the same GSSManager instance:

                 mgr.addProviderAtEnd(B, m2)
        then the previous setting with the pair (B, null) subsumes this and therefore this request should be ignored. The same would happen if a request is made for the already existing pairs of (A, m1) or (B, null).

        Please note, however, that the following call:

                 mgr.addProviderAtEnd(A, null)
        is not subsumed by the previous setting of (A, m1) and the list will effectively become {..., (A, m1), (B, null), (A, null)}
        Parameters:
        p - the provider instance that should be used whenever support is needed for mech.
        mech - the mechanism for which the provider is being set
        Throws:
        GSSException - containing the following major error codes: GSSException.UNAVAILABLE, GSSException.FAILURE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


GSSName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Interface GSSName

  • public interface GSSName
    This interface encapsulates a single GSS-API principal entity. The application obtains an implementation of this interface through one of the createName methods that exist in the GSSManager class. Conceptually a GSSName contains many representations of the entity or many primitive name elements, one for each supported underlying mechanism. In GSS terminology, a GSSName that contains an element from just one mechanism is called a Mechanism Name (MN)

    Since different authentication mechanisms may employ different namespaces for identifying their principals, GSS-API's naming support is necessarily complex in multi-mechanism environments (or even in some single-mechanism environments where the underlying mechanism supports multiple namespaces). Different name formats and their definitions are identified with Oid's and some standard types are defined in this interface. The format of the names can be derived based on the unique Oid of its name type.

    Included below are code examples utilizing the GSSName interface. The code below creates a GSSName, converts it to an MN, performs a comparison, obtains a printable representation of the name, exports it to a byte array and then re-imports to obtain a new GSSName.

          GSSManager manager = GSSManager.getInstance();

      // create a host based service name
      GSSName name = manager.createName("service@host",
                   GSSName.NT_HOSTBASED_SERVICE);

      Oid krb5 = new Oid("1.2.840.113554.1.2.2");

      GSSName mechName = name.canonicalize(krb5);

      // the above two steps are equivalent to the following
      GSSName mechName = manager.createName("service@host",
                      GSSName.NT_HOSTBASED_SERVICE, krb5);

      // perform name comparison
      if (name.equals(mechName))
              print("Names are equals.");

      // obtain textual representation of name and its printable
      // name type
      print(mechName.toString() +
                      mechName.getStringNameType().toString());

      // export and re-import the name
      byte [] exportName = mechName.export();

      // create a new name object from the exported buffer
      GSSName newName = manager.createName(exportName,
                      GSSName.NT_EXPORT_NAME);
    Since:
    1.4
    See Also:
    export(),
equals(GSSName),
GSSManager.createName(String, Oid),
GSSManager.createName(String, Oid, Oid),
GSSManager.createName(byte[], Oid)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static Oid NT_ANONYMOUS
      Name type for representing an anonymous entity.
      static Oid NT_EXPORT_NAME
      Name type used to indicate an exported name produced by the export method.
      static Oid NT_HOSTBASED_SERVICE
      Oid indicating a host-based service name form.
      static Oid NT_MACHINE_UID_NAME
      Name type to indicate a numeric user identifier corresponding to a user on a local system.
      static Oid NT_STRING_UID_NAME
      Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.
      static Oid NT_USER_NAME
      Name type to indicate a named user on a local system.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      GSSName canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      boolean equals(GSSName another)
      Compares two GSSName objects to determine if they refer to the same entity.
      boolean equals(Object another)
      Compares this GSSName object to another Object that might be a GSSName.
      byte[] export()
      Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions.
      Oid getStringNameType()
      Returns the name type of the printable representation of this name that can be obtained from the toString method.
      int hashCode()
      Returns a hashcode value for this GSSName.
      boolean isAnonymous()
      Tests if this name object represents an anonymous entity.
      boolean isMN()
      Tests if this name object represents a Mechanism Name (MN).
      String toString()
      Returns a textual representation of the GSSName object.

    • Field Detail

      • NT_HOSTBASED_SERVICE

        static final Oid NT_HOSTBASED_SERVICE
        Oid indicating a host-based service name form. It is used to represent services associated with host computers. This name form is constructed using two elements, "service" and "hostname", as follows: service@hostname.

         It represents the following Oid value:
{ iso(1) member-body(2) United
 States(840) mit(113554) infosys(1) gssapi(2) generic(1) service_name(4)
 }

      • NT_USER_NAME

        static final Oid NT_USER_NAME
        Name type to indicate a named user on a local system.

         It represents the following Oid value:
{ iso(1) member-body(2) United
 States(840) mit(113554) infosys(1) gssapi(2) generic(1) user_name(1)
 }

      • NT_MACHINE_UID_NAME

        static final Oid NT_MACHINE_UID_NAME
        Name type to indicate a numeric user identifier corresponding to a user on a local system. (e.g. Uid).

        It represents the following Oid value:
        { iso(1) member-body(2) United States(840) mit(113554) infosys(1) gssapi(2) generic(1) machine_uid_name(2) }

      • NT_STRING_UID_NAME

        static final Oid NT_STRING_UID_NAME
        Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.

         It represents the following Oid value:
{ iso(1) member-body(2) United
 States(840) mit(113554) infosys(1) gssapi(2) generic(1)
 string_uid_name(3) }

      • NT_ANONYMOUS

        static final Oid NT_ANONYMOUS
        Name type for representing an anonymous entity.

        It represents the following Oid value:
        { 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 3(gss-anonymous-name) }

      • NT_EXPORT_NAME

        static final Oid NT_EXPORT_NAME
        Name type used to indicate an exported name produced by the export method.

        It represents the following Oid value:
        { 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 4(gss-api-exported-name) }

    • Method Detail

      • equals

        boolean equals(GSSName another)
        throws GSSException
        Compares two GSSName objects to determine if they refer to the same entity.
        Parameters:
        another - the GSSName to compare this name with
        Returns:
        true if the two names contain at least one primitive element in common. If either of the names represents an anonymous entity, the method will return false.
        Throws:
        GSSException - when the names cannot be compared, containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.FAILURE

      • equals

        boolean equals(Object another)
        Compares this GSSName object to another Object that might be a GSSName. The behaviour is exactly the same as in equals except that no GSSException is thrown; instead, false will be returned in the situation where an error occurs.
        Overrides:
        equals in class Object
        Parameters:
        another - the object to compare this name to
        Returns:
        true if the object to compare to is also a GSSName and the two names refer to the same entity.
        See Also:
        equals(GSSName)

      • hashCode

        int hashCode()
        Returns a hashcode value for this GSSName.
        Overrides:
        hashCode in class Object
        Returns:
        a hashCode value
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • canonicalize

        GSSName canonicalize(Oid mech)
              throws GSSException
        Creates a name that is canonicalized for some mechanism.
        Parameters:
        mech - the oid for the mechanism for which the canonical form of the name is requested.
        Returns:
        a GSSName that contains just one primitive element representing this name in a canonicalized form for the desired mechanism.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.FAILURE

      • export

        byte[] export()
       throws GSSException
        Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions. If the name is not an MN, implementations may throw a GSSException with the NAME_NOT_MN status code. If an implementation chooses not to throw an exception, it should use some system specific default mechanism to canonicalize the name and then export it. Structurally, an exported name object consists of a header containing an OID identifying the mechanism that authenticated the name, and a trailer containing the name itself, where the syntax of the trailer is defined by the individual mechanism specification. The format of the header of the output buffer is specified in RFC 2743.

        The exported name is useful when used in large access control lists where the overhead of creating a GSSName object on each name and invoking the equals method on each name from the ACL may be prohibitive.

        Exported names may be re-imported by using the byte array factory method GSSManager.createName and specifying the NT_EXPORT_NAME as the name type object identifier. The resulting GSSName name will also be a MN.

        Returns:
        a byte[] containing the exported name. RFC 2743 defines the "Mechanism-Independent Exported Name Object Format" for these bytes.
        Throws:
        GSSException - containing the following major error codes: GSSException.BAD_NAME, GSSException.BAD_NAMETYPE, GSSException.FAILURE

      • toString

        String toString()
        Returns a textual representation of the GSSName object. To retrieve the printed name format, which determines the syntax of the returned string, use the getStringNameType method.
        Overrides:
        toString in class Object
        Returns:
        a String representing this name in printable form.

      • getStringNameType

        Oid getStringNameType()
               throws GSSException
        Returns the name type of the printable representation of this name that can be obtained from the toString method.
        Returns:
        an Oid representing the namespace of the name returned from the toString method.
        Throws:
        GSSException - containing the following major error codes: GSSException.FAILURE

      • isAnonymous

        boolean isAnonymous()
        Tests if this name object represents an anonymous entity.
        Returns:
        true if this is an anonymous name, false otherwise.

      • isMN

        boolean isMN()
        Tests if this name object represents a Mechanism Name (MN). An MN is a GSSName the contains exactly one mechanism's primitive name element.
        Returns:
        true if this is an MN, false otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MessageProp (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Class MessageProp

  • java.lang.Object
    • org.ietf.jgss.MessageProp

  • public class MessageProp
extends Object
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.

    When used with the GSSContext interface's wrap and getMIC methods, an instance of this class is used to indicate the desired Quality-of-Protection (QOP) and to request if confidentiality services are to be applied to caller supplied data (wrap only). To request default QOP, the value of 0 should be used for QOP.

    When used with the unwrap and verifyMIC methods of the GSSContext interface, an instance of this class will be used to indicate the applied QOP and confidentiality services over the supplied message. In the case of verifyMIC, the confidentiality state will always be false. Upon return from these methods, this object will also contain any supplementary status values applicable to the processed token. The supplementary status values can indicate old tokens, out of sequence tokens, gap tokens or duplicate tokens.

    Since:
    1.4
    See Also:
    GSSContext.wrap(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.unwrap(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.getMIC(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.verifyMIC(byte[], int, int, byte[], int, int, org.ietf.jgss.MessageProp)

    • Constructor Summary

      Constructors
      Constructor and Description
      MessageProp(boolean privState)
      Constructor which sets the desired privacy state.
      MessageProp(int qop, boolean privState)
      Constructor which sets the values for the qop and privacy state.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getMinorStatus()
      Retrieves the minor status code that the underlying mechanism might have set for this per-message operation.
      String getMinorString()
      Retrieves a string explaining the minor status code.
      boolean getPrivacy()
      Retrieves the privacy state.
      int getQOP()
      Retrieves the QOP value.
      boolean isDuplicateToken()
      Tests if this is a duplicate of an earlier token.
      boolean isGapToken()
      Tests if an expected token was not received, i.e., one or more predecessor tokens have not yet been successfully processed.
      boolean isOldToken()
      Tests if this token's validity period has expired, i.e., the token is too old to be checked for duplication.
      boolean isUnseqToken()
      Tests if a later token had already been processed.
      void setPrivacy(boolean privState)
      Sets the privacy state.
      void setQOP(int qop)
      Sets the QOP value.
      void setSupplementaryStates(boolean duplicate, boolean old, boolean unseq, boolean gap, int minorStatus, String minorString)
      This method sets the state for the supplementary information flags and the minor status in MessageProp.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MessageProp

        public MessageProp(boolean privState)
        Constructor which sets the desired privacy state. The QOP value used is 0.
        Parameters:
        privState - the privacy (i.e. confidentiality) state

      • MessageProp

        public MessageProp(int qop,
                   boolean privState)
        Constructor which sets the values for the qop and privacy state.
        Parameters:
        qop - the QOP value
        privState - the privacy (i.e. confidentiality) state

    • Method Detail

      • getQOP

        public int getQOP()
        Retrieves the QOP value.
        Returns:
        an int representing the QOP value
        See Also:
        setQOP(int)

      • getPrivacy

        public boolean getPrivacy()
        Retrieves the privacy state.
        Returns:
        true if the privacy (i.e., confidentiality) state is true, false otherwise.
        See Also:
        setPrivacy(boolean)

      • setQOP

        public void setQOP(int qop)
        Sets the QOP value.
        Parameters:
        qop - the int value to set the QOP to
        See Also:
        getQOP()

      • setPrivacy

        public void setPrivacy(boolean privState)
        Sets the privacy state.
        Parameters:
        privState - true is the privacy (i.e., confidentiality) state is true, false otherwise.
        See Also:
        getPrivacy()

      • isDuplicateToken

        public boolean isDuplicateToken()
        Tests if this is a duplicate of an earlier token.
        Returns:
        true if this is a duplicate, false otherwise.

      • isOldToken

        public boolean isOldToken()
        Tests if this token's validity period has expired, i.e., the token is too old to be checked for duplication.
        Returns:
        true if the token's validity period has expired, false otherwise.

      • isUnseqToken

        public boolean isUnseqToken()
        Tests if a later token had already been processed.
        Returns:
        true if a later token had already been processed, false otherwise.

      • isGapToken

        public boolean isGapToken()
        Tests if an expected token was not received, i.e., one or more predecessor tokens have not yet been successfully processed.
        Returns:
        true if an expected per-message token was not received, false otherwise.

      • getMinorStatus

        public int getMinorStatus()
        Retrieves the minor status code that the underlying mechanism might have set for this per-message operation.
        Returns:
        the int minor status

      • getMinorString

        public String getMinorString()
        Retrieves a string explaining the minor status code.
        Returns:
        a String corresponding to the minor status code. null will be returned when no minor status code has been set.

      • setSupplementaryStates

        public void setSupplementaryStates(boolean duplicate,
                                   boolean old,
                                   boolean unseq,
                                   boolean gap,
                                   int minorStatus,
                                   String minorString)
        This method sets the state for the supplementary information flags and the minor status in MessageProp. It is not used by the application but by the GSS implementation to return this information to the caller of a per-message context method.
        Parameters:
        duplicate - true if the token was a duplicate of an earlier token, false otherwise
        old - true if the token's validity period has expired, false otherwise
        unseq - true if a later token has already been processed, false otherwise
        gap - true if one or more predecessor tokens have not yet been successfully processed, false otherwise
        minorStatus - the int minor status code for the per-message operation
        minorString - the textual representation of the minorStatus value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Oid (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact3
org.ietf.jgss

Class Oid

  • java.lang.Object
    • org.ietf.jgss.Oid

  • public class Oid
extends Object
    This class represents Universal Object Identifiers (Oids) and their associated operations.

    Oids are hierarchically globally-interpretable identifiers used within the GSS-API framework to identify mechanisms and name formats.

    The structure and encoding of Oids is defined in ISOIEC-8824 and ISOIEC-8825. For example the Oid representation of Kerberos V5 mechanism is "1.2.840.113554.1.2.2"

    The GSSName name class contains public static Oid objects representing the standard name types defined in GSS-API.

    Since:
    1.4

    • Constructor Summary

      Constructors
      Constructor and Description
      Oid(byte[] data)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(InputStream derOid)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(String strOid)
      Constructs an Oid object from a string representation of its integer components.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean containedIn(Oid[] oids)
      A utility method to test if this Oid value is contained within the supplied Oid array.
      boolean equals(Object other)
      Tests if two Oid objects represent the same Object identifier value.
      byte[] getDER()
      Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.
      int hashCode()
      Returns a hashcode value for this Oid.
      String toString()
      Returns a string representation of the oid's integer components in dot separated notation.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Oid

        public Oid(String strOid)
    throws GSSException
        Constructs an Oid object from a string representation of its integer components.
        Parameters:
        strOid - the dot separated string representation of the oid. For instance, "1.2.840.113554.1.2.2".
        Throws:
        GSSException - may be thrown when the string is incorrectly formatted

      • Oid

        public Oid(InputStream derOid)
    throws GSSException
        Creates an Oid object from its ASN.1 DER encoding. This refers to the full encoding including tag and length. The structure and encoding of Oids is defined in ISOIEC-8824 and ISOIEC-8825. This method is identical in functionality to its byte array counterpart.
        Parameters:
        derOid - stream containing the DER encoded oid
        Throws:
        GSSException - may be thrown when the DER encoding does not follow the prescribed format.

      • Oid

        public Oid(byte[] data)
    throws GSSException
        Creates an Oid object from its ASN.1 DER encoding. This refers to the full encoding including tag and length. The structure and encoding of Oids is defined in ISOIEC-8824 and ISOIEC-8825. This method is identical in functionality to its InputStream conterpart.
        Parameters:
        data - byte array containing the DER encoded oid
        Throws:
        GSSException - may be thrown when the DER encoding does not follow the prescribed format.

    • Method Detail

      • toString

        public String toString()
        Returns a string representation of the oid's integer components in dot separated notation.
        Overrides:
        toString in class Object
        Returns:
        string representation in the following format: "1.2.3.4.5"

      • equals

        public boolean equals(Object other)
        Tests if two Oid objects represent the same Object identifier value.
        Overrides:
        equals in class Object
        Parameters:
        other - the Oid object that has to be compared to this one
        Returns:
        true if the two Oid objects represent the same value, false otherwise.
        See Also:
        Object.hashCode(), HashMap

      • getDER

        public byte[] getDER()
              throws GSSException
        Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.
        Returns:
        byte array containing the DER encoding of this oid object.
        Throws:
        GSSException - may be thrown when the oid can't be encoded

      • containedIn

        public boolean containedIn(Oid[] oids)
        A utility method to test if this Oid value is contained within the supplied Oid array.
        Parameters:
        oids - the array of Oid's to search
        Returns:
        true if the array contains this Oid value, false otherwise

      • hashCode

        public int hashCode()
        Returns a hashcode value for this Oid.
        Overrides:
        hashCode in class Object
        Returns:
        a hashCode value
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.ietf.jgss (Java Platform SE 8 )

org.ietf.jgss

Interfaces

  • GSSContext
  • GSSCredential
  • GSSName

Classes

  • ChannelBinding
  • GSSManager
  • MessageProp
  • Oid

Exceptions

  • GSSException


org.ietf.jgss (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.ietf.jgss

This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

See: Description

  • Interface Summary
    Interface Description
    GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context.
    GSSCredential
    This interface encapsulates the GSS-API credentials for an entity.
    GSSName
    This interface encapsulates a single GSS-API principal entity.
  • Class Summary
    Class Description
    ChannelBinding
    This class encapsulates the concept of caller-provided channel binding information.
    GSSManager
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.
    MessageProp
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.
    Oid
    This class represents Universal Object Identifiers (Oids) and their associated operations.
  • Exception Summary
    Exception Description
    GSSException
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.

Package org.ietf.jgss Description

This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API. The security mechanisms that an application can chose to use are identified with unique object identifiers. One example of such a mechanism is the Kerberos v5 GSS-API mechanism (object identifier 1.2.840.113554.1.2.2). This mechanism is available through the default instance of the GSSManager class.

The GSS-API is defined in a language independent way in RFC 2743. The Java language bindings are defined in RFC 2853

An application starts out by instantiating a GSSManager which then serves as a factory for a security context. An application can use specific principal names and credentials that are also created using the GSSManager; or it can instantiate a context with system defaults. It then goes through a context establishment loop. Once a context is established with the peer, authentication is complete. Data protection such as integrity and confidentiality can then be obtained from this context.

The GSS-API does not perform any communication with the peer. It merely produces tokens that the application must somehow transport to the other end.

Credential Acquisition

The GSS-API itself does not dictate how an underlying mechanism obtains the credentials that are needed for authentication. It is assumed that prior to calling the GSS-API, these credentials are obtained and stored in a location that the mechanism provider is aware of. However, the default model in the Java platform will be that mechanism providers must obtain credentials only from the private or public credential sets associated with the Subject in the current access control context. The Kerberos v5 mechanism will search for the required INITIATE and ACCEPT credentials (KerberosTicket and KerberosKey) in the private credential set where as some other mechanism might look in the public set or in both. If the desired credential is not present in the appropriate sets of the current Subject, the GSS-API call must fail.

This model has the advantage that credential management is simple and predictable from the applications point of view. An application, given the right permissions, can purge the credentials in the Subject or renew them using standard Java API's. If it purged the credentials, it would be sure that the JGSS mechanism would fail, or if it renewed a time based credential it would be sure that a JGSS mechanism would succeed.

This model does require that a JAAS login be performed in order to authenticate and populate a Subject that the JGSS mechanism can later utilize. However, applications have the ability to relax this restriction by means of a system property: javax.security.auth.useSubjectCredsOnly. By default this system property will be assumed to be true (even when it is unset) indicating that providers must only use the credentials that are present in the current Subject. However, if this property is explicitly set to false by the application, then it indicates that the provider is free to use any credentials cache of its choice. Such a credential cache might be a disk cache, an in-memory cache, or even just the current Subject itself.

Related Documentation

For an online tutorial on using Java GSS-API, please see Introduction to JAAS and Java GSS-API.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.ietf.jgss Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.ietf.jgss

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.ietf.jgss.ChannelBinding
    • org.ietf.jgss.GSSManager
    • org.ietf.jgss.MessageProp
    • org.ietf.jgss.Oid
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.ietf.jgss.GSSException

Interface Hierarchy

  • java.lang.Cloneable
    • org.ietf.jgss.GSSCredential
  • org.ietf.jgss.GSSContext
  • org.ietf.jgss.GSSName
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.ietf.jgss (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.ietf.jgss

  • Packages that use org.ietf.jgss
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.
  • Classes in org.ietf.jgss used by org.ietf.jgss
    Class and Description
    ChannelBinding
    This class encapsulates the concept of caller-provided channel binding information.
    GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context.
    GSSCredential
    This interface encapsulates the GSS-API credentials for an entity.
    GSSException
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.
    GSSManager
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.
    GSSName
    This interface encapsulates a single GSS-API principal entity.
    MessageProp
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.
    Oid
    This class represents Universal Object Identifiers (Oids) and their associated operations.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.ietf.jgss.ChannelBinding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.ietf.jgss.ChannelBinding

  • Packages that use ChannelBinding
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of ChannelBinding in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type ChannelBinding
      Modifier and Type Method and Description
      void GSSContext.setChannelBinding(ChannelBinding cb)
      Sets the channel bindings to be used during context establishment.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.ietf.jgss.GSSContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.ietf.jgss.GSSContext

  • Packages that use GSSContext
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSContext in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSContext
      Modifier and Type Method and Description
      abstract GSSContext GSSManager.createContext(byte[] interProcessToken)
      Factory method for creating a previously exported context.
      abstract GSSContext GSSManager.createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.ietf.jgss.GSSCredential (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.ietf.jgss.GSSCredential

  • Packages that use GSSCredential
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSCredential in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSCredential
      Modifier and Type Method and Description
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSCredential GSSManager.createCredential(int usage)
      Factory method for acquiring default credentials.
      GSSCredential GSSContext.getDelegCred()
      Obtains the credentials delegated by the context initiator to the context acceptor.
      Methods in org.ietf.jgss with parameters of type GSSCredential
      Modifier and Type Method and Description
      abstract GSSContext GSSManager.createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.ietf.jgss.GSSException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.ietf.jgss.GSSException

  • Packages that use GSSException
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSException in org.ietf.jgss

      Methods in org.ietf.jgss that throw GSSException
      Modifier and Type Method and Description
      byte[] GSSContext.acceptSecContext(byte[] inToken, int offset, int len)
      Called by the context acceptor upon receiving a token from the peer.
      void GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream)
      Called by the context acceptor to process a token from the peer using streams.
      void GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      abstract void GSSManager.addProviderAtEnd(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
      abstract void GSSManager.addProviderAtFront(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
      GSSName GSSName.canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      abstract GSSContext GSSManager.createContext(byte[] interProcessToken)
      Factory method for creating a previously exported context.
      abstract GSSContext GSSManager.createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSCredential GSSManager.createCredential(int usage)
      Factory method for acquiring default credentials.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      void GSSCredential.dispose()
      Releases any sensitive information that the GSSCredential object may be containing.
      void GSSContext.dispose()
      Releases any system resources and cryptographic information stored in the context object and invalidates the context.
      boolean GSSName.equals(GSSName another)
      Compares two GSSName objects to determine if they refer to the same entity.
      byte[] GSSName.export()
      Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions.
      byte[] GSSContext.export()
      Exports this context so that another process may import it..
      GSSCredential GSSContext.getDelegCred()
      Obtains the credentials delegated by the context initiator to the context acceptor.
      byte[] Oid.getDER()
      Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.
      Oid GSSContext.getMech()
      Determines what mechanism is being used for this context.
      Oid[] GSSCredential.getMechs()
      Returns a list of mechanisms supported by this credential.
      byte[] GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp)
      Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.
      void GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.
      GSSName GSSCredential.getName()
      Retrieves the name of the entity that the credential asserts.
      GSSName GSSCredential.getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      abstract Oid[] GSSManager.getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.
      int GSSCredential.getRemainingAcceptLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.
      int GSSCredential.getRemainingInitLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.
      int GSSCredential.getRemainingLifetime()
      Returns the remaining lifetime in seconds for a credential.
      GSSName GSSContext.getSrcName()
      Returns the name of the context initiator.
      Oid GSSName.getStringNameType()
      Returns the name type of the printable representation of this name that can be obtained from the toString method.
      GSSName GSSContext.getTargName()
      Returns the name of the context acceptor.
      int GSSCredential.getUsage()
      Returns the credential usage mode.
      int GSSCredential.getUsage(Oid mech)
      Returns the credential usage mode for a specific mechanism.
      int GSSContext.getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize)
      Used to determine limits on the size of the message that can be passed to wrap.
      byte[] GSSContext.initSecContext(byte[] inputBuf, int offset, int len)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method.
      int GSSContext.initSecContext(InputStream inStream, OutputStream outStream)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams.
      boolean GSSContext.isInitiator()
      Determines if this is the context initiator.
      boolean GSSContext.isTransferable()
      Determines if the context is transferable to other processes through the use of the export method.
      void GSSContext.requestAnonymity(boolean state)
      Requests that the initiator's identity not be disclosed to the acceptor.
      void GSSContext.requestConf(boolean state)
      Requests that data confidentiality be enabled for the wrap method.
      void GSSContext.requestCredDeleg(boolean state)
      Requests that the initiator's credentials be delegated to the acceptor during context establishment.
      void GSSContext.requestInteg(boolean state)
      Requests that data integrity be enabled for the wrap and getMICmethods.
      void GSSContext.requestLifetime(int lifetime)
      Requests a lifetime in seconds for the context.
      void GSSContext.requestMutualAuth(boolean state)
      Requests that mutual authentication be done during context establishment.
      void GSSContext.requestReplayDet(boolean state)
      Requests that replay detection be enabled for the per-message security services after context establishment.
      void GSSContext.requestSequenceDet(boolean state)
      Requests that sequence checking be enabled for the per-message security services after context establishment.
      void GSSContext.setChannelBinding(ChannelBinding cb)
      Sets the channel bindings to be used during context establishment.
      byte[] GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Used to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp)
      Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
      void GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
      byte[] GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Applies per-message security services over the established security context.
      void GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Applies per-message security services over the established security context using streams.
      Constructors in org.ietf.jgss that throw GSSException
      Constructor and Description
      Oid(byte[] data)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(InputStream derOid)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(String strOid)
      Constructs an Oid object from a string representation of its integer components.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.ietf.jgss.GSSManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.ietf.jgss.GSSManager

  • Packages that use GSSManager
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSManager in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSManager
      Modifier and Type Method and Description
      static GSSManager GSSManager.getInstance()
      Returns the default GSSManager implementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.ietf.jgss.GSSName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.ietf.jgss.GSSName

  • Packages that use GSSName
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSName in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSName
      Modifier and Type Method and Description
      GSSName GSSName.canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      GSSName GSSCredential.getName()
      Retrieves the name of the entity that the credential asserts.
      GSSName GSSCredential.getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      GSSName GSSContext.getSrcName()
      Returns the name of the context initiator.
      GSSName GSSContext.getTargName()
      Returns the name of the context acceptor.
      Methods in org.ietf.jgss with parameters of type GSSName
      Modifier and Type Method and Description
      void GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      boolean GSSName.equals(GSSName another)
      Compares two GSSName objects to determine if they refer to the same entity.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.ietf.jgss.MessageProp (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.ietf.jgss.MessageProp

  • Packages that use MessageProp
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of MessageProp in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type MessageProp
      Modifier and Type Method and Description
      byte[] GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp)
      Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.
      void GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.
      byte[] GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Used to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp)
      Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
      void GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
      byte[] GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Applies per-message security services over the established security context.
      void GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Applies per-message security services over the established security context using streams.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.ietf.jgss.Oid (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.ietf.jgss.Oid

  • Packages that use Oid
    Package Description
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of Oid in org.ietf.jgss

      Fields in org.ietf.jgss declared as Oid
      Modifier and Type Field and Description
      static Oid GSSName.NT_ANONYMOUS
      Name type for representing an anonymous entity.
      static Oid GSSName.NT_EXPORT_NAME
      Name type used to indicate an exported name produced by the export method.
      static Oid GSSName.NT_HOSTBASED_SERVICE
      Oid indicating a host-based service name form.
      static Oid GSSName.NT_MACHINE_UID_NAME
      Name type to indicate a numeric user identifier corresponding to a user on a local system.
      static Oid GSSName.NT_STRING_UID_NAME
      Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.
      static Oid GSSName.NT_USER_NAME
      Name type to indicate a named user on a local system.
      Methods in org.ietf.jgss that return Oid
      Modifier and Type Method and Description
      Oid GSSContext.getMech()
      Determines what mechanism is being used for this context.
      Oid[] GSSCredential.getMechs()
      Returns a list of mechanisms supported by this credential.
      abstract Oid[] GSSManager.getMechs()
      Returns a list of mechanisms that are available to GSS-API callers through this GSSManager.
      abstract Oid[] GSSManager.getMechsForName(Oid nameType)
      Returns a list of mechanisms that support the indicated name type.
      abstract Oid[] GSSManager.getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.
      Oid GSSName.getStringNameType()
      Returns the name type of the printable representation of this name that can be obtained from the toString method.
      Methods in org.ietf.jgss with parameters of type Oid
      Modifier and Type Method and Description
      void GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      abstract void GSSManager.addProviderAtEnd(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
      abstract void GSSManager.addProviderAtFront(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
      GSSName GSSName.canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      boolean Oid.containedIn(Oid[] oids)
      A utility method to test if this Oid value is contained within the supplied Oid array.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract Oid[] GSSManager.getMechsForName(Oid nameType)
      Returns a list of mechanisms that support the indicated name type.
      GSSName GSSCredential.getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      abstract Oid[] GSSManager.getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.
      int GSSCredential.getRemainingAcceptLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.
      int GSSCredential.getRemainingInitLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.
      int GSSCredential.getUsage(Oid mech)
      Returns the credential usage mode for a specific mechanism.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ACTIVITY_COMPLETED (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ACTIVITY_COMPLETED

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
  • All Implemented Interfaces:
    Serializable

    public final class ACTIVITY_COMPLETED
extends SystemException
    The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed. It indicates that the Activity context in which the method call was made has been completed due to a timeout of either the Activity itself or a transaction that encompasses the Activity, or that the Activity completed in a manner other than that originally requested.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      ACTIVITY_COMPLETED()
      Constructs an ACTIVITY_COMPLETED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
      ACTIVITY_COMPLETED(String detailMessage)
      Constructs an ACTIVITY_COMPLETED exception with the specified message.
      ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED()
        Constructs an ACTIVITY_COMPLETED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED(String detailMessage)
        Constructs an ACTIVITY_COMPLETED exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED(int minorCode,
                          CompletionStatus completionStatus)
        Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED(String detailMessage,
                          int minorCode,
                          CompletionStatus completionStatus)
        Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ACTIVITY_REQUIRED (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ACTIVITY_REQUIRED

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_REQUIRED
  • All Implemented Interfaces:
    Serializable

    public final class ACTIVITY_REQUIRED
extends SystemException
    The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required. It indicates that an Activity context was necessary to perform the invoked operation, but one was not found associated with the calling thread.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      ACTIVITY_REQUIRED()
      Constructs an ACTIVITY_REQUIRED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
      ACTIVITY_REQUIRED(String detailMessage)
      Constructs an ACTIVITY_REQUIRED exception with the specified message.
      ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED()
        Constructs an ACTIVITY_REQUIRED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED(String detailMessage)
        Constructs an ACTIVITY_REQUIRED exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED(int minorCode,
                         CompletionStatus completionStatus)
        Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED(String detailMessage,
                         int minorCode,
                         CompletionStatus completionStatus)
        Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Any (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class Any

  • java.lang.Object
    • org.omg.CORBA.Any
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public abstract class Any
extends Object
implements IDLEntity
    Serves as a container for any data that can be described in IDL or for any IDL primitive type. An Any object is used as a component of a NamedValue object, which provides information about arguments or return values in requests, and which is used to define name/value pairs in Context objects.

    An Any object consists of two parts:

    1. a data value
    2. a TypeCode object describing the type of the data value contained in the Any object. For example, a TypeCode object for an array contains a field for the length of the array and a field for the type of elements in the array. (Note that in this case, the second field of the TypeCode object is itself a TypeCode object.)

    A large part of the Any class consists of pairs of methods for inserting values into and extracting values from an Any object.

    For a given primitive type X, these methods are:

    void insert_X(X x)
    This method allows the insertion of an instance x of primitive type X into the value field of the Any object. Note that the method insert_X also resets the Any object's type field if necessary.
    X extract_X()
    This method allows the extraction of an instance of type X from the Any object.

    This method throws the exception BAD_OPERATION under two conditions:

    1. the type of the element contained in the Any object is not X
    2. the method extract_X is called before the value field of the Any object has been set

    There are distinct method pairs for each primitive IDL data type (insert_long and extract_long, insert_string and extract_string, and so on).

    The class Any also has methods for getting and setting the type code, for testing two Any objects for equality, and for reading an Any object from a stream or writing it to a stream.

    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Any()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      abstract InputStream create_input_stream()
      Creates an input stream from which this Any object's value can be unmarshalled.
      abstract OutputStream create_output_stream()
      Creates an output stream into which this Any object's value can be marshalled.
      abstract boolean equal(Any a)
      Checks for equality between this Any object and the given Any object.
      abstract Any extract_any()
      Extracts the Any object in this Any object's value field.
      abstract boolean extract_boolean()
      Extracts the boolean in this Any object's value field.
      abstract char extract_char()
      Extracts the char in this Any object's value field.
      abstract double extract_double()
      Extracts the double in this Any object's value field.
      BigDecimal extract_fixed()
      Extracts the java.math.BigDecimal object in this Any object's value field.
      abstract float extract_float()
      Extracts the float in this Any object's value field.
      abstract int extract_long()
      Extracts the int in this Any object's value field.
      abstract long extract_longlong()
      Extracts the long in this Any object's value field.
      abstract Object extract_Object()
      Extracts the org.omg.CORBA.Object in this Any object's value field.
      abstract byte extract_octet()
      Extracts the byte in this Any object's value field.
      Principal extract_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract short extract_short()
      Extracts the short in this Any object's value field.
      Streamable extract_Streamable()
      Extracts a Streamable from this Any object's value field.
      abstract String extract_string()
      Extracts the String object in this Any object's value field.
      abstract TypeCode extract_TypeCode()
      Extracts the TypeCode object in this Any object's value field.
      abstract int extract_ulong()
      Extracts the int in this Any object's value field.
      abstract long extract_ulonglong()
      Extracts the long in this Any object's value field.
      abstract short extract_ushort()
      Extracts the short in this Any object's value field.
      abstract Serializable extract_Value()
      Extracts the java.io.Serializable object in this Any object's value field.
      abstract char extract_wchar()
      Extracts the char in this Any object's value field.
      abstract String extract_wstring()
      Extracts the String object in this Any object's value field.
      abstract void insert_any(Any a)
      Inserts the given Any object into this Any object's value field.
      abstract void insert_boolean(boolean b)
      Inserts the given boolean into this Any object's value field.
      abstract void insert_char(char c)
      Inserts the given char into this Any object's value field.
      abstract void insert_double(double d)
      Inserts the given double into this Any object's value field.
      void insert_fixed(BigDecimal value)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void insert_fixed(BigDecimal value, TypeCode type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      abstract void insert_float(float f)
      Inserts the given float into this Any object's value field.
      abstract void insert_long(int l)
      Inserts the given int into this Any object's value field.
      abstract void insert_longlong(long l)
      Inserts the given long into this Any object's value field.
      abstract void insert_Object(Object o)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      abstract void insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      abstract void insert_octet(byte b)
      Inserts the given byte into this Any object's value field.
      void insert_Principal(Principal p)
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract void insert_short(short s)
      Inserts the given short into this Any object's value field.
      void insert_Streamable(Streamable s)
      Inserts the given Streamable object into this Any object's value field.
      abstract void insert_string(String s)
      Inserts the given String object into this Any object's value field.
      abstract void insert_TypeCode(TypeCode t)
      Inserts the given TypeCode object into this Any object's value field.
      abstract void insert_ulong(int l)
      Inserts the given int into this Any object's value field.
      abstract void insert_ulonglong(long l)
      Inserts the given long into this Any object's value field.
      abstract void insert_ushort(short s)
      Inserts the given short into this Any object's value field.
      abstract void insert_Value(Serializable v)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void insert_Value(Serializable v, TypeCode t)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void insert_wchar(char c)
      Inserts the given char into this Any object's value field.
      abstract void insert_wstring(String s)
      Inserts the given String object into this Any object's value field.
      abstract void read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
      abstract TypeCode type()
      Returns type information for the element contained in this Any object.
      abstract void type(TypeCode t)
      Sets this Any object's type field to the given TypeCode object and clears its value.
      abstract void write_value(OutputStream os)
      Writes out the value of this Any object to the given output stream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Any

        public Any()

    • Method Detail

      • equal

        public abstract boolean equal(Any a)
        Checks for equality between this Any object and the given Any object. Two Any objects are equal if both their values and type codes are equal.
        Parameters:
        a - the Any object to test for equality
        Returns:
        true if the Any objects are equal; false otherwise
        See Also:
        CORBA package comments for unimplemented features

      • type

        public abstract TypeCode type()
        Returns type information for the element contained in this Any object.
        Returns:
        the TypeCode object containing type information about the value contained in this Any object

      • type

        public abstract void type(TypeCode t)
        Sets this Any object's type field to the given TypeCode object and clears its value.

        Note that using this method to set the type code wipes out the value if there is one. The method is provided primarily so that the type may be set properly for IDL out parameters. Generally, setting the type is done by the insert_X methods, which will set the type to X if it is not already set to X.

        Parameters:
        t - the TypeCode object giving information for the value in this Any object

      • read_value

        public abstract void read_value(InputStream is,
                                TypeCode t)
                         throws MARSHAL
        Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
        Parameters:
        is - the org.omg.CORBA.portable.InputStream object from which to read the value contained in this Any object
        t - a TypeCode object containing type information about the value to be read
        Throws:
        MARSHAL - when the given TypeCode object is not consistent with the value that was contained in the input stream

      • write_value

        public abstract void write_value(OutputStream os)
        Writes out the value of this Any object to the given output stream. If both typecode and value need to be written, use create_output_stream() to create an OutputStream, then use write_any on the OutputStream.

        If this method is called on an Any object that has not had a value inserted into its value field, it will throw the exception java.lang.NullPointerException.

        Parameters:
        os - the org.omg.CORBA.portable.OutputStream object into which to marshal the value of this Any object

      • create_output_stream

        public abstract OutputStream create_output_stream()
        Creates an output stream into which this Any object's value can be marshalled.
        Returns:
        the newly-created OutputStream

      • create_input_stream

        public abstract InputStream create_input_stream()
        Creates an input stream from which this Any object's value can be unmarshalled.
        Returns:
        the newly-created InputStream

      • extract_short

        public abstract short extract_short()
                             throws BAD_OPERATION
        Extracts the short in this Any object's value field.
        Returns:
        the short stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a short or the value field has not yet been set

      • insert_short

        public abstract void insert_short(short s)
        Inserts the given short into this Any object's value field.
        Parameters:
        s - the short to insert into this Any object

      • extract_long

        public abstract int extract_long()
                          throws BAD_OPERATION
        Extracts the int in this Any object's value field.
        Returns:
        the int stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than an int or the value field has not yet been set

      • insert_long

        public abstract void insert_long(int l)
        Inserts the given int into this Any object's value field.
        Parameters:
        l - the int to insert into this Any object

      • extract_longlong

        public abstract long extract_longlong()
                               throws BAD_OPERATION
        Extracts the long in this Any object's value field.
        Returns:
        the long stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a long or the value field has not yet been set

      • insert_longlong

        public abstract void insert_longlong(long l)
        Inserts the given long into this Any object's value field.
        Parameters:
        l - the long to insert into this Any object

      • extract_ushort

        public abstract short extract_ushort()
                              throws BAD_OPERATION
        Extracts the short in this Any object's value field.
        Returns:
        the short stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a short or the value field has not yet been set

      • insert_ushort

        public abstract void insert_ushort(short s)
        Inserts the given short into this Any object's value field.
        Parameters:
        s - the short to insert into this Any object

      • extract_ulong

        public abstract int extract_ulong()
                           throws BAD_OPERATION
        Extracts the int in this Any object's value field.
        Returns:
        the int stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than an int or the value field has not yet been set

      • insert_ulong

        public abstract void insert_ulong(int l)
        Inserts the given int into this Any object's value field.
        Parameters:
        l - the int to insert into this Any object

      • extract_ulonglong

        public abstract long extract_ulonglong()
                                throws BAD_OPERATION
        Extracts the long in this Any object's value field.
        Returns:
        the long stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a long or the value field has not yet been set

      • insert_ulonglong

        public abstract void insert_ulonglong(long l)
        Inserts the given long into this Any object's value field.
        Parameters:
        l - the long to insert into this Any object

      • extract_float

        public abstract float extract_float()
                             throws BAD_OPERATION
        Extracts the float in this Any object's value field.
        Returns:
        the float stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a float or the value field has not yet been set

      • insert_float

        public abstract void insert_float(float f)
        Inserts the given float into this Any object's value field.
        Parameters:
        f - the float to insert into this Any object

      • extract_double

        public abstract double extract_double()
                               throws BAD_OPERATION
        Extracts the double in this Any object's value field.
        Returns:
        the double stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a double or the value field has not yet been set

      • insert_double

        public abstract void insert_double(double d)
        Inserts the given double into this Any object's value field.
        Parameters:
        d - the double to insert into this Any object

      • extract_boolean

        public abstract boolean extract_boolean()
                                 throws BAD_OPERATION
        Extracts the boolean in this Any object's value field.
        Returns:
        the boolean stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a boolean or the value field has not yet been set

      • insert_boolean

        public abstract void insert_boolean(boolean b)
        Inserts the given boolean into this Any object's value field.
        Parameters:
        b - the boolean to insert into this Any object

      • extract_char

        public abstract char extract_char()
                           throws BAD_OPERATION
        Extracts the char in this Any object's value field.
        Returns:
        the char stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a char or the value field has not yet been set

      • insert_char

        public abstract void insert_char(char c)
                          throws DATA_CONVERSION
        Inserts the given char into this Any object's value field.
        Parameters:
        c - the char to insert into this Any object
        Throws:
        DATA_CONVERSION - if there is a data conversion error

      • extract_wchar

        public abstract char extract_wchar()
                            throws BAD_OPERATION
        Extracts the char in this Any object's value field.
        Returns:
        the char stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a char or the value field has not yet been set

      • insert_wchar

        public abstract void insert_wchar(char c)
        Inserts the given char into this Any object's value field.
        Parameters:
        c - the char to insert into this Any object

      • extract_octet

        public abstract byte extract_octet()
                            throws BAD_OPERATION
        Extracts the byte in this Any object's value field.
        Returns:
        the byte stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a byte or the value field has not yet been set

      • insert_octet

        public abstract void insert_octet(byte b)
        Inserts the given byte into this Any object's value field.
        Parameters:
        b - the byte to insert into this Any object

      • extract_any

        public abstract Any extract_any()
                         throws BAD_OPERATION
        Extracts the Any object in this Any object's value field.
        Returns:
        the Any object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than an Any object or the value field has not yet been set

      • insert_any

        public abstract void insert_any(Any a)
        Inserts the given Any object into this Any object's value field.
        Parameters:
        a - the Any object to insert into this Any object

      • extract_Object

        public abstract Object extract_Object()
                               throws BAD_OPERATION
        Extracts the org.omg.CORBA.Object in this Any object's value field.
        Returns:
        the org.omg.CORBA.Object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than an org.omg.CORBA.Object or the value field has not yet been set

      • insert_Object

        public abstract void insert_Object(Object o)
        Inserts the given org.omg.CORBA.Object object into this Any object's value field.
        Parameters:
        o - the org.omg.CORBA.Object object to insert into this Any object

      • extract_Value

        public abstract Serializable extract_Value()
                                    throws BAD_OPERATION
        Extracts the java.io.Serializable object in this Any object's value field.
        Returns:
        the java.io.Serializable object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a java.io.Serializable object or the value field has not yet been set

      • insert_Value

        public abstract void insert_Value(Serializable v)
        Inserts the given java.io.Serializable object into this Any object's value field.
        Parameters:
        v - the java.io.Serializable object to insert into this Any object

      • insert_Value

        public abstract void insert_Value(Serializable v,
                                  TypeCode t)
                           throws MARSHAL
        Inserts the given java.io.Serializable object into this Any object's value field.
        Parameters:
        v - the java.io.Serializable object to insert into this Any object
        t - the TypeCode object that is to be inserted into this Any object's type field and that describes the java.io.Serializable object being inserted
        Throws:
        MARSHAL - if the ORB has a problem marshalling or unmarshalling parameters

      • insert_Object

        public abstract void insert_Object(Object o,
                                   TypeCode t)
                            throws BAD_PARAM
        Inserts the given org.omg.CORBA.Object object into this Any object's value field.
        Parameters:
        o - the org.omg.CORBA.Object instance to insert into this Any object
        t - the TypeCode object that is to be inserted into this Any object and that describes the Object being inserted
        Throws:
        BAD_OPERATION - if this method is invalid for this Any object
        BAD_PARAM

      • extract_string

        public abstract String extract_string()
                               throws BAD_OPERATION
        Extracts the String object in this Any object's value field.
        Returns:
        the String object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a String object or the value field has not yet been set

      • insert_string

        public abstract void insert_string(String s)
                            throws DATA_CONVERSION,
                                   MARSHAL
        Inserts the given String object into this Any object's value field.
        Parameters:
        s - the String object to insert into this Any object
        Throws:
        DATA_CONVERSION - if there is a data conversion error
        MARSHAL - if the ORB has a problem marshalling or unmarshalling parameters

      • extract_wstring

        public abstract String extract_wstring()
                                throws BAD_OPERATION
        Extracts the String object in this Any object's value field.
        Returns:
        the String object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a String object or the value field has not yet been set

      • insert_wstring

        public abstract void insert_wstring(String s)
                             throws MARSHAL
        Inserts the given String object into this Any object's value field.
        Parameters:
        s - the String object to insert into this Any object
        Throws:
        MARSHAL - if the ORB has a problem marshalling or unmarshalling parameters

      • extract_TypeCode

        public abstract TypeCode extract_TypeCode()
                                   throws BAD_OPERATION
        Extracts the TypeCode object in this Any object's value field.
        Returns:
        the TypeCode object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a TypeCode object or the value field has not yet been set

      • insert_TypeCode

        public abstract void insert_TypeCode(TypeCode t)
        Inserts the given TypeCode object into this Any object's value field.
        Parameters:
        t - the TypeCode object to insert into this Any object

      • extract_Principal

        @Deprecated
public Principal extract_Principal()
                                        throws BAD_OPERATION
        Deprecated. Deprecated by CORBA 2.2.
        Extracts the Principal object in this Any object's value field. Note that the class Principal has been deprecated.
        Returns:
        the Principal object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a Principal object or the value field has not yet been set
        See Also:
        CORBA package comments for unimplemented features

      • insert_Principal

        @Deprecated
public void insert_Principal(Principal p)
        Deprecated. Deprecated by CORBA 2.2.
        Inserts the given Principal object into this Any object's value field. Note that the class Principal has been deprecated.
        Parameters:
        p - the Principal object to insert into this Any object
        See Also:
        CORBA package comments for unimplemented features

      • extract_Streamable

        public Streamable extract_Streamable()
                              throws BAD_INV_ORDER
        Extracts a Streamable from this Any object's value field. This method allows the extraction of non-primitive IDL types.
        Returns:
        the Streamable stored in the Any object.
        Throws:
        BAD_INV_ORDER - if the caller has invoked operations in the wrong order
        See Also:
        CORBA package comments for unimplemented features

      • insert_Streamable

        public void insert_Streamable(Streamable s)
        Inserts the given Streamable object into this Any object's value field. This method allows the insertion of non-primitive IDL types.
        Parameters:
        s - the Streamable object to insert into this Any object; may be a non-primitive IDL type
        See Also:
        CORBA package comments for unimplemented features

      • extract_fixed

        public BigDecimal extract_fixed()
        Extracts the java.math.BigDecimal object in this Any object's value field.
        Returns:
        the java.math.BigDecimal object stored in this Any object
        Throws:
        BAD_OPERATION - if this Any object contains something other than a java.math.BigDecimal object or the value field has not yet been set
        See Also:
        CORBA package comments for unimplemented features

      • insert_fixed

        public void insert_fixed(BigDecimal value)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Inserts the given java.math.BigDecimal object into this Any object's value field.

        Parameters:
        value - the java.math.BigDecimal object to insert into this Any object
        See Also:
        CORBA package comments for unimplemented features

      • insert_fixed

        public void insert_fixed(BigDecimal value,
                         TypeCode type)
                  throws BAD_INV_ORDER
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Inserts the given java.math.BigDecimal object into this Any object's value field.

        Parameters:
        value - the java.math.BigDecimal object to insert into this Any object
        type - the TypeCode object that is to be inserted into this Any object's type field and that describes the java.math.BigDecimal object being inserted
        Throws:
        BAD_INV_ORDER - if this method is invoked improperly
        See Also:
        CORBA package comments for unimplemented features
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AnyHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class AnyHolder

  • java.lang.Object
    • org.omg.CORBA.AnyHolder
  • All Implemented Interfaces:
    Streamable

    public final class AnyHolder
extends Object
implements Streamable
    The Holder for Any. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for Any objects that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL any as an "out" or "inout" parameter, the programmer must pass an instance of AnyHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myAnyHolder is an instance of AnyHolder, the value stored in its value field can be accessed with myAnyHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Any value
      The Any value held by this AnyHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      AnyHolder()
      Constructs a new AnyHolder object with its value field initialized to null.
      AnyHolder(Any initial)
      Constructs a new AnyHolder object for the given Any object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in this AnyHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this AnyHolder object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Any value
        The Any value held by this AnyHolder object.

    • Constructor Detail

      • AnyHolder

        public AnyHolder()
        Constructs a new AnyHolder object with its value field initialized to null.

      • AnyHolder

        public AnyHolder(Any initial)
        Constructs a new AnyHolder object for the given Any object.
        Parameters:
        initial - the Any object with which to initialize the value field of the new AnyHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this AnyHolder object.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in this AnyHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in this AnyHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AnySeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class AnySeqHelper

  • java.lang.Object
    • org.omg.CORBA.AnySeqHelper

  • public abstract class AnySeqHelper
extends Object
    The Helper for AnySeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/AnySeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      AnySeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Any[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Any[] that)
      static Any[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Any[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AnySeqHelper

        public AnySeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Any[] that)

      • extract

        public static Any[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Any[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Any[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AnySeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class AnySeqHolder

  • java.lang.Object
    • org.omg.CORBA.AnySeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class AnySeqHolder
extends Object
implements Streamable
    The Holder for AnySeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/AnySeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Any[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      AnySeqHolder()
      AnySeqHolder(Any[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Any[] value

    • Constructor Detail

      • AnySeqHolder

        public AnySeqHolder()

      • AnySeqHolder

        public AnySeqHolder(Any[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ARG_IN (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface ARG_IN

  • public interface ARG_IN
    Signifies an "input" argument to an invocation, meaning that the argument is being passed from the client to the server. ARG_IN.value is one of the possible values used to indicate the direction in which a parameter is being passed during an invocation performed using the Dynamic Invocation Interface (DII).

    The code fragment below shows a typical usage:

        ORB orb = ORB.init(args, null);
    org.omg.CORBA.NamedValue nv = orb.create_named_value(
         "IDLArgumentIdentifier", myAny, org.omg.CORBA.ARG_IN.value);
    Since:
    JDK1.2
    See Also:
    NamedValue

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value indicating an input argument.

    • Field Detail

      • value

        static final int value
        The value indicating an input argument.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ARG_INOUT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface ARG_INOUT

  • public interface ARG_INOUT
    Signifies an argument used for both input and output in an invocation, meaning that the argument is being passed from the client to the server and then back from the server to the client. ARG_INOUT.value is one of the possible values used to indicate the direction in which a parameter is being passed during a dynamic invocation using the Dynamic Invocation Interface (DII).

    The code fragment below shows a typical usage:

      ORB orb = ORB.init(args, null);
  org.omg.CORBA.NamedValue nv = orb.create_named_value(
        "argumentIdentifier", myAny, org.omg.CORBA.ARG_INOUT.value);
    Since:
    JDK1.2
    See Also:
    NamedValue

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The constant value indicating an argument used for both input and output.

    • Field Detail

      • value

        static final int value
        The constant value indicating an argument used for both input and output.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ARG_OUT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface ARG_OUT

  • public interface ARG_OUT
    A constant that signifies an "output" argument to an invocation, meaning that the argument is being passed from the server to the client. ARG_OUT.value is one of the possible values used to indicate the direction in which a parameter is being passed during a dynamic invocation using the Dynamic Invocation Interface (DII).

    The code fragment below shows a typical usage:

      ORB orb = ORB.init(args, null);
  org.omg.CORBA.NamedValue nv = orb.create_named_value(
        "argumentIdentifier", myAny, org.omg.CORBA.ARG_OUT.value);
    Since:
    JDK1.2
    See Also:
    NamedValue

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The constant value indicating an output argument.

    • Field Detail

      • value

        static final int value
        The constant value indicating an output argument.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_CONTEXT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BAD_CONTEXT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_CONTEXT
  • All Implemented Interfaces:
    Serializable

    public final class BAD_CONTEXT
extends SystemException
    Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      BAD_CONTEXT()
      Constructs a BAD_CONTEXT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_CONTEXT(int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
      BAD_CONTEXT(String s)
      Constructs a BAD_CONTEXT exception with the specified detail message, a minor code of 0 and a completion state of COMPLETED_NO.
      BAD_CONTEXT(String s, int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BAD_CONTEXT

        public BAD_CONTEXT()
        Constructs a BAD_CONTEXT exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_CONTEXT

        public BAD_CONTEXT(String s)
        Constructs a BAD_CONTEXT exception with the specified detail message, a minor code of 0 and a completion state of COMPLETED_NO.
        Parameters:
        s - a String object containing a detail message

      • BAD_CONTEXT

        public BAD_CONTEXT(int minor,
                   CompletionStatus completed)
        Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_CONTEXT

        public BAD_CONTEXT(String s,
                   int minor,
                   CompletionStatus completed)
        Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_INV_ORDER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BAD_INV_ORDER

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_INV_ORDER
  • All Implemented Interfaces:
    Serializable

    public final class BAD_INV_ORDER
extends SystemException
    This exception indicates that the caller has invoked operations in the wrong order. For example, it can be raised by an ORB if an application makes an ORB-related call without having correctly initialized the ORB first.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      BAD_INV_ORDER()
      Constructs a BAD_INV_ORDER exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_INV_ORDER(int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
      BAD_INV_ORDER(String s)
      Constructs a BAD_INV_ORDER exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BAD_INV_ORDER

        public BAD_INV_ORDER()
        Constructs a BAD_INV_ORDER exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_INV_ORDER

        public BAD_INV_ORDER(String s)
        Constructs a BAD_INV_ORDER exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • BAD_INV_ORDER

        public BAD_INV_ORDER(int minor,
                     CompletionStatus completed)
        Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_INV_ORDER

        public BAD_INV_ORDER(String s,
                     int minor,
                     CompletionStatus completed)
        Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_OPERATION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BAD_OPERATION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_OPERATION
  • All Implemented Interfaces:
    Serializable

    public final class BAD_OPERATION
extends SystemException
    Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      BAD_OPERATION()
      Constructs a BAD_OPERATION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_OPERATION(int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified minor code and completion status.
      BAD_OPERATION(String s)
      Constructs a BAD_OPERATION exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_OPERATION(String s, int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BAD_OPERATION

        public BAD_OPERATION()
        Constructs a BAD_OPERATION exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_OPERATION

        public BAD_OPERATION(String s)
        Constructs a BAD_OPERATION exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • BAD_OPERATION

        public BAD_OPERATION(int minor,
                     CompletionStatus completed)
        Constructs a BAD_OPERATION exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_OPERATION

        public BAD_OPERATION(String s,
                     int minor,
                     CompletionStatus completed)
        Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_PARAM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BAD_PARAM

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_PARAM
  • All Implemented Interfaces:
    Serializable

    public final class BAD_PARAM
extends SystemException
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal. An ORB may raise this exception if null values or null pointers are passed to an operation (for language mappings where the concept of a null pointers or null values applies). BAD_PARAM can also be raised as a result of a client generating requests with incorrect parameters using the DII.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions, meaning of minor codes

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      BAD_PARAM()
      Constructs a BAD_PARAM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_PARAM(int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified minor code and completion status.
      BAD_PARAM(String s)
      Constructs a BAD_PARAM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_PARAM(String s, int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BAD_PARAM

        public BAD_PARAM()
        Constructs a BAD_PARAM exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_PARAM

        public BAD_PARAM(String s)
        Constructs a BAD_PARAM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message describing this exception

      • BAD_PARAM

        public BAD_PARAM(int minor,
                 CompletionStatus completed)
        Constructs a BAD_PARAM exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • BAD_PARAM

        public BAD_PARAM(String s,
                 int minor,
                 CompletionStatus completed)
        Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_POLICY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface BAD_POLICY

  • public interface BAD_POLICY
    A PolicyErrorCode which would be filled in the PolicyError exception.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The Error code in PolicyError exception.

    • Field Detail

      • value

        static final short value
        The Error code in PolicyError exception.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_POLICY_TYPE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface BAD_POLICY_TYPE

  • public interface BAD_POLICY_TYPE
    A PolicyErrorCode which would be filled in the PolicyError exception.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The Error code in PolicyError exception.

    • Field Detail

      • value

        static final short value
        The Error code in PolicyError exception.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_POLICY_VALUE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface BAD_POLICY_VALUE

  • public interface BAD_POLICY_VALUE
    Contains the value used to indicate a policy value that is incorrect for a valid policy type in a call to the create_policy method defined in the ORB class.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The value used to represent a bad policy value error in a PolicyError exception.

    • Field Detail

      • value

        static final short value
        The value used to represent a bad policy value error in a PolicyError exception.
        See Also:
        PolicyError, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_QOS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BAD_QOS

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_QOS
  • All Implemented Interfaces:
    Serializable

    public final class BAD_QOS
extends SystemException
    The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      BAD_QOS()
      Constructs an BAD_QOS exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      BAD_QOS(int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified minor code and completion status.
      BAD_QOS(String detailMessage)
      Constructs an BAD_QOS exception with the specified message.
      BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BAD_QOS

        public BAD_QOS()
        Constructs an BAD_QOS exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • BAD_QOS

        public BAD_QOS(String detailMessage)
        Constructs an BAD_QOS exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • BAD_QOS

        public BAD_QOS(int minorCode,
               CompletionStatus completionStatus)
        Constructs an BAD_QOS exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • BAD_QOS

        public BAD_QOS(String detailMessage,
               int minorCode,
               CompletionStatus completionStatus)
        Constructs an BAD_QOS exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BAD_TYPECODE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BAD_TYPECODE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_TYPECODE
  • All Implemented Interfaces:
    Serializable

    public final class BAD_TYPECODE
extends SystemException
    Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      BAD_TYPECODE()
      Constructs a BAD_TYPECODE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_TYPECODE(int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
      BAD_TYPECODE(String s)
      Constructs a BAD_TYPECODE exception with the specified detail, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_TYPECODE(String s, int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BAD_TYPECODE

        public BAD_TYPECODE()
        Constructs a BAD_TYPECODE exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_TYPECODE

        public BAD_TYPECODE(String s)
        Constructs a BAD_TYPECODE exception with the specified detail, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • BAD_TYPECODE

        public BAD_TYPECODE(int minor,
                    CompletionStatus completed)
        Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_TYPECODE

        public BAD_TYPECODE(String s,
                    int minor,
                    CompletionStatus completed)
        Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BooleanHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BooleanHolder

  • java.lang.Object
    • org.omg.CORBA.BooleanHolder
  • All Implemented Interfaces:
    Streamable

    public final class BooleanHolder
extends Object
implements Streamable
    The Holder for Boolean. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a boolean that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL boolean as an "out" or "inout" parameter, the programmer must pass an instance of BooleanHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myBooleanHolder is an instance of BooleanHolder, the value stored in its value field can be accessed with myBooleanHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      boolean value
      The boolean value held by this BooleanHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      BooleanHolder()
      Constructs a new BooleanHolder object with its value field initialized to false.
      BooleanHolder(boolean initial)
      Constructs a new BooleanHolder object with its value field initialized with the given boolean.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
      void _write(OutputStream output)
      Marshals the value in this BooleanHolder object's value field to the output stream output.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public boolean value
        The boolean value held by this BooleanHolder object.

    • Constructor Detail

      • BooleanHolder

        public BooleanHolder()
        Constructs a new BooleanHolder object with its value field initialized to false.

      • BooleanHolder

        public BooleanHolder(boolean initial)
        Constructs a new BooleanHolder object with its value field initialized with the given boolean.
        Parameters:
        initial - the boolean with which to initialize the value field of the newly-created BooleanHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream object containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals the value in this BooleanHolder object's value field to the output stream output.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode for the value held in this BooleanHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BooleanSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BooleanSeqHelper

  • java.lang.Object
    • org.omg.CORBA.BooleanSeqHelper

  • public abstract class BooleanSeqHelper
extends Object
    The Helper for BooleanSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/BooleanSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      BooleanSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static boolean[] | extract(Any a)
      static String | id()
      static void | insert(Any a, boolean[] that)
      static boolean[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, boolean[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BooleanSeqHelper

        public BooleanSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          boolean[] that)

      • extract

        public static boolean[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static boolean[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         boolean[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BooleanSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class BooleanSeqHolder

  • java.lang.Object
    • org.omg.CORBA.BooleanSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class BooleanSeqHolder
extends Object
implements Streamable
    The Holder for BooleanSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/BooleanSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      boolean[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      BooleanSeqHolder()
      BooleanSeqHolder(boolean[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public boolean[] value

    • Constructor Detail

      • BooleanSeqHolder

        public BooleanSeqHolder()

      • BooleanSeqHolder

        public BooleanSeqHolder(boolean[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Bounds (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class Bounds

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.Bounds
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Bounds
extends UserException
    A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
    See Also:
    documentation on Java IDL exceptions

    • Constructor Summary

      Constructors
      Constructor and Description
      Bounds()
      Constructs an Bounds with no specified detail message.
      Bounds(String reason)
      Constructs an Bounds with the specified detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Bounds

        public Bounds()
        Constructs an Bounds with no specified detail message.

      • Bounds

        public Bounds(String reason)
        Constructs an Bounds with the specified detail message.
        Parameters:
        reason - the detail message.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ByteHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ByteHolder

  • java.lang.Object
    • org.omg.CORBA.ByteHolder
  • All Implemented Interfaces:
    Streamable

    public final class ByteHolder
extends Object
implements Streamable
    The Holder for Byte. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a byte that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL octet as an "out" or "inout" parameter, the programmer must pass an instance of ByteHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myByteHolder is an instance of ByteHolder, the value stored in its value field can be accessed with myByteHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte value
      The byte value held by this ByteHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      ByteHolder()
      Constructs a new ByteHolder object with its value field initialized to 0.
      ByteHolder(byte initial)
      Constructs a new ByteHolder object for the given byte.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this ByteHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this ByteHolder object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public byte value
        The byte value held by this ByteHolder object.

    • Constructor Detail

      • ByteHolder

        public ByteHolder()
        Constructs a new ByteHolder object with its value field initialized to 0.

      • ByteHolder

        public ByteHolder(byte initial)
        Constructs a new ByteHolder object for the given byte.
        Parameters:
        initial - the byte with which to initialize the value field of the new ByteHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this ByteHolder object.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this ByteHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in this ByteHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CharHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CharHolder

  • java.lang.Object
    • org.omg.CORBA.CharHolder
  • All Implemented Interfaces:
    Streamable

    public final class CharHolder
extends Object
implements Streamable
    The Holder for Char. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a char that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL char as an "out" or "inout" parameter, the programmer must pass an instance of CharHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myCharHolder is an instance of CharHolder, the value stored in its value field can be accessed with myCharHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      char value
      The char value held by this CharHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      CharHolder()
      Constructs a new CharHolder object with its value field initialized to 0.
      CharHolder(char initial)
      Constructs a new CharHolder object for the given char.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in this CharHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this CharHolder object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public char value
        The char value held by this CharHolder object.

    • Constructor Detail

      • CharHolder

        public CharHolder()
        Constructs a new CharHolder object with its value field initialized to 0.

      • CharHolder

        public CharHolder(char initial)
        Constructs a new CharHolder object for the given char.
        Parameters:
        initial - the char with which to initialize the value field of the new CharHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this CharHolder object.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in this CharHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in this CharHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CharSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CharSeqHelper

  • java.lang.Object
    • org.omg.CORBA.CharSeqHelper

  • public abstract class CharSeqHelper
extends Object
    The Helper for CharSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/CharSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      CharSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static char[] | extract(Any a)
      static String | id()
      static void | insert(Any a, char[] that)
      static char[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, char[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CharSeqHelper

        public CharSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          char[] that)

      • extract

        public static char[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static char[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         char[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CharSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CharSeqHolder

  • java.lang.Object
    • org.omg.CORBA.CharSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class CharSeqHolder
extends Object
implements Streamable
    The Holder for CharSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/CharSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      char[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      CharSeqHolder()
      CharSeqHolder(char[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public char[] value

    • Constructor Detail

      • CharSeqHolder

        public CharSeqHolder()

      • CharSeqHolder

        public CharSeqHolder(char[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CODESET_INCOMPATIBLE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CODESET_INCOMPATIBLE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.CODESET_INCOMPATIBLE
  • All Implemented Interfaces:
    Serializable

    public final class CODESET_INCOMPATIBLE
extends SystemException
    This exception is raised whenever meaningful communication is not possible between client and server native code sets.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      CODESET_INCOMPATIBLE()
      Constructs an CODESET_INCOMPATIBLE exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
      CODESET_INCOMPATIBLE(String detailMessage)
      Constructs an CODESET_INCOMPATIBLE exception with the specified message.
      CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE()
        Constructs an CODESET_INCOMPATIBLE exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE(String detailMessage)
        Constructs an CODESET_INCOMPATIBLE exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE(int minorCode,
                            CompletionStatus completionStatus)
        Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE(String detailMessage,
                            int minorCode,
                            CompletionStatus completionStatus)
        Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


COMM_FAILURE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class COMM_FAILURE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.COMM_FAILURE
  • All Implemented Interfaces:
    Serializable

    public final class COMM_FAILURE
extends SystemException
    This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section meaning of minor codes to see the minor codes for this exception.

    Since:
    JDK1.2
    See Also:
    meaning of minor codes

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      COMM_FAILURE()
      Constructs a COMM_FAILURE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      COMM_FAILURE(int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified minor code and completion status.
      COMM_FAILURE(String s)
      Constructs a COMM_FAILURE exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      COMM_FAILURE(String s, int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • COMM_FAILURE

        public COMM_FAILURE()
        Constructs a COMM_FAILURE exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • COMM_FAILURE

        public COMM_FAILURE(String s)
        Constructs a COMM_FAILURE exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message describing this exception

      • COMM_FAILURE

        public COMM_FAILURE(int minor,
                    CompletionStatus completed)
        Constructs a COMM_FAILURE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status, which must be one of COMPLETED_YES, COMPLETED_NO, or COMPLETED_MAYBE.

      • COMM_FAILURE

        public COMM_FAILURE(String s,
                    int minor,
                    CompletionStatus completed)
        Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status, which must be one of COMPLETED_YES, COMPLETED_NO, or COMPLETED_MAYBE.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CompletionStatus (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CompletionStatus

  • java.lang.Object
    • org.omg.CORBA.CompletionStatus
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class CompletionStatus
extends Object
implements IDLEntity
    An object that indicates whether a method had completed running when a SystemException was thrown.

    The class CompletionStatus contains three CompletionStatus instances, which are constants representing each possible completion status: COMPLETED_MAYBE, COMPLETED_NO, and COMPLETED_YES. It also contains three int members, each a constant corresponding to one of the CompletionStatus instances. These int members make it possible to use a switch statement.

    The class also contains two methods:

    • public int value() -- which accesses the value field of a CompletionStatus object
    • public static CompletionStatus from_int(int i) -- for creating an instance from one of the int members
    Since:
    JDK1.2
    See Also:
    SystemException

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int _COMPLETED_MAYBE
      The constant indicating that a method completed running before a SystemException was thrown.
      static int _COMPLETED_NO
      The constant indicating that a method completed running before a SystemException was thrown.
      static int _COMPLETED_YES
      The constant indicating that a method completed running before a SystemException was thrown.
      static CompletionStatus COMPLETED_MAYBE
      An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.
      static CompletionStatus COMPLETED_NO
      An instance of CompletionStatus initialized with the constant _COMPLETED_NO.
      static CompletionStatus COMPLETED_YES
      An instance of CompletionStatus initialized with the constant _COMPLETED_YES.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      static CompletionStatus from_int(int i)
      Creates a CompletionStatus object from the given int.
      int value()
      Retrieves the value of this CompletionStatus object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _COMPLETED_YES

        public static final int _COMPLETED_YES
        The constant indicating that a method completed running before a SystemException was thrown.
        See Also:
        Constant Field Values

      • _COMPLETED_NO

        public static final int _COMPLETED_NO
        The constant indicating that a method completed running before a SystemException was thrown.
        See Also:
        Constant Field Values

      • _COMPLETED_MAYBE

        public static final int _COMPLETED_MAYBE
        The constant indicating that a method completed running before a SystemException was thrown.
        See Also:
        Constant Field Values

      • COMPLETED_YES

        public static final CompletionStatus COMPLETED_YES
        An instance of CompletionStatus initialized with the constant _COMPLETED_YES.

      • COMPLETED_NO

        public static final CompletionStatus COMPLETED_NO
        An instance of CompletionStatus initialized with the constant _COMPLETED_NO.

      • COMPLETED_MAYBE

        public static final CompletionStatus COMPLETED_MAYBE
        An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.

    • Method Detail

      • value

        public int value()
        Retrieves the value of this CompletionStatus object.
        Returns:
        one of the possible CompletionStatus values: _COMPLETED_YES, _COMPLETED_NO, or _COMPLETED_MAYBE

      • from_int

        public static CompletionStatus from_int(int i)
        Creates a CompletionStatus object from the given int.
        Parameters:
        i - one of _COMPLETED_YES, _COMPLETED_NO, or _COMPLETED_MAYBE
        Returns:
        one of the possible CompletionStatus objects with values: _COMPLETED_YES, _COMPLETED_NO, or _COMPLETED_MAYBE
        Throws:
        BAD_PARAM - if the argument given is not one of the int constants defined in CompletionStatus
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CompletionStatusHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CompletionStatusHelper

  • java.lang.Object
    • org.omg.CORBA.CompletionStatusHelper

  • public abstract class CompletionStatusHelper
extends Object
    The Helper for CompletionStatus. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/CompletionStatusHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      CompletionStatusHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static CompletionStatus | extract(Any a)
      static String | id()
      static void | insert(Any a, CompletionStatus that)
      static CompletionStatus | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, CompletionStatus value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CompletionStatusHelper

        public CompletionStatusHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          CompletionStatus that)

      • extract

        public static CompletionStatus extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CompletionStatus read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         CompletionStatus value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Context (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class Context

  • java.lang.Object
    • org.omg.CORBA.Context

  • public abstract class Context
extends Object
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation. A Context object contains a list of properties in the form of NamedValue objects. These properties represent information about the client, the environment, or the circumstances of a request and generally are properties that might be inconvenient to pass as parameters.

    A Context object is created by first calling the ORB method get_default_context and then calling the method create_child on the default context.

    Each property in a Context object is represented by a NamedValue object. The property name is contained in the NamedValue object's name field, and the value associated with the name is contained in the Any object that was assigned to the NamedValue object's value field.

    Context properties can represent a portion of a client's or application's environment that is meant to be propagated to (and made implicitly part of) a server's environment. (Examples might be a window identifier or user preference information). Once a server has been invoked (that is, after the properties are propagated), the server may query its Context object for these properties using the method get_values.

    When an operation declaration includes a context clause, the stubs and skeletons will have an additional argument added for the context. When an operation invocation occurs, the ORB causes the properties that were named in the operation definition in IDL and that are present in the client's Context object to be provided in the Context object parameter to the invoked method.

    Context property names (which are strings) typically have the form of an OMG IDL identifier or a series of OMG IDL identifiers separated by periods. A context property name pattern is either a property name or a property name followed by a single "*". A property name pattern without a trailing "*" is said to match only itself. A property name pattern of the form "<name>*" matches any property name that starts with <name> and continues with zero or more additional characters.

    Property name patterns are used in the context clause of an operation definition and as a parameter for the method Context.get_values.

    Context objects may be "chained" together to achieve a particular defaulting behavior. A Context object created with the method create_child will be chained to its parent (the Context object that created it), and that means that the parent will be searched after the child in a search for property names.

    Properties defined in a particular Context object effectively override those properties in the next higher level. The scope used in a search for properties may be restricted by specifying a starting scope and by using the flag CTX_RESTRICT_SCOPE when invoking the method get_values.

    A Context object may be named for purposes of specifying a starting search scope.

    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Context()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract String context_name()
      Retrieves the name of this Context object.
      abstract Context create_child(String child_ctx_name)
      Creates a Context object with the given string as its name and with this Context object set as its parent.
      abstract void delete_values(String propname)
      Deletes from this Context object the NamedValue object(s) whose name field matches the given property name.
      abstract NVList get_values(String start_scope, int op_flags, String pattern)
      Retrieves the NamedValue objects whose name field matches the given name or name pattern.
      abstract Context parent()
      Retrieves the parent of this Context object.
      abstract void set_one_value(String propname, Any propvalue)
      Creates a NamedValue object and adds it to this Context object.
      abstract void set_values(NVList values)
      I Sets one or more property values in this Context object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Context

        public Context()

    • Method Detail

      • context_name

        public abstract String context_name()
        Retrieves the name of this Context object.
        Returns:
        the name of this Context object

      • parent

        public abstract Context parent()
        Retrieves the parent of this Context object.
        Returns:
        the Context object that is the parent of this Context object

      • create_child

        public abstract Context create_child(String child_ctx_name)
        Creates a Context object with the given string as its name and with this Context object set as its parent.

        The new Context object is chained into its parent Context object. This means that in a search for matching property names, if a match is not found in this context, the search will continue in the parent. If that is not successful, the search will continue in the grandparent, if there is one, and so on.

        Parameters:
        child_ctx_name - the String object to be set as the name of the new Context object
        Returns:
        the newly-created child Context object initialized with the specified name

      • set_one_value

        public abstract void set_one_value(String propname,
                                   Any propvalue)
        Creates a NamedValue object and adds it to this Context object. The name field of the new NamedValue object is set to the given string, the value field is set to the given Any object, and the flags field is set to zero.
        Parameters:
        propname - the name of the property to be set
        propvalue - the Any object to which the value of the property will be set. The Any object's value field contains the value to be associated with the given propname; the kind field must be set to TCKind.tk_string.

      • set_values

        public abstract void set_values(NVList values)
        I Sets one or more property values in this Context object. The NVList supplied to this method contains one or more NamedValue objects. In each NamedValue object, the name field holds the name of the property, and the flags field must be set to zero. The NamedValue object's value field contains an Any object, which, in turn, contains the value for the property. Since the value is always a string, the Any object must have the kind field of its TypeCode set to TCKind.tk_string.
        Parameters:
        values - an NVList containing the property names and associated values to be set
        See Also:
        get_values(java.lang.String, int, java.lang.String), NamedValue, Any

      • delete_values

        public abstract void delete_values(String propname)
        Deletes from this Context object the NamedValue object(s) whose name field matches the given property name. If the String object supplied for propname has a trailing wildcard character ("*"), then all NamedValue objects whose name fields match will be deleted. The search scope is always limited to this Context object.

        If no matching property is found, an exception is returned.

        Parameters:
        propname - name of the property to be deleted

      • get_values

        public abstract NVList get_values(String start_scope,
                                  int op_flags,
                                  String pattern)
        Retrieves the NamedValue objects whose name field matches the given name or name pattern. This method allows for wildcard searches, which means that there can be multiple matches and therefore multiple values returned. If the property is not found at the indicated level, the search continues up the context object tree until a match is found or all Context objects in the chain have been exhausted.

        If no match is found, an error is returned and no property list is returned.

        Parameters:
        start_scope - a String object indicating the context object level at which to initiate the search for the specified properties (for example, "_USER", "_GROUP", "_SYSTEM"). Valid scope names are implementation-specific. If a scope name is omitted, the search begins with the specified context object. If the specified scope name is not found, an exception is returned.
        op_flags - an operation flag. The one flag that may be specified is CTX_RESTRICT_SCOPE. If this flag is specified, searching is limited to the specified start_scope or this Context object.
        pattern - the property name whose values are to be retrieved. pattern may be a name or a name with a trailing wildcard character ("*").
        Returns:
        an NVList containing all the property values (in the form of NamedValue objects) whose associated property name matches the given name or name pattern
        See Also:
        set_values(org.omg.CORBA.NVList), NamedValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ContextList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ContextList

  • java.lang.Object
    • org.omg.CORBA.ContextList

  • public abstract class ContextList
extends Object
    An object containing a modifiable list of String objects that represent property names. This class is used in Request operations to describe the contexts that need to be resolved and sent with the invocation. (A context is resolved by giving a property name and getting back the value associated with it.) This is done by calling the Context method get_values and supplying a string from a ContextList object as the third parameter. The method get_values returns an NVList object containing the NamedValue objects that hold the value(s) identified by the given string.

    A ContextList object is created by the ORB, as illustrated here:

       ORB orb = ORB.init(args, null);
   org.omg.CORBA.ContextList ctxList = orb.create_context_list();
    The variable ctxList represents an empty ContextList object. Strings are added to the list with the method add, accessed with the method item, and removed with the method remove.
    Since:
    JDK1.2
    See Also:
    Context

    • Constructor Summary

      Constructors
      Constructor and Description
      ContextList()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void add(String ctx)
      Adds a String object to this ContextList object.
      abstract int count()
      Returns the number of String objects in this ContextList object.
      abstract String item(int index)
      Returns the String object at the given index.
      abstract void remove(int index)
      Removes the String object at the given index.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ContextList

        public ContextList()

    • Method Detail

      • count

        public abstract int count()
        Returns the number of String objects in this ContextList object.
        Returns:
        an int representing the number of Strings in this ContextList object

      • add

        public abstract void add(String ctx)
        Adds a String object to this ContextList object.
        Parameters:
        ctx - the String object to be added

      • item

        public abstract String item(int index)
                     throws Bounds
        Returns the String object at the given index.
        Parameters:
        index - the index of the string desired, with 0 being the index of the first string
        Returns:
        the string at the given index
        Throws:
        Bounds - if the index is greater than or equal to the number of strings in this ContextList object

      • remove

        public abstract void remove(int index)
                     throws Bounds
        Removes the String object at the given index. Note that the indices of all strings following the one removed are shifted down by one.
        Parameters:
        index - the index of the String object to be removed, with 0 designating the first string
        Throws:
        Bounds - if the index is greater than or equal to the number of String objects in this ContextList object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CTX_RESTRICT_SCOPE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface CTX_RESTRICT_SCOPE

  • public interface CTX_RESTRICT_SCOPE
    A flag that can be used as the second parameter to the method Context.get_values to restrict the search scope. When this flag is used, it restricts the search for context values to this particular Context object or to the scope specified in the first parameter to Context.get_values.

    Usage:

         NVList props = myContext.get_values("_USER",
                     CTX_RESTRICT_SCOPE.value, "id*");
    Since:
    JDK1.2
    See Also:
    Context.get_values(String, int, String)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The field containing the int value of a CTX_RESTRICT_SCOPE flag.

    • Field Detail

      • value

        static final int value
        The field containing the int value of a CTX_RESTRICT_SCOPE flag.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Current (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface Current

  • All Superinterfaces:
    CurrentOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    Current, Current

    public interface Current
extends CurrentOperations, Object, IDLEntity
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running. This information is accessed in a structured manner using interfaces derived from the Current interface defined in the CORBA module.

    Each ORB or CORBA service that needs its own context derives an interface from the CORBA module's Current. Users of the service can obtain an instance of the appropriate Current interface by invoking ORB::resolve_initial_references.

    org/omg/CORBA/Current.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CurrentHelper

  • java.lang.Object
    • org.omg.CORBA.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    The Helper for Current. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/CurrentHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      CurrentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Current value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CurrentHelper

        public CurrentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Current value)

      • narrow

        public static Current narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class CurrentHolder

  • java.lang.Object
    • org.omg.CORBA.CurrentHolder
  • All Implemented Interfaces:
    Streamable

    public final class CurrentHolder
extends Object
implements Streamable
    The Holder for Current. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/CurrentHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Current value

    • Constructor Summary

      Constructors
      Constructor and Description
      CurrentHolder()
      CurrentHolder(Current initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Current value

    • Constructor Detail

      • CurrentHolder

        public CurrentHolder()

      • CurrentHolder

        public CurrentHolder(Current initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface CurrentOperations

  • All Known Subinterfaces:
    Current, Current, Current, CurrentOperations, CurrentOperations

    public interface CurrentOperations
    The interface for Current. For more information on Operations interfaces, see "Generated Files". org/omg/CORBA/CurrentOperations.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CustomMarshal (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface CustomMarshal

  • All Known Subinterfaces:
    CustomValue

    public interface CustomMarshal
    An abstract value type that is meant to be used by the ORB, not the user. Semantically it is treated as a custom value type's implicit base class, although the custom valuetype does not actually inherit it in IDL. The implementer of a custom value type shall provide an implementation of the CustomMarshal operations. The manner in which this is done is specified in the IDL to Java langauge mapping. Each custom marshaled value type shall have its own implementation.
    See Also:
    DataInputStream

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void marshal(DataOutputStream os)
      Marshal method has to be implemented by the Customized Marshal class.
      void unmarshal(DataInputStream is)
      Unmarshal method has to be implemented by the Customized Marshal class.

    • Method Detail

      • marshal

        void marshal(DataOutputStream os)
        Marshal method has to be implemented by the Customized Marshal class. This is the method invoked for Marshalling.
        Parameters:
        os - a DataOutputStream

      • unmarshal

        void unmarshal(DataInputStream is)
        Unmarshal method has to be implemented by the Customized Marshal class. This is the method invoked for Unmarshalling.
        Parameters:
        is - a DataInputStream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DataInputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DataInputStream

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase

    public interface DataInputStream
extends ValueBase
    Defines the methods used to read primitive data types from input streams for unmarshaling custom value types. This interface is used by user written custom unmarshaling code for custom value types.
    See Also:
    DataOutputStream, CustomMarshal

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object read_Abstract()
      Reads an IDL Abstract interface from the input stream.
      void read_any_array(AnySeqHolder seq, int offset, int length)
      Reads array of IDL Anys from offset for length elements from the input stream.
      Any read_any()
      Reads an IDL Any value from the input stream.
      void read_boolean_array(BooleanSeqHolder seq, int offset, int length)
      Reads array of IDL booleans from offset for length elements from the input stream.
      boolean read_boolean()
      Reads an IDL boolean value from the input stream.
      void read_char_array(CharSeqHolder seq, int offset, int length)
      Reads array of IDL characters from offset for length elements from the input stream.
      char read_char()
      Reads an IDL character value from the input stream.
      void read_double_array(DoubleSeqHolder seq, int offset, int length)
      Reads array of IDL doubles from offset for length elements from the input stream.
      double read_double()
      Reads an IDL double from the input stream.
      void read_float_array(FloatSeqHolder seq, int offset, int length)
      Reads array of IDL floats from offset for length elements from the input stream.
      float read_float()
      Reads an IDL float from the input stream.
      void read_long_array(LongSeqHolder seq, int offset, int length)
      Reads array of IDL longs from offset for length elements from the input stream.
      int read_long()
      Reads an IDL long from the input stream.
      void read_longlong_array(LongLongSeqHolder seq, int offset, int length)
      Reads array of IDL long longs from offset for length elements from the input stream.
      long read_longlong()
      Reads an IDL long long from the input stream.
      Object read_Object()
      Reads an IDL CORBA::Object from the input stream.
      void read_octet_array(OctetSeqHolder seq, int offset, int length)
      Reads array of IDL octets from offset for length elements from the input stream.
      byte read_octet()
      Reads an IDL octet value from the input stream.
      void read_short_array(ShortSeqHolder seq, int offset, int length)
      Reads array of IDL shorts from offset for length elements from the input stream.
      short read_short()
      Reads an IDL short from the input stream.
      String read_string()
      Reads an IDL string from the input stream.
      TypeCode read_TypeCode()
      Reads an IDL typecode from the input stream.
      void read_ulong_array(ULongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned longs from offset for length elements from the input stream.
      int read_ulong()
      Reads an IDL unsigned long from the input stream.
      void read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned long longs from offset for length elements from the input stream.
      long read_ulonglong()
      Reads an unsigned IDL long long from the input stream.
      void read_ushort_array(UShortSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned shorts from offset for length elements from the input stream.
      short read_ushort()
      Reads an IDL unsigned short from the input stream.
      Serializable read_Value()
      Reads an IDL value type from the input stream.
      void read_wchar_array(WCharSeqHolder seq, int offset, int length)
      Reads array of IDL wide characters from offset for length elements from the input stream.
      char read_wchar()
      Reads an IDL wide character value from the input stream.
      String read_wstring()
      Reads an IDL wide string from the input stream.

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • Method Detail

      • read_any

        Any read_any()
        Reads an IDL Any value from the input stream.
        Returns:
        the Any read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_boolean

        boolean read_boolean()
        Reads an IDL boolean value from the input stream.
        Returns:
        the boolean read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_char

        char read_char()
        Reads an IDL character value from the input stream.
        Returns:
        the character read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_wchar

        char read_wchar()
        Reads an IDL wide character value from the input stream.
        Returns:
        the wide character read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_octet

        byte read_octet()
        Reads an IDL octet value from the input stream.
        Returns:
        the octet value read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_short

        short read_short()
        Reads an IDL short from the input stream.
        Returns:
        the short read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ushort

        short read_ushort()
        Reads an IDL unsigned short from the input stream.
        Returns:
        the unsigned short read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_long

        int read_long()
        Reads an IDL long from the input stream.
        Returns:
        the long read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulong

        int read_ulong()
        Reads an IDL unsigned long from the input stream.
        Returns:
        the unsigned long read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_longlong

        long read_longlong()
        Reads an IDL long long from the input stream.
        Returns:
        the long long read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulonglong

        long read_ulonglong()
        Reads an unsigned IDL long long from the input stream.
        Returns:
        the unsigned long long read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_float

        float read_float()
        Reads an IDL float from the input stream.
        Returns:
        the float read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_double

        double read_double()
        Reads an IDL double from the input stream.
        Returns:
        the double read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_string

        String read_string()
        Reads an IDL string from the input stream.
        Returns:
        the string read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_wstring

        String read_wstring()
        Reads an IDL wide string from the input stream.
        Returns:
        the wide string read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_Object

        Object read_Object()
        Reads an IDL CORBA::Object from the input stream.
        Returns:
        the CORBA::Object read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_Abstract

        Object read_Abstract()
        Reads an IDL Abstract interface from the input stream.
        Returns:
        the Abstract interface read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_Value

        Serializable read_Value()
        Reads an IDL value type from the input stream.
        Returns:
        the value type read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_TypeCode

        TypeCode read_TypeCode()
        Reads an IDL typecode from the input stream.
        Returns:
        the typecode read.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_any_array

        void read_any_array(AnySeqHolder seq,
                    int offset,
                    int length)
        Reads array of IDL Anys from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_boolean_array

        void read_boolean_array(BooleanSeqHolder seq,
                        int offset,
                        int length)
        Reads array of IDL booleans from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_char_array

        void read_char_array(CharSeqHolder seq,
                     int offset,
                     int length)
        Reads array of IDL characters from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_wchar_array

        void read_wchar_array(WCharSeqHolder seq,
                      int offset,
                      int length)
        Reads array of IDL wide characters from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_octet_array

        void read_octet_array(OctetSeqHolder seq,
                      int offset,
                      int length)
        Reads array of IDL octets from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_short_array

        void read_short_array(ShortSeqHolder seq,
                      int offset,
                      int length)
        Reads array of IDL shorts from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ushort_array

        void read_ushort_array(UShortSeqHolder seq,
                       int offset,
                       int length)
        Reads array of IDL unsigned shorts from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_long_array

        void read_long_array(LongSeqHolder seq,
                     int offset,
                     int length)
        Reads array of IDL longs from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulong_array

        void read_ulong_array(ULongSeqHolder seq,
                      int offset,
                      int length)
        Reads array of IDL unsigned longs from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulonglong_array

        void read_ulonglong_array(ULongLongSeqHolder seq,
                          int offset,
                          int length)
        Reads array of IDL unsigned long longs from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_longlong_array

        void read_longlong_array(LongLongSeqHolder seq,
                         int offset,
                         int length)
        Reads array of IDL long longs from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_float_array

        void read_float_array(FloatSeqHolder seq,
                      int offset,
                      int length)
        Reads array of IDL floats from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_double_array

        void read_double_array(DoubleSeqHolder seq,
                       int offset,
                       int length)
        Reads array of IDL doubles from offset for length elements from the input stream.
        Parameters:
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        Throws:
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DataOutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DataOutputStream

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase

    public interface DataOutputStream
extends ValueBase
    Defines the methods used to write primitive data types to output streams for marshalling custom value types. This interface is used by user written custom marshalling code for custom value types.
    See Also:
    DataInputStream, CustomMarshal

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void write_Abstract(Object value)
      Writes the IDL Abstract interface type to the output stream.
      void write_any_array(Any[] seq, int offset, int length)
      Writes the array of IDL Anys from offset for length elements to the output stream.
      void write_any(Any value)
      Writes the Any value to the output stream.
      void write_boolean_array(boolean[] seq, int offset, int length)
      Writes the array of IDL booleans from offset for length elements to the output stream.
      void write_boolean(boolean value)
      Writes the boolean value to the output stream.
      void write_char_array(char[] seq, int offset, int length)
      Writes the array of IDL characters from offset for length elements to the output stream.
      void write_char(char value)
      Writes the IDL character value to the output stream.
      void write_double_array(double[] seq, int offset, int length)
      Writes the array of IDL doubles from offset for length elements to the output stream.
      void write_double(double value)
      Writes the IDL double value to the output stream.
      void write_float_array(float[] seq, int offset, int length)
      Writes the array of IDL floats from offset for length elements to the output stream.
      void write_float(float value)
      Writes the IDL float value to the output stream.
      void write_long_array(int[] seq, int offset, int length)
      Writes the array of IDL longs from offset for length elements to the output stream.
      void write_long(int value)
      Writes the IDL long value (represented as a Java int) to the output stream.
      void write_longlong_array(long[] seq, int offset, int length)
      Writes the array of IDL long longs from offset for length elements to the output stream.
      void write_longlong(long value)
      Writes the IDL long long value (represented as a Java long) to the output stream.
      void write_Object(Object value)
      Writes the IDL CORBA::Object value to the output stream.
      void write_octet_array(byte[] seq, int offset, int length)
      Writes the array of IDL octets from offset for length elements to the output stream.
      void write_octet(byte value)
      Writes the IDL octet value (represented as a Java byte) to the output stream.
      void write_short_array(short[] seq, int offset, int length)
      Writes the array of IDL shorts from offset for length elements to the output stream.
      void write_short(short value)
      Writes the IDL short value to the output stream.
      void write_string(String value)
      Writes the IDL string value to the output stream.
      void write_TypeCode(TypeCode value)
      Writes the typecode to the output stream.
      void write_ulong_array(int[] seq, int offset, int length)
      Writes the array of IDL unsigned longs (represented as Java ints) from offset for length elements to the output stream.
      void write_ulong(int value)
      Writes the IDL unsigned long value (represented as a Java int) to the output stream.
      void write_ulonglong_array(long[] seq, int offset, int length)
      Writes the array of IDL unsigned long longs (represented as Java longs) from offset for length elements to the output stream.
      void write_ulonglong(long value)
      Writes the IDL unsigned long long value (represented as a Java long) to the output stream.
      void write_ushort_array(short[] seq, int offset, int length)
      Writes the array of IDL unsigned shorts (represented as Java shorts) from offset for length elements to the output stream.
      void write_ushort(short value)
      Writes the IDL unsigned short value (represented as a Java short value) to the output stream.
      void write_Value(Serializable value)
      Writes the IDL value type value to the output stream.
      void write_wchar_array(char[] seq, int offset, int length)
      Writes the array of IDL wide characters from offset for length elements to the output stream.
      void write_wchar(char value)
      Writes the IDL wide character value to the output stream.
      void write_wstring(String value)
      Writes the IDL wide string value (represented as a Java String) to the output stream.

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • Method Detail

      • write_any

        void write_any(Any value)
        Writes the Any value to the output stream.
        Parameters:
        value - The value to be written.

      • write_boolean

        void write_boolean(boolean value)
        Writes the boolean value to the output stream.
        Parameters:
        value - The value to be written.

      • write_char

        void write_char(char value)
        Writes the IDL character value to the output stream.
        Parameters:
        value - The value to be written.

      • write_wchar

        void write_wchar(char value)
        Writes the IDL wide character value to the output stream.
        Parameters:
        value - The value to be written.

      • write_octet

        void write_octet(byte value)
        Writes the IDL octet value (represented as a Java byte) to the output stream.
        Parameters:
        value - The value to be written.

      • write_short

        void write_short(short value)
        Writes the IDL short value to the output stream.
        Parameters:
        value - The value to be written.

      • write_ushort

        void write_ushort(short value)
        Writes the IDL unsigned short value (represented as a Java short value) to the output stream.
        Parameters:
        value - The value to be written.

      • write_long

        void write_long(int value)
        Writes the IDL long value (represented as a Java int) to the output stream.
        Parameters:
        value - The value to be written.

      • write_ulong

        void write_ulong(int value)
        Writes the IDL unsigned long value (represented as a Java int) to the output stream.
        Parameters:
        value - The value to be written.

      • write_longlong

        void write_longlong(long value)
        Writes the IDL long long value (represented as a Java long) to the output stream.
        Parameters:
        value - The value to be written.

      • write_ulonglong

        void write_ulonglong(long value)
        Writes the IDL unsigned long long value (represented as a Java long) to the output stream.
        Parameters:
        value - The value to be written.

      • write_float

        void write_float(float value)
        Writes the IDL float value to the output stream.
        Parameters:
        value - The value to be written.

      • write_double

        void write_double(double value)
        Writes the IDL double value to the output stream.
        Parameters:
        value - The value to be written.

      • write_string

        void write_string(String value)
        Writes the IDL string value to the output stream.
        Parameters:
        value - The value to be written.

      • write_wstring

        void write_wstring(String value)
        Writes the IDL wide string value (represented as a Java String) to the output stream.
        Parameters:
        value - The value to be written.

      • write_Object

        void write_Object(Object value)
        Writes the IDL CORBA::Object value to the output stream.
        Parameters:
        value - The value to be written.

      • write_Abstract

        void write_Abstract(Object value)
        Writes the IDL Abstract interface type to the output stream.
        Parameters:
        value - The value to be written.

      • write_Value

        void write_Value(Serializable value)
        Writes the IDL value type value to the output stream.
        Parameters:
        value - The value to be written.

      • write_TypeCode

        void write_TypeCode(TypeCode value)
        Writes the typecode to the output stream.
        Parameters:
        value - The value to be written.

      • write_any_array

        void write_any_array(Any[] seq,
                     int offset,
                     int length)
        Writes the array of IDL Anys from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_boolean_array

        void write_boolean_array(boolean[] seq,
                         int offset,
                         int length)
        Writes the array of IDL booleans from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_char_array

        void write_char_array(char[] seq,
                      int offset,
                      int length)
        Writes the array of IDL characters from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_wchar_array

        void write_wchar_array(char[] seq,
                       int offset,
                       int length)
        Writes the array of IDL wide characters from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_octet_array

        void write_octet_array(byte[] seq,
                       int offset,
                       int length)
        Writes the array of IDL octets from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_short_array

        void write_short_array(short[] seq,
                       int offset,
                       int length)
        Writes the array of IDL shorts from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_ushort_array

        void write_ushort_array(short[] seq,
                        int offset,
                        int length)
        Writes the array of IDL unsigned shorts (represented as Java shorts) from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_long_array

        void write_long_array(int[] seq,
                      int offset,
                      int length)
        Writes the array of IDL longs from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_ulong_array

        void write_ulong_array(int[] seq,
                       int offset,
                       int length)
        Writes the array of IDL unsigned longs (represented as Java ints) from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_ulonglong_array

        void write_ulonglong_array(long[] seq,
                           int offset,
                           int length)
        Writes the array of IDL unsigned long longs (represented as Java longs) from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_longlong_array

        void write_longlong_array(long[] seq,
                          int offset,
                          int length)
        Writes the array of IDL long longs from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_float_array

        void write_float_array(float[] seq,
                       int offset,
                       int length)
        Writes the array of IDL floats from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_double_array

        void write_double_array(double[] seq,
                        int offset,
                        int length)
        Writes the array of IDL doubles from offset for length elements to the output stream.
        Parameters:
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DATA_CONVERSION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DATA_CONVERSION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.DATA_CONVERSION
  • All Implemented Interfaces:
    Serializable

    public final class DATA_CONVERSION
extends SystemException
    This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa. For example, DATA_CONVERSION can be raised if wide character codeset conversion fails, or if an ORB cannot convert floating point values between different representations.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section meaning of minor codes to see the minor codes for this exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      DATA_CONVERSION()
      Constructs a DATA_CONVERSION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      DATA_CONVERSION(int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
      DATA_CONVERSION(String s)
      Constructs a DATA_CONVERSION exception with the specified detail.
      DATA_CONVERSION(String s, int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DATA_CONVERSION

        public DATA_CONVERSION()
        Constructs a DATA_CONVERSION exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • DATA_CONVERSION

        public DATA_CONVERSION(String s)
        Constructs a DATA_CONVERSION exception with the specified detail.
        Parameters:
        s - the String containing a detail message

      • DATA_CONVERSION

        public DATA_CONVERSION(int minor,
                       CompletionStatus completed)
        Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • DATA_CONVERSION

        public DATA_CONVERSION(String s,
                       int minor,
                       CompletionStatus completed)
        Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefinitionKind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DefinitionKind

  • java.lang.Object
    • org.omg.CORBA.DefinitionKind
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class DefinitionKind
extends Object
implements IDLEntity
    The class that provides the constants used to identify the type of an Interface Repository object. This class contains two kinds of constants, those that are an int and those that are an instance of the class DefinitionKind. This class provides the method from_int, which given one of the int constants, creates the corresponding DefinitionKind instance. It also provides the method value, which returns the int constant that is the value for a DefinitionKind instance.
    See Also:
    IRObject

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int _dk_AbstractInterface
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Alias
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_all
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Array
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Attribute
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Constant
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Enum
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Exception
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Fixed
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Interface
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Module
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Native
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_none
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Operation
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Primitive
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Repository
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Sequence
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_String
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Struct
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Typedef
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Union
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Value
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_ValueBox
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_ValueMember
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Wstring
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static DefinitionKind dk_AbstractInterface
      The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.
      static DefinitionKind dk_Alias
      The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.
      static DefinitionKind dk_all
      The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate.
      static DefinitionKind dk_Array
      The static instance of DefinitionKind indicating that an Interface Repository object is an Array.
      static DefinitionKind dk_Attribute
      The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.
      static DefinitionKind dk_Constant
      The static instance of DefinitionKind indicating that an Interface Repository object is a constant.
      static DefinitionKind dk_Enum
      The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.
      static DefinitionKind dk_Exception
      The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.
      static DefinitionKind dk_Fixed
      The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.
      static DefinitionKind dk_Interface
      The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.
      static DefinitionKind dk_Module
      The static instance of DefinitionKind indicating that an Interface Repository object is a Module.
      static DefinitionKind dk_Native
      The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.
      static DefinitionKind dk_none
      The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.
      static DefinitionKind dk_Operation
      The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.
      static DefinitionKind dk_Primitive
      The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.
      static DefinitionKind dk_Repository
      The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.
      static DefinitionKind dk_Sequence
      The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.
      static DefinitionKind dk_String
      The static instance of DefinitionKind indicating that an Interface Repository object is a String.
      static DefinitionKind dk_Struct
      The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.
      static DefinitionKind dk_Typedef
      The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.
      static DefinitionKind dk_Union
      The static instance of DefinitionKind indicating that an Interface Repository object is a Union.
      static DefinitionKind dk_Value
      The static instance of DefinitionKind indicating that an Interface Repository object is a Value.
      static DefinitionKind dk_ValueBox
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.
      static DefinitionKind dk_ValueMember
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.
      static DefinitionKind dk_Wstring
      The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected DefinitionKind(int _value)
      Constructs a DefinitionKind object with its _value field initialized with the given value.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      static DefinitionKind from_int(int i)
      Creates a DefinitionKind instance corresponding to the given code .
      int value()
      Returns the int constant identifying the type of an IR object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _dk_none

        public static final int _dk_none
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_all

        public static final int _dk_all
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Attribute

        public static final int _dk_Attribute
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Constant

        public static final int _dk_Constant
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Exception

        public static final int _dk_Exception
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Interface

        public static final int _dk_Interface
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Module

        public static final int _dk_Module
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Operation

        public static final int _dk_Operation
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Typedef

        public static final int _dk_Typedef
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Alias

        public static final int _dk_Alias
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Struct

        public static final int _dk_Struct
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Union

        public static final int _dk_Union
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Enum

        public static final int _dk_Enum
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Primitive

        public static final int _dk_Primitive
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_String

        public static final int _dk_String
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Sequence

        public static final int _dk_Sequence
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Array

        public static final int _dk_Array
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Repository

        public static final int _dk_Repository
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Wstring

        public static final int _dk_Wstring
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Fixed

        public static final int _dk_Fixed
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Value

        public static final int _dk_Value
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_ValueBox

        public static final int _dk_ValueBox
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_ValueMember

        public static final int _dk_ValueMember
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_Native

        public static final int _dk_Native
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • _dk_AbstractInterface

        public static final int _dk_AbstractInterface
        The constant that indicates that an Interface Repository object does not have a definition kind.
        See Also:
        Constant Field Values

      • dk_none

        public static final DefinitionKind dk_none
        The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.

      • dk_all

        public static final DefinitionKind dk_all
        The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate. The Container's contents method makes use of this constant to return all contained definitions of any kind.

      • dk_Attribute

        public static final DefinitionKind dk_Attribute
        The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.

      • dk_Constant

        public static final DefinitionKind dk_Constant
        The static instance of DefinitionKind indicating that an Interface Repository object is a constant.

      • dk_Exception

        public static final DefinitionKind dk_Exception
        The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.

      • dk_Interface

        public static final DefinitionKind dk_Interface
        The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.

      • dk_Module

        public static final DefinitionKind dk_Module
        The static instance of DefinitionKind indicating that an Interface Repository object is a Module.

      • dk_Operation

        public static final DefinitionKind dk_Operation
        The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.

      • dk_Typedef

        public static final DefinitionKind dk_Typedef
        The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.

      • dk_Alias

        public static final DefinitionKind dk_Alias
        The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.

      • dk_Struct

        public static final DefinitionKind dk_Struct
        The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.

      • dk_Union

        public static final DefinitionKind dk_Union
        The static instance of DefinitionKind indicating that an Interface Repository object is a Union.

      • dk_Enum

        public static final DefinitionKind dk_Enum
        The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.

      • dk_Primitive

        public static final DefinitionKind dk_Primitive
        The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.

      • dk_String

        public static final DefinitionKind dk_String
        The static instance of DefinitionKind indicating that an Interface Repository object is a String.

      • dk_Sequence

        public static final DefinitionKind dk_Sequence
        The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.

      • dk_Array

        public static final DefinitionKind dk_Array
        The static instance of DefinitionKind indicating that an Interface Repository object is an Array.

      • dk_Repository

        public static final DefinitionKind dk_Repository
        The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.

      • dk_Wstring

        public static final DefinitionKind dk_Wstring
        The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.

      • dk_Fixed

        public static final DefinitionKind dk_Fixed
        The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.

      • dk_Value

        public static final DefinitionKind dk_Value
        The static instance of DefinitionKind indicating that an Interface Repository object is a Value.

      • dk_ValueBox

        public static final DefinitionKind dk_ValueBox
        The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.

      • dk_ValueMember

        public static final DefinitionKind dk_ValueMember
        The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.

      • dk_Native

        public static final DefinitionKind dk_Native
        The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.

      • dk_AbstractInterface

        public static final DefinitionKind dk_AbstractInterface
        The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.

    • Constructor Detail

      • DefinitionKind

        protected DefinitionKind(int _value)
        Constructs a DefinitionKind object with its _value field initialized with the given value.
        Parameters:
        _value - one of the int constants defined in the class DefinitionKind

    • Method Detail

      • value

        public int value()
        Returns the int constant identifying the type of an IR object.
        Returns:
        the int constant from the class DefinitionKind that is the value of this DefinitionKind instance

      • from_int

        public static DefinitionKind from_int(int i)
        Creates a DefinitionKind instance corresponding to the given code .
        Parameters:
        i - one of the int constants from the class DefinitionKind
        Returns:
        the DefinitionKind instance corresponding to the given code
        Throws:
        BAD_PARAM - if the given parameter is not one of the int constants from the class DefinitionKind
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefinitionKindHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DefinitionKindHelper

  • java.lang.Object
    • org.omg.CORBA.DefinitionKindHelper

  • public abstract class DefinitionKindHelper
extends Object
    The Helper for DefinitionKind. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/DefinitionKindHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      DefinitionKindHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DefinitionKind | extract(Any a)
      static String | id()
      static void | insert(Any a, DefinitionKind that)
      static DefinitionKind | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DefinitionKind value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefinitionKindHelper

        public DefinitionKindHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DefinitionKind that)

      • extract

        public static DefinitionKind extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DefinitionKind read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DefinitionKind value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DomainManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DomainManager

  • All Superinterfaces:
    DomainManagerOperations, IDLEntity, Object, Serializable

    public interface DomainManager
extends DomainManagerOperations, Object, IDLEntity
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies. The DomainManager has associated with it the policy objects for a particular domain. The domain manager also records the membership of the domain and provides the means to add and remove members. The domain manager is itself a member of a domain, possibly the domain it manages. The domain manager provides mechanisms for establishing and navigating relationships to superior and subordinate domains and creating and accessing policies.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.DomainManagerOperations

        get_domain_policy

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DomainManagerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DomainManagerOperations

  • All Known Subinterfaces:
    DomainManager

    public interface DomainManagerOperations
    Provides the DomainManager with the means to access policies.

    The DomainManager has associated with it the policy objects for a particular domain. The domain manager also records the membership of the domain and provides the means to add and remove members. The domain manager is itself a member of a domain, possibly the domain it manages. The domain manager provides mechanisms for establishing and navigating relationships to superior and subordinate domains and creating and accessing policies.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Policy get_domain_policy(int policy_type)
      This returns the policy of the specified type for objects in this domain.

    • Method Detail

      • get_domain_policy

        Policy get_domain_policy(int policy_type)
        This returns the policy of the specified type for objects in this domain. The types of policies available are domain specific. See the CORBA specification for a list of standard ORB policies.
        Parameters:
        policy_type - Type of policy to request
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DoubleHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DoubleHolder

  • java.lang.Object
    • org.omg.CORBA.DoubleHolder
  • All Implemented Interfaces:
    Streamable

    public final class DoubleHolder
extends Object
implements Streamable
    The Holder for Double. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a double that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL double as an "out" or "inout" parameter, the programmer must pass an instance of DoubleHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myDoubleHolder is an instance of DoubleHolder, the value stored in its value field can be accessed with myDoubleHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      double value
      The double value held by this DoubleHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleHolder()
      Constructs a new DoubleHolder object with its value field initialized to 0.0.
      DoubleHolder(double initial)
      Constructs a new DoubleHolder object for the given double.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Read a double value from the input stream and store it in the value member.
      TypeCode _type()
      Return the TypeCode of this holder object.
      void _write(OutputStream output)
      Write the double value stored in this holder to an OutputStream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public double value
        The double value held by this DoubleHolder object.

    • Constructor Detail

      • DoubleHolder

        public DoubleHolder()
        Constructs a new DoubleHolder object with its value field initialized to 0.0.

      • DoubleHolder

        public DoubleHolder(double initial)
        Constructs a new DoubleHolder object for the given double.
        Parameters:
        initial - the double with which to initialize the value field of the new DoubleHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Read a double value from the input stream and store it in the value member.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream to read from.

      • _write

        public void _write(OutputStream output)
        Write the double value stored in this holder to an OutputStream.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream to write into.

      • _type

        public TypeCode _type()
        Return the TypeCode of this holder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DoubleSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DoubleSeqHelper

  • java.lang.Object
    • org.omg.CORBA.DoubleSeqHelper

  • public abstract class DoubleSeqHelper
extends Object
    The Helper for DoubleSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/DoubleSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static double[] | extract(Any a)
      static String | id()
      static void | insert(Any a, double[] that)
      static double[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, double[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DoubleSeqHelper

        public DoubleSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          double[] that)

      • extract

        public static double[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static double[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         double[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DoubleSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DoubleSeqHolder

  • java.lang.Object
    • org.omg.CORBA.DoubleSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class DoubleSeqHolder
extends Object
implements Streamable
    The Holder for DoubleSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/DoubleSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      double[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      DoubleSeqHolder()
      DoubleSeqHolder(double[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public double[] value

    • Constructor Detail

      • DoubleSeqHolder

        public DoubleSeqHolder()

      • DoubleSeqHolder

        public DoubleSeqHolder(double[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynamicImplementation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class DynamicImplementation

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA.DynamicImplementation
  • All Implemented Interfaces:
    Object
    Direct Known Subclasses:
    _BindingIteratorImplBase, _NamingContextImplBase
    Deprecated.
    org.omg.CORBA.DynamicImplementation

    @Deprecated
public class DynamicImplementation
extends ObjectImpl

    • Constructor Summary

      Constructors
      Constructor and Description
      DynamicImplementation()
      Deprecated.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      String[] _ids()
      Deprecated.
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void invoke(ServerRequest request)
      Deprecated.
      Deprecated by Portable Object Adapter

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • DynamicImplementation

        public DynamicImplementation()
        Deprecated.

    • Method Detail

      • invoke

        @Deprecated
public void invoke(ServerRequest request)
        Deprecated. Deprecated by Portable Object Adapter

      • _ids

        public String[] _ids()
        Deprecated.
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAny (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynAny

  • All Superinterfaces:
    Object
    All Known Subinterfaces:
    DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue
    Deprecated.
    Use the new DynAny instead

    @Deprecated
public interface DynAny
extends Object
    Enables org.omg.CORBA.Any values to be dynamically interpreted (traversed) and constructed. A DynAny object is associated with a data value which may correspond to a copy of the value inserted into an Any. The DynAny APIs enable traversal of the data value associated with an Any at runtime and extraction of the primitive constituents of the data value.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      void assign(DynAny dyn_any)
      Deprecated.
      Copy the contents from one Dynamic Any into another.
      DynAny copy()
      Deprecated.
      Clones this DynAny object.
      DynAny current_component()
      Deprecated.
      Returns a DynAny object reference that can be used to get/set the value of the component currently accessed.
      void destroy()
      Deprecated.
      Destroys this DynAny object and frees any resources used to represent the data value associated with it.
      void from_any(Any value)
      Deprecated.
      Make a DynAny object from an Any object.
      Any get_any()
      Deprecated.
      Retrieves the org.omg.CORBA.Any contained in this DynAny object.
      boolean get_boolean()
      Deprecated.
      Retrieves the boolean contained in this DynAny object.
      char get_char()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      double get_double()
      Deprecated.
      Retrieves the double contained in this DynAny object.
      float get_float()
      Deprecated.
      Retrieves the float contained in this DynAny object.
      int get_long()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long get_longlong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      byte get_octet()
      Deprecated.
      Retrieves the byte contained in this DynAny object.
      Object get_reference()
      Deprecated.
      Retrieves the org.omg.CORBA.Other contained in this DynAny object.
      short get_short()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      String get_string()
      Deprecated.
      Retrieves the String contained in this DynAny object.
      TypeCode get_typecode()
      Deprecated.
      Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
      int get_ulong()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long get_ulonglong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      short get_ushort()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      Serializable get_val()
      Deprecated.
      Retrieves the java.io.Serializable object contained in this DynAny object.
      char get_wchar()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      String get_wstring()
      Deprecated.
      Retrieves the String contained in this DynAny object.
      void insert_any(Any value)
      Deprecated.
      Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
      void insert_boolean(boolean value)
      Deprecated.
      Inserts the given boolean as the value for this DynAny object.
      void insert_char(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void insert_double(double value)
      Deprecated.
      Inserts the given double as the value for this DynAny object.
      void insert_float(float value)
      Deprecated.
      Inserts the given float as the value for this DynAny object.
      void insert_long(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void insert_longlong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void insert_octet(byte value)
      Deprecated.
      Inserts the given byte as the value for this DynAny object.
      void insert_reference(Object value)
      Deprecated.
      Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
      void insert_short(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void insert_string(String value)
      Deprecated.
      Inserts the given String object as the value for this DynAny object.
      void insert_typecode(TypeCode value)
      Deprecated.
      Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
      void insert_ulong(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void insert_ulonglong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void insert_ushort(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void insert_val(Serializable value)
      Deprecated.
      Inserts the given java.io.Serializable object as the value for this DynAny object.
      void insert_wchar(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void insert_wstring(String value)
      Deprecated.
      Inserts the given String as the value for this DynAny object.
      boolean next()
      Deprecated.
      Moves to the next component of this DynAny object.
      void rewind()
      Deprecated.
      Moves the internal pointer to the first component.
      boolean seek(int index)
      Deprecated.
      Moves the internal pointer to the given index.
      Any to_any()
      Deprecated.
      Convert a DynAny object to an Any object.
      TypeCode type()
      Deprecated.
      Returns the TypeCode of the object inserted into this DynAny.

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • type

        TypeCode type()
        Deprecated.
        Returns the TypeCode of the object inserted into this DynAny.
        Returns:
        the TypeCode object.

      • assign

        void assign(DynAny dyn_any)
     throws Invalid
        Deprecated.
        Copy the contents from one Dynamic Any into another.
        Parameters:
        dyn_any - the DynAny object whose contents are assigned to this DynAny.
        Throws:
        Invalid - if the source DynAny is invalid

      • from_any

        void from_any(Any value)
       throws Invalid
        Deprecated.
        Make a DynAny object from an Any object.
        Parameters:
        value - the Any object.
        Throws:
        Invalid - if the source Any object is empty or bad

      • to_any

        Any to_any()
    throws Invalid
        Deprecated.
        Convert a DynAny object to an Any object.
        Returns:
        the Any object.
        Throws:
        Invalid - if this DynAny is empty or bad. created or does not contain a meaningful value

      • destroy

        void destroy()
        Deprecated.
        Destroys this DynAny object and frees any resources used to represent the data value associated with it. This method also destroys all DynAny objects obtained from it.

        Destruction of DynAny objects should be handled with care, taking into account issues dealing with the representation of data values associated with DynAny objects. A programmer who wants to destroy a DynAny object but still be able to manipulate some component of the data value associated with it, should first create a DynAny object for the component and then make a copy of the created DynAny object.

      • copy

        DynAny copy()
        Deprecated.
        Clones this DynAny object.
        Returns:
        a copy of this DynAny object

      • insert_boolean

        void insert_boolean(boolean value)
             throws InvalidValue
        Deprecated.
        Inserts the given boolean as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the boolean to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_octet

        void insert_octet(byte value)
           throws InvalidValue
        Deprecated.
        Inserts the given byte as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the byte to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_char

        void insert_char(char value)
          throws InvalidValue
        Deprecated.
        Inserts the given char as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the char to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_short

        void insert_short(short value)
           throws InvalidValue
        Deprecated.
        Inserts the given short as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the short to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_ushort

        void insert_ushort(short value)
            throws InvalidValue
        Deprecated.
        Inserts the given short as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the short to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_long

        void insert_long(int value)
          throws InvalidValue
        Deprecated.
        Inserts the given int as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the int to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_ulong

        void insert_ulong(int value)
           throws InvalidValue
        Deprecated.
        Inserts the given int as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the int to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_float

        void insert_float(float value)
           throws InvalidValue
        Deprecated.
        Inserts the given float as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the float to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_double

        void insert_double(double value)
            throws InvalidValue
        Deprecated.
        Inserts the given double as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the double to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_string

        void insert_string(String value)
            throws InvalidValue
        Deprecated.
        Inserts the given String object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the String to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_reference

        void insert_reference(Object value)
               throws InvalidValue
        Deprecated.
        Inserts the given org.omg.CORBA.Object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the org.omg.CORBA.Object to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_typecode

        void insert_typecode(TypeCode value)
              throws InvalidValue
        Deprecated.
        Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the org.omg.CORBA.TypeCode to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_longlong

        void insert_longlong(long value)
              throws InvalidValue
        Deprecated.
        Inserts the given long as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the long to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_ulonglong

        void insert_ulonglong(long value)
               throws InvalidValue
        Deprecated.
        Inserts the given long as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the long to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_wchar

        void insert_wchar(char value)
           throws InvalidValue
        Deprecated.
        Inserts the given char as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the char to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_wstring

        void insert_wstring(String value)
             throws InvalidValue
        Deprecated.
        Inserts the given String as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the String to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_any

        void insert_any(Any value)
         throws InvalidValue
        Deprecated.
        Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the org.omg.CORBA.Any object to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_val

        void insert_val(Serializable value)
         throws InvalidValue
        Deprecated.
        Inserts the given java.io.Serializable object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        Parameters:
        value - the java.io.Serializable object to insert into this DynAny object
        Throws:
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • get_val

        Serializable get_val()
              throws TypeMismatch
        Deprecated.
        Retrieves the java.io.Serializable object contained in this DynAny object.
        Returns:
        the java.io.Serializable object that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a java.io.Serializable object

      • get_boolean

        boolean get_boolean()
             throws TypeMismatch
        Deprecated.
        Retrieves the boolean contained in this DynAny object.
        Returns:
        the boolean that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a boolean

      • get_octet

        byte get_octet()
        throws TypeMismatch
        Deprecated.
        Retrieves the byte contained in this DynAny object.
        Returns:
        the byte that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a byte

      • get_char

        char get_char()
       throws TypeMismatch
        Deprecated.
        Retrieves the char contained in this DynAny object.
        Returns:
        the char that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a char

      • get_short

        short get_short()
         throws TypeMismatch
        Deprecated.
        Retrieves the short contained in this DynAny object.
        Returns:
        the short that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a short

      • get_ushort

        short get_ushort()
          throws TypeMismatch
        Deprecated.
        Retrieves the short contained in this DynAny object.
        Returns:
        the short that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a short

      • get_long

        int get_long()
      throws TypeMismatch
        Deprecated.
        Retrieves the int contained in this DynAny object.
        Returns:
        the int that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a int

      • get_ulong

        int get_ulong()
       throws TypeMismatch
        Deprecated.
        Retrieves the int contained in this DynAny object.
        Returns:
        the int that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a int

      • get_float

        float get_float()
         throws TypeMismatch
        Deprecated.
        Retrieves the float contained in this DynAny object.
        Returns:
        the float that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a float

      • get_double

        double get_double()
           throws TypeMismatch
        Deprecated.
        Retrieves the double contained in this DynAny object.
        Returns:
        the double that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a double

      • get_string

        String get_string()
           throws TypeMismatch
        Deprecated.
        Retrieves the String contained in this DynAny object.
        Returns:
        the String that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a String

      • get_reference

        Object get_reference()
              throws TypeMismatch
        Deprecated.
        Retrieves the org.omg.CORBA.Other contained in this DynAny object.
        Returns:
        the org.omg.CORBA.Other that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for an org.omg.CORBA.Other

      • get_typecode

        TypeCode get_typecode()
               throws TypeMismatch
        Deprecated.
        Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
        Returns:
        the org.omg.CORBA.TypeCode that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a org.omg.CORBA.TypeCode

      • get_longlong

        long get_longlong()
           throws TypeMismatch
        Deprecated.
        Retrieves the long contained in this DynAny object.
        Returns:
        the long that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a long

      • get_ulonglong

        long get_ulonglong()
            throws TypeMismatch
        Deprecated.
        Retrieves the long contained in this DynAny object.
        Returns:
        the long that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a long

      • get_wchar

        char get_wchar()
        throws TypeMismatch
        Deprecated.
        Retrieves the char contained in this DynAny object.
        Returns:
        the char that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a char

      • get_wstring

        String get_wstring()
            throws TypeMismatch
        Deprecated.
        Retrieves the String contained in this DynAny object.
        Returns:
        the String that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a String

      • get_any

        Any get_any()
     throws TypeMismatch
        Deprecated.
        Retrieves the org.omg.CORBA.Any contained in this DynAny object.
        Returns:
        the org.omg.CORBA.Any that is the value for this DynAny object
        Throws:
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for an org.omg.CORBA.Any

      • current_component

        DynAny current_component()
        Deprecated.
        Returns a DynAny object reference that can be used to get/set the value of the component currently accessed. The appropriate insert method can be called on the resulting DynAny object to initialize the component. The appropriate get method can be called on the resulting DynAny object to extract the value of the component.
        Returns:
        a DynAny object reference that can be used to retrieve or set the value of the component currently accessed

      • next

        boolean next()
        Deprecated.
        Moves to the next component of this DynAny object. This method is used for iterating through the components of a constructed type, effectively moving a pointer from one component to the next. The pointer starts out on the first component when a DynAny object is created.
        Returns:
        true if the pointer points to a component; false if there are no more components or this DynAny is associated with a basic type rather than a constructed type

      • seek

        boolean seek(int index)
        Deprecated.
        Moves the internal pointer to the given index. Logically, this method sets a new offset for this pointer.
        Parameters:
        index - an int indicating the position to which the pointer should move. The first position is 0.
        Returns:
        true if the pointer points to a component; false if there is no component at the designated index. If this DynAny object is associated with a basic type, this method returns false for any index other than 0.

      • rewind

        void rewind()
        Deprecated.
        Moves the internal pointer to the first component.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynArray (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynArray

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynArray instead

    @Deprecated
public interface DynArray
extends Object, DynAny
    Represents a DynAny object associated with an array.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      Any[] get_elements()
      Deprecated.
      Returns the value of all the elements of this array.
      void set_elements(Any[] value)
      Deprecated.
      Sets the value of this DynArray object to the given array.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • get_elements

        Any[] get_elements()
        Deprecated.
        Returns the value of all the elements of this array.
        Returns:
        the array of Any objects that is the value for this DynArray object
        See Also:
        set_elements(org.omg.CORBA.Any[])

      • set_elements

        void set_elements(Any[] value)
           throws InvalidSeq
        Deprecated.
        Sets the value of this DynArray object to the given array.
        Parameters:
        value - the array of Any objects
        Throws:
        InvalidSeq - if the sequence is bad
        See Also:
        get_elements()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynEnum (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynEnum

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynEnum instead

    @Deprecated
public interface DynEnum
extends Object, DynAny
    Represents a DynAny object associated with an IDL enum.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      String value_as_string()
      Deprecated.
      Return the value of the IDL enum stored in this DynEnum as a string.
      void value_as_string(String arg)
      Deprecated.
      Set a particular enum in this DynEnum.
      int value_as_ulong()
      Deprecated.
      Return the value of the IDL enum as a Java int.
      void value_as_ulong(int arg)
      Deprecated.
      Set the value of the IDL enum.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • value_as_string

        String value_as_string()
        Deprecated.
        Return the value of the IDL enum stored in this DynEnum as a string.
        Returns:
        the stringified value.

      • value_as_string

        void value_as_string(String arg)
        Deprecated.
        Set a particular enum in this DynEnum.
        Parameters:
        arg - the string corresponding to the value.

      • value_as_ulong

        int value_as_ulong()
        Deprecated.
        Return the value of the IDL enum as a Java int.
        Returns:
        the integer value.

      • value_as_ulong

        void value_as_ulong(int arg)
        Deprecated.
        Set the value of the IDL enum.
        Parameters:
        arg - the int value of the enum.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynFixed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynFixed

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynFixed instead

    @Deprecated
public interface DynFixed
extends Object, DynAny
    Represents a DynAny object that is associated with an IDL fixed type.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      byte[] get_value()
      Deprecated.
      Returns the value of the fixed type represented in this DynFixed object.
      void set_value(byte[] val)
      Deprecated.
      Sets the given fixed type instance as the value for this DynFixed object.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • get_value

        byte[] get_value()
        Deprecated.
        Returns the value of the fixed type represented in this DynFixed object.
        Returns:
        the value as a byte array
        See Also:
        set_value(byte[])

      • set_value

        void set_value(byte[] val)
        throws InvalidValue
        Deprecated.
        Sets the given fixed type instance as the value for this DynFixed object.
        Parameters:
        val - the value of the fixed type as a byte array
        Throws:
        InvalidValue - if the given argument is bad
        See Also:
        get_value()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynSequence (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynSequence

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynSequence instead

    @Deprecated
public interface DynSequence
extends Object, DynAny
    The representation of a DynAny object that is associated with an IDL sequence.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      Any[] get_elements()
      Deprecated.
      Returns the value of every element in this sequence.
      int length()
      Deprecated.
      Returns the length of the sequence represented by this DynFixed object.
      void length(int arg)
      Deprecated.
      Sets the length of the sequence represented by this DynFixed object to the given argument.
      void set_elements(Any[] value)
      Deprecated.
      Sets the values of all elements in this sequence with the given array.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • length

        int length()
        Deprecated.
        Returns the length of the sequence represented by this DynFixed object.
        Returns:
        the length of the sequence

      • length

        void length(int arg)
        Deprecated.
        Sets the length of the sequence represented by this DynFixed object to the given argument.
        Parameters:
        arg - the length of the sequence

      • get_elements

        Any[] get_elements()
        Deprecated.
        Returns the value of every element in this sequence.
        Returns:
        an array of Any objects containing the values in the sequence
        See Also:
        set_elements(org.omg.CORBA.Any[])

      • set_elements

        void set_elements(Any[] value)
           throws InvalidSeq
        Deprecated.
        Sets the values of all elements in this sequence with the given array.
        Parameters:
        value - the array of Any objects to be set
        Throws:
        InvalidSeq - if the array of values is bad
        See Also:
        get_elements()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynStruct (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynStruct

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynStruct instead

    @Deprecated
public interface DynStruct
extends Object, DynAny
    The representation of a DynAny object that is associated with an IDL struct.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      TCKind current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the kind of the current member.
      String current_member_name()
      Deprecated.
      During a traversal, returns the name of the current member.
      NameValuePair[] get_members()
      Deprecated.
      Returns an array containing all the members of the stored struct.
      void set_members(NameValuePair[] value)
      Deprecated.
      Set the members of the struct.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • current_member_name

        String current_member_name()
        Deprecated.
        During a traversal, returns the name of the current member.
        Returns:
        the string name of the current member

      • current_member_kind

        TCKind current_member_kind()
        Deprecated.
        Returns the TCKind object that describes the kind of the current member.
        Returns:
        the TCKind object that describes the current member

      • get_members

        NameValuePair[] get_members()
        Deprecated.
        Returns an array containing all the members of the stored struct.
        Returns:
        the array of name-value pairs
        See Also:
        set_members(org.omg.CORBA.NameValuePair[])

      • set_members

        void set_members(NameValuePair[] value)
          throws InvalidSeq
        Deprecated.
        Set the members of the struct.
        Parameters:
        value - the array of name-value pairs.
        Throws:
        InvalidSeq - if the given argument is invalid
        See Also:
        get_members()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynUnion (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynUnion

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynUnion instead

    @Deprecated
public interface DynUnion
extends Object, DynAny
    The DynUnion interface represents a DynAny object that is associated with an IDL union. Union values can be traversed using the operations defined in DynAny. The first component in the union corresponds to the discriminator; the second corresponds to the actual value of the union. Calling the method next() twice allows you to access both components.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      TCKind discriminator_kind()
      Deprecated.
      Returns the TCKind object associated with the discriminator of this union.
      DynAny discriminator()
      Deprecated.
      Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
      TCKind member_kind()
      Deprecated.
      Returns the TCKind associated with the member of this union.
      String member_name()
      Deprecated.
      Allows for the inspection of the name of this union member without checking the value of the discriminator.
      void member_name(String arg)
      Deprecated.
      Allows for the assignment of the name of this union member.
      DynAny member()
      Deprecated.
      Returns a DynAny object reference that is used in order to insert/get a member of this union.
      boolean set_as_default()
      Deprecated.
      Determines whether the discriminator associated with this union has been assigned a valid default value.
      void set_as_default(boolean arg)
      Deprecated.
      Determines whether the discriminator associated with this union gets assigned a valid default value.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • set_as_default

        boolean set_as_default()
        Deprecated.
        Determines whether the discriminator associated with this union has been assigned a valid default value.
        Returns:
        true if the discriminator has a default value; false otherwise

      • set_as_default

        void set_as_default(boolean arg)
        Deprecated.
        Determines whether the discriminator associated with this union gets assigned a valid default value.
        Parameters:
        arg - true if the discriminator gets assigned a default value

      • discriminator

        DynAny discriminator()
        Deprecated.
        Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
        Returns:
        a DynAny object reference representing the discriminator value

      • discriminator_kind

        TCKind discriminator_kind()
        Deprecated.
        Returns the TCKind object associated with the discriminator of this union.
        Returns:
        the TCKind object associated with the discriminator of this union

      • member

        DynAny member()
        Deprecated.
        Returns a DynAny object reference that is used in order to insert/get a member of this union.
        Returns:
        the DynAny object representing a member of this union

      • member_name

        String member_name()
        Deprecated.
        Allows for the inspection of the name of this union member without checking the value of the discriminator.
        Returns:
        the name of this union member

      • member_name

        void member_name(String arg)
        Deprecated.
        Allows for the assignment of the name of this union member.
        Parameters:
        arg - the new name of this union member

      • member_kind

        TCKind member_kind()
        Deprecated.
        Returns the TCKind associated with the member of this union.
        Returns:
        the TCKind object associated with the member of this union
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface DynValue

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynValue instead

    @Deprecated
public interface DynValue
extends Object, DynAny
    The representation of a DynAny object that is associated with an IDL value type.

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      TCKind current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the current member.
      String current_member_name()
      Deprecated.
      Returns the name of the current member while traversing a DynAny object that represents a Value object.
      NameValuePair[] get_members()
      Deprecated.
      Returns an array containing all the members of the value object stored in this DynValue.
      void set_members(NameValuePair[] value)
      Deprecated.
      Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.

      • Methods inherited from interface org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Method Detail

      • current_member_name

        String current_member_name()
        Deprecated.
        Returns the name of the current member while traversing a DynAny object that represents a Value object.
        Returns:
        the name of the current member

      • current_member_kind

        TCKind current_member_kind()
        Deprecated.
        Returns the TCKind object that describes the current member.
        Returns:
        the TCKind object corresponding to the current member

      • get_members

        NameValuePair[] get_members()
        Deprecated.
        Returns an array containing all the members of the value object stored in this DynValue.
        Returns:
        an array of name-value pairs.
        See Also:
        set_members(org.omg.CORBA.NameValuePair[])

      • set_members

        void set_members(NameValuePair[] value)
          throws InvalidSeq
        Deprecated.
        Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.
        Parameters:
        value - the array of name-value pairs to be set
        Throws:
        InvalidSeq - if an inconsistent value is part of the given array
        See Also:
        get_members()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Environment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class Environment

  • java.lang.Object
    • org.omg.CORBA.Environment

  • public abstract class Environment
extends Object
    A container (holder) for an exception that is used in Request operations to make exceptions available to the client. An Environment object is created with the ORB method create_environment.
    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Environment()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void clear()
      Clears this Environment object of its exception.
      abstract Exception exception()
      Retrieves the exception in this Environment object.
      abstract void exception(Exception except)
      Inserts the given exception into this Environment object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Environment

        public Environment()

    • Method Detail

      • exception

        public abstract Exception exception()
        Retrieves the exception in this Environment object.
        Returns:
        the exception in this Environment object

      • exception

        public abstract void exception(Exception except)
        Inserts the given exception into this Environment object.
        Parameters:
        except - the exception to be set

      • clear

        public abstract void clear()
        Clears this Environment object of its exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ExceptionList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ExceptionList

  • java.lang.Object
    • org.omg.CORBA.ExceptionList

  • public abstract class ExceptionList
extends Object
    An object used in Request operations to describe the exceptions that can be thrown by a method. It maintains a modifiable list of TypeCodes of the exceptions.

    The following code fragment demonstrates creating an ExceptionList object:

        ORB orb = ORB.init(args, null);
    org.omg.CORBA.ExceptionList excList = orb.create_exception_list();
    The variable excList represents an ExceptionList object with no TypeCode objects in it.

    To add items to the list, you first create a TypeCode object for the exception you want to include, using the ORB method create_exception_tc. Then you use the ExceptionList method add to add it to the list. The class ExceptionList has a method for getting the number of TypeCode objects in the list, and after items have been added, it is possible to call methods for accessing or deleting an item at a designated index.

    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ExceptionList()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void add(TypeCode exc)
      Adds a TypeCode object describing an exception to this ExceptionList object.
      abstract int count()
      Retrieves the number of TypeCode objects in this ExceptionList object.
      abstract TypeCode item(int index)
      Returns the TypeCode object at the given index.
      abstract void remove(int index)
      Removes the TypeCode object at the given index.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ExceptionList

        public ExceptionList()

    • Method Detail

      • count

        public abstract int count()
        Retrieves the number of TypeCode objects in this ExceptionList object.
        Returns:
        the number of TypeCode objects in this ExceptionList object

      • add

        public abstract void add(TypeCode exc)
        Adds a TypeCode object describing an exception to this ExceptionList object.
        Parameters:
        exc - the TypeCode object to be added

      • item

        public abstract TypeCode item(int index)
                       throws Bounds
        Returns the TypeCode object at the given index. The first item is at index 0.
        Parameters:
        index - the index of the TypeCode object desired. This must be an int between 0 and the number of TypeCode objects minus one, inclusive.
        Returns:
        the TypeCode object at the given index
        Throws:
        Bounds - if the index given is greater than or equal to the number of TypeCode objects in this ExceptionList object

      • remove

        public abstract void remove(int index)
                     throws Bounds
        Removes the TypeCode object at the given index. Note that the indices of all the TypeCoded objects following the one deleted are shifted down by one.
        Parameters:
        index - the index of the TypeCode object to be removed. This must be an int between 0 and the number of TypeCode objects minus one, inclusive.
        Throws:
        Bounds - if the index is greater than or equal to the number of TypeCode objects in this ExceptionList object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FieldNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class FieldNameHelper

  • java.lang.Object
    • org.omg.CORBA.FieldNameHelper

  • public abstract class FieldNameHelper
extends Object
    The Helper for FieldName. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/FieldNameHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      FieldNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FieldNameHelper

        public FieldNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FixedHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class FixedHolder

  • java.lang.Object
    • org.omg.CORBA.FixedHolder
  • All Implemented Interfaces:
    Streamable

    public final class FixedHolder
extends Object
implements Streamable
    The Holder for Fixed. For more information on Holder files, see "Generated Files: Holder Files".

    FixedHolder is a container class for values of IDL type "fixed", which is mapped to the Java class java.math.BigDecimal. It is usually used to store "out" and "inout" IDL method parameters. If an IDL method signature has a fixed as an "out" or "inout" parameter, the programmer must pass an instance of FixedHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the contained value corresponding to the "out" value returned from the server.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      BigDecimal value
      The value held by the FixedHolder

    • Constructor Summary

      Constructors
      Constructor and Description
      FixedHolder()
      Construct the FixedHolder without initializing the contained value.
      FixedHolder(BigDecimal initial)
      Construct the FixedHolder and initialize it with the given value.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Read a fixed point value from the input stream and store it in the value member.
      TypeCode _type()
      Return the TypeCode of this holder object.
      void _write(OutputStream output)
      Write the fixed point value stored in this holder to an OutputStream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public BigDecimal value
        The value held by the FixedHolder

    • Constructor Detail

      • FixedHolder

        public FixedHolder()
        Construct the FixedHolder without initializing the contained value.

      • FixedHolder

        public FixedHolder(BigDecimal initial)
        Construct the FixedHolder and initialize it with the given value.
        Parameters:
        initial - the value used to initialize the FixedHolder

    • Method Detail

      • _read

        public void _read(InputStream input)
        Read a fixed point value from the input stream and store it in the value member.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream to read from.

      • _write

        public void _write(OutputStream output)
        Write the fixed point value stored in this holder to an OutputStream.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream to write into.

      • _type

        public TypeCode _type()
        Return the TypeCode of this holder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FloatHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class FloatHolder

  • java.lang.Object
    • org.omg.CORBA.FloatHolder
  • All Implemented Interfaces:
    Streamable

    public final class FloatHolder
extends Object
implements Streamable
    The Holder for Float. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a float that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL float as an "out" or "inout" parameter, the programmer must pass an instance of FloatHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myFloatHolder is an instance of FloatHolder, the value stored in its value field can be accessed with myFloatHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      float value
      The float value held by this FloatHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      FloatHolder()
      Constructs a new FloatHolder object with its value field initialized to 0.0.
      FloatHolder(float initial)
      Constructs a new FloatHolder object for the given float.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Read a float from an input stream and initialize the value member with the float value.
      TypeCode _type()
      Return the TypeCode of this Streamable.
      void _write(OutputStream output)
      Write the float value into an output stream.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public float value
        The float value held by this FloatHolder object.

    • Constructor Detail

      • FloatHolder

        public FloatHolder()
        Constructs a new FloatHolder object with its value field initialized to 0.0.

      • FloatHolder

        public FloatHolder(float initial)
        Constructs a new FloatHolder object for the given float.
        Parameters:
        initial - the float with which to initialize the value field of the new FloatHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Read a float from an input stream and initialize the value member with the float value.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream to read from.

      • _write

        public void _write(OutputStream output)
        Write the float value into an output stream.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream to write into.

      • _type

        public TypeCode _type()
        Return the TypeCode of this Streamable.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FloatSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class FloatSeqHelper

  • java.lang.Object
    • org.omg.CORBA.FloatSeqHelper

  • public abstract class FloatSeqHelper
extends Object
    The Helper for FloatSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/FloatSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      FloatSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static float[] | extract(Any a)
      static String | id()
      static void | insert(Any a, float[] that)
      static float[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, float[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FloatSeqHelper

        public FloatSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          float[] that)

      • extract

        public static float[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static float[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         float[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FloatSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class FloatSeqHolder

  • java.lang.Object
    • org.omg.CORBA.FloatSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class FloatSeqHolder
extends Object
implements Streamable
    The Holder for FloatSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/FloatSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      float[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      FloatSeqHolder()
      FloatSeqHolder(float[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public float[] value

    • Constructor Detail

      • FloatSeqHolder

        public FloatSeqHolder()

      • FloatSeqHolder

        public FloatSeqHolder(float[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FREE_MEM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class FREE_MEM

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.FREE_MEM
  • All Implemented Interfaces:
    Serializable

    public final class FREE_MEM
extends SystemException
    Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      FREE_MEM()
      Constructs a FREE_MEM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      FREE_MEM(int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified minor code and completion status.
      FREE_MEM(String s)
      Constructs a FREE_MEM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      FREE_MEM(String s, int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FREE_MEM

        public FREE_MEM()
        Constructs a FREE_MEM exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • FREE_MEM

        public FREE_MEM(String s)
        Constructs a FREE_MEM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • FREE_MEM

        public FREE_MEM(int minor,
                CompletionStatus completed)
        Constructs a FREE_MEM exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • FREE_MEM

        public FREE_MEM(String s,
                int minor,
                CompletionStatus completed)
        Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdentifierHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class IdentifierHelper

  • java.lang.Object
    • org.omg.CORBA.IdentifierHelper

  • public abstract class IdentifierHelper
extends Object
    The Helper for Identifier. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/IdentifierHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:42 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      IdentifierHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IdentifierHelper

        public IdentifierHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IDLType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface IDLType

  • All Superinterfaces:
    IDLEntity, IDLTypeOperations, IRObject, IRObjectOperations, Object, Serializable
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IDLType
extends IDLTypeOperations, IRObject, IDLEntity
    An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types. It provides access to the TypeCode object describing the type and is used in defining the other interfaces wherever definitions of IDLType must be referenced.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.IDLTypeOperations

        type

      • Methods inherited from interface org.omg.CORBA.IRObjectOperations

        def_kind, destroy

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IDLTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class IDLTypeHelper

  • java.lang.Object
    • org.omg.CORBA.IDLTypeHelper

  • public abstract class IDLTypeHelper
extends Object
    The Helper for IDLType. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/IDLTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      IDLTypeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static IDLType | extract(Any a)
      static String | id()
      static void | insert(Any a, IDLType that)
      static IDLType | narrow(Object obj)
      static IDLType | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, IDLType value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IDLTypeHelper

        public IDLTypeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          IDLType that)

      • extract

        public static IDLType extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IDLType read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         IDLType value)

      • narrow

        public static IDLType narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IDLTypeOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface IDLTypeOperations

  • All Superinterfaces:
    IRObjectOperations
    All Known Subinterfaces:
    IDLType
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IDLTypeOperations
extends IRObjectOperations
    This interface must be implemented by all IDLType objects. The IDLType is inherited by all IR objects that represent IDL types, including interfaces, typedefs, and anonymous types.
    See Also:
    IDLType, IRObject, IRObjectOperations

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      TypeCode type()
      The type attribute describes the type defined by an object derived from IDLType.

      • Methods inherited from interface org.omg.CORBA.IRObjectOperations

        def_kind, destroy

    • Method Detail

      • type

        TypeCode type()
        The type attribute describes the type defined by an object derived from IDLType.
        Returns:
        the TypeCode defined by this object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IMP_LIMIT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class IMP_LIMIT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.IMP_LIMIT
  • All Implemented Interfaces:
    Serializable

    public final class IMP_LIMIT
extends SystemException
    This exception indicates that an implementation limit was exceeded in the ORB run time. For example, an ORB may reach the maximum number of references it can hold simultaneously in an address space, the size of a parameter may have exceeded the allowed maximum, or an ORB may impose a maximum on the number of clients or servers that can run simultaneously.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      IMP_LIMIT()
      Constructs an IMP_LIMIT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      IMP_LIMIT(int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified minor code and completion status.
      IMP_LIMIT(String s)
      Constructs an IMP_LIMIT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      IMP_LIMIT(String s, int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • IMP_LIMIT

        public IMP_LIMIT()
        Constructs an IMP_LIMIT exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • IMP_LIMIT

        public IMP_LIMIT(String s)
        Constructs an IMP_LIMIT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • IMP_LIMIT

        public IMP_LIMIT(int minor,
                 CompletionStatus completed)
        Constructs an IMP_LIMIT exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • IMP_LIMIT

        public IMP_LIMIT(String s,
                 int minor,
                 CompletionStatus completed)
        Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INITIALIZE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INITIALIZE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INITIALIZE
  • All Implemented Interfaces:
    Serializable

    public final class INITIALIZE
extends SystemException
    Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INITIALIZE()
      Constructs an INITIALIZE exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO.
      INITIALIZE(int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified minor code and completion status.
      INITIALIZE(String s)
      Constructs an INITIALIZE exception with the specified detail message, a minor code of 0, and a completion state of CompletionStatus.COMPLETED_NO.
      INITIALIZE(String s, int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INITIALIZE

        public INITIALIZE()
        Constructs an INITIALIZE exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO.

      • INITIALIZE

        public INITIALIZE(String s)
        Constructs an INITIALIZE exception with the specified detail message, a minor code of 0, and a completion state of CompletionStatus.COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • INITIALIZE

        public INITIALIZE(int minor,
                  CompletionStatus completed)
        Constructs an INITIALIZE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status of the method that threw this exception

      • INITIALIZE

        public INITIALIZE(String s,
                  int minor,
                  CompletionStatus completed)
        Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status of the method that threw this exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INTERNAL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INTERNAL

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INTERNAL
  • All Implemented Interfaces:
    Serializable

    public final class INTERNAL
extends SystemException
    This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section meaning of minor codes to see the minor codes for this exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INTERNAL()
      Constructs an INTERNAL exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INTERNAL(int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified minor code and completion status.
      INTERNAL(String s)
      Constructs an INTERNAL exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INTERNAL(String s, int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INTERNAL

        public INTERNAL()
        Constructs an INTERNAL exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INTERNAL

        public INTERNAL(String s)
        Constructs an INTERNAL exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • INTERNAL

        public INTERNAL(int minor,
                CompletionStatus completed)
        Constructs an INTERNAL exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus that indicates the completion status of the method that threw this exception

      • INTERNAL

        public INTERNAL(String s,
                int minor,
                CompletionStatus completed)
        Constructs an INTERNAL exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus that indicates the completion status of the method that threw this exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INTF_REPOS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INTF_REPOS

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INTF_REPOS
  • All Implemented Interfaces:
    Serializable

    public final class INTF_REPOS
extends SystemException
    Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INTF_REPOS()
      Constructs an INTF_REPOS exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INTF_REPOS(int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified minor code and completion status.
      INTF_REPOS(String s)
      Constructs an INTF_REPOS exception with the specified detail.
      INTF_REPOS(String s, int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INTF_REPOS

        public INTF_REPOS()
        Constructs an INTF_REPOS exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INTF_REPOS

        public INTF_REPOS(String s)
        Constructs an INTF_REPOS exception with the specified detail.
        Parameters:
        s - the String containing a detail message

      • INTF_REPOS

        public INTF_REPOS(int minor,
                  CompletionStatus completed)
        Constructs an INTF_REPOS exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • INTF_REPOS

        public INTF_REPOS(String s,
                  int minor,
                  CompletionStatus completed)
        Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IntHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class IntHolder

  • java.lang.Object
    • org.omg.CORBA.IntHolder
  • All Implemented Interfaces:
    Streamable

    public final class IntHolder
extends Object
implements Streamable
    The Holder for Int. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for an int that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL long as an "out" or "inout" parameter, the programmer must pass an instance of IntHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myIntHolder is an instance of IntHolder, the value stored in its value field can be accessed with myIntHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      int value
      The int value held by this IntHolder object in its value field.

    • Constructor Summary

      Constructors
      Constructor and Description
      IntHolder()
      Constructs a new IntHolder object with its value field initialized to 0.
      IntHolder(int initial)
      Constructs a new IntHolder object with its value field initialized to the given int.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
      void _write(OutputStream output)
      Marshals the value in this IntHolder object's value field to the output stream output.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public int value
        The int value held by this IntHolder object in its value field.

    • Constructor Detail

      • IntHolder

        public IntHolder()
        Constructs a new IntHolder object with its value field initialized to 0.

      • IntHolder

        public IntHolder(int initial)
        Constructs a new IntHolder object with its value field initialized to the given int.
        Parameters:
        initial - the int with which to initialize the value field of the newly-created IntHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream object containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals the value in this IntHolder object's value field to the output stream output.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream object that will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
        Specified by:
        _type in interface Streamable
        Returns:
        the type code for the value held in this IntHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INVALID_ACTIVITY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INVALID_ACTIVITY

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INVALID_ACTIVITY
  • All Implemented Interfaces:
    Serializable

    public final class INVALID_ACTIVITY
extends SystemException
    The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended. It is also raised when an attempted invocation is made that is incompatible with the Activity's current state.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INVALID_ACTIVITY()
      Constructs an INVALID_ACTIVITY exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
      INVALID_ACTIVITY(String detailMessage)
      Constructs an INVALID_ACTIVITY exception with the specified message.
      INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY()
        Constructs an INVALID_ACTIVITY exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY(String detailMessage)
        Constructs an INVALID_ACTIVITY exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY(int minorCode,
                        CompletionStatus completionStatus)
        Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY(String detailMessage,
                        int minorCode,
                        CompletionStatus completionStatus)
        Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INVALID_TRANSACTION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INVALID_TRANSACTION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INVALID_TRANSACTION
  • All Implemented Interfaces:
    Serializable

    public final class INVALID_TRANSACTION
extends SystemException
    Exception thrown when the request carried an invalid transaction context. For example, this exception could be raised if an error occurred when trying to register a resource.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INVALID_TRANSACTION()
      Constructs an INVALID_TRANSACTION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INVALID_TRANSACTION(int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
      INVALID_TRANSACTION(String s)
      Constructs an INVALID_TRANSACTION exception with the specified detail message.
      INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION()
        Constructs an INVALID_TRANSACTION exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION(String s)
        Constructs an INVALID_TRANSACTION exception with the specified detail message.
        Parameters:
        s - the String containing a detail message

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION(int minor,
                           CompletionStatus completed)
        Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION(String s,
                           int minor,
                           CompletionStatus completed)
        Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INV_FLAG (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INV_FLAG

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_FLAG
  • All Implemented Interfaces:
    Serializable

    public final class INV_FLAG
extends SystemException
    Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INV_FLAG()
      Constructs an INV_FLAG exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INV_FLAG(int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified minor code and completion status.
      INV_FLAG(String s)
      Constructs an INV_FLAG exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_FLAG(String s, int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INV_FLAG

        public INV_FLAG()
        Constructs an INV_FLAG exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INV_FLAG

        public INV_FLAG(String s)
        Constructs an INV_FLAG exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • INV_FLAG

        public INV_FLAG(int minor,
                CompletionStatus completed)
        Constructs an INV_FLAG exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • INV_FLAG

        public INV_FLAG(String s,
                int minor,
                CompletionStatus completed)
        Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INV_IDENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INV_IDENT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_IDENT
  • All Implemented Interfaces:
    Serializable

    public final class INV_IDENT
extends SystemException
    This exception indicates that an IDL identifier is syntactically invalid. It may be raised if, for example, an identifier passed to the interface repository does not conform to IDL identifier syntax, or if an illegal operation name is used with the DII.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INV_IDENT()
      Constructs an INV_IDENT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INV_IDENT(int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified minor code and completion status.
      INV_IDENT(String s)
      Constructs an INV_IDENT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_IDENT(String s, int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INV_IDENT

        public INV_IDENT()
        Constructs an INV_IDENT exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INV_IDENT

        public INV_IDENT(String s)
        Constructs an INV_IDENT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • INV_IDENT

        public INV_IDENT(int minor,
                 CompletionStatus completed)
        Constructs an INV_IDENT exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - a CompletionStatus object indicating the completion status

      • INV_IDENT

        public INV_IDENT(String s,
                 int minor,
                 CompletionStatus completed)
        Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - a CompletionStatus object indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INV_OBJREF (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INV_OBJREF

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_OBJREF
  • All Implemented Interfaces:
    Serializable

    public final class INV_OBJREF
extends SystemException
    This exception indicates that an object reference is internally malformed. For example, the repository ID may have incorrect syntax or the addressing information may be invalid. This exception is raised by ORB::string_to_object if the passed string does not decode correctly. An ORB may choose to detect calls via nil references (but is not obliged to do detect them). INV_OBJREF is used to indicate this.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INV_OBJREF()
      Constructs an INV_OBJREF exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INV_OBJREF(int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified minor code and completion status.
      INV_OBJREF(String s)
      Constructs an INV_OBJREF exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_OBJREF(String s, int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INV_OBJREF

        public INV_OBJREF()
        Constructs an INV_OBJREF exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INV_OBJREF

        public INV_OBJREF(String s)
        Constructs an INV_OBJREF exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • INV_OBJREF

        public INV_OBJREF(int minor,
                  CompletionStatus completed)
        Constructs an INV_OBJREF exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - a CompletionStatus instance indicating the completion status

      • INV_OBJREF

        public INV_OBJREF(String s,
                  int minor,
                  CompletionStatus completed)
        Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        s - the String containing a detail message
        minor - the minor code
        completed - a CompletionStatus instance indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INV_POLICY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class INV_POLICY

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_POLICY
  • All Implemented Interfaces:
    Serializable

    public final class INV_POLICY
extends SystemException
    Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation. It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      INV_POLICY()
      Constructs a INV_POLICY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      INV_POLICY(int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified minor code and completion status.
      INV_POLICY(String s)
      Constructs a INV_POLICY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_POLICY(String s, int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • INV_POLICY

        public INV_POLICY()
        Constructs a INV_POLICY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • INV_POLICY

        public INV_POLICY(String s)
        Constructs a INV_POLICY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • INV_POLICY

        public INV_POLICY(int minor,
                  CompletionStatus completed)
        Constructs a INV_POLICY exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • INV_POLICY

        public INV_POLICY(String s,
                  int minor,
                  CompletionStatus completed)
        Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IRObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface IRObject

  • All Superinterfaces:
    IDLEntity, IRObjectOperations, Object, Serializable
    All Known Subinterfaces:
    IDLType
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IRObject
extends IRObjectOperations, Object, IDLEntity
    An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.IRObjectOperations

        def_kind, destroy

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IRObjectOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface IRObjectOperations

  • All Known Subinterfaces:
    IDLType, IDLTypeOperations, IRObject
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IRObjectOperations
    This is the Operations interface for the mapping from IRObject. Several interfaces are used as base interfaces for objects in the Interface Repository (IR). These base interfaces are not instantiable. A common set of operations is used to locate objects within the Interface Repository. Some of these operations are defined in the IRObject. All IR objects inherit from the IRObject interface, which provides an operation for identifying the actual type of the object. (The IDL base interface IRObject represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.) All java implementations of IR objects must implement the IRObjectOperations interface.
    See Also:
    IDLTypeOperations, IDLType, IRObject

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DefinitionKind def_kind()
      Returns the DefinitionKind corresponding to this Interface Repository object.
      void destroy()
      Destroys this object.

    • Method Detail

      • def_kind

        DefinitionKind def_kind()
        Returns the DefinitionKind corresponding to this Interface Repository object.
        Returns:
        the DefinitionKind corresponding to this Interface Repository object.

      • destroy

        void destroy()
        Destroys this object. If the object is a Container, this method is applied to all its contents. If the object contains an IDLType attribute for an anonymous type, that IDLType is destroyed. If the object is currently contained in some other object, it is removed. If the method is invoked on a Repository or on a PrimitiveDef then the BAD_INV_ORDER exception is raised with minor value 2. An attempt to destroy an object that would leave the repository in an incoherent state causes BAD_INV_ORDER exception to be raised with the minor code 1.
        Throws:
        BAD_INV_ORDER - if this method is invoked on a repository or PrimitiveDef, or if an attempt to destroy an object would leave the repository in an incoherent state
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LocalObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class LocalObject

  • java.lang.Object
    • org.omg.CORBA.LocalObject
  • All Implemented Interfaces:
    Object

    public class LocalObject
extends Object
implements Object

    Used as a base class for implementation of a local IDL interface in the Java language mapping. It is a class which implements all the operations in the org.omg.CORBA.Object interface.

    Local interfaces are implemented by using CORBA::LocalObject to provide implementations of Object pseudo operations and any other ORB-specific support mechanisms that are appropriate for such objects. Object implementation techniques are inherently language-mapping specific. Therefore, the LocalObject type is not defined in IDL, but is specified in each language mapping.

    Methods that do not apply to local objects throw an org.omg.CORBA.NO_IMPLEMENT exception with the message, "This is a locally contrained object." Attempting to use a LocalObject to create a DII request results in NO_IMPLEMENT system exception. Attempting to marshal or stringify a LocalObject results in a MARSHAL system exception. Narrowing and widening references to LocalObjects must work as for regular object references.

    LocalObject is to be used as the base class of locally constrained objects, such as those in the PortableServer module. The specification here is based on the CORBA Components Volume I - orbos/99-07-01

    See Also:
    CORBA package comments for unimplemented features

    • Constructor Summary

      Constructors
      Constructor and Description
      LocalObject()
      Constructs a default LocalObject instance.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object _duplicate()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      DomainManager[] _get_domain_managers()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object _get_interface_def()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object _get_interface()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Policy _get_policy(int policy_type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      int _hash(int maximum)
      Returns a hash value that is consistent for the lifetime of the object, using the given number as the maximum.
      InputStream _invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      boolean _is_a(String repository_id)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      boolean _is_equivalent(Object that)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      boolean _is_local()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      boolean _non_existent()
      Always returns false.
      ORB _orb()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void _release()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void _releaseReply(InputStream input)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request _request(String operation)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      OutputStream _request(String operation, boolean responseExpected)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void _servant_postinvoke(ServantObject servant)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      ServantObject _servant_preinvoke(String operation, Class expectedType)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object _set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      boolean validate_connection()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LocalObject

        public LocalObject()
        Constructs a default LocalObject instance.

    • Method Detail

      • _is_equivalent

        public boolean _is_equivalent(Object that)

        Determines whether the two object references are equivalent, so far as the ORB can easily determine. Two object references are equivalent if they are identical. Two distinct object references which in fact refer to the same object are also equivalent. However, ORBs are not required to attempt determination of whether two distinct object references refer to the same object, since such determination could be impractically expensive.

        Default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _is_equivalent in interface Object
        Parameters:
        that - the object reference with which to check for equivalence
        Returns:
        true if this object reference is known to be equivalent to the given object reference. Note that false indicates only that the two object references are distinct, not necessarily that they reference distinct objects.

      • _non_existent

        public boolean _non_existent()
        Always returns false. This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _non_existent in interface Object
        Returns:
        false

      • _hash

        public int _hash(int maximum)
        Returns a hash value that is consistent for the lifetime of the object, using the given number as the maximum. This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _hash in interface Object
        Parameters:
        maximum - an int identifying maximum value of the hashcode
        Returns:
        this instance's hashcode

      • _is_a

        public boolean _is_a(String repository_id)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _is_a in interface Object
        Parameters:
        repository_id - a String
        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features

      • _duplicate

        public Object _duplicate()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _duplicate in interface Object
        Returns:
        a duplicate of this LocalObject instance.
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _release

        public void _release()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _release in interface Object
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _request

        public Request _request(String operation)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _request in interface Object
        Parameters:
        operation - a String giving the name of an operation to be performed by the request that is returned
        Returns:
        a Request object with the given operation
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _create_request

        public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _create_request in interface Object
        Parameters:
        ctx - a Context object containing a list of properties
        operation - the String representing the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        Returns:
        a new Request object initialized with the given arguments
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _create_request

        public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result,
                               ExceptionList exceptions,
                               ContextList contexts)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _create_request in interface Object
        Parameters:
        ctx - a Context object containing a list of properties
        operation - the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        exceptions - an ExceptionList object containing a list of possible exceptions the method can throw
        contexts - a ContextList object containing a list of context strings that need to be resolved and sent with the Request instance
        Returns:
        the new Request object initialized with the given arguments
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _get_interface

        public Object _get_interface()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features

      • _get_interface_def

        public Object _get_interface_def()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _get_interface_def in interface Object
        Returns:
        the InterfaceDef object in the Interface Repository which provides type information about the object referred to by this object reference
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _orb

        public ORB _orb()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Returns:
        the ORB instance that created the Delegate contained in this ObjectImpl
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _get_policy

        public Policy _get_policy(int policy_type)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _get_policy in interface Object
        Parameters:
        policy_type - an int
        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features

      • _get_domain_managers

        public DomainManager[] _get_domain_managers()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        Specified by:
        _get_domain_managers in interface Object
        Returns:
        the list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _set_policy_override

        public Object _set_policy_override(Policy[] policies,
                                   SetOverrideType set_add)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.
        Specified by:
        _set_policy_override in interface Object
        Parameters:
        policies - an array
        set_add - a flag
        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features

      • _is_local

        public boolean _is_local()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Returns true for this LocalObject instance.

        Returns:
        true always
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _servant_preinvoke

        public ServantObject _servant_preinvoke(String operation,
                                        Class expectedType)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Parameters:
        operation - a String indicating which operation to preinvoke
        expectedType - the class of the type of operation mentioned above
        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local object
        See Also:
        CORBA package comments for unimplemented features

      • _servant_postinvoke

        public void _servant_postinvoke(ServantObject servant)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Parameters:
        servant - the servant object on which to post-invoke
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • _request

        public OutputStream _request(String operation,
                             boolean responseExpected)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Called by a stub to obtain an OutputStream for marshaling arguments. The stub must supply the operation name, and indicate if a response is expected (i.e is this a oneway call).

        Parameters:
        operation - the name of the operation being requested
        responseExpected - true if a response is expected, false if it is a one-way call
        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features

      • _invoke

        public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Called to invoke an operation. The stub provides an OutputStream that was previously returned by a _request() call. _invoke returns an InputStream which contains the marshaled reply. If an exception occurs, _invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.

        Parameters:
        output - the OutputStream to invoke
        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        ApplicationException - If an exception occurs, _invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.
        RemarshalException - If an exception occurs, _invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features

      • _releaseReply

        public void _releaseReply(InputStream input)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        May optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed. The stub passes the InputStream returned by _invoke() or ApplicationException.getInputStream(). A null value may also be passed to _releaseReply, in which case the method is a no-op.

        Parameters:
        input - the reply stream back to the ORB or null
        Throws:
        NO_IMPLEMENT
        See Also:
        CORBA package comments for unimplemented features

      • validate_connection

        public boolean validate_connection()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        Returns:
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        Throws:
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        See Also:
        CORBA package comments for unimplemented features
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LongHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class LongHolder

  • java.lang.Object
    • org.omg.CORBA.LongHolder
  • All Implemented Interfaces:
    Streamable

    public final class LongHolder
extends Object
implements Streamable
    The Holder for Long. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a long that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL long long as an "out" or "inout" parameter, the programmer must pass an instance of LongHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myLongHolder is an instance of LongHolder, the value stored in its value field can be accessed with myLongHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      long value
      The long value held by this LongHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      LongHolder()
      Constructs a new LongHolder object with its value field initialized to 0.
      LongHolder(long initial)
      Constructs a new LongHolder object with its value field initialized to the given long.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      void _write(OutputStream output)
      Marshals to output the value in the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public long value
        The long value held by this LongHolder object.

    • Constructor Detail

      • LongHolder

        public LongHolder()
        Constructs a new LongHolder object with its value field initialized to 0.

      • LongHolder

        public LongHolder(long initial)
        Constructs a new LongHolder object with its value field initialized to the given long.
        Parameters:
        initial - the long with which to initialize the value field of the newly-created LongHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LongLongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class LongLongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.LongLongSeqHelper

  • public abstract class LongLongSeqHelper
extends Object
    The Helper for LongLongSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/LongLongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      LongLongSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static long[] | extract(Any a)
      static String | id()
      static void | insert(Any a, long[] that)
      static long[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, long[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LongLongSeqHelper

        public LongLongSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          long[] that)

      • extract

        public static long[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static long[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         long[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LongLongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class LongLongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.LongLongSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class LongLongSeqHolder
extends Object
implements Streamable
    The Holder for LongLongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/LongLongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      long[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      LongLongSeqHolder()
      LongLongSeqHolder(long[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public long[] value

    • Constructor Detail

      • LongLongSeqHolder

        public LongLongSeqHolder()

      • LongLongSeqHolder

        public LongLongSeqHolder(long[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class LongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.LongSeqHelper

  • public abstract class LongSeqHelper
extends Object
    The Helper for LongSeqHelper. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/LongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      LongSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int[] | extract(Any a)
      static String | id()
      static void | insert(Any a, int[] that)
      static int[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LongSeqHelper

        public LongSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int[] that)

      • extract

        public static int[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class LongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.LongSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class LongSeqHolder
extends Object
implements Streamable
    The Holder for LongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/LongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      int[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      LongSeqHolder()
      LongSeqHolder(int[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public int[] value

    • Constructor Detail

      • LongSeqHolder

        public LongSeqHolder()

      • LongSeqHolder

        public LongSeqHolder(int[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MARSHAL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class MARSHAL

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.MARSHAL
  • All Implemented Interfaces:
    Serializable

    public final class MARSHAL
extends SystemException
    A request or reply from the network is structurally invalid. This error typically indicates a bug in either the client-side or server-side run time. For example, if a reply from the server indicates that the message contains 1000 bytes, but the actual message is shorter or longer than 1000 bytes, the ORB raises this exception. MARSHAL can also be caused by using the DII or DSI incorrectly, for example, if the type of the actual parameters sent does not agree with IDL signature of an operation.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    Since:
    JDK1.2

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      MARSHAL()
      Constructs a MARSHAL exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      MARSHAL(int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified minor code and completion status.
      MARSHAL(String s)
      Constructs a MARSHAL exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      MARSHAL(String s, int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • MARSHAL

        public MARSHAL()
        Constructs a MARSHAL exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • MARSHAL

        public MARSHAL(String s)
        Constructs a MARSHAL exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description of the exception

      • MARSHAL

        public MARSHAL(int minor,
               CompletionStatus completed)
        Constructs a MARSHAL exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • MARSHAL

        public MARSHAL(String s,
               int minor,
               CompletionStatus completed)
        Constructs a MARSHAL exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamedValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NamedValue

  • java.lang.Object
    • org.omg.CORBA.NamedValue

  • public abstract class NamedValue
extends Object
    An object used in the DII and DSI to describe arguments and return values. NamedValue objects are also used in the Context object routines to pass lists of property names and values.

    A NamedValue object contains:

    • a name -- If the NamedValue object is used to describe arguments to a request, the name will be an argument identifier specified in the OMG IDL interface definition for the operation being described.
    • a value -- an Any object
    • an argument mode flag -- one of the following:
      • ARG_IN.value
      • ARG_OUT.value
      • ARG_INOUT.value
      • zero -- if this NamedValue object represents a property in a Context object rather than a parameter or return value

    The class NamedValue has three methods, which access its fields. The following code fragment demonstrates creating a NamedValue object and then accessing its fields:

        ORB orb = ORB.init(args, null);
    String s = "argument_1";
    org.omg.CORBA.Any myAny = orb.create_any();
    myAny.insert_long(12345);
    int in = org.omg.CORBA.ARG_IN.value;

    org.omg.CORBA.NamedValue nv = orb.create_named_value(
        s, myAny, in);
    System.out.println("This nv name is " + nv.name());
    try {
        System.out.println("This nv value is " + nv.value().extract_long());
        System.out.println("This nv flag is " + nv.flags());
    } catch (org.omg.CORBA.BAD_OPERATION b) {
      System.out.println("extract failed");
    }

    If this code fragment were put into a main method, the output would be something like the following:

        This nv name is argument_1
    This nv value is 12345
    This nv flag is 1

    Note that the method value returns an Any object. In order to access the long contained in the Any object, we used the method extract_long.

    Since:
    JDK1.2
    See Also:
    Any, ARG_IN, ARG_INOUT, ARG_OUT

    • Constructor Summary

      Constructors
      Constructor and Description
      NamedValue()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract int flags()
      Retrieves the argument mode flag for this NamedValue object.
      abstract String name()
      Retrieves the name for this NamedValue object.
      abstract Any value()
      Retrieves the value for this NamedValue object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NamedValue

        public NamedValue()

    • Method Detail

      • name

        public abstract String name()
        Retrieves the name for this NamedValue object.
        Returns:
        a String object representing the name of this NamedValue object

      • value

        public abstract Any value()
        Retrieves the value for this NamedValue object.
        Returns:
        an Any object containing the value of this NamedValue object

      • flags

        public abstract int flags()
        Retrieves the argument mode flag for this NamedValue object.
        Returns:
        an int representing the argument mode for this NamedValue object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameValuePair (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NameValuePair

  • java.lang.Object
    • org.omg.CORBA.NameValuePair
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NameValuePair
extends Object
implements IDLEntity
    Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String id
      The name to be associated with a value by this NameValuePair object.
      Any value
      The value to be associated with a name by this NameValuePair object.

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePair()
      Constructs an empty NameValuePair object.
      NameValuePair(String __id, Any __value)
      Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        public String id
        The name to be associated with a value by this NameValuePair object.

      • value

        public Any value
        The value to be associated with a name by this NameValuePair object.

    • Constructor Detail

      • NameValuePair

        public NameValuePair()
        Constructs an empty NameValuePair object. To associate a name with a value after using this constructor, the fields of this object have to be accessed individually.

      • NameValuePair

        public NameValuePair(String __id,
                     Any __value)
        Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.
        Parameters:
        __id - the name to be associated with the given Any object
        __value - the Any object to be associated with the given name
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameValuePairHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NameValuePairHelper

  • java.lang.Object
    • org.omg.CORBA.NameValuePairHelper

  • public abstract class NameValuePairHelper
extends Object
    The Helper for NameValuePair. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/NameValuePairHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePairHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameValuePair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair that)
      static NameValuePair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameValuePairHelper

        public NameValuePairHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameValuePair that)

      • extract

        public static NameValuePair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameValuePair value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NO_IMPLEMENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NO_IMPLEMENT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_IMPLEMENT
  • All Implemented Interfaces:
    Serializable

    public final class NO_IMPLEMENT
extends SystemException
    This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists. NO_IMPLEMENT can, for example, be raised by an ORB if a client asks for an object's type definition from the interface repository, but no interface repository is provided by the ORB.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    Since:
    JDK1.2

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      NO_IMPLEMENT()
      Constructs a NO_IMPLEMENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_IMPLEMENT(int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
      NO_IMPLEMENT(String s)
      Constructs a NO_IMPLEMENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NO_IMPLEMENT

        public NO_IMPLEMENT()
        Constructs a NO_IMPLEMENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_IMPLEMENT

        public NO_IMPLEMENT(String s)
        Constructs a NO_IMPLEMENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description of the exception

      • NO_IMPLEMENT

        public NO_IMPLEMENT(int minor,
                    CompletionStatus completed)
        Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
        Parameters:
        minor - an int specifying the minor code
        completed - a CompletionStatus instance indicating the completion status

      • NO_IMPLEMENT

        public NO_IMPLEMENT(String s,
                    int minor,
                    CompletionStatus completed)
        Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - an int specifying the minor code
        completed - a CompletionStatus instance indicating the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NO_MEMORY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NO_MEMORY

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_MEMORY
  • All Implemented Interfaces:
    Serializable

    public final class NO_MEMORY
extends SystemException
    Exception thrown when the ORB run time has run out of memory.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      NO_MEMORY()
      Constructs a NO_MEMORY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_MEMORY(int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified minor code and completion status.
      NO_MEMORY(String s)
      Constructs a NO_MEMORY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_MEMORY(String s, int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NO_MEMORY

        public NO_MEMORY()
        Constructs a NO_MEMORY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_MEMORY

        public NO_MEMORY(String s)
        Constructs a NO_MEMORY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description message

      • NO_MEMORY

        public NO_MEMORY(int minor,
                 CompletionStatus completed)
        Constructs a NO_MEMORY exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • NO_MEMORY

        public NO_MEMORY(String s,
                 int minor,
                 CompletionStatus completed)
        Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NO_PERMISSION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NO_PERMISSION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_PERMISSION
  • All Implemented Interfaces:
    Serializable

    public final class NO_PERMISSION
extends SystemException
    Exception thrown when an invocation failed because the caller has insufficient privileges.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      NO_PERMISSION()
      Constructs a NO_PERMISSION exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_PERMISSION(int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified minor code and completion status.
      NO_PERMISSION(String s)
      Constructs a NO_PERMISSION exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_PERMISSION(String s, int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NO_PERMISSION

        public NO_PERMISSION()
        Constructs a NO_PERMISSION exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_PERMISSION

        public NO_PERMISSION(String s)
        Constructs a NO_PERMISSION exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description message

      • NO_PERMISSION

        public NO_PERMISSION(int minor,
                     CompletionStatus completed)
        Constructs a NO_PERMISSION exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • NO_PERMISSION

        public NO_PERMISSION(String s,
                     int minor,
                     CompletionStatus completed)
        Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NO_RESOURCES (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NO_RESOURCES

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_RESOURCES
  • All Implemented Interfaces:
    Serializable

    public final class NO_RESOURCES
extends SystemException
    Exception thrown when the ORB has encountered some general resource limitation. For example, the run time may have reached the maximum permissible number of open connections.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      NO_RESOURCES()
      Constructs a NO_RESOURCES exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_RESOURCES(int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified minor code and completion status.
      NO_RESOURCES(String s)
      Constructs a NO_RESOURCES exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_RESOURCES(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NO_RESOURCES

        public NO_RESOURCES()
        Constructs a NO_RESOURCES exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_RESOURCES

        public NO_RESOURCES(String s)
        Constructs a NO_RESOURCES exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description message

      • NO_RESOURCES

        public NO_RESOURCES(int minor,
                    CompletionStatus completed)
        Constructs a NO_RESOURCES exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • NO_RESOURCES

        public NO_RESOURCES(String s,
                    int minor,
                    CompletionStatus completed)
        Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NO_RESPONSE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NO_RESPONSE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_RESPONSE
  • All Implemented Interfaces:
    Serializable

    public final class NO_RESPONSE
extends SystemException
    This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      NO_RESPONSE()
      Constructs a NO_RESPONSE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_RESPONSE(int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified minor code and completion status.
      NO_RESPONSE(String s)
      Constructs a NO_RESPONSE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_RESPONSE(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NO_RESPONSE

        public NO_RESPONSE()
        Constructs a NO_RESPONSE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_RESPONSE

        public NO_RESPONSE(String s)
        Constructs a NO_RESPONSE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description message

      • NO_RESPONSE

        public NO_RESPONSE(int minor,
                   CompletionStatus completed)
        Constructs a NO_RESPONSE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • NO_RESPONSE

        public NO_RESPONSE(String s,
                   int minor,
                   CompletionStatus completed)
        Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NVList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class NVList

  • java.lang.Object
    • org.omg.CORBA.NVList

  • public abstract class NVList
extends Object
    A modifiable list containing NamedValue objects.

    The class NVList is used as follows:

    • to describe arguments for a Request object in the Dynamic Invocation Interface and the Dynamic Skeleton Interface
    • to describe context values in a Context object

    Each NamedValue object consists of the following:

    • a name, which is a String object
    • a value, as an Any object
    • an argument mode flag

    An NVList object may be created using one of the following ORB methods:

    1. org.omg.CORBA.ORB.create_list
          org.omg.CORBA.NVList nv = orb.create_list(3);
      The variable nv represents a newly-created NVList object. The argument is a memory-management hint to the orb and does not imply the actual length of the list. If, for example, you want to use an NVList object in a request, and the method being invoked takes three parameters, you might optimize by supplying 3 to the method create_list. Note that the new NVList will not necessarily have a length of 3; it could have a length of 2 or 4, for instance. Note also that you can add any number of NamedValue objects to this list regardless of its original length.

    2. org.omg.CORBA.ORB.create_operation_list
          org.omg.CORBA.NVList nv = orb.create_operation_list(myOperationDef);
      The variable nv represents a newly-created NVList object that contains descriptions of the arguments to the method described in the given OperationDef object.

    The methods in the class NVList all deal with the NamedValue objects in the list. There are three methods for adding a NamedValue object, a method for getting the count of NamedValue objects in the list, a method for retrieving a NamedValue object at a given index, and a method for removing a NamedValue object at a given index.

    Since:
    JDK1.2
    See Also:
    Request, ServerRequest, NamedValue, Context

    • Constructor Summary

      Constructors
      Constructor and Description
      NVList()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract NamedValue add_item(String item_name, int flags)
      Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object.
      abstract NamedValue add_value(String item_name, Any val, int flags)
      Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
      abstract NamedValue add(int flags)
      Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object.
      abstract int count()
      Returns the number of NamedValue objects that have been added to this NVList object.
      abstract NamedValue item(int index)
      Retrieves the NamedValue object at the given index.
      abstract void remove(int index)
      Removes the NamedValue object at the given index.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NVList

        public NVList()

    • Method Detail

      • count

        public abstract int count()
        Returns the number of NamedValue objects that have been added to this NVList object.
        Returns:
        an int indicating the number of NamedValue objects in this NVList.

      • add

        public abstract NamedValue add(int flags)
        Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object. The flag can be any one of the argument passing modes: ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value.
        Parameters:
        flags - one of the argument mode flags
        Returns:
        the newly-created NamedValue object

      • add_item

        public abstract NamedValue add_item(String item_name,
                                    int flags)
        Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object. The flag can be any one of the argument passing modes: ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value.
        Parameters:
        item_name - the name for the new NamedValue object
        flags - one of the argument mode flags
        Returns:
        the newly-created NamedValue object

      • add_value

        public abstract NamedValue add_value(String item_name,
                                     Any val,
                                     int flags)
        Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
        Parameters:
        item_name - the name for the new NamedValue object
        val - an Any object containing the value for the new NamedValue object
        flags - one of the following argument passing modes: ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value
        Returns:
        the newly created NamedValue object

      • item

        public abstract NamedValue item(int index)
                         throws Bounds
        Retrieves the NamedValue object at the given index.
        Parameters:
        index - the index of the desired NamedValue object, which must be between zero and the length of the list minus one, inclusive. The first item is at index zero.
        Returns:
        the NamedValue object at the given index
        Throws:
        Bounds - if the index is greater than or equal to number of NamedValue objects

      • remove

        public abstract void remove(int index)
                     throws Bounds
        Removes the NamedValue object at the given index. Note that the indices of all NamedValue objects following the one removed are shifted down by one.
        Parameters:
        index - the index of the NamedValue object to be removed, which must be between zero and the length of the list minus one, inclusive. The first item is at index zero.
        Throws:
        Bounds - if the index is greater than or equal to number of NamedValue objects in the list
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Object (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface Object

  • All Known Subinterfaces:
    AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, DomainManager, DynAny, DynAny, DynAnyFactory, DynArray, DynArray, DynEnum, DynEnum, DynFixed, DynFixed, DynSequence, DynSequence, DynStruct, DynStruct, DynUnion, DynUnion, DynValue, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, ThreadPolicy
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _Remote_Stub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, LocalObject, ObjectImpl, ObjectImpl, Stub

    public interface Object
    The definition for a CORBA object reference.

    A CORBA object reference is a handle for a particular CORBA object implemented by a server. A CORBA object reference identifies the same CORBA object each time the reference is used to invoke a method on the object. A CORBA object may have multiple, distinct object references.

    The org.omg.CORBA.Object interface is the root of the inheritance hierarchy for all CORBA object references in the Java programming language, analogous to java.rmi.Remote for RMI remote objects.

    A CORBA object may be either local or remote. If it is a local object (that is, running in the same VM as the client), invocations may be directly serviced by the object instance, and the object reference could point to the actual instance of the object implementation class. If a CORBA object is a remote object (that is, running in a different VM from the client), the object reference points to a stub (proxy) which uses the ORB machinery to make a remote invocation on the server where the object implementation resides.

    Default implementations of the methods in the interface org.omg.CORBA.Object are provided in the class org.omg.CORBA.portable.ObjectImpl, which is the base class for stubs and object implementations.

    See Also:
    ObjectImpl

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      Object _duplicate()
      Returns a duplicate of this CORBA object reference.
      DomainManager[] _get_domain_managers()
      Retrieves the DomainManagers of this object.
      Object _get_interface_def()
      Obtains an InterfaceDef for the object implementation referenced by this object reference.
      Policy _get_policy(int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      int _hash(int maximum)
      Returns an ORB-internal identifier for this object reference.
      boolean _is_a(String repositoryIdentifier)
      Checks whether this object is an instance of a class that implements the given interface.
      boolean _is_equivalent(Object other)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      boolean _non_existent()
      Determines whether the server object for this object reference has been destroyed.
      void _release()
      Signals that the caller is done using this object reference, so internal ORB resources associated with this object reference can be released.
      Request _request(String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      Object _set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.

    • Method Detail

      • _is_a

        boolean _is_a(String repositoryIdentifier)
        Checks whether this object is an instance of a class that implements the given interface.
        Parameters:
        repositoryIdentifier - the interface to check against
        Returns:
        true if this object reference is an instance of a class that implements the interface; false otherwise

      • _is_equivalent

        boolean _is_equivalent(Object other)
        Determines whether the two object references are equivalent, so far as the ORB can easily determine. Two object references are equivalent if they are identical. Two distinct object references which in fact refer to the same object are also equivalent. However, ORBs are not required to attempt determination of whether two distinct object references refer to the same object, since such determination could be impractically expensive.
        Parameters:
        other - the other object reference with which to check for equivalence
        Returns:
        true if this object reference is known to be equivalent to the given object reference. Note that false indicates only that the two object references are distinct, not necessarily that they reference distinct objects.

      • _non_existent

        boolean _non_existent()
        Determines whether the server object for this object reference has been destroyed.
        Returns:
        true if the ORB knows authoritatively that the server object does not exist; false otherwise

      • _hash

        int _hash(int maximum)
        Returns an ORB-internal identifier for this object reference. This is a hash identifier, which does not change during the lifetime of the object reference, and so neither will any hash function of that identifier change. The value returned is not guaranteed to be unique; in other words, another object reference may have the same hash value. If two object references hash differently, then they are distinct object references; however, both may still refer to the same CORBA object.
        Parameters:
        maximum - the upper bound on the hash value returned by the ORB
        Returns:
        the ORB-internal hash identifier for this object reference

      • _duplicate

        Object _duplicate()
        Returns a duplicate of this CORBA object reference. The server object implementation is not involved in creating the duplicate, and the implementation cannot distinguish whether the original object reference or a duplicate was used to make a request.

        Note that this method is not very useful in the Java platform, since memory management is handled by the VM. It is included for compliance with the CORBA APIs.

        The method _duplicate may return this object reference itself.

        Returns:
        a duplicate of this object reference or this object reference itself

      • _release

        void _release()
        Signals that the caller is done using this object reference, so internal ORB resources associated with this object reference can be released. Note that the object implementation is not involved in this operation, and other references to the same object are not affected.

      • _get_interface_def

        Object _get_interface_def()
        Obtains an InterfaceDef for the object implementation referenced by this object reference. The InterfaceDef object may be used to introspect on the methods, attributes, and other type information for the object referred to by this object reference.
        Returns:
        the InterfaceDef object in the Interface Repository which provides type information about the object referred to by this object reference

      • _request

        Request _request(String operation)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        Parameters:
        operation - the name of the method to be invoked using the Request instance
        Returns:
        the newly-created Request instance

      • _create_request

        Request _create_request(Context ctx,
                        String operation,
                        NVList arg_list,
                        NamedValue result)
        Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
        Parameters:
        ctx - a Context object containing a list of properties
        operation - the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        Returns:
        the newly-created Request object
        See Also:
        Request, NVList, NamedValue

      • _create_request

        Request _create_request(Context ctx,
                        String operation,
                        NVList arg_list,
                        NamedValue result,
                        ExceptionList exclist,
                        ContextList ctxlist)
        Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
        Parameters:
        ctx - a Context object containing a list of properties
        operation - the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        exclist - an ExceptionList object containing a list of possible exceptions the method can throw
        ctxlist - a ContextList object containing a list of context strings that need to be resolved and sent with the Request instance
        Returns:
        the newly-created Request object
        See Also:
        Request, NVList, NamedValue, ExceptionList, ContextList

      • _get_policy

        Policy _get_policy(int policy_type)
        Returns the Policy object of the specified type which applies to this object.
        Parameters:
        policy_type - the type of policy to be obtained
        Returns:
        A Policy object of the type specified by the policy_type parameter
        Throws:
        BAD_PARAM - when the value of policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object

      • _get_domain_managers

        DomainManager[] _get_domain_managers()
        Retrieves the DomainManagers of this object. This allows administration services (and applications) to retrieve the domain managers, and hence the security and other policies applicable to individual objects that are members of the domain.
        Returns:
        the list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.

      • _set_policy_override

        Object _set_policy_override(Policy[] policies,
                            SetOverrideType set_add)
        Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
        Parameters:
        policies - an array of Policy objects containing the policies to be added or to be used as replacements
        set_add - either SetOverrideType.SET_OVERRIDE, indicating that the given policies will replace any existing ones, or SetOverrideType.ADD_OVERRIDE, indicating that the given policies should be added to any existing ones
        Returns:
        a new Object with the given policies replacing or added to those in this Object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ObjectHelper

  • java.lang.Object
    • org.omg.CORBA.ObjectHelper

  • public abstract class ObjectHelper
extends Object

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Object | extract(Any a)
      static String | id()
      static void | insert(Any a, Object that)
      static Object | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Object value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectHelper

        public ObjectHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Object that)

      • extract

        public static Object extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Object read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Object value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ObjectHolder

  • java.lang.Object
    • org.omg.CORBA.ObjectHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectHolder
extends Object
implements Streamable
    The Holder for Object. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a CORBA object reference (a value of type org.omg.CORBA.Object). It is usually used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has a CORBA Object reference as an "out" or "inout" parameter, the programmer must pass an instance of ObjectHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myObjectHolder is an instance of ObjectHolder, the value stored in its value field can be accessed with myObjectHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object value
      The Object value held by this ObjectHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectHolder()
      Constructs a new ObjectHolder object with its value field initialized to null.
      ObjectHolder(Object initial)
      Constructs a new ObjectHolder object with its value field initialized to the given Object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this ObjectHolder object
      void _write(OutputStream output)
      Marshals to output the value in this ObjectHolder object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Object value
        The Object value held by this ObjectHolder object.

    • Constructor Detail

      • ObjectHolder

        public ObjectHolder()
        Constructs a new ObjectHolder object with its value field initialized to null.

      • ObjectHolder

        public ObjectHolder(Object initial)
        Constructs a new ObjectHolder object with its value field initialized to the given Object.
        Parameters:
        initial - the Object with which to initialize the value field of the newly-created ObjectHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this ObjectHolder object.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this ObjectHolder object
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in this ObjectHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OBJECT_NOT_EXIST (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class OBJECT_NOT_EXIST

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.OBJECT_NOT_EXIST
  • All Implemented Interfaces:
    Serializable

    public final class OBJECT_NOT_EXIST
extends SystemException
    Exception raised whenever an invocation on a deleted object was performed. It is an authoritative "hard" fault report. Anyone receiving it is allowed (even expected) to delete all copies of this object reference and to perform other appropriate "final recovery" style procedures. Bridges forward this exception to clients, also destroying any records they may hold (for example, proxy objects used in reference translation). The clients could in turn purge any of their own data structures.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      OBJECT_NOT_EXIST()
      Constructs an OBJECT_NOT_EXIST exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
      OBJECT_NOT_EXIST(String s)
      Constructs an OBJECT_NOT_EXIST exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST()
        Constructs an OBJECT_NOT_EXIST exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST(String s)
        Constructs an OBJECT_NOT_EXIST exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description message

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST(int minor,
                        CompletionStatus completed)
        Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST(String s,
                        int minor,
                        CompletionStatus completed)
        Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OBJ_ADAPTER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class OBJ_ADAPTER

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.OBJ_ADAPTER
  • All Implemented Interfaces:
    Serializable

    public final class OBJ_ADAPTER
extends SystemException
    This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    Since:
    JDK1.2
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      OBJ_ADAPTER()
      Constructs an OBJ_ADAPTER exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      OBJ_ADAPTER(int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
      OBJ_ADAPTER(String s)
      Constructs an OBJ_ADAPTER exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • OBJ_ADAPTER

        public OBJ_ADAPTER()
        Constructs an OBJ_ADAPTER exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • OBJ_ADAPTER

        public OBJ_ADAPTER(String s)
        Constructs an OBJ_ADAPTER exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a description message

      • OBJ_ADAPTER

        public OBJ_ADAPTER(int minor,
                   CompletionStatus completed)
        Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • OBJ_ADAPTER

        public OBJ_ADAPTER(String s,
                   int minor,
                   CompletionStatus completed)
        Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OctetSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class OctetSeqHelper

  • java.lang.Object
    • org.omg.CORBA.OctetSeqHelper

  • public abstract class OctetSeqHelper
extends Object
    The Helper for OctetSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/OctetSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      OctetSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static byte[] | extract(Any a)
      static String | id()
      static void | insert(Any a, byte[] that)
      static byte[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, byte[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • OctetSeqHelper

        public OctetSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          byte[] that)

      • extract

        public static byte[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static byte[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         byte[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OctetSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class OctetSeqHolder

  • java.lang.Object
    • org.omg.CORBA.OctetSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class OctetSeqHolder
extends Object
implements Streamable
    The Holder for OctetSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/OctetSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      byte[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      OctetSeqHolder()
      OctetSeqHolder(byte[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public byte[] value

    • Constructor Detail

      • OctetSeqHolder

        public OctetSeqHolder()

      • OctetSeqHolder

        public OctetSeqHolder(byte[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OMGVMCID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface OMGVMCID

  • public interface OMGVMCID
    The vendor minor code ID reserved for OMG. Minor codes for the standard exceptions are prefaced by the VMCID assigned to OMG, defined as the constant OMGVMCID, which, like all VMCIDs, occupies the high order 20 bits.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The vendor minor code ID reserved for OMG.

    • Field Detail

      • value

        static final int value
        The vendor minor code ID reserved for OMG. This value is or'd with the high order 20 bits of the minor code to produce the minor value in a system exception.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORB (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ORB

  • java.lang.Object
    • org.omg.CORBA.ORB
  • Direct Known Subclasses:
    ORB

    public abstract class ORB
extends Object
    A class providing APIs for the CORBA Object Request Broker features. The ORB class also provides "pluggable ORB implementation" APIs that allow another vendor's ORB implementation to be used.

    An ORB makes it possible for CORBA objects to communicate with each other by connecting objects making requests (clients) with objects servicing requests (servers).

    The ORB class, which encapsulates generic CORBA functionality, does the following: (Note that items 5 and 6, which include most of the methods in the class ORB, are typically used with the Dynamic Invocation Interface (DII) and the Dynamic Skeleton Interface (DSI). These interfaces may be used by a developer directly, but most commonly they are used by the ORB internally and are not seen by the general programmer.)

    1. initializes the ORB implementation by supplying values for predefined properties and environmental parameters
    2. obtains initial object references to services such as the NameService using the method resolve_initial_references
    3. converts object references to strings and back
    4. connects the ORB to a servant (an instance of a CORBA object implementation) and disconnects the ORB from a servant
    5. creates objects such as
      • TypeCode
      • Any
      • NamedValue
      • Context
      • Environment
      • lists (such as NVList) containing these objects
    6. sends multiple messages in the DII

    The ORB class can be used to obtain references to objects implemented anywhere on the network.

    An application or applet gains access to the CORBA environment by initializing itself into an ORB using one of three init methods. Two of the three methods use the properties (associations of a name with a value) shown in the table below.

    Property Name | Property Value
    Standard Java CORBA Properties:
    org.omg.CORBA.ORBClass | class name of an ORB implementation
    org.omg.CORBA.ORBSingletonClass | class name of the ORB returned by init()

    These properties allow a different vendor's ORB implementation to be "plugged in."

    When an ORB instance is being created, the class name of the ORB implementation is located using the following standard search order:

    1. check in Applet parameter or application string array, if any
    2. check in properties parameter, if any
    3. check in the System properties
    4. check in the orb.properties file located in the user.home directory (if any)
    5. check in the orb.properties file located in the java.home/lib directory (if any)
    6. fall back on a hardcoded default behavior (use the Java IDL implementation)

    Note that Java IDL provides a default implementation for the fully-functional ORB and for the Singleton ORB. When the method init is given no parameters, the default Singleton ORB is returned. When the method init is given parameters but no ORB class is specified, the Java IDL ORB implementation is returned.

    The following code fragment creates an ORB object initialized with the default ORB Singleton. This ORB has a restricted implementation to prevent malicious applets from doing anything beyond creating typecodes. It is called a singleton because there is only one instance for an entire virtual machine.

        ORB orb = ORB.init();

    The following code fragment creates an ORB object for an application. The parameter args represents the arguments supplied to the application's main method. Since the property specifies the ORB class to be "SomeORBImplementation", the new ORB will be initialized with that ORB implementation. If p had been null, and the arguments had not specified an ORB class, the new ORB would have been initialized with the default Java IDL implementation.

        Properties p = new Properties();
    p.put("org.omg.CORBA.ORBClass", "SomeORBImplementation");
    ORB orb = ORB.init(args, p);

    The following code fragment creates an ORB object for the applet supplied as the first parameter. If the given applet does not specify an ORB class, the new ORB will be initialized with the default Java IDL implementation.

        ORB orb = ORB.init(myApplet, null);

    An application or applet can be initialized in one or more ORBs. ORB initialization is a bootstrap call into the CORBA world.

    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      ORB()

    • Method Summary

      All Methods Static Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void connect(Object obj)
      Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB.
      TypeCode create_abstract_interface_tc(String id, String name)
      Create a TypeCode object for an IDL abstract interface.
      abstract TypeCode create_alias_tc(String id, String name, TypeCode original_type)
      Creates a TypeCode object representing an IDL alias (typedef).
      abstract Any create_any()
      Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
      abstract TypeCode create_array_tc(int length, TypeCode element_type)
      Creates a TypeCode object representing an IDL array.
      DynAny create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract ContextList create_context_list()
      Creates an empty ContextList object.
      DynAny create_dyn_any(Any value)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynArray create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynEnum create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynSequence create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynStruct create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynUnion create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract TypeCode create_enum_tc(String id, String name, String[] members)
      Creates a TypeCode object representing an IDL enum.
      abstract Environment create_environment()
      Creates an Environment object.
      abstract ExceptionList create_exception_list()
      Creates an empty ExceptionList object.
      abstract TypeCode create_exception_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL exception.
      TypeCode create_fixed_tc(short digits, short scale)
      Create a TypeCode object for an IDL fixed type.
      abstract TypeCode create_interface_tc(String id, String name)
      Creates a TypeCode object representing an IDL interface.
      abstract NVList create_list(int count)
      Allocates an NVList with (probably) enough space for the specified number of NamedValue objects.
      abstract NamedValue create_named_value(String s, Any any, int flags)
      Creates a NamedValue object using the given name, value, and argument mode flags.
      TypeCode create_native_tc(String id, String name)
      Create a TypeCode object for an IDL native type.
      NVList create_operation_list(Object oper)
      Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
      abstract OutputStream create_output_stream()
      Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
      Policy create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      abstract TypeCode create_recursive_sequence_tc(int bound, int offset)
      Deprecated.
      Use a combination of create_recursive_tc and create_sequence_tc instead
      TypeCode create_recursive_tc(String id)
      Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion.
      abstract TypeCode create_sequence_tc(int bound, TypeCode element_type)
      Creates a TypeCode object representing an IDL sequence.
      abstract TypeCode create_string_tc(int bound)
      Creates a TypeCode object representing a bounded IDL string.
      abstract TypeCode create_struct_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL struct.
      abstract TypeCode create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      TypeCode create_value_box_tc(String id, String name, TypeCode boxed_type)
      Creates a TypeCode object for an IDL value box.
      TypeCode create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      abstract TypeCode create_wstring_tc(int bound)
      Creates a TypeCode object representing a bounded IDL wstring (wide string).
      void destroy()
      Destroys the ORB so that its resources can be reclaimed.
      void disconnect(Object obj)
      Disconnects the given servant object from the ORB.
      Current get_current()
      Deprecated.
      use resolve_initial_references.
      abstract Context get_default_context()
      Gets the default Context object.
      abstract Request get_next_response()
      Gets the next Request instance for which a response has been received.
      abstract TypeCode get_primitive_tc(TCKind tcKind)
      Retrieves the TypeCode object that represents the given primitive IDL type.
      boolean get_service_information(short service_type, ServiceInformationHolder service_info)
      Used to obtain information about CORBA facilities and services that are supported by this ORB.
      static ORB init()
      Returns the ORB singleton object.
      static ORB init(Applet app, Properties props)
      Creates a new ORB instance for an applet.
      static ORB init(String[] args, Properties props)
      Creates a new ORB instance for a standalone application.
      abstract String[] list_initial_services()
      Returns a list of the initially available CORBA object references, such as "NameService" and "InterfaceRepository".
      abstract String object_to_string(Object obj)
      Converts the given CORBA object reference to a string.
      void perform_work()
      Performs an implementation-dependent unit of work if called by the main thread.
      abstract boolean poll_next_response()
      Finds out if any of the deferred (asynchronous) invocations have a response yet.
      abstract Object resolve_initial_references(String object_name)
      Resolves a specific object reference from the set of available initial service names.
      void run()
      This operation blocks the current thread until the ORB has completed the shutdown process, initiated when some thread calls shutdown.
      abstract void send_multiple_requests_deferred(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously.
      abstract void send_multiple_requests_oneway(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously without expecting any responses.
      protected abstract void set_parameters(Applet app, Properties props)
      Allows the ORB implementation to be initialized with the given applet and parameters.
      protected abstract void set_parameters(String[] args, Properties props)
      Allows the ORB implementation to be initialized with the given parameters and properties.
      void shutdown(boolean wait_for_completion)
      Instructs the ORB to shut down, which causes all object adapters to shut down, in preparation for destruction.
      If the wait_for_completion parameter is true, this operation blocks until all ORB processing (including processing of currently executing requests, object deactivation, and other object adapter operations) has completed.
      abstract Object string_to_object(String str)
      Converts a string produced by the method object_to_string back to a CORBA object reference.
      boolean work_pending()
      Returns true if the ORB needs the main thread to perform some work, and false if the ORB does not need the main thread.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ORB

        public ORB()

    • Method Detail

      • init

        public static ORB init()
        Returns the ORB singleton object. This method always returns the same ORB instance, which is an instance of the class described by the org.omg.CORBA.ORBSingletonClass system property.

        This no-argument version of the method init is used primarily as a factory for TypeCode objects, which are used by Helper classes to implement the method type. It is also used to create Any objects that are used to describe union labels (as part of creating a TypeCode object for a union).

        This method is not intended to be used by applets, and in the event that it is called in an applet environment, the ORB it returns is restricted so that it can be used only as a factory for TypeCode objects. Any TypeCode objects it produces can be safely shared among untrusted applets.

        If an ORB is created using this method from an applet, a system exception will be thrown if methods other than those for creating TypeCode objects are invoked.

        Returns:
        the singleton ORB

      • init

        public static ORB init(String[] args,
                       Properties props)
        Creates a new ORB instance for a standalone application. This method may be called from applications only and returns a new fully functional ORB object each time it is called.
        Parameters:
        args - command-line arguments for the application's main method; may be null
        props - application-specific properties; may be null
        Returns:
        the newly-created ORB instance

      • init

        public static ORB init(Applet app,
                       Properties props)
        Creates a new ORB instance for an applet. This method may be called from applets only and returns a new fully-functional ORB object each time it is called.
        Parameters:
        app - the applet; may be null
        props - applet-specific properties; may be null
        Returns:
        the newly-created ORB instance

      • set_parameters

        protected abstract void set_parameters(String[] args,
                                       Properties props)
        Allows the ORB implementation to be initialized with the given parameters and properties. This method, used in applications only, is implemented by subclass ORB implementations and called by the appropriate init method to pass in its parameters.
        Parameters:
        args - command-line arguments for the application's main method; may be null
        props - application-specific properties; may be null

      • set_parameters

        protected abstract void set_parameters(Applet app,
                                       Properties props)
        Allows the ORB implementation to be initialized with the given applet and parameters. This method, used in applets only, is implemented by subclass ORB implementations and called by the appropriate init method to pass in its parameters.
        Parameters:
        app - the applet; may be null
        props - applet-specific properties; may be null

      • connect

        public void connect(Object obj)
        Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB. The servant class must extend the ImplBase class corresponding to the interface that is supported by the server. The servant must thus be a CORBA object reference, and inherit from org.omg.CORBA.Object. Servants created by the user can start receiving remote invocations after the method connect has been called. A servant may also be automatically and implicitly connected to the ORB if it is passed as an IDL parameter in an IDL method invocation on a non-local object, that is, if the servant object has to be marshalled and sent outside of the process address space.

        Calling the method connect has no effect when the servant object is already connected to the ORB.

        Deprecated by the OMG in favor of the Portable Object Adapter APIs.

        Parameters:
        obj - The servant object reference

      • destroy

        public void destroy()
        Destroys the ORB so that its resources can be reclaimed. Any operation invoked on a destroyed ORB reference will throw the OBJECT_NOT_EXIST exception. Once an ORB has been destroyed, another call to init with the same ORBid will return a reference to a newly constructed ORB.

        If destroy is called on an ORB that has not been shut down, it will start the shut down process and block until the ORB has shut down before it destroys the ORB.
        If an application calls destroy in a thread that is currently servicing an invocation, the BAD_INV_ORDER system exception will be thrown with the OMG minor code 3, since blocking would result in a deadlock.

        For maximum portability and to avoid resource leaks, an application should always call shutdown and destroy on all ORB instances before exiting.

        Throws:
        BAD_INV_ORDER - if the current thread is servicing an invocation

      • disconnect

        public void disconnect(Object obj)
        Disconnects the given servant object from the ORB. After this method returns, the ORB will reject incoming remote requests for the disconnected servant and will send the exception org.omg.CORBA.OBJECT_NOT_EXIST back to the remote client. Thus the object appears to be destroyed from the point of view of remote clients. Note, however, that local requests issued using the servant directly do not pass through the ORB; hence, they will continue to be processed by the servant.

        Calling the method disconnect has no effect if the servant is not connected to the ORB.

        Deprecated by the OMG in favor of the Portable Object Adapter APIs.

        Parameters:
        obj - The servant object to be disconnected from the ORB

      • list_initial_services

        public abstract String[] list_initial_services()
        Returns a list of the initially available CORBA object references, such as "NameService" and "InterfaceRepository".
        Returns:
        an array of String objects that represent the object references for CORBA services that are initially available with this ORB

      • resolve_initial_references

        public abstract Object resolve_initial_references(String object_name)
                                           throws InvalidName
        Resolves a specific object reference from the set of available initial service names.
        Parameters:
        object_name - the name of the initial service as a string
        Returns:
        the object reference associated with the given name
        Throws:
        InvalidName - if the given name is not associated with a known service

      • object_to_string

        public abstract String object_to_string(Object obj)
        Converts the given CORBA object reference to a string. Note that the format of this string is predefined by IIOP, allowing strings generated by a different ORB to be converted back into an object reference.

        The resulting String object may be stored or communicated in any way that a String object can be manipulated.

        Parameters:
        obj - the object reference to stringify
        Returns:
        the string representing the object reference

      • string_to_object

        public abstract Object string_to_object(String str)
        Converts a string produced by the method object_to_string back to a CORBA object reference.
        Parameters:
        str - the string to be converted back to an object reference. It must be the result of converting an object reference to a string using the method object_to_string.
        Returns:
        the object reference

      • create_list

        public abstract NVList create_list(int count)
        Allocates an NVList with (probably) enough space for the specified number of NamedValue objects. Note that the specified size is only a hint to help with storage allocation and does not imply the maximum size of the list.
        Parameters:
        count - suggested number of NamedValue objects for which to allocate space
        Returns:
        the newly-created NVList
        See Also:
        NVList

      • create_operation_list

        public NVList create_operation_list(Object oper)
        Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object. This OperationDef object is obtained from an Interface Repository. The arguments in the returned NVList object are in the same order as in the original IDL operation definition, which makes it possible for the list to be used in dynamic invocation requests.
        Parameters:
        oper - the OperationDef object to use to create the list
        Returns:
        a newly-created NVList object containing descriptions of the arguments to the method described in the given OperationDef object
        See Also:
        NVList

      • create_named_value

        public abstract NamedValue create_named_value(String s,
                                              Any any,
                                              int flags)
        Creates a NamedValue object using the given name, value, and argument mode flags.

        A NamedValue object serves as (1) a parameter or return value or (2) a context property. It may be used by itself or as an element in an NVList object.

        Parameters:
        s - the name of the NamedValue object
        any - the Any value to be inserted into the NamedValue object
        flags - the argument mode flags for the NamedValue: one of ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value.
        Returns:
        the newly-created NamedValue object
        See Also:
        NamedValue

      • create_exception_list

        public abstract ExceptionList create_exception_list()
        Creates an empty ExceptionList object.
        Returns:
        the newly-created ExceptionList object

      • create_context_list

        public abstract ContextList create_context_list()
        Creates an empty ContextList object.
        Returns:
        the newly-created ContextList object
        See Also:
        ContextList, Context

      • get_default_context

        public abstract Context get_default_context()
        Gets the default Context object.
        Returns:
        the default Context object
        See Also:
        Context

      • create_environment

        public abstract Environment create_environment()
        Creates an Environment object.
        Returns:
        the newly-created Environment object
        See Also:
        Environment

      • create_output_stream

        public abstract OutputStream create_output_stream()
        Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
        Returns:
        the newly-created org.omg.CORBA.portable.OutputStream object

      • send_multiple_requests_oneway

        public abstract void send_multiple_requests_oneway(Request[] req)
        Sends multiple dynamic (DII) requests asynchronously without expecting any responses. Note that oneway invocations are not guaranteed to reach the server.
        Parameters:
        req - an array of request objects

      • send_multiple_requests_deferred

        public abstract void send_multiple_requests_deferred(Request[] req)
        Sends multiple dynamic (DII) requests asynchronously.
        Parameters:
        req - an array of Request objects

      • poll_next_response

        public abstract boolean poll_next_response()
        Finds out if any of the deferred (asynchronous) invocations have a response yet.
        Returns:
        true if there is a response available; false otherwise

      • get_next_response

        public abstract Request get_next_response()
                                   throws WrongTransaction
        Gets the next Request instance for which a response has been received.
        Returns:
        the next Request object ready with a response
        Throws:
        WrongTransaction - if the method get_next_response is called from a transaction scope different from the one from which the original request was sent. See the OMG Transaction Service specification for details.

      • get_primitive_tc

        public abstract TypeCode get_primitive_tc(TCKind tcKind)
        Retrieves the TypeCode object that represents the given primitive IDL type.
        Parameters:
        tcKind - the TCKind instance corresponding to the desired primitive type
        Returns:
        the requested TypeCode object

      • create_struct_tc

        public abstract TypeCode create_struct_tc(String id,
                                          String name,
                                          StructMember[] members)
        Creates a TypeCode object representing an IDL struct. The TypeCode object is initialized with the given id, name, and members.
        Parameters:
        id - the repository id for the struct
        name - the name of the struct
        members - an array describing the members of the struct
        Returns:
        a newly-created TypeCode object describing an IDL struct

      • create_union_tc

        public abstract TypeCode create_union_tc(String id,
                                         String name,
                                         TypeCode discriminator_type,
                                         UnionMember[] members)
        Creates a TypeCode object representing an IDL union. The TypeCode object is initialized with the given id, name, discriminator type, and members.
        Parameters:
        id - the repository id of the union
        name - the name of the union
        discriminator_type - the type of the union discriminator
        members - an array describing the members of the union
        Returns:
        a newly-created TypeCode object describing an IDL union

      • create_enum_tc

        public abstract TypeCode create_enum_tc(String id,
                                        String name,
                                        String[] members)
        Creates a TypeCode object representing an IDL enum. The TypeCode object is initialized with the given id, name, and members.
        Parameters:
        id - the repository id for the enum
        name - the name for the enum
        members - an array describing the members of the enum
        Returns:
        a newly-created TypeCode object describing an IDL enum

      • create_alias_tc

        public abstract TypeCode create_alias_tc(String id,
                                         String name,
                                         TypeCode original_type)
        Creates a TypeCode object representing an IDL alias (typedef). The TypeCode object is initialized with the given id, name, and original type.
        Parameters:
        id - the repository id for the alias
        name - the name for the alias
        original_type - the TypeCode object describing the original type for which this is an alias
        Returns:
        a newly-created TypeCode object describing an IDL alias

      • create_exception_tc

        public abstract TypeCode create_exception_tc(String id,
                                             String name,
                                             StructMember[] members)
        Creates a TypeCode object representing an IDL exception. The TypeCode object is initialized with the given id, name, and members.
        Parameters:
        id - the repository id for the exception
        name - the name for the exception
        members - an array describing the members of the exception
        Returns:
        a newly-created TypeCode object describing an IDL exception

      • create_interface_tc

        public abstract TypeCode create_interface_tc(String id,
                                             String name)
        Creates a TypeCode object representing an IDL interface. The TypeCode object is initialized with the given id and name.
        Parameters:
        id - the repository id for the interface
        name - the name for the interface
        Returns:
        a newly-created TypeCode object describing an IDL interface

      • create_string_tc

        public abstract TypeCode create_string_tc(int bound)
        Creates a TypeCode object representing a bounded IDL string. The TypeCode object is initialized with the given bound, which represents the maximum length of the string. Zero indicates that the string described by this type code is unbounded.
        Parameters:
        bound - the bound for the string; cannot be negative
        Returns:
        a newly-created TypeCode object describing a bounded IDL string
        Throws:
        BAD_PARAM - if bound is a negative value

      • create_wstring_tc

        public abstract TypeCode create_wstring_tc(int bound)
        Creates a TypeCode object representing a bounded IDL wstring (wide string). The TypeCode object is initialized with the given bound, which represents the maximum length of the wide string. Zero indicates that the string described by this type code is unbounded.
        Parameters:
        bound - the bound for the wstring; cannot be negative
        Returns:
        a newly-created TypeCode object describing a bounded IDL wstring
        Throws:
        BAD_PARAM - if bound is a negative value

      • create_sequence_tc

        public abstract TypeCode create_sequence_tc(int bound,
                                            TypeCode element_type)
        Creates a TypeCode object representing an IDL sequence. The TypeCode object is initialized with the given bound and element type.
        Parameters:
        bound - the bound for the sequence, 0 if unbounded
        element_type - the TypeCode object describing the elements contained in the sequence
        Returns:
        a newly-created TypeCode object describing an IDL sequence

      • create_recursive_sequence_tc

        @Deprecated
public abstract TypeCode create_recursive_sequence_tc(int bound,
                                                                  int offset)
        Deprecated. Use a combination of create_recursive_tc and create_sequence_tc instead
        Creates a TypeCode object representing a a recursive IDL sequence.

        For the IDL struct Node in following code fragment, the offset parameter for creating its sequence would be 1:

            Struct Node {
        long value;
        Sequence <Node> subnodes;
    };
        Parameters:
        bound - the bound for the sequence, 0 if unbounded
        offset - the index to the enclosing TypeCode object that describes the elements of this sequence
        Returns:
        a newly-created TypeCode object describing a recursive sequence
        See Also:
        create_recursive_tc, create_sequence_tc

      • create_array_tc

        public abstract TypeCode create_array_tc(int length,
                                         TypeCode element_type)
        Creates a TypeCode object representing an IDL array. The TypeCode object is initialized with the given length and element type.
        Parameters:
        length - the length of the array
        element_type - a TypeCode object describing the type of element contained in the array
        Returns:
        a newly-created TypeCode object describing an IDL array

      • create_native_tc

        public TypeCode create_native_tc(String id,
                                 String name)
        Create a TypeCode object for an IDL native type.
        Parameters:
        id - the logical id for the native type.
        name - the name of the native type.
        Returns:
        the requested TypeCode.

      • create_abstract_interface_tc

        public TypeCode create_abstract_interface_tc(String id,
                                             String name)
        Create a TypeCode object for an IDL abstract interface.
        Parameters:
        id - the logical id for the abstract interface type.
        name - the name of the abstract interface type.
        Returns:
        the requested TypeCode.

      • create_fixed_tc

        public TypeCode create_fixed_tc(short digits,
                                short scale)
        Create a TypeCode object for an IDL fixed type.
        Parameters:
        digits - specifies the total number of decimal digits in the number and must be from 1 to 31 inclusive.
        scale - specifies the position of the decimal point.
        Returns:
        the requested TypeCode.

      • create_value_tc

        public TypeCode create_value_tc(String id,
                                String name,
                                short type_modifier,
                                TypeCode concrete_base,
                                ValueMember[] members)
        Create a TypeCode object for an IDL value type. The concrete_base parameter is the TypeCode for the immediate concrete valuetype base of the valuetype for which the TypeCode is being created. It may be null if the valuetype does not have a concrete base.
        Parameters:
        id - the logical id for the value type.
        name - the name of the value type.
        type_modifier - one of the value type modifier constants: VM_NONE, VM_CUSTOM, VM_ABSTRACT or VM_TRUNCATABLE
        concrete_base - a TypeCode object describing the concrete valuetype base
        members - an array containing the members of the value type
        Returns:
        the requested TypeCode

      • create_recursive_tc

        public TypeCode create_recursive_tc(String id)
        Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion. The id parameter specifies the repository id of the type for which the recursive TypeCode is serving as a placeholder. Once the recursive TypeCode has been properly embedded in the enclosing TypeCode which corresponds to the specified repository id, it will function as a normal TypeCode. Invoking operations on the recursive TypeCode before it has been embedded in the enclosing TypeCode will result in a BAD_TYPECODE exception.

        For example, the following IDL type declaration contains recursion:

            Struct Node {
        Sequence<Node> subnodes;
    };

        To create a TypeCode for struct Node, you would invoke the TypeCode creation operations as shown below:

         String nodeID = "IDL:Node:1.0";
 TypeCode recursiveSeqTC = orb.create_sequence_tc(0, orb.create_recursive_tc(nodeID));
 StructMember[] members = { new StructMember("subnodes", recursiveSeqTC, null) };
 TypeCode structNodeTC = orb.create_struct_tc(nodeID, "Node", members);

        Also note that the following is an illegal IDL type declaration:

            Struct Node {
        Node next;
    };

        Recursive types can only appear within sequences which can be empty. That way marshaling problems, when transmitting the struct in an Any, are avoided.

        Parameters:
        id - the logical id of the referenced type
        Returns:
        the requested TypeCode

      • create_value_box_tc

        public TypeCode create_value_box_tc(String id,
                                    String name,
                                    TypeCode boxed_type)
        Creates a TypeCode object for an IDL value box.
        Parameters:
        id - the logical id for the value type
        name - the name of the value type
        boxed_type - the TypeCode for the type
        Returns:
        the requested TypeCode

      • create_any

        public abstract Any create_any()
        Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
        Returns:
        a newly-created Any object

      • get_current

        @Deprecated
public Current get_current()
        Deprecated. use resolve_initial_references.
        Retrieves a Current object. The Current interface is used to manage thread-specific information for use by services such as transactions and security.
        Returns:
        a newly-created Current object
        See Also:
        CORBA package comments for unimplemented features

      • run

        public void run()
        This operation blocks the current thread until the ORB has completed the shutdown process, initiated when some thread calls shutdown. It may be used by multiple threads which get all notified when the ORB shuts down.

      • shutdown

        public void shutdown(boolean wait_for_completion)
        Instructs the ORB to shut down, which causes all object adapters to shut down, in preparation for destruction.
        If the wait_for_completion parameter is true, this operation blocks until all ORB processing (including processing of currently executing requests, object deactivation, and other object adapter operations) has completed. If an application does this in a thread that is currently servicing an invocation, the BAD_INV_ORDER system exception will be thrown with the OMG minor code 3, since blocking would result in a deadlock.
        If the wait_for_completion parameter is FALSE, then shutdown may not have completed upon return.

        While the ORB is in the process of shutting down, the ORB operates as normal, servicing incoming and outgoing requests until all requests have been completed. Once an ORB has shutdown, only object reference management operations may be invoked on the ORB or any object reference obtained from it. An application may also invoke the destroy operation on the ORB itself. Invoking any other operation will throw the BAD_INV_ORDER system exception with the OMG minor code 4.

        The ORB.run method will return after shutdown has been called.

        Parameters:
        wait_for_completion - true if the call should block until the shutdown is complete; false if it should return immediately
        Throws:
        BAD_INV_ORDER - if the current thread is servicing an invocation

      • work_pending

        public boolean work_pending()
        Returns true if the ORB needs the main thread to perform some work, and false if the ORB does not need the main thread.
        Returns:
        true if there is work pending, meaning that the ORB needs the main thread to perform some work; false if there is no work pending and thus the ORB does not need the main thread

      • perform_work

        public void perform_work()
        Performs an implementation-dependent unit of work if called by the main thread. Otherwise it does nothing. The methods work_pending and perform_work can be used in conjunction to implement a simple polling loop that multiplexes the main thread among the ORB and other activities.

      • get_service_information

        public boolean get_service_information(short service_type,
                                       ServiceInformationHolder service_info)
        Used to obtain information about CORBA facilities and services that are supported by this ORB. The service type for which information is being requested is passed in as the in parameter service_type, the values defined by constants in the CORBA module. If service information is available for that type, that is returned in the out parameter service_info, and the operation returns the value true. If no information for the requested services type is available, the operation returns false (i.e., the service is not supported by this ORB).

        Parameters:
        service_type - a short indicating the service type for which information is being requested
        service_info - a ServiceInformationHolder object that will hold the ServiceInformation object produced by this method
        Returns:
        true if service information is available for the service_type; false if no information for the requested services type is available
        See Also:
        CORBA package comments for unimplemented features

      • create_dyn_any

        @Deprecated
public DynAny create_dyn_any(Any value)
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynAny object from the given Any object.

        Parameters:
        value - the Any object from which to create a new DynAny object
        Returns:
        the new DynAny object created from the given Any object
        See Also:
        CORBA package comments for unimplemented features

      • create_basic_dyn_any

        @Deprecated
public DynAny create_basic_dyn_any(TypeCode type)
                                        throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a basic DynAny object from the given TypeCode object.

        Parameters:
        type - the TypeCode object from which to create a new DynAny object
        Returns:
        the new DynAny object created from the given TypeCode object
        Throws:
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        See Also:
        CORBA package comments for unimplemented features

      • create_dyn_struct

        @Deprecated
public DynStruct create_dyn_struct(TypeCode type)
                                        throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynStruct object from the given TypeCode object.

        Parameters:
        type - the TypeCode object from which to create a new DynStruct object
        Returns:
        the new DynStruct object created from the given TypeCode object
        Throws:
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        See Also:
        CORBA package comments for unimplemented features

      • create_dyn_sequence

        @Deprecated
public DynSequence create_dyn_sequence(TypeCode type)
                                            throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynSequence object from the given TypeCode object.

        Parameters:
        type - the TypeCode object from which to create a new DynSequence object
        Returns:
        the new DynSequence object created from the given TypeCode object
        Throws:
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        See Also:
        CORBA package comments for unimplemented features

      • create_dyn_array

        @Deprecated
public DynArray create_dyn_array(TypeCode type)
                                      throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynArray object from the given TypeCode object.

        Parameters:
        type - the TypeCode object from which to create a new DynArray object
        Returns:
        the new DynArray object created from the given TypeCode object
        Throws:
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        See Also:
        CORBA package comments for unimplemented features

      • create_dyn_union

        @Deprecated
public DynUnion create_dyn_union(TypeCode type)
                                      throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynUnion object from the given TypeCode object.

        Parameters:
        type - the TypeCode object from which to create a new DynUnion object
        Returns:
        the new DynUnion object created from the given TypeCode object
        Throws:
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        See Also:
        CORBA package comments for unimplemented features

      • create_dyn_enum

        @Deprecated
public DynEnum create_dyn_enum(TypeCode type)
                                    throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynEnum object from the given TypeCode object.

        Parameters:
        type - the TypeCode object from which to create a new DynEnum object
        Returns:
        the new DynEnum object created from the given TypeCode object
        Throws:
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        See Also:
        CORBA package comments for unimplemented features

      • create_policy

        public Policy create_policy(int type,
                            Any val)
                     throws PolicyError
        Can be invoked to create new instances of policy objects of a specific type with specified initial state. If create_policy fails to instantiate a new Policy object due to its inability to interpret the requested type and content of the policy, it raises the PolicyError exception with the appropriate reason.
        Parameters:
        type - the PolicyType of the policy object to be created
        val - the value that will be used to set the initial state of the Policy object that is created
        Returns:
        Reference to a newly created Policy object of type specified by the type parameter and initialized to a state specified by the val parameter
        Throws:
        org.omg.CORBA.PolicyError - when the requested policy is not supported or a requested initial state for the policy is not supported.
        PolicyError
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA (Java Platform SE 8 )

org.omg.CORBA

Interfaces

  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • CTX_RESTRICT_SCOPE
  • Current
  • CurrentOperations
  • CustomMarshal
  • DataInputStream
  • DataOutputStream
  • DomainManager
  • DomainManagerOperations
  • DynAny
  • DynArray
  • DynEnum
  • DynFixed
  • DynSequence
  • DynStruct
  • DynUnion
  • DynValue
  • IDLType
  • IDLTypeOperations
  • IRObject
  • IRObjectOperations
  • Object
  • OMGVMCID
  • Policy
  • PolicyOperations
  • PRIVATE_MEMBER
  • PUBLIC_MEMBER
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_NONE
  • VM_TRUNCATABLE

Classes

  • _IDLTypeStub
  • _PolicyStub
  • Any
  • AnyHolder
  • AnySeqHelper
  • AnySeqHolder
  • BooleanHolder
  • BooleanSeqHelper
  • BooleanSeqHolder
  • ByteHolder
  • CharHolder
  • CharSeqHelper
  • CharSeqHolder
  • CompletionStatus
  • CompletionStatusHelper
  • Context
  • ContextList
  • CurrentHelper
  • CurrentHolder
  • DefinitionKind
  • DefinitionKindHelper
  • DoubleHolder
  • DoubleSeqHelper
  • DoubleSeqHolder
  • DynamicImplementation
  • Environment
  • ExceptionList
  • FieldNameHelper
  • FixedHolder
  • FloatHolder
  • FloatSeqHelper
  • FloatSeqHolder
  • IdentifierHelper
  • IDLTypeHelper
  • IntHolder
  • LocalObject
  • LongHolder
  • LongLongSeqHelper
  • LongLongSeqHolder
  • LongSeqHelper
  • LongSeqHolder
  • NamedValue
  • NameValuePair
  • NameValuePairHelper
  • NVList
  • ObjectHelper
  • ObjectHolder
  • OctetSeqHelper
  • OctetSeqHolder
  • ORB
  • ParameterMode
  • ParameterModeHelper
  • ParameterModeHolder
  • PolicyErrorCodeHelper
  • PolicyErrorHelper
  • PolicyErrorHolder
  • PolicyHelper
  • PolicyHolder
  • PolicyListHelper
  • PolicyListHolder
  • PolicyTypeHelper
  • Principal
  • PrincipalHolder
  • RepositoryIdHelper
  • Request
  • ServerRequest
  • ServiceDetail
  • ServiceDetailHelper
  • ServiceInformation
  • ServiceInformationHelper
  • ServiceInformationHolder
  • SetOverrideType
  • SetOverrideTypeHelper
  • ShortHolder
  • ShortSeqHelper
  • ShortSeqHolder
  • StringHolder
  • StringSeqHelper
  • StringSeqHolder
  • StringValueHelper
  • StructMember
  • StructMemberHelper
  • TCKind
  • TypeCode
  • TypeCodeHolder
  • ULongLongSeqHelper
  • ULongLongSeqHolder
  • ULongSeqHelper
  • ULongSeqHolder
  • UnionMember
  • UnionMemberHelper
  • UnknownUserExceptionHelper
  • UnknownUserExceptionHolder
  • UShortSeqHelper
  • UShortSeqHolder
  • ValueBaseHelper
  • ValueBaseHolder
  • ValueMember
  • ValueMemberHelper
  • VersionSpecHelper
  • VisibilityHelper
  • WCharSeqHelper
  • WCharSeqHolder
  • WrongTransactionHelper
  • WrongTransactionHolder
  • WStringSeqHelper
  • WStringSeqHolder
  • WStringValueHelper

Exceptions

  • ACTIVITY_COMPLETED
  • ACTIVITY_REQUIRED
  • BAD_CONTEXT
  • BAD_INV_ORDER
  • BAD_OPERATION
  • BAD_PARAM
  • BAD_QOS
  • BAD_TYPECODE
  • Bounds
  • CODESET_INCOMPATIBLE
  • COMM_FAILURE
  • DATA_CONVERSION
  • FREE_MEM
  • IMP_LIMIT
  • INITIALIZE
  • INTERNAL
  • INTF_REPOS
  • INV_FLAG
  • INV_IDENT
  • INV_OBJREF
  • INV_POLICY
  • INVALID_ACTIVITY
  • INVALID_TRANSACTION
  • MARSHAL
  • NO_IMPLEMENT
  • NO_MEMORY
  • NO_PERMISSION
  • NO_RESOURCES
  • NO_RESPONSE
  • OBJ_ADAPTER
  • OBJECT_NOT_EXIST
  • PERSIST_STORE
  • PolicyError
  • REBIND
  • SystemException
  • TIMEOUT
  • TRANSACTION_MODE
  • TRANSACTION_REQUIRED
  • TRANSACTION_ROLLEDBACK
  • TRANSACTION_UNAVAILABLE
  • TRANSIENT
  • UNKNOWN
  • UnknownUserException
  • UserException
  • WrongTransaction


org.omg.CORBA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA

Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

See: Description

  • Interface Summary
    Interface Description
    ARG_IN
    Signifies an "input" argument to an invocation, meaning that the argument is being passed from the client to the server.
    ARG_INOUT
    Signifies an argument used for both input and output in an invocation, meaning that the argument is being passed from the client to the server and then back from the server to the client.
    ARG_OUT
    A constant that signifies an "output" argument to an invocation, meaning that the argument is being passed from the server to the client.
    BAD_POLICY
    A PolicyErrorCode which would be filled in the PolicyError exception.
    BAD_POLICY_TYPE
    A PolicyErrorCode which would be filled in the PolicyError exception.
    BAD_POLICY_VALUE
    Contains the value used to indicate a policy value that is incorrect for a valid policy type in a call to the create_policy method defined in the ORB class.
    CTX_RESTRICT_SCOPE
    A flag that can be used as the second parameter to the method Context.get_values to restrict the search scope.
    Current
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
    CurrentOperations
    The interface for Current.
    CustomMarshal
    An abstract value type that is meant to be used by the ORB, not the user.
    DataInputStream
    Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
    DataOutputStream
    Defines the methods used to write primitive data types to output streams for marshalling custom value types.
    DomainManager
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
    DomainManagerOperations
    Provides the DomainManager with the means to access policies.
    DynAny Deprecated
    Use the new DynAny instead
    DynArray Deprecated
    Use the new DynArray instead
    DynEnum Deprecated
    Use the new DynEnum instead
    DynFixed Deprecated
    Use the new DynFixed instead
    DynSequence Deprecated
    Use the new DynSequence instead
    DynStruct Deprecated
    Use the new DynStruct instead
    DynUnion Deprecated
    Use the new DynUnion instead
    DynValue Deprecated
    Use the new DynValue instead
    IDLType
    An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
    IDLTypeOperations
    This interface must be implemented by all IDLType objects.
    IRObject
    An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
    IRObjectOperations
    This is the Operations interface for the mapping from IRObject.
    Object
    The definition for a CORBA object reference.
    OMGVMCID
    The vendor minor code ID reserved for OMG.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyOperations
    Provides the operations for a Policy object.
    PRIVATE_MEMBER
    Constant to define a private member in the ValueMember class.
    PUBLIC_MEMBER
    Constant to define a public member in the ValueMember class.
    UNSUPPORTED_POLICY
    One of the PolicyErrorCodes which would be filled if the requested Policy is understood to be valid by the ORB, but is not currently supported.
    UNSUPPORTED_POLICY_VALUE
    A PolicyErrorCode which would be filled if the value requested for the Policy is of a valid type and within the valid range for that type, but this valid value is not currently supported.
    VM_ABSTRACT
    Defines the code used to represent an Abstract interface in a typecode.
    VM_CUSTOM
    Defines the code used to represent a custom marshalled value type in a typecode.
    VM_NONE
    Defines the code used to represent the one of the values of a value type in a typecode.
    VM_TRUNCATABLE
    Defines the code used to represent a truncatable value type in a typecode.
  • Class Summary
    Class Description
    _IDLTypeStub
    The Stub for IDLType.
    _PolicyStub
    The Stub for Policy.
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    AnyHolder
    The Holder for Any.
    AnySeqHelper
    The Helper for AnySeq.
    AnySeqHolder
    The Holder for AnySeq.
    BooleanHolder
    The Holder for Boolean.
    BooleanSeqHelper
    The Helper for BooleanSeq.
    BooleanSeqHolder
    The Holder for BooleanSeq.
    ByteHolder
    The Holder for Byte.
    CharHolder
    The Holder for Char.
    CharSeqHelper
    The Helper for CharSeq.
    CharSeqHolder
    The Holder for CharSeq.
    CompletionStatus
    An object that indicates whether a method had completed running when a SystemException was thrown.
    CompletionStatusHelper
    The Helper for CompletionStatus.
    Context
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
    ContextList
    An object containing a modifiable list of String objects that represent property names.
    CurrentHelper
    The Helper for Current.
    CurrentHolder
    The Holder for Current.
    DefinitionKind
    The class that provides the constants used to identify the type of an Interface Repository object.
    DefinitionKindHelper
    The Helper for DefinitionKind.
    DoubleHolder
    The Holder for Double.
    DoubleSeqHelper
    The Helper for DoubleSeq.
    DoubleSeqHolder
    The Holder for DoubleSeq.
    DynamicImplementation Deprecated
    org.omg.CORBA.DynamicImplementation
    Environment
    A container (holder) for an exception that is used in Request operations to make exceptions available to the client.
    ExceptionList
    An object used in Request operations to describe the exceptions that can be thrown by a method.
    FieldNameHelper
    The Helper for FieldName.
    FixedHolder
    The Holder for Fixed.
    FloatHolder
    The Holder for Float.
    FloatSeqHelper
    The Helper for FloatSeq.
    FloatSeqHolder
    The Holder for FloatSeq.
    IdentifierHelper
    The Helper for Identifier.
    IDLTypeHelper
    The Helper for IDLType.
    IntHolder
    The Holder for Int.
    LocalObject
    Used as a base class for implementation of a local IDL interface in the Java language mapping.
    LongHolder
    The Holder for Long.
    LongLongSeqHelper
    The Helper for LongLongSeq.
    LongLongSeqHolder
    The Holder for LongLongSeq.
    LongSeqHelper
    The Helper for LongSeqHelper.
    LongSeqHolder
    The Holder for LongSeq.
    NamedValue
    An object used in the DII and DSI to describe arguments and return values.
    NameValuePair
    Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
    NameValuePairHelper
    The Helper for NameValuePair.
    NVList
    A modifiable list containing NamedValue objects.
    ObjectHelper
    ObjectHolder
    The Holder for Object.
    OctetSeqHelper
    The Helper for OctetSeq.
    OctetSeqHolder
    The Holder for OctetSeq.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    ParameterMode
    Enumeration of parameter modes for Parameter.
    ParameterModeHelper
    Enumeration of parameter modes for Parameter.
    ParameterModeHolder
    Enumeration of parameter modes for Parameter.
    PolicyErrorCodeHelper
    Encapsulates a reason a Policy may be invalid.
    PolicyErrorHelper
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
    PolicyErrorHolder
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
    PolicyHelper
    The Helper for Policy.
    PolicyHolder
    The Holder for Policy.
    PolicyListHelper
    The Helper for PolicyList.
    PolicyListHolder
    The Holder for PolicyList.
    PolicyTypeHelper
    The Helper for PolicyType.
    Principal Deprecated
    Deprecated by CORBA 2.2.
    PrincipalHolder Deprecated
    Deprecated by CORBA 2.2.
    RepositoryIdHelper
    The Helper for RepositoryId.
    Request
    An object containing the information necessary for invoking a method.
    ServerRequest
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).
    ServiceDetail
    An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.
    ServiceDetailHelper
    ServiceInformation
    An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.
    ServiceInformationHelper
    ServiceInformationHolder
    The Holder for ServiceInformation.
    SetOverrideType
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
    SetOverrideTypeHelper
    The Helper for SetOverrideType.
    ShortHolder
    The Holder for Short.
    ShortSeqHelper
    The Helper for ShortSeqHelper.
    ShortSeqHolder
    The Holder for ShortSeq.
    StringHolder
    The Holder for String.
    StringSeqHelper
    An array of Strings
    StringSeqHolder
    An array of Strings
    StringValueHelper
    The Helper for StringValue.
    StructMember
    Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.
    StructMemberHelper
    The Helper for StructMember.
    TCKind
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
    TypeCode
    A container for information about a specific CORBA data type.
    TypeCodeHolder
    The Holder for TypeCode.
    ULongLongSeqHelper
    The Helper for ULongLongSeq.
    ULongLongSeqHolder
    The Holder for ULongLongSeq.
    ULongSeqHelper
    The Helper for ULongSeq.
    ULongSeqHolder
    The Holder for ULongSeq.
    UnionMember
    A description in the Interface Repository of a member of an IDL union.
    UnionMemberHelper
    The Helper for UnionMember.
    UnknownUserExceptionHelper
    The Helper for UnknownUserException.
    UnknownUserExceptionHolder
    The Holder for UnknownUserException.
    UShortSeqHelper
    The Helper for UShortSeq.
    UShortSeqHolder
    The Holder for UShortSeq.
    ValueBaseHelper
    ValueBaseHolder
    The Holder for ValueBase.
    ValueMember
    A description in the Interface Repository of a member of a value object.
    ValueMemberHelper
    The Helper for ValueMember.
    VersionSpecHelper
    The Helper for VersionSpec.
    VisibilityHelper
    The Helper for Visibility.
    WCharSeqHelper
    The Helper for WCharSeq.
    WCharSeqHolder
    The Holder for WCharSeq.
    WrongTransactionHelper
    The Helper for WrongTransaction.
    WrongTransactionHolder
    The Holder for WrongTransaction.
    WStringSeqHelper
    An array of WStrings
    WStringSeqHolder
    An array of WStrings
    WStringValueHelper
    org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications : ORB core as defined by CORBA 2.3.1 (formal/99-10-07) IDL/Java Language Mapping as defined in ptc/00-01-08
  • Exception Summary
    Exception Description
    ACTIVITY_COMPLETED
    The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed.
    ACTIVITY_REQUIRED
    The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required.
    BAD_CONTEXT
    Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.
    BAD_INV_ORDER
    This exception indicates that the caller has invoked operations in the wrong order.
    BAD_OPERATION
    Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
    BAD_PARAM
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
    BAD_QOS
    The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
    BAD_TYPECODE
    Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).
    Bounds
    A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
    CODESET_INCOMPATIBLE
    This exception is raised whenever meaningful communication is not possible between client and server native code sets.
    COMM_FAILURE
    This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.
    DATA_CONVERSION
    This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
    FREE_MEM
    Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.
    IMP_LIMIT
    This exception indicates that an implementation limit was exceeded in the ORB run time.
    INITIALIZE
    Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.
    INTERNAL
    This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.
    INTF_REPOS
    Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.
    INV_FLAG
    Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).
    INV_IDENT
    This exception indicates that an IDL identifier is syntactically invalid.
    INV_OBJREF
    This exception indicates that an object reference is internally malformed.
    INV_POLICY
    Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation.
    INVALID_ACTIVITY
    The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended.
    INVALID_TRANSACTION
    Exception thrown when the request carried an invalid transaction context.
    MARSHAL
    A request or reply from the network is structurally invalid.
    NO_IMPLEMENT
    This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists.
    NO_MEMORY
    Exception thrown when the ORB run time has run out of memory.
    NO_PERMISSION
    Exception thrown when an invocation failed because the caller has insufficient privileges.
    NO_RESOURCES
    Exception thrown when the ORB has encountered some general resource limitation.
    NO_RESPONSE
    This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.
    OBJ_ADAPTER
    This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.
    OBJECT_NOT_EXIST
    Exception raised whenever an invocation on a deleted object was performed.
    PERSIST_STORE
    This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.
    PolicyError
    A user exception thrown when a policy error occurs.
    REBIND
    REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD.
    SystemException
    The root class for all CORBA standard exceptions.
    TIMEOUT
    TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded.
    TRANSACTION_MODE
    The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation).
    TRANSACTION_REQUIRED
    Exception indicates that the request carried a null transaction context, but an active transaction is required.
    TRANSACTION_ROLLEDBACK
    Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back.
    TRANSACTION_UNAVAILABLE
    The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated.
    TRANSIENT
    Exception thrown when the ORB attempted to reach an object and failed.
    UNKNOWN
    This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression.
    UnknownUserException
    A class that contains user exceptions returned by the server.
    UserException
    The root class for CORBA IDL-defined user exceptions.
    WrongTransaction
    The CORBA WrongTransaction user-defined exception.

Package org.omg.CORBA Description

Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

For a precise list of supported sections of official CORBA specifications with which the Java[TM] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[TM] SE 6.

General Information

The information in this section is information relevant to someone who compiles Interface Definition Language (IDL) files and uses the ORB to write clients and servers.

The classes and interfaces described in this section can be put into four groups: ORB classes, Exceptions, Helper classes, and Holder classes.

The ORB Class

An ORB handles (or brokers) method invocations between a client and the method's implementation on a server. Because the client and server may be anywhere on a network, and because the invocation and implementation may be written in different programming languages, an ORB does a great deal of work behind the scenes to accomplish this communication.

Most of what an ORB does is completely transparent to the user, and a major portion of the CORBA package consists of classes used by the ORB behind the scenes. The result is that most programmers will use only a small part of this package directly. In fact, most programmers will use only a few methods from the ORB class, some exceptions, and occasionally, a holder class.

ORB Methods

Before an application can enter the CORBA environment, it must first:

  • Be initialized into the ORB and possibly the object adapter (POA) environments.
  • Get references to ORB object (for use in future ORB operations) and perhaps other objects (including the root POA or some Object Adapter objects).

The following operations are provided to initialize applications and obtain the appropriate object references:

  • Operations providing access to the ORB, which are discussed in this section.
  • Operations providing access to Object Adapters, Interface Repository, Naming Service, and other Object Services. These operations are described in Other Classes.

When an application requires a CORBA environment it needs a mechanism to get an ORB object reference and possibly an OA object reference (such as the root POA). This serves two purposes. First, it initializes an application into the ORB and OA environments. Second, it returns the ORB object reference and the OA object reference to the application for use in future ORB and OA operations.

In order to obtain an ORB object reference, applications call the ORB.init operation. The parameters to the call can comprise an identifier for the ORB for which the object reference is required, and an arg_list, which is used to allow environment-specific data to be passed into the call.

These are the ORB methods that provide access to the ORB:

  • init()
  • init(String [] args, Properties props)
  • init(Applet app, Properties props)

Using the init() method without parameters initiates a singleton ORB, which can only give typecode creation anys needed in code generated in Helper classes by idlj.

Applications require a portable means by which to obtain their initial object references. References are required for the root POA, POA Current, Interface Repository, and various Object Services instances. The functionality required by the application is similar to that provided by the Naming Service. However, the OMG does not want to mandate that the Naming Service be made available to all applications in order that they may be portably initialized. Consequently, the operations shown in this section provide a simplified, local version of the Naming Service that applications can use to obtain a small, defined set of object references which are essential to its operation. Because only a small well-defined set of objects are expected with this mechanism, the naming context can be flattened to be a single-level name space. This simplification results in only two operations being defined to achieve the functionality required.

Initial references are obtained via two operations provided in the ORB object interface, providing facilities to list and resolve initial object references. These are:

  • resolve_initial_references(String name)
  • list_initial_services()
  • register_initial_reference(String id, org.omg.CORBA.Object obj)

An example that uses some of these methods is Getting Started with Java IDL.

Exceptions

Exceptions in Java IDL are similar to those in any code written in the Java programming language. If a method is defined to throw an exception, then any code using that method must have a try/catch block and handle that exception when it is thrown.

The documentation on Java IDL exceptions has more information and explains the difference between system exceptions and user-defined exceptions.

The following is a list of the system exceptions (which are unchecked exceptions inheriting through org.omg.CORBA.SystemException from java.lang.RuntimeException) that are defined in the package org.omg.CORBA:

        BAD_CONTEXT
        BAD_INV_ORDER
        BAD_OPERATION
        BAD_PARAM
        BAD_TYPECODE
        COMM_FAILURE
        DATA_CONVERSION
        FREE_MEM
        IMP_LIMIT
        INITIALIZE
        INTERNAL
        INTF_REPOS
        INVALID_TRANSACTION
        INV_FLAG
        INV_IDENT
        INV_OBJREF
        INV_POLICY
        MARSHAL
        NO_IMPLEMENT
        NO_MEMORY
        NO_PERMISSION
        NO_RESOURCES
        NO_RESPONSE
        OBJECT_NOT_EXIST
        OBJ_ADAPTER
        PERSIST_STORE
        TRANSACTION_REQUIRED
        TRANSACTION_ROLLEDBACK
        TRANSIENT
        UNKNOWN

The following is a list of user-defined exceptions defined in the package org.omg.CORBA.

        Bounds
        UnknownUserException
        WrongTransaction
        PolicyError

Subpackages

There are some packages inside the CORBA package with "Package" as part of their names. These packages are generally quite small because all they do is provide exceptions or classes for use by interfaces and classes in the CORBA package.

For example, the package org.omg.CORBA.TypeCodePackage contains two exceptions thrown by methods in the class TypeCode. These exceptions are:

  • BadKind
  • Bounds
The package org.omg.CORBA.ORBPackage contains two exceptions:
  • InvalidName
  • InconsistentTypeCode

Another package that is a subpackage of CORBA is the portable package. It provides a set of ORB APIs that makes it possible for code generated by one vendor's IDL compiler to run on another vendor's ORB.

Holder classes

Support for out and inout parameter passing modes requires the use of additional holder classes. Because the Java programming language does not support out or inout parameters, holder classes are needed as a means of passing a parameter that can be modified. To support portable stubs and skeletons, holder classes also implement the org.omg.CORBA.portable.Streamable interface.

Holder classes are named by appending "Holder" to the name of the type. The name of the type refers to its name in the Java programming language. For example, a holder class for the interface named Account in the Java programming language would be named AccountHolder.

Holder classes are available for all of the basic IDL datatypes in the org.omg.CORBA package. So, for example, there are already-defined classes for LongHolder, ShortHolder, FloatHolder, and so on. Classes are also generated for all named user-defined IDL types except those defined by typedefs. (Note that in this context user defined includes types that are defined in OMG specifications such as those for the Interface Repository, and other OMG services.)

Each holder class has:

  • a constructor from an instance
  • a default constructor
  • a public instance member, value which is the typed value.
  • a method for reading an input stream and assigning the contents to the type's value field
  • a method for writing the value of the value field to an output stream
  • a method for getting the typecode of the type

The default constructor sets the value field to the default value for the type as defined by the Java language:

  • false for boolean
  • 0 for numeric and char types
  • null for strings and object references

As an example, if the interface Account, defined in OMG IDL, were mapped to the Java programming language, the following holder class would be generated:

public final class AccountHolder implements
    org.omg.CORBA.portable.Streamable
{
  // field that holds an Account object
  public Account value = null;

  // default constructor
  public AccountHolder ()
  {
  }

  // creates a new AccountHolder from initialValue
  public AccountHolder (Account initialValue)
  {
    value = initialValue;
  }

  // reads the contents of i and assigns the contents to value
  public void _read (org.omg.CORBA.portable.InputStream i)
  {
    value = AccountHelper.read (i);
  }

  // writes value to o
  public void _write (org.omg.CORBA.portable.OutputStream o)
  {
    AccountHelper.write (o, value);
  }

  // returns the typecode for Account
  public org.omg.CORBA.TypeCode _type ()
  {
    return AccountHelper.type ();
  }

}

For more information on Holder classes, see Chapter 1.4, Mapping for Basic Types in the OMG IDL to Java Language Mapping. The Holder classes defined in the package org.omg.CORBA are:

     AnyHolder
     AnySeqHolder
     BooleanHolder
     BooleanSeqHolder
     ByteHolder
     CharHolder
     CharSeqHolder
     CurrentHolder
     DoubleHolder
     DoubleSeqHolder
     FixedHolder
     FloatHolder
     FloatSeqHolder
     IntHolder
     LongHolder
     LongLongSeqHolder
     LongSeqHolder
     ObjectHolder
     OctetSeqHolder
     ParameterModeHolder
     PolicyErrorHolder
     PolicyListHolder
     PrincipalHolder
     ServiceInformationHolder
     ShortHolder
     ShortSeqHolder
     StringHolder
     StringSeqHolder
     TypeCodeHolder
     ULongLongSeqHolder
     ULongSeqHolder
     UnknownUserExceptionHolder
     UShortSeqHolder
     ValueBaseHolder
     WCharSeqHolder
     WrongTransactionHolder
     WStringSeqHolder

Helper Classes

Helper files supply several static methods needed to manipulate the type. These include:

  • Any insert and extract operations for the type
  • getting the repository id
  • getting the typecode
  • reading and writing the type from and to a stream
  • implement the ValueHelper interface (if it is a user-defined value type)

The helper class for a mapped IDL interface or abstract interface also include narrow operation(s). The static narrow method allows an org.omg.CORBA.Object to be narrowed to the object reference of a more specific type. The IDL exception CORBA.BAD_PARAM is thrown if the narrow fails because the object reference does not support the requested type. A different system exception is raised to indicate other kinds of errors. Trying to narrow a null will always succeed with a return value of null. Generally, the only helper method an application programmer uses is the narrow method. The other methods are normally used behind the scenes and are transparent to the programmer.

Helper classes fall into two broad categories, helpers for value types and helpers for non value types. Because all of the helper classes in one category provide the same methods, one generic explanation of each category of helper classes is presented here.

When OMG IDL is mapped to the Java programming language, a "helper" class is generated for each user-defined type. This generated class will have the name of the user-defined type with the suffix Helper appended. For example, if the interface Account is defined in OMG IDL, the idlj compiler will automatically generate a class named AccountHelper. The AccountHelper class will contain the static methods needed for manipulating instances of the type, in this case, Account objects.

The narrow Method

When an object is the return value for a method, it is returned in the form of a generic object, either an org.omg.CORBA.Object object or a java.lang.Object object. This object must be cast to its more specific type before it can be operated on. For example, an Account object will be returned as a generic object and must be narrowed to an Account object so that Account methods may be called on it.

The narrow method has two forms, one that takes an org.omg.CORBA.Object object and one that takes a java.lang.Object object. Whether the interface is abstract or not determines which narrow method its helper class will provide. The helper class for an interface that is not abstract will have a narrow method that takes a CORBA object, whereas the narrow method for an interface that is abstract will take an object in the Java programming language. The helper class for a non-abstract interface that has at least one abstract base interface will provide both versions of the narrow method.

The Hello World tutorial uses a narrow method that looks like this:

        // create and initialize the ORB
        ORB orb = ORB.init(args, null);

        // get the root naming context
        org.omg.CORBA.Object objRef =
            orb.resolve_initial_references("NameService");
        // Use NamingContextExt instead of NamingContext. This is
        // part of latest Inter-Operable naming Service.
        NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

        // resolve the Object Reference in Naming
        String name = "Hello";
        helloImpl = HelloHelper.narrow(ncRef.resolve_str(name));

Example of a Basic Helper Class

A basic helper class, for purposes of this explanation, is one with the methods that are provided by every helper class, plus a narrow method if the type defined in OMG IDL maps to an interface in the Java programming language. Types that are not value types will have a basic helper class generated for them.

For example, assuming that the interface Account is not a value type IDL type and is also not an abstract interface and has no abstract base interfaces, its AccountHelper class will look like this:

abstract public class AccountHelper
{
  private static String  _id = "IDL:Account:1.0";

  // inserts an Account object into an Any object
  public static void insert (org.omg.CORBA.Any a, Account that)
  {
    org.omg.CORBA.portable.OutputStream out = a.create_output_stream ();
    a.type (type ());
    write (out, that);
    a.read_value (out.create_input_stream (), type ());
  }

  // extracts an Account object from an Any object
  public static Account extract (org.omg.CORBA.Any a)
  {
    return read (a.create_input_stream ());
  }

  private static org.omg.CORBA.TypeCode __typeCode = null;
  // gets the typecode for this type
  synchronized public static org.omg.CORBA.TypeCode type ()
  {
    if (__typeCode == null)
    {
      __typeCode = org.omg.CORBA.ORB.init ().create_interface_tc (AccountHelper.id (), "Account");
    }
    return __typeCode;
  }

  // gets the repository id for this type
  public static String id ()
  {
    return _id;
  }

  // reads an Account object from an input stream
  public static Account read (org.omg.CORBA.portable.InputStream istream)
  {
    return narrow (istream.read_Object (_AccountStub.class));
  }

  // writes an Account object to an outputstream
  public static void write (org.omg.CORBA.portable.OutputStream ostream, Account value)
  {
    ostream.write_Object ((org.omg.CORBA.Object) value);
  }

  // converts (narrows) an Object to an Account object
  public static Account narrow (org.omg.CORBA.Object obj)
  {
    if (obj == null)
      return null;
    else if (obj instanceof Account)
      return (Account)obj;
    else if (!obj._is_a (id ()))
      throw new org.omg.CORBA.BAD_PARAM ();
    else
    {
      org.omg.CORBA.portable.Delegate delegate = ((org.omg.CORBA.portable.ObjectImpl)obj)._get_delegate ();
      _AccountStub stub = new _AccountStub ();
      stub._set_delegate(delegate);
      return stub;
    }
  }

}

Value Type Helper Classes

A helper class for a value type includes different renderings of the same methods generated for non-value type methods. The main difference is that value types are types that can be passed by value as parameters or return values of a method, which means that they must be serializable.

Assuming that Address is a value type, the AddressHelper class will look like this:

abstract public class AddressHelper
{
  private static String  _id = "IDL:Address:1.0";

  // same as for non-value type
  public static void insert (org.omg.CORBA.Any a, Address that)
  {
    org.omg.CORBA.portable.OutputStream out = a.create_output_stream ();
    a.type (type ());
    write (out, that);
    a.read_value (out.create_input_stream (), type ());
  }

  // same as for non-value type
  public static Address extract (org.omg.CORBA.Any a)
  {
    return read (a.create_input_stream ());
  }

  private static org.omg.CORBA.TypeCode __typeCode = null;
  private static boolean __active = false;

  // getting the typecode for the type
  synchronized public static org.omg.CORBA.TypeCode type ()
  {
    if (__typeCode == null)
    {
      synchronized (org.omg.CORBA.TypeCode.class)
      {
        if (__typeCode == null)
        {
          if (__active)
          {
            return org.omg.CORBA.ORB.init().create_recursive_tc ( _id );
          }
          __active = true;
          org.omg.CORBA.ValueMember[] _members0 = new org.omg.CORBA.ValueMember[0];
          org.omg.CORBA.TypeCode _tcOf_members0 = null;
          __typeCode = org.omg.CORBA.ORB.init ().create_value_tc (_id, "Address", org.omg.CORBA.VM_NONE.value, null, _members0);
          __active = false;
        }
      }
    }
    return __typeCode;
  }

  // same as for non-value type
  public static String id ()
  {
    return _id;
  }

  // reads a serializable instance of Address from the given input stream
  public static Address read (org.omg.CORBA.portable.InputStream istream)
  {
    return (Address)((org.omg.CORBA_2_3.portable.InputStream) istream).read_value (id ());
  }

  // writes a serializable instance of Address to the given output stream
  public static void write (org.omg.CORBA.portable.OutputStream ostream, Address value)
  {
    ((org.omg.CORBA_2_3.portable.OutputStream) ostream).write_value (value, id ());
  }

}

The Helper classes defined in the package org.omg.CORBA are:

     AnySeqHelper
     BooleanSeqHelper
     CharSeqHelper
     CompletionStatusHelper
     CurrentHelper
     DefinitionKindHelper
     DoubleSeqHelper
     FieldNameHelper
     FloatSeqHelper
     IdentifierHelper
     IDLTypeHelper
     LongLongSeqHelper
     LongSeqHelper
     NameValuePairHelper
     ObjectHelper
     OctetSeqHelper
     ParameterModeHelper
     PolicyErrorCodeHelper
     PolicyErrorHelper
     PolicyHelper
     PolicyListHelper
     PolicyTypeHelper
     RepositoryIdHelper
     ServiceDetailHelper
     ServiceInformationHelper
     SetOverrideTypeHelper
     ShortSeqHelper
     StringSeqHelper
     StringValueHelper
     StructMemberHelper
     ULongLongSeqHelper
     ULongSeqHelper
     UnionMemberHelper
     UnknownUserExceptionHelper
     UShortSeqHelper
     ValueBaseHelper
     ValueMemberHelper
     VersionSpecHelper
     VisibilityHelper
     WCharSeqHelper
     WrongTransactionHelper
     WStringSeqHelper
     WStringValueHelper

Other Classes

The other classes and interfaces in the CORBA package, which are used behind the scenes, can be put into four groups. Three of the groups are used with requests in some capacity, and the fourth group, concerning the Interface Repository, is a category by itself.

Classes Created by an ORB

The first group contains classes that are created by an ORB and contain information used in request operations.
  • TCKind -- indicates the kind (datatype) for a TypeCode object
  • TypeCode -- indicates a datatype and possibly other information
  • Any -- contains a value and its typecode
  • NamedValue -- contains a name, an Any object, and an argument mode flag. NamedValue objects contain information about method arguments, method return values, or a context.
  • ContextList -- a list of strings that describe the contexts that need to be resolved and sent with an invocation
  • ExceptionList -- a list of TypeCodes for exceptions that may be thrown by a method
  • Environment -- a container for the exception thrown during a method invocation
  • Context -- a list of NamedValue objects used to pass auxiliary information from client to server
  • NVList -- a list of NamedValue objects, used to pass arguments or get results

Classes That Deal with Requests

The second group of classes deals with requests:
  • Object -- the base class for all CORBA object references
  • Request -- the main class in the DII, which contains methods for adding arguments to the request, for accessing information about the method being invoked (the method name, its arguments, exceptions it throws, and so on), and for making invocations on the request
  • DynamicImplementation -- the base class for server implementations using the DSI. It has the method invoke, which is used by an implementation of this class to determine the state of a ServerRequest object and to set its result or exception
  • ServerRequest -- captures the explicit state of a request for the Dynamic Skeleton Interface

Interfaces That Serve as Constants

The third group contains interfaces that serve as constants. The IDL-to-Java mapping mandates that IDL enums are mapped to a Java class with the enumerated values represented as public static final fields in that class (e.g. DefinitionKind). On the other hand IDL constants defined outside of an IDL interface are mapped to a Java interface for each constant.

This is why several interfaces in the org.omg.CORBA package consist of a single field, value, which is a short. This field is a constant used for such things as an error code or value modifier. For example, the value field of the interface BAD_POLICY is one of the possible reasons for the exception PolicyError to be thrown. To specify this error code, you would use BAD_POLICY.value.

The exception PolicyError uses the value field of the following interfaces as its possible error codes.

  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
The method TypeCode.type_modifier returns the value field of one of the following interfaces. The VM in the names of these interfaces stands for "value modifier."
  • VM_NONE
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_TRUNCATABLE
The following constants are returned by a ValueMember object's access method to denote the visibility of the ValueMember object.
  • PRIVATE_MEMBER
  • PUBLIC_MEMBER
These flags, used in NamedValue objects or as parameters to methods, are defined in the following interfaces:
  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • CTX_RESTRICT_SCOPE

Interface Repository Interfaces and Classes

A fourth group contains the Interface Repository interfaces and classes, which are generated by the idlj compiler from the OMG IDL interface ir.idl. The purpose of the Interface Repository is to identify the interfaces stored in it so that they can be accessed by an ORB. Each module, type, interface, attribute, operation, parameter, exception, constant, and so on is described completely by the Interface Repository API.

An ORB does not require that there be an interface repository, and Java IDL does not include one. Even though this release does not include an implementation of an interface repository, the following IR classes and interfaces have been included for the purpose of creating typecodes (see create_value_tc, create_struct_tc, create_union_tc and create_exception_tc methods in interface org.omg.CORBA.ORB):
&nbs

  • IRObject
  • IDLType
  • DefinitionKind
  • StructMember
  • UnionMember
  • ValueMember

Related Documentation

For overviews, guides, and a tutorial, please see:
  • Java IDL home page

CORBA Features Not Implemented in Java IDL

Some of the API included in org.omg subpackages is provided for conformance with the current OMG CORBA specification but is not implemented in Sun's release of the JDKTM. This enables other JDK licensees to provide implementations of this API in standard extensions and products.

Features That Throw NO_IMPLEMENT

Some of the API included in org.omg subpackages throw NO_IMPLEMENT exceptions for various reasons. Among these reasons are:

  • In some cases, for example LocalObject, the complete implementation according to the specification indicates that these API should throw NO_IMPLEMENT.

  • In most cases, for example methods in ORB.java, methods that throw NO_IMPLEMENT are actually implemented in subclasses elsewhere in the ORB code.

  • In some cases, for example _get_interface_def() and _get_interface, API are really not yet implemented.

General Summary of Features or API Not Implemented in This Release:

  • Interface Repository. An Interface Repository is not required for normal operation of Java IDL.
  • Java IDL does not support long double.
  • Policies (org.omg.CORBA.Policy) and methods for getting them are not implemented.
  • Domain managers (org.omg.CORBA.DomainManager) and methods for getting them are not implemented.
  • Service Information org.omg.CORBA.ServiceInformation and ORB method public boolean get_service_information(short service_type, ServiceInformationHolder service_info) are not implemented.
  • ORB methods for supporting single-threading (perform_work, work_pending) are not implemented.
  • IDL contexts.

Specific List of Unimplemented Features in Package org.omg.CORBA

Unimplemented Methods in package org.omg.CORBA:

  • ORB
    • public org.omg.CORBA.Policy create_policy(int type, org.omg.CORBA.Any val)
    • public void perform_work()
    • public boolean work_pending()
    • public org.omg.CORBA.Current get_current()
    • create_operation_list
    • get_default_context
    • get_service_information
    • obsolete DynAnys (deprecated in favor of DynamicAny package)
Since:
JDK1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.Any (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.AnyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.AnySeqHelper
    • org.omg.CORBA.AnySeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanSeqHelper
    • org.omg.CORBA.BooleanSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ByteHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharSeqHelper
    • org.omg.CORBA.CharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CompletionStatus (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.CompletionStatusHelper
    • org.omg.CORBA.Context
    • org.omg.CORBA.ContextList
    • org.omg.CORBA.CurrentHelper
    • org.omg.CORBA.CurrentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DefinitionKind (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DefinitionKindHelper
    • org.omg.CORBA.DoubleHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DoubleSeqHelper
    • org.omg.CORBA.DoubleSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.Environment
    • org.omg.CORBA.ExceptionList
    • org.omg.CORBA.FieldNameHelper
    • org.omg.CORBA.FixedHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatSeqHelper
    • org.omg.CORBA.FloatSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.IdentifierHelper
    • org.omg.CORBA.IDLTypeHelper
    • org.omg.CORBA.IntHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LocalObject (implements org.omg.CORBA.Object)
    • org.omg.CORBA.LongHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongLongSeqHelper
    • org.omg.CORBA.LongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongSeqHelper
    • org.omg.CORBA.LongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.NamedValue
    • org.omg.CORBA.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.NameValuePairHelper
    • org.omg.CORBA.NVList
    • org.omg.CORBA.ObjectHelper
    • org.omg.CORBA.ObjectHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA._IDLTypeStub (implements org.omg.CORBA.IDLType)
      • org.omg.CORBA._PolicyStub (implements org.omg.CORBA.Policy)
      • org.omg.CORBA.DynamicImplementation
    • org.omg.CORBA.OctetSeqHelper
    • org.omg.CORBA.OctetSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ORB
    • org.omg.CORBA.ParameterMode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ParameterModeHelper
    • org.omg.CORBA.ParameterModeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyErrorCodeHelper
    • org.omg.CORBA.PolicyErrorHelper
    • org.omg.CORBA.PolicyErrorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyHelper
    • org.omg.CORBA.PolicyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyListHelper
    • org.omg.CORBA.PolicyListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyTypeHelper
    • org.omg.CORBA.Principal
    • org.omg.CORBA.PrincipalHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.RepositoryIdHelper
    • org.omg.CORBA.Request
    • org.omg.CORBA.ServerRequest
    • org.omg.CORBA.ServiceDetail (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.CORBA.ServiceInformation (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceInformationHelper
    • org.omg.CORBA.ServiceInformationHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.SetOverrideType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.SetOverrideTypeHelper
    • org.omg.CORBA.ShortHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ShortSeqHelper
    • org.omg.CORBA.ShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringSeqHelper
    • org.omg.CORBA.StringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • org.omg.CORBA.StructMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.StructMemberHelper
    • org.omg.CORBA.TCKind
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
            • org.omg.CORBA.ACTIVITY_REQUIRED
            • org.omg.CORBA.BAD_CONTEXT
            • org.omg.CORBA.BAD_INV_ORDER
            • org.omg.CORBA.BAD_OPERATION
            • org.omg.CORBA.BAD_PARAM
            • org.omg.CORBA.BAD_QOS
            • org.omg.CORBA.BAD_TYPECODE
            • org.omg.CORBA.CODESET_INCOMPATIBLE
            • org.omg.CORBA.COMM_FAILURE
            • org.omg.CORBA.DATA_CONVERSION
            • org.omg.CORBA.FREE_MEM
            • org.omg.CORBA.IMP_LIMIT
            • org.omg.CORBA.INITIALIZE
            • org.omg.CORBA.INTERNAL
            • org.omg.CORBA.INTF_REPOS
            • org.omg.CORBA.INV_FLAG
            • org.omg.CORBA.INV_IDENT
            • org.omg.CORBA.INV_OBJREF
            • org.omg.CORBA.INV_POLICY
            • org.omg.CORBA.INVALID_ACTIVITY
            • org.omg.CORBA.INVALID_TRANSACTION
            • org.omg.CORBA.MARSHAL
            • org.omg.CORBA.NO_IMPLEMENT
            • org.omg.CORBA.NO_MEMORY
            • org.omg.CORBA.NO_PERMISSION
            • org.omg.CORBA.NO_RESOURCES
            • org.omg.CORBA.NO_RESPONSE
            • org.omg.CORBA.OBJ_ADAPTER
            • org.omg.CORBA.OBJECT_NOT_EXIST
            • org.omg.CORBA.PERSIST_STORE
            • org.omg.CORBA.REBIND
            • org.omg.CORBA.TIMEOUT
            • org.omg.CORBA.TRANSACTION_MODE
            • org.omg.CORBA.TRANSACTION_REQUIRED
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
            • org.omg.CORBA.TRANSIENT
            • org.omg.CORBA.UNKNOWN
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.Bounds
          • org.omg.CORBA.PolicyError
          • org.omg.CORBA.UnknownUserException
          • org.omg.CORBA.WrongTransaction
    • org.omg.CORBA.TypeCode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.TypeCodeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongLongSeqHelper
    • org.omg.CORBA.ULongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongSeqHelper
    • org.omg.CORBA.ULongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.UnionMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.UnionMemberHelper
    • org.omg.CORBA.UnknownUserExceptionHelper
    • org.omg.CORBA.UnknownUserExceptionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.UShortSeqHelper
    • org.omg.CORBA.UShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueBaseHelper
    • org.omg.CORBA.ValueBaseHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ValueMemberHelper
    • org.omg.CORBA.VersionSpecHelper
    • org.omg.CORBA.VisibilityHelper
    • org.omg.CORBA.WCharSeqHelper
    • org.omg.CORBA.WCharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WrongTransactionHelper
    • org.omg.CORBA.WrongTransactionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringSeqHelper
    • org.omg.CORBA.WStringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)

Interface Hierarchy

  • org.omg.CORBA.ARG_IN
  • org.omg.CORBA.ARG_INOUT
  • org.omg.CORBA.ARG_OUT
  • org.omg.CORBA.BAD_POLICY
  • org.omg.CORBA.BAD_POLICY_TYPE
  • org.omg.CORBA.BAD_POLICY_VALUE
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CustomMarshal
  • org.omg.CORBA.DomainManagerOperations
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.IRObjectOperations
    • org.omg.CORBA.IDLTypeOperations
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynAny
      • org.omg.CORBA.DynArray (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynValue (also extends org.omg.CORBA.Object)
    • org.omg.CORBA.DynArray (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynValue (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
  • org.omg.CORBA.OMGVMCID
  • org.omg.CORBA.PolicyOperations
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PRIVATE_MEMBER
  • org.omg.CORBA.PUBLIC_MEMBER
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
      • org.omg.CORBA.IRObject (also extends org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
        • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.DataInputStream
        • org.omg.CORBA.DataOutputStream
  • org.omg.CORBA.UNSUPPORTED_POLICY
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • org.omg.CORBA.VM_ABSTRACT
  • org.omg.CORBA.VM_CUSTOM
  • org.omg.CORBA.VM_NONE
  • org.omg.CORBA.VM_TRUNCATABLE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA

  • Packages that use org.omg.CORBA
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in org.omg.CORBA used by javax.rmi.CORBA
    Class and Description
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    SystemException
    The root class for all CORBA standard exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    AnySeqHolder
    The Holder for AnySeq.
    BAD_INV_ORDER
    This exception indicates that the caller has invoked operations in the wrong order.
    BAD_OPERATION
    Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
    BAD_PARAM
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
    BooleanSeqHolder
    The Holder for BooleanSeq.
    Bounds
    A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
    CharSeqHolder
    The Holder for CharSeq.
    CompletionStatus
    An object that indicates whether a method had completed running when a SystemException was thrown.
    Context
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
    ContextList
    An object containing a modifiable list of String objects that represent property names.
    Current
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
    CurrentOperations
    The interface for Current.
    DATA_CONVERSION
    This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
    DataInputStream
    Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
    DataOutputStream
    Defines the methods used to write primitive data types to output streams for marshalling custom value types.
    DefinitionKind
    The class that provides the constants used to identify the type of an Interface Repository object.
    DomainManager
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
    DomainManagerOperations
    Provides the DomainManager with the means to access policies.
    DoubleSeqHolder
    The Holder for DoubleSeq.
    DynAny
    Deprecated.
    Use the new DynAny instead
    DynArray
    Deprecated.
    Use the new DynArray instead
    DynEnum
    Deprecated.
    Use the new DynEnum instead
    DynSequence
    Deprecated.
    Use the new DynSequence instead
    DynStruct
    Deprecated.
    Use the new DynStruct instead
    DynUnion
    Deprecated.
    Use the new DynUnion instead
    Environment
    A container (holder) for an exception that is used in Request operations to make exceptions available to the client.
    ExceptionList
    An object used in Request operations to describe the exceptions that can be thrown by a method.
    FloatSeqHolder
    The Holder for FloatSeq.
    IDLType
    An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
    IDLTypeOperations
    This interface must be implemented by all IDLType objects.
    IRObject
    An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
    IRObjectOperations
    This is the Operations interface for the mapping from IRObject.
    LongLongSeqHolder
    The Holder for LongLongSeq.
    LongSeqHolder
    The Holder for LongSeq.
    MARSHAL
    A request or reply from the network is structurally invalid.
    NamedValue
    An object used in the DII and DSI to describe arguments and return values.
    NameValuePair
    Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
    NVList
    A modifiable list containing NamedValue objects.
    Object
    The definition for a CORBA object reference.
    OctetSeqHolder
    The Holder for OctetSeq.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    ParameterMode
    Enumeration of parameter modes for Parameter.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyError
    A user exception thrown when a policy error occurs.
    PolicyOperations
    Provides the operations for a Policy object.
    Principal
    Deprecated.
    Deprecated by CORBA 2.2.
    Request
    An object containing the information necessary for invoking a method.
    ServerRequest
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).
    ServiceDetail
    An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.
    ServiceInformation
    An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.
    ServiceInformationHolder
    The Holder for ServiceInformation.
    SetOverrideType
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
    ShortSeqHolder
    The Holder for ShortSeq.
    StructMember
    Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.
    SystemException
    The root class for all CORBA standard exceptions.
    TCKind
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
    TypeCode
    A container for information about a specific CORBA data type.
    ULongLongSeqHolder
    The Holder for ULongLongSeq.
    ULongSeqHolder
    The Holder for ULongSeq.
    UnionMember
    A description in the Interface Repository of a member of an IDL union.
    UnknownUserException
    A class that contains user exceptions returned by the server.
    UserException
    The root class for CORBA IDL-defined user exceptions.
    UShortSeqHolder
    The Holder for UShortSeq.
    ValueMember
    A description in the Interface Repository of a member of a value object.
    WCharSeqHolder
    The Holder for WCharSeq.
    WrongTransaction
    The CORBA WrongTransaction user-defined exception.
  • Classes in org.omg.CORBA used by org.omg.CORBA.DynAnyPackage
    Class and Description
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA.ORBPackage
    Class and Description
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA.TypeCodePackage
    Class and Description
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA.portable
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Context
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
    ContextList
    An object containing a modifiable list of String objects that represent property names.
    CustomMarshal
    An abstract value type that is meant to be used by the ORB, not the user.
    DomainManager
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
    ExceptionList
    An object used in Request operations to describe the exceptions that can be thrown by a method.
    NamedValue
    An object used in the DII and DSI to describe arguments and return values.
    NVList
    A modifiable list containing NamedValue objects.
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    Principal
    Deprecated.
    Deprecated by CORBA 2.2.
    Request
    An object containing the information necessary for invoking a method.
    SetOverrideType
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
    SystemException
    The root class for all CORBA standard exceptions.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.CORBA_2_3
    Class and Description
    BAD_PARAM
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
  • Classes in org.omg.CORBA used by org.omg.CosNaming
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    DynamicImplementation
    Deprecated.
    org.omg.CORBA.DynamicImplementation
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    ServerRequest
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.CosNaming.NamingContextExtPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CosNaming.NamingContextPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.Dynamic
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    ParameterMode
    Enumeration of parameter modes for Parameter.
  • Classes in org.omg.CORBA used by org.omg.DynamicAny
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Object
    The definition for a CORBA object reference.
    TCKind
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.DynamicAny.DynAnyFactoryPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.DynamicAny.DynAnyPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.IOP
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Object
    The definition for a CORBA object reference.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.IOP.CodecFactoryPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.IOP.CodecPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.Messaging
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.PortableInterceptor
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Object
    The definition for a CORBA object reference.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyError
    A user exception thrown when a policy error occurs.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableInterceptor.ORBInitInfoPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Current
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
    CurrentOperations
    The interface for Current.
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyOperations
    Provides the operations for a Policy object.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.CurrentPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.POAManagerPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.POAPackage
    Class and Description
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.ServantLocatorPackage
    Class and Description
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.SendingContext
    Class and Description
    Object
    The definition for a CORBA object reference.
  • Classes in org.omg.CORBA used by org.omg.stub.java.rmi
    Class and Description
    Object
    The definition for a CORBA object reference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParameterMode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ParameterMode

  • java.lang.Object
    • org.omg.CORBA.ParameterMode
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ParameterMode
extends Object
implements IDLEntity
    Enumeration of parameter modes for Parameter. Possible vaues:
    • PARAM_IN - Represents an "in" parameter.
    • PARAM_OUT - Represents an "out" parameter.
    • PARAM_INOUT - Represents an "inout" parameter.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _PARAM_IN
      static int | _PARAM_INOUT
      static int | _PARAM_OUT
      static ParameterMode | PARAM_IN
      static ParameterMode | PARAM_INOUT
      static ParameterMode | PARAM_OUT

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ParameterMode(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ParameterMode | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _PARAM_IN

        public static final int _PARAM_IN
        See Also:
        Constant Field Values

      • PARAM_IN

        public static final ParameterMode PARAM_IN

      • _PARAM_OUT

        public static final int _PARAM_OUT
        See Also:
        Constant Field Values

      • PARAM_OUT

        public static final ParameterMode PARAM_OUT

      • _PARAM_INOUT

        public static final int _PARAM_INOUT
        See Also:
        Constant Field Values

      • PARAM_INOUT

        public static final ParameterMode PARAM_INOUT

    • Constructor Detail

      • ParameterMode

        protected ParameterMode(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ParameterMode from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParameterModeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ParameterModeHelper

  • java.lang.Object
    • org.omg.CORBA.ParameterModeHelper

  • public abstract class ParameterModeHelper
extends Object
    Enumeration of parameter modes for Parameter. Possible vaues:
    • PARAM_IN - Represents an "in" parameter.
    • PARAM_OUT - Represents an "out" parameter.
    • PARAM_INOUT - Represents an "inout" parameter.

    • Constructor Summary

      Constructors
      Constructor and Description
      ParameterModeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ParameterMode | extract(Any a)
      static String | id()
      static void | insert(Any a, ParameterMode that)
      static ParameterMode | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ParameterMode value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ParameterModeHelper

        public ParameterModeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ParameterMode that)

      • extract

        public static ParameterMode extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ParameterMode read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ParameterMode value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParameterModeHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ParameterModeHolder

  • java.lang.Object
    • org.omg.CORBA.ParameterModeHolder
  • All Implemented Interfaces:
    Streamable

    public final class ParameterModeHolder
extends Object
implements Streamable
    Enumeration of parameter modes for Parameter. Possible vaues:
    • PARAM_IN - Represents an "in" parameter.
    • PARAM_OUT - Represents an "out" parameter.
    • PARAM_INOUT - Represents an "inout" parameter.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ParameterMode value

    • Constructor Summary

      Constructors
      Constructor and Description
      ParameterModeHolder()
      ParameterModeHolder(ParameterMode initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ParameterMode value

    • Constructor Detail

      • ParameterModeHolder

        public ParameterModeHolder()

      • ParameterModeHolder

        public ParameterModeHolder(ParameterMode initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PERSIST_STORE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PERSIST_STORE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.PERSIST_STORE
  • All Implemented Interfaces:
    Serializable

    public final class PERSIST_STORE
extends SystemException
    This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      PERSIST_STORE()
      Constructs a PERSIST_STORE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      PERSIST_STORE(int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified minor code and completion status.
      PERSIST_STORE(String s)
      Constructs a PERSIST_STORE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      PERSIST_STORE(String s, int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • PERSIST_STORE

        public PERSIST_STORE()
        Constructs a PERSIST_STORE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • PERSIST_STORE

        public PERSIST_STORE(String s)
        Constructs a PERSIST_STORE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • PERSIST_STORE

        public PERSIST_STORE(int minor,
                     CompletionStatus completed)
        Constructs a PERSIST_STORE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • PERSIST_STORE

        public PERSIST_STORE(String s,
                     int minor,
                     CompletionStatus completed)
        Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Policy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface Policy

  • All Superinterfaces:
    IDLEntity, Object, PolicyOperations, Serializable
    All Known Subinterfaces:
    IdAssignmentPolicy, IdUniquenessPolicy, ImplicitActivationPolicy, LifespanPolicy, RequestProcessingPolicy, ServantRetentionPolicy, ThreadPolicy
    All Known Implementing Classes:
    _PolicyStub

    public interface Policy
extends PolicyOperations, Object, IDLEntity
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation. This information is accessed in a structured manner using interfaces derived from the Policy interface defined in the CORBA module. A CORBA service does not have to use this method of accessing operating options, but may choose to do so. The Security Service in particular uses this technique for associating Security Policy with objects in the system. An interface generated by the IDL-to-Java compiler. org/omg/CORBA/Policy.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.PolicyError
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class PolicyError
extends UserException
    A user exception thrown when a policy error occurs. A PolicyError exception may include one of the following policy error reason codes defined in the org.omg.CORBA package: BAD_POLICY, BAD_POLICY_TYPE, BAD_POLICY_VALUE, UNSUPPORTED_POLICY, UNSUPPORTED_POLICY_VALUE.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      short reason
      The reason for the PolicyError exception being thrown.

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyError()
      Constructs a default PolicyError user exception with no reason code and an empty reason detail message.
      PolicyError(short __reason)
      Constructs a PolicyError user exception initialized with the given reason code and an empty reason detail message.
      PolicyError(String reason_string, short __reason)
      Constructs a PolicyError user exception initialized with the given reason detail message and reason code.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • reason

        public short reason
        The reason for the PolicyError exception being thrown.

    • Constructor Detail

      • PolicyError

        public PolicyError()
        Constructs a default PolicyError user exception with no reason code and an empty reason detail message.

      • PolicyError

        public PolicyError(short __reason)
        Constructs a PolicyError user exception initialized with the given reason code and an empty reason detail message.
        Parameters:
        __reason - the reason code.

      • PolicyError

        public PolicyError(String reason_string,
                   short __reason)
        Constructs a PolicyError user exception initialized with the given reason detail message and reason code.
        Parameters:
        reason_string - the reason detail message.
        __reason - the reason code.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyErrorCodeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyErrorCodeHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyErrorCodeHelper

  • public abstract class PolicyErrorCodeHelper
extends Object
    Encapsulates a reason a Policy may be invalid.
    See Also:
    PolicyError

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyErrorCodeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PolicyErrorCodeHelper

        public PolicyErrorCodeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyErrorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyErrorHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyErrorHelper

  • public abstract class PolicyErrorHelper
extends Object
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyErrorHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static PolicyError | extract(Any a)
      static String | id()
      static void | insert(Any a, PolicyError that)
      static PolicyError | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, PolicyError value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PolicyErrorHelper

        public PolicyErrorHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          PolicyError that)

      • extract

        public static PolicyError extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static PolicyError read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         PolicyError value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyErrorHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyErrorHolder

  • java.lang.Object
    • org.omg.CORBA.PolicyErrorHolder
  • All Implemented Interfaces:
    Streamable

    public final class PolicyErrorHolder
extends Object
implements Streamable
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      PolicyError value

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyErrorHolder()
      PolicyErrorHolder(PolicyError initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public PolicyError value

    • Constructor Detail

      • PolicyErrorHolder

        public PolicyErrorHolder()

      • PolicyErrorHolder

        public PolicyErrorHolder(PolicyError initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyHelper

  • public abstract class PolicyHelper
extends Object
    The Helper for Policy. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/PolicyHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Policy | extract(Any a)
      static String | id()
      static void | insert(Any a, Policy that)
      static Policy | narrow(Object obj)
      static Policy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Policy value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PolicyHelper

        public PolicyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Policy that)

      • extract

        public static Policy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Policy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Policy value)

      • narrow

        public static Policy narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyHolder

  • java.lang.Object
    • org.omg.CORBA.PolicyHolder
  • All Implemented Interfaces:
    Streamable

    public final class PolicyHolder
extends Object
implements Streamable
    The Holder for Policy. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/PolicyHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Policy value

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyHolder()
      PolicyHolder(Policy initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Policy value

    • Constructor Detail

      • PolicyHolder

        public PolicyHolder()

      • PolicyHolder

        public PolicyHolder(Policy initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyListHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyListHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyListHelper

  • public abstract class PolicyListHelper
extends Object
    The Helper for PolicyList. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/PolicyListHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyListHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Policy[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Policy[] that)
      static Policy[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Policy[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PolicyListHelper

        public PolicyListHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Policy[] that)

      • extract

        public static Policy[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Policy[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Policy[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyListHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyListHolder

  • java.lang.Object
    • org.omg.CORBA.PolicyListHolder
  • All Implemented Interfaces:
    Streamable

    public final class PolicyListHolder
extends Object
implements Streamable
    The Holder for PolicyList. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/PolicyListHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Policy[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyListHolder()
      PolicyListHolder(Policy[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Policy[] value

    • Constructor Detail

      • PolicyListHolder

        public PolicyListHolder()

      • PolicyListHolder

        public PolicyListHolder(Policy[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface PolicyOperations

  • All Known Subinterfaces:
    IdAssignmentPolicy, IdAssignmentPolicyOperations, IdUniquenessPolicy, IdUniquenessPolicyOperations, ImplicitActivationPolicy, ImplicitActivationPolicyOperations, LifespanPolicy, LifespanPolicyOperations, Policy, RequestProcessingPolicy, RequestProcessingPolicyOperations, ServantRetentionPolicy, ServantRetentionPolicyOperations, ThreadPolicy, ThreadPolicyOperations
    All Known Implementing Classes:
    _PolicyStub

    public interface PolicyOperations
    Provides the operations for a Policy object.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Policy copy()
      Returns a copy of the Policy object.
      void destroy()
      Destroys the Policy object.
      int policy_type()
      Returns the constant value that corresponds to the type of the policy object.

    • Method Detail

      • policy_type

        int policy_type()
        Returns the constant value that corresponds to the type of the policy object. The values of the policy objects are allocated by the OMG. New values for PolicyType should be obtained from the OMG by sending mail to request@omg.org. In general the constant values that are allocated are defined in conjunction with the definition of the corresponding policy object.
        Returns:
        the constant value that corresponds to the type of the policy object

      • copy

        Policy copy()
        Returns a copy of the Policy object. The copy does not retain any relationships that the policy had with any domain or object.
        Returns:
        a copy of the Policy object

      • destroy

        void destroy()
        Destroys the Policy object. It is the responsibility of the Policy object to determine whether it can be destroyed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PolicyTypeHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyTypeHelper

  • public abstract class PolicyTypeHelper
extends Object
    The Helper for PolicyType. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/PolicyTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      PolicyTypeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • PolicyTypeHelper

        public PolicyTypeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Principal (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class Principal

  • java.lang.Object
    • org.omg.CORBA.Principal
  • Deprecated.
    Deprecated by CORBA 2.2.

    @Deprecated
public class Principal
extends Object
    A class that contains information about the identity of the client, for access control and other purposes. It contains a single attribute, the name of the Principal, encoded as a sequence of bytes.

    • Constructor Summary

      Constructors
      Constructor and Description
      Principal()
      Deprecated.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      byte[] name()
      Deprecated.
      Deprecated by CORBA 2.2.
      void name(byte[] value)
      Deprecated.
      Deprecated by CORBA 2.2.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Principal

        public Principal()
        Deprecated.

    • Method Detail

      • name

        @Deprecated
public void name(byte[] value)
        Deprecated. Deprecated by CORBA 2.2.
        Sets the name of this Principal object to the given value.
        Parameters:
        value - the value to be set in the Principal

      • name

        @Deprecated
public byte[] name()
        Deprecated. Deprecated by CORBA 2.2.
        Gets the name of this Principal object.
        Returns:
        the name of this Principal object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PrincipalHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class PrincipalHolder

  • java.lang.Object
    • org.omg.CORBA.PrincipalHolder
  • All Implemented Interfaces:
    Streamable
    Deprecated.
    Deprecated by CORBA 2.2.

    @Deprecated
public final class PrincipalHolder
extends Object
implements Streamable
    The Holder for Principal. For more information on Holder files, see "Generated Files: Holder Files".

    A container class for values of type Principal that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL Principal as an "out" or "inout" parameter, the programmer must pass an instance of PrincipalHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myPrincipalHolder is an instance of PrincipalHolder, the value stored in its value field can be accessed with myPrincipalHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Principal value
      Deprecated.
      The Principal value held by this PrincipalHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      PrincipalHolder()
      Deprecated.
      Constructs a new PrincipalHolder object with its value field initialized to null.
      PrincipalHolder(Principal initial)
      Deprecated.
      Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Deprecated.
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Deprecated.
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream output)
      Deprecated.
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Principal value
        Deprecated.
        The Principal value held by this PrincipalHolder object.

    • Constructor Detail

      • PrincipalHolder

        public PrincipalHolder()
        Deprecated.
        Constructs a new PrincipalHolder object with its value field initialized to null.

      • PrincipalHolder

        public PrincipalHolder(Principal initial)
        Deprecated.
        Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.
        Parameters:
        initial - the Principal with which to initialize the value field of the newly-created PrincipalHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Deprecated.
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream output)
        Deprecated.
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the CDR OutputStream

      • _type

        public TypeCode _type()
        Deprecated.
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PRIVATE_MEMBER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface PRIVATE_MEMBER

  • public interface PRIVATE_MEMBER
    Constant to define a private member in the ValueMember class.

    PRIVATE_MEMBER is one of the two constants of typedef Visibility used in the interface repository to identify visibility of a ValueMember type. The other constant is PUBLIC_MEMBER.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static short | value

    • Field Detail

      • value

        static final short value
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PUBLIC_MEMBER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface PUBLIC_MEMBER

  • public interface PUBLIC_MEMBER
    Constant to define a public member in the ValueMember class.

    PUBLIC_MEMBER is one of the two constants of typedef Visibility used in the interface repository to identify visibility of a ValueMember type. The other constant is PRIVATE_MEMBER.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static short | value

    • Field Detail

      • value

        static final short value
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


REBIND (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class REBIND

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.REBIND
  • All Implemented Interfaces:
    Serializable

    public final class REBIND
extends SystemException
    REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD. This exception is also raised if the current effective RebindPolicy has a value of NO_RECONNECT and a connection must be reopened.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      REBIND()
      Constructs an REBIND exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      REBIND(int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified minor code and completion status.
      REBIND(String detailMessage)
      Constructs an REBIND exception with the specified message.
      REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • REBIND

        public REBIND()
        Constructs an REBIND exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • REBIND

        public REBIND(String detailMessage)
        Constructs an REBIND exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • REBIND

        public REBIND(int minorCode,
              CompletionStatus completionStatus)
        Constructs an REBIND exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • REBIND

        public REBIND(String detailMessage,
              int minorCode,
              CompletionStatus completionStatus)
        Constructs an REBIND exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RepositoryIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class RepositoryIdHelper

  • java.lang.Object
    • org.omg.CORBA.RepositoryIdHelper

  • public abstract class RepositoryIdHelper
extends Object
    The Helper for RepositoryId. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/RepositoryIdHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      RepositoryIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • RepositoryIdHelper

        public RepositoryIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Request (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class Request

  • java.lang.Object
    • org.omg.CORBA.Request

  • public abstract class Request
extends Object
    An object containing the information necessary for invoking a method. This class is the cornerstone of the ORB Dynamic Invocation Interface (DII), which allows dynamic creation and invocation of requests. A server cannot tell the difference between a client invocation using a client stub and a request using the DII.

    A Request object consists of:

    • the name of the operation to be invoked
    • an NVList containing arguments for the operation.
      Each item in the list is a NamedValue object, which has three parts:
      1. the name of the argument
      2. the value of the argument (as an Any object)
      3. the argument mode flag indicating whether the argument is for input, output, or both

    Request objects may also contain additional information, depending on how an operation was defined in the original IDL interface definition. For example, where appropriate, they may contain a NamedValue object to hold the return value or exception, a context, a list of possible exceptions, and a list of context strings that need to be resolved.

    New Request objects are created using one of the create_request methods in the Object class. In other words, a create_request method is performed on the object which is to be invoked.

    See Also:
    NamedValue

    • Constructor Summary

      Constructors
      Constructor and Description
      Request()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract Any add_in_arg()
      Creates an input argument and adds it to this Request object.
      abstract Any add_inout_arg()
      Adds an input/output argument to this Request object.
      abstract Any add_named_in_arg(String name)
      Creates an input argument with the given name and adds it to this Request object.
      abstract Any add_named_inout_arg(String name)
      Adds an input/output argument with the given name to this Request object.
      abstract Any add_named_out_arg(String name)
      Adds an output argument with the given name to this Request object.
      abstract Any add_out_arg()
      Adds an output argument to this Request object.
      abstract NVList arguments()
      Retrieves the NVList object containing the arguments to the method being invoked.
      abstract ContextList contexts()
      Retrieves the ContextList object for this request.
      abstract Context ctx()
      Retrieves the Context object for this request.
      abstract void ctx(Context c)
      Sets this request's Context object to the one given.
      abstract Environment env()
      Retrieves the Environment object for this request.
      abstract ExceptionList exceptions()
      Retrieves the ExceptionList object for this request.
      abstract void get_response()
      Allows the user to access the response for the invocation triggered earlier with the send_deferred method.
      abstract void invoke()
      Makes a synchronous invocation using the information in the Request object.
      abstract String operation()
      Retrieves the name of the method to be invoked.
      abstract boolean poll_response()
      Allows the user to determine whether a response has been received for the invocation triggered earlier with the send_deferred method.
      abstract NamedValue result()
      Retrieves the NamedValue object containing the return value for the method.
      abstract Any return_value()
      Returns the Any object that contains the value for the result of the method.
      abstract void send_deferred()
      Makes an asynchronous invocation on the request.
      abstract void send_oneway()
      Makes a oneway invocation on the request.
      abstract void set_return_type(TypeCode tc)
      Sets the typecode for the return value of the method.
      abstract Object target()
      Retrieves the the target object reference.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Request

        public Request()

    • Method Detail

      • target

        public abstract Object target()
        Retrieves the the target object reference.
        Returns:
        the object reference that points to the object implementation for the method to be invoked

      • operation

        public abstract String operation()
        Retrieves the name of the method to be invoked.
        Returns:
        the name of the method to be invoked

      • arguments

        public abstract NVList arguments()
        Retrieves the NVList object containing the arguments to the method being invoked. The elements in the list are NamedValue objects, with each one describing an argument to the method.
        Returns:
        the NVList object containing the arguments for the method

      • result

        public abstract NamedValue result()
        Retrieves the NamedValue object containing the return value for the method.
        Returns:
        the NamedValue object containing the result of the method

      • env

        public abstract Environment env()
        Retrieves the Environment object for this request. It contains the exception that the method being invoked has thrown (after the invocation returns).
        Returns:
        the Environment object for this request

      • exceptions

        public abstract ExceptionList exceptions()
        Retrieves the ExceptionList object for this request. This list contains TypeCode objects describing the exceptions that may be thrown by the method being invoked.
        Returns:
        the ExceptionList object describing the exceptions that may be thrown by the method being invoked

      • contexts

        public abstract ContextList contexts()
        Retrieves the ContextList object for this request. This list contains context Strings that need to be resolved and sent with the invocation.
        Returns:
        the list of context strings whose values need to be resolved and sent with the invocation.

      • ctx

        public abstract Context ctx()
        Retrieves the Context object for this request. This is a list of properties giving information about the client, the environment, or the circumstances of this request.
        Returns:
        the Context object that is to be used to resolve any context strings whose values need to be sent with the invocation

      • ctx

        public abstract void ctx(Context c)
        Sets this request's Context object to the one given.
        Parameters:
        c - the new Context object to be used for resolving context strings

      • add_in_arg

        public abstract Any add_in_arg()
        Creates an input argument and adds it to this Request object.
        Returns:
        an Any object that contains the value and typecode for the input argument added

      • add_named_in_arg

        public abstract Any add_named_in_arg(String name)
        Creates an input argument with the given name and adds it to this Request object.
        Parameters:
        name - the name of the argument being added
        Returns:
        an Any object that contains the value and typecode for the input argument added

      • add_inout_arg

        public abstract Any add_inout_arg()
        Adds an input/output argument to this Request object.
        Returns:
        an Any object that contains the value and typecode for the input/output argument added

      • add_named_inout_arg

        public abstract Any add_named_inout_arg(String name)
        Adds an input/output argument with the given name to this Request object.
        Parameters:
        name - the name of the argument being added
        Returns:
        an Any object that contains the value and typecode for the input/output argument added

      • add_out_arg

        public abstract Any add_out_arg()
        Adds an output argument to this Request object.
        Returns:
        an Any object that contains the value and typecode for the output argument added

      • add_named_out_arg

        public abstract Any add_named_out_arg(String name)
        Adds an output argument with the given name to this Request object.
        Parameters:
        name - the name of the argument being added
        Returns:
        an Any object that contains the value and typecode for the output argument added

      • set_return_type

        public abstract void set_return_type(TypeCode tc)
        Sets the typecode for the return value of the method.
        Parameters:
        tc - the TypeCode object containing type information for the return value

      • return_value

        public abstract Any return_value()
        Returns the Any object that contains the value for the result of the method.
        Returns:
        an Any object containing the value and typecode for the return value

      • invoke

        public abstract void invoke()
        Makes a synchronous invocation using the information in the Request object. Exception information is placed into the Request object's environment object.

      • send_oneway

        public abstract void send_oneway()
        Makes a oneway invocation on the request. In other words, it does not expect or wait for a response. Note that this can be used even if the operation was not declared as oneway in the IDL declaration. No response or exception information is returned.

      • send_deferred

        public abstract void send_deferred()
        Makes an asynchronous invocation on the request. In other words, it does not wait for a response before it returns to the user. The user can then later use the methods poll_response and get_response to get the result or exception information for the invocation.

      • poll_response

        public abstract boolean poll_response()
        Allows the user to determine whether a response has been received for the invocation triggered earlier with the send_deferred method.
        Returns:
        true if the method response has been received; false otherwise

      • get_response

        public abstract void get_response()
                           throws WrongTransaction
        Allows the user to access the response for the invocation triggered earlier with the send_deferred method.
        Throws:
        WrongTransaction - if the method get_response was invoked from a different transaction's scope than the one from which the request was originally sent. See the OMG Transaction Service specification for details.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServerRequest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ServerRequest

  • java.lang.Object
    • org.omg.CORBA.ServerRequest

  • public abstract class ServerRequest
extends Object
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI). This class, the cornerstone of the DSI, is analogous to the Request object in the DII.

    The ORB is responsible for creating this embodiment of a request, and delivering it to a Dynamic Implementation Routine (DIR). A dynamic servant (a DIR) is created by implementing the DynamicImplementation class, which has a single invoke method. This method accepts a ServerRequest object. The abstract class ServerRequest defines methods for accessing the method name, the arguments and the context of the request, as well as methods for setting the result of the request either as a return value or an exception.

    A subtlety with accessing the arguments of the request is that the DIR needs to provide type information about the expected arguments, since there is no compiled information about these. This information is provided through an NVList, which is a list of NamedValue objects. Each NamedValue object contains an Any object, which in turn has a TypeCode object representing the type of the argument.

    Similarly, type information needs to be provided for the response, for either the expected result or for an exception, so the methods result and except take an Any object as a parameter.

    See Also:
    DynamicImplementation, NVList, NamedValue

    • Constructor Summary

      Constructors
      Constructor and Description
      ServerRequest()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void arguments(NVList args)
      Specifies method parameter types and retrieves "in" and "inout" argument values.
      abstract Context ctx()
      Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference.
      void except(Any any)
      Deprecated.
      use set_exception()
      String op_name()
      Deprecated.
      use operation()
      String operation()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void params(NVList params)
      Deprecated.
      use the method arguments
      void result(Any any)
      Deprecated.
      use the method set_result
      void set_exception(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void set_result(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServerRequest

        public ServerRequest()

    • Method Detail

      • op_name

        @Deprecated
public String op_name()
        Deprecated. use operation()
        Retrieves the name of the operation being invoked. According to OMG IDL's rules, these names must be unique among all operations supported by this object's "most-derived" interface. Note that the operation names for getting and setting attributes are _get_<attribute_name> and _set_<attribute_name>, respectively.
        Returns:
        the name of the operation to be invoked

      • operation

        public String operation()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Retrieves the name of the operation being invoked. According to OMG IDL's rules, these names must be unique among all operations supported by this object's "most-derived" interface. Note that the operation names for getting and setting attributes are _get_<attribute_name> and _set_<attribute_name>, respectively.

        Returns:
        the name of the operation to be invoked
        See Also:
        CORBA package comments for unimplemented features

      • params

        @Deprecated
public void params(NVList params)
        Deprecated. use the method arguments
        Specifies method parameter types and retrieves "in" and "inout" argument values.

        Note that this method is deprecated; use the method arguments in its place.

        Unless it calls the method set_exception, the DIR must call this method exactly once, even if the method signature contains no parameters. Once the method arguments or set_exception has been called, calling arguments on the same ServerRequest object will result in a BAD_INV_ORDER system exception. The DIR must pass in to the method arguments an NVList initialized with TypeCodes and Flags describing the parameter types for the operation, in the order in which they appear in the IDL specification (left to right). A potentially-different NVList will be returned from arguments, with the "in" and "inout" argument values supplied. If it does not call the method set_exception, the DIR must supply the returned NVList with return values for any "out" arguments before returning, and may also change the return values for any "inout" arguments.

        Parameters:
        params - the arguments of the method, in the form of an NVList object

      • arguments

        public void arguments(NVList args)
        Specifies method parameter types and retrieves "in" and "inout" argument values. Unless it calls the method set_exception, the DIR must call this method exactly once, even if the method signature contains no parameters. Once the method arguments or set_exception has been called, calling arguments on the same ServerRequest object will result in a BAD_INV_ORDER system exception. The DIR must pass in to the method arguments an NVList initialized with TypeCodes and Flags describing the parameter types for the operation, in the order in which they appear in the IDL specification (left to right). A potentially-different NVList will be returned from arguments, with the "in" and "inout" argument values supplied. If it does not call the method set_exception, the DIR must supply the returned NVList with return values for any "out" arguments before returning, and it may also change the return values for any "inout" arguments.
        Parameters:
        args - the arguments of the method, in the form of an NVList
        See Also:
        CORBA package comments for unimplemented features

      • result

        @Deprecated
public void result(Any any)
        Deprecated. use the method set_result
        Specifies any return value for the call.

        Note that this method is deprecated; use the method set_result in its place.

        Unless the method set_exception is called, if the invoked method has a non-void result type, the method set_result must be called exactly once before the DIR returns. If the operation has a void result type, the method set_result may optionally be called once with an Any object whose type is tk_void. Calling the method set_result before the method arguments has been called or after the method set_result or set_exception has been called will result in a BAD_INV_ORDER exception. Calling the method set_result without having previously called the method ctx when the IDL operation contains a context expression, or when the NVList passed to arguments did not describe all parameters passed by the client, may result in a MARSHAL system exception.

        Parameters:
        any - an Any object containing the return value to be set

      • set_result

        public void set_result(Any any)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Specifies any return value for the call. Unless the method set_exception is called, if the invoked method has a non-void result type, the method set_result must be called exactly once before the DIR returns. If the operation has a void result type, the method set_result may optionally be called once with an Any object whose type is tk_void. Calling the method set_result before the method arguments has been called or after the method set_result or set_exception has been called will result in a BAD_INV_ORDER exception. Calling the method set_result without having previously called the method ctx when the IDL operation contains a context expression, or when the NVList passed to arguments did not describe all parameters passed by the client, may result in a MARSHAL system exception.

        Parameters:
        any - an Any object containing the return value to be set
        See Also:
        CORBA package comments for unimplemented features

      • except

        @Deprecated
public void except(Any any)
        Deprecated. use set_exception()
        The DIR may call set_exception at any time to return an exception to the client. The Any passed to set_exception must contain either a system exception or a user exception specified in the raises expression of the invoked operation's IDL definition. Passing in an Any that does not contain an exception will result in a BAD_PARAM system exception. Passing in an unlisted user exception will result in either the DIR receiving a BAD_PARAM system exception or in the client receiving an UNKNOWN_EXCEPTION system exception.
        Parameters:
        any - the Any object containing the exception

      • set_exception

        public void set_exception(Any any)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Returns the given exception to the client. This method is invoked by the DIR, which may call it at any time. The Any object passed to this method must contain either a system exception or one of the user exceptions specified in the invoked operation's IDL definition. Passing in an Any object that does not contain an exception will cause a BAD_PARAM system exception to be thrown. Passing in an unlisted user exception will result in either the DIR receiving a BAD_PARAM system exception or in the client receiving an UNKNOWN_EXCEPTION system exception.

        Parameters:
        any - the Any object containing the exception
        Throws:
        BAD_PARAM - if the given Any object does not contain an exception or the exception is an unlisted user exception
        UNKNOWN_EXCEPTION - if the given exception is an unlisted user exception and the DIR did not receive a BAD_PARAM exception
        See Also:
        CORBA package comments for unimplemented features

      • ctx

        public abstract Context ctx()
        Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference. Calling the method ctx before the method arguments has been called or after the method ctx, set_result, or set_exception has been called will result in a BAD_INV_ORDER system exception.
        Returns:
        the context object that is to be used to resolve any context strings whose values need to be sent with the invocation.
        Throws:
        BAD_INV_ORDER - if (1) the method ctx is called before the method arguments or (2) the method ctx is called after calling set_result or set_exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceDetail (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ServiceDetail

  • java.lang.Object
    • org.omg.CORBA.ServiceDetail
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServiceDetail
extends Object
implements IDLEntity
    An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] service_detail
      The data describing the ORB service that this ServiceDetail object represents.
      int service_detail_type
      The type of the ORB service that this ServiceDetail object represents.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceDetail()
      Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.
      ServiceDetail(int service_detail_type, byte[] service_detail)
      Constructs a ServiceDetail object with the given ORB service type and the given description.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • service_detail_type

        public int service_detail_type
        The type of the ORB service that this ServiceDetail object represents.

      • service_detail

        public byte[] service_detail
        The data describing the ORB service that this ServiceDetail object represents.

    • Constructor Detail

      • ServiceDetail

        public ServiceDetail()
        Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.

      • ServiceDetail

        public ServiceDetail(int service_detail_type,
                     byte[] service_detail)
        Constructs a ServiceDetail object with the given ORB service type and the given description.
        Parameters:
        service_detail_type - an int specifying the type of ORB service
        service_detail - a byte array describing the ORB service
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceDetailHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ServiceDetailHelper

  • java.lang.Object
    • org.omg.CORBA.ServiceDetailHelper

  • public abstract class ServiceDetailHelper
extends Object

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceDetailHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServiceDetail | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceDetail that)
      static ServiceDetail | read(InputStream in)
      static TypeCode | type()
      static void | write(OutputStream out, ServiceDetail that)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceDetailHelper

        public ServiceDetailHelper()

    • Method Detail

      • write

        public static void write(OutputStream out,
                         ServiceDetail that)

      • read

        public static ServiceDetail read(InputStream in)

      • extract

        public static ServiceDetail extract(Any a)

      • insert

        public static void insert(Any a,
                          ServiceDetail that)

      • type

        public static TypeCode type()

      • id

        public static String id()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceInformation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ServiceInformation

  • java.lang.Object
    • org.omg.CORBA.ServiceInformation
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServiceInformation
extends Object
implements IDLEntity
    An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ServiceDetail[] service_details
      Array of ServiceDetails giving more details about the service.
      int[] service_options
      Array of ints representing service options.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceInformation()
      Constructs a ServiceInformation object with empty service_options and service_details.
      ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
      Constructs a ServiceInformation object with the given service_options and service_details.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • service_options

        public int[] service_options
        Array of ints representing service options.

      • service_details

        public ServiceDetail[] service_details
        Array of ServiceDetails giving more details about the service.

    • Constructor Detail

      • ServiceInformation

        public ServiceInformation()
        Constructs a ServiceInformation object with empty service_options and service_details.

      • ServiceInformation

        public ServiceInformation(int[] __service_options,
                          ServiceDetail[] __service_details)
        Constructs a ServiceInformation object with the given service_options and service_details.
        Parameters:
        __service_options - An array of ints describing the service options.
        __service_details - An array of ServiceDetails describing the service details.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceInformationHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ServiceInformationHelper

  • java.lang.Object
    • org.omg.CORBA.ServiceInformationHelper

  • public abstract class ServiceInformationHelper
extends Object

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceInformationHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServiceInformation | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceInformation that)
      static ServiceInformation | read(InputStream in)
      static TypeCode | type()
      static void | write(OutputStream out, ServiceInformation that)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceInformationHelper

        public ServiceInformationHelper()

    • Method Detail

      • write

        public static void write(OutputStream out,
                         ServiceInformation that)

      • read

        public static ServiceInformation read(InputStream in)

      • extract

        public static ServiceInformation extract(Any a)

      • insert

        public static void insert(Any a,
                          ServiceInformation that)

      • type

        public static TypeCode type()

      • id

        public static String id()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceInformationHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ServiceInformationHolder

  • java.lang.Object
    • org.omg.CORBA.ServiceInformationHolder
  • All Implemented Interfaces:
    Streamable

    public final class ServiceInformationHolder
extends Object
implements Streamable
    The Holder for ServiceInformation. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a ServiceInformation object that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL xxx as an "out" or "inout" parameter, the programmer must pass an instance of ServiceInformationHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myServiceInformationHolder is an instance of ServiceInformationHolder, the value stored in its value field can be accessed with myServiceInformationHolder.value.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ServiceInformation value
      The ServiceInformation value held by this ServiceInformationHolder object in its value field.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceInformationHolder()
      Constructs a new ServiceInformationHolder object with its value field initialized to null.
      ServiceInformationHolder(ServiceInformation arg)
      Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream in)
      Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
      void _write(OutputStream out)
      Marshals the value in this ServiceInformationHolder object's value field to the output stream out.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ServiceInformation value
        The ServiceInformation value held by this ServiceInformationHolder object in its value field.

    • Constructor Detail

      • ServiceInformationHolder

        public ServiceInformationHolder()
        Constructs a new ServiceInformationHolder object with its value field initialized to null.

      • ServiceInformationHolder

        public ServiceInformationHolder(ServiceInformation arg)
        Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.
        Parameters:
        arg - the ServiceInformation object with which to initialize the value field of the newly-created ServiceInformationHolder object

    • Method Detail

      • _write

        public void _write(OutputStream out)
        Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
        Specified by:
        _write in interface Streamable
        Parameters:
        out - the OutputStream object that will contain the CDR formatted data

      • _read

        public void _read(InputStream in)
        Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
        Specified by:
        _read in interface Streamable
        Parameters:
        in - the InputStream object containing CDR formatted data from the wire

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
        Specified by:
        _type in interface Streamable
        Returns:
        the type code for the value held in this ServiceInformationHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SetOverrideType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class SetOverrideType

  • java.lang.Object
    • org.omg.CORBA.SetOverrideType
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class SetOverrideType
extends Object
implements IDLEntity
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.

    The method Object._set_policy_override(org.omg.CORBA.Policy[], org.omg.CORBA.SetOverrideType) takes either SetOverrideType.SET_OVERRIDE or SetOverrideType.ADD_OVERRIDE as its second argument. The method _set_policy_override creates a new Object initialized with the Policy objects supplied as the first argument. If the second argument is ADD_OVERRIDE, the new policies are added to those of the Object instance that is calling the _set_policy_override method. If SET_OVERRIDE is given instead, the existing policies are replaced with the given ones.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int _ADD_OVERRIDE
      The int constant for the enum value ADD_OVERRIDE.
      static int _SET_OVERRIDE
      The int constant for the enum value SET_OVERRIDE.
      static SetOverrideType ADD_OVERRIDE
      The SetOverrideType constant for the enum value ADD_OVERRIDE.
      static SetOverrideType SET_OVERRIDE
      The SetOverrideType constant for the enum value SET_OVERRIDE.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SetOverrideType(int _value)
      Constructs a SetOverrideType instance from an int.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      static SetOverrideType from_int(int i)
      Converts the given int to the corresponding SetOverrideType instance.
      int value()
      Retrieves the value of this SetOverrideType instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _SET_OVERRIDE

        public static final int _SET_OVERRIDE
        The int constant for the enum value SET_OVERRIDE.
        See Also:
        Constant Field Values

      • _ADD_OVERRIDE

        public static final int _ADD_OVERRIDE
        The int constant for the enum value ADD_OVERRIDE.
        See Also:
        Constant Field Values

      • SET_OVERRIDE

        public static final SetOverrideType SET_OVERRIDE
        The SetOverrideType constant for the enum value SET_OVERRIDE.

      • ADD_OVERRIDE

        public static final SetOverrideType ADD_OVERRIDE
        The SetOverrideType constant for the enum value ADD_OVERRIDE.

    • Constructor Detail

      • SetOverrideType

        protected SetOverrideType(int _value)
        Constructs a SetOverrideType instance from an int.
        Parameters:
        _value - must be either SET_OVERRIDE or ADD_OVERRIDE

    • Method Detail

      • value

        public int value()
        Retrieves the value of this SetOverrideType instance.
        Returns:
        the int for this SetOverrideType instance.

      • from_int

        public static SetOverrideType from_int(int i)
        Converts the given int to the corresponding SetOverrideType instance.
        Parameters:
        i - the int to convert; must be either SetOverrideType._SET_OVERRIDE or SetOverrideType._ADD_OVERRIDE
        Returns:
        the SetOverrideType instance whose value matches the given int
        Throws:
        BAD_PARAM - if the given int does not match the value of any SetOverrideType instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SetOverrideTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class SetOverrideTypeHelper

  • java.lang.Object
    • org.omg.CORBA.SetOverrideTypeHelper

  • public abstract class SetOverrideTypeHelper
extends Object
    The Helper for SetOverrideType. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/SetOverrideTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      SetOverrideTypeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static SetOverrideType | extract(Any a)
      static String | id()
      static void | insert(Any a, SetOverrideType that)
      static SetOverrideType | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, SetOverrideType value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SetOverrideTypeHelper

        public SetOverrideTypeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          SetOverrideType that)

      • extract

        public static SetOverrideType extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static SetOverrideType read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         SetOverrideType value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ShortHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ShortHolder

  • java.lang.Object
    • org.omg.CORBA.ShortHolder
  • All Implemented Interfaces:
    Streamable

    public final class ShortHolder
extends Object
implements Streamable
    The Holder for Short. For more information on Holder files, see "Generated Files: Holder Files".

    short that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL short as an "out" or "inout" parameter, the programmer must pass an instance of ShortHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myShortHolder is an instance of ShortHolder, the value stored in its value field can be accessed with myShortHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      short value
      The short value held by this ShortHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      ShortHolder()
      Constructs a new ShortHolder object with its value field initialized to 0.
      ShortHolder(short initial)
      Constructs a new ShortHolder object with its value field initialized to the given short.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this ShortHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this ShortHolder object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public short value
        The short value held by this ShortHolder object.

    • Constructor Detail

      • ShortHolder

        public ShortHolder()
        Constructs a new ShortHolder object with its value field initialized to 0.

      • ShortHolder

        public ShortHolder(short initial)
        Constructs a new ShortHolder object with its value field initialized to the given short.
        Parameters:
        initial - the short with which to initialize the value field of the newly-created ShortHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this ShortHolder object.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this ShortHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in this ShortHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ShortSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ShortSeqHelper

  • java.lang.Object
    • org.omg.CORBA.ShortSeqHelper

  • public abstract class ShortSeqHelper
extends Object
    The Helper for ShortSeqHelper. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ShortSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      ShortSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short[] | extract(Any a)
      static String | id()
      static void | insert(Any a, short[] that)
      static short[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ShortSeqHelper

        public ShortSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short[] that)

      • extract

        public static short[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ShortSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ShortSeqHolder

  • java.lang.Object
    • org.omg.CORBA.ShortSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class ShortSeqHolder
extends Object
implements Streamable
    The Holder for ShortSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/ShortSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      ShortSeqHolder()
      ShortSeqHolder(short[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public short[] value

    • Constructor Detail

      • ShortSeqHolder

        public ShortSeqHolder()

      • ShortSeqHolder

        public ShortSeqHolder(short[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StringHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class StringHolder

  • java.lang.Object
    • org.omg.CORBA.StringHolder
  • All Implemented Interfaces:
    Streamable

    public final class StringHolder
extends Object
implements Streamable
    The Holder for String. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a String that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL string as an "out" or "inout" parameter, the programmer must pass an instance of StringHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myStringHolder is an instance of StringHolder, the value stored in its value field can be accessed with myStringHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String value
      The String value held by this StringHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      StringHolder()
      Constructs a new StringHolder object with its value field initialized to null.
      StringHolder(String initial)
      Constructs a new StringHolder object with its value field initialized to the given String.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
      void _write(OutputStream output)
      Marshals the value held by this StringHolder object to the output stream output.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public String value
        The String value held by this StringHolder object.

    • Constructor Detail

      • StringHolder

        public StringHolder()
        Constructs a new StringHolder object with its value field initialized to null.

      • StringHolder

        public StringHolder(String initial)
        Constructs a new StringHolder object with its value field initialized to the given String.
        Parameters:
        initial - the String with which to initialize the value field of the newly-created StringHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals the value held by this StringHolder object to the output stream output.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the type code of the value held in this StringHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StringSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class StringSeqHelper

  • java.lang.Object
    • org.omg.CORBA.StringSeqHelper

  • public abstract class StringSeqHelper
extends Object
    An array of Strings

    • Constructor Summary

      Constructors
      Constructor and Description
      StringSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StringSeqHelper

        public StringSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StringSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class StringSeqHolder

  • java.lang.Object
    • org.omg.CORBA.StringSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class StringSeqHolder
extends Object
implements Streamable
    An array of Strings

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      StringSeqHolder()
      StringSeqHolder(String[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public String[] value

    • Constructor Detail

      • StringSeqHolder

        public StringSeqHolder()

      • StringSeqHolder

        public StringSeqHolder(String[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StringValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class StringValueHelper

  • java.lang.Object
    • org.omg.CORBA.StringValueHelper
  • All Implemented Interfaces:
    BoxedValueHelper

    public class StringValueHelper
extends Object
implements BoxedValueHelper
    The Helper for StringValue. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/StringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      StringValueHelper()

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      String get_id()
      static String | id()
      static void | insert(Any a, String that)
      Serializable | read_value(InputStream istream)
      static String | read(InputStream istream)
      static TypeCode | type()
      void | write_value(OutputStream ostream, Serializable value)
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StringValueHelper

        public StringValueHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • read_value

        public Serializable read_value(InputStream istream)
        Specified by:
        read_value in interface BoxedValueHelper

      • write

        public static void write(OutputStream ostream,
                         String value)

      • write_value

        public void write_value(OutputStream ostream,
                        Serializable value)
        Specified by:
        write_value in interface BoxedValueHelper

      • get_id

        public String get_id()
        Specified by:
        get_id in interface BoxedValueHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StructMember (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class StructMember

  • java.lang.Object
    • org.omg.CORBA.StructMember
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class StructMember
extends Object
implements IDLEntity
    Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String name
      The name of the struct member described by this StructMember object.
      TypeCode type
      The type of the struct member described by this StructMember object.
      IDLType type_def
      The typedef that represents the IDL type of the struct member described by this StructMember object.

    • Constructor Summary

      Constructors
      Constructor and Description
      StructMember()
      Constructs a default StructMember object.
      StructMember(String __name, TypeCode __type, IDLType __type_def)
      Constructs a StructMember object initialized with the given values.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        public String name
        The name of the struct member described by this StructMember object.

      • type

        public TypeCode type
        The type of the struct member described by this StructMember object.

      • type_def

        public IDLType type_def
        The typedef that represents the IDL type of the struct member described by this StructMember object.

    • Constructor Detail

      • StructMember

        public StructMember()
        Constructs a default StructMember object.

      • StructMember

        public StructMember(String __name,
                    TypeCode __type,
                    IDLType __type_def)
        Constructs a StructMember object initialized with the given values.
        Parameters:
        __name - a String object with the name of the struct member
        __type - a TypeCode object describing the type of the struct member
        __type_def - an IDLType object representing the IDL type of the struct member
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StructMemberHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class StructMemberHelper

  • java.lang.Object
    • org.omg.CORBA.StructMemberHelper

  • public abstract class StructMemberHelper
extends Object
    The Helper for StructMember. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/StructMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      StructMemberHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static StructMember | extract(Any a)
      static String | id()
      static void | insert(Any a, StructMember that)
      static StructMember | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, StructMember value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StructMemberHelper

        public StructMemberHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          StructMember that)

      • extract

        public static StructMember extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static StructMember read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         StructMember value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SystemException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class SystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    ACTIVITY_COMPLETED, ACTIVITY_REQUIRED, BAD_CONTEXT, BAD_INV_ORDER, BAD_OPERATION, BAD_PARAM, BAD_QOS, BAD_TYPECODE, CODESET_INCOMPATIBLE, COMM_FAILURE, DATA_CONVERSION, FREE_MEM, IMP_LIMIT, IndirectionException, INITIALIZE, INTERNAL, INTF_REPOS, INV_FLAG, INV_IDENT, INV_OBJREF, INV_POLICY, INVALID_ACTIVITY, INVALID_TRANSACTION, MARSHAL, NO_IMPLEMENT, NO_MEMORY, NO_PERMISSION, NO_RESOURCES, NO_RESPONSE, OBJ_ADAPTER, OBJECT_NOT_EXIST, PERSIST_STORE, REBIND, TIMEOUT, TRANSACTION_MODE, TRANSACTION_REQUIRED, TRANSACTION_ROLLEDBACK, TRANSACTION_UNAVAILABLE, TRANSIENT, UNKNOWN, UnknownException

    public abstract class SystemException
extends RuntimeException
    The root class for all CORBA standard exceptions. These exceptions may be thrown as a result of any CORBA operation invocation and may also be returned by many standard CORBA API methods. The standard exceptions contain a minor code, allowing more detailed specification, and a completion status. This class is subclassed to generate each one of the set of standard ORB exceptions. SystemException extends java.lang.RuntimeException; thus none of the SystemException exceptions need to be declared in signatures of the Java methods mapped from operations in IDL interfaces.
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      Fields
      Modifier and Type Field and Description
      CompletionStatus completed
      The status of the operation that threw this exception.
      int minor
      The CORBA Exception minor code.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected SystemException(String reason, int minor, CompletionStatus completed)
      Constructs a SystemException exception with the specified detail message, minor code, and completion status.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String toString()
      Converts this exception to a representative string.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • minor

        public int minor
        The CORBA Exception minor code.

      • completed

        public CompletionStatus completed
        The status of the operation that threw this exception.

    • Constructor Detail

      • SystemException

        protected SystemException(String reason,
                          int minor,
                          CompletionStatus completed)
        Constructs a SystemException exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        Parameters:
        reason - the String containing a detail message
        minor - the minor code
        completed - the completion status

    • Method Detail

      • toString

        public String toString()
        Converts this exception to a representative string.
        Overrides:
        toString in class Throwable
        Returns:
        a string representation of this throwable.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TCKind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TCKind

  • java.lang.Object
    • org.omg.CORBA.TCKind

  • public class TCKind
extends Object
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object. There is one kind for each primitive and essential IDL data type.

    The class TCKind consists of:

    • a set of int constants, one for each kind of IDL data type. These int constants make it possible to use a switch statement.
    • a set of TCKind constants, one for each kind of IDL data type. The value field for each TCKind instance is initialized with the int constant that corresponds with the IDL data type that the instance represents.
    • the method from_intfor converting an int to its corresponding TCKind instance

      Example:

            org.omg.CORBA.TCKind k = org.omg.CORBA.TCKind.from_int(
                         org.omg.CORBA.TCKind._tk_string);
      The variable k represents the TCKind instance for the IDL type string, which is tk_string.

    • the method value for accessing the _value field of a TCKind constant

      Example:

         int i = org.omg.CORBA.TCKind.tk_char.value();
      The variable i represents 9, the value for the IDL data type char.

    The value field of a TCKind instance is the CDR encoding used for a TypeCode object in an IIOP message.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int _tk_abstract_interface
      The int constant for the IDL data type abstract interface.
      static int _tk_alias
      The int constant for the IDL data type alias.
      static int _tk_any
      The int constant for the IDL data type any.
      static int _tk_array
      The int constant for the IDL data type array.
      static int _tk_boolean
      The int constant for the IDL data type boolean.
      static int _tk_char
      The int constant for the IDL data type char.
      static int _tk_double
      The int constant for the IDL data type double.
      static int _tk_enum
      The int constant for the IDL data type enum.
      static int _tk_except
      The int constant for the IDL data type except.
      static int _tk_fixed
      The int constant for the IDL data type fixed.
      static int _tk_float
      The int constant for the IDL data type float.
      static int _tk_long
      The int constant for the IDL data type long.
      static int _tk_longdouble
      The int constant for the IDL data type longdouble.
      static int _tk_longlong
      The int constant for the IDL data type longlong.
      static int _tk_native
      The int constant for the IDL data type native.
      static int _tk_null
      The int constant for a null IDL data type.
      static int _tk_objref
      The int constant for the IDL data type objref.
      static int _tk_octet
      The int constant for the IDL data type octet.
      static int _tk_Principal
      The int constant for the IDL data type Principal.
      static int _tk_sequence
      The int constant for the IDL data type sequence.
      static int _tk_short
      The int constant for the IDL data type short.
      static int _tk_string
      The int constant for the IDL data type string.
      static int _tk_struct
      The int constant for the IDL data type struct.
      static int _tk_TypeCode
      The int constant for the IDL data type TypeCode.
      static int _tk_ulong
      The int constant for the IDL data type ulong.
      static int _tk_ulonglong
      The int constant for the IDL data type ulonglong.
      static int _tk_union
      The int constant for the IDL data type union.
      static int _tk_ushort
      The int constant for the IDL data type ushort.
      static int _tk_value
      The int constant for the IDL data type value.
      static int _tk_value_box
      The int constant for the IDL data type value_box.
      static int _tk_void
      The int constant for the IDL data type void.
      static int _tk_wchar
      The int constant for the IDL data type wchar.
      static int _tk_wstring
      The int constant for the IDL data type wstring.
      static TCKind tk_abstract_interface
      The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.
      static TCKind tk_alias
      The TCKind constant whose value field is initialized with TCKind._tk_alias.
      static TCKind tk_any
      The TCKind constant whose value field is initialized with TCKind._tk_any.
      static TCKind tk_array
      The TCKind constant whose value field is initialized with TCKind._tk_array.
      static TCKind tk_boolean
      The TCKind constant whose value field is initialized with TCKind._tk_boolean.
      static TCKind tk_char
      The TCKind constant whose value field is initialized with TCKind._tk_char.
      static TCKind tk_double
      The TCKind constant whose value field is initialized with TCKind._tk_double.
      static TCKind tk_enum
      The TCKind constant whose value field is initialized with TCKind._tk_enum.
      static TCKind tk_except
      The TCKind constant whose value field is initialized with TCKind._tk_except.
      static TCKind tk_fixed
      The TCKind constant whose value field is initialized with TCKind._tk_fixed.
      static TCKind tk_float
      The TCKind constant whose value field is initialized with TCKind._tk_float.
      static TCKind tk_long
      The TCKind constant whose value field is initialized with TCKind._tk_long.
      static TCKind tk_longdouble
      The TCKind constant whose value field is initialized with TCKind._tk_longdouble.
      static TCKind tk_longlong
      The TCKind constant whose value field is initialized with TCKind._tk_longlong.
      static TCKind tk_native
      The TCKind constant whose value field is initialized with TCKind._tk_native.
      static TCKind tk_null
      The TCKind constant whose value field is initialized with TCKind._tk_null.
      static TCKind tk_objref
      The TCKind constant whose value field is initialized with TCKind._tk_objref.
      static TCKind tk_octet
      The TCKind constant whose value field is initialized with TCKind._tk_octet.
      static TCKind tk_Principal
      The TCKind constant whose value field is initialized with TCKind._tk_Principal.
      static TCKind tk_sequence
      The TCKind constant whose value field is initialized with TCKind._tk_sequence.
      static TCKind tk_short
      The TCKind constant whose value field is initialized with TCKind._tk_short.
      static TCKind tk_string
      The TCKind constant whose value field is initialized with TCKind._tk_string.
      static TCKind tk_struct
      The TCKind constant whose value field is initialized with TCKind._tk_struct.
      static TCKind tk_TypeCode
      The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.
      static TCKind tk_ulong
      The TCKind constant whose value field is initialized with TCKind._tk_ulong.
      static TCKind tk_ulonglong
      The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.
      static TCKind tk_union
      The TCKind constant whose value field is initialized with TCKind._tk_union.
      static TCKind tk_ushort
      The TCKind constant whose value field is initialized with TCKind._tk_ushort.
      static TCKind tk_value
      The TCKind constant whose value field is initialized with TCKind._tk_value.
      static TCKind tk_value_box
      The TCKind constant whose value field is initialized with TCKind._tk_value_box.
      static TCKind tk_void
      The TCKind constant whose value field is initialized with TCKind._tk_void.
      static TCKind tk_wchar
      The TCKind constant whose value field is initialized with TCKind._tk_wchar.
      static TCKind tk_wstring
      The TCKind constant whose value field is initialized with TCKind._tk_wstring.

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected TCKind(int _value)
      Deprecated.
      Do not use this constructor as this method should be private according to the OMG specification. Use from_int(int) instead.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      static TCKind from_int(int i)
      Converts the given int to the corresponding TCKind instance.
      int value()
      Retrieves the value of this TCKind instance.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _tk_null

        public static final int _tk_null
        The int constant for a null IDL data type.
        See Also:
        Constant Field Values

      • _tk_void

        public static final int _tk_void
        The int constant for the IDL data type void.
        See Also:
        Constant Field Values

      • _tk_short

        public static final int _tk_short
        The int constant for the IDL data type short.
        See Also:
        Constant Field Values

      • _tk_long

        public static final int _tk_long
        The int constant for the IDL data type long.
        See Also:
        Constant Field Values

      • _tk_ushort

        public static final int _tk_ushort
        The int constant for the IDL data type ushort.
        See Also:
        Constant Field Values

      • _tk_ulong

        public static final int _tk_ulong
        The int constant for the IDL data type ulong.
        See Also:
        Constant Field Values

      • _tk_float

        public static final int _tk_float
        The int constant for the IDL data type float.
        See Also:
        Constant Field Values

      • _tk_double

        public static final int _tk_double
        The int constant for the IDL data type double.
        See Also:
        Constant Field Values

      • _tk_boolean

        public static final int _tk_boolean
        The int constant for the IDL data type boolean.
        See Also:
        Constant Field Values

      • _tk_char

        public static final int _tk_char
        The int constant for the IDL data type char.
        See Also:
        Constant Field Values

      • _tk_octet

        public static final int _tk_octet
        The int constant for the IDL data type octet.
        See Also:
        Constant Field Values

      • _tk_any

        public static final int _tk_any
        The int constant for the IDL data type any.
        See Also:
        Constant Field Values

      • _tk_TypeCode

        public static final int _tk_TypeCode
        The int constant for the IDL data type TypeCode.
        See Also:
        Constant Field Values

      • _tk_Principal

        public static final int _tk_Principal
        The int constant for the IDL data type Principal.
        See Also:
        Constant Field Values

      • _tk_objref

        public static final int _tk_objref
        The int constant for the IDL data type objref.
        See Also:
        Constant Field Values

      • _tk_struct

        public static final int _tk_struct
        The int constant for the IDL data type struct.
        See Also:
        Constant Field Values

      • _tk_union

        public static final int _tk_union
        The int constant for the IDL data type union.
        See Also:
        Constant Field Values

      • _tk_enum

        public static final int _tk_enum
        The int constant for the IDL data type enum.
        See Also:
        Constant Field Values

      • _tk_string

        public static final int _tk_string
        The int constant for the IDL data type string.
        See Also:
        Constant Field Values

      • _tk_sequence

        public static final int _tk_sequence
        The int constant for the IDL data type sequence.
        See Also:
        Constant Field Values

      • _tk_array

        public static final int _tk_array
        The int constant for the IDL data type array.
        See Also:
        Constant Field Values

      • _tk_alias

        public static final int _tk_alias
        The int constant for the IDL data type alias.
        See Also:
        Constant Field Values

      • _tk_except

        public static final int _tk_except
        The int constant for the IDL data type except.
        See Also:
        Constant Field Values

      • _tk_longlong

        public static final int _tk_longlong
        The int constant for the IDL data type longlong.
        See Also:
        Constant Field Values

      • _tk_ulonglong

        public static final int _tk_ulonglong
        The int constant for the IDL data type ulonglong.
        See Also:
        Constant Field Values

      • _tk_longdouble

        public static final int _tk_longdouble
        The int constant for the IDL data type longdouble.
        See Also:
        Constant Field Values

      • _tk_wchar

        public static final int _tk_wchar
        The int constant for the IDL data type wchar.
        See Also:
        Constant Field Values

      • _tk_wstring

        public static final int _tk_wstring
        The int constant for the IDL data type wstring.
        See Also:
        Constant Field Values

      • _tk_fixed

        public static final int _tk_fixed
        The int constant for the IDL data type fixed.
        See Also:
        Constant Field Values

      • _tk_value

        public static final int _tk_value
        The int constant for the IDL data type value.
        See Also:
        Constant Field Values

      • _tk_value_box

        public static final int _tk_value_box
        The int constant for the IDL data type value_box.
        See Also:
        Constant Field Values

      • _tk_native

        public static final int _tk_native
        The int constant for the IDL data type native.
        See Also:
        Constant Field Values

      • _tk_abstract_interface

        public static final int _tk_abstract_interface
        The int constant for the IDL data type abstract interface.
        See Also:
        Constant Field Values

      • tk_null

        public static final TCKind tk_null
        The TCKind constant whose value field is initialized with TCKind._tk_null.

      • tk_void

        public static final TCKind tk_void
        The TCKind constant whose value field is initialized with TCKind._tk_void.

      • tk_short

        public static final TCKind tk_short
        The TCKind constant whose value field is initialized with TCKind._tk_short.

      • tk_long

        public static final TCKind tk_long
        The TCKind constant whose value field is initialized with TCKind._tk_long.

      • tk_ushort

        public static final TCKind tk_ushort
        The TCKind constant whose value field is initialized with TCKind._tk_ushort.

      • tk_ulong

        public static final TCKind tk_ulong
        The TCKind constant whose value field is initialized with TCKind._tk_ulong.

      • tk_float

        public static final TCKind tk_float
        The TCKind constant whose value field is initialized with TCKind._tk_float.

      • tk_double

        public static final TCKind tk_double
        The TCKind constant whose value field is initialized with TCKind._tk_double.

      • tk_boolean

        public static final TCKind tk_boolean
        The TCKind constant whose value field is initialized with TCKind._tk_boolean.

      • tk_char

        public static final TCKind tk_char
        The TCKind constant whose value field is initialized with TCKind._tk_char.

      • tk_octet

        public static final TCKind tk_octet
        The TCKind constant whose value field is initialized with TCKind._tk_octet.

      • tk_any

        public static final TCKind tk_any
        The TCKind constant whose value field is initialized with TCKind._tk_any.

      • tk_TypeCode

        public static final TCKind tk_TypeCode
        The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.

      • tk_Principal

        public static final TCKind tk_Principal
        The TCKind constant whose value field is initialized with TCKind._tk_Principal.

      • tk_objref

        public static final TCKind tk_objref
        The TCKind constant whose value field is initialized with TCKind._tk_objref.

      • tk_struct

        public static final TCKind tk_struct
        The TCKind constant whose value field is initialized with TCKind._tk_struct.

      • tk_union

        public static final TCKind tk_union
        The TCKind constant whose value field is initialized with TCKind._tk_union.

      • tk_enum

        public static final TCKind tk_enum
        The TCKind constant whose value field is initialized with TCKind._tk_enum.

      • tk_string

        public static final TCKind tk_string
        The TCKind constant whose value field is initialized with TCKind._tk_string.

      • tk_sequence

        public static final TCKind tk_sequence
        The TCKind constant whose value field is initialized with TCKind._tk_sequence.

      • tk_array

        public static final TCKind tk_array
        The TCKind constant whose value field is initialized with TCKind._tk_array.

      • tk_alias

        public static final TCKind tk_alias
        The TCKind constant whose value field is initialized with TCKind._tk_alias.

      • tk_except

        public static final TCKind tk_except
        The TCKind constant whose value field is initialized with TCKind._tk_except.

      • tk_longlong

        public static final TCKind tk_longlong
        The TCKind constant whose value field is initialized with TCKind._tk_longlong.

      • tk_ulonglong

        public static final TCKind tk_ulonglong
        The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.

      • tk_longdouble

        public static final TCKind tk_longdouble
        The TCKind constant whose value field is initialized with TCKind._tk_longdouble.

      • tk_wchar

        public static final TCKind tk_wchar
        The TCKind constant whose value field is initialized with TCKind._tk_wchar.

      • tk_wstring

        public static final TCKind tk_wstring
        The TCKind constant whose value field is initialized with TCKind._tk_wstring.

      • tk_fixed

        public static final TCKind tk_fixed
        The TCKind constant whose value field is initialized with TCKind._tk_fixed.

      • tk_value

        public static final TCKind tk_value
        The TCKind constant whose value field is initialized with TCKind._tk_value.

      • tk_value_box

        public static final TCKind tk_value_box
        The TCKind constant whose value field is initialized with TCKind._tk_value_box.

      • tk_native

        public static final TCKind tk_native
        The TCKind constant whose value field is initialized with TCKind._tk_native.

      • tk_abstract_interface

        public static final TCKind tk_abstract_interface
        The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.

    • Constructor Detail

      • TCKind

        @Deprecated
protected TCKind(int _value)
        Deprecated. Do not use this constructor as this method should be private according to the OMG specification. Use from_int(int) instead.
        Creates a new TCKind instance initialized with the given int.
        Parameters:
        _value - the int to convert. It must be one of the int constants in the class TCKind.

    • Method Detail

      • value

        public int value()
        Retrieves the value of this TCKind instance.
        Returns:
        the int that represents the kind of IDL data type for this TCKind instance

      • from_int

        public static TCKind from_int(int i)
        Converts the given int to the corresponding TCKind instance.
        Parameters:
        i - the int to convert. It must be one of the int constants in the class TCKind.
        Returns:
        the TCKind instance whose value field matches the given int
        Throws:
        BAD_PARAM - if the given int does not match the _value field of any TCKind instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TIMEOUT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TIMEOUT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TIMEOUT
  • All Implemented Interfaces:
    Serializable

    public final class TIMEOUT
extends SystemException
    TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded. It is a standard system exception because time-to-live QoS can be applied to any invocation.
    Since:
    J2SE 1.5
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      TIMEOUT()
      Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      TIMEOUT(int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified minor code and completion status.
      TIMEOUT(String detailMessage)
      Constructs an TIMEOUT exception with the specified message.
      TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TIMEOUT

        public TIMEOUT()
        Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • TIMEOUT

        public TIMEOUT(String detailMessage)
        Constructs an TIMEOUT exception with the specified message.
        Parameters:
        detailMessage - string containing a detailed message.

      • TIMEOUT

        public TIMEOUT(int minorCode,
               CompletionStatus completionStatus)
        Constructs an TIMEOUT exception with the specified minor code and completion status.
        Parameters:
        minorCode - minor code.
        completionStatus - completion status.

      • TIMEOUT

        public TIMEOUT(String detailMessage,
               int minorCode,
               CompletionStatus completionStatus)
        Constructs an TIMEOUT exception with the specified message, minor code, and completion status.
        Parameters:
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TRANSACTION_MODE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TRANSACTION_MODE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_MODE
  • All Implemented Interfaces:
    Serializable

    public final class TRANSACTION_MODE
extends SystemException
    The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation). It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG CORBA core 2.4 specification has details.
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      TRANSACTION_MODE()
      Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_MODE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
      TRANSACTION_MODE(String s)
      Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TRANSACTION_MODE

        public TRANSACTION_MODE()
        Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_MODE

        public TRANSACTION_MODE(String s)
        Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • TRANSACTION_MODE

        public TRANSACTION_MODE(int minor,
                        CompletionStatus completed)
        Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • TRANSACTION_MODE

        public TRANSACTION_MODE(String s,
                        int minor,
                        CompletionStatus completed)
        Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TRANSACTION_REQUIRED (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TRANSACTION_REQUIRED

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_REQUIRED
  • All Implemented Interfaces:
    Serializable

    public final class TRANSACTION_REQUIRED
extends SystemException
    Exception indicates that the request carried a null transaction context, but an active transaction is required.

    It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG Transaction Service specfication has details.

    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      TRANSACTION_REQUIRED()
      Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
      TRANSACTION_REQUIRED(String s)
      Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED()
        Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED(String s)
        Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED(int minor,
                            CompletionStatus completed)
        Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED(String s,
                            int minor,
                            CompletionStatus completed)
        Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TRANSACTION_ROLLEDBACK (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TRANSACTION_ROLLEDBACK

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
  • All Implemented Interfaces:
    Serializable

    public final class TRANSACTION_ROLLEDBACK
extends SystemException
    Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back. Thus, the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.

    See the OMG Transaction Service specification for details. It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      TRANSACTION_ROLLEDBACK()
      Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
      TRANSACTION_ROLLEDBACK(String s)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK()
        Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK(String s)
        Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK(int minor,
                              CompletionStatus completed)
        Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK(String s,
                              int minor,
                              CompletionStatus completed)
        Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TRANSACTION_UNAVAILABLE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TRANSACTION_UNAVAILABLE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
  • All Implemented Interfaces:
    Serializable

    public final class TRANSACTION_UNAVAILABLE
extends SystemException
    The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated. It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG CORBA core 2.4 specification has details.
    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      TRANSACTION_UNAVAILABLE()
      Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
      TRANSACTION_UNAVAILABLE(String s)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE()
        Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE(String s)
        Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE(int minor,
                               CompletionStatus completed)
        Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE(String s,
                               int minor,
                               CompletionStatus completed)
        Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TRANSIENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TRANSIENT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSIENT
  • All Implemented Interfaces:
    Serializable

    public final class TRANSIENT
extends SystemException
    Exception thrown when the ORB attempted to reach an object and failed. It is not an indication that an object does not exist. Instead, it simply means that no further determination of an object's status was possible because it could not be reached. This exception is raised if an attempt to establish a connection fails, for example, because the server or the implementation repository is down.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      TRANSIENT()
      Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSIENT(int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified minor code and completion status.
      TRANSIENT(String s)
      Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSIENT(String s, int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TRANSIENT

        public TRANSIENT()
        Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSIENT

        public TRANSIENT(String s)
        Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • TRANSIENT

        public TRANSIENT(int minor,
                 CompletionStatus completed)
        Constructs a TRANSIENT exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • TRANSIENT

        public TRANSIENT(String s,
                 int minor,
                 CompletionStatus completed)
        Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeCode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TypeCode

  • java.lang.Object
    • org.omg.CORBA.TypeCode
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public abstract class TypeCode
extends Object
implements IDLEntity
    A container for information about a specific CORBA data type.

    TypeCode objects are used:

    • in the Dynamic Invocation Interface -- to indicate the types of the actual arguments or the type of the return value.
      NamedValue objects are used to represent arguments and return values. One of their components is an Any object, which in turn has as one of its components a TypeCode object.
    • by an Interface Repository to represent the type specifications that are part of many OMG IDL declarations

    The representation of a TypeCode object is opaque, but abstractly, a TypeCode object consists of:

    • a kind field, which is set to an instance of the class TCKind
    • zero or more additional fields appropriate for the particular kind. For example, the TypeCode object describing the OMG IDL type 1ong has kind TCKind.tk_long and no additional fields. The TypeCode describing OMG IDL type sequence<boolean, 10> has a kind field with the value TCKind.tk_sequence and also fields with the values boolean and 10 for the type of sequence elements and the length of the sequence.

    TypeCode objects can be obtained in various ways:
    1. from a call to the method Any.insert_X, where X is a basic IDL type. This method creates a TypeCode object for type X and assigns it to the Any object's type field.
    2. from invocations of methods in the ORB class

      For example, the following creates a TypeCode object for a string with a maximum of 30 characters:

         org.omg.CORBA.TypeCode tcString = orb.create_string_tc(30);

      The following creates a TypeCode object for an array of five strings:

         org.omg.CORBA.TypeCode tcArray = orb.create_array_tc(
                                       5, TCKind.tk_string);

      The following creates a TypeCode object for an interface named "Account":

         org.omg.CORBA.TypeCode tcInterface = orb.create_interface_tc(
                                                 "thisId", "Account");
    3. as the return value from the _type method in Holder classes for user-defined IDL types. These Holder classes are generated by the idltojava compiler.
    4. from a CORBA Interface Repository

    Most of the methods in the class TypeCode are accessors, and the information contained in a TypeCode object is specific to a particular type. Therefore, methods must be invoked only on the kind of type codes to which they apply. If an accessor method tries to access information from an inappropriate kind of type code, it will throw the exception TypeCodePackage.BadKind. For example, if the method discriminator_type is called on anything other than a union, it will throw BadKind because only unions have a discriminator. The following list shows which methods apply to which kinds of type codes:

    These methods may be invoked on all TypeCode kinds:

    • equal
    • kind

    These methods may be invoked on objref, struct, union, enum, alias, exception, value, value_box, native, and abstract_interface:

    • id
    • name

    These methods may be invoked on struct, union, enum, and exception:

    • member_count
    • member_name

    These methods may be invoked on struct, union, and exception:

    • member_type(int index)

    These methods may be invoked on union:

    • member_label
    • discriminator_type
    • default_index

    These methods may be invoked on string, sequence, and array:

    • length

    These methods may be invoked on alias, sequence, array, and value_box:

    • content_type

    Unlike other CORBA pseudo-objects, TypeCode objects can be passed as general IDL parameters.

    The methods parameter and param_count, which are deprecated, are not mapped.

    Java IDL extends the CORBA specification to allow all operations permitted on a struct TypeCode to be permitted on an exception TypeCode as well.

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeCode()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract TypeCode concrete_base_type()
      Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
      abstract TypeCode content_type()
      Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
      abstract int default_index()
      Returns the index of the default member, or -1 if there is no default member.
      abstract TypeCode discriminator_type()
      Returns a TypeCode object describing all non-default member labels.
      abstract boolean equal(TypeCode tc)
      Compares this TypeCode object with the given one, testing for equality.
      abstract boolean equivalent(TypeCode tc)
      Tests to see if the given TypeCode object is equivalent to this TypeCode object.
      abstract short fixed_digits()
      Returns the number of digits in the fixed type described by this TypeCode object.
      abstract short fixed_scale()
      Returns the scale of the fixed type described by this TypeCode object.
      abstract TypeCode get_compact_typecode()
      Strips out all optional name and member name fields, but leaves all alias typecodes intact.
      abstract String id()
      Retrieves the RepositoryId globally identifying the type of this TypeCode object.
      abstract TCKind kind()
      Retrieves the kind of this TypeCode object.
      abstract int length()
      Returns the number of elements in the type described by this TypeCode object.
      abstract int member_count()
      Retrieves the number of members in the type described by this TypeCode object.
      abstract Any member_label(int index)
      Retrieves the label of the union member identified by the given index.
      abstract String member_name(int index)
      Retrieves the simple name of the member identified by the given index.
      abstract TypeCode member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      abstract short member_visibility(int index)
      Returns the constant that indicates the visibility of the member at the given index.
      abstract String name()
      Retrieves the simple name identifying this TypeCode object within its enclosing scope.
      abstract short type_modifier()
      Returns a constant indicating the modifier of the value type that this TypeCode object describes.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TypeCode

        public TypeCode()

    • Method Detail

      • equal

        public abstract boolean equal(TypeCode tc)
        Compares this TypeCode object with the given one, testing for equality. TypeCode objects are equal if they are interchangeable and give identical results when TypeCode operations are applied to them.
        Parameters:
        tc - the TypeCode object to compare against
        Returns:
        true if the type codes are equal; false otherwise

      • equivalent

        public abstract boolean equivalent(TypeCode tc)
        Tests to see if the given TypeCode object is equivalent to this TypeCode object.

        Parameters:
        tc - the typecode to compare with this typecode
        Returns:
        true if the given typecode is equivalent to this typecode; false otherwise

      • get_compact_typecode

        public abstract TypeCode get_compact_typecode()
        Strips out all optional name and member name fields, but leaves all alias typecodes intact.
        Returns:
        a TypeCode object with optional name and member name fields stripped out, except for alias typecodes, which are left intact
        See Also:
        CORBA package comments for unimplemented features

      • kind

        public abstract TCKind kind()
        Retrieves the kind of this TypeCode object. The kind of a type code determines which TypeCode methods may legally be invoked on it.

        The method kind may be invoked on any TypeCode object.

        Returns:
        the TCKind instance indicating the value of the kind field of this TypeCode object

      • id

        public abstract String id()
                   throws BadKind
        Retrieves the RepositoryId globally identifying the type of this TypeCode object.

        The method id can be invoked on object reference, structure, union, enumeration, alias, exception, valuetype, boxed valuetype, native, and abstract interface type codes. Object reference, exception, valuetype, boxed valuetype, native, and abstract interface TypeCode objects always have a RepositoryId. Structure, union, enumeration, and alias TypeCode objects obtained from the Interface Repository or the method ORB.create_operation_list also always have a RepositoryId. If there is no RepositoryId, the method can return an empty string.

        Returns:
        the RepositoryId for this TypeCode object or an empty string if there is no RepositoryID
        Throws:
        BadKind - if the method is invoked on an inappropriate kind ofTypeCode object

      • name

        public abstract String name()
                     throws BadKind
        Retrieves the simple name identifying this TypeCode object within its enclosing scope. Since names are local to a Repository, the name returned from a TypeCode object may not match the name of the type in any particular Repository, and may even be an empty string.

        The method name can be invoked on object reference, structure, union, enumeration, alias, exception, valuetype, boxed valuetype, native, and abstract interface TypeCode objects.

        Returns:
        the name identifying this TypeCode object or an empty string
        Throws:
        BadKind - if the method is invoked on an inappropriate kind ofTypeCode object

      • member_count

        public abstract int member_count()
                          throws BadKind
        Retrieves the number of members in the type described by this TypeCode object.

        The method member_count can be invoked on structure, union, and enumeration TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

        Returns:
        the number of members constituting the type described by this TypeCode object
        Throws:
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • member_name

        public abstract String member_name(int index)
                            throws BadKind,
                                   Bounds
        Retrieves the simple name of the member identified by the given index. Since names are local to a Repository, the name returned from a TypeCode object may not match the name of the member in any particular Repository, and may even be an empty string.

        The method member_name can be invoked on structure, union, and enumeration TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

        Parameters:
        index - index of the member for which a name is being reqested
        Returns:
        simple name of the member identified by the index or an empty string
        Throws:
        Bounds - if the index is equal to or greater than the number of members constituting the type
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • member_type

        public abstract TypeCode member_type(int index)
                              throws BadKind,
                                     Bounds
        Retrieves the TypeCode object describing the type of the member identified by the given index.

        The method member_type can be invoked on structure and union TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

        Parameters:
        index - index of the member for which type information is begin requested
        Returns:
        the TypeCode object describing the member at the given index
        Throws:
        Bounds - if the index is equal to or greater than the number of members constituting the type
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • member_label

        public abstract Any member_label(int index)
                          throws BadKind,
                                 Bounds
        Retrieves the label of the union member identified by the given index. For the default member, the label is the zero octet.

        The method member_label can only be invoked on union TypeCode objects.

        Parameters:
        index - index of the union member for which the label is being requested
        Returns:
        an Any object describing the label of the requested union member or the zero octet for the default member
        Throws:
        Bounds - if the index is equal to or greater than the number of members constituting the union
        BadKind - if the method is invoked on a non-union TypeCode object

      • discriminator_type

        public abstract TypeCode discriminator_type()
                                     throws BadKind
        Returns a TypeCode object describing all non-default member labels. The method discriminator_type can be invoked only on union TypeCode objects.
        Returns:
        the TypeCode object describing the non-default member labels
        Throws:
        BadKind - if the method is invoked on a non-union TypeCode object

      • default_index

        public abstract int default_index()
                           throws BadKind
        Returns the index of the default member, or -1 if there is no default member.

        The method default_index can be invoked only on union TypeCode objects.

        Returns:
        the index of the default member, or -1 if there is no default member
        Throws:
        BadKind - if the method is invoked on a non-union TypeCode object

      • length

        public abstract int length()
                    throws BadKind
        Returns the number of elements in the type described by this TypeCode object. For strings and sequences, it returns the bound, with zero indicating an unbounded string or sequence. For arrays, it returns the number of elements in the array.

        The method length can be invoked on string, sequence, and array TypeCode objects.

        Returns:
        the bound for strings and sequences, or the number of elements for arrays
        Throws:
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • content_type

        public abstract TypeCode content_type()
                               throws BadKind
        Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object. For sequences and arrays, it returns the element type. For aliases, it returns the original type. Note that multidimensional arrays are represented by nesting TypeCode objects, one per dimension. For boxed valuetypes, it returns the boxed type.

        The method content_type can be invoked on sequence, array, alias, and boxed valuetype TypeCode objects.

        Returns:
        a TypeCode object representing the element type for sequences and arrays, the original type for aliases, or the boxed type for boxed valuetypes.
        Throws:
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • fixed_digits

        public abstract short fixed_digits()
                            throws BadKind
        Returns the number of digits in the fixed type described by this TypeCode object. For example, the typecode for the number 3000.275d could be fixed<7,3>, where 7 is the precision and 3 is the scale.
        Returns:
        the total number of digits
        Throws:
        BadKind - if this method is invoked on an inappropriate kind of TypeCode object

      • fixed_scale

        public abstract short fixed_scale()
                           throws BadKind
        Returns the scale of the fixed type described by this TypeCode object. A positive number indicates the number of digits to the right of the decimal point. For example, the number 3000d could have the typecode fixed<4,0>, where the first number is the precision and the second number is the scale. A negative number is also possible and adds zeroes to the left of the decimal point. In this case, fixed<1,-3>, could be the typecode for the number 3000d.
        Returns:
        the scale of the fixed type that this TypeCode object describes
        Throws:
        BadKind - if this method is invoked on an inappropriate kind of TypeCode object

      • member_visibility

        public abstract short member_visibility(int index)
                                 throws BadKind,
                                        Bounds
        Returns the constant that indicates the visibility of the member at the given index. This operation can only be invoked on non-boxed value TypeCode objects.
        Parameters:
        index - an int indicating the index into the value
        Returns:
        either PRIVATE_MEMBER.value or PUBLIC_MEMBER.value
        Throws:
        BadKind - if this method is invoked on a non-value type TypeCode object
        Bounds - if the given index is out of bounds
        See Also:
        CORBA package comments for unimplemented features

      • type_modifier

        public abstract short type_modifier()
                             throws BadKind
        Returns a constant indicating the modifier of the value type that this TypeCode object describes. The constant returned must be one of the following: VM_NONE.value, VM_ABSTRACT.value, VM_CUSTOM.value, or VM_TRUNCATABLE.value,
        Returns:
        a constant describing the value type that this TypeCode object describes
        Throws:
        BadKind - if this method is invoked on a non-value type TypeCode object
        See Also:
        CORBA package comments for unimplemented features

      • concrete_base_type

        public abstract TypeCode concrete_base_type()
                                     throws BadKind
        Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes. Returns null if it doesn't have a concrete base type.
        Returns:
        the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes
        Throws:
        BadKind - if this method is invoked on a non-boxed value type TypeCode object
        See Also:
        CORBA package comments for unimplemented features
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeCodeHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class TypeCodeHolder

  • java.lang.Object
    • org.omg.CORBA.TypeCodeHolder
  • All Implemented Interfaces:
    Streamable

    public final class TypeCodeHolder
extends Object
implements Streamable
    The Holder for TypeCode. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a TypeCode object that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL TypeCode as an "out" or "inout" parameter, the programmer must pass an instance of TypeCodeHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myTypeCodeHolder is an instance of TypeCodeHolder, the value stored in its value field can be accessed with myTypeCodeHolder.value.

    Since:
    JDK1.2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TypeCode value
      The TypeCode value held by this TypeCodeHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeCodeHolder()
      Constructs a new TypeCodeHolder object with its value field initialized to null.
      TypeCodeHolder(TypeCode initial)
      Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this TypeCodeHolder object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TypeCode value
        The TypeCode value held by this TypeCodeHolder object.

    • Constructor Detail

      • TypeCodeHolder

        public TypeCodeHolder()
        Constructs a new TypeCodeHolder object with its value field initialized to null.

      • TypeCodeHolder

        public TypeCodeHolder(TypeCode initial)
        Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.
        Parameters:
        initial - the TypeCode object with which to initialize the value field of the newly-created TypeCodeHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this TypeCodeHolder object.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in this TypeCodeHolder object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ULongLongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ULongLongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.ULongLongSeqHelper

  • public abstract class ULongLongSeqHelper
extends Object
    The Helper for ULongLongSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ULongLongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      ULongLongSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static long[] | extract(Any a)
      static String | id()
      static void | insert(Any a, long[] that)
      static long[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, long[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ULongLongSeqHelper

        public ULongLongSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          long[] that)

      • extract

        public static long[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static long[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         long[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ULongLongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ULongLongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.ULongLongSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class ULongLongSeqHolder
extends Object
implements Streamable
    The Holder for ULongLongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/ULongLongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      long[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      ULongLongSeqHolder()
      ULongLongSeqHolder(long[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public long[] value

    • Constructor Detail

      • ULongLongSeqHolder

        public ULongLongSeqHolder()

      • ULongLongSeqHolder

        public ULongLongSeqHolder(long[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ULongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ULongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.ULongSeqHelper

  • public abstract class ULongSeqHelper
extends Object
    The Helper for ULongSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ULongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      ULongSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int[] | extract(Any a)
      static String | id()
      static void | insert(Any a, int[] that)
      static int[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ULongSeqHelper

        public ULongSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int[] that)

      • extract

        public static int[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ULongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ULongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.ULongSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class ULongSeqHolder
extends Object
implements Streamable
    The Holder for ULongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/ULongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      int[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      ULongSeqHolder()
      ULongSeqHolder(int[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public int[] value

    • Constructor Detail

      • ULongSeqHolder

        public ULongSeqHolder()

      • ULongSeqHolder

        public ULongSeqHolder(int[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnionMember (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UnionMember

  • java.lang.Object
    • org.omg.CORBA.UnionMember
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class UnionMember
extends Object
implements IDLEntity
    A description in the Interface Repository of a member of an IDL union.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Any label
      The label of the union member described by this UnionMember object.
      String name
      The name of the union member described by this UnionMember object.
      TypeCode type
      The type of the union member described by this UnionMember object.
      IDLType type_def
      The typedef that represents the IDL type of the union member described by this UnionMember object.

    • Constructor Summary

      Constructors
      Constructor and Description
      UnionMember()
      Constructs a new UnionMember object with its fields initialized to null.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        public String name
        The name of the union member described by this UnionMember object.

      • label

        public Any label
        The label of the union member described by this UnionMember object.

      • type

        public TypeCode type
        The type of the union member described by this UnionMember object.

      • type_def

        public IDLType type_def
        The typedef that represents the IDL type of the union member described by this UnionMember object.

    • Constructor Detail

      • UnionMember

        public UnionMember()
        Constructs a new UnionMember object with its fields initialized to null.

      • UnionMember

        public UnionMember(String __name,
                   Any __label,
                   TypeCode __type,
                   IDLType __type_def)
        Constructs a new UnionMember object with its fields initialized to the given values.
        Parameters:
        __name - a String object with the name of this UnionMember object
        __label - an Any object with the label of this UnionMember object
        __type - a TypeCode object describing the type of this UnionMember object
        __type_def - an IDLType object that represents the IDL type of this UnionMember object
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnionMemberHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UnionMemberHelper

  • java.lang.Object
    • org.omg.CORBA.UnionMemberHelper

  • public abstract class UnionMemberHelper
extends Object
    The Helper for UnionMember. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/UnionMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      UnionMemberHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static UnionMember | extract(Any a)
      static String | id()
      static void | insert(Any a, UnionMember that)
      static UnionMember | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnionMember value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UnionMemberHelper

        public UnionMemberHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          UnionMember that)

      • extract

        public static UnionMember extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnionMember read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         UnionMember value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UNKNOWN (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UNKNOWN

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.UNKNOWN
  • All Implemented Interfaces:
    Serializable

    public final class UNKNOWN
extends SystemException
    This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression. UNKNOWN is also raised if the server returns a system exception that is unknown to the client. (This can happen if the server uses a later version of CORBA than the client and new system exceptions have been added to the later version.)

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    See Also:
    documentation on Java IDL exceptions

    • Field Summary

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      UNKNOWN()
      Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      UNKNOWN(int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified minor code and completion status.
      UNKNOWN(String s)
      Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      UNKNOWN(String s, int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UNKNOWN

        public UNKNOWN()
        Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • UNKNOWN

        public UNKNOWN(String s)
        Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        Parameters:
        s - the String containing a detail message

      • UNKNOWN

        public UNKNOWN(int minor,
               CompletionStatus completed)
        Constructs an UNKNOWN exception with the specified minor code and completion status.
        Parameters:
        minor - the minor code
        completed - the completion status

      • UNKNOWN

        public UNKNOWN(String s,
               int minor,
               CompletionStatus completed)
        Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.
        Parameters:
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnknownUserException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UnknownUserException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.UnknownUserException
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class UnknownUserException
extends UserException
    A class that contains user exceptions returned by the server. When the client uses the DII to make an invocation, any user exception returned from the server is enclosed in an Any object contained in the UnknownUserException object. This is available from the Environment object returned by the method Request.env.
    See Also:
    documentation on Java IDL exceptions, Request

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Any except
      The Any instance that contains the actual user exception thrown by the server.

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownUserException()
      Constructs an UnknownUserException object.
      UnknownUserException(Any a)
      Constructs an UnknownUserException object that contains the given Any object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • except

        public Any except
        The Any instance that contains the actual user exception thrown by the server.

    • Constructor Detail

      • UnknownUserException

        public UnknownUserException()
        Constructs an UnknownUserException object.

      • UnknownUserException

        public UnknownUserException(Any a)
        Constructs an UnknownUserException object that contains the given Any object.
        Parameters:
        a - an Any object that contains a user exception returned by the server
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnknownUserExceptionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UnknownUserExceptionHelper

  • java.lang.Object
    • org.omg.CORBA.UnknownUserExceptionHelper

  • public abstract class UnknownUserExceptionHelper
extends Object
    The Helper for UnknownUserException. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/UnknownUserExceptionHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:52:22 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownUserExceptionHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static UnknownUserException | extract(Any a)
      static String | id()
      static void | insert(Any a, UnknownUserException that)
      static UnknownUserException | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnknownUserException value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UnknownUserExceptionHelper

        public UnknownUserExceptionHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          UnknownUserException that)

      • extract

        public static UnknownUserException extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnknownUserException read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         UnknownUserException value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnknownUserExceptionHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UnknownUserExceptionHolder

  • java.lang.Object
    • org.omg.CORBA.UnknownUserExceptionHolder
  • All Implemented Interfaces:
    Streamable

    public final class UnknownUserExceptionHolder
extends Object
implements Streamable
    The Holder for UnknownUserException. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/UnknownUserExceptionHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:52:22 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      UnknownUserException value

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownUserExceptionHolder()
      UnknownUserExceptionHolder(UnknownUserException initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public UnknownUserException value

    • Constructor Detail

      • UnknownUserExceptionHolder

        public UnknownUserExceptionHolder()

      • UnknownUserExceptionHolder

        public UnknownUserExceptionHolder(UnknownUserException initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UNSUPPORTED_POLICY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface UNSUPPORTED_POLICY

  • public interface UNSUPPORTED_POLICY
    One of the PolicyErrorCodes which would be filled if the requested Policy is understood to be valid by the ORB, but is not currently supported.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The Error code for PolicyError exception.

    • Field Detail

      • value

        static final short value
        The Error code for PolicyError exception.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UNSUPPORTED_POLICY_VALUE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface UNSUPPORTED_POLICY_VALUE

  • public interface UNSUPPORTED_POLICY_VALUE
    A PolicyErrorCode which would be filled if the value requested for the Policy is of a valid type and within the valid range for that type, but this valid value is not currently supported.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The Error code for PolicyError exception.

    • Field Detail

      • value

        static final short value
        The Error code for PolicyError exception.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UserException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UserException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
  • All Implemented Interfaces:
    Serializable, IDLEntity
    Direct Known Subclasses:
    AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, BadKind, Bounds, Bounds, CannotProceed, DuplicateName, FormatMismatch, ForwardRequest, ForwardRequest, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, NoContext, NoServant, NotEmpty, NotFound, ObjectAlreadyActive, ObjectNotActive, PolicyError, ServantAlreadyActive, ServantNotActive, TypeMismatch, TypeMismatch, TypeMismatch, UnknownEncoding, UnknownUserException, WrongAdapter, WrongPolicy, WrongTransaction

    public abstract class UserException
extends Exception
implements IDLEntity
    The root class for CORBA IDL-defined user exceptions. All CORBA user exceptions are checked exceptions, which means that they need to be declared in method signatures.
    See Also:
    documentation on Java IDL exceptions

    • Constructor Summary

      Constructors
      Modifier Constructor and Description
      protected UserException()
      Constructs a UserException object.
      protected UserException(String reason)
      Constructs a UserException object with a detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UserException

        protected UserException()
        Constructs a UserException object. This method is called only by subclasses.

      • UserException

        protected UserException(String reason)
        Constructs a UserException object with a detail message. This method is called only by subclasses.
        Parameters:
        reason - a String object giving the reason for this exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UShortSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UShortSeqHelper

  • java.lang.Object
    • org.omg.CORBA.UShortSeqHelper

  • public abstract class UShortSeqHelper
extends Object
    The Helper for UShortSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/UShortSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      UShortSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short[] | extract(Any a)
      static String | id()
      static void | insert(Any a, short[] that)
      static short[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UShortSeqHelper

        public UShortSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short[] that)

      • extract

        public static short[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UShortSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class UShortSeqHolder

  • java.lang.Object
    • org.omg.CORBA.UShortSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class UShortSeqHolder
extends Object
implements Streamable
    The Holder for UShortSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/UShortSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      UShortSeqHolder()
      UShortSeqHolder(short[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public short[] value

    • Constructor Detail

      • UShortSeqHolder

        public UShortSeqHolder()

      • UShortSeqHolder

        public UShortSeqHolder(short[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueBaseHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ValueBaseHelper

  • java.lang.Object
    • org.omg.CORBA.ValueBaseHelper

  • public abstract class ValueBaseHelper
extends Object

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueBaseHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Serializable | extract(Any a)
      static String | id()
      static void | insert(Any a, Serializable that)
      static Serializable | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Serializable value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValueBaseHelper

        public ValueBaseHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Serializable that)

      • extract

        public static Serializable extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Serializable read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Serializable value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueBaseHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ValueBaseHolder

  • java.lang.Object
    • org.omg.CORBA.ValueBaseHolder
  • All Implemented Interfaces:
    Streamable

    public final class ValueBaseHolder
extends Object
implements Streamable
    The Holder for ValueBase. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a java.io.Serializable that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL ValueBase as an "out" or "inout" parameter, the programmer must pass an instance of ValueBaseHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myValueBaseHolder is an instance of ValueBaseHolder, the value stored in its value field can be accessed with myValueBaseHolder.value.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Serializable value
      The java.io.Serializable value held by this ValueBaseHolder object.

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueBaseHolder()
      Constructs a new ValueBaseHolder object with its value field initialized to 0.
      ValueBaseHolder(Serializable initial)
      Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      void _write(OutputStream output)
      Marshals to output the value in the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Serializable value
        The java.io.Serializable value held by this ValueBaseHolder object.

    • Constructor Detail

      • ValueBaseHolder

        public ValueBaseHolder()
        Constructs a new ValueBaseHolder object with its value field initialized to 0.

      • ValueBaseHolder

        public ValueBaseHolder(Serializable initial)
        Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.
        Parameters:
        initial - the java.io.Serializable with which to initialize the value field of the newly-created ValueBaseHolder object

    • Method Detail

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode of the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueMember (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ValueMember

  • java.lang.Object
    • org.omg.CORBA.ValueMember
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ValueMember
extends Object
implements IDLEntity
    A description in the Interface Repository of a member of a value object.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      short access
      The type of access (public, private) for the value member described by this ValueMember object.
      String defined_in
      The repository ID of the value in which this member is defined.
      String id
      The repository ID of the value member described by this ValueMember object;
      String name
      The name of the value member described by this ValueMember object.
      TypeCode type
      The type of of this value member.
      IDLType type_def
      The typedef that represents the IDL type of the value member described by this ValueMember object.
      String version
      The version of the value in which this member is defined.

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueMember()
      Constructs a default ValueMember object.
      ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
      Constructs a ValueMember object initialized with the given values.

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • name

        public String name
        The name of the value member described by this ValueMember object.

      • id

        public String id
        The repository ID of the value member described by this ValueMember object;

      • defined_in

        public String defined_in
        The repository ID of the value in which this member is defined.

      • version

        public String version
        The version of the value in which this member is defined.

      • type

        public TypeCode type
        The type of of this value member.

      • type_def

        public IDLType type_def
        The typedef that represents the IDL type of the value member described by this ValueMember object.

      • access

        public short access
        The type of access (public, private) for the value member described by this ValueMember object.

    • Constructor Detail

      • ValueMember

        public ValueMember()
        Constructs a default ValueMember object.

      • ValueMember

        public ValueMember(String __name,
                   String __id,
                   String __defined_in,
                   String __version,
                   TypeCode __type,
                   IDLType __type_def,
                   short __access)
        Constructs a ValueMember object initialized with the given values.
        Parameters:
        __name - The name of the value member described by this ValueMember object.
        __id - The repository ID of the value member described by this ValueMember object;
        __defined_in - The repository ID of the value in which this member is defined.
        __version - The version of the value in which this member is defined.
        __type - The type of of this value member.
        __type_def - The typedef that represents the IDL type of the value member described by this ValueMember object.
        __access - The type of access (public, private) for the value member described by this ValueMember object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueMemberHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class ValueMemberHelper

  • java.lang.Object
    • org.omg.CORBA.ValueMemberHelper

  • public abstract class ValueMemberHelper
extends Object
    The Helper for ValueMember. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ValueMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      ValueMemberHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ValueMember | extract(Any a)
      static String | id()
      static void | insert(Any a, ValueMember that)
      static ValueMember | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ValueMember value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ValueMemberHelper

        public ValueMemberHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ValueMember that)

      • extract

        public static ValueMember extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ValueMember read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ValueMember value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VersionSpecHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class VersionSpecHelper

  • java.lang.Object
    • org.omg.CORBA.VersionSpecHelper

  • public abstract class VersionSpecHelper
extends Object
    The Helper for VersionSpec. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/VersionSpecHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      VersionSpecHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VersionSpecHelper

        public VersionSpecHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VisibilityHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class VisibilityHelper

  • java.lang.Object
    • org.omg.CORBA.VisibilityHelper

  • public abstract class VisibilityHelper
extends Object
    The Helper for Visibility. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/VisibilityHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      VisibilityHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • VisibilityHelper

        public VisibilityHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VM_ABSTRACT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_ABSTRACT

  • public interface VM_ABSTRACT
    Defines the code used to represent an Abstract interface in a typecode. This is one of the possible results of the type_modified method on the TypeCode interface.
    See Also:
    TypeCode

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The value representing an abstract interface value type in a typecode.

    • Field Detail

      • value

        static final short value
        The value representing an abstract interface value type in a typecode.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VM_CUSTOM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_CUSTOM

  • public interface VM_CUSTOM
    Defines the code used to represent a custom marshalled value type in a typecode. This is one of the possible results of the type_modifier method on the TypeCode interface.
    See Also:
    TypeCode

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The value representing a custom marshalled value type in a typecode.

    • Field Detail

      • value

        static final short value
        The value representing a custom marshalled value type in a typecode.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VM_NONE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_NONE

  • public interface VM_NONE
    Defines the code used to represent the one of the values of a value type in a typecode.
    Since:
    JDK1.2
    See Also:
    TypeCode

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The value representing the value type in a typecode as per CORBA 2.3 spec.

    • Field Detail

      • value

        static final short value
        The value representing the value type in a typecode as per CORBA 2.3 spec.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


VM_TRUNCATABLE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_TRUNCATABLE

  • public interface VM_TRUNCATABLE
    Defines the code used to represent a truncatable value type in a typecode. A value type is truncatable if it inherits "safely" from another value type, which means it can be cast to a more general inherited type. This is one of the possible results of the type_modifier method on the TypeCode interface.
    See Also:
    TypeCode

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The value representing a truncatable value type in a typecode.

    • Field Detail

      • value

        static final short value
        The value representing a truncatable value type in a typecode.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WCharSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WCharSeqHelper

  • java.lang.Object
    • org.omg.CORBA.WCharSeqHelper

  • public abstract class WCharSeqHelper
extends Object
    The Helper for WCharSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/WCharSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      WCharSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static char[] | extract(Any a)
      static String | id()
      static void | insert(Any a, char[] that)
      static char[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, char[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WCharSeqHelper

        public WCharSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          char[] that)

      • extract

        public static char[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static char[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         char[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WCharSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WCharSeqHolder

  • java.lang.Object
    • org.omg.CORBA.WCharSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class WCharSeqHolder
extends Object
implements Streamable
    The Holder for WCharSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/WCharSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      char[] | value

    • Constructor Summary

      Constructors
      Constructor and Description
      WCharSeqHolder()
      WCharSeqHolder(char[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public char[] value

    • Constructor Detail

      • WCharSeqHolder

        public WCharSeqHolder()

      • WCharSeqHolder

        public WCharSeqHolder(char[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongTransaction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WrongTransaction

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.WrongTransaction
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class WrongTransaction
extends UserException
    The CORBA WrongTransaction user-defined exception. This exception is thrown only by the methods Request.get_response and ORB.get_next_response when they are invoked from a transaction scope that is different from the one in which the client originally sent the request. See the OMG Transaction Service Specification for details.
    See Also:
    documentation on Java IDL exceptions

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongTransaction()
      Constructs a WrongTransaction object with an empty detail message.
      WrongTransaction(String reason)
      Constructs a WrongTransaction object with the given detail message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WrongTransaction

        public WrongTransaction()
        Constructs a WrongTransaction object with an empty detail message.

      • WrongTransaction

        public WrongTransaction(String reason)
        Constructs a WrongTransaction object with the given detail message.
        Parameters:
        reason - The detail message explaining what caused this exception to be thrown.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongTransactionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WrongTransactionHelper

  • java.lang.Object
    • org.omg.CORBA.WrongTransactionHelper

  • public abstract class WrongTransactionHelper
extends Object
    The Helper for WrongTransaction. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/WrongTransactionHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:32:50 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongTransactionHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static WrongTransaction | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongTransaction that)
      static WrongTransaction | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongTransaction value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WrongTransactionHelper

        public WrongTransactionHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          WrongTransaction that)

      • extract

        public static WrongTransaction extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongTransaction read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         WrongTransaction value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongTransactionHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WrongTransactionHolder

  • java.lang.Object
    • org.omg.CORBA.WrongTransactionHolder
  • All Implemented Interfaces:
    Streamable

    public final class WrongTransactionHolder
extends Object
implements Streamable
    The Holder for WrongTransaction. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/WrongTransactionHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:32:50 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      WrongTransaction value

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongTransactionHolder()
      WrongTransactionHolder(WrongTransaction initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public WrongTransaction value

    • Constructor Detail

      • WrongTransactionHolder

        public WrongTransactionHolder()

      • WrongTransactionHolder

        public WrongTransactionHolder(WrongTransaction initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WStringSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WStringSeqHelper

  • java.lang.Object
    • org.omg.CORBA.WStringSeqHelper

  • public abstract class WStringSeqHelper
extends Object
    An array of WStrings

    • Constructor Summary

      Constructors
      Constructor and Description
      WStringSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WStringSeqHelper

        public WStringSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WStringSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WStringSeqHolder

  • java.lang.Object
    • org.omg.CORBA.WStringSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class WStringSeqHolder
extends Object
implements Streamable
    An array of WStrings

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      WStringSeqHolder()
      WStringSeqHolder(String[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public String[] value

    • Constructor Detail

      • WStringSeqHolder

        public WStringSeqHolder()

      • WStringSeqHolder

        public WStringSeqHolder(String[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WStringValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class WStringValueHelper

  • java.lang.Object
    • org.omg.CORBA.WStringValueHelper
  • All Implemented Interfaces:
    BoxedValueHelper

    public class WStringValueHelper
extends Object
implements BoxedValueHelper
    org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :
    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • Constructor Summary

      Constructors
      Constructor and Description
      WStringValueHelper()

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      String get_id()
      static String | id()
      static void | insert(Any a, String that)
      Serializable | read_value(InputStream istream)
      static String | read(InputStream istream)
      static TypeCode | type()
      void | write_value(OutputStream ostream, Serializable value)
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WStringValueHelper

        public WStringValueHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • read_value

        public Serializable read_value(InputStream istream)
        Specified by:
        read_value in interface BoxedValueHelper

      • write

        public static void write(OutputStream ostream,
                         String value)

      • write_value

        public void write_value(OutputStream ostream,
                        Serializable value)
        Specified by:
        write_value in interface BoxedValueHelper

      • get_id

        public String get_id()
        Specified by:
        get_id in interface BoxedValueHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_IDLTypeStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class _IDLTypeStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA._IDLTypeStub
  • All Implemented Interfaces:
    Serializable, IDLType, IDLTypeOperations, IRObject, IRObjectOperations, Object, IDLEntity

    public class _IDLTypeStub
extends ObjectImpl
implements IDLType
    The Stub for IDLType. For more information on Stub files, see "Generated Files: Stubs".

    org/omg/CORBA/_IDLTypeStub.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl. 03 June 1999 11:33:44 o'clock GMT+00:00

    • Constructor Summary

      Constructors
      Constructor and Description
      _IDLTypeStub()
      Constructs a default _IDLTypeStub object.
      _IDLTypeStub(Delegate delegate)
      Constructs an _IDLTypeStub object initialized with the given Delegate object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      DefinitionKind def_kind()
      Returns the DefinitionKind corresponding to this Interface Repository object.
      void destroy()
      Destroys this object.
      TypeCode type()
      The type attribute describes the type defined by an object derived from IDLType.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _IDLTypeStub

        public _IDLTypeStub()
        Constructs a default _IDLTypeStub object. NOTE: If the default constructor is used, the object is useless until the method _set_delegate has been called.

      • _IDLTypeStub

        public _IDLTypeStub(Delegate delegate)
        Constructs an _IDLTypeStub object initialized with the given Delegate object.
        Parameters:
        delegate - a Delegate object

    • Method Detail

      • type

        public TypeCode type()
        Description copied from interface: IDLTypeOperations
        The type attribute describes the type defined by an object derived from IDLType.
        Specified by:
        type in interface IDLTypeOperations
        Returns:
        the TypeCode defined by this object.

      • def_kind

        public DefinitionKind def_kind()
        Description copied from interface: IRObjectOperations
        Returns the DefinitionKind corresponding to this Interface Repository object.
        Specified by:
        def_kind in interface IRObjectOperations
        Returns:
        the DefinitionKind corresponding to this Interface Repository object.

      • destroy

        public void destroy()
        Description copied from interface: IRObjectOperations
        Destroys this object. If the object is a Container, this method is applied to all its contents. If the object contains an IDLType attribute for an anonymous type, that IDLType is destroyed. If the object is currently contained in some other object, it is removed. If the method is invoked on a Repository or on a PrimitiveDef then the BAD_INV_ORDER exception is raised with minor value 2. An attempt to destroy an object that would leave the repository in an incoherent state causes BAD_INV_ORDER exception to be raised with the minor code 1.
        Specified by:
        destroy in interface IRObjectOperations

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_PolicyStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA

Class _PolicyStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA._PolicyStub
  • All Implemented Interfaces:
    Serializable, Object, Policy, PolicyOperations, IDLEntity

    public class _PolicyStub
extends ObjectImpl
implements Policy
    The Stub for Policy. For more information on Stub files, see "Generated Files: Stubs".

    org/omg/CORBA/_PolicyStub.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl. Saturday, July 17, 1999 12:26:20 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      _PolicyStub()
      Constructors NOTE: If the default constructor is used, the object is useless until _set_delegate (...) is called.
      _PolicyStub(Delegate delegate)
      Constructs a _PolicyStub object initialized with the given Delegate object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      Policy copy()
      Copies the policy object.
      void destroy()
      Destroys the policy object.
      int policy_type()
      Returns the constant value that corresponds to the type of the policy object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _PolicyStub

        public _PolicyStub()
        Constructors NOTE: If the default constructor is used, the object is useless until _set_delegate (...) is called.

      • _PolicyStub

        public _PolicyStub(Delegate delegate)
        Constructs a _PolicyStub object initialized with the given Delegate object.
        Parameters:
        delegate - a Delegate Object

    • Method Detail

      • policy_type

        public int policy_type()
        Returns the constant value that corresponds to the type of the policy object. The values of the polivy objectys are allocated by the OMG. New values for PolicyType should be obtained from the OMG by sending mail to request@omg.org. In general the constant values that are allocated are defined in conjunction with the definition of the corresponding policy object.
        Specified by:
        policy_type in interface PolicyOperations
        Returns:
        the constant value that corresponds to the type of the policy object.

      • copy

        public Policy copy()
        Copies the policy object. The copy does not retain any relationships that the policy had with any domain or object.
        Specified by:
        copy in interface PolicyOperations
        Returns:
        the copy of the policy object.

      • destroy

        public void destroy()
        Destroys the policy object. It is the responsibility of the policy object to determine whether it can be destroyed.
        Specified by:
        destroy in interface PolicyOperations

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ACTIVITY_COMPLETED (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ACTIVITY_COMPLETED

No usage of org.omg.CORBA.ACTIVITY_COMPLETED
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ACTIVITY_REQUIRED (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ACTIVITY_REQUIRED

No usage of org.omg.CORBA.ACTIVITY_REQUIRED
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.Any (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.Any

  • Packages that use Any
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of Any in org.omg.CORBA

      Fields in org.omg.CORBA declared as Any
      Modifier and Type | Field and Description
      Any UnknownUserException.except
      The Any instance that contains the actual user exception thrown by the server.
      Any UnionMember.label
      The label of the union member described by this UnionMember object.
      Any AnyHolder.value
      The Any value held by this AnyHolder object.
      Any[] | AnySeqHolder.value
      Any NameValuePair.value
      The value to be associated with a name by this NameValuePair object.
      Methods in org.omg.CORBA that return Any
      Modifier and Type | Method and Description
      abstract Any Request.add_in_arg()
      Creates an input argument and adds it to this Request object.
      abstract Any Request.add_inout_arg()
      Adds an input/output argument to this Request object.
      abstract Any Request.add_named_in_arg(String name)
      Creates an input argument with the given name and adds it to this Request object.
      abstract Any Request.add_named_inout_arg(String name)
      Adds an input/output argument with the given name to this Request object.
      abstract Any Request.add_named_out_arg(String name)
      Adds an output argument with the given name to this Request object.
      abstract Any Request.add_out_arg()
      Adds an output argument to this Request object.
      abstract Any ORB.create_any()
      Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
      abstract Any Any.extract_any()
      Extracts the Any object in this Any object's value field.
      static Any[] | AnySeqHelper.extract(Any a)
      Any DynAny.get_any()
      Deprecated.
      Retrieves the org.omg.CORBA.Any contained in this DynAny object.
      Any[] DynArray.get_elements()
      Deprecated.
      Returns the value of all the elements of this array.
      Any[] DynSequence.get_elements()
      Deprecated.
      Returns the value of every element in this sequence.
      abstract Any TypeCode.member_label(int index)
      Retrieves the label of the union member identified by the given index.
      Any DataInputStream.read_any()
      Reads an IDL Any value from the input stream.
      static Any[] | AnySeqHelper.read(InputStream istream)
      abstract Any Request.return_value()
      Returns the Any object that contains the value for the result of the method.
      Any DynAny.to_any()
      Deprecated.
      Convert a DynAny object to an Any object.
      abstract Any NamedValue.value()
      Retrieves the value for this NamedValue object.
      Methods in org.omg.CORBA with parameters of type Any
      Modifier and Type | Method and Description
      abstract NamedValue NVList.add_value(String item_name, Any val, int flags)
      Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
      DynAny ORB.create_dyn_any(Any value)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract NamedValue ORB.create_named_value(String s, Any any, int flags)
      Creates a NamedValue object using the given name, value, and argument mode flags.
      Policy ORB.create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      abstract boolean Any.equal(Any a)
      Checks for equality between this Any object and the given Any object.
      void ServerRequest.except(Any any)
      Deprecated.
      use set_exception()
      static UnknownUserException | UnknownUserExceptionHelper.extract(Any a)
      static double[] | DoubleSeqHelper.extract(Any a)
      static ServiceDetail | ServiceDetailHelper.extract(Any a)
      static ValueMember | ValueMemberHelper.extract(Any a)
      static SetOverrideType | SetOverrideTypeHelper.extract(Any a)
      static String | StringValueHelper.extract(Any a)
      static long[] | LongLongSeqHelper.extract(Any a)
      static String | RepositoryIdHelper.extract(Any a)
      static UnionMember | UnionMemberHelper.extract(Any a)
      static ServiceInformation | ServiceInformationHelper.extract(Any a)
      static String[] | WStringSeqHelper.extract(Any a)
      static StructMember | StructMemberHelper.extract(Any a)
      static char[] | CharSeqHelper.extract(Any a)
      static ParameterMode | ParameterModeHelper.extract(Any a)
      static Object | ObjectHelper.extract(Any a)
      static short[] | ShortSeqHelper.extract(Any a)
      static IDLType | IDLTypeHelper.extract(Any a)
      static short | VisibilityHelper.extract(Any a)
      static int[] | LongSeqHelper.extract(Any a)
      static String | VersionSpecHelper.extract(Any a)
      static byte[] | OctetSeqHelper.extract(Any a)
      static NameValuePair | NameValuePairHelper.extract(Any a)
      static float[] | FloatSeqHelper.extract(Any a)
      static CompletionStatus | CompletionStatusHelper.extract(Any a)
      static Policy[] | PolicyListHelper.extract(Any a)
      static String | IdentifierHelper.extract(Any a)
      static String[] | StringSeqHelper.extract(Any a)
      static DefinitionKind | DefinitionKindHelper.extract(Any a)
      static Policy | PolicyHelper.extract(Any a)
      static String | FieldNameHelper.extract(Any a)
      static int[] | ULongSeqHelper.extract(Any a)
      static long[] | ULongLongSeqHelper.extract(Any a)
      static Current | CurrentHelper.extract(Any a)
      static Any[] | AnySeqHelper.extract(Any a)
      static PolicyError | PolicyErrorHelper.extract(Any a)
      static short | PolicyErrorCodeHelper.extract(Any a)
      static Serializable | ValueBaseHelper.extract(Any a)
      static char[] | WCharSeqHelper.extract(Any a)
      static int | PolicyTypeHelper.extract(Any a)
      static String | WStringValueHelper.extract(Any a)
      static WrongTransaction | WrongTransactionHelper.extract(Any a)
      static boolean[] | BooleanSeqHelper.extract(Any a)
      static short[] | UShortSeqHelper.extract(Any a)
      void DynAny.from_any(Any value)
      Deprecated.
      Make a DynAny object from an Any object.
      abstract void Any.insert_any(Any a)
      Inserts the given Any object into this Any object's value field.
      void DynAny.insert_any(Any value)
      Deprecated.
      Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | BooleanSeqHelper.insert(Any a, boolean[] that)
      static void | OctetSeqHelper.insert(Any a, byte[] that)
      static void | CharSeqHelper.insert(Any a, char[] that)
      static void | WCharSeqHelper.insert(Any a, char[] that)
      static void | CompletionStatusHelper.insert(Any a, CompletionStatus that)
      static void | CurrentHelper.insert(Any a, Current that)
      static void | DefinitionKindHelper.insert(Any a, DefinitionKind that)
      static void | DoubleSeqHelper.insert(Any a, double[] that)
      static void | FloatSeqHelper.insert(Any a, float[] that)
      static void | IDLTypeHelper.insert(Any a, IDLType that)
      static void | PolicyTypeHelper.insert(Any a, int that)
      static void | LongSeqHelper.insert(Any a, int[] that)
      static void | ULongSeqHelper.insert(Any a, int[] that)
      static void | LongLongSeqHelper.insert(Any a, long[] that)
      static void | ULongLongSeqHelper.insert(Any a, long[] that)
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      static void | ObjectHelper.insert(Any a, Object that)
      static void | ParameterModeHelper.insert(Any a, ParameterMode that)
      static void | PolicyHelper.insert(Any a, Policy that)
      static void | PolicyListHelper.insert(Any a, Policy[] that)
      static void | PolicyErrorHelper.insert(Any a, PolicyError that)
      static void | ValueBaseHelper.insert(Any a, Serializable that)
      static void | ServiceDetailHelper.insert(Any a, ServiceDetail that)
      static void | ServiceInformationHelper.insert(Any a, ServiceInformation that)
      static void | SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
      static void | VisibilityHelper.insert(Any a, short that)
      static void | PolicyErrorCodeHelper.insert(Any a, short that)
      static void | ShortSeqHelper.insert(Any a, short[] that)
      static void | UShortSeqHelper.insert(Any a, short[] that)
      static void | StringValueHelper.insert(Any a, String that)
      static void | RepositoryIdHelper.insert(Any a, String that)
      static void | VersionSpecHelper.insert(Any a, String that)
      static void | IdentifierHelper.insert(Any a, String that)
      static void | FieldNameHelper.insert(Any a, String that)
      static void | WStringValueHelper.insert(Any a, String that)
      static void | WStringSeqHelper.insert(Any a, String[] that)
      static void | StringSeqHelper.insert(Any a, String[] that)
      static void | StructMemberHelper.insert(Any a, StructMember that)
      static void | UnionMemberHelper.insert(Any a, UnionMember that)
      static void | UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
      static void | ValueMemberHelper.insert(Any a, ValueMember that)
      static void | WrongTransactionHelper.insert(Any a, WrongTransaction that)
      void ServerRequest.result(Any any)
      Deprecated.
      use the method set_result
      void DynArray.set_elements(Any[] value)
      Deprecated.
      Sets the value of this DynArray object to the given array.
      void DynSequence.set_elements(Any[] value)
      Deprecated.
      Sets the values of all elements in this sequence with the given array.
      void ServerRequest.set_exception(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      abstract void Context.set_one_value(String propname, Any propvalue)
      Creates a NamedValue object and adds it to this Context object.
      void ServerRequest.set_result(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void DataOutputStream.write_any_array(Any[] seq, int offset, int length)
      Writes the array of IDL Anys from offset for length elements to the output stream.
      void DataOutputStream.write_any(Any value)
      Writes the Any value to the output stream.
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      Constructors in org.omg.CORBA with parameters of type Any
      Constructor and Description
      AnyHolder(Any initial)
      Constructs a new AnyHolder object for the given Any object.
      AnySeqHolder(Any[] initialValue)
      NameValuePair(String __id, Any __value)
      Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.
      UnknownUserException(Any a)
      Constructs an UnknownUserException object that contains the given Any object.

    • Uses of Any in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Any
      Modifier and Type Method and Description
      abstract Any InputStream.read_any()
      Reads an Any from this input stream.
      Methods in org.omg.CORBA.portable with parameters of type Any
      Modifier and Type Method and Description
      abstract void OutputStream.write_any(Any value)
      Writes an Any on this output stream.

    • Uses of Any in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type Any
      Modifier and Type | Method and Description
      static BindingType | BindingTypeHelper.extract(Any a)
      static NamingContextExt | NamingContextExtHelper.extract(Any a)
      static NameComponent | NameComponentHelper.extract(Any a)
      static String | IstringHelper.extract(Any a)
      static Binding | BindingHelper.extract(Any a)
      static NameComponent[] | NameHelper.extract(Any a)
      static BindingIterator | BindingIteratorHelper.extract(Any a)
      static Binding[] | BindingListHelper.extract(Any a)
      static NamingContext | NamingContextHelper.extract(Any a)
      static void | BindingHelper.insert(Any a, Binding that)
      static void | BindingListHelper.insert(Any a, Binding[] that)
      static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
      static void | BindingTypeHelper.insert(Any a, BindingType that)
      static void | NameComponentHelper.insert(Any a, NameComponent that)
      static void | NameHelper.insert(Any a, NameComponent[] that)
      static void | NamingContextHelper.insert(Any a, NamingContext that)
      static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
      static void | IstringHelper.insert(Any a, String that)

    • Uses of Any in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type Any
      Modifier and Type | Method and Description
      static String | StringNameHelper.extract(Any a)
      static String | AddressHelper.extract(Any a)
      static InvalidAddress | InvalidAddressHelper.extract(Any a)
      static String | URLStringHelper.extract(Any a)
      static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
      static void | StringNameHelper.insert(Any a, String that)
      static void | AddressHelper.insert(Any a, String that)
      static void | URLStringHelper.insert(Any a, String that)

    • Uses of Any in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type Any
      Modifier and Type | Method and Description
      static NotEmpty | NotEmptyHelper.extract(Any a)
      static NotFound | NotFoundHelper.extract(Any a)
      static NotFoundReason | NotFoundReasonHelper.extract(Any a)
      static AlreadyBound | AlreadyBoundHelper.extract(Any a)
      static CannotProceed | CannotProceedHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.extract(Any a)
      static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
      static void | CannotProceedHelper.insert(Any a, CannotProceed that)
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | NotEmptyHelper.insert(Any a, NotEmpty that)
      static void | NotFoundHelper.insert(Any a, NotFound that)
      static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)

    • Uses of Any in org.omg.Dynamic

      Fields in org.omg.Dynamic declared as Any
      Modifier and Type | Field and Description
      Any | Parameter.argument
      Constructors in org.omg.Dynamic with parameters of type Any
      Constructor and Description
      Parameter(Any _argument, ParameterMode _mode)

    • Uses of Any in org.omg.DynamicAny

      Fields in org.omg.DynamicAny declared as Any
      Modifier and Type Field and Description
      Any NameValuePair.value
      The Any value associated with the name.
      Methods in org.omg.DynamicAny that return Any
      Modifier and Type | Method and Description
      static Any[] | AnySeqHelper.extract(Any a)
      Any _DynFixedStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynAnyStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynArrayStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynStructStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynValueStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynUnionStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynAnyOperations.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynEnumStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynSequenceStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynValueBoxOperations.get_boxed_value()
      Returns the boxed value as an Any.
      Any[] _DynArrayStub.get_elements()
      Returns the elements of the DynArray.
      Any[] DynArrayOperations.get_elements()
      Returns the elements of the DynArray.
      Any[] DynSequenceOperations.get_elements()
      Returns the elements of the sequence.
      Any[] _DynSequenceStub.get_elements()
      Returns the elements of the sequence.
      static Any[] | AnySeqHelper.read(InputStream istream)
      Any _DynFixedStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynAnyStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynArrayStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynStructStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynValueStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynUnionStub.to_any()
      Creates an any value from a DynAny object.
      Any DynAnyOperations.to_any()
      Creates an any value from a DynAny object.
      Any _DynEnumStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynSequenceStub.to_any()
      Creates an any value from a DynAny object.
      Methods in org.omg.DynamicAny with parameters of type Any
      Modifier and Type | Method and Description
      DynAny _DynAnyFactoryStub.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny DynAnyFactoryOperations.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
      static DynArray | DynArrayHelper.extract(Any a)
      static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
      static DynUnion | DynUnionHelper.extract(Any a)
      static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
      static DynValue | DynValueHelper.extract(Any a)
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
      static NameValuePair | NameValuePairHelper.extract(Any a)
      static DynFixed | DynFixedHelper.extract(Any a)
      static String | FieldNameHelper.extract(Any a)
      static DynStruct | DynStructHelper.extract(Any a)
      static DynEnum | DynEnumHelper.extract(Any a)
      static Any[] | AnySeqHelper.extract(Any a)
      static DynSequence | DynSequenceHelper.extract(Any a)
      static DynAny[] | DynAnySeqHelper.extract(Any a)
      static DynAny | DynAnyHelper.extract(Any a)
      void _DynFixedStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynAnyStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynArrayStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynStructStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynValueStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynUnionStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void DynAnyOperations.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynEnumStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynSequenceStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynFixedStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynAnyStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynArrayStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynStructStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynValueStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynUnionStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void DynAnyOperations.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynEnumStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynSequenceStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | DynAnyHelper.insert(Any a, DynAny that)
      static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
      static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
      static void | DynArrayHelper.insert(Any a, DynArray that)
      static void | DynEnumHelper.insert(Any a, DynEnum that)
      static void | DynFixedHelper.insert(Any a, DynFixed that)
      static void | DynSequenceHelper.insert(Any a, DynSequence that)
      static void | DynStructHelper.insert(Any a, DynStruct that)
      static void | DynUnionHelper.insert(Any a, DynUnion that)
      static void | DynValueHelper.insert(Any a, DynValue that)
      static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
      static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
      static void | FieldNameHelper.insert(Any a, String that)
      void DynValueBoxOperations.set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.
      void _DynArrayStub.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynArrayOperations.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements(Any[] value)
      Sets the elements of a sequence.
      void _DynSequenceStub.set_elements(Any[] value)
      Sets the elements of a sequence.
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      Constructors in org.omg.DynamicAny with parameters of type Any
      Constructor and Description
      NameValuePair(String _id, Any _value)

    • Uses of Any in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type Any
      Modifier and Type | Method and Description
      static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
      static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)

    • Uses of Any in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type Any
      Modifier and Type | Method and Description
      static InvalidValue | InvalidValueHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static void | InvalidValueHelper.insert(Any a, InvalidValue that)
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

    • Uses of Any in org.omg.IOP

      Methods in org.omg.IOP that return Any
      Modifier and Type Method and Description
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any CodecOperations.decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.
      Methods in org.omg.IOP with parameters of type Any
      Modifier and Type | Method and Description
      byte[] CodecOperations.encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] CodecOperations.encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
      static TaggedComponent | TaggedComponentHelper.extract(Any a)
      static CodecFactory | CodecFactoryHelper.extract(Any a)
      static ServiceContext | ServiceContextHelper.extract(Any a)
      static int | ProfileIdHelper.extract(Any a)
      static ServiceContext[] | ServiceContextListHelper.extract(Any a)
      static int | ServiceIdHelper.extract(Any a)
      static IOR | IORHelper.extract(Any a)
      static TaggedProfile | TaggedProfileHelper.extract(Any a)
      static int | ComponentIdHelper.extract(Any a)
      static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
      static void | ProfileIdHelper.insert(Any a, int that)
      static void | ServiceIdHelper.insert(Any a, int that)
      static void | ComponentIdHelper.insert(Any a, int that)
      static void | IORHelper.insert(Any a, IOR that)
      static void | ServiceContextHelper.insert(Any a, ServiceContext that)
      static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
      static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
      static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
      static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)

    • Uses of Any in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type Any
      Modifier and Type | Method and Description
      static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
      static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)

    • Uses of Any in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage with parameters of type Any
      Modifier and Type | Method and Description
      static FormatMismatch | FormatMismatchHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
      static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
      static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

    • Uses of Any in org.omg.Messaging

      Methods in org.omg.Messaging with parameters of type Any
      Modifier and Type | Method and Description
      static short | SyncScopeHelper.extract(Any a)
      static void | SyncScopeHelper.insert(Any a, short that)

    • Uses of Any in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Any
      Modifier and Type Method and Description
      Any RequestInfoOperations.get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      Any CurrentOperations.get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      Any ClientRequestInfoOperations.received_exception()
      Returns an any which contains the exception to be returned to the client.
      Any RequestInfoOperations.result()
      Returns an any containing the result of the operation invocation.
      Any ServerRequestInfoOperations.sending_exception()
      Returns an any which contains the exception to be returned to the client.
      Methods in org.omg.PortableInterceptor with parameters of type Any
      Modifier and Type | Method and Description
      Policy PolicyFactoryOperations.create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static short | AdapterStateHelper.extract(Any a)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
      static byte[] | ObjectIdHelper.extract(Any a)
      static String | ORBIdHelper.extract(Any a)
      static InvalidSlot | InvalidSlotHelper.extract(Any a)
      static int | AdapterManagerIdHelper.extract(Any a)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
      static Current | CurrentHelper.extract(Any a)
      static String[] | AdapterNameHelper.extract(Any a)
      static String | ServerIdHelper.extract(Any a)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
      static void | ObjectIdHelper.insert(Any a, byte[] that)
      static void | CurrentHelper.insert(Any a, Current that)
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | AdapterManagerIdHelper.insert(Any a, int that)
      static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
      static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
      static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
      static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
      static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
      static void | AdapterStateHelper.insert(Any a, short that)
      static void | ORBIdHelper.insert(Any a, String that)
      static void | ServerIdHelper.insert(Any a, String that)
      static void | AdapterNameHelper.insert(Any a, String[] that)
      void ServerRequestInfoOperations.set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      void CurrentOperations.set_slot(int id, Any data)
      Sets data in a slot.

    • Uses of Any in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type Any
      Modifier and Type | Method and Description
      static String | ObjectIdHelper.extract(Any a)
      static DuplicateName | DuplicateNameHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.extract(Any a)
      static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | ObjectIdHelper.insert(Any a, String that)

    • Uses of Any in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type Any
      Modifier and Type | Method and Description
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ServantLocator | ServantLocatorHelper.extract(Any a)
      static POA | POAHelper.extract(Any a)
      static ServantActivator | ServantActivatorHelper.extract(Any a)
      static Current | CurrentHelper.extract(Any a)
      static void | CurrentHelper.insert(Any a, Current that)
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | POAHelper.insert(Any a, POA that)
      static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
      static void | ServantLocatorHelper.insert(Any a, ServantLocator that)

    • Uses of Any in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage with parameters of type Any
      Modifier and Type | Method and Description
      static NoContext | NoContextHelper.extract(Any a)
      static void | NoContextHelper.insert(Any a, NoContext that)

    • Uses of Any in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type Any
      Modifier and Type | Method and Description
      static AdapterInactive | AdapterInactiveHelper.extract(Any a)
      static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)

    • Uses of Any in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage with parameters of type Any
      Modifier and Type | Method and Description
      static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
      static WrongPolicy | WrongPolicyHelper.extract(Any a)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
      static ServantNotActive | ServantNotActiveHelper.extract(Any a)
      static NoServant | NoServantHelper.extract(Any a)
      static WrongAdapter | WrongAdapterHelper.extract(Any a)
      static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
      static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
      static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
      static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
      static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
      static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
      static void | NoServantHelper.insert(Any a, NoServant that)
      static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
      static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
      static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
      static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
      static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
      static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.AnyHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.AnyHolder

No usage of org.omg.CORBA.AnyHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.AnySeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.AnySeqHelper

No usage of org.omg.CORBA.AnySeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.AnySeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.AnySeqHolder

  • Packages that use AnySeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of AnySeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type AnySeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_any_array(AnySeqHolder seq, int offset, int length)
      Reads array of IDL Anys from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.ARG_IN (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.ARG_IN

No usage of org.omg.CORBA.ARG_IN
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.ARG_INOUT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.ARG_INOUT

No usage of org.omg.CORBA.ARG_INOUT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.ARG_OUT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.ARG_OUT

No usage of org.omg.CORBA.ARG_OUT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BAD_CONTEXT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BAD_CONTEXT

No usage of org.omg.CORBA.BAD_CONTEXT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BAD_INV_ORDER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BAD_INV_ORDER

  • Packages that use BAD_INV_ORDER
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BAD_INV_ORDER in org.omg.CORBA

      Methods in org.omg.CORBA that throw BAD_INV_ORDER
      Modifier and Type Method and Description
      Streamable Any.extract_Streamable()
      Extracts a Streamable from this Any object's value field.
      void Any.insert_fixed(BigDecimal value, TypeCode type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BAD_OPERATION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BAD_OPERATION

  • Packages that use BAD_OPERATION
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BAD_OPERATION in org.omg.CORBA

      Methods in org.omg.CORBA that throw BAD_OPERATION
      Modifier and Type Method and Description
      abstract Any Any.extract_any()
      Extracts the Any object in this Any object's value field.
      abstract boolean Any.extract_boolean()
      Extracts the boolean in this Any object's value field.
      abstract char Any.extract_char()
      Extracts the char in this Any object's value field.
      abstract double Any.extract_double()
      Extracts the double in this Any object's value field.
      abstract float Any.extract_float()
      Extracts the float in this Any object's value field.
      abstract int Any.extract_long()
      Extracts the int in this Any object's value field.
      abstract long Any.extract_longlong()
      Extracts the long in this Any object's value field.
      abstract Object Any.extract_Object()
      Extracts the org.omg.CORBA.Object in this Any object's value field.
      abstract byte Any.extract_octet()
      Extracts the byte in this Any object's value field.
      Principal Any.extract_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract short Any.extract_short()
      Extracts the short in this Any object's value field.
      abstract String Any.extract_string()
      Extracts the String object in this Any object's value field.
      abstract TypeCode Any.extract_TypeCode()
      Extracts the TypeCode object in this Any object's value field.
      abstract int Any.extract_ulong()
      Extracts the int in this Any object's value field.
      abstract long Any.extract_ulonglong()
      Extracts the long in this Any object's value field.
      abstract short Any.extract_ushort()
      Extracts the short in this Any object's value field.
      abstract Serializable Any.extract_Value()
      Extracts the java.io.Serializable object in this Any object's value field.
      abstract char Any.extract_wchar()
      Extracts the char in this Any object's value field.
      abstract String Any.extract_wstring()
      Extracts the String object in this Any object's value field.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BAD_PARAM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BAD_PARAM

  • Packages that use BAD_PARAM
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

    • Uses of BAD_PARAM in org.omg.CORBA

      Methods in org.omg.CORBA that throw BAD_PARAM
      Modifier and Type Method and Description
      abstract void Any.insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.

    • Uses of BAD_PARAM in org.omg.CORBA_2_3

      Methods in org.omg.CORBA_2_3 that throw BAD_PARAM
      Modifier and Type | Method and Description
      Object | ORB.get_value_def(String repid)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.BAD_POLICY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.BAD_POLICY

No usage of org.omg.CORBA.BAD_POLICY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.BAD_POLICY_TYPE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.BAD_POLICY_TYPE

No usage of org.omg.CORBA.BAD_POLICY_TYPE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.BAD_POLICY_VALUE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.BAD_POLICY_VALUE

No usage of org.omg.CORBA.BAD_POLICY_VALUE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BAD_QOS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BAD_QOS

No usage of org.omg.CORBA.BAD_QOS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BAD_TYPECODE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BAD_TYPECODE

No usage of org.omg.CORBA.BAD_TYPECODE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BooleanHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BooleanHolder

No usage of org.omg.CORBA.BooleanHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BooleanSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BooleanSeqHelper

No usage of org.omg.CORBA.BooleanSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.BooleanSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.BooleanSeqHolder

  • Packages that use BooleanSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BooleanSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type BooleanSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_boolean_array(BooleanSeqHolder seq, int offset, int length)
      Reads array of IDL booleans from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.Bounds (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.Bounds

  • Packages that use Bounds
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Bounds in org.omg.CORBA

      Methods in org.omg.CORBA that throw Bounds
      Modifier and Type Method and Description
      abstract TypeCode ExceptionList.item(int index)
      Returns the TypeCode object at the given index.
      abstract NamedValue NVList.item(int index)
      Retrieves the NamedValue object at the given index.
      abstract String ContextList.item(int index)
      Returns the String object at the given index.
      abstract void ExceptionList.remove(int index)
      Removes the TypeCode object at the given index.
      abstract void NVList.remove(int index)
      Removes the NamedValue object at the given index.
      abstract void ContextList.remove(int index)
      Removes the String object at the given index.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ByteHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ByteHolder

No usage of org.omg.CORBA.ByteHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CharHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CharHolder

No usage of org.omg.CORBA.CharHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CharSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CharSeqHelper

No usage of org.omg.CORBA.CharSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CharSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CharSeqHolder

  • Packages that use CharSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of CharSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type CharSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_char_array(CharSeqHolder seq, int offset, int length)
      Reads array of IDL characters from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CODESET_INCOMPATIBLE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CODESET_INCOMPATIBLE

No usage of org.omg.CORBA.CODESET_INCOMPATIBLE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.COMM_FAILURE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.COMM_FAILURE

No usage of org.omg.CORBA.COMM_FAILURE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CompletionStatus (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CompletionStatus

  • Packages that use CompletionStatus
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of CompletionStatus in org.omg.CORBA

      Fields in org.omg.CORBA declared as CompletionStatus
      Modifier and Type Field and Description
      CompletionStatus SystemException.completed
      The status of the operation that threw this exception.
      static CompletionStatus CompletionStatus.COMPLETED_MAYBE
      An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.
      static CompletionStatus CompletionStatus.COMPLETED_NO
      An instance of CompletionStatus initialized with the constant _COMPLETED_NO.
      static CompletionStatus CompletionStatus.COMPLETED_YES
      An instance of CompletionStatus initialized with the constant _COMPLETED_YES.
      Methods in org.omg.CORBA that return CompletionStatus
      Modifier and Type | Method and Description
      static CompletionStatus | CompletionStatusHelper.extract(Any a)
      static CompletionStatus CompletionStatus.from_int(int i)
      Creates a CompletionStatus object from the given int.
      static CompletionStatus | CompletionStatusHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type CompletionStatus
      Modifier and Type | Method and Description
      static void | CompletionStatusHelper.insert(Any a, CompletionStatus that)
      static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)
      Constructors in org.omg.CORBA with parameters of type CompletionStatus
      Constructor and Description
      ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
      ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.
      ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
      ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.
      BAD_CONTEXT(int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
      BAD_CONTEXT(String s, int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status.
      BAD_INV_ORDER(int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
      BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status.
      BAD_OPERATION(int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified minor code and completion status.
      BAD_OPERATION(String s, int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status.
      BAD_PARAM(int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified minor code and completion status.
      BAD_PARAM(String s, int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status.
      BAD_QOS(int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified minor code and completion status.
      BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified message, minor code, and completion status.
      BAD_TYPECODE(int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
      BAD_TYPECODE(String s, int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status.
      CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
      CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.
      COMM_FAILURE(int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified minor code and completion status.
      COMM_FAILURE(String s, int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status.
      DATA_CONVERSION(int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
      DATA_CONVERSION(String s, int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status.
      FREE_MEM(int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified minor code and completion status.
      FREE_MEM(String s, int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status.
      IMP_LIMIT(int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified minor code and completion status.
      IMP_LIMIT(String s, int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status.
      INITIALIZE(int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified minor code and completion status.
      INITIALIZE(String s, int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status.
      INTERNAL(int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified minor code and completion status.
      INTERNAL(String s, int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified detail message, minor code, and completion status.
      INTF_REPOS(int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified minor code and completion status.
      INTF_REPOS(String s, int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status.
      INV_FLAG(int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified minor code and completion status.
      INV_FLAG(String s, int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status.
      INV_IDENT(int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified minor code and completion status.
      INV_IDENT(String s, int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status.
      INV_OBJREF(int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified minor code and completion status.
      INV_OBJREF(String s, int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status.
      INV_POLICY(int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified minor code and completion status.
      INV_POLICY(String s, int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.
      INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
      INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.
      INVALID_TRANSACTION(int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
      INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status.
      MARSHAL(int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified minor code and completion status.
      MARSHAL(String s, int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified description message, minor code, and completion status.
      NO_IMPLEMENT(int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
      NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.
      NO_MEMORY(int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified minor code and completion status.
      NO_MEMORY(String s, int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.
      NO_PERMISSION(int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified minor code and completion status.
      NO_PERMISSION(String s, int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.
      NO_RESOURCES(int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified minor code and completion status.
      NO_RESOURCES(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.
      NO_RESPONSE(int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified minor code and completion status.
      NO_RESPONSE(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.
      OBJ_ADAPTER(int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
      OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.
      OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
      OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.
      PERSIST_STORE(int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified minor code and completion status.
      PERSIST_STORE(String s, int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.
      REBIND(int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified minor code and completion status.
      REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified message, minor code, and completion status.
      SystemException(String reason, int minor, CompletionStatus completed)
      Constructs a SystemException exception with the specified detail message, minor code, and completion status.
      TIMEOUT(int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified minor code and completion status.
      TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified message, minor code, and completion status.
      TRANSACTION_MODE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
      TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.
      TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
      TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.
      TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
      TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.
      TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
      TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.
      TRANSIENT(int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified minor code and completion status.
      TRANSIENT(String s, int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.
      UNKNOWN(int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified minor code and completion status.
      UNKNOWN(String s, int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CompletionStatusHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CompletionStatusHelper

No usage of org.omg.CORBA.CompletionStatusHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.Context (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.Context

  • Packages that use Context
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Context in org.omg.CORBA

      Methods in org.omg.CORBA that return Context
      Modifier and Type Method and Description
      abstract Context Context.create_child(String child_ctx_name)
      Creates a Context object with the given string as its name and with this Context object set as its parent.
      abstract Context ServerRequest.ctx()
      Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference.
      abstract Context Request.ctx()
      Retrieves the Context object for this request.
      abstract Context ORB.get_default_context()
      Gets the default Context object.
      abstract Context Context.parent()
      Retrieves the parent of this Context object.
      Methods in org.omg.CORBA with parameters of type Context
      Modifier and Type Method and Description
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      abstract void Request.ctx(Context c)
      Sets this request's Context object to the one given.

    • Uses of Context in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Context
      Modifier and Type Method and Description
      Context InputStream.read_Context()
      Reads a CORBA context from the stream.
      Methods in org.omg.CORBA.portable with parameters of type Context
      Modifier and Type Method and Description
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      void OutputStream.write_Context(Context ctx, ContextList contexts)
      Writes a CORBA context on this stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ContextList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ContextList

  • Packages that use ContextList
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ContextList in org.omg.CORBA

      Methods in org.omg.CORBA that return ContextList
      Modifier and Type Method and Description
      abstract ContextList Request.contexts()
      Retrieves the ContextList object for this request.
      abstract ContextList ORB.create_context_list()
      Creates an empty ContextList object.
      Methods in org.omg.CORBA with parameters of type ContextList
      Modifier and Type Method and Description
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.

    • Uses of ContextList in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type ContextList
      Modifier and Type Method and Description
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      void OutputStream.write_Context(Context ctx, ContextList contexts)
      Writes a CORBA context on this stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.CTX_RESTRICT_SCOPE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.CTX_RESTRICT_SCOPE

No usage of org.omg.CORBA.CTX_RESTRICT_SCOPE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.Current (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.Current

  • Packages that use Current
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Current in org.omg.CORBA

      Fields in org.omg.CORBA declared as Current
      Modifier and Type | Field and Description
      Current | CurrentHolder.value
      Methods in org.omg.CORBA that return Current
      Modifier and Type | Method and Description
      static Current | CurrentHelper.extract(Any a)
      Current ORB.get_current()
      Deprecated.
      use resolve_initial_references.
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type Current
      Modifier and Type | Method and Description
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      Constructors in org.omg.CORBA with parameters of type Current
      Constructor and Description
      CurrentHolder(Current initialValue)

    • Uses of Current in org.omg.PortableServer

      Subinterfaces of Current in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  Current
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CurrentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CurrentHelper

No usage of org.omg.CORBA.CurrentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.CurrentHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.CurrentHolder

No usage of org.omg.CORBA.CurrentHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.CurrentOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.CurrentOperations

  • Packages that use CurrentOperations
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CurrentOperations in org.omg.CORBA

      Subinterfaces of CurrentOperations in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  Current
      Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.

    • Uses of CurrentOperations in org.omg.PortableServer

      Subinterfaces of CurrentOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  CurrentOperations
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.CustomMarshal (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.CustomMarshal

  • Packages that use CustomMarshal
    Package Description
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of CustomMarshal in org.omg.CORBA.portable

      Subinterfaces of CustomMarshal in org.omg.CORBA.portable
      Modifier and Type Interface and Description
      interface  CustomValue
      An extension of ValueBase that is implemented by custom value types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DataInputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DataInputStream

  • Packages that use DataInputStream
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DataInputStream in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type DataInputStream
      Modifier and Type Method and Description
      void CustomMarshal.unmarshal(DataInputStream is)
      Unmarshal method has to be implemented by the Customized Marshal class.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DataOutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DataOutputStream

  • Packages that use DataOutputStream
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DataOutputStream in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type DataOutputStream
      Modifier and Type Method and Description
      void CustomMarshal.marshal(DataOutputStream os)
      Marshal method has to be implemented by the Customized Marshal class.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DATA_CONVERSION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DATA_CONVERSION

  • Packages that use DATA_CONVERSION
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DATA_CONVERSION in org.omg.CORBA

      Methods in org.omg.CORBA that throw DATA_CONVERSION
      Modifier and Type Method and Description
      abstract void Any.insert_char(char c)
      Inserts the given char into this Any object's value field.
      abstract void Any.insert_string(String s)
      Inserts the given String object into this Any object's value field.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DefinitionKind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DefinitionKind

  • Packages that use DefinitionKind
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DefinitionKind in org.omg.CORBA

      Fields in org.omg.CORBA declared as DefinitionKind
      Modifier and Type Field and Description
      static DefinitionKind DefinitionKind.dk_AbstractInterface
      The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.
      static DefinitionKind DefinitionKind.dk_Alias
      The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.
      static DefinitionKind DefinitionKind.dk_all
      The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate.
      static DefinitionKind DefinitionKind.dk_Array
      The static instance of DefinitionKind indicating that an Interface Repository object is an Array.
      static DefinitionKind DefinitionKind.dk_Attribute
      The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.
      static DefinitionKind DefinitionKind.dk_Constant
      The static instance of DefinitionKind indicating that an Interface Repository object is a constant.
      static DefinitionKind DefinitionKind.dk_Enum
      The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.
      static DefinitionKind DefinitionKind.dk_Exception
      The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.
      static DefinitionKind DefinitionKind.dk_Fixed
      The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.
      static DefinitionKind DefinitionKind.dk_Interface
      The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.
      static DefinitionKind DefinitionKind.dk_Module
      The static instance of DefinitionKind indicating that an Interface Repository object is a Module.
      static DefinitionKind DefinitionKind.dk_Native
      The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.
      static DefinitionKind DefinitionKind.dk_none
      The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.
      static DefinitionKind DefinitionKind.dk_Operation
      The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.
      static DefinitionKind DefinitionKind.dk_Primitive
      The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.
      static DefinitionKind DefinitionKind.dk_Repository
      The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.
      static DefinitionKind DefinitionKind.dk_Sequence
      The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.
      static DefinitionKind DefinitionKind.dk_String
      The static instance of DefinitionKind indicating that an Interface Repository object is a String.
      static DefinitionKind DefinitionKind.dk_Struct
      The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.
      static DefinitionKind DefinitionKind.dk_Typedef
      The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.
      static DefinitionKind DefinitionKind.dk_Union
      The static instance of DefinitionKind indicating that an Interface Repository object is a Union.
      static DefinitionKind DefinitionKind.dk_Value
      The static instance of DefinitionKind indicating that an Interface Repository object is a Value.
      static DefinitionKind DefinitionKind.dk_ValueBox
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.
      static DefinitionKind DefinitionKind.dk_ValueMember
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.
      static DefinitionKind DefinitionKind.dk_Wstring
      The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.
      Methods in org.omg.CORBA that return DefinitionKind
      Modifier and Type | Method and Description
      DefinitionKind | _IDLTypeStub.def_kind()
      DefinitionKind IRObjectOperations.def_kind()
      Returns the DefinitionKind corresponding to this Interface Repository object.
      static DefinitionKind | DefinitionKindHelper.extract(Any a)
      static DefinitionKind DefinitionKind.from_int(int i)
      Creates a DefinitionKind instance corresponding to the given code .
      static DefinitionKind | DefinitionKindHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type DefinitionKind
      Modifier and Type | Method and Description
      static void | DefinitionKindHelper.insert(Any a, DefinitionKind that)
      static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DefinitionKindHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DefinitionKindHelper

No usage of org.omg.CORBA.DefinitionKindHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DomainManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DomainManager

  • Packages that use DomainManager
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of DomainManager in org.omg.CORBA

      Methods in org.omg.CORBA that return DomainManager
      Modifier and Type Method and Description
      DomainManager[] LocalObject._get_domain_managers()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      DomainManager[] Object._get_domain_managers()
      Retrieves the DomainManagers of this object.

    • Uses of DomainManager in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return DomainManager
      Modifier and Type Method and Description
      DomainManager[] ObjectImpl._get_domain_managers()
      Retrieves a list of the domain managers for this ObjectImpl object.
      DomainManager[] Delegate.get_domain_managers(Object self)
      Retrieves the DomainManagers of this object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DomainManagerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DomainManagerOperations

  • Packages that use DomainManagerOperations
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DomainManagerOperations in org.omg.CORBA

      Subinterfaces of DomainManagerOperations in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  DomainManager
      Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DoubleHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DoubleHolder

No usage of org.omg.CORBA.DoubleHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DoubleSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DoubleSeqHelper

No usage of org.omg.CORBA.DoubleSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DoubleSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DoubleSeqHolder

  • Packages that use DoubleSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DoubleSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type DoubleSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_double_array(DoubleSeqHolder seq, int offset, int length)
      Reads array of IDL doubles from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DynamicImplementation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DynamicImplementation

  • Packages that use DynamicImplementation
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of DynamicImplementation in org.omg.CosNaming

      Subclasses of DynamicImplementation in org.omg.CosNaming
      Modifier and Type | Class and Description
      class  | _BindingIteratorImplBase
      class  | _NamingContextImplBase
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynAny (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynAny

  • Packages that use DynAny
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynAny in org.omg.CORBA

      Subinterfaces of DynAny in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  DynArray
      Deprecated.
      Use the new DynArray instead
      interface  DynEnum
      Deprecated.
      Use the new DynEnum instead
      interface  DynFixed
      Deprecated.
      Use the new DynFixed instead
      interface  DynSequence
      Deprecated.
      Use the new DynSequence instead
      interface  DynStruct
      Deprecated.
      Use the new DynStruct instead
      interface  DynUnion
      Deprecated.
      Use the new DynUnion instead
      interface  DynValue
      Deprecated.
      Use the new DynValue instead
      Methods in org.omg.CORBA that return DynAny
      Modifier and Type Method and Description
      DynAny DynAny.copy()
      Deprecated.
      Clones this DynAny object.
      DynAny ORB.create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynAny ORB.create_dyn_any(Any value)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynAny DynAny.current_component()
      Deprecated.
      Returns a DynAny object reference that can be used to get/set the value of the component currently accessed.
      DynAny DynUnion.discriminator()
      Deprecated.
      Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
      DynAny DynUnion.member()
      Deprecated.
      Returns a DynAny object reference that is used in order to insert/get a member of this union.
      Methods in org.omg.CORBA with parameters of type DynAny
      Modifier and Type Method and Description
      void DynAny.assign(DynAny dyn_any)
      Deprecated.
      Copy the contents from one Dynamic Any into another.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynArray (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynArray

  • Packages that use DynArray
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynArray in org.omg.CORBA

      Methods in org.omg.CORBA that return DynArray
      Modifier and Type Method and Description
      DynArray ORB.create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynEnum (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynEnum

  • Packages that use DynEnum
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynEnum in org.omg.CORBA

      Methods in org.omg.CORBA that return DynEnum
      Modifier and Type Method and Description
      DynEnum ORB.create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynFixed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynFixed

No usage of org.omg.CORBA.DynFixed
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynSequence (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynSequence

  • Packages that use DynSequence
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynSequence in org.omg.CORBA

      Methods in org.omg.CORBA that return DynSequence
      Modifier and Type Method and Description
      DynSequence ORB.create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynStruct (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynStruct

  • Packages that use DynStruct
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynStruct in org.omg.CORBA

      Methods in org.omg.CORBA that return DynStruct
      Modifier and Type Method and Description
      DynStruct ORB.create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynUnion (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynUnion

  • Packages that use DynUnion
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynUnion in org.omg.CORBA

      Methods in org.omg.CORBA that return DynUnion
      Modifier and Type Method and Description
      DynUnion ORB.create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.DynValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.DynValue

No usage of org.omg.CORBA.DynValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.Environment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.Environment

  • Packages that use Environment
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Environment in org.omg.CORBA

      Methods in org.omg.CORBA that return Environment
      Modifier and Type Method and Description
      abstract Environment ORB.create_environment()
      Creates an Environment object.
      abstract Environment Request.env()
      Retrieves the Environment object for this request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ExceptionList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ExceptionList

  • Packages that use ExceptionList
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ExceptionList in org.omg.CORBA

      Methods in org.omg.CORBA that return ExceptionList
      Modifier and Type Method and Description
      abstract ExceptionList ORB.create_exception_list()
      Creates an empty ExceptionList object.
      abstract ExceptionList Request.exceptions()
      Retrieves the ExceptionList object for this request.
      Methods in org.omg.CORBA with parameters of type ExceptionList
      Modifier and Type Method and Description
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.

    • Uses of ExceptionList in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type ExceptionList
      Modifier and Type Method and Description
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.FieldNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.FieldNameHelper

No usage of org.omg.CORBA.FieldNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.FixedHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.FixedHolder

No usage of org.omg.CORBA.FixedHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.FloatHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.FloatHolder

No usage of org.omg.CORBA.FloatHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.FloatSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.FloatSeqHelper

No usage of org.omg.CORBA.FloatSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.FloatSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.FloatSeqHolder

  • Packages that use FloatSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of FloatSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type FloatSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_float_array(FloatSeqHolder seq, int offset, int length)
      Reads array of IDL floats from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.FREE_MEM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.FREE_MEM

No usage of org.omg.CORBA.FREE_MEM
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.IdentifierHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.IdentifierHelper

No usage of org.omg.CORBA.IdentifierHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.IDLType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.IDLType

  • Packages that use IDLType
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IDLType in org.omg.CORBA

      Classes in org.omg.CORBA that implement IDLType
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
      Fields in org.omg.CORBA declared as IDLType
      Modifier and Type Field and Description
      IDLType UnionMember.type_def
      The typedef that represents the IDL type of the union member described by this UnionMember object.
      IDLType StructMember.type_def
      The typedef that represents the IDL type of the struct member described by this StructMember object.
      IDLType ValueMember.type_def
      The typedef that represents the IDL type of the value member described by this ValueMember object.
      Methods in org.omg.CORBA that return IDLType
      Modifier and Type | Method and Description
      static IDLType | IDLTypeHelper.extract(Any a)
      static IDLType | IDLTypeHelper.narrow(Object obj)
      static IDLType | IDLTypeHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type IDLType
      Modifier and Type | Method and Description
      static void | IDLTypeHelper.insert(Any a, IDLType that)
      static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)
      Constructors in org.omg.CORBA with parameters of type IDLType
      Constructor and Description
      StructMember(String __name, TypeCode __type, IDLType __type_def)
      Constructs a StructMember object initialized with the given values.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.
      ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
      Constructs a ValueMember object initialized with the given values.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.IDLTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.IDLTypeHelper

No usage of org.omg.CORBA.IDLTypeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.IDLTypeOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.IDLTypeOperations

  • Packages that use IDLTypeOperations
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IDLTypeOperations in org.omg.CORBA

      Subinterfaces of IDLTypeOperations in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      Classes in org.omg.CORBA that implement IDLTypeOperations
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.IMP_LIMIT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.IMP_LIMIT

No usage of org.omg.CORBA.IMP_LIMIT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INITIALIZE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INITIALIZE

No usage of org.omg.CORBA.INITIALIZE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INTERNAL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INTERNAL

No usage of org.omg.CORBA.INTERNAL
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INTF_REPOS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INTF_REPOS

No usage of org.omg.CORBA.INTF_REPOS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.IntHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.IntHolder

No usage of org.omg.CORBA.IntHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INVALID_ACTIVITY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INVALID_ACTIVITY

No usage of org.omg.CORBA.INVALID_ACTIVITY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INVALID_TRANSACTION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INVALID_TRANSACTION

No usage of org.omg.CORBA.INVALID_TRANSACTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INV_FLAG (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INV_FLAG

No usage of org.omg.CORBA.INV_FLAG
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INV_IDENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INV_IDENT

No usage of org.omg.CORBA.INV_IDENT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INV_OBJREF (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INV_OBJREF

No usage of org.omg.CORBA.INV_OBJREF
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.INV_POLICY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.INV_POLICY

No usage of org.omg.CORBA.INV_POLICY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.IRObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.IRObject

  • Packages that use IRObject
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IRObject in org.omg.CORBA

      Subinterfaces of IRObject in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      Classes in org.omg.CORBA that implement IRObject
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.IRObjectOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.IRObjectOperations

  • Packages that use IRObjectOperations
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IRObjectOperations in org.omg.CORBA

      Subinterfaces of IRObjectOperations in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      interface  IDLTypeOperations
      This interface must be implemented by all IDLType objects.
      interface  IRObject
      An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
      Classes in org.omg.CORBA that implement IRObjectOperations
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.LocalObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.LocalObject

No usage of org.omg.CORBA.LocalObject
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.LongHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.LongHolder

No usage of org.omg.CORBA.LongHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.LongLongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.LongLongSeqHelper

No usage of org.omg.CORBA.LongLongSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.LongLongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.LongLongSeqHolder

  • Packages that use LongLongSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of LongLongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type LongLongSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_longlong_array(LongLongSeqHolder seq, int offset, int length)
      Reads array of IDL long longs from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.LongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.LongSeqHelper

No usage of org.omg.CORBA.LongSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.LongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.LongSeqHolder

  • Packages that use LongSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of LongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type LongSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_long_array(LongSeqHolder seq, int offset, int length)
      Reads array of IDL longs from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.MARSHAL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.MARSHAL

  • Packages that use MARSHAL
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of MARSHAL in org.omg.CORBA

      Methods in org.omg.CORBA that throw MARSHAL
      Modifier and Type Method and Description
      abstract void Any.insert_string(String s)
      Inserts the given String object into this Any object's value field.
      abstract void Any.insert_Value(Serializable v, TypeCode t)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void Any.insert_wstring(String s)
      Inserts the given String object into this Any object's value field.
      abstract void Any.read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NamedValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NamedValue

  • Packages that use NamedValue
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of NamedValue in org.omg.CORBA

      Methods in org.omg.CORBA that return NamedValue
      Modifier and Type Method and Description
      abstract NamedValue NVList.add_item(String item_name, int flags)
      Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object.
      abstract NamedValue NVList.add_value(String item_name, Any val, int flags)
      Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
      abstract NamedValue NVList.add(int flags)
      Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object.
      abstract NamedValue ORB.create_named_value(String s, Any any, int flags)
      Creates a NamedValue object using the given name, value, and argument mode flags.
      abstract NamedValue NVList.item(int index)
      Retrieves the NamedValue object at the given index.
      abstract NamedValue Request.result()
      Retrieves the NamedValue object containing the return value for the method.
      Methods in org.omg.CORBA with parameters of type NamedValue
      Modifier and Type Method and Description
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.

    • Uses of NamedValue in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type NamedValue
      Modifier and Type Method and Description
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NameValuePair (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NameValuePair

  • Packages that use NameValuePair
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of NameValuePair in org.omg.CORBA

      Methods in org.omg.CORBA that return NameValuePair
      Modifier and Type | Method and Description
      static NameValuePair | NameValuePairHelper.extract(Any a)
      NameValuePair[] DynStruct.get_members()
      Deprecated.
      Returns an array containing all the members of the stored struct.
      NameValuePair[] DynValue.get_members()
      Deprecated.
      Returns an array containing all the members of the value object stored in this DynValue.
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type NameValuePair
      Modifier and Type | Method and Description
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      void DynStruct.set_members(NameValuePair[] value)
      Deprecated.
      Set the members of the struct.
      void DynValue.set_members(NameValuePair[] value)
      Deprecated.
      Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NameValuePairHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NameValuePairHelper

No usage of org.omg.CORBA.NameValuePairHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NO_IMPLEMENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NO_IMPLEMENT

No usage of org.omg.CORBA.NO_IMPLEMENT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NO_MEMORY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NO_MEMORY

No usage of org.omg.CORBA.NO_MEMORY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NO_PERMISSION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NO_PERMISSION

No usage of org.omg.CORBA.NO_PERMISSION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NO_RESOURCES (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NO_RESOURCES

No usage of org.omg.CORBA.NO_RESOURCES
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NO_RESPONSE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NO_RESPONSE

No usage of org.omg.CORBA.NO_RESPONSE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.NVList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.NVList

  • Packages that use NVList
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of NVList in org.omg.CORBA

      Methods in org.omg.CORBA that return NVList
      Modifier and Type Method and Description
      abstract NVList Request.arguments()
      Retrieves the NVList object containing the arguments to the method being invoked.
      abstract NVList ORB.create_list(int count)
      Allocates an NVList with (probably) enough space for the specified number of NamedValue objects.
      NVList ORB.create_operation_list(Object oper)
      Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
      abstract NVList Context.get_values(String start_scope, int op_flags, String pattern)
      Retrieves the NamedValue objects whose name field matches the given name or name pattern.
      Methods in org.omg.CORBA with parameters of type NVList
      Modifier and Type Method and Description
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      void ServerRequest.arguments(NVList args)
      Specifies method parameter types and retrieves "in" and "inout" argument values.
      void ServerRequest.params(NVList params)
      Deprecated.
      use the method arguments
      abstract void Context.set_values(NVList values)
      I Sets one or more property values in this Context object.

    • Uses of NVList in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type NVList
      Modifier and Type Method and Description
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.Object (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.Object

  • Packages that use Object
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of Object in javax.rmi.CORBA

      Classes in javax.rmi.CORBA that implement Object
      Modifier and Type Class and Description
      class  Stub
      Base class from which all RMI-IIOP stubs must inherit.
      Methods in javax.rmi.CORBA that return Object
      Modifier and Type Method and Description
      Object Tie.thisObject()
      Returns an object reference for the target object represented by this tie.

    • Uses of Object in org.omg.CORBA

      Subinterfaces of Object in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  Current
      Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
      interface  DomainManager
      Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
      interface  DynAny
      Deprecated.
      Use the new DynAny instead
      interface  DynArray
      Deprecated.
      Use the new DynArray instead
      interface  DynEnum
      Deprecated.
      Use the new DynEnum instead
      interface  DynFixed
      Deprecated.
      Use the new DynFixed instead
      interface  DynSequence
      Deprecated.
      Use the new DynSequence instead
      interface  DynStruct
      Deprecated.
      Use the new DynStruct instead
      interface  DynUnion
      Deprecated.
      Use the new DynUnion instead
      interface  DynValue
      Deprecated.
      Use the new DynValue instead
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      interface  IRObject
      An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
      interface  Policy
      Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
      Classes in org.omg.CORBA that implement Object
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
      class  _PolicyStub
      The Stub for Policy.
      class  DynamicImplementation
      Deprecated.
      org.omg.CORBA.DynamicImplementation
      class  LocalObject
      Used as a base class for implementation of a local IDL interface in the Java language mapping.
      Fields in org.omg.CORBA declared as Object
      Modifier and Type Field and Description
      Object ObjectHolder.value
      The Object value held by this ObjectHolder object.
      Methods in org.omg.CORBA that return Object
      Modifier and Type | Method and Description
      Object LocalObject._duplicate()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object Object._duplicate()
      Returns a duplicate of this CORBA object reference.
      Object LocalObject._get_interface_def()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object Object._get_interface_def()
      Obtains an InterfaceDef for the object implementation referenced by this object reference.
      Object LocalObject._get_interface()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
      abstract Object Any.extract_Object()
      Extracts the org.omg.CORBA.Object in this Any object's value field.
      static Object | ObjectHelper.extract(Any a)
      Object DynAny.get_reference()
      Deprecated.
      Retrieves the org.omg.CORBA.Other contained in this DynAny object.
      Object DataInputStream.read_Object()
      Reads an IDL CORBA::Object from the input stream.
      static Object | ObjectHelper.read(InputStream istream)
      abstract Object ORB.resolve_initial_references(String object_name)
      Resolves a specific object reference from the set of available initial service names.
      abstract Object ORB.string_to_object(String str)
      Converts a string produced by the method object_to_string back to a CORBA object reference.
      abstract Object Request.target()
      Retrieves the the target object reference.
      Methods in org.omg.CORBA with parameters of type Object
      Modifier and Type | Method and Description
      boolean LocalObject._is_equivalent(Object that)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      boolean Object._is_equivalent(Object other)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      void ORB.connect(Object obj)
      Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB.
      NVList ORB.create_operation_list(Object oper)
      Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
      void ORB.disconnect(Object obj)
      Disconnects the given servant object from the ORB.
      abstract void Any.insert_Object(Object o)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      abstract void Any.insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      void DynAny.insert_reference(Object value)
      Deprecated.
      Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
      static void | ObjectHelper.insert(Any a, Object that)
      static IDLType | IDLTypeHelper.narrow(Object obj)
      static Policy | PolicyHelper.narrow(Object obj)
      static Current | CurrentHelper.narrow(Object obj)
      abstract String ORB.object_to_string(Object obj)
      Converts the given CORBA object reference to a string.
      void DataOutputStream.write_Object(Object value)
      Writes the IDL CORBA::Object value to the output stream.
      static void | ObjectHelper.write(OutputStream ostream, Object value)
      Constructors in org.omg.CORBA with parameters of type Object
      Constructor and Description
      ObjectHolder(Object initial)
      Constructs a new ObjectHolder object with its value field initialized to the given Object.

    • Uses of Object in org.omg.CORBA_2_3

      Methods in org.omg.CORBA_2_3 that return Object
      Modifier and Type | Method and Description
      Object | ORB.get_value_def(String repid)

    • Uses of Object in org.omg.CORBA_2_3.portable

      Methods in org.omg.CORBA_2_3.portable with parameters of type Object
      Modifier and Type Method and Description
      String Delegate.get_codebase(Object self)
      Returns the codebase for object reference provided.

    • Uses of Object in org.omg.CORBA.portable

      Classes in org.omg.CORBA.portable that implement Object
      Modifier and Type Class and Description
      class  ObjectImpl
      The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
      Methods in org.omg.CORBA.portable that return Object
      Modifier and Type Method and Description
      Object ObjectImpl._duplicate()
      Returns a duplicate of this ObjectImpl object.
      Object ObjectImpl._get_interface_def()
      Retrieves the interface definition for this ObjectImpl object.
      Object ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      abstract Object Delegate.duplicate(Object obj)
      Returns a duplicate of the object reference provided.
      abstract Object Delegate.get_interface_def(Object self)
      Return an InterfaceDef for the object reference provided.
      abstract Object InputStream.read_Object()
      Reads a CORBA object from this input stream.
      Object InputStream.read_Object(Class clz)
      Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
      Methods in org.omg.CORBA.portable with parameters of type Object
      Modifier and Type Method and Description
      boolean ObjectImpl._is_equivalent(Object that)
      Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Object Delegate.duplicate(Object obj)
      Returns a duplicate of the object reference provided.
      boolean Delegate.equals(Object self, Object obj)
      Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
      DomainManager[] Delegate.get_domain_managers(Object self)
      Retrieves the DomainManagers of this object.
      abstract Object Delegate.get_interface_def(Object self)
      Return an InterfaceDef for the object reference provided.
      Policy Delegate.get_policy(Object self, int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      abstract int Delegate.hash(Object obj, int max)
      Returns an ORB-internal identifier (hashcode) for this object reference.
      int Delegate.hashCode(Object self)
      Provides the implementation to override the hashCode() method of the delegating CORBA object.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      abstract boolean Delegate.is_a(Object obj, String repository_id)
      Checks if the object reference is an instance of the given interface.
      abstract boolean Delegate.is_equivalent(Object obj, Object other)
      Determines if the two object references are equivalent.
      boolean Delegate.is_local(Object self)
      Returns true if this object is implemented by a local servant.
      abstract boolean Delegate.non_existent(Object obj)
      Determines whether the server object for the object reference has been destroyed.
      ORB Delegate.orb(Object obj)
      Provides a reference to the orb associated with its parameter.
      abstract void Delegate.release(Object obj)
      Releases resources associated with the object reference provided.
      void Delegate.releaseReply(Object self, InputStream input)
      releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
      abstract Request Delegate.request(Object obj, String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      OutputStream Delegate.request(Object self, String operation, boolean responseExpected)
      request is called by a stub to obtain an OutputStream for marshaling arguments.
      void Delegate.servant_postinvoke(Object self, ServantObject servant)
      servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
      ServantObject Delegate.servant_preinvoke(Object self, String operation, Class expectedType)
      Returns a Java reference to the servant which should be used for this request.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
      String Delegate.toString(Object self)
      Provides the implementation to override the toString() method of the delegating CORBA object.
      abstract void OutputStream.write_Object(Object value)
      Writes a CORBA Object on this output stream.

    • Uses of Object in org.omg.CosNaming

      Subinterfaces of Object in org.omg.CosNaming
      Modifier and Type Interface and Description
      interface  BindingIterator
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      interface  NamingContext
      A naming context is an object that contains a set of name bindings in which each name is unique.
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement Object
      Modifier and Type | Class and Description
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      Methods in org.omg.CosNaming that return Object
      Modifier and Type Method and Description
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Methods in org.omg.CosNaming with parameters of type Object
      Modifier and Type | Method and Description
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
      static BindingIterator | BindingIteratorHelper.narrow(Object obj)
      static NamingContext | NamingContextHelper.narrow(Object obj)
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)
      static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)
      static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)

    • Uses of Object in org.omg.DynamicAny

      Subinterfaces of Object in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynAnyFactory
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      Classes in org.omg.DynamicAny that implement Object
      Modifier and Type Class and Description
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      Methods in org.omg.DynamicAny that return Object
      Modifier and Type Method and Description
      Object _DynFixedStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynAnyStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynArrayStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynStructStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynValueStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynUnionStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object DynAnyOperations.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynEnumStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynSequenceStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Methods in org.omg.DynamicAny with parameters of type Object
      Modifier and Type | Method and Description
      void _DynFixedStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynAnyStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynArrayStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynStructStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynValueStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynUnionStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void DynAnyOperations.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynEnumStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynSequenceStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      static DynArray | DynArrayHelper.narrow(Object obj)
      static DynUnion | DynUnionHelper.narrow(Object obj)
      static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
      static DynValue | DynValueHelper.narrow(Object obj)
      static DynFixed | DynFixedHelper.narrow(Object obj)
      static DynStruct | DynStructHelper.narrow(Object obj)
      static DynEnum | DynEnumHelper.narrow(Object obj)
      static DynSequence | DynSequenceHelper.narrow(Object obj)
      static DynAny | DynAnyHelper.narrow(Object obj)
      static DynArray | DynArrayHelper.unchecked_narrow(Object obj)
      static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)
      static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)
      static DynValue | DynValueHelper.unchecked_narrow(Object obj)
      static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)
      static DynStruct | DynStructHelper.unchecked_narrow(Object obj)
      static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)
      static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)
      static DynAny | DynAnyHelper.unchecked_narrow(Object obj)

    • Uses of Object in org.omg.IOP

      Subinterfaces of Object in org.omg.IOP
      Modifier and Type Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
      Methods in org.omg.IOP with parameters of type Object
      Modifier and Type | Method and Description
      static CodecFactory | CodecFactoryHelper.narrow(Object obj)
      static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)

    • Uses of Object in org.omg.PortableInterceptor

      Subinterfaces of Object in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      Fields in org.omg.PortableInterceptor declared as Object
      Modifier and Type Field and Description
      Object ForwardRequest.forward
      The new object to forward the request to.
      Methods in org.omg.PortableInterceptor that return Object
      Modifier and Type Method and Description
      Object ClientRequestInfoOperations.effective_target()
      Returns the actual object on which the operation will be invoked.
      Object RequestInfoOperations.forward_reference()
      Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
      Object ObjectReferenceFactory.make_object(String repositoryId, byte[] object_id)
      make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
      Object ORBInitInfoOperations.resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.
      Object ClientRequestInfoOperations.target()
      Returns the object which the client called to perform the operation.
      Methods in org.omg.PortableInterceptor with parameters of type Object
      Modifier and Type | Method and Description
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
      static Current | CurrentHelper.narrow(Object obj)
      void ORBInitInfoOperations.register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)
      static Current | CurrentHelper.unchecked_narrow(Object obj)
      Constructors in org.omg.PortableInterceptor with parameters of type Object
      Constructor and Description
      ForwardRequest(Object _forward)
      ForwardRequest(String $reason, Object _forward)

    • Uses of Object in org.omg.PortableServer

      Subinterfaces of Object in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  POA
      A POA object manages the implementation of a collection of objects.
      interface  POAManager
      Each POA object has an associated POAManager object.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      Classes in org.omg.PortableServer that implement Object
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Fields in org.omg.PortableServer declared as Object
      Modifier and Type | Field and Description
      Object | ForwardRequest.forward_reference
      Methods in org.omg.PortableServer that return Object
      Modifier and Type Method and Description
      Object Servant._get_interface_def()
      Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
      Object Servant._this_object()
      Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
      Object Servant._this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
      Object POAOperations.create_reference_with_id(byte[] oid, String intf)
      This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
      Object POAOperations.create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      Methods in org.omg.PortableServer with parameters of type Object
      Modifier and Type | Method and Description
      static ServantLocator | ServantLocatorHelper.narrow(Object obj)
      static POA | POAHelper.narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.narrow(Object obj)
      static Current | CurrentHelper.narrow(Object obj)
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
      Constructors in org.omg.PortableServer with parameters of type Object
      Constructor and Description
      ForwardRequest(Object _forward_reference)
      ForwardRequest(String $reason, Object _forward_reference)

    • Uses of Object in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return Object
      Modifier and Type Method and Description
      Object Delegate.get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      Object Delegate.this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

    • Uses of Object in org.omg.SendingContext

      Subinterfaces of Object in org.omg.SendingContext
      Modifier and Type Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.

    • Uses of Object in org.omg.stub.java.rmi

      Classes in org.omg.stub.java.rmi that implement Object
      Modifier and Type Class and Description
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ObjectHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ObjectHelper

No usage of org.omg.CORBA.ObjectHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ObjectHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ObjectHolder

No usage of org.omg.CORBA.ObjectHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.OBJECT_NOT_EXIST (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.OBJECT_NOT_EXIST

No usage of org.omg.CORBA.OBJECT_NOT_EXIST
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.OBJ_ADAPTER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.OBJ_ADAPTER

No usage of org.omg.CORBA.OBJ_ADAPTER
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.OctetSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.OctetSeqHelper

No usage of org.omg.CORBA.OctetSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.OctetSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.OctetSeqHolder

  • Packages that use OctetSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of OctetSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type OctetSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_octet_array(OctetSeqHolder seq, int offset, int length)
      Reads array of IDL octets from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.OMGVMCID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.OMGVMCID

No usage of org.omg.CORBA.OMGVMCID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ORB (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ORB

  • Packages that use ORB
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ORB in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return ORB
      Modifier and Type Method and Description
      ORB Tie.orb()
      Returns the ORB for this tie.
      Methods in javax.rmi.CORBA with parameters of type ORB
      Modifier and Type Method and Description
      void Stub.connect(ORB orb)
      Connects this stub to an ORB.
      void StubDelegate.connect(Stub self, ORB orb)
      Delegation call for Stub.connect(org.omg.CORBA.ORB).
      static Object Util.copyObject(Object obj, ORB orb)
      Copies or connects an object.
      Object UtilDelegate.copyObject(Object obj, ORB orb)
      Delegation call for Util.copyObject(java.lang.Object, org.omg.CORBA.ORB).
      static Object[] Util.copyObjects(Object[] obj, ORB orb)
      Copies or connects an array of objects.
      Object[] UtilDelegate.copyObjects(Object[] obj, ORB orb)
      Delegation call for Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB).
      void Tie.orb(ORB orb)
      Sets the ORB for this tie.

    • Uses of ORB in org.omg.CORBA

      Methods in org.omg.CORBA that return ORB
      Modifier and Type Method and Description
      ORB LocalObject._orb()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      static ORB ORB.init()
      Returns the ORB singleton object.
      static ORB ORB.init(Applet app, Properties props)
      Creates a new ORB instance for an applet.
      static ORB ORB.init(String[] args, Properties props)
      Creates a new ORB instance for a standalone application.

    • Uses of ORB in org.omg.CORBA_2_3

      Subclasses of ORB in org.omg.CORBA_2_3
      Modifier and Type Class and Description
      class  ORB
      A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

    • Uses of ORB in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return ORB
      Modifier and Type Method and Description
      ORB ObjectImpl._orb()
      Returns a reference to the ORB associated with this object and its delegate.
      ORB InputStream.orb()
      Returns the ORB that created this InputStream.
      ORB OutputStream.orb()
      Returns the ORB that created this OutputStream.
      ORB Delegate.orb(Object obj)
      Provides a reference to the orb associated with its parameter.

    • Uses of ORB in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type ORB
      Modifier and Type | Method and Description
      BindingIterator | BindingIteratorPOA._this(ORB orb)
      NamingContext | NamingContextPOA._this(ORB orb)
      NamingContextExt | NamingContextExtPOA._this(ORB orb)

    • Uses of ORB in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ORB
      Modifier and Type Method and Description
      ORB Servant._orb()
      Returns the instance of the ORB currently associated with the Servant (convenience method).
      Methods in org.omg.PortableServer with parameters of type ORB
      Modifier and Type | Method and Description
      Object Servant._this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
      ServantActivator | ServantActivatorPOA._this(ORB orb)
      ServantLocator | ServantLocatorPOA._this(ORB orb)

    • Uses of ORB in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return ORB
      Modifier and Type Method and Description
      ORB Delegate.orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ParameterMode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ParameterMode

  • Packages that use ParameterMode
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.

    • Uses of ParameterMode in org.omg.CORBA

      Fields in org.omg.CORBA declared as ParameterMode
      Modifier and Type | Field and Description
      static ParameterMode | ParameterMode.PARAM_IN
      static ParameterMode | ParameterMode.PARAM_INOUT
      static ParameterMode | ParameterMode.PARAM_OUT
      ParameterMode | ParameterModeHolder.value
      Methods in org.omg.CORBA that return ParameterMode
      Modifier and Type | Method and Description
      static ParameterMode | ParameterModeHelper.extract(Any a)
      static ParameterMode | ParameterMode.from_int(int value)
      static ParameterMode | ParameterModeHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type ParameterMode
      Modifier and Type | Method and Description
      static void | ParameterModeHelper.insert(Any a, ParameterMode that)
      static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)
      Constructors in org.omg.CORBA with parameters of type ParameterMode
      Constructor and Description
      ParameterModeHolder(ParameterMode initialValue)

    • Uses of ParameterMode in org.omg.Dynamic

      Fields in org.omg.Dynamic declared as ParameterMode
      Modifier and Type | Field and Description
      ParameterMode | Parameter.mode
      Constructors in org.omg.Dynamic with parameters of type ParameterMode
      Constructor and Description
      Parameter(Any _argument, ParameterMode _mode)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ParameterModeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ParameterModeHelper

No usage of org.omg.CORBA.ParameterModeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ParameterModeHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ParameterModeHolder

No usage of org.omg.CORBA.ParameterModeHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PERSIST_STORE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PERSIST_STORE

No usage of org.omg.CORBA.PERSIST_STORE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.Policy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.Policy

  • Packages that use Policy
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Policy in org.omg.CORBA

      Classes in org.omg.CORBA that implement Policy
      Modifier and Type Class and Description
      class  _PolicyStub
      The Stub for Policy.
      Fields in org.omg.CORBA declared as Policy
      Modifier and Type | Field and Description
      Policy[] | PolicyListHolder.value
      Policy | PolicyHolder.value
      Methods in org.omg.CORBA that return Policy
      Modifier and Type | Method and Description
      Policy LocalObject._get_policy(int policy_type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Policy Object._get_policy(int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      Policy _PolicyStub.copy()
      Copies the policy object.
      Policy PolicyOperations.copy()
      Returns a copy of the Policy object.
      Policy ORB.create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      static Policy[] | PolicyListHelper.extract(Any a)
      static Policy | PolicyHelper.extract(Any a)
      Policy DomainManagerOperations.get_domain_policy(int policy_type)
      This returns the policy of the specified type for objects in this domain.
      static Policy | PolicyHelper.narrow(Object obj)
      static Policy[] | PolicyListHelper.read(InputStream istream)
      static Policy | PolicyHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type Policy
      Modifier and Type | Method and Description
      Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
      static void | PolicyHelper.insert(Any a, Policy that)
      static void | PolicyListHelper.insert(Any a, Policy[] that)
      static void | PolicyHelper.write(OutputStream ostream, Policy value)
      static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)
      Constructors in org.omg.CORBA with parameters of type Policy
      Constructor and Description
      PolicyHolder(Policy initialValue)
      PolicyListHolder(Policy[] initialValue)

    • Uses of Policy in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Policy
      Modifier and Type Method and Description
      Policy ObjectImpl._get_policy(int policy_type)
      Retrieves the Policy object for this ObjectImpl object that has the given policy type.
      Policy Delegate.get_policy(Object self, int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      Methods in org.omg.CORBA.portable with parameters of type Policy
      Modifier and Type Method and Description
      Object ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.

    • Uses of Policy in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Policy
      Modifier and Type Method and Description
      Policy PolicyFactoryOperations.create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
      Policy IORInfoOperations.get_effective_policy(int type)
      Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.
      Policy ClientRequestInfoOperations.get_request_policy(int type)
      Returns the given policy in effect for this operation.
      Policy ServerRequestInfoOperations.get_server_policy(int type)
      Returns the policy in effect for this operation for the given policy type.

    • Uses of Policy in org.omg.PortableServer

      Subinterfaces of Policy in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      Methods in org.omg.PortableServer with parameters of type Policy
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyError

  • Packages that use PolicyError
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyError in org.omg.CORBA

      Fields in org.omg.CORBA declared as PolicyError
      Modifier and Type | Field and Description
      PolicyError | PolicyErrorHolder.value
      Methods in org.omg.CORBA that return PolicyError
      Modifier and Type | Method and Description
      static PolicyError | PolicyErrorHelper.extract(Any a)
      static PolicyError | PolicyErrorHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type PolicyError
      Modifier and Type | Method and Description
      static void | PolicyErrorHelper.insert(Any a, PolicyError that)
      static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)
      Methods in org.omg.CORBA that throw PolicyError
      Modifier and Type Method and Description
      Policy ORB.create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      Constructors in org.omg.CORBA with parameters of type PolicyError
      Constructor and Description
      PolicyErrorHolder(PolicyError initialValue)

    • Uses of PolicyError in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw PolicyError
      Modifier and Type Method and Description
      Policy PolicyFactoryOperations.create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyErrorCodeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyErrorCodeHelper

No usage of org.omg.CORBA.PolicyErrorCodeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyErrorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyErrorHelper

No usage of org.omg.CORBA.PolicyErrorHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyErrorHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyErrorHolder

No usage of org.omg.CORBA.PolicyErrorHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyHelper

No usage of org.omg.CORBA.PolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyHolder

No usage of org.omg.CORBA.PolicyHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyListHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyListHelper

No usage of org.omg.CORBA.PolicyListHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyListHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyListHolder

No usage of org.omg.CORBA.PolicyListHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.PolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.PolicyOperations

  • Packages that use PolicyOperations
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of PolicyOperations in org.omg.CORBA

      Subinterfaces of PolicyOperations in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  Policy
      Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
      Classes in org.omg.CORBA that implement PolicyOperations
      Modifier and Type Class and Description
      class  _PolicyStub
      The Stub for Policy.

    • Uses of PolicyOperations in org.omg.PortableServer

      Subinterfaces of PolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdAssignmentPolicyOperations
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  IdUniquenessPolicyOperations
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  ImplicitActivationPolicyOperations
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  LifespanPolicyOperations
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  RequestProcessingPolicyOperations
      This policy specifies how requests are processed by the created POA.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ServantRetentionPolicyOperations
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      interface  ThreadPolicyOperations
      The ThreadPolicy specifies the threading model used with the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PolicyTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PolicyTypeHelper

No usage of org.omg.CORBA.PolicyTypeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.Principal (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.Principal

  • Packages that use Principal
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Principal in org.omg.CORBA

      Fields in org.omg.CORBA declared as Principal
      Modifier and Type Field and Description
      Principal PrincipalHolder.value
      Deprecated.
      The Principal value held by this PrincipalHolder object.
      Methods in org.omg.CORBA that return Principal
      Modifier and Type Method and Description
      Principal Any.extract_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      Methods in org.omg.CORBA with parameters of type Principal
      Modifier and Type Method and Description
      void Any.insert_Principal(Principal p)
      Deprecated.
      Deprecated by CORBA 2.2.
      Constructors in org.omg.CORBA with parameters of type Principal
      Constructor and Description
      PrincipalHolder(Principal initial)
      Deprecated.
      Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.

    • Uses of Principal in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Principal
      Modifier and Type Method and Description
      Principal InputStream.read_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      Methods in org.omg.CORBA.portable with parameters of type Principal
      Modifier and Type Method and Description
      void OutputStream.write_Principal(Principal value)
      Deprecated.
      Deprecated by CORBA 2.2.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.PrincipalHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.PrincipalHolder

No usage of org.omg.CORBA.PrincipalHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.PRIVATE_MEMBER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.PRIVATE_MEMBER

No usage of org.omg.CORBA.PRIVATE_MEMBER
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.PUBLIC_MEMBER (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.PUBLIC_MEMBER

No usage of org.omg.CORBA.PUBLIC_MEMBER
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.REBIND (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.REBIND

No usage of org.omg.CORBA.REBIND
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.RepositoryIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.RepositoryIdHelper

No usage of org.omg.CORBA.RepositoryIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.Request (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.Request

  • Packages that use Request
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Request in org.omg.CORBA

      Methods in org.omg.CORBA that return Request
      Modifier and Type Method and Description
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      Request LocalObject._request(String operation)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._request(String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request ORB.get_next_response()
      Gets the next Request instance for which a response has been received.
      Methods in org.omg.CORBA with parameters of type Request
      Modifier and Type Method and Description
      abstract void ORB.send_multiple_requests_deferred(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously.
      abstract void ORB.send_multiple_requests_oneway(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously without expecting any responses.

    • Uses of Request in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Request
      Modifier and Type Method and Description
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      Request ObjectImpl._request(String operation)
      Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.request(Object obj, String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ServerRequest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ServerRequest

  • Packages that use ServerRequest
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServerRequest in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ServerRequest
      Modifier and Type Method and Description
      void DynamicImplementation.invoke(ServerRequest request)
      Deprecated.
      Deprecated by Portable Object Adapter

    • Uses of ServerRequest in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type ServerRequest
      Modifier and Type | Method and Description
      void | _NamingContextImplBase.invoke(ServerRequest r)
      void | _BindingIteratorImplBase.invoke(ServerRequest r)

    • Uses of ServerRequest in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type ServerRequest
      Modifier and Type Method and Description
      abstract void DynamicImplementation.invoke(ServerRequest request)
      Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ServiceDetail (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ServiceDetail

  • Packages that use ServiceDetail
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ServiceDetail in org.omg.CORBA

      Fields in org.omg.CORBA declared as ServiceDetail
      Modifier and Type Field and Description
      ServiceDetail[] ServiceInformation.service_details
      Array of ServiceDetails giving more details about the service.
      Methods in org.omg.CORBA that return ServiceDetail
      Modifier and Type | Method and Description
      static ServiceDetail | ServiceDetailHelper.extract(Any a)
      static ServiceDetail | ServiceDetailHelper.read(InputStream in)
      Methods in org.omg.CORBA with parameters of type ServiceDetail
      Modifier and Type | Method and Description
      static void | ServiceDetailHelper.insert(Any a, ServiceDetail that)
      static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)
      Constructors in org.omg.CORBA with parameters of type ServiceDetail
      Constructor and Description
      ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
      Constructs a ServiceInformation object with the given service_options and service_details.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ServiceDetailHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ServiceDetailHelper

No usage of org.omg.CORBA.ServiceDetailHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ServiceInformation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ServiceInformation

  • Packages that use ServiceInformation
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ServiceInformation in org.omg.CORBA

      Fields in org.omg.CORBA declared as ServiceInformation
      Modifier and Type Field and Description
      ServiceInformation ServiceInformationHolder.value
      The ServiceInformation value held by this ServiceInformationHolder object in its value field.
      Methods in org.omg.CORBA that return ServiceInformation
      Modifier and Type | Method and Description
      static ServiceInformation | ServiceInformationHelper.extract(Any a)
      static ServiceInformation | ServiceInformationHelper.read(InputStream in)
      Methods in org.omg.CORBA with parameters of type ServiceInformation
      Modifier and Type | Method and Description
      static void | ServiceInformationHelper.insert(Any a, ServiceInformation that)
      static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)
      Constructors in org.omg.CORBA with parameters of type ServiceInformation
      Constructor and Description
      ServiceInformationHolder(ServiceInformation arg)
      Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ServiceInformationHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ServiceInformationHelper

No usage of org.omg.CORBA.ServiceInformationHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ServiceInformationHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ServiceInformationHolder

  • Packages that use ServiceInformationHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ServiceInformationHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ServiceInformationHolder
      Modifier and Type Method and Description
      boolean ORB.get_service_information(short service_type, ServiceInformationHolder service_info)
      Used to obtain information about CORBA facilities and services that are supported by this ORB.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.SetOverrideType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.SetOverrideType

  • Packages that use SetOverrideType
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of SetOverrideType in org.omg.CORBA

      Fields in org.omg.CORBA declared as SetOverrideType
      Modifier and Type Field and Description
      static SetOverrideType SetOverrideType.ADD_OVERRIDE
      The SetOverrideType constant for the enum value ADD_OVERRIDE.
      static SetOverrideType SetOverrideType.SET_OVERRIDE
      The SetOverrideType constant for the enum value SET_OVERRIDE.
      Methods in org.omg.CORBA that return SetOverrideType
      Modifier and Type | Method and Description
      static SetOverrideType | SetOverrideTypeHelper.extract(Any a)
      static SetOverrideType SetOverrideType.from_int(int i)
      Converts the given int to the corresponding SetOverrideType instance.
      static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type SetOverrideType
      Modifier and Type | Method and Description
      Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
      static void | SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
      static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)

    • Uses of SetOverrideType in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type SetOverrideType
      Modifier and Type Method and Description
      Object ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.SetOverrideTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.SetOverrideTypeHelper

No usage of org.omg.CORBA.SetOverrideTypeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ShortHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ShortHolder

No usage of org.omg.CORBA.ShortHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ShortSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ShortSeqHelper

No usage of org.omg.CORBA.ShortSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ShortSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ShortSeqHolder

  • Packages that use ShortSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ShortSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ShortSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_short_array(ShortSeqHolder seq, int offset, int length)
      Reads array of IDL shorts from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.StringHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.StringHolder

No usage of org.omg.CORBA.StringHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.StringSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.StringSeqHelper

No usage of org.omg.CORBA.StringSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.StringSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.StringSeqHolder

No usage of org.omg.CORBA.StringSeqHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.StringValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.StringValueHelper

No usage of org.omg.CORBA.StringValueHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.StructMember (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.StructMember

  • Packages that use StructMember
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of StructMember in org.omg.CORBA

      Methods in org.omg.CORBA that return StructMember
      Modifier and Type | Method and Description
      static StructMember | StructMemberHelper.extract(Any a)
      static StructMember | StructMemberHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type StructMember
      Modifier and Type | Method and Description
      abstract TypeCode ORB.create_exception_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL exception.
      abstract TypeCode ORB.create_struct_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL struct.
      static void | StructMemberHelper.insert(Any a, StructMember that)
      static void | StructMemberHelper.write(OutputStream ostream, StructMember value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.StructMemberHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.StructMemberHelper

No usage of org.omg.CORBA.StructMemberHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.SystemException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.SystemException

  • Packages that use SystemException
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of SystemException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type SystemException
      Modifier and Type Method and Description
      static RemoteException Util.mapSystemException(SystemException ex)
      Maps a SystemException to a RemoteException.
      RemoteException UtilDelegate.mapSystemException(SystemException ex)
      Delegation call for Util.mapSystemException(org.omg.CORBA.SystemException).

    • Uses of SystemException in org.omg.CORBA

      Subclasses of SystemException in org.omg.CORBA
      Modifier and Type Class and Description
      class  ACTIVITY_COMPLETED
      The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed.
      class  ACTIVITY_REQUIRED
      The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required.
      class  BAD_CONTEXT
      Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.
      class  BAD_INV_ORDER
      This exception indicates that the caller has invoked operations in the wrong order.
      class  BAD_OPERATION
      Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
      class  BAD_PARAM
      Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
      class  BAD_QOS
      The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
      class  BAD_TYPECODE
      Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).
      class  CODESET_INCOMPATIBLE
      This exception is raised whenever meaningful communication is not possible between client and server native code sets.
      class  COMM_FAILURE
      This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.
      class  DATA_CONVERSION
      This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
      class  FREE_MEM
      Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.
      class  IMP_LIMIT
      This exception indicates that an implementation limit was exceeded in the ORB run time.
      class  INITIALIZE
      Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.
      class  INTERNAL
      This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.
      class  INTF_REPOS
      Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.
      class  INV_FLAG
      Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).
      class  INV_IDENT
      This exception indicates that an IDL identifier is syntactically invalid.
      class  INV_OBJREF
      This exception indicates that an object reference is internally malformed.
      class  INV_POLICY
      Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation.
      class  INVALID_ACTIVITY
      The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended.
      class  INVALID_TRANSACTION
      Exception thrown when the request carried an invalid transaction context.
      class  MARSHAL
      A request or reply from the network is structurally invalid.
      class  NO_IMPLEMENT
      This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists.
      class  NO_MEMORY
      Exception thrown when the ORB run time has run out of memory.
      class  NO_PERMISSION
      Exception thrown when an invocation failed because the caller has insufficient privileges.
      class  NO_RESOURCES
      Exception thrown when the ORB has encountered some general resource limitation.
      class  NO_RESPONSE
      This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.
      class  OBJ_ADAPTER
      This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.
      class  OBJECT_NOT_EXIST
      Exception raised whenever an invocation on a deleted object was performed.
      class  PERSIST_STORE
      This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.
      class  REBIND
      REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD.
      class  TIMEOUT
      TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded.
      class  TRANSACTION_MODE
      The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation).
      class  TRANSACTION_REQUIRED
      Exception indicates that the request carried a null transaction context, but an active transaction is required.
      class  TRANSACTION_ROLLEDBACK
      Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back.
      class  TRANSACTION_UNAVAILABLE
      The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated.
      class  TRANSIENT
      Exception thrown when the ORB attempted to reach an object and failed.
      class  UNKNOWN
      This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression.

    • Uses of SystemException in org.omg.CORBA.portable

      Subclasses of SystemException in org.omg.CORBA.portable
      Modifier and Type Class and Description
      class  IndirectionException
      The Indirection exception is a Java specific system exception.
      class  UnknownException
      The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs.
      Methods in org.omg.CORBA.portable that throw SystemException
      Modifier and Type Method and Description
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TCKind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TCKind

  • Packages that use TCKind
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of TCKind in org.omg.CORBA

      Fields in org.omg.CORBA declared as TCKind
      Modifier and Type Field and Description
      static TCKind TCKind.tk_abstract_interface
      The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.
      static TCKind TCKind.tk_alias
      The TCKind constant whose value field is initialized with TCKind._tk_alias.
      static TCKind TCKind.tk_any
      The TCKind constant whose value field is initialized with TCKind._tk_any.
      static TCKind TCKind.tk_array
      The TCKind constant whose value field is initialized with TCKind._tk_array.
      static TCKind TCKind.tk_boolean
      The TCKind constant whose value field is initialized with TCKind._tk_boolean.
      static TCKind TCKind.tk_char
      The TCKind constant whose value field is initialized with TCKind._tk_char.
      static TCKind TCKind.tk_double
      The TCKind constant whose value field is initialized with TCKind._tk_double.
      static TCKind TCKind.tk_enum
      The TCKind constant whose value field is initialized with TCKind._tk_enum.
      static TCKind TCKind.tk_except
      The TCKind constant whose value field is initialized with TCKind._tk_except.
      static TCKind TCKind.tk_fixed
      The TCKind constant whose value field is initialized with TCKind._tk_fixed.
      static TCKind TCKind.tk_float
      The TCKind constant whose value field is initialized with TCKind._tk_float.
      static TCKind TCKind.tk_long
      The TCKind constant whose value field is initialized with TCKind._tk_long.
      static TCKind TCKind.tk_longdouble
      The TCKind constant whose value field is initialized with TCKind._tk_longdouble.
      static TCKind TCKind.tk_longlong
      The TCKind constant whose value field is initialized with TCKind._tk_longlong.
      static TCKind TCKind.tk_native
      The TCKind constant whose value field is initialized with TCKind._tk_native.
      static TCKind TCKind.tk_null
      The TCKind constant whose value field is initialized with TCKind._tk_null.
      static TCKind TCKind.tk_objref
      The TCKind constant whose value field is initialized with TCKind._tk_objref.
      static TCKind TCKind.tk_octet
      The TCKind constant whose value field is initialized with TCKind._tk_octet.
      static TCKind TCKind.tk_Principal
      The TCKind constant whose value field is initialized with TCKind._tk_Principal.
      static TCKind TCKind.tk_sequence
      The TCKind constant whose value field is initialized with TCKind._tk_sequence.
      static TCKind TCKind.tk_short
      The TCKind constant whose value field is initialized with TCKind._tk_short.
      static TCKind TCKind.tk_string
      The TCKind constant whose value field is initialized with TCKind._tk_string.
      static TCKind TCKind.tk_struct
      The TCKind constant whose value field is initialized with TCKind._tk_struct.
      static TCKind TCKind.tk_TypeCode
      The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.
      static TCKind TCKind.tk_ulong
      The TCKind constant whose value field is initialized with TCKind._tk_ulong.
      static TCKind TCKind.tk_ulonglong
      The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.
      static TCKind TCKind.tk_union
      The TCKind constant whose value field is initialized with TCKind._tk_union.
      static TCKind TCKind.tk_ushort
      The TCKind constant whose value field is initialized with TCKind._tk_ushort.
      static TCKind TCKind.tk_value
      The TCKind constant whose value field is initialized with TCKind._tk_value.
      static TCKind TCKind.tk_value_box
      The TCKind constant whose value field is initialized with TCKind._tk_value_box.
      static TCKind TCKind.tk_void
      The TCKind constant whose value field is initialized with TCKind._tk_void.
      static TCKind TCKind.tk_wchar
      The TCKind constant whose value field is initialized with TCKind._tk_wchar.
      static TCKind TCKind.tk_wstring
      The TCKind constant whose value field is initialized with TCKind._tk_wstring.
      Methods in org.omg.CORBA that return TCKind
      Modifier and Type Method and Description
      TCKind DynStruct.current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the kind of the current member.
      TCKind DynValue.current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the current member.
      TCKind DynUnion.discriminator_kind()
      Deprecated.
      Returns the TCKind object associated with the discriminator of this union.
      static TCKind TCKind.from_int(int i)
      Converts the given int to the corresponding TCKind instance.
      abstract TCKind TypeCode.kind()
      Retrieves the kind of this TypeCode object.
      TCKind DynUnion.member_kind()
      Deprecated.
      Returns the TCKind associated with the member of this union.
      Methods in org.omg.CORBA with parameters of type TCKind
      Modifier and Type Method and Description
      abstract TypeCode ORB.get_primitive_tc(TCKind tcKind)
      Retrieves the TypeCode object that represents the given primitive IDL type.

    • Uses of TCKind in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return TCKind
      Modifier and Type Method and Description
      TCKind DynValueOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynStructStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynStructOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynValueStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynUnionOperations.discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      TCKind _DynUnionStub.discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      TCKind DynUnionOperations.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      TCKind _DynUnionStub.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TIMEOUT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TIMEOUT

No usage of org.omg.CORBA.TIMEOUT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TRANSACTION_MODE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TRANSACTION_MODE

No usage of org.omg.CORBA.TRANSACTION_MODE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TRANSACTION_REQUIRED (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TRANSACTION_REQUIRED

No usage of org.omg.CORBA.TRANSACTION_REQUIRED
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TRANSACTION_ROLLEDBACK (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TRANSACTION_ROLLEDBACK

No usage of org.omg.CORBA.TRANSACTION_ROLLEDBACK
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TRANSACTION_UNAVAILABLE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TRANSACTION_UNAVAILABLE

No usage of org.omg.CORBA.TRANSACTION_UNAVAILABLE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TRANSIENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TRANSIENT

No usage of org.omg.CORBA.TRANSIENT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TypeCode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TypeCode

  • Packages that use TypeCode
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of TypeCode in org.omg.CORBA

      Fields in org.omg.CORBA declared as TypeCode
      Modifier and Type Field and Description
      TypeCode UnionMember.type
      The type of the union member described by this UnionMember object.
      TypeCode StructMember.type
      The type of the struct member described by this StructMember object.
      TypeCode ValueMember.type
      The type of of this value member.
      TypeCode TypeCodeHolder.value
      The TypeCode value held by this TypeCodeHolder object.
      Methods in org.omg.CORBA that return TypeCode
      Modifier and Type | Method and Description
      TypeCode ValueBaseHolder._type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      TypeCode TypeCodeHolder._type()
      Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
      TypeCode | DoubleSeqHolder._type()
      TypeCode LongHolder._type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      TypeCode PrincipalHolder._type()
      Deprecated.
      TypeCode AnyHolder._type()
      Returns the TypeCode object corresponding to the value held in this AnyHolder object.
      TypeCode | LongLongSeqHolder._type()
      TypeCode ObjectHolder._type()
      Returns the TypeCode corresponding to the value held in this ObjectHolder object
      TypeCode | WrongTransactionHolder._type()
      TypeCode | WStringSeqHolder._type()
      TypeCode | StringSeqHolder._type()
      TypeCode | CurrentHolder._type()
      TypeCode | ULongSeqHolder._type()
      TypeCode FloatHolder._type()
      Return the TypeCode of this Streamable.
      TypeCode ShortHolder._type()
      Returns the TypeCode corresponding to the value held in this ShortHolder object.
      TypeCode | CharSeqHolder._type()
      TypeCode DoubleHolder._type()
      Return the TypeCode of this holder object.
      TypeCode | OctetSeqHolder._type()
      TypeCode StringHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
      TypeCode | LongSeqHolder._type()
      TypeCode ServiceInformationHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
      TypeCode BooleanHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
      TypeCode IntHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
      TypeCode | PolicyListHolder._type()
      TypeCode ByteHolder._type()
      Returns the TypeCode corresponding to the value held in this ByteHolder object.
      TypeCode | ULongLongSeqHolder._type()
      TypeCode | AnySeqHolder._type()
      TypeCode | FloatSeqHolder._type()
      TypeCode | PolicyErrorHolder._type()
      TypeCode | WCharSeqHolder._type()
      TypeCode | ParameterModeHolder._type()
      TypeCode | UnknownUserExceptionHolder._type()
      TypeCode | UShortSeqHolder._type()
      TypeCode | PolicyHolder._type()
      TypeCode | ShortSeqHolder._type()
      TypeCode CharHolder._type()
      Returns the TypeCode object corresponding to the value held in this CharHolder object.
      TypeCode | BooleanSeqHolder._type()
      TypeCode FixedHolder._type()
      Return the TypeCode of this holder object.
      abstract TypeCode TypeCode.concrete_base_type()
      Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
      abstract TypeCode TypeCode.content_type()
      Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
      TypeCode ORB.create_abstract_interface_tc(String id, String name)
      Create a TypeCode object for an IDL abstract interface.
      abstract TypeCode ORB.create_alias_tc(String id, String name, TypeCode original_type)
      Creates a TypeCode object representing an IDL alias (typedef).
      abstract TypeCode ORB.create_array_tc(int length, TypeCode element_type)
      Creates a TypeCode object representing an IDL array.
      abstract TypeCode ORB.create_enum_tc(String id, String name, String[] members)
      Creates a TypeCode object representing an IDL enum.
      abstract TypeCode ORB.create_exception_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL exception.
      TypeCode ORB.create_fixed_tc(short digits, short scale)
      Create a TypeCode object for an IDL fixed type.
      abstract TypeCode ORB.create_interface_tc(String id, String name)
      Creates a TypeCode object representing an IDL interface.
      TypeCode ORB.create_native_tc(String id, String name)
      Create a TypeCode object for an IDL native type.
      abstract TypeCode ORB.create_recursive_sequence_tc(int bound, int offset)
      Deprecated.
      Use a combination of create_recursive_tc and create_sequence_tc instead
      TypeCode ORB.create_recursive_tc(String id)
      Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion.
      abstract TypeCode ORB.create_sequence_tc(int bound, TypeCode element_type)
      Creates a TypeCode object representing an IDL sequence.
      abstract TypeCode ORB.create_string_tc(int bound)
      Creates a TypeCode object representing a bounded IDL string.
      abstract TypeCode ORB.create_struct_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL struct.
      abstract TypeCode ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      TypeCode ORB.create_value_box_tc(String id, String name, TypeCode boxed_type)
      Creates a TypeCode object for an IDL value box.
      TypeCode ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      abstract TypeCode ORB.create_wstring_tc(int bound)
      Creates a TypeCode object representing a bounded IDL wstring (wide string).
      abstract TypeCode TypeCode.discriminator_type()
      Returns a TypeCode object describing all non-default member labels.
      abstract TypeCode Any.extract_TypeCode()
      Extracts the TypeCode object in this Any object's value field.
      abstract TypeCode TypeCode.get_compact_typecode()
      Strips out all optional name and member name fields, but leaves all alias typecodes intact.
      abstract TypeCode ORB.get_primitive_tc(TCKind tcKind)
      Retrieves the TypeCode object that represents the given primitive IDL type.
      TypeCode DynAny.get_typecode()
      Deprecated.
      Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
      abstract TypeCode ExceptionList.item(int index)
      Returns the TypeCode object at the given index.
      abstract TypeCode TypeCode.member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      TypeCode DataInputStream.read_TypeCode()
      Reads an IDL typecode from the input stream.
      static TypeCode | UnknownUserExceptionHelper.type()
      static TypeCode | DoubleSeqHelper.type()
      static TypeCode | ServiceDetailHelper.type()
      static TypeCode | ValueMemberHelper.type()
      static TypeCode | SetOverrideTypeHelper.type()
      static TypeCode | StringValueHelper.type()
      static TypeCode | LongLongSeqHelper.type()
      static TypeCode | RepositoryIdHelper.type()
      static TypeCode | UnionMemberHelper.type()
      static TypeCode | ServiceInformationHelper.type()
      static TypeCode | WStringSeqHelper.type()
      abstract TypeCode Any.type()
      Returns type information for the element contained in this Any object.
      static TypeCode | StructMemberHelper.type()
      static TypeCode | CharSeqHelper.type()
      static TypeCode | ParameterModeHelper.type()
      static TypeCode | ObjectHelper.type()
      static TypeCode | ShortSeqHelper.type()
      static TypeCode | IDLTypeHelper.type()
      static TypeCode | VisibilityHelper.type()
      TypeCode IDLTypeOperations.type()
      The type attribute describes the type defined by an object derived from IDLType.
      static TypeCode | LongSeqHelper.type()
      static TypeCode | VersionSpecHelper.type()
      TypeCode DynAny.type()
      Deprecated.
      Returns the TypeCode of the object inserted into this DynAny.
      static TypeCode | OctetSeqHelper.type()
      static TypeCode | NameValuePairHelper.type()
      static TypeCode | FloatSeqHelper.type()
      static TypeCode | CompletionStatusHelper.type()
      static TypeCode | PolicyListHelper.type()
      static TypeCode | IdentifierHelper.type()
      static TypeCode | StringSeqHelper.type()
      static TypeCode | DefinitionKindHelper.type()
      static TypeCode | PolicyHelper.type()
      static TypeCode | FieldNameHelper.type()
      TypeCode | _IDLTypeStub.type()
      static TypeCode | ULongSeqHelper.type()
      static TypeCode | ULongLongSeqHelper.type()
      static TypeCode | CurrentHelper.type()
      static TypeCode | AnySeqHelper.type()
      static TypeCode | PolicyErrorHelper.type()
      static TypeCode | PolicyErrorCodeHelper.type()
      static TypeCode | ValueBaseHelper.type()
      static TypeCode | WCharSeqHelper.type()
      static TypeCode | PolicyTypeHelper.type()
      static TypeCode | WStringValueHelper.type()
      static TypeCode | WrongTransactionHelper.type()
      static TypeCode | BooleanSeqHelper.type()
      static TypeCode | UShortSeqHelper.type()
      Methods in org.omg.CORBA with parameters of type TypeCode
      Modifier and Type Method and Description
      abstract void ExceptionList.add(TypeCode exc)
      Adds a TypeCode object describing an exception to this ExceptionList object.
      abstract TypeCode ORB.create_alias_tc(String id, String name, TypeCode original_type)
      Creates a TypeCode object representing an IDL alias (typedef).
      abstract TypeCode ORB.create_array_tc(int length, TypeCode element_type)
      Creates a TypeCode object representing an IDL array.
      DynAny ORB.create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynArray ORB.create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynEnum ORB.create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynSequence ORB.create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynStruct ORB.create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynUnion ORB.create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract TypeCode ORB.create_sequence_tc(int bound, TypeCode element_type)
      Creates a TypeCode object representing an IDL sequence.
      abstract TypeCode ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      TypeCode ORB.create_value_box_tc(String id, String name, TypeCode boxed_type)
      Creates a TypeCode object for an IDL value box.
      TypeCode ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      abstract boolean TypeCode.equal(TypeCode tc)
      Compares this TypeCode object with the given one, testing for equality.
      abstract boolean TypeCode.equivalent(TypeCode tc)
      Tests to see if the given TypeCode object is equivalent to this TypeCode object.
      void Any.insert_fixed(BigDecimal value, TypeCode type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      abstract void Any.insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      void DynAny.insert_typecode(TypeCode value)
      Deprecated.
      Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
      abstract void Any.insert_TypeCode(TypeCode t)
      Inserts the given TypeCode object into this Any object's value field.
      abstract void Any.insert_Value(Serializable v, TypeCode t)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void Any.read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
      abstract void Request.set_return_type(TypeCode tc)
      Sets the typecode for the return value of the method.
      abstract void Any.type(TypeCode t)
      Sets this Any object's type field to the given TypeCode object and clears its value.
      void DataOutputStream.write_TypeCode(TypeCode value)
      Writes the typecode to the output stream.
      Constructors in org.omg.CORBA with parameters of type TypeCode
      Constructor and Description
      StructMember(String __name, TypeCode __type, IDLType __type_def)
      Constructs a StructMember object initialized with the given values.
      TypeCodeHolder(TypeCode initial)
      Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.
      ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
      Constructs a ValueMember object initialized with the given values.

    • Uses of TypeCode in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return TypeCode
      Modifier and Type Method and Description
      TypeCode Streamable._type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      abstract TypeCode InputStream.read_TypeCode()
      Reads a TypeCode from this input stream.
      Methods in org.omg.CORBA.portable with parameters of type TypeCode
      Modifier and Type Method and Description
      abstract void OutputStream.write_TypeCode(TypeCode value)
      Writes a TypeCode on this output stream.

    • Uses of TypeCode in org.omg.CosNaming

      Methods in org.omg.CosNaming that return TypeCode
      Modifier and Type | Method and Description
      TypeCode | BindingHolder._type()
      TypeCode | NamingContextExtHolder._type()
      TypeCode | BindingIteratorHolder._type()
      TypeCode | NameHolder._type()
      TypeCode | NameComponentHolder._type()
      TypeCode | BindingListHolder._type()
      TypeCode | NamingContextHolder._type()
      TypeCode | BindingTypeHolder._type()
      static TypeCode | BindingTypeHelper.type()
      static TypeCode | NamingContextExtHelper.type()
      static TypeCode | NameComponentHelper.type()
      static TypeCode | IstringHelper.type()
      static TypeCode | BindingHelper.type()
      static TypeCode | NameHelper.type()
      static TypeCode | BindingIteratorHelper.type()
      static TypeCode | BindingListHelper.type()
      static TypeCode | NamingContextHelper.type()

    • Uses of TypeCode in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage that return TypeCode
      Modifier and Type | Method and Description
      TypeCode | InvalidAddressHolder._type()
      static TypeCode | StringNameHelper.type()
      static TypeCode | AddressHelper.type()
      static TypeCode | InvalidAddressHelper.type()
      static TypeCode | URLStringHelper.type()

    • Uses of TypeCode in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage that return TypeCode
      Modifier and Type | Method and Description
      TypeCode | CannotProceedHolder._type()
      TypeCode | NotEmptyHolder._type()
      TypeCode | InvalidNameHolder._type()
      TypeCode | AlreadyBoundHolder._type()
      TypeCode | NotFoundHolder._type()
      TypeCode | NotFoundReasonHolder._type()
      static TypeCode | NotEmptyHelper.type()
      static TypeCode | NotFoundHelper.type()
      static TypeCode | NotFoundReasonHelper.type()
      static TypeCode | AlreadyBoundHelper.type()
      static TypeCode | CannotProceedHelper.type()
      static TypeCode | InvalidNameHelper.type()

    • Uses of TypeCode in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return TypeCode
      Modifier and Type | Method and Description
      TypeCode _DynFixedStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynAnyStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynArrayStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynStructStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynValueStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynUnionStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode DynAnyOperations.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynEnumStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynSequenceStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      static TypeCode | NameValuePairSeqHelper.type()
      TypeCode _DynFixedStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | DynArrayHelper.type()
      TypeCode _DynAnyStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | NameDynAnyPairHelper.type()
      TypeCode _DynArrayStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynStructStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | DynUnionHelper.type()
      static TypeCode | DynAnyFactoryHelper.type()
      static TypeCode | DynValueHelper.type()
      static TypeCode | NameDynAnyPairSeqHelper.type()
      static TypeCode | NameValuePairHelper.type()
      TypeCode _DynValueStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | DynFixedHelper.type()
      static TypeCode | FieldNameHelper.type()
      static TypeCode | DynStructHelper.type()
      static TypeCode | DynEnumHelper.type()
      TypeCode _DynUnionStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | AnySeqHelper.type()
      static TypeCode | DynSequenceHelper.type()
      static TypeCode | DynAnySeqHelper.type()
      TypeCode DynAnyOperations.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynEnumStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynSequenceStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | DynAnyHelper.type()
      Methods in org.omg.DynamicAny with parameters of type TypeCode
      Modifier and Type Method and Description
      DynAny _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      void _DynFixedStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynAnyStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynArrayStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynStructStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynValueStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynUnionStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void DynAnyOperations.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynEnumStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynSequenceStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.

    • Uses of TypeCode in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | InconsistentTypeCodeHelper.type()

    • Uses of TypeCode in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | InvalidValueHelper.type()
      static TypeCode | TypeMismatchHelper.type()

    • Uses of TypeCode in org.omg.IOP

      Methods in org.omg.IOP that return TypeCode
      Modifier and Type | Method and Description
      TypeCode | TaggedComponentHolder._type()
      TypeCode | TaggedProfileHolder._type()
      TypeCode | IORHolder._type()
      TypeCode | MultipleComponentProfileHolder._type()
      TypeCode | ServiceContextHolder._type()
      TypeCode | ServiceContextListHolder._type()
      static TypeCode | MultipleComponentProfileHelper.type()
      static TypeCode | TaggedComponentHelper.type()
      static TypeCode | CodecFactoryHelper.type()
      static TypeCode | ServiceContextHelper.type()
      static TypeCode | ProfileIdHelper.type()
      static TypeCode | ServiceContextListHelper.type()
      static TypeCode | ServiceIdHelper.type()
      static TypeCode | IORHelper.type()
      static TypeCode | TaggedProfileHelper.type()
      static TypeCode | ComponentIdHelper.type()
      Methods in org.omg.IOP with parameters of type TypeCode
      Modifier and Type Method and Description
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.

    • Uses of TypeCode in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | UnknownEncodingHelper.type()

    • Uses of TypeCode in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | FormatMismatchHelper.type()
      static TypeCode | TypeMismatchHelper.type()
      static TypeCode | InvalidTypeForEncodingHelper.type()

    • Uses of TypeCode in org.omg.Messaging

      Methods in org.omg.Messaging that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | SyncScopeHelper.type()

    • Uses of TypeCode in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TypeCode
      Modifier and Type | Method and Description
      TypeCode | IORInterceptor_3_0Holder._type()
      TypeCode | ObjectReferenceTemplateSeqHolder._type()
      TypeCode | ObjectReferenceFactoryHolder._type()
      TypeCode | ObjectReferenceTemplateHolder._type()
      TypeCode[] RequestInfoOperations.exceptions()
      Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
      static TypeCode | ObjectReferenceTemplateHelper.type()
      static TypeCode | ForwardRequestHelper.type()
      static TypeCode | AdapterStateHelper.type()
      static TypeCode | IORInterceptor_3_0Helper.type()
      static TypeCode | ObjectIdHelper.type()
      static TypeCode | ORBIdHelper.type()
      static TypeCode | InvalidSlotHelper.type()
      static TypeCode | AdapterManagerIdHelper.type()
      static TypeCode | ObjectReferenceFactoryHelper.type()
      static TypeCode | CurrentHelper.type()
      static TypeCode | AdapterNameHelper.type()
      static TypeCode | ServerIdHelper.type()
      static TypeCode | ObjectReferenceTemplateSeqHelper.type()

    • Uses of TypeCode in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | ObjectIdHelper.type()
      static TypeCode | DuplicateNameHelper.type()
      static TypeCode | InvalidNameHelper.type()

    • Uses of TypeCode in org.omg.PortableServer

      Methods in org.omg.PortableServer that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | ForwardRequestHelper.type()
      static TypeCode | ServantLocatorHelper.type()
      static TypeCode | POAHelper.type()
      static TypeCode | ServantActivatorHelper.type()
      static TypeCode | CurrentHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | NoContextHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | AdapterInactiveHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return TypeCode
      Modifier and Type | Method and Description
      static TypeCode | ServantAlreadyActiveHelper.type()
      static TypeCode | ObjectAlreadyActiveHelper.type()
      static TypeCode | WrongPolicyHelper.type()
      static TypeCode | AdapterAlreadyExistsHelper.type()
      static TypeCode | ServantNotActiveHelper.type()
      static TypeCode | NoServantHelper.type()
      static TypeCode | WrongAdapterHelper.type()
      static TypeCode | InvalidPolicyHelper.type()
      static TypeCode | ObjectNotActiveHelper.type()
      static TypeCode | AdapterNonExistentHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.ServantLocatorPackage

      Methods in org.omg.PortableServer.ServantLocatorPackage that return TypeCode
      Modifier and Type | Method and Description
      TypeCode | CookieHolder._type()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TypeCodeHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TypeCodeHolder

No usage of org.omg.CORBA.TypeCodeHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ULongLongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ULongLongSeqHelper

No usage of org.omg.CORBA.ULongLongSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ULongLongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ULongLongSeqHolder

  • Packages that use ULongLongSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ULongLongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ULongLongSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned long longs from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ULongSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ULongSeqHelper

No usage of org.omg.CORBA.ULongSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ULongSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ULongSeqHolder

  • Packages that use ULongSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ULongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ULongSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_ulong_array(ULongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned longs from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UnionMember (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UnionMember

  • Packages that use UnionMember
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of UnionMember in org.omg.CORBA

      Methods in org.omg.CORBA that return UnionMember
      Modifier and Type | Method and Description
      static UnionMember | UnionMemberHelper.extract(Any a)
      static UnionMember | UnionMemberHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type UnionMember
      Modifier and Type | Method and Description
      abstract TypeCode ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      static void | UnionMemberHelper.insert(Any a, UnionMember that)
      static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UnionMemberHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UnionMemberHelper

No usage of org.omg.CORBA.UnionMemberHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UNKNOWN (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UNKNOWN

No usage of org.omg.CORBA.UNKNOWN
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UnknownUserException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UnknownUserException

  • Packages that use UnknownUserException
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of UnknownUserException in org.omg.CORBA

      Fields in org.omg.CORBA declared as UnknownUserException
      Modifier and Type | Field and Description
      UnknownUserException | UnknownUserExceptionHolder.value
      Methods in org.omg.CORBA that return UnknownUserException
      Modifier and Type | Method and Description
      static UnknownUserException | UnknownUserExceptionHelper.extract(Any a)
      static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type UnknownUserException
      Modifier and Type | Method and Description
      static void | UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
      static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)
      Constructors in org.omg.CORBA with parameters of type UnknownUserException
      Constructor and Description
      UnknownUserExceptionHolder(UnknownUserException initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UnknownUserExceptionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UnknownUserExceptionHelper

No usage of org.omg.CORBA.UnknownUserExceptionHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UnknownUserExceptionHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UnknownUserExceptionHolder

No usage of org.omg.CORBA.UnknownUserExceptionHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.UNSUPPORTED_POLICY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.UNSUPPORTED_POLICY

No usage of org.omg.CORBA.UNSUPPORTED_POLICY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.UNSUPPORTED_POLICY_VALUE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.UNSUPPORTED_POLICY_VALUE

No usage of org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UserException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UserException

  • Packages that use UserException
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of UserException in org.omg.CORBA

      Subclasses of UserException in org.omg.CORBA
      Modifier and Type Class and Description
      class  Bounds
      A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
      class  PolicyError
      A user exception thrown when a policy error occurs.
      class  UnknownUserException
      A class that contains user exceptions returned by the server.
      class  WrongTransaction
      The CORBA WrongTransaction user-defined exception.

    • Uses of UserException in org.omg.CORBA.DynAnyPackage

      Subclasses of UserException in org.omg.CORBA.DynAnyPackage
      Modifier and Type | Class and Description
      class  Invalid
      Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
      class  InvalidSeq
      The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
      class  | InvalidValue
      class  TypeMismatch
      TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

    • Uses of UserException in org.omg.CORBA.ORBPackage

      Subclasses of UserException in org.omg.CORBA.ORBPackage
      Modifier and Type Class and Description
      class  InconsistentTypeCode
      InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
      class  InvalidName
      The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

    • Uses of UserException in org.omg.CORBA.TypeCodePackage

      Subclasses of UserException in org.omg.CORBA.TypeCodePackage
      Modifier and Type Class and Description
      class  BadKind
      The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.

    • Uses of UserException in org.omg.CosNaming.NamingContextExtPackage

      Subclasses of UserException in org.omg.CosNaming.NamingContextExtPackage
      Modifier and Type Class and Description
      class  InvalidAddress
      org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

    • Uses of UserException in org.omg.CosNaming.NamingContextPackage

      Subclasses of UserException in org.omg.CosNaming.NamingContextPackage
      Modifier and Type Class and Description
      class  AlreadyBound
      org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
      class  CannotProceed
      org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
      class  NotEmpty
      org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
      class  NotFound
      org/omg/CosNaming/NamingContextPackage/NotFound.java .

    • Uses of UserException in org.omg.IOP.CodecFactoryPackage

      Subclasses of UserException in org.omg.IOP.CodecFactoryPackage
      Modifier and Type Class and Description
      class  UnknownEncoding
      org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

    • Uses of UserException in org.omg.IOP.CodecPackage

      Subclasses of UserException in org.omg.IOP.CodecPackage
      Modifier and Type Class and Description
      class  FormatMismatch
      org/omg/IOP/CodecPackage/FormatMismatch.java .
      class  InvalidTypeForEncoding
      org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .

    • Uses of UserException in org.omg.PortableInterceptor

      Subclasses of UserException in org.omg.PortableInterceptor
      Modifier and Type Class and Description
      class  InvalidSlot
      org/omg/PortableInterceptor/InvalidSlot.java .

    • Uses of UserException in org.omg.PortableInterceptor.ORBInitInfoPackage

      Subclasses of UserException in org.omg.PortableInterceptor.ORBInitInfoPackage
      Modifier and Type Class and Description
      class  DuplicateName
      org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .

    • Uses of UserException in org.omg.PortableServer

      Subclasses of UserException in org.omg.PortableServer
      Modifier and Type Class and Description
      class  ForwardRequest
      org/omg/PortableServer/ForwardRequest.java .

    • Uses of UserException in org.omg.PortableServer.CurrentPackage

      Subclasses of UserException in org.omg.PortableServer.CurrentPackage
      Modifier and Type Class and Description
      class  NoContext
      org/omg/PortableServer/CurrentPackage/NoContext.java .

    • Uses of UserException in org.omg.PortableServer.POAManagerPackage

      Subclasses of UserException in org.omg.PortableServer.POAManagerPackage
      Modifier and Type Class and Description
      class  AdapterInactive
      org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .

    • Uses of UserException in org.omg.PortableServer.POAPackage

      Subclasses of UserException in org.omg.PortableServer.POAPackage
      Modifier and Type Class and Description
      class  AdapterAlreadyExists
      org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
      class  AdapterNonExistent
      org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
      class  InvalidPolicy
      org/omg/PortableServer/POAPackage/InvalidPolicy.java .
      class  NoServant
      org/omg/PortableServer/POAPackage/NoServant.java .
      class  ObjectAlreadyActive
      org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
      class  ObjectNotActive
      org/omg/PortableServer/POAPackage/ObjectNotActive.java .
      class  ServantAlreadyActive
      org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
      class  ServantNotActive
      org/omg/PortableServer/POAPackage/ServantNotActive.java .
      class  WrongAdapter
      org/omg/PortableServer/POAPackage/WrongAdapter.java .
      class  WrongPolicy
      org/omg/PortableServer/POAPackage/WrongPolicy.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UShortSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UShortSeqHelper

No usage of org.omg.CORBA.UShortSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.UShortSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.UShortSeqHolder

  • Packages that use UShortSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of UShortSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type UShortSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_ushort_array(UShortSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned shorts from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ValueBaseHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ValueBaseHelper

No usage of org.omg.CORBA.ValueBaseHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ValueBaseHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ValueBaseHolder

No usage of org.omg.CORBA.ValueBaseHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ValueMember (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ValueMember

  • Packages that use ValueMember
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ValueMember in org.omg.CORBA

      Methods in org.omg.CORBA that return ValueMember
      Modifier and Type | Method and Description
      static ValueMember | ValueMemberHelper.extract(Any a)
      static ValueMember | ValueMemberHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type ValueMember
      Modifier and Type | Method and Description
      TypeCode ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      static void | ValueMemberHelper.insert(Any a, ValueMember that)
      static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ValueMemberHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ValueMemberHelper

No usage of org.omg.CORBA.ValueMemberHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.VersionSpecHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.VersionSpecHelper

No usage of org.omg.CORBA.VersionSpecHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.VisibilityHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.VisibilityHelper

No usage of org.omg.CORBA.VisibilityHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.VM_ABSTRACT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.VM_ABSTRACT

No usage of org.omg.CORBA.VM_ABSTRACT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.VM_CUSTOM (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.VM_CUSTOM

No usage of org.omg.CORBA.VM_CUSTOM
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.VM_NONE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.VM_NONE

No usage of org.omg.CORBA.VM_NONE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.VM_TRUNCATABLE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.VM_TRUNCATABLE

No usage of org.omg.CORBA.VM_TRUNCATABLE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WCharSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WCharSeqHelper

No usage of org.omg.CORBA.WCharSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WCharSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WCharSeqHolder

  • Packages that use WCharSeqHolder
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of WCharSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type WCharSeqHolder
      Modifier and Type Method and Description
      void DataInputStream.read_wchar_array(WCharSeqHolder seq, int offset, int length)
      Reads array of IDL wide characters from offset for length elements from the input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WrongTransaction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WrongTransaction

  • Packages that use WrongTransaction
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of WrongTransaction in org.omg.CORBA

      Fields in org.omg.CORBA declared as WrongTransaction
      Modifier and Type | Field and Description
      WrongTransaction | WrongTransactionHolder.value
      Methods in org.omg.CORBA that return WrongTransaction
      Modifier and Type | Method and Description
      static WrongTransaction | WrongTransactionHelper.extract(Any a)
      static WrongTransaction | WrongTransactionHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type WrongTransaction
      Modifier and Type | Method and Description
      static void | WrongTransactionHelper.insert(Any a, WrongTransaction that)
      static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)
      Methods in org.omg.CORBA that throw WrongTransaction
      Modifier and Type Method and Description
      abstract Request ORB.get_next_response()
      Gets the next Request instance for which a response has been received.
      abstract void Request.get_response()
      Allows the user to access the response for the invocation triggered earlier with the send_deferred method.
      Constructors in org.omg.CORBA with parameters of type WrongTransaction
      Constructor and Description
      WrongTransactionHolder(WrongTransaction initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WrongTransactionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WrongTransactionHelper

No usage of org.omg.CORBA.WrongTransactionHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WrongTransactionHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WrongTransactionHolder

No usage of org.omg.CORBA.WrongTransactionHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WStringSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WStringSeqHelper

No usage of org.omg.CORBA.WStringSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WStringSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WStringSeqHolder

No usage of org.omg.CORBA.WStringSeqHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.WStringValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.WStringValueHelper

No usage of org.omg.CORBA.WStringValueHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA._IDLTypeStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA._IDLTypeStub

No usage of org.omg.CORBA._IDLTypeStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA._PolicyStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA._PolicyStub

No usage of org.omg.CORBA._PolicyStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Official Specifications for CORBA support in Java[tm] SE 6

Specification References

The specifications with which the Java[tm] Platform, Standard Edition (Java SE) v.1.6.0 ORB complies are as follows. If these links do not take you to the referenced specification, the OMG may have changed the URL, and you can link to www.omg.org to search for the correct specification.
  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Revised IDL to Java language mapping (ptc/00-11-03)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (ptc/00-08-07)
  • Portable Interceptors (ptc/2001-03-04)
These are the only specifications referenced by this document.

Supported Specification Details

Not all of the above specifications are currently implemented in the ORB in Java[tm] SE 6. The precise list of supported sections is as follows:
  • CORBA 2.3.1 chapters 1-3 and 6-9
  • Revised IDL to Java language mapping, section 1.21.8.2, the orb.properties file.
  • CORBA 2.3.1 chapter 4 with the following replacements from the Portable Interceptors specification:
    • section 4.2.3.5 destroy
    • section 4.5.2 CodeFactory and PICurrent are required
    • Section 4.5.3.4 as updated for register_initial_reference
  • CORBA 2.3.1 chapter 5 with the following update from the Portable Interceptors specification:
    • 5.5.2 StringSeq and WStringSeq are required. This adds the following classes to org.omg.CORBA:
      • StringSeqHolder
      • StringSeqHelper
      • WStringSeqHolder
      • WStringSeqHelper
  • CORBA 2.3.1 sections 10.6.1 and 10.6.2 are supported for repository IDs.
  • CORBA 2.3.1 section 10.7 for TypeCode APIs.
  • CORBA 2.3.1 chapter 11, Portable Object Adapter (POA), with the following updates from the Portable Interceptors specification:
    • Section 11.3.7 POAs must preserve all policies
    • Section 11.3.8.2 again states that POAs must preserve all policies
    • Section 11.3.8.26 POA::id is required.
  • CORBA 2.3.1 chapters 13 and 15 define GIOP 1.0, 1.1, and 1.2. The Java SE 6 ORB fully supports all versions of GIOP, with the exception that the bi-directional GIOP feature defined in sections 15.8 and 15.9 is not supported.
  • All of the Interoperable Naming Service is supported.
  • Portable Interceptors section 13.8 (the new Coder/Decoder interfaces) and all of chapter 21 (the interceptor specification).
  • Section 1.21.8 of the Revised IDL to Java Language Mapping Specification (ptc/00-11-03) has been changed from the version in the IDL to Java Language Mapping Specification (ptc/00-01-08).

Tools

  • The IDL to Java compiler (idlj) complies with:
    • CORBA 2.3.1 chapter 3 (IDL definition)
    • CORBA 2.3.1 chapters 5 and 6 (semantics of Value types)
    • CORBA 2.3.1 section 10.6.5 (pragmas)
    • The IDL to Java mapping specification
    • The Revised IDL to Java language mapping specification section 1.12.1 "local interfaces"
  • The Java to IDL compiler (the IIOP backend for rmic) complies with:
    • CORBA 2.3.1 chapters 5 and 6 (value types)
    • The Java to IDL language mapping. Note that this implicitly references section 1.21 of the IDL to Java language mapping
    • IDL generated by the -idl flag complies with CORBA 2.3.1 chapter 3.


IDL-to-Java Generated Files

The files that are generated by the IDL-to-Java compiler, in accordance with the IDL-to-Java Language Mapping Specification, which is implemented in JavaTM SE 6 according the compliance document.

In general IDL names and identifiers are mapped to Java names and identifiers with no change. Because of the nature of the Java language, a single IDL construct may be mapped to several (differently named) Java constructs. The additional names are constructed by appending a descriptive suffix. For example, the IDL interface foo is mapped to the Java interfaces foo and fooOperations, and additional Java classes fooHelper, fooHolder, fooPOA, and optionally fooPOATie.

The mapping in effect reserves the use of several names for its own purposes. These are:

  • The Java class <type>Helper, where <type> is the name of an IDL defined type.
  • The Java class <type>Holder, where <type> is the name of an IDL defined type (with certain exceptions such as typedef aliases).
  • The Java classes <basicJavaType>Holder, where <basicJavaType> is one of the Java primitive datatypes that is used by one of the IDL basic datatypes.
  • The Java classes <interface>Operations, <interface>POA, and <interface>POATie, where <interface> is the name of an IDL interface type.
  • The nested scope Java package name <interface>Package, where <interface> is the name of an IDL interface.

    Helper Files

    Helper files supply several static methods needed to manipulate the type. These include Any insert and extract operations for the type, getting the repository id, getting the typecode, and reading and writing the type from and to a stream.

    The helper class for a mapped IDL interface or abstract interface also include narrow operation(s). The static narrow method allows an org.omg.CORBA.Object to be narrowed to the object reference of a more specific type. The IDL exception CORBA::BAD_PARAM is thrown if the narrow fails because the object reference does not support the requested type. A different system exception is raised to indicate other kinds of errors. Trying to narrow a null will always succeed with a return value of null.

    Holder Files

    Support for out and inout parameter passing modes requires the use of additional holder classes. These classes are available for all of the basic IDL datatypes in the org.omg.CORBA package and are generated for all named user defined IDL types except those defined by typedefs. (Note that in this context user defined includes types that are defined in OMG specifications such as those for the Interface Repository, and other OMG services.)

    Each holder class has a constructor from an instance, a default constructor, and has a public instance member, value which is the typed value. The default constructor sets the value field to the default value for the type as defined by the Java language: false for boolean, 0 for numeric and char types, null for strings, null for object references.

    To support portable stubs and skeletons, holder classes also implement the org.omg.CORBA.portable.Streamable interface.

    Operations Files

    A non abstract IDL interface is mapped to two public Java interfaces: a signature interface and an operations interface. The signature interface, which extends IDLEntity, has the same name as the IDL interface name and is used as the signature type in method declarations when interfaces of the specified type are used in other interfaces. The operations interface has the same name as the IDL interface with the suffix Operations appended to the end and is used in the server-side mapping and as a mechanism for providing optimized calls for collocated client and servers.

    The Java operations interface contains the mapped operation signatures. The Java signature interface extends the operations interface, the (mapped) base org.omg.CORBA.Object, as well as org.omg.portable.IDLEntity. Methods can be invoked on the signature interface. Interface inheritance expressed in IDL is reflected in both the Java signature interface and operations interface hierarchies.

    Stubs

    For the mapping of a non-object-oriented language, there will be a programming interface to the stubs for each interface type. Generally, the stubs will present access to the OMG IDL-defined operations on an object in a way that is easy for programmers to predict once they are familiar with OMG IDL and the language mapping for the particular programming language. The stubs make calls on the rest of the ORB using interfaces that are private to, and presumably optimized for, the particular ORB Core. If more than one ORB is available, there may be different stubs corresponding to the different ORBs. In this case, it is necessary for the ORB and language mapping to cooperate to associate the correct stubs with the particular object reference.

    Object-oriented programming languages, such as Java, C++, and Smalltalk, do not require stub interfaces.


Invalid (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.DynAnyPackage

Class Invalid

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.Invalid
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Invalid
extends UserException
    Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.

    • Constructor Summary

      Constructors
      Constructor and Description
      Invalid()
      Constructs an Invalid object.
      Invalid(String reason)
      Constructs an Invalid object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Invalid

        public Invalid()
        Constructs an Invalid object.

      • Invalid

        public Invalid(String reason)
        Constructs an Invalid object.
        Parameters:
        reason - a String giving more information regarding the bad parameter passed to a dynamic any operation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidSeq (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.DynAnyPackage

Class InvalidSeq

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidSeq
extends UserException
    The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSeq()
      Constructs an InvalidSeq object.
      InvalidSeq(String reason)
      Constructs an InvalidSeq object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidSeq

        public InvalidSeq()
        Constructs an InvalidSeq object.

      • InvalidSeq

        public InvalidSeq(String reason)
        Constructs an InvalidSeq object.
        Parameters:
        reason - a String giving more information regarding the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.DynAnyPackage

Class InvalidValue

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.InvalidValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidValue
extends UserException

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidValue()
      Constructs an InvalidValue object.
      InvalidValue(String reason)
      Constructs an InvalidValue object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidValue

        public InvalidValue()
        Constructs an InvalidValue object.

      • InvalidValue

        public InvalidValue(String reason)
        Constructs an InvalidValue object.
        Parameters:
        reason - a String giving more information regarding the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.DynAnyPackage (Java Platform SE 8 )

org.omg.CORBA.DynAnyPackage

Exceptions

  • Invalid
  • InvalidSeq
  • InvalidValue
  • TypeMismatch


org.omg.CORBA.DynAnyPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA.DynAnyPackage

Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).

See: Description

  • Exception Summary
    Exception Description
    Invalid
    Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
    InvalidSeq
    The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
    InvalidValue
    TypeMismatch
    TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

Package org.omg.CORBA.DynAnyPackage Description

Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
Since:
JDK1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.DynAnyPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA.DynAnyPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.DynAnyPackage.Invalid
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
          • org.omg.CORBA.DynAnyPackage.InvalidValue
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA.DynAnyPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA.DynAnyPackage

  • Packages that use org.omg.CORBA.DynAnyPackage
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
  • Classes in org.omg.CORBA.DynAnyPackage used by org.omg.CORBA
    Class and Description
    Invalid
    Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
    InvalidSeq
    The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
    InvalidValue
    TypeMismatch
    TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.DynAnyPackage

Class TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatch()
      Constructs a TypeMismatch object.
      TypeMismatch(String reason)
      Constructs a TypeMismatch object.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeMismatch

        public TypeMismatch()
        Constructs a TypeMismatch object.

      • TypeMismatch

        public TypeMismatch(String reason)
        Constructs a TypeMismatch object.
        Parameters:
        reason - a String giving more information regarding the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DynAnyPackage.Invalid (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DynAnyPackage.Invalid

  • Packages that use Invalid
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Invalid in org.omg.CORBA

      Methods in org.omg.CORBA that throw Invalid
      Modifier and Type Method and Description
      void DynAny.assign(DynAny dyn_any)
      Deprecated.
      Copy the contents from one Dynamic Any into another.
      void DynAny.from_any(Any value)
      Deprecated.
      Make a DynAny object from an Any object.
      Any DynAny.to_any()
      Deprecated.
      Convert a DynAny object to an Any object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DynAnyPackage.InvalidSeq (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DynAnyPackage.InvalidSeq

  • Packages that use InvalidSeq
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InvalidSeq in org.omg.CORBA

      Methods in org.omg.CORBA that throw InvalidSeq
      Modifier and Type Method and Description
      void DynArray.set_elements(Any[] value)
      Deprecated.
      Sets the value of this DynArray object to the given array.
      void DynSequence.set_elements(Any[] value)
      Deprecated.
      Sets the values of all elements in this sequence with the given array.
      void DynStruct.set_members(NameValuePair[] value)
      Deprecated.
      Set the members of the struct.
      void DynValue.set_members(NameValuePair[] value)
      Deprecated.
      Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DynAnyPackage.InvalidValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DynAnyPackage.InvalidValue

  • Packages that use InvalidValue
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InvalidValue in org.omg.CORBA

      Methods in org.omg.CORBA that throw InvalidValue
      Modifier and Type Method and Description
      void DynAny.insert_any(Any value)
      Deprecated.
      Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
      void DynAny.insert_boolean(boolean value)
      Deprecated.
      Inserts the given boolean as the value for this DynAny object.
      void DynAny.insert_char(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void DynAny.insert_double(double value)
      Deprecated.
      Inserts the given double as the value for this DynAny object.
      void DynAny.insert_float(float value)
      Deprecated.
      Inserts the given float as the value for this DynAny object.
      void DynAny.insert_long(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void DynAny.insert_longlong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void DynAny.insert_octet(byte value)
      Deprecated.
      Inserts the given byte as the value for this DynAny object.
      void DynAny.insert_reference(Object value)
      Deprecated.
      Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
      void DynAny.insert_short(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void DynAny.insert_string(String value)
      Deprecated.
      Inserts the given String object as the value for this DynAny object.
      void DynAny.insert_typecode(TypeCode value)
      Deprecated.
      Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
      void DynAny.insert_ulong(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void DynAny.insert_ulonglong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void DynAny.insert_ushort(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void DynAny.insert_val(Serializable value)
      Deprecated.
      Inserts the given java.io.Serializable object as the value for this DynAny object.
      void DynAny.insert_wchar(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void DynAny.insert_wstring(String value)
      Deprecated.
      Inserts the given String as the value for this DynAny object.
      void DynFixed.set_value(byte[] val)
      Deprecated.
      Sets the given fixed type instance as the value for this DynFixed object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.DynAnyPackage.TypeMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.DynAnyPackage.TypeMismatch

  • Packages that use TypeMismatch
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of TypeMismatch in org.omg.CORBA

      Methods in org.omg.CORBA that throw TypeMismatch
      Modifier and Type Method and Description
      Any DynAny.get_any()
      Deprecated.
      Retrieves the org.omg.CORBA.Any contained in this DynAny object.
      boolean DynAny.get_boolean()
      Deprecated.
      Retrieves the boolean contained in this DynAny object.
      char DynAny.get_char()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      double DynAny.get_double()
      Deprecated.
      Retrieves the double contained in this DynAny object.
      float DynAny.get_float()
      Deprecated.
      Retrieves the float contained in this DynAny object.
      int DynAny.get_long()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long DynAny.get_longlong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      byte DynAny.get_octet()
      Deprecated.
      Retrieves the byte contained in this DynAny object.
      Object DynAny.get_reference()
      Deprecated.
      Retrieves the org.omg.CORBA.Other contained in this DynAny object.
      short DynAny.get_short()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      String DynAny.get_string()
      Deprecated.
      Retrieves the String contained in this DynAny object.
      TypeCode DynAny.get_typecode()
      Deprecated.
      Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
      int DynAny.get_ulong()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long DynAny.get_ulonglong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      short DynAny.get_ushort()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      Serializable DynAny.get_val()
      Deprecated.
      Retrieves the java.io.Serializable object contained in this DynAny object.
      char DynAny.get_wchar()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      String DynAny.get_wstring()
      Deprecated.
      Retrieves the String contained in this DynAny object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InconsistentTypeCode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.ORBPackage

Class InconsistentTypeCode

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InconsistentTypeCode
extends UserException
    InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.

    • Constructor Summary

      Constructors
      Constructor and Description
      InconsistentTypeCode()
      Constructs an InconsistentTypeCode user exception with no reason message.
      InconsistentTypeCode(String reason)
      Constructs an InconsistentTypeCode user exception with the specified reason message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InconsistentTypeCode

        public InconsistentTypeCode()
        Constructs an InconsistentTypeCode user exception with no reason message.

      • InconsistentTypeCode

        public InconsistentTypeCode(String reason)
        Constructs an InconsistentTypeCode user exception with the specified reason message.
        Parameters:
        reason - The String containing a reason message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.ORBPackage

Class InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.ORBPackage.InvalidName
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.
    Since:
    JDK1.2
    See Also:
    ORB.resolve_initial_references(String)

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidName()
      Constructs an InvalidName exception with no reason message.
      InvalidName(String reason)
      Constructs an InvalidName exception with the specified reason message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidName

        public InvalidName()
        Constructs an InvalidName exception with no reason message.

      • InvalidName

        public InvalidName(String reason)
        Constructs an InvalidName exception with the specified reason message.
        Parameters:
        reason - the String containing a reason message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.ORBPackage (Java Platform SE 8 )

org.omg.CORBA.ORBPackage

Exceptions

  • InconsistentTypeCode
  • InvalidName


org.omg.CORBA.ORBPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA.ORBPackage

Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.

See: Description

  • Exception Summary
    Exception Description
    InconsistentTypeCode
    InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
    InvalidName
    The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

Package org.omg.CORBA.ORBPackage Description

Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.

Related Documentation

For an overview, please see:
  • comments on the CORBA package
Since:
JDK1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.ORBPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA.ORBPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
          • org.omg.CORBA.ORBPackage.InvalidName
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA.ORBPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA.ORBPackage

  • Packages that use org.omg.CORBA.ORBPackage
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
  • Classes in org.omg.CORBA.ORBPackage used by org.omg.CORBA
    Class and Description
    InconsistentTypeCode
    InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
    InvalidName
    The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ORBPackage.InconsistentTypeCode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ORBPackage.InconsistentTypeCode

  • Packages that use InconsistentTypeCode
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InconsistentTypeCode in org.omg.CORBA

      Methods in org.omg.CORBA that throw InconsistentTypeCode
      Modifier and Type Method and Description
      DynAny ORB.create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynArray ORB.create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynEnum ORB.create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynSequence ORB.create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynStruct ORB.create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynUnion ORB.create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.ORBPackage.InvalidName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.ORBPackage.InvalidName

  • Packages that use InvalidName
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InvalidName in org.omg.CORBA

      Methods in org.omg.CORBA that throw InvalidName
      Modifier and Type Method and Description
      abstract Object ORB.resolve_initial_references(String object_name)
      Resolves a specific object reference from the set of available initial service names.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ApplicationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class ApplicationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.portable.ApplicationException
  • All Implemented Interfaces:
    Serializable

    public class ApplicationException
extends Exception
    This class is used for reporting application level exceptions between ORBs and stubs.

    • Constructor Summary

      Constructors
      Constructor and Description
      ApplicationException(String id, InputStream ins)
      Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getId()
      Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.
      InputStream getInputStream()
      Returns the input stream from which the exception data can be read as its parameters.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ApplicationException

        public ApplicationException(String id,
                            InputStream ins)
        Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.
        Parameters:
        id - the repository id of the user exception
        ins - the stream which contains the user exception data

    • Method Detail

      • getId

        public String getId()
        Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.
        Returns:
        The CORBA repository ID of this exception

      • getInputStream

        public InputStream getInputStream()
        Returns the input stream from which the exception data can be read as its parameters.
        Returns:
        The stream which contains the user exception data
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BoxedValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface BoxedValueHelper

  • All Known Implementing Classes:
    StringValueHelper, WStringValueHelper

    public interface BoxedValueHelper

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type | Method and Description
      String get_id()
      Serializable | read_value(InputStream is)
      void | write_value(OutputStream os, Serializable value)

    • Method Detail

      • read_value

        Serializable read_value(InputStream is)

      • write_value

        void write_value(OutputStream os,
                 Serializable value)

      • get_id

        String get_id()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CustomValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface CustomValue

  • All Superinterfaces:
    CustomMarshal, IDLEntity, Serializable, ValueBase

    public interface CustomValue
extends ValueBase, CustomMarshal
    An extension of ValueBase that is implemented by custom value types.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

      • Methods inherited from interface org.omg.CORBA.CustomMarshal

        marshal, unmarshal
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Delegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class Delegate

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
  • Direct Known Subclasses:
    Delegate

    public abstract class Delegate
extends Object
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods. Each stub (proxy) contains a delegate object, to which all org.omg.CORBA.Object methods are forwarded. This allows a stub generated by one vendor's ORB to work with the delegate from another vendor's ORB.
    See Also:
    Object

    • Constructor Summary

      Constructors
      Constructor and Description
      Delegate()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Object duplicate(Object obj)
      Returns a duplicate of the object reference provided.
      boolean equals(Object self, Object obj)
      Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
      DomainManager[] get_domain_managers(Object self)
      Retrieves the DomainManagers of this object.
      abstract Object get_interface_def(Object self)
      Return an InterfaceDef for the object reference provided.
      Policy get_policy(Object self, int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      abstract int hash(Object obj, int max)
      Returns an ORB-internal identifier (hashcode) for this object reference.
      int hashCode(Object self)
      Provides the implementation to override the hashCode() method of the delegating CORBA object.
      InputStream invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      abstract boolean is_a(Object obj, String repository_id)
      Checks if the object reference is an instance of the given interface.
      abstract boolean is_equivalent(Object obj, Object other)
      Determines if the two object references are equivalent.
      boolean is_local(Object self)
      Returns true if this object is implemented by a local servant.
      abstract boolean non_existent(Object obj)
      Determines whether the server object for the object reference has been destroyed.
      ORB orb(Object obj)
      Provides a reference to the orb associated with its parameter.
      abstract void release(Object obj)
      Releases resources associated with the object reference provided.
      void releaseReply(Object self, InputStream input)
      releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
      abstract Request request(Object obj, String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      OutputStream request(Object self, String operation, boolean responseExpected)
      request is called by a stub to obtain an OutputStream for marshaling arguments.
      void servant_postinvoke(Object self, ServantObject servant)
      servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
      ServantObject servant_preinvoke(Object self, String operation, Class expectedType)
      Returns a Java reference to the servant which should be used for this request.
      Object set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
      String toString(Object self)
      Provides the implementation to override the toString() method of the delegating CORBA object.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Delegate

        public Delegate()

    • Method Detail

      • get_interface_def

        public abstract Object get_interface_def(Object self)
        Return an InterfaceDef for the object reference provided.
        Parameters:
        self - The object reference whose InterfaceDef needs to be returned
        Returns:
        the InterfaceDef

      • duplicate

        public abstract Object duplicate(Object obj)
        Returns a duplicate of the object reference provided.
        Parameters:
        obj - The object reference whose duplicate needs to be returned
        Returns:
        the duplicate object reference

      • release

        public abstract void release(Object obj)
        Releases resources associated with the object reference provided.
        Parameters:
        obj - The object reference whose resources need to be released

      • is_a

        public abstract boolean is_a(Object obj,
                             String repository_id)
        Checks if the object reference is an instance of the given interface.
        Parameters:
        obj - The object reference to be checked.
        repository_id - The repository identifier of the interface to check against.
        Returns:
        true if the object reference supports the interface

      • non_existent

        public abstract boolean non_existent(Object obj)
        Determines whether the server object for the object reference has been destroyed.
        Parameters:
        obj - The object reference which delegated to this delegate.
        Returns:
        true if the ORB knows authoritatively that the server object does not exist, false otherwise

      • is_equivalent

        public abstract boolean is_equivalent(Object obj,
                                      Object other)
        Determines if the two object references are equivalent.
        Parameters:
        obj - The object reference which delegated to this delegate.
        other - The object reference to check equivalence against.
        Returns:
        true if the objects are CORBA-equivalent.

      • hash

        public abstract int hash(Object obj,
                         int max)
        Returns an ORB-internal identifier (hashcode) for this object reference.
        Parameters:
        obj - The object reference which delegated to this delegate.
        max - specifies an upper bound on the hash value returned by the ORB.
        Returns:
        ORB-internal hash identifier for object reference

      • request

        public abstract Request request(Object obj,
                                String operation)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        Parameters:
        obj - The object reference which delegated to this delegate.
        operation - The name of the operation to be invoked using the Request instance.
        Returns:
        the created Request instance

      • create_request

        public abstract Request create_request(Object obj,
                                       Context ctx,
                                       String operation,
                                       NVList arg_list,
                                       NamedValue result)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        Parameters:
        obj - The object reference which delegated to this delegate.
        ctx - The context to be used.
        operation - The name of the operation to be invoked.
        arg_list - The arguments to the operation in the form of an NVList.
        result - A container for the result as a NamedValue.
        Returns:
        The created Request object.

      • create_request

        public abstract Request create_request(Object obj,
                                       Context ctx,
                                       String operation,
                                       NVList arg_list,
                                       NamedValue result,
                                       ExceptionList exclist,
                                       ContextList ctxlist)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        Parameters:
        obj - The object reference which delegated to this delegate.
        ctx - The context to be used.
        operation - The name of the operation to be invoked.
        arg_list - The arguments to the operation in the form of an NVList.
        result - A container for the result as a NamedValue.
        exclist - A list of possible exceptions the operation can throw.
        ctxlist - A list of context strings that need to be resolved and sent with the Request.
        Returns:
        The created Request object.

      • orb

        public ORB orb(Object obj)
        Provides a reference to the orb associated with its parameter.
        Parameters:
        obj - the object reference which delegated to this delegate.
        Returns:
        the associated orb.
        See Also:
        portable package comments for unimplemented features

      • get_policy

        public Policy get_policy(Object self,
                         int policy_type)
        Returns the Policy object of the specified type which applies to this object.
        Parameters:
        self - The object reference which delegated to this delegate.
        policy_type - The type of policy to be obtained.
        Returns:
        A Policy object of the type specified by the policy_type parameter.
        Throws:
        BAD_PARAM - raised when the value of policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object.
        See Also:
        portable package comments for unimplemented features

      • get_domain_managers

        public DomainManager[] get_domain_managers(Object self)
        Retrieves the DomainManagers of this object. This allows administration services (and applications) to retrieve the domain managers, and hence the security and other policies applicable to individual objects that are members of the domain.
        Parameters:
        self - The object reference which delegated to this delegate.
        Returns:
        The list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.
        See Also:
        portable package comments for unimplemented features

      • set_policy_override

        public Object set_policy_override(Object self,
                                  Policy[] policies,
                                  SetOverrideType set_add)
        Associates the policies passed in with a newly created object reference that it returns. Only certain policies that pertain to the invocation of an operation at the client end can be overridden using this operation. Attempts to override any other policy will result in the raising of the CORBA::NO_PERMISSION exception.
        Parameters:
        self - The object reference which delegated to this delegate.
        policies - A sequence of references to Policy objects.
        set_add - Indicates whether these policies should be added onto any otheroverrides that already exist (ADD_OVERRIDE) in the object reference, or they should be added to a clean override free object reference (SET_OVERRIDE).
        Returns:
        A new object reference with the new policies associated with it.
        See Also:
        portable package comments for unimplemented features

      • is_local

        public boolean is_local(Object self)
        Returns true if this object is implemented by a local servant.
        Parameters:
        self - The object reference which delegated to this delegate.
        Returns:
        true only if the servant incarnating this object is located in this Java VM. Return false if the servant is not local or the ORB does not support local stubs for this particular servant. The default behavior of is_local() is to return false.

      • servant_preinvoke

        public ServantObject servant_preinvoke(Object self,
                                       String operation,
                                       Class expectedType)
        Returns a Java reference to the servant which should be used for this request. servant_preinvoke() is invoked by a local stub. If a ServantObject object is returned, then its servant field has been set to an object of the expected type (Note: the object may or may not be the actual servant instance). The local stub may cast the servant field to the expected type, and then invoke the operation directly. The ServantRequest object is valid for only one invocation, and cannot be used for more than one invocation.
        Parameters:
        self - The object reference which delegated to this delegate.
        operation - a string containing the operation name. The operation name corresponds to the operation name as it would be encoded in a GIOP request.
        expectedType - a Class object representing the expected type of the servant. The expected type is the Class object associated with the operations class of the stub's interface (e.g. A stub for an interface Foo, would pass the Class object for the FooOperations interface).
        Returns:
        a ServantObject object. The method may return a null value if it does not wish to support this optimization (e.g. due to security, transactions, etc). The method must return null if the servant is not of the expected type.

      • servant_postinvoke

        public void servant_postinvoke(Object self,
                               ServantObject servant)
        servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant. This method must be called if servant_preinvoke() returned a non-null value, even if an exception was thrown by the servant's method. For this reason, the call to servant_postinvoke() should be placed in a Java finally clause.
        Parameters:
        self - The object reference which delegated to this delegate.
        servant - the instance of the ServantObject returned from the servant_preinvoke() method.

      • request

        public OutputStream request(Object self,
                            String operation,
                            boolean responseExpected)
        request is called by a stub to obtain an OutputStream for marshaling arguments. The stub must supply the operation name, and indicate if a response is expected (i.e is this a oneway call).
        Parameters:
        self - The object reference which delegated to this delegate.
        operation - a string containing the operation name. The operation name corresponds to the operation name as it would be encoded in a GIOP request.
        responseExpected - false if the operation is a one way operation, and true otherwise.
        Returns:
        OutputStream the OutputStream into which request arguments can be marshaled.
        See Also:
        portable package comments for unimplemented features

      • invoke

        public InputStream invoke(Object self,
                          OutputStream output)
                   throws ApplicationException,
                          RemarshalException
        invoke is called by a stub to invoke an operation. The stub provides an OutputStream that was previously returned by a request() call. invoke returns an InputStream which contains the marshaled reply. If an exception occurs, invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.
        Parameters:
        self - The object reference which delegated to this delegate.
        output - the OutputStream which contains marshaled arguments
        Returns:
        input the InputStream from which reply parameters can be unmarshaled.
        Throws:
        ApplicationException - thrown when implementation throws (upon invocation) an exception defined as part of its remote method definition.
        RemarshalException - thrown when remarshalling fails.
        See Also:
        portable package comments for unimplemented features

      • releaseReply

        public void releaseReply(Object self,
                         InputStream input)
        releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed. The stub passes the InputStream returned by invoke() or ApplicationException.getInputStream(). A null value may also be passed to releaseReply, in which case the method is a noop.
        Parameters:
        self - The object reference which delegated to this delegate.
        input - the InputStream returned from invoke().
        See Also:
        portable package comments for unimplemented features

      • toString

        public String toString(Object self)
        Provides the implementation to override the toString() method of the delegating CORBA object.
        Parameters:
        self - the object reference that delegated to this delegate
        Returns:
        a String object that represents the object reference that delegated to this Delegate object

      • hashCode

        public int hashCode(Object self)
        Provides the implementation to override the hashCode() method of the delegating CORBA object.
        Parameters:
        self - the object reference that delegated to this delegate
        Returns:
        an int that represents the hashcode for the object reference that delegated to this Delegate object

      • equals

        public boolean equals(Object self,
                      Object obj)
        Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
        Parameters:
        self - the object reference that delegated to this delegate
        obj - the Object with which to compare
        Returns:
        true if obj equals self; false otherwise
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IDLEntity (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface IDLEntity

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, CustomValue, DataInputStream, DataOutputStream, DomainManager, DynAny, DynAnyFactory, DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ObjectReferenceFactory, ObjectReferenceTemplate, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, StreamableValue, ThreadPolicy, ValueBase
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, Any, BadKind, Binding, BindingType, Bounds, Bounds, CannotProceed, CompletionStatus, DefinitionKind, DuplicateName, Encoding, FormatMismatch, ForwardRequest, ForwardRequest, IdAssignmentPolicyValue, IdUniquenessPolicyValue, ImplicitActivationPolicyValue, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, IOR, LifespanPolicyValue, NameComponent, NameDynAnyPair, NameValuePair, NameValuePair, NoContext, NoServant, NotEmpty, NotFound, NotFoundReason, ObjectAlreadyActive, ObjectNotActive, Parameter, ParameterMode, PolicyError, RequestProcessingPolicyValue, ServantAlreadyActive, ServantNotActive, ServantRetentionPolicyValue, ServiceContext, ServiceDetail, ServiceInformation, SetOverrideType, State, StructMember, TaggedComponent, TaggedProfile, ThreadPolicyValue, TypeCode, TypeMismatch, TypeMismatch, TypeMismatch, UnionMember, UnknownEncoding, UnknownUserException, UserException, ValueMember, WrongAdapter, WrongPolicy, WrongTransaction

    public interface IDLEntity
extends Serializable
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class. RMI IIOP serialization looks for such a marker to perform marshalling/unmarshalling.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IndirectionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class IndirectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.IndirectionException
  • All Implemented Interfaces:
    Serializable

    public class IndirectionException
extends SystemException
    The Indirection exception is a Java specific system exception. It is thrown when the ORB's input stream is called to demarshal a value that is encoded as an indirection that is in the process of being demarshaled. This can occur when the ORB input stream calls the ValueHandler to demarshal an RMI value whose state contains a recursive reference to itself. Because the top-level ValueHandler.read_value() call has not yet returned a value, the ORB input stream's indirection table does not contain an entry for an object with the stream offset specified by the indirection tag. The stream offset is returned in the exception's offset field.
    See Also:
    InputStream, OutputStream

    • Field Summary

      Fields
      Modifier and Type Field and Description
      int offset
      Points to the stream's offset.

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      IndirectionException(int offset)
      Creates an IndirectionException with the right offset value.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • offset

        public int offset
        Points to the stream's offset.

    • Constructor Detail

      • IndirectionException

        public IndirectionException(int offset)
        Creates an IndirectionException with the right offset value. The stream offset is returned in the exception's offset field. This exception is constructed and thrown during reading recursively defined values off of a stream.
        Parameters:
        offset - the stream offset where recursion is detected.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class InputStream

  • java.lang.Object
    • java.io.InputStream
      • org.omg.CORBA.portable.InputStream
  • All Implemented Interfaces:
    Closeable, AutoCloseable
    Direct Known Subclasses:
    InputStream

    public abstract class InputStream
extends InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams. These methods are used by the ORB to unmarshal IDL types as well as to extract IDL types out of Anys. The _array versions of the methods can be directly used to read sequences and arrays of IDL types.
    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      InputStream()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      ORB orb()
      Returns the ORB that created this InputStream.
      abstract Any read_any()
      Reads an Any from this input stream.
      abstract void read_boolean_array(boolean[] value, int offset, int length)
      Reads an array of booleans from this input stream.
      abstract boolean read_boolean()
      Reads a boolean value from this input stream.
      abstract void read_char_array(char[] value, int offset, int length)
      Reads an array of chars from this input stream.
      abstract char read_char()
      Reads a char value from this input stream.
      Context read_Context()
      Reads a CORBA context from the stream.
      abstract void read_double_array(double[] value, int offset, int length)
      Reads an array of doubles from this input stream.
      abstract double read_double()
      Reads a double value from this input stream.
      BigDecimal read_fixed()
      Reads a BigDecimal number.
      abstract void read_float_array(float[] value, int offset, int length)
      Reads an array of floats from this input stream.
      abstract float read_float()
      Reads a float value from this input stream.
      abstract void read_long_array(int[] value, int offset, int length)
      Reads an array of CORBA longs (that is, Java ints) from this input stream.
      abstract int read_long()
      Reads a CORBA long (that is, Java int) value from this input stream.
      abstract void read_longlong_array(long[] value, int offset, int length)
      Reads an array of CORBA longlongs (that is, Java longs) from this input stream.
      abstract long read_longlong()
      Reads a CORBA longlong (that is, Java long) value from this input stream.
      abstract Object read_Object()
      Reads a CORBA object from this input stream.
      Object read_Object(Class clz)
      Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument.
      abstract void read_octet_array(byte[] value, int offset, int length)
      Reads an array of octets (that is, bytes) from this input stream.
      abstract byte read_octet()
      Reads an octet (that is, a byte) value from this input stream.
      Principal read_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract void read_short_array(short[] value, int offset, int length)
      Reads an array of shorts from this input stream.
      abstract short read_short()
      Reads a short value from this input stream.
      abstract String read_string()
      Reads a string value from this input stream.
      abstract TypeCode read_TypeCode()
      Reads a TypeCode from this input stream.
      abstract void read_ulong_array(int[] value, int offset, int length)
      Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.
      abstract int read_ulong()
      Reads an unsigned CORBA long (that is, Java int) value from this input stream.
      abstract void read_ulonglong_array(long[] value, int offset, int length)
      Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.
      abstract long read_ulonglong()
      Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.
      abstract void read_ushort_array(short[] value, int offset, int length)
      Reads an array of unsigned shorts from this input stream.
      abstract short read_ushort()
      Reads a unsigned short value from this input stream.
      abstract void read_wchar_array(char[] value, int offset, int length)
      Reads an array of wide chars from this input stream.
      abstract char read_wchar()
      Reads a wide char value from this input stream.
      abstract String read_wstring()
      Reads a wide string value from this input stream.
      int read()
      Reads the next byte of data from the input stream.

      • Methods inherited from class java.io.InputStream

        available, close, mark, markSupported, read, read, reset, skip

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InputStream

        public InputStream()

    • Method Detail

      • read_boolean

        public abstract boolean read_boolean()
        Reads a boolean value from this input stream.
        Returns:
        the boolean value read from this input stream

      • read_char

        public abstract char read_char()
        Reads a char value from this input stream.
        Returns:
        the char value read from this input stream

      • read_wchar

        public abstract char read_wchar()
        Reads a wide char value from this input stream.
        Returns:
        the char value read from this input stream

      • read_octet

        public abstract byte read_octet()
        Reads an octet (that is, a byte) value from this input stream.
        Returns:
        the byte value read from this input stream

      • read_short

        public abstract short read_short()
        Reads a short value from this input stream.
        Returns:
        the short value read from this input stream

      • read_ushort

        public abstract short read_ushort()
        Reads a unsigned short value from this input stream.
        Returns:
        the short value read from this input stream

      • read_long

        public abstract int read_long()
        Reads a CORBA long (that is, Java int) value from this input stream.
        Returns:
        the int value read from this input stream

      • read_ulong

        public abstract int read_ulong()
        Reads an unsigned CORBA long (that is, Java int) value from this input stream.
        Returns:
        the int value read from this input stream

      • read_longlong

        public abstract long read_longlong()
        Reads a CORBA longlong (that is, Java long) value from this input stream.
        Returns:
        the long value read from this input stream

      • read_ulonglong

        public abstract long read_ulonglong()
        Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.
        Returns:
        the long value read from this input stream

      • read_float

        public abstract float read_float()
        Reads a float value from this input stream.
        Returns:
        the float value read from this input stream

      • read_double

        public abstract double read_double()
        Reads a double value from this input stream.
        Returns:
        the double value read from this input stream

      • read_string

        public abstract String read_string()
        Reads a string value from this input stream.
        Returns:
        the String value read from this input stream

      • read_wstring

        public abstract String read_wstring()
        Reads a wide string value from this input stream.
        Returns:
        the String value read from this input stream

      • read_boolean_array

        public abstract void read_boolean_array(boolean[] value,
                                        int offset,
                                        int length)
        Reads an array of booleans from this input stream.
        Parameters:
        value - returned array of booleans.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_char_array

        public abstract void read_char_array(char[] value,
                                     int offset,
                                     int length)
        Reads an array of chars from this input stream.
        Parameters:
        value - returned array of chars.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_wchar_array

        public abstract void read_wchar_array(char[] value,
                                      int offset,
                                      int length)
        Reads an array of wide chars from this input stream.
        Parameters:
        value - returned array of wide chars.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_octet_array

        public abstract void read_octet_array(byte[] value,
                                      int offset,
                                      int length)
        Reads an array of octets (that is, bytes) from this input stream.
        Parameters:
        value - returned array of octets (that is, bytes).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_short_array

        public abstract void read_short_array(short[] value,
                                      int offset,
                                      int length)
        Reads an array of shorts from this input stream.
        Parameters:
        value - returned array of shorts.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_ushort_array

        public abstract void read_ushort_array(short[] value,
                                       int offset,
                                       int length)
        Reads an array of unsigned shorts from this input stream.
        Parameters:
        value - returned array of shorts.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_long_array

        public abstract void read_long_array(int[] value,
                                     int offset,
                                     int length)
        Reads an array of CORBA longs (that is, Java ints) from this input stream.
        Parameters:
        value - returned array of CORBA longs (that is, Java ints).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_ulong_array

        public abstract void read_ulong_array(int[] value,
                                      int offset,
                                      int length)
        Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.
        Parameters:
        value - returned array of CORBA longs (that is, Java ints).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_longlong_array

        public abstract void read_longlong_array(long[] value,
                                         int offset,
                                         int length)
        Reads an array of CORBA longlongs (that is, Java longs) from this input stream.
        Parameters:
        value - returned array of CORBA longs (that is, Java longs).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_ulonglong_array

        public abstract void read_ulonglong_array(long[] value,
                                          int offset,
                                          int length)
        Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.
        Parameters:
        value - returned array of CORBA longs (that is, Java longs).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_float_array

        public abstract void read_float_array(float[] value,
                                      int offset,
                                      int length)
        Reads an array of floats from this input stream.
        Parameters:
        value - returned array of floats.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_double_array

        public abstract void read_double_array(double[] value,
                                       int offset,
                                       int length)
        Reads an array of doubles from this input stream.
        Parameters:
        value - returned array of doubles.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_Object

        public abstract Object read_Object()
        Reads a CORBA object from this input stream.
        Returns:
        the Object instance read from this input stream.

      • read_TypeCode

        public abstract TypeCode read_TypeCode()
        Reads a TypeCode from this input stream.
        Returns:
        the TypeCode instance read from this input stream.

      • read_any

        public abstract Any read_any()
        Reads an Any from this input stream.
        Returns:
        the Any instance read from this input stream.

      • read_Principal

        @Deprecated
public Principal read_Principal()
        Deprecated. Deprecated by CORBA 2.2.
        Returns principal for invocation.
        Returns:
        Principal for invocation.

      • read

        public int read()
         throws IOException
        Description copied from class: InputStream
        Reads the next byte of data from the input stream. The value byte is returned as an int in the range 0 to 255. If no byte is available because the end of the stream has been reached, the value -1 is returned. This method blocks until input data is available, the end of the stream is detected, or an exception is thrown.

        A subclass must provide an implementation of this method.

        Specified by:
        read in class InputStream
        Returns:
        the next byte of data, or -1 if the end of the stream is reached.
        Throws:
        IOException - if an I/O error occurs.
        See Also:
        portable package comments for unimplemented features

      • read_fixed

        public BigDecimal read_fixed()
        Reads a BigDecimal number.
        Returns:
        a java.math.BigDecimal number

      • read_Context

        public Context read_Context()
        Reads a CORBA context from the stream.
        Returns:
        a CORBA context
        See Also:
        portable package comments for unimplemented features

      • read_Object

        public Object read_Object(Class clz)
        Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument. This class is the stub class of the expected type.
        Parameters:
        clz - The Class object for the stub class which corresponds to the type that is statistically expected, or the Class object for the RMI/IDL interface type that is statistically expected.
        Returns:
        an Object instance of clz read from this stream
        See Also:
        portable package comments for unimplemented features

      • orb

        public ORB orb()
        Returns the ORB that created this InputStream.
        Returns:
        the ORB object that created this stream
        See Also:
        portable package comments for unimplemented features
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvokeHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface InvokeHandler

  • All Known Subinterfaces:
    Tie
    All Known Implementing Classes:
    BindingIteratorPOA, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA

    public interface InvokeHandler
    This interface provides a dispatching mechanism for an incoming call. It is invoked by the ORB to dispatch a request to a servant.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      OutputStream _invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.

    • Method Detail

      • _invoke

        OutputStream _invoke(String method,
                     InputStream input,
                     ResponseHandler handler)
              throws SystemException
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Parameters:
        method - The method name.
        input - The InputStream containing the marshalled arguments.
        handler - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply
        Throws:
        SystemException - is thrown when invocation fails due to a CORBA system exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class ObjectImpl

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
  • All Implemented Interfaces:
    Object
    Direct Known Subclasses:
    _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, ObjectImpl

    public abstract class ObjectImpl
extends Object
implements Object
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods. All method implementations are forwarded to a Delegate object stored in the ObjectImpl instance. ObjectImpl allows for portable stubs because the Delegate can be implemented by a different vendor-specific ORB.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectImpl()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      Object _duplicate()
      Returns a duplicate of this ObjectImpl object.
      Delegate _get_delegate()
      Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
      DomainManager[] _get_domain_managers()
      Retrieves a list of the domain managers for this ObjectImpl object.
      Object _get_interface_def()
      Retrieves the interface definition for this ObjectImpl object.
      Policy _get_policy(int policy_type)
      Retrieves the Policy object for this ObjectImpl object that has the given policy type.
      int _hash(int maximum)
      Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
      abstract String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      InputStream _invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      boolean _is_a(String repository_id)
      Checks whether the object identified by the given repository identifier is an ObjectImpl object.
      boolean _is_equivalent(Object that)
      Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
      boolean _is_local()
      Checks whether this ObjectImpl object is implemented by a local servant.
      boolean _non_existent()
      Checks whether the server object for this ObjectImpl object has been destroyed.
      ORB _orb()
      Returns a reference to the ORB associated with this object and its delegate.
      void _release()
      Releases the resources associated with this ObjectImpl object.
      void _releaseReply(InputStream input)
      Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
      Request _request(String operation)
      Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
      OutputStream _request(String operation, boolean responseExpected)
      Returns an OutputStream object to use for marshalling the arguments of the given method.
      void _servant_postinvoke(ServantObject servant)
      Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
      ServantObject _servant_preinvoke(String operation, Class expectedType)
      Returns a Java reference to the local servant that should be used for sending a request for the method specified.
      void _set_delegate(Delegate delegate)
      Sets the Delegate for this ObjectImpl instance to the given Delegate object.
      Object _set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      boolean equals(Object obj)
      Compares this ObjectImpl object with the given one for equality.
      int hashCode()
      Returns the hash code for this ObjectImpl object.
      String toString()
      Returns a String object that represents this ObjectImpl object.

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectImpl

        public ObjectImpl()

    • Method Detail

      • _get_delegate

        public Delegate _get_delegate()
        Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
        Returns:
        the Delegate contained in this ObjectImpl instance
        Throws:
        BAD_OPERATION - if the delegate has not been set
        See Also:
        _set_delegate(org.omg.CORBA.portable.Delegate)

      • _set_delegate

        public void _set_delegate(Delegate delegate)
        Sets the Delegate for this ObjectImpl instance to the given Delegate object. All method invocations on this ObjectImpl object will be forwarded to this delegate.
        Parameters:
        delegate - the Delegate instance to which all method calls on this ObjectImpl object will be delegated; may be implemented by a third-party ORB
        See Also:
        _get_delegate()

      • _ids

        public abstract String[] _ids()
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance

      • _duplicate

        public Object _duplicate()
        Returns a duplicate of this ObjectImpl object.
        Specified by:
        _duplicate in interface Object
        Returns:
        an orb.omg.CORBA.Object object that is a duplicate of this object

      • _release

        public void _release()
        Releases the resources associated with this ObjectImpl object.
        Specified by:
        _release in interface Object

      • _is_a

        public boolean _is_a(String repository_id)
        Checks whether the object identified by the given repository identifier is an ObjectImpl object.
        Specified by:
        _is_a in interface Object
        Parameters:
        repository_id - a String object with the repository identifier to check
        Returns:
        true if the object identified by the given repository id is an instance of ObjectImpl; false otherwise

      • _is_equivalent

        public boolean _is_equivalent(Object that)
        Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
        Specified by:
        _is_equivalent in interface Object
        Parameters:
        that - an instance of ObjectImpl to compare with this ObjectImpl object
        Returns:
        true if the given object is equivalent to this ObjectImpl object; false otherwise

      • _non_existent

        public boolean _non_existent()
        Checks whether the server object for this ObjectImpl object has been destroyed.
        Specified by:
        _non_existent in interface Object
        Returns:
        true if the ORB knows authoritatively that the server object does not exist; false otherwise

      • _hash

        public int _hash(int maximum)
        Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
        Specified by:
        _hash in interface Object
        Parameters:
        maximum - an int indicating the upper bound on the hash value returned by the ORB
        Returns:
        an int representing the hash code for this ObjectImpl object

      • _request

        public Request _request(String operation)
        Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
        Specified by:
        _request in interface Object
        Parameters:
        operation - the method to be invoked by the new Request object
        Returns:
        a new Request object initialized with the given method

      • _create_request

        public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result)
        Creates a Request object that contains the given context, method, argument list, and container for the result.
        Specified by:
        _create_request in interface Object
        Parameters:
        ctx - the Context for the request
        operation - the method that the new Request object will invoke
        arg_list - the arguments for the method; an NVList in which each argument is a NamedValue object
        result - a NamedValue object to be used for returning the result of executing the request's method
        Returns:
        a new Request object initialized with the given context, method, argument list, and container for the return value
        See Also:
        Request, NVList, NamedValue

      • _create_request

        public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result,
                               ExceptionList exceptions,
                               ContextList contexts)
        Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings. This Request object is for use in the Dynamic Invocation Interface.
        Specified by:
        _create_request in interface Object
        Parameters:
        ctx - the Context object that contains the context strings that must be resolved before they are sent along with the request
        operation - the method that the new Request object will invoke
        arg_list - the arguments for the method; an NVList in which each argument is a NamedValue object
        result - a NamedValue object to be used for returning the result of executing the request's method
        exceptions - a list of the exceptions that the given method throws
        contexts - a list of the properties that are needed to resolve the contexts in ctx; the strings in contexts are used as arguments to the method Context.get_values, which returns the value associated with the given property
        Returns:
        a new Request object initialized with the given context strings to resolve, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings
        See Also:
        Request, NVList, NamedValue, ExceptionList, ContextList

      • _get_interface_def

        public Object _get_interface_def()
        Retrieves the interface definition for this ObjectImpl object.
        Specified by:
        _get_interface_def in interface Object
        Returns:
        the org.omg.CORBA.Object instance that is the interface definition for this ObjectImpl object

      • _orb

        public ORB _orb()
        Returns a reference to the ORB associated with this object and its delegate. This is the ORB object that created the delegate.
        Returns:
        the ORB instance that created the Delegate object contained in this ObjectImpl object

      • _get_policy

        public Policy _get_policy(int policy_type)
        Retrieves the Policy object for this ObjectImpl object that has the given policy type.
        Specified by:
        _get_policy in interface Object
        Parameters:
        policy_type - an int indicating the policy type
        Returns:
        the Policy object that is the specified policy type and that applies to this ObjectImpl object
        See Also:
        PolicyOperations.policy_type()

      • _get_domain_managers

        public DomainManager[] _get_domain_managers()
        Retrieves a list of the domain managers for this ObjectImpl object.
        Specified by:
        _get_domain_managers in interface Object
        Returns:
        an array containing the DomainManager objects for this instance of ObjectImpl

      • _set_policy_override

        public Object _set_policy_override(Policy[] policies,
                                   SetOverrideType set_add)
        Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
        Specified by:
        _set_policy_override in interface Object
        Parameters:
        policies - an array of Policy objects with the policies that will replace the current policies or be added to the current policies
        set_add - either SetOverrideType.SET_OVERRIDE, indicating that the given policies will replace any existing ones, or SetOverrideType.ADD_OVERRIDE, indicating that the given policies should be added to any existing ones
        Returns:
        an Object with the given policies replacing or added to its previous policies

      • _is_local

        public boolean _is_local()
        Checks whether this ObjectImpl object is implemented by a local servant. If so, local invocation API's may be used.
        Returns:
        true if this object is implemented by a local servant; false otherwise

      • _servant_preinvoke

        public ServantObject _servant_preinvoke(String operation,
                                        Class expectedType)
        Returns a Java reference to the local servant that should be used for sending a request for the method specified. If this ObjectImpl object is a local stub, it will invoke the _servant_preinvoke method before sending a request in order to obtain the ServantObject instance to use.

        If a ServantObject object is returned, its servant field has been set to an object of the expected type (Note: the object may or may not be the actual servant instance). The local stub may cast the servant field to the expected type, and then invoke the operation directly. The ServantRequest object is valid for only one invocation and cannot be used for more than one invocation.

        Parameters:
        operation - a String containing the name of the method to be invoked. This name should correspond to the method name as it would be encoded in a GIOP request.
        expectedType - a Class object representing the expected type of the servant that is returned. This expected type is the Class object associated with the operations class for the stub's interface. For example, a stub for an interface Foo would pass the Class object for the FooOperations interface.
        Returns:
        (1) a ServantObject object, which may or may not be the actual servant instance, or (2) null if (a) the servant is not local or (b) the servant has ceased to be local due to a ForwardRequest from a POA ServantManager
        Throws:
        BAD_PARAM - if the servant is not the expected type

      • _servant_postinvoke

        public void _servant_postinvoke(ServantObject servant)
        Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke. The _servant_postinvoke method must be called if the _servant_preinvoke method returned a non-null value, even if an exception was thrown by the method invoked by the servant. For this reason, the call to the method _servant_postinvoke should be placed in a Java finally clause.
        Parameters:
        servant - the instance of the ServantObject returned by the _servant_preinvoke method

      • _request

        public OutputStream _request(String operation,
                             boolean responseExpected)
        Returns an OutputStream object to use for marshalling the arguments of the given method. This method is called by a stub, which must indicate if a response is expected, that is, whether or not the call is oneway.
        Parameters:
        operation - a String giving the name of the method.
        responseExpected - a boolean -- true if the request is not one way, that is, a response is expected
        Returns:
        an OutputStream object for dispatching the request

      • _invoke

        public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
        Invokes an operation and returns an InputStream object for reading the response. The stub provides the OutputStream object that was previously returned by a call to the _request method. The method specified as an argument to _request when it was called previously is the method that this method invokes.

        If an exception occurs, the _invoke method may throw an ApplicationException object that contains an InputStream from which the user exception state may be unmarshalled.

        Parameters:
        output - an OutputStream object for dispatching the request
        Returns:
        an InputStream object containing the marshalled response to the method invoked
        Throws:
        ApplicationException - if the invocation meets application-defined exception
        RemarshalException - if the invocation leads to a remarshalling error
        See Also:
        _request(java.lang.String)

      • _releaseReply

        public void _releaseReply(InputStream input)
        Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke. Calling this method is optional for the stub.
        Parameters:
        input - the InputStream object that was returned by the _invoke method or the ApplicationException.getInputStream method; may be null, in which case this method does nothing
        See Also:
        _invoke(org.omg.CORBA.portable.OutputStream)

      • toString

        public String toString()
        Returns a String object that represents this ObjectImpl object.
        Overrides:
        toString in class Object
        Returns:
        the String representation of this object

      • hashCode

        public int hashCode()
        Returns the hash code for this ObjectImpl object.
        Overrides:
        hashCode in class Object
        Returns:
        the hash code for this object
        See Also:
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Compares this ObjectImpl object with the given one for equality.
        Overrides:
        equals in class Object
        Parameters:
        obj - the object with which to compare this object
        Returns:
        true if the two objects are equal; false otherwise
        See Also:
        Object.hashCode(), HashMap
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class OutputStream

  • java.lang.Object
    • java.io.OutputStream
      • org.omg.CORBA.portable.OutputStream
  • All Implemented Interfaces:
    Closeable, Flushable, AutoCloseable
    Direct Known Subclasses:
    OutputStream

    public abstract class OutputStream
extends OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams. These methods are used by the ORB to marshal IDL types as well as to insert IDL types into Anys. The _array versions of the methods can be directly used to write sequences and arrays of IDL types.
    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      OutputStream()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      abstract InputStream create_input_stream()
      Returns an input stream with the same buffer.
      ORB orb()
      Returns the ORB that created this OutputStream.
      abstract void write_any(Any value)
      Writes an Any on this output stream.
      abstract void write_boolean_array(boolean[] value, int offset, int length)
      Writes an array of booleans on this output stream.
      abstract void write_boolean(boolean value)
      Writes a boolean value to this stream.
      abstract void write_char_array(char[] value, int offset, int length)
      Writes an array of chars on this output stream.
      abstract void write_char(char value)
      Writes a char value to this stream.
      void write_Context(Context ctx, ContextList contexts)
      Writes a CORBA context on this stream.
      abstract void write_double_array(double[] value, int offset, int length)
      Writes an array of doubles on this output stream.
      abstract void write_double(double value)
      Writes a double value to this stream.
      void write_fixed(BigDecimal value)
      Writes a BigDecimal number.
      abstract void write_float_array(float[] value, int offset, int length)
      Writes an array of floats on this output stream.
      abstract void write_float(float value)
      Writes a float value to this stream.
      abstract void write_long_array(int[] value, int offset, int length)
      Writes an array of CORBA longs (i.e.
      abstract void write_long(int value)
      Writes a CORBA long (i.e.
      abstract void write_longlong_array(long[] value, int offset, int length)
      Writes an array of CORBA longlongs (i.e.
      abstract void write_longlong(long value)
      Writes a CORBA longlong (i.e.
      abstract void write_Object(Object value)
      Writes a CORBA Object on this output stream.
      abstract void write_octet_array(byte[] value, int offset, int length)
      Writes an array of CORBA octets (bytes) on this output stream.
      abstract void write_octet(byte value)
      Writes a CORBA octet (i.e.
      void write_Principal(Principal value)
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract void write_short_array(short[] value, int offset, int length)
      Writes an array of shorts on this output stream.
      abstract void write_short(short value)
      Writes a short value to this stream.
      abstract void write_string(String value)
      Writes a string value to this stream.
      abstract void write_TypeCode(TypeCode value)
      Writes a TypeCode on this output stream.
      abstract void write_ulong_array(int[] value, int offset, int length)
      Writes an array of unsigned CORBA longs (i.e.
      abstract void write_ulong(int value)
      Writes an unsigned CORBA long (i.e.
      abstract void write_ulonglong_array(long[] value, int offset, int length)
      Writes an array of unsigned CORBA longlongs (i.e.
      abstract void write_ulonglong(long value)
      Writes an unsigned CORBA longlong (i.e.
      abstract void write_ushort_array(short[] value, int offset, int length)
      Writes an array of unsigned shorts on this output stream.
      abstract void write_ushort(short value)
      Writes an unsigned short value to this stream.
      abstract void write_wchar_array(char[] value, int offset, int length)
      Writes an array of wide chars on this output stream.
      abstract void write_wchar(char value)
      Writes a wide char value to this stream.
      abstract void write_wstring(String value)
      Writes a wide string value to this stream.
      void write(int b)
      Writes an integer (length of arrays) onto this stream.

      • Methods inherited from class java.io.OutputStream

        close, flush, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • OutputStream

        public OutputStream()

    • Method Detail

      • create_input_stream

        public abstract InputStream create_input_stream()
        Returns an input stream with the same buffer.
        Returns:
        an input stream with the same buffer.

      • write_boolean

        public abstract void write_boolean(boolean value)
        Writes a boolean value to this stream.
        Parameters:
        value - the value to be written.

      • write_char

        public abstract void write_char(char value)
        Writes a char value to this stream.
        Parameters:
        value - the value to be written.

      • write_wchar

        public abstract void write_wchar(char value)
        Writes a wide char value to this stream.
        Parameters:
        value - the value to be written.

      • write_octet

        public abstract void write_octet(byte value)
        Writes a CORBA octet (i.e. byte) value to this stream.
        Parameters:
        value - the value to be written.

      • write_short

        public abstract void write_short(short value)
        Writes a short value to this stream.
        Parameters:
        value - the value to be written.

      • write_ushort

        public abstract void write_ushort(short value)
        Writes an unsigned short value to this stream.
        Parameters:
        value - the value to be written.

      • write_long

        public abstract void write_long(int value)
        Writes a CORBA long (i.e. Java int) value to this stream.
        Parameters:
        value - the value to be written.

      • write_ulong

        public abstract void write_ulong(int value)
        Writes an unsigned CORBA long (i.e. Java int) value to this stream.
        Parameters:
        value - the value to be written.

      • write_longlong

        public abstract void write_longlong(long value)
        Writes a CORBA longlong (i.e. Java long) value to this stream.
        Parameters:
        value - the value to be written.

      • write_ulonglong

        public abstract void write_ulonglong(long value)
        Writes an unsigned CORBA longlong (i.e. Java long) value to this stream.
        Parameters:
        value - the value to be written.

      • write_float

        public abstract void write_float(float value)
        Writes a float value to this stream.
        Parameters:
        value - the value to be written.

      • write_double

        public abstract void write_double(double value)
        Writes a double value to this stream.
        Parameters:
        value - the value to be written.

      • write_string

        public abstract void write_string(String value)
        Writes a string value to this stream.
        Parameters:
        value - the value to be written.

      • write_wstring

        public abstract void write_wstring(String value)
        Writes a wide string value to this stream.
        Parameters:
        value - the value to be written.

      • write_boolean_array

        public abstract void write_boolean_array(boolean[] value,
                                         int offset,
                                         int length)
        Writes an array of booleans on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_char_array

        public abstract void write_char_array(char[] value,
                                      int offset,
                                      int length)
        Writes an array of chars on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_wchar_array

        public abstract void write_wchar_array(char[] value,
                                       int offset,
                                       int length)
        Writes an array of wide chars on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_octet_array

        public abstract void write_octet_array(byte[] value,
                                       int offset,
                                       int length)
        Writes an array of CORBA octets (bytes) on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_short_array

        public abstract void write_short_array(short[] value,
                                       int offset,
                                       int length)
        Writes an array of shorts on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_ushort_array

        public abstract void write_ushort_array(short[] value,
                                        int offset,
                                        int length)
        Writes an array of unsigned shorts on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_long_array

        public abstract void write_long_array(int[] value,
                                      int offset,
                                      int length)
        Writes an array of CORBA longs (i.e. Java ints) on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_ulong_array

        public abstract void write_ulong_array(int[] value,
                                       int offset,
                                       int length)
        Writes an array of unsigned CORBA longs (i.e. Java ints) on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_longlong_array

        public abstract void write_longlong_array(long[] value,
                                          int offset,
                                          int length)
        Writes an array of CORBA longlongs (i.e. Java longs) on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_ulonglong_array

        public abstract void write_ulonglong_array(long[] value,
                                           int offset,
                                           int length)
        Writes an array of unsigned CORBA longlongs (i.e. Java ints) on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_float_array

        public abstract void write_float_array(float[] value,
                                       int offset,
                                       int length)
        Writes an array of floats on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_double_array

        public abstract void write_double_array(double[] value,
                                        int offset,
                                        int length)
        Writes an array of doubles on this output stream.
        Parameters:
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_Object

        public abstract void write_Object(Object value)
        Writes a CORBA Object on this output stream.
        Parameters:
        value - the value to be written.

      • write_TypeCode

        public abstract void write_TypeCode(TypeCode value)
        Writes a TypeCode on this output stream.
        Parameters:
        value - the value to be written.

      • write_any

        public abstract void write_any(Any value)
        Writes an Any on this output stream.
        Parameters:
        value - the value to be written.

      • write_Principal

        @Deprecated
public void write_Principal(Principal value)
        Deprecated. Deprecated by CORBA 2.2.
        Writes a Principle on this output stream.
        Parameters:
        value - the value to be written.

      • write

        public void write(int b)
           throws IOException
        Writes an integer (length of arrays) onto this stream.
        Specified by:
        write in class OutputStream
        Parameters:
        b - the value to be written.
        Throws:
        IOException - if there is an input/output error
        See Also:
        portable package comments for unimplemented features

      • write_fixed

        public void write_fixed(BigDecimal value)
        Writes a BigDecimal number.
        Parameters:
        value - a BidDecimal--value to be written.

      • write_Context

        public void write_Context(Context ctx,
                          ContextList contexts)
        Writes a CORBA context on this stream. The Context is marshaled as a sequence of strings. Only those Context values specified in the contexts parameter are actually written.
        Parameters:
        ctx - a CORBA context
        contexts - a ContextList object containing the list of contexts to be written
        See Also:
        portable package comments for unimplemented features

      • orb

        public ORB orb()
        Returns the ORB that created this OutputStream.
        Returns:
        the ORB that created this OutputStream
        See Also:
        portable package comments for unimplemented features
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.portable (Java Platform SE 8 )

org.omg.CORBA.portable

Interfaces

  • BoxedValueHelper
  • CustomValue
  • IDLEntity
  • InvokeHandler
  • ResponseHandler
  • Streamable
  • StreamableValue
  • ValueBase
  • ValueFactory
  • ValueInputStream
  • ValueOutputStream

Classes

  • Delegate
  • InputStream
  • ObjectImpl
  • OutputStream
  • ServantObject

Exceptions

  • ApplicationException
  • IndirectionException
  • RemarshalException
  • UnknownException


org.omg.CORBA.portable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA.portable

Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

See: Description

  • Interface Summary
    Interface Description
    BoxedValueHelper
    CustomValue
    An extension of ValueBase that is implemented by custom value types.
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    StreamableValue
    Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
    ValueFactory
    The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory.
    ValueInputStream
    Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.
    ValueOutputStream
    Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.
  • Class Summary
    Class Description
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    ServantObject
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.
  • Exception Summary
    Exception Description
    ApplicationException
    This class is used for reporting application level exceptions between ORBs and stubs.
    IndirectionException
    The Indirection exception is a Java specific system exception.
    RemarshalException
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
    UnknownException
    The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs.

Package org.omg.CORBA.portable Description

Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB. Stubs and other code, generated either from IDL or interfaces written in the Java programming language, can call into these ORB APIs.

CORBA Features Throwing NO_IMPLEMENT() Exceptions

Some methods throw NO_IMPLEMENT() exceptions by default, but ORB vendors can override them to provide real implementations. The ORB included in Sun's release of the Java[tm] Platform, Standard Edition 6, includes implementations for the following methods.

List of Unimplemented Features in Package org.omg.CORBA.portable

Unimplemented Interfaces in package org.omg.CORBA.portable

  • InvokeHandler
  • ResponseHandler

Unimplemented Methods in package org.omg.CORBA.portable

  • InputStream
    • public int read()
    • public.math.BigDecimal read_fixed()
    • public org.omg.CORBA.Context read_Context()
    • public org.omg.CORBA.Object read_Object(java.lang.Class clz)
    • public org.omg.CORBA.ORB orb()
  • OutputStream
    • public org.omg.CORBA.ORB orb()
    • public void write_Context(org.omg.CORBA.Context ctx, org.omg.CORBA.ContextList contexts)
    • public void write_fixed(java.math.BigDecimal value)
    • public void write(int b)
  • Delegate
    • public void releaseReply(org.omg.CORBA.Object self, InputStream input)
    • public InputStream invoke(org.omg.CORBA.Object self, OutputStream output)
    • public OutputStream request(org.omg.CORBA.Object self, String operation, boolean responseExpected)
    • public org.omg.CORBA.Object set_policy_override(org.omg.CORBA.Object self, org.omg.CORBA.Policy[] policies, org.omg.CORBA.SetOverrideType set_add)
    • public org.omg.CORBA.DomainManager[] get_domain_managers( org.omg.CORBA.Object self)
    • public org.omg.CORBA.Policy get_policy(org.omg.CORBA.Object self, int policy_type)
Since:
JDK1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.portable Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA.portable

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
    • java.io.InputStream (implements java.io.Closeable)
      • org.omg.CORBA.portable.InputStream
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.omg.CORBA.portable.OutputStream
    • org.omg.CORBA.portable.ServantObject
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.portable.ApplicationException
        • org.omg.CORBA.portable.RemarshalException
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.IndirectionException
            • org.omg.CORBA.portable.UnknownException

Interface Hierarchy

  • org.omg.CORBA.portable.BoxedValueHelper
  • org.omg.CORBA.CustomMarshal
    • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.portable.ValueBase)
  • org.omg.CORBA.portable.InvokeHandler
  • org.omg.CORBA.portable.ResponseHandler
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal)
        • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable)
  • org.omg.CORBA.portable.Streamable
    • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.ValueBase)
  • org.omg.CORBA.portable.ValueFactory
  • org.omg.CORBA.portable.ValueInputStream
  • org.omg.CORBA.portable.ValueOutputStream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA.portable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA.portable

  • Packages that use org.omg.CORBA.portable
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in org.omg.CORBA.portable used by javax.rmi.CORBA
    Class and Description
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA
    Class and Description
    ApplicationException
    This class is used for reporting application level exceptions between ORBs and stubs.
    BoxedValueHelper
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    RemarshalException
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
    ServantObject
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.DynAnyPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.ORBPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.TypeCodePackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.portable
    Class and Description
    ApplicationException
    This class is used for reporting application level exceptions between ORBs and stubs.
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    RemarshalException
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
    ServantObject
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA_2_3
    Class and Description
    ValueFactory
    The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA_2_3.portable
    Class and Description
    BoxedValueHelper
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.CosNaming
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.CosNaming.NamingContextExtPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.CosNaming.NamingContextPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.Dynamic
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.DynamicAny
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.DynamicAny.DynAnyFactoryPackage
    Class and Description
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.DynamicAny.DynAnyPackage
    Class and Description
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.IOP
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.IOP.CodecFactoryPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.IOP.CodecPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.Messaging
    Class and Description
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableInterceptor
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableInterceptor.ORBInitInfoPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.CurrentPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.POAManagerPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.POAPackage
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.ServantLocatorPackage
    Class and Description
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.SendingContext
    Class and Description
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.stub.java.rmi
    Class and Description
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RemarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class RemarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.portable.RemarshalException
  • All Implemented Interfaces:
    Serializable

    public final class RemarshalException
extends Exception
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB. In this case the ORB must remarshal the request before trying again. Stubs which use the stream-based model shall catch the RemarshalException which is potentially thrown from the _invoke() method of ObjectImpl. Upon catching the exception, the stub shall immediately remarshal the request by calling _request(), marshalling the arguments (if any), and then calling _invoke(). The stub shall repeat this process until _invoke() returns normally or raises some exception other than RemarshalException.

    • Constructor Summary

      Constructors
      Constructor and Description
      RemarshalException()
      Constructs a RemarshalException.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • RemarshalException

        public RemarshalException()
        Constructs a RemarshalException.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ResponseHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface ResponseHandler

  • public interface ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      OutputStream createExceptionReply()
      Called by the servant during a method invocation.
      OutputStream createReply()
      Called by the servant during a method invocation.

    • Method Detail

      • createReply

        OutputStream createReply()
        Called by the servant during a method invocation. The servant should call this method to create a reply marshal buffer if no exception occurred.
        Returns:
        an OutputStream suitable for marshalling the reply.
        See Also:
        portable package comments for unimplemented features

      • createExceptionReply

        OutputStream createExceptionReply()
        Called by the servant during a method invocation. The servant should call this method to create a reply marshal buffer if a user exception occurred.
        Returns:
        an OutputStream suitable for marshalling the exception ID and the user exception body.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class ServantObject

  • java.lang.Object
    • org.omg.CORBA.portable.ServantObject

  • public class ServantObject
extends Object
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e. clients and servers residing in the same Java VM). The local stub API is supported via three additional methods on ObjectImpl and Delegate. ORB vendors may subclass this class to return additional request state that may be required by their implementations.
    See Also:
    ObjectImpl, Delegate

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object servant
      The real servant.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantObject()

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • servant

        public Object servant
        The real servant. The local stub may cast this field to the expected type, and then invoke the operation directly. Note, the object may or may not be the actual servant instance.

    • Constructor Detail

      • ServantObject

        public ServantObject()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Streamable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface Streamable

  • All Known Subinterfaces:
    StreamableValue
    All Known Implementing Classes:
    AlreadyBoundHolder, AnyHolder, AnySeqHolder, BindingHolder, BindingIteratorHolder, BindingListHolder, BindingTypeHolder, BooleanHolder, BooleanSeqHolder, ByteHolder, CannotProceedHolder, CharHolder, CharSeqHolder, CookieHolder, CurrentHolder, DoubleHolder, DoubleSeqHolder, FixedHolder, FloatHolder, FloatSeqHolder, IntHolder, InvalidAddressHolder, InvalidNameHolder, IORHolder, IORInterceptor_3_0Holder, LongHolder, LongLongSeqHolder, LongSeqHolder, MultipleComponentProfileHolder, NameComponentHolder, NameHolder, NamingContextExtHolder, NamingContextHolder, NotEmptyHolder, NotFoundHolder, NotFoundReasonHolder, ObjectHolder, ObjectReferenceFactoryHolder, ObjectReferenceTemplateHolder, ObjectReferenceTemplateSeqHolder, OctetSeqHolder, ParameterModeHolder, PolicyErrorHolder, PolicyHolder, PolicyListHolder, PrincipalHolder, ServiceContextHolder, ServiceContextListHolder, ServiceInformationHolder, ShortHolder, ShortSeqHolder, StringHolder, StringSeqHolder, TaggedComponentHolder, TaggedProfileHolder, TypeCodeHolder, ULongLongSeqHolder, ULongSeqHolder, UnknownUserExceptionHolder, UShortSeqHolder, ValueBaseHolder, WCharSeqHolder, WrongTransactionHolder, WStringSeqHolder

    public interface Streamable
    The base class for the Holder classess of all complex IDL types. The ORB treats all generated Holders as Streamable to invoke the methods for marshalling and unmarshalling.
    Since:
    JDK1.2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void _read(InputStream istream)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream ostream)
      Marshals to ostream the value in the value field of the Holder.

    • Method Detail

      • _read

        void _read(InputStream istream)
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Parameters:
        istream - the InputStream that represents the CDR data from the wire.

      • _write

        void _write(OutputStream ostream)
        Marshals to ostream the value in the value field of the Holder.
        Parameters:
        ostream - the CDR OutputStream

      • _type

        TypeCode _type()
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StreamableValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface StreamableValue

  • All Superinterfaces:
    IDLEntity, Serializable, Streamable, ValueBase

    public interface StreamableValue
extends Streamable, ValueBase
    Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled. All value types implement ValueBase either directly or indirectly by implementing either the StreamableValue or CustomValue interface.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.portable.Streamable

        _read, _type, _write

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnknownException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Class UnknownException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.UnknownException
  • All Implemented Interfaces:
    Serializable

    public class UnknownException
extends SystemException
    The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs. It provides a Java representation of an UNKNOWN system exception that has an UnknownExceptionInfo service context. If the CORBA system exception org.omg.CORBA.portable.UnknownException is thrown, then the stub does one of the following: (1) Translates it to org.omg.CORBA.UNKNOWN. (2) Translates it to the nested exception that the UnknownException contains. (3) Passes it on directly to the user.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Throwable originalEx
      A throwable--the original exception that was wrapped in a CORBA UnknownException.

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownException(Throwable ex)
      Constructs an UnknownException object.

    • Method Summary

      • Methods inherited from class org.omg.CORBA.SystemException

        toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • originalEx

        public Throwable originalEx
        A throwable--the original exception that was wrapped in a CORBA UnknownException.

    • Constructor Detail

      • UnknownException

        public UnknownException(Throwable ex)
        Constructs an UnknownException object.
        Parameters:
        ex - a Throwable object--to be wrapped in this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface ValueBase

  • All Superinterfaces:
    IDLEntity, Serializable
    All Known Subinterfaces:
    CustomValue, DataInputStream, DataOutputStream, ObjectReferenceFactory, ObjectReferenceTemplate, StreamableValue

    public interface ValueBase
extends IDLEntity
    The generated Java classes corresponding to valuetype IDL types implement this interface. In other words, the Java mapping of valuetype objects implement the ValueBase interface. The generated Java class for valuetype's shall provide an implementation of the ValueBase interface for the corresponding value type. For value types that are streamable (i.e. non-custom), the generated Java class shall also provide an implementation for the org.omg.CORBA.portable.Streamable interface. (CORBA::ValueBase is mapped to java.io.Serializable.)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String[] _truncatable_ids()
      Provides truncatable repository ids.

    • Method Detail

      • _truncatable_ids

        String[] _truncatable_ids()
        Provides truncatable repository ids.
        Returns:
        a String array--list of truncatable repository ids.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface ValueFactory

  • public interface ValueFactory
    The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory. The read_value() method is called by the ORB runtime while in the process of unmarshaling a value type. A user shall implement this method as part of implementing a type specific value factory. In the implementation, the user shall call is.read_value(java.io.Serializable) with a uninitialized valuetype to use for unmarshaling. The value returned by the stream is the same value passed in, with all the data unmarshaled.
    See Also:
    ORB

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Serializable read_value(InputStream is)
      Is called by the ORB runtime while in the process of unmarshaling a value type.

    • Method Detail

      • read_value

        Serializable read_value(InputStream is)
        Is called by the ORB runtime while in the process of unmarshaling a value type. A user shall implement this method as part of implementing a type specific value factory.
        Parameters:
        is - an InputStream object--from which the value will be read.
        Returns:
        a Serializable object--the value read off of "is" Input stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueInputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface ValueInputStream

  • public interface ValueInputStream
    Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void end_value()
      The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
      void start_value()
      The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

    • Method Detail

      • start_value

        void start_value()
        The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

      • end_value

        void end_value()
        The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ValueOutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface ValueOutputStream

  • public interface ValueOutputStream
    Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void end_value()
      The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
      void start_value(String rep_id)
      The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

    • Method Detail

      • start_value

        void start_value(String rep_id)
        The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

      • end_value

        void end_value()
        The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.ApplicationException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.ApplicationException

  • Packages that use ApplicationException
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ApplicationException in org.omg.CORBA

      Methods in org.omg.CORBA that throw ApplicationException
      Modifier and Type Method and Description
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

    • Uses of ApplicationException in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that throw ApplicationException
      Modifier and Type Method and Description
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.BoxedValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.BoxedValueHelper

  • Packages that use BoxedValueHelper
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

    • Uses of BoxedValueHelper in org.omg.CORBA

      Classes in org.omg.CORBA that implement BoxedValueHelper
      Modifier and Type Class and Description
      class  StringValueHelper
      The Helper for StringValue.
      class  WStringValueHelper
      org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications : ORB core as defined by CORBA 2.3.1 (formal/99-10-07) IDL/Java Language Mapping as defined in ptc/00-01-08

    • Uses of BoxedValueHelper in org.omg.CORBA_2_3.portable

      Methods in org.omg.CORBA_2_3.portable with parameters of type BoxedValueHelper
      Modifier and Type Method and Description
      Serializable InputStream.read_value(BoxedValueHelper factory)
      Unmarshalls a value type from the input stream.
      void OutputStream.write_value(Serializable value, BoxedValueHelper factory)
      Marshals a value type to the output stream.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.CustomValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.CustomValue

No usage of org.omg.CORBA.portable.CustomValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.Delegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.Delegate

  • Packages that use Delegate
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Delegate in org.omg.CORBA

      Constructors in org.omg.CORBA with parameters of type Delegate
      Constructor and Description
      _IDLTypeStub(Delegate delegate)
      Constructs an _IDLTypeStub object initialized with the given Delegate object.
      _PolicyStub(Delegate delegate)
      Constructs a _PolicyStub object initialized with the given Delegate object.

    • Uses of Delegate in org.omg.CORBA_2_3.portable

      Subclasses of Delegate in org.omg.CORBA_2_3.portable
      Modifier and Type Class and Description
      class  Delegate
      Delegate class provides the ORB vendor specific implementation of CORBA object.

    • Uses of Delegate in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Delegate
      Modifier and Type Method and Description
      Delegate ObjectImpl._get_delegate()
      Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
      Methods in org.omg.CORBA.portable with parameters of type Delegate
      Modifier and Type Method and Description
      void ObjectImpl._set_delegate(Delegate delegate)
      Sets the Delegate for this ObjectImpl instance to the given Delegate object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.IDLEntity (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.IDLEntity

  • Packages that use IDLEntity
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.SendingContext
    Provides support for the marshalling of value types.

    • Uses of IDLEntity in org.omg.CORBA

      Subinterfaces of IDLEntity in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  Current
      Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
      interface  DataInputStream
      Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
      interface  DataOutputStream
      Defines the methods used to write primitive data types to output streams for marshalling custom value types.
      interface  DomainManager
      Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      interface  IRObject
      An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
      interface  Policy
      Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
      Classes in org.omg.CORBA that implement IDLEntity
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
      class  _PolicyStub
      The Stub for Policy.
      class  Any
      Serves as a container for any data that can be described in IDL or for any IDL primitive type.
      class  Bounds
      A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
      class  CompletionStatus
      An object that indicates whether a method had completed running when a SystemException was thrown.
      class  DefinitionKind
      The class that provides the constants used to identify the type of an Interface Repository object.
      class  NameValuePair
      Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
      class  ParameterMode
      Enumeration of parameter modes for Parameter.
      class  PolicyError
      A user exception thrown when a policy error occurs.
      class  ServiceDetail
      An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.
      class  ServiceInformation
      An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.
      class  SetOverrideType
      The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
      class  StructMember
      Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.
      class  TypeCode
      A container for information about a specific CORBA data type.
      class  UnionMember
      A description in the Interface Repository of a member of an IDL union.
      class  UnknownUserException
      A class that contains user exceptions returned by the server.
      class  UserException
      The root class for CORBA IDL-defined user exceptions.
      class  ValueMember
      A description in the Interface Repository of a member of a value object.
      class  WrongTransaction
      The CORBA WrongTransaction user-defined exception.

    • Uses of IDLEntity in org.omg.CORBA.DynAnyPackage

      Classes in org.omg.CORBA.DynAnyPackage that implement IDLEntity
      Modifier and Type | Class and Description
      class  Invalid
      Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
      class  InvalidSeq
      The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
      class  | InvalidValue
      class  TypeMismatch
      TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

    • Uses of IDLEntity in org.omg.CORBA.ORBPackage

      Classes in org.omg.CORBA.ORBPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  InconsistentTypeCode
      InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
      class  InvalidName
      The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

    • Uses of IDLEntity in org.omg.CORBA.portable

      Subinterfaces of IDLEntity in org.omg.CORBA.portable
      Modifier and Type Interface and Description
      interface  CustomValue
      An extension of ValueBase that is implemented by custom value types.
      interface  StreamableValue
      Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.
      interface  ValueBase
      The generated Java classes corresponding to valuetype IDL types implement this interface.

    • Uses of IDLEntity in org.omg.CORBA.TypeCodePackage

      Classes in org.omg.CORBA.TypeCodePackage that implement IDLEntity
      Modifier and Type Class and Description
      class  BadKind
      The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.

    • Uses of IDLEntity in org.omg.CosNaming

      Subinterfaces of IDLEntity in org.omg.CosNaming
      Modifier and Type Interface and Description
      interface  BindingIterator
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      interface  NamingContext
      A naming context is an object that contains a set of name bindings in which each name is unique.
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement IDLEntity
      Modifier and Type | Class and Description
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      class  Binding
      org/omg/CosNaming/Binding.java .
      class  BindingType
      Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
      class  NameComponent
      org/omg/CosNaming/NameComponent.java .

    • Uses of IDLEntity in org.omg.CosNaming.NamingContextExtPackage

      Classes in org.omg.CosNaming.NamingContextExtPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  InvalidAddress
      org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

    • Uses of IDLEntity in org.omg.CosNaming.NamingContextPackage

      Classes in org.omg.CosNaming.NamingContextPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  AlreadyBound
      org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
      class  CannotProceed
      org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
      class  NotEmpty
      org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
      class  NotFound
      org/omg/CosNaming/NamingContextPackage/NotFound.java .
      class  NotFoundReason
      Indicates the reason for not able to resolve.

    • Uses of IDLEntity in org.omg.Dynamic

      Classes in org.omg.Dynamic that implement IDLEntity
      Modifier and Type Class and Description
      class  Parameter
      org/omg/Dynamic/Parameter.java .

    • Uses of IDLEntity in org.omg.DynamicAny

      Subinterfaces of IDLEntity in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynAny
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      interface  DynAnyFactory
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      Classes in org.omg.DynamicAny that implement IDLEntity
      Modifier and Type Class and Description
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      class  NameDynAnyPair
      org/omg/DynamicAny/NameDynAnyPair.java .

    • Uses of IDLEntity in org.omg.IOP

      Subinterfaces of IDLEntity in org.omg.IOP
      Modifier and Type Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
      Classes in org.omg.IOP that implement IDLEntity
      Modifier and Type Class and Description
      class  Encoding
      org/omg/IOP/Encoding.java .
      class  IOR
      org/omg/IOP/IOR.java .
      class  ServiceContext
      org/omg/IOP/ServiceContext.java .
      class  TaggedComponent
      org/omg/IOP/TaggedComponent.java .
      class  TaggedProfile
      org/omg/IOP/TaggedProfile.java .

    • Uses of IDLEntity in org.omg.IOP.CodecFactoryPackage

      Classes in org.omg.IOP.CodecFactoryPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  UnknownEncoding
      org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

    • Uses of IDLEntity in org.omg.IOP.CodecPackage

      Classes in org.omg.IOP.CodecPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  FormatMismatch
      org/omg/IOP/CodecPackage/FormatMismatch.java .
      class  InvalidTypeForEncoding
      org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .

    • Uses of IDLEntity in org.omg.PortableInterceptor

      Subinterfaces of IDLEntity in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ObjectReferenceFactory
      The object reference factory.
      interface  ObjectReferenceTemplate
      The object reference template.
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      Classes in org.omg.PortableInterceptor that implement IDLEntity
      Modifier and Type Class and Description
      class  InvalidSlot
      org/omg/PortableInterceptor/InvalidSlot.java .

    • Uses of IDLEntity in org.omg.PortableInterceptor.ORBInitInfoPackage

      Classes in org.omg.PortableInterceptor.ORBInitInfoPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  DuplicateName
      org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .

    • Uses of IDLEntity in org.omg.PortableServer

      Subinterfaces of IDLEntity in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  POA
      A POA object manages the implementation of a collection of objects.
      interface  POAManager
      Each POA object has an associated POAManager object.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      Classes in org.omg.PortableServer that implement IDLEntity
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ForwardRequest
      org/omg/PortableServer/ForwardRequest.java .
      class  IdAssignmentPolicyValue
      The IdAssignmentPolicyValue can have the following values.
      class  IdUniquenessPolicyValue
      IdUniquenessPolicyValue can have the following values.
      class  ImplicitActivationPolicyValue
      ImplicitActivationPolicyValue has the following semantics.
      class  LifespanPolicyValue
      The LifespanPolicyValue can have the following values.
      class  RequestProcessingPolicyValue
      The RequestProcessingPolicyValue can have the following values.
      class  ServantRetentionPolicyValue
      ServantRetentionPolicyValue can have the following values.
      class  ThreadPolicyValue
      The ThreadPolicyValue can have the following values.

    • Uses of IDLEntity in org.omg.PortableServer.CurrentPackage

      Classes in org.omg.PortableServer.CurrentPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  NoContext
      org/omg/PortableServer/CurrentPackage/NoContext.java .

    • Uses of IDLEntity in org.omg.PortableServer.POAManagerPackage

      Classes in org.omg.PortableServer.POAManagerPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  AdapterInactive
      org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
      class  State
      Specifies the states for the POAManager

    • Uses of IDLEntity in org.omg.PortableServer.POAPackage

      Classes in org.omg.PortableServer.POAPackage that implement IDLEntity
      Modifier and Type Class and Description
      class  AdapterAlreadyExists
      org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
      class  AdapterNonExistent
      org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
      class  InvalidPolicy
      org/omg/PortableServer/POAPackage/InvalidPolicy.java .
      class  NoServant
      org/omg/PortableServer/POAPackage/NoServant.java .
      class  ObjectAlreadyActive
      org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
      class  ObjectNotActive
      org/omg/PortableServer/POAPackage/ObjectNotActive.java .
      class  ServantAlreadyActive
      org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
      class  ServantNotActive
      org/omg/PortableServer/POAPackage/ServantNotActive.java .
      class  WrongAdapter
      org/omg/PortableServer/POAPackage/WrongAdapter.java .
      class  WrongPolicy
      org/omg/PortableServer/POAPackage/WrongPolicy.java .

    • Uses of IDLEntity in org.omg.SendingContext

      Subinterfaces of IDLEntity in org.omg.SendingContext
      Modifier and Type Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.IndirectionException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.IndirectionException

No usage of org.omg.CORBA.portable.IndirectionException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.InputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.InputStream

  • Packages that use InputStream
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of InputStream in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type InputStream
      Modifier and Type Method and Description
      static Object Util.readAny(InputStream in)
      Reads a java.lang.Object as a CORBA any.
      Object UtilDelegate.readAny(InputStream in)
      Delegation call for Util.readAny(org.omg.CORBA.portable.InputStream).
      Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
      Reads a value from the stream using Java semantics.

    • Uses of InputStream in org.omg.CORBA

      Methods in org.omg.CORBA that return InputStream
      Modifier and Type Method and Description
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      abstract InputStream Any.create_input_stream()
      Creates an input stream from which this Any object's value can be unmarshalled.
      Methods in org.omg.CORBA with parameters of type InputStream
      Modifier and Type | Method and Description
      void ValueBaseHolder._read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      void TypeCodeHolder._read(InputStream input)
      Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
      void | DoubleSeqHolder._read(InputStream i)
      void LongHolder._read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      void PrincipalHolder._read(InputStream input)
      Deprecated.
      void AnyHolder._read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      void | LongLongSeqHolder._read(InputStream i)
      void ObjectHolder._read(InputStream input)
      Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
      void | WrongTransactionHolder._read(InputStream i)
      void | WStringSeqHolder._read(InputStream i)
      void | StringSeqHolder._read(InputStream i)
      void | CurrentHolder._read(InputStream i)
      void | ULongSeqHolder._read(InputStream i)
      void FloatHolder._read(InputStream input)
      Read a float from an input stream and initialize the value member with the float value.
      void ShortHolder._read(InputStream input)
      Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
      void | CharSeqHolder._read(InputStream i)
      void DoubleHolder._read(InputStream input)
      Read a double value from the input stream and store it in the value member.
      void | OctetSeqHolder._read(InputStream i)
      void StringHolder._read(InputStream input)
      Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
      void | LongSeqHolder._read(InputStream i)
      void ServiceInformationHolder._read(InputStream in)
      Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
      void BooleanHolder._read(InputStream input)
      Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
      void IntHolder._read(InputStream input)
      Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
      void | PolicyListHolder._read(InputStream i)
      void ByteHolder._read(InputStream input)
      Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
      void | ULongLongSeqHolder._read(InputStream i)
      void | AnySeqHolder._read(InputStream i)
      void | FloatSeqHolder._read(InputStream i)
      void | PolicyErrorHolder._read(InputStream i)
      void | WCharSeqHolder._read(InputStream i)
      void | ParameterModeHolder._read(InputStream i)
      void | UnknownUserExceptionHolder._read(InputStream i)
      void | UShortSeqHolder._read(InputStream i)
      void | PolicyHolder._read(InputStream i)
      void | ShortSeqHolder._read(InputStream i)
      void CharHolder._read(InputStream input)
      Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
      void | BooleanSeqHolder._read(InputStream i)
      void FixedHolder._read(InputStream input)
      Read a fixed point value from the input stream and store it in the value member.
      void LocalObject._releaseReply(InputStream input)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Serializable | StringValueHelper.read_value(InputStream istream)
      Serializable | WStringValueHelper.read_value(InputStream istream)
      abstract void Any.read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
      static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)
      static double[] | DoubleSeqHelper.read(InputStream istream)
      static ServiceDetail | ServiceDetailHelper.read(InputStream in)
      static ValueMember | ValueMemberHelper.read(InputStream istream)
      static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)
      static String | StringValueHelper.read(InputStream istream)
      static long[] | LongLongSeqHelper.read(InputStream istream)
      static String | RepositoryIdHelper.read(InputStream istream)
      static UnionMember | UnionMemberHelper.read(InputStream istream)
      static ServiceInformation | ServiceInformationHelper.read(InputStream in)
      static String[] | WStringSeqHelper.read(InputStream istream)
      static StructMember | StructMemberHelper.read(InputStream istream)
      static char[] | CharSeqHelper.read(InputStream istream)
      static ParameterMode | ParameterModeHelper.read(InputStream istream)
      static Object | ObjectHelper.read(InputStream istream)
      static short[] | ShortSeqHelper.read(InputStream istream)
      static IDLType | IDLTypeHelper.read(InputStream istream)
      static short | VisibilityHelper.read(InputStream istream)
      static int[] | LongSeqHelper.read(InputStream istream)
      static String | VersionSpecHelper.read(InputStream istream)
      static byte[] | OctetSeqHelper.read(InputStream istream)
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      static float[] | FloatSeqHelper.read(InputStream istream)
      static CompletionStatus | CompletionStatusHelper.read(InputStream istream)
      static Policy[] | PolicyListHelper.read(InputStream istream)
      static String | IdentifierHelper.read(InputStream istream)
      static String[] | StringSeqHelper.read(InputStream istream)
      static DefinitionKind | DefinitionKindHelper.read(InputStream istream)
      static Policy | PolicyHelper.read(InputStream istream)
      static String | FieldNameHelper.read(InputStream istream)
      static int[] | ULongSeqHelper.read(InputStream istream)
      static long[] | ULongLongSeqHelper.read(InputStream istream)
      static Current | CurrentHelper.read(InputStream istream)
      static Any[] | AnySeqHelper.read(InputStream istream)
      static PolicyError | PolicyErrorHelper.read(InputStream istream)
      static short | PolicyErrorCodeHelper.read(InputStream istream)
      static Serializable | ValueBaseHelper.read(InputStream istream)
      static char[] | WCharSeqHelper.read(InputStream istream)
      static int | PolicyTypeHelper.read(InputStream istream)
      static String | WStringValueHelper.read(InputStream istream)
      static WrongTransaction | WrongTransactionHelper.read(InputStream istream)
      static boolean[] | BooleanSeqHelper.read(InputStream istream)
      static short[] | UShortSeqHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.CORBA_2_3.portable

      Subclasses of InputStream in org.omg.CORBA_2_3.portable
      Modifier and Type Class and Description
      class  InputStream
      InputStream provides for the reading of all of the mapped IDL types from the stream.

    • Uses of InputStream in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return InputStream
      Modifier and Type Method and Description
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      abstract InputStream OutputStream.create_input_stream()
      Returns an input stream with the same buffer.
      InputStream ApplicationException.getInputStream()
      Returns the input stream from which the exception data can be read as its parameters.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      Methods in org.omg.CORBA.portable with parameters of type InputStream
      Modifier and Type | Method and Description
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.
      void Streamable._read(InputStream istream)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      void ObjectImpl._releaseReply(InputStream input)
      Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
      Serializable | BoxedValueHelper.read_value(InputStream is)
      void Delegate.releaseReply(Object self, InputStream input)
      releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
      Constructors in org.omg.CORBA.portable with parameters of type InputStream
      Constructor and Description
      ApplicationException(String id, InputStream ins)
      Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.

    • Uses of InputStream in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type InputStream
      Modifier and Type | Method and Description
      OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      void | BindingHolder._read(InputStream i)
      void | NamingContextExtHolder._read(InputStream i)
      void | BindingIteratorHolder._read(InputStream i)
      void | NameHolder._read(InputStream i)
      void | NameComponentHolder._read(InputStream i)
      void | BindingListHolder._read(InputStream i)
      void | NamingContextHolder._read(InputStream i)
      void | BindingTypeHolder._read(InputStream i)
      static BindingType | BindingTypeHelper.read(InputStream istream)
      static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
      static NameComponent | NameComponentHelper.read(InputStream istream)
      static String | IstringHelper.read(InputStream istream)
      static Binding | BindingHelper.read(InputStream istream)
      static NameComponent[] | NameHelper.read(InputStream istream)
      static BindingIterator | BindingIteratorHelper.read(InputStream istream)
      static Binding[] | BindingListHelper.read(InputStream istream)
      static NamingContext | NamingContextHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      void | InvalidAddressHolder._read(InputStream i)
      static String | StringNameHelper.read(InputStream istream)
      static String | AddressHelper.read(InputStream istream)
      static InvalidAddress | InvalidAddressHelper.read(InputStream istream)
      static String | URLStringHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      void | CannotProceedHolder._read(InputStream i)
      void | NotEmptyHolder._read(InputStream i)
      void | InvalidNameHolder._read(InputStream i)
      void | AlreadyBoundHolder._read(InputStream i)
      void | NotFoundHolder._read(InputStream i)
      void | NotFoundReasonHolder._read(InputStream i)
      static NotEmpty | NotEmptyHelper.read(InputStream istream)
      static NotFound | NotFoundHelper.read(InputStream istream)
      static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)
      static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)
      static CannotProceed | CannotProceedHelper.read(InputStream istream)
      static InvalidName | InvalidNameHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.DynamicAny

      Methods in org.omg.DynamicAny with parameters of type InputStream
      Modifier and Type | Method and Description
      static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)
      static DynArray | DynArrayHelper.read(InputStream istream)
      static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
      static DynUnion | DynUnionHelper.read(InputStream istream)
      static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
      static DynValue | DynValueHelper.read(InputStream istream)
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      static DynFixed | DynFixedHelper.read(InputStream istream)
      static String | FieldNameHelper.read(InputStream istream)
      static DynStruct | DynStructHelper.read(InputStream istream)
      static DynEnum | DynEnumHelper.read(InputStream istream)
      static Any[] | AnySeqHelper.read(InputStream istream)
      static DynSequence | DynSequenceHelper.read(InputStream istream)
      static DynAny[] | DynAnySeqHelper.read(InputStream istream)
      static DynAny | DynAnyHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static InconsistentTypeCode | InconsistentTypeCodeHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static InvalidValue | InvalidValueHelper.read(InputStream istream)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.IOP

      Methods in org.omg.IOP with parameters of type InputStream
      Modifier and Type | Method and Description
      void | TaggedComponentHolder._read(InputStream i)
      void | TaggedProfileHolder._read(InputStream i)
      void | IORHolder._read(InputStream i)
      void | MultipleComponentProfileHolder._read(InputStream i)
      void | ServiceContextHolder._read(InputStream i)
      void | ServiceContextListHolder._read(InputStream i)
      static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
      static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
      static CodecFactory | CodecFactoryHelper.read(InputStream istream)
      static ServiceContext | ServiceContextHelper.read(InputStream istream)
      static int | ProfileIdHelper.read(InputStream istream)
      static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
      static int | ServiceIdHelper.read(InputStream istream)
      static IOR | IORHelper.read(InputStream istream)
      static TaggedProfile | TaggedProfileHelper.read(InputStream istream)
      static int | ComponentIdHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static FormatMismatch | FormatMismatchHelper.read(InputStream istream)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.Messaging

      Methods in org.omg.Messaging with parameters of type InputStream
      Modifier and Type | Method and Description
      static short | SyncScopeHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type InputStream
      Modifier and Type | Method and Description
      void | IORInterceptor_3_0Holder._read(InputStream i)
      void | ObjectReferenceTemplateSeqHolder._read(InputStream i)
      void | ObjectReferenceFactoryHolder._read(InputStream i)
      void | ObjectReferenceTemplateHolder._read(InputStream i)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      static short | AdapterStateHelper.read(InputStream istream)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
      static byte[] | ObjectIdHelper.read(InputStream istream)
      static String | ORBIdHelper.read(InputStream istream)
      static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
      static int | AdapterManagerIdHelper.read(InputStream istream)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
      static Current | CurrentHelper.read(InputStream istream)
      static String[] | AdapterNameHelper.read(InputStream istream)
      static String | ServerIdHelper.read(InputStream istream)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static String | ObjectIdHelper.read(InputStream istream)
      static DuplicateName | DuplicateNameHelper.read(InputStream istream)
      static InvalidName | InvalidNameHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type InputStream
      Modifier and Type | Method and Description
      OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      static ServantLocator | ServantLocatorHelper.read(InputStream istream)
      static POA | POAHelper.read(InputStream istream)
      static ServantActivator | ServantActivatorHelper.read(InputStream istream)
      static Current | CurrentHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static NoContext | NoContextHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
      static WrongPolicy | WrongPolicyHelper.read(InputStream istream)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)
      static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
      static NoServant | NoServantHelper.read(InputStream istream)
      static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
      static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
      static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
      static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.ServantLocatorPackage

      Methods in org.omg.PortableServer.ServantLocatorPackage with parameters of type InputStream
      Modifier and Type | Method and Description
      void | CookieHolder._read(InputStream is)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.InvokeHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.InvokeHandler

  • Packages that use InvokeHandler
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of InvokeHandler in javax.rmi.CORBA

      Subinterfaces of InvokeHandler in javax.rmi.CORBA
      Modifier and Type Interface and Description
      interface  Tie
      Defines methods which all RMI-IIOP server side ties must implement.

    • Uses of InvokeHandler in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement InvokeHandler
      Modifier and Type Class and Description
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of InvokeHandler in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement InvokeHandler
      Modifier and Type Class and Description
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.ObjectImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.ObjectImpl

  • Packages that use ObjectImpl
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of ObjectImpl in javax.rmi.CORBA

      Subclasses of ObjectImpl in javax.rmi.CORBA
      Modifier and Type Class and Description
      class  Stub
      Base class from which all RMI-IIOP stubs must inherit.

    • Uses of ObjectImpl in org.omg.CORBA

      Subclasses of ObjectImpl in org.omg.CORBA
      Modifier and Type Class and Description
      class  _IDLTypeStub
      The Stub for IDLType.
      class  _PolicyStub
      The Stub for Policy.
      class  DynamicImplementation
      Deprecated.
      org.omg.CORBA.DynamicImplementation

    • Uses of ObjectImpl in org.omg.CORBA_2_3.portable

      Subclasses of ObjectImpl in org.omg.CORBA_2_3.portable
      Modifier and Type Class and Description
      class  ObjectImpl
      ObjectImpl class is the base class for all stubs.

    • Uses of ObjectImpl in org.omg.CosNaming

      Subclasses of ObjectImpl in org.omg.CosNaming
      Modifier and Type | Class and Description
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of ObjectImpl in org.omg.DynamicAny

      Subclasses of ObjectImpl in org.omg.DynamicAny
      Modifier and Type Class and Description
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.

    • Uses of ObjectImpl in org.omg.PortableServer

      Subclasses of ObjectImpl in org.omg.PortableServer
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.

    • Uses of ObjectImpl in org.omg.stub.java.rmi

      Subclasses of ObjectImpl in org.omg.stub.java.rmi
      Modifier and Type Class and Description
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.OutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.OutputStream

  • Packages that use OutputStream
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of OutputStream in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type OutputStream
      Modifier and Type Method and Description
      static void Util.writeAbstractObject(OutputStream out, Object obj)
      Writes a java.lang.Object as either a value or a CORBA Object.
      void UtilDelegate.writeAbstractObject(OutputStream out, Object obj)
      Delegation call for Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      static void Util.writeAny(OutputStream out, Object obj)
      Writes any java.lang.Object as a CORBA any.
      void UtilDelegate.writeAny(OutputStream out, Object obj)
      Delegation call for Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      static void Util.writeRemoteObject(OutputStream out, Object obj)
      Writes a java.lang.Object as a CORBA Object.
      void UtilDelegate.writeRemoteObject(OutputStream out, Object obj)
      Delegation call for Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      void ValueHandler.writeValue(OutputStream out, Serializable value)
      Writes a value to the stream using Java semantics.
      void ValueHandlerMultiFormat.writeValue(OutputStream out, Serializable value, byte streamFormatVersion)
      Allows the ORB to pass the stream format version for RMI/IDL custom value types.

    • Uses of OutputStream in org.omg.CORBA

      Methods in org.omg.CORBA that return OutputStream
      Modifier and Type Method and Description
      OutputStream LocalObject._request(String operation, boolean responseExpected)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      abstract OutputStream Any.create_output_stream()
      Creates an output stream into which this Any object's value can be marshalled.
      abstract OutputStream ORB.create_output_stream()
      Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
      Methods in org.omg.CORBA with parameters of type OutputStream
      Modifier and Type | Method and Description
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void ValueBaseHolder._write(OutputStream output)
      Marshals to output the value in the Holder.
      void TypeCodeHolder._write(OutputStream output)
      Marshals to output the value in this TypeCodeHolder object.
      void | DoubleSeqHolder._write(OutputStream o)
      void LongHolder._write(OutputStream output)
      Marshals to output the value in the Holder.
      void PrincipalHolder._write(OutputStream output)
      Deprecated.
      void AnyHolder._write(OutputStream output)
      Marshals to output the value in this AnyHolder object.
      void | LongLongSeqHolder._write(OutputStream o)
      void ObjectHolder._write(OutputStream output)
      Marshals to output the value in this ObjectHolder object.
      void | WrongTransactionHolder._write(OutputStream o)
      void | WStringSeqHolder._write(OutputStream o)
      void | StringSeqHolder._write(OutputStream o)
      void | CurrentHolder._write(OutputStream o)
      void | ULongSeqHolder._write(OutputStream o)
      void FloatHolder._write(OutputStream output)
      Write the float value into an output stream.
      void ShortHolder._write(OutputStream output)
      Marshals to output the value in this ShortHolder object.
      void | CharSeqHolder._write(OutputStream o)
      void DoubleHolder._write(OutputStream output)
      Write the double value stored in this holder to an OutputStream.
      void | OctetSeqHolder._write(OutputStream o)
      void StringHolder._write(OutputStream output)
      Marshals the value held by this StringHolder object to the output stream output.
      void | LongSeqHolder._write(OutputStream o)
      void ServiceInformationHolder._write(OutputStream out)
      Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
      void BooleanHolder._write(OutputStream output)
      Marshals the value in this BooleanHolder object's value field to the output stream output.
      void IntHolder._write(OutputStream output)
      Marshals the value in this IntHolder object's value field to the output stream output.
      void | PolicyListHolder._write(OutputStream o)
      void ByteHolder._write(OutputStream output)
      Marshals to output the value in this ByteHolder object.
      void | ULongLongSeqHolder._write(OutputStream o)
      void | AnySeqHolder._write(OutputStream o)
      void | FloatSeqHolder._write(OutputStream o)
      void | PolicyErrorHolder._write(OutputStream o)
      void | WCharSeqHolder._write(OutputStream o)
      void | ParameterModeHolder._write(OutputStream o)
      void | UnknownUserExceptionHolder._write(OutputStream o)
      void | UShortSeqHolder._write(OutputStream o)
      void | PolicyHolder._write(OutputStream o)
      void | ShortSeqHolder._write(OutputStream o)
      void CharHolder._write(OutputStream output)
      Marshals to output the value in this CharHolder object.
      void | BooleanSeqHolder._write(OutputStream o)
      void FixedHolder._write(OutputStream output)
      Write the fixed point value stored in this holder to an OutputStream.
      abstract void Any.write_value(OutputStream os)
      Writes out the value of this Any object to the given output stream.
      void | StringValueHelper.write_value(OutputStream ostream, Serializable value)
      void | WStringValueHelper.write_value(OutputStream ostream, Serializable value)
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      static void | BooleanSeqHelper.write(OutputStream ostream, boolean[] value)
      static void | OctetSeqHelper.write(OutputStream ostream, byte[] value)
      static void | CharSeqHelper.write(OutputStream ostream, char[] value)
      static void | WCharSeqHelper.write(OutputStream ostream, char[] value)
      static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)
      static void | DoubleSeqHelper.write(OutputStream ostream, double[] value)
      static void | FloatSeqHelper.write(OutputStream ostream, float[] value)
      static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)
      static void | PolicyTypeHelper.write(OutputStream ostream, int value)
      static void | LongSeqHelper.write(OutputStream ostream, int[] value)
      static void | ULongSeqHelper.write(OutputStream ostream, int[] value)
      static void | LongLongSeqHelper.write(OutputStream ostream, long[] value)
      static void | ULongLongSeqHelper.write(OutputStream ostream, long[] value)
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
      static void | ObjectHelper.write(OutputStream ostream, Object value)
      static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)
      static void | PolicyHelper.write(OutputStream ostream, Policy value)
      static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)
      static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)
      static void | ValueBaseHelper.write(OutputStream ostream, Serializable value)
      static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)
      static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)
      static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)
      static void | VisibilityHelper.write(OutputStream ostream, short value)
      static void | PolicyErrorCodeHelper.write(OutputStream ostream, short value)
      static void | ShortSeqHelper.write(OutputStream ostream, short[] value)
      static void | UShortSeqHelper.write(OutputStream ostream, short[] value)
      static void | StringValueHelper.write(OutputStream ostream, String value)
      static void | RepositoryIdHelper.write(OutputStream ostream, String value)
      static void | VersionSpecHelper.write(OutputStream ostream, String value)
      static void | IdentifierHelper.write(OutputStream ostream, String value)
      static void | FieldNameHelper.write(OutputStream ostream, String value)
      static void | WStringValueHelper.write(OutputStream ostream, String value)
      static void | WStringSeqHelper.write(OutputStream ostream, String[] value)
      static void | StringSeqHelper.write(OutputStream ostream, String[] value)
      static void | StructMemberHelper.write(OutputStream ostream, StructMember value)
      static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)
      static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)
      static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)
      static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)

    • Uses of OutputStream in org.omg.CORBA_2_3.portable

      Subclasses of OutputStream in org.omg.CORBA_2_3.portable
      Modifier and Type Class and Description
      class  OutputStream
      OutputStream provides interface for writing of all of the mapped IDL type to the stream.

    • Uses of OutputStream in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return OutputStream
      Modifier and Type Method and Description
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.
      OutputStream ObjectImpl._request(String operation, boolean responseExpected)
      Returns an OutputStream object to use for marshalling the arguments of the given method.
      OutputStream ResponseHandler.createExceptionReply()
      Called by the servant during a method invocation.
      OutputStream ResponseHandler.createReply()
      Called by the servant during a method invocation.
      OutputStream Delegate.request(Object self, String operation, boolean responseExpected)
      request is called by a stub to obtain an OutputStream for marshaling arguments.
      Methods in org.omg.CORBA.portable with parameters of type OutputStream
      Modifier and Type | Method and Description
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      void Streamable._write(OutputStream ostream)
      Marshals to ostream the value in the value field of the Holder.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      void | BoxedValueHelper.write_value(OutputStream os, Serializable value)

    • Uses of OutputStream in org.omg.CosNaming

      Methods in org.omg.CosNaming that return OutputStream
      Modifier and Type | Method and Description
      OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      Methods in org.omg.CosNaming with parameters of type OutputStream
      Modifier and Type | Method and Description
      void | BindingHolder._write(OutputStream o)
      void | NamingContextExtHolder._write(OutputStream o)
      void | BindingIteratorHolder._write(OutputStream o)
      void | NameHolder._write(OutputStream o)
      void | NameComponentHolder._write(OutputStream o)
      void | BindingListHolder._write(OutputStream o)
      void | NamingContextHolder._write(OutputStream o)
      void | BindingTypeHolder._write(OutputStream o)
      static void | BindingHelper.write(OutputStream ostream, Binding value)
      static void | BindingListHelper.write(OutputStream ostream, Binding[] value)
      static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)
      static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)
      static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
      static void | NameHelper.write(OutputStream ostream, NameComponent[] value)
      static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)
      static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)
      static void | IstringHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      void | InvalidAddressHolder._write(OutputStream o)
      static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)
      static void | StringNameHelper.write(OutputStream ostream, String value)
      static void | AddressHelper.write(OutputStream ostream, String value)
      static void | URLStringHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      void | CannotProceedHolder._write(OutputStream o)
      void | NotEmptyHolder._write(OutputStream o)
      void | InvalidNameHolder._write(OutputStream o)
      void | AlreadyBoundHolder._write(OutputStream o)
      void | NotFoundHolder._write(OutputStream o)
      void | NotFoundReasonHolder._write(OutputStream o)
      static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)
      static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
      static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)
      static void | NotFoundHelper.write(OutputStream ostream, NotFound value)
      static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)

    • Uses of OutputStream in org.omg.DynamicAny

      Methods in org.omg.DynamicAny with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
      static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)
      static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)
      static void | DynArrayHelper.write(OutputStream ostream, DynArray value)
      static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)
      static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)
      static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)
      static void | DynStructHelper.write(OutputStream ostream, DynStruct value)
      static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)
      static void | DynValueHelper.write(OutputStream ostream, DynValue value)
      static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
      static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
      static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)
      static void | FieldNameHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)

    • Uses of OutputStream in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

    • Uses of OutputStream in org.omg.IOP

      Methods in org.omg.IOP with parameters of type OutputStream
      Modifier and Type | Method and Description
      void | TaggedComponentHolder._write(OutputStream o)
      void | TaggedProfileHolder._write(OutputStream o)
      void | IORHolder._write(OutputStream o)
      void | MultipleComponentProfileHolder._write(OutputStream o)
      void | ServiceContextHolder._write(OutputStream o)
      void | ServiceContextListHolder._write(OutputStream o)
      static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)
      static void | ProfileIdHelper.write(OutputStream ostream, int value)
      static void | ServiceIdHelper.write(OutputStream ostream, int value)
      static void | ComponentIdHelper.write(OutputStream ostream, int value)
      static void | IORHelper.write(OutputStream ostream, IOR value)
      static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
      static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
      static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
      static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
      static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)

    • Uses of OutputStream in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)

    • Uses of OutputStream in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
      static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

    • Uses of OutputStream in org.omg.Messaging

      Methods in org.omg.Messaging with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | SyncScopeHelper.write(OutputStream ostream, short value)

    • Uses of OutputStream in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type OutputStream
      Modifier and Type | Method and Description
      void | IORInterceptor_3_0Holder._write(OutputStream o)
      void | ObjectReferenceTemplateSeqHolder._write(OutputStream o)
      void | ObjectReferenceFactoryHolder._write(OutputStream o)
      void | ObjectReferenceTemplateHolder._write(OutputStream o)
      static void | ObjectIdHelper.write(OutputStream ostream, byte[] value)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      static void | AdapterManagerIdHelper.write(OutputStream ostream, int value)
      static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
      static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
      static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
      static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
      static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
      static void | AdapterStateHelper.write(OutputStream ostream, short value)
      static void | ORBIdHelper.write(OutputStream ostream, String value)
      static void | ServerIdHelper.write(OutputStream ostream, String value)
      static void | AdapterNameHelper.write(OutputStream ostream, String[] value)

    • Uses of OutputStream in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
      static void | ObjectIdHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.PortableServer

      Methods in org.omg.PortableServer that return OutputStream
      Modifier and Type | Method and Description
      OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      Methods in org.omg.PortableServer with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      static void | POAHelper.write(OutputStream ostream, POA value)
      static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
      static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)

    • Uses of OutputStream in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | NoContextHelper.write(OutputStream ostream, NoContext value)

    • Uses of OutputStream in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)

    • Uses of OutputStream in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
      static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
      static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
      static void | NoServantHelper.write(OutputStream ostream, NoServant value)
      static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
      static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
      static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
      static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
      static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
      static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)

    • Uses of OutputStream in org.omg.PortableServer.ServantLocatorPackage

      Methods in org.omg.PortableServer.ServantLocatorPackage with parameters of type OutputStream
      Modifier and Type | Method and Description
      void | CookieHolder._write(OutputStream os)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.RemarshalException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.RemarshalException

  • Packages that use RemarshalException
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of RemarshalException in org.omg.CORBA

      Methods in org.omg.CORBA that throw RemarshalException
      Modifier and Type Method and Description
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

    • Uses of RemarshalException in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that throw RemarshalException
      Modifier and Type Method and Description
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.ResponseHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.ResponseHandler

  • Packages that use ResponseHandler
    Package Description
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ResponseHandler in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type ResponseHandler
      Modifier and Type Method and Description
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.

    • Uses of ResponseHandler in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type ResponseHandler
      Modifier and Type | Method and Description
      OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

    • Uses of ResponseHandler in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type ResponseHandler
      Modifier and Type | Method and Description
      OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.ServantObject (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.ServantObject

  • Packages that use ServantObject
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ServantObject in org.omg.CORBA

      Methods in org.omg.CORBA that return ServantObject
      Modifier and Type Method and Description
      ServantObject LocalObject._servant_preinvoke(String operation, Class expectedType)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Methods in org.omg.CORBA with parameters of type ServantObject
      Modifier and Type Method and Description
      void LocalObject._servant_postinvoke(ServantObject servant)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

    • Uses of ServantObject in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return ServantObject
      Modifier and Type Method and Description
      ServantObject ObjectImpl._servant_preinvoke(String operation, Class expectedType)
      Returns a Java reference to the local servant that should be used for sending a request for the method specified.
      ServantObject Delegate.servant_preinvoke(Object self, String operation, Class expectedType)
      Returns a Java reference to the servant which should be used for this request.
      Methods in org.omg.CORBA.portable with parameters of type ServantObject
      Modifier and Type Method and Description
      void ObjectImpl._servant_postinvoke(ServantObject servant)
      Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
      void Delegate.servant_postinvoke(Object self, ServantObject servant)
      servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.Streamable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.Streamable

  • Packages that use Streamable
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of Streamable in org.omg.CORBA

      Classes in org.omg.CORBA that implement Streamable
      Modifier and Type Class and Description
      class  AnyHolder
      The Holder for Any.
      class  AnySeqHolder
      The Holder for AnySeq.
      class  BooleanHolder
      The Holder for Boolean.
      class  BooleanSeqHolder
      The Holder for BooleanSeq.
      class  ByteHolder
      The Holder for Byte.
      class  CharHolder
      The Holder for Char.
      class  CharSeqHolder
      The Holder for CharSeq.
      class  CurrentHolder
      The Holder for Current.
      class  DoubleHolder
      The Holder for Double.
      class  DoubleSeqHolder
      The Holder for DoubleSeq.
      class  FixedHolder
      The Holder for Fixed.
      class  FloatHolder
      The Holder for Float.
      class  FloatSeqHolder
      The Holder for FloatSeq.
      class  IntHolder
      The Holder for Int.
      class  LongHolder
      The Holder for Long.
      class  LongLongSeqHolder
      The Holder for LongLongSeq.
      class  LongSeqHolder
      The Holder for LongSeq.
      class  ObjectHolder
      The Holder for Object.
      class  OctetSeqHolder
      The Holder for OctetSeq.
      class  ParameterModeHolder
      Enumeration of parameter modes for Parameter.
      class  PolicyErrorHolder
      Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
      class  PolicyHolder
      The Holder for Policy.
      class  PolicyListHolder
      The Holder for PolicyList.
      class  PrincipalHolder
      Deprecated.
      Deprecated by CORBA 2.2.
      class  ServiceInformationHolder
      The Holder for ServiceInformation.
      class  ShortHolder
      The Holder for Short.
      class  ShortSeqHolder
      The Holder for ShortSeq.
      class  StringHolder
      The Holder for String.
      class  StringSeqHolder
      An array of Strings
      class  TypeCodeHolder
      The Holder for TypeCode.
      class  ULongLongSeqHolder
      The Holder for ULongLongSeq.
      class  ULongSeqHolder
      The Holder for ULongSeq.
      class  UnknownUserExceptionHolder
      The Holder for UnknownUserException.
      class  UShortSeqHolder
      The Holder for UShortSeq.
      class  ValueBaseHolder
      The Holder for ValueBase.
      class  WCharSeqHolder
      The Holder for WCharSeq.
      class  WrongTransactionHolder
      The Holder for WrongTransaction.
      class  WStringSeqHolder
      An array of WStrings
      Methods in org.omg.CORBA that return Streamable
      Modifier and Type Method and Description
      Streamable Any.extract_Streamable()
      Extracts a Streamable from this Any object's value field.
      Methods in org.omg.CORBA with parameters of type Streamable
      Modifier and Type Method and Description
      void Any.insert_Streamable(Streamable s)
      Inserts the given Streamable object into this Any object's value field.

    • Uses of Streamable in org.omg.CORBA.portable

      Subinterfaces of Streamable in org.omg.CORBA.portable
      Modifier and Type Interface and Description
      interface  StreamableValue
      Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.

    • Uses of Streamable in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement Streamable
      Modifier and Type Class and Description
      class  BindingHolder
      org/omg/CosNaming/BindingHolder.java .
      class  BindingIteratorHolder
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  BindingListHolder
      List of Bindings.
      class  BindingTypeHolder
      Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
      class  NameComponentHolder
      org/omg/CosNaming/NameComponentHolder.java .
      class  NameHolder
      A name is a sequence of name components.
      class  NamingContextExtHolder
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextHolder
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of Streamable in org.omg.CosNaming.NamingContextExtPackage

      Classes in org.omg.CosNaming.NamingContextExtPackage that implement Streamable
      Modifier and Type Class and Description
      class  InvalidAddressHolder
      org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .

    • Uses of Streamable in org.omg.CosNaming.NamingContextPackage

      Classes in org.omg.CosNaming.NamingContextPackage that implement Streamable
      Modifier and Type Class and Description
      class  AlreadyBoundHolder
      org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
      class  CannotProceedHolder
      org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
      class  InvalidNameHolder
      org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
      class  NotEmptyHolder
      org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java .
      class  NotFoundHolder
      org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java .
      class  NotFoundReasonHolder
      Indicates the reason for not able to resolve.

    • Uses of Streamable in org.omg.IOP

      Classes in org.omg.IOP that implement Streamable
      Modifier and Type Class and Description
      class  IORHolder
      org/omg/IOP/IORHolder.java .
      class  MultipleComponentProfileHolder
      An array of tagged components, forming a multiple component profile.
      class  ServiceContextHolder
      org/omg/IOP/ServiceContextHolder.java .
      class  ServiceContextListHolder
      An array of service contexts, forming a service context list.
      class  TaggedComponentHolder
      org/omg/IOP/TaggedComponentHolder.java .
      class  TaggedProfileHolder
      org/omg/IOP/TaggedProfileHolder.java .

    • Uses of Streamable in org.omg.PortableInterceptor

      Classes in org.omg.PortableInterceptor that implement Streamable
      Modifier and Type Class and Description
      class  IORInterceptor_3_0Holder
      org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
      class  ObjectReferenceFactoryHolder
      The object reference factory.
      class  ObjectReferenceTemplateHolder
      The object reference template.
      class  ObjectReferenceTemplateSeqHolder
      Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • Uses of Streamable in org.omg.PortableServer.ServantLocatorPackage

      Classes in org.omg.PortableServer.ServantLocatorPackage that implement Streamable
      Modifier and Type Class and Description
      class  CookieHolder
      The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.StreamableValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.StreamableValue

No usage of org.omg.CORBA.portable.StreamableValue
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.portable.UnknownException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.portable.UnknownException

No usage of org.omg.CORBA.portable.UnknownException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.ValueBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.ValueBase

  • Packages that use ValueBase
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ValueBase in org.omg.CORBA

      Subinterfaces of ValueBase in org.omg.CORBA
      Modifier and Type Interface and Description
      interface  DataInputStream
      Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
      interface  DataOutputStream
      Defines the methods used to write primitive data types to output streams for marshalling custom value types.

    • Uses of ValueBase in org.omg.CORBA.portable

      Subinterfaces of ValueBase in org.omg.CORBA.portable
      Modifier and Type Interface and Description
      interface  CustomValue
      An extension of ValueBase that is implemented by custom value types.
      interface  StreamableValue
      Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.

    • Uses of ValueBase in org.omg.PortableInterceptor

      Subinterfaces of ValueBase in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ObjectReferenceFactory
      The object reference factory.
      interface  ObjectReferenceTemplate
      The object reference template.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.ValueFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.ValueFactory

  • Packages that use ValueFactory
    Package Description
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

    • Uses of ValueFactory in org.omg.CORBA_2_3

      Methods in org.omg.CORBA_2_3 that return ValueFactory
      Modifier and Type | Method and Description
      ValueFactory | ORB.lookup_value_factory(String id)
      ValueFactory | ORB.register_value_factory(String id, ValueFactory factory)
      Methods in org.omg.CORBA_2_3 with parameters of type ValueFactory
      Modifier and Type | Method and Description
      ValueFactory | ORB.register_value_factory(String id, ValueFactory factory)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.ValueInputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.ValueInputStream

No usage of org.omg.CORBA.portable.ValueInputStream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CORBA.portable.ValueOutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CORBA.portable.ValueOutputStream

No usage of org.omg.CORBA.portable.ValueOutputStream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BadKind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.TypeCodePackage

Class BadKind

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.TypeCodePackage.BadKind
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class BadKind
extends UserException
    The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object. For example, invoking the method discriminator_type() on an instance of TypeCode that does not represent an IDL union will cause the exception BadKind to be thrown.
    Since:
    JDK1.2
    See Also:
    TypeCode

    • Constructor Summary

      Constructors
      Constructor and Description
      BadKind()
      Constructs a BadKind exception with no reason message.
      BadKind(String reason)
      Constructs a BadKind exception with the specified reason message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • BadKind

        public BadKind()
        Constructs a BadKind exception with no reason message.

      • BadKind

        public BadKind(String reason)
        Constructs a BadKind exception with the specified reason message.
        Parameters:
        reason - the String containing a reason message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Bounds (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA.TypeCodePackage

Class Bounds

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.TypeCodePackage.Bounds
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Bounds
extends UserException
    Provides the TypeCode operations member_name(), member_type(), and member_label. These methods raise Bounds when the index parameter is greater than or equal to the number of members constituting the type.
    Since:
    JDK1.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Bounds()
      Constructs a Bounds exception with no reason message.
      Bounds(String reason)
      Constructs a Bounds exception with the specified reason message.

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • Bounds

        public Bounds()
        Constructs a Bounds exception with no reason message.

      • Bounds

        public Bounds(String reason)
        Constructs a Bounds exception with the specified reason message.
        Parameters:
        reason - the String containing a reason message
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.TypeCodePackage (Java Platform SE 8 )

org.omg.CORBA.TypeCodePackage

Exceptions

  • BadKind
  • Bounds


org.omg.CORBA.TypeCodePackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA.TypeCodePackage

Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.

See: Description

  • Exception Summary
    Exception Description
    BadKind
    The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
    Bounds
    Provides the TypeCode operations member_name(), member_type(), and member_label.

Package org.omg.CORBA.TypeCodePackage Description

Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.

Related Documentation

For an overview, please see:
  • comments on the CORBA package
Since:
JDK1.2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA.TypeCodePackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA.TypeCodePackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.TypeCodePackage.BadKind
          • org.omg.CORBA.TypeCodePackage.Bounds
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA.TypeCodePackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA.TypeCodePackage

  • Packages that use org.omg.CORBA.TypeCodePackage
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
  • Classes in org.omg.CORBA.TypeCodePackage used by org.omg.CORBA
    Class and Description
    BadKind
    The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
    Bounds
    Provides the TypeCode operations member_name(), member_type(), and member_label.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TypeCodePackage.BadKind (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TypeCodePackage.BadKind

  • Packages that use BadKind
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BadKind in org.omg.CORBA

      Methods in org.omg.CORBA that throw BadKind
      Modifier and Type Method and Description
      abstract TypeCode TypeCode.concrete_base_type()
      Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
      abstract TypeCode TypeCode.content_type()
      Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
      abstract int TypeCode.default_index()
      Returns the index of the default member, or -1 if there is no default member.
      abstract TypeCode TypeCode.discriminator_type()
      Returns a TypeCode object describing all non-default member labels.
      abstract short TypeCode.fixed_digits()
      Returns the number of digits in the fixed type described by this TypeCode object.
      abstract short TypeCode.fixed_scale()
      Returns the scale of the fixed type described by this TypeCode object.
      abstract String TypeCode.id()
      Retrieves the RepositoryId globally identifying the type of this TypeCode object.
      abstract int TypeCode.length()
      Returns the number of elements in the type described by this TypeCode object.
      abstract int TypeCode.member_count()
      Retrieves the number of members in the type described by this TypeCode object.
      abstract Any TypeCode.member_label(int index)
      Retrieves the label of the union member identified by the given index.
      abstract String TypeCode.member_name(int index)
      Retrieves the simple name of the member identified by the given index.
      abstract TypeCode TypeCode.member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      abstract short TypeCode.member_visibility(int index)
      Returns the constant that indicates the visibility of the member at the given index.
      abstract String TypeCode.name()
      Retrieves the simple name identifying this TypeCode object within its enclosing scope.
      abstract short TypeCode.type_modifier()
      Returns a constant indicating the modifier of the value type that this TypeCode object describes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA.TypeCodePackage.Bounds (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA.TypeCodePackage.Bounds

  • Packages that use Bounds
    Package Description
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Bounds in org.omg.CORBA

      Methods in org.omg.CORBA that throw Bounds
      Modifier and Type Method and Description
      abstract Any TypeCode.member_label(int index)
      Retrieves the label of the union member identified by the given index.
      abstract String TypeCode.member_name(int index)
      Retrieves the simple name of the member identified by the given index.
      abstract TypeCode TypeCode.member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      abstract short TypeCode.member_visibility(int index)
      Returns the constant that indicates the visibility of the member at the given index.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORB (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA_2_3

Class ORB

  • java.lang.Object
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB

  • public abstract class ORB
extends ORB
    A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

    • Constructor Summary

      Constructors
      Constructor and Description
      ORB()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      Object | get_value_def(String repid)
      ValueFactory | lookup_value_factory(String id)
      ValueFactory | register_value_factory(String id, ValueFactory factory)
      void | set_delegate(Object wrapper)
      void | unregister_value_factory(String id)

      • Methods inherited from class org.omg.CORBA.ORB

        connect, create_abstract_interface_tc, create_alias_tc, create_any, create_array_tc, create_basic_dyn_any, create_context_list, create_dyn_any, create_dyn_array, create_dyn_enum, create_dyn_sequence, create_dyn_struct, create_dyn_union, create_enum_tc, create_environment, create_exception_list, create_exception_tc, create_fixed_tc, create_interface_tc, create_list, create_named_value, create_native_tc, create_operation_list, create_output_stream, create_policy, create_recursive_sequence_tc, create_recursive_tc, create_sequence_tc, create_string_tc, create_struct_tc, create_union_tc, create_value_box_tc, create_value_tc, create_wstring_tc, destroy, disconnect, get_current, get_default_context, get_next_response, get_primitive_tc, get_service_information, init, init, init, list_initial_services, object_to_string, perform_work, poll_next_response, resolve_initial_references, run, send_multiple_requests_deferred, send_multiple_requests_oneway, set_parameters, set_parameters, shutdown, string_to_object, work_pending

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ORB

        public ORB()

    • Method Detail

      • register_value_factory

        public ValueFactory register_value_factory(String id,
                                           ValueFactory factory)

      • unregister_value_factory

        public void unregister_value_factory(String id)

      • lookup_value_factory

        public ValueFactory lookup_value_factory(String id)

      • get_value_def

        public Object get_value_def(String repid)
                     throws BAD_PARAM
        Throws:
        BAD_PARAM
        See Also:
        CORBA_2_3 package comments for unimplemented features

      • set_delegate

        public void set_delegate(Object wrapper)
        See Also:
        CORBA_2_3 package comments for unimplemented features
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA_2_3 (Java Platform SE 8 )

org.omg.CORBA_2_3

Classes

  • ORB


org.omg.CORBA_2_3 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA_2_3

The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

See: Description

  • Class Summary
    Class Description
    ORB
    A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

Package org.omg.CORBA_2_3 Description

The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

The following methods in the abstract class org.omg.CORBA_2_3.ORB are unimplemented:

  • public org.omg.CORBA.portable.ValueFactory register_value_factory(String id, org.omg.CORBA.portable.ValueFactory factory)
  • public void unregister_value_factory(String id)
  • public org.omg.CORBA.portable.ValueFactory lookup_value_factory(String id)
  • public org.omg.CORBA.Object get_value_def(String repid)
  • public void set_delegate(java.lang.Object wrapper)
Since:
JDK 1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA_2_3 Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA_2_3

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA_2_3 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA_2_3

No usage of org.omg.CORBA_2_3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA_2_3.ORB (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA_2_3.ORB

No usage of org.omg.CORBA_2_3.ORB
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Delegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA_2_3.portable

Class Delegate

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate

  • public abstract class Delegate
extends Delegate
    Delegate class provides the ORB vendor specific implementation of CORBA object. It extends org.omg.CORBA.portable.Delegate and provides new methods that were defined by CORBA 2.3.
    Since:
    JDK1.2
    See Also:
    Delegate

    • Constructor Summary

      Constructors
      Constructor and Description
      Delegate()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String get_codebase(Object self)
      Returns the codebase for object reference provided.

      • Methods inherited from class org.omg.CORBA.portable.Delegate

        create_request, create_request, duplicate, equals, get_domain_managers, get_interface_def, get_policy, hash, hashCode, invoke, is_a, is_equivalent, is_local, non_existent, orb, release, releaseReply, request, request, servant_postinvoke, servant_preinvoke, set_policy_override, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Delegate

        public Delegate()

    • Method Detail

      • get_codebase

        public String get_codebase(Object self)
        Returns the codebase for object reference provided.
        Parameters:
        self - the object reference whose codebase needs to be returned.
        Returns:
        the codebase as a space delimited list of url strings or null if none.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA_2_3.portable

Class InputStream

  • java.lang.Object
    • java.io.InputStream
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
  • All Implemented Interfaces:
    Closeable, AutoCloseable

    public abstract class InputStream
extends InputStream
    InputStream provides for the reading of all of the mapped IDL types from the stream. It extends org.omg.CORBA.portable.InputStream. This class defines new methods that were added for CORBA 2.3.
    Since:
    JDK1.2
    See Also:
    InputStream

    • Constructor Summary

      Constructors
      Constructor and Description
      InputStream()
      Create a new instance of this class.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Object read_abstract_interface()
      Unmarshal the value object or a suitable stub object.
      Object read_abstract_interface(Class clz)
      Unmarshal the class object or the stub class corresponding to the passed type.
      Serializable read_value()
      Unmarshalls a value type from the input stream.
      Serializable read_value(BoxedValueHelper factory)
      Unmarshalls a value type from the input stream.
      Serializable read_value(Class clz)
      Unmarshalls a value type from the input stream.
      Serializable read_value(Serializable value)
      Unmarshalls a value type from the input stream.
      Serializable read_value(String rep_id)
      Unmarshalls a value type from the input stream.

      • Methods inherited from class org.omg.CORBA.portable.InputStream

        orb, read_any, read_boolean_array, read_boolean, read_char_array, read_char, read_Context, read_double_array, read_double, read_fixed, read_float_array, read_float, read_long_array, read_long, read_longlong_array, read_longlong, read_Object, read_Object, read_octet_array, read_octet, read_Principal, read_short_array, read_short, read_string, read_TypeCode, read_ulong_array, read_ulong, read_ulonglong_array, read_ulonglong, read_ushort_array, read_ushort, read_wchar_array, read_wchar, read_wstring, read

      • Methods inherited from class java.io.InputStream

        available, close, mark, markSupported, read, read, reset, skip

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InputStream

        public InputStream()
        Create a new instance of this class. throw SecurityException if SecurityManager is installed and enableSubclassImplementation SerializablePermission is not granted or jdk.corba.allowOutputStreamSubclass system property is either not set or is set to 'false'

    • Method Detail

      • read_value

        public Serializable read_value()
        Unmarshalls a value type from the input stream.
        Returns:
        the value type unmarshalled from the input stream

      • read_value

        public Serializable read_value(Class clz)
        Unmarshalls a value type from the input stream.
        Parameters:
        clz - is the declared type of the value to be unmarshalled
        Returns:
        the value unmarshalled from the input stream

      • read_value

        public Serializable read_value(BoxedValueHelper factory)
        Unmarshalls a value type from the input stream.
        Parameters:
        factory - is the instance fo the helper to be used for unmarshalling the value type
        Returns:
        the value unmarshalled from the input stream

      • read_value

        public Serializable read_value(String rep_id)
        Unmarshalls a value type from the input stream.
        Parameters:
        rep_id - identifies the type of the value to be unmarshalled
        Returns:
        value type unmarshalled from the input stream

      • read_value

        public Serializable read_value(Serializable value)
        Unmarshalls a value type from the input stream.
        Parameters:
        value - is an uninitialized value which is added to the orb's indirection table before calling Streamable._read() or CustomMarshal.unmarshal() to unmarshal the value.
        Returns:
        value type unmarshalled from the input stream

      • read_abstract_interface

        public Object read_abstract_interface()
        Unmarshal the value object or a suitable stub object.
        Returns:
        ORB runtime returns the value object or a suitable stub object.

      • read_abstract_interface

        public Object read_abstract_interface(Class clz)
        Unmarshal the class object or the stub class corresponding to the passed type.
        Parameters:
        clz - is the Class object for the stub class which corresponds to the type that is statically expected.
        Returns:
        ORB runtime returns the value object or a suitable stub object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA_2_3.portable

Class ObjectImpl

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA_2_3.portable.ObjectImpl
  • All Implemented Interfaces:
    Object
    Direct Known Subclasses:
    Stub

    public abstract class ObjectImpl
extends ObjectImpl
    ObjectImpl class is the base class for all stubs. It provides the basic delegation mechanism. It extends org.omg.CORBA.portable.ObjectImpl and provides new methods defined by CORBA 2.3.
    Since:
    JDK1.2
    See Also:
    ObjectImpl

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectImpl()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String _get_codebase()
      Returns the codebase for this object reference.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _ids, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectImpl

        public ObjectImpl()

    • Method Detail

      • _get_codebase

        public String _get_codebase()
        Returns the codebase for this object reference.
        Returns:
        the codebase as a space delimited list of url strings or null if none.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


OutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CORBA_2_3.portable

Class OutputStream

  • java.lang.Object
    • java.io.OutputStream
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
  • All Implemented Interfaces:
    Closeable, Flushable, AutoCloseable

    public abstract class OutputStream
extends OutputStream
    OutputStream provides interface for writing of all of the mapped IDL type to the stream. It extends org.omg.CORBA.portable.OutputStream, and defines new methods defined by CORBA 2.3.
    Since:
    JDK1.2
    See Also:
    OutputStream

    • Constructor Summary

      Constructors
      Constructor and Description
      OutputStream()
      Create a new instance of this class.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void write_abstract_interface(Object obj)
      Marshals a value object or a stub object.
      void write_value(Serializable value)
      Marshals a value type to the output stream.
      void write_value(Serializable value, BoxedValueHelper factory)
      Marshals a value type to the output stream.
      void write_value(Serializable value, Class clz)
      Marshals a value type to the output stream.
      void write_value(Serializable value, String repository_id)
      Marshals a value type to the output stream.

      • Methods inherited from class org.omg.CORBA.portable.OutputStream

        create_input_stream, orb, write_any, write_boolean_array, write_boolean, write_char_array, write_char, write_Context, write_double_array, write_double, write_fixed, write_float_array, write_float, write_long_array, write_long, write_longlong_array, write_longlong, write_Object, write_octet_array, write_octet, write_Principal, write_short_array, write_short, write_string, write_TypeCode, write_ulong_array, write_ulong, write_ulonglong_array, write_ulonglong, write_ushort_array, write_ushort, write_wchar_array, write_wchar, write_wstring, write

      • Methods inherited from class java.io.OutputStream

        close, flush, write, write

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • OutputStream

        public OutputStream()
        Create a new instance of this class. throw SecurityException if SecurityManager is installed and enableSubclassImplementation SerializablePermission is not granted or jdk.corba.allowOutputStreamSubclass system property is either not set or is set to 'false'

    • Method Detail

      • write_value

        public void write_value(Serializable value)
        Marshals a value type to the output stream.
        Parameters:
        value - is the acutal value to write

      • write_value

        public void write_value(Serializable value,
                        Class clz)
        Marshals a value type to the output stream.
        Parameters:
        value - is the acutal value to write
        clz - is the declared type of the value to be marshaled

      • write_value

        public void write_value(Serializable value,
                        String repository_id)
        Marshals a value type to the output stream.
        Parameters:
        value - is the acutal value to write
        repository_id - identifies the type of the value type to be marshaled

      • write_value

        public void write_value(Serializable value,
                        BoxedValueHelper factory)
        Marshals a value type to the output stream.
        Parameters:
        value - is the acutal value to write
        factory - is the instance of the helper to be used for marshaling the boxed value

      • write_abstract_interface

        public void write_abstract_interface(Object obj)
        Marshals a value object or a stub object.
        Parameters:
        obj - the actual value object to marshal or the stub to be marshalled
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA_2_3.portable (Java Platform SE 8 )

org.omg.CORBA_2_3.portable

Classes

  • Delegate
  • InputStream
  • ObjectImpl
  • OutputStream


org.omg.CORBA_2_3.portable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CORBA_2_3.portable

Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

See: Description

  • Class Summary
    Class Description
    Delegate
    Delegate class provides the ORB vendor specific implementation of CORBA object.
    InputStream
    InputStream provides for the reading of all of the mapped IDL types from the stream.
    ObjectImpl
    ObjectImpl class is the base class for all stubs.
    OutputStream
    OutputStream provides interface for writing of all of the mapped IDL type to the stream.

Package org.omg.CORBA_2_3.portable Description

Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CORBA_2_3.portable Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CORBA_2_3.portable

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate
    • java.io.InputStream (implements java.io.Closeable)
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CORBA_2_3.portable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CORBA_2_3.portable

  • Packages that use org.omg.CORBA_2_3.portable
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in org.omg.CORBA_2_3.portable used by javax.rmi.CORBA
    Class and Description
    ObjectImpl
    ObjectImpl class is the base class for all stubs.
  • Classes in org.omg.CORBA_2_3.portable used by org.omg.CORBA.portable
    Class and Description
    InputStream
    InputStream provides for the reading of all of the mapped IDL types from the stream.
  • Classes in org.omg.CORBA_2_3.portable used by org.omg.stub.java.rmi
    Class and Description
    ObjectImpl
    ObjectImpl class is the base class for all stubs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA_2_3.portable.Delegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA_2_3.portable.Delegate

No usage of org.omg.CORBA_2_3.portable.Delegate
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA_2_3.portable.InputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA_2_3.portable.InputStream

  • Packages that use InputStream
    Package Description
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of InputStream in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type InputStream
      Modifier and Type Method and Description
      Serializable ValueFactory.read_value(InputStream is)
      Is called by the ORB runtime while in the process of unmarshaling a value type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA_2_3.portable.ObjectImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA_2_3.portable.ObjectImpl

  • Packages that use ObjectImpl
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of ObjectImpl in javax.rmi.CORBA

      Subclasses of ObjectImpl in javax.rmi.CORBA
      Modifier and Type Class and Description
      class  Stub
      Base class from which all RMI-IIOP stubs must inherit.

    • Uses of ObjectImpl in org.omg.stub.java.rmi

      Subclasses of ObjectImpl in org.omg.stub.java.rmi
      Modifier and Type Class and Description
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CORBA_2_3.portable.OutputStream (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CORBA_2_3.portable.OutputStream

No usage of org.omg.CORBA_2_3.portable.OutputStream
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Binding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class Binding

  • java.lang.Object
    • org.omg.CosNaming.Binding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Binding
extends Object
implements IDLEntity
    org/omg/CosNaming/Binding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NameComponent[] binding_name
      BindingType binding_type

    • Constructor Summary

      Constructors
      Constructor and Description
      Binding()
      Binding(NameComponent[] _binding_name, BindingType _binding_type)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • binding_name

        public NameComponent[] binding_name

      • binding_type

        public BindingType binding_type

    • Constructor Detail

      • Binding

        public Binding()

      • Binding

        public Binding(NameComponent[] _binding_name,
               BindingType _binding_type)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingHelper

  • public abstract class BindingHelper
extends Object
    org/omg/CosNaming/BindingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Binding | extract(Any a)
      static String | id()
      static void | insert(Any a, Binding that)
      static Binding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Binding value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BindingHelper

        public BindingHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Binding that)

      • extract

        public static Binding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Binding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Binding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingHolder
  • All Implemented Interfaces:
    Streamable

    public final class BindingHolder
extends Object
implements Streamable
    org/omg/CosNaming/BindingHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Binding value

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingHolder()
      BindingHolder(Binding initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Binding value

    • Constructor Detail

      • BindingHolder

        public BindingHolder()

      • BindingHolder

        public BindingHolder(Binding initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingIterator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Interface BindingIterator

  • All Superinterfaces:
    BindingIteratorOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub

    public interface BindingIterator
extends BindingIteratorOperations, Object, IDLEntity
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    See Also:
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • Method Summary

      • Methods inherited from interface org.omg.CosNaming.BindingIteratorOperations

        destroy, next_n, next_one

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingIteratorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingIteratorHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingIteratorHelper

  • public abstract class BindingIteratorHelper
extends Object
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    See Also:
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingIteratorHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static BindingIterator | extract(Any a)
      static String | id()
      static void | insert(Any a, BindingIterator that)
      static BindingIterator | narrow(Object obj)
      static BindingIterator | read(InputStream istream)
      static TypeCode | type()
      static BindingIterator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, BindingIterator value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BindingIteratorHelper

        public BindingIteratorHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          BindingIterator that)

      • extract

        public static BindingIterator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static BindingIterator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         BindingIterator value)

      • narrow

        public static BindingIterator narrow(Object obj)

      • unchecked_narrow

        public static BindingIterator unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingIteratorHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingIteratorHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingIteratorHolder
  • All Implemented Interfaces:
    Streamable

    public final class BindingIteratorHolder
extends Object
implements Streamable
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    See Also:
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • Field Summary

      Fields
      Modifier and Type Field and Description
      BindingIterator value

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingIteratorHolder()
      BindingIteratorHolder(BindingIterator initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public BindingIterator value

    • Constructor Detail

      • BindingIteratorHolder

        public BindingIteratorHolder()

      • BindingIteratorHolder

        public BindingIteratorHolder(BindingIterator initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingIteratorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Interface BindingIteratorOperations

  • All Known Subinterfaces:
    BindingIterator
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub, BindingIteratorPOA

    public interface BindingIteratorOperations
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    See Also:
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void destroy()
      This operation destroys the iterator.
      boolean next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
      boolean next_one(BindingHolder b)
      This operation returns the next binding.

    • Method Detail

      • next_one

        boolean next_one(BindingHolder b)
        This operation returns the next binding. If there are no more bindings, false is returned.
        Parameters:
        b - the returned binding

      • next_n

        boolean next_n(int how_many,
               BindingListHolder bl)
        This operation returns at most the requested number of bindings.
        Parameters:
        how_many - the maximum number of bindings tro return

        bl - the returned bindings

      • destroy

        void destroy()
        This operation destroys the iterator.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingIteratorPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingIteratorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA
  • All Implemented Interfaces:
    InvokeHandler, BindingIteratorOperations

    public abstract class BindingIteratorPOA
extends Servant
implements BindingIteratorOperations, InvokeHandler
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    See Also:
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingIteratorPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      BindingIterator _this()
      BindingIterator | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.CosNaming.BindingIteratorOperations

        destroy, next_n, next_one

    • Constructor Detail

      • BindingIteratorPOA

        public BindingIteratorPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public BindingIterator _this()

      • _this

        public BindingIterator _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingListHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingListHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingListHelper

  • public abstract class BindingListHelper
extends Object
    List of Bindings.

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingListHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Binding[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Binding[] that)
      static Binding[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Binding[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BindingListHelper

        public BindingListHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Binding[] that)

      • extract

        public static Binding[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Binding[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Binding[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingListHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingListHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingListHolder
  • All Implemented Interfaces:
    Streamable

    public final class BindingListHolder
extends Object
implements Streamable
    List of Bindings.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Binding[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingListHolder()
      BindingListHolder(Binding[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Binding[] value

    • Constructor Detail

      • BindingListHolder

        public BindingListHolder()

      • BindingListHolder

        public BindingListHolder(Binding[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingType

  • java.lang.Object
    • org.omg.CosNaming.BindingType
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class BindingType
extends Object
implements IDLEntity
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _ncontext
      static int | _nobject
      static BindingType | ncontext
      static BindingType | nobject

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | BindingType(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static BindingType | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _nobject

        public static final int _nobject
        See Also:
        Constant Field Values

      • nobject

        public static final BindingType nobject

      • _ncontext

        public static final int _ncontext
        See Also:
        Constant Field Values

      • ncontext

        public static final BindingType ncontext

    • Constructor Detail

      • BindingType

        protected BindingType(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static BindingType from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingTypeHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingTypeHelper

  • public abstract class BindingTypeHelper
extends Object
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingTypeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static BindingType | extract(Any a)
      static String | id()
      static void | insert(Any a, BindingType that)
      static BindingType | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, BindingType value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • BindingTypeHelper

        public BindingTypeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          BindingType that)

      • extract

        public static BindingType extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static BindingType read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         BindingType value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


BindingTypeHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class BindingTypeHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingTypeHolder
  • All Implemented Interfaces:
    Streamable

    public final class BindingTypeHolder
extends Object
implements Streamable
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      BindingType value

    • Constructor Summary

      Constructors
      Constructor and Description
      BindingTypeHolder()
      BindingTypeHolder(BindingType initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public BindingType value

    • Constructor Detail

      • BindingTypeHolder

        public BindingTypeHolder()

      • BindingTypeHolder

        public BindingTypeHolder(BindingType initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IstringHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class IstringHelper

  • java.lang.Object
    • org.omg.CosNaming.IstringHelper

  • public abstract class IstringHelper
extends Object
    org/omg/CosNaming/IstringHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      IstringHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IstringHelper

        public IstringHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameComponent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NameComponent

  • java.lang.Object
    • org.omg.CosNaming.NameComponent
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NameComponent
extends Object
implements IDLEntity
    org/omg/CosNaming/NameComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String id
      String kind

    • Constructor Summary

      Constructors
      Constructor and Description
      NameComponent()
      NameComponent(String _id, String _kind)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        public String id

      • kind

        public String kind

    • Constructor Detail

      • NameComponent

        public NameComponent()

      • NameComponent

        public NameComponent(String _id,
                     String _kind)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameComponentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NameComponentHelper

  • java.lang.Object
    • org.omg.CosNaming.NameComponentHelper

  • public abstract class NameComponentHelper
extends Object
    org/omg/CosNaming/NameComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameComponentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameComponent | extract(Any a)
      static String | id()
      static void | insert(Any a, NameComponent that)
      static NameComponent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameComponent value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameComponentHelper

        public NameComponentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameComponent that)

      • extract

        public static NameComponent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameComponent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameComponent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameComponentHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NameComponentHolder

  • java.lang.Object
    • org.omg.CosNaming.NameComponentHolder
  • All Implemented Interfaces:
    Streamable

    public final class NameComponentHolder
extends Object
implements Streamable
    org/omg/CosNaming/NameComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NameComponent value

    • Constructor Summary

      Constructors
      Constructor and Description
      NameComponentHolder()
      NameComponentHolder(NameComponent initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NameComponent value

    • Constructor Detail

      • NameComponentHolder

        public NameComponentHolder()

      • NameComponentHolder

        public NameComponentHolder(NameComponent initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NameHelper

  • java.lang.Object
    • org.omg.CosNaming.NameHelper

  • public abstract class NameHelper
extends Object
    A name is a sequence of name components.

    • Constructor Summary

      Constructors
      Constructor and Description
      NameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameComponent[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameComponent[] that)
      static NameComponent[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameComponent[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameHelper

        public NameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameComponent[] that)

      • extract

        public static NameComponent[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameComponent[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameComponent[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NameHolder

  • java.lang.Object
    • org.omg.CosNaming.NameHolder
  • All Implemented Interfaces:
    Streamable

    public final class NameHolder
extends Object
implements Streamable
    A name is a sequence of name components.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NameComponent[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      NameHolder()
      NameHolder(NameComponent[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NameComponent[] value

    • Constructor Detail

      • NameHolder

        public NameHolder()

      • NameHolder

        public NameHolder(NameComponent[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Interface NamingContext

  • All Superinterfaces:
    IDLEntity, NamingContextOperations, Object, Serializable
    All Known Subinterfaces:
    NamingContextExt
    All Known Implementing Classes:
    _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub

    public interface NamingContext
extends NamingContextOperations, Object, IDLEntity
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • Method Summary

      • Methods inherited from interface org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextExt (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Interface NamingContextExt

  • All Superinterfaces:
    IDLEntity, NamingContext, NamingContextExtOperations, NamingContextOperations, Object, Serializable
    All Known Implementing Classes:
    _NamingContextExtStub

    public interface NamingContextExt
extends NamingContextExtOperations, NamingContext, IDLEntity
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • Method Summary

      • Methods inherited from interface org.omg.CosNaming.NamingContextExtOperations

        resolve_str, to_name, to_string, to_url

      • Methods inherited from interface org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextExtHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NamingContextExtHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtHelper

  • public abstract class NamingContextExtHelper
extends Object
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • Constructor Summary

      Constructors
      Constructor and Description
      NamingContextExtHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NamingContextExt | extract(Any a)
      static String | id()
      static void | insert(Any a, NamingContextExt that)
      static NamingContextExt | narrow(Object obj)
      static NamingContextExt | read(InputStream istream)
      static TypeCode | type()
      static NamingContextExt | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, NamingContextExt value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NamingContextExtHelper

        public NamingContextExtHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NamingContextExt that)

      • extract

        public static NamingContextExt extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NamingContextExt read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NamingContextExt value)

      • narrow

        public static NamingContextExt narrow(Object obj)

      • unchecked_narrow

        public static NamingContextExt unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextExtHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NamingContextExtHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtHolder
  • All Implemented Interfaces:
    Streamable

    public final class NamingContextExtHolder
extends Object
implements Streamable
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NamingContextExt value

    • Constructor Summary

      Constructors
      Constructor and Description
      NamingContextExtHolder()
      NamingContextExtHolder(NamingContextExt initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NamingContextExt value

    • Constructor Detail

      • NamingContextExtHolder

        public NamingContextExtHolder()

      • NamingContextExtHolder

        public NamingContextExtHolder(NamingContextExt initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextExtOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Interface NamingContextExtOperations

  • All Superinterfaces:
    NamingContextOperations
    All Known Subinterfaces:
    NamingContextExt
    All Known Implementing Classes:
    _NamingContextExtStub, NamingContextExtPOA

    public interface NamingContextExtOperations
extends NamingContextOperations
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      NameComponent[] to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      String to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.

      • Methods inherited from interface org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

    • Method Detail

      • to_string

        String to_string(NameComponent[] n)
          throws InvalidName
        This operation creates a stringified name from the array of Name components.
        Parameters:
        n - Name of the object

        Throws:
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_name

        NameComponent[] to_name(String sn)
                 throws InvalidName
        This operation converts a Stringified Name into an equivalent array of Name Components.
        Parameters:
        sn - Stringified Name of the object

        Throws:
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_url

        String to_url(String addr,
              String sn)
       throws InvalidAddress,
              InvalidName
        This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
        Parameters:
        addr - internet based address of the host machine where Name Service is running

        sn - Stringified Name of the object

        Throws:
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        org.omg.CosNaming.NamingContextPackage.InvalidAddress - Indicates the internet based address of the host machine is incorrect

        InvalidAddress
        InvalidName

      • resolve_str

        Object resolve_str(String sn)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        This operation resolves the Stringified name into the object reference.
        Parameters:
        sn - Stringified Name of the object

        Throws:
        NotFound - Indicates there is no object reference for the given name.

        CannotProceed - Indicates that the given compound name is incorrect

        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextExtPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NamingContextExtPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.NamingContextExtPOA
  • All Implemented Interfaces:
    InvokeHandler, NamingContextExtOperations, NamingContextOperations

    public abstract class NamingContextExtPOA
extends Servant
implements NamingContextExtOperations, InvokeHandler
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • Constructor Summary

      Constructors
      Constructor and Description
      NamingContextExtPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      NamingContextExt _this()
      NamingContextExt | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.CosNaming.NamingContextExtOperations

        resolve_str, to_name, to_string, to_url

      • Methods inherited from interface org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

    • Constructor Detail

      • NamingContextExtPOA

        public NamingContextExtPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public NamingContextExt _this()

      • _this

        public NamingContextExt _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NamingContextHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextHelper

  • public abstract class NamingContextHelper
extends Object
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • Constructor Summary

      Constructors
      Constructor and Description
      NamingContextHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NamingContext | extract(Any a)
      static String | id()
      static void | insert(Any a, NamingContext that)
      static NamingContext | narrow(Object obj)
      static NamingContext | read(InputStream istream)
      static TypeCode | type()
      static NamingContext | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, NamingContext value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NamingContextHelper

        public NamingContextHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NamingContext that)

      • extract

        public static NamingContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NamingContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NamingContext value)

      • narrow

        public static NamingContext narrow(Object obj)

      • unchecked_narrow

        public static NamingContext unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NamingContextHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextHolder
  • All Implemented Interfaces:
    Streamable

    public final class NamingContextHolder
extends Object
implements Streamable
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NamingContext value

    • Constructor Summary

      Constructors
      Constructor and Description
      NamingContextHolder()
      NamingContextHolder(NamingContext initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NamingContext value

    • Constructor Detail

      • NamingContextHolder

        public NamingContextHolder()

      • NamingContextHolder

        public NamingContextHolder(NamingContext initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Interface NamingContextOperations

  • All Known Subinterfaces:
    NamingContext, NamingContextExt, NamingContextExtOperations
    All Known Implementing Classes:
    _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, NamingContextExtPOA, NamingContextPOA

    public interface NamingContextOperations
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void destroy()
      The destroy operation deletes a naming context.
      void list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      NamingContext new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      void rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Method Detail

      • bind

        void bind(NameComponent[] n,
          Object obj)
   throws NotFound,
          CannotProceed,
          InvalidName,
          AlreadyBound
        Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.
        Parameters:
        n - Name of the object

        obj - The Object to bind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • bind_context

        void bind_context(NameComponent[] n,
                  NamingContext nc)
           throws NotFound,
                  CannotProceed,
                  InvalidName,
                  AlreadyBound
        Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.
        Parameters:
        n - Name of the object

        nc - NamingContect object to bind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • rebind

        void rebind(NameComponent[] n,
            Object obj)
     throws NotFound,
            CannotProceed,
            InvalidName
        Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.
        Parameters:
        n - Name of the object

        obj - The Object to rebind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • rebind_context

        void rebind_context(NameComponent[] n,
                    NamingContext nc)
             throws NotFound,
                    CannotProceed,
                    InvalidName
        Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.
        Parameters:
        n - Name of the object

        nc - NamingContect object to rebind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • resolve

        Object resolve(NameComponent[] n)
        throws NotFound,
               CannotProceed,
               InvalidName
        The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • unbind

        void unbind(NameComponent[] n)
     throws NotFound,
            CannotProceed,
            InvalidName
        The unbind operation removes a name binding from a context.
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • list

        void list(int how_many,
          BindingListHolder bl,
          BindingIteratorHolder bi)
        The list operation allows a client to iterate through a set of bindings in a naming context.

        The list operation returns at most the requested number of bindings in BindingList bl.

        • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
        • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.
        Parameters:
        how_many - the maximum number of bindings to return

        bl - the returned list of bindings

        bi - the returned binding iterator

      • new_context

        NamingContext new_context()
        This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.

      • bind_new_context

        NamingContext bind_new_context(NameComponent[] n)
                        throws NotFound,
                               AlreadyBound,
                               CannotProceed,
                               InvalidName
        This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        AlreadyBound - Indicates an object is already bound to the specified name.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • destroy

        void destroy()
      throws NotEmpty
        The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.
        Throws:
        NotEmpty - Indicates that the Naming Context contains bindings.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamingContextPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class NamingContextPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.NamingContextPOA
  • All Implemented Interfaces:
    InvokeHandler, NamingContextOperations

    public abstract class NamingContextPOA
extends Servant
implements NamingContextOperations, InvokeHandler
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • Constructor Summary

      Constructors
      Constructor and Description
      NamingContextPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      NamingContext _this()
      NamingContext | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

    • Constructor Detail

      • NamingContextPOA

        public NamingContextPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public NamingContext _this()

      • _this

        public NamingContext _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CosNaming (Java Platform SE 8 )

org.omg.CosNaming

Interfaces

  • BindingIterator
  • BindingIteratorOperations
  • NamingContext
  • NamingContextExt
  • NamingContextExtOperations
  • NamingContextOperations

Classes

  • _BindingIteratorImplBase
  • _BindingIteratorStub
  • _NamingContextExtStub
  • _NamingContextImplBase
  • _NamingContextStub
  • Binding
  • BindingHelper
  • BindingHolder
  • BindingIteratorHelper
  • BindingIteratorHolder
  • BindingIteratorPOA
  • BindingListHelper
  • BindingListHolder
  • BindingType
  • BindingTypeHelper
  • BindingTypeHolder
  • IstringHelper
  • NameComponent
  • NameComponentHelper
  • NameComponentHolder
  • NameHelper
  • NameHolder
  • NamingContextExtHelper
  • NamingContextExtHolder
  • NamingContextExtPOA
  • NamingContextHelper
  • NamingContextHolder
  • NamingContextPOA


org.omg.CosNaming (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CosNaming

Provides a naming service for Java IDL.

See: Description

  • Interface Summary
    Interface Description
    BindingIterator
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorOperations
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextExt
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtOperations
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextOperations
    A naming context is an object that contains a set of name bindings in which each name is unique.
  • Class Summary
    Class Description
    _BindingIteratorImplBase
    _BindingIteratorStub
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    _NamingContextExtStub
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    _NamingContextImplBase
    _NamingContextStub
    A naming context is an object that contains a set of name bindings in which each name is unique.
    Binding
    org/omg/CosNaming/Binding.java .
    BindingHelper
    org/omg/CosNaming/BindingHelper.java .
    BindingHolder
    org/omg/CosNaming/BindingHolder.java .
    BindingIteratorHelper
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorHolder
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorPOA
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingListHelper
    List of Bindings.
    BindingListHolder
    List of Bindings.
    BindingType
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    BindingTypeHelper
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    BindingTypeHolder
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    IstringHelper
    org/omg/CosNaming/IstringHelper.java .
    NameComponent
    org/omg/CosNaming/NameComponent.java .
    NameComponentHelper
    org/omg/CosNaming/NameComponentHelper.java .
    NameComponentHolder
    org/omg/CosNaming/NameComponentHolder.java .
    NameHelper
    A name is a sequence of name components.
    NameHolder
    A name is a sequence of name components.
    NamingContextExtHelper
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtHolder
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtPOA
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextHelper
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextHolder
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextPOA
    A naming context is an object that contains a set of name bindings in which each name is unique.

Package org.omg.CosNaming Description

Provides a naming service for Java IDL. The Object Request Broker Daemon (ORBD) also includes both a transient and persistent naming service.

The package and all its classes and interfaces were generated by running the tool idlj on the file nameservice.idl, which is a module written in OMG IDL.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Interfaces

The package org.omg.CosNaming contains two public interfaces and several auxiliary classes.

The interfaces are:

  • NamingContext
  • BindingIterator

These two interfaces provide the means to bind/unbind names and object references, to retrieve bound object references, and to iterate through a list of bindings. The NamingContext interface supplies the main functionality for the naming service, and BindingIterator provides a means of iterating through a list of name/object reference bindings.

Auxiliary Classes

In order to map an OMG IDL interface to the Java programming language, the idlj compiler creates Java classes that can be thought of as auxiliary classes. Comments for the generated auxiliary classes used by the interfaces NamingContext and BindingIterator are included here.

Classes Used by NamingContext and BindingIterator

The following are classes used by the naming service. (Helper and holder classes, which are generated for each of the classes listed here, are discussed below.)
  • public final class NameComponent -- a building block for names. (Names are bound to object references in a naming context.)

    A name is an array of one or more NameComponent objects. A name with a single NameComponent is called a simple name; a name with multiple NameComponent objects is called a compound name.

    A NameComponent object consists of two fields:

    1. id -- a String used as an identifier
    2. kind -- a String that can be used for any descriptive purpose. Its importance is that it can be used to describe an object without affecting syntax. The C programming language, for example, uses the the syntactic convention of appending the extension ".c" to a file name to indicate that it is a source code file. In a NameComponent object, the kind field can be used to describe the type of object rather than a file extension or some other syntactic convention. Examples of the value of the kind field include the strings "c_source", "object_code", "executable", "postscript", and "". It is not unusual for the kind field to be the empty string.

    In a name, each NameComponent object except the last denotes a NamingContext object; the last NameComponent object denotes the bound object reference. This is similar to a path name, in which the last name is the file name, and all names before it are directory names.

  • public final class Binding -- an object that associates a name with an object reference or a naming context. A Binding object has two fields:
    1. binding_name - an array of one or more NameComponent objects that represents the bound name
    2. binding_type - a BindingType object indicating whether the binding is between a name and an object reference or between a name and a naming context

    The interface NamingContext has methods for binding/unbinding names with object references or naming contexts, for listing bindings, and for resolving bindings (given a name, the method resolve returns the object reference bound to it).

  • public final class BindingType -- an object that specifies whether the given Binding object is a binding between a name and an object reference (that is, not a naming context) or between a name and a naming context.

    The classBindingType consists of two methods and four constants. Two of these constants are BindingType objects, and two are ints.

    The BindingType objects can be passed to the constructor for the class Binding or used as parameters or return values. These BindingType objects are:

    • public static final BindingType nobject -- to indicate that the binding is with an object reference
    • public static final BindingType ncontext -- to indicate that the binding is with a naming context

    The int constants can be supplied to the method from_int to create BindingType objects, or they can be return values for the method value. These constants are:

    • public static final int _nobject
    • public static final int _ncontext
    If the method from_int is supplied with anything other than _nobject or _ncontext, it will throw the exception org.omg.CORBA.BAD_PARAM.

    Usage is as follows:

           BindingType btObject = from_int(_nobject);
       BindingType btContext = from_int(_ncontext);
    The variable btObject refers to a BindingType object initialized to represent a binding with an object reference. The variable btContext refers to a BindingType object initialized to represent a binding with a NamingContex object.

    The method value returns either _nobject or _ncontext, so in the following line of code, the variable bt will contain _nobject or _ncontext:

           int bt = BindingType.value();

Holder Classes

OMG IDL uses OUT and INOUT parameters for returning values from operations. The mapping to the Java programming language, which does not have OUT and INOUT parameters, creates a special class for each type, called a holder class. An instance of a holder class can be passed to a Java method as a parameter, and a value can be assigned to its value field. This allows it to perform the function of an OUT or INOUT parameter.

The following holder classes are generated for the package org.omg.CosNaming:

  • NamingContextHolder
  • BindingIteratorHolder
  • BindingHolder
  • BindingListHolder
  • BindingTypeHolder
  • NameComponentHolder
  • NameHolder

Note that in the org.omg.CORBA package, there is a holder class for each of the basic Java types: IntHolder, ShortHolder, StringHolder, and so on.

Note also that there is a NameHolder class even though there is no Name class; similarly, there is a BindingListHolder class even though there is no BindingList class. This is true because in the OMG IDL interface, Name and BindingList are typedefs. There is no mapping from an IDL typedef to a Java construct, but holder classes are generated if the typedef is for a sequence or an array. As mapped to the Java programming language, Name is an array of NameComponent objects, and a BindingList is an array of Binding objects. All holder classes have at least two constructors and one field:

  • value field -- an instance of the type being used as an OUT or INOUT parameter. For example, the value field of a NamingContextHolder will be a NamingContext object.
  • default constructor -- a constructor that creates a new holder object initialized with the default value for the type. For example, a new BindingHolder object created with the default constructor will have its value field set to null because that is the default value for an object. Other defaults are false for boolean, 0 for numeric and char types, and null for object references.
  • constructor from an instance -- a constructor that creates a new holder object whose value field is initialized with the instance supplied

A holder class for a user-defined type (a Java class) has three more methods, but application developers do not use them directly.

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types.

There is only one method in a helper class that an application programmer uses: the method narrow. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the CosNaming package, only the classes NamingContextHelper and BindingIteratorHelper have a narrow method.

  • public static NamingContext narrow(org.omg.CORBA.Object obj) -- converts the given CORBA object to a NamingContext object
  • public static BindingIterator narrow(org.omg.CORBA.Object obj) -- converts the given CORBA object to a BindingIterator object

Package org.omg.CosNaming.NamingContextPackage

This package supplies Helper and Holder classes for the exceptions used in the package org.omg.CosNaming and also for the class NotFoundReason, which supplies a reason for the exception NotFound.

There are Helper and Holder classes for the following exceptions:

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound

Naming Service Compatibility

Sun's implementation of the CosNaming package complies with the OMG COSNaming specification. In other words, the APIs in Sun's naming service are implemented according to the guidelines for a naming service provided by OMG. Therefore, if a third-party vendor has implemented a naming service that is OMG compliant, it is possible to switch between Sun's implementation of CosNaming and the third-party vendor's implementation. However, it is important to understand that there can be minor variations in the way different vendors implement the naming service, such as differences in the exception strings.

Instructions for Using a Third Party's Naming Service

Although we encourage using an ORB and ORB services that are both from one vendor, it is possible to plug in a third party's COSNaming implementation with Sun's RMI-IIOP ORB. Here are the steps to follow:
  1. Create a properties file for the Bootstrap server and give it two entries. For example, you could call this properties file /tmp/services and put the following in it: NameService, <Stringified IOR of the Root Naming Context>.

    This associates NameService with the Root Naming Context of the CosNaming implementation that you want to use.

  2. Start the standalone Bootstrap server using the following command:

      java -classpath $(CLASSPATH)
      com.sun.corba.ee.internal.CosNaming.BootstrapServer -InitialServicesFile
      "/tmp/services" [-ORBInitialPort port]

    Note that the square brackets at the end of the command indicate that specifying a port number is optional.

Now when an application calls the method org.omg.CORBA.ORB.resolve_initial_references, CORBA processes will contact the Bootstrap Server to get the Root Naming Context.

Package Specification

  • Interoperable Naming Service (ptc/00-08-07)

Related Documentation

For an overview and examples of how to use the CosNaming API, please see:
  • Naming Service

For an overview of Java IDL, please see:

  • Java IDL home page
Since:
JDK1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CosNaming Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CosNaming

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CosNaming.Binding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingHelper
    • org.omg.CosNaming.BindingHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingIteratorHelper
    • org.omg.CosNaming.BindingIteratorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingListHelper
    • org.omg.CosNaming.BindingListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingTypeHelper
    • org.omg.CosNaming.BindingTypeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.IstringHelper
    • org.omg.CosNaming.NameComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NameComponentHelper
    • org.omg.CosNaming.NameComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NameHelper
    • org.omg.CosNaming.NameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtHelper
    • org.omg.CosNaming.NamingContextExtHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextHelper
    • org.omg.CosNaming.NamingContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CosNaming._BindingIteratorStub (implements org.omg.CosNaming.BindingIterator)
      • org.omg.CosNaming._NamingContextExtStub (implements org.omg.CosNaming.NamingContextExt)
      • org.omg.CosNaming._NamingContextStub (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase (implements org.omg.CosNaming.BindingIterator)
        • org.omg.CosNaming._NamingContextImplBase (implements org.omg.CosNaming.NamingContext)
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA (implements org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.InvokeHandler)
      • org.omg.CosNaming.NamingContextExtPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextOperations)

Interface Hierarchy

  • org.omg.CosNaming.BindingIteratorOperations
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CosNaming.NamingContextOperations
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExtOperations
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext)
  • org.omg.CORBA.Object
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContext (also extends org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
        • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CosNaming (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CosNaming

  • Packages that use org.omg.CosNaming
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
  • Classes in org.omg.CosNaming used by org.omg.CosNaming
    Class and Description
    Binding
    org/omg/CosNaming/Binding.java .
    BindingHolder
    org/omg/CosNaming/BindingHolder.java .
    BindingIterator
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorHolder
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorOperations
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingListHolder
    List of Bindings.
    BindingType
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    NameComponent
    org/omg/CosNaming/NameComponent.java .
    NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextExt
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtOperations
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextOperations
    A naming context is an object that contains a set of name bindings in which each name is unique.
  • Classes in org.omg.CosNaming used by org.omg.CosNaming.NamingContextPackage
    Class and Description
    NameComponent
    org/omg/CosNaming/NameComponent.java .
    NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_BindingIteratorImplBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class _BindingIteratorImplBase

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations

    public abstract class _BindingIteratorImplBase
extends DynamicImplementation
implements BindingIterator
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      _BindingIteratorImplBase()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void | invoke(ServerRequest r)

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CosNaming.BindingIteratorOperations

        destroy, next_n, next_one

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _BindingIteratorImplBase

        public _BindingIteratorImplBase()

    • Method Detail

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Overrides:
        _ids in class DynamicImplementation
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance

      • invoke

        public void invoke(ServerRequest r)
        Overrides:
        invoke in class DynamicImplementation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_BindingIteratorStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class _BindingIteratorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CosNaming._BindingIteratorStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations

    public class _BindingIteratorStub
extends ObjectImpl
implements BindingIterator
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    See Also:
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder), Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      _BindingIteratorStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void destroy()
      This operation destroys the iterator.
      boolean next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
      boolean next_one(BindingHolder b)
      This operation returns the next binding.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _BindingIteratorStub

        public _BindingIteratorStub()

    • Method Detail

      • next_one

        public boolean next_one(BindingHolder b)
        This operation returns the next binding. If there are no more bindings, false is returned.
        Specified by:
        next_one in interface BindingIteratorOperations
        Parameters:
        b - the returned binding

      • next_n

        public boolean next_n(int how_many,
                      BindingListHolder bl)
        This operation returns at most the requested number of bindings.
        Specified by:
        next_n in interface BindingIteratorOperations
        Parameters:
        how_many - the maximum number of bindings tro return

        bl - the returned bindings

      • destroy

        public void destroy()
        This operation destroys the iterator.
        Specified by:
        destroy in interface BindingIteratorOperations

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_NamingContextExtStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class _NamingContextExtStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CosNaming._NamingContextExtStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, NamingContext, NamingContextExt, NamingContextExtOperations, NamingContextOperations

    public class _NamingContextExtStub
extends ObjectImpl
implements NamingContextExt
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      _NamingContextExtStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void destroy()
      The destroy operation deletes a naming context.
      void list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      NamingContext new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      void rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      NameComponent[] to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      String to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      void unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _NamingContextExtStub

        public _NamingContextExtStub()

    • Method Detail

      • to_string

        public String to_string(NameComponent[] n)
                 throws InvalidName
        This operation creates a stringified name from the array of Name components.
        Specified by:
        to_string in interface NamingContextExtOperations
        Parameters:
        n - Name of the object

        Throws:
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_name

        public NameComponent[] to_name(String sn)
                        throws InvalidName
        This operation converts a Stringified Name into an equivalent array of Name Components.
        Specified by:
        to_name in interface NamingContextExtOperations
        Parameters:
        sn - Stringified Name of the object

        Throws:
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_url

        public String to_url(String addr,
                     String sn)
              throws InvalidAddress,
                     InvalidName
        This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
        Specified by:
        to_url in interface NamingContextExtOperations
        Parameters:
        addr - internet based address of the host machine where Name Service is running

        sn - Stringified Name of the object

        Throws:
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        org.omg.CosNaming.NamingContextPackage.InvalidAddress - Indicates the internet based address of the host machine is incorrect

        InvalidAddress
        InvalidName

      • resolve_str

        public Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
        This operation resolves the Stringified name into the object reference.
        Specified by:
        resolve_str in interface NamingContextExtOperations
        Parameters:
        sn - Stringified Name of the object

        Throws:
        NotFound - Indicates there is no object reference for the given name.

        CannotProceed - Indicates that the given compound name is incorrect

        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • bind

        public void bind(NameComponent[] n,
                 Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
        Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.
        Specified by:
        bind in interface NamingContextOperations
        Parameters:
        n - Name of the object

        obj - The Object to bind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • bind_context

        public void bind_context(NameComponent[] n,
                         NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
        Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.
        Specified by:
        bind_context in interface NamingContextOperations
        Parameters:
        n - Name of the object

        nc - NamingContect object to bind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • rebind

        public void rebind(NameComponent[] n,
                   Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.
        Specified by:
        rebind in interface NamingContextOperations
        Parameters:
        n - Name of the object

        obj - The Object to rebind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • rebind_context

        public void rebind_context(NameComponent[] n,
                           NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
        Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.
        Specified by:
        rebind_context in interface NamingContextOperations
        Parameters:
        n - Name of the object

        nc - NamingContect object to rebind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • resolve

        public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
        The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.
        Specified by:
        resolve in interface NamingContextOperations
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • unbind

        public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        The unbind operation removes a name binding from a context.
        Specified by:
        unbind in interface NamingContextOperations
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • list

        public void list(int how_many,
                 BindingListHolder bl,
                 BindingIteratorHolder bi)
        The list operation allows a client to iterate through a set of bindings in a naming context.

        The list operation returns at most the requested number of bindings in BindingList bl.

        • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
        • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.
        Specified by:
        list in interface NamingContextOperations
        Parameters:
        how_many - the maximum number of bindings to return

        bl - the returned list of bindings

        bi - the returned binding iterator

      • new_context

        public NamingContext new_context()
        This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.
        Specified by:
        new_context in interface NamingContextOperations

      • bind_new_context

        public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
        This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).
        Specified by:
        bind_new_context in interface NamingContextOperations
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        AlreadyBound - Indicates an object is already bound to the specified name.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • destroy

        public void destroy()
             throws NotEmpty
        The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.
        Specified by:
        destroy in interface NamingContextOperations
        Throws:
        NotEmpty - Indicates that the Naming Context contains bindings.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_NamingContextImplBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class _NamingContextImplBase

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._NamingContextImplBase
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, NamingContext, NamingContextOperations

    public abstract class _NamingContextImplBase
extends DynamicImplementation
implements NamingContext
    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      _NamingContextImplBase()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void | invoke(ServerRequest r)

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _NamingContextImplBase

        public _NamingContextImplBase()

    • Method Detail

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Overrides:
        _ids in class DynamicImplementation
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance

      • invoke

        public void invoke(ServerRequest r)
        Overrides:
        invoke in class DynamicImplementation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_NamingContextStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming

Class _NamingContextStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CosNaming._NamingContextStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, NamingContext, NamingContextOperations

    public class _NamingContextStub
extends ObjectImpl
implements NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    See Also:
    Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      _NamingContextStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void destroy()
      The destroy operation deletes a naming context.
      void list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      NamingContext new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      void rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Constructor Detail

      • _NamingContextStub

        public _NamingContextStub()

    • Method Detail

      • bind

        public void bind(NameComponent[] n,
                 Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
        Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.
        Specified by:
        bind in interface NamingContextOperations
        Parameters:
        n - Name of the object

        obj - The Object to bind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • bind_context

        public void bind_context(NameComponent[] n,
                         NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
        Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.
        Specified by:
        bind_context in interface NamingContextOperations
        Parameters:
        n - Name of the object

        nc - NamingContect object to bind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • rebind

        public void rebind(NameComponent[] n,
                   Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.
        Specified by:
        rebind in interface NamingContextOperations
        Parameters:
        n - Name of the object

        obj - The Object to rebind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • rebind_context

        public void rebind_context(NameComponent[] n,
                           NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
        Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.
        Specified by:
        rebind_context in interface NamingContextOperations
        Parameters:
        n - Name of the object

        nc - NamingContect object to rebind with the given name

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • resolve

        public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
        The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.
        Specified by:
        resolve in interface NamingContextOperations
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • unbind

        public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        The unbind operation removes a name binding from a context.
        Specified by:
        unbind in interface NamingContextOperations
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • list

        public void list(int how_many,
                 BindingListHolder bl,
                 BindingIteratorHolder bi)
        The list operation allows a client to iterate through a set of bindings in a naming context.

        The list operation returns at most the requested number of bindings in BindingList bl.

        • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
        • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.
        Specified by:
        list in interface NamingContextOperations
        Parameters:
        how_many - the maximum number of bindings to return

        bl - the returned list of bindings

        bi - the returned binding iterator

      • new_context

        public NamingContext new_context()
        This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.
        Specified by:
        new_context in interface NamingContextOperations

      • bind_new_context

        public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
        This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).
        Specified by:
        bind_new_context in interface NamingContextOperations
        Parameters:
        n - Name of the object

        Throws:
        NotFound - Indicates the name does not identify a binding.

        AlreadyBound - Indicates an object is already bound to the specified name.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • destroy

        public void destroy()
             throws NotEmpty
        The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.
        Specified by:
        destroy in interface NamingContextOperations
        Throws:
        NotEmpty - Indicates that the Naming Context contains bindings.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.Binding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.Binding

  • Packages that use Binding
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of Binding in org.omg.CosNaming

      Fields in org.omg.CosNaming declared as Binding
      Modifier and Type | Field and Description
      Binding | BindingHolder.value
      Binding[] | BindingListHolder.value
      Methods in org.omg.CosNaming that return Binding
      Modifier and Type | Method and Description
      static Binding | BindingHelper.extract(Any a)
      static Binding[] | BindingListHelper.extract(Any a)
      static Binding | BindingHelper.read(InputStream istream)
      static Binding[] | BindingListHelper.read(InputStream istream)
      Methods in org.omg.CosNaming with parameters of type Binding
      Modifier and Type | Method and Description
      static void | BindingHelper.insert(Any a, Binding that)
      static void | BindingListHelper.insert(Any a, Binding[] that)
      static void | BindingHelper.write(OutputStream ostream, Binding value)
      static void | BindingListHelper.write(OutputStream ostream, Binding[] value)
      Constructors in org.omg.CosNaming with parameters of type Binding
      Constructor and Description
      BindingHolder(Binding initialValue)
      BindingListHolder(Binding[] initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingHelper

No usage of org.omg.CosNaming.BindingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingHolder

  • Packages that use BindingHolder
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingHolder in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type BindingHolder
      Modifier and Type Method and Description
      boolean BindingIteratorOperations.next_one(BindingHolder b)
      This operation returns the next binding.
      boolean _BindingIteratorStub.next_one(BindingHolder b)
      This operation returns the next binding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CosNaming.BindingIterator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CosNaming.BindingIterator

  • Packages that use BindingIterator
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingIterator in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement BindingIterator
      Modifier and Type | Class and Description
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      Fields in org.omg.CosNaming declared as BindingIterator
      Modifier and Type | Field and Description
      BindingIterator | BindingIteratorHolder.value
      Methods in org.omg.CosNaming that return BindingIterator
      Modifier and Type | Method and Description
      BindingIterator | BindingIteratorPOA._this()
      BindingIterator | BindingIteratorPOA._this(ORB orb)
      static BindingIterator | BindingIteratorHelper.extract(Any a)
      static BindingIterator | BindingIteratorHelper.narrow(Object obj)
      static BindingIterator | BindingIteratorHelper.read(InputStream istream)
      static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.CosNaming with parameters of type BindingIterator
      Modifier and Type | Method and Description
      static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
      static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)
      Constructors in org.omg.CosNaming with parameters of type BindingIterator
      Constructor and Description
      BindingIteratorHolder(BindingIterator initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingIteratorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingIteratorHelper

No usage of org.omg.CosNaming.BindingIteratorHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingIteratorHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingIteratorHolder

  • Packages that use BindingIteratorHolder
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingIteratorHolder in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type BindingIteratorHolder
      Modifier and Type Method and Description
      void NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CosNaming.BindingIteratorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CosNaming.BindingIteratorOperations

  • Packages that use BindingIteratorOperations
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingIteratorOperations in org.omg.CosNaming

      Subinterfaces of BindingIteratorOperations in org.omg.CosNaming
      Modifier and Type Interface and Description
      interface  BindingIterator
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      Classes in org.omg.CosNaming that implement BindingIteratorOperations
      Modifier and Type | Class and Description
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingIteratorPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingIteratorPOA

No usage of org.omg.CosNaming.BindingIteratorPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingListHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingListHelper

No usage of org.omg.CosNaming.BindingListHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingListHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingListHolder

  • Packages that use BindingListHolder
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingListHolder in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type BindingListHolder
      Modifier and Type Method and Description
      void NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      boolean BindingIteratorOperations.next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
      boolean _BindingIteratorStub.next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingType

  • Packages that use BindingType
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingType in org.omg.CosNaming

      Fields in org.omg.CosNaming declared as BindingType
      Modifier and Type | Field and Description
      BindingType | Binding.binding_type
      static BindingType | BindingType.ncontext
      static BindingType | BindingType.nobject
      BindingType | BindingTypeHolder.value
      Methods in org.omg.CosNaming that return BindingType
      Modifier and Type | Method and Description
      static BindingType | BindingTypeHelper.extract(Any a)
      static BindingType | BindingType.from_int(int value)
      static BindingType | BindingTypeHelper.read(InputStream istream)
      Methods in org.omg.CosNaming with parameters of type BindingType
      Modifier and Type | Method and Description
      static void | BindingTypeHelper.insert(Any a, BindingType that)
      static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)
      Constructors in org.omg.CosNaming with parameters of type BindingType
      Constructor and Description
      Binding(NameComponent[] _binding_name, BindingType _binding_type)
      BindingTypeHolder(BindingType initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingTypeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingTypeHelper

No usage of org.omg.CosNaming.BindingTypeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.BindingTypeHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.BindingTypeHolder

No usage of org.omg.CosNaming.BindingTypeHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.IstringHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.IstringHelper

No usage of org.omg.CosNaming.IstringHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NameComponent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NameComponent

  • Packages that use NameComponent
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NameComponent in org.omg.CosNaming

      Fields in org.omg.CosNaming declared as NameComponent
      Modifier and Type | Field and Description
      NameComponent[] | Binding.binding_name
      NameComponent[] | NameHolder.value
      NameComponent | NameComponentHolder.value
      Methods in org.omg.CosNaming that return NameComponent
      Modifier and Type | Method and Description
      static NameComponent | NameComponentHelper.extract(Any a)
      static NameComponent[] | NameHelper.extract(Any a)
      static NameComponent | NameComponentHelper.read(InputStream istream)
      static NameComponent[] | NameHelper.read(InputStream istream)
      NameComponent[] NamingContextExtOperations.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      NameComponent[] _NamingContextExtStub.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      Methods in org.omg.CosNaming with parameters of type NameComponent
      Modifier and Type | Method and Description
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      static void | NameComponentHelper.insert(Any a, NameComponent that)
      static void | NameHelper.insert(Any a, NameComponent[] that)
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      String NamingContextExtOperations.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String _NamingContextExtStub.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
      static void | NameHelper.write(OutputStream ostream, NameComponent[] value)
      Constructors in org.omg.CosNaming with parameters of type NameComponent
      Constructor and Description
      Binding(NameComponent[] _binding_name, BindingType _binding_type)
      NameComponentHolder(NameComponent initialValue)
      NameHolder(NameComponent[] initialValue)

    • Uses of NameComponent in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NameComponent
      Modifier and Type | Field and Description
      NameComponent[] | CannotProceed.rest_of_name
      NameComponent[] | NotFound.rest_of_name
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NameComponent
      Constructor and Description
      CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
      CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
      NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NameComponentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NameComponentHelper

No usage of org.omg.CosNaming.NameComponentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NameComponentHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NameComponentHolder

No usage of org.omg.CosNaming.NameComponentHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NameHelper

No usage of org.omg.CosNaming.NameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NameHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NameHolder

No usage of org.omg.CosNaming.NameHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CosNaming.NamingContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CosNaming.NamingContext

  • Packages that use NamingContext
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NamingContext in org.omg.CosNaming

      Subinterfaces of NamingContext in org.omg.CosNaming
      Modifier and Type Interface and Description
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement NamingContext
      Modifier and Type | Class and Description
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      Fields in org.omg.CosNaming declared as NamingContext
      Modifier and Type | Field and Description
      NamingContext | NamingContextHolder.value
      Methods in org.omg.CosNaming that return NamingContext
      Modifier and Type | Method and Description
      NamingContext | NamingContextPOA._this()
      NamingContext | NamingContextPOA._this(ORB orb)
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      static NamingContext | NamingContextHelper.extract(Any a)
      static NamingContext | NamingContextHelper.narrow(Object obj)
      NamingContext NamingContextOperations.new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      NamingContext _NamingContextExtStub.new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      NamingContext _NamingContextStub.new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      static NamingContext | NamingContextHelper.read(InputStream istream)
      static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)
      Methods in org.omg.CosNaming with parameters of type NamingContext
      Modifier and Type | Method and Description
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      static void | NamingContextHelper.insert(Any a, NamingContext that)
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)
      Constructors in org.omg.CosNaming with parameters of type NamingContext
      Constructor and Description
      NamingContextHolder(NamingContext initialValue)

    • Uses of NamingContext in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NamingContext
      Modifier and Type | Field and Description
      NamingContext | CannotProceed.cxt
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NamingContext
      Constructor and Description
      CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
      CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CosNaming.NamingContextExt (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CosNaming.NamingContextExt

  • Packages that use NamingContextExt
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of NamingContextExt in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement NamingContextExt
      Modifier and Type Class and Description
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Fields in org.omg.CosNaming declared as NamingContextExt
      Modifier and Type | Field and Description
      NamingContextExt | NamingContextExtHolder.value
      Methods in org.omg.CosNaming that return NamingContextExt
      Modifier and Type | Method and Description
      NamingContextExt | NamingContextExtPOA._this()
      NamingContextExt | NamingContextExtPOA._this(ORB orb)
      static NamingContextExt | NamingContextExtHelper.extract(Any a)
      static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
      static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
      static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)
      Methods in org.omg.CosNaming with parameters of type NamingContextExt
      Modifier and Type | Method and Description
      static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
      static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)
      Constructors in org.omg.CosNaming with parameters of type NamingContextExt
      Constructor and Description
      NamingContextExtHolder(NamingContextExt initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtHelper

No usage of org.omg.CosNaming.NamingContextExtHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtHolder

No usage of org.omg.CosNaming.NamingContextExtHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CosNaming.NamingContextExtOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CosNaming.NamingContextExtOperations

  • Packages that use NamingContextExtOperations
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of NamingContextExtOperations in org.omg.CosNaming

      Subinterfaces of NamingContextExtOperations in org.omg.CosNaming
      Modifier and Type Interface and Description
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement NamingContextExtOperations
      Modifier and Type Class and Description
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPOA

No usage of org.omg.CosNaming.NamingContextExtPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextHelper

No usage of org.omg.CosNaming.NamingContextHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextHolder

No usage of org.omg.CosNaming.NamingContextHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.CosNaming.NamingContextOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.CosNaming.NamingContextOperations

  • Packages that use NamingContextOperations
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of NamingContextOperations in org.omg.CosNaming

      Subinterfaces of NamingContextOperations in org.omg.CosNaming
      Modifier and Type Interface and Description
      interface  NamingContext
      A naming context is an object that contains a set of name bindings in which each name is unique.
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      interface  NamingContextExtOperations
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement NamingContextOperations
      Modifier and Type | Class and Description
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPOA

No usage of org.omg.CosNaming.NamingContextPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming._BindingIteratorImplBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming._BindingIteratorImplBase

No usage of org.omg.CosNaming._BindingIteratorImplBase
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming._BindingIteratorStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming._BindingIteratorStub

No usage of org.omg.CosNaming._BindingIteratorStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming._NamingContextExtStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming._NamingContextExtStub

No usage of org.omg.CosNaming._NamingContextExtStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming._NamingContextImplBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming._NamingContextImplBase

No usage of org.omg.CosNaming._NamingContextImplBase
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming._NamingContextStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming._NamingContextStub

No usage of org.omg.CosNaming._NamingContextStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AddressHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextExtPackage

Class AddressHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper

  • public abstract class AddressHelper
extends Object
    Address is the Host and Port information represented as a String.

    • Constructor Summary

      Constructors
      Constructor and Description
      AddressHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AddressHelper

        public AddressHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidAddress (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextExtPackage

Class InvalidAddress

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidAddress
extends UserException
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidAddress()
      InvalidAddress(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidAddress

        public InvalidAddress()

      • InvalidAddress

        public InvalidAddress(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidAddressHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextExtPackage

Class InvalidAddressHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

  • public abstract class InvalidAddressHelper
extends Object
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidAddressHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidAddress | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidAddress that)
      static InvalidAddress | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidAddress value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidAddressHelper

        public InvalidAddressHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidAddress that)

      • extract

        public static InvalidAddress extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidAddress read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidAddress value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidAddressHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextExtPackage

Class InvalidAddressHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
  • All Implemented Interfaces:
    Streamable

    public final class InvalidAddressHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      InvalidAddress value

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidAddressHolder()
      InvalidAddressHolder(InvalidAddress initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public InvalidAddress value

    • Constructor Detail

      • InvalidAddressHolder

        public InvalidAddressHolder()

      • InvalidAddressHolder

        public InvalidAddressHolder(InvalidAddress initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CosNaming.NamingContextExtPackage (Java Platform SE 8 )

org.omg.CosNaming.NamingContextExtPackage

Classes

  • AddressHelper
  • InvalidAddressHelper
  • InvalidAddressHolder
  • StringNameHelper
  • URLStringHelper

Exceptions

  • InvalidAddress


org.omg.CosNaming.NamingContextExtPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CosNaming.NamingContextExtPackage

This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

See: Description

  • Class Summary
    Class Description
    AddressHelper
    Address is the Host and Port information represented as a String.
    InvalidAddressHelper
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java .
    InvalidAddressHolder
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .
    StringNameHelper
    StringName is the Stringified Name, Array of Name Components represented as a String.
    URLStringHelper
    URLString is the URL address (corbaloc: or corbaname:) represented as a String.
  • Exception Summary
    Exception Description
    InvalidAddress
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

Package org.omg.CosNaming.NamingContextExtPackage Description

This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

  • AddressHelper
  • StringNameHelper
  • URLStringHelper
  • InvalidAddress

    Package Specification

    For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CosNaming.NamingContextExtPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CosNaming.NamingContextExtPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CosNaming.NamingContextExtPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CosNaming.NamingContextExtPackage

  • Packages that use org.omg.CosNaming.NamingContextExtPackage
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
  • Classes in org.omg.CosNaming.NamingContextExtPackage used by org.omg.CosNaming
    Class and Description
    InvalidAddress
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .
  • Classes in org.omg.CosNaming.NamingContextExtPackage used by org.omg.CosNaming.NamingContextExtPackage
    Class and Description
    InvalidAddress
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


StringNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextExtPackage

Class StringNameHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

  • public abstract class StringNameHelper
extends Object
    StringName is the Stringified Name, Array of Name Components represented as a String.

    • Constructor Summary

      Constructors
      Constructor and Description
      StringNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • StringNameHelper

        public StringNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


URLStringHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextExtPackage

Class URLStringHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

  • public abstract class URLStringHelper
extends Object
    URLString is the URL address (corbaloc: or corbaname:) represented as a String.

    • Constructor Summary

      Constructors
      Constructor and Description
      URLStringHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • URLStringHelper

        public URLStringHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPackage.AddressHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.AddressHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.AddressHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPackage.InvalidAddress (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.InvalidAddress

  • Packages that use InvalidAddress
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

    • Uses of InvalidAddress in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw InvalidAddress
      Modifier and Type Method and Description
      String NamingContextExtOperations.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      String _NamingContextExtStub.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.

    • Uses of InvalidAddress in org.omg.CosNaming.NamingContextExtPackage

      Fields in org.omg.CosNaming.NamingContextExtPackage declared as InvalidAddress
      Modifier and Type | Field and Description
      InvalidAddress | InvalidAddressHolder.value
      Methods in org.omg.CosNaming.NamingContextExtPackage that return InvalidAddress
      Modifier and Type | Method and Description
      static InvalidAddress | InvalidAddressHelper.extract(Any a)
      static InvalidAddress | InvalidAddressHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type InvalidAddress
      Modifier and Type | Method and Description
      static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
      static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)
      Constructors in org.omg.CosNaming.NamingContextExtPackage with parameters of type InvalidAddress
      Constructor and Description
      InvalidAddressHolder(InvalidAddress initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder

No usage of org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AlreadyBound (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class AlreadyBound

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AlreadyBound
extends UserException
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AlreadyBound()
      AlreadyBound(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AlreadyBound

        public AlreadyBound()

      • AlreadyBound

        public AlreadyBound(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AlreadyBoundHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class AlreadyBoundHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

  • public abstract class AlreadyBoundHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AlreadyBoundHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AlreadyBound | extract(Any a)
      static String | id()
      static void | insert(Any a, AlreadyBound that)
      static AlreadyBound | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AlreadyBound value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AlreadyBoundHelper

        public AlreadyBoundHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AlreadyBound that)

      • extract

        public static AlreadyBound extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AlreadyBound read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AlreadyBound value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AlreadyBoundHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class AlreadyBoundHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
  • All Implemented Interfaces:
    Streamable

    public final class AlreadyBoundHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      AlreadyBound value

    • Constructor Summary

      Constructors
      Constructor and Description
      AlreadyBoundHolder()
      AlreadyBoundHolder(AlreadyBound initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public AlreadyBound value

    • Constructor Detail

      • AlreadyBoundHolder

        public AlreadyBoundHolder()

      • AlreadyBoundHolder

        public AlreadyBoundHolder(AlreadyBound initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CannotProceed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class CannotProceed

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class CannotProceed
extends UserException
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NamingContext cxt
      NameComponent[] rest_of_name

    • Constructor Summary

      Constructors
      Constructor and Description
      CannotProceed()
      CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
      CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • cxt

        public NamingContext cxt

      • rest_of_name

        public NameComponent[] rest_of_name

    • Constructor Detail

      • CannotProceed

        public CannotProceed()

      • CannotProceed

        public CannotProceed(NamingContext _cxt,
                     NameComponent[] _rest_of_name)

      • CannotProceed

        public CannotProceed(String $reason,
                     NamingContext _cxt,
                     NameComponent[] _rest_of_name)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CannotProceedHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class CannotProceedHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

  • public abstract class CannotProceedHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      CannotProceedHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static CannotProceed | extract(Any a)
      static String | id()
      static void | insert(Any a, CannotProceed that)
      static CannotProceed | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, CannotProceed value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CannotProceedHelper

        public CannotProceedHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          CannotProceed that)

      • extract

        public static CannotProceed extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CannotProceed read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         CannotProceed value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CannotProceedHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class CannotProceedHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
  • All Implemented Interfaces:
    Streamable

    public final class CannotProceedHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      CannotProceed value

    • Constructor Summary

      Constructors
      Constructor and Description
      CannotProceedHolder()
      CannotProceedHolder(CannotProceed initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public CannotProceed value

    • Constructor Detail

      • CannotProceedHolder

        public CannotProceedHolder()

      • CannotProceedHolder

        public CannotProceedHolder(CannotProceed initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.InvalidName
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    org/omg/CosNaming/NamingContextPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidName()
      InvalidName(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidName

        public InvalidName()

      • InvalidName

        public InvalidName(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class InvalidNameHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

  • public abstract class InvalidNameHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidName | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidName that)
      static InvalidName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidName value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidNameHelper

        public InvalidNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidName that)

      • extract

        public static InvalidName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidNameHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class InvalidNameHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
  • All Implemented Interfaces:
    Streamable

    public final class InvalidNameHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      InvalidName value

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidNameHolder()
      InvalidNameHolder(InvalidName initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public InvalidName value

    • Constructor Detail

      • InvalidNameHolder

        public InvalidNameHolder()

      • InvalidNameHolder

        public InvalidNameHolder(InvalidName initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotEmpty (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotEmpty

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NotEmpty
extends UserException
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NotEmpty()
      NotEmpty(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NotEmpty

        public NotEmpty()

      • NotEmpty

        public NotEmpty(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotEmptyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotEmptyHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

  • public abstract class NotEmptyHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NotEmptyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NotEmpty | extract(Any a)
      static String | id()
      static void | insert(Any a, NotEmpty that)
      static NotEmpty | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NotEmpty value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NotEmptyHelper

        public NotEmptyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NotEmpty that)

      • extract

        public static NotEmpty extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NotEmpty read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NotEmpty value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotEmptyHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotEmptyHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
  • All Implemented Interfaces:
    Streamable

    public final class NotEmptyHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NotEmpty value

    • Constructor Summary

      Constructors
      Constructor and Description
      NotEmptyHolder()
      NotEmptyHolder(NotEmpty initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NotEmpty value

    • Constructor Detail

      • NotEmptyHolder

        public NotEmptyHolder()

      • NotEmptyHolder

        public NotEmptyHolder(NotEmpty initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotFound (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotFound

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.NotFound
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NotFound
extends UserException
    org/omg/CosNaming/NamingContextPackage/NotFound.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NameComponent[] rest_of_name
      NotFoundReason why

    • Constructor Summary

      Constructors
      Constructor and Description
      NotFound()
      NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • why

        public NotFoundReason why

      • rest_of_name

        public NameComponent[] rest_of_name

    • Constructor Detail

      • NotFound

        public NotFound()

      • NotFound

        public NotFound(NotFoundReason _why,
                NameComponent[] _rest_of_name)

      • NotFound

        public NotFound(String $reason,
                NotFoundReason _why,
                NameComponent[] _rest_of_name)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotFoundHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotFoundHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper

  • public abstract class NotFoundHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NotFoundHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NotFound | extract(Any a)
      static String | id()
      static void | insert(Any a, NotFound that)
      static NotFound | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NotFound value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NotFoundHelper

        public NotFoundHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NotFound that)

      • extract

        public static NotFound extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NotFound read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NotFound value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotFoundHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotFoundHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder
  • All Implemented Interfaces:
    Streamable

    public final class NotFoundHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/CosNaming/nameservice.idl Monday, June 8, 2015 7:28:44 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NotFound value

    • Constructor Summary

      Constructors
      Constructor and Description
      NotFoundHolder()
      NotFoundHolder(NotFound initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NotFound value

    • Constructor Detail

      • NotFoundHolder

        public NotFoundHolder()

      • NotFoundHolder

        public NotFoundHolder(NotFound initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotFoundReason (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotFoundReason

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class NotFoundReason
extends Object
implements IDLEntity
    Indicates the reason for not able to resolve.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _missing_node
      static int | _not_context
      static int | _not_object
      static NotFoundReason | missing_node
      static NotFoundReason | not_context
      static NotFoundReason | not_object

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | NotFoundReason(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static NotFoundReason | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _missing_node

        public static final int _missing_node
        See Also:
        Constant Field Values

      • missing_node

        public static final NotFoundReason missing_node

      • _not_context

        public static final int _not_context
        See Also:
        Constant Field Values

      • not_context

        public static final NotFoundReason not_context

      • _not_object

        public static final int _not_object
        See Also:
        Constant Field Values

      • not_object

        public static final NotFoundReason not_object

    • Constructor Detail

      • NotFoundReason

        protected NotFoundReason(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static NotFoundReason from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotFoundReasonHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotFoundReasonHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

  • public abstract class NotFoundReasonHelper
extends Object
    Indicates the reason for not able to resolve.

    • Constructor Summary

      Constructors
      Constructor and Description
      NotFoundReasonHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NotFoundReason | extract(Any a)
      static String | id()
      static void | insert(Any a, NotFoundReason that)
      static NotFoundReason | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NotFoundReason value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NotFoundReasonHelper

        public NotFoundReasonHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NotFoundReason that)

      • extract

        public static NotFoundReason extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NotFoundReason read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NotFoundReason value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NotFoundReasonHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.CosNaming.NamingContextPackage

Class NotFoundReasonHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
  • All Implemented Interfaces:
    Streamable

    public final class NotFoundReasonHolder
extends Object
implements Streamable
    Indicates the reason for not able to resolve.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      NotFoundReason value

    • Constructor Summary

      Constructors
      Constructor and Description
      NotFoundReasonHolder()
      NotFoundReasonHolder(NotFoundReason initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public NotFoundReason value

    • Constructor Detail

      • NotFoundReasonHolder

        public NotFoundReasonHolder()

      • NotFoundReasonHolder

        public NotFoundReasonHolder(NotFoundReason initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CosNaming.NamingContextPackage (Java Platform SE 8 )

org.omg.CosNaming.NamingContextPackage

Classes

  • AlreadyBoundHelper
  • AlreadyBoundHolder
  • CannotProceedHelper
  • CannotProceedHolder
  • InvalidNameHelper
  • InvalidNameHolder
  • NotEmptyHelper
  • NotEmptyHolder
  • NotFoundHelper
  • NotFoundHolder
  • NotFoundReason
  • NotFoundReasonHelper
  • NotFoundReasonHolder

Exceptions

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound


org.omg.CosNaming.NamingContextPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.CosNaming.NamingContextPackage

This package contains Exception classes for the org.omg.CosNaming package.

See: Description

  • Class Summary
    Class Description
    AlreadyBoundHelper
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java .
    AlreadyBoundHolder
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
    CannotProceedHelper
    org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java .
    CannotProceedHolder
    org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
    InvalidNameHelper
    org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java .
    InvalidNameHolder
    org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
    NotEmptyHelper
    org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java .
    NotEmptyHolder
    org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java .
    NotFoundHelper
    org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java .
    NotFoundHolder
    org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java .
    NotFoundReason
    Indicates the reason for not able to resolve.
    NotFoundReasonHelper
    Indicates the reason for not able to resolve.
    NotFoundReasonHolder
    Indicates the reason for not able to resolve.
  • Exception Summary
    Exception Description
    AlreadyBound
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
    CannotProceed
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
    InvalidName
    org/omg/CosNaming/NamingContextPackage/InvalidName.java .
    NotEmpty
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
    NotFound
    org/omg/CosNaming/NamingContextPackage/NotFound.java .

Package org.omg.CosNaming.NamingContextPackage Description

This package contains Exception classes for the org.omg.CosNaming package. The list of exception classes are:

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound
  • NotFoundReason

    Package Specification

    For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.CosNaming.NamingContextPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.CosNaming.NamingContextPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (implements org.omg.CORBA.portable.Streamable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
          • org.omg.CosNaming.NamingContextPackage.InvalidName
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
          • org.omg.CosNaming.NamingContextPackage.NotFound
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.CosNaming.NamingContextPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.CosNaming.NamingContextPackage

  • Packages that use org.omg.CosNaming.NamingContextPackage
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
  • Classes in org.omg.CosNaming.NamingContextPackage used by org.omg.CosNaming
    Class and Description
    AlreadyBound
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
    CannotProceed
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
    InvalidName
    org/omg/CosNaming/NamingContextPackage/InvalidName.java .
    NotEmpty
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
    NotFound
    org/omg/CosNaming/NamingContextPackage/NotFound.java .
  • Classes in org.omg.CosNaming.NamingContextPackage used by org.omg.CosNaming.NamingContextPackage
    Class and Description
    AlreadyBound
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
    CannotProceed
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
    InvalidName
    org/omg/CosNaming/NamingContextPackage/InvalidName.java .
    NotEmpty
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
    NotFound
    org/omg/CosNaming/NamingContextPackage/NotFound.java .
    NotFoundReason
    Indicates the reason for not able to resolve.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.AlreadyBound (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.AlreadyBound

  • Packages that use AlreadyBound
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of AlreadyBound in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw AlreadyBound
      Modifier and Type Method and Description
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.

    • Uses of AlreadyBound in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as AlreadyBound
      Modifier and Type | Field and Description
      AlreadyBound | AlreadyBoundHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return AlreadyBound
      Modifier and Type | Method and Description
      static AlreadyBound | AlreadyBoundHelper.extract(Any a)
      static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type AlreadyBound
      Modifier and Type | Method and Description
      static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
      static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type AlreadyBound
      Constructor and Description
      AlreadyBoundHolder(AlreadyBound initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

No usage of org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder

No usage of org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.CannotProceed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.CannotProceed

  • Packages that use CannotProceed
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of CannotProceed in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw CannotProceed
      Modifier and Type Method and Description
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Uses of CannotProceed in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as CannotProceed
      Modifier and Type | Field and Description
      CannotProceed | CannotProceedHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return CannotProceed
      Modifier and Type | Method and Description
      static CannotProceed | CannotProceedHelper.extract(Any a)
      static CannotProceed | CannotProceedHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type CannotProceed
      Modifier and Type | Method and Description
      static void | CannotProceedHelper.insert(Any a, CannotProceed that)
      static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type CannotProceed
      Constructor and Description
      CannotProceedHolder(CannotProceed initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

No usage of org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.CannotProceedHolder

No usage of org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.InvalidName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.InvalidName

  • Packages that use InvalidName
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of InvalidName in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw InvalidName
      Modifier and Type Method and Description
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      NameComponent[] NamingContextExtOperations.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      NameComponent[] _NamingContextExtStub.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      String NamingContextExtOperations.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String _NamingContextExtStub.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String NamingContextExtOperations.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      String _NamingContextExtStub.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Uses of InvalidName in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as InvalidName
      Modifier and Type | Field and Description
      InvalidName | InvalidNameHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return InvalidName
      Modifier and Type | Method and Description
      static InvalidName | InvalidNameHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type InvalidName
      Modifier and Type | Method and Description
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type InvalidName
      Constructor and Description
      InvalidNameHolder(InvalidName initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

No usage of org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.InvalidNameHolder

No usage of org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotEmpty (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotEmpty

  • Packages that use NotEmpty
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NotEmpty in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw NotEmpty
      Modifier and Type Method and Description
      void NamingContextOperations.destroy()
      The destroy operation deletes a naming context.
      void _NamingContextExtStub.destroy()
      The destroy operation deletes a naming context.
      void _NamingContextStub.destroy()
      The destroy operation deletes a naming context.

    • Uses of NotEmpty in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NotEmpty
      Modifier and Type | Field and Description
      NotEmpty | NotEmptyHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return NotEmpty
      Modifier and Type | Method and Description
      static NotEmpty | NotEmptyHelper.extract(Any a)
      static NotEmpty | NotEmptyHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type NotEmpty
      Modifier and Type | Method and Description
      static void | NotEmptyHelper.insert(Any a, NotEmpty that)
      static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NotEmpty
      Constructor and Description
      NotEmptyHolder(NotEmpty initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

No usage of org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotEmptyHolder

No usage of org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFound (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFound

  • Packages that use NotFound
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NotFound in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw NotFound
      Modifier and Type Method and Description
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Uses of NotFound in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NotFound
      Modifier and Type | Field and Description
      NotFound | NotFoundHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return NotFound
      Modifier and Type | Method and Description
      static NotFound | NotFoundHelper.extract(Any a)
      static NotFound | NotFoundHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type NotFound
      Modifier and Type | Method and Description
      static void | NotFoundHelper.insert(Any a, NotFound that)
      static void | NotFoundHelper.write(OutputStream ostream, NotFound value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NotFound
      Constructor and Description
      NotFoundHolder(NotFound initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundHelper

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundHolder

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundReason (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundReason

  • Packages that use NotFoundReason
    Package Description
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NotFoundReason in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NotFoundReason
      Modifier and Type | Field and Description
      static NotFoundReason | NotFoundReason.missing_node
      static NotFoundReason | NotFoundReason.not_context
      static NotFoundReason | NotFoundReason.not_object
      NotFoundReason | NotFoundReasonHolder.value
      NotFoundReason | NotFound.why
      Methods in org.omg.CosNaming.NamingContextPackage that return NotFoundReason
      Modifier and Type | Method and Description
      static NotFoundReason | NotFoundReasonHelper.extract(Any a)
      static NotFoundReason | NotFoundReason.from_int(int value)
      static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type NotFoundReason
      Modifier and Type | Method and Description
      static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)
      static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NotFoundReason
      Constructor and Description
      NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFoundReasonHolder(NotFoundReason initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.Dynamic (Java Platform SE 8 )

org.omg.Dynamic

Classes

  • Parameter


org.omg.Dynamic (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.Dynamic

This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.

See: Description

  • Class Summary
    Class Description
    Parameter
    org/omg/Dynamic/Parameter.java .

Package org.omg.Dynamic Description

This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.Dynamic Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.Dynamic

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.Dynamic.Parameter (implements org.omg.CORBA.portable.IDLEntity)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.Dynamic (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.Dynamic

  • Packages that use org.omg.Dynamic
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.Dynamic used by org.omg.PortableInterceptor
    Class and Description
    Parameter
    org/omg/Dynamic/Parameter.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Parameter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.Dynamic

Class Parameter

  • java.lang.Object
    • org.omg.Dynamic.Parameter
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Parameter
extends Object
implements IDLEntity
    org/omg/Dynamic/Parameter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Any argument
      ParameterMode mode

    • Constructor Summary

      Constructors
      Constructor and Description
      Parameter()
      Parameter(Any _argument, ParameterMode _mode)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • argument

        public Any argument

      • mode

        public ParameterMode mode

    • Constructor Detail

      • Parameter

        public Parameter()

      • Parameter

        public Parameter(Any _argument,
                 ParameterMode _mode)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.Dynamic.Parameter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.Dynamic.Parameter

  • Packages that use Parameter
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Parameter in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Parameter
      Modifier and Type Method and Description
      Parameter[] RequestInfoOperations.arguments()
      Returns an array of Parameter objects, containing the arguments on the operation being invoked.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AnySeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class AnySeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.AnySeqHelper

  • public abstract class AnySeqHelper
extends Object
    org/omg/DynamicAny/AnySeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AnySeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Any[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Any[] that)
      static Any[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Any[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AnySeqHelper

        public AnySeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Any[] that)

      • extract

        public static Any[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Any[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Any[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAny (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynAny

  • All Superinterfaces:
    DynAnyOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon
    All Known Implementing Classes:
    _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub

    public interface DynAny
extends DynAnyOperations, Object, IDLEntity
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAnyFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynAnyFactory

  • All Superinterfaces:
    DynAnyFactoryOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynAnyFactoryStub

    public interface DynAnyFactory
extends DynAnyFactoryOperations, Object, IDLEntity
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynAnyFactoryOperations

        create_dyn_any_from_type_code, create_dyn_any

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAnyFactoryHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynAnyFactoryHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryHelper

  • public abstract class DynAnyFactoryHelper
extends Object
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynAnyFactoryHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynAnyFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, DynAnyFactory that)
      static DynAnyFactory | narrow(Object obj)
      static DynAnyFactory | read(InputStream istream)
      static TypeCode | type()
      static DynAnyFactory | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynAnyFactory value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynAnyFactoryHelper

        public DynAnyFactoryHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynAnyFactory that)

      • extract

        public static DynAnyFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynAnyFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynAnyFactory value)

      • narrow

        public static DynAnyFactory narrow(Object obj)

      • unchecked_narrow

        public static DynAnyFactory unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAnyFactoryOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynAnyFactoryOperations

  • All Known Subinterfaces:
    DynAnyFactory
    All Known Implementing Classes:
    _DynAnyFactoryStub

    public interface DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DynAny create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

    • Method Detail

      • create_dyn_any

        DynAny create_dyn_any(Any value)
               throws InconsistentTypeCode
        Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise
        Throws:
        InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

      • create_dyn_any_from_type_code

        DynAny create_dyn_any_from_type_code(TypeCode type)
                              throws InconsistentTypeCode
        Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
        • false for boolean
        • zero for numeric types
        • zero for types octet, char, and wchar
        • the empty string for string and wstring
        • null for object references
        • a type code with a TCKind value of tk_null for type codes
        • for any values, an any containing a type code with a TCKind value of tk_null type and no value
        For complex types, creation of the corresponding DynAny assigns a default value as follows:
        • For DynSequence it sets the current position to -1 and creates an empty sequence.
        • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
        • For DynFixed it sets the current position to -1 and sets the value zero.
        • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
        • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
        • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
        • For DynValue and DynValueBox it initializes to a null value.
        Throws:
        InconsistentTypeCode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAnyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynAnyHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyHelper

  • public abstract class DynAnyHelper
extends Object
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynAnyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynAny | extract(Any a)
      static String | id()
      static void | insert(Any a, DynAny that)
      static DynAny | narrow(Object obj)
      static DynAny | read(InputStream istream)
      static TypeCode | type()
      static DynAny | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynAny value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynAnyHelper

        public DynAnyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynAny that)

      • extract

        public static DynAny extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynAny read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynAny value)

      • narrow

        public static DynAny narrow(Object obj)

      • unchecked_narrow

        public static DynAny unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAnyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynAnyOperations

  • All Known Subinterfaces:
    DynAny, DynArray, DynArrayOperations, DynEnum, DynEnumOperations, DynFixed, DynFixedOperations, DynSequence, DynSequenceOperations, DynStruct, DynStructOperations, DynUnion, DynUnionOperations, DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations
    All Known Implementing Classes:
    _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub

    public interface DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

    • Method Detail

      • type

        TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        void assign(DynAny dyn_any)
     throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        void from_any(Any value)
       throws TypeMismatch,
              InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

      • copy

        DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        void insert_boolean(boolean value)
             throws TypeMismatch,
                    InvalidValue
        Inserts a boolean value into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        void insert_octet(byte value)
           throws TypeMismatch,
                  InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        void insert_char(char value)
          throws TypeMismatch,
                 InvalidValue
        Inserts a char value into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        void insert_short(short value)
           throws TypeMismatch,
                  InvalidValue
        Inserts a short value into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        void insert_ushort(short value)
            throws TypeMismatch,
                   InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        void insert_long(int value)
          throws TypeMismatch,
                 InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        void insert_ulong(int value)
           throws TypeMismatch,
                  InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        void insert_float(float value)
           throws TypeMismatch,
                  InvalidValue
        Inserts a float value into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        void insert_double(double value)
            throws TypeMismatch,
                   InvalidValue
        Inserts a double value into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        void insert_string(String value)
            throws TypeMismatch,
                   InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        void insert_reference(Object value)
               throws TypeMismatch,
                      InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        void insert_typecode(TypeCode value)
              throws TypeMismatch,
                     InvalidValue
        Inserts a TypeCode object into the DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        void insert_longlong(long value)
              throws TypeMismatch,
                     InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        void insert_ulonglong(long value)
               throws TypeMismatch,
                      InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        void insert_wchar(char value)
           throws TypeMismatch,
                  InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        void insert_wstring(String value)
             throws TypeMismatch,
                    InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        void insert_any(Any value)
         throws TypeMismatch,
                InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        void insert_dyn_any(DynAny value)
             throws TypeMismatch,
                    InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        void insert_val(Serializable value)
         throws TypeMismatch,
                InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        boolean get_boolean()
             throws TypeMismatch,
                    InvalidValue
        Extracts the boolean value from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        byte get_octet()
        throws TypeMismatch,
               InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        char get_char()
       throws TypeMismatch,
              InvalidValue
        Extracts the char value from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        short get_short()
         throws TypeMismatch,
                InvalidValue
        Extracts the short value from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        short get_ushort()
          throws TypeMismatch,
                 InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        int get_long()
      throws TypeMismatch,
             InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        int get_ulong()
       throws TypeMismatch,
              InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        float get_float()
         throws TypeMismatch,
                InvalidValue
        Extracts the float value from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        double get_double()
           throws TypeMismatch,
                  InvalidValue
        Extracts the double value from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        String get_string()
           throws TypeMismatch,
                  InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        Object get_reference()
              throws TypeMismatch,
                     InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        TypeCode get_typecode()
               throws TypeMismatch,
                      InvalidValue
        Extracts the TypeCode object from this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        long get_longlong()
           throws TypeMismatch,
                  InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        long get_ulonglong()
            throws TypeMismatch,
                   InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        char get_wchar()
        throws TypeMismatch,
               InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        String get_wstring()
            throws TypeMismatch,
                   InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        Any get_any()
     throws TypeMismatch,
            InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        DynAny get_dyn_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        Serializable get_val()
              throws TypeMismatch,
                     InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

      • rewind

        void rewind()
        Is equivalent to seek(0).

      • next

        boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

      • component_count

        int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.

      • current_component

        DynAny current_component()
                  throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynAnySeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynAnySeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnySeqHelper

  • public abstract class DynAnySeqHelper
extends Object
    org/omg/DynamicAny/DynAnySeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      DynAnySeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynAny[] | extract(Any a)
      static String | id()
      static void | insert(Any a, DynAny[] that)
      static DynAny[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DynAny[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynAnySeqHelper

        public DynAnySeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynAny[] that)

      • extract

        public static DynAny[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynAny[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynAny[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynArray (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynArray

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynArrayOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynArrayStub

    public interface DynArray
extends DynArrayOperations, DynAny, IDLEntity
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynArrayOperations

        get_elements_as_dyn_any, get_elements, set_elements_as_dyn_any, set_elements

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynArrayHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynArrayHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynArrayHelper

  • public abstract class DynArrayHelper
extends Object
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynArrayHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynArray | extract(Any a)
      static String | id()
      static void | insert(Any a, DynArray that)
      static DynArray | narrow(Object obj)
      static DynArray | read(InputStream istream)
      static TypeCode | type()
      static DynArray | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynArray value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynArrayHelper

        public DynArrayHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynArray that)

      • extract

        public static DynArray extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynArray read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynArray value)

      • narrow

        public static DynArray narrow(Object obj)

      • unchecked_narrow

        public static DynArray unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynArrayOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynArrayOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynArray
    All Known Implementing Classes:
    _DynArrayStub

    public interface DynArrayOperations
extends DynAnyOperations
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DynAny[] get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      Any[] get_elements()
      Returns the elements of the DynArray.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_elements

        Any[] get_elements()
        Returns the elements of the DynArray.

      • set_elements

        void set_elements(Any[] value)
           throws TypeMismatch,
                  InvalidValue
        Sets the DynArray to contain the passed elements.
        Throws:
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • get_elements_as_dyn_any

        DynAny[] get_elements_as_dyn_any()
        Returns the elements of the DynArray as DynAnys.

      • set_elements_as_dyn_any

        void set_elements_as_dyn_any(DynAny[] value)
                      throws TypeMismatch,
                             InvalidValue
        Sets the DynArray to contain the passed elements.
        Throws:
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynEnum (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynEnum

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynEnumOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynEnumStub

    public interface DynEnum
extends DynEnumOperations, DynAny, IDLEntity
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynEnumOperations

        get_as_string, get_as_ulong, set_as_string, set_as_ulong

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynEnumHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynEnumHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynEnumHelper

  • public abstract class DynEnumHelper
extends Object
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynEnumHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynEnum | extract(Any a)
      static String | id()
      static void | insert(Any a, DynEnum that)
      static DynEnum | narrow(Object obj)
      static DynEnum | read(InputStream istream)
      static TypeCode | type()
      static DynEnum | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynEnum value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynEnumHelper

        public DynEnumHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynEnum that)

      • extract

        public static DynEnum extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynEnum read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynEnum value)

      • narrow

        public static DynEnum narrow(Object obj)

      • unchecked_narrow

        public static DynEnum unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynEnumOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynEnumOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynEnum
    All Known Implementing Classes:
    _DynEnumStub

    public interface DynEnumOperations
extends DynAnyOperations
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String get_as_string()
      Returns the value of the DynEnum as an IDL identifier.
      int get_as_ulong()
      Returns the value of the DynEnum as the enumerated value's ordinal value.
      void set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_as_string

        String get_as_string()
        Returns the value of the DynEnum as an IDL identifier.

      • set_as_string

        void set_as_string(String value)
            throws InvalidValue
        Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
        Throws:
        InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

      • get_as_ulong

        int get_as_ulong()
        Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.

      • set_as_ulong

        void set_as_ulong(int value)
           throws InvalidValue
        Sets the value of the DynEnum as the enumerated value's ordinal value.
        Throws:
        InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynFixed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynFixed

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynFixedOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynFixedStub

    public interface DynFixed
extends DynFixedOperations, DynAny, IDLEntity
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynFixedOperations

        get_value, set_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynFixedHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynFixedHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynFixedHelper

  • public abstract class DynFixedHelper
extends Object
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynFixedHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynFixed | extract(Any a)
      static String | id()
      static void | insert(Any a, DynFixed that)
      static DynFixed | narrow(Object obj)
      static DynFixed | read(InputStream istream)
      static TypeCode | type()
      static DynFixed | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynFixed value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynFixedHelper

        public DynFixedHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynFixed that)

      • extract

        public static DynFixed extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynFixed read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynFixed value)

      • narrow

        public static DynFixed narrow(Object obj)

      • unchecked_narrow

        public static DynFixed unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynFixedOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynFixedOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynFixed
    All Known Implementing Classes:
    _DynFixedStub

    public interface DynFixedOperations
extends DynAnyOperations
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String get_value()
      Returns the value of a DynFixed.
      boolean set_value(String val)
      Sets the value of the DynFixed.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_value

        String get_value()
        Returns the value of a DynFixed.

      • set_value

        boolean set_value(String val)
           throws TypeMismatch,
                  InvalidValue
        Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.
        Throws:
        TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
        InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynSequence (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynSequence

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynSequenceOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynSequenceStub

    public interface DynSequence
extends DynSequenceOperations, DynAny, IDLEntity
    DynSequence objects support the manipulation of IDL sequences.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynSequenceOperations

        get_elements_as_dyn_any, get_elements, get_length, set_elements_as_dyn_any, set_elements, set_length

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynSequenceHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynSequenceHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynSequenceHelper

  • public abstract class DynSequenceHelper
extends Object
    DynSequence objects support the manipulation of IDL sequences.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynSequenceHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynSequence | extract(Any a)
      static String | id()
      static void | insert(Any a, DynSequence that)
      static DynSequence | narrow(Object obj)
      static DynSequence | read(InputStream istream)
      static TypeCode | type()
      static DynSequence | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynSequence value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynSequenceHelper

        public DynSequenceHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynSequence that)

      • extract

        public static DynSequence extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynSequence read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynSequence value)

      • narrow

        public static DynSequence narrow(Object obj)

      • unchecked_narrow

        public static DynSequence unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynSequenceOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynSequenceOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynSequence
    All Known Implementing Classes:
    _DynSequenceStub

    public interface DynSequenceOperations
extends DynAnyOperations
    DynSequence objects support the manipulation of IDL sequences.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DynAny[] get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      Any[] get_elements()
      Returns the elements of the sequence.
      int get_length()
      Returns the current length of the sequence.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void set_elements(Any[] value)
      Sets the elements of a sequence.
      void set_length(int len)
      Sets the length of the sequence.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_length

        int get_length()
        Returns the current length of the sequence.

      • set_length

        void set_length(int len)
         throws InvalidValue
        Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
        • If the length of the sequence is set to zero, the current position is set to -1.
        • If the current position is -1 before decreasing the length, it remains at -1.
        • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
        • If the current position indicates a valid element and that element is removed, the current position is set to -1.
        Throws:
        InvalidValue - if this is a bounded sequence and len is larger than the bound

      • get_elements

        Any[] get_elements()
        Returns the elements of the sequence.

      • set_elements

        void set_elements(Any[] value)
           throws TypeMismatch,
                  InvalidValue
        Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        Throws:
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • get_elements_as_dyn_any

        DynAny[] get_elements_as_dyn_any()
        Returns the DynAnys representing the elements of the sequence.

      • set_elements_as_dyn_any

        void set_elements_as_dyn_any(DynAny[] value)
                      throws TypeMismatch,
                             InvalidValue
        Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        Throws:
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynStruct (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynStruct

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynStructOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynStructStub

    public interface DynStruct
extends DynStructOperations, DynAny, IDLEntity
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynStructOperations

        current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynStructHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynStructHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynStructHelper

  • public abstract class DynStructHelper
extends Object
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynStructHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynStruct | extract(Any a)
      static String | id()
      static void | insert(Any a, DynStruct that)
      static DynStruct | narrow(Object obj)
      static DynStruct | read(InputStream istream)
      static TypeCode | type()
      static DynStruct | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynStruct value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynStructHelper

        public DynStructHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynStruct that)

      • extract

        public static DynStruct extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynStruct read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynStruct value)

      • narrow

        public static DynStruct narrow(Object obj)

      • unchecked_narrow

        public static DynStruct unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynStructOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynStructOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynStruct
    All Known Implementing Classes:
    _DynStructStub

    public interface DynStructOperations
extends DynAnyOperations
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • current_member_name

        String current_member_name()
                    throws TypeMismatch,
                           InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Throws:
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        TCKind current_member_kind()
                    throws TypeMismatch,
                           InvalidValue
        Returns the TCKind associated with the member at the current position.
        Throws:
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • get_members

        NameValuePair[] get_members()
        Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

      • set_members

        void set_members(NameValuePair[] value)
          throws TypeMismatch,
                 InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • get_members_as_dyn_any

        NameDynAnyPair[] get_members_as_dyn_any()
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

      • set_members_as_dyn_any

        void set_members_as_dyn_any(NameDynAnyPair[] value)
                     throws TypeMismatch,
                            InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynUnion (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynUnion

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynUnionOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynUnionStub

    public interface DynUnion
extends DynUnionOperations, DynAny, IDLEntity
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynUnionOperations

        discriminator_kind, get_discriminator, has_no_active_member, member_kind, member_name, member, set_discriminator, set_to_default_member, set_to_no_active_member

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynUnionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynUnionHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynUnionHelper

  • public abstract class DynUnionHelper
extends Object
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynUnionHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynUnion | extract(Any a)
      static String | id()
      static void | insert(Any a, DynUnion that)
      static DynUnion | narrow(Object obj)
      static DynUnion | read(InputStream istream)
      static TypeCode | type()
      static DynUnion | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynUnion value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynUnionHelper

        public DynUnionHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynUnion that)

      • extract

        public static DynUnion extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynUnion read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynUnion value)

      • narrow

        public static DynUnion narrow(Object obj)

      • unchecked_narrow

        public static DynUnion unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynUnionOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynUnionOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynUnion
    All Known Implementing Classes:
    _DynUnionStub

    public interface DynUnionOperations
extends DynAnyOperations
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      TCKind discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      DynAny get_discriminator()
      Returns the current discriminator value.
      boolean has_no_active_member()
      Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
      TCKind member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String member_name()
      Returns the name of the currently active member.
      DynAny member()
      Returns the currently active member.
      void set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_discriminator

        DynAny get_discriminator()
        Returns the current discriminator value.

      • set_discriminator

        void set_discriminator(DynAny d)
                throws TypeMismatch
        Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).
        Throws:
        TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

      • set_to_default_member

        void set_to_default_member()
                    throws TypeMismatch
        Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.
        Throws:
        TypeMismatch - if the union does not have an explicit default case

      • set_to_no_active_member

        void set_to_no_active_member()
                      throws TypeMismatch
        Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.
        Throws:
        TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

      • has_no_active_member

        boolean has_no_active_member()
        Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.

      • discriminator_kind

        TCKind discriminator_kind()
        Returns the TCKind value of the discriminators TypeCode.

      • member_kind

        TCKind member_kind()
            throws InvalidValue
        Returns the TCKind value of the currently active members TypeCode.
        Throws:
        InvalidValue - if the union does not have a currently active member

      • member

        DynAny member()
       throws InvalidValue
        Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.
        Throws:
        InvalidValue - if the union has no active member

      • member_name

        String member_name()
            throws InvalidValue
        Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.
        Throws:
        InvalidValue - if the union has no active member
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValue

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValue
extends DynValueOperations, DynValueCommon, IDLEntity
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynValueOperations

        current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValueBox (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueBox

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, IDLEntity, Object, Serializable

    public interface DynValueBox
extends DynValueBoxOperations, DynValueCommon, IDLEntity
    DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynValueBoxOperations

        get_boxed_value_as_dyn_any, get_boxed_value, set_boxed_value_as_dyn_any, set_boxed_value

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValueBoxOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueBoxOperations

  • All Superinterfaces:
    DynAnyOperations, DynValueCommonOperations
    All Known Subinterfaces:
    DynValueBox

    public interface DynValueBoxOperations
extends DynValueCommonOperations
    DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DynAny get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      Any get_boxed_value()
      Returns the boxed value as an Any.
      void set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_boxed_value

        Any get_boxed_value()
             throws InvalidValue
        Returns the boxed value as an Any.
        Throws:
        InvalidValue - if this object represents a null value box type

      • set_boxed_value

        void set_boxed_value(Any boxed)
              throws TypeMismatch
        Replaces the boxed value with the specified value. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.
        Throws:
        TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.

      • get_boxed_value_as_dyn_any

        DynAny get_boxed_value_as_dyn_any()
                           throws InvalidValue
        Returns the boxed value as a DynAny.
        Throws:
        InvalidValue - if this object represents a null value box type

      • set_boxed_value_as_dyn_any

        void set_boxed_value_as_dyn_any(DynAny boxed)
                         throws TypeMismatch
        Replaces the boxed value with the value contained in the parameter. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.
        Throws:
        TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValueCommon (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueCommon

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueCommonOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    DynValue, DynValueBox
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueCommon
extends DynValueCommonOperations, DynAny, IDLEntity
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValueCommonOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueCommonOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueOperations
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueCommonOperations
extends DynAnyOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean is_null()
      Returns true if the DynValueCommon represents a null value type.
      void set_to_null()
      Changes the representation of a DynValueCommon to a null value type.
      void set_to_value()
      Replaces a null value type with a newly constructed value.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • is_null

        boolean is_null()
        Returns true if the DynValueCommon represents a null value type.

      • set_to_null

        void set_to_null()
        Changes the representation of a DynValueCommon to a null value type.

      • set_to_value

        void set_to_value()
        Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynValueHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynValueHelper

  • public abstract class DynValueHelper
extends Object
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynValueHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynValue | extract(Any a)
      static String | id()
      static void | insert(Any a, DynValue that)
      static DynValue | narrow(Object obj)
      static DynValue | read(InputStream istream)
      static TypeCode | type()
      static DynValue | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynValue value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynValueHelper

        public DynValueHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynValue that)

      • extract

        public static DynValue extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynValue read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynValue value)

      • narrow

        public static DynValue narrow(Object obj)

      • unchecked_narrow

        public static DynValue unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynValueOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueOperations

  • All Superinterfaces:
    DynAnyOperations, DynValueCommonOperations
    All Known Subinterfaces:
    DynValue
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueOperations
extends DynValueCommonOperations
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • current_member_name

        String current_member_name()
                    throws TypeMismatch,
                           InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        TCKind current_member_kind()
                    throws TypeMismatch,
                           InvalidValue
        Returns the TCKind associated with the member at the current position.
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • get_members

        NameValuePair[] get_members()
                     throws InvalidValue
        Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members

        void set_members(NameValuePair[] value)
          throws TypeMismatch,
                 InvalidValue
        Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • get_members_as_dyn_any

        NameDynAnyPair[] get_members_as_dyn_any()
                                 throws InvalidValue
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members_as_dyn_any

        void set_members_as_dyn_any(NameDynAnyPair[] value)
                     throws TypeMismatch,
                            InvalidValue
        Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FieldNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class FieldNameHelper

  • java.lang.Object
    • org.omg.DynamicAny.FieldNameHelper

  • public abstract class FieldNameHelper
extends Object
    org/omg/DynamicAny/FieldNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      FieldNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FieldNameHelper

        public FieldNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameDynAnyPair (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameDynAnyPair

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPair
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NameDynAnyPair
extends Object
implements IDLEntity
    org/omg/DynamicAny/NameDynAnyPair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String id
      The name associated with the DynAny.
      DynAny value
      The DynAny value associated with the name.

    • Constructor Summary

      Constructors
      Constructor and Description
      NameDynAnyPair()
      NameDynAnyPair(String _id, DynAny _value)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        public String id
        The name associated with the DynAny.

      • value

        public DynAny value
        The DynAny value associated with the name.

    • Constructor Detail

      • NameDynAnyPair

        public NameDynAnyPair()

      • NameDynAnyPair

        public NameDynAnyPair(String _id,
                      DynAny _value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameDynAnyPairHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameDynAnyPairHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPairHelper

  • public abstract class NameDynAnyPairHelper
extends Object
    org/omg/DynamicAny/NameDynAnyPairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameDynAnyPairHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameDynAnyPair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameDynAnyPair that)
      static NameDynAnyPair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameDynAnyPair value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameDynAnyPairHelper

        public NameDynAnyPairHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameDynAnyPair that)

      • extract

        public static NameDynAnyPair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameDynAnyPair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameDynAnyPair value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameDynAnyPairSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameDynAnyPairSeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper

  • public abstract class NameDynAnyPairSeqHelper
extends Object
    org/omg/DynamicAny/NameDynAnyPairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameDynAnyPairSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameDynAnyPair[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameDynAnyPair[] that)
      static NameDynAnyPair[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameDynAnyPair[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameDynAnyPairSeqHelper

        public NameDynAnyPairSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameDynAnyPair[] that)

      • extract

        public static NameDynAnyPair[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameDynAnyPair[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameDynAnyPair[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameValuePair (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameValuePair

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePair
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NameValuePair
extends Object
implements IDLEntity
    org/omg/DynamicAny/NameValuePair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String id
      The name associated with the Any.
      Any value
      The Any value associated with the name.

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePair()
      NameValuePair(String _id, Any _value)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        public String id
        The name associated with the Any.

      • value

        public Any value
        The Any value associated with the name.

    • Constructor Detail

      • NameValuePair

        public NameValuePair()

      • NameValuePair

        public NameValuePair(String _id,
                     Any _value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameValuePairHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameValuePairHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePairHelper

  • public abstract class NameValuePairHelper
extends Object
    org/omg/DynamicAny/NameValuePairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePairHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameValuePair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair that)
      static NameValuePair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameValuePairHelper

        public NameValuePairHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameValuePair that)

      • extract

        public static NameValuePair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameValuePair value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameValuePairSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameValuePairSeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePairSeqHelper

  • public abstract class NameValuePairSeqHelper
extends Object
    org/omg/DynamicAny/NameValuePairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePairSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameValuePair[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair[] that)
      static NameValuePair[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameValuePairSeqHelper

        public NameValuePairSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameValuePair[] that)

      • extract

        public static NameValuePair[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameValuePair[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.DynamicAny (Java Platform SE 8 )

org.omg.DynamicAny

Interfaces

  • DynAny
  • DynAnyFactory
  • DynAnyFactoryOperations
  • DynAnyOperations
  • DynArray
  • DynArrayOperations
  • DynEnum
  • DynEnumOperations
  • DynFixed
  • DynFixedOperations
  • DynSequence
  • DynSequenceOperations
  • DynStruct
  • DynStructOperations
  • DynUnion
  • DynUnionOperations
  • DynValue
  • DynValueBox
  • DynValueBoxOperations
  • DynValueCommon
  • DynValueCommonOperations
  • DynValueOperations

Classes

  • _DynAnyFactoryStub
  • _DynAnyStub
  • _DynArrayStub
  • _DynEnumStub
  • _DynFixedStub
  • _DynSequenceStub
  • _DynStructStub
  • _DynUnionStub
  • _DynValueStub
  • AnySeqHelper
  • DynAnyFactoryHelper
  • DynAnyHelper
  • DynAnySeqHelper
  • DynArrayHelper
  • DynEnumHelper
  • DynFixedHelper
  • DynSequenceHelper
  • DynStructHelper
  • DynUnionHelper
  • DynValueHelper
  • FieldNameHelper
  • NameDynAnyPair
  • NameDynAnyPairHelper
  • NameDynAnyPairSeqHelper
  • NameValuePair
  • NameValuePairHelper
  • NameValuePairSeqHelper


org.omg.DynamicAny (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.DynamicAny

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

See: Description

  • Interface Summary
    Interface Description
    DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynArray
    DynArray objects support the manipulation of IDL arrays.
    DynArrayOperations
    DynArray objects support the manipulation of IDL arrays.
    DynEnum
    DynEnum objects support the manipulation of IDL enumerated values.
    DynEnumOperations
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixed
    DynFixed objects support the manipulation of IDL fixed values.
    DynFixedOperations
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequence
    DynSequence objects support the manipulation of IDL sequences.
    DynSequenceOperations
    DynSequence objects support the manipulation of IDL sequences.
    DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynStructOperations
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnion
    DynUnion objects support the manipulation of IDL unions.
    DynUnionOperations
    DynUnion objects support the manipulation of IDL unions.
    DynValue
    DynValue objects support the manipulation of IDL non-boxed value types.
    DynValueBox
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueBoxOperations
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueCommon
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueCommonOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueOperations
    DynValue objects support the manipulation of IDL non-boxed value types.
  • Class Summary
    Class Description
    _DynAnyFactoryStub
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    _DynAnyStub
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    _DynArrayStub
    DynArray objects support the manipulation of IDL arrays.
    _DynEnumStub
    DynEnum objects support the manipulation of IDL enumerated values.
    _DynFixedStub
    DynFixed objects support the manipulation of IDL fixed values.
    _DynSequenceStub
    DynSequence objects support the manipulation of IDL sequences.
    _DynStructStub
    DynStruct objects support the manipulation of IDL struct and exception values.
    _DynUnionStub
    DynUnion objects support the manipulation of IDL unions.
    _DynValueStub
    DynValue objects support the manipulation of IDL non-boxed value types.
    AnySeqHelper
    org/omg/DynamicAny/AnySeqHelper.java .
    DynAnyFactoryHelper
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyHelper
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnySeqHelper
    org/omg/DynamicAny/DynAnySeqHelper.java .
    DynArrayHelper
    DynArray objects support the manipulation of IDL arrays.
    DynEnumHelper
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixedHelper
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequenceHelper
    DynSequence objects support the manipulation of IDL sequences.
    DynStructHelper
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnionHelper
    DynUnion objects support the manipulation of IDL unions.
    DynValueHelper
    DynValue objects support the manipulation of IDL non-boxed value types.
    FieldNameHelper
    org/omg/DynamicAny/FieldNameHelper.java .
    NameDynAnyPair
    org/omg/DynamicAny/NameDynAnyPair.java .
    NameDynAnyPairHelper
    org/omg/DynamicAny/NameDynAnyPairHelper.java .
    NameDynAnyPairSeqHelper
    org/omg/DynamicAny/NameDynAnyPairSeqHelper.java .
    NameValuePair
    org/omg/DynamicAny/NameValuePair.java .
    NameValuePairHelper
    org/omg/DynamicAny/NameValuePairHelper.java .
    NameValuePairSeqHelper
    org/omg/DynamicAny/NameValuePairSeqHelper.java .

Package org.omg.DynamicAny Description

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

An any can be passed to a program that doesn't have any static information for the type of the any (code generated for the type by an IDL compiler has not been compiled with the object implementation). As a result, the object receiving the any does not have a portable method of using it.

DynAnys enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value. This is especially helpful for writing powerful generic servers (bridges, event channels supporting filtering). Similarly, this facility enables the construction of an any at runtime, without having static knowledge of its type. This is especially helpful for writing generic clients (bridges, browsers, debuggers, user interface tools).

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an Any. A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty.

Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type). A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Handling DynAny objects

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

Basic operations include:

  • insert_boolean, get_boolean
  • insert_char, get_char
  • insert_short, get_short
  • insert_ushort, get_ushort
  • insert_long, get_long
  • insert_ulong, get_ulong
  • insert_double, get_double
  • insert_string, get_string
  • insert_reference, get_reference
  • insert_typecode, get_typecode
  • insert_longlong, get_longlong
  • insert_ulonglong, get_ulonglong
  • insert_longdouble, get_longdouble
  • insert_wchar, get_wchar
  • insert_wstring, get_wstring
  • insert_any, get_any
  • insert_dyn_any, get_dyn_any
  • insert_val, get_val
  • insert_octet, get_octet
  • insert_float, get_float
  • get_value
  • get_as_string
  • get_as_ulong
  • get_members
  • get_members_as_dyn_any
  • get_discriminator
  • get_length
  • get_elements
  • get_elements_as_dyn_any
  • get_boxed_value
  • get_boxed_value_as_dyn_any

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.DynamicAny Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.DynamicAny

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • org.omg.DynamicAny.FieldNameHelper
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)

Interface Hierarchy

  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • org.omg.CORBA.Object
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.DynamicAny (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.DynamicAny

  • Packages that use org.omg.DynamicAny
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
  • Classes in org.omg.DynamicAny used by org.omg.DynamicAny
    Class and Description
    DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynArray
    DynArray objects support the manipulation of IDL arrays.
    DynArrayOperations
    DynArray objects support the manipulation of IDL arrays.
    DynEnum
    DynEnum objects support the manipulation of IDL enumerated values.
    DynEnumOperations
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixed
    DynFixed objects support the manipulation of IDL fixed values.
    DynFixedOperations
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequence
    DynSequence objects support the manipulation of IDL sequences.
    DynSequenceOperations
    DynSequence objects support the manipulation of IDL sequences.
    DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynStructOperations
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnion
    DynUnion objects support the manipulation of IDL unions.
    DynUnionOperations
    DynUnion objects support the manipulation of IDL unions.
    DynValue
    DynValue objects support the manipulation of IDL non-boxed value types.
    DynValueBoxOperations
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueCommon
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueCommonOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueOperations
    DynValue objects support the manipulation of IDL non-boxed value types.
    NameDynAnyPair
    org/omg/DynamicAny/NameDynAnyPair.java .
    NameValuePair
    org/omg/DynamicAny/NameValuePair.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynAnyFactoryStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynAnyFactoryStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynAnyFactoryStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAnyFactory, DynAnyFactoryOperations

    public class _DynAnyFactoryStub
extends ObjectImpl
implements DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynAnyFactoryStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      DynAny create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynAnyFactoryStub

        public _DynAnyFactoryStub()

    • Method Detail

      • create_dyn_any

        public DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
        Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise
        Specified by:
        create_dyn_any in interface DynAnyFactoryOperations
        Throws:
        InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

      • create_dyn_any_from_type_code

        public DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
        Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
        • false for boolean
        • zero for numeric types
        • zero for types octet, char, and wchar
        • the empty string for string and wstring
        • null for object references
        • a type code with a TCKind value of tk_null for type codes
        • for any values, an any containing a type code with a TCKind value of tk_null type and no value
        For complex types, creation of the corresponding DynAny assigns a default value as follows:
        • For DynSequence it sets the current position to -1 and creates an empty sequence.
        • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
        • For DynFixed it sets the current position to -1 and sets the value zero.
        • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
        • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
        • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
        • For DynValue and DynValueBox it initializes to a null value.
        Specified by:
        create_dyn_any_from_type_code in interface DynAnyFactoryOperations
        Throws:
        InconsistentTypeCode

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynAnyStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynAnyStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynAnyStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations

    public class _DynAnyStub
extends ObjectImpl
implements DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynAnyStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynAnyStub

        public _DynAnyStub()

    • Method Detail

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynArrayStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynArrayStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynArrayStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynArray, DynArrayOperations

    public class _DynArrayStub
extends ObjectImpl
implements DynArray
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynArrayStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      Any[] get_elements()
      Returns the elements of the DynArray.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynArrayStub

        public _DynArrayStub()

    • Method Detail

      • get_elements

        public Any[] get_elements()
        Returns the elements of the DynArray.
        Specified by:
        get_elements in interface DynArrayOperations

      • set_elements

        public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the DynArray to contain the passed elements.
        Specified by:
        set_elements in interface DynArrayOperations
        Throws:
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • get_elements_as_dyn_any

        public DynAny[] get_elements_as_dyn_any()
        Returns the elements of the DynArray as DynAnys.
        Specified by:
        get_elements_as_dyn_any in interface DynArrayOperations

      • set_elements_as_dyn_any

        public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the DynArray to contain the passed elements.
        Specified by:
        set_elements_as_dyn_any in interface DynArrayOperations
        Throws:
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynEnumStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynEnumStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynEnumStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynEnum, DynEnumOperations

    public class _DynEnumStub
extends ObjectImpl
implements DynEnum
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynEnumStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      String get_as_string()
      Returns the value of the DynEnum as an IDL identifier.
      int get_as_ulong()
      Returns the value of the DynEnum as the enumerated value's ordinal value.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynEnumStub

        public _DynEnumStub()

    • Method Detail

      • get_as_string

        public String get_as_string()
        Returns the value of the DynEnum as an IDL identifier.
        Specified by:
        get_as_string in interface DynEnumOperations

      • set_as_string

        public void set_as_string(String value)
                   throws InvalidValue
        Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
        Specified by:
        set_as_string in interface DynEnumOperations
        Throws:
        InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

      • get_as_ulong

        public int get_as_ulong()
        Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.
        Specified by:
        get_as_ulong in interface DynEnumOperations

      • set_as_ulong

        public void set_as_ulong(int value)
                  throws InvalidValue
        Sets the value of the DynEnum as the enumerated value's ordinal value.
        Specified by:
        set_as_ulong in interface DynEnumOperations
        Throws:
        InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynFixedStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynFixedStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynFixedStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynFixed, DynFixedOperations

    public class _DynFixedStub
extends ObjectImpl
implements DynFixed
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynFixedStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      String get_value()
      Returns the value of a DynFixed.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      boolean set_value(String val)
      Sets the value of the DynFixed.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynFixedStub

        public _DynFixedStub()

    • Method Detail

      • get_value

        public String get_value()
        Returns the value of a DynFixed.
        Specified by:
        get_value in interface DynFixedOperations

      • set_value

        public boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
        Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.
        Specified by:
        set_value in interface DynFixedOperations
        Throws:
        TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
        InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynSequenceStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynSequenceStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynSequenceStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynSequence, DynSequenceOperations

    public class _DynSequenceStub
extends ObjectImpl
implements DynSequence
    DynSequence objects support the manipulation of IDL sequences.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynSequenceStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      Any[] get_elements()
      Returns the elements of the sequence.
      float get_float()
      Extracts the float value from this DynAny.
      int get_length()
      Returns the current length of the sequence.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void set_elements(Any[] value)
      Sets the elements of a sequence.
      void set_length(int len)
      Sets the length of the sequence.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynSequenceStub

        public _DynSequenceStub()

    • Method Detail

      • get_length

        public int get_length()
        Returns the current length of the sequence.
        Specified by:
        get_length in interface DynSequenceOperations

      • set_length

        public void set_length(int len)
                throws InvalidValue
        Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
        • If the length of the sequence is set to zero, the current position is set to -1.
        • If the current position is -1 before decreasing the length, it remains at -1.
        • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
        • If the current position indicates a valid element and that element is removed, the current position is set to -1.
        Specified by:
        set_length in interface DynSequenceOperations
        Throws:
        InvalidValue - if this is a bounded sequence and len is larger than the bound

      • get_elements

        public Any[] get_elements()
        Returns the elements of the sequence.
        Specified by:
        get_elements in interface DynSequenceOperations

      • set_elements

        public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        Specified by:
        set_elements in interface DynSequenceOperations
        Throws:
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • get_elements_as_dyn_any

        public DynAny[] get_elements_as_dyn_any()
        Returns the DynAnys representing the elements of the sequence.
        Specified by:
        get_elements_as_dyn_any in interface DynSequenceOperations

      • set_elements_as_dyn_any

        public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        Specified by:
        set_elements_as_dyn_any in interface DynSequenceOperations
        Throws:
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynStructStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynStructStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynStructStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynStruct, DynStructOperations

    public class _DynStructStub
extends ObjectImpl
implements DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynStructStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynStructStub

        public _DynStructStub()

    • Method Detail

      • current_member_name

        public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Specified by:
        current_member_name in interface DynStructOperations
        Throws:
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        Specified by:
        current_member_kind in interface DynStructOperations
        Throws:
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • get_members

        public NameValuePair[] get_members()
        Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.
        Specified by:
        get_members in interface DynStructOperations

      • set_members

        public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members in interface DynStructOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • get_members_as_dyn_any

        public NameDynAnyPair[] get_members_as_dyn_any()
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.
        Specified by:
        get_members_as_dyn_any in interface DynStructOperations

      • set_members_as_dyn_any

        public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members_as_dyn_any in interface DynStructOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynUnionStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynUnionStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynUnionStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynUnion, DynUnionOperations

    public class _DynUnionStub
extends ObjectImpl
implements DynUnion
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynUnionStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      TCKind discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      DynAny get_discriminator()
      Returns the current discriminator value.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      boolean has_no_active_member()
      Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      TCKind member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String member_name()
      Returns the name of the currently active member.
      DynAny member()
      Returns the currently active member.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynUnionStub

        public _DynUnionStub()

    • Method Detail

      • get_discriminator

        public DynAny get_discriminator()
        Returns the current discriminator value.
        Specified by:
        get_discriminator in interface DynUnionOperations

      • set_discriminator

        public void set_discriminator(DynAny d)
                       throws TypeMismatch
        Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).
        Specified by:
        set_discriminator in interface DynUnionOperations
        Throws:
        TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

      • set_to_default_member

        public void set_to_default_member()
                           throws TypeMismatch
        Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.
        Specified by:
        set_to_default_member in interface DynUnionOperations
        Throws:
        TypeMismatch - if the union does not have an explicit default case

      • set_to_no_active_member

        public void set_to_no_active_member()
                             throws TypeMismatch
        Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.
        Specified by:
        set_to_no_active_member in interface DynUnionOperations
        Throws:
        TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

      • has_no_active_member

        public boolean has_no_active_member()
        Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.
        Specified by:
        has_no_active_member in interface DynUnionOperations

      • discriminator_kind

        public TCKind discriminator_kind()
        Returns the TCKind value of the discriminators TypeCode.
        Specified by:
        discriminator_kind in interface DynUnionOperations

      • member_kind

        public TCKind member_kind()
                   throws InvalidValue
        Returns the TCKind value of the currently active members TypeCode.
        Specified by:
        member_kind in interface DynUnionOperations
        Throws:
        InvalidValue - if the union does not have a currently active member

      • member

        public DynAny member()
              throws InvalidValue
        Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.
        Specified by:
        member in interface DynUnionOperations
        Throws:
        InvalidValue - if the union has no active member

      • member_name

        public String member_name()
                   throws InvalidValue
        Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.
        Specified by:
        member_name in interface DynUnionOperations
        Throws:
        InvalidValue - if the union has no active member

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_DynValueStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynValueStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynValueStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynValue, DynValueCommon, DynValueCommonOperations, DynValueOperations

    public class _DynValueStub
extends ObjectImpl
implements DynValue
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynValueStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean is_null()
      Returns true if the DynValueCommon represents a null value type.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void set_to_null()
      Changes the representation of a DynValueCommon to a null value type.
      void set_to_value()
      Replaces a null value type with a newly constructed value.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynValueStub

        public _DynValueStub()

    • Method Detail

      • current_member_name

        public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Specified by:
        current_member_name in interface DynValueOperations
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        Specified by:
        current_member_kind in interface DynValueOperations
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • get_members

        public NameValuePair[] get_members()
                            throws InvalidValue
        Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Specified by:
        get_members in interface DynValueOperations
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members

        public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members in interface DynValueOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • get_members_as_dyn_any

        public NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Specified by:
        get_members_as_dyn_any in interface DynValueOperations
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members_as_dyn_any

        public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members_as_dyn_any in interface DynValueOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • is_null

        public boolean is_null()
        Returns true if the DynValueCommon represents a null value type.
        Specified by:
        is_null in interface DynValueCommonOperations

      • set_to_null

        public void set_to_null()
        Changes the representation of a DynValueCommon to a null value type.
        Specified by:
        set_to_null in interface DynValueCommonOperations

      • set_to_value

        public void set_to_value()
        Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.
        Specified by:
        set_to_value in interface DynValueCommonOperations

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.AnySeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.AnySeqHelper

No usage of org.omg.DynamicAny.AnySeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynAny (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynAny

  • Packages that use DynAny
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAny in org.omg.DynamicAny

      Subinterfaces of DynAny in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      Classes in org.omg.DynamicAny that implement DynAny
      Modifier and Type Class and Description
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      Fields in org.omg.DynamicAny declared as DynAny
      Modifier and Type Field and Description
      DynAny NameDynAnyPair.value
      The DynAny value associated with the name.
      Methods in org.omg.DynamicAny that return DynAny
      Modifier and Type | Method and Description
      DynAny _DynFixedStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynAnyStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynArrayStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynStructStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynValueStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynUnionStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny DynAnyOperations.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynEnumStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynSequenceStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny _DynAnyFactoryStub.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny DynAnyFactoryOperations.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny _DynFixedStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynAnyStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynArrayStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynStructStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynValueStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynUnionStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny DynAnyOperations.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynEnumStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynSequenceStub.current_component()
      Returns the DynAny for the component at the current position.
      static DynAny[] | DynAnySeqHelper.extract(Any a)
      static DynAny | DynAnyHelper.extract(Any a)
      DynAny DynValueBoxOperations.get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      DynAny DynUnionOperations.get_discriminator()
      Returns the current discriminator value.
      DynAny _DynUnionStub.get_discriminator()
      Returns the current discriminator value.
      DynAny _DynFixedStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynAnyStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynArrayStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynStructStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynValueStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynUnionStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny DynAnyOperations.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynEnumStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynSequenceStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] _DynArrayStub.get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      DynAny[] DynArrayOperations.get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      DynAny[] DynSequenceOperations.get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      DynAny[] _DynSequenceStub.get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      DynAny DynUnionOperations.member()
      Returns the currently active member.
      DynAny _DynUnionStub.member()
      Returns the currently active member.
      static DynAny | DynAnyHelper.narrow(Object obj)
      static DynAny[] | DynAnySeqHelper.read(InputStream istream)
      static DynAny | DynAnyHelper.read(InputStream istream)
      static DynAny | DynAnyHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynAny
      Modifier and Type | Method and Description
      void _DynFixedStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynAnyStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynArrayStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynStructStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynValueStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynUnionStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void DynAnyOperations.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynEnumStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynSequenceStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      boolean _DynFixedStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynAnyStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynArrayStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynStructStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynValueStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynUnionStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean DynAnyOperations.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynEnumStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynSequenceStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void _DynFixedStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynAnyStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynArrayStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynStructStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynValueStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynUnionStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void DynAnyOperations.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynEnumStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynSequenceStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      static void | DynAnyHelper.insert(Any a, DynAny that)
      static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
      void DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void DynUnionOperations.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void _DynUnionStub.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void _DynArrayStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynArrayOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
      static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)
      Constructors in org.omg.DynamicAny with parameters of type DynAny
      Constructor and Description
      NameDynAnyPair(String _id, DynAny _value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynAnyFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynAnyFactory

  • Packages that use DynAnyFactory
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAnyFactory in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynAnyFactory
      Modifier and Type Class and Description
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      Methods in org.omg.DynamicAny that return DynAnyFactory
      Modifier and Type | Method and Description
      static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
      static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
      static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
      static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynAnyFactory
      Modifier and Type | Method and Description
      static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
      static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyFactoryHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyFactoryHelper

No usage of org.omg.DynamicAny.DynAnyFactoryHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynAnyFactoryOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynAnyFactoryOperations

  • Packages that use DynAnyFactoryOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAnyFactoryOperations in org.omg.DynamicAny

      Subinterfaces of DynAnyFactoryOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynAnyFactory
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      Classes in org.omg.DynamicAny that implement DynAnyFactoryOperations
      Modifier and Type Class and Description
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyHelper

No usage of org.omg.DynamicAny.DynAnyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynAnyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynAnyOperations

  • Packages that use DynAnyOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAnyOperations in org.omg.DynamicAny

      Subinterfaces of DynAnyOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynAny
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      interface  DynArrayOperations
      DynArray objects support the manipulation of IDL arrays.
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynEnumOperations
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynFixedOperations
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynSequenceOperations
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynStructOperations
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      interface  DynUnionOperations
      DynUnion objects support the manipulation of IDL unions.
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueBoxOperations
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      interface  DynValueCommonOperations
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      interface  DynValueOperations
      DynValue objects support the manipulation of IDL non-boxed value types.
      Classes in org.omg.DynamicAny that implement DynAnyOperations
      Modifier and Type Class and Description
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnySeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnySeqHelper

No usage of org.omg.DynamicAny.DynAnySeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynArray (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynArray

  • Packages that use DynArray
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynArray in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynArray
      Modifier and Type Class and Description
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      Methods in org.omg.DynamicAny that return DynArray
      Modifier and Type | Method and Description
      static DynArray | DynArrayHelper.extract(Any a)
      static DynArray | DynArrayHelper.narrow(Object obj)
      static DynArray | DynArrayHelper.read(InputStream istream)
      static DynArray | DynArrayHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynArray
      Modifier and Type | Method and Description
      static void | DynArrayHelper.insert(Any a, DynArray that)
      static void | DynArrayHelper.write(OutputStream ostream, DynArray value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynArrayHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynArrayHelper

No usage of org.omg.DynamicAny.DynArrayHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynArrayOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynArrayOperations

  • Packages that use DynArrayOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynArrayOperations in org.omg.DynamicAny

      Subinterfaces of DynArrayOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      Classes in org.omg.DynamicAny that implement DynArrayOperations
      Modifier and Type Class and Description
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynEnum (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynEnum

  • Packages that use DynEnum
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynEnum in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynEnum
      Modifier and Type Class and Description
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      Methods in org.omg.DynamicAny that return DynEnum
      Modifier and Type | Method and Description
      static DynEnum | DynEnumHelper.extract(Any a)
      static DynEnum | DynEnumHelper.narrow(Object obj)
      static DynEnum | DynEnumHelper.read(InputStream istream)
      static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynEnum
      Modifier and Type | Method and Description
      static void | DynEnumHelper.insert(Any a, DynEnum that)
      static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynEnumHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynEnumHelper

No usage of org.omg.DynamicAny.DynEnumHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynEnumOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynEnumOperations

  • Packages that use DynEnumOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynEnumOperations in org.omg.DynamicAny

      Subinterfaces of DynEnumOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      Classes in org.omg.DynamicAny that implement DynEnumOperations
      Modifier and Type Class and Description
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynFixed (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynFixed

  • Packages that use DynFixed
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynFixed in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynFixed
      Modifier and Type Class and Description
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      Methods in org.omg.DynamicAny that return DynFixed
      Modifier and Type | Method and Description
      static DynFixed | DynFixedHelper.extract(Any a)
      static DynFixed | DynFixedHelper.narrow(Object obj)
      static DynFixed | DynFixedHelper.read(InputStream istream)
      static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynFixed
      Modifier and Type | Method and Description
      static void | DynFixedHelper.insert(Any a, DynFixed that)
      static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynFixedHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynFixedHelper

No usage of org.omg.DynamicAny.DynFixedHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynFixedOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynFixedOperations

  • Packages that use DynFixedOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynFixedOperations in org.omg.DynamicAny

      Subinterfaces of DynFixedOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      Classes in org.omg.DynamicAny that implement DynFixedOperations
      Modifier and Type Class and Description
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynSequence (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynSequence

  • Packages that use DynSequence
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynSequence in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynSequence
      Modifier and Type Class and Description
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      Methods in org.omg.DynamicAny that return DynSequence
      Modifier and Type | Method and Description
      static DynSequence | DynSequenceHelper.extract(Any a)
      static DynSequence | DynSequenceHelper.narrow(Object obj)
      static DynSequence | DynSequenceHelper.read(InputStream istream)
      static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynSequence
      Modifier and Type | Method and Description
      static void | DynSequenceHelper.insert(Any a, DynSequence that)
      static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynSequenceHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynSequenceHelper

No usage of org.omg.DynamicAny.DynSequenceHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynSequenceOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynSequenceOperations

  • Packages that use DynSequenceOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynSequenceOperations in org.omg.DynamicAny

      Subinterfaces of DynSequenceOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      Classes in org.omg.DynamicAny that implement DynSequenceOperations
      Modifier and Type Class and Description
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynStruct (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynStruct

  • Packages that use DynStruct
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynStruct in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynStruct
      Modifier and Type Class and Description
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      Methods in org.omg.DynamicAny that return DynStruct
      Modifier and Type | Method and Description
      static DynStruct | DynStructHelper.extract(Any a)
      static DynStruct | DynStructHelper.narrow(Object obj)
      static DynStruct | DynStructHelper.read(InputStream istream)
      static DynStruct | DynStructHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynStruct
      Modifier and Type | Method and Description
      static void | DynStructHelper.insert(Any a, DynStruct that)
      static void | DynStructHelper.write(OutputStream ostream, DynStruct value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynStructHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynStructHelper

No usage of org.omg.DynamicAny.DynStructHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynStructOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynStructOperations

  • Packages that use DynStructOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynStructOperations in org.omg.DynamicAny

      Subinterfaces of DynStructOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      Classes in org.omg.DynamicAny that implement DynStructOperations
      Modifier and Type Class and Description
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynUnion (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynUnion

  • Packages that use DynUnion
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynUnion in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynUnion
      Modifier and Type Class and Description
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      Methods in org.omg.DynamicAny that return DynUnion
      Modifier and Type | Method and Description
      static DynUnion | DynUnionHelper.extract(Any a)
      static DynUnion | DynUnionHelper.narrow(Object obj)
      static DynUnion | DynUnionHelper.read(InputStream istream)
      static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynUnion
      Modifier and Type | Method and Description
      static void | DynUnionHelper.insert(Any a, DynUnion that)
      static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynUnionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynUnionHelper

No usage of org.omg.DynamicAny.DynUnionHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynUnionOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynUnionOperations

  • Packages that use DynUnionOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynUnionOperations in org.omg.DynamicAny

      Subinterfaces of DynUnionOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      Classes in org.omg.DynamicAny that implement DynUnionOperations
      Modifier and Type Class and Description
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynValue

  • Packages that use DynValue
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValue in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynValue
      Modifier and Type Class and Description
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      Methods in org.omg.DynamicAny that return DynValue
      Modifier and Type | Method and Description
      static DynValue | DynValueHelper.extract(Any a)
      static DynValue | DynValueHelper.narrow(Object obj)
      static DynValue | DynValueHelper.read(InputStream istream)
      static DynValue | DynValueHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynValue
      Modifier and Type | Method and Description
      static void | DynValueHelper.insert(Any a, DynValue that)
      static void | DynValueHelper.write(OutputStream ostream, DynValue value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynValueBox (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynValueBox

No usage of org.omg.DynamicAny.DynValueBox
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynValueBoxOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynValueBoxOperations

  • Packages that use DynValueBoxOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueBoxOperations in org.omg.DynamicAny

      Subinterfaces of DynValueBoxOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynValueCommon (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynValueCommon

  • Packages that use DynValueCommon
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueCommon in org.omg.DynamicAny

      Subinterfaces of DynValueCommon in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      Classes in org.omg.DynamicAny that implement DynValueCommon
      Modifier and Type Class and Description
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynValueCommonOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynValueCommonOperations

  • Packages that use DynValueCommonOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueCommonOperations in org.omg.DynamicAny

      Subinterfaces of DynValueCommonOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueBoxOperations
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      interface  DynValueOperations
      DynValue objects support the manipulation of IDL non-boxed value types.
      Classes in org.omg.DynamicAny that implement DynValueCommonOperations
      Modifier and Type Class and Description
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynValueHelper

No usage of org.omg.DynamicAny.DynValueHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.DynamicAny.DynValueOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.DynamicAny.DynValueOperations

  • Packages that use DynValueOperations
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueOperations in org.omg.DynamicAny

      Subinterfaces of DynValueOperations in org.omg.DynamicAny
      Modifier and Type Interface and Description
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      Classes in org.omg.DynamicAny that implement DynValueOperations
      Modifier and Type Class and Description
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.FieldNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.FieldNameHelper

No usage of org.omg.DynamicAny.FieldNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.NameDynAnyPair (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.NameDynAnyPair

  • Packages that use NameDynAnyPair
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of NameDynAnyPair in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return NameDynAnyPair
      Modifier and Type | Method and Description
      static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
      NameDynAnyPair[] DynValueOperations.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameDynAnyPair[] _DynStructStub.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameDynAnyPair[] DynStructOperations.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameDynAnyPair[] _DynValueStub.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny with parameters of type NameDynAnyPair
      Modifier and Type | Method and Description
      static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
      static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
      void DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
      static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.NameDynAnyPairHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.NameDynAnyPairHelper

No usage of org.omg.DynamicAny.NameDynAnyPairHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.NameDynAnyPairSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.NameDynAnyPairSeqHelper

No usage of org.omg.DynamicAny.NameDynAnyPairSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.NameValuePair (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.NameValuePair

  • Packages that use NameValuePair
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of NameValuePair in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return NameValuePair
      Modifier and Type | Method and Description
      static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
      static NameValuePair | NameValuePairHelper.extract(Any a)
      NameValuePair[] DynValueOperations.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      NameValuePair[] _DynStructStub.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] DynStructOperations.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] _DynValueStub.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny with parameters of type NameValuePair
      Modifier and Type | Method and Description
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
      void DynValueOperations.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void _DynStructStub.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void DynStructOperations.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void _DynValueStub.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
      static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.NameValuePairHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.NameValuePairHelper

No usage of org.omg.DynamicAny.NameValuePairHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.NameValuePairSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.NameValuePairSeqHelper

No usage of org.omg.DynamicAny.NameValuePairSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynAnyFactoryStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynAnyFactoryStub

No usage of org.omg.DynamicAny._DynAnyFactoryStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynAnyStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynAnyStub

No usage of org.omg.DynamicAny._DynAnyStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynArrayStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynArrayStub

No usage of org.omg.DynamicAny._DynArrayStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynEnumStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynEnumStub

No usage of org.omg.DynamicAny._DynEnumStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynFixedStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynFixedStub

No usage of org.omg.DynamicAny._DynFixedStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynSequenceStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynSequenceStub

No usage of org.omg.DynamicAny._DynSequenceStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynStructStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynStructStub

No usage of org.omg.DynamicAny._DynStructStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynUnionStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynUnionStub

No usage of org.omg.DynamicAny._DynUnionStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny._DynValueStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny._DynValueStub

No usage of org.omg.DynamicAny._DynValueStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InconsistentTypeCode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny.DynAnyFactoryPackage

Class InconsistentTypeCode

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InconsistentTypeCode
extends UserException
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InconsistentTypeCode()
      InconsistentTypeCode(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InconsistentTypeCode

        public InconsistentTypeCode()

      • InconsistentTypeCode

        public InconsistentTypeCode(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InconsistentTypeCodeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny.DynAnyFactoryPackage

Class InconsistentTypeCodeHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

  • public abstract class InconsistentTypeCodeHelper
extends Object
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InconsistentTypeCodeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InconsistentTypeCode | extract(Any a)
      static String | id()
      static void | insert(Any a, InconsistentTypeCode that)
      static InconsistentTypeCode | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InconsistentTypeCode value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InconsistentTypeCodeHelper

        public InconsistentTypeCodeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InconsistentTypeCode that)

      • extract

        public static InconsistentTypeCode extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InconsistentTypeCode read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InconsistentTypeCode value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.DynamicAny.DynAnyFactoryPackage (Java Platform SE 8 )

org.omg.DynamicAny.DynAnyFactoryPackage

Classes

  • InconsistentTypeCodeHelper

Exceptions

  • InconsistentTypeCode


org.omg.DynamicAny.DynAnyFactoryPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.DynamicAny.DynAnyFactoryPackage

This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.

See: Description

  • Class Summary
    Class Description
    InconsistentTypeCodeHelper
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java .
  • Exception Summary
    Exception Description
    InconsistentTypeCode
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .

Package org.omg.DynamicAny.DynAnyFactoryPackage Description

This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.DynamicAny.DynAnyFactoryPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.DynamicAny.DynAnyFactoryPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.DynamicAny.DynAnyFactoryPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.DynamicAny.DynAnyFactoryPackage

  • Packages that use org.omg.DynamicAny.DynAnyFactoryPackage
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
  • Classes in org.omg.DynamicAny.DynAnyFactoryPackage used by org.omg.DynamicAny
    Class and Description
    InconsistentTypeCode
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .
  • Classes in org.omg.DynamicAny.DynAnyFactoryPackage used by org.omg.DynamicAny.DynAnyFactoryPackage
    Class and Description
    InconsistentTypeCode
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode

  • Packages that use InconsistentTypeCode
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.

    • Uses of InconsistentTypeCode in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that throw InconsistentTypeCode
      Modifier and Type Method and Description
      DynAny _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny _DynAnyFactoryStub.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny DynAnyFactoryOperations.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

    • Uses of InconsistentTypeCode in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage that return InconsistentTypeCode
      Modifier and Type | Method and Description
      static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
      static InconsistentTypeCode | InconsistentTypeCodeHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type InconsistentTypeCode
      Modifier and Type | Method and Description
      static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)
      static void | InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

No usage of org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny.DynAnyPackage

Class InvalidValue

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidValue
extends UserException
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidValue()
      InvalidValue(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidValue

        public InvalidValue()

      • InvalidValue

        public InvalidValue(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny.DynAnyPackage

Class InvalidValueHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

  • public abstract class InvalidValueHelper
extends Object
    org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidValueHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidValue | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidValue that)
      static InvalidValue | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidValue value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidValueHelper

        public InvalidValueHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidValue that)

      • extract

        public static InvalidValue extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidValue read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidValue value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.DynamicAny.DynAnyPackage (Java Platform SE 8 )

org.omg.DynamicAny.DynAnyPackage

Classes

  • InvalidValueHelper
  • TypeMismatchHelper

Exceptions

  • InvalidValue
  • TypeMismatch


org.omg.DynamicAny.DynAnyPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.DynamicAny.DynAnyPackage

This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

See: Description

  • Class Summary
    Class Description
    InvalidValueHelper
    org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java .
    TypeMismatchHelper
    org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java .
  • Exception Summary
    Exception Description
    InvalidValue
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
    TypeMismatch
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .

Package org.omg.DynamicAny.DynAnyPackage Description

This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.DynamicAny.DynAnyPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.DynamicAny.DynAnyPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.DynamicAny.DynAnyPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.DynamicAny.DynAnyPackage

  • Packages that use org.omg.DynamicAny.DynAnyPackage
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
  • Classes in org.omg.DynamicAny.DynAnyPackage used by org.omg.DynamicAny
    Class and Description
    InvalidValue
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
    TypeMismatch
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .
  • Classes in org.omg.DynamicAny.DynAnyPackage used by org.omg.DynamicAny.DynAnyPackage
    Class and Description
    InvalidValue
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
    TypeMismatch
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny.DynAnyPackage

Class TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatch()
      TypeMismatch(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeMismatch

        public TypeMismatch()

      • TypeMismatch

        public TypeMismatch(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeMismatchHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny.DynAnyPackage

Class TypeMismatchHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

  • public abstract class TypeMismatchHelper
extends Object
    org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatchHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TypeMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, TypeMismatch that)
      static TypeMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TypeMismatch value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TypeMismatchHelper

        public TypeMismatchHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TypeMismatch that)

      • extract

        public static TypeMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TypeMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TypeMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyPackage.InvalidValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyPackage.InvalidValue

  • Packages that use InvalidValue
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

    • Uses of InvalidValue in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that throw InvalidValue
      Modifier and Type Method and Description
      TCKind DynValueOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynStructStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynStructOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynValueStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String DynValueOperations.current_member_name()
      Returns the name of the member at the current position.
      String _DynStructStub.current_member_name()
      Returns the name of the member at the current position.
      String DynStructOperations.current_member_name()
      Returns the name of the member at the current position.
      String _DynValueStub.current_member_name()
      Returns the name of the member at the current position.
      void _DynFixedStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynAnyStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynArrayStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynStructStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynValueStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynUnionStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void DynAnyOperations.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynEnumStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynSequenceStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any _DynFixedStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynAnyStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynArrayStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynStructStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynValueStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynUnionStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynAnyOperations.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynEnumStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynSequenceStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean _DynFixedStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynAnyStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynArrayStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynStructStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynValueStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynUnionStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean DynAnyOperations.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynEnumStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynSequenceStub.get_boolean()
      Extracts the boolean value from this DynAny.
      DynAny DynValueBoxOperations.get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      Any DynValueBoxOperations.get_boxed_value()
      Returns the boxed value as an Any.
      char _DynFixedStub.get_char()
      Extracts the char value from this DynAny.
      char _DynAnyStub.get_char()
      Extracts the char value from this DynAny.
      char _DynArrayStub.get_char()
      Extracts the char value from this DynAny.
      char _DynStructStub.get_char()
      Extracts the char value from this DynAny.
      char _DynValueStub.get_char()
      Extracts the char value from this DynAny.
      char _DynUnionStub.get_char()
      Extracts the char value from this DynAny.
      char DynAnyOperations.get_char()
      Extracts the char value from this DynAny.
      char _DynEnumStub.get_char()
      Extracts the char value from this DynAny.
      char _DynSequenceStub.get_char()
      Extracts the char value from this DynAny.
      double _DynFixedStub.get_double()
      Extracts the double value from this DynAny.
      double _DynAnyStub.get_double()
      Extracts the double value from this DynAny.
      double _DynArrayStub.get_double()
      Extracts the double value from this DynAny.
      double _DynStructStub.get_double()
      Extracts the double value from this DynAny.
      double _DynValueStub.get_double()
      Extracts the double value from this DynAny.
      double _DynUnionStub.get_double()
      Extracts the double value from this DynAny.
      double DynAnyOperations.get_double()
      Extracts the double value from this DynAny.
      double _DynEnumStub.get_double()
      Extracts the double value from this DynAny.
      double _DynSequenceStub.get_double()
      Extracts the double value from this DynAny.
      DynAny _DynFixedStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynAnyStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynArrayStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynStructStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynValueStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynUnionStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny DynAnyOperations.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynEnumStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynSequenceStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float _DynFixedStub.get_float()
      Extracts the float value from this DynAny.
      float _DynAnyStub.get_float()
      Extracts the float value from this DynAny.
      float _DynArrayStub.get_float()
      Extracts the float value from this DynAny.
      float _DynStructStub.get_float()
      Extracts the float value from this DynAny.
      float _DynValueStub.get_float()
      Extracts the float value from this DynAny.
      float _DynUnionStub.get_float()
      Extracts the float value from this DynAny.
      float DynAnyOperations.get_float()
      Extracts the float value from this DynAny.
      float _DynEnumStub.get_float()
      Extracts the float value from this DynAny.
      float _DynSequenceStub.get_float()
      Extracts the float value from this DynAny.
      int _DynFixedStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynValueStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_long()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_long()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_long()
      Extracts the integer value from this DynAny.
      long _DynFixedStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynValueStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_longlong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_longlong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] DynValueOperations.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameDynAnyPair[] _DynValueStub.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] DynValueOperations.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      NameValuePair[] _DynValueStub.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      byte _DynFixedStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynAnyStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynArrayStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynStructStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynValueStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynUnionStub.get_octet()
      Extracts the byte value from this DynAny.
      byte DynAnyOperations.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynEnumStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynSequenceStub.get_octet()
      Extracts the byte value from this DynAny.
      Object _DynFixedStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynAnyStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynArrayStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynStructStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynValueStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynUnionStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object DynAnyOperations.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynEnumStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynSequenceStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short _DynFixedStub.get_short()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_short()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_short()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_short()
      Extracts the short value from this DynAny.
      short _DynValueStub.get_short()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_short()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_short()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_short()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_short()
      Extracts the short value from this DynAny.
      String _DynFixedStub.get_string()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_string()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_string()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_string()
      Extracts the string value from this DynAny.
      String _DynValueStub.get_string()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_string()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_string()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_string()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_string()
      Extracts the string value from this DynAny.
      TypeCode _DynFixedStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynAnyStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynArrayStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynStructStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynValueStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynUnionStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode DynAnyOperations.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynEnumStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynSequenceStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      int _DynFixedStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynValueStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_ulong()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_ulong()
      Extracts the integer value from this DynAny.
      long _DynFixedStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynValueStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_ulonglong()
      Extracts the long value from this DynAny.
      short _DynFixedStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynValueStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_ushort()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_ushort()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_ushort()
      Extracts the short value from this DynAny.
      Serializable _DynFixedStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynAnyStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynArrayStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynStructStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynValueStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynUnionStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable DynAnyOperations.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynEnumStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynSequenceStub.get_val()
      Extracts a Serializable object from this DynAny.
      char _DynFixedStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynAnyStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynArrayStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynStructStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynValueStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynUnionStub.get_wchar()
      Extracts the long value from this DynAny.
      char DynAnyOperations.get_wchar()
      Extracts the long value from this DynAny.
      char _DynEnumStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynSequenceStub.get_wchar()
      Extracts the long value from this DynAny.
      String _DynFixedStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynValueStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_wstring()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_wstring()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_wstring()
      Extracts the string value from this DynAny.
      void _DynFixedStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynAnyStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynArrayStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynStructStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynValueStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynUnionStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void DynAnyOperations.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynEnumStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynSequenceStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynFixedStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynAnyStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynArrayStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynStructStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynValueStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynUnionStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void DynAnyOperations.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynEnumStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynSequenceStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynFixedStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynAnyStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynArrayStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynStructStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynValueStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynUnionStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void DynAnyOperations.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynEnumStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynSequenceStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynFixedStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynAnyStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynArrayStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynStructStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynValueStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynUnionStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void DynAnyOperations.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynEnumStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynSequenceStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynFixedStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynAnyStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynArrayStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynStructStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynValueStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynUnionStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void DynAnyOperations.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynEnumStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynSequenceStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynFixedStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynAnyStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynArrayStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynStructStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynValueStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynUnionStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void DynAnyOperations.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynEnumStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynSequenceStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynFixedStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynAnyStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynArrayStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynStructStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynValueStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynUnionStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void DynAnyOperations.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynEnumStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynSequenceStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynFixedStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynValueStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynFixedStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynAnyStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynArrayStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynStructStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynValueStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynUnionStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void DynAnyOperations.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynEnumStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynSequenceStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynFixedStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynAnyStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynArrayStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynStructStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynValueStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynUnionStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void DynAnyOperations.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynEnumStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynSequenceStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynFixedStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynValueStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      TCKind DynUnionOperations.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      TCKind _DynUnionStub.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String DynUnionOperations.member_name()
      Returns the name of the currently active member.
      String _DynUnionStub.member_name()
      Returns the name of the currently active member.
      DynAny DynUnionOperations.member()
      Returns the currently active member.
      DynAny _DynUnionStub.member()
      Returns the currently active member.
      void DynEnumOperations.set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void _DynEnumStub.set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void DynEnumOperations.set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      void _DynEnumStub.set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      void _DynArrayStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynArrayOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynArrayStub.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynArrayOperations.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements(Any[] value)
      Sets the elements of a sequence.
      void _DynSequenceStub.set_elements(Any[] value)
      Sets the elements of a sequence.
      void DynSequenceOperations.set_length(int len)
      Sets the length of the sequence.
      void _DynSequenceStub.set_length(int len)
      Sets the length of the sequence.
      void DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void DynValueOperations.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void _DynStructStub.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void DynStructOperations.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void _DynValueStub.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      boolean _DynFixedStub.set_value(String val)
      Sets the value of the DynFixed.
      boolean DynFixedOperations.set_value(String val)
      Sets the value of the DynFixed.

    • Uses of InvalidValue in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage that return InvalidValue
      Modifier and Type | Method and Description
      static InvalidValue | InvalidValueHelper.extract(Any a)
      static InvalidValue | InvalidValueHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type InvalidValue
      Modifier and Type | Method and Description
      static void | InvalidValueHelper.insert(Any a, InvalidValue that)
      static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

No usage of org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyPackage.TypeMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyPackage.TypeMismatch

  • Packages that use TypeMismatch
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

    • Uses of TypeMismatch in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that throw TypeMismatch
      Modifier and Type Method and Description
      void _DynFixedStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynAnyStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynArrayStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynStructStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynValueStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynUnionStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void DynAnyOperations.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynEnumStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynSequenceStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      DynAny _DynFixedStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynAnyStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynArrayStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynStructStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynValueStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynUnionStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny DynAnyOperations.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynEnumStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynSequenceStub.current_component()
      Returns the DynAny for the component at the current position.
      TCKind DynValueOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynStructStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynStructOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynValueStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String DynValueOperations.current_member_name()
      Returns the name of the member at the current position.
      String _DynStructStub.current_member_name()
      Returns the name of the member at the current position.
      String DynStructOperations.current_member_name()
      Returns the name of the member at the current position.
      String _DynValueStub.current_member_name()
      Returns the name of the member at the current position.
      void _DynFixedStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynAnyStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynArrayStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynStructStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynValueStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynUnionStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void DynAnyOperations.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynEnumStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynSequenceStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any _DynFixedStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynAnyStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynArrayStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynStructStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynValueStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynUnionStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynAnyOperations.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynEnumStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynSequenceStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean _DynFixedStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynAnyStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynArrayStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynStructStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynValueStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynUnionStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean DynAnyOperations.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynEnumStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynSequenceStub.get_boolean()
      Extracts the boolean value from this DynAny.
      char _DynFixedStub.get_char()
      Extracts the char value from this DynAny.
      char _DynAnyStub.get_char()
      Extracts the char value from this DynAny.
      char _DynArrayStub.get_char()
      Extracts the char value from this DynAny.
      char _DynStructStub.get_char()
      Extracts the char value from this DynAny.
      char _DynValueStub.get_char()
      Extracts the char value from this DynAny.
      char _DynUnionStub.get_char()
      Extracts the char value from this DynAny.
      char DynAnyOperations.get_char()
      Extracts the char value from this DynAny.
      char _DynEnumStub.get_char()
      Extracts the char value from this DynAny.
      char _DynSequenceStub.get_char()
      Extracts the char value from this DynAny.
      double _DynFixedStub.get_double()
      Extracts the double value from this DynAny.
      double _DynAnyStub.get_double()
      Extracts the double value from this DynAny.
      double _DynArrayStub.get_double()
      Extracts the double value from this DynAny.
      double _DynStructStub.get_double()
      Extracts the double value from this DynAny.
      double _DynValueStub.get_double()
      Extracts the double value from this DynAny.
      double _DynUnionStub.get_double()
      Extracts the double value from this DynAny.
      double DynAnyOperations.get_double()
      Extracts the double value from this DynAny.
      double _DynEnumStub.get_double()
      Extracts the double value from this DynAny.
      double _DynSequenceStub.get_double()
      Extracts the double value from this DynAny.
      DynAny _DynFixedStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynAnyStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynArrayStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynStructStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynValueStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynUnionStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny DynAnyOperations.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynEnumStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynSequenceStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float _DynFixedStub.get_float()
      Extracts the float value from this DynAny.
      float _DynAnyStub.get_float()
      Extracts the float value from this DynAny.
      float _DynArrayStub.get_float()
      Extracts the float value from this DynAny.
      float _DynStructStub.get_float()
      Extracts the float value from this DynAny.
      float _DynValueStub.get_float()
      Extracts the float value from this DynAny.
      float _DynUnionStub.get_float()
      Extracts the float value from this DynAny.
      float DynAnyOperations.get_float()
      Extracts the float value from this DynAny.
      float _DynEnumStub.get_float()
      Extracts the float value from this DynAny.
      float _DynSequenceStub.get_float()
      Extracts the float value from this DynAny.
      int _DynFixedStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynValueStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_long()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_long()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_long()
      Extracts the integer value from this DynAny.
      long _DynFixedStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynValueStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_longlong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_longlong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_longlong()
      Extracts the long value from this DynAny.
      byte _DynFixedStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynAnyStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynArrayStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynStructStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynValueStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynUnionStub.get_octet()
      Extracts the byte value from this DynAny.
      byte DynAnyOperations.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynEnumStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynSequenceStub.get_octet()
      Extracts the byte value from this DynAny.
      Object _DynFixedStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynAnyStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynArrayStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynStructStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynValueStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynUnionStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object DynAnyOperations.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynEnumStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynSequenceStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short _DynFixedStub.get_short()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_short()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_short()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_short()
      Extracts the short value from this DynAny.
      short _DynValueStub.get_short()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_short()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_short()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_short()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_short()
      Extracts the short value from this DynAny.
      String _DynFixedStub.get_string()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_string()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_string()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_string()
      Extracts the string value from this DynAny.
      String _DynValueStub.get_string()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_string()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_string()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_string()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_string()
      Extracts the string value from this DynAny.
      TypeCode _DynFixedStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynAnyStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynArrayStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynStructStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynValueStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynUnionStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode DynAnyOperations.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynEnumStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynSequenceStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      int _DynFixedStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynValueStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_ulong()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_ulong()
      Extracts the integer value from this DynAny.
      long _DynFixedStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynValueStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_ulonglong()
      Extracts the long value from this DynAny.
      short _DynFixedStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynValueStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_ushort()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_ushort()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_ushort()
      Extracts the short value from this DynAny.
      Serializable _DynFixedStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynAnyStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynArrayStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynStructStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynValueStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynUnionStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable DynAnyOperations.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynEnumStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynSequenceStub.get_val()
      Extracts a Serializable object from this DynAny.
      char _DynFixedStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynAnyStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynArrayStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynStructStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynValueStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynUnionStub.get_wchar()
      Extracts the long value from this DynAny.
      char DynAnyOperations.get_wchar()
      Extracts the long value from this DynAny.
      char _DynEnumStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynSequenceStub.get_wchar()
      Extracts the long value from this DynAny.
      String _DynFixedStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynValueStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_wstring()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_wstring()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_wstring()
      Extracts the string value from this DynAny.
      void _DynFixedStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynAnyStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynArrayStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynStructStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynValueStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynUnionStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void DynAnyOperations.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynEnumStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynSequenceStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynFixedStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynAnyStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynArrayStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynStructStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynValueStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynUnionStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void DynAnyOperations.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynEnumStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynSequenceStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynFixedStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynAnyStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynArrayStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynStructStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynValueStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynUnionStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void DynAnyOperations.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynEnumStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynSequenceStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynFixedStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynAnyStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynArrayStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynStructStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynValueStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynUnionStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void DynAnyOperations.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynEnumStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynSequenceStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynFixedStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynAnyStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynArrayStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynStructStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynValueStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynUnionStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void DynAnyOperations.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynEnumStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynSequenceStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynFixedStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynAnyStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynArrayStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynStructStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynValueStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynUnionStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void DynAnyOperations.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynEnumStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynSequenceStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynFixedStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynAnyStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynArrayStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynStructStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynValueStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynUnionStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void DynAnyOperations.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynEnumStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynSequenceStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynFixedStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynValueStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynFixedStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynAnyStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynArrayStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynStructStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynValueStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynUnionStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void DynAnyOperations.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynEnumStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynSequenceStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynFixedStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynAnyStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynArrayStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynStructStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynValueStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynUnionStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void DynAnyOperations.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynEnumStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynSequenceStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynFixedStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynValueStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void DynValueBoxOperations.set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.
      void DynUnionOperations.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void _DynUnionStub.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void _DynArrayStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynArrayOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynArrayStub.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynArrayOperations.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements(Any[] value)
      Sets the elements of a sequence.
      void _DynSequenceStub.set_elements(Any[] value)
      Sets the elements of a sequence.
      void DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void DynValueOperations.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void _DynStructStub.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void DynStructOperations.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void _DynValueStub.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void DynUnionOperations.set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void _DynUnionStub.set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void DynUnionOperations.set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      void _DynUnionStub.set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      boolean _DynFixedStub.set_value(String val)
      Sets the value of the DynFixed.
      boolean DynFixedOperations.set_value(String val)
      Sets the value of the DynFixed.

    • Uses of TypeMismatch in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage that return TypeMismatch
      Modifier and Type | Method and Description
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type TypeMismatch
      Modifier and Type | Method and Description
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

No usage of org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Codec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface Codec

  • All Superinterfaces:
    CodecOperations, IDLEntity, Object, Serializable

    public interface Codec
extends CodecOperations, Object, IDLEntity
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

    A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      • Methods inherited from interface org.omg.IOP.CodecOperations

        decode_value, decode, encode_value, encode

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CodecFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodecFactory

  • All Superinterfaces:
    CodecFactoryOperations, IDLEntity, Object, Serializable

    public interface CodecFactory
extends CodecFactoryOperations, Object, IDLEntity
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      • Methods inherited from interface org.omg.IOP.CodecFactoryOperations

        create_codec

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CodecFactoryHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class CodecFactoryHelper

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper

  • public abstract class CodecFactoryHelper
extends Object
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Constructor Summary

      Constructors
      Constructor and Description
      CodecFactoryHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static CodecFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, CodecFactory that)
      static CodecFactory | narrow(Object obj)
      static CodecFactory | read(InputStream istream)
      static TypeCode | type()
      static CodecFactory | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, CodecFactory value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CodecFactoryHelper

        public CodecFactoryHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          CodecFactory that)

      • extract

        public static CodecFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CodecFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         CodecFactory value)

      • narrow

        public static CodecFactory narrow(Object obj)

      • unchecked_narrow

        public static CodecFactory unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CodecFactoryOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodecFactoryOperations

  • All Known Subinterfaces:
    CodecFactory

    public interface CodecFactoryOperations
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Codec create_codec(Encoding enc)
      Create a Codec of the given encoding.

    • Method Detail

      • create_codec

        Codec create_codec(Encoding enc)
            throws UnknownEncoding
        Create a Codec of the given encoding.

        Parameters:
        enc - The encoding for which to create a Codec.
        Returns:
        A Codec obtained with the given encoding.
        Throws:
        UnknownEncoding - thrown if this factory cannot create a Codec of the given encoding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CodecOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodecOperations

  • All Known Subinterfaces:
    Codec

    public interface CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

    A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Any decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.
      byte[] encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.

    • Method Detail

      • encode

        byte[] encode(Any data)
       throws InvalidTypeForEncoding
        Converts the given any into a byte array based on the encoding format effective for this Codec.
        Parameters:
        data - The data, in the form of an any, to be encoded into a byte array.
        Returns:
        A byte array containing the encoded Any. This byte array contains both the TypeCode and the data of the type.
        Throws:
        InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

      • decode

        Any decode(byte[] data)
    throws FormatMismatch
        Decodes the given byte array into an Any based on the encoding format effective for this Codec.
        Parameters:
        data - The data, in the form of a byte array, to be decoded into an Any.
        Returns:
        An Any containing the data from the decoded byte array.
        Throws:
        FormatMismatch - is thrown if the byte array cannot be decoded into an Any.

      • encode_value

        byte[] encode_value(Any data)
             throws InvalidTypeForEncoding
        Converts the given any into a byte array based on the encoding format effective for this Codec. Only the data from the Any is encoded, not the TypeCode.
        Parameters:
        data - The data, in the form of an Any, to be encoded into a byte array.
        Returns:
        A byte array containing the data from the encoded any.
        Throws:
        InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

      • decode_value

        Any decode_value(byte[] data,
                 TypeCode tc)
          throws FormatMismatch,
                 TypeMismatch
        Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
        Parameters:
        data - The data, in the form of a byte array, to be decoded into an Any.
        tc - The TypeCode to be used to decode the data.
        Returns:
        An Any containing the data from the decoded byte array.
        Throws:
        FormatMismatch - thrown if the byte array cannot be decoded into an Any.
        TypeMismatch
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CodeSets (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodeSets

  • public interface CodeSets
    org/omg/IOP/CodeSets.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.

    • Field Detail

      • value

        static final int value
        Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ComponentIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ComponentIdHelper

  • java.lang.Object
    • org.omg.IOP.ComponentIdHelper

  • public abstract class ComponentIdHelper
extends Object
    Standard way of representing multicomponent profiles. This would be encapsulated in a TaggedProfile.

    • Constructor Summary

      Constructors
      Constructor and Description
      ComponentIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ComponentIdHelper

        public ComponentIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Encoding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class Encoding

  • java.lang.Object
    • org.omg.IOP.Encoding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Encoding
extends Object
implements IDLEntity
    org/omg/IOP/Encoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      short format
      The encoding format.
      byte major_version
      The major version of this Encoding format.
      byte minor_version
      The minor version of this Encoding format.

    • Constructor Summary

      Constructors
      Constructor and Description
      Encoding()
      Encoding(short _format, byte _major_version, byte _minor_version)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • format

        public short format
        The encoding format.

      • major_version

        public byte major_version
        The major version of this Encoding format.

      • minor_version

        public byte minor_version
        The minor version of this Encoding format.

    • Constructor Detail

      • Encoding

        public Encoding()

      • Encoding

        public Encoding(short _format,
                byte _major_version,
                byte _minor_version)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ENCODING_CDR_ENCAPS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface ENCODING_CDR_ENCAPS

  • public interface ENCODING_CDR_ENCAPS
    org/omg/IOP/ENCODING_CDR_ENCAPS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The CDR Encapsulation encoding.

    • Field Detail

      • value

        static final short value
        The CDR Encapsulation encoding.
        See Also:
        CodecFactory, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ExceptionDetailMessage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface ExceptionDetailMessage

  • public interface ExceptionDetailMessage
    org/omg/IOP/ExceptionDetailMessage.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16.

    • Field Detail

      • value

        static final int value
        CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16. This service context may be sent on Reply messages with a reply_status of SYSTEM_EXCEPTION or USER_EXCEPTION. The usage of this service context is defined by language mappings.

        IDL/Java: ptc/02-01-22: 1.15.2: When a System Exception is marshaled, its GIOP Reply message shall include an associated ExceptionDetailMessage service context. The callee's stack trace is often very valuable debugging information but may contain sensitive or unwanted information. The wstring within the service context will therefore contain additional information relating to the exception, for example the result of calling either printStackTrace(PrintWriter) or getMessage() on the exception. When unmarshaling a System Exception on the client side, the wstring from any ExceptionDetailMessage service context shall become the Java error message in the unmarshaled exception object.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IOR (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class IOR

  • java.lang.Object
    • org.omg.IOP.IOR
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class IOR
extends Object
implements IDLEntity
    org/omg/IOP/IOR.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedProfile[] profiles
      An array of tagged profiles associated with this object reference.
      String type_id
      The type id, represented as a String.

    • Constructor Summary

      Constructors
      Constructor and Description
      IOR()
      IOR(String _type_id, TaggedProfile[] _profiles)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • type_id

        public String type_id
        The type id, represented as a String.

      • profiles

        public TaggedProfile[] profiles
        An array of tagged profiles associated with this object reference.

    • Constructor Detail

      • IOR

        public IOR()

      • IOR

        public IOR(String _type_id,
           TaggedProfile[] _profiles)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class IORHelper

  • java.lang.Object
    • org.omg.IOP.IORHelper

  • public abstract class IORHelper
extends Object
    org/omg/IOP/IORHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      IORHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static IOR | extract(Any a)
      static String | id()
      static void | insert(Any a, IOR that)
      static IOR | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, IOR value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IORHelper

        public IORHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          IOR that)

      • extract

        public static IOR extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IOR read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         IOR value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class IORHolder

  • java.lang.Object
    • org.omg.IOP.IORHolder
  • All Implemented Interfaces:
    Streamable

    public final class IORHolder
extends Object
implements Streamable
    org/omg/IOP/IORHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      IOR value

    • Constructor Summary

      Constructors
      Constructor and Description
      IORHolder()
      IORHolder(IOR initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public IOR value

    • Constructor Detail

      • IORHolder

        public IORHolder()

      • IORHolder

        public IORHolder(IOR initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MultipleComponentProfileHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class MultipleComponentProfileHelper

  • java.lang.Object
    • org.omg.IOP.MultipleComponentProfileHelper

  • public abstract class MultipleComponentProfileHelper
extends Object
    An array of tagged components, forming a multiple component profile.

    • Constructor Summary

      Constructors
      Constructor and Description
      MultipleComponentProfileHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TaggedComponent[] | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedComponent[] that)
      static TaggedComponent[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedComponent[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MultipleComponentProfileHelper

        public MultipleComponentProfileHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TaggedComponent[] that)

      • extract

        public static TaggedComponent[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedComponent[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TaggedComponent[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MultipleComponentProfileHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class MultipleComponentProfileHolder

  • java.lang.Object
    • org.omg.IOP.MultipleComponentProfileHolder
  • All Implemented Interfaces:
    Streamable

    public final class MultipleComponentProfileHolder
extends Object
implements Streamable
    An array of tagged components, forming a multiple component profile.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedComponent[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      MultipleComponentProfileHolder()
      MultipleComponentProfileHolder(TaggedComponent[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TaggedComponent[] value

    • Constructor Detail

      • MultipleComponentProfileHolder

        public MultipleComponentProfileHolder()

      • MultipleComponentProfileHolder

        public MultipleComponentProfileHolder(TaggedComponent[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.IOP (Java Platform SE 8 )

org.omg.IOP

Interfaces

  • Codec
  • CodecFactory
  • CodecFactoryOperations
  • CodecOperations
  • CodeSets
  • ENCODING_CDR_ENCAPS
  • ExceptionDetailMessage
  • RMICustomMaxStreamFormat
  • TAG_ALTERNATE_IIOP_ADDRESS
  • TAG_CODE_SETS
  • TAG_INTERNET_IOP
  • TAG_JAVA_CODEBASE
  • TAG_MULTIPLE_COMPONENTS
  • TAG_ORB_TYPE
  • TAG_POLICIES
  • TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • TransactionService

Classes

  • CodecFactoryHelper
  • ComponentIdHelper
  • Encoding
  • IOR
  • IORHelper
  • IORHolder
  • MultipleComponentProfileHelper
  • MultipleComponentProfileHolder
  • ProfileIdHelper
  • ServiceContext
  • ServiceContextHelper
  • ServiceContextHolder
  • ServiceContextListHelper
  • ServiceContextListHolder
  • ServiceIdHelper
  • TaggedComponent
  • TaggedComponentHelper
  • TaggedComponentHolder
  • TaggedProfile
  • TaggedProfileHelper
  • TaggedProfileHolder


org.omg.IOP (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.IOP

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

See: Description

  • Interface Summary
    Interface Description
    Codec
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodecFactory
    Codecs are obtained from the CodecFactory.
    CodecFactoryOperations
    Codecs are obtained from the CodecFactory.
    CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodeSets
    org/omg/IOP/CodeSets.java .
    ENCODING_CDR_ENCAPS
    org/omg/IOP/ENCODING_CDR_ENCAPS.java .
    ExceptionDetailMessage
    org/omg/IOP/ExceptionDetailMessage.java .
    RMICustomMaxStreamFormat
    org/omg/IOP/RMICustomMaxStreamFormat.java .
    TAG_ALTERNATE_IIOP_ADDRESS
    org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java .
    TAG_CODE_SETS
    org/omg/IOP/TAG_CODE_SETS.java .
    TAG_INTERNET_IOP
    org/omg/IOP/TAG_INTERNET_IOP.java .
    TAG_JAVA_CODEBASE
    org/omg/IOP/TAG_JAVA_CODEBASE.java .
    TAG_MULTIPLE_COMPONENTS
    org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java .
    TAG_ORB_TYPE
    org/omg/IOP/TAG_ORB_TYPE.java .
    TAG_POLICIES
    org/omg/IOP/TAG_POLICIES.java .
    TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java .
    TransactionService
    org/omg/IOP/TransactionService.java .
  • Class Summary
    Class Description
    CodecFactoryHelper
    Codecs are obtained from the CodecFactory.
    ComponentIdHelper
    Standard way of representing multicomponent profiles.
    Encoding
    org/omg/IOP/Encoding.java .
    IOR
    org/omg/IOP/IOR.java .
    IORHelper
    org/omg/IOP/IORHelper.java .
    IORHolder
    org/omg/IOP/IORHolder.java .
    MultipleComponentProfileHelper
    An array of tagged components, forming a multiple component profile.
    MultipleComponentProfileHolder
    An array of tagged components, forming a multiple component profile.
    ProfileIdHelper
    Profile ID
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    ServiceContextHelper
    org/omg/IOP/ServiceContextHelper.java .
    ServiceContextHolder
    org/omg/IOP/ServiceContextHolder.java .
    ServiceContextListHelper
    An array of service contexts, forming a service context list.
    ServiceContextListHolder
    An array of service contexts, forming a service context list.
    ServiceIdHelper
    A service id, represented as an int
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedComponentHelper
    org/omg/IOP/TaggedComponentHelper.java .
    TaggedComponentHolder
    org/omg/IOP/TaggedComponentHolder.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
    TaggedProfileHelper
    org/omg/IOP/TaggedProfileHelper.java .
    TaggedProfileHolder
    org/omg/IOP/TaggedProfileHolder.java .

Package org.omg.IOP Description

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the IOP module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.IOP Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.IOP

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper
    • org.omg.IOP.ComponentIdHelper
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ProfileIdHelper
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceIdHelper
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)

Interface Hierarchy

  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.omg.IOP.ExceptionDetailMessage
  • org.omg.CORBA.Object
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • org.omg.IOP.TransactionService
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.IOP (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.IOP

  • Packages that use org.omg.IOP
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.IOP used by org.omg.IOP
    Class and Description
    Codec
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodecFactory
    Codecs are obtained from the CodecFactory.
    CodecFactoryOperations
    Codecs are obtained from the CodecFactory.
    CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    Encoding
    org/omg/IOP/Encoding.java .
    IOR
    org/omg/IOP/IOR.java .
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
  • Classes in org.omg.IOP used by org.omg.PortableInterceptor
    Class and Description
    CodecFactory
    Codecs are obtained from the CodecFactory.
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ProfileIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ProfileIdHelper

  • java.lang.Object
    • org.omg.IOP.ProfileIdHelper

  • public abstract class ProfileIdHelper
extends Object
    Profile ID

    • Constructor Summary

      Constructors
      Constructor and Description
      ProfileIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ProfileIdHelper

        public ProfileIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RMICustomMaxStreamFormat (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface RMICustomMaxStreamFormat

  • public interface RMICustomMaxStreamFormat
    org/omg/IOP/RMICustomMaxStreamFormat.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version.

    • Field Detail

      • value

        static final int value
        Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version. See Java to IDL ptc/02-01-12 1.4.12.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContext

  • java.lang.Object
    • org.omg.IOP.ServiceContext
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServiceContext
extends Object
implements IDLEntity
    org/omg/IOP/ServiceContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] context_data
      The data associated with this service context
      int context_id
      The service context id

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContext()
      ServiceContext(int _context_id, byte[] _context_data)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • context_id

        public int context_id
        The service context id

      • context_data

        public byte[] context_data
        The data associated with this service context

    • Constructor Detail

      • ServiceContext

        public ServiceContext()

      • ServiceContext

        public ServiceContext(int _context_id,
                      byte[] _context_data)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceContextHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextHelper

  • java.lang.Object
    • org.omg.IOP.ServiceContextHelper

  • public abstract class ServiceContextHelper
extends Object
    org/omg/IOP/ServiceContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServiceContext | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceContext that)
      static ServiceContext | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServiceContext value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceContextHelper

        public ServiceContextHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServiceContext that)

      • extract

        public static ServiceContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServiceContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServiceContext value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceContextHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextHolder

  • java.lang.Object
    • org.omg.IOP.ServiceContextHolder
  • All Implemented Interfaces:
    Streamable

    public final class ServiceContextHolder
extends Object
implements Streamable
    org/omg/IOP/ServiceContextHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ServiceContext value

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextHolder()
      ServiceContextHolder(ServiceContext initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ServiceContext value

    • Constructor Detail

      • ServiceContextHolder

        public ServiceContextHolder()

      • ServiceContextHolder

        public ServiceContextHolder(ServiceContext initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceContextListHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextListHelper

  • java.lang.Object
    • org.omg.IOP.ServiceContextListHelper

  • public abstract class ServiceContextListHelper
extends Object
    An array of service contexts, forming a service context list.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextListHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServiceContext[] | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceContext[] that)
      static ServiceContext[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServiceContext[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceContextListHelper

        public ServiceContextListHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServiceContext[] that)

      • extract

        public static ServiceContext[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServiceContext[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServiceContext[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceContextListHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextListHolder

  • java.lang.Object
    • org.omg.IOP.ServiceContextListHolder
  • All Implemented Interfaces:
    Streamable

    public final class ServiceContextListHolder
extends Object
implements Streamable
    An array of service contexts, forming a service context list.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ServiceContext[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextListHolder()
      ServiceContextListHolder(ServiceContext[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ServiceContext[] value

    • Constructor Detail

      • ServiceContextListHolder

        public ServiceContextListHolder()

      • ServiceContextListHolder

        public ServiceContextListHolder(ServiceContext[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServiceIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceIdHelper

  • java.lang.Object
    • org.omg.IOP.ServiceIdHelper

  • public abstract class ServiceIdHelper
extends Object
    A service id, represented as an int

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceIdHelper

        public ServiceIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TaggedComponent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedComponent

  • java.lang.Object
    • org.omg.IOP.TaggedComponent
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TaggedComponent
extends Object
implements IDLEntity
    org/omg/IOP/TaggedComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] component_data
      The component data associated with the component id.
      int tag
      The tag, represented as a component id.

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedComponent()
      TaggedComponent(int _tag, byte[] _component_data)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • tag

        public int tag
        The tag, represented as a component id.

      • component_data

        public byte[] component_data
        The component data associated with the component id.

    • Constructor Detail

      • TaggedComponent

        public TaggedComponent()

      • TaggedComponent

        public TaggedComponent(int _tag,
                       byte[] _component_data)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TaggedComponentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedComponentHelper

  • java.lang.Object
    • org.omg.IOP.TaggedComponentHelper

  • public abstract class TaggedComponentHelper
extends Object
    org/omg/IOP/TaggedComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedComponentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TaggedComponent | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedComponent that)
      static TaggedComponent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedComponent value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TaggedComponentHelper

        public TaggedComponentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TaggedComponent that)

      • extract

        public static TaggedComponent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedComponent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TaggedComponent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TaggedComponentHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedComponentHolder

  • java.lang.Object
    • org.omg.IOP.TaggedComponentHolder
  • All Implemented Interfaces:
    Streamable

    public final class TaggedComponentHolder
extends Object
implements Streamable
    org/omg/IOP/TaggedComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedComponent value

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedComponentHolder()
      TaggedComponentHolder(TaggedComponent initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TaggedComponent value

    • Constructor Detail

      • TaggedComponentHolder

        public TaggedComponentHolder()

      • TaggedComponentHolder

        public TaggedComponentHolder(TaggedComponent initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TaggedProfile (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedProfile

  • java.lang.Object
    • org.omg.IOP.TaggedProfile
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TaggedProfile
extends Object
implements IDLEntity
    org/omg/IOP/TaggedProfile.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] profile_data
      The associated profile data.
      int tag
      The tag, represented as a profile id.

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedProfile()
      TaggedProfile(int _tag, byte[] _profile_data)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • tag

        public int tag
        The tag, represented as a profile id.

      • profile_data

        public byte[] profile_data
        The associated profile data.

    • Constructor Detail

      • TaggedProfile

        public TaggedProfile()

      • TaggedProfile

        public TaggedProfile(int _tag,
                     byte[] _profile_data)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TaggedProfileHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedProfileHelper

  • java.lang.Object
    • org.omg.IOP.TaggedProfileHelper

  • public abstract class TaggedProfileHelper
extends Object
    org/omg/IOP/TaggedProfileHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedProfileHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TaggedProfile | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedProfile that)
      static TaggedProfile | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedProfile value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TaggedProfileHelper

        public TaggedProfileHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TaggedProfile that)

      • extract

        public static TaggedProfile extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedProfile read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TaggedProfile value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TaggedProfileHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedProfileHolder

  • java.lang.Object
    • org.omg.IOP.TaggedProfileHolder
  • All Implemented Interfaces:
    Streamable

    public final class TaggedProfileHolder
extends Object
implements Streamable
    org/omg/IOP/TaggedProfileHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedProfile value

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedProfileHolder()
      TaggedProfileHolder(TaggedProfile initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TaggedProfile value

    • Constructor Detail

      • TaggedProfileHolder

        public TaggedProfileHolder()

      • TaggedProfileHolder

        public TaggedProfileHolder(TaggedProfile initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_ALTERNATE_IIOP_ADDRESS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_ALTERNATE_IIOP_ADDRESS

  • public interface TAG_ALTERNATE_IIOP_ADDRESS
    org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

    • Field Detail

      • value

        static final int value
        In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

        The TAG_ALTERNATE_IIOP_ADDRESS component has an associated value of type:

             struct {
         string HostID,
         short Port
     };
        encoded as a CDR encapsulation.

        Zero or more instances of the TAG_ALTERNATE_IIOP_ADDRESS component type may be included in a version 1.2 TAG_INTERNET_IOP Profile. Each of these alternative addresses may be used by the client orb, in addition to the host and port address expressed in the body of the Profile. In cases where one or more TAG_ALTERNATE_IIOP_ADDRESS components are present in a TAG_INTERNET_IOP Profile, no order of use is prescribed by Version 1.2 of IIOP.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_CODE_SETS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_CODE_SETS

  • public interface TAG_CODE_SETS
    org/omg/IOP/TAG_CODE_SETS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The code set component of the IOR multi-component profile structure contains: server's native char code set and conversion code sets, and server's native wchar code set and conversion code sets. Both char and wchar conversion code sets are listed in order of preference.

    • Field Detail

      • value

        static final int value
        The code set component of the IOR multi-component profile structure contains:
        • server's native char code set and conversion code sets, and
        • server's native wchar code set and conversion code sets.
        Both char and wchar conversion code sets are listed in order of preference.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_INTERNET_IOP (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_INTERNET_IOP

  • public interface TAG_INTERNET_IOP
    org/omg/IOP/TAG_INTERNET_IOP.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies profiles that support the Internet Inter-ORB Protocol.

    • Field Detail

      • value

        static final int value
        Identifies profiles that support the Internet Inter-ORB Protocol. The ProfileBody of this profile contains a CDR encapsulation of a structure containing addressing and object identification information used by IIOP. Version 1.1 of the TAG_INTERNET_IOP profile also includes an array of TaggedComponent objects that can contain additional information supporting optional IIOP features, ORB services such as security, and future protocol extensions.

        Protocols other than IIOP (such as ESIOPs and other GIOPs) can share profile information (such as object identity or security information) with IIOP by encoding their additional profile information as components in the TAG_INTERNET_IOP profile. All TAG_INTERNET_IOP profiles support IIOP, regardless of whether they also support additional protocols. Interoperable ORBs are not required to create or understand any other profile, nor are they required to create or understand any of the components defined for other protocols that might share the TAG_INTERNET_IOP profile with IIOP.

        The profile_data for the TAG_INTERNET_IOP profile is a CDR encapsulation of the IIOP.ProfileBody_1_1 type.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_JAVA_CODEBASE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_JAVA_CODEBASE

  • public interface TAG_JAVA_CODEBASE
    org/omg/IOP/TAG_JAVA_CODEBASE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Class downloading is supported for stubs, ties, values, and value helpers.

    • Field Detail

      • value

        static final int value
        Class downloading is supported for stubs, ties, values, and value helpers. The specification allows transmission of codebase information on the wire for stubs and ties, and enables usage of pre-existing ClassLoaders when relevant.

        For values and value helpers, the codebase is transmitted after the value tag. For stubs and ties, the codebase is transmitted as the TaggedComponent TAG_JAVA_CODEBASE in the IOR profile, where the component_data is a CDR encapsulation of the codebase written as an IDL string. The codebase is a space-separated list of one or more URLs.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_MULTIPLE_COMPONENTS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_MULTIPLE_COMPONENTS

  • public interface TAG_MULTIPLE_COMPONENTS
    org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Indicates that the value encapsulated is of type MultipleComponentProfile.

    • Field Detail

      • value

        static final int value
        Indicates that the value encapsulated is of type MultipleComponentProfile. In this case, the profile consists of a list of protocol components, the use of which must be specified by the protocol using this profile. This profile may be used to carry IOR components.

        The profile_data for the TAG_MULTIPLE_COMPONENTS profile is a CDR encapsulation of the MultipleComponentProfile type shown above.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_ORB_TYPE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_ORB_TYPE

  • public interface TAG_ORB_TYPE
    org/omg/IOP/TAG_ORB_TYPE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

    • Field Detail

      • value

        static final int value
        It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

        The TAG_ORB_TYPE component has an associated value of type unsigned long (Java long), encoded as a CDR encapsulation, designating an ORB type ID allocated by the OMG for the ORB type of the originating ORB. Anyone may register any ORB types by submitting a short (one-paragraph) description of the ORB type to the OMG, and will receive a new ORB type ID in return. A list of ORB type descriptions and values will be made available on the OMG web server.

        The TAG_ORB_TYPE component can appear at most once in any IOR profile. For profiles supporting IIOP 1.1 or greater, it is optionally present.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_POLICIES (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_POLICIES

  • public interface TAG_POLICIES
    org/omg/IOP/TAG_POLICIES.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.

    • Field Detail

      • value

        static final int value
        A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TAG_RMI_CUSTOM_MAX_STREAM_FORMAT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

  • public interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      RMI-IIOP has multiple stream format versions.

    • Field Detail

      • value

        static final int value
        RMI-IIOP has multiple stream format versions. A server can specify its maximum version by including the TAG_RMI_CUSTOM_MAX_STREAM_FORMAT tagged component or rely on the default of version 1 for GIOP 1.2 and less and version 2 for GIOP 1.3 and higher. See Java to IDL ptc/02-01-12 1.4.11.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TransactionService (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TransactionService

  • public interface TransactionService
    org/omg/IOP/TransactionService.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.

    • Field Detail

      • value

        static final int value
        Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.Codec (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.Codec

  • Packages that use Codec
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of Codec in org.omg.IOP

      Methods in org.omg.IOP that return Codec
      Modifier and Type Method and Description
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.CodecFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodecFactory

  • Packages that use CodecFactory
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of CodecFactory in org.omg.IOP

      Methods in org.omg.IOP that return CodecFactory
      Modifier and Type | Method and Description
      static CodecFactory | CodecFactoryHelper.extract(Any a)
      static CodecFactory | CodecFactoryHelper.narrow(Object obj)
      static CodecFactory | CodecFactoryHelper.read(InputStream istream)
      static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)
      Methods in org.omg.IOP with parameters of type CodecFactory
      Modifier and Type | Method and Description
      static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
      static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)

    • Uses of CodecFactory in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return CodecFactory
      Modifier and Type Method and Description
      CodecFactory ORBInitInfoOperations.codec_factory()
      Returns the IOP.CodecFactory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecFactoryHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecFactoryHelper

No usage of org.omg.IOP.CodecFactoryHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.CodecFactoryOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodecFactoryOperations

  • Packages that use CodecFactoryOperations
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of CodecFactoryOperations in org.omg.IOP

      Subinterfaces of CodecFactoryOperations in org.omg.IOP
      Modifier and Type Interface and Description
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.CodecOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodecOperations

  • Packages that use CodecOperations
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of CodecOperations in org.omg.IOP

      Subinterfaces of CodecOperations in org.omg.IOP
      Modifier and Type Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.CodeSets (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodeSets

No usage of org.omg.IOP.CodeSets
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ComponentIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ComponentIdHelper

No usage of org.omg.IOP.ComponentIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.Encoding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.Encoding

  • Packages that use Encoding
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of Encoding in org.omg.IOP

      Methods in org.omg.IOP with parameters of type Encoding
      Modifier and Type Method and Description
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.ENCODING_CDR_ENCAPS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.ENCODING_CDR_ENCAPS

No usage of org.omg.IOP.ENCODING_CDR_ENCAPS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.ExceptionDetailMessage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.ExceptionDetailMessage

No usage of org.omg.IOP.ExceptionDetailMessage
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.IOR (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.IOR

  • Packages that use IOR
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of IOR in org.omg.IOP

      Fields in org.omg.IOP declared as IOR
      Modifier and Type | Field and Description
      IOR | IORHolder.value
      Methods in org.omg.IOP that return IOR
      Modifier and Type | Method and Description
      static IOR | IORHelper.extract(Any a)
      static IOR | IORHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type IOR
      Modifier and Type | Method and Description
      static void | IORHelper.insert(Any a, IOR that)
      static void | IORHelper.write(OutputStream ostream, IOR value)
      Constructors in org.omg.IOP with parameters of type IOR
      Constructor and Description
      IORHolder(IOR initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.IORHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.IORHelper

No usage of org.omg.IOP.IORHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.IORHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.IORHolder

No usage of org.omg.IOP.IORHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.MultipleComponentProfileHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.MultipleComponentProfileHelper

No usage of org.omg.IOP.MultipleComponentProfileHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.MultipleComponentProfileHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.MultipleComponentProfileHolder

No usage of org.omg.IOP.MultipleComponentProfileHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ProfileIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ProfileIdHelper

No usage of org.omg.IOP.ProfileIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.RMICustomMaxStreamFormat (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.RMICustomMaxStreamFormat

No usage of org.omg.IOP.RMICustomMaxStreamFormat
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ServiceContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContext

  • Packages that use ServiceContext
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServiceContext in org.omg.IOP

      Fields in org.omg.IOP declared as ServiceContext
      Modifier and Type | Field and Description
      ServiceContext | ServiceContextHolder.value
      ServiceContext[] | ServiceContextListHolder.value
      Methods in org.omg.IOP that return ServiceContext
      Modifier and Type | Method and Description
      static ServiceContext | ServiceContextHelper.extract(Any a)
      static ServiceContext[] | ServiceContextListHelper.extract(Any a)
      static ServiceContext | ServiceContextHelper.read(InputStream istream)
      static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type ServiceContext
      Modifier and Type | Method and Description
      static void | ServiceContextHelper.insert(Any a, ServiceContext that)
      static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
      static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
      static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
      Constructors in org.omg.IOP with parameters of type ServiceContext
      Constructor and Description
      ServiceContextHolder(ServiceContext initialValue)
      ServiceContextListHolder(ServiceContext[] initialValue)

    • Uses of ServiceContext in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return ServiceContext
      Modifier and Type Method and Description
      ServiceContext RequestInfoOperations.get_reply_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the reply.
      ServiceContext RequestInfoOperations.get_request_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the request.
      Methods in org.omg.PortableInterceptor with parameters of type ServiceContext
      Modifier and Type Method and Description
      void ServerRequestInfoOperations.add_reply_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      void ClientRequestInfoOperations.add_request_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ServiceContextHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextHelper

No usage of org.omg.IOP.ServiceContextHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ServiceContextHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextHolder

No usage of org.omg.IOP.ServiceContextHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ServiceContextListHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextListHelper

No usage of org.omg.IOP.ServiceContextListHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ServiceContextListHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextListHolder

No usage of org.omg.IOP.ServiceContextListHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.ServiceIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceIdHelper

No usage of org.omg.IOP.ServiceIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.TaggedComponent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedComponent

  • Packages that use TaggedComponent
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of TaggedComponent in org.omg.IOP

      Fields in org.omg.IOP declared as TaggedComponent
      Modifier and Type | Field and Description
      TaggedComponent | TaggedComponentHolder.value
      TaggedComponent[] | MultipleComponentProfileHolder.value
      Methods in org.omg.IOP that return TaggedComponent
      Modifier and Type | Method and Description
      static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
      static TaggedComponent | TaggedComponentHelper.extract(Any a)
      static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
      static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type TaggedComponent
      Modifier and Type | Method and Description
      static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
      static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
      static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
      static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
      Constructors in org.omg.IOP with parameters of type TaggedComponent
      Constructor and Description
      MultipleComponentProfileHolder(TaggedComponent[] initialValue)
      TaggedComponentHolder(TaggedComponent initialValue)

    • Uses of TaggedComponent in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TaggedComponent
      Modifier and Type Method and Description
      TaggedComponent ClientRequestInfoOperations.get_effective_component(int id)
      Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
      TaggedComponent[] ClientRequestInfoOperations.get_effective_components(int id)
      Returns an array of all tagged components with the given ID from the profile selected for this request.
      Methods in org.omg.PortableInterceptor with parameters of type TaggedComponent
      Modifier and Type Method and Description
      void IORInfoOperations.add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id)
      A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      void IORInfoOperations.add_ior_component(TaggedComponent tagged_component)
      A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.TaggedComponentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedComponentHelper

No usage of org.omg.IOP.TaggedComponentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.TaggedComponentHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedComponentHolder

No usage of org.omg.IOP.TaggedComponentHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.TaggedProfile (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedProfile

  • Packages that use TaggedProfile
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of TaggedProfile in org.omg.IOP

      Fields in org.omg.IOP declared as TaggedProfile
      Modifier and Type | Field and Description
      TaggedProfile[] IOR.profiles
      An array of tagged profiles associated with this object reference.
      TaggedProfile | TaggedProfileHolder.value
      Methods in org.omg.IOP that return TaggedProfile
      Modifier and Type | Method and Description
      static TaggedProfile | TaggedProfileHelper.extract(Any a)
      static TaggedProfile | TaggedProfileHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type TaggedProfile
      Modifier and Type | Method and Description
      static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)
      static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)
      Constructors in org.omg.IOP with parameters of type TaggedProfile
      Constructor and Description
      IOR(String _type_id, TaggedProfile[] _profiles)
      TaggedProfileHolder(TaggedProfile initialValue)

    • Uses of TaggedProfile in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TaggedProfile
      Modifier and Type Method and Description
      TaggedProfile ClientRequestInfoOperations.effective_profile()
      Returns the profile that will be used to send the request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.TaggedProfileHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedProfileHelper

No usage of org.omg.IOP.TaggedProfileHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.TaggedProfileHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedProfileHolder

No usage of org.omg.IOP.TaggedProfileHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS

No usage of org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_CODE_SETS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_CODE_SETS

No usage of org.omg.IOP.TAG_CODE_SETS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_INTERNET_IOP (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_INTERNET_IOP

No usage of org.omg.IOP.TAG_INTERNET_IOP
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_JAVA_CODEBASE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_JAVA_CODEBASE

No usage of org.omg.IOP.TAG_JAVA_CODEBASE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_MULTIPLE_COMPONENTS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_MULTIPLE_COMPONENTS

No usage of org.omg.IOP.TAG_MULTIPLE_COMPONENTS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_ORB_TYPE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_ORB_TYPE

No usage of org.omg.IOP.TAG_ORB_TYPE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_POLICIES (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_POLICIES

No usage of org.omg.IOP.TAG_POLICIES
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

No usage of org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.IOP.TransactionService (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TransactionService

No usage of org.omg.IOP.TransactionService
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.IOP.CodecFactoryPackage (Java Platform SE 8 )

org.omg.IOP.CodecFactoryPackage

Classes

  • UnknownEncodingHelper

Exceptions

  • UnknownEncoding


org.omg.IOP.CodecFactoryPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.IOP.CodecFactoryPackage

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

See: Description

  • Class Summary
    Class Description
    UnknownEncodingHelper
    org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java .
  • Exception Summary
    Exception Description
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

Package org.omg.IOP.CodecFactoryPackage Description

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.IOP.CodecFactoryPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.IOP.CodecFactoryPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.IOP.CodecFactoryPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.IOP.CodecFactoryPackage

  • Packages that use org.omg.IOP.CodecFactoryPackage
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
  • Classes in org.omg.IOP.CodecFactoryPackage used by org.omg.IOP
    Class and Description
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
  • Classes in org.omg.IOP.CodecFactoryPackage used by org.omg.IOP.CodecFactoryPackage
    Class and Description
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnknownEncoding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecFactoryPackage

Class UnknownEncoding

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class UnknownEncoding
extends UserException
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownEncoding()
      UnknownEncoding(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnknownEncoding

        public UnknownEncoding()

      • UnknownEncoding

        public UnknownEncoding(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UnknownEncodingHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecFactoryPackage

Class UnknownEncodingHelper

  • java.lang.Object
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

  • public abstract class UnknownEncodingHelper
extends Object
    org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownEncodingHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static UnknownEncoding | extract(Any a)
      static String | id()
      static void | insert(Any a, UnknownEncoding that)
      static UnknownEncoding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnknownEncoding value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UnknownEncodingHelper

        public UnknownEncodingHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          UnknownEncoding that)

      • extract

        public static UnknownEncoding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnknownEncoding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         UnknownEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecFactoryPackage.UnknownEncoding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecFactoryPackage.UnknownEncoding

  • Packages that use UnknownEncoding
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

    • Uses of UnknownEncoding in org.omg.IOP

      Methods in org.omg.IOP that throw UnknownEncoding
      Modifier and Type Method and Description
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.

    • Uses of UnknownEncoding in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage that return UnknownEncoding
      Modifier and Type | Method and Description
      static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
      static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type UnknownEncoding
      Modifier and Type | Method and Description
      static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)
      static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

No usage of org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FormatMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class FormatMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.FormatMismatch
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class FormatMismatch
extends UserException
    org/omg/IOP/CodecPackage/FormatMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      FormatMismatch()
      FormatMismatch(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FormatMismatch

        public FormatMismatch()

      • FormatMismatch

        public FormatMismatch(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


FormatMismatchHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class FormatMismatchHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper

  • public abstract class FormatMismatchHelper
extends Object
    org/omg/IOP/CodecPackage/FormatMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      FormatMismatchHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static FormatMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, FormatMismatch that)
      static FormatMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, FormatMismatch value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FormatMismatchHelper

        public FormatMismatchHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          FormatMismatch that)

      • extract

        public static FormatMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static FormatMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         FormatMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidTypeForEncoding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class InvalidTypeForEncoding

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidTypeForEncoding
extends UserException
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidTypeForEncoding()
      InvalidTypeForEncoding(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidTypeForEncoding

        public InvalidTypeForEncoding()

      • InvalidTypeForEncoding

        public InvalidTypeForEncoding(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidTypeForEncodingHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class InvalidTypeForEncodingHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

  • public abstract class InvalidTypeForEncodingHelper
extends Object
    org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidTypeForEncodingHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidTypeForEncoding | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidTypeForEncoding that)
      static InvalidTypeForEncoding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidTypeForEncoding value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidTypeForEncodingHelper

        public InvalidTypeForEncodingHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidTypeForEncoding that)

      • extract

        public static InvalidTypeForEncoding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidTypeForEncoding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidTypeForEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.IOP.CodecPackage (Java Platform SE 8 )

org.omg.IOP.CodecPackage

Classes

  • FormatMismatchHelper
  • InvalidTypeForEncodingHelper
  • TypeMismatchHelper

Exceptions

  • FormatMismatch
  • InvalidTypeForEncoding
  • TypeMismatch


org.omg.IOP.CodecPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.IOP.CodecPackage

This package is generated from the IOP::Codec IDL interface definition.

See: Description

  • Class Summary
    Class Description
    FormatMismatchHelper
    org/omg/IOP/CodecPackage/FormatMismatchHelper.java .
    InvalidTypeForEncodingHelper
    org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java .
    TypeMismatchHelper
    org/omg/IOP/CodecPackage/TypeMismatchHelper.java .
  • Exception Summary
    Exception Description
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .

Package org.omg.IOP.CodecPackage Description

This package is generated from the IOP::Codec IDL interface definition. It contains the Java representations of the IDL exceptions specified in IOP::Codec (as part of the Portable Interceptors specification). Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.IOP.CodecPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.IOP.CodecPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.IOP.CodecPackage.TypeMismatch
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.IOP.CodecPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.IOP.CodecPackage

  • Packages that use org.omg.IOP.CodecPackage
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
  • Classes in org.omg.IOP.CodecPackage used by org.omg.IOP
    Class and Description
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .
  • Classes in org.omg.IOP.CodecPackage used by org.omg.IOP.CodecPackage
    Class and Description
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.TypeMismatch
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    org/omg/IOP/CodecPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatch()
      TypeMismatch(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeMismatch

        public TypeMismatch()

      • TypeMismatch

        public TypeMismatch(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeMismatchHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class TypeMismatchHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.TypeMismatchHelper

  • public abstract class TypeMismatchHelper
extends Object
    org/omg/IOP/CodecPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatchHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TypeMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, TypeMismatch that)
      static TypeMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TypeMismatch value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TypeMismatchHelper

        public TypeMismatchHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TypeMismatch that)

      • extract

        public static TypeMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TypeMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TypeMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecPackage.FormatMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.FormatMismatch

  • Packages that use FormatMismatch
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of FormatMismatch in org.omg.IOP

      Methods in org.omg.IOP that throw FormatMismatch
      Modifier and Type Method and Description
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any CodecOperations.decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.

    • Uses of FormatMismatch in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return FormatMismatch
      Modifier and Type | Method and Description
      static FormatMismatch | FormatMismatchHelper.extract(Any a)
      static FormatMismatch | FormatMismatchHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type FormatMismatch
      Modifier and Type | Method and Description
      static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
      static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecPackage.FormatMismatchHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.FormatMismatchHelper

No usage of org.omg.IOP.CodecPackage.FormatMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecPackage.InvalidTypeForEncoding (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.InvalidTypeForEncoding

  • Packages that use InvalidTypeForEncoding
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of InvalidTypeForEncoding in org.omg.IOP

      Methods in org.omg.IOP that throw InvalidTypeForEncoding
      Modifier and Type Method and Description
      byte[] CodecOperations.encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] CodecOperations.encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.

    • Uses of InvalidTypeForEncoding in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return InvalidTypeForEncoding
      Modifier and Type | Method and Description
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type InvalidTypeForEncoding
      Modifier and Type | Method and Description
      static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
      static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

No usage of org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecPackage.TypeMismatch (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.TypeMismatch

  • Packages that use TypeMismatch
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of TypeMismatch in org.omg.IOP

      Methods in org.omg.IOP that throw TypeMismatch
      Modifier and Type Method and Description
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.

    • Uses of TypeMismatch in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return TypeMismatch
      Modifier and Type | Method and Description
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type TypeMismatch
      Modifier and Type | Method and Description
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.IOP.CodecPackage.TypeMismatchHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.TypeMismatchHelper

No usage of org.omg.IOP.CodecPackage.TypeMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.Messaging (Java Platform SE 8 )

org.omg.Messaging

Interfaces

  • SYNC_WITH_TRANSPORT

Classes

  • SyncScopeHelper


org.omg.Messaging (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.Messaging

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.

See: Description

  • Interface Summary
    Interface Description
    SYNC_WITH_TRANSPORT
    org/omg/Messaging/SYNC_WITH_TRANSPORT.java .
  • Class Summary
    Class Description
    SyncScopeHelper
    Synchronization scope

Package org.omg.Messaging Description

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the Messaging module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.Messaging Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.Messaging

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

Interface Hierarchy

  • org.omg.Messaging.SYNC_WITH_TRANSPORT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.Messaging (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.Messaging

No usage of org.omg.Messaging
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SyncScopeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.Messaging

Class SyncScopeHelper

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

  • public abstract class SyncScopeHelper
extends Object
    Synchronization scope

    • Constructor Summary

      Constructors
      Constructor and Description
      SyncScopeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SyncScopeHelper

        public SyncScopeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SYNC_WITH_TRANSPORT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.Messaging

Interface SYNC_WITH_TRANSPORT

  • public interface SYNC_WITH_TRANSPORT
    org/omg/Messaging/SYNC_WITH_TRANSPORT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Messaging.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.

    • Field Detail

      • value

        static final short value
        Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.Messaging.SyncScopeHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.Messaging.SyncScopeHelper

No usage of org.omg.Messaging.SyncScopeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.Messaging.SYNC_WITH_TRANSPORT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.Messaging.SYNC_WITH_TRANSPORT

No usage of org.omg.Messaging.SYNC_WITH_TRANSPORT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ACTIVE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ACTIVE

  • public interface ACTIVE
    org/omg/PortableInterceptor/ACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that indicates normal request processing.

    • Field Detail

      • value

        static final short value
        Object adapter state that indicates normal request processing.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterManagerIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class AdapterManagerIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper

  • public abstract class AdapterManagerIdHelper
extends Object
    Adapter manager identifier. Every object adapter has an adapter manager, indicated in this API only through the ID. A group of object adapter instances may share the same adapter manager, in which case state transitions reported for the adapter manager are observed by all object adapters with the same adapter manager ID.

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterManagerIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterManagerIdHelper

        public AdapterManagerIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class AdapterNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterNameHelper

  • public abstract class AdapterNameHelper
extends Object
    The name of an object adapter. This is unique only within the scope of the ORB that created the object adapter.

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterNameHelper

        public AdapterNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterStateHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class AdapterStateHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterStateHelper

  • public abstract class AdapterStateHelper
extends Object
    Type of object adapter state. State changes are reported either to the object adapter or to the adapter manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterStateHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterStateHelper

        public AdapterStateHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ClientRequestInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInfo

  • All Superinterfaces:
    ClientRequestInfoOperations, IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable

    public interface ClientRequestInfo
extends ClientRequestInfoOperations, RequestInfo, IDLEntity
    Request Information, accessible to client-side request interceptors.

    Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    send_request send_poll receive_reply receive_exception receive_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             yes1 no yes no no

    exceptions

             yes no yes yes yes

    contexts

             yes no yes yes yes

    operation_context

             yes no yes yes yes

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes no yes yes yes

    reply_status

             no no yes yes yes

    forward_reference

             no no no no yes2

    get_slot

             yes yes yes yes yes

    get_request_service_context

             yes no yes yes yes

    get_reply_service_context

             no no yes yes yes
    ClientRequestInfo-specific:

    target

             yes yes yes yes yes

    effective_target

             yes yes yes yes yes

    effective_profile

             yes yes yes yes yes

    received_exception

             no no no yes no

    received_exception_id

             no no no yes no

    get_effective_component

             yes no yes yes yes

    get_effective_components

             yes no yes yes yes

    get_request_policy

             yes no yes yes yes

    add_request_service_context

             yes no no no no
    1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    See Also:
    ClientRequestInterceptor

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ClientRequestInfoOperations

        add_request_service_context, effective_profile, effective_target, get_effective_component, get_effective_components, get_request_policy, received_exception_id, received_exception, target

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ClientRequestInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInfoOperations

  • All Superinterfaces:
    RequestInfoOperations
    All Known Subinterfaces:
    ClientRequestInfo

    public interface ClientRequestInfoOperations
extends RequestInfoOperations
    Request Information, accessible to client-side request interceptors.

    Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    send_request send_poll receive_reply receive_exception receive_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             yes1 no yes no no

    exceptions

             yes no yes yes yes

    contexts

             yes no yes yes yes

    operation_context

             yes no yes yes yes

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes no yes yes yes

    reply_status

             no no yes yes yes

    forward_reference

             no no no no yes2

    get_slot

             yes yes yes yes yes

    get_request_service_context

             yes no yes yes yes

    get_reply_service_context

             no no yes yes yes
    ClientRequestInfo-specific:

    target

             yes yes yes yes yes

    effective_target

             yes yes yes yes yes

    effective_profile

             yes yes yes yes yes

    received_exception

             no no no yes no

    received_exception_id

             no no no yes no

    get_effective_component

             yes no yes yes yes

    get_effective_components

             yes no yes yes yes

    get_request_policy

             yes no yes yes yes

    add_request_service_context

             yes no no no no
    1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    See Also:
    ClientRequestInterceptor

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add_request_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      TaggedProfile effective_profile()
      Returns the profile that will be used to send the request.
      Object effective_target()
      Returns the actual object on which the operation will be invoked.
      TaggedComponent get_effective_component(int id)
      Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
      TaggedComponent[] get_effective_components(int id)
      Returns an array of all tagged components with the given ID from the profile selected for this request.
      Policy get_request_policy(int type)
      Returns the given policy in effect for this operation.
      String received_exception_id()
      Returns the repository id of the exception to be returned to the client.
      Any received_exception()
      Returns an any which contains the exception to be returned to the client.
      Object target()
      Returns the object which the client called to perform the operation.

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

    • Method Detail

      • target

        Object target()
        Returns the object which the client called to perform the operation.
        See Also:
        effective_target()

      • effective_target

        Object effective_target()
        Returns the actual object on which the operation will be invoked. If the reply_status is LOCATION_FORWARD, then on subsequent requests, effective_target will contain the forwarded IOR while target will remain unchanged.
        See Also:
        target()

      • effective_profile

        TaggedProfile effective_profile()
        Returns the profile that will be used to send the request. If a location forward has occurred for this operation's object and that object's profile changed accordingly, then this profile will be that located profile.

      • received_exception

        Any received_exception()
        Returns an any which contains the exception to be returned to the client.

        If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don t provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1. However, the repository id of the exception is available in the received_exception_id attribute.

        See Also:
        received_exception_id()

      • received_exception_id

        String received_exception_id()
        Returns the repository id of the exception to be returned to the client.
        See Also:
        received_exception(), PortableInterceptor package comments for limitations / unimplemented features

      • get_effective_component

        TaggedComponent get_effective_component(int id)
        Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.

        If there is more than one component for a given component ID, it is undefined which component this operation returns. If there is more than one component for a given component ID, get_effective_components should be called instead.

        Parameters:
        id - The component id of the component which is to be returned.
        Returns:
        The IOP.TaggedComponent obtained with the given identifier.
        Throws:
        BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
        See Also:
        get_effective_components(int)

      • get_effective_components

        TaggedComponent[] get_effective_components(int id)
        Returns an array of all tagged components with the given ID from the profile selected for this request.
        Parameters:
        id - The component id of the components which are to be returned.
        Returns:
        An array of TaggedComponent objects, each of which contains the given identifier.
        Throws:
        BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
        See Also:
        get_effective_component(int)

      • get_request_policy

        Policy get_request_policy(int type)
        Returns the given policy in effect for this operation.
        Parameters:
        type - The policy type which specifies the policy to be returned.
        Returns:
        The CORBA.Policy obtained with the given type.
        Throws:
        INV_POLICY - thrown, with a standard minor code of 1, if the policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • add_request_service_context

        void add_request_service_context(ServiceContext service_context,
                                 boolean replace)
        Allows Interceptors to add service contexts to the request.

        There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

        Parameters:
        service_context - The IOP.ServiceContext to be added to the request.
        replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ClientRequestInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInterceptor

  • All Superinterfaces:
    ClientRequestInterceptorOperations, IDLEntity, Interceptor, InterceptorOperations, Object, Serializable

    public interface ClientRequestInterceptor
extends ClientRequestInterceptorOperations, Interceptor, IDLEntity
    Client-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

    See Also:
    ClientRequestInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations

        receive_exception, receive_other, receive_reply, send_poll, send_request

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ClientRequestInterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    ClientRequestInterceptor

    public interface ClientRequestInterceptorOperations
extends InterceptorOperations
    Client-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

    See Also:
    ClientRequestInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void receive_reply(ClientRequestInfo ri)
      Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
      void send_poll(ClientRequestInfo ri)
      Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
      void send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • send_request

        void send_request(ClientRequestInfo ri)
           throws ForwardRequest
        Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

        This interception point may throw a system exception. If it does, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called. This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_poll

        void send_poll(ClientRequestInfo ri)
        Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.

        With TII, an application may poll for a response to a request sent previously by the polling client or some other client. This poll is reported to Interceptors through the send_poll interception point and the response is returned through the receive_reply or receive_exception interception points. If the response is not available before the poll time-out expires, the system exception TIMEOUT is thrown and receive_exception is called with this exception.

        This interception point may throw a system exception. If it does, no other Interceptors' send_poll operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        TIMEOUT - thrown if the response is not available before the poll time-out expires

      • receive_reply

        void receive_reply(ClientRequestInfo ri)
        Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_reply operations are called. The remaining Interceptors in the Flow Stack shall have their receive_exception interception point called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

        Parameters:
        ri - Information about the current request being intercepted.

      • receive_exception

        void receive_exception(ClientRequestInfo ri)
                throws ForwardRequest
        Indicates to the interceptor that an exception occurred. Allows an Interceptor to query the exception's information before it is thrown to the client.

        This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to receive_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_exception operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_other interception point called.

        If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request s at-most-once semantics would be lost.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

        Under some conditions, depending on what policies are in effect, an exception (such as COMM_FAILURE) may result in a retry of the request. While this retry is a new request with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the PortableInterceptor.Current for both the original request and the retrying request is the same.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • receive_other

        void receive_other(ClientRequestInfo ri)
            throws ForwardRequest
        Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received); or on asynchronous calls, the reply does not immediately follow the request, but control shall return to the client and an ending interception point shall be called.

        For retries, depending on the policies in effect, a new request may or may not follow when a retry has been indicated. If a new request does follow, while this request is a new request, with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the request scoped PortableInterceptor.Current for both the original request and the retrying request is the same.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_other operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_exception interception point called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' receive_other operations are called with the new information provided by the ForwardRequest exception.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO. If the target invocation had completed, this interception point would not be called.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Current (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface Current

  • All Superinterfaces:
    Current, CurrentOperations, IDLEntity, Object, Serializable

    public interface Current
extends CurrentOperations, Current, IDLEntity
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.CurrentOperations

        get_slot, set_slot

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class CurrentHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • Constructor Summary

      Constructors
      Constructor and Description
      CurrentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static Current | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, Current value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CurrentHelper

        public CurrentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Current value)

      • narrow

        public static Current narrow(Object obj)

      • unchecked_narrow

        public static Current unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface CurrentOperations

  • All Superinterfaces:
    CurrentOperations
    All Known Subinterfaces:
    Current

    public interface CurrentOperations
extends CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Any get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      void set_slot(int id, Any data)
      Sets data in a slot.

    • Method Detail

      • get_slot

        Any get_slot(int id)
      throws InvalidSlot
        Retrieves the slot data the application set in PICurrent via get_slot. The data is in the form of an Any.

        If the given slot has not been set, an Any containing a type code with a TCKind value of tk_null and no value is returned.

        Parameters:
        id - The SlotId of the slot from which the data will be returned.
        Returns:
        The data, in the form of an Any, of the given slot identifier.
        Throws:
        InvalidSlot - thrown if get_slot is called on a slot that has not been allocated.
        BAD_INV_ORDER - thrown if get_slot is called from within an ORB initializer

      • set_slot

        void set_slot(int id,
              Any data)
       throws InvalidSlot
        Sets data in a slot. The data is in the form of an Any. If data already exists in that slot, it is overridden.
        Parameters:
        id - The SlotId of the slot to which the data will be set.
        data - The data, in the form of an Any, which will be set to the identified slot.
        Throws:
        InvalidSlot - thrown if set_slot is called on a slot that has not been allocated.
        BAD_INV_ORDER - thrown if set_slot is called from within an ORB initializer.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DISCARDING (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface DISCARDING

  • public interface DISCARDING
    org/omg/PortableInterceptor/DISCARDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that causes all requests to be discarded.

    • Field Detail

      • value

        static final short value
        Object adapter state that causes all requests to be discarded.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardRequest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ForwardRequest

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ForwardRequest
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ForwardRequest
extends UserException
    org/omg/PortableInterceptor/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object forward
      The new object to forward the request to.

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequest()
      ForwardRequest(Object _forward)
      ForwardRequest(String $reason, Object _forward)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • forward

        public Object forward
        The new object to forward the request to.

    • Constructor Detail

      • ForwardRequest

        public ForwardRequest()

      • ForwardRequest

        public ForwardRequest(Object _forward)

      • ForwardRequest

        public ForwardRequest(String $reason,
                      Object _forward)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardRequestHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ForwardRequestHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ForwardRequestHelper

  • public abstract class ForwardRequestHelper
extends Object
    org/omg/PortableInterceptor/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequestHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ForwardRequest | extract(Any a)
      static String | id()
      static void | insert(Any a, ForwardRequest that)
      static ForwardRequest | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ForwardRequest value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ForwardRequestHelper

        public ForwardRequestHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ForwardRequest that)

      • extract

        public static ForwardRequest extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ForwardRequest read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ForwardRequest value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HOLDING (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface HOLDING

  • public interface HOLDING
    org/omg/PortableInterceptor/HOLDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that holds requests temporarily until the state is changed.

    • Field Detail

      • value

        static final short value
        Object adapter state that holds requests temporarily until the state is changed.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


INACTIVE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface INACTIVE

  • public interface INACTIVE
    org/omg/PortableInterceptor/INACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that causes all requests to be discarded.

    • Field Detail

      • value

        static final short value
        Object adapter state that causes all requests to be discarded. This state indicates that the adapter is shutting down.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Interceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface Interceptor

  • All Superinterfaces:
    IDLEntity, InterceptorOperations, Object, Serializable
    All Known Subinterfaces:
    ClientRequestInterceptor, IORInterceptor, IORInterceptor_3_0, ServerRequestInterceptor

    public interface Interceptor
extends InterceptorOperations, Object, IDLEntity
    All Portable Interceptors implement Interceptor.

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface InterceptorOperations

  • All Known Subinterfaces:
    ClientRequestInterceptor, ClientRequestInterceptorOperations, Interceptor, IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations, IORInterceptorOperations, ServerRequestInterceptor, ServerRequestInterceptorOperations

    public interface InterceptorOperations
    All Portable Interceptors implement Interceptor.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void destroy()
      Provides an opportunity to destroy this interceptor.
      String name()
      Returns the name of the interceptor.

    • Method Detail

      • name

        String name()
        Returns the name of the interceptor.

        Each Interceptor may have a name that may be used administratively to order the lists of Interceptors. Only one Interceptor of a given name can be registered with the ORB for each Interceptor type. An Interceptor may be anonymous, i.e., have an empty string as the name attribute. Any number of anonymous Interceptors may be registered with the ORB.

        Returns:
        the name of the interceptor.

      • destroy

        void destroy()
        Provides an opportunity to destroy this interceptor. The destroy method is called during ORB.destroy. When an application calls ORB.destroy, the ORB:
        1. waits for all requests in progress to complete
        2. calls the Interceptor.destroy operation for each interceptor
        3. completes destruction of the ORB
        Method invocations from within Interceptor.destroy on object references for objects implemented on the ORB being destroyed result in undefined behavior. However, method invocations on objects implemented on an ORB other than the one being destroyed are permitted. (This means that the ORB being destroyed is still capable of acting as a client, but not as a server.)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidSlot (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class InvalidSlot

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.InvalidSlot
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidSlot
extends UserException
    org/omg/PortableInterceptor/InvalidSlot.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSlot()
      InvalidSlot(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidSlot

        public InvalidSlot()

      • InvalidSlot

        public InvalidSlot(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidSlotHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class InvalidSlotHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.InvalidSlotHelper

  • public abstract class InvalidSlotHelper
extends Object
    org/omg/PortableInterceptor/InvalidSlotHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSlotHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidSlot | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidSlot that)
      static InvalidSlot | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidSlot value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidSlotHelper

        public InvalidSlotHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidSlot that)

      • extract

        public static InvalidSlot extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidSlot read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidSlot value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInfo

  • All Superinterfaces:
    IDLEntity, IORInfoOperations, Object, Serializable

    public interface IORInfo
extends IORInfoOperations, Object, IDLEntity
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.
    See Also:
    IORInterceptor

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.IORInfoOperations

        adapter_template, add_ior_component_to_profile, add_ior_component, current_factory, current_factory, get_effective_policy, manager_id, state

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInfoOperations

  • All Known Subinterfaces:
    IORInfo

    public interface IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.
    See Also:
    IORInterceptor

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ObjectReferenceTemplate adapter_template()
      Return the object reference template of the object adapter that was just created and is running IOR interceptors.
      void add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id)
      A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      void add_ior_component(TaggedComponent tagged_component)
      A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      ObjectReferenceFactory current_factory()
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      void current_factory(ObjectReferenceFactory newCurrent_factory)
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      Policy get_effective_policy(int type)
      Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.
      int manager_id()
      Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.
      short state()
      Return the adapter state of the object adapter that was just created and is running IOR interceptors.

    • Method Detail

      • get_effective_policy

        Policy get_effective_policy(int type)
        Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed. When the IOR being constructed is for an object implemented using a POA, all Policy objects passed to the PortableServer.POA.create_POA call that created that POA are accessable via get_effective_policy.

        If a policy for the given type is not known to the ORB, then this operation will throw INV_POLICY with a standard minor code of 2.

        Parameters:
        type - an int specifying the type of policy to return.
        Returns:
        The effective CORBA.Policy object of the requested type. If the given policy type is known, but no policy of that type is in effect, then this operation will return a nil object reference.

      • add_ior_component

        void add_ior_component(TaggedComponent tagged_component)
        A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in all profiles.

        Any number of components may exist with the same component ID.

        Parameters:
        tagged_component - The IOP.TaggedComponent to add.

      • add_ior_component_to_profile

        void add_ior_component_to_profile(TaggedComponent tagged_component,
                                  int profile_id)
        A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in the specified profile.

        Any number of components may exist with the same component ID.

        Parameters:
        tagged_component - The IOP.TaggedComponent to add.
        profile_id - The profile id of the profile to which this component will be added.
        Throws:
        BAD_PARAM - thrown, with a standard minor code of 29, if the given profile ID does not define a known profile or it is impossible to add components to that profile.

      • manager_id

        int manager_id()
        Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.

      • state

        short state()
        Return the adapter state of the object adapter that was just created and is running IOR interceptors.

      • adapter_template

        ObjectReferenceTemplate adapter_template()
        Return the object reference template of the object adapter that was just created and is running IOR interceptors.

      • current_factory

        ObjectReferenceFactory current_factory()
        On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.

      • current_factory

        void current_factory(ObjectReferenceFactory newCurrent_factory)
        On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, IORInterceptorOperations, Object, Serializable
    All Known Subinterfaces:
    IORInterceptor_3_0

    public interface IORInterceptor
extends IORInterceptorOperations, Interceptor, IDLEntity
    Interceptor used to establish tagged components in the profiles within an IOR.

    In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

    This is supported through the IORInterceptor and IORInfo interfaces.

    See Also:
    IORInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations

    public interface IORInterceptorOperations
extends InterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.

    In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

    This is supported through the IORInterceptor and IORInfo interfaces.

    See Also:
    IORInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void establish_components(IORInfo info)
      A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • establish_components

        void establish_components(IORInfo info)
        A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference. This operation is not necessarily called for each individual object reference. In the case of the POA, this operation is called each time POA::create_POA is called. In any case, establish_components is guaranteed to be called at least once for each distinct set of server policies.

        An implementation of establish_components must not throw exceptions. If it does, the ORB shall ignore the exception and proceed to call the next IOR Interceptor's establish_components operation.

        Parameters:
        info - The IORInfo instance used by the ORB service to query applicable policies and add components to be included in the generated IORs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInterceptor_3_0 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor_3_0

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, IORInterceptor, IORInterceptor_3_0Operations, IORInterceptorOperations, Object, Serializable

    public interface IORInterceptor_3_0
extends IORInterceptor_3_0Operations, IORInterceptor, IDLEntity
    org/omg/PortableInterceptor/IORInterceptor_3_0.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations

        adapter_manager_state_changed, adapter_state_changed, components_established

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInterceptor_3_0Helper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class IORInterceptor_3_0Helper

  • java.lang.Object
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper

  • public abstract class IORInterceptor_3_0Helper
extends Object
    org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      IORInterceptor_3_0Helper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static IORInterceptor_3_0 | extract(Any a)
      static String | id()
      static void | insert(Any a, IORInterceptor_3_0 that)
      static IORInterceptor_3_0 | narrow(Object obj)
      static IORInterceptor_3_0 | read(InputStream istream)
      static TypeCode | type()
      static IORInterceptor_3_0 | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, IORInterceptor_3_0 value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IORInterceptor_3_0Helper

        public IORInterceptor_3_0Helper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          IORInterceptor_3_0 that)

      • extract

        public static IORInterceptor_3_0 extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IORInterceptor_3_0 read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         IORInterceptor_3_0 value)

      • narrow

        public static IORInterceptor_3_0 narrow(Object obj)

      • unchecked_narrow

        public static IORInterceptor_3_0 unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInterceptor_3_0Holder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class IORInterceptor_3_0Holder

  • java.lang.Object
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder
  • All Implemented Interfaces:
    Streamable

    public final class IORInterceptor_3_0Holder
extends Object
implements Streamable
    org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      IORInterceptor_3_0 value

    • Constructor Summary

      Constructors
      Constructor and Description
      IORInterceptor_3_0Holder()
      IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public IORInterceptor_3_0 value

    • Constructor Detail

      • IORInterceptor_3_0Holder

        public IORInterceptor_3_0Holder()

      • IORInterceptor_3_0Holder

        public IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IORInterceptor_3_0Operations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor_3_0Operations

  • All Superinterfaces:
    InterceptorOperations, IORInterceptorOperations
    All Known Subinterfaces:
    IORInterceptor_3_0

    public interface IORInterceptor_3_0Operations
extends IORInterceptorOperations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void adapter_manager_state_changed(int id, short state)
      Called whenever the state of an adapter manager changes.
      void adapter_state_changed(ObjectReferenceTemplate[] templates, short state)
      Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
      void components_established(IORInfo info)
      The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • components_established

        void components_established(IORInfo info)
        The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances. The adapter_template is available in info during this call. The current_factory may be get or set in info during this call.

        Any exception thrown from this method is handled by the Object Adapter that called this interceptor. In the case of the POA, an exception results in a OBJ_ADAPTER exception with an OMG standard minor code of 6.

        Parameters:
        info - The IORInfo for the object adapter being created.

      • adapter_manager_state_changed

        void adapter_manager_state_changed(int id,
                                   short state)
        Called whenever the state of an adapter manager changes. For the POA, that is the POAManager. If the state change is reported through adapter_manager_state_changed, it is not reported through adapter_state_changed.
        Parameters:
        id - the adapter manager id of the adapter manager that changed state
        state - the new state of the adapter manager

      • adapter_state_changed

        void adapter_state_changed(ObjectReferenceTemplate[] templates,
                           short state)
        Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager. Such changes are reported to all registered IORInterceptor_3_0 instances.
        Parameters:
        templates - the sequence of ObjectReferenceTemplate instances on which this state change occurred.
        state - the new AdapterState shared by all of the templates.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LOCATION_FORWARD (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface LOCATION_FORWARD

  • public interface LOCATION_FORWARD
    org/omg/PortableInterceptor/LOCATION_FORWARD.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a LocationForward reply status.

    • Field Detail

      • value

        static final short value
        Indicates a LocationForward reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NON_EXISTENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface NON_EXISTENT

  • public interface NON_EXISTENT
    org/omg/PortableInterceptor/NON_EXISTENT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state indicating that the adapter has been destroyed.

    • Field Detail

      • value

        static final short value
        Object adapter state indicating that the adapter has been destroyed.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectIdHelper

  • public abstract class ObjectIdHelper
extends Object
    Type of an object id. This provides the identity of a particular object that was created by an object adapter.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static byte[] | extract(Any a)
      static String | id()
      static void | insert(Any a, byte[] that)
      static byte[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, byte[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectIdHelper

        public ObjectIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          byte[] that)

      • extract

        public static byte[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static byte[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         byte[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ObjectReferenceFactory

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase
    All Known Subinterfaces:
    ObjectReferenceTemplate

    public interface ObjectReferenceFactory
extends ValueBase
    The object reference factory. This provides the capability of creating an object reference.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object make_object(String repositoryId, byte[] object_id)
      make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • Method Detail

      • make_object

        Object make_object(String repositoryId,
                   byte[] object_id)
        make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceFactoryHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceFactoryHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

  • public abstract class ObjectReferenceFactoryHelper
extends Object
    The object reference factory. This provides the capability of creating an object reference.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceFactoryHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectReferenceFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceFactory that)
      static ObjectReferenceFactory | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceFactory value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectReferenceFactoryHelper

        public ObjectReferenceFactoryHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectReferenceFactory that)

      • extract

        public static ObjectReferenceFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectReferenceFactory value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceFactoryHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceFactoryHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectReferenceFactoryHolder
extends Object
implements Streamable
    The object reference factory. This provides the capability of creating an object reference.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ObjectReferenceFactory value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceFactoryHolder()
      ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ObjectReferenceFactory value

    • Constructor Detail

      • ObjectReferenceFactoryHolder

        public ObjectReferenceFactoryHolder()

      • ObjectReferenceFactoryHolder

        public ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceTemplate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ObjectReferenceTemplate

  • All Superinterfaces:
    IDLEntity, ObjectReferenceFactory, Serializable, ValueBase

    public interface ObjectReferenceTemplate
extends ObjectReferenceFactory
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String[] adapter_name()
      String orb_id()
      String server_id()

      • Methods inherited from interface org.omg.PortableInterceptor.ObjectReferenceFactory

        make_object

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • Method Detail

      • server_id

        String server_id()

      • orb_id

        String orb_id()

      • adapter_name

        String[] adapter_name()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceTemplateHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

  • public abstract class ObjectReferenceTemplateHelper
extends Object
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectReferenceTemplate | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceTemplate that)
      static ObjectReferenceTemplate | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceTemplate value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectReferenceTemplateHelper

        public ObjectReferenceTemplateHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectReferenceTemplate that)

      • extract

        public static ObjectReferenceTemplate extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceTemplate read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectReferenceTemplate value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceTemplateHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectReferenceTemplateHolder
extends Object
implements Streamable
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ObjectReferenceTemplate value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateHolder()
      ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ObjectReferenceTemplate value

    • Constructor Detail

      • ObjectReferenceTemplateHolder

        public ObjectReferenceTemplateHolder()

      • ObjectReferenceTemplateHolder

        public ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceTemplateSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateSeqHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

  • public abstract class ObjectReferenceTemplateSeqHelper
extends Object
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectReferenceTemplate[] | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceTemplate[] that)
      static ObjectReferenceTemplate[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceTemplate[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectReferenceTemplateSeqHelper

        public ObjectReferenceTemplateSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectReferenceTemplate[] that)

      • extract

        public static ObjectReferenceTemplate[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceTemplate[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectReferenceTemplate[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectReferenceTemplateSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateSeqHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectReferenceTemplateSeqHolder
extends Object
implements Streamable
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ObjectReferenceTemplate[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateSeqHolder()
      ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ObjectReferenceTemplate[] value

    • Constructor Detail

      • ObjectReferenceTemplateSeqHolder

        public ObjectReferenceTemplateSeqHolder()

      • ObjectReferenceTemplateSeqHolder

        public ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORBIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ORBIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBIdHelper

  • public abstract class ORBIdHelper
extends Object
    org/omg/PortableInterceptor/ORBIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ORBIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ORBIdHelper

        public ORBIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORBInitializer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitializer

  • All Superinterfaces:
    IDLEntity, Object, ORBInitializerOperations, Serializable

    public interface ORBInitializer
extends ORBInitializerOperations, Object, IDLEntity
    Facilitates interceptor registration and ORB initialization.

    Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

    An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

    Registering ORB Initializers in Java

    ORBInitializers are registered via Java ORB properties.

    The property names are of the form:

    org.omg.PortableInterceptor.ORBInitializerClass.<Service>
    where <Service> is the string name of a class which implements
    org.omg.PortableInterceptor.ORBInitializer
    To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
    During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

    Example

    A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

     package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
    To run a program called MyApp using this logging service, the user could type:
    java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

    Notes about Registering Interceptors

    Request Interceptors are registered on a per-ORB basis.

    To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

    To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

    Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

    See Also:
    ORBInitInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ORBInitializerOperations

        post_init, pre_init

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORBInitializerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitializerOperations

  • All Known Subinterfaces:
    ORBInitializer

    public interface ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.

    Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

    An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

    Registering ORB Initializers in Java

    ORBInitializers are registered via Java ORB properties.

    The property names are of the form:

    org.omg.PortableInterceptor.ORBInitializerClass.<Service>
    where <Service> is the string name of a class which implements
    org.omg.PortableInterceptor.ORBInitializer
    To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
    During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

    Example

    A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

     package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
    To run a program called MyApp using this logging service, the user could type:
    java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

    Notes about Registering Interceptors

    Request Interceptors are registered on a per-ORB basis.

    To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

    To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

    Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

    See Also:
    ORBInitInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void post_init(ORBInitInfo info)
      Called during ORB initialization.
      void pre_init(ORBInitInfo info)
      Called during ORB initialization.

    • Method Detail

      • pre_init

        void pre_init(ORBInitInfo info)
        Called during ORB initialization. If it is expected that initial services registered by an interceptor will be used by other interceptors, then those initial services shall be registered at this point via calls to ORBInitInfo.register_initial_reference.
        Parameters:
        info - provides initialization attributes and operations by which Interceptors can be registered.

      • post_init

        void post_init(ORBInitInfo info)
        Called during ORB initialization. If a service must resolve initial references as part of its initialization, it can assume that all initial references will be available at this point.

        Calling the post_init operations is not the final task of ORB initialization. The final task, following the post_init calls, is attaching the lists of registered interceptors to the ORB. Therefore, the ORB does not contain the interceptors during calls to post_init. If an ORB-mediated call is made from within post_init, no request interceptors will be invoked on that call. Likewise, if an operation is performed which causes an IOR to be created, no IOR interceptors will be invoked.

        Parameters:
        info - provides initialization attributes and operations by which Interceptors can be registered.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORBInitInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitInfo

  • All Superinterfaces:
    IDLEntity, Object, ORBInitInfoOperations, Serializable

    public interface ORBInitInfo
extends ORBInitInfoOperations, Object, IDLEntity
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

    The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

    See Also:
    ORBInitializer

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ORBInitInfoOperations

        add_client_request_interceptor, add_ior_interceptor, add_server_request_interceptor, allocate_slot_id, arguments, codec_factory, orb_id, register_initial_reference, register_policy_factory, resolve_initial_references

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ORBInitInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitInfoOperations

  • All Known Subinterfaces:
    ORBInitInfo

    public interface ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

    The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

    See Also:
    ORBInitializer

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
      void add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
      void add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.
      int allocate_slot_id()
      Called to allocate a slot on PortableInterceptor.Current.
      String[] arguments()
      Returns the arguments passed to ORB.init.
      CodecFactory codec_factory()
      Returns the IOP.CodecFactory.
      String orb_id()
      Returns the ID of the ORB being initialized.
      void register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      void register_policy_factory(int type, PolicyFactory policy_factory)
      Registers a PolicyFactory for the given PolicyType.
      Object resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.

    • Method Detail

      • arguments

        String[] arguments()
        Returns the arguments passed to ORB.init. They may or may not contain the ORB's arguments.

      • orb_id

        String orb_id()
        Returns the ID of the ORB being initialized.

      • codec_factory

        CodecFactory codec_factory()
        Returns the IOP.CodecFactory. The CodecFactory is normally obtained via a call to ORB.resolve_initial_references( "CodecFactory" ), but since the ORB is not yet available and Interceptors, particularly when processing service contexts, will require a Codec, a means of obtaining a Codec is necessary during ORB initialization.

      • register_initial_reference

        void register_initial_reference(String id,
                                Object obj)
                         throws InvalidName
        Identical to ORB.register_initial_reference. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may need to be registered as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA.ORB.ObjectId) and (CORBA.ORB.InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.
        Throws:
        InvalidName

      • resolve_initial_references

        Object resolve_initial_references(String id)
                           throws InvalidName
        Identical to ORB.resolve_initial_references. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may be required from the ORB as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA::ORB::ObjectId and CORBA::ORB::InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.

        This operation is only valid during post_init.

        Throws:
        InvalidName

      • add_client_request_interceptor

        void add_client_request_interceptor(ClientRequestInterceptor interceptor)
                             throws DuplicateName
        Used to add a client-side request Interceptor to the list of client-side request Interceptors.
        Parameters:
        interceptor - The ClientRequestInterceptor to be added.
        Throws:
        DuplicateName - thrown if a client-side request Interceptor has already been registered with this Interceptor's name.

      • add_server_request_interceptor

        void add_server_request_interceptor(ServerRequestInterceptor interceptor)
                             throws DuplicateName
        Used to add a server-side request Interceptor to the list of server-side request Interceptors.
        Parameters:
        interceptor - The ServerRequestInterceptor to be added.
        Throws:
        DuplicateName - thrown if a server-side request Interceptor has already been registered with this Interceptor's name

      • add_ior_interceptor

        void add_ior_interceptor(IORInterceptor interceptor)
                  throws DuplicateName
        Used to add an IOR Interceptor to the list of IOR Interceptors.
        Parameters:
        interceptor - The IORInterceptor to be added.
        Throws:
        DuplicateName - thrown if an IOR Interceptor has already been registered with this Interceptor's name.

      • allocate_slot_id

        int allocate_slot_id()
        Called to allocate a slot on PortableInterceptor.Current.

        Note that while slot id's can be allocated within an ORB initializer, the slots themselves cannot be initialized.

        Returns:
        The index to the slot which has been allocated.
        Throws:
        BAD_INV_ORDER - thrown, with a standard minor code of 14, if set_slot or get_slot is called on the PICurrent within an ORB initializer.
        See Also:
        Current

      • register_policy_factory

        void register_policy_factory(int type,
                             PolicyFactory policy_factory)
        Registers a PolicyFactory for the given PolicyType.
        Parameters:
        type - The policy type that the given PolicyFactory serves.
        policy_factory - The factory for the given policy type.
        Throws:
        BAD_INV_ORDER - thrown, with a standard minor code of 16, if a PolicyFactory already exists for the given PolicyType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableInterceptor (Java Platform SE 8 )

org.omg.PortableInterceptor

Interfaces

  • ACTIVE
  • ClientRequestInfo
  • ClientRequestInfoOperations
  • ClientRequestInterceptor
  • ClientRequestInterceptorOperations
  • Current
  • CurrentOperations
  • DISCARDING
  • HOLDING
  • INACTIVE
  • Interceptor
  • InterceptorOperations
  • IORInfo
  • IORInfoOperations
  • IORInterceptor
  • IORInterceptor_3_0
  • IORInterceptor_3_0Operations
  • IORInterceptorOperations
  • LOCATION_FORWARD
  • NON_EXISTENT
  • ObjectReferenceFactory
  • ObjectReferenceTemplate
  • ORBInitializer
  • ORBInitializerOperations
  • ORBInitInfo
  • ORBInitInfoOperations
  • PolicyFactory
  • PolicyFactoryOperations
  • RequestInfo
  • RequestInfoOperations
  • ServerRequestInfo
  • ServerRequestInfoOperations
  • ServerRequestInterceptor
  • ServerRequestInterceptorOperations
  • SUCCESSFUL
  • SYSTEM_EXCEPTION
  • TRANSPORT_RETRY
  • UNKNOWN
  • USER_EXCEPTION

Classes

  • AdapterManagerIdHelper
  • AdapterNameHelper
  • AdapterStateHelper
  • CurrentHelper
  • ForwardRequestHelper
  • InvalidSlotHelper
  • IORInterceptor_3_0Helper
  • IORInterceptor_3_0Holder
  • ObjectIdHelper
  • ObjectReferenceFactoryHelper
  • ObjectReferenceFactoryHolder
  • ObjectReferenceTemplateHelper
  • ObjectReferenceTemplateHolder
  • ObjectReferenceTemplateSeqHelper
  • ObjectReferenceTemplateSeqHolder
  • ORBIdHelper
  • ServerIdHelper

Exceptions

  • ForwardRequest
  • InvalidSlot


org.omg.PortableInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableInterceptor

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

See: Description

  • Interface Summary
    Interface Description
    ACTIVE
    org/omg/PortableInterceptor/ACTIVE.java .
    ClientRequestInfo
    Request Information, accessible to client-side request interceptors.
    ClientRequestInfoOperations
    Request Information, accessible to client-side request interceptors.
    ClientRequestInterceptor
    Client-side request interceptor.
    ClientRequestInterceptorOperations
    Client-side request interceptor.
    Current
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    DISCARDING
    org/omg/PortableInterceptor/DISCARDING.java .
    HOLDING
    org/omg/PortableInterceptor/HOLDING.java .
    INACTIVE
    org/omg/PortableInterceptor/INACTIVE.java .
    Interceptor
    All Portable Interceptors implement Interceptor.
    InterceptorOperations
    All Portable Interceptors implement Interceptor.
    IORInfo
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInterceptor
    Interceptor used to establish tagged components in the profiles within an IOR.
    IORInterceptor_3_0
    org/omg/PortableInterceptor/IORInterceptor_3_0.java .
    IORInterceptor_3_0Operations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
    IORInterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.
    LOCATION_FORWARD
    org/omg/PortableInterceptor/LOCATION_FORWARD.java .
    NON_EXISTENT
    org/omg/PortableInterceptor/NON_EXISTENT.java .
    ObjectReferenceFactory
    The object reference factory.
    ObjectReferenceTemplate
    The object reference template.
    ORBInitializer
    Facilitates interceptor registration and ORB initialization.
    ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.
    ORBInitInfo
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    PolicyFactory
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    RequestInfo
    Request Information, accessible to Interceptors.
    RequestInfoOperations
    Request Information, accessible to Interceptors.
    ServerRequestInfo
    Request Information, accessible to server-side request interceptors.
    ServerRequestInfoOperations
    Request Information, accessible to server-side request interceptors.
    ServerRequestInterceptor
    Server-side request interceptor.
    ServerRequestInterceptorOperations
    Server-side request interceptor.
    SUCCESSFUL
    org/omg/PortableInterceptor/SUCCESSFUL.java .
    SYSTEM_EXCEPTION
    org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java .
    TRANSPORT_RETRY
    org/omg/PortableInterceptor/TRANSPORT_RETRY.java .
    UNKNOWN
    org/omg/PortableInterceptor/UNKNOWN.java .
    USER_EXCEPTION
    org/omg/PortableInterceptor/USER_EXCEPTION.java .
  • Class Summary
    Class Description
    AdapterManagerIdHelper
    Adapter manager identifier.
    AdapterNameHelper
    The name of an object adapter.
    AdapterStateHelper
    Type of object adapter state.
    CurrentHelper
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    ForwardRequestHelper
    org/omg/PortableInterceptor/ForwardRequestHelper.java .
    InvalidSlotHelper
    org/omg/PortableInterceptor/InvalidSlotHelper.java .
    IORInterceptor_3_0Helper
    org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java .
    IORInterceptor_3_0Holder
    org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
    ObjectIdHelper
    Type of an object id.
    ObjectReferenceFactoryHelper
    The object reference factory.
    ObjectReferenceFactoryHolder
    The object reference factory.
    ObjectReferenceTemplateHelper
    The object reference template.
    ObjectReferenceTemplateHolder
    The object reference template.
    ObjectReferenceTemplateSeqHelper
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
    ObjectReferenceTemplateSeqHolder
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
    ORBIdHelper
    org/omg/PortableInterceptor/ORBIdHelper.java .
    ServerIdHelper
    org/omg/PortableInterceptor/ServerIdHelper.java .
  • Exception Summary
    Exception Description
    ForwardRequest
    org/omg/PortableInterceptor/ForwardRequest.java .
    InvalidSlot
    org/omg/PortableInterceptor/InvalidSlot.java .

Package org.omg.PortableInterceptor Description

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

Interceptor Types

There are currently three types of interceptors that can be registered:
  • IORInterceptor - Used to establish tagged components in the profiles within an IOR.
  • ClientRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the client side.
  • ServerRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the server side.
See the javadocs for class ORBInitializer for how to go about registering interceptors.

Known limitations / unimplemented methods in package org.omg.PortableInterceptor

  • RequestInfo
    • sync_scope(): Always returns SYNC_WITH_TRANSPORT
    • arguments(): Only supported for DII/DSI calls
    • exceptions(): Only supported for DII calls on client side. Not supported on server-side.
    • contexts(): Only supported for DII calls on client side. Not supported on server-side since our ORB does not send contexts.
    • operation_context(): Only supported for DII calls on client side. Not supported on server-side since ORB does not send contexts.
    • result(): Only supported for DII/DSI calls
  • ClientRequestInfo
    • received_exception_id(): Always returns null in the DII case
    • get_request_policy(int type): Not implemented.
  • ServerRequestInfo
    • sending_exception(): Does not support user exceptions on the server side in non-DSI case.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableInterceptor Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableInterceptor

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ORBIdHelper
    • org.omg.PortableInterceptor.ServerIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.PortableInterceptor.InvalidSlot

Interface Hierarchy

  • org.omg.PortableInterceptor.ACTIVE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableInterceptor.DISCARDING
  • org.omg.PortableInterceptor.HOLDING
  • org.omg.PortableInterceptor.INACTIVE
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.omg.PortableInterceptor.NON_EXISTENT
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.PortableInterceptor.Interceptor (also extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (also extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • org.omg.PortableInterceptor.UNKNOWN
  • org.omg.PortableInterceptor.USER_EXCEPTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableInterceptor

  • Packages that use org.omg.PortableInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.PortableInterceptor used by org.omg.PortableInterceptor
    Class and Description
    ClientRequestInfo
    Request Information, accessible to client-side request interceptors.
    ClientRequestInfoOperations
    Request Information, accessible to client-side request interceptors.
    ClientRequestInterceptor
    Client-side request interceptor.
    ClientRequestInterceptorOperations
    Client-side request interceptor.
    Current
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    ForwardRequest
    org/omg/PortableInterceptor/ForwardRequest.java .
    Interceptor
    All Portable Interceptors implement Interceptor.
    InterceptorOperations
    All Portable Interceptors implement Interceptor.
    InvalidSlot
    org/omg/PortableInterceptor/InvalidSlot.java .
    IORInfo
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInterceptor
    Interceptor used to establish tagged components in the profiles within an IOR.
    IORInterceptor_3_0
    org/omg/PortableInterceptor/IORInterceptor_3_0.java .
    IORInterceptor_3_0Operations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
    IORInterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.
    ObjectReferenceFactory
    The object reference factory.
    ObjectReferenceTemplate
    The object reference template.
    ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.
    ORBInitInfo
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    PolicyFactory
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    RequestInfo
    Request Information, accessible to Interceptors.
    RequestInfoOperations
    Request Information, accessible to Interceptors.
    ServerRequestInfo
    Request Information, accessible to server-side request interceptors.
    ServerRequestInfoOperations
    Request Information, accessible to server-side request interceptors.
    ServerRequestInterceptor
    Server-side request interceptor.
    ServerRequestInterceptorOperations
    Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface PolicyFactory

  • All Superinterfaces:
    IDLEntity, Object, PolicyFactoryOperations, Serializable

    public interface PolicyFactory
extends PolicyFactoryOperations, Object, IDLEntity
    Enables policy types to be constructed using CORBA.ORB.create_policy.

    A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

    See Also:
    ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.PolicyFactoryOperations

        create_policy

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


PolicyFactoryOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface PolicyFactoryOperations

  • All Known Subinterfaces:
    PolicyFactory

    public interface PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.

    A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

    See Also:
    ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Policy create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

    • Method Detail

      • create_policy

        Policy create_policy(int type,
                     Any value)
              throws PolicyError
        Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

        The ORB calls create_policy on a registered PolicyFactory instance when CORBA.ORB.create_policy is called for the PolicyType under which the PolicyFactory has been registered. The create_policy operation then returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any. If it cannot, it shall throw an exception as described for CORBA.ORB.create_policy.

        Parameters:
        type - An int specifying the type of policy being created.
        value - An any containing data with which to construct the CORBA.Policy.
        Returns:
        A CORBA.Policy object of the specified type and value.
        Throws:
        PolicyError
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RequestInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface RequestInfo

  • All Superinterfaces:
    IDLEntity, Object, RequestInfoOperations, Serializable
    All Known Subinterfaces:
    ClientRequestInfo, ServerRequestInfo

    public interface RequestInfo
extends RequestInfoOperations, Object, IDLEntity
    Request Information, accessible to Interceptors.

    Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

    See Also:
    ClientRequestInfo, ServerRequestInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RequestInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface RequestInfoOperations

  • All Known Subinterfaces:
    ClientRequestInfo, ClientRequestInfoOperations, RequestInfo, ServerRequestInfo, ServerRequestInfoOperations

    public interface RequestInfoOperations
    Request Information, accessible to Interceptors.

    Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

    See Also:
    ClientRequestInfo, ServerRequestInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Parameter[] arguments()
      Returns an array of Parameter objects, containing the arguments on the operation being invoked.
      String[] contexts()
      Returns an array of String objects describing the contexts that may be passed on this operation invocation.
      TypeCode[] exceptions()
      Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
      Object forward_reference()
      Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
      ServiceContext get_reply_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the reply.
      ServiceContext get_request_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the request.
      Any get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      String[] operation_context()
      Returns an array of String objects containing the contexts being sent on the request.
      String operation()
      Returns the name of the operation being invoked.
      short reply_status()
      Describes the state of the result of the operation invocation.
      int request_id()
      Returns an id that uniquely identifies an active request/reply sequence.
      boolean response_expected()
      Indicates whether a response is expected.
      Any result()
      Returns an any containing the result of the operation invocation.
      short sync_scope()
      Defines how far the request shall progress before control is returned to the client.

    • Method Detail

      • request_id

        int request_id()
        Returns an id that uniquely identifies an active request/reply sequence. Once a request/reply sequence is concluded this ID may be reused. Note that this id is not the same as the GIOP request_id. If GIOP is the transport mechanism used, then these IDs may very well be the same, but this is not guaranteed nor required.

      • operation

        String operation()
        Returns the name of the operation being invoked.

      • arguments

        Parameter[] arguments()
        Returns an array of Parameter objects, containing the arguments on the operation being invoked. If there are no arguments, this attribute will be a zero length array.

        Not all environments provide access to the arguments. With the Java portable bindings, for example, the arguments are not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Arguments are available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if arguments are not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • exceptions

        TypeCode[] exceptions()
        Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw. If there are no user exceptions, this will return a zero length array.

        Not all environments provide access to the exception list. With the Java portable bindings, for example, the exception list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Exceptions are available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if exceptions are not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • contexts

        String[] contexts()
        Returns an array of String objects describing the contexts that may be passed on this operation invocation. If there are no contexts, this will return a zero length array.

        Not all environments provide access to the context list. With the Java portable bindings, for example, the context list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Contexts are available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if contexts are not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • operation_context

        String[] operation_context()
        Returns an array of String objects containing the contexts being sent on the request.

        Not all environments provide access to the context. With the Java portable bindings, for example, the context is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with standard minor code of 1.

        Note: operation_context is available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if operation context is not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • result

        Any result()
        Returns an any containing the result of the operation invocation. If the operation return type is void, this attribute will be an any containing a type code with a TCKind value of tk_void and no value.

        Not all environments provide access to the result. With the Java portable bindings, for example, the result is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Result is available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if result is not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • response_expected

        boolean response_expected()
        Indicates whether a response is expected.

        On the client, a reply is not returned when response_expected is false, so receive_reply cannot be called. receive_other is called unless an exception occurs, in which case receive_exception is called.

        On the client, within send_poll, this attribute is true.

      • sync_scope

        short sync_scope()
        Defines how far the request shall progress before control is returned to the client. This is defined in the Messaging specification, and is pertinent only when response_expected is false. If response_expected is true, the value of sync_scope is undefined. This attribute may have one of the following values:
        • Messaging.SYNC_NONE
        • Messaging.SYNC_WITH_TRANSPORT
        • Messaging.SYNC_WITH_SERVER
        • Messaging.SYNC_WITH_TARGET
        On the server, for all scopes, a reply will be created from the return of the target operation call, but the reply will not return to the client. Although it does not return to the client, it does occur, so the normal server-side interception points are followed (i.e., receive_request_service_contexts, receive_request, send_reply or send_exception).

        For SYNC_WITH_SERVER and SYNC_WITH_TARGET, the server does send an empty reply back to the client before the target is invoked. This reply is not intercepted by server-side Interceptors.

        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • reply_status

        short reply_status()
        Describes the state of the result of the operation invocation. The return value can be one of the following:
        • PortableInterceptor.SUCCESSFUL
        • PortableInterceptor.SYSTEM_EXCEPTION
        • PortableInterceptor.USER_EXCEPTION
        • PortableInterceptor.LOCATION_FORWARD
        • PortableInterceptor.TRANSPORT_RETRY
        On the client:
        • Within the receive_reply interception point, this will only return SUCCESSFUL
          • .
        • Within the receive_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
        • Within the receive_other interception point, this will be any of: SUCCESSFUL, LOCATION_FORWARD, or TRANSPORT_RETRY. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status. TRANSPORT_RETRY means that the transport mechanism indicated a retry - a GIOP reply with a status of NEEDS_ADDRESSING_MODE, for instance.
        On the server:
        • Within the send_reply interception point, this will only be SUCCESSFUL.
        • Within the send_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
        • Within the send_other interception point, this attribute will be any of: SUCCESSFUL, or LOCATION_FORWARD. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status.
        See Also:
        SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY

      • forward_reference

        Object forward_reference()
        Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD. It is indeterminate whether a forwarded request will actually occur.

      • get_slot

        Any get_slot(int id)
      throws InvalidSlot
        Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.

        If the given slot has not been set, then an any containing a type code with a TCKind value of tk_null is returned.

        Parameters:
        id - The SlotId of the slot which is to be returned.
        Returns:
        The slot data, in the form of an any, obtained with the given identifier.
        Throws:
        InvalidSlot - thrown if the ID does not define an allocated slot.
        See Also:
        Current

      • get_request_service_context

        ServiceContext get_request_service_context(int id)
        Returns a copy of the service context with the given ID that is associated with the request.

        Parameters:
        id - The IOP.ServiceId of the service context which is to be returned.
        Returns:
        The IOP.ServiceContext obtained with the given identifier.
        Throws:
        BAD_PARAM - thrown with a standard minor code of 26, if the request's service context does not contain an entry for that ID.

      • get_reply_service_context

        ServiceContext get_reply_service_context(int id)
        Returns a copy of the service context with the given ID that is associated with the reply.
        Parameters:
        id - The IOP.ServiceId of the service context which is to be returned.
        Returns:
        The IOP.ServiceContext obtained with the given identifier.
        Throws:
        BAD_PARAM - thrown with a standard minor code of 26 if the request's service context does not contain an entry for that ID.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServerIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ServerIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ServerIdHelper

  • public abstract class ServerIdHelper
extends Object
    org/omg/PortableInterceptor/ServerIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServerIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServerIdHelper

        public ServerIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServerRequestInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInfo

  • All Superinterfaces:
    IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable, ServerRequestInfoOperations

    public interface ServerRequestInfo
extends ServerRequestInfoOperations, RequestInfo, IDLEntity
    Request Information, accessible to server-side request interceptors.

    Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    receive_request_
    service_contexts     		receive_request send_reply send_exception send_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             no yes1 yes no2 no2

    exceptions

             no yes yes yes yes

    contexts

             no yes yes yes yes

    operation_context

             no yes yes no no

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes yes yes yes yes
    request_id | yes | yes | yes | yes | yes
    operation | yes | yes | yes | yes | yes
    arguments | no | yes1 | yes | no2 | no2
    exceptions | no | yes | yes | yes | yes
    contexts | no | yes | yes | yes | yes
    operation_context | no | yes | yes | no | no
    result | no | no | yes | no | no
    response_expected | yes | yes | yes | yes | yes
    sync_scope | yes | yes | yes | yes | yes
    reply_status | no | no | yes | yes | yes
    forward_reference | no | no | no | no | yes2
    get_slot | yes | yes | yes | yes | yes
    get_request_service_context | yes | no | yes | yes | yes
    get_reply_service_context | no | no | yes | yes | yes
    ServerRequestInfo-specific:
    sending_exception | no | no | no | yes | no
    object_id | no | yes | yes | yes3 | yes3
    adapter_id | no | yes | yes | yes3 | yes3
    server_id | no | yes | yes | yes | yes
    orb_id | no | yes | yes | yes | yes
    adapter_name | no | yes | yes | yes | yes
    target_most_derived_interface | no | yes | no4 | no4 | no4
    get_server_policy | yes | yes | yes | yes | yes
    set_slot | yes | yes | yes | yes | yes
    target_is_a | no | yes | no4 | no4 | no4
    add_reply_service_context | yes | yes | yes | yes | yes
    1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
    4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
      5. .
    See Also:
    ServerRequestInterceptor

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ServerRequestInfoOperations

        adapter_id, adapter_name, add_reply_service_context, get_server_policy, object_id, orb_id, sending_exception, server_id, set_slot, target_is_a, target_most_derived_interface

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServerRequestInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInfoOperations

  • All Superinterfaces:
    RequestInfoOperations
    All Known Subinterfaces:
    ServerRequestInfo

    public interface ServerRequestInfoOperations
extends RequestInfoOperations
    Request Information, accessible to server-side request interceptors.

    Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    receive_request_
    service_contexts     		receive_request send_reply send_exception send_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             no yes1 yes no2 no2

    exceptions

             no yes yes yes yes

    contexts

             no yes yes yes yes

    operation_context

             no yes yes no no

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes yes yes yes yes
    request_id | yes | yes | yes | yes | yes
    operation | yes | yes | yes | yes | yes
    arguments | no | yes1 | yes | no2 | no2
    exceptions | no | yes | yes | yes | yes
    contexts | no | yes | yes | yes | yes
    operation_context | no | yes | yes | no | no
    result | no | no | yes | no | no
    response_expected | yes | yes | yes | yes | yes
    sync_scope | yes | yes | yes | yes | yes
    reply_status | no | no | yes | yes | yes
    forward_reference | no | no | no | no | yes2
    get_slot | yes | yes | yes | yes | yes
    get_request_service_context | yes | no | yes | yes | yes
    get_reply_service_context | no | no | yes | yes | yes
    ServerRequestInfo-specific:
    sending_exception | no | no | no | yes | no
    object_id | no | yes | yes | yes3 | yes3
    adapter_id | no | yes | yes | yes3 | yes3
    server_id | no | yes | yes | yes | yes
    orb_id | no | yes | yes | yes | yes
    adapter_name | no | yes | yes | yes | yes
    target_most_derived_interface | no | yes | no4 | no4 | no4
    get_server_policy | yes | yes | yes | yes | yes
    set_slot | yes | yes | yes | yes | yes
    target_is_a | no | yes | no4 | no4 | no4
    add_reply_service_context | yes | yes | yes | yes | yes
    1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
    4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
      5. .
    See Also:
    ServerRequestInterceptor

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] adapter_id()
      Returns the opaque identifier for the object adapter.
      String[] adapter_name()
      Returns the sequence of strings that identifies the object adapter instance that is handling this request.
      void add_reply_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      Policy get_server_policy(int type)
      Returns the policy in effect for this operation for the given policy type.
      byte[] object_id()
      Returns the opaque object_id describing the target of the operation invocation.
      String orb_id()
      Returns the ID that was used to create the ORB.
      Any sending_exception()
      Returns an any which contains the exception to be returned to the client.
      String server_id()
      Returns the server ID that was specified on ORB::init using the -ORBServerId argument.
      void set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      boolean target_is_a(String id)
      Returns true if the servant is the given repository id, false if it is not.
      String target_most_derived_interface()
      Returns the repository id for the most derived interface of the servant.

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

    • Method Detail

      • sending_exception

        Any sending_exception()
        Returns an any which contains the exception to be returned to the client.

        If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don't provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1.

        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • object_id

        byte[] object_id()
        Returns the opaque object_id describing the target of the operation invocation.

      • adapter_id

        byte[] adapter_id()
        Returns the opaque identifier for the object adapter.

      • server_id

        String server_id()
        Returns the server ID that was specified on ORB::init using the -ORBServerId argument.

      • orb_id

        String orb_id()
        Returns the ID that was used to create the ORB.

      • adapter_name

        String[] adapter_name()
        Returns the sequence of strings that identifies the object adapter instance that is handling this request.

      • target_most_derived_interface

        String target_most_derived_interface()
        Returns the repository id for the most derived interface of the servant.

      • get_server_policy

        Policy get_server_policy(int type)
        Returns the policy in effect for this operation for the given policy type. The returned CORBA.Policy object shall only be a policy whose type was registered via register_policy_factory.
        Parameters:
        type - The CORBA.PolicyType which specifies the policy to be returned.
        Returns:
        The CORBA.Policy obtained with the given policy type.
        Throws:
        INV_POLICY - thrown, with a standard minor code of 2, if a policy for the given type was not registered via register_policy_factory.
        See Also:
        ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

      • set_slot

        void set_slot(int id,
              Any data)
       throws InvalidSlot
        Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request. If data already exists in that slot, it will be overwritten.
        Parameters:
        id - The id of the slot.
        data - The data, in the form of an any, to store in that slot.
        Throws:
        InvalidSlot - thrown if the ID does not define an allocated slot.
        See Also:
        Current

      • target_is_a

        boolean target_is_a(String id)
        Returns true if the servant is the given repository id, false if it is not.
        Parameters:
        id - The caller wants to know if the servant is this repository id.
        Returns:
        Is the servant the given RepositoryId?

      • add_reply_service_context

        void add_reply_service_context(ServiceContext service_context,
                               boolean replace)
        Allows Interceptors to add service contexts to the request.

        There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

        Parameters:
        service_context - The IOP.ServiceContext to add to the reply.
        replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
        Throws:
        BAD_INV_ORDER - thrown, with a standard minor code of 15, if replace is false and a service context already exists with the given ID.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServerRequestInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInterceptor

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, Object, Serializable, ServerRequestInterceptorOperations

    public interface ServerRequestInterceptor
extends ServerRequestInterceptorOperations, Interceptor, IDLEntity
    Server-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

    See Also:
    ServerRequestInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations

        receive_request_service_contexts, receive_request, send_exception, send_other, send_reply

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServerRequestInterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    ServerRequestInterceptor

    public interface ServerRequestInterceptorOperations
extends InterceptorOperations
    Server-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

    See Also:
    ServerRequestInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void send_reply(ServerRequestInfo ri)
      Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • receive_request_service_contexts

        void receive_request_service_contexts(ServerRequestInfo ri)
                               throws ForwardRequest
        Allows the interceptor to process service context information.

        At this interception point, Interceptors must get their service context information from the incoming request transfer it to PortableInterceptor.Current's slots.

        This interception point is called before the servant manager is called. Operation parameters are not yet available at this point. This interception point may or may not execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • receive_request

        void receive_request(ServerRequestInfo ri)
              throws ForwardRequest
        Allows an Interceptor to query request information after all the information, including operation parameters, are available. This interception point shall execute in the same thread as the target invocation.

        In the DSI model, since the parameters are first available when the user code calls arguments, receive_request is called from within arguments. It is possible that arguments is not called in the DSI model. The target may call set_exception before calling arguments. The ORB shall guarantee that receive_request is called once, either through arguments or through set_exception. If it is called through set_exception, requesting the arguments will result in NO_RESOURCES being thrown with a standard minor code of 1.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_reply

        void send_reply(ServerRequestInfo ri)
        Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client. This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' send_reply operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception point called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

        Parameters:
        ri - Information about the current request being intercepted.

      • send_exception

        void send_exception(ServerRequestInfo ri)
             throws ForwardRequest
        Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client. When an exception occurs, this interception point is called. This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to send_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_exception operations are called. The remaining Interceptors in the Flow Stack shall have their send_other interception points called.

        If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request's at-most-once semantics would be lost.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_other

        void send_other(ServerRequestInfo ri)
         throws ForwardRequest
        Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received). This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' send_other operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception points called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' send_other operations are called with the new information provided by the ForwardRequest exception.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SUCCESSFUL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface SUCCESSFUL

  • public interface SUCCESSFUL
    org/omg/PortableInterceptor/SUCCESSFUL.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a successful Reply Status.

    • Field Detail

      • value

        static final short value
        Indicates a successful Reply Status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SYSTEM_EXCEPTION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface SYSTEM_EXCEPTION

  • public interface SYSTEM_EXCEPTION
    org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a SystemException reply status.

    • Field Detail

      • value

        static final short value
        Indicates a SystemException reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TRANSPORT_RETRY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface TRANSPORT_RETRY

  • public interface TRANSPORT_RETRY
    org/omg/PortableInterceptor/TRANSPORT_RETRY.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a Transport Retry reply status.

    • Field Detail

      • value

        static final short value
        Indicates a Transport Retry reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UNKNOWN (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface UNKNOWN

  • public interface UNKNOWN
    org/omg/PortableInterceptor/UNKNOWN.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      XXX

    • Field Detail

      • value

        static final short value
        XXX
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


USER_EXCEPTION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface USER_EXCEPTION

  • public interface USER_EXCEPTION
    org/omg/PortableInterceptor/USER_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a UserException reply status.

    • Field Detail

      • value

        static final short value
        Indicates a UserException reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ACTIVE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ACTIVE

No usage of org.omg.PortableInterceptor.ACTIVE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.AdapterManagerIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.AdapterManagerIdHelper

No usage of org.omg.PortableInterceptor.AdapterManagerIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.AdapterNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.AdapterNameHelper

No usage of org.omg.PortableInterceptor.AdapterNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.AdapterStateHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.AdapterStateHelper

No usage of org.omg.PortableInterceptor.AdapterStateHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ClientRequestInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInfo

  • Packages that use ClientRequestInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ClientRequestInfo
      Modifier and Type Method and Description
      void ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ClientRequestInterceptorOperations.receive_reply(ClientRequestInfo ri)
      Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
      void ClientRequestInterceptorOperations.send_poll(ClientRequestInfo ri)
      Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
      void ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ClientRequestInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInfoOperations

  • Packages that use ClientRequestInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ClientRequestInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ClientRequestInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInterceptor

  • Packages that use ClientRequestInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInterceptor in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ClientRequestInterceptor
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInterceptorOperations

  • Packages that use ClientRequestInterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of ClientRequestInterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.Current (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.Current

  • Packages that use Current
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Current in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Current
      Modifier and Type | Method and Description
      static Current | CurrentHelper.extract(Any a)
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      static Current | CurrentHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableInterceptor with parameters of type Current
      Modifier and Type | Method and Description
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.CurrentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.CurrentHelper

No usage of org.omg.PortableInterceptor.CurrentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.CurrentOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.CurrentOperations

  • Packages that use CurrentOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of CurrentOperations in org.omg.PortableInterceptor

      Subinterfaces of CurrentOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  Current
      Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.DISCARDING (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.DISCARDING

No usage of org.omg.PortableInterceptor.DISCARDING
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ForwardRequest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ForwardRequest

  • Packages that use ForwardRequest
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ForwardRequest in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return ForwardRequest
      Modifier and Type | Method and Description
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ForwardRequest
      Modifier and Type | Method and Description
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      Methods in org.omg.PortableInterceptor that throw ForwardRequest
      Modifier and Type Method and Description
      void ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ForwardRequestHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ForwardRequestHelper

No usage of org.omg.PortableInterceptor.ForwardRequestHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.HOLDING (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.HOLDING

No usage of org.omg.PortableInterceptor.HOLDING
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.INACTIVE (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.INACTIVE

No usage of org.omg.PortableInterceptor.INACTIVE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.Interceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.Interceptor

  • Packages that use Interceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Interceptor in org.omg.PortableInterceptor

      Subinterfaces of Interceptor in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ServerRequestInterceptor
      Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.InterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.InterceptorOperations

  • Packages that use InterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of InterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of InterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  ClientRequestInterceptorOperations
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  IORInterceptor_3_0Operations
      org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
      interface  IORInterceptorOperations
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      interface  ServerRequestInterceptorOperations
      Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.InvalidSlot (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.InvalidSlot

  • Packages that use InvalidSlot
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of InvalidSlot in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return InvalidSlot
      Modifier and Type | Method and Description
      static InvalidSlot | InvalidSlotHelper.extract(Any a)
      static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type InvalidSlot
      Modifier and Type | Method and Description
      static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
      static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
      Methods in org.omg.PortableInterceptor that throw InvalidSlot
      Modifier and Type Method and Description
      Any RequestInfoOperations.get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      Any CurrentOperations.get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      void ServerRequestInfoOperations.set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      void CurrentOperations.set_slot(int id, Any data)
      Sets data in a slot.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.InvalidSlotHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.InvalidSlotHelper

No usage of org.omg.PortableInterceptor.InvalidSlotHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.IORInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInfo

  • Packages that use IORInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type IORInfo
      Modifier and Type Method and Description
      void IORInterceptor_3_0Operations.components_established(IORInfo info)
      The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.
      void IORInterceptorOperations.establish_components(IORInfo info)
      A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.IORInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInfoOperations

  • Packages that use IORInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of IORInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.IORInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor

  • Packages that use IORInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptor in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      Methods in org.omg.PortableInterceptor with parameters of type IORInterceptor
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.IORInterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptorOperations

  • Packages that use IORInterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  IORInterceptor_3_0Operations
      org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.IORInterceptor_3_0 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor_3_0

  • Packages that use IORInterceptor_3_0
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor_3_0 in org.omg.PortableInterceptor

      Fields in org.omg.PortableInterceptor declared as IORInterceptor_3_0
      Modifier and Type | Field and Description
      IORInterceptor_3_0 | IORInterceptor_3_0Holder.value
      Methods in org.omg.PortableInterceptor that return IORInterceptor_3_0
      Modifier and Type | Method and Description
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableInterceptor with parameters of type IORInterceptor_3_0
      Modifier and Type | Method and Description
      static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
      static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
      Constructors in org.omg.PortableInterceptor with parameters of type IORInterceptor_3_0
      Constructor and Description
      IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.IORInterceptor_3_0Helper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.IORInterceptor_3_0Helper

No usage of org.omg.PortableInterceptor.IORInterceptor_3_0Helper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.IORInterceptor_3_0Holder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.IORInterceptor_3_0Holder

No usage of org.omg.PortableInterceptor.IORInterceptor_3_0Holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor_3_0Operations

  • Packages that use IORInterceptor_3_0Operations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor_3_0Operations in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptor_3_0Operations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.LOCATION_FORWARD (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.LOCATION_FORWARD

No usage of org.omg.PortableInterceptor.LOCATION_FORWARD
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.NON_EXISTENT (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.NON_EXISTENT

No usage of org.omg.PortableInterceptor.NON_EXISTENT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectIdHelper

No usage of org.omg.PortableInterceptor.ObjectIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ObjectReferenceFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ObjectReferenceFactory

  • Packages that use ObjectReferenceFactory
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ObjectReferenceFactory in org.omg.PortableInterceptor

      Subinterfaces of ObjectReferenceFactory in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ObjectReferenceTemplate
      The object reference template.
      Fields in org.omg.PortableInterceptor declared as ObjectReferenceFactory
      Modifier and Type | Field and Description
      ObjectReferenceFactory | ObjectReferenceFactoryHolder.value
      Methods in org.omg.PortableInterceptor that return ObjectReferenceFactory
      Modifier and Type | Method and Description
      ObjectReferenceFactory IORInfoOperations.current_factory()
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ObjectReferenceFactory
      Modifier and Type | Method and Description
      void IORInfoOperations.current_factory(ObjectReferenceFactory newCurrent_factory)
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
      static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
      Constructors in org.omg.PortableInterceptor with parameters of type ObjectReferenceFactory
      Constructor and Description
      ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceFactoryHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ObjectReferenceTemplate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ObjectReferenceTemplate

  • Packages that use ObjectReferenceTemplate
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ObjectReferenceTemplate in org.omg.PortableInterceptor

      Fields in org.omg.PortableInterceptor declared as ObjectReferenceTemplate
      Modifier and Type | Field and Description
      ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHolder.value
      ObjectReferenceTemplate | ObjectReferenceTemplateHolder.value
      Methods in org.omg.PortableInterceptor that return ObjectReferenceTemplate
      Modifier and Type | Method and Description
      ObjectReferenceTemplate IORInfoOperations.adapter_template()
      Return the object reference template of the object adapter that was just created and is running IOR interceptors.
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ObjectReferenceTemplate
      Modifier and Type | Method and Description
      void IORInterceptor_3_0Operations.adapter_state_changed(ObjectReferenceTemplate[] templates, short state)
      Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
      static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
      static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
      static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
      static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
      Constructors in org.omg.PortableInterceptor with parameters of type ObjectReferenceTemplate
      Constructor and Description
      ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
      ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ORBIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBIdHelper

No usage of org.omg.PortableInterceptor.ORBIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ORBInitializer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitializer

No usage of org.omg.PortableInterceptor.ORBInitializer
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ORBInitializerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitializerOperations

  • Packages that use ORBInitializerOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitializerOperations in org.omg.PortableInterceptor

      Subinterfaces of ORBInitializerOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ORBInitInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitInfo

  • Packages that use ORBInitInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ORBInitInfo
      Modifier and Type Method and Description
      void ORBInitializerOperations.post_init(ORBInitInfo info)
      Called during ORB initialization.
      void ORBInitializerOperations.pre_init(ORBInitInfo info)
      Called during ORB initialization.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ORBInitInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitInfoOperations

  • Packages that use ORBInitInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ORBInitInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.PolicyFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.PolicyFactory

  • Packages that use PolicyFactory
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyFactory in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type PolicyFactory
      Modifier and Type Method and Description
      void ORBInitInfoOperations.register_policy_factory(int type, PolicyFactory policy_factory)
      Registers a PolicyFactory for the given PolicyType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.PolicyFactoryOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.PolicyFactoryOperations

  • Packages that use PolicyFactoryOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyFactoryOperations in org.omg.PortableInterceptor

      Subinterfaces of PolicyFactoryOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.RequestInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.RequestInfo

  • Packages that use RequestInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of RequestInfo in org.omg.PortableInterceptor

      Subinterfaces of RequestInfo in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.RequestInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.RequestInfoOperations

  • Packages that use RequestInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of RequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of RequestInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInfoOperations
      Request Information, accessible to client-side request interceptors.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInfoOperations
      Request Information, accessible to server-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ServerIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ServerIdHelper

No usage of org.omg.PortableInterceptor.ServerIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ServerRequestInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInfo

  • Packages that use ServerRequestInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ServerRequestInfo
      Modifier and Type Method and Description
      void ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ServerRequestInterceptorOperations.send_reply(ServerRequestInfo ri)
      Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ServerRequestInfoOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInfoOperations

  • Packages that use ServerRequestInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ServerRequestInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ServerRequestInterceptor (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInterceptor

  • Packages that use ServerRequestInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInterceptor in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ServerRequestInterceptor
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInterceptorOperations

  • Packages that use ServerRequestInterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of ServerRequestInterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ServerRequestInterceptor
      Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.SUCCESSFUL (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.SUCCESSFUL

No usage of org.omg.PortableInterceptor.SUCCESSFUL
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.SYSTEM_EXCEPTION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.SYSTEM_EXCEPTION

No usage of org.omg.PortableInterceptor.SYSTEM_EXCEPTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.TRANSPORT_RETRY (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.TRANSPORT_RETRY

No usage of org.omg.PortableInterceptor.TRANSPORT_RETRY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.UNKNOWN (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.UNKNOWN

No usage of org.omg.PortableInterceptor.UNKNOWN
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableInterceptor.USER_EXCEPTION (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.USER_EXCEPTION

No usage of org.omg.PortableInterceptor.USER_EXCEPTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DuplicateName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class DuplicateName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class DuplicateName
extends UserException
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String name
      The name for which there was already an interceptor registered.

    • Constructor Summary

      Constructors
      Constructor and Description
      DuplicateName()
      DuplicateName(String _name)
      DuplicateName(String $reason, String _name)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • name

        public String name
        The name for which there was already an interceptor registered.

    • Constructor Detail

      • DuplicateName

        public DuplicateName()

      • DuplicateName

        public DuplicateName(String _name)

      • DuplicateName

        public DuplicateName(String $reason,
                     String _name)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DuplicateNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class DuplicateNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

  • public abstract class DuplicateNameHelper
extends Object
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      DuplicateNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DuplicateName | extract(Any a)
      static String | id()
      static void | insert(Any a, DuplicateName that)
      static DuplicateName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DuplicateName value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DuplicateNameHelper

        public DuplicateNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DuplicateName that)

      • extract

        public static DuplicateName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DuplicateName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DuplicateName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidName()
      InvalidName(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidName

        public InvalidName()

      • InvalidName

        public InvalidName(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class InvalidNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

  • public abstract class InvalidNameHelper
extends Object
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidName | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidName that)
      static InvalidName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidName value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidNameHelper

        public InvalidNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidName that)

      • extract

        public static InvalidName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class ObjectIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

  • public abstract class ObjectIdHelper
extends Object
    Object id, represented as a String

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectIdHelper

        public ObjectIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 8 )

org.omg.PortableInterceptor.ORBInitInfoPackage

Classes

  • DuplicateNameHelper
  • InvalidNameHelper
  • ObjectIdHelper

Exceptions

  • DuplicateName
  • InvalidName


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableInterceptor.ORBInitInfoPackage

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

See: Description

  • Class Summary
    Class Description
    DuplicateNameHelper
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java .
    InvalidNameHelper
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java .
    ObjectIdHelper
    Object id, represented as a String
  • Exception Summary
    Exception Description
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .

Package org.omg.PortableInterceptor.ORBInitInfoPackage Description

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableInterceptor.ORBInitInfoPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableInterceptor.ORBInitInfoPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableInterceptor.ORBInitInfoPackage

  • Packages that use org.omg.PortableInterceptor.ORBInitInfoPackage
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
  • Classes in org.omg.PortableInterceptor.ORBInitInfoPackage used by org.omg.PortableInterceptor
    Class and Description
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
  • Classes in org.omg.PortableInterceptor.ORBInitInfoPackage used by org.omg.PortableInterceptor.ORBInitInfoPackage
    Class and Description
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName

  • Packages that use DuplicateName
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

    • Uses of DuplicateName in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw DuplicateName
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
      void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
      void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.

    • Uses of DuplicateName in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return DuplicateName
      Modifier and Type | Method and Description
      static DuplicateName | DuplicateNameHelper.extract(Any a)
      static DuplicateName | DuplicateNameHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type DuplicateName
      Modifier and Type | Method and Description
      static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
      static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName

  • Packages that use InvalidName
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

    • Uses of InvalidName in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw InvalidName
      Modifier and Type Method and Description
      void ORBInitInfoOperations.register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      Object ORBInitInfoOperations.resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.

    • Uses of InvalidName in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return InvalidName
      Modifier and Type | Method and Description
      static InvalidName | InvalidNameHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type InvalidName
      Modifier and Type | Method and Description
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterActivator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface AdapterActivator

  • All Superinterfaces:
    AdapterActivatorOperations, IDLEntity, Object, Serializable

    public interface AdapterActivator
extends AdapterActivatorOperations, Object, IDLEntity
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.AdapterActivatorOperations

        unknown_adapter

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterActivatorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface AdapterActivatorOperations

  • All Known Subinterfaces:
    AdapterActivator

    public interface AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean unknown_adapter(POA parent, String name)
      This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.

    • Method Detail

      • unknown_adapter

        boolean unknown_adapter(POA parent,
                        String name)
        This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist. The ORB invokes this operation once for each POA that must be created in order for the target POA to exist.
        Parameters:
        parent - indicates the parent POA for the POA that needs to be created.
        name - identifies the name of the POA relative to the parent.
        Returns:
        returns TRUE if the POA was created or FALSE otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Current (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface Current

  • All Superinterfaces:
    Current, CurrentOperations, IDLEntity, Object, Serializable

    public interface Current
extends CurrentOperations, Current, IDLEntity
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.CurrentOperations

        get_object_id, get_POA

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class CurrentHelper

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • Constructor Summary

      Constructors
      Constructor and Description
      CurrentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Current value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CurrentHelper

        public CurrentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Current value)

      • narrow

        public static Current narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CurrentOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface CurrentOperations

  • All Superinterfaces:
    CurrentOperations
    All Known Subinterfaces:
    Current

    public interface CurrentOperations
extends CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] get_object_id()
      Returns the ObjectId identifying the object in whose context it is called.
      POA get_POA()
      Returns reference to the POA implementing the object in whose context it is called.

    • Method Detail

      • get_POA

        POA get_POA()
     throws NoContext
        Returns reference to the POA implementing the object in whose context it is called.
        Returns:
        The poa implementing the object
        Throws:
        NoContext - is raised when the operation is outside the context of a POA-dispatched operation

      • get_object_id

        byte[] get_object_id()
              throws NoContext
        Returns the ObjectId identifying the object in whose context it is called.
        Returns:
        the ObjectId of the object
        Throws:
        NoContext - is raised when the operation is called outside the context of a POA-dispatched operation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DynamicImplementation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class DynamicImplementation

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation

  • public abstract class DynamicImplementation
extends Servant
    Allows dynamic handling of object invocations. POA-based DSI servants inherit from the standard DynamicImplementation class, this class inherits from the Servant class. Based on IDL to Java spec. CORBA V 2.3.1 ptc/00-01-08.pdf.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynamicImplementation()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void invoke(ServerRequest request)
      Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.

      • Methods inherited from class org.omg.PortableServer.Servant

        _all_interfaces, _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynamicImplementation

        public DynamicImplementation()

    • Method Detail

      • invoke

        public abstract void invoke(ServerRequest request)
        Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
        Parameters:
        request - the request issued to the CORBA object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardRequest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ForwardRequest

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.ForwardRequest
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ForwardRequest
extends UserException
    org/omg/PortableServer/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object forward_reference

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequest()
      ForwardRequest(Object _forward_reference)
      ForwardRequest(String $reason, Object _forward_reference)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • forward_reference

        public Object forward_reference

    • Constructor Detail

      • ForwardRequest

        public ForwardRequest()

      • ForwardRequest

        public ForwardRequest(Object _forward_reference)

      • ForwardRequest

        public ForwardRequest(String $reason,
                      Object _forward_reference)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ForwardRequestHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ForwardRequestHelper

  • java.lang.Object
    • org.omg.PortableServer.ForwardRequestHelper

  • public abstract class ForwardRequestHelper
extends Object
    org/omg/PortableServer/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequestHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ForwardRequest | extract(Any a)
      static String | id()
      static void | insert(Any a, ForwardRequest that)
      static ForwardRequest | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ForwardRequest value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ForwardRequestHelper

        public ForwardRequestHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ForwardRequest that)

      • extract

        public static ForwardRequest extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ForwardRequest read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ForwardRequest value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdAssignmentPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdAssignmentPolicy

  • All Superinterfaces:
    IdAssignmentPolicyOperations, IDLEntity, Object, Policy, PolicyOperations, Serializable

    public interface IdAssignmentPolicy
extends IdAssignmentPolicyOperations, Policy, IDLEntity
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.IdAssignmentPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdAssignmentPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdAssignmentPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    IdAssignmentPolicy

    public interface IdAssignmentPolicyOperations
extends PolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      IdAssignmentPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        IdAssignmentPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdAssignmentPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class IdAssignmentPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.IdAssignmentPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class IdAssignmentPolicyValue
extends Object
implements IDLEntity
    The IdAssignmentPolicyValue can have the following values. USER_ID - Objects created with that POA are assigned Object Ids only by the application. SYSTEM_ID - Objects created with that POA are assigned Object Ids only by the POA. If the POA also has the PERSISTENT policy, assigned Object Ids must be unique across all instantiations of the same POA.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _SYSTEM_ID
      static int | _USER_ID
      static IdAssignmentPolicyValue | SYSTEM_ID
      static IdAssignmentPolicyValue | USER_ID

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | IdAssignmentPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static IdAssignmentPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _USER_ID

        public static final int _USER_ID
        See Also:
        Constant Field Values

      • USER_ID

        public static final IdAssignmentPolicyValue USER_ID

      • _SYSTEM_ID

        public static final int _SYSTEM_ID
        See Also:
        Constant Field Values

      • SYSTEM_ID

        public static final IdAssignmentPolicyValue SYSTEM_ID

    • Constructor Detail

      • IdAssignmentPolicyValue

        protected IdAssignmentPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static IdAssignmentPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdUniquenessPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdUniquenessPolicy

  • All Superinterfaces:
    IDLEntity, IdUniquenessPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface IdUniquenessPolicy
extends IdUniquenessPolicyOperations, Policy, IDLEntity
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.IdUniquenessPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdUniquenessPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdUniquenessPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    IdUniquenessPolicy

    public interface IdUniquenessPolicyOperations
extends PolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      IdUniquenessPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        IdUniquenessPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IdUniquenessPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class IdUniquenessPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.IdUniquenessPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class IdUniquenessPolicyValue
extends Object
implements IDLEntity
    IdUniquenessPolicyValue can have the following values. UNIQUE_ID - Servants activated with that POA support exactly one Object Id. MULTIPLE_ID - a servant activated with that POA may support one or more Object Ids.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _MULTIPLE_ID
      static int | _UNIQUE_ID
      static IdUniquenessPolicyValue | MULTIPLE_ID
      static IdUniquenessPolicyValue | UNIQUE_ID

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | IdUniquenessPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static IdUniquenessPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _UNIQUE_ID

        public static final int _UNIQUE_ID
        See Also:
        Constant Field Values

      • UNIQUE_ID

        public static final IdUniquenessPolicyValue UNIQUE_ID

      • _MULTIPLE_ID

        public static final int _MULTIPLE_ID
        See Also:
        Constant Field Values

      • MULTIPLE_ID

        public static final IdUniquenessPolicyValue MULTIPLE_ID

    • Constructor Detail

      • IdUniquenessPolicyValue

        protected IdUniquenessPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static IdUniquenessPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ID_ASSIGNMENT_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ID_ASSIGNMENT_POLICY_ID

  • public interface ID_ASSIGNMENT_POLICY_ID
    org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing ID_ASSIGNMENT_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing ID_ASSIGNMENT_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ID_UNIQUENESS_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ID_UNIQUENESS_POLICY_ID

  • public interface ID_UNIQUENESS_POLICY_ID
    org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing ID_UNIQUENESS_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing ID_UNIQUENESS_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ImplicitActivationPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ImplicitActivationPolicy

  • All Superinterfaces:
    IDLEntity, ImplicitActivationPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface ImplicitActivationPolicy
extends ImplicitActivationPolicyOperations, Policy, IDLEntity
    This policy specifies whether implicit activation of servants is supported in the created POA.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ImplicitActivationPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ImplicitActivationPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ImplicitActivationPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ImplicitActivationPolicy

    public interface ImplicitActivationPolicyOperations
extends PolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ImplicitActivationPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        ImplicitActivationPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ImplicitActivationPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ImplicitActivationPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ImplicitActivationPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ImplicitActivationPolicyValue
extends Object
implements IDLEntity
    ImplicitActivationPolicyValue has the following semantics. IMPLICIT_ACTIVATION to indicate implicit activation of servants. This requires SYSTEM_ID and RETAIN policies to be set. NO_IMPLICIT_ACTIVATION to indicate no implicit servant activation.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _IMPLICIT_ACTIVATION
      static int | _NO_IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | NO_IMPLICIT_ACTIVATION

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ImplicitActivationPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ImplicitActivationPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _IMPLICIT_ACTIVATION

        public static final int _IMPLICIT_ACTIVATION
        See Also:
        Constant Field Values

      • IMPLICIT_ACTIVATION

        public static final ImplicitActivationPolicyValue IMPLICIT_ACTIVATION

      • _NO_IMPLICIT_ACTIVATION

        public static final int _NO_IMPLICIT_ACTIVATION
        See Also:
        Constant Field Values

      • NO_IMPLICIT_ACTIVATION

        public static final ImplicitActivationPolicyValue NO_IMPLICIT_ACTIVATION

    • Constructor Detail

      • ImplicitActivationPolicyValue

        protected ImplicitActivationPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ImplicitActivationPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


IMPLICIT_ACTIVATION_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IMPLICIT_ACTIVATION_POLICY_ID

  • public interface IMPLICIT_ACTIVATION_POLICY_ID
    org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing IMPLICIT_ACTIVATION_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing IMPLICIT_ACTIVATION_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LifespanPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface LifespanPolicy

  • All Superinterfaces:
    IDLEntity, LifespanPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface LifespanPolicy
extends LifespanPolicyOperations, Policy, IDLEntity
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.LifespanPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LifespanPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface LifespanPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    LifespanPolicy

    public interface LifespanPolicyOperations
extends PolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LifespanPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        LifespanPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LifespanPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class LifespanPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.LifespanPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class LifespanPolicyValue
extends Object
implements IDLEntity
    The LifespanPolicyValue can have the following values. TRANSIENT - The objects implemented in the POA cannot outlive the POA instance in which they are first created. PERSISTENT - The objects implemented in the POA can outlive the process in which they are first created.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _PERSISTENT
      static int | _TRANSIENT
      static LifespanPolicyValue | PERSISTENT
      static LifespanPolicyValue | TRANSIENT

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | LifespanPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static LifespanPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _TRANSIENT

        public static final int _TRANSIENT
        See Also:
        Constant Field Values

      • TRANSIENT

        public static final LifespanPolicyValue TRANSIENT

      • _PERSISTENT

        public static final int _PERSISTENT
        See Also:
        Constant Field Values

      • PERSISTENT

        public static final LifespanPolicyValue PERSISTENT

    • Constructor Detail

      • LifespanPolicyValue

        protected LifespanPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static LifespanPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LIFESPAN_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface LIFESPAN_POLICY_ID

  • public interface LIFESPAN_POLICY_ID
    org/omg/PortableServer/LIFESPAN_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing LIFESPAN_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing LIFESPAN_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer (Java Platform SE 8 )

org.omg.PortableServer

Interfaces

  • AdapterActivator
  • AdapterActivatorOperations
  • Current
  • CurrentOperations
  • ID_ASSIGNMENT_POLICY_ID
  • ID_UNIQUENESS_POLICY_ID
  • IdAssignmentPolicy
  • IdAssignmentPolicyOperations
  • IdUniquenessPolicy
  • IdUniquenessPolicyOperations
  • IMPLICIT_ACTIVATION_POLICY_ID
  • ImplicitActivationPolicy
  • ImplicitActivationPolicyOperations
  • LIFESPAN_POLICY_ID
  • LifespanPolicy
  • LifespanPolicyOperations
  • POA
  • POAManager
  • POAManagerOperations
  • POAOperations
  • REQUEST_PROCESSING_POLICY_ID
  • RequestProcessingPolicy
  • RequestProcessingPolicyOperations
  • SERVANT_RETENTION_POLICY_ID
  • ServantActivator
  • ServantActivatorOperations
  • ServantLocator
  • ServantLocatorOperations
  • ServantManager
  • ServantManagerOperations
  • ServantRetentionPolicy
  • ServantRetentionPolicyOperations
  • THREAD_POLICY_ID
  • ThreadPolicy
  • ThreadPolicyOperations

Classes

  • _ServantActivatorStub
  • _ServantLocatorStub
  • CurrentHelper
  • DynamicImplementation
  • ForwardRequestHelper
  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • POAHelper
  • RequestProcessingPolicyValue
  • Servant
  • ServantActivatorHelper
  • ServantActivatorPOA
  • ServantLocatorHelper
  • ServantLocatorPOA
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Exceptions

  • ForwardRequest


org.omg.PortableServer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

See: Description

  • Interface Summary
    Interface Description
    AdapterActivator
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    Current
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    ID_ASSIGNMENT_POLICY_ID
    org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java .
    ID_UNIQUENESS_POLICY_ID
    org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java .
    IdAssignmentPolicy
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdUniquenessPolicy
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IMPLICIT_ACTIVATION_POLICY_ID
    org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java .
    ImplicitActivationPolicy
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.
    LIFESPAN_POLICY_ID
    org/omg/PortableServer/LIFESPAN_POLICY_ID.java .
    LifespanPolicy
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    POA
    A POA object manages the implementation of a collection of objects.
    POAManager
    Each POA object has an associated POAManager object.
    POAManagerOperations
    Each POA object has an associated POAManager object.
    POAOperations
    A POA object manages the implementation of a collection of objects.
    REQUEST_PROCESSING_POLICY_ID
    org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java .
    RequestProcessingPolicy
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyOperations
    This policy specifies how requests are processed by the created POA.
    SERVANT_RETENTION_POLICY_ID
    org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java .
    ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantManager
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantRetentionPolicy
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    THREAD_POLICY_ID
    org/omg/PortableServer/THREAD_POLICY_ID.java .
    ThreadPolicy
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA.
  • Class Summary
    Class Description
    _ServantActivatorStub
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    _ServantLocatorStub
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    CurrentHelper
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    DynamicImplementation
    Allows dynamic handling of object invocations.
    ForwardRequestHelper
    org/omg/PortableServer/ForwardRequestHelper.java .
    IdAssignmentPolicyValue
    The IdAssignmentPolicyValue can have the following values.
    IdUniquenessPolicyValue
    IdUniquenessPolicyValue can have the following values.
    ImplicitActivationPolicyValue
    ImplicitActivationPolicyValue has the following semantics.
    LifespanPolicyValue
    The LifespanPolicyValue can have the following values.
    POAHelper
    A POA object manages the implementation of a collection of objects.
    RequestProcessingPolicyValue
    The RequestProcessingPolicyValue can have the following values.
    Servant
    Defines the native Servant type.
    ServantActivatorHelper
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorPOA
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocatorHelper
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorPOA
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantRetentionPolicyValue
    ServantRetentionPolicyValue can have the following values.
    ThreadPolicyValue
    The ThreadPolicyValue can have the following values.
  • Exception Summary
    Exception Description
    ForwardRequest
    org/omg/PortableServer/ForwardRequest.java .

Package org.omg.PortableServer Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

In Java, Portable Object Adaptor (POA)-based Dynamic Skeleton Interface (DSI) servants inherit from the standard DynamicImplementation class, which inherits from the Servant class. The native Servant type is defined by the PortableServer module for the POA. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

POA-related Interfaces

The PortableServer module defines the following POA-related interfaces:

  • POA
  • POAManager
  • ServantManager
  • ServantActivator
  • ServantLocator
  • AdapterActivator
  • ThreadPolicy
  • LifespanPolicy
  • IdUniquenessPolicy
  • IdAssignmentPolicy
  • ImplicitActivationPolicy
  • ServantRetentionPolicy
  • RequestProcessingPolicy
  • Current

In addition, the POA defines the Servant native type.

Operations classes

Each of the interfaces listed above has an associated Operations interface. The Operations interface is generated by the idlj compiler and contains the method signatures for methods defined in its associated interface. The Operations interface can be accessed by both the client and the server, while its associated interface can only be called by the client.

Value Classes

Classes ending in the suffix PolicyValue provide the values used for the create_POA call, which sets the policy for the POA. See the sample code below for a demonstration. PolicyValue files include the following:

  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • RequestProcessingPolicyValue
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types. There is only one method in a helper class that an application programmer uses: the narrow method. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the PortableServer package, only the following classes have a narrow method:

  • ForwardRequestHelper
  • ServantActivatorHelper
  • ServantLocatorHelper

POA Classes

POA classes are used to implement the ServantActivator or ServantLocator.

Exceptions

The ForwardRequest exception indicates to the ORB that it is responsible for delivering the current request and subsequent ForwardRequest requests to the object denoted in the forward_reference member of the exception.

Interfaces Implemented by the Application Programmer

Most of what PortableServer does is transparent to the user. The result is that programmers will use only a few of the interfaces mentioned above. The remaining interfaces will be provided by the ORB implementation. The interfaces of interest to application programmers are the following:

  • AdapterActivator

    Adapter activators are associated with POAs. An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE. An application server that creates all its needed POAs at the beginning of execution does not need to use or provide an adapter activator; it is necessary only for the case in which POAs need to be created during request processing.

  • ServantLocator

    When the POA has the NON_RETAIN policy, it uses servant managers that are ServantLocators.

  • ServantActivator

    When the POA has the RETAIN policy, it uses servant managers that are ServantActivators.

Package org.omg.PortableServer.ServantLocatorPackage

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Related Documentation

For an overview of Java IDL, please see:

  • Java IDL home page.

    Example Code

    Example Server Code

    import javax.naming.InitialContext;
import javax.naming.Context;
import javax.rmi.PortableRemoteObject ;
import com.sun.corba.se.impl.poa.POAORB;
import org.omg.PortableServer.*;
import java.util.*;
import org.omg.CORBA.*;
import javax.rmi.CORBA.Stub;
import javax.rmi.CORBA.Util;

public class HelloServer {
    public HelloServer(String[] args) {
        try {
            Properties p = System.getProperties();
         //   p.put("org.omg.CORBA.ORBClass", "com.sun.corba.ee.internal.POA.POAORB");
            ORB orb = ORB.init( args, p );

            POA rootPOA = (POA)orb.resolve_initial_references("RootPOA");

            Policy[] tpolicy = new Policy[3];
            tpolicy[0] = rootPOA.create_lifespan_policy(
                LifespanPolicyValue.TRANSIENT );
            tpolicy[1] = rootPOA.create_request_processing_policy(
                RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY );
            tpolicy[2] = rootPOA.create_servant_retention_policy(
                ServantRetentionPolicyValue.RETAIN);
            POA tpoa = rootPOA.create_POA("MyTransientPOA", null, tpolicy);

            String  ObjectId = "MyObjectId";
            byte[] oid = ObjectId.getBytes();

            org.omg.CORBA.Object obj = tpoa.create_reference_with_id(oid,
                new _HelloImpl_Tie()._all_interfaces(tpoa, oid)[0]);
            HelloInterface helloRef = (HelloInterface)PortableRemoteObject.narrow(
                obj, HelloInterface.class );

            Context initialNamingContext = new InitialContext();
            initialNamingContext.rebind("HelloService", helloRef);
            System.out.println("Hello Server: Ready...");
            orb.run();
         } catch (Exception e) {
            System.out.println("Trouble: " + e);
            e.printStackTrace();
         }
     }

     public static void main(String args[]) {
         new HelloServer( args );
     }
}

    • Since:
    1.4
    Skip navigation links
    • Overview
    • Package
    • Class
    • Use
    • Tree
    • Deprecated
    • Index
    • Help
    Java™ Platform
    Standard Ed. 8
    • Prev Package
    • Next Package
    • Frames
    • No Frames
    • All Classes

    Submit a bug or feature
    For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
    Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
    • org.omg.PortableServer.POAHelper
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.ForwardRequest

Interface Hierarchy

  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.POA (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.THREAD_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableServer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer

  • Packages that use org.omg.PortableServer
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer used by org.omg.CosNaming
    Class and Description
    POA
    A POA object manages the implementation of a collection of objects.
    Servant
    Defines the native Servant type.
  • Classes in org.omg.PortableServer used by org.omg.PortableServer
    Class and Description
    AdapterActivator
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    Current
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    ForwardRequest
    org/omg/PortableServer/ForwardRequest.java .
    IdAssignmentPolicy
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyValue
    The IdAssignmentPolicyValue can have the following values.
    IdUniquenessPolicy
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyValue
    IdUniquenessPolicyValue can have the following values.
    ImplicitActivationPolicy
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyValue
    ImplicitActivationPolicyValue has the following semantics.
    LifespanPolicy
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyValue
    The LifespanPolicyValue can have the following values.
    POA
    A POA object manages the implementation of a collection of objects.
    POAManager
    Each POA object has an associated POAManager object.
    POAManagerOperations
    Each POA object has an associated POAManager object.
    POAOperations
    A POA object manages the implementation of a collection of objects.
    RequestProcessingPolicy
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyOperations
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyValue
    The RequestProcessingPolicyValue can have the following values.
    Servant
    Defines the native Servant type.
    ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantManager
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantRetentionPolicy
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyValue
    ServantRetentionPolicyValue can have the following values.
    ThreadPolicy
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyValue
    The ThreadPolicyValue can have the following values.
  • Classes in org.omg.PortableServer used by org.omg.PortableServer.portable
    Class and Description
    POA
    A POA object manages the implementation of a collection of objects.
    Servant
    Defines the native Servant type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


POA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POA

  • All Superinterfaces:
    IDLEntity, Object, POAOperations, Serializable

    public interface POA
extends POAOperations, Object, IDLEntity
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.POAOperations

        activate_object_with_id, activate_object, create_id_assignment_policy, create_id_uniqueness_policy, create_implicit_activation_policy, create_lifespan_policy, create_POA, create_reference_with_id, create_reference, create_request_processing_policy, create_servant_retention_policy, create_thread_policy, deactivate_object, destroy, find_POA, get_servant_manager, get_servant, id_to_reference, id_to_servant, id, reference_to_id, reference_to_servant, servant_to_id, servant_to_reference, set_servant_manager, set_servant, the_activator, the_activator, the_children, the_name, the_parent, the_POAManager

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


POAHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class POAHelper

  • java.lang.Object
    • org.omg.PortableServer.POAHelper

  • public abstract class POAHelper
extends Object
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • Constructor Summary

      Constructors
      Constructor and Description
      POAHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static POA | extract(Any a)
      static String | id()
      static void | insert(Any a, POA that)
      static POA | narrow(Object obj)
      static POA | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, POA value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • POAHelper

        public POAHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          POA that)

      • extract

        public static POA extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static POA read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         POA value)

      • narrow

        public static POA narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


POAManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAManager

  • All Superinterfaces:
    IDLEntity, Object, POAManagerOperations, Serializable

    public interface POAManager
extends POAManagerOperations, Object, IDLEntity
    Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.POAManagerOperations

        activate, deactivate, discard_requests, get_state, hold_requests

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


POAManagerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAManagerOperations

  • All Known Subinterfaces:
    POAManager

    public interface POAManagerOperations
    Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void activate()
      This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
      void deactivate(boolean etherealize_objects, boolean wait_for_completion)
      This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
      void discard_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to discarding.
      State get_state()
      This operation returns the state of the POA manager.
      void hold_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

    • Method Detail

      • activate

        void activate()
       throws AdapterInactive
        This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • hold_requests

        void hold_requests(boolean wait_for_completion)
            throws AdapterInactive
        This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.
        Parameters:
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • discard_requests

        void discard_requests(boolean wait_for_completion)
               throws AdapterInactive
        This operation changes the state of the POA manager to discarding. This causes associated POAs to discard incoming requests.
        Parameters:
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • deactivate

        void deactivate(boolean etherealize_objects,
                boolean wait_for_completion)
         throws AdapterInactive
        This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
        Parameters:
        etherealize_objects - a flag to indicate whether to invoke the etherealize operation of the associated servant manager for all active objects.
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • get_state

        State get_state()
        This operation returns the state of the POA manager.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


POAOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAOperations

  • All Known Subinterfaces:
    POA

    public interface POAOperations
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      POA create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
      Object create_reference_with_id(byte[] oid, String intf)
      This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
      Object create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ThreadPolicy create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      void deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      void destroy(boolean etherealize_objects, boolean wait_for_completion)
      This operation destroys the POA and all descendant POAs.
      POA find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
      ServantManager get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Servant get_servant()
      This operation returns the default servant associated with the POA.
      Object id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] id()
      This returns the unique id of the POA in the process in which it is created.
      byte[] reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
      void set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.
      AdapterActivator the_activator()
      This attribute identifies the adapter activator associated with the POA.
      void the_activator(AdapterActivator newThe_activator)
      This attribute identifies the adapter activator associated with the POA.
      POA[] the_children()
      This attribute identifies the current set of all child POAs of the POA.
      String the_name()
      This attribute identifies the POA relative to its parent.
      POA the_parent()
      This attribute identifies the parent of the POA.
      POAManager the_POAManager()
      This attribute identifies the POA manager associated with the POA.

    • Method Detail

      • create_POA

        POA create_POA(String adapter_name,
               POAManager a_POAManager,
               Policy[] policies)
        throws AdapterAlreadyExists,
               InvalidPolicy
        This operation creates a new POA as a child of the target POA.
        Parameters:
        adapter_name - identifies the new POA with respect to other POAs with the same parent POA.
        a_POAManager - specifies the POA Manager to be associated with the new POA.
        policies - specifies policy objects to be associated with the POA to control its behavior.
        Throws:
        AdapterAlreadyExists - specifies that the target POA already has a child POA with the specified name.
        InvalidPolicy - is raised if any of the policy objects are not valid for the ORB, or are in conflict, or require an administrative action that has not been performed.

      • find_POA

        POA find_POA(String adapter_name,
             boolean activate_it)
      throws AdapterNonExistent
        If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
        Parameters:
        adapter_name - POA name to be found.
        activate_it - if a POA with the specified name does not exist and the value of the activate_it parameter is TRUE, the target POA's AdapterActivator, if one exists, is invoked.
        Returns:
        POA if one exists or is activated by the AdapterActivator.
        Throws:
        AdapterNonExistent

      • destroy

        void destroy(boolean etherealize_objects,
             boolean wait_for_completion)
        This operation destroys the POA and all descendant POAs. All descendant POAs are destroyed (recursively) before the destruction of the containing POA. The POA so destroyed (that is, the POA with its name) may be re-created later in the same process.
        Parameters:
        etherealize_objects - flag to indicate whether etherealize operation on servant manager needs to be called.
        wait_for_completion - flag to indicate whether POA and its children need to wait for active requests and the etherealization to complete.

      • create_thread_policy

        ThreadPolicy create_thread_policy(ThreadPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        ThreadPolcy Object

      • create_lifespan_policy

        LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        LifespanPolicy Object.

      • create_id_uniqueness_policy

        IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        IdUniquenessPolicy Object.

      • create_id_assignment_policy

        IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        IdAssignmentPolicy Object.

      • create_implicit_activation_policy

        ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        ImplicitActivationPolicy Object.

      • create_servant_retention_policy

        ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        ServantRetentionPolicy Object.

      • create_request_processing_policy

        RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        RequestProcessingPolicy Object.

      • the_name

        String the_name()
        This attribute identifies the POA relative to its parent. This name is assigned when the POA is created.

      • the_parent

        POA the_parent()
        This attribute identifies the parent of the POA. The parent of the root POA is null.

      • the_children

        POA[] the_children()
        This attribute identifies the current set of all child POAs of the POA. The set of child POAs includes only the POA's immediate children, and not their descendants.

      • the_POAManager

        POAManager the_POAManager()
        This attribute identifies the POA manager associated with the POA.

      • the_activator

        AdapterActivator the_activator()
        This attribute identifies the adapter activator associated with the POA.

      • the_activator

        void the_activator(AdapterActivator newThe_activator)
        This attribute identifies the adapter activator associated with the POA.

      • get_servant_manager

        ServantManager get_servant_manager()
                            throws WrongPolicy
        If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface. For a NON_RETAIN policy, the ServantManager shall support the ServantLocator interface. If the argument is nil, or does not support the required interface, then the OBJ_ADAPTER exception is raised.
        Returns:
        ServantManager associated with a POA or null if none exists.
        Throws:
        WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

      • set_servant_manager

        void set_servant_manager(ServantManager imgr)
                  throws WrongPolicy
        This operation sets the default servant manager associated with the POA. This operation may only be invoked once after a POA has been created. Attempting to set the servant manager after one has already been set will result in the BAD_INV_ORDER exception being raised.
        Parameters:
        imgr - servant manager to be used as a default.
        Throws:
        WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

      • get_servant

        Servant get_servant()
             throws NoServant,
                    WrongPolicy
        This operation returns the default servant associated with the POA.
        Returns:
        p_servant default servant associated with a POA.
        Throws:
        NoServant - raised if no default servant is associated with the POA.
        WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

      • set_servant

        void set_servant(Servant p_servant)
          throws WrongPolicy
        This operation registers the specified servant with the POA as the default servant. This servant will be used for all requests for which no servant is found in the Active Object Map.
        Parameters:
        p_servant - servant to be used as a default.
        Throws:
        WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

      • activate_object

        byte[] activate_object(Servant p_servant)
                throws ServantAlreadyActive,
                       WrongPolicy
        This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
        Parameters:
        p_servant - servant to be associated with an object to be activated.
        Returns:
        POA generated object id.
        Throws:
        ServantAlreadyActive - is raised if the POA has UNIQUE_ID policy and servant is is already in the Active Object Map.
        WrongPolicy - raised if the SYSTEM_ID and RETAIN policies are not specified.

      • activate_object_with_id

        void activate_object_with_id(byte[] id,
                             Servant p_servant)
                      throws ServantAlreadyActive,
                             ObjectAlreadyActive,
                             WrongPolicy
        This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
        Parameters:
        id - object id for the object to be activated.
        p_servant - servant to be associated with the object.
        Throws:
        ServantAlreadyActive - raised if the POA has the UNIQUE_ID policy and the servant is already in the Active Object Map.
        ObjectAlreadyActive - raised if the object is already active in the POA.
        WrongPolicy - raised if the RETAIN policy is is not specified.

      • deactivate_object

        void deactivate_object(byte[] oid)
                throws ObjectNotActive,
                       WrongPolicy
        This operation causes the ObjectId specified in the oid parameter to be deactivated. An ObjectId which has been deactivated continues to process requests until there are no active requests for that ObjectId. A deactivated ObjectId is removed from the Active Object Map when all requests executing for that ObjectId have completed.
        Parameters:
        oid - Object Id for the object to be deactivated.
        Throws:
        ObjectNotActive - if the object with the specified oid is not in the Active Object Map.
        WrongPolicy - raised if the RETAIN policy is is not specified.

      • create_reference

        Object create_reference(String intf)
                 throws WrongPolicy
        This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
        Parameters:
        intf - rep id for creating an object reference.
        Returns:
        object reference created using intf.
        Throws:
        WrongPolicy - if SYSTEM_ID policy is not specified.

      • create_reference_with_id

        Object create_reference_with_id(byte[] oid,
                                String intf)
        This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values. It does not cause an activation to take place. The resulting reference may be passed to clients, so that subsequent requests on those references will cause the object to be activated if necessary, or the default servant used, depending on the applicable policies.
        Parameters:
        oid - object id for creating an objref
        intf - rep id for creating an objref
        Returns:
        object reference created using oid and intf
        Throws:
        BAD_PARAM - is raised if the POA has the SYSTEM_ID policy and it detects that the Object Id value was not generated by the system or for this POA.

      • servant_to_id

        byte[] servant_to_id(Servant p_servant)
              throws ServantNotActive,
                     WrongPolicy
        This operation has four possible behaviors. 1. If the POA has the UNIQUE_ID policy and the specified servant is active, the Object Id associated with that servant is returned. 2. If the POA has the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and that Object Id is returned. 3. If the POA has the USE_DEFAULT_SERVANT policy, the servant specified is the default servant, and the operation is being invoked in the context of executing a request on the default servant, then the ObjectId associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.
        Parameters:
        p_servant - servant for which the object disi returned.
        Returns:
        object id associated with the servant.
        Throws:
        ServantNotActive - if the above rules and policy combination is not met.
        WrongPolicy - if the USE_DEFAULT_SERVANT policy or a combination of the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies are not present.

      • servant_to_reference

        Object servant_to_reference(Servant p_servant)
                     throws ServantNotActive,
                            WrongPolicy
        This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA. It has four possible behaviors. 1. If the POA has both the RETAIN and the UNIQUE_ID policy and the specified servant is active, an object reference encapsulating the information used to activate the servant is returned. 2. If the POA has both the RETAIN and the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and a corresponding object reference is returned. 3. If the operation was invoked in the context of executing a request on the specified servant, the reference associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.
        Parameters:
        p_servant - servant for which the object reference needs to be obtained.
        Returns:
        object reference associated with the servant.
        Throws:
        WrongPolicy - if the operation is not invoked in the context of executing a request on the specified servant and the required policies are not present.
        ServantNotActive - if the above specified policies and rules are not met.

      • reference_to_servant

        Servant reference_to_servant(Object reference)
                      throws ObjectNotActive,
                             WrongPolicy,
                             WrongAdapter
        If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant. If the object reference was not created by this POA, the WrongAdapter exception is raised. (OMG Issue on inconsistency with the POA.IDL.
        Parameters:
        reference - object reference for which the servant is returned.
        Returns:
        servant associated with the reference.
        Throws:
        WrongPolicy - if neither the RETAIN policy or the USE_DEFAULT_SERVANT policy is present.
        ObjectNotActive - if the servant is not present in the Active Object Map (for RETAIN) or no default servant is registered (for USE_DEFAULT_POLICY).
        WrongAdapter - if reference was not created by this POA instance.

      • reference_to_id

        byte[] reference_to_id(Object reference)
                throws WrongAdapter,
                       WrongPolicy
        This operation returns the Object Id value encapsulated by the specified reference. This operation is valid only if the reference was created by the POA on which the operation is being performed. The object denoted by the reference does not have to be active for this operation to succeed.
        Parameters:
        reference - the object reference from which the object id needs to be returned.
        Returns:
        object id encapsulated in the reference.
        Throws:
        WrongAdapter - if the reference was not created by the POA specified in the reference.
        WrongPolicy - declared to allow future extensions.

      • id_to_servant

        Servant id_to_servant(byte[] oid)
               throws ObjectNotActive,
                      WrongPolicy
        If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant.
        Parameters:
        oid - object id for the which the servant is returned.
        Returns:
        servant associated with oid.
        Throws:
        ObjectNotActive - is raised if ObjectId is is not in the Active Object Map (for RETAIN policy), or no default servant is registered (for USE_DEFAULT_SERVANT policy).
        WrongPolicy - is raised if the RETAIN policy or the USE_DEFAULT_SERVANT policy is not present.

      • id_to_reference

        Object id_to_reference(byte[] oid)
                throws ObjectNotActive,
                       WrongPolicy
        If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
        Parameters:
        oid - id of the object for which the reference is returned.
        Returns:
        the object reference
        Throws:
        ObjectNotActive - if the Object Id value is not active in the POA.
        WrongPolicy - if the RETAIN policy is not present.

      • id

        byte[] id()
        This returns the unique id of the POA in the process in which it is created. It is for use by portable interceptors.

        This id is guaranteed unique for the life span of the POA in the process. For persistent POAs, this means that if a POA is created in the same path with the same name as another POA, these POAs are identical and, therefore, have the same id. For transient POAs, each POA is unique.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RequestProcessingPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface RequestProcessingPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, RequestProcessingPolicyOperations, Serializable

    public interface RequestProcessingPolicy
extends RequestProcessingPolicyOperations, Policy, IDLEntity
    This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.RequestProcessingPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RequestProcessingPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface RequestProcessingPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    RequestProcessingPolicy

    public interface RequestProcessingPolicyOperations
extends PolicyOperations
    This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      RequestProcessingPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        RequestProcessingPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RequestProcessingPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class RequestProcessingPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.RequestProcessingPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class RequestProcessingPolicyValue
extends Object
implements IDLEntity
    The RequestProcessingPolicyValue can have the following values. USE_ACTIVE_OBJECT_MAP_ONLY - If the Object Id is not found in the Active Object Map, an OBJECT_NOT_EXIST exception is returned to the client. The RETAIN policy is also required. USE_DEFAULT_SERVANT - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a default servant has been registered with the POA using the set_servant operation, the request is dispatched to the default servant. USE_SERVANT_MANAGER - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a servant manager has been registered with the POA using the set_servant_manager operation, the servant manager is given the opportunity to locate a servant or raise an exception.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _USE_ACTIVE_OBJECT_MAP_ONLY
      static int | _USE_DEFAULT_SERVANT
      static int | _USE_SERVANT_MANAGER
      static RequestProcessingPolicyValue | USE_ACTIVE_OBJECT_MAP_ONLY
      static RequestProcessingPolicyValue | USE_DEFAULT_SERVANT
      static RequestProcessingPolicyValue | USE_SERVANT_MANAGER

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | RequestProcessingPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static RequestProcessingPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _USE_ACTIVE_OBJECT_MAP_ONLY

        public static final int _USE_ACTIVE_OBJECT_MAP_ONLY
        See Also:
        Constant Field Values

      • USE_ACTIVE_OBJECT_MAP_ONLY

        public static final RequestProcessingPolicyValue USE_ACTIVE_OBJECT_MAP_ONLY

      • _USE_DEFAULT_SERVANT

        public static final int _USE_DEFAULT_SERVANT
        See Also:
        Constant Field Values

      • USE_DEFAULT_SERVANT

        public static final RequestProcessingPolicyValue USE_DEFAULT_SERVANT

      • _USE_SERVANT_MANAGER

        public static final int _USE_SERVANT_MANAGER
        See Also:
        Constant Field Values

      • USE_SERVANT_MANAGER

        public static final RequestProcessingPolicyValue USE_SERVANT_MANAGER

    • Constructor Detail

      • RequestProcessingPolicyValue

        protected RequestProcessingPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static RequestProcessingPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


REQUEST_PROCESSING_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface REQUEST_PROCESSING_POLICY_ID

  • public interface REQUEST_PROCESSING_POLICY_ID
    org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing REQUEST_PROCESSING_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing REQUEST_PROCESSING_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Servant (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class Servant

  • java.lang.Object
    • org.omg.PortableServer.Servant
  • Direct Known Subclasses:
    BindingIteratorPOA, DynamicImplementation, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA

    public abstract class Servant
extends Object
    Defines the native Servant type. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior. Based on IDL to Java spec. (CORBA V2.3.1) ptc/00-01-08.pdf.

    • Constructor Summary

      Constructors
      Constructor and Description
      Servant()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      POA _default_POA()
      Returns the root POA from the ORB instance associated with the servant.
      Delegate _get_delegate()
      Gets the ORB vendor-specific implementation of PortableServer::Servant.
      Object _get_interface_def()
      Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
      boolean _is_a(String repository_id)
      Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
      boolean _non_existent()
      Checks for the existence of an Object.
      byte[] _object_id()
      Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
      ORB _orb()
      Returns the instance of the ORB currently associated with the Servant (convenience method).
      POA _poa()
      Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
      void _set_delegate(Delegate delegate)
      Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
      Object _this_object()
      Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
      Object _this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Servant

        public Servant()

    • Method Detail

      • _get_delegate

        public final Delegate _get_delegate()
        Gets the ORB vendor-specific implementation of PortableServer::Servant.
        Returns:
        _delegate the ORB vendor-specific implementation of PortableServer::Servant.

      • _set_delegate

        public final void _set_delegate(Delegate delegate)
        Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
        Parameters:
        delegate - ORB vendor-specific implementation of the PortableServer::Servant.

      • _this_object

        public final Object _this_object()
        Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
        Returns:
        this_object Object reference associated with the request.

      • _this_object

        public final Object _this_object(ORB orb)
        Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
        Parameters:
        orb - ORB with which the servant is associated.
        Returns:
        _this_object reference associated with the request.

      • _orb

        public final ORB _orb()
        Returns the instance of the ORB currently associated with the Servant (convenience method).
        Returns:
        orb the instance of the ORB currently associated with the Servant.

      • _poa

        public final POA _poa()
        Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
        Returns:
        poa POA associated with the servant.

      • _object_id

        public final byte[] _object_id()
        Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
        Returns:
        object_id the Object ID associated with this servant.

      • _default_POA

        public POA _default_POA()
        Returns the root POA from the ORB instance associated with the servant. Subclasses may override this method to return a different POA.
        Returns:
        default_POA the POA associated with the Servant.

      • _is_a

        public boolean _is_a(String repository_id)
        Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
        Parameters:
        repository_id - the repository_id to be checked in the repository list or against the id of generic CORBA objects.
        Returns:
        is_a boolean indicating whether the specified repository_id is in the repository list or is same as a generic CORBA object.

      • _non_existent

        public boolean _non_existent()
        Checks for the existence of an Object. The Servant provides a default implementation of _non_existent() that can be overridden by derived servants.
        Returns:
        non_existent true if that object does not exist, false otherwise.

      • _get_interface_def

        public Object _get_interface_def()
        Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant. The invoker of _get_interface_def must narrow the result to an InterfaceDef in order to use it.

        This default implementation of _get_interface_def() can be overridden by derived servants if the default behavior is not adequate. As defined in the CORBA 2.3.1 specification, section 11.3.1, the default behavior of _get_interface_def() is to use the most derived interface of a static servant or the most derived interface retrieved from a dynamic servant to obtain the InterfaceDef. This behavior must be supported by the Delegate that implements the Servant.

        Returns:
        get_interface_def an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.

      • _all_interfaces

        public abstract String[] _all_interfaces(POA poa,
                                         byte[] objectId)
        Used by the ORB to obtain complete type information from the servant.
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantActivator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantActivator

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantActivatorOperations, ServantManager, ServantManagerOperations
    All Known Implementing Classes:
    _ServantActivatorStub

    public interface ServantActivator
extends ServantActivatorOperations, ServantManager, IDLEntity
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ServantActivatorOperations

        etherealize, incarnate

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantActivatorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantActivatorHelper

  • java.lang.Object
    • org.omg.PortableServer.ServantActivatorHelper

  • public abstract class ServantActivatorHelper
extends Object
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantActivatorHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantActivator | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantActivator that)
      static ServantActivator | narrow(Object obj)
      static ServantActivator | read(InputStream istream)
      static TypeCode | type()
      static ServantActivator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, ServantActivator value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantActivatorHelper

        public ServantActivatorHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantActivator that)

      • extract

        public static ServantActivator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantActivator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantActivator value)

      • narrow

        public static ServantActivator narrow(Object obj)

      • unchecked_narrow

        public static ServantActivator unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantActivatorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantActivatorOperations

  • All Superinterfaces:
    ServantManagerOperations
    All Known Subinterfaces:
    ServantActivator
    All Known Implementing Classes:
    _ServantActivatorStub, ServantActivatorPOA

    public interface ServantActivatorOperations
extends ServantManagerOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

    • Method Detail

      • incarnate

        Servant incarnate(byte[] oid,
                  POA adapter)
           throws ForwardRequest
        This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Parameters:
        oid - object Id associated with the object on the request was made.
        adapter - object reference for the POA in which the object is being activated.
        Returns:
        Servant corresponding to oid is created or located by the user supplied servant manager.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • etherealize

        void etherealize(byte[] oid,
                 POA adapter,
                 Servant serv,
                 boolean cleanup_in_progress,
                 boolean remaining_activations)
        This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Parameters:
        oid - object Id associated with the object being deactivated.
        adapter - object reference for the POA in which the object was active.
        serv - contains reference to the servant associated with the object being deactivated.
        cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
        remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantActivatorPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantActivatorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.ServantActivatorPOA
  • All Implemented Interfaces:
    InvokeHandler, ServantActivatorOperations, ServantManagerOperations

    public abstract class ServantActivatorPOA
extends Servant
implements ServantActivatorOperations, InvokeHandler
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantActivatorPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      ServantActivator _this()
      ServantActivator | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.PortableServer.ServantActivatorOperations

        etherealize, incarnate

    • Constructor Detail

      • ServantActivatorPOA

        public ServantActivatorPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public ServantActivator _this()

      • _this

        public ServantActivator _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantLocator

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantLocatorOperations, ServantManager, ServantManagerOperations
    All Known Implementing Classes:
    _ServantLocatorStub

    public interface ServantLocator
extends ServantLocatorOperations, ServantManager, IDLEntity
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ServantLocatorOperations

        postinvoke, preinvoke

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantLocatorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantLocatorHelper

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorHelper

  • public abstract class ServantLocatorHelper
extends Object
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantLocatorHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantLocator | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantLocator that)
      static ServantLocator | narrow(Object obj)
      static ServantLocator | read(InputStream istream)
      static TypeCode | type()
      static ServantLocator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, ServantLocator value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantLocatorHelper

        public ServantLocatorHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantLocator that)

      • extract

        public static ServantLocator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantLocator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantLocator value)

      • narrow

        public static ServantLocator narrow(Object obj)

      • unchecked_narrow

        public static ServantLocator unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantLocatorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantLocatorOperations

  • All Superinterfaces:
    ServantManagerOperations
    All Known Subinterfaces:
    ServantLocator
    All Known Implementing Classes:
    _ServantLocatorStub, ServantLocatorPOA

    public interface ServantLocatorOperations
extends ServantManagerOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

    • Method Detail

      • preinvoke

        Servant preinvoke(byte[] oid,
                  POA adapter,
                  String operation,
                  CookieHolder the_cookie)
           throws ForwardRequest
        This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
        Parameters:
        oid - the object id associated with object on which the request was made.
        adapter - the reference for POA in which the object is being activated.
        operation - the operation name.
        the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
        Returns:
        Servant used to process incoming request.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • postinvoke

        void postinvoke(byte[] oid,
                POA adapter,
                String operation,
                Object the_cookie,
                Servant the_servant)
        This operation is invoked whenener a servant completes a request.
        Parameters:
        oid - the object id ssociated with object on which the request was made.
        adapter - the reference for POA in which the object was active.
        the_cookie - an opaque value that contains the data set by preinvoke.
        the_servant - reference to the servant that is associated with the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantLocatorPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantLocatorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.ServantLocatorPOA
  • All Implemented Interfaces:
    InvokeHandler, ServantLocatorOperations, ServantManagerOperations

    public abstract class ServantLocatorPOA
extends Servant
implements ServantLocatorOperations, InvokeHandler
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantLocatorPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      ServantLocator _this()
      ServantLocator | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.PortableServer.ServantLocatorOperations

        postinvoke, preinvoke

    • Constructor Detail

      • ServantLocatorPOA

        public ServantLocatorPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public ServantLocator _this()

      • _this

        public ServantLocator _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantManager

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantManagerOperations
    All Known Subinterfaces:
    ServantActivator, ServantLocator
    All Known Implementing Classes:
    _ServantActivatorStub, _ServantLocatorStub

    public interface ServantManager
extends ServantManagerOperations, Object, IDLEntity
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantManagerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantManagerOperations

  • All Known Subinterfaces:
    ServantActivator, ServantActivatorOperations, ServantLocator, ServantLocatorOperations, ServantManager
    All Known Implementing Classes:
    _ServantActivatorStub, _ServantLocatorStub, ServantActivatorPOA, ServantLocatorPOA

    public interface ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantRetentionPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantRetentionPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, Serializable, ServantRetentionPolicyOperations

    public interface ServantRetentionPolicy
extends ServantRetentionPolicyOperations, Policy, IDLEntity
    This policy specifies whether the created POA retains active servants in an Active Object Map.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ServantRetentionPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantRetentionPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantRetentionPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ServantRetentionPolicy

    public interface ServantRetentionPolicyOperations
extends PolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ServantRetentionPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        ServantRetentionPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantRetentionPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantRetentionPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ServantRetentionPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ServantRetentionPolicyValue
extends Object
implements IDLEntity
    ServantRetentionPolicyValue can have the following values. RETAIN - to indicate that the POA will retain active servants in its Active Object Map. NON_RETAIN - to indicate Servants are not retained by the POA. If no ServantRetentionPolicy is specified at POA creation, the default is RETAIN.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _NON_RETAIN
      static int | _RETAIN
      static ServantRetentionPolicyValue | NON_RETAIN
      static ServantRetentionPolicyValue | RETAIN

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ServantRetentionPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantRetentionPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _RETAIN

        public static final int _RETAIN
        See Also:
        Constant Field Values

      • RETAIN

        public static final ServantRetentionPolicyValue RETAIN

      • _NON_RETAIN

        public static final int _NON_RETAIN
        See Also:
        Constant Field Values

      • NON_RETAIN

        public static final ServantRetentionPolicyValue NON_RETAIN

    • Constructor Detail

      • ServantRetentionPolicyValue

        protected ServantRetentionPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ServantRetentionPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SERVANT_RETENTION_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface SERVANT_RETENTION_POLICY_ID

  • public interface SERVANT_RETENTION_POLICY_ID
    org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing SERVANT_RETENTION_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing SERVANT_RETENTION_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ThreadPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ThreadPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, Serializable, ThreadPolicyOperations

    public interface ThreadPolicy
extends ThreadPolicyOperations, Policy, IDLEntity
    The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ThreadPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ThreadPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ThreadPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ThreadPolicy

    public interface ThreadPolicyOperations
extends PolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ThreadPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        ThreadPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ThreadPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ThreadPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ThreadPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ThreadPolicyValue
extends Object
implements IDLEntity
    The ThreadPolicyValue can have the following values. ORB_CTRL_MODEL - The ORB is responsible for assigning requests for an ORB- controlled POA to threads. SINGLE_THREAD_MODEL - Requests for a single-threaded POA are processed sequentially.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _ORB_CTRL_MODEL
      static int | _SINGLE_THREAD_MODEL
      static ThreadPolicyValue | ORB_CTRL_MODEL
      static ThreadPolicyValue | SINGLE_THREAD_MODEL

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ThreadPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ThreadPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _ORB_CTRL_MODEL

        public static final int _ORB_CTRL_MODEL
        See Also:
        Constant Field Values

      • ORB_CTRL_MODEL

        public static final ThreadPolicyValue ORB_CTRL_MODEL

      • _SINGLE_THREAD_MODEL

        public static final int _SINGLE_THREAD_MODEL
        See Also:
        Constant Field Values

      • SINGLE_THREAD_MODEL

        public static final ThreadPolicyValue SINGLE_THREAD_MODEL

    • Constructor Detail

      • ThreadPolicyValue

        protected ThreadPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ThreadPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


THREAD_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface THREAD_POLICY_ID

  • public interface THREAD_POLICY_ID
    org/omg/PortableServer/THREAD_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing THREAD_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing THREAD_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_ServantActivatorStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class _ServantActivatorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.PortableServer._ServantActivatorStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, ServantActivator, ServantActivatorOperations, ServantManager, ServantManagerOperations

    public class _ServantActivatorStub
extends ObjectImpl
implements ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _ServantActivatorStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _ServantActivatorStub

        public _ServantActivatorStub()

    • Method Detail

      • incarnate

        public Servant incarnate(byte[] oid,
                         POA adapter)
                  throws ForwardRequest
        This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Specified by:
        incarnate in interface ServantActivatorOperations
        Parameters:
        oid - object Id associated with the object on the request was made.
        adapter - object reference for the POA in which the object is being activated.
        Returns:
        Servant corresponding to oid is created or located by the user supplied servant manager.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • etherealize

        public void etherealize(byte[] oid,
                        POA adapter,
                        Servant serv,
                        boolean cleanup_in_progress,
                        boolean remaining_activations)
        This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Specified by:
        etherealize in interface ServantActivatorOperations
        Parameters:
        oid - object Id associated with the object being deactivated.
        adapter - object reference for the POA in which the object was active.
        serv - contains reference to the servant associated with the object being deactivated.
        cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
        remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_ServantLocatorStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class _ServantLocatorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.PortableServer._ServantLocatorStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, ServantLocator, ServantLocatorOperations, ServantManager, ServantManagerOperations

    public class _ServantLocatorStub
extends ObjectImpl
implements ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _ServantLocatorStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _ServantLocatorStub

        public _ServantLocatorStub()

    • Method Detail

      • preinvoke

        public Servant preinvoke(byte[] oid,
                         POA adapter,
                         String operation,
                         CookieHolder the_cookie)
                  throws ForwardRequest
        This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
        Specified by:
        preinvoke in interface ServantLocatorOperations
        Parameters:
        oid - the object id associated with object on which the request was made.
        adapter - the reference for POA in which the object is being activated.
        operation - the operation name.
        the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
        Returns:
        Servant used to process incoming request.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • postinvoke

        public void postinvoke(byte[] oid,
                       POA adapter,
                       String operation,
                       Object the_cookie,
                       Servant the_servant)
        This operation is invoked whenener a servant completes a request.
        Specified by:
        postinvoke in interface ServantLocatorOperations
        Parameters:
        oid - the object id ssociated with object on which the request was made.
        adapter - the reference for POA in which the object was active.
        the_cookie - an opaque value that contains the data set by preinvoke.
        the_servant - reference to the servant that is associated with the object.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.AdapterActivator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.AdapterActivator

  • Packages that use AdapterActivator
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of AdapterActivator in org.omg.PortableServer

      Methods in org.omg.PortableServer that return AdapterActivator
      Modifier and Type Method and Description
      AdapterActivator POAOperations.the_activator()
      This attribute identifies the adapter activator associated with the POA.
      Methods in org.omg.PortableServer with parameters of type AdapterActivator
      Modifier and Type Method and Description
      void POAOperations.the_activator(AdapterActivator newThe_activator)
      This attribute identifies the adapter activator associated with the POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.AdapterActivatorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.AdapterActivatorOperations

  • Packages that use AdapterActivatorOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of AdapterActivatorOperations in org.omg.PortableServer

      Subinterfaces of AdapterActivatorOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.Current (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.Current

  • Packages that use Current
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Current in org.omg.PortableServer

      Methods in org.omg.PortableServer that return Current
      Modifier and Type | Method and Description
      static Current | CurrentHelper.extract(Any a)
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      Methods in org.omg.PortableServer with parameters of type Current
      Modifier and Type | Method and Description
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.CurrentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.CurrentHelper

No usage of org.omg.PortableServer.CurrentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.CurrentOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.CurrentOperations

  • Packages that use CurrentOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CurrentOperations in org.omg.PortableServer

      Subinterfaces of CurrentOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  Current
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.DynamicImplementation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.DynamicImplementation

No usage of org.omg.PortableServer.DynamicImplementation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ForwardRequest (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ForwardRequest

  • Packages that use ForwardRequest
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ForwardRequest in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ForwardRequest
      Modifier and Type | Method and Description
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      Methods in org.omg.PortableServer with parameters of type ForwardRequest
      Modifier and Type | Method and Description
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      Methods in org.omg.PortableServer that throw ForwardRequest
      Modifier and Type Method and Description
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ForwardRequestHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ForwardRequestHelper

No usage of org.omg.PortableServer.ForwardRequestHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.IdAssignmentPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdAssignmentPolicy

  • Packages that use IdAssignmentPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return IdAssignmentPolicy
      Modifier and Type Method and Description
      IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.IdAssignmentPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdAssignmentPolicyOperations

  • Packages that use IdAssignmentPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicyOperations in org.omg.PortableServer

      Subinterfaces of IdAssignmentPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.IdAssignmentPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.IdAssignmentPolicyValue

  • Packages that use IdAssignmentPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as IdAssignmentPolicyValue
      Modifier and Type | Field and Description
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.SYSTEM_ID
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.USER_ID
      Methods in org.omg.PortableServer that return IdAssignmentPolicyValue
      Modifier and Type | Method and Description
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.from_int(int value)
      IdAssignmentPolicyValue IdAssignmentPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type IdAssignmentPolicyValue
      Modifier and Type Method and Description
      IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.IdUniquenessPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdUniquenessPolicy

  • Packages that use IdUniquenessPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return IdUniquenessPolicy
      Modifier and Type Method and Description
      IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.IdUniquenessPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdUniquenessPolicyOperations

  • Packages that use IdUniquenessPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicyOperations in org.omg.PortableServer

      Subinterfaces of IdUniquenessPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.IdUniquenessPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.IdUniquenessPolicyValue

  • Packages that use IdUniquenessPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as IdUniquenessPolicyValue
      Modifier and Type | Field and Description
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.MULTIPLE_ID
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.UNIQUE_ID
      Methods in org.omg.PortableServer that return IdUniquenessPolicyValue
      Modifier and Type | Method and Description
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.from_int(int value)
      IdUniquenessPolicyValue IdUniquenessPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type IdUniquenessPolicyValue
      Modifier and Type Method and Description
      IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID

No usage of org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID

No usage of org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ImplicitActivationPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ImplicitActivationPolicy

  • Packages that use ImplicitActivationPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ImplicitActivationPolicy
      Modifier and Type Method and Description
      ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ImplicitActivationPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ImplicitActivationPolicyOperations

  • Packages that use ImplicitActivationPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicyOperations in org.omg.PortableServer

      Subinterfaces of ImplicitActivationPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ImplicitActivationPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ImplicitActivationPolicyValue

  • Packages that use ImplicitActivationPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ImplicitActivationPolicyValue
      Modifier and Type | Field and Description
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.NO_IMPLICIT_ACTIVATION
      Methods in org.omg.PortableServer that return ImplicitActivationPolicyValue
      Modifier and Type | Method and Description
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.from_int(int value)
      ImplicitActivationPolicyValue ImplicitActivationPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ImplicitActivationPolicyValue
      Modifier and Type Method and Description
      ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID

No usage of org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.LifespanPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.LifespanPolicy

  • Packages that use LifespanPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return LifespanPolicy
      Modifier and Type Method and Description
      LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.LifespanPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.LifespanPolicyOperations

  • Packages that use LifespanPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicyOperations in org.omg.PortableServer

      Subinterfaces of LifespanPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.LifespanPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.LifespanPolicyValue

  • Packages that use LifespanPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as LifespanPolicyValue
      Modifier and Type | Field and Description
      static LifespanPolicyValue | LifespanPolicyValue.PERSISTENT
      static LifespanPolicyValue | LifespanPolicyValue.TRANSIENT
      Methods in org.omg.PortableServer that return LifespanPolicyValue
      Modifier and Type | Method and Description
      static LifespanPolicyValue | LifespanPolicyValue.from_int(int value)
      LifespanPolicyValue LifespanPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type LifespanPolicyValue
      Modifier and Type Method and Description
      LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.LIFESPAN_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.LIFESPAN_POLICY_ID

No usage of org.omg.PortableServer.LIFESPAN_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.POA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POA

  • Packages that use POA
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POA in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type POA
      Modifier and Type | Method and Description
      String[] | BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | NamingContextPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)

    • Uses of POA in org.omg.PortableServer

      Methods in org.omg.PortableServer that return POA
      Modifier and Type | Method and Description
      POA Servant._default_POA()
      Returns the root POA from the ORB instance associated with the servant.
      POA Servant._poa()
      Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
      static POA | POAHelper.extract(Any a)
      POA POAOperations.find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
      POA CurrentOperations.get_POA()
      Returns reference to the POA implementing the object in whose context it is called.
      static POA | POAHelper.narrow(Object obj)
      static POA | POAHelper.read(InputStream istream)
      POA[] POAOperations.the_children()
      This attribute identifies the current set of all child POAs of the POA.
      POA POAOperations.the_parent()
      This attribute identifies the parent of the POA.
      Methods in org.omg.PortableServer with parameters of type POA
      Modifier and Type | Method and Description
      String[] | ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)
      abstract String[] Servant._all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      void ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      static void | POAHelper.insert(Any a, POA that)
      void ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      void _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      boolean AdapterActivatorOperations.unknown_adapter(POA parent, String name)
      This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.
      static void | POAHelper.write(OutputStream ostream, POA value)

    • Uses of POA in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return POA
      Modifier and Type Method and Description
      POA Delegate.default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      POA Delegate.poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAHelper

No usage of org.omg.PortableServer.POAHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.POAManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POAManager

  • Packages that use POAManager
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAManager in org.omg.PortableServer

      Methods in org.omg.PortableServer that return POAManager
      Modifier and Type Method and Description
      POAManager POAOperations.the_POAManager()
      This attribute identifies the POA manager associated with the POA.
      Methods in org.omg.PortableServer with parameters of type POAManager
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.POAManagerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POAManagerOperations

  • Packages that use POAManagerOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAManagerOperations in org.omg.PortableServer

      Subinterfaces of POAManagerOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  POAManager
      Each POA object has an associated POAManager object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.POAOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POAOperations

  • Packages that use POAOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAOperations in org.omg.PortableServer

      Subinterfaces of POAOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  POA
      A POA object manages the implementation of a collection of objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.RequestProcessingPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.RequestProcessingPolicy

  • Packages that use RequestProcessingPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return RequestProcessingPolicy
      Modifier and Type Method and Description
      RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.RequestProcessingPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.RequestProcessingPolicyOperations

  • Packages that use RequestProcessingPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicyOperations in org.omg.PortableServer

      Subinterfaces of RequestProcessingPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.RequestProcessingPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.RequestProcessingPolicyValue

  • Packages that use RequestProcessingPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as RequestProcessingPolicyValue
      Modifier and Type | Field and Description
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_DEFAULT_SERVANT
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_SERVANT_MANAGER
      Methods in org.omg.PortableServer that return RequestProcessingPolicyValue
      Modifier and Type | Method and Description
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.from_int(int value)
      RequestProcessingPolicyValue RequestProcessingPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type RequestProcessingPolicyValue
      Modifier and Type Method and Description
      RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID

No usage of org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.Servant (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.Servant

  • Packages that use Servant
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Servant in org.omg.CosNaming

      Subclasses of Servant in org.omg.CosNaming
      Modifier and Type Class and Description
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of Servant in org.omg.PortableServer

      Subclasses of Servant in org.omg.PortableServer
      Modifier and Type Class and Description
      class  DynamicImplementation
      Allows dynamic handling of object invocations.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return Servant
      Modifier and Type Method and Description
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Methods in org.omg.PortableServer with parameters of type Servant
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      void ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      void _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void POAOperations.set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.

    • Uses of Servant in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable with parameters of type Servant
      Modifier and Type Method and Description
      POA Delegate.default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      Object Delegate.get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      boolean Delegate.is_a(Servant Self, String Repository_Id)
      This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
      boolean Delegate.non_existent(Servant Self)
      This operation is used to check for the existence of the Object.
      byte[] Delegate.object_id(Servant Self)
      The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
      ORB Delegate.orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
      POA Delegate.poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
      Object Delegate.this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantActivator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantActivator

  • Packages that use ServantActivator
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantActivator in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement ServantActivator
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      Methods in org.omg.PortableServer that return ServantActivator
      Modifier and Type | Method and Description
      ServantActivator | ServantActivatorPOA._this()
      ServantActivator | ServantActivatorPOA._this(ORB orb)
      static ServantActivator | ServantActivatorHelper.extract(Any a)
      static ServantActivator | ServantActivatorHelper.narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.read(InputStream istream)
      static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableServer with parameters of type ServantActivator
      Modifier and Type | Method and Description
      static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
      static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ServantActivatorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantActivatorHelper

No usage of org.omg.PortableServer.ServantActivatorHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantActivatorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantActivatorOperations

  • Packages that use ServantActivatorOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantActivatorOperations in org.omg.PortableServer

      Subinterfaces of ServantActivatorOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      Classes in org.omg.PortableServer that implement ServantActivatorOperations
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ServantActivatorPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantActivatorPOA

No usage of org.omg.PortableServer.ServantActivatorPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantLocator

  • Packages that use ServantLocator
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantLocator in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement ServantLocator
      Modifier and Type Class and Description
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return ServantLocator
      Modifier and Type | Method and Description
      ServantLocator | ServantLocatorPOA._this()
      ServantLocator | ServantLocatorPOA._this(ORB orb)
      static ServantLocator | ServantLocatorHelper.extract(Any a)
      static ServantLocator | ServantLocatorHelper.narrow(Object obj)
      static ServantLocator | ServantLocatorHelper.read(InputStream istream)
      static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableServer with parameters of type ServantLocator
      Modifier and Type | Method and Description
      static void | ServantLocatorHelper.insert(Any a, ServantLocator that)
      static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ServantLocatorHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantLocatorHelper

No usage of org.omg.PortableServer.ServantLocatorHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantLocatorOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantLocatorOperations

  • Packages that use ServantLocatorOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantLocatorOperations in org.omg.PortableServer

      Subinterfaces of ServantLocatorOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Classes in org.omg.PortableServer that implement ServantLocatorOperations
      Modifier and Type Class and Description
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ServantLocatorPOA (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantLocatorPOA

No usage of org.omg.PortableServer.ServantLocatorPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantManager (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantManager

  • Packages that use ServantManager
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantManager in org.omg.PortableServer

      Subinterfaces of ServantManager in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Classes in org.omg.PortableServer that implement ServantManager
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return ServantManager
      Modifier and Type Method and Description
      ServantManager POAOperations.get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Methods in org.omg.PortableServer with parameters of type ServantManager
      Modifier and Type Method and Description
      void POAOperations.set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantManagerOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantManagerOperations

  • Packages that use ServantManagerOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantManagerOperations in org.omg.PortableServer

      Subinterfaces of ServantManagerOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantActivatorOperations
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantLocatorOperations
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      Classes in org.omg.PortableServer that implement ServantManagerOperations
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantRetentionPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantRetentionPolicy

  • Packages that use ServantRetentionPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ServantRetentionPolicy
      Modifier and Type Method and Description
      ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ServantRetentionPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantRetentionPolicyOperations

  • Packages that use ServantRetentionPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicyOperations in org.omg.PortableServer

      Subinterfaces of ServantRetentionPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ServantRetentionPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantRetentionPolicyValue

  • Packages that use ServantRetentionPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ServantRetentionPolicyValue
      Modifier and Type | Field and Description
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.NON_RETAIN
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.RETAIN
      Methods in org.omg.PortableServer that return ServantRetentionPolicyValue
      Modifier and Type | Method and Description
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.from_int(int value)
      ServantRetentionPolicyValue ServantRetentionPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ServantRetentionPolicyValue
      Modifier and Type Method and Description
      ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID

No usage of org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ThreadPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ThreadPolicy

  • Packages that use ThreadPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ThreadPolicy
      Modifier and Type Method and Description
      ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.ThreadPolicyOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ThreadPolicyOperations

  • Packages that use ThreadPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicyOperations in org.omg.PortableServer

      Subinterfaces of ThreadPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ThreadPolicyValue (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ThreadPolicyValue

  • Packages that use ThreadPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ThreadPolicyValue
      Modifier and Type | Field and Description
      static ThreadPolicyValue | ThreadPolicyValue.ORB_CTRL_MODEL
      static ThreadPolicyValue | ThreadPolicyValue.SINGLE_THREAD_MODEL
      Methods in org.omg.PortableServer that return ThreadPolicyValue
      Modifier and Type | Method and Description
      static ThreadPolicyValue | ThreadPolicyValue.from_int(int value)
      ThreadPolicyValue ThreadPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ThreadPolicyValue
      Modifier and Type Method and Description
      ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.THREAD_POLICY_ID (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.THREAD_POLICY_ID

No usage of org.omg.PortableServer.THREAD_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer._ServantActivatorStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer._ServantActivatorStub

No usage of org.omg.PortableServer._ServantActivatorStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer._ServantLocatorStub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer._ServantLocatorStub

No usage of org.omg.PortableServer._ServantLocatorStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NoContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.CurrentPackage

Class NoContext

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.CurrentPackage.NoContext
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NoContext
extends UserException
    org/omg/PortableServer/CurrentPackage/NoContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoContext()
      NoContext(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoContext

        public NoContext()

      • NoContext

        public NoContext(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NoContextHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.CurrentPackage

Class NoContextHelper

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper

  • public abstract class NoContextHelper
extends Object
    org/omg/PortableServer/CurrentPackage/NoContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoContextHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NoContext | extract(Any a)
      static String | id()
      static void | insert(Any a, NoContext that)
      static NoContext | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NoContext value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NoContextHelper

        public NoContextHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NoContext that)

      • extract

        public static NoContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NoContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NoContext value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.CurrentPackage (Java Platform SE 8 )

org.omg.PortableServer.CurrentPackage

Classes

  • NoContextHelper

Exceptions

  • NoContext


org.omg.PortableServer.CurrentPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.CurrentPackage

Provides method implementations with access to the identity of the object on which the method was invoked.

See: Description

  • Class Summary
    Class Description
    NoContextHelper
    org/omg/PortableServer/CurrentPackage/NoContextHelper.java .
  • Exception Summary
    Exception Description
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .

Package org.omg.PortableServer.CurrentPackage Description

Provides method implementations with access to the identity of the object on which the method was invoked. The Current package supports servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.CurrentPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.CurrentPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.CurrentPackage.NoContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableServer.CurrentPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.CurrentPackage

  • Packages that use org.omg.PortableServer.CurrentPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
  • Classes in org.omg.PortableServer.CurrentPackage used by org.omg.PortableServer
    Class and Description
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .
  • Classes in org.omg.PortableServer.CurrentPackage used by org.omg.PortableServer.CurrentPackage
    Class and Description
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.CurrentPackage.NoContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.CurrentPackage.NoContext

  • Packages that use NoContext
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.

    • Uses of NoContext in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw NoContext
      Modifier and Type Method and Description
      byte[] CurrentOperations.get_object_id()
      Returns the ObjectId identifying the object in whose context it is called.
      POA CurrentOperations.get_POA()
      Returns reference to the POA implementing the object in whose context it is called.

    • Uses of NoContext in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage that return NoContext
      Modifier and Type | Method and Description
      static NoContext | NoContextHelper.extract(Any a)
      static NoContext | NoContextHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.CurrentPackage with parameters of type NoContext
      Modifier and Type | Method and Description
      static void | NoContextHelper.insert(Any a, NoContext that)
      static void | NoContextHelper.write(OutputStream ostream, NoContext value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.CurrentPackage.NoContextHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.CurrentPackage.NoContextHelper

No usage of org.omg.PortableServer.CurrentPackage.NoContextHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterInactive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAManagerPackage

Class AdapterInactive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AdapterInactive
extends UserException
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterInactive()
      AdapterInactive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AdapterInactive

        public AdapterInactive()

      • AdapterInactive

        public AdapterInactive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterInactiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAManagerPackage

Class AdapterInactiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

  • public abstract class AdapterInactiveHelper
extends Object
    org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterInactiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AdapterInactive | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterInactive that)
      static AdapterInactive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterInactive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterInactiveHelper

        public AdapterInactiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AdapterInactive that)

      • extract

        public static AdapterInactive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterInactive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AdapterInactive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.POAManagerPackage (Java Platform SE 8 )

org.omg.PortableServer.POAManagerPackage

Classes

  • AdapterInactiveHelper
  • State

Exceptions

  • AdapterInactive


org.omg.PortableServer.POAManagerPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.POAManagerPackage

Encapsulates the processing state of the POAs it is associated with.

See: Description

  • Class Summary
    Class Description
    AdapterInactiveHelper
    org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java .
    State
    Specifies the states for the POAManager
  • Exception Summary
    Exception Description
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .

Package org.omg.PortableServer.POAManagerPackage Description

Encapsulates the processing state of the POAs it is associated with. Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.POAManagerPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.POAManagerPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableServer.POAManagerPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.POAManagerPackage

  • Packages that use org.omg.PortableServer.POAManagerPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
  • Classes in org.omg.PortableServer.POAManagerPackage used by org.omg.PortableServer
    Class and Description
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
    State
    Specifies the states for the POAManager
  • Classes in org.omg.PortableServer.POAManagerPackage used by org.omg.PortableServer.POAManagerPackage
    Class and Description
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
    State
    Specifies the states for the POAManager
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


State (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAManagerPackage

Class State

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.State
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class State
extends Object
implements IDLEntity
    Specifies the states for the POAManager

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _ACTIVE
      static int | _DISCARDING
      static int | _HOLDING
      static int | _INACTIVE
      static State | ACTIVE
      static State | DISCARDING
      static State | HOLDING
      static State | INACTIVE

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | State(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static State | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _HOLDING

        public static final int _HOLDING
        See Also:
        Constant Field Values

      • HOLDING

        public static final State HOLDING

      • _ACTIVE

        public static final int _ACTIVE
        See Also:
        Constant Field Values

      • ACTIVE

        public static final State ACTIVE

      • _DISCARDING

        public static final int _DISCARDING
        See Also:
        Constant Field Values

      • DISCARDING

        public static final State DISCARDING

      • _INACTIVE

        public static final int _INACTIVE
        See Also:
        Constant Field Values

      • INACTIVE

        public static final State INACTIVE

    • Constructor Detail

      • State

        protected State(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static State from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAManagerPackage.AdapterInactive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAManagerPackage.AdapterInactive

  • Packages that use AdapterInactive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.

    • Uses of AdapterInactive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterInactive
      Modifier and Type Method and Description
      void POAManagerOperations.activate()
      This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
      void POAManagerOperations.deactivate(boolean etherealize_objects, boolean wait_for_completion)
      This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
      void POAManagerOperations.discard_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to discarding.
      void POAManagerOperations.hold_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

    • Uses of AdapterInactive in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage that return AdapterInactive
      Modifier and Type | Method and Description
      static AdapterInactive | AdapterInactiveHelper.extract(Any a)
      static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type AdapterInactive
      Modifier and Type | Method and Description
      static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)
      static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

No usage of org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAManagerPackage.State (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAManagerPackage.State

  • Packages that use State
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.

    • Uses of State in org.omg.PortableServer

      Methods in org.omg.PortableServer that return State
      Modifier and Type Method and Description
      State POAManagerOperations.get_state()
      This operation returns the state of the POA manager.

    • Uses of State in org.omg.PortableServer.POAManagerPackage

      Fields in org.omg.PortableServer.POAManagerPackage declared as State
      Modifier and Type | Field and Description
      static State | State.ACTIVE
      static State | State.DISCARDING
      static State | State.HOLDING
      static State | State.INACTIVE
      Methods in org.omg.PortableServer.POAManagerPackage that return State
      Modifier and Type | Method and Description
      static State | State.from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterAlreadyExists (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterAlreadyExists

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AdapterAlreadyExists
extends UserException
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterAlreadyExists()
      AdapterAlreadyExists(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AdapterAlreadyExists

        public AdapterAlreadyExists()

      • AdapterAlreadyExists

        public AdapterAlreadyExists(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterAlreadyExistsHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterAlreadyExistsHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

  • public abstract class AdapterAlreadyExistsHelper
extends Object
    org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterAlreadyExistsHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AdapterAlreadyExists | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterAlreadyExists that)
      static AdapterAlreadyExists | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterAlreadyExists value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterAlreadyExistsHelper

        public AdapterAlreadyExistsHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AdapterAlreadyExists that)

      • extract

        public static AdapterAlreadyExists extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterAlreadyExists read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AdapterAlreadyExists value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterNonExistent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterNonExistent

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AdapterNonExistent
extends UserException
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterNonExistent()
      AdapterNonExistent(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AdapterNonExistent

        public AdapterNonExistent()

      • AdapterNonExistent

        public AdapterNonExistent(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AdapterNonExistentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterNonExistentHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

  • public abstract class AdapterNonExistentHelper
extends Object
    org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterNonExistentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AdapterNonExistent | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterNonExistent that)
      static AdapterNonExistent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterNonExistent value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterNonExistentHelper

        public AdapterNonExistentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AdapterNonExistent that)

      • extract

        public static AdapterNonExistent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterNonExistent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AdapterNonExistent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class InvalidPolicy

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.InvalidPolicy
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidPolicy
extends UserException
    org/omg/PortableServer/POAPackage/InvalidPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | index

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidPolicy()
      InvalidPolicy(short _index)
      InvalidPolicy(String $reason, short _index)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • index

        public short index

    • Constructor Detail

      • InvalidPolicy

        public InvalidPolicy()

      • InvalidPolicy

        public InvalidPolicy(short _index)

      • InvalidPolicy

        public InvalidPolicy(String $reason,
                     short _index)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InvalidPolicyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class InvalidPolicyHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper

  • public abstract class InvalidPolicyHelper
extends Object
    org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidPolicyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidPolicy | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidPolicy that)
      static InvalidPolicy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidPolicy value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidPolicyHelper

        public InvalidPolicyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidPolicy that)

      • extract

        public static InvalidPolicy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidPolicy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NoServant (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class NoServant

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.NoServant
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NoServant
extends UserException
    org/omg/PortableServer/POAPackage/NoServant.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoServant()
      NoServant(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoServant

        public NoServant()

      • NoServant

        public NoServant(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NoServantHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class NoServantHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.NoServantHelper

  • public abstract class NoServantHelper
extends Object
    org/omg/PortableServer/POAPackage/NoServantHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoServantHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NoServant | extract(Any a)
      static String | id()
      static void | insert(Any a, NoServant that)
      static NoServant | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NoServant value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NoServantHelper

        public NoServantHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NoServant that)

      • extract

        public static NoServant extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NoServant read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NoServant value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectAlreadyActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectAlreadyActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ObjectAlreadyActive
extends UserException
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectAlreadyActive()
      ObjectAlreadyActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectAlreadyActive

        public ObjectAlreadyActive()

      • ObjectAlreadyActive

        public ObjectAlreadyActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectAlreadyActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectAlreadyActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

  • public abstract class ObjectAlreadyActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectAlreadyActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectAlreadyActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectAlreadyActive that)
      static ObjectAlreadyActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectAlreadyActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectAlreadyActiveHelper

        public ObjectAlreadyActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectAlreadyActive that)

      • extract

        public static ObjectAlreadyActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectAlreadyActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectNotActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectNotActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ObjectNotActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ObjectNotActive
extends UserException
    org/omg/PortableServer/POAPackage/ObjectNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectNotActive()
      ObjectNotActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectNotActive

        public ObjectNotActive()

      • ObjectNotActive

        public ObjectNotActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ObjectNotActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectNotActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

  • public abstract class ObjectNotActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectNotActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectNotActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectNotActive that)
      static ObjectNotActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectNotActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectNotActiveHelper

        public ObjectNotActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectNotActive that)

      • extract

        public static ObjectNotActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectNotActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.POAPackage (Java Platform SE 8 )

org.omg.PortableServer.POAPackage

Classes

  • AdapterAlreadyExistsHelper
  • AdapterNonExistentHelper
  • InvalidPolicyHelper
  • NoServantHelper
  • ObjectAlreadyActiveHelper
  • ObjectNotActiveHelper
  • ServantAlreadyActiveHelper
  • ServantNotActiveHelper
  • WrongAdapterHelper
  • WrongPolicyHelper

Exceptions

  • AdapterAlreadyExists
  • AdapterNonExistent
  • InvalidPolicy
  • NoServant
  • ObjectAlreadyActive
  • ObjectNotActive
  • ServantAlreadyActive
  • ServantNotActive
  • WrongAdapter
  • WrongPolicy


org.omg.PortableServer.POAPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.POAPackage

Allows programmers to construct object implementations that are portable between different ORB products.

See: Description

  • Class Summary
    Class Description
    AdapterAlreadyExistsHelper
    org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java .
    AdapterNonExistentHelper
    org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java .
    InvalidPolicyHelper
    org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java .
    NoServantHelper
    org/omg/PortableServer/POAPackage/NoServantHelper.java .
    ObjectAlreadyActiveHelper
    org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java .
    ObjectNotActiveHelper
    org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java .
    ServantAlreadyActiveHelper
    org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java .
    ServantNotActiveHelper
    org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java .
    WrongAdapterHelper
    org/omg/PortableServer/POAPackage/WrongAdapterHelper.java .
    WrongPolicyHelper
    org/omg/PortableServer/POAPackage/WrongPolicyHelper.java .
  • Exception Summary
    Exception Description
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .

Package org.omg.PortableServer.POAPackage Description

Allows programmers to construct object implementations that are portable between different ORB products.

The Portable Object Adaptor (POA) is designed to meet the following goals:

  • Allow programmers to construct object implementations that are portable between different ORB products.
  • Provide support for objects with persistent identities.
  • Provide support for transparent activation of objects.
  • Allow a single servant to support multiple object identities simultaneously.

Given an interface My defined in My.idl, the file MyPOA.java is generated by the idlj compiler. You must provide the implementation for My and it must inherit from MyPOA.

MyPOA.java is a stream-based skeleton that extends org.omg.PortableServer.Servant and implements the InvokeHandler interface and the operations interface associated with the IDL interface the skeleton implements.

The PortableServer module for the Portable Object Adapter (POA) defines the native Servant type. In the Java programming language, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

All Mapping corresponds to the Chapter 11 of CORBA V2.3.1 specified by OMG document formal/99-10-07.pdf. The exception to this is the id attribute, which is added in ptc/00-08-06, section 11.3.8.26.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.POAPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.POAPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableServer.POAPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.POAPackage

  • Packages that use org.omg.PortableServer.POAPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
  • Classes in org.omg.PortableServer.POAPackage used by org.omg.PortableServer
    Class and Description
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .
  • Classes in org.omg.PortableServer.POAPackage used by org.omg.PortableServer.POAPackage
    Class and Description
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantAlreadyActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantAlreadyActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServantAlreadyActive
extends UserException
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantAlreadyActive()
      ServantAlreadyActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServantAlreadyActive

        public ServantAlreadyActive()

      • ServantAlreadyActive

        public ServantAlreadyActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantAlreadyActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantAlreadyActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

  • public abstract class ServantAlreadyActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantAlreadyActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantAlreadyActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantAlreadyActive that)
      static ServantAlreadyActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServantAlreadyActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantAlreadyActiveHelper

        public ServantAlreadyActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantAlreadyActive that)

      • extract

        public static ServantAlreadyActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantAlreadyActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantNotActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantNotActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ServantNotActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServantNotActive
extends UserException
    org/omg/PortableServer/POAPackage/ServantNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantNotActive()
      ServantNotActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServantNotActive

        public ServantNotActive()

      • ServantNotActive

        public ServantNotActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ServantNotActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantNotActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper

  • public abstract class ServantNotActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantNotActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantNotActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantNotActive that)
      static ServantNotActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServantNotActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantNotActiveHelper

        public ServantNotActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantNotActive that)

      • extract

        public static ServantNotActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantNotActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongAdapter

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.WrongAdapter
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class WrongAdapter
extends UserException
    org/omg/PortableServer/POAPackage/WrongAdapter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongAdapter()
      WrongAdapter(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WrongAdapter

        public WrongAdapter()

      • WrongAdapter

        public WrongAdapter(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongAdapterHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongAdapterHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper

  • public abstract class WrongAdapterHelper
extends Object
    org/omg/PortableServer/POAPackage/WrongAdapterHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongAdapterHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static WrongAdapter | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongAdapter that)
      static WrongAdapter | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongAdapter value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WrongAdapterHelper

        public WrongAdapterHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          WrongAdapter that)

      • extract

        public static WrongAdapter extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongAdapter read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         WrongAdapter value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongPolicy

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.WrongPolicy
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class WrongPolicy
extends UserException
    org/omg/PortableServer/POAPackage/WrongPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongPolicy()
      WrongPolicy(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WrongPolicy

        public WrongPolicy()

      • WrongPolicy

        public WrongPolicy(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


WrongPolicyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongPolicyHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper

  • public abstract class WrongPolicyHelper
extends Object
    org/omg/PortableServer/POAPackage/WrongPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u51/3951/corba/src/share/classes/org/omg/PortableServer/poa.idl Monday, June 8, 2015 7:28:45 PM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongPolicyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static WrongPolicy | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongPolicy that)
      static WrongPolicy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongPolicy value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WrongPolicyHelper

        public WrongPolicyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          WrongPolicy that)

      • extract

        public static WrongPolicy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongPolicy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         WrongPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.AdapterAlreadyExists (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterAlreadyExists

  • Packages that use AdapterAlreadyExists
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of AdapterAlreadyExists in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterAlreadyExists
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.

    • Uses of AdapterAlreadyExists in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return AdapterAlreadyExists
      Modifier and Type | Method and Description
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type AdapterAlreadyExists
      Modifier and Type | Method and Description
      static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
      static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

No usage of org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.AdapterNonExistent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterNonExistent

  • Packages that use AdapterNonExistent
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of AdapterNonExistent in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterNonExistent
      Modifier and Type Method and Description
      POA POAOperations.find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.

    • Uses of AdapterNonExistent in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return AdapterNonExistent
      Modifier and Type | Method and Description
      static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
      static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type AdapterNonExistent
      Modifier and Type | Method and Description
      static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
      static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

No usage of org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.InvalidPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.InvalidPolicy

  • Packages that use InvalidPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of InvalidPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw InvalidPolicy
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.

    • Uses of InvalidPolicy in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return InvalidPolicy
      Modifier and Type | Method and Description
      static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
      static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type InvalidPolicy
      Modifier and Type | Method and Description
      static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
      static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.InvalidPolicyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.InvalidPolicyHelper

No usage of org.omg.PortableServer.POAPackage.InvalidPolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.NoServant (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.NoServant

  • Packages that use NoServant
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of NoServant in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw NoServant
      Modifier and Type Method and Description
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.

    • Uses of NoServant in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return NoServant
      Modifier and Type | Method and Description
      static NoServant | NoServantHelper.extract(Any a)
      static NoServant | NoServantHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type NoServant
      Modifier and Type | Method and Description
      static void | NoServantHelper.insert(Any a, NoServant that)
      static void | NoServantHelper.write(OutputStream ostream, NoServant value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.NoServantHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.NoServantHelper

No usage of org.omg.PortableServer.POAPackage.NoServantHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ObjectAlreadyActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectAlreadyActive

  • Packages that use ObjectAlreadyActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ObjectAlreadyActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ObjectAlreadyActive
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.

    • Uses of ObjectAlreadyActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ObjectAlreadyActive
      Modifier and Type | Method and Description
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ObjectAlreadyActive
      Modifier and Type | Method and Description
      static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
      static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

No usage of org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ObjectNotActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectNotActive

  • Packages that use ObjectNotActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ObjectNotActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ObjectNotActive
      Modifier and Type Method and Description
      void POAOperations.deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.

    • Uses of ObjectNotActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ObjectNotActive
      Modifier and Type | Method and Description
      static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
      static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ObjectNotActive
      Modifier and Type | Method and Description
      static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
      static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

No usage of org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ServantAlreadyActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantAlreadyActive

  • Packages that use ServantAlreadyActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ServantAlreadyActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ServantAlreadyActive
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.

    • Uses of ServantAlreadyActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ServantAlreadyActive
      Modifier and Type | Method and Description
      static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
      static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ServantAlreadyActive
      Modifier and Type | Method and Description
      static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
      static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

No usage of org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ServantNotActive (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantNotActive

  • Packages that use ServantNotActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ServantNotActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ServantNotActive
      Modifier and Type Method and Description
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.

    • Uses of ServantNotActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ServantNotActive
      Modifier and Type | Method and Description
      static ServantNotActive | ServantNotActiveHelper.extract(Any a)
      static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ServantNotActive
      Modifier and Type | Method and Description
      static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
      static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.ServantNotActiveHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantNotActiveHelper

No usage of org.omg.PortableServer.POAPackage.ServantNotActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.WrongAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongAdapter

  • Packages that use WrongAdapter
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of WrongAdapter in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw WrongAdapter
      Modifier and Type Method and Description
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.

    • Uses of WrongAdapter in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return WrongAdapter
      Modifier and Type | Method and Description
      static WrongAdapter | WrongAdapterHelper.extract(Any a)
      static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type WrongAdapter
      Modifier and Type | Method and Description
      static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
      static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.WrongAdapterHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongAdapterHelper

No usage of org.omg.PortableServer.POAPackage.WrongAdapterHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.WrongPolicy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongPolicy

  • Packages that use WrongPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of WrongPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw WrongPolicy
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      Object POAOperations.create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      void POAOperations.deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      ServantManager POAOperations.get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void POAOperations.set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
      void POAOperations.set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.

    • Uses of WrongPolicy in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return WrongPolicy
      Modifier and Type | Method and Description
      static WrongPolicy | WrongPolicyHelper.extract(Any a)
      static WrongPolicy | WrongPolicyHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type WrongPolicy
      Modifier and Type | Method and Description
      static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
      static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.POAPackage.WrongPolicyHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongPolicyHelper

No usage of org.omg.PortableServer.POAPackage.WrongPolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Delegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.portable

Interface Delegate

  • public interface Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB vendor specific implementation of PortableServer::Servant. Conformant to spec CORBA V2.3.1, ptc/00-01-08.pdf

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      POA default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      Object get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      boolean is_a(Servant Self, String Repository_Id)
      This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
      boolean non_existent(Servant Self)
      This operation is used to check for the existence of the Object.
      byte[] object_id(Servant Self)
      The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
      ORB orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
      POA poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
      Object this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

    • Method Detail

      • orb

        ORB orb(Servant Self)
        Convenience method that returns the instance of the ORB currently associated with the Servant.
        Parameters:
        Self - the servant.
        Returns:
        ORB associated with the Servant.

      • this_object

        Object this_object(Servant Self)
        This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
        Parameters:
        Self - the servant.
        Returns:
        Object reference associated with the request.

      • poa

        POA poa(Servant Self)
        The method _poa() is equivalent to calling PortableServer::Current:get_POA.
        Parameters:
        Self - the servant.
        Returns:
        POA associated with the servant.

      • object_id

        byte[] object_id(Servant Self)
        The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
        Parameters:
        Self - the servant.
        Returns:
        ObjectId associated with this servant.

      • default_POA

        POA default_POA(Servant Self)
        The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
        Parameters:
        Self - the servant.
        Returns:
        POA associated with the servant class.

      • is_a

        boolean is_a(Servant Self,
             String Repository_Id)
        This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
        Parameters:
        Self - the servant.
        Repository_Id - the repository_id to be checked in the repository list or against the id of generic CORBA object.
        Returns:
        boolean indicating whether the specified repid is in the list or is same as that got generic CORBA object.

      • non_existent

        boolean non_existent(Servant Self)
        This operation is used to check for the existence of the Object.
        Parameters:
        Self - the servant.
        Returns:
        boolean true to indicate that object does not exist, and false otherwise.

      • get_interface_def

        Object get_interface_def(Servant self)
        This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
        Parameters:
        self - the servant.
        Returns:
        type information corresponding to the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.portable (Java Platform SE 8 )

org.omg.PortableServer.portable

Interfaces

  • Delegate


org.omg.PortableServer.portable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.portable

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

See: Description

  • Interface Summary
    Interface Description
    Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.

Package org.omg.PortableServer.portable Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

The portable package contains interfaces and classes that are designed for and intended to be used by an ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB-vendor-specific implementation of PortableServer::Servant. This package conforms CORBA Specification V2.3.1, ptc/00-01-08.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.portable Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.portable

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • org.omg.PortableServer.portable.Delegate
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableServer.portable (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.portable

  • Packages that use org.omg.PortableServer.portable
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer.portable used by org.omg.PortableServer
    Class and Description
    Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.PortableServer.portable.Delegate (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.portable.Delegate

  • Packages that use Delegate
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Delegate in org.omg.PortableServer

      Methods in org.omg.PortableServer that return Delegate
      Modifier and Type Method and Description
      Delegate Servant._get_delegate()
      Gets the ORB vendor-specific implementation of PortableServer::Servant.
      Methods in org.omg.PortableServer with parameters of type Delegate
      Modifier and Type Method and Description
      void Servant._set_delegate(Delegate delegate)
      Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CookieHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.ServantLocatorPackage

Class CookieHolder

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder
  • All Implemented Interfaces:
    Streamable

    public final class CookieHolder
extends Object
implements Streamable
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object. A CookieHolder class is provided for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object value

    • Constructor Summary

      Constructors
      Constructor and Description
      CookieHolder()
      CookieHolder(Object initial)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream is)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream os)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Object value

    • Constructor Detail

      • CookieHolder

        public CookieHolder()

      • CookieHolder

        public CookieHolder(Object initial)

    • Method Detail

      • _read

        public void _read(InputStream is)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        is - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream os)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        os - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 8 )

org.omg.PortableServer.ServantLocatorPackage

Classes

  • CookieHolder


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.ServantLocatorPackage

Provides classes and interfaces for locating the servant.

See: Description

  • Class Summary
    Class Description
    CookieHolder
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.

Package org.omg.PortableServer.ServantLocatorPackage Description

Provides classes and interfaces for locating the servant.

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.PortableServer.ServantLocatorPackage Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.ServantLocatorPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.ServantLocatorPackage

  • Packages that use org.omg.PortableServer.ServantLocatorPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer.ServantLocatorPackage used by org.omg.PortableServer
    Class and Description
    CookieHolder
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.PortableServer.ServantLocatorPackage.CookieHolder (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantLocatorPackage.CookieHolder

  • Packages that use CookieHolder
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CookieHolder in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type CookieHolder
      Modifier and Type Method and Description
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.SendingContext (Java Platform SE 8 )

org.omg.SendingContext

Interfaces

  • RunTime
  • RunTimeOperations


org.omg.SendingContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.SendingContext

Provides support for the marshalling of value types.

See: Description

  • Interface Summary
    Interface Description
    RunTime
    Defines the base class that represents the Sending Context of a request.
    RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request.

Package org.omg.SendingContext Description

Provides support for the marshalling of value types. Value type marshalling may require access to an implementation of the value type or to meta information about the value type. This information is passed between the sending context and the receiving context using a particular service context containing an instance of the SendingContext.RunTime interface.

A sending context may be either the client side or the server side of an invocation, depending on which contains a value type. The sending context is the client side of an invocation if the request contains a value type. It is the server side if the reply contains a value type. The other party in the communication is the receiving context.

The service context marshalled for SendingContext consists of an encapsulated IOR for the SendingContext.RunTime interface. RunTime is just a marker interface defined to allow extensibility in the future. There is currently only one subinterface of RunTime defined: the SendingContext.CodeBase interface. The interface CodeBase defines operations to obtain code URLs and meta-information about a value type received from the sending context.

Note that these classes are currently defined in the com.sun.org.omg.SendingContext package rather than in the package org.omg.SendingContext. This has been done to avoid including large parts of the interface repository in the JDK core, since the interface repository is still evolving in response to the needs of the CORBA Components work.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.SendingContext Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.SendingContext

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • org.omg.CORBA.Object
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.SendingContext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.SendingContext

  • Packages that use org.omg.SendingContext
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
  • Classes in org.omg.SendingContext used by javax.rmi.CORBA
    Class and Description
    RunTime
    Defines the base class that represents the Sending Context of a request.
  • Classes in org.omg.SendingContext used by org.omg.SendingContext
    Class and Description
    RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RunTime (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.SendingContext

Interface RunTime

  • All Superinterfaces:
    IDLEntity, Object, RunTimeOperations, Serializable

    public interface RunTime
extends RunTimeOperations, Object, IDLEntity
    Defines the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


RunTimeOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.SendingContext

Interface RunTimeOperations

  • All Known Subinterfaces:
    RunTime

    public interface RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.SendingContext.RunTime (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.SendingContext.RunTime

  • Packages that use RunTime
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.

    • Uses of RunTime in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return RunTime
      Modifier and Type Method and Description
      RunTime ValueHandler.getRunTimeCodeBase()
      Returns the CodeBase for this ValueHandler.
      Methods in javax.rmi.CORBA with parameters of type RunTime
      Modifier and Type Method and Description
      Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
      Reads a value from the stream using Java semantics.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.omg.SendingContext.RunTimeOperations (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.SendingContext.RunTimeOperations

  • Packages that use RunTimeOperations
    Package Description
    org.omg.SendingContext
    Provides support for the marshalling of value types.

    • Uses of RunTimeOperations in org.omg.SendingContext

      Subinterfaces of RunTimeOperations in org.omg.SendingContext
      Modifier and Type Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.stub.java.rmi (Java Platform SE 8 )

org.omg.stub.java.rmi

Classes

  • _Remote_Stub


org.omg.stub.java.rmi (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.stub.java.rmi

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

See: Description

  • Class Summary
    Class Description
    _Remote_Stub
    This class provides the Stub for the Remote Type.

Package org.omg.stub.java.rmi Description

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.omg.stub.java.rmi Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.stub.java.rmi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.omg.stub.java.rmi (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.stub.java.rmi

No usage of org.omg.stub.java.rmi
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


_Remote_Stub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.stub.java.rmi

Class _Remote_Stub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub
          • org.omg.stub.java.rmi._Remote_Stub
  • All Implemented Interfaces:
    Serializable, Remote, Object

    public final class _Remote_Stub
extends Stub
implements Remote
    This class provides the Stub for the Remote Type. The class is generated by the rmic compiler, and is still under works at OMG. It's contents are subject to change without notice as the specification evolves.

    • Constructor Summary

      Constructors
      Constructor and Description
      _Remote_Stub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Returns an array of repository ids that an object implements.

      • Methods inherited from class javax.rmi.CORBA.Stub

        connect, equals, hashCode, toString

      • Methods inherited from class org.omg.CORBA_2_3.portable.ObjectImpl

        _get_codebase

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • _Remote_Stub

        public _Remote_Stub()

    • Method Detail

      • _ids

        public String[] _ids()
        Returns an array of repository ids that an object implements. The string at index zero represents the most derived interface. The last id, for the generic CORBA object is (i.e., IDL:omg.org/CORBA/Object:1.0") is implied and not present.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        an array of repository ids that an object implements.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.omg.stub.java.rmi._Remote_Stub (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.stub.java.rmi._Remote_Stub

No usage of org.omg.stub.java.rmi._Remote_Stub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Attr (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Attr

  • All Superinterfaces:
    Node

    public interface Attr
extends Node
    The Attr interface represents an attribute in an Element object. Typically the allowable values for the attribute are defined in a schema associated with the document.

    Attr objects inherit the Node interface, but since they are not actually child nodes of the element they describe, the DOM does not consider them part of the document tree. Thus, the Node attributes parentNode, previousSibling, and nextSibling have a null value for Attr objects. The DOM takes the view that attributes are properties of elements rather than having a separate identity from the elements they are associated with; this should make it more efficient to implement such features as default attributes associated with all elements of a given type. Furthermore, Attr nodes may not be immediate children of a DocumentFragment. However, they can be associated with Element nodes contained within a DocumentFragment. In short, users and implementors of the DOM need to be aware that Attr nodes have some things in common with other objects inheriting the Node interface, but they also are quite distinct.

    The attribute's effective value is determined as follows: if this attribute has been explicitly assigned any value, that value is the attribute's effective value; otherwise, if there is a declaration for this attribute, and that declaration includes a default value, then that default value is the attribute's effective value; otherwise, the attribute does not exist on this element in the structure model until it has been explicitly added. Note that the Node.nodeValue attribute on the Attr instance can also be used to retrieve the string version of the attribute's value(s).

    If the attribute was not explicitly given a value in the instance document but has a default value provided by the schema associated with the document, an attribute node will be created with specified set to false. Removing attribute nodes for which a default value is defined in the schema generates a new attribute node with the default value and specified set to false. If validation occurred while invoking Document.normalizeDocument(), attribute nodes with specified equals to false are recomputed according to the default attribute values provided by the schema. If no default value is associate with this attribute in the schema, the attribute node is discarded.

    In XML, where the value of an attribute can contain entity references, the child nodes of the Attr node may be either Text or EntityReference nodes (when these are in use; see the description of EntityReference for discussion).

    The DOM Core represents all attribute values as simple strings, even if the DTD or schema associated with the document declares them of some specific type such as tokenized.

    The way attribute value normalization is performed by the DOM implementation depends on how much the implementation knows about the schema in use. Typically, the value and nodeValue attributes of an Attr node initially returns the normalized value given by the parser. It is also the case after Document.normalizeDocument() is called (assuming the right options have been set). But this may not be the case after mutation, independently of whether the mutation is performed by setting the string value directly or by changing the Attr child nodes. In particular, this is true when character references are involved, given that they are not represented in the DOM and they impact attribute value normalization. On the other hand, if the implementation knows about the schema in use when the attribute value is changed, and it is of a different type than CDATA, it may normalize it again at that time. This is especially true of specialized DOM implementations, such as SVG DOM implementations, which store attribute values in an internal form different from a string.

    The following table gives some examples of the relations between the attribute value in the original document (parsed attribute), the value as exposed in the DOM, and the serialization of the value:

    Examples Parsed attribute value Initial Attr.value Serialized attribute value
    Character reference
    "x&#178;=5"

    "x²=5"

    "x&#178;=5"
    Built-in character entity
    "y&lt;6"

    "y<6"

    "y&lt;6"
    Literal newline between
     "x=5&#10;y=6"

    "x=5 y=6"

    "x=5&#10;y=6"
    Normalized newline between
    "x=5
 y=6"

    "x=5 y=6"

    "x=5 y=6"
    Entity e with literal newline
     <!ENTITY e '...&#10;...'> [...]> "x=5&e;y=6"
             Dependent on Implementation and Load Options Dependent on Implementation and Load/Save Options

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of this attribute.
      Element getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.
      TypeInfo getSchemaTypeInfo()
      The type information associated with this attribute.
      boolean getSpecified()
      True if this attribute was explicitly given a value in the instance document, false otherwise.
      String getValue()
      On retrieval, the value of the attribute is returned as a string.
      boolean isId()
      Returns whether this attribute is known to be of type ID (i.e.
      void setValue(String value)
      On retrieval, the value of the attribute is returned as a string.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getName

        String getName()
        Returns the name of this attribute. If Node.localName is different from null, this attribute is a qualified name.

      • getSpecified

        boolean getSpecified()
        True if this attribute was explicitly given a value in the instance document, false otherwise. If the application changed the value of this attribute node (even if it ends up having the same value as the default value) then it is set to true. The implementation may handle attributes with default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.

      • getValue

        String getValue()
        On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
        On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
        Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.

      • setValue

        void setValue(String value)
       throws DOMException
        On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
        On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
        Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

      • getOwnerElement

        Element getOwnerElement()
        The Element node this attribute is attached to or null if this attribute is not in use.
        Since:
        DOM Level 2

      • getSchemaTypeInfo

        TypeInfo getSchemaTypeInfo()
        The type information associated with this attribute. While the type information contained in this attribute is guarantee to be correct after loading the document or invoking Document.normalizeDocument(), schemaTypeInfo may not be reliable if the node was moved.
        Since:
        DOM Level 3

      • isId

        boolean isId()
        Returns whether this attribute is known to be of type ID (i.e. to contain an identifier for its owner element) or not. When it is and its value is unique, the ownerElement of this attribute can be retrieved using the method Document.getElementById . The implementation could use several ways to determine if an attribute node is known to contain an identifier:
        • If validation occurred using an XML Schema [XML Schema Part 1] while loading the document or while invoking Document.normalizeDocument(), the post-schema-validation infoset contributions (PSVI contributions) values are used to determine if this attribute is a schema-determined ID attribute using the schema-determined ID definition in [XPointer] .
        • If validation occurred using a DTD while loading the document or while invoking Document.normalizeDocument(), the infoset [type definition] value is used to determine if this attribute is a DTD-determined ID attribute using the DTD-determined ID definition in [XPointer] .
        • from the use of the methods Element.setIdAttribute(), Element.setIdAttributeNS(), or Element.setIdAttributeNode(), i.e. it is an user-determined ID attribute;

          Note: XPointer framework (see section 3.2 in [XPointer] ) consider the DOM user-determined ID attribute as being part of the XPointer externally-determined ID definition.

        • using mechanisms that are outside the scope of this specification, it is then an externally-determined ID attribute. This includes using schema languages different from XML schema and DTD.

        If validation occurred while invoking Document.normalizeDocument(), all user-determined ID attributes are reset and all attribute nodes ID information are then reevaluated in accordance to the schema used. As a consequence, if the Attr.schemaTypeInfo attribute contains an ID type, isId will always return true.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CDATASection (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface CDATASection

  • All Superinterfaces:
    CharacterData, Node, Text

    public interface CDATASection
extends Text
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup. The only delimiter that is recognized in a CDATA section is the "]]>" string that ends the CDATA section. CDATA sections cannot be nested. Their primary purpose is for including material such as XML fragments, without needing to escape all the delimiters.

    The CharacterData.data attribute holds the text that is contained by the CDATA section. Note that this may contain characters that need to be escaped outside of CDATA sections and that, depending on the character encoding ("charset") chosen for serialization, it may be impossible to write out some characters as part of a CDATA section.

    The CDATASection interface inherits from the CharacterData interface through the Text interface. Adjacent CDATASection nodes are not merged by use of the normalize method of the Node interface.

    No lexical check is done on the content of a CDATA section and it is therefore possible to have the character sequence "]]>" in the content, which is illegal in a CDATA section per section 2.7 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization or the cdata section must be splitted before the serialization (see also the parameter "split-cdata-sections" in the DOMConfiguration interface).

    Note: Because no markup is recognized within a CDATASection, character numeric references cannot be used as an escape mechanism when serializing. Therefore, action needs to be taken when serializing a CDATASection with a character encoding where some of the contained characters cannot be represented. Failure to do so would not produce well-formed XML.

    Note: One potential solution in the serialization process is to end the CDATA section before the character, output the character using a character reference or entity reference, and open a new CDATA section for any further characters in the text node. Note, however, that some code conversion libraries at the time of writing do not return an error or exception when a character is missing from the encoding, making the task of ensuring that data is not corrupted on serialization more difficult.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.Text

        getWholeText, isElementContentWhitespace, replaceWholeText, splitText

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


CharacterData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface CharacterData

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    CDATASection, Comment, Text, Text

    public interface CharacterData
extends Node
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM. For clarity this set is defined here rather than on each object that uses these attributes and methods. No DOM objects correspond directly to CharacterData, though Text and others do inherit the interface from it. All offsets in this interface start from 0.

    As explained in the DOMString interface, text strings in the DOM are represented in UTF-16, i.e. as a sequence of 16-bit units. In the following, the term 16-bit units is used whenever necessary to indicate that indexing on CharacterData is done in 16-bit units.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void appendData(String arg)
      Append the string to the end of the character data of the node.
      void deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      String getData()
      The character data of the node that implements this interface.
      int getLength()
      The number of 16-bit units that are available through data and the substringData method below.
      void insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      void setData(String data)
      The character data of the node that implements this interface.
      String substringData(int offset, int count)
      Extracts a range of data from the node.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getData

        String getData()
        throws DOMException
        The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

      • setData

        void setData(String data)
      throws DOMException
        The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

      • getLength

        int getLength()
        The number of 16-bit units that are available through data and the substringData method below. This may have the value zero, i.e., CharacterData nodes may be empty.

      • substringData

        String substringData(int offset,
                     int count)
              throws DOMException
        Extracts a range of data from the node.
        Parameters:
        offset - Start offset of substring to extract.
        count - The number of 16-bit units to extract.
        Returns:
        The specified substring. If the sum of offset and count exceeds the length, then all 16-bit units to the end of the data are returned.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        DOMSTRING_SIZE_ERR: Raised if the specified range of text does not fit into a DOMString.

      • appendData

        void appendData(String arg)
         throws DOMException
        Append the string to the end of the character data of the node. Upon success, data provides access to the concatenation of data and the DOMString specified.
        Parameters:
        arg - The DOMString to append.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • insertData

        void insertData(int offset,
                String arg)
         throws DOMException
        Insert a string at the specified 16-bit unit offset.
        Parameters:
        offset - The character offset at which to insert.
        arg - The DOMString to insert.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • deleteData

        void deleteData(int offset,
                int count)
         throws DOMException
        Remove a range of 16-bit units from the node. Upon success, data and length reflect the change.
        Parameters:
        offset - The offset from which to start removing.
        count - The number of 16-bit units to delete. If the sum of offset and count exceeds length then all 16-bit units from offset to the end of the data are deleted.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • replaceData

        void replaceData(int offset,
                 int count,
                 String arg)
          throws DOMException
        Replace the characters starting at the specified 16-bit unit offset with the specified string.
        Parameters:
        offset - The offset from which to start replacing.
        count - The number of 16-bit units to replace. If the sum of offset and count exceeds length, then all 16-bit units to the end of the data are replaced; (i.e., the effect is the same as a remove method call with the same range, followed by an append method invocation).
        arg - The DOMString with which the range must be replaced.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Comment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Comment

  • All Superinterfaces:
    CharacterData, Node

    public interface Comment
extends CharacterData
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'. Note that this is the definition of a comment in XML, and, in practice, HTML, although some HTML tools may implement the full SGML comment structure.

    No lexical check is done on the content of a comment and it is therefore possible to have the character sequence "--" (double-hyphen) in the content, which is illegal in a comment per section 2.5 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.w3c.dom (Java Platform SE 8 )

compact2 - org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM).

See: Description

  • Interface Summary
    Interface Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM). Supports the Document Object Model Level 2 Core APIi, Document Object Model (DOM) Level 3 Core, and Document Object Model (DOM) Level 3 Load and Save.
Since:
JDK1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.w3c.dom (Java Platform SE 8 )

compact3 - org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM).

See: Description

  • Interface Summary
    Interface Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM). Supports the Document Object Model Level 2 Core APIi, Document Object Model (DOM) Level 3 Core, and Document Object Model (DOM) Level 3 Load and Save.
Since:
JDK1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Document (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Document

  • All Superinterfaces:
    Node
    All Known Implementing Classes:
    SOAPPart

    public interface Document
extends Node
    The Document interface represents the entire HTML or XML document. Conceptually, it is the root of the document tree, and provides the primary access to the document's data.

    Since elements, text nodes, comments, processing instructions, etc. cannot exist outside the context of a Document, the Document interface also contains the factory methods needed to create these objects. The Node objects created have a ownerDocument attribute which associates them with the Document within whose context they were created.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Node adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Attr createAttribute(String name)
      Creates an Attr of the given name.
      Attr createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Comment createComment(String data)
      Creates a Comment node given the specified string.
      DocumentFragment createDocumentFragment()
      Creates an empty DocumentFragment object.
      Element createElement(String tagName)
      Creates an element of the type specified.
      Element createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      Text createTextNode(String data)
      Creates a Text node given the specified string.
      DocumentType getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Element getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      String getDocumentURI()
      The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
      DOMConfiguration getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.
      Element getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      NodeList getElementsByTagName(String tagname)
      Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
      NodeList getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
      DOMImplementation getImplementation()
      The DOMImplementation object that handles this document.
      String getInputEncoding()
      An attribute specifying the encoding used for this document at the time of the parsing.
      boolean getStrictErrorChecking()
      An attribute specifying whether error checking is enforced or not.
      String getXmlEncoding()
      An attribute specifying, as part of the XML declaration, the encoding of this document.
      boolean getXmlStandalone()
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      String getXmlVersion()
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Node importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      void normalizeDocument()
      This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form.
      Node renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      void setDocumentURI(String documentURI)
      The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
      void setStrictErrorChecking(boolean strictErrorChecking)
      An attribute specifying whether error checking is enforced or not.
      void setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getDoctype

        DocumentType getDoctype()
        The Document Type Declaration (see DocumentType) associated with this document. For XML documents without a document type declaration this returns null. For HTML documents, a DocumentType object may be returned, independently of the presence or absence of document type declaration in the HTML document.
        This provides direct access to the DocumentType node, child node of this Document. This node can be set at document creation time and later changed through the use of child nodes manipulation methods, such as Node.insertBefore, or Node.replaceChild. Note, however, that while some implementations may instantiate different types of Document objects supporting additional features than the "Core", such as "HTML" [DOM Level 2 HTML] , based on the DocumentType specified at creation time, changing it afterwards is very unlikely to result in a change of the features supported.
        Since:
        DOM Level 3

      • getImplementation

        DOMImplementation getImplementation()
        The DOMImplementation object that handles this document. A DOM application may use objects from multiple implementations.

      • getDocumentElement

        Element getDocumentElement()
        This is a convenience attribute that allows direct access to the child node that is the document element of the document.

      • createElement

        Element createElement(String tagName)
               throws DOMException
        Creates an element of the type specified. Note that the instance returned implements the Element interface, so attributes can be specified directly on the returned object.
        In addition, if there are known attributes with default values, Attr nodes representing them are automatically created and attached to the element.
        To create an element with a qualified name and namespace URI, use the createElementNS method.
        Parameters:
        tagName - The name of the element type to instantiate. For XML, this is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use. In that case, the name is mapped to the canonical form of that markup by the DOM implementation.
        Returns:
        A new Element object with the nodeName attribute set to tagName, and localName, prefix, and namespaceURI set to null.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

      • createDocumentFragment

        DocumentFragment createDocumentFragment()
        Creates an empty DocumentFragment object.
        Returns:
        A new DocumentFragment.

      • createTextNode

        Text createTextNode(String data)
        Creates a Text node given the specified string.
        Parameters:
        data - The data for the node.
        Returns:
        The new Text object.

      • createComment

        Comment createComment(String data)
        Creates a Comment node given the specified string.
        Parameters:
        data - The data for the node.
        Returns:
        The new Comment object.

      • createCDATASection

        CDATASection createCDATASection(String data)
                         throws DOMException
        Creates a CDATASection node whose value is the specified string.
        Parameters:
        data - The data for the CDATASection contents.
        Returns:
        The new CDATASection object.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • createProcessingInstruction

        ProcessingInstruction createProcessingInstruction(String target,
                                                  String data)
                                           throws DOMException
        Creates a ProcessingInstruction node given the specified name and data strings.
        Parameters:
        target - The target part of the processing instruction.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the target name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the target name is namespace well-formed.
        data - The data for the node.
        Returns:
        The new ProcessingInstruction object.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified target is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • createAttribute

        Attr createAttribute(String name)
              throws DOMException
        Creates an Attr of the given name. Note that the Attr instance can then be set on an Element using the setAttributeNode method.
        To create an attribute with a qualified name and namespace URI, use the createAttributeNS method.
        Parameters:
        name - The name of the attribute.
        Returns:
        A new Attr object with the nodeName attribute set to name, and localName, prefix, and namespaceURI set to null. The value of the attribute is the empty string.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

      • createEntityReference

        EntityReference createEntityReference(String name)
                               throws DOMException
        Creates an EntityReference object. In addition, if the referenced entity is known, the child list of the EntityReference node is made the same as that of the corresponding Entity node.

        Note: If any descendant of the Entity node has an unbound namespace prefix, the corresponding descendant of the created EntityReference node is also unbound; (its namespaceURI is null). The DOM Level 2 and 3 do not support any mechanism to resolve namespace prefixes in this case.

        Parameters:
        name - The name of the entity to reference.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the entity name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the entity name is namespace well-formed.
        Returns:
        The new EntityReference object.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • getElementsByTagName

        NodeList getElementsByTagName(String tagname)
        Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
        Parameters:
        tagname - The name of the tag to match on. The special value "*" matches all tags. For XML, the tagname parameter is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use.
        Returns:
        A new NodeList object containing all the matched Elements.

      • importNode

        Node importNode(Node importedNode,
                boolean deep)
         throws DOMException
        Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node. The returned node has no parent; (parentNode is null).
        For all nodes, importing a node creates a node object owned by the importing document, with attribute values identical to the source node's nodeName and nodeType, plus the attributes related to namespaces (prefix, localName, and namespaceURI). As in the cloneNode operation, the source node is not altered. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
        Additional information is copied as appropriate to the nodeType, attempting to mirror the behavior expected if a fragment of XML or HTML source was copied from one document to another, recognizing that the two documents may have different DTDs in the XML case. The following list describes the specifics for each type of node.
        ATTRIBUTE_NODE
        The ownerElement attribute is set to null and the specified flag is set to true on the generated Attr. The descendants of the source Attr are recursively imported and the resulting nodes reassembled to form the corresponding subtree. Note that the deep parameter has no effect on Attr nodes; they always carry their children with them when imported.
        DOCUMENT_FRAGMENT_NODE
        If the deep option was set to true, the descendants of the source DocumentFragment are recursively imported and the resulting nodes reassembled under the imported DocumentFragment to form the corresponding subtree. Otherwise, this simply generates an empty DocumentFragment.
        DOCUMENT_NODE
        Document nodes cannot be imported.
        DOCUMENT_TYPE_NODE
        DocumentType nodes cannot be imported.
        ELEMENT_NODE
        Specified attribute nodes of the source element are imported, and the generated Attr nodes are attached to the generated Element. Default attributes are not copied, though if the document being imported into defines default attributes for this element name, those are assigned. If the importNode deep parameter was set to true, the descendants of the source element are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
        ENTITY_NODE
        Entity nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId, systemId, and notationName attributes are copied. If a deep import is requested, the descendants of the the source Entity are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
        ENTITY_REFERENCE_NODE
        Only the EntityReference itself is copied, even if a deep import is requested, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
        NOTATION_NODE
        Notation nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId and systemId attributes are copied. Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
        PROCESSING_INSTRUCTION_NODE
        The imported node copies its target and data values from those of the source node.Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
        These three types of nodes inheriting from CharacterData copy their data and length attributes from those of the source node.Note that the deep parameter has no effect on these types of nodes since they cannot have any children.
        Parameters:
        importedNode - The node to import.
        deep - If true, recursively import the subtree under the specified node; if false, import only the node itself, as explained above. This has no effect on nodes that cannot have any children, and on Attr, and EntityReference nodes.
        Returns:
        The imported node that belongs to this Document.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the type of node being imported is not supported.
        INVALID_CHARACTER_ERR: Raised if one of the imported names is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute. This may happen when importing an XML 1.1 [XML 1.1] element into an XML 1.0 document, for instance.
        Since:
        DOM Level 2

      • createElementNS

        Element createElementNS(String namespaceURI,
                        String qualifiedName)
                 throws DOMException
        Creates an element of the given qualified name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the element to create.
        qualifiedName - The qualified name of the element type to instantiate.
        Returns:
        A new Element object with the following attributes:
        Attribute | Value
        Node.nodeName | qualifiedName
        Node.namespaceURI | namespaceURI
        Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
        Node.localName | local name, extracted from qualifiedName
        Element.tagName | qualifiedName
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
        Since:
        DOM Level 2

      • createAttributeNS

        Attr createAttributeNS(String namespaceURI,
                       String qualifiedName)
                throws DOMException
        Creates an attribute of the given qualified name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to create.
        qualifiedName - The qualified name of the attribute to instantiate.
        Returns:
        A new Attr object with the following attributes:
        Attribute | Value
        Node.nodeName | qualifiedName
        Node.namespaceURI | namespaceURI
        Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
        Node.localName | local name, extracted from qualifiedName
        Attr.name | qualifiedName
        Node.nodeValue | the empty string
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
        Since:
        DOM Level 2

      • getElementsByTagNameNS

        NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
        Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
        Parameters:
        namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
        localName - The local name of the elements to match on. The special value "*" matches all local names.
        Returns:
        A new NodeList object containing all the matched Elements.
        Since:
        DOM Level 2

      • getElementById

        Element getElementById(String elementId)
        Returns the Element that has an ID attribute with the given value. If no such element exists, this returns null . If more than one element has an ID attribute with that value, what is returned is undefined.
        The DOM implementation is expected to use the attribute Attr.isId to determine if an attribute is of type ID.

        Note: Attributes with the name "ID" or "id" are not of type ID unless so defined.

        Parameters:
        elementId - The unique id value for an element.
        Returns:
        The matching element or null if there is none.
        Since:
        DOM Level 2

      • getInputEncoding

        String getInputEncoding()
        An attribute specifying the encoding used for this document at the time of the parsing. This is null when it is not known, such as when the Document was created in memory.
        Since:
        DOM Level 3

      • getXmlEncoding

        String getXmlEncoding()
        An attribute specifying, as part of the XML declaration, the encoding of this document. This is null when unspecified or when it is not known, such as when the Document was created in memory.
        Since:
        DOM Level 3

      • getXmlStandalone

        boolean getXmlStandalone()
        An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

        Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

        Since:
        DOM Level 3

      • setXmlStandalone

        void setXmlStandalone(boolean xmlStandalone)
               throws DOMException
        An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

        Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if this document does not support the "XML" feature.
        Since:
        DOM Level 3

      • getXmlVersion

        String getXmlVersion()
        An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
        DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.
        Since:
        DOM Level 3

      • setXmlVersion

        void setXmlVersion(String xmlVersion)
            throws DOMException
        An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
        DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the version is set to a value that is not supported by this Document or if this document does not support the "XML" feature.
        Since:
        DOM Level 3

      • getStrictErrorChecking

        boolean getStrictErrorChecking()
        An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.
        Since:
        DOM Level 3

      • setStrictErrorChecking

        void setStrictErrorChecking(boolean strictErrorChecking)
        An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.
        Since:
        DOM Level 3

      • getDocumentURI

        String getDocumentURI()
        The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
        Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.
        Since:
        DOM Level 3

      • setDocumentURI

        void setDocumentURI(String documentURI)
        The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
        Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.
        Since:
        DOM Level 3

      • adoptNode

        Node adoptNode(Node source)
        throws DOMException
        Attempts to adopt a node from another document to this document. If supported, it changes the ownerDocument of the source node, its children, as well as the attached attribute nodes if there are any. If the source node has a parent it is first removed from the child list of its parent. This effectively allows moving a subtree from one document to another (unlike importNode() which create a copy of the source node instead of moving it). When it fails, applications should use Document.importNode() instead. Note that if the adopted node is already part of this document (i.e. the source and target document are the same), this method still has the effect of removing the source node from the child list of its parent, if any. The following list describes the specifics for each type of node.
        ATTRIBUTE_NODE
        The ownerElement attribute is set to null and the specified flag is set to true on the adopted Attr. The descendants of the source Attr are recursively adopted.
        DOCUMENT_FRAGMENT_NODE
        The descendants of the source node are recursively adopted.
        DOCUMENT_NODE
        Document nodes cannot be adopted.
        DOCUMENT_TYPE_NODE
        DocumentType nodes cannot be adopted.
        ELEMENT_NODE
        Specified attribute nodes of the source element are adopted. Default attributes are discarded, though if the document being adopted into defines default attributes for this element name, those are assigned. The descendants of the source element are recursively adopted.
        ENTITY_NODE
        Entity nodes cannot be adopted.
        ENTITY_REFERENCE_NODE
        Only the EntityReference node itself is adopted, the descendants are discarded, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
        NOTATION_NODE
        Notation nodes cannot be adopted.
        PROCESSING_INSTRUCTION_NODE, TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
        These nodes can all be adopted. No specifics.

        Note: Since it does not create new nodes unlike the Document.importNode() method, this method does not raise an INVALID_CHARACTER_ERR exception, and applications should use the Document.normalizeDocument() method to check if an imported name is not an XML name according to the XML version in use.

        Parameters:
        source - The node to move into this document.
        Returns:
        The adopted node, or null if this operation fails, such as when the source node comes from a different implementation.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the source node is of type DOCUMENT, DOCUMENT_TYPE.
        NO_MODIFICATION_ALLOWED_ERR: Raised when the source node is readonly.
        Since:
        DOM Level 3

      • getDomConfig

        DOMConfiguration getDomConfig()
        The configuration used when Document.normalizeDocument() is invoked.
        Since:
        DOM Level 3

      • normalizeDocument

        void normalizeDocument()
        This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form. As a consequence, this method updates the replacement tree of EntityReference nodes and normalizes Text nodes, as defined in the method Node.normalize().
        Otherwise, the actual result depends on the features being set on the Document.domConfig object and governing what operations actually take place. Noticeably this method could also make the document namespace well-formed according to the algorithm described in , check the character normalization, remove the CDATASection nodes, etc. See DOMConfiguration for details.
        // Keep in the document
 the information defined // in the XML Information Set (Java example)
 DOMConfiguration docConfig = myDocument.getDomConfig();
 docConfig.setParameter("infoset", Boolean.TRUE);
 myDocument.normalizeDocument();

        Mutation events, when supported, are generated to reflect the changes occurring on the document.
        If errors occur during the invocation of this method, such as an attempt to update a read-only node or a Node.nodeName contains an invalid character according to the XML version in use, errors or warnings (DOMError.SEVERITY_ERROR or DOMError.SEVERITY_WARNING) will be reported using the DOMErrorHandler object associated with the "error-handler " parameter. Note this method might also report fatal errors ( DOMError.SEVERITY_FATAL_ERROR) if an implementation cannot recover from an error.
        Since:
        DOM Level 3

      • renameNode

        Node renameNode(Node n,
                String namespaceURI,
                String qualifiedName)
         throws DOMException
        Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
        When possible this simply changes the name of the given node, otherwise this creates a new node with the specified name and replaces the existing node with the new node as described below.
        If simply changing the name of the given node is not possible, the following operations are performed: a new node is created, any registered event listener is registered on the new node, any user data attached to the old node is removed from that node, the old node is removed from its parent if it has one, the children are moved to the new node, if the renamed node is an Element its attributes are moved to the new node, the new node is inserted at the position the old node used to have in its parent's child nodes list if it has one, the user data that was attached to the old node is attached to the new node.
        When the node being renamed is an Element only the specified attributes are moved, default attributes originated from the DTD are updated according to the new element name. In addition, the implementation may update default attributes from other schemas. Applications should use Document.normalizeDocument() to guarantee these attributes are up-to-date.
        When the node being renamed is an Attr that is attached to an Element, the node is first removed from the Element attributes map. Then, once renamed, either by modifying the existing node or creating a new one as described above, it is put back.
        In addition,
        • a user data event NODE_RENAMED is fired,
        • when the implementation supports the feature "MutationNameEvents", each mutation operation involved in this method fires the appropriate event, and in the end the event { http://www.w3.org/2001/xml-events, DOMElementNameChanged} or { http://www.w3.org/2001/xml-events, DOMAttributeNameChanged} is fired.
        Parameters:
        n - The node to rename.
        namespaceURI - The new namespace URI.
        qualifiedName - The new qualified name.
        Returns:
        The renamed node. This is either the specified node or the new node that was created to replace the specified node.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised when the type of the specified node is neither ELEMENT_NODE nor ATTRIBUTE_NODE, or if the implementation does not support the renaming of the document element.
        INVALID_CHARACTER_ERR: Raised if the new qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        WRONG_DOCUMENT_ERR: Raised when the specified node was created from a different document than this document.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] . Also raised, when the node being renamed is an attribute, if the qualifiedName, or its prefix, is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/".
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentFragment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DocumentFragment

  • All Superinterfaces:
    Node

    public interface DocumentFragment
extends Node
    DocumentFragment is a "lightweight" or "minimal" Document object. It is very common to want to be able to extract a portion of a document's tree or to create a new fragment of a document. Imagine implementing a user command like cut or rearranging a document by moving fragments around. It is desirable to have an object which can hold such fragments and it is quite natural to use a Node for this purpose. While it is true that a Document object could fulfill this role, a Document object can potentially be a heavyweight object, depending on the underlying implementation. What is really needed for this is a very lightweight object. DocumentFragment is such an object.

    Furthermore, various operations -- such as inserting nodes as children of another Node -- may take DocumentFragment objects as arguments; this results in all the child nodes of the DocumentFragment being moved to the child list of this node.

    The children of a DocumentFragment node are zero or more nodes representing the tops of any sub-trees defining the structure of the document. DocumentFragment nodes do not need to be well-formed XML documents (although they do need to follow the rules imposed upon well-formed XML parsed entities, which can have multiple top nodes). For example, a DocumentFragment might have only one child and that child node could be a Text node. Such a structure model represents neither an HTML document nor a well-formed XML document.

    When a DocumentFragment is inserted into a Document (or indeed any other Node that may take children) the children of the DocumentFragment and not the DocumentFragment itself are inserted into the Node. This makes the DocumentFragment very useful when the user wishes to create nodes that are siblings; the DocumentFragment acts as the parent of these nodes so that the user can use the standard methods from the Node interface, such as Node.insertBefore and Node.appendChild.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DocumentType

  • All Superinterfaces:
    Node

    public interface DocumentType
extends Node
    Each Document has a doctype attribute whose value is either null or a DocumentType object. The DocumentType interface in the DOM Core provides an interface to the list of entities that are defined for the document, and little else because the effect of namespaces and the various XML schema efforts on DTD representation are not clearly understood as of this writing.

    DOM Level 3 doesn't support editing DocumentType nodes. DocumentType nodes are read-only.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      NamedNodeMap getEntities()
      A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
      String getInternalSubset()
      The internal subset as a string, or null if there is none.
      String getName()
      The name of DTD; i.e., the name immediately following the DOCTYPE keyword.
      NamedNodeMap getNotations()
      A NamedNodeMap containing the notations declared in the DTD.
      String getPublicId()
      The public identifier of the external subset.
      String getSystemId()
      The system identifier of the external subset.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getName

        String getName()
        The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

      • getEntities

        NamedNodeMap getEntities()
        A NamedNodeMap containing the general entities, both external and internal, declared in the DTD. Parameter entities are not contained. Duplicates are discarded. For example in:
        <!DOCTYPE
 ex SYSTEM "ex.dtd" [ <!ENTITY foo "foo"> <!ENTITY bar
 "bar"> <!ENTITY bar "bar2"> <!ENTITY % baz "baz">
 ]> <ex/>
        the interface provides access to foo and the first declaration of bar but not the second declaration of bar or baz. Every node in this map also implements the Entity interface.
        The DOM Level 2 does not support editing entities, therefore entities cannot be altered in any way.

      • getNotations

        NamedNodeMap getNotations()
        A NamedNodeMap containing the notations declared in the DTD. Duplicates are discarded. Every node in this map also implements the Notation interface.
        The DOM Level 2 does not support editing notations, therefore notations cannot be altered in any way.

      • getPublicId

        String getPublicId()
        The public identifier of the external subset.
        Since:
        DOM Level 2

      • getSystemId

        String getSystemId()
        The system identifier of the external subset. This may be an absolute URI or not.
        Since:
        DOM Level 2

      • getInternalSubset

        String getInternalSubset()
        The internal subset as a string, or null if there is none. This is does not contain the delimiting square brackets.

        Note: The actual content returned depends on how much information is available to the implementation. This may vary depending on various parameters, including the XML processor used to build the document.

        Since:
        DOM Level 2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMConfiguration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMConfiguration

  • public interface DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters. Using the configuration, it is possible to change Document.normalizeDocument() behavior, such as replacing the CDATASection nodes with Text nodes or specifying the type of the schema that must be used when the validation of the Document is requested. DOMConfiguration objects are also used in [DOM Level 3 Load and Save] in the DOMParser and DOMSerializer interfaces.

    The parameter names used by the DOMConfiguration object are defined throughout the DOM Level 3 specifications. Names are case-insensitive. To avoid possible conflicts, as a convention, names referring to parameters defined outside the DOM specification should be made unique. Because parameters are exposed as properties in names are recommended to follow the section 5.16 Identifiers of [Unicode] with the addition of the character '-' (HYPHEN-MINUS) but it is not enforced by the DOM implementation. DOM Level 3 Core Implementations are required to recognize all parameters defined in this specification. Some parameter values may also be required to be supported by the implementation. Refer to the definition of the parameter to know if a value must be supported or not.

    Note: Parameters are similar to features and properties used in SAX2 [SAX].

    The following list of parameters defined in the DOM:

    "canonical-form"
    true
    [optional] Canonicalize the document according to the rules specified in [Canonical XML], such as removing the DocumentType node (if any) from the tree, or removing superfluous namespace declarations from each element. Note that this is limited to what can be represented in the DOM; in particular, there is no way to specify the order of the attributes in the DOM. In addition, Setting this parameter to true will also set the state of the parameters listed below. Later changes to the state of one of those parameters will revert "canonical-form" back to false. Parameters set to false: "entities", " normalize-characters", "cdata-sections". Parameters set to true: "namespaces", "namespace-declarations", "well-formed", "element-content-whitespace". Other parameters are not changed unless explicitly specified in the description of the parameters.
    false
    [required] (default)Do not canonicalize the document.
    "cdata-sections"
    true
    [required] (default)Keep CDATASection nodes in the document.
    false
    [required]Transform CDATASection nodes in the document into Text nodes. The new Text node is then combined with any adjacent Text node.
    "check-character-normalization"
    true
    [optional] Check if the characters in the document are fully normalized, as defined in appendix B of [XML 1.1]. When a sequence of characters is encountered that fails normalization checking, an error with the DOMError.type equals to "check-character-normalization-failure" is issued.
    false
    [required] (default)Do not check if characters are normalized.
    "comments"
    true
    [required] (default)Keep Comment nodes in the document.
    false
    [required]Discard Comment nodes in the document.
    "datatype-normalization"
    true
    [optional] Expose schema normalized values in the tree, such as XML Schema normalized values in the case of XML Schema. Since this parameter requires to have schema information, the "validate" parameter will also be set to true. Having this parameter activated when "validate" is false has no effect and no schema-normalization will happen.

    Note: Since the document contains the result of the XML 1.0 processing, this parameter does not apply to attribute value normalization as defined in section 3.3.3 of [XML 1.0] and is only meant for schema languages other than Document Type Definition (DTD).

    false
    [required] (default) Do not perform schema normalization on the tree.
    "element-content-whitespace"
    true
    [required] (default)Keep all whitespaces in the document.
    false
    [optional] Discard all Text nodes that contain whitespaces in element content, as described in [element content whitespace]. The implementation is expected to use the attribute Text.isElementContentWhitespace to determine if a Text node should be discarded or not.
    "entities"
    true
    [required] (default)Keep EntityReference nodes in the document.
    false
    [required] Remove all EntityReference nodes from the document, putting the entity expansions directly in their place. Text nodes are normalized, as defined in Node.normalize. Only unexpanded entity references are kept in the document.

    Note: This parameter does not affect Entity nodes.

    "error-handler"
    [required] Contains a DOMErrorHandler object. If an error is encountered in the document, the implementation will call back the DOMErrorHandler registered using this parameter. The implementation may provide a default DOMErrorHandler object. When called, DOMError.relatedData will contain the closest node to where the error occurred. If the implementation is unable to determine the node where the error occurs, DOMError.relatedData will contain the Document node. Mutations to the document from within an error handler will result in implementation dependent behavior.
    "infoset"
    true
    [required]Keep in the document the information defined in the XML Information Set [XML Information Set] .This forces the following parameters to false: " validate-if-schema", "entities", "datatype-normalization", "cdata-sections ".This forces the following parameters to true: " namespace-declarations", "well-formed", "element-content-whitespace", " comments", "namespaces".Other parameters are not changed unless explicitly specified in the description of the parameters. Note that querying this parameter with getParameter returns true only if the individual parameters specified above are appropriately set.
    false
    Setting infoset to false has no effect.
    "namespaces"
    true
    [required] (default) Perform the namespace processing as defined in .
    false
    [optional] Do not perform the namespace processing.
    "namespace-declarations"
    This parameter has no effect if the parameter "namespaces" is set to false.
    true
    [required] (default) Include namespace declaration attributes, specified or defaulted from the schema, in the document. See also the sections "Declaring Namespaces" in [XML Namespaces] and [XML Namespaces 1.1] .
    false
    [required]Discard all namespace declaration attributes. The namespace prefixes ( Node.prefix) are retained even if this parameter is set to false.
    "normalize-characters"
    true
    [optional] Fully normalized the characters in the document as defined in appendix B of [XML 1.1].
    false
    [required] (default)Do not perform character normalization.
    "schema-location"
    [optional] Represent a DOMString object containing a list of URIs, separated by whitespaces (characters matching the nonterminal production S defined in section 2.3 [XML 1.0]), that represents the schemas against which validation should occur, i.e. the current schema. The types of schemas referenced in this list must match the type specified with schema-type, otherwise the behavior of an implementation is undefined. The schemas specified using this property take precedence to the schema information specified in the document itself. For namespace aware schema, if a schema specified using this property and a schema specified in the document instance (i.e. using the schemaLocation attribute) in a schema document (i.e. using schema import mechanisms) share the same targetNamespace, the schema specified by the user using this property will be used. If two schemas specified using this property share the same targetNamespace or have no namespace, the behavior is implementation dependent. If no location has been provided, this parameter is null.

    Note: The "schema-location" parameter is ignored unless the "schema-type" parameter value is set. It is strongly recommended that Document.documentURI will be set so that an implementation can successfully resolve any external entities referenced.

    "schema-type"
    [optional] Represent a DOMString object containing an absolute URI and representing the type of the schema language used to validate a document against. Note that no lexical checking is done on the absolute URI. If this parameter is not set, a default value may be provided by the implementation, based on the schema languages supported and on the schema language used at load time. If no value is provided, this parameter is null.

    Note: For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

    "split-cdata-sections"
    true
    [required] (default)Split CDATA sections containing the CDATA section termination marker ']]>'. When a CDATA section is split a warning is issued with a DOMError.type equals to "cdata-sections-splitted" and DOMError.relatedData equals to the first CDATASection node in document order resulting from the split.
    false
    [required]Signal an error if a CDATASection contains an unrepresentable character.
    "validate"
    true
    [optional] Require the validation against a schema (i.e. XML schema, DTD, any other type or representation of schema) of the document as it is being normalized as defined by [XML 1.0]. If validation errors are found, or no schema was found, the error handler is notified. Schema-normalized values will not be exposed according to the schema in used unless the parameter "datatype-normalization" is true. This parameter will reevaluate:
    • Attribute nodes with Attr.specified equals to false, as specified in the description of the Attr interface;
    • The value of the attribute Text.isElementContentWhitespace for all Text nodes;
    • The value of the attribute Attr.isId for all Attr nodes;
    • The attributes Element.schemaTypeInfo and Attr.schemaTypeInfo.

    Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false. Applications should also consider setting the parameter "well-formed" to true, which is the default for that option, when validating the document.

    false
    [required] (default) Do not accomplish schema processing, including the internal subset processing. Default attribute values information are kept. Note that validation might still happen if "validate-if-schema" is true .
    "validate-if-schema"
    true
    [optional]Enable validation only if a declaration for the document element can be found in a schema (independently of where it is found, i.e. XML schema, DTD, or any other type or representation of schema). If validation is enabled, this parameter has the same behavior as the parameter "validate" set to true.

    Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false.

    false
    [required] (default) No schema processing should be performed if the document has a schema, including internal subset processing. Default attribute values information are kept. Note that validation must still happen if "validate " is true.
    "well-formed"
    true
    [required] (default) Check if all nodes are XML well formed according to the XML version in use in Document.xmlVersion:
    • check if the attribute Node.nodeName contains invalid characters according to its node type and generate a DOMError of type "wf-invalid-character-in-node-name", with a DOMError.SEVERITY_ERROR severity, if necessary;
    • check if the text content inside Attr, Element, Comment, Text, CDATASection nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
    • check if the data inside ProcessingInstruction nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
    false
    [optional] Do not check for XML well-formedness.

    The resolution of the system identifiers associated with entities is done using Document.documentURI. However, when the feature "LS" defined in [DOM Level 3 Load and Save] is supported by the DOM implementation, the parameter "resource-resolver" can also be used on DOMConfiguration objects attached to Document nodes. If this parameter is set, Document.normalizeDocument() will invoke the resource resolver instead of using Document.documentURI.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean canSetParameter(String name, Object value)
      Check if setting a parameter to a specific value is supported.
      Object getParameter(String name)
      Return the value of a parameter if known.
      DOMStringList getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
      void setParameter(String name, Object value)
      Set the value of a parameter.

    • Method Detail

      • setParameter

        void setParameter(String name,
                  Object value)
           throws DOMException
        Set the value of a parameter.
        Parameters:
        name - The name of the parameter to set.
        value - The new value or null if the user wishes to unset the parameter. While the type of the value parameter is defined as DOMUserData, the object type must match the type defined by the definition of the parameter. For example, if the parameter is "error-handler", the value must be of type DOMErrorHandler.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.
        NOT_SUPPORTED_ERR: Raised when the parameter name is recognized but the requested value cannot be set.
        TYPE_MISMATCH_ERR: Raised if the value type for this parameter name is incompatible with the expected value type.

      • getParameter

        Object getParameter(String name)
             throws DOMException
        Return the value of a parameter if known.
        Parameters:
        name - The name of the parameter.
        Returns:
        The current object associated with the specified parameter or null if no object has been associated or if the parameter is not supported.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.

      • canSetParameter

        boolean canSetParameter(String name,
                        Object value)
        Check if setting a parameter to a specific value is supported.
        Parameters:
        name - The name of the parameter to check.
        value - An object. if null, the returned value is true.
        Returns:
        true if the parameter could be successfully set to the specified value, or false if the parameter is not recognized or the requested value is not supported. This does not change the current value of the parameter itself.

      • getParameterNames

        DOMStringList getParameterNames()
        The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application. Note that this list can also contain parameter names defined outside this specification.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMError

  • public interface DOMError
    DOMError is an interface that describes an error.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short SEVERITY_ERROR
      The severity of the error described by the DOMError is error.
      static short SEVERITY_FATAL_ERROR
      The severity of the error described by the DOMError is fatal error.
      static short SEVERITY_WARNING
      The severity of the error described by the DOMError is warning.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DOMLocator getLocation()
      The location of the error.
      String getMessage()
      An implementation specific string describing the error that occurred.
      Object getRelatedData()
      The related DOMError.type dependent data if any.
      Object getRelatedException()
      The related platform dependent exception if any.
      short getSeverity()
      The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.
      String getType()
      A DOMString indicating which related data is expected in relatedData.

    • Field Detail

      • SEVERITY_WARNING

        static final short SEVERITY_WARNING
        The severity of the error described by the DOMError is warning. A SEVERITY_WARNING will not cause the processing to stop, unless DOMErrorHandler.handleError() returns false.
        See Also:
        Constant Field Values

      • SEVERITY_ERROR

        static final short SEVERITY_ERROR
        The severity of the error described by the DOMError is error. A SEVERITY_ERROR may not cause the processing to stop if the error can be recovered, unless DOMErrorHandler.handleError() returns false.
        See Also:
        Constant Field Values

      • SEVERITY_FATAL_ERROR

        static final short SEVERITY_FATAL_ERROR
        The severity of the error described by the DOMError is fatal error. A SEVERITY_FATAL_ERROR will cause the normal processing to stop. The return value of DOMErrorHandler.handleError() is ignored unless the implementation chooses to continue, in which case the behavior becomes undefined.
        See Also:
        Constant Field Values

    • Method Detail

      • getSeverity

        short getSeverity()
        The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.

      • getMessage

        String getMessage()
        An implementation specific string describing the error that occurred.

      • getType

        String getType()
        A DOMString indicating which related data is expected in relatedData. Users should refer to the specification of the error in order to find its DOMString type and relatedData definitions if any.

        Note: As an example, Document.normalizeDocument() does generate warnings when the "split-cdata-sections" parameter is in use. Therefore, the method generates a SEVERITY_WARNING with type "cdata-sections-splitted" and the first CDATASection node in document order resulting from the split is returned by the relatedData attribute.

      • getRelatedException

        Object getRelatedException()
        The related platform dependent exception if any.

      • getRelatedData

        Object getRelatedData()
        The related DOMError.type dependent data if any.

      • getLocation

        DOMLocator getLocation()
        The location of the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMErrorHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMErrorHandler

  • public interface DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g. validating a document). A DOMErrorHandler object can be attached to a Document using the "error-handler" on the DOMConfiguration interface. If more than one error needs to be reported during an operation, the sequence and numbers of the errors passed to the error handler are implementation dependent.

    The application that is using the DOM implementation is expected to implement this interface.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean handleError(DOMError error)
      This method is called on the error handler when an error occurs.

    • Method Detail

      • handleError

        boolean handleError(DOMError error)
        This method is called on the error handler when an error occurs.
        If an exception is thrown from this method, it is considered to be equivalent of returning true.
        Parameters:
        error - The error object that describes the error. This object may be reused by the DOM implementation across multiple calls to the handleError method.
        Returns:
        If the handleError method returns false, the DOM implementation should stop the current processing when possible. If the method returns true, the processing may continue depending on DOMError.severity.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Class DOMException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException
  • All Implemented Interfaces:
    Serializable

    public class DOMException
extends RuntimeException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable). In general, DOM methods return specific error values in ordinary processing situations, such as out-of-bound errors when using NodeList.

    Implementations should raise other exceptions under other circumstances. For example, implementations should raise an implementation-dependent exception if a null argument is passed when null was not expected.

    Some languages and object systems do not support the concept of exceptions. For such systems, error conditions may be indicated using native error reporting mechanisms. For some bindings, for example, methods may return error codes similar to those listed in the corresponding method descriptions.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | code
      static short DOMSTRING_SIZE_ERR
      If the specified range of text does not fit into a DOMString.
      static short HIERARCHY_REQUEST_ERR
      If any Node is inserted somewhere it doesn't belong.
      static short INDEX_SIZE_ERR
      If index or size is negative, or greater than the allowed value.
      static short INUSE_ATTRIBUTE_ERR
      If an attempt is made to add an attribute that is already in use elsewhere.
      static short INVALID_ACCESS_ERR
      If a parameter or an operation is not supported by the underlying object.
      static short INVALID_CHARACTER_ERR
      If an invalid or illegal character is specified, such as in an XML name.
      static short INVALID_MODIFICATION_ERR
      If an attempt is made to modify the type of the underlying object.
      static short INVALID_STATE_ERR
      If an attempt is made to use an object that is not, or is no longer, usable.
      static short NAMESPACE_ERR
      If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
      static short NO_DATA_ALLOWED_ERR
      If data is specified for a Node which does not support data.
      static short NO_MODIFICATION_ALLOWED_ERR
      If an attempt is made to modify an object where modifications are not allowed.
      static short NOT_FOUND_ERR
      If an attempt is made to reference a Node in a context where it does not exist.
      static short NOT_SUPPORTED_ERR
      If the implementation does not support the requested type of object or operation.
      static short SYNTAX_ERR
      If an invalid or illegal string is specified.
      static short TYPE_MISMATCH_ERR
      If the type of an object is incompatible with the expected type of the parameter associated to the object.
      static short VALIDATION_ERR
      If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.
      static short WRONG_DOCUMENT_ERR
      If a Node is used in a different document than the one that created it (that doesn't support it).

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMException(short code, String message)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • code

        public short code

      • INDEX_SIZE_ERR

        public static final short INDEX_SIZE_ERR
        If index or size is negative, or greater than the allowed value.
        See Also:
        Constant Field Values

      • DOMSTRING_SIZE_ERR

        public static final short DOMSTRING_SIZE_ERR
        If the specified range of text does not fit into a DOMString.
        See Also:
        Constant Field Values

      • HIERARCHY_REQUEST_ERR

        public static final short HIERARCHY_REQUEST_ERR
        If any Node is inserted somewhere it doesn't belong.
        See Also:
        Constant Field Values

      • WRONG_DOCUMENT_ERR

        public static final short WRONG_DOCUMENT_ERR
        If a Node is used in a different document than the one that created it (that doesn't support it).
        See Also:
        Constant Field Values

      • INVALID_CHARACTER_ERR

        public static final short INVALID_CHARACTER_ERR
        If an invalid or illegal character is specified, such as in an XML name.
        See Also:
        Constant Field Values

      • NO_DATA_ALLOWED_ERR

        public static final short NO_DATA_ALLOWED_ERR
        If data is specified for a Node which does not support data.
        See Also:
        Constant Field Values

      • NO_MODIFICATION_ALLOWED_ERR

        public static final short NO_MODIFICATION_ALLOWED_ERR
        If an attempt is made to modify an object where modifications are not allowed.
        See Also:
        Constant Field Values

      • NOT_FOUND_ERR

        public static final short NOT_FOUND_ERR
        If an attempt is made to reference a Node in a context where it does not exist.
        See Also:
        Constant Field Values

      • NOT_SUPPORTED_ERR

        public static final short NOT_SUPPORTED_ERR
        If the implementation does not support the requested type of object or operation.
        See Also:
        Constant Field Values

      • INUSE_ATTRIBUTE_ERR

        public static final short INUSE_ATTRIBUTE_ERR
        If an attempt is made to add an attribute that is already in use elsewhere.
        See Also:
        Constant Field Values

      • INVALID_STATE_ERR

        public static final short INVALID_STATE_ERR
        If an attempt is made to use an object that is not, or is no longer, usable.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • SYNTAX_ERR

        public static final short SYNTAX_ERR
        If an invalid or illegal string is specified.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • INVALID_MODIFICATION_ERR

        public static final short INVALID_MODIFICATION_ERR
        If an attempt is made to modify the type of the underlying object.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • NAMESPACE_ERR

        public static final short NAMESPACE_ERR
        If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • INVALID_ACCESS_ERR

        public static final short INVALID_ACCESS_ERR
        If a parameter or an operation is not supported by the underlying object.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • VALIDATION_ERR

        public static final short VALIDATION_ERR
        If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done. This code is used in [DOM Level 3 Validation] . Refer to this specification for further information.
        Since:
        DOM Level 3
        See Also:
        Constant Field Values

      • TYPE_MISMATCH_ERR

        public static final short TYPE_MISMATCH_ERR
        If the type of an object is incompatible with the expected type of the parameter associated to the object.
        Since:
        DOM Level 3
        See Also:
        Constant Field Values

    • Constructor Detail

      • DOMException

        public DOMException(short code,
                    String message)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMImplementation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMImplementation

  • public interface DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Document createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Object getFeature(String feature, String version)
      This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features.
      boolean hasFeature(String feature, String version)
      Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.

    • Method Detail

      • hasFeature

        boolean hasFeature(String feature,
                   String version)
        Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.
        Parameters:
        feature - The name of the feature to test.
        version - This is the version number of the feature to test.
        Returns:
        true if the feature is implemented in the specified version, false otherwise.

      • createDocumentType

        DocumentType createDocumentType(String qualifiedName,
                                String publicId,
                                String systemId)
                         throws DOMException
        Creates an empty DocumentType node. Entity declarations and notations are not made available. Entity reference expansions and default attribute additions do not occur..
        Parameters:
        qualifiedName - The qualified name of the document type to be created.
        publicId - The external subset public identifier.
        systemId - The external subset system identifier.
        Returns:
        A new DocumentType node with Node.ownerDocument set to null.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
        NAMESPACE_ERR: Raised if the qualifiedName is malformed.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • createDocument

        Document createDocument(String namespaceURI,
                        String qualifiedName,
                        DocumentType doctype)
                 throws DOMException
        Creates a DOM Document object of the specified type with its document element.
        Note that based on the DocumentType given to create the document, the implementation may instantiate specialized Document objects that support additional features than the "Core", such as "HTML" [DOM Level 2 HTML] . On the other hand, setting the DocumentType after the document was created makes this very unlikely to happen. Alternatively, specialized Document creation methods, such as createHTMLDocument [DOM Level 2 HTML] , can be used to obtain specific types of Document objects.
        Parameters:
        namespaceURI - The namespace URI of the document element to create or null.
        qualifiedName - The qualified name of the document element to be created or null.
        doctype - The type of document to be created or null. When doctype is not null, its Node.ownerDocument attribute is set to the document being created.
        Returns:
        A new Document object with its document element. If the NamespaceURI, qualifiedName, and doctype are null, the returned Document is empty with no document element.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
        NAMESPACE_ERR: Raised if the qualifiedName is malformed, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName is null and the namespaceURI is different from null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the DOM implementation does not support the "XML" feature but a non-null namespace URI was provided, since namespaces were defined by XML.
        WRONG_DOCUMENT_ERR: Raised if doctype has already been used with a different document or was created from a different implementation.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getFeature

        Object getFeature(String feature,
                  String version)
        This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features. The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the DOMImplementation interface.
        Parameters:
        feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
        version - This is the version number of the feature to test.
        Returns:
        Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the DOMImplementation interface, it must delegate to the primary core DOMImplementation and not return results inconsistent with the primary core DOMImplementation such as hasFeature, getFeature, etc.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMImplementationList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMImplementationList

  • public interface DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented. The items in the DOMImplementationList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getLength()
      The number of DOMImplementations in the list.
      DOMImplementation item(int index)
      Returns the indexth item in the collection.

    • Method Detail

      • item

        DOMImplementation item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of DOMImplementations in the list, this returns null.
        Parameters:
        index - Index into the collection.
        Returns:
        The DOMImplementation at the index th position in the DOMImplementationList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of DOMImplementations in the list. The range of valid child node indices is 0 to length-1 inclusive.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMImplementationSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMImplementationSource

  • public interface DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features. Each implemented DOMImplementationSource object is listed in the binding-specific list of available sources so that its DOMImplementation objects are made available.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DOMImplementation getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementationList getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • Method Detail

      • getDOMImplementation

        DOMImplementation getDOMImplementation(String features)
        A method to request the first DOM implementation that supports the specified features.
        Parameters:
        features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This method returns the first item of the list returned by getDOMImplementationList. As an example, the string "XML 3.0 Traversal +Events 2.0" will request a DOM implementation that supports the module "XML" for its 3.0 version, a module that support of the "Traversal" module for any version, and the module "Events" for its 2.0 version. The module "Events" must be accessible using the method Node.getFeature() and DOMImplementation.getFeature().
        Returns:
        The first DOM implementation that support the desired features, or null if this source has none.

      • getDOMImplementationList

        DOMImplementationList getDOMImplementationList(String features)
        A method to request a list of DOM implementations that support the specified features and versions, as specified in .
        Parameters:
        features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 3.0 Traversal +Events 2.0"
        Returns:
        A list of DOM implementations that support the desired features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMLocator

  • public interface DOMLocator
    DOMLocator is an interface that describes a location (e.g. where an error occurred).

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getByteOffset()
      The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.
      int getColumnNumber()
      The column number this locator is pointing to, or -1 if there is no column number available.
      int getLineNumber()
      The line number this locator is pointing to, or -1 if there is no column number available.
      Node getRelatedNode()
      The node this locator is pointing to, or null if no node is available.
      String getUri()
      The URI this locator is pointing to, or null if no URI is available.
      int getUtf16Offset()
      The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

    • Method Detail

      • getLineNumber

        int getLineNumber()
        The line number this locator is pointing to, or -1 if there is no column number available.

      • getColumnNumber

        int getColumnNumber()
        The column number this locator is pointing to, or -1 if there is no column number available.

      • getByteOffset

        int getByteOffset()
        The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.

      • getUtf16Offset

        int getUtf16Offset()
        The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

      • getRelatedNode

        Node getRelatedNode()
        The node this locator is pointing to, or null if no node is available.

      • getUri

        String getUri()
        The URI this locator is pointing to, or null if no URI is available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMStringList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMStringList

  • public interface DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented. The items in the DOMStringList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean contains(String str)
      Test if a string is part of this DOMStringList.
      int getLength()
      The number of DOMStrings in the list.
      String item(int index)
      Returns the indexth item in the collection.

    • Method Detail

      • item

        String item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of DOMStrings in the list, this returns null.
        Parameters:
        index - Index into the collection.
        Returns:
        The DOMString at the indexth position in the DOMStringList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of DOMStrings in the list. The range of valid child node indices is 0 to length-1 inclusive.

      • contains

        boolean contains(String str)
        Test if a string is part of this DOMStringList.
        Parameters:
        str - The string to look for.
        Returns:
        true if the string has been found, false otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Element (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Element

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
    All Known Implementing Classes:
    IIOMetadataNode

    public interface Element
extends Node
    The Element interface represents an element in an HTML or XML document. Elements may have attributes associated with them; since the Element interface inherits from Node, the generic Node interface attribute attributes may be used to retrieve the set of all attributes for an element. There are methods on the Element interface to retrieve either an Attr object by name or an attribute value by name. In XML, where an attribute value may contain entity references, an Attr object should be retrieved to examine the possibly fairly complex sub-tree representing the attribute value. On the other hand, in HTML, where all attributes have simple string values, methods to directly access an attribute value can safely be used as a convenience.

    Note: In DOM Level 2, the method normalize is inherited from the Node interface where it was moved.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getAttribute(String name)
      Retrieves an attribute value by name.
      Attr getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      NodeList getElementsByTagName(String name)
      Returns a NodeList of all descendant Elements with a given tag name, in document order.
      NodeList getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      TypeInfo getSchemaTypeInfo()
      The type information associated with this element.
      String getTagName()
      The name of the element.
      boolean hasAttribute(String name)
      Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
      boolean hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      void removeAttribute(String name)
      Removes an attribute by name.
      Attr removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      void setAttribute(String name, String value)
      Adds a new attribute.
      Attr setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getTagName

        String getTagName()
        The name of the element. If Node.localName is different from null, this attribute is a qualified name. For example, in:
         <elementExample id="demo"> ...
 </elementExample> ,
        tagName has the value "elementExample". Note that this is case-preserving in XML, as are all of the operations of the DOM. The HTML DOM returns the tagName of an HTML element in the canonical uppercase form, regardless of the case in the source HTML document.

      • getAttribute

        String getAttribute(String name)
        Retrieves an attribute value by name.
        Parameters:
        name - The name of the attribute to retrieve.
        Returns:
        The Attr value as a string, or the empty string if that attribute does not have a specified or default value.

      • setAttribute

        void setAttribute(String name,
                  String value)
           throws DOMException
        Adds a new attribute. If an attribute with that name is already present in the element, its value is changed to be that of the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNode to assign it as the value of an attribute.
        To set an attribute with a qualified name and namespace URI, use the setAttributeNS method.
        Parameters:
        name - The name of the attribute to create or alter.
        value - Value to set in string form.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • removeAttribute

        void removeAttribute(String name)
              throws DOMException
        Removes an attribute by name. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        If no attribute with this name is found, this method has no effect.
        To remove an attribute by local name and namespace URI, use the removeAttributeNS method.
        Parameters:
        name - The name of the attribute to remove.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • getAttributeNode

        Attr getAttributeNode(String name)
        Retrieves an attribute node by name.
        To retrieve an attribute node by qualified name and namespace URI, use the getAttributeNodeNS method.
        Parameters:
        name - The name (nodeName) of the attribute to retrieve.
        Returns:
        The Attr node with the specified name ( nodeName) or null if there is no such attribute.

      • setAttributeNode

        Attr setAttributeNode(Attr newAttr)
               throws DOMException
        Adds a new attribute node. If an attribute with that name ( nodeName) is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
        To add a new attribute node with a qualified name and namespace URI, use the setAttributeNodeNS method.
        Parameters:
        newAttr - The Attr node to add to the attribute list.
        Returns:
        If the newAttr attribute replaces an existing attribute, the replaced Attr node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.

      • removeAttributeNode

        Attr removeAttributeNode(Attr oldAttr)
                  throws DOMException
        Removes the specified attribute node. If a default value for the removed Attr node is defined in the DTD, a new node immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        Parameters:
        oldAttr - The Attr node to remove from the attribute list.
        Returns:
        The Attr node that was removed.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if oldAttr is not an attribute of the element.

      • getElementsByTagName

        NodeList getElementsByTagName(String name)
        Returns a NodeList of all descendant Elements with a given tag name, in document order.
        Parameters:
        name - The name of the tag to match on. The special value "*" matches all tags.
        Returns:
        A list of matching Element nodes.

      • getAttributeNS

        String getAttributeNS(String namespaceURI,
                      String localName)
               throws DOMException
        Retrieves an attribute value by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to retrieve.
        localName - The local name of the attribute to retrieve.
        Returns:
        The Attr value as a string, or the empty string if that attribute does not have a specified or default value.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • setAttributeNS

        void setAttributeNS(String namespaceURI,
                    String qualifiedName,
                    String value)
             throws DOMException
        Adds a new attribute. If an attribute with the same local name and namespace URI is already present on the element, its prefix is changed to be the prefix part of the qualifiedName, and its value is changed to be the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNodeNS or setAttributeNode to assign it as the value of an attribute.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to create or alter.
        qualifiedName - The qualified name of the attribute to create or alter.
        value - The value to set in string form.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NAMESPACE_ERR: Raised if the qualifiedName is malformed per the Namespaces in XML specification, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • removeAttributeNS

        void removeAttributeNS(String namespaceURI,
                       String localName)
                throws DOMException
        Removes an attribute by local name and namespace URI. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        If no attribute with this local name and namespace URI is found, this method has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to remove.
        localName - The local name of the attribute to remove.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getAttributeNodeNS

        Attr getAttributeNodeNS(String namespaceURI,
                        String localName)
                 throws DOMException
        Retrieves an Attr node by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to retrieve.
        localName - The local name of the attribute to retrieve.
        Returns:
        The Attr node with the specified attribute local name and namespace URI or null if there is no such attribute.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • setAttributeNodeNS

        Attr setAttributeNodeNS(Attr newAttr)
                 throws DOMException
        Adds a new attribute. If an attribute with that local name and that namespace URI is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        newAttr - The Attr node to add to the attribute list.
        Returns:
        If the newAttr attribute replaces an existing attribute with the same local name and namespace URI, the replaced Attr node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getElementsByTagNameNS

        NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
                         throws DOMException
        Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
        Parameters:
        namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
        localName - The local name of the elements to match on. The special value "*" matches all local names.
        Returns:
        A new NodeList object containing all the matched Elements.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • hasAttribute

        boolean hasAttribute(String name)
        Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
        Parameters:
        name - The name of the attribute to look for.
        Returns:
        true if an attribute with the given name is specified on this element or has a default value, false otherwise.
        Since:
        DOM Level 2

      • hasAttributeNS

        boolean hasAttributeNS(String namespaceURI,
                       String localName)
                throws DOMException
        Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to look for.
        localName - The local name of the attribute to look for.
        Returns:
        true if an attribute with the given local name and namespace URI is specified or has a default value on this element, false otherwise.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getSchemaTypeInfo

        TypeInfo getSchemaTypeInfo()
        The type information associated with this element.
        Since:
        DOM Level 3

      • setIdAttribute

        void setIdAttribute(String name,
                    boolean isId)
             throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        To specify an attribute by local name and namespace URI, use the setIdAttributeNS method.
        Parameters:
        name - The name of the attribute.
        isId - Whether the attribute is a of type ID.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        Since:
        DOM Level 3

      • setIdAttributeNS

        void setIdAttributeNS(String namespaceURI,
                      String localName,
                      boolean isId)
               throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        Parameters:
        namespaceURI - The namespace URI of the attribute.
        localName - The local name of the attribute.
        isId - Whether the attribute is a of type ID.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        Since:
        DOM Level 3

      • setIdAttributeNode

        void setIdAttributeNode(Attr idAttr,
                        boolean isId)
                 throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        Parameters:
        idAttr - The attribute node.
        isId - Whether the attribute is a of type ID.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Entity (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Entity

  • All Superinterfaces:
    Node

    public interface Entity
extends Node
    This interface represents a known entity, either parsed or unparsed, in an XML document. Note that this models the entity itself not the entity declaration.

    The nodeName attribute that is inherited from Node contains the name of the entity.

    An XML processor may choose to completely expand entities before the structure model is passed to the DOM; in this case there will be no EntityReference nodes in the document tree.

    XML does not mandate that a non-validating XML processor read and process entity declarations made in the external subset or declared in parameter entities. This means that parsed entities declared in the external subset need not be expanded by some classes of applications, and that the replacement text of the entity may not be available. When the replacement text is available, the corresponding Entity node's child list represents the structure of that replacement value. Otherwise, the child list is empty.

    DOM Level 3 does not support editing Entity nodes; if a user wants to make changes to the contents of an Entity, every related EntityReference node has to be replaced in the structure model by a clone of the Entity's contents, and then the desired changes must be made to each of those clones instead. Entity nodes and all their descendants are readonly.

    An Entity node does not have any parent.

    Note: If the entity contains an unbound namespace prefix, the namespaceURI of the corresponding node in the Entity node subtree is null. The same is true for EntityReference nodes that refer to this entity, when they are created using the createEntityReference method of the Document interface.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getInputEncoding()
      An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity.
      String getNotationName()
      For unparsed entities, the name of the notation for the entity.
      String getPublicId()
      The public identifier associated with the entity if specified, and null otherwise.
      String getSystemId()
      The system identifier associated with the entity if specified, and null otherwise.
      String getXmlEncoding()
      An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity.
      String getXmlVersion()
      An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getPublicId

        String getPublicId()
        The public identifier associated with the entity if specified, and null otherwise.

      • getSystemId

        String getSystemId()
        The system identifier associated with the entity if specified, and null otherwise. This may be an absolute URI or not.

      • getNotationName

        String getNotationName()
        For unparsed entities, the name of the notation for the entity. For parsed entities, this is null.

      • getInputEncoding

        String getInputEncoding()
        An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity. This is null if it an entity from the internal subset or if it is not known.
        Since:
        DOM Level 3

      • getXmlEncoding

        String getXmlEncoding()
        An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity. This is null otherwise.
        Since:
        DOM Level 3

      • getXmlVersion

        String getXmlVersion()
        An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity. This is null otherwise.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EntityReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface EntityReference

  • All Superinterfaces:
    Node

    public interface EntityReference
extends Node
    EntityReference nodes may be used to represent an entity reference in the tree. Note that character references and references to predefined entities are considered to be expanded by the HTML or XML processor so that characters are represented by their Unicode equivalent rather than by an entity reference. Moreover, the XML processor may completely expand references to entities while building the Document, instead of providing EntityReference nodes. If it does provide such nodes, then for an EntityReference node that represents a reference to a known entity an Entity exists, and the subtree of the EntityReference node is a copy of the Entity node subtree. However, the latter may not be true when an entity contains an unbound namespace prefix. In such a case, because the namespace prefix resolution depends on where the entity reference is, the descendants of the EntityReference node may be bound to different namespace URIs. When an EntityReference node represents a reference to an unknown entity, the node has no children and its replacement value, when used by Attr.value for example, is empty.

    As for Entity nodes, EntityReference nodes and all their descendants are readonly.

    Note: EntityReference nodes may cause element content and attribute value normalization problems when, such as in XML 1.0 and XML Schema, the normalization is performed after entity reference are expanded.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamedNodeMap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface NamedNodeMap

  • public interface NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name. Note that NamedNodeMap does not inherit from NodeList; NamedNodeMaps are not maintained in any particular order. Objects contained in an object implementing NamedNodeMap may also be accessed by an ordinal index, but this is simply to allow convenient enumeration of the contents of a NamedNodeMap, and does not imply that the DOM specifies an order to these Nodes.

    NamedNodeMap objects in the DOM are live.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getLength()
      The number of nodes in this map.
      Node getNamedItem(String name)
      Retrieves a node specified by name.
      Node getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      Node item(int index)
      Returns the indexth item in the map.
      Node removeNamedItem(String name)
      Removes a node specified by name.
      Node removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.

    • Method Detail

      • getNamedItem

        Node getNamedItem(String name)
        Retrieves a node specified by name.
        Parameters:
        name - The nodeName of a node to retrieve.
        Returns:
        A Node (of any type) with the specified nodeName, or null if it does not identify any node in this map.

      • setNamedItem

        Node setNamedItem(Node arg)
           throws DOMException
        Adds a node using its nodeName attribute. If a node with that name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
        As the nodeName attribute is used to derive the name which the node must be stored under, multiple nodes of certain types (those that have a "special" string value) cannot be stored as the names would clash. This is seen as preferable to allowing nodes to be aliased.
        Parameters:
        arg - A node to store in this map. The node will later be accessible using the value of its nodeName attribute.
        Returns:
        If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.

      • removeNamedItem

        Node removeNamedItem(String name)
              throws DOMException
        Removes a node specified by name. When this map contains the attributes attached to an element, if the removed attribute is known to have a default value, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
        Parameters:
        name - The nodeName of the node to remove.
        Returns:
        The node removed from this map if a node with such a name exists.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised if there is no node named name in this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.

      • item

        Node item(int index)
        Returns the indexth item in the map. If index is greater than or equal to the number of nodes in this map, this returns null.
        Parameters:
        index - Index into this map.
        Returns:
        The node at the indexth position in the map, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of nodes in this map. The range of valid child node indices is 0 to length-1 inclusive.

      • getNamedItemNS

        Node getNamedItemNS(String namespaceURI,
                    String localName)
             throws DOMException
        Retrieves a node specified by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the node to retrieve.
        localName - The local name of the node to retrieve.
        Returns:
        A Node (of any type) with the specified local name and namespace URI, or null if they do not identify any node in this map.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • setNamedItemNS

        Node setNamedItemNS(Node arg)
             throws DOMException
        Adds a node using its namespaceURI and localName. If a node with that namespace URI and that local name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        arg - A node to store in this map. The node will later be accessible using the value of its namespaceURI and localName attributes.
        Returns:
        If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • removeNamedItemNS

        Node removeNamedItemNS(String namespaceURI,
                       String localName)
                throws DOMException
        Removes a node specified by local name and namespace URI. A removed attribute may be known to have a default value when this map contains the attributes attached to an element, as returned by the attributes attribute of the Node interface. If so, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the node to remove.
        localName - The local name of the node to remove.
        Returns:
        The node removed from this map if a node with such a local name and namespace URI exists.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised if there is no node with the specified namespaceURI and localName in this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NameList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface NameList

  • public interface NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented. The items in the NameList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean contains(String str)
      Test if a name is part of this NameList.
      boolean containsNS(String namespaceURI, String name)
      Test if the pair namespaceURI/name is part of this NameList.
      int getLength()
      The number of pairs (name and namespaceURI) in the list.
      String getName(int index)
      Returns the indexth name item in the collection.
      String getNamespaceURI(int index)
      Returns the indexth namespaceURI item in the collection.

    • Method Detail

      • getName

        String getName(int index)
        Returns the indexth name item in the collection.
        Parameters:
        index - Index into the collection.
        Returns:
        The name at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

      • getNamespaceURI

        String getNamespaceURI(int index)
        Returns the indexth namespaceURI item in the collection.
        Parameters:
        index - Index into the collection.
        Returns:
        The namespace URI at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

      • getLength

        int getLength()
        The number of pairs (name and namespaceURI) in the list. The range of valid child node indices is 0 to length-1 inclusive.

      • contains

        boolean contains(String str)
        Test if a name is part of this NameList.
        Parameters:
        str - The name to look for.
        Returns:
        true if the name has been found, false otherwise.

      • containsNS

        boolean containsNS(String namespaceURI,
                   String name)
        Test if the pair namespaceURI/name is part of this NameList.
        Parameters:
        namespaceURI - The namespace URI to look for.
        name - The name to look for.
        Returns:
        true if the pair namespaceURI/name has been found, false otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Node (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Node

  • All Known Subinterfaces:
    Attr, CDATASection, CharacterData, Comment, Detail, DetailEntry, Document, DocumentFragment, DocumentType, Element, Entity, EntityReference, Node, Notation, ProcessingInstruction, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text, Text
    All Known Implementing Classes:
    IIOMetadataNode, SOAPPart

    public interface Node
    The Node interface is the primary datatype for the entire Document Object Model. It represents a single node in the document tree. While all objects implementing the Node interface expose methods for dealing with children, not all objects implementing the Node interface may have children. For example, Text nodes may not have children, and adding children to such nodes results in a DOMException being raised.

    The attributes nodeName, nodeValue and attributes are included as a mechanism to get at node information without casting down to the specific derived interface. In cases where there is no obvious mapping of these attributes for a specific nodeType (e.g., nodeValue for an Element or attributes for a Comment ), this returns null. Note that the specialized interfaces may contain additional and more convenient mechanisms to get and set the relevant information.

    The values of nodeName, nodeValue, and attributes vary according to the node type as follows:

    Interface | nodeName | nodeValue | attributes
    Attr | same as Attr.name | same as Attr.value | null
    CDATASection | "#cdata-section" | same as CharacterData.data, the content of the CDATA Section | null
    Comment | "#comment" | same as CharacterData.data, the content of the comment | null
    Document | "#document" | null | null
    DocumentFragment | "#document-fragment" | null | null
    DocumentType | same as DocumentType.name | null | null
    Element | same as Element.tagName | null | NamedNodeMap
    Entity | entity name | null | null
    EntityReference | name of entity referenced | null | null
    Notation | notation name | null | null
    ProcessingInstruction | same as ProcessingInstruction.target | same as ProcessingInstruction.data | null
    Text | "#text" | same as CharacterData.data, the content of the text node | null

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short ATTRIBUTE_NODE
      The node is an Attr.
      static short CDATA_SECTION_NODE
      The node is a CDATASection.
      static short COMMENT_NODE
      The node is a Comment.
      static short DOCUMENT_FRAGMENT_NODE
      The node is a DocumentFragment.
      static short DOCUMENT_NODE
      The node is a Document.
      static short DOCUMENT_POSITION_CONTAINED_BY
      The node is contained by the reference node.
      static short DOCUMENT_POSITION_CONTAINS
      The node contains the reference node.
      static short DOCUMENT_POSITION_DISCONNECTED
      The two nodes are disconnected.
      static short DOCUMENT_POSITION_FOLLOWING
      The node follows the reference node.
      static short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
      The determination of preceding versus following is implementation-specific.
      static short DOCUMENT_POSITION_PRECEDING
      The second node precedes the reference node.
      static short DOCUMENT_TYPE_NODE
      The node is a DocumentType.
      static short ELEMENT_NODE
      The node is an Element.
      static short ENTITY_NODE
      The node is an Entity.
      static short ENTITY_REFERENCE_NODE
      The node is an EntityReference.
      static short NOTATION_NODE
      The node is a Notation.
      static short PROCESSING_INSTRUCTION_NODE
      The node is a ProcessingInstruction.
      static short TEXT_NODE
      The node is a Text node.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Node appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node cloneNode(boolean deep)
      Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
      short compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      NamedNodeMap getAttributes()
      A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
      String getBaseURI()
      The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.
      NodeList getChildNodes()
      A NodeList that contains all children of this node.
      Object getFeature(String feature, String version)
      This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in .
      Node getFirstChild()
      The first child of this node.
      Node getLastChild()
      The last child of this node.
      String getLocalName()
      Returns the local part of the qualified name of this node.
      String getNamespaceURI()
      The namespace URI of this node, or null if it is unspecified (see ).
      Node getNextSibling()
      The node immediately following this node.
      String getNodeName()
      The name of this node, depending on its type; see the table above.
      short getNodeType()
      A code representing the type of the underlying object, as defined above.
      String getNodeValue()
      The value of this node, depending on its type; see the table above.
      Document getOwnerDocument()
      The Document object associated with this node.
      Node getParentNode()
      The parent of this node.
      String getPrefix()
      The namespace prefix of this node, or null if it is unspecified.
      Node getPreviousSibling()
      The node immediately preceding this node.
      String getTextContent()
      This attribute returns the text content of this node and its descendants.
      Object getUserData(String key)
      Retrieves the object associated to a key on a this node.
      boolean hasAttributes()
      Returns whether this node (if it is an element) has any attributes.
      boolean hasChildNodes()
      Returns whether this node has any children.
      Node insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean isDefaultNamespace(String namespaceURI)
      This method checks if the specified namespaceURI is the default namespace or not.
      boolean isEqualNode(Node arg)
      Tests whether two nodes are equal.
      boolean isSameNode(Node other)
      Returns whether this node is the same node as the given one.
      boolean isSupported(String feature, String version)
      Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
      String lookupNamespaceURI(String prefix)
      Look up the namespace URI associated to the given prefix, starting from this node.
      String lookupPrefix(String namespaceURI)
      Look up the prefix associated to the given namespace URI, starting from this node.
      void normalize()
      Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
      Node removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      Object setUserData(String key, Object data, UserDataHandler handler)
      Associate an object to a key on this node.

    • Field Detail

      • ELEMENT_NODE

        static final short ELEMENT_NODE
        The node is an Element.
        See Also:
        Constant Field Values

      • ATTRIBUTE_NODE

        static final short ATTRIBUTE_NODE
        The node is an Attr.
        See Also:
        Constant Field Values

      • TEXT_NODE

        static final short TEXT_NODE
        The node is a Text node.
        See Also:
        Constant Field Values

      • CDATA_SECTION_NODE

        static final short CDATA_SECTION_NODE
        The node is a CDATASection.
        See Also:
        Constant Field Values

      • ENTITY_REFERENCE_NODE

        static final short ENTITY_REFERENCE_NODE
        The node is an EntityReference.
        See Also:
        Constant Field Values

      • ENTITY_NODE

        static final short ENTITY_NODE
        The node is an Entity.
        See Also:
        Constant Field Values

      • PROCESSING_INSTRUCTION_NODE

        static final short PROCESSING_INSTRUCTION_NODE
        The node is a ProcessingInstruction.
        See Also:
        Constant Field Values

      • COMMENT_NODE

        static final short COMMENT_NODE
        The node is a Comment.
        See Also:
        Constant Field Values

      • DOCUMENT_NODE

        static final short DOCUMENT_NODE
        The node is a Document.
        See Also:
        Constant Field Values

      • DOCUMENT_TYPE_NODE

        static final short DOCUMENT_TYPE_NODE
        The node is a DocumentType.
        See Also:
        Constant Field Values

      • DOCUMENT_FRAGMENT_NODE

        static final short DOCUMENT_FRAGMENT_NODE
        The node is a DocumentFragment.
        See Also:
        Constant Field Values

      • NOTATION_NODE

        static final short NOTATION_NODE
        The node is a Notation.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_DISCONNECTED

        static final short DOCUMENT_POSITION_DISCONNECTED
        The two nodes are disconnected. Order between disconnected nodes is always implementation-specific.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_PRECEDING

        static final short DOCUMENT_POSITION_PRECEDING
        The second node precedes the reference node.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_FOLLOWING

        static final short DOCUMENT_POSITION_FOLLOWING
        The node follows the reference node.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_CONTAINS

        static final short DOCUMENT_POSITION_CONTAINS
        The node contains the reference node. A node which contains is always preceding, too.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_CONTAINED_BY

        static final short DOCUMENT_POSITION_CONTAINED_BY
        The node is contained by the reference node. A node which is contained is always following, too.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC

        static final short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
        The determination of preceding versus following is implementation-specific.
        See Also:
        Constant Field Values

    • Method Detail

      • getNodeName

        String getNodeName()
        The name of this node, depending on its type; see the table above.

      • getNodeValue

        String getNodeValue()
             throws DOMException
        The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

      • setNodeValue

        void setNodeValue(String nodeValue)
           throws DOMException
        The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly and if it is not defined to be null.

      • getNodeType

        short getNodeType()
        A code representing the type of the underlying object, as defined above.

      • getParentNode

        Node getParentNode()
        The parent of this node. All nodes, except Attr, Document, DocumentFragment, Entity, and Notation may have a parent. However, if a node has just been created and not yet added to the tree, or if it has been removed from the tree, this is null.

      • getChildNodes

        NodeList getChildNodes()
        A NodeList that contains all children of this node. If there are no children, this is a NodeList containing no nodes.

      • getFirstChild

        Node getFirstChild()
        The first child of this node. If there is no such node, this returns null.

      • getLastChild

        Node getLastChild()
        The last child of this node. If there is no such node, this returns null.

      • getPreviousSibling

        Node getPreviousSibling()
        The node immediately preceding this node. If there is no such node, this returns null.

      • getNextSibling

        Node getNextSibling()
        The node immediately following this node. If there is no such node, this returns null.

      • getAttributes

        NamedNodeMap getAttributes()
        A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.

      • getOwnerDocument

        Document getOwnerDocument()
        The Document object associated with this node. This is also the Document object used to create new nodes. When this node is a Document or a DocumentType which is not used with any Document yet, this is null.
        Since:
        DOM Level 2

      • insertBefore

        Node insertBefore(Node newChild,
                  Node refChild)
           throws DOMException
        Inserts the node newChild before the existing child node refChild. If refChild is null, insert newChild at the end of the list of children.
        If newChild is a DocumentFragment object, all of its children are inserted, in the same order, before refChild. If the newChild is already in the tree, it is first removed.

        Note: Inserting a node before itself is implementation dependent.

        Parameters:
        newChild - The node to insert.
        refChild - The reference node, i.e., the node before which the new node must be inserted.
        Returns:
        The node being inserted.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to insert is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to insert a second DocumentType or Element node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the parent of the node being inserted is readonly.
        NOT_FOUND_ERR: Raised if refChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the insertion of a DocumentType or Element node.
        Since:
        DOM Level 3

      • replaceChild

        Node replaceChild(Node newChild,
                  Node oldChild)
           throws DOMException
        Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
        If newChild is a DocumentFragment object, oldChild is replaced by all of the DocumentFragment children, which are inserted in the same order. If the newChild is already in the tree, it is first removed.

        Note: Replacing a node with itself is implementation dependent.

        Parameters:
        newChild - The new node to put in the child list.
        oldChild - The node being replaced in the list.
        Returns:
        The node replaced.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to put in is one of this node's ancestors or this node itself, or if this node is of type Document and the result of the replacement operation would add a second DocumentType or Element on the Document node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node or the parent of the new node is readonly.
        NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
        Since:
        DOM Level 3

      • removeChild

        Node removeChild(Node oldChild)
          throws DOMException
        Removes the child node indicated by oldChild from the list of children, and returns it.
        Parameters:
        oldChild - The node being removed.
        Returns:
        The node removed.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or the Element child.
        Since:
        DOM Level 3

      • appendChild

        Node appendChild(Node newChild)
          throws DOMException
        Adds the node newChild to the end of the list of children of this node. If the newChild is already in the tree, it is first removed.
        Parameters:
        newChild - The node to add.If it is a DocumentFragment object, the entire contents of the document fragment are moved into the child list of this node
        Returns:
        The node added.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to append is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to append a second DocumentType or Element node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the previous parent of the node being inserted is readonly.
        NOT_SUPPORTED_ERR: if the newChild node is a child of the Document node, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or Element child.
        Since:
        DOM Level 3

      • hasChildNodes

        boolean hasChildNodes()
        Returns whether this node has any children.
        Returns:
        Returns true if this node has any children, false otherwise.

      • cloneNode

        Node cloneNode(boolean deep)
        Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes. The duplicate node has no parent ( parentNode is null) and no user data. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
        Cloning an Element copies all attributes and their values, including those generated by the XML processor to represent defaulted attributes, but this method does not copy any children it contains unless it is a deep clone. This includes text contained in an the Element since the text is contained in a child Text node. Cloning an Attr directly, as opposed to be cloned as part of an Element cloning operation, returns a specified attribute (specified is true). Cloning an Attr always clones its children, since they represent its value, no matter whether this is a deep clone or not. Cloning an EntityReference automatically constructs its subtree if a corresponding Entity is available, no matter whether this is a deep clone or not. Cloning any other type of node simply returns a copy of this node.
        Note that cloning an immutable subtree results in a mutable copy, but the children of an EntityReference clone are readonly . In addition, clones of unspecified Attr nodes are specified. And, cloning Document, DocumentType, Entity, and Notation nodes is implementation dependent.
        Parameters:
        deep - If true, recursively clone the subtree under the specified node; if false, clone only the node itself (and its attributes, if it is an Element).
        Returns:
        The duplicate node.

      • normalize

        void normalize()
        Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer [XPointer] lookups) that depend on a particular document tree structure are to be used. If the parameter "normalize-characters" of the DOMConfiguration object attached to the Node.ownerDocument is true, this method will also fully normalize the characters of the Text nodes.

        Note: In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

        Since:
        DOM Level 3

      • isSupported

        boolean isSupported(String feature,
                    String version)
        Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
        Parameters:
        feature - The name of the feature to test.
        version - This is the version number of the feature to test.
        Returns:
        Returns true if the specified feature is supported on this node, false otherwise.
        Since:
        DOM Level 2

      • getNamespaceURI

        String getNamespaceURI()
        The namespace URI of this node, or null if it is unspecified (see ).
        This is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.

        Note: Per the Namespaces in XML Specification [XML Namespaces] an attribute does not inherit its namespace from the element it is attached to. If an attribute is not explicitly given a namespace, it simply has no namespace.

        Since:
        DOM Level 2

      • getPrefix

        String getPrefix()
        The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
        Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
        Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.
        Since:
        DOM Level 2

      • setPrefix

        void setPrefix(String prefix)
        throws DOMException
        The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
        Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
        Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified prefix contains an illegal character according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NAMESPACE_ERR: Raised if the specified prefix is malformed per the Namespaces in XML specification, if the namespaceURI of this node is null, if the specified prefix is "xml" and the namespaceURI of this node is different from " http://www.w3.org/XML/1998/namespace", if this node is an attribute and the specified prefix is "xmlns" and the namespaceURI of this node is different from "http://www.w3.org/2000/xmlns/", or if this node is an attribute and the qualifiedName of this node is "xmlns" [XML Namespaces] .
        Since:
        DOM Level 2

      • getLocalName

        String getLocalName()
        Returns the local part of the qualified name of this node.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.
        Since:
        DOM Level 2

      • hasAttributes

        boolean hasAttributes()
        Returns whether this node (if it is an element) has any attributes.
        Returns:
        Returns true if this node has any attributes, false otherwise.
        Since:
        DOM Level 2

      • getBaseURI

        String getBaseURI()
        The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI. This value is computed as described in . However, when the Document supports the feature "HTML" [DOM Level 2 HTML] , the base URI is computed using first the value of the href attribute of the HTML BASE element if any, and the value of the documentURI attribute from the Document interface otherwise.
        Since:
        DOM Level 3

      • compareDocumentPosition

        short compareDocumentPosition(Node other)
                       throws DOMException
        Compares the reference node, i.e. the node on which this method is being called, with a node, i.e. the one passed as a parameter, with regard to their position in the document and according to the document order.
        Parameters:
        other - The node to compare against the reference node.
        Returns:
        Returns how the node is positioned relatively to the reference node.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: when the compared nodes are from different DOM implementations that do not coordinate to return consistent implementation-specific results.
        Since:
        DOM Level 3

      • getTextContent

        String getTextContent()
               throws DOMException
        This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
        On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
        The string returned is made of the text content of this node depending on its type, as defined below:
        Node type | Content
        ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
        DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.
        Since:
        DOM Level 3

      • setTextContent

        void setTextContent(String textContent)
             throws DOMException
        This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
        On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
        The string returned is made of the text content of this node depending on its type, as defined below:
        Node type | Content
        ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
        DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
        Since:
        DOM Level 3

      • isSameNode

        boolean isSameNode(Node other)
        Returns whether this node is the same node as the given one.
        This method provides a way to determine whether two Node references returned by the implementation reference the same object. When two Node references are references to the same object, even if through a proxy, the references may be used completely interchangeably, such that all attributes have the same values and calling the same DOM method on either reference always has exactly the same effect.
        Parameters:
        other - The node to test against.
        Returns:
        Returns true if the nodes are the same, false otherwise.
        Since:
        DOM Level 3

      • lookupPrefix

        String lookupPrefix(String namespaceURI)
        Look up the prefix associated to the given namespace URI, starting from this node. The default namespace declarations are ignored by this method.
        See for details on the algorithm used by this method.
        Parameters:
        namespaceURI - The namespace URI to look for.
        Returns:
        Returns an associated namespace prefix if found or null if none is found. If more than one prefix are associated to the namespace prefix, the returned namespace prefix is implementation dependent.
        Since:
        DOM Level 3

      • isDefaultNamespace

        boolean isDefaultNamespace(String namespaceURI)
        This method checks if the specified namespaceURI is the default namespace or not.
        Parameters:
        namespaceURI - The namespace URI to look for.
        Returns:
        Returns true if the specified namespaceURI is the default namespace, false otherwise.
        Since:
        DOM Level 3

      • lookupNamespaceURI

        String lookupNamespaceURI(String prefix)
        Look up the namespace URI associated to the given prefix, starting from this node.
        See for details on the algorithm used by this method.
        Parameters:
        prefix - The prefix to look for. If this parameter is null, the method will return the default namespace URI if any.
        Returns:
        Returns the associated namespace URI or null if none is found.
        Since:
        DOM Level 3

      • isEqualNode

        boolean isEqualNode(Node arg)
        Tests whether two nodes are equal.
        This method tests for equality of nodes, not sameness (i.e., whether the two nodes are references to the same object) which can be tested with Node.isSameNode(). All nodes that are the same will also be equal, though the reverse may not be true.
        Two nodes are equal if and only if the following conditions are satisfied:
        • The two nodes are of the same type.
        • The following string attributes are equal: nodeName, localName, namespaceURI, prefix, nodeValue . This is: they are both null, or they have the same length and are character for character identical.
        • The attributes NamedNodeMaps are equal. This is: they are both null, or they have the same length and for each node that exists in one map there is a node that exists in the other map and is equal, although not necessarily at the same index.
        • The childNodes NodeLists are equal. This is: they are both null, or they have the same length and contain equal nodes at the same index. Note that normalization can affect equality; to avoid this, nodes should be normalized before being compared.

        For two DocumentType nodes to be equal, the following conditions must also be satisfied:
        • The following string attributes are equal: publicId, systemId, internalSubset.
        • The entities NamedNodeMaps are equal.
        • The notations NamedNodeMaps are equal.

        On the other hand, the following do not affect equality: the ownerDocument, baseURI, and parentNode attributes, the specified attribute for Attr nodes, the schemaTypeInfo attribute for Attr and Element nodes, the Text.isElementContentWhitespace attribute for Text nodes, as well as any user data or event listeners registered on the nodes.

        Note: As a general rule, anything not mentioned in the description above is not significant in consideration of equality checking. Note that future versions of this specification may take into account more attributes and implementations conform to this specification are expected to be updated accordingly.

        Parameters:
        arg - The node to compare equality with.
        Returns:
        Returns true if the nodes are equal, false otherwise.
        Since:
        DOM Level 3

      • getFeature

        Object getFeature(String feature,
                  String version)
        This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in . The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the Node interface.
        Parameters:
        feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
        version - This is the version number of the feature to test.
        Returns:
        Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the Node interface, it must delegate to the primary core Node and not return results inconsistent with the primary core Node such as attributes, childNodes, etc.
        Since:
        DOM Level 3

      • setUserData

        Object setUserData(String key,
                   Object data,
                   UserDataHandler handler)
        Associate an object to a key on this node. The object can later be retrieved from this node by calling getUserData with the same key.
        Parameters:
        key - The key to associate the object to.
        data - The object to associate to the given key, or null to remove any existing association to that key.
        handler - The handler to associate to that key, or null.
        Returns:
        Returns the DOMUserData previously associated to the given key on this node, or null if there was none.
        Since:
        DOM Level 3

      • getUserData

        Object getUserData(String key)
        Retrieves the object associated to a key on a this node. The object must first have been set to this node by calling setUserData with the same key.
        Parameters:
        key - The key the object is associated to.
        Returns:
        Returns the DOMUserData associated to the given key on this node, or null if there was none.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NodeList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface NodeList

  • All Known Implementing Classes:
    IIOMetadataNode

    public interface NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented. NodeList objects in the DOM are live.

    The items in the NodeList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getLength()
      The number of nodes in the list.
      Node item(int index)
      Returns the indexth item in the collection.

    • Method Detail

      • item

        Node item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of nodes in the list, this returns null.
        Parameters:
        index - Index into the collection.
        Returns:
        The node at the indexth position in the NodeList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of nodes in the list. The range of valid child node indices is 0 to length-1 inclusive.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Notation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Notation

  • All Superinterfaces:
    Node

    public interface Notation
extends Node
    This interface represents a notation declared in the DTD. A notation either declares, by name, the format of an unparsed entity (see section 4.7 of the XML 1.0 specification [XML 1.0]), or is used for formal declaration of processing instruction targets (see section 2.6 of the XML 1.0 specification [XML 1.0]). The nodeName attribute inherited from Node is set to the declared name of the notation.

    The DOM Core does not support editing Notation nodes; they are therefore readonly.

    A Notation node does not have any parent.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getPublicId()
      The public identifier of this notation.
      String getSystemId()
      The system identifier of this notation.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getPublicId

        String getPublicId()
        The public identifier of this notation. If the public identifier was not specified, this is null.

      • getSystemId

        String getSystemId()
        The system identifier of this notation. If the system identifier was not specified, this is null. This may be an absolute URI or not.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom (Java Platform SE 8 )

org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM).

See: Description

  • Interface Summary
    Interface Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM). Supports the Document Object Model Level 2 Core APIi, Document Object Model (DOM) Level 3 Core, and Document Object Model (DOM) Level 3 Load and Save.
Since:
JDK1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException

Interface Hierarchy

  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
  • org.w3c.dom.NodeList
  • org.w3c.dom.TypeInfo
  • org.w3c.dom.UserDataHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.w3c.dom (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom

  • Packages that use org.w3c.dom
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.bootstrap
    org.w3c.dom.events
    org.w3c.dom.ls
  • Classes in org.w3c.dom used by javax.imageio.metadata
    Class and Description
    Attr
    The Attr interface represents an attribute in an Element object.
    Document
    The Document interface represents the entire HTML or XML document.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Element
    The Element interface represents an element in an HTML or XML document.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Classes in org.w3c.dom used by javax.xml.bind
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.bind.annotation
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.bind.helpers
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.crypto.dom
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.crypto.dsig.dom
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.parsers
    Class and Description
    Document
    The Document interface represents the entire HTML or XML document.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
  • Classes in org.w3c.dom used by javax.xml.soap
    Class and Description
    Document
    The Document interface represents the entire HTML or XML document.
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
  • Classes in org.w3c.dom used by javax.xml.transform.dom
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.validation
    Class and Description
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
  • Classes in org.w3c.dom used by javax.xml.ws
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.ws.spi
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.ws.wsaddressing
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by org.w3c.dom
    Class and Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Classes in org.w3c.dom used by org.w3c.dom.bootstrap
    Class and Description
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
  • Classes in org.w3c.dom used by org.w3c.dom.events
    Class and Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by org.w3c.dom.ls
    Class and Description
    Document
    The Document interface represents the entire HTML or XML document.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ProcessingInstruction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface ProcessingInstruction

  • All Superinterfaces:
    Node

    public interface ProcessingInstruction
extends Node
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.

    No lexical check is done on the content of a processing instruction and it is therefore possible to have the character sequence "?>" in the content, which is illegal a processing instruction per section 2.6 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getData()
      The content of this processing instruction.
      String getTarget()
      The target of this processing instruction.
      void setData(String data)
      The content of this processing instruction.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getTarget

        String getTarget()
        The target of this processing instruction. XML defines this as being the first token following the markup that begins the processing instruction.

      • getData

        String getData()
        The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.

      • setData

        void setData(String data)
      throws DOMException
        The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Text (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Text

  • All Superinterfaces:
    CharacterData, Node
    All Known Subinterfaces:
    CDATASection, Text

    public interface Text
extends CharacterData
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr. If there is no markup inside an element's content, the text is contained in a single object implementing the Text interface that is the only child of the element. If there is markup, it is parsed into the information items (elements, comments, etc.) and Text nodes that form the list of children of the element.

    When a document is first made available via the DOM, there is only one Text node for each block of text. Users may create adjacent Text nodes that represent the contents of a given element without any intervening markup, but should be aware that there is no way to represent the separations between these nodes in XML or HTML, so they will not (in general) persist between DOM editing sessions. The Node.normalize() method merges any such adjacent Text objects into a single node for each block of text.

    No lexical check is done on the content of a Text node and, depending on its position in the document, some characters must be escaped during serialization using character references; e.g. the characters "<&" if the textual content is part of an element or of an attribute, the character sequence "]]>" when part of an element, the quotation mark character " or the apostrophe character ' when part of an attribute.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getWholeText()
      Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
      boolean isElementContentWhitespace()
      Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace".
      Text replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      Text splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • splitText

        Text splitText(int offset)
        throws DOMException
        Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings. After being split, this node will contain all the content up to the offset point. A new node of the same type, which contains all the content at and after the offset point, is returned. If the original node had a parent node, the new node is inserted as the next sibling of the original node. When the offset is equal to the length of this node, the new node has no data.
        Parameters:
        offset - The 16-bit unit offset at which to split, starting from 0.
        Returns:
        The new node, of the same type as this node.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • isElementContentWhitespace

        boolean isElementContentWhitespace()
        Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace". The text node is determined to contain whitespace in element content during the load of the document or if validation occurs while using Document.normalizeDocument().
        Since:
        DOM Level 3

      • getWholeText

        String getWholeText()
        Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
        For instance, in the example below wholeText on the Text node that contains "bar" returns "barfoo", while on the Text node that contains "foo" it returns "barfoo".
                             +-----+
                     | <p> |
                     +-----+
                       /\
                      /  \
               /-----\    +-------+
               | bar |    | &ent; |
               \-----/    +-------+
                              |
                              |
                           /-----\
                           | foo |
                           \-----/
        Figure: barTextNode.wholeText value is "barfoo"
        Since:
        DOM Level 3

      • replaceWholeText

        Text replaceWholeText(String content)
               throws DOMException
        Replaces the text of the current node and all logically-adjacent text nodes with the specified text. All logically-adjacent text nodes are removed including the current node unless it was the recipient of the replacement text.

        This method returns the node which received the replacement text. The returned node is:

        • null, when the replacement text is the empty string;
        • the current node, except when the current node is read-only;
        • a new Text node of the same type ( Text or CDATASection) as the current node inserted at the location of the replacement.

        For instance, in the above example calling replaceWholeText on the Text node that contains "bar" with "yo" in argument results in the following:

                             +-----+
                     | <p> |
                     +-----+
                        |
                        |
                     /-----\
                     | yo  |
                     \-----/
        Figure: barTextNode.replaceWholeText("yo") modifies the textual content of barTextNode with "yo"

        Where the nodes to be removed are read-only descendants of an EntityReference, the EntityReference must be removed instead of the read-only nodes. If any EntityReference to be removed has descendants that are not EntityReference, Text, or CDATASection nodes, the replaceWholeText method must fail before performing any modification of the document, raising a DOMException with the code NO_MODIFICATION_ALLOWED_ERR.

        For instance, in the example below calling replaceWholeText on the Text node that contains "bar" fails, because the EntityReference node "ent" contains an Element node which cannot be removed.

        Parameters:
        content - The content of the replacing Text node.
        Returns:
        The Text node created with the specified content.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if one of the Text nodes being replaced is readonly.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


TypeInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface TypeInfo

  • public interface TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document. The type is a pair of a namespace URI and name properties, and depends on the document's schema.

    If the document's schema is an XML DTD [XML 1.0], the values are computed as follows:

    • If this type is referenced from an Attr node, typeNamespace is "http://www.w3.org/TR/REC-xml" and typeName represents the [attribute type] property in the [XML Information Set] . If there is no declaration for the attribute, typeNamespace and typeName are null.
    • If this type is referenced from an Element node, typeNamespace and typeName are null.

    If the document's schema is an XML Schema [XML Schema Part 1] , the values are computed as follows using the post-schema-validation infoset contributions (also called PSVI contributions):

    • If the [validity] property exists AND is "invalid" or "notKnown": the {target namespace} and {name} properties of the declared type if available, otherwise null.

      Note: At the time of writing, the XML Schema specification does not require exposing the declared type. Thus, DOM implementations might choose not to provide type information if validity is not valid.

    • If the [validity] property exists and is "valid":
      1. If [member type definition] exists:
        1. If {name} is not absent, then expose {name} and {target namespace} properties of the [member type definition] property;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      2. If the [type definition] property exists:
        1. If {name} is not absent, then expose {name} and {target namespace} properties of the [type definition] property;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      3. If the [member type definition anonymous] exists:
        1. If it is false, then expose [member type definition name] and [member type definition namespace] properties;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      4. If the [type definition anonymous] exists:
        1. If it is false, then expose [type definition name] and [type definition namespace] properties;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.

    Note: Other schema languages are outside the scope of the W3C and therefore should define how to represent their type systems using TypeInfo.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int DERIVATION_EXTENSION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
      static int DERIVATION_LIST
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
      static int DERIVATION_RESTRICTION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
      static int DERIVATION_UNION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getTypeName()
      The name of a type declared for the associated element or attribute, or null if unknown.
      String getTypeNamespace()
      The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.
      boolean isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod)
      This method returns if there is a derivation between the reference type definition, i.e.

    • Field Detail

      • DERIVATION_RESTRICTION

        static final int DERIVATION_RESTRICTION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
        The reference type definition is derived by restriction from the other type definition if the other type definition is the same as the reference type definition, or if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and all the derivation methods involved are restriction.
        See Also:
        Constant Field Values

      • DERIVATION_EXTENSION

        static final int DERIVATION_EXTENSION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
        The reference type definition is derived by extension from the other type definition if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and at least one of the derivation methods involved is an extension.
        See Also:
        Constant Field Values

      • DERIVATION_UNION

        static final int DERIVATION_UNION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
        The reference type definition is derived by union from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} union, and one of the {member type definitions} is T2. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.
        See Also:
        Constant Field Values

      • DERIVATION_LIST

        static final int DERIVATION_LIST
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
        The reference type definition is derived by list from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} list, and T2 is the {item type definition}. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.
        See Also:
        Constant Field Values

    • Method Detail

      • getTypeName

        String getTypeName()
        The name of a type declared for the associated element or attribute, or null if unknown.

      • getTypeNamespace

        String getTypeNamespace()
        The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.

      • isDerivedFrom

        boolean isDerivedFrom(String typeNamespaceArg,
                      String typeNameArg,
                      int derivationMethod)
        This method returns if there is a derivation between the reference type definition, i.e. the TypeInfo on which the method is being called, and the other type definition, i.e. the one passed as parameters.
        Parameters:
        typeNamespaceArg - the namespace of the other type definition.
        typeNameArg - the name of the other type definition.
        derivationMethod - the type of derivation and conditions applied between two types, as described in the list of constants provided in this interface.
        Returns:
        If the document's schema is a DTD or no schema is associated with the document, this method will always return false . If the document's schema is an XML Schema, the method will return true if the reference type definition is derived from the other type definition according to the derivation parameter. If the value of the parameter is 0 (no bit is set to 1 for the derivationMethod parameter), the method will return true if the other type definition can be reached by recursing any combination of {base type definition}, {item type definition}, or {member type definitions} from the reference type definition.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UserDataHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface UserDataHandler

  • public interface UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed. This can be used by the application to implement various behaviors regarding the data it associates to the DOM nodes. This interface defines that handler.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short NODE_ADOPTED
      The node is adopted, using Document.adoptNode().
      static short NODE_CLONED
      The node is cloned, using Node.cloneNode().
      static short NODE_DELETED
      The node is deleted.
      static short NODE_IMPORTED
      The node is imported, using Document.importNode().
      static short NODE_RENAMED
      The node is renamed, using Document.renameNode().

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void handle(short operation, String key, Object data, Node src, Node dst)
      This method is called whenever the node for which this handler is registered is imported or cloned.

    • Field Detail

      • NODE_CLONED

        static final short NODE_CLONED
        The node is cloned, using Node.cloneNode().
        See Also:
        Constant Field Values

      • NODE_IMPORTED

        static final short NODE_IMPORTED
        The node is imported, using Document.importNode().
        See Also:
        Constant Field Values

      • NODE_DELETED

        static final short NODE_DELETED
        The node is deleted.

        Note: This may not be supported or may not be reliable in certain environments, such as Java, where the implementation has no real control over when objects are actually deleted.

        See Also:
        Constant Field Values

      • NODE_RENAMED

        static final short NODE_RENAMED
        The node is renamed, using Document.renameNode().
        See Also:
        Constant Field Values

      • NODE_ADOPTED

        static final short NODE_ADOPTED
        The node is adopted, using Document.adoptNode().
        See Also:
        Constant Field Values

    • Method Detail

      • handle

        void handle(short operation,
            String key,
            Object data,
            Node src,
            Node dst)
        This method is called whenever the node for which this handler is registered is imported or cloned.
        DOM applications must not raise exceptions in a UserDataHandler. The effect of throwing exceptions from the handler is DOM implementation dependent.
        Parameters:
        operation - Specifies the type of operation that is being performed on the node.
        key - Specifies the key for which this handler is being called.
        data - Specifies the data for which this handler is being called.
        src - Specifies the node being cloned, adopted, imported, or renamed. This is null when the node is being deleted.
        dst - Specifies the node newly created if any, or null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.w3c.dom.bootstrap (Java Platform SE 8 )

compact2 - org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.bootstrap

  • Class Summary
    Class Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.w3c.dom.bootstrap (Java Platform SE 8 )

compact3 - org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.bootstrap

  • Class Summary
    Class Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMImplementationRegistry (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.bootstrap

Class DOMImplementationRegistry

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry

  • public final class DOMImplementationRegistry
extends Object
    A factory that enables applications to obtain instances of DOMImplementation.

    Example:

      // get an instance of the DOMImplementation registry
  DOMImplementationRegistry registry =
       DOMImplementationRegistry.newInstance();
  // get a DOM implementation the Level 3 XML module
  DOMImplementation domImpl =
       registry.getDOMImplementation("XML 3.0");

    This provides an application with an implementation-independent starting point. DOM implementations may modify this class to meet new security standards or to provide *additional* fallbacks for the list of DOMImplementationSources.

    Since:
    DOM Level 3
    See Also:
    DOMImplementation, DOMImplementationSource

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PROPERTY
      The system property to specify the DOMImplementationSource class names.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addSource(DOMImplementationSource s)
      Register an implementation.
      DOMImplementation getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.
      DOMImplementationList getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
      static DOMImplementationRegistry newInstance()
      Obtain a new instance of a DOMImplementationRegistry.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PROPERTY

        public static final String PROPERTY
        The system property to specify the DOMImplementationSource class names.
        See Also:
        Constant Field Values

    • Method Detail

      • newInstance

        public static DOMImplementationRegistry newInstance()
                                             throws ClassNotFoundException,
                                                    InstantiationException,
                                                    IllegalAccessException,
                                                    ClassCastException
        Obtain a new instance of a DOMImplementationRegistry. The DOMImplementationRegistry is initialized by the application or the implementation, depending on the context, by first checking the value of the Java system property org.w3c.dom.DOMImplementationSourceList and the service provider whose contents are at "META_INF/services/org.w3c.dom.DOMImplementationSourceList". The value of this property is a white-space separated list of names of availables classes implementing the DOMImplementationSource interface. Each class listed in the class name list is instantiated and any exceptions encountered are thrown to the application.
        Returns:
        an initialized instance of DOMImplementationRegistry
        Throws:
        ClassNotFoundException - If any specified class can not be found
        InstantiationException - If any specified class is an interface or abstract class
        IllegalAccessException - If the default constructor of a specified class is not accessible
        ClassCastException - If any specified class does not implement DOMImplementationSource

      • getDOMImplementation

        public DOMImplementation getDOMImplementation(String features)
        Return the first implementation that has the desired features, or null if none is found.
        Parameters:
        features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
        Returns:
        An implementation that has the desired features, or null if none found.

      • getDOMImplementationList

        public DOMImplementationList getDOMImplementationList(String features)
        Return a list of implementations that support the desired features.
        Parameters:
        features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
        Returns:
        A list of DOMImplementations that support the desired features.

      • addSource

        public void addSource(DOMImplementationSource s)
        Register an implementation.
        Parameters:
        s - The source to be registered, may not be null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.bootstrap (Java Platform SE 8 )

org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.bootstrap

  • Class Summary
    Class Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.bootstrap Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.bootstrap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.w3c.dom.bootstrap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.bootstrap

  • Packages that use org.w3c.dom.bootstrap
    Package Description
    org.w3c.dom.bootstrap
  • Classes in org.w3c.dom.bootstrap used by org.w3c.dom.bootstrap
    Class and Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.w3c.dom.bootstrap.DOMImplementationRegistry (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.bootstrap.DOMImplementationRegistry

  • Packages that use DOMImplementationRegistry
    Package Description
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationRegistry in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationRegistry
      Modifier and Type Method and Description
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
      Obtain a new instance of a DOMImplementationRegistry.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Attr (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Attr

  • Packages that use Attr
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of Attr in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Attr
      Modifier and Type | Method and Description
      Attr | IIOMetadataNode.getAttributeNode(String name)
      Attr IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName)
      Equivalent to getAttributeNode(localName).
      Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      Attr IIOMetadataNode.setAttributeNodeNS(Attr newAttr)
      Equivalent to setAttributeNode(newAttr).
      Methods in javax.imageio.metadata with parameters of type Attr
      Modifier and Type | Method and Description
      Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      Attr IIOMetadataNode.setAttributeNodeNS(Attr newAttr)
      Equivalent to setAttributeNode(newAttr).
      void IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of Attr in org.w3c.dom

      Methods in org.w3c.dom that return Attr
      Modifier and Type Method and Description
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      Attr Element.getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      Methods in org.w3c.dom with parameters of type Attr
      Modifier and Type Method and Description
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.CDATASection (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.CDATASection

  • Packages that use CDATASection
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of CDATASection in org.w3c.dom

      Methods in org.w3c.dom that return CDATASection
      Modifier and Type Method and Description
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.CharacterData (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.CharacterData

  • Packages that use CharacterData
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of CharacterData in org.w3c.dom

      Subinterfaces of CharacterData in org.w3c.dom
      Modifier and Type Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Comment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Comment

  • Packages that use Comment
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of Comment in org.w3c.dom

      Methods in org.w3c.dom that return Comment
      Modifier and Type Method and Description
      Comment Document.createComment(String data)
      Creates a Comment node given the specified string.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Document (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Document

  • Packages that use Document
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.ls

    • Uses of Document in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Document
      Modifier and Type Method and Description
      Document IIOMetadataNode.getOwnerDocument()
      Returns null, since IIOMetadataNodes do not belong to any Document.

    • Uses of Document in javax.xml.parsers

      Methods in javax.xml.parsers that return Document
      Modifier and Type Method and Description
      abstract Document DocumentBuilder.newDocument()
      Obtain a new instance of a DOM Document object to build a DOM tree with.
      Document DocumentBuilder.parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.

    • Uses of Document in javax.xml.soap

      Classes in javax.xml.soap that implement Document
      Modifier and Type Class and Description
      class  SOAPPart
      The container for the SOAP-specific portion of a SOAPMessage object.
      Methods in javax.xml.soap that return Document
      Modifier and Type Method and Description
      Document SOAPBody.extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      Methods in javax.xml.soap with parameters of type Document
      Modifier and Type Method and Description
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.

    • Uses of Document in org.w3c.dom

      Methods in org.w3c.dom that return Document
      Modifier and Type Method and Description
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      Document Node.getOwnerDocument()
      The Document object associated with this node.

    • Uses of Document in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Document
      Modifier and Type Method and Description
      Document LSLoadEvent.getNewDocument()
      The document that finished loading.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DocumentFragment (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DocumentFragment

  • Packages that use DocumentFragment
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DocumentFragment in org.w3c.dom

      Methods in org.w3c.dom that return DocumentFragment
      Modifier and Type Method and Description
      DocumentFragment Document.createDocumentFragment()
      Creates an empty DocumentFragment object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DocumentType (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DocumentType

  • Packages that use DocumentType
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DocumentType in org.w3c.dom

      Methods in org.w3c.dom that return DocumentType
      Modifier and Type Method and Description
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      DocumentType Document.getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Methods in org.w3c.dom with parameters of type DocumentType
      Modifier and Type Method and Description
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMConfiguration (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMConfiguration

  • Packages that use DOMConfiguration
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.ls

    • Uses of DOMConfiguration in org.w3c.dom

      Methods in org.w3c.dom that return DOMConfiguration
      Modifier and Type Method and Description
      DOMConfiguration Document.getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.

    • Uses of DOMConfiguration in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return DOMConfiguration
      Modifier and Type Method and Description
      DOMConfiguration LSParser.getDomConfig()
      The DOMConfiguration object used when parsing an input source.
      DOMConfiguration LSSerializer.getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMError (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMError

  • Packages that use DOMError
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DOMError in org.w3c.dom

      Methods in org.w3c.dom with parameters of type DOMError
      Modifier and Type Method and Description
      boolean DOMErrorHandler.handleError(DOMError error)
      This method is called on the error handler when an error occurs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMErrorHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMErrorHandler

No usage of org.w3c.dom.DOMErrorHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.w3c.dom.DOMException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.DOMException

  • Packages that use DOMException
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of DOMException in javax.imageio.metadata

      Methods in javax.imageio.metadata that throw DOMException
      Modifier and Type | Method and Description
      short IIOMetadataNode.compareDocumentPosition(Node other)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getBaseURI()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.getFeature(String feature, String version)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getNamespaceURI()
      Returns null, since namespaces are not supported.
      TypeInfo IIOMetadataNode.getSchemaTypeInfo()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getTextContent()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.getUserData(String key)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isDefaultNamespace(String namespaceURI)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isEqualNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isSameNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.lookupNamespaceURI(String prefix)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.lookupPrefix(String namespaceURI)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      void IIOMetadataNode.setIdAttribute(String name, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setTextContent(String textContent)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of DOMException in org.w3c.dom

      Methods in org.w3c.dom that throw DOMException
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      void CharacterData.appendData(String arg)
      Append the string to the end of the character data of the node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      void CharacterData.deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String Element.getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      String CharacterData.getData()
      The character data of the node that implements this interface.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      String Node.getNodeValue()
      The value of this node, depending on its type; see the table above.
      Object DOMConfiguration.getParameter(String name)
      Return the value of a parameter if known.
      String Node.getTextContent()
      This attribute returns the text content of this node and its descendants.
      boolean Element.hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      void CharacterData.insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void Element.removeAttribute(String name)
      Removes an attribute by name.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void Element.removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void CharacterData.replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      void Element.setAttribute(String name, String value)
      Adds a new attribute.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void CharacterData.setData(String data)
      The character data of the node that implements this interface.
      void ProcessingInstruction.setData(String data)
      The content of this processing instruction.
      void Element.setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      void Node.setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void DOMConfiguration.setParameter(String name, Object value)
      Set the value of a parameter.
      void Node.setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void Node.setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      void Attr.setValue(String value)
      On retrieval, the value of the attribute is returned as a string.
      void Document.setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void Document.setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
      String CharacterData.substringData(int offset, int count)
      Extracts a range of data from the node.

    • Uses of DOMException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw DOMException
      Modifier and Type | Method and Description
      Event | DocumentEvent.createEvent(String eventType)

    • Uses of DOMException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw DOMException
      Modifier and Type Method and Description
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMImplementation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementation

  • Packages that use DOMImplementation
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.bootstrap

    • Uses of DOMImplementation in javax.xml.parsers

      Methods in javax.xml.parsers that return DOMImplementation
      Modifier and Type Method and Description
      abstract DOMImplementation DocumentBuilder.getDOMImplementation()
      Obtain an instance of a DOMImplementation object.

    • Uses of DOMImplementation in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMImplementationSource.getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementation Document.getImplementation()
      The DOMImplementation object that handles this document.
      DOMImplementation DOMImplementationList.item(int index)
      Returns the indexth item in the collection.

    • Uses of DOMImplementation in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMImplementationRegistry.getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMImplementationList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementationList

  • Packages that use DOMImplementationList
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationList in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementationList
      Modifier and Type Method and Description
      DOMImplementationList DOMImplementationSource.getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • Uses of DOMImplementationList in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationList
      Modifier and Type Method and Description
      DOMImplementationList DOMImplementationRegistry.getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMImplementationSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementationSource

  • Packages that use DOMImplementationSource
    Package Description
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationSource in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap with parameters of type DOMImplementationSource
      Modifier and Type Method and Description
      void DOMImplementationRegistry.addSource(DOMImplementationSource s)
      Register an implementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMLocator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMLocator

  • Packages that use DOMLocator
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DOMLocator in org.w3c.dom

      Methods in org.w3c.dom that return DOMLocator
      Modifier and Type Method and Description
      DOMLocator DOMError.getLocation()
      The location of the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.DOMStringList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMStringList

  • Packages that use DOMStringList
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DOMStringList in org.w3c.dom

      Methods in org.w3c.dom that return DOMStringList
      Modifier and Type Method and Description
      DOMStringList DOMConfiguration.getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Element (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Element

  • Packages that use Element
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.ls

    • Uses of Element in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Element
      Modifier and Type Class and Description
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.

    • Uses of Element in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return Element
      Modifier and Type | Method and Description
      Element | W3CDomHandler.getElement(DOMResult r)
      Methods in javax.xml.bind.annotation with parameters of type Element
      Modifier and Type | Method and Description
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of Element in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Element
      Modifier and Type Method and Description
      Element DOMCryptoContext.getElementById(String idValue)
      Returns the Element with the specified ID attribute value.
      Methods in javax.xml.crypto.dom with parameters of type Element
      Modifier and Type Method and Description
      void DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
      Registers the element's attribute specified by the namespace URI and local name to be of type ID.

    • Uses of Element in javax.xml.soap

      Subinterfaces of Element in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Methods in javax.xml.soap with parameters of type Element
      Modifier and Type Method and Description
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.

    • Uses of Element in javax.xml.ws

      Methods in javax.xml.ws with parameters of type Element
      Modifier and Type Method and Description
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      EndpointReference WebServiceContext.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      abstract EndpointReference Endpoint.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.

    • Uses of Element in javax.xml.ws.spi

      Method parameters in javax.xml.ws.spi with type arguments of type Element
      Modifier and Type Method and Description
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of Element in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type Element
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.

    • Uses of Element in org.w3c.dom

      Methods in org.w3c.dom that return Element
      Modifier and Type Method and Description
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      Element Document.getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      Element Document.getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      Element Attr.getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.

    • Uses of Element in org.w3c.dom.ls

      Methods in org.w3c.dom.ls with parameters of type Element
      Modifier and Type Method and Description
      short LSParserFilter.startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Entity (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Entity

No usage of org.w3c.dom.Entity
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.EntityReference (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.EntityReference

  • Packages that use EntityReference
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of EntityReference in org.w3c.dom

      Methods in org.w3c.dom that return EntityReference
      Modifier and Type Method and Description
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.NamedNodeMap (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.NamedNodeMap

  • Packages that use NamedNodeMap
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of NamedNodeMap in javax.imageio.metadata

      Methods in javax.imageio.metadata that return NamedNodeMap
      Modifier and Type Method and Description
      NamedNodeMap IIOMetadataNode.getAttributes()
      Returns a NamedNodeMap containing the attributes of this node.

    • Uses of NamedNodeMap in org.w3c.dom

      Methods in org.w3c.dom that return NamedNodeMap
      Modifier and Type Method and Description
      NamedNodeMap Node.getAttributes()
      A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
      NamedNodeMap DocumentType.getEntities()
      A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
      NamedNodeMap DocumentType.getNotations()
      A NamedNodeMap containing the notations declared in the DTD.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.NameList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.NameList

No usage of org.w3c.dom.NameList
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Node (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Node

  • Packages that use Node
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Node in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Node
      Modifier and Type Class and Description
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
      Fields in javax.imageio.metadata declared as Node
      Modifier and Type Field and Description
      protected Node IIOInvalidTreeException.offendingNode
      The Node that led to the parsing error, or null.
      Methods in javax.imageio.metadata that return Node
      Modifier and Type | Method and Description
      Node IIOMetadataNode.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node IIOMetadataNode.cloneNode(boolean deep)
      Returns a duplicate of this node.
      abstract Node IIOMetadata.getAsTree(String formatName)
      Returns an XML DOM Node object that represents the root of a tree of metadata contained within this object according to the conventions defined by a given metadata format.
      Node IIOMetadataNode.getFirstChild()
      Returns the first child of this node, or null if the node has no children.
      Node IIOMetadataNode.getLastChild()
      Returns the last child of this node, or null if the node has no children.
      Node IIOMetadataNode.getNextSibling()
      Returns the next sibling of this node, or null if the node has no next sibling.
      Node IIOInvalidTreeException.getOffendingNode()
      Returns the Node that caused the error in parsing.
      Node IIOMetadataNode.getParentNode()
      Returns the parent of this node.
      Node IIOMetadataNode.getPreviousSibling()
      Returns the previous sibling of this node, or null if this node has no previous sibling.
      Node IIOMetadataNode.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      Node | IIOMetadataNode.item(int index)
      Node IIOMetadataNode.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node IIOMetadataNode.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Methods in javax.imageio.metadata with parameters of type Node
      Modifier and Type Method and Description
      Node IIOMetadataNode.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      short IIOMetadataNode.compareDocumentPosition(Node other)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Node IIOMetadataNode.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean IIOMetadataNode.isEqualNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isSameNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      abstract void IIOMetadata.mergeTree(String formatName, Node root)
      Alters the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
      Node IIOMetadataNode.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node IIOMetadataNode.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void IIOMetadata.setFromTree(String formatName, Node root)
      Sets the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
      Constructors in javax.imageio.metadata with parameters of type Node
      Constructor and Description
      IIOInvalidTreeException(String message, Node offendingNode)
      Constructs an IIOInvalidTreeException with a message string and a reference to the Node that caused the parsing error.
      IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
      Constructs an IIOInvalidTreeException with a message string, a reference to an exception that caused this exception, and a reference to the Node that caused the parsing error.

    • Uses of Node in javax.xml.bind

      Methods in javax.xml.bind that return Node
      Modifier and Type Method and Description
      Node ValidationEventLocator.getNode()
      Return a reference to the DOM Node if available
      Node Marshaller.getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Methods in javax.xml.bind that return types with arguments of type Node
      Modifier and Type Method and Description
      Binder<Node> JAXBContext.createBinder()
      Creates a Binder for W3C DOM.
      Methods in javax.xml.bind with parameters of type Node
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      Object Unmarshaller.unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

    • Uses of Node in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Node
      Modifier and Type | Method and Description
      Node | ValidationEventLocatorImpl.getNode()
      Node AbstractMarshallerImpl.getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      Methods in javax.xml.bind.helpers with parameters of type Node
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.marshal(Object obj, Node node)
      void ValidationEventLocatorImpl.setNode(Node _node)
      Set the Node field on this event locator.
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
      Constructors in javax.xml.bind.helpers with parameters of type Node
      Constructor and Description
      ValidationEventLocatorImpl(Node _node)
      Constructs an object that points to a DOM Node.

    • Uses of Node in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Node
      Modifier and Type Method and Description
      Node DOMURIReference.getHere()
      Returns the here node.
      Node DOMStructure.getNode()
      Returns the node contained in this DOMStructure.
      Constructors in javax.xml.crypto.dom with parameters of type Node
      Constructor and Description
      DOMStructure(Node node)
      Creates a DOMStructure containing the specified node.

    • Uses of Node in javax.xml.crypto.dsig.dom

      Methods in javax.xml.crypto.dsig.dom that return Node
      Modifier and Type Method and Description
      Node DOMSignContext.getNextSibling()
      Returns the nextSibling node.
      Node DOMValidateContext.getNode()
      Returns the node.
      Node DOMSignContext.getParent()
      Returns the parent node.
      Methods in javax.xml.crypto.dsig.dom with parameters of type Node
      Modifier and Type Method and Description
      void DOMSignContext.setNextSibling(Node nextSibling)
      Sets the next sibling node.
      void DOMValidateContext.setNode(Node node)
      Sets the node.
      void DOMSignContext.setParent(Node parent)
      Sets the parent node.
      Constructors in javax.xml.crypto.dsig.dom with parameters of type Node
      Constructor and Description
      DOMSignContext(Key signingKey, Node parent)
      Creates a DOMSignContext with the specified signing key and parent node.
      DOMSignContext(Key signingKey, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
      DOMValidateContext(Key validatingKey, Node node)
      Creates a DOMValidateContext containing the specified key and node.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.

    • Uses of Node in javax.xml.soap

      Subinterfaces of Node in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  Node
      A representation of a node (element) in an XML document.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Classes in javax.xml.soap that implement Node
      Modifier and Type Class and Description
      class  SOAPPart
      The container for the SOAP-specific portion of a SOAPMessage object.

    • Uses of Node in javax.xml.transform.dom

      Methods in javax.xml.transform.dom that return Node
      Modifier and Type Method and Description
      Node DOMResult.getNextSibling()
      Get the child node before which the result nodes will be inserted.
      Node DOMSource.getNode()
      Get the node that represents a Source DOM tree.
      Node DOMResult.getNode()
      Get the node that will contain the result DOM tree.
      Node DOMLocator.getOriginatingNode()
      Return the node where the event occurred.
      Methods in javax.xml.transform.dom with parameters of type Node
      Modifier and Type Method and Description
      void DOMResult.setNextSibling(Node nextSibling)
      Set the child node before which the result nodes will be inserted.
      void DOMSource.setNode(Node node)
      Set the node that will represents a Source DOM tree.
      void DOMResult.setNode(Node node)
      Set the node that will contain the result DOM tree.
      Constructors in javax.xml.transform.dom with parameters of type Node
      Constructor and Description
      DOMResult(Node node)
      Use a DOM node to create a new output target.
      DOMResult(Node node, Node nextSibling)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
      DOMResult(Node node, Node nextSibling, String systemId)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
      DOMResult(Node node, String systemId)
      Use a DOM node to create a new output target with the specified System ID.
      DOMSource(Node n)
      Create a new input source with a DOM node.
      DOMSource(Node node, String systemID)
      Create a new input source with a DOM node, and with the system ID also passed in as the base URI.

    • Uses of Node in org.w3c.dom

      Subinterfaces of Node in org.w3c.dom
      Modifier and Type Interface and Description
      interface  Attr
      The Attr interface represents an attribute in an Element object.
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  CharacterData
      The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Document
      The Document interface represents the entire HTML or XML document.
      interface  DocumentFragment
      DocumentFragment is a "lightweight" or "minimal" Document object.
      interface  DocumentType
      Each Document has a doctype attribute whose value is either null or a DocumentType object.
      interface  Element
      The Element interface represents an element in an HTML or XML document.
      interface  Entity
      This interface represents a known entity, either parsed or unparsed, in an XML document.
      interface  EntityReference
      EntityReference nodes may be used to represent an entity reference in the tree.
      interface  Notation
      This interface represents a notation declared in the DTD.
      interface  ProcessingInstruction
      The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
      Methods in org.w3c.dom that return Node
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node Node.cloneNode(boolean deep)
      Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
      Node Node.getFirstChild()
      The first child of this node.
      Node Node.getLastChild()
      The last child of this node.
      Node NamedNodeMap.getNamedItem(String name)
      Retrieves a node specified by name.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      Node Node.getNextSibling()
      The node immediately following this node.
      Node Node.getParentNode()
      The parent of this node.
      Node Node.getPreviousSibling()
      The node immediately preceding this node.
      Node DOMLocator.getRelatedNode()
      The node this locator is pointing to, or null if no node is available.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      Node NodeList.item(int index)
      Returns the indexth item in the collection.
      Node NamedNodeMap.item(int index)
      Returns the indexth item in the map.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      Methods in org.w3c.dom with parameters of type Node
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      void UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
      This method is called whenever the node for which this handler is registered is imported or cloned.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean Node.isEqualNode(Node arg)
      Tests whether two nodes are equal.
      boolean Node.isSameNode(Node other)
      Returns whether this node is the same node as the given one.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.

    • Uses of Node in org.w3c.dom.events

      Methods in org.w3c.dom.events that return Node
      Modifier and Type Method and Description
      Node MutationEvent.getRelatedNode()
      relatedNode is used to identify a secondary node related to a mutation event.
      Methods in org.w3c.dom.events with parameters of type Node
      Modifier and Type Method and Description
      void MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
      The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.

    • Uses of Node in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Node
      Modifier and Type Method and Description
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      Methods in org.w3c.dom.ls with parameters of type Node
      Modifier and Type Method and Description
      short LSParserFilter.acceptNode(Node nodeArg)
      This method will be called by the parser at the completion of the parsing of each node.
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean LSSerializer.writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.NodeList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.NodeList

  • Packages that use NodeList
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of NodeList in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement NodeList
      Modifier and Type Class and Description
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
      Methods in javax.imageio.metadata that return NodeList
      Modifier and Type | Method and Description
      NodeList IIOMetadataNode.getChildNodes()
      Returns a NodeList that contains all children of this node.
      NodeList | IIOMetadataNode.getElementsByTagName(String name)
      NodeList IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName)
      Equivalent to getElementsByTagName(localName).

    • Uses of NodeList in org.w3c.dom

      Methods in org.w3c.dom that return NodeList
      Modifier and Type Method and Description
      NodeList Node.getChildNodes()
      A NodeList that contains all children of this node.
      NodeList Element.getElementsByTagName(String name)
      Returns a NodeList of all descendant Elements with a given tag name, in document order.
      NodeList Document.getElementsByTagName(String tagname)
      Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      NodeList Document.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Notation (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Notation

No usage of org.w3c.dom.Notation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ProcessingInstruction (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ProcessingInstruction

  • Packages that use ProcessingInstruction
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of ProcessingInstruction in org.w3c.dom

      Methods in org.w3c.dom that return ProcessingInstruction
      Modifier and Type Method and Description
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Text (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Text

  • Packages that use Text
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of Text in javax.xml.soap

      Subinterfaces of Text in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Text
      A representation of a node whose value is text.

    • Uses of Text in org.w3c.dom

      Subinterfaces of Text in org.w3c.dom
      Modifier and Type Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      Methods in org.w3c.dom that return Text
      Modifier and Type Method and Description
      Text Document.createTextNode(String data)
      Creates a Text node given the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.TypeInfo (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.TypeInfo

  • Packages that use TypeInfo
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of TypeInfo in javax.imageio.metadata

      Methods in javax.imageio.metadata that return TypeInfo
      Modifier and Type Method and Description
      TypeInfo IIOMetadataNode.getSchemaTypeInfo()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of TypeInfo in javax.xml.validation

      Methods in javax.xml.validation that return TypeInfo
      Modifier and Type Method and Description
      abstract TypeInfo TypeInfoProvider.getAttributeTypeInfo(int index)
      Returns the immutable TypeInfo object for the specified attribute of the current element.
      abstract TypeInfo TypeInfoProvider.getElementTypeInfo()
      Returns the immutable TypeInfo object for the current element.

    • Uses of TypeInfo in org.w3c.dom

      Methods in org.w3c.dom that return TypeInfo
      Modifier and Type Method and Description
      TypeInfo Element.getSchemaTypeInfo()
      The type information associated with this element.
      TypeInfo Attr.getSchemaTypeInfo()
      The type information associated with this attribute.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.UserDataHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.UserDataHandler

  • Packages that use UserDataHandler
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of UserDataHandler in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type UserDataHandler
      Modifier and Type Method and Description
      Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of UserDataHandler in org.w3c.dom

      Methods in org.w3c.dom with parameters of type UserDataHandler
      Modifier and Type Method and Description
      Object Node.setUserData(String key, Object data, UserDataHandler handler)
      Associate an object to a key on this node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.w3c.dom.events (Java Platform SE 8 )

compact2 - org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException


org.w3c.dom.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.events

  • Interface Summary
    Interface Description
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception Description
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.w3c.dom.events (Java Platform SE 8 )

compact3 - org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException


org.w3c.dom.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.events

  • Interface Summary
    Interface Description
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception Description
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface DocumentEvent

  • public interface DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation. It is expected that the DocumentEvent interface will be implemented on the same object which implements the Document interface in an implementation which supports the Event model.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type | Method and Description
      Event | createEvent(String eventType)

    • Method Detail

      • createEvent

        Event createEvent(String eventType)
           throws DOMException
        Parameters:
        eventType - The eventType parameter specifies the type of Event interface to be created. If the Event interface specified is supported by the implementation this method will return a new Event of the interface type requested. If the Event is to be dispatched via the dispatchEvent method the appropriate event init method must be called after creation in order to initialize the Event's values. As an example, a user wishing to synthesize some kind of UIEvent would call createEvent with the parameter "UIEvents". The initUIEvent method could then be called on the newly created UIEvent to set the specific type of UIEvent to be dispatched and set its context information.The createEvent method is used in creating Events when it is either inconvenient or unnecessary for the user to create an Event themselves. In cases where the implementation provided Event is insufficient, users may supply their own Event implementations for use with the dispatchEvent method.
        Returns:
        The newly created Event
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the implementation does not support the type of Event interface requested
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Event (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface Event

  • All Known Subinterfaces:
    LSLoadEvent, LSProgressEvent, MouseEvent, MutationEvent, UIEvent

    public interface Event
    The Event interface is used to provide contextual information about an event to the handler processing the event. An object which implements the Event interface is generally passed as the first parameter to an event handler. More specific context information is passed to event handlers by deriving additional interfaces from Event which contain information directly relating to the type of event they accompany. These derived interfaces are also implemented by the object passed to the event listener.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short AT_TARGET
      The event is currently being evaluated at the target EventTarget.
      static short BUBBLING_PHASE
      The current event phase is the bubbling phase.
      static short CAPTURING_PHASE
      The current event phase is the capturing phase.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean getBubbles()
      Used to indicate whether or not an event is a bubbling event.
      boolean getCancelable()
      Used to indicate whether or not an event can have its default action prevented.
      EventTarget getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      short getEventPhase()
      Used to indicate which phase of event flow is currently being evaluated.
      EventTarget getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      long getTimeStamp()
      Used to specify the time (in milliseconds relative to the epoch) at which the event was created.
      String getType()
      The name of the event (case-insensitive).
      void initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg)
      The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface.
      void preventDefault()
      If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur.
      void stopPropagation()
      The stopPropagation method is used prevent further propagation of an event during event flow.

    • Field Detail

      • CAPTURING_PHASE

        static final short CAPTURING_PHASE
        The current event phase is the capturing phase.
        See Also:
        Constant Field Values

      • AT_TARGET

        static final short AT_TARGET
        The event is currently being evaluated at the target EventTarget.
        See Also:
        Constant Field Values

      • BUBBLING_PHASE

        static final short BUBBLING_PHASE
        The current event phase is the bubbling phase.
        See Also:
        Constant Field Values

    • Method Detail

      • getType

        String getType()
        The name of the event (case-insensitive). The name must be an XML name.

      • getTarget

        EventTarget getTarget()
        Used to indicate the EventTarget to which the event was originally dispatched.

      • getCurrentTarget

        EventTarget getCurrentTarget()
        Used to indicate the EventTarget whose EventListeners are currently being processed. This is particularly useful during capturing and bubbling.

      • getEventPhase

        short getEventPhase()
        Used to indicate which phase of event flow is currently being evaluated.

      • getBubbles

        boolean getBubbles()
        Used to indicate whether or not an event is a bubbling event. If the event can bubble the value is true, else the value is false.

      • getCancelable

        boolean getCancelable()
        Used to indicate whether or not an event can have its default action prevented. If the default action can be prevented the value is true, else the value is false.

      • getTimeStamp

        long getTimeStamp()
        Used to specify the time (in milliseconds relative to the epoch) at which the event was created. Due to the fact that some systems may not provide this information the value of timeStamp may be not available for all events. When not available, a value of 0 will be returned. Examples of epoch time are the time of the system start or 0:0:0 UTC 1st January 1970.

      • stopPropagation

        void stopPropagation()
        The stopPropagation method is used prevent further propagation of an event during event flow. If this method is called by any EventListener the event will cease propagating through the tree. The event will complete dispatch to all listeners on the current EventTarget before event flow stops. This method may be used during any stage of event flow.

      • preventDefault

        void preventDefault()
        If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur. If, during any stage of event flow, the preventDefault method is called the event is canceled. Any default action associated with the event will not occur. Calling this method for a non-cancelable event has no effect. Once preventDefault has been called it will remain in effect throughout the remainder of the event's propagation. This method may be used during any stage of event flow.

      • initEvent

        void initEvent(String eventTypeArg,
               boolean canBubbleArg,
               boolean cancelableArg)
        The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface. This method may only be called before the Event has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times the final invocation takes precedence. If called from a subclass of Event interface only the values specified in the initEvent method are modified, all other attributes are left unchanged.
        Parameters:
        eventTypeArg - Specifies the event type. This type may be any event type currently defined in this specification or a new event type.. The string must be an XML name. Any new event type must not begin with any upper, lower, or mixed case version of the string "DOM". This prefix is reserved for future DOM event sets. It is also strongly recommended that third parties adding their own events use their own prefix to avoid confusion and lessen the probability of conflicts with other new events.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EventException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Class EventException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException
  • All Implemented Interfaces:
    Serializable

    public class EventException
extends RuntimeException
    Event operations may throw an EventException as specified in their method descriptions.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | code
      static short UNSPECIFIED_EVENT_TYPE_ERR
      If the Event's type was not specified by initializing the event before the method was called.

    • Constructor Summary

      Constructors
      Constructor and Description
      EventException(short code, String message)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • code

        public short code

      • UNSPECIFIED_EVENT_TYPE_ERR

        public static final short UNSPECIFIED_EVENT_TYPE_ERR
        If the Event's type was not specified by initializing the event before the method was called. Specification of the Event's type as null or an empty string will also trigger this exception.
        See Also:
        Constant Field Values

    • Constructor Detail

      • EventException

        public EventException(short code,
                      String message)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EventListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface EventListener

  • public interface EventListener
    The EventListener interface is the primary method for handling events. Users implement the EventListener interface and register their listener on an EventTarget using the AddEventListener method. The users should also remove their EventListener from its EventTarget after they have completed using the listener.

    When a Node is copied using the cloneNode method the EventListeners attached to the source Node are not attached to the copied Node. If the user wishes the same EventListeners to be added to the newly created copy the user must add them manually.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • Method Detail

      • handleEvent

        void handleEvent(Event evt)
        This method is called whenever an event occurs of the type for which the EventListener interface was registered.
        Parameters:
        evt - The Event contains contextual information about the event. It also contains the stopPropagation and preventDefault methods which are used in determining the event's flow and default action.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EventTarget (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface EventTarget

  • public interface EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model. Therefore, this interface can be obtained by using binding-specific casting methods on an instance of the Node interface. The interface allows registration and removal of EventListeners on an EventTarget and dispatch of events to that EventTarget.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      boolean dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.

    • Method Detail

      • addEventListener

        void addEventListener(String type,
                      EventListener listener,
                      boolean useCapture)
        This method allows the registration of event listeners on the event target. If an EventListener is added to an EventTarget while it is processing an event, it will not be triggered by the current actions but may be triggered during a later stage of event flow, such as the bubbling phase.
        If multiple identical EventListeners are registered on the same EventTarget with the same parameters the duplicate instances are discarded. They do not cause the EventListener to be called twice and since they are discarded they do not need to be removed with the removeEventListener method.
        Parameters:
        type - The event type for which the user is registering
        listener - The listener parameter takes an interface implemented by the user which contains the methods to be called when the event occurs.
        useCapture - If true, useCapture indicates that the user wishes to initiate capture. After initiating capture, all events of the specified type will be dispatched to the registered EventListener before being dispatched to any EventTargets beneath them in the tree. Events which are bubbling upward through the tree will not trigger an EventListener designated to use capture.

      • removeEventListener

        void removeEventListener(String type,
                         EventListener listener,
                         boolean useCapture)
        This method allows the removal of event listeners from the event target. If an EventListener is removed from an EventTarget while it is processing an event, it will not be triggered by the current actions. EventListeners can never be invoked after being removed.
        Calling removeEventListener with arguments which do not identify any currently registered EventListener on the EventTarget has no effect.
        Parameters:
        type - Specifies the event type of the EventListener being removed.
        listener - The EventListener parameter indicates the EventListener to be removed.
        useCapture - Specifies whether the EventListener being removed was registered as a capturing listener or not. If a listener was registered twice, one with capture and one without, each must be removed separately. Removal of a capturing listener does not affect a non-capturing version of the same listener, and vice versa.

      • dispatchEvent

        boolean dispatchEvent(Event evt)
               throws EventException
        This method allows the dispatch of events into the implementations event model. Events dispatched in this manner will have the same capturing and bubbling behavior as events dispatched directly by the implementation. The target of the event is the EventTarget on which dispatchEvent is called.
        Parameters:
        evt - Specifies the event type, behavior, and contextual information to be used in processing the event.
        Returns:
        The return value of dispatchEvent indicates whether any of the listeners which handled the event called preventDefault. If preventDefault was called the value is false, else the value is true.
        Throws:
        EventException - UNSPECIFIED_EVENT_TYPE_ERR: Raised if the Event's type was not specified by initializing the event before dispatchEvent was called. Specification of the Event's type as null or an empty string will also trigger this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MouseEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface MouseEvent

  • All Superinterfaces:
    Event, UIEvent

    public interface MouseEvent
extends UIEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.

    The detail attribute inherited from UIEvent indicates the number of times a mouse button has been pressed and released over the same screen location during a user action. The attribute value is 1 when the user begins this action and increments by 1 for each full sequence of pressing and releasing. If the user moves the mouse between the mousedown and mouseup the value will be set to 0, indicating that no click is occurring.

    In the case of nested elements mouse events are always targeted at the most deeply nested element. Ancestors of the targeted element may use bubbling to obtain notification of mouse events which occur within its descendent elements.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean getAltKey()
      Used to indicate whether the 'alt' key was depressed during the firing of the event.
      short getButton()
      During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state.
      int getClientX()
      The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.
      int getClientY()
      The vertical coordinate at which the event occurred relative to the DOM implementation's client area.
      boolean getCtrlKey()
      Used to indicate whether the 'ctrl' key was depressed during the firing of the event.
      boolean getMetaKey()
      Used to indicate whether the 'meta' key was depressed during the firing of the event.
      EventTarget getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      int getScreenX()
      The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.
      int getScreenY()
      The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.
      boolean getShiftKey()
      Used to indicate whether the 'shift' key was depressed during the firing of the event.
      void initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.

      • Methods inherited from interface org.w3c.dom.events.UIEvent

        getDetail, getView, initUIEvent

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getScreenX

        int getScreenX()
        The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.

      • getScreenY

        int getScreenY()
        The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.

      • getClientX

        int getClientX()
        The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.

      • getClientY

        int getClientY()
        The vertical coordinate at which the event occurred relative to the DOM implementation's client area.

      • getCtrlKey

        boolean getCtrlKey()
        Used to indicate whether the 'ctrl' key was depressed during the firing of the event.

      • getShiftKey

        boolean getShiftKey()
        Used to indicate whether the 'shift' key was depressed during the firing of the event.

      • getAltKey

        boolean getAltKey()
        Used to indicate whether the 'alt' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

      • getMetaKey

        boolean getMetaKey()
        Used to indicate whether the 'meta' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

      • getButton

        short getButton()
        During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state. The values for button range from zero to indicate the left button of the mouse, one to indicate the middle button if present, and two to indicate the right button. For mice configured for left handed use in which the button actions are reversed the values are instead read from right to left.

      • getRelatedTarget

        EventTarget getRelatedTarget()
        Used to identify a secondary EventTarget related to a UI event. Currently this attribute is used with the mouseover event to indicate the EventTarget which the pointing device exited and with the mouseout event to indicate the EventTarget which the pointing device entered.

      • initMouseEvent

        void initMouseEvent(String typeArg,
                    boolean canBubbleArg,
                    boolean cancelableArg,
                    AbstractView viewArg,
                    int detailArg,
                    int screenXArg,
                    int screenYArg,
                    int clientXArg,
                    int clientYArg,
                    boolean ctrlKeyArg,
                    boolean altKeyArg,
                    boolean shiftKeyArg,
                    boolean metaKeyArg,
                    short buttonArg,
                    EventTarget relatedTargetArg)
        The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface. This method may only be called before the MouseEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        Parameters:
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        viewArg - Specifies the Event's AbstractView.
        detailArg - Specifies the Event's mouse click count.
        screenXArg - Specifies the Event's screen x coordinate
        screenYArg - Specifies the Event's screen y coordinate
        clientXArg - Specifies the Event's client x coordinate
        clientYArg - Specifies the Event's client y coordinate
        ctrlKeyArg - Specifies whether or not control key was depressed during the Event.
        altKeyArg - Specifies whether or not alt key was depressed during the Event.
        shiftKeyArg - Specifies whether or not shift key was depressed during the Event.
        metaKeyArg - Specifies whether or not meta key was depressed during the Event.
        buttonArg - Specifies the Event's mouse button.
        relatedTargetArg - Specifies the Event's related EventTarget.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


MutationEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface MutationEvent

  • All Superinterfaces:
    Event

    public interface MutationEvent
extends Event
    The MutationEvent interface provides specific contextual information associated with Mutation events.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short ADDITION
      The Attr was just added.
      static short MODIFICATION
      The Attr was modified in place.
      static short REMOVAL
      The Attr was just removed.

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      short getAttrChange()
      attrChange indicates the type of change which triggered the DOMAttrModified event.
      String getAttrName()
      attrName indicates the name of the changed Attr node in a DOMAttrModified event.
      String getNewValue()
      newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
      String getPrevValue()
      prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
      Node getRelatedNode()
      relatedNode is used to identify a secondary node related to a mutation event.
      void initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
      The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Field Detail

      • MODIFICATION

        static final short MODIFICATION
        The Attr was modified in place.
        See Also:
        Constant Field Values

      • ADDITION

        static final short ADDITION
        The Attr was just added.
        See Also:
        Constant Field Values

      • REMOVAL

        static final short REMOVAL
        The Attr was just removed.
        See Also:
        Constant Field Values

    • Method Detail

      • getRelatedNode

        Node getRelatedNode()
        relatedNode is used to identify a secondary node related to a mutation event. For example, if a mutation event is dispatched to a node indicating that its parent has changed, the relatedNode is the changed parent. If an event is instead dispatched to a subtree indicating a node was changed within it, the relatedNode is the changed node. In the case of the DOMAttrModified event it indicates the Attr node which was modified, added, or removed.

      • getPrevValue

        String getPrevValue()
        prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

      • getNewValue

        String getNewValue()
        newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

      • getAttrName

        String getAttrName()
        attrName indicates the name of the changed Attr node in a DOMAttrModified event.

      • getAttrChange

        short getAttrChange()
        attrChange indicates the type of change which triggered the DOMAttrModified event. The values can be MODIFICATION , ADDITION, or REMOVAL.

      • initMutationEvent

        void initMutationEvent(String typeArg,
                       boolean canBubbleArg,
                       boolean cancelableArg,
                       Node relatedNodeArg,
                       String prevValueArg,
                       String newValueArg,
                       String attrNameArg,
                       short attrChangeArg)
        The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface. This method may only be called before the MutationEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        Parameters:
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        relatedNodeArg - Specifies the Event's related Node.
        prevValueArg - Specifies the Event's prevValue attribute. This value may be null.
        newValueArg - Specifies the Event's newValue attribute. This value may be null.
        attrNameArg - Specifies the Event's attrName attribute. This value may be null.
        attrChangeArg - Specifies the Event's attrChange attribute
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.events (Java Platform SE 8 )

org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException


org.w3c.dom.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.events

  • Interface Summary
    Interface Description
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception Description
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.events Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.events

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException

Interface Hierarchy

  • org.w3c.dom.events.DocumentEvent
  • org.w3c.dom.events.Event
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • org.w3c.dom.events.EventListener
  • org.w3c.dom.events.EventTarget
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.w3c.dom.events (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.events

  • Packages that use org.w3c.dom.events
    Package Description
    org.w3c.dom.events
    org.w3c.dom.ls
  • Classes in org.w3c.dom.events used by org.w3c.dom.events
    Class and Description
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Classes in org.w3c.dom.events used by org.w3c.dom.ls
    Class and Description
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


UIEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface UIEvent

  • All Superinterfaces:
    Event
    All Known Subinterfaces:
    MouseEvent

    public interface UIEvent
extends Event
    The UIEvent interface provides specific contextual information associated with User Interface events.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getDetail()
      Specifies some detail information about the Event, depending on the type of event.
      AbstractView getView()
      The view attribute identifies the AbstractView from which the event was generated.
      void initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg)
      The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getView

        AbstractView getView()
        The view attribute identifies the AbstractView from which the event was generated.

      • getDetail

        int getDetail()
        Specifies some detail information about the Event, depending on the type of event.

      • initUIEvent

        void initUIEvent(String typeArg,
                 boolean canBubbleArg,
                 boolean cancelableArg,
                 AbstractView viewArg,
                 int detailArg)
        The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface. This method may only be called before the UIEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        Parameters:
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        viewArg - Specifies the Event's AbstractView.
        detailArg - Specifies the Event's detail.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.DocumentEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.DocumentEvent

No usage of org.w3c.dom.events.DocumentEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.Event (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.Event

  • Packages that use Event
    Package Description
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Event in org.w3c.dom.events

      Subinterfaces of Event in org.w3c.dom.events
      Modifier and Type Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
      interface  MutationEvent
      The MutationEvent interface provides specific contextual information associated with Mutation events.
      interface  UIEvent
      The UIEvent interface provides specific contextual information associated with User Interface events.
      Methods in org.w3c.dom.events that return Event
      Modifier and Type | Method and Description
      Event | DocumentEvent.createEvent(String eventType)
      Methods in org.w3c.dom.events with parameters of type Event
      Modifier and Type Method and Description
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void EventListener.handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • Uses of Event in org.w3c.dom.ls

      Subinterfaces of Event in org.w3c.dom.ls
      Modifier and Type Interface and Description
      interface  LSLoadEvent
      This interface represents a load event object that signals the completion of a document load.
      interface  LSProgressEvent
      This interface represents a progress event object that notifies the application about progress as a document is parsed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.w3c.dom.events.EventException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.events.EventException

  • Packages that use EventException
    Package Description
    org.w3c.dom.events

    • Uses of EventException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw EventException
      Modifier and Type Method and Description
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.EventListener (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.EventListener

  • Packages that use EventListener
    Package Description
    org.w3c.dom.events

    • Uses of EventListener in org.w3c.dom.events

      Methods in org.w3c.dom.events with parameters of type EventListener
      Modifier and Type Method and Description
      void EventTarget.addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      void EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.EventTarget (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.EventTarget

  • Packages that use EventTarget
    Package Description
    org.w3c.dom.events

    • Uses of EventTarget in org.w3c.dom.events

      Methods in org.w3c.dom.events that return EventTarget
      Modifier and Type Method and Description
      EventTarget Event.getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      EventTarget MouseEvent.getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      EventTarget Event.getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      Methods in org.w3c.dom.events with parameters of type EventTarget
      Modifier and Type Method and Description
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.MouseEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.MouseEvent

No usage of org.w3c.dom.events.MouseEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.MutationEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.MutationEvent

No usage of org.w3c.dom.events.MutationEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.UIEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.UIEvent

  • Packages that use UIEvent
    Package Description
    org.w3c.dom.events

    • Uses of UIEvent in org.w3c.dom.events

      Subinterfaces of UIEvent in org.w3c.dom.events
      Modifier and Type Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.w3c.dom.ls (Java Platform SE 8 )

compact2 - org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException


org.w3c.dom.ls (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.ls

  • Interface Summary
    Interface Description
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.w3c.dom.ls (Java Platform SE 8 )

compact3 - org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException


org.w3c.dom.ls (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.ls

  • Interface Summary
    Interface Description
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DOMImplementationLS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface DOMImplementationLS

  • public interface DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.

    The expectation is that an instance of the DOMImplementationLS interface can be obtained by using binding-specific casting methods on an instance of the DOMImplementation interface or, if the Document supports the feature "Core" version "3.0" defined in [DOM Level 3 Core] , by using the method DOMImplementation.getFeature with parameter values "LS" (or "LS-Async") and "3.0" (respectively).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short MODE_ASYNCHRONOUS
      Create an asynchronous LSParser.
      static short MODE_SYNCHRONOUS
      Create a synchronous LSParser.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput createLSInput()
      Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
      LSOutput createLSOutput()
      Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
      LSParser createLSParser(short mode, String schemaType)
      Create a new LSParser.
      LSSerializer createLSSerializer()
      Create a new LSSerializer object.

    • Field Detail

      • MODE_SYNCHRONOUS

        static final short MODE_SYNCHRONOUS
        Create a synchronous LSParser.
        See Also:
        Constant Field Values

      • MODE_ASYNCHRONOUS

        static final short MODE_ASYNCHRONOUS
        Create an asynchronous LSParser.
        See Also:
        Constant Field Values

    • Method Detail

      • createLSParser

        LSParser createLSParser(short mode,
                        String schemaType)
                 throws DOMException
        Create a new LSParser. The newly constructed parser may then be configured by means of its DOMConfiguration object, and used to parse documents by means of its parse method.
        Parameters:
        mode - The mode argument is either MODE_SYNCHRONOUS or MODE_ASYNCHRONOUS, if mode is MODE_SYNCHRONOUS then the LSParser that is created will operate in synchronous mode, if it's MODE_ASYNCHRONOUS then the LSParser that is created will operate in asynchronous mode.
        schemaType - An absolute URI representing the type of the schema language used during the load of a Document using the newly created LSParser. Note that no lexical checking is done on the absolute URI. In order to create a LSParser for any kind of schema types (i.e. the LSParser will be free to use any schema found), use the value null.

        Note: For W3C XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other Schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

        Returns:
        The newly created LSParser object. This LSParser is either synchronous or asynchronous depending on the value of the mode argument.

        Note: By default, the newly created LSParser does not contain a DOMErrorHandler, i.e. the value of the " error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSParser object contains a reference to the default error handler.

        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the requested mode or schema type is not supported.

      • createLSSerializer

        LSSerializer createLSSerializer()
        Create a new LSSerializer object.
        Returns:
        The newly created LSSerializer object.

        Note: By default, the newly created LSSerializer has no DOMErrorHandler, i.e. the value of the "error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSSerializer object contains a reference to the default error handler.

      • createLSInput

        LSInput createLSInput()
        Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
        Returns:
        The newly created input object.

      • createLSOutput

        LSOutput createLSOutput()
        Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
        Returns:
        The newly created output object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Class LSException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException
  • All Implemented Interfaces:
    Serializable

    public class LSException
extends RuntimeException
    Parser or write operations may throw an LSException if the processing is stopped. The processing can be stopped due to a DOMError with a severity of DOMError.SEVERITY_FATAL_ERROR or a non recovered DOMError.SEVERITY_ERROR, or if DOMErrorHandler.handleError() returned false.

    Note: As suggested in the definition of the constants in the DOMError interface, a DOM implementation may choose to continue after a fatal error, but the resulting DOM tree is then implementation dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | code
      static short PARSE_ERR
      If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
      static short SERIALIZE_ERR
      If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.

    • Constructor Summary

      Constructors
      Constructor and Description
      LSException(short code, String message)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • code

        public short code

      • PARSE_ERR

        public static final short PARSE_ERR
        If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
        See Also:
        Constant Field Values

      • SERIALIZE_ERR

        public static final short SERIALIZE_ERR
        If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.
        See Also:
        Constant Field Values

    • Constructor Detail

      • LSException

        public LSException(short code,
                   String message)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSInput (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSInput

  • public interface LSInput
    This interface represents an input source for data.

    This interface allows an application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

    The exact definitions of a byte stream and a character stream are binding dependent.

    The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSInput() to create objects that implement this interface.

    The LSParser will use the LSInput object to determine how to read data. The LSParser will look at the different inputs specified in the LSInput in the following order to know which one to read from, the first one that is not null and not an empty string will be used:

    1. LSInput.characterStream
    2. LSInput.byteStream
    3. LSInput.stringData
    4. LSInput.systemId
    5. LSInput.publicId

    If all inputs are null, the LSParser will report a DOMError with its DOMError.type set to "no-input-specified" and its DOMError.severity set to DOMError.SEVERITY_FATAL_ERROR.

    LSInput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getBaseURI()
      The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
      InputStream getByteStream()
      An attribute of a language and binding dependent type that represents a stream of bytes.
      boolean getCertifiedText()
      If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
      Reader getCharacterStream()
      An attribute of a language and binding dependent type that represents a stream of 16-bit units.
      String getEncoding()
      The character encoding, if known.
      String getPublicId()
      The public identifier for this input source.
      String getStringData()
      String data to parse.
      String getSystemId()
      The system identifier, a URI reference [IETF RFC 2396], for this input source.
      void setBaseURI(String baseURI)
      The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
      void setByteStream(InputStream byteStream)
      An attribute of a language and binding dependent type that represents a stream of bytes.
      void setCertifiedText(boolean certifiedText)
      If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
      void setCharacterStream(Reader characterStream)
      An attribute of a language and binding dependent type that represents a stream of 16-bit units.
      void setEncoding(String encoding)
      The character encoding, if known.
      void setPublicId(String publicId)
      The public identifier for this input source.
      void setStringData(String stringData)
      String data to parse.
      void setSystemId(String systemId)
      The system identifier, a URI reference [IETF RFC 2396], for this input source.

    • Method Detail

      • getCharacterStream

        Reader getCharacterStream()
        An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • setCharacterStream

        void setCharacterStream(Reader characterStream)
        An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • getByteStream

        InputStream getByteStream()
        An attribute of a language and binding dependent type that represents a stream of bytes.
        If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

      • setByteStream

        void setByteStream(InputStream byteStream)
        An attribute of a language and binding dependent type that represents a stream of bytes.
        If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

      • getStringData

        String getStringData()
        String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • setStringData

        void setStringData(String stringData)
        String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • getSystemId

        String getSystemId()
        The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
        If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
        If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

      • setSystemId

        void setSystemId(String systemId)
        The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
        If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
        If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

      • getPublicId

        String getPublicId()
        The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

      • setPublicId

        void setPublicId(String publicId)
        The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

      • getBaseURI

        String getBaseURI()
        The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
        If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

      • setBaseURI

        void setBaseURI(String baseURI)
        The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
        If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

      • getEncoding

        String getEncoding()
        The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
        This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

      • setEncoding

        void setEncoding(String encoding)
        The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
        This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

      • getCertifiedText

        boolean getCertifiedText()
        If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

      • setCertifiedText

        void setCertifiedText(boolean certifiedText)
        If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSLoadEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSLoadEvent

  • All Superinterfaces:
    Event

    public interface LSLoadEvent
extends Event
    This interface represents a load event object that signals the completion of a document load.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput getInput()
      The input source that was parsed.
      Document getNewDocument()
      The document that finished loading.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getNewDocument

        Document getNewDocument()
        The document that finished loading.

      • getInput

        LSInput getInput()
        The input source that was parsed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSOutput (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSOutput

  • public interface LSOutput
    This interface represents an output destination for data.

    This interface allows an application to encapsulate information about an output destination in a single object, which may include a URI, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

    The exact definitions of a byte stream and a character stream are binding dependent.

    The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSOutput() to create objects that implement this interface.

    The LSSerializer will use the LSOutput object to determine where to serialize the output to. The LSSerializer will look at the different outputs specified in the LSOutput in the following order to know which one to output to, the first one that is not null and not an empty string will be used:

    1. LSOutput.characterStream
    2. LSOutput.byteStream
    3. LSOutput.systemId

    LSOutput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      OutputStream getByteStream()
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
      Writer getCharacterStream()
      An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
      String getEncoding()
      The character encoding to use for the output.
      String getSystemId()
      The system identifier, a URI reference [IETF RFC 2396], for this output destination.
      void setByteStream(OutputStream byteStream)
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
      void setCharacterStream(Writer characterStream)
      An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
      void setEncoding(String encoding)
      The character encoding to use for the output.
      void setSystemId(String systemId)
      The system identifier, a URI reference [IETF RFC 2396], for this output destination.

    • Method Detail

      • getCharacterStream

        Writer getCharacterStream()
        An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

      • setCharacterStream

        void setCharacterStream(Writer characterStream)
        An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

      • getByteStream

        OutputStream getByteStream()
        An attribute of a language and binding dependent type that represents a writable stream of bytes.

      • setByteStream

        void setByteStream(OutputStream byteStream)
        An attribute of a language and binding dependent type that represents a writable stream of bytes.

      • getSystemId

        String getSystemId()
        The system identifier, a URI reference [IETF RFC 2396], for this output destination.
        If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

      • setSystemId

        void setSystemId(String systemId)
        The system identifier, a URI reference [IETF RFC 2396], for this output destination.
        If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

      • getEncoding

        String getEncoding()
        The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.

      • setEncoding

        void setEncoding(String encoding)
        The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSParser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSParser

  • public interface LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.

    LSParser provides an API for parsing XML and building the corresponding DOM document structure. A LSParser instance can be obtained by invoking the DOMImplementationLS.createLSParser() method.

    As specified in [DOM Level 3 Core] , when a document is first made available via the LSParser:

    • there will never be two adjacent nodes of type NODE_TEXT, and there will never be empty text nodes.
    • it is expected that the value and nodeValue attributes of an Attr node initially return the XML 1.0 normalized value. However, if the parameters " validate-if-schema" and " datatype-normalization" are set to true, depending on the attribute normalization used, the attribute values may differ from the ones obtained by the XML 1.0 attribute normalization. If the parameters " datatype-normalization" is set to false, the XML 1.0 attribute normalization is guaranteed to occur, and if the attributes list does not contain namespace declarations, the attributes attribute on Element node represents the property [attributes] defined in [XML Information Set] .

    Asynchronous LSParser objects are expected to also implement the events::EventTarget interface so that event listeners can be registered on asynchronous LSParser objects.

    Events supported by asynchronous LSParser objects are:

    load
    The LSParser finishes to load the document. See also the definition of the LSLoadEvent interface.
    progress
    The LSParser signals progress as data is parsed. This specification does not attempt to define exactly when progress events should be dispatched. That is intentionally left as implementation-dependent. Here is one example of how an application might dispatch progress events: Once the parser starts receiving data, a progress event is dispatched to indicate that the parsing starts. From there on, a progress event is dispatched for every 4096 bytes of data that is received and processed. This is only one example, though, and implementations can choose to dispatch progress events at any time while parsing, or not dispatch them at all. See also the definition of the LSProgressEvent interface.

    Note: All events defined in this specification use the namespace URI "http://www.w3.org/2002/DOMLS".

    While parsing an input source, errors are reported to the application through the error handler (LSParser.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors that can occur while parsing XML, or any other markup, but some common error cases are defined. The types (DOMError.type) of errors and warnings defined by this specification are:

    "check-character-normalization-failure" [error]
    Raised if the parameter " check-character-normalization" is set to true and a string is encountered that fails normalization checking.
    "doctype-not-allowed" [fatal]
    Raised if the configuration parameter "disallow-doctype" is set to true and a doctype is encountered.
    "no-input-specified" [fatal]
    Raised when loading a document and no input is specified in the LSInput object.
    "pi-base-uri-not-preserved" [warning]
    Raised if a processing instruction is encountered in a location where the base URI of the processing instruction can not be preserved. One example of a case where this warning will be raised is if the configuration parameter " entities" is set to false and the following XML file is parsed:
     <!DOCTYPE root [ <!ENTITY e SYSTEM 'subdir/myentity.ent' ]>
 <root> &e; </root>
    And subdir/myentity.ent contains:
    <one> <two/> </one> <?pi 3.14159?>
 <more/>
    "unbound-prefix-in-entity" [warning]
    An implementation dependent warning that may be raised if the configuration parameter " namespaces" is set to true and an unbound namespace prefix is encountered in an entity's replacement text. Raising this warning is not enforced since some existing parsers may not recognize unbound namespace prefixes in the replacement text of entities.
    "unknown-character-denormalization" [fatal]
    Raised if the configuration parameter "ignore-unknown-character-denormalizations" is set to false and a character is encountered for which the processor cannot determine the normalization properties.
    "unsupported-encoding" [fatal]
    Raised if an unsupported encoding is encountered.
    "unsupported-media-type" [fatal]
    Raised if the configuration parameter "supported-media-types-only" is set to true and an unsupported media type is encountered.

    In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...), XML well-formedness errors, and so on.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short ACTION_APPEND_AS_CHILDREN
      Append the result of the parse operation as children of the context node.
      static short ACTION_INSERT_AFTER
      Insert the result of the parse operation as the immediately following sibling of the context node.
      static short ACTION_INSERT_BEFORE
      Insert the result of the parse operation as the immediately preceding sibling of the context node.
      static short ACTION_REPLACE
      Replace the context node with the result of the parse operation.
      static short ACTION_REPLACE_CHILDREN
      Replace all the children of the context node with the result of the parse operation.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void abort()
      Abort the loading of the document that is currently being loaded by the LSParser.
      boolean getAsync()
      true if the LSParser is asynchronous, false if it is synchronous.
      boolean getBusy()
      true if the LSParser is currently busy loading a document, otherwise false.
      DOMConfiguration getDomConfig()
      The DOMConfiguration object used when parsing an input source.
      LSParserFilter getFilter()
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
      Document parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      void setFilter(LSParserFilter filter)
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

    • Field Detail

      • ACTION_APPEND_AS_CHILDREN

        static final short ACTION_APPEND_AS_CHILDREN
        Append the result of the parse operation as children of the context node. For this action to work, the context node must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_REPLACE_CHILDREN

        static final short ACTION_REPLACE_CHILDREN
        Replace all the children of the context node with the result of the parse operation. For this action to work, the context node must be an Element, a Document, or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_INSERT_BEFORE

        static final short ACTION_INSERT_BEFORE
        Insert the result of the parse operation as the immediately preceding sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_INSERT_AFTER

        static final short ACTION_INSERT_AFTER
        Insert the result of the parse operation as the immediately following sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_REPLACE

        static final short ACTION_REPLACE
        Replace the context node with the result of the parse operation. For this action to work, the context node must have a parent, and the parent must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

    • Method Detail

      • getDomConfig

        DOMConfiguration getDomConfig()
        The DOMConfiguration object used when parsing an input source. This DOMConfiguration is specific to the parse operation. No parameter values from this DOMConfiguration object are passed automatically to the DOMConfiguration object on the Document that is created, or used, by the parse operation. The DOM application is responsible for passing any needed parameter values from this DOMConfiguration object to the DOMConfiguration object referenced by the Document object.
        In addition to the parameters recognized in on the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSParser add or modify the following parameters:
        "charset-overrides-xml-encoding"
        true
        [optional] (default) If a higher level protocol such as HTTP [IETF RFC 2616] provides an indication of the character encoding of the input stream being processed, that will override any encoding specified in the XML declaration or the Text declaration (see also section 4.3.3, "Character Encoding in Entities", in [XML 1.0]). Explicitly setting an encoding in the LSInput overrides any encoding from the protocol.
        false
        [required] The parser ignores any character set encoding information from higher-level protocols.
        "disallow-doctype"
        true
        [optional] Throw a fatal "doctype-not-allowed" error if a doctype node is found while parsing the document. This is useful when dealing with things like SOAP envelopes where doctype nodes are not allowed.
        false
        [required] (default) Allow doctype nodes in the document.
        "ignore-unknown-character-denormalizations"
        true
        [required] (default) If, while verifying full normalization when [XML 1.1] is supported, a processor encounters characters for which it cannot determine the normalization properties, then the processor will ignore any possible denormalizations caused by these characters. This parameter is ignored for [XML 1.0].
        false
        [optional] Report an fatal "unknown-character-denormalization" error if a character is encountered for which the processor cannot determine the normalization properties.
        "infoset"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter will default to true for LSParser.
        "namespaces"
        true
        [required] (default) Perform the namespace processing as defined in [XML Namespaces] and [XML Namespaces 1.1] .
        false
        [optional] Do not perform the namespace processing.
        "resource-resolver"
        [required] A reference to a LSResourceResolver object, or null. If the value of this parameter is not null when an external resource (such as an external XML entity or an XML schema location) is encountered, the implementation will request that the LSResourceResolver referenced in this parameter resolves the resource.
        "supported-media-types-only"
        true
        [optional] Check that the media type of the parsed resource is a supported media type. If an unsupported media type is encountered, a fatal error of type "unsupported-media-type" will be raised. The media types defined in [IETF RFC 3023] must always be accepted.
        false
        [required] (default) Accept any media type.
        "validate"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
        "validate-if-schema"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
        "well-formed"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter cannot be set to false.

      • getFilter

        LSParserFilter getFilter()
        When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

      • setFilter

        void setFilter(LSParserFilter filter)
        When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

      • getAsync

        boolean getAsync()
        true if the LSParser is asynchronous, false if it is synchronous.

      • getBusy

        boolean getBusy()
        true if the LSParser is currently busy loading a document, otherwise false.

      • parse

        Document parse(LSInput input)
        throws DOMException,
               LSException
        Parse an XML document from a resource identified by a LSInput.
        Parameters:
        input - The LSInput from which the source of the document is to be read.
        Returns:
        If the LSParser is a synchronous LSParser, the newly created and populated Document is returned. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
        Throws:
        DOMException - INVALID_STATE_ERR: Raised if the LSParser's LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • parseURI

        Document parseURI(String uri)
           throws DOMException,
                  LSException
        Parse an XML document from a location identified by a URI reference [IETF RFC 2396]. If the URI contains a fragment identifier (see section 4.1 in [IETF RFC 2396]), the behavior is not defined by this specification, future versions of this specification may define the behavior.
        Parameters:
        uri - The location of the XML document to be read.
        Returns:
        If the LSParser is a synchronous LSParser, the newly created and populated Document is returned, or null if an error occured. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
        Throws:
        DOMException - INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • parseWithContext

        Node parseWithContext(LSInput input,
                      Node contextArg,
                      short action)
               throws DOMException,
                      LSException
        Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments. When parsing the input stream, the context node (or its parent, depending on where the result will be inserted) is used for resolving unbound namespace prefixes. The context node's ownerDocument node (or the node itself if the node of type DOCUMENT_NODE) is used to resolve default attributes and entity references.
        As the new data is inserted into the document, at least one mutation event is fired per new immediate child or sibling of the context node.
        If the context node is a Document node and the action is ACTION_REPLACE_CHILDREN, then the document that is passed as the context node will be changed such that its xmlEncoding, documentURI, xmlVersion, inputEncoding, xmlStandalone, and all other such attributes are set to what they would be set to if the input source was parsed using LSParser.parse().
        This method is always synchronous, even if the LSParser is asynchronous (LSParser.async is true).
        If an error occurs while parsing, the caller is notified through the ErrorHandler instance associated with the " error-handler" parameter of the DOMConfiguration.
        When calling parseWithContext, the values of the following configuration parameters will be ignored and their default values will always be used instead: " validate", " validate-if-schema", and " element-content-whitespace". Other parameters will be treated normally, and the parser is expected to call the LSParserFilter just as if a whole document was parsed.
        Parameters:
        input - The LSInput from which the source document is to be read. The source document must be an XML fragment, i.e. anything except a complete XML document (except in the case where the context node of type DOCUMENT_NODE, and the action is ACTION_REPLACE_CHILDREN), a DOCTYPE (internal subset), entity declaration(s), notation declaration(s), or XML or text declaration(s).
        contextArg - The node that is used as the context for the data that is being parsed. This node must be a Document node, a DocumentFragment node, or a node of a type that is allowed as a child of an Element node, e.g. it cannot be an Attribute node.
        action - This parameter describes which action should be taken between the new set of nodes being inserted and the existing children of the context node. The set of possible actions is defined in ACTION_TYPES above.
        Returns:
        Return the node that is the result of the parse operation. If the result is more than one top-level node, the first one is returned.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if the content cannot replace, be inserted before, after, or as a child of the context node (see also Node.insertBefore or Node.replaceChild in [DOM Level 3 Core] ).
        NOT_SUPPORTED_ERR: Raised if the LSParser doesn't support this method, or if the context node is of type Document and the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
        NO_MODIFICATION_ALLOWED_ERR: Raised if the context node is a read only node and the content is being appended to its child list, or if the parent node of the context node is read only node and the content is being inserted in its child list.
        INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML fragment. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • abort

        void abort()
        Abort the loading of the document that is currently being loaded by the LSParser. If the LSParser is currently not busy, a call to this method does nothing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSParserFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSParserFilter

  • public interface LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing. As each node is examined, it may be modified or removed, or the entire parse may be terminated early.

    At the time any of the filter methods are called by the parser, the owner Document and DOMImplementation objects exist and are accessible. The document element is never passed to the LSParserFilter methods, i.e. it is not possible to filter out the document element. Document, DocumentType, Notation, Entity, and Attr nodes are never passed to the acceptNode method on the filter. The child nodes of an EntityReference node are passed to the filter if the parameter " entities" is set to false. Note that, as described by the parameter " entities", unexpanded entity reference nodes are never discarded and are always passed to the filter.

    All validity checking while parsing a document occurs on the source document as it appears on the input stream, not on the DOM document as it is built in memory. With filters, the document in memory may be a subset of the document on the stream, and its validity may have been affected by the filtering.

    All default attributes must be present on elements when the elements are passed to the filter methods. All other default content must be passed to the filter methods.

    DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short FILTER_ACCEPT
      Accept the node.
      static short FILTER_INTERRUPT
      Interrupt the normal processing of the document.
      static short FILTER_REJECT
      Reject the node and its children.
      static short FILTER_SKIP
      Skip this single node.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      short acceptNode(Node nodeArg)
      This method will be called by the parser at the completion of the parsing of each node.
      int getWhatToShow()
      Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode.
      short startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.

    • Field Detail

      • FILTER_ACCEPT

        static final short FILTER_ACCEPT
        Accept the node.
        See Also:
        Constant Field Values

      • FILTER_REJECT

        static final short FILTER_REJECT
        Reject the node and its children.
        See Also:
        Constant Field Values

      • FILTER_SKIP

        static final short FILTER_SKIP
        Skip this single node. The children of this node will still be considered.
        See Also:
        Constant Field Values

      • FILTER_INTERRUPT

        static final short FILTER_INTERRUPT
        Interrupt the normal processing of the document.
        See Also:
        Constant Field Values

    • Method Detail

      • startElement

        short startElement(Element elementArg)
        The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed. The intent is to allow the element, including any children, to be efficiently skipped. Note that only element nodes are passed to the startElement function.
        The element node passed to startElement for filtering will include all of the Element's attributes, but none of the children nodes. The Element may not yet be in place in the document being constructed (it may not have a parent node.)
        A startElement filter function may access or change the attributes for the Element. Changing Namespace declarations will have no effect on namespace resolution by the parser.
        For efficiency, the Element node passed to the filter may not be the same one as is actually placed in the tree if the node is accepted. And the actual node (node object identity) may be reused during the process of reading in and filtering a document.
        Parameters:
        elementArg - The newly encountered element. At the time this method is called, the element is incomplete - it will have its attributes, but no children.
        Returns:
        • FILTER_ACCEPT if the Element should be included in the DOM document being built.
        • FILTER_REJECT if the Element and all of its children should be rejected.
        • FILTER_SKIP if the Element should be skipped. All of its children are inserted in place of the skipped Element node.
        • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Element is rejected.
        Returning any other values will result in unspecified behavior.

      • acceptNode

        short acceptNode(Node nodeArg)
        This method will be called by the parser at the completion of the parsing of each node. The node and all of its descendants will exist and be complete. The parent node will also exist, although it may be incomplete, i.e. it may have additional children that have not yet been parsed. Attribute nodes are never passed to this function.
        From within this method, the new node may be freely modified - children may be added or removed, text nodes modified, etc. The state of the rest of the document outside this node is not defined, and the affect of any attempt to navigate to, or to modify any other part of the document is undefined.
        For validating parsers, the checks are made on the original document, before any modification by the filter. No validity checks are made on any document modifications made by the filter.
        If this new node is rejected, the parser might reuse the new node and any of its descendants.
        Parameters:
        nodeArg - The newly constructed element. At the time this method is called, the element is complete - it has all of its children (and their children, recursively) and attributes, and is attached as a child to its parent.
        Returns:
        • FILTER_ACCEPT if this Node should be included in the DOM document being built.
        • FILTER_REJECT if the Node and all of its children should be rejected.
        • FILTER_SKIP if the Node should be skipped and the Node should be replaced by all the children of the Node.
        • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Node is accepted and will be the last completely parsed node.

      • getWhatToShow

        int getWhatToShow()
        Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode. If a node is not shown to the filter using this attribute, it is automatically included in the DOM document being built. See NodeFilter for definition of the constants. The constants SHOW_ATTRIBUTE , SHOW_DOCUMENT, SHOW_DOCUMENT_TYPE, SHOW_NOTATION, SHOW_ENTITY, and SHOW_DOCUMENT_FRAGMENT are meaningless here. Those nodes will never be passed to LSParserFilter.acceptNode.
        The constants used here are defined in [DOM Level 2 Traversal and Range] .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSProgressEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSProgressEvent

  • All Superinterfaces:
    Event

    public interface LSProgressEvent
extends Event
    This interface represents a progress event object that notifies the application about progress as a document is parsed. It extends the Event interface defined in [DOM Level 3 Events] .

    The units used for the attributes position and totalSize are not specified and can be implementation and input dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput getInput()
      The input source that is being parsed.
      int getPosition()
      The current position in the input source, including all external entities and other resources that have been read.
      int getTotalSize()
      The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getInput

        LSInput getInput()
        The input source that is being parsed.

      • getPosition

        int getPosition()
        The current position in the input source, including all external entities and other resources that have been read.

      • getTotalSize

        int getTotalSize()
        The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen. A value of 0 is returned if the total size cannot be determined or estimated.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSResourceResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSResourceResolver

  • public interface LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.

    Applications needing to implement custom handling for external resources can implement this interface and register their implementation by setting the "resource-resolver" parameter of DOMConfiguration objects attached to LSParser and LSSerializer. It can also be register on DOMConfiguration objects attached to Document if the "LS" feature is supported.

    The LSParser will then allow the application to intercept any external entities, including the external DTD subset and external parameter entities, before including them. The top-level document entity is never passed to the resolveResource method.

    Many DOM applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialized input sources, or for applications that use URNs.

    Note: LSResourceResolver is based on the SAX2 [SAX] EntityResolver interface.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
      Allow the application to resolve external resources.

    • Method Detail

      • resolveResource

        LSInput resolveResource(String type,
                        String namespaceURI,
                        String publicId,
                        String systemId,
                        String baseURI)
        Allow the application to resolve external resources.
        The LSParser will call this method before opening any external resource, including the external DTD subset, external entities referenced within the DTD, and external entities referenced within the document element (however, the top-level document entity is not passed to this method). The application may then request that the LSParser resolve the external resource itself, that it use an alternative URI, or that it use an entirely different input source.
        Application writers can use this method to redirect external system identifiers to secure and/or local URI, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box).
        Parameters:
        type - The type of the resource being resolved. For XML [XML 1.0] resources (i.e. entities), applications must use the value "http://www.w3.org/TR/REC-xml". For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". Other types of resources are outside the scope of this specification and therefore should recommend an absolute URI in order to use this method.
        namespaceURI - The namespace of the resource being resolved, e.g. the target namespace of the XML Schema [XML Schema Part 1] when resolving XML Schema resources.
        publicId - The public identifier of the external entity being referenced, or null if no public identifier was supplied or if the resource is not an entity.
        systemId - The system identifier, a URI reference [IETF RFC 2396], of the external resource being referenced, or null if no system identifier was supplied.
        baseURI - The absolute base URI of the resource being parsed, or null if there is no base URI.
        Returns:
        A LSInput object describing the new input source, or null to request that the parser open a regular URI connection to the resource.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSSerializer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSSerializer

  • public interface LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML. The XML data is written to a string or an output stream. Any changes or fixups made during the serialization affect only the serialized data. The Document object and its children are never altered by the serialization operation.

    During serialization of XML data, namespace fixup is done as defined in [DOM Level 3 Core] , Appendix B. [DOM Level 2 Core] allows empty strings as a real namespace URI. If the namespaceURI of a Node is empty string, the serialization will treat them as null, ignoring the prefix if any.

    LSSerializer accepts any node type for serialization. For nodes of type Document or Entity, well-formed XML will be created when possible (well-formedness is guaranteed if the document or entity comes from a parse operation and is unchanged since it was created). The serialized output for these node types is either as a XML document or an External XML Entity, respectively, and is acceptable input for an XML parser. For all other types of nodes the serialized form is implementation dependent.

    Within a Document, DocumentFragment, or Entity being serialized, Nodes are processed as follows

    • Document nodes are written, including the XML declaration (unless the parameter "xml-declaration" is set to false) and a DTD subset, if one exists in the DOM. Writing a Document node serializes the entire document.
    • Entity nodes, when written directly by LSSerializer.write, outputs the entity expansion but no namespace fixup is done. The resulting output will be valid as an external entity.
    • If the parameter " entities" is set to true, EntityReference nodes are serialized as an entity reference of the form " &entityName;" in the output. Child nodes (the expansion) of the entity reference are ignored. If the parameter " entities" is set to false, only the children of the entity reference are serialized. EntityReference nodes with no children (no corresponding Entity node or the corresponding Entity nodes have no children) are always serialized.
    • CDATAsections containing content characters that cannot be represented in the specified output encoding are handled according to the " split-cdata-sections" parameter. If the parameter is set to true, CDATAsections are split, and the unrepresentable characters are serialized as numeric character references in ordinary content. The exact position and number of splits is not specified. If the parameter is set to false, unrepresentable characters in a CDATAsection are reported as "wf-invalid-character" errors if the parameter " well-formed" is set to true. The error is not recoverable - there is no mechanism for supplying alternative characters and continuing with the serialization.
    • DocumentFragment nodes are serialized by serializing the children of the document fragment in the order they appear in the document fragment.
    • All other node types (Element, Text, etc.) are serialized to their corresponding XML source form.

    Note: The serialization of a Node does not always generate a well-formed XML document, i.e. a LSParser might throw fatal errors when parsing the resulting serialization.

    Within the character data of a document (outside of markup), any characters that cannot be represented directly are replaced with character references. Occurrences of '<' and '&' are replaced by the predefined entities &lt; and &amp;. The other predefined entities (&gt;, &apos;, and &quot;) might not be used, except where needed (e.g. using &gt; in cases such as ']]>'). Any characters that cannot be represented directly in the output character encoding are serialized as numeric character references (and since character encoding standards commonly use hexadecimal representations of characters, using the hexadecimal representation when serializing character references is encouraged).

    To allow attribute values to contain both single and double quotes, the apostrophe or single-quote character (') may be represented as "&apos;", and the double-quote character (") as "&quot;". New line characters and other characters that cannot be represented directly in attribute values in the output character encoding are serialized as a numeric character reference.

    Within markup, but outside of attributes, any occurrence of a character that cannot be represented in the output character encoding is reported as a DOMError fatal error. An example would be serializing the element <LaCañada/> with encoding="us-ascii". This will result with a generation of a DOMError "wf-invalid-character-in-node-name" (as proposed in " well-formed").

    When requested by setting the parameter " normalize-characters" on LSSerializer to true, character normalization is performed according to the definition of fully normalized characters included in appendix E of [XML 1.1] on all data to be serialized, both markup and character data. The character normalization process affects only the data as it is being written; it does not alter the DOM's view of the document after serialization has completed.

    Implementations are required to support the encodings "UTF-8", "UTF-16", "UTF-16BE", and "UTF-16LE" to guarantee that data is serializable in all encodings that are required to be supported by all XML parsers. When the encoding is UTF-8, whether or not a byte order mark is serialized, or if the output is big-endian or little-endian, is implementation dependent. When the encoding is UTF-16, whether or not the output is big-endian or little-endian is implementation dependent, but a Byte Order Mark must be generated for non-character outputs, such as LSOutput.byteStream or LSOutput.systemId. If the Byte Order Mark is not generated, a "byte-order-mark-needed" warning is reported. When the encoding is UTF-16LE or UTF-16BE, the output is big-endian (UTF-16BE) or little-endian (UTF-16LE) and the Byte Order Mark is not be generated. In all cases, the encoding declaration, if generated, will correspond to the encoding used during the serialization (e.g. encoding="UTF-16" will appear if UTF-16 was requested).

    Namespaces are fixed up during serialization, the serialization process will verify that namespace declarations, namespace prefixes and the namespace URI associated with elements and attributes are consistent. If inconsistencies are found, the serialized form of the document will be altered to remove them. The method used for doing the namespace fixup while serializing a document is the algorithm defined in Appendix B.1, "Namespace normalization", of [DOM Level 3 Core] .

    While serializing a document, the parameter "discard-default-content" controls whether or not non-specified data is serialized.

    While serializing, errors and warnings are reported to the application through the error handler (LSSerializer.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors and warnings that can occur while serializing a DOM node, but some common error and warning cases are defined. The types ( DOMError.type) of errors and warnings defined by this specification are:

    "no-output-specified" [fatal]
    Raised when writing to a LSOutput if no output is specified in the LSOutput.
    "unbound-prefix-in-entity-reference" [fatal]
    Raised if the configuration parameter " namespaces" is set to true and an entity whose replacement text contains unbound namespace prefixes is referenced in a location where there are no bindings for the namespace prefixes.
    "unsupported-encoding" [fatal]
    Raised if an unsupported encoding is encountered.

    In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...) and so on.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DOMConfiguration getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
      LSSerializerFilter getFilter()
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      String getNewLine()
      The end-of-line sequence of characters to be used in the XML being written out.
      void setFilter(LSSerializerFilter filter)
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      void setNewLine(String newLine)
      The end-of-line sequence of characters to be used in the XML being written out.
      boolean write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.

    • Method Detail

      • getDomConfig

        DOMConfiguration getDomConfig()
        The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
        In addition to the parameters recognized by the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSSerializer adds, or modifies, the following parameters:
        "canonical-form"
        true
        [optional] Writes the document according to the rules specified in [Canonical XML]. In addition to the behavior described in " canonical-form" [DOM Level 3 Core] , setting this parameter to true will set the parameters "format-pretty-print", "discard-default-content", and "xml-declaration ", to false. Setting one of those parameters to true will set this parameter to false. Serializing an XML 1.1 document when "canonical-form" is true will generate a fatal error.
        false
        [required] (default) Do not canonicalize the output.
        "discard-default-content"
        true
        [required] (default) Use the Attr.specified attribute to decide what attributes should be discarded. Note that some implementations might use whatever information available to the implementation (i.e. XML schema, DTD, the Attr.specified attribute, and so on) to determine what attributes and content to discard if this parameter is set to true.
        false
        [required]Keep all attributes and all content.
        "format-pretty-print"
        true
        [optional] Formatting the output by adding whitespace to produce a pretty-printed, indented, human-readable form. The exact form of the transformations is not specified by this specification. Pretty-printing changes the content of the document and may affect the validity of the document, validating implementations should preserve validity.
        false
        [required] (default) Don't pretty-print the result.
        "ignore-unknown-character-denormalizations"
        true
        [required] (default) If, while verifying full normalization when [XML 1.1] is supported, a character is encountered for which the normalization properties cannot be determined, then raise a "unknown-character-denormalization" warning (instead of raising an error, if this parameter is not set) and ignore any possible denormalizations caused by these characters.
        false
        [optional] Report a fatal error if a character is encountered for which the processor cannot determine the normalization properties.
        "normalize-characters"
        This parameter is equivalent to the one defined by DOMConfiguration in [DOM Level 3 Core] . Unlike in the Core, the default value for this parameter is true. While DOM implementations are not required to support fully normalizing the characters in the document according to appendix E of [XML 1.1], this parameter must be activated by default if supported.
        "xml-declaration"
        true
        [required] (default) If a Document, Element, or Entity node is serialized, the XML declaration, or text declaration, should be included. The version (Document.xmlVersion if the document is a Level 3 document and the version is non-null, otherwise use the value "1.0"), and the output encoding (see LSSerializer.write for details on how to find the output encoding) are specified in the serialized XML declaration.
        false
        [required] Do not serialize the XML and text declarations. Report a "xml-declaration-needed" warning if this will cause problems (i.e. the serialized data is of an XML version other than [XML 1.0], or an encoding would be needed to be able to re-parse the serialized data).

      • getNewLine

        String getNewLine()
        The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
        On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

      • setNewLine

        void setNewLine(String newLine)
        The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
        On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

      • getFilter

        LSSerializerFilter getFilter()
        When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

      • setFilter

        void setFilter(LSSerializerFilter filter)
        When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

      • write

        boolean write(Node nodeArg,
              LSOutput destination)
       throws LSException
        Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to the supplied LSOutput.
        When writing to a LSOutput, the encoding is found by looking at the encoding information that is reachable through the LSOutput and the item to be written (or its owner document) in this order:
        1. LSOutput.encoding,
        2. Document.inputEncoding,
        3. Document.xmlEncoding.

        If no encoding is reachable through the above properties, a default encoding of "UTF-8" will be used. If the specified encoding is not supported an "unsupported-encoding" fatal error is raised.
        If no output is specified in the LSOutput, a "no-output-specified" fatal error is raised.
        The implementation is responsible of associating the appropriate media type with the serialized data.
        When writing to a HTTP URI, a HTTP PUT is performed. When writing to other types of URIs, the mechanism for writing the data to the URI is implementation dependent.
        Parameters:
        nodeArg - The node to serialize.
        destination - The destination for the serialized DOM.
        Returns:
        Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
        Throws:
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • writeToURI

        boolean writeToURI(Node nodeArg,
                   String uri)
            throws LSException
        A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
        Parameters:
        nodeArg - The node to serialize.
        uri - The URI to write to.
        Returns:
        Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
        Throws:
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • writeToString

        String writeToString(Node nodeArg)
              throws DOMException,
                     LSException
        Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to a DOMString that is returned to the caller. The encoding used is the encoding of the DOMString type, i.e. UTF-16. Note that no Byte Order Mark is generated in a DOMString object.
        Parameters:
        nodeArg - The node to serialize.
        Returns:
        Returns the serialized data.
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised if the resulting string is too long to fit in a DOMString.
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LSSerializerFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSSerializerFilter

  • All Superinterfaces:
    org.w3c.dom.traversal.NodeFilter

    public interface LSSerializerFilter
extends org.w3c.dom.traversal.NodeFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not. The LSSerializerFilter interface is based on the NodeFilter interface defined in [DOM Level 2 Traversal and Range] .

    Document, DocumentType, DocumentFragment, Notation, Entity , and children of Attr nodes are not passed to the filter. The child nodes of an EntityReference node are only passed to the filter if the EntityReference node is skipped by the method LSParserFilter.acceptNode().

    When serializing an Element, the element is passed to the filter before any of its attributes are passed to the filter. Namespace declaration attributes, and default attributes (except in the case when " discard-default-content" is set to false), are never passed to the filter.

    The result of any attempt to modify a node passed to a LSSerializerFilter is implementation dependent.

    DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

    For efficiency, a node passed to the filter may not be the same as the one that is actually in the tree. And the actual node (node object identity) may be reused during the process of filtering and serializing a document.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.traversal.NodeFilter

        FILTER_ACCEPT, FILTER_REJECT, FILTER_SKIP, SHOW_ALL, SHOW_ATTRIBUTE, SHOW_CDATA_SECTION, SHOW_COMMENT, SHOW_DOCUMENT, SHOW_DOCUMENT_FRAGMENT, SHOW_DOCUMENT_TYPE, SHOW_ELEMENT, SHOW_ENTITY, SHOW_ENTITY_REFERENCE, SHOW_NOTATION, SHOW_PROCESSING_INSTRUCTION, SHOW_TEXT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getWhatToShow()
      Tells the LSSerializer what types of nodes to show to the filter.

      • Methods inherited from interface org.w3c.dom.traversal.NodeFilter

        acceptNode

    • Method Detail

      • getWhatToShow

        int getWhatToShow()
        Tells the LSSerializer what types of nodes to show to the filter. If a node is not shown to the filter using this attribute, it is automatically serialized. See NodeFilter for definition of the constants. The constants SHOW_DOCUMENT , SHOW_DOCUMENT_TYPE, SHOW_DOCUMENT_FRAGMENT , SHOW_NOTATION, and SHOW_ENTITY are meaningless here, such nodes will never be passed to a LSSerializerFilter.
        Unlike [DOM Level 2 Traversal and Range] , the SHOW_ATTRIBUTE constant indicates that the Attr nodes are shown and passed to the filter.
        The constants used here are defined in [DOM Level 2 Traversal and Range] .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.ls (Java Platform SE 8 )

org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException


org.w3c.dom.ls (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.ls

  • Interface Summary
    Interface Description
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.ls Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.ls

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException

Interface Hierarchy

  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.w3c.dom.ls (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.ls

  • Packages that use org.w3c.dom.ls
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.w3c.dom.ls
  • Classes in org.w3c.dom.ls used by javax.xml.validation
    Class and Description
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
  • Classes in org.w3c.dom.ls used by org.w3c.dom.ls
    Class and Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
    LSInput
    This interface represents an input source for data.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.DOMImplementationLS (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.DOMImplementationLS

No usage of org.w3c.dom.ls.DOMImplementationLS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.w3c.dom.ls.LSException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.ls.LSException

  • Packages that use LSException
    Package Description
    org.w3c.dom.ls

    • Uses of LSException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw LSException
      Modifier and Type Method and Description
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean LSSerializer.writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSInput (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSInput

  • Packages that use LSInput
    Package Description
    org.w3c.dom.ls

    • Uses of LSInput in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSInput
      Modifier and Type Method and Description
      LSInput DOMImplementationLS.createLSInput()
      Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
      LSInput LSProgressEvent.getInput()
      The input source that is being parsed.
      LSInput LSLoadEvent.getInput()
      The input source that was parsed.
      LSInput LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
      Allow the application to resolve external resources.
      Methods in org.w3c.dom.ls with parameters of type LSInput
      Modifier and Type Method and Description
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSLoadEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSLoadEvent

No usage of org.w3c.dom.ls.LSLoadEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSOutput (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSOutput

  • Packages that use LSOutput
    Package Description
    org.w3c.dom.ls

    • Uses of LSOutput in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSOutput
      Modifier and Type Method and Description
      LSOutput DOMImplementationLS.createLSOutput()
      Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
      Methods in org.w3c.dom.ls with parameters of type LSOutput
      Modifier and Type Method and Description
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSParser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSParser

  • Packages that use LSParser
    Package Description
    org.w3c.dom.ls

    • Uses of LSParser in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSParser
      Modifier and Type Method and Description
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSParserFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSParserFilter

  • Packages that use LSParserFilter
    Package Description
    org.w3c.dom.ls

    • Uses of LSParserFilter in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSParserFilter
      Modifier and Type Method and Description
      LSParserFilter LSParser.getFilter()
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
      Methods in org.w3c.dom.ls with parameters of type LSParserFilter
      Modifier and Type Method and Description
      void LSParser.setFilter(LSParserFilter filter)
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSProgressEvent (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSProgressEvent

No usage of org.w3c.dom.ls.LSProgressEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSResourceResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSResourceResolver

  • Packages that use LSResourceResolver
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of LSResourceResolver in javax.xml.validation

      Methods in javax.xml.validation that return LSResourceResolver
      Modifier and Type Method and Description
      abstract LSResourceResolver SchemaFactory.getResourceResolver()
      Gets the current LSResourceResolver set to this SchemaFactory.
      abstract LSResourceResolver ValidatorHandler.getResourceResolver()
      Gets the current LSResourceResolver set to this ValidatorHandler.
      abstract LSResourceResolver Validator.getResourceResolver()
      Gets the current LSResourceResolver set to this Validator.
      Methods in javax.xml.validation with parameters of type LSResourceResolver
      Modifier and Type Method and Description
      abstract void SchemaFactory.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution when parsing schemas.
      abstract void ValidatorHandler.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      abstract void Validator.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSSerializer (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSSerializer

  • Packages that use LSSerializer
    Package Description
    org.w3c.dom.ls

    • Uses of LSSerializer in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSSerializer
      Modifier and Type Method and Description
      LSSerializer DOMImplementationLS.createLSSerializer()
      Create a new LSSerializer object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.ls.LSSerializerFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSSerializerFilter

  • Packages that use LSSerializerFilter
    Package Description
    org.w3c.dom.ls

    • Uses of LSSerializerFilter in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSSerializerFilter
      Modifier and Type Method and Description
      LSSerializerFilter LSSerializer.getFilter()
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      Methods in org.w3c.dom.ls with parameters of type LSSerializerFilter
      Modifier and Type Method and Description
      void LSSerializer.setFilter(LSSerializerFilter filter)
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AbstractView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.views

Interface AbstractView

  • public interface AbstractView
    A base interface that all views shall derive from.

    See also the Document Object Model (DOM) Level 2 Views Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DocumentView getDocument()
      The source DocumentView of which this is an AbstractView.

    • Method Detail

      • getDocument

        DocumentView getDocument()
        The source DocumentView of which this is an AbstractView.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.w3c.dom.views (Java Platform SE 8 )

compact2 - org.w3c.dom.views

Interfaces

  • AbstractView
  • DocumentView


org.w3c.dom.views (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.w3c.dom.views (Java Platform SE 8 )

compact3 - org.w3c.dom.views

Interfaces

  • AbstractView
  • DocumentView


org.w3c.dom.views (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.views

Interface DocumentView

  • public interface DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views. It provides an attribute to retrieve the default view of a document.

    See also the Document Object Model (DOM) Level 2 Views Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      AbstractView getDefaultView()
      The default AbstractView for this Document, or null if none available.

    • Method Detail

      • getDefaultView

        AbstractView getDefaultView()
        The default AbstractView for this Document, or null if none available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.views (Java Platform SE 8 )

org.w3c.dom.views

Interfaces

  • AbstractView
  • DocumentView


org.w3c.dom.views (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.w3c.dom.views Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.views

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • org.w3c.dom.views.AbstractView
  • org.w3c.dom.views.DocumentView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.w3c.dom.views (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.views

  • Packages that use org.w3c.dom.views
    Package Description
    org.w3c.dom.events
    org.w3c.dom.views
  • Classes in org.w3c.dom.views used by org.w3c.dom.events
    Class and Description
    AbstractView
    A base interface that all views shall derive from.
  • Classes in org.w3c.dom.views used by org.w3c.dom.views
    Class and Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.views.AbstractView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.views.AbstractView

  • Packages that use AbstractView
    Package Description
    org.w3c.dom.events
    org.w3c.dom.views

    • Uses of AbstractView in org.w3c.dom.events

      Methods in org.w3c.dom.events that return AbstractView
      Modifier and Type Method and Description
      AbstractView UIEvent.getView()
      The view attribute identifies the AbstractView from which the event was generated.
      Methods in org.w3c.dom.events with parameters of type AbstractView
      Modifier and Type Method and Description
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
      void UIEvent.initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg)
      The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.

    • Uses of AbstractView in org.w3c.dom.views

      Methods in org.w3c.dom.views that return AbstractView
      Modifier and Type Method and Description
      AbstractView DocumentView.getDefaultView()
      The default AbstractView for this Document, or null if none available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.views.DocumentView (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.views.DocumentView

  • Packages that use DocumentView
    Package Description
    org.w3c.dom.views

    • Uses of DocumentView in org.w3c.dom.views

      Methods in org.w3c.dom.views that return DocumentView
      Modifier and Type Method and Description
      DocumentView AbstractView.getDocument()
      The source DocumentView of which this is an AbstractView.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttributeList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface AttributeList

  • All Known Implementing Classes:
    AttributeListImpl
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.

    public interface AttributeList
    Interface for an element's attribute specifications.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is the original SAX1 interface for reporting an element's attributes. Unlike the new Attributes interface, it does not support Namespace-related information.

    When an attribute list is supplied as part of a startElement event, the list will return valid results only during the scope of the event; once the event handler returns control to the parser, the attribute list is invalid. To save a persistent copy of the attribute list, use the SAX1 AttributeListImpl helper class.

    An attribute list includes only attributes that have been specified or defaulted: #IMPLIED attributes will not be included.

    There are two ways for the SAX application to obtain information from the AttributeList. First, it can iterate through the entire list:

     public void startElement (String name, AttributeList atts) {
   for (int i = 0; i < atts.getLength(); i++) {
     String name = atts.getName(i);
     String type = atts.getType(i);
     String value = atts.getValue(i);
     [...]
   }
 }

    (Note that the result of getLength() will be zero if there are no attributes.)

    As an alternative, the application can request the value or type of specific attributes:

     public void startElement (String name, AttributeList atts) {
   String identifier = atts.getValue("id");
   String label = atts.getValue("label");
   [...]
 }
    Since:
    SAX 1.0
    See Also:
    startElement, AttributeListImpl

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      int getLength()
      Deprecated.
      Return the number of attributes in this list.
      String getName(int i)
      Deprecated.
      Return the name of an attribute in this list (by position).
      String getType(int i)
      Deprecated.
      Return the type of an attribute in the list (by position).
      String getType(String name)
      Deprecated.
      Return the type of an attribute in the list (by name).
      String getValue(int i)
      Deprecated.
      Return the value of an attribute in the list (by position).
      String getValue(String name)
      Deprecated.
      Return the value of an attribute in the list (by name).

    • Method Detail

      • getLength

        int getLength()
        Deprecated.
        Return the number of attributes in this list.

        The SAX parser may provide attributes in any arbitrary order, regardless of the order in which they were declared or specified. The number of attributes may be zero.

        Returns:
        The number of attributes in the list.

      • getName

        String getName(int i)
        Deprecated.
        Return the name of an attribute in this list (by position).

        The names must be unique: the SAX parser shall not include the same attribute twice. Attributes without values (those declared #IMPLIED without a value specified in the start tag) will be omitted from the list.

        If the attribute name has a namespace prefix, the prefix will still be attached.

        Parameters:
        i - The index of the attribute in the list (starting at 0).
        Returns:
        The name of the indexed attribute, or null if the index is out of range.
        See Also:
        getLength()

      • getType

        String getType(int i)
        Deprecated.
        Return the type of an attribute in the list (by position).

        The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

        If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommentation (clause 3.3.3, "Attribute-Value Normalization").

        For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

        Parameters:
        i - The index of the attribute in the list (starting at 0).
        Returns:
        The attribute type as a string, or null if the index is out of range.
        See Also:
        getLength(), getType(java.lang.String)

      • getValue

        String getValue(int i)
        Deprecated.
        Return the value of an attribute in the list (by position).

        If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string separated by whitespace.

        Parameters:
        i - The index of the attribute in the list (starting at 0).
        Returns:
        The attribute value as a string, or null if the index is out of range.
        See Also:
        getLength(), getValue(java.lang.String)

      • getType

        String getType(String name)
        Deprecated.
        Return the type of an attribute in the list (by name).

        The return value is the same as the return value for getType(int).

        If the attribute name has a namespace prefix in the document, the application must include the prefix here.

        Parameters:
        name - The name of the attribute.
        Returns:
        The attribute type as a string, or null if no such attribute exists.
        See Also:
        getType(int)

      • getValue

        String getValue(String name)
        Deprecated.
        Return the value of an attribute in the list (by name).

        The return value is the same as the return value for getValue(int).

        If the attribute name has a namespace prefix in the document, the application must include the prefix here.

        Parameters:
        name - the name of the attribute to return
        Returns:
        The attribute value as a string, or null if no such attribute exists.
        See Also:
        getValue(int)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Attributes (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface Attributes

  • All Known Subinterfaces:
    Attributes2
    All Known Implementing Classes:
    Attributes2Impl, AttributesImpl

    public interface Attributes
    Interface for a list of XML attributes.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This interface allows access to a list of attributes in three different ways:

    1. by attribute index;
    2. by Namespace-qualified name; or
    3. by qualified (prefixed) name.

    The list will not contain attributes that were declared #IMPLIED but not specified in the start tag. It will also not contain attributes used as Namespace declarations (xmlns*) unless the http://xml.org/sax/features/namespace-prefixes feature is set to true (it is false by default). Because SAX2 conforms to the original "Namespaces in XML" recommendation, it normally does not give namespace declaration attributes a namespace URI.

    Some SAX2 parsers may support using an optional feature flag (http://xml.org/sax/features/xmlns-uris) to request that those attributes be given URIs, conforming to a later backwards-incompatible revision of that recommendation. (The attribute's "local name" will be the prefix, or "xmlns" when defining a default element namespace.) For portability, handler code should always resolve that conflict, rather than requiring parsers that can change the setting of that feature flag.

    If the namespace-prefixes feature (see above) is false, access by qualified name may not be available; if the http://xml.org/sax/features/namespaces feature is false, access by Namespace-qualified names may not be available.

    This interface replaces the now-deprecated SAX1 AttributeList interface, which does not contain Namespace support. In addition to Namespace support, it adds the getIndex methods (below).

    The order of attributes in the list is unspecified, and will vary from implementation to implementation.

    Since:
    SAX 2.0
    See Also:
    AttributesImpl, DeclHandler.attributeDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getIndex(String qName)
      Look up the index of an attribute by XML qualified (prefixed) name.
      int getIndex(String uri, String localName)
      Look up the index of an attribute by Namespace name.
      int getLength()
      Return the number of attributes in the list.
      String getLocalName(int index)
      Look up an attribute's local name by index.
      String getQName(int index)
      Look up an attribute's XML qualified (prefixed) name by index.
      String getType(int index)
      Look up an attribute's type by index.
      String getType(String qName)
      Look up an attribute's type by XML qualified (prefixed) name.
      String getType(String uri, String localName)
      Look up an attribute's type by Namespace name.
      String getURI(int index)
      Look up an attribute's Namespace URI by index.
      String getValue(int index)
      Look up an attribute's value by index.
      String getValue(String qName)
      Look up an attribute's value by XML qualified (prefixed) name.
      String getValue(String uri, String localName)
      Look up an attribute's value by Namespace name.

    • Method Detail

      • getLength

        int getLength()
        Return the number of attributes in the list.

        Once you know the number of attributes, you can iterate through the list.

        Returns:
        The number of attributes in the list.
        See Also:
        getURI(int), getLocalName(int), getQName(int), getType(int), getValue(int)

      • getURI

        String getURI(int index)
        Look up an attribute's Namespace URI by index.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The Namespace URI, or the empty string if none is available, or null if the index is out of range.
        See Also:
        getLength()

      • getLocalName

        String getLocalName(int index)
        Look up an attribute's local name by index.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The local name, or the empty string if Namespace processing is not being performed, or null if the index is out of range.
        See Also:
        getLength()

      • getQName

        String getQName(int index)
        Look up an attribute's XML qualified (prefixed) name by index.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The XML qualified name, or the empty string if none is available, or null if the index is out of range.
        See Also:
        getLength()

      • getType

        String getType(int index)
        Look up an attribute's type by index.

        The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

        If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommendation (clause 3.3.3, "Attribute-Value Normalization").

        For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The attribute's type as a string, or null if the index is out of range.
        See Also:
        getLength()

      • getValue

        String getValue(int index)
        Look up an attribute's value by index.

        If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string with each token separated by a single space.

        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The attribute's value as a string, or null if the index is out of range.
        See Also:
        getLength()

      • getIndex

        int getIndex(String uri,
             String localName)
        Look up the index of an attribute by Namespace name.
        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        The index of the attribute, or -1 if it does not appear in the list.

      • getIndex

        int getIndex(String qName)
        Look up the index of an attribute by XML qualified (prefixed) name.
        Parameters:
        qName - The qualified (prefixed) name.
        Returns:
        The index of the attribute, or -1 if it does not appear in the list.

      • getType

        String getType(String uri,
               String localName)
        Look up an attribute's type by Namespace name.

        See getType(int) for a description of the possible types.

        Parameters:
        uri - The Namespace URI, or the empty String if the name has no Namespace URI.
        localName - The local name of the attribute.
        Returns:
        The attribute type as a string, or null if the attribute is not in the list or if Namespace processing is not being performed.

      • getType

        String getType(String qName)
        Look up an attribute's type by XML qualified (prefixed) name.

        See getType(int) for a description of the possible types.

        Parameters:
        qName - The XML qualified name.
        Returns:
        The attribute type as a string, or null if the attribute is not in the list or if qualified names are not available.

      • getValue

        String getValue(String uri,
                String localName)
        Look up an attribute's value by Namespace name.

        See getValue(int) for a description of the possible values.

        Parameters:
        uri - The Namespace URI, or the empty String if the name has no Namespace URI.
        localName - The local name of the attribute.
        Returns:
        The attribute value as a string, or null if the attribute is not in the list.

      • getValue

        String getValue(String qName)
        Look up an attribute's value by XML qualified (prefixed) name.

        See getValue(int) for a description of the possible values.

        Parameters:
        qName - The XML qualified name.
        Returns:
        The attribute value as a string, or null if the attribute is not in the list or if qualified names are not available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.xml.sax (Java Platform SE 8 )

compact2 - org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException


org.xml.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.xml.sax

This package provides the core SAX APIs.

See: Description

  • Interface Summary
    Interface Description
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    Class Description
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception Description
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.xml.sax (Java Platform SE 8 )

compact3 - org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException


org.xml.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.xml.sax

This package provides the core SAX APIs.

See: Description

  • Interface Summary
    Interface Description
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    Class Description
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception Description
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ContentHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface ContentHandler

  • All Known Subinterfaces:
    TemplatesHandler, TransformerHandler, UnmarshallerHandler
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, ValidatorHandler, XMLFilterImpl, XMLReaderAdapter

    public interface ContentHandler
    Receive notification of the logical content of a document.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is the main interface that most SAX applications implement: if the application needs to be informed of basic parsing events, it implements this interface and registers an instance with the SAX parser using the setContentHandler method. The parser uses the instance to report basic document-related events like the start and end of elements and character data.

    The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

    This interface is similar to the now-deprecated SAX 1.0 DocumentHandler interface, but it adds support for Namespaces and for reporting skipped entities (in non-validating XML processors).

    Implementors should note that there is also a ContentHandler class in the java.net package; that means that it's probably a bad idea to do

    import java.net.*;
 import org.xml.sax.*;

    In fact, "import ...*" is usually a sign of sloppy programming anyway, so the user should consider this a feature rather than a bug.

    Since:
    SAX 2.0
    See Also:
    XMLReader, DTDHandler, ErrorHandler

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Receive notification of character data.
      void endDocument()
      Receive notification of the end of a document.
      void endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void endPrefixMapping(String prefix)
      End the scope of a prefix-URI mapping.
      void ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void setDocumentLocator(Locator locator)
      Receive an object for locating the origin of SAX document events.
      void skippedEntity(String name)
      Receive notification of a skipped entity.
      void startDocument()
      Receive notification of the beginning of a document.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.
      void startPrefixMapping(String prefix, String uri)
      Begin the scope of a prefix-URI Namespace mapping.

    • Method Detail

      • setDocumentLocator

        void setDocumentLocator(Locator locator)
        Receive an object for locating the origin of SAX document events.

        SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the ContentHandler interface.

        The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

        Note that the locator will return correct information only during the invocation SAX event callbacks after startDocument returns and before endDocument is called. The application should not attempt to use it at any other time.

        Parameters:
        locator - an object that can return the location of any SAX document event
        See Also:
        Locator

      • startDocument

        void startDocument()
            throws SAXException
        Receive notification of the beginning of a document.

        The SAX parser will invoke this method only once, before any other event callbacks (except for setDocumentLocator).

        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        endDocument()

      • endDocument

        void endDocument()
          throws SAXException
        Receive notification of the end of a document.

        There is an apparent contradiction between the documentation for this method and the documentation for ErrorHandler.fatalError(org.xml.sax.SAXParseException). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

        The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        startDocument()

      • startPrefixMapping

        void startPrefixMapping(String prefix,
                        String uri)
                 throws SAXException
        Begin the scope of a prefix-URI Namespace mapping.

        The information from this event is not necessary for normal Namespace processing: the SAX XML reader will automatically replace prefixes for element and attribute names when the http://xml.org/sax/features/namespaces feature is true (the default).

        There are cases, however, when applications need to use prefixes in character data or in attribute values, where they cannot safely be expanded automatically; the start/endPrefixMapping event supplies the information to the application to expand prefixes in those contexts itself, if necessary.

        Note that start/endPrefixMapping events are not guaranteed to be properly nested relative to each other: all startPrefixMapping events will occur immediately before the corresponding startElement event, and all endPrefixMapping events will occur immediately after the corresponding endElement event, but their order is not otherwise guaranteed.

        There should never be start/endPrefixMapping events for the "xml" prefix, since it is predeclared and immutable.

        Parameters:
        prefix - the Namespace prefix being declared. An empty string is used for the default element namespace, which has no prefix.
        uri - the Namespace URI the prefix is mapped to
        Throws:
        SAXException - the client may throw an exception during processing
        See Also:
        endPrefixMapping(java.lang.String), startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endPrefixMapping

        void endPrefixMapping(String prefix)
               throws SAXException
        End the scope of a prefix-URI mapping.

        See startPrefixMapping for details. These events will always occur immediately after the corresponding endElement event, but the order of endPrefixMapping events is not otherwise guaranteed.

        Parameters:
        prefix - the prefix that was being mapped. This is the empty string when a default mapping scope ends.
        Throws:
        SAXException - the client may throw an exception during processing
        See Also:
        startPrefixMapping(java.lang.String, java.lang.String), endElement(java.lang.String, java.lang.String, java.lang.String)

      • startElement

        void startElement(String uri,
                  String localName,
                  String qName,
                  Attributes atts)
           throws SAXException
        Receive notification of the beginning of an element.

        The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement event for every startElement event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement event.

        This event allows up to three name components for each element:

        1. the Namespace URI;
        2. the local name; and
        3. the qualified (prefixed) name.

        Any or all of these may be provided, depending on the values of the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes properties:

        • the Namespace URI and local name are required when the namespaces property is true (the default), and are optional when the namespaces property is false (if one is specified, both must be);
        • the qualified name is required when the namespace-prefixes property is true, and is optional when the namespace-prefixes property is false (the default).

        Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted. The attribute list will contain attributes used for Namespace declarations (xmlns* attributes) only if the http://xml.org/sax/features/namespace-prefixes property is true (it is false by default, and support for a true value is optional).

        Like characters(), attribute values may have characters that need more than one char value.

        Parameters:
        uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
        localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
        qName - the qualified name (with prefix), or the empty string if qualified names are not available
        atts - the attributes attached to the element. If there are no attributes, it shall be an empty Attributes object. The value of this object after startElement returns is undefined
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

      • endElement

        void endElement(String uri,
                String localName,
                String qName)
         throws SAXException
        Receive notification of the end of an element.

        The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement event for every endElement event (even when the element is empty).

        For information on the names, see startElement.

        Parameters:
        uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
        localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
        qName - the qualified XML name (with prefix), or the empty string if qualified names are not available
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception

      • characters

        void characters(char[] ch,
                int start,
                int length)
         throws SAXException
        Receive notification of character data.

        The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Individual characters may consist of more than one Java char value. There are two important cases where this happens, because characters can't be represented in just sixteen bits. In one case, characters are represented in a Surrogate Pair, using two special Unicode values. Such characters are in the so-called "Astral Planes", with a code point above U+FFFF. A second case involves composite characters, such as a base character combining with one or more accent characters.

        Your code should not assume that algorithms using char-at-a-time idioms will be working in character units; in some cases they will split characters. This is relevant wherever XML permits arbitrary characters, such as attribute values, processing instruction data, and comments as well as in data reported from this method. It's also generally relevant whenever Java code manipulates internationalized text; the issue isn't unique to XML.

        Note that some parsers will report whitespace in element content using the ignorableWhitespace method rather than this one (validating parsers must do so).

        Parameters:
        ch - the characters from the XML document
        start - the start position in the array
        length - the number of characters to read from the array
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                  throws SAXException
        Receive notification of ignorable whitespace in element content.

        Validating Parsers must use this method to report each chunk of whitespace in element content (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

        SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Parameters:
        ch - the characters from the XML document
        start - the start position in the array
        length - the number of characters to read from the array
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        characters(char[], int, int)

      • processingInstruction

        void processingInstruction(String target,
                           String data)
                    throws SAXException
        Receive notification of a processing instruction.

        The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

        A SAX parser must never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

        Like characters(), processing instruction data may have characters that need more than one char value.

        Parameters:
        target - the processing instruction target
        data - the processing instruction data, or null if none was supplied. The data does not include any whitespace separating it from the target
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception

      • skippedEntity

        void skippedEntity(String name)
            throws SAXException
        Receive notification of a skipped entity. This is not called for entity references within markup constructs such as element start tags or markup declarations. (The XML recommendation requires reporting skipped external entities. SAX also reports internal entity expansion/non-expansion, except within markup constructs.)

        The Parser will invoke this method each time the entity is skipped. Non-validating processors may skip entities if they have not seen the declarations (because, for example, the entity was declared in an external DTD subset). All processors may skip external entities, depending on the values of the http://xml.org/sax/features/external-general-entities and the http://xml.org/sax/features/external-parameter-entities properties.

        Parameters:
        name - the name of the skipped entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be the string "[dtd]"
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DocumentHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface DocumentHandler

  • All Known Implementing Classes:
    HandlerBase, ParserAdapter
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.

    public interface DocumentHandler
    Receive notification of general document events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This was the main event-handling interface for SAX1; in SAX2, it has been replaced by ContentHandler, which provides Namespace support and reporting of skipped entities. This interface is included in SAX2 only to support legacy SAX1 applications.

    The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

    Application writers who do not want to implement the entire interface can derive a class from HandlerBase, which implements the default functionality; parser writers can instantiate HandlerBase to obtain a default handler. The application can find the location of any document event using the Locator interface supplied by the Parser through the setDocumentLocator method.

    Since:
    SAX 1.0
    See Also:
    Parser.setDocumentHandler(org.xml.sax.DocumentHandler), Locator, HandlerBase

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data.
      void endDocument()
      Deprecated.
      Receive notification of the end of a document.
      void endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void setDocumentLocator(Locator locator)
      Deprecated.
      Receive an object for locating the origin of SAX document events.
      void startDocument()
      Deprecated.
      Receive notification of the beginning of a document.
      void startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.

    • Method Detail

      • setDocumentLocator

        void setDocumentLocator(Locator locator)
        Deprecated.
        Receive an object for locating the origin of SAX document events.

        SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the DocumentHandler interface.

        The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

        Note that the locator will return correct information only during the invocation of the events in this interface. The application should not attempt to use it at any other time.

        Parameters:
        locator - An object that can return the location of any SAX document event.
        See Also:
        Locator

      • startDocument

        void startDocument()
            throws SAXException
        Deprecated.
        Receive notification of the beginning of a document.

        The SAX parser will invoke this method only once, before any other methods in this interface or in DTDHandler (except for setDocumentLocator).

        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.

      • endDocument

        void endDocument()
          throws SAXException
        Deprecated.
        Receive notification of the end of a document.

        The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.

      • startElement

        void startElement(String name,
                  AttributeList atts)
           throws SAXException
        Deprecated.
        Receive notification of the beginning of an element.

        The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement() event for every startElement() event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement() event.

        If the element name has a namespace prefix, the prefix will still be attached. Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted.

        Parameters:
        name - The element type name.
        atts - The attributes attached to the element, if any.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        endElement(java.lang.String), AttributeList

      • endElement

        void endElement(String name)
         throws SAXException
        Deprecated.
        Receive notification of the end of an element.

        The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement() event for every endElement() event (even when the element is empty).

        If the element name has a namespace prefix, the prefix will still be attached to the name.

        Parameters:
        name - The element type name
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.

      • characters

        void characters(char[] ch,
                int start,
                int length)
         throws SAXException
        Deprecated.
        Receive notification of character data.

        The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Note that some parsers will report whitespace using the ignorableWhitespace() method rather than this one (validating parsers must do so).

        Parameters:
        ch - The characters from the XML document.
        start - The start position in the array.
        length - The number of characters to read from the array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                  throws SAXException
        Deprecated.
        Receive notification of ignorable whitespace in element content.

        Validating Parsers must use this method to report each chunk of ignorable whitespace (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

        SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Parameters:
        ch - The characters from the XML document.
        start - The start position in the array.
        length - The number of characters to read from the array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        characters(char[], int, int)

      • processingInstruction

        void processingInstruction(String target,
                           String data)
                    throws SAXException
        Deprecated.
        Receive notification of a processing instruction.

        The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

        A SAX parser should never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

        Parameters:
        target - The processing instruction target.
        data - The processing instruction data, or null if none was supplied.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DTDHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface DTDHandler

  • All Known Subinterfaces:
    TransformerHandler
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface DTDHandler
    Receive notification of basic DTD-related events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs information about notations and unparsed entities, then the application implements this interface and registers an instance with the SAX parser using the parser's setDTDHandler method. The parser uses the instance to report notation and unparsed entity declarations to the application.

    Note that this interface includes only those DTD events that the XML recommendation requires processors to report: notation and unparsed entity declarations.

    The SAX parser may report these events in any order, regardless of the order in which the notations and unparsed entities were declared; however, all DTD events must be reported after the document handler's startDocument event, and before the first startElement event. (If the LexicalHandler is used, these events must also be reported before the endDTD event.)

    It is up to the application to store the information for future use (perhaps in a hash table or object tree). If the application encounters attributes of type "NOTATION", "ENTITY", or "ENTITIES", it can use the information that it obtained through this interface to find the entity and/or notation corresponding with the attribute value.

    Since:
    SAX 1.0
    See Also:
    XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration event.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration event.

    • Method Detail

      • notationDecl

        void notationDecl(String name,
                  String publicId,
                  String systemId)
           throws SAXException
        Receive notification of a notation declaration event.

        It is up to the application to record the notation for later reference, if necessary; notations may appear as attribute values and in unparsed entity declarations, and are sometime used with processing instruction target names.

        At least one of publicId and systemId must be non-null. If a system identifier is present, and it is a URL, the SAX parser must resolve it fully before passing it to the application through this event.

        There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.

        Parameters:
        name - The notation name.
        publicId - The notation's public identifier, or null if none was given.
        systemId - The notation's system identifier, or null if none was given.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

      • unparsedEntityDecl

        void unparsedEntityDecl(String name,
                        String publicId,
                        String systemId,
                        String notationName)
                 throws SAXException
        Receive notification of an unparsed entity declaration event.

        Note that the notation name corresponds to a notation reported by the notationDecl event. It is up to the application to record the entity for later reference, if necessary; unparsed entities may appear as attribute values.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Parameters:
        name - The unparsed entity's name.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        notationName - The name of the associated notation.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EntityResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface EntityResolver

  • All Known Subinterfaces:
    EntityResolver2
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface EntityResolver
    Basic interface for resolving entities.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs to implement customized handling for external entities, it must implement this interface and register an instance with the SAX driver using the setEntityResolver method.

    The XML reader will then allow the application to intercept any external entities (including the external DTD subset and external parameter entities, if any) before including them.

    Many SAX applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialised input sources, or for applications that use URI types other than URLs.

    The following resolver would provide the application with a special character stream for the entity with the system identifier "http://www.myhost.com/today":

     import org.xml.sax.EntityResolver;
 import org.xml.sax.InputSource;

 public class MyResolver implements EntityResolver {
   public InputSource resolveEntity (String publicId, String systemId)
   {
     if (systemId.equals("http://www.myhost.com/today")) {
              // return a special input source
       MyReader reader = new MyReader();
       return new InputSource(reader);
     } else {
              // use the default behaviour
       return null;
     }
   }
 }

    The application can also use this interface to redirect system identifiers to local URIs or to look up replacements in a catalog (possibly by using the public identifier).

    Since:
    SAX 1.0
    See Also:
    XMLReader.setEntityResolver(org.xml.sax.EntityResolver), InputSource

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      InputSource resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.

    • Method Detail

      • resolveEntity

        InputSource resolveEntity(String publicId,
                          String systemId)
                   throws SAXException,
                          IOException
        Allow the application to resolve external entities.

        The parser will call this method before opening any external entity except the top-level document entity. Such entities include the external DTD subset and external parameter entities referenced within the DTD (in either case, only if the parser reads external parameter entities), and external general entities referenced within the document element (if the parser reads external general entities). The application may request that the parser locate the entity itself, that it use an alternative URI, or that it use data provided by the application (as a character or byte input stream).

        Application writers can use this method to redirect external system identifiers to secure and/or local URIs, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box). Neither XML nor SAX specifies a preferred policy for using public or system IDs to resolve resources. However, SAX specifies how to interpret any InputSource returned by this method, and that if none is returned, then the system ID will be dereferenced as a URL.

        If the system identifier is a URL, the SAX parser must resolve it fully before reporting it to the application.

        Parameters:
        publicId - The public identifier of the external entity being referenced, or null if none was supplied.
        systemId - The system identifier of the external entity being referenced.
        Returns:
        An InputSource object describing the new input source, or null to request that the parser open a regular URI connection to the system identifier.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
        See Also:
        InputSource
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ErrorHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface ErrorHandler

  • All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface ErrorHandler
    Basic interface for SAX error handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs to implement customized error handling, it must implement this interface and then register an instance with the XML reader using the setErrorHandler method. The parser will then report all errors and warnings through this interface.

    WARNING: If an application does not register an ErrorHandler, XML parsing errors will go unreported, except that SAXParseExceptions will be thrown for fatal errors. In order to detect validity errors, an ErrorHandler that does something with error() calls must be registered.

    For XML processing errors, a SAX driver must use this interface in preference to throwing an exception: it is up to the application to decide whether to throw an exception for different types of errors and warnings. Note, however, that there is no requirement that the parser continue to report additional errors after a call to fatalError. In other words, a SAX driver class may throw an exception after reporting any fatalError. Also parsers may throw appropriate exceptions for non-XML errors. For example, XMLReader.parse() would throw an IOException for errors accessing entities or the document.

    Since:
    SAX 1.0
    See Also:
    XMLReader.setErrorHandler(org.xml.sax.ErrorHandler), SAXParseException

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void error(SAXParseException exception)
      Receive notification of a recoverable error.
      void fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void warning(SAXParseException exception)
      Receive notification of a warning.

    • Method Detail

      • warning

        void warning(SAXParseException exception)
      throws SAXException
        Receive notification of a warning.

        SAX parsers will use this method to report conditions that are not errors or fatal errors as defined by the XML recommendation. The default behaviour is to take no action.

        The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end.

        Filters may use this method to report other, non-XML warnings as well.

        Parameters:
        exception - The warning information encapsulated in a SAX parse exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        SAXParseException

      • error

        void error(SAXParseException exception)
    throws SAXException
        Receive notification of a recoverable error.

        This corresponds to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a validating parser would use this callback to report the violation of a validity constraint. The default behaviour is to take no action.

        The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end. If the application cannot do so, then the parser should report a fatal error even if the XML recommendation does not require it to do so.

        Filters may use this method to report other, non-XML errors as well.

        Parameters:
        exception - The error information encapsulated in a SAX parse exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        SAXParseException

      • fatalError

        void fatalError(SAXParseException exception)
         throws SAXException
        Receive notification of a non-recoverable error.

        There is an apparent contradiction between the documentation for this method and the documentation for ContentHandler.endDocument(). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

        This corresponds to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a parser would use this callback to report the violation of a well-formedness constraint.

        The application must assume that the document is unusable after the parser has invoked this method, and should continue (if at all) only for the sake of collecting additional error messages: in fact, SAX parsers are free to stop reporting any other events once this method has been invoked.

        Parameters:
        exception - The error information encapsulated in a SAX parse exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


HandlerBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class HandlerBase

  • java.lang.Object
    • org.xml.sax.HandlerBase
  • All Implemented Interfaces:
    DocumentHandler, DTDHandler, EntityResolver, ErrorHandler
    Deprecated.
    This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.

    public class HandlerBase
extends Object
implements EntityResolver, DTDHandler, DocumentHandler, ErrorHandler
    Default base class for handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class implements the default behaviour for four SAX1 interfaces: EntityResolver, DTDHandler, DocumentHandler, and ErrorHandler. It is now obsolete, but is included in SAX2 to support legacy SAX1 applications. SAX2 applications should use the DefaultHandler class instead.

    Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

    Note that the use of this class is optional.

    Since:
    SAX 1.0
    See Also:
    EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      HandlerBase()
      Deprecated.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data inside an element.
      void endDocument()
      Deprecated.
      Receive notification of the end of the document.
      void endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void notationDecl(String name, String publicId, String systemId)
      Deprecated.
      Receive notification of a notation declaration.
      void processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      InputSource resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      void setDocumentLocator(Locator locator)
      Deprecated.
      Receive a Locator object for document events.
      void startDocument()
      Deprecated.
      Receive notification of the beginning of the document.
      void startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Deprecated.
      Receive notification of an unparsed entity declaration.
      void warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HandlerBase

        public HandlerBase()
        Deprecated.

    • Method Detail

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException
        Deprecated.
        Resolve an external entity.

        Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

        Specified by:
        resolveEntity in interface EntityResolver
        Parameters:
        publicId - The public identifer, or null if none is available.
        systemId - The system identifier provided in the XML document.
        Returns:
        The new input source, or null to require the default behaviour.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)

      • notationDecl

        public void notationDecl(String name,
                         String publicId,
                         String systemId)
        Deprecated.
        Receive notification of a notation declaration.

        By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

        Specified by:
        notationDecl in interface DTDHandler
        Parameters:
        name - The notation name.
        publicId - The notation public identifier, or null if not available.
        systemId - The notation system identifier.
        See Also:
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
        Deprecated.
        Receive notification of an unparsed entity declaration.

        By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

        Specified by:
        unparsedEntityDecl in interface DTDHandler
        Parameters:
        name - The entity name.
        publicId - The entity public identifier, or null if not available.
        systemId - The entity system identifier.
        notationName - The name of the associated notation.
        See Also:
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Deprecated.
        Receive a Locator object for document events.

        By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

        Specified by:
        setDocumentLocator in interface DocumentHandler
        Parameters:
        locator - A locator for all SAX document events.
        See Also:
        DocumentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Deprecated.
        Receive notification of the beginning of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

        Specified by:
        startDocument in interface DocumentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Deprecated.
        Receive notification of the end of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

        Specified by:
        endDocument in interface DocumentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.endDocument()

      • startElement

        public void startElement(String name,
                         AttributeList attributes)
                  throws SAXException
        Deprecated.
        Receive notification of the start of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

        Specified by:
        startElement in interface DocumentHandler
        Parameters:
        name - The element type name.
        attributes - The specified or defaulted attributes.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • endElement

        public void endElement(String name)
                throws SAXException
        Deprecated.
        Receive notification of the end of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

        Specified by:
        endElement in interface DocumentHandler
        Parameters:
        name - the element name
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.endElement(java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Deprecated.
        Receive notification of character data inside an element.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

        Specified by:
        characters in interface DocumentHandler
        Parameters:
        ch - The characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Deprecated.
        Receive notification of ignorable whitespace in element content.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

        Specified by:
        ignorableWhitespace in interface DocumentHandler
        Parameters:
        ch - The whitespace characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Deprecated.
        Receive notification of a processing instruction.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        Specified by:
        processingInstruction in interface DocumentHandler
        Parameters:
        target - The processing instruction target.
        data - The processing instruction data, or null if none is supplied.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.processingInstruction(java.lang.String, java.lang.String)

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Deprecated.
        Receive notification of a parser warning.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

        Specified by:
        warning in interface ErrorHandler
        Parameters:
        e - The warning information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Deprecated.
        Receive notification of a recoverable parser error.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

        Specified by:
        error in interface ErrorHandler
        Parameters:
        e - The warning information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Deprecated.
        Report a fatal XML parsing error.

        The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

        Specified by:
        fatalError in interface ErrorHandler
        Parameters:
        e - The error information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


InputSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class InputSource

  • java.lang.Object
    • org.xml.sax.InputSource

  • public class InputSource
extends Object
    A single input source for an XML entity.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class allows a SAX application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), and/or a character stream.

    There are two places that the application can deliver an input source to the parser: as the argument to the Parser.parse method, or as the return value of the EntityResolver.resolveEntity method.

    The SAX parser will use the InputSource object to determine how to read XML input. If there is a character stream available, the parser will read that stream directly, disregarding any text encoding declaration found in that stream. If there is no character stream, but there is a byte stream, the parser will use that byte stream, using the encoding specified in the InputSource or else (if no encoding is specified) autodetecting the character encoding using an algorithm such as the one in the XML specification. If neither a character stream nor a byte stream is available, the parser will attempt to open a URI connection to the resource identified by the system identifier.

    An InputSource object belongs to the application: the SAX parser shall never modify it in any way (it may modify a copy if necessary). However, standard processing of both byte and character streams is to close them on as part of end-of-parse cleanup, so applications should not attempt to re-use such streams after they have been handed to a parser.

    Since:
    SAX 1.0
    See Also:
    XMLReader.parse(org.xml.sax.InputSource), EntityResolver.resolveEntity(java.lang.String, java.lang.String), InputStream, Reader

    • Constructor Summary

      Constructors
      Constructor and Description
      InputSource()
      Zero-argument default constructor.
      InputSource(InputStream byteStream)
      Create a new input source with a byte stream.
      InputSource(Reader characterStream)
      Create a new input source with a character stream.
      InputSource(String systemId)
      Create a new input source with a system identifier.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      InputStream getByteStream()
      Get the byte stream for this input source.
      Reader getCharacterStream()
      Get the character stream for this input source.
      String getEncoding()
      Get the character encoding for a byte stream or URI.
      String getPublicId()
      Get the public identifier for this input source.
      String getSystemId()
      Get the system identifier for this input source.
      void setByteStream(InputStream byteStream)
      Set the byte stream for this input source.
      void setCharacterStream(Reader characterStream)
      Set the character stream for this input source.
      void setEncoding(String encoding)
      Set the character encoding, if known.
      void setPublicId(String publicId)
      Set the public identifier for this input source.
      void setSystemId(String systemId)
      Set the system identifier for this input source.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InputSource

        public InputSource()
        Zero-argument default constructor.
        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader),
setEncoding(java.lang.String)

      • InputSource

        public InputSource(String systemId)
        Create a new input source with a system identifier.

        Applications may use setPublicId to include a public identifier as well, or setEncoding to specify the character encoding, if known.

        If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

        Parameters:
        systemId - The system identifier (URI).
        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setEncoding(java.lang.String),
setCharacterStream(java.io.Reader)

      • InputSource

        public InputSource(InputStream byteStream)
        Create a new input source with a byte stream.

        Application writers should use setSystemId() to provide a base for resolving relative URIs, may use setPublicId to include a public identifier, and may use setEncoding to specify the object's character encoding.

        Parameters:
        byteStream - The raw byte stream containing the document.
        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setEncoding(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

      • InputSource

        public InputSource(Reader characterStream)
        Create a new input source with a character stream.

        Application writers should use setSystemId() to provide a base for resolving relative URIs, and may use setPublicId to include a public identifier.

        The character stream shall not include a byte order mark.

        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

    • Method Detail

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this input source.

        The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

        Parameters:
        publicId - The public identifier as a string.
        See Also:
        getPublicId(),
Locator.getPublicId(),
SAXParseException.getPublicId()

      • getPublicId

        public String getPublicId()
        Get the public identifier for this input source.
        Returns:
        The public identifier, or null if none was supplied.
        See Also:
        setPublicId(java.lang.String)

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this input source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

        If the application knows the character encoding of the object pointed to by the system identifier, it can register the encoding using the setEncoding method.

        If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

        Parameters:
        systemId - The system identifier as a string.
        See Also:
        setEncoding(java.lang.String),
getSystemId(),
Locator.getSystemId(),
SAXParseException.getSystemId()

      • getSystemId

        public String getSystemId()
        Get the system identifier for this input source.

        The getEncoding method will return the character encoding of the object pointed to, or null if unknown.

        If the system ID is a URL, it will be fully resolved.

        Returns:
        The system identifier, or null if none was supplied.
        See Also:
        setSystemId(java.lang.String), getEncoding()

      • setByteStream

        public void setByteStream(InputStream byteStream)
        Set the byte stream for this input source.

        The SAX parser will ignore this if there is also a character stream specified, but it will use a byte stream in preference to opening a URI connection itself.

        If the application knows the character encoding of the byte stream, it should set it with the setEncoding method.

        Parameters:
        byteStream - A byte stream containing an XML document or other entity.
        See Also:
        setEncoding(java.lang.String),
getByteStream(),
getEncoding(),
InputStream

      • getByteStream

        public InputStream getByteStream()
        Get the byte stream for this input source.

        The getEncoding method will return the character encoding for this byte stream, or null if unknown.

        Returns:
        The byte stream, or null if none was supplied.
        See Also:
        getEncoding(), setByteStream(java.io.InputStream)

      • setEncoding

        public void setEncoding(String encoding)
        Set the character encoding, if known.

        The encoding must be a string acceptable for an XML encoding declaration (see section 4.3.3 of the XML 1.0 recommendation).

        This method has no effect when the application provides a character stream.

        Parameters:
        encoding - A string describing the character encoding.
        See Also:
        setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
getEncoding()

      • getEncoding

        public String getEncoding()
        Get the character encoding for a byte stream or URI. This value will be ignored when the application provides a character stream.
        Returns:
        The encoding, or null if none was supplied.
        See Also:
        setByteStream(java.io.InputStream),
getSystemId(),
getByteStream()

      • setCharacterStream

        public void setCharacterStream(Reader characterStream)
        Set the character stream for this input source.

        If there is a character stream specified, the SAX parser will ignore any byte stream and will not attempt to open a URI connection to the system identifier.

        Parameters:
        characterStream - The character stream containing the XML document or other entity.
        See Also:
        getCharacterStream(), Reader

      • getCharacterStream

        public Reader getCharacterStream()
        Get the character stream for this input source.
        Returns:
        The character stream, or null if none was supplied.
        See Also:
        setCharacterStream(java.io.Reader)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Locator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface Locator

  • All Known Subinterfaces:
    Locator2
    All Known Implementing Classes:
    Locator2Impl, LocatorImpl

    public interface Locator
    Interface for associating a SAX event with a document location.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX parser provides location information to the SAX application, it does so by implementing this interface and then passing an instance to the application using the content handler's setDocumentLocator method. The application can use the object to obtain the location of any other SAX event in the XML source document.

    Note that the results returned by the object will be valid only during the scope of each callback method: the application will receive unpredictable results if it attempts to use the locator at any other time, or after parsing completes.

    SAX parsers are not required to supply a locator, but they are very strongly encouraged to do so. If the parser supplies a locator, it must do so before reporting any other document events. If no locator has been set by the time the application receives the startDocument event, the application should assume that a locator is not available.

    Since:
    SAX 1.0
    See Also:
    ContentHandler.setDocumentLocator(org.xml.sax.Locator)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the column number where the current document event ends.
      int getLineNumber()
      Return the line number where the current document event ends.
      String getPublicId()
      Return the public identifier for the current document event.
      String getSystemId()
      Return the system identifier for the current document event.

    • Method Detail

      • getPublicId

        String getPublicId()
        Return the public identifier for the current document event.

        The return value is the public identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

        Returns:
        A string containing the public identifier, or null if none is available.
        See Also:
        getSystemId()

      • getSystemId

        String getSystemId()
        Return the system identifier for the current document event.

        The return value is the system identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application. For example, a file name must always be provided as a file:... URL, and other kinds of relative URI are also resolved against their bases.

        Returns:
        A string containing the system identifier, or null if none is available.
        See Also:
        getPublicId()

      • getLineNumber

        int getLineNumber()
        Return the line number where the current document event ends. Lines are delimited by line ends, which are defined in the XML specification.

        Warning: The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. In some cases, these "line" numbers match what would be displayed as columns, and in others they may not match the source text due to internal entity expansion.

        The return value is an approximation of the line number in the document entity or external parsed entity where the markup triggering the event appears.

        If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first line is line 1.

        Returns:
        The line number, or -1 if none is available.
        See Also:
        getColumnNumber()

      • getColumnNumber

        int getColumnNumber()
        Return the column number where the current document event ends. This is one-based number of Java char values since the last line end.

        Warning: The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. For example, when lines contain combining character sequences, wide characters, surrogate pairs, or bi-directional text, the value may not correspond to the column in a text editor's display.

        The return value is an approximation of the column number in the document entity or external parsed entity where the markup triggering the event appears.

        If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first column in each line is column 1.

        Returns:
        The column number, or -1 if none is available.
        See Also:
        getLineNumber()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.xml.sax (Java Platform SE 8 )

org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException


org.xml.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.xml.sax

This package provides the core SAX APIs.

See: Description

  • Interface Summary
    Interface Description
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    Class Description
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception Description
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.xml.sax Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.xml.sax

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.InputSource
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException

Interface Hierarchy

  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
  • org.xml.sax.ContentHandler
  • org.xml.sax.DocumentHandler
  • org.xml.sax.DTDHandler
  • org.xml.sax.EntityResolver
  • org.xml.sax.ErrorHandler
  • org.xml.sax.Locator
  • org.xml.sax.Parser
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.xml.sax (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.xml.sax

  • Packages that use org.xml.sax
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.
  • Classes in org.xml.sax used by java.beans
    Class and Description
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by javax.xml.bind
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by javax.xml.bind.helpers
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.parsers
    Class and Description
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    HandlerBase
    Deprecated.
    This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
    InputSource
    A single input source for an XML entity.
    Parser
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.transform.sax
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    DTDHandler
    Receive notification of basic DTD-related events.
    InputSource
    A single input source for an XML entity.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.validation
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    ErrorHandler
    Basic interface for SAX error handlers.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
  • Classes in org.xml.sax used by javax.xml.xpath
    Class and Description
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by org.xml.sax
    Class and Description
    AttributeList
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by org.xml.sax.ext
    Class and Description
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
  • Classes in org.xml.sax used by org.xml.sax.helpers
    Class and Description
    AttributeList
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    Parser
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface Parser

  • All Known Implementing Classes:
    XMLReaderAdapter
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.

    public interface Parser
    Basic interface for SAX (Simple API for XML) parsers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This was the main event supplier interface for SAX1; it has been replaced in SAX2 by XMLReader, which includes Namespace support and sophisticated configurability and extensibility.

    All SAX1 parsers must implement this basic interface: it allows applications to register handlers for different types of events and to initiate a parse from a URI, or a character stream.

    All SAX1 parsers must also implement a zero-argument constructor (though other constructors are also allowed).

    SAX1 parsers are reusable but not re-entrant: the application may reuse a parser object (possibly with a different input source) once the first parse has completed successfully, but it may not invoke the parse() methods recursively within a parse.

    Since:
    SAX 1.0
    See Also:
    EntityResolver, DTDHandler, DocumentHandler, ErrorHandler, HandlerBase, InputSource

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      void parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void parse(String systemId)
      Deprecated.
      Parse an XML document from a system identifier (URI).
      void setDocumentHandler(DocumentHandler handler)
      Deprecated.
      Allow an application to register a document event handler.
      void setDTDHandler(DTDHandler handler)
      Deprecated.
      Allow an application to register a DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Deprecated.
      Allow an application to register a custom entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Deprecated.
      Allow an application to register an error event handler.
      void setLocale(Locale locale)
      Deprecated.
      Allow an application to request a locale for errors and warnings.

    • Method Detail

      • setLocale

        void setLocale(Locale locale)
        throws SAXException
        Deprecated.
        Allow an application to request a locale for errors and warnings.

        SAX parsers are not required to provide localisation for errors and warnings; if they cannot support the requested locale, however, they must throw a SAX exception. Applications may not request a locale change in the middle of a parse.

        Parameters:
        locale - A Java Locale object.
        Throws:
        SAXException - Throws an exception (using the previous or default locale) if the requested locale is not supported.
        See Also:
        SAXException, SAXParseException

      • setEntityResolver

        void setEntityResolver(EntityResolver resolver)
        Deprecated.
        Allow an application to register a custom entity resolver.

        If the application does not register an entity resolver, the SAX parser will resolve system identifiers and open connections to entities itself (this is the default behaviour implemented in HandlerBase).

        Applications may register a new or different entity resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

        Parameters:
        resolver - The object for resolving entities.
        See Also:
        EntityResolver, HandlerBase

      • setDTDHandler

        void setDTDHandler(DTDHandler handler)
        Deprecated.
        Allow an application to register a DTD event handler.

        If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The DTD handler.
        See Also:
        DTDHandler, HandlerBase

      • setDocumentHandler

        void setDocumentHandler(DocumentHandler handler)
        Deprecated.
        Allow an application to register a document event handler.

        If the application does not register a document handler, all document events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The document handler.
        See Also:
        DocumentHandler, HandlerBase

      • setErrorHandler

        void setErrorHandler(ErrorHandler handler)
        Deprecated.
        Allow an application to register an error event handler.

        If the application does not register an error event handler, all error events reported by the SAX parser will be silently ignored, except for fatalError, which will throw a SAXException (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The error handler.
        See Also:
        ErrorHandler, SAXException, HandlerBase

      • parse

        void parse(InputSource source)
    throws SAXException,
           IOException
        Deprecated.
        Parse an XML document.

        The application can use this method to instruct the SAX parser to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

        Applications may not invoke this method while a parse is in progress (they should create a new Parser instead for each additional XML document). Once a parse is complete, an application may reuse the same Parser object, possibly with a different input source.

        Parameters:
        source - The input source for the top-level of the XML document.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setDocumentHandler(org.xml.sax.DocumentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(String systemId)
    throws SAXException,
           IOException
        Deprecated.
        Parse an XML document from a system identifier (URI).

        This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

         parse(new InputSource(systemId));

        If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

        Parameters:
        systemId - The system identifier (URI).
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        parse(org.xml.sax.InputSource)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    SAXNotRecognizedException, SAXNotSupportedException, SAXParseException

    public class SAXException
extends Exception
    Encapsulate a general SAX error or warning.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class can contain basic error or warning information from either the XML parser or the application: a parser writer or application writer can subclass it to provide additional functionality. SAX handlers may throw this exception or any exception subclassed from it.

    If the application needs to pass through other types of exceptions, it must wrap those exceptions in a SAXException or an exception derived from a SAXException.

    If the parser or application needs to include information about a specific location in an XML document, it should use the SAXParseException subclass.

    Since:
    SAX 1.0
    Version:
    2.0.1 (sax2r2)
    See Also:
    SAXParseException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXException()
      Create a new SAXException.
      SAXException(Exception e)
      Create a new SAXException wrapping an existing exception.
      SAXException(String message)
      Create a new SAXException.
      SAXException(String message, Exception e)
      Create a new SAXException from an existing exception.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Return the cause of the exception
      Exception getException()
      Return the embedded exception, if any.
      String getMessage()
      Return a detail message for this exception.
      String toString()
      Override toString to pick up any embedded exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXException

        public SAXException()
        Create a new SAXException.

      • SAXException

        public SAXException(String message)
        Create a new SAXException.
        Parameters:
        message - The error or warning message.

      • SAXException

        public SAXException(Exception e)
        Create a new SAXException wrapping an existing exception.

        The existing exception will be embedded in the new one, and its message will become the default message for the SAXException.

        Parameters:
        e - The exception to be wrapped in a SAXException.

      • SAXException

        public SAXException(String message,
                    Exception e)
        Create a new SAXException from an existing exception.

        The existing exception will be embedded in the new one, but the new exception will have its own message.

        Parameters:
        message - The detail message.
        e - The exception to be wrapped in a SAXException.

    • Method Detail

      • getMessage

        public String getMessage()
        Return a detail message for this exception.

        If there is an embedded exception, and if the SAXException has no detail message of its own, this method will return the detail message from the embedded exception.

        Overrides:
        getMessage in class Throwable
        Returns:
        The error or warning message.

      • getException

        public Exception getException()
        Return the embedded exception, if any.
        Returns:
        The embedded exception, or null if there is none.

      • getCause

        public Throwable getCause()
        Return the cause of the exception
        Overrides:
        getCause in class Throwable
        Returns:
        Return the cause of the exception

      • toString

        public String toString()
        Override toString to pick up any embedded exception.
        Overrides:
        toString in class Throwable
        Returns:
        A string representation of this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXNotRecognizedException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXNotRecognizedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
  • All Implemented Interfaces:
    Serializable

    public class SAXNotRecognizedException
extends SAXException
    Exception class for an unrecognized identifier.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XMLReader will throw this exception when it finds an unrecognized feature or property identifier; SAX applications and extensions may use this class for other, similar purposes.

    Since:
    SAX 2.0
    See Also:
    SAXNotSupportedException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXNotRecognizedException()
      Default constructor.
      SAXNotRecognizedException(String message)
      Construct a new exception with the given message.

    • Method Summary

      • Methods inherited from class org.xml.sax.SAXException

        getCause, getException, getMessage, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXNotRecognizedException

        public SAXNotRecognizedException()
        Default constructor.

      • SAXNotRecognizedException

        public SAXNotRecognizedException(String message)
        Construct a new exception with the given message.
        Parameters:
        message - The text message of the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXNotSupportedException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class SAXNotSupportedException
extends SAXException
    Exception class for an unsupported operation.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XMLReader will throw this exception when it recognizes a feature or property identifier, but cannot perform the requested operation (setting a state or value). Other SAX2 applications and extensions may use this class for similar purposes.

    Since:
    SAX 2.0
    See Also:
    SAXNotRecognizedException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXNotSupportedException()
      Construct a new exception with no message.
      SAXNotSupportedException(String message)
      Construct a new exception with the given message.

    • Method Summary

      • Methods inherited from class org.xml.sax.SAXException

        getCause, getException, getMessage, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXNotSupportedException

        public SAXNotSupportedException()
        Construct a new exception with no message.

      • SAXNotSupportedException

        public SAXNotSupportedException(String message)
        Construct a new exception with the given message.
        Parameters:
        message - The text message of the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


SAXParseException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXParseException
  • All Implemented Interfaces:
    Serializable

    public class SAXParseException
extends SAXException
    Encapsulate an XML parse error or warning.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This exception may include information for locating the error in the original XML document, as if it came from a Locator object. Note that although the application will receive a SAXParseException as the argument to the handlers in the ErrorHandler interface, the application is not actually required to throw the exception; instead, it can simply read the information in it and take a different action.

    Since this exception is a subclass of SAXException, it inherits the ability to wrap another exception.

    Since:
    SAX 1.0
    Version:
    2.0.1 (sax2r2)
    See Also:
    SAXException, Locator, ErrorHandler, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXParseException(String message, Locator locator)
      Create a new SAXParseException from a message and a Locator.
      SAXParseException(String message, Locator locator, Exception e)
      Wrap an existing exception in a SAXParseException.
      SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
      Create a new SAXParseException.
      SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
      Create a new SAXParseException with an embedded exception.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      The column number of the end of the text where the exception occurred.
      int getLineNumber()
      The line number of the end of the text where the exception occurred.
      String getPublicId()
      Get the public identifier of the entity where the exception occurred.
      String getSystemId()
      Get the system identifier of the entity where the exception occurred.
      String toString()
      Override toString to provide more detailed error message.

      • Methods inherited from class org.xml.sax.SAXException

        getCause, getException, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXParseException

        public SAXParseException(String message,
                         Locator locator)
        Create a new SAXParseException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback.

        Parameters:
        message - The error or warning message.
        locator - The locator object for the error or warning (may be null).
        See Also:
        Locator

      • SAXParseException

        public SAXParseException(String message,
                         Locator locator,
                         Exception e)
        Wrap an existing exception in a SAXParseException.

        This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback, and needs to wrap an existing exception that is not a subclass of SAXException.

        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning (may be null).
        e - Any exception.
        See Also:
        Locator

      • SAXParseException

        public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber)
        Create a new SAXParseException.

        This constructor is most useful for parser writers.

        All parameters except the message are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

        Parameters:
        message - The error or warning message.
        publicId - The public identifier of the entity that generated the error or warning.
        systemId - The system identifier of the entity that generated the error or warning.
        lineNumber - The line number of the end of the text that caused the error or warning.
        columnNumber - The column number of the end of the text that cause the error or warning.

      • SAXParseException

        public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber,
                         Exception e)
        Create a new SAXParseException with an embedded exception.

        This constructor is most useful for parser writers who need to wrap an exception that is not a subclass of SAXException.

        All parameters except the message and exception are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        publicId - The public identifier of the entity that generated the error or warning.
        systemId - The system identifier of the entity that generated the error or warning.
        lineNumber - The line number of the end of the text that caused the error or warning.
        columnNumber - The column number of the end of the text that cause the error or warning.
        e - Another exception to embed in this one.

    • Method Detail

      • getPublicId

        public String getPublicId()
        Get the public identifier of the entity where the exception occurred.
        Returns:
        A string containing the public identifier, or null if none is available.
        See Also:
        Locator.getPublicId()

      • getSystemId

        public String getSystemId()
        Get the system identifier of the entity where the exception occurred.

        If the system identifier is a URL, it will have been resolved fully.

        Returns:
        A string containing the system identifier, or null if none is available.
        See Also:
        Locator.getSystemId()

      • getLineNumber

        public int getLineNumber()
        The line number of the end of the text where the exception occurred.

        The first line is line 1.

        Returns:
        An integer representing the line number, or -1 if none is available.
        See Also:
        Locator.getLineNumber()

      • getColumnNumber

        public int getColumnNumber()
        The column number of the end of the text where the exception occurred.

        The first column in a line is position 1.

        Returns:
        An integer representing the column number, or -1 if none is available.
        See Also:
        Locator.getColumnNumber()

      • toString

        public String toString()
        Override toString to provide more detailed error message.
        Overrides:
        toString in class SAXException
        Returns:
        A string representation of this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface XMLFilter

  • All Superinterfaces:
    XMLReader
    All Known Implementing Classes:
    XMLFilterImpl

    public interface XMLFilter
extends XMLReader
    Interface for an XML filter.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XML filter is like an XML reader, except that it obtains its events from another XML reader rather than a primary source like an XML document or database. Filters can modify a stream of events as they pass on to the final application.

    The XMLFilterImpl helper class provides a convenient base for creating SAX2 filters, by passing on all EntityResolver, DTDHandler, ContentHandler and ErrorHandler events automatically.

    Since:
    SAX 2.0
    See Also:
    XMLFilterImpl

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      XMLReader getParent()
      Get the parent reader.
      void setParent(XMLReader parent)
      Set the parent reader.

      • Methods inherited from interface org.xml.sax.XMLReader

        getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getProperty, parse, parse, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setProperty

    • Method Detail

      • setParent

        void setParent(XMLReader parent)
        Set the parent reader.

        This method allows the application to link the filter to a parent reader (which may be another filter). The argument may not be null.

        Parameters:
        parent - The parent reader.

      • getParent

        XMLReader getParent()
        Get the parent reader.

        This method allows the application to query the parent reader (which may be another filter). It is generally a bad idea to perform any operations on the parent reader directly: they should all pass through this filter.

        Returns:
        The parent filter, or null if none has been set.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface XMLReader

  • All Known Subinterfaces:
    XMLFilter
    All Known Implementing Classes:
    ParserAdapter, XMLFilterImpl

    public interface XMLReader
    Interface for reading an XML document using callbacks.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    Note: despite its name, this interface does not extend the standard Java Reader interface, because reading XML is a fundamentally different activity than reading character data.

    XMLReader is the interface that an XML parser's SAX2 driver must implement. This interface allows an application to set and query features and properties in the parser, to register event handlers for document processing, and to initiate a document parse.

    All SAX interfaces are assumed to be synchronous: the parse methods must not return until parsing is complete, and readers must wait for an event-handler callback to return before reporting the next event.

    This interface replaces the (now deprecated) SAX 1.0 Parser interface. The XMLReader interface contains two important enhancements over the old Parser interface (as well as some minor ones):

    1. it adds a standard way to query and set features and properties; and
    2. it adds Namespace support, which is required for many higher-level XML standards.

    There are adapters available to convert a SAX1 Parser to a SAX2 XMLReader and vice-versa.

    Since:
    SAX 2.0
    See Also:
    XMLFilter, ParserAdapter, XMLReaderAdapter

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ContentHandler getContentHandler()
      Return the current content handler.
      DTDHandler getDTDHandler()
      Return the current DTD handler.
      EntityResolver getEntityResolver()
      Return the current entity resolver.
      ErrorHandler getErrorHandler()
      Return the current error handler.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      void parse(InputSource input)
      Parse an XML document.
      void parse(String systemId)
      Parse an XML document from a system identifier (URI).
      void setContentHandler(ContentHandler handler)
      Allow an application to register a content event handler.
      void setDTDHandler(DTDHandler handler)
      Allow an application to register a DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Allow an application to register an entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Allow an application to register an error event handler.
      void setFeature(String name, boolean value)
      Set the value of a feature flag.
      void setProperty(String name, Object value)
      Set the value of a property.

    • Method Detail

      • getFeature

        boolean getFeature(String name)
            throws SAXNotRecognizedException,
                   SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for an XMLReader to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a parse. Also, some feature values may not be programmatically accessible. (In the case of an adapter for SAX1 Parser, there is no implementation-independent way to expose whether the underlying parser is performing validation, expanding external entities, and so forth.)

        All XMLReaders are required to recognize the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes feature names.

        Typical usage is something like this:

         XMLReader r = new MySAXDriver();

                         // try to activate validation
 try {
   r.setFeature("http://xml.org/sax/features/validation", true);
 } catch (SAXException e) {
   System.err.println("Cannot activate validation.");
 }

                         // register event handlers
 r.setContentHandler(new MyContentHandler());
 r.setErrorHandler(new MyErrorHandler());

                         // parse the first document
 try {
   r.parse("http://www.foo.com/mydoc.xml");
 } catch (IOException e) {
   System.err.println("I/O exception reading XML document");
 } catch (SAXException e) {
   System.err.println("XML exception reading document.");
 }

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        Parameters:
        name - The feature name, which is a fully-qualified URI.
        Returns:
        The current value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot determine its value at this time.
        See Also:
        setFeature(java.lang.String, boolean)

      • setFeature

        void setFeature(String name,
                boolean value)
         throws SAXNotRecognizedException,
                SAXNotSupportedException
        Set the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for an XMLReader to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

        All XMLReaders are required to support setting http://xml.org/sax/features/namespaces to true and http://xml.org/sax/features/namespace-prefixes to false.

        Parameters:
        name - The feature name, which is a fully-qualified URI.
        value - The requested value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot set the requested value.
        See Also:
        getFeature(java.lang.String)

      • getProperty

        Object getProperty(String name)
            throws SAXNotRecognizedException,
                   SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a parse.

        XMLReaders are not required to recognize any specific property names, though an initial core set is documented for SAX2.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        Parameters:
        name - The property name, which is a fully-qualified URI.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        See Also:
        setProperty(java.lang.String, java.lang.Object)

      • setProperty

        void setProperty(String name,
                 Object value)
          throws SAXNotRecognizedException,
                 SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

        XMLReaders are not required to recognize setting any specific property names, though a core set is defined by SAX2.

        This method is also the standard mechanism for setting extended handlers.

        Parameters:
        name - The property name, which is a fully-qualified URI.
        value - The requested value for the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot set the requested value.

      • setEntityResolver

        void setEntityResolver(EntityResolver resolver)
        Allow an application to register an entity resolver.

        If the application does not register an entity resolver, the XMLReader will perform its own default resolution.

        Applications may register a new or different resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

        Parameters:
        resolver - The entity resolver.
        See Also:
        getEntityResolver()

      • getEntityResolver

        EntityResolver getEntityResolver()
        Return the current entity resolver.
        Returns:
        The current entity resolver, or null if none has been registered.
        See Also:
        setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        void setDTDHandler(DTDHandler handler)
        Allow an application to register a DTD event handler.

        If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The DTD handler.
        See Also:
        getDTDHandler()

      • getDTDHandler

        DTDHandler getDTDHandler()
        Return the current DTD handler.
        Returns:
        The current DTD handler, or null if none has been registered.
        See Also:
        setDTDHandler(org.xml.sax.DTDHandler)

      • setContentHandler

        void setContentHandler(ContentHandler handler)
        Allow an application to register a content event handler.

        If the application does not register a content handler, all content events reported by the SAX parser will be silently ignored.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The content handler.
        See Also:
        getContentHandler()

      • getContentHandler

        ContentHandler getContentHandler()
        Return the current content handler.
        Returns:
        The current content handler, or null if none has been registered.
        See Also:
        setContentHandler(org.xml.sax.ContentHandler)

      • setErrorHandler

        void setErrorHandler(ErrorHandler handler)
        Allow an application to register an error event handler.

        If the application does not register an error handler, all error events reported by the SAX parser will be silently ignored; however, normal processing may not continue. It is highly recommended that all SAX applications implement an error handler to avoid unexpected bugs.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The error handler.
        See Also:
        getErrorHandler()

      • getErrorHandler

        ErrorHandler getErrorHandler()
        Return the current error handler.
        Returns:
        The current error handler, or null if none has been registered.
        See Also:
        setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(InputSource input)
    throws IOException,
           SAXException
        Parse an XML document.

        The application can use this method to instruct the XML reader to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

        Applications may not invoke this method while a parse is in progress (they should create a new XMLReader instead for each nested XML document). Once a parse is complete, an application may reuse the same XMLReader object, possibly with a different input source. Configuration of the XMLReader object (such as handler bindings and values established for feature flags and properties) is unchanged by completion of a parse, unless the definition of that aspect of the configuration explicitly specifies other behavior. (For example, feature flags or properties exposing characteristics of the document being parsed.)

        During the parse, the XMLReader will provide information about the XML document through the registered event handlers.

        This method is synchronous: it will not return until parsing has ended. If a client application wants to terminate parsing early, it should throw an exception.

        Parameters:
        input - The input source for the top-level of the XML document.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setContentHandler(org.xml.sax.ContentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(String systemId)
    throws IOException,
           SAXException
        Parse an XML document from a system identifier (URI).

        This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

         parse(new InputSource(systemId));

        If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

        Parameters:
        systemId - The system identifier (URI).
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        parse(org.xml.sax.InputSource)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.AttributeList (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.AttributeList

  • Packages that use AttributeList
    Package Description
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of AttributeList in org.xml.sax

      Methods in org.xml.sax with parameters of type AttributeList
      Modifier and Type Method and Description
      void DocumentHandler.startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.
      void HandlerBase.startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.

    • Uses of AttributeList in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement AttributeList
      Modifier and Type Class and Description
      class  AttributeListImpl
      Deprecated.
      This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
      Methods in org.xml.sax.helpers with parameters of type AttributeList
      Modifier and Type Method and Description
      void AttributeListImpl.setAttributeList(AttributeList atts)
      Deprecated.
      Set the attribute list, discarding previous contents.
      void ParserAdapter.startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.
      Constructors in org.xml.sax.helpers with parameters of type AttributeList
      Constructor and Description
      AttributeListImpl(AttributeList atts)
      Deprecated.
      Construct a persistent copy of an existing attribute list.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.Attributes (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.Attributes

  • Packages that use Attributes
    Package Description
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Attributes in org.xml.sax

      Methods in org.xml.sax with parameters of type Attributes
      Modifier and Type Method and Description
      void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.

    • Uses of Attributes in org.xml.sax.ext

      Subinterfaces of Attributes in org.xml.sax.ext
      Modifier and Type Interface and Description
      interface  Attributes2
      SAX2 extension to augment the per-attribute information provided though Attributes.
      Classes in org.xml.sax.ext that implement Attributes
      Modifier and Type Class and Description
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
      Methods in org.xml.sax.ext with parameters of type Attributes
      Modifier and Type Method and Description
      void Attributes2Impl.setAttributes(Attributes atts)
      Copy an entire Attributes object.
      Constructors in org.xml.sax.ext with parameters of type Attributes
      Constructor and Description
      Attributes2Impl(Attributes atts)
      Copy an existing Attributes or Attributes2 object.

    • Uses of Attributes in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Attributes
      Modifier and Type Class and Description
      class  AttributesImpl
      Default implementation of the Attributes interface.
      Methods in org.xml.sax.helpers with parameters of type Attributes
      Modifier and Type Method and Description
      void AttributesImpl.setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      Constructors in org.xml.sax.helpers with parameters of type Attributes
      Constructor and Description
      AttributesImpl(Attributes atts)
      Copy an existing Attributes object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ContentHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ContentHandler

  • Packages that use ContentHandler
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of ContentHandler in javax.xml.bind

      Subinterfaces of ContentHandler in javax.xml.bind
      Modifier and Type Interface and Description
      interface  UnmarshallerHandler
      Unmarshaller implemented as SAX ContentHandler.
      Methods in javax.xml.bind with parameters of type ContentHandler
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.

    • Uses of ContentHandler in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type ContentHandler
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

    • Uses of ContentHandler in javax.xml.transform.sax

      Subinterfaces of ContentHandler in javax.xml.transform.sax
      Modifier and Type Interface and Description
      interface  TemplatesHandler
      A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
      Methods in javax.xml.transform.sax that return ContentHandler
      Modifier and Type Method and Description
      ContentHandler SAXResult.getHandler()
      Get the ContentHandler that is the Result.
      Methods in javax.xml.transform.sax with parameters of type ContentHandler
      Modifier and Type Method and Description
      void SAXResult.setHandler(ContentHandler handler)
      Set the target to be a SAX2 ContentHandler.
      Constructors in javax.xml.transform.sax with parameters of type ContentHandler
      Constructor and Description
      SAXResult(ContentHandler handler)
      Create a SAXResult that targets a SAX2 ContentHandler.

    • Uses of ContentHandler in javax.xml.validation

      Classes in javax.xml.validation that implement ContentHandler
      Modifier and Type Class and Description
      class  ValidatorHandler
      Streaming validator that works on SAX stream.
      Methods in javax.xml.validation that return ContentHandler
      Modifier and Type Method and Description
      abstract ContentHandler ValidatorHandler.getContentHandler()
      Gets the ContentHandler which receives the augmented validation result.
      Methods in javax.xml.validation with parameters of type ContentHandler
      Modifier and Type Method and Description
      abstract void ValidatorHandler.setContentHandler(ContentHandler receiver)
      Sets the ContentHandler which receives the augmented validation result.

    • Uses of ContentHandler in org.xml.sax

      Methods in org.xml.sax that return ContentHandler
      Modifier and Type Method and Description
      ContentHandler XMLReader.getContentHandler()
      Return the current content handler.
      Methods in org.xml.sax with parameters of type ContentHandler
      Modifier and Type Method and Description
      void XMLReader.setContentHandler(ContentHandler handler)
      Allow an application to register a content event handler.

    • Uses of ContentHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement ContentHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of ContentHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement ContentHandler
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      class  XMLReaderAdapter
      Adapt a SAX2 XMLReader as a SAX1 Parser.
      Methods in org.xml.sax.helpers that return ContentHandler
      Modifier and Type Method and Description
      ContentHandler XMLFilterImpl.getContentHandler()
      Get the content event handler.
      ContentHandler ParserAdapter.getContentHandler()
      Return the current content handler.
      Methods in org.xml.sax.helpers with parameters of type ContentHandler
      Modifier and Type Method and Description
      void XMLFilterImpl.setContentHandler(ContentHandler handler)
      Set the content event handler.
      void ParserAdapter.setContentHandler(ContentHandler handler)
      Set the content handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.DocumentHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.DocumentHandler

  • Packages that use DocumentHandler
    Package Description
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of DocumentHandler in org.xml.sax

      Classes in org.xml.sax that implement DocumentHandler
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax with parameters of type DocumentHandler
      Modifier and Type Method and Description
      void Parser.setDocumentHandler(DocumentHandler handler)
      Deprecated.
      Allow an application to register a document event handler.

    • Uses of DocumentHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement DocumentHandler
      Modifier and Type Class and Description
      class  ParserAdapter
      Adapt a SAX1 Parser as a SAX2 XMLReader.
      Methods in org.xml.sax.helpers with parameters of type DocumentHandler
      Modifier and Type Method and Description
      void XMLReaderAdapter.setDocumentHandler(DocumentHandler handler)
      Register the SAX1 document event handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.DTDHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.DTDHandler

  • Packages that use DTDHandler
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of DTDHandler in javax.xml.transform.sax

      Subinterfaces of DTDHandler in javax.xml.transform.sax
      Modifier and Type Interface and Description
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

    • Uses of DTDHandler in org.xml.sax

      Classes in org.xml.sax that implement DTDHandler
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return DTDHandler
      Modifier and Type Method and Description
      DTDHandler XMLReader.getDTDHandler()
      Return the current DTD handler.
      Methods in org.xml.sax with parameters of type DTDHandler
      Modifier and Type Method and Description
      void Parser.setDTDHandler(DTDHandler handler)
      Deprecated.
      Allow an application to register a DTD event handler.
      void XMLReader.setDTDHandler(DTDHandler handler)
      Allow an application to register a DTD event handler.

    • Uses of DTDHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement DTDHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of DTDHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement DTDHandler
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return DTDHandler
      Modifier and Type Method and Description
      DTDHandler XMLFilterImpl.getDTDHandler()
      Get the current DTD event handler.
      DTDHandler ParserAdapter.getDTDHandler()
      Return the current DTD handler.
      Methods in org.xml.sax.helpers with parameters of type DTDHandler
      Modifier and Type Method and Description
      void XMLReaderAdapter.setDTDHandler(DTDHandler handler)
      Register the DTD event handler.
      void XMLFilterImpl.setDTDHandler(DTDHandler handler)
      Set the DTD event handler.
      void ParserAdapter.setDTDHandler(DTDHandler handler)
      Set the DTD handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.EntityResolver (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.EntityResolver

  • Packages that use EntityResolver
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of EntityResolver in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type EntityResolver
      Modifier and Type Method and Description
      abstract void DocumentBuilder.setEntityResolver(EntityResolver er)
      Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.

    • Uses of EntityResolver in org.xml.sax

      Classes in org.xml.sax that implement EntityResolver
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return EntityResolver
      Modifier and Type Method and Description
      EntityResolver XMLReader.getEntityResolver()
      Return the current entity resolver.
      Methods in org.xml.sax with parameters of type EntityResolver
      Modifier and Type Method and Description
      void Parser.setEntityResolver(EntityResolver resolver)
      Deprecated.
      Allow an application to register a custom entity resolver.
      void XMLReader.setEntityResolver(EntityResolver resolver)
      Allow an application to register an entity resolver.

    • Uses of EntityResolver in org.xml.sax.ext

      Subinterfaces of EntityResolver in org.xml.sax.ext
      Modifier and Type Interface and Description
      interface  EntityResolver2
      Extended interface for mapping external entity references to input sources, or providing a missing external subset.
      Classes in org.xml.sax.ext that implement EntityResolver
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of EntityResolver in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement EntityResolver
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return EntityResolver
      Modifier and Type Method and Description
      EntityResolver XMLFilterImpl.getEntityResolver()
      Get the current entity resolver.
      EntityResolver ParserAdapter.getEntityResolver()
      Return the current entity resolver.
      Methods in org.xml.sax.helpers with parameters of type EntityResolver
      Modifier and Type Method and Description
      void XMLReaderAdapter.setEntityResolver(EntityResolver resolver)
      Register the entity resolver.
      void XMLFilterImpl.setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void ParserAdapter.setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ErrorHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ErrorHandler

  • Packages that use ErrorHandler
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of ErrorHandler in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type ErrorHandler
      Modifier and Type Method and Description
      abstract void DocumentBuilder.setErrorHandler(ErrorHandler eh)
      Specify the ErrorHandler to be used by the parser.

    • Uses of ErrorHandler in javax.xml.validation

      Methods in javax.xml.validation that return ErrorHandler
      Modifier and Type Method and Description
      abstract ErrorHandler SchemaFactory.getErrorHandler()
      Gets the current ErrorHandler set to this SchemaFactory.
      abstract ErrorHandler ValidatorHandler.getErrorHandler()
      Gets the current ErrorHandler set to this ValidatorHandler.
      abstract ErrorHandler Validator.getErrorHandler()
      Gets the current ErrorHandler set to this Validator.
      Methods in javax.xml.validation with parameters of type ErrorHandler
      Modifier and Type Method and Description
      abstract void SchemaFactory.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.
      abstract void ValidatorHandler.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validation.
      abstract void Validator.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validate method invocation.

    • Uses of ErrorHandler in org.xml.sax

      Classes in org.xml.sax that implement ErrorHandler
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return ErrorHandler
      Modifier and Type Method and Description
      ErrorHandler XMLReader.getErrorHandler()
      Return the current error handler.
      Methods in org.xml.sax with parameters of type ErrorHandler
      Modifier and Type Method and Description
      void Parser.setErrorHandler(ErrorHandler handler)
      Deprecated.
      Allow an application to register an error event handler.
      void XMLReader.setErrorHandler(ErrorHandler handler)
      Allow an application to register an error event handler.

    • Uses of ErrorHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement ErrorHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of ErrorHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement ErrorHandler
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return ErrorHandler
      Modifier and Type Method and Description
      ErrorHandler XMLFilterImpl.getErrorHandler()
      Get the current error event handler.
      ErrorHandler ParserAdapter.getErrorHandler()
      Return the current error handler.
      Methods in org.xml.sax.helpers with parameters of type ErrorHandler
      Modifier and Type Method and Description
      void XMLReaderAdapter.setErrorHandler(ErrorHandler handler)
      Register the error event handler.
      void XMLFilterImpl.setErrorHandler(ErrorHandler handler)
      Set the error event handler.
      void ParserAdapter.setErrorHandler(ErrorHandler handler)
      Set the error handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.HandlerBase (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.HandlerBase

  • Packages that use HandlerBase
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of HandlerBase in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type HandlerBase
      Modifier and Type Method and Description
      void SAXParser.parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.InputSource (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.InputSource

  • Packages that use InputSource
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of InputSource in java.beans

      Constructors in java.beans with parameters of type InputSource
      Constructor and Description
      XMLDecoder(InputSource is)
      Creates a new decoder to parse XML archives created by the XMLEncoder class.

    • Uses of InputSource in javax.xml.bind

      Methods in javax.xml.bind with parameters of type InputSource
      Modifier and Type Method and Description
      Object Unmarshaller.unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

    • Uses of InputSource in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type InputSource
      Modifier and Type | Method and Description
      Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.

    • Uses of InputSource in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type InputSource
      Modifier and Type Method and Description
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.

    • Uses of InputSource in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return InputSource
      Modifier and Type Method and Description
      InputSource SAXSource.getInputSource()
      Get the SAX InputSource to be used for the Source.
      static InputSource SAXSource.sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.
      Methods in javax.xml.transform.sax with parameters of type InputSource
      Modifier and Type Method and Description
      void SAXSource.setInputSource(InputSource inputSource)
      Set the SAX InputSource to be used for the Source.
      Constructors in javax.xml.transform.sax with parameters of type InputSource
      Constructor and Description
      SAXSource(InputSource inputSource)
      Create a SAXSource, using a SAX InputSource.
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Uses of InputSource in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type InputSource
      Modifier and Type Method and Description
      String XPathExpression.evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPath.evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.

    • Uses of InputSource in org.xml.sax

      Methods in org.xml.sax that return InputSource
      Modifier and Type Method and Description
      InputSource EntityResolver.resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.
      InputSource HandlerBase.resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      Methods in org.xml.sax with parameters of type InputSource
      Modifier and Type Method and Description
      void Parser.parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void XMLReader.parse(InputSource input)
      Parse an XML document.

    • Uses of InputSource in org.xml.sax.ext

      Methods in org.xml.sax.ext that return InputSource
      Modifier and Type Method and Description
      InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.

    • Uses of InputSource in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that return InputSource
      Modifier and Type Method and Description
      InputSource DefaultHandler.resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      InputSource XMLFilterImpl.resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      Methods in org.xml.sax.helpers with parameters of type InputSource
      Modifier and Type Method and Description
      void XMLReaderAdapter.parse(InputSource input)
      Parse the document.
      void XMLFilterImpl.parse(InputSource input)
      Parse a document.
      void ParserAdapter.parse(InputSource input)
      Parse an XML document.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.Locator (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.Locator

  • Packages that use Locator
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Locator in javax.xml.bind.helpers

      Constructors in javax.xml.bind.helpers with parameters of type Locator
      Constructor and Description
      ValidationEventLocatorImpl(Locator loc)
      Constructs an object from an org.xml.sax.Locator.

    • Uses of Locator in org.xml.sax

      Methods in org.xml.sax with parameters of type Locator
      Modifier and Type Method and Description
      void ContentHandler.setDocumentLocator(Locator locator)
      Receive an object for locating the origin of SAX document events.
      void DocumentHandler.setDocumentLocator(Locator locator)
      Deprecated.
      Receive an object for locating the origin of SAX document events.
      void HandlerBase.setDocumentLocator(Locator locator)
      Deprecated.
      Receive a Locator object for document events.
      Constructors in org.xml.sax with parameters of type Locator
      Constructor and Description
      SAXParseException(String message, Locator locator)
      Create a new SAXParseException from a message and a Locator.
      SAXParseException(String message, Locator locator, Exception e)
      Wrap an existing exception in a SAXParseException.

    • Uses of Locator in org.xml.sax.ext

      Subinterfaces of Locator in org.xml.sax.ext
      Modifier and Type Interface and Description
      interface  Locator2
      SAX2 extension to augment the entity information provided though a Locator.
      Classes in org.xml.sax.ext that implement Locator
      Modifier and Type Class and Description
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
      Constructors in org.xml.sax.ext with parameters of type Locator
      Constructor and Description
      Locator2Impl(Locator locator)
      Copy an existing Locator or Locator2 object.

    • Uses of Locator in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Locator
      Modifier and Type Class and Description
      class  LocatorImpl
      Provide an optional convenience implementation of Locator.
      Methods in org.xml.sax.helpers with parameters of type Locator
      Modifier and Type Method and Description
      void XMLReaderAdapter.setDocumentLocator(Locator locator)
      Set a document locator.
      void DefaultHandler.setDocumentLocator(Locator locator)
      Receive a Locator object for document events.
      void XMLFilterImpl.setDocumentLocator(Locator locator)
      Filter a new document locator event.
      void ParserAdapter.setDocumentLocator(Locator locator)
      Adapter implementation method; do not call.
      Constructors in org.xml.sax.helpers with parameters of type Locator
      Constructor and Description
      LocatorImpl(Locator locator)
      Copy constructor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.Parser (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.Parser

  • Packages that use Parser
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Parser in javax.xml.parsers

      Methods in javax.xml.parsers that return Parser
      Modifier and Type Method and Description
      abstract Parser SAXParser.getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.

    • Uses of Parser in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Parser
      Modifier and Type Class and Description
      class  XMLReaderAdapter
      Adapt a SAX2 XMLReader as a SAX1 Parser.
      Methods in org.xml.sax.helpers that return Parser
      Modifier and Type Method and Description
      static Parser ParserFactory.makeParser()
      Deprecated.
      Create a new SAX parser using the `org.xml.sax.parser' system property.
      static Parser ParserFactory.makeParser(String className)
      Deprecated.
      Create a new SAX parser object using the class name provided.
      Constructors in org.xml.sax.helpers with parameters of type Parser
      Constructor and Description
      ParserAdapter(Parser parser)
      Construct a new parser adapter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.SAXException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXException

  • Packages that use SAXException
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type SAXException
      Modifier and Type Method and Description
      protected UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.

    • Uses of SAXException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXException
      Modifier and Type Method and Description
      abstract Parser SAXParser.getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.
      abstract XMLReader SAXParser.getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      Document DocumentBuilder.parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      void SAXParser.parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void SAXParser.parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      Document DocumentBuilder.parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      Document DocumentBuilder.parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.
      void SAXParser.parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
      void SAXParser.parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.

    • Uses of SAXException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXException
      Modifier and Type Method and Description
      abstract Schema SchemaFactory.newSchema()
      Creates a special Schema object.
      Schema SchemaFactory.newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema SchemaFactory.newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
      void Validator.validate(Source source)
      Validates the specified input.
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of SAXException in org.xml.sax

      Subclasses of SAXException in org.xml.sax
      Modifier and Type Class and Description
      class  SAXNotRecognizedException
      Exception class for an unrecognized identifier.
      class  SAXNotSupportedException
      Exception class for an unsupported operation.
      class  SAXParseException
      Encapsulate an XML parse error or warning.
      Methods in org.xml.sax that throw SAXException
      Modifier and Type Method and Description
      void ContentHandler.characters(char[] ch, int start, int length)
      Receive notification of character data.
      void DocumentHandler.characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data.
      void HandlerBase.characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data inside an element.
      void ContentHandler.endDocument()
      Receive notification of the end of a document.
      void DocumentHandler.endDocument()
      Deprecated.
      Receive notification of the end of a document.
      void HandlerBase.endDocument()
      Deprecated.
      Receive notification of the end of the document.
      void DocumentHandler.endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void HandlerBase.endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void ContentHandler.endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void ContentHandler.endPrefixMapping(String prefix)
      End the scope of a prefix-URI mapping.
      void ErrorHandler.error(SAXParseException exception)
      Receive notification of a recoverable error.
      void HandlerBase.error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void ErrorHandler.fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void HandlerBase.fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ContentHandler.ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void DocumentHandler.ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void HandlerBase.ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void DTDHandler.notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration event.
      void Parser.parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void XMLReader.parse(InputSource input)
      Parse an XML document.
      void Parser.parse(String systemId)
      Deprecated.
      Parse an XML document from a system identifier (URI).
      void XMLReader.parse(String systemId)
      Parse an XML document from a system identifier (URI).
      void ContentHandler.processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void DocumentHandler.processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void HandlerBase.processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      InputSource EntityResolver.resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.
      InputSource HandlerBase.resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      void Parser.setLocale(Locale locale)
      Deprecated.
      Allow an application to request a locale for errors and warnings.
      void ContentHandler.skippedEntity(String name)
      Receive notification of a skipped entity.
      void ContentHandler.startDocument()
      Receive notification of the beginning of a document.
      void DocumentHandler.startDocument()
      Deprecated.
      Receive notification of the beginning of a document.
      void HandlerBase.startDocument()
      Deprecated.
      Receive notification of the beginning of the document.
      void DocumentHandler.startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.
      void HandlerBase.startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.
      void ContentHandler.startPrefixMapping(String prefix, String uri)
      Begin the scope of a prefix-URI Namespace mapping.
      void DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration event.
      void ErrorHandler.warning(SAXParseException exception)
      Receive notification of a warning.
      void HandlerBase.warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.

    • Uses of SAXException in org.xml.sax.ext

      Methods in org.xml.sax.ext that throw SAXException
      Modifier and Type | Method and Description
      void | DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)
      void DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void | DefaultHandler2.comment(char[] ch, int start, int length)
      void LexicalHandler.comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void | DefaultHandler2.elementDecl(String name, String model)
      void DeclHandler.elementDecl(String name, String model)
      Report an element type declaration.
      void | DefaultHandler2.endCDATA()
      void LexicalHandler.endCDATA()
      Report the end of a CDATA section.
      void | DefaultHandler2.endDTD()
      void LexicalHandler.endDTD()
      Report the end of DTD declarations.
      void | DefaultHandler2.endEntity(String name)
      void LexicalHandler.endEntity(String name)
      Report the end of an entity.
      void | DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)
      void DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      void | DefaultHandler2.internalEntityDecl(String name, String value)
      void DeclHandler.internalEntityDecl(String name, String value)
      Report an internal entity declaration.
      InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.
      void | DefaultHandler2.startCDATA()
      void LexicalHandler.startCDATA()
      Report the start of a CDATA section.
      void | DefaultHandler2.startDTD(String name, String publicId, String systemId)
      void LexicalHandler.startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void | DefaultHandler2.startEntity(String name)
      void LexicalHandler.startEntity(String name)
      Report the beginning of some internal and external XML entities.

    • Uses of SAXException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXException
      Modifier and Type Method and Description
      void XMLReaderAdapter.characters(char[] ch, int start, int length)
      Adapt a SAX2 characters event.
      void DefaultHandler.characters(char[] ch, int start, int length)
      Receive notification of character data inside an element.
      void XMLFilterImpl.characters(char[] ch, int start, int length)
      Filter a character data event.
      void ParserAdapter.characters(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      static XMLReader XMLReaderFactory.createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader XMLReaderFactory.createXMLReader(String className)
      Attempt to create an XML reader from a class name.
      void XMLReaderAdapter.endDocument()
      End document event.
      void DefaultHandler.endDocument()
      Receive notification of the end of the document.
      void XMLFilterImpl.endDocument()
      Filter an end document event.
      void ParserAdapter.endDocument()
      Adapter implementation method; do not call.
      void ParserAdapter.endElement(String qName)
      Adapter implementation method; do not call.
      void XMLReaderAdapter.endElement(String uri, String localName, String qName)
      Adapt a SAX2 end element event.
      void DefaultHandler.endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void XMLFilterImpl.endElement(String uri, String localName, String qName)
      Filter an end element event.
      void DefaultHandler.endPrefixMapping(String prefix)
      Receive notification of the end of a Namespace mapping.
      void XMLFilterImpl.endPrefixMapping(String prefix)
      Filter an end Namespace prefix mapping event.
      void DefaultHandler.error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void XMLFilterImpl.error(SAXParseException e)
      Filter an error event.
      void DefaultHandler.fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void XMLFilterImpl.fatalError(SAXParseException e)
      Filter a fatal error event.
      void XMLReaderAdapter.ignorableWhitespace(char[] ch, int start, int length)
      Adapt a SAX2 ignorable whitespace event.
      void DefaultHandler.ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void XMLFilterImpl.ignorableWhitespace(char[] ch, int start, int length)
      Filter an ignorable whitespace event.
      void ParserAdapter.ignorableWhitespace(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void DefaultHandler.notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration.
      void XMLFilterImpl.notationDecl(String name, String publicId, String systemId)
      Filter a notation declaration event.
      void XMLReaderAdapter.parse(InputSource input)
      Parse the document.
      void XMLFilterImpl.parse(InputSource input)
      Parse a document.
      void ParserAdapter.parse(InputSource input)
      Parse an XML document.
      void XMLReaderAdapter.parse(String systemId)
      Parse the document.
      void XMLFilterImpl.parse(String systemId)
      Parse a document.
      void ParserAdapter.parse(String systemId)
      Parse an XML document.
      void XMLReaderAdapter.processingInstruction(String target, String data)
      Adapt a SAX2 processing instruction event.
      void DefaultHandler.processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void XMLFilterImpl.processingInstruction(String target, String data)
      Filter a processing instruction event.
      void ParserAdapter.processingInstruction(String target, String data)
      Adapter implementation method; do not call.
      InputSource DefaultHandler.resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      InputSource XMLFilterImpl.resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      void XMLReaderAdapter.setLocale(Locale locale)
      Set the locale for error reporting.
      void XMLReaderAdapter.skippedEntity(String name)
      Adapt a SAX2 skipped entity event.
      void DefaultHandler.skippedEntity(String name)
      Receive notification of a skipped entity.
      void XMLFilterImpl.skippedEntity(String name)
      Filter a skipped entity event.
      void XMLReaderAdapter.startDocument()
      Start document event.
      void DefaultHandler.startDocument()
      Receive notification of the beginning of the document.
      void XMLFilterImpl.startDocument()
      Filter a start document event.
      void ParserAdapter.startDocument()
      Adapter implementation method; do not call.
      void ParserAdapter.startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.
      void XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void DefaultHandler.startPrefixMapping(String prefix, String uri)
      Receive notification of the start of a Namespace mapping.
      void XMLFilterImpl.startPrefixMapping(String prefix, String uri)
      Filter a start Namespace prefix mapping event.
      void DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration.
      void XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Filter an unparsed entity declaration event.
      void DefaultHandler.warning(SAXParseException e)
      Receive notification of a parser warning.
      void XMLFilterImpl.warning(SAXParseException e)
      Filter a warning event.
      Constructors in org.xml.sax.helpers that throw SAXException
      Constructor and Description
      ParserAdapter()
      Construct a new parser adapter.
      XMLReaderAdapter()
      Create a new adapter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.SAXNotRecognizedException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXNotRecognizedException

  • Packages that use SAXNotRecognizedException
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXNotRecognizedException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract Object SAXParser.getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void SAXParser.setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

    • Uses of SAXNotRecognizedException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      boolean SchemaFactory.getFeature(String name)
      Look up the value of a feature flag.
      boolean ValidatorHandler.getFeature(String name)
      Look up the value of a feature flag.
      boolean Validator.getFeature(String name)
      Look up the value of a feature flag.
      Object SchemaFactory.getProperty(String name)
      Look up the value of a property.
      Object ValidatorHandler.getProperty(String name)
      Look up the value of a property.
      Object Validator.getProperty(String name)
      Look up the value of a property.
      void SchemaFactory.setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void ValidatorHandler.setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void Validator.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void SchemaFactory.setProperty(String name, Object object)
      Set the value of a property.
      void ValidatorHandler.setProperty(String name, Object object)
      Set the value of a property.
      void Validator.setProperty(String name, Object object)
      Set the value of a property.

    • Uses of SAXNotRecognizedException in org.xml.sax

      Methods in org.xml.sax that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      boolean XMLReader.getFeature(String name)
      Look up the value of a feature flag.
      Object XMLReader.getProperty(String name)
      Look up the value of a property.
      void XMLReader.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void XMLReader.setProperty(String name, Object value)
      Set the value of a property.

    • Uses of SAXNotRecognizedException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      boolean XMLFilterImpl.getFeature(String name)
      Look up the value of a feature.
      boolean ParserAdapter.getFeature(String name)
      Check a parser feature flag.
      Object XMLFilterImpl.getProperty(String name)
      Look up the value of a property.
      Object ParserAdapter.getProperty(String name)
      Get a parser property.
      void XMLFilterImpl.setFeature(String name, boolean value)
      Set the value of a feature.
      void ParserAdapter.setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void XMLFilterImpl.setProperty(String name, Object value)
      Set the value of a property.
      void ParserAdapter.setProperty(String name, Object value)
      Set a parser property.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.SAXNotSupportedException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXNotSupportedException

  • Packages that use SAXNotSupportedException
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXNotSupportedException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXNotSupportedException
      Modifier and Type Method and Description
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract Object SAXParser.getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void SAXParser.setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

    • Uses of SAXNotSupportedException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXNotSupportedException
      Modifier and Type Method and Description
      boolean SchemaFactory.getFeature(String name)
      Look up the value of a feature flag.
      boolean ValidatorHandler.getFeature(String name)
      Look up the value of a feature flag.
      boolean Validator.getFeature(String name)
      Look up the value of a feature flag.
      Object SchemaFactory.getProperty(String name)
      Look up the value of a property.
      Object ValidatorHandler.getProperty(String name)
      Look up the value of a property.
      Object Validator.getProperty(String name)
      Look up the value of a property.
      void SchemaFactory.setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void ValidatorHandler.setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void Validator.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void SchemaFactory.setProperty(String name, Object object)
      Set the value of a property.
      void ValidatorHandler.setProperty(String name, Object object)
      Set the value of a property.
      void Validator.setProperty(String name, Object object)
      Set the value of a property.

    • Uses of SAXNotSupportedException in org.xml.sax

      Methods in org.xml.sax that throw SAXNotSupportedException
      Modifier and Type Method and Description
      boolean XMLReader.getFeature(String name)
      Look up the value of a feature flag.
      Object XMLReader.getProperty(String name)
      Look up the value of a property.
      void XMLReader.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void XMLReader.setProperty(String name, Object value)
      Set the value of a property.

    • Uses of SAXNotSupportedException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXNotSupportedException
      Modifier and Type Method and Description
      boolean XMLFilterImpl.getFeature(String name)
      Look up the value of a feature.
      boolean ParserAdapter.getFeature(String name)
      Check a parser feature flag.
      Object XMLFilterImpl.getProperty(String name)
      Look up the value of a property.
      Object ParserAdapter.getProperty(String name)
      Get a parser property.
      void XMLFilterImpl.setFeature(String name, boolean value)
      Set the value of a feature.
      void ParserAdapter.setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void XMLFilterImpl.setProperty(String name, Object value)
      Set the value of a property.
      void ParserAdapter.setProperty(String name, Object value)
      Set a parser property.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.SAXParseException (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXParseException

  • Packages that use SAXParseException
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXParseException in javax.xml.bind.helpers

      Constructors in javax.xml.bind.helpers with parameters of type SAXParseException
      Constructor and Description
      ValidationEventLocatorImpl(SAXParseException e)
      Constructs an object from the location information of a SAXParseException.

    • Uses of SAXParseException in org.xml.sax

      Methods in org.xml.sax with parameters of type SAXParseException
      Modifier and Type Method and Description
      void ErrorHandler.error(SAXParseException exception)
      Receive notification of a recoverable error.
      void HandlerBase.error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void ErrorHandler.fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void HandlerBase.fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ErrorHandler.warning(SAXParseException exception)
      Receive notification of a warning.
      void HandlerBase.warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.

    • Uses of SAXParseException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers with parameters of type SAXParseException
      Modifier and Type Method and Description
      void DefaultHandler.error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void XMLFilterImpl.error(SAXParseException e)
      Filter an error event.
      void DefaultHandler.fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void XMLFilterImpl.fatalError(SAXParseException e)
      Filter a fatal error event.
      void DefaultHandler.warning(SAXParseException e)
      Receive notification of a parser warning.
      void XMLFilterImpl.warning(SAXParseException e)
      Filter a warning event.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.XMLFilter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.XMLFilter

  • Packages that use XMLFilter
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of XMLFilter in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return XMLFilter
      Modifier and Type Method and Description
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..

    • Uses of XMLFilter in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement XMLFilter
      Modifier and Type Class and Description
      class  XMLFilterImpl
      Base class for deriving an XML filter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.XMLReader (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.XMLReader

  • Packages that use XMLReader
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of XMLReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return XMLReader
      Modifier and Type Method and Description
      protected XMLReader AbstractUnmarshallerImpl.getXMLReader()
      Obtains a configured XMLReader.
      Methods in javax.xml.bind.helpers with parameters of type XMLReader
      Modifier and Type Method and Description
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.

    • Uses of XMLReader in javax.xml.parsers

      Methods in javax.xml.parsers that return XMLReader
      Modifier and Type Method and Description
      abstract XMLReader SAXParser.getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.

    • Uses of XMLReader in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return XMLReader
      Modifier and Type Method and Description
      XMLReader SAXSource.getXMLReader()
      Get the XMLReader to be used for the Source.
      Methods in javax.xml.transform.sax with parameters of type XMLReader
      Modifier and Type Method and Description
      void SAXSource.setXMLReader(XMLReader reader)
      Set the XMLReader to be used for the Source.
      Constructors in javax.xml.transform.sax with parameters of type XMLReader
      Constructor and Description
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Uses of XMLReader in org.xml.sax

      Subinterfaces of XMLReader in org.xml.sax
      Modifier and Type Interface and Description
      interface  XMLFilter
      Interface for an XML filter.
      Methods in org.xml.sax that return XMLReader
      Modifier and Type Method and Description
      XMLReader XMLFilter.getParent()
      Get the parent reader.
      Methods in org.xml.sax with parameters of type XMLReader
      Modifier and Type Method and Description
      void XMLFilter.setParent(XMLReader parent)
      Set the parent reader.

    • Uses of XMLReader in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement XMLReader
      Modifier and Type Class and Description
      class  ParserAdapter
      Adapt a SAX1 Parser as a SAX2 XMLReader.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return XMLReader
      Modifier and Type Method and Description
      static XMLReader XMLReaderFactory.createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader XMLReaderFactory.createXMLReader(String className)
      Attempt to create an XML reader from a class name.
      XMLReader XMLFilterImpl.getParent()
      Get the parent reader.
      Methods in org.xml.sax.helpers with parameters of type XMLReader
      Modifier and Type Method and Description
      void XMLFilterImpl.setParent(XMLReader parent)
      Set the parent reader.
      Constructors in org.xml.sax.helpers with parameters of type XMLReader
      Constructor and Description
      XMLFilterImpl(XMLReader parent)
      Construct an XML filter with the specified parent.
      XMLReaderAdapter(XMLReader xmlReader)
      Create a new adapter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Attributes2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface Attributes2

  • All Superinterfaces:
    Attributes
    All Known Implementing Classes:
    Attributes2Impl

    public interface Attributes2
extends Attributes
    SAX2 extension to augment the per-attribute information provided though Attributes. If an implementation supports this extension, the attributes provided in ContentHandler.startElement() will implement this interface, and the http://xml.org/sax/features/use-attributes2 feature flag will have the value true.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

    Note that if an attribute was defaulted (!isSpecified()) it will of necessity also have been declared (isDeclared()) in the DTD. Similarly if an attribute's type is anything except CDATA, then it must have been declared.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean isDeclared(int index)
      Returns false unless the attribute was declared in the DTD.
      boolean isDeclared(String qName)
      Returns false unless the attribute was declared in the DTD.
      boolean isDeclared(String uri, String localName)
      Returns false unless the attribute was declared in the DTD.
      boolean isSpecified(int index)
      Returns true unless the attribute value was provided by DTD defaulting.
      boolean isSpecified(String qName)
      Returns true unless the attribute value was provided by DTD defaulting.
      boolean isSpecified(String uri, String localName)
      Returns true unless the attribute value was provided by DTD defaulting.

      • Methods inherited from interface org.xml.sax.Attributes

        getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

    • Method Detail

      • isDeclared

        boolean isDeclared(int index)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        true if the attribute was declared in the DTD, false otherwise.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isDeclared

        boolean isDeclared(String qName)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.
        Throws:
        IllegalArgumentException - When the supplied name does not identify an attribute.

      • isDeclared

        boolean isDeclared(String uri,
                   String localName)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).

        Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.
        Throws:
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        boolean isSpecified(int index)
        Returns true unless the attribute value was provided by DTD defaulting.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isSpecified

        boolean isSpecified(String uri,
                    String localName)
        Returns true unless the attribute value was provided by DTD defaulting.

        Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        Throws:
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        boolean isSpecified(String qName)
        Returns true unless the attribute value was provided by DTD defaulting.
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        Throws:
        IllegalArgumentException - When the supplied name does not identify an attribute.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Attributes2Impl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Class Attributes2Impl

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl
      • org.xml.sax.ext.Attributes2Impl
  • All Implemented Interfaces:
    Attributes, Attributes2

    public class Attributes2Impl
extends AttributesImpl
implements Attributes2
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    This is not part of core-only SAX2 distributions.

    The specified flag for each attribute will always be true, unless it has been set to false in the copy constructor or using setSpecified(int, boolean). Similarly, the declared flag for each attribute will always be false, except for defaulted attributes (specified is false), non-CDATA attributes, or when it is set to true using setDeclared(int, boolean). If you change an attribute's type by hand, you may need to modify its declared flag to match.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Constructor Summary

      Constructors
      Constructor and Description
      Attributes2Impl()
      Construct a new, empty Attributes2Impl object.
      Attributes2Impl(Attributes atts)
      Copy an existing Attributes or Attributes2 object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addAttribute(String uri, String localName, String qName, String type, String value)
      Add an attribute to the end of the list, setting its "specified" flag to true.
      boolean isDeclared(int index)
      Returns the current value of the attribute's "declared" flag.
      boolean isDeclared(String qName)
      Returns the current value of the attribute's "declared" flag.
      boolean isDeclared(String uri, String localName)
      Returns the current value of the attribute's "declared" flag.
      boolean isSpecified(int index)
      Returns the current value of an attribute's "specified" flag.
      boolean isSpecified(String qName)
      Returns the current value of an attribute's "specified" flag.
      boolean isSpecified(String uri, String localName)
      Returns the current value of an attribute's "specified" flag.
      void removeAttribute(int index)
      Remove an attribute from the list.
      void setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void setDeclared(int index, boolean value)
      Assign a value to the "declared" flag of a specific attribute.
      void setSpecified(int index, boolean value)
      Assign a value to the "specified" flag of a specific attribute.

      • Methods inherited from class org.xml.sax.helpers.AttributesImpl

        clear, getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue, setAttribute, setLocalName, setQName, setType, setURI, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.xml.sax.Attributes

        getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

    • Constructor Detail

      • Attributes2Impl

        public Attributes2Impl()
        Construct a new, empty Attributes2Impl object.

      • Attributes2Impl

        public Attributes2Impl(Attributes atts)
        Copy an existing Attributes or Attributes2 object. If the object implements Attributes2, values of the specified and declared flags for each attribute are copied. Otherwise the flag values are defaulted to assume no DTD was used, unless there is evidence to the contrary (such as attributes with type other than CDATA, which must have been declared).

        This constructor is especially useful inside a startElement event.

        Parameters:
        atts - The existing Attributes object.

    • Method Detail

      • isDeclared

        public boolean isDeclared(int index)
        Returns the current value of the attribute's "declared" flag.
        Specified by:
        isDeclared in interface Attributes2
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        true if the attribute was declared in the DTD, false otherwise.

      • isDeclared

        public boolean isDeclared(String uri,
                          String localName)
        Returns the current value of the attribute's "declared" flag.
        Specified by:
        isDeclared in interface Attributes2
        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.

      • isDeclared

        public boolean isDeclared(String qName)
        Returns the current value of the attribute's "declared" flag.
        Specified by:
        isDeclared in interface Attributes2
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.

      • isSpecified

        public boolean isSpecified(int index)
        Returns the current value of an attribute's "specified" flag.
        Specified by:
        isSpecified in interface Attributes2
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        current flag value
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isSpecified

        public boolean isSpecified(String uri,
                           String localName)
        Returns the current value of an attribute's "specified" flag.
        Specified by:
        isSpecified in interface Attributes2
        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        current flag value
        Throws:
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        public boolean isSpecified(String qName)
        Returns the current value of an attribute's "specified" flag.
        Specified by:
        isSpecified in interface Attributes2
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        current flag value
        Throws:
        IllegalArgumentException - When the supplied name does not identify an attribute.

      • setAttributes

        public void setAttributes(Attributes atts)
        Copy an entire Attributes object. The "specified" flags are assigned as true, and "declared" flags as false (except when an attribute's type is not CDATA), unless the object is an Attributes2 object. In that case those flag values are all copied.
        Overrides:
        setAttributes in class AttributesImpl
        Parameters:
        atts - The attributes to copy.
        See Also:
        AttributesImpl.setAttributes(org.xml.sax.Attributes)

      • addAttribute

        public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
        Add an attribute to the end of the list, setting its "specified" flag to true. To set that flag's value to false, use setSpecified(int, boolean).

        Unless the attribute type is CDATA, this attribute is marked as being declared in the DTD. To set that flag's value to true for CDATA attributes, use setDeclared(int, boolean).

        Overrides:
        addAttribute in class AttributesImpl
        Parameters:
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.
        See Also:
        AttributesImpl.addAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • removeAttribute

        public void removeAttribute(int index)
        Description copied from class: AttributesImpl
        Remove an attribute from the list.
        Overrides:
        removeAttribute in class AttributesImpl
        Parameters:
        index - The index of the attribute (zero-based).

      • setDeclared

        public void setDeclared(int index,
                        boolean value)
        Assign a value to the "declared" flag of a specific attribute. This is normally needed only for attributes of type CDATA, including attributes whose type is changed to or from CDATA.
        Parameters:
        index - The index of the attribute (zero-based).
        value - The desired flag value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
        See Also:
        AttributesImpl.setType(int, java.lang.String)

      • setSpecified

        public void setSpecified(int index,
                         boolean value)
        Assign a value to the "specified" flag of a specific attribute. This is the only way this flag can be cleared, except clearing by initialization with the copy constructor.
        Parameters:
        index - The index of the attribute (zero-based).
        value - The desired flag value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.xml.sax.ext (Java Platform SE 8 )

compact2 - org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl


org.xml.sax.ext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See: Description

  • Interface Summary
    Interface Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    Class Description
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.xml.sax.ext (Java Platform SE 8 )

compact3 - org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl


org.xml.sax.ext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See: Description

  • Interface Summary
    Interface Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    Class Description
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DeclHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface DeclHandler

  • All Known Implementing Classes:
    DefaultHandler2

    public interface DeclHandler
    SAX2 extension handler for DTD declaration events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is an optional extension handler for SAX2 to provide more complete information about DTD declarations in an XML document. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

    Note that data-related DTD declarations (unparsed entities and notations) are already reported through the DTDHandler interface.

    If you are using the declaration handler together with a lexical handler, all of the events will occur between the startDTD and the endDTD events.

    To set the DeclHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/declaration-handler and an object implementing this interface (or null) as the value. If the reader does not report declaration events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

    Since:
    SAX 2.0 (extensions 1.0)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void elementDecl(String name, String model)
      Report an element type declaration.
      void externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      void internalEntityDecl(String name, String value)
      Report an internal entity declaration.

    • Method Detail

      • elementDecl

        void elementDecl(String name,
                 String model)
          throws SAXException
        Report an element type declaration.

        The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

        Parameters:
        name - The element type name.
        model - The content model as a normalized string.
        Throws:
        SAXException - The application may raise an exception.

      • attributeDecl

        void attributeDecl(String eName,
                   String aName,
                   String type,
                   String mode,
                   String value)
            throws SAXException
        Report an attribute type declaration.

        Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

        The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

        Parameters:
        eName - The name of the associated element.
        aName - The name of the attribute.
        type - A string representing the attribute type.
        mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
        value - A string representing the attribute's default value, or null if there is none.
        Throws:
        SAXException - The application may raise an exception.

      • internalEntityDecl

        void internalEntityDecl(String name,
                        String value)
                 throws SAXException
        Report an internal entity declaration.

        Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        value - The replacement text of the entity.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • externalEntityDecl

        void externalEntityDecl(String name,
                        String publicId,
                        String systemId)
                 throws SAXException
        Report a parsed external entity declaration.

        Only the effective (first) declaration for each entity will be reported.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultHandler2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Class DefaultHandler2

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler
      • org.xml.sax.ext.DefaultHandler2
  • All Implemented Interfaces:
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler, DeclHandler, EntityResolver2, LexicalHandler

    public class DefaultHandler2
extends DefaultHandler
implements LexicalHandler, DeclHandler, EntityResolver2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions. Except for overriding the original SAX1 resolveEntity() method the added handler methods just return. Subclassers may override everything on a method-by-method basis.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    Note: this class might yet learn that the ContentHandler.setDocumentLocator() call might be passed a Locator2 object, and that the ContentHandler.startElement() call might be passed a Attributes2 object.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultHandler2()
      Constructs a handler which ignores all parsing events.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void elementDecl(String name, String model)
      Report an element type declaration.
      void endCDATA()
      Report the end of a CDATA section.
      void endDTD()
      Report the end of DTD declarations.
      void endEntity(String name)
      Report the end of an entity.
      void externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      InputSource getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      void internalEntityDecl(String name, String value)
      Report an internal entity declaration.
      InputSource resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      void startCDATA()
      Report the start of a CDATA section.
      void startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void startEntity(String name)
      Report the beginning of some internal and external XML entities.

      • Methods inherited from class org.xml.sax.helpers.DefaultHandler

        characters, endDocument, endElement, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping, unparsedEntityDecl, warning

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefaultHandler2

        public DefaultHandler2()
        Constructs a handler which ignores all parsing events.

    • Method Detail

      • startCDATA

        public void startCDATA()
                throws SAXException
        Description copied from interface: LexicalHandler
        Report the start of a CDATA section.

        The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

        Specified by:
        startCDATA in interface LexicalHandler
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.endCDATA()

      • endCDATA

        public void endCDATA()
              throws SAXException
        Description copied from interface: LexicalHandler
        Report the end of a CDATA section.
        Specified by:
        endCDATA in interface LexicalHandler
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.startCDATA()

      • startDTD

        public void startDTD(String name,
                     String publicId,
                     String systemId)
              throws SAXException
        Description copied from interface: LexicalHandler
        Report the start of DTD declarations, if any.

        This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

        Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

        Specified by:
        startDTD in interface LexicalHandler
        Parameters:
        name - The document type name.
        publicId - The declared public identifier for the external DTD subset, or null if none was declared.
        systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.endDTD(), LexicalHandler.startEntity(java.lang.String)

      • endDTD

        public void endDTD()
            throws SAXException
        Description copied from interface: LexicalHandler
        Report the end of DTD declarations.

        This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        Specified by:
        endDTD in interface LexicalHandler
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.startDTD(java.lang.String, java.lang.String, java.lang.String)

      • startEntity

        public void startEntity(String name)
                 throws SAXException
        Description copied from interface: LexicalHandler
        Report the beginning of some internal and external XML entities.

        The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

        General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

        When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

        Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

        Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

        • general entities within attribute values
        • parameter entities within declarations

        These will be silently expanded, with no indication of where the original entity boundaries were.

        Note also that the boundaries of character references (which are not really entities anyway) are not reported.

        All start/endEntity events must be properly nested.

        Specified by:
        startEntity in interface LexicalHandler
        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

      • endEntity

        public void endEntity(String name)
               throws SAXException
        Description copied from interface: LexicalHandler
        Report the end of an entity.
        Specified by:
        endEntity in interface LexicalHandler
        Parameters:
        name - The name of the entity that is ending.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.startEntity(java.lang.String)

      • comment

        public void comment(char[] ch,
                    int start,
                    int length)
             throws SAXException
        Description copied from interface: LexicalHandler
        Report an XML comment anywhere in the document.

        This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

        Specified by:
        comment in interface LexicalHandler
        Parameters:
        ch - An array holding the characters in the comment.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The application may raise an exception.

      • attributeDecl

        public void attributeDecl(String eName,
                          String aName,
                          String type,
                          String mode,
                          String value)
                   throws SAXException
        Description copied from interface: DeclHandler
        Report an attribute type declaration.

        Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

        The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

        Specified by:
        attributeDecl in interface DeclHandler
        Parameters:
        eName - The name of the associated element.
        aName - The name of the attribute.
        type - A string representing the attribute type.
        mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
        value - A string representing the attribute's default value, or null if there is none.
        Throws:
        SAXException - The application may raise an exception.

      • elementDecl

        public void elementDecl(String name,
                        String model)
                 throws SAXException
        Description copied from interface: DeclHandler
        Report an element type declaration.

        The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

        Specified by:
        elementDecl in interface DeclHandler
        Parameters:
        name - The element type name.
        model - The content model as a normalized string.
        Throws:
        SAXException - The application may raise an exception.

      • externalEntityDecl

        public void externalEntityDecl(String name,
                               String publicId,
                               String systemId)
                        throws SAXException
        Description copied from interface: DeclHandler
        Report a parsed external entity declaration.

        Only the effective (first) declaration for each entity will be reported.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Specified by:
        externalEntityDecl in interface DeclHandler
        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        DeclHandler.internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • internalEntityDecl

        public void internalEntityDecl(String name,
                               String value)
                        throws SAXException
        Description copied from interface: DeclHandler
        Report an internal entity declaration.

        Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

        Specified by:
        internalEntityDecl in interface DeclHandler
        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        value - The replacement text of the entity.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • getExternalSubset

        public InputSource getExternalSubset(String name,
                                     String baseURI)
                              throws SAXException,
                                     IOException
        Tells the parser that if no external subset has been declared in the document text, none should be used.
        Specified by:
        getExternalSubset in interface EntityResolver2
        Parameters:
        name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
        baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
        Returns:
        An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        public InputSource resolveEntity(String name,
                                 String publicId,
                                 String baseURI,
                                 String systemId)
                          throws SAXException,
                                 IOException
        Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI. Note that because the older DefaultHandler.resolveEntity(), method is overridden to call this one, this method may sometimes be invoked with null name and baseURI, and with the systemId already absolutized.
        Specified by:
        resolveEntity in interface EntityResolver2
        Parameters:
        name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
        publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
        baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
        systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
        Returns:
        An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
        Invokes EntityResolver2.resolveEntity() with null entity name and base URI. You only need to override that method to use this class.
        Specified by:
        resolveEntity in interface EntityResolver
        Overrides:
        resolveEntity in class DefaultHandler
        Parameters:
        publicId - The public identifier, or null if none is available.
        systemId - The system identifier provided in the XML document.
        Returns:
        The new input source, or null to require the default behaviour.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
        See Also:
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


EntityResolver2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface EntityResolver2

  • All Superinterfaces:
    EntityResolver
    All Known Implementing Classes:
    DefaultHandler2

    public interface EntityResolver2
extends EntityResolver
    Extended interface for mapping external entity references to input sources, or providing a missing external subset. The XMLReader.setEntityResolver() method is used to provide implementations of this interface to parsers. When a parser uses the methods in this interface, the EntityResolver2.resolveEntity() method (in this interface) is used instead of the older (SAX 1.0) EntityResolver.resolveEntity() method.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    If a SAX application requires the customized handling which this interface defines for external entities, it must ensure that it uses an XMLReader with the http://xml.org/sax/features/use-entity-resolver2 feature flag set to true (which is its default value when the feature is recognized). If that flag is unrecognized, or its value is false, or the resolver does not implement this interface, then only the EntityResolver method will be used.

    That supports three categories of application that modify entity resolution. Old Style applications won't know about this interface; they will provide an EntityResolver. Transitional Mode provide an EntityResolver2 and automatically get the benefit of its methods in any systems (parsers or other tools) supporting it, due to polymorphism. Both Old Style and Transitional Mode applications will work with any SAX2 parser. New style applications will fail to run except on SAX2 parsers that support this particular feature. They will insist that feature flag have a value of "true", and the EntityResolver2 implementation they provide might throw an exception if the original SAX 1.0 style entity resolution method is invoked.

    Since:
    SAX 2.0 (extensions 1.1 alpha)
    See Also:
    XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      InputSource getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.

      • Methods inherited from interface org.xml.sax.EntityResolver

        resolveEntity

    • Method Detail

      • getExternalSubset

        InputSource getExternalSubset(String name,
                              String baseURI)
                       throws SAXException,
                              IOException
        Allows applications to provide an external subset for documents that don't explicitly define one. Documents with DOCTYPE declarations that omit an external subset can thus augment the declarations available for validation, entity processing, and attribute processing (normalization, defaulting, and reporting types including ID). This augmentation is reported through the startDTD() method as if the document text had originally included the external subset; this callback is made before any internal subset data or errors are reported.

        This method can also be used with documents that have no DOCTYPE declaration. When the root element is encountered, but no DOCTYPE declaration has been seen, this method is invoked. If it returns a value for the external subset, that root element is declared to be the root element, giving the effect of splicing a DOCTYPE declaration at the end the prolog of a document that could not otherwise be valid. The sequence of parser callbacks in that case logically resembles this:

         ... comments and PIs from the prolog (as usual)
 startDTD ("rootName", source.getPublicId (), source.getSystemId ());
 startEntity ("[dtd]");
 ... declarations, comments, and PIs from the external subset
 endEntity ("[dtd]");
 endDTD ();
 ... then the rest of the document (as usual)
 startElement (..., "rootName", ...);

        Note that the InputSource gets no further resolution. Implementations of this method may wish to invoke resolveEntity() to gain benefits such as use of local caches of DTD entities. Also, this method will never be used by a (non-validating) processor that is not including external parameter entities.

        Uses for this method include facilitating data validation when interoperating with XML processors that would always require undesirable network accesses for external entities, or which for other reasons adopt a "no DTDs" policy. Non-validation motives include forcing documents to include DTDs so that attributes are handled consistently. For example, an XPath processor needs to know which attibutes have type "ID" before it can process a widely used type of reference.

        Warning: Returning an external subset modifies the input document. By providing definitions for general entities, it can make a malformed document appear to be well formed.

        Parameters:
        name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
        baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
        Returns:
        An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        InputSource resolveEntity(String name,
                          String publicId,
                          String baseURI,
                          String systemId)
                   throws SAXException,
                          IOException
        Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution. This method is only called for external entities which have been properly declared. This method provides more flexibility than the EntityResolver interface, supporting implementations of more complex catalogue schemes such as the one defined by the OASIS XML Catalogs specification.

        Parsers configured to use this resolver method will call it to determine the input source to use for any external entity being included because of a reference in the XML text. That excludes the document entity, and any external entity returned by getExternalSubset(). When a (non-validating) processor is configured not to include a class of entities (parameter or general) through use of feature flags, this method is not invoked for such entities.

        Note that the entity naming scheme used here is the same one used in the LexicalHandler, or in the ContentHandler.skippedEntity() method.

        Parameters:
        name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
        publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
        baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
        systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
        Returns:
        An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LexicalHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface LexicalHandler

  • All Known Subinterfaces:
    TransformerHandler
    All Known Implementing Classes:
    DefaultHandler2

    public interface LexicalHandler
    SAX2 extension handler for lexical events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is an optional extension handler for SAX2 to provide lexical information about an XML document, such as comments and CDATA section boundaries. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

    The events in the lexical handler apply to the entire document, not just to the document element, and all lexical handler events must appear between the content handler's startDocument and endDocument events.

    To set the LexicalHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/lexical-handler and an object implementing this interface (or null) as the value. If the reader does not report lexical events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

    Since:
    SAX 2.0 (extensions 1.0)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void endCDATA()
      Report the end of a CDATA section.
      void endDTD()
      Report the end of DTD declarations.
      void endEntity(String name)
      Report the end of an entity.
      void startCDATA()
      Report the start of a CDATA section.
      void startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void startEntity(String name)
      Report the beginning of some internal and external XML entities.

    • Method Detail

      • startDTD

        void startDTD(String name,
              String publicId,
              String systemId)
       throws SAXException
        Report the start of DTD declarations, if any.

        This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

        Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

        Parameters:
        name - The document type name.
        publicId - The declared public identifier for the external DTD subset, or null if none was declared.
        systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        endDTD(), startEntity(java.lang.String)

      • endDTD

        void endDTD()
     throws SAXException
        Report the end of DTD declarations.

        This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        Throws:
        SAXException - The application may raise an exception.
        See Also:
        startDTD(java.lang.String, java.lang.String, java.lang.String)

      • startEntity

        void startEntity(String name)
          throws SAXException
        Report the beginning of some internal and external XML entities.

        The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

        General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

        When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

        Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

        Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

        • general entities within attribute values
        • parameter entities within declarations

        These will be silently expanded, with no indication of where the original entity boundaries were.

        Note also that the boundaries of character references (which are not really entities anyway) are not reported.

        All start/endEntity events must be properly nested.

        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

      • endEntity

        void endEntity(String name)
        throws SAXException
        Report the end of an entity.
        Parameters:
        name - The name of the entity that is ending.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        startEntity(java.lang.String)

      • startCDATA

        void startCDATA()
         throws SAXException
        Report the start of a CDATA section.

        The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

        Throws:
        SAXException - The application may raise an exception.
        See Also:
        endCDATA()

      • endCDATA

        void endCDATA()
       throws SAXException
        Report the end of a CDATA section.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        startCDATA()

      • comment

        void comment(char[] ch,
             int start,
             int length)
      throws SAXException
        Report an XML comment anywhere in the document.

        This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

        Parameters:
        ch - An array holding the characters in the comment.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The application may raise an exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Locator2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface Locator2

  • All Superinterfaces:
    Locator
    All Known Implementing Classes:
    Locator2Impl

    public interface Locator2
extends Locator
    SAX2 extension to augment the entity information provided though a Locator. If an implementation supports this extension, the Locator provided in ContentHandler.setDocumentLocator() will implement this interface, and the http://xml.org/sax/features/use-locator2 feature flag will have the value true.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getEncoding()
      Returns the name of the character encoding for the entity.
      String getXMLVersion()
      Returns the version of XML used for the entity.

      • Methods inherited from interface org.xml.sax.Locator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • Method Detail

      • getXMLVersion

        String getXMLVersion()
        Returns the version of XML used for the entity. This will normally be the identifier from the current entity's <?xml version='...' ...?> declaration, or be defaulted by the parser.
        Returns:
        Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.

      • getEncoding

        String getEncoding()
        Returns the name of the character encoding for the entity. If the encoding was declared externally (for example, in a MIME Content-Type header), that will be the name returned. Else if there was an <?xml ...encoding='...'?> declaration at the start of the document, that encoding name will be returned. Otherwise the encoding will been inferred (normally to be UTF-8, or some UTF-16 variant), and that inferred name will be returned.

        When an InputSource is used to provide an entity's character stream, this method returns the encoding provided in that input stream.

        Note that some recent W3C specifications require that text in some encodings be normalized, using Unicode Normalization Form C, before processing. Such normalization must be performed by applications, and would normally be triggered based on the value returned by this method.

        Encoding names may be those used by the underlying JVM, and comparisons should be case-insensitive.

        Returns:
        Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Locator2Impl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Class Locator2Impl

  • java.lang.Object
    • org.xml.sax.helpers.LocatorImpl
      • org.xml.sax.ext.Locator2Impl
  • All Implemented Interfaces:
    Locator2, Locator

    public class Locator2Impl
extends LocatorImpl
implements Locator2
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    This is not part of core-only SAX2 distributions.

    Since:
    SAX 2.0.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Locator2Impl()
      Construct a new, empty Locator2Impl object.
      Locator2Impl(Locator locator)
      Copy an existing Locator or Locator2 object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getEncoding()
      Returns the current value of the encoding property.
      String getXMLVersion()
      Returns the current value of the version property.
      void setEncoding(String encoding)
      Assigns the current value of the encoding property.
      void setXMLVersion(String version)
      Assigns the current value of the version property.

      • Methods inherited from class org.xml.sax.helpers.LocatorImpl

        getColumnNumber, getLineNumber, getPublicId, getSystemId, setColumnNumber, setLineNumber, setPublicId, setSystemId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.xml.sax.Locator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • Constructor Detail

      • Locator2Impl

        public Locator2Impl()
        Construct a new, empty Locator2Impl object. This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

      • Locator2Impl

        public Locator2Impl(Locator locator)
        Copy an existing Locator or Locator2 object. If the object implements Locator2, values of the encoding and versionstrings are copied, otherwise they set to null.
        Parameters:
        locator - The existing Locator object.

    • Method Detail

      • getXMLVersion

        public String getXMLVersion()
        Returns the current value of the version property.
        Specified by:
        getXMLVersion in interface Locator2
        Returns:
        Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.
        See Also:
        setXMLVersion(java.lang.String)

      • getEncoding

        public String getEncoding()
        Returns the current value of the encoding property.
        Specified by:
        getEncoding in interface Locator2
        Returns:
        Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
        See Also:
        setEncoding(java.lang.String)

      • setXMLVersion

        public void setXMLVersion(String version)
        Assigns the current value of the version property.
        Parameters:
        version - the new "version" value
        See Also:
        getXMLVersion()

      • setEncoding

        public void setEncoding(String encoding)
        Assigns the current value of the encoding property.
        Parameters:
        encoding - the new "encoding" value
        See Also:
        getEncoding()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.xml.sax.ext (Java Platform SE 8 )

org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl


org.xml.sax.ext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See: Description

  • Interface Summary
    Interface Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    Class Description
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.xml.sax.ext Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.xml.sax.ext

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)

Interface Hierarchy

  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • org.xml.sax.ext.DeclHandler
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • org.xml.sax.ext.LexicalHandler
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.xml.sax.ext (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.xml.sax.ext

  • Packages that use org.xml.sax.ext
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
  • Classes in org.xml.sax.ext used by javax.xml.transform.sax
    Class and Description
    LexicalHandler
    SAX2 extension handler for lexical events.
  • Classes in org.xml.sax.ext used by org.xml.sax.ext
    Class and Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ext.Attributes2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.Attributes2

  • Packages that use Attributes2
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of Attributes2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement Attributes2
      Modifier and Type Class and Description
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.ext.Attributes2Impl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.ext.Attributes2Impl

No usage of org.xml.sax.ext.Attributes2Impl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ext.DeclHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.DeclHandler

  • Packages that use DeclHandler
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of DeclHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement DeclHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.ext.DefaultHandler2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.ext.DefaultHandler2

No usage of org.xml.sax.ext.DefaultHandler2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ext.EntityResolver2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.EntityResolver2

  • Packages that use EntityResolver2
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of EntityResolver2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement EntityResolver2
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ext.LexicalHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.LexicalHandler

  • Packages that use LexicalHandler
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of LexicalHandler in javax.xml.transform.sax

      Subinterfaces of LexicalHandler in javax.xml.transform.sax
      Modifier and Type Interface and Description
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
      Methods in javax.xml.transform.sax that return LexicalHandler
      Modifier and Type Method and Description
      LexicalHandler SAXResult.getLexicalHandler()
      Get a SAX2 LexicalHandler for the output.
      Methods in javax.xml.transform.sax with parameters of type LexicalHandler
      Modifier and Type Method and Description
      void SAXResult.setLexicalHandler(LexicalHandler handler)
      Set the SAX2 LexicalHandler for the output.

    • Uses of LexicalHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement LexicalHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.xml.sax.ext.Locator2 (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.Locator2

  • Packages that use Locator2
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of Locator2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement Locator2
      Modifier and Type Class and Description
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.ext.Locator2Impl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.ext.Locator2Impl

No usage of org.xml.sax.ext.Locator2Impl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttributeListImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class AttributeListImpl

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl
  • All Implemented Interfaces:
    AttributeList
    Deprecated.
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.

    public class AttributeListImpl
extends Object
implements AttributeList
    Default implementation for AttributeList.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    AttributeList implements the deprecated SAX1 AttributeList interface, and has been replaced by the new SAX2 AttributesImpl interface.

    This class provides a convenience implementation of the SAX AttributeList interface. This implementation is useful both for SAX parser writers, who can use it to provide attributes to the application, and for SAX application writers, who can use it to create a persistent copy of an element's attribute specifications:

     private AttributeList myatts;

 public void startElement (String name, AttributeList atts)
 {
              // create a persistent copy of the attribute list
              // for use outside this method
   myatts = new AttributeListImpl(atts);
   [...]
 }

    Please note that SAX parsers are not required to use this class to provide an implementation of AttributeList; it is supplied only as an optional convenience. In particular, parser writers are encouraged to invent more efficient implementations.

    Since:
    SAX 1.0
    See Also:
    AttributeList, DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

    • Constructor Summary

      Constructors
      Constructor and Description
      AttributeListImpl()
      Deprecated.
      Create an empty attribute list.
      AttributeListImpl(AttributeList atts)
      Deprecated.
      Construct a persistent copy of an existing attribute list.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void addAttribute(String name, String type, String value)
      Deprecated.
      Add an attribute to an attribute list.
      void clear()
      Deprecated.
      Clear the attribute list.
      int getLength()
      Deprecated.
      Return the number of attributes in the list.
      String getName(int i)
      Deprecated.
      Get the name of an attribute (by position).
      String getType(int i)
      Deprecated.
      Get the type of an attribute (by position).
      String getType(String name)
      Deprecated.
      Get the type of an attribute (by name).
      String getValue(int i)
      Deprecated.
      Get the value of an attribute (by position).
      String getValue(String name)
      Deprecated.
      Get the value of an attribute (by name).
      void removeAttribute(String name)
      Deprecated.
      Remove an attribute from the list.
      void setAttributeList(AttributeList atts)
      Deprecated.
      Set the attribute list, discarding previous contents.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttributeListImpl

        public AttributeListImpl()
        Deprecated.
        Create an empty attribute list.

        This constructor is most useful for parser writers, who will use it to create a single, reusable attribute list that can be reset with the clear method between elements.

        See Also:
        addAttribute(java.lang.String, java.lang.String, java.lang.String), clear()

      • AttributeListImpl

        public AttributeListImpl(AttributeList atts)
        Deprecated.
        Construct a persistent copy of an existing attribute list.

        This constructor is most useful for application writers, who will use it to create a persistent copy of an existing attribute list.

        Parameters:
        atts - The attribute list to copy
        See Also:
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

    • Method Detail

      • setAttributeList

        public void setAttributeList(AttributeList atts)
        Deprecated.
        Set the attribute list, discarding previous contents.

        This method allows an application writer to reuse an attribute list easily.

        Parameters:
        atts - The attribute list to copy.

      • addAttribute

        public void addAttribute(String name,
                         String type,
                         String value)
        Deprecated.
        Add an attribute to an attribute list.

        This method is provided for SAX parser writers, to allow them to build up an attribute list incrementally before delivering it to the application.

        Parameters:
        name - The attribute name.
        type - The attribute type ("NMTOKEN" for an enumeration).
        value - The attribute value (must not be null).
        See Also:
        removeAttribute(java.lang.String), DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • removeAttribute

        public void removeAttribute(String name)
        Deprecated.
        Remove an attribute from the list.

        SAX application writers can use this method to filter an attribute out of an AttributeList. Note that invoking this method will change the length of the attribute list and some of the attribute's indices.

        If the requested attribute is not in the list, this is a no-op.

        Parameters:
        name - The attribute name.
        See Also:
        addAttribute(java.lang.String, java.lang.String, java.lang.String)

      • clear

        public void clear()
        Deprecated.
        Clear the attribute list.

        SAX parser writers can use this method to reset the attribute list between DocumentHandler.startElement events. Normally, it will make sense to reuse the same AttributeListImpl object rather than allocating a new one each time.

        See Also:
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • getLength

        public int getLength()
        Deprecated.
        Return the number of attributes in the list.
        Specified by:
        getLength in interface AttributeList
        Returns:
        The number of attributes in the list.
        See Also:
        AttributeList.getLength()

      • getName

        public String getName(int i)
        Deprecated.
        Get the name of an attribute (by position).
        Specified by:
        getName in interface AttributeList
        Parameters:
        i - The position of the attribute in the list.
        Returns:
        The attribute name as a string, or null if there is no attribute at that position.
        See Also:
        AttributeList.getName(int)

      • getType

        public String getType(int i)
        Deprecated.
        Get the type of an attribute (by position).
        Specified by:
        getType in interface AttributeList
        Parameters:
        i - The position of the attribute in the list.
        Returns:
        The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read), or null if there is no attribute at that position.
        See Also:
        AttributeList.getType(int)

      • getValue

        public String getValue(int i)
        Deprecated.
        Get the value of an attribute (by position).
        Specified by:
        getValue in interface AttributeList
        Parameters:
        i - The position of the attribute in the list.
        Returns:
        The attribute value as a string, or null if there is no attribute at that position.
        See Also:
        AttributeList.getValue(int)

      • getType

        public String getType(String name)
        Deprecated.
        Get the type of an attribute (by name).
        Specified by:
        getType in interface AttributeList
        Parameters:
        name - The attribute name.
        Returns:
        The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read).
        See Also:
        AttributeList.getType(java.lang.String)

      • getValue

        public String getValue(String name)
        Deprecated.
        Get the value of an attribute (by name).
        Specified by:
        getValue in interface AttributeList
        Parameters:
        name - The attribute name.
        Returns:
        The attribute value as a string, or null if no such attribute exists.
        See Also:
        AttributeList.getValue(java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


AttributesImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class AttributesImpl

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl
  • All Implemented Interfaces:
    Attributes
    Direct Known Subclasses:
    Attributes2Impl

    public class AttributesImpl
extends Object
implements Attributes
    Default implementation of the Attributes interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class provides a default implementation of the SAX2 Attributes interface, with the addition of manipulators so that the list can be modified or reused.

    There are two typical uses of this class:

    1. to take a persistent snapshot of an Attributes object in a startElement event; or
    2. to construct or modify an Attributes object in a SAX2 driver or filter.

    This class replaces the now-deprecated SAX1 AttributeListImpl class; in addition to supporting the updated Attributes interface rather than the deprecated AttributeList interface, it also includes a much more efficient implementation using a single array rather than a set of Vectors.

    Since:
    SAX 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      AttributesImpl()
      Construct a new, empty AttributesImpl object.
      AttributesImpl(Attributes atts)
      Copy an existing Attributes object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addAttribute(String uri, String localName, String qName, String type, String value)
      Add an attribute to the end of the list.
      void clear()
      Clear the attribute list for reuse.
      int getIndex(String qName)
      Look up an attribute's index by qualified (prefixed) name.
      int getIndex(String uri, String localName)
      Look up an attribute's index by Namespace name.
      int getLength()
      Return the number of attributes in the list.
      String getLocalName(int index)
      Return an attribute's local name.
      String getQName(int index)
      Return an attribute's qualified (prefixed) name.
      String getType(int index)
      Return an attribute's type by index.
      String getType(String qName)
      Look up an attribute's type by qualified (prefixed) name.
      String getType(String uri, String localName)
      Look up an attribute's type by Namespace-qualified name.
      String getURI(int index)
      Return an attribute's Namespace URI.
      String getValue(int index)
      Return an attribute's value by index.
      String getValue(String qName)
      Look up an attribute's value by qualified (prefixed) name.
      String getValue(String uri, String localName)
      Look up an attribute's value by Namespace-qualified name.
      void removeAttribute(int index)
      Remove an attribute from the list.
      void setAttribute(int index, String uri, String localName, String qName, String type, String value)
      Set an attribute in the list.
      void setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void setLocalName(int index, String localName)
      Set the local name of a specific attribute.
      void setQName(int index, String qName)
      Set the qualified name of a specific attribute.
      void setType(int index, String type)
      Set the type of a specific attribute.
      void setURI(int index, String uri)
      Set the Namespace URI of a specific attribute.
      void setValue(int index, String value)
      Set the value of a specific attribute.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttributesImpl

        public AttributesImpl()
        Construct a new, empty AttributesImpl object.

      • AttributesImpl

        public AttributesImpl(Attributes atts)
        Copy an existing Attributes object.

        This constructor is especially useful inside a startElement event.

        Parameters:
        atts - The existing Attributes object.

    • Method Detail

      • getLength

        public int getLength()
        Return the number of attributes in the list.
        Specified by:
        getLength in interface Attributes
        Returns:
        The number of attributes in the list.
        See Also:
        Attributes.getLength()

      • getURI

        public String getURI(int index)
        Return an attribute's Namespace URI.
        Specified by:
        getURI in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The Namespace URI, the empty string if none is available, or null if the index is out of range.
        See Also:
        Attributes.getURI(int)

      • getLocalName

        public String getLocalName(int index)
        Return an attribute's local name.
        Specified by:
        getLocalName in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's local name, the empty string if none is available, or null if the index if out of range.
        See Also:
        Attributes.getLocalName(int)

      • getQName

        public String getQName(int index)
        Return an attribute's qualified (prefixed) name.
        Specified by:
        getQName in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's qualified name, the empty string if none is available, or null if the index is out of bounds.
        See Also:
        Attributes.getQName(int)

      • getType

        public String getType(int index)
        Return an attribute's type by index.
        Specified by:
        getType in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's type, "CDATA" if the type is unknown, or null if the index is out of bounds.
        See Also:
        Attributes.getType(int)

      • getValue

        public String getValue(int index)
        Return an attribute's value by index.
        Specified by:
        getValue in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's value or null if the index is out of bounds.
        See Also:
        Attributes.getValue(int)

      • getIndex

        public int getIndex(String uri,
                    String localName)
        Look up an attribute's index by Namespace name.

        In many cases, it will be more efficient to look up the name once and use the index query methods rather than using the name query methods repeatedly.

        Specified by:
        getIndex in interface Attributes
        Parameters:
        uri - The attribute's Namespace URI, or the empty string if none is available.
        localName - The attribute's local name.
        Returns:
        The attribute's index, or -1 if none matches.
        See Also:
        Attributes.getIndex(java.lang.String,java.lang.String)

      • getIndex

        public int getIndex(String qName)
        Look up an attribute's index by qualified (prefixed) name.
        Specified by:
        getIndex in interface Attributes
        Parameters:
        qName - The qualified name.
        Returns:
        The attribute's index, or -1 if none matches.
        See Also:
        Attributes.getIndex(java.lang.String)

      • getType

        public String getType(String uri,
                      String localName)
        Look up an attribute's type by Namespace-qualified name.
        Specified by:
        getType in interface Attributes
        Parameters:
        uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
        localName - The local name.
        Returns:
        The attribute's type, or null if there is no matching attribute.
        See Also:
        Attributes.getType(java.lang.String,java.lang.String)

      • getType

        public String getType(String qName)
        Look up an attribute's type by qualified (prefixed) name.
        Specified by:
        getType in interface Attributes
        Parameters:
        qName - The qualified name.
        Returns:
        The attribute's type, or null if there is no matching attribute.
        See Also:
        Attributes.getType(java.lang.String)

      • getValue

        public String getValue(String uri,
                       String localName)
        Look up an attribute's value by Namespace-qualified name.
        Specified by:
        getValue in interface Attributes
        Parameters:
        uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
        localName - The local name.
        Returns:
        The attribute's value, or null if there is no matching attribute.
        See Also:
        Attributes.getValue(java.lang.String,java.lang.String)

      • getValue

        public String getValue(String qName)
        Look up an attribute's value by qualified (prefixed) name.
        Specified by:
        getValue in interface Attributes
        Parameters:
        qName - The qualified name.
        Returns:
        The attribute's value, or null if there is no matching attribute.
        See Also:
        Attributes.getValue(java.lang.String)

      • clear

        public void clear()
        Clear the attribute list for reuse.

        Note that little memory is freed by this call: the current array is kept so it can be reused.

      • setAttributes

        public void setAttributes(Attributes atts)
        Copy an entire Attributes object.

        It may be more efficient to reuse an existing object rather than constantly allocating new ones.

        Parameters:
        atts - The attributes to copy.

      • addAttribute

        public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
        Add an attribute to the end of the list.

        For the sake of speed, this method does no checking to see if the attribute is already in the list: that is the responsibility of the application.

        Parameters:
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.

      • setAttribute

        public void setAttribute(int index,
                         String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
        Set an attribute in the list.

        For the sake of speed, this method does no checking for name conflicts or well-formedness: such checks are the responsibility of the application.

        Parameters:
        index - The index of the attribute (zero-based).
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • removeAttribute

        public void removeAttribute(int index)
        Remove an attribute from the list.
        Parameters:
        index - The index of the attribute (zero-based).
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setURI

        public void setURI(int index,
                   String uri)
        Set the Namespace URI of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        uri - The attribute's Namespace URI, or the empty string for none.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setLocalName

        public void setLocalName(int index,
                         String localName)
        Set the local name of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        localName - The attribute's local name, or the empty string for none.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setQName

        public void setQName(int index,
                     String qName)
        Set the qualified name of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        qName - The attribute's qualified name, or the empty string for none.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setType

        public void setType(int index,
                    String type)
        Set the type of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        type - The attribute's type.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setValue

        public void setValue(int index,
                     String value)
        Set the value of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        value - The attribute's value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - org.xml.sax.helpers (Java Platform SE 8 )

compact2 - org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See: Description

  • Class Summary
    Class Description
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


compact3 - org.xml.sax.helpers (Java Platform SE 8 )

compact3 - org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See: Description

  • Class Summary
    Class Description
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


DefaultHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class DefaultHandler

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler
  • All Implemented Interfaces:
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler
    Direct Known Subclasses:
    DefaultHandler2

    public class DefaultHandler
extends Object
implements EntityResolver, DTDHandler, ContentHandler, ErrorHandler
    Default base class for SAX2 event handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is available as a convenience base class for SAX2 applications: it provides default implementations for all of the callbacks in the four core SAX2 handler classes:

    • EntityResolver
    • DTDHandler
    • ContentHandler
    • ErrorHandler

    Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

    This class replaces the deprecated SAX1 HandlerBase class.

    Since:
    SAX 2.0
    See Also:
    EntityResolver, DTDHandler, ContentHandler, ErrorHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultHandler()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Receive notification of character data inside an element.
      void endDocument()
      Receive notification of the end of the document.
      void endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void endPrefixMapping(String prefix)
      Receive notification of the end of a Namespace mapping.
      void error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration.
      void processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      InputSource resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      void setDocumentLocator(Locator locator)
      Receive a Locator object for document events.
      void skippedEntity(String name)
      Receive notification of a skipped entity.
      void startDocument()
      Receive notification of the beginning of the document.
      void startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void startPrefixMapping(String prefix, String uri)
      Receive notification of the start of a Namespace mapping.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration.
      void warning(SAXParseException e)
      Receive notification of a parser warning.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefaultHandler

        public DefaultHandler()

    • Method Detail

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws IOException,
                                 SAXException
        Resolve an external entity.

        Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

        Specified by:
        resolveEntity in interface EntityResolver
        Parameters:
        publicId - The public identifier, or null if none is available.
        systemId - The system identifier provided in the XML document.
        Returns:
        The new input source, or null to require the default behaviour.
        Throws:
        IOException - If there is an error setting up the new input source.
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)

      • notationDecl

        public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
        Receive notification of a notation declaration.

        By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

        Specified by:
        notationDecl in interface DTDHandler
        Parameters:
        name - The notation name.
        publicId - The notation public identifier, or null if not available.
        systemId - The notation system identifier.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
        Receive notification of an unparsed entity declaration.

        By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

        Specified by:
        unparsedEntityDecl in interface DTDHandler
        Parameters:
        name - The entity name.
        publicId - The entity public identifier, or null if not available.
        systemId - The entity system identifier.
        notationName - The name of the associated notation.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Receive a Locator object for document events.

        By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

        Specified by:
        setDocumentLocator in interface ContentHandler
        Parameters:
        locator - A locator for all SAX document events.
        See Also:
        ContentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Receive notification of the beginning of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

        Specified by:
        startDocument in interface ContentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Receive notification of the end of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

        Specified by:
        endDocument in interface ContentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.endDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
        Receive notification of the start of a Namespace mapping.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each Namespace prefix scope (such as storing the prefix mapping).

        Specified by:
        startPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix being declared.
        uri - The Namespace URI mapped to the prefix.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
                      throws SAXException
        Receive notification of the end of a Namespace mapping.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each prefix mapping.

        Specified by:
        endPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix being declared.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.endPrefixMapping(java.lang.String)

      • startElement

        public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes attributes)
                  throws SAXException
        Receive notification of the start of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

        Specified by:
        startElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
        localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
        qName - The qualified name (with prefix), or the empty string if qualified names are not available.
        attributes - The attributes attached to the element. If there are no attributes, it shall be an empty Attributes object.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endElement

        public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
        Receive notification of the end of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

        Specified by:
        endElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
        localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
        qName - The qualified name (with prefix), or the empty string if qualified names are not available.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Receive notification of character data inside an element.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

        Specified by:
        characters in interface ContentHandler
        Parameters:
        ch - The characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Receive notification of ignorable whitespace in element content.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

        Specified by:
        ignorableWhitespace in interface ContentHandler
        Parameters:
        ch - The whitespace characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Receive notification of a processing instruction.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        Specified by:
        processingInstruction in interface ContentHandler
        Parameters:
        target - The processing instruction target.
        data - The processing instruction data, or null if none is supplied.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Receive notification of a skipped entity.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        Specified by:
        skippedEntity in interface ContentHandler
        Parameters:
        name - The name of the skipped entity.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Receive notification of a parser warning.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

        Specified by:
        warning in interface ErrorHandler
        Parameters:
        e - The warning information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Receive notification of a recoverable parser error.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

        Specified by:
        error in interface ErrorHandler
        Parameters:
        e - The error information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Report a fatal XML parsing error.

        The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

        Specified by:
        fatalError in interface ErrorHandler
        Parameters:
        e - The error information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


LocatorImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class LocatorImpl

  • java.lang.Object
    • org.xml.sax.helpers.LocatorImpl
  • All Implemented Interfaces:
    Locator
    Direct Known Subclasses:
    Locator2Impl

    public class LocatorImpl
extends Object
implements Locator
    Provide an optional convenience implementation of Locator.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is available mainly for application writers, who can use it to make a persistent snapshot of a locator at any point during a document parse:

     Locator locator;
 Locator startloc;

 public void setLocator (Locator locator)
 {
         // note the locator
   this.locator = locator;
 }

 public void startDocument ()
 {
         // save the location of the start of the document
         // for future use.
   Locator startloc = new LocatorImpl(locator);
 }

    Normally, parser writers will not use this class, since it is more efficient to provide location information only when requested, rather than constantly updating a Locator object.

    Since:
    SAX 1.0
    See Also:
    Locator

    • Constructor Summary

      Constructors
      Constructor and Description
      LocatorImpl()
      Zero-argument constructor.
      LocatorImpl(Locator locator)
      Copy constructor.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the saved column number (1-based).
      int getLineNumber()
      Return the saved line number (1-based).
      String getPublicId()
      Return the saved public identifier.
      String getSystemId()
      Return the saved system identifier.
      void setColumnNumber(int columnNumber)
      Set the column number for this locator (1-based).
      void setLineNumber(int lineNumber)
      Set the line number for this locator (1-based).
      void setPublicId(String publicId)
      Set the public identifier for this locator.
      void setSystemId(String systemId)
      Set the system identifier for this locator.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LocatorImpl

        public LocatorImpl()
        Zero-argument constructor.

        This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

      • LocatorImpl

        public LocatorImpl(Locator locator)
        Copy constructor.

        Create a persistent copy of the current state of a locator. When the original locator changes, this copy will still keep the original values (and it can be used outside the scope of DocumentHandler methods).

        Parameters:
        locator - The locator to copy.

    • Method Detail

      • getPublicId

        public String getPublicId()
        Return the saved public identifier.
        Specified by:
        getPublicId in interface Locator
        Returns:
        The public identifier as a string, or null if none is available.
        See Also:
        Locator.getPublicId(), setPublicId(java.lang.String)

      • getSystemId

        public String getSystemId()
        Return the saved system identifier.
        Specified by:
        getSystemId in interface Locator
        Returns:
        The system identifier as a string, or null if none is available.
        See Also:
        Locator.getSystemId(), setSystemId(java.lang.String)

      • getLineNumber

        public int getLineNumber()
        Return the saved line number (1-based).
        Specified by:
        getLineNumber in interface Locator
        Returns:
        The line number as an integer, or -1 if none is available.
        See Also:
        Locator.getLineNumber(), setLineNumber(int)

      • getColumnNumber

        public int getColumnNumber()
        Return the saved column number (1-based).
        Specified by:
        getColumnNumber in interface Locator
        Returns:
        The column number as an integer, or -1 if none is available.
        See Also:
        Locator.getColumnNumber(), setColumnNumber(int)

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this locator.
        Parameters:
        publicId - The new public identifier, or null if none is available.
        See Also:
        getPublicId()

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this locator.
        Parameters:
        systemId - The new system identifier, or null if none is available.
        See Also:
        getSystemId()

      • setLineNumber

        public void setLineNumber(int lineNumber)
        Set the line number for this locator (1-based).
        Parameters:
        lineNumber - The line number, or -1 if none is available.
        See Also:
        getLineNumber()

      • setColumnNumber

        public void setColumnNumber(int columnNumber)
        Set the column number for this locator (1-based).
        Parameters:
        columnNumber - The column number, or -1 if none is available.
        See Also:
        getColumnNumber()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


NamespaceSupport (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class NamespaceSupport

  • java.lang.Object
    • org.xml.sax.helpers.NamespaceSupport

  • public class NamespaceSupport
extends Object
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class encapsulates the logic of Namespace processing: it tracks the declarations currently in force for each context and automatically processes qualified XML names into their Namespace parts; it can also be used in reverse for generating XML qnames from Namespaces.

    Namespace support objects are reusable, but the reset method must be invoked between each session.

    Here is a simple session:

     String parts[] = new String[3];
 NamespaceSupport support = new NamespaceSupport();

 support.pushContext();
 support.declarePrefix("", "http://www.w3.org/1999/xhtml");
 support.declarePrefix("dc", "http://www.purl.org/dc#");

 parts = support.processName("p", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 parts = support.processName("dc:title", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 support.popContext();

    Note that this class is optimized for the use case where most elements do not contain Namespace declarations: if the same prefix/URI mapping is repeated for each context (for example), this class will be somewhat less efficient.

    Although SAX drivers (parsers) may choose to use this class to implement namespace handling, they are not required to do so. Applications must track namespace information themselves if they want to use namespace information.

    Since:
    SAX 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String NSDECL
      The namespace declaration URI as a constant.
      static String XMLNS
      The XML Namespace URI as a constant.

    • Constructor Summary

      Constructors
      Constructor and Description
      NamespaceSupport()
      Create a new Namespace support object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean declarePrefix(String prefix, String uri)
      Declare a Namespace prefix.
      Enumeration getDeclaredPrefixes()
      Return an enumeration of all prefixes declared in this context.
      String getPrefix(String uri)
      Return one of the prefixes mapped to a Namespace URI.
      Enumeration getPrefixes()
      Return an enumeration of all prefixes whose declarations are active in the current context.
      Enumeration getPrefixes(String uri)
      Return an enumeration of all prefixes for a given URI whose declarations are active in the current context.
      String getURI(String prefix)
      Look up a prefix and get the currently-mapped Namespace URI.
      boolean isNamespaceDeclUris()
      Returns true if namespace declaration attributes are placed into a namespace.
      void popContext()
      Revert to the previous Namespace context.
      String[] processName(String qName, String[] parts, boolean isAttribute)
      Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().
      void pushContext()
      Start a new Namespace context.
      void reset()
      Reset this Namespace support object for reuse.
      void setNamespaceDeclUris(boolean value)
      Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName().

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • XMLNS

        public static final String XMLNS
        The XML Namespace URI as a constant. The value is http://www.w3.org/XML/1998/namespace as defined in the "Namespaces in XML" * recommendation.

        This is the Namespace URI that is automatically mapped to the "xml" prefix.

        See Also:
        Constant Field Values

      • NSDECL

        public static final String NSDECL
        The namespace declaration URI as a constant. The value is http://www.w3.org/xmlns/2000/, as defined in a backwards-incompatible erratum to the "Namespaces in XML" recommendation. Because that erratum postdated SAX2, SAX2 defaults to the original recommendation, and does not normally use this URI.

        This is the Namespace URI that is optionally applied to xmlns and xmlns:* attributes, which are used to declare namespaces.

        Since:
        SAX 2.1alpha
        See Also:
        setNamespaceDeclUris(boolean), isNamespaceDeclUris(), Constant Field Values

    • Constructor Detail

      • NamespaceSupport

        public NamespaceSupport()
        Create a new Namespace support object.

    • Method Detail

      • reset

        public void reset()
        Reset this Namespace support object for reuse.

        It is necessary to invoke this method before reusing the Namespace support object for a new session. If namespace declaration URIs are to be supported, that flag must also be set to a non-default value.

        See Also:
        setNamespaceDeclUris(boolean)

      • pushContext

        public void pushContext()
        Start a new Namespace context. The new context will automatically inherit the declarations of its parent context, but it will also keep track of which declarations were made within this context.

        Event callback code should start a new context once per element. This means being ready to call this in either of two places. For elements that don't include namespace declarations, the ContentHandler.startElement() callback is the right place. For elements with such a declaration, it'd done in the first ContentHandler.startPrefixMapping() callback. A boolean flag can be used to track whether a context has been started yet. When either of those methods is called, it checks the flag to see if a new context needs to be started. If so, it starts the context and sets the flag. After ContentHandler.startElement() does that, it always clears the flag.

        Normally, SAX drivers would push a new context at the beginning of each XML element. Then they perform a first pass over the attributes to process all namespace declarations, making ContentHandler.startPrefixMapping() callbacks. Then a second pass is made, to determine the namespace-qualified names for all attributes and for the element name. Finally all the information for the ContentHandler.startElement() callback is available, so it can then be made.

        The Namespace support object always starts with a base context already in force: in this context, only the "xml" prefix is declared.

        See Also:
        ContentHandler, popContext()

      • popContext

        public void popContext()
        Revert to the previous Namespace context.

        Normally, you should pop the context at the end of each XML element. After popping the context, all Namespace prefix mappings that were previously in force are restored.

        You must not attempt to declare additional Namespace prefixes after popping a context, unless you push another context first.

        See Also:
        pushContext()

      • declarePrefix

        public boolean declarePrefix(String prefix,
                             String uri)
        Declare a Namespace prefix. All prefixes must be declared before they are referenced. For example, a SAX driver (parser) would scan an element's attributes in two passes: first for namespace declarations, then a second pass using processName() to interpret prefixes against (potentially redefined) prefixes.

        This method declares a prefix in the current Namespace context; the prefix will remain in force until this context is popped, unless it is shadowed in a descendant context.

        To declare the default element Namespace, use the empty string as the prefix.

        Note that there is an asymmetry in this library: getPrefix will not return the "" prefix, even if you have declared a default element namespace. To check for a default namespace, you have to look it up explicitly using getURI. This asymmetry exists to make it easier to look up prefixes for attribute names, where the default prefix is not allowed.

        Parameters:
        prefix - The prefix to declare, or the empty string to indicate the default element namespace. This may never have the value "xml" or "xmlns".
        uri - The Namespace URI to associate with the prefix.
        Returns:
        true if the prefix was legal, false otherwise
        See Also:
        processName(java.lang.String, java.lang.String[], boolean),
getURI(java.lang.String),
getPrefix(java.lang.String)

      • processName

        public String[] processName(String qName,
                            String[] parts,
                            boolean isAttribute)
        Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().

        This method processes a raw XML qualified name in the current context by removing the prefix and looking it up among the prefixes currently declared. The return value will be the array supplied by the caller, filled in as follows:

        parts[0]
        The Namespace URI, or an empty string if none is in use.
        parts[1]
        The local name (without prefix).
        parts[2]
        The original raw name.

        All of the strings in the array will be internalized. If the raw name has a prefix that has not been declared, then the return value will be null.

        Note that attribute names are processed differently than element names: an unprefixed element name will receive the default Namespace (if any), while an unprefixed attribute name will not.

        Parameters:
        qName - The XML qualified name to be processed.
        parts - An array supplied by the caller, capable of holding at least three members.
        isAttribute - A flag indicating whether this is an attribute name (true) or an element name (false).
        Returns:
        The supplied array holding three internalized strings representing the Namespace URI (or empty string), the local name, and the XML qualified name; or null if there is an undeclared prefix.
        See Also:
        declarePrefix(java.lang.String, java.lang.String), String.intern()

      • getURI

        public String getURI(String prefix)
        Look up a prefix and get the currently-mapped Namespace URI.

        This method looks up the prefix in the current context. Use the empty string ("") for the default Namespace.

        Parameters:
        prefix - The prefix to look up.
        Returns:
        The associated Namespace URI, or null if the prefix is undeclared in this context.
        See Also:
        getPrefix(java.lang.String), getPrefixes()

      • getPrefixes

        public Enumeration getPrefixes()
        Return an enumeration of all prefixes whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

        Note: if there is a default prefix, it will not be returned in this enumeration; check for the default prefix using the getURI with an argument of "".

        Returns:
        An enumeration of prefixes (never empty).
        See Also:
        getDeclaredPrefixes(), getURI(java.lang.String)

      • getPrefix

        public String getPrefix(String uri)
        Return one of the prefixes mapped to a Namespace URI.

        If more than one prefix is currently mapped to the same URI, this method will make an arbitrary selection; if you want all of the prefixes, use the getPrefixes() method instead.

        Note: this will never return the empty (default) prefix; to check for a default prefix, use the getURI method with an argument of "".

        Parameters:
        uri - the namespace URI
        Returns:
        one of the prefixes currently mapped to the URI supplied, or null if none is mapped or if the URI is assigned to the default namespace
        See Also:
        getPrefixes(java.lang.String), getURI(java.lang.String)

      • getPrefixes

        public Enumeration getPrefixes(String uri)
        Return an enumeration of all prefixes for a given URI whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

        This method returns prefixes mapped to a specific Namespace URI. The xml: prefix will be included. If you want only one prefix that's mapped to the Namespace URI, and you don't care which one you get, use the getPrefix method instead.

        Note: the empty (default) prefix is never included in this enumeration; to check for the presence of a default Namespace, use the getURI method with an argument of "".

        Parameters:
        uri - The Namespace URI.
        Returns:
        An enumeration of prefixes (never empty).
        See Also:
        getPrefix(java.lang.String),
getDeclaredPrefixes(),
getURI(java.lang.String)

      • getDeclaredPrefixes

        public Enumeration getDeclaredPrefixes()
        Return an enumeration of all prefixes declared in this context.

        The empty (default) prefix will be included in this enumeration; note that this behaviour differs from that of getPrefix(java.lang.String) and getPrefixes().

        Returns:
        An enumeration of all prefixes declared in this context.
        See Also:
        getPrefixes(), getURI(java.lang.String)

      • setNamespaceDeclUris

        public void setNamespaceDeclUris(boolean value)
        Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName(). This may only be changed before any contexts have been pushed.
        Throws:
        IllegalStateException - when attempting to set this after any context has been pushed.
        Since:
        SAX 2.1alpha

      • isNamespaceDeclUris

        public boolean isNamespaceDeclUris()
        Returns true if namespace declaration attributes are placed into a namespace. This behavior is not the default.
        Since:
        SAX 2.1alpha
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.xml.sax.helpers (Java Platform SE 8 )

org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See: Description

  • Class Summary
    Class Description
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


org.xml.sax.helpers Class Hierarchy (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.xml.sax.helpers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
    • org.xml.sax.helpers.NamespaceSupport
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Package org.xml.sax.helpers (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.xml.sax.helpers

  • Packages that use org.xml.sax.helpers
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
  • Classes in org.xml.sax.helpers used by java.beans
    Class and Description
    DefaultHandler
    Default base class for SAX2 event handlers.
  • Classes in org.xml.sax.helpers used by javax.xml.parsers
    Class and Description
    DefaultHandler
    Default base class for SAX2 event handlers.
  • Classes in org.xml.sax.helpers used by org.xml.sax.ext
    Class and Description
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParserAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class ParserAdapter

  • java.lang.Object
    • org.xml.sax.helpers.ParserAdapter
  • All Implemented Interfaces:
    DocumentHandler, XMLReader

    public class ParserAdapter
extends Object
implements XMLReader, DocumentHandler
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class wraps a SAX1 Parser and makes it act as a SAX2 XMLReader, with feature, property, and Namespace support. Note that it is not possible to report skippedEntity events, since SAX1 does not make that information available.

    This adapter does not test for duplicate Namespace-qualified attribute names.

    Since:
    SAX 2.0
    Version:
    2.0.1 (sax2r2)
    See Also:
    XMLReaderAdapter, XMLReader, Parser

    • Constructor Summary

      Constructors
      Constructor and Description
      ParserAdapter()
      Construct a new parser adapter.
      ParserAdapter(Parser parser)
      Construct a new parser adapter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void endDocument()
      Adapter implementation method; do not call.
      void endElement(String qName)
      Adapter implementation method; do not call.
      ContentHandler getContentHandler()
      Return the current content handler.
      DTDHandler getDTDHandler()
      Return the current DTD handler.
      EntityResolver getEntityResolver()
      Return the current entity resolver.
      ErrorHandler getErrorHandler()
      Return the current error handler.
      boolean getFeature(String name)
      Check a parser feature flag.
      Object getProperty(String name)
      Get a parser property.
      void ignorableWhitespace(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void parse(InputSource input)
      Parse an XML document.
      void parse(String systemId)
      Parse an XML document.
      void processingInstruction(String target, String data)
      Adapter implementation method; do not call.
      void setContentHandler(ContentHandler handler)
      Set the content handler.
      void setDocumentLocator(Locator locator)
      Adapter implementation method; do not call.
      void setDTDHandler(DTDHandler handler)
      Set the DTD handler.
      void setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Set the error handler.
      void setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void setProperty(String name, Object value)
      Set a parser property.
      void startDocument()
      Adapter implementation method; do not call.
      void startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ParserAdapter

        public ParserAdapter()
              throws SAXException
        Construct a new parser adapter.

        Use the "org.xml.sax.parser" property to locate the embedded SAX1 driver.

        Throws:
        SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.parser property is not specified.

      • ParserAdapter

        public ParserAdapter(Parser parser)
        Construct a new parser adapter.

        Note that the embedded parser cannot be changed once the adapter is created; to embed a different parser, allocate a new ParserAdapter.

        Parameters:
        parser - The SAX1 parser to embed.
        Throws:
        NullPointerException - If the parser parameter is null.

    • Method Detail

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set a feature flag for the parser.

        The only features recognized are namespaces and namespace-prefixes.

        Specified by:
        setFeature in interface XMLReader
        Parameters:
        name - The feature name, as a complete URI.
        value - The requested feature value.
        Throws:
        SAXNotRecognizedException - If the feature can't be assigned or retrieved.
        SAXNotSupportedException - If the feature can't be assigned that value.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Check a parser feature flag.

        The only features recognized are namespaces and namespace-prefixes.

        Specified by:
        getFeature in interface XMLReader
        Parameters:
        name - The feature name, as a complete URI.
        Returns:
        The current feature value.
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - If the feature is not currently readable.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • setProperty

        public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set a parser property.

        No properties are currently recognized.

        Specified by:
        setProperty in interface XMLReader
        Parameters:
        name - The property name.
        value - The property value.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - If the property can't be assigned that value.
        See Also:
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Get a parser property.

        No properties are currently recognized.

        Specified by:
        getProperty in interface XMLReader
        Parameters:
        name - The property name.
        Returns:
        The property value.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - If the property value is not currently readable.
        See Also:
        XMLReader.getProperty(java.lang.String)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Set the entity resolver.
        Specified by:
        setEntityResolver in interface XMLReader
        Parameters:
        resolver - The new entity resolver.
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getEntityResolver

        public EntityResolver getEntityResolver()
        Return the current entity resolver.
        Specified by:
        getEntityResolver in interface XMLReader
        Returns:
        The current entity resolver, or null if none was supplied.
        See Also:
        XMLReader.getEntityResolver()

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Set the DTD handler.
        Specified by:
        setDTDHandler in interface XMLReader
        Parameters:
        handler - the new DTD handler
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getDTDHandler

        public DTDHandler getDTDHandler()
        Return the current DTD handler.
        Specified by:
        getDTDHandler in interface XMLReader
        Returns:
        the current DTD handler, or null if none was supplied
        See Also:
        XMLReader.getEntityResolver()

      • setContentHandler

        public void setContentHandler(ContentHandler handler)
        Set the content handler.
        Specified by:
        setContentHandler in interface XMLReader
        Parameters:
        handler - the new content handler
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getContentHandler

        public ContentHandler getContentHandler()
        Return the current content handler.
        Specified by:
        getContentHandler in interface XMLReader
        Returns:
        The current content handler, or null if none was supplied.
        See Also:
        XMLReader.getEntityResolver()

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Set the error handler.
        Specified by:
        setErrorHandler in interface XMLReader
        Parameters:
        handler - The new error handler.
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getErrorHandler

        public ErrorHandler getErrorHandler()
        Return the current error handler.
        Specified by:
        getErrorHandler in interface XMLReader
        Returns:
        The current error handler, or null if none was supplied.
        See Also:
        XMLReader.getEntityResolver()

      • parse

        public void parse(String systemId)
           throws IOException,
                  SAXException
        Parse an XML document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        systemId - The absolute URL of the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

      • parse

        public void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse an XML document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        input - An input source for the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Adapter implementation method; do not call. Adapt a SAX1 document locator event.
        Specified by:
        setDocumentLocator in interface DocumentHandler
        Parameters:
        locator - A document locator.
        See Also:
        ContentHandler.setDocumentLocator(org.xml.sax.Locator)

      • startDocument

        public void startDocument()
                   throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 start document event.
        Specified by:
        startDocument in interface DocumentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 end document event.
        Specified by:
        endDocument in interface DocumentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.endDocument()

      • startElement

        public void startElement(String qName,
                         AttributeList qAtts)
                  throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 startElement event.

        If necessary, perform Namespace processing.

        Specified by:
        startElement in interface DocumentHandler
        Parameters:
        qName - The qualified (prefixed) name.
        qAtts - The XML attribute list (with qnames).
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.endElement(java.lang.String), AttributeList

      • endElement

        public void endElement(String qName)
                throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 end element event.
        Specified by:
        endElement in interface DocumentHandler
        Parameters:
        qName - The qualified (prefixed) name.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.endElement(java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 characters event.
        Specified by:
        characters in interface DocumentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 ignorable whitespace event.
        Specified by:
        ignorableWhitespace in interface DocumentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 processing instruction event.
        Specified by:
        processingInstruction in interface DocumentHandler
        Parameters:
        target - The processing instruction target.
        data - The remainder of the processing instruction
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.processingInstruction(java.lang.String, java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


ParserFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class ParserFactory

  • java.lang.Object
    • org.xml.sax.helpers.ParserFactory
  • Deprecated.
    This class works with the deprecated Parser interface.

    public class ParserFactory
extends Object
    Java-specific class for dynamically loading SAX parsers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    Note: This class is designed to work with the now-deprecated SAX1 Parser class. SAX2 applications should use XMLReaderFactory instead.

    ParserFactory is not part of the platform-independent definition of SAX; it is an additional convenience class designed specifically for Java XML application writers. SAX applications can use the static methods in this class to allocate a SAX parser dynamically at run-time based either on the value of the `org.xml.sax.parser' system property or on a string containing the class name.

    Note that the application still requires an XML parser that implements SAX1.

    Since:
    SAX 1.0
    Version:
    2.0.1 (sax2r2)

    • Method Summary

      All Methods Static Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      static Parser makeParser()
      Deprecated.
      Create a new SAX parser using the `org.xml.sax.parser' system property.
      static Parser makeParser(String className)
      Deprecated.
      Create a new SAX parser object using the class name provided.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • makeParser

        public static Parser makeParser()
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                NullPointerException,
                                ClassCastException
        Deprecated.
        Create a new SAX parser using the `org.xml.sax.parser' system property.

        The named class must exist and must implement the Parser interface.

        Throws:
        NullPointerException - There is no value for the `org.xml.sax.parser' system property.
        ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
        IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
        InstantiationException - The SAX parser class was found but could not be instantiated.
        ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
        See Also:
        makeParser(java.lang.String), Parser

      • makeParser

        public static Parser makeParser(String className)
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                ClassCastException
        Deprecated.
        Create a new SAX parser object using the class name provided.

        The named class must exist and must implement the Parser interface.

        Parameters:
        className - A string containing the name of the SAX parser class.
        Throws:
        ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
        IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
        InstantiationException - The SAX parser class was found but could not be instantiated.
        ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
        See Also:
        makeParser(), Parser
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLFilterImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class XMLFilterImpl

  • java.lang.Object
    • org.xml.sax.helpers.XMLFilterImpl
  • All Implemented Interfaces:
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler, XMLFilter, XMLReader

    public class XMLFilterImpl
extends Object
implements XMLFilter, EntityResolver, DTDHandler, ContentHandler, ErrorHandler
    Base class for deriving an XML filter.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is designed to sit between an XMLReader and the client application's event handlers. By default, it does nothing but pass requests up to the reader and events on to the handlers unmodified, but subclasses can override specific methods to modify the event stream or the configuration requests as they pass through.

    Since:
    SAX 2.0
    See Also:
    XMLFilter, XMLReader, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLFilterImpl()
      Construct an empty XML filter, with no parent.
      XMLFilterImpl(XMLReader parent)
      Construct an XML filter with the specified parent.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Filter a character data event.
      void endDocument()
      Filter an end document event.
      void endElement(String uri, String localName, String qName)
      Filter an end element event.
      void endPrefixMapping(String prefix)
      Filter an end Namespace prefix mapping event.
      void error(SAXParseException e)
      Filter an error event.
      void fatalError(SAXParseException e)
      Filter a fatal error event.
      ContentHandler getContentHandler()
      Get the content event handler.
      DTDHandler getDTDHandler()
      Get the current DTD event handler.
      EntityResolver getEntityResolver()
      Get the current entity resolver.
      ErrorHandler getErrorHandler()
      Get the current error event handler.
      boolean getFeature(String name)
      Look up the value of a feature.
      XMLReader getParent()
      Get the parent reader.
      Object getProperty(String name)
      Look up the value of a property.
      void ignorableWhitespace(char[] ch, int start, int length)
      Filter an ignorable whitespace event.
      void notationDecl(String name, String publicId, String systemId)
      Filter a notation declaration event.
      void parse(InputSource input)
      Parse a document.
      void parse(String systemId)
      Parse a document.
      void processingInstruction(String target, String data)
      Filter a processing instruction event.
      InputSource resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      void setContentHandler(ContentHandler handler)
      Set the content event handler.
      void setDocumentLocator(Locator locator)
      Filter a new document locator event.
      void setDTDHandler(DTDHandler handler)
      Set the DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Set the error event handler.
      void setFeature(String name, boolean value)
      Set the value of a feature.
      void setParent(XMLReader parent)
      Set the parent reader.
      void setProperty(String name, Object value)
      Set the value of a property.
      void skippedEntity(String name)
      Filter a skipped entity event.
      void startDocument()
      Filter a start document event.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void startPrefixMapping(String prefix, String uri)
      Filter a start Namespace prefix mapping event.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Filter an unparsed entity declaration event.
      void warning(SAXParseException e)
      Filter a warning event.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XMLFilterImpl

        public XMLFilterImpl()
        Construct an empty XML filter, with no parent.

        This filter will have no parent: you must assign a parent before you start a parse or do any configuration with setFeature or setProperty, unless you use this as a pure event consumer rather than as an XMLReader.

        See Also:
        XMLReader.setFeature(java.lang.String, boolean),
XMLReader.setProperty(java.lang.String, java.lang.Object),
setParent(org.xml.sax.XMLReader)

      • XMLFilterImpl

        public XMLFilterImpl(XMLReader parent)
        Construct an XML filter with the specified parent.
        See Also:
        setParent(org.xml.sax.XMLReader), getParent()

    • Method Detail

      • setParent

        public void setParent(XMLReader parent)
        Set the parent reader.

        This is the XMLReader from which this filter will obtain its events and to which it will pass its configuration requests. The parent may itself be another filter.

        If there is no parent reader set, any attempt to parse or to set or get a feature or property will fail.

        Specified by:
        setParent in interface XMLFilter
        Parameters:
        parent - The parent XML reader.
        See Also:
        getParent()

      • getParent

        public XMLReader getParent()
        Get the parent reader.
        Specified by:
        getParent in interface XMLFilter
        Returns:
        The parent XML reader, or null if none is set.
        See Also:
        setParent(org.xml.sax.XMLReader)

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set the value of a feature.

        This will always fail if the parent is null.

        Specified by:
        setFeature in interface XMLReader
        Parameters:
        name - The feature name.
        value - The requested feature value.
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the feature name but cannot set the requested value.
        See Also:
        XMLReader.getFeature(java.lang.String)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature.

        This will always fail if the parent is null.

        Specified by:
        getFeature in interface XMLReader
        Parameters:
        name - The feature name.
        Returns:
        The current value of the feature.
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the feature name but cannot determine its value at this time.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • setProperty

        public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        This will always fail if the parent is null.

        Specified by:
        setProperty in interface XMLReader
        Parameters:
        name - The property name.
        value - The requested property value.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the property name but cannot set the requested value.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.
        Specified by:
        getProperty in interface XMLReader
        Parameters:
        name - The property name.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the property name but cannot determine its value at this time.
        See Also:
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Set the entity resolver.
        Specified by:
        setEntityResolver in interface XMLReader
        Parameters:
        resolver - The new entity resolver.
        See Also:
        XMLReader.getEntityResolver()

      • getEntityResolver

        public EntityResolver getEntityResolver()
        Get the current entity resolver.
        Specified by:
        getEntityResolver in interface XMLReader
        Returns:
        The current entity resolver, or null if none was set.
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Set the DTD event handler.
        Specified by:
        setDTDHandler in interface XMLReader
        Parameters:
        handler - the new DTD handler
        See Also:
        XMLReader.getDTDHandler()

      • getDTDHandler

        public DTDHandler getDTDHandler()
        Get the current DTD event handler.
        Specified by:
        getDTDHandler in interface XMLReader
        Returns:
        The current DTD handler, or null if none was set.
        See Also:
        XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

      • setContentHandler

        public void setContentHandler(ContentHandler handler)
        Set the content event handler.
        Specified by:
        setContentHandler in interface XMLReader
        Parameters:
        handler - the new content handler
        See Also:
        XMLReader.getContentHandler()

      • getContentHandler

        public ContentHandler getContentHandler()
        Get the content event handler.
        Specified by:
        getContentHandler in interface XMLReader
        Returns:
        The current content handler, or null if none was set.
        See Also:
        XMLReader.setContentHandler(org.xml.sax.ContentHandler)

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Set the error event handler.
        Specified by:
        setErrorHandler in interface XMLReader
        Parameters:
        handler - the new error handler
        See Also:
        XMLReader.getErrorHandler()

      • getErrorHandler

        public ErrorHandler getErrorHandler()
        Get the current error event handler.
        Specified by:
        getErrorHandler in interface XMLReader
        Returns:
        The current error handler, or null if none was set.
        See Also:
        XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(InputSource input)
           throws SAXException,
                  IOException
        Parse a document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        input - The input source for the document entity.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        InputSource,
XMLReader.parse(java.lang.String),
XMLReader.setEntityResolver(org.xml.sax.EntityResolver),
XMLReader.setDTDHandler(org.xml.sax.DTDHandler),
XMLReader.setContentHandler(org.xml.sax.ContentHandler),
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(String systemId)
           throws SAXException,
                  IOException
        Parse a document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        systemId - The system identifier as a fully-qualified URI.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        XMLReader.parse(org.xml.sax.InputSource)

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
        Filter an external entity resolution.
        Specified by:
        resolveEntity in interface EntityResolver
        Parameters:
        publicId - The entity's public identifier, or null.
        systemId - The entity's system identifier.
        Returns:
        A new InputSource or null for the default.
        Throws:
        SAXException - The client may throw an exception during processing.
        IOException - The client may throw an I/O-related exception while obtaining the new InputSource.
        See Also:
        InputSource

      • notationDecl

        public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
        Filter a notation declaration event.
        Specified by:
        notationDecl in interface DTDHandler
        Parameters:
        name - The notation name.
        publicId - The notation's public identifier, or null.
        systemId - The notation's system identifier, or null.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
        Filter an unparsed entity declaration event.
        Specified by:
        unparsedEntityDecl in interface DTDHandler
        Parameters:
        name - The entity name.
        publicId - The entity's public identifier, or null.
        systemId - The entity's system identifier, or null.
        notationName - The name of the associated notation.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Filter a new document locator event.
        Specified by:
        setDocumentLocator in interface ContentHandler
        Parameters:
        locator - The document locator.
        See Also:
        Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Filter a start document event.
        Specified by:
        startDocument in interface ContentHandler
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.endDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Filter an end document event.
        Specified by:
        endDocument in interface ContentHandler
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.startDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
        Filter a start Namespace prefix mapping event.
        Specified by:
        startPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix.
        uri - The Namespace URI.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.endPrefixMapping(java.lang.String), ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
                      throws SAXException
        Filter an end Namespace prefix mapping event.
        Specified by:
        endPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String), ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • startElement

        public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
        Filter a start element event.
        Specified by:
        startElement in interface ContentHandler
        Parameters:
        uri - The element's Namespace URI, or the empty string.
        localName - The element's local name, or the empty string.
        qName - The element's qualified (prefixed) name, or the empty string.
        atts - The element's attributes.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

      • endElement

        public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
        Filter an end element event.
        Specified by:
        endElement in interface ContentHandler
        Parameters:
        uri - The element's Namespace URI, or the empty string.
        localName - The element's local name, or the empty string.
        qName - The element's qualified (prefixed) name, or the empty string.
        Throws:
        SAXException - The client may throw an exception during processing.

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Filter a character data event.
        Specified by:
        characters in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Filter an ignorable whitespace event.
        Specified by:
        ignorableWhitespace in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.characters(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Filter a processing instruction event.
        Specified by:
        processingInstruction in interface ContentHandler
        Parameters:
        target - The processing instruction target.
        data - The text following the target.
        Throws:
        SAXException - The client may throw an exception during processing.

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Filter a skipped entity event.
        Specified by:
        skippedEntity in interface ContentHandler
        Parameters:
        name - The name of the skipped entity.
        Throws:
        SAXException - The client may throw an exception during processing.

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Filter a warning event.
        Specified by:
        warning in interface ErrorHandler
        Parameters:
        e - The warning as an exception.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Filter an error event.
        Specified by:
        error in interface ErrorHandler
        Parameters:
        e - The error as an exception.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Filter a fatal error event.
        Specified by:
        fatalError in interface ErrorHandler
        Parameters:
        e - The error as an exception.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLReaderAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class XMLReaderAdapter

  • java.lang.Object
    • org.xml.sax.helpers.XMLReaderAdapter
  • All Implemented Interfaces:
    ContentHandler, Parser

    public class XMLReaderAdapter
extends Object
implements Parser, ContentHandler
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class wraps a SAX2 XMLReader and makes it act as a SAX1 Parser. The XMLReader must support a true value for the http://xml.org/sax/features/namespace-prefixes property or parsing will fail with a SAXException; if the XMLReader supports a false value for the http://xml.org/sax/features/namespaces property, that will also be used to improve efficiency.

    Since:
    SAX 2.0
    See Also:
    Parser, XMLReader

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLReaderAdapter()
      Create a new adapter.
      XMLReaderAdapter(XMLReader xmlReader)
      Create a new adapter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Adapt a SAX2 characters event.
      void endDocument()
      End document event.
      void endElement(String uri, String localName, String qName)
      Adapt a SAX2 end element event.
      void endPrefixMapping(String prefix)
      Adapt a SAX2 end prefix mapping event.
      void ignorableWhitespace(char[] ch, int start, int length)
      Adapt a SAX2 ignorable whitespace event.
      void parse(InputSource input)
      Parse the document.
      void parse(String systemId)
      Parse the document.
      void processingInstruction(String target, String data)
      Adapt a SAX2 processing instruction event.
      void setDocumentHandler(DocumentHandler handler)
      Register the SAX1 document event handler.
      void setDocumentLocator(Locator locator)
      Set a document locator.
      void setDTDHandler(DTDHandler handler)
      Register the DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Register the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Register the error event handler.
      void setLocale(Locale locale)
      Set the locale for error reporting.
      void skippedEntity(String name)
      Adapt a SAX2 skipped entity event.
      void startDocument()
      Start document event.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void startPrefixMapping(String prefix, String uri)
      Adapt a SAX2 start prefix mapping event.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XMLReaderAdapter

        public XMLReaderAdapter()
                 throws SAXException
        Create a new adapter.

        Use the "org.xml.sax.driver" property to locate the SAX2 driver to embed.

        Throws:
        SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.driver property is not specified.

      • XMLReaderAdapter

        public XMLReaderAdapter(XMLReader xmlReader)
        Create a new adapter.

        Create a new adapter, wrapped around a SAX2 XMLReader. The adapter will make the XMLReader act like a SAX1 Parser.

        Parameters:
        xmlReader - The SAX2 XMLReader to wrap.
        Throws:
        NullPointerException - If the argument is null.

    • Method Detail

      • setLocale

        public void setLocale(Locale locale)
               throws SAXException
        Set the locale for error reporting.

        This is not supported in SAX2, and will always throw an exception.

        Specified by:
        setLocale in interface Parser
        Parameters:
        locale - the locale for error reporting.
        Throws:
        SAXException - Thrown unless overridden.
        See Also:
        Parser.setLocale(java.util.Locale)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Register the entity resolver.
        Specified by:
        setEntityResolver in interface Parser
        Parameters:
        resolver - The new resolver.
        See Also:
        Parser.setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Register the DTD event handler.
        Specified by:
        setDTDHandler in interface Parser
        Parameters:
        handler - The new DTD event handler.
        See Also:
        Parser.setDTDHandler(org.xml.sax.DTDHandler)

      • setDocumentHandler

        public void setDocumentHandler(DocumentHandler handler)
        Register the SAX1 document event handler.

        Note that the SAX1 document handler has no Namespace support.

        Specified by:
        setDocumentHandler in interface Parser
        Parameters:
        handler - The new SAX1 document event handler.
        See Also:
        Parser.setDocumentHandler(org.xml.sax.DocumentHandler)

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Register the error event handler.
        Specified by:
        setErrorHandler in interface Parser
        Parameters:
        handler - The new error event handler.
        See Also:
        Parser.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(String systemId)
           throws IOException,
                  SAXException
        Parse the document.

        This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

        Specified by:
        parse in interface Parser
        Parameters:
        systemId - The absolute URL of the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

      • parse

        public void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse the document.

        This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

        Specified by:
        parse in interface Parser
        Parameters:
        input - An input source for the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Set a document locator.
        Specified by:
        setDocumentLocator in interface ContentHandler
        Parameters:
        locator - The document locator.
        See Also:
        ContentHandler.setDocumentLocator(org.xml.sax.Locator)

      • startDocument

        public void startDocument()
                   throws SAXException
        Start document event.
        Specified by:
        startDocument in interface ContentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        End document event.
        Specified by:
        endDocument in interface ContentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.endDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                               String uri)
        Adapt a SAX2 start prefix mapping event.
        Specified by:
        startPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The prefix being mapped.
        uri - The Namespace URI being mapped to.
        See Also:
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
        Adapt a SAX2 end prefix mapping event.
        Specified by:
        endPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The prefix being mapped.
        See Also:
        ContentHandler.endPrefixMapping(java.lang.String)

      • startElement

        public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
        Adapt a SAX2 start element event.
        Specified by:
        startElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI.
        localName - The Namespace local name.
        qName - The qualified (prefixed) name.
        atts - The SAX2 attributes.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.endDocument()

      • endElement

        public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
        Adapt a SAX2 end element event.
        Specified by:
        endElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI.
        localName - The Namespace local name.
        qName - The qualified (prefixed) name.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Adapt a SAX2 characters event.
        Specified by:
        characters in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Adapt a SAX2 ignorable whitespace event.
        Specified by:
        ignorableWhitespace in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Adapt a SAX2 processing instruction event.
        Specified by:
        processingInstruction in interface ContentHandler
        Parameters:
        target - The processing instruction target.
        data - The remainder of the processing instruction
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Adapt a SAX2 skipped entity event.
        Specified by:
        skippedEntity in interface ContentHandler
        Parameters:
        name - The name of the skipped entity.
        Throws:
        SAXException - Throwable by subclasses.
        See Also:
        ContentHandler.skippedEntity(java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


XMLReaderFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class XMLReaderFactory

  • java.lang.Object
    • org.xml.sax.helpers.XMLReaderFactory

  • public final class XMLReaderFactory
extends Object
    Factory for creating an XML reader.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class contains static methods for creating an XML reader from an explicit class name, or based on runtime defaults:

     try {
   XMLReader myReader = XMLReaderFactory.createXMLReader();
 } catch (SAXException e) {
   System.err.println(e.getMessage());
 }

    Note to Distributions bundled with parsers: You should modify the implementation of the no-arguments createXMLReader to handle cases where the external configuration mechanisms aren't set up. That method should do its best to return a parser when one is in the class path, even when nothing bound its class name to org.xml.sax.driver so those configuration mechanisms would see it.

    Since:
    SAX 2.0
    Version:
    2.0.1 (sax2r2)

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static XMLReader createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader createXMLReader(String className)
      Attempt to create an XML reader from a class name.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • createXMLReader

        public static XMLReader createXMLReader()
                                 throws SAXException
        Attempt to create an XMLReader from system defaults. In environments which can support it, the name of the XMLReader class is determined by trying each these options in order, and using the first one which succeeds:

        • If the system property org.xml.sax.driver has a value, that is used as an XMLReader class name.
        • The JAR "Services API" is used to look for a class name in the META-INF/services/org.xml.sax.driver file in jarfiles available to the runtime.
        • SAX parser distributions are strongly encouraged to provide a default XMLReader class name that will take effect only when previous options (on this list) are not successful.
        • Finally, if ParserFactory.makeParser() can return a system default SAX1 parser, that parser is wrapped in a ParserAdapter. (This is a migration aid for SAX1 environments, where the org.xml.sax.parser system property will often be usable.)

        In environments such as small embedded systems, which can not support that flexibility, other mechanisms to determine the default may be used.

        Note that many Java environments allow system properties to be initialized on a command line. This means that in most cases setting a good value for that property ensures that calls to this method will succeed, except when security policies intervene. This will also maximize application portability to older SAX environments, with less robust implementations of this method.

        Returns:
        A new XMLReader.
        Throws:
        SAXException - If no default XMLReader class can be identified and instantiated.
        See Also:
        createXMLReader(java.lang.String)

      • createXMLReader

        public static XMLReader createXMLReader(String className)
                                 throws SAXException
        Attempt to create an XML reader from a class name.

        Given a class name, this method attempts to load and instantiate the class as an XML reader.

        Note that this method will not be usable in environments where the caller (perhaps an applet) is not permitted to load classes dynamically.

        Returns:
        A new XML reader.
        Throws:
        SAXException - If the class cannot be loaded, instantiated, and cast to XMLReader.
        See Also:
        createXMLReader()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.AttributeListImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.AttributeListImpl

No usage of org.xml.sax.helpers.AttributeListImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.AttributesImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.AttributesImpl

  • Packages that use AttributesImpl
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of AttributesImpl in org.xml.sax.ext

      Subclasses of AttributesImpl in org.xml.sax.ext
      Modifier and Type Class and Description
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.DefaultHandler (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.DefaultHandler

  • Packages that use DefaultHandler
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of DefaultHandler in java.beans

      Methods in java.beans that return DefaultHandler
      Modifier and Type Method and Description
      static DefaultHandler XMLDecoder.createHandler(Object owner, ExceptionListener el, ClassLoader cl)
      Creates a new handler for SAX parser that can be used to parse embedded XML archives created by the XMLEncoder class.

    • Uses of DefaultHandler in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type DefaultHandler
      Modifier and Type Method and Description
      void SAXParser.parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.

    • Uses of DefaultHandler in org.xml.sax.ext

      Subclasses of DefaultHandler in org.xml.sax.ext
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.LocatorImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.LocatorImpl

  • Packages that use LocatorImpl
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of LocatorImpl in org.xml.sax.ext

      Subclasses of LocatorImpl in org.xml.sax.ext
      Modifier and Type Class and Description
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.NamespaceSupport (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.NamespaceSupport

No usage of org.xml.sax.helpers.NamespaceSupport
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.ParserAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.ParserAdapter

No usage of org.xml.sax.helpers.ParserAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.ParserFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.ParserFactory

No usage of org.xml.sax.helpers.ParserFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.XMLFilterImpl (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.XMLFilterImpl

No usage of org.xml.sax.helpers.XMLFilterImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.XMLReaderAdapter (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.XMLReaderAdapter

No usage of org.xml.sax.helpers.XMLReaderAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class org.xml.sax.helpers.XMLReaderFactory (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.XMLReaderFactory

No usage of org.xml.sax.helpers.XMLReaderFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.
Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.


Java 2D Features in Java SE 1.4

  • New Pipeline Architecture
  • Hardware Acceleration for OffscreenImages
  • Pluggable Image I/OFramework
  • New Java Print Service API
  • Support for additional ImageTypes
  • Public Bidi Algorithm
  • Font Rasterizer support for TrueType Hinting
  • Hinted Lucida Fonts
  • OpenType Font Table Support
  • Support for Numeric Shaping
  • Improved Complex Text Layout Support
  • Complete Porter-Duff Support
  • Support for Checking if Font has a Transform
  • New Equality Methods for FontRenderContext

New Pipeline Architecture

The bugtraq reports that correspond to this change are: 4228939 and 4268962

In the JDK 1.2 and 1.3 common operations on a Graphics object often invalidated the rendering data cached for this Graphics object. This invalidation interrupted the rendering process by causing continuous re-creation of rendering information for the Graphics object, even for such simple and benign operations as create(), setColor(), and translate(). Because the rendering of Swing hierarchies relies heavily on these common operations, the invalidation and re-creation of rendering data caused poor repaint performance for many Swing applications.

The new pipeline architecture reduces this performance overhead with several implementation changes that:

  • Improve the way that data is shared by the various rendering pipelines.
  • Reduce the amount of code executed and garbage created when responding to changes in the rendering attributes.
  • Improve the way that various graphics routines are chosen such as the routines that copy pixels from one format and location to another.
These changes are especially noticeable when the following calls are used frequently, as they are in Swing applications:
  • getGraphics, Graphics.create() and Graphics.dispose()
  • Graphics.setColor(), Graphics.translate
  • Graphics.copyArea, especially when the source and destination regions overlap.
The runtime footprint should also be improved through better code sharing.

Other changes in the pipeline architecture have greatly improved the performance of:

  • draw(Shape) and fill(Shape), especially when the Shape is a GeneralPath
  • scaled drawImage.
  • Blitting from an offscreen image created with createImage() multiple times without any intervening rendering or modifications to that image
  • Remote X11 display over the network of applications that use createImage() to create an image buffer for double buffering.
  • Rendering non-opaque text.
  • Systems, such as the SGI Visual 320 workstation, which have display cards that use an RGBx format for pixel storage.
  • Rendering coordinates outside of the range -32768 to 32767 with antialiasing turned off.
For more information on this feature, see the whitepaper, High Performance Graphics.

Hardware Acceleration for Offscreen Images

The bugtraq report that corresponds to this change is: 4330166

The JDK 1.4 provides access to hardware acceleration for offscreen images, resulting in better performance of rendering to and copying from these images. One problem with hardware-accelerated images is that, on some platforms such as Microsoft Windows, their contents can be lost at any time due to circumstances beyond the application's control. The new VolatileImage class allows you to create a hardware-accelerated offscreen image and manage the contents of that image.

This new API includes:

  • java.awt.image.VolatileImage:
    This class represents an image whose content can be lost at any time, but provides performance benefits. For example, on Microsoft Windows this image can be stored in VRAM and can benefit from hardware acceleration. The class includes methods that you can call to find out if the contents of the image need to be restored.
  • createVolatileImage(w,h) in Component.
    This method creates a VolatileImage that is compatible with the Component.
  • createCompatibleVolatileImage(int width, int height)
    This method creates a VolatileImage that is compatible with the GraphicsConfiguration.
  • GraphicsDevice.getAvailableAcceleratedMemory
    This method returns the number of bytes of available accelerated memory.

Pluggable Image I/O Framework

The bugtraq report that corresponds to this change is: 4101949

The Java Image I/O API is an pluggable, extensible framework that supports reading and writing images of various formats and protocols. The API provides this support through plug-ins, most of which will be written by third parties. A conforming implementation will only be required to provide a minimal set of plug-ins, principally for compatibility with previous versions of the Java SDK. An application using this API should be able to read and write images without knowing the image's storage format or the plug-in used to support the format.

Fundamentally, all image I/O operations consist of reading or writing streams that contain one or more images, one or more preview (thumbnail) images associated with each image, and metadata, which is everything other than pixel data.

The Java Image I/O API allows applications to:

  • Auto-detect installed plug-ins
  • Choose plug-ins based on format name, file suffix, file contents, or MIME type
  • Access individual images in multi-image files
  • Monitor reading and writing progress
  • Provide progressive updates of images being loaded
  • Read or write only a region of interest of an image
  • Read only selected bands of an image
  • Choose the output size of resolution-independent imagery
  • Retrieve detailed image and stream metadata
  • Work with unknown formats using generic interfaces
  • Work efficiently with both random-access and streaming data sources
  • Transcode between different formats

See Java Image I/O for more information on the Java Image I/O API.

New Java Print Service

The bugtraq reports that corresponds to this change are:
4285177 and 4360752

This API is the product of JSR006, Unified Printing API, and will allow client applications to provide rich access to the capablities of print services available including:

  • Printer browsing and selection
  • Discovery of the capablities of printers
  • Selection of printers for a printer job
  • Specification of a printer job.
Since all capabilities will be exposed through the API, server applications become first class citizens of this API.

Server applications can be beneficiaries of the capabilities for spooling documents to print services, whereas previously only graphics calls could be used to generate printer jobs from Java applications.

See Java Print Service for more information.

Support for float and double Image Types

The bugtraq report that corresponds to this change is: 4364491

Prior to the SDK 1.4, the Java 2D API did not have DataBuffer subclasses for float or double sample types. The Java Image I/O API needs these classes to read and write float and double image types.

The SDK 1.4 contains two new classes to provide float and double image type support: DataBufferFloat and DataBufferDouble. The DataBufferFloat class wraps float arrays of pixels. The DataBufferDouble class wraps double arrays of pixels.

The existing ComponentColorModel and ComponentSampleModel class implementations have also been updated to support signed short,float, and double data. These classes include definitions of the normalized ranges of component values for the newly-supported data types:

  • For the existing data types, the range remains 0.0 to 1.0.
  • For short data, the values are scaled to between -1.0 and 1.0.
  • For float data, the range is the full range of the float primitive type.
  • For double data, the range is also the range of the float primitive type, since values must be cast to float to interact with the ColorSpace class.
The ComponentColorModel class will not clamp the pixel data. Applications are expected to scale to the appropriate range. Methods are added to the ColorSpace class to determine per component minimum and maximum normalized values. Alpha component values must still range from 0.0 to 1.0 normalized.

The complete additional API is listed below.

java.awt.image.ColorModel includes three new methods to parallel existing methods:

  • getDataElement(float[] normComponents, int normOffset)
  • getDataElements(float[] normComponents, int normOffset, Object obj)
  • getNormalizedComponents(Object pixel, float[] normComponents, int normOffset)
java.awt.image.ComponentColorModel includes a new constructor based on the new datatypes and new methods to override the existing ColorModel methods:
  • ComponentColorModel(ColorSpace colorSpace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
  • getRed(Object inData)
  • getGreen(Object inData)
  • getBlue(Object inData)
  • getAlpha(Object inData)
  • getDataElements(int rgb, Object pixel)
  • coerceData(WritableRaster raster, boolean isAlphaPremultiplied)
  • createCompatibleWritableRaster(int w, int h)
  • createCompatibleSampleModel(int w, int h)
java.awt.image.SampleModel includes two new methods to accept the new datatypes:
  • getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
  • setDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
java.awt.image.ComponentSampleModel includes two methods to accept the new datatypes:
  • createDataBuffer()
  • getDataElements(int x, int y, Object obj, DataBuffer data)
java.awt.image.BandedSampleModel has three methods that were edited to accept the new datatypes:
  • createDataBuffer()
  • getDataElements(int x, int y, Object obj, DataBuffer data)
  • setDataElements(int x, int y, Object obj, DataBuffer data)
java.awt.color.ColorSpace includes two new methods determine per component minimum and maximum normalized values:
  • getMinValue(int component)
  • getMaxValue(int component)
java.awt.color.ICC_ColorSpace includes new methods override the two new ColorSpace methods.

Public Bidi Algorithm

The bugtraq report that corresponds to this change is: 4285083

The Unicode Bidirectional Algorithm analyzes text using the Unicode character properties and determines the direction of runs of the text. The algorithm is necessary to properly display bidirectional text, such as Hebrew and Arabic text, in the correct order.

The current implementation is all written in the Java programming language, but the SDK 1.4 will include efficient access from native font code so that Hebrew and Arabic text can be more efficiently rendered. The SDK 1.4 will provide access to the native code through the Java Native Interface.

The new public Bidi class implements the Unicode 3.0 Bidi Algorithm and allows access to information on the bidirectional reordering of text so that the mixed, bidirectional text is properly displayed.

The example BidiSample demonstrates some of the Bidi routines.

Font Rasterizer support for TrueType hinting

Before this release, the T2K font rasterizer used by Java 2D did not support font-hinting for TrueType fonts. As a result, when TrueType fonts did not always display with a consistent, attractive appearance. For this release, the T2K rasterizer has been modified to use the hints stored in the TrueType fonts.

By adding this functionality to the T2K rasterizer, dependency on native rasterizers has been greatly reduced. Reducing this dependency results in:

  • Greater portability because hinting of TrueType fonts is performed by the cross-platform T2K rasterizer, not the native rasterizer.
  • More consistent metrics display of TrueType fonts because the same rasterizer is being used for on-screen and off-screen drawing.

Hinted Lucida Fonts

The bugtraq report that corresponds to this change is: 4285089

For the SDK 1.4, the Lucida fonts that are in the Java SE will be upgraded to contain hints. This will give the Java SE higher quality fonts that could be used in place of existing fonts or if no other fonts are available. Adding hints to the Lucida fonts also allows the new cross-platform rasterizer to hint the Lucida fonts contained in the SDK, which causes the Lucida fonts to be displayed in a more consistent and attractive manner.

OpenType Font Table Support

The bugtraq report that corresponds to this change is: 4285161

The SDK 1.4 includes a new architecture for providing general OpenType font support. This new architecture provides international character support for contextual scripts like Thai, Indic, Arabic, and Hebrew. It also provides enhanced typographical support for Roman languages.

Support for Numeric Shaping

The bugtraq report that corresponds to this change is: 4210199

Currently, when Java 2D renders numerals surrounded by Arabic text, the numerals have Arabic (roman) shapes, which are the commonly expected numeral shapes in most western countries. However, people in a Hindi locale expect to see Hindi shapes.

A new attribute, TextAttribute.NUMERIC_SHAPING, and a new class, NumericShaper, enable you to shape ASCII digits to other Unicode decimal ranges.

For example, to cause a TextLayout instance to convert digits from European to Arabic:

  1. Create a NumericShaper that shapes ARABIC digits:
          Numeric Shaper nS
         = NumericShaper.getContextualShaper(NumericShaper.ARABIC)
  2. Add the NumericShaper to an attribute Map along with the key value of TextAttribute.NUMERIC_SHAPING:
          Map map = new HashMap();
      map.put(TextAttribute.NUMERIC_SHAPING, nS);
  3. Create a TextLayout with the attribute Map:
          FontRenderContext frc = ...;
      TextLayout layout = new TextLayout(text, map, frc);
  4. Render the text:
          layout.draw(g2d, x, y);

The NumericShaper class includes 19 constants representing different Unicode decimal ranges, allowing you to convert to 19 different digit shapes, including Devanagari and Thai.

Improved Complex-Layout Support in GlyphVector

Prior to this release, clients could not access glyph-to-character mapping information from GlyphVector. Clients can use this information to find out which glyphs in the GlyphVector correspond to which characters. This release also defines new methods to get the precise bounds of the GlyphVector and of individual glyphs within a GlyphVector.

Note: Although clients can use GlyphVector and the glyph-to-character mapping information to implement selection and hit testing, most clients will find TextLayout and the Swing JTextArea and JTextField classes to be more useful and convenient.

These GlyphVector methods are new in the SDK 1.4:

  • getGlyphCharIndex(int glyphIndex)
    Returns the character index of the specified glyph. The character index is the index of the first logical character represented by the glyph.
  • getGlyphCharIndices(int beginGlyphIndex, int numEntries, int[] codeReturn)
    Returns the character indices of the specified glyphs.
  • getGlyphOutline(int glyphIndex, float x, float y)
    Returns a Shape whose interior corresponds to the visual representation of the specified glyph within this GlyphVector, offset to x, y.
  • getPixelBounds(FontRenderContext renderFRC, float x, float y)
    Returns the pixel bounds of this GlyphVector when rendered in a graphics with the given FontRenderContext at the given location.
  • getGlyphPixelBounds(int index, FontRenderContext renderFRC, float x, float y)
    Returns the pixel bounds of the glyph at index when this GlyphVector is rendered in a Graphics with the given FontRenderContext at the given location.
These new GlyphMetrics methods deal with transformed fonts:
  • getAdvanceX()
    Returns the x-component of the advance of the glyph.
  • getAdvanceY
    Returns the y-component of the advance of the glyph.
Complete Porter-Duff Support

The bugtraq report that corresponds to this change is: 4380232

The AlphaComposite class provides alpha blending capabilities according to modes or rules established by Porter and Duff. Out of the 12 rules that Porter and Duff identified, the AlphaComposite API for the SDK, version 1.3 defines and implements only 8 of them:

  • Clear
  • A (Src)
  • A over B (SrcOver)
  • B over A (DstOver)
  • A in B (SrcIn)
  • B in A (DstIn)
  • A held out by B (SrcOut)
  • B held out by A (DstOut)

For the SDK 1.4, AlphaComposite implements the remaining 4 Porter-Duff rules:

  • B (Dst)
  • A atop B (SrcAtop)
  • B atop A (DstAtop)
  • A xor B (Xor)

Support for Checking if Font has a Transform

The bugtraq report that corresponds to this change is: 4314043

As of the SDK 1.2 the Font object has a transform attribute that can be accessed with the Font.getTransform method. You can perform geometric transformations, such as rotating and shearing, on the Font by setting the transform attribute. However, most applications use the Size attribute rather than the transform to control the size and shape of characters. In this case, the transform is a simple identity transform.

Currently, the only way to determine if the transform is an identity transform is to call getTransform and inspect the returned AffineTransform. Unfortunately, calling getTransform requires the Font object to clone the AffineTransform because the transform is mutable.

Two new methods in the SDK 1.4 allow you to check if a Font object's transform is an identity tranform without creating a new AffineTransform:

  • java.awt.Font.isTransformed:
    Returns true if this Font object has a non-identity AffineTransform attribute.
  • java.awt.font.TransformAttribute.isIdentity:
    Returns true if the wrapped transform is an identity transform.
New Equality Methods for FontRenderContext

The bugtraq report that corresponds to this change is: 4328579

A FontRenderContext object encapsulates state about the graphics context and is used by GlyphVector and TextLayout. Three new methods in FontRenderContext allow you to compare the FontRenderContext in the GlyphVector against the one in the graphics context into which the GlyphVector draws:

  • equals(FontRenderContext)
  • equals(Object)
  • hashCode()
These equals methods also have performance benefits because a client does not have to create an AffineTransform to perform an equality test.

*As used on this web site, the terms "Java Virtual Machine" or "JVM" mean a virtual machine for the Java platform.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Scripting Languages and Java

Documentation Contents
Java Platform, Standard Edition Java Scripting Programmer's Guide
Contents Previous Next

1 Scripting Languages and Java

This chapter describes the characteristics of scripting languages and how they can be used by Java programmers.

Scripting languages are programming languages that support the ability to write scripts. Unlike source files for other programming languages that must be compiled into bytecode before you run them, scripts are evaluated by a runtime environment (in this case, by a script engine) directly.

Most scripting languages are dynamically typed. This enables you to create new variables without declaring the variable type (the interpreter assigns the type based on the type of the object associated with the variable), and you can reuse the same variable for objects of different types (type conversion is performed automatically).

Scripting languages generally have simple syntax; they allow complex tasks to be performed in relatively few steps.

Although scripting languages are usually interpreted at runtime, they can be compiled into Java bytecode that can then be executed on the Java Virtual Machine (JVM). Scripting languages can be faster and easier to use for certain problems, so it is sometimes chosen by developers of Java applications. However, if you write your Java application in a scripting language, then you lose the benefits of the Java language (such as type safety and access to the class library).

Java Specification Request (JSR) 223: Scripting for the Java Platform addresses the issue of integrating Java and scripting languages. It defines a standard framework and application programming interface (API) to embed scripts in your Java applications and access Java objects from scripts. You can find more information about JSR 223 on the Java Community Process (JCP) website at http://jcp.org/en/jsr/detail?id=223

By embedding scripts in your Java code, you can customize and extend the Java application. For example, you can have configuration parameters, business logic, math expressions, and other external parts written as scripts. When developing your Java application, you do not need to choose the scripting language. If you write your application with the Java Scripting API (defined by JSR 223), then users can write scripts in any language compliant with JSR 223. For information about using the Java Scripting API, see Chapter 2.

When writing a script in a language compliant with JSR 223, you have access to the entire standard Java library. For more information about accessing Java from scripts, see Chapter 3.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


About Sample / Test Applications and Code

Sample Applications and Code

The source code provided with samples and demos for the JDK is meant to illustrate the usage of a given feature or technique and has been deliberately simplified.

Additional steps required for a production-quality application, such as security checks, input validation, and proper error handling, might not be present in the sample code.

Usage of sample code in production environments is strongly discouraged.

Applications Used For Testing

Applications such as the lightweight HTTP server are shipped with the JDK to help developers deploy and test their code easily. They have not been developed in accordance with software development standards for production-quality applications.

Usage of such test and/or support applications in production environments is strongly discouraged.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.jdi.AbsentInformationException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.AbsentInformationException

  • Packages that use AbsentInformationException
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of AbsentInformationException in com.sun.jdi

      Methods in com.sun.jdi that throw AbsentInformationException
      Modifier and Type Method and Description
      List<Location> ReferenceType.allLineLocations()
      Returns a list containing a Location object for each executable source line in this reference type.
      List<Location> Method.allLineLocations()
      Returns a list containing a Location object for each executable source line in this method.
      List<Location> ReferenceType.allLineLocations(String stratum, String sourceName)
      Returns a list containing a Location object for each executable source line in this reference type.
      List<Location> Method.allLineLocations(String stratum, String sourceName)
      Returns a list containing a Location object for each executable source line in this method.
      List<LocalVariable> Method.arguments()
      Returns a list containing each LocalVariable that is declared as an argument of this method.
      List<Location> ReferenceType.locationsOfLine(int lineNumber)
      Returns a List containing all Location objects that map to the given line number.
      List<Location> Method.locationsOfLine(int lineNumber)
      Returns a List containing all Location objects that map to the given line number.
      List<Location> ReferenceType.locationsOfLine(String stratum, String sourceName, int lineNumber)
      Returns a List containing all Location objects that map to the given line number.
      List<Location> Method.locationsOfLine(String stratum, String sourceName, int lineNumber)
      Returns a List containing all Location objects that map to the given line number and source name.
      String ReferenceType.sourceDebugExtension()
      Get the source debug extension of this type.
      String ReferenceType.sourceName()
      Gets an identifying name for the source corresponding to the declaration of this type.
      String Location.sourceName()
      Gets an identifing name for the source corresponding to this location.
      String Location.sourceName(String stratum)
      Gets an identifing name for the source corresponding to this location.
      List<String> ReferenceType.sourceNames(String stratum)
      Gets the identifying names for all the source corresponding to the declaration of this type.
      String Location.sourcePath()
      Gets the path to the source corresponding to this location.
      String Location.sourcePath(String stratum)
      Gets the path to the source corresponding to this location.
      List<String> ReferenceType.sourcePaths(String stratum)
      Gets the paths to the source corresponding to the declaration of this type.
      List<LocalVariable> Method.variables()
      Returns a list containing each LocalVariable declared in this method.
      List<LocalVariable> Method.variablesByName(String name)
      Returns a list containing each LocalVariable of a given name in this method.
      LocalVariable StackFrame.visibleVariableByName(String name)
      Finds a LocalVariable that matches the given name and is visible at the current frame location.
      List<LocalVariable> StackFrame.visibleVariables()
      Returns a list containing each LocalVariable that can be accessed from this frame's location.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.AbstractNotificationHandler (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.AbstractNotificationHandler

No usage of com.sun.nio.sctp.AbstractNotificationHandler
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.views.AbstractView (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.views.AbstractView

  • Packages that use AbstractView
    Package Description
    org.w3c.dom.css
    org.w3c.dom.events
    org.w3c.dom.views

    • Uses of AbstractView in org.w3c.dom.css

      Subinterfaces of AbstractView in org.w3c.dom.css
      Modifier and Type Interface and Description
      interface  ViewCSS
      This interface represents a CSS view.

    • Uses of AbstractView in org.w3c.dom.events

      Methods in org.w3c.dom.events that return AbstractView
      Modifier and Type Method and Description
      AbstractView UIEvent.getView()
      The view attribute identifies the AbstractView from which the event was generated.
      Methods in org.w3c.dom.events with parameters of type AbstractView
      Modifier and Type Method and Description
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
      void UIEvent.initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg)
      The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.

    • Uses of AbstractView in org.w3c.dom.views

      Methods in org.w3c.dom.views that return AbstractView
      Modifier and Type Method and Description
      AbstractView DocumentView.getDefaultView()
      The default AbstractView for this Document, or null if none available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.jdi.Accessible (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.Accessible

  • Packages that use Accessible
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of Accessible in com.sun.jdi

      Subinterfaces of Accessible in com.sun.jdi
      Modifier and Type Interface and Description
      interface  ArrayType
      Provides access to the class of an array and the type of its components in the target VM.
      interface  ClassType
      A mirror of a class in the target VM.
      interface  Field
      A class or instance variable in the target VM.
      interface  InterfaceType
      A mirror of an interface in the target VM.
      interface  Method
      A static or instance method in the target VM.
      interface  ReferenceType
      The type of an object in a target VM.
      interface  TypeComponent
      An entity declared within a user defined type (class or interface).
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.event.AccessWatchpointEvent (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.AccessWatchpointEvent

No usage of com.sun.jdi.event.AccessWatchpointEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.AccessWatchpointRequest (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.AccessWatchpointRequest

  • Packages that use AccessWatchpointRequest
    Package Description
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of AccessWatchpointRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return AccessWatchpointRequest
      Modifier and Type Method and Description
      AccessWatchpointRequest EventRequestManager.createAccessWatchpointRequest(Field field)
      Creates a new disabled watchpoint which watches accesses to the specified field.
      Methods in com.sun.jdi.request that return types with arguments of type AccessWatchpointRequest
      Modifier and Type Method and Description
      List<AccessWatchpointRequest> EventRequestManager.accessWatchpointRequests()
      Return an unmodifiable list of the enabled and disabled access watchpoint requests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Acknowledgments

The Java Native Interface (JNI) specification was formed as a result of a series of discussions among JavaSoft and Java licensees. The goal is to achieve a native interface standard.

Sheng Liang at JavaSoft is responsible for the JNI design and specification. JNI is partly evolved from Netscape’s Java Runtime Interface (JRI), which was designed by Warren Harris. Warren Harris also helped to improve the JNI design. Simon Nash at IBM and Patrick Beard at Apple provided extensive feedbacks that shaped the JNI design in many ways.

In addition, the JNI benefited greatly from JavaSoft internal design reviews. These design reviews were conducted by James Gosling, Peter Kessler, Tim Lindholm, Mark Reinhold, Derek White, and Frank Yellin.

We also want to acknowledge the helpful comments and suggestions we received from numerous people on various drafts of the specification.

Lastly, Beth Stearns improved the presentation of this document.

Contents | Previous | Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JAAS Authorization

This tutorial expands the program and policy file developed in the JAAS Authentication tutorial to demonstrate the JAAS authorization component, which ensures the authenticated caller has the access control rights (permissions) required to do subsequent security-sensitive operations. Since the authorization component requires that the user authentication first be completed, please read the JAAS Authentication tutorial first if you have not already done so.

The rest of this tutorial consists of the following sections:

  • What is JAAS Authorization?
  • How is JAAS Authorization Performed?
    • How Do You Make Principal-Based Policy File Statements?
    • How Do You Associate a Subject with an Access Control Context?
  • The Authorization Tutorial Code
  • The Login Configuration File
  • The Policy File
  • Running the Authorization Tutorial Code

If you want to first see the tutorial code in action, you can skip directly to Running the Authorization Tutorial Code and then go back to the other sections to learn more.

What is JAAS Authorization?

JAAS authorization extends the existing Java security architecture that uses a security policy to specify what access rights are granted to executing code. That architecture, introduced in the Java 2 platform, is code-centric. That is, the permissions are granted based on code characteristics: where the code is coming from and whether it is digitally signed and if so by whom. We saw an example of this in the jaasacn.policy file used in the JAAS Authentication tutorial. That file contains the following:

grant codebase "file:./JaasAcn.jar" {
   permission javax.security.auth.AuthPermission
                    "createLoginContext.JaasSample";
};

This grants the code in the JaasAcn.jar file, located in the current directory, the specified permission. (No signer is specified, so it doesn't matter whether the code is signed or not.)

JAAS authorization augments the existing code-centric access controls with new user-centric access controls. Permissions can be granted based not just on what code is running but also on who is running it.

When an application uses JAAS authentication to authenticate the user (or other entity such as a service), a Subject is created as a result. The purpose of the Subject is to represent the authenticated user. A Subject is comprised of a set of Principals, where each Principal represents an identity for that user. For example, a Subject could have a name Principal ("Susan Smith") and a Social Security Number Principal ("987-65-4321"), thereby distinguishing this Subject from other Subjects.

Permissions can be granted in the policy to specific Principals. After the user has been authenticated, the application can associate the Subject with the current access control context. For each subsequent security-checked operation, (a local file access, for example), the Java runtime will automatically determine whether the policy grants the required permission only to a specific Principal and if so, the operation will be allowed only if the Subject associated with the access control context contains the designated Principal.

How is JAAS Authorization Performed?

To make JAAS authorization take place, the following is required:

  • The user must be authenticated, as described in the JAAS Authentication tutorial.
  • Principal-based entries must be configured in the security policy.
  • The Subject that is the result of authentication must be associated with the current access control context.

How Do You Make Principal-Based Policy File Statements?

Policy file grant statements can now optionally include one or more Principal fields. Inclusion of a Principal field indicates that the user or other entity represented by the specified Principal, executing the specified code, has the designated permissions.

Thus, the basic format of a grant statement is now

grant <signer(s) field>, <codeBase URL>
  <Principal field(s)> {
    permission perm_class_name "target_name", "action";
    ....
    permission perm_class_name "target_name", "action";
  };
where each of the signer, codeBase and Principal fields is optional and the order between the fields doesn't matter.

A Principal field looks like the following:

Principal Principal_class "principal_name"

That is, it is the word "Principal" (where case doesn't matter) followed by the (fully qualified) name of a Principal class and a principal name.

A Principal class is a class that implements the java.security.Principal interface. All Principal objects have an associated name that can be obtained by calling their getName method. The format used for the name is dependent on each Principal implementation.

The type of Principal placed in the Subject created by the Kerberos authentication mechanism used by this tutorial is javax.security.auth.kerberos.KerberosPrincipal, so that is what should be used as the Principal_class part of our grant statement's Principal designation. User names for KerberosPrincipals are of the form "name@realm". Thus, if the user name is "mjones" and the realm is "KRBNT-OPS.ABC.COM", the full principal_name designation to use in the grant statement is "mjones@KRBNT-OPS.ABC.COM".

It is possible to include more than one Principal field in a grant statement. If multiple Principal fields are specified, then the permissions in that grant statement are granted only if the Subject associated with the current access control context contains all of those Principals.

To grant the same set of permissions to different Principals, create multiple grant statements where each lists the permissions and contains a single Principal field designating one of the Principals.

The policy file for this tutorial includes one grant statement with a Principal field:

grant codebase "file:./SampleAction.jar",
    Principal javax.security.auth.kerberos.KerberosPrincipal
        "your_user_name@your_realm"  {

   permission java.util.PropertyPermission "java.home", "read";
   permission java.util.PropertyPermission "user.home", "read";
   permission java.io.FilePermission "foo.txt", "read";
};
where you substitute your Kerberos user name (complete with "@" and realm) for "your_user_name@your_realm".

This specifies that the indicated permissions are granted to the specified principal executing the code in SampleAction.jar.

How Do You Associate a Subject with an Access Control Context?

To create and associate a Subject with an access control context, you need the following:

  • The user must first be authenticated, as described in JAAS Authentication.
  • The static doAs method from the Subject class must be called, passing it an authenticated Subject and a java.security.PrivilegedAction or java.security.PrivilegedExceptionAction. (See API for Privileged Blocks for a comparison of PrivilegedAction and PrivilegedExceptionAction.) The doAs method associates the provided Subject with the current access control context and then invokes the run method from the action. The run method implementation contains all the code to be executed as the specified Subject. The action thus executes as the specified Subject.

    The static doAsPrivileged method from the Subject class may be called instead of the doAs method. In addition to the parameters passed to doAs, doAsPrivileged requires a third parameter: an AccessControlContext. Unlike doAs, which associates the provided Subject with the current access control context, doAsPrivileged associates the Subject with the provided access control context. See doAs vs. doAsPrivileged in the JAAS Reference Guide for a comparison of those methods.

The Authorization Tutorial Code

The code for this tutorial consists of two files:

  • JaasAzn.java is exactly the same as the JaasAcn.java from the JAAS Authentication tutorial except for the additional code needed to call Subject.doAsPrivileged.
  • SampleAction.java contains the SampleAction class. This class implements PrivilegedAction and has a run method that contains all the code we want to be executed with Principal-based authorization checks.

JaasAzn.java

JaasAzn.java is exactly the same as the JaasAcn.java code used in the previous tutorial except with three statements added at the end of the main method, after the authentication is done. These statements result in (1) association of a Subject representing the authenticated user with the current access control context and (2) execution of the code in the run method of SampleAction. Associating the Subject with the access control context enables security-sensitive operations in the SampleAction run method (and any code it invokes directly or indirectly) to be executed if a Principal representing the authenticated user is granted the required permissions in the current policy.

Like JaasAcn.java, JaasAzn.java instantiates a LoginContext lc and calls its login method to perform the authentication. If successful, the authenticated Subject (which includes a Principal representing the user) is obtained by calling the LoginContext's getSubject method:

Subject mySubject = lc.getSubject();

The main method then calls Subject.doAsPrivileged, passing it the authenticated Subject mySubject, a PrivilegedAction (SampleAction) and a null AccessControlContext, as described in the following.

The SampleAction class is instantiated via the following:

PrivilegedAction action = new SampleAction();

The call to Subject.doAsPrivileged is performed via:

Subject.doAsPrivileged(mySubject, action, null);

The doAsPrivileged method invokes execution of the run method in the PrivilegedAction action (SampleAction) to initiate execution of the rest of the code, which is considered to be executed on behalf of the Subject mySubject.

Passing null as the AccessControlContext (third) argument to doAsPrivileged indicates that mySubject should be associated with a new empty AccessControlContext. The result is that security checks occurring during execution of SampleAction will only require permissions for the SampleAction code itself (or other code it invokes), running as mySubject. Note that the caller of doAsPrivileged (and the callers on the execution stack at the time doAsPrivileged was called) do not require any permissions while the action executes.

SampleAction.java

SampleAction.java contains the SampleAction class. This class implements java.security.PrivilegedAction and has a run method that contains all the code we want to be executed as the Subject mySubject. For this tutorial, we will perform three operations, each of which cannot be done unless code has been granted required permissions. We will:

  • Read and print the value of the java.home system property,
  • Read and print the value of the user.home system property, and
  • Determine whether or not a file named foo.txt exists in the current directory.

Here is the code:

import java.io.File;
import java.security.PrivilegedAction;

public class SampleAction implements PrivilegedAction {

  public Object run() {

    System.out.println("\nYour java.home property value is: "
                + System.getProperty("java.home"));

    System.out.println("\nYour user.home property value is: "
                + System.getProperty("user.home"));

    File f = new File("foo.txt");
    System.out.print("\nfoo.txt does ");
    if (!f.exists())
        System.out.print("not ");
    System.out.println("exist in the current working directory.");
    return null;
  }
}

The Login Configuration File

The login configuration file used for this tutorial can be exactly the same as that used by the JAAS Authentication tutorial. Thus we can use jaas.conf, which contains just one entry:

JaasSample {
  com.sun.security.auth.module.Krb5LoginModule required;
};

This entry is named "JaasSample" and that is the name that both our tutorial applications JaasAcn and JaasAzn use to refer to it. The entry specifies that the LoginModule to be used to do the user authentication is the Krb5LoginModule in the com.sun.security.auth.module package and that this Krb5LoginModule is required to "succeed" in order for authentication to be considered successful. The Krb5LoginModule succeeds only if the name and password supplied by the user are successfully used to log the user into the Kerberos KDC.

The Policy File

This authorization tutorial contains two classes, JaasAzn and SampleAction. The code in each class contains some security-sensitive operations and thus relevant permissions are required in a policy file in order for the operations to be executed.

Permissions Required by JaasAzn

The main method of the JaasAzn class does two operations for which permissions are required. It

  • creates a LoginContext, and
  • calls the doAsPrivileged static method of the Subject class.

The LoginContext creation is exactly the same as was done in the authentication tutorial, and it thus needs the same javax.security.auth.AuthPermission permission with target "createLoginContext.JaasSample".

In order to call the doAsPrivileged method of the Subject class, you need to have a javax.security.auth.AuthPermission with target "doAsPrivileged".

Assuming the JaasAzn class is placed in a JAR file named JaasAzn.jar, these permissions can be granted to the JaasAzn code via the following grant statement in the policy file:

grant codebase "file:./JaasAzn.jar" {
   permission javax.security.auth.AuthPermission
                    "createLoginContext.JaasSample";
   permission javax.security.auth.AuthPermission "doAsPrivileged";
};

Permissions Required by SampleAction

The SampleAction code does three operations for which permissions are required. It

  • reads the value of the "java.home" system property.
  • reads the value of the "user.home" system property.
  • checks to see whether or not a file named foo.txt exists in the current directory.

The permissions required for these operations are the following:

permission java.util.PropertyPermission "java.home", "read";
permission java.util.PropertyPermission "user.home", "read";
permission java.io.FilePermission "foo.txt", "read";

We need to grant these permissions to the code in SampleAction.class, which we will place in a JAR file named SampleAction.jar. However, for this particular grant statement we want to grant the permissions not just to the code but to a specific user executing the code, to demonstrate how to restrict access to a particular user.

Thus, as explained in How Do You Make Principal-Based Policy File Statements?, our grant statement looks like the following:

grant codebase "file:./SampleAction.jar",
    Principal javax.security.auth.kerberos.KerberosPrincipal
        "your_user_name@your_realm"  {

   permission java.util.PropertyPermission "java.home", "read";
   permission java.util.PropertyPermission "user.home", "read";
   permission java.io.FilePermission "foo.txt", "read";
};
You substitute your Kerberos user name (complete with "@" and realm) for "your_user_name@your_realm". For example, if your user name is "mjones" and your realm is "KRBNT-OPERATIONS.ABC.COM", you would use "mjones@KRBNT-OPERATIONS.ABC.COM" (complete with the quotes).

The Full Policy File

The full policy file is jaasazn.policy.

Running the Authorization Tutorial Code

To execute our JAAS authorization tutorial code, all you have to do is

  1. Place the following files into a directory:
    • The JaasAzn.java source file.
    • The SampleAction.java source file.
    • The jaas.conf login configuration file.
    • The jaasazn.policy policy file.
  2. Replace "your_user_name@your_realm" in jaasazn.policy with your user name and realm.
  3. Compile SampleAction.java and JaasAzn.java:
    javac SampleAction.java JaasAzn.java
  4. Create a JAR file named JaasAzn.jar containing JaasAzn.class:
    jar -cvf JaasAzn.jar JaasAzn.class
  5. Create a JAR file named SampleAction.jar containing SampleAction.class:
    jar -cvf SampleAction.jar SampleAction.class
  6. Execute the JaasAzn application, specifying
    1. by an appropriate -classpath clause that classes should be searched for in the JaasAzn.jar and SampleAction.jar JAR files,
    2. by -Djava.security.manager that a security manager should be installed,
    3. by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified.
    4. by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified.
    5. by -Djava.security.policy=jaasazn.policy that the policy file to be used is jaasazn.policy, and
    6. by -Djava.security.auth.login.config=jaas.conf that the login configuration file to be used is jaas.conf.

    Below are the full commands to use for both Microsoft Windows and Solaris, Linux, and Mac OS X systems. The only difference is that on Windows systems you use semicolons to separate classpath items, while you use colons for that purpose on Solaris, Linux, and Mac OS X. Be sure to replace <your_realm> with your Kerberos realm, and <your_kdc> with your Kerberos KDC.

    Here is the full command for Windows systems:

    java -classpath JaasAzn.jar;SampleAction.jar
 -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=jaasazn.policy
 -Djava.security.auth.login.config=jaas.conf JaasAzn

    Here is the full command for Solaris, Linux, and Mac OS X systems:

    java -classpath JaasAzn.jar:SampleAction.jar
 -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=jaasazn.policy
 -Djava.security.auth.login.config=jaas.conf JaasAzn

    Type the full command on one line. Multiple lines are used here for legibility. If the command is too long for your system, you may need to place it in a .bat file (for Windows) or a .sh file (for Solaris, Linux, and Mac OS X) and then run that file to execute the command.

    You will be prompted for your Kerberos user name and password, and the underlying Kerberos authentication mechanism specified in the login configuration file will log you into Kerberos. If your login is successful, you will see the message "Authentication succeeded!" and if not, you will see "Authentication Failed."

    For login troubleshooting suggestions, see Troubleshooting.

    Once authentication is successfully completed, the rest of the program (in SampleAction) will be executed on behalf of you, the user, requiring you to have been granted appropriate permissions. The jaasazn.policy policy file grants you the required permissions, so you will see a display of the values of your java.home and user.home system properties and a statement as to whether or not you have a file named foo.txt in the current directory.

Tutorials Introduction and TOC
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JAAS Authentication

The Java Authentication and Authorization Service (JAAS) was introduced as an optional package to the Java 2 SDK, Standard Edition (J2SDK), v 1.3. JAAS has now been integrated into the J2SDK 1.4.

JAAS can be used for two purposes:

  • for authentication of users, to reliably and securely determine who is currently executing Java code, regardless of whether the code is running as an application, an applet, a bean, or a servlet; and
  • for authorization of users to ensure they have the access control rights (permissions) required to do the actions performed.

This section provides a basic tutorial for the authentication component. The authorization component will be described in the JAAS Authorization tutorial.

JAAS authentication is performed in a pluggable fashion. This permits Java applications to remain independent from underlying authentication technologies. New or updated technologies can be plugged in without requiring modifications to the application itself. An implementation for a particular authentication technology to be used is determined at runtime. The implementation is specified in a login configuration file. The authentication technology used for this tutorial is Kerberos. (See Kerberos Requirements.)

The rest of this tutorial consists of the following sections:

  1. The Authentication Tutorial Code
  2. The Login Configuration
  3. Running the Code
  4. Running the Code with a Security Manager

If you want to first see the tutorial code in action, you can skip directly to Running the Code and then go back to the other sections to learn about coding and configuration file details.

The Authentication Tutorial Code

Our authentication tutorial code is contained in a single source file, JaasAcn.java. This file's main method performs the authentication and then reports whether or not authentication succeeded.

The code for authenticating the user is very simple, consisting of just two steps:

  1. Instantiate a LoginContext.
  2. Call the LoginContext's login method.

First the basic code is shown, followed by a complete listing of the JaasAcn.java source file, complete with import statements and error handling.

Instantiating a LoginContext

In order to authenticate a user, you first need a javax.security.auth.login.LoginContext. Here is the basic way to instantiate a LoginContext:

import javax.security.auth.login.*;
. . .
LoginContext lc =
    new LoginContext(<config file entry name>,
           <CallbackHandler to be used for user interaction>);
and here is the specific way our tutorial code does the instantiation:
import javax.security.auth.login.*;
import com.sun.security.auth.callback.TextCallbackHandler;
. . .
LoginContext lc =
    new LoginContext("JaasSample",
          new TextCallbackHandler());

The arguments are the following:

  1. The name of an entry in the JAAS login configuration file

    This is the name for the LoginContext to use to look up an entry for this application in the JAAS login configuration file, described here. Such an entry specifies the class(es) that implement the desired underlying authentication technology(ies). The class(es) must implement the LoginModule interface, which is in the javax.security.auth.spi package.

    In our sample code, we use the Krb5LoginModule in the com.sun.security.auth.module package, which performs Kerberos authentication.

    The entry in the login configuration file we use for this tutorial (see jaas.conf) has the name "JaasSample", so that is the name we specify as the first argument to the LoginContext constructor.

  2. A CallbackHandler instance.

    When a LoginModule needs to communicate with the user, for example to ask for a user name and password, it does not do so directly. That is because there are various ways of communicating with a user, and it is desirable for LoginModules to remain independent of the different types of user interaction. Rather, the LoginModule invokes a CallbackHandler to perform the user interaction and obtain the requested information, such as the user name and password. (CallbackHandler is an interface in the javax.security.auth.callback pkg.)

    An instance of the particular CallbackHandler to be used is specified as the second argument to the LoginContext constructor. The LoginContext forwards that instance to the underlying LoginModule (in our case Krb5LoginModule). An application typically provides its own CallbackHandler implementation. A simple CallbackHandler, TextCallbackHandler, is provided in the com.sun.security.auth.callback package to output information to and read input from the command line.

Calling the LoginContext's login Method

Once we have a LoginContext lc, we can call its login method to carry out the authentication process:

lc.login();

The LoginContext instantiates a new empty javax.security.auth.Subject object (which represents the user or service being authenticated). The LoginContext constructs the configured LoginModule (in our case Krb5LoginModule) and initializes it with this new Subject and TextCallbackHandler.

The LoginContext's login method then calls methods in the Krb5LoginModule to perform the login and authentication. The Krb5LoginModule will utilize the TextCallbackHandler to obtain the user name and password. Then the Krb5LoginModule will use this information to get the user credentials from the Kerberos KDC. See the Kerberos reference documentation.

If authentication is successful, the Krb5LoginModule populates the Subject with (1) a Kerberos Principal representing the user and (2) the user's credentials (TGT). See Subjects, Principals, Authentication, and Credentials for information on these terms.

The calling application can subsequently retrieve the authenticated Subject by calling the LoginContext's getSubject method, although doing so is not necessary for this tutorial.

The Complete JaasAcn.java Code

Now that you have seen the basic code required to authenticate the user, we can put it all together into the full class in JaasAcn.java, which includes relevant import statements and error handling:

import javax.security.auth.*;
import javax.security.auth.callback.*;
import javax.security.auth.login.*;
import com.sun.security.auth.callback.TextCallbackHandler;

/**
 * This JaasAcn application attempts to authenticate a user
 * and reports whether or not the authentication was successful.
 */
public class JaasAcn {

  public static void main(String[] args) {

      // Obtain a LoginContext, needed for authentication. Tell
      // it to use the LoginModule implementation specified by
      // the entry named "JaasSample" in the JAAS login
      // configuration file and to also use the specified
      // CallbackHandler.
      LoginContext lc = null;
      try {
          lc = new LoginContext("JaasSample",
                      new TextCallbackHandler());
      } catch (LoginException le) {
          System.err.println("Cannot create LoginContext. "
              + le.getMessage());
          System.exit(-1);
      } catch (SecurityException se) {
          System.err.println("Cannot create LoginContext. "
              + se.getMessage());
          System.exit(-1);
      }

      try {

          // attempt authentication
          lc.login();

      } catch (LoginException le) {

          System.err.println("Authentication failed: "
          System.err.println("  " + le.getMessage());
          System.exit(-1);

      }

      System.out.println("Authentication succeeded!");

    }
}

The Login Configuration

JAAS authentication is performed in a pluggable fashion, so applications can remain independent from underlying authentication technologies. A system administrator determines the authentication technologies, or LoginModules, to be used for each application and configures them in a login Configuration. The source of the configuration information (for example, a file or a database) is up to the current javax.security.auth.login.Configuration implementation. The default Configuration implementation from Sun Microsystems reads configuration information from configuration files, as described in com.sun.security.auth.login.ConfigFile.html.

See JAAS Login Configuration File for information as to what a login configuration file is, what it contains, and how to specify which login configuration file should be used.

The Login Configuration File for This Tutorial

As noted, the login configuration file we use for this tutorial, jaas.conf, contains just one entry, which is

JaasSample {
  com.sun.security.auth.module.Krb5LoginModule required;
};

This entry is named "JaasSample" and that is the name that our tutorial application, JaasAcn, uses to refer to this entry. The entry specifies that the LoginModule to be used to do the user authentication is the Krb5LoginModule in the com.sun.security.auth.module package and that this Krb5LoginModule is required to "succeed" in order for authentication to be considered successful. The Krb5LoginModule succeeds only if the name and password supplied by the user are successfully used to log the user into the Kerberos KDC.

For information about all the possible options that can be passed to Krb5LoginModule, see the Krb5LoginModule documentation.

Running the Code

To execute our JAAS authentication tutorial code, all you have to do is

  1. Place the JaasAcn.java application source file and the jaas.conf login configuration file into a directory.
  2. Compile JaasAcn.java:
    javac JaasAcn.java
  3. Execute the JaasAcn application, specifying
    • by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified. For example, if your realm is "KRBNT-OPERATIONS.EXAMPLE.COM" you'd put -Djava.security.krb5.realm=KRBNT-OPERATIONS.EXAMPLE.COM.
    • by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified. For example, if your KDC is "samplekdc.example.com" you'd put -Djava.security.krb5.kdc=samplekdc.example.com.
    • by -Djava.security.auth.login.config=jaas.conf that the login configuration file to be used is jaas.conf.

The full command is below. Be sure to replace <your_realm> with your Kerberos realm, and <your_kdc> with your Kerberos KDC.

java -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.auth.login.config=jaas.conf JaasAcn

Type all that on one line. Multiple lines are used here for legibility.

You will be prompted for your Kerberos user name and password, and the underlying Kerberos authentication mechanism specified in the login configuration file will log you into Kerberos. If your login is successful, you will see the following message:

Authentication succeeded!
If the login is not successful (for example, if you misspell your password), you will see
Authentication failed:
followed by a reason for the failure. For example, if you mistype your user name, you may see a message like the following (where the formatting is slightly modified here to increase legibility):
Authentication failed:
  Kerberos Authentication Failed:
    javax.security.auth.login.LoginException:
      KrbException: Client not found in Kerberos database

For login troubleshooting suggestions, see Troubleshooting.

After fixing any problems, re-run the program to try again.

Running the Code with a Security Manager

When a Java program is run with a security manager installed, the program is not allowed to access resources or otherwise perform security-sensitive operations unless it is explicitly granted permission to do so by the security policy in effect. In Java platforms that are compatible with J2SE v 1.2 and later, the permission must be granted by an entry in a policy file.

Most browsers install a security manager, so applets typically run under the scrutiny of a security manager. Applications, on the other hand, do not, since a security manager is not automatically installed when an application is running. Thus an application, like our JaasAcn application, by default has full access to resources.

To run an application with a security manager, simply invoke the interpreter with a -Djava.security.manager argument included on the command line.

If you try invoking JaasAcn with a security manager but without specifying any policy file, you will get the following (unless you have a default policy setup elsewhere that grants the required permissions or grants AllPermission):

% java -Djava.security.manager \
 -Djava.security.krb5.realm=<your_realm> \
 -Djava.security.krb5.kdc=<your_kdc> \
 -Djava.security.auth.login.config=jaas.conf JaasAcn
Exception in thread "main" java.security.AccessControlException:
  access denied (
  javax.security.auth.AuthPermission createLoginContext.JaasSample)

As you can see, you get an AccessControlException, because we haven't created and used a policy file granting our code the permission that is required in order to be allowed to create a LoginContext.

Here are the complete steps required in order to be able to run our JaasAcn application with a security manager installed. You can skip the first two steps if you have already done them, as described in Running the Code.

  1. Place the JaasAcn.java application source file and the jaas.conf login configuration file into a directory.
  2. Compile JaasAcn.java:
    javac JaasAcn.java
  3. Create a JAR file containing JaasAcn.class:
    jar -cvf JaasAcn.jar JaasAcn.class

    This command creates a JAR file, JaasAcn.jar, and places the JaasAcn.class file inside it.

  4. Create a policy file granting the code in the JAR file the required permission.

    The permission that is needed by code attempting to instantiate a LoginContext is a javax.security.auth.AuthPermission with target "createLoginContext.<entry name>". Here, <entry name> refers to the name of the login configuration file entry that the application references in its instantiation of LoginContext. The name used by our JaasAcn application's LoginContext instantiation is "JaasSample", as you can see in the code:

    LoginContext lc =
    new LoginContext("JaasSample",
          new TextCallbackHandler());
    Thus, the permission that needs to be granted to JaasAcn.jar is
    permission javax.security.auth.AuthPermission
  "createLoginContext.JaasSample";
    Copy the policy file jaasacn.policy to the same directory as that in which you stored JaasAcn.java, etc. This is a text file containing the following grant statement to grant JaasAcn.jar (in the current directory) the required permission:
    grant codebase "file:./JaasAcn.jar" {
   permission javax.security.auth.AuthPermission
                    "createLoginContext.JaasSample";
};

    Note: Policy files and the structure of entries within them are described in Default Policy Implementation and Policy File Syntax. Permissions are described here.

  5. Execute the JaasAcn application, specifying
    1. by an appropriate -classpath clause that classes should be searched for in the JaasAcn.jar JAR file,
    2. by -Djava.security.manager that a security manager should be installed,
    3. by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified. For example, if your realm is "KRBNT-OPERATIONS.EXAMPLE.COM" you'd put -Djava.security.krb5.realm=KRBNT-OPERATIONS.EXAMPLE.COM.
    4. by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified. For example, if your KDC is "samplekdc.example.com" you'd put -Djava.security.krb5.kdc=samplekdc.example.com.
    5. by -Djava.security.policy=jaasacn.policy that the policy file to be used is jaasacn.policy, and
    6. by -Djava.security.auth.login.config=jaas.conf that the login configuration file to be used is jaas.conf.

    The full command is below. Be sure to replace <your_realm> with your Kerberos realm, and <your_kdc> with your Kerberos KDC.

    java -classpath JaasAcn.jar -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=jaasacn.policy
 -Djava.security.auth.login.config=jaas.conf JaasAcn

    Type all that on one line. Multiple lines are used here for legibility. If the command is too long for your system, you may need to place it in a .bat file (for Windows) or a .sh file (for Solaris, Linux, and Mac OS X) and then run that file to execute the command.

    Since the specified policy file contains an entry granting the code the required permission, JaasAcn will be allowed to instantiate a LoginContext and continue execution. You will be prompted for your Kerberos user name and password, and the underlying Kerberos authentication mechanism specified in the login configuration file will log you into Kerberos. If your login is successful, you will see the message "Authentication succeeded!" and if not, you will see "Authentication failed:" followed by a reason for the failure.

    For login troubleshooting suggestions, see Troubleshooting.

Tutorials Introduction and TOC
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java IDL: Using Adapter Activators

Documentation Contents

Using Adapter Activators

When creating a new POA, the application developer may declare specific policy choices for the new POA and provide a different adapter activator and servant manager (these are callback objects used by the POA to activate POAs on demand and activate servants). Creating new POAs also allows the application developer to partition the name space of objects, as Object Ids are interpreted relative to a POA. Finally, by creating new POAs, the developer can independently control request processing for multiple sets of objects.

An adapter activator is optional. You would use an adapter activator if POAs need to be created during request processing. If all needed POAs are created when the application is initialized, an adapter activator is not required.

An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when the find_POA method is called with an activate parameter value of TRUE. The ORB will invoke an operation on an adapter activator when a request is received for a child POA that does not currently exist. The adapter activator can then create the required POA on demand.

A request must be capable of conveying the Object Id of the target object as well as the identification of the POA that created the target object reference. When a client issues a request, the ORB first locates an appropriate server (perhaps starting one if needed) and then it locates the appropriate POA within that server.

If the POA does not exist in the server process, the application has the opportunity to re-create the required POA by using an adapter activator. An adapter activator is a user-implemented object that can be associated with a POA. It is invoked by the ORB when a request is received for a nonexistent child POA. The adapter activator has the opportunity to create the required POA. If it does not, the client receives the ADAPTER_NONEXISTENT exception.

Once the ORB has located the appropriate POA, it delivers the request to that POA. The further processing of that request depends both upon the policies associated with that POA as well as the object's current state of activation.

An Example Using Adapter Activators

The following example code shows an application that uses Adapter Activators to enable the POA to be created during request processing. This application builds on the "Hello World" example. The following files are included in this example:

  • Client.java
  • Server.java
  • Hello.idl
  • HelloServant.java
  • Makefile
  • run.bat

For instructions on running this example, see Running the Example Adapter Activator Application.

Client.java

The code for the example client initializes the ORB, resolves HelloServant, and invokes the sayHello() method.

//Client.java
import org.omg.CORBA.ORB;
import org.omg.CosNaming.NamingContext;
import org.omg.CosNaming.NamingContextHelper;
import org.omg.CosNaming.NameComponent;

public class Client {

    public void run(String[] args) {
        try {
            //initialize the orb
            ORB orb = ORB.init(args, null);
            System.out.println("ORB initialized");

            NamingContext namingContext = NamingContextHelper.narrow(
                orb.resolve_initial_references("NameService"));
            NameComponent[] nc = { new NameComponent("HelloServer", "") };

            //resolve HelloServant and invoke sayHello()
            Hello helloRef = HelloHelper.narrow(namingContext.resolve(nc));
            System.out.println("Resolved HelloServant");

            System.out.println(helloRef.sayHello());

        } catch (Exception e) {
            e.printStackTrace();
        }
    }

    public static void main(String[] args) {
        new Client().run(args);
    }
}

Server.java

The code for the server does the following:

  • Initializes the ORB.
  • Resolve RootPOA.
  • Registers the adapter activator with rootPOA so that child POAs can be created on demand.
  • Runs find_POA with an activate parameter of TRUE to cause the adapter activator associated with rootPOA to be invoked if 'HelloPOA' does not exist.
  • Creates the object reference for HelloServant and registers it with the naming service.
  • Destroys 'HelloPOA'. This POA will be transparently recreated when the ORB receives a request on HelloPOA using the adapter activator we registered with the RootPOA.
  • Activates rootPOA.
  • Waits for incoming requests.
  • Creates MyAdapterActivator to create the POA with appropriate policies, associate the servant with the new POA, and activate the new POA.
//Server.java
import org.omg.CORBA.ORB;
import org.omg.CORBA.LocalObject;
import org.omg.CORBA.Policy;
import org.omg.PortableServer.POA;
import org.omg.PortableServer.POAHelper;
import org.omg.PortableServer.AdapterActivator;
import org.omg.PortableServer.IdAssignmentPolicyValue;
import org.omg.PortableServer.LifespanPolicyValue;
import org.omg.PortableServer.ImplicitActivationPolicyValue;
import org.omg.CosNaming.NamingContext;
import org.omg.CosNaming.NamingContextHelper;
import org.omg.CosNaming.NameComponent;

public class Server {

    public void run(String[] args) {
        try {
            //initialize the orb
            ORB orb = ORB.init(args, null);
            System.out.println("ORB initialized");

            //resolve RootPOA
            POA rootPOA = POAHelper.narrow(
                orb.resolve_initial_references("RootPOA"));

            //register adapter activator with rootPOA so that child POAs can
            //be created on demand
            rootPOA.the_activator(new MyAdapterActivator());

            //find_POA with an activate parameter TRUE would cause the
            //adapter activator associated with rootPOA to be invoked if
            //'HelloPOA' does not exist
            POA childPOA = rootPOA.find_POA("HelloPOA", true);

            //Create the object reference for HelloServant
            //and register with naming service
            org.omg.CORBA.Object obj = childPOA.id_to_reference(
                "abcd".getBytes());
            Hello helloRef = HelloHelper.narrow(obj);

            NamingContext namingContext = NamingContextHelper.narrow(
                orb.resolve_initial_references("NameService"));
            NameComponent[] nc = { new NameComponent("HelloServer", "") };
            namingContext.rebind(nc, helloRef);

            //Destroy 'HelloPOA'. This POA will be transparently recreated when
            //ORB receives a request on HelloPOA using the adapter activator we
            //registered with the RootPOA
            childPOA.destroy(true, true);

            //activate rootPOA
            rootPOA.the_POAManager().activate();

            //wait for incoming requests
            System.out.println("Server ready and running....");
            orb.run();
        } catch (Exception e) {
            e.printStackTrace();
        }
    }

    public static void main(String[] args) {
        new Server().run(args);
    }
}

class MyAdapterActivator extends LocalObject implements AdapterActivator {

    public boolean unknown_adapter(POA parent, String name) {
        System.out.println("unknown_adapter() invoked for POA - " + name);
        try {
            // create the POA with appropriate policies
            // this sample uses PERSISTENT, NO_IMPLICIT_ACTIVATION
            // and USER_ID policies
            Policy[] policy = new Policy[3];
            policy[0] = parent.create_lifespan_policy(
                LifespanPolicyValue.PERSISTENT);
            policy[1] = parent.create_id_assignment_policy(
                IdAssignmentPolicyValue.USER_ID);
            policy[2] = parent.create_implicit_activation_policy(
                ImplicitActivationPolicyValue.NO_IMPLICIT_ACTIVATION);

            POA child = parent.create_POA(name, null, policy);

            //Associate the servant with the new POA
            HelloServant hello = new HelloServant();
            child.activate_object_with_id("abcd".getBytes(), hello);

            //activate the new POA
            child.the_POAManager().activate();

            return true;
        } catch (Exception e) {
            e.printStackTrace();
        }
        return false;
    }
}

Hello.idl

This Interface Definition Language (IDL) file is used in all of the "Hello World" example variations on this site. This IDL file describes a CORBA object whose sayHello() operation returns a string.
interface Hello { string sayHello(); };

HelloServant.java

The servant is the implementation of the Hello IDL interface; each Hello instance is implemented by a HelloServant instance. The servant is a subclass of HelloPOA, which is generated by the idlj compiler from the example IDL. The servant contains one method for each IDL operation, in this example, the sayHello() method. Servant methods are just like ordinary Java methods; the extra code to deal with the ORB, with marshaling arguments and results, and so on, is provided by the skeleton.
//HelloServant.java
public class HelloServant extends HelloPOA {

    public String sayHello() {
        return "Hello :)";
    }
}

Makefile

The make program generates a sequence of commands for execution by the shell on Solaris, Linux, or Mac OS X.

JAVA_HOME=<path_to_your_Java_installation_bin_directory>

#setup tools
JAVA=$(JAVA_HOME)/bin/java
JAVAC=$(JAVA_HOME)/bin/javac
IDLJ=$(JAVA_HOME)/bin/idlj
ORBD=$(JAVA_HOME)/bin/orbd

all     : clean build run

clean   :
        - rm -rf classes orb.db

build   :
        mkdir -p classes
        $(IDLJ) -fall -td classes Hello.idl
        $(JAVAC) -classpath classes -d classes HelloServant.java Server.java Client.java

run     : runorbd register runclient

runorbd :
        $(ORBD) -ORBInitialPort 10001 &
        sleep 20

register:
        #servertool does not support script based register due to a bug
        #using class instead
        #Please note that the name of the servertool
        #class may change in future releases.
        $(JAVA) com.sun.corba.se.internal.Activation.ServerTool \
        -ORBInitialPort 10001 -cmd \
        register -server Server -classpath classes

runclient :
        $(JAVA) -classpath classes Client -ORBInitialPort 10001

run.bat

The bat utility generates a sequence of commands for execution by the Microsoft Windows command shell.

SET JAVA_HOME=<path_to_your_Java_installation_build_directory>

mkdir classes

%JAVA_HOME%\bin\idlj -fall -td classes Hello.idl
%JAVA_HOME%\bin\javac -classpath classes -d classes HelloServant.java Server.java Client.java

REM - Start the ORB daemon

start %JAVA_HOME%\bin\orbd -ORBInitialPort 10001 -ORBDebug orbd
@echo Wait 10-15 seconds for the orbd to start
@pause

REM - Register the persistent server with orbd using servertool
REM - Please note that the name of the servertool
REM - class may change in future releases.
%JAVA_HOME%\bin\java com.sun.corba.se.internal.Activation.ServerTool -ORBInitialPort 10001 -cmd register -server Server -classpath classes

%JAVA_HOME%\bin\java -classpath classes Client -ORBInitialPort 10001

Running the Example Adapter Activator Application

To run this example,

  • Create the files using the code shown above.
  • Run the example using either of these methods:
    • If you have the Make utility, run the application using the Makefile:

      make all

    • If you have the batch utility, run the application using run.bat. From the application directory, enter:

      run

You will see output generated to the terminal window similar to that below when you run the Makefile:

rm -rf classes orb.db mkdir -p classes /j2sdk1.5.0/bin/idlj -fall -td classes Hello.idl /j2sdk1.5.0/bin/javac -classpath classes -d classes HelloServant.java Server.java Client.java /j2sdk1.5.0/bin/orbd -ORBInitialPort 10001 & sleep 20 #servertool does not support script based register due to a bug #using class instead #Please note that the name of the servertool
#class may change in future releases.
/j2sdk1.5.0/bin/java com.sun.corba.se.internal.Activation.ServerTool \
-ORBInitialPort 10001 -cmd \
register -server Server -classpath classes

        server registered (serverid = 257).

/j2sdk1.5.0/bin/java -classpath classes Client -ORBInitialPort 10001
ORB initialized
Resolved HelloServant
Hello :)
Shut down ORBD when you have completed this example.
  • If using the Solaris, Linux, or Mac OS X operating system, type pkill orbd in the terminal window.
  • If using Microsoft Windows, enter Ctrl+C in the command prompt window.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Skip navigation bar
Contents | Previous | Next

Chapter 4

Using JMX Agents

A Java Management Extensions (JMX) agent is a management entity that runs in a Java Virtual Machine (Java VM) and acts as the liaison between the MBeans and the management application. The various components of a JMX agent are outlined in the following sections:

  • "MBean Server"
  • "Agent Services"
  • "Protocol Adaptors and Connectors"

MBean Server

The MBean server is the core component of a JMX agent. It is a registry for objects that are exposed to management operations in an agent. Any object registered with the MBean server becomes visible to management applications. However, the MBean server only exposes the management interface of an MBean, never its direct object reference.

Any resource that you want to manage from outside the agent’s Java VM must be registered as an MBean in the server. The MBean server also provides a standardized interface for accessing MBeans within the same Java VM, giving local objects all the benefits of manipulating manageable resources. MBeans can be instantiated and registered by:

  • Another MBean
  • The agent itself
  • A remote management application

When you register an MBean, you must assign it a unique object name. A management application uses the object name to identify the object on which it is to perform a management operation. The operations available on MBeans include:

  • Discovering the management interface of MBeans
  • Reading and writing their attribute values
  • Performing operations defined by the MBeans
  • Getting notifications emitted by MBeans
  • Querying MBeans based on their object name or their attribute values

Agent Services

Agent services are objects that can perform management operations on the MBeans registered in the MBean server. By including management intelligence into the agent, JMX helps you build more powerful management solutions. Agent services are often MBeans as well, allowing them and their functionality to be controlled through the MBean server. The JMX specification defines the following agent services:

  • Dynamic class loading through the management applet (m-let) service retrieves and instantiates new classes and native libraries dynamically downloaded from the network.
  • Monitors observe the numerical or string value of MBean attributes and can notify other objects of several types of changes.
  • Timers provide a scheduling mechanism and can send notifications at predetermined intervals.
  • The relation service defines associations between MBeans and maintains the consistency of the relation.

Protocol Adaptors and Connectors

Protocol adaptors and connectors make the agent accessible from remote management applications. They provide a view through a specific protocol of the MBeans instantiated and registered in the MBean server. They enable a management application outside the Java VM to:

  • Get or set attributes of existing MBeans
  • Perform operations on existing MBeans
  • Instantiate and register new MBeans
  • Register for and receive notifications emitted by MBeans

Consequently, for a JMX agent to be manageable, it must include at least one protocol adaptor or connector. The Java SE platform includes the standard RMI connector. An agent can include any number of protocol adaptors and connectors, allowing it to be managed and monitored remotely through different protocols simultaneously.

Protocol Adaptors

Protocol adaptors provide a management view of the JMX agent through a given protocol. They adapt the operations of MBeans and the MBean server into a representation in the given protocol, and possibly into a different information model, for example SNMP. The Java SE platform does not include any protocol adaptors as standard.

Management applications that connect to a protocol adaptor are usually specific to the given protocol. This is typically the case for legacy management solutions that rely on a specific management protocol. They access the JMX agent not through a remote representation of the MBean server, but through operations that are mapped to those of the MBean server.

Connectors

Connectors are used to connect an agent with a remote management application enabled for JMX technology, namely, a management application developed using the distributed services of the JMX specification. This kind of communication involves a connector server in the agent and a connector client in the manager.

These components convey management operations transparently point-to-point over a specific protocol. The JMX Remote API provides a remote interface to the MBean server through which the management application can perform operations. A connector is specific to a given protocol, but the management application can use any connector indifferently because they have the same remote interface.

See Chapter 5, "Using JMX Connectors to Manage Resources Remotely" for more information on standard JMX connectors.

Contents | Previous | Next

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.tools.attach.AgentInitializationException (Attach API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.tools.attach.AgentInitializationException

  • Packages that use AgentInitializationException
    Package Description
    com.sun.tools.attach
    Provides the API to attach to a JavaTM virtual machine.

    • Uses of AgentInitializationException in com.sun.tools.attach

      Methods in com.sun.tools.attach that throw AgentInitializationException
      Modifier and Type Method and Description
      void VirtualMachine.loadAgent(String agent)
      Loads an agent.
      abstract void VirtualMachine.loadAgent(String agent, String options)
      Loads an agent.
      void VirtualMachine.loadAgentLibrary(String agentLibrary)
      Loads an agent library.
      abstract void VirtualMachine.loadAgentLibrary(String agentLibrary, String options)
      Loads an agent library.
      void VirtualMachine.loadAgentPath(String agentPath)
      Load a native agent library by full pathname.
      abstract void VirtualMachine.loadAgentPath(String agentPath, String options)
      Load a native agent library by full pathname.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.tools.attach.AgentLoadException (Attach API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.tools.attach.AgentLoadException

  • Packages that use AgentLoadException
    Package Description
    com.sun.tools.attach
    Provides the API to attach to a JavaTM virtual machine.

    • Uses of AgentLoadException in com.sun.tools.attach

      Methods in com.sun.tools.attach that throw AgentLoadException
      Modifier and Type Method and Description
      void VirtualMachine.loadAgent(String agent)
      Loads an agent.
      abstract void VirtualMachine.loadAgent(String agent, String options)
      Loads an agent.
      void VirtualMachine.loadAgentLibrary(String agentLibrary)
      Loads an agent library.
      abstract void VirtualMachine.loadAgentLibrary(String agentLibrary, String options)
      Loads an agent library.
      void VirtualMachine.loadAgentPath(String agentPath)
      Load a native agent library by full pathname.
      abstract void VirtualMachine.loadAgentPath(String agentPath, String options)
      Load a native agent library by full pathname.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.javadoc.AnnotatedType (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.AnnotatedType

    • Uses of AnnotatedType in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotatedType
      Modifier and Type Method and Description
      AnnotatedType Type.asAnnotatedType()
      Returns this type as a AnnotatedType if it represents an annotated type.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.source.tree.AnnotatedTypeTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.AnnotatedTypeTree

  • Packages that use AnnotatedTypeTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of AnnotatedTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type AnnotatedTypeTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitAnnotatedType(AnnotatedTypeTree node, P p)

    • Uses of AnnotatedTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AnnotatedTypeTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitAnnotatedType(AnnotatedTypeTree node, P p)
      R | TreeScanner.visitAnnotatedType(AnnotatedTypeTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.javadoc.AnnotationDesc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.AnnotationDesc

    • Uses of AnnotationDesc in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationDesc
      Modifier and Type | Method and Description
      AnnotationDesc[] Parameter.annotations()
      Get the annotations of this parameter.
      AnnotationDesc[] ProgramElementDoc.annotations()
      Get the annotations of this program element.
      AnnotationDesc[] PackageDoc.annotations()
      Get the annotations of this package.
      AnnotationDesc[] | AnnotatedType.annotations()
      AnnotationDesc[] TypeVariable.annotations()
      Get the annotations of this program element.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.javadoc.AnnotationDesc.ElementValuePair (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.AnnotationDesc.ElementValuePair

    • Uses of AnnotationDesc.ElementValuePair in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationDesc.ElementValuePair
      Modifier and Type Method and Description
      AnnotationDesc.ElementValuePair[] AnnotationDesc.elementValues()
      Returns this annotation's elements and their values.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Annotations

Many APIs require a fair amount of boilerplate code. For example, in order to write a JAX-RPC web service, you must provide a paired interface and implementation. This boilerplate could be generated automatically by a tool if the program were “decorated” with annotations indicating which methods were remotely accessible.

Other APIs require “side files” to be maintained in parallel with programs. For example JavaBeans requires a BeanInfo class to be maintained in parallel with a bean, and Enterprise JavaBeans (EJB) requires a deployment descriptor. It would be more convenient and less error-prone if the information in these side files were maintained as annotations in the program itself.

The Java platform has always had various ad hoc annotation mechanisms. For example the transient modifier is an ad hoc annotation indicating that a field should be ignored by the serialization subsystem, and the @deprecated javadoc tag is an ad hoc annotation indicating that the method should no longer be used. The platform has a general purpose annotation (also known as metadata) facility that permits you to define and use your own annotation types. The facility consists of a syntax for declaring annotation types, a syntax for annotating declarations, APIs for reading annotations, a class file representation for annotations, and annotation processing support provided by the javac tool.

Annotations do not directly affect program semantics, but they do affect the way programs are treated by tools and libraries, which can in turn affect the semantics of the running program. Annotations can be read from source files, class files, or reflectively at run time.

Annotations complement javadoc tags. In general, if the markup is intended to affect or produce documentation, it should probably be a javadoc tag; otherwise, it should be an annotation.

Typical application programmers will never have to define an annotation type, but it is not hard to do so. Annotation type declarations are similar to normal interface declarations. An at-sign (@) precedes the interface keyword. Each method declaration defines an element of the annotation type. Method declarations must not have any parameters or a throws clause. Return types are restricted to primitives, String, Class, enums, annotations, and arrays of the preceding types. Methods can have default values. Here is an example annotation type declaration:

/**
 * Describes the Request-For-Enhancement(RFE) that led
 * to the presence of the annotated API element.
 */
public @interface RequestForEnhancement {
    int    id();
    String synopsis();
    String engineer() default "[unassigned]";
    String date()    default "[unimplemented]";
}

Once an annotation type is defined, you can use it to annotate declarations. An annotation is a special kind of modifier, and can be used anywhere that other modifiers (such as public, static, or final) can be used. By convention, annotations precede other modifiers. Annotations consist of an at-sign (@) followed by an annotation type and a parenthesized list of element-value pairs. The values must be compile-time constants. Here is a method declaration with an annotation corresponding to the annotation type declared above:

@RequestForEnhancement(
    id       = 2868724,
    synopsis = "Enable time-travel",
    engineer = "Mr. Peabody",
    date     = "4/1/3007"
)
public static void travelThroughTime(Date destination) { ... }

An annotation type with no elements is termed a marker annotation type, for example:

/**
 * Indicates that the specification of the annotated API element
 * is preliminary and subject to change.
 */
public @interface Preliminary { }

It is permissible to omit the parentheses in marker annotations, as shown below:

@Preliminary public class TimeTravel { ... }

In annotations with a single element, the element should be named value, as shown below:

/**
 * Associates a copyright notice with the annotated API element.
 */
public @interface Copyright {
    String value();
}

It is permissible to omit the element name and equals sign (=) in a single-element annotation whose element name is value, as shown below:

@Copyright("2002 Yoyodyne Propulsion Systems")
public class OscillationOverthruster { ... }

To tie it all together, we'll build a simple annotation-based test framework. First we need a marker annotation type to indicate that a method is a test method, and should be run by the testing tool:

import java.lang.annotation.*;

/**
 * Indicates that the annotated method is a test method.
 * This annotation should be used only on parameterless static methods.
 */
@Retention(RetentionPolicy.RUNTIME)
@Target(ElementType.METHOD)
public @interface Test { }

Note that the annotation type declaration is itself annotated. Such annotations are called meta-annotations. The first (@Retention(RetentionPolicy.RUNTIME)) indicates that annotations with this type are to be retained by the VM so they can be read reflectively at run-time. The second (@Target(ElementType.METHOD)) indicates that this annotation type can be used to annotate only method declarations.

Here is a sample program, some of whose methods are annotated with the above interface:

public class Foo {
    @Test public static void m1() { }
    public static void m2() { }
    @Test public static void m3() {
        throw new RuntimeException("Boom");
    }
    public static void m4() { }
    @Test public static void m5() { }
    public static void m6() { }
    @Test public static void m7() {
        throw new RuntimeException("Crash");
    }
    public static void m8() { }
}

Here is the testing tool:

import java.lang.reflect.*;

public class RunTests {
   public static void main(String[] args) throws Exception {
      int passed = 0, failed = 0;
      for (Method m : Class.forName(args[0]).getMethods()) {
         if (m.isAnnotationPresent(Test.class)) {
            try {
               m.invoke(null);
               passed++;
            } catch (Throwable ex) {
               System.out.printf("Test %s failed: %s %n", m, ex.getCause());
               failed++;
            }
         }
      }
      System.out.printf("Passed: %d, Failed %d%n", passed, failed);
   }
}

The tool takes a class name as a command line argument and iterates over all the methods of the named class attempting to invoke each method that is annotated with the Test annotation type (defined above). The reflective query to find out if a method has a Test annotation is highlighted in green. If a test method invocation throws an exception, the test is deemed to have failed, and a failure report is printed. Finally, a summary is printed showing the number of tests that passed and failed. Here is how it looks when you run the testing tool on the Foo program (above):

$ java RunTests Foo
Test public static void Foo.m3() failed: java.lang.RuntimeException: Boom
Test public static void Foo.m7() failed: java.lang.RuntimeException: Crash
Passed: 2, Failed 2
While this testing tool is clearly a toy, it demonstrates the power of annotations and could easily be extended to overcome its limitations.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.AnnotationTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.AnnotationTree

  • Packages that use AnnotationTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of AnnotationTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type AnnotationTree
      Modifier and Type | Method and Description
      List<? extends AnnotationTree> | NewArrayTree.getAnnotations()
      List<? extends AnnotationTree> TypeParameterTree.getAnnotations()
      Return annotations on the type parameter declaration.
      List<? extends AnnotationTree> | AnnotatedTypeTree.getAnnotations()
      List<? extends AnnotationTree> | ModifiersTree.getAnnotations()
      List<? extends List<? extends AnnotationTree>> | NewArrayTree.getDimAnnotations()
      List<? extends AnnotationTree> | CompilationUnitTree.getPackageAnnotations()
      Methods in com.sun.source.tree with parameters of type AnnotationTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitAnnotation(AnnotationTree node, P p)

    • Uses of AnnotationTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AnnotationTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitAnnotation(AnnotationTree node, P p)
      R | TreeScanner.visitAnnotation(AnnotationTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.javadoc.AnnotationTypeDoc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.AnnotationTypeDoc

    • Uses of AnnotationTypeDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationTypeDoc
      Modifier and Type Method and Description
      AnnotationTypeDoc AnnotationDesc.annotationType()
      Returns the annotation type of this annotation.
      AnnotationTypeDoc[] PackageDoc.annotationTypes()
      Get included annotation types in this package.
      AnnotationTypeDoc Type.asAnnotationTypeDoc()
      Return this type as an AnnotationTypeDoc if it represents an annotation type.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.javadoc.AnnotationTypeElementDoc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.AnnotationTypeElementDoc

    • Uses of AnnotationTypeElementDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationTypeElementDoc
      Modifier and Type Method and Description
      AnnotationTypeElementDoc AnnotationDesc.ElementValuePair.element()
      Returns the annotation type element.
      AnnotationTypeElementDoc[] AnnotationTypeDoc.elements()
      Returns the elements of this annotation type.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.javadoc.AnnotationValue (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.AnnotationValue

    • Uses of AnnotationValue in com.sun.javadoc

      Methods in com.sun.javadoc that return AnnotationValue
      Modifier and Type Method and Description
      AnnotationValue AnnotationTypeElementDoc.defaultValue()
      Returns the default value of this element.
      AnnotationValue AnnotationDesc.ElementValuePair.value()
      Returns the value associated with the annotation type element.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


The Java Scripting API

Documentation Contents
Java Platform, Standard Edition Java Scripting Programmer's Guide
Contents Previous Next

2 The Java Scripting API

This chapter describes how the Java Scripting API (defined by JSR 223) is used to embed scripts in your Java applications, and provides a number of examples with Java classes, which demostrate the features of the Java Scripting API.

The Java Scripting API consists of classes and interfaces from the javax.script package. It is a relatively small and simple package with the ScriptEngineManager class as the starting point. A ScriptEngineManager object can discover script engines through the JAR file service discovery mechanism, and instantiate ScriptEngine objects that interpret scripts written in a specific scripting language. For more information about the javax.script package, see the Java SE specification at http://docs.oracle.com/javase/8/docs/api/javax/script/package-summary.html

The Nashorn engine is the default ECMAScript (JavaScript) engine bundled with the Java SE Development Kit (JDK). The Nashorn engine was developed fully in Java by Oracle as part of an OpenJDK project. You can find more information about the Nashorn project at http://openjdk.java.net/projects/nashorn/

Although Nashorn is the default ECMAScript engine used by the Java Scripting API, you can use any script engine compliant with JSR 223, or you can implement your own. This document does not cover the implementation of script engines compliant with JSR 223, but at the most basic level, you must implement the javax.script.ScriptEngine and javax.script.ScriptEngineFactory interfaces. The abstract class javax.script.AbstractScriptEngine provides useful defaults for a few methods in the ScriptEngine interface.

To use the Java Scripting API:

  1. Create a ScriptEngineManager object.

  2. Get a ScriptEngine object from the manager.

  3. Evaluate the script using the script engine's eval() method.

The following examples shows you how to use the Java Scripting API in Java. To keep the examples simple, exceptions are not handled. However, there are checked and runtime exceptions thrown by the Java Scripting API, and they should be properly handled. In every example, an instance of the ScriptEngineManager class is used to request the Nashorn engine (an object of the ScriptEngine class) using the getEngineByName() method. If the engine with the specified name is not present, null is returned. For more information about using the Nashorn engine, see the Nashorn User's Guide.

Note:

Each ScriptEngine object has its own variable scope. For information about using multiple variable scopes, see Example 8.

Example 1 - Evaluating a Statement

In this example, the eval() method is called on the script engine instance to execute JavaScript code from a String object.

import javax.script.*;

public class EvalScript {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // evaluate JavaScript code
        engine.eval("print('Hello, World')");
    }
}
Example 2 - Evaluating a Script File

In this example, the eval() method takes in a FileReader object that reads JavaScript code from a file named script.js. By wrapping various input stream objects as readers, it is possible to execute scripts from files, URLs, and other resources.

import javax.script.*;

public class EvalFile {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // evaluate JavaScript code
        engine.eval(new java.io.FileReader("script.js"));
    }
}
Example 3 - Exposing a Java Object as a Global Variable

In this example, a File object is created and exposed to the engine as a global variable named file using the put() method. Then the eval() method is called with JavaScript code that accesses the variable and calls the getAbsolutePath() method.

Note:

The syntax to access fields and call methods of Java objects exposed as variables depends on the scripting language. This example uses JavaScript syntax, which is similar to Java.

import javax.script.*;
import java.io.*;

public class ScriptVars {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // create File object
        File f = new File("test.txt");

        // expose File object as a global variable to the engine
        engine.put("file", f);

        // evaluate JavaScript code and access the variable
        engine.eval("print(file.getAbsolutePath())");
    }
}
Example 4 - Invoking a Script Function

In this example, the eval() method is called with JavaScript code that defines a function with one parameter. Then, an Invocable object is created and its invokeFunction() method is used to invoke the function.

Note:

Not all script engines implement the Invocable interface. This example uses the Nashorn engine, which can invoke functions in scripts that have previously been evaluated by this engine.

import javax.script.*;

public class InvokeScriptFunction {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // evaluate JavaScript code that defines a function with one parameter
        engine.eval("function hello(name) { print('Hello, ' + name) }");

        // create an Invocable object by casting the script engine object
        Invocable inv = (Invocable) engine;

        // invoke the function named "hello" with "Scripting!" as the argument
        inv.invokeFunction("hello", "Scripting!");
    }
}
Example 5 - Invoking a Script Object's Method

In this example, the eval() method is called with JavaScript code that defines an object with a method. This object is then exposed from the script to the Java application using the script engine's get() method. Then, an Invocable object is created, and its invokeMethod() method is used to invoke the method defined for the script object.

Note:

Not all script engines implement the Invocable interface. This example uses the Nashorn engine, which can invoke methods in scripts that have previously been evaluated by this engine.

import javax.script.*;

public class InvokeScriptMethod {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // evaluate JavaScript code that defines an object with one method
        engine.eval("var obj = new Object()");
        engine.eval("obj.hello = function(name) { print('Hello, ' + name) }");

        // expose object defined in the script to the Java application
        Object obj = engine.get("obj");

        // create an Invocable object by casting the script engine object
        Invocable inv = (Invocable) engine;

        // invoke the method named "hello" on the object defined in the script
        // with "Script Method!" as the argument
        inv.invokeMethod(obj, "hello", "Script Method!");
    }
}
Example 6 - Implementing a Java Interface with Script Functions

In this example, the eval() method is called with JavaScript code that defines a function. Then, an Invocable object is created, and its getInterface() method is used to create a Runnable interface object. The methods of the interface are implemented by script functions with matching names (in this case, the run() function is used to implement the run() method in the interface object). Finally, a new thread is started that runs the script function.

import javax.script.*;

public class ImplementRunnable {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // evaluate JavaScript code that defines a function with one parameter
        engine.eval("function run() { print('run() function called') }");

        // create an Invocable object by casting the script engine object
        Invocable inv = (Invocable) engine;

        // get Runnable interface object
        Runnable r = inv.getInterface(Runnable.class);

        // start a new thread that runs the script
        Thread th = new Thread(r);
        th.start();
        th.join();
    }
}
Example 7 - Implementing a Java Interface with the Script Object's Methods

In this example, the eval() method is called with JavaScript code that defines an object with a method. This object is then exposed from the script to the Java application using the script engine's get() method. Then, an Invocable object is created, and its getInterface() method is used to create a Runnable interface object. The methods of the interface are implemented by the script object's methods with matching names (in this case, the run method of the obj object is used to implement the run() method in the interface object). Finally, a new thread is started that runs the script object's method.

import javax.script.*;

public class ImplementRunnableObject {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // evaluate JavaScript code that defines a function with one parameter
        engine.eval("var obj = new Object()")
        engine.eval("obj.run = function() { print('obj.run() method called') }");

        // expose object defined in the script to the Java application
        Object obj = engine.get("obj");

        // create an Invocable object by casting the script engine object
        Invocable inv = (Invocable) engine;

        // get Runnable interface object
        Runnable r = inv.getInterface(obj, Runnable.class);

        // start a new thread that runs the script
        Thread th = new Thread(r);
        th.start();
        th.join();
    }
}
Example 8 - Using Multiple Scopes

In this example, the script engine's put() method is used to set the variable x to a String object hello. Then, the eval() method is used to print the variable in the default scope. Then, a different script context is defined, and its scope is used to set the same variable to a different value (a String object world). Finally, the variable is printed in the new script context that displays a different value.

A single scope is an instance of the javax.script.Bindings interface. This interface is derived from the java.util.Map<String, Object> interface. A scope is a set of name and value pairs where the name is a non-empty, non-null String object. The javax.script.ScriptContext interface supports multiple scopes with associated Bindings for each scope. By default, every script engine has a default script context. The default script context has at least one scope represented by the static field ENGINE_SCOPE. Various scopes supported by a script context are available through the getScopes() method.

import javax.script.*;

public class MultipleScopes {
    public static void main(String[] args) throws Exception {
        ScriptEngineManager manager = new ScriptEngineManager();
        ScriptEngine engine = manager.getEngineByName("nashorn");

        // set global variable
        engine.put("x","hello");

        // evaluate JavaScript code that prints the variable (x = "hello")
        engine.eval("print(x)");

        // define a different script context
        ScriptContext newContext = new SimpleScriptContext();
        newContext.setBindings(engine.createBindings(), ScriptContext.ENGINE_SCOPE);
        Bindings engineScope = newContext.getBindings(ScriptContext.ENGINE_SCOPE);

        // set the variable to a different value in another scope
        engineScope.put("x", "world");

        // evaluate the same code but in a different script context (x = "world")
        engine.eval("print(x)", newContext);
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Input Method Client API Reference

The following classes are part of the input method client API:

  • java.awt.event
    • java.awt.event.InputMethodEvent
    • java.awt.event.InputMethodListener
  • java.awt.im
    • java.awt.im.InputContext
    • java.awt.im.InputMethodHighlight
    • java.awt.im.InputMethodRequests
    • java.awt.im.InputSubset

    In addition, the following classes and members in other frameworks support the input method client API:

  • java.awt
    • java.awt.AWTEvent
      • INPUT_METHOD_EVENT_MASK
    • java.awt.AWTEventMulticaster
      • add(InputMethodListener, InputMethodListener)
      • caretPositionChanged(InputMethodEvent)
      • inputMethodTextChanged(InputMethodEvent)
      • remove(InputMethodListener, InputMethodListener)
    • java.awt.Component
      • addInputMethodListener(InputMethodListener)
      • enableInputMethods(boolean)
      • getInputContext()
      • getInputMethodRequests()
      • processInputMethodEvent(InputMethodEvent)
      • removeInputMethodListener(InputMethodListener)
    • java.awt.Graphics
      • drawString(AttributedCharacterIterator, int, int)
    • java.awt.Toolkit
      • mapInputMethodHighlight
    • java.awt.Window
      • getInputContext()
  • java.awt.font
    • java.awt.font.TextAttribute
      • INPUT_METHOD_UNDERLINE
      • UNDERLINE_LOW_ONE_PIXEL
      • UNDERLINE_LOW_TWO_PIXEL
      • UNDERLINE_LOW_DOTTED
      • UNDERLINE_LOW_GRAY
      • UNDERLINE_LOW_DASHED
  • java.lang
    • java.lang.Character.Subset
  • java.text
    • java.text.Annotation
    • java.text.AttributedCharacterIterator
    • java.text.AttributedCharacterIterator.Attribute
    • java.text.AttributedString

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Input Method Client API Tutorial

Contents

  1. Implementing an Active Client Component
    • Handling Input Method Events
    • Handling Input Method Highlight Attributes
    • Handling Input Method Requests
    • Ending Input Operations
  2. Enhancing an Active Client Component
    • Handling Additional Text Attributes
    • Creating Private Input Contexts
    • Selecting Input Methods
    • Setting an Expected Character Subset
    • Using Engine-Specific Functionality
  3. Implementing a Non-Client
  4. Sample Code

1. Implementing an Active Client Component

The input method client API makes it possible for client components to implement integrated text input user interfaces such as on-the-spot input. The API defines events and methods that facilitate the communication between a client component and an input method. It also lets the client component request an input method for a particular language.

Since the API doesn't make any assumptions about how and where the text is drawn, it can also be used to implement other input styles such as over-the-spot editing. In this style, the composed text is drawn over surrounding text and covers it instead of being integrated and formatted with it.

Any client component class can become an active client of the input method client API and thus support an integrated text input user interface by performing the following steps:

  • Implement the InputMethodListener interface to handle incoming InputMethodEvents generated by the current input method, and register the listener.
  • Implement the InputMethodRequests interface and override getInputMethodRequests to return the request handler.
  • Store InputMethodHighlight attributes along with composed text and pass them on to the drawing routines.
  • End input operations when the user initiates an operation that requires all text to be committed.

Optionally, the client component can also use the following functionality:

  • Store other text attributes that are created by input methods, and return them when text is requested.
  • Create a private input context (instead of sharing one with other components in the same window).
  • Select input methods, for example, based on the language of the text being edited.
  • Set an expected character subset.

Client components don't need to deal with setting up input contexts, activating or deactivating contexts, or dispatching events to input methods, since all this is handled automatically by AWT.

Handling Input Method Events

The input method framework provides an event class, InputMethodEvent, to support the communication between input methods and text components. The class has two separate event kinds: text changed and caret changed. An event listener interface, InputMethodListener, supports these two events. An active client component must implement the InputMethodListener interface, register the listener, and handle both kinds of events.

InputMethodEvent instances are sent to the client component when there is a change to the user's input text, its highlighting, or to the caret location within the composed text. The event sent for caret-only changes is a simplified version of the one for text changes (it just doesn't have text information), so the following discussion assumes the text-changed event.

An event reporting a text change has a reference to an instance of AttributedCharacterIterator that represents either composed text or committed text or both together. The event's committed character count value specifies how many characters in the iterator's range are committed text; all remaining characters are composed text. Committed text always precedes composed text. If the component has no previous composed text, the committed and composed text replace any selected text or are inserted at the current insertion position of the component's text. If there is previous composed text, the entire previous composed text is replaced with the new committed and composed text. The insertion point moves to the end of the committed text. The client component is responsible for redrawing the updated text.

The event also contains information about the current caret location within the composed text (null if no caret is to be displayed), and about the part of the composed text that is most important to keep in view (null if the input method doesn't have a recommendation).

Handling Input Method Highlight Attributes

The text component generally draws the composed text as part of the text being edited, using its regular text layout and drawing functionality. However, it needs to add certain highlight style attributes to the composed text to indicate the current state of the composition. The framework defines these style attributes as abstract styles (for example, "unconverted unselected text" or "converted selected text"), and maps them internally to platform-dependent concrete styles (for example, 2-pixel gray underline).

Highlight attributes are represented by the InputMethodHighlight class. Instances of this class are used as attribute values of the AttributedCharacterIterator instances representing composed text. Text components must store these attributes with the composed text and pass them on to the drawing routines when drawing composed text. They can use either the drawString methods that accept AttributedCharacterIterator, or create a TextLayout from the iterator and use its draw method. These drawing methods interact with the input method framework to map abstract to concrete highlight styles. Text components using these methods therefore generally do not need to be concerned with the internal details of the input method highlights. If a text component uses some other mechanism to render the text, it should check the input method highlight for concrete style information, and, if none is provided, use Toolkit.mapInputMethodHighlight to map to a concrete style.

Some input methods may treat highlights as "annotations". Annotations are attributes that apply to a specified range of text, but not to subranges or the concatenation of ranges. They are represented by wrapping the InputMethodHighlight instance into an Annotation instance. Input methods may use annotation highlights to separate text segments that will be converted as separate units. On some platforms, these highlights are rendered so as to make the segments visible, for example, by using underlines with short breaks between the segments. Text components have to be able to handle input method highlights whether they are wrapped in Annotation instances or not. If a text component implements line wrapping, special care needs to be taken when the range to which a highlight annotation applies crosses a line boundary: The normal behavior (implemented, for example, in AttributedString) would be to discard the attribute because it doesn't apply to subranges. But, since in this case there's only a visual break and not a logical break, the highlight needs to be preserved - it has to be treated as if it applied to the subranges that are rendered on separate lines. One way to do this is by implementing the AttributedCharacterIterator in a way that returns highlight annotations even for subranges of the intended range.

Handling Input Method Requests

An input method needs to access component information to perform input operations. For example, an input method needs to know the location where a list of possible choices can be shown.

An active client component therefore must implement the InputMethodRequests interface, and override getInputMethodRequests to return the request handler. The interface includes methods to:

  • Perform conversions between screen coordinates and offsets within the composed text.
  • Obtain specified text of the component.
  • Cancel the latest committed text.
  • Obtain the insertion position within the component's committed text.

Ending Input Operations

Input methods typically recognize some user actions that end input operations, for example, an operation that commits all uncommitted text. However, there are also user actions that start operations for which input operations should be ended, but that an input method cannot recognize. Saving the document containing the text is one such example. In these cases, the component has to explicitly call the input context's endComposition method.

2. Enhancing an Active Client Component

Handling Additional Text Attributes

In addition to the input method highlight information, input methods may also attach other attributes to the text they send to a text component. These attributes may be useful information for the component. They may also improve the input method's performance if returned by the InputMethodRequest methods. For the latter reason, it is recommended that text components keep this attribute information around while the text is being edited, and return it with any text requested.

The AttributedCharacterIterator.Attribute class defines the following common attributes:

  • LANGUAGE - the language of the text, specified as a Locale object.
  • READING - a phonetic representation (yomi in Japanese), specified as a String object.
  • INPUT_METHOD_SEGMENT - segmentation information used by input methods.

Input methods written in the Java programming language may define additional attributes.

Creating Private Input Contexts

By default, one InputContext instance is created per Window instance, and this input context is shared by all components within the window's containment hierarchy. This reduces the number of instances created overall, and lets input methods combine information about all the text entered in this window (input methods often use information about previously entered text to improve their conversion accuracy). It means, however, that only one input operation is possible at any one time within a window, and that the text needs to be committed when moving the focus from one text component to another. If this is not desired, text components can create their own input context instances and override getInputContext to return them. A component that doesn't have its own input context uses the one used by its parent.

Selecting Input Methods

Text components can use the input context's selectInputMethod operation to select an input method for a given language or locale. This may be helpful, for example, if the user clicks in text that is written in that language, since it's likely that she wants to continue in the same language. Or, the text component may know that the application only allows text in a certain language to be entered.

Setting an Expected Character Subset

Text components can use the input context's setCharacterSubsets operation to tell input methods which characters can be meaningfully entered. For example, a database application may know that certain fields should only receive input in hiragana (one of the syllabic subscripts used in Japanese), another one only Latin characters, a third one any kind of characters. Passing on this information to input methods may allow the input methods to limit the range of characters that can be entered, or to switch to a different input mode that particularly supports the specified character subsets.

Using Engine-Specific Functionality

Some input methods may provide functionality to client components that can not be made available through the input method framework API. This is possible through input method control objects. The input method developer must publish an interface for these objects. Client components that want to take advantage of the additional functionality can then call InputContext.getInputMethodControlObject, check whether the returned object is an instance of a known control object class, and if it is, call its methods.

3. Implementing a Non-Client

By default, all components that process key events are clients of the input method framework, that is, input method support is enabled for them. In some cases, components may not want to have their input processed by input methods. For example, games may want to interpret keyboard events directly. These components should call enableInputMethods(false), so that events do not get forwarded to input methods.

4. Sample Code

This sample code shows how to implement the different kinds of input method clients that are possible with the input method framework: an active client, a passive client, a non-client, and a peered text component.

  • Applet - run this applet in a browser, and you can experiment with the different client components.
  • Source Code
    • IMFDemo.java - the applet/application that contains the different client components.
    • LWTextComponent.java - a lightweight text editing component that doesn't know about input methods, but can be extended to an active client.
    • ActiveClient.java - extends LWTextComponent to become an active client component.
    • PeeredTextArea.java - a peered text component.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

Part VI

Appendix

This part describes troubleshooting guide appendix and contains the following topics.

  • Fatal Error Log

    Describes fatal error log contents and location.

  • Java 2D Properties

    Describes properties that are useful in troubleshooting issues with Java 2D.

  • Environment Variables and System Properties

    Describes environment variables and system properties that are useful in troubleshooting issues with Java HotSpot Server VM.

  • Command-Line Options

    Describes command-line options that are useful in diagnosing issues with Java HotSpot Server VM.

  • Summary of Tools in This Release

    Provides a summary of tools available in the current and previous release of JDK.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Code Overview: AudioSystem.java

Documentation Contents

< Contents

Appendix 1: Code Overview: AudioSystem.java

For the benefit of service providers and API implementers, a brief overview of the Java Sound source code is provided.

javax.sound.sampled.AudioSystem is the entry point to JavaSound for obtaining resources; i.e., mixers, lines, etc. And each method of AudioSystem involves getting the providers of some service—MixerProvider[], FormatConversionProvider[], AudioFileReader[], or AudioFileWriter[]. Then the method goes on to obtain some specific information or perform some task. There is much similarity in how these methods work. Let us take a look at how getMixerInfo() works.

The following is a sequence diagram of getMixerInfo() in AudioSystem.java:

Sequence diagram of getMixerInfo() in AudioSystem.java

getMixerInfo() in AudioSystem first calls getMixerProviders(), a private static method of AudioSystem. The first thing that getMixerProviders() does is attempt to load sun.misc.Service. If an exception is thrown, it means that a pre-1.3 JRE is in use and there is no service provider lookup mechanism present. If an exception is thrown, then sun.media.sound.DefaultServices is used to obtain service providers (not depicted in above diagram). If the 1.3 mechanims is present, then getJDK13Serives() is called (shown above) with "javax.sound.sampled.spi.MixerProvider" as the argument.

getJDK13Services() is another private static method of AudioSystem. It attempts to the load the class for "com.sun.media.sound.JDK13Services", and if it succeeds it set Class jdk13Services equal to it. A bit of trickery is then performed by using Class.getMethod() to get the getProviders() method of jdk13Services, which is returned as object Method m. The method is then invoked, which has the effect of invoking getProviders("javax.sound.sampled.spi.MixerProvider") on JDK13Services. This in turn uses the providers() method of sun.misc.Service to return a vector of mixer providers, MixerProvider[]. The getMixerInfo() method of MixerProvider is then called on each element of the vector to return info (Mixer.info) for all mixers of all mixer providers.

Other services are handled in a similar way. For
instance, getTargetEncodings() calls
getFormatConversionProviders(),
getAudioFileFormat() calls
getAudioFileReaders(), etc., which are similarly
structured to getMixerProviders().

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Code Overview: AudioSystem.java

Documentation Contents

< Contents

Appendix 2: sound.properties File

The Java Sound Configuration file, sound.properties, can be used to specify default service providers for javax.sound.sampled.AudioSystem and javax.sound.midi.MidiSystem.

Properties Keys

The following keys are recognized by AudioSystem methods:

javax.sound.sampled.Clip
javax.sound.sampled.Port
javax.sound.sampled.SourceDataLine
javax.sound.sampled.TargetDataLine

The following keys are recognized by MidiSystem methods:

javax.sound.midi.Sequencer
javax.sound.midi.Synthesizer
javax.sound.midi.Transmitter
javax.sound.midi.Receiver

The values should specify the full class name of the service provider and/or the device name.

sound.properties is located at $JAVAHOME/jre/lib.

For more details, see the class descriptions for AudioSystem and MidiSystem.

Examples

To use MyDeviceProvider as the default for SourceDataLine lines, set the following key:

javax.sound.sampled.SourceDataLine=com.xyz.MyDeviceProvider

To specify the default Synthesizer by its name InternalSynth, set the following key:

javax.sound.midi.Synthesizer=#InternalSynth

To specify the default Receiver by provider and name, set the following key:

javax.sound.midi.Receiver=com.sun.media.sound.MidiProvider#SunMIDI1

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents

Examples for LDAP Programmers

CONTENTS | PREV | NEXT

Appendix B:

This appendix contains sample JNDI programs intended to help a developer familiar with the LDAP C API. Starting with sample programs from the Netscape Directory SDK for accessing and updating the directory using the LDAP C API, we show the equivalent way of doing the same thing for Java applications using JNDI.

B.1 Search the Directory

B.2 Read An Entry

B.3 Get Attributes

B.4 Compare An Attribute

B.5 Modify Attributes

B.6 Rename An Entry

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


B.1 Search the Directory

CONTENTS | PREV | NEXT

Appendix B:

B.1.1 Search Using LDAP C API B.1.2 Search Using JNDI

B.1.1 Search Using LDAP C API

/*
 * Copyright (c) 1996. Netscape Communications Corporation.  All
 * rights reserved.
 *
 * Search the directory for all people whose surname (last name) is
 * "Jensen".
 * Since the "sn" attribute is a caseignorestring (cis), case
 * is not significant when searching.
 *
 */
#include "examples.h"
int
main( int argc, char **argv )
{
    LDAP *ld;
    LDAPMessage *result, *e;
    BerElement *ber;
    char *a, *dn;
    char **vals;
    int i;

    /* get a handle to an LDAP connection */
    if ( (ld = ldap_init( MY_HOST, MY_PORT )) == NULL ) {
        perror( ldap_init );
        return( 1 );
    }
    /* authenticate to the directory as nobody */
    if ( ldap_simple_bind_s( ld, NULL, NULL ) != LDAP_SUCCESS ) {
        ldap_perror( ld, ldap_simple_bind_s );
        return( 1 );
    }
    /* search for all entries with surname of Jensen */
    if ( ldap_search_s( ld, MY_SEARCHBASE, LDAP_SCOPE_SUBTREE,
        MY_FILTER, NULL, 0, &result ) != LDAP_SUCCESS ) {
            ldap_perror( ld, ldap_search_s );
            return( 1 );
    }
    /* for each entry print out name + all attrs and values */
    for ( e = ldap_first_entry( ld, result ); e != NULL;
        e = ldap_next_entry( ld, e ) ) {
            if ( (dn = ldap_get_dn( ld, e )) != NULL ) {
                printf( "dn: %s\n", dn );
                ldap_memfree( dn );
            }
            for ( a = ldap_first_attribute( ld, e, &ber );
                a != NULL; a = ldap_next_attribute( ld, e, ber ) ) {
                    if ((vals = ldap_get_values( ld, e, a)) != NULL ) {
                        for ( i = 0; vals[i] != NULL; i++ ) {
                            printf( "%s: %s\n", a, vals[i] );
                        }
                        ldap_value_free( vals );
                     }
                     ldap_memfree( a );
            }
            if ( ber != NULL ) {
                ber_free( ber, 0 );
            }
            printf( "\n" );
    }
    ldap_msgfree( result );
    ldap_unbind( ld );
    return( 0 );
}

B.1.2 Search Using JNDI

/*
 * Copyright (c) 1999 Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.util.Hashtable;
import java.util.Enumeration;
import javax.naming.*;
import javax.naming.directory.*;
/*
 * Search the directory for all people whose surname (last name) is
 * "Jensen".
 * Since the "sn" attribute is a caseignorestring (cis), case
 * is not significant when searching.
 *
 * [equivalent to search.c in Netscape's SDK.]
 *
 */
class Search {
public static void main(String[] args) {
    Hashtable env = new Hashtable(5, 0.75f);
    /*
     * Specify the initial context implementation to use.
     * This could also be set by using the -D option to the java program.
     * For example,
     *   java -Djava.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory \
     *     Search
     */
    env.put(Context.INITIAL_CONTEXT_FACTORY, Env.INITCTX);
    /* Specify host and port to use for directory service */
    env.put(Context.PROVIDER_URL, Env.MY_SERVICE);
    try {
        /* get a handle to an Initial DirContext */
        DirContext ctx = new InitialDirContext(env);
        /* specify search constraints to search subtree */
        SearchControls constraints = new SearchControls();
        constraints.setSearchScope(SearchControls.SUBTREE_SCOPE);
        /* search for all entries with surname of Jensen */
        NamingEnumeration results
            = ctx.search(Env.MY_SEARCHBASE, Env.MY_FILTER, constraints);
        /* for each entry print out name + all attrs and values */
        while (results != null && results.hasMore()) {
            SearchResult si = (SearchResult)results.next();
            /* print its name */
            System.out.println("name: " + si.getName());
            Attributes attrs = si.getAttributes();
            if (attrs == null) {
                System.out.println("No attributes");
            } else {
                /* print each attribute */
                for (NamingEnumeration ae = attrs.getAll();
                     ae.hasMoreElements();) {
                    Attribute attr = (Attribute)ae.next();
                    String attrId = attr.getID();
                    /* print each value */
                    for (Enumeration vals = attr.getAll();
                         vals.hasMoreElements();
                         System.out.println(attrId + ": " + vals.nextElement()))
                            ;
                }
            }
            System.out.println();
        }
    } catch (NamingException e) {
        System.err.println("Search example failed.");
        e.printStackTrace();
    }
}
}

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


B.2 Read An Entry

CONTENTS | PREV | NEXT

Appendix B:

B.2.1 Read Using LDAP C-API B.2.2 Read Using JNDI

B.2.1 Read Using LDAP C-API

/*
 * Copyright (c) 1996.  Netscape Communications Corporation.  All
 * rights reserved.
 *
 * Search the directory for the specific entry
 * "cn=Barbara Jensen, ou=Product Development, o=Ace Industry, c=US".
 * Retrieve all attributes from the entry.
 *
 */
#include "examples.h"
int
main( int argc, char **argv )
{
    LDAP        *ld;
    LDAPMessage *result, *e;
    BerElement  *ber;
    char        *a, *dn;
    char        **vals;
    int         i;
    /* get a handle to an LDAP connection */
    if ( (ld = ldap_init( MY_HOST, MY_PORT )) == NULL ) {
        perror( "ldap_init");
        return( 1 );
    }
    /* authenticate to the directory as nobody */
    if ( ldap_simple_bind_s( ld, NULL, NULL ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_simple_bind_s" );
        return( 1 );
    }
    /* search for Babs entry */
    if ( ldap_search_s( ld, ENTRYDN, LDAP_SCOPE_SUBTREE,
            "(objectclass=*)", NULL, 0, &result ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_search_s" );
        return( 1 );
    }
    /* for each entry print out name + all attrs and values */
    for ( e = ldap_first_entry( ld, result ); e != NULL;
            e = ldap_next_entry( ld, e ) ) {
        if ( (dn = ldap_get_dn( ld, e )) != NULL ) {
            printf( "dn: %s\n", dn );
            ldap_memfree( dn );
        }
        for ( a = ldap_first_attribute( ld, e, &ber );
                a != NULL; a = ldap_next_attribute( ld, e, ber ) ) {
            if ((vals = ldap_get_values( ld, e, a)) != NULL ) {
                for ( i = 0; vals[i] != NULL; i++ ) {
                    printf( "%s: %s\n", a, vals[i] );
                }
                ldap_value_free( vals );
            }
            ldap_memfree( a );
        }
        if ( ber != NULL ) {
            ber_free( ber, 0 );
        }
        printf( "\n" );
    }
    ldap_msgfree( result );
    ldap_unbind( ld );
    return( 0 );
}

B.2.2 Read Using JNDI

/*
 * @(#)Rdentry.java     1.2 99/07/26
 *
 * Copyright (c) 1997, 1999, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */
import java.util.Hashtable;

import javax.naming.*;
import javax.naming.directory.*;
/*
 * Search the directory for the specific entry
 * "cn=Barbara Jensen, ou=Product Development, o=Ace Industry, c=US".
 * Retrieve all attributes from the entry.
 *
 * [Equivalent to rdentry.c in Netscape SDK]
 */
class Rdentry {
public static void main(String[] args) {
    Hashtable env = new Hashtable(5, 0.75f);
    /*
     * Specify the initial context implementation to use.
     * This could also be set by using the -D option to the java program.
     * For example,
     *   java -Djava.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory \
     *       Rdentry
     */
    env.put(Context.INITIAL_CONTEXT_FACTORY, Env.INITCTX);
    /* Specify host and port to use for directory service */
    env.put(Context.PROVIDER_URL, Env.MY_SERVICE);
    try {
        /* get a handle to an Initial DirContext */
        DirContext ctx = new InitialDirContext(env);
        /* Read Babs' entry */
        Attributes attrs = ctx.getAttributes(Env.ENTRYDN);
        if (attrs == null) {
            System.out.println(Env.ENTRYDN + "has no attributes");
        } else {
            /* print each attribute */
            for (NamingEnumeration ae = attrs.getAll();
                 ae.hasMoreElements();) {
                Attribute attr = (Attribute)ae.next();
                String attrId = attr.getID();
                /* print each value */
                for (NamingEnumeration vals = attr.getAll();
                     vals.hasMoreElements();
                     System.out.println(attrId + ": " + vals.nextElement()))
                    ;
            }
        }
    } catch (NamingException e) {
        System.err.println("Rdentry example failed.");
        e.printStackTrace();
    }
}
}

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


B.3 Get Attributes

CONTENTS | PREV | NEXT

Appendix B:

B.3.1 Get Attributes Using LDAP C API B.3.2 Get Attributes Using JNDI

B.3.1 Get Attributes Using LDAP C API

/*
 * Copyright (c) 1996.  Netscape Communications Corporation.  All
 * rights reserved.
 *
 * Retrieve several attributes of a particular entry.
 */
#include "examples.h"

int
main( int argc, char **argv )
{
    LDAP                *ld;
    LDAPMessage         *result, *e;
    char                **vals, *attrs[ 5 ];
    int                 i;
    /* get a handle to an LDAP connection */
    if ( (ld = ldap_init( MY_HOST, MY_PORT )) == NULL ) {
        perror( "ldap_init" );
        return( 1 );
    }
    attrs[ 0 ] = "cn";         /* Get canonical name(s) (full name) */
    attrs[ 1 ] = "sn";         /* Get surname(s) (last name) */
    attrs[ 2 ] = "mail";       /* Get email address(es) */
    attrs[ 3 ] = "telephonenumber";      /* Get telephone number(s) */
    attrs[ 4 ] = NULL;
    if ( ldap_search_s( ld, ENTRYDN, LDAP_SCOPE_BASE,
            "(objectclass=*)", attrs, 0, &result ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_search_s" );
        return( 1 );
    }
    /* print it out */
    if (( e = ldap_first_entry( ld, result )) != NULL ) {
        if (( vals = ldap_get_values( ld, e, "cn" )) != NULL ) {
            printf( "Full name:\n" );
            for ( i = 0; vals[i] != NULL; i++ ) {
                printf( "\t%s\n", vals[i] );
            }
            ldap_value_free( vals );
        }
        if (( vals = ldap_get_values( ld, e, "sn" )) != NULL ) {
            printf( "Last name (surname):\n" );
            for ( i = 0; vals[i] != NULL; i++ ) {
                printf( "\t%s\n", vals[i] );
            }
            ldap_value_free( vals );
        }
        if (( vals = ldap_get_values( ld, e, "mail" )) != NULL ) {
            printf( "Email address:\n" );
            for ( i = 0; vals[i] != NULL; i++ ) {
                printf( "\t%s\n", vals[i] );
            }
            ldap_value_free( vals );
        }
        if (( vals = ldap_get_values( ld, e, "telephonenumber" )) != NULL ) {
            printf( "Telephone number:\n" );
            for ( i = 0; vals[i] != NULL; i++ ) {
                printf( "\t%s\n", vals[i] );
            }
            ldap_value_free( vals );
        }
    }
    ldap_msgfree( result );
    ldap_unbind( ld );
    return( 0 );
}

B.3.2 Get Attributes Using JNDI

/*
 *
 * @(#)Getattrs.java      1.2 99/07/26
 *
 * Copyright (c) 1997, 1999, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.util.Hashtable;
import java.util.Enumeration;

import javax.naming.*;
import javax.naming.directory.*;
/*
 * Retrieve several attributes of a particular entry.
 *
 * [equivalent to getattrs.c in Netscape SDK]
 */
class Getattrs {
public static void main(String[] args) {
    Hashtable env = new Hashtable(5, 0.75f);
    /*
     * Specify the initial context implementation to use.
     * For example,
     * This could also be set by using the -D option to the java program.
     *   java -Djava.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory \
     *       Getattrs
     */
    env.put(Context.INITIAL_CONTEXT_FACTORY, Env.INITCTX);
    /* Specify host and port to use for directory service */
    env.put(Context.PROVIDER_URL, Env.MY_SERVICE);
    try {
        /* get a handle to an Initial DirContext */
        DirContext ctx = new InitialDirContext(env);
        String[] attrs = new String[4];
        attrs[ 0 ] = "cn";              /* Get canonical name(s) (full name) */
        attrs[ 1 ] = "sn";              /* Get surname(s) (last name) */
        attrs[ 2 ] = "mail";            /* Get email address(es) */
        attrs[ 3 ] = "telephonenumber"; /* Get telephone number(s) */
        Attributes result = ctx.getAttributes(Env.ENTRYDN, attrs);
        if (result == null) {
            System.out.println(Env.ENTRYDN +
                               "has none of the specified attributes.");
        } else {
            /* print it out */
            Attribute attr = result.get("cn");
            if (attr != null) {
                System.out.println("Full name:" );
                for (NamingEnumeration vals = attr.getAll();
                     vals.hasMoreElements();
                     System.out.println("\t" + vals.nextElement()))
                    ;
            }
            attr = result.get("sn");
            if (attr != null) {
                System.out.println("Last name (surname):" );
                for (NamingEnumeration vals = attr.getAll();
                     vals.hasMoreElements();
                     System.out.println("\t" + vals.nextElement()))
                    ;
            }
            attr = result.get("mail");
            if (attr != null) {
                System.out.println("Email address:" );
                for (NamingEnumeration vals = attr.getAll();
                     vals.hasMoreElements();
                     System.out.println("\t" + vals.nextElement()))
                    ;
            }
            attr = result.get("telephonenumber");
            if (attr != null) {
                System.out.println("Telephone number:" );
                for (NamingEnumeration vals = attr.getAll();
                     vals.hasMoreElements();
                     System.out.println("\t" + vals.nextElement()))
                    ;
            }
        }
    } catch (NamingException e) {
        System.err.println("Getattrs example failed.");
        e.printStackTrace();
    }
}
}

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


B.4 Compare An Attribute

CONTENTS | PREV | NEXT

Appendix B:

B.4.1 Compare Using LDAP C API B.4.2 Compare Using JNDI

B.4.1 Compare Using LDAP C API

/*
 * Copyright (c) 1996.  Netscape Communications Corporation.  All
 * rights reserved.
 *
 * Use ldap_compare() to compare values agains values contained in entry
 * "cn=Barbara Jensen, ou=Product Development, o=Ace Industry, c=US".
 * We test to see if (1) the value "person" is one of the values in the
 * objectclass attribute (it is), and if (2) the value "xyzzy" is in the
 * objectlass attribute (it isn't, or at least, it shouldn't be).
 *
 */
#include "examples.h"
int
main( int main, char **argv )
{
    LDAP        *ld;
    int         rc;
    /* get a handle to an LDAP connection */
    if ( (ld = ldap_init( MY_HOST, MY_PORT )) == NULL ) {
        perror( "ldap_init" );
        return( 1 );
    }
    /* authenticate to the directory as nobody */
    if ( ldap_simple_bind_s( ld, NULL, NULL ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_simple_bind_s" );
        return( 1 );
    }
    /* compare the value "person" against the objectclass attribute */
    rc = ldap_compare_s( ld, ENTRYDN, "objectclass", "person" );
    switch ( rc ) {
    case LDAP_COMPARE_TRUE:
        printf( "The value \"person\" is contained in the objectclass "
                "attribute.\n" );
        break;
    case LDAP_COMPARE_FALSE:
        printf( "The value \"person\" is not contained in the objectclass "
                "attribute.\n" );
        break;
    default:
        ldap_perror( ld, "ldap_compare_s" );
    }
    /* compare the value "xyzzy" against the objectclass attribute */
    rc = ldap_compare_s( ld, ENTRYDN, "objectclass", "xyzzy" );
    switch ( rc ) {
    case LDAP_COMPARE_TRUE:
        printf( "The value \"xyzzy\" is contained in the objectclass "
                "attribute.\n" );
        break;
    case LDAP_COMPARE_FALSE:
        printf( "The value \"xyzzy\" is not contained in the objectclass "
                "attribute.\n" );
        break;
    default:
        ldap_perror( ld, "ldap_compare_s" );
    }
    ldap_unbind( ld );
    return( 0 );
}

B.4.2 Compare Using JNDI

/*
 * @(#)Compare.java       1.2 99/07/26
 *
 * Copyright (c) 1997, 1999, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 *
 */

import java.util.Hashtable;

import javax.naming.*;
import javax.naming.directory.*;
/*
 * Use search() to compare values against values contained in entry
 * "cn=Barbara Jensen, ou=Product Development, o=Ace Industry, c=US".
 * We test to see if (1) the value "person" is one of the values in the
 * objectclass attribute (it is), and if (2) the value "xyzzy" is in the
 * objectlass attribute (it isn't, or at least, it shouldn't be).
 *
 * [equivalent to compare.c in Netscape SDK]
 *
 */
class Compare {
public static void main(String[] args) {
    Hashtable env = new Hashtable(5, 0.75f);
    /*
     * Specify the initial context implementation to use.
     * This could also be set by using the -D option to the java program.
     * For example,
     *    java -Djava.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory \
     *       Compare
     */
    env.put(Context.INITIAL_CONTEXT_FACTORY, Env.INITCTX);
    /* Specify host and port to use for directory service */
    env.put(Context.PROVIDER_URL, Env.MY_SERVICE);
    DirContext ctx = null;
    SearchControls ctls = new SearchControls();
    ctls.setSearchScope(SearchControls.OBJECT_SCOPE);
    ctls.setReturningAttributes(new String[0]);  // do not return any attrs
    try {
        /* get a handle to an Initial DirContext */
        ctx = new InitialDirContext(env);
    } catch (NamingException e) {
        System.err.println("Cannot get initial context.");
        return;
    }
    try {
        NamingEnumeration results =
            ctx.search(Env.ENTRYDN, "objectclass=person", ctls);
        if (results != null && results.hasMoreElements()) {
            System.out.println(
                "The value \"person\" is contained in the objectclass attribute.");
        } else {
            System.out.println(
          "The value \"person\" is not contained in the objectclass attribute." );
        }
    } catch (NamingException e) {
        System.err.println("Comparison of value person failed.");
    }
    try {
        NamingEnumeration results =
            ctx.search(Env.ENTRYDN, "objectclass=xyzzy", ctls);

        if (results != null && results.hasMoreElements()) {
            System.out.println(
                "The value \"xyzzy\" is contained in the objectclass attribute.");
        } else {
            System.out.println(
          "The value \"xyzzy\" is not contained in the objectclass attribute." );
        }
    } catch (NamingException e) {
        System.err.println("Comparison of value xyzzy failed.");
    }
}
}

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


B.5 Modify Attributes

CONTENTS | PREV | NEXT

Appendix B:

B.5.1 Modify Attributes Using LDAP C API B.5.2 Modify Attributes Using JNDI

B.5.1 Modify Attributes Using LDAP C API

/*
 * Copyright (c) 1996.  Netscape Communications Corporation.  All
 * rights reserved.
 *
 * Modify an entry:
 *  - replace any existing values in the "mail" attribute with "babs@example.com"
 *  - add a new value to the "description" attribute
 */
#include "examples.h"
int
main( int argc, char **argv )
{
    LDAP        *ld;
    LDAPMod     mod0;
    LDAPMod     mod1;
    LDAPMod     *mods[ 3 ];
    char        *vals0[ 2 ];
    char        *vals1[ 2 ];
    time_t      now;
    char        buf[ 128 ];
    /* get a handle to an LDAP connection */
    if ( (ld = ldap_init( MY_HOST, MY_PORT )) == NULL ) {
        perror( "ldap_init" );
        return( 1 );
    }
    /* authenticate */
    if ( ldap_simple_bind_s( ld, ENTRYDN, ENTRYPW ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_simple_bind_s" );
        return( 1 );
    }
    /* construct the list of modifications to make */
    mod0.mod_op = LDAP_MOD_REPLACE;
    mod0.mod_type = "mail";
    vals0[0] = "babs@example.com";
    vals0[1] = NULL;
    mod0.mod_values = vals0;
    mod1.mod_op = LDAP_MOD_ADD;
    mod1.mod_type = "description";
    time( &now );
    sprintf( buf, "This entry was modified with the modattrs program on %s",
            ctime( &now ));
    /* Get rid of \n which ctime put on the end of the time string */
    if ( buf[ strlen( buf ) - 1 ] == '\n' ) {
        buf[ strlen( buf ) - 1 ] = '\0';
    }
    vals1[ 0 ] = buf;
    vals1[ 1 ] = NULL;
    mod1.mod_values = vals1;
    mods[ 0 ] = &mod0;
    mods[ 1 ] = &mod1;
    mods[ 2 ] = NULL;
    /* make the change */
    if ( ldap_modify_s( ld, ENTRYDN, mods )
            != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_modify_s" );
        return( 1 );
    }
    ldap_unbind( ld );
    printf( "modification was successful\n" );
    return( 0 );
}

Modify Attributes Using JNDI

/*
 * @(#)Modattrs.java      1.2 99/07/26
 *
 * Copyright (c) 1997, 1998, 1999, Oracle and/or its affiliates.
 * All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle or the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.util.Hashtable;
import java.util.Date;

import javax.naming.*;
import javax.naming.directory.*;
/*
 * Modify an entry:
 *  - replace any existing values in the "mail"
 *    attribute with "babs@example.com"
 *  - add a new value to the "description" attribute
 *
 * [equivalent to modattrs.c in Netscape SDK]
 */
class Modattrs {
public static void main(String[] args) {
    Hashtable env = new Hashtable(5, 0.75f);
    /*
     * Specify the initial context implementation to use.
     * This could also be set by using the -D option to the java program.
     * For example,
     *   java -Djava.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory \
     *       Modattrs
     */
    env.put(Context.INITIAL_CONTEXT_FACTORY, Env.INITCTX);
    /* Specify host and port to use for directory service */
    env.put(Context.PROVIDER_URL, Env.MY_SERVICE);
    /* specify authentication information */
    env.put(Context.SECURITY_AUTHENTICATION, "simple");
    env.put(Context.SECURITY_PRINCIPAL, Env.MGR_DN);
    env.put(Context.SECURITY_CREDENTIALS, Env.MGR_PW);
    try {
        /* get a handle to an Initial DirContext */
        DirContext ctx = new InitialDirContext(env);
        /* construct the list of modifications to make */
        ModificationItem[] mods = new ModificationItem[2];
        Attribute mod0 = new BasicAttribute("mail", "babs@eng");
        // Update mail attribute
        mods[0] = new ModificationItem(DirContext.REPLACE_ATTRIBUTE, mod0);
        // Add another value to description attribute
        Attribute mod1 =
            new BasicAttribute("description",
                          "This entry was modified with the Modattrs program on " +
                          (new Date()).toString());
        mods[1] = new ModificationItem(DirContext.ADD_ATTRIBUTE, mod1);
         /* Delete the description attribute altogether */
        /*
        Attribute mod1 =  new BasicAttribute("description");
        mods[2] = new ModificationItem(DirContext.REMOVE_ATTRIBUTE, mod1);
        */
        /* make the change */
        ctx.modifyAttributes(Env.ENTRYDN, mods);
        System.out.println( "modification was successful." );
    } catch (NamingException e) {
        System.err.println("modification failed. " + e);
    }
}
}

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


B.6 Rename An Entry

CONTENTS | PREV | NEXT

Appendix B:

B.6.1 Rename Using LDAP C API

 B.6.2 Rename Using JNDI

B.6.1 Rename Using LDAP C API

/*
 * Copyright (c) 1996.  Netscape Communications Corporation.  All
 * rights reserved.
 *
 * Modify the RDN (relative distinguished name) of an entry.  In this
 * example, we change the dn "cn=Jacques Smith, o=Ace Industry, c=US"
 * to "cn=Jacques M Smith, o=Ace Industry, c=US".
 *
 * Since it is an error to either (1) attempt to modrdn an entry which
 * does not exist, or (2) modrdn an entry where the destination name
 * already exists, we take some steps, for this example, to make sure
 * we will succeed.  We (1) add "cn=Jacques Smith" (if the entry exists,
 * we just ignore the error, and (2) delete "cn=Jacques M Smith" (if the
 * entry doesn't exist, we ignore the error).
 *
 * We pass 0 for the "deleteoldrdn" argument to ldap_modrdn2_s().  This
 * means that after we change the RDN, the server will put the value
 * "Jacques Smith" into the cn attribute of the new entry, in addition to
 * "Jacques M Smith".
 */
#include "examples.h"
#define        NMODS        4
unsigned long        global_counter = 0;
static void free_mods( LDAPMod **mods );
int
main( int argc, char **argv )
{
    LDAP                    *ld;
    char                    *dn, *ndn, *nrdn;
    int                     i;
    int                     rc;
    LDAPMod                 **mods;
    /* Values we will use in creating the entry */
    char *objectclass_values[] = { "top", "person", "organizationalPerson",
                                   "inetOrgPerson", NULL };
    char *cn_values[] = { "Jacques Smith", NULL };
    char *sn_values[] = { "Smith", NULL };
    char *givenname_values[] = { "Jacques", NULL };
    /* Specify the DN we are adding */
    dn = "cn=Jacques Smith, o=Ace Industry, c=US";
    /* the destination DN */
    ndn = "cn=Jacques M Smith, o=Ace Industry, c=US";
    /* the new RDN */
    nrdn = "cn=Jacques M Smith";
    /* get a handle to an LDAP connection */
    if ( (ld = ldap_init( MY_HOST, MY_PORT )) == NULL ) {
        perror( "ldap_init" );
        return( 1 );
    }
    /* authenticate to the directory as the Directory Manager */
    if ( ldap_simple_bind_s( ld, MGR_DN, MGR_PW ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_simple_bind_s" );
        return( 1 );
    }
    if (( mods = ( LDAPMod ** ) malloc(( NMODS + 1 ) * sizeof( LDAPMod *)))
            == NULL ) {
        fprintf( stderr, "Cannot allocate memory for mods array\n" );
        return( 1 );
    }
    /* Construct the array of values to add */
    for ( i = 0; i < NMODS; i++ ) {
        if (( mods[ i ] = ( LDAPMod * ) malloc( sizeof( LDAPMod ))) == NULL ) {
            fprintf( stderr, "Cannot allocate memory for mods element\n" );
            return( 1 );
        }
    }
    mods[ 0 ]->mod_op = 0;
    mods[ 0 ]->mod_type = "objectclass";
    mods[ 0 ]->mod_values = objectclass_values;
    mods[ 1 ]->mod_op = 0;
    mods[ 1 ]->mod_type = "cn";
    mods[ 1 ]->mod_values = cn_values;
    mods[ 2 ]->mod_op = 0;
    mods[ 2 ]->mod_type = "sn";
    mods[ 2 ]->mod_values = sn_values;
    mods[ 3 ]->mod_op = 0;
    mods[ 3 ]->mod_type = "givenname";
    mods[ 3 ]->mod_values = givenname_values;
    mods[ 4 ] = NULL;

    /* Add the entry */
    if (( rc = ldap_add_s( ld, dn, mods )) != LDAP_SUCCESS ) {
        /* If entry exists already, fine.  Ignore this error. */
        if ( rc == LDAP_ALREADY_EXISTS ) {
            printf( "Entry \"%s is already in the directory.\n", dn );
        } else {
            ldap_perror( ld, "ldap_add_s" );
            free_mods( mods );
            return( 1 );
        }
    } else {
        printf( "Added entry \"%s\".\n", dn );
    }
    free_mods( mods );
    /* Delete the destination entry, for this example */
    if (( rc = ldap_delete_s( ld, ndn )) != LDAP_SUCCESS ) {
        /* If entry does not exist, fine.  Ignore this error. */
        if ( rc == LDAP_NO_SUCH_OBJECT ) {
            printf( "Entry \"%s\" is not in the directory.  "
                    "No need to delete.\n", ndn );
        } else {
            ldap_perror( ld, "ldap_delete_s" );
            return( 1 )
        }
    } else {
        printf( "Deleted entry \"%s\".\n", ndn );
    }
    /* Do the modrdn operation */
    if ( ldap_modrdn2_s( ld, dn, nrdn, 0 ) != LDAP_SUCCESS ) {
        ldap_perror( ld, "ldap_modrdn2_s" );
        return( 1 );
    }
    printf( "The modrdn operation was successful.  Entry\n"
            "\"%s\" has been changed to\n"
            "\"%s\".\n", dn, ndn );
    ldap_unbind( ld );
    return 0;
}

/*
 * Free a mods array.
 */
static void
free_mods( LDAPMod **mods )
{
    int i;

    for ( i = 0; i < NMODS; i++ ) {
        free( mods[ i ] );
    }
    free( mods );
}

B.6.2 Rename Using JNDI

/*
 * @(#)Modrdn.java      1.2 99/07/26
 *
 * Copyright (c) 1997, 1999, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 *
 */

import java.util.Hashtable;
import java.util.Date;

import javax.naming.*;
import javax.naming.directory.*;
/*
 * Modify the RDN (relative distinguished name) of an entry.  In this
 * example, we change the dn "cn=Jacques Smith, o=Ace Industry, c=US"
 * to "cn=Jacques M Smith, o=Ace Industry, c=US".
 *
 * Since it is an error to either (1) attempt to modrdn an entry which
 * does not exist, or (2) modrdn an entry where the destination name
 * already exists, we take some steps, for this example, to make sure
 * we'll succeed.  We (1) add "cn=Jacques Smith" (if the entry exists,
 * we just ignore the error, and (2) delete "cn=Jacques M Smith" (if the
 * entry doesn't exist, we ignore the error).
 *
 * After renaming, we add back the attribute "Jacques Smith" into the cn
 * attribute.
 *
 * [based on modrdn.c of Netscape  SDK]
 */
class Modrdn {
public static void main(String[] args) {
    /* Values we'll use in creating the entry */
    Attribute objClasses = new BasicAttribute("objectclass");
    objClasses.add("top");
    objClasses.add("person");
    objClasses.add("organizationalPerson");
    objClasses.add("inetOrgPerson");
    Attribute cn = new BasicAttribute("cn", "Jacques Smith");
    Attribute sn = new BasicAttribute("sn", "Smith");
    Attribute givenNames = new BasicAttribute("givenname", "Jacques");
    /* Specify the DN we're adding */
    String dn = "cn=Jacques Smith, " + Env.MY_MODBASE;
    /* the destination DN */
    String ndn = "cn=Jacques M Smith, " + Env.MY_MODBASE;
    /* the new RDN */
    String nrdn = "cn=Jacques M Smith";
    Hashtable env = new Hashtable(5, 0.75f);
    /*
     * Specify the initial context implementation to use.
     * This could also be set by using the -D option to the java program.
     * For example,
     *   java -Djava.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory \
     *       Modrdn
     */
    env.put(Context.INITIAL_CONTEXT_FACTORY, Env.INITCTX);
    /* Specify host and port to use for directory service */
    env.put(Context.PROVIDER_URL, Env.MY_SERVICE);
    /* specify authentication information */
    env.put(Context.SECURITY_AUTHENTICATION, "simple");
    env.put(Context.SECURITY_PRINCIPAL, Env.MGR_DN);
    env.put(Context.SECURITY_CREDENTIALS, Env.MGR_PW);
    DirContext ctx = null;
    try {
        /* get a handle to an Initial DirContext */
        ctx = new InitialDirContext(env);
        Attributes orig = new BasicAttributes();
        orig.put(objClasses);
        orig.put(cn);
        orig.put(sn);
        orig.put(givenNames);
        /* Add the entry */
        ctx.createSubcontext(dn, orig);
        System.out.println( "Added entry " + dn + ".");
    } catch (NameAlreadyBoundException e) {
        /* If entry exists already, fine.  Ignore this error. */
        System.out.println("Entry " + dn + " already exists, no need to add");
    } catch (NamingException e) {
        System.err.println("Modrdn: problem adding entry." + e);
        System.exit(1);
    }
    try {
        /* Delete the destination entry, for this example */
        ctx.destroySubcontext(ndn);
        System.out.println( "Deleted entry " + ndn + "." );
    } catch (NameNotFoundException e) {
        /* If entry does not exist, fine.  Ignore this error. */
        System.out.println( "Entry " + ndn + " is not in the directory.  " +
                    "No need to delete.");
    } catch (NamingException e) {
        System.err.println("Modrdn: problem deleting entry." + e);
        System.exit(1);
    }

    /* Do the modrdn operation */
    try {
        ctx.rename(dn, ndn);
        System.out.println("The modrdn operation was successful.  Entry " +
                           dn + " has been changed to " + ndn + ".");
    } catch (NamingException e) {
        System.err.println("Modify operation failed." + e);
    }
}
}

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Skip navigation bar
Contents | Previous | Next

Appendix A

JMX Technology Versions

Java Management Extensions Technology (JMX) became a standard part of the Java platform in the Java Platform Standard Edition (Java SE) 5.0. The JMX technology was developed through the Java Community Process (JCP) as two closely related Java Specification Requests (JSRs). The versions of the JSRs implemented in Java SE 5.0 are detailed in the following sections.

Java Management Extensions (JMX) Instrumentation and Agent Specification (JSR 3)

The Java SE 6 platform implements version 1.4 of the JMX Specification (Maintenance Release, October 2006). It incorporates the modifications listed in the errata provided with the download.

JMX Remote API Specification (JSR 160)

The Java SE 6 platform implements version 1.4 of the JMX Remote API Specification (Maintenance Release, October 2006).

In addition to standard RMI and RMI/IIOP connectors, JSR 160 also defines optional JMX Messaging Protocol (JMXMP) connectors based on TCP sockets. The Java SE platform does not include these optional connectors. However, you might want to use JMXMP connectors if, for example, you require a more advanced level of security.

If you want to use a JMXMP connector, download the JSR 160 Reference Implementation from the download page specified at the beginning of this section, and add the jmxremote_optional.jar file to your classpath. You will find examples of use of JMXMP connectors in the JMX Remote API Tutorial included with the JSR 160 Reference Implementation.

Contents | Previous | Next

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Applet Deployment Parameters

See Applet Deployment Parameters in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Applet Developer's Guide

See Applet Development Guide in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Plug-in and Applet Architecture

See Java Plug-In and Applet Architecture in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Migrating Java Applets to Java Web Start Applications

See Migrating Java Applets to the Java Network Launching Protocol in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Applet Status And Event Handlers

See Applet Status And Event Handlers in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


appletviewer

Runs applets outside of a web browser.

Synopsis

appletviewer [options] url...

options

The command-line options separated by spaces. See Options.

url

The location of the documents or resources to be displayed. You can specify multiple URLs separated by spaces.

Description

The appletviewer command connects to the documents or resources designated by urls and displays each applet referenced by the documents in its own window. If the documents referred to by urls do not reference any applets with the OBJECT, EMBED, or APPLET tag, then the appletviewer command does nothing. For details about the HTML tags that the appletviewer command supports, see AppletViewer Tags at
http://docs.oracle.com/javase/8/docs/technotes/tools/appletviewertags.html

The appletviewer command requires encoded URLs according to the escaping mechanism defined in RFC2396. Only encoded URLs are supported. However, file names must be unencoded, as specified in RFC2396.

Note: The appletviewer command is intended for development purposes only. For more information, see About Sample/Test Applications and Code at
http://docs.oracle.com/javase/8/docs/technotes/samples/aboutCodeSamples.html

Options

-debug

Starts the Applet Viewer in the Java debugger with the jdb command to debug the applets in the document.

-encoding encoding-name

Specifies the input HTML file encoding name.

-Jjavaoption

Passes the string javaoption as a single argument to the Java interpreter, which runs the Applet Viewer. The argument should not contain spaces. Multiple argument words must all begin with the prefix -J. This is useful for adjusting the compiler's execution environment or memory usage.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java VisualVM

Documentation Contents

Java VisualVM - Working with Local Applications

When you start Java VisualVM, a node for each local Java application is displayed under the Local node in the Applications window. You can expand an application node to see the profiler snapshots, thread dumps and heap dumps of the application. Right-clicking an application node or sub-node invokes a popup menu enabling you to choose various actions.
Note: The list of local applications always includes Java VisualVM.

screenshot of VisualVM Applications window showing popup menu options

A local application node generally has the following items available in the popup menu.

  • Open. Opens the tab for the application in the main window where you can view application data.
  • Thread Dump. Takes a thread dump for the application.
  • Heap Dump. Takes a heap dump for the application.
  • Profile. Opens the Profiler sub-tab for the application where you can choose to profile the application. (Note that even though Java VisualVM appears in the application tree, Java VisualVM cannot profile itself).
  • Profiler Snapshot. Creates a snapshot of the results from the profiling session. The snapshot opens in the main window and a node for the snapshot appears under the application node. This command is only available when Java VisualVM is profiling the application.
  • Application Snapshot. Creates an application snapshot containing all application dumps and snapshots. A node for the application snapshot appears under the Snapshots node.
  • Enable Heap Dump on OOME. Select this if you want Java VisualVM to automatically take a heap dump when the application encounters an OutOfMemoryException.

You can perform the following tasks directly from the popup menu.

View Application Data

Java VisualVM displays data about each running local application in a dedicated tab in the main window. Each application tab has sub-tabs where information about that application is displayed.

To open the application tab, right-click the application node in the Applications window and choose Open. (Alternatively, double-click the application node.) When you click Open, the Overview tab of the application tab opens in the main window.

The application tab for a local application has the following sub-tabs:

  • Overview. For more, see Viewing Application Overview
  • Monitor. For more, see Monitoring an Application
  • Threads. For more, see Monitoring Application Threads
  • Profiler. For more, see Profiling Applications

Additional tabs and sub-tabs may be visible depending on the installed plugins.

Take a Thread Dump

You can use Java VisualVM to take a thread dump to capture information about the active application threads at the time you take the thread dump. When you take a thread dump, the thread dump opens in a sub-tab of the application in the main window. A node for the thread dump appears under the application node in the Applications window.

You can take a thread dump in the following ways:

  • Right-click the application node in the Applications window and choose Thread Dump.
  • Click the Thread Dump button in the Threads tab of the application tab.

When you take a thread dump, the thread dump opens in a sub-tab of the application in the main window. A node for the thread dump appears under the application node.

For more about working with application threads, see the following document:

  • Monitoring Application Threads

Take a Heap Dump

You can take a heap dump of a local application to capture a snapshot of the objects on the heap.

You can take a heap dump in the following ways:

  • Right-click the application node in the Applications window and choose Heap Dump.
  • Click the Heap Dump button in the Monitor tab of the application tab.

When you take a heap dump, the heap dump opens in a sub-tab of the application in the main window. A node for the heap dump appears under the application node.

For more about working with the heap, see the following document:

  • Browsing a Heap Dump

Profile an Application

Java VisualVM includes a profiler that enables you to analyze the performance and memory usage of a local application. You can profile an application without restarting it. To start a profiling session, right-click the application node and choosing Profile from the popup menu to open the profiling tab.
Note: Java VisualVM cannot be used to Profile itself.

For more see the following document:

  • Profiling Applications

Take Snapshots

Java VisualVM enables you to take snapshots that capture application data at the time the snapshot is taken. You can save snapshots to your local system and then examine them later or send them to others.

Java VisualVM enables you to take the following types of snapshots:

  • Profiler snapshots. A profiler snapshot captures the profiling data at the moment the snapshot is takes. The snapshot is either a memory snapshot or a CPU snapshot. You can take a profiler snapshot only when you are profiling an application.
  • Application snapshots. An application snapshot is an archive that contains all the heap dumps, thread dumps and snapshots that are listed below the application node.

For more see the following document:

  • Working with Snapshots
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java VisualVM

Documentation Contents

Java VisualVM - Working with Remote Applications

Java VisualVM is able to access and display data about applications running on remote hosts. After connecting to a remote host, Java VisualVM can display general data about the application's runtime environment and can monitor memory heap and thread activity.

Note. Java VisualVM can retrieve monitoring information on remote applications but it cannot profile remote applications.

Connecting to a Remote Host

Connected remote hosts are displayed as nodes under the Remote node in the Applications window. When you are connected to a remote host, Java VisualVM displays applications running on the host as sub-nodes, and automatically updates the status of the remote applications, removing the applications when they stop and adding applications when they start.

To add a remote host, right-click the Remote node in the Applications window, choose Add Remote Host and type the host name or IP address in the Add Remote Host dialog box. (You can also specify a display name that will be used to refer to the host when listed under the Remote node.)

Add Remote Host dialog box

Note: To retrieve and display information on applications running on the remote host, the jstatd utility needs to be running on the remote host. To start the jstatd utility, type jstatd on the command line. The jstatd utility is included as part of Java Development Kit (JDK) version 6. For more on jstatd, see the man page for Solaris, Linux, or Mac OS X or Windows.

When Java VisualVM is connected to a remote host, a node for the remote host appears under the Remote node in the Applications window. You can expand the remote host node to view the applications running on the remote host.

Remote node in Applications window

Viewing Application Data

Java VisualVM displays data about each running remote application in a dedicated tab in the main window. To open the application tab, right-click the application node in the Applications window and choose Open. (Alternatively, you can double-click the application node.) When you click Open, the Overview tab of the application tab opens in the main window.

Overview tab of remote application

You can use the sub-tabs in the application tab to view details about the application.
For more see the following documents:

  • Viewing Application Overview
  • Monitoring an Application
  • Monitoring Application Threads
  • Connecting to JMX Agents Explicitly
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java VisualVM

Using the Applications Window

When you start Java VisualVM, the Applications window is visible in the left side of the Java VisualVM window. The Applications window uses a tree structure to enable you to quickly view the applications that are running on local and connected remote JVM software instances. The Applications window also displays core dumps and application snapshots.

Applications Window Nodes

The Application window has nodes and sub-nodes that you can expand to view running applications and saved files. For most nodes in the Applications window, you can view additional information and perform actions by right-clicking a node and choosing an item from the popup menu. The actions available in the popup menu vary according to the node.

screenshot of VisualVM window

The Applications window has the following primary nodes:

Local Node

The Local node displays the name and process IDs (PID) of Java applications that are running on the same system as Java VisualVM. When you launch Java VisualVM and expand the Local node, Java VisualVM automatically displays the currently running Java applications. Java VisualVM is always listed as one of the local applications. When a new local Java application is launched, a node for that application appears under the Local node. The application node disappears when the application terminates.

If you use Java VisualVM to take thread dumps, heap dumps or profiling snapshots of an application, they are displayed as sub-nodes below the node for that application. You can right-click a dump or snapshot sub-node to save it to your local system. You can collect and archive all the information collected about an application and save it as an application snapshot.

For more information about how to view data about local applications, see the following pages:

  • Working with Local Applications
  • Working with Snapshots
  • Using the Java VisualVM Profiler

Remote Node

When Java VisualVM connects to a remote host, the remote host is listed as a node under the Remote node. When connected to a remote host, you can expand the node for the remote host to see the Java applications that are running on that host. When a Java application is launched on the remote host, a node for that application is displayed under the remote host node.

You need to explicitly add the location of remote hosts if you want Java VisualVM to be able to connect to the host. Once a remote host is added, Java VisualVM persists the address of the remote host and will make a connection to the host each time Java VisualVM is started. If you do not want Java VisualVM to connect to the host on startup, you should right-click the remote host node and choose Remove before quitting Java VisualVM.

Note: To retrieve and display information on applications running on the remote host, the jstatd utility needs to be running on the remote host. To start the utility, type jstatd on the command line. The jstatd utility is included as part of the Java Development Kit (JDK) version 6.

For more information about how to view data about remote applications, see the following pages:

  • Working with Remote Applications.
  • The jstatd man page for Solaris, Linux, or Mac OS X or Windows.

VM Coredumps

The VM Coredumps node lists open core dump binary files when you open the files in Java VisualVM. A core dump is a binary file that contains information about the runtime status of the machine at the time the core dump was taken. If you have a core dump you can then extract an overview of the system properties, a heap dump and a thread dump.

Note: The Core Dump node is only visible if Java VisualVM is running on Solaris or Linux.

For more information, see the following document:

  • Working with Core Dumps

Snapshots

The Snapshots node lists any application snapshots that are saved in the Java VisualVM userdir until they are explicitly deleted. An application snapshot captures the collected heap dumps, thread dumps and profiler snapshots of an application at the moment the snapshot is taken. You can expand the application snapshot node to see the data collected in the snapshot.

You can right-click an application snapshot node or any of the items listed under the node to open a popup menu enabling you to open, save, delete and rename the selected item.

For more information about taking and saving snapshots, see the following document:

  • Working with Snapshots
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

CHAPTER 3

Writing Image I/O Applications

3.1 Reading and Writing Images

The javax.imageio.ImageIO class provides a set of static convenience methods that perform most simple Image I/O operations.

Reading an image that is in a standard format (GIF, PNG, or JPEG) is simple:

File f = new File("c:\images\myimage.gif");
BufferedImage bi = ImageIO.read(f);

The format of the image will be auto-detected by the API based on the contents of the file. Most image files contain a "magic number" in their first few bytes that identifies the file format. For formats that do not have a magic number, auto-detection may fail and somewhat more sophisticated application code will be needed.

Additional formats may be handled by installing JAR files containing plug-ins; the details are described in the next chapter. Once a plug-in has been installed, a new format will be understood automatically without any changes to the application code.

The set of formats available for reading can be obtained by calling ImageIO.getReaderFormatNames. This will return an array of Strings containing the names of the available formats, such as "gif" and "png."

Writing an image in a supported format is equally simple:

BufferedImage bi;
File f = new File("c:\images\myimage.png");
ImageIO.write(im, "png", f);

The list of supported formats may be obtained by calling ImageIO.getWriterFormatNames.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.2 Going Further

The methods described above are sufficient for simple applications. However, the Image I/O API offers much more power for writing sophisticated applications. In order to make use of the advanced features of the API, applications will work directly with the ImageReader and ImageWriter classes that are part of the API.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.3 ImageReader

Rather than using the ImageIO class to perform the entire decoding operation, an application may use the ImageIO class to obtain an ImageReader object that may be used to perform the read:

Iterator readers = ImageIO.getImageReadersByFormatName("gif");
ImageReader reader = (ImageReader)readers.next();

Readers may also be retrieved based on file contents, file suffix, or MIME type. The mechanism for locating and instantiating the reader makes use of the javax.imageio.spi.ImageReaderSpi class, which allows information about a reader plug-in to be retrieved without actually instantiating the plug-in. The notion of "service provider interfaces" (SPIs) is described in detail in the following chapter.

Once a reader has been obtained, it must be supplied with an input source. Most readers are able to read from an ImageInputStream, which is a special input source that is defined by the Image I/O API. A special input source is used in order to make it simple for reader and writers to work with both file and streaming I/O.

Obtaining an ImageInputStream is straightforward. Given an input source in the form of a File or InputStream, an ImageInputStream is produced by the call:

Object source; // File or InputStream
ImageInputStream iis = ImageIO.createImageInputStream(source);

Once a source has been obtained, it may be attached to the reader by calling:

reader.setInput(iis, true);

The second parameter should be set to false if the source file contains multiple images and the application is not guaranteed to read them in order. For file formats that allow only a single image to be stored in a file, it is always legal to pass in a value of true.

Once the reader has its input source set, we can use it to obtain information about the image without necessarily causing image data to be read into memory. For example, calling reader.getImageWidth(0) allows us to obtain the width of the first image stored in the file. A well-written plug-in will attempt to decode only as much of the file as is necessary to determine the image width, without reading any pixels.

To read the image, the application may call reader.read(imageIndex), where imageIndex is the index of the image within the file. This produces the same result as if it had called ImageIO.read, as shown above.

3.3.1 ImageReadParam

More control may be obtained by supplying the read method with an additional parameter of type ImageReadParam. An ImageReadParam allows the application to specify a destination image in which the decoded image data should be stored, allowing better control over memory use. It also allows a region of interest to be specified, as well as subsampling factors that may be used to obtain a scaled-down version of the image.

When a source region is set, the reader plug-in will attempt to decode only the desired region, to the extent that the file format allows partial decoding. In any case, no pixels outside the region will appear in the output. This capability makes it possible to work with extremely large images in a limited amount of memory.

For example, to decode only the upper-left quadrant of the image, the application first obtains an ImageReadParam that is suitable for use with the reader:

ImageReadParam param = reader.getDefaultReadParam();
Next, the source region of interest is set on the ImageReadParam:
import java.awt.Rectangle;
int imageIndex = 0;
int half_width = reader.getImageWidth(imageIndex)/2;
int half_height = reader.getImageHeight(imageIndex)/2;
Rectangle rect = new Rectangle(0, 0, half_width, half_height);
param.setSourceRegion(rect);

Finally, the image is read using the ImageReadParam:

BufferedImage bi = reader.read(imageIndex, param);

The result is a new BufferedImage whose width and height are equal to half those of the original image (rounding down if the image had an odd width or height).

The lower-right quadrant of the image may then be read into the same BufferedImage that was created to hold the upper-left quadrant, overwriting the previous pixel data:

param.setDestination(bi);
rect = new Rectangle(half_width, half_height, half_width, half_height);
param.setSourceRegion(rect);
BufferedImage bi2 = reader.read(0, param);
if (bi == bi2) {
        System.out.println("The same BufferedImage was used!");
} else {
        System.out.println("This can't happen!");
}

In practice, the application could simply call reader.read(0, param) without assigning the result anywhere, knowing that the pixels will be written into the existing BufferedImage bi.

As another example, to read every third pixel of the image, resulting in an image one-ninth the size of the original, subsampling factors may be set in the ImageReadParam:

param = reader.getDefaultImageParam();
param.setSourceSubsampling(3, 3, 0, 0);
BufferedImage bi3 = reader.read(0, param);

3.3.2 IIOParamController

A plug-in may optionally supply an IIOParamController object that may be used to set up an IIOReadParam (or IIOWriteParam) using a graphical user interface (GUI), or any other interface. A reader plug-in may attach an IIOParamController to any ImageReadParam objects that it creates:

ImageReadParam param = reader.getDefaultImageParam();
IIOParamController controller = param.getController();
if (controller != null) {
        controller.activate(param);
}

When the controller's activate method is called, it displays the GUI and handles user events such as slider movements and button presses. Typically the interface will contain an "OK" or "Apply" button, which when pressed will cause the activate method to return. The controller is responsible for calling methods on its associated ImageReadParam to update its state, either in response to each GUI event, or all at once prior to returning from activate.

3.3.3 Reading From Multi-Image Files

All the methods in the ImageReader class that deal with images take an imageIndex parameter. This parameter allows access to any of the images in a multi-image file.

The ImageReader.getNumImages method returns the number of images that are stored in the input file. This method takes a boolean parameter, allowSearch. Some image formats, notably GIF, do not provide any way to determine the number of images without reading the entire file. Since this may be costly, setting allowSearch to false will allow the reader to return a value of -1 instead of the actual number of images. If the parameter is true, the reader will always return the actual number of images.

Even if the number of images is not known by the application, it is still possible to call read(imageIndex); if the index is too large, the method will throw an IndexOutOfBoundsException. Thus, the application can request images with increasing indices until it receives an exception.

3.3.4 Reading "Thumbnail" Images

Some image formats allow a small preview image (or multiple previews) to be stored alongside the main image. These "thumbnail" images are useful for identifying image files quickly, without the need to decode the entire image.

Applications can determine how many thumbnail images associated with a particular image are available by calling:

reader.getNumThumbnails(imageIndex);

If a thumbnail image is present, it can be retrieved by calling:

int thumbailIndex = 0;
BufferedImage bi;
bi = reader.readThumbnail(imageIndex, thumbnailIndex);

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.4 The ImageWriter Class

Just as we obtained a list of ImageReaders for a particular format using a method from the ImageIO class, we can obtain a list of ImageWriters:

Iterator writers = ImageIO.getImageWritersByFormatName("png");
ImageWriter writer = (ImageWriter)writers.next();

Once an ImageWriter has been obtained, its destination must be set to an ImageOutputStream:

File f = new File("c:\images\myimage.png");
ImageOutputStream ios = ImageIO.createImageOutputStream(f);
writer.setOutput(ios);

Finally, the image may be written to the output stream:

BufferedImage bi;
writer.write(bi);

3.4.1 Writing Multiple Images

The IIOImage class is use to store references to an image, one or more thumbnail images, and metadata (non-image data) associated with the image. Metadata will be discussed below; for now, we will simply pass null as the value for the metadata-related parameters.

The ImageWriter class contains a write method that creates a new file from an IIOImage, and a writeInsert method that adds an IIOImage to an existing file . By calling the two in sequence a multi-image file may be written:

BufferedImage first_bi, second_bi;
IIOImage first_IIOImage = new IIOImage(first_bi, null, null);
IIOImage second_IIOImage = new IIOImage(second_bi, null, null);
writer.write(null, first_IIOImage, null);
if (writer.canInsertImage(1)) {
        writer.writeInsert(1, second_IIOImage, null);
} else {
        System.err.println("Writer can't append a second image!");
}

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.5 Handling Metadata

Data stored in an image file that does not represent actual pixel values is referred to as metadata. The javax.imageio.metadata package contains classes and interfaces for accessing metadata.

Metadata may contain complex, hierarchical structures. The Java XML Document Object Model (DOM) API is used to represent these structures, allowing developers to leverage their knowledge of these interfaces.

The Image I/O API differentiates between stream metadata, which is associated with all images stored in an image file, and image metadata which is associated with a single image. For image formats that contain a single image, only image metadata is used.

Metadata may be obtained by calling the ImageReader.getStreamMetadata and getImageMetadata(int imageIndex) methods. These return an object that implements the IIOMetadata interface. The actual class type of the returned object is up to the ImageReader, and will usually be a unique class used only by that reader. This object should be designed to store as much of the metadata allowed by the format as possible, as losslessly as possible. However, this fidelity to the specifications of the image format comes at a cost, as access to the metadata becomes format-specific.

In order to allow access to the metadata without the need for format-specific application code, IIOMetadata objects expose their internal information in the form of an XML DOM structure, which is essentially a tree of nodes of various types that may contain a set of attributes (String values accessed by name), and which may reference a set of child nodes.

A single plug-in may support multiple document formats, which are distinguished by a format name. Typically, at least two formats will be supported by a given plug-in. The first is a common, plug-in neutral format called com.sun.imageio_1.0, which is defined in the class comment for the IIOMetadata interface. The second will be a highly plug-in specific format that exposes all of the internal structure of the IIOMetadata object in the form of a DOM. The latter format is referred to as the native format of the plug-in; its name may be determined by calling the getNativeMetadataFormatName method of the IIOMetadata object returned by the reader (advanced users may call a method of the same name on the ImageReaderSpi object used to instantiate the reader. The latter approach is useful for selecting a plug-in based on its support for a particular format). The names of all of the supported document formats may be determined similarly by calling getMetadataFormatNames.

The contents of an IIOMetadata object may be accessed in the form of a tree of XML Node objects by calling its getAsTree method. This method takes a String argument which is the name of one of the document formats supported by the plug-in. This document may then be manipulated as a standard XML DOM tree.

As an example, to print the contents of an XML DOM tree, the following code may be used:

public void displayMetadata(Node root) {
        displayMetadata(root, 0);
}

void indent(int level) {
        for (int i = 0; i < level; i++) {
                System.out.print("  ");
        }
}

void displayMetadata(Node node, int level) {
        indent(level); // emit open tag
        System.out.print("<" + node.getNodeName());
        NamedNodeMap map = node.getAttributes();
        if (map != null) { // print attribute values
                int length = map.getLength();
                for (int i = 0; i < length; i++) {
                        Node attr = map.item(i);
                        System.out.print(" " + attr.getNodeName() +
                                         "=\"" + attr.getNodeValue() + "\"");
                }
        }

        Node child = node.getFirstChild();
        if (child != null) {
                System.out.println(">"); // close current tag
                while (child != null) { // emit child tags recursively
                        displayMetadata(child, level + 1);
                        child = child.getNextSibling();
                }
                indent(level); // emit close tag
                System.out.println("</" + node.getNodeName() + ">");
        } else {
                System.out.println("/>");
        }
}
Executing displayMetadata on the metadata from a PNG test image yields the output:
<com.sun.imageio.png_1.0>
  <IHDR width="32" height="32" bitDepth="8" colorType="RGB"
compressionMethod="deflate" filterMethod="adaptive" interlaceMethod="none"/>
  <cHRM whitePointX="31270" whitePointY="32900" redX="64000" redY="33000"
greenX="30000" greenY="60000" blueX="15000" blueY="6000"/>
  <gAMA value="100000"/>
</com.sun.imageio.png_1.0>
We see that the image contains IHDR, cHRM, and gAMA chunks. The interpretation of the attribute values requires an understanding of the PNG format; however, it is still possible for an application that does not understand PNG internals to display the values and allow them to be edited interactively.

3.5.1 The IIOMetadataFormat Interface

An IIOMetadataFormat object is used to describe the legal structure of a metadata document format. It constrains the types of nodes that may appear, the types of nodes that may be children of a node of a given type, the names and data types of the attributes that may appear at a node of a given type, and the audiotape of an Object value that may be stored at a node of a given type. In XML terms, the information provided by the IIOMetadataFormat interface is somewhere in between a DTD (Document Type Definition), which gives information about node types, children, and attributes, and an XML Schema, which provides detailed information about data types.

For simplicity, only a subset of legal DTD structures can be described by IIOMetadataFormat. For example, the children of a node may be defined in an IIOMetadataFormat as a sequence in which each child must appear once (a, b, c), a sequence in which each child is optional (a?, b?, c?), a choice of a single child (a | b | c), or a repetition of a single node type (a)*, whereas a DTD allows many more combinations.

A node may not contain any textual data, but may contain a reference to an arbitrary Object. The IIOMetadataFormat indicates the class type and optionally the legal enumerated values or a range of values for the Object. Arrays are supported as well.

A DTD does not allow any attribute data types other than character strings; an XML Schema allows extremely complex data types to be built up from simpler ones. IIOMetadataFormat occupies a middle ground; it allows attributes to be constrained to belong to one of a predefined set of simple data types, including integers, floating-point decimals, and dates. Lists of these data types are also allowed.

Since an IIOMetadataFormat might be used to automatically construct a user interface for displaying and editing metadata, restricted the set of legal structures greatly simplifies the mapping between formats and user interface designs.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.6 Transcoding

Transcoding refers to reading an image file with a reader plug-in, and writing out the image using a writer plug-in, especially, if the writer plug-in cannot directly understand the native metadata format of the reader. In such a case, there will always be some loss of information, even if both plug-ins deal with the same file format. A transcoder plug-in is responsible for converting the stream and image metadata that have been created by a reader plug-in into a better form for use by a writer plug-in. The API does not mandate the presence of any transcoder plug-ins, but they may be installed and registered just like readers and writers.

A set of reader and writer plug-ins may be designed to interpret each other's metadata without the need for a separate transcoder. The relationships between plug-ins can be determined using the ImageReaderSpi.getImageWriterSpiNames and ImageWriterSpi.getImageReaderSpiNames methods, which indicate which plug-ins are known to work well with a given plug-in of the opposite type. If multiple plug-ins are being written by a single vendor, this mechanism will provide the best quality.

However, when working with plug-ins that have not been designed to interoperate, a transcoder plug-in may be provided by a developer who understands the metadata formats of a given pair of reader and writer plug-ins, even though each was written without knowledge of the other.

Given a particular pair of reader and writer plug-ins, the set of appropriate transcoder plug-ins may be located as follows:

ImageReader reader;
ImageWriter writer;

Iterator transcoders = ImageIO.getImageTranscoders(reader, writer);

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.7 Listening for Events

As an image is being read or written, the plug-in may provide updates to the
application. The application may provide one or more classes that implement
interfaces from the javax.image.event package. Instances of these classes are then
added to the ImageReader or ImageWriter being used. For example,

class MyReadProgressListener implements IIOReadProgressListener {

        public MyReadProgressListener() {}

        public void imageStarted(ImageReader source) {
                System.out.println("Started reading!");
        }

        // Other methods from IIOReadProgressListener omitted
}

IIOReadProgressListener listener = new MyReadProgressListener();
reader.addIIOReadProgressListener(listener);
As the ImageReader.read method progresses, methods on listener will be called at various times to indicate how much of the image has been read. Because these methods are being called while ImageReader.read is active, they must not call most methods from the same ImageReader object. They may call ImageReader.abort(), which will cause ImageReader.read to return even if it is only partially complete.

3.7.1 The IIOReadProgressListener Interface

An IIOReadProgressListener may be used to provide simple status information during reading. An estimate of the percentage of completion of a read is provided, which may be used to update a Swing JProgressBar or other progress indicator, or to estimate the time remaining to read a large image.

The imageStarted method will be called at the start of the read. During the read, the imageProgress method will be called multiple times, each time with a different, increasing value for its percentageDone parameter. When the read is about to complete, the imageComplete method will be called.

Similarly, the thumbnailStarted, thumbnailProgress, and thumbnailComplete methods will be called during thumbnail reads.

Other methods exist to indicate the start and end of a sequence of image reads performed by the ImageReader.readAll method. Additionally, it is possible for an ongoing read to be aborted using the ImageReader.abort method; in this case, the listener's readAborted method will be called.

3.7.2 The IIOReadUpdateListener Interface

An IIOReadUpdateListener provides more detailed information on the progress of an image read. Some image formats allow interlaced or progressive encoding, in which a subset of the pixel data is made available quickly, so that a crude version of the image may be displayed while the remainder of the pixel data is still being received and decoded. A typical scheme might begin by sending only every fourth row, and only every fourth pixel in each of those rows, so that the initial image requires only one sixteenth of the total amount of data to be transmitted and decoded. If interlacing were not used, only the top one-sixteenth of the image would be displayed in the same amount of time. Thus, a person viewing an interlaced image will be able to get a sense of its contents much sooner than if a traditional left-to-right, top-to-bottom order were used.

By implementing the methods of the IIOReadUpdateListener interface, an application class can receive notification when groups of possibly non-contiguous pixels are ready to be displayed. These methods also receive a reference to the BufferedImage that is in the process of being filled in, which may be used to refresh the display to include the newly decoded pixels.

When decoding an interlaced or progressive image, the decoding proceeds in multiple passes. At the start of each pass, the listener's passStarted method will be called to indicate the set of pixels that may be overwritten during the following pass. This estimate is conservative; not every pixel in the region will necessarily be updated during the pass. As the pass progresses, the imageUpdate method will be called with arguments describing the region of pixels that have receive new values. This region is described by the coordinates of its upper-left corner, its width and height, and the spacing between the pixels that make up the pass (in the example above, both parameters would be equal to 4 for the initial pass). When a pass has completed, the passComplete method is called. Similar methods allow the progress of thumbnail image reads to be tracked.

3.7.3 The IIOReadWarningListener Interface

By attaching an IIOReadWarningListener to an ImageReader, information on non-fatal errors may be received. For example, a reader might detect a tag or chunk that should not be present. Even though the reader may choose to ignore the error and proceed with decoding, it may wish to inform the application that the input source was malformed, as this could indicate problems in the application that generated the images.

ImageReaders may specify a set of Locales for which they can provide localized warning messages. The set of available locales can be obtained from the reader's getAvailableLocales method. The desired locale should then be set by calling the reader's setLocale method prior to attaching the IIOReadWarningListener. Each listener will receive messages in the Locale that was in effect at the time it was attached to the reader.

3.7.4 The IIOWriteProgressListener and IIOWriteWarningListener Interfaces

The IIOWriteProgressListener and IIOWriteWarningListener interfaces function similarly to their reader counterparts.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 3 - Writing Image I/O Applications

Documentation Contents
CONTENTS | PREV | NEXT

3.8 Handling Errors using IIOException

In the examples above, the possibility of fatal errors was not considered. Errors may result from a number of sources, including true I/O errors (e.g., file not found, file unreadable, file on corrupt media), security violations (e.g., no permission to read files from an applet), file format problems (file contents corrupted, file using a variant of the format that is not supported by the plug-in), or even bugs in the API implementation or in the plug-in.

The Image I/O API makes use of its own subclass of the standard IOException class, called IIOException. IIOExceptions are used to signal all errors encountered during the parsing of a source file (e.g., an incorrect checksum or an invalid value for a particular byte within the file), including true I/O errors that result in an IOException being thrown within the reader.

An IIOException contains a (non-localized) message describing the reason for the exception, as well as a reference to another Exception that was the cause of the IIOException, if one exists.

Thus, application code that attempts to provide graceful handling of errors will look something like:

File f = new File("c:\images\myimage.gif");
ImageInputStream iis = null;
try {
        iis = ImageIO.createImageInputStream(f);
} catch (IIOException iioe1) {
        System.out.println("Unable to create an input stream!");
        return;
}

reader.setInput(stream);
try {
        reader.read(0, param);
} catch (IIOException iioe2) {
        System.out.println("An error occurred during reading: " +
                                 iioe2.getMessage());
        Throwable t = iioe2.getCause();
        if ((t != null) && (t instanceof IOException)) {
                System.out.println("Caused by IOException: " +
                                   t.getMessage());
        }
}

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of Figure Example of How Application Retrieves "AES" Cipher Instance / Architecture of Service Provider Interface

Link to figure Example of How Application Retrieves "AES" Cipher Instance in Java Cryptography Architecture (JCA) Reference Guide

Link to figure Architecture of Service Provider Interface in How to Implement a Provider in the Java Cryptography Architecture

This figure consists of five boxes:

  • Application: This box contains the following pseudocode:

    c:Cipher.getInstance("AES");

  • JCA/JCE: This box contains the following list:

    • Signature
    • Message Digest
    • Key Script Generator
    • Key Factory
    • Algorithm Parameters
    • Cipher
    • Key Agreement
    • Key Generator
    • Secret Key Factory
    • MAC

  • CSP, CSP2, CSP3: These boxes represent cryptographic service providers

  • The fifth box represents CSP3. It contains the following headers and pseudocode:

    • Provider.class

      "Cipher.AES" -> "com.foo.AESCipher"

    • com.foo.AESCipher.class

      package com.foo:
  class AESCipher extends CipherSPi {
    .
    .
    .
  }

Arrows connect the boxes as follows:

  • From Application to JCA/JCE
  • From JCA/JCE to CSP1, CSP2, and CSP3 (the arrow branches)

A dotted line connects CSP3 to the headings Provider.class and com.foo.AESCipher.class

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Skip navigation bar
Contents | Previous | Next

Chapter 2

JMX Architecture

JMX technology provides a standard API for management and monitoring of resources. The API includes remote access, so a remote management application can manage and monitor applications, systems, and networks. This chapter outlines JMX architecture in the following sections:

  • "Architecture Outline"
  • "Instrumenting Resources Using MBeans"
  • "Creating a JMX Agent"
  • "Managing Resources Remotely"

Architecture Outline

JMX technology is defined by two closely related specifications developed through the Java Community Process (JCP) as Java Specification Request (JSR) 3 and JSR 160:

  • JSR 3, Java Management Extensions Instrumentation and Agent Specification
  • JSR 160, Java Management Extensions Remote API

The following table shows that the management architecture can be broken down into three levels. The first two levels shown in the table, instrumentation and agent,

Java VM are defined by JSR 3. The remote management level is defined by JSR 160.

TABLE 2-1 – JMX Technology Architecture
Level | Description
Instrumentation | Resources, such as applications, devices, or services, are instrumented using Java objects called Managed Beans (MBeans). MBeans expose their management interfaces, composed of attributes and operations, through a JMX agent for remote management and monitoring.
Agent | The main component of a JMX agent is the MBean server. This is a core managed object server in which MBeans are registered. A JMX agent also includes a set of services for handling MBeans. JMX agents directly control resources and make them available to remote management agents.
Remote Management | Protocol adaptors and standard connectors make a JMX agent accessible from remote management applications outside the agent’s Java Virtual Machine (Java VM).

Instrumenting Resources Using MBeans

To manage resources using JMX technology, you must first instrument the resources in the Java programming language. You use Java objects known as MBeans to implement the access to the instrumentation of resources. MBeans must follow the design patterns and interfaces defined in the specification. This ensures that all MBeans provide the instrumentation of managed resources in a standardized way.

Once a resource has been instrumented by MBeans, it can be managed through a JMX agent. MBeans do not require knowledge of the JMX agent with which they will operate.

MBeans are designed to be flexible, simple, and easy to implement. Developers of applications, systems, and networks can make their products manageable in a standard way without having to understand or invest in complex management systems. Existing resources can be made manageable with minimum effort.

In addition, the instrumentation level specifies a notification mechanism. This allows MBeans to generate and propagate notification events to components of the other levels.

Creating a JMX Agent

A JMX agent is a standard management agent that directly controls resources and makes them available to remote management applications. JMX agents are usually located on the same machine as the resources they control, but this is not a requirement.

The core component of a JMX agent is the MBean server, a managed object server in which MBeans are registered. A JMX agent also includes a set of services to manage MBeans, and at least one communications adaptor or connector to allow access by a management application.

When you implement a JMX agent, you do not need to know the semantics or functions of the resources that it will be used to manage. In fact, a JMX agent does not even need to know which resources it will serve, because any resource instrumented in compliance with the JMX specification can use any JMX agent that offers the services it requires. Similarly, the agent does not need to know the functions of the management applications that will access it.

Managing Resources Remotely

JMX API instrumentation can be accessed in many different ways, either through existing management protocols such as the Simple Network Management Protocol (SNMP), or through proprietary protocols. The MBean server relies on protocol adaptors and connectors to make a JMX agent accessible from management applications outside the agent’s Java Virtual Machine (Java VM).

Each adaptor provides a view through a specific protocol of all MBeans registered in the MBean server. For example, an HTML adaptor could display an MBean in a Web browser.

Connectors provide a manager-side interface that handles the communication between manager and JMX agent. Each connector provides the same remote management interface though a different protocol. When a remote management application uses this interface, it can connect to a JMX agent transparently through the network, regardless of the protocol.

JMX technology provides a standard solution for exporting JMX API instrumentation to remote applications, based on Remote Method Invocation (RMI). In addition, the JMX Remote API defines an optional protocol based directly on TCP sockets, called the JMX Messaging Protocol (JMXMP). An implementation of the JMX Remote API does not have to support this optional protocol. The Java SE platform does not include the optional protocol. See Appendix A, "JMX Technology Versions" for further information.

The JMX Remote API specification describes how you can advertise and find JMX agents using existing discovery and lookup infrastructures. Examples of how to do this are provided and are described in the Java Management Extensions (JMX) Technology Tutorial. The specification does not define its own discovery and lookup service. The use of existing discovery and lookup services is optional: alternatively you can encode the addresses of your JMX API agents in the form of URLs, and communicate these URLs to the manager.

Contents | Previous | Next

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.ArrayAccessTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ArrayAccessTree

  • Packages that use ArrayAccessTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ArrayAccessTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ArrayAccessTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitArrayAccess(ArrayAccessTree node, P p)

    • Uses of ArrayAccessTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ArrayAccessTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitArrayAccess(ArrayAccessTree node, P p)
      R | TreeScanner.visitArrayAccess(ArrayAccessTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.ArrayReference (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ArrayReference

  • Packages that use ArrayReference
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of ArrayReference in com.sun.jdi

      Methods in com.sun.jdi that return ArrayReference
      Modifier and Type Method and Description
      ArrayReference ArrayType.newInstance(int length)
      Creates a new instance of this array class in the target VM.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.ArrayType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ArrayType

No usage of com.sun.jdi.ArrayType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.ArrayTypeTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ArrayTypeTree

  • Packages that use ArrayTypeTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ArrayTypeTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ArrayTypeTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitArrayType(ArrayTypeTree node, P p)

    • Uses of ArrayTypeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ArrayTypeTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitArrayType(ArrayTypeTree node, P p)
      R | TreeScanner.visitArrayType(ArrayTypeTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Programming With Assertions

An assertion is a statement in the Java programming language that enables you to test your assumptions about your program. For example, if you write a method that calculates the speed of a particle, you might assert that the calculated speed is less than the speed of light.

Each assertion contains a boolean expression that you believe will be true when the assertion executes. If it is not true, the system will throw an error. By verifying that the boolean expression is indeed true, the assertion confirms your assumptions about the behavior of your program, increasing your confidence that the program is free of errors.

Experience has shown that writing assertions while programming is one of the quickest and most effective ways to detect and correct bugs. As an added benefit, assertions serve to document the inner workings of your program, enhancing maintainability.

This document shows you how to program with assertions. It covers the topics:

  • Introduction
  • Putting Assertions Into Your Code
  • Compiling Files That Use Assertions
  • Enabling and Disabling Assertions
  • Compatibility With Existing Programs
  • Design FAQ

Introduction

The assertion statement has two forms. The first, simpler form is:

assert Expression1 ;

where Expression1 is a boolean expression. When the system runs the assertion, it evaluates Expression1 and if it is false throws an AssertionError with no detail message.

The second form of the assertion statement is:

assert Expression1 : Expression2 ;

where:

  • Expression1 is a boolean expression.
  • Expression2 is an expression that has a value. (It cannot be an invocation of a method that is declared void.)

Use this version of the assert statement to provide a detail message for the AssertionError. The system passes the value of Expression2 to the appropriate AssertionError constructor, which uses the string representation of the value as the error's detail message.

The purpose of the detail message is to capture and communicate the details of the assertion failure. The message should allow you to diagnose and ultimately fix the error that led the assertion to fail. Note that the detail message is not a user-level error message, so it is generally unnecessary to make these messages understandable in isolation, or to internationalize them. The detail message is meant to be interpreted in the context of a full stack trace, in conjunction with the source code containing the failed assertion.

Like all uncaught exceptions, assertion failures are generally labeled in the stack trace with the file and line number from which they were thrown. The second form of the assertion statement should be used in preference to the first only when the program has some additional information that might help diagnose the failure. For example, if Expression1 involves the relationship between two variables x and y, the second form should be used. Under these circumstances, a reasonable candidate for Expression2 would be "x: " + x + ", y: " + y.

In some cases Expression1 may be expensive to evaluate. For example, suppose you write a method to find the minimum element in an unsorted list, and you add an assertion to verify that the selected element is indeed the minimum. The work done by the assert will be at least as expensive as the work done by the method itself. To ensure that assertions are not a performance liability in deployed applications, assertions can be enabled or disabled when the program is started, and are disabled by default. Disabling assertions eliminates their performance penalty entirely. Once disabled, they are essentially equivalent to empty statements in semantics and performance. See Enabling and Disabling Assertions for more information.

The addition of the assert keyword to the Java programming language has implications for existing code. See Compatibility With Existing Programs for more information.

Putting Assertions Into Your Code

There are many situations where it is good to use assertions, including:

  • Internal Invariants
  • Control-Flow Invariants
  • Preconditions, Postconditions, and Class Invariants

There are also situations where you should not use them:

  • Do not use assertions for argument checking in public methods.

    Argument checking is typically part of the published specifications (or contract) of a method, and these specifications must be obeyed whether assertions are enabled or disabled. Another problem with using assertions for argument checking is that erroneous arguments should result in an appropriate runtime exception (such as IllegalArgumentException, IndexOutOfBoundsException, or NullPointerException). An assertion failure will not throw an appropriate exception.

  • Do not use assertions to do any work that your application requires for correct operation.

    Because assertions may be disabled, programs must not assume that the boolean expression contained in an assertion will be evaluated. Violating this rule has dire consequences. For example, suppose you wanted to remove all of the null elements from a list names, and knew that the list contained one or more nulls. It would be wrong to do this:

    // Broken! - action is contained in assertion
assert names.remove(null);

    The program would work fine when asserts were enabled, but would fail when they were disabled, as it would no longer remove the null elements from the list. The correct idiom is to perform the action before the assertion and then assert that the action succeeded:

    // Fixed - action precedes assertion
boolean nullsRemoved = names.remove(null);
assert nullsRemoved;  // Runs whether or not asserts are enabled

    As a rule, the expressions contained in assertions should be free of side effects: evaluating the expression should not affect any state that is visible after the evaluation is complete. One exception to this rule is that assertions can modify state that is used only from within other assertions. An idiom that makes use of this exception is presented later in this document.

Internal Invariants

Before assertions were available, many programmers used comments to indicate their assumptions concerning a program's behavior. For example, you might have written something like this to explain your assumption about an else clause in a multiway if-statement:

if (i % 3 == 0) {
    ...
} else if (i % 3 == 1) {
    ...
} else { // We know (i % 3 == 2)
    ...
}

You should now use an assertion whenever you would have written a comment that asserts an invariant. For example, you should rewrite the previous if-statement like this:

if (i % 3 == 0) {
   ...
} else if (i % 3 == 1) {
    ...
} else {
    assert i % 3 == 2 : i;
    ...
}

Note, incidentally, that the assertion in the above example may fail if i is negative, as the % operator is not a true modulus operator, but computes the remainder, which may be negative.

Another good candidate for an assertion is a switch statement with no default case. The absence of a default case typically indicates that a programmer believes that one of the cases will always be executed. The assumption that a particular variable will have one of a small number of values is an invariant that should be checked with an assertion. For example, suppose the following switch statement appears in a program that handles playing cards:

switch(suit) {
  case Suit.CLUBS:
    ...
  break;

  case Suit.DIAMONDS:
    ...
  break;

  case Suit.HEARTS:
    ...
    break;

  case Suit.SPADES:
      ...
}

It probably indicates an assumption that the suit variable will have one of only four values. To test this assumption, you should add the following default case:

default:
    assert false : suit;

If the suit variable takes on another value and assertions are enabled, the assert will fail and an AssertionError will be thrown.

An acceptable alternative is:

default:
    throw new AssertionError(suit);

This alternative offers protection even if assertions are disabled, but the extra protection adds no cost: the throw statement won't execute unless the program has failed. Moreover, the alternative is legal under some circumstances where the assert statement is not. If the enclosing method returns a value, each case in the switch statement contains a return statement, and no return statement follows the switch statement, then it would cause a syntax error to add a default case with an assertion. (The method would return without a value if no case matched and assertions were disabled.)

Control-Flow Invariants

The previous example not only tests an invariant, it also checks an assumption about the application's flow of control. The author of the original switch statement probably assumed not only that the suit variable would always have one of four values, but also that one of the four cases would always be executed. It points out another general area where you should use assertions: place an assertion at any location you assume will not be reached. The assertions statement to use is:

assert false;

For example, suppose you have a method that looks like this:

void foo() {
    for (...) {
      if (...)
        return;
    }
    // Execution should never reach this point!!!
}

Replace the final comment so that the code now reads:

void foo() {
    for (...) {
      if (...)
        return;
    }
    assert false; // Execution should never reach this point!
}

Note: Use this technique with discretion. If a statement is unreachable as defined in the Java Language Specification, you will get a compile time error if you try to assert that it is not reached. Again, an acceptable alternative is simply to throw an AssertionError.

Preconditions, Postconditions, and Class Invariants

While the assert construct is not a full-blown design-by-contract facility, it can help support an informal design-by-contract style of programming. This section shows you how to use asserts for:

  • Preconditions — what must be true when a method is invoked.
    • Lock-Status Preconditions — preconditions concerning whether or not a given lock is held.
  • Postconditions — what must be true after a method completes successfully.
  • Class invariants — what must be true about each instance of a class.

Preconditions

By convention, preconditions on public methods are enforced by explicit checks that throw particular, specified exceptions. For example:

/**
  * Sets the refresh rate.
  *
  * @param  rate refresh rate, in frames per second.
  * @throws IllegalArgumentException if rate <= 0 or
  * rate > MAX_REFRESH_RATE.
*/
public void setRefreshRate(int rate) {
  // Enforce specified precondition in public method
  if (rate <= 0 || rate > MAX_REFRESH_RATE)
    throw new IllegalArgumentException("Illegal rate: " + rate);
    setRefreshInterval(1000/rate);
  }

This convention is unaffected by the addition of the assert construct. Do not use assertions to check the parameters of a public method. An assert is inappropriate because the method guarantees that it will always enforce the argument checks. It must check its arguments whether or not assertions are enabled. Further, the assert construct does not throw an exception of the specified type. It can throw only an AssertionError.

You can, however, use an assertion to test a nonpublic method's precondition that you believe will be true no matter what a client does with the class. For example, an assertion is appropriate in the following "helper method" that is invoked by the previous method:

/**
 * Sets the refresh interval (which must correspond to a legal frame rate).
 *
 * @param  interval refresh interval in milliseconds.
*/
 private void setRefreshInterval(int interval) {
  // Confirm adherence to precondition in nonpublic method
  assert interval > 0 && interval <= 1000/MAX_REFRESH_RATE : interval;

  ... // Set the refresh interval
 }

Note, the above assertion will fail if MAX_REFRESH_RATE is greater than 1000 and the client selects a refresh rate greater than 1000. This would, in fact, indicate a bug in the library!

Lock-Status Preconditions

Classes designed for multithreaded use often have non-public methods with preconditions relating to whether or not some lock is held. For example, it is not uncommon to see something like this:

private Object[] a;
public synchronized int find(Object key) {
  return find(key, a, 0, a.length);
}

// Recursive helper method - always called with a lock on this object
private int find(Object key, Object[] arr, int start, int len) {
 ...
}

A static method called holdsLock has been added to the Thread class to test whether the current thread holds the lock on a specified object. This method can be used in combination with an assert statement to supplement a comment describing a lock-status precondition, as shown in the following example:

// Recursive helper method - always called with a lock on this.
private int find(Object key, Object[] arr, int start, int len) {
  assert Thread.holdsLock(this); // lock-status assertion
  ...
}

Note that it is also possible to write a lock-status assertion asserting that a given lock isn't held.

Postconditions

You can test postcondition with assertions in both public and nonpublic methods. For example, the following public method uses an assert statement to check a post condition:

 /**
  * Returns a BigInteger whose value is (this-1 mod m).
  *
  * @param  m the modulus.
  * @return this-1 mod m.
  * @throws ArithmeticException  m <= 0, or this BigInteger
  *has no multiplicative inverse mod m (that is, this BigInteger
  *is not relatively prime to m).
  */
public BigInteger modInverse(BigInteger m) {
  if (m.signum <= 0)
    throw new ArithmeticException("Modulus not positive: " + m);
  ... // Do the computation
  assert this.multiply(result).mod(m).equals(ONE) : this;
  return result;
}

Occasionally it is necessary to save some data prior to performing a computation in order to check a postcondition. You can do this with two assert statements and a simple inner class that saves the state of one or more variables so they can be checked (or rechecked) after the computation. For example, suppose you have a piece of code that looks like this:

 void foo(int[] array) {
  // Manipulate array
  ...

  // At this point, array will contain exactly the ints that it did
  // prior to manipulation, in the same order.
 }

Here is how you could modify the above method to turn the textual assertion of a postcondition into a functional one:

 void foo(final int[] array) {

  // Inner class that saves state and performs final consistency check
  class DataCopy {
private int[] arrayCopy;

DataCopy() { arrayCopy = (int[]) array.clone(); }

boolean isConsistent() { return Arrays.equals(array, arrayCopy); }
  }

  DataCopy copy = null;

  // Always succeeds; has side effect of saving a copy of array
  assert ((copy = new DataCopy()) != null);

  ... // Manipulate array

  // Ensure array has same ints in same order as before manipulation.
  assert copy.isConsistent();
  }

You can easily generalize this idiom to save more than one data field, and to test arbitrarily complex assertions concerning pre-computation and post-computation values.

You might be tempted to replace the first assert statement (which is executed solely for its side-effect) by the following, more expressive statement:

 copy = new DataCopy();

Don't make this replacement. The statement above would copy the array whether or not asserts were enabled, violating the principle that assertions should have no cost when disabled.

Class Invariants

A class invariant is a type of internal invariant that applies to every instance of a class at all times, except when an instance is in transition from one consistent state to another. A class invariant can specify the relationships among multiple attributes, and should be true before and after any method completes. For example, suppose you implement a balanced tree data structure of some sort. A class invariant might be that the tree is balanced and properly ordered.

The assertion mechanism does not enforce any particular style for checking invariants. It is sometimes convenient, though, to combine the expressions that check required constraints into a single internal method that can be called by assertions. Continuing the balanced tree example, it might be appropriate to implement a private method that checked that the tree was indeed balanced as per the dictates of the data structure:

 // Returns true if this tree is properly balanced
 private boolean balanced() {
  ...
 }

Because this method checks a constraint that should be true before and after any method completes, each public method and constructor should contain the following line immediately prior to its return:

 assert balanced();

It is generally unnecessary to place similar checks at the head of each public method unless the data structure is implemented by native methods. In this case, it is possible that a memory corruption bug could corrupt a "native peer" data structure in between method invocations. A failure of the assertion at the head of such a method would indicate that such memory corruption had occurred. Similarly, it may be advisable to include class invariant checks at the heads of methods in classes whose state is modifiable by other classes. (Better yet, design classes so that their state is not directly visible to other classes!)

Advanced Uses

The following sections discuss topics that apply only to resource-constrained devices and to systems where asserts must not be disabled in the field. If you have no interest in these topics, skip to the next section, "Compiling Files that Use Assertions".

Removing all Trace of Assertions from Class Files

Programmers developing applications for resource-constrained devices may wish to strip assertions out of class files entirely. While this makes it impossible to enable assertions in the field, it also reduces class file size, possibly leading to improved class loading performance. In the absence of a high quality JIT, it could lead to decreased footprint and improved runtime performance.

The assertion facility offers no direct support for stripping assertions out of class files. The assert statement may, however, be used in conjunction with the "conditional compilation" idiom described in the Java Language Specification, enabling the compiler to eliminate all traces of these asserts from the class files that it generates:

 static final boolean asserts = ... ; // false to eliminate asserts

 if (asserts)
  assert <expr> ;

Requiring that Assertions are Enabled

Programmers of certain critical systems might wish to ensure that assertions are not disabled in the field. The following static initialization idiom prevents a class from being initialized if its assertions have been disabled:

 static {
  boolean assertsEnabled = false;
  assert assertsEnabled = true; // Intentional side effect!!!
  if (!assertsEnabled)
throw new RuntimeException("Asserts must be enabled!!!");
 }

Put this static-initializer at the top of your class.

Compiling Files That Use Assertions

In order for the javac compiler to accept code containing assertions, you must use the -source 1.4 command-line option as in this example:

 javac -source 1.4 MyClass.java

This flag is necessary so as not to cause source compatibility problems.

Enabling and Disabling Assertions

By default, assertions are disabled at runtime. Two command-line switches allow you to selectively enable or disable assertions.

To enable assertions at various granularities, use the -enableassertions, or -ea, switch. To disable assertions at various granularities, use the -disableassertions, or -da, switch. You specify the granularity with the arguments that you provide to the switch:

  • no arguments
    Enables or disables assertions in all classes except system classes.
  • packageName...
    Enables or disables assertions in the named package and any subpackages.
  • ...
    Enables or disables assertions in the unnamed package in the current working directory.
  • className
    Enables or disables assertions in the named class

For example, the following command runs a program, BatTutor, with assertions enabled in only package com.wombat.fruitbat and its subpackages:

 java -ea:com.wombat.fruitbat... BatTutor

If a single command line contains multiple instances of these switches, they are processed in order before loading any classes. For example, the following command runs the BatTutor program with assertions enabled in package com.wombat.fruitbat but disabled in class com.wombat.fruitbat.Brickbat:

 java -ea:com.wombat.fruitbat... -da:com.wombat.fruitbat.Brickbat BatTutor

The above switches apply to all class loaders. With one exception, they also apply to system classes (which do not have an explicit class loader). The exception concerns the switches with no arguments, which (as indicated above) do not apply to system classes.This behavior makes it easy to enable asserts in all classes except for system classes, which is commonly desirable.

To enable assertions in all system classes, use a different switch: -enablesystemassertions, or -esa. Similarly, to disable assertions in system classes, use -disablesystemassertions, or -dsa.

For example, the following command runs the BatTutor program with assertions enabled in system classes, as well as in the com.wombat.fruitbat package and its subpackages:

 java -esa -ea:com.wombat.fruitbat...

The assertion status of a class (enabled or disabled) is set at the time it is initialized, and does not change. There is, however, one corner case that demands special treatment. It is possible, though generally not desirable, to execute methods or constructors prior to initialization. This can happen when a class hierarchy contains a circularity in its static initialization.

If an assert statement executes before its class is initialized, the execution must behave as if assertions were enabled in the class. This topic is discussed in detail in the assertions specification in the Java Language Specification.

Compatibility With Existing Programs

The addition of the assert keyword to the Java programming language does not cause any problems with preexisting binaries (.class files). If you try to compile an application that uses assert as an identifier, however, you will receive a warning or error message. In order to ease the transition from a world where assert is a legal identifier to one where it isn't, the compiler supports two modes of operation in this release:

  • source mode 1.3 (default) — the compiler accepts programs that use assert as an identifier, but issues warnings. In this mode, programs are not permitted to use the assert statement.
  • source mode 1.4 — the compiler generates an error message if the program uses assert as an identifier. In this mode, programs are permitted to use the assert statement.

Unless you specifically request source mode 1.4 with the -source 1.4 flag, the compiler operates in source mode 1.3. If you forget to use this flag, programs that use the new assert statement will not compile. Having the compiler use the old semantics as its default behavior (that is, allowing assert to be used as an identifier) was done for maximal source compatibility. Source mode 1.3 is likely to be phased out over time.

Design FAQ

Here is a collection of frequently asked questions concerning the design of the assertion facility.

  • General Questions
  • Compatibility
  • Syntax and Semantics
  • The AssertionError Class
  • Enabling and Disabling Assertions

General Questions

  • Why provide an assertion facility, given that one can program assertions atop the Java programming language with no special support?

    Although ad hoc implementations are possible, they are of necessity either ugly (requiring an if statement for each assertion) or inefficient (evaluating the condition even if assertions are disabled). Further, each ad hoc implementation has its own means of enabling and disabling assertions, which lessens the utility of these implementations, especially for debugging in the field. As a result of these shortcomings, assertions have never become a part of the culture among engineers using the Java programming language. Adding assertion support to the platform stands a good chance of rectifying this situation.

  • Why does this facility justify a language change, as opposed to a library solution?

    We recognize that a language change is a serious effort, not to be undertaken lightly. The library approach was considered. It was, however, deemed essential that the runtime cost of assertions be negligible if they are disabled. In order to achieve this with a library, the programmer is forced to hard-code each assertion as an if statement. Many programmers would not do this. Either they would omit the if statement and performance would suffer, or they would ignore the facility entirely. Note also that assertions were contained in James Gosling's original specification for the Java programming language. Assertions were removed from the Oak specification because time constraints prevented a satisfactory design and implementation.

  • Why not provide a full-fledged design-by-contract facility with preconditions, postconditions and class invariants, like the one in the Eiffel programming language?

    We considered providing such a facility, but were unable to convince ourselves that it is possible to graft it onto the Java programming language without massive changes to the Java platform libraries, and massive inconsistencies between old and new libraries. Further, we were not convinced that such a facility would preserve the simplicity that is the hallmark of the Java programming language. On balance, we came to the conclusion that a simple boolean assertion facility was a fairly straight-forward solution and far less risky. It's worth noting that adding a boolean assertion facility to the language doesn't preclude adding a full-fledged design-by-contract facility at some time in the future.

    The simple assertion facility does enable a limited form of design-by-contract style programming. The assert statement is appropriate for nonpublic precondition, postcondition and class invariant checking. Public precondition checking should still be performed by checks inside methods that result in particular, documented exceptions, such as IllegalArgumentException and IllegalStateException.

  • In addition to boolean assertions, why not provide an assert-like construct to suppress the execution of an entire block of code if assertions are disabled?

    Providing such a construct would encourage programmers to put complex assertions inline, when they are better relegated to separate methods.

Compatibility

  • Won't the new keyword cause compatibility problems with existing programs that use assert as an identifier?

    Yes, for source files. (Binaries for classes that use assert as an identifier will continue to work fine.) To ease the transition, we implemented a strategy whereby developers can continue using assert as an identifier during a transitional period.

  • Doesn't this facility produce class files that cannot be run against older JREs?

    Yes. Class files will contain calls to the new ClassLoader and Class methods, such as desiredAssertionStatus. If a class file containing calls to these methods is run against an older JRE (whose ClassLoader class doesn't define the methods), the program will fail at run time, throwing a NoSuchMethodError. It is generally the case that programs using new facilities are not compatible with older releases.

Syntax and Semantics

  • Why allow primitive types in Expression2?

    There is no compelling reason to restrict the type of this expression. Allowing arbitrary types provides convenience for developers who, for example, want to associate a unique integer code with each assertion. Further, it makes this expression feel like the argument of System.out.println(...), which is seen as desirable.

The AssertionError Class

  • When an AssertionError is generated by an assert statement in which Expression2 is absent, why isn't the program text of the asserted condition used as the detail message (for example, "height < maxHeight")?

    While doing so might improve out-of-the-box usefulness of assertions in some cases, the benefit doesn't justify the cost of adding all those string constants to .class files and runtime images.

  • Why doesn't an AssertionError allow access to the object that generated it? Similarly, why not pass an arbitrary object from the assertion to the AssertionError constructor in place of a detail message?

    Access to these objects would encourage programmers to attempt to recover from assertion failures, which defeats the purpose of the facility.

  • Why not provide context accessors (like getFile, getline, getMethod) on AssertionError?

    This facility is best provided on Throwable, so it may be used for all throwables, not just assertion errors. We enhanced Throwable with the getStackTrace method to provide this functionality.

  • Why is AssertionError a subclass of Error rather than RuntimeException?

    This issue was controversial. The expert group discussed it at length, and came to the conclusion that Error was more appropriate to discourage programmers from attempting to recover from assertion failures. It is, in general, difficult or impossible to localize the source of an assertion failure. Such a failure indicates that the program is operating "outside of known space," and attempts to continue execution are likely to be harmful. Further, convention dictates that methods specify most runtime exceptions they may throw (with @throws doc comments). It makes little sense to include in a method's specification the circumstances under which it may generate an assertion failure. Such information may be regarded as an implementation detail, which can change from implementation to implementation and release to release.

Enabling and Disabling Assertions

  • Why not provide a compiler flag to completely eliminate assertions from object files?

    It is a firm requirement that it be possible to enable assertions in the field, for enhanced serviceability. It would have been possible to also permit developers to eliminate assertions from object files at compile time. Assertions can contain side effects, though they should not, and such a flag could therefore alter the behavior of a program in significant ways. It is viewed as good thing that there is only one semantics associated with each valid Java program. Also, we want to encourage users to leave asserts in object files so they can be enabled in the field. Finally, the spec demands that assertions behave as if enabled when a class runs before it is initialized. It would be impossible to offer these semantics if assertions were stripped from the class file. Note, however, that the standard "conditional compilation idiom" described in the Java Language Specification can be used to achieve this effect for developers who really want it.

  • Why do the commands that enable and disable assertions use package-tree semantics instead of the more traditional package semantics?

    Hierarchical control is useful, as programmers really do use package hierarchies to organize their code. For example, package-tree semantics allow assertions to be enabled or disabled in all of Swing at one time.

  • Why does setClassAssertionStatus return a boolean instead of throwing an exception if it is invoked when it's too late to set the assertion status (that is, if the named class has already been initialized)?

    No action (other than perhaps a warning message) is necessary or desirable if it's too late to set the assertion status. An exception seems unduly heavyweight.

  • Why not overload a single method name to take the place of setDefaultAssertionStatus and setAssertionStatus?

    Clarity in method naming is for the greater good. Overloading tends to cause confusion.

  • Why not tweak the semantics of desiredAssertionStatus to make it more "programmer friendly" by returning the actual assertion status if a class is already initialized?

    It's not clear that there would be any use for the resulting method. The method isn't designed for application programmer use, and it seems inadvisable to make it slower and more complex than necessary.

  • Why is there no RuntimePermission to prevent applets from enabling/disabling assertions?

    While applets have no reason to call any of the ClassLoader methods for modifying assertion status, allowing them to do so seems harmless. At worst, an applet can mount a weak denial-of-service attack by enabling assertions in classes that have yet to be initialized. Moreover, applets can only affect the assert status of classes that are to be loaded by class loaders that the applets can access. There already exists a RuntimePermission to prevent untrusted code from gaining access to class loaders (getClassLoader).

  • Why not provide a construct to query the assert status of the containing class?

    Such a construct would encourage people to inline complex assertion code, which we view as a bad thing. Further, it is straightforward to query the assert status atop the current API, if you feel you must:

    boolean assertsEnabled = false;
assert assertsEnabled = true;  // Intentional side-effect!!!
// Now assertsEnabled is set to the correct value
  • Why does an assert statement that executes before its class is initialized behave as if assertions were enabled in the class?

  • Few programmers are aware of the fact that a class's constructors and methods can run prior to its initialization. When this happens, it is quite likely that the class's invariants have not yet been established, which can cause serious and subtle bugs. Any assertion that executes in this state is likely to fail, alerting the programmer to the problem. Thus, it is generally helpful to the programmer to execute all assertions encountered while in this state.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.AssertTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.AssertTree

  • Packages that use AssertTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of AssertTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type AssertTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitAssert(AssertTree node, P p)

    • Uses of AssertTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AssertTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitAssert(AssertTree node, P p)
      R | TreeScanner.visitAssert(AssertTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.AssignmentTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.AssignmentTree

  • Packages that use AssignmentTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of AssignmentTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type AssignmentTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitAssignment(AssignmentTree node, P p)

    • Uses of AssignmentTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AssignmentTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitAssignment(AssignmentTree node, P p)
      R | TreeScanner.visitAssignment(AssignmentTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.Association (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.Association

    • Uses of Association in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return Association
      Modifier and Type Method and Description
      abstract Association SendFailedNotification.association()
      Returns the association that this notification is applicable to.
      abstract Association MessageInfo.association()
      Returns the association that the message was received on, if the message has been received, otherwise the association that the message is to be sent on.
      abstract Association SctpChannel.association()
      Returns the association on this channel's socket.
      Association Notification.association()
      Returns the association that this notification is applicable to.
      abstract Association ShutdownNotification.association()
      Returns the association that this notification is applicable to.
      abstract Association PeerAddressChangeNotification.association()
      Returns the association that this notification is applicable to.
      abstract Association AssociationChangeNotification.association()
      Returns the association that this notification is applicable to.
      Methods in com.sun.nio.sctp that return types with arguments of type Association
      Modifier and Type Method and Description
      abstract Set<Association> SctpMultiChannel.associations()
      Returns the open associations on this channel's socket.
      Methods in com.sun.nio.sctp with parameters of type Association
      Modifier and Type Method and Description
      abstract SctpChannel SctpMultiChannel.branch(Association association)
      Branches off an association.
      static MessageInfo MessageInfo.createOutgoing(Association association, SocketAddress address, int streamNumber)
      Creates a MessageInfo instance suitable for use when sending a message to a given association.
      abstract <T> T SctpMultiChannel.getOption(SctpSocketOption<T> name, Association association)
      Returns the value of a socket option.
      abstract Set<SocketAddress> SctpMultiChannel.getRemoteAddresses(Association association)
      Returns all of the remote addresses to which the given association on this channel's socket is connected.
      abstract <T> SctpMultiChannel SctpMultiChannel.setOption(SctpSocketOption<T> name, T value, Association association)
      Sets the value of a socket option.
      abstract SctpMultiChannel SctpMultiChannel.shutdown(Association association)
      Shutdown an association without closing the channel.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.AssociationChangeNotification (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.AssociationChangeNotification

    • Uses of AssociationChangeNotification in com.sun.nio.sctp

      Methods in com.sun.nio.sctp with parameters of type AssociationChangeNotification
      Modifier and Type Method and Description
      HandlerResult AbstractNotificationHandler.handleNotification(AssociationChangeNotification notification, T attachment)
      Invoked when an AssociationChangeNotification is received from the SCTP stack.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.AssociationChangeNotification.AssocChangeEvent (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.AssociationChangeNotification.AssocChangeEvent

    • Uses of AssociationChangeNotification.AssocChangeEvent in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return AssociationChangeNotification.AssocChangeEvent
      Modifier and Type Method and Description
      abstract AssociationChangeNotification.AssocChangeEvent AssociationChangeNotification.event()
      Returns the type of change event.
      static AssociationChangeNotification.AssocChangeEvent AssociationChangeNotification.AssocChangeEvent.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AssociationChangeNotification.AssocChangeEvent[] AssociationChangeNotification.AssocChangeEvent.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.ATR (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.ATR

    • Uses of ATR in javax.smartcardio

      Methods in javax.smartcardio that return ATR
      Modifier and Type Method and Description
      abstract ATR Card.getATR()
      Returns the ATR of this card.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.connect.AttachingConnector (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.AttachingConnector

  • Packages that use AttachingConnector
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of AttachingConnector in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type AttachingConnector
      Modifier and Type Method and Description
      List<AttachingConnector> VirtualMachineManager.attachingConnectors()
      Returns the list of known AttachingConnector objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.tools.attach.AttachNotSupportedException (Attach API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.tools.attach.AttachNotSupportedException

  • Packages that use AttachNotSupportedException
    Package Description
    com.sun.tools.attach
    Provides the API to attach to a JavaTM virtual machine.
    com.sun.tools.attach.spi
    Only developers who are defining new attach providers should need to make direct use of this package.

    • Uses of AttachNotSupportedException in com.sun.tools.attach

      Methods in com.sun.tools.attach that throw AttachNotSupportedException
      Modifier and Type Method and Description
      static VirtualMachine VirtualMachine.attach(String id)
      Attaches to a Java virtual machine.
      static VirtualMachine VirtualMachine.attach(VirtualMachineDescriptor vmd)
      Attaches to a Java virtual machine.

    • Uses of AttachNotSupportedException in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that throw AttachNotSupportedException
      Modifier and Type Method and Description
      abstract VirtualMachine AttachProvider.attachVirtualMachine(String id)
      Attaches to a Java virtual machine.
      VirtualMachine AttachProvider.attachVirtualMachine(VirtualMachineDescriptor vmd)
      Attaches to a Java virtual machine.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.tools.attach.AttachOperationFailedException (Attach API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.tools.attach.AttachOperationFailedException

No usage of com.sun.tools.attach.AttachOperationFailedException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.tools.attach.AttachPermission (Attach API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.tools.attach.AttachPermission

No usage of com.sun.tools.attach.AttachPermission
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.tools.attach.spi.AttachProvider (Attach API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.tools.attach.spi.AttachProvider

  • Packages that use AttachProvider
    Package Description
    com.sun.tools.attach
    Provides the API to attach to a JavaTM virtual machine.
    com.sun.tools.attach.spi
    Only developers who are defining new attach providers should need to make direct use of this package.

    • Uses of AttachProvider in com.sun.tools.attach

      Methods in com.sun.tools.attach that return AttachProvider
      Modifier and Type Method and Description
      AttachProvider VirtualMachine.provider()
      Returns the provider that created this virtual machine.
      AttachProvider VirtualMachineDescriptor.provider()
      Return the AttachProvider that this descriptor references.
      Constructors in com.sun.tools.attach with parameters of type AttachProvider
      Constructor and Description
      VirtualMachine(AttachProvider provider, String id)
      Initializes a new instance of this class.
      VirtualMachineDescriptor(AttachProvider provider, String id)
      Creates a virtual machine descriptor from the given components.
      VirtualMachineDescriptor(AttachProvider provider, String id, String displayName)
      Creates a virtual machine descriptor from the given components.

    • Uses of AttachProvider in com.sun.tools.attach.spi

      Methods in com.sun.tools.attach.spi that return types with arguments of type AttachProvider
      Modifier and Type Method and Description
      static List<AttachProvider> AttachProvider.providers()
      Returns a list of the installed attach providers.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Attach API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Attr (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Attr

  • Packages that use Attr
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of Attr in org.w3c.dom

      Methods in org.w3c.dom that return Attr
      Modifier and Type Method and Description
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      Attr Element.getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      Methods in org.w3c.dom with parameters of type Attr
      Modifier and Type Method and Description
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

CHAPTER 2

Attributes

When sending print data to a printer, a client also provides instructions on how to print the data, such as: what media (paper) to use and how many copies to print. The client specifies these processing instructions using the attribute definitions of the Java Print Service API.

The Java Print Service API includes two packages that define attributes: javax.print.attribute and javax.print.attribute.standard. The javax.print.attribute package contains the interfaces and classes that describe the types of attributes and how they are collected into sets. The javax.print.attribute.standard package enumerates all of the standard attributes in the API. Most of the attribute definitions in the JPS API are implementations of the standard and extensible attributes defined by the Internet Printing Protocol (IPP) Specification from the IETF.

This chapter describes the attribute definitions of the JPS API in more detail.The Attribute Categories and Values section explains what an attribute is according to the JPS. The Attribute Roles section describes the type of attributes. The Attribute Sets section describes how the attributes are collected into sets. The Standard Attributes section describes some of the more-commonly used attributes defined in the javax.attribute.standard package.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

Attribute Categories and Values

Every printer has a set of capabilities, such as the ability to print on different paper sizes or the ability to print more than one copy. Each of the capabilities has a range of values. For example, a printer's orientation capability might have this range of values: [landscape, portrait]. For each print request, the capability is set to one of these possible values. The Java Print Service API uses the term attribute category to refer to a printer capability, such as orientation, and the term attribute value to refer to the value of the capability, such as landscape.

In the Java Print Service API, an attribute category is represented by a Java class implementing the Attribute interface, and attribute values are instances of such a class or one of its subclasses. For example, to print 5 copies of a job, an application constructs an instance of the Copies class with the value of 5 and uses the Copies instance to specify the print job. The Copies class represents the attribute category, and the Copies instance represents the attribute value. Because the attribute value is encapsulated as a Java object, the attribute value implies its attribute category, and so an attribute value is usually referred to simply as an attribute. The category and value constitute a key-value pair, which you can add to a set along with other attributes. See Attribute Sets for more information

The Attribute interface defines just two methods: getName and getCategory. The getName method returns a String name for the attribute category. The getCategory method returns the class that first implements that category. To ensure that all implementations of a particular category report the same name and class, subclasses should not override the getName or getCategory methods.

To determine what attribute categories and values are supported by a printer, use the query methods defined in the PrintService interface. A print request does not need to specify attribute values for all of the target printer's supported attribute categories: each supported attribute category has a default value. For example, a printer might support printing up to 999 copies of a job, but if a print request does not specify the number of copies, the printer almost always prints a default of just 1 copy.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

Attribute Roles

When submitting a print job to a printer, the client provides the attributes describing the characteristics of the print data, such as the document name, and how the print data should be printed, such as double-sided, five copies. If a print job consists of multiple pieces of print data, different pieces might have different processing instructions, such as 8 x 11 inch media for the first document, and 11 x 17 inch media for another document.

Once the printer starts processing the print job, additional information about the job becomes available, which might include: the job state (such as completed or queued) and the number of pages printed so far. These pieces of information are also attributes. Attributes can also describe the printer itself, such as: the printer name, the printer location, and the number of jobs queued.

The Java Print Service API defines these different kinds of attribute roles with five subinterfaces of Attribute:

  • PrintRequestAttribute is used by an application to represents a setting applied to an entire print job and to specify how the entire print job should be printed.
  • DocAttribute is used by an application to specify a characteristic of a single document and the print job settings to be applied to the document.
  • PrintJobAttribute is used by a print service to report how a job is being printed. These values will usually be identical the requested attribute values. However, if the printer does not support the value of a print request attribute then the corresponding print job attribute contains a different value that is supported by the printer
  • PrintServiceAttribute is used by a print service to report the status of the print service.
  • SupportedValuesAttribute is used by a print service o indicate the range of values supported for a request attribute. For example, a printer might support only a certain range of copies. When a print service is queried for the supported range of copies, it returns this information in a CopiesSupported object, which implements SupportedValuesAttribute.
Many attributes can be members of more than one role. For example, the Media attribute belongs to the doc, print job, and print request roles because the Media attribute can describe the paper size, the paper tray, or paper type. In fact, most doc attributes are also request attributes, and all request attributes are also job attributes.

The next section describes how to collect attributes together into attribute sets, which also have roles.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

Attribute Sets

A client usually needs to provide more than one processing instruction when submitting a print job. For example, the client might need to specify an A4 media and a landscape orientation. To send more than one processing instruction to the printer, the client collects the attributes representing the instructions into an attribute set, which the Java Print Service API represents with the AttributeSet interface.

The AttributeSet interface is similar to the java.util.Map interface: it provides a map of keys to values, in which each key is unique and can contain no more than one value. However, the AttributeSet interface is designed to specifically support the needs of the Java Print Service API. An AttributeSet requires that:

  • Each key in an AttributeSet corresponds to a category, and the value of the key can only be one of the attribute values that belong to the category represented by the key. Thus, unlike a Map, an AttributeSet restricts the possible values of a key: an attribute category cannot be set to an attribute value that does not belong to that category.
  • Only attributes implementing the Attribute interface can be added to the attribute set.
  • Only one attribute from a particular category can exist in an AttributeSet. For example, if an attribute set already contains a Media attribute, adding another Media attribute overwrites the first one.
Like a single attribute, an attribute set has a role. The roles are defined by the AttributeSet subinterfaces, which parallel the Attribute subinterfaces mentioned in the Attribute Roles section. The AttributeSet subinterfaces are: PrintRequestAttributeSet, PrintJobAttributeSet, DocAttributeSet, and PrintServiceAttributeSet. The role of the attribute set determines what kind of attributes it contains: a print request attribute set can contain only print request attributes.

The Java Print Service API includes HashAttributeSet as a concrete implementation of the AttributeSet interface, but developers can provide their own implementation. Rather than using HashAttributeSet directly, applications will more often use one of the subclasses of HashAttributeSet, which are: HashPrintRequestAttributeSet, HashPrintJobAttributeSet, HashDocumentAttributeSet, and HashPrintServiceAttributeSet. These subclasses implement the corresponding AttributeSet subinterfaces. For example PrintRequestAttributeSet extends AttributeSet, and HashPrintRequestAttributeSet is the concrete implementation of PrintRequestAttributeSet. An attribute set created with HashPrintRequestAttributeSet or any implementation of PrintRequestAttributeSet can contain only request attributes.

Unlike its subclasses, a HashAttributeSet can contain any kind of attribute. An application uses a HashAttributeSet directly when it needs a set to contain more than one kind of attribute. One example is the set returned by the getUnsupportedAttributes method of PrintService. The unsupported attributes returned might belong to more than one attribute role.

As with single attributes, applications will more often create request attribute sets because specifying print requests is the printing application's primary function. To create a request attribute set, use one of the constructors from the HashPrintRequestAttributeSet class:

PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
The next section describes some of the more commonly-used attributes that you can add to a set.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

How to Specify Attributes

Whether you are printing or streaming data, you specify attributes in the same way. You will usually use PrintRequestAttribute more often than the other kinds of attributes because print request attributes specify the settings for an entire print job. Bec ause you will most likely want to specify more than one attribute for a particular job, you need to create an attribute set. This sample demonstrates creating a PrintRequestAttributeSet that instructs the service to use A4 media to print five copies of th e job using both sides of the paper:

PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
aset.add(new Copies(5));
aset.add(MediaSize.ISO_A4);
aset.add(Sides.DUPLEX);
After creating an attribute set, you will pass it to the print job's print method, along with the DocFlavor. The Specifying Document Types discusses using DocFlavor. The Printing and Streaming Documents chapter discusses how to print. The next section explains some of the more commonly-used attributes in more detail.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

Standard Attributes

The javax.print.attribute.standard package enumerates all of the standard attributes in the Java Print Service API. Most of these standard attributes are taken from the attributes defined in the IETF Internet Printing Protocol (IPP) 1.1 specification. This means that each IPP-compliant attribute class(category) defined in package javax.print.attribute.standard corresponds to an IPP attribute category, and the name (as returned by getName) is the actual IPP name for the category. The class names also usually reflect the IPP name as closely as the coding conventions of the Java programming language permit. Furthermore the values defined for a category are the same as the IPP values. IPP compatibility of each attribute category is documented in the API specification.

This section describes the attributes that developers will probably use most frequently. The more commonly-used attributes, including the ones listed here, implement PrintRequestAttribute because printing applications will usually specify how an entire print job should be printed, which is the role of a PrintRequestAttribute.

OrientationRequested

The OrientationRequested attribute category allows you to specify the orientation of the imaging on the paper. The possible attribute values are: PORTRAIT, LANDSCAPE, REVERSE_PORTRAIT, and REVERSE_LANDSCAPE. OrientationRequested.PORTRAIT is usually the default value. This code snippet demonstrates adding an OrientationRequested attribute to a set:

aset.add(OrientationRequested.REVERSE_PORTRAIT);
The OrientationRequested object is a type-safe enumeration encapsulating String values, which correspond to the possible orientations. These values are the actual IPP keywords.

Some pre-formatted document types, such as "Postscript", might not be able to support this attribute category because pre-formatted document types embed printer language commands that are interpreted by the printer, and these commands take precedence over a client request.

Clients can discover the supported orientation values for a particular print service by calling:

PrintService.getSupportedAttributeValues(OrientationRequested.class, ...).
This method returns an array of type OrientationRequested enumerating the supported values.

Copies

The Copies attribute category allows you to specify the number of copies to print. The Copies class encapsulates an integer representing the number of copies requested. This code snippet demonstrates adding a Copies attribute, set to five copies, to an attribute set:

aset.add(Copies(5));
Clients can discover the range of copies that a print service supports by calling :

PrintService.getSupportedAttributeValues(Copies.class, ...)
This method returns a CopiesSupported object, which encapsulates a range of integer values representing the range of copies that the service can handle. Calling getSupportedAttributeValues with CopiesSupported instead of Copies always returns null because the CopiesSupported object does not implement the PrintRequestAttribute interface, and so a client cannot specify a CopiesSupported attribute in a print request.

This code sample demonstrates discovering if a print service supports printing 5 copies and adding a Copies attribute with a value of 5 copies to an attribute set:

CopiesSupported copSupp =
        (CopiesSupported) service.getSupportedAttributeValues(Copies.class, null,
                                                                                null);
if (copSupp != null && copSupp.contains(5)) {
        requestAttrSet.add(new Copies(5));
} else { ...
}

Media

Media is the IPP attribute that identifies the medium on which to print. The Media attribute is an important attribute to understand, butis relatively complex.

The Java Print Service API defines three subclasses of the abstract class Media to reflect the overloaded Media attribute in the IPP specification: MediaSizeName, MediaName and MediaTray. All the Media subclasses have the Media category, for which each subclass defines different standard attribute values. For example, a MediaTray object can specify a value of MANUAL for the Media attribute to indicate that the document must be printed on paper from the printer's manual tray. This code snippet demonstrates adding a Media attribute to a set:

aset.add(MediaTray.MANUAL);

The value of the Media attribute is always a String, but because the attribute is overloaded, its value determines the type of media to which the attribute refers. For example, the IPP pre-defined set of attribute values include the values "a4" and "top-tray". If Media is set to the value "a4" then the Media attribute refers to the size of paper, but if Media is set to "top-tray" then the Media attribute refers to the paper source. Because the String attribute value can refer to such diverse types of media, an application can extend the attribute set to include values such as "company-letterhead" or "yellow letter paper". Of course, to extend the Media attribute in this way, an application must discover a print service that is configured to print with this media.

In most cases, applications will use either MediaSizeName or MediaTray. The MediaSizeName class enumerates the media by size. The MediaTray class enumerates the paper trays on a printer, which usually include a main tray and a manual feed tray. The IPP 1.1 specification does not provide for specifying both the media size and the media tray at the same time, which means, for example, that an application cannot request size A4 paper from the manual tray. A future revision of the IPP specification might provide for a way to request more than one type of media at a time, in which case the JPS API will most likely be enhanced to implement this change.

The JPS API also includes two additional media-related Attribute classes that are not IPP attributes: MediaSize and MediaPrintableArea.

MediaSize

MediaSize is not a request attribute; it is an enumeration of paper dimensions and a mapping to MediaSizeName instances. Each MediaSizeName instance usually has a MediaSize object associated with it so that clients can obtain the dimensions of the paper that the MediaSizeName instance defines. To determine the dimensions of the MediaSizeName instance, call:

MediaSize size = MediaSizeName.getMediaSizeForName(paper);

MediaPrintableArea

MediaPrintableArea is used in a print request in conjunction with a compatible Media to specify the area of the paper on which to print. Printer hardware usually defines the printable area of a page, which is rarely the entire page. For this reason, an application needs to determine what printable area a printer defines for a particular size media to ensure that the print data can fit within this area.

For example, to determine the supported printable area for 5" x 7" paper, the application needs to choose a media size attribute value that corresponds to this size paper and then query the print service with the media size:

PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
aset.add(MediaSizeName.NA_5X7);
MediaPrintableArea printableArea =
(MediaPrintableArea)service.
        getSupportedAttributeValues(MediaPrintableArea.class, null, aset);
The returned value indicates the largest printable area that can be supported by that printer for that paper size.

Destination

The Destination attribute allows you to redirect your print data to a file rather than sending it to a printer device. The "print-to-file" option is very common in user dialogs, but the spooled data is not always usable because it might be a device-specific raster that can only be interpreted by the device from which it was redirected. For this reason, the Java Print Service API requires that the client query the print service to determine if it can redirect the output to a file. The service might not support the category at all, or it might support only particular values. For example, since the JPS API can be used in an network environment, in which the formatting of print data does not occur on the host computer, specifying a local file for output might not be possible because the service formatting the data might not have access to the local filesystems of the client. The Destination attribute takes a URL as the value of the destination, which allows a network printer to use a protocol such as ftp to upload formatted print data. However, most printers that support this attribute will run as part of a local environment and can accept the "file:" protocol URL. This code snippet redirects the output to a file called out.prn on the c: drive:

aset.add(new Destination("file:c:\out.prn"));

SheetCollate

The SheetCollate attribute allows you to specify whether or not your print job is collated when you are printing more than one copy of a multi-page document. For example, the pages of a 3-page, 2-copy collated job will print as (1,2,3,1,2,3), but the pages of the same document submitted in a 2-copy uncollated job will be printed as (1,1,2,2,3,3). This attribute is not in version 1.1 of the IPP specification, but it is very useful and most printers support it. This code snippet demonstrates specifying a collated job:

aset.add(SheetCollate.COLLATED);

Sides

Some printers, particularly high-end printers, can print on both sides of the paper. The Sides attribute allows applications to specify two-sided printing instead of the usual default of single-sided printing. Two-sided printing is sometimes referred to as "duplex" or "tumble" printing. These two values are differentiated by the orientation of the output. The Java Print Service API refers to duplex as "two sided long edge" and tumble as "two sided short edge". Read the API specification for Sides for further explanation. This code snippet specifiesthat a job print the documents two-sided:

aset.add(Sides.DUPLEX);

Fidelity

The Fidelity attribute is an IPP boolean attribute that represents whether or not a print job should be rejected if the print service does not support any attribute specified in the print request. Fidelity is not an attribute many developers will need to consider, but it is an important attribute in the context of the JPS API. The default value is FIDELITY_FALSE, which indicates that a print job should not be rejected if the print service does not support an attribute specified in the print request. For example, if an application specifies an orientation of reverse landscape, but the printer does not support reverse landscape, the job is rejected if fidelity is true, but if fidelity is false then the printer might substitute a reasonable alternative, such as the landscape orientation. The Fidelity attribute allows applications to decide whether to only print the document exactly as specified or to print it even though the printer might not support all attributes. This code snippet specifies that a job should be rejected if the printer does not support the requested attributes:

aset.add(Fidelity.FIDELITY_TRUE);
For the cases in which fidelity is important, the Java Print Service API provides many tools for applications to query exactly what can be supported for a particular print request. See the various query methods on the PrintService interface.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 2 - Attributes

Documentation Contents
CONTENTS | PREV | NEXT

Uses of JPS Attributes

Unlike attributes of previous Java printing APIs, the Java Print Service attributes can be used in both the program and from the user dialog. Applications can specify as little as needed about how a job should be printed and can inspect the selections made by end users in user dialogs.

The JPS attributes are designed to be extensible. An AttributeSet can contain anything that properly implements the Attribute interfaces, which means that the set of standard attributes can evolve and still be compatible with future JDK versions, and implementors of services can extend attributes in two ways:

  • Using their own subclasses of a standard attribute category to support additional values of that category.
  • Creating new attribute categories.
Demonstrating attribute usage from the user dialog requires providing a user interface, which is beyond the scope of this user guide. Likewise, extending JPS attributes is a task for service providers, and is not included as an example in this version of the user guide. However, the Printing a Document chapter explains a simple printing application, which covers the basics of using the JPS attributes as described in this chapter.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.doctree.AttributeTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.AttributeTree

  • Packages that use AttributeTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of AttributeTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type AttributeTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitAttribute(AttributeTree node, P p)

    • Uses of AttributeTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AttributeTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitAttribute(AttributeTree node, P p)
      R | DocTreeScanner.visitAttribute(AttributeTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.source.doctree.AttributeTree.ValueKind (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.source.doctree.AttributeTree.ValueKind

  • Packages that use AttributeTree.ValueKind
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).

    • Uses of AttributeTree.ValueKind in com.sun.source.doctree

      Methods in com.sun.source.doctree that return AttributeTree.ValueKind
      Modifier and Type | Method and Description
      AttributeTree.ValueKind | AttributeTree.getValueKind()
      static AttributeTree.ValueKind AttributeTree.ValueKind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AttributeTree.ValueKind[] AttributeTree.ValueKind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.Authenticator (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Authenticator

  • Packages that use Authenticator
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of Authenticator in com.sun.net.httpserver

      Subclasses of Authenticator in com.sun.net.httpserver
      Modifier and Type Class and Description
      class  BasicAuthenticator
      BasicAuthenticator provides an implementation of HTTP Basic authentication.
      Methods in com.sun.net.httpserver that return Authenticator
      Modifier and Type Method and Description
      abstract Authenticator HttpContext.getAuthenticator()
      Returns the currently set Authenticator for this context if one exists.
      abstract Authenticator HttpContext.setAuthenticator(Authenticator auth)
      Sets the Authenticator for this HttpContext.
      Methods in com.sun.net.httpserver with parameters of type Authenticator
      Modifier and Type Method and Description
      abstract Authenticator HttpContext.setAuthenticator(Authenticator auth)
      Sets the Authenticator for this HttpContext.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.Authenticator.Failure (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Authenticator.Failure

No usage of com.sun.net.httpserver.Authenticator.Failure
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.Authenticator.Result (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Authenticator.Result

  • Packages that use Authenticator.Result
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of Authenticator.Result in com.sun.net.httpserver

      Subclasses of Authenticator.Result in com.sun.net.httpserver
      Modifier and Type Class and Description
      static class  Authenticator.Failure
      Indicates an authentication failure.
      static class  Authenticator.Retry
      Indicates an authentication must be retried.
      static class  Authenticator.Success
      Indicates an authentication has succeeded and the authenticated user principal can be acquired by calling getPrincipal().
      Methods in com.sun.net.httpserver that return Authenticator.Result
      Modifier and Type | Method and Description
      abstract Authenticator.Result Authenticator.authenticate(HttpExchange exch)
      called to authenticate each incoming request.
      Authenticator.Result | BasicAuthenticator.authenticate(HttpExchange t)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.Authenticator.Retry (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Authenticator.Retry

No usage of com.sun.net.httpserver.Authenticator.Retry
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.Authenticator.Success (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Authenticator.Success

No usage of com.sun.net.httpserver.Authenticator.Success
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.security.jgss.AuthorizationDataEntry (Java GSS-API Utilities )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.security.jgss.AuthorizationDataEntry

No usage of com.sun.security.jgss.AuthorizationDataEntry
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2000, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.doctree.AuthorTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.AuthorTree

  • Packages that use AuthorTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of AuthorTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type AuthorTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitAuthor(AuthorTree node, P p)

    • Uses of AuthorTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type AuthorTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitAuthor(AuthorTree node, P p)
      R | DocTreeScanner.visitAuthor(AuthorTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Autoboxing

As any Java programmer knows, you can't put an int (or other primitive value) into a collection. Collections can only hold object references, so you have to box primitive values into the appropriate wrapper class (which is Integer in the case of int). When you take the object out of the collection, you get the Integer that you put in; if you need an int, you must unbox the Integer using the intValue method. All of this boxing and unboxing is a pain, and clutters up your code. The autoboxing and unboxing feature automates the process, eliminating the pain and the clutter.

The following example illustrates autoboxing and unboxing, along with generics and the for-each loop. In a mere ten lines of code, it computes and prints an alphabetized frequency table of the words appearing on the command line.

import java.util.*;

// Prints a frequency table of the words on the command line
public class Frequency {
   public static void main(String[] args) {
      Map<String, Integer> m = new TreeMap<String, Integer>();
      for (String word : args) {
          Integer freq = m.get(word);
          m.put(word, (freq == null ? 1 : freq + 1));
      }
      System.out.println(m);
   }
}

java Frequency if it is to be it is up to me to do the watusi
{be=1, do=1, if=1, is=2, it=2, me=1, the=1, to=3, up=1, watusi=1}

The program first declares a map from String to Integer, associating the number of times a word occurs on the command line with the word. Then it iterates over each word on the command line. For each word, it looks up the word in the map. Then it puts a revised entry for the word into the map. The line that does this (highlighted in green) contains both autoboxing and unboxing. To compute the new value to associate with the word, first it looks at the current value (freq). If it is null, this is the first occurrence of the word, so it puts 1 into the map. Otherwise, it adds 1 to the number of prior occurrences and puts that value into the map. But of course you cannot put an int into a map, nor can you add one to an Integer. What is really happening is this: In order to add 1 to freq, it is automatically unboxed, resulting in an expression of type int. Since both of the alternative expressions in the conditional expression are of type int, so too is the conditional expression itself. In order to put this int value into the map, it is automatically boxed into an Integer.

The result of all this magic is that you can largely ignore the distinction between int and Integer, with a few caveats. An Integer expression can have a null value. If your program tries to autounbox null, it will throw a NullPointerException. The == operator performs reference identity comparisons on Integer expressions and value equality comparisons on int expressions. Finally, there are performance costs associated with boxing and unboxing, even if it is done automatically.

Here is another sample program featuring autoboxing and unboxing. It is a static factory that takes an int array and returns a List of Integer backed by the array. In a mere ten lines of code this method provides the full richness of the List interface atop an int array. All changes to the list write through to the array and vice-versa. The lines that use autoboxing or unboxing are highlighted in green:

// List adapter for primitive int array
public static List<Integer> asList(final int[] a) {
    return new AbstractList<Integer>() {
        public Integer get(int i) { return a[i]; }
        // Throws NullPointerException if val == null
        public Integer set(int i, Integer val) {
            Integer oldVal = a[i];
            a[i] = val;
            return oldVal;
        }
        public int size() { return a.length; }
    };
}

The performance of the resulting list is likely to be poor, as it boxes or unboxes on every get or set operation. It is plenty fast enough for occasional use, but it would be folly to use it in a performance critical inner loop.

So when should you use autoboxing and unboxing? Use them only when there is an "impedance mismatch" between reference types and primitives, for example, when you have to put numerical values into a collection. It is not appropriate to use autoboxing and unboxing for scientific computing, or other performance-sensitive numerical code. An Integer is not a substitute for an int; autoboxing and unboxing blur the distinction between primitive types and reference types, but they do not eliminate it.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


AWT

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10 AWT

This chapter provides information and guidance on some specific procedures for troubleshooting common issues that might occur in the Java SE Abstract Window Toolkit (AWT).

This chapter contains the following sections:

  • Debug Tips for AWT

  • Layout Manager Issues

  • Key Events

  • Modality Issues

  • Memory Leaks

  • AWT Crashes

  • Focus Events

  • Data Transfer

  • Other Issues

  • Heavyweight/Lightweight Components Mix

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Debug Tips for AWT

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.1 Debug Tips for AWT

This section provides some helpful tips to be aware of when debugging issues related to AWT.

To dump the AWT component hierarchy, press Control+Shift+F1.

If the application hangs, get a stack trace by pressing Control+Break on Windows (which sends the SIGBREAK signal) or Control+\ on Oracle Solaris and Linux operating systems (which sends the SIGQUIT signal).

To trace X11 errors on Oracle Solaris and Linux operating systems, set the sun.awt.noisyerrorhandler system property to true. In Java SE 6 and earlier releases, the NOISY_AWT environment variable was used for this purpose.

Prior to Java SE 8, exceptions thrown in the AWT Event Dispatch Thread (EDT) could be caught by setting the system property sun.awt.exception.handler to the name of the class that implements the public void handle(Throwable) method. This mechanism has been updated in Java SE 8 to use the standard Thread.UncaughtExceptionHandler interface.

Loggers can produce helpful output when debugging AWT problems. For information on using loggers, see the Java Logging Overview documentation and the java.util.logging package description.

The following loggers are available:

java.awt
java.awt.focus
java.awt.event
java.awt.mixing
sun.awt
sun.awt.windows
sun.awt.X11
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Layout Manager Issues

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.2 Layout Manager Issues

This section describes some possible problems with layout managers and provides workarounds when available.

  1. Issue 1: Call to invalidate() and validate() increases component size

    Cause: Due to some specifics of the GridBagLayout layout manager, if ipadx or ipady is set, and invalidate() and validate() are called, then the size of the component increases to the value of ipadx or ipady. This happens because the GridBagLayout layout manager iteratively calculates the amount of space needed to store the component within the container.

    Workaround: The JDK does not provide a reliable and simple way to detect if the layout manager should rearrange components or not in such a case, but there is a very simple workaround. Use components with the overridden method getPreferredSize(), which always returns the current needed size as shown in Example 10-1.

    Example 10-1 Components with the Overridden Method

    public Dimension getPreferredSize(){
   return new Dimension(size+xpad*2+1, size+ypad*2+1);
}

  2. Issue 2: Infinite recursion with validate() from any Container.doLayout() method

    Cause: Invoking validate() from any Container.doLayout() method can lead to infinite recursion because AWT itself invokes doLayout() from validate().

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Key Events

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.3 Key Events

This section describes issues related to handling key events.

The following keyboard issues are currently unresolved:

  • On some non-English keyboards certain accented keys are engraved on the keytop and therefore are primary layer characters. Nevertheless, they cannot be used for mnemonics because there is no corresponding Java keycode.

  • Changing the default locale at runtime does not change the text that is displayed for the menu accelerator keys.

  • On a standard 109-key Japanese keyboard, the yen key and the backslash key both generate a backslash, because they have the same character code for the WM_CHAR message. AWT should distinguish them. This will be fixed in a future release.

The following keyboard issues concern the Oracle Solaris 10 and Linux x86 systems.

  • Keyboard input in these systems is usually based on the X keyboard extension (XKB) of the X Window System. Users can configure one keyboard layout (for instance, Danish: dk) or several layouts to switch between (for example, us and dk).

  • With some keyboard layouts, for instance sk, hu, and cz, pressing the decimal separator on the numeric keypad not only enters a delimiter but also deletes the previous character. This is due to a native bug. A workaround is to use two layouts, for example, us and sk. In this case the numeric keypad works correctly in both layouts.

  • On UNIX systems that support dynamic keyboard changes, a running Java application does not recognize such a change. For instance, changing the keyboard from US to German does not change the keyboard mapping. Although the X server detects the change and sends out a MappingNotify event to interested clients, AWT does not refresh its notion of the keycode-keysym mapping.

 Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Modality Issues

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.4 Modality Issues

This sections provides information about issues related to using modality.

With the Java SE 6 release, many problems were fixed and many improvements were implemented in the area of AWT modality. If you observe a modality problem with Java SE 1.5 or an earlier release, first upgrade to the latest Java SE release to see if the problem has been already fixed.

Some of the problems that were fixed in Java SE 6 are the following:

  • Modal dialog goes behind a blocked frame.

  • Two modal dialogs with the same parent window opened at the same time.

The section addresses the following issues.

  • UNIX window managers:

    Many of the modality improvements are unavailable in some Oracle Solaris or Linux environments, for example, when using Common Desktop Environment (CDE) window managers. With Java SE 6 and later releases, to see if a modality type or modal exclusion type is supported in a particular configuration, use the following methods:

    • Toolkit.isModalityTypeSupported()

    • Toolkit.isModalExclusionTypeSupported()

    When a modal dialog appears on the screen, the window manager might hide some of the Java top-level windows in the same application from the taskbar. This can confuse end users, but it does not affect their work much, because all the hidden windows are modal blocked and cannot be operated.

  • Applets:

    When your application runs as an applet in a browser and shows a modal dialog, the browser window might become blocked. The implementation of this blocking varies in different browsers and operating systems. For example, on Windows, both Internet Explorer and Mozilla Firefox work correctly, and on Oracle Solaris and Linux operating systems, Mozilla Firefox windows are not blocked. This will be corrected in a future release.

  • Other modality problems:

    For more information on modality-related features and how to use them, see the AWT Modality specification.

    One of the sections in that specification describes some AWT features that might be related to or affected by modal dialogs: always-on-top property, focus handling, window states, and so on. Application behavior in such cases is usually unspecified or depends on the platform; therefore, do not rely on any particular behavior.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Memory Leaks

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.5 Memory Leaks

This section first describes how to troubleshoot memory leaks and then presents some possible sources of memory leaks and provides workarounds.

To get more information on a memory leak, execute java with the heap profiler active as shown in Example 10-2. Specify that the output should be generated in binary format so that you can use the jhat utility to read the output.

Example 10-2 Heap Profiler to Find a Memory Leak

$ java -agentlib:hprof=file=snapshot.hprof,format=b application

For more information on troubleshooting memory leaks, as well as descriptions of the jhat utility and other troubleshooting tools that are available, see the Java SE HotSpot VM Troubleshooting Guide.

The following issue is addressed:

  • Issue 1: Memory leak in application

    Cause: Frames and dialogs are sometimes not being garbage-collected. This bug will be corrected in a future version of Java SE.

    Workaround: Known memory leaks occur in cases when the system starts to transfer focus to a focusable top-level element (window, dialog, frame), but the element is closed, hidden, or disposed of before the focus transfer is complete. Therefore, the application must wait for the focus transfer operation to finish before closing, hiding, or disposing of the element.

    Note:

    This problem normally occurs only when these actions are performed programmatically, since the user typically cannot physically perform these actions fast enough to cause the problem.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


AWT Crashes

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.6 AWT Crashes

This topic describes how to determine if a crash is related to AWT, as well as how to troubleshoot such crashes.

  • To distinguish an AWT crash:

    When a crash occurs, an error log is created with information and the state obtained at the time of the crash. For detailed information about the fatal error log file, see Appendix A.

    A line near the top of the file indicates the library where the error occurred. Example 10-3 shows a part of the error log file in the case when the crash was related to the AWT library.

    Example 10-3 Error Log for AWT Library Crash

    ...
# Java VM: Java HotSpot(TM) Client VM (1.6.0-beta2-b76 mixed mode, sharing)
# Problematic frame:
# C  [awt.dll+0x123456]
...

    However, the crash can happen somewhere deep in the system libraries, although still caused by AWT. In such cases the indication awt.dll does not appear as a problematic frame, and you need to look further in the file, in the section Stack: Native frames: Java frames as shown in Example 10-4.

    Example 10-4 Error Log for Stack Native Frames

    Stack: [0x0aeb0000,0x0aef0000),  sp=0x0aeefa44,  free space=254k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  0x00abc751
C  [USER32.dll+0x3a5f]
C  [USER32.dll+0x3b2e]
C  [USER32.dll+0x5874]
C  [USER32.dll+0x58a4]
C  [ntdll.dll+0x108f]
C  [USER32.dll+0x5e7e]
C  [awt.dll+0xec889]
C  [awt.dll+0xf877d]
j  sun.awt.windows.WToolkit.eventLoop()V+0
j  sun.awt.windows.WToolkit.run()V+69
j  java.lang.Thread.run()V+11
v  ~StubRoutines::call_stub
V  [jvm.dll+0x83c86]
V  [jvm.dll+0xd870f]
V  [jvm.dll+0x83b48]
V  [jvm.dll+0x838a5]
V  [jvm.dll+0x9ebc8]
V  [jvm.dll+0x108ba1]
V  [jvm.dll+0x108b6f]
C  [MSVCRT.dll+0x27fb8]
C  [kernel32.dll+0x202ed]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  sun.awt.windows.WToolkit.eventLoop()V+0
j  sun.awt.windows.WToolkit.run()V+69
j  java.lang.Thread.run()V+11
v  ~StubRoutines::call_stub

    If the text awt.dll appears somewhere in the native frames, then the crash might be related to AWT.

  • To troubleshoot an AWT crash:

    Most of the AWT crashes occur on the Windows platform and are caused by thread races. Many of these problems were fixed in Java SE 6, so if your crash occurred in an earlier release, first try to determine if the problem is already fixed in the latest release.

    One of the possible causes of crashes is that many AWT operations are asynchronous. For example, if you show a frame with a call to frame.setVisible(true), then you cannot be sure that it will be the active window after the return from this call.

    Another example concerns native file dialogs. It takes some time for the operating system to initialize and show these dialogs, and if you dispose of them immediately after the call to setVisible(true), then a crash might occur. Therefore, if your application contains some AWT calls running simultaneously or immediately one after another, it is a good idea to insert some delays between them or add some synchronization.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Focus Events

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.7 Focus Events

This section describes the following troubleshooting issues related to focus events.

  • How to Trace Focus Events

  • Native Focus System

  • Focus System in Java Plug-in

  • Focus Models Supported by X Window Managers

  • Miscellaneous Problems with Focus

10.7.1 How to Trace Focus Events

To troubleshoot a problem with focus, you can trace focus events. You can do it by adding a focus listener to the toolkit, as shown in Example 10-5.

Example 10-5 Trace Focus Events

Toolkit.getDefaultToolkit().addAWTEventListener(new AWTEventListener(
   public void eventDispatched(AWTEvent e) {
      System.err.println(e);
   }
), FocusEvent.FOCUS_EVENT_MASK | WindowEvent.WINDOW_FOCUS_EVENT_MASK |
   WindowEvent.WINDOW_EVENT_MASK);

The System.err stream is used here because it does not buffer the output.

Remember that the correct order of focus events is the following:

  • FOCUS_LOST on component losing focus

  • WINDOW_LOST_FOCUS on top-level losing focus

  • WINDOW_DEACTIVATED on top-level losing activation

  • WINDOW_ACTIVATED on top-level becoming active widow

  • WINDOW_GAINED_FOCUS on top-level becoming focused window

  • FOCUS_GAINED on component gaining focus

When focus is transferred between components inside the focused window, only FOCUS_LOST and FOCUS_GAINED events should be generated. When focus is transferred between owned windows of the same owner or between an owned window and its owner, then the following events should be generated:

  • FOCUS_LOST

  • WINDOW_LOST_FOCUS

  • WINDOW_GAINED_FOCUS

  • FOCUS_GAINED

Note: The events losing focus or activation should come first.

10.7.2 Native Focus System

Sometimes a problem may be caused by the native platform. To check this, investigate the native events that are related to focus. Make sure that the window you want to be focused gets activated and the component you want to focus receives the native focus event.

On the Windows platform, the native focus events are the following:

  • WM_ACTIVATE for a top-level. WPARAM is WA_ACTIVE when activating and WA_INACTIVE when deactivating.

  • WM_SETFOCUS and WM_KILLFOCUS for a component.

On the Windows platform, a concept of synthetic focus has been implemented. It means that a focus owner component only emulates its focusable state whereas real native focus is set to a focus proxy component. This component receives key and input method native messages and dispatches them to a focus owner. Prior to JDK7 a focus proxy component was a dedicated hidden child component inside a frame/dialog. In the latest JDK releases a frame/dialog itself serves as a focus proxy. Now it proxies focus not only for components in an owned window but for all child components as well. A simple window never receives native focus and relies on focus proxy of its owner. This mechanism is transparent for a user but should be taken into account when debugging.

On Oracle Solaris and Linux operating systems, XToolkit uses a focus model that allows AWT to manage focus itself. With this model the window manager does not directly set input focus on a top-level window, but instead it sends only the WM_TAKE_FOCUS client message to indicate that focus should be set. AWT then explicitly sets focus on the top-level window if it is allowed.

Note: The X server and some window managers may nevertheless send focus events to a window. However all such events are discarded by AWT.

AWT does not generate the hierarchical chains of focus events when a component inside a top-level gains focus. Moreover, the native window mapped to the component itself does not get any native focus event. On the Oracle Solaris and Linux platforms, as well as on the Windows platform, AWT uses the focus proxy mechanism. Therefore, focus on the component is set by synthesizing a focus event, whereas the invisible focus proxy has native focus.

A native window that is mapped to a Window object (not a Frame or Dialog object) has the override-redirect flag set. Thus the window manager does not notify the window about focus change. Focus is requested on the window only in response to a mouse click. This window will not receive native focus events at all. Therefore, you can trace only FocusIn or FocusOut events on a frame or dialog. Since the major processing of focus occurs at the Java level, debugging focus with XToolkit is simpler than with WToolkit.

10.7.3 Focus System in Java Plug-in

An applet is embedded in a browser as a child (though not a direct child) of an EmbeddedFrame. This is a special Frame that has the ability to communicate with the plugin. From the applet's perspective the EmbeddedFrame is a full top-level Frame.

Managing focus for an EmbeddedFrame requires special additional actions. When an applet first starts, the EmbeddedFrame does not get activated by default by the native system. The activation is performed by the plugin that triggers a special API provided by the EmbeddedFrame. When focus leaves the applet, the EmbeddedFrame is also deactivated in a synthesized manner.

10.7.4 Focus Models Supported by X Window Managers

The following focus models are supported by X window managers:

  • click-to-focus is a commonly used focus model. (For example, Microsoft Windows uses this model.)

  • focus-follows-mouse is a focus model in which focus goes to the window that the mouse hovers over.

The focus-follows-mouse model is not detected in XAWT in Java SE 7, and this causes problems for simple windows (objects of java.awt.Window class). Such windows have the override-redirect property, which means that they can be focused only when the mouse button is pressed, and not by hovering over the window. As a workaround, set MouseListener on the window and request focus on it when mouse crosses the window borders.

10.7.5 Miscellaneous Problems with Focus

This section describes some issues related to focus in AWT that can occur and suggests solutions.

  • Issue 1 - Linux + KDE, XToolkit cannot be switched between two frames when a frame's title is clicked.

    Clicking a component inside a frame causes focus to change.

    Solution: Check the version of your window manager and upgrade it to 3.0 or greater.

  • Issue 2 - You want to manage focus using KeyListener to transfer focus in response to Tab/Shift+Tab, but not key event appear.

    Solution: To catch traversal key events, you must enable them by calling Component.setFocusTraversalKeysEnabled(true).

  • Issue 3 - A window is set modal excluded with Window.setModalExclusionType(ModalExclusionType).

    The frame, its owner, is modal blocked. In this case the window will also remain modal blocked.

    Solution: A window cannot become the focused window when its owner is not allowed to get focus. The solution is to exclude the owner from modality.

  • Issue 4 - On Windows a component requests focus and is concurrently removed from its container.

    Sometimes java.lang.NullPointerException: null pData is thrown.

    Solution: The easiest way to avoid throwing the exception is to do the removal along with requesting focus on EDT. Another, more complicated, approach is to synchronize requesting focus and removal if you need to perform these actions on different threads.

  • Issue 5 - When focus is requested on a component and the focus owner is immediately removed, focus goes to the component after the removed component.

    For example, Component A is the focus owner. Focus is requested on Component B, and immediately after this Component A is removed from its container. Eventually focus goes to Component C, which is located after Component A in the container, but not to Component B.

    Solution: In this case, ensure that the requesting focus is executed after Component A is removed, not before.

  • Issue 6 - On Windows, when a window is set alwaysOnTop in an inactive frame, the window cannot receive key events.

    For example, a frame is displayed, with a window that it owns. The frame is inactive, so the window is not focused. Then the window is set to alwaysOnTop. The window gains focus, but its owner remains inactive. Therefore, the window cannot receive key events.

    Solution: Bring the frame to front (the Frame.toFront() method) before setting the window to alwaysOnTop.

  • Issue 7 - When a splash screen is shown and a frame is shown after the splash screen window closes, the frame does not get activated.

    Solution: Bring the frame to front (the Frame.toFront() method) after showing it (the Frame.setVisible(true) method).

  • Issue 8 - The WindowFocusListener.windowGainedFocus(WindowEvent) method does not return the frame's most recent focus owner.

    For example, a frame is the focused window, and one of its components is the focus owner. Another window is clicked, and then the frame is clicked again. WINDOW_GAINED_FOCUS comes to the frame and the WindowFocusListener.windowGainedFocus(WindowEvent) method is called. However, inside of this callback you cannot determine the frame's most recent focus owner, because Frame.getMostRecentFocusOwner() returns null.

    Solution: You can get the frame's most recent focus owner inside the WindowListener.windowActivated(WindowEvent) callback. However, by this time the frame will have become the focused window only if it does not have owned windows.

    Note:

    This approach does not work for the window, only for the frame or dialog.

  • Issue 9 - An Applet Steals focus when it starts.

    Solution: This behavior is the default with JDK. However you might need to prevent the applet from getting focus on startup, for example, if your applet is invisible and does not require focus at all. In this case, you can set the special parameter initial_focus to false in the HTML tag, as shown in Example 10-6.

    Example 10-6 HTML tag for Applet Focus

    <applet code="MyApplet" width=50 height=50>
<param name=initial_focus value="false">
</applet>

  • Issue 10 - A window is disabled with Component.setEnabled(false), but does not get totally unfocusable.

    Solution: Do not assume that the condition set by calling Component.setEnabled(false) or Component.setFocusable(false) will be maintained unfocusable along with all its content. Instead, use the Window.setFocusableWindowState(boolean) method.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Data Transfer

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.8 Data Transfer

This following section discusses possible problems with data transfer features, which allows you to add drag and drop (DnD) and cut, copy and paste (CCP) operations to the application.

  • Debug Drag and Drop Applications

  • Frequent Issues with Data Transfer

10.8.1 Debug Drag and Drop Applications

It is difficult to use a debugger to troubleshoot DnD features, because during the drag-and-drop operation all input is grabbed. Therefore, if you place a breakpoint during DnD, you might need to restart your X server. Try to use remote debugging instead.

Two simple methods can be used to troubleshoot most issues with DnD:

  • Printing all DataFlavor instances

  • Printing received data

An alternative to remote debugging is the System.err.println() function, which prints output without delay.

10.8.2 Frequent Issues with Data Transfer

This section describes some issues that frequently arise with data transfer operations in AWT and suggests troubleshooting solutions.

  1. Issue 1 - Pasting a huge amount of data from the clipboard takes too much time.

    Using the Clipboard.getContents() function for a paste operation sometimes causes the application to hang for a while, especially if a rich application provides the data to paste.

    The Clipboard.getContents() function fetches clipboard data in all available flavors (for example, some text and image flavors), and this can be expensive and unnecessary.

    Solution: Use the Clipboard.getData() method to get only specific data from the clipboard. If data in only one or a few flavors are needed, use one of the following Clipboard methods instead of getContents():

    • DataFlavor[] getAvailableDataFlavors()

    • boolean isDataFlavorAvailable(DataFlavor flavor)

    • Object getData(DataFlavor flavor)

  2. Issue 2 - When a Java application uses Transferable.getTransferData() for DnD operations, the drag seems to take a long time.

    In order to initialize transferred data only if it is needed, initialization code was put in Transferable.getTransferData().

    Transferable data is expensive to generate, and during a DnD operation Transferable.getTransferData() is invoked more than once, causing a slowdown.

    Solution: Cache the Transferable data so that it is generated only once.

  3. Issue 3 - Files cannot be transferred between a Java application and the GNOME/KDE desktop and file browser.

    On Windows and some window managers, transferred file lists can be represented as DataFlavor.javaFileListFlavor data flavor. But not all window managers represent lists of files in this format. For example, the GNOME window manager represents a file list as a list of URIs.

    Workaround: To get files, request data of type String, and then translate the string to a list of files according to text/uri-list format described in RFC 2483. To enable dropping files from a Java application to GNOME/KDE desktop and file browser, export data in the text/uri-list format. For a code example, see the Work Around section from the RFE.

    Solution: Move a window with an image rendered on it as the mouse cursor moves during a DnD operation. See the code example in the Work Around section from the RFE.

  4. Issue 4 - An image is passed to one of the startDrag() methods of DragGestureEvent or DragSource, but the image is not displayed during the subsequent DnD operation.

  5. Issue 5 - There is no way to transfer an array using DnD.

    The DataFlavor class has no constructor which handles arrays. The mime type for array contains characters which should be escaped. The code in Example 10-7 throws an IllegalArgumentException.

    Example 10-7 Code for IllegalArgumentException

    new DataFlavor(DataFlavor.javaJVMLocalObjectMimeType +
"; class=" +
(new String[0]).getClass().getName())

    Solution: Quote the value of the representation class parameter, as shown in Example 10-8, where the quotation marks are escaped:

    Example 10-8 Code for Representation Class Parameter

    new DataFlavor(DataFlavor.javaJVMLocalObjectMimeType +
"; class=" +
"\"" +
(new String[0]).getClass().getName() +
"\"")

    For more information, see the this bug report.

  6. Issue 6 - There are problems using AWT DnD support with Swing components.

    Various problems can arise, for example, odd events are fired during a DnD operation, multiple items cannot be dragged and dropped, an InvalidDnDOperationException is thrown.

    Solution: Use Swing's DnD support with Swing components. Although the Swing DnD implementation is based on the AWT DnD implementation, you cannot mix Swing and AWT DnD. For more information, see the DnD section of the Swing Tutorial and Java Swing documentation.

  7. Issue 7 - There is no way to change the state of the source to depend on the target.

    In order to change the state of the source to depend on the target, you need to have references to the source and target components in the same area of code, but this is not currently implemented in the DnD API.

    Workaround: One workaround is to add flags to the transferable object that allow you to determine the context of the event.

    For the transfer of data within one Java VM, the following workaround is proposed:

    • Implement your target component as DragSourceListener.

    • In DragGestureRecognizer.dragGestureRecognized() add the target at drag source listener, as shown in Example 10-9.

      Example 10-9 Code for Drag Source Listener

      public void dragGestureRecognized(DragGestureEvent dge) {
             dge.startDrag(null, new StringSelection("SomeTransferedText"));
             dge.getDragSource().addDragSourceListener(target);
        }

    • Now you can get the target and the source in the dragEnter(), dragOver(), dropActionChanged(), and dragDropEnd() methods of DragSourceListener().

  8. Issue 8 - Transferring of objects in an application takes a long time.

    The transferring of a big bundle of data or the creation of transferred objects takes too long. The user must wait a long time for the data transfer to complete.

    This expensive operation makes transferring too long because you must wait until Transferable.getTransferData() finishes.

    Solution: This solution is valid only for transferring data within one Java VM. Create or get expensive resources before the drag operation. For example, obtain file content when you create transferable, so that Transferable.getTransferData() will not be too long.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Other Issues

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.9 Other Issues

This section describes other issues such as, splash screen issues, pop up menu issues, and background color inheritance with AWT and provides information for troubleshooting them. In particular, it contains the following subsections:

  • Splash Screen Issues

  • Tray Icon Issues

  • Popup Menu Issues

  • Background/Foreground Color Inheritance

  • AWT Panel Size Restriction

  • Hangs during Debugging Popup Menus and Similar Components on X11

  • Window.toFront()/toBack() Behavior on X11

10.9.1 Splash Screen Issues

This section describes some issues that can arise with the splash screen in AWT.

  • Issue 1 - The user specified a JAR file with an appropriate MANIFEST.MF in -classpath, but the splash screen does not work.

    Solution: See solution to the next issue.

  • Issue 2 - It is not clear which of several JAR files in an application should contain the splash screen image.

    Solution: The splash screen image will be picked from a JAR file only if the file is used with the -jar command-line option. This JAR file should contain both the "SplashScreen-Image" manifest option and the image file. JAR files in -classpath will never be checked for splash screens in MANIFEST.MF. If you do not use -jar, you can still use -splash to specify the splash screen image in the command line.

  • Issue 3 - Translucent PNG splash screens do not work on Oracle Solaris and Linux operating systems.

    Solution: This is a native limitation of X11. On Oracle Solaris and Linux operating systems, the alpha channel of a translucent image will be compared with 50% threshold. Alpha values above 0.5 will make opaque pixels and pixels with alpha below 0.5 will be completely transparent. Translucency support might improve in future versions of Java SE.

10.9.2 Tray Icon Issues

With the Java SE 6 release on Windows 98, the method TrayIcon.displayMessage() is not supported because the native service to display a balloon is not supported on Windows 98.

If a SecurityManager is installed, the value of AWTPermission must be set to accessSystemTray in order to create a TrayIcon object.

10.9.3 Popup Menu Issues

In the JPopupMenu.setInvoker() method, the invoker is the component in which the popup menu is to be displayed. If this property is set to null, the popup menu does not function correctly.

The solution is to set the popup's invoker to itself.

10.9.4 Background/Foreground Color Inheritance

Many AWT components use their own defaults for background and foreground colors instead of using the colors of their parents.

This behavior is platform-dependent: the same component can behave differently on different platforms. In addition, some components use the default value for one of the background or foreground colors, but take the value from the parent for another color.

To ensure the consistency of your application on every platform, use explicit color assignment (both foreground and background) for every component or container.

10.9.5 AWT Panel Size Restriction

The AWT container has a size limitation. On most platforms, this limit is 32767 pixels. This means that, for example, if the canvas objects are 25 pixels high, a Java AWT panel cannot display more than 1310 objects.

Unfortunately there is no way to change this limit, neither with Java code nor with native code. The limit depends on what data type the operating system uses to store a widget size. For example, the Windows 2000/XP operating system and the Linux X operating system use integer type and are therefore limited to the maximum size of an integer. Other operating systems might use different types, such as long, and in this case the limit could be higher.

For more information, refer to the documentation for your platform.

The following are examples of workarounds for this limit that might be helpful:

  • Display components page by page.

  • Use tabs to display a few components at a time.

10.9.6 Hangs during Debugging Popup Menus and Similar Components on X11

Certain graphical user interface (GUI) actions require grabbing all the input events in order to determine when the action should terminate (for example, navigating popup menus). While the grab is active, no other applications receive input events. If a Java application is being debugged, and a breakpoint is reached while the grab has been active, the operating system appears to hang. This happens because the Java application holding the grab is stopped by the debugger and cannot process any input events, and other applications simply do not receive the events due to the installed grab. In order to allow debugging such applications, the following system property should be set when running the application from the debugger:

-Dsun.awt.disablegrab=true

This effectively turns off setting the grab, and as such does not hang the system. However, with this option set, in some cases this may lead to inability to terminate a GUI actions that would normally be terminated. For example, popup menus may not be dismissed when clicking a window's title bar.

10.9.7 Window.toFront()/toBack() Behavior on X11

Due to restrictions enforced by third-party software (in particular, by window managers such as the Metacity), the toFront()/toBack() methods may not always work as expected and cause the window to not change its stacking order in relation to other top-level windows. More details are available in the CR 6472274.

If an application ultimately wants to bring a window to top, it can try to workaround the issue by calling Window.setAlwaysOnTop(true) to temporarily make the window always stay on top and then calling setAlwaysOnTop(false) to reset the "always on top" state.

Note:

This workaround is not guaranteed to always work because window managers can enforce more restrictions in the future. Also, the setting a window to "always on top" is available to trusted applications only. An unsigned applet or an unsigned Web Start application running in a sandbox cannot use this API, and thus is unable to work around the issue.

However, native applications experience similar issues, and as such this peculiarity makes Java applications behave similar to native applications. Therefore this issue cannot really be considered a bug.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Heavyweight/Lightweight Components Mix

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

10.10 Heavyweight/Lightweight Components Mix

This section discusses possible issues with the heavyweight/lightweight (HW/LW) mixing feature. In particular, it addresses the following issues:

  • Validate the component hierarchy:

    Changing any layout-related properties of a component, such as its size, location, or font, invalidates the component as well as its ancestors. In order for the HW/LW Mixing feature to function correctly, the component hierarchy must be validated after making such changes. By default, invalidation stops on the top-most container of the hierarchy (for example, a Frame object). Therefore, to restore the validity of the hierarchy, the application should call the Frame.validate() method. For example:

    component.setFont(myFont);
frame.validate();

    where frame refers to a frame which contains component. Note: Swing applications and the Swing library often use the following pattern:

    component.setFont(myFont);
component.revalidate();

    The revalidate() call is not sufficient because it validates the hierarchy starting from the nearest validate root of the component only, thus leaving the upper containers invalid. In that case, the HW/LW feature may not calculate correct shapes for HW components, and visual artifacts may be seen on the screen.

    To verify the validity of the whole component hierarchy a user can use the key combination Control+Shift+F1 as described in Debug Tips for AWT. A component marked 'invalid' may indicate a missing validate() call somewhere.

  • Validate roots:

    The concept of validate roots mentioned in Validate the component hierarchy has been introduced in Swing in order to speed up the process of validating component hierarchies because it may take a significant amount of time. While such optimization leaves upper parts of hierarchies invalid, this did not bring any issues because the layout of components inside a validate root does not affect the layout of outside component hierarchy (that is, the siblings of the validate root). However, when HW and LW components are mixed together in a hierarchy, this statement is no longer true. That is why the feature requires the whole component hierarchy to be valid.

    Calling frame.validate() may be inefficient as well, and as such AWT supports an alternative, optimized way of handling invalidation/validation of component hierarchies. This feature is enabled with a system property:

    -Djava.awt.smartInvalidate=true

    Once this property is specified, the invalidate() method will stop invalidation of the hierarchy when it reaches the nearest validate root of a component on which the invalidate() method has been invoked. Afterwards, to restore the validity of the component hierarchy, the application should simply call:

    component.revalidate();

    Note: In this case, calling frame.validate() would be effectively a no-op (a statement that does nothing) because frame is still valid. Since some applications rely on calling validate() directly on a component upper than the validate root of the hierarchy (for example, a frame), this new optimized behavior may cause incompatibility issues, and hence it is available only when specifying the system property.

    If an application experiences any difficulties running in this new optimized mode, a user can use the key combination Control+Shift+F1 as described in Debug Tips for AWT to investigate what parts of the component hierarchy are left invalid, and thus possibly cause the problems.

  • Swing painting optimization:

    By default, the Swing library assumes that there are no HW components in the component hierarchy, and therefore uses optimized drawing techniques to boost performance of the Swing GUI. If a component hierarchy contains HW components, the optimizations must be turned off. This is relevant for Swing JScrollPanes in the first place. You can change the scrolling mode by using the JViewPort.setScrollMode(int) method.

  • Non-opaque LW components:

    Non-opaque LW components are not supported by the HW/LW mixing feature implementation by default. In order to enable mixing non-rectangular LW components with HW components, the application must use the com.sun.awt.AWTUtilities.setComponentMixingCutoutShape() non-public API.

    Note: The non-rectangular LW components should still paint themselves using either opaque (alpha = 1.0) or transparent (alpha = 0.0) colors. Using translucent colors (with 0.0 < alpha < 1.0) is not supported.

  • Disable the default HW/LW mix feature:

    In the past, some developers have implemented their own support for cases when HW and LW components must be mixed together. The built-in implementation of the feature available since JDK 6 and JDK 7 may cause problems with custom workarounds. In order to disable the built-in feature the application must be started with the following system property:

    -Dsun.awt.disableMixing=true
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


AWT Native Interface

Documentation Contents

The AWT Native Interface

The Key to Rendering to an AWT Canvas from Native Code

The new Java SE AWT Native Interface enables rendering libraries compiled to native code to draw directly to a Java Canvas drawing surface. This means that such libraries can be used without being converted to Java first and without significant impact on performance. An example illustrating how easy it is to use the AWT Native Interface is presented and discussed in this technical note.

Introduction

The definition of Java Standard Edition includes JNI, the Java Native Interface. Most Java developers will never need to use it, but the interface is invaluable in certain situations because it provides the only way for Java byte code to interact directly with application code that has been compiled to the native machine instructions for the host microprocessor. JNI is most often used as an ``escape valve'' to enable access to platform functionality not yet supported by the Java programming language. For example, you could use JNI to integrate with native code that communicates with a peripheral device, such as a scanner, connected to a system via a USB port.

Of course, JNI is general enough to be used to access almost any sort of native library, regardless of whether the task to be accomplished could also be done using pure Java. The major penalty for using it is that code portability suffers, but this may be acceptable or even necessary for business or technical reasons.

Business reasons? Consider the situation where the legacy software you are trying to port to Java uses a third-party library for a critical set of operations. If you do not have source rights to this library and you cannot convince the owner to provide a Java version, you may not be able to use it. Even if you do have the source, the effort needed to port a standard library to Java and test it may be too expensive to consider.

Another important reason for leaving the native code alone is related to performance. If you are dealing with a finely crafted piece of code, carefully tuned for performance over the course of years, you probably do not want to convert it to Java and risk a performance penalty. It is usually best to keep it intact until you are satisfied that the benefits of Java portability and code maintainability outweigh the expected performance difference.

A rendering library is a good example of a piece of native code that most developers would just as soon leave alone for performance reasons. Unfortunately, this is the very type of library that has been most difficult to integrate with Java code through JNI. The fundamental problem has been that the rendering code cannot identify where to draw. It needs access to information about a Java drawing surface (such as a handle to the underlying peer of a Canvas), but cannot get it.

Until now, the Java platform has kept access to this information private — "private" in the sense of undocumented, unsupported, and deprecated. The good news is that this situation will be remedied with the introduction of the "AWT Native Interface" in the Java upgrade release ("Kestrel"). For the first time there will be an official way to obtain all the information you need to know about the peer of a Java Canvas so that you can draw directly to the Canvas from a native code library using the drawing routines provided by the operating system.

How It Works

In this section we'll describe the most common usage of the AWT Native Interface — overriding the paint method to direct drawing operations to a native rendering library which then queries the Java VM to determine the information it needs in order to render. Note, however, that any native code may use the AWT Native Interface to learn about a target drawing surface, not just code in a paint method.

The first step in hooking up a native rendering library to a Java Canvas is to define a new class that extends Canvas and overrides the paint method. The Java system routes all drawing operations for a Canvas object through the paint method, as it does for all other GUI objects.

The new paint method, to be implemented in the native rendering library, must be declared as public native void , and the native library itself is loaded at runtime by including a call to System.loadLibrary( "myRenderingLib")in the static block of the class. The myRenderingLib name is used for the native shared library; for the Solaris operating environment, the actual name for the library file on disk is libmyRenderingLib.so .

Here is a simple example of such a class:

import java.awt.*;
import java.awt.event.*;

public class MyCanvas extends Canvas {
    static {
        System.loadLibrary("myRenderingLib");
    }
    public native void paint(Graphics g);

    public static void main(String[] args) {
        Frame f = new Frame();
        f.setBounds(0, 0, 500, 110);
        f.add( new MyCanvas() );
        f.addWindowListener( new WindowAdapter() {
            public void windowClosing(WindowEvent ev) {
                System.exit(0);
            }
        } );
        f.show();
    }
}

Note that this class has a main method that can be used torun this code as an application for testing purposes.

The next step is to run the javah tool on the MyCanvas class file above to generate a C/C++ header file that describes the interface to the native paint method that Java expects to be used. javah is a standard tool included with the Java SDK.

The final step the most interesting one is to write the native rendering method, with an interface that conforms to the header file that javah generated, and build it as a standard shared library (called myRenderingLib in the above example) by linking it, for the Solaris operating environment, against the jre/lib/sparc/libjawt.so library. (For Microsoft Windows, link against the jre/bin/jawt.dll library.) This code will call back to the Java virtual machine to get the drawing surface information it needs to access the MyCanvas peer. Once this information is available, the code can draw directly to MyCanvas using standard drawing routines supplied by the underlying operating system.

Here is sample source code for a native paint method designed for use in a Solaris X11-based drawing environment and a Java VM where the AWT Native Interface is present:

#include "MyCanvas.h"
#include "jawt_md.h"

/*
 * Class:     MyCanvas
 * Method:    paint
 * Signature: (Ljava/awt/Graphics;)V
 */
JNIEXPORT void JNICALL Java_MyCanvas_paint
(JNIEnv* env, jobject canvas, jobject graphics)
{
    JAWT awt;
    JAWT_DrawingSurface* ds;
    JAWT_DrawingSurfaceInfo* dsi;
    JAWT_X11DrawingSurfaceInfo* dsi_x11;
    jboolean result;
    jint lock;
    GC gc;

    short       i;
    char        *testString = "^^^ rendered from native code ^^^";

    /* Get the AWT */
    awt.version = JAWT_VERSION_1_3;
    if (JAWT_GetAWT(env, &awt) == JNI_FALSE) {
        printf("AWT Not found\n");
        return;
    }

    /* Get the drawing surface */
    ds = awt.GetDrawingSurface(env, canvas);
    if (ds == NULL) {
        printf("NULL drawing surface\n");
        return;
    }

    /* Lock the drawing surface */
    lock = ds->Lock(ds);
    if((lock & JAWT_LOCK_ERROR) != 0) {
        printf("Error locking surface\n");
        awt.FreeDrawingSurface(ds);
        return;
    }

    /* Get the drawing surface info */
    dsi = ds->GetDrawingSurfaceInfo(ds);
    if (dsi == NULL) {
        printf("Error getting surface info\n");
        ds->Unlock(ds);
        awt.FreeDrawingSurface(ds);
        return;
    }

    /* Get the platform-specific drawing info */
    dsi_x11 = (JAWT_X11DrawingSurfaceInfo*)dsi->platformInfo;

    /* Now paint */
    gc = XCreateGC(dsi_x11->display, dsi_x11->drawable, 0, 0);
    XSetBackground(dsi_x11->display, gc, 0);
    for (i=0; i<36;i++)
    {
        XSetForeground(dsi_x11->display, gc, 10*i);
        XFillRectangle(dsi_x11->display, dsi_x11->drawable, gc,
                        10*i, 5, 90, 90);
    }
    XSetForeground(dsi_x11->display, gc, 155);
    XDrawImageString(dsi_x11->display, dsi_x11->drawable, gc,
                        100, 110, testString, strlen(testString));
    XFreeGC(dsi_x11->display, gc);

    /* Free the drawing surface info */
    ds->FreeDrawingSurfaceInfo(dsi);

    /* Unlock the drawing surface */
    ds->Unlock(ds);

    /* Free the drawing surface */
    awt.FreeDrawingSurface(ds);
}

The key data structure here is JAWT , which is defined in jawt.h (included by jawt_md.h) ; it provides access to all the information the native code needs to get the job done. The first part of the native method is boilerplate: it populates the JAWT structure, gets a JAWT_DrawingSurface structure, locks the surface (only one drawing engine at a time, please!), then gets a JAWT_DrawingSurfaceInfo structure that contains a pointer (in the platformInfo field) to the necessary platform-specific drawing information. It also includes the bounding rectangle of the drawing surface and the current clipping region.

The structure of the information pointed to by platformInfo is defined in a machine-dependent header file called jawt_md.h. For Solaris/X11 drawing, it includes information about the X11 display and X11 drawable associated with MyCanvas. After the drawing operations are completed, there is more boilerplate code as JAWT_DrawingSurfaceInfo is freed and JAWT_DrawingSurface is unlocked and freed.

The corresponding code for the Microsoft Windows platform would be structured similarly, but would include the version of jawt_md.h for Microsoft Windows and the structure located in the platformInfo field of drawing surface info would be cast as a JAWT_Win32DrawingSurfaceInfo* . And, of course, the actual drawing operations would need to be changed to those appropriate for the Microsoft Windows platform.

Summary

The ability to draw directly into a Java Canvas from a native code library is extremely useful for developers planning to migrate a legacy software system to Java, especially one that includes a high-performance rendering engine. It makes it much easier to migrate in stages, leaving performance-sensitive rendering code alone, while other less-sensitive portions of code are converted to Java. The result can be a modern Java-centric application, providing the benefit of portability and development efficiency, but one that does not sacrifice an investment in performance of a key piece of native code.

References

The definitive reference to the Java Native Interface is The Java Native Interface: Programmer's Guide and Specification by Sheng Liang. This book was published in June 1999 by Addison-Wesley. The ISBN is 0-201-32577-2.

Appendix

Header Files for jawt.h and jawt_md.h

jawt.h

#ifndef _JAVASOFT_JAWT_H_
#define _JAVASOFT_JAWT_H_

#include "jni.h"

#ifdef __cplusplus
extern "C" {
#endif

/*
 * AWT native interface
 *
 * The AWT native interface allows a native C or C++ application a means
 * by which to access native structures in AWT.  This is to facilitate moving
 * legacy C and C++ applications to Java and to target the needs of the
 * community who, at present, wish to do their own native rendering to canvases
 * for performance reasons.  Standard extensions such as Java3D also require a
 * means to access the underlying native data structures of AWT.
 *
 * There may be future extensions to this API depending on demand.
 *
 * A VM does not have to implement this API in order to pass the JCK.
 * It is recommended, however, that this API is implemented on VMs that support
 * standard extensions, such as Java3D.
 *
 * Since this is a native API, any program which uses it cannot be considered
 * 100% pure java.
 */

/*
 * AWT Native Drawing Surface (JAWT_DrawingSurface).
 *
 * For each platform, there is a native drawing surface structure.  This
 * platform-specific structure can be found in jawt_md.h.  It is recommended
 * that additional platforms follow the same model.  It is also recommended
 * that VMs on Microsoft Windows platforms and Solaris operating environment
 * support the existing structures in jawt_md.h.
 *
 *******************
 * EXAMPLE OF USAGE:
 *******************
 *
 * In Miscrosoft Windows, a programmer wishes to access the HWND of a canvas
 * to perform native rendering into it.  The programmer has declared the
 * paint() method for their canvas subclass to be native:
 *
 *
 * MyCanvas.java:
 *
 * import java.awt.*;
 *
 * public class MyCanvas extends Canvas {
 *
 *     static {
 *         System.loadLibrary("mylib");
 *     }
 *
 *     public native void paint(Graphics g);
 * }
 *
 *
 * myfile.c:
 *
 * #include "jawt_md.h"
 * #include <assert.h>
 *
 * JNIEXPORT void JNICALL
 * Java_MyCanvas_paint(JNIEnv* env, jobject canvas, jobject graphics)
 * {
 *     JAWT awt;
 *     JAWT_DrawingSurface* ds;
 *     JAWT_DrawingSurfaceInfo* dsi;
 *     JAWT_Win32DrawingSurfaceInfo* dsi_win;
 *     jboolean result;
 *     jint lock;
 *
 *     // Get the AWT
 *     awt.version = JAWT_VERSION_1_3;
 *     result = JAWT_GetAWT(env, &awt);
 *     assert(result != JNI_FALSE);
 *
 *     // Get the drawing surface
 *     ds = awt.GetDrawingSurface(env, canvas);
 *     assert(ds != NULL);
 *
 *     // Lock the drawing surface
 *     lock = ds->Lock(ds);
 *     assert((lock & JAWT_LOCK_ERROR) == 0);
 *
 *     // Get the drawing surface info
 *     dsi = ds->GetDrawingSurfaceInfo(ds);
 *
 *     // Get the platform-specific drawing info
 *     dsi_win = (JAWT_Win32DrawingSurfaceInfo*)dsi->platformInfo;
 *
 *     //////////////////////////////
 *     // !!! DO PAINTING HERE !!! //
 *     //////////////////////////////
 *
 *     // Free the drawing surface info
 *     ds->FreeDrawingSurfaceInfo(dsi);
 *
 *     // Unlock the drawing surface
 *     ds->Unlock(ds);
 *
 *     // Free the drawing surface
 *     awt.FreeDrawingSurface(ds);
 * }
 *
 */

/*
 * JAWT_Rectangle
 * Structure for a native rectangle.
 */
typedef struct jawt_Rectangle {
    jint x;
    jint y;
    jint width;
    jint height;
} JAWT_Rectangle;

struct jawt_DrawingSurface;

/*
 * JAWT_DrawingSurfaceInfo
 * Structure for containing the underlying drawing information of a component.
 */
typedef struct jawt_DrawingSurfaceInfo {
    /*
     * Pointer to the platform-specific information.  This can be safely
     * cast to a JAWT_Win32DrawingSurfaceInfo on Microsoft Windows or a
     * JAWT_X11DrawingSurfaceInfo on Solaris operating environment.
     * See jawt_md.h for details.
     */
    void* platformInfo;
    /* Cached pointer to the underlying drawing surface */
    struct jawt_DrawingSurface* ds;
    /* Bounding rectangle of the drawing surface */
    JAWT_Rectangle bounds;
    /* Number of rectangles in the clip */
    jint clipSize;
    /* Clip rectangle array */
    JAWT_Rectangle* clip;
} JAWT_DrawingSurfaceInfo;

#define JAWT_LOCK_ERROR                 0x00000001
#define JAWT_LOCK_CLIP_CHANGED          0x00000002
#define JAWT_LOCK_BOUNDS_CHANGED        0x00000004
#define JAWT_LOCK_SURFACE_CHANGED       0x00000008

/*
 * JAWT_DrawingSurface
 * Structure for containing the underlying drawing information of a component.
 * All operations on a JAWT_DrawingSurface MUST be performed from the same
 * thread as the call to GetDrawingSurface.
 */
typedef struct jawt_DrawingSurface {
    /* Cached reference to the Java environment of the calling thread */
    JNIEnv* env;
    /* Cached reference to the target object */
    jobject target;
    /*
     * Lock the surface of the target component for native rendering.
     * When finished drawing, the surface must be unlocked with
     * Unlock().  This function returns a bitmask with one or more of the
     * following values:
     *
     * JAWT_LOCK_ERROR - When an error has occurred and the surface could not
     * be locked.
     *
     * JAWT_LOCK_CLIP_CHANGED - When the clip region has changed.
     *
     * JAWT_LOCK_BOUNDS_CHANGED - When the bounds of the surface have changed.
     *
     * JAWT_LOCK_SURFACE_CHANGED - When the surface itself has changed
     */
    jint (JNICALL *Lock)
        (struct jawt_DrawingSurface* ds);
    /*
     * Get the drawing surface info.
     * The value returned may be cached, but the values may change if
     * additional calls to Lock() or Unlock() are made.
     * Lock() must be called before this can return a valid value.
     * Returns NULL if an error has occurred.
     * When finished with the returned value, FreeDrawingSurfaceInfo must be
     * called.
     */
    JAWT_DrawingSurfaceInfo* (JNICALL *GetDrawingSurfaceInfo)
        (struct jawt_DrawingSurface* ds);
    /*
     * Free the drawing surface info.
     */
    void (JNICALL *FreeDrawingSurfaceInfo)
        (JAWT_DrawingSurfaceInfo* dsi);
    /*
     * Unlock the drawing surface of the target component for native rendering.
     */
    void (JNICALL *Unlock)
        (struct jawt_DrawingSurface* ds);
} JAWT_DrawingSurface;

/*
 * JAWT
 * Structure for containing native AWT functions.
 */
typedef struct jawt {
    /*
     * Version of this structure.  This must always be set before
     * calling JAWT_GetAWT()
     */
    jint version;
    /*
     * Return a drawing surface from a target jobject.  This value
     * may be cached.
     * Returns NULL if an error has occurred.
     * Target must be a java.awt.Canvas.
     * FreeDrawingSurface() must be called when finished with the
     * returned JAWT_DrawingSurface.
     */
    JAWT_DrawingSurface* (JNICALL *GetDrawingSurface)
        (JNIEnv* env, jobject target);
    /*
     * Free the drawing surface allocated in GetDrawingSurface.
     */
    void (JNICALL *FreeDrawingSurface)
        (JAWT_DrawingSurface* ds);
} JAWT;

/*
 * Get the AWT native structure.  This function returns JNI_FALSE if
 * an error occurs.
 */
_JNI_IMPORT_OR_EXPORT_
jboolean JNICALL JAWT_GetAWT(JNIEnv* env, JAWT* awt);

#define JAWT_VERSION_1_3 0x00010003

#ifdef __cplusplus
} /* extern "C" */
#endif

#endif /* !_JAVASOFT_JAWT_H_ */

jawt_md.h (Solaris/X11 operating environment version)

#ifndef _JAVASOFT_JAWT_MD_H_
#define _JAVASOFT_JAWT_MD_H_

#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include <X11/Intrinsic.h>
#include "jawt.h"

#ifdef __cplusplus
extern "C" {
#endif

/*
 * X11-specific declarations for AWT native interface.
 * See notes in jawt.h for an example of use.
 */
typedef struct jawt_X11DrawingSurfaceInfo {
    Drawable drawable;
    Display* display;
    VisualID visualID;
    Colormap colormapID;
    int depth;
} JAWT_X11DrawingSurfaceInfo;

#ifdef __cplusplus
}
#endif

#endif /* !_JAVASOFT_JAWT_MD_H_ */

jawt_md.h (Microsoft Windows version)

#ifndef _JAVASOFT_JAWT_MD_H_
#define _JAVASOFT_JAWT_MD_H_

#include <windows.h>
#include "jawt.h"

#ifdef __cplusplus
extern "C" {
#endif

/*
 * Microsoft Windows specific declarations for AWT native interface.
 * See notes in jawt.h for an example of use.
 */
typedef struct jawt_Win32DrawingSurfaceInfo {
    /* Native window, DDB, or DIB handle */
    union {
        HWND hwnd;
        HBITMAP hbitmap;
        void* pbits;
    };
    /*
     * This HDC should always be used instead of the HDC returned from
     * BeginPaint() or any calls to GetDC().
     */
    HDC hdc;
    HPALETTE hpalette;
} JAWT_Win32DrawingSurfaceInfo;

#ifdef __cplusplus
}
#endif

#endif /* !_JAVASOFT_JAWT_MD_H_ */
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


AWT Enhancements

Documentation Contents

AWT Enhancements in the Java SE 1.4

1.4.2 Bug Fixes
1.4.1 Bug Fixes
New Focus Subsystem
Deprecated Focus Methods
ActionEvents (and Other Events) Need Timestamps
Headless Support
Window Centering API Required for Multiscreen Support
The New Fullscreen Exclusive Mode API
Sync Out of Range Error From Video Driver Under Windows NT Undecorated Frames
Mouse Wheel Support
Programmatic Zooming of Frames
Dynamic Layout During Resize
Access to Component Listener Lists
Changes to Drag and Drop
64-Bit Compliance on Solaris
Inconsistent DLLs Warning
Removal of the DrawingSurface API
New InputEvent Key Modifiers
Change in Drop Down Behavior for Choice Menus
Choice Component Now Obeys Layout Manager Constraints

1.4.2 Bug Fixes

4648702: On Microsoft Windows 2000 and Windows XP, a TextArea will sometimes display only a vertical scrollbar, even though the SCROLLBARS_BOTH field is set to true.

4636311: Modal dialogs may hang when run from a Runnable on release 1.3.1 and 1.4.

4385243: Unable to input text in Microsoft Windows locales that don't have an ANSI code page (such as Hindi).

1.4.1 Bug Fixes

4690831: Game applets fail to repaint properly with Internet Explorer.

4627627: Focus traversal keys moved from awt.properties to Preferences API.

4636548/ 4639735: Crash of release 1.4 when screensaver on Microsoft Windows 2000 is activated.

4379138: Problems on Linux with key events for some dead keys.

4627542: Swing applications don't support international keyboards under Linux.

4395157: Under Linux on 1.3, can't type "%" in applets.

4669873: A drag and drop bug, reported on hopper-beta under Microsoft Windows, caused an application to briefly freeze during DnD and is fixed in the final release of 1.4.1.

New Focus Subsystem

The bugtraq report that corresponds to this change is: 4290675.

A new focus subsystem replaces the previous focus architecture and addresses many focus-related bugs caused by platform inconsistencies, and incompatibilities between AWT and Swing components. See the new Focus Model Specification for further details.

See the javadoc here.

Headless Support

The bugtraq report that corresponds to this change is: 4281163.

Many environments, such as mainframe machines and dedicated servers, do not support a display, keyboard, or mouse. Headless support is enabled by the new GraphicsEnvironment methods isHeadless and isHeadlessInstance. These methods indicate whether a display, keyboard, and mouse can be supported in a graphics environment.

The API changes for headless include:

  • A new public exception class, java.awt.HeadlessException, is introduced. It is derived from UnsupportedOperationException, which derives from RuntimeException, so that existing implementations of methods that throw the new exception will not require signature changes.
  • Two new methods, are added to java.awt.GraphicsEnvironment.
        public static boolean isHeadless()

    public boolean isHeadlessInstance()
  • The constructors of Applet and all heavyweight components (*) are changed to throw HeadlessException if a display, keyboard, and mouse are not supported by the toolkit implementation. All javadoc tags on all constructors are changed to reflect this RuntimeException.
  • The Robot constructor throws an AWTException if a display, keyboard, and mouse are not supported by the toolkit implementation.
  • Many of the methods in Toolkit and GraphicsEnvironment, with the exception of fonts, imaging, and printing, are changed to throw HeadlessException if a display, keyboard, and mouse are not supported. All the javadoc tags on these methods are changed to reflect this RuntimeException.
  • Other methods that may be affected by lack of display, keyboard, or mouse support, are changed to throw HeadlessException.
  • It should be worth noting that the HeadlessException is thrown if and only if isHeadless returns true, and that all javadoc comments should specify this.

(*)Applet, Button, Checkbox, Choice, FileDialog, Label, List, Menu, MenuBar, MenuComponent, MenuItem, PopupMenu, Scrollbar, ScrollPane, TextArea, TextComponent, Frame, Window, Dialog, JApplet, JFrame, JWindow, JDialog, and TextField. Canvas and Panel do not need to throw this exception since these can be given empty peers and treated as lightweights.

To run our environment with a headless implementation, the follow property may be specified at the java command line:

  -Djava.awt.headless=true
If this property is not specified and a display, keyboard, and mouse are not supported, then headless implementation is used by default.

Source code should check for headless, so that the exception may be caught gracefully. For example, see the following pre-headless implementation of the class Foo:

class Foo {
  static Choice c = new Choice();  // could throw HeadlessException
}
The new and improved implementation of Foo should be placed in a static block:
class Foo {
  static Choice c;
  static {
    try {
      c = new Choice();
    catch (HeadlessException e) {
        ...
    }
  }
}

The New Fullscreen Exclusive Mode API

The bugtraq report that corresponds to this change is: 4189326.

The new full-screen exclusive mode API supports high performance graphics by suspending the windowing system so that drawing can be done directly to the screen. Full screen mode, which is entirely different from simply taking an AWT Frame, Window, or Dialog and expanding it to fit the screen, is a graphics mode whereby the application takes entire control over the contents of video memory. The application tells the graphics card what to draw, how to draw it, and when to draw it. This mode is not always available. On some operating systems, it may not be implemented at all. On other operating systems, it may only be available if the capability is supported by the graphics card. Nevertheless, this mode is critical for performance and is necessary for enabling hardware page-flipping on Windows.

For a tutorial explaining how to use the full screen exclusive API mode with several code examples, see here.

API Changes:

  • A new public final class, java.awt.DisplayMode, is introduced.
  • Changes to java.awt.GraphicsDevice:
        public void setFullScreenWindow(Window w)

    public Window getFullScreenWindow()

    public boolean isDisplayChangeSupported()

    public void setDisplayMode(DisplayMode dm)

    public DisplayMode getDisplayMode()

    public DisplayMode[] getDisplayModes()
  • The algorithm which handles direct video buffer control has been localized to a new class, java.awt.image.BufferStrategy.
  • A new class java.awt.BufferCapabilities can be used when creating a buffer strategy. Likewise, a new class java.awt.ImageCapabilities is available to define the image capabilities of a specific configuration.
  • An application programmer can create and use a buffer strategy from a Canvas or a Window. There are two buffer strategies that are supported as protected inner classes: java.awt.Component.FlipBufferStrategy and java.awt.Component.BltBufferStrategy. One of these two inner classes is used on the Canvas or Window when the createBufferStrategy method is called, depending on the BufferCapabilities object supplied when creating the strategy (if any). To get the buffer strategy used by a particular component, the getBufferStrategy method is used.
Sync Out of Range Error From Video Driver Under Windows NT

The bugtraq report that corresponds to this change is: 4452207.

If you have a Dell Optiplex GX110 using an Intel 810 Graphics Controller, under Windows NT, you may get a "sync out of range" message from the video driver if you change the display mode more than once and use a high display resolution. There is evidently a bug in the (DirectX) video driver that is causing this. There are several workarounds to this problem:

  • Disable DirectDraw by using -Dsun.java2d.noddraw=true at the command line.
  • Do not change the display resolution more than once during the lifetime of a program that is intended to run on this hardware.
  • Disallow the following display modes on this hardware:
        1152 X 864     8       85
    1152 X 864     16      85
    1152 X 864     24      85

    1280 X 1024    8       70,72,75,85
    1280 X 1024    16      70,72,75,85
    1280 X 1024    24      70,75,85

    Bad Color (Unsatisfactory appearance in terms of color)

    1024 X 768     8       60,70,72,75,85

Undecorated Frames

The bugtraq report that corresponds to this change is: 4038769.

For certain applications having no native frame decorations makes sense. For example, applications that will run across many platforms and that require that the look and feel is the same, or when the programmer does not want the end-user coming in contact with the native operating system.

This release allows a Java application to turn off the creation of frame decorations; no native titlebar, system menu, border, or other native operating system dependent screen components appear when this mode is enabled. AWT and Swing components work transparently.

Changes to java.awt.Frame:

    public void setUndecorated(boolean undecorated)

    public boolean isUndecorated()

Changes to java.awt.Dialog:

    public void setUndecorated(boolean undecorated)

    public boolean isUndecorated()

Mouse Wheel Support

The bugtraq report that corresponds to this change is: 4289845.

The mouse wheel, with a scroll wheel in place of the middle mouse button, is enabled with new built-in Java support for scrolling via the mouse wheel. The java.awt.event.MouseWheelEvent class enables seamless support for mouse wheel scrolling in Java applications with no recompiling required. Also, a new java.awt.event.MouseWheelListener interface allows customization of mouse wheel behavior.

Note, for those using the mouse wheel on Linux, see here.

  • Scrolling Behavior:
    • A scrollbar is considered "scrollable" if it is both showing and there is more content in the scrolling Component than can be displayed at once, such that the scroll thumb does not occupy the entire scroll track.
    • It is possible for a scrollbar to be showing, but not be scrollable. Usually this occurs when a scrollbar is set to always be displayed.
    • The scrollbar to be scrolled by the mouse wheel is determined as follows:
      • If only one scrollbar is scrollable, it will be scrolled.
      • If both a horizontal and a vertical scrollbar are scrollable, the vertical scrollbar will be scrolled.
    • Wheel scrolling may be disabled altogether using setWheelScrollEnabled(false).
    • Up/away-from-user rotations cause vertical scroll bars to scroll upwards, and horizontal scrollbars to scroll to the left. Just the opposite is true for down/towards rotations.
    • No scrolling takes place if a scroll thumb is at the end of the scroll track.
  • Heavyweight support:
    • Some native peers with integrated scroll bars can handle mouse wheel scrolling by themselves. Examples on Windows includes TextArea, Choice, FileDialog, and List. Such components will let their native peers handle wheel scrolling.
    • Components which do not inherit any native mouse wheel behavior will propagate mouse wheel events up the Container hierarchy until a Container with MouseWheelEvents enabled is found. This is typically a ScrollPane. Mouse wheel events are delivered to the Component with MouseWheelEvents enabled.
    • Alternatively, client programmers may add MouseWheelListeners to customize what happens when the mouse wheel is moved while the mouse is over a Component. In the case of Components that already have native handling of mouse wheel events, clients may consume the mouse wheel event to avoid native handling.
    • java.awt.ScrollPane is modified to have MouseWheelEvents enabled by default. When a ScrollPane receives a MouseWheelEvent, it will properly scroll its contained Component. This functionality may be disabled with the new setWheelScrollingEnabled method.

  • Lightweight Support:

    • Lightweight components will deliver mouse wheel events to their first ancestor with a MouseWheelListener.
    • MouseWheelListeners may be added to any JComponent for custom event handling.
    • javax.swing.JScrollPane is modified to properly scroll its viewed component. Like java.awt.ScrollPane, this may be disabled using setWheelScrollingEnabled.
  • New API:

    In addition to the new class and new interface previously mentioned, there are some other changes to the API to support the mouse wheel.

    • Change to java.awt.AWTEvent:
          public final static long MOUSE_WHEEL_EVENT_MASK;
    • Changes to java.awt.AWTEventMulticaster:
          public void mouseWheelMoved(MouseWheelEvent e)

    public static MouseWheelListener add(MouseWheelListener a, MouseWheelListener b)

    public static MouseWheelListener remove(MouseWheelListener l, MouseWheelListener oldl)
    • Changes to java.awt.Component:
          public synchronized void addMouseWheelListener(MouseWheelListener l)

    public synchronized void removeMouseWheelListener(MouseWheelListener l)
    • Changes to java.awt.ScrollPane:
          public void setWheelScrollingEnabled(boolean handleWheel)

    public boolean isWheelScrollingEnabled()
    • Change to java.awt.Robot:
          public synchronized void mouseWheel(int wheelAmt)
  • Linux Mouse Wheel Support:

    For Linux to recognize your mouse wheel, two modifications to the /etc/X11/XF86Config file are required. Under the "Pointer" section:

    • Add the line:

          ZAxisMapping 4 5

    • Change the protocol to: "imps/2" (this will vary depending on your particular wheel mouse).

Programmatic Zooming of Frames

The bugtraq report that corresponds to this change is: 4071554.

Previously there was no way to zoom (or maximize) a Frame programmatically. This feature has been added to this release.

The new interface java.awt.event.WindowStateListener is introduced.

Changes to java.awt.Frame:

    public static final int MAXIMIZED_HORIZ;

    public static final int MAXIMIZED_VERT;

    public static final int MAXIMIZED_BOTH;

    public synchronized void setMaximizedBounds(Rectangle bounds)

    public Rectangle getMaximizedBounds()

    public synchronized void setExtendedState(int state)

    public synchronized int getExtendedState()

Changes to java.awt.event.WindowEvent:

    public static final int WINDOW_STATE_CHANGED;

    public WindowEvent(Window source, int id, Window opposite, int oldState, int newState)

    public WindowEvent(Window source, int id, int oldState, int newState)

    public int getOldState()

    public int getNewState()

Changes to java.awt.AWTEvent:

    public final static long WINDOW_STATE_EVENT_MASK;

Changes to java.awt.Toolkit:

    public boolean isFrameStateSupported(int state) throws HeadlessException

Changes to java.awt.Window:

    public synchronized void addWindowStateListener(WindowStateListener l)

    public synchronized void removeWindowStateListener(WindowStateListener l)

    public synchronized WindowStateListener[] getWindowStateListeners()

    protected void processWindowStateEvent(WindowEvent e)

Change to java.awt.event.WindowAdapter:

    public void windowStateChanged(WindowEvent e)

Changes to java.awt.AWTEventMulticaster:

    public static WindowStateListener add(WindowStateListener a, WindowStateListener b)

    public static WindowStateListener remove(WindowStateListener l, WindowStateListener oldl)

Dynamic Layout During Resize

The bugtraq report that corresponds to this change is: 4077991.

Previously, dynamic window resizing wasn't supported on all platforms. For example, on Windows NT, with solid resize on, resizing a window recalculated the layout only when the drag was finished. This has been fixed in this release with the addition of the new desktop property awt.dynamicLayoutSupported. When dynamic layout is enabled, a Container continually lays out its components as it resizes. If disabled, the layout will be validated after resizing has finished.

API changes to java.awt.Toolkit.

    public void setDynamicLayout(boolean dynamic)

    protected boolean isDynamicLayoutSet()

    public boolean isDynamicLayoutActive()

Access to Component Listener Lists

The bugtraq report that corresponds to this change is: 4290704.

Previously all of the state in an AWT component that could be written could also be read. For example, there are no write-only properties in the component API. Event listeners were a notable exception. AWT event listeners are managed according to the JavaBeans conventions with a pair of methods: addXXXListener and removeXXXListener for a listener that implements the XXXEventListener interface.

No access was provided to the listener lists themselves. The fields that contain the listener lists are package private and no method was provided that returns the contents of a listener list. This has caused some problems for Swing and other AWT clients.

To mitigate the problem in the Java 2 SDK, v1.3 release, we added a getListeners method to Component and to the Swing classes that defined listener lists. The getListeners method uses a class to specify a particular listener list. For example to get all of the listeners added with addFocusListener, one would write: getListeners(FocusListener.class).

This particular approach to exposing listener lists was taken to minimize the overall change to the AWT/Swing public API. It was not intended to be a convention for all JavaBeans and it did not handle PropertyChangeListeners - which can be added to a single property, as in addPropertyChangeListener("myProperty", myListener). For this release, we have designed a more complete solution to accessing event listeners. The two conceptual changes are:

  • The addition of a getFooListeners method to the add/remove convention in AWT and Swing classes.
  • Support for PropertyChangeListeners and VetoableChangeListeners, including those which listen to a single property, using the new java.util.EventListenerProxy class.

There is a new java.awt.event.AWTEventListenerProxy class.

API Changes to java.awt.Toolkit:

    public PropertyChangeListener[] getPropertyChangeListeners()

    public synchronized PropertyChangeListener[] getPropertyChangeListeners(String propertyName)

    public AWTEventListener[] getAWTEventListeners()

    public AWTEventListener[] getAWTEventListeners(long eventMask)

Changes to Drag and Drop

The bugtraq reports that corresponds to this change are: 4407057 and 4426750.

In the Solaris and Linux releases of Java 2 Standard Edition, SDK 1.3, several of the AWT heavyweight Components exhibited default drag behavior via the middle mouse button, even if the application did not identify these Components as DragSources via the java.awt.dnd API. These Components were implemented using Motif peers, and Motif provides middle button drag behavior for these peers by default.

Because of the design of the AWT, and because of bugs in the Motif library, this default behavior has been the source of numerous stability problems. Rather than continue to risk the stability of AWT and Drag & Drop for a niche feature, we have chosen to disable this feature explicitly in our implementations.

Developers can still identify these Components as DragSources in their applications using the java.awt.dnd API. This is both functional and supported. This approach is superior to relying upon default Motif behavior in any case, because it enables drag support for these Components on all platforms, not just Solaris and Linux.

64-Bit Compliance on Solaris Machines

The bugtraq report that corresponds to this change is: 4295833.

64-bit Solaris applications use 64 bits to address memory instead of 32. This allows larger applications by providing a much larger virtual memory space. For this release, AWT has been brought up to 64-bit compliance. For more information, see here.

Inconsistent DLLs Warning

The bugtraq report that corresponds to this change is: 4414004.

If you have installed English VC++ 6.0 onto a machine that also has Asian Windows NT installed, you may encounter strange artifacts when rendering Asian text in the TextArea component. You may also see this problem if you have installed Microsoft Exchange or Microsoft Office 97 onto a machine running Asian Windows NT 4.0. Although this problem was reported on the Japanese version of Windows NT, it will probably occur on other non-Latin versions of NT as well, such as Chinese or Korean.

The problem was caused when the installation of those programs replaced the Asian Riched32.dll with the English version. The problem can be corrected by replacing Riched32.dll with the Asian version.

Removal of the Drawing Surface API

The bugtraq report that corresponds to this change is: 4293646.

The sun.awt.DrawingSurface API has been removed. It was never made public, but some developers have been using it. The functionality has been replaced by the JAWT. For more information, see the AWT Native Interface description.

Window Centering API Required for Multiscreen Support

The bugtraq report that corresponds to this change is: 4463949.

Xinerama-aware applications running on multi-headed systems have caused problems which have resulted in a variety of bug reports. Some multi-headed environments use monitors with little or no borders, which can be butted up against one another such that the resulting effect is one mammoth display. In this case, a "properly" centered window may span multiple screens. Other multi-headed environments use regular CRT monitors, with several inches of packaging between the actual display areas. In this case, a window spanning multiple screens produces a disconcerting effect, especially if the window cannot be dragged onto one monitor or the other (the Solaris login screen, for example). In short there was no way to tell where to center a window in a Xinerama environment.

To address this problem, the X group has added API which allows Xinerama users to specify where they want "centered" windows to be centered, and allows developers of Xinerama-aware applications to code accordingly.

Prior to this release, the way to center a window has been to center it within the bounds of the default GraphicsDevice, like this:

    bounds = getDefaultScreenDevice().getDefaultConfiguration().getBounds();
    frame.setLocation(bounds / 2 - size of window / 2);
This code would center the windows "correctly" on Xinerama systems where windows should be centered to the entire Xinerama coordinate space.

As of this release, post 4356756-fix JDKs will center windows "correctly" on Xinerama systems where windows should be centered within the first display.

To accomplish this, the getCenterPoint method has been added to GraphicsEnvironment .

This method works as follows on various platforms:

  • Microsoft Windows/Macintosh:
    These platforms include all monitors in a single virtual coordinate space. However, there is one "primary" display (on Microsoft Windows the primary display contains the task bar, on the Mac, the menubar). Here, getCenterPoint returns the coordinates of the center of the primary display.
  • X-Window, non-Xinerama
    Each display has its own coordinate system; the upper-left corner of every display is 0.0. Again, there is a "first" display. Here, getCenterPoint returns the center point of the primary display.
  • X-Window, Xinerama
    All monitors share a single virtual coordinate space, as on Microsoft Windows. However, it is possible for the user to specify through X resources where windows should be centered. If these resources are set, getCenterPoint reflects their value. Otherwise, it returns the point at the center of the virtual coordinate space. (In practice, this will almost always be set - CDE sets it by default.)

As of JDK 1.4, the correct code for centering is:

    frame.setLocation(getCenterPoint() - size of window / 2);

The other method added to GraphicsEnvironment is getMaximumWindowBounds. Both getCenterPoint and getMaximumWindowBounds throw a HeadlessException when in Headless mode.

New InputEvent Key Modifiers

The bugtraq reports that corresponds to this change are: 4387938 and 4421515.

Previously, the InputEvent modifiers had the same values for keyboard and mouse buttons. In certain situations there was no way to distinguish which one was pressed or when more than one was held simultaneously. These situations included cases when more than one mouse button was down at the same time, or when a modifier key was used to modify a mouse event.

To address this deficiency, the following constants were added to InputEvent:

  • SHIFT_DOWN_MASK
  • CTRL_DOWN_MASK
  • META_DOWN_MASK
  • ALT_DOWN_MASK
  • ALT_GRAPH_DOWN_MASK
  • BUTTON1_DOWN_MASK
  • BUTTON2_DOWN_MASK
  • BUTTON3_DOWN_MASK

The following methods were added to InputEvent:

  • getModifiersEx
  • getModifiersExText

The class spec for MouseEvent was updated. The following constants were also added to MouseEvent:

  • NOBUTTON
  • BUTTON1
  • BUTTON2
  • BUTTON3

These methods in MouseEvent were added:

  • MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int button)
  • getButton
  • getMouseModifiersText

DragSourceDragEvent has the new method getGestureModifiersEx.

Change in Drop Down Behavior for Choice Menus

The bugtraq report that corresponds to this change is: 4462677.

The Choice drop down menu behavior has changed from JDK 1.3.1 to 1.4. In 1.3.1, you could click anywhere on the choice bar and the menu would drop down. In 1.4, you must click on the arrow selector on the right hand side of the Choice bar. Clicking anywhere else on the Choice bar has no effect. Also, the symbol on the Choice bar has changed from a bar to an arrow/bar combination. Finally, if the drop down menu extends outside of the parent, when clicking on that area, the application underneath is brought to the foreground. This happens on Solaris, not Windows.

Choice Component Now Obeys Layout Manager Constraints

The bugtraq report that corresponds to this change is: 4288285.

In releases prior to 1.4, the AWT Choice widget sometimes ignored the size that the layout manager told it to be. As of this release, it now obeys the layout manager constraints.

Deprecated Focus Methods

The bugtraq report that corresponds to this change is: 4476300.

The new focus subsystem, introduced in this release, introduced a new architecture and a new terminology for handling keyboard focus in sophisticated AWT and Swing applications. Prior to this project, many of the focus-related APIs were inconsistent in usage and termonology, were improperly documented, and led to poorly designed UIs. Now that the new architecture is in place, the most egregious of these APIs has been deprecated.

The following constants and methods have been deprecated:

  • javax.swing.FocusManager.FOCUS_MANAGER_CLASS_PROPERTY
  • javax.swing.FocusManager.disableSwingFocusManager()
  • javax.swing.FocusManager.isFocusManagerEnabled()
  • javax.swing.JComponent.requestDefaultFocus()
  • javax.swing.JComponent.isManagingFocus()
  • javax.swing.JComponent.setNextFocusableComponent(Component)
  • javax.swing.JComponent.getNextFocusableComponent()
  • java.awt.Component.isFocusTraversable()
  • java.awt.Component.hasFocus()
  • javax.swing.SwingUtilities.findFocusOwner(Component)
ActionEvents (and Other Events) Need Timestamps

The bugtraq report that corresponds to this change is: 4434193.

The new focus architecture includes a type-ahead mechanism that ensures that subsequent KeyEvents that follow a KeyEvent that initiates a focus transfer are not delivered until the transfer is completed. The design for this feature is based on the UTC timestamps of the various events. Events with timestamps later than that of the initiating event are enqueued pending resolution of the transfer; events with earlier timestamps are not.

To implement this feature, the focus code keeps track of the timestamp of the event currently being handled. If a focus change is initiated during this handling, the timestamp is available for use. However, if the current event does not have a timestamp, then the current system time is used. This time is usually too far ahead of the time that the event actually occurred to be of any real use. As a result, the type-ahead mechanism fails, and KeyEvents are delivered before the focus transfer is completed.

The most common case where we encountered this problem was with ActionEvents. ActionEvents are high-level, semantic events generated in response to underlying InputEvents. While the InputEvents had timestamps associated with them, the ActionEvents did not. The ActionEvent API has therefore been expanded to accomodate a timestamp and the implementation has been updated so that an ActionEvent's timestamp is equal to that of its underlying InputEvent.

The following methods have been added to ActionEvent:

  • ActionEvent(Object source, int id, String command, long when, int modifiers)
  • getWhen

The following ActionEvent methods were modified:

  • ActionEvent(Object source, int id, String command)
  • ActionEvent(Object source, int id, String command, int modifiers)

The getWhen method was added to InvocationEvent.

The InvocationEvent constructors InvocationEvent(Object, Runnable) and InvocationEvent(Object, Runnable, Object, boolean) were modified.

A new constructor InputMethodEvent(Component, int, long, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) was added to InputMethodEvent, as well as the getWhen method.

The following InputMethodEvent constructors have been modified:

  • InputMethodEvent(Component, int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo)
  • InputMethodEvent(Component, int, TextHitInfo, TextHitInfo).

Finally, the following methods were added to EventQueue:

  • getMostRecentEventTime
  • getCurrentEvent
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.net.httpserver.BasicAuthenticator (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.BasicAuthenticator

No usage of com.sun.net.httpserver.BasicAuthenticator
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Use of Java GSS-API for Secure Message Exchanges Without JAAS Programming

This tutorial presents two sample applications demonstrating the use of the Java GSS-API for secure exchanges of messages between communicating applications, in this case a client application and a server application.

Java GSS-API uses what is called a "security mechanism" to provide these services. The GSS-API implementation contains support for the Kerberos V5 mechanism in addition to any other vendor-specific choices. The Kerberos V5 mechanism is used for this tutorial.

In order to perform authentication between the client and server and to establish cryptographic keys for secure communication, a GSS-API mechanism needs access to certain credentials for the local entity on each side of the connection. In our case, the credential used on the client side consists of a Kerberos ticket, and on the server side, it consists of a long-term Kerberos secret key. Kerberos tickets can optionally include the host address and IPv4 and IPv6 host addresses are both supported. Java GSS-API requires that the mechanism obtain these credentials from the Subject associated with the thread's access control context.

To populate a Subject with such credentials, client and server applications typically will first perform JAAS authentication using a Kerberos module. The JAAS Authentication tutorial demonstrates how to do this. The JAAS Authorization tutorial then demonstrates how to associate the authenticated Subject with the thread's access control context. A utility has also been written as a convenience to automatically perform those operations on your behalf. The Use of JAAS Login Utility tutorial demonstrates how to use the Login utility.

For this tutorial, we will not have the client and server perform JAAS authentication, nor will we have them use the Login utility. Instead, we will rely on setting the system property javax.security.auth.useSubjectCredsOnly to false, which allows us to relax the restriction of requiring a GSS mechanism to obtain necessary credentials from an existing Subject, set up by JAAS. See The useSubjectCredsOnly System Property.

Note: This is a simplified introductory tutorial. For example, we do not include any policy files or run the sample code using a security manager. In real life, code using Java GSS-API should be run with a security manager, so that security-sensitive operations would not be allowed unless the required permissions were explicitly granted.

There is another tutorial, Use of JAAS Login Utility and Java GSS-API for Secure Message Exchanges, that is just like the tutorial you are reading except that it utilizes the Login utility, policy files, and a more complex login configuration file (A login configuration file, required whenever JAAS authentication is done, specifies the desired authentication module).

As with all tutorials in this series, the underlying technology used to support authentication and secure communication for the applications in this tutorial is Kerberos V5. See Kerberos Requirements.

  • Overview of the Client And Server Applications
  • The SampleClient and SampleServer Code
  • Kerberos User and Service Principal Names
  • The Login Configuration File
  • The useSubjectCredsOnly System Property
  • Running the SampleClient and SampleServer Programs

If you want to first see the tutorial code in action, you can skip directly to Running the SampleClient and SampleServer Programs and then go back to the other sections to learn more.

Overview of the Client And Server Applications

The applications for this tutorial are named SampleClient and SampleServer.

Here is a summary of execution of the SampleClient and SampleServer applications:

  1. Run the SampleServer application. SampleServer
    1. Reads its argument, the port number that it should listen on for client connections.
    2. Creates a ServerSocket for listening for client connections on that port.
    3. Listens for a connection.
  2. Run the SampleClient application (possibly on a different machine). SampleClient
    1. Reads its arguments: (1) The name of the Kerberos principal that represents SampleServer. (See Kerberos User and Service Principal Names.), (2) the name of the host (machine) on which SampleServer is running, and (3) the port number on which SampleServer listens for client connections.
    2. Attempts a socket connection with the SampleServer, using the host and port it was passed as arguments.
  3. The socket connection is accepted by SampleServer and both applications initialize a DataInputStream and a DataOutputStream from the socket input and output streams, to be used for future data exchanges.
  4. SampleClient and SampleServer each instantiate a GSSContext and follow a protocol for establishing a shared context that will enable subsequent secure data exchanges.
  5. SampleClient and SampleServer can now securely exchange messages.
  6. When SampleClient and SampleServer are done exchanging messages, they perform clean-up operations.

The actual code and further details are presented in the following sections.

The SampleClient and SampleServer Code

The entire code for both the SampleClient and SampleServer programs resides in their main methods and can be broken down into the following subparts:

  1. Obtain the Command-Line Arguments
  2. Establish a Socket Connection for Transfers Between SampleClient and SampleServer
  3. Establish a Security Context
  4. Securely Exchange Messages
  5. Clean Up

Note: The Java GSS-API classes utilized by these programs (GSSManager, GSSContext, GSSName, GSSCredential, MessageProp, and Oid) are found in the org.ietf.jgss package.

Obtaining the Command-Line Arguments

The first thing both our client and server main methods do is read the command-line arguments.

Arguments Read By SampleClient

SampleClient expects three arguments:

  1. A service principal name -- The name of the Kerberos principal that represents SampleServer. (See Kerberos User and Service Principal Names.)
  2. A host name -- The machine on which SampleServer is running.
  3. A port number -- The port number of the port on which SampleServer listens for connections.

Here is the code for reading the command-line arguments:

if (args.length < 3) {
    System.out.println("Usage: java <options> Login SampleClient "
       + " <servicePrincipal> <hostName> <port>");
    System.exit(-1);
}

String server = args[0];
String hostName = args[1];
int port = Integer.parseInt(args[2]);

Argument Read By SampleServer

SampleServer expects just one argument:

  • A local port number -- The port number used by SampleServer for listening for connections with clients. This number should be the same as the port number specified when running the SampleClient program.

Here is the code for reading the command-line argument:

if (args.length != 1) {
    System.out.println(
        "Usage: java <options> Login SampleServer <localPort>");
    System.exit(-1);
}

int localPort = Integer.parseInt(args[0]);

Establishing a Socket Connection for Message Exchanges

Java GSS-API provides methods for creating and interpreting tokens (opaque byte data). The tokens contain messages to be securely exchanged between two peers, but the method of actual token transfer is up to the peers. For our SampleClient and SampleServer applications, we establish a socket connection between the client and server and exchange data using the socket input and output streams.

SampleClient Code For Socket Connection

SampleClient was passed as arguments the name of the host machine SampleServer is running on, as well as the port number on which SampleServer will be listening for connections, so SampleClient has all it needs to establish a socket connection with SampleServer. It uses the following code to set up the connection and initialize a DataInputStream and a DataOutputStream for future data exchanges:

Socket socket = new Socket(hostName, port);

DataInputStream inStream =
  new DataInputStream(socket.getInputStream());
DataOutputStream outStream =
  new DataOutputStream(socket.getOutputStream());

System.out.println("Connected to server "
   + socket.getInetAddress());

SampleServer Code For Socket Connection

The SampleServer application was passed as an argument the port number to be used for listening for connections from clients. It creates a ServerSocket for listening on that port:

ServerSocket ss = new ServerSocket(localPort);

The ServerSocket can then wait for and accept a connection from a client, and then initialize a DataInputStream and a DataOutputStream for future data exchanges with the client :

Socket socket = ss.accept();

DataInputStream inStream =
    new DataInputStream(socket.getInputStream());
DataOutputStream outStream =
    new DataOutputStream(socket.getOutputStream());

System.out.println("Got connection from client "
    + socket.getInetAddress());

The accept method waits until a client (in our case, SampleClient) requests a connection on the host and port of the SampleServer, which SampleClient does via

Socket socket = new Socket(hostName, port);

When the connection is requested and established, the accept method returns a new Socket object bound to a new port. The server can communicate with the client over this new socket and continue to listen for other client connection requests on the ServerSocket bound to the original port. Thus, a server program typically has a loop which can handle multiple connection requests.

The basic loop structure for our SampleServer is the following:

while (true) {

    Socket socket = ss.accept();

    <Establish input and output streams for the connection>;
    <Establish a context with the client>;
    <Exchange messages with the client>;
    <Clean up>;
}

Client connections are queued at the original port, so with this program structure used by SampleServer, the interaction with the first client making a connection has to complete before the next connection can be accepted. The server could actually service multiple clients simultaneously through the use of threads - one thread per client connection, as in

while (true) {
    <accept a connection>;
    <create a thread to handle the client>;
}

Establishing a Security Context

Before two applications can use Java GSS-API to securely exchange messages between them, they must establish a joint security context using their credentials. (Note: In the case of SampleClient, the credentials were established when the Login utility authenticated the user on whose behalf the SampleClient was run, and similarly for SampleServer.) The security context encapsulates shared state information that might include, for example, cryptographic keys. One use of such keys might be to encrypt messages to be exchanged, if encryption is requested.

As part of the security context establishment, the context initiator (in our case, SampleClient) is authenticated to the acceptor (SampleServer), and may require that the acceptor also be authenticated back to the initiator, in which case we say that "mutual authentication" took place.

Both applications create and use a GSSContext object to establish and maintain the shared information that makes up the security context.

The instantiation of the context object is done differently by the context initiator and the context acceptor. After the initiator instantiates a GSSContext, it may choose to set various context options that will determine the characteristics of the desired security context, for example, specifying whether or not mutual authentication should take place. After all the desired characteristics have been set, the initiator calls the initSecContext method, which produces a token required by the acceptor's acceptSecContext method.

While Java GSS-API methods exist for preparing tokens to be exchanged between applications, it is the responsibility of the applications to actually transfer the tokens between them. So after the initiator has received a token from its call to initSecContext, it sends that token to the acceptor. The acceptor calls acceptSecContext, passing it the token. The acceptSecContext method may in turn return a token. If it does, the acceptor should send that token to the initiator, which should then call initSecContext again and pass it this token. Each time initSecContext or acceptSecContext returns a token, the application that called the method should send the token to its peer and that peer should pass the token to its appropriate method (acceptSecContext or initSecContext). This continues until the context is fully established (which is the case when the context's isEstablished method returns true).

The context establishment code for our sample applications is described in the following:

  • Context Establishment by SampleClient
  • Context Establishment by SampleServer

Context Establishment by SampleClient

In our client/server scenario, SampleClient is the context initiator. Here are the basic steps it takes to establish a security context. It

  1. Instantiates a GSSContext.
  2. Sets the desired optional features on the context.
  3. Loops while the context is not yet established, each time calling initSecContext, sending any returned token to SampleServer, and receiving a token (if any) from SampleServer.

SampleClient GSSContext Instantiation

A GSSContext is created by instantiating a GSSManager and then calling one of its createContext methods. The GSSManager class serves as a factory for other important GSS API classes. It can create instances of classes implementing the GSSContext, GSSCredential, and GSSName interfaces.

SampleClient obtains an instance of the default GSSManager subclass by calling the GSSManager static method getInstance:

GSSManager manager = GSSManager.getInstance();

The default GSSManager subclass is one whose create* methods (createContext, etc.) return classes whose implementations support Kerberos as the underlying technology.

The GSSManager factory method for creating a context on the initiator's side has the following signature:

GSSContext createContext(GSSName peer, Oid mech,
            GSSCredential myCred, int lifetime);

The arguments are described below, followed by the complete call to createContext.

The GSSName peer Argument

The peer in our client/server paradigm is the server. For the peer argument, we need a GSSName for the service principal representing the server. (See Kerberos User and Service Principal Names.) A String for the service principal name is passed as the first argument to SampleClient, which places the argument into its local String variable named server. The GSSManager manager is used to instantiate a GSSName by calling one of its createName methods. SampleClient calls the createName method with the following signature:

GSSName createName(String nameStr, Oid nameType);

SampleClient passes the server String for the nameStr argument.

The second argument is an Oid. An Oid represents a Universal Object Identifier. Oids are hierarchically globally-interpretable identifiers used within the GSS-API framework to identify mechanisms and name types. The structure and encoding of Oids is defined in the ISOIEC-8824 and ISOIEC-8825 standards. The Oid passed to the createName method is specifically a name type Oid (not a mechanism Oid).

In GSS-API, string names are often mapped from a mechanism-independent format into a mechanism-specific format. Usually, an Oid specifies what name format the string is in so that the mechanism knows how to do this mapping. Passing in a null Oid indicates that the name is already in a native format that the mechanism uses. This is the case for the server String; it is in the appropriate format for a Kerberos Version 5 name. Thus, SampleClient passes a null for the Oid. Here is the call:

GSSName serverName = manager.createName(server, null);

The Oid mech Argument

The second argument to the GSSManager createContext method is an Oid representing the mechanism to be used for the authentication between the client and the server during context establishment and for subsequent secure communication between them.

Our tutorial will use Kerberos V5 as the security mechanism. The Oid for the Kerberos V5 mechanism is defined in RFC 1964 as "1.2.840.113554.1.2.2" so we create such an Oid:

Oid krb5Oid = new Oid("1.2.840.113554.1.2.2");

SampleClient passes krb5Oid as the second argument to createContext.

The GSSCredential myCred Argument

The third argument to the GSSManager createContext method is a GSSCredential representing the caller's credentials. If you pass null for this argument, as SampleClient does, the default credentials are used.

The int lifetime Argument

The final argument to the GSSManager createContext method is an int specifying the desired lifetime, in seconds, for the context that is created. SampleClient passes GSSContext.DEFAULT_LIFETIME to request a default lifetime.

The Complete createContext Call

Now that we have all the required arguments, here is the call SampleClient makes to create a GSSContext:

GSSContext context =
    manager.createContext(serverName,
                          krb5Oid,
                          null,
                          GSSContext.DEFAULT_LIFETIME);

SampleClient Setting of Desired Options

After instantiating a context, and prior to actually establishing the context with the context acceptor, the context initiator may choose to set various options that determine the desired security context characteristics. Each such option is set by calling a request method on the instantiated context. Most request methods take a boolean argument for indicating whether or not the feature is requested. It is not always possible for a request to be satisfied, so whether or not it was can be determined after context establishment by calling one of the get methods.

SampleClient requests the following:

  1. Mutual authentication. The context initiator is always authenticated to the acceptor. If the initiator requests mutual authentication, then the acceptor is also authenticated to the initiator.
  2. Confidentiality. Requesting confidentiality means that you request the enabling of encryption for the context method named wrap. Encryption is actually used only if the MessageProp object passed to the wrap method requests privacy.
  3. Integrity. This requests integrity for the wrap and getMIC methods. When integrity is requested, a cryptographic tag known as a Message Integrity Code (MIC) will be generated when calling those methods. When getMIC is called, the generated MIC appears in the returned token. When wrap is called, the MIC is packaged together with the message (the original message or the result of encrypting the message, depending on whether confidentiality was applied) all as part of one token. You can subsequently verify the MIC against the message to ensure that the message has not been modified in transit.

The SampleClient code for making these requests on the GSSException context is the following:

context.requestMutualAuth(true);  // Mutual authentication
context.requestConf(true);  // Will use encryption later
context.requestInteg(true); // Will use integrity later

Note: When using the default GSSManager implementation and the Kerberos mechanism, these requests will always be granted.

SampleClient Context Establishment Loop

After SampleClient has instantiated a GSSContext and specified the desired context options, it can actually establish the security context with SampleServer. To do so, SampleClient has a loop. Each loop iteration

  1. Calls the context's initSecContext method. If this is the first call, the method is passed a null token. Otherwise, it is passed the token most recently sent to SampleClient by SampleServer (a token generated by a SampleServer call to acceptSecContext).
  2. Sends the token returned by initSecContext (if any) to SampleServer. The first call to initSecContext always produces a token. The last call might not return a token.
  3. Checks to see if the context is established. If not, SampleClient receives another token from SampleServer and then starts the next loop iteration.

The tokens returned by initSecContext or received from SampleServer are placed in a byte array. Tokens should be treated by SampleClient and SampleServer as opaque data to be passed between them and interpreted by Java GSS-API methods.

The initSecContext arguments are a byte array containing a token, the starting offset into that array of where the token begins, and the token length. For the first call, SampleClient passes a null token, since no token has yet been received from SampleServer.

To exchange tokens with SampleServer, SampleClient uses the DataInputStream inStream and DataOutputStream outStream it previously set up using the input and output streams for the socket connection made with SampleServer. Note that whenever a token is written, the number of bytes in the token is written first, followed by the token itself. The reasons are discussed in the introduction to the The SampleClient and SampleServer Message Exchanges section.

Here is the SampleClient context establishment loop, followed by code displaying information about who the client and server are and whether or not mutual authentication actually took place:

byte[] token = new byte[0];

while (!context.isEstablished()) {

    // token is ignored on the first call
    token = context.initSecContext(token, 0, token.length);

    // Send a token to the server if one was generated by
    // initSecContext
    if (token != null) {
        System.out.println("Will send token of size "
                   + token.length + " from initSecContext.");
        outStream.writeInt(token.length);
        outStream.write(token);
        outStream.flush();
    }

    // If the client is done with context establishment
    // then there will be no more tokens to read in this loop
    if (!context.isEstablished()) {
        token = new byte[inStream.readInt()];
        System.out.println("Will read input token of size "
                   + token.length
                   + " for processing by initSecContext");
        inStream.readFully(token);
    }
}

System.out.println("Context Established! ");
System.out.println("Client is " + context.getSrcName());
System.out.println("Server is " + context.getTargName());
if (context.getMutualAuthState())
    System.out.println("Mutual authentication took place!");

Context Establishment by SampleServer

In our client/server scenario, SampleServer is the context acceptor. Here are the basic steps it takes to establish a security context. It

  1. Instantiates a GSSContext.
  2. Loops while the context is not yet established, each time receiving a token from SampleClient, calling acceptSecContext and passing it the token, and sending any returned token to SampleClient.

SampleServer GSSContext Instantiation

As described in SampleClient GSSContext Instantiation, a GSSContext is created by instantiating a GSSManager and then calling one of its createContext methods.

Like SampleClient, SampleServer obtains an instance of the default GSSManager subclass by calling the GSSManager static method getInstance:

GSSManager manager = GSSManager.getInstance();

The GSSManager factory method for creating a context on the acceptor's side has the following signature:

GSSContext createContext(GSSCredential myCred);

If you pass null for the GSSCredential argument, as SampleServer does, the default credentials are used. The context is instantiated via the following:

GSSContext context = manager.createContext((GSSCredential)null);

SampleServer Context Establishment Loop

After SampleServer has instantiated a GSSContext, it can establish the security context with SampleClient. To do so, SampleServer has a loop that continues until the context is established. Each loop iteration does the following:

  1. Receives a token from SampleClient. This token is the result of a SampleClient initSecContext call.
  2. Calls the context's acceptSecContext method, passing it the token just received.
  3. If acceptSecContext returns a token, then SampleServer sends this token to SampleClient and then starts the next loop iteration if the context is not yet established.

The tokens returned by acceptSecContext or received from SampleClient are placed in a byte array.

The acceptSecContext arguments are a byte array containing a token, the starting offset into that array of where the token begins, and the token length.

To exchange tokens with SampleClient, SampleServer uses the DataInputStream inStream and DataOutputStream outStream it previously set up using the input and output streams for the socket connection made with SampleClient.

Here is the SampleServer context establishment loop:

byte[] token = null;

while (!context.isEstablished()) {

    token = new byte[inStream.readInt()];
    System.out.println("Will read input token of size "
       + token.length
       + " for processing by acceptSecContext");
    inStream.readFully(token);

    token = context.acceptSecContext(token, 0, token.length);

    // Send a token to the peer if one was generated by
    // acceptSecContext
    if (token != null) {
        System.out.println("Will send token of size "
           + token.length
           + " from acceptSecContext.");
        outStream.writeInt(token.length);
        outStream.write(token);
        outStream.flush();
    }
}

System.out.print("Context Established! ");
System.out.println("Client is " + context.getSrcName());
System.out.println("Server is " + context.getTargName());
if (context.getMutualAuthState())
    System.out.println("Mutual authentication took place!");

Exchanging Messages Securely

Once a security context has been established between SampleClient and SampleServer, they can use the context to securely exchange messages.

  • GSSContext Methods for Message Exchange
  • The SampleClient and SampleServer Message Exchanges

GSSContext Methods for Message Exchange

Two types of methods exist for preparing messages for secure exchange: wrap and getMIC. There are actually two wrap methods (and two getMIC methods), where the differences between the two are the indication of where the input message is (a byte array or an input stream) and where the output should go (to a byte array return value or to an output stream).

These methods for preparing messages for exchange, and the corresponding methods for interpretation by the peer of the resulting tokens, are described below.

wrap

The wrap method is the primary method for message exchanges.

The signature for the wrap method called by SampleClient is the following:

byte[] wrap (byte[] inBuf, int offset, interface len,
                MessageProp msgProp)

You pass wrap a message (in inBuf), the offset into inBuf where the message begins (offset), and the length of the message (len). You also pass a MessageProp, which is used to indicate the desired QOP (Quality-of-Protection) and to specify whether or not privacy (encryption) is desired. A QOP value selects the cryptographic integrity and encryption (if requested) algorithm(s) to be used. The algorithms corresponding to various QOP values are specified by the provider of the underlying mechanism. For example, the values for Kerberos V5 are defined in RFC 1964 in section 4.2. It is common to specify 0 as the QOP value to request the default QOP.

The wrap method returns a token containing the message and a cryptographic Message Integrity Code (MIC) over it. The message placed in the token will be encrypted if the MessageProp indicates privacy is desired. You do not need to know the format of the returned token; it should be treated as opaque data. You send the returned token to your peer application, which calls the unwrap method to "unwrap" the token to get the original message and to verify its integrity.

getMIC

If you simply want to get a token containing a cryptographic Message Integrity Code (MIC) for a supplied message, you call getMIC. A sample reason you might want to do this is to confirm with your peer that you both have the same data, by just transporting a MIC for that data without incurring the cost of transporting the data itself to each other.

The signature for the getMIC method called by SampleServer is the following:

byte[] getMIC (byte[] inMsg, int offset, int len,
            MessageProp msgProp)

You pass getMIC a message (in inMsg), the offset into inMsg where the message begins (offset), and the length of the message (len). You also pass a MessageProp, which is used to indicate the desired QOP (Quality-of-Protection). It is common to specify 0 as the QOP value to request the default QOP.

If you have a token created by getMIC and the message used to calculate the MIC (or a message purported to be the message on which the MIC was calculated), you can call the verifyMIC method to verify the MIC for the message. If the verification is successful (that is, if a GSSException is not thrown), it proves that the message is exactly the same as it was when the MIC was calculated. A peer receiving a message from an application typically expects a MIC as well, so that they can verify the MIC and be assured the message has not been modified or corrupted in transit. Note: If you know ahead of time that you will want the MIC as well as the message then it is more convenient to use the wrap and unwrap methods. But there could be situations where the message and the MIC are received separately.

The signature for the verifyMIC corresponding to the getMIC shown above is

void verifyMIC (byte[] inToken, int tokOffset, int tokLen,
        byte[] inMsg, int msgOffset, int msgLen,
        MessageProp msgProp);

This verifies the MIC contained in the inToken (of length tokLen, starting at offset tokOffset) over the message contained in inMsg (of length msgLen, starting at offset msgOffset). The MessageProp is used by the underlying mechanism to return information to the caller, such as the QOP indicating the strength of protection that was applied to the message.

The SampleClient and SampleServer Message Exchanges

The message exchanges between SampleClient and SampleServer are summarized below, followed by the coding details.

These steps are the "standard" steps used for verifying a GSS-API client and server. A group at MIT has written a GSS-API client and a GSS-API server that have become fairly popular test programs for checking interoperability between different implementations of the GSS-API library. (These GSS-API sample applications can be downloaded as a part of the Kerberos distribution available from MIT at http://web.mit.edu/kerberos.) This client and server from MIT follow the protocol that once the context is established, the client sends a message across and it expects back the MIC on that message. If you implement a GSS-API library, it is common practice to test it by running either the client or server using your library implementation against a corresponding peer server or client that uses another GSS-API library implementation. If both library implementations conform to the standards, then the two peers will be able to communicate successfully.

One implication of testing your client or server against ones written in C (like the MIT ones) is the way tokens must be exchanged. C implementations of GSS-API do not include stream-based methods. In the absence of stream-based methods on your peer, when you write a token you must first write the number of bytes and then write the token. Similarly, when you are reading a token, you first read the number of bytes and then read the token. This is what SampleClient and SampleServer do.

Here is the summary of the SampleClient and SampleServer message exchanges:

  1. SampleClient calls wrap to encrypt and calculate a MIC for a message.
  2. SampleClient sends the token returned from wrap to SampleServer.
  3. SampleServer calls unwrap to obtain the original message and verify its integrity.
  4. SampleServer calls getMIC to calculate a MIC on the decrypted message.
  5. SampleServer sends the token returned by getMIC (which contains the MIC) to SampleClient.
  6. SampleClient calls verifyMIC to verify that the MIC sent by SampleServer is a valid MIC for the original message.

SampleClient Code to Encrypt the Message and Send It

The SampleClient code for encrypting a message, calculating a MIC for it, and sending the result to SampleServer is the following:

byte[] messageBytes = "Hello There!\0".getBytes();

/*
 * The first MessageProp argument is 0 to request
 * the default Quality-of-Protection.
 * The second argument is true to request
 * privacy (encryption of the message).
 */
MessageProp prop =  new MessageProp(0, true);

/*
 * Encrypt the data and send it across. Integrity protection
 * is always applied, irrespective of encryption.
 */
token = context.wrap(messageBytes, 0, messageBytes.length,
    prop);
System.out.println("Will send wrap token of size "
    + token.length);
outStream.writeInt(token.length);
outStream.write(token);
outStream.flush();

SampleServer Code to Unwrap Token, Calculate MIC, and Send It

The following SampleServer code reads the wrapped token sent by SampleClient and "unwraps" it to obtain the original message and have its integrity verified. The unwrapping in this case includes decryption since the message was encrypted.

Note: Here the integrity check is expected to succeed. But note that in general if an integrity check fails it signifies that the message was changed in transit. If the unwrap method encounters an integrity check failure, it throws a GSSException with major error code GSSException.BAD_MIC.

/*
 * Create a MessageProp which unwrap will use to return
 * information such as the Quality-of-Protection that was
 * applied to the wrapped token, whether or not it was
 * encrypted, etc. Since the initial MessageProp values
 * are ignored, it doesn't matter what they are set to.
 */
MessageProp prop = new MessageProp(0, false);

/*
 * Read the token. This uses the same token byte array
 * as that used during context establishment.
 */
token = new byte[inStream.readInt()];
System.out.println("Will read token of size "
    + token.length);
inStream.readFully(token);

byte[] bytes = context.unwrap(token, 0, token.length, prop);
String str = new String(bytes);
System.out.println("Received data \""
    + str + "\" of length " + str.length());
System.out.println("Encryption applied: "
    + prop.getPrivacy());

Next, SampleServer generates a MIC for the decrypted message and sends it to SampleClient. This is not really necessary but simply illustrates generating a MIC on the decrypted message, which should be exactly the same as the original message SampleClient wrapped and sent to SampleServer. When SampleServer generates this and sends it to SampleClient, and SampleClient verifies it, this proves to SampleClient that the decrypted message SampleServer has is in fact exactly the same as the original message from SampleClient.

/*
 * First reset the QOP of the MessageProp to 0
 * to ensure the default Quality-of-Protection
 * is applied.
 */
prop.setQOP(0);

token = context.getMIC(bytes, 0, bytes.length, prop);

System.out.println("Will send MIC token of size "
                   + token.length);
outStream.writeInt(token.length);
outStream.write(token);
outStream.flush();

SampleClient Code to Verify the MIC

The following SampleClient code reads the MIC calculated by SampleServer on the decrypted message and then verifies that the MIC is a MIC for the original message, proving that the decrypted message SampleServer has is the same as the original message:

token = new byte[inStream.readInt()];
System.out.println("Will read token of size " + token.length);
inStream.readFully(token);

/*
 * Recall messageBytes is the byte array containing
 * the original message and prop is the MessageProp
 * already instantiated by SampleClient.
 */
context.verifyMIC(token, 0, token.length,
          messageBytes, 0, messageBytes.length,
          prop);

System.out.println("Verified received MIC for message.");

Clean Up

When SampleClient and SampleServer have finished exchanging messages, they need to perform cleanup operations. Both contain the following code to
  • close the socket connection and
  • release system resources and cryptographic information stored in the context object and then invalidate the context.
socket.close();
context.dispose();

Kerberos User and Service Principal Names

Since the underlying authentication and secure communication technology used by this tutorial is Kerberos V5, we use Kerberos-style principal names wherever a user or service is called for.

For example, when you run SampleClient you are asked to provide your user name. Your Kerberos-style user name is simply the user name you were assigned for Kerberos authentication. It consists of a base user name (like "mjones") followed by an "@" and your realm (like "mjones@KRBNT-OPERATIONS.EXAMPLE.COM").

A server program like SampleServer is typically considered to offer a "service" and to be run on behalf of a particular "service principal." A service principal name for SampleServer is needed in several places:

  • When you run SampleServer, and SampleClient attempts a connection to it, the underlying Kerberos mechanism will attempt to authenticate to the Kerberos KDC. It prompts you to log in. You should log in as the appropriate service principal.
  • When you run SampleClient, one of the arguments is the service principal name. This is needed so SampleClient can initiate establishment of a security context with the appropriate service.
  • If the SampleClient and SampleServer programs were run with a security manager (they're not for this tutorial), the client and server policy files would each require a ServicePermission with name equal to the service principal name and action equal to "initiate" or "accept" (for initiating or accepting establishment of a security context).

Throughout this document, and in the accompanying login configuration file,

service_principal@your_realm
is used as a placeholder to be replaced by the actual name to be used in your environment. Any Kerberos principal can actually be used for the service principal name. So for the purposes of trying out this tutorial, you could use your user name as both the client user name and the service principal name.

In a production environment, system administrators typically like servers to be run as specific principals only and may assign a particular name to be used. Often the Kerberos-style service principal name assigned is of the form

service_name/machine_name@realm;

For example, an nfs service run on a machine named "raven" in the realm named "KRBNT-OPERATIONS.EXAMPLE.COM" could have the service principal name

nfs/raven@KRBNT-OPERATIONS.EXAMPLE.COM

Such multi-component names are not required, however. Single-component names, just like those of user principals, can be used. For example, an installation might use the same ftp service principal ftp@realm for all ftp servers in that realm, while another installation might have different ftp principals for different ftp servers, such as ftp/host1@realm and ftp/host2@realm on machines host1 and host2, respectively.

When the Realm is Required in Principal Names

If the realm of a user or service principal name is the default realm (see Kerberos Requirements), you can leave off the realm when you are logging into Kerberos (that is, when you are prompted for your username). Thus, for example, if your user name is "mjones@KRBNT-OPERATIONS.EXAMPLE.COM", and you run SampleClient, when it requests your user name you could just specify "mjones", leaving off the realm. The name is interpreted in the context of being a Kerberos principal name and the default realm is appended, as needed.

You can also leave off the realm if a principal name will be converted to a GSSName by a GSSManager createName method. For example, when you run SampleClient, one of the arguments is the server service principal name. You can specify the name without including the realm, because SampleClient passes the name to such a createName method, which appends the default realm as needed.

It is recommended that you always include realms when principal names are used in login configuration files and policy files, because the behavior of the parsers for such files may be implementation-dependent; they may or may not append the default realm before such names are utilized and subsequent actions may fail if there is no realm in the name.

The Login Configuration File

For this tutorial, we are letting the underlying Kerberos mechanism obtain credentials of the users running SampleClient and SampleServer, rather than invoking JAAS methods directly (as in the JAAS Authentication and JAAS Authorization tutorials) or indirectly (for example, via the Login utility described in the Use of JAAS Login Utility tutorial and in the Use of JAAS Login Utility and Java GSS-API for Secure Message Exchanges tutorial).

The default Kerberos mechanism implementation supplied by Sun Microsystems actually prompts for a Kerberos name and password and authenticates the specified user (or service) to the Kerberos KDC. The mechanism relies on JAAS to perform this authentication.

JAAS supports a pluggable authentication framework, meaning that any type of authentication module can be plugged under a calling application. A login configuration specifies the login module to be used for a particular application. The default JAAS implementation from Sun Microsystems requires that the login configuration information be specified in a file. (Note: Some other vendors might not have file-based implementations.) See JAAS Login Configuration File for information as to what a login configuration file is, what it contains, and how to specify which login configuration file should be used.

For this tutorial, the Kerberos login module com.sun.security.auth.module.Krb5LoginModule is specified in the configuration file. This login module prompts for a Kerberos name and password and attempts to authenticate to the Kerberos KDC.

Both SampleClient and SampleServer can use the same login configuration file, if that file contains two entries, one entry for the client side and one for the server side.

The bcsLogin.conf login configuration file used for this tutorial is the following:

com.sun.security.jgss.initiate  {
  com.sun.security.auth.module.Krb5LoginModule required;
};

com.sun.security.jgss.accept  {
  com.sun.security.auth.module.Krb5LoginModule required storeKey=true
};

Entries with these two names (com.sun.security.jgss.initiate and com.sun.security.jgss.accept) are used by Sun implementations of GSS-API mechanisms when they need new credentials. Since the mechanism used in this tutorial is the Kerberos V5 mechanism, a Kerberos login module will need to be invoked in order to obtain these credentials. Thus we list Krb5LoginModule as a required module in these entries. The com.sun.security.jgss.initiate entry specifies the configuration for the client side and the com.sun.security.jgss.accept entry for the server side.

The Krb5LoginModule succeeds only if the attempt to log in to the Kerberos KDC as a specified entity is successful. When running SampleClient or SampleServer, the user will be prompted for a name and password.

The SampleServer entry storeKey=true indicates that a secret key should be calculated from the password provided during login and it should be stored in the private credentials of the Subject created as a result of login. This key is subsequently utilized during mutual authentication when establishing a security context between SampleClient and SampleServer.

For information about all the possible options that can be passed to Krb5LoginModule, see the Krb5LoginModule documentation.

The useSubjectCredsOnly System Property

For this tutorial, we set the system property javax.security.auth.useSubjectCredsOnly to false, which allows us to relax the usual restriction of requiring a GSS mechanism to obtain necessary credentials from an existing Subject, set up by JAAS. When this restriction is relaxed, it allows the mechanism to obtain credentials from some vendor-specific location. For example, some vendors might choose to use the operating system's cache if one exists, while others might choose to read from a protected file on disk.

When this restriction is relaxed, Sun Microsystem's Kerberos mechanism still looks for the credentials in the Subject associated with the thread's access control context, but if it doesn't find any there, it performs JAAS authentication using a Kerberos module to obtain new ones. The Kerberos module prompts you for a Kerberos principal name and password. Note that Kerberos mechanism implementations from other vendors may behave differently when this property is set to false. Consult their documentation to determine their implementation's behavior.

Running the SampleClient and SampleServer Programs

To execute the SampleClient and SampleServer programs, do the following:

  • Prepare SampleServer for Execution
  • Prepare SampleClient for Execution
  • Execute SampleServer
  • Execute SampleClient

Prepare SampleServer for Execution

To prepare SampleServer for execution, do the following:

  1. Copy the following files into a directory accessible by the machine on which you will run SampleServer:
    • The SampleServer.java source file.
    • The bcsLogin.conf login configuration file.
  2. Compile SampleServer.java:
    javac SampleServer.java

Prepare SampleClient for Execution

To prepare SampleClient for execution, do the following:

  1. Copy the following files into a directory accessible by the machine on which you will run SampleClient:
    • The SampleClient.java source file.
    • The bcsLogin.conf login configuration file.
  2. Compile SampleClient.java:
    javac SampleClient.java

Execute SampleServer

It is important to execute SampleServer before SampleClient because SampleClient will try to make a socket connection to SampleServer and that will fail if SampleServer is not yet running and accepting socket connections.

To execute SampleServer, be sure to run it on the machine it is expected to be run on. This machine name (host name) is specified as an argument to SampleClient. The service principal name appears in several places, including the login configuration file and the policy files.

Go to the directory in which you have prepared SampleServer for execution. Execute SampleServer, specifying

  • by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified. For example, if your realm is "KRBNT-OPERATIONS.EXAMPLE.COM" you'd put -Djava.security.krb5.realm=KRBNT-OPERATIONS.EXAMPLE.COM.
  • by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified. For example, if your KDC is "samplekdc.example.com" you'd put -Djava.security.krb5.kdc=samplekdc.example.com.
  • by -Djavax.security.auth.useSubjectCredsOnly=false that the underlying mechanism can decide how to get credentials. See The useSubjectCredsOnly System Property.
  • by -Djava.security.auth.login.config=bcsLogin.conf that the login configuration file to be used is bcsLogin.conf.

The only argument required by SampleServer is one specifying the port number to be used for listening for client connections. Choose a high port number unlikely to be used for anything else. An example would be something like 4444.

Below is the full command to use for both Microsoft Windows and Solaris, Linux, and Mac OS X systems.

Important: In this command, you must replace <port_number> with an appropriate port number, <your_realm> with your Kerberos realm, and <your_kdc> with your Kerberos KDC.

Here is the command:

java -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djavax.security.auth.useSubjectCredsOnly=false
 -Djava.security.auth.login.config=bcsLogin.conf
 SampleServer <port_number>

The full command should appear on one line (or, on Solaris, Linux, or Mac OS X systems, on multiple lines where each line but the last is terminated with " \" indicating that there is more to come). Multiple lines are used here just for legibility. Since this command is very long, you may need to place it in a .bat file (for Windows) or a .sh file (for Solaris, Linux, or Mac OS X) and then run that file to execute the command.

The SampleServer code will listen for socket connections on the specified port. When prompted, type the Kerberos name and password for the service principal. The underlying Kerberos authentication mechanism specified in the login configuration file will log the service principal into Kerberos.

For login troubleshooting suggestions, see Troubleshooting.

Execute SampleClient

To execute SampleClient, first go to the directory in which you have prepared SampleClient for execution. Execute SampleClient, specifying

  • by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified.
  • by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified.
  • by -Djavax.security.auth.useSubjectCredsOnly=false that the underlying mechanism can decide how to get credentials.
  • by -Djava.security.auth.login.config=bcsLogin.conf that the login configuration file to be used is bcsLogin.conf.

The SampleClient arguments are (1) the Kerberos name of the service principal that represents SampleServer, (2) the name of the host (machine) on which SampleServer is running, and (3) the port number on which SampleServer is listening for client connections.

Below is the full command to use for both Windows and Solaris, Linux, and Mac OS X systems.

Important: In this command, you must replace <service_principal>, <host>, <port_number>, <your_realm>, and <your_kdc> with appropriate values (and note that the port number must be the same as the port number passed as an argument to SampleServer). These values need not be placed in quotes.

Here is the command:

java -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djavax.security.auth.useSubjectCredsOnly=false
 -Djava.security.auth.login.config=bcsLogin.conf
 SampleClient <service_principal> <host> <port_number>

Type the full command on one line. Multiple lines are used here for legibility. As with the command for executing SampleServer, if the command is too long to type directly into your command window, place it in a .bat file (Windows) or a .sh file (Solaris, Linux, and Mac OS X) and then execute that file.

When prompted, type your Kerberos user name and password. The underlying Kerberos authentication mechanism specified in the login configuration file will log you into Kerberos. The SampleClient code requests a socket connection with SampleServer. Once SampleServer accepts the connection, SampleClient and SampleServer establish a shared context and then exchange messages as described in this tutorial.

For login troubleshooting suggestions, see Troubleshooting.

Tutorials Introduction and TOC
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


BasicService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface BasicService

  • public interface BasicService
    The BasicService interface provides access to the codebase of the application, if an application is run in offline mode, and simple interaction with the native browser on the given platform.

    This interface mimics loosely the AppletContext functionality.

    Since:
    1.4.2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      java.net.URL getCodeBase()
      Returns the codebase for the application.
      boolean isOffline()
      Determines if the system is offline.
      boolean isWebBrowserSupported()
      Checks if a Web browser is supported on the current platform and by the given JNLP Client.
      boolean showDocument(java.net.URL url)
      Directs a browser on the client to show the given URL.

    • Method Detail

      • getCodeBase

        java.net.URL getCodeBase()
        Returns the codebase for the application. The codebase is either specified directly in the JNLP file, or it is the location of the JAR file containing the main class of the application.
        Returns:
        a URL with the codebase of the application, or null if the application is running from local file system.

      • isOffline

        boolean isOffline()
        Determines if the system is offline. The return value represents the JNLP client's "best guess" at the online / offline state of the client system. The return value is does not have to be guaranteed to be reliable, as it is sometimes difficult to ascertain the true online / offline state of a client system.
        Returns:
        true if the system is offline, otherwise false

      • showDocument

        boolean showDocument(java.net.URL url)
        Directs a browser on the client to show the given URL. This will typically replace the page currently being viewed in a browser with the given URL, or cause a browser to be launched that will show the given URL.
        Parameters:
        url - an URL giving the location of the document. A relative URL will be relative to the codebase.
        Returns:
        true if the request succeded false if the url is null or the request failed.

      • isWebBrowserSupported

        boolean isWebBrowserSupported()
        Checks if a Web browser is supported on the current platform and by the given JNLP Client. If this is not the case, then showDocument(java.net.URL) will always return false.
        Returns:
        true if a Web browser is supported, otherwise false
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Extensible Runtime Containment and Services Protocol for JavaBeans Version 1.0

1.0 Introduction.

Currently the JavaBeans specification (Version 1.0) contains neither conventions describing a hierarchy or logical structure of JavaBeans, nor conventions for those JavaBeans to rendezvous with, or obtain arbitrary services or facilities from, the execution environment within which the JavaBean was instantiated.

It is desirable to both provide a logical, traversable, hierarchy of JavaBeans, and further to provide a general mechanism whereby an object instantiating an arbitrary JavaBean can offer that JavaBean a variety of services, or interpose itself between the underlying system service and the JavaBean, in a conventional fashion.

In other component models there exists the concept of a relationship between a Component and its environment, or Container, wherein a newly instantiated Component is provided with a reference to its Container or Embedding Context.

The Container, or Embedding Context not only establishes the hierarchy or logical structure, but its also acts as a service provider that Components may interrogate in order to determine, and subsequently employ, the services provided by their Context.

This proposal defines such a protocol that supports extensible mechanisms that:

  • Introduce an abstraction for the environment, or context, in which a JavaBean logically functions during its lifecycle, that is a hierarchy or structure of JavaBeans.
  • Enable the dynamic addition of arbitrary services to a JavaBean’s environment.
  • Provide a single service discovery mechanism through which JavaBeans may interrogate their environment in order both to ascertain the availability of particular services and to subsequently employ those services.
  • Provide a simple mechanism to propagate an Environment to a JavaBean.
  • Provide better support for JavaBeans that are also Applets.
graphic representation of previous list points

2.0 API Specification

2.1 interface java.beans.beancontext.BeanContext

The hierarchal structure and general facilities of a BeanContext are provided for as follows:

public interface                java.beans.beancontext.BeanContext
           extends              java.beans.beancontext.BeanContextChild,
                      java.util.Collection,
                         java.beans.DesignMode,
                         java.beans.Visibility {

        Object instantiateChild(String beanName)
                  throws IOException, ClassNotFoundException;

        public InputStream
                getResourceAsStream(String           name,
                                    BeanContextChild requestor
                );

        public java.net.URL
                getResource(String           name,
                            BeanContextChild requestor
                );

        void addBeanContextMembershipListener(
                   BeanContextMembershipListener bcml
          );

        void removeBeanContextMembershipListener{
                    BeanContextMembershipListener bcml
        );

        public static final Object globalHierarchyLock;
}

Notifications of changes in the membership of a BeanContext are modeled as follows:

public interface BeanContextMembershipListener
          extends   java.util.Listener {
        void childrenAdded(BeanContextMembershipEvent   bcme);
        void childrenRemoved(BeanContextMembershipEvent bcme);
}

The base class of all BeanContext related Events is defined by:

public abstract class BeanContextEvent
          extends  java.util.EventObject {
        public BeanContext getBeanContext();

        public synchronized void
                setPropagatedFrom(BeanContext bc);

        public synchronized BeanContext getPropagatedFrom();

        public synchronized boolean isPropagated()
}

The BeanContextMembershipEvent is defined as:

public class BeanContextMembershipEvent
          extends BeanContextEvent {

        public BeanContextMembershipEvent(BeanContext bc,
                                          Object[]    deltas);

        public BeanContextMembershipEvent(BeanContext bc,
                                          Collection     deltas);

        public int size();

        public boolean contains(Object child);

        public Object[] toArray();

        public Iterator iterator();
}

2.1.1 The BeanContext as a participant in nested structure

One of the roles of the BeanContext is to introduce the notion of a hierarchical nesting or structure of BeanContext and JavaBean instances. In order to model this structure the BeanContext must expose API that defines the relationships in the structure or hierarchy.

The BeanContext exposes its superstructure through implementation of the java.beans.beancontext.BeanContextChild interface (as described later). This interface allows the discovery and manipulation of a BeanContext’s nesting BeanContext, and thus introduces a facility to create a hierarchy of BeanContexts.

The BeanContext exposes its substructure through a number of interface methods modeled by the java.util.Collection interface semantics

BeanContexts are required to implement all the mandatory Collection API’s, with the following particular semantics for add() and remove():.

The add() method may be invoked in order to nest a new Object, BeanContextChild, or BeanContext within the target BeanContext. A conformant add() implementation is required to adhere to the following semantics:

  • Synchronize on the BeanContext.globalHierarchyLock.
  • Each child object shall appear only once in the set of children for a given BeanContext. If the instance is already a member of the BeanContext then the method shall return False.
  • Each valid child shall be added to the set of children of a given source BeanContext, and thus shall appear in the set of children, obtained through either the toArray(), or iterator() methods, until such time as that child is deleted from the nesting BeanContext via an invocation of remove(), removeAll(), retainAll(), or clear()
  • As the child is added to the set of nested children, and where that child implements the java.beans.beancontext.BeanContextChild interface (or BeanContextProxy, see later for details), the BeanContext shall invoke the setBeanContext() method upon that child, with a reference to itself. Upon invocation, a child may, if it is for some reason unable or unprepared to function in that BeanContext, throw a PropertyVetoException to notify the nesting BeanContext. If the child throws such an exception the BeanContext shall revoke the addition of the child (and any other partial changes made to the state of the BeanContext as a side effect of this addition operation) to the set of nested children and throw an IllegalStateException.
  • JavaBeans that implement the java.beans.Visibility interface shall be notified via the appropriate method, either dontUseGui() or okToUseGui(), of their current ability to render GUI as defined the policy of the BeanContext.
  • If the newly added child implements BeanContextChild, the BeanContext shall register itself with the child on both its VetoableChangeListener and PropertyChangeListener interfaces to monitor, at least, that BeanContextChild’s “beanContext” property.

By doing so the BeanContext can monitor its child and can detect when such children are removed by a 3rd party (usually another BeanContext) invoking setBeanContext(). A BeanContext may veto such a change by a 3rd party if it determines that the child is not in a state to depart membership at that time.

  • If the JavaBean(s) added implement Listener interfaces that the BeanContext is a source for, then the BeanContext may register the newly added objects via the appropriate Listener registration methods as a permissible side effect of nesting.
  • If the JavaBean(s) added are Event Sources for Event that a particular BeanContext has interest in the BeanContext may, as a side effect of adding the child, register Listeners on that child. The BeanContext should avoid using Serializable Listeners thus avoiding accidental serialization of unwanted structure when a child serializes itself.
  • Once the targetChild has been successfully processed, the BeanContext shall fire a java.beans.beancontext.BeanContextMembershipEvent, containing a reference to the newly added targetChild, to the childrenAdded() method of all the BeanContextMemebrshipListeners currently registered.
  • The method shall return true if successful.

The remove() method may be invoked in order to remove an existing child JavaBean or BeanContext from within the target BeanContext. A conformant remove() implementation is required to adhere to the following semantics:

  • Synchronize with the BeanContext.globalHierarchyLock.
  • If a particular child is not present in the set of children for the source BeanContext, the method shall return False.
  • Remove the valid targetChild from the set of children for the source BeanContext, also removing that child from any other Listener interfaces that it was implicitly registered on, for that BeanContext as a side-effect of nesting.

Subsequently, if the targetChild implements the java.beans.beancontext.BeanContextChild interface (or BeanContextProxy, see later for deatils), the BeanContext shall invoke the setBeanContext() with a null1 BeanContext value, in order to notify that child that it is no longer nested within the BeanContext.

If a particular BeanContextChild is in a state where it is not able to be un-nested from its nesting BeanContext it may throw a PropertyVetoException, upon receipt of this the BeanContext shall revoke the remove operation for this instance and throw IllegalStateException. To avoid infinite recursion, children are not permitted to repeatedly veto subsequent remove notifications. In practice, a child should attempt to resolve the condition (if temporary) that precludes it’s removal from it’s current nesting BeanContext.

  • If the targetChild implements java.beans.beancontext.BeanContextChild then the BeanContext shall de-register itself from that child’s PropertyChangeListener and VetoableChangeListener sources.
  • If the BeanContext had previously registered the object(s) removed as Listeners on events sources implemented by the BeanContext as a side effect of nesting those objects, then the BeanContext shall de-register the newly removed object from the applicable source(s) via the appropriate Listener de-registration method(s)
  • If the BeanContext had previously registered Listener(s) on the object(s) removed then the BeanContext shall remove those Listener(s) from those object(s).
  • Once the targetChild has been removed from the set of children, the BeanContext shall fire a java.beans.beancontext.BeanContextMembershipEvent, containing a reference to the targetChild just removed, to the childrenRemoved() method of all the BeanContextMembershipListeners currently registered.
  • Finally the method shall return the value true if successful.

Note that the lifetime of any child of a nesting BeanContext, is at least for the duration of that child’s containment within a given BeanContext. For simple JavaBeans that are not aware of their containment within a BeanContext, this usually implies that the JavaBean shall exist for at least the lifetime of the nesting BeanContext.

BeanContext’s are not required to implement either addAll(), removeAll(), retainAll() or clear() optional methods defined by java.util.Collection API, however if they do they must implement the semantics defined, per object, for both add() and remove() above. In the failure cases these methods shall revoke any partially applied changes to return the BeanContext to the state it was in prior to the failing composite operation being invoked, no BeanContextEvents shall be fired in the failure case as is consistent with the definition of add() and remove() above.

BeanContextMembershipListeners may be added and removed via invocations of addBeanContextMembershipListener() and removeBeanContextMembershipListener().

The toArray(), method shall return a copy of the current set of JavaBean or BeanContext instances nested within the target BeanContext, and the iterator() method shall supply a java.util.Iterator object over the same set of children.

The contains() method shall return true if the object specified is currently a child of the BeanContext.

The size() method returns the current number of children nested.

The isEmpty() method returns true if the BeanContext has no children.

Note that all the Collection methods all require proper synchronization between each other by a given implementation in order to function correctly in a multi-threaded environment, that is, to ensure that any changes to the membership of the set of JavaBeans nested within a given BeanContext are applied atomically. All implementations are required to synchronized their implementations of these methods with the BeanContext.globalHierarchyLock.

In some situations, add() and remove() (or a variant thereof) operations may occur nested, that is multiple occurrences may appear on the stack of the calling Thread simultaneously, e.g: when BeanContextChild, A, is added (or removed), it’s setBeanContext() method also adds (or removes) another BeanContextChild, B. A particular BeanContext implementation may choose to fire either two BeanContextMembershipListener notifications, one for each add()/remove() operation of B then A (in this order since B is successfully added before A), or coalesce these into a single notification containing both A, and B. Note that should A be unable to be added or removed for any reason it shall not perform, or undo, any add or remove operations upon B as a side-effect, prior to throwing a PropertyVetoException to indicate this condition, that is, it must avoid or undo any side-effect membership changes prior to rejecting any changes to its own membership status.

The instantiateChild() method is a convenience method that may be invoked to instantiate a new JavaBean instance as a child of the target BeanContext. The implementation of the JavaBean is derived from the value of the beanName actual parameter, and is defined by the java.beans.Beans.instantiate() method.

Typically, this shall be implemented by calling the appropriate java.beans.Beans.instantiate() method, using the ClassLoader of the target BeanContext. However a particular BeanContext implementation may interpose side-effects on the instantiate operation in their implementation of this method.

The BeanContextEvent is the abstract root EventObject class for all Events pertaining to changes in state of a BeanContext’s defined semantics. This abstract root class defines the BeanContext that is the source of the notification, and also introduces a mechanism to allow the propagation of BeanContextEvent subclasses through a hierarchy of BeanContexts. The setPropagatedFrom() and getPropagatedFrom() methods allows a BeanContext to identify itself as the source of a propagated Event to the BeanContext to which it subsequently propagates the Event to. This is a general propagation mechanism and should be used with care as it has significant performance implications when propagated through large hierarchies.

The BeanContextMembershipEvent describes changes that occur in the membership of a particular BeanContext instance. This event encapsulates the list of children either added to, or removed from, the membership of a particular BeanContext instance, i.e the delta in the membership set.

Whenever a successful add(), remove(), addAll(), retainAll(), removeAll(), or clear() is invoked upon a particular BeanContext instance, a BeanContextMembershipEvent is fired describing the children effected by the operation.

2.1.2 Resources.

The BeanContext defines two methods; getResourceAsStream() and getResource() which are analogous to those methods found on java.lang.ClassLoader. BeanContextChild instances nested within a BeanContext shall invoke the methods on their nesting BeanContext in preference for those on ClassLoader, to allow a BeanContext implementation to augment the semantics by interposing behavior between the child and the underlying ClassLoader semantics.

2.1.3 The BeanContext as a Service Provider

The service facilities of a BeanContext are provided as follows:

public interface BeanContextServices
          extends   BeanContext,BeanContextServicesListener {

        boolean addService(Class           serviceClass,
                           BeanContextServiceProvider service);

        boolean revokeService(Class           serviceClass,
                              BeanContextServiceProvider bcsp,
                              boolean         revokeNow
        );

        boolean hasService(Class serviceClass);

        Object getService(BeanContextChild      bcc,
                          Object                requestor.
                          Class                 serviceClass,
                          Object                serviceSelector,
                          BeanContextServicesRevokedListener sl
        ) throws TooManyListenersException;

        void releaseService(BeanContextChild bcc,
                            Object           requestor,
                            Object           service);

        Iterator getCurrentServiceClasses();

        public Iterator getCurrentServiceSelectors(Class sc);

        addBeanContextServicesListener(
                BeanContextServicesListener bcsl
        );

        removeBeanContextServicesListener(
                BeanContextServicesListener bcsl
     );
}

The BeanContextServiceProvider interface is defined as follows:

public interface BeanContextServiceProvider {
        Object getService(BeanContext bc,
                          Object      requestor,
                          Class       serviceCls,
                          Object      serviceSelector);

        void releaseService(BeanContext bc,
                            Object      requestor,
                            Object      service);

        Iterator getCurrentServiceSelectors(BeanContext bc,
                                            Class serviceCls);
}

The BeanContextServiceRevokedListener is defined as follows:

public interface BeanContextServiceRevokedListener
          extends java.util.EventListener {
        void serviceRevoked(
                BeanContextServiceRevokedEvent bcsre
        );
}

The BeanContextServicesListener is defined as follows:

public interface BeanContextServicesListener
          extends BeanContextServiceRevokedListener {
        void serviceAvailable(
                BeanContextServiceAvailableEvent bcsae
        );
}

The BeanContextServiceAvailableEvent is defined as follows:

public class BeanContextServiceAvailableEvent
          extends BeanContextEvent {

        public BeanContextServiceAvailableEvent(
                        BeanContextServices        bcs,
                        Class                      sc
     );

        BeanContextServices getSourceAsBeanContextServices();

        public Class getServiceClass();

        public boolean isServiceClass(Class serviceClass);

        public Iterator getCurrentServiceSelectors();
}

The BeanContextServiceRevokedEvent is defined as follows:

public class BeanContextServiceRevokedEvent
          extends BeanContextEvent {
        public BeanContextServiceRevokedEvent(
                                BeanContextServices        bcs,
                                Class                      sc,
                             boolean                    invalidNow
        );
        public BeanContextServices
                        getSourceAsBeanContextServices();

        public Class getServiceClass();

        public boolean isServiceClass(Class service);

        public boolean isCurrentServiceInvalidNow();
}

The BeanContextServiceProviderBeanInfo is defined as follows:

public interface BeanContextServicesProviderBeanInfo
       extends   java.beans.BeanInfo {
    java.beans.BeanInfo[] getServicesBeanInfo();
}

Apart from providing a structured hierarchy, the other major role of a BeanContext is to provide a standard mechanism for a JavaBean component to obtain context-specific facilities or services from its environment.

A service, represented by a Class object, is typically a reference to either an interface, or to an implementation that is not publicly instantiable. This Class defines an interface protocol or contract between a BeanContextServiceProvider, the factory of the service, and an arbitrary object associated with a BeanContextChild that is currently nested within the BeanContext the service is registered with. Typically such protocols encapsulate some context specific or sensitive behavior that isolates a BeanContextChild’s implementation from such dependencies thus resulting in simpler implementations, greater interoperability and portability.

A BeanContextServiceProvider, is a “factory” for one or more services. It registers itself with a particular BeanContextServices via it’s adService() method, if the service is not already registered with the BeanContextServices, the BeanContextServices associates the service specified with the BeanContextServiceProvider, and fires a BeanContextServiceAvailableEvent via the serviceAvailable() method to those BeanContextServicesListeners currently registered, then returns true, otherwise false indicating that the service is already registered for that BeanContextServices.

Once registered, and until revoked, the service is available via the BeanContextServices getService() method.

The hasService() method may be used to test the presence of a particular service, and the getCurrentServices() method returns an iterator over the currently available services for that BeanContextServices.

A BeanContextChild or any arbitrary object associated with a BeanContextChild, may obtain a reference to a currently registered service from its nesting BeanContextServices via an invocation of the getService() method. The getService() method specifies; the BeanContextChild, the associated requestor, the Class of the service requested, a service dependent parameter (known as a Service Selector), and a BeanContextServicesRevokedListener used to subsequently notify the requestor that the service class has been revoked by the BeanContextServiceProvider. The Listener is registered automatically with a unicast event source per requestor and service class and is automatically unregistered when a requestor relinquishes all references of a given service class, or as a side effect of the service being “forcibly revoked” by the providing BeanContextServiceProvider.

The BeanContextServices passes this getService() invocation onto the associated BeanContextServiceProvider (if any) to be satisfied via an invocation of its getService() method. The BeanContextServiceProvider is passed the BeanContext, the Class of the service provided, the service dependent service parameter (the Service Selector) and a reference to the object requesting the service.

The reference to the BeanContext is intended to enable the BeanContextServiceProvider to distinguish service requests from multiple sources. A BeanContextServiceProvider is only permitted to retain a weak reference to any BeanContext so obtained.

The Service Selector parameter is a service dependent value used by a service requestor for a particular service in order to parameterize the service to be provided to it by the BeanContextServiceProvider. Some examples of its usage are; a parameter to a constructor for the service implementation class; a value for a particular service’s property, or as a key into a map of existing implementations.

The reference to the requestor is intended to permit the BeanContextServiceProvider to interrogate the state of the requestor in order to perform any customization or parameterization of the service, therefore this reference shall be treated as immutable by the BeanContextServicesProvider. Additionally the BeanContextServiceProvider is permitted to retain only weak and immutable reference to both the requestor and the BeanContextChild after returning from the getService() invocation.

The BeanContextServiceProvider may satisfy the request, returning a reference to an instance of the Class of the requested service (such that the reference returned shall result in the expression: <serviceRefence> instanceof <serviceClass> being true), return null, or throw an unchecked exception.

In the case when a nested BeanContextServices is requested for a particular service that it has no BeanContextServiceProvider for, then the BeanContextServices may delegate the service requested to its own nesting BeanContextServices in order to be satisfied. Thus delegation requests can propagate from the leaf BeanContextServices to the root BeanContextServices.

A BeanContextChild may query a particular BeanContextServices for a list of currently available Service Classes (via the getCurrentServiceClasses() method)and any associated Service Selectors, if a particular service Class implements a finite list of apriori values for a Service Class, via its nesting BeanContextServices.getCurrentServiceSelectors() method, which in turn obtains the currently available Service Selectors (if any) via the BeanContextServiceProvider.getCurrentServiceSelectors() method.

If the service in question does not implement a finite set of apriori values for the set of valid Service Selectors it shall return null.

A reference obtained by a BeanContextChild via getService() is valid until the reference is released by the BeanContextChild via an invocation of its nesting BeanContextServices releaseService() method, except in the case where the BeanContextServices fires a BeanContextServiceRevokedEvent and that Event’s isCurrentServiceInvalidNow() method returns true, in this case the BeanContextServices and/or the BeanContextServiceProvider that provided the service has determined that current service references are immediately invalidated, or “forcibly revoked” (this typically occurs in the following situation).

When BeanContextChild instances are removed from a particular BeanContextServices instance, they shall discard all references to any services they obtained from that BeanContextServices by appropriate invocations of releaseService(). If the un-nesting BeanContextChild is also a BeanContextServices instance, and if any of these service references have been exposed to the un-nesting BeanContextServices’s own members as a result of a delegated getService() request as defined above, the BeanContextServiecs shall fire a BeanContextServiceRevokedEvent to notify its nested children that the service(s) are “forcibly revoked”. This immediate invalidation of current references to delegated services at un-nesting is to ensure that services that are dependent upon the structure of the hierarchy are not used by requestors after their location in the structure has changed.

BeanContextChild instances receiving a “forcable revocation” of a Service Class shall not invoke releaseService() for any references it may hold of that type, since in this case, the BeanContextServiceProvider or the BeanContextServices that provided the service reference to that BeanContextChild has already invalidated all references to that service on their behalf.

A BeanContextServiceProvider may revoke a Service Class at any time after it has registered it with a BeanContextServices by invoking its revokeService() method. Once the BeanContextServices has fired a BeanContextServiceRevokedEvent notifying the currently registered BeanContextServiceRevokedListeners and the BeanContextServicesListeners that the service is now unavailable it shall no longer satisfy any new service requests for the revoked service until (if at all) that Service Class is re-registered. References obtained by BeanContextChild requestors to a service prior to its being revoked remain valid, and therefore the service shall remain valid to satisfy those extant references, until all references to that service are released, unless in exceptional circumstances the BeanContextServiceProvider, or BeanContextServices, when revoking the service, wants to immediately terminate service to all the current references. This immediate revocation is achieved by invoking the BeanContextServices .revokeService() method with an actual parameter value of revokeNow == true. Subsequent to immediate invalidation of current service references the service implementation may throw a service specific unchecked exception in response to any attempts to continue to use the revoked service by service requestors that have erroneously retained references to the service, ignoring the earlier immediate revocation notification.

Note that in order to function correctly (when delegating service requests) in a multi-threaded environment, implementations of BeanContextServices are required to synchronize their implementations of; addService(), hasService(), getCurrentServiceClasses(), getCurrentServiceSelectors(), getService(), releaseService() and revokeService() with the BeanContext.globalHierarhyLock.

A BeanContextServicesProvider may expose the BeanInfo for the Service Classes it provides implementations for by providing a BeanInfo class that implements BeanContextServicesProviderBeanInfo. Thus exposing an array of BeanInfo’s, one for each Service Class supported. Builder tools can, for example, use this infomation to provide application developers with a palette of Servlice Classes for inclusion in an application.

2.1.4 The role of a BeanContext in Persistence

Since one of the primary roles of a BeanContext is to represent a logical nested structure of JavaBean component and BeanContext instance hierarchies, it is natural to expect that in many scenarios that hierarchy should be persistent, i.e that the BeanContext should participate in persistence mechanisms, in particular, either java.io.Serializable or java.io.Externalizable (If the latter the BeanContext is responsible for acting as the persistence container for the sub-graph of children, encoding and decoding the class information, and maintaining sub-graph equivalence after deserialization, basically the function(s) provide for serialization by ObjectOutputStream and ObjectInputStream).

In particular BeanContexts shall persist and restore their current children that implement the appropriate persistence interfaces when they themselves are made persistent or subsequently restored.

As a result of the above requirement, persistent BeanContextChild implementations are required to not persist any references to either their nesting BeanContext, or to any Delegates obtained via its nesting BeanContextServices.

BeanContexts shall, when restoring an instance of BeanContextChild from its persistence state, be required to perform the equivalent of invoking add()on the newly instantiated BeanContextChild,, in order to notify the newly restored instance of its nesting BeanContext, thus allowing that BeanContextChild to fully reestablish its dependencies on its environment.

Also note that since BeanContext implements java.beans.beancontext.BeanContextChild it shall obey the persistence requirements defined below for implementors of that interface.

2.1.5 BeanContext with associated presentation hierarchies

Although not required, many BeanContexts may be associated within a presentation hierarchy of java.awt.Containers and java.awt.Components. A Container cannot implement BeanContext directly2 but may be associated with one by implementing the BeanContextProxy interface described herein.

public interface BeanContextProxy {
    BeanContext getBeanContext();
}

For instances of classes that do not (or cannot in the case of Component or subclasses thereof) directly implement the BeanContext interface, but are associated with an instance of such an implementation, (via delegation) such instances may expose this association by implementing the BeanContextProxy interface. By doing so, this enables arbitrary 3rd parties, such as builder tools, to interrogate and discover the BeanContext associated with such objects for the purposes of either nesting objects within that associated BeanContext, observing changes in the membership, or obtaining services thereof.

This also permits multiple distinct objects (e.g: Containers) to share a single BeanContext. [Note though that in this case a shared BeanContext shall not implement BeanContextContainerProxy since that is a peer-to-peer relationship between a single BeanContext and the Container implementing that interface]

The value returned from getBeanContext() is constant for the lifetime of the implementing instance, that is the relationship between a BeanContextProxy and it’s associated BeanContext is static and thus may not change for the lifetime of either participant.

No class may implement both the BeanContext (or BeanContextChild) and the BeanContextProxy interfaces, they are mutually exclusive.

Some BeanContextProxy implementors may also implement java.util.Collection, or some other collection-like API (e.g java.awt.Container), in addition to, and possibly distinct from, maintaining a BeanContext based Collection.

In such cases it is possible to add, or remove, elements from either the BeanContext, via it’s Collection API’s, or the BeanContextProxy implementor using it’s own collection-like API’s (e.g: public boolean java.awt.Container.add(Component)). It is implementation dependent whether or not objects added or removed from either the BeanContext’s Collection, or the BeanContextProxy implementor’s collection are also added or removed from the corresponding object’s collection (i.e: should a Container.add() also infer a BeanContext.add() and vica-versa?). In such situations both participants (the implementor of BeanContextProxy and the BeanContext itself) are required to; 1) implement the same add/remove semantics as the other (i.e: if x.add(o) has a side effect of x.getBeanContext().add(o) then x.getBeanContext().add(o) should also a have side effect of x.add(o)), and 2) before adding/removing an object to/from the other participants collection, it should test (synchronized) if that object is/is not a member of the other participants collection before proceeding with the operation in question (this is to avoid infinite recursion between collection operations on both participants) (i.e: x.add(o) should not invoke x.getBeanContext().add(o) if x.getBeanContext().contains(o) is true and vica-versa).

It is important to note that if an object that implements BeanContextProxy is added to , or removed from, a BeanContext, that in addition to the operation performed on that object, the same operation should be performed on the BeanContext returned from BeanContextProxy.getBeanContext(). That is an implementor of BeanContextProxy shall be treated as though it directly implemented BeanContext by any nesting BeanContext. (and vica-versa if the operation is applied to the BeanContext its shall also be applied to the corresponding BeanContextProxy)

The following interface is defined to allow a BeanContext to expose a reference to an associated Container to enable it’s BeanContextChild members to add, or remove, their associated Component objects to/from that Container or to inspect some state on the Container.

public interface BeanContextContainerProxy {
        Container getContainer()
}

When a BeanContextChild with an associated Component is added to a BeanContext with an associated Container there are three models of interaction that can occur in relation to the nesting of the Component in the Container as a result:

  • If the associated Component was added to the associated Container via a Container API, then the nesting of the BeanContextChild in the BeanContext is a side effect of that and no further action is required.
  • If the Component and Container are not nested then the nesting BeanContext may as a side effect cause the Component associated with the BeanContextChild to be added to it’s associated Container.

OR

  • If the Component and Container are not nested then the BeanContextChild being nested may as a side effect may cause it’s Component to be associated with the Container associated with the nesting BeanContext.

Thus, for greatest interoperability a BeanContextChild shall always check if its Compoent’s parent is the BeanContext Container, and if it is not, then it may add itself if appropriate. Thus a BeanContextChild may function correctly under all scenarios.

The BeanContextChild is responsible for initially causing itself to eligible to be displayed via an invocation of show() [note that the BeanContextChild may also subsequently repeatedly hide() and show() itself].

The nesting BeanContext, or its associated Container, may subsequently hide() or show() the BeanContextChild’s Component arbitrarily, but it is strongly recommended that it treat that Component as immutable in all other respects with the exception of registering Listeners to obtain event notifications, or where other Component/Container specific protocols permit or require the Container to alter the state of its Component containees. An example of such a permitted interaction would be where a property such as background or foreground color were propagated from Container to Component.

Once a BeanContextChild has been un-nested from it’s BeanContext, it’s associated Component (if any) shall be removed from that BeanContext’s Container as a side effect of the removal operation, this is the responsibility of the BeanContext (typically if the BeanContextChild has been moved to another BeanContext with an associated Container via an invocation of it’s setBeanContext() method, the Component will already have been re-parented as a side effect of that operation by the time the original BeanContext is notified of the change via a PropertyChangeEvent from the child, however the check should be made and the Component removed if it has not already occurred).

To avoid infinite recursion, both a BeanContext and a BeanContextChild that also are associated with a Container and Component nesting relationship should avoid undoing any changes applied to the Component by the other party in the relationship. In general the BeanContext is responsible for the appearance, visibility and relative layout of the BeanContextChild’s Component, and the BeanContextChild is responsible for the Component’s state and content pertaining to the application functionality it is implementing.

The value returned from the getContainer() method is constant for the lifetime of the implementing BeanContext, that is the relationship between a BeanContext and a Container is static for the lifetime of both participants.

In addition the following interface is also defined:

public interface BeanContextChildComponentProxy {
    Component getComponent();
}

A BeanContext or a BeanContextChild may implement this interface to expose the GUI Component that it is associated with to it’s nesting BeanContext. A BeanContext may use this method to establish the relationship between references to instances of Component and BeanContextChild that are known to it, where a BeanContextChild and Component are not implemented by the same object instance (that is the BeanContextChild delegates its Component implementation to a distinct object rather than inheriting from Component]. A BeanContext may interrogate the Component reference it obtains from a nested BeanContextChild in order to determine its state, and it may also register Listeners for particular events, however it is strongly recommended that the BeanContext treat the reference as generally immutable to avoid changing the Component state.

The value returned from the getComponent() method is a constant for the lifetime of that BeanContextChild.

In the situation where a BeanContext has an associated Container, but does not wish to expose that Container by implementing the BeanContextContainerProxy interface, but wishes to handle the nesting of an arbitrary BeanContextChild’s associated Component (exposed by the BeanContextChild either implementing the BeanContextChildComponentProxy interface or as direct subclass of Component) the BeanContext is permitted to add/remove that Component to/from its associated Container.In such cases the BeanContextChild and it’s associated Component implementation shall not interfere with this action.

If a class implements both BeanContextChildComponentProxy and BeanContextContainerProxy then the object returned by both getComponent() and getContainer() shall be the same object.

2.2 interface java.beans.beancontext.BeanContextChild3

Simple JavaBeans that do not require any support or knowledge of their environment shall continue to function as they do today. However both JavaBeans that wish to utilize their containing BeanContext, and BeanContexts that may be nested, require to implement a mechanism that enables the propagation of the reference to the enclosing BeanContext through to cognizant JavaBeans and nested BeanContexts, the interface proposed is:

public interface java.beans.beancontext.BeanContextChild {
        void        setBeanContext(BeanContext bc)
                                throws PropertyVetoException;

        BeanContext getBeanContext();

        void addPropertyChangeListener
                (String name, PropertyChangeListener pcl);

     void removePropertyChangeListener
                (String name, PropertyChangeListener pcl);

        void addVetoableChangeListener
                (String name, VetoableChangeListener pcl);

     void removeVetoableChangeListener
                (String name, VetoableChangeListener pcl);

}

The expected usage is that some 3rd party shall invoke one of the appropriate methods defined on BeanContext (by virtue of its inheritance from Collection) in order to add a BeanContextChild to the membership of the target BeanContext. As a consequence the BeanContext shall attempt to set the BeanContextChild’s “beanContext” property by invoking its setter method, setBeanContext(). Only a BeanContext may call a BeanContextChild’s setBeanContext() method, since this is the mechanism that a BeanContext uses to notify a child that it is now has a new BeanContext value. Since this property is not directly settable or customizable by a user in the context of an application construction tool the BeanInfo for a BeanContextChild should set the hidden state for this property in order for builder tools to avoid presenting the property to the user for customization.

A BeanContextChild object may throw a PropertyVetoException, to notify the nesting BeanContext that it is unable to function/be nested within that particular BeanContext. Such a veto shall be interpreted by a BeanContext as an indication that the BeanContextChild has determined that it is unable to function in that particular BeanContext and is final.

During the un-nesting of a BeanContextChild from its BeanContext, it is possible for the child, or a 3rd party listening to the child’s “beanContext” property for PropertyVetoEvents, to throw a PropertyVetoException to notify the caller that it is not in a state to be un-nested. In order to bound this interaction a BeanContextChild, or 3rd party, may veto the initial un-nesting notification, but may not veto any subsequent notifications, and must, upon receipt of such notifications, amend its state accordingly to prepare itself to be subsequently un-nested.

Note that classes that implement this interface, also act as an Event Source for (sub)interface(s) of java.beans.PropertyChangeListener, and are required to update their state accordingly and subsequently fire the appropriate java.beans.PropertyChangeEvent with propertyName = “beanContext”, oldValue = the reference to the previous nesting BeanContext, and newValue = the reference to the new nesting BeanContext, to notify any Listeners that its nesting BeanContext has changed value.

BeanContextChild instances, or nested BeanContexts in the process of terminating themselves, shall invoke the remove() method on their nesting BeanContext in order to withdraw themselves from the hierarchy prior to termination.

2.2.1 Important Persistence considerations

Instances of BeanContextChild nested within an BeanContext, will typically define fields or instance variables that will contain references to their nesting BeanContext instance, and possibly services obtained from that BeanContextServices instance via its getService() method.

In order to ensure that the act of making such an instance persistent does not erroneously persist objects from the instances nesting environment, such instances shall be required to define such fields, or instance variables as either transient, or to implement custom persistence methods that avoid persisting such state.

This requirement is crucial since operations such as cutting and pasting object instances through a clipboard via object serialization will not function correctly if the act of serializing the target object also serializes much of the entire source environment it is nested within.

3.0 Overloading java.beans.instantiate() static method

Since java.beans.instantiate() is the current mechanism for (re)instantiating JavaBeans we need to extend or overload the syntax and semantics of this method in order to accommodate the introduction of the BeanContext abstraction. The extension proposed is:

public static Object instantiate(ClassLoader cl,
                                                String        beanName,
                                                BeanContext beanContext);

This method behaves has it is currently defined in the JavaBeans specification, but in addition to these existing semantics, when a non-null BeanContext is specified then the method invokes the add() method on the beanContext actual parameter with the value of the targetChild actual parameter = a reference to the newly instantiated JavaBean component.4

4.0 Providing better support for Beans that are also Applets

The current implementation of java.beans.instantiate() contains minimal support for instantiating JavaBeans that are also Applets. In particular, this method will currently construct an AppletContext and AppletStub for the newly instantiated JavaBean, set the stub on the newly instantiated Applet, and init() the Applet if it has not already been invoked.

Unfortunately this does not provide sufficient support in order to allow most Applets to be fully functional, since the AppletContext and AppletStub created by java.beans.instantiate(), are no-ops. This is a direct consequence of the lack of sufficient specification of how to construct AppletContext and AppletStub implementations in the existing Applet API’s. Furthermore, even if such specifications existed we would require an API that propagated a number of Applet attributes such as its Codebase, Parameters, AppletContext, and Documentbase into java.beans.instantiate() in order for it to subsequently instantiate the appropriately initialized objects.

Since key to supporting fully functional Applets is to provide them with fully functional AppletContext and AppletStub instances, the design goal is to provide a mechanism to provide this state to instantiate() so that it may carry out the appropriate initialization and binding5, therefore the proposed interface is:

public static Object
                        instantiate(ClassLoader                                 cl,
                                          String                beanName,
                                          BeanContext           bCtxt,
                                          AppletInitializer                                                                                                                     ai
                        );

public interface AppletInitializer {
        void initialize(Applet newApplet, BeanContext bCtxt);
        void activate(Applet newApplet);
}

If the newly instantiated JavaBean component is an instance of java.applet.Applet then the new constructed Applet, (Bean) will be passed to the AppletInitializer via a call to initialize().

Compliant implementations of AppletInitializer.initialize() shall:

  • Associate the newly instantiated Applet with the appropriate AppletContext.
  • Instantiate an AppletStub() and associate that AppletStub with the Applet via
  • an invocation of setStub().
  • If BeanContext parameter is null, then it shall associate the Applet with its appropriate Container by adding that Applet to its Container via an invocation of add(). If the BeanContext parameter is non-null, then it is the responsibility of the BeanContext to associate the Applet with its Container during the subsequent invocation of its addChildren() method.

Compliant implementations of AppletInitializer.activate() shall mark the Applet as active, and may optionally also invoke the Applet’s start() method.

Note that if the newly instantiated JavaBean is not an instance of Applet, then the AppletInitializer interface is ignored.

5.0 Standard/Suggested Conventions for BeanContext Services

5.1 BeanContexts that support InfoBus.

The InfoBus technology is a standard extension package that is intended to facilitate the rendezvous and exchange of dynamic self describing data, based upon a publish and subscribe abstraction, between JavaBean Components within a single Java Virtual Machine.

A BeanContext that exposes an InfoBus to its nested BeanContextChild shall do so by exposing a service via the hasService() and getService() methods of type javax.infobus.InfoBus.

Thus BeanContextChild implementations may locate a common InfoBus implementation for their current BeanContext by using this mechanism to rendezvous with that InfoBus instance.

The Infobus 1.2 specification shall define a convenience mechanism provided by the InfoBus class to simplify the discovery mechanism for BeanContextChild instances nested within a particular instance of BeanContextServices.

5.2 BeanContexts that support printing

A BeanContext that wishes to expose printing facilities to its descendants may delegate a reference of (sub)type java.awt.PrintJob.

As the Java Network Printing Interface evolves additional specifications will be provided to expose it’s facilities via the services mechanism.

5.3 BeanContext Design/Runtime mode support.

JavaBeans support the concepts of “design”-mode, when JavaBeans are being manipulated and composed by a developer in an Application Builder or IDE, and “Run”-mode, when the resulting JavaBeans are instantiated at runtime as part of an Applet, Application or some other executable abstraction.

In the first version of the specification, the “mode” or state, that is “design”-time or “run”-time was a JVM global attribute. This is insufficient since, for example, in an Application Builder environment, there may be JavaBeans that function, in “run”-mode, as part of the Application Builder environment itself, as well as the JavaBeans that function, in “design”-mode, under construction by the developer using the Application Builder to compose an application.

Therefore we require the ability to scope this “mode” at a granularity below that of JVM global.

The BeanContext abstraction, as a “Container” or “Context” for one or more JavaBeans provides appropriate mechanism to better scope this “mode”.

Thus BeanContext’s that wish to expose and propagate this “mode” to its descendants may delegate a reference of type java.beans.DesignMode:

public interface java.beans.DesignMode {
        void    setDesignTime(boolean isDesignTime);
        boolean isDesignTime();
}

Additionally, BeanContexts delegating such a reference shall be required to fire the appropriate java.beans.propertyChangeEvent, with propertyName = “designTime”, with the appropriate values for oldValue and newValue, when the “mode” changes value.

Note that it is illegal for instances of BeanContextChild to call setDesignTime() on instances of BeanContext that they are nested within.

5.4 BeanContext Visibility support.

JavaBeans with associated presentation, or GUI, may be instantiated in environments where the ability to present that GUI is either not physically possible (when the hardware is not present), or is not appropriate under the current conditions (running in a server context instead of a client).

The first version of the JavaBeans Specification introduced the java.beans.Visibility interface in order to provide a mechanism for JavaBeans to have their “visible” state, or ability to render a GUI, controlled from their environment.

BeanContexts that wish to enforce a particular policy regarding the ability of their children to present GUI, shall use the java.beans.Visibility interface to control their children.

5.5 Determining Locale from a BeanContext

BeanContexts may have a locale associated with them, in order to associate and propagate this important attribute across the JavaBeans nested therein.

Therefore, BeanContexts, shall be required to fire the appropriate java.beans.PropertyChangeEvent, with propertyName = “locale”, oldValue = the reference to the previous value of the Locale delegate, and newValue = the reference to the new value of the Locale delegate, in order to notify its Listeners of any change in Locale.

Setting and getting the value of the Locale on the BeanContext is implementation dependent.

6.0 Support classes

In order to ease the implementation of this relatively complex protocol a “helper” classes are provided; java.beans.beancontext.BeanContextChildSupport, java.beans.beancontext.BeanContextSupport, and java.beans.beancontext.BeanContextServicesSupport. These classes are designed to either be subclassed, or delegated implicitly by another object, and provides fully compliant (extensible) implementations of the protocols embodied herein.

1Note, if the remove() was invoked as a result of the BeanContext receiving an unexpected PropertyChan- geEvent notification as a result of a 3rd party invoking setBeanContext() then the remove implementation shall not invoke setBeanContext(null) on that child as part of the remove() semantics, since to do so would overwrite the value previously set by the 3rd party.
2Unfortunately because of method name collisions between Component and Collection a Component can- not implement BeanContext or Collection directly and must model the capability with a “HasA” rather than an “IsA” relationship.
3I don’t like this name much but I am struggling for a better alternative! (we are stuck with it)
4Note: Since simple JavaBeans have no knowledge of a BeanContext, it is not advisable to introduce such instances into the hierarchy since there is no mechanism for these simple JavaBeans to remove them- selves from the hierarchy and thus subsequently be garbage collected.
5AppletContext objects expose a list of Applet objects they “contain”, unfortunately the current Applet or AppletStub API’s as defined, provide no mechanism for the AppletContext to discover its Applets from its AppletStubs, or for an AppletStub to inform its AppletContext of its Applet. Therefore we will have to assume that this binding/discovery can occur in order for this mechanism to be worthwhile in java.beans.instantiate().

Contents
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Extensible Runtime Containment and Server Protocol for JavaBeans Version 1.0

Documentation Contents

Extensible Runtime Containment and Server Protocol for JavaBeans

Version 1.0

Laurence Cable

Contents | Previous | Next

Extensible Runtime Containment and Server Protocol for JavaBeans Version 1.0

2.0 API Specification

3.0 Overloading java.beans.instantiate() static method

4.0 Providing better support for Beans that are also Applets

5.0 Standard/Suggested Conventions for BeanContext Services

6.0 Support classes

Contents | Previous | Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Binary Literals

In Java SE 7, the integral types (byte, short, int, and long) can also be expressed using the binary number system. To specify a binary literal, add the prefix 0b or 0B to the number. The following examples show binary literals:

// An 8-bit 'byte' value:
byte aByte = (byte)0b00100001;

// A 16-bit 'short' value:
short aShort = (short)0b1010000101000101;

// Some 32-bit 'int' values:
int anInt1 = 0b10100001010001011010000101000101;
int anInt2 = 0b101;
int anInt3 = 0B101; // The B can be upper or lower case.

// A 64-bit 'long' value. Note the "L" suffix:
long aLong = 0b1010000101000101101000010100010110100001010001011010000101000101L;

Binary literals can make relationships among data more apparent than they would be in hexadecimal or octal. For example, each successive number in the following array is rotated by one bit:

public static final int[] phases = {
  0b00110001,
  0b01100010,
  0b11000100,
  0b10001001,
  0b00010011,
  0b00100110,
  0b01001100,
  0b10011000
}

In hexadecimal, the relationship among the numbers is not readily apparent:

public static final int[] phases = {
    0x31, 0x62, 0xC4, 0x89, 0x13, 0x26, 0x4C, 0x98
}

You can use binary integral constants in code that you can verify against a specifications document, such as a simulator for a hypothetical 8-bit microprocessor:

public State decodeInstruction(int instruction, State state) {
  if ((instruction & 0b11100000) == 0b00000000) {
    final int register = instruction & 0b00001111;
    switch (instruction & 0b11110000) {
      case 0b00000000: return state.nop();
      case 0b00010000: return state.copyAccumTo(register);
      case 0b00100000: return state.addToAccum(register);
      case 0b00110000: return state.subFromAccum(register);
      case 0b01000000: return state.multiplyAccumBy(register);
      case 0b01010000: return state.divideAccumBy(register);
      case 0b01100000: return state.setAccumFrom(register);
      case 0b01110000: return state.returnFromCall();
      default: throw new IllegalArgumentException();
    }
  } else {
    final int address = instruction & 0b00011111;
    switch (instruction & 0b11100000) {
      case 0b00100000: return state.jumpTo(address);
      case 0b01000000: return state.jumpIfAccumZeroTo(address);
      case 0b01000000: return state.jumpIfAccumNonzeroTo(address);
      case 0b01100000: return state.setAccumFromMemory(address);
      case 0b10100000: return state.writeAccumToMemory(address);
      case 0b11000000: return state.callTo(address);
      default: throw new IllegalArgumentException();
    }
  }
}

You can use binary literals to make a bitmap more readable:

public static final short[] HAPPY_FACE = {
   (short)0b0000011111100000;
   (short)0b0000100000010000;
   (short)0b0001000000001000;
   (short)0b0010000000000100;
   (short)0b0100000000000010;
   (short)0b1000011001100001;
   (short)0b1000011001100001;
   (short)0b1000000000000001;
   (short)0b1000000000000001;
   (short)0b1001000000001001;
   (short)0b1000100000010001;
   (short)0b0100011111100010;
   (short)0b0010000000000100;
   (short)0b0001000000001000;
   (short)0b0000100000010000;
   (short)0b0000011111100000;
}
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.BinaryTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.BinaryTree

  • Packages that use BinaryTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of BinaryTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type BinaryTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitBinary(BinaryTree node, P p)

    • Uses of BinaryTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type BinaryTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitBinary(BinaryTree node, P p)
      R | TreeScanner.visitBinary(BinaryTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Blacklist Jar Feature

Support for blacklisting signed jar files has been added to 6u14. A blacklist is a list of signed jars that contain serious security vulnerabilities that can be exploited by untrusted applets or applications. A system-wide blacklist will be distributed with each JRE release. Java Plugin and Web Start will consult this blacklist and refuse to load any class or resource contained in a jar file that's on the blacklist. By default, blacklist checking is enabled. The deployment.security.blacklist.check deployment configuration property can be used to toggle this behavior. The blacklist is updated using the property deployment.blacklist.url which defaults to https://javadl-esd-secure.oracle.com/update/blacklist.

The blacklist entries are the union of the blacklist files pointed to by the deployment.system.security.blacklist and deployment.user.security.blacklist properties. By default, deployment.system.security.blacklist points to the blacklist file in the jre/lib/security directory, and deployment.user.security.blacklist points to a blacklist file that contains additional entries added by a user.

The blacklist is a text file with the following format:

    attribute : value

Each jar file on the blacklist is identified by the x-Digest-Manifest attribute where x is the name of the MessageDigest algorithm, and the value is the base64 encoded hash value of the Manifest. Comments are denoted by lines starting with the # (number) symbol.

Here is an example:

    # Buggy Utilities, version 1.0
    SHA1-Digest-Manifest : QONXbQg+EtNOguIOAgpUUOadhv8=
    # Malware Inc., version 99.99
    SHA-256-Digest-Manifest : SewaudBCZ3iXt1KX0BeFHpQiiM1xYLtvLw3Ow2RJfcs=
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.doctree.BlockTagTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.BlockTagTree

  • Packages that use BlockTagTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).

    • Uses of BlockTagTree in com.sun.source.doctree

      Subinterfaces of BlockTagTree in com.sun.source.doctree
      Modifier and Type Interface and Description
      interface  AuthorTree
      A tree node for an @author block tag.
      interface  DeprecatedTree
      A tree node for an @deprecated block tag.
      interface  ParamTree
      A tree node for an @param block tag.
      interface  ReturnTree
      A tree node for an @return block tag.
      interface  SeeTree
      A tree node for an @see block tag.
      interface  SerialDataTree
      A tree node for an @serialData block tag.
      interface  SerialFieldTree
      A tree node for an @serialData block tag.
      interface  SerialTree
      A tree node for an @serial block tag.
      interface  SinceTree
      A tree node for an @since block tag.
      interface  ThrowsTree
      A tree node for an @exception or @throws block tag.
      interface  UnknownBlockTagTree
      A tree node for an unrecognized inline tag.
      interface  VersionTree
      A tree node for an @version block tag.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.BlockTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.BlockTree

  • Packages that use BlockTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of BlockTree in com.sun.source.tree

      Methods in com.sun.source.tree that return BlockTree
      Modifier and Type | Method and Description
      BlockTree | SynchronizedTree.getBlock()
      BlockTree | CatchTree.getBlock()
      BlockTree | TryTree.getBlock()
      BlockTree | MethodTree.getBody()
      BlockTree | TryTree.getFinallyBlock()
      Methods in com.sun.source.tree with parameters of type BlockTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitBlock(BlockTree node, P p)

    • Uses of BlockTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type BlockTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitBlock(BlockTree node, P p)
      R | TreeScanner.visitBlock(BlockTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.BooleanType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.BooleanType

No usage of com.sun.jdi.BooleanType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.BooleanValue (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.BooleanValue

  • Packages that use BooleanValue
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of BooleanValue in com.sun.jdi

      Methods in com.sun.jdi that return BooleanValue
      Modifier and Type Method and Description
      BooleanValue VirtualMachine.mirrorOf(boolean value)
      Creates a BooleanValue for the given value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.Bootstrap (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.Bootstrap

No usage of com.sun.jdi.Bootstrap
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.event.BreakpointEvent (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.BreakpointEvent

No usage of com.sun.jdi.event.BreakpointEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.BreakpointRequest (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.BreakpointRequest

  • Packages that use BreakpointRequest
    Package Description
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of BreakpointRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return BreakpointRequest
      Modifier and Type Method and Description
      BreakpointRequest EventRequestManager.createBreakpointRequest(Location location)
      Creates a new disabled BreakpointRequest.
      Methods in com.sun.jdi.request that return types with arguments of type BreakpointRequest
      Modifier and Type Method and Description
      List<BreakpointRequest> EventRequestManager.breakpointRequests()
      Return an unmodifiable list of the enabled and disabled breakpoint requests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.BreakTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.BreakTree

  • Packages that use BreakTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of BreakTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type BreakTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitBreak(BreakTree node, P p)

    • Uses of BreakTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type BreakTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitBreak(BreakTree node, P p)
      R | TreeScanner.visitBreak(BreakTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Submit a Bug Report

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

17 Submit a Bug Report

This chapter provides guidance on how to submit a bug report. It includes suggestions about what to try before submitting a report and what data to collect for the report.

This chapter contains the following sections:

  • Check for Fixes in Update Releases

  • Prepare to Submit a Bug Report

  • Collect Data for a Bug Report

  • Collect Core Dumps

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Check for Fixes in Update Releases

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

17.1 Check for Fixes in Update Releases

The current platform is Java SE 8. Regularly scheduled updates to this release contain fixes for a set of critical bugs identified since the initial release of the platform. When an update release becomes available, it becomes the default download at the Java SE Downloads site.

The download site includes release notes that lists the bug fixes in the release. Each bug in the list is linked to the bug description in the bug database. The release notes also includes the list of fixes in previous update releases. If you encounter an issue, or suspect a bug, then, as an early step in the diagnosis, check the list of fixes that are available in the most recent update release.

Sometimes it is not obvious if an issue is a duplicate of a bug that has been already fixed. It is always recommended to test with the available latest update release to see if the issue persists.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Prepare to Submit a Bug Report

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

17.2 Prepare to Submit a Bug Report

Before submitting a bug report, consider the following recommendations:

  • First of all, test with the latest update release to see if the issue persists. Frequently, a bug report submitted for an older release is first suggested to test with the available latest update release or even an available latest EA (Early Access) release. The EA release may contain many new features and bug fixes.

  • Collect as much relevant data as possible. For example, generate a thread-dump in the case of a deadlock, or locate the core file (where applicable) and hs_err file in the case of a crash. In every case, it is important to document the environment and the actions performed just before the problem is encountered.

  • Where applicable, try to restore the original state and reproduce the problem using the documented steps. This helps to determine if the problem is reproducible or an intermittent issue.

  • If the issue is reproducible, try to narrow down the problem. In some cases, a bug can be demonstrated with a small standalone test case. Bugs that are demonstrated by small test cases will typically be easy to diagnose when compared to test cases that consist of a large complex application.

  • Search the bug database to see if this bug or a similar bug has been reported. If the bug has already been reported, the bug report might have further information, such as the following:

    • If the bug has already been fixed, the release in which it was fixed.

    • A workaround for the problem.

    • Comments in the evaluation that explain, in further detail, the circumstances that cause the bug to arise.

  • If you conclude that the bug has not already been reported, submit a new bug.

Before submitting a bug, verify that the environment where the problem arises is a supported configuration. See the Supported System Configurations.

In addition to the system configurations, check the list of supported locales. See the Supported Locales web page.

In the case of Oracle Solaris, check the recommended patch cluster for the operating system release to ensure that the recommended patches are installed.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Collect Data for a Bug Report

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

17.3 Collect Data for a Bug Report

In general, it is recommended to test with the available latest update release or even an available latest EA (Early Access) release to see if the issue persists and then collect as much relevant data as possible when you create a bug report or submit a support call. The following sections suggest the data to collect and, where applicable, it provides recommendations for the commands or general procedure for obtaining the data.

  • Hardware Details

  • Operating System Details

  • Java SE Version

  • Command-Line Options

  • Environment Variables

  • Fatal Error Log

  • Core or Crash Dump

  • Detailed Description of the Problem

  • Logs and Traces

  • Results from Troubleshooting Steps

17.3.1 Hardware Details

Sometimes a bug arises or can be reproduced only on certain hardware configurations. If a fatal error occurs, the error log might contain the hardware details. If an error log is not available, document in the bug report the number and the type of processors in the machine, the clock speed, and, where applicable and if known, some details on the features of that processor. For example, in the case of Intel processors, it might be relevant that hyper-threading is available.

17.3.2 Operating System Details

On the Oracle Solaris operating system, the showrev -a command prints the operating system version and patch information.

On Linux, it is important to know which distribution and version is used. Sometimes the /etc/*release file indicates the release information, but as components and packages can be upgraded independently, it is not always a reliable indication of the configuration. Therefore, in addition to the information from the *release file, collect the following information:

  • The kernel version. This can be obtained using the uname -a command.

  • The glibc version. The rpm -q glibc command indicates the patch level of glibc.

  • The thread library. There are two thread libraries for Linux, namely LinuxThreads and NPTL. The LinuxThreads library is used on 2.4 and older kernels and has "fixed stack" and "floating stack" variants. The Native POSIX Thread Library (NPTL) is used on the 2.6 kernel. Some Linux releases (such as RHEL3) include backports of NPTL to the 2.4 kernel. Use the command getconf GNU_LIBPTHREAD_VERSION to determine which thread library is used. If the getconf command returns an error to say that the variable does not exist, then it is likely that you are using an old kernel with the LinuxThreads library.

17.3.3 Java SE Version

The Java SE version string can be obtained using the java -version command.

Multiple versions of Java SE may be installed on the same machine. Therefore, ensure that you use the appropriate version of the java command by verifying that the installation bin directory appears in your PATH environment variable before other installations.

17.3.4 Command-Line Options

If the bug report does not include a fatal error log, it is important to document the full command line and all its options. This includes any options that specify heap settings (for example, the -mx option) or any -XX options that specify HotSpot specific options.

One of the features in Java SE is garbage collector ergonomics. On server-class machines the java command launches the HotSpot Server VM and a parallel garbage collector. A machine is considered to be a server machine if it has at least two processors and 2GB or more of memory.

The -XX:+PrintCommandLineFlags option can be used to verify the command-line options. This option prints all command-line flags to the VM. The command-line options can also be obtained for a running VM or core file using the jmap utility.

17.3.5 Environment Variables

Sometimes problems arise due to environment variable settings. When creating the bug report, indicate the values of the following Java environment variables (if set).

  • JAVA_HOME

  • JRE_HOME

  • JAVA_TOOL_OPTIONS

  • _JAVA_OPTIONS

  • CLASSPATH

  • JAVA_COMPILER

  • PATH

  • USERNAME

In addition, collect the following operating-system-specific environment variables.

  • On Oracle Solaris and Linux operating systems, collect the values of the following environment variables.

    • LD_LIBRARY_PATH

    • LD_PRELOAD

    • SHELL

    • DISPLAY

    • HOSTTYPE

    • OSTYPE

    • ARCH

    • MACHTYPE

  • On Linux, also collect the values of the following environment variables.

    • LD_ASSUME_KERNEL

    • _JAVA_SR_SIGNUM

  • On Windows, collect the values of the following environment variables.

    • OS

    • PROCESSOR_IDENTIFIER

    • _ALT_JAVA_HOME_DIR

17.3.6 Fatal Error Log

It is recommended to test with the latest update release to see if the problem persists.

When a fatal error occurs, an error log is created. For detailed information about this file, see Appendix A.

The error log contains much information obtained at the time of the fatal error, such as version and environment information, details on the threads that provoked the crash, and so forth.

If the fatal error log is generated, be sure to include it in the bug report or support call.

17.3.7 Core or Crash Dump

Core and crash dumps can be very useful when trying to diagnose a system crash or hung process. The procedure for generating a dump is described in Collect Core Dumps.

17.3.8 Detailed Description of the Problem

When creating a problem description, try to include as much relevant information as possible. Describe the application, the environment, and most importantly the events leading up to the time when the problem was encountered.

  • If the problem is reproducible, list the steps that are required to demonstrate the problem.

  • If the problem can be demonstrated with a small test case, include the test case and the commands to compile and execute the test case.

  • If the test case or problem requires third-party code (for example, a commercial or open source library or package), provide details on where and how to obtain the library.

Sometimes the problem can be reproduced only in a complex application environment. In this case, the description, coupled with logs, core file, and other relevant information, might be the sole means to diagnose the issue. In these situations the description should indicate if the submitter is willing to run further diagnosis or run test binaries on the system where the issue arises.

17.3.9 Logs and Traces

In some cases, log or trace output can help to quickly determine the cause of a problem.

For example, in the case of a performance issue the output of the -verbose:gc option can help in diagnosing the problem. (This is the option to enable output from the garbage collector.)

In other cases the output from the jstat command can be used to capture statistical information over the time period leading up to the problem.

In the case of a deadlock or a hung VM (for example, due to a loop) the thread stacks can help diagnose the problem. The thread stacks are obtained by pressing Control+\ on Oracle Solaris and Linux and Control+Break on Windows.

In general, include all relevant logs, traces and other output in the bug report or support call.

17.3.10 Results from Troubleshooting Steps

Before submitting the bug report, be sure to document any troubleshooting steps that were performed.

For example, if the problem is a crash and the application has native libraries, you might have already run the application with the -Xcheck:jni option to reduce the likelihood that the bug is in the native code. Another case could be a crash that occurs with the HotSpot Server VM (-server option). If you have also tested with the HotSpot Client VM (-client option) and the problem does not occur, this gives an indication that the bug might be specific to the HotSpot Server VM.

In general, include in the bug report all troubleshooting steps and results that have already occurred. This type of information can often reduce the time that is required to diagnose an issue.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Collect Core Dumps

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

17.4 Collect Core Dumps

This section explains how to generate and collect core dumps (also known as crash dumps). A core dump or a crash dump is a memory snapshot of a running process. A core dump can be automatically created by the operating system when a fatal or unhandled error (for example, signal or system exception) occurs. Alternatively, a core dump can be forced by means of system-provided command-line utilities. Sometimes a core dump is useful when diagnosing a process that appears to be hung; the core dump may reveal information about the cause of the hang.

When collecting a core dump, be sure to gather other information about the environment so that the core file can be analyzed (for example, OS version, patch information, and the fatal error log).

Core dumps do not usually contain all the memory pages of the crashed or hung process. With each of the operating systems discussed here, the text (or code) pages of the process are not included in core dumps. But to be useful, a core dump must consist of pages of heap and stack as a minimum. Collecting non-truncated good core dump files is essential for postmortem analysis of the crash.

The following sections describe scenarios for collecting core dumps.

  • Collect Core Dumps on Oracle Solaris

  • Collect Core Dumps on Linux

  • Reasons for Not Getting a Core File

  • Collect Crash Dumps on Windows

17.4.1 Collect Core Dumps on Oracle Solaris

With the Oracle Solaris operating system, unhandled signals such as a segmentation violation, illegal instruction, and so forth, result in a core dump. By default, the core dump is created in the current working directory of the process and the name of the core dump file is core. The user can configure the location and name of the core dump using the core file administration utility, coreadm. This procedure is fully described in the man page for the coreadm utility.

The ulimit utility is used to get or set the limitations on the system resources available to the current shell and its descendants. Use the ulimit -c command to check or set the core file size limit. Make sure that the limit is set to unlimited; otherwise the core file could be truncated.

Note:

ulimit is a Bash shell built-in command; on a C shell, use the limit command.

Ensure that any scripts that are used to launch the VM or your application do not disable core dump creation.

The gcore utility can be used to get a core image of running processes. This utility accepts a process id (pid) of the process for which you want to force core dump.

To get the list of Java processes running on the machine, you can use any of the following commands:

  • ps -ef | grep java

  • pgrep java

  • jps

Note:

The jps command-line utility does not perform name matching (that is, looking for "java" in the process command name) and so it can list Java VM embedded processes as well as the Java processes.

The following are two methods to collect core dumps on Oracle Solaris.

  • ShowMessageBoxOnError option on Oracle Solaris:

    A Java process can be started with the -XX:+ShowMessageBoxOnError command-line option. When a fatal error is encountered, the process prints a message to standard error and waits for a yes or no response from standard input. Example 17-1 shows the output when an unexpected signal occurs.

    Example 17-1 Unexpected Signal Error on Solaris

    =======================================================================
Unexpected Error
-----------------------------------------------------------------------
SIGSEGV (0xb) at pc=0xfeba31ac, pid=8677, tid=2
Do you want to debug the problem?
To debug, run 'dbx - 8677'; then switch to thread 2
Enter 'yes' to launch dbx automatically (PATH must include dbx)
Otherwise, press RETURN to abort...
=======================================================================

    Before answering yes or pressing RETURN (Enter), use the gcore utility to force a core dump. Then you can type yes to launch the dbx debugger.

  • Suspend a process with truss utility:

    In situations where it is not possible to specify the -XX:+ShowMessageBoxOnError option, you might be able to use the truss utility. This Oracle Solaris operating system utility is used to trace system calls and signals. You can use this utility to suspend the process when it reaches a specific function or system call.

    The command in Example 17-2 shows how to use the truss utility to suspend a process when the exit system call is executed (in other words, the process is about to exit).

    Example 17-2 Use truss Utility to Suspend a Process

    $ truss -t \!all -s \!all -T exit -p pid

    When the process calls exit, it will be suspended. At this point, you can attach the debugger to the process or call gcore to force a core dump.

17.4.2 Collect Core Dumps on Linux

On the Linux operating system, unhandled signals such as segmentation violation, illegal instruction, and so forth, result in a core dump. By default, the core dump is created in the current working directory of the process and the name of the core dump file is core.pid, where pid is the process id of the crashed Java process.

The ulimit utility is used to get or set the limitations on the system resources available to the current shell and its descendants. Use the ulimit -c command to check or set the core file size limit. Make sure that the limit is set to unlimited; otherwise the core file could be truncated.

Note:

ulimit is a Bash shell built-in command; on a C shell, use the limit command.

Ensure that any scripts that are used to launch the VM or your application do not disable core dump creation.

You can use the gcore command in the gdb (GNU Debugger) interface to get a core image of a running process. This utility accepts the pid of the process for which you want to force the core dump.

To get the list of Java processes running on the machine, you can use any of the following commands:

  • ps -ef | grep java

  • pgrep java

  • jps

Note:

The jps command-line utility does not perform name matching (that is, looking for "java" in the process command name) and so it can list Java VM embedded processes as well as the Java processes.

The following is one option to collect core dumps on Linux.

  • ShowMessageBoxOnError option in Linux:

    A Java process can be started with the -XX:+ShowMessageBoxOnError command-line option. When a fatal error is encountered, the process prints a message to standard error and waits for a yes or no response from standard input. Example 17-3 shows the output when an unexpected signal occurs.

    Example 17-3 Unexpected Signal Error in Linux

    =======================================================================
Unexpected Error
-----------------------------------------------------------------------
SIGSEGV (0xb) at pc=0x06232e5f, pid=11185, tid=8194
Do you want to debug the problem?
To debug, run 'gdb /proc/11185/exe 11185'; then switch to thread 8194
Enter 'yes' to launch gdb automatically (PATH must include gdb)
Otherwise, press RETURN to abort...
=======================================================================

    Type yes to launch the gdb (GNU Debugger) interface, as suggested by the error report shown above. In the gdb prompt, you can give the gcore command. This command creates a core dump of the debugged process with the name core.pid, where pid is the process ID of the crashed process. Make sure that the gdb gcore command is supported in your versions of gdb. Look for help gcore in the gdb command prompt.

17.4.3 Reasons for Not Getting a Core File

The following list explains the major reasons that a core file might not be generated. This list pertains to both Oracle Solaris and Linux operating systems, unless specified otherwise.

  • The current user does not have permission to write in the current working directory of the process.

  • The current user has write permission on the current working directory, but there is already a file named core that has read-only permission.

  • The current directory does not have enough space or there is no space left.

  • The current directory has a subdirectory named core.

  • The current working directory is remote. It might be mapped by NFS (Network File System), and NFS failed just at the time the core dump was about to be created.

  • Oracle Solaris operating system only: The coreadm tool has been used to configure the directory and name of the core file, but any of the above reasons apply for the configured directory or filename.

  • The core file size limit is too low. Check your core file limit using the ulimit -c command (Bash shell) or the limit -c command (C shell). If the output from this command is not unlimited, the core dump file size might not be large enough. If this is the case, you will get truncated core dumps or no core dump at all. In addition, ensure that any scripts that are used to launch the VM or your application do not disable core dump creation.

  • The process is running a setuid program and therefore the operating system will not dump core unless it is configured explicitly.

  • Java specific: If the process received SIGSEGV or SIGILL but no core dump, it is possible that the process handled it. For example, HotSpot VM uses the SIGSEGV signal for legitimate purposes, such as throwing NullPointerException, deoptimization, and so forth. The signal is unhandled by the Java VM only if the current instruction (PC) falls outside Java VM generated code. These are the only cases in which HotSpot dumps core.

  • Java specific: The JNI Invocation API was used to create the VM. The standard Java launcher was not used. The custom Java launcher program handled the signal by just consuming it and produced the log entry silently. This situation has occurred with certain Application Servers and Web Servers. These Java VM embedding programs transparently attempt to restart (fail over) the system after an abnormal termination. In this case, the fact that a core dump is not produced is a feature and not a bug.

17.4.4 Collect Crash Dumps on Windows

On Windows operating system there are three types of crash dumps:

  • Dr. Watson logfile, which is a text error log file that includes faulting stack trace and a few other details.

  • User minidump, which can be considered a "partial" core dump. It is not a complete core dump, because it does not contain all the useful memory pages of the process.

  • Dr. Watson full-dump, which is equivalent to a Unix core dump. This dump contains most memory pages of the process (except for code pages).

When an unexpected exception occurs on Windows, the action taken depends on two values in the following registry key:

\\HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

The two values are named Debugger and Auto. The Auto value indicates if the debugger specified in the value of the Debugger entry starts automatically when an application error occurs.

  • A value of 0 for Auto means that the system displays a message box notifying the user when an application error occurs.

  • A value of 1 for Auto means that the debugger starts automatically.

The value of Debugger is the debugger command that is to be used to debug program errors.

When a program error occurs, Windows examines the Auto value and if the value is 0 it executes the command in the Debugger value. If the value for Debugger is a valid command, a message box is created with two buttons: OK and Cancel. If the user clicks OK, the program is terminated. If the user clicks Cancel, the specified debugger is started. If the value for the Auto entry is set to 1 and the value for the Debugger entry specifies the command for a valid debugger, the system automatically starts the debugger and does not generate a message box.

The following are two ways to collect crash dump on Windows.

  • Configure Dr.Watson:

    The Dr. Watson debugger is used to create crash dump files. By default, the Dr. Watson debugger (drwtsn32.exe) is installed into the Windows system folder (%SystemRoot%\System32).

    To install Dr. Watson as the postmortem debugger, run the following command:

    drwtsn32 -i

    To configure name and location of crash dump files, run drwtsn32 without any options.

    In the Dr. Watson GUI window, make sure that the Create Crash Dump File check box is selected and that the crash dump file path and log file path are configured in their respective text fields.

    Dr. Watson may be configured to create a full dump using the registry. The registry key is shown in Example 17-4.

    Example 17-4 Registry Key to Create a Full Dump

    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Entry Name: CreateCrashDump
Value: (0 = disabled, 1 = enabled)

    Note: If the application handles the exception, then the registry-configured debugger is not invoked. In that case it might be appropriate to use the -XX:+ShowMessageBoxOnError command-line option to force the process to wait for user intervention on fatal error conditions.

  • Force a crash dump:

    On the Windows operating system, the userdump command-line utility can be used to force a Dr. Watson dump of a running process. The userdump utility does not ship with Windows but instead is released as a component of the OEM Support Tools package.

    An alternative way to force a crash dump is to use the windbg debugger. The main advantage of using windbg is that it can attach to a process in a non-invasive manner (that is, read-only). Normally Windows terminates a process after a crash dump is obtained but with the non-invasive attach it is possible to obtain a crash dump and let the process continue. To attach the debugger non-invasively requires selecting the Attach to Process option and the Noninvasive checkbox.

    When the debugger is attached, a crash dump can be obtained using the command shown in Example 17-5.

    Example 17-5 Get a Crash Dump

    .dump /f crash.dmp

    The windbg debugger is included in the "Debugging Tools for Windows" download.

    An additional utility in this download is the dumpchk.exe utility, which can verify that a memory dump file has been created correctly.

    Both userdump.exe and windbg require the pid of the process. The userdump -p command lists the process and program for all processes. This is useful if you know that the application is started with the java.exe launcher. However, if a custom launcher is used (embedded VM), it might be difficult to recognize the process. In that case you can use the jps command-line utility as it lists the pids of the Java processes only.

    As with Oracle Solaris and Linux operating systems, you can also use the -XX:+ShowMessageBoxOnError command-line option on Windows. When a fatal error is encountered, the process shows a message box and waits for a yes or no response from the user.

    Before clicking Yes or No, you can use the userdump.exe utility to generate the Dr. Watson dump for the Java process. This utility can also be used in cases when the process appears to be hung.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration bundle_file_struc.png

Documentation Contents

Image shows the directory structure in two columns for the files and folders in a self-contained application package. The first column shows the top level folder named bundles with the subfolders named ColorfulCircles and runtime. The ColorfulCircles folder has a subfolder named app, which has a subfolder named web-files. The runtime folder has a subfolder named jre, which has the subfolders named bin and lib.

The second column shows folders named app and runtime, and files named ColorfulCircles.exe and ColorfulCircles.ico.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.ByteType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ByteType

No usage of com.sun.jdi.ByteType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.ByteValue (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ByteValue

  • Packages that use ByteValue
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of ByteValue in com.sun.jdi

      Methods in com.sun.jdi that return ByteValue
      Modifier and Type Method and Description
      ByteValue VirtualMachine.mirrorOf(byte value)
      Creates a ByteValue for the given value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Supported Calendars

This page documents supported calendar systems.

1. Introduction

Calendar is an abstract base class for converting between a Date object and a set of integer fields such as YEAR, MONTH, DAY, HOUR, and so on. Subclasses of Calendar interpret a Date according to the rules of a specific calendar system. The platform provides one public concrete subclass of Calendar: GregorianCalendar. The factory method, Calendar.getInstance, returns the concrete calendar system implementation for the given Locale. The following are supported calendar systems:

Locale | Calendar System | Since (JRE version)
th_TH (with any variant) | Thai Buddhist calendar | 1.4
ja_JP_JP | Japanese imperial calendar | 1.6
Any except above Locales | Gregorian calendar (GregorianCalendar) | 1.1

2. Thai Buddhist Calendar

In Thailand, the Gregorian calendar system is used with the Buddhist Era-based year numbering. In Buddhist Era (พุทธศักราช) or B.E. (พ.ศ.) for short, year 1 corresponds to BCE (BC) 543 (Julian). Therefore, Gregorian year + 543 is the B.E. year value.

The Calendar.getInstance method returns a Thai Buddhist calendar instance if a Thai locale is specified, which is determined by its language and country values. This Thai Buddhist calendar implementation supports dates accurately from B.E. 2484 (1941 Gregorian). The historical calendar system transitions are not supported by the implementation. The Calendar.ERA value for Buddhist Era is 1.

3. Japanese Imperial Calendar

In Japan, the Gregorian calendar system is used with the imperial era-based year numbering. An imperial era starts from an emperor's ascension and its year number is reset to 1 with a new era name. The first year of an imperial era is not in sync with the Gregorian year boundaries, and any day could be the first day of an imperial era. For example, the current era started from January 8, 1989 (Gregorian). However, the month and the day of month numberings are in sync with the Gregorian calendar system.

The Calendar.getInstance method returns a Japanese imperial calendar instance if ja_JP_JP locale is specified. This implementation supports the eras since Meiji with the following transition dates.

Era Name
(in Japanese)
 Era
Abbr.
 ERA
 field value
 Transition date and time
(Gregorian)
- (西暦)
 -
 0
 -
Meiji (明治)
 M
 1
 1868-01-01 00:00:00 local time
Taisho (大正)
 T
 2
 1912-07-30 00:00:00 local time
Showa (昭和)
 S
 3
 1926-12-25 00:00:00 local time
Heisei (平成)
 H
 4
 1989-01-08 00:00:00 local time

Before Meiji, the Gregorian year numbering is supported. Unlike GregorianCalendar, the Japanese imperial calendar implementation doesn't support any Julian to Gregorian transition, and the year numbering before Gregorian 1 is 0, -1, -2, ..., not 1, 2, 3, ... Strictly speaking, the Gregorian calendar is in use from 1873 (Meiji 5) and other calendar systems were used before that year. However, the implementation defines the first day of Meiji as January 1, 1868, which is not historically accurate. The Japanese decrees related to calendar systems don't specify how to deal with time zones outside of Japan. The implementation assumes that era transitions occur at midnight in local time in any time zone.

In the Calendar API, some fields are in sync with the year value for the era transitions and therefore handle irregular rules in the first year of an imperial era. The following table shows those fields.

Calendar field
 Description
WEEK_OF_YEAR
         To determine the first WEEK_OF_YEAR of year 1 in each era, the same rules as determining the first week by the first day of week and minimal days in the first week values are applied. For example, if the first day of week is SUNDAY and the minimal days in the first week is 1, the WEEK_OF_YEAR value of 1926-12-18 is 51 of Taisho 15 and the value of 1926-12-25 is 1 of Showa 1.
DAY_OF_YEAR
         The DAY_OF_YEAR value of the first day of each era is 1. For example, looking at the transition between the Showa and Heisei eras, the last day of the Showa era (Showa 64.01.07, gregorian value 1989-01-07) is 7 and the next day, which is the first day of the Heisei era (Heisei 1.01.08), is 1. The getLeastMaximum method returns the minimum value of all year 1 lengths in days.

4. Formatting and Parsing Non-GregorianCalendar Dates

A DateFormat instance has a Calendar instance for internal date-time conversions based on the given Locale or the default one. The same rule is applied for creating a Calendar instance. For example, if ja_JP_JP locale is specified, the DateFormat.getDateInstance method returns a DateFormat instance that handles Japanese imperial calendar dates. The following code:
DateFormat df = DateFormat.getDateInstance(DateFormat.FULL,
                                           new Locale("ja", "JP", "JP"));
System.out.println(df.format(new Date()));
will produce the output, like:
平成17年10月25日
Also, the DateFormat.parse method parses a date string with an imperial era. The following code:
System.out.println(df.parse("平成元年10月25日"));
will produce the output in the Asia/Tokyo time zone:
Wed Oct 25 00:00:00 JST 1989
Note that a Date object returned by the DateFormat.parse method represents a corresponding Gregorian date. To convert a Date to a Japanese imperial date, the Calendar.setTime method must be used with the given Date.

In SimpleDateFormat, the following rules are applied for the Thai Buddhist and Japanese imperial calendar systems.

Calendar system
         Pattern Letter
         Description
Thai Buddhist G
         The number of pattern letters doesn't affect displayed era names.
Thai Buddhist y
         The same rule of the number of pattern letters as GregorianCalendar is applied.
Japanese imperial G
         For formatting, if the number of pattern letters is 4 or more, the long era names (e.g., "平成") are used. Otherwise, the abbreviations (e.g., "H") are used. For parsing, both the long era names and abbreviations are accepted.
Japanese imperial y
         For formatting, if the number of pattern letters is 4 or more, the first year of an era is formatted as the locale specific representation, such as "元" in Japanese locale. Other year values are displayed as numbers. The 2- and 4-digit rules of GregorianCalendar date formatting are not applied. For parsing, both the locale specific representation and the number representation are accepted.

If the variant element is "TH" in Thai locale, the Thai digits are used for the date-time formatting. For example, the following code:
DateFormat df = DateFormat.getDateInstance(DateFormat.FULL,
                                           new Locale("th", "TH", "TH"));
System.out.println(df.format(new Date()));
will produce the output, like:
วันอังคารที่ ๒๕ ตุลาคม พ.ศ. ๒๕๔๘

5. Serialization Considerations

When a Calendar object returned by the Calendar.getInstance factory method is serialized and sent to another JVM, deserialization of the object fails if the destination JVM does not support the same Calendar subclass that has been used to create the serialized Calendar object. Please make sure that the same Calendar subclasses are supported in JVMs where you would like to exchange serialized Calendar objects.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class javax.smartcardio.Card (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.Card

    • Uses of Card in javax.smartcardio

      Methods in javax.smartcardio that return Card
      Modifier and Type Method and Description
      abstract Card CardTerminal.connect(String protocol)
      Establishes a connection to the card.
      abstract Card CardChannel.getCard()
      Returns the Card this channel is associated with.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardChannel (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardChannel

    • Uses of CardChannel in javax.smartcardio

      Methods in javax.smartcardio that return CardChannel
      Modifier and Type Method and Description
      abstract CardChannel Card.getBasicChannel()
      Returns the CardChannel for the basic logical channel.
      abstract CardChannel Card.openLogicalChannel()
      Opens a new logical channel to the card and returns it.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardException (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardException

    • Uses of CardException in javax.smartcardio

      Subclasses of CardException in javax.smartcardio
      Modifier and Type Class and Description
      class  CardNotPresentException
      Exception thrown when an application tries to establish a connection with a terminal that has no card present.
      Methods in javax.smartcardio that throw CardException
      Modifier and Type Method and Description
      abstract void Card.beginExclusive()
      Requests exclusive access to this card.
      abstract void CardChannel.close()
      Closes this CardChannel.
      abstract Card CardTerminal.connect(String protocol)
      Establishes a connection to the card.
      abstract void Card.disconnect(boolean reset)
      Disconnects the connection with this card.
      abstract void Card.endExclusive()
      Releases the exclusive access previously established using beginExclusive.
      abstract boolean CardTerminal.isCardPresent()
      Returns whether a card is present in this terminal.
      List<CardTerminal> CardTerminals.list()
      Returns an unmodifiable list of all available terminals.
      abstract List<CardTerminal> CardTerminals.list(CardTerminals.State state)
      Returns an unmodifiable list of all terminals matching the specified state.
      abstract CardChannel Card.openLogicalChannel()
      Opens a new logical channel to the card and returns it.
      abstract int CardChannel.transmit(ByteBuffer command, ByteBuffer response)
      Transmits the command APDU stored in the command ByteBuffer and receives the response APDU in the response ByteBuffer.
      abstract ResponseAPDU CardChannel.transmit(CommandAPDU command)
      Transmits the specified command APDU to the Smart Card and returns the response APDU.
      abstract byte[] Card.transmitControlCommand(int controlCode, byte[] command)
      Transmits a control command to the terminal device.
      abstract boolean CardTerminal.waitForCardAbsent(long timeout)
      Waits until a card is absent in this terminal or the timeout expires.
      abstract boolean CardTerminal.waitForCardPresent(long timeout)
      Waits until a card is present in this terminal or the timeout expires.
      void CardTerminals.waitForChange()
      Waits for card insertion or removal in any of the terminals of this object.
      abstract boolean CardTerminals.waitForChange(long timeout)
      Waits for card insertion or removal in any of the terminals of this object or until the timeout expires.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardNotPresentException (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardNotPresentException

No usage of javax.smartcardio.CardNotPresentException
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardPermission (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardPermission

No usage of javax.smartcardio.CardPermission
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardTerminal (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardTerminal

    • Uses of CardTerminal in javax.smartcardio

      Methods in javax.smartcardio that return CardTerminal
      Modifier and Type Method and Description
      CardTerminal CardTerminals.getTerminal(String name)
      Returns the terminal with the specified name or null if no such terminal exists.
      Methods in javax.smartcardio that return types with arguments of type CardTerminal
      Modifier and Type Method and Description
      List<CardTerminal> CardTerminals.list()
      Returns an unmodifiable list of all available terminals.
      abstract List<CardTerminal> CardTerminals.list(CardTerminals.State state)
      Returns an unmodifiable list of all terminals matching the specified state.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardTerminals (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardTerminals

    • Uses of CardTerminals in javax.smartcardio

      Methods in javax.smartcardio that return CardTerminals
      Modifier and Type Method and Description
      protected abstract CardTerminals TerminalFactorySpi.engineTerminals()
      Returns the CardTerminals created by this factory.
      CardTerminals TerminalFactory.terminals()
      Returns a new CardTerminals object encapsulating the terminals supported by this factory.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class javax.smartcardio.CardTerminals.State (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CardTerminals.State

    • Uses of CardTerminals.State in javax.smartcardio

      Methods in javax.smartcardio that return CardTerminals.State
      Modifier and Type Method and Description
      static CardTerminals.State CardTerminals.State.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static CardTerminals.State[] CardTerminals.State.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.smartcardio with parameters of type CardTerminals.State
      Modifier and Type Method and Description
      abstract List<CardTerminal> CardTerminals.list(CardTerminals.State state)
      Returns an unmodifiable list of all terminals matching the specified state.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.CaseTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.CaseTree

  • Packages that use CaseTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of CaseTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type CaseTree
      Modifier and Type | Method and Description
      List<? extends CaseTree> | SwitchTree.getCases()
      Methods in com.sun.source.tree with parameters of type CaseTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitCase(CaseTree node, P p)

    • Uses of CaseTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CaseTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitCase(CaseTree node, P p)
      R | TreeScanner.visitCase(CaseTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Catching Multiple Exception Types and Rethrowing Exceptions with Improved Type Checking

This page covers the following topics:

  • Handling More Than One Type of Exception
  • Rethrowing Exceptions with More Inclusive Type Checking

Handling More Than One Type of Exception

In Java SE 7 and later, a single catch block can handle more than one type of exception. This feature can reduce code duplication and lessen the temptation to catch an overly broad exception.

Consider the following example, which contains duplicate code in each of the catch blocks:

catch (IOException ex) {
     logger.log(ex);
     throw ex;
} catch (SQLException ex) {
     logger.log(ex);
     throw ex;
}

In releases prior to Java SE 7, it is difficult to create a common method to eliminate the duplicated code because the variable ex has different types.

The following example, which is valid in Java SE 7 and later, eliminates the duplicated code:

catch (IOException|SQLException ex) {
    logger.log(ex);
    throw ex;
}

The catch clause specifies the types of exceptions that the block can handle, and each exception type is separated with a vertical bar (|).

Note: If a catch block handles more than one exception type, then the catch parameter is implicitly final. In this example, the catch parameter ex is final and therefore you cannot assign any values to it within the catch block.

Bytecode generated by compiling a catch block that handles multiple exception types will be smaller (and thus superior) than compiling many catch blocks that handle only one exception type each. A catch block that handles multiple exception types creates no duplication in the bytecode generated by the compiler; the bytecode has no replication of exception handlers.

Rethrowing Exceptions with More Inclusive Type Checking

The Java SE 7 compiler performs more precise analysis of rethrown exceptions than earlier releases of Java SE. This enables you to specify more specific exception types in the throws clause of a method declaration.

Consider the following example:

  static class FirstException extends Exception { }
  static class SecondException extends Exception { }

  public void rethrowException(String exceptionName) throws Exception {
    try {
      if (exceptionName.equals("First")) {
        throw new FirstException();
      } else {
        throw new SecondException();
      }
    } catch (Exception e) {
      throw e;
    }
  }

This examples's try block could throw either FirstException or SecondException. Suppose you want to specify these exception types in the throws clause of the rethrowException method declaration. In releases prior to Java SE 7, you cannot do so. Because the exception parameter of the catch clause, e, is type Exception, and the catch block rethrows the exception parameter e, you can only specify the exception type Exception in the throws clause of the rethrowException method declaration.

However, in Java SE 7, you can specify the exception types FirstException and SecondException in the throws clause in the rethrowException method declaration. The Java SE 7 compiler can determine that the exception thrown by the statement throw e must have come from the try block, and the only exceptions thrown by the try block can be FirstException and SecondException. Even though the exception parameter of the catch clause, e, is type Exception, the compiler can determine that it is an instance of either FirstException or SecondException:

  public void rethrowException(String exceptionName)
  throws FirstException, SecondException {
    try {
      // ...
    }
    catch (Exception e) {
      throw e;
    }
  }

This analysis is disabled if the catch parameter is assigned to another value in the catch block. However, if the catch parameter is assigned to another value, you must specify the exception type Exception in the throws clause of the method declaration.

In detail, in Java SE 7 and later, when you declare one or more exception types in a catch clause, and rethrow the exception handled by this catch block, the compiler verifies that the type of the rethrown exception meets the following conditions:

  • The try block is able to throw it.
  • There are no other preceding catch blocks that can handle it.
  • It is a subtype or supertype of one of the catch clause's exception parameters.

The Java SE 7 compiler allows you to specify the exception types FirstException and SecondException in the throws clause in the rethrowException method declaration because you can rethrow an exception that is a supertype of any of the types declared in the throws.

In releases prior to Java SE 7, you cannot throw an exception that is a supertype of one of the catch clause's exception parameters. A compiler from a release prior to Java SE 7 generates the error, "unreported exception Exception; must be caught or declared to be thrown" at the statement throw e. The compiler checks if the type of the exception thrown is assignable to any of the types declared in the throws clause of the rethrowException method declaration. However, the type of the catch parameter e is Exception, which is a supertype, not a subtype, of FirstException andSecondException.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.CatchTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.CatchTree

  • Packages that use CatchTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of CatchTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type CatchTree
      Modifier and Type | Method and Description
      List<? extends CatchTree> | TryTree.getCatches()
      Methods in com.sun.source.tree with parameters of type CatchTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitCatch(CatchTree node, P p)

    • Uses of CatchTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CatchTree
      Modifier and Type | Method and Description
      abstract TypeMirror Trees.getLub(CatchTree tree)
      Gets the lub of an exception parameter declared in a catch clause.
      R | SimpleTreeVisitor.visitCatch(CatchTree node, P p)
      R | TreeScanner.visitCatch(CatchTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.CDATASection (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.CDATASection

  • Packages that use CDATASection
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of CDATASection in org.w3c.dom

      Methods in org.w3c.dom that return CDATASection
      Modifier and Type Method and Description
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


X.509 certificates

Documentation Contents

X.509 Certificates and Certificate Revocation Lists (CRLs)

In One Sentence: What is a Certificate?
What Applications use Certificates?
How do I get a Certificate?
What is Inside an X.509 Certificate?
What Java API Can Be Used to Access and Manage Certificates?
What Java Tool Can Generate, Display, Import, and Export X.509 Certificates?

In One Sentence: What is a Certificate?

A public-key certificate is a digitally signed statement from one entity, saying that the public key (and some other information) of another entity has some specific value.

Let us expand on some of the key terms used in this sentence:

Public Keys
These are numbers associated with a particular entity, and are intended to be known to everyone who needs to have trusted interactions with that entity. Public keys are used to verify signatures.
Digitally Signed
If some data is digitally signed it has been stored with the "identity" of an entity, and a signature that proves that entity knows about the data. The data is rendered unforgeable by signing with the entitys' private key.
Identity
A known way of addressing an entity. In some systems the identity is the public key, in others it can be anything from a UNIX UID to an Email address to an X.509 Distinguished Name.
Signature
A signature is computed over some data using the private key of an entity (the signer).
Private Keys
These are numbers, each of which is supposed to be known only to the particular entity whose private key it is (that is, it's supposed to be kept secret). Private and public keys exist in pairs in all public key cryptography systems (also referred to as "public key crypto systems"). In a typical public key crypto system, such as DSA, a private key corresponds to exactly one public key. Private keys are used to compute signatures.
Entity
An entity is a person, organization, program, computer, business, bank, or something else you are trusting to some degree.

Basically, public key cryptography requires access to users' public keys. In a large-scale networked environment it is impossible to guarantee that prior relationships between communicating entities have been established or that a trusted repository exists with all used public keys. Certificates were invented as a solution to this public key distribution problem. Now a Certification Authority (CA) can act as a Trusted Third Party. CAs are entities (e.g., businesses) that are trusted to sign (issue) certificates for other entities. It is assumed that CAs will only create valid and reliable certificates as they are bound by legal agreements. There are many public Certification Authorities, such as VeriSign, Thawte, Entrust, and so on. You can also run your own Certification Authority using products such as the Netscape/Microsoft Certificate Servers or the Entrust CA product for your organization.

What Applications use Certificates?

Probably the most widely visible application of X.509 certificates today is in web browsers (such as Mozilla Firefox and Microsoft Internet Explorer) that support the TLS protocol. TLS (Transport Layer Security) is a security protocol that provides privacy and authentication for your network traffic. These browsers can only use this protocol with web servers that support TLS.

Other technologies that rely on X.509 certificates include:

  • Various code-signing schemes, such as signed Java ARchives, and Microsoft Authenticode.
  • Various secure E-Mail standards, such as PEM and S/MIME.
  • E-Commerce protocols, such as SET.

How do I Get a Certificate?

There are two basic techniques used to get certificates:

  1. you can create one yourself (using the right tools, such as keytool), or
  2. you can ask a Certification Authority to issue you one (either directly or using a tool such as keytool to generate the request).
The main inputs to the certificate creation process are:
  • Matched public and private keys, generated using some special tools (such as keytool), or a browser. Only the public key is ever shown to anyone else. The private key is used to sign data; if someone knows your private key, they can masquerade as you ... perhaps forging legal documents attributed to you!
  • You need to provide information about the entity being certified (e.g., you). This normally includes information such as your name and organizational address. If you ask a CA to issue a certificate for you, you will normally need to provide proof to show correctness of the information.

If you are asking a CA to issue you a certificate, you provide your public key and some information about you. You'll use a tool (such as keytool or a browser that supports Certificate Signing Request generation). to digitally sign this information, and send it to the CA. The CA will then generate the certificate and return it.

If you're generating the certificate yourself, you'll take that same information, add a little more (dates during which the certificate is valid, a serial number), and just create the certificate using some tool (such as keytool). Not everyone will accept self-signed certificates; one part of the value provided by a CA is to serve as a neutral and trusted introduction service, based in part on their verification requirements, which are openly published in their Certification Service Practices (CSP).

What's Inside an X.509 Certificate?

The X.509 standard defines what information can go into a certificate, and describes how to write it down (the data format). All X.509 certificates have the following data, in addition to the signature:

Version
This identifies which version of the X.509 standard applies to this certificate, which affects what information can be specified in it. Thus far, three versions are defined.
Serial Number
The entity that created the certificate is responsible for assigning it a serial number to distinguish it from other certificates it issues. This information is used in numerous ways, for example when a certificate is revoked its serial number is placed in a Certificate Revocation List (CRL).
Signature Algorithm Identifier
This identifies the algorithm used by the CA to sign the certificate.
Issuer Name
The X.500 name of the entity that signed the certificate. This is normally a CA. Using this certificate implies trusting the entity that signed this certificate. (Note that in some cases, such as root or top-level CA certificates, the issuer signs its own certificate.)
Validity Period
Each certificate is valid only for a limited amount of time. This period is described by a start date and time and an end date and time, and can be as short as a few seconds or almost as long as a century. The validity period chosen depends on a number of factors, such as the strength of the private key used to sign the certificate or the amount one is willing to pay for a certificate. This is the expected period that entities can rely on the public value, if the associated private key has not been compromised.
Subject Name
The name of the entity whose public key the certificate identifies. This name uses the X.500 standard, so it is intended to be unique across the Internet. This is the Distinguished Name (DN) of the entity, for example,
    CN=Java Duke, OU=Java Software Division, O=Sun Microsystems Inc, C=US
(These refer to the subject's Common Name, Organizational Unit, Organization, and Country.)
Subject Public Key Information
This is the public key of the entity being named, together with an algorithm identifier which specifies which public key crypto system this key belongs to and any associated key parameters.

X.509 Version 1 has been available since 1988, is widely deployed, and is the most generic.

X.509 Version 2 introduced the concept of subject and issuer unique identifiers to handle the possibility of reuse of subject and/or issuer names over time. Most certificate profile documents strongly recommend that names not be reused, and that certificates should not make use of unique identifiers. Version 2 certificates are not widely used.

X.509 Version 3 is the most recent (1996) and supports the notion of extensions, whereby anyone can define an extension and include it in the certificate. Some common extensions in use today are: KeyUsage (limits the use of the keys to particular purposes such as "signing-only") and AlternativeNames (allows other identities to also be associated with this public key, e.g. DNS names, Email addresses, IP addresses). Extensions can be marked critical to indicate that the extension should be checked and enforced/used. For example, if a certificate has the KeyUsage extension marked critical and set to "keyCertSign" then if this certificate is presented during SSL communication, it should be rejected, as the certificate extension indicates that the associated private key should only be used for signing certificates and not for SSL use.

All the data in a certificate is encoded using two related standards called ASN.1/DER. Abstract Syntax Notation 1 describes data. The Definite Encoding Rules describe a single way to store and transfer that data. People have been known to describe this combination simultaneously as "powerful and flexible" and as "cryptic and awkward".

The IETF PKIX working group is in the process of defining standards for the Internet Public Key Infrastructure. We are closely following their work, and support the X.509 Certificate and CRL Profile, which is specified in RFC 3280.

What Java API Can Be Used to Access and Manage Certificates?

The Certificate API, found in the java.security.cert package, includes the following:
  • the CertificateFactory class defines the functionality of a certificate factory, which is used to generate certificate, certificate revocation list (CRL), and certification path objects from their encoding.
  • the Certificate class is an abstract class for managing a variety of certificates. It is an abstraction for certificates that have different formats but important common uses. For example, different types of certificates, such as X.509 and PGP, share general certificate functionality (like encoding and verifying) and some types of information like public key.
  • the CRL class is an abstract class for managing a variety of Certificate Revocation Lists (CRLs).
  • the X509Certificate class is an abstract class for X.509 Certificates. It provides a standard way to access all the attributes of an X.509 certificate.
  • the X509Extension interface is an interface for an X.509 extension. The extensions defined for X.509 v3 certificates and v2 CRLs (Certificate Revocation Lists) provide mechanisms for associating additional attributes with users or public keys, such as for managing the certification hierarchy, and for managing CRL distribution.
  • the X509CRL class is an abstract class for an X.509 Certificate Revocation List (CRL). A CRL is a time-stamped list identifying revoked certificates. It is signed by a Certification Authority (CA) and made freely available in a public repository.
  • the X509CRLEntry class is an abstract class for a CRL entry.
In JDK 1.4, new classes were added to support building and validating chains of certificates, or certification paths. These classes are described in further detail in the PKI Programmer's Guide.

What Java Tool Can Generate, Display, Import, and Export X.509 Certificates?

There is a tool named keytool ( for Solaris, Linux, or Mac OS X) ( for Windows ) that can be used to create public/private key pairs and self-signed X.509 v3 certificates, and to manage keystores. Keys and certificates are used to digitally sign your Java applications and applets (see the jarsigner (for Solaris, Linux, or Mac OS X) (for Windows) tool).

A keystore is a protected database that holds keys and certificates. Access to a keystore is guarded by a password (defined at the time the keystore is created, by the person who creates the keystore, and changeable only when providing the current password). In addition, each private key in a keystore can be guarded by its own password.

Using keytool, it is possible to display, import, and export X.509 v1, v2, and v3 certificates stored as files, and to generate new self-signed v3 certificates. For examples, see the "EXAMPLES" section of the keytool documentation ( for Solaris, Linux, or Mac OS X ) ( for Windows ).

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Working with Signed RIAs

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

25 Working with Signed RIAs

This topic provides information about working with the certificates used to sign Rich Internet applications (RIAs), which are Java and JavaFX applications that are embedded in a web page or launched from a browser.

This topic contains the following sections:

  • Support for Dynamic Trust Management

  • Signing RIAs

  • Deploying RIAs

25.1 Support for Dynamic Trust Management

Java SE has a fine-grained access control based on "codesource" and "protection domain". Every class that is loaded from a JAR file has a codesource, which encapsulates the following information:

  • The location (URL) where the class came from. In addition, every class that is loaded by a classloader belongs to one and only one protection domain, based on its codesource, that is, based on where the class came from and who signed it. Every protection domain has a set of permissions associated with it, based on the configured security policy. The protection domain encapsulates the codesource and the set of permissions granted to it

  • The list of principals who signed it (its certificates). Each signer principal in the codesource is represented by its X.509 public-key certificate and supporting certificate chain.

A certificate chain is a list of hierarchically ordered public-key certificates, starting at the signer's public-key certificate and ending at the certificate of a Root Certification Authority ("Root CA"). The public key of one certificate in the chain is used to verify the signature on the previous certificate in the chain. The Root CA certificate is self-signed. The assumption is that the Root CA is trusted because it is well known and widely published.

Deployment class loaders check the configured security policy to determine which permissions to grant to a given codesource. The codesource and the set of permissions granted to it then form a protection domain. This behavior is common to all secure classloaders, that is, instances of java.security.SecureClassLoader.

If the certificate chain can be verified all the way up to its Root CA certificate, the that Root CA certificate is checked to verifiy that it is contained in the database of trusted Root CA certificates. If so, the certificate chain of the authenticated signer is shown and the user is asked to grant AllPermission to code signed by that principal. Java code that is assigned the AllPermission permission is treated the same as system code, meaning it has all the privileges that system code has. The user can then choose whether to grant AllPermission to code signed by that principal, and whether such permission should be granted to any code signed by that principal for all subsequent sessions or for the current session only.

25.2 Signing RIAs

Signed RIAs are supported to make deployment of RIAs easier. This section provides step-by-step instructions for signing RIAs using certificates from a trusted Certificate Authority (CA), enabling novice developers to sign their RIAs without having to wade through the many complex security issues involved.

Signing applets requires the following items:

  1. Signing tool

  2. A keypair and a certificate chain for the public keys

  3. The RIA and all its class files, bundled as JAR files

25.2.1 Signing Tool

The format of the following tool for signing RIAs is supported:

  • jarsigner: Signing tool shipped as part of the Java SDK

25.2.2 Getting Certificates

Certificates can be purchased from a CA, such as VeriSign and Thawte. Some CAs, such as VeriSign, implement different protocols for issuing certificates, depending on the particular signing tool you are using.

Jarsigner is known to work with VeriSign and Thawte certificates and might work with Certificate Authorties. To use Jarsigner to sign RIAs, obtain code signing certificates for Java from VeriSign, Thawte, or similar certificates from other CAs. During the process of certificate enrollment, you will be asked to provide the certificate signing request (CSR). To generate the CSR, follow these steps:

  1. Use keytool to generate an RSA keypair (using the "-genkey -keyalg rsa" options). Make sure your distinguished name contains all the components mandated by VeriSign/Thawte, for example:

    C:\Program Files\Java\jdk1.8.0\bin\keytool -genkey -keyalg rsa -alias MyCert
Enter keystore password: *********
What is your first and last name?
[Unknown]: XXXXXXX YYY
What is the name of your organizational unit?
[Unknown]: Example Software
What is the name of your organization?
[Unknown]: New Technology Company
What is the name of your City or Locality?
[Unknown]: Cupertino
What is the name of your State or Province?
[Unknown]: CA
What is the two-letter country code for this unit?
[Unknown]: US
Is <CN=XXXXXXX YYY, OU=Example Software, O=New Technology Company,
 L=Cupertino, ST=CA, C=US> correct?
[no]: yes

Enter key password for <MyCert>
(RETURN if same as keystore password): *********

  2. Use "keytool -certreq" to generate a certification signing request. Copy the result and paste it into the VeriSign/Thawte webform, for example,

    C:\Program Files\Java\jdk1.8.0\bin\keytool -certreq -alias MyCert

Enter keystore password: *********
-----BEGIN NEW CERTIFICATE REQUEST-----
MIIBtjCCAR8CAQAwdjELMAkGA1UEBhMCVVMxCzAJBgNVBAgTAkNBMRIwE
AYDVQQHEwlDdXBlcnRpbm8xGTAXBgNVBAoTEFN1biBNaWNyb3N5c3RlbX
MxFjAUBgNVBAsTDUphdmEgU29mdHdhcmUxEzARBgNVBAMTClN0YW5sZXk
gSG8wgZ8wDQYJKoZIhvcNAQEBBQADgY0AMIGJAoGBALTgU8PovA4y59eb
oPjY65BwCSc/zPqtOZKJlaW4WP+UhmebE+T2Mho7P5zXjGf7elo3tV5uI
3vzgGfnhgpf73EoMow8EJhly4w/YsXKqeJEqqvNogzAD+qUv7Ld6dLOv0
CO5qvpmBAO6mfaI1XAgx/4xU/6009jVQe0TgIoocB5AgMBAAGgADANBgk
qhkiG9w0BAQQFAAOBgQAWmLrkifKiUYtd4ykhBtPWSwW/IKkgyfIuNMML
dF1DH8neSnXf3ZLI32f2yXvs7u3/xn6chnTXh4HYCJoGYOAbB3WNbAoQR
i6u6TLLOvgv9pMNUo6v1qB0xly1faizjimVYBwLhOenkA3Bw7S8UIVfdv
84cO9dFUGcr/Pfrl3GtQ==
-----END NEW CERTIFICATE REQUEST-----

  3. The CA will send you a certificate reply chain by email. Copy the chain and store it in a file. Use "keytool -import" to import the chain into your keystore, for example:

    C:\Program Files\Java\jdk1.6.0\bin\keytool -import -alias MyCert -file VSSStanleyNew.cer

  4. Your certificate and its supporting chain have been validated and imported into your keystore. You are now ready to use jarsigner to sign your JAR file.

Note:

You must use either the same alias name for all of the above steps or no alias name, in which case the alias name defaults to "mykey".

25.2.3 Bundling RIAs as JAR Files

To use Jarsigner to sign RIAs, the RIAs must be bundled as JAR files. The Jar tool (command jar ...), which comes with the Java SE SDK, can be used for that purpose, for example:

C:\Program Files\Java\jdk1.8.0\bin\jar cvf C:\TestApplet.jar .
added manifest
adding: TestApplet.class (in = 94208) (out= 20103)(deflated 78%)
adding: TestHelper.class (in = 16384) (out= 779)(deflated 95%)

This example creates a JAR file C:\TestApplet.jar that contains all of the files under the current directory and its sub-directories.

After the JAR file is created, verify its content using the jar tool again, for example:

C:\Program Files\Java\jdk1.8.0\bin\jar tvf TestApplet.jar
 0 Mon Mar 06 18:02:54 PST 2000 META-INF/
 68 Mon Mar 06 18:02:54 PST 2000 META-INF/MANIFEST.MF
 94208 Wed Mar 10 11:48:52 PST 2000 TestApplet.class
 16384 Wed Mar 10 11:48:52 PST 2000 TestHelper.class

This ensures that the class files are stored with the proper path within the JAR file.

25.2.4 Signing the JAR Files

When you have the certificates, the signing tool, and the JAR files for the RIAs, you are ready to sign the RIAs.

To sign applets using jarsigner, follow these steps:

  1. Use jarsigner to sign the JAR file, using the credentials in your keystore that were generated in the previous steps. Make sure the same alias name is specified, for example:

    C:\Program Files\Java\jdk1.8.0\bin\jarsigner C:\TestApplet.jar MyCert
Enter Passphrase for keystore: ********

  2. Use "jarsigner -verify -verbose -certs" to verify the jar files.

    C:\Program Files\Java\jdk1.8.0\bin\jarsigner -verify -verbose
 -certs d:\TestApplet.jar

 245 Wed Mar 10 11:48:52 PST 2000 META-INF/manifest.mf
 187 Wed Mar 10 11:48:52 PST 2000 META-INF/MYCERT.SF
 968 Wed Mar 10 11:48:52 PST 2000 META-INF/MYCERT.RSA
smk 943 Wed Mar 10 11:48:52 PST 2000 TestApplet.class
smk 163 Wed Mar 10 11:48:52 PST 2000 TestHelper.class

 X.509, CN=XXXXXXX YYY, OU=Example Software,
 O=New Technology Company, L=Cupertino,
 ST=CA, C=US (mycert)
 X.509, CN=New Technology Company, OU=Java Plug-in QA,
 O=New Technology Company, L=Cupertino, ST=CA, C=US
 X.509, EmailAddress=server-certs@thawte.com,
 CN=Thawte Server CA, OU=Certification
 Services Division, O=Thawte Consulting cc,
 L=Cape Town, ST=Western Cape, C=ZA

 s = signature was verified
 m = entry is listed in manifest
 k = at least one certificate was found in keystore
 i = at least one certificate was found in identity scope

jar verified.

  3. Your RIA has been signed properly. You are now ready to deploy your signed RIA.

25.2.5 Microsoft Authenticode

Authenticode is a proprietary signing technology used in Microsoft Internet Explorer on Win32 for supporting signed applets in IE's JVM. Authenticode is not supported in Java Plug-in. Instead, the Java Plug-in supports use of signed applets in IE.

25.3 Deploying RIAs

To deploy RIAs, follow these steps:

  1. Reference the JAR from the HTML page using archive, cache_archive, or cache_archive_ex format.

  2. Place the JAR file and HTML page on the web server.

When a RIA is started, the following items are verified:

  1. The RIA is correctly signed.

  2. The certificate chain and root CA are valid.

If the RIA is correctly signed and the certificate chain and root CA are valid, a security dialog is shown that prompts the user to accept or block the RIA. See Section 23.5, "Security Dialogs" for information.

If the user chooses to allow the RIA to run, it runs in the corresponding security context.

25.3.1 Certificate Management

The Certificates dialog from the Java Control Panel manages signed RIAs. Access this dialog from the Security tab by clicking Manage Certificates. The Certificates dialog contains a list of certificates that received "Grant always" permission. Users can remove any certificate from the list, and if a RIA signed by a removed certificate is encountered again, a security dialog is shown to ask the user for permission. Users can also export and view certificates through the Java Control Panel.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java PKI API Programmer's Guide

Documentation Contents

Java PKI Programmer's Guide

Skip Table of Contents
  • Overview
    • Who Should Read This Document
    • Related Documentation
    • Introduction
  • Core Classes and Interfaces
    • Basic Classes
      • The CertPath Class
      • The CertificateFactory Class
      • The CertPathParameters Interface
    • Certification Path Validation Classes
      • The CertPathValidator Class
      • The CertPathValidatorResult Interface
    • Certification Path Building Classes
      • The CertPathBuilder Class
      • The CertPathBuilderResult Interface
    • Certificate/CRL Storage Classes
      • The CertStore Class
      • The CertStoreParameters Interface
        • The LDAPCertStoreParameters Class
        • The CollectionCertStoreParameters Class
      • The CertSelector and CRLSelector Interfaces
        • The X509CertSelector Class
        • The X509CRLSelector Class
    • PKIX Classes
      • The TrustAnchor Class
      • The PKIXParameters Class
      • The PKIXCertPathValidatorResult Class
      • The PolicyNode Interface and PolicyQualifierInfo Class
      • The PKIXBuilderParameters Class
      • The PKIXCertPathBuilderResult Class
      • The PKIXCertPathChecker Class
      • Using PKIXCertPathChecker in Certificate Path Validation
  • Implementing a Service Provider
  • Signature Timestamp Support
  • Appendix A: Standard Names
  • Appendix B: The "SUN" Provider
  • Appendix C: On-Line Certificate Status Protocol (OCSP) Support
  • Appendix D: Disabling Cryptographic Algorithms

Overview

The Java Certification Path API consists of classes and interfaces for handling certification paths (also known as "certificate chains"). A certification path is an ordered list of certificates. If a certification path meets certain validation rules, it may be used to securely establish the mapping of a public key to a subject.

This API defines interfaces and abstract classes for creating, building, and validating certification paths. Implementations may be plugged in using a provider-based interface. The API is based on the Cryptographic Service Provider architecture, described in the Java Cryptography Architecture Reference Guide.

The API also includes algorithm-specific classes for building and validating X.509 certification paths according to the PKIX standards. The PKIX standards are developed by the IETF PKIX working group.

This API was originally specified using the Java Community Process program as Java Specification Request (JSR) 000055. The API was included in the Java SDK, starting with Java SE Development Kit (JDK) 1.4. Please refer to JSR 55: Certification Path API for more information on the JSR.

Who Should Read This Document

This document is intended for two classes of experienced developers:

  1. those who want to design secure applications that build or validate certification paths.

  2. those who want to write a service provider implementation for building or validating certification paths.

Related Documentation

This document assumes you have already read the following documents:

  • X.509 Certificates and Certificate Revocation Lists (CRLs)

  • Java Cryptography Architecture Reference Guide

  • How to Implement a Provider for the Java Cryptography Architecture

Introduction

Users of public key applications and systems must be confident that a subject's public key is genuine, i.e., that the associated private key is owned by the subject. Public key certificates are used to establish this trust. A public key (or identity) certificate is a binding of a public key to an identity, which is digitally signed by the private key of another entity, often called a Certification Authority (CA). We shall use the term CA to refer to an entity that signs a certificate for the remainder of this section.

If the user does not have a trusted copy of the public key of the CA that signed the subject's public key certificate, then another public key certificate vouching for the signing CA is required. This logic can be applied recursively, until a chain of certificates (or a certification path) is discovered from a trust anchor or a most-trusted CA to the target subject (commonly referred to as the end-entity). The most-trusted CA is usually specified by a certificate issued to a CA that the user directly trusts. In general, a certification path is an ordered list of certificates, usually comprised of the end-entity's public key certificate and zero or more additional certificates. A certification path typically has one or more encodings, allowing it to be safely transmitted across networks and to different operating system architectures.

The following figure illustrates a certification path from a most-trusted CA's public key (CA 1) to the target subject (Alice). The certification path establishes trust in Alice's public key through an intermediate CA named CA2.

Certification path from a most-trusted CA's public key (CA 1) to the target subject (Alice)

Description of Figure Certification Path

A certification path must be validated before it can be relied on to establish trust in a subject's public key. Validation can consist of various checks on the certificates contained in the certification path, such as verifying the signatures and checking that each certificate has not been revoked. The PKIX standards define an algorithm for validating certification paths consisting of X.509 certificates.

Often a user may not have a certification path from a most-trusted CA to the subject. Providing services to build or discover certification paths is an important feature of public key enabled systems. RFC 2587 defines an LDAP (Lightweight Directory Access Protocol) schema definition which facilitates the discovery of X.509 certification paths using the LDAP directory service protocol.

Building and validating certification paths is an important part of many standard security protocols such as SSL/TLS, S/MIME, and IPSEC. The Java Certification Path API provides a set of classes and interfaces for developers who need to integrate this functionality into their applications. This API benefits two types of developers: those who need to write service provider implementations for a specific certification path building or validation algorithm; and those who need to access standard algorithms for creating, building, and validating certification paths in an implementation-independent manner.

Core Classes and Interfaces

The core classes of the Java Certification Path API consist of interfaces and classes that support certification path functionality in an algorithm- and implementation -independent manner. The API also includes a set of algorithm-specific classes for the PKIX standards that are discussed in the section titled PKIX Classes. The API builds on and extends the existing java.security.cert package for handling certificates. The core classes can be broken up into 4 class categories: Basic, Validation, Building, and Storage:

  • Basic Certification Path Classes

    • CertPath, CertificateFactory, CertPathParameters

  • Certification Path Validation Classes

    • CertPathValidator, CertPathValidatorResult

  • Certification Path Building Classes

    • CertPathBuilder, CertPathBuilderResult

  • Certificate/CRL Storage Classes

    • CertStore, CertStoreParameters, CertSelector, CRLSelector

The following sections describe the most commonly used methods of each class and interface. Usage examples for some of the classes are interspersed throughout the guide. The complete reference documentation for the relevant Certification Path API classes can be found in:

  • java.security.cert package summary

Most of the classes and interfaces in the CertPath API are not thread-safe. However, there are some exceptions which will be noted in this guide and the API specification. Multiple threads that need to access a single non-thread-safe object concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating separate objects need not synchronize.

Basic Certification Path Classes

The basic certification path classes provide fundamental functionality for encoding and representing certification paths. The key basic class in the Java Certification Path API is CertPath, which encapsulates the universal aspects shared by all types of certification paths. An application uses an instance of the CertificateFactory class to create a CertPath object.

The CertPath Class

The CertPath class is an abstract class for certification paths. It defines the functionality shared by all certification path objects. Various certification path types can be implemented by subclassing the CertPath class, even though they may have different contents and ordering schemes. All CertPath objects are serializable, immutable and thread-safe and share the following characteristics:

  • A type

    This corresponds to the type of the certificates in the certification path, for example: X.509. The type of a CertPath is obtained using the method:

        public String getType()

    See Appendix A in the Java Cryptography Architecture Reference Guide for information about standard certificate types.

  • A list of certificates

    The getCertificates method returns the list of certificates in the certification path:

        public abstract List<? extends Certificate> getCertificates()
    This method returns a List of zero or more java.security.cert.Certificate objects. The returned List and the Certificates contained within it are immutable, in order to protect the contents of the CertPath object. The ordering of the certificates returned depends on the type. By convention, the certificates in a CertPath object of type X.509 are ordered starting with the target certificate and ending with a certificate issued by the trust anchor. That is, the issuer of one certificate is the subject of the following one. The certificate representing the TrustAnchor should not be included in the certification path. Unvalidated X.509 CertPaths may not follow this convention. PKIX CertPathValidators will detect any departure from these conventions that cause the certification path to be invalid and throw a CertPathValidatorException.

  • One or more encodings

    Each CertPath object supports one or more encodings. These are external encoded forms for the certification path, used when a standard representation of the path is needed outside the Java Virtual Machine (as when transmitting the path over a network to some other party). Each path can be encoded in a default format, the bytes of which are returned using the method:

        public abstract byte[] getEncoded()
    Alternatively, the getEncoded(String) method returns a specific supported encoding by specifying the encoding format as a String (ex: "PKCS7"). A list of standard encoding formats are defined in Appendix A.

        public abstract byte[] getEncoded(String encoding)
    Also, the getEncodings method returns an iterator over the supported encoding format Strings (the default encoding format is returned first):

        public abstract Iterator<String> getEncodings()

All CertPath objects are also Serializable. CertPath objects are resolved into an alternate CertPathRep object during serialization. This allows a CertPath object to be serialized into an equivalent representation regardless of its underlying implementation.

CertPath objects are generated from an encoded byte array or list of Certificates using a CertificateFactory. Alternatively, a CertPathBuilder may be used to try to find a CertPath from a most-trusted CA to a particular subject. Once a CertPath object has been created, it may be validated by passing it to the validate method of CertPathValidator. Each of these concepts are explained in more detail in subsequent sections.

The CertificateFactory Class

The CertificateFactory class is an engine class that defines the functionality of a certificate factory. In releases prior to JDK 1.4 it was used to generate Certificate and CRL objects. It was enhanced in JDK 1.4 to also be used to generate certification path (CertPath) objects. A CertificateFactory should not be confused with a CertPathBuilder. A CertPathBuilder (discussed later) is used to discover or find a certification path when one does not exist. In contrast, a CertificateFactory is used when a certification path has already been discovered and the caller needs to instantiate a CertPath object from its contents which exist in a different form such as an encoded byte array or an array of Certificates.

Creating a CertificateFactory Object

See the CertificateFactory section in the Java Cryptography Architecture Reference Guide for details on creating a CertificateFactory object.

Generating CertPath Objects

A CertificateFactory instance generates CertPath objects from a List of Certificate objects or from an InputStream that contains the encoded form of a CertPath. Just like a CertPath, each CertificateFactory supports a default encoding format for certification paths (ex: PKCS#7). To generate a CertPath object and initialize it with the data read from an input stream (in the default encoding format), use the generateCertPath method:

    public final CertPath generateCertPath(InputStream inStream)

or from a particular encoding format:

    public final CertPath generateCertPath(InputStream inStream,
                                           String encoding)

To find out what encoding formats are supported, use the getCertPathEncodings method (the default encoding is returned first):

    public final Iterator<String> getCertPathEncodings()

To generate a certification path object from a List of Certificate objects, use the following method:

    public final CertPath generateCertPath(List<? extends Certificate> certificates)

A CertificateFactory always returns CertPath objects that consist of Certificates that are of the same type as the factory. For example, a CertificateFactory of type X.509 returns CertPath objects consisting of certificates that are an instance of java.security.cert.X509Certificate.

The following code sample illustrates generating a certification path from a PKCS#7 encoded certificate reply stored in a file:

    // open an input stream to the file
    FileInputStream fis = new FileInputStream(filename);
    // instantiate a CertificateFactory for X.509
    CertificateFactory cf = CertificateFactory.getInstance("X.509");
    // extract the certification path from
    // the PKCS7 SignedData structure
    CertPath cp = cf.generateCertPath(fis, "PKCS7");
    // print each certificate in the path
    List<Certificate> certs = cp.getCertificates();
    for (Certificate cert : certs) {
        System.out.println(cert);
    }
Here's another code sample that fetches a certificate chain from a KeyStore and converts it to a CertPath using a CertificateFactory:
    // instantiate a KeyStore with type JKS
    KeyStore ks = KeyStore.getInstance("JKS");
    // load the contents of the KeyStore
    ks.load(new FileInputStream("./keystore"),
        "password".toCharArray());
    // fetch certificate chain stored with alias "sean"
    Certificate[] certArray = ks.getCertificateChain("sean");
    // convert chain to a List
    List certList = Arrays.asList(certArray);
    // instantiate a CertificateFactory for X.509
    CertificateFactory cf = CertificateFactory.getInstance("X.509");
    // extract the certification path from
    // the List of Certificates
    CertPath cp = cf.generateCertPath(certList);

Note that there is an existing method in CertificateFactory named generateCertificates that parses a sequence of Certificates. For encodings consisting of multiple certificates, use generateCertificates when you want to parse a collection of possibly unrelated certificates. Otherwise, use generateCertPath when you want to generate a CertPath and subsequently validate it with a CertPathValidator (discussed later).

The CertPathParameters Interface

The CertPathParameters interface is a transparent representation of the set of parameters used with a particular certification path builder or validation algorithm. Its main purpose is to group (and provide type safety for) all certification path parameter specifications. The CertPathParameters interface extends the Cloneable interface and defines a clone() method that does not throw an exception. All concrete implementations of this interface should implement and override the Object.clone() method, if necessary. This allows applications to clone any CertPathParameters object.

Objects implementing the CertPathParameters interface are passed as arguments to methods of the CertPathValidator and CertPathBuilder classes. Typically, a concrete implementation of the CertPathParameters interface will hold a set of input parameters specific to a particular certification path build or validation algorithm. For example, the PKIXParameters class is an implementation of the CertPathParameters interface that holds a set of input parameters for the PKIX certification path validation algorithm. One such parameter is the set of most-trusted CAs that the caller trusts for anchoring the validation process. This parameter among others is discussed in more detail in the section discussing the PKIXParameters class.

Certification Path Validation Classes

The Java Certification Path API includes classes and interfaces for validating certification paths. An application uses an instance of the CertPathValidator class to validate a CertPath object. If successful, the result of the validation algorithm is returned in an object implementing the CertPathValidatorResult interface.

The CertPathValidator Class

The CertPathValidator class is an engine class used to validate a certification path.

Creating a CertPathValidator Object

As with all engine classes, the way to get a CertPathValidator object for a particular validation algorithm is to call one of the getInstance static factory methods on the CertPathValidator class:

        public static CertPathValidator getInstance(String algorithm)
        public static CertPathValidator getInstance(String algorithm,
                                                    String provider)
        public static CertPathValidator getInstance(String algorithm,
                                                    Provider provider)
The algorithm parameter is the name of a certification path validation algorithm (for example, "PKIX"). Standard CertPathValidator algorithm names are listed in Appendix A.
Validating a Certification Path

Once a CertPathValidator object is created, paths can be validated by calling the validate method, passing it the certification path to be validated and a set of algorithm-specific parameters:

        public final CertPathValidatorResult
                validate(CertPath certPath, CertPathParameters params)
                throws CertPathValidatorException,
                       InvalidAlgorithmParameterException

If the validation algorithm is successful, the result is returned in an object implementing the CertPathValidatorResult interface. Otherwise, a CertPathValidatorException is thrown. The CertPathValidatorException contains methods that return the CertPath, and if relevant, the index of the certificate that caused the algorithm to fail and the root exception or cause of the failure.

Note that the CertPath and CertPathParameters passed to the validate method must be of a type that is supported by the validation algorithm. Otherwise, an InvalidAlgorithmParameterException is thrown. For example, a CertPathValidator instance that implements the PKIX algorithm validates CertPath objects of type X.509 and CertPathParameters that are an instance of PKIXParameters.

The CertPathValidatorResult Interface

The CertPathValidatorResult interface is a transparent representation of the successful result or output of a certification path validation algorithm. Its main purpose is to group (and provide type safety for) all validation results. Like the CertPathParameters interface, CertPathValidatorResult extends Cloneable and defines a clone() method that does not throw an exception. This allows applications to clone any CertPathValidatorResult object.

Objects implementing the CertPathValidatorResult interface are returned by the validate method of CertPathValidator (only when successful; otherwise a CertPathValidatorException is thrown with a description of the failure). Typically, a concrete implementation of the CertPathValidatorResult interface will hold a set of output parameters specific to a particular certification path validation algorithm. For example, the PKIXCertPathValidatorResult class is an implementation of the CertPathValidatorResult interface which contains methods to get the output parameters of the PKIX certification path validation algorithm. One such parameter is the valid policy tree. This parameter among others is discussed in more detail in the section discussing the PKIXCertPathValidatorResult class.

Here's a simplified code sample that illustrates how to create a CertPathValidator and use it to validate a certification path. The sample assumes that the CertPath and CertPathParameters objects which are passed to the validate method have been previously created; a more complete example will be illustrated in the section describing the PKIX classes.

    // create CertPathValidator that implements the "PKIX" algorithm
    CertPathValidator cpv = null;
    try {
        cpv = CertPathValidator.getInstance("PKIX");
    } catch (NoSuchAlgorithmException nsae) {
        System.err.println(nsae);
        System.exit(1);
    }
    // validate certification path ("cp") with specified parameters ("params")
    try {
        CertPathValidatorResult cpvResult = cpv.validate(cp, params);
    } catch (InvalidAlgorithmParameterException iape) {
        System.err.println("validation failed: " + iape);
        System.exit(1);
    } catch (CertPathValidatorException cpve) {
        System.err.println("validation failed: " + cpve);
        System.err.println("index of certificate that caused exception: "
                + cpve.getIndex());
        System.exit(1);
    }

Certification Path Building Classes

The Java Certification Path API includes classes for building (or discovering) certification paths. An application uses an instance of the CertPathBuilder class to build a CertPath object. If successful, the result of the build is returned in an object implementing the CertPathBuilderResult interface.

The CertPathBuilder Class

The CertPathBuilder class is an engine class used to build a certification path.

Creating a CertPathBuilder Object

As with all engine classes, the way to get a CertPathBuilder object for a particular build algorithm is to call one of the getInstance static factory method on the CertPathBuilder class:

        public static CertPathBuilder getInstance(String algorithm)
        public static CertPathBuilder getInstance(String algorithm,
                                                  String provider)
        public static CertPathBuilder getInstance(String algorithm,
                                                  Provider provider)
The algorithm parameter is the name of a certification path builder algorithm (for example, "PKIX"). Standard CertPathBuilder algorithm names are listed in Appendix A.
Building a Certification Path

Once a CertPathBuilder object is created, paths can be constructed by calling the build method, passing it an algorithm-specific parameter specification:

        public final CertPathBuilderResult build(CertPathParameters params)
                throws CertPathBuilderException,
                       InvalidAlgorithmParameterException

If the build algorithm is successful, the result is returned in an object implementing the CertPathBuilderResult interface. Otherwise, a CertPathBuilderException is thrown containing information about the failure; for example, the underlying exception (if any) and an error message.

Note that the CertPathParameters passed to the build method must be of a type that is supported by the build algorithm. Otherwise, an InvalidAlgorithmParameterException is thrown.

The CertPathBuilderResult Interface

The CertPathBuilderResult interface is a transparent representation of the result or output of a certification path builder algorithm. This interface contains a method to return the certification path that has been successfully built:

        public CertPath getCertPath()

The purpose of the CertPathBuilderResult interface is to group (and provide type safety for) all build results. Like the CertPathValidatorResult interface, CertPathBuilderResult extends Cloneable and defines a clone() method that does not throw an exception. This allows applications to clone any CertPathBuilderResult object.

Objects implementing the CertPathBuilderResult interface are returned by the build method of CertPathBuilder.

Here's a simplified code sample that illustrates how to create a CertPathBuilder and use it to build a certification path. The sample assumes that the CertPathParameters object which is passed to the build method has been previously created; a more complete example will be illustrated in the section describing the PKIX classes.

    // create CertPathBuilder that implements the "PKIX" algorithm
    CertPathBuilder cpb = null;
    try {
        cpb = CertPathBuilder.getInstance("PKIX");
    } catch (NoSuchAlgorithmException nsae) {
        System.err.println(nsae);
        System.exit(1);
    }
    // build certification path using specified parameters ("params")
    try {
        CertPathBuilderResult cpbResult = cpb.build(params);
        CertPath cp = cpbResult.getCertPath();
        System.out.println("build passed, path contents: " + cp);
    } catch (InvalidAlgorithmParameterException iape) {
        System.err.println("build failed: " + iape);
        System.exit(1);
    } catch (CertPathBuilderException cpbe) {
        System.err.println("build failed: " + cpbe);
        System.exit(1);
    }

Certificate/CRL Storage Classes

The Java Certification Path API also includes the CertStore class for retrieving certificates and CRLs from a repository. This is useful because it allows a caller to specify the repository a CertPathValidator or CertPathBuilder implementation should use to find certificates and CRLs (see the addCertStores method of PKIXParameters for an example).

A CertPathValidator implementation may use the CertStore object that the caller specifies as a callback mechanism to fetch CRLs for performing revocation checks. Similarly, a CertPathBuilder may use the CertStore as a callback mechanism to fetch certificates and, if performing revocation checks, CRLs.

The CertStore Class

The CertStore class is an engine class used to provide the functionality of a certificate and certificate revocation list (CRL) repository. It can be used by CertPathBuilder and CertPathValidator implementations to find certificates and CRLs or as a general purpose certificate and CRL retrieval mechanism.

Unlike the java.security.KeyStore class, which provides access to a cache of private keys and trusted certificates, a CertStore is designed to provide access to a potentially vast repository of untrusted certificates and CRLs. For example, an LDAP implementation of CertStore provides access to certificates and CRLs stored in one or more directories using the LDAP protocol.

All public methods of CertStore objects are thread-safe. That is, multiple threads may concurrently invoke these methods on a single CertStore object (or more than one) with no ill effects. This allows a CertPathBuilder to search for a CRL while simultaneously searching for further certificates, for instance.

Creating a CertStore Object

As with all engine classes, the way to get a CertStore object for a particular repository type is to call one of the getInstance static factory methods on the CertStore class:

        public static CertStore getInstance(String type,
                CertStoreParameters params)
        public static CertStore getInstance(String type,
                CertStoreParameters params, String provider)
        public static CertStore getInstance(String type,
                CertStoreParameters params, Provider provider)
The type parameter is the name of a certificate repository type (for example, "LDAP"). Standard CertStore types are listed in Appendix A.

The initialization parameters (params) are specific to the repository type. For example, the initialization parameters for a server-based repository may include the hostname and the port of the server. An InvalidAlgorithmParameterException is thrown if the parameters are invalid for this CertStore type. The getCertStoreParameters method returns the CertStoreParameters that were used to initialize a CertStore:

        public final CertStoreParameters getCertStoreParameters()
Retrieving Certificates

Once you have created a CertStore object, you can retrieve certificates from the repository using the getCertificates method. This method takes a CertSelector (discussed in more detail later) object as an argument, which specifies a set of selection criteria for determining which certificates should be returned:

        public final Collection<? extends Certificate> getCertificates(CertSelector selector)
                throws CertStoreException

This method returns a Collection of java.security.cert.Certificate objects that satisfy the selection criteria. An empty Collection is returned if there are no matches. A CertStoreException is usually thrown if an unexpected error condition is encountered, such as a communications failure with a remote repository.

For some CertStore implementations, it may not be feasible to search the entire repository for certificates or CRLs that match the specified selection criteria. In these instances, the CertStore implementation may use information that is specified in the selectors to locate certificates and CRLs. For instance, an LDAP CertStore may not search all entries in the directory. Instead, it may just search entries that are likely to contain the certificates it is looking for. If the CertSelector provided does not provide enough information for the LDAP CertStore to determine which entries it should look in, the LDAP CertStore may throw a CertStoreException.

Retrieving CRLs

You can also retrieve CRLs from the repository using the getCRLs method. This method takes a CRLSelector (discussed in more detail later) object as an argument, which specifies a set of selection criteria for determining which CRLs should be returned:

        public final Collection<? extends CRL> getCRLs(CRLSelector selector)
                throws CertStoreException

This method returns a Collection of java.security.cert.CRL objects that satisfy the selection criteria. An empty Collection is returned if there are no matches.

The CertStoreParameters Interface

The CertStoreParameters interface is a transparent representation of the set of parameters used with a particular CertStore. Its main purpose is to group (and provide type safety for) all certificate storage parameter specifications. The CertStoreParameters interface extends the Cloneable interface and defines a clone method that does not throw an exception. Implementations of this interface should implement and override the Object.clone() method, if necessary. This allows applications to clone any CertStoreParameters object.

Objects implementing the CertStoreParameters interface are passed as arguments to the getInstance method of the CertStore class. Two classes implementing the CertStoreParameters interface are defined in this API: the LDAPCertStoreParameters and the CollectionCertStoreParameters classes.

The LDAPCertStoreParameters Class

The LDAPCertStoreParameters class is an implementation of the CertStoreParameters interface and holds a set of minimal initialization parameters (host and port number of the directory server) for retrieving certificates and CRLs from a CertStore of type LDAP.

Please refer to the LDAPCertStoreParameters API documentation for more detailed information on this class.

The CollectionCertStoreParameters Class

The CollectionCertStoreParameters class is an implementation of the CertStoreParameters interface and holds a set of initialization parameters for retrieving certificates and CRLs from a CertStore of type Collection.

Please refer to the CollectionCertStoreParameters API documentation for more detailed information on this class.

The CertSelector and CRLSelector Interfaces

The CertSelector and CRLSelector interfaces are a specification of the set of criteria for selecting certificates and CRLs from a collection or large group of certificates and CRLs. The interfaces group and provide type safety for all selector specifications. Each selector interface extends Cloneable and defines a clone() method that does not throw an exception. This allows applications to clone any CertSelector or CRLSelector object.

The CertSelector and CRLSelector interfaces each define a method named match. The match method takes a Certificate or CRL object as an argument and returns true if the object satisfies the selection criteria. Otherwise, it returns false. The match method for the CertSelector interface is defined as follows:

        public boolean match(Certificate cert)

and for the CRLSelector interface:

        public boolean match(CRL crl)

Typically, objects implementing these interfaces are passed as parameters to the getCertificates and getCRLs methods of the CertStore class. These methods return a Collection of Certificates or CRLs from the CertStore repository that match the specified selection criteria. CertSelectors may also be used to specify the validation constraints on a target or end-entity certificate in a certification path (see for example, the PKIXParameters.setTargetCertConstraints method.

The X509CertSelector Class

The X509CertSelector class is an implementation of the CertSelector interface that defines a set of criteria for selecting X.509 certificates. An X509Certificate object must match all of the specified criteria to be selected by the match method. The selection criteria are designed to be used by a CertPathBuilder implementation to discover potential certificates as it builds an X.509 certification path.

For example, the setSubject method of X509CertSelector allows a PKIX CertPathBuilder to filter out X509Certificates that do not match the issuer name of the preceding X509Certificate in a partially completed chain. By setting this and other criteria in an X509CertSelector object, a CertPathBuilder is able to discard irrelevant certificates and more easily find an X.509 certification path that meets the requirements specified in the CertPathParameters object.

Please refer to http://www.ietf.org/rfc/rfc3280.txt for definitions of the X.509 certificate extensions mentioned in this section.

Creating an X509CertSelector Object

An X509CertSelector object is created by calling the default constructor:

        public X509CertSelector()

No criteria are initially set (any X509Certificate will match).

Setting Selection Criteria

The selection criteria allow a caller to match on different components of an X.509 certificate. A few of the methods for setting selection criteria are described here. Please refer to the X509CertSelector API documentation for details on the other methods.

The setIssuer methods set the issuer criterion:

        public void setIssuer(X500Principal issuer)
        public void setIssuer(String issuerDN)
        public void setIssuer(byte[] issuerDN)

The specified distinguished name (in X500Principal, RFC 2253 String or ASN.1 DER encoded form) must match the issuer distinguished name in the certificate. If null, any issuer distinguished name will do. Note that use of an X500Principal to represent a distinguished name is preferred because it is more efficient and suitably typed.

Similarly, the setSubject methods set the subject criterion:

        public void setSubject(X500Principal subject)
        public void setSubject(String subjectDN)
        public void setSubject(byte[] subjectDN)

The specified distinguished name (in X500Principal, RFC 2253 String or ASN.1 DER encoded form) must match the subject distinguished name in the certificate. If null, any subject distinguished name will do.

The setSerialNumber method sets the serialNumber criterion:

        public void setSerialNumber(BigInteger serial)

The specified serial number must match the certificate serial number in the certificate. If null, any certificate serial number will do.

The setAuthorityKeyIdentifier method sets the authorityKeyIdentifier criterion:

        public void setAuthorityKeyIdentifier(byte[] authorityKeyID)

The certificate must contain an Authority Key Identifier extension matching the specified value. If null, no check will be done on the authorityKeyIdentifier criterion.

The setCertificateValid method sets the certificateValid criterion:

        public void setCertificateValid(Date certValid)

The specified date must fall within the certificate validity period for the certificate. If null, any date is valid.

The setKeyUsage method sets the keyUsage criterion:

        public void setKeyUsage(boolean[] keyUsage)

The certificate's Key Usage Extension must allow the specified key usage values (those which are set to true). If null, no keyUsage check will be done.

Getting Selection Criteria

The current values for each of the selection criteria can be retrieved using an appropriate get method. Please refer to the X509CertSelector API documentation for further details on these methods.

Example

Here is an example of retrieving X.509 certificates from an LDAP CertStore with the X509CertSelector class.

First, we create the LDAPCertStoreParameters object that we will use to initialize the CertStore object with the hostname and port of the LDAP server:

        LDAPCertStoreParameters lcsp = new
                LDAPCertStoreParameters("ldap.sun.com", 389);

Next, create the CertStore object, and pass it the LDAPCertStoreParameters object, as in the following statement:

        CertStore cs = CertStore.getInstance("LDAP", lcsp);

This call creates a CertStore object that retrieves certificates and CRLs from an LDAP repository using the schema defined in RFC 2587.

The following block of code establishes an X509CertSelector to retrieve all unexpired (as of the current date and time) end-entity certificates issued to a particular subject with 1) a key usage that allows digital signatures, and 2) a subject alternative name with a specific email address:

        X509CertSelector xcs = new X509CertSelector();
        // select only unexpired certificates
        xcs.setCertificateValid(new Date());
        // select only certificates issued to
        // 'CN=alice, O=xyz, C=us'
        xcs.setSubject(new X500Principal("CN=alice, O=xyz, C=us"));
        // select only end-entity certificates
        xcs.setBasicConstraints(-2);
        // select only certificates with a digitalSignature
        // keyUsage bit set (set the first entry in the
        // boolean array to true)
        boolean[] keyUsage = {true};
        xcs.setKeyUsage(keyUsage);
        // select only certificates with a subjectAltName of
        // 'alice@xyz.example.com' (1 is the integer value of
        // an RFC822Name)
        xcs.addSubjectAlternativeName(1, "alice@xyz.example.com");

Then we pass the selector to the getCertificates method of our CertStore object that we previously created:

        Collection<Certificate> certs = cs.getCertificates(xcs);

A PKIX CertPathBuilder may use similar code to help discover and sort through potential certificates by discarding those that do not meet validation constraints or other criteria.

The X509CRLSelector Class

The X509CRLSelector class is an implementation of the CRLSelector interface that defines a set of criteria for selecting X.509 CRLs. An X509CRL object must match all of the specified criteria to be selected by the match method. The selection criteria are designed to be useful to a CertPathValidator or CertPathBuilder implementation that must retrieve CRLs from a repository to check the revocation status of certificates in an X.509 certification path.

For example, the setDateAndTime method of X509CRLSelector allows a PKIX CertPathValidator to filter out X509CRLs that have been issued after or expire before the time indicated. By setting this and other criteria in an X509CRLSelector object, it allows the CertPathValidator to discard irrelevant CRLs and more easily check if a certificate has been revoked.

Please refer to http://www.ietf.org/rfc/rfc3280.txt for definitions of the X.509 CRL fields and extensions mentioned in this section.

Creating an X509CRLSelector Object

An X509CRLSelector object is created by calling the default constructor:

        public X509CRLSelector()

No criteria are initially set (any X509CRL will match).

Setting Selection Criteria

The selection criteria allow a caller to match on different components of an X.509 CRL. Most of the methods for setting selection criteria are described here. Please refer to the X509CRLSelector API documentation for details on the remaining methods.

The setIssuers and setIssuerNames methods set the issuerNames criterion:

        public void setIssuers(Collection<X500Principal> issuers)
        public void setIssuerNames(Collection<?> names)

The issuer distinguished name in the CRL must match at least one of the specified distinguished names. The setIssuers method is preferred as the use of X500Principals to represent distinguished names is more efficient and suitably typed. For the setIssuerNames method, each entry of the names argument is either a String or a byte array (representing the name, in RFC 2253 or ASN.1 DER encoded form, respectively). If null, any issuer distinguished name will do.

The setMinCRLNumber and setMaxCRLNumber methods set the minCRLNumber and maxCRLNumber criterion:

        public void setMinCRLNumber(BigInteger minCRL)
        public void setMaxCRLNumber(BigInteger maxCRL)

The CRL must have a CRL Number extension whose value is greater than or equal to the specified value if the setMinCRLNumber method is called, and less than or equal to the specified value if the setMaxCRLNumber method is called. If the value passed to one of these methods is null, the corresponding check is not done.

The setDateAndTime method sets the dateAndTime criterion:

        public void setDateAndTime(Date dateAndTime)

The specified date must be equal to or later than the value of the thisUpdate component of the CRL and earlier than the value of the nextUpdate component. If null, no dateAndTime check will be done.

The setCertificateChecking method sets the certificate whose revocation status is being checked:

        public void setCertificateChecking(X509Certificate cert)

This is not a criterion. Rather, it is optional information that may help a CertStore find CRLs that would be relevant when checking revocation for the specified certificate. If null is specified, then no such optional information is provided. An application should always call this method when checking revocation for a particular certificate, as it may provide the CertStore with more information for finding the correct CRLs and filtering out irrelevant ones.

Getting Selection Criteria

The current values for each of the selection criteria can be retrieved using an appropriate get method. Please refer to the X509CRLSelectorAPI documentation for further details on these methods.

Example

Creating an X509CRLSelector to retrieve CRLs from an LDAP repository is similar to the X509CertSelector example. Suppose we want to retrieve all current (as of the current date and time) CRLs issued by a specific CA and with a minimum CRL number. First, we create an X509CRLSelector object and call the appropriate methods to set the selection criteria:

        X509CRLSelector xcrls = new X509CRLSelector();
        // select CRLs satisfying current date and time
        xcrls.setDateAndTime(new Date());
        // select CRLs issued by 'O=xyz, C=us'
        xcrls.addIssuerName("O=xyz, C=us");
        // select only CRLs with a CRL number at least '2'
        xcrls.setMinCRLNumber(new BigInteger("2"));

Then we pass the selector to the getCRLs method of our CertStore object (created in the X509CertSelector example):

        Collection<CRL> crls = cs.getCRLs(xcrls);

PKIX Classes

The Java Certification Path API also includes a set of algorithm-specific classes modeled for use with the PKIX certification path validation algorithm defined in RFC 3280: Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile.

The TrustAnchor Class

This class represents a "most-trusted CA", which is used as a trust anchor for validating X.509 certification paths. A most-trusted CA includes the public key of the CA, the CA's name, and any constraints upon the set of paths which may be validated using this key. These parameters can be specified in the form of a trusted X509Certificate or as individual parameters.

All TrustAnchor objects are immutable and thread-safe. That is, multiple threads may concurrently invoke the methods defined in this class on a single TrustAnchor object (or more than one) with no ill effects. Requiring TrustAnchor objects to be immutable and thread-safe allows them to be passed around to various pieces of code without worrying about coordinating access.

Note that although this class is described as a PKIX class it may be used with other X.509 certification path validation algorithms.

Creating a TrustAnchor Object

To instantiate a TrustAnchor object, a caller must specify "the most-trusted CA" as a trusted X509Certificate or public key and distinguished name pair. The caller may also optionally specify name constraints that are applied to the trust anchor by the validation algorithm during initialization. Note that support for name constraints on trust anchors is not required by the PKIX algorithm, therefore a PKIX CertPathValidator or CertPathBuilder may choose not to support this parameter and instead throw an exception. Use one of the following constructors to create a TrustAnchor object:

        public TrustAnchor(X509Certificate trustedCert,
                byte[] nameConstraints)
        public TrustAnchor(X500Principal caPrincipal, PublicKey pubKey,
                byte[] nameConstraints)
        public TrustAnchor(String caName, PublicKey pubKey,
                byte[] nameConstraints)

The nameConstraints parameter is specified as a byte array containing the ASN.1 DER encoding of a NameConstraints extension. An IllegalArgumentException is thrown if the name constraints cannot be decoded (are not formatted correctly).

Getting Parameter Values

Each of the parameters can be retrieved using a corresponding get method:

        public final X509Certificate getTrustedCert()
        public final X500Principal getCA()
        public final String getCAName()
        public final PublicKey getCAPublicKey()
        public final byte[] getNameConstraints()
Note that the getTrustedCert method returns null if the trust anchor was specified as a public key and name pair. Likewise, the getCA, getCAName and getCAPublicKey methods return null if the trust anchor was specified as an X509Certificate.

The PKIXParameters Class

This class (which implements the CertPathParameters interface) specifies the set of input parameters defined by the PKIX certification path validation algorithm. It also includes a few additional useful parameters.

An X.509 CertPath object and a PKIXParameters object are passed as arguments to the validate method of a CertPathValidator instance implementing the PKIX algorithm. The CertPathValidator uses the parameters to initialize the PKIX certification path validation algorithm.

Creating a PKIXParameters Object

To instantiate a PKIXParameters object, a caller must specify "the most-trusted CA(s)" as defined by the PKIX validation algorithm. The most-trusted CAs can be specified using one of two constructors:

        public PKIXParameters(Set<TrustAnchor> trustAnchors)
            throws InvalidAlgorithmParameterException
        public PKIXParameters(KeyStore keystore)
            throws KeyStoreException, InvalidAlgorithmParameterException

The first constructor allows the caller to specify the most-trusted CAs as a Set of TrustAnchor objects. Alternatively, a caller can use the second constructor and specify a KeyStore instance containing trusted certificate entries, each of which will be considered as a most-trusted CA.

Setting Parameter Values

Once a PKIXParameters object has been created, a caller can set (or replace the current value of) various parameters. A few of the methods for setting parameters are described here. Please refer to the PKIXParameters API documentation for details on the other methods.

The setInitialPolicies method sets the initial policy identifiers, as specified by the PKIX validation algorithm. The elements of the Set are object identifiers (OIDs) represented as a String. If the initialPolicies parameter is null or not set, any policy is acceptable:

        public void setInitialPolicies(Set<String> initialPolicies)

The setDate method sets the time for which the validity of the path should be determined. If the date parameter is not set or is null, the current date is used:

        public void setDate(Date date)

The setPolicyMappingInhibited method sets the value of the policy mapping inhibited flag. The default value for the flag, if not specified, is false:

        public void setPolicyMappingInhibited(boolean val)

The setExplicitPolicyRequired method sets the value of the explicit policy required flag. The default value for the flag, if not specified, is false:

        public void setExplicitPolicyRequired(boolean val)

The setAnyPolicyInhibited method sets the value of the any policy inhibited flag. The default value for the flag, if not specified, is false:

        public void setAnyPolicyInhibited(boolean val)

The setTargetCertConstraints method allows the caller to set constraints on the target or end-entity certificate. For example, the caller can specify that the target certificate must contain a specific subject name. The constraints are specified as a CertSelector object. If the selector parameter is null or not set, no constraints are defined on the target certificate:

        public void setTargetCertConstraints(CertSelector selector)

The setCertStores method allows a caller to specify a List of CertStore objects that will be used by a PKIX implementation of CertPathValidator to find CRLs for path validation. This provides an extensible mechanism for specifying where to locate CRLs. The setCertStores method takes a List of CertStore objects as a parameter. The first CertStores in the list may be preferred to those that appear later.

        public void setCertStores(List<CertStore> stores)

The setCertPathCheckers method allows a caller to extend the PKIX validation algorithm by creating implementation-specific certification path checkers. For example, this mechanism can be used to process private certificate extensions. The setCertPathCheckers method takes a list of PKIXCertPathChecker (discussed later) objects as a parameter:

        public void setCertPathCheckers(List<PKIXCertPathChecker> checkers)

The setRevocationEnabled method allows a caller to disable revocation checking. Revocation checking is enabled by default, since it is a required check of the PKIX validation algorithm. However, PKIX does not define how revocation should be checked. An implementation may use CRLs or OCSP, for example. This method allows the caller to disable the implementation's default revocation checking mechanism if it is not appropriate. A different revocation checking mechanism can then be specified by calling the setCertPathCheckers method, and passing it a PKIXCertPathChecker that implements the alternate mechanism.

        public void setRevocationEnabled(boolean val)

The setPolicyQualifiersRejected method allows a caller to enable or disable policy qualifier processing. When a PKIXParameters object is created, this flag is set to true. This setting reflects the most common (and simplest) strategy for processing policy qualifiers. Applications that want to use a more sophisticated policy must set this flag to false.

        public void setPolicyQualifiersRejected(boolean qualifiersRejected)
Getting Parameter Values

The current values for each of the parameters can be retrieved using an appropriate get method. Please refer to the PKIXParameters API documentation for further details on these methods.

The PKIXCertPathValidatorResult Class

This class (which implements the CertPathValidatorResult interface) represents the result of the PKIX certification path validation algorithm. It holds the valid policy tree and subject public key resulting from the validation algorithm, and includes methods (getPolicyTree() and getPublicKey()) for returning them. Instances of PKIXCertPathValidatorResult are returned by the validate method of CertPathValidator objects implementing the PKIX algorithm.

Please refer to the PKIXCertPathValidatorResult API documentation for more detailed information on this class.

The PolicyNode Interface and PolicyQualifierInfo Class

The PKIX validation algorithm defines several outputs related to certificate policy processing. Most applications will not need to use these outputs, but all providers that implement the PKIX validation or building algorithm must support them.

The PolicyNode interface represents a node of a valid policy tree resulting from a successful execution of the PKIX certification path validation. An application can obtain the root of a valid policy tree using the getPolicyTree method of PKIXCertPathValidatorResult. Policy Trees are discussed in more detail in the PKIX Certificate and CRL Profile.

The getPolicyQualifiers method of PolicyNode returns a Set of PolicyQualifierInfo objects, each of which represents a policy qualifier contained in the Certificate Policies extension of the relevant certificate that this policy applies to.

Most applications will not need to examine the valid policy tree and policy qualifiers. They can achieve their policy processing goals by setting the policy-related parameters in PKIXParameters. However, the valid policy tree is available for more sophisticated applications, especially those that process policy qualifiers.

Please refer to the PolicyNode and PolicyQualifierInfo API documentation for more detailed information on these classes.

Example of Validating a Certification Path using the PKIX algorithm

This is an example of validating a certification path with the PKIX validation algorithm. The example ignores most of the exception handling and assumes that the certification path and public key of the trust anchor have already been created.

First, create the CertPathValidator, as in the following line:

    CertPathValidator cpv = CertPathValidator.getInstance("PKIX");

The next step is to create a TrustAnchor object. This will be used as an anchor for validating the certification path. In this example, the most-trusted CA is specified as a public key and name (name constraints are not applied and are specified as null):

    TrustAnchor anchor = new TrustAnchor("O=xyz,C=us", pubkey, null);

The next step is to create a PKIXParameters object. This will be used to populate the parameters used by the PKIX algorithm. In this example, we pass to the constructor a Set containing a single element - the TrustAnchor we created in the previous step:

    PKIXParameters params = new PKIXParameters(Collections.singleton(anchor));

Next, we populate the parameters object with constraints or other parameters used by the validation algorithm. In this example, we enable the explicitPolicyRequired flag and specify a set of initial policy OIDs (the contents of the set are not shown):

    // set other PKIX parameters here
    params.setExplicitPolicyRequired(true);
    params.setInitialPolicies(policyIds);

The final step is to validate the certification path using the input parameter set we have created:

    try {
        PKIXCertPathValidatorResult result =
            (PKIXCertPathValidatorResult) cpv.validate(certPath, params);
        PolicyNode policyTree = result.getPolicyTree();
        PublicKey subjectPublicKey = result.getPublicKey();
    } catch (CertPathValidatorException cpve) {
        System.out.println("Validation failure, cert["
            + cpve.getIndex() + "] :" + cpve.getMessage());
    }

If the validation algorithm is successful, the policy tree and subject public key resulting from the validation algorithm are obtained using the getPolicyTree and getPublicKey methods of PKIXCertPathValidatorResult.

Otherwise, a CertPathValidatorException is thrown and the caller can catch the exception and print some details about the failure, such as the error message and the index of the certificate that caused the failure.

The PKIXBuilderParameters Class

This class (which extends the PKIXParameters class) specifies the set of parameters to be used with CertPathBuilders that build certification paths validated against the PKIX certification path validation algorithm.

A PKIXBuilderParameters object is passed as an argument to the build method of a CertPathBuilder instance implementing the PKIX algorithm. All PKIX CertPathBuilders must return certification paths which have been validated according to the PKIX certification path validation algorithm.

Please note that the mechanism that a PKIX CertPathBuilder uses to validate a constructed path is an implementation detail. For example, an implementation might attempt to first build a path with minimal validation and then fully validate it using an instance of a PKIX CertPathValidator, whereas a more efficient implementation may validate more of the path as it is building it, and backtrack to previous stages if it encounters validation failures or dead-ends.

Creating a PKIXBuilderParameters Object

Creating a PKIXBuilderParameters object is similar to creating a PKIXParameters object. However, a caller must specify constraints on the target or end-entity certificate when creating a PKIXBuilderParameters object. These constraints should provide the CertPathBuilder with enough information to find the target certificate. The constraints are specified as a CertSelector object. Use one of the following constructors to create a PKIXBuilderParameters object:

        public PKIXBuilderParameters(Set<TrustAnchor> trustAnchors,
                CertSelector targetConstraints)
                throws InvalidAlgorithmParameterException
        public PKIXBuilderParameters(KeyStore keystore,
                CertSelector targetConstraints)
                throws KeyStoreException, InvalidAlgorithmParameterException
Getting/Setting Parameter Values

The PKIXBuilderParameters class inherits all of the parameters that can be set in the PKIXParameters class. In addition, the setMaxPathLength method can be called to place a limit on the maximum number of certificates in a certification path:

        public void setMaxPathLength(int maxPathLength)

The maxPathLength parameter specifies the maximum number of non-self-issued intermediate certificates that may exist in a certification path. A CertPathBuilder instance implementing the PKIX algorithm must not build paths longer than the length specified. If the value is 0, the path can only contain a single certificate. If the value is -1, the path length is unconstrained (i.e., there is no maximum). The default maximum path length, if not specified, is 5. This method is useful to prevent the CertPathBuilder from spending resources and time constructing long paths that may or may not meet the caller's requirements.

If any of the CA certificates in the path contain a Basic Constraints extension, the value of the pathLenConstraint component of the extension overrides the value of the maxPathLength parameter whenever the result is a certification path of smaller length. There is also a corresponding getMaxPathLength method for retrieving this parameter:

        public int getMaxPathLength()

Also, the setCertStores method (inherited from the PKIXParameters class) is typically used by a PKIX implementation of CertPathBuilder to find Certificates for path construction as well as finding CRLs for path validation. This provides an extensible mechanism for specifying where to locate Certificates and CRLs.

The PKIXCertPathBuilderResult Class

This class (which extends the PKIXCertPathValidatorResult class and implements the CertPathBuilderResult interface) represents the successful result of the PKIX certification path construction algorithm. Instances of PKIXCertPathBuilderResult are returned by the build method of CertPathBuilder objects implementing the PKIX algorithm.

The getCertPath method of a PKIXCertPathBuilderResult instance always returns a CertPath object validated using the PKIX certification path validation algorithm. The returned CertPath object does not include the most-trusted CA certificate that may have been used to anchor the path. Instead, use the getTrustAnchor method to get the Certificate of the most-trusted CA.

Please refer to the PKIXCertPathBuilderResult API documentation for more detailed information on this class.

Example of Building a Certification Path using the PKIX algorithm

This is an example of building a certification path validated against the PKIX algorithm. Some details have been left out, such as exception handling, and the creation of the trust anchors and certificates for populating the CertStore.

First, create the CertPathBuilder, as in the following example:

    CertPathBuilder cpb = CertPathBuilder.getInstance("PKIX");

This call creates a CertPathBuilder object that returns paths validated against the PKIX algorithm.

The next step is to create a PKIXBuilderParameters object. This will be used to populate the PKIX parameters used by the CertPathBuilder:

    // Create parameters object, passing it a Set of
    // trust anchors for anchoring the path
    // and a target subject DN.
    X509CertSelector targetConstraints = new X509CertSelector();
    targetConstraints.setSubject("CN=alice,O=xyz,C=us");
    PKIXBuilderParameters params =
        new PKIXBuilderParameters(trustAnchors, targetConstraints);

The next step is to specify the CertStore that the CertPathBuilder will use to look for certificates and CRLs. For this example, we will populate a Collection CertStore with the certificates and CRLs:

    CollectionCertStoreParameters ccsp =
        new CollectionCertStoreParameters(certsAndCrls);
    CertStore store = CertStore.getInstance("Collection", ccsp);
    params.addCertStore(store);

The next step is to build the certification path using the input parameter set we have created:

    try {
        PKIXCertPathBuilderResult result =
            (PKIXCertPathBuilderResult) cpb.build(params);
        CertPath cp = result.getCertPath();
    } catch (CertPathBuilderException cpbe) {
        System.out.println("build failed: " + cpbe.getMessage());
    }

If the CertPathBuilder cannot build a path that meets the supplied parameters it will throw a CertPathBuilderException. Otherwise, the validated certification path can be obtained from the PKIXCertPathBuilderResult using the getCertPath method.

The PKIXCertPathChecker Class

This section describes a powerful class that allows a user to extend a PKIX CertPathValidator or CertPathBuilder implementation. This is an advanced feature that most users will not need to understand. However, anyone implementing a PKIX service provider should read this section.

The PKIXCertPathChecker class is an abstract class that executes one or more checks on an X.509 certificate. Developers should create concrete implementations of the PKIXCertPathChecker class when it is necessary to dynamically extend a PKIX CertPathValidator or CertPathBuilder implementation at runtime. The following are a few examples of when a PKIXCertPathChecker implementation is useful:

  • If the revocation mechanism supplied by a PKIX CertPathValidator or CertPathBuilder implementation is not adequate: For example, you can use the PKIXRevocationChecker class (introduced in JDK 8; see Check Revocation Status of Certificates with PKIXRevocationChecker Class) to have more control over the revocation mechanism, or you can implement your own PKIXCertPathChecker to check that certificates have not been revoked.

  • If the user wants to recognize certificates containing a critical private extension. Since the extension is private, it will not be recognized by the PKIX CertPathValidator or CertPathBuilder implementation and a CertPathValidatorException will be thrown. In this case, a developer can implement a PKIXCertPathChecker that recognizes and processes the critical private extension.

  • If the developer wants to record information about each certificate processed for debugging or display purposes.

  • If the user wants to reject certificates with certain policy qualifiers.

The setCertPathCheckers method of the PKIXParameters class allows a user to pass a List of PKIXCertPathChecker objects to a PKIX CertPathValidator or CertPathBuilder implementation. Each of the PKIXCertPathChecker objects will be called in turn, for each certificate processed by the PKIX CertPathValidator or CertPathBuilder implementation.

Creating and using a PKIXCertPathChecker Object

The PKIXCertPathChecker class does not have a public constructor. This is intentional, since creating an instance of PKIXCertPathChecker is an implementation-specific issue. For example, the constructor for a PKIXCertPathChecker implementation that uses OCSP to check a certificate's revocation status may require the hostname and port of the OCSP server:

        PKIXCertPathChecker checker = new OCSPChecker("ocsp.sun.com", 1321);

Once the checker has been instantiated, it can be added as a parameter using the addCertPathChecker method of the PKIXParameters class:

        params.addCertPathChecker(checker);

Alternatively, a List of checkers can be added using the setCertPathCheckers method of the PKIXParameters class.

Implementing a PKIXCertPathChecker Object

The PKIXCertPathChecker class is abstract. It has four methods (check, getSupportedExtensions, init, and isForwardCheckingSupported) that all concrete subclasses must implement.

Implementing a PKIXCertPathChecker may be trivial or complex. A PKIXCertPathChecker implementation can be stateless or stateful. A stateless implementation does not maintain state between successive calls of the check method. For example, a PKIXCertPathChecker that checks that each certificate contains a particular policy qualifier is stateless. In contrast, a stateful implementation does maintain state between successive calls of the check method. The check method of a stateful implementation usually depends on the contents of prior certificates in the certification path. For example, a PKIXCertPathChecker that processes the NameConstraints extension is stateful.

Also, the order in which the certificates processed by a service provider implementation are presented (passed) to a PKIXCertPathChecker is very important, especially if the implementation is stateful. Depending on the algorithm used by the service provider, the certificates may be presented in reverse or forward order. A reverse ordering means that the certificates are ordered from the most trusted CA (if present) to the target subject, whereas a forward ordering means that the certificates are ordered from the target subject to the most trusted CA. The order must be made known to the PKIXCertPathChecker implementation, so that it knows how to process consecutive certificates.

Initializing a PKIXCertPathChecker Object

The init method initializes the internal state of the checker:

        public abstract void init(boolean forward)

All stateful implementations should clear or initialize any internal state in the checker. This prevents a service provider implementation from calling a checker that is in an uninitialized state. It also allows stateful checkers to be reused in subsequent operations without reinstantiating them. The forward parameter indicates the order of the certificates presented to the PKIXCertPathChecker. If forward is true, the certificates are presented from target to trust anchor; if false, from trust anchor to target.

Forward Checking

The isForwardCheckingSupported method returns a boolean that indicates if the PKIXCertPathChecker supports forward checking:

        public abstract boolean isForwardCheckingSupported()

All PKIXCertPathChecker implementations mustsupport reverse checking. A PKIXCertPathChecker implementation maysupport forward checking.

Supporting forward checking improves the efficiency of CertPathBuilders that build forward, since it allows paths to be checked as they are built. However, some stateful PKIXCertPathCheckers may find it difficult or impossible to support forward checking.

Supported Extensions

The getSupportedExtensions method returns an immutable Set of OID Strings for the X.509 extensions that the PKIXCertPathChecker implementation supports (i.e., recognizes, is able to process):

        public abstract Set<String> getSupportedExtensions()

The method should return null if no extensions are processed. All implementations should return the Set of OID Strings that the check method may process.

A CertPathBuilder can use this information to identify certificates with unrecognized critical extensions, even when performing a forward build with a PKIXCertPathChecker that does not support forward checking.

Executing the Check

The following method executes a check on the certificate:

        public abstract void
                check(Certificate cert, Collection<String> unresolvedCritExts)
                throws CertPathValidatorException

The unresolvedCritExts parameter contains a collection of OIDs as Strings. These OIDs represent the set of critical extensions in the certificate that have not yet been resolved by the certification path validation algorithm. Concrete implementations of the check method should remove any critical extensions that it processes from the unresolvedCritExts parameter.

If the certificate does not pass the check(s), a CertPathValidatorException should be thrown.

Cloning a PKIXCertPathChecker

The PKIXCertPathChecker class implements the Cloneable interface. All stateful PKIXCertPathChecker implementations must override the clone method if necessary. The default implementation of the clone method calls the Object.clone method, which performs a simple clone by copying all fields of the original object to the new object. A stateless implementation should not override the clone method. However, all stateful implementations must ensure that the default clone method is correct, and override it if necessary. For example, a PKIXCertPathChecker that stores state in an array must override the clone method to make a copy of the array, rather than just a reference to the array.

The reason that PKIXCertPathChecker objects are Cloneable is to allow a PKIX CertPathBuilder implementation to efficiently backtrack and try another path when a potential certification path reaches a dead end or point of failure. In this case, the implementation is able to restore prior path validation states by restoring the cloned objects.

Example

This is an example of a stateless PKIXCertPathChecker implementation. It checks if a private extension exists in a certificate and processes it according to some rules.

        import java.security.cert.Certificate;
        import java.security.cert.X509Certificate;
        import java.util.Collection;
        import java.util.Collections;
        import java.util.Set;
        import java.security.cert.PKIXCertPathChecker;
        import java.security.cert.CertPathValidatorException;

        public class MyChecker extends PKIXCertPathChecker {
            private static Set supportedExtensions =
                Collections.singleton("2.16.840.1.113730.1.1");

            /*
             * Initialize checker
             */
            public void init(boolean forward)
                throws CertPathValidatorException {
                // nothing to initialize
            }

            public Set getSupportedExtensions() {
                return supportedExtensions;
            }

            public boolean isForwardCheckingSupported() {
                return true;
            }

            /*
             * Check certificate for presence of Netscape's
             * private extension
             * with OID "2.16.840.1.113730.1.1"
             */
            public void check(Certificate cert,
                              Collection unresolvedCritExts)
                throws CertPathValidatorException
            {
                X509Certificate xcert = (X509Certificate) cert;
                byte[] ext =
                    xcert.getExtensionValue("2.16.840.1.113730.1.1");
                if (ext == null)
                    return;

                //
              // process private extension according to some
                // rules - if check fails, throw a
                // CertPathValidatorException ...
                // {insert code here}

                // remove extension from collection of unresolved
                // extensions (if it exists)
                if (unresolvedCritExts != null)
                    unresolvedCritExts.remove("2.16.840.1.113730.1.1");
            }
        }
How a PKIX Service Provider implementation should use a PKIXCertPathChecker

Each PKIXCertPathChecker object must be initialized by a service provider implementation before commencing the build or validation algorithm, for example:

        List<PKIXCertPathChecker> checkers = params.getCertPathCheckers();
        for (PKIXCertPathChecker checker : checkers) {
            checker.init(false);
        }

For each certificate that it validates, the service provider implementation must call the check method of each PKIXCertPathChecker object in turn, passing it the certificate and any remaining unresolved critical extensions:

        for (PKIXCertPathChecker checker : checkers) {
            checker.check(cert, unresolvedCritExts);
        }

If any of the checks throw a CertPathValidatorException, a CertPathValidator implementation should terminate the validation procedure. However, a CertPathBuilder implementation may simply log the failure and continue to search for other potential paths. If all of the checks are successful, the service provider implementation should check that all critical extensions have been resolved and if not, consider the validation to have failed. For example:

        if (unresolvedCritExts != null &&
            !unresolvedCritExts.isEmpty())
        {
            // note that a CertPathBuilder may have an enclosing
            // try block to catch the exception below and continue on error
            throw new CertPathValidatorException
                ("Unrecognized Critical Extension");
        }

As discussed in the previous section, a CertPathBuilder implementation may need to backtrack when a potential certification path reaches a dead end or point of failure. Backtracking in this context implies returning to the previous certificate in the path and checking for other potential paths. If the CertPathBuilder implementation is validating the path as it is building it, it will need to restore the previous state of each PKIXCertPathChecker. It can do this by making clones of the PKIXCertPathChecker objects before each certificate is processed, for example:

        /* clone checkers */
        List newList = new ArrayList(checkers);
        ListIterator li = newList.listIterator();
        while (li.hasNext()) {
            PKIXCertPathChecker checker = (PKIXCertPathChecker) li.next();
            li.set(checker.clone());
        }

Using PKIXCertPathChecker in Certificate Path Validation

Using a PKIXCertPathChecker to customize certificate path validation is relatively straightforward.

Basic Certification Path Validation

First, consider code that validates a certificate path:

Set<TrustAnchor> trustAnchors = getTrustAnchors();
CertPath cp = getCertPath();

PKIXParameters pkixp = new PKIXParameters(trustAnchors);
pkixp.setRevocationEnabled(false);

CertPathValidator cpv = CertPathValidator.getInstance("PKIX");
PKIXCertPathValidatorResult pcpvr =
    (PKIXCertPathValidatorResult)cpv.validate(cp, pkixp);

If the validation fails, the validate() method throws an exception.

The fundamental steps are as follows:

  1. Obtain the CA root certificates and the certification path to be validated.
  2. Create a PKIXParameters with the trust anchors.
  3. Use a CertPathValidator to validate the certificate path.

In this example, getTrustAnchors() and getCertPath() are the methods that obtain CA root certificates and the certification path.

The getTrustAnchors() method in the example must return a Set of TrustAnchors that represent the CA root certificates you wish to use for validation. Here is one simple implementation that loads a single CA root certificate from a file:

public Set<TrustAnchor> getTrustAnchors()
    throws IOException, CertificateException {
  InputStream in = new FileInputStream("x509_ca-certificate.cer");
  CertificateFactory cf = CertificateFactory.getInstance("X.509");
  X509Certificate c = (X509Certificate)cf.generateCertificate(in);
  in.close();

  TrustAnchor anchor = new TrustAnchor(c, null);
  return Collections.singleton(anchor);
}

Similarly, here is a simple implementation of getCertPath() that loads a certificate path from a file:

public CertPath getCertPath() throws IOException, CertificateException {
  CertificateFactory cf = CertificateFactory.getInstance("X.509");

  InputStream in = new FileInputStream("certpath.pkcs7");
  CertPath cp = cf.generateCertPath(in, "PKCS7");
  in.close();

  return cp;
}

Note that PKCS#7 does not require a specific order for the certificates in the file, so this code only works for certification path validation when the certificates are ordered starting from the entity to be validated and progressing back toward the CA root. If the certificates are not in the right order, you need to do some additional processing. CertificateFactory has a generateCertPath() method that accepts a Collection, which is useful for this type of processing.

Adding in a PKIXCertPathChecker

To customize certification path validation, add a PKIXCertPathChecker as follows. In this example, SimpleChecker is a PKIXCertPathChecker subclass. The new lines are shown in bold.

Set<TrustAnchor> trustAnchors = getTrustAnchors();
CertPath cp = getCertPath();

PKIXParameters pkixp = new PKIXParameters(trustAnchors);
pkixp.setRevocationEnabled(false);

SimpleChecker sc = new SimpleChecker();
pkixp.addCertPathChecker(sc);

CertPathValidator cpv = CertPathValidator.getInstance("PKIX");
PKIXCertPathValidatorResult pcpvr =
    (PKIXCertPathValidatorResult)cpv.validate(cp, pkixp);

SimpleChecker is a rudimentary subclass of PKIXCertPathChecker. Its check() method is called for every certificate in the certification path that is being validated. SimpleChecker uses an AlgorithmConstraints implementation to examine the signature algorithm and public key of each certificate.

import java.security.AlgorithmConstraints;
import java.security.CryptoPrimitive;
import java.security.Key;
import java.security.cert.*;
import java.util.*;

public class SimpleChecker extends PKIXCertPathChecker {
  private final static Set<CryptoPrimitive> SIGNATURE_PRIMITIVE_SET =
      EnumSet.of(CryptoPrimitive.SIGNATURE);

  public void init(boolean forward) throws CertPathValidatorException {}

  public boolean isForwardCheckingSupported() { return true; }

  public Set<String> getSupportedExtensions() { return null; }

  public void check(Certificate cert,
      Collection<String> unresolvedCritExts)
      throws CertPathValidatorException {
    X509Certificate c = (X509Certificate)cert;
    String sa = c.getSigAlgName();
    Key key = c.getPublicKey();

    AlgorithmConstraints constraints = new SimpleConstraints();

    if (constraints.permits(SIGNATURE_PRIMITIVE_SET, sa, null) == false)
      throw new CertPathValidatorException("Forbidden algorithm: " + sa);

    if (constraints.permits(SIGNATURE_PRIMITIVE_SET, key) == false)
      throw new CertPathValidatorException("Forbidden key: " + key);
  }
}

Finally, SimpleConstraints is a rather severe AlgorithmConstraints implementation that allows only RSA algorithms and requires keys to be 2048 bits or larger.

import java.security.AlgorithmConstraints;
import java.security.AlgorithmParameters;
import java.security.CryptoPrimitive;
import java.security.Key;
import java.security.interfaces.RSAKey;
import java.util.Set;

public class SimpleConstraints implements AlgorithmConstraints {
  public boolean permits(Set<CryptoPrimitive> primitives,
      String algorithm, AlgorithmParameters parameters) {
    return permits(primitives, algorithm, null, parameters);
  }

  public boolean permits(Set<CryptoPrimitive> primitives, Key key) {
    return permits(primitives, null, key, null);
  }

  public boolean permits(Set<CryptoPrimitive> primitives,
      String algorithm, Key key, AlgorithmParameters parameters) {
    if (algorithm == null) algorithm = key.getAlgorithm();

    if (algorithm.indexOf("RSA") == -1) return false;

    if (key != null) {
      RSAKey rsaKey = (RSAKey)key;
      int size = rsaKey.getModulus().bitLength();
      if (size < 2048) return false;
    }

    return true;
  }
}
Check Revocation Status of Certificates with PKIXRevocationChecker Class

The PKIXRevocationChecker class (introduced in JDK 8), which is a subclass of PKIXCertPathChecker, checks the revocation status of certificates with the PKIX algorithm.

An instance of PKIXRevocationChecker checks the revocation status of certificates with the Online Certificate Status Protocol (OCSP) or Certificate Revocation Lists (CRLs). OCSP is described in RFC 2560 and is a network protocol for determining the status of a certificate. A CRL is a time-stamped list identifying revoked certificates, and RFC 5280 describes an algorithm for determining the revocation status of certificates using CRLs.

Each PKIX CertPathValidator and CertPathBuilder instance provides a default revocation implementation that is enabled by default. If you want more control over the revocation settings used by that implementation, use the PKIXRevocationChecker class.

Follow these general steps to check the revocation status of a certificate path with the PKIXRevocationChecker class:

  1. Obtain a PKIXRevocationChecker instance by calling the getRevocationChecker method of a PKIX CertPathValidator or CertPathBuilder instance.

  2. Set additional parameters and options specific to certificate revocation with methods contained in the PKIXRevocationChecker class. These methods include setOCSPResponder(URI), which sets the URI that identifies the location of the OCSP responder (although normally the URI is included in the certificate and does not have to be set) and setOptions(Set<PKIXRevocationChecker.Option>), which sets revocation options. PKIXRevocationChecker.Option is an enumerated type used to specify the following options:

    • ONLY_END_ENTITY: Only check the revocation status of end-entity certificates.
    • PREFER_CRLS: By default, OCSP is the preferred mechanism for checking revocation status, with CRLs as the fallback mechanism. Switch this preference to CRLs with this option.
    • SOFT_FAIL: Ignore network failures.

  3. After obtaining an instance of PKIXRevocationChecker, add it to a PKIXParameters or PKIXBuilderParameters object with the addCertPathChecker or setCertPathCheckers method.

  4. Follow one of these steps depending on whether you are using a PKIX CertPathValidator or CertPathBuilder instance:

    • If you are using a PKIX CertPathValidator instance, call the validate method using as arguments the certificate path you want to validate and the PKIXParameters object that contains a revocation checker.

    • If you are using a PKIX CertPathBuilder instance, call the build method using as arguments the PKIXBuilderParameters object that contains a revocation checker.

  5. Call the validate method of the PKIX CertPathValidator or CertPathBuilder instance using as arguments the certificate path you want to validate and the PKIXParameters or PKIXBuilderParameters object that contains a revocation checker.

The following excerpt checks the revocation status of certificates contained in a certificate path. The CertPath object path is the certificate path, and params is an object of type PKIXParameters:

    CertPathValidator cpv = CertPathValidator.getInstance("PKIX");
    PKIXRevocationChecker rc = (PKIXRevocationChecker)cpv.getRevocationChecker();
    rc.setOptions(EnumSet.of(Option.SOFT_FAIL));
    params.addCertPathChecker(rc);
    params.setRevocationEnabled(false);
    CertPathValidatorResult res = cpv.validate(path, params);

In this excerpt, the SOFT_FAIL option causes the revocation checker to ignore any network failures (such as failing to establish a connection to the OCSP server) when it checks the revocation status.

Implementing a Service Provider

This section is intended for experienced programmers wishing to create their own provider packages supplying certification path service implementations. This section assumes you have read the document: How to Implement a Provider for the Java Cryptography Architecture.

The following engine classes are defined in the Java Certification Path API:

  • CertPathValidator - used to validate certification paths

  • CertPathBuilder - used to build certification paths

  • CertStore - used to retrieve certificates and CRLs from a repository

In addition, the pre-existing CertificateFactory engine class was enhanced in the JDK 1.4 to support generation of certification paths.

The application interfaces supplied by an engine class are implemented in terms of a "Service Provider Interface" (SPI). The name of each SPI class is the same as that of the corresponding engine class, followed by "Spi". For example, the SPI class corresponding to the CertPathValidator engine class is the CertPathValidatorSpi class. Each SPI class is abstract. To supply the implementation of a particular type of service, for a specific algorithm or type, a provider must subclass the corresponding SPI class and provide implementations for all the abstract methods. For example, the CertStore class provides access to the functionality of retrieving certificates and CRLs from a repository. The actual implementation supplied in a CertStoreSpi subclass would be that for a specific type of certificate repository, such as LDAP.

Steps to Implement and Integrate a Provider

Developers should follow the required steps listed in the How To Implement A Provider for the Java Cryptography Architecture document. Here are some additional rules to follow for certain steps:

Step 3: Write your "Master Class", a subclass of Provider

These are the properties that must be defined for the certification path services, where the algorithm name is substituted for algName, and certstore type for storeType:

  • CertPathValidator.algName

  • CertPathBuilder.algName

  • CertStore.storeType

See Appendix A for the standard names that are defined for algName and storeType. The value of each property must be the fully qualified name of the class implementing the specified algorithm, or certstore type. That is, it must be the package name followed by the class name, where the two are separated by a period. For example, a provider sets the CertPathValidator.PKIX property to have the value "sun.security.provider.certpath.PKIXCertPathValidator" as follows:

put("CertPathValidator.PKIX", "sun.security.provider.certpath.PKIXCertPathValidator")

In addition, service attributes can be defined for the certification path services. These attributes can be used as filters for selecting service providers. See Appendix A for the definition of some standard service attributes. For example, a provider may set the ValidationAlgorithm service attribute to the name of an RFC or specification that defines the PKIX validation algorithm:

put("CertPathValidator.PKIX ValidationAlgorithm", "RFC3280");

Step 8: Document your Provider and its Supported Services

Certification path service providers should document the following information for each SPI:

Certificate Factories

A provider should document what types of certification paths (and the version numbers of the certificates in the path, if relevant) can be created by the factory. A provider should describe the ordering of the certificates in the certification path, as well as the contents.

A provider should document the list of encoding formats supported. This is not technically necessary, since the client can request them by calling the getCertPathEncodings method. However, the documentation should describe each encoding format in more detail and reference any standards when applicable.

Certification Path Validators

A provider should document any relevant information regarding the CertPathValidator implementation, including the types of certification paths that it validates. In particular, a PKIX CertPathValidator implementation should document the following information:

  • The RFC or specification it is compliant with.
  • The mechanism it uses to check that certificates have not been revoked.
  • Any optional certificate or CRL extensions that it recognizes and how it processes them.

Certification Path Builders

A provider should document any relevant information regarding the CertPathBuilder implementation, including the types of certification paths that it creates and whether or not they are validated. In particular a PKIX CertPathBuilder implementation should document the following information:

  • The RFC or specification it is compliant with.
  • The mechanism it uses to check that certificates have not been revoked.
  • Any optional certificate or CRL extensions that it recognizes and how it processes them.
  • Details on the algorithm it uses for finding certification paths. Ex: depth-first, breadth-first, forward (i.e., from target to trust anchor(s)), reverse (i.e., from trust anchor(s) to target).
  • The algorithm it uses to select and sort potential certificates. For example, given two certificates that are potential candidates for the next certificate in the path, what criteria are used to select one before the other? What criteria are used to reject a certificate?
  • If applicable, the algorithm it uses for backtracking or constructing another path (i.e., when potential paths do not meet constraints).
  • The types of CertStore implementations that have been tested. The implementation should be designed to work with any CertStore type, but this information may still be useful.

All CertPathBuilder implementations should provide additional debugging support, in order to analyze and correct potential path building problems. Details on how to access this debugging information should be documented.

Certificate/CRL Stores

A provider should document what types of certificates and CRLs (and the version numbers, if relevant) are retrieved by the CertStore.

A provider should also document any relevant information regarding the CertStore implementation (such as protocols used or formats supported). For example, an LDAP CertStore implementation should describe which versions of LDAP are supported and which standard attributes are used for finding certificates and CRLs. It should also document if the implementation caches results, and for how long (i.e., under what conditions are they refreshed).

If the implementation returns the certificates and CRLs in a particular order, it should describe the sorting algorithm. An implementation should also document any additional or default initialization parameters.

Finally, an implementation should document if and how it uses information in the CertSelector or CRLSelector objects to find certificates and CRLs.

Service Interdependencies

Here are some common types of algorithm interdependencies in certification path service implementations:

Certification Path Validation and Signature Algorithms

A CertPathValidator implementation often requires use of a signature algorithm to verify each certificate's digital signature. The setSigProvider method of the PKIXParameters class allows a user to specify a specific Signature provider.

Certification Path Builders and Certificate Factories

A CertPathBuilder implementation will often utilize a CertificateFactory to generate a certification path from a list of certificates.

CertStores and Certificate Factories

A CertStore implementation will often utilize a CertificateFactory to generate certificates and CRLs from their encodings. For example, an LDAP CertStore implementation may use an X.509 CertificateFactory to generate X.509 certificates and CRLs from their ASN.1 encoded form.

Certification Path Parameter Specification Interfaces

The Certification Path API contains two interfaces representing transparent specifications of parameters, the CertPathParameters and CertStoreParameters interfaces.

Two implementations of the CertPathParameters interface are included, the PKIXParameters and PKIXBuilderParameters classes. If you are working with PKIX certification path validation and algorithm parameters, you can utilize these classes. If you need parameters for a different algorithm, you will need to supply your own CertPathParameters implementation for that algorithm.

Two implementations of the CertStoreParameters interface are included, the LDAPCertStoreParameters and the CollectionCertStoreParameters classes. These classes are to be used with LDAP and Collection CertStore implementations, respectively. If you need parameters for a different repository type, you will need to supply your own CertStoreParameters implementation for that type.

The CertPathParameters and CertStoreParameters interfaces each define a clone method that implementations should override. A typical implementation will perform a "deep" copy of the object, such that subsequent changes to the copy will not affect the original (and vice versa). However, this is not an absolute requirement for implementations of CertStoreParameters. A shallow copy implementation of clone is more appropriate for applications that need to hold a reference to a parameter contained in the CertStoreParameters. For example, since CertStore.getInstance makes a clone of the specified CertStoreParamters, a shallow copy clone allows an application to hold a reference to and later release the resources of a particular CertStore initialization parameter, rather than waiting for the garbage collection mechanism. This should be done with the utmost care, since the CertStore may still be in use by other threads.

Certification Path Result Specification Interfaces

The Certification Path API contains two interfaces representing transparent specifications of results, the CertPathValidatorResult and CertPathBuilderResult interfaces.

One implementation for each of the interfaces is included: the PKIXCertPathValidatorResult and PKIXCertPathBuilderResult classes. If you are implementing PKIX certification path service providers, you can utilize these classes. If you need certification path results for a different algorithm, you will need to supply your own CertPathValidatorResult or CertPathBuilderResult implementation for that algorithm.

A PKIX implementation of a CertPathValidator or a CertPathBuilder may find it useful to store additional information in the PKIXCertPathValidatorResult or PKIXCertPathBuilderResult, such as debugging traces. In these cases, the implementation should implement a subclass of the appropriate result class with methods to retrieve the relevant information. These classes must be shipped with the provider classes, for example, as part of the provider JAR file.

Certification Path Exception Classes

The Certification Path API contains a set of exception classes for handling errors. CertPathValidatorException, CertPathBuilderException, and CertStoreException are subclasses of GeneralSecurityException.

You may need to extend these classes in your service provider implementation. For example, a CertPathBuilder implementation may provide additional information such as debugging traces when a CertPathBuilderException is thrown. The implementation may throw a subclass of CertPathBuilderException that holds this information. Likewise, a CertStore implementation can provide additional information when a failure occurs by throwing a subclass of CertStoreException. Also, you may want to implement a subclass of CertPathValidatorException to describe a particular failure mode of your CertPathValidator implementation.

In each case, the new exception classes must be shipped with the provider classes, for example, as part of the provider JAR file. Each provider should document the exception subclasses.

TrustAnchor Class

As previously mentioned, a PKIX CertPathValidator or CertPathBuilder is not required to support the nameConstraints parameter of the TrustAnchor class. Implementations should throw an InvalidAlgorithmParameterException if this parameter is not supported.

Signature Timestamp Support

Introduction

This section describes the enhancements that have been added to support signature timestamps.

Prior to Java SE 5.0, the signature generated by jarsigner contained no information about w hen the signature was generated. With no other information available, systems/deployers (including users of the Java Plug-in) often based their validity assessment of a signed JAR file on the validity of the signing certificate. When the signing certificate expires, systems/deployers conclude that the signature, and hence, the JAR file, has expired. Because signing certificates typically expire annually, this caused customers significant problems by forcing them to re-sign deployed JAR files annually.

Starting in Java SE 5.0, jarsigner can generate signatures that include a timestamp, thus enabling systems/deployer (including Java Plug-in) to check whether the JAR file was signed while the signing certificate was still valid. In addition, APIs were added in Java SE 5.0 to allow applications to obtain the timestamp information.

The following time-of-signing enhancements and additions are supported:

  • Jarsigner Enhancements
  • Java Plug-in Enhancements
  • API Enhancements

Jarsigner Enhancements

The jarsigner tool can now generate and store a signature timestamp when signing a JAR file. In addition, jarsigner supports alternative signing mechanisms. This behavior is optional and is controlled by the user at the time of signing through the options described below.

Jarsigner Timestamp Options

The following jarsigner options support signature timestamps:

-tsa url

If "-tsa http://example.tsa.url" appears on the command line when signing a JAR file then a timestamp is generated for the signature. The URL, http://example.tsa.url, identifies the location of the Time Stamping Authority (TSA). It overrides any URL found via the -tsacert option. The -tsa option does not require the TSA's public key certificate to be present in the keystore.

To generate the timestamp, jarsigner communicates with the TSA using the Time-Stamp Protocol (TSP) defined in RFC 3161. If successful, the timestamp token returned by the TSA is stored along with the signature in the signature block file.

-tsacert alias

If "-tsacert alias" appears on the command line when signing a JAR file then a timestamp is generated for the signature. The alias identifies the TSA's public key certificate in the keystore that is currently in effect. The entry's certificate is examined for a Subject Information Access extension that contains a URL identifying the location of the TSA.

The TSA's public key certificate must be present in the keystore when using -tsacert.

Alternative Signing Options

Specifying an Alternative Signing Mechanism

-altsigner class

Specifies that an alternative signing mechanism be used. The fully-qualified class name identifies a class file that extends the com.sun.jarsigner.ContentSigner abstract class. The path to this class file is defined by the -altsignerpath option. If the -altsigner option is used, jarsigner uses the signing mechanism provided by the specified class. Otherwise, jarsigner uses its default signing mechanism.

For example, to use the signing mechanism provided by a class named com.sun.sun.jarsigner.AuthSigner, use the jarsigner option "-altsigner com.sun.jarsigner.AuthSigner"

Specifying Path to Alternative Signing Mechanism

-altsignerpath classpathlist

Specifies the path to the class file (the class file name is specified with the -altsigner option described above) and any JAR files it depends on. If the class file is in a JAR file, then this specifies the path to that JAR file, as shown in the example below.

An absolute path or a path relative to the current directory may be specified. If classpathlist contains multiple paths or JAR files, they should be separated with a colon (:) on Solaris and a semi-colon (;) on Windows. This option is not necessary if the class is already in the search path.

Example of specifying the path to a jar file that contains the class file:

    -altsignerpath /home/user/lib/authsigner.jar

Note that the JAR file name is included.

Example of specifying the path to the jar file that contains the class file:

    -altsignerpath /home/user/classes/com/sun/tools/jarsigner/

Note that the JAR file name is omitted.

Java Plug-in Enhancements

In Java SE 5.0, the Java Plug-in was enhanced to check signature timestamps (if available) when validating JAR files. The Java Plug-in will no longer present a dialog when it encounters an expired or revoked certificate when validating a signed jar, provided that the signature timestamp confirms that the signature was generated prior to the expiration or revocation date.

The TSA's certificate must be available from the Plug-in's keystore or certificate stores when the Plug-in is validating a JAR file containing a signature timestamp.

The Plug-in reverts to 1.4.x behavior if the signature does not contain a timestamp.

API Enhancements

The security and JAR APIs were enhanced to enable applications to access timestamp information.

Two new classes were added to the java.security package. These classes are CodeSigner, which maintains information associated with a signer, and Timestamp, which represents information associated with a signature timestamp.

New methods were added to the java.security.CodeSource class and java.util.jar.JarEntry class to allow access to this new, optional information.

Appendix A: Standard Names

The Java Certification Path API requires and utilizes a set of standard names for certification path validation algorithms, encodings and certificate storage types. The standard names previously found here in Appendix A and in the other security specifications (JCA/JSSE/etc.) have been combined in the Standard Names document. Specific provider information can be found in the Sun Provider Documentation.

Please note that a service provider may choose to define a new name for a proprietary or non-standard algorithm that is not mentioned in the Standard Names document. However, to prevent name collisions, it is recommended that the name be prefixed with the reverse Internet domain name of the provider's organization (for example: com.sun.MyCertPathValidator).

Appendix B: The "SUN" Provider

The CertPath implementation in the SUN provider as of Java SE 5 passed the Public Key Interoperability Test Suite (PKITS).

The "SUN" provider supports the following standard algorithms, types and encodings:

  • CertificateFactory: X.509 CertPath type with PKCS7 and PkiPath encodings
  • CertPathValidator: PKIX algorithm
  • CertPathBuilder: PKIX algorithm
  • CertStore: LDAP and Collection CertStore types
Each of these service provider interface implementations is discussed in more detail below.

CertificateFactory

The "SUN" provider for the CertificateFactory engine class has been enhanced to support generation of X.509 CertPath objects. The PKCS7 and PkiPath encodings are supported. The PKCS#7 implementation supports a subset of RFC 2315 (only the SignedData ContentInfo type is supported). The certificates in the CertPath are ordered in the forward direction (from target to trust anchor). Each certificate in the CertPath is of type java.security.cert.X509Certificate, and versions 1, 2 and 3 are supported.

CertPathValidator

The "SUN" provider supplies a PKIX implementation of the CertPathValidator engine class. The implementation validates CertPaths of type X.509 and implements the certification path validation algorithm defined in RFC 3280: PKIX Certificate and CRL Profile. This implementation sets the ValidationAlgorithm service attribute to "RFC3280".

In the Java SE 7 release, weak cryptographic algorithms can be disabled in the "SUN" provider using a security property. The jdk.certpath.disabledAlgorithms property is a list of disabled algorithms that applies to certificate path verification.

From JDK 8 onwards the default value of jdk.certpath.disabledAlgorithms is as follows:

    jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 1024

This means that no signature algorithm involving MD2 will be used to verify a certificate. And use of certificates with RSA key size of less than 1024 bits in length is restricted. Appendix D has examples of values for jdk.certpath.disabledAlgorithms.

The PKIX Certificate and CRL Profile has many optional features. The "SUN" provider implements support for the policy mapping, authority information access and CRL distribution point certificate extensions, the issuing distribution point CRL extension, and the reason code and certificate issuer CRL entry extensions. It does not implement support for the freshest CRL or subject information access certificate extensions. It also does not include support for the freshest CRL and delta CRL Indicator CRL extensions and the invalidity date and hold instruction code CRL entry extensions.

The implementation supports a CRL revocation checking mechanism that conforms to section 6.3 of the PKIX Certificate and CRL Profile. OCSP (RFC 2560) is also currently supported as a built in revocation checking mechanism. See Appendix C for more details on the implementation and configuration and how it works in conjunction with CRLs.

The implementation does not support the nameConstraints parameter of the TrustAnchor class and the validate method throws an InvalidAlgorithmParameterException if it is specified.

CertPathBuilder

The "SUN" provider supplies a PKIX implementation of the CertPathBuilder engine class. The implementation builds CertPaths of type X.509. Each CertPath is validated according to the PKIX algorithm defined in RFC 3280: PKIX Certificate and CRL Profile. This implementation sets the ValidationAlgorithm service attribute to "RFC3280".

The implementation requires that the targetConstraints parameter of a PKIXBuilderParameters object is an instance of X509CertSelector and the subject criterion is set to a non-null value. Otherwise the build method throws an InvalidAlgorithmParameterException.

The implementation builds CertPath objects in a forward direction using a depth-first algorithm. It backtracks to previous states and tries alternate paths when a potential path is determined to be invalid or exceeds the PKIXBuilderParameters maxPathLength parameter.

Validation of the path is performed in the same manner as the CertPathValidator implementation. The implementation validates most of the path as it is being built, in order to eliminate invalid paths earlier in the process. Validation checks that cannot be executed on certificates ordered in a forward direction are delayed and executed on the path after it has been constructed (but before it is returned to the application).

As with CertPathValidator, the jdk.certpath.disabledAlgorithms security property can be used to exclude cryptographic algorithms that are not considered safe.

When two or more potential certificates are discovered that may lead to finding a path that meets the specified constraints, the implementation uses the following criteria to prioritize the certificates (in the examples below, assume a TrustAnchor distinguished name of "ou=D,ou=C,o=B,c=A" is specified):

  1. The issuer DN of the certificate matches the DN of one of the specified TrustAnchors (ex: issuerDN = "ou=D,ou=C,o=B,c=A").
  2. The issuer DN of the certificate is a descendant of the DN of one of the TrustAnchors, ordered by proximity to the anchor (ex: issuerDN = "ou=E,ou=D,ou=C,o=B,c=A").
  3. The issuer DN of the certificate is an ancestor of the DN of one of the TrustAnchors, ordered by proximity to the anchor (ex: issuerDN = "ou=C,o=B,c=A".
  4. The issuer DN of the certificate is in the same namespace of one of the TrustAnchors, ordered by proximity to the anchor (ex: issuerDN = "ou=G,ou=C,o=B,c=A").
  5. The issuer DN of the certificate is an ancestor of the subject DN of the certificate, ordered by proximity to the subject.
These are followed by certificates which don't meet any of the above criteria.

This implementation has been tested with the LDAP and Collection CertStore implementations included in this release of the "SUN" provider.

Debugging support can be enabled by setting the java.security.debug property to certpath. For example:

       java -Djava.security.debug=certpath BuildCertPath
This will print additional debugging information to standard error.

CertStore

The "SUN" provider supports two implementations of the CertStore engine class: Collection and LDAP.

Collection CertStore

The Collection CertStore implementation can hold any objects that are an instance of java.security.cert.Certificate or java.security.cert.CRL.

The certificates and CRLs are not returned in any particular order and will not contain duplicates.

LDAP CertStore

The LDAP CertStore implementation retrieves certificates and CRLs from an LDAP directory using the LDAP schema defined in RFC 2587. The LDAPSchema service attribute is set to "RFC2587".

The implementation fetches certificates from different locations, depending on the values of the subject, issuer, and basicConstraints selection criteria specified in the X509CertSelector. It performs as many of the following operations as possible:

  1. Subject non-null, basicConstraints <= -1

    Looks for certificates in the subject DN's "userCertificate" attribute.

  2. Subject non-null, basicConstraints >= -1

    Looks for certificates in the forward element of the subject DN's "crossCertificatePair" attribute AND in the subject's "caCertificate" attribute.

  3. Issuer non-null, basicConstraints >= -1

    Looks for certificates in the reverse element of the issuer DN's "crossCertificatePair" attribute AND in the issuer DN's "caCertificate" attribute.

In each case, certificates are checked using X509CertSelector.match() before adding them to the resulting collection.

If none of the conditions specified above applies, then an exception is thrown to indicate that it was impossible to fetch certificates using the criteria supplied. Note that even if one or more of the conditions apply, the Collection returned may still be empty if there are no certificates in the directory.

The implementation fetches CRLs from the issuer DNs specified in the setCertificateChecking, addIssuerName or setIssuerNames methods of the X509CRLSelector class. If no issuer DNs have been specified using one of these methods, the implementation throws an exception indicating it was impossible to fetch CRLs using the criteria supplied. Otherwise, the CRLs are searched as follows:

The implementation first creates a list of issuer names. If a certificate was specified in the setCertificateChecking method, it uses the issuer of that certificate. Otherwise, it uses the issuer names specified using the addIssuerName or setIssuerNames methods.

Next, the implementation iterates through the list of issuer names. For each issuer name, it searches first in the issuer's "authorityRevocationList" attribute and then, if no matching CRL was found there, in the issuer's "certificateRevocationList" attribute. One exception to the above is that if the issuer name was obtained from the certificate specified in the setCertificateChecking method, it only checks the issuer's "authorityRevocationList" attribute if the specified certificate is a CA certificate.

All CRLs are checked using X509CRLSelector.match() before adding them to the resulting collection.

If no CRLs satisfying the selection criteria can be found, an empty Collection is returned.

Caching

By default each LDAP CertStore instance caches lookups for a maximum of 30 seconds. The cache lifetime can be changed by setting the system property sun.security.certpath.ldap.cache.lifetime to a value in seconds. A value of 0 disables the cache completely. A value of -1 means unlimited lifetime.

Support for the CRL Distribution Points Extension

Support for the CRL Distribution Points extension is available. It is disabled by default for compatibility and can be enabled by setting the system property com.sun.security.enableCRLDP to the value true.

If set to true, Sun's PKIX implementation uses the information in a certificate's CRL Distribution Points extension (in addition to CertStores that are specified) to find the CRL, provided the distribution point is an X.500 distinguished name or a URI of type ldap, http, or ftp.

Note: Depending on your network and firewall setup, it may be necessary to also configure your networking proxy servers as described in the networking documentation.

Support for the Authority Information Access (AIA) Extension

Support for the caIssuers access method of the Authority Information Access extension is available. It is disabled by default for compatibility and can be enabled by setting the system property com.sun.security.enableAIAcaIssuers to the value true.

If set to true, Sun's PKIX implementation of CertPathBuilder uses the information in a certificate's AIA extension (in addition to CertStores that are specified) to find the issuing CA certificate, provided it is a URI of type ldap, http, or ftp.

Note: Depending on your network and firewall setup, it may be necessary to also configure your networking proxy servers as described in the networking documentation.

Appendix C: On-Line Certificate Status Protocol (OCSP) Support

Client-side support for the On-Line Certificate Status Protocol (OCSP) as defined in RFC 2560 is supported as of JDK 5.0. OCSP checking is controlled by the following five security properties:

Property Name | Description
ocsp.enable | This property's value is either true or false. If true, OCSP checking is enabled when doing certificate revocation checking; if false or not set, OCSP checking is disabled.
ocsp.responderURL This property's value is a URL that identifies the location of the OCSP responder. Here is an example.
ocsp.responderURL=http://ocsp.example.net:80

By default, the location of the OCSP responder is determined implicitly from the certificate being validated. The property is used when the Authority Information Access extension (defined in RFC 3280) is absent from the certificate or when it requires overriding.
ocsp.responderCertSubjectName This property's value is the subject name of the OCSP responder's certificate. Here is an example.
ocsp.responderCertSubjectName="CN=OCSP Responder, O=XYZ Corp"

By default, the certificate of the OCSP responder is that of the issuer of the certificate being validated. This property identifies the certificate of the OCSP responder when the default does not apply. Its value is a string distinguished name (defined in RFC 2253) which identifies a certificate in the set of certificates supplied during cert path validation. In cases where the subject name alone is not sufficient to uniquely identify the certificate, then both the ocsp.responderCertIssuerName and ocsp.responderCertSerialNumber properties must be used instead. When th is property is set, then those two properties are ignored.
ocsp.responderCertIssuerName This property's value is the issuer name of the OCSP responder's certificate . Here is an example.
ocsp.responderCertIssuerName="CN=Enterprise CA, O=XYZ Corp"

By default, the certificate of the OCSP responder is that of the issuer of the certificate being validated. This property identifies the certificate of the OCSP responder when the default does not apply. Its value is a string distinguished name (defined in RFC 2253) which identifies a certificate in the set of certificates supplied during cert path validation. When this property is set then the ocsp.responderCertSerialNumber property must also be set. Note that this property is ignored when the ocsp.responderCertSubjectName property has been set.
ocsp.responderCertSerialNumber This property's value is the serial number of the OCSP responder's certificate Here is an example.
ocsp.responderCertSerialNumber=2A:FF:00

By default, the certificate of the OCSP responder is that of the issuer of the certificate being validated. This property identifies the certificate of the OCSP responder when the default does not apply. Its value is a string of hexadecimal digits (colon or space separators may be present) which identifies a certificate in the set of certificates supplied during cert path validation. When this property is set then the ocsp.responderCertIssuerName property must also be set. Note that this property is ignored when the ocsp.responderCertSubjectName property has been set.

These properties may be set either staticly in the Java runtime's $JAVA_HOME/jre/lib/security/java.security file, or dynamically using the java.security.Security.setProperty() method.

By default, OCSP checking is not enabled. It is enabled by setting the ocsp.enable property to "true". Use of the remaining properties is optional. Note that enabling OCSP checking only has an effect if revocation checking has also been enabled. Revocation checking is enabled via the PKIXParameters.setRevocationEnabled() method.

OCSP checking works in conjunction with Certificate Revocation Lists (CRLs) during revocation checking. Below is a summary of the interaction of OCSP and CRLs. Failover to CRLs occurs only if an OCSP problem is encountered. Failover does not occur if the OCSP responder confirms either that the certificate has been revoked or that it has not been revoked.

PKIXParameters RevocationEnabled (default=true) | ocsp.enable (default=false) | Behavior
true | true | Revocation checking using OCSP, failover to using CRLs
true | false | Revocation checking using CRLs only
false | true | No revocation checking
false | false | No revocation checking

Appendix D: Disabling Cryptographic Algorithms

The jdk.certpath.disabledAlgorithms security property contains a list of cryptographic algorithms that will not be used during certification path processing. The exact syntax of the property is described in the jre/lib/security/java.security file, but is briefly summarized here.

The security property contains a list of cryptographic algorithms that must not be used. The algorithm names are separated by commas. Furthermore, you can also specify restrictions on key sizes.

For example, the following line in java.security specifies that the MD2 and DSA algorithms must not be used for certification path processing. Furthermore, RSA is disabled for key sizes less than 2048 bits.

jdk.certpath.disabledAlgorithms=MD2, DSA, RSA keySize < 2048
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chained Exception Facility

It is common for Java code to catch one exception and throw another:

try {
    ...
} catch(YourException e) {
    throw new MyException();
}

Unfortunately, the information contained in the "causative exception" (YourException in the example above) is generally lost, which greatly complicates debugging. Recognizing this problem, developers sometimes build ad hoc mechanisms to allow certain "wrapped exceptions" to contain a second exception. An accessor is generally provided to extract the contained exception. Such mechanisms are sometimes known as "exception chaining facilities", as they allow arbitrary chains of exceptions to be constructed when contained exceptions are, themselves, wrapped exceptions.

There are many advantages to unifying all of these facilities. Chief among them are: (1) We guarantee that anyone who wants to record the fact that one exception caused another can do so, regardless of what the exceptions are. (2) By providing a common API to record the fact that one exception caused another, we ease this task, making it more likely that programmers will take the trouble to do it. (3) By providing a common API to access causative exceptions, we greatly increase the likelihood that this information will be made available to those who need it. In fact, the proposed mechanism prints entire "causal chain" as part of the standard stack backtrace, ensuring that preexisting programs will provide this information with no additional effort on the part of their authors.

To address these issues, we have added two new methods to Throwable, getCause() and initCause(Throwable), and two new constructors, Throwable(Throwable) and Throwable(String, Throwable). Other "general purpose" exception classes (like Exception, RunTimeException and Error) have been similarly outfitted with (Throwable) and (String, Throwable) constructors. However, even exceptions without such constructors will be usable as "wrapped exceptions" via the initCause method.

The implementation of Throwable.printStackTrace has been modified to display backtraces for the entire causal chain of exceptions. New method getStackTrace provides programmatic access to the stack trace information provided by printStackTrace.

All of the platform's wrapped exceptions will be retrofitted to support the new facility (in addition to their legacy APIs).

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Object Serialization Specification: -

CONTENTS | PREV | NEXT Java Object Serialization Specification
version 6.0

Change History

May 12, 2005 Updates for JavaTM SE Development Kit, v6 Beta 1

  • Added statement about how an array object returned by a readResolve invocation for an unshared read is handled.
  • Clarified the behavior in the event of an invalid serialPersistentFields value.
  • Clarified that serialVersionUID matching is waived for array classes.
  • Clarified when IllegalArgumentException is thrown by ObjectOutputStream.PutFields methods.

July 24, 2003 Updates for JavaTM 2 SDK, Standard Edition, v1.5 Beta 1

  • Added support for serializing enum constants.
  • Added specification of class modifier flags used in the computation of default serialVersionUID values to Section 4.6, "Stream Unique Identifiers".

Aug. 16, 2001 Updates for JavaTM 2 SDK, Standard Edition, v1.4 Beta 2

  • Added support for class-defined readObjectNoData methods, to be used for initializing serializable class fields in cases not covered by class-defined readObject methods. See Section 3.5, "The readObjectNoData Method", as well as Appendix A, "Security in Object Serialization".
  • New methods ObjectOutputStream.writeUnshared and ObjectInputStream.readUnshared provide a mechanism for ensuring unique references to deserialized objects. See Section 2.1, "The ObjectOutputStream Class", Section 3.1, "The ObjectInputStream Class", as well as Appendix A, "Security in Object Serialization".
  • Documented new security checks in the one-argument constructors for ObjectOutputStream and ObjectInputStream. See Section 2.1, "The ObjectOutputStream Class" and Section 3.1, "The ObjectInputStream Class".
  • Added caution against using inner classes for serialization in Section 1.10, "The Serializable Interface".
  • Clarified requirement that class-defined writeObject methods invoke ObjectOutputStream.defaultWriteObject or writeFields once before writing optional data, and that class-defined readObject methods invoke ObjectInputStream.defaultReadObject or readFields once before reading optional data. See Section 2.3, "The writeObject Method" and Section 3.4, "The readObject Method".
  • Clarified the behavior of ObjectInputStream when class-defined readObject or readExternal methods attempt read operations which exceed the bounds of available data; see Section 3.4, "The readObject Method" and Section 3.6, "The readExternal Method".
  • Clarified the description of non-proxy class descriptor field type strings to require that they be written in "field descriptor" format; see Section 6.2, "Stream Elements".

July 30, 1999 Updates for JavaTM 2 SDK, Standard Edition, v1.3 Beta

  • Added the ability to write String objects for which the UTF encoding is longer than 65535 bytes in length. See Section 6.2, "Stream Elements".
  • New methods ObjectOutputStream.writeClassDescriptor and ObjectInputStream.readClassDescriptor provide a means of customizing the serialized representation of ObjectStreamClass class descriptors. See Section 2.1, "The ObjectOutputStream Class" and Section 3.1, "The ObjectInputStream Class".
  • Expanded Appendix A, "Security in Object Serialization".

Sept. 30, 1998 Updates for JDKTM 1.2 Beta4 RC1

  • Documentation corrections only.

June 22, 1998 Updates for JDKTM 1.2 Beta4

  • Eliminated JDKTM 1.2 java.io interfaces, Replaceable and Resolvable.References to either of these classes as an interface should be replaced with java.io.Serializable. Serialization will use reflection to invoke the methods, writeReplace and readResolve, if the Serializable class defines these methods. See Section 2.5, "The writeReplace Method" and Section 3.7, "The readResolve Method."
  • New javadoc tags @serial, @serialField, and @serialData provide a way to document the Serialized Form of a Serializable class. Javadoc generates a serialization specification based on the contents of these tags. See Section 1.6, "Documenting Serializable Fields and Data for a Class."
  • Special Serializable class member, serialPersistentFields, must be declared private. See Section 1.5, "Defining Serializable Fields for a Class."
  • Clarified the steps involved in computing the serialVersionUID in Section 4.6, "Stream Unique Identifiers."

Feb. 6, 1998 Updates for JDKTM 1.2 Beta 3

  • Introduced the concept of STREAM_PROTOCOL versions. Added the STREAM_PROTOCOL_2 version to indicate a new format for Externalizable objects that enable skipping by an Externalizable object within the stream, even when the object's class is not available in the local Virtual Machine. Compatibility issues are discussed in Section 6.3, "Stream Protocol Versions."
  • The ObjectInputStream.resolveClass method can return a local class in a different package than the name of the class within the stream. This capability enables renaming of packages between releases. The serialVersionUID and the base class name must be the same in the stream and in the local version of the class. See Section 3.1, "The ObjectInputStream Class."
  • Allow substitution of String or array objects when writing them to or reading them from the stream. See Section 2.1, "The ObjectOutputStream Class" and Section 3.1, "The ObjectInputStream Class."

Sept. 4, 1997 Updates for JDKTM 1.2 Beta1

  • Separated the Replaceable interface into two interfaces: Replaceable and Resolvable. The Replaceable interface allows a class to nominate its own replacement just before serializing the object to the stream. The Resolvable interface allows a class to nominate its own replacement when reading an object from the stream.
  • Modified serialization to use the JDKTM 1.2 security model. There is a check for SerializablePermission "enableSubstitution" within the ObjectInputStream.enableReplace and ObjectOutputStream.enableResolve methods. See Section 2.1, "The ObjectOutputStream Class" and Section 3.1, "The ObjectInputStream Class."
  • Updated writeObject's exception handler to write handled IOExceptions into the stream. See Section 2.1, "The ObjectOutputStream Class."

July 3, 1997 Updates for JDKTM 1.2 Alpha

  • Documented the requirements for specifying the serialized state of classes. See Section 1.5, "Defining Serializable Fields for a Class."
  • Added the Serializable Fields API to allow classes more flexibility in accessing the serialized fields of a class. The stream protocol is unchanged. See Section 1.7, "Accessing Serializable Fields of a Class," Section 2.2, "The ObjectOutputStream.PutField Class," and Section 3.2, "The ObjectInputStream.GetField Class."
  • Clarified that field descriptors and data are written to and read from the stream in canonical order. See Section 4.1, "The ObjectStreamClass Class."

CONTENTS | PREV | NEXT
Copyright © 2005, 2010, Oracle and/or its affiliates. All rights reserved.


Appendix C: JNDI Change History

CONTENTS | PREV | NEXT

Appendix 4:

JNDI 1.2: Changes Since JNDI 1.1

  • Added javax.naming.event package.
  • Added javax.naming.ldap package.
  • Added support for configuration using resource files. See Chapter 6 of the JNDI API document.

API-related Changes

  • Added NamingEnumeration.close() for cancelling or terminating enumerations.
  • Added ReferralException.getReferralContext(Hashtable env) and ReferralException.retryReferral() to allow creation and retry of referral context with different environment properties.
  • Clarified how context methods that accept Name argument should deal with CompositeName and non CompositeName arguments. Specifically, instances of CompositeName are treated as composite name, while all others are treated as compound name.
  • Added Context.getNameInNamespace() for retrieving the full name of a context within its own namespace.
  • Clarified definition of the class factory location of a Reference object. Specifically, the location is a codebase, which consists of a list space-separated URLs.
  • Added support for ordered multivalued attributes to Attribute and BasicAttribute .
  • Added BasicAttributes.equals() and BasicAttributes.hashCode() .
  • Redefined semantics of DirContext.getSchemaClassDefinition() so that it returns a context that contains the DirContext objects of class definitions, rather than returning one (arbitrary) class definition.
  • Added protected InitialContext / InitialDirContext constructors to allow lazy initialization. Useful for subclass implementations.

SPI-related Changes

  • Added StateFactory / NamingManager.getStateToBind() , analogous to ObjectFactory / NamingManager.getObjectInstance() , for transforming an object's state before the object is bound in the naming/directory service.
  • Added interfaces DirObjectFactory and DirStateFactory to better support service providers that implement the DirContext interface. Added DirectoryManager.getObjectInstance() and DirectoryManager.getStateToStore() to use these interfaces.
  • Refined definition of NamingManager.getObjectInstance() to not treat URL strings specially. Instead, the URL should be wrapped inside a Reference whose RefAddr type is "URL".
  • Made ResolveResult implement Serializable .
  • Defined a special form of Reference called a next naming system (nns) reference for supporting "dynamic federation". This reference has a RefAddr type of "nns" and a content consisting of the resolved object.
  • Added the string constant NamingManager.CPE which names a property set by NamingManager.getContinuationContext() / DirectoryManager.getContinuationContext() . The value of this property is an instance of CannotProceedException . This is useful to service providers that implement federation by chaining the CPEs.
  • Defined a convention for service providers to use when naming environment properties. See Section 6.1.

CONTENTS | PREV | NEXT

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Collections Framework Change Summary for Java SE 1.4

Documentation Contents

Collections Framework Enhancements

This page summarizes the enhancements made to the collections framework in Java SE 1.4.

  • The Collections utility class has several new methods:
    • rotate(List list, int distance) - Rotates all of the elements in the list by the specified distance. This operation is common in GUI computations: moving one or more columns in a table can be accomplished efficiently by applying this operation to a sublist. This operation is also common in mathematical and scientific calculations.
    • replaceAll(List list, Object oldVal, Object newVal) - Replaces all occurrences of one specified value with another. This is essentially a convenience method. Though not difficult to program, it's very commonly needed.
    • indexOfSubList(List source, List target) - Returns the index of the first sublist of source that is equal to target. Commonly used in many domains including text processing.
    • lastIndexOfSubList(List source, List target) - Returns the index of the last sublist of source that is equal to target. Commonly used in many domains including text processing.
    • swap(List list, int i, int j) - Swaps the elements at the specified positions in the specified list. Essentially a convenience method, though this implementation is faster than the naive implementation.
    • list(Enumeration e) - Returns an ArrayList containing the elements returned by the specified enumeration. This convenience method provides interoperability between legacy APIs that return enumerations and new APIs that require collections.
  • New interface RandomAccess is a marker interface that allows List implementations to indicate that they support fast (generally constant time) random access. This allows generic algorithms to alter their behavior to provide good performance when applied to either random or sequential access lists.
  • New class LinkedHashMap provides an insertion-ordered Map implementation that runs nearly as fast as HashMap. Internally, it uses a hash table with a doubly linked list running through it in insertion order. Also available is a corresponding Set implementation, called LinkedHashSet.
  • New class IdentityHashMap is an identity-based Map implementation based on a hash table. This class is useful for topology-preserving object graph transformations (such as serialization or deep-copying). To perform such transformations, you need to maintain an identity-based "node table" that keeps track of which objects have already been seen. Identity-based maps are also used to maintain object-to-meta-information mappings in dynamic debuggers and similar systems. Finally, identity-based maps are useful in thwarting "spoof attacks" resulting from intentionally perverse equals methods. (IdentityHashMap never invokes the equals method on its keys.) An added benefit of this implementation is that it is fast.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Collections Framework Change Summary for JDK 5

Documentation Contents

Collections Framework Enhancements

This page summarizes enhancements to the collections framework in version 5 of the JDK.

Three new language features significantly enhance the collections framework:

  • Generics - adds compile-time type safety to the collections framework and eliminates the need to cast when reading elements from collections.
  • Enhanced for loop - eliminates the need for explicit iterators when interating over collections.
  • Autoboxing/unboxing - automatically converts primitives (such as int) to wrapper classes (such as Integer) when inserting them into collections, and converts wrapper class instances to primitives when reading from collections.

Three new collection interfaces are provided:

  • Queue - represents a collection designed for holding elements prior to processing. Besides basic Collection operations, queues provide additional insertion, extraction, and inspection operations.
  • BlockingQueue - extends Queue with operations that wait for the queue to become non-empty when retrieving an element, and that wait for space to become available in the queue when storing an element. (This interface is part of the new package java.util.concurrent.)
  • ConcurrentMap - extends Map with atomic putIfAbsent, remove, and replace methods. (This interface is part of java.util.concurrent.)

Two new concrete Queue implementations are provided, one existing List implementation has been retrofitted to implement Queue, and one abstract Queue implementation is provided:

  • PriorityQueue - an unbounded priority queue backed by a heap.
  • ConcurrentLinkedQueue - an unbounded thread-safe FIFO (first-in first-out) queue backed by linked nodes. (This class is part of java.util.concurrent.)
  • LinkedList - retrofitted to implement the Queue interface. When accessed via the Queue interface, LinkedList behaves as a FIFO queue.
  • AbstractQueue - a skeletal Queue implementation.

Five new BlockingQueue implementations are provided, all of which are part of java.util.concurrent:

  • LinkedBlockingQueue - an optionally bounded FIFO blocking queue backed by linked nodes.
  • ArrayBlockingQueue - a bounded FIFO blocking queue backed by an array.
  • PriorityBlockingQueue - an unbounded blocking priority queue backed by a heap.
  • DelayQueue - a time-based scheduling queue backed by a heap.
  • SynchronousQueue - a simple rendezvous mechanism utilizing the BlockingQueue interface.

One ConcurrentMap implementation is provided:

  • ConcurrentHashMap - a highly concurrent, high-performance ConcurrentMap implementation backed by a hash table. This implementation never blocks when performing retrievals and allows the client to select the concurrency level for updates. It is intended as a drop-in replacement for Hashtable: in addition to implementing ConcurrentMap, it supports all of the "legacy" methods peculiar to Hashtable.

Special-purpose List and Set implementations are provided for use in situations where read operations vastly outnumber write operations and iteration cannot or should not be synchronized:

  • CopyOnWriteArrayList - a List implementation backed by an array. All mutative operations (such as add, set, and remove) are implemented by making a new copy of the array. No synchronization is necessary, even during iteration, and iterators are guaranteed never to throw ConcurrentModificationException. This implementation is well-suited to maintaining event-handler lists (where change is infrequent, and traversal is frequent and potentially time-consuming).
  • CopyOnWriteArraySet - a Set implementation backed by a copy-on-write array. This implementation is similar in nature to CopyOnWriteArrayList. Unlike most Set implementations, the add, remove, and contains methods require time proportional to the size of the set. This implementation is well-suited to maintaining event-handler lists that must prevent duplicates.

Special-purpose Set and Map implementations are provided for use with enums:

  • EnumSet - a high-performance Set implementation backed by a bit-vector. All elements of each EnumSet instance must be elements of a single enum type.
  • EnumMap - a high-performance Map implementation backed by an array. All keys in each EnumMap instance must be elements of a single enum type.

A new family of wrapper implementations is provided, primarily for use with generic collections:

  • Collections.checkedInterface - returns a dynamically typesafe view of the specified collection, which throws a ClassCastException if a client attempts to add an element of the wrong type. The generics mechanism in the language provides compile-time (static) type checking, but it is possible to defeat this mechanism. Dynamically typesafe views eliminate this possibility entirely.

Three new generic algorithms and one comparator converter were added to the Collections utility class:

  • frequency(Collection<?> c, Object o) - counts the number of times the specified element occurs in the specified collection.
  • disjoint(Collection<?> c1, Collection<?> c2) - determines whether two collecitons are disjoint, in other words, whether they contain no elements in common.
  • addAll(Collection<? super T> c, T... a) - convenience method to add all of the elements in the specified array to the specified collection.
  • Comparator<T> reverseOrder(Comparator<T> cmp) - returns a comparator that represents the reverse ordering of the specified comparator.

The Arrays utility class has been outfitted with content-based hashCode and toString methods for arrays of all types. These methods complement the existing equals methods. Versions of all three methods are provided to operate on nested (or "multidimensional") arrays: deepEquals, deepHashCode, and deepToString. It is now trivial to print the contents of any array. The idiom for printing a "flat" array is:

    System.out.println(Arrays.toString(a));

The idiom for printing a nested (multidimensional) array is:

    System.out.println(Arrays.deepToString(a));

Finally, Boolean was retrofitted to implement Comparable.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Enhancements in java.lang.instrument

Documentation Contents

Enhancements in Java SE 6

for the java.lang.instrument Package

The following functionality has been added to the java.lang.instrument package between its initial release in JDK 5.0 and Java™ SE 6.

  • Support for retransformation of class files - To facilitate dynamic transformation of classes that have already been loaded, the following methods have been added.
    • Instrumentation.retransformClasses(Class...)
    • Instrumentation.addTransformer(ClassFileTransformer, boolean)
    • Instrumentation.isModifiableClass(Class)
    • Instrumentation.isRetransformClassesSupported()
    They are suited to operations such as adding instrumentation to methods whose classes have already been loaded. Support for retransformation means that access to the original class file is no longer required in order to instrument loaded classes. They enable the easy removal of applied transformations and are designed to work in multi-agent environments.
  • Support for instrumenting native methods - The following methods allow native methods to be instrumented by providing a JVM-aware mechanism for wrapping the native method.
    • Instrumentation.setNativeMethodPrefix(ClassFileTransformer, String)
    • Instrumentation.isNativeMethodPrefixSupported()
  • Support for appending to class loader search - The following methods allow instrumentation support classes to be defined in the appropriate class loader.
  • Instrumentation.appendToBootstrapClassLoaderSearch(JarFile)
  • Instrumentation.appendToSystemClassLoaderSearch(JarFile)
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Concurrency Utilities Enhancements in Java SE 7

The fork/join framework, which is based on the ForkJoinPool class, is an implementation of the Executor interface. It is designed to efficiently run a large number of tasks using a pool of worker threads. A work-stealing technique is used to keep all the worker threads busy, to take full advantage of multiple processors. See Fork/Join in The Java Tutorials. The directory <Java home>/sample/forkjoin/ contains samples that demonstrate the fork/join framework.

The ThreadLocalRandom class eliminates contention among threads using pseudo-random numbers; see Concurrent Random Numbers.

The Phaser class is a new synchronization barrier, similar to CyclicBarrier.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Concurrency Utilities Enhancements in Java SE 8

New classes and interfaces in java.util.concurrent

The java.util.concurrent package contains two new interfaces and four new classes:

  • Interface CompletableFuture.AsynchronousCompletionTask: A marker interface identifying asynchronous tasks produced by async methods.
  • Interface CompletionStage<T>: A stage of a possibly asynchronous computation, that performs an action or computes a value when another CompletionStage completes.
  • Class CompletableFuture<T>: A Future that may be explicitly completed (setting its value and status), and may be used as a CompletionStage, supporting dependent functions and actions that trigger upon its completion.
  • Class ConcurrentHashMap.KeySetView<K,V>: A view of a ConcurrentHashMap as a Set of keys, in which additions may optionally be enabled by mapping to a common value.
  • Class CountedCompleter<T>: A ForkJoinTask with a completion action performed when triggered and there are no remaining pending actions.
  • Class CompletionException: Exception thrown when an error or other exception is encountered in the course of completing a result or task.

New methods in java.util.concurrent.ConcurrentHashMap

The Collections Framework has undergone a major revision in Java 8 to add aggregate operations based on the newly added streams facility and lambda expressions. As a result, the ConcurrentHashMap class introduces over 30 new methods in this release. These include various forEach methods (forEach, forEachKey, forEachValue, and forEachEntry), search methods (search, searchKeys, searchValues, and searchEntries) and a large number of reduction methods (reduce, reduceToDouble, reduceToLong etc.)

Other miscellaneous methods (mappingCount and newKeySet) have been added as well. As a result of the JDK 8 changes, ConcurrentHashMaps (and classes built from them) are now more useful as caches. These changes include methods to compute values for keys when they are not present, plus improved support for scanning (and possibly evicting) entries, as well as better support for maps with large numbers of elements.

For complete details, see the java.util.concurrent.ConcurrentHashMap API specification.

New classes in java.util.concurrent.atomic

Maintaining a single count, sum, etc. that is updated by possibly many threads is a common scalability problem. This release introduces scalable updatable variable support through a small set of new classes (DoubleAccumulator, DoubleAdder, LongAccumulator, LongAdder), which internally employ contention-reduction techniques that provide huge throughput improvements as compared to Atomic variables. This is made possible by relaxing atomicity guarantees in a way that is acceptable in most applications.

  • DoubleAccumulator: One or more variables that together maintain a running double value updated using a supplied function.
  • DoubleAdder: One or more variables that together maintain an initially zero double sum.
  • LongAccumulator: One or more variables that together maintain a running long value updated using a supplied function.
  • LongAdder: One or more variables that together maintain an initially zero long sum.

New methods in java.util.concurrent.ForkJoinPool

A static commonPool() method is now available and appropriate for most applications. The common pool is used by any ForkJoinTask that is not explicitly submitted to a specified pool. Using the common pool normally reduces resource usage (its threads are slowly reclaimed during periods of non-use, and reinstated upon subsequent use). Two new methods (getCommonPoolParallelism() and commonPool()) have been added, which return the targeted parallelism level of the common pool, or the common pool instance, respectively.

New class java.util.concurrent.locks.StampedLock

A new StampedLock class adds a capability-based lock with three modes for controlling read/write access (writing, reading, and optimistic reading). This class also supports methods that conditionally provide conversions across the three modes.

For complete details, see the java.util.concurrent.StampedLock API documentation.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


V1.4 JavaBeans API Enhancements

Documentation Contents

API Enhancements to the JavaBeans Component API in v1.4

This document describes changes to the java.beans package that were introduced in Java SE 1.4:

  • New API for Long-Term Persistence
  • Other API Additions
  • Changes to the Introspector
  • Garbage Collection and Custom Attributes

New API for Long-Term Persistence

To support long-term persistence, the following classes were added:

Class | Description
Statement | An object that represents a method call, possibly with arguments, upon an object. For example: a.setFoo(b).
Expression | A statement that returns a result. For example: a.getFoo().
XMLDecoder | Reads XML documents that were created using XMLEncoder.
Encoder | Uses persistence delegates to break an object graph down into a series of Statements and Expressions that can be used to recreate it.
XMLEncoder | An Encoder that produces statements and expressions in an XML encoding.
PersistenceDelegate | An abstract class that defines objects that can express the state of another object using the public methods of that object's class.
DefaultPersistenceDelegate | The persistence delegate used, by default, for beans.

See JavaBeans Component API for links to where you can find more information about long-term persistence.

Other API Additions

The following classes were also added in v1.4:

Class | Description
EventHandler | Provides support for dynamically generating event listeners that have a small footprint and can be saved automatically by the persistence scheme.
ExceptionListener | Defines a listener to be notified when a exception was thrown but then recovered from. You can register an exception listener on an XMLEncoder or XMLDecoder object to be notified when the object encounters a recoverable problem while writing or reading a bean.
PropertyChangeListenerProxy | A proxy that implements PropertyChangeListener and serves to group another PropertyChangeListener (the real event handler) with a specific property; the proxy forwards property change events to the real event handler.
VetoableChangeListenerProxy | A proxy that implements VetoableChangeListener and serves to group another VetoableChangeListener (the real event handler) with a specific constrained property; the proxy forwards vetoable property change events to the real event handler.

The following classes have additional methods:

  • The PropertyChangeSupport class now contains a no-argument method to get all the registered property change listeners: getPropertyChangeListeners.
  • Similarly, the VetoableChangeSupport class now contains a no-argument method to get all the registered vetoable change listeners: getVetoableChangeListeners.

Changes to the Introspector

The Introspector class has been reimplemented, and its performance has improved. The new implementation has caused the following changes in the behavior of the introspector:
  • FeatureDescriptors are now shared on a per-BeanInfo basis, rather than copied when the BeanInfo is returned. This change improves the performance of the getBeanInfo method. It also means that when an attribute/value in a FeatureDescriptor changes, that change is persistent among getBeanInfo invocations as long as the BeanInfo is not garbage collected. (Garbage collection of BeanInfos is described in Garbage Collection and Custom Attributes.)
  • The getBeanInfo methods no longer create a copy of the requested BeanInfo. Instead, they cache the BeanInfo and return it. If necessary, you can get the old behavior by storing a reference to the returned BeanInfo and using the flushFromCaches method to flush the bean's class from the introspector's cache.
  • If the instantiate method can't instantiate a particular class using the sibling or bootstrap class loader, it now tries to load the class using the current thread's class loader.

Garbage Collection and Custom Attributes

As of v 1.4, a BeanInfo can be garbage collected when no direct references to it exist and the system is low on memory. This is implemented in the Introspector by wrapping BeanInfos in SoftReferences.

The possibility of garbage collection affects how you store custom attributes inside BeanInfos. If a particular BeanInfo is garbage collected, then the next time you invoke Introspector.getBeanInfo to get the BeanInfo, the returned object won't contain any custom attributes.

To avoid this problem, if you store custom attributes inside a BeanInfo you must ensure that the BeanInfo is correctly initialized with those attributes every time you retrieve the BeanInfo. The following is an example of initializing a BeanInfo class with a custom property in the bean descriptor. The code would be similar for a custom attribute in a property descriptor, method descriptor, or event set descriptor.

BeanInfo beanInfo = getBeanInfo(SomeBean.class);
BeanDescriptor beanDescriptor = beanInfo.getBeanDescriptor();

/*
 * Before using the BeanInfo, check to see if our custom
 * property has been initialized.  (Even if we initialized
 * it before, if the BeanInfo has been garbage collected,
 * then we need to initialize it again.)  Since our custom
 * property's value could be null, we define another property
 * to tell us if the custom property is initialized.
 */
if (beanDescriptor.getValue("myProperty_init") == null) {
    beanDescriptor.setValue("myProperty", someValue);
    beanDescriptor.setValue("myProperty_init", Boolean.TRUE);
}
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JavaBeans API Enhancements in Java SE 5.0

Documentation Contents

API Enhancements to the JavaBeans Component API in Java SE 5.0

This document describes changes to the java.beans package that were introduced in Java SE 5.0:
  • Support for IndexedPropertyChangeEvent
  • New Method for Creating a PropertyEditor
  • Public Constructors for PropertyEditorSupport

Support for IndexedPropertyChangeEvent

The bugtraq report that corresponds to this change is: 4353056

A new subclass of PropertyChangeEvent named IndexedPropertyChangeEvent has been added to support bound properties that use an index to identify the part of the bean that changed. Also, three methods, all named fireIndexedPropertyChange, have been added to the PropertyChangeSupport utility class to support firing indexed property change events. You can find an example of using indexed property change events in IndexedTest.java.

New Method for Creating a PropertyEditor

The bugtraq report that corresponds to this change is: 4274639

A new method called createPropertyEditor has been added to the PropertyDescriptor class.

Public Constructors for PropertyEditorSupport

The bugtraq report that corresponds to this change is: 4305280

The two PropertyEditorSupport constructors are now public instead of protected, so that PropertyEditorSupport objects can be more easily created and used as delegates. Also, the source object is now exposed by means of new setSource and getSource methods.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Enhancements to the JavaBeans API in Java SE 6.0

Documentation Contents

Enhancements to the JavaBeans Component API in Java SE 6.0

java.beans

Major Features
Fixed Bugs

Major Features

The @ConstructorProperties annotation

The @ConstructorProperties annotation was introduced in Java SE 6.0 to show how the parameters of annotated constructor correspond to an object's properties. Previously, the constructor DefaultPersistenceDelegate(String[] constructorPropertyNames) was used for the same goal, but was not an appropriate approach for library classes.

Technically, an annotation is used for copying beans with read-only properties. In the following code example the Food properties are read-only.

public class Food {
     private final int varieties;
     private final String country;

     @ConstructorProperties({"varieties", "country"})
     public Point(int varieties, String country) {
         this.varieties = varieties;
         this.country = country;
     }
     public int getVarieties() {
         return this.varieties;
     }
     public String getCountry() {
         return this.country;
     }
}

To create a vegetable object with the same properties that the fruit object has, use the following code:

Food fruit = new Food (5, "Argentina");
Food vegetable = new Food (fruit.getVarieties(), fruit.getCountry());
Defining the annotation accomplishes two goals:
  • Eliminates the need for the developer to explicitly use the DefaultPersistenceDelegate class.
  • Describes the relationship between a constructor parameter and a property, but not an operational logic, therefore the annotation can be applied to both bean related areas, such as Long Term Persistence, and to non-beans related areas, such JMX.

Fixed Bugs

The EventHandler class

6179222: Possible a NullPointerException error with the EventHandler class

The NPR exception was thrown by the EventHandler class. The create method of the EventHandler class checks the null value, and javadoc is corrected accordingly.

6204552: The EventHandler documentation and exception handling problems

Documentation on the EventHandler class of the eventPropertyName argument did not clearly explain waht the argument supports. Information about what the eventProperName property is capable of is included in the documentation for the create method.

6210265: The EventHandler class should not cache the Method object

The method search is improved, and the method is prevented from being cached in the EventHandler class field.

6271692: The target property of the EventHandler class did support same syntax as the event property

The target property syntax is fixed and now supports an arbitrary number of methods or properties. This was accomplished by separating each property or method with a ".".

The XMLEncoder class

The following fixes were performed to improve the long-term persistence process.

6245149: The java.beans.XMLEncoder class does not encode java.net.URI objects

The Statement class could not access a member of the java.net.URI class with modifiers private. In JDK 6.0 an appropriate PersistenceDelegate is provided to solve this problem.

4921212: The XMLEncoder class does not encode null entries in HashMap objects

A null Key entry of the HashMap object was not included into the XML output. The fix includes a null Key entry to the XML file.

6256805: The XMLEncoder class emits invalid XML

The XMLEncoder class produces an XML output only for valid XML characters. A new code attribute was introduced for a character element. The code contains a hexadecimal value if it starts with "#". Otherwise it contains a decimal value.

5015403: The XMLEncoder class does not encode enumerations correctly

The XMLEncoder class was not serializing an enumeration correctly. The EnumPersistenceDelegate class, a new persistence delegate, was introduced to support the serialization of enum classes.

4741757: The XMLEncoder class ignores persistence delegates when used with Java Web Start

A DefaultPersistenceDelegate class for some classes was created improperly. As a result the hack that adds field access for properties and breaking JavaBeans specification was detected. The performed fix removes the hack that was intended for the following classes: java.awt.Dimension, java.awt.Point, and java.awt.Rectangle.

6338070: The XMLDecoder class ignores statements made to owner unless the read() method is called

Initially the XMLDecoder class was created with lazy initialization. The fix enables parsing in the close() method if a file is not parsed by the readObject() method.

6341798: The XMLDecoder class fails when using Turkish Locale

The XMLDecoder class did not function correctly when reading an English XML file on a machine with the locale set to Turkish. To fix this bug the toLowerCase and toUpperCase methods are invoked in the English locale.

6437265: Some Component object is missing during xml serializing

Container objects were not serialized. The fix adds special behavior to the persistence delegate for containers with BorderLayout.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
[Top] [Prev] [Next] [Bottom]

Appendix C: JNDI Change History

JNDI 1.2: JNDI Changes Since JNDI 1.1

  • Added javax.naming.event package.
  • Added javax.naming.ldap package.
  • Added support for configuration using resource files. See Chapter 6 of the JNDI API document.

API-related Changes

  • Added NamingEnumeration.close() for cancelling or terminating enumerations.
  • Added ReferralException.getReferralContext(Hashtable env) and ReferralException.retryReferral() to allow creation and retry of referral context with different environment properties.
  • Clarified how context methods that accept Name argument should deal with CompositeName and nonCompositeName arguments. Specifically, instances of CompositeName are treated as composite name, while al l others are treated as compound name.
  • Added Context.getNameInNamespace() for retrieving the full name of a context within its own namespace.
  • Clarified definition of the class factory location of a Reference object. Specifically, the location is a codebase, which consists of a list space-separated URLs.
  • Added support for ordered multivalued attributes to Attribute and BasicAttribute.
  • Added BasicAttributes.equals() and BasicAttributes.hashCode().
  • Redefined semantics of DirContext.getSchemaClassDefinition() so that it returns a context that contains the DirContext objects of class definitions, rather than returning one (arbitrary) class definition.
  • Added protected InitialContext/InitialDirContext constructors to allow lazy initialization. Useful for subclass implementations.

SPI-related Changes

  • Added StateFactory/NamingManager.getStateToBind(), analogous to ObjectFactory/NamingManager.getObjectInstance(), for transforming an object's state before the object is bound in the naming/directory service.
  • Added interfaces DirObjectFactory and DirStateFactory to better support service providers that implement the DirContext interface. Added DirectoryManager.getObjectInstance() and DirectoryManager.getStateToStore() to use these interfaces.
  • Refined definition of NamingManager.getObjectInstance() to not treat URL strings specially. Instead, the URL should be wrapped inside a Reference whose RefAddr type is "URL".
  • Made ResolveResult implement Serializable.
  • Defined a special form of Reference called a next naming system (nns) reference for supporting "dynamic federation". This reference has a RefAddr type of "nns" and a content consisting of the resolved object.
  • Added the string constant NamingManager.CPE which names a property set by NamingManager.getContinuationContext()/DirectoryManager.getContinuationContext(). The value of this property is an instance of CannotProceedException. This is useful to service providers that implement federation by chaining the CPEs.
  • Defined a convention for service providers to use when naming environment properties. See Section 6.1.

[Top] [Prev] [Next] [Bottom]
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 1: Introduction to the Java Sound API

Design Goals

The Java Sound API is a low-level API for effecting and controlling the input and output of sound media, including both audio and Musical Instrument Digital Interface (MIDI) data. The Java Sound API provides explicit control over the capabilities normally required for sound input and output, in a framework that promotes extensibility and flexibility.

Who is the Java Sound API For?

Because sound is so fundamental, the Java Sound API fulfills the needs of a wide range of application developers. Potential application areas include:

  • Communication frameworks, such as conferencing and telephony
  • End-user content delivery systems, such as media players and music using streamed content
  • Interactive application programs, such as games and Web sites that use dynamic content
  • Content creation and editing
  • Tools, toolkits, and utilities

How Does the Java Sound API Relate to Other Interfaces?

The Java Sound API provides the lowest level of sound support on the Java platform. It provides application programs with a great amount of control over sound operations, and it is extensible. For example, the Java Sound API supplies mechanisms for installing, accessing, and manipulating system resources such as audio mixers, MIDI synthesizers, other audio or MIDI devices, file readers and writers, and sound format converters. The Java Sound API does not include sophisticated sound editors or graphical tools, but it provides capabilities upon which such programs can be built. It emphasizes low-level control beyond that commonly expected by the end user.

There are other Java platform APIs that have sound-related elements. The Java Media Framework (JMF) is a higher-level API that is currently available as a Standard Extension to the Java platform. JMF specifies a unified architecture, messaging protocol, and programming interface for capturing and playing back time-based media. JMF provides a simpler solution for basic media-player application programs, and it enables synchronization between different media types, such as audio and video. On the other hand, programs that focus on sound can benefit from the Java Sound API, especially if they require more advanced features, such as the ability to carefully control buffered audio playback or directly manipulate a MIDI synthesizer. Other Java APIs with sound aspects include Java 3D and APIs for telephony and speech. An implementation of any of these APIs might use an implementation of the Java Sound API internally, but is not required to do so.

Packages

The Java Sound API includes support for both digital audio and MIDI data. These two major modules of functionality are provided in separate packages:

  • javax.sound.sampled This package specifies interfaces for capture, mixing, and playback of digital (sampled) audio.
  • javax.sound.midi This package provides interfaces for MIDI synthesis, sequencing, and event transport.

Two other packages permit service providers (as opposed to application developers) to create custom software components that extend the capabilities of an implementation of the Java Sound API:
  • javax.sound.sampled.spi
  • javax.sound.midi.spi

The rest of this chapter briefly discusses the sampled-audio system, the MIDI system, and the SPI packages. Each of these is then discussed in detail in a subsequent part of the guide.

Sampled Audio

What Is Sampled Audio?

The javax.sound.sampled package handles digital audio data, which the Java Sound API refers to as sampled audio. Samples are successive snapshots of a signal. In the case of audio, the signal is a sound wave. A microphone converts the acoustic signal into a corresponding analog electrical signal, and an analog-to-digital converter transforms that analog signal into a sampled digital form. The following figure shows a brief moment in a sound recording.

A sampled sound wave A Sampled Sound Wave

This graph plots sound pressure (amplitude) on the vertical axis, and time on the horizontal axis. The amplitude of the analog sound wave is measured periodically at a certain rate, resulting in the discrete samples (the red data points in the figure) that comprise the digital audio signal. The center horizontal line indicates zero amplitude; points above the line are positive-valued samples, and points below are negative. The accuracy of the digital approximation of the analog signal depends on its resolution in time (the sampling rate) and its quantization, or resolution in amplitude (the number of bits used to represent each sample). As a point of reference, the audio recorded for storage on compact discs is sampled 44,100 times per second and represented with 16 bits per sample.

The term "sampled audio" is used here slightly loosely. A sound wave could be sampled at discrete intervals while being left in an analog form. For purposes of the Java Sound API, however, "sampled audio" is equivalent to "digital audio."

Typically, sampled audio on a computer comes from a sound recording, but the sound could instead be synthetically generated (for example, to create the sounds of a touch-tone telephone). The term "sampled audio" refers to the type of data, not its origin.

Further information about the structure of digital audio data is given under "What Is Formatted Audio Data?" in Chapter 2, "Overview of the Sampled Package."

Audio Configurations

The Java Sound API does not assume a specific audio hardware configuration; it is designed to allow different sorts of audio components to be installed on a system and accessed by the API. The Java Sound API supports common functionality such as input and output from a sound card (for example, for recording and playback of sound files) as well as mixing of multiple streams of audio. Here is one example of a typical audio architecture:

The following context describes this graphic

A Typical Audio Architecture

In this example, a device such as a sound card has various input and output ports, and mixing is provided in the software. The mixer might receive data that has been read from a file, streamed from a network, generated on the fly by an application program, or produced by a MIDI synthesizer. (The javax.sound.midi package, discussed next, supplies a Java language interface for synthesizers.) The mixer combines all its audio inputs into a single stream, which can be sent to an output device for rendering.

MIDI

The javax.sound.midi package contains APIs for transporting and sequencing MIDI events, and for synthesizing sound from those events.

What Is MIDI?

Whereas sampled audio is a direct representation of a sound itself, MIDI data can be thought of as a recipe for creating a sound, especially a musical sound. MIDI data, unlike audio data, does not describe sound directly. Instead, it describes events that affect the sound a synthesizer is making. MIDI data is analogous to a graphical user interface's keyboard and mouse events. In the case of MIDI, the events can be thought of as actions upon a musical keyboard, along with actions on various pedals, sliders, switches, and knobs on that musical instrument. These events need not actually originate with a hardware musical instrument; they can be simulated in software, and they can be stored in MIDI files. A program that can create, edit, and perform these files is called a sequencer. Many computer sound cards include MIDI-controllable music synthesizer chips to which sequencers can send their MIDI events. Synthesizers can also be implemented entirely in software. The synthesizers interpret the MIDI events that they receive and produce audio output. Usually the sound synthesized from MIDI data is musical sound (as opposed to speech, for example). MIDI synthesizers are also capable of generating various kinds of sound effects.

Some sound cards include MIDI input and output ports to which external MIDI hardware devices (such as keyboard synthesizers or other instruments) can be connected. From a MIDI input port, an application program can receive events generated by an external MIDI-equipped musical instrument. The program might play the musical performance using the computer's internal synthesizer, save it to disk as a MIDI file, or render it into musical notation. A program might use a MIDI output port to play an external instrument, or to control other external devices such as recording equipment.

More information about MIDI data is given in Chapter 8, "Overview of the MIDI Package," particularly in the section "A MIDI Refresher: Wires and Files."

MIDI Configurations

The diagram below illustrates the functional relationships between the major components in a possible MIDI configuration based on the Java Sound API. (As with audio, the Java Sound API permits a variety of MIDI software devices to be installed and interconnected. The system shown here is one potential scenario.) The flow of data between components is indicated by arrows. The data can be in a standard file format, or (as indicated by the key in the lower right corner of the diagram), it can be audio, raw MIDI bytes, or time-tagged MIDI messages.

The following context describes this graphic

A Possible MIDI Configuration

In this example, the application program prepares a musical performance by loading a musical score that's stored as a standard MIDI file on a disk (left side of the diagram). Standard MIDI files contain tracks, each of which is a list of time-tagged MIDI events. Most of the events represent musical notes (pitches and rhythms). This MIDI file is read and then "performed" by a software sequencer. A sequencer performs its music by sending MIDI messages to some other device, such as an internal or external synthesizer. The synthesizer itself may read a soundbank file containing instructions for emulating the sounds of certain musical instruments. If not, the synthesizer will play the notes stored in the MIDI file using whatever instrument sounds are already loaded into the synthesizer.

As illustrated, the MIDI events must be translated into raw (non-time-tagged) MIDI before being sent through a MIDI output port to an external synthesizer. Similarly, raw MIDI data coming into the computer from an external MIDI source (a keyboard instrument, in the diagram) is translated into time-tagged MIDI messages that can control a synthesizer, or that a sequencer can store for later use. All these aspects of MIDI data flow are explained in detail in the subsequent chapters on MIDI (see Part II of this guide).

Service Provider Interfaces

The javax.sound.sampled.spi and javax.sound.midi.spi packages contain APIs that let software developers create new audio or MIDI resources that can be provided separately to the user and "plugged in" to an existing implementation of the Java Sound API. Here are some examples of services (resources) that can be added in this way:

  • An audio mixer
  • A MIDI synthesizer
  • A file parser that can read or write a new type of audio or MIDI file
  • A converter that translates between different sound data formats

In some cases, services are software interfaces to the capabilities of hardware devices, such as sound cards, and the service provider might be the same as the vendor of the hardware. In other cases, the services exist purely in software. For example, a synthesizer or a mixer could be an interface to a chip on a sound card, or it could be implemented without any hardware support at all.

An implementation of the Java Sound API contains a basic set of services, but the service provider interface (SPI) packages allow third parties to create new services. These third-party services are integrated into the system in the same way as the built-in services. The AudioSystem class in the sampled package and the MidiSystem class in the midi package act as coordinators that let application programs access the services explicitly or implicitly. Often the existence of a service is completely transparent to an application program that uses it. The service-provider mechanism benefits users of application programs based on the Java Sound API, because new sound features can be added to a program without requiring a new release of the JDK or runtime environment, and, in many cases, without even requiring a new release of the application program itself.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 2: Overview of the Sampled Package

Notes

  1. Direct Audio mixers are always the default on Windows. They are the default on Solaris if the Solaris audio mixer is enabled (see Solaris man page for mixer). On Linux, they are the default only if there is a device that supports mixing.
  2. Because they are "direct," Direct Audio mixers do not support SAMPLE_RATE control.
  3. The default mixer can be selected via the sound.properties file.

This chapter provides an introduction to the Java Sound API's digital audio architecture, which is accessed through the javax.sound.sampled package. First, an explanation is given of the package's focus: playback and capture of formatted audio data. Then this chapter describes the three fundamental components required for playback or capture: an audio data format, a line, and a mixer. The Line interface and its subinterfaces are introduced briefly.

Design Goals

Before examining the elements of the Java Sound API, it helps to understand the orientation of the javax.sound.sampled package.

A Focus on Data Transport

The javax.sound.sampled package is fundamentally concerned with audio transport—in other words, the Java Sound API focuses on playback and capture. The central task that the Java Sound API addresses is how to move bytes of formatted audio data into and out of the system. This task involves opening audio input and output devices and managing buffers that get filled with real-time sound data. It can also involve mixing multiple streams of audio into one stream (whether for input or output). The transport of sound into or out of the system has to be correctly handled when the user requests that the flow of sound be started, paused, resumed, or stopped.

To support this focus on basic audio input and output, the Java Sound API provides methods for converting between various audio data formats, and for reading and writing common types of sound files. However, it does not attempt to be a comprehensive sound-file toolkit. A particular implementation of the Java Sound API need not support an extensive set of file types or data format conversions. Third-party service providers can supply modules that "plug in" to an existing implementation to support additional file types and conversions.

Buffered and Unbuffered Handling of Audio

The Java Sound API can handle audio transport in both a streaming, buffered fashion and an in-memory, unbuffered fashion. "Streaming" is used here in a general sense to refer to real-time handling of audio bytes; it does not refer to the specific, well-known case of sending audio over the Internet in a certain format. In other words, a stream of audio is simply a continuous set of audio bytes that arrive more or less at the same rate that they are to be handled (played, recorded, etc.). Operations on the bytes commence before all the data has arrived. In the streaming model, particularly in the case of audio input rather than audio output, you do not necessarily know in advance how long the sound is and when it will finish arriving. You simply handle one buffer of audio data at a time, until the operation is halted. In the case of audio output (playback), you also need to buffer data if the sound you want to play is too large to fit in memory all at once. In other words, you deliver your audio bytes to the sound engine in chunks, and it takes care of playing each sample at the right time. Mechanisms are provided that make it easy to know how much data to deliver in each chunk.

The Java Sound API also permits unbuffered transport in the case of playback only, assuming you already have all the audio data at hand and it is not too large to fit in memory. In this situation, there is no need for the application program to buffer the audio, although the buffered, real-time approach is still available if desired. Instead, the entire sound can be preloaded at once into memory for subsequent playback. Because all the sound data is loaded in advance, playback can start immediately, for example, as soon as the user clicks a Start button. This can be an advantage compared to the buffered model, where the playback has to wait for the first buffer to fill. In addition, the in-memory, unbuffered model allows sounds to be easily looped (cycled) or set to arbitrary positions in the data.

These two models for playback are discussed further in Chapter 4, "Playing Back Audio." Buffered recording is discussed in Chapter 5, "Capturing Audio."

The Essentials: Format, Mixer, and Line

To play or capture sound using the Java Sound API, you need at least three things: formatted audio data, a mixer, and a line. Each of these is explained below.

What Is Formatted Audio Data?

Formatted audio data refers to sound in any of a number of standard formats. The Java Sound API distinguishes between data formats and file formats.

Data Formats

A data format tells you how to interpret a series of bytes of "raw" sampled audio data, such as samples that have already been read from a sound file, or samples that have been captured from the microphone input. You might need to know, for example, how many bits constitute one sample (the representation of the shortest instant of sound), and similarly you might need to know the sound's sample rate (how fast the samples are supposed to follow one another). When setting up for playback or capture, you specify the data format of the sound you are capturing or playing.

In the Java Sound API, a data format is represented by an AudioFormat object, which includes the following attributes:

  • Encoding technique, usually pulse code modulation (PCM)
  • Number of channels (1 for mono, 2 for stereo, etc.)
  • Sample rate (number of samples per second, per channel)
  • Number of bits per sample (per channel)
  • Frame rate
  • Frame size in bytes
  • Byte order (big-endian or little-endian)

PCM is one kind of encoding of the sound waveform. The Java Sound API includes two PCM encodings that use linear quantization of amplitude, and signed or unsigned integer values. Linear quantization means that the number stored in each sample is directly proportional (except for any distortion) to the original sound pressure at that instant and similarly proportional to the displacement of a loudspeaker or eardrum that is vibrating with the sound at that instant. Compact discs, for example, use linear PCM-encoded sound. Mu-law encoding and a-law encoding are common nonlinear encodings that provide a more compressed version of the audio data; these encodings are typically used for telephony or recordings of speech. A nonlinear encoding maps the original sound's amplitude to the stored value using a nonlinear function, which can be designed to give more amplitude resolution to quiet sounds than to loud sounds.

A frame contains the data for all channels at a particular time. For PCM-encoded data, the frame is simply the set of simultaneous samples in all channels, for a given instant in time, without any additional information. In this case, the frame rate is equal to the sample rate, and the frame size in bytes is the number of channels multiplied by the sample size in bits, divided by the number of bits in a byte.

For other kinds of encodings, a frame might contain additional information besides the samples, and the frame rate might be completely different from the sample rate. For example, consider the MP3 (MPEG-1 Audio Layer 3) encoding, which is not explicitly mentioned in the current version of the Java Sound API, but which could be supported by an implementation of the Java Sound API or by a third-party service provider. In MP3, each frame contains a bundle of compressed data for a series of samples, not just one sample per channel. Because each frame encapsulates a whole series of samples, the frame rate is slower than the sample rate. The frame also contains a header. Despite the header, the frame size in bytes is less than the size in bytes of the equivalent number of PCM frames. (After all, the purpose of MP3 is to be more compact than PCM data.) For such an encoding, the sample rate and sample size refer to the PCM data that the encoded sound will eventually be converted into before being delivered to a digital-to-analog converter (DAC).

File Formats

A file format specifies the structure of a sound file, including not only the format of the raw audio data in the file, but also other information that can be stored in the file. Sound files come in various standard varieties, such as WAVE (also known as WAV, and often associated with PCs), AIFF (often associated with Macintoshes), and AU (often associated with UNIX systems). The different types of sound file have different structures. For example, they might have a different arrangement of data in the file's "header." A header contains descriptive information that typically precedes the file's actual audio samples, although some file formats allow successive "chunks" of descriptive and audio data. The header includes a specification of the data format that was used for storing the audio in the sound file. Any of these types of sound file can contain various data formats (although usually there is only one data format within a given file), and the same data format can be used in files that have different file formats.

In the Java Sound API, a file format is represented by an AudioFileFormat object, which contains:

  • The file type (WAVE, AIFF, etc.)
  • The file's length in bytes
  • The length, in frames, of the audio data contained in the file
  • An AudioFormat object that specifies the data format of the audio data contained in the file

The AudioSystem class (described in Chapter 3, "Accessing Audio System Resources") provides methods for reading and writing sounds in different file formats, and for converting between different data formats. Some of the methods let you access a file's contents through a kind of stream called an AudioInputStream. An AudioInputStream is a subclass of the generic Java InputStream class, which encapsulates a series of bytes that can be read sequentially. To its superclass, the AudioInputStream class adds knowledge of the bytes' audio data format (represented by an AudioFormat object). By reading a sound file as an AudioInputStream, you get immediate access to the samples, without having to worry about the sound file's structure (its header, chunks, etc.). A single method invocation gives you all the information you need about the data format and the file type.

What Is a Mixer?

Many application programming interfaces (APIs) for sound make use of the notion of an audio device. A device is often a software interface to a physical input/output device. For example, a sound-input device might represent the input capabilities of a sound card, including a microphone input, a line-level analog input, and perhaps a digital audio input.

In the Java Sound API, devices are represented by Mixer objects. The purpose of a mixer is to handle one or more streams of audio input and one or more streams of audio output. In the typical case, it actually mixes together multiple incoming streams into one outgoing stream. A Mixer object can represent the sound-mixing capabilities of a physical device such as a sound card, which might need to mix the sound coming in to the computer from various inputs, or the sound coming from application programs and going to outputs.

Alternatively, a Mixer object can represent sound-mixing capabilities that are implemented entirely in software, without any inherent interface to physical devices.

In the Java Sound API, a component such as the microphone input on a sound card is not itself considered a device—that is, a mixer—but rather a port into or out of the mixer. A port typically provides a single stream of audio into or out of the mixer (although the stream can be multichannel, such as stereo). The mixer might have several such ports. For example, a mixer representing a sound card's output capabilities might mix several streams of audio together, and then send the mixed signal to any or all of various output ports connected to the mixer. These output ports could be (for example) a headphone jack, a built-in speaker, or a line-level output.

To understand the notion of a mixer in the Java Sound API, it helps to visualize a physical mixing console, such as those used in live concerts and recording studios. (See illustration that follows.)

Physical mixing console

A Physical Mixing Console

A physical mixer has "strips" (also called "slices"), each representing a path through which a single audio signal goes into the mixer for processing. The strip has knobs and other controls by which you can control the volume and pan (placement in the stereo image) for the signal in that strip. Also, the mixer might have a separate bus for effects such as reverb, and this bus can be connected to an internal or external reverberation unit. Each strip has a potentiometer that controls how much of that strip's signal goes into the reverberated mix. The reverberated ("wet") mix is then mixed with the "dry" signals from the strips. A physical mixer sends this final mixture to an output bus, which typically goes to a tape recorder (or disk-based recording system) and/or speakers.

Imagine a live concert that is being recorded in stereo. Cables (or wireless connections) coming from the many microphones and electric instruments on stage are plugged into the inputs of the mixing console. Each input goes to a separate strip of the mixer, as illustrated. The sound engineer decides on the settings of the gain, pan, and reverb controls. The output of all the strips and the reverb unit are mixed together into two channels. These two channels go to two outputs on the mixer, into which cables are plugged that connect to the stereo tape recorder's inputs. The two channels are perhaps also sent via an amplifier to speakers in the hall, depending on the type of music and the size of the hall.

Now imagine a recording studio, in which each instrument or singer is recorded to a separate track of a multitrack tape recorder. After the instruments and singers have all been recorded, the recording engineer performs a "mixdown" to combine all the taped tracks into a two-channel (stereo) recording that can be distributed on compact discs. In this case, the input to each of the mixer's strips is not a microphone, but one track of the multitrack recording. Once again, the engineer can use controls on the strips to decide each track's volume, pan, and reverb amount. The mixer's outputs go once again to a stereo recorder and to stereo speakers, as in the example of the live concert.

These two examples illustrate two different uses of a mixer: to capture multiple input channels, combine them into fewer tracks, and save the mixture, or to play back multiple tracks while mixing them down to fewer tracks.

In the Java Sound API, a mixer can similarly be used for input (capturing audio) or output (playing back audio). In the case of input, the source from which the mixer gets audio for mixing is one or more input ports. The mixer sends the captured and mixed audio streams to its target, which is an object with a buffer from which an application program can retrieve this mixed audio data. In the case of audio output, the situation is reversed. The mixer's source for audio is one or more objects containing buffers into which one or more application programs write their sound data; and the mixer's target is one or more output ports.

What Is a Line?

The metaphor of a physical mixing console is also useful for understanding the Java Sound API's concept of a line.

A line is an element of the digital audio "pipeline"—that is, a path for moving audio into or out of the system. Usually the line is a path into or out of a mixer (although technically the mixer itself is also a kind of line).

Audio input and output ports are lines. These are analogous to the microphones and speakers connected to a physical mixing console. Another kind of line is a data path through which an application program can get input audio from, or send output audio to, a mixer. These data paths are analogous to the tracks of the multitrack recorder connected to the physical mixing console.

One difference between lines in the Java Sound API and those of a physical mixer is that the audio data flowing through a line in the Java Sound API can be mono or multichannel (for example, stereo). By contrast, each of a physical mixer's inputs and outputs is typically a single channel of sound. To get two or more channels of output from the physical mixer, two or more physical outputs are normally used (at least in the case of analog sound; a digital output jack is often multichannel). In the Java Sound API, the number of channels in a line is specified by the AudioFormat of the data that is currently flowing through the line.

Lines in an Audio-output Configuration

Let's now examine some specific kinds of lines and mixers. The following diagram shows different types of lines in a simple audio-output system that could be part of an implementation of the Java Sound API:

Possible configuration of lines for audio output

A Possible Configuration of Lines for Audio Output

In this example, an application program has gotten access to some available inputs of an audio-input mixer: one or more clips and source data lines. A clip is a mixer input (a kind of line) into which you can load audio data prior to playback; a source data line is a mixer input that accepts a real-time stream of audio data. The application program preloads audio data from a sound file into the clips. It then pushes other audio data into the source data lines, a buffer at a time. The mixer reads data from all these lines, each of which may have its own reverberation, gain, and pan controls, and mixes the dry audio signals with the wet (reverberated) mix. The mixer delivers its final output to one or more output ports, such as a speaker, a headphone jack, and a line-out jack.

Although the various lines are depicted as separate rectangles in the diagram, they are all "owned" by the mixer, and can be considered integral parts of the mixer. The reverb, gain, and pan rectangles represent processing controls (rather than lines) that can be applied by the mixer to data flowing through the lines.

Note that this is just one example of a possible mixer that is supported by the API. Not all audio configurations will have all the features illustrated. An individual source data line might not support panning, a mixer might not implement reverb, and so on.

Lines in an Audio-input Configuration

A simple audio-input system might be similar:

Possible configuration of lines for audio input

A Possible Configuration of Lines for Audio Input

Here, data flows into the mixer from one or more input ports, commonly the microphone or the line-in jack. Gain and pan are applied, and the mixer delivers the captured data to an application program via the mixer's target data line. A target data line is a mixer output, containing the mixture of the streamed input sounds. The simplest mixer has just one target data line, but some mixers can deliver captured data to multiple target data lines simultaneously.

The Line Interface Hierarchy

Now that we've seen some functional pictures of what lines and mixers are, let's discuss them from a slightly more programmatic perspective. Several types of line are defined by subinterfaces of the basic Line interface. The interface hierarchy is shown below.

Line interface hierarchy

The Line Interface Hierarchy

The base interface, Line, describes the minimal functionality common to all lines:

  • Controls Data lines and ports often have a set of controls that affect the audio signal passing through the line. The Java Sound API specifies control classes that can be used to manipulate aspects of sound such as: gain (which affects the signal's volume in decibels), pan (which affects the sound's right-left positioning, reverb (which adds reverberation to the sound to emulate different kinds of room acoustics), and sample rate (which affects the rate of playback as well as the sound's pitch).
  • Open or closed status Successful opening of a line guarantees that resources have been allocated to the line. A mixer has a finite number of lines, so at some point multiple application programs (or the same one) might vie for usage of the mixer's lines. Closing a line indicates that any resources used by the line may now be released.
  • Events A line generates events when it opens or closes. Subinterfaces of Line can introduce other types of events. When a line generates an event, the event is sent to all objects that have registered to "listen" for events on that line. An application program can create these objects, register them to listen for line events, and react to the events as desired.

We'll now examine the subinterfaces of the Line interface.

Ports are simple lines for input or output of audio to or from audio devices. As mentioned earlier, some common types of ports are the microphone, line input, CD-ROM drive, speaker, headphone, and line output.

The Mixer interface represents a mixer, of course, which as we have seen represents either a hardware or a software device. The Mixer interface provides methods for obtaining a mixer's lines. These include source lines, which feed audio to the mixer, and target lines, to which the mixer delivers its mixed audio. For an audio-input mixer, the source lines are input ports such as the microphone input, and the target lines are TargetDataLines (described below), which deliver audio to the application program. For an audio-output mixer, on the other hand, the source lines are Clips or SourceDataLines (described below), to which the application program feeds audio data, and the target lines are output ports such as the speaker.

A Mixer is defined as having one or more source lines and one or more target lines. Note that this definition means that a mixer need not actually mix data; it might have only a single source line. The Mixer API is intended to encompass a variety of devices, but the typical case supports mixing.

The Mixer interface supports synchronization; that is, you can specify that two or more of a mixer's lines be treated as a synchronized group. Then you can start, stop, or close all those data lines by sending a single message to any line in the group, instead of having to control each line individually. With a mixer that supports this feature, you can obtain sample-accurate synchronization between lines.

The generic Line interface does not provide a means to start and stop playback or recording. For that you need a data line. The DataLine interface supplies the following additional media-related features beyond those of a Line:

  • Audio format Each data line has an audio format associated with its data stream.
  • Media position A data line can report its current position in the media, expressed in sample frames. This represents the number of sample frames captured by or rendered from the data line since it was opened.
  • Buffer size This is the size of the data line's internal buffer in bytes. For a source data line, the internal buffer is one to which data can be written, and for a target data line it's one from which data can be read.
  • Level (the current amplitude of the audio signal)

  • Start and stop playback or capture

  • Pause and resume playback or capture

  • Flush (discard unprocessed data from the queue)

  • Drain (block until all unprocessed data has been drained from the queue, and the data line's buffer has become empty)

  • Active status A data line is considered active if it is engaged in active presentation or capture of audio data to or from a mixer.
  • Events START and STOP events are produced when active presentation or capture of data from or to the data line starts or stops.

A TargetDataLine receives audio data from a mixer. Commonly, the mixer has captured audio data from a port such as a microphone; it might process or mix this captured audio before placing the data in the target data line's buffer. The TargetDataLine interface provides methods for reading the data from the target data line's buffer and for determining how much data is currently available for reading.

A SourceDataLine receives audio data for playback. It provides methods for writing data to the source data line's buffer for playback, and for determining how much data the line is prepared to receive without blocking.

A Clip is a data line into which audio data can be loaded prior to playback. Because the data is pre-loaded rather than streamed, the clip's duration is known before playback, and you can choose any starting position in the media. Clips can be looped, meaning that upon playback, all the data between two specified loop points will repeat a specified number of times, or indefinitely.

This chapter has introduced most of the important interfaces and classes of the sampled-audio API. Subsequent chapters show how you can access and use these objects in your application program.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 3: Accessing Audio System Resources

Notes

  1. The Port class was not available on all platforms before JDK 5.0.
  2. With version 5.0, the sound.properties file can be used to set default devices for Clip, Port, SourceDataLine, and TargetDataLine. For details, see the AudioSystem class in the API; for examples, see Appendix 2: sound.properties File in this guide.
  3. While the method for obtaining lines, as outlined below in Getting a Line of a Desired Type, is still valid, for 5.0 there are convenience methods for Clip, SourceDataLine, and TargetDataLine: AudioSystem.getClip(), AudioSystem.getSourceDataLine(), and AudioSystem.getTargetDataLine(). See the AudioSystem for details.

The Java Sound API takes a flexible approach to system configuration. Different sorts of audio devices (mixers) can be installed on a computer. The API makes few assumptions about what devices have been installed and what their capabilities are. Instead, it provides ways for the system to report about the available audio components, and ways for your program to access them.

This section shows how your program can learn what sampled-audio resources have been installed on the computer, and how it can gain access to the available resources. Among other things, the resources include mixers and the various types of lines owned by the mixers.

The AudioSystem Class

The AudioSystem class acts as a clearinghouse for audio components, including built-in services and separately installed services from third-party providers. AudioSystem serves as an application program's entry point for accessing these installed sampled-audio resources. You can query the AudioSystem to learn what sorts of resources have been installed, and then you can obtain access to them. For example, an application program might start out by asking the AudioSystem class whether there is a mixer that has a certain configuration, such as one of the input or output configurations illustrated earlier in the discussion of lines. From the mixer, the program would then obtain data lines, and so on.

Here are some of the resources an application program can obtain from the AudioSystem:

  • Mixers A system typically has multiple mixers installed. There is usually at least one for audio input and one for audio output. There might also be mixers that don't have I/O ports but instead accept audio from an application program and deliver the mixed audio back to the program. The AudioSystem class provides a list of all of the installed mixers.
  • Lines Even though every line is associated with a mixer, an application program can get a line directly from the AudioSystem, without dealing explicitly with mixers.
  • Format conversions An application program can use format conversions to translate audio data from one format to another. Conversions are described in Chapter 7, "Using Files and Format Converters."
  • Files and streams The AudioSystem class provides methods for translating between audio files and audio streams. It can also report the file format of a sound file and can write files in different formats. These facilities are discussed in Chapter 7, "Using Files and Format Converters."

Information Objects

Several classes in the Java Sound API provide useful information about associated interfaces. For example, Mixer.Info provides details about an installed mixer, such as the mixer's vendor, name, description, and version. Line.Info obtains the class of a specific line. Subclasses of Line.Info include Port.Info and DataLine.Info, which obtain details relevant to a specific port and data line, respectively. Each of these classes is described further in the appropriate section below. It's important not to confuse the Info object with the mixer or line object that it describes.

Getting a Mixer

Usually, one of the first things a program that uses the Java Sound API needs to do is to obtain a mixer, or at least one line of a mixer, so that you can get sound into or out of the computer. Your program might need a specific kind of mixer, or you might want to display a list of all the available mixers so that the user can select one. In either case, you need to learn what kinds of mixers are installed. AudioSystem provides the following method:

    static Mixer.Info[] getMixerInfo()
Each Mixer.Info object returned by this method identifies one type of mixer that is installed. (Usually a system has at most one mixer of a given type. If there happens to be more than one of a given type, the returned array still only has one Mixer.Info for that type.) An application program can iterate over the Mixer.Info objects to find an appropriate one, according to its needs. The Mixer.Info includes the following strings to identify the kind of mixer:
  • Name
  • Version
  • Vendor
  • Description

These are arbitrary strings, so an application program that needs a specific mixer must know what to expect and what to compare the strings to. The company that provides the mixer should include this information in its documentation. Alternatively, and perhaps more typically, the application program will display all the Mixer.Info objects' strings to the user and let the user choose the corresponding mixer.

Once an appropriate mixer is found, the application program invokes the following AudioSystem method to obtain the desired mixer:

    static Mixer getMixer(Mixer.Info info)
What if your program needs a mixer that has certain capabilities, but it doesn't need a specific mixer made by a specific vendor? And what if you can't depend on the user's knowing which mixer should be chosen? In that case, the information in the Mixer.Info objects won't be of much use. Instead, you can iterate over all the Mixer.Info objects returned by getMixerInfo, get a mixer for each by invoking getMixer, and query each mixer for its capabilities. For example, you might need a mixer that can write its mixed audio data to a certain number of target data lines simultaneously. In that case, you would query each mixer using this Mixer method: int getMaxLines(Line.Info info)

Here, the Line.Info would specify a TargetDataLine. The Line.Info class is discussed in the next section.

Getting a Line of a Desired Type

There are two ways to get a line:

  • Directly from the AudioSystem object
  • From a mixer that you have already obtained from the AudioSystem object (see "Getting a Mixer," in this chapter)

Getting a Line Directly from the AudioSystem

Let's assume you haven't obtained a mixer, and your program is a simple one that really only needs a certain kind of line; the details of the mixer don't matter to you. You can use the AudioSystem method:

    static Line getLine(Line.Info info)
which is analogous to the getMixer method discussed above. Unlike Mixer.Info, the Line.Info used as an argument doesn't store textual information to specify the desired line. Instead, it stores information about the class of line desired.

Line.Info is an abstract class, so you use one of its subclasses (Port.Info or DataLine.Info) to obtain a line. The following code excerpt uses the DataLine.Info subclass to obtain and open a target data line:

TargetDataLine line;
DataLine.Info info = new DataLine.Info(TargetDataLine.class,
    format); // format is an AudioFormat object
if (!AudioSystem.isLineSupported(info)) {
    // Handle the error.
    }
    // Obtain and open the line.
try {
    line = (TargetDataLine) AudioSystem.getLine(info);
    line.open(format);
} catch (LineUnavailableException ex) {
        // Handle the error.
    //...
}
This code obtains a TargetDataLine object without specifying any attributes other than its class and its audio format. You can use analogous code to obtain other kinds of lines. For a SourceDataLine or a Clip, just substitute that class for TargetDataLine as the class of the line variable, and also in the first argument to the DataLine.Info constructor.

For a Port, you can use static instances of Port.Info, in code like the following:

if (AudioSystem.isLineSupported(Port.Info.MICROPHONE)) {
    try {
        line = (Port) AudioSystem.getLine(
            Port.Info.MICROPHONE);
    }
}
Note the use of the method isLineSupported to see whether the mixer even has a line of the desired type.

Recall that a source line is an input to a mixer—namely, a Port object if the mixer represents an audio-input device, and a SourceDataLine or Clip object if the mixer represents an audio-output device. Similarly, a target line is an output of the mixer: a Port object for an audio-output mixer, and a TargetDataLine object for an audio-input mixer. What if a mixer doesn't connect to any external hardware device at all? For example, consider an internal or software-only mixer that gets audio from an application program and delivers its mixed audio back to the program. This kind of mixer has SourceDataLine or Clip objects for its input lines and TargetDataLine objects for its output lines.

You can also use the following AudioSystem methods to learn more about source and target lines of a specified type that are supported by any installed mixer:

    static Line.Info[] getSourceLineInfo(Line.Info info)
    static Line.Info[] getTargetLineInfo(Line.Info info)
Note that the array returned by each of these methods indicates unique types of lines, not necessarily all the lines. For example, if two of a mixer's lines, or two lines of different mixers, have identical Line.Info objects, the two lines will represented by only one Line.Info in the returned array.

Getting a Line from a Mixer

The Mixer interface includes variations on the AudioSystem access methods for source and target lines, described above. These Mixer methods include ones that take Line.Info arguments, just as AudioSystem's methods do. However, Mixer also includes these variants, which take no arguments:

    Line.Info[] getSourceLineInfo()
    Line.Info[] getTargetLineInfo()
These methods return arrays of all the Line.Info objects for the particular mixer. Once you've obtained the arrays, you can iterate over them, calling Mixer's getLine method to obtain each line, followed by Line's open method to reserve use of each line for your program.

Selecting Input and Output Ports

The previous section, regarding how to obtain a line of a desired type, applies to ports as well as other types of lines. You can obtain all of the source (i.e., input) and target (i.e, output) ports by passing a Port.Info object to the AudioSystem (or Mixer) methods getSourceLineInfo and getTargetLineInfo that take a Line.Info argument. You then iterate over the returned array of objects and invoke Mixer's getLine method to get each port.

You can then open each Port by invoking Line's open method. Opening a port means you turn it on—that is, you allow sound to come in or out the port. Similarly, you can close ports that you don't want sound to travel through, because some ports might already be open before you even obtain them. Some platforms leave all ports on by default; or a user or system administrator might have selected certain ports to be on or off, using another application program or operating-system software.

Warning: If you want to select a certain port and make sure that the sound is actually going in or out the port, you can open the port as described. However, this can be considered user-hostile behavior! For example, a user might have the speaker port turned off so as not to disturb her co-workers. She would be rather upset if your program suddenly overrode her wishes and started blaring music. As another example, a user might want to be assured that his computer's microphone is never turned on without his knowledge, to avoid eavesdropping. In general, it is recommended not to open or close ports unless your program is responding to the user's intentions, as expressed through the user interface. Instead, respect the settings that the user or the operating system has already selected.

It isn't necessary to open or close a port before the mixer it's attached to will function correctly. For example, you can start playing back sound into an audio-output mixer, even though all its output ports are closed. The data still flows into the mixer; the playback isn't blocked. The user just won't hear anything. As soon as the user opens an output port, the sound will be audible through that port, starting at whatever point in the media the playback has already reached.

Also, you don't need to access the ports to learn whether the mixer has certain ports. To learn whether a mixer is actually an audio-output mixer, for example, you can invoke getTargetLineInfo to see whether it has output ports. There's no reason to access the ports themselves unless you want to change their settings (such as their open-or-closed state, or the settings of any controls they might have).

Permission to Use Audio Resources

The Java Sound API includes an AudioPermission class that indicates what kinds of access an applet (or an application running with a security manager) can have to the sampled-audio system. Permission to record sound is controlled separately. This permission should be granted with care, to help prevent security risks such as unauthorized eavesdropping. By default, applets and applications are granted permissions as follows:

  • An applet running with the applet security manager can play, but not record, audio.
  • An application running with no security manager can both play and record audio.
  • An application running with the default security manager can play, but not record, audio.

In general, applets are run under the scrutiny of a security manager and aren't permitted to record sound. Applications, on the other hand, don't automatically install a security manager, and are able to record sound. (However, if the default security manager is invoked explicitly for an application, the application isn't permitted to record sound.)

Both applets and applications can record sound even when running with a security manager if they have been granted explicit permission to do so.

If your program doesn't have permission to record (or play) sound, an exception will be thrown when it attempts to open a line. There is nothing you can do about this in your program, other than to catch the exception and report the problem to the user, because permissions can't be changed through the API. (If they could, they would be pointless, because nothing would be secure!) Generally, permissions are set in one or more policy configuration files, which a user or system administrator can edit using a text editor or the Policy Tool program.

For more information on security and permissions, see "Security Architecture" and "Policy Permissions" in the Security guide and the specialized trail on security in the Java Tutorial.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 4: Playing Back Audio

Playback is sometimes referred to as presentation or rendering. These are general terms that are applicable to other kinds of media besides sound. The essential feature is that a sequence of data is delivered somewhere for eventual perception by a user. If the data is time-based, as sound is, it must be delivered at the correct rate. With sound even more than video, it's important that the rate of data flow be maintained, because interruptions to sound playback often produce loud clicks or irritating distortion. The Java Sound API is designed to help application programs play sounds smoothly and continuously, even very long sounds.

The previous chapter discussed how to obtain a line from the audio system or from a mixer. This chapter shows how to play sound through a line.

There are two kinds of line that you can use for playing sound: a Clip and a SourceDataLine. These two interfaces were introduced briefly under "The Line Interface Hierarchy" in Chapter 2, "Overview of the Sampled Package." The chief difference between the two is that with a Clip you specify all the sound data at one time, before playback, whereas with a SourceDataLine you keep writing new buffers of data continuously during playback. Although there are many situations in which you could use either a Clip or a SourceDataLine, the following criteria help identify which kind of line is better suited for a particular situation:

  • Use a Clip when you have non-real-time sound data that can be preloaded into memory.

    For example, you might read a short sound file into a clip. If you want the sound to play back more than once, a Clip is more convenient than a SourceDataLine, especially if you want the playback to loop (cycle repeatedly through all or part of the sound). If you need to start the playback at an arbitrary position in the sound, the Clip interface provides a method to do that easily. Finally, playback from a Clip generally has less latency than buffered playback from a SourceDataLine. In other words, because the sound is preloaded into a clip, playback can start immediately instead of having to wait for the buffer to be filled.

  • Use a SourceDataLine for streaming data, such as a long sound file that won't all fit in memory at once, or a sound whose data can't be known in advance of playback.

    As an example of the latter case, suppose you're monitoring sound input—that is, playing sound back as it's being captured. If you don't have a mixer that can send input audio right back out an output port, your application program will have to take the captured data and send it to an audio-output mixer. In this case, a SourceDataLine is more appropriate than a Clip. Another example of sound that can't be known in advance occurs when you synthesize or manipulate the sound data interactively in response to the user's input. For example, imagine a game that gives aural feedback by "morphing" from one sound to another as the user moves the mouse. The dynamic nature of the sound transformation requires the application program to update the sound data continuously during playback, instead of supplying it all before playback starts.

Using a Clip

You obtain a Clip as described earlier under "Getting a Line of a Desired Type" in Chapter 3, "Accessing Audio System Resources": Construct a DataLine.Info object with Clip.class for the first argument, and pass this DataLine.Info as an argument to the getLine method of AudioSystem or Mixer.

Setting Up the Clip for Playback

Obtaining a line just means you've gotten a way to refer to it; getLine doesn't actually reserve the line for you. Because a mixer might have a limited number of lines of the desired type available, it can happen that after you invoke getLine to obtain the clip, another application program jumps in and grabs the clip before you're ready to start playback. To actually use the clip, you need to reserve it for your program's exclusive use by invoking one of the following Clip methods:

   void open(AudioInputStream stream)
   void open(AudioFormat format, byte[] data, int offset,
   int bufferSize)
Despite the bufferSize argument in the second open method above, Clip (unlike SourceDataLine) includes no methods for writing new data to the buffer. The bufferSize argument here just specifies how much of the byte array to load into the clip. It's not a buffer into which you can subsequently load more data, as you can with a SourceDataLine's buffer.

After opening the clip, you can specify at what point in the data it should start playback, using Clip's setFramePosition or setMicroSecondPosition methods. Otherwise, it will start at the beginning. You can also configure the playback to cycle repeatedly, using the setLoopPoints method.

Starting and Stopping Playback

When you're ready to start playback, simply invoke the start method. To stop or pause the clip, invoke the stop method, and to resume playback, invoke start again. The clip remembers the media position where it stopped playback, so there's no need for explicit pause and resume methods. If you don't want it to resume where it left off, you can "rewind" the clip to the beginning (or to any other position, for that matter) using the frame- or microsecond-positioning methods mentioned above.

A Clip's volume level and activity status (active versus inactive) can be monitored by invoking the DataLine methods getLevel and isActive, respectively. An active Clip is one that is currently playing sound.

Using a SourceDataLine

Obtaining a SourceDataLine is similar to obtaining a Clip. See "Getting a Line of a Desired Type" in Chapter 3, "Accessing Audio System Resources."

Setting Up the SourceDataLine for Playback

Opening the SourceDataLine is also similar to opening a Clip, in that the purpose is once again to reserve the line. However, you use a different method, inherited from DataLine:

    void open(AudioFormat format)
Notice that when you open a SourceDataLine, you don't associate any sound data with the line yet, unlike opening a Clip. Instead, you just specify the format of the audio data you want to play. The system chooses a default buffer length.

You can also stipulate a certain buffer length in bytes, using this variant:

    void open(AudioFormat format, int bufferSize)
For consistency with similar methods, the buffersize argument is expressed in bytes, but it must correspond to an integral number of frames.

How would you select a buffer size? It depends on your program's needs.

To start with, shorter buffer sizes mean less latency. When you send new data, you hear it sooner. For some application programs, particularly highly interactive ones, this kind of responsiveness is important. For example, in a game, the onset of playback might need to be tightly synchronized with a visual event. Such programs might need a latency of less than 0.1 second. As another example, a conferencing application needs to avoid delays in both playback and capture. However, many application programs can afford a greater delay, up to a second or more, because it doesn't matter exactly when the sound starts playing, as long as the delay doesn't confuse or annoy the user. This might be the case for an application program that streams a large audio file using one-second buffers. The user probably won't care if playback takes a second to start, because the sound itself lasts so long and the experience isn't highly interactive.

On the other hand, shorter buffer sizes also mean a greater risk that you'll fail to write data fast enough into the buffer. If that happens, the audio data will contain discontinuities, which will probably be audible as clicks or breakups in the sound. Shorter buffer sizes also mean that your program has to work harder to keep the buffers filled, resulting in more intensive CPU usage. This can slow down the execution of other threads in your program, not to mention other programs.

So an optimal value for the buffer size is one that minimizes latency just to the degree that's acceptable for your application program, while keeping it large enough to reduce the risk of buffer underflow and to avoid unnecessary consumption of CPU resources. For a program like a conferencing application, delays are more annoying than low-fidelity sound, so a small buffer size is preferable. For streaming music, an initial delay is acceptable, but breakups in the sound are not. Thus for streaming music a larger buffer size—say, a second—is preferable. (Note that high sample rates make the buffers larger in terms of the number of bytes, which are the units for measuring buffer size in the DataLine API.)

Instead of using the open method described above, it's also possible to open a SourceDataLine using Line's open() method, without arguments. In this case, the line is opened with its default audio format and buffer size. However, you can't change these later. If you want to know the line's default audio format and buffer size, you can invoke DataLine's getFormat and getBufferSize methods, even before the line has ever been opened.

Starting and Stopping Playback

Once the SourceDataLine is open, you can start playing sound. You do this by invoking DataLine's start method, and then writing data repeatedly to the line's playback buffer.

The start method permits the line to begin playing sound as soon as there's any data in its buffer. You place data in the buffer by the following method:

    int write(byte[] b, int offset, int length)
The offset into the array is expressed in bytes, as is the array's length.

The line begins sending data as soon as possible to its mixer. When the mixer itself delivers the data to its target, the SourceDataLine generates a START event. (In a typical implementation of the Java Sound API, the delay between the moment that the source line delivers data to the mixer and the moment that the mixer delivers the data to its target is negligible—that is, much less than the time of one sample.) This START event gets sent to the line's listeners, as explained below under "Monitoring a Line's Status." The line is now considered active, so the isActive method of DataLine will return true. Notice that all this happens only once the buffer contains data to play, not necessarily right when the start method is invoked. If you invoked start on a new SourceDataLine but never wrote data to the buffer, the line would never be active and a START event would never be sent. (However, in this case, the isRunning method of DataLine would return true.)

So how do you know how much data to write to the buffer, and when to send the second batch of data? Fortunately, you don't need to time the second invocation of write to synchronize with the end of the first buffer! Instead, you can take advantage of the write method's blocking behavior:

  • The method returns as soon as the data has been written to the buffer. It doesn't wait until all the data in the buffer has finished playing. (If it did, you might not have time to write the next buffer without creating a discontinuity in the audio.)
  • It's all right to try to write more data than the buffer will hold. In this case, the method blocks (doesn't return) until all the data you requested has actually been placed in the buffer. In other words, one buffer's worth of your data at a time will be written to the buffer and played, until the remaining data all fits in the buffer, at which point the method returns. Whether or not the method blocks, it returns as soon as the last buffer's worth of data from this invocation can be written. Again, this means that your code will in all likelihood regain control before playback of the last buffer's worth of data has finished.
  • While in many contexts it is fine to write more data than the buffer will hold, if you want to be certain that the next write issued does not block, you can limit the number of bytes you write to the number that DataLine's available method returns.

Here's an example of iterating through chunks of data that are read from a stream, writing one chunk at a time to the SourceDataLine for playback:
// read chunks from a stream and write them to a source data
line
line.start();
while (total < totalToRead && !stopped)}
    numBytesRead = stream.read(myData, 0, numBytesToRead);
    if (numBytesRead == -1) break;
    total += numBytesRead;
    line.write(myData, 0, numBytesRead);

}
If you don't want the write method to block, you can first invoke the available method (inside the loop) to find out how many bytes can be written without blocking, and then limit the numBytesToRead variable to this number, before reading from the stream. In the example given, though, blocking won't matter much, since the write method is invoked inside a loop that won't complete until the last buffer is written in the final loop iteration. Whether or not you use the blocking technique, you'll probably want to invoke this playback loop in a separate thread from the rest of the application program, so that your program doesn't appear to freeze when playing a long sound. On each iteration of the loop, you can test whether the user has requested playback to stop. Such a request needs to set the stopped boolean, used in the code above, to true.

Since write returns before all the data has finished playing, how do you learn when the playback has actually completed? One way is to invoke the drain method of DataLine after writing the last buffer's worth of data. This method blocks until all the data has been played. When control returns to your program, you can free up the line, if desired, without fear of prematurely cutting off the playback of any audio samples:

line.write(b, offset, numBytesToWrite);
//this is the final invocation of write
line.drain();
line.stop();
line.close();
line = null;
You can intentionally stop playback prematurely, of course. For example, the application program might provide the user with a Stop button. Invoke DataLine's stop method to stop playback immediately, even in the middle of a buffer. This leaves any unplayed data in the buffer, so that if you subsequently invoke start, the playback resumes where it left off. If that's not what you want to happen, you can discard the data left in the buffer by invoking flush.

A SourceDataLine generates a STOP event whenever the flow of data has been stopped, whether this stoppage was initiated by the drain method, the stop method, or the flush method, or because the end of a playback buffer was reached before the application program invoked write again to provide new data. A STOP event doesn't necessarily mean that the stop method was invoked, and it doesn't necessarily mean that a subsequent invocation of isRunning will return false. It does, however, mean that isActive will return false. (When the start method has been invoked, the isRunning method will return true, even if a STOP event is generated, and it will begin to return false only once the stop method is invoked.) It's important to realize that START and STOP events correspond to isActive, not to isRunning.

Monitoring a Line's Status

Once you have started a sound playing, how do you find when it's finished? We saw one solution above—invoking the drain method after writing the last buffer of data—but that approach is applicable only to a SourceDataLine. Another approach, which works for both SourceDataLines and Clips, is to register to receive notifications from the line whenever the line changes its state. These notifications are generated in the form of LineEvent objects, of which there are four types: OPEN, CLOSE, START, and STOP.

Any object in your program that implements the LineListener interface can register to receive such notifications. To implement the LineListener interface, the object simply needs an update method that takes a LineEvent argument. To register this object as one of the line's listeners, you invoke the following Line method:

public void addLineListener(LineListener listener)

Whenever the line opens, closes, starts, or stops, it sends an update message to all its listeners. Your object can query the LineEvent that it receives. First you might invoke LineEvent.getLine to make sure the line that stopped is the one you care about. In the case we're discussing here, you want to know if the sound is finished, so you see whether the LineEvent is of type STOP. If it is, you might check the sound's current position, which is also stored in the LineEvent object, and compare it to the sound's length (if known) to see whether it reached the end and wasn't stopped by some other means (such as the user's clicking a Stop button, although you'd probably be able to determine that cause elsewhere in your code).

Along the same lines, if you need to know when the line is opened, closed, or started, you use the same mechanism. LineEvents are generated by different kinds of lines, not just Clips and SourceDataLines. However, in the case of a Port you can't count on getting an event to learn about a line's open or closed state. For example, a Port might be initially open when it's created, so you don't invoke the open method and the Port doesn't ever generate an OPEN event. (See "Selecting Input and Output Ports" in Chapter 3, "Accessing Audio System Resources.")

Synchronizing Playback on Multiple Lines

If you're playing back multiple tracks of audio simultaneously, you probably want to have them all start and stop at exactly the same time. Some mixers facilitate this behavior with their synchronize method, which lets you apply operations such as open, close, start, and stop to a group of data lines using a single command, instead of having to control each line individually. Furthermore, the degree of accuracy with which operations are applied to the lines is controllable.

To find out whether a particular mixer offers this feature for a specified group of data lines, invoke the Mixer interface's isSynchronizationSupported method:

boolean isSynchronizationSupported(Line[] lines,
  boolean  maintainSync)
The first parameter specifies a group of specific data lines, and the second parameter indicates the accuracy with which synchronization must be maintained. If the second parameter is true, the query is asking whether the mixer is capable of maintaining sample-accurate precision in controlling the specified lines at all times; otherwise, precise synchronization is required only during start and stop operations, not throughout playback.

Processing the Outgoing Audio

Some source data lines have signal-processing controls, such as gain, pan, reverb, and sample-rate controls. Similar controls, especially gain controls, might be present on the output ports as well. For more information on how to determine whether a line has such controls, and how to use them if it does, see Chapter 6, "Processing Audio with Controls."

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 5: Capturing Audio

Capturing refers to the process of obtaining a signal from outside the computer. A common application of audio capture is recording, such as recording the microphone input to a sound file. However, capturing isn't synonymous with recording, because recording implies that the application always saves the sound data that's coming in. An application that captures audio doesn't necessarily store the audio. Instead it might do something with the data as it's coming in—such as transcribe speech into text—but then discard each buffer of audio as soon as it's finished with that buffer.

As discussed in Chapter 2, "Overview of the Sampled Package," a typical audio-input system in an implementation of the Java Sound API consists of:

  1. An input port, such as a microphone port or a line-in port, which feeds its incoming audio data into:
  2. A mixer, which places the input data in:
  3. One or more target data lines, from which an application can retrieve the data.

    Commonly, only one input port can be open at a time, but an audio-input mixer that mixes audio from multiple ports is also possible. Another scenario consists of a mixer that has no ports but instead gets its audio input over a network.

    The TargetDataLine interface was introduced briefly under "The Line Interface Hierarchy" in Chapter 2, "Overview of the Sampled Package." TargetDataLine is directly analogous to the SourceDataLine interface, which was discussed extensively in Chapter 4, "Playing Back Audio." Recall that the SourceDataLine interface consists of:

  • A write method to send audio to the mixer
  • An available method to determine how much data can be written to the buffer without blocking

Similarly, TargetDataLine consists of:
  • A read method to get audio from the mixer
  • An available method to determine how much data can be read from the buffer without blocking

Setting Up a TargetDataLine

The process of obtaining a target data line was described in Chapter 3, "Accessing Audio System Resources," but we repeat it here for convenience:

TargetDataLine line;
DataLine.Info info = new DataLine.Info(TargetDataLine.class,
    format); // format is an AudioFormat object
if (!AudioSystem.isLineSupported(info)) {
    // Handle the error ...
}
// Obtain and open the line.
try {
    line = (TargetDataLine) AudioSystem.getLine(info);
    line.open(format);
} catch (LineUnavailableException ex) {
    // Handle the error ...
}
You could instead invoke Mixer's getLine method, rather than AudioSystem's.

As shown in this example, once you've obtained a target data line, you reserve it for your application's use by invoking the DataLine method open, exactly as was described in the case of a source data line in Chapter 4, "Playing Back Audio." The single-parameter version of the open method causes the line's buffer to have the default size. You can instead set the buffer size according to your application's needs by invoking the two-parameter version:

    void open(AudioFormat format, int bufferSize)
When choosing a buffer size, keep in mind the tradeoff between the delays incurred by long buffers, on the one hand, and the risk of discontinuities in the audio if the buffers are so short that you can't retrieve the data fast enough, on the other hand. When capturing audio, you risk data overflow if you don't pull data from the filled buffers fast enough. If overflow occurs, some of the captured data will be discarded, which will probably cause audible clicks and skips in the sound. This is the opposite situation from playback, where you risk data underflow, which can result in gaps in the sound. (See Chapter 4, "Playing Back Audio," for more on choosing buffer sizes.)

Reading the Data from the TargetDataLine

Once the line is open, it is ready to start capturing data, but it isn't active yet. To actually commence the audio capture, use the DataLine method start. This begins delivering input audio data to the line's buffer for your application to read. Your application should invoke start only when it's ready to begin reading from the line; otherwise a lot of processing is wasted on filling the capture buffer, only to have it overflow (that is, discard data).

To start retrieving data from the buffer, invoke TargetDataLine's read method:

int read(byte[] b, int offset, int length)
This method attempts to read length bytes of data into the array b, starting at the byte position offset in the array. The method returns the number of bytes actually read.

As with SourceDataLine's write method, you can request more data than actually fits in the buffer, because the method blocks until the requested amount of data has been delivered, even if you request many buffers' worth of data.

To avoid having your application hang during recording, you can invoke the read method within a loop, until you've retrieved all the audio input, as in this example:

// Assume that the TargetDataLine, line, has already
// been obtained and opened.
ByteArrayOutputStream out  = new ByteArrayOutputStream();
int numBytesRead;
byte[] data = new byte[line.getBufferSize() / 5];

// Begin audio capture.
line.start();

// Here, stopped is a global boolean set by another thread.
while (!stopped) {
   // Read the next chunk of data from the TargetDataLine.
   numBytesRead =  line.read(data, 0, data.length);
   // Save this chunk of data.
   out.write(data, 0, numBytesRead);
}
Notice that in this example, the size of the byte array into which the data is read is set to be one-fifth the size of the line's buffer. If you instead make it as big as the line's buffer and try to read the entire buffer, you need to be very exact in your timing, because data will be dumped if the mixer needs to deliver data to the line while you are reading from it. By using some fraction of the line's buffer size, as shown here, your application will be more successful in sharing access to the line's buffer with the mixer.

The read method of TargetDataLine takes three arguments: a byte array, an offset into the array, and the number of bytes of input data that you would like to read. In this example, the third argument is simply the length of your byte array. The read method returns the number of bytes that were actually read into your array.

Typically, you read data from the line in a loop, as in this example. Within the while loop, each chunk of retrieved data is processed in whatever way is appropriate for the application—here, it's written to a ByteArrayOutputStream. Not shown here is the use of a separate thread to set the boolean stopped, which terminates the loop. This boolean's value might be set to true when the user clicks a Stop button, and also when a listener receives a CLOSE or STOP event from the line. The listener is necessary for CLOSE events and recommended for STOP events. Otherwise, if the line gets stopped somehow without stopped being set to true, the while loop will capture zero bytes on each iteration, running fast and wasting CPU cycles. A more thorough code example would show the loop being re-entered if capture becomes active again.

As with a source data line, it's possible to drain or flush a target data line. For example, if you're recording the input to a file, you'll probably want to invoke the drain method when the user clicks a Stop button. The drain method will cause the mixer's remaining data to get delivered to the target data line's buffer. If you don't drain the data, the captured sound might seem to be truncated prematurely at the end.

There might be some cases where you instead want to flush the data. In any case, if you neither flush nor drain the data, it will be left in the mixer. This means that when capture recommences, there will be some leftover sound at the beginning of the new recording, which might be undesirable. It can be useful, then, to flush the target data line before restarting the capture.

Monitoring the Line's Status

Because the TargetDataLine interface extends DataLine, target data lines generate events in the same way source data lines do. You can register an object to receive events whenever the target data line opens, closes, starts, or stops. For more information, see "Monitoring the Line's Status" in Chapter 4, "Playing Back Audio."

Processing the Incoming Audio

Like some source data lines, some mixers' target data lines have signal-processing controls, such as gain, pan, reverb, or sample-rate controls. The input ports might have similar controls, especially gain controls. For more information on how to determine whether a line has such controls, and how to use them if it does, see Chapter 6, "Processing Audio with Controls."

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 6: Processing Audio with Controls

Previous chapters have discussed how to play or capture audio samples. The implicit goal has been to deliver samples as faithfully as possible, without modification (other than possibly mixing the samples with those from other audio lines). Sometimes, however, you want to be able to modify the signal. The user might want it to sound louder, quieter, fuller, more reverberant, higher or lower in pitch, and so on. This chapter discusses the Java Sound API features that provide these kinds of signal processing.

There are two ways to apply signal processing:

  • You can use any processing supported by the mixer or its component lines, by querying for Control objects and then setting the controls as the user desires. Typical controls supported by mixers and lines include gain, pan, and reverberation controls.
  • If the kind of processing you need isn't provided by the mixer or its lines, your program can operate directly on the audio bytes, manipulating them as desired.

This chapter discusses the first technique in greater detail, because there is no special API for the second technique.

Introduction to Controls

A mixer can have various sorts of signal-processing controls on some or all of its lines. For example, a mixer used for audio capture might have an input port with a gain control, and target data lines with gain and pan controls. A mixer used for audio playback might have sample-rate controls on its source data lines. In each case, the controls are all accessed through methods of the Line interface.

Because the Mixer interface extends Line, the mixer itself can have its own set of controls. These might serve as master controls affecting all the mixer's source or target lines. For example, the mixer might have a master gain control whose value in decibels is added to the values of individual gain controls on its target lines.

Others of the mixer's own controls might affect a special line, neither a source nor a target, that the mixer uses internally for its processing. For example, a global reverb control might choose the sort of reverberation to apply to a mixture of the input signals, and this "wet" (reverberated) signal would get mixed back into the "dry" signal before delivery to the mixer's target lines.

If the mixer or any of its lines have controls, you might wish to expose the controls via graphical objects in your program's user interface, so that the user can adjust the audio characteristics as desired. The controls are not themselves graphical; they just allow you to retrieve and change their settings. It's up to you to decide what sort of graphical representations (sliders, buttons, etc.), if any, to use in your program.

All controls are implemented as concrete subclasses of the abstract class Control. Many typical audio-processing controls can be described by abstract subclasses of Control based on a data type (such as boolean, enumerated, or float). Boolean controls, for example, represent binary-state controls, such as on/off controls for mute or reverb. Float controls, on the other hand, are well suited to represent continuously variable controls, such as pan, balance, or volume.

The Java Sound API specifies the following abstract subclasses of Control:

  • BooleanControl—represents a binary-state (true or false) control. For example, mute, solo, and on/off switches would be good candidates for BooleanControls.
  • FloatControl—data model providing control over a range of floating-point values. For example, volume and pan are FloatControls that could be manipulated via a dial or slider.
  • EnumControl—offers a choice from a set of objects. For example, you might associate a set of buttons in the user interface with an EnumControl to select one of several preset reverberation settings.
  • CompoundControl—provides access to a collection of related items, each of which is itself an instance of a Control subclass. CompoundControls represent multi-control modules such as graphic equalizers. (A graphic equalizer would typically be depicted by a set of sliders, each affecting a FloatControl.)

Each subclass of Control above has methods appropriate for its underlying data type. Most of the classes include methods that set and get the control's current value(s), get the control's label(s), and so on.

Of course, each class has methods that are particular to it and the data model represented by the class. For example, EnumControl has a method that lets you get the set of its possible values, and FloatControl permits you to get its minimum and maximum values, as well as the precision (increment or step size) of the control.

Each subclass of Control has a corresponding Control.Type subclass, which includes static instances that identify specific controls.

The following table shows each Control subclass, its corresponding Control.Type subclass, and the static instances that indicate specific kinds of controls:

Control | Control.Type | Control.Type instances
BooleanControl | BooleanControl.Type | MUTE Mute status of line APPLY_REVERB Reverberation on/off
CompoundControl | CompoundControl.Type | (none)
EnumControl | EnumControl.Type | REVERB Access to reverb settings (each is an instance of ReverbType)
FloatControl | FloatControl.Type | AUX_RETURN Auxiliary return gain on a line AUX_SEND Auxiliary send gain on a line BALANCE Left-right volume balance MASTER_GAIN Overall gain on a line PAN Left-right position REVERB_RETURN Post-reverb gain on a line REVERB_SEND Pre-reverb gain on a line SAMPLE_RATE Playback sample rate VOLUME Volume on a line

An implementation of the Java Sound API can provide any or all of these control types on its mixers and lines. It can also supply additional control types not defined in the Java Sound API. Such control types could be implemented via concrete subclasses of any of these four abstract subclasses, or via additional Control subclasses that don't inherit from any of these four abstract subclasses. An application program can query each line to find what controls it supports.

Getting a Line that Has the Desired Controls

In many cases, an application program will simply display whatever controls happen to be supported by the line in question. If the line doesn't have any controls, so be it. But what if it's important to find a line that has certain controls? In that case, you can use a Line.Info to obtain a line that has the right characteristics, as described under "Getting a Line of a Desired Type" in Chapter 3, "Accessing Audio System Resources."

For example, suppose you prefer an input port that lets the user set the volume of the sound input. The following code excerpt shows how one might query the default mixer to determine whether it has the desired port and control:

Port lineIn;
FloatControl volCtrl;
try {
  mixer = AudioSystem.getMixer(null);
  lineIn = (Port)mixer.getLine(Port.Info.LINE_IN);
  lineIn.open();
  volCtrl = (FloatControl) lineIn.getControl(
      FloatControl.Type.VOLUME);
  // Assuming getControl call succeeds,
  // we now have our LINE_IN VOLUME control.
} catch (Exception e) {
  System.out.println("Failed trying to find LINE_IN"
    + " VOLUME control: exception = " + e);
}
if (volCtrl != null)
  // ...

Getting the Controls from the Line

An application program that needs to expose controls in its user interface might simply query the available lines and controls, and then display an appropriate user-interface element for every control on every line of interest. In such a case, the program's only mission is to provide the user with "handles" on the control; not to know what those controls do to the audio signal. As long as the program knows how to map a line's controls into user-interface elements, the Java Sound API architecture of Mixer, Line, and Control will generally take care of the rest.

For example, suppose your program plays back sound. You're using a SourceDataLine, which you've obtained as described under "Getting a Line of a Desired Type" in Chapter 3, "Accessing Audio System Resources." You can access the line's controls by invoking the Line method:

Control[] getControls()
Then, for each of the controls in this returned array, you then use the following Control method to get the control's type:
Control.Type getType()
Knowing the specific Control.Type instance, your program can display a corresponding user-interface element. Of course, choosing "a corresponding user-interface element" for a specific Control.Type depends on the approach taken by your program. On the one hand, you might use the same kind of element to represent all Control.Type instances of the same class. This would require you to query the class of the Control.Type instance using, for example, the Object.getClass method. Let's say the result matched BooleanControl.Type. In this case, your program might display a generic checkbox or toggle button, but if its class matched FloatControl.Type, then you might display a graphic slider.

On the other hand, your program might distinguish between different types of controls—even those of the same class—and use a different user-interface element for each one. This would require you to test the instance returned by Control's getType method. Then if, for example, the type matched BooleanControl.Type.APPLY_REVERB, your program might display a checkbox; while if the type matched BooleanControl.Type.MUTE, you might instead display a toggle button.

Using a Control to Change the Audio Signal

Note

The current implementation requires that to change the value of a Control its corresponding Line must be open.

Now that you know how to access a control and determine its type, this section will describe how to use Controls to change aspects of the audio signal. This section doesn't cover every available control; rather, it provides a few examples in this area to show you how to get started. These example include:

  • Controlling a line's mute state
  • Changing a line's volume
  • Selecting among various reverberation presets

Suppose that your program has accessed all of its mixers, their lines and the controls on those lines, and that it has a data structure to manage the logical associations between the controls and their corresponding user-interface elements. Then, translating the user's manipulations of those controls into the corresponding Control methods becomes a fairly straightforward matter.

The following subsections describe some of the methods that must be invoked to affect the changes to specific controls.

Controlling a Line's Mute State

Controlling the mute state of any line is simply a matter of calling the following BooleanControl method:

void setValue(boolean value)
(Presumably, the program knows, by referring to its control-management data structures, that the mute is an instance of a BooleanControl.) To mute the signal that's passing through the line, the program invokes the method above, specifying true as the value. To turn muting off, permitting the signal to flow through the line, the program invokes the method with the parameter set to false.

Changing a Line's Volume

Let's assume your program associates a particular graphic slider with a particular line's volume control. The value of a volume control (i.e., FloatControl.Type.VOLUME) is set using the following FloatControl method:

void setValue(float newValue)
Detecting that the user moved the slider, the program gets the slider's current value and passes it, as the parameter newValue, to the method above. This changes the volume of the signal flowing though the line that "owns" the control.

Selecting among Various Reverberation Presets

Let's suppose that our program has a mixer with a line that has a control of type EnumControl.Type.REVERB. Calling the EnumControl method:

java.lang.Objects[] getValues()
on that control produces an array of ReverbType objects. If desired, the particular parameter settings of each of these objects can be accessed using the following ReverbType methods:
int getDecayTime()
int getEarlyReflectionDelay()
float getEarlyReflectionIntensity()
int getLateReflectionDelay()
float getLateReflectionIntensity()
For example, if a program only wants a single reverb setting that sounds like a cavern, it can iterate over the ReverbType objects until it finds one for which getDecayTime returns a value greater than 2000. For a thorough explanation of these methods, including a table of representative return values, see the API reference documentation for javax.sound.sampled.ReverbType.

Typically, though, a program will create a user-interface element, for example, a radio button, for each of the ReverbType objects within the array returned by the getValues method. When the user clicks on one of these radio buttons, the program invokes the EnumControl method

void setValue(java.lang.Object value)
where value is set to the ReverbType that corresponds to the newly engaged button. The audio signal sent through the line that "owns" this EnumControl will then be reverberated according to the parameter settings that constitute the control's current ReverbType (i.e., the particular ReverbType specified in the value argument of the setValue method).

So, from our application program's perspective, enabling a user to move from one reverberation preset (i.e., ReverbType) to another is simply a matter of connecting each element of the array returned by getValues to a distinct radio button.

Manipulating the Audio Data Directly

The Control API allows an implementation of the Java Sound API, or a third-party provider of a mixer, to supply arbitrary sorts of signal processing through controls. But what if no mixer offers the kind of signal processing you need? It will take more work, but you might be able to implement the signal processing in your program. Because the Java Sound API gives you access to the audio data as an array of bytes, you can alter these bytes in any way you choose.

If you're processing incoming sound, you can read the bytes from a TargetDataLine and then manipulate them. An algorithmically trivial example that can yield sonically intriguing results is to play a sound backwards by arranging its frames in reverse order. This trivial example may not be of much use for your program, but there are numerous sophisticated digital signal processing (DSP) techniques that might be more appropriate. Some examples are equalization, dynamic-range compression, peak limiting, and time stretching or compression, as well as special effects such as delay, chorus, flanging, distortion, and so on.

To play back processed sound, you can place your manipulated array of bytes into a SourceDataLine or Clip. Of course, the array of bytes need not be derived from an existing sound. You can synthesize sounds from scratch, although this requires some knowledge of acoustics or else access to sound-synthesis functions. For either processing or synthesis, you may want to consult an audio DSP textbook for the algorithms in which you're interested, or else import a third-party library of signal-processing functions into your program. For playback of synthesized sound, consider whether the Synthesizer API in the javax.sound.midi package meets your needs instead. (See Chapter 12, "Synthesizing Sound.")

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 7: Using Files and Format Converters

Most application programs that deal with sound need to read sound files or audio streams. This is common functionality, regardless of what the program may subsequently do with the data it reads (such as play, mix, or process it). Similarly, many programs need to write sound files (or streams). In some cases, the data that has been read (or that will be written) needs to be converted to a different format.

As was briefly mentioned in Chapter 3, "Accessing Audio System Resources," the Java Sound API provides application developers with various facilities for file input/output and format translations. Application programs can read, write, and translate between a variety of sound file formats and audio data formats.

Chapter 2, "Overview of the Sampled Package," introduced the main classes related to sound files and audio data formats. As a review:

  • A stream of audio data, as might be read from or written to a file, is represented by an AudioInputStream object. (AudioInputStream inherits from java.io.InputStream.)
  • The format of this audio data is represented by an AudioFormat object.

    This format specifies how the audio samples themselves are arranged, but not the structure of a file that they might be stored in. In other words, an AudioFormat describes "raw" audio data, such as the system might hand your program after capturing it from a microphone input or after parsing it from a sound file. An AudioFormat includes such information as the encoding, the byte order, the number of channels, the sampling rate, and the number of bits per sample.

  • There are several well-known, standard formats for sound files, such as WAV, AIFF, or AU. The different types of sound file have different structures for storing audio data as well as for storing descriptive information about the audio data. A sound file format is represented in the Java Sound API by an AudioFileFormat object. The AudioFileFormat includes an AudioFormat object to describe the format of the audio data stored in the file, and also includes information about the file type and the length of the data in the file.
  • The AudioSystem class provides methods for (1) storing a stream of audio data from an AudioInputStream into an audio file of a particular type (in other words, writing a file), (2) extracting a stream of audio bytes (an AudioInputStream) from an audio file (in other words, reading a file), and (3) converting audio data from one data format to another. The present chapter, which is divided into three sections, explains these three kinds of activity.

Note that an implementation of the Java Sound API does not necessarily provide comprehensive facilities for reading, writing, and converting audio in different data and file formats. It might support only the most common data and file formats. However, service providers can develop and distribute conversion services that extend this set, as outlined in Chapter 14, "Providing Sampled-Audio Services." The AudioSystem class supplies methods that allow application programs to learn what conversions are available, as described later in this chapter under "Converting File and Data Formats."

Reading Sound Files

The AudioSystem class provides two types of file-reading services:

  • Information about the format of the audio data stored in the sound file
  • A stream of formatted audio data that can be read from the sound file

The first of these is given by three variants of the getAudioFileFormat method:

static AudioFileFormat getAudioFileFormat (java.io.File file)
static AudioFileFormat getAudioFileFormat(java.io.InputStream stream)
static AudioFileFormat getAudioFileFormat (java.net.URL url)

As mentioned above, the returned AudioFileFormat object tells you the file type, the length of the data in the file, encoding, the byte order, the number of channels, the sampling rate, and the number of bits per sample.

The second type of file-reading functionality is given by these AudioSystem methods

static AudioInputStream getAudioInputStream (java.io.File file)
static AudioInputStream getAudioInputStream (java.net.URL url)
static AudioInputStream getAudioInputStream (java.io.InputStream stream)

These methods give you an object (an AudioInputStream) that lets you read the file's audio data, using one of the read methods of AudioInputStream. We'll see an example momentarily.

Suppose you're writing a sound-editing application that allows the user to load sound data from a file, display a corresponding waveform or spectrogram, edit the sound, play back the edited data, and save the result in a new file. Or perhaps your program will read the data stored in a file, apply some kind of signal processing (such as an algorithm that slows the sound down without changing its pitch), and then play the processed audio. In either case, you need to get access to the data contained in the audio file. Assuming that your program provides some means for the user to select or specify an input sound file, reading that file's audio data involves three steps:

  2. Get an AudioInputStream object from the file.
  3. Create a byte array in which you'll store successive chunks of data from the file.
  4. Repeatedly read bytes from the audio input stream into the array. On each iteration, do something useful with the bytes in the array (for example, you might play them, filter them, analyze them, display them, or write them to another file).

The following code example outlines these steps.
int totalFramesRead = 0;
File fileIn = new File(somePathName);
// somePathName is a pre-existing string whose value was
// based on a user selection.
try {
  AudioInputStream audioInputStream =
    AudioSystem.getAudioInputStream(fileIn);
  int bytesPerFrame =
    audioInputStream.getFormat().getFrameSize();
  // Set an arbitrary buffer size of 1024 frames.
  int numBytes = 1024 * bytesPerFrame;
  byte[] audioBytes = new byte[numBytes];
  try {
    int numBytesRead = 0;
    int numFramesRead = 0;
    // Try to read numBytes bytes from the file.
    while ((numBytesRead =
      audioInputStream.read(audioBytes)) != -1) {
      // Calculate the number of frames actually read.
      numFramesRead = numBytesRead / bytesPerFrame;
      totalFramesRead += numFramesRead;
      // Here, do something useful with the audio data that's
      // now in the audioBytes array...
    }
  } catch (Exception ex) {
    // Handle the error...
  }
} catch (Exception e) {
  // Handle the error...
}
Let's take a look at what's happening in the above code sample. First, the outer try clause instantiates an AudioInputStream object through the call to the AudioSystem.getAudioInputStream(File) method. This method transparently performs all of the testing required to determine whether the specified file is actually a sound file of a type that is supported by the Java Sound API. If the file being inspected (fileIn in this example) is not a sound file, or is a sound file of some unsupported type, an UnsupportedAudioFileException exception is thrown. This behavior is convenient, in that the application programmer need not be bothered with testing file attributes, nor with adhering to any file-naming conventions. Instead, the getAudioInputStream method takes care of all the low-level parsing and verification that is required to validate the input file.

The outer try clause then creates a byte array, audioBytes, of an arbitrary fixed length. We make sure that its length in bytes equals an integral number of frames, so that we won't end up reading only part of a frame or, even worse, only part of a sample. This byte array will serve as a buffer to temporarily hold a chunk of audio data as it's read from the stream. If we knew we would be reading nothing but very short sound files, we could make this array the same length as the data in the file, by deriving the length in bytes from the length in frames, as returned by AudioInputStream's getFrameLength method. (Actually, we'd probably just use a Clip object instead.) But to avoid running out of memory in the general case, we instead read the file in chunks, one buffer at a time.

The inner try clause contains a while loop, which is where we read the audio data from the AudioInputStream into the byte array. You should add code in this loop to handle the audio data in this array in whatever way is appropriate for your program's needs. If you're applying some kind of signal processing to the data, you'll probably need to query the AudioInputStream's AudioFormat further, to learn the number of bits per sample and so on.

Note that the method AudioInputStream.read(byte[]) returns the number of bytes read—not the number of samples or frames. This method returns -1 when there's no more data to read. Upon detecting this condition, we break from the while loop.

Writing Sound Files

The previous section described the basics of reading a sound file, using specific methods of the AudioSystem and AudioInputStream classes. This section describes how to write audio data out to a new file.

The following AudioSystem method creates a disk file of a specified file type. The file will contain the audio data that's in the specified AudioInputStream:

static int write(AudioInputStream in,
  AudioFileFormat.Type fileType, File out)
Note that the second argument must be one of the file types supported by the system (for example, AU, AIFF, or WAV), otherwise the write method will throw an IllegalArgumentException. To avoid this, you can test whether or not a particular AudioInputStream may be written to a particular type of file, by invoking this AudioSystem method:
static boolean isFileTypeSupported
  (AudioFileFormat.Type fileType, AudioInputStream stream)
which will return true only if the particular combination is supported.

More generally, you can learn what types of file the system can write by invoking one of these AudioSystem methods:

static AudioFileFormat.Type[] getAudioFileTypes()
static AudioFileFormat.Type[]
  getAudioFileTypes(AudioInputStream stream)
The first of these returns all the types of file that the system can write, and the second returns only those that the system can write from the given audio input stream.

The following excerpt demonstrates one technique for creating an output file from an AudioInputStream using the write method mentioned above.

File fileOut = new File(someNewPathName);
AudioFileFormat.Type fileType = fileFormat.getType();
if (AudioSystem.isFileTypeSupported(fileType,
    audioInputStream)) {
  AudioSystem.write(audioInputStream, fileType, fileOut);
}
The first statement above, creates a new File object, fileOut, with a user- or program-specified pathname. The second statement gets a file type from a pre-existing AudioFileFormat object called fileFormat, which might have been obtained from another sound file, such as the one that was read in the "Reading Sound Files" section of this chapter. (You could instead supply whatever supported file type you want, instead of getting the file type from elsewhere. For example, you might delete the second statement and replace the other two occurrences of fileType in the code above with AudioFileFormat.Type.WAVE.)

The third statement tests whether a file of the designated type can be written from a desired AudioInputStream. Like the file format, this stream might have been derived from the sound file previously read. (If so, presumably you've processed or altered its data in some way, because otherwise there are easier ways to simply copy a file.) Or perhaps the stream contains bytes that have been freshly captured from the microphone input.

Finally, the stream, file type, and output file are passed to the AudioSystem.write method, to accomplish the goal of writing the file.

Converting File and Data Formats

Recall from the section "What Is Formatted Audio Data?" in Chapter 2, "Overview of the Sampled Package," that the Java Sound API distinguishes between audio file formats and audio data formats. The two are more or less independent. Roughly speaking, the data format refers to the way in which the computer represents each raw data point (sample), while the file format refers to the organization of a sound file as stored on a disk. Each sound file format has a particular structure that defines, for example, the information stored in the file's header. In some cases, the file format also includes structures that contain some form of meta-data, in addition to the actual "raw" audio samples. The remainder of this chapter examines methods of the Java Sound API that enable a variety of file-format and data-format conversions.

Converting from One File Format to Another

This section covers the fundamentals of converting audio file types in the Java Sound API. Once again we pose a hypothetical program whose purpose, this time, is to read audio data from an arbitrary input file and write it into a file whose type is AIFF. Of course, the input file must be of a type that the system is capable of reading, and the output file must be of a type that the system is capable of writing. (In this example, we assume that the system is capable of writing AIFF files.) The example program doesn't do any data format conversion. If the input file's data format can't be represented as an AIFF file, the program simply notifies the user of that problem. On the other hand, if the input sound file is an already an AIFF file, the program notifies the user that there is no need to convert it.

The following function implements the logic just described:

public void ConvertFileToAIFF(String inputPath,
  String outputPath) {
  AudioFileFormat inFileFormat;
  File inFile;
  File outFile;
  try {
    inFile = new File(inputPath);
    outFile = new File(outputPath);
  } catch (NullPointerException ex) {
    System.out.println("Error: one of the
      ConvertFileToAIFF" +" parameters is null!");
    return;
  }
  try {
    // query file type
    inFileFormat = AudioSystem.getAudioFileFormat(inFile);
    if (inFileFormat.getType() != AudioFileFormat.Type.AIFF)
    {
      // inFile is not AIFF, so let's try to convert it.
      AudioInputStream inFileAIS =
        AudioSystem.getAudioInputStream(inFile);
      inFileAIS.reset(); // rewind
      if (AudioSystem.isFileTypeSupported(
             AudioFileFormat.Type.AIFF, inFileAIS)) {
         // inFileAIS can be converted to AIFF.
         // so write the AudioInputStream to the
         // output file.
         AudioSystem.write(inFileAIS,
           AudioFileFormat.Type.AIFF, outFile);
         System.out.println("Successfully made AIFF file, "
           + outFile.getPath() + ", from "
           + inFileFormat.getType() + " file, " +
           inFile.getPath() + ".");
         inFileAIS.close();
         return; // All done now
       } else
         System.out.println("Warning: AIFF conversion of "
           + inFile.getPath()
           + " is not currently supported by AudioSystem.");
    } else
      System.out.println("Input file " + inFile.getPath() +
          " is AIFF." + " Conversion is unnecessary.");
  } catch (UnsupportedAudioFileException e) {
    System.out.println("Error: " + inFile.getPath()
        + " is not a supported audio file type!");
    return;
  } catch (IOException e) {
    System.out.println("Error: failure attempting to read "
      + inFile.getPath() + "!");
    return;
  }
}

As mentioned, the purpose of this example function, ConvertFileToAIFF, is to query an input file to determine whether it's an AIFF sound file, and if it isn't, to try to convert it to one, producing a new copy whose pathname is specified by the second argument. (As an exercise, you might try making this function more general, so that instead of always converting to AIFF, the function converts to the file type specified by a new function argument.) Note that the audio data format of the copy—that is, the new file-mimics the audio data format of original input file.

Most of this function is self-explanatory and is not specific to the Java Sound API. There are, however, a few Java Sound API methods used by the routine that are crucial for sound file-type conversions. These method invocations are all found in the second try clause, above, and include the following:

  • AudioSystem.getAudioFileFormat: used here to determine whether the input file is already an AIFF type. If so, the function quickly returns; otherwise the conversion attempt proceeds.
  • AudioSystem.isFileTypeSupported: Indicates whether the system can write a file of the specified type that contains audio data from the specified AudioInputStream. In our example, this method returns true if the specified audio input file can be converted to AIFF audio file format. If AudioFileFormat.Type.AIFF isn't supported, ConvertFileToAIFF issues a warning that the input file can't be converted, then returns.
  • AudioSystem.write: used here to write the audio data from the AudioInputStream inFileAIS to the output file outFile.

The second of these methods, isFileTypeSupported, helps to determine, in advance of the write, whether a particular input sound file can be converted to a particular output sound file type. In the next section we will see how, with a few modifications to this ConvertFileToAIFF sample routine, we can convert the audio data format, as well as the sound file type.

Converting Audio between Different Data Formats

The previous section showed how to use the Java Sound API to convert a file from one file format (that is, one type of sound file) to another. This section explores some of the methods that enable audio data format conversions.

In the previous section, we read data from a file of an arbitrary type, and saved it in an AIFF file. Note that although we changed the type of file used to store the data, we didn't change the format of the audio data itself. (Most common audio file types, including AIFF, can contain audio data of various formats.) So if the original file contained CD-quality audio data (16-bit sample size, 44.1-kHz sample rate, and two channels), so would our output AIFF file.

Now suppose that we want to specify the data format of the output file, as well as the file type. For example, perhaps we are saving many long files for use on the Internet, and are concerned about the amount of disk space and download time required by our files. We might choose to create smaller AIFF files that contain lower-resolution data-for example, data that has an 8-bit sample size, an 8-kHz sample rate, and a single channel.

Without going into as much coding detail as before, let's explore some of the methods used for data format conversion, and consider the modifications that we would need to make to the ConvertFileToAIFF function to accomplish the new goal.

The principal method for audio data conversion is, once again, found in the AudioSystem class. This method is a variant of getAudioInputStream:

AudioInputStream getAudioInputStream(AudioFormat
    format, AudioInputStream stream)
This function returns an AudioInputStream that is the result of converting the AudioInputStream, stream, using the indicated AudioFormat, format. If the conversion isn't supported by AudioSystem, this function throws an IllegalArgumentException.

To avoid that, we can first check whether the system can perform the required conversion by invoking this AudioSystem method:

boolean isConversionSupported(AudioFormat targetFormat,
    AudioFormat sourceFormat)
In this case, we'd pass stream.getFormat() as the second argument.

To create a specific AudioFormat object, we use one of the two AudioFormat constructors shown below, either

 AudioFormat(float sampleRate, int sampleSizeInBits,
    int channels, boolean signed, boolean bigEndian)
which constructs an AudioFormat with a linear PCM encoding and the given parameters, or
AudioFormat(AudioFormat.Encoding encoding,
    float sampleRate, int sampleSizeInBits, int channels,
    int frameSize, float frameRate, boolean bigEndian)
which also constructs an AudioFormat, but lets you specify the encoding, frame size, and frame rate, in addition to the other parameters.

Now, armed with the methods above, let's see how we might extend our ConvertFileToAIFF function to perform the desired "low-res" audio data format conversion. First, we would construct an AudioFormat object describing the desired output audio data format. The following statement would suffice and could be inserted near the top of the function:

AudioFormat outDataFormat = new AudioFormat((float) 8000.0,
(int) 8, (int) 1, true, false);
Since the AudioFormat constructor above is describing a format with 8-bit samples, the last parameter to the constructor, which specifies whether the samples are big or little endian, is irrelevant. (Big versus little endian is only an issue if the sample size is greater than a single byte.)

The following example shows how we would use this new AudioFormat to convert the AudioInputStream, inFileAIS, that we created from the input file:

AudioInputStream lowResAIS;
  if (AudioSystem.isConversionSupported(outDataFormat,
    inFileAIS.getFormat())) {
    lowResAIS = AudioSystem.getAudioInputStream
      (outDataFormat, inFileAIS);
  }
It wouldn't matter too much where we inserted this code, as long as it was after the construction of inFileAIS. Without the isConversionSupported test, the call would fail and throw an IllegalArgumentException if the particular conversion being requested was unsupported. (In this case, control would transfer to the appropriate catch clause in our function.)

So by this point in the process, we would have produced a new AudioInputStream, resulting from the conversion of the original input file (in its AudioInputStream form) to the desired low-resolution audio data format as defined by outDataFormat.

The final step to produce the desired low-resolution, AIFF sound file would be to replace the AudioInputStream parameter in the call to AudioSystem.write (that is, the first parameter) with our converted stream, lowResAIS, as follows:

AudioSystem.write(lowResAIS, AudioFileFormat.Type.AIFF,
  outFile);
These few modifications to our earlier function produce something that converts both the audio data and the file format of any specified input file, assuming of course that the system supports the conversion.

Learning What Conversions Are Available

Several AudioSystem methods test their parameters to determine whether the system supports a particular data format conversion or file-writing operation. (Typically, each method is paired with another that performs the data conversion or writes the file.) One of these query methods, AudioSystem.isFileTypeSupported, was used in our example function, ConvertFileToAIFF, to determine whether the system was capable of writing the audio data to an AIFF file. A related AudioSystem method, getAudioFileTypes(AudioInputStream), returns the complete list of supported file types for the given stream, as an array of AudioFileFormat.Type instances. The method:

boolean isConversionSupported(AudioFormat.Encoding encoding,
                              AudioFormat format)
is used to determine whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified audio format. Similarly, the method:
boolean isConversionSupported(AudioFormat newFormat,
                              AudioFormat oldFormat)

tells us whether an AudioInputStream with the specified audio format, newFormat, can be obtained through the conversion of an AudioInputStream that has the audio format oldFormat. (This method was invoked in the previous section's code excerpt that created a low-resolution audio input stream, lowResAIS.)

These format-related queries help prevent errors when attempting to perform format conversions with the Java Sound API.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 8: Overview of the MIDI Package

Chapter 1,"Introduction to Java Sound," gave a glimpse into the MIDI capabilities of the Java Sound API. The present chapter assumes you've read Chapter 1. The discussion here provides a more detailed introduction to the Java Sound API's MIDI architecture, which is accessed through the javax.sound.midi package. Some basic features of MIDI itself are explained, as a refresher or introduction, to place the Java Sound API's MIDI features in context. The chapter then goes on to discuss the Java Sound API's approach to MIDI, as a preparation for the programming tasks that are explained in subsequent chapters. This chapter's discussion of the MIDI API is divided into two main areas: data and devices.

A MIDI Refresher: Wires and Files

The Musical Instrument Digital Interface (MIDI) standard defines a communication protocol for electronic music devices, such as electronic keyboard instruments and personal computers. MIDI data can be transmitted over special cables during a live performance, and can also be stored in a standard type of file for later playback or editing.

This section reviews some MIDI basics, without reference to the Java Sound API. The discussion is intended as a refresher for readers acquainted with MIDI, and as a brief introduction for those who are not, to provide background for the subsequent discussion of the Java Sound API's MIDI package. If you have a thorough understanding of MIDI, you can safely skip this section. Before writing substantial MIDI applications, programmers who are unfamiliar with MIDI will probably need a fuller description of MIDI than can be included in this programmer's guide. See the Complete MIDI 1.0 Detailed Specification, which is available only in hard copy from http://www.midi.org (although you might find paraphrased or summarized versions on the Web).

MIDI is both a hardware specification and a software specification. To understand MIDI's design, it helps to understand its history. MIDI was originally designed for passing musical events, such as key depressions, between electronic keyboard instruments such as synthesizers. (As mentioned in Chapter 1, MIDI data consists primarily of control events that communicate a musician's gestures. MIDI data doesn't contain the audio that results from these events.) Hardware devices known as sequencers stored sequences of notes that could control a synthesizer, allowing musical performances to be recorded and subsequently played back. Later, hardware interfaces were developed that connected MIDI instruments to a computer's serial port, allowing sequencers to be implemented in software. More recently, computer sound cards have incorporated hardware for MIDI I/O and for synthesizing musical sound. Today, many users of MIDI deal only with sound cards, never connecting to external MIDI devices. CPUs have become fast enough that synthesizers, too, can be implemented in software. A sound card is needed only for audio I/O and, in some applications, for communicating with external MIDI devices.

The brief hardware portion of the MIDI specification prescribes the pinouts for MIDI cables and the jacks into which these cables are plugged. This portion need not concern us. Because devices that originally required hardware, such as sequencers and synthesizers, are now implementable in software, perhaps the only reason for most programmers to know anything about MIDI hardware devices is simply to understand the metaphors in MIDI. However, external MIDI hardware devices are still essential for some important music applications, and so the Java Sound API supports input and output of MIDI data.

The software portion of the MIDI specification is extensive. This portion concerns the structure of MIDI data and how devices such as synthesizers should respond to that data. It is important to understand that MIDI data can be streamed or sequenced. This duality reflects two different parts of the Complete MIDI 1.0 Detailed Specification:

  • MIDI 1.0
  • Standard MIDI Files

We'll explain what's meant by streaming and sequencing by examining the purpose of each of these two parts of the MIDI specification.

Streaming Data in the MIDI Wire Protocol

The first of these two parts of the MIDI specification describes what is known informally as "MIDI wire protocol." MIDI wire protocol, which is the original MIDI protocol, is based on the assumption that the MIDI data is being sent over a MIDI cable (the "wire"). The cable transmits digital data from one MIDI device to another. Each of the MIDI devices might be a musical instrument or a similar device, or it might be a general-purpose computer equipped with a MIDI-capable sound card or a MIDI-to-serial-port interface.

MIDI data, as defined by MIDI wire protocol, is organized into messages. The different kinds of message are distinguished by the first byte in the message, known as the status byte. (Status bytes are the only bytes that have the highest-order bit set to 1.) The bytes that follow the status byte in a message are known as data bytes. Certain MIDI messages, known as channel messages, have a status byte that contains four bits to specify the kind of channel message and another four bits to specify the channel number. There are therefore 16 MIDI channels; devices that receive MIDI messages can be set to respond to channel messages on all or only one of these virtual channels. Often each MIDI channel (which shouldn't be confused with a channel of audio) is used to send the notes for a different instrument. As an example, two common channel messages are Note On and Note Off, which start a note sounding and then stop it, respectively. These two messages each take two data bytes: the first specifies the note's pitch and the second its "velocity" (how fast the key is depressed or released, assuming a keyboard instrument is playing the note).

MIDI wire protocol defines a streaming model for MIDI data. A central feature of this protocol is that the bytes of MIDI data are delivered in real time—in other words, they are streamed. The data itself contains no timing information; each event is processed as it's received, and it's assumed that it arrives at the correct time. That model is fine if the notes are being generated by a live musician, but it's insufficient if you want to store the notes for later playback, or if you want to compose them out of real time. This limitation is understandable when you realize that MIDI was originally designed for musical performance, as a way for a keyboard musician to control more than one synthesizer, back in the days before many musicians used computers. (The first version of the specification was released in 1984.)

Sequenced Data in Standard MIDI Files

The Standard MIDI Files part of the MIDI specification addresses the timing limitation in MIDI wire protocol. A standard MIDI file is a digital file that contains MIDI events. An event is simply a MIDI message, as defined in the MIDI wire protocol, but with an additional piece of information that specifies the event's timing. (There are also some events that don't correspond to MIDI wire protocol messages, as we'll see in the next section.) The additional timing information is a series of bytes that indicates when to perform the operation described by the message. In other words, a standard MIDI file specifies not just which notes to play, but exactly when to play each of them. It's a bit like a musical score.

The information in a standard MIDI file is referred to as a sequence. A standard MIDI file contains one or more tracks. Each track typically contains the notes that a single instrument would play if the music were performed by live musicians. A sequencer is a software or hardware device that can read a sequence and deliver the MIDI messages contained in it at the right time. A sequencer is a bit like an orchestra conductor: it has the information for all the notes, including their timings, and it tells some other entity when to perform the notes.

The Java Sound API's Representation of MIDI Data

Now that we've sketched the MIDI specification's approach to streamed and sequenced musical data, let's examine how the Java Sound API represents that data.

MIDI Messages

MidiMessage is an abstract class that represents a "raw" MIDI message. A "raw" MIDI message is usually a message defined by the MIDI wire protocol. It can also be one of the events defined by the Standard MIDI Files specification, but without the event's timing information. There are three categories of raw MIDI message, represented in the Java Sound API by these three respective MidiMessage subclasses:

  • ShortMessages are the most common messages and have at most two data bytes following the status byte. The channel messages, such as Note On and Note Off, are all short messages, as are some other messages.
  • SysexMessages contain system-exclusive MIDI messages. They may have many bytes, and generally contain manufacturer-specific instructions.
  • MetaMessages occur in MIDI files, but not in MIDI wire protocol. Meta messages contain data, such as lyrics or tempo settings, that might be useful to sequencers but that are usually meaningless for synthesizers.

MIDI Events

As we've seen, standard MIDI files contain events that are wrappers for "raw" MIDI messages along with timing information. An instance of the Java Sound API's MidiEvent class represents an event such as might be stored in a standard MIDI file.

The API for MidiEvent includes methods to set and get the event's timing value. There's also a method to retrieve its embedded raw MIDI message, which is an instance of a subclass of MidiMessage, discussed next. (The embedded raw MIDI message can be set only when constructing the MidiEvent.)

Sequences and Tracks

As mentioned earlier, a standard MIDI file stores events that are arranged into tracks. Usually the file represents one musical composition, and usually each track represents a part such as might have been played by a single instrumentalist. Each note that the instrumentalist plays is represented by at least two events: a Note On that starts the note, and a Note Off that ends it. The track may also contain events that don't correspond to notes, such as meta-events (which were mentioned above).

The Java Sound API organizes MIDI data in a three-part hierarchy:

  • Sequence
  • Track
  • MidiEvent

A Track is a collection of MidiEvents, and a Sequence is a collection of Tracks. This hierarchy reflects the files, tracks, and events of the Standard MIDI Files specification. (Note: this is a hierarchy in terms of containment and ownership; it's not a class hierarchy in terms of inheritance. Each of these three classes inherits directly from java.lang.Object.)

Sequences can be read from MIDI files, or created from scratch and edited by adding Tracks to the Sequence (or removing them). Similarly, MidiEvents can be added to or removed from the tracks in the sequence.

The Java Sound API's Representation of MIDI Devices

The previous section explained how MIDI messages are represented in the Java Sound API. However, MIDI messages don't exist in a vacuum. They're typically sent from one device to another. A program that uses the Java Sound API can generate MIDI messages from scratch, but more often the messages are instead created by a software device, such as a sequencer, or received from outside the computer through a MIDI input port. Such a device usually sends these messages to another device, such as a synthesizer or a MIDI output port.

The MidiDevice Interface

In the world of external MIDI hardware devices, many devices can transmit MIDI messages to other devices and also receive messages from other devices. Similarly, in the Java Sound API, software objects that implement the MidiDevice interface can transmit and receive messages. Such an object can be implemented purely in software, or it can serve as an interface to hardware such as a sound card's MIDI capabilities. The base MidiDevice interface provides all the functionality generally required by a MIDI input or output port. Synthesizers and sequencers, however, further implement one of the subinterfaces of MidiDevice: Synthesizer or Sequencer, respectively.

The MidiDevice interface includes API for opening and closing a device. It also includes an inner class called MidiDevice.Info that provides textual descriptions of the device, including its name, vendor, and version. If you've read the sampled-audio portion of this programmer's guide, this API will probably sound familiar, because its design is similar to that of the javax.sampled.Mixer interface, which represents an audio device and which has an analogous inner class, Mixer.Info.

Transmitters and Receivers

Most MIDI devices are capable of sending MidiMessages, receiving them, or both. The way a device sends data is via one or more transmitter objects that it "owns." Similarly, the way a device receives data is via one or more of its receiver objects. The transmitter objects implement the Transmitter interface, and the receivers implement the Receiver interface.

Each transmitter can be connected to only one receiver at a time, and vice versa. A device that sends its MIDI messages to multiple other devices simultaneously does so by having multiple transmitters, each connected to a receiver of a different device. Similarly, a device that can receive MIDI messages from more than one source at a time must do so via multiple receivers.

Sequencers

A sequencer is a device for capturing and playing back sequences of MIDI events. It has transmitters, because it typically sends the MIDI messages stored in the sequence to another device, such as a synthesizer or MIDI output port. It also has receivers, because it can capture MIDI messages and store them in a sequence. To its superinterface, MidiDevice, Sequencer adds methods for basic MIDI sequencing operations. A sequencer can load a sequence from a MIDI file, query and set the sequence's tempo, and synchronize other devices to it. An application program can register an object to be notified when the sequencer processes certain kinds of events.

Synthesizers

A Synthesizer is a device for generating sound. It's the only object in the javax.sound.midi package that produces audio data. A synthesizer device controls a set of MIDI channel objects—typically 16 of them, since the MIDI specification calls for 16 MIDI channels. These MIDI channel objects are instances of a class that implements the MidiChannel interface, whose methods represent the MIDI specification's "channel voice messages" and "channel mode messages."

An application program can generate sound by directly invoking methods of a synthesizer's MIDI channel objects. More commonly, though, a synthesizer generates sound in response to messages sent to one or more of its receivers. These messages might be sent by a sequencer or MIDI input port, for example. The synthesizer parses each message that its receivers get, and usually dispatches a corresponding command (such as noteOn or controlChange) to one of its MidiChannel objects, according to the MIDI channel number specified in the event.

The MidiChannel uses the note information in these messages to synthesize music. For example, a noteOn message specifies the note's pitch and "velocity" (volume). However, the note information is insufficient; the synthesizer also requires precise instructions on how to create the audio signal for each note. These instructions are represented by an Instrument. Each Instrument typically emulates a different real-world musical instrument or sound effect. The Instruments might come as presets with the synthesizer, or they might be loaded from soundbank files. In the synthesizer, the Instruments are arranged by bank number (these can be thought of as rows) and program number (columns).

This chapter has provided a background for understanding MIDI data, and it has introduced some of the important interfaces and classes related to MIDI in the Java Sound API. Subsequent chapters show how you can access and use these objects in your application program.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 9: Accessing MIDI System Resources

Note

With version 5.0, the sound.properties file can be used to set default devices for Sequencer, Synthesizer, Transmitter, and Receiver. For details, see the MidiSystem class in the API; for examples, see Appendix 2: sound.properties File in this guide.

The Java Sound API offers a flexible model for MIDI system configuration, just as it does for configuration of the sampled-audio system. An implementation of the Java Sound API can itself provide different sorts of MIDI devices, and additional ones can be supplied by service providers and installed by users. You can write your program in such a way that it makes few assumptions about which specific MIDI devices are installed on the computer. Instead, the program can take advantage of the MIDI system's defaults, or it can allow the user to select from whatever devices happen to be available.

This section shows how your program can learn what MIDI resources have been installed, and how to get access to the desired ones. After you've accessed and opened the devices, you can connect them to each other, as discussed in the next chapter, "Transmitting and Receiving MIDI Messages."

The MidiSystem Class

The role of the MidiSystem class in the Java Sound API's MIDI package is directly analogous to the role of AudioSystem in the sampled-audio package. MidiSystem acts as a clearinghouse for accessing the installed MIDI resources.

You can query the MidiSystem to learn what sorts of devices are installed, and then you can iterate over the available devices and obtain access to the desired ones. For example, an application program might start out by asking the MidiSystem what synthesizers are available, and then display a list of them, from which the user can select one. A simpler application program might just use the system's default synthesizer.

The MidiSystem class also provides methods for translating between MIDI files and Sequences. It can report the file format of a MIDI file and can write files of different types.

An application program can obtain the following resources from the MidiSystem:

  • Sequencers
  • Synthesizers
  • Transmitters (such as those associated with MIDI input ports)
  • Receivers (such as those associated with MIDI output ports)
  • Data from standard MIDI files
  • Data from soundbank files

This chapter focuses on the first four of these types of resource. The MidiSystem class's file-handling facilities are discussed in Chapter 11, "Playing, Recording, and Editing MIDI Sequences," and Chapter 12, "Synthesizing Sound." To understand how the MIDI system itself gets access to all these resources, see Part III of this guide, "Service Provider Interfaces."

Obtaining Default Devices

A typical MIDI application program that uses the Java Sound API begins by obtaining the devices it needs, which can consist of one or more sequencers, synthesizers, input ports, or output ports.

There is a default synthesizer device, a default sequencer device, a default transmitting device, and a default receiving device. The latter two devices normally represent the MIDI input and output ports, respectively, if there are any available on the system. (It's easy to get confused about the directionality here. Think of the ports' transmission or reception in relation to the software, not in relation to any external physical devices connected to the physical ports. A MIDI input port transmits data from an external device to a Java Sound API Receiver, and likewise a MIDI output port receives data from a software object and relays the data to an external device.)

A simple application program might just use the default instead of exploring all the installed devices. The MidiSystem class includes the following methods for retrieving default resources:

    static Sequencer getSequencer()
    static Synthesizer getSynthesizer()
    static Receiver getReceiver()
    static Transmitter getTransmitter()

The first two of these methods obtain the system's default sequencing and synthesis resources, which either represent physical devices or are implemented wholly in software. The getReceiver method obtains a Receiver object that takes MIDI messages sent to it and relays them to the default receiving device. Similarly, the getTransmitter method obtains a Transmitter object that can send MIDI messages to some receiver on behalf of the default transmitting device.

Learning What Devices Are Installed

Instead of using the default devices, a more thorough approach is to select the desired devices from the full set of devices that are installed on the system. An application program can select the desired devices programmatically, or it can display a list of available devices and let the user select which ones to use. The MidiSystem class provides a method for learning which devices are installed, and a corresponding method to obtain a device of a given type.

Here is the method for learning about the installed devices:

    static MidiDevice.Info[] getMidiDeviceInfo()

As you can see, it returns an array of information objects. Each of these returned MidiDevice.Info objects identifies one type of sequencer, synthesizer, port, or other device that is installed. (Usually a system has at most one instance of a given type. For example, a given model of synthesizer from a certain vendor will be installed only once. ) The MidiDevice.Info includes the following strings to describe the device:

  • Name
  • Version number
  • Vendor (the company that created the device)
  • A description of the device

You can display these strings in your user interface to let the user select from the list of devices.

However, to use the strings programmatically to select a device (as opposed to displaying the strings to the user), you need to know in advance what they might be. The company that provides each device should include this information in its documentation. An application program that requires or prefers a particular device can use this information to locate that device. This approach has the drawback of limiting the program to device implementations that it knows about in advance.

Another, more general, approach is to go ahead and iterate over the MidiDevice.Info objects, obtaining each corresponding device, and determining programmatically whether it's suitable to use (or at least suitable to include in a list from which the user can choose). The next section describes how to do this.

Obtaining a Desired Device

Once an appropriate device's info object is found, the application program invokes the following MidiSystem method to obtain the corresponding device itself:

    static MidiDevice getMidiDevice(MidiDevice.Info info)

You can use this method if you've already found the info object describing the device you need. However, if you can't interpret the info objects returned by getMidiDeviceInfo to determine which device you need, and if you don't want to display information about all the devices to the user, you might be able to do the following instead: Iterate over all the MidiDevice.Info objects returned by getMidiDeviceInfo, get the corresponding devices using the method above, and test each device to see whether it's suitable. In other words, you can query each device for its class and its capabilities before including it in the list that you display to the user, or as a way to decide upon a device programmatically without involving the user. For example, if your program needs a synthesizer, you can obtain each of the installed devices, see which are instances of classes that implement the Synthesizer interface, and then display them in a list from which the user can choose one, as follows:

// Obtain information about all the installed synthesizers.
Vector synthInfos;
MidiDevice device;
MidiDevice.Info[] infos = MidiSystem.getMidiDeviceInfo();
for (int i = 0; i < infos.length; i++) {
    try {
        device = MidiSystem.getMidiDevice(infos[i]);
    } catch (MidiUnavailableException e) {
          // Handle or throw exception...
    }
    if (device instanceof Synthesizer) {
        synthInfos.add(infos[i]);
    }
}
// Now, display strings from synthInfos list in GUI.

As another example, you might choose a device programmatically, without involving the user. Let's suppose you want to obtain the synthesizer that can play the most notes simultaneously. You iterate over all the MidiDevice.Info objects, as above, but after determining that a device is a synthesizer, you query its capabilities by invoking the getMaxPolyphony method of Synthesizer. You reserve the synthesizer that has the greatest polyphony, as described in the next section. Even though you're not asking the user to choose a synthesizer, you might still display strings from the chosen MidiDevice.Info object, just for the user's information.

Opening Devices

The previous section showed how to get an installed device. However, a device might be installed but unavailable. For example, another application program might have exclusive use of it. To actually reserve a device for your program, you need to use the MidiDevice method open:

if (!(device.isOpen())) {
    try {
      device.open();
  } catch (MidiUnavailableException e) {
          // Handle or throw exception...
  }
}

Once you've accessed a device and reserved it by opening it, you'll probably want to connect it to one or more other devices to let MIDI data flow between them. This procedure is described in Chapter 10, "Transmitting and Receiving MIDI Messages."

When done with a device, you release it for other programs' use by invoking the close method of MidiDevice.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 10: Transmitting and Receiving MIDI Messages

Understanding Devices, Transmitters, and Receivers

The Java Sound API specifies a message-routing architecture for MIDI data that's flexible and easy to use, once you understand how it works. The system is based on a module-connection design: distinct modules, each of which performs a specific task, can be interconnected (networked), enabling data to flow from one module to another.

The base module in the Java Sound API's messaging system is MidiDevice (a Java language interface). MidiDevices include sequencers (which record, play, load, and edit sequences of time-stamped MIDI messages), synthesizers (which generate sounds when triggered by MIDI messages), and MIDI input and output ports, through which data comes from and goes to external MIDI devices. The functionality typically required of MIDI ports is described by the base MidiDevice interface. The Sequencer and Synthesizer interfaces extend the MidiDevice interface to describe the additional functionality characteristic of MIDI sequencers and synthesizers, respectively. Concrete classes that function as sequencers or synthesizers should implement these interfaces.

A MidiDevice typically owns one or more ancillary objects that implement the Receiver or Transmitter interfaces. These interfaces represent the "plugs" or "portals" that connect devices together, permitting data to flow into and out of them. By connecting a Transmitter of one MidiDevice to a Receiver of another, you can create a network of modules in which data flows from one to another.

The MidiDevice interface includes methods for determining how many transmitter and receiver objects the device can support concurrently, and other methods for accessing those objects. A MIDI output port normally has at least one Receiver through which the outgoing messages may be received; similarly, a synthesizer normally responds to messages sent to its Receiver or Receivers. A MIDI input port normally has at least one Transmitter, which propagates the incoming messages. A full-featured sequencer supports both Receivers, which receive messages during recording, and Transmitters, which send messages during playback.

The Transmitter interface includes methods for setting and querying the receivers to which the transmitter sends its MidiMessages. Setting the receiver establishes the connection between the two. The Receiver interface contains a method that sends a MidiMessage to the receiver. Typically, this method is invoked by a Transmitter. Both the Transmitter and Receiver interfaces include a close method that frees up a previously connected transmitter or receiver, making it available for a different connection.

We'll now examine how to use transmitters and receivers. Before getting to the typical case of connecting two devices (such as hooking a sequencer to a synthesizer), we'll examine the simpler case where you send a MIDI message directly from your application program to a device. Studying this simple scenario should make it easier to understand how the Java Sound API arranges for sending MIDI messages between two devices.

Sending a Message to a Receiver without Using a Transmitter

Let's say you want to create a MIDI message from scratch and then send it to some receiver. You can create a new, blank ShortMessage and then fill it with MIDI data using the following ShortMessage method:

void setMessage(int command, int channel, int data1,
         int data2)

Once you have a message ready to send, you can send it to a Receiver object, using this Receiver method:

void send(MidiMessage message, long timeStamp)

The time-stamp argument will be explained momentarily. For now, we'll just mention that its value can be set to -1 if you don't care about specifying a precise time. In this case, the device receiving the message will try to respond to the message as soon as possible.

An application program can obtain a receiver for a MidiDevice by invoking the device's getReceiver method. If the device can't provide a receiver to the program (typically because all the device's receivers are already in use), a MidiUnavailableException is thrown. Otherwise, the receiver returned from this method is available for immediate use by the program. When the program has finished using the receiver, it should call the receiver's close method. If the program attempts to invoke methods on a receiver after calling close, an IllegalStateException may be thrown.

As a concrete simple example of sending a message without using a transmitter, let's send a Note On message to the default receiver, which is typically associated with a device such as the MIDI output port or a synthesizer. We do this by creating a suitable ShortMessage and passing it as an argument to Receiver's send method:

  ShortMessage myMsg = new ShortMessage();
  // Start playing the note Middle C (60),
  // moderately loud (velocity = 93).
  myMsg.setMessage(ShortMessage.NOTE_ON, 0, 60, 93);
  long timeStamp = -1;
  Receiver       rcvr = MidiSystem.getReceiver();
  rcvr.send(myMsg, timeStamp);

This code uses a static integer field of ShortMessage, namely, NOTE_ON, for use as the MIDI message's status byte. The other parts of the MIDI message are given explicit numeric values as arguments to the setMessage method. The zero indicates that the note is to be played using MIDI channel number 1; the 60 indicates the note Middle C; and the 93 is an arbitrary key-down velocity value, which typically indicates that the synthesizer that eventually plays the note should play it somewhat loudly. (The MIDI specification leaves the exact interpretation of velocity up to the synthesizer's implementation of its current instrument.) This MIDI message is then sent to the receiver with a time stamp of -1. We now need to examine exactly what the time stamp parameter means, which is the subject of the next section.

Understanding Time Stamps

Chapter 8, "Overview of the MIDI Package," explained that the MIDI specification has different parts. One part describes MIDI "wire" protocol (messages sent between devices in real time), and another part describes Standard MIDI Files (messages stored as events in "sequences"). In the latter part of the specification, each event stored in a standard MIDI file is tagged with a timing value that indicates when that event should be played. By contrast, messages in MIDI wire protocol are always supposed to be processed immediately, as soon as they're received by a device, so they have no accompanying timing values.

The Java Sound API adds an additional twist. It comes as no surprise that timing values are present in the MidiEvent objects that are stored in sequences (as might be read from a MIDI file), just as in the Standard MIDI Files specification. But in the Java Sound API, even the messages sent between devices—in other words, the messages that correspond to MIDI wire protocol—can be given timing values, known as time stamps. It is these time stamps that concern us here. (The timing values in MidiEvent objects are discussed in detail in Chapter 11, "Playing, Recording, and Editing MIDI Sequences.")

Time Stamps on Messages Sent to Devices

The time stamp that can optionally accompany messages sent between devices in the Java Sound API is quite different from the timing values in a standard MIDI file. The timing values in a MIDI file are often based on musical concepts such as beats and tempo, and each event's timing measures the time elapsed since the previous event. In contrast, the time stamp on a message sent to a device's Receiver object always measures absolute time in microseconds. Specifically, it measures the number of microseconds elapsed since the device that owns the receiver was opened.

This kind of time stamp is designed to help compensate for latencies introduced by the operating system or by the application program. It's important to realize that these time stamps are used for minor adjustments to timing, not to implement complex queues that can schedule events at completely arbitrary times (as MidiEvent timing values do).

The time stamp on a message sent to a device (through a Receiver) can provide precise timing information to the device. The device might use this information when it processes the message. For example, it might adjust the event's timing by a few milliseconds to match the information in the time stamp. On the other hand, not all devices support time stamps, so the device might completely ignore the message's time stamp.

Even if a device supports time stamps, it might not schedule the event for exactly the time that you requested. You can't expect to send a message whose time stamp is very far in the future and have the device handle it as you intended, and you certainly can't expect a device to correctly schedule a message whose time stamp is in the past! It's up to the device to decide how to handle time stamps that are too far off in the future or are in the past. The sender doesn't know what the device considers to be too far off, or whether the device had any problem with the time stamp. This ignorance mimics the behavior of external MIDI hardware devices, which send messages without ever knowing whether they were received correctly. (MIDI wire protocol is unidirectional.)

Some devices send time-stamped messages (via a Transmitter). For example, the messages sent by a MIDI input port might be stamped with the time the incoming message arrived at the port. On some systems, the event-handling mechanisms cause a certain amount of timing precision to be lost during subsequent processing of the message. The message's time stamp allows the original timing information to be preserved.

To learn whether a device supports time stamps, invoke the following method of MidiDevice:

    long getMicrosecondPosition()

This method returns -1 if the device ignores time stamps. Otherwise, it returns the device's current notion of time, which you as the sender can use as an offset when determining the time stamps for messages you subsequently send. For example, if you want to send a message with a time stamp for five milliseconds in the future, you can get the device's current position in microseconds, add 5000 microseconds, and use that as the time stamp. Keep in mind that the MidiDevice's notion of time always places time zero at the time the device was opened.

Now, with all that explanation of time stamps as a background, let's return to the send method of Receiver:

void send(MidiMessage message, long timeStamp)

The timeStamp argument is expressed in microseconds, according to the receiving device's notion of time. If the device doesn't support time stamps, it simply ignores the timeStamp argument. You aren't required to time-stamp the messages you send to a receiver. You can use -1 for the timeStamp argument to indicate that you don't care about adjusting the exact timing; you're just leaving it up to the receiving device to process the message as soon as it can. However, it's not advisable to send -1 with some messages and explicit time stamps with other messages sent to the same receiver. Doing so is likely to cause irregularities in the resultant timing.

Connecting Transmitters to Receivers

We've seen how you can send a MIDI message directly to a receiver, without using a transmitter. Now let's look at the more common case, where you aren't creating MIDI messages from scratch, but are simply connecting devices together so that one of them can send MIDI messages to the other.

Connecting to a Single Device

The specific case we'll take as our first example is connecting a sequencer to a synthesizer. After this connection is made, starting the sequencer running will cause the synthesizer to generate audio from the events in the sequencer's current sequence. For now, we'll ignore the process of loading a sequence from a MIDI file into the sequencer. Also, we won't go into the mechanism of playing the sequence. Loading and playing sequences is discussed in detail in Chapter 11, "Playing, Recording, and Editing MIDI Sequences." Loading instruments into the synthesizer is discussed in Chapter 12, "Synthesizing Sound." For now, all we're interested in is how to make the connection between the sequencer and the synthesizer. This will serve as an illustration of the more general process of connecting one device's transmitter to another device's receiver.

For simplicity, we'll use the default sequencer and the default synthesizer. (See Chapter 9, "Accessing MIDI System Resources," for more about default devices and how to access non-default devices.)

    Sequencer          seq;
    Transmitter         seqTrans;
    Synthesizer         synth;
    Receiver         synthRcvr;
    try {
          seq     = MidiSystem.getSequencer();
          seqTrans = seq.getTransmitter();
          synth   = MidiSystem.getSynthesizer();
          synthRcvr = synth.getReceiver();
          seqTrans.setReceiver(synthRcvr);
    } catch (MidiUnavailableException e) {
          // handle or throw exception
    }

An implementation might actually have a single object that serves as both the default sequencer and the default synthesizer. In other words, the implementation might use a class that implements both the Sequencer interface and the Synthesizer interface. In that case, it probably wouldn't be necessary to make the explicit connection that we did in the code above. For portability, though, it's safer not to assume such a configuration. If desired, you can test for this condition, of course:

if (seq instanceof Synthesizer)

although the explicit connection above should work in any case.

Connecting to More than One Device

The previous code example illustrated a one-to-one connection between a transmitter and a receiver. But, what if you need to send the same MIDI message to multiple receivers? For example, suppose you want to capture MIDI data from an external device to drive the internal synthesizer while simultaneously recording the data to a sequence. This form of connection, sometimes referred to as "fan out" or as a "splitter," is straightforward. The following statements show how to create a fan-out connection, through which the MIDI messages arriving at the MIDI input port are sent to both a Synthesizer object and a Sequencer object. We assume you've already obtained and opened the three devices: the input port, sequencer, and synthesizer. (To obtain the input port, you'll need to iterate over all the items returned by MidiSystem.getMidiDeviceInfo.)

    Synthesizer  synth;
    Sequencer    seq;
    MidiDevice   inputPort;
    // [obtain and open the three devices...]
    Transmitter   inPortTrans1, inPortTrans2;
    Receiver            synthRcvr;
    Receiver            seqRcvr;
    try {
          inPortTrans1 = inputPort.getTransmitter();
          synthRcvr = synth.getReceiver();
          inPortTrans1.setReceiver(synthRcvr);
          inPortTrans2 = inputPort.getTransmitter();
          seqRcvr = seq.getReceiver();
          inPortTrans2.setReceiver(seqRcvr);
    } catch (MidiUnavailableException e) {
          // handle or throw exception
    }

This code introduces a dual invocation of the MidiDevice.getTransmitter method, assigning the results to inPortTrans1 and inPortTrans2. As mentioned earlier, a device can own multiple transmitters and receivers. Each time MidiDevice.getTransmitter() is invoked for a given device, another transmitter is returned, until no more are available, at which time an exception will be thrown.

To learn how many transmitters and receivers a device supports, you can use the following MidiDevice method:

    int getMaxTransmitters()
    int getMaxReceivers()

These methods return the total number owned by the device, not the number currently available.

A transmitter can transmit MIDI messages to only one receiver at a time. (Every time you call Transmitter's setReceiver method, the existing Receiver, if any, is replaced by the newly specified one. You can tell whether the transmitter currently has a receiver by invoking Transmitter.getReceiver.) However, if a device has multiple transmitters, it can send data to more than one device at a time, by connecting each transmitter to a different receiver, as we saw in the case of the input port above.

Similarly, a device can use its multiple receivers to receive from more than one device at a time. The multiple-receiver code that's required is straightforward, being directly analogous to the multiple-transmitter code above. It's also possible for a single receiver to receive messages from more than one transmitter at a time.

Closing Connections

Once you're done with a connection, you can free up its resources by invoking the close method for each transmitter and receiver that you've obtained. The Transmitter and Receiver interfaces each have a close method. Note that invoking Transmitter.setReceiver doesn't close the transmitter's current receiver. The receiver is left open, and it can still receive messages from any other transmitter that's connected to it.

If you're also done with the devices, you can similarly make them available to other application programs by invoking MidiDevice.close(). Closing a device automatically closes all its transmitters and receivers.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 11: Playing, Recording and Editing MIDI Sequences

Note

With the 5.0 release, there is a new real-time Sequencer (implementation) that works with all Midi devices and, via its getTransmitter() method, an unlimited number of transmitters may be obtained. Prior to this release, it was not possible to get a Transmitter from a Sequencer.

In the world of MIDI, a sequencer is any hardware or software device that can precisely play or record a sequence of time-stamped MIDI messages. Similarly, in the Java Sound API, the Sequencer abstract interface defines the properties of an object that can play and record Sequences of MidiEvent objects. A Sequencer typically loads these MidiEvent sequences from a standard MIDI file or saves them to such a file. Sequences can also be edited. This chapter explains how to use Sequencer objects, along with related classes and interfaces, to accomplish such tasks.

Introduction to Sequencers

To develop an intuitive understanding of what a Sequencer is, think of it by analogy with a tape recorder, which a sequencer resembles in many respects. Whereas a tape recorder plays audio, a sequencer plays MIDI data. A sequence is a multi-track, linear, time-ordered recording of MIDI musical data, which a sequencer can play at various speeds, rewind, shuttle to particular points, record into, or copy to a file for storage.

Chapter 10, "Transmitting and Receiving MIDI Messages," explained that devices typically have Receiver objects, Transmitter objects, or both. To play music, a device generally receives MidiMessages through a Receiver, which in turn has usually received them from a Transmitter that belongs to a Sequencer. The device that owns this Receiver might be a Synthesizer, which will generate audio directly, or it might be a MIDI output port, which transmits MIDI data through a physical cable to some external piece of equipment. Similarly, to record music, a series of time-stamped MidiMessages are generally sent to a Receiver owned by a Sequencer, which places them in a Sequence object. Typically the object sending the messages is a Transmitter associated with a hardware input port, and the port relays MIDI data that it gets from an external instrument. However, the device responsible for sending the messages might instead be some other Sequencer, or any other device that has a Transmitter. Furthermore, as mentioned in Chapter 10, a program can send messages without using any Transmitter at all.

A Sequencer itself has both Receivers and Transmitters. When it's recording, it actually obtains MidiMessages via its Receivers. During playback, it uses its Transmitters to send MidiMessages that are stored in the Sequence that it has recorded (or loaded from a file).

One way to think of the role of a Sequencer in the Java Sound API is as an aggregator and "de-aggregator" of MidiMessages. A series of separate MidiMessages, each of which is independent, is sent to the Sequencer along with its own time stamp that marks the timing of a musical event. These MidiMessages are encapsulated in MidiEvent objects and collected in Sequence objects through the action of the Sequencer.record method. A Sequence is a data structure containing aggregates of MidiEvents, and it usually represents a series of musical notes, often an entire song or composition. On playback, the Sequencer again extracts the MidiMessages from the MidiEvent objects in the Sequence and then transmits them to one or more devices that will either render them into sound, save them, modify them, or pass them on to some other device.

Some sequencers might have neither transmitters nor receivers. For example, they might create MidiEvents from scratch as a result of keyboard or mouse events, instead of receiving MidiMessages through Receivers. Similarly, they might play music by communicating directly with an internal synthesizer (which could actually be the same object as the sequencer) instead of sending MidiMessages to a Receiver associated with a separate object. However, the rest of this chapter assumes the normal case of a sequencer that uses Receivers and Transmitters.

When to Use a Sequencer

It's possible for an application program to send MIDI messages directly to a device, without using a sequencer, as was described in Chapter 10, "Transmitting and Receiving MIDI Messages." The program simply invokes the Receiver.send method each time it wants to send a message. This is a straightforward approach that's useful when the program itself creates the messages in real time. For example, consider a program that lets the user play notes by clicking on an onscreen piano keyboard. When the program gets a mouse-down event, it immediately sends the appropriate Note On message to the synthesizer.

As mentioned in Chapter 10, the program can include a time stamp with each MIDI message it sends to the device's receiver. However, such time stamps are used only for fine-tuning the timing, to correct for processing latency. The caller can't generally set arbitrary time stamps; the time value passed to Receiver.send must be close to the present time, or the receiving device might not be able to schedule the message correctly. This means that if an application program wanted to create a queue of MIDI messages for an entire piece of music ahead of time (instead of creating each message in response to a real-time event), it would have to be very careful to schedule each invocation of Receiver.send for nearly the right time.

Fortunately, most application programs don't have to be concerned with such scheduling. Instead of invoking Receiver.send itself, a program can use a Sequencer object to manage the queue of MIDI messages for it. The sequencer takes care of scheduling and sending the messages—in other words, playing the music with the correct timing. Generally, it's advantageous to use a sequencer whenever you need to convert a non-real-time series of MIDI messages to a real-time series (as in playback), or vice versa (as in recording). Sequencers are most commonly used for playing data from MIDI files and for recording data from a MIDI input port.

Understanding Sequence Data

Before examining the Sequencer API, it helps to understand the kind of data that's stored in a sequence.

Sequences and Tracks

In the Java Sound API, sequencers closely follow the Standard MIDI Files specification in the way that they organize recorded MIDI data. As mentioned above, a Sequence is an aggregation of MidiEvents, organized in time. But there is more structure to a Sequence than just a linear series of MidiEvents: a Sequence actually contains global timing information plus a collection of Tracks, and it is the Tracks themselves that hold the MidiEvent data. So the data played by a sequencer consists of a three-level hierarchy of objects: Sequencer, Track, and MidiEvent.

In the conventional use of these objects, the Sequence represents a complete musical composition or section of a composition, with each Track corresponding to a voice or player in the ensemble. In this model, all the data on a particular Track would also therefore be encoded into a particular MIDI channel reserved for that voice or player.

This way of organizing data is convenient for purposes of editing sequences, but note that this is just a conventional way to use Tracks. There is nothing in the definition of the Track class per se that keeps it from containing a mix of MidiEvents on different MIDI channels. For example, an entire multi-channel MIDI composition can be mixed and recorded onto one Track. Also, standard MIDI files of Type 0 (as opposed to Type 1 and Type 2) contain by definition only one track; so a Sequence that's read from such a file will necessarily have a single Track object.

MidiEvents and Ticks

As discussed in Chapter 8, "Overview of the MIDI Package," the Java Sound API includes MidiMessage objects that correspond to the raw two- or three-byte sequences that make up most standard MIDI messages. A MidiEvent is simply a packaging of a MidiMessage along with an accompanying timing value that specifies when the event occurs. (We might then say that a sequence really consists of a four- or five-level hierarchy of data, rather than three-level, because the ostensible lowest level, MidiEvent, actually contains a lower-level MidiMessage, and likewise the MidiMessage object contains an array of bytes that comprises a standard MIDI message.)

In the Java Sound API, there are two different ways in which MidiMessages can be associated with timing values. One is the way mentioned above under "When to Use a Sequencer." This technique is described in detail under "Sending a Message to a Receiver without Using a Transmitter" and "Understanding Time Stamps" in Chapter 10, "Transmitting and Receiving MIDI Messages." There, we saw that the send method of Receiver takes a MidiMessage argument and a time-stamp argument. That kind of time stamp can only be expressed in microseconds.

The other way in which a MidiMessage can have its timing specified is by being encapsulated in a MidiEvent. In this case, the timing is expressed in slightly more abstract units called ticks.

What is the duration of a tick? It can vary between sequences (but not within a sequence), and its value is stored in the header of a standard MIDI file. The size of a tick is given in one of two types of units:

  • Pulses (ticks) per quarter note, abbreviated as PPQ
  • Ticks per frame, also known as SMPTE time code (a standard adopted by the Society of Motion Picture and Television Engineers)

If the unit is PPQ, the size of a tick is expressed as a fraction of a quarter note, which is a relative, not absolute, time value. A quarter note is a musical duration value that often corresponds to one beat of the music (a quarter of a measure in 4/4 time). The duration of a quarter note is dependent on the tempo, which can vary during the course of the music if the sequence contains tempo-change events. So if the sequence's timing increments (ticks) occur, say 96 times per quarter note, each event's timing value measures that event's position in musical terms, not as an absolute time value.

On the other hand, in the case of SMPTE, the units measure absolute time, and the notion of tempo is inapplicable. There are actually four different SMPTE conventions available, which refer to the number of motion-picture frames per second. The number of frames per second can be 24, 25, 29.97, or 30. With SMPTE time code, the size of a tick is expressed as a fraction of a frame.

In the Java Sound API, you can invoke Sequence.getDivisionType to learn which type of unit—namely, PPQ or one of the SMPTE units—is used in a particular sequence. You can then calculate the size of a tick after invoking Sequence.getResolution. The latter method returns the number of ticks per quarter note if the division type is PPQ, or per SMPTE frame if the division type is one of the SMPTE conventions. You can get the size of a tick using this formula in the case of PPQ:

ticksPerSecond =
    resolution * (currentTempoInBeatsPerMinute / 60.0);
tickSize = 1.0 / ticksPerSecond;

and this formula in the case of SMPTE:

framesPerSecond =
  (divisionType == Sequence.SMPTE_24 ? 24
    : (divisionType == Sequence.SMPTE_25 ? 25
      : (divisionType == Sequence.SMPTE_30 ? 30
        : (divisionType == Sequence.SMPTE_30DROP ?
            29.97))));
ticksPerSecond = resolution * framesPerSecond;
tickSize = 1.0 / ticksPerSecond;

The Java Sound API's definition of timing in a sequence mirrors that of the Standard MIDI Files specification. However, there's one important difference. The tick values contained in MidiEvents measure cumulative time, rather than delta time. In a standard MIDI file, each event's timing information measures the amount of time elapsed since the onset of the previous event in the sequence. This is called delta time. But in the Java Sound API, the ticks aren't delta values; they're the previous event's time value plus the delta value. In other words, in the Java Sound API the timing value for each event is always greater than that of the previous event in the sequence (or equal, if the events are supposed to be simultaneous). Each event's timing value measures the time elapsed since the beginning of the sequence.

To summarize, the Java Sound API expresses timing information in either MIDI ticks or microseconds. MidiEvents store timing information in terms of MIDI ticks. The duration of a tick can be calculated from the Sequence's global timing information and, if the sequence uses tempo-based timing, the current musical tempo. The time stamp associated with a MidiMessage sent to a Receiver, on the other hand, is always expressed in microseconds.

One goal of this design is to avoid conflicting notions of time. It's the job of a Sequencer to interpret the time units in its MidiEvents, which might have PPQ units, and translate these into absolute time in microseconds, taking the current tempo into account. The sequencer must also express the microseconds relative to the time when the device receiving the message was opened. Note that a sequencer can have multiple transmitters, each delivering messages to a different receiver that might be associated with a completely different device. You can see, then, that the sequencer has to be able to perform multiple translations at the same time, making sure that each device receives time stamps appropriate for its notion of time.

To make matters more complicated, different devices might update their notions of time based on different sources (such as the operating system's clock, or a clock maintained by a sound card). This means that their timings can drift relative to the sequencer's. To keep in synchronization with the sequencer, some devices permit themselves to be "slaves" to the sequencer's notion of time. Setting masters and slaves is discussed later under "Using Advanced Sequencer Features."

Overview of Sequencer Methods

The Sequencer interface provides methods in several categories:

  • Methods to load sequence data from a MIDI file or a Sequence object, and to save the currently loaded sequence data to a MIDI file.
  • Methods analogous to the transport functions of a tape recorder, for stopping and starting playback and recording, enabling and disabling recording on specific tracks, and shuttling the current playback or recording position in a Sequence.
  • Advanced methods for querying and setting the synchronization and timing parameters of the object. A Sequencer may play at different tempos, with some Tracks muted, and in various synchronization states with other objects.
  • Advanced methods for registering "listener" objects that are notified when the Sequencer processes certain kinds of MIDI events.

Regardless of which Sequencer methods you'll invoke, the first step is to obtain a Sequencer device from the system and reserve it for your program's use.

Obtaining a Sequencer

An application program doesn't instantiate a Sequencer; after all, Sequencer is just an interface. Instead, like all devices in the Java Sound API's MIDI package, a Sequencer is accessed through the static MidiSystem object. As mentioned in Chapter 9, "Accessing MIDI System Resources," the following MidiSystem method can be used to obtain the default Sequencer:

    static Sequencer getSequencer()

The following code fragment obtains the default Sequencer, acquires any system resources it needs, and makes it operational:

    Sequencer sequencer;
    // Get default sequencer.
    sequencer = MidiSystem.getSequencer();
    if (sequencer == null) {
        // Error -- sequencer device is not supported.
        // Inform user and return...
    } else {
         // Acquire resources and make operational.
        sequencer.open();
    }

The invocation of open reserves the sequencer device for your program's use. It doesn't make much sense to imagine sharing a sequencer, because it can play only one sequence at a time. When you're done using the sequencer, you can make it available to other programs by invoking close.

Non-default sequencers can be obtained as described in Chapter 9, "Accessing MIDI System Resources."

Loading a Sequence

Having obtained a sequencer from the system and reserved it, you then need load the data that the sequencer should play. There are three typical ways of accomplishing this:

  • Reading the sequence data from a MIDI file
  • Recording it in real time by receiving MIDI messages from another device, such as a MIDI input port
  • Building it programmatically "from scratch" by adding tracks to an empty sequence and adding MidiEvent objects to those tracks

We'll now look at the first of these ways of getting sequence data. (The other two ways are described later under "Recording and Saving Sequences" and "Editing a Sequence," respectively.) This first way actually encompasses two slightly different approaches. One approach is to feed MIDI file data to an InputStream that you then read directly to the sequencer by means of Sequencer.setSequence(InputStream). With this approach, you don't explicitly create a Sequence object. In fact, the Sequencer implementation might not even create a Sequence behind the scenes, because some sequencers have a built-in mechanism for handling data directly from a file.

The other approach is to create a Sequence explicitly. You'll need to use this approach if you're going to edit the sequence data before playing it. With this approach, you invoke MidiSystem's overloaded method getSequence. The method is able to get the sequence from an InputStream, a File, or a URL. The method returns a Sequence object that can then be loaded into a Sequencer for playback. Expanding on the previous code excerpt, here's an example of obtaining a Sequence object from a File and loading it into our sequencer:

    try {
        File myMidiFile = new File("seq1.mid");
        // Construct a Sequence object, and
        // load it into my sequencer.
         Sequence mySeq = MidiSystem.getSequence(myMidiFile);
        sequencer.setSequence(mySeq);
    } catch (Exception e) {
        // Handle error and/or return
    }

Like MidiSystem's getSequence method, setSequence may throw an InvalidMidiDataException—and, in the case of the InputStream variant, an IOException—if it runs into any trouble.

Playing a Sequence

Starting and stopping a Sequencer is accomplished using the following methods:

    void start()

and

    void stop()

The Sequencer.start method begins playback of the sequence. Note that playback starts at the current position in a sequence. Loading an existing sequence using the setSequence method, described above, initializes the sequencer's current position to the very beginning of the sequence. The stop method stops the sequencer, but it does not automatically rewind the current Sequence. Starting a stopped Sequence without resetting the position simply resumes playback of the sequence from the current position. In this case, the stop method has served as a pause operation. However, there are various Sequencer methods for setting the current sequence position to an arbitrary value before playback is started. (We'll discuss these methods below.)

As mentioned earlier, a Sequencer typically has one or more Transmitter objects, through which it sends MidiMessages to a Receiver. It is through these Transmitters that a Sequencer plays the Sequence, by emitting appropriately timed MidiMessages that correspond to the MidiEvents contained in the current Sequence. Therefore, part of the setup procedure for playing back a Sequence is to invoke the setReceiver method on the Sequencer's Transmitter object, in effect wiring its output to the device that will make use of the played-back data. For more details on Transmitters and Receivers, see Chapter 10, "Transmitting and Receiving MIDI Messages."

Recording and Saving Sequences

To capture MIDI data to a Sequence, and subsequently to a file, you need to perform some additional steps beyond those described above. The following outline shows the steps necessary to set up for recording to a Track in a Sequence:

  2. Use MidiSystem.getSequencer to get a new sequencer to use for recording, as above.
  3. Set up the "wiring" of the MIDI connections. The object that is transmitting the MIDI data to be recorded should be configured, through its setReceiver method, to send data to a Receiver associated with the recording Sequencer.
  4. Create a new Sequence object, which will store the recorded data. When you create the Sequence object, you must specify the global timing information for the sequence. For example:
          Sequence mySeq;
      try{
          mySeq = new Sequence(Sequence.PPQ, 10);
      } catch (Exception ex) {
          ex.printStackTrace();
      }
    The constructor for Sequence takes as arguments a divisionType and a timing resolution. The divisionType argument specifies the units of the resolution argument. In this case, we've specified that the timing resolution of the Sequence we're creating will be 10 pulses per quarter note. An additional optional argument to the Sequence constructor is a number of tracks argument, which would cause the initial sequence to begin with the specified number of (initially empty) Tracks. Otherwise the Sequence will be created with no initial Tracks; they can be added later as needed.
  5. Create an empty Track in the Sequence, with Sequence.createTrack. This step is unnecessary if the Sequence was created with initial Tracks.
  6. Using Sequencer.setSequence, select our new Sequence to receive the recording. The setSequence method ties together an existing Sequence with the Sequencer, which is somewhat analogous to loading a tape onto a tape recorder.
  7. Invoke Sequencer.recordEnable for each Track to be recorded. If necessary, get a reference to the available Tracks in the Sequence by invoking Sequence.getTracks.
  8. Invoke startRecording on the Sequencer.
  9. When done recording, invoke Sequencer.stop or Sequencer.stopRecording.
  10. Save the recorded Sequence to a MIDI file with MidiSystem.write. The write method of MidiSystem takes a Sequence as one of its arguments, and will write that Sequence to a stream or file.

Editing a Sequence

Many application programs allow a sequence to be created by loading it from a file, and quite a few also allow a sequence to be created by capturing it from live MIDI input (that is, recording). Some programs, however, will need to create MIDI sequences from scratch, whether programmatically or in response to user input. Full-featured sequencer programs permit the user to manually construct new sequences, as well as to edit existing ones.

These data-editing operations are achieved in the Java Sound API not by Sequencer methods, but by methods of the data objects themselves: Sequence, Track, and MidiEvent. You can create an empty sequence using one of the Sequence constructors, and then add tracks to it by invoking the following Sequence method:

    Track createTrack()
If your program allows the user to edit sequences, you'll need this Sequence method to remove tracks:
    boolean deleteTrack(Track track)

Once the sequence contains tracks, you can modify the contents of the tracks by invoking methods of the Track class. The MidiEvents contained in the Track are stored as a java.util.Vector in the Track object, and Track provides a set of methods for accessing, adding, and removing the events in the list. The methods add and remove are fairly self-explanatory, adding or removing a specified MidiEvent from a Track. A get method is provided, which takes an index into the Track's event list and returns the MidiEvent stored there. In addition, there are size and tick methods, which respectively return the number of MidiEvents in the track, and the track's duration, expressed as a total number of Ticks.

To create a new event before adding it to the track, you'll of course use the MidiEvent constructor. To specify or modify the MIDI message embedded in the event, you can invoke the setMessage method of the appropriate MidiMessage subclass (ShortMessage, SysexMessage, or MetaMessage). To modify the time that the event should occur, invoke MidiEvent.setTick.

In combination, these low-level methods provide the basis for the editing functionality needed by a full-featured sequencer program.

Using Advanced Sequencer Features

So far, this chapter has focused on simple playback and recording of MIDI data. This section will briefly describe some of the more advanced features available through methods of the Sequencer interface and the Sequence class.

Moving to an Arbitrary Position in the Sequence

There are two Sequencer methods that obtain the sequencer's current position in the sequence. The first of these:

    long getTickPosition()

returns the position measured in MIDI ticks from the beginning of the sequence. The second method:

long getMicrosecondPosition()

returns the current position in microseconds. This method assumes that the sequence is being played at the default rate as stored in the MIDI file or in the Sequence. It does not return a different value if you've changed the playback speed as described below.

You can similarly set the sequencer's current position according to one unit or the other:

void setTickPosition(long tick)

or

void setMicrosecondPosition(long microsecond)

Changing the Playback Speed

As indicated earlier, a sequence's speed is indicated by its tempo, which can vary over the course of the sequence. A sequence can contain events that encapsulate standard MIDI tempo-change messages. When the sequencer processes such an event, it changes the speed of playback to reflect the indicated tempo. In addition, you can programmatically change the tempo by invoking any of these Sequencer methods:

    public void setTempoInBPM(float bpm)
    public void setTempoInMPQ(float mpq)
    public void setTempoFactor(float factor)
The first two of these methods set the tempo in beats per minute or microseconds per quarter note, respectively. The tempo will stay at the specified value until one of these methods is invoked again, or until a tempo-change event is encountered in the sequence, at which point the current tempo is overridden by the newly specified one.

The third method, setTempoFactor, is different in nature. It scales whatever tempo is set for the sequencer (whether by tempo-change events or by one of the first two methods above). The default scalar is 1.0 (no change). Although this method causes the playback or recording to be faster or slower than the nominal tempo (unless the factor is 1.0), it doesn't alter the nominal tempo. In other words, the tempo values returned by getTempoInBPM and getTempoInMPQ are unaffected by the tempo factor, even though the tempo factor does affect the actual rate of playback or recording. Also, if the tempo is changed by a tempo-change event or by one of the first two methods, it still gets scaled by whatever tempo factor was last set. If you load a new sequence, however, the tempo factor is reset to 1.0.

Note that all these tempo-change directives are ineffectual when the sequence's division type is one of the SMPTE types, instead of PPQ.

Muting or Soloing Individual Tracks in the Sequence

It's often convenient for users of sequencers to be able to turn off certain tracks, to hear more clearly exactly what is happening in the music. A full-featured sequencer program lets the user choose which tracks should sound during playback. (Speaking more precisely, since sequencers don't actually create sound themselves, the user chooses which tracks will contribute to the stream of MIDI messages that the sequencer produces.) Typically, there are two types of graphical controls on each track: a mute button and a solo button. If the mute button is activated, that track will not sound under any circumstances, until the mute button is deactivated. Soloing is a less well-known feature. It's roughly the opposite of muting. If the solo button on any track is activated, only tracks whose solo buttons are activated will sound. This feature lets the user quickly audition a small number of tracks without having to mute all the other tracks. The mute button typically takes priority over the solo button: if both are activated, the track doesn't sound.

Using Sequencer methods, muting or soloing tracks (as well as querying a track's current mute or solo state) is easily accomplished. Let's assume we have obtained the default Sequencer and that we've loaded sequence data into it. Muting the fifth track in the sequence would be accomplished as follows:

    sequencer.setTrackMute(4, true);
    boolean muted = sequencer.getTrackMute(4);
    if (!muted) {
        return;         // muting failed
    }
There are a couple of things to note about the above code snippet. First, tracks of a sequence are numbered starting with 0 and ending with the total number of tracks minus 1. Also, the second argument to setTrackMute is a boolean. If it's true, the request is to mute the track; otherwise the request is to unmute the specified track. Lastly, in order to test that the muting took effect, we invoke the Sequencer getTrackMute method, passing it the track number we're querying. If it returns true, as we'd expect in this case, then the mute request worked. If it returns false, then it failed.

Mute requests may fail for various reasons. For example, the track number specified in the setTrackMute call might exceed the total number of tracks, or the sequencer might not support muting. By calling getTrackMute, we can determine if our request succeeded or failed.

As an aside, the boolean that's returned by getTrackMute can, indeed, tell us if a failure occurred, but it can't tell us why it occurred. We could test to see if a failure was caused by passing an invalid track number to the setTrackMute method. To do this, we would call the getTracks method of Sequence, which returns an array containing all of the tracks in the sequence. If the track number specified in the setTrackMute call exceeds the length of this array, then we know we specified an invalid track number.

If the mute request succeeded, then in our example, the fifth track will not sound when the sequence is playing, nor will any other tracks that are currently muted.

The method and techniques for soloing a track are very similar to those for muting. To solo a track, invoke the setTrackSolo method of Sequence:

void setTrackSolo(int track, boolean bSolo)
As in setTrackMute, the first argument specifies the zero-based track number, and the second argument, if true, specifies that the track should be in solo mode; otherwise the track should not be soloed.

By default, a track is neither muted nor soloed.

Synchronizing with Other MIDI Devices

Sequencer has an inner class called Sequencer.SyncMode. A SyncMode object represents one of the ways in which a MIDI sequencer's notion of time can be synchronized with a master or slave device. If the sequencer is being synchronized to a master, the sequencer revises its current time in response to certain MIDI messages from the master. If the sequencer has a slave, the sequencer similarly sends MIDI messages to control the slave's timing.

There are three predefined modes that specify possible masters for a sequencer: INTERNAL_CLOCK, MIDI_SYNC, and MIDI_TIME_CODE. The latter two work if the sequencer receives MIDI messages from another device. In these two modes, the sequencer's time gets reset based on system real-time timing clock messages or MIDI time code (MTC) messages, respectively. (See the MIDI specification for more information about these types of message.) These two modes can also be used as slave modes, in which case the sequencer sends the corresponding types of MIDI messages to its receiver. A fourth mode, NO_SYNC, is used to indicate that the sequencer should not send timing information to its receivers.

By calling the setMasterSyncMode method with a supported SyncMode object as the argument, you can specify how the sequencer's timing is controlled. Likewise, the setSlaveSyncMode method determines what timing information the sequencer will send to its receivers. This information controls the timing of devices that use the sequencer as a master timing source.

Specifying Special Event Listeners

Each track of a sequence can contain many different kinds of MidiEvents. Such events include Note On and Note Off messages, program changes, control changes, and meta events. The Java Sound API specifies "listener" interfaces for the last two of these event types (control change events and meta events). You can use these interfaces to receive notifications when such events occur during playback of a sequence.

Objects that support the ControllerEventListener interface can receive notification when a Sequencer processes particular control-change messages. A control-change message is a standard type of MIDI message that represents a change in the value of a MIDI controller, such as a pitch-bend wheel or a data slider. (See the MIDI specification for the complete list of control-change messages.) When such a message is processed during playback of a sequence, the message instructs any device (probably a synthesizer) that's receiving the data from the sequencer to update the value of some parameter. The parameter usually controls some aspect of sound synthesis, such as the pitch of the currently sounding notes if the controller was the pitch-bend wheel. When a sequence is being recorded, the control-change message means that a controller on the external physical device that created the message has been moved, or that such a move has been simulated in software.

Here's how the ControllerEventListener interface is used. Let's assume that you've developed a class that implements the ControllerEventListener interface, meaning that your class contains the following method:

    void controlChange(ShortMessage msg)
Let's also assume that you've created an instance of your class and assigned it to a variable called myListener. If you include the following statements somewhere within your program:
    int[] controllersOfInterest = { 1, 2, 4 };
    sequencer.addControllerEventListener(myListener,
        controllersOfInterest);
then your class's controlChange method will be invoked every time the sequencer processes a control-change message for MIDI controller numbers 1, 2, or 4. In other words, when the Sequencer processes a request to set the value of any of the registered controllers, the Sequencer will invoke your class's controlChange method. (Note that the assignments of MIDI controller numbers to specific control devices is detailed in the MIDI 1.0 Specification.)

The controlChange method is passed a ShortMessage containing the controller number affected, and the new value to which the controller was set. You can obtain the controller number using the ShortMessage.getData1 method, and the new setting of the controller's value using the ShortMessage.getData2 method.

The other kind of special event listener is defined by the MetaEventListener interface. Meta messages, according to the Standard MIDI Files 1.0 specification, are messages that are not present in MIDI wire protocol but that can be embedded in a MIDI file. They are not meaningful to a synthesizer, but can be interpreted by a sequencer. Meta messages include instructions (such as tempo change commands), lyrics or other text, and other indicators (such as end-of-track).

The MetaEventListener mechanism is analogous to ControllerEventListener. Implement the MetaEventListener interface in any class whose instances need to be notified when a MetaMessage is processed by the sequencer. This involves adding the following method to the class:

void meta(MetaMessage msg)

You register an instance of this class by passing it as the argument to the Sequencer addMetaEventListener method:

boolean b = sequencer.addMetaEventListener
        (myMetaListener);
This is slightly different from the approach taken by the ControllerEventListener interface, because you have to register to receive all MetaMessages, not just selected ones of interest. If the sequencer encounters a MetaMessage in its sequence, it will invoke myMetaListener.meta, passing it the MetaMessage encountered. The meta method can invoke getType on its MetaMessage argument to obtain an integer from 0 to 127 that indicates the message type, as defined by the Standard MIDI Files 1.0 specification.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 12: Synthesizing Sound

Most programs that avail themselves of the Java Sound API's MIDI package do so to synthesize sound. The entire apparatus of MIDI files, events, sequences, and sequencers, which was discussed in other chapters, nearly always has the goal of eventually sending musical data to a synthesizer to convert into audio. (Possible exceptions include programs that convert MIDI into musical notation that can be read by a musician, and programs that send messages to external MIDI-controlled devices such as mixing consoles.)

The Synthesizer interface is therefore fundamental to the MIDI package. This chapter shows how to manipulate a synthesizer to play sound. Many programs will simply use a sequencer to send MIDI file data to the synthesizer, and won't need to invoke many Synthesizer methods directly. However, it's possible to control a synthesizer directly, without using sequencers or even MidiMessage objects, as explained near the end of this chapter.

The synthesis architecture might seem complex for readers who are unfamiliar with MIDI. Its API includes three interfaces:

  • Synthesizer
  • MidiChannel
  • Soundbank

and four classes:
  • Instrument
  • Patch
  • SoundbankResource
  • VoiceStatus

As orientation for all this API, the next section explains some of the basics of MIDI synthesis and how they're reflected in the Java Sound API. (Also see the brief section "Synthesizers" under "The Java Sound API's Representation of MIDI Devices" in Chapter 8, "Overview of the MIDI Package.") Subsequent sections give a more detailed look at the API.

Understanding MIDI Synthesis

How does a synthesizer generate sound? Depending on its implementation, it may use one or more sound-synthesis techniques. For example, many synthesizers use wavetable synthesis. A wavetable synthesizer reads stored snippets of audio from memory, playing them at different sample rates and looping them to create notes of different pitches and durations. For example, to synthesize the sound of a saxophone playing the note C#a4 (MIDI note number 61), the synthesizer might access a very short snippet from a recording of a saxophone playing the note Middle C (MIDI note number 60), and then cycle repeatedly through this snippet at a slightly faster sample rate than it was recorded at, which creates a long note of a slightly higher pitch. Other synthesizers use techniques such as frequency modulation (FM), additive synthesis, or physical modeling, which don't make use of stored audio but instead generate audio from scratch using different algorithms.

Instruments

What all synthesis techniques have in common is the ability to create many sorts of sounds. Different algorithms, or different settings of parameters within the same algorithm, create different-sounding results. An instrument is a specification for synthesizing a certain type of sound. That sound may emulate a traditional musical instrument, such as a piano or violin; it may emulate some other kind of sound source, for instance, a telephone or helicopter; or it may emulate no "real-world" sound at all. A specification called General MIDI defines a standard list of 128 instruments, but most synthesizers allow other instruments as well. Many synthesizers provide a collection of built-in instruments that are always available for use; some synthesizers also support mechanisms for loading additional instruments.

An instrument may be vendor-specific—in other words, applicable to only one synthesizer or several models from the same vendor. This incompatibility results when two different synthesizers use different sound-synthesis techniques, or different internal algorithms and parameters even if the fundamental technique is the same. Because the details of the synthesis technique are often proprietary, incompatibility is common. The Java Sound API includes ways to detect whether a given synthesizer supports a given instrument.

An instrument can usually be considered a preset; you don't have to know anything about the details of the synthesis technique that produces its sound. However, you can still vary aspects of its sound. Each Note On message specifies the pitch and volume of an individual note. You can also alter the sound through other MIDI commands such as controller messages or system-exclusive messages.

Channels

Many synthesizers are multimbral (sometimes called polytimbral), meaning that they can play the notes of different instruments simultaneously. (Timbre is the characteristic sound quality that enables a listener to distinguish one kind of musical instrument from other kinds.) Multimbral synthesizers can emulate an entire ensemble of real-world instruments, instead of only one instrument at a time. MIDI synthesizers normally implement this feature by taking advantage of the different MIDI channels on which the MIDI specification allows data to be transmitted. In this case, the synthesizer is actually a collection of sound-generating units, each emulating a different instrument and responding independently to messages that are received on a different MIDI channel. Since the MIDI specification provides only 16 channels, a typical MIDI synthesizer can play up to 16 different instruments at once. The synthesizer receives a stream of MIDI commands, many of which are channel commands. (Channel commands are targeted to a particular MIDI channel; for more information, see the MIDI specification.) If the synthesizer is multitimbral, it routes each channel command to the correct sound-generating unit, according to the channel number indicated in the command.

In the Java Sound API, these sound-generating units are instances of classes that implement the MidiChannel interface. A synthesizer object has at least one MidiChannel object. If the synthesizer is multimbral, it has more than one, normally 16. Each MidiChannel represents an independent sound-generating unit.

Because a synthesizer's MidiChannel objects are more or less independent, the assignment of instruments to channels doesn't have to be unique. For example, all 16 channels could be playing a piano timbre, as though there were an ensemble of 16 pianos. Any grouping is possible—for instance, channels 1, 5, and 8 could be playing guitar sounds, while channels 2 and 3 play percussion and channel 12 has a bass timbre. The instrument being played on a given MIDI channel can be changed dynamically; this is known as a program change.

Even though most synthesizers allow only 16 or fewer instruments to be active at a given time, these instruments can generally be chosen from a much larger selection and assigned to particular channels as required.

Soundbanks and Patches

Instruments are organized hierarchically in a synthesizer. As was mentioned in Chapter 8, "Overview of the MIDI Package," the instruments are arranged by bank number and program number. Banks and programs can be thought of as rows and columns in a two-dimensional table of instruments. A bank is a collection of programs. The MIDI specification allows up to 128 programs in a bank, and up to 128 banks. However, a particular synthesizer might support only one bank, or a few banks, and might support fewer than 128 programs per bank.

In the Java Sound API, there's a higher level to the hierarchy: a soundbank. Soundbanks can contain up to 128 banks, each containing up to 128 instruments. Some synthesizers can load an entire soundbank into memory.

To select an instrument from the current soundbank, you specify a bank number and a program number. The MIDI specification accomplishes this with two MIDI commands: bank select and program change. In the Java Sound API, the combination of a bank number and program number is encapsulated in a Patch object. You change a MIDI channel's current instrument by specifying a new patch. The patch can be considered the two-dimensional index of the instruments in the current soundbank.

You might be wondering if soundbanks, too, are indexed numerically. The answer is no; the MIDI specification does not provide for this. In the Java Sound API, a Soundbank object can be obtained by reading a soundbank file. If the soundbank is supported by the synthesizer, its instruments can be loaded into the synthesizer individually as desired, or all at once. Many synthesizers have a built-in or default soundbank; the instruments contained in this soundbank are always available to the synthesizer.

Voices

It's important to distinguish between the number of timbres a synthesizer can play simultaneously and the number of notes it can play simultaneously. The former was described above under "Channels." The ability to play multiple notes at once is referred to as polyphony. Even a synthesizer that isn't multitimbral can generally play more than one note at a time (all having the same timbre, but different pitches). For example, playing any chord, such as a G major triad or a B minor seventh chord, requires polyphony. Any synthesizer that generates sound in real time has a limitation on the number of notes it can synthesize at once. In the Java Sound API, the synthesizer reports this limitation through the getMaxPolyphony method.

A voice is a succession of single notes, such as a melody that a person can sing. Polyphony consists of multiple voices, such as the parts sung by a choir. A 32-voice synthesizer, for example, can play 32 notes simultaneously. (However, some MIDI literature uses the word "voice" in a different sense, similar to the meaning of "instrument" or "timbre.")

The process of assigning incoming MIDI notes to specific voices is known as voice allocation. A synthesizer maintains a list of voices, keeping track of which ones are active (meaning that they currently have notes sounding). When a note stops sounding, the voice becomes inactive, meaning that it's now free to accept the next note-on request that the synthesizer receives. An incoming stream of MIDI commands can easily request more simultaneous notes than the synthesizer is capable of generating. When all the synthesizer's voices are active, how should the next Note On request be handled? Synthesizers can implement different strategies: the most recently requested note can be ignored; or it can be played by discontinuing another note, such as the least recently started one.

Although the MIDI specification does not require it, a synthesizer can make public the contents of each of its voices. The Java Sound API includes a VoiceStatus class for this purpose.

A VoiceStatus reports on the voice's current active or inactive status, MIDI channel, bank and program number, MIDI note number, and MIDI volume.

With this background, let's examine the specifics of the Java Sound API for synthesis.

Managing Instruments and Soundbanks

In many cases, a program can make use of a Synthesizer object without explicitly invoking almost any of the synthesis API. For example, suppose you're playing a standard MIDI file. You load it into a Sequence object, which you play by having a sequencer send the data to the default synthesizer. The data in the sequence controls the synthesizer as intended, playing all the right notes at the right times.

However, there are cases when this simple scenario is inadequate. The sequence contains the right music, but the instruments sound all wrong! This unfortunate situation probably arose because the creator of the MIDI file had different instruments in mind than the ones that are currently loaded into the synthesizer.

The MIDI 1.0 Specification provides for bank-select and program-change commands, which affect which instrument is currently playing on each MIDI channel. However, the specification does not define what instrument should reside in each patch location (bank and program number). The more recent General MIDI specification addresses this problem by defining a bank containing 128 programs that correspond to specific instrument sounds. A General MIDI synthesizer uses 128 instruments that match this specified set. Different General MIDI synthesizers can sound quite different, even when playing what's supposed to be the same instrument. However, a MIDI file should for the most part sound similar (even if not identical), no matter which General MIDI synthesizer is playing it.

Nonetheless, not all creators of MIDI files want to be limited to the set of 128 timbres defined by General MIDI. This section shows how to change the instruments from the default set that the synthesizer comes with. (If there is no default, meaning that no instruments are loaded when you access the synthesizer, you'll have to use this API to start with in any case.)

Learning What Instruments Are Loaded

To learn whether the instruments currently loaded into the synthesizer are the ones you want, you can invoke this Synthesizer method:

Instrument[] getLoadedInstruments()
and iterate over the returned array to see exactly which instruments are currently loaded. Most likely, you would display the instruments' names in the user interface (using the getName method of Instrument), and let the user decide whether to use those instruments or load others. The Instrument API includes a method that reports which soundbank the instrument belongs to. The soundbank's name might help your program or the user ascertain exactly what the instrument is.

This Synthesizer method:

Soundbank getDefaultSoundbank()
gives you the default soundbank. The Soundbank API includes methods to retrieve the soundbank's name, vendor, and version number, by which the program or the user can verify the bank's identity. However, you can't assume when you first get a synthesizer that the instruments from the default soundbank have been loaded into the synthesizer. For example, a synthesizer might have a large assortment of built-in instruments available for use, but because of its limited memory it might not load them automatically.

Loading Different Instruments

The user might decide to load instruments that are different from the current ones (or you might make that decision programmatically). The following method tells you which instruments come with the synthesizer (versus having to be loaded from soundbank files):

Instrument[] getAvailableInstruments()
You can load any of these instruments by invoking:
boolean loadInstrument(Instrument instrument)
The instrument gets loaded into the synthesizer in the location specified by the instrument's Patch object (which can be retrieved using the getPatch method of Instrument).

To load instruments from other soundbanks, first invoke Synthesizer's isSupportedSoundbank method to make sure that the soundbank is compatible with this synthesizer (if it isn't, you can iterate over the system's synthesizers to try to find one that supports the soundbank). You can then invoke one of these methods to load instruments from the soundbank:

boolean loadAllInstruments(Soundbank soundbank)
boolean loadInstruments(Soundbank soundbank,
  Patch[] patchList)
As the names suggest, the first of these loads the entire set of instruments from a given soundbank, and the second loads selected instruments from the soundbank. You could also use Soundbank's getInstruments method to access all the instruments, then iterate over them and load selected instruments one at a time using loadInstrument.

It's not necessary for all the instruments you load to be from the same soundbank. You could use loadInstrument or loadInstruments to load certain instruments from one soundbank, another set from a different soundbank, and so on.

Each instrument has its own Patch object that specifies the location on the synthesizer where the instrument should be loaded. The location is defined by a bank number and a program number. There's no API to change the location by changing the patch's bank or program number.

However, it is possible to load an instrument into a location other than the one specified by its patch, using the following method of Synthesizer:

boolean remapInstrument(Instrument from, Instrument to)
This method unloads its first argument from the synthesizer, and places its second argument in whatever synthesizer patch location had been occupied by the first argument.

Unloading Instruments

Loading an instrument into a program location automatically unloads whatever instrument was already at that location, if any. You can also explicitly unload instruments without necessarily replacing them with new ones. Synthesizer includes three unloading methods that correspond to the three loading methods. If the synthesizer receives a program-change message that selects a program location where no instrument is currently loaded, there won't be any sound from the MIDI channel on which the program-change message was sent.

Accessing Soundbank Resources

Some synthesizers store other information besides instruments in their soundbanks. For example, a wavetable synthesizer stores audio samples that one or more instruments can access. Because the samples might be shared by multiple instruments, they're stored in the soundbank independently of any instrument. Both the Soundbank interface and the Instrument class provide a method call getSoundbankResources, which returns a list of SoundbankResource objects. The details of these objects are specific to the synthesizer for which the soundbank is designed. In the case of wavetable synthesis, a resource might be an object that encapsulates a series of audio samples, taken from one snippet of a sound recording. Synthesizers that use other synthesis techniques might store other kinds of objects in the synthesizer's SoundbankResources array.

Querying the Synthesizer's Capabilities and Current State

The Synthesizer interface includes methods that return information about the synthesizer's capabilities:

    public long getLatency()
    public int getMaxPolyphony()
The latency measures the worst-case delay between the time a MIDI message is delivered to the synthesizer and the time that the synthesizer actually produces the corresponding result. For example, it might take a synthesizer a few milliseconds to begin generating audio after receiving a note-on event.

The getMaxPolyphony method indicates how many notes the synthesizer can sound simultaneously, as discussed under "Voices" in the section "Understanding MIDI Synthesis" earlier in this chapter. As mentioned in the same discussion, a synthesizer can provide information about its voices. This is accomplished through the following method:

public VoiceStatus[] getVoiceStatus()
Each VoiceStatus in the returned array reports the voice's current active or inactive status, MIDI channel, bank and program number, MIDI note number, and MIDI volume. The array's length should normally be the same number returned by getMaxPolyphony. If the synthesizer isn't playing, all its VoiceStatus objects have their active field set to false.

You can learn additional information about the current status of a synthesizer by retrieving its MidiChannel objects and querying their state. This is discussed more in the next section.

Using Channels

Sometimes it's useful or necessary to access a synthesizer's MidiChannel objects directly. This section discusses such situations.

Controlling the Synthesizer without Using a Sequencer

When using a sequence, such as one read from a MIDI file, you don't need to send MIDI commands to the synthesizer yourself. Instead, you just load the sequence into a sequencer, connect the sequencer to the synthesizer, and let it run. The sequencer takes care of scheduling the events, and the result is a predictable musical performance. This scenario works fine when the desired music is known in advance, which is true when it's read from a file.

In some situations, however, the music is generated on the fly as it's playing. For example, the user interface might display a musical keyboard or a guitar fretboard and let the user play notes at will by clicking with the mouse. As another example, an application might use a synthesizer not to play music per se, but to generate sound effects in response to the user's actions. This scenario is typical of games. As a final example, the application might indeed be playing music that's read from a file, but the user interface allows the user to interact with the music, altering it dynamically. In all these cases, the application sends commands directly to the synthesizer, since the MIDI messages need to be delivered immediately, instead of being scheduled for some determinate point in the future.

There are at least two ways of sending a MIDI message to the synthesizer without using a sequencer. The first is to construct a MidiMessage and pass it to the synthesizer using the send method of Receiver. For example, to produce a Middle C (MIDI note number 60) on MIDI channel 5 (one-based) immediately, you could do the following:

    ShortMessage myMsg = new ShortMessage();
    // Play the note Middle C (60) moderately loud
    // (velocity = 93)on channel 4 (zero-based).
    myMsg.setMessage(ShortMessage.NOTE_ON, 4, 60, 93);
    Synthesizer synth = MidiSystem.getSynthesizer();
    Receiver synthRcvr = synth.getReceiver();
    synthRcvr.send(myMsg, -1); // -1 means no time stamp
The second way is to bypass the message-passing layer (that is, the MidiMessage and Receiver API) altogether, and interact with the synthesizer's MidiChannel objects directly. You first need to retrieve the synthesizer's MidiChannel objects, using the following Synthesizer method:
public MidiChannel[] getChannels()
after which you can invoke the desired MidiChannel methods directly. This is a more immediate route than sending the corresponding MidiMessages to the synthesizer's Receiver and letting the synthesizer handle the communication with its own MidiChannels. For example, the code corresponding to the preceding example would be:
    Synthesizer synth = MidiSystem.getSynthesizer();
    MidiChannel chan[] = synth.getChannels();
    // Check for null; maybe not all 16 channels exist.
    if (chan[4] != null) {
         chan[4].noteOn(60, 93);
    }

Getting a Channel's Current State

The MidiChannel interface provides methods that correspond one-to-one to each of the "channel voice" or "channel mode" messages defined by the MIDI specification. We saw one case with the use of the noteOn method in the previous example. However, in addition to these canonical methods, the Java Sound API's MidiChannel interface adds some "get" methods to retrieve the value most recently set by corresponding voice or mode "set" methods:

    int       getChannelPressure()
    int       getController(int controller)
    boolean   getMono()
    boolean   getOmni()
    int       getPitchBend()
    int       getPolyPressure(int noteNumber)
    int       getProgram()
These methods might be useful for displaying channel state to the user, or for deciding what values to send subsequently to the channel.

Muting and Soloing a Channel

The Java Sound API adds the notions of per-channel solo and mute, which are not required by the MIDI specification. These are similar to the solo and mute on the tracks of a MIDI sequence. (See "Muting or Soloing Individual Tracks in the Sequence" in Chapter 11, "Playing, Recording, and Editing MIDI Sequences.)"

If mute is on, this channel will not sound, but other channels are unaffected. If solo is on, this channel, and any other soloed channel, will sound (if it isn't muted), but no other channels will sound. A channel that is both soloed and muted will not sound. The MidiChannel API includes four methods:

    boolean      getMute()
    boolean      getSolo()
    void         setMute(boolean muteState)
    void         setSolo(boolean soloState)

Permission to Play Synthesized Sound

The audio produced by any installed MIDI synthesizer is typically routed through the sampled-audio system. If your program doesn't have permission to play audio, the synthesizer's sound won't be heard, and a security exception will be thrown. For more information on audio permissions, see "Permission to Use Audio Resources" in Chapter 3, "Accessing Audio System Resources."

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 13: Introduction to the Service Provider Interfaces

Note

For version 5.0, new constructors for AudioFormat, AudioFileFormat, and MidiFileFormat allow the description of more advanced formats.

What Are Services?

Services are units of sound-handling functionality that are automatically available when an application program makes use of an implementation of the Java Sound API. They consist of objects that do the work of reading, writing, mixing, processing, and converting audio and MIDI data. An implementation of the Java Sound API generally supplies a basic set of services, but mechanisms are also included in the API to support the development of new sound services by third-party developers (or by the vendor of the implementation itself). These new services can be "plugged into" an existing installed implementation to expand its functionality without requiring a new release. In the Java Sound API architecture, third-party services are integrated into the system in such a way that an application program's interface to them is the same as the interface to the "built-in" services. In some cases, application developers who use the javax.sound.sampled and javax.sound.midi packages might not even be aware that they are employing third-party services.

Examples of potential third-party, sampled-audio services include:

  • Sound file readers and writers
  • Converters that translate between different audio data formats
  • New audio mixers and input/output devices, whether implemented purely in software, or in hardware with a software interface
Third-party MIDI services might consist of:
  • MIDI file readers and writers
  • Readers for various types of soundbank files (which are often specific to particular synthesizers)
  • MIDI-controlled sound synthesizers, sequencers, and I/O ports, whether implemented purely in software, or in hardware with a software interface

How Services Work

The javax.sound.sampled and javax.sound.midi packages provide functionality to application developers who wish to include sound services in their application programs. These packages are for consumers of sound services, providing interfaces to get information about, control, and access audio and MIDI services. In addition, the Java Sound API also supplies two packages that define abstract classes to be used by providers of sound services: the javax.sound.sampled.spi and javax.sound.midi.spi packages.

Developers of new sound services implement concrete subclasses of the appropriate classes in the SPI packages. These subclasses, along with any additional classes required to support the new service, are placed in a Java Archive (JAR) archive file with a description of the included service or services. When this JAR file is installed in the user's CLASSPATH, the runtime system automatically makes the new service available, extending the functionality of the Java platform's runtime system.

Once the new service is installed, it can be accessed just like any previously installed service. Consumers of services can get information about the new service, or obtain instances of the new service class itself, by invoking methods of the AudioSystem and MidiSystem classes (in the javax.sound.sampled and javax.sound.midi packages, respectively) to return information about the new services, or to return instances of new or existing service classes themselves. Application programs need not—and should not—reference the classes in the SPI packages (and their subclasses) directly to make use of the installed services.

For example, suppose a hypothetical service provider called Acme Software, Inc. is interested in supplying a package that allows application programs to read a new format of sound file (but one whose audio data is in a standard data format). The SPI class AudioFileReader can be subclassed into a class called, say, AcmeAudioFileReader. In the new subclass, Acme would supply implementations of all the methods defined in AudioFileReader; in this case there are only two methods (with argument variants), getAudioFileFormat and getAudioInputStream. Then when an application program attempted to read a sound file that happened to be in Acme's file format, it would invoke methods of the AudioSystem class in javax.sound.sampled to access the file and information about it. The methods AudioSystem.getAudioInputStream and AudioSystem.getAudioFileFormat provide a standard API to read audio streams; with the AcmeAudioFileReader class installed, this interface is extended to support the new file type transparently. Application developers don't need direct access to the newly registered SPI classes: the AudioSystem object methods pass the query on to the installed AcmeAudioFileReader class.

What's the point of having these "factory" classes? Why not permit the application developer to get access directly to newly provided services? That is a possible approach, but having all management and instantiation of services pass through gatekeeper system objects shields the application developer from having to know anything about the identity of installed services. Application developers just use services of value to them, perhaps without even realizing it. At the same time this architecture permits service providers to effectively manage the available resources in their packages.

Often the use of new sound services is transparent to the application program. For example, imagine a situation where an application developer wants to read in a stream of audio from a file. Assuming that thePathName identifies an audio input file, the program does this:

    File theInFile = new File(thePathName);
    AudioInputStream theInStream = AudioSystem.getAudioInputStream(theInFile);
Behind the scenes, the AudioSystem determines what installed service can read the file and asks it to supply the audio data as an AudioInputStream object. The developer might not know or even care that the input audio file is in some new file format (such as Acme's), supported by installed third-party services. The program's first contact with the stream is through the AudioSystem object, and all its subsequent access to the stream and its properties are through the methods of AudioInputStream. Both of these are standard objects in the javax.sound.sampled API; the special handling that the new file format may require is completely hidden.

How Providers Prepare New Services

Service providers supply their new services in specially formatted JAR files, which are to be installed in a directory on the user's system where the Java runtime will find them. JAR files are archive files, each containing sets of files that might be organized in hierarchical directory structures within the archive. Details about the preparation of the class files that go into these archives are discussed in Chapters 14 and 15, which describe the specifics of the audio and MIDI SPI packages; here we'll just give an overview of the process of JAR file creation.

The JAR file for a new service or services should contain a class file for each service supported in the JAR file. Following the Java platform's convention, each class file has the name of the newly defined class, which is a concrete subclass of one of the abstract service provider classes. The JAR file also must include any supporting classes required by the new service implementation. So that the new service or services can be located by the runtime system's service provider mechanism, the JAR file must also contain special files (described below) that map the SPI class names to the new subclasses being defined.

To continue from our example above, say Acme Software, Inc. is distributing a package of new sampled-audio services. Let's suppose this package consists of two new services:

  • The AcmeAudioFileReader class, which was mentioned above, and which is a subclass of AudioFileReader
  • A subclass of AudioFileWriter called AcmeAudioFileWriter, which will write sound files in Acme's new format
Starting from an arbitrary directory—let's call it /devel—where we want to do the build, we create subdirectories and put the new class files in them, organized in such a manner as to give the desired pathname by which the new classes will be referenced:
    com/acme/AcmeAudioFileReader.class
    com/acme/AcmeAudioFileWriter.class
In addition, for each new SPI class being subclassed, we create a mapping file in a specially named directory META-INF/services. The name of the file is the name of the SPI class being subclassed, and the file contains the names of the new subclasses of that SPI abstract class.

We create the file

META-INF/services/javax.sound.sampled.spi.AudioFileReader, which consists of

    # Providers of sound file-reading services
    # (a comment line begins with a pound sign)
    com.acme.AcmeAudioFileReader

and also the file

META-INF/services/javax.sound.sampled.spi.AudioFileWriter, which consists of

   # Providers of sound file-writing services
    com.acme.AcmeAudioFileWriter

Now we run jar from any directory with the command line:

jar cvf acme.jar -C /devel .
The -C option causes jar to switch to the /devel directory, instead of using the directory in which the command is executed. The final period argument instructs jar to archive all the contents of that directory (namely, /devel), but not the directory itself.

This run will create the file acme.jar with the contents:

com/acme/AcmeAudioFileReader.class
com/acme/AcmeAudioFileWriter.class
META-INF/services/javax.sound.sampled.spi.AudioFileReader
META-INF/services/javax.sound.sampled.spi.AudioFileWriter
META-INF/Manifest.mf
The file Manifest.mf, which is generated by the jar utility itself, is a list of all the files contained in the archive.

How Users Install New Services

For end users (or system administrators) who wish to get access to a new service through their application programs, installation is simple. They place the provided JAR file in a directory in their CLASSPATH. Upon execution, the Java runtime will find the referenced classes when needed.

It's not an error to install more than one provider for the same service. For example, two different service providers might supply support for reading the same type of sound file. In such a case, the system arbitrarily chooses one of the providers. Users who care which provider is chosen should install only the desired one.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 14: Providing Sampled-Audio Services

As discussed in Chapter 13, "Introduction to the Service Provider Interfaces," the Java Sound API includes two packages, javax.sound.sampled.spi and javax.sound.midi.spi, that define abstract classes to be used by developers of sound services. By implementing and installing a subclass of one of these abstract classes, a service provider registers the new service, extending the functionality of the runtime system. The present chapter tells you how to go about using the javax.sound.sampled.spi package to provide new services for handling sampled audio.

This chapter can be safely skipped by application programmers who merely wish to use existing audio services in their programs. For the use of the installed audio services in an application program, see Part I, "Sampled Audio," of this Programmer's Guide. This chapter assumes that the reader is familiar with the Java Sound API methods that application programs invoke to access installed audio services.

Introduction

There are four abstract classes in the javax.sound.sampled.spi package, representing four different types of services that you can provide for the sampled-audio system:

  • AudioFileWriter provides sound file-writing services. These services make it possible for an application program to write a stream of audio data to a file of a particular type.
  • AudioFileReader provides file-reading services. These services enable an application program to ascertain a sound file's characteristics, and to obtain a stream from which the file's audio data can be read.
  • FormatConversionProvider provides services for converting audio data formats. These services allow an application program to translate audio streams from one data format to another.
  • MixerProvider provides management of a particular kind of mixer. This mechanism allows an application program to obtain information about, and access instances of, a given kind of mixer.

To recapitulate the discussion in Chapter 13, service providers can extend the functionality of the runtime system. A typical SPI class has two types of methods: ones that respond to queries about the types of services available from a particular provider, and ones that either perform the new service directly, or return instances of objects that actually provide the service. The runtime environment's service-provider mechanism provides registration of installed services with the audio system, and management of the new service provider classes.

In essence there is a double isolation of the service instances from the application developer. An application program never directly creates instances of the service objects, such as mixers or format converters, that it needs for its audio processing tasks. Nor does the program even directly request these objects from the SPI classes that administer them. The application program makes requests to the AudioSystem object in the javax.sound.sampled package, and AudioSystem in turn uses the SPI objects to process these queries and service requests.

The existence of new audio services might be completely transparent to both the user and the application programmer. All application references are through standard objects of the javax.sound.sampled package, primarily AudioSystem, and the special handling that new services might be providing is often completely hidden.

In this chapter, we'll continue the previous chapter's convention of referring to new SPI subclasses by names like AcmeMixer and AcmeMixerProvider.

Providing Audio File-Writing Services

Let's start with AudioFileWriter, one of the simpler SPI classes.

A subclass that implements the methods of AudioFileWriter must provide implementations of a set of methods to handle queries about the file formats and file types supported by the class, as well as provide methods that actually write out a supplied audio data stream to a File or OutputStream.

AudioFileWriter includes two methods that have concrete implementations in the base class:

boolean isFileTypeSupported(AudioFileFormat.Type fileType)
boolean isFileTypeSupported(AudioFileFormat.Type fileType,
    AudioInputStream stream)
The first of these methods informs the caller whether this file writer can write sound files of the specified type. This method is a general inquiry, it will return true if the file writer can write that kind of file, assuming the file writer is handed appropriate audio data. However, the ability to write a file can depend on the format of the specific audio data that's handed to the file writer. A file writer might not support every audio data format, or the constraint might be imposed by the file format itself. (Not all kinds of audio data can be written to all kinds of sound files.) The second method is more specific, then, asking whether a particular AudioInputStream can be written to a particular type of file.

Generally, you won't need to override these two concrete methods. Each is simply a wrapper that invokes one of two other query methods and iterates over the results returned. These other two query methods are abstract and therefore need to be implemented in the subclass:

abstract AudioFileFormat.Type[] getAudioFileTypes()
abstract AudioFileFormat.Type[]
    getAudioFileTypes(AudioInputStream stream)
These methods correspond directly to the previous two. Each returns an array of all the supported file types-all that are supported in general, in the case of the first method, and all that are supported for a specific audio stream, in the case of the second method. A typical implementation of the first method might simply return an array that the file writer's constructor initializes. An implementation of the second method might test the stream's AudioFormat object to see whether it's a data format that the requested type of file supports.

The final two methods of AudioFileWriter do the actual file-writing work:

abstract  int write(AudioInputStream stream,
    AudioFileFormat.Type fileType, java.io.File out)
 abstract  int write(AudioInputStream stream,
    AudioFileFormat.Type fileType, java.io.OutputStream out)
These methods write a stream of bytes representing the audio data to the stream or file specified by the third argument. The details of how this is done depend on the structure of the specified type of file. The write method must write the file's header and the audio data in the manner prescribed for sound files of this format (whether it's a standard type of sound file or a new, possibly proprietary one).

Providing Audio File-Reading Services

The AudioFileReader class consists of six abstract methods that your subclass needs to implement-actually, two different overloaded methods, each of which can take a File, URL, or InputStream argument. The first of these overloaded methods accepts queries about the file format of a specified file:

abstract AudioFileFormat getAudioFileFormat(
    java.io.File file)
abstract AudioFileFormat getAudioFileFormat(
    java.io.InputStream stream)
abstract AudioFileFormat getAudioFileFormat(
    java.net.URL url)
A typical implementation of getAudioFileFormat method reads and parses the sound file's header to ascertain its file format. See the description of the AudioFileFormat class to see what fields need to be read from the header, and refer to the specification for the particular file type to figure out how to parse the header.

Because the caller providing a stream as an argument to this method expects the stream to be unaltered by the method, the file reader should generally start by marking the stream. After reading to the end of the header, it should reset the stream to its original position.

The other overloaded AudioFileReader method provides file-reading services, by returning an AudioInputStream from which the file's audio data can be read:

abstract AudioInputStream getAudioInputStream(
    java.io.File file)
abstract AudioInputStream getAudioInputStream(
     java.io.InputStream stream)
abstract AudioInputStream getAudioInputStream(
     java.net.URL url)
Typically, an implementation of getAudioInputStream returns an AudioInputStream wound to the beginning of the file's data chunk (after the header), ready for reading. It would be conceivable, though, for a file reader to return an AudioInputStream whose audio format represents a stream of data that is in some way decoded from what is contained in the file. The important thing is that the method return a formatted stream from which the audio data contained in the file can be read. The AudioFormat encapsulated in the returned AudioInputStream object will inform the caller about the stream's data format, which is usually, but not necessarily, the same as the data format in the file itself.

Generally, the returned stream is an instance of AudioInputStream; it's unlikely you would ever need to subclass AudioInputStream.

Providing Format-Conversion Services

A FormatConversionProvider subclass transforms an AudioInputStream that has one audio data format into one that has another format. The former (input) stream is referred to as the source stream, and the latter (output) stream is referred to as the target stream. Recall from Chapter 2, "Overview of the Sampled Package," that an AudioInputStream contains an AudioFormat, and the AudioFormat in turn contains a particular type of data encoding, represented by an AudioFormat.Encoding object. The format and encoding in the source stream are called the source format and source encoding, and those in the target stream are likewise called the target format and target encoding.

The work of conversion is performed in the overloaded abstract method of FormatConversionProvider called getAudioInputStream. The class also has abstract query methods for learning about all the supported target and source formats and encodings. There are concrete wrapper methods for querying about a specific conversion.

The two variants of getAudioInputStream are:

abstract AudioInputStream getAudioInputStream(
    AudioFormat.Encoding targetEncoding,
    AudioInputStream sourceStream)
and
abstract AudioInputStream getAudioInputStream(
    AudioFormat targetFormat,
    AudioInputStream sourceStream)
These differ in the first argument, according to whether the caller is specifying a complete target format or just the format's encoding.

A typical implementation of getAudioInputStream works by returning a new subclass of AudioInputStream that wraps around the original (source) AudioInputStream and applies a data format conversion to its data whenever a read method is invoked. For example, consider the case of a new FormatConversionProvider subclass called AcmeCodec, which works with a new AudioInputStream subclass called AcmeCodecStream.

The implementation of AcmeCodec's second getAudioInputStream method might be:

public AudioInputStream getAudioInputStream
      (AudioFormat outputFormat, AudioInputStream stream) {
        AudioInputStream cs = null;
        AudioFormat inputFormat = stream.getFormat();
        if (inputFormat.matches(outputFormat) ) {
            cs = stream;
        } else {
            cs = (AudioInputStream)
                (new AcmeCodecStream(stream, outputFormat));
            tempBuffer = new byte[tempBufferSize];
        }
        return cs;
    }
The actual format conversion takes place in new read methods of the returned AcmeCodecStream, a subclass of AudioInputStream. Again, application programs that access this returned AcmeCodecStream simply operate on it as an AudioInputStream, and don't need to know the details of its implementation.

The other methods of a FormatConversionProvider all permit queries about the input and output encodings and formats that the object supports. The following four methods, being abstract, need to be implemented:

abstract AudioFormat.Encoding[] getSourceEncodings()
abstract AudioFormat.Encoding[] getTargetEncodings()
abstract AudioFormat.Encoding[] getTargetEncodings(
    AudioFormat sourceFormat)
abstract  AudioFormat[] getTargetFormats(
    AudioFormat.Encoding targetEncoding,
    AudioFormat sourceFormat)

As in the query methods of the AudioFileReader class discussed above, these queries are typically handled by checking private data of the object and, for the latter two methods, comparing them against the argument(s).

The remaining four FormatConversionProvider methods are concrete and generally don't need to be overridden:

boolean isConversionSupported(
    AudioFormat.Encoding targetEncoding,
    AudioFormat sourceFormat)
boolean isConversionSupported(AudioFormat targetFormat,
    AudioFormat sourceFormat)
boolean isSourceEncodingSupported(
    AudioFormat.Encoding sourceEncoding)
boolean isTargetEncodingSupported(
    AudioFormat.Encoding targetEncoding)
As with AudioFileWriter.isFileTypeSupported(), the default implementation of each of these methods is essentially a wrapper that invokes one of the other query methods and iterates over the results returned.

Providing New Types of Mixers

As its name implies, a MixerProvider supplies instances of mixers. Each concrete MixerProvider subclass acts as a factory for the Mixer objects used by an application program. Of course, defining a new MixerProvider only makes sense if one or more new implementations of the Mixer interface are also defined. As in the FormatConversionProvider example above, where our getAudioInputStream method returned a subclass of AudioInputStream that performed the conversion, our new class AcmeMixerProvider has a method getMixer that returns an instance of another new class that implements the Mixer interface. We'll call the latter class AcmeMixer. Particularly if the mixer is implemented in hardware, the provider might support only one static instance of the requested device. If so, it should return this static instance in response to each invocation of getMixer.

Since AcmeMixer supports the Mixer interface, application programs don't require any additional information to access its basic functionality. However, if AcmeMixer supports functionality not defined in the Mixer interface, and the vendor wants to make this extended functionality accessible to application programs, the mixer should of course be defined as a public class with additional, well-documented public methods, so that a program that wishes to make use of this extended functionality can import AcmeMixer and cast the object returned by getMixer to this type.

The other two methods of MixerProvider are:

abstract Mixer.Info[] getMixerInfo()
and
boolean isMixerSupported(Mixer.Info info)
These methods allow the audio system to determine whether this particular provider class can produce a device that an application program needs. In other words, the AudioSystem object can iterate over all the installed MixerProviders to see which ones, if any, can supply the device that the application program has requested of the AudioSystem. (See the discussion under "Getting a Mixer" in Chapter 3, "Accessing Audio System Resources.") The getMixerInfo method returns an array of objects containing information about the kinds of mixer available from this provider object. The system can pass these information objects, along with those from other providers, to an application program.

A single MixerProvider can provide more than one kind of mixer. When the system invokes the MixerProvider's getMixerInfo method, it gets a list of information objects identifying the different kinds of mixer that this provider supports. The system can then invoke MixerProvider.getMixer(Mixer.Info) to obtain each mixer of interest.

Your subclass needs to implement getMixerInfo, as it's abstract. The isMixerSupported method is concrete and doesn't generally need to be overridden. The default implementation simply compares the provided Mixer.Info to each one in the array returned by getMixerInfo.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Chapter 15: Providing MIDI Services

Chapter 13, "Introduction to the Service Provider Interfaces," explained that the javax.sound.sampled.spi and javax.sound.midi.spi packages define abstract classes to be used by developers of sound services. By implementing a subclass of one of these abstract classes, a service provider can create a new service that extends the functionality of the runtime system. Chapter 14 covered the use of the javax.sound.sampled.spi package. The present chapter discusses how to use the javax.sound.midi.spi package to provide new services for handling MIDI devices and files.

Applications programmers who only use existing MIDI services in their programs can safely skip this chapter. For an overview of MIDI and the use of the installed MIDI services in an application program, see Part II, "MIDI," of this Programmer's Guide. This chapter assumes that the reader is familiar with the Java Sound API methods that application programs invoke to access installed MIDI services.

Introduction

There are four abstract classes in the javax.sound.midi.spi package, which represent four different types of services that you can provide for the MIDI system:

  • MidiFileWriter provides MIDI file-writing services. These services make it possible for an application program to save, to a MIDI file, a MIDI Sequence that it has generated or processed.
  • MidiFileReader provides file-reading services that return a MIDI Sequence from a MIDI file for use in an application program.
  • MidiDeviceProvider supplies instances of one or more specific types of MIDI device, possibly including hardware devices.
  • SoundbankReader supplies soundbank file-reading services. Concrete subclasses of SoundbankReader parse a given soundbank file, producing a Soundbank object that can be loaded into a Synthesizer.

An application program will not directly create an instance of a service object—whether a provider object, such as a MidiDeviceProvider, or an object, such as a Synthesizer, that is supplied by the provider object. Nor will the program directly refer to the SPI classes. Instead, the application program makes requests to the MidiSystem object in the javax.sound.midi package, and MidiSystem in turn uses concrete subclasses of the javax.sound.midi.spi classes to process these requests.

Providing MIDI File-Writing Services

There are three standard MIDI file formats, all of which an implementation of the Java Sound API can support: Type 0, Type 1, and Type 2. These file formats differ in their internal representation of the MIDI sequence data in the file, and are appropriate for different kinds of sequences. If an implementation doesn't itself support all three types, a service provider can supply the support for the unimplemented ones. There are also variants of the standard MIDI file formats, some of them proprietary, which similarly could be supported by a third-party vendor.

The ability to write MIDI files is provided by concrete subclasses of MidiFileWriter. This abstract class is directly analogous to javax.sampled.spi.AudioFileWriter. Again, the methods are grouped into query methods for learning what types of files can be written, and methods for actually writing a file. As with AudioFileWriter, two of the query methods are concrete:

boolean isFileTypeSupported(int fileType)
boolean isFileTypeSupported(int fileType, Sequence sequence)
The first of these provides general information about whether the file writer can ever write the specified type of MIDI file type. The second method is more specific: it asks whether a particular Sequence can be written to the specified type of MIDI file. Generally, you don't need to override either of these two concrete methods. In the default implementation, each invokes one of two other corresponding query methods and iterates over the results returned. Being abstract, these other two query methods need to be implemented in the subclass:
abstract int[] getMidiFileTypes()
abstract int[] getMidiFileTypes(Sequence sequence)
The first of these returns an array of all the file types that are supported in general. A typical implementation might initialize the array in the file writer's constructor and return the array from this method. From that set of file types, the second method finds the subset to which the file writer can write the given Sequence. In accordance with the MIDI specification, not all types of sequences can be written to all types of MIDI files.

The write methods of a MidiFileWriter subclass perform the encoding of the data in a given Sequence into the correct data format for the requested type of MIDI file, writing the coded stream to either a file or an output stream:

abstract int write(Sequence in, int fileType,
                   java.io.File out)
abstract int write(Sequence in, int fileType,
                   java.io.OutputStream out)
To do this, the write method must parse the Sequence by iterating over its tracks, construct an appropriate file header, and write the header and tracks to the output. The MIDI file's header format is, of course, defined by the MIDI specification. It includes such information as a "magic number" identifying this as a MIDI file, the header's length, the number of tracks, and the sequence's timing information (division type and resolution). The rest of the MIDI file consists of the track data, in the format defined by the MIDI specification.

Let's briefly look at how the application program, MIDI system, and service provider cooperate in writing a MIDI file. In a typical situation, an application program has a particular MIDI Sequence to save to a file. The program queries the MidiSystem object to see what MIDI file formats, if any, are supported for the particular Sequence at hand, before attempting to write the file. The MidiSystem.getMidiFileTypes(Sequence) method returns an array of all the MIDI file types to which the system can write a particular sequence. It does this by invoking the corresponding getMidiFileTypes method for each of the installed MidiFileWriter services, and collecting and returning the results in an array of integers that can be thought of as a master list of all file types compatible with the given Sequence. When it comes to writing the Sequence to a file, the call to MidiSystem.write is passed an integer representing a file type, along with the Sequence to be written and the output file; MidiSystem uses the supplied type to decide which installed MidiFileWriter should handle the write request, and dispatches a corresponding write to the appropriate MidiFileWriter.

Providing MIDI File-Reading Services

The MidiFileReader abstract class is directly analogous to javax.sampled.spi.AudioFileReader class. Both consist of two overloaded methods, each of which can take a File, URL, or InputStream argument. The first of the overloaded methods returns the file format of a specified file. In the case of MidiFileReader, the API is:

abstract MidiFileFormat getMidiFileFormat(java.io.File file)
abstract MidiFileFormat getMidiFileFormat(
    java.io.InputStream stream)
abstract MidiFileFormat getMidiFileFormat(java.net.URL url)
Concrete subclasses must implement these methods to return a filled-out MidiFileFormat object describing the format of the specified MIDI file (or stream or URL), assuming that the file is of a type supported by the file reader and that it contains valid header information. Otherwise, an InvalidMidiDataException should be thrown.

The other overloaded method returns a MIDI Sequence from a given file, stream, or URL :

abstract Sequence getSequence(java.io.File file)
abstract Sequence getSequence(java.io.InputStream stream)
abstract Sequence getSequence(java.net.URL url)
The getSequence method performs the actual work of parsing the bytes in the MIDI input file and constructing a corresponding Sequence object. This is essentially the inverse of the process used by MidiFileWriter.write. Because there is a one-to-one correspondence between the contents of a MIDI file as defined by the MIDI specification and a Sequence object as defined by the Java Sound API, the details of the parsing are straightforward. If the file passed to getSequence contains data that the file reader can't parse (for example, because the file has been corrupted or doesn't conform to the MIDI specification), an InvalidMidiDataException should be thrown.

Providing Particular MIDI Devices

A MidiDeviceProvider can be considered a factory that supplies one or more particular types of MIDI device. The class consists of a method that returns an instance of a MIDI device, as well as query methods to learn what kinds of devices this provider can supply.

As with the other javax.sound.midi.spi services, application developers get indirect access to a MidiDeviceProvider service through a call to MidiSystem methods, in this case MidiSystem.getMidiDevice and MidiSystem.getMidiDeviceInfo. The purpose of subclassing MidiDeviceProvider is to supply a new kind of device, so the service developer must also create an accompanying class for the device being returned—just as we saw with MixerProvider in the javax.sound.sampled.spi package. There, the returned device's class implemented the javax.sound.sampled.Mixer interface; here it implements the javax.sound.midi.MidiDevice interface. It might also implement a subinterface of MidiDevice, such as Synthesizer or Sequencer.

Because a single subclass of MidiDeviceProvider can provide more than one type of MidiDevice, the getDeviceInfo method of the class returns an array of MidiDevice.Info objects enumerating the different MidiDevices available:

abstract MidiDevice.Info[] getDeviceInfo()

The returned array can contain a single element, of course. A typical implementation of the provider might initialize an array in its constructor and return it here. This allows MidiSystem to iterate over all installed MidiDeviceProviders to construct a list of all installed devices. MidiSystem can then return this list (MidiDevice.Info[] array) to an application program.

MidiDeviceProvider also includes a concrete query method:

boolean isDeviceSupported(MidiDevice.Info info)
This method permits the system to query the provider about a specific kind of device. Generally, you don't need to override this convenience method. The default implementation iterates over the array returned by getDeviceInfo and compares the argument to each element.

The third and final MidiDeviceProvider method returns the requested device:

abstract MidiDevice getDevice(MidiDevice.Info info)
This method should first test the argument to make sure it describes a device that this provider can supply. If it doesn't, it should throw an IllegalArgumentException. Otherwise, it returns the device.

Providing Soundbank File-Reading Services

A SoundBank is a set of Instruments that can be loaded into a Synthesizer. An Instrument is an implementation of a sound-synthesis algorithm that produces a particular sort of sound, and includes accompanying name and information strings. A SoundBank roughly corresponds to a bank in the MIDI specification, but it's a more extensive and addressable collection; it can perhaps better be thought of as a collection of MIDI banks. (For more background information on SoundBanks and Synthesizers, see Chapter 12, "Synthesizing Sound.")

SoundbankReader consists of a single overloaded method, which the system invokes to read a Soundbank object from a soundbank file:

abstract Soundbank getSoundbank(java.io.File file)
abstract Soundbank getSoundbank(java.io.InputStream stream)
abstract Soundbank getSoundbank(java.net.URL url)

Concrete subclasses of SoundbankReader will work in tandem with particular provider-defined implementations of SoundBank, Instrument, and Synthesizer to allow the system to load a SoundBank from a file into an instance of a particular Synthesizer class. Synthesis techniques may differ wildly from one Synthesizer to another, and, as a consequence, the data stored in an Instrument or SoundBank providing control or specification data for the synthesis process of a Synthesizer can take a variety of forms. One synthesis technique may require only a few bytes of parameter data; another may be based on extensive sound samples. The resources present in a SoundBank will depend upon the nature of the Synthesizer into which they get loaded, and therefore the implementation of the getSoundbank method of a SoundbankReader subclass has access to knowledge of a particular kind of SoundBank. In addition, a particular subclass of SoundbankReader understands a particular file format for storing the SoundBank data. That file format may be vendor-specific and proprietary.

SoundBank is just an interface, with only weak constraints on the contents of a SoundBank object. The methods an object must support to implement this interface (getResources, getInstruments, getVendor, getName, etc.) impose loose requirements on the data that the object contains. For example, getResources and getInstruments can return empty arrays. The actual contents of a subclassed SoundBank object, in particular its instruments and its non-instrument resources, are defined by the service provider. Thus, the mechanism of parsing a soundbank file depends entirely on the specification of that particular kind of soundbank file.

Soundbank files are created outside the Java Sound API, typically by the vendor of the synthesizer that can load that kind of soundbank. Some vendors might supply end-user tools for creating such files.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface org.w3c.dom.CharacterData (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.CharacterData

  • Packages that use CharacterData
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of CharacterData in org.w3c.dom

      Subinterfaces of CharacterData in org.w3c.dom
      Modifier and Type Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.jdi.CharType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.CharType

No usage of com.sun.jdi.CharType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.CharValue (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.CharValue

  • Packages that use CharValue
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of CharValue in com.sun.jdi

      Methods in com.sun.jdi that return CharValue
      Modifier and Type Method and Description
      CharValue VirtualMachine.mirrorOf(char value)
      Creates a CharValue for the given value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Description of Figure The Cipher Class

Link to figure The Cipher Class

This figure consists of boxes labeled as follows:

  • Key: Contains a box labeled Secret Key
  • Plaintext
  • These two boxes are attached to each other:
    • Cipher (AES): Box 1 of 2
    • Encrypt
  • Algorithm Parameters
  • Ciphertext
  • These two boxes are attached to each other:
    • Cipher (AES): Box 2 of 2
    • Decrypt
  • Plaintext

Labeled arrows connect these boxes:

  • update(): From Plaintext to the Cipher (AES) #1
  • doFinal(): From Plaintext to Encrypt
  • update(): From Ciphertext to the Cipher (AES) #2
  • doFinal(): From Ciphertext to Decrypt

Unlabeled arrows connect these boxes:

  • From Key to the Cipher (AES) #1 and Cipher (AES) #2 (the arrow branches)
  • From Cipher (AES) #1 to Algorithm Parameters
  • From Algorithm Parameters to the Cipher (AES) compartment of the Decrypt box
  • From Cipher (AES) #2 to Plaintext
  • From Decrypt to Plaintext
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


City Input Method

Contents

  1. About City Input Method
  2. Installing and Selecting the Input Method
  3. Using the Input Method for the First Time
  4. Using the Input Method
  5. Controlling the Status Window
  6. Supported Cities and Locales

1. About City Input Method

City Input Method is a simple input method that lets users enter city names by just typing a three-character airport code and converting it to a corresponding city name. If the user enters more than one airport code (up to three at a time are possible), the input method creates a short phrase such as "From San Francisco to Beijing via Tokyo". For each city, the input method knows the city names and phrases in a number of different languages (or, more precisely, locales). City names and phrases in all supported languages can be freely mixed in any input operation. The input method can be used to enter text into any text component that supports input methods, such as a Swing text component.

2. Installing and Selecting the Input Method

To make the input method available to applications, its jar file must be installed into the extensions directory of a JRE environment. After launching a Java application with a text component that supports input methods, the input method can be selected using the input method selection user interface provided by the runtime environment. First, make sure that a text component has the focus - typically, the text component indicates this by showing an insertion point. Then, choose the "Select Input Method" menu from the menu that can be pulled down from the top left corner of the window (the System menu on Windows, Window menu on Solaris), then choose "City Input Method" and the desired locale from the popup menu. Note that correct text display in some languages depends on the font configuration, so you may want to pick the locale of the host operating system or a language that is supported by most fonts, such as English or German.

3. Using the Input Method for the First Time

After selecting the input method, type "SFO", the code for San Francisco International Airport. You will see that the text is input into the text component, but highlighted to indicate that it is still being composed (the text is inverted on Solaris, underlined on Windows). Then type a Space character to start conversion. You will see that the airport code is replaced with the name of San Francisco in the language that you selected. The text is still highlighted, although the highlight may now look somewhat different. Type Space again. A lookup window opens, which shows the city name in all available languages, with the originally displayed name selected. Continue typing Space. You will see that the selection cycles through all the names, and that the selected name is also shown in the text component. Type Return. The lookup window disappears, and the most recently selected name is now shown in the text component without any highlight - it is committed.

4. Using the Input Method

Entering Raw Text

Raw text is any text that is entered through the input method, but hasn't been converted yet. From the moment you type the first character of an airport until you start conversion the input method is in raw text mode. In this mode, letters from "a" to "z" or their uppercase variants (the input method is case insensitive) are added to the raw text input. You can use backspace to delete a character, and you can click into the text using the mouse to move the insertion point.

Converting to City Names

You can start the conversion process from airport codes to city names when the raw text includes one, two, or three airport codes - that is, three, six, or nine characters. To start conversion, type Space. A single airport code is converted to just a city name. Two or three airport codes are converted to phrases such as "From San Francisco to Frankfurt" for two codes or "From San Francisco to Frankfurt via Chicago" for three codes. Each city name is considered a separate segment. One of the segments is selected, that is, it can be further converted using the lookup window. If there are multiple segments, the segment selection can be changed by clicking into a segment or by using the Arrow Right and Arrow Left keys.

Continuing Conversion Using the Lookup Window

The lookup window is a temporary window that shows the city names in all available languages for the airport code of the selected segment, and lets the user choose a different name. To show the window, select a segment, then type Space. The window opens just below or, if there's not enough space, in another location near the segment's text. The currently selected city name is outlined. To change the name selection, type Space, Arrow Down, or Arrow Up to cycle through all available names. To confirm a selected name, you usually commit as described in the next section. To select a name and close the lookup window without committing, type the number in front of the desired name.

Committing the Input

Committing the input text means to end input method processing of it, and make it a normal part of the text component's text body. All input method highlighting is removed from committed text. You can commit the entire input text at any time by typing Return. If you entered more than one airport code and have started conversion, you can also perform a partial commit: typing Control-Arrow Down commits the text up to the currently selected segment, but leaves following segments available for further conversion.

Conversion is requested using the Space character. During conversion, the input method first offers the city name in the selected language (if that name is available). If the user does not accept this selection, a second step brings up a choice window that offers all available names for the city, with the corresponding locale name.

5. Controlling the Status Window

The input method provides a little status window that shows the currently selected locale. Initially this window is positioned near the lower right corner of the screen, but it can be moved to a different location. To request that the status window automatically positions itself below the window containing the currently focussed text component, double-click into the status window's content area.

6. Supported Cities and Locales

The input method's knowledge of the world is limited - airport codes it knows include: SFO, NYC, JFK, LGA, ORD, FRA, MUC, TYO, NRT, HND, KIX, ITM, PEK, BJS, SHA, HKG, TPE. It currently supports the following languages: English, German, Japanese (normal and yomi), Simplified Chinese, Traditional Chinese.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Multithreaded Custom Class Loaders in Java

The Java SE 7 release contains an important enhancement for multithreaded custom class loaders. In previous releases, certain types of custom class loaders were prone to deadlock. The Java SE 7 release modifies the locking mechanism to avoid deadlock.

Background

The function of a java.lang.ClassLoader is to locate the bytecode for a particular class, then transform that bytecode into a usable class in the runtime system. The runtime system provides class loaders that can locate bootstrap classes, extension classes, and user classes. The CLASSPATH environment variable is one way to indicate to the runtime system where the bytecode is located.

Knowing about the CLASSPATH environment variable is all you may need to know about class loading. In some specific situations, however, customizing the behavior of a class loader by creating your own subclass may be necessary.

Custom class loaders will not run into deadlocks if they adhere to an acyclic class loader delegation model. Acyclic delegation is what the architects of ClassLoader envisioned. In this model, every class loader has a parent (delegate). When a class is requested, the class loader first checks if the class was loaded previously. If the class is not found, the class loader asks its parent to locate the class. If the parent cannot find the class, the class loader attempts to locate the class itself.

Deadlock Scenario

In earlier releases of the Java platform, multithreaded custom class loaders could deadlock when they did not have an acyclic delegation model. Here is one example:

Class Hierarchy:
  class A extends B
  class C extends D

ClassLoader Delegation Hierarchy:

Custom Classloader CL1:
  directly loads class A
  delegates to custom ClassLoader CL2 for class B

Custom Classloader CL2:
  directly loads class C
  delegates to custom ClassLoader CL1 for class D

Thread 1:
  Use CL1 to load class A (locks CL1)
    defineClass A triggers
      loadClass B (try to lock CL2)

Thread 2:
  Use CL2 to load class C (locks CL2)
    defineClass C triggers
      loadClass D (try to lock CL1)

Synchronization in the ClassLoader class was previously heavy-handed, or in technical terms, not sufficiently granular. A request to load a class synchronized on the entire ClassLoader object, which made it prone to deadlock.

Class Loader Synchronization in the Java SE 7 Release

The Java SE 7 release includes the concept of a parallel capable class loader. Loading a class by a parallel capable class loader now synchronizes on the pair consisting of the class loader and the class name.

In the previous scenario, using the Java SE 7 release, the threads are no longer deadlocked, and all classes are loaded successfully:

Thread 1:
  Use CL1 to load class A (locks CL1+A)
    defineClass A triggers
      loadClass B (locks CL2+B)

Thread 2:
  Use CL2 to load class C (locks CL2+C)
    defineClass C triggers
      loadClass D (locks CL1+D)

Recommendations for Multithreaded Custom Class Loaders

Custom class loaders that do not have a history of deadlocks do not require any changes. In particular, you do not need to change custom class loaders that follow the recommended acyclic hierarchical delegation model, that is, delegating first to their parent class. For backward compatibility, the Java SE 7 release continues to lock a class loader object unless it registers as parallel capable.

To create new custom class loaders, the process is similar in the Java SE 7 release as in previous releases. Create a subclass of ClassLoader, then override the findClass() method and possibly loadClass(). Overriding loadClass() makes your life more difficult, but it is the only way to use a different delegation model.

If you have a custom class loader with a risk of deadlocking, with the Java SE 7 release, you can avoid deadlocks by following these rules:

  1. Ensure that your custom class loader is multithread safe for concurrent class loading.
    1. Decide upon an internal locking scheme. For example, java.lang.ClassLoader uses a locking scheme based on the requested class name.
    2. Remove all synchronization on the class loader object lock alone.
    3. Ensure that critical sections are safe for multiple threads loading different classes.
  2. In your custom class loader's static initializer, invoke java.lang.ClassLoader's static method registerAsParallelCapable(). This registration indicates that all instances of your custom class loader are multithread safe.
  3. Check that all class loader classes that this custom class loader extends also invoke the registerAsParallelCapable() method in their class initializers. Ensure that they are multithread safe for concurrent class loading.

If your custom class loader overrides only findClass(String), you do not need further changes. This is the recommended mechanism to create a custom class loader.

If your custom class loader overrides either the protected loadClass(String, boolean) method or the public loadClass(String) method, you must also ensure that the protected defineClass() method is called only once for each class loader and class name pair.

Troubleshooting

If your product ships and appears to have problems due to incomplete handling of critical sections, you can use a new VM flag -XX:+AlwaysLockClassLoader. This flag reverts to locking the class loader lock before invoking your custom class loader's findClass() or loadClass() method, even for class loaders that register as parallel capable.

References

Class Loader API Modifications for Deadlock Fix at OpenJDK

Bug Database Bug 4670071 Detail

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Object Serialization Specification: 4 - Class Descriptors

CONTENTS | PREV | NEXT Java Object Serialization Specification
version 6.0

Class Descriptors

CHAPTER 4

Topics:
  • The ObjectStreamClass Class
  • Dynamic Proxy Class Descriptors
  • Serialized Form
  • The ObjectStreamField Class
  • Inspecting Serializable Classes
  • Stream Unique Identifiers

4.1 The ObjectStreamClass Class

The ObjectStreamClass provides information about classes that are saved in a Serialization stream. The descriptor provides the fully-qualified name of the class and its serialization version UID. A SerialVersionUID identifies the unique original class version for which this class is capable of writing streams and from which it can read.

package java.io;

public class ObjectStreamClass
{
    public static ObjectStreamClass lookup(Class cl);

        public static ObjectStreamClass lookupAny(Class cl);

    public String getName();

    public Class forClass();

    public ObjectStreamField[] getFields();

    public long getSerialVersionUID();

    public String toString();
}
The lookup method returns the ObjectStreamClass descriptor for the specified class in the virtual machine. If the class has defined serialVersionUID it is retrieved from the class. If the serialVersionUID is not defined by the class, it is computed from the definition of the class in the virtual machine. If the specified class is not serializable or externalizable, null is returned.

The lookupAny method behaves like the lookup method, except that it returns the descriptor for any class, regardless of whether it implements Serializable. The serialVersionUID of a class that does not implement Serializable is 0L.

The getName method returns the name of the class, in the same format that is used by the Class.getName method.

The forClass method returns the Class in the local virtual machine if one was found by ObjectInputStream.resolveClass method. Otherwise, it returns null.

The getFields method returns an array of ObjectStreamField objects that represent the serializable fields of this class.

The getSerialVersionUID method returns the serialVersionUID of this class. Refer to Section 4.6, "Stream Unique Identifiers." If not specified by the class, the value returned is a hash computed from the class's name, interfaces, methods, and fields using the Secure Hash Algorithm (SHA) as defined by the National Institute of Standards.

The toString method returns a printable representation of the class descriptor including the name of the class and the serialVersionUID.

4.2 Dynamic Proxy Class Descriptors

ObjectStreamClass descriptors are also used to provide information about dynamic proxy classes (e.g., classes obtained via calls to the getProxyClass method of java.lang.reflect.Proxy) saved in a serialization stream. A dynamic proxy class itself has no serializable fields and a serialVersionUID of 0L. In other words, when the Class object for a dynamic proxy class is passed to the static lookup method of ObjectStreamClass, the returned ObjectStreamClass instance will have the following properties:

  • Invoking its getSerialVersionUID method will return 0L.
  • Invoking its getFields method will return an array of length zero.
  • Invoking its getField method with any String argument will return null.

4.3 Serialized Form

The serialized form of an ObjectStreamClass instance depends on whether or not the Class object it represents is serializable, externalizable, or a dynamic proxy class.

When an ObjectStreamClass instance that does not represent a dynamic proxy class is written to the stream, it writes the class name and serialVersionUID, flags, and the number of fields. Depending on the class, additional information may be written:

  • For non-serializable classes, the number of fields is always zero. Neither the SC_SERIALIZABLE nor the SC_EXTERNALIZABLE flag bits are set.
  • For serializable classes, the SC_SERIALIZABLE flag is set, the number of fields counts the number of serializable fields and is followed by a descriptor for each serializable field. The descriptors are written in canonical order. The descriptors for primitive typed fields are written first sorted by field name followed by descriptors for the object typed fields sorted by field name. The names are sorted using String.compareTo. For details of the format, refer to Section 6.4, "Grammar for the Stream Format".
  • For externalizable classes, flags includes the SC_EXTERNALIZABLE flag, and the number of fields is always zero.
  • For enum types, flags includes the SC_ENUM flag, and the number of fields is always zero.
When an ObjectOutputStream serializes the ObjectStreamClass descriptor for a dynamic proxy class, as determined by passing its Class object to the isProxyClass method of java.lang.reflect.Proxy, it writes the number of interfaces that the dynamic proxy class implements, followed by the interface names. Interfaces are listed in the order that they are returned by invoking the getInterfaces method on the Class object of the dynamic proxy class.

The serialized representations of ObjectStreamClass descriptors for dynamic proxy classes and non-dynamic proxy classes are differentiated through the use of different typecodes (TC_PROXYCLASSDESC and TC_CLASSDESC, respectively); for a more detailed specification of the grammar, see Section 6.4, "Grammar for the Stream Format".

4.4 The ObjectStreamField Class

An ObjectStreamField represents a serializable field of a serializable class. The serializable fields of a class can be retrieved from the ObjectStreamClass.

The special static serializable field, serialPersistentFields, is an array of ObjectStreamField components that is used to override the default serializable fields.

package java.io;

public class ObjectStreamField implements Comparable {

    public ObjectStreamField(String fieldName,
                             Class fieldType);

    public ObjectStreamField(String fieldName,
                             Class fieldType,
                             boolean unshared);

    public String getName();

    public Class getType();

    public String getTypeString();

    public char getTypeCode();

    public boolean isPrimitive();

    public boolean isUnshared();

    public int getOffset();

    protected void setOffset(int offset);

    public int compareTo(Object obj);

    public String toString();
}
ObjectStreamField objects are used to specify the serializable fields of a class or to describe the fields present in a stream. Its constructors accept arguments describing the field to represent: a string specifying the name of the field, a Class object specifying the type of the field, and a boolean flag (implicitly false for the two-argument constructor) indicating whether or not values of the represented field should be read and written as "unshared" objects if default serialization/deserialization is in use (see the descriptions of the ObjectInputStream.readUnshared and ObjectOutputStream.writeUnshared methods in sections 3.1 and 2.1, respectively).

The getName method returns the name of the serializable field.

The getType method returns the type of the field.

The getTypeString method returns the type signature of the field.

The getTypeCode method returns a character encoding of the field type (`B' for byte, `C' for char, `D' for double, `F' for float, `I' for int, `J' for long, `L' for non-array object types, `S' for short, `Z' for boolean, and `[` for arrays).

The isPrimitive method returns true if the field is of primitive type, or false otherwise.

The isUnshared method returns true if values of the field should be written as "unshared" objects, or false otherwise.

The getOffset method returns the offset of the field's value within instance data of the class defining the field.

The setOffset method allows ObjectStreamField subclasses to modify the offset value returned by the getOffset method.

The compareTo method compares ObjectStreamFields for use in sorting. Primitive fields are ranked as "smaller" than non-primitive fields; fields otherwise equal are ranked alphabetically.

The toString method returns a printable representation with name and type.

4.5 Inspecting Serializable Classes

The program serialver can be used to find out if a class is serializable and to get its serialVersionUID. When invoked with the-show option, it puts up a simple user interface. To find out if a class is serializable and to find out its serialVersionUID, enter its full class name, then press either the Enter or the Show button. The string printed can be copied and pasted into the evolved class.

serialver, Serial Version Inspector program

When invoked on the command line with one or more class names, serialver prints the serialVersionUID for each class in a form suitable for copying into an evolving class. When invoked with no arguments, it prints a usage line.

4.6 Stream Unique Identifiers

Each versioned class must identify the original class version for which it is capable of writing streams and from which it can read. For example, a versioned class must declare:

    private static final long serialVersionUID = 3487495895819393L;

The stream-unique identifier is a 64-bit hash of the class name, interface class names, methods, and fields. The value must be declared in all versions of a class except the first. It may be declared in the original class but is not required. The value is fixed for all compatible classes. If the SUID is not declared for a class, the value defaults to the hash for that class. The serialVersionUID for dynamic proxy classes and enum types always have the value 0L. Array classes cannot declare an explicit serialVersionUID, so they always have the default computed value, but the requirement for matching serialVersionUID values is waived for array classes.

Note - It is strongly recommended that all serializable classes explicitly declare serialVersionUID values, since the default serialVersionUID computation is highly sensitive to class details that may vary depending on compiler implementations, and can thus result in unexpected serialVersionUID conflicts during deserialization, causing deserialization to fail.
The initial version of an Externalizable class must output a stream data format that is extensible in the future. The initial version of the method readExternal has to be able to read the output format of all future versions of the method writeExternal.

The serialVersionUID is computed using the signature of a stream of bytes that reflect the class definition. The National Institute of Standards and Technology (NIST) Secure Hash Algorithm (SHA-1) is used to compute a signature for the stream. The first two 32-bit quantities are used to form a 64-bit hash. A java.lang.DataOutputStream is used to convert primitive data types to a sequence of bytes. The values input to the stream are defined by the Java Virtual Machine (VM) specification for classes. Class modifiers may include the ACC_PUBLIC, ACC_FINAL, ACC_INTERFACE, and ACC_ABSTRACT flags; other flags are ignored and do not affect serialVersionUID computation. Similarly, for field modifiers, only the ACC_PUBLIC, ACC_PRIVATE, ACC_PROTECTED, ACC_STATIC, ACC_FINAL, ACC_VOLATILE, and ACC_TRANSIENT flags are used when computing serialVersionUID values. For constructor and method modifiers, only the ACC_PUBLIC, ACC_PRIVATE, ACC_PROTECTED, ACC_STATIC, ACC_FINAL, ACC_SYNCHRONIZED, ACC_NATIVE, ACC_ABSTRACT and ACC_STRICT flags are used. Names and descriptors are written in the format used by the java.io.DataOutputStream.writeUTF method.

The sequence of items in the stream is as follows:

  1. The class name.
  2. The class modifiers written as a 32-bit integer.
  3. The name of each interface sorted by name.
  4. For each field of the class sorted by field name (except private static and private transient fields:
    1. The name of the field.
    2. The modifiers of the field written as a 32-bit integer.
    3. The descriptor of the field.
  5. If a class initializer exists, write out the following:
    1. The name of the method, <clinit>.
    2. The modifier of the method, java.lang.reflect.Modifier.STATIC, written as a 32-bit integer.
    3. The descriptor of the method, ()V.
  6. For each non-private constructor sorted by method name and signature:
    1. The name of the method, <init>.
    2. The modifiers of the method written as a 32-bit integer.
    3. The descriptor of the method.
  7. For each non-private method sorted by method name and signature:
    1. The name of the method.
    2. The modifiers of the method written as a 32-bit integer.
    3. The descriptor of the method.
  8. The SHA-1 algorithm is executed on the stream of bytes produced by DataOutputStream and produces five 32-bit values sha[0..4].
  9. The hash value is assembled from the first and second 32-bit values of the SHA-1 message digest. If the result of the message digest, the five 32-bit words H0 H1 H2 H3 H4, is in an array of five int values named sha, the hash value would be computed as follows:
      long hash = ((sha[0] >>> 24) & 0xFF) |
              ((sha[0] >>> 16) & 0xFF) << 8 |
              ((sha[0] >>> 8) & 0xFF) << 16 |
              ((sha[0] >>> 0) & 0xFF) << 24 |
              ((sha[1] >>> 24) & 0xFF) << 32 |
              ((sha[1] >>> 16) & 0xFF) << 40 |
              ((sha[1] >>> 8) & 0xFF) << 48 |
              ((sha[1] >>> 0) & 0xFF) << 56;

CONTENTS | PREV | NEXT
Copyright © 2005, 2010, Oracle and/or its affiliates. All rights reserved.


Class Data Sharing

Overview

Class data sharing (CDS) helps reduce the startup time for Java programming language applications, in particular smaller applications, as well as reduce footprint. When the JRE is installed using the installer, the installer loads a set of classes from the system jar file into a private internal representation, and dumps that representation to a file, called a "shared archive". If the JRE installer is not being used, this can be done manually, as explained below. During subsequent JVM invocations, the shared archive is memory-mapped in, saving the cost of loading those classes and allowing much of the JVM's metadata for these classes to be shared among multiple JVM processes.

Class data sharing is supported only with the Java HotSpot Client VM, and only with the serial garbage collector.

The primary motivation for including CDS in Java SE is the decrease in startup time it provides. CDS produces better results for smaller applications because it eliminates a fixed cost: that of loading certain core classes. The smaller the application relative to the number of core classes it uses, the larger the saved fraction of startup time.

The footprint cost of new JVM instances has been reduced in two ways. First, a portion of the shared archive, currently between five and six megabytes, is mapped read-only and therefore shared among multiple JVM processes. Previously this data was replicated in each JVM instance. Second, since the shared archive contains class data in the form in which the Java Hotspot VM uses it, the memory which would otherwise be required to access the original class information in rt.jar is not needed. These savings allow more applications to be run concurrently on the same machine. On Microsoft Windows, the footprint of a process, as measured by various tools, may appear to increase, because a larger number of pages are being mapped in to the process' address space. This is offset by the reduction in the amount of memory (inside Microsoft Windows) which is needed to hold portions on rt.jar. Reducing footprint remains a high priority.

Regenerating the Shared Archive

Under some circumstances the system administrator may need to manually regenerate the shared archive. This is typically only necessary on Solaris if the Java SE packages were installed over the network to a machine of a different architecture than that performing the installation. Regardless, these regeneration instructions apply to all supported platforms.

The shared archive file is colocated with the shared library for the JVM. On Solaris, Linux, or Mac OS X platforms, it is stored in jre/lib/[arch]/client/classes.jsa and on Microsoft Windows platforms in jre/bin/[client or server]/classes.jsa. If this file exists, it must be manually removed before regeneration.

To regenerate the archive, log in as the administrator; in networked situations, log on to a machine of the same architecture as the Java SE installation and ensure that you have permission to write to the installation directory. Then execute the command

java -Xshare:dump Diagnostic information will be printed as the archive is generated.

Manually Controlling Class Data Sharing

The class data sharing feature is automatically enabled when conditions allow it to be used. The following command line options are present primarily for diagnostic and debugging purposes and may change or be removed in future releases.

-Xshare:off
Disable class data sharing.
-Xshare:on
Require class data sharing to be enabled. If it could not be enabled for various reasons, print an error message and exit.
-Xshare:auto
The default; enable class data sharing whenever possible.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.javadoc.ClassDoc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.ClassDoc

    • Uses of ClassDoc in com.sun.javadoc

      Subinterfaces of ClassDoc in com.sun.javadoc
      Modifier and Type Interface and Description
      interface  AnnotationTypeDoc
      Represents an annotation type.
      Methods in com.sun.javadoc that return ClassDoc
      Modifier and Type Method and Description
      ClassDoc[] PackageDoc.allClasses()
      Get all included classes and interfaces in the package.
      ClassDoc[] PackageDoc.allClasses(boolean filter)
      Get all classes and interfaces in the package, filtered to the specified access modifier option.
      ClassDoc Type.asClassDoc()
      Return this type as a ClassDoc if it represents a class or interface.
      ClassDoc ParameterizedType.asClassDoc()
      Return the generic class or interface that declared this type.
      ClassDoc[] RootDoc.classes()
      Return the included classes and interfaces in all packages.
      ClassDoc RootDoc.classNamed(String qualifiedName)
      Return a ClassDoc for the specified class or interface name.
      ClassDoc ProgramElementDoc.containingClass()
      Get the containing class or interface of this program element.
      ClassDoc[] PackageDoc.enums()
      Get included enum types in this package.
      ClassDoc[] PackageDoc.errors()
      Get included Error classes in this package.
      ClassDoc ThrowsTag.exception()
      Return a ClassDoc that represents the exception.
      ClassDoc[] PackageDoc.exceptions()
      Get included Exception classes in this package.
      ClassDoc SerialFieldTag.fieldTypeDoc()
      Return the ClassDoc for field type.
      ClassDoc ClassDoc.findClass(String className)
      Find the specified class or interface within the context of this class doc.
      ClassDoc PackageDoc.findClass(String className)
      Lookup a class or interface within this package.
      ClassDoc[] ClassDoc.importedClasses()
      Deprecated.
      Import declarations are implementation details that should not be exposed here. In addition, not all imported classes are imported through single-type-import declarations.
      ClassDoc[] ClassDoc.innerClasses()
      Return included nested classes and interfaces within this class or interface.
      ClassDoc[] ClassDoc.innerClasses(boolean filter)
      Return nested classes and interfaces within this class or interface filtered to the specified access modifier option.
      ClassDoc[] ClassDoc.interfaces()
      Return interfaces implemented by this class or interfaces extended by this interface.
      ClassDoc[] PackageDoc.interfaces()
      Get included interfaces in this package, omitting annotation types.
      ClassDoc[] PackageDoc.ordinaryClasses()
      Get included ordinary classes (that is, exclude exceptions, errors, enums, interfaces, and annotation types) in this package.
      ClassDoc MethodDoc.overriddenClass()
      Return the class containing the method that this method overrides.
      ClassDoc SeeTag.referencedClass()
      Get the class doc referenced by the class name part of @see.
      ClassDoc[] RootDoc.specifiedClasses()
      Return the classes and interfaces specified as source file names on the command line.
      ClassDoc ClassDoc.superclass()
      Return the superclass of this class.
      ClassDoc[] ExecutableMemberDoc.thrownExceptions()
      Return exceptions this method or constructor throws.
      Methods in com.sun.javadoc with parameters of type ClassDoc
      Modifier and Type Method and Description
      boolean ClassDoc.subclassOf(ClassDoc cd)
      Test whether this class is a subclass of the specified class.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Closing a URLClassLoader

How to Close a URLClassLoader?

The URLClassLoader close() method effectively eliminates the problem of how to support updated implementations of the classes and resources loaded from a particular codebase, and in particular from JAR files. In principle, once the application clears all references to a loader object, the garbage collector and finalization mechanisms will eventually ensure that all resources (such as the JarFile objects) are released and closed.

The application can then replace the JAR file, and create a new URLClassLoader instance to load from the same location, but this time using the new implementation of the classes/resources. However, since it can't be predicted exactly when finalization and garbage collection will occur, problems are caused for applications which need to be able to do this in a predictable and timely fashion. It is a problem on Windows, because open files cannot be deleted or replaced.

In Java SE 7, the URLClassLoader close() method effectively invalidates the loader, so that no new classes can be loaded from it. It also closes any JAR files that were opened by the loader. This allows the application to delete or replace these files and, if necessary, create new loaders using new implementations.

The close() method follows the familiar "Closeable" pattern, and URLClassLoader now implements the Closeable interface, which defines URLClassLoader.close(). The following sample code shows how one might use the method.

       //
       // create a class loader loading from "foo.jar"
       //
       URL url = new URL("file:foo.jar");
       URLClassLoader loader = new URLClassLoader (new URL[] {url});
       Class cl = Class.forName ("Foo", true, loader);
       Runnable foo = (Runnable) cl.newInstance();
       foo.run();
       loader.close ();

       // foo.jar gets updated somehow

       loader = new URLClassLoader (new URL[] {url});
       cl = Class.forName ("Foo", true, loader);
       foo = (Runnable) cl.newInstance();
       // run the new implementation of Foo
       foo.run();
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.ClassLoaderReference (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ClassLoaderReference

  • Packages that use ClassLoaderReference
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of ClassLoaderReference in com.sun.jdi

      Methods in com.sun.jdi that return ClassLoaderReference
      Modifier and Type Method and Description
      ClassLoaderReference ReferenceType.classLoader()
      Gets the classloader object which loaded the class corresponding to this type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.ClassNotLoadedException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.ClassNotLoadedException

  • Packages that use ClassNotLoadedException
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of ClassNotLoadedException in com.sun.jdi

      Methods in com.sun.jdi that throw ClassNotLoadedException
      Modifier and Type Method and Description
      List<Type> Method.argumentTypes()
      Returns a list containing the type of each formal parameter of this method.
      Type ArrayType.componentType()
      Returns the component type of this array, as specified in the array declaration.
      void ThreadReference.forceEarlyReturn(Value value)
      Force a method to return before it reaches a return statement.
      Value ObjectReference.invokeMethod(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Invokes the specified Method on this object in the target VM.
      Value ClassType.invokeMethod(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Invokes the specified static Method in the target VM.
      default Value InterfaceType.invokeMethod(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Invokes the specified static Method in the target VM.
      ObjectReference ClassType.newInstance(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Constructs a new instance of this type, using the given constructor Method in the target VM.
      Type Method.returnType()
      Returns the return type, as specified in the declaration of this method.
      void ObjectReference.setValue(Field field, Value value)
      Sets the value of a given instance or static field in this object.
      void ClassType.setValue(Field field, Value value)
      Assigns a value to a static field.
      void ArrayReference.setValue(int index, Value value)
      Replaces an array component with another value.
      void StackFrame.setValue(LocalVariable variable, Value value)
      Sets the Value of a LocalVariable in this frame.
      void ArrayReference.setValues(int index, List<? extends Value> values, int srcIndex, int length)
      Replaces a range of array components with other values.
      void ArrayReference.setValues(List<? extends Value> values)
      Replaces all array components with other values.
      Type Field.type()
      Returns the type of this field.
      Type LocalVariable.type()
      Returns the type of this variable.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.ClassNotPreparedException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.ClassNotPreparedException

No usage of com.sun.jdi.ClassNotPreparedException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.ClassObjectReference (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ClassObjectReference

  • Packages that use ClassObjectReference
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of ClassObjectReference in com.sun.jdi

      Methods in com.sun.jdi that return ClassObjectReference
      Modifier and Type Method and Description
      ClassObjectReference ReferenceType.classObject()
      Returns the class object that corresponds to this type in the target VM.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Setting the Class Path

Documentation Contents
Java Platform, Standard Edition Tools Reference
Contents Previous Next

2 Setting the Class Path

The class path is the path that the Java Runtime Environment (JRE) searches for classes and other resource files.

This chapter covers the following topics:

  • Synopsis

  • Description

  • JDK Commands Class Path Options

  • CLASSPATH Environment Variable

  • Class Path Wild Cards

  • Class Path and Package Names

Synopsis

The class search path (class path) can be set using either the -classpath option when calling a JDK tool (the preferred method) or by setting the CLASSPATH environment variable. The -classpath option is preferred because you can set it individually for each application without affecting other applications and without other applications modifying its value.

sdkTool -classpath classpath1:classpath2...

set CLASSPATH=classpath1;classpath2...

sdkTool

A command-line tool, such as java, javac, javadoc, or apt. For a listing, see JDK Tools and Utilities at
http://docs.oracle.com/javase/8/docs/technotes/tools/index.html

classpath1:classpath2

Class paths to the JAR, zip or class files. Each class path should end with a file name or directory depending on what you are setting the class path to, as follows:

  • For a JAR or zip file that contains class files, the class path ends with the name of the zip or JAR file.

  • For class files in an unnamed package, the class path ends with the directory that contains the class files.

  • For class files in a named package, the class path ends with the directory that contains the root package, which is the first package in the full package name.

Multiple path entries are separated by semicolons with no spaces around the equals sign (=) in Windows and colons in Oracle Solaris.

The default class path is the current directory. Setting the CLASSPATH variable or using the -classpath command-line option overrides that default, so if you want to include the current directory in the search path, then you must include a dot (.) in the new settings.

Class path entries that are neither directories nor archives (.zip or JAR files) nor the asterisk (*) wildcard character are ignored.

Description

The class path tells the JDK tools and applications where to find third-party and user-defined classes that are not extensions or part of the Java platform. See The Extension Mechanism at
http://docs.oracle.com/javase/8/docs/technotes/guides/extensions/index.html

The class path needs to find any classes you have compiled with the javac compiler. The default is the current directory to conveniently enable those classes to be found.

The JDK, the JVM and other JDK tools find classes by searching the Java platform (bootstrap) classes, any extension classes, and the class path, in that order. For details about the search strategy, see How Classes Are Found at
http://docs.oracle.com/javase/8/docs/technotes/tools/findingclasses.html

Class libraries for most applications use the extensions mechanism. You only need to set the class path when you want to load a class that is (a) not in the current directory or in any of its subdirectories, and (b) not in a location specified by the extensions mechanism.

If you upgrade from an earlier release of the JDK, then your startup settings might include CLASSPATH settings that are no longer needed. You should remove any settings that are not application-specific, such as classes.zip. Some third-party applications that use the Java Virtual Machine (JVM) can modify your CLASSPATH environment variable to include the libraries they use. Such settings can remain.

You can change the class path by using the -classpath or -cp option of some Java commands when you call the JVM or other JDK tools or by using the CLASSPATH environment variable. See JDK Commands Class Path Options. Using the -classpath option is preferred over setting the CLASSPATH environment variable because you can set it individually for each application without affecting other applications and without other applications modifying its value. See CLASSPATH Environment Variable.

Classes can be stored in directories (folders) or in archive files. The Java platform classes are stored in rt.jar. For more details about archives and information about how the class path works, see Class Path and Package Names.

Note: Some earlier releases of the JDK had a <jdk-dir>/classes entry in the default class path. That directory exists for use by the JDK software and should not be used for application classes. Application classes should be placed in a directory outside of the JDK directory hierarchy. That way, installing a new JDK does not force you to reinstall application classes. For compatibility with earlier releases, applications that use the <jdk-dir>/classes directory as a class library run in the current release, but there is no guarantee that they will run in future releases.

JDK Commands Class Path Options

The following commands have a -classpath option that replaces the path or paths specified by the CLASSPATH environment variable while the tool runs: java, jdb, javac, javah and jdeps.

The -classpath option is the recommended option for changing class path settings, because each application can have the class path it needs without interfering with any other application.The java command also has a -cp option that is an abbreviation for -classpath.

For very special cases, both the java and javac commands have options that let you change the path they use to find their own class libraries. Most users will never need to use those options.

CLASSPATH Environment Variable

As explained in JDK Commands Class Path Options, the -classpath command-line option is preferred over the CLASSPATH environment variable. However, if you decide to use the CLASSPATH environment variable, this section explains how to set and clear it.

Set CLASSPATH

The CLASSPATH environment variable is modified with the set command. The format is:

set CLASSPATH=path1;path2
...

The paths should begin with the letter specifying the drive, for example, C:\. That way, the classes will still be found if you happen to switch to a different drive. If the path entries start with backslash (\) and you are on drive D:, for example, then the classes will be expected on D:, rather than C:.

Clear CLASSPATH

If your CLASSPATH environment variable was set to a value that is not correct, or if your startup file or script is setting an incorrect path, then you can unset CLASSPATH with:

set CLASSPATH=

This command unsets CLASSPATH for the current command prompt window only. You should also delete or modify your startup settings to ensure that you have the correct CLASSPATH settings in future sessions.

Change Startup Settings

If the CLASSPATH variable is set at system startup, then the place to look for it depends on your operating system:

Windows 95 and 98: Examine autoexec.bat for the set command.

Other (Windows NT, Windows 2000, ...): The CLASSPATH environment variable can be set with the System utility in the Control Panel.

If the CLASSPATH variable is set at system startup, then the place to look for it depends on the shell you are running:

The csh, tcsh shells: Examine your .cshrc file for the setenv command.

The sh, ksh shells: Examine your .profile file for the export command.

Class Path Wild Cards

Class path entries can contain the base name wildcard character (*), which is considered equivalent to specifying a list of all of the files in the directory with the extension .jar or .JAR. For example, the class path entry mydir/* specifies all JAR files in the directory named mydir. A class path entry consisting of * expands to a list of all the jar files in the current directory. Files are considered regardless of whether they are hidden (have names beginning with '.').

A class path entry that contains an asterisk (*) does not match class files. To match both classes and JAR files in a single directory mydir, use either mydir:mydir/* or mydir/*:mydir. The order chosen determines whether the classes and resources in mydir are loaded before JAR files in mydir or vice versa.

Subdirectories are not searched recursively. For example, mydir/* searches for JAR files only in mydir, not in mydir/subdir1, mydir/subdir2, and so on.

The order in which the JAR files in a directory are enumerated in the expanded class path is not specified and may vary from platform to platform and even from moment to moment on the same machine. A well-constructed application should not depend upon any particular order. If a specific order is required, then the JAR files can be enumerated explicitly in the class path.

Expansion of wild cards is done early, before the invocation of a program's main method, rather than late, during the class-loading process. Each element of the input class path that contains a wildcard is replaced by the (possibly empty) sequence of elements generated by enumerating the JAR files in the named directory. For example, if the directory mydir contains a.jar, b.jar, and c.jar, then the class path mydir/* is expanded into mydir/a.jar:mydir/b.jar:mydir/c.jar, and that string would be the value of the system property java.class.path.

The CLASSPATH environment variable is not treated any differently from the -classpath or -cp options. Wild cards are honored in all of these cases. However, class path wild cards are not honored in the Class-Path jar-manifest header.

Class Path and Package Names

Java classes are organized into packages that are mapped to directories in the file system. But, unlike the file system, whenever you specify a package name, you specify the whole package name and never part of it. For example, the package name for java.awt.Button is always specified as java.awt.

For example, suppose you want the Java JRE to find a class named Cool.class in the package utility.myapp. If the path to that directory is C:\java\MyClasses\utility\myapp, then you would set the class path so that it contains C:\java\MyClasses. To run that application, you could use the following java command:

java -classpath C:\java\MyClasses utility.myapp.Cool

The entire package name is specified in the command. It is not possible, for example, to set the class path so it contains C:\java\MyClasses\utility and use the command java myapp.Cool. The class would not be found.

You might wonder what defines the package name for a class. The answer is that the package name is part of the class and cannot be modified, except by recompiling the class.

An interesting consequence of the package specification mechanism is that files that are part of the same package can exist in different directories. The package name is the same for each class, but the path to each file might start from a different directory in the class path.

Folders and Archive Files

When classes are stored in a directory (folder), such as c:\java\MyClasses\utility\myapp, then the class path entry points to the directory that contains the first element of the package name (in this case, C:\java\MyClasses, because the package name is utility.myapp).

When classes are stored in an archive file (a zip or JAR file) the class path entry is the path to and including the zip or JAR file. For example, the command to use a class library that is in a JAR file as follows:

java -classpath C:\java\MyClasses\myclasses.jar utility.myapp.Cool

Multiple Specifications

To find class files in the directory C:\java\MyClasses and classes in C:\java\OtherClasses, you would set the class path to the following. Note that the two paths are separated by a semicolon.

java -classpath C:\java\MyClasses;C:\java\OtherClasses ...

Specification Order

The order in which you specify multiple class path entries is important. The Java interpreter will look for classes in the directories in the order they appear in the class path variable. In the previous example, the Java interpreter will first look for a needed class in the directory C:\java\MyClasses. Only when it does not find a class with the proper name in that directory will the interpreter look in the C:\java\OtherClasses directory.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.event.ClassPrepareEvent (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.ClassPrepareEvent

No usage of com.sun.jdi.event.ClassPrepareEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.ClassPrepareRequest (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.ClassPrepareRequest

  • Packages that use ClassPrepareRequest
    Package Description
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of ClassPrepareRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ClassPrepareRequest
      Modifier and Type Method and Description
      ClassPrepareRequest EventRequestManager.createClassPrepareRequest()
      Creates a new disabled ClassPrepareRequest.
      Methods in com.sun.jdi.request that return types with arguments of type ClassPrepareRequest
      Modifier and Type Method and Description
      List<ClassPrepareRequest> EventRequestManager.classPrepareRequests()
      Return an unmodifiable list of the enabled and disabled class prepare requests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.ClassTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ClassTree

  • Packages that use ClassTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ClassTree in com.sun.source.tree

      Methods in com.sun.source.tree that return ClassTree
      Modifier and Type | Method and Description
      ClassTree | NewClassTree.getClassBody()
      Methods in com.sun.source.tree with parameters of type ClassTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitClass(ClassTree node, P p)

    • Uses of ClassTree in com.sun.source.util

      Methods in com.sun.source.util that return ClassTree
      Modifier and Type Method and Description
      abstract ClassTree Trees.getTree(TypeElement element)
      Gets the ClassTree node for a given TypeElement.
      Methods in com.sun.source.util with parameters of type ClassTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitClass(ClassTree node, P p)
      R | TreeScanner.visitClass(ClassTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.ClassType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.ClassType

  • Packages that use ClassType
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of ClassType in com.sun.jdi

      Methods in com.sun.jdi that return ClassType
      Modifier and Type Method and Description
      ClassType ClassType.superclass()
      Gets the superclass of this class.
      Methods in com.sun.jdi that return types with arguments of type ClassType
      Modifier and Type Method and Description
      List<ClassType> InterfaceType.implementors()
      Gets the currently prepared classes which directly implement this interface.
      List<ClassType> ClassType.subclasses()
      Gets the currently loaded, direct subclasses of this class.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.event.ClassUnloadEvent (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.ClassUnloadEvent

No usage of com.sun.jdi.event.ClassUnloadEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.ClassUnloadRequest (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.ClassUnloadRequest

  • Packages that use ClassUnloadRequest
    Package Description
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of ClassUnloadRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ClassUnloadRequest
      Modifier and Type Method and Description
      ClassUnloadRequest EventRequestManager.createClassUnloadRequest()
      Creates a new disabled ClassUnloadRequest.
      Methods in com.sun.jdi.request that return types with arguments of type ClassUnloadRequest
      Modifier and Type Method and Description
      List<ClassUnloadRequest> EventRequestManager.classUnloadRequests()
      Return an unmodifiable list of the enabled and disabled class unload requests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

Part III

Debug Core Library Issues

This part describes issues and troubleshooting techniques that arise with time zone settings and contains the following topic.

  • Time Zone Settings in the JRE

    Describes some issues that arise with time zone settings with Java Runtime Environment (JRE) and troubleshooting techniques to resolve these issues.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Setting the Security Level of the Java Client

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

23 Setting the Security Level of the Java Client

This topic describes the security level of the Java Client, policy files, permissions, and security dialogs. These security features provide users with some control over what Java and JavaFX applications are allowed to run.

This topic contains the following sections:

  • Setting the Security Level of the Java Client

  • Policy Files and Permissions

  • Property Files and Certificates

  • Browser Keystores

  • Security Dialogs

  • Warning Banner

  • More Information

23.1 Setting the Security Level of the Java Client

Using the Java Control Panel or installation options, the user can control, the level of security that is used when running Java and JavaFX applications that are embedded in a web page or launched from a web page, collectively referred to as Rich Internet Applications or RIAs. The user can select from three levels of security, including disabled, where no RIAs are allowed to run in the browser. Setting the security level does not affect desktop (also called stand-alone) applications.

23.1.1 Ensuring the Most Secure JRE

Before the browser plug-in software attempts to run a RIA, it verifies that the JRE version is at or above the security baseline for that family and that the age of the JRE is recent. If the JRE is determined to be below the security baseline, or if unable to verify the baseline and the current date is past the JRE Expiration Date, additional security warnings are displayed, or in some cases, the RIA is blocked. If the RIA is not automatically blocked, the user has the option to block the RIA, to continue running the RIA, or to go to java.com to download the latest release. The JRE expiration date can be found in the release notes for JDK Update releases starting with JDK 7u21.

23.1.2 JRE Expiration Date

The JRE relies on periodic checks with an Oracle Server to determine if the JRE is still considered up-to-date with all of the available security fixes (above the security baseline). From the 7u10 release onwards, all JREs contain a hard-coded expiration date. The expiration date is calculated to end after the scheduled release of the next Critical Patch Update.

JREs that are unable to contact Oracle Servers for an extended period of time now offer additional protection after a reasonable period and do not continue to behave as if they were up-to-date with regard to security fixes.

To test what happens when the JRE falls below the security baseline or expires, see Section 23.1.2.1, "Testing a JRE Below the Security Baseline" and Section 23.1.2.2, "Testing an Expired JRE".

23.1.2.1 Testing a JRE Below the Security Baseline

To see how applications behave when the JRE falls below the Security Baseline, follow these steps:

  1. Install the JRE that you want to test.

  2. Remove the following files, if they exist:

    • <user-deployment-home>/deployment.properties

    • <user-deployment-home>/security/baseline.versions

    • <user-deployment-home>/security/update.timestamp

    See Section 21.1, "Deployment Configuration File (deployment.properties)" for the location of the deployment.properties file on each supported platform.

  3. From the command line, run the following command:

    javaws -SSVBaselineUpdate

    The <user-deployment-home>/security/baseline.versions file is downloaded.

  4. Edit the <user-deployment-home>/security/baseline.versions file.

    Set the version number of the JRE for the JRE family that you are testing to a value greater than the version that you are testing. For example, if you are testing JRE version 8u5, set the version in the file to 1.8.0_99. The JRE periodically updates this file, so make the file read-only to prevent your changes from being overwritten.

  5. Run any RIA.

    The Java Update Needed prompt is shown. Click Later to continue running the application. See Why do I see the Java Update Needed messages? on java.com for information on this prompt.

  6. When you are done testing, repeat Step 2 and Step 3 to restore the correct version of the files.

23.1.2.2 Testing an Expired JRE

To see how applications behave after the JRE has expired, follow these steps:

  1. Install the JRE that you want to test.

  2. Remove the following files, if they exist:

    • <user-deployment-home>/deployment.properties

    • <user-deployment-home>/security/baseline.versions

    See Section 21.1, "Deployment Configuration File (deployment.properties)" for the location of the deployment.properties file on each supported platform.

  3. Set the system to a future date beyond the expiration date of the JRE. Get the expiration date from the Release Notes for the release that you are testing.

  4. Run any RIA.

    The Java Update Needed prompt is shown. Click Later to continue running the application. See Why do I see the Java Update Needed messages? on java.com for information on this prompt.

23.1.3 Disabling Java in the Browser

If you prefer to completely disable access to Java through the browser, de-select the Enable Java content in the browser option in the Java Control Panel under the Security tab. See Section 20.4, "Security" for information.

If you do not need to run Java through a browser, consider installing the Server JRE, which does not contain the Java Plug-In. See Server JRE (Java SE Runtime Environment) 7 Downloads for information.

23.1.4 Setting the Security Level

Note: These settings affect all browsers that use Oracle's Java browser plug-in. They do not affect stand-alone applications.

The Security tab of the Java Control Panel contains a Security Level setting that controls the restrictions placed on any RIA that is run from the web. The user can select a level of High or Very High. This setting determines if a RIA is allowed to run and if so, the warnings you must accept before the RIA is started. The warnings contain information about the signing status of the RIA, the location of the RIA, and whether the RIA is requesting enhanced permissions to run outside the security sandbox.

At the Very High setting, only RIAs that are signed with a valid certificate that is located in the Signer CA keystore, and include the Permissions attribute in the manifest for the main JAR file are allowed to run with security prompts. At the High setting, RIAs that are signed with a valid certificate that is located in the Signer CA keystore, and include the Permissions attribute in the manifest for the main JAR file are allowed to run with security prompts. Applications are also allowed to run with security prompts when the revocation status of the certificate cannot be checked. For more information on security levels, see Section 20.4, "Security."

The default security level is High.

The ability to run applications is also affected by the settings described in Section 23.1.5, "Security Options for a Secure Execution Environment."

23.1.5 Security Options for a Secure Execution Environment

The following options are available in the Advanced tab of the Java Control Panel to set the behavior when a RIA is started:

  • Allow user to grant permissions to signed content

  • Show sandbox warning banner

  • Allow user to accept JNLP security requests

  • Don't prompt for client certificate selection when no certificates or only one exists

  • Warn if site certificate does not match hostname

  • Show site certificate even if it is valid

See Section 20.5, "Advanced" for more information on advanced options.

23.1.6 Install Options

Note:

These options are available only on Microsoft Windows.

Starting in the JDK 7u10 release, arguments for command line installation are available for setting the security level for Java in the browser. Admin privileges are required to install the JRE.

  • On installation, the WEB_JAVA argument has the following effect:

    • WEB_JAVA=1 enables Java in the browser

    • WEB_JAVA=0 disables Java in the browser

  • On installation, the WEB_JAVA_SECURITY_LEVEL argument has the following effect:

    • WEB_JAVA_SECURITY_LEVEL=VH sets the security level to very high

    • WEB_JAVA_SECURITY_LEVEL=H sets the security level to high

After installation of the JRE, you can check the Java Control Panel to verify that the security level settings are correct.

23.1.7 RIAs with Mixed Code

This information also applies to RIAs that contain calls between privileged code and sandbox code. For more information, see Chapter 27, "Mixing Privileged Code and Sandbox Code."

23.2 Policy Files and Permissions

RIAs are by default run in a secure sandbox that defines the set of permissions that code in an untrusted application is granted.

The standard Java policy files can be used to enhance the permissions granted to untrusted applications. In addition to $JRE_HOME/lib/security/java.policy (used by all java programs), applications and applets loaded by Java Web Start and Java Plug-in load an additional policy file, whose location can be configured by the deployment configuration property: deployment.system.security.policy.

The default sandbox, combined with the permissions granted by these policy files, if they exist, determine the permissions granted to untrusted code.

One other policy file, whose location is determined by the deployment configuration property deployment.security.trusted.policy, can be used to restrict the permissions granted to trusted code. When this property is not set, which is the default, trusted code will be granted the AllPermission permission. When this property is set, trusted code will be granted only the permissions granted to untrusted code, plus any other permissions granted by the policy file pointed to by this property.

23.3 Property Files and Certificates

The deployment configuration also has several properties that determine how and if code can be trusted. Normally, any signed JAR file in Java Plug-in, and any set of signed JAR files in Java Web Start that are listed in a JNLP file requesting the AllPermission permission, will be granted trust by the user after the certificate chains have been verified and shown to the user in a security dialog.

The deployment configuration property deployment.user.security.trusted.certs points to a certificate store that contains the certificates already accepted by the user.

The deployment configuration property deployment.system.security.trusted.certs can be configured to point to a certificate store of certificates pre-accepted by the system administrator.

If a JAR file (in Java Plug-in) or set of JAR files in a JNLP file requesting the AllPermission permission (in Java Web Start) is signed by a certificate that is in one of these stores, it will be trusted.

The deployment configuration property deployment.security.askgrantdialog.show can control if the user is permitted to grant trust to new code signed with new certificates.

23.4 Browser Keystores

Java Plug-in and Java Web Start support browser keystore in Internet Explorer and Firefox. Certificates and keys in browser keystores are used for the following purposes:

  • Signature signing verification

  • HTTPS server authentication

  • HTTPS client authentication

If the certificates and keys are on the smart cards, they are also recognized by Java Plug-in and Java Web Start if exposed in the browser keystore.

By default, browser keystore support is enabled. Users can configure the support through the Advanced tab in the Java Control Panel. See Section 20.5, "Advanced" for information.

23.4.1 Internet Explorer keystore support

On Windows, browser keystore is supported through Internet Explorer. Certificates and keys in Internet Explorer are automatically recognized by Java Plug-in and Java Web Start when Java and JavaFX applications are deployed on Windows.

This feature is supported only with Internet Explorer 5.0 or higher.

23.4.2 Mozilla keystore support

On Linux and Solaris, browser keystore is supported through Mozilla. Certificates and keys in Mozilla are recognized by Java Plug-in and Java Web Start when Java and JavaFX applications are deployed on Linux and Solaris.

Support for Mozilla keystore requires a Mozilla library called JSS (Network Security Services for Java). By default, JSS is a separate component that does not ship with Mozilla -- it is the responsibility of the deployer to install JSS with Mozilla. Java Plug-in and Java Web Start enable the Mozilla keystore support after JSS is deployed.

This feature is supported only with Mozilla 1.4 or higher and JSS 3.2 or higher, assuming both Mozilla and JSS are compiled using the same compiler on the same platform.

23.4.3 Installing JSS with Mozilla

To install on Windows, follow these steps:

  1. Create jss directory under Mozilla's installed directory.

  2. Copy JSS JAR file into the jss directory.

  3. Copy JSS native library DLL into Mozilla's installed directory.

To install on Solaris or Linux, follow these steps:

  1. Create jss directory under Mozilla's installed directory.

  2. Copy JSS JAR file into the jss directory.

  3. Copy JSS native library .so into Mozilla's installed directory.

  4. Set environment variable MOZILLA_HOME to Mozilla's installed directory in Mozilla's launch script.

  5. Change environment variable LD_LIBRARY_PATH to include Mozilla's installed directory in Mozilla's launch script.

23.5 Security Dialogs

The Root Certificate Authority certificate stores are the union of the certificate stores in the files pointed to by the properties: deployment.user.security.cacerts and deployment.system.security.cacerts. By default deployment.system.security.cacerts points to the cacerts file in the jre/lib/security directory. deployment.user.security.cacerts points to a file that contains any additional cacerts imported into it using the Certificates dialog in the Security tab of the Java Control Panel.

If the deployment.security.askgrantdialog.show property allows it, and the code is signed with certificate chains that can be properly validated, the users are then prompted to grant trust to the code. The following sections describe the security dialogs.

23.5.1 Dialog Contents

Beginning with the 7u21 release, users are notified when a RIA is launched with a security prompt similar to the following screen shot.

Figure 23-1 Security Dialog for a Trusted Application

Description of Figure 23-1 follows
Description of "Figure 23-1 Security Dialog for a Trusted Application"

Depending on the RIA, the security prompt shows the following information:

  • Name of the RIA, or notification that the application is unsigned.

    The name that is shown is the value of the Application-Name attribute in the JAR file manifest. If the Application-Name attribute is not present, the value for the Main-Class attribute is used. If neither attribute is present in the manifest, no title is shown in the security prompts. Titles are not shown for unsigned RIAs. See Section 26.3, "Application-Name Attribute" for information.

  • Warning when an out-of-date JRE is being used.

    For enterprises that manage the update process of user's systems, the deployment property deployment.expiration.check.enabled can be set to suppress the warnings for out-of-date JREs. See Chapter 21, "Deployment Configuration File and Properties" for information.

  • Information about the publisher.

    If the application is self-signed or signed by an unknown authority, the publisher is shown as UNKNOWN.

  • Warnings about the certificate.

    If the certificate is expired, revoked, or the server that tracks which certificates were revoked cannot be accessed, the prompt shows a warning. A warning is also shown if the certificate is not valid until a future date.

  • Location from which the application is accessed.

    The value is either a URL for applications that are accessed from a website, or a directory for applications that are accessed from a local drive.

  • Level of access required by the application.

    Limited access restricts the application to the security sandbox, unrestricted access provides the application with access to resources on the user's system.

  • Warning about missing JAR file manifest attributes.

    JAR file manifest attributes are available to provide additional protection for an application. The warning indicates that the manifest is missing a recommended attribute. See Chapter 26, "JAR File Manifest Attributes for Security" for information.

  • For unsigned or self-signed applications, a checkbox that the user must select before the Run button is enabled.

  • Option to not show the prompt again.

    For signed RIAs, future prompts for this RIA and RIAs from the same location that are signed with the same certificate can be turned off. If the RIA is a sandbox application, then the prompt is turned off only for other sandbox applications that are signed with the same certificate. When shown, click Show Options to access the option to turn off the prompt.

    Prompts that were previously hidden can be restored through a button on the Security tab of the Java Control Panel. See Section 20.4.4, "Restore Security Prompts" for information.

  • Buttons to Run the RIA, Cancel the RIA, and when a JRE is out of date, to Update to the latest JRE.

For a description and examples of the security prompts, see "What should I do when I see a security prompt from Java?" on java.com.

23.5.2 Improving the User Experience

The best experience for the user is when the RIA is restricted to the security sandbox and is signed with a current certificate from a trusted certificate authority. Clicking Run is all that is needed from the user to run the RIA.

As conditions become less secure, warning messages become stronger, and in some cases, more action is needed by the user, as described for the following situations:

  • If the RIA is signed with a certificate from a trusted certificate authority, but requires unrestricted access to the user's system, the prompt warns the users about the risk of running the RIA. Clicking Run starts the RIA.

  • If the RIA is signed with a certificate and the revocation status of the certificate cannot be checked, the prompt provides stronger warnings about the risk of running the RIA. The user must select the option to accept the risk, which enables the Run button, then click Run to run the RIA.

  • Additional warnings are shown in some cases, such as when sandbox code attempts to access privileged code, or a RIA attempts to access resources that it does not have permission to access. These warnings require additional responses from the user.

For guidelines on deploying your RIA, see Deployment Best Practices in the Java Tutorial. For information on how the deployment of RIAs is handled, see Chapter 24, "Rich Internet Application Deployment Process.".

23.5.3 Java Control Panel Settings That Affect the Dialogs Shown

The Java Control Panel can be used to set options that are related to the security prompts. The Security tab provides an option to block Java content from running in a browser. The Security Level setting determines if the applet is automatically blocked and what level of prompting the user receives if the RIA is not blocked. See Section 20.4, "Security" for more information.

The Advanced tab provides options for managing RIAs:

  • Secure Execution Environment options provide control for allowing or prohibiting users from granting privileges. If the user is not allowed to grant privileges, the security prompt is not shown and the app or features of the app are blocked.

  • Mixed code security verification options provide control for showing or hiding prompts that warn of mixed code. If the prompts are hidden, some features might be blocked without any notice to the user.

See Section 20.5, "Advanced" for more information.

23.6 Warning Banner

One final setting can be used to customize the user experience in Java Web Start. By default the sandbox does not include the AWTPermissionshowWindowWithoutWarningBanner. Without this permission, all top-level windows will contain the awt banner "Java Application Window" or "Java Applet Window". The deployment configuration property deployment.security.sandbox.awtwarningwindow can be used to add this permission to untrusted code.

23.7 More Information

For a detailed discussion of properties, see Chapter 21, "Deployment Configuration File and Properties."

For details about security in the Java Control Panel, see Section 20.4, "Security."

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

Part IV

Debug Client Issues

This part describes Java Client issues, troubleshooting techniques, and debugging tips for Client issues. The following topics are included.

  • Introduction to Client Issues

    Provides an overview of Java Client technologies, describes Java Client issues and troubleshooting tips.

  • AWT

    Provides guidance on specific procedures for debugging issues that occur with Java SE Abstract Windows Toolkit (AWT).

  • Java 2D

    Provides guidance on troubleshooting some common issues found in Java 2D API.

  • Swing

    Provides guidance on troubleshooting some common issues found in Java SE Swing API.

  • Internationalization

    Provides guidance on troubleshooting some issues found in Java Internationalization.

  • Java Sound

    Describes some issues and causes that arise with Java Sound technology and suggests work-arounds.

  • Applets and Java Web Start Applications

    Describes problems, troubleshooting tips, and solutions in deploying Java Applications and Applets.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Rich Internet Applications - Development, Deployment, and Runtime Enhancements

Java Rich Internet Applications Guide > Enhancements and Other Features > Rich Internet Applications - Development, Deployment, and Runtime Enhancements

Java rich Internet application (RIA) technology is getting increasingly sophisticated. New features are being added in every release of the Java Runtime Environment (JRE) software. This quick reference helps you keep up with the vibrant technology and implement RIA solutions that work elegantly on all versions of the client JRE software. The quick reference provides information about significant capabilities added in each version of the JRE software starting with the Java SE 6 update 10 release.

JDK 8

See What's New in the Java Platform, Standard Edition Deployment Guide.

JDK 7

See Java Rich Internet Applications Enhancements in Java SE 7 in the Java Platform, Standard Edition Deployment Guide.

Java SE 6 update 21

  • Customized loading progress indicator: Customized loading progress indicator can access applet context and invoke JavaScript code in parent web page.

Java SE 6 update 18

  • Customized loading progress indicator: Customized loading progress indicator can be displayed in a top level window or applet container. Default splash screen is never displayed. Custom splash screen displayed when loaded from cache.

Java SE 6 update 10

  • Java Network Launch Protocol (JNLP) Support: The next generation Java Plug-in enables applets that can be deployed by using JNLP and can access JNLP API.
  • Draggable applet: Applets can be dragged out of the browser if specified as "draggable".
  • Splash screen: Custom splash screen displayed if specified.

Resources

  • Deployment trail in the Java Tutorials
  • JavaFX Documentation
  • Deploying JavaFX Applications
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Use of JAAS Login Utility and Java GSS-API for Secure Message Exchanges

This tutorial presents two sample applications to demonstrate the use of the Java GSS-API. This API permits secure exchanges of messages between communicating applications. Here are the sample client and server applications you'll need for this tutorial:

  • SampleClient
  • SampleServer
Note: This tutorial uses the same client and server applications as the Use of Java GSS-API for Secure Message Exchanges Without JAAS Programming tutorial. In that tutorial, JAAS (Java Authentication and Authorization Service) programming is not required. Instead, you let the underlying mechanism decide how to get credentials.
This tutorial uses policy files and a more complex login configuration file. The programs are run with a security manager; as a result, security-sensitive operations are not allowed unless the required permissions were explicitly granted. This tutorial also demonstrates how JAAS authorization adds user-centric access control that applies control based on who is running the code--not just on what code is running.

Contents:

  • Before You Start: Recommended Reading
  • Overview of the Client And Server Applications
  • Kerberos User and Service Principal Names
  • The Login Configuration File
  • The Policy Files
  • Running the SampleClient and SampleServer Programs

Before You Start: Recommended Reading

In this Java GSS-API tutorial, the first step is JAAS authentication. Previous tutorials demonstrated the use of JAAS for user authentication and authorization, and presented examples of policy files and of login configuration files (specifying the underlying authentication technology to be used) that JAAS requires. Applications in the JAAS introductory tutorials, JAAS Authentication and JAAS Authorization, made direct calls to JAAS methods. The Use of JAAS Login Utility tutorial showed the use of a utility program that frees the application from having to do this. The client and server applications in the current tutorial also use the same utility program, so we recommend you read the login utility tutorial first.

As with all tutorials in this series, the underlying technology used to support authentication and secure communication for the applications in this tutorial is Kerberos. See Kerberos Requirements.

Overview of the Client and Server Applications

The applications for this tutorial are named SampleClient and SampleServer.

Each is invoked by executing the Login utility supplied with this tutorial and passing it as arguments the name of the application (SampleClient or SampleServer), followed by the arguments needed by the application. The Login utility uses a JAAS LoginContext to authenticate the user using Kerberos. Finally, the Login utility invokes the main method of the application class, in our case either SampleClient or SampleServer, and passes the application its arguments.

Here is a summary of execution of the SampleClient and SampleServer applications:

  1. Run the SampleServer application by running the Login utility and passing it as arguments the name "SampleServer" followed by the arguments for the SampleServer program. The Login utility prompts you for the password for the principal that SampleServer should run as. (See Kerberos User and Service Principal Names.) After authentication is complete, SampleServer is run it:
    1. Reads its argument, the port number that it should listen on for client connections.
    2. Creates a ServerSocket for listening for client connections on that port.
    3. Listens for a connection.
  2. Run the SampleClient application (possibly on a different machine), by running the Login utility and passing it as arguments the name "SampleClient" followed by the arguments for the SampleClient program. The Login utility prompts you for your Kerberos name and password. After authentication is complete, SampleClient is run. It
    1. Reads its arguments: (1) The name of the Kerberos principal that represents SampleServer. (See Kerberos User and Service Principal Names.), (2) the name of the host (machine) on which SampleServer is running, and (3) the port number on which SampleServer listens for client connections.
    2. Attempts a socket connection with the SampleServer, using the host and port it was passed as arguments.
  3. The socket connection is accepted by SampleServer and both applications initialize a DataInputStream and a DataOutputStream from the socket input and output streams, to be used for future data exchanges.
  4. SampleClient and SampleServer each instantiate a GSSContext and establish a shared context that will enable subsequent secure data exchanges.
  5. SampleClient and SampleServer can now securely exchange messages.
  6. When SampleClient and SampleServer are done exchanging messages, they perform clean-up operations.
Note: Refer to "The SampleClient and SampleServer Code" section of the Use of Java GSS-API for Secure Message Exchanges Without JAAS Programming tutorial for a full discussion of the code used in this tutorial.

Kerberos User and Service Principal Names

Since the underlying authentication and secure communication technology used by this tutorial is Kerberos V5, we use Kerberos-style principal names wherever a user or service is called for.

For example, when you run SampleClient you are asked to provide your user name. Your Kerberos-style user name is simply the user name you were assigned for Kerberos authentication. It consists of a base user name (like "mjones") followed by an "@" and your realm (like "mjones@KRBNT-OPERATIONS.EXAMPLE.COM").

A server program like SampleServer is typically considered to offer a "service" and to be run on behalf of a particular "service principal." A service principal name for SampleServer is needed in several places:

  • When you run SampleServer you must log in as the appropriate service principal. The login configuration file for this tutorial actually specifies the service principal name (as an option to the Krb5LoginModule), so the JAAS authentication (done by the Login utility) just asks you to specify the password for that service principal. If you specify the correct password, the authentication is successful, a Subject is created containing a Principal with the service principal name, and that Subject is associated with a new access control context. The subsequently-executed code (the SampleServer code) is considered to be executed on behalf of the specified principal.
  • When you run SampleClient, one of the arguments is the service principal name. This is needed so SampleClient can initiate establishment of a security context with the appropriate service.
  • The client and server policy files each require a ServicePermission with name equal to the service principal name and action equal to "initiate" or "accept" (for initiating or accepting establishment of a security context).

Throughout this document, and in the accompanying login configuration file and policy files,

service_principal@your_realm
is used as a placeholder to be replaced by the actual name to be used in your environment. Any Kerberos principal can actually be used for the service principal name. So for the purposes of trying out this tutorial, you could use your user name as both the client user name and the service principal name.

In a production environment, system administrators typically like servers to be run as specific principals only and may assign a particular name to be used. Often the Kerberos-style service principal name assigned is of the form

service_name/machine_name@realm;

For example, an nfs service run on a machine named "raven" in the realm named "KRBNT-OPERATIONS.EXAMPLE.COM" could have the service principal name

nfs/raven@KRBNT-OPERATIONS.EXAMPLE.COM

Such multi-component names are not required, however. Single-component names, just like those of user principals, can be used. For example, an installation might use the same ftp service principal ftp@realm for all ftp servers in that realm, while another installation might have different ftp principals for different ftp servers, such as ftp/host1@realm and ftp/host2@realm on machines host1 and host2, respectively.

When the Realm is Required in Principal Names

If the realm of a user or service principal name is the default realm (see Kerberos Requirements), you can leave off the realm when you are logging into Kerberos (that is, when you are prompted for your username). Thus, for example, if your user name is "mjones@KRBNT-OPERATIONS.EXAMPLE.COM", and you run SampleClient, when it requests your user name you could just specify "mjones", leaving off the realm. The name is interpreted in the context of being a Kerberos principal name and the default realm is appended, as needed.

You can also leave off the realm if a principal name will be converted to a GSSName by a GSSManager createName method. For example, when you run SampleClient, one of the arguments is the server service principal name. You can specify the name without including the realm, because SampleClient passes the name to such a createName method, which appends the default realm as needed.

It is recommended that you always include realms when principal names are used in login configuration files and policy files, because the behavior of the parsers for such files may be implementation-dependent; they may or may not append the default realm before such names are utilized and subsequent actions may fail if there is no realm in the name.

The Login Configuration File

Whenever JAAS is used, a login configuration is required to specify the desired authentication technology. (See JAAS Login Configuration File for more information about what a login configuration file is.) Both SampleClient and SampleServer can use the same login configuration file, if that file contains two entries, one entry for the client side and one for the server side.

The csLogin.conf login configuration file used for this tutorial is the following:

SampleClient {
  com.sun.security.auth.module.Krb5LoginModule required;
};

SampleServer {
  com.sun.security.auth.module.Krb5LoginModule required storeKey=true
    principal="service_principal@your_realm";
};

Note that the name for each entry matches the respective class names for our two top-level applications, SampleClient and SampleServer. Recall that this is also the name that is passed to the Login utility that performs JAAS operations for the application. That utility expects the name of the entry to be looked up in your login configuration file to be the same as the name it is passed.

Both entries specify that Sun's Kerberos V5 LoginModule must be used to successfully authenticate the user. The Krb5LoginModule succeeds only if the attempt to log in to the Kerberos KDC as a specified entity is successful. In the case of SampleClient, the user will be prompted for their name and password. In the case of SampleServer, a name is already supplied in this login configuration file (the specified principal, as described below) and the user running SampleServer is just asked for the password for the entity specified by that name. They must specify the correct password in order for authentication to succeed.

The SampleServer entry storeKey=true indicates that a secret key should be calculated from the password provided during login and it should be stored in the private credentials of the Subject created as a result of login. This key is subsequently utilized during mutual authentication when establishing a security context between SampleClient and SampleServer.

The Krb5LoginModule has a principal option that can be used to specify that only the specified principal (entity/user) should be logged in for the given program. Here, the SampleClient entry does not specify a principal (although it could, if desired), so the user is prompted for a user name and password and anyone with a valid user name and password can run SampleClient. SampleServer, on the other hand, indicates a particular principal because system administrators usually like servers to be run as specific principals only. In this case, the user running SampleServer is prompted for that principal's password and must supply the correct one in order for authentication to succeed.

Note that you must replace "service_principal@your_realm" with the name of the service principal that represents SampleServer. (See Kerberos User and Service Principal Names.)

For information about all the possible options that can be passed to Krb5LoginModule, see the Krb5LoginModule documentation.

The Policy Files

The policy file used when running SampleClient is client.policy, and the policy file used when running SampleServer is server.policy. Their contents are described below.

The Client Policy File

Permissions Required by the Login utility Classes

A number of permissions are required by the classes in Login.java (Login and MyAction). As recommended in the previous tutorial on the use of Login, we create a Login.jar JAR file containing the Login.class and MyAction.class files and in the client.policy policy file we grant Login.jar AllPermission:

grant codebase "file:./Login.jar" {
   permission java.security.AllPermission;
};

Permissions Required by SampleClient

The SampleClient code does two types of operations for which permissions are required. It

  • opens a socket connection with the host machine running the SampleServer application.
  • initiates establishment of a security context with SampleServer.

The permission required to open a socket connection is

permission java.net.SocketPermission "*", "connect";

You may replace the "*" with the hostname or IP address of the machine that SampleServer will be running on.

The permission(s) required to initiate establishment of a security context will depend on the underlying mechanism. This tutorial uses Kerberos as the underlying mechanism, and for that two javax.security.auth.kerberos.ServicePermissions are required. A ServicePermission contains a service principal name and an action (or list of actions). To initiate establishment of a security context, you need two ServicePermissions with action "initiate", whose names specify:

  • the service principal name for the ticket granting service for your realm. Granting this permission essentially allows the use of Kerberos as a client.
  • the service principal name representing SampleServer. (See Kerberos User and Service Principal Names.) Granting this permission allows you to interact with the service, SampleServer, using Kerberos.

We want to grant the permissions to a specific authenticated user executing SampleClient, so we specify both the SampleClient code location (in SampleClient.jar) and a Principal designation indicating the user name and realm for the user (you, the person who will run SampleClient). (See How Do You Make Principal-Based Policy File Statements? in the second tutorial of this series for information on policy file grant statements that include Principal designations.)

Here is the basic form for the grant statement:

  grant CodeBase "file:./SampleClient.jar",
    Principal javax.security.auth.kerberos.KerberosPrincipal
        "your_user_name@your_realm" {

    permission java.net.SocketPermission "*", "connect";

    permission javax.security.auth.kerberos.ServicePermission
        "krbtgt/your_realm@your_realm",
        "initiate";

    permission javax.security.auth.kerberos.ServicePermission
        "service_principal@your_realm",
        "initiate";
};

You must substitute your Kerberos user name (complete with "@" and realm) for "your_user_name@your_realm". For example, if your user name is "mjones" and your realm is "KRBNT-OPERATIONS.EXAMPLE.COM", you would use "mjones@KRBNT-OPERATIONS.EXAMPLE.COM" (complete with the quotes).

You must also substitute your realm in "krbtgt/your_realm@your_realm" and the service principal name for the service principal representing the server for "service_principal@your_realm". Suppose the former is "krbtgt/KRBNT-OPERATIONS.EXAMPLE.COM@KRBNT-OPERATIONS.EXAMPLE.COM" and the latter is "sample/raven.example.com@KRBNT-OPERATIONS.EXAMPLE.COM", and your user name is as specified in the previous paragraph. Then the grant statement would be

grant CodeBase "file:./SampleClient.jar",
    Principal javax.security.auth.kerberos.KerberosPrincipal
        "mjones@KRBNT-OPERATIONS.EXAMPLE.COM" {

    permission java.net.SocketPermission "*", "connect";

    permission javax.security.auth.kerberos.ServicePermission
        "krbtgt/KRBNT-OPERATIONS.EXAMPLE.COM@KRBNT-OPERATIONS.EXAMPLE.COM",
        "initiate";

    permission javax.security.auth.kerberos.ServicePermission
        "sample/raven.example.com@KRBNT-OPERATIONS.EXAMPLE.COM",
        "initiate";
};

The Server Policy File

Permissions Required by the Login Utility Classes

The grant statement in the server policy file for the Login classes is exactly the same as the one in the client policy file, as described in Permissions Required by the Login Utility Classes:

grant codebase "file:./Login.jar" {
   permission java.security.AllPermission;
};

Permissions Required by SampleServer

The SampleServer code does two types of operations for which permissions are required. It

  • accepts socket connections.
  • accepts establishment of a security context, that is, it is the "acceptor" for security context establishment.

The permission required to accept socket connections is

permission java.net.SocketPermission "*", "accept";

You may replace the "*" with the hostname or IP address of the machine that SampleClient will be running on.

The permission required to accept establishment of a security context is

permission javax.security.auth.kerberos.ServicePermission
    "service_principal@your_realm",
    "accept";
where "service_principal@your_realm" is the Kerberos name of the service principal that represents SampleServer.

We want to grant the permissions to a specific authenticated user executing SampleServer (the service principal considered to represent SampleServer), so we specify both the SampleServer code location (in SampleServer.jar) and a Principal designation indicating the service principal. Suppose this name is "sample/raven.example.com@KRBNT-OPERATIONS.EXAMPLE.COM". Then the grant statement would be

  grant CodeBase "file:./SampleServer.jar"
    Principal javax.security.auth.kerberos.KerberosPrincipal
        "sample/raven.example.com@KRBNT-OPERATIONS.EXAMPLE.COM" {

    permission java.net.SocketPermission "*", "accept";

    permission javax.security.auth.kerberos.ServicePermission
        "sample/raven.example.com@KRBNT-OPERATIONS.EXAMPLE.COM", "accept";
};

Running the SampleClient and SampleServer Programs

To execute the SampleClient and SampleServer programs, do the following:

  • Prepare SampleServer for Execution
  • Prepare SampleClient for Execution
  • Execute SampleServer
  • Execute SampleClient

Prepare SampleServer for Execution

To prepare SampleServer for execution, do the following:

  1. Copy the following files into a directory accessible by the machine on which you will run SampleServer:
    • The Login.java source file.
    • The SampleServer.java source file.
    • The csLogin.conf login configuration file.
    • The server.policy policy file.
  2. Replace "service_principal@your_realm" in csLogin.conf with the name of the service principal representing SampleServer.
  3. In both places it appears, replace "service_principal@your_realm" in server.policy with the Kerberos name of the service principal that represents SampleServer. (The same name as that used in the login configuration file.)
  4. Compile Login.java and SampleServer.java:
    javac Login.java SampleServer.java

    Note that Login.java contains two classes and thus compiling Login.java creates Login.class and MyAction.class.

  5. Create a JAR file named Login.jar containing Login.class and MyAction.class:
    jar -cvf Login.jar Login.class MyAction.class
  6. Create a JAR file named SampleServer.jar containing SampleServer.class:
    jar -cvf SampleServer.jar SampleServer.class

Prepare SampleClient for Execution

To prepare SampleClient for execution, do the following:

  1. Copy the following files into a directory accessible by the machine on which you will run SampleClient:
    • The Login.java source file.
    • The SampleClient.java source file.
    • The csLogin.conf login configuration file.
    • The client.policy policy file.
  2. Replace parts of client.policy:
    • replace "your_user_name@your_realm" with your user name and realm.
    • replace your_realm in "krbtgt/your_realm@your_realm" with your realm.
    • replace "service_principal@your_realm" with the Kerberos name of the service principal that represents SampleServer.
  3. Compile Login.java and SampleClient.java:
    javac Login.java SampleClient.java
  4. Create a JAR file named Login.jar containing Login.class and MyAction.class:
    jar -cvf Login.jar Login.class MyAction.class
  5. Create a JAR file named SampleClient.jar containing SampleClient.class:
    jar -cvf SampleClient.jar SampleClient.class

Execute SampleServer

It is important to execute SampleServer before SampleClient because SampleClient will try to make a socket connection to SampleServer and that will fail if SampleServer is not yet running and accepting socket connections.

To execute SampleServer, be sure to run it on the machine it is expected to be run on. This machine name (host name) is specified as an argument to SampleClient. The service principal name appears in several places, including the login configuration file and the policy files.

Go to the directory in which you have prepared SampleServer for execution. Execute the Login class, specifying

  • by an appropriate -classpath clause that classes should be searched for in the Login.jar and SampleServer.jar JAR files,
  • by -Djava.security.manager that a security manager should be installed,
  • by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified. For example, if your realm is "KRBNT-OPERATIONS.EXAMPLE.COM" you'd put -Djava.security.krb5.realm=KRBNT-OPERATIONS.EXAMPLE.COM.
  • by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified. For example, if your KDC is "samplekdc.example.com" you'd put -Djava.security.krb5.kdc=samplekdc.example.com.
  • by -Djava.security.policy=server.policy that the policy file to be used is server.policy, and
  • by -Djava.security.auth.login.config=csLogin.conf that the login configuration file to be used is csLogin.conf.

You pass the name of your application (in this case, "SampleServer") as an argument to Login. You then add as arguments any arguments required by your application, which in the case of SampleServer is a single argument specifying the port number to be used for listening for client connections. Choose a high port number unlikely to be used for anything else. An example would be something like 4444.

Below are the full commands to use for both Microsoft Windows and Solaris, Linux, and Mac OS X systems. The only difference is that on Microsoft Windows systems you use semicolons to separate classpath items, while you use colons for that purpose on Solaris, Linux, and Mac OS X systems.

Important: In these commands, you must replace <port_number> with an appropriate port number, <your_realm> with your Kerberos realm, and <your_kdc> with your Kerberos KDC.

Here is the command for Microsoft Windows systems:

java -classpath Login.jar;SampleServer.jar
 -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=server.policy
 -Djava.security.auth.login.config=csLogin.conf
 Login SampleServer <port_number>

Here is the command for Solaris, Linux, and Mac OS X systems:

java -classpath Login.jar:SampleServer.jar
 -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=server.policy
 -Djava.security.auth.login.config=csLogin.conf
 Login SampleServer <port_number>

Type the full command on one line. Multiple lines are used here for legibility. If the command is too long for your system, you may need to place it in a .bat file (for Microsoft Windows) or a .sh file (for Solaris, Linux, and Mac OS X) and then run that file to execute the command.

You will be prompted for the Kerberos password for the service principal. The underlying Kerberos authentication mechanism specified in the login configuration file will log the service principal into Kerberos. Once authentication is successfully completed, the SampleServer code will be executed on behalf of the service principal. It will listen for socket connections on the specified port.

For login troubleshooting suggestions, see Troubleshooting.

Execute SampleClient

To execute SampleClient, go to the directory in which you have prepared SampleClient for execution. Then execute the Login class, specifying

  • by an appropriate -classpath clause that classes should be searched for in the Login.jar and SampleClient.jar JAR files,
  • by -Djava.security.manager that a security manager should be installed,
  • by -Djava.security.krb5.realm=<your_realm> that your Kerberos realm is the one specified.
  • by -Djava.security.krb5.kdc=<your_kdc> that your Kerberos KDC is the one specified.
  • by -Djava.security.policy=client.policy that the policy file to be used is client.policy, and
  • by -Djava.security.auth.login.config=csLogin.conf that the login configuration file to be used is csLogin.conf.

Pass to Login the name of your application ("SampleClient") followed by the arguments required by SampleClient. The SampleClient arguments are (1) the Kerberos name of the service principal that represents SampleServer, (2) the name of the host (machine) on which SampleServer is running, and (3) the port number on which SampleServer is listening for client connections.

Below are the full commands to use for both Microsoft Windows and Solaris, Linux, and Mac OS X systems.

Important: In these commands, you must replace <service_principal>, <host>, <port_number>, <your_realm>, and <your_kdc> with appropriate values (and note that the port number must be the same as the port number passed as an argument to SampleServer). These values need not be placed in quotes.

Here is the command for Microsoft Windows systems:

java -classpath Login.jar;SampleClient.jar
 -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=client.policy
 -Djava.security.auth.login.config=csLogin.conf
 Login SampleClient <service_principal> <host> <port_number>

Here is the command for Solaris, Linux, and Mac OS X systems:

java -classpath Login.jar:SampleClient.jar
 -Djava.security.manager
 -Djava.security.krb5.realm=<your_realm>
 -Djava.security.krb5.kdc=<your_kdc>
 -Djava.security.policy=client.policy
 -Djava.security.auth.login.config=csLogin.conf
 Login SampleClient <service_principal> <host> <port_number>

Type the full command on one line. Multiple lines are used here for legibility. As with the command for executing SampleServer, if the command is too long to type directly into your command window, place it in a .bat file (Microsoft Windows) or a .sh file (Solaris, Linux, and Mac OS X) and then execute that file.

When prompted, type your Kerberos user name and password. The underlying Kerberos authentication mechanism specified in the login configuration file will log you into Kerberos. Once authentication is successfully completed, the SampleClient code will be executed on behalf of you. It will request a socket connection with SampleServer. Once SampleServer accepts the connection, SampleClient and SampleServer establish a shared context and then exchange messages as described in this tutorial.

For login troubleshooting suggestions, see Troubleshooting.

Tutorials Introduction and TOC
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


ClipboardService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface ClipboardService

  • public interface ClipboardService
    ClipboardService provides methods for accessing the shared system-wide clipboard, even for applications that are running in the untrusted execution environment. Implementors should warn the user of the potential security risk of letting an untrusted application have access to potentially confidential information stored in the clipboard, or overwriting the contents of the clipboard.
    Since:
    1.4.2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      java.awt.datatransfer.Transferable getContents()
      Returns a Transferable object representing the current contents of the clipboard.
      void setContents(java.awt.datatransfer.Transferable contents)
      Sets the current contents of the clipboard to the specified Transferable object.

    • Method Detail

      • getContents

        java.awt.datatransfer.Transferable getContents()
        Returns a Transferable object representing the current contents of the clipboard. If the clipboard currently has no contents, it returns null.
        Returns:
        The current Transferable object on the clipboard.

      • setContents

        void setContents(java.awt.datatransfer.Transferable contents)
        Sets the current contents of the clipboard to the specified Transferable object.
        Parameters:
        contents - The Transferable object representing clipboard content.
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Command-Line Options

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

D Command-Line Options

This appendix describes some command-line options that can be useful in diagnosing problems with the Java HotSpot VM.

This appendix contains the following sections:

  • Java HotSpot VM Command-Line Options

  • Other Command-Line Options

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java HotSpot VM Command-Line Options

Command-line options that are prefixed with -XX are specific to the Java HotSpot Virtual Machine. Many of these options are important for performance tuning and diagnostic purposes, and are therefore described in this appendix. For information on all possible -XX options, see the Java HotSpot VM Options.

You can dynamically set, unset, or change the value of certain Java VM flags for a specified Java process using the jinfo -flag command. See The jinfo Utility and the JConsole utility.

For a complete list of these flags, use the MBeans tab of the JConsole utility. See the list of values for the DiagnosticOptions attribute of the HotSpotDiagnostic MBean, which is in the com.sun.management domain. The following are the flags:

  • HeapDumpOnOutOfMemoryError

  • HeapDumpPath

  • PrintGC

  • PrintGCDetails

  • PrintGCTimeStamps

  • PrintClassHistogram

  • PrintConcurrentLocks

The -XX:HeapDumpOnOutOfMemoryError Option

This option tells the Java HotSpot VM to generate a heap dump when an allocation from the Java heap or the permanent generation cannot be satisfied. There is no overhead in running with this option, so it can be useful for production systems where the OutOfMemoryError exception takes a long time to surface.

You can also specify this option at runtime with the MBeans tab in the JConsole utility.

The heap dump is in HPROF binary format, and so it can be analyzed using any tools that can import this format. For example, the jhat tool can be used to do rudimentary analysis of the dump. For more information on the jhat tool, see The jhat Utility.

Example D-1 shows the result of running out of memory with this flag set.

Example D-1 Sample Code for Running Out of Memory

$ java -XX:+HeapDumpOnOutOfMemoryError -mn256m -mx512m ConsumeHeap
java.lang.OutOfMemoryError: Java heap space
Dumping heap to java_pid2262.hprof ...
Heap dump file created [531535128 bytes in 14.691 secs]
Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
        at ConsumeHeap$BigObject.(ConsumeHeap.java:22)
        at ConsumeHeap.main(ConsumeHeap.java:32)

The ConsumeHeap fills up the Java heap and runs out of memory. When the java.lang.OutOfMemoryError exception is thrown, a heap dump file is created. In this case the file is 507 MB and is created with the name java_pid2262.hprof in the current directory.

By default the heap dump is created in a file called java_pidpid.hprof in the working directory of the VM, as in the example above. You can specify an alternative file name or directory with the -XX:HeapDumpPath= option. For example -XX:HeapDumpPath=/disk2/dumps will cause the heap dump to be generated in the /disk2/dumps directory.

The -XX:OnError Option

When a fatal error occurs, the Java HotSpot VM can optionally execute a user-supplied script or command. The script or command is specified using the -XX:OnError=string command-line option, where string is a single command, or a list of commands separated by semicolons. Within this string, all occurrences of %p are replaced with the current PID, and all occurrences of %% are replaced by a single %. The following examples demonstrate how this option can be used when launching a Java application named MyApp with the java launcher.

  • java -XX:OnError="pmap %p" MyApp

    On Oracle Solaris operating system the pmap command displays information about the address space of a process. In the example above, if a fatal error occurs, the pmap command is executed to display the address space of the current process.

  • java -XX:OnError="cat hs_err_pid%p.log | mail support@acme.com" MyApp

    In the example above, the contents of the fatal error log file are mailed to a support alias when a fatal error is encountered.

  • java -XX:OnError="gcore %p; dbx - %p" MyApp

    On Oracle Solaris operating system the gcore command creates a core image of the specified process, and the dbx command launches the debugger. In the example above, the gcore command is executed to create the core image of the current process, and the debugger is started to attach to the process when an unexpected error is encountered.

  • java -XX:OnError="gdb - %p" MyApp

    On Linux the gdb command launches the debugger. In the example above, the gdb debugger is launched and attached to the current process when an unexpected error is encountered.

  • java -XX:OnError="userdump.exe %p" MyApp

    On Windows the userdump.exe utility creates a crash dump of the specified process. The utility does not ship with Windows and should be downloaded from the Microsoft website as a part of the Microsoft OEM Support Tools package.

    In the above example, the userdump.exe utility is executed to create a core dump of the current process in case of a fatal error.

    Note:

    The example assumes that the path to the userdump.exe utility is defined in the PATH variable.
    Tip

    If you do not have the userdump.exe utility installed, the Dr. Watson debugger can be configured as the post-mortem debugger so that a crash dump is created when an unexpected error is encountered.

For more information on creating crash dumps on Windows, see Collect Crash Dumps on Windows.

The -XX:ShowMessageBoxOnError Option

When this option is set and a fatal error is encountered, the HotSpot VM will display information about the fatal error and prompt the user to specify whether the native debugger is to be launched. In the case of Oracle Solaris and Linux operating systems, the output and prompt are sent to the application console (standard input and standard output). In the case of Windows, a Windows message box pops up.

Example D-2 shows a fatal error encountered on a Linux system.

Example D-2 Fatal Error on a Linux System

==============================================================================
Unexpected Error
------------------------------------------------------------------------------
SIGSEGV (0xb) at pc=0x2000000001164db1, pid=10791, tid=1026

Do you want to debug the problem?

To debug, run 'gdb /proc/10791/exe 10791'; then switch to thread 1026
Enter 'yes' to launch gdb automatically (PATH must include gdb)
Otherwise, press RETURN to abort...
==============================================================================

In this case a SIGSEGV error has occurred and the user is prompted to specify whether the gdb debugger is to be launched to attach to the process. If the user enters y or yes, gdb will be launched (assuming it is set in the PATH variable).

On Oracle Solaris operating system the message is similar to the above except that the user is prompted to start the dbx debugger.

On Windows a message box is displayed. If the user clicks Yes, the VM will attempt to start the default debugger. This debugger is configured by a registry setting which is described in Collect Crash Dumps on Windows. If Microsoft Visual Studio is installed, the default debugger is typically configured to be msdev.exe.

In the above example the output includes the PID (pid=10791) and also the thread ID (tid=1026). If the debugger is launched, one of the initial steps in the debugger might be to select the thread and obtain its stack trace.

As the process is waiting for a response it is possible to use other tools to obtain a crash dump or query the state of the process. On Oracle Solaris operating system, for example, a core dump can be obtained using the gcore utility.

On Windows a Dr. Watson crash dump can be obtained using the userdump or windbg programs. The windbg utility is included in Microsoft's Debugging Tools for Windows and is described in Collect Crash Dumps on Windows. In windbg, select the Attach to a Process menu option, which displays the list of processes and prompts for the PID. The HotSpot VM displays a message box, which includes the PID. Once selected the .dump /f command can be used to force a crash dump. Figure D-1 is an example crash dump created in a file named crash.dump.

Figure D-1 Example of a Crash Dump Created by windbg

Description of Figure D-1 follows
Description of "Figure D-1 Example of a Crash Dump Created by windbg"

In general the -XX:+ShowMessageBoxOnError option is more useful in a development environment where debugger tools are available. The -XX:OnError option is more suitable for production environments where a fixed sequence of commands or scripts are executed when a fatal error is encountered.

Other -XX Options

Several other -XX command-line options can be useful in troubleshooting:

  • -XX:OnOutOfMemoryError=string

    This option can be used to specify a command or script to execute when an OutOfMemoryError exception is thrown.

  • -XX:ErrorFile=filename

    This option can be used to specify a location for the fatal error log file, see Location of Fatal Error Log.

  • -xx:HeapDumpPath=path

    This option can be used to specify a location for the heap dump, see The -XX:HeapDumpOnOutOfMemoryError Option.

  • -XX:MaxPermSize=size

    This option can be used to specify the size of the permanent generation memory, see Exception in thread thread_name: java.lang.OutOfMemoryError: GC Overhead limit exceeded.

  • -XX:+PrintCommandLineFlags

    This option can be used to print all the VM command-line flags, see Collect Data for a Bug Report.

  • -XX:+PrintConcurrentLocks

    This option can be used to cause the Control+Break handler to print a list of concurrent locks owned by each thread.

  • -XX:+PrintClassHistogram

    This option can be used to cause the Control+Break handler to print a heap histogram.

  • -XX:+PrintGCDetails and-XX:+PrintGCTimeStamps

    These options can be used to print detailed information about garbage collection, see The -verbose:gc Option.

  • -XX:+UseAltSigs

    On Oracle Solaris 8 and 9 operating system, this option can be used to instruct the HotSpot VM to use alternate signals to SIGUSR1 and SIGUSR2, see Handle Signals on Oracle Solaris and Linux.

  • -XX:+UseConcMarkSweepGC , -XX:+UseSerialGC and -XX:+UseParallelGC

    These options can be used to specify the garbage collection policy to be used, see Working Around Crashes during Garbage Collection.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Other Command-Line Options

In addition to the -XX options, many other command-line options can provide troubleshooting information. This section describes a few of these options.

The -Xcheck:jni Option

This option is useful in diagnosing problems with applications that use the Java Native Interface (JNI). Sometimes bugs in the native code can cause the HotSpot VM to crash or behave incorrectly.

The -Xcheck:jni option is added to the command line that starts the application, as in the following example:

java -Xcheck:jni MyApp

The -Xcheck:jni option causes the VM to do additional validation on the arguments passed to JNI functions. Note: The option is not guaranteed to find all invalid arguments or diagnose logic bugs in the application code, but it can help diagnose a large number of such problems.

When an invalid argument is detected, the VM prints a message to the application console or to standard output, prints the stack trace of the offending thread, and aborts the VM.

Example D-3 shows a null value was incorrectly passed to a JNI function that does not allow a null value.

Example D-3 Null Value Passed to JNI Function

FATAL ERROR in native method: Null object passed to JNI
    at java.net.PlainSocketImpl.socketAccept(Native Method)
    at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:343)
    - locked <0x450b9f70> (a java.net.PlainSocketImpl)
    at java.net.ServerSocket.implAccept(ServerSocket.java:439)
    at java.net.ServerSocket.accept(ServerSocket.java:410)
    at org.apache.tomcat.service.PoolTcpEndpoint.acceptSocket
                        (PoolTcpEndpoint.java:286)
    at org.apache.tomcat.service.TcpWorkerThread.runIt
                        (PoolTcpEndpoint.java:402)
    at org.apache.tomcat.util.ThreadPool$ControlRunnable.run
                        (ThreadPool.java:498)
    at java.lang.Thread.run(Thread.java:536)

Example D-4 shows an incorrect argument was provided to a JNI function that expects a jfieldID argument.

Example D-4 Incorrect Argument Provided to a JNI Function

FATAL ERROR in native method: Instance field not found in JNI get/set
                        field operations
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
        - locked <0xf082f290> (a java.net.PlainSocketImpl)
        at java.net.ServerSocket.bind(ServerSocket.java:318)
        at java.net.ServerSocket.<init>(ServerSocket.java:185)
        at jvm003a.<init>(jvm003.java:190)
        at jvm003a.<init>(jvm003.java:151)
        at jvm003.run(jvm003.java:51)
        at jvm003.main(jvm003.java:30)

The following list presents examples of other problems that the -Xcheck:jni option can help diagnose:

  • Cases where the JNI environment for the wrong thread is used

  • Cases where an invalid JNI reference is used

  • Cases where a reference to a non-array type is provided to a function that requires an array type

  • Cases where a non-static field ID is provided to a function that expects a static field ID

  • Cases where a JNI call is made with an exception pending

In general, all errors detected by the -Xcheck:jni option are fatal errors (that is, the error is printed and the VM is aborted). There is one exception to this behavior, when a JNI call is made within a JNI critical region. In this case, the following non-fatal warning message is printed, as shown in Example D-5.

Example D-5 Non-Fatal Warning Message

Warning: Calling other JNI functions in the scope of
Get/ReleasePrimitiveArrayCritical or Get/ReleaseStringCritical

A JNI critical region is created when native code uses the JNI functions GetPrimitiveArrayCritical or GetStringCritical to obtain a reference to an array or string in the Java heap. The reference is held until the native code calls the corresponding release function. The code between the get and release is called a JNI critical section and during that time the HotSpot VM cannot bring the VM to a state that allows garbage collection to occur. The general recommendation is not to use other JNI functions within a JNI critical section, and in particular any JNI function that could potentially cause a deadlock. The warning printed above by the -Xcheck:jni option is thus an indication of a potential issue; it does not always indicate an application bug.

For more information on JNI, see the Java Native Interface documentation.

The -verbose:class Option

This option enables logging of class loading and unloading.

The -verbose:gc Option

This option enables logging of garbage collection (GC) information. It can be combined with other HotSpot VM specific options such as -XX:+PrintGCDetails and -XX:+PrintGCTimeStamps to get further information about GC. The information output includes the size of the generations before and after each GC, total size of the heap, the size of objects promoted, and the time taken.

More information about these options, along with detailed information about GC analysis and tuning are described in the GC Portal article.

The -verbose:gc option can be dynamically enabled at runtime using the management API or JVM TI. For more information on these APIs, see Custom Diagnostic Tools.

The JConsole monitoring and management tool can also enable or disable the option when the tool is attached to a management VM. For more information see JConsole.

The -verbose:jni Option

This option enables logging of JNI. When a JNI or native method is resolved, the HotSpot VM prints a trace message to the application console (standard output). It also prints a trace message when a native method is registered using the JNI RegisterNative function. The -verbose:jni option can be useful in diagnosing issues with applications that use native libraries.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.jdi.connect.spi.ClosedConnectionException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.connect.spi.ClosedConnectionException

No usage of com.sun.jdi.connect.spi.ClosedConnectionException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Concurrent Mark Sweep (CMS) Collector

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

8 Concurrent Mark Sweep (CMS) Collector

The Concurrent Mark Sweep (CMS) collector is designed for applications that prefer shorter garbage collection pauses and that can afford to share processor resources with the garbage collector while the application is running. Typically applications that have a relatively large set of long-lived data (a large tenured generation) and run on machines with two or more processors tend to benefit from the use of this collector. However, this collector should be considered for any application with a low pause time requirement. The CMS collector is enabled with the command-line option -XX:+UseConcMarkSweepGC.

Similar to the other available collectors, the CMS collector is generational; thus both minor and major collections occur. The CMS collector attempts to reduce pause times due to major collections by using separate garbage collector threads to trace the reachable objects concurrently with the execution of the application threads. During each major collection cycle, the CMS collector pauses all the application threads for a brief period at the beginning of the collection and again toward the middle of the collection. The second pause tends to be the longer of the two pauses. Multiple threads are used to do the collection work during both pauses. The remainder of the collection (including most of the tracing of live objects and sweeping of unreachable objects is done with one or more garbage collector threads that run concurrently with the application. Minor collections can interleave with an ongoing major cycle, and are done in a manner similar to the parallel collector (in particular, the application threads are stopped during minor collections).

Concurrent Mode Failure

The CMS collector uses one or more garbage collector threads that run simultaneously with the application threads with the goal of completing the collection of the tenured generation before it becomes full. As described previously, in normal operation, the CMS collector does most of its tracing and sweeping work with the application threads still running, so only brief pauses are seen by the application threads. However, if the CMS collector is unable to finish reclaiming the unreachable objects before the tenured generation fills up, or if an allocation cannot be satisfied with the available free space blocks in the tenured generation, then the application is paused and the collection is completed with all the application threads stopped. The inability to complete a collection concurrently is referred to as concurrent mode failure and indicates the need to adjust the CMS collector parameters. If a concurrent collection is interrupted by an explicit garbage collection (System.gc()) or for a garbage collection needed to provide information for diagnostic tools, then a concurrent mode interruption is reported.

Excessive GC Time and OutOfMemoryError

The CMS collector throws an OutOfMemoryError if too much time is being spent in garbage collection: if more than 98% of the total time is spent in garbage collection and less than 2% of the heap is recovered, then an OutOfMemoryError is thrown. This feature is designed to prevent applications from running for an extended period of time while making little or no progress because the heap is too small. If necessary, this feature can be disabled by adding the option -XX:-UseGCOverheadLimit to the command line.

The policy is the same as that in the parallel collector, except that time spent performing concurrent collections is not counted toward the 98% time limit. In other words, only collections performed while the application is stopped count toward excessive GC time. Such collections are typically due to a concurrent mode failure or an explicit collection request (for example, a call to System.gc).

Floating Garbage

The CMS collector, like all the other collectors in Java HotSpot VM, is a tracing collector that identifies at least all the reachable objects in the heap. In the parlance of Richard Jones and Rafael D. Lins in their publication Garbage Collection: Algorithms for Automated Dynamic Memory, it is an incremental update collector. Because application threads and the garbage collector thread run concurrently during a major collection, objects that are traced by the garbage collector thread may subsequently become unreachable by the time collection process ends. Such unreachable objects that have not yet been reclaimed are referred to as floating garbage. The amount of floating garbage depends on the duration of the concurrent collection cycle and on the frequency of reference updates, also known as mutations, by the application. Furthermore, because the young generation and the tenured generation are collected independently, each acts a source of roots to the other. As a rough guideline, try increasing the size of the tenured generation by 20% to account for the floating garbage. Floating garbage in the heap at the end of one concurrent collection cycle is collected during the next collection cycle.

Pauses

The CMS collector pauses an application twice during a concurrent collection cycle. The first pause is to mark as live the objects directly reachable from the roots (for example, object references from application thread stacks and registers, static objects and so on) and from elsewhere in the heap (for example, the young generation). This first pause is referred to as the initial mark pause. The second pause comes at the end of the concurrent tracing phase and finds objects that were missed by the concurrent tracing due to updates by the application threads of references in an object after the CMS collector had finished tracing that object. This second pause is referred to as the remark pause.

Concurrent Phases

The concurrent tracing of the reachable object graph occurs between the initial mark pause and the remark pause. During this concurrent tracing phase one or more concurrent garbage collector threads may be using processor resources that would otherwise have been available to the application. As a result, compute-bound applications may see a commensurate fall in application throughput during this and other concurrent phases even though the application threads are not paused. After the remark pause, a concurrent sweeping phase collects the objects identified as unreachable. Once a collection cycle completes, the CMS collector waits, consuming almost no computational resources, until the start of the next major collection cycle.

Starting a Concurrent Collection Cycle

With the serial collector a major collection occurs whenever the tenured generation becomes full and all application threads are stopped while the collection is done. In contrast, the start of a concurrent collection must be timed such that the collection can finish before the tenured generation becomes full; otherwise, the application would observe longer pauses due to concurrent mode failure. There are several ways to start a concurrent collection.

Based on recent history, the CMS collector maintains estimates of the time remaining before the tenured generation will be exhausted and of the time needed for a concurrent collection cycle. Using these dynamic estimates, a concurrent collection cycle is started with the aim of completing the collection cycle before the tenured generation is exhausted. These estimates are padded for safety, because concurrent mode failure can be very costly.

A concurrent collection also starts if the occupancy of the tenured generation exceeds an initiating occupancy (a percentage of the tenured generation). The default value for this initiating occupancy threshold is approximately 92%, but the value is subject to change from release to release. This value can be manually adjusted using the command-line option -XX:CMSInitiatingOccupancyFraction=<N>, where <N> is an integral percentage (0 to 100) of the tenured generation size.

Scheduling Pauses

The pauses for the young generation collection and the tenured generation collection occur independently. They do not overlap, but may occur in quick succession such that the pause from one collection, immediately followed by one from the other collection, can appear to be a single, longer pause. To avoid this, the CMS collector attempts to schedule the remark pause roughly midway between the previous and next young generation pauses. This scheduling is currently not done for the initial mark pause, which is usually much shorter than the remark pause.

Incremental Mode

Note that the incremental mode is being deprecated in Java SE 8 and may be removed in a future major release.

The CMS collector can be used in a mode in which the concurrent phases are done incrementally. Recall that during a concurrent phase the garbage collector thread is using one or more processors. The incremental mode is meant to lessen the effect of long concurrent phases by periodically stopping the concurrent phase to yield back the processor to the application. This mode, referred to here as i-cms, divides the work done concurrently by the collector into small chunks of time that are scheduled between young generation collections. This feature is useful when applications that need the low pause times provided by the CMS collector are run on machines with small numbers of processors (for example, 1 or 2).

The concurrent collection cycle typically includes the following steps:

  • Stop all application threads, identify the set of objects reachable from roots, and then resume all application threads.

  • Concurrently trace the reachable object graph, using one or more processors, while the application threads are executing.

  • Concurrently retrace sections of the object graph that were modified since the tracing in the previous step, using one processor.

  • Stop all application threads and retrace sections of the roots and object graph that may have been modified since they were last examined, and then resume all application threads.

  • Concurrently sweep up the unreachable objects to the free lists used for allocation, using one processor.

  • Concurrently resize the heap and prepare the support data structures for the next collection cycle, using one processor.

Normally, the CMS collector uses one or more processors during the entire concurrent tracing phase, without voluntarily relinquishing them. Similarly, one processor is used for the entire concurrent sweep phase, again without relinquishing it. This overhead can be too much of a disruption for applications with response time constraints that might otherwise have used the processing cores, particularly when run on systems with just one or two processors. Incremental mode solves this problem by breaking up the concurrent phases into short bursts of activity, which are scheduled to occur midway between minor pauses.

The i-cms mode uses a duty cycle to control the amount of work the CMS collector is allowed to do before voluntarily giving up the processor. The duty cycle is the percentage of time between young generation collections that the CMS collector is allowed to run. The i-cms mode can automatically compute the duty cycle based on the behavior of the application (the recommended method, known as automatic pacing), or the duty cycle can be set to a fixed value on the command line.

Command-Line Options

Table 8-1, "Command-Line Options for i-cms" list command-line options that control the i-cms mode. The section Recommended Options suggests an initial set of options.

Table 8-1 Command-Line Options for i-cms

Option | Description | Default Value, Java SE 5 and Earlier | Default Value, Java SE 6 and Later
-XX:+CMSIncrementalMode | Enables incremental mode. Note that the CMS collector must also be enabled (with -XX:+UseConcMarkSweepGC) for this option to work. | disabled | disabled
-XX:+CMSIncrementalPacing | Enables automatic pacing. The incremental mode duty cycle is automatically adjusted based on statistics collected while the JVM is running. | disabled | disabled
-XX:CMSIncrementalDutyCycle=<N> | The percentage (0 to 100) of time between minor collections that the CMS collector is allowed to run. If CMSIncrementalPacing is enabled, then this is just the initial value. | 50 | 10
-XX:CMSIncrementalDutyCycleMin=<N> | The percentage (0 to 100) that is the lower bound on the duty cycle when CMSIncrementalPacing is enabled. | 10 | 0
-XX:CMSIncrementalSafetyFactor=<N> | The percentage (0 to 100) used to add conservatism when computing the duty cycle | 10 | 10
-XX:CMSIncrementalOffset=<N> | The percentage (0 to 100) by which the incremental mode duty cycle is shifted to the right within the period between minor collections. | 0 | 0
-XX:CMSExpAvgFactor=<N> | The percentage (0 to 100) used to weight the current sample when computing exponential averages for the CMS collection statistics. | 25 | 25

Recommended Options

To use i-cms in Java SE 8, use the following command-line options:

-XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode \
-XX:+PrintGCDetails -XX:+PrintGCTimeStamps

The first two options enable the CMS collector and i-cms, respectively. The last two options are not required; they simply cause diagnostic information about garbage collection to be written to standard output, so that garbage collection behavior can be seen and later analyzed.

For Java SE 5 and earlier releases, Oracle recommends using the following as an initial set of command-line options for i-cms:

-XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode \
-XX:+PrintGCDetails -XX:+PrintGCTimeStamps \
-XX:+CMSIncrementalPacing -XX:CMSIncrementalDutyCycleMin=0
-XX:CMSIncrementalDutyCycle=10

The same values are recommended for JavaSE8 although the values for the three options that control i-cms automatic pacing became the default in JavaSE6.

Basic Troubleshooting

The i-cms automatic pacing feature uses statistics gathered while the program is running to compute a duty cycle so that concurrent collections complete before the heap becomes full. However, past behavior is not a perfect predictor of future behavior and the estimates may not always be accurate enough to prevent the heap from becoming full. If too many full collections occur, then try the steps in Table 8-2, "Troubleshooting the i-cms Automatic Pacing Feature", one at a time.

Table 8-2 Troubleshooting the i-cms Automatic Pacing Feature

Step | Options
1. Increase the safety factor. | -XX:CMSIncrementalSafetyFactor=<N>
2. Increase the minimum duty cycle. | -XX:CMSIncrementalDutyCycleMin=<N>
3. Disable automatic pacing and use a fixed duty cycle. | -XX:-CMSIncrementalPacing -XX:CMSIncrementalDutyCycle=<N>

Measurements

Example 8-1, "Output from the CMS Collector" is the output from the CMS collector with the options -verbose:gc and -XX:+PrintGCDetails, with a few minor details removed. Note that the output for the CMS collector is interspersed with the output from the minor collections; typically many minor collections occur during a concurrent collection cycle. CMS-initial-mark indicates the start of the concurrent collection cycle, CMS-concurrent-mark indicates the end of the concurrent marking phase, and CMS-concurrent-sweep marks the end of the concurrent sweeping phase. Not discussed previously is the precleaning phase indicated by CMS-concurrent-preclean. Precleaning represents work that can be done concurrently in preparation for the remark phase CMS-remark. The final phase is indicated by CMS-concurrent-reset and is in preparation for the next concurrent collection.

Example 8-1 Output from the CMS Collector

[GC [1 CMS-initial-mark: 13991K(20288K)] 14103K(22400K), 0.0023781 secs]
[GC [DefNew: 2112K->64K(2112K), 0.0837052 secs] 16103K->15476K(22400K), 0.0838519 secs]
...
[GC [DefNew: 2077K->63K(2112K), 0.0126205 secs] 17552K->15855K(22400K), 0.0127482 secs]
[CMS-concurrent-mark: 0.267/0.374 secs]
[GC [DefNew: 2111K->64K(2112K), 0.0190851 secs] 17903K->16154K(22400K), 0.0191903 secs]
[CMS-concurrent-preclean: 0.044/0.064 secs]
[GC [1 CMS-remark: 16090K(20288K)] 17242K(22400K), 0.0210460 secs]
[GC [DefNew: 2112K->63K(2112K), 0.0716116 secs] 18177K->17382K(22400K), 0.0718204 secs]
[GC [DefNew: 2111K->63K(2112K), 0.0830392 secs] 19363K->18757K(22400K), 0.0832943 secs]
...
[GC [DefNew: 2111K->0K(2112K), 0.0035190 secs] 17527K->15479K(22400K), 0.0036052 secs]
[CMS-concurrent-sweep: 0.291/0.662 secs]
[GC [DefNew: 2048K->0K(2112K), 0.0013347 secs] 17527K->15479K(27912K), 0.0014231 secs]
[CMS-concurrent-reset: 0.016/0.016 secs]
[GC [DefNew: 2048K->1K(2112K), 0.0013936 secs] 17527K->15479K(27912K), 0.0014814 secs
]

The initial mark pause is typically short relative to the minor collection pause time. The concurrent phases (concurrent mark, concurrent preclean and concurrent sweep) normally last significantly longer than a minor collection pause, as indicated by Example 8-1, "Output from the CMS Collector". Note, however, that the application is not paused during these concurrent phases. The remark pause is often comparable in length to a minor collection. The remark pause is affected by certain application characteristics (for example, a high rate of object modification can increase this pause) and the time since the last minor collection (for example, more objects in the young generation may increase this pause).

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Concurrent Mark Sweep Collector Enhancements

  • Description
  • System.gc() Performed Concurrently
  • Larger Default Young Generation Size
  • Parallel Marking
  • More Information

Description

The concurrent mark sweep collector, also known as the concurrent collector or CMS, is targeted at applications that are sensitive to garbage collection pauses. It performs most garbage collection activity concurrently, i.e., while the application threads are running, to keep garbage collection-induced pauses short. The key performance enhancements made to the CMS collector in JDK 6 are outlined below. See the documents referenced below for more detailed information on these changes, the CMS collector, and garbage collection in HotSpot.

Note that these features only apply when the CMS collector is in use; the option -XX:+UseConcMarkSweepGC selects the CMS collector.

System.gc() Performed Concurrently

The System.gc() and Runtime.getRuntime().gc() methods instruct the JVM to run the garbage collector to recycle unused objects. The HotSpot implementation of these methods currently stops all application threads to collect the entire heap, which can result in a lengthy pause particularly when the heap is large. This works against the goal of the CMS collector to keep pauses short.

In JDK 6, the CMS collector can optionally perform these collections concurrently, to avoid a lengthy pause in response to a System.gc() or Runtime.getRuntime().gc() call. To enable this feature, add the option

-XX:+ExplicitGCInvokesConcurrent

to the java command line.

Larger Default Young Generation Size

Several changes were made that increase the default size of the young generation when the CMS collector is used:

  • the minimum young generation size was increased from 4MB to 16MB.
  • the proportion of the overall heap used for the young generation was increased from 1/15 to 1/7.
  • the survivor spaces are now used by default, and their default size was increased. (In prior releases the survivor spaces were disabled by default with the CMS collector.)

The primary effect of these changes is to improve application performance by reducing garbage collection overhead. However, because the default young generation size is larger, applications may also see larger young generation pause times and a larger memory footprint. If necessary, please see the documents referenced below for more details on generations, survivor spaces and the options available for adjusting their sizes.

Parallel Marking

The CMS collector now uses multiple threads to perform the concurrent marking task in parallel on platforms with multiple processors. This reduces the duration of the concurrent marking cycle, allowing the collector to support applications with larger numbers of threads and higher object allocation rates, particularly on large multiprocessor machines. Prior releases used only a single thread for concurrent marking, limiting the collector's ability to keep up with applications with very high object allocation rates.

More Information

The HotSpot memory management whitepaper provides more detail about the CMS collector and the other collectors available in HotSpot, as well as descriptions of the generations, survivor spaces and other memory management concepts.

The HotSpot documentation page contains links to Garbage Collection Tuning Guides, specific to each release, which include guidelines for choosing the garbage collector that best suits your application and techniques that can help reduce garbage collection overhead.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Dynamic code downloading using Java RMI

Documentation Contents

Dynamic code downloading using Java RMI
(Using the java.rmi.server.codebase Property)

This tutorial is organized as follows:

  1. Starting out
  2. What is a codebase?
  3. How does it work?
  4. Using codebase in Java RMI for more than just stub downloading
  5. Command-line examples
  6. Troubleshooting tips

1.0 Starting out

One of the most significant capabilities of the Java platform is the ability to dynamically download Java software from any Uniform Resource Locator (URL) to a virtual machine (VM) running in a separate process, usually on a different physical system. The result is that a remote system can run a program, for example an applet, which has never been installed on its disk. For the first few sections of this document, codebase with regard to applets will be discussed in order to help describe codebase with regard to Java Remote Method Invocation (Java RMI).

For example, a VM running from within a web browser can download the bytecodes for subclasses of java.applet.Applet and any other classes needed by that applet. The system on which the browser is running has most likely never run this applet before, nor installed it on its disk. Once all the necessary classes have been downloaded from the server, the browser can start the execution of the applet program using the local resources of the system on which the client browser is running.

Java RMI takes advantage of this capability to download and execute classes and on systems where those classes have never been installed on disk. Using the Java RMI API any VM, not only those in browsers, can download any Java class file including specialized Java RMI stub classes, which enable the execution of method calls on a remote server using the server system's resources.

The notion of a codebase originates from the use of ClassLoaders in the Java programming language. When a Java program uses a ClassLoader, that class loader needs to know the location(s) from which it should be allowed to load classes. Usually, a class loader is used in conjunction with an HTTP server that is serving up compiled classes for the Java platform. Most likely, the first ClassLoader/codebase pairing that you came into contact with was the AppletClassLoader, and the "codebase" part of the <applet> HTML tag, so this tutorial will assume that you have some experience with Java RMI programming, as well as writing HTML files that contain applet tags. For example, the HTML source will contain something like:

<applet height=100 width=100 codebase="myclasses/" code="My.class">
        <param name="ticker">
</applet>

2.0 What is a codebase?

A codebase can be defined as a source, or a place, from which to load classes into a virtual machine. For example, if you invited a new friend over for dinner, you would need to give that friend directions to the place where you lived, so that he or she could locate your house. Similarly, you can think of a codebase as the directions that you give to a VM, so it can find your [potentially remote] classes.

You can think of your CLASSPATH as a "local codebase", because it is the list of places on disk from which you load local classes. When loading classes from a local disk-based source, your CLASSPATH variable is consulted. Your CLASSPATH can be set to take either relative or absolute path names to directories and/or archives of class files. So just as CLASSPATH is a kind of "local codebase", the codebase used by applets and remote objects can be thought of as a "remote codebase".

3.0 How does it work?

3.1 How codebase is used in applets

To interact with an applet, that applet and any classes that it needs to run must be accessible by remote clients. While applets can be accessed from "ftp://" or local "file:///" URLs, they are usually accessed from a remote HTTP server.

  1. The client browser requests an applet class that is not found in the client's CLASSPATH
  2. The class definition of the applet (and any other class(es) that it needs) is downloaded from the server to the client using HTTP
  3. The applet executes on the client
illustrates three steps above

Figure 1: Downloading applets

The applet's codebase is always relative to the URL of the HTML page in which the <applet> tag is contained.

3.2 How codebase is used in Java RMI

Using Java RMI, applications can create remote objects that accept method calls from clients in other VMs. In order for a client to call methods on a remote object, the client must have a way to communicate with the remote object. Rather than having to program the client to speak the remote object's protocol, Java RMI uses special classes called stubs that can be downloaded to the client that are used to communicate with (make method calls on) the remote object. The java.rmi.server.codebase property value represents one or more URL locations from which these stubs (and any classes needed by the stubs) can be downloaded.

Like applets, the classes needed to execute remote method calls can be downloaded from "file:///" URLs, but like applets, a "file:///" URL generally requires that the client and the server reside on the same physical host, unless the file system referred to by the URL is made available using some other protocol, such as NFS.

Generally, the classes needed to execute remote method calls should be made accessible from a network resource, such as an HTTP or FTP server.

illustrates the first 5 steps of the stub downloadling process, as listed below

Figure 2: Downloading Java RMI stubs

  1. The remote object's codebase is specified by the remote object's server by setting the java.rmi.server.codebase property. The Java RMI server registers a remote object, bound to a name, with the Java RMI registry. The codebase set on the server VM is annotated to the remote object reference in the Java RMI registry.
  2. The Java RMI client requests a reference to a named remote object. The reference (the remote object's stub instance) is what the client will use to make remote method calls to the remote object.
  3. The Java RMI registry returns a reference (the stub instance) to the requested class. If the class definition for the stub instance can be found locally in the client's CLASSPATH , which is always searched before the codebase, the client will load the class locally. However, if the definition for the stub is not found in the client's CLASSPATH, the client will attempt to retrieve the class definition from the remote object's codebase.
  4. The client requests the class definition from the codebase. The codebase the client uses is the URL that was annotated to the stub instance when the stub class was loaded by the registry. Back in step 1, the annotated stub for the exported object was then registered with the Java RMI registry bound to a name.
  5. The class definition for the stub (and any other class(es) that it needs) is downloaded to the client.
    Note: Steps 4 and 5 are the sames steps that the registry took to load the remote object class, when the remote object was bound to a name in (registered with) the Java RMI registry. When the registry attempted to load the remote object's stub class, it requested the class definition from the codebase associated with that remote object.
  6. Now the client has all the information that it needs to invoke remote methods on the remote object. The stub instance acts as a proxy to the remote object that exists on the server; so unlike the applet which uses a codebase to execute code in its local VM, the Java RMI client uses the remote object's codebase to execute code in another, potentially remote VM, as illustrated in Figure 3:
illustrates the final step of the above procedure

Figure 3: Java RMI client making a remote method call

4.0 Using codebase in Java RMI for more than just stub downloading

In addition to downloading stubs and their associated classes to clients, the java.rmi.server.codebase property can be used to specify a location from which any class, not only stubs, can be downloaded.

When a client makes a method call to a remote object, the method that it calls could be written to accept no arguments or a number of arguments. There are three distinct cases that may occur, based on the data type(s) of the method argument(s).

In the first case, all of the method parameters (and return value) are primitive data types, so the remote object knows how to interpret them as method parameters, and there is no need to check its CLASSPATH or any codebase.

In the second case, at least one remote method parameter or the return value is an object, for which the remote object can find the class definition locally in its CLASSPATH.

In the third case (shown as Step 6, in Figure 4), the remote method receives an object instance, for which the remote object cannot find the class definition locally in its CLASSPATH. This type of remote method call is illustrated in Figure 4. The class of the object sent by the client will be a subtype of the declared parameter type. A subtype is either:

  • An implementation of the interface that is declared as the method parameter (or return) type
  • A subclass of the class that is declared as the method parameter (or return) type
Illustrates passing an unknown subtype as a method parameter, as described above and below.

Figure 4: Java RMI client making a remote method call, passing an unknown subtype as a method parameter

7. Like the applet's codebase, the client-specified codebase is used to download Remote classes, non-remote classes, and interfaces to other VMs. If the codebase property is set on the client application, then that codebase is annotated to the subtype instance when the subtype class is loaded by the client. If the codebase is not set on the client, the remote object will mistakenly use its own codebase.

5.0 Command-line examples

In the case of an applet, the applet codebase value is embedded in an HTML page, as we saw in the HTML example in the first section of this tutorial.

In the case of Java RMI codebase, rather than having a reference to the class embedded in an HTML page, the client first contacts the Java RMI registry for a reference to the remote object. Because the remote object's codebase can refer to any URL, not just one that is relative to a known URL, the value of the Java RMI codebase must be an absolute URL to the location of the stub class and any other classes needed by the stub class. This value of the codebase property can refer to:

  • The URL of a directory in which the classes are organized in package-named sub-directories
  • The URL of a JAR file in which the classes are organized in package-named directories
  • A space-delimited string containing multiple instances of JAR files and/or directories that meet the criteria above

Note: When the codebase property value is set to the URL of a directory, the value must be terminated by a "/".

Examples

If the location of your downloadable classes is on an HTTP server named "webvector", in the directory "export" (under the web root), your codebase property setting might look like this:

        -Djava.rmi.server.codebase=http://webvector/export/

If the location of your downloadable classes is on an HTTP server named "webline", in a JAR file named "mystuff.jar", in the directory "public" (under the web root), your codebase property setting might look like this:

        -Djava.rmi.server.codebase=http://webline/public/mystuff.jar

Now let's suppose that the location of your downloadable classes has been split between two JAR files, "myStuff.jar" and "myOtherStuff.jar". If these JAR files are located on different servers (named "webfront" and "webwave"), your codebase property setting might look like this:

        -Djava.rmi.server.codebase="http://webfront/myStuff.jar http://webwave/myOtherStuff.jar"

6.0 Troubleshooting tips

Any serializable class, including Java RMI stubs, can be downloaded if your Java RMI programs are configured properly. Here are the conditions under which dynamic stub downloading will work:

  1. The stub class and any of the classes that the stub relies on are served up from a URL reachable from the client.
  2. The java.rmi.server.codebase property has been set on the server program (or in the case of activation, the "setup" program) that makes the call to bind or rebind, such that:
    • The value of the codebase property is the URL in step A

      and

    • If the URL specified as the value of the codebase property is a directory, it must end in a trailing "/"

  3. The rmiregistry cannot find the stub class or any of the classes that the stub relies on in its CLASSPATH. This is so the codebase gets annotated to the stub when the registry does its class load of the stub, as a result of calls to bind or rebind in the server or setup code.
  4. The client has installed a SecurityManager that allows the stub to be downloaded. This means that the client must also have a properly configured security policy file.

There are two common problems associated with the java.rmi.server.codebase property, which are discussed next.

6.1 If you encounter a problem running your Java RMI server

The first problem you might encounter is the receipt of a ClassNotFoundException when attempting to bind or rebind a remote object to a name in the registry. This exception is usually due to a malformed codebase property, resulting in the registry not being able to locate the remote object's stubs or other classes needed by the stub.

It is important to note that the remote object's stub implements all the same interfaces as the remote object itself, so those interfaces, as well as any other custom classes declared as method parameters or return values, must also be available for download from the specified codebase.

Most frequently, this exception is thrown as a result of omitting the trailing slash from the URL value of the property. Other reasons would include: the value of the property is not a URL; the path to the classes specified in the URL is incorrect or misspelled; the stub class or any other necessary classes are not all available from the specified URL.

The exception that you may encounter in such a case would look like this:

java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
        java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
        java.lang.ClassNotFoundException: examples.callback.MessageReceiverImpl_Stub
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
        java.lang.ClassNotFoundException: examples.callback.MessageReceiverImpl_Stub
java.lang.ClassNotFoundException: examples.callback.MessageReceiverImpl_Stub
        at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(Compiled Code)
        at sun.rmi.transport.StreamRemoteCall.executeCall(Compiled Code)
        at sun.rmi.server.UnicastRef.invoke(Compiled Code)
        at sun.rmi.registry.RegistryImpl_Stub.rebind(Compiled Code)
        at java.rmi.Naming.rebind(Compiled Code)
        at examples.callback.MessageReceiverImpl.main(Compiled Code)
RemoteException occurred in server thread; nested exception is:
        java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
        java.lang.ClassNotFoundException: examples.callback.MessageReceiverImpl_Stub

6.2 If you encounter a problem running your Java RMI client

The second problem you could encounter is the receipt of a ClassNotFoundException when attempting to lookup a remote object in the registry. If you receive this exception in a stacktrace resulting from an attempt to run your Java RMI client code, then your problem is the CLASSPATH with which your Java RMI registry was started. See requirement C in section 6.0. Here is what the exception will look like:

java.rmi.UnmarshalException: Return value class not found; nested exception is:
        java.lang.ClassNotFoundException: MyImpl_Stub
        at sun.rmi.registry.RegistryImpl_Stub.lookup(RegistryImpl_Stub.java:109
        at java.rmi.Naming.lookup(Naming.java:60)
        at RmiClient.main(MyClient.java:28)

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Codebase Determination

See Codebase Determination in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Coding Tips

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

18 Coding Tips

This topic provides programming tips for development and deployment of Java and JavaFX applications that work in all execution environments.

This topic includes the following sections:

  • Detecting Embedded Applications

  • Accessing Application Parameters

  • Using JavaFX Host Services

  • Loading Resources

  • Managing the Stage Size of JavaFX Applications

18.1 Detecting Embedded Applications

When an application is run in a browser, the application gets staged with predefined dimensions, which cannot be updated directly. Example 18-1 shows simple code to detect if a JavaFX application is embedded in a web page. The code can be used in either the main application or the JavaFX preloader start method.

Example 18-1 Detect if the JavaFX Application is Embedded in a Web Page

public void start(Stage stage) {
    boolean isEmbedded = (stage.getWidth() > 0);
    ...
}

As an alternative, you can try to get a reference to the web context from the Application.getHostServices() method. Null is returned if the application is not embedded.

18.2 Accessing Application Parameters

JavaFX applications support both named and unnamed parameters that can be passed in a variety of ways:

  • Specified on the command line for a standalone launch.

  • Hardcoded in the application package (JAR and deployment descriptor).

  • Passed from the HTML page in which the application is embedded.

In a JavaFX application, access parameters from a preloader or main application using the getParameters() method. For example, the code in Example 18-2 gets a list of all named parameters and their values:

Example 18-2 Get a List of Named Deployment Parameters and Values

Map m = getParameters().getNamed();
String labelText = "List of application parameters: \n";
for(String st: (Set<String>) m.keySet()) {
    labelText += "  ["+st+"] : ["+m.get(st)+"]\n";
}

For Java applets, see Defining and Using Applet Parameters in the Java Tutorials for information on accessing application parameters.

18.3 Using JavaFX Host Services

For JavaFX applications, the Application.getHostServices() method provides access to execution-mode-specific services, including:

  • Access to information about the code base and the document base.

    For example, for embedded applications this is the URL of the application and URL of the host web page, respectively.

  • Access to the host web page using the JavaScript engine, only available to embedded applications.

  • Ability to open a web page in the browser.

Example 18-3 shows a few things you can do with getHostServices().

Example 18-3 Using getHostServices()

final HostServices services = getHostServices();

Button jsButton = new Button("Test Javascript");
jsButton.setOnAction(new EventHandler<ActionEvent>()  {
    public void handle(ActionEvent t) {
        JSObject js = services.getWebContext();
        js.eval("window.alert('Hello from JavaFX')");
    }
});

Button openButton = new Button("Test openDocument()");
    openButton.setOnAction(new EventHandler<ActionEvent>() {
        public void handle(ActionEvent t) {
        services.showDocument("http://javafx.com/");
    }
});

18.4 Loading Resources

Using the File API and explicit relative references to external data files or resources might not work when the application is loaded from the web.

To refer to resources relative to your application, use the getResource() method on one of the application classes, as shown in Example 18-4.

Example 18-4 Use the getResource() Method to Load Resources

scene.getStylesheets().
    add(this.getClass().getResource("my.css").toExternalForm());

As an alternative, consider using getCodeBase() or getDocumentBase() from the HostServices class to refer to resources relative to the application or the location where the application is used.

18.5 Managing the Stage Size of JavaFX Applications

When a JavaFX application is embedded in a web page, the application cannot control stage dimensions. Dimensions specified at packaging time are preferences only and can be overridden by the user, for example if the user has custom browser zoom settings. Also, the stage can be resized at any time by the user.

To provide a good user experience, be prepared for arbitrary stage sizes. Otherwise, the application might be cropped, or garbage could be painted in the unused area of the stage.

If your application uses layouts, then you do not need to do anything. Layouts take care of resizing for you. Otherwise, implement resizing logic and listen to stage dimension changes to update the application, as shown in the simplified code in Example 18-5.

Example 18-5 Using Listeners to Resize an Embedded Application

public class ResizeFriendlyApp extends Application implements
        ChangeListener<Number> {
    private Stage stage;
    public void start(Stage stage) {
        //be resize friendly
        this.stage = stage;
        stage.widthProperty().addListener(this);
        stage.heightProperty().addListener(this);

        ...

        //resize content
        resize(stage.getWidth(), stage.getHeight());

        stage.show();
    }

    private void resize(double width, double height) {
        //relayout the application to match given size
    }

    public void changed(ObservableValue<? extends Number> ov,
            Number t, Number t1) {
        resize(stage.getWidth(), stage.getHeight());
    }
}
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Available Collectors

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

5 Available Collectors

The discussion to this point has been about the serial collector. The Java HotSpot VM includes three different types of collectors, each with different performance characteristics.

  • The serial collector uses a single thread to perform all garbage collection work, which makes it relatively efficient because there is no communication overhead between threads. It is best-suited to single processor machines, because it cannot take advantage of multiprocessor hardware, although it can be useful on multiprocessors for applications with small data sets (up to approximately 100 MB). The serial collector is selected by default on certain hardware and operating system configurations, or can be explicitly enabled with the option -XX:+UseSerialGC.

  • The parallel collector (also known as the throughput collector) performs minor collections in parallel, which can significantly reduce garbage collection overhead. It is intended for applications with medium-sized to large-sized data sets that are run on multiprocessor or multithreaded hardware. The parallel collector is selected by default on certain hardware and operating system configurations, or can be explicitly enabled with the option -XX:+UseParallelGC.

    • Parallel compaction is a feature that enables the parallel collector to perform major collections in parallel. Without parallel compaction, major collections are performed using a single thread, which can significantly limit scalability. Parallel compaction is enabled by default if the option -XX:+UseParallelGC has been specified. The option to turn it off is -XX:-UseParallelOldGC.

  • The mostly concurrent collector performs most of its work concurrently (for example, while the application is still running) to keep garbage collection pauses short. It is designed for applications with medium-sized to large-sized data sets in which response time is more important than overall throughput because the techniques used to minimize pauses can reduce application performance. The Java HotSpot VM offers a choice between two mostly concurrent collectors; see The Mostly Concurrent Collectors. Use the option -XX:+UseConcMarkSweepGC to enable the CMS collector or -XX:+UseG1GC to enable the G1 collector.

Selecting a Collector

Unless your application has rather strict pause time requirements, first run your application and allow the VM to select a collector. If necessary, adjust the heap size to improve performance. If the performance still does not meet your goals, then use the following guidelines as a starting point for selecting a collector.

  • If the application has a small data set (up to approximately 100 MB), then

    select the serial collector with the option -XX:+UseSerialGC.

  • If the application will be run on a single processor and there are no pause time requirements, then let the VM select the collector, or select the serial collector with the option -XX:+UseSerialGC.

  • If (a) peak application performance is the first priority and (b) there are no pause time requirements or pauses of 1 second or longer are acceptable, then let the VM select the collector, or select the parallel collector with -XX:+UseParallelGC.

  • If response time is more important than overall throughput and garbage collection pauses must be kept shorter than approximately 1 second, then select the concurrent collector with -XX:+UseConcMarkSweepGC or -XX:+UseG1GC.

These guidelines provide only a starting point for selecting a collector because performance is dependent on the size of the heap, the amount of live data maintained by the application, and the number and speed of available processors. Pause times are particularly sensitive to these factors, so the threshold of 1 second mentioned previously is only approximate: the parallel collector will experience pause times longer than 1 second on many data size and hardware combinations; conversely, the concurrent collector may not be able to keep pauses shorter than 1 second on some combinations.

If the recommended collector does not achieve the desired performance, first attempt to adjust the heap and generation sizes to meet the desired goals. If performance is still inadequate, then try a different collector: use the concurrent collector to reduce pause times and use the parallel collector to increase overall throughput on multiprocessor hardware.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class javax.smartcardio.CommandAPDU (Java Smart Card I/O )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
javax.smartcardio.CommandAPDU

    • Uses of CommandAPDU in javax.smartcardio

      Methods in javax.smartcardio with parameters of type CommandAPDU
      Modifier and Type Method and Description
      abstract ResponseAPDU CardChannel.transmit(CommandAPDU command)
      Transmits the specified command APDU to the Smart Card and returns the response APDU.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java Smart Card I/O
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Comment (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Comment

  • Packages that use Comment
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of Comment in org.w3c.dom

      Methods in org.w3c.dom that return Comment
      Modifier and Type Method and Description
      Comment Document.createComment(String data)
      Creates a Comment node given the specified string.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.source.doctree.CommentTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.CommentTree

  • Packages that use CommentTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of CommentTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type CommentTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitComment(CommentTree node, P p)

    • Uses of CommentTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CommentTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitComment(CommentTree node, P p)
      R | DocTreeScanner.visitComment(CommentTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


compact1 - jdk (Compiler Tree API )

compact1 - jdk

Annotation Types

  • Exported


jdk (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact1

Package jdk

  • Annotation Types Summary
    Annotation Type Description
    Exported
    Indicates whether or not a JDK specific type or package is an exported part of the JDK suitable for use outside of the JDK implementation itself.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


compact2 - com.sun.net.httpserver.spi (Java HTTP Server )

compact2 - com.sun.net.httpserver.spi

Classes

  • HttpServerProvider


org.w3c.dom.views (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


compact3 - com.sun.net.httpserver.spi (Java HTTP Server )

compact3 - com.sun.net.httpserver.spi

Classes

  • HttpServerProvider


org.w3c.dom.views (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Compact Profiles

Compact profiles, introduced in Java SE 8, define subsets of the Java SE Platform API that can reduce the static size of the Java runtime on devices that have limited storage capacity.

Overview

A compact profile (or simply profile) is a subset of the full Java SE Platform API. Because they have smaller storage footprints, profiles can enable many Java applications to run on resource-constrained devices. Choosing a profile that closely matches an application's functional needs minimizes the storage devoted to unused functions.

Compact profiles address API choices only; they are unrelated to the Java virtual machine, the language proper, or tools.

There are three profiles, compact1, compact2, and compact3. Each profile includes the APIs of the lower-numbered profiles (compact2 is a superset of compact1). The full SE API is a superset of the compact3 profile. The following table shows the high-level composition of each:

Full SE API | Beans | JNI | JAX-WS
 | Preferences | Accessibility | IDL
 | RMI-IIOP | CORBA | Print Service
 | Sound | Swing | Java 2D
 | AWT | Drag and Drop | Input Methods
 | Image I/O |  |
compact3 | Security1 | JMX |
 | XML JAXP2 | Management | Instrumentation
compact2 | JDBC | RMI | XML JAXP
compact1 | Core (java.lang.*) | Security | Serialization
 | Networking | Ref Objects | Regular Expressions
 | Date and Time | Input/Output | Collections
 | Logging | Concurrency | Reflection
 | JAR | ZIP | Versioning
 | Internationalization | JNDI | Override Mechanism
 | Extension Mechanism | Scripting |

1. Adds kerberos, acl, and sasl to compact1 Security.
2. Adds crypto to compact2 XML JAXP.

These JDK 8 tools have explicit support for profiles:

  • javac compiler [Solaris, Linux, or Mac OS X or Windows]: The -profile profile option directs the compiler to flag usage of an API not present in profile.
  • jdeps static dependency analyzer [Solaris, Linux, or Mac OS X or Windows]: The -profile option shows the profile or file containing a package.

Detailed Profile Composition

The following table lists the API packages in each of the compact profiles. The API Reference also defines profile composition.

compact1 | compact2 Additions | compact3 Additions
java.io | java.rmi | java.lang.instrument
java.lang | java.rmi.activation | java.lang.management
java.lang.annotation | java.rmi.dgc | java.security.acl
java.lang.invoke | java.rmi.registry | java.util.prefs
java.lang.ref | java.rmi.server | javax.annotation.processing
java.lang.reflect | java.sql | javax.lang.model
java.math | javax.rmi.ssl | javax.lang.model.element
java.net | javax.sql | javax.lang.model.type
java.nio | javax.transaction | javax.lang.model.util
java.nio.channels | javax.transaction.xa | javax.management
java.nio.channels.spi | javax.xml | javax.management.loading
java.nio.charset | javax.xml.datatype | javax.management.modelmbean
java.nio.charset.spi | javax.xml.namespace | javax.management.monitor
java.nio.file | javax.xml.parsers | javax.management.openmbean
java.nio.file.attribute | javax.xml.stream | javax.management.relation
java.nio.file.spi | javax.xml.stream.events | javax.management.remote
java.security | javax.xml.stream.util | javax.management.remote.rmi
java.security.cert | javax.xml.transform | javax.management.timer
java.security.interfaces | javax.xml.transform.dom | javax.naming
java.security.spec | javax.xml.transform.sax | javax.naming.directory
java.text | javax.xml.transform.stax | javax.naming.event
java.text.spi | javax.xml.transform.stream | javax.naming.ldap
java.time | javax.xml.validation | javax.naming.spi
java.time.chrono | javax.xml.xpath | javax.security.auth.kerberos
java.time.format | org.w3c.dom | javax.security.sasl
java.time.temporal | org.w3c.dom.bootstrap | javax.sql.rowset
java.time.zone | org.w3c.dom.events | javax.sql.rowset.serial
java.util | org.w3c.dom.ls | javax.sql.rowset.spi
java.util.concurrent | org.xml.sax | javax.tools
java.util.concurrent.atomic | org.xml.sax.ext | javax.xml.crypto
java.util.concurrent.locks | org.xml.sax.helpers | javax.xml.crypto.dom
java.util.function |  | javax.xml.crypto.dsig
java.util.jar |  | javax.xml.crypto.dsig.dom
java.util.logging |  | javax.xml.crypto.dsig.keyinfo
java.util.regex |  | javax.xml.crypto.dsig.spec
java.util.spi |  | org.ietf.jgss
java.util.stream |  |
java.util.zip |  |
javax.crypto |  |
javax.crypto.interfaces |  |
javax.crypto.spec |  |
javax.net |  |
javax.net.ssl |  |
javax.script |  |
javax.security.auth |  |
javax.security.auth.callback |  |
javax.security.auth.login |  |
javax.security.auth.spi |  |
javax.security.auth.x500 |  |
javax.security.cert |  |

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


CORBA Compatibility Information

Documentation Contents

CORBA Compatibility Information - J2SE 5.0

  • CORBA API Changes Between J2SE 1.4.x and J2SE 5.0.x
  • Official Specifications for CORBA support in J2SE 5.0.x
  • Other Compatibility Information

CORBA API Changes Between J2SE 1.3 and J2SE 5.0

This document contains information regarding all of the API changes related to CORBA functionality between JDK 1.3 and 5.0. The changes have been made to make the APIs for the CORBA technology shipped in the JDK 5.0 compliant to the CORBA 2.3 mapping as specified by the following OMG documents:

  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (/ptc/00-08-07)
  • Portable Interceptors (ptc/2001-03-04)

API changes to org.omg.COSNaming classes

To comply with the IDL to Java mapping specified by the CORBA Version 2.3 specification, the following org.omg.COSNaming classes have been regenerated from the idlj compiler shipped with the JDK. This change (CCC 4284015) consists of the following API changes. Compatibility impact: None.

  1. To conform with CORBA V (2.3) All Helpers Section 1.5.2 Spec ptc/00-01-08.pdf, all Helpers are now abstract public classes. Below is the list of all Helper classes under org.omg.CosNaming that have been changed to abstract public classes.

    • BindingHelper.java
    • BindingIteratorHelper.java
    • BindingListHelper.java
    • BindingTypeHelper.java
    • IStringHelper.java
    • NameComponentHelper.java
    • NameHelper.java
    • NamingContextHelper.java
    • AlreadyBoundHelper.java
    • CannotProceedHelper.java
    • InvalidNameHelper.java
    • NotEmptyHelper.java
    • NotFoundHelper.java
    • NotFoundReasonHelper.java

    To conform with Section 1.7 OMG Spec ptc/00-01-08.pdf, Mapping for Enum, the mapping for the following Enum constructors is changed to protected.

    CLASS | BEFORE | NOW
    BindingType.java | private BindingType( int ) | protected BindingType( int )
    NotFoundReason.java | private NotFoundReason( int ) | protected NotFoundReason( int )

  2. To conform with CORBA 2.3 spec (ptc/00-01-08.pdf), Deletion of constructors in Stub classes, the following constructors have been deleted.

    CLASS | BEFORE | NOW
    _BindingIteratorStub.java | public _BindingIteratorStub(org.omg.CORBA.portable.Delegate d) | The constructor is deleted.
    _NamingContextStub.java | public _NamingContextStub(org.omg.CORBA.portable.Delegate d) | The constructor is deleted.

  3. To conform with CORBA 2.3 spec (ptc/00-01-08.pdf), the following exceptions have been changed.

    CLASS | BEFORE | NOW
    AlreadyBound.java | public final class AlreadyBound extends org.omg.CORBA.UserException implements org.omg.CORBA.portable.IDLEntity | public final class AlreadyBound extends org.omg.CORBA.UserException
    AlreadyBound.java | Only default constructor | Add new constructor public AlreadyBound (String reason)
    CannotProceed.java | public final class CannotProceed extends org.omg.CORBA.UserException implements org.omg.CORBA.portable.IDLEntity | public final class CannotProceed extends org.omg.CORBA.UserException
    CannotProceed.java | Only default constructor | Add new constructor public CannotProceed (String reason)
    InvalidName.java | public final class InvalidName extends org.omg.CORBA.UserException implements org.omg.CORBA.portable.IDLEntity | public final class InvalidName extends org.omg.CORBA.UserException
    InvalidName.java | Only default constructor | Add new constructor public InvalidName (String reason)
    NotEmpty.java | public final class NotEmpty extends org.omg.CORBA.UserException implements org.omg.CORBA.portable.IDLEntity | public final class NotEmpty extends org.omg.CORBA.UserException
    NotEmpty.java | Only default constructor | Add new constructor public NotEmpty (String reason)
    NotFound.java | public final class NotFound extends org.omg.CORBA.UserException implements org.omg.CORBA.portable.IDLEntity | public final class NotFound extends org.omg.CORBA.UserException
    NotFound.java | Only default constructor | Add new constructor public NotFound (String, org.omg.CosNaming.NamingContextPackage.NotFoundReason, org.omg.CosNaming.NameComponent[])

  4. To conform with the CORBA 2.3 specification, the following classes have been added.

    • NamingContextPOA.java
    • BindingIteratorPOA.java

  5. To conform with the CORBA 2.3 specification, the following classes are deprecated.

    • _NamingContextImplBase.java
    • _BindingIteratorImplBase.java

API changes to org.omg.CORBA

  • To conform to OMG spec 99-07-57, IDL to Java mapping, the following methods have been changed.
    • The signature of method org.omg.CORBA.Any.insert_fixed(java.math.BigDecimal, org.omg.CORBA.TypeCode) is changed to throw an org.omg.CORBA.Bad_INV_ORDER exception. System exception does not need to be declared in user's code. (CCC 4340915)
    • The method TypeCode.equivalent is defined as abstract. BEFORE: threw a NO_IMPLEMENT exception. Compatibility impact: Minimal impact for licensees, not for end user. Licensees need to provide a dummy implementation of this method. (CCC 4340932)
    • The method TypeCode.get_compact_typecode is defined as abstract. BEFORE: threw a NO_IMPLEMENT exception. Compatibility impact: Minimal impact for licensees, not for end user. Licensees need to provide a dummy implementation of this method. (CCC 4340932)
    • The mapping for the get_interface_def(org.omg.CORBA.Object) method in org.omg.CORBA.portable.Delegate.java is defined as abstract. Compatibility impact: Yes, a non-abstract method is converted to abstract. (CCC 4366071)
    • The mapping for the write_Principal() method in org.omg.CORBA.portable.OutputStream.java is no longer abstract. Compatibility impact: No, an abstract method is converted to non-abstract. (CCC 4366072)
    • The mapping for the read_Principal() method in org.omg.CORBA.portable.InputStream.java is no longer abstract. Compatibility impact: None, changing a method that is declared abstract to no longer be abstract does not break compatibility with pre-existing binaries. (CCC 4366074)
  • To conform to the CORBA 2.3 specification, the org.omg.DomainManagerOperations interface no longer extends org.omg.CORBA.Object. Compatibility impact: None, no CORBA program will use the DomainManagerOperations interface directly. The DomainManagerOperations interface can only be used by the programs via the DomainManager interface, which already extends org.omg.CORBA.Object. (CCC 4340907)
  • The following classes are declared as abstract and no longer have a private constructor. (CCC 4372196)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.CORBA.ServiceInformationHelper
  • To conform with the IDL to Java spec in section 1.15.2, the default constructor javadoc comments in the following org.omg.CORBA files have been changed from COMPLETED_MAYBE to COMPLETED_NO. Compatibility impact: None. (CCC 4363355)
    • INTERNAL.java
    • INVALID_TRANSACTION.java
    • INV_OBJREF.java
  • The following Helper classes in org.omg.CORBA have been changed from public final to public abstract, and the default constructor for the Helper classes has been deleted. This change has been made to comply with the ORB core specification as defined by CORBA 2.3.1 and with the IDL/Java Language mapping as defined in ptc/00-01-08. Compatibility impact: Minimal since the Helper classes have been made 'abstract' as defined by the OMG IDL/Java Language mapping specification, applications which had previously instantiated a Helper class instance would fail. But the Helper class has only static methods in it, and there is no good reason for an application to create an instance of the Helper class. (CCC 4364208)
    • AnySeqHelper.java
    • BooleanSeqHelper.java
    • CharSeqHelper.java
    • DoubleSeqHelper.java
    • FloatSeqHelper.java
    • LongLongSeqHelper.java
    • LongSeqHelper.java
    • OctetSeqHelper.java
    • ShortSeqHelper.java
    • StringValueHelper.java
    • ULongLongSeqHelper.java
    • ULongSeqHelper.java
    • UShortSeqHelper.java
    • WCharSeqHelper.java
    • WStringValueHelper.java
  • To conform with the recently passed OMG issue 3015, which adds a new class, AbstractInterfaceDef to Interface Repository classes, we have added the following new constants to org.omg.CORBA.DefinitionKind. Compatibility impact: None. (CCC 4367601)
    • _dk_AbstractInterface=24. This is a constant that indicates that an Interface Repository object is representing an abstract object.
    • public static final DefinitionKind dk_AbstractInterface = new DefinitionKind(_dk_AbstractInterface). This is the static instance of DefinitionKind, indicating that an Interface Repository object represents an abstract interface.
  • The following org.omg.CORBA APIs for typecodes were changed to conform to the OMG specification. All of the classes in the following list are in the org.omg.CORBA package. Compatibility impact: Yes. See each change below for details. (CCC 4368800)
    • The Typecode methods fixed_digits, fixed_scale, member_visibility, type_modified, and concrete_base_type are changed from concrete to abstract. Typecode is always implemented by an ORB implementor and never subclassed by an ORB user, so this should not impact customers.
    • TCKind.from_int no longer throws the unchecked exception BAD_PARAM. Since BAD_PARAM is an unchecked exception, removing the exception should not affect customer code at compile time.
    • Principal is changed to a concrete class with methods that throw NO_IMPLEMENT from an abstract class with abstract methods. Principal is deprecated and rarely used. In any case, it would not generally be subclassed by a user and would always be fully implemented by an ORB implementor.
    • An extract_Streamable method is added to Any. Adding a method does not affect compatibility.
    • Any.insert_object( object, Typecode ) is changed to throw BAD_PARAM. Since BAD_PARAM is an unchecked exception, adding the exception should not affect customer code at compile time.
    • The Any methods insert_Streamable, extract_Principal, and insert_Principal are no longer abstract. Any is fully implemented by ORB implementors and never subclassed by ORB users, so this should not impact customers.
    • The Any methods extract_value and insert_value are changed to abstract. Any is fully implemented by ORB implementors and never subclassed by ORB users, so this should not impact customers.
  • The Identifier field is added to org.omg.CORBA.Initializer. Compatibility impact: None. (CCC 4372194)
  • To comply with ptc/00-01-08.pdf, the following classes are changed:
    • org.omg.CORBA.ORBPackage.InvalidName.java is declared as final. Compatibility impact: Yes. The InvalidName is being declared as final, which would impact source code that was subclassing this. Since it is an exception type, we do not anticipate this kind of behavior. (CCC 4366734)
    • org.omg.stub.java.rmi._Remote_Stub.java returns a clone of _type_ids. This will prevent mangling of the original type_ids_ array by external users. (CCC 4366734)
    • The from_int(Int i) method in org.omg.CORBA.SetOverrideType no longer throws a BAD_PARAM exception. Compatibility impact: No. Should not cause a compatibility problem since we are removing a throws declaration of an unchecked exception. (CCC 4369490)
    • The from_int(Int i) method in org.omg.CORBA.DefinitionKind no longer throws a BAD_PARAM exception. Compatibility impact: No. (CCC 4370659)
    • org.omg.CORBA.DynamicImplementation has been deprecated by the OMG in favor of the Portable Object Adapter (POA). A default invoke body is supplied. Compatibility impact: No. Should not impact anyone implementing this class. (CCC 4369490)
  • The following classes are changed to correct errors. Compatibility impact: No (CCC 4362556)
    • Helper and Holder classes are added to UnknownUserException.java. No compatibility impact.
    • Helper and Holder classes are added to WrongTransaction.java, and the class is declared final. No compatibility impact.
    • CompletionStatus.java is declared final, no longer implements IDLEntity, is changed to a private constructor. A BAD_PARAM RuntimeException will no longer explicitly be thrown by from_int. Compatibility impact: Yes. New code written using the new CompletionStatus.java class will not have to explicitly catch the BAD_PARAM runtime exception. If it's recompiled with an older JDK, it would get a compile-time error. -- These changes were undone due to JCK regression (4375061). An OMG issue has been filed instead (http://www.omg.org/issues/java-rtf.html#Issue3946).
    • INV_POLICY.java is declared as final. No compatibility impact.
  • The addition of portable interceptors requires a new method on existing CORBA APIs and four new classes generated from IDL typedefs. Compatibility impact: none, these changes are all additions. (CCC 4379826)
    • register_initial_reference is added in public class org.omg.CORBA.ORB.
    • New class org.omg.CORBA.StringSeqHelper is added for 2 IDL typedefs.
    • New class org.omg.CORBA.StringSeqHolder is added for 2 IDL typedefs.
    • New class org.omg.CORBA.WStringSeqHelper is added for 2 IDL typedefs.
    • New class org.omg.CORBA.WStringSeqHolder is added for 2 IDL typedefs.

API changes to javax.rmi.CORBA

To comply with OMG API specifications, the following changes have been made to javax.rmi.CORBA:
  • The protected constructor in javax.rmi.CORBA.Stub is removed. Compatibility impact: None. (CCC 4366722)
  • To comply with OMG specification 00-01-06.pdf, the jaxax.rmi.CORBA.ClassDesc constructor is removed. (CCC 4366734)

Non-API changes

The following non-API changes were also implemented in JDK 5.0.
  • Correct repository id computations. Compatibility impact: Yes. Added ORB versioning support to allow interoperability with the JDK 1.3 ORB, maintain backwards compatibility, and enable interoperability with other vendor ORBs. (CCC 4365188)
  • To conform with the recently passed OMG issue 3015, we have taken all Interface Repository-related version pragmas out of org.omg.CORBA.ir.idl. This also changes the Repository ID values of a few IR interfaces that we ship in org.omg.CORBA, for example, IDLTypeHelper, from

    private static String _id = "IDL:omg.org/CORBA/IDLType:2.3";
    to
    private static String _id = "IDL:omg.org/CORBA/IDLType:1.0";

    Compatibility impact: Yes. This change might affect interoperability with existing implementations. Restart the application and the IR if you get a COMM_FAILURE exception (or something similar). (CCC 4372718)

  • Added @serial exclude tags to all org.omg.* package files so that JAVADOC will ignore the whole package for the Serialization spec. There is no requirement from Object Management Group (OMG) to have Serialization compatibility between different versions. Practically speaking there are no use cases where the org.omg classes will be serialized in one version and de-serialized in the next version. Compatibility impact: None. (CCC 4394004)
  • Changed idlj compiler arguments in support of POA, which is a new CORBA feature in Merlin. Changes to the idlj tool arguments include:
    • removed undocumented -poa flag
    • enabled generation of standard POA-based skeletons by default
    • added a new flag, -oldImplBase, to allow generation of backward compatible skeletons (compatible with JDK 1.2 and 1.3)

    Compatibility impact: Yes, existing programs that use the compiler may need to add the -oldImplBase flag to their idlj invocation to maintain compatibility. (CCC 4407835)

New API

The following new API were added to JDK 5.0.
  • The PortableInterceptor API is added. An incorrect specification, ptc/2000-04-05, was being referenced in the test plan. Another incorrect specification, orbos/99-12-02 was being referenced in the feature list (ptc/2000-04-05 is the same as orbos/99-12-02 except the format has changed). The correct specification reference for this new API is http://www.omg.org/cgi-gin/doc?ptc/2001-03-04. CCC 4307834 includes the list of changes/additions from ptc/2000-04-05. Compatibility impact: none, this is a new feature so no existing code uses it.
  • The addition of portable interceptors requires a new method, id, in public interface org.omg.PortableServer.POA.

Official Specifications for CORBA support in J2SE 5.0

Specification References

The specifications with which the Java 2 Platform Standard Edition (J2SE) 5.0 ORB complies are as follows. If these links do not take you to the referenced specification, the OMG may have changed the URL, and you can link to www.omg.org to search for the correct specification.
  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Revised IDL to Java language mapping (ptc/00-11-03)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (ptc/00-08-07)
  • Portable Interceptors (ptc/2001-08-31)
These are the only specifications referenced by this document.

Supported Specification Details

Not all of the above specifications are currently implemented in the ORB in J2SE 5.0. The precise list of supported sections is as follows:
  • CORBA 2.3.1 chapters 1-3 and 6-9
  • Revised IDL to Java language mapping, section 1.21.8.2, the orb.properties file.
  • CORBA 2.3.1 chapter 4 with the following replacements from the Portable Interceptors specification:
    • section 4.2.3.5 destroy
    • section 4.5.2 CodeFactory and PICurrent are required
    • Section 4.5.3.4 as updated for register_initial_reference
  • CORBA 2.3.1 chapter 5 with the following update from the Portable Interceptors specification:
    • 5.5.2 StringSeq and WStringSeq are required. This adds the following classes to org.omg.CORBA:
      • StringSeqHolder
      • StringSeqHelper
      • WStringSeqHolder
      • WStringSeqHelper
  • CORBA 2.3.1 sections 10.6.1 and 10.6.2 are supported for repository IDs.
  • CORBA 2.3.1 section 10.7 for TypeCode APIs.
  • CORBA 2.3.1 chapter 11, Portable Object Adapter (POA), with the following updates from the Portable Interceptors specification:
    • Section 11.3.7 POAs must preserve all policies
    • Section 11.3.8.2 again states that POAs must preserve all policies
    • Section 11.3.8.26 POA::id is required.
  • CORBA 2.3.1 chapters 13 and 15 define GIOP 1.0, 1.1, and 1.2. The J2SE 5.0 ORB fully supports all versions of GIOP, with the exception that the bi-directional GIOP feature defined in sections 15.8 and 15.9 is not supported.
  • All of the Interoperable Naming Service is supported.
  • Portable Interceptors section 13.8 (the new Coder/Decoder interfaces) and all of chapter 21 (the interceptor specification).
  • Section 1.21.8 of the Revised IDL to Java Language Mapping Specification (ptc/00-11-03) has been changed from the version in the IDL to Java Language Mapping Specification (ptc/00-01-08).

Tools

  • The IDL to Java compiler (idlj) complies with:
    • CORBA 2.3.1 chapter 3 (IDL definition)
    • CORBA 2.3.1 chapters 5 and 6 (semantics of Value types)
    • CORBA 2.3.1 section 10.6.5 (pragmas)
    • The IDL to Java mapping specification
    • The Revised IDL to Java language mapping specification section 1.12.1 "local interfaces"
  • The Java to IDL compiler (the IIOP backend for rmic) complies with:
    • CORBA 2.3.1 chapters 5 and 6 (value types)
    • The Java to IDL language mapping. Note that this implicitly references section 1.21 of the IDL to Java language mapping
    • IDL generated by the -idl flag complies with CORBA 2.3.1 chapter 3.

Other Compatibility Information

  • The class java.util.Calendar is not interoperable between J2SE 1.3.x and J2SE 5.0 when using RMI-IIOP. OMG issue 3151 may resolve this, but it will probably have to be implemented in a later release of the Java platform.

    The J2SE 5.0 version of Calendar writes a ZoneInfo object in its writeObject method. Similarly, it calls readObject to read this. Based on Java Object Serialization, it expects that if it's talking to an older version, the object won't be there, so the stream will throw an EOFException and keep the stream position intact.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.CompilationUnitTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.CompilationUnitTree

  • Packages that use CompilationUnitTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of CompilationUnitTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type CompilationUnitTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitCompilationUnit(CompilationUnitTree node, P p)

    • Uses of CompilationUnitTree in com.sun.source.util

      Methods in com.sun.source.util that return CompilationUnitTree
      Modifier and Type | Method and Description
      CompilationUnitTree TreePath.getCompilationUnit()
      Get the compilation unit associated with this path.
      CompilationUnitTree | TaskEvent.getCompilationUnit()
      Methods in com.sun.source.util that return types with arguments of type CompilationUnitTree
      Modifier and Type Method and Description
      abstract Iterable<? extends CompilationUnitTree> JavacTask.parse()
      Parse the specified files returning a list of abstract syntax trees.
      Methods in com.sun.source.util with parameters of type CompilationUnitTree
      Modifier and Type | Method and Description
      long DocSourcePositions.getEndPosition(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      Gets the ending position of the tree within the comment within the file.
      long SourcePositions.getEndPosition(CompilationUnitTree file, Tree tree)
      Gets the ending position of tree within file.
      static TreePath TreePath.getPath(CompilationUnitTree unit, Tree target)
      Gets a tree path for a tree node within a compilation unit.
      abstract TreePath Trees.getPath(CompilationUnitTree unit, Tree node)
      Gets the path to tree node within the specified compilation unit.
      long DocSourcePositions.getStartPosition(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      Gets the starting position of the tree within the comment within the file.
      long SourcePositions.getStartPosition(CompilationUnitTree file, Tree tree)
      Gets the starting position of tree within file.
      abstract void DocTrees.printMessage(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      Prints a message of the specified kind at the location of the tree within the provided compilation unit
      abstract void Trees.printMessage(Diagnostic.Kind kind, CharSequence msg, Tree t, CompilationUnitTree root)
      Prints a message of the specified kind at the location of the tree within the provided compilation unit
      R | SimpleTreeVisitor.visitCompilationUnit(CompilationUnitTree node, P p)
      R | TreeScanner.visitCompilationUnit(CompilationUnitTree node, P p)
      Constructors in com.sun.source.util with parameters of type CompilationUnitTree
      Constructor and Description
      TaskEvent(TaskEvent.Kind kind, CompilationUnitTree unit)
      TaskEvent(TaskEvent.Kind kind, CompilationUnitTree unit, TypeElement clazz)
      TreePath(CompilationUnitTree t)
      Creates a TreePath for a root node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Official Specifications for CORBA support in J2SE 5.0

Specification References

The specifications with which the Java 2 Platform Standard Edition (J2SE) 5.0 ORB complies are as follows. If these links do not take you to the referenced specification, the OMG may have changed the URL, and you can link to www.omg.org to search for the correct specification.
  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Revised IDL to Java language mapping (ptc/00-11-03)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (ptc/00-08-07)
  • Portable Interceptors (ptc/2001-08-31)
These are the only specifications referenced by this document.

Supported Specification Details

Not all of the above specifications are currently implemented in the ORB in J2SE 5.0. The precise list of supported sections is as follows:
  • CORBA 2.3.1 chapters 1-3 and 6-9
  • Revised IDL to Java language mapping, section 1.21.8.2, the orb.properties file.
  • CORBA 2.3.1 chapter 4 with the following replacements from the Portable Interceptors specification:
    • section 4.2.3.5 destroy
    • section 4.5.2 CodeFactory and PICurrent are required
    • Section 4.5.3.4 as updated for register_initial_reference
  • CORBA 2.3.1 chapter 5 with the following update from the Portable Interceptors specification:
    • 5.5.2 StringSeq and WStringSeq are required. This adds the following classes to org.omg.CORBA:
      • StringSeqHolder
      • StringSeqHelper
      • WStringSeqHolder
      • WStringSeqHelper
  • CORBA 2.3.1 sections 10.6.1 and 10.6.2 are supported for repository IDs.
  • CORBA 2.3.1 section 10.7 for TypeCode APIs.
  • CORBA 2.3.1 chapter 11, Portable Object Adapter (POA), with the following updates from the Portable Interceptors specification:
    • Section 11.3.7 POAs must preserve all policies
    • Section 11.3.8.2 again states that POAs must preserve all policies
    • Section 11.3.8.26 POA::id is required.
  • CORBA 2.3.1 chapters 13 and 15 define GIOP 1.0, 1.1, and 1.2. The J2SE 5.0 ORB fully supports all versions of GIOP, with the exception that the bi-directional GIOP feature defined in sections 15.8 and 15.9 is not supported.
  • All of the Interoperable Naming Service is supported.
  • Portable Interceptors section 13.8 (the new Coder/Decoder interfaces) and all of chapter 21 (the interceptor specification).
  • Section 1.21.8 of the Revised IDL to Java Language Mapping Specification (ptc/00-11-03) has been changed from the version in the IDL to Java Language Mapping Specification (ptc/00-01-08).

Tools

  • The IDL to Java compiler (idlj) complies with:
    • CORBA 2.3.1 chapter 3 (IDL definition)
    • CORBA 2.3.1 chapters 5 and 6 (semantics of Value types)
    • CORBA 2.3.1 section 10.6.5 (pragmas)
    • The IDL to Java mapping specification
    • The Revised IDL to Java language mapping specification section 1.12.1 "local interfaces"
  • The Java to IDL compiler (the IIOP backend for rmic) complies with:
    • CORBA 2.3.1 chapters 5 and 6 (value types)
    • The Java to IDL language mapping. Note that this implicitly references section 1.21 of the IDL to Java language mapping
    • IDL generated by the -idl flag complies with CORBA 2.3.1 chapter 3.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.CompoundAssignmentTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.CompoundAssignmentTree

  • Packages that use CompoundAssignmentTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of CompoundAssignmentTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type CompoundAssignmentTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitCompoundAssignment(CompoundAssignmentTree node, P p)

    • Uses of CompoundAssignmentTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type CompoundAssignmentTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitCompoundAssignment(CompoundAssignmentTree node, P p)
      R | TreeScanner.visitCompoundAssignment(CompoundAssignmentTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Compression Formats for Network Deployment

See Compression Formats for Network Deployment in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


The Mostly Concurrent Collectors

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

7 The Mostly Concurrent Collectors

Java Hotspot VM has two mostly concurrent collectors in JDK 8:

  • Concurrent Mark Sweep (CMS) Collector: This collector is for applications that prefer shorter garbage collection pauses and can afford to share processor resources with the garbage collection.

  • Garbage-First Garbage Collector: This server-style collector is for multiprocessor machines with large memories. It meets garbage collection pause time goals with high probability while achieving high throughput.

Overhead of Concurrency

The mostly concurrent collector trades processor resources (which would otherwise be available to the application) for shorter major collection pause times. The most visible overhead is the use of one or more processors during the concurrent parts of the collection. On an N processor system, the concurrent part of the collection will use K/N of the available processors, where 1<=K<=ceiling{N/4}. (Note that the precise choice of and bounds on K are subject to change.) In addition to the use of processors during concurrent phases, additional overhead is incurred to enable concurrency. Thus while garbage collection pauses are typically much shorter with the concurrent collector, application throughput also tends to be slightly lower than with the other collectors.

On a machine with more than one processing core, processors are available for application threads during the concurrent part of the collection, so the concurrent garbage collector thread does not "pause" the application. This usually results in shorter pauses, but again fewer processor resources are available to the application and some slowdown should be expected, especially if the application uses all of the processing cores maximally. As N increases, the reduction in processor resources due to concurrent garbage collection becomes smaller, and the benefit from concurrent collection increases. The section Concurrent Mode Failure in Concurrent Mark Sweep (CMS) Collector discusses potential limits to such scaling.

Because at least one processor is used for garbage collection during the concurrent phases, the concurrent collectors do not normally provide any benefit on a uniprocessor (single-core) machine. However, there is a separate mode available for CMS (not G1) that can achieve low pauses on systems with only one or two processors; see Incremental Mode in Concurrent Mark Sweep (CMS) Collector for details. This feature is being deprecated in Java SE 8 and may be removed in a later major release.

Additional References

The Garbage-First Garbage Collector:

http://www.oracle.com/technetwork/java/javase/tech/g1-intro-jsp-135488.html

Garbage-First Garbage Collector Tuning:

http://www.oracle.com/technetwork/articles/java/g1gc-1984535.html

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.ConditionalExpressionTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ConditionalExpressionTree

  • Packages that use ConditionalExpressionTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ConditionalExpressionTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ConditionalExpressionTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitConditionalExpression(ConditionalExpressionTree node, P p)

    • Uses of ConditionalExpressionTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ConditionalExpressionTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitConditionalExpression(ConditionalExpressionTree node, P p)
      R | TreeScanner.visitConditionalExpression(ConditionalExpressionTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Installing With a Configuration File

Documentation Contents
Java Platform, Standard Edition Installation Guide
Contents Previous

20 Installing With a Configuration File

This page describes the configuration file that supplements JDK command line installation options.Windows, OS X, and Linux command-line installers support the configuration file, but not every operating system supports all configuration file options.

An installer configuration file is an alternative to, and extension of, options specified on the installer command line. You can use a configuration file to standardize installations, and you can use a configuration file to specify options that are not available on the command line.

This page has these sections:

  • Using a Configuration File

  • Configuration File Options

  • Sample Configuration File

  • System Runtime Configuration File

Using a Configuration File

If you are installing the JRE on Windows, use the INSTALLCFG command-line option to specify a configuration file:

jre INSTALLCFG=configuration_file_path

  • jre is the installer base file name, for example, jre-8u05-windows-i586.exe.

  • configuration_file_path is the path to the configuration file.

If you are installing JRE on Solaris, Linux, or OS X, create a configuration file name named /etc/java/config/jre-install.properties. When you launch the JRE installer, it looks for a a configuration file with this specific path and name.

Configuration File Options

The following table lists the installer configuration file options that apply for each operating system.

Note:

You may substitute the value Enable for 1 and the value Disable for 0.

You may use the same options at the command line when running the JRE Windows Offline Installer. See "Command-Line Installation".

Table 20-1 Configuration File Options

Option | Operating Systems | Values | Description | JRE Offline Installer | Saved in Runtime Config file
INSTALL_SILENT= | Windows | Enable, Disable | Silent (non-interactive) installation. Default: Disable | yes | yes
INSTALLDIR= | Windows | path | Folder/directory into which the files are installed. Default: Operating system default path For Windows, this will only work for first time install of a family. Linux and Solaris use operating system tools for this purpose and installation directory relocation will be handled by operating system tools (for example: rpm --prefix=path)] | yes | no
STATIC= | Windows | Enable, Disable | Perform a static installation (see "Static Installation"). Default: Disable | yes | no
AUTO_UPDATE= | Windows OS X | Enable, Disable | Enable the auto update feature. Default: Enable | yes | yes
WEB_JAVA= | Windows OS X Linux | Enable, Disable | Configure the installation so downloaded Java applications are, or are not, allowed to run in a web browser or by Java Web Start. Default: Enable | yes | no
WEB_JAVA_SECURITY_LEVEL= | Windows OS X Linux | H (high), VH (very high) | Configure the installation's security level for Java applications running in a browser or run with Java Web Start. Default: H | yes | no
WEB_ANALYTICS= | Windows | Enable, Disable | Allow or disallow the installer to send installation-related statistics to an Oracle server. Default: Enable | yes | yes
EULA= | Windows | Enable, Disable | If a Java applet or Java Web Start application is launched, then prompt the user to accept the end-user license agreement (EULA). Default: Disable | yes | yes
REBOOT= | Windows | Enable, Disable | If disabled, then the installer will never prompt you to restart your computer after installing the JRE. However, in most cases, the installer does not need to restart your computer after installing the JRE. Default: Enable | yes | no
NOSTARTMENU= | Windows | Enable, Disable | Specify that the installer installs the JRE without setting up Java start-up items. Default: Disable | yes | no
SPONSORS= | Windows(32 bit) | Enable, Disable | Install Java without being presented with any third party sponsor offers. Default: Enable | no | no

Sample Configuration File

The following is a sample configuration file for Windows. It specifies the following:

  • Perform a silent install.

  • Install the JRE in the directory C:\java\jre.

  • Set the security level for unsigned Java applications running in a browser to very high.

Example 20-1 Sample Configuration File for Windows

INSTALL_SILENT=Enable
INSTALLDIR=C:\java\jre
WEB_JAVA_SECURITY_LEVEL=VH

System Runtime Configuration File

After installing the JRE with a configuration file, the installer saves the file (with a subset of options used during install) in one of the following locations in your computer, depending on your operating system:

  • Windows: %ALLUSERSPROFILE%\Oracle\Java\java.settings.cfg

    The value of the environment variable %ALLUSERSPROFILE% is typically C:\ProgramData.

  • Solaris and Linux: /etc/Oracle/Java/java.settings.cfg

  • OS X: /Library/Application/Support/Oracle/Java/java.settings.cfg

Contents Previous
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.security.auth.login.ConfigFile (Java Authentication and Authorization Service )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Authentication and Authorization Service
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.security.auth.login.ConfigFile

No usage of com.sun.security.auth.login.ConfigFile
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Authentication and Authorization Service
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.connect.spi.Connection (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.connect.spi.Connection

  • Packages that use Connection
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.
    com.sun.jdi.connect.spi
    This package comprises the interfaces and classes used to develop new TransportService implementations.

    • Uses of Connection in com.sun.jdi

      Methods in com.sun.jdi with parameters of type Connection
      Modifier and Type Method and Description
      VirtualMachine VirtualMachineManager.createVirtualMachine(Connection connection)
      Creates a new virtual machine.
      VirtualMachine VirtualMachineManager.createVirtualMachine(Connection connection, Process process)
      Create a virtual machine mirror for a target VM.

    • Uses of Connection in com.sun.jdi.connect.spi

      Methods in com.sun.jdi.connect.spi that return Connection
      Modifier and Type Method and Description
      abstract Connection TransportService.accept(TransportService.ListenKey listenKey, long acceptTimeout, long handshakeTimeout)
      Accept a connection from a target VM.
      abstract Connection TransportService.attach(String address, long attachTimeout, long handshakeTimeout)
      Attaches to the specified address.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Orderly (and Abortive) Connection Release in Java

Documentation Contents

Orderly Versus Abortive Connection Release in Java

This article covers the following topics:

  • Overview
  • Description of the Problem
  • How to Avoid the Problem

Overview

To ensure orderly or graceful release of TCP connections is a challenge with TCP networking applications. Abortive or ungraceful release may result if special care is not taken. In Java, an unexpected abortive release can manifest itself by the application receiving a java.net.SocketException when reading or writing to the socket. read() and write() normally return a numeric value indicating, respectively, the number of bytes received or sent. If an exception is received instead, this indicates the connection has been aborted and also that data may have been lost or discarded. This article explains what causes socket connections to be aborted and provides tips for avoiding the situation, except for the case where an application intends to abort the connection.

Description of the Problem

First, we need to distinguish the differences between an abortive and an orderly connection release. To understand this distinction we need to look at what happens at the TCP protocol level. It is helpful to imagine an established TCP connection as actually two separate, semi-independent streams of data. If the two peers are A and B, then one stream delivers data from A to B, and the other stream from B to A. An orderly release occurs in two stages. First one side (say A) decides to stop sending data and sends a FIN message across to B. When the TCP stack at B's side receives the FIN it knows that no more data is coming from A, and whenever B reads all preceding data off the socket, further reads will return the value -1 to indicate end-of-file. This procedure is known as the TCP half-close, because only one half of the connection is closed. Not surprisingly, the procedure for the other half is exactly the same. B sends a FIN message to A, who eventually receives a -1 after reading all preceding data sent by A off the socket.

By contrast, an abortive close uses the RST (Reset) message. If either side issues an RST, this means the entire connection is aborted and the TCP stack can throw away any queued data which has not been sent or received by either application.

So, how do Java applications perform orderly and abortive releases? Let's consider abortive releases first. A convention that has existed since the days of the original BSD sockets is that the "linger" socket option can be used to force an abortive connection release. Either application can call Socket.setLinger (true, 0) to tell the TCP stack that when this socket is closed, the abortive (RST) procedure is to be used. Setting the linger option has no immediate effect, except that when Socket.close() is called subsequently, the connection is aborted with an RST message. As we will see shortly, there are other ways that may cause a connection to be aborted, but this is the simplest way to make it happen.

The close() method is also used to perform orderly release, as well as abortive. So, at its simplest, the difference between an orderly release and an abortive release could be as little as not setting the linger(0) option, described above, prior to calling Socket.close(). Take the example of two connected peers A and B: If A calls Socket.close(), a FIN message is sent from A to B; and when B calls Socket.close(), a FIN is sent from B to A. In fact, the default setting for the linger option is to not use abortive close; so if two applications terminate their connection just by using Socket.close(), then the outcome should be an orderly release. So what, then, is the problem?

The problem is a slight mismatch between the semantics of Socket.close() and the TCP FIN message. Sending a TCP FIN message means "I am finished sending", whereas Socket.close() means "I am finished sending and receiving." When you call Socket.close(), clearly it is no longer possible to send data; nor, however, is it possible to receive data. So what happens, for example, when A attempts an orderly release by closing the socket, but B continues to send data? This is perfectly allowable in the TCP specification, because as far as TCP is concerned only one half of the connection has been closed. But since A's socket is closed there is nobody to read data if B should continue sending. In this situation A's TCP stack must send an RST to forcibly terminate the connection.

Another common scenario, which may result in an unintended SocketException, is the following: Say A has sent data to B, but B closes the socket without reading all the data. In this situation, B's TCP stack knows that some data is effectively lost and it will forcibly terminate with RST rather than use the orderly FIN procedure. A will get a SocketException if it then tries to send or receive data from the socket.

How to avoid the problem

There are a number of simple ways to avoid being surprised by this problem.

  1. Structure data with a higher-level protocol. Protocols such as HTTP, which are built on top of TCP, deal with the issue by making it clear to both sides when it is safe to close the socket.
  2. Always consume data from a socket before closing it. This will help avoid the second scenario described above.
  3. Use shutdownOutput(). This method has the same effect as close() in that a FIN is sent to indicate that this peer has finished sending, but it is still possible to read from the socket until such time as the remote peer sends a FIN and end-of-file is read from the stream. Then the socket can be closed with Socket.close().
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.connect.Connector (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.Connector

  • Packages that use Connector
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.
    com.sun.jdi.connect
    This package defines connections between the virtual machine using the JDI and the target virtual machine.

    • Uses of Connector in com.sun.jdi

      Methods in com.sun.jdi that return types with arguments of type Connector
      Modifier and Type Method and Description
      List<Connector> VirtualMachineManager.allConnectors()
      Returns the list of all known Connector objects.

    • Uses of Connector in com.sun.jdi.connect

      Subinterfaces of Connector in com.sun.jdi.connect
      Modifier and Type Interface and Description
      interface  AttachingConnector
      A connector which attaches to a previously running target VM.
      interface  LaunchingConnector
      A connector which can launch a target VM before connecting to it.
      interface  ListeningConnector
      A connector which listens for a connection initiated by a target VM.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.connect.Connector.Argument (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.Connector.Argument

  • Packages that use Connector.Argument
    Package Description
    com.sun.jdi.connect
    This package defines connections between the virtual machine using the JDI and the target virtual machine.

    • Uses of Connector.Argument in com.sun.jdi.connect

      Subinterfaces of Connector.Argument in com.sun.jdi.connect
      Modifier and Type Interface and Description
      static interface  Connector.BooleanArgument
      Specification for and value of a Connector argument, whose value is Boolean.
      static interface  Connector.IntegerArgument
      Specification for and value of a Connector argument, whose value is an integer.
      static interface  Connector.SelectedArgument
      Specification for and value of a Connector argument, whose value is a String selected from a list of choices.
      static interface  Connector.StringArgument
      Specification for and value of a Connector argument, whose value is a String.
      Methods in com.sun.jdi.connect that return types with arguments of type Connector.Argument
      Modifier and Type Method and Description
      Map<String,Connector.Argument> Connector.defaultArguments()
      Returns the arguments accepted by this Connector and their default values.
      Method parameters in com.sun.jdi.connect with type arguments of type Connector.Argument
      Modifier and Type Method and Description
      VirtualMachine ListeningConnector.accept(Map<String,? extends Connector.Argument> arguments)
      Waits for a target VM to attach to this connector.
      VirtualMachine AttachingConnector.attach(Map<String,? extends Connector.Argument> arguments)
      Attaches to a running application and and returns a mirror of its VM.
      VirtualMachine LaunchingConnector.launch(Map<String,? extends Connector.Argument> arguments)
      Launches an application and connects to its VM.
      String ListeningConnector.startListening(Map<String,? extends Connector.Argument> arguments)
      Listens for one or more connections initiated by target VMs.
      void ListeningConnector.stopListening(Map<String,? extends Connector.Argument> arguments)
      Cancels listening for connections.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.connect.Connector.BooleanArgument (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.Connector.BooleanArgument

No usage of com.sun.jdi.connect.Connector.BooleanArgument
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.connect.Connector.IntegerArgument (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.Connector.IntegerArgument

No usage of com.sun.jdi.connect.Connector.IntegerArgument
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.connect.Connector.SelectedArgument (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.Connector.SelectedArgument

No usage of com.sun.jdi.connect.Connector.SelectedArgument
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.connect.Connector.StringArgument (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.connect.Connector.StringArgument

No usage of com.sun.jdi.connect.Connector.StringArgument
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Documentation Contents
Skip navigation bar
Contents | Previous | Next Java Management Extensions (JMX) Technology Tutorial

Chapter 3

JMX Connectors

This chapter introduces the concepts of standard and dynamic management beans (MBeans) and also shows how to use Java Management Extensions (JMX) technology to perform operations on MBeans, both locally and remotely.

Accessing Standard and Dynamic MBeans via the RMI Connector

This example demonstrates standard and dynamic MBeans only.

As seen in Chapter 2, "Essentials of the JMX API", a standard MBean is one that statically defines its management interface through the names of the methods it contains. A dynamic MBean implements a specific Java interface and reveals its attributes and operations at run time.

The JMX technology defines a connector based on RMI. The RMI connector supports the Java Remote Method Protocol (JRMP) transport, and optionally, the Internet Inter-Object Request Broker (ORB) Protocol (IIOP) transport. This connector allows you to connect to an MBean in an MBean server from a remote location, and perform operations on it, exactly as if the operations were being performed locally.

The purpose of this example is to demonstrate the implementation of a standard MBean and a dynamic MBean. It also shows how to perform operations on them, both locally, and remotely through an RMI connection between a server and a remote client.

When you run this example:

  • The server:
  • Creates an MBean server
  • Registers a SimpleStandard and a SimpleDynamic MBean in the local MBean server
  • Performs local operations on the MBeans
  • Creates an RMI connector server
  • The client:
  • Creates an RMI connector
  • Registers a SimpleStandard and a SimpleDynamic MBean on the remote MBean server
  • Performs remote operations on both MBeans

The RMI connector example is contained in the directory work_dir/jmx_examples/Basic.

  2. Open the work_dir/jmx_examples/Basic directory.

    Inside this directory, you will find the following files:

    • Server.java
    • SimpleStandardMBean.java
    • SimpleStandard.java
    • SimpleDynamic.java
    • ClientListener.java
    • Client.java
    • README
  3. Open each of the *.java files in a text editor.

Analyzing the Example Classes

The following sections analyze each of the classes used in the basic MBean example, and explain how they perform the operations described in the preceding section.

Server.java

Due to its size, the Server.java class is shown in several code excerpts.

CODE EXAMPLE 3-1 MBean Example Class Server.java (Excerpt 1)

public class Server {

 public static void main(String[] args) {
     try {

         MBeanServer mbs = MBeanServerFactory.createMBeanServer();
         waitForEnterPressed();

         String domain = mbs.getDefaultDomain();
         waitForEnterPressed();

         String mbeanClassName = "SimpleStandard";
         String mbeanObjectNameStr =
             domain + ":type=" + mbeanClassName + ",name=1";
         ObjectName mbeanObjectName =
             createSimpleMBean(mbs, mbeanClassName, mbeanObjectNameStr);
         waitForEnterPressed();

         printMBeanInfo(mbs, mbeanObjectName, mbeanClassName);
         waitForEnterPressed();

         manageSimpleMBean(mbs, mbeanObjectName, mbeanClassName);
         waitForEnterPressed();

         mbeanClassName = "SimpleDynamic";
         mbeanObjectNameStr =
             domain + ":type=" + mbeanClassName + ",name=1";
         mbeanObjectName =
             createSimpleMBean(mbs, mbeanClassName, mbeanObjectNameStr);
         waitForEnterPressed();

         printMBeanInfo(mbs, mbeanObjectName, mbeanClassName);
         waitForEnterPressed();

         manageSimpleMBean(mbs, mbeanObjectName, mbeanClassName);
         waitForEnterPressed();

         [...]

Examining this class, you can see that the following occurs:

Firstly, the Server.java class creates a new MBean server called mbs by calling the createMBeanServer() method of the MBeanServerFactory class.

Then, the default domain in which the MBean server is registered is obtained with a call to the getDefaultDomain() method of the MBeanServer interface. The domain is identified by the string domain.

The MBean class named SimpleStandard is also identified by a variable, in this case the string mbeanClassName. SimpleStandard is the name of the Java class for the Java object of which this MBean is an instance. The SimpleStandard.java object is examined in Section "SimpleStandard.java".

Another variable, the string mbeanObjectNameStr, is defined as the combination of the domain, plus the following key=value pairs:

  • The type, which in this case is the mbeanClassName.
  • A name, to differentiate this MBean from other MBeans of the same type that might be created subsequently. In this case the name number is 1.

The purpose of mbeanObjectNameStr is to give the MBean a human-readable identifier.

A call to createSimpleMBean() creates and registers the SimpleStandard MBean in the local MBean server, with the given object name.

The operations printMBeanInfo(), and manageSimpleMBean() are then performed on the SimpleStandard MBean. Like createSimpleMBean(), these methods are defined later in the Server.java code, and are shown in CODE EXAMPLE 3-4 and CODE EXAMPLE 3-5.

In code that is not shown here, a second MBean of the type SimpleDynamic is created and registered in the MBean server in exactly the same way as the SimpleStandard MBean. As the name suggests, this MBean is an instance of the SimpleDynamic Java object, which is examined in Section "SimpleDynamic.java".

CODE EXAMPLE 3-2 MBean Example Class Server.java (Excerpt 2)

[...]

JMXServiceURL url =
  new JMXServiceURL("service:jmx:rmi:///jndi/rmi://localhost:9999/server");
JMXConnectorServer cs =
  JMXConnectorServerFactory.newJMXConnectorServer(url, null, mbs);
cs.start();
waitForEnterPressed();
cs.stop();

[...]

In CODE EXAMPLE 3-2, an RMI connector server is created so that operations can be performed on the MBeans remotely. A call to the class JMXServiceURL creates a new service URL called url, which serves as an address for the connector server. In this example, the service URL is given in JNDI form, rather than in encoded form (see the API documentation for the javax.management.remote.rmi package for an explanation of JNDI form). This service URL defines the following:

  • The connector will use the default RMI transport, denoted by rmi.
  • The RMI registry in which the RMI connector stub will be stored will be running on port 9999 on the local host, and the server address will be registered under the name server. The port 9999 specified in the example is arbitrary; you can use any available port.

An RMI connector server named cs is created by calling the constructor JMXConnectorServerFactory, with the service URL url, a null environment map, and the MBean server mbs as parameters. The connector server cs is launched by calling the start() method of JMXConnectorServer, whereupon RMIConnectorServer exports the RMI object server to the RMI registry. The connection will remain open until the Enter key is pressed, as instructed by the simple method waitForEnterPressed, that is defined later in the Server code.

CODE EXAMPLE 3-3 MBean Example Class Server.java (Excerpt 3)

[...]

private static ObjectName createSimpleMBean(MBeanServer mbs,
                                              String mbeanClassName,
                                              String mbeanObjectNameStr) {
     echo("\n>>> Create the " + mbeanClassName +
          " MBean within the MBeanServer");
     echo("ObjectName = " + mbeanObjectNameStr);
     try {
          ObjectName mbeanObjectName =
             ObjectName.getInstance(mbeanObjectNameStr);
          mbs.createMBean(mbeanClassName, mbeanObjectName);
             return mbeanObjectName;
          } catch (Exception e) {
            echo(       "!!! Could not create the " +
                  mbeanClassName + " MBean !!!");
            e.printStackTrace();
            echo("\nEXITING...\n");
            System.exit(1);
        }
        return null;
     }

[...]

CODE EXAMPLE 3-3 shows the definition of the createSimpleMBean() method. In this method, the MBean instance with the object name mbeanObjectNameStr is passed to the getInstance() method of the ObjectName interface to create a new object name for registering the MBean inside the MBean server. The resulting object name instance is named mbeanObjectName. A call to the MBeanServer method createMBean() then instantiates an MBean defined by the combination of the Java object identified by mbeanClassName and the MBean instance mbeanObjectName and registers this MBean in the MBean server mbs.

CODE EXAMPLE 3-4 MBean Example Class Server.java (Excerpt 4)
[...]

private static void printMBeanInfo(MBeanServer mbs,
                                     ObjectName mbeanObjectName,
                                     String mbeanClassName) {
     MBeanInfo info = null;
     try {
         info = mbs.getMBeanInfo(mbeanObjectName);
     } catch (Exception e) {
         echo(  "!!! Could not get MBeanInfo object for " +
         mbeanClassName +" !!!");
         e.printStackTrace();
         return;
     }

     MBeanAttributeInfo[] attrInfo = info.getAttributes();
     if (attrInfo.length > 0) {
         for (int i = 0; i < attrInfo.length; i++) {
        echo(" ** NAME:    " + attrInfo[i].getName());
        echo("    DESCR:   " + attrInfo[i].getDescription());
        echo("    TYPE:    " + attrInfo[i].getType() +
                "READ: "+ attrInfo[i].isReadable() +
                "WRITE: "+ attrInfo[i].isWritable());
        }
     } else echo(" ** No attributes **");

[...]

In CODE EXAMPLE 3-4 we see the definition of the method printMBeanInfo(). The printMBeanInfo() method calls the MBeanServer method getMBeanInfo() to obtain details of the attributes and operations that are exposed by the MBean mbeanObjectName. MBeanAttributeInfo defines the following methods, each of which is called in turn to obtain information about the mbeanObjectName MBean’s attributes:

  • getName, to obtain the attribute’s name.
  • getDescription, to obtain the human readable description of the attribute.
  • getType, to obtain the class name of the attribute.
  • isReadable, to determine whether or not the attribute is readable.
  • isWritable, to determine whether or not the attribute is writable.

In code that is not shown here, calls are made to obtain information about the mbeanObjectName MBean’s constructors, operations and notifications:

  • MBeanConstructorInfo, to obtain information about the MBean’s Java class.
  • MBeanOperationInfo, to learn what operations the MBean performs, and what parameters it takes.
  • MBeanNotificationInfo, to find out what notifications the MBean sends when its operations are performed.
CODE EXAMPLE 3-5 MBean Example Class Server.java (Excerpt 5)
[...]

private static void manageSimpleMBean(MBeanServer mbs,
                                        ObjectName mbeanObjectName,
                                        String mbeanClassName) {
        try {
            printSimpleAttributes(mbs, mbeanObjectName);

            Attribute stateAttribute = new Attribute("State",
                                                     "new state");
            mbs.setAttribute(mbeanObjectName, stateAttribute);

            printSimpleAttributes(mbs, mbeanObjectName);

            echo("\n    Invoking reset operation...");
            mbs.invoke(mbeanObjectName, "reset", null, null);

            printSimpleAttributes(mbs, mbeanObjectName);
        } catch (Exception e) {
            e.printStackTrace();
        }
    }

    private static void printSimpleAttributes(
                                        MBeanServer mbs,
                                        ObjectName mbeanObjectName) {
        try {
            String State =
               (String) mbs.getAttribute(mbeanObjectName, "State");
            Integer NbChanges =
               (Integer) mbs.getAttribute(mbeanObjectName,
                                          "NbChanges");
        } catch (Exception e) {
            echo(       "!!! Could not read attributes !!!");
            e.printStackTrace();
        }
   }

[...]

CODE EXAMPLE 3-5 shows a method for managing a simple MBean.

The manageSimpleMBean() method first of all calls the printSimpleAttributes() method that is also defined by Server. The printSimpleAttributes() method obtains an MBean attribute called state from the MBean mbeanObjectName, as well as another MBean attribute called NbChanges. Both of these attributes are defined in the SimpleStandard class, shown in Section "SimpleStandard.java".

The manageSimpleMBean() method then defines an attribute called stateAttribute, which is an instance of the Attribute class. The stateAttribute attribute associates a value of new state with the existing attribute state, defined by SimpleStandard. A call to the MBeanServer method setAttribute() then sets the mbeanObjectName MBean’s state to the new state defined by stateAttribute.

Finally, a call to the MBeanServer method invoke() invokes the mbeanObjectName MBean’s reset operation. The reset operation is defined in the SimpleStandard class.

SimpleStandardMBean.java

The SimpleStandardMBean.java class is shown in CODE EXAMPLE 3-1.

CODE EXAMPLE 3-1 MBean Example Class SimpleStandardMBean.java

public interface SimpleStandardMBean {

       public String getState();
       public void setState(String s);
       public int getNbChanges();
       public void reset();

}

The SimpleStandardMBean.java class is a straightforward JMX specification management interface for the MBean SimpleStandard. This interface exposes the four operations defined by SimpleStandard for management through a JMX agent.

SimpleStandard.java

The SimpleStandard.java class is shown in CODE EXAMPLE 3-1.

CODE EXAMPLE 3-1 MBean Example Class SimpleStandard.java

public class SimpleStandard
    extends NotificationBroadcasterSupport
    implements SimpleStandardMBean {
    public String getState() {
       return state;
    }
    public void setState(String s) {
       state = s;
       nbChanges++;
    }

    public int getNbChanges() {
        return nbChanges;
    }

    public void reset() {
       AttributeChangeNotification acn =
           new AttributeChangeNotification(this,
                                          0,
                                          0,
                                          "NbChanges reset",
                                          "NbChanges",
                                          "Integer",
                                          new Integer(nbChanges),
                                          new Integer(0));
       state = "initial state";
       nbChanges = 0;
       nbResets++;
       sendNotification(acn);
    }

    public int getNbResets() {
       return nbResets;
    }

    public MBeanNotificationInfo[] getNotificationInfo() {
        return new MBeanNotificationInfo[] {
          new MBeanNotificationInfo(
          new String[] {
            AttributeChangeNotification.ATTRIBUTE_CHANGE },
            AttributeChangeNotification.class.getName(),
            "This notification is emitted when the reset()
             method is called.")
        };
    }

    private String state = "initial state";
    private int nbChanges = 0;
    private int nbResets = 0;

}

The SimpleStandard class defines a straightforward JMX specification standard MBean.

The SimpleStandard MBean exposes operations and attributes for management by implementing the corresponding SimpleStandardMBean interface, shown in Section "SimpleStandardMBean.java".

The simple operations exposed by this MBean are as follows:

  • To define a state.
  • To update this state.
  • To count the number of times the state is updated
  • To reset the values of the state and the number of changes to their original value of zero
  • To send a notification whenever the reset operation is invoked

The notification emitted by the reset operation is an instance of the class AttributeChangeNotification, which collects information about the number of changes carried out on the State attribute before calling reset. The content of the notification sent is defined by the MBeanNotificationInfo instance.

SimpleDynamic.java

The SimpleDynamic class is shown in CODE EXAMPLE 3-1.

CODE EXAMPLE 3-1 MBean Example Class SimpleDynamic.java

public class SimpleDynamic
    extends NotificationBroadcasterSupport
    implements DynamicMBean {

    public SimpleDynamic() {
        buildDynamicMBeanInfo();
    }

[...]

The SimpleDynamic dynamic MBean shows how to expose attributes and operations for management at runtime, by implementing the DynamicMBean interface. It starts by defining a method, buildDynamicMBeanInfo(), for obtaining information for the MBean dynamically. The buildDynamicMBeanInfo() method builds the MBeanInfo for the dynamic MBean.

The rest of the code of SimpleDynamic corresponds to the implementation of the DynamicMBean interface. The attributes, operations and notifications exposed are identical to those exposed by the SimpleStandard MBean.

ClientListener.java

The ClientListener.java class is shown in CODE EXAMPLE 3-1.

CODE EXAMPLE 3-1 MBean Example Class ClientListener.java

public class ClientListener implements NotificationListener {
 public void handleNotification(Notification notification, Object handback)
     {
         System.out.println("\nReceived notification: " + notification);
     }
}

The ClientListener class implements a straightforward JMX specification notification listener.

The handleNotification() method of the NotificationListener interface is called upon reception of a notification, and prints out a message to confirm that a notification has been received.

Client.java

The Client.java class is shown in CODE EXAMPLE 3-1.

CODE EXAMPLE 3-1 MBean Example Class Client.java

public class Client {

  public static void main(String[] args) {
    try {
      // Create an RMI connector client
      //
      JMXServiceURL url = new JMXServiceURL(
         "service:jmx:rmi:///jndi/rmi://localhost:9999/server");
      JMXConnector jmxc = JMXConnectorFactory.connect(url, null);
      ClientListener listener = new ClientListener();
      MBeanServerConnection mbsc = jmxc.getMBeanServerConnection();
      waitForEnterPressed();

      // Get domains from MBeanServer
      //
      String domains[] = mbsc.getDomains();
      for (int i = 0; i < domains.length; i++) {
          System.out.println("Domain[" + i + "] = " + domains[i]);
      }
      waitForEnterPressed();

      String domain = mbsc.getDefaultDomain();

      // Create SimpleStandard MBean
      ObjectName mbeanName =
             new ObjectName(domain +":type=SimpleStandard,name=2");
      mbsc.createMBean("SimpleStandard", stdMBeanName, null, null);
      waitForEnterPressed();

      // Create SimpleDynamic MBean
      ObjectName dynMBeanName =
          new ObjectName(domain +":type=SimpleDynamic,name=2");
      echo("\nCreate SimpleDynamic MBean...");
      mbsc.createMBean("SimpleDynamic", dynMBeanName, null, null);
      waitForEnterPressed();

      // Get MBean count
      echo("\nMBean count = " + mbsc.getMBeanCount());

      // Query MBean names
      echo("\nQuery MBeanServer MBeans:");
      Set names = mbsc.queryNames(null, null);
      for (Iterator i = names.iterator(); i.hasNext(); ) {
      echo(     "ObjectName = " + (ObjectName) i.next());
      }
      waitForEnterPressed();

      mbsc.setAttribute(stdMBeanName,
                        new Attribute("State", "changed state"));

      SimpleStandardMBean proxy = JMX.newMBeanProxy(
          mbsc, stdMBeanName, SimpleStandardMBean.class, true);
      echo("\nState = " + proxy.getState());

      ClientListener listener = new ClientListener();
      mbsc.addNotificationListener(stdMBeanName, listener, null, null);

      mbsc.invoke(stdMBeanName, "reset", null, null);

      mbsc.removeNotificationListener(stdMBeanName, listener);
      mbsc.unregisterMBean(stdMBeanName);

      [...]

      jmxc.close();
    } catch (Exception e) {
      e.printStackTrace();
    }
  }
}
[...]

The Client.java class creates an RMI connector client that is configured to connect to the RMI connector server created by Server.java.

As you can see, Client.java defines the same service URL url as that defined by Server.java. This allows the connector client to retrieve the RMI connector server stub named server from the RMI registry running on port 9999 of the local host, and to connect to the RMI connector server.

With the RMI registry thus identified, the connector client can be created. The connector client, jmxc, is an instance of the interface JMXConnector, created by the connect() method of JMXConnectorFactory. The connect() method is passed the parameters url and a null environment map when it is called.

The Client also creates an instance of ClientListener, to listen for notifications, as shown in Section "ClientListener.java".

An instance of a JMX specification MBeanServerConnection, named mbsc, is then created by calling the getMBeanServerConnection() method of the JMXConnector instance jmxc.

The connector client is now connected to the MBean server created by Server.java, and can register MBeans and perform operations on them with the connection remaining completely transparent to both ends.

The client creates and registers the SimpleStandard MBean and the SimpleDynamic MBean in the MBean server with a call to the createMBean() method of MBeanServerConnection, and performs the operations defined by SimpleStandard and SimpleDynamic as if they were local JMX specification MBean operations.

MBean proxies allow you to access an MBean through a Java interface, allowing you to make calls on the proxy rather than having to write lengthy code to access a remote MBean. An MBean proxy for SimpleStandardMBean is created here by calling the method newMBeanProxy() in the javax.management.JMX class, passing it the MBean’s MBeanServerConnection, object name, the class name of the MBean interface and true, to signify that the proxy must behave as a NotificationBroadcaster. You can make proxies for MXBeans in exactly the same way as for standard MBeans, by simply calling newMXBeanProxy() instead of newMBeanProxy().

The code for the different operations performed on SimpleDynamic is not shown here, because the operations are the same as those performed on SimpleStandard.

Finally, the client unregisters the SimpleStandard MBean and closes the connection. The final removeNotificationListener is optional, as listeners registered by a remote client are removed when that client is closed.

Running the MBean Example

Having examined the example classes, you can now run the example. To run the example, follow the steps below, or see the README file:

  2. Compile the Java classes.

    $ javac *.java

  3. Start an RMI registry on port 9999 of the local host.

    The RMI registry will be used by the Server to register the RMI connector stub.

    $ rmiregistry 9999 &

  4. Start the Server class.

    $ java -classpath . Server

    You will see confirmation of the creation of the MBean server and the creation of the SimpleStandard MBean in the MBean server. You will then be prompted to press the Enter key to obtain information about, and then to perform operations on, the SimpleStandard MBean.

    Once the operations on the SimpleStandard have completed, the process will be repeated for the SimpleDynamic MBean.

    Once both the MBeans have been created and their operations performed, you see the creation of an RMI connector server, to allow operations to be performed on the MBeans from the remote Client.

  5. Start the Client class in another terminal window.

    $ java -classpath . Client

    You will see confirmation of the creation of the RMI connector client and of the connection with the connector server. You will also be informed of the domain name, and the creation and registration of SimpleStandard and SimpleDynamic MBeans. The client will then perform operations on SimpleStandard and SimpleDynamic MBeans, before unregistering them.

Contents | Previous | Next

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JPDA Connection and Invocation

Documentation Contents

Connection and Invocation Details

Contents

Transports
Connectors
Oracle VM Invocation Options
Debugging Plug-in Applets
Connecting with JDB
Service Provider Interfaces

Transports

A JPDA Transport is a method of communication between a debugger and the virtual machine that is being debugged (hereafter the target VM). The communication is connection oriented - one side acts as a server, listening for a connection. The other side acts as a client and connects to the server. JPDA allows either the debugger application or the target VM to act as the server. Transport implementations can allow communications between processes running on a single machine, on different machines, or either. When establishing a connection a transport addresses is used to identify the end-point of the connection. The format of a transport address depends on the type of transport.

Within JPDA the debugger application uses the Java Debug Interface (JDI) interface and the Connector abstraction to establish a connection to the target VM. The Connector used by the debugger application encapsulates the transport. On the target VM an agent supporting the Java Debug Wire Protocol is used to communicate with the debugger. This agent (which may be built into the target VM or loaded from a runtime library) encapsulates the transport to communicate with the debugger.

Two transport implementations are shipped with the reference implementation: A socket transport based on TCP/IP, and a shared memory transport. The specifications do not require any specific transport implementation to exist. In addition to transports provided with the implementation the architecture includes service provider interfaces to allow additional transports be developed and deployed.

Socket Transport

The JPDA reference implementation provides a socket transport for the Solaris, Linux, and Microsoft Windows platforms. With the socket transport, the debugger application and the target VM can reside either on the same machine or on different machines. The socket transport uses a single stream TCP/IP connection between the debugger application and the target VM. Both IPv4 and IPv6 are supported on the JDI side of the socket transport. The current implementation on the target VM side only supports IPv4, but this could change in a future release so that both IPv4 and IPv6 are supported.

Command and reply packets are written to the stream in accordance with the JDWP specification using the JDWP Transport Interface. Since many small packets can be sent over JDWP, the TCP_NO_DELAY socket option can improve performance in some socket implementations by avoiding delays that could occur if the socket implementation buffers small packets before sending them. Sockets are closed gracefully so that unsent data is sent if possible.

The socket transport is identified through a unique string, dt_socket. This name can be used to select the socket transport when invoking the target VM. Within the debugger application a corresponding Connector is used which encapsulates the socket transport.

In contexts where a client is attaching to a server, socket transport addresses have the format "<name>:<port>" where <name> is the host name and <port> is the socket port number at which it attaches or listens. In contexts where a server is waiting for a client to attach, the address consists of the port number alone (the host name is implicit).

Shared Memory Transport

In addition to the socket transport, the JPDA reference implementation provides a shared memory transport on the Microsoft Windows platform. The shared memory transport uses a shared memory region to exchange JDWP packets between the debugger application and the target VM. With the shared memory transport, the debugger application and target VM must reside on the same machine.

The shared memory transport is identified through a unique string, dt_shmem. This name can be used to select the socket transport when invoking the target VM. Within the debugger application a corresponding Connector is used which encapsulates the shared memory transport.

Shared memory transport addresses are simply names that can be used as Microsoft Windows file-mapping object names. The name string can consist of any combination of characters, excluding the backslash.

Connectors

A connector is a JDI abstraction that is used in establishing a connection between a debugger application (written to the JDI) and a target VM. Different JDI implementations are free to provide different connector implementations to match the transports and VMs they support. The connector interfaces are very general, to allow JDI to be used with varying connector implementations. Connectors are configured through a set of name/value pairs. Specific connectors accept different name/value pairs.

A good JDI client application will allow users to choose and configure any connector that may be present, but it can be beneficial to incorporate knowledge of specific connectors into the debugger to make their configuration a more pleasant user experience. The example JDB implementation provided with the JPDA illustrates this approach.

The JDI reference implementations provides several connectors which map to the available transport types and the modes of connection (launching, listening, and attaching). These connectors are described in the following sections. A List containing these connectors is returned by JDI method VirtualMachineManager.allConnectors(). In addition, each attaching, listening, and launching connector is contained in the lists returned by the corresponding VirtualMachineManager methods attachingConnectors(), listeningConnectors(), and launchingConnectors().

Command Line Launching Connector

This connector can be used by a debugger application to launch an Oracle VM or any other VM which supports the same invocation options with respect to debugging. The details of launching the VM and specifying the necessary debug options are handled by the connector. The underlying transport used by this connector depends on the platform. On Microsoft Windows, the shared memory transport is used. On Solaris and Linux the socket transport is used.

This connector is uniquely identified by the name "com.sun.jdi.CommandLineLaunch".

Command Line Launching Connector Arguments
name | required? | default value | description
home | no | current java.home property value | Location of the Java Runtime Environment (JRE) used to invoke the Target VM.
options | no | "" | Options, in addition to the standard debugging options, with which to invoke the VM.
main | yes | "" | The debugged application's main class and command line arguments.
suspend | no | true | True if the target VM is to be suspended immediately before the main class is loaded; false otherwise.
quote | yes | "\"" | The character used to combine space-delimited text on the command line.
vmexec | yes | "java" | The VM launcher executable. This can be changed to javaw or to java_g for debugging, if that launcher is available.

Raw Command Line Launching Connector

This connector can be used by a debugger application to launch any VM. The entire command line must be specified and it is not edited in any way. The details of launching the VM with the given command line are handled by the connector. The underlying transport used by this connector depends on the platform. On Microsoft Windows, the shared memory transport is used. On the Solaris operating environment, the socket transport is used.

This connector is uniquely identified by the name "com.sun.jdi.RawCommandLineLaunch".

Raw Command Line Launching Connector Arguments
name | required? | default value | description
command | yes | "" | Full command line to invoke the target VM with the application to be debugged..
address | yes | "" | Transport address at which to listen for the newly launched target VM to connect. This value is typically part of the raw command argument as well, but this is not required if the target VM has some other means of determining the transport address to which it should connect.
quote | yes | "\"" | The character used to combine space-delimited text on the command line.

Socket Attaching Connector

This connector can be used by a debugger application to attach to a currently running target VM through the socket transport. The target VM must have been invoked with options consistent with this connector's arguments described in the following table. For an Oracle VM, the necessary options are described in Oracle Invocation VM Options.

This connector is uniquely identified by the name "com.sun.jdi.SocketAttach".

Socket Attaching Connector Arguments
name | required? | default value | description
hostname | no | local host name | Name of host machine to connect to.
port | yes | "" | Port number on the host machine to connect to.
timeout | no | "" | The timeout, in milliseconds, to use when attaching to the target VM.

Shared Memory Attaching Connector

This connector can be used by a debugger application to attach to a currently running target VM through the shared memory transport. It is available only on the Microsoft Windows platform. The target VM must have been invoked with options consistent with this connectors arguments described in the following table. For an Oracle VM, the necessary options are described in Oracle VM Invocation Options.

This connector is uniquely identified by the name "com.sun.jdi.SharedMemoryAttach".

Shared Memory Attaching Connector Arguments
name | required? | default value | description
name | yes | "" | The shared memory transport address at which the target VM is listening..
timeout | no | "" | The timeout, in milliseconds, to use when attaching to the target VM

Socket Listening Connector

This connector can be used by a debugger application to accept a connection from a separately invoked target VM through the socket transport.. The target VM must be invoked with options consistent with this connector's arguments described in the following table. For an Oracle VM, the necessary options are described in Oracle VM Invocation Options.

This connector can accept connections from multiple target VMs.

This connector is uniquely identified by the name "com.sun.jdi.SocketListen".

Socket Listening Connector Arguments
name | required? | default value | description
port | no | Ephemeral port number (port assigned by the TCP/IP stack) | Port number at which to listen for a connection..
localAddress | no | All addresses assigned to the host | An IP address assigned to the host
timeout | no | "" | The timeout, in milliseconds, to use while waiting for the target VM to connect

Shared Memory Listening Connector

This connector can be used by a debugger application to accept a connection from a separately invoked target VM through the shared memory transport. It is available only on the Microsoft Windows platform. The target VM must be invoked with options consistent with this connector's arguments described in the following table. For an Oracle VM, the necessary options are described in Oracle VM Invocation Options.

This connector can accept connections from multiple target VMs.

This connector is uniquely identified by the name "com.sun.jdi.SharedMemoryListen".

Shared Memory Listening Connector Arguments
name | required? | default value | description
name | yes | "" | A shared memory transport address at which to listen for the target VM connection.
timeout | no | "" | The timeout, in milliseconds, to use while waiting for the target VM to connect

Process Attaching Connector

This connector can be used by a debugger application to attach to a currently running target VM that was started with the "server=y" debugging sub-option described in Oracle VM Invocation Options. The target VM must be Java SE 6 or newer.

The Process Attaching Connector does not have an associated transport. Instead, the transport is determined dynamically when an attach actually occurs. Because of this, the transport().name() method for this connector returns "local".

This connector is uniquely identified by the name "com.sun.jdi.ProcessAttach".

Process Attaching Connector Arguments
name | required? | default value | description
pid | yes | "" | The Process ID of a process to be debugged.
timeout | no | "" | The timeout, in milliseconds, to use when attaching to the target VM.

SA Core Attaching Connector

This connector can be used by a debugger application to debug a core file. It is possible that the core file is corrupted to the extent that not all available debugging operations can be performed on it.

The VirtualMachine object returned by this connector's attach() method is 'read-only'. This means that the method:
vm.canBeModified()
will return false, and that the JDI client should not call any JDI methods that are defined to throw a VMCannotBeModifiedException in this case. The word size (i.e. 32 bit/64 bit) and version (e.g. 5.0, 5.1) of the debugger's Virtual Machine must be the same as that of the Virtual Machine of the process from which the core file was produced.
This connector allows multiple debugging sessions on the same core file.

This connector is uniquely identified by the name "sun.jvm.hotspot.jdi.SACoreAttachingConnector".

SA Core Attaching Connector Arguments
name | required? | default value | description
core | no | core | Pathname of the core file to debug
javaExecutable | yes | "" | Pathname of the Java executable that produced the core file.

SA PID Attaching Connector

This connector can be used by a debugger application to debug a process. It is not available on the Linux Itanium platform. It is possible that the process is corrupted to the extent that not all available debugging operations can be performed on it.

The VirtualMachine object returned by this connector's attach() method is 'read-only'. This means that the method:
vm.canBeModified()
will return false, and that the JDI client should not call any JDI methods that are defined to throw a VMCannotBeModifiedException in this case.

The process to be debugged need not have been started in debug mode(ie, with -agentlib:jdwp or -Xrunjdwp). It is permissable for the process to be hung. The word size (i.e. 32 bit/64 bit) and version (e.g. 5.0, 5.1) of the debugger and debuggee must be the same. The process is suspended when this connector attaches and resumed when this connector detaches. More than one SAPIDAttachingConnector can not attach to a single process simultaneously.

This connector is uniquely identified by the name "sun.jvm.hotspot.jdi.SAPIDAttachingConnector".

SA PID Attaching Connector Arguments
name | required? | default value | description
pid | yes | "" | The Process ID of a process to be debugged.

SA Debug Server Attaching Connector

This connector can be used by a debugger application to debug a process or core file on a machine other than the machine upon which the debugger is running. It is not available on the Linux Itanium platform. It is possible that the remote process/core file is corrupted to the extent that not all available debugging operations can be performed on it.

The VirtualMachine object returned by this connector's attach() method is 'read-only'. This means that the method:
vm.canBeModified()
will return false, and that the JDI client should not call any JDI methods that are defined to throw a VMCannotBeModifiedException in this case.

This connector uses RMI to communicate with a 'debug server' running on the remote machine.
Before the attach() method on this connector is called, the debug server must be started on the remote machine
and told what process or corefile is to be debugged. The following must be done on the remote machine:
  • start the RMI registry with sa-jdi.jar in the classpath:

${JAVA_HOME}/bin/rmiregistry -J-Xbootclasspath/p:${JAVA_HOME}/lib/sa-jdi.jar
  • start the 'debug-server' on the remote machine, specifying the process or corefile to be debugged:
${JAVA_HOME}/bin/java \
    -classpath ${JAVA_HOME}/lib/sa-jdi.jar \
    sun.jvm.hotspot.jdi.SADebugServer \
    <pid> \
    [uniqueID]

or

${JAVA_HOME}/bin/java \
    -classpath ${JAVA_HOME}/lib/sa-jdi.jar \
    sun.jvm.hotspot.jdi.SADebugServer \
    <pathname to the java executable that produced the core file>\
    <pathname of the corefile to debug> \
     [uniqueID]

An alternative to the above two steps is to use the jsadebugd (Solaris, Linux, or Mac OS X or Windows) command to start the RMI registry and debug-server on the remote machine.

'uniqueID' is an optional string. If more than one debug server is to run at the same time on the same machine, then each must have a different 'uniqueID' string.

In the above, JAVA_HOME must contain the pathname of a Java installation that is the same bit size (i.e. 32 bit/64 bit) and the same version (e.g. 5.0, 5.1) as the version used by the debuggee. However the debugger does not have to be the same bit size and version.

A process to be debugged need not have been started in debug mode(ie, with -agentlib:jdwp or -Xrunjdwp). It is permissable for the process to be hung. The process is suspended when the debug server attaches to it. When a debug server attached to a process is killed (by ^C or other means), the debuggee process will be resumed. Attaching more than one debug server to a corefile is permitted, but only one debug server can be attached to a process.

This connector allows multiple debugging sessions connected to the same debug server.

This connector is uniquely identified by the name "sun.jvm.hotspot.jdi.SADebugServerAttachingConnector".

SA DebugServer Attaching Connector Arguments
name | required? | default value | description
debugServerName | yes | "" | The IP address or name of the machine upon which the debug server is running. If the machine contains multiple debug servers, this name must be of the form uniqueID@IPAddress or uniqueID@hostname where 'uniqueID' is the string used to start the corresponding debug server.

Oracle VM Invocation Options

This section describes the options necessary to invoke an Oracle VM for debugging.

Oracle's VM implementation requires command line options to load the JDWP agent for debugging. The -agentlib:jdwp option is used to load and specify options to the JDWP agent.

The -agentlib:jdwp option is specified as follows:

-agentlib:jdwp=<sub-options>
Loads the JPDA reference implementation of JDWP. This library resides in the target VM and uses JVM TI and JNI to interact with it. It uses a transport and the JDWP protocol to communicate with a separate debugger application. Specific sub-options are described in -Xrunjdwp Sub-options.

-agentlib:jdwp and -Xrunjdwp sub-options

The -agentlib:jdwp and -Xrunjdwp option can be further qualified with sub-options. The sub-options are specified as follows:

    -agentlib:jdwp=<name1>[=<value1>],<name2>[=<value2>]...

or

    -Xrunjdwp:<name1>[=<value1>],<name2>[=<value2>]...

The following table describes the options that can be used:

-Xrunjdwp Sub-options
name | required? | default value | description
help | no | N/A | Prints a brief help message and exits the VM.
transport | yes | none | Name of the transport to use in connecting to debugger application.
server no "n" If "y", listen for a debugger application to attach; otherwise, attach to the debugger application at the specified address.

If "y" and no address is specified, choose a transport address at which to listen for a debugger application, and print the address to the standard output stream.
address yes, if server=n
no, otherwise 		"" Transport address for the connection. If server=n, attempt to attach to debugger application at this address. If server=y, listen for a connection at this address.
timeout no "" If server=y specifies the timeout, in milliseconds, to wait for the debugger to attach. If server=n specifies the timeout, in milliseconds, to use when attaching to the debugger. Note that the timeout option may be ignored by some transport implementations.
launch no none At completion of JDWP initialization, launch the process given in this string. This option is used in combination with onthrow and/or onuncaught to provide "Just-In-Time debugging" in which a debugger process is launched when a particular event occurs in this VM.

Note that the launched process is not started in its own window. In most cases the launched process should be a small application which in turns launches the debugger application in its own window.

The following strings are appended to the string given in this argument (space-delimited). They can aid the launched debugger in establishing a connection with this VM. The resulting string is executed.

  • The value of the transport sub-option.
  • The value of the address sub-option (or the generated address if one is not given)
onthrow | no | none | Delay initialization of the JDWP library until an exception of the given class is thrown in this VM. The exception class name must be package-qualified.Connection establishment is included in JDWP initialization, so it will not begin until the exception is thrown.
onuncaught | no | "n" | If "y", delay initialization of the JDWP library until an uncaught exception is thrown in this VM. Connection establishment is included in JDWP initialization, so it will not begin until the exception is thrown. See the JDI specification for com.sun.jdi.ExceptionEvent for a definition of uncaught exceptions.
suspend | no | "y" | If "y", VMStartEvent has a suspendPolicy of SUSPEND_ALL. If "n", VMStartEvent has a suspendPolicy of SUSPEND_NONE.

Examples

-agentlib:jdwp=transport=dt_socket,server=y,address=8000
Listen for a socket connection on port 8000. Suspend this VM before main class loads (suspend=y by default). Once the debugger application connects, it can send a JDWP command to resume the VM.

-agentlib:jdwp=transport=dt_socket,server=y,address=localhost:8000,timeout=5000
Listen for a socket connection on port 8000 on the loopback address only. Terminate if the debugger does not attach within 5 seconds. Suspend this VM before main class loads (suspend=y by default). Once the debugger application connects, it can send a JDWP command to resume the VM.

-agentlib:jdwp=transport=dt_shmem,server=y,suspend=n
Choose an available shared memory transport address and print it to stdout. Listen for a shared memory connection at that address. Allow the VM to begin executing before the debugger application attaches.

-agentlib:jdwp=transport=dt_socket,address=myhost:8000
Attach to a running debugger application via socket on host myhost at port 8000. Suspend this VM before the main class loads.

-agentlib:jdwp=transport=dt_shmem,address=mysharedmemory
Attach to a running debugger application via shared memory at transport address "mysharedmemory". Suspend this VM before the main class loads.

-agentlib:jdwp=transport=dt_socket,server=y,address=8000,onthrow=java.io.IOException,launch=/usr/local/bin/debugstub
Wait for an instance of java.io.IOException to be thrown in this VM. Suspend the VM (suspend=y by default). Listen for a socket connection on port 8000. Execute the following: "/usr/local/bin/debugstub dt_socket myhost:8000".This program can launch a debugger process in a separate window which will attach to this VM and begin debugging it.

-agentlib:jdwp=transport=dt_shmem,server=y,onuncaught=y,launch=d:\bin\debugstub.exe
Wait for an uncaught exception to be thrown in this VM. Suspend the VM. Select a shared memory transport address and listen for a connection at that address. Execute the following: "d:\bin\debugstub.exe dt_shmem <address>", where <address> is the selected shared memory address. This program can launch a debugger process in a separate window which will attach to this VM and begin debugging it.

Debugging Plug-in Applets

Applets running under Java Plug-in can be debugged. The required VM options described above can be specified in the Plug-In control panel, under the "Basic" tab, in the "Java Run-Time Parameters". The debug options under the "Advanced" tab should not be used as they will enable the old sun.tools.debug debug support. In future versions of Java Plug-in, these debug options will be changed to use JPDA.

JDI launching connectors cannot be used to debug Plug-in applets.

Connecting with JDB

The example implementation of JDB provided with the JPDA, provides an illustration of the usage of JDI connectors. There are "shortcut" options to JDB which assume the use of connectors known to it (that is, connectors present in the reference implementation). It also provides a way to establish a general connection using any connector. While JDB is hardly an example of a good debugger interface, it does provide a simple example of connectors in use.

In JDB, the -attach option provides access to one of the attaching connectors in the reference implementation (shared memory on Microsoft Windows, sockets on the Solaris and Linux platforms). The -listen option provides access to one of the listening connectors in the reference implementation (shared memory on Microsoft Windows, sockets on the Solaris and Linux platforms). A class name and arguments specified directly on the command line provide access to the command line launching connector.

For example:

jdb -attach myhost:8000

is an easy way to attach to a target VM with the Socket Attaching Connector (on the Solaris operating environment), and

jdb Hello 1 2 3

is an easy way to launch a target VM with the Command Line Launching Connector.

However, the -connect option is also provided by JDB to handle any connector by taking an connector name and a set of arbitrary name/value argument pairs. For example the command lines above have the following equivalents.

jdb -connect com.sun.jdi.SocketAttach:hostname=myhost,port=8000
jdb -connect "com.sun.jdi.CommandLineLaunch:main=Hello 1 2 3"

These command lines are more cumbersome than the ones above, but the -connect option can be used with any connector. This kind of operation is a primitive example of how a JDI debugger can deal with any kind of connector while providing a simplified interface for dealing with common, well-known connectors.

Service Provider Interfaces

JPDA includes service provider interfaces to allow the development and deployment of connector and transport implementations. These service provider interfaces allow debugger and other tool vendors develop new connector implementations and provide addition transport mechanisms over and beyond the socket and shared memory transport provided by Oracle. The service provider interfaces in JDI are specified in the com.sun.jdi.connect.spi package.

In addition to the service provider interfaces in JDI the Oracle implementation also includes a transport library interface called the Java Debug Wire Protocol Transport Interface. A transport library is loaded by the JDWP agent in the target VM and is used to establish a connection to the debugger and to transport JDWP packets between the debugger and the VM.

Further information on the service provider interfaces can be in the document Java Platform Debugger Architecture - Service Provider Interfaces.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Other Considerations

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous

11 Other Considerations

This section covers other situations that affect garbage collection.

Finalization and Weak, Soft, and Phantom References

Some applications interact with garbage collection by using finalization and weak, soft, or phantom references. These features can create performance artifacts at the Java programming language level. An example of this is relying on finalization to close file descriptors, which makes an external resource (descriptors) dependent on garbage collection promptness. Relying on garbage collection to manage resources other than memory is almost always a bad idea.

The section Related Documents in the Preface includes an article that discusses in depth some of the pitfalls of finalization and techniques for avoiding them.

Explicit Garbage Collection

Another way that applications can interact with garbage collection is by invoking full garbage collections explicitly by calling System.gc(). This can force a major collection to be done when it may not be necessary (for example, when a minor collection would suffice), and so in general should be avoided. The performance effect of explicit garbage collections can be measured by disabling them using the flag -XX:+DisableExplicitGC, which causes the VM to ignore calls to System.gc().

One of the most commonly encountered uses of explicit garbage collection occurs with the distributed garbage collection (DGC) of Remote Method Invocation (RMI). Applications using RMI refer to objects in other virtual machines. Garbage cannot be collected in these distributed applications without occasionally invoking garbage collection of the local heap, so RMI forces full collections periodically. The frequency of these collections can be controlled with properties, as in the following example:

java -Dsun.rmi.dgc.client.gcInterval=3600000
    -Dsun.rmi.dgc.server.gcInterval=3600000 ...

This example specifies explicit garbage collection once per hour instead of the default rate of once per minute. However, this may also cause some objects to take much longer to be reclaimed. These properties can be set as high as Long.MAX_VALUE to make the time between explicit collections effectively infinite if there is no desire for an upper bound on the timeliness of DGC activity.

Soft References

Soft references are kept alive longer in the server virtual machine than in the client. The rate of clearing can be controlled with the command-line option -XX:SoftRefLRUPolicyMSPerMB=<N>, which specifies the number of milliseconds (ms) a soft reference will be kept alive (once it is no longer strongly reachable) for each megabyte of free space in the heap. The default value is 1000 ms per megabyte, which means that a soft reference will survive (after the last strong reference to the object has been collected) for 1 second for each megabyte of free space in the heap. This is an approximate figure because soft references are cleared only during garbage collection, which may occur sporadically.

Class Metadata

Java classes have an internal representation within Java Hotspot VM and are referred to as class metadata. In previous releases of Java Hotspot VM, the class metadata was allocated in the so called permanent generation. In JDK 8, the permanent generation was removed and the class metadata is allocated in native memory. The amount of native memory that can be used for class metadata is by default unlimited. Use the option MaxMetaspaceSize to put an upper limit on the amount of native memory used for class metadata.

Java Hotspot VM explicitly manages the space used for metadata. Space is requested from the OS and then divided into chunks. A class loader allocates space for metadata from its chunks (a chunk is bound to a specific class loader). When classes are unloaded for a class loader, its chunks are recycled for reuse or returned to the OS. Metadata uses space allocated by mmap, not by malloc.

If UseCompressedOops is turned on and UseCompressedClassesPointers is used, then two logically different areas of native memory are used for class metadata. UseCompressedClassPointers uses a 32-bit offset to represent the class pointer in a 64-bit process as does UseCompressedOops for Java object references. A region is allocated for these compressed class pointers (the 32-bit offsets). The size of the region can be set with CompressedClassSpaceSize and is 1 gigabyte (GB) by default. The space for the compressed class pointers is reserved as space allocated by mmap at initialization and committed as needed. The MaxMetaspaceSize applies to the sum of the committed compressed class space and the space for the other class metadata.

Class metadata is deallocated when the corresponding Java class is unloaded. Java classes are unloaded as a result of garbage collection, and garbage collections may be induced in order to unload classes and deallocate class metadata. When the space committed for class metadata reaches a certain level (a high-water mark), a garbage collection is induced. After the garbage collection, the high-water mark may be raised or lowered depending on the amount of space freed from class metadata. The high-water mark would be raised so as not to induce another garbage collection too soon. The high-water mark is initially set to the value of the command-line option MetaspaceSize. It is raised or lowered based on the options MaxMetaspaceFreeRatio and MinMetaspaceFreeRatio. If the committed space available for class metadata as a percentage of the total committed space for class metadata is greater than MaxMetaspaceFreeRatio, then the high-water mark will be lowered. If it is less than MinMetaspaceFreeRatio, then the high-water mark will be raised.

Specify a higher value for the option MetaspaceSize to avoid early garbage collections induced for class metadata. The amount of class metadata allocated for an application is application-dependent and general guidelines do not exist for the selection of MetaspaceSize. The default size of MetaspaceSize is platform-dependent and ranges from 12 MB to about 20 MB.

Information about the space used for metadata is included in a printout of the heap. A typical output is shown in Example 11-1, "Typical Heap Printout".

Example 11-1 Typical Heap Printout

Heap
  PSYoungGen      total 10752K, used 4419K
    [0xffffffff6ac00000, 0xffffffff6b800000, 0xffffffff6b800000)
    eden space 9216K, 47% used
      [0xffffffff6ac00000,0xffffffff6b050d68,0xffffffff6b500000)
    from space 1536K, 0% used
      [0xffffffff6b680000,0xffffffff6b680000,0xffffffff6b800000)
    to   space 1536K, 0% used
      [0xffffffff6b500000,0xffffffff6b500000,0xffffffff6b680000)
  ParOldGen       total 20480K, used 20011K
      [0xffffffff69800000, 0xffffffff6ac00000, 0xffffffff6ac00000)
    object space 20480K, 97% used
      [0xffffffff69800000,0xffffffff6ab8add8,0xffffffff6ac00000)
  Metaspace       used 2425K, capacity 4498K, committed 4864K, reserved 1056768K
    class space   used 262K, capacity 386K, committed 512K, reserved 1048576K

In the line beginning with Metaspace, the used value is the amount of space used for loaded classes. The capacity value is the space available for metadata in currently allocated chunks. The committed value is the amount of space available for chunks. The reserved value is the amount of space reserved (but not necessarily committed) for metadata. The line beginning with class space line contains the corresponding values for the metadata for compressed class pointers.

                Contents
                Previous

  Oracle and/or its affiliates

Copyright
© 1993, 2015, Oracle and/or its affiliates. All rights
reserved.

Contact
Us


Java Console

See Debugging Options in the Java Console in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Console, Tracing, and Logging

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

22 Java Console, Tracing, and Logging

This topic describes the Java Console, a debugging aid that redirects any System.out and System.err to the console window. The console is available for applets running with Java Plug-in and applications running with Java Web Start.

This topic includes the following sections:

  • Debugging Options in the Java Console

  • Tracing and Logging

22.1 Debugging Options in the Java Console

Figure 22-1 shows the options that are available in the Java Console for debugging applets and Java Web Start applications.

Figure 22-1 Java Console

Description of Figure 22-1 follows
Description of "Figure 22-1 Java Console"

An option is selected by typing its letter or number when the Java Console window has focus. The options are described in Table 22-1.

Table 22-1 Java Console Debugging Options

Key | Description
c: | Clears the Java Console window.
f: | Triggers finalization on the objects in the finalization queue and then displays memory information. Memory refers to the current heap size used by the JRE. Free is the available memory that is free in the heap. The percent (xx%) is the free memory as a percent of the total heap size.
g: | Triggers garbage collection and displays memory information as described above.
h: | Displays help message, which is being described here.
l: | Displays a list of the cached ClassLoader objects in the Java Plug-in. Classes are cached to avoid having to load them again when returning to previously-visited pages. When a page is visited the first time, a ClassLoader object will be created and all of the classes that are downloaded will be cached in that object. These objects are created and cached according to their codebase. To identify a ClassLoader object, the "classloader list" displays the codebase for that object. Additional information displayed with a ClassLoader object includes zombie, cache and info. zombie = true indicates that a ClassLoader object is not being used (i.e., the applet is not currently loaded on the page). cache = true indicates that the applet should be cached, while false indicates that the applet will be destroyed when the page is left. info is a value used for debugging.
m: | Displays heap memory usage as described above.
o: | Triggers logging, which directs output from the Java Plug-in Console to a log file.
p: | Reloads the proxy configuration.
q: | Causes the Java Console to disapper from the main screen.
r: | Reloads the policy configuration.
s: | Prints out the system properties. This is mostly for debugging.
t: | Prints out all the existing thread groups. The first group shown is Group main. ac stands for active count; it is the total number of active threads in a thread group and its child thread groups. agc stands for active group count; it is the number of active child thread groups of a thread group. pri stands for priority; it is the priority of a thread group. Following Group main, other thread groups will be shown as Group <name>, where name is the URL associated with an applet. Individual listings of threads will show the thread name, the thread priority, alive if the thread is alive or destroyed if the thread is in the process of being destroyed, and daemon if the thread is a daemon thread.
x: | This removes (destroys) all ClassLoader objects in the cache. Modified jar files will be downloaded from the server when a page with an applet is refreshed or revisited if you first do this: type "x" in the Java Console to clear the Classloader cache.
0-5: | This sets the trace-level options as described in Section 22.2, "Tracing and Logging" Section 22.2, "Tracing and Logging.".

22.2 Tracing and Logging

Tracing is a facility to redirect any output in the Java Console to a trace file. Similar to tracing, logging is a facility to redirect any output in the Java Console to a log file using the Java Logging API.

22.2.1 Tracing

Tracing for Java Plug-in and Java Web Start can be turned on by setting the property deployment.trace property to true. This property turns on all tracing facilities inside Java Plug-in and Java Web Start. To enable more fine-grained tracing, the deployment.trace.level property can be used. The deployment.trace.level property can have one of the following values:

  • basic

  • cache

  • net

  • security

  • ext

  • liveconnect

  • drs

To use all of the tracing levels, set deployment.trace.level to all.

To enable tracing while running, you can set trace-level options (0-5) in the Java Console, with the following meanings:

  • 0: off

  • 1: basic

  • 2: network, cache, and basic

  • 3: security, network and basic

  • 4: extension, security, network and basic

  • 5: LiveConnect, extension, security, network, temp, basic, and Deployment Rule Set

See Section 22.1, "Debugging Options in the Java Console" for information.

Another way to set fine-grained tracing is through the Java Control Panel. For example, to enable tracing for everything (option 5 above), enter the following options in the "Java Run Time Parameters" textfield:

-Ddeployment.trace=true
-Ddeployment.trace.level=all

See Section 20.3.2, "Java Runtime Parameters" for more information.

Tracing set through the Control Panel takes effect when Java Plug-in or Java Web Start is launched, but changes made through the Control Panel while Java Plug-in or Java Web Start is running has no effect until restarted.

22.2.2 Logging

To enable logging perform the following actions:

  • Open Java Control Panel

  • Click Advanced tab.

  • Select Enable Logging under the Debugging option

22.2.3 File Names

  • plugin<random-number>.trace - Name of the trace file for Java Plug-in.

  • plugin<random-number>.log - Name of the log file for Java Plug-in.

  • javaws<random-number>.trace - Name fo the trace file for Java Web Start.

  • javaws<random-number>.log - Name of the log file for Java Web Start.

  • jcp.trace - Name of the trace file that is created when the Java Control Panel is run.

<random-number> is a number that is generated when the file is created.

22.2.4 File Locations

The default location (directory) of the trace and log files is:

  • <user.home>/.java/deployment/log on Solaris and Linux

  • ~/Library/Application Support/Oracle/Java/Deployment/log on OS X

  • <User Application Data Folder>\Sun\Java\Deployment\log on Windows

If the environment variable USER_JPI_PROFILE is set to <user plugin home> then the trace and log files will be written to:

  • <user plugin home>/.java/deployment/log on Solaris and Linux

  • <user plugin home>/Library/Application Support/Oracle/Java/Deployment/log on OS X

  • <user plugin home>\Sun\Java\Deployment\log on Windows

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.javadoc.ConstructorDoc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.ConstructorDoc

    • Uses of ConstructorDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return ConstructorDoc
      Modifier and Type Method and Description
      ConstructorDoc[] ClassDoc.constructors()
      Return included constructors in this class.
      ConstructorDoc[] ClassDoc.constructors(boolean filter)
      Return constructors in this class, filtered to the specified access modifier option.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Java Sound Programmer Guide

Introductory Material

Preface

For Whom This Guide Is Intended
What this Guide Describes
For More Information

Chapter: 1 Introduction to the Java Sound API

Design Goals
Who is the Java Sound API For?
How Does the Java Sound API Relate to Other Interfaces?
Packages
Sampled Audio
What Is Sampled Audio?
Audio Configurations
MIDI
What Is MIDI?
MIDI Configurations
Service Provider Interfaces

Part I: Sampled Audio

Chapter 2: Overview of the Sampled Package

Design Goals
A Focus on Data Transport
Buffered and Unbuffered Handling of Audio
The Essentials: Format, Mixer, and Line
What Is Formatted Audio Data?
What Is a Mixer?
What Is a Line?
Lines in an Audio-output Configuration
Lines in an Audio-input Configuration
The Line Interface Hierarchy

Chapter 3: Accessing Audio System Resources

The AudioSystem Class
Information Objects
Getting a Mixer
Getting a Line of a Desired Type
Getting a Line Directly from the AudioSystem
Getting a Line from a Mixer
Selecting Input and Output Ports
Permission to Use Audio Resources

Chapter 4: Playing Back Audio

Using a Clip
Setting Up the Clip for Playback
Starting and Stopping Playback
Using a SourceDataLine
Setting Up the SourceDataLine for Playback
Starting and Stopping Playback
Monitoring a Line's Status
Synchronizing Playback on Multiple Lines
Processing the Outgoing Audio

Chapter 5: Capturing Audio

Setting Up a TargetDataLine
Reading the Data from the TargetDataLine
Monitoring the Line's Status
Processing the Incoming Audio

Chapter 6: Processing Audio with Controls

Introduction to Controls
Getting a Line that Has the Desired Controls
Getting the Controls from the Line
Using a Control to Change the Audio Signal
Controlling a Line's Mute State
Changing a Line's Volume
Selecting among Various Reverberation Presets
Manipulating the Audio Data Directly

Chapter 7: Using Files and Format Converters

Reading Sound Files
Writing Sound Files
Converting File and Data Formats
Converting from One File Format to Another
Converting Audio between Different Data Formats
Learning What Conversions Are Available

Part II: MIDI

Chapter 8: Overview of the MIDI Package

A MIDI Refresher: Wires and Files
Streaming Data in the MIDI Wire Protocol
Sequenced Data in Standard MIDI Files
The Java Sound API's Representation of MIDI Data
MIDI Messages
MIDI Events
Sequences and Tracks
The Java Sound API's Representation of MIDI Devices
The MidiDevice Interface
Transmitters and Receivers
Sequencers
Synthesizers

Chapter 9: Accessing MIDI System Resources

The MidiSystem Class
Obtaining Default Devices
Learning What Devices Are Installed
Obtaining a Desired Device
Opening Devices

Chapter 10: Transmitting and Receiving MIDI Messages

Understanding Devices, Transmitters, and Receivers
Sending a Message to a Receiver without Using a Transmitter
Understanding Time Stamps
Time Stamps on Messages Sent to Devices
Connecting Transmitters to Receivers
Connecting to a Single Device
Connecting to More than One Device
Closing Connections

Chapter 11: Playing, Recording, and Editing MIDI Sequences

Introduction to Sequencers
When to Use a Sequencer
Understanding Sequence Data
Sequences and Tracks
MidiEvents and Ticks
Overview of Sequencer Methods
Obtaining a Sequencer
Loading a Sequence
Playing a Sequence
Recording and Saving Sequences
Editing a Sequence
Using Advanced Sequencer Features
Moving to an Arbitrary Position in the Sequence
Changing the Playback Speed
Muting or Soloing Individual
Tracks in the Sequence
Synchronizing with Other MIDI Devices
Specifying Special Event Listeners

Chapter 12: Synthesizing Sound

Understanding MIDI Synthesis
Instruments
Channels
Soundbanks and Patches
Voices
Managing Instruments and Soundbanks
Learning What Instruments Are Loaded
Loading Different Instruments
Unloading Instruments
Accessing Soundbank Resources
Querying the Synthesizer's Capabilities and Current State
Using Channels
Controlling the Synthesizer without
Using a Sequencer
Getting a Channel's Current State
Muting and Soloing a Channel
Permission to Play Synthesized Sound

Part III: Service Provider Interfaces

Chapter 13: Introduction to the Service Provider Interfaces

What Are Services?
How Services Work
How Providers Prepare New Services
How Users Install New Services

Chapter 14: Providing Sampled-Audio Services

Introduction
Providing Audio File-Writing Services
Providing Audio File-Reading Services
Providing Format-Conversion Services
Providing New Types of Mixers

Chapter 15: Providing MIDI Services

Introduction
Providing MIDI File-Writing Services
Providing MIDI File-Reading Services
Providing Particular MIDI Devices
Providing Soundbank File-Reading Services

Appendices

Appendix 1: Code Overview: AudioSystem.java

Appendix 2: sound.properties File

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.ContinueTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ContinueTree

  • Packages that use ContinueTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ContinueTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ContinueTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitContinue(ContinueTree node, P p)

    • Uses of ContinueTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ContinueTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitContinue(ContinueTree node, P p)
      R | TreeScanner.visitContinue(ContinueTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


CORBA and Java technologies

Documentation Contents

CORBA Technology and the Java Platform Standard Edition

The Java Platform Standard Edition, v1.4, provides an Object Request Broker (ORB) and two CORBA programming models that can utilize the Java CORBA ORB and Internet InterORB Protocol (IIOP). This topic discusses these options for creating and distributing CORBA technology.

CORBA technology is an integral part of the Java platform. It consists of an Object Request Broker (ORB), APIs for the RMI programming model, and APIs for the IDL programming model.

For more information on which specifications are implemented in this release of the Java platform, see the compliance document.

How does Java SE leverage CORBA

Common Object Request Broker Architecture (CORBA) technology is the open standard for heterogeneous computing. CORBA complements the Java platform by providing a distributed object framework, services to support that framework, and interoperability with other languages. The Java platform complements CORBA by providing a portable, highly productive implementation environment, and a very robust platform. By combining the Java platform with CORBA and other key enterprise technologies, the Java Platform is the ultimate platform for distributed technology solutions.

CORBA standards provide the proven, interoperable infrastructure to the Java platform. IIOP (Internet Inter-ORB Protocol) manages the communication between the object components that power the system. The Java platform provides a portable object infrastructure that works on every major operating system. CORBA provides the network transparency, Java provides the implementation transparency.

The Object Request Broker

An Object Request Broker (ORB) is part of the Java Platform Standard Edition, since version 1.3. The ORB is a runtime component that can be used for distributed computing using IIOP communication.

NOTE: Although it is true that ORBs written in different languages should be able to talk to each other, we haven't tested the interoperability of the Java ORB with other vendor's ORBs.

The Object Management Group (OMG) is an industry consortium that creates and publishes specifications for CORBA. Vendors implement the specifications to produce products known as Object Request Brokers (ORB). The good news for developers is that the Java Platform Standard Edition, v1.2 and higher includes an ORB that is available in every deployment of the Java Platform Standard Edition. For more information, see the ORB class.

The Java CORBA ORB supports both the RMI and IDL programming models, both of which can use the underlying IIOP wire-level protocol for communication.

Introducing the CORBA Programming Models

History of the CORBA Programming Models

In 1997, Remote Method Invocation, or RMI, was introduced in JDK 1.1. Initially, RMI was positioned as a natural outgrowth of Remote Procedure Calls (RPC), strictly for enabling calls to be made between Java objects in different virtual machines, and even on different physical machines.

In 1998, came JDK 1.2, which introduced Java IDL, a Java API for interoperability and integration with CORBA. Java IDL included both a Java-based ORB, which supported IIOP, and the IDL-to-Java compiler, idltojava, for generating client-side stubs and server-side code skeletons. The ORB supports both the RMI over IIOP and Java IDL programming models.

In 1999, the RMI over IIOP standard extension to the Java platform was introduced for JDK 1.1.6 and 1.2. Now that RMI over IIOP is integrated into J2SE version 1.3 and higher, the optional download has been end-of-lifed, but is still available from the archives.

The OMG finalized modifications of its IIOP specification so that it would support most of the JDK 1.1 functionality of RMI. RMI over IIOP was introduced as a standard extension to JDK 1.2. This enabled remote objects written in the Java programming language to be accessible from any language via IIOP.

J2SE, v.1.3 introduced a new, 100% Pure Java, IDL-to-Java compiler, idlj, along with support for IDL abstract interfaces and value types. Also in v.1.3, RMI over IIOP is included in the JDK.

J2SE v.1.4, the current version, was introduced in 2001, and includes support for the Portable Object Adapter, Portable Interceptors, Interoperable Naming Service, GIOP 1.2, and Dynamic Anys. J2SE v.1.4 also includes an Object Request Broker Daemon (ORBD), which is used to enable clients to transparently locate and invoke persistent objects on servers in the CORBA environment, and servertool, which provides a command-line interface for application programmers to register, unregister, startup, and shutdown a persistent server. For more information on new features in J2SE v.1.4, see Changes in CORBA Features Between J2SE 1.3 and 1.4.

Comparing the CORBA Programming Models

Cross-language, cross-vendor interoperability is achieved via the Internet InterORB Protocol, or IIOP. IIOP is a transport protocol for distributed applications written in either IDL or Java RMI.

When using the IDL programming model, the interface is everything! It defines the points of entry that can be called from a remote process, such as the types of arguments the called procedure will accept, or the value/output parameter of information returned. Using IDL, the programmer can make the entry points and data types that pass between communicating processes act like a standard language.

CORBA is a language-neutral system in which the argument values or return values are limited to what can be represented in the involved implementation languages. In CORBA, object orientation is limited only to objects that can be passed by reference (the object code itself cannot be passed from machine-to-machine) or are predefined in the overall framework. Passed and returned types must be those declared in the interface.

With RMI, the interface and the implementation language are described in the same language, so you don't have to worry about mapping from one to the other. Language-level objects (the code itself) can be passed from one process to the next. Values can be returned by their actual type, not the declared type. Or, you can compile the interfaces to generate IIOP stubs and skeletons which allow your objects to be accessible from other CORBA-compliant languages.

The RMI Programming Model

What is the RMI Programming Model

The RMI Programming model is a general object model for distributed computing via the rmi API. You can choose to work completely within the Java programming language, using the Java Remote Method Protocol (JRMP) or work with other CORBA-compliant programming languages using the Internet InterORB Protocol (IIOP).

The RMI programming model is part of the Java Platform Standard Edition, and consists of both an Object Request Broker (ORB) and the rmic compiler. The rmic compiler is used to generate stubs, skeletons, and ties for remote objects using either the JRMP or IIOP protocols. The rmic compiler can also generates OMG IDL. For more information on using rmic, link to rmic - The Java RMI Stub Compiler.

The RMI over IIOP Programmer's Guide discusses the differences between using RMI with JRMP or IIOP.

When should I use the RMI programming model instead of the IDL programming model?

The RMI programming model speeds distributed application development by allowing developers to work completely in the Java programming language. When using the RMI programming model to produce Java technology-based distributed applications, there is no separate Interface Definition Language (IDL) or mapping to learn. The RMI programming model provides flexibility by allowing developers to pass any serializable Java object (Objects By Value) between application components. Like the IDL programming model, the RMI programming model is based on open standards defined with the participation of hundreds of vendors and users in the Java Community Process (JCP). Like the IDL programming model, the RMI programming model can use the Internet Inter-ORB Protocol (IIOP) as its communication protocol. IIOP eases legacy application and platform integration by allowing application components written in C++, Smalltalk, and other CORBA supported languages to communicate with components running on the Java platform.

With the RMI programming model, developers can write remote interfaces in the Java programming language and implement them simply using Java technology and the Java RMI APIs. These interfaces can be implemented in any other language that is supported by an OMG mapping and a vendor supplied ORB for that language. Similarly, clients can be written in other languages using IDL derived from the remote Java technology-based interfaces.

Where can I found out more about the RMI programming model

  • For more information on RMI over IIOP, see RMI over IIOP Documentation.
  • For more information on RMI over JRMP, see RMI Documentation.
  • For an introductory tutorial using RMI over IIOP, see Tutorial: Getting Started with RMI over IIOP.
  • For more information on mapping Java interfaces to OMG IDL, see Catalog of OMG IDL / Language Mappings Specificatons.

The IDL Programming Model

What is the IDL Programming Model

The IDL programming model, known as Java IDL, consists of both the Java CORBA ORB and the idlj compiler that maps the OMG IDL to Java bindings that use the Java CORBA ORB, as well as a set of APIs, which can be explored by selecting the org.omg prefix from the Package section of the API index.

Java IDL adds CORBA (Common Object Request Broker Architecture) capability to the Java platform, providing standards-based interoperability and connectivity. Java IDL enables distributed Web-enabled Java applications to transparently invoke operations on remote network services using the industry standard IDL (Object Management Group Interface Definition Language) and IIOP (Internet Inter-ORB Protocol) defined by the Object Management Group. Runtime components include a Java ORB for distributed computing using IIOP communication.

To use the IDL programming model, you define remote interfaces using the Object Management Group's (OMG) Interface Definition Language (IDL), then compile the interfaces using the idlj compiler. When you run the idlj compiler over your interface definition file, it generates the Java version of the interface, as well as the class code files for the stubs and skeletons that enable your applications to hook into the ORB.

Java IDL is part of the Java Platform Standard Edition. To develop applications with Java IDL, use the Java IDL Compiler, idlj (Solaris, Linux, or Mac OS X or Windows), idlj, which is included in every installation of J2SE v1.3 and higher.

When should I use the IDL programming model instead of the RMI programming model?

The OMG IDL (Interface Definition Language) is a purely declarative language designed for specifying programming-language-independent operational interfaces for distributed applications. OMG specifies a mapping from IDL to several different programming languages, including Java, C, C++, Lisp, Python, Smalltalk, COBOL, and Ada. When mapped, each statement in OMG IDL is translated to a corresponding statement in the programming language of choice. Java IDL is an implementation of the CORBA specification. For example, you could use the Java IDL Compiler, idlj, to map an IDL interface to Java and implement the client class in Java. If you map the same IDL to C++, using an IDL-to-C++ compiler and a C++ ORB, and implement the server in that language, the Java client and C++ server interoperate through the ORB.

NOTE: Although it is true that ORBs written in different languages should be able to talk to each other, we haven't tested the interoperability of the Java ORB with other vendor's ORBs.

Where can I find out more about the IDL programming model

  • For more information on the IDL programming model, see Java IDL Documentation.
  • For an introductory tutorial to the IDL programming model, see the Getting Started with Java IDL tutorial.
  • For more information on how IDL maps to the Java language, see see the Catalog of OMG IDL / Language Mappings Specificatons.

Comparison of IDL and RMI programming models

There are several scenarios that will define how you will want to create distributed CORBA applications. Here are some of them:

  • If you have been developing CORBA applications using IDL for some time, you will probably want to stay in this environment. Create the interfaces using IDL, and define the client and server applications using the Java programming language to take advantage of its portabile, highly productive implementation environment, and its very robust platform.
  • If all of your applications are written in the Java programming language, you will probably want to use Java RMI to enable communication between Java objects on different virtual machines and different physical machines. Using Java RMI without its IIOP option leverages its strengths of code portability, security, and garbage collection.
  • If you are writing most of your new applications using the Java programming language, but need to maintain legacy applications written in other programming languages as well, you will probably want to use Java RMI with its IIOP compiler option.

What about CORBA and J2EE?

In addition to Java IDL and RMI over IIOP, J2EE includes Enterprise JavaBeans technology (EJB).

Enterprise JavaBeans is part of the Java Platform, Enterprise Edition. The EJB server-side component model simplifies development of middleware components that are transactional, scalable, and portable. EJB servers reduce the complexity of developing middleware by providing automatic support for middleware services such as transactions, security, database connectivity, and more.

EJBs use RMI over IIOP for their distributed object model, and use the Java Transaction Service (JTS) for their distributed transaction model. When Enterprise JavaBeans are implemented using the RMI over IIOP protocol for EJB interoperability in heterogeneous server environments, the standard mapping of the EJB architecture to CORBA enables the following interoperability:

  • A Java client using an ORB from one vendor can access enterprise beans residing on an EJB server provided by another vendor.
  • Enterprise beans in one EJB server can access enterprise beans in another EJB server.
  • A non-Java platform CORBA client can access any enterprise bean object.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java VisualVM

Working with Core Dumps

When you start Java VisualVM, the Applications window is visible in the left of the Java VisualVM window. The Applications window enables you to quickly view running local and remote applications. The Applications also displays core dumps and profiling snapshots saved to your local system.

The Core Dump node is visible in the Applications window if Java VisualVM is running on Solaris or Linux. Generally, Java VisualVM can only open a core dump if the core dump was taken on the same machine. A core dump contains informaton on the Java Development Kit (JDK) and kernel of the machine where the core dump was taken. To open the core dump in Java VisualVM, this information must match the JDK software and kernel of the local system.

A core dump is a binary file capturing the entire heap contents at the moment the dump is captured. When you load a core dump in Java VisualVM, a node for the core dump appears below the Core Dump node.

screenshot of Applications window showing Core Dump node

To view an overview of the core dump, right-click the core dump node and choose Open. (Alternatively, double-click the node.)

screenshot of Overview tab of core dump

You can right-click the core dump node and choose Heap Dump or Thread Dump to view the heap dump and thread dump from the core dump.

screenshot of Overview tab of core dump

You can then save the thread dump and heap dump to your local system.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface org.w3c.dom.css.Counter (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.Counter

  • Packages that use Counter
    Package Description
    org.w3c.dom.css

    • Uses of Counter in org.w3c.dom.css

      Methods in org.w3c.dom.css that return Counter
      Modifier and Type Method and Description
      Counter CSSPrimitiveValue.getCounterValue()
      This method is used to get the Counter value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Description of Figure Certification Path

Documentation Contents

Description of Figure CertificationPath

Link to figure Certification Path.

This figure consists of three boxes arranged horizontally:

  • The first box is divided into three sections horizontally. These sections contain the following text, from top to bottom:

    • Issuer = CA2
    • Subject = Alice
    • Alice's Public Key

    The last section also contains an image of a key.

  • The second box is divided into three sections horizontally. These sections contain the following text, from top to bottom:

    • Issuer = CA1
    • Subject = CA2
    • CA2's Public Key

    The last section also contains an image of a key.

  • The third box contains the text "CA1's Public Key" and an image of a key.

Arrows connect the following boxes and sections

  • From "CA1's Public Key" to "Issuer = CA1"
  • From "Subject = CA2" to "Issuer = CA2"
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Oracle Legal Notices

Copyright Notice

Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.

Trademark Notice

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

Intel and Intel Xeon are trademarks or registered trademarks of Intel Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. AMD, Opteron, the AMD logo, and the AMD Opteron logo are trademarks or registered trademarks of Advanced Micro Devices. UNIX is a registered trademark of The Open Group.

License Restrictions Warranty/Consequential Damages Disclaimer

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

Warranty Disclaimer

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

Restricted Rights Notice

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users are "commercial computer software" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.

Hazardous Applications Notice

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

Third-Party Content, Products, and Services Disclaimer

This software or hardware and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.

Alpha and Beta Draft Documentation Notice

If this document is in preproduction status:

This documentation is in preproduction status and is intended for demonstration and preliminary use only. It may not be specific to the hardware on which you are using the software. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to this documentation and will not be responsible for any loss, costs, or damages incurred due to the use of this documentation.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration crash-dump-windbg.gif

Documentation Contents

This illustration contains a screenshot of the output from windbg a debugging tool for Windows. There is a single window with several dozens of lines of debugging information text.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Troubleshoot System Crashes

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

5 Troubleshoot System Crashes

This chapter provides information and guidance on some specific procedures for troubleshooting system crashes.

A crash, or fatal error, causes a process to terminate abnormally. There are various possible reasons for a crash. For example, a crash can occur due to a bug in the Java HotSpot VM, in a system library, in a Java SE library or an API, in application native code, or even in the operating system (OS). External factors, such as resource exhaustion in the OS can also cause a crash.

Crashes caused by bugs in the Java HotSpot VM or in the Java SE library code are rare. This chapter provides suggestions on how to examine a crash and work around some of the issues (if possible) until the cause of the bug is diagnosed and fixed.

In general the first step with any crash is to locate the fatal error log. This is a text file that the Java HotSpot VM generates in the event of a crash. See Appendix A for an explanation of how to locate this file, as well as a detailed description of the file.

This chapter contains the following sections:

  • Determine Where the Crash Occurred

  • Find a Workaround

  • Microsoft Visual C++ Version Considerations

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Determine Where the Crash Occurred

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

5.1 Determine Where the Crash Occurred

This section provides a number of examples which demonstrate how the error log can be used to find the cause of the crash, and suggests some tips for troubleshooting the problem depending on the cause.

The error log header indicates the type of error and the problematic frame, while the thread stack indicates the current thread and stack trace. See Header Format.

The following are possible causes for the crash.

  • Crash in Native Code

  • Crash in Compiled Code

  • Crash in HotSpot Compiler Thread

  • Crash in VM Thread

  • Crash Due to Stack Overflow

5.1.1 Crash in Native Code

If the fatal error log indicates the problematic frame to be a native library, there might be a bug in native code or the Java Native Interface (JNI) library code. The crash could of course be caused by something else, but analysis of the library and any core file or crash dump is a good starting place. Consider the extract in Example 5-1 from the header of a fatal error log.

Example 5-1 Extract from the Header of a Fatal Error Log

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0x417789d7, pid=21139, tid=1024
#
# Java VM: Java HotSpot(TM) Server VM (6-beta2-b63 mixed mode)
# Problematic frame:
# C  [libApplication.so+0x9d7]

In this case a SIGSEGV occurred with a thread executing in the library libApplication.so.

In some cases a bug in a native library manifests itself as a crash in Java VM code. Consider the crash in Example 5-2, where a JavaThread fails while in the _thread_in_vm state (meaning that it is executing in Java VM code).

Example 5-2 Example for a Crash

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x08083d77, pid=3700, tid=2896
#
# Java VM: Java HotSpot(TM) Client VM (1.5-internal mixed mode)
# Problematic frame:
# V  [jvm.dll+0x83d77]

---------------  T H R E A D  ---------------

Current thread (0x00036960):  JavaThread "main" [_thread_in_vm, id=2896]
 :
Stack: [0x00040000,0x00080000),  sp=0x0007f9f8,  free space=254k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V  [jvm.dll+0x83d77]
C  [App.dll+0x1047]          <========= C/native frame
j  Test.foo()V+0
j  Test.main([Ljava/lang/String;)V+0
v  ~StubRoutines::call_stub
V  [jvm.dll+0x80f13]
V  [jvm.dll+0xd3842]
V  [jvm.dll+0x80de4]
V  [jvm.dll+0x87cd2]
C  [java.exe+0x14c0]
C  [java.exe+0x64cd]
C  [kernel32.dll+0x214c7]
 :

In this case, although the problematic frame is a VM frame, the thread stack shows that a native routine in App.dll has called into the VM (probably with JNI).

The first step to solving a crash in a native library is to investigate the source of the native library where the crash occurred.

  • If the native library is provided by your application, then investigate the source code of your native library. A significant number of issues with JNI code can be identified by running the application with the -Xcheck:jni option added to the command line. See The -Xcheck:jni Option.

  • If the native library has been provided by another vendor and is used by your application, then file a bug report against this third-party application and provide the fatal error log information.

  • If the native library where the crash occurred is part of the Java Runtime Environment (JRE) (for example awt.dll, net.dll, and so forth), then it is possible that you have encountered a library or API bug. If so, gather as much data as possible and submit a bug or report, indicating the library name. You can find JRE libraries in the jre/lib or jre/bin directories of the JRE distribution. See Submit a Bug Report.

You can troubleshoot a crash in a native application library by attaching the native debugger to the core file or crash dump, if it is available. Depending on the OS, the native debugger is dbx, gdb, or windbg. See Native Operating System Tools.

5.1.2 Crash in Compiled Code

If the fatal error log indicates that the crash occurred in compiled code, then it is possible that you have encountered a compiler bug that has resulted in incorrect code generation. You can recognize a crash in compiled code if the type of the problematic frame is J (meaning a compiled Java frame). Example 5-3 shows such a crash.

Example 5-3 Crash in Compiled Code

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0x0000002a99eb0c10, pid=6106, tid=278546
#
# Java VM: Java HotSpot(TM) 64-Bit Server VM (1.6.0-beta-b51 mixed mode)
# Problematic frame:
# J  org.foobar.Scanner.body()V
#
:
Stack: [0x0000002aea560000,0x0000002aea660000),  sp=0x0000002aea65ddf0,
  free space=1015k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
J  org.foobar.Scanner.body()V

[error occurred during error reporting, step 120, id 0xb]

Note: A complete thread stack is not available. The output line "error occurred during error reporting" means that a problem arose trying to obtain the stack trace (this might indicate stack corruption).

It might be possible to temporarily work around the issue by switching the compiler (for example, by using the HotSpot Client VM instead of the HotSpot Server VM, or visa versa) or by excluding from compilation the method that provoked the crash. In this specific example it might not be possible to switch the compiler as it was taken from a 64-bit Server VM and hence it might not be feasible to switch to a 32-bit Client VM.

For more information on possible workarounds, see Working Around Crashes in the HotSpot Compiler Thread or Compiled Code.

5.1.3 Crash in HotSpot Compiler Thread

If the fatal error log output shows that the current thread is JavaThread named CompilerThread0, CompilerThread1, or AdapterCompiler, then it is possible that you have encountered a compiler bug. In this case it might be necessary to temporarily work around the issue by switching the compiler (for example, by using the HotSpot Client VM instead of the HotSpot Server VM, or visa versa), or by excluding from compilation the method that provoked the crash.

For more information on possible workarounds, see Working Around Crashes in the HotSpot Compiler Thread or Compiled Code.

5.1.4 Crash in VM Thread

If the fatal error log output shows that the current thread is VMThread, then look for the line containing VM_Operation in the THREAD section. VMThread is a special thread in the HotSpot VM. It performs special tasks in the VM such as garbage collection (GC). If the VM_Operation suggests that the operation is a GC, then it is possible that you have encountered an issue such as heap corruption.

Besides a GC issue, it could equally be something else (such as a compiler or runtime bug) that leaves object references in the heap in an inconsistent or incorrect state. In this case, collect as much information as possible about the environment and try possible workarounds. If the issue is related to GC, you might be able to temporarily work around the issue by changing the GC configuration.

For more information on possible workarounds, see Working Around Crashes during Garbage Collection.

5.1.5 Crash Due to Stack Overflow

A stack overflow in Java language code will normally result in the offending thread throwing the java.lang.StackOverflowError exception. On the other hand, C and C++ write past the end of the stack and provoke a stack overflow. This is a fatal error which causes the process to terminate.

In the HotSpot implementation, Java methods share stack frames with C/C++ native code, namely user native code and the virtual machine itself. Java methods generate code that checks whether stack space is available a fixed distance towards the end of the stack so that the native code can be called without exceeding the stack space. This distance towards the end of the stack is called "Shadow Pages". The size of the shadow pages is between 3 and 20 pages, depending on the platform. This distance is tunable, so that applications with native code needing more than the default distance can increase the shadow page size. The option to increase shadow pages is -XX:StackShadowPages=n, where n is greater than the default stack shadow pages for the platform.

If your application gets a segmentation fault without a core file or fatal error log file see Appendix A, or a STACK_OVERFLOW_ERROR on Windows, or the message "An irrecoverable stack overflow has occurred", this indicates that the value of StackShadowPages was exceeded and more space is needed.

If you increase the value of StackShadowPages, you might also need to increase the default thread stack size using the -Xss parameter. Increasing the default thread stack size might decrease the number of threads that can be created, so be careful in choosing a value for the thread stack size. The thread stack size varies by platform from 256 KB to 1024 KB.

Example 5-4 Stack Overflow Exception

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  EXCEPTION_STACK_OVERFLOW (0xc00000fd) at pc=0x10001011, pid=296, tid=2940
#
# Java VM: Java HotSpot(TM) Client VM (1.6-internal mixed mode, sharing)
# Problematic frame:
# C  [App.dll+0x1011]
#

---------------  T H R E A D  ---------------

Current thread (0x000367c0):  JavaThread "main" [_thread_in_native, id=2940]
:
Stack: [0x00040000,0x00080000),  sp=0x00041000,  free space=4k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [App.dll+0x1011]
C  [App.dll+0x1020]
C  [App.dll+0x1020]
:
C  [App.dll+0x1020]
C  [App.dll+0x1020]
...<more frames>...

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  Test.foo()V+0
j  Test.main([Ljava/lang/String;)V+0
v  ~StubRoutines::call_stub

You can interpret the following information from Example 5-4.

  • The exception is EXCEPTION_STACK_OVERFLOW.

  • The thread state is _thread_in_native, which means that the thread is executing native or JNI code.

  • In the stack information, the free space is only 4 KB (a single page on a Windows system). In addition, the stack pointer (sp) is at 0x00041000, which is close to the end of the stack at 0x00040000.

  • The printout of the native frames shows that a recursive native function is the issue in this case. The output notation ...<more frames>... indicates that additional frames exist but were not printed. The output is limited to 100 frames.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Find a Workaround

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

5.2 Find a Workaround

If a crash occurs with a critical application, and the crash appears to be caused by a bug in the HotSpot VM, then it might be desirable to quickly find a temporary workaround. The purpose of this section is to suggest some possible workarounds. If the crash occurs with an application that is deployed with the most recent release of the JDK, then the crash should always be reported to Oracle.

WARNING:

Even if a workaround in this section successfully eliminates a crash, the workaround is not a fix for the problem, but merely a temporary solution. Submit a support call or bug report with the original configuration that demonstrated the issue.

The following are three scenarios to find workarounds for system crashes.

  • Working Around Crashes in the HotSpot Compiler Thread or Compiled Code

  • Working Around Crashes during Garbage Collection

  • Working Around Crashes Caused by Class Data Sharing

5.2.1 Working Around Crashes in the HotSpot Compiler Thread or Compiled Code

If the fatal error log indicates that the crash occurred in a compiler thread, then it is possible (but not always the case) that you have encountered a compiler bug. Similarly, if the crash is in compiled code then it is possible that the compiler has generated incorrect code.

In case of the HotSpot Client VM (-client option), the compiler thread appears in the error log as CompilerThread0. With the HotSpot Server VM there are multiple compiler threads and these appear in the error log file as CompilerThread0, CompilerThread1, and AdapterThread.

Since JDK 7u5 release, the HotSpot compiler is ignored by default. A command line option is available to simulate the old behavior, which is useful when multiple methods have been excluded. For details on the command line option, see notable bug fixes in JDK 7u5.

To exclude methods from being compiled by using a JVM flag instead of .hotspot_compile file, see -XX:CompileCommand in Advanced JIT Compiler Options.

Example 5-5 shows a fragment of an error log for a compiler bug that was encountered and fixed during the development. The log file shows that the HotSpot Server VM is used and the crash occurred in CompilerThread1. In addition, the log file shows that the current CompileTask was the compilation of the java.lang.Thread.setPriority method.

Example 5-5 Error Log for a Compiler Bug

# An unexpected error has been detected by HotSpot Virtual Machine:
#
:
# Java VM: Java HotSpot(TM) Server VM (1.5-internal-debug mixed mode)
:
---------------  T H R E A D  ---------------

Current thread (0x001e9350): JavaThread "CompilerThread1" daemon [_thread_in_vm, id=20]

Stack: [0xb2500000,0xb2580000),  sp=0xb257e500,  free space=505k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V  [libjvm.so+0xc3b13c]
:

Current CompileTask:
opto: 11      java.lang.Thread.setPriority(I)V (53 bytes)

---------------  P R O C E S S  ---------------

Java Threads: ( => current thread )
  0x00229930 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=21]
=>0x001e9350 JavaThread "CompilerThread1" daemon [_thread_in_vm, id=20]
 :

In this case there are two potential workarounds:

  • The brute force approach: change the configuration so that the application is run with the -client option to specify the HotSpot Client VM.

  • The subtle approach: assume that the bug only occurs during the compilation of the java.lang.Thread.setPriority method and exclude this method from compilation.

The first approach (to use the -client option) might be trivial to configure in some environments. In others, it might be more difficult if the configuration is complex or if the command line to configure the VM is not readily accessible. In general, switching from the HotSpot Server VM to the HotSpot Client VM also reduces the peak performance of an application. Depending on the environment, this might be acceptable until the actual issue is diagnosed and fixed.

The second approach (exclude the method from compilation) requires creating the file .hotspot_compiler in the working directory of the application. Example 5-6 shows this approach.

Example 5-6 Exclude the Method from Compilation

exclude java/lang/Thread setPriority

In general the format of this file is exclude class method, where class is the class (fully qualified with the package name) and method is the name of the method. Constructor methods are specified as <init> and static initializers are specified as <clinit>.

Note:

The .hotspot_compiler file is an unsupported interface. It is documented here solely for the purposes of troubleshooting and finding a temporary workaround.

Once the application is restarted, the compiler will not attempt to compile any of the methods excluded in the .hotspot_compiler file. In some cases this can provide temporary relief until the root cause of the crash is diagnosed and the bug is fixed.

In order to verify that the HotSpot VM correctly located and processed the .hotspot_compiler file that is shown in Example 5-6, look for the log information at runtime. Note: The file name separator is a dot, not a slash.

5.2.2 Working Around Crashes during Garbage Collection

If a crash occurs during garbage collection (GC), then the fatal error log reports that a VM_Operation is in progress. For the purposes of this discussion, assume that the mostly concurrent GC (-XX:+UseConcMarkSweep) is not in use. The VM_Operation is shown in the THREAD section of the log and indicates one of the following situations:

  • Generation collection for allocation

  • Full generation collection

  • Parallel gc failed allocation

  • Parallel gc failed permanent allocation

  • Parallel gc system gc

Most likely the current thread reported in the log is the VMThread. This is the special thread used to execute special tasks in the HotSpot VM. Example 5-7 is a fragment of the fatal error log from a crash in the serial garbage collector.

Example 5-7 Crash in Serial Garbage Collector

---------------  T H R E A D  ---------------

Current thread (0x002cb720):  VMThread [id=3252]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000000

Registers:
EAX=0x0000000a, EBX=0x00000001, ECX=0x00289530, EDX=0x00000000
ESP=0x02aefc2c, EBP=0x02aefc44, ESI=0x00289530, EDI=0x00289530
EIP=0x0806d17a, EFLAGS=0x00010246

Top of Stack: (sp=0x02aefc2c)
0x02aefc2c:   00289530 081641e8 00000001 0806e4b8
0x02aefc3c:   00000001 00000000 02aefc9c 0806e4c5
0x02aefc4c:   081641e8 081641c8 00000001 00289530
0x02aefc5c:   00000000 00000000 00000001 00000001
0x02aefc6c:   00000000 00000000 00000000 08072a9e
0x02aefc7c:   00000000 00000000 00000000 00035378
0x02aefc8c:   00035378 00280d88 00280d88 147fee00
0x02aefc9c:   02aefce8 0806e0f5 00000001 00289530
Instructions: (pc=0x0806d17a)
0x0806d16a:   15 08 83 3d c0 be 15 08 05 53 56 57 8b f1 75 0f
0x0806d17a:   0f be 05 00 00 00 00 83 c0 05 a3 c0 be 15 08 8b

Stack: [0x02ab0000,0x02af0000),  sp=0x02aefc2c,  free space=255k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V  [jvm.dll+0x6d17a]
V  [jvm.dll+0x6e4c5]
V  [jvm.dll+0x6e0f5]
V  [jvm.dll+0x71771]
V  [jvm.dll+0xfd1d3]
V  [jvm.dll+0x6cd99]
V  [jvm.dll+0x504bf]
V  [jvm.dll+0x6cf4b]
V  [jvm.dll+0x1175d5]
V  [jvm.dll+0x1170a0]
V  [jvm.dll+0x11728f]
V  [jvm.dll+0x116fd5]
C  [MSVCRT.dll+0x27fb8]
C  [kernel32.dll+0x1d33b]

VM_Operation (0x0373f71c): generation collection for allocation, mode:
 safepoint, requested by thread 0x02db7108

Note:

A crash during garbage collection does not imply a bug in the garbage collection implementation. It could also indicate a compiler or runtime bug, or some other issue.

You can try the following workarounds if you get a repeated crash during garbage collection:

  • Switch GC configuration. For example, if you are using the serial collector, try the throughput collector, or visa versa.

  • If you are using the HotSpot Server VM, try the HotSpot Client VM.

If you are not sure which garbage collector is in use, you can use the jmap utility on Oracle Solaris and Linux operating systems. See The jmap Utility to obtain the heap information from the core file, if the core file is available. In general if the GC configuration is not specified on the command line, then the serial collector will be used on Windows. On Oracle Solaris and Linux operating systems it depends on the machine configuration. If the machine has at least 2 GB of memory and has at least 2 CPUs, then the throughput collector (Parallel GC) will be used. For smaller machines the serial collector is the default. The option to select the serial collector is -XX:+UseSerialGC and the option to select the throughput collector is -XX:+UseParallelGC. If, as a workaround, you switch from the throughput collector to the serial collector, then you might experience some performance degradation on multi-processor systems. This might be acceptable until the root issue is diagnosed and resolved.

5.2.3 Working Around Crashes Caused by Class Data Sharing

Class data sharing (CDS) was a new feature in J2SE 5.0. When the JRE is installed on 32-bit platforms using the Sun-provided installer, the installer loads a set of classes from the system JAR file into a private internal representation and dumps that representation to a file called a shared archive. When the VM is started, the shared archive is memory-mapped in. This saves on class loading and allows much of the metadata associated with the classes to be shared across multiple VM instances. In J2SE 5.0, CDS is enabled only when the HotSpot Client VM is used. In addition, sharing is supported only with the serial garbage collector.

The fatal error log prints the version string in the header of the log. If sharing is enabled, it is indicated by the text "sharing", as shown in Example 5-8.

Example 5-8 Error Log for Class Data Sharing

# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x08083d77, pid=3572, tid=784
#
# Java VM: Java HotSpot(TM) Client VM (1.5-internal mixed mode, sharing)
# Problematic frame:
# V  [jvm.dll+0x83d77]

CDS can be disabled by providing the -Xshare:off option on the command line. If the crash only occurs with sharing enabled, then it is possible that you have encountered a bug in this feature. In that case gather as much information as possible and submit a bug report.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Microsoft Visual C++ Version Considerations

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

5.3 Microsoft Visual C++ Version Considerations

The JDK software is built on Windows using Microsoft Visual Studio 2010 Professional for both 32-bit and 64-bit platforms. If you experience a crash with a Java application and if you have native or JNI libraries that are compiled with a different release of the compiler, then you must consider compatibility issues between the runtimes. Specifically, your environment is supported only if you follow the Microsoft guidelines when dealing with multiple runtimes. For example, if you allocate memory using one runtime, then you must release it using the same runtime. Unpredictable behavior or crashes can arise if you release a resource using a different library than the one that allocated the resource.

 Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Cryptography Architecture (JCA) Reference Guide

Skip Table of Contents
  • Introduction
    • Design Principles
    • Architecture
    • JCA Concepts
  • Core Classes and Interfaces
    • The Provider Class
      • How Provider Implementations are Requested and Supplied
      • Installing Providers
    • The Security Class
    • The SecureRandom Class
    • The MessageDigest Class
    • The Signature Class
    • The Cipher Class
    • Other Cipher-based Classes
      • The Cipher Stream Classes
        • The CipherInputStream Class
        • The CipherOutputStream Class
      • The SealedObject Class
    • The Mac Class
    • Key Interfaces
    • The KeyPair Class
    • Key Specification Interfaces and Classes
      • The KeySpec Interface
      • The KeySpec Subinterfaces
      • The EncodedKeySpec Class
        • The PKCS8EncodedKeySpec Class
        • The X509EncodedKeySpec Class
    • Of Factories and Generators
    • The KeyFactory Class
    • The SecretKeyFactory Class
    • The KeyPairGenerator Class
    • The KeyGenerator Class
    • The KeyAgreement Class
    • Key Management
      • Keystore Location
      • Keystore Implementation
      • The KeyStore Class
    • Algorithm Parameters Classes
      • The AlgorithmParameterSpec Interface
      • The AlgorithmParameters Class
      • The AlgorithmParameterGenerator Class
    • The CertificateFactory Class
  • How the JCA Might Be Used in a SSL/TLS Implementation
  • How to Make Applications "Exempt" from Cryptographic Restrictions
  • Code Examples
    • Computing a MessageDigest Object
    • Generating a Pair of Keys
    • Generating and Verifying a Signature Using Generated Keys
    • Generating/Verifying Signatures Using Key Specifications and KeyFactory
    • Determining If Two Keys Are Equal
    • Reading Base64-Encoded Certificates
    • Parsing a Certificate Reply
    • Using Encryption
    • Using Password-Based Encryption
    • Using Key Agreement
  • Appendix A: Standard Names
  • Appendix B: Jurisdiction Policy File Format
  • Appendix C: Maximum Key Sizes Allowed by "Strong" Jurisdiction Policy Files
  • Appendix D: Sample Programs
    • Diffie-Hellman Key Exchange between 2 Parties
    • Diffie-Hellman Key Exchange between 3 Parties
    • Blowfish Cipher Example
    • HMAC-MD5 Example
    • Reading ASCII Passwords From an InputStream Example

Introduction

The Java platform strongly emphasizes security, including language safety, cryptography, public key infrastructure, authentication, secure communication, and access control.

The JCA is a major piece of the platform, and contains a "provider" architecture and a set of APIs for digital signatures, message digests (hashes), certificates and certificate validation, encryption (symmetric/asymmetric block/stream ciphers), key generation and management, and secure random number generation, to name a few. These APIs allow developers to easily integrate security into their application code. The architecture was designed around the following principles:

  • Implementation independence: Applications do not need to implement security algorithms. Rather, they can request security services from the Java platform. Security services are implemented in providers (see below), which are plugged into the Java platform via a standard interface. An application may rely on multiple independent providers for security functionality.

  • Implementation interoperability: Providers are interoperable across applications. Specifically, an application is not bound to a specific provider, and a provider is not bound to a specific application.

  • Algorithm extensibility: The Java platform includes a number of built-in providers that implement a basic set of security services that are widely used today. However, some applications may rely on emerging standards not yet implemented, or on proprietary services. The Java platform supports the installation of custom providers that implement such services.

Other cryptographic communication libraries available in the JDK use the JCA provider architecture, but are described elsewhere. The Java Secure Socket Extension (JSSE) provides access to Secure Socket Layer (SSL) and Transport Layer Security (TLS) implementations. The Java Generic Security Services (JGSS) (via Kerberos) APIs, and the Simple Authentication and Security Layer (SASL) can also be used for securely exchanging messages between communicating applications.

Notes on Terminology

  • Prior to JDK 1.4, the JCE was an unbundled product, and as such, the JCA and JCE were regularly referred to as separate, distinct components. As JCE is now bundled in the JDK, the distinction is becoming less apparent. Since the JCE uses the same architecture as the JCA, the JCE should be more properly thought of as a part of the JCA.

  • The JCA within the JDK includes two software components:

    1. the framework that defines and supports cryptographic services for which providers supply implementations. This framework includes packages such as java.security, javax.crypto, javax.crypto.spec, and javax.crypto.interfaces.
    2. the actual providers such as Sun, SunRsaSign, SunJCE, which contain the actual cryptographic implementations.

    Whenever a specific JCA provider is mentioned, it will be referred to explicitly by the provider's name.

WARNING: The JCA makes it easy to incorporate security features into your application. However, this document does not cover the theory of security/cryptography beyond an elementary introduction to concepts necessary to discuss the APIs. This document also does not cover the strengths/weaknesses of specific algorithms, not does it cover protocol design. Cryptography is an advanced topic and one should consult a solid, preferably recent, reference in order to make best use of these tools.

You should always understand what you are doing and why: DO NOT simply copy random code and expect it to fully solve your usage scenario. Many applications have been deployed that contain significant security or performance problems because the wrong tool or algorithm was selected.

Design Principles

The JCA was designed around these principles:

  • implementation independence and interoperability
  • algorithm independence and extensibility

Implementation independence and algorithm independence are complementary; you can use cryptographic services, such as digital signatures and message digests, without worrying about the implementation details or even the algorithms that form the basis for these concepts. While complete algorithm-independence is not possible, the JCA provides standardized, algorithm-specific APIs. When implementation-independence is not desirable, the JCA lets developers indicate a specific implementation.

Algorithm independence is achieved by defining types of cryptographic "engines" (services), and defining classes that provide the functionality of these cryptographic engines. These classes are called engine classes, and examples are the MessageDigest, Signature, KeyFactory, KeyPairGenerator, and Cipher classes.

Implementation independence is achieved using a "provider"-based architecture. The term Cryptographic Service Provider (CSP) (used interchangeably with "provider" in this document) refers to a package or set of packages that implement one or more cryptographic services, such as digital signature algorithms, message digest algorithms, and key conversion services. A program may simply request a particular type of object (such as a Signature object) implementing a particular service (such as the DSA signature algorithm) and get an implementation from one of the installed providers. If desired, a program may instead request an implementation from a specific provider. Providers may be updated transparently to the application, for example when faster or more secure versions are available.

Implementation interoperability means that various implementations can work with each other, use each other's keys, or verify each other's signatures. This would mean, for example, that for the same algorithms, a key generated by one provider would be usable by another, and a signature generated by one provider would be verifiable by another.

Algorithm extensibility means that new algorithms that fit in one of the supported engine classes can be added easily.

Architecture

Cryptographic Service Providers

java.security.Provider is the base class for all security providers. Each CSP contains an instance of this class which contains the provider's name and lists all of the security services/algorithms it implements. When an instance of a particular algorithm is needed, the JCA framework consults the provider's database, and if a suitable match is found, the instance is created.

Providers contain a package (or a set of packages) that supply concrete implementations for the advertised cryptographic algorithms. Each JDK installation has one or more providers installed and configured by default. Additional providers may be added statically or dynamically (see the Provider and Security classes). Clients may configure their runtime environment to specify the provider preference order. The preference order is the order in which providers are searched for requested services when no specific provider is requested.

To use the JCA, an application simply requests a particular type of object (such as a MessageDigest) and a particular algorithm or service (such as the "MD5" algorithm), and gets an implementation from one of the installed providers. Alternatively, the program can request the objects from a specific provider. Each provider has a name used to refer to it.

    md = MessageDigest.getInstance("MD5");
    md = MessageDigest.getInstance("MD5", "ProviderC");

The following figure illustrates requesting an "MD5" message digest implementation. The figure show three different providers that implement various message digest algorithms ("SHA-1", "MD5", "SHA-256", and "SHA-512"). The providers are ordered by preference from left to right (1-3). In the first illustration, an application requests an MD5 algorithm implementation without specifying a provider name. The providers are searched in preference order and the implementation from the first provider supplying that particular algorithm, ProviderB, is returned. In the second figure, the application requests the MD5 algorithm implementation from a specific provider, ProviderC. This time the implementation from ProviderC is returned, even though a provider with a higher preference order, ProviderB, also supplies an MD5 implementation.

MD5 Message Digest Implementation

Description of Figure MD5 Message Digest Implementation

Cryptographic implementations in the JDK are distributed via several different providers (Sun, SunJSSE, SunJCE, SunRsaSign) primarily for historical reasons, but to a lesser extent by the type of functionality and algorithms they provide. Other Java runtime environments may not necessarily contain these Sun providers, so applications should not request an provider-specific implementation unless it is known that a particular provider will be available.

The JCA offers a set of APIs that allow users to query which providers are installed and what services they support.

This architecture also makes it easy for end-users to add additional providers. Many third party provider implementations are already available. See The Provider Class for more information on how providers are written, installed, and registered.

How Providers Are Actually Implemented

As mentioned earlier, algorithm independence is achieved by defining a generic high-level Application Programming Interface (API) that all applications use to access a service type. Implementation independence is achieved by having all provider implementations conform to well-defined interfaces. Instances of engine classes are thus "backed" by implementation classes which have the same method signatures. Application calls are routed through the engine class and are delivered to the underlying backing implementation. The implementation handles the request and return the proper results.

The application API methods in each engine class are routed to the provider's implementations through classes that implement the corresponding Service Provider Interface (SPI). That is, for each engine class, there is a corresponding abstract SPI class which defines the methods that each cryptographic service provider's algorithm must implement. The name of each SPI class is the same as that of the corresponding engine class, followed by Spi. For example, the Signature engine class provides access to the functionality of a digital signature algorithm. The actual provider implementation is supplied in a subclass of SignatureSpi. Applications call the engine class' API methods, which in turn call the SPI methods in the actual implementation.

Each SPI class is abstract. To supply the implementation of a particular type of service for a specific algorithm, a provider must subclass the corresponding SPI class and provide implementations for all the abstract methods.

For each engine class in the API, implementation instances are requested and instantiated by calling the getInstance() factory method in the engine class. A factory method is a static method that returns an instance of a class. The engine classes use the framework provider selection mechanism described above to obtain the actual backing implementation (SPI), and then creates the actual engine object. Each instance of the engine class encapsulates (as a private field) the instance of the corresponding SPI class, known as the SPI object. All API methods of an API object are declared final and their implementations invoke the corresponding SPI methods of the encapsulated SPI object.

To make this clearer, review the following code and illustration:

    import javax.crypto.*;

    Cipher c = Cipher.getInstance("AES");
    c.init(ENCRYPT_MODE, key);
Example of How Application Retrieves AES Cipher Intstance

Description of Example of How Application Retrieves "AES" Cipher Instance

Here an application wants an "AES" javax.crypto.Cipher instance, and doesn't care which provider is used. The application calls the getInstance() factory methods of the Cipher engine class, which in turn asks the JCA framework to find the first provider instance that supports "AES". The framework consults each installed provider, and obtains the provider's instance of the Provider class. (Recall that the Provider class is a database of available algorithms.) The framework searches each provider, finally finding a suitable entry in CSP3. This database entry points to the implementation class com.foo.AESCipher which extends CipherSpi, and is thus suitable for use by the Cipher engine class. An instance of com.foo.AESCipher is created, and is encapsulated in a newly-created instance of javax.crypto.Cipher, which is returned to the application. When the application now does the init() operation on the Cipher instance, the Cipher engine class routes the request into the corresponding engineInit() backing method in the com.foo.AESCipher class.

Appendix A lists the Standard Names defined for the Java environment. Other third-party providers may define their own implementations of these services, or even additional services.

Key Management

A database called a "keystore" can be used to manage a repository of keys and certificates. Keystores are available to applications that need data for authentication, encryption, or signing purposes.

Applications can access a keystore via an implementation of the KeyStore class, which is in the java.security package. A default KeyStore implementation is provided by Sun Microsystems. It implements the keystore as a file, using a proprietary keystore type (format) named "jks". Other keystore formats are available, such as "jceks" which is an alternate proprietary keystore format with much stronger encryption than "jks", and "pkcs12", which is based on the RSA PKCS12 Personal Information Exchange Syntax Standard.

Applications can choose different keystore implementations from different providers, using the same provider mechanism described above.

See the Key Management section for more information.

JCA Concepts

This section introduces the major JCA APIs.

Engine Classes and Algorithms

An engine class provides the interface to a specific type of cryptographic service, independent of a particular cryptographic algorithm or provider. The engines either provide:

  • cryptographic operations (encryption, digital signatures, message digests, etc.),
  • generators or converters of cryptographic material (keys and algorithm parameters), or
  • objects (keystores or certificates) that encapsulate the cryptographic data and can be used at higher layers of abstraction.

The following engine classes are available:

  • SecureRandom: used to generate random or pseudo-random numbers.
  • MessageDigest: used to calculate the message digest (hash) of specified data.
  • Signature: initialized with keys, these are used to sign data and verify digital signatures.
  • Cipher: initialized with keys, these used for encrypting/decrypting data. There are various types of algorithms: symmetric bulk encryption (e.g. AES, DES, DESede, Blowfish, IDEA), stream encryption (e.g. RC4), asymmetric encryption (e.g. RSA), and password-based encryption (PBE).
  • Message Authentication Codes (MAC): like MessageDigests, these also generate hash values, but are first initialized with keys to protect the integrity of messages.
  • KeyFactory: used to convert existing opaque cryptographic keys of type Key into key specifications (transparent representations of the underlying key material), and vice versa.
  • SecretKeyFactory: used to convert existing opaque cryptographic keys of type SecretKey into key specifications (transparent representations of the underlying key material), and vice versa. SecretKeyFactorys are specialized KeyFactorys that create secret (symmetric) keys only.
  • KeyPairGenerator: used to generate a new pair of public and private keys suitable for use with a specified algorithm.
  • KeyGenerator: used to generate new secret keys for use with a specified algorithm.
  • KeyAgreement: used by two or more parties to agree upon and establish a specific key to use for a particular cryptographic operation.
  • AlgorithmParameters: used to store the parameters for a particular algorithm, including parameter encoding and decoding.
  • AlgorithmParameterGenerator : used to generate a set of AlgorithmParameters suitable for a specified algorithm.
  • KeyStore: used to create and manage a keystore. A keystore is a database of keys. Private keys in a keystore have a certificate chain associated with them, which authenticates the corresponding public key. A keystore also contains certificates from trusted entities.
  • CertificateFactory: used to create public key certificates and Certificate Revocation Lists (CRLs).
  • CertPathBuilder: used to build certificate chains (also known as certification paths).
  • CertPathValidator: used to validate certificate chains.
  • CertStore: used to retrieve Certificates and CRLs from a repository.

NOTE: A generator creates objects with brand-new contents, whereas a factory creates objects from existing material (for example, an encoding).

Core Classes and Interfaces

This section discusses the core classes and interfaces provided in the JCA:

  • the Provider and Security classes,
  • the SecureRandom, MessageDigest, Signature, Cipher, Mac, KeyFactory, SecretKeyFactory, KeyPairGenerator, KeyGenerator, KeyAgreement, AlgorithmParameters, AlgorithmParameterGenerator , KeyStore, and CertificateFactory, engine classes,
  • the Key interfaces and classes,
  • the Algorithm Parameter Specification Interfaces and Classes and the Key Specification Interfaces and Classes, and
  • miscellaneous support and convenience interfaces and classes.

NOTE: For more information on the CertPathBuilder, CertPathValidator, and CertStore engine classes, please see the Java PKI Programmer's Guide.

The guide will cover the most useful high-level classes first (Provider, Security, SecureRandom, MessageDigest, Signature, Cipher, and Mac), then delve into the various support classes. For now, it is sufficient to simply say that Keys (public, private, and secret) are generated and represented by the various JCA classes, and are used by the high-level classes as part of their operation.

This section shows the signatures of the main methods in each class and interface. Examples for some of these classes (MessageDigest, Signature, KeyPairGenerator, SecureRandom, KeyFactory, and key specification classes) are supplied in the corresponding Examples sections.

The complete reference documentation for the relevant Security API packages can be found in the package summaries:

  • java.security
  • javax.crypto
  • java.security.cert
  • java.security.spec
  • javax.crypto.spec
  • java.security.interfaces
  • javax.crypto.interfaces

The Provider Class

The term "Cryptographic Service Provider" (used interchangeably with "provider" in this document) refers to a package or set of packages that supply a concrete implementation of a subset of the JDK Security API cryptography features. The Provider class is the interface to such a package or set of packages. It has methods for accessing the provider name, version number, and other information. Please note that in addition to registering implementations of cryptographic services, the Provider class can also be used to register implementations of other security services that might get defined as part of the JDK Security API or one of its extensions.

To supply implementations of cryptographic services, an entity (e.g., a development group) writes the implementation code and creates a subclass of the Provider class. The constructor of the Provider subclass sets the values of various properties; the JDK Security API uses these values to look up the services that the provider implements. In other words, the subclass specifies the names of the classes implementing the services.

Example of Provider Subclass

Description of Figure Example of Provider Subclass

There are several types of services that can be implemented by provider packages; for more information, see Engine Classes and Algorithms.

The different implementations may have different characteristics. Some may be software-based, while others may be hardware-based. Some may be platform-independent, while others may be platform-specific. Some provider source code may be available for review and evaluation, while some may not. The JCA lets both end-users and developers decide what their needs are.

In this section we explain how end-users install the cryptography implementations that fit their needs, and how developers request the implementations that fit theirs.

NOTE: For information about implementing a provider, see the guide How To Implement a Provider for the Java Cryptography Architecture.

How Provider Implementations Are Requested and Supplied

For each engine class in the API, a implementation instance is requested and instantiated by calling one of the getInstance methods on the engine class, specifying the name of the desired algorithm and, optionally, the name of the provider (or the Provider class) whose implementation is desired.

static EngineClassName getInstance(String algorithm)
    throws NoSuchAlgorithmException

static EngineClassName getInstance(String algorithm, String provider)
    throws NoSuchAlgorithmException, NoSuchProviderException

static EngineClassName getInstance(String algorithm, Provider provider)
    throws NoSuchAlgorithmException
where EngineClassName is the desired engine type (MessageDigest/Cipher/etc). For example:
    MessageDigest md = MessageDigest.getInstance("MD5");
    KeyAgreement ka = KeyAgreement.getInstance("DH", "SunJCE");
return an instance of the "MD5" MessageDigest and "DH" KeyAgreement objects, respectively.

Appendix A contains the list of names that have been standardized for use with the Java environment. Some providers may choose to also include alias names that also refer to the same algorithm. For example, the "SHA-1" algorithm might be referred to as "SHA1". Applications should use standard names instead of an alias, as not all providers may alias algorithm names in the same way.

NOTE: The algorithm name is not case-sensitive. For example, all the following calls are equivalent:

MessageDigest.getInstance("SHA-1")
MessageDigest.getInstance("sha-1")
MessageDigest.getInstance("sHa-1")

If no provider is specified, getInstance searches the registered providers for an implementation of the requested cryptographic service associated with the named algorithm. In any given Java Virtual Machine (JVM), providers are installed in a given preference order, the order in which the provider list is searched if a specific provider is not requested. For example, suppose there are two providers installed in a JVM, PROVIDER_1 and PROVIDER_2. Assume that:

  • PROVIDER_1 implements SHA1withDSA, SHA-1, MD5, DES, and DES3.
    PROVIDER_1 has preference order 1 (the highest priority).
  • PROVIDER_2 implements SHA1withDSA, MD5withRSA, MD2withRSA, MD2, MD5, RC4, RC5, DES, and RSA.
    PROVIDER_2 has preference order 2.
Now let's look at three scenarios:
  1. If we are looking for an MD5 implementation. Both providers supply such an implementation. The PROVIDER_1 implementation is returned since PROVIDER_1 has the highest priority and is searched first.
  2. If we are looking for an MD5withRSA signature algorithm, PROVIDER_1 is first searched for it. No implementation is found, so PROVIDER_2 is searched. Since an implementation is found, it is returned.
  3. Suppose we are looking for a SHA1withRSA signature algorithm. Since no installed provider implements it, a NoSuchAlgorithmException is thrown.

The getInstance methods that include a provider argument are for developers who want to specify which provider they want an algorithm from. A federal agency, for example, will want to use a provider implementation that has received federal certification. Let's assume that the SHA1withDSA implementation from PROVIDER_1 has not received such certification, while the DSA implementation of PROVIDER_2 has received it.

A federal agency program would then have the following call, specifying PROVIDER_2 since it has the certified implementation:

Signature dsa = Signature.getInstance("SHA1withDSA", "PROVIDER_2");

In this case, if PROVIDER_2 was not installed, a NoSuchProviderException would be thrown, even if another installed provider implements the algorithm requested.

A program also has the option of getting a list of all the installed providers (using the getProviders method in the Security class) and choosing one from the list.

NOTE: General purpose applications SHOULD NOT request cryptographic services from specific providers. Otherwise, applications are tied to specific providers which may not be available on other Java implementations. They also might not be able to take advantage of available optimized providers (for example hardware accelerators via PKCS11 or native OS implementations such as Microsoft's MSCAPI) that have a higher preference order than the specific requested provider.

Installing Providers

In order to be used, a cryptographic provider must first be installed, then registered either statically or dynamically. There are a variety of Sun providers shipped with this release (SUN, SunJCE, SunJSSE, SunRsaSign, etc.) that are already installed and registered. The following sections describe how to install and register additional providers.

Installing the Provider Classes

There are two possible ways to install the provider classes:

  1. On the normal Java classpath

    Place a zip or JAR file containing the classes anywhere in your classpath. Some algorithms types (Ciphers) require the provider be a signed Jar file.

  2. As an Installed/Bundled Extension

    The provider will be considered an installed extension if it is placed in the standard extension directory. In the JDK, that would be located in:

    • Solaris, Linux, or Mac OS X: <java-home>/lib/ext
    • Windows: <java-home>\lib\ext

    Here <java-home> refers to the directory where the runtime software is installed, which is the top-level directory of the Java Runtime Environment (JRE) or the jre directory in the Java JDK software. For example, if you have JDK 6 installed on Solaris in a directory named /home/user1/JDK1.6.0, or on Microsoft Windows in a directory named C:\Java\JDK1.6.0, then you need to install the JAR file in the following directory:

    • Solaris, Linux, or Mac OS X: /home/user1/JDK1.6.0/jre/lib/ext
    • Windows: C:\JDK1.6.0\jre\lib\ext

    Similarly, if you have the JRE 6 installed on Solaris in a directory named /home/user1/jre1.6.0, or on Microsoft Windows in a directory named C:\jre1.6.0, you need to install the JAR file in the following directory:

    • Solaris, Linux, or Mac OS X: /home/user1/jre1.6.0/lib/ext
    • Windows: C:\jre1.6.0\lib\ext
    For more information on how to deploy an extension, see How is an extension deployed?

Registering the Provider

The next step is to add the provider to your list of registered providers. Providers can be registered statically by editing a security properties configuration file before running a Java application, or dynamically by calling a method at runtime. To prevent the installation of rogue providers being added to the runtime environment, applications attempting to dynamically register a provider must possess the appropriate runtime privilege.

Static Registration

The configuration file is located in the following location:

  • Solaris, Linux, or Mac OS X: <java-home>/lib/security/java.security
  • Windows: <java-home>\lib\security\java.security

For each registered provider, this file should have a statement of the following form:

    security.provider.n=masterClassName

This declares a provider, and specifies its preference order n. The preference order is the order in which providers are searched for requested algorithms (when no specific provider is requested). The order is 1-based: 1 is the most preferred, followed by 2, and so on.

masterClassName must specify the fully qualified name of provider's master class. The provider's documentation will specify its master class. This class is always a subclass of the Provider class. The subclass constructor sets the values of various properties that are required for the Java Cryptography API to look up the algorithms or other facilities the provider implements.

The JDK comes standard with automatically installed and configured providers such as "SUN" and "SunJCE". The "SUN" provider's master class is the SUN class in the sun.security.provider package, and the corresponding java.security file entry is as follows:

    security.provider.5=sun.security.provider.Sun

To utilize another JCA provider, add a line referencing the alternate provider, specify the preference order ( making corresponding adjustments to the other providers' orders, if needed).

Suppose that the master class of CompanyX's provider is com.companyx.provider.ProviderX, and that you would like to configure this provider as the eighth most-preferred. To do so, you would add the following line to the java.security file:

    security.provider.8=com.companyx.provider.ProviderX
Dynamic Registration
To register providers dynamically, applications call either the addProvider or insertProviderAt method in the Security class. This type of registration is not persistent across VM instances, and can only be done by "trusted" programs with the appropriate privilege. See Security.

Setting Provider Permissions

Whenever encryption providers are used (that is, those that supply implementations of Cipher, KeyAgreement, KeyGenerator, Mac, or SecretKeyFactory), and the provider is not an installed extension Permissions may need to be granted for when applets or applications using JCA are run while a security manager is installed. There is typically a security manager installed whenever an applet is running, and a security manager may be installed for an application either via code in the application itself or via a command-line argument. Permissions do not need to be granted to installed extensions, since the default system policy configuration file grants all permissions to installed extensions (that is, installed in the extensions directory).

The documentation from the vendor of each provider you will be using should include information as to which permissions it requires, and how to grant such permissions. For example, the following permissions may be needed by a provider if it is not an installed extension and a security manager is installed:

  • java.lang.RuntimePermission "getProtectionDomain" to get class protection domains. The provider may need to get its own protection domain in the process of doing self-integrity checking.
  • java.security.SecurityPermission "putProviderProperty.{name}" to set provider properties, where {name} is replaced by the actual provider name.

For example, a sample statement granting permissions to a provider whose name is "MyJCE" and whose code is in myjce_provider.jar appears below. Such a statement could appear in a policy file. In this example, the myjce_provider.jar file is assumed to be in the /localWork directory.

    grant codeBase "file:/localWork/myjce_provider.jar" {
        permission java.lang.RuntimePermission "getProtectionDomain";
        permission java.security.SecurityPermission
            "putProviderProperty.MyJCE";
     };

Provider Class Methods

Each Provider class instance has a (currently case-sensitive) name, a version number, and a string description of the provider and its services. You can query the Provider instance for this information by calling the following methods:

public String getName()
public double getVersion()
public String getInfo()

The Security Class

The Security class manages installed providers and security-wide properties. It only contains static methods and is never instantiated. The methods for adding or removing providers, and for setting Security properties, can only be executed by a trusted program. Currently, a "trusted program" is either

  • a local application not running under a security manager, or
  • an applet or application with permission to execute the specified method (see below).
The determination that code is considered trusted to perform an attempted action (such as adding a provider) requires that the applet is granted the proper permission(s) for that particular action. The policy configuration file(s) for a JDK installation specify what permissions (which types of system resource accesses) are allowed by code from specified code sources. (See below and the "Default Policy Implementation and Policy File Syntax" and "Java Security Architecture Specification" files for more information.)

Code being executed is always considered to come from a particular "code source". The code source includes not only the location (URL) where the code originated from, but also a reference to any public key(s) corresponding to the private key(s) that may have been used to sign the code. Public keys in a code source are referenced by (symbolic) alias names from the user's keystore.

In a policy configuration file, a code source is represented by two components: a code base (URL), and an alias name (preceded by signedBy), where the alias name identifies the keystore entry containing the public key that must be used to verify the code's signature.

Each "grant" statement in such a file grants a specified code source a set of permissions, specifying which actions are allowed.

Here is a sample policy configuration file:

grant codeBase "file:/home/sysadmin/", signedBy "sysadmin" {
    permission java.security.SecurityPermission "insertProvider.*";
    permission java.security.SecurityPermission "removeProvider.*";
    permission java.security.SecurityPermission "putProviderProperty.*";
};
This configuration file specifies that code loaded from a signed JAR file from beneath the /home/sysadmin/ directory on the local file system can add or remove providers or set provider properties. (Note that the signature of the JAR file can be verified using the public key referenced by the alias name sysadmin in the user's keystore.)

Either component of the code source (or both) may be missing. Here's an example of a configuration file where the codeBase is omitted:

grant signedBy "sysadmin" {
    permission java.security.SecurityPermission "insertProvider.*";
    permission java.security.SecurityPermission "removeProvider.*";
};
If this policy is in effect, code that comes in a JAR File signed by sysadmin can add/remove providers--regardless of where the JAR File originated.

Here's an example without a signer:

grant codeBase "file:/home/sysadmin/" {
    permission java.security.SecurityPermission "insertProvider.*";
    permission java.security.SecurityPermission "removeProvider.*";
};
In this case, code that comes from anywhere within the /home/sysadmin/ directory on the local filesystem can add/remove providers. The code does not need to be signed.

An example where neither codeBase nor signedBy is included is:

grant {
    permission java.security.SecurityPermission "insertProvider.*";
    permission java.security.SecurityPermission "removeProvider.*";
};
Here, with both code source components missing, any code (regardless of where it originates, or whether or not it is signed, or who signed it) can add/remove providers. Obviously, this is definitely NOT recommended, as this grant could open a security hole. Untrusted code could install a Provider, thus affecting later code that is depending on a properly functioning implementation. (For example, a rogue Cipher object might capture and store the sensitive information it receives.)

Managing Providers

The following tables summarize the methods in the Security class you can use to query which Providers are installed, as well as to install or remove providers at runtime.

Querying Providers
Method | Description
static Provider[] getProviders() | Returns an array containing all the installed providers (technically, the Provider subclass for each package provider). The order of the Providers in the array is their preference order.
static Provider getProvider
(String providerName) 		Returns the Provider named providerName. It returns null if the Provider is not found.

Adding Providers
Method | Description
static int addProvider(Provider provider) | Adds a Provider to the end of the list of installed Providers. It returns the preference position in which the Provider was added, or -1 if the Provider was not added because it was already installed.
static int insertProviderAt (Provider provider, int position) | Adds a new Provider at a specified position. If the given provider is installed at the requested position, the provider formerly at that position and all providers with a position greater than position are shifted up one position (towards the end of the list). This method returns the preference position in which the Provider was added, or -1 if the Provider was not added because it was already installed.

Removing Providers
Method | Description
static void removeProvider(String name) | Removes the Provider with the specified name. It returns silently if the provider is not installed. When the specified provider is removed, all providers located at a position greater than where the specified provider was are shifted down one position (towards the head of the list of installed providers).

NOTE: If you want to change the preference position of a provider, you must first remove it, and then insert it back in at the new preference position.

Security Properties

The Security class maintains a list of system-wide security properties. These properties are similar to the System properties, but are security-related. These properties can be set statically or dynamically. We have already seen an example of static security properties (that is, registering a provider statically via the "security.provider.i" security property). If you want to set properties dynamically, trusted programs can use the following methods:

static String getProperty(String key)
static void setProperty(String key, String datum)
Note: the list of security providers is established during VM startup, therefore the methods described above must be used to alter the provider list.

As a reminder, the configuration file is located in the following location:

  • Solaris, Linux, or Mac OS X: <java-home>/lib/security/java.security
  • Windows: <java-home>\lib\security\java.security

The SecureRandom Class

The SecureRandom class is an engine class that provides the functionality of a Random Number Generator (RNG). It differs from the java.lang.Random class in that it produces cryptographically strong random numbers. If there is insufficient randomness in a generator, it makes it much easier to compromise your protection mechanisms. Random numbers are used throughout cryptography, such as generating cryptographic keys, algorithmic parameters, and so on.

All Java SE implementations must indicate the strongest (most random) implementation of SecureRandom that they provide in the securerandom.strongAlgorithms property of the java.security.Security class. This implementation can be used when a particularly strong random value is required.

The SecureRandom Class

Description of The SecureRandom Class

Creating a SecureRandom Object

There are several ways to obtain an instance of SecureRandom:

  • All Java SE implementations provide a default SecureRandom using the no-argument constructor: new SecureRandom().

  • To get a specific implementation of SecureRandom, use one of the getInstance() static factory methods.

  • Use the getInstanceStrong() method to obtain a strong SecureRandom implementation as defined by the securerandom.strongAlgorithms property of the java.security.Security class. This property lists platform implementations that are suitable for generating important values.

Seeding or Re-Seeding the SecureRandom Object

The SecureRandom implementation attempts to completely randomize the internal state of the generator itself unless the caller follows the call to a getInstance method with a call to one of the setSeed methods:

synchronized public void setSeed(byte[] seed)
public void setSeed(long seed)

Once the SecureRandom object has been seeded, it will produce bits as random as the original seeds.

At any time a SecureRandom object may be re-seeded using one of the setSeed methods. The given seed supplements, rather than replaces, the existing seed; therefore, repeated calls are guaranteed never to reduce randomness.

Using a SecureRandom Object

To get random bytes, a caller simply passes an array of any length, which is then filled with random bytes:

synchronized public void nextBytes(byte[] bytes)

Generating Seed Bytes

If desired, it is possible to invoke the generateSeed method to generate a given number of seed bytes (to seed other random number generators, for example):

byte[] generateSeed(int numBytes)

The MessageDigest Class

The MessageDigest class is an engine class designed to provide the functionality of cryptographically secure message digests such as SHA-1 or MD5. A cryptographically secure message digest takes arbitrary-sized input (a byte array), and generates a fixed-size output, called a digest or hash.

The MessageDigest Class

Description of Figure The MessageDigest Class

For example, the MD5 algorithm produces a 16 byte digest, and SHA1's is 20 bytes.

A digest has two properties:

  • It should be computationally infeasible to find two messages that hash to the same value.
  • The digest should not reveal anything about the input that was used to generate it.

Message digests are used to produce unique and reliable identifiers of data. They are sometimes called "checksums" or the "digital fingerprints" of the data. Changes to just one bit of the message should produce a different digest value.

Message digests have many uses and can determine when data has been modified, intentionally or not. Recently, there has been considerable effort to determine if there are any weaknesses in popular algorithms, with mixed results. When selecting a digest algorithm, one should always consult a recent reference to determine its status and appropriateness for the task at hand.

Creating a MessageDigest Object

The first step for computing a digest is to create a message digest instance. MessageDigest objects are obtained by using one of the getInstance() static factory methods in the MessageDigest class. The factory method returns an initialized message digest object. It thus does not need further initialization.

Updating a Message Digest Object

The next step for calculating the digest of some data is to supply the data to the initialized message digest object. It can be provided all at once, or in chunks. Pieces can be fed to the message digest by calling one of the update methods:

void update(byte input)
void update(byte[] input)
void update(byte[] input, int offset, int len)

Computing the Digest

After the data chunks have been supplied by calls to update, the digest is computed using a call to one of the digest methods:

byte[] digest()
byte[] digest(byte[] input)
int digest(byte[] buf, int offset, int len)

The first method return the computed digest. The second method does a final update(input) with the input byte array before calling digest(), which returns the digest byte array. The last method stores the computed digest in the provided buffer buf, starting at offset. len is the number of bytes in buf allotted for the digest, the method returns the number of bytes actually stored in buf. If there is not enough room in the buffer, the method will throw an exception.

Please see the Computing a MessageDigest example in the Code Examples section for more details.

The Signature Class

The Signature class is an engine class designed to provide the functionality of a cryptographic digital signature algorithm such as DSA or RSAwithMD5. A cryptographically secure signature algorithm takes arbitrary-sized input and a private key and generates a relatively short (often fixed-size) string of bytes, called the signature, with the following properties:

  • Only the owner of a private/public key pair is able to create a signature. It should be computationally infeasible for anyone having a public key to recover the private key.
  • Given the public key corresponding to the private key used to generate the signature, it should be possible to verify the authenticity and integrity of the input.
  • The signature and the public key do not reveal anything about the private key.

It can also be used to verify whether or not an alleged signature is in fact the authentic signature of the data associated with it.

The Signature Class

Description of Figure The Signature Class

A Signature object is initialized for signing with a Private Key and is given the data to be signed. The resulting signature bytes are typically kept with the signed data. When verification is needed, another Signature object is created and initialized for verification and given the corresponding Public Key. The data and the signature bytes are fed to the signature object, and if the data and signature match, the Signature object reports success.

Even though a signature seems similar to a message digest, they have very different purposes in the type of protection they provide. In fact, algorithms such as "SHA1WithRSA" use the message digest "SHA1" to initially "compress" the large data sets into a more manageable form, then sign the resulting 20 byte message digest with the "RSA" algorithm.

Please see the Examples section for an example of signing and verifying data.

Signature Object States

Signature objects are modal objects. This means that a Signature object is always in a given state, where it may only do one type of operation. States are represented as final integer constants defined in their respective classes.

The three states a Signature object may have are:

  • UNINITIALIZED
  • SIGN
  • VERIFY
When it is first created, a Signature object is in the UNINITIALIZED state. The Signature class defines two initialization methods, initSign and initVerify, which change the state to SIGN and VERIFY, respectively.

Creating a Signature Object

The first step for signing or verifying a signature is to create a Signature instance. Signature objects are obtained by using one of the Signature getInstance() static factory methods.

Initializing a Signature Object

A Signature object must be initialized before it is used. The initialization method depends on whether the object is going to be used for signing or for verification.

If it is going to be used for signing, the object must first be initialized with the private key of the entity whose signature is going to be generated. This initialization is done by calling the method:

final void initSign(PrivateKey privateKey)
This method puts the Signature object in the SIGN state.

If instead the Signature object is going to be used for verification, it must first be initialized with the public key of the entity whose signature is going to be verified. This initialization is done by calling either of these methods:

    final void initVerify(PublicKey publicKey)

    final void initVerify(Certificate certificate)

This method puts the Signature object in the VERIFY state.

Signing

If the Signature object has been initialized for signing (if it is in the SIGN state), the data to be signed can then be supplied to the object. This is done by making one or more calls to one of the update methods:

final void update(byte b)
final void update(byte[] data)
final void update(byte[] data, int off, int len)

Calls to the update method(s) should be made until all the data to be signed has been supplied to the Signature object.

To generate the signature, simply call one of the sign methods:

final byte[] sign()
final int sign(byte[] outbuf, int offset, int len)

The first method returns the signature result in a byte array. The second stores the signature result in the provided buffer outbuf, starting at offset. len is the number of bytes in outbuf allotted for the signature. The method returns the number of bytes actually stored.

Signature encoding is algorithm specific. See the Standard Names document for more information about the use of ASN.1 encoding in the Java Cryptography Architecture.

A call to a sign method resets the signature object to the state it was in when previously initialized for signing via a call to initSign. That is, the object is reset and available to generate another signature with the same private key, if desired, via new calls to update and sign.

Alternatively, a new call can be made to initSign specifying a different private key, or to initVerify (to initialize the Signature object to verify a signature).

Verifying

If the Signature object has been initialized for verification (if it is in the VERIFY state), it can then verify if an alleged signature is in fact the authentic signature of the data associated with it. To start the process, the data to be verified (as opposed to the signature itself) is supplied to the object. The data is passed to the object by calling one of the update methods:

final void update(byte b)
final void update(byte[] data)
final void update(byte[] data, int off, int len)

Calls to the update method(s) should be made until all the data to be verified has been supplied to the Signature object. The signature can now be verified by calling one of the verify methods:

final boolean verify(byte[] signature)

final boolean verify(byte[] signature, int offset, int length)

The argument must be a byte array containing the signature. This byte array would hold the signature bytes which were returned by a previous call to one of the sign methods.

The verify method returns a boolean indicating whether or not the encoded signature is the authentic signature of the data supplied to the update method(s).

A call to the verify method resets the signature object to its state when it was initialized for verification via a call to initVerify. That is, the object is reset and available to verify another signature from the identity whose public key was specified in the call to initVerify.

Alternatively, a new call can be made to initVerify specifying a different public key (to initialize the Signature object for verifying a signature from a different entity), or to initSign (to initialize the Signature object for generating a signature).

The Cipher Class

The Cipher class provides the functionality of a cryptographic cipher used for encryption and decryption. Encryption is the process of taking data (called cleartext) and a key, and producing data (ciphertext) meaningless to a third-party who does not know the key. Decryption is the inverse process: that of taking ciphertext and a key and producing cleartext.

The Cipher Class

Description of Figure The Cipher Class

Symmetric vs. Asymmetric Cryptography

There are two major types of encryption: symmetric (also known as secret key), and asymmetric (or public key cryptography). In symmetric cryptography, the same secret key to both encrypt and decrypt the data. Keeping the key private is critical to keeping the data confidential. On the other hand, asymmetric cryptography uses a public/private key pair to encrypt data. Data encrypted with one key is decrypted with the other. A user first generates a public/private key pair, and then publishes the public key in a trusted database that anyone can access. A user who wishes to communicate securely with that user encrypts the data using the retrieved public key. Only the holder of the private key will be able to decrypt. Keeping the private key confidential is critical to this scheme.

Asymmetric algorithms (such as RSA) are generally much slower than symmetric ones. These algorithms are not designed for efficiently protecting large amounts of data. In practice, asymmetric algorithms are used to exchange smaller secret keys which are used to initialize symmetric algorithms.

Stream vs. Block Ciphers

There are two major types of ciphers: block and stream. Block ciphers process entire blocks at a time, usually many bytes in length. If there is not enough data to make a complete input block, the data must be padded: that is, before encryption, dummy bytes must be added to make a multiple of the cipher's block size. These bytes are then stripped off during the decryption phase. The padding can either be done by the application, or by initializing a cipher to use a padding type such as "PKCS5PADDING". In contrast, stream ciphers process incoming data one small unit (typically a byte or even a bit) at a time. This allows for ciphers to process an arbitrary amount of data without padding.

Modes Of Operation

When encrypting using a simple block cipher, two identical blocks of plaintext will always produce an identical block of cipher text. Cryptanalysts trying to break the ciphertext will have an easier job if they note blocks of repeating text. In order to add more complexity to the text, feedback modes use the previous block of output to alter the input blocks before applying the encryption algorithm. The first block will need an initial value, and this value is called the initialization vector (IV). Since the IV simply alters the data before any encryption, the IV should be random but does not necessarily need to be kept secret. There are a variety of modes, such as CBC (Cipher Block Chaining), CFB (Cipher Feedback Mode), and OFB (Output Feedback Mode). ECB (Electronic Cookbook Mode) is a mode with no feedback.

Some algorithms such as AES and RSA allow for keys of different lengths, but others are fixed, such as DES and 3DES. Encryption using a longer key generally implies a stronger resistance to message recovery. As usual, there is a trade off between security and time, so choose the key length appropriately.

Most algorithms use binary keys. Most humans do not have the ability to remember long sequences of binary numbers, even when represented in hexadecimal. Character passwords are much easier to recall. Because character passwords are generally chosen from a small number of characters (for example, [a-zA-Z0-9]), protocols such as "Password-Based Encryption" (PBE) have been defined which take character passwords and generate strong binary keys. In order to make the task of getting from password to key very time-consuming for an attacker (via so-called "dictionary attacks" where common dictionary word->value mappings are precomputed), most PBE implementations will mix in a random number, known as a salt, to increase the key randomness.

Newer cipher modes such as Authenticated Encryption with Associated Data (AEAD) (for example, Galois/Counter Mode (GCM)) encrypt data and authenticate the resulting message simultaneously. Additional Associated Data (AAD) can be used during the calculation of the resulting AEAD tag (Mac), but this AAD data is not output as ciphertext. (For example, some data might not need to be kept confidential, but should figure into the tag calculation to detect modifications.) The Cipher.updateAAD() methods can be used to include AAD in the tag calculations.

Using an AES Cipher with GCM Mode

AES Cipher with GCM is an AEAD Cipher which has different usage patterns than the non-AEAD ciphers. Apart from the regular data, it also takes AAD which is optional for encryption/decryption but AAD must be supplied before data for encryption/decryption. In addition, in order to use GCM securely, callers should not re-use key and IV combinations for encryption. This means that the cipher object should be explicitly re-initialized with a different set of parameters every time for each encryption operation.

    SecretKey myKey = ...
    byte[] myAAD = ...
    byte[] plainText = ...
        int myTLen = ...
        byte[] myIv = ...

    GCMParameterSpec myParams = new GCMParameterSpec(myTLen, myIv);
    Cipher c = Cipher.getInstance("AES/GCM/NoPadding");
    c.init(Cipher.ENCRYPT_MODE, myKey, myParams);

    // AAD is optional, if present, it must be supplied before any update/doFinal calls.
    c.updateAAD(myAAD);  // if AAD is non-null
    byte[] cipherText = new byte[c.getOutputSize(plainText.length)];
    c.doFinal(plainText, 0, plainText.length, cipherText);    // conclusion of encryption operation

    // To decrypt, same AAD and GCM parameters must be supplied
    c.init(Cipher.DECRYPT_MODE, myKey, myParams);
    c.updateAAD(myAAD);
    byte[] recoveredText = c.doFinal(cipherText);

    // MUST CHANGE IV VALUE if the same key were to be used again for encryption
         byte[] newIv = ...;
    myParams = new GCMParameterSpec(myTLen, newIv);

Creating a Cipher Object

Cipher objects are obtained by using one of the Cipher getInstance() static factory methods. Here, the algorithm name is slightly different than with other engine classes, in that it specifies not just an algorithm name, but a "transformation". A transformation is a string that describes the operation (or set of operations) to be performed on the given input to produce some output. A transformation always includes the name of a cryptographic algorithm (e.g., DES), and may be followed by a mode and padding scheme.

A transformation is of the form:

  • "algorithm/mode/padding" or
  • "algorithm"

For example, the following are valid transformations:

    "DES/CBC/PKCS5Padding"

    "DES"

If just a transformation name is specified, the system will determine if there is an implementation of the requested transformation available in the environment, and if there is more than one, returns there is a preferred one.

If both a transformation name and a package provider are specified, the system will determine if there is an implementation of the requested transformation in the package requested, and throw an exception if there is not.

It is recommended to use a transformation that fully specifies the algorithm, mode, and padding. By not doing so, the provider will use a default. For example, the SunJCE and SunPKCS11 providers use ECB as the default mode, and PKCS5Padding as the default padding for many symmetric ciphers.

This means that in the case of the SunJCE provider:

    Cipher c1 = Cipher.getInstance("DES/ECB/PKCS5Padding");
and
    Cipher c1 = Cipher.getInstance("DES");

are equivalent statements.

Note: ECB mode is the easiest block cipher mode to use and is the default in the JDK/JRE. ECB works well for single blocks of data, but absolutely should not be used for multiple data blocks.

Using modes such as CFB and OFB, block ciphers can encrypt data in units smaller than the cipher's actual block size. When requesting such a mode, you may optionally specify the number of bits to be processed at a time by appending this number to the mode name as shown in the "DES/CFB8/NoPadding" and "DES/OFB32/PKCS5Padding" transformations. If no such number is specified, a provider-specific default is used. (For example, the SunJCE provider uses a default of 64 bits for DES.) Thus, block ciphers can be turned into byte-oriented stream ciphers by using an 8 bit mode such as CFB8 or OFB8.

Appendix A of this document contains a list of standard names that can be used to specify the algorithm name, mode, and padding scheme components of a transformation.

The objects returned by factory methods are uninitialized, and must be initialized before they become usable.

Initializing a Cipher Object

A Cipher object obtained via getInstance must be initialized for one of four modes, which are defined as final integer constants in the Cipher class. The modes can be referenced by their symbolic names, which are shown below along with a description of the purpose of each mode:

ENCRYPT_MODE
Encryption of data.
DECRYPT_MODE
Decryption of data.
WRAP_MODE
Wrapping a java.security.Key into bytes so that the key can be securely transported.
UNWRAP_MODE
Unwrapping of a previously wrapped key into a java.security.Key object.

Each of the Cipher initialization methods takes an operational mode parameter (opmode), and initializes the Cipher object for that mode. Other parameters include the key (key) or certificate containing the key (certificate), algorithm parameters (params), and a source of randomness (random).

To initialize a Cipher object, call one of the following init methods:

    public void init(int opmode, Key key);

    public void init(int opmode, Certificate certificate);

    public void init(int opmode, Key key, SecureRandom random);

    public void init(int opmode, Certificate certificate,
                     SecureRandom random);

    public void init(int opmode, Key key,
                     AlgorithmParameterSpec params);

    public void init(int opmode, Key key,
                     AlgorithmParameterSpec params, SecureRandom random);

    public void init(int opmode, Key key,
                     AlgorithmParameters params);

    public void init(int opmode, Key key,
                     AlgorithmParameters params, SecureRandom random);

If a Cipher object that requires parameters (e.g., an initialization vector) is initialized for encryption, and no parameters are supplied to the init method, the underlying cipher implementation is supposed to supply the required parameters itself, either by generating random parameters or by using a default, provider-specific set of parameters.

However, if a Cipher object that requires parameters is initialized for decryption, and no parameters are supplied to the init method, an InvalidKeyException or InvalidAlgorithmParameterException exception will be raised, depending on the init method that has been used.

See the section about Managing Algorithm Parameters for more details.

The same parameters that were used for encryption must be used for decryption.

Note that when a Cipher object is initialized, it loses all previously-acquired state. In other words, initializing a Cipher is equivalent to creating a new instance of that Cipher, and initializing it. For example, if a Cipher is first initialized for decryption with a given key, and then initialized for encryption, it will lose any state acquired while in decryption mode.

Encrypting and Decrypting Data

Data can be encrypted or decrypted in one step (single-part operation) or in multiple steps (multiple-part operation). A multiple-part operation is useful if you do not know in advance how long the data is going to be, or if the data is too long to be stored in memory all at once.

To encrypt or decrypt data in a single step, call one of the doFinal methods:

    public byte[] doFinal(byte[] input);

    public byte[] doFinal(byte[] input, int inputOffset, int inputLen);

    public int doFinal(byte[] input, int inputOffset,
                       int inputLen, byte[] output);

    public int doFinal(byte[] input, int inputOffset,
                       int inputLen, byte[] output, int outputOffset)

To encrypt or decrypt data in multiple steps, call one of the update methods:

    public byte[] update(byte[] input);

    public byte[] update(byte[] input, int inputOffset, int inputLen);

    public int update(byte[] input, int inputOffset, int inputLen,
                      byte[] output);

    public int update(byte[] input, int inputOffset, int inputLen,
                      byte[] output, int outputOffset)

A multiple-part operation must be terminated by one of the above doFinal methods (if there is still some input data left for the last step), or by one of the following doFinal methods (if there is no input data left for the last step):

    public byte[] doFinal();

    public int doFinal(byte[] output, int outputOffset);

All the doFinal methods take care of any necessary padding (or unpadding), if padding (or unpadding) has been requested as part of the specified transformation.

A call to doFinal resets the Cipher object to the state it was in when initialized via a call to init. That is, the Cipher object is reset and available to encrypt or decrypt (depending on the operation mode that was specified in the call to init) more data.

Wrapping and Unwrapping Keys

Wrapping a key enables secure transfer of the key from one place to another.

The wrap/unwrap API makes it more convenient to write code since it works with key objects directly. These methods also enable the possibility of secure transfer of hardware-based keys.

To wrap a Key, first initialize the Cipher object for WRAP_MODE, and then call the following:

    public final byte[] wrap(Key key);

If you are supplying the wrapped key bytes (the result of calling wrap) to someone else who will unwrap them, be sure to also send additional information the recipient will need in order to do the unwrap:

  1. the name of the key algorithm, and
  2. the type of the wrapped key (one of Cipher.SECRET_KEY, Cipher.PRIVATE_KEY, or Cipher.PUBLIC_KEY).

The key algorithm name can be determined by calling the getAlgorithm method from the Key interface:

    public String getAlgorithm();

To unwrap the bytes returned by a previous call to wrap, first initialize a Cipher object for UNWRAP_MODE, then call the following:

    public final Key unwrap(byte[] wrappedKey,
                            String wrappedKeyAlgorithm,
                            int wrappedKeyType));

Here, wrappedKey is the bytes returned from the previous call to wrap, wrappedKeyAlgorithm is the algorithm associated with the wrapped key, and wrappedKeyType is the type of the wrapped key. This must be one of Cipher.SECRET_KEY, Cipher.PRIVATE_KEY, or Cipher.PUBLIC_KEY.

Managing Algorithm Parameters

The parameters being used by the underlying Cipher implementation, which were either explicitly passed to the init method by the application or generated by the underlying implementation itself, can be retrieved from the Cipher object by calling its getParameters method, which returns the parameters as a java.security.AlgorithmParameters object (or null if no parameters are being used). If the parameter is an initialization vector (IV), it can also be retrieved by calling the getIV method.

In the following example, a Cipher object implementing password-based encryption (PBE) is initialized with just a key and no parameters. However, the selected algorithm for password-based encryption requires two parameters - a salt and an iteration count. Those will be generated by the underlying algorithm implementation itself. The application can retrieve the generated parameters from the Cipher object as follows:

    import javax.crypto.*;
    import java.security.AlgorithmParameters;

    // get cipher object for password-based encryption
    Cipher c = Cipher.getInstance("PBEWithHmacSHA256AndAES_256");

    // initialize cipher for encryption, without supplying
    // any parameters. Here, "myKey" is assumed to refer
    // to an already-generated key.
    c.init(Cipher.ENCRYPT_MODE, myKey);

    // encrypt some data and store away ciphertext
    // for later decryption
    byte[] cipherText = c.doFinal("This is just an example".getBytes());

    // retrieve parameters generated by underlying cipher
    // implementation
    AlgorithmParameters algParams = c.getParameters();

    // get parameter encoding and store it away
    byte[] encodedAlgParams = algParams.getEncoded();

The same parameters that were used for encryption must be used for decryption. They can be instantiated from their encoding and used to initialize the corresponding Cipher object for decryption, as follows:

    import javax.crypto.*;
    import java.security.AlgorithmParameters;

    // get parameter object for password-based encryption
    AlgorithmParameters algParams;
    algParams = AlgorithmParameters.getInstance("PBEWithHmacSHA256AndAES_256");

    // initialize with parameter encoding from above
    algParams.init(encodedAlgParams);

    // get cipher object for password-based encryption
    Cipher c = Cipher.getInstance("PBEWithHmacSHA256AndAES_256");

    // initialize cipher for decryption, using one of the
    // init() methods that takes an AlgorithmParameters
    // object, and pass it the algParams object from above
    c.init(Cipher.DECRYPT_MODE, myKey, algParams);

If you did not specify any parameters when you initialized a Cipher object, and you are not sure whether or not the underlying implementation uses any parameters, you can find out by simply calling the getParameters method of your Cipher object and checking the value returned. A return value of null indicates that no parameters were used.

The following cipher algorithms implemented by the SunJCE provider use parameters:

  • DES, DES-EDE, and Blowfish, when used in feedback (i.e., CBC, CFB, OFB, or PCBC) mode, use an initialization vector (IV). The javax.crypto.spec.IvParameterSpec class can be used to initialize a Cipher object with a given IV.
  • PBE Cipher algorithms use a set of parameters, comprising of a salt and an iteration count. The javax.crypto.spec.PBEParameterSpec class can be used to initialize a Cipher object implementing a PBE algorithm (for example: PBEWithHmacSHA256AndAES_256) with a given salt and iteration count.

Note that you do not have to worry about storing or transferring any algorithm parameters for use by the decryption operation if you use the SealedObject class. This class attaches the parameters used for sealing (encryption) to the encrypted object contents, and uses the same parameters for unsealing (decryption).

Cipher Output Considerations

Some of the update and doFinal methods of Cipher allow the caller to specify the output buffer into which to encrypt or decrypt the data. In these cases, it is important to pass a buffer that is large enough to hold the result of the encryption or decryption operation.

The following method in Cipher can be used to determine how big the output buffer should be:

    public int getOutputSize(int inputLen)

Other Cipher-based Classes

There are some helper classes which internally use Ciphers to provide easy access to common cipher uses.

The Cipher Stream Classes

The CipherInputStream Class

This class is a FilterInputStream that encrypts or decrypts the data passing through it. It is composed of an InputStream, or one of its subclasses, and a Cipher. CipherInputStream represents a secure input stream into which a Cipher object has been interposed. The read methods of CipherInputStream return data that are read from the underlying InputStream but have additionally been processed by the embedded Cipher object. The Cipher object must be fully initialized before being used by a CipherInputStream.

For example, if the embedded Cipher has been initialized for decryption, the CipherInputStream will attempt to decrypt the data it reads from the underlying InputStream before returning them to the application.

This class adheres strictly to the semantics, especially the failure semantics, of its ancestor classes java.io.FilterInputStream and java.io.InputStream. This class has exactly those methods specified in its ancestor classes, and overrides them all, so that the data are additionally processed by the embedded cipher. Moreover, this class catches all exceptions that are not thrown by its ancestor classes. In particular, the skip(long) method skips only data that has been processed by the Cipher.

It is crucial for a programmer using this class not to use methods that are not defined or overridden in this class (such as a new method or constructor that is later added to one of the super classes), because the design and implementation of those methods are unlikely to have considered security impact with regard to CipherInputStream.

As an example of its usage, suppose cipher1 has been initialized for encryption. The code below demonstrates how to use a CipherInputStream containing that cipher and a FileInputStream in order to encrypt input stream data:

    FileInputStream fis;
    FileOutputStream fos;
    CipherInputStream cis;

    fis = new FileInputStream("/tmp/a.txt");
    cis = new CipherInputStream(fis, cipher1);
    fos = new FileOutputStream("/tmp/b.txt");
    byte[] b = new byte[8];
    int i = cis.read(b);
    while (i != -1) {
        fos.write(b, 0, i);
        i = cis.read(b);
    }
    fos.close();

The above program reads and encrypts the content from the file /tmp/a.txt and then stores the result (the encrypted bytes) in /tmp/b.txt.

The following example demonstrates how to easily connect several instances of CipherInputStream and FileInputStream. In this example, assume that cipher1 and cipher2 have been initialized for encryption and decryption (with corresponding keys), respectively.

    FileInputStream fis;
    FileOutputStream fos;
    CipherInputStream cis1, cis2;

    fis = new FileInputStream("/tmp/a.txt");
    cis1 = new CipherInputStream(fis, cipher1);
    cis2 = new CipherInputStream(cis1, cipher2);
    fos = new FileOutputStream("/tmp/b.txt");
    byte[] b = new byte[8];
    int i = cis2.read(b);
    while (i != -1) {
        fos.write(b, 0, i);
        i = cis2.read(b);
    }
    fos.close();

The above program copies the content from file /tmp/a.txt to /tmp/b.txt, except that the content is first encrypted and then decrypted back when it is read from /tmp/a.txt. Of course since this program simply encrypts text and decrypts it back right away, it's actually not very useful except as a simple way of illustrating chaining of CipherInputStreams.

Note that the read methods of the CipherInputStream will block until data is returned from the underlying cipher. If a block cipher is used, a full block of cipher text will have to be obtained from the underlying InputStream.

The CipherOutputStream Class

This class is a FilterOutputStream that encrypts or decrypts the data passing through it. It is composed of an OutputStream, or one of its subclasses, and a Cipher. CipherOutputStream represents a secure output stream into which a Cipher object has been interposed. The write methods of CipherOutputStream first process the data with the embedded Cipher object before writing them out to the underlying OutputStream. The Cipher object must be fully initialized before being used by a CipherOutputStream.

For example, if the embedded Cipher has been initialized for encryption, the CipherOutputStream will encrypt its data, before writing them out to the underlying output stream.

This class adheres strictly to the semantics, especially the failure semantics, of its ancestor classes java.io.OutputStream and java.io.FilterOutputStream. This class has exactly those methods specified in its ancestor classes, and overrides them all, so that all data are additionally processed by the embedded cipher. Moreover, this class catches all exceptions that are not thrown by its ancestor classes.

It is crucial for a programmer using this class not to use methods that are not defined or overridden in this class (such as a new method or constructor that is later added to one of the super classes), because the design and implementation of those methods are unlikely to have considered security impact with regard to CipherOutputStream.

As an example of its usage, suppose cipher1 has been initialized for encryption. The code below demonstrates how to use a CipherOutputStream containing that cipher and a FileOutputStream in order to encrypt data to be written to an output stream:

    FileInputStream fis;
    FileOutputStream fos;
    CipherOutputStream cos;

    fis = new FileInputStream("/tmp/a.txt");
    fos = new FileOutputStream("/tmp/b.txt");
    cos = new CipherOutputStream(fos, cipher1);
    byte[] b = new byte[8];
    int i = fis.read(b);
    while (i != -1) {
        cos.write(b, 0, i);
        i = fis.read(b);
    }
    cos.flush();

The above program reads the content from the file /tmp/a.txt, then encrypts and stores the result (the encrypted bytes) in /tmp/b.txt.

The following example demonstrates how to easily connect several instances of CipherOutputStream and FileOutputStream. In this example, assume that cipher1 and cipher2 have been initialized for decryption and encryption (with corresponding keys), respectively:

    FileInputStream fis;
    FileOutputStream fos;
    CipherOutputStream cos1, cos2;

    fis = new FileInputStream("/tmp/a.txt");
    fos = new FileOutputStream("/tmp/b.txt");
    cos1 = new CipherOutputStream(fos, cipher1);
    cos2 = new CipherOutputStream(cos1, cipher2);
    byte[] b = new byte[8];
    int i = fis.read(b);
    while (i != -1) {
        cos2.write(b, 0, i);
        i = fis.read(b);
    }
    cos2.flush();

The above program copies the content from file /tmp/a.txt to /tmp/b.txt, except that the content is first encrypted and then decrypted back before it is written to /tmp/b.txt.

One thing to keep in mind when using block cipher algorithms is that a full block of plaintext data must be given to the CipherOutputStream before the data will be encrypted and sent to the underlying output stream.

There is one other important difference between the flush and close methods of this class, which becomes even more relevant if the encapsulated Cipher object implements a block cipher algorithm with padding turned on:

  • flush flushes the underlying OutputStream by forcing any buffered output bytes that have already been processed by the encapsulated Cipher object to be written out. Any bytes buffered by the encapsulated Cipher object and waiting to be processed by it will not be written out.
  • close closes the underlying OutputStream and releases any system resources associated with it. It invokes the doFinal method of the encapsulated Cipher object, causing any bytes buffered by it to be processed and written out to the underlying stream by calling its flush method.

The SealedObject Class

This class enables a programmer to create an object and protect its confidentiality with a cryptographic algorithm.

Given any object that implements the java.io.Serializable interface, one can create a SealedObject that encapsulates the original object, in serialized format (i.e., a "deep copy"), and seals (encrypts) its serialized contents, using a cryptographic algorithm such as DES, to protect its confidentiality. The encrypted content can later be decrypted (with the corresponding algorithm using the correct decryption key) and de-serialized, yielding the original object.

A typical usage is illustrated in the following code segment: In order to seal an object, you create a SealedObject from the object to be sealed and a fully initialized Cipher object that will encrypt the serialized object contents. In this example, the String "This is a secret" is sealed using the DES algorithm. Note that any algorithm parameters that may be used in the sealing operation are stored inside of SealedObject:

    // create Cipher object
    // NOTE: sKey is assumed to refer to an already-generated
    // secret DES key.
    Cipher c = Cipher.getInstance("DES");
    c.init(Cipher.ENCRYPT_MODE, sKey);

    // do the sealing
    SealedObject so = new SealedObject("This is a secret", c);

The original object that was sealed can be recovered in two different ways:

  • by using a Cipher object that has been initialized with the exact same algorithm, key, padding scheme, etc., that were used to seal the object:
        c.init(Cipher.DECRYPT_MODE, sKey);
    try {
        String s = (String)so.getObject(c);
    } catch (Exception e) {
        // do something
    };

    This approach has the advantage that the party who unseals the sealed object does not require knowledge of the decryption key. For example, after one party has initialized the cipher object with the required decryption key, it could hand over the cipher object to another party who then unseals the sealed object.

  • by using the appropriate decryption key (since DES is a symmetric encryption algorithm, we use the same key for sealing and unsealing):
        try {
        String s = (String)so.getObject(sKey);
    } catch (Exception e) {
        // do something
    };

    In this approach, the getObject method creates a cipher object for the appropriate decryption algorithm and initializes it with the given decryption key and the algorithm parameters (if any) that were stored in the sealed object. This approach has the advantage that the party who unseals the object does not need to keep track of the parameters (e.g., the IV) that were used to seal the object.

The Mac Class

Similar to a MessageDigest, a Message Authentication Code (MAC) provides a way to check the integrity of information transmitted over or stored in an unreliable medium, but includes a secret key in the calculation. Only someone with the proper key will be able to verify the received message. Typically, message authentication codes are used between two parties that share a secret key in order to validate information transmitted between these parties.

The Mac Class

Description of Figure 8: The Mac Class

A MAC mechanism that is based on cryptographic hash functions is referred to as HMAC. HMAC can be used with any cryptographic hash function, e.g., MD5 or SHA-1, in combination with a secret shared key.

The Mac class provides the functionality of a Message Authentication Code (MAC). Please refer to the code example.

Creating a Mac Object

Mac objects are obtained by using one of the Mac getInstance() static factory methods.

Initializing a Mac Object

A Mac object is always initialized with a (secret) key and may optionally be initialized with a set of parameters, depending on the underlying MAC algorithm.

To initialize a Mac object, call one of its init methods:

    public void init(Key key);

    public void init(Key key, AlgorithmParameterSpec params);

You can initialize your Mac object with any (secret-)key object that implements the javax.crypto.SecretKey interface. This could be an object returned by javax.crypto.KeyGenerator.generateKey(), or one that is the result of a key agreement protocol, as returned by javax.crypto.KeyAgreement.generateSecret(), or an instance of javax.crypto.spec.SecretKeySpec.

With some MAC algorithms, the (secret-)key algorithm associated with the (secret-)key object used to initialize the Mac object does not matter (this is the case with the HMAC-MD5 and HMAC-SHA1 implementations of the SunJCE provider). With others, however, the (secret-)key algorithm does matter, and an InvalidKeyException is thrown if a (secret-)key object with an inappropriate (secret-)key algorithm is used.

Computing a MAC

A MAC can be computed in one step (single-part operation) or in multiple steps (multiple-part operation). A multiple-part operation is useful if you do not know in advance how long the data is going to be, or if the data is too long to be stored in memory all at once.

To compute the MAC of some data in a single step, call the following doFinal method:

    public byte[] doFinal(byte[] input);

To compute the MAC of some data in multiple steps, call one of the update methods:

    public void update(byte input);

    public void update(byte[] input);

    public void update(byte[] input, int inputOffset, int inputLen);

A multiple-part operation must be terminated by the above doFinal method (if there is still some input data left for the last step), or by one of the following doFinal methods (if there is no input data left for the last step):

    public byte[] doFinal();

    public void doFinal(byte[] output, int outOffset);

Key Interfaces

To this point, we have focused the high-level uses of the JCA without getting lost in the details of what keys are and how they are generated/represented. It is now time to turn our attention to keys.

The java.security.Key interface is the top-level interface for all opaque keys. It defines the functionality shared by all opaque key objects.

An opaque key representation is one in which you have no direct access to the key material that constitutes a key. In other words: "opaque" gives you limited access to the key--just the three methods defined by the Key interface (see below): getAlgorithm, getFormat, and getEncoded.

This is in contrast to a transparent representation, in which you can access each key material value individually, through one of the get methods defined in the corresponding specification class.

All opaque keys have three characteristics:

An Algorithm
The key algorithm for that key. The key algorithm is usually an encryption or asymmetric operation algorithm (such as AES, DSA or RSA), which will work with those algorithms and with related algorithms (such as MD5withRSA, SHA1withRSA, etc.) The name of the algorithm of a key is obtained using this method:
String getAlgorithm()
An Encoded Form
The external encoded form for the key used when a standard representation of the key is needed outside the Java Virtual Machine, as when transmitting the key to some other party. The key is encoded according to a standard format (such as X.509 or PKCS8), and is returned using the method:
byte[] getEncoded()
A Format
The name of the format of the encoded key. It is returned by the method:
String getFormat()
Keys are generally obtained through key generators such as KeyGenerator and KeyPairGenerator, certificates, key specifications (using a KeyFactory), or a KeyStore implementation accessing a keystore database used to manage keys. It is possible to parse encoded keys, in an algorithm-dependent manner, using a KeyFactory.

It is also possible to parse certificates, using a CertificateFactory.

Here is a list of interfaces which extend the Key interface in the java.security.interfaces and javax.crypto.interfaces packages:

  • SecretKey
    • PBEKey
  • PrivateKey
    • DHPrivateKey
    • DSAPrivateKey
    • ECPrivateKey
    • RSAMultiPrimePrivateCrtKey
    • RSAPrivateCrtKey
    • RSAPrivateKey
  • PublicKey
    • DHPublicKey
    • DSAPublicKey
    • ECPublicKey
    • RSAPublicKey

The PublicKey and PrivateKey Interfaces

The PublicKey and PrivateKey interfaces (which both extend the Key interface) are methodless interfaces, used for type-safety and type-identification.

The KeyPair Class

The KeyPair class is a simple holder for a key pair (a public key and a private key). It has two public methods, one for returning the private key, and the other for returning the public key:

PrivateKey getPrivate()
PublicKey getPublic()

Key Specification Interfaces and Classes

Key objects and key specifications (KeySpecs) are two different representations of key data. Ciphers use Key objects to initialize their encryption algorithms, but keys may need to be converted into a more portable format for transmission or storage.

A transparent representation of keys means that you can access each key material value individually, through one of the get methods defined in the corresponding specification class. For example, DSAPrivateKeySpec defines getX, getP, getQ, and getG methods, to access the private key x, and the DSA algorithm parameters used to calculate the key: the prime p, the sub-prime q, and the base g. If the key is stored on a hardware device, its specification may contain information that helps identify the key on the device.

This representation is contrasted with an opaque representation, as defined by the Key interface, in which you have no direct access to the key material fields. In other words, an "opaque" representation gives you limited access to the key--just the three methods defined by the Key interface: getAlgorithm, getFormat, and getEncoded.

A key may be specified in an algorithm-specific way, or in an algorithm-independent encoding format (such as ASN.1). For example, a DSA private key may be specified by its components x, p, q, and g (see DSAPrivateKeySpec), or it may be specified using its DER encoding (see PKCS8EncodedKeySpec).

The KeyFactory and SecretKeyFactory classes can be used to convert between opaque and transparent key representations (that is, between Keys and KeySpecs, assuming that the operation is possible. (For example, private keys on smart cards might not be able leave the card. Such Keys are not convertible.)

In the following sections, we discuss the key specification interfaces and classes in the java.security.spec package.

The KeySpec Interface

This interface contains no methods or constants. Its only purpose is to group and provide type safety for all key specifications. All key specifications must implement this interface.

The KeySpec Subinterfaces

Like the Key interface, there are a similar set of KeySpec interfaces.

  • SecretKeySpec
  • EncodedKeySpec
    • PKCS8EncodedKeySpec
    • X509EncodedKeySpec
  • DESKeySpec
  • DESedeKeySpec
  • PBEKeySpec
  • DHPrivateKeySpec
  • DSAPrivateKeySpec
  • ECPrivateKeySpec
  • RSAPrivateKeySpec
    • RSAMultiPrimePrivateCrtKeySpec
    • RSAPrivateCrtKeySpec
  • DHPublicKeySpec
  • DSAPublicKeySpec
  • ECPublicKeySpec
  • RSAPublicKeySpec

The EncodedKeySpec Class

This abstract class (which implements the KeySpec interface) represents a public or private key in encoded format. Its getEncoded method returns the encoded key:

abstract byte[] getEncoded();
and its getFormat method returns the name of the encoding format:
abstract String getFormat();

See the next sections for the concrete implementations PKCS8EncodedKeySpec and X509EncodedKeySpec.

The PKCS8EncodedKeySpec Class

This class, which is a subclass of EncodedKeySpec, represents the DER encoding of a private key, according to the format specified in the PKCS8 standard. Its getEncoded method returns the key bytes, encoded according to the PKCS8 standard. Its getFormat method returns the string "PKCS#8".

The X509EncodedKeySpec Class

This class, which is a subclass of EncodedKeySpec, represents the DER encoding of a public key, according to the format specified in the X.509 standard. Its getEncoded method returns the key bytes, encoded according to the X.509 standard. Its getFormat method returns the string "X.509".

Of Generators and Factories

Newcomers to Java and the JCA APIs in particular sometimes do not grasp the distinction between generators and factories.

Differences Between Generators and Factories

Description of Figure Differences Between Generators and Factories

Generators are used to generate brand new objects. Generators can be initialized in either an algorithm-dependent or algorithm-independent way. For example, to create a Diffie-Hellman (DH) keypair, an application could specify the necessary P and G values, or the generator could simply be initialized with the appropriate key length, and the generator will select appropriate P and G values. In both cases, the generator will produce brand new keys based on the parameters.

On the other hand, factories are used to convert data from one existing object type to another. For example, an application might have available the components of a DH private key and can package them as a KeySpec, but needs to convert them into a PrivateKey object that can be used by a KeyAgreement object, or vice-versa. Or they might have the byte array of a certificate, but need to use a CertificateFactory to convert it into a X509Certificate object. Applications use factory objects to do the conversion.

The KeyFactory Class

The KeyFactory class is an engine class designed to perform conversions between opaque cryptographic Keys and key specifications (transparent representations of the underlying key material).

The KeyFactory Class<

Description of Figure The KeyFactory Class

Key factories are bi-directional. They allow you to build an opaque key object from a given key specification (key material), or to retrieve the underlying key material of a key object in a suitable format.

Multiple compatible key specifications can exist for the same key. For example, a DSA public key may be specified by its components y, p, q, and g (see java.security.spec.DSAPublicKeySpec), or it may be specified using its DER encoding according to the X.509 standard (see X509EncodedKeySpec).

A key factory can be used to translate between compatible key specifications. Key parsing can be achieved through translation between compatible key specifications, e.g., when you translate from X509EncodedKeySpec to DSAPublicKeySpec, you basically parse the encoded key into its components. For an example, see the end of the Generating/Verifying Signatures Using Key Specifications and KeyFactory section.

Creating a KeyFactory Object

KeyFactory objects are obtained by using one of the KeyFactory getInstance() static factory methods.

Converting Between a Key Specification and a Key Object

If you have a key specification for a public key, you can obtain an opaque PublicKey object from the specification by using the generatePublic method:

PublicKey generatePublic(KeySpec keySpec)

Similarly, if you have a key specification for a private key, you can obtain an opaque PrivateKey object from the specification by using the generatePrivate method:

PrivateKey generatePrivate(KeySpec keySpec)

Converting Between a Key Object and a Key Specification

If you have a Key object, you can get a corresponding key specification object by calling the getKeySpec method:

KeySpec getKeySpec(Key key, Class keySpec)
keySpec identifies the specification class in which the key material should be returned. It could, for example, be DSAPublicKeySpec.class, to indicate that the key material should be returned in an instance of the DSAPublicKeySpec class.

Please see the Examples section for more details.

The SecretKeyFactory Class

This class represents a factory for secret keys. Unlike KeyFactory, a javax.crypto.SecretKeyFactory object operates only on secret (symmetric) keys, whereas a java.security.KeyFactory object processes the public and private key components of a key pair.

The SecretKeyFactory Class

Description of The SecretKeyFactory Class

Key factories are used to convert Keys (opaque cryptographic keys of type java.security.Key) into key specifications (transparent representations of the underlying key material in a suitable format), and vice versa.

Objects of type java.security.Key, of which java.security.PublicKey, java.security.PrivateKey, and javax.crypto.SecretKey are subclasses, are opaque key objects, because you cannot tell how they are implemented. The underlying implementation is provider-dependent, and may be software or hardware based. Key factories allow providers to supply their own implementations of cryptographic keys.

For example, if you have a key specification for a Diffie Hellman public key, consisting of the public value y, the prime modulus p, and the base g, and you feed the same specification to Diffie-Hellman key factories from different providers, the resulting PublicKey objects will most likely have different underlying implementations.

A provider should document the key specifications supported by its secret key factory. For example, the SecretKeyFactory for DES keys supplied by the SunJCE provider supports DESKeySpec as a transparent representation of DES keys, the SecretKeyFactory for DES-EDE keys supports DESedeKeySpec as a transparent representation of DES-EDE keys, and the SecretKeyFactory for PBE supports PBEKeySpec as a transparent representation of the underlying password.

The following is an example of how to use a SecretKeyFactory to convert secret key data into a SecretKey object, which can be used for a subsequent Cipher operation:

    // Note the following bytes are not realistic secret key data
    // bytes but are simply supplied as an illustration of using data
    // bytes (key material) you already have to build a DESKeySpec.
    byte[] desKeyData = { (byte)0x01, (byte)0x02, (byte)0x03,
    (byte)0x04, (byte)0x05, (byte)0x06, (byte)0x07, (byte)0x08 };
    DESKeySpec desKeySpec = new DESKeySpec(desKeyData);
    SecretKeyFactory keyFactory = SecretKeyFactory.getInstance("DES");
    SecretKey secretKey = keyFactory.generateSecret(desKeySpec);

In this case, the underlying implementation of SecretKey is based on the provider of KeyFactory.

An alternative, provider-independent way of creating a functionally equivalent SecretKey object from the same key material is to use the javax.crypto.spec.SecretKeySpec class, which implements the javax.crypto.SecretKey interface:

    byte[] desKeyData = { (byte)0x01, (byte)0x02, ...};
    SecretKeySpec secretKey = new SecretKeySpec(desKeyData, "DES");

Creating a SecretKeyFactory Object

SecretKeyFactory objects are obtained by using one of the SecretKeyFactory getInstance() static factory methods.

Converting Between a Key Specification and a Secret Key Object

If you have a key specification for a secret key, you can obtain an opaque SecretKey object from the specification by using the generateSecret method:

SecretKey generateSecret(KeySpec keySpec)

Converting Between a Secret Key Object and a Key Specification

If you have a Secret Key object, you can get a corresponding key specification object by calling the getKeySpec method:

KeySpec getKeySpec(Key key, Class keySpec)
keySpec identifies the specification class in which the key material should be returned. It could, for example, be DESKeySpec.class, to indicate that the key material should be returned in an instance of the DESKeySpec class.

The KeyPairGenerator Class

The KeyPairGenerator class is an engine class used to generate pairs of public and private keys.

The KeyPairGenerator Class

Description of The KeyPairGenerator Class

There are two ways to generate a key pair: in an algorithm-independent manner, and in an algorithm-specific manner. The only difference between the two is the initialization of the object.

Please see the Examples section for examples of calls to the methods documented below.

Creating a KeyPairGenerator

All key pair generation starts with a KeyPairGenerator. KeyPairGenerator objects are obtained by using one of the KeyPairGenerator getInstance() static factory methods.

Initializing a KeyPairGenerator

A key pair generator for a particular algorithm creates a public/private key pair that can be used with this algorithm. It also associates algorithm-specific parameters with each of the generated keys.

A key pair generator needs to be initialized before it can generate keys. In most cases, algorithm-independent initialization is sufficient. But in other cases, algorithm-specific initialization can be used.

Algorithm-Independent Initialization

All key pair generators share the concepts of a keysize and a source of randomness. The keysize is interpreted differently for different algorithms. For example, in the case of the DSA algorithm, the keysize corresponds to the length of the modulus. (See the Standard Names document for information about the keysizes for specific algorithms.)

An initialize method takes two universally shared types of arguments:

void initialize(int keysize, SecureRandom random)
Another initialize method takes only a keysize argument; it uses a system-provided source of randomness:
void initialize(int keysize)

Since no other parameters are specified when you call the above algorithm-independent initialize methods, it is up to the provider what to do about the algorithm-specific parameters (if any) to be associated with each of the keys.

If the algorithm is a "DSA" algorithm, and the modulus size (keysize) is 512, 768, or 1024, then the SUN provider uses a set of precomputed values for the p, q, and g parameters. If the modulus size is not one of the above values, the SUN provider creates a new set of parameters. Other providers might have precomputed parameter sets for more than just the three modulus sizes mentioned above. Still others might not have a list of precomputed parameters at all and instead always create new parameter sets.

Algorithm-Specific Initialization

For situations where a set of algorithm-specific parameters already exists (such as "community parameters" in DSA), there are two initialize methods that have an AlgorithmParameterSpec argument. One also has a SecureRandom argument, while the source of randomness is system-provided for the other:

void initialize(AlgorithmParameterSpec params,
                SecureRandom random)

void initialize(AlgorithmParameterSpec params)
See the Examples section for more details.

Generating a Key Pair

The procedure for generating a key pair is always the same, regardless of initialization (and of the algorithm). You always call the following method from KeyPairGenerator:

KeyPair generateKeyPair()
Multiple calls to generateKeyPair will yield different key pairs.

The KeyGenerator Class

A key generator is used to generate secret keys for symmetric algorithms.

The KeyGenerator Class

Description of Figure The KeyGenerator Class

Creating a KeyGenerator

KeyGenerator objects are obtained by using one of the KeyGenerator getInstance() static factory methods.

Initializing a KeyGenerator Object

A key generator for a particular symmetric-key algorithm creates a symmetric key that can be used with that algorithm. It also associates algorithm-specific parameters (if any) with the generated key.

There are two ways to generate a key: in an algorithm-independent manner, and in an algorithm-specific manner. The only difference between the two is the initialization of the object:

  • Algorithm-Independent Initialization

    All key generators share the concepts of a keysize and a source of randomness. There is an init method that takes these two universally shared types of arguments. There is also one that takes just a keysize argument, and uses a system-provided source of randomness, and one that takes just a source of randomness:

    public void init(SecureRandom random);

    public void init(int keysize);

    public void init(int keysize, SecureRandom random);

    Since no other parameters are specified when you call the above algorithm-independent init methods, it is up to the provider what to do about the algorithm-specific parameters (if any) to be associated with the generated key.

  • Algorithm-Specific Initialization

    For situations where a set of algorithm-specific parameters already exists, there are two init methods that have an AlgorithmParameterSpec argument. One also has a SecureRandom argument, while the source of randomness is system-provided for the other:

        public void init(AlgorithmParameterSpec params);

    public void init(AlgorithmParameterSpec params, SecureRandom random);

In case the client does not explicitly initialize the KeyGenerator (via a call to an init method), each provider must supply (and document) a default initialization.

Creating a Key

The following method generates a secret key:

    public SecretKey generateKey();

The KeyAgreement Class

Key agreement is a protocol by which 2 or more parties can establish the same cryptographic keys, without having to exchange any secret information.

The KeyAgreement Class

Description of Figure The KeyAgreement Class

Each party initializes their key agreement object with their private key, and then enters the public keys for each party that will participate in the communication. In most cases, there are just two parties, but algorithms such as Diffie-Hellman allow for multiple parties (3 or more) to participate. When all the public keys have been entered, each KeyAgreement object will generate (agree upon) the same key.

The KeyAgreement class provides the functionality of a key agreement protocol. The keys involved in establishing a shared secret are created by one of the key generators (KeyPairGenerator or KeyGenerator), a KeyFactory, or as a result from an intermediate phase of the key agreement protocol.

Creating a KeyAgreement Object

Each party involved in the key agreement has to create a KeyAgreement object. KeyAgreement objects are obtained by using one of the KeyAgreement getInstance() static factory methods.

Initializing a KeyAgreement Object

You initialize a KeyAgreement object with your private information. In the case of Diffie-Hellman, you initialize it with your Diffie-Hellman private key. Additional initialization information may contain a source of randomness and/or a set of algorithm parameters. Note that if the requested key agreement algorithm requires the specification of algorithm parameters, and only a key, but no parameters are provided to initialize the KeyAgreement object, the key must contain the required algorithm parameters. (For example, the Diffie-Hellman algorithm uses a prime modulus p and a base generator g as its parameters.)

To initialize a KeyAgreement object, call one of its init methods:

    public void init(Key key);

    public void init(Key key, SecureRandom random);

    public void init(Key key, AlgorithmParameterSpec params);

    public void init(Key key, AlgorithmParameterSpec params,
                     SecureRandom random);

Executing a KeyAgreement Phase

Every key agreement protocol consists of a number of phases that need to be executed by each party involved in the key agreement.

To execute the next phase in the key agreement, call the doPhase method:

    public Key doPhase(Key key, boolean lastPhase);

The key parameter contains the key to be processed by that phase. In most cases, this is the public key of one of the other parties involved in the key agreement, or an intermediate key that was generated by a previous phase. doPhase may return an intermediate key that you may have to send to the other parties of this key agreement, so they can process it in a subsequent phase.

The lastPhase parameter specifies whether or not the phase to be executed is the last one in the key agreement: A value of FALSE indicates that this is not the last phase of the key agreement (there are more phases to follow), and a value of TRUE indicates that this is the last phase of the key agreement and the key agreement is completed, i.e., generateSecret can be called next.

In the example of Diffie-Hellman between two parties , you call doPhase once, with lastPhase set to TRUE. In the example of Diffie-Hellman between three parties, you call doPhase twice: the first time with lastPhase set to FALSE, the 2nd time with lastPhase set to TRUE.

Generating the Shared Secret

After each party has executed all the required key agreement phases, it can compute the shared secret by calling one of the generateSecret methods:

    public byte[] generateSecret();

    public int generateSecret(byte[] sharedSecret, int offset);

    public SecretKey generateSecret(String algorithm);

Key Management

A database called a "keystore" can be used to manage a repository of keys and certificates. (A certificate is a digitally signed statement from one entity, saying that the public key of some other entity has a particular value.)

Keystore Location

The user keystore is by default stored in a file named .keystore in the user's home directory, as determined by the "user.home" system property. On Solaris systems "user.home" defaults to the user's home directory. On Win32 systems, given user name uName, "user.home" defaults to:

  • C:\Winnt\Profiles\uName on multi-user Windows NT systems
  • C:\Windows\Profiles\uName on multi-user Windows 95/98/2000 systems
  • C:\Windows on single-user Windows 95/98/2000 systems

Of course, keystore files can be located as desired. In some environments, it may make sense for multiple keystores to exist. For example, in JSSE (SSL/TLS), one keystore might hold a user's private keys, and another might hold certificates used to establish trust relationships.

In addition to the user's keystore, the JDK also maintains a system-wide keystore which is used to store trusted certificates from a variety of Certificate Authorities (CA's). These CA certificates can be used to help make trust decisions. For example, in SSL/TLS when the SunJSSE provider is presented with certificates from a remote peer, the default trustmanager will consult the:

  • Solaris, Linux, or Mac OS X: <java-home>/lib/ext/cacerts
  • Windows: <java-home>\lib\ext\cacerts

file to determine if the connection is to be trusted. Instead of using the system-wide cacerts keystore, applications can set up and use their own keystores, or even use the user keystore described above.

Keystore Implementation

The KeyStore class supplies well-defined interfaces to access and modify the information in a keystore. It is possible for there to be multiple different concrete implementations, where each implementation is that for a particular type of keystore.

Currently, there are two command-line tools that make use of KeyStore: keytool and jarsigner, and also a GUI-based tool named policytool. It is also used by the Policy reference implementation when it processes policy files specifying the permissions (allowed accesses to system resources) to be granted to code from various sources. Since KeyStore is publicly available, JDK users can write additional security applications that use it.

Applications can choose different types of keystore implementations from different providers, using the getInstance factory method in the KeyStore class. A keystore type defines the storage and data format of the keystore information, and the algorithms used to protect private keys in the keystore and the integrity of the keystore itself. Keystore implementations of different types are not compatible.

There is a built-in default keystore implementation type known as "jks" that is provided by Sun Microsystems. It implements the keystore as a file, utilizing a proprietary keystore type (format). It protects each private key with its own individual password, and also protects the integrity of the entire keystore with a (possibly different) password. The default is specified by the following line in the security properties file:

    keystore.type=jks

To have tools and other applications use a different default keystore implementation, you can change that line to specify a default type. If you have a provider package that supplies a keystore implementation for a keystore type called "jceks", change the line to:

    keystore.type=jceks

Some applications, such as keytool, also let you override the default keystore type (via the -storetype command-line parameter).

NOTE: Keystore type designations are case-insensitive. For example, "jks" would be considered the same as "JKS".

There are three other types of keystores that come with the JDK implementation.

  1. "jceks" is an alternate proprietary keystore format to "jks" that uses much stronger encryption in the form of Password-Based Encryption with Triple-DES.

    The Sun "jceks" implementation can parse and convert a "jks" keystore file to the "jceks" format. You may upgrade your keystore of type "jks" to a keystore of type "jceks" by changing the password of a private-key entry in your keystore and specifying "-storetype jceks" as the keystore type. To apply the cryptographically strong(er) key protection supplied to a private key named "signkey" in your default keystore, use the following command, which will prompt you for the old and new key passwords:

        keytool -keypasswd -alias signkey -storetype jceks
    See Security Tools for more information about keytool and about keystores and how they are managed.
    NOTE: Keystore type designations are case-insensitive. For example, "jceks" would be considered the same as "JCEKS".
  2. "pkcs12" is another option. This is a cross platform keystore based on the RSA PKCS12 Personal Information Exchange Syntax Standard. This standard is primarily meant for storing or transporting a user's private keys, certificates, and miscellaneous secrets. As of JDK 8, arbitrary attributes can be associated with individual entries in a PKCS12 keystore.
  3. "dks" is a domain keystore. It is a collection of keystores presented as a single logical keystore. The keystores that comprise a given domain are specified by configuration data whose syntax is described in DomainLoadStoreParameter.

Keystore implementations are provider-based. Developers interested in writing their own KeyStore implementations should consult How to Implement a Provider for the Java Cryptography Architecture for more information on this topic.

The KeyStore Class

The KeyStore class is an engine class that supplies well-defined interfaces to access and modify the information in a keystore.

The KeyStore Class

Description of Figure The KeyStore Class

This class represents an in-memory collection of keys and certificates. KeyStore manages two types of entries:

Key Entry

This type of keystore entry holds very sensitive cryptographic key information, which is stored in a protected format to prevent unauthorized access. Typically, a key stored in this type of entry is a secret key, or a private key accompanied by the certificate chain authenticating the corresponding public key.

Private keys and certificate chains are used by a given entity for self-authentication using digital signatures. For example, software distribution organizations digitally sign JAR files as part of releasing and/or licensing software.

Trusted Certificate Entry

This type of entry contains a single public key certificate belonging to another party. It is called a trusted certificate because the keystore owner trusts that the public key in the certificate indeed belongs to the identity identified by the subject (owner) of the certificate.

This type of entry can be used to authenticate other parties.

Each entry in a keystore is identified by an "alias" string. In the case of private keys and their associated certificate chains, these strings distinguish among the different ways in which the entity may authenticate itself. For example, the entity may authenticate itself using different certificate authorities, or using different public key algorithms.

Whether keystores are persistent, and the mechanisms used by the keystore if it is persistent, are not specified here. This convention allows use of a variety of techniques for protecting sensitive (e.g., private or secret) keys. Smart cards or other integrated cryptographic engines (SafeKeyper) are one option, and simpler mechanisms such as files may also be used (in a variety of formats).

The main KeyStore methods are described below.

Creating a KeyStore Object

KeyStore objects are obtained by using one of the KeyStore getInstance() static factory methods.

Loading a Particular Keystore into Memory

Before a KeyStore object can be used, the actual keystore data must be loaded into memory via the load method:

final void load(InputStream stream, char[] password)

The optional password is used to check the integrity of the keystore data. If no password is supplied, no integrity check is performed.

To create an empty keystore, you pass null as the InputStream argument to the load method.

A DKS keystore is loaded by passing a DomainLoadStoreParameter to the alternative load method:

final void load(KeyStore.LoadStoreParameter param)

Getting a List of the Keystore Aliases

All keystore entries are accessed via unique aliases. The aliases method returns an enumeration of the alias names in the keystore:

final Enumeration aliases()

Determining Keystore Entry Types

As stated in The KeyStore Class, there are two different types of entries in a keystore. The following methods determine whether the entry specified by the given alias is a key/certificate or a trusted certificate entry, respectively:

final boolean isKeyEntry(String alias)
final boolean isCertificateEntry(String alias)

Adding/Setting/Deleting Keystore Entries

The setCertificateEntry method assigns a certificate to a specified alias:

final void setCertificateEntry(String alias, Certificate cert)

If alias doesn't exist, a trusted certificate entry with that alias is created. If alias exists and identifies a trusted certificate entry, the certificate associated with it is replaced by cert.

The setKeyEntry methods add (if alias doesn't yet exist) or set key entries:

final void setKeyEntry(String alias,
                       Key key,
                       char[] password,
                       Certificate[] chain)

final void setKeyEntry(String alias,
                       byte[] key,
                       Certificate[] chain)

In the method with key as a byte array, it is the bytes for a key in protected format. For example, in the keystore implementation supplied by the SUN provider, the key byte array is expected to contain a protected private key, encoded as an EncryptedPrivateKeyInfo as defined in the PKCS8 standard. In the other method, the password is the password used to protect the key.

The deleteEntry method deletes an entry:

final void deleteEntry(String alias)

PKCS #12 keystores support entries containing arbitrary attributes. Use the java.security.PKCS12Attribute class to create the attributes. When creating the new keystore entry use a constructor method that accepts attributes. Finally, use the following method to add the entry to the keystore:

final void setEntry(String alias, Entry entry,
                    ProtectionParameter protParam)

Getting Information from the Keystore

The getKey method returns the key associated with the given alias. The key is recovered using the given password:

final Key getKey(String alias, char[] password)

The following methods return the certificate, or certificate chain, respectively, associated with the given alias:

final Certificate getCertificate(String alias)
final Certificate[] getCertificateChain(String alias)

You can determine the name (alias) of the first entry whose certificate matches a given certificate via the following:

final String getCertificateAlias(Certificate cert)

PKCS #12 keystores support entries containing arbitrary attributes. Use the following method to retrieve an entry that may contain attributes:

final Entry getEntry(String alias, ProtectionParameter protParam)

and then use the KeyStore.Entry.getAttributes method to extract such attributes and use the methods of the KeyStore.Entry.Attribute interface to examine them.

Saving the KeyStore

The in-memory keystore can be saved via the store method:

final void store(OutputStream stream, char[] password)

The password is used to calculate an integrity checksum of the keystore data, which is appended to the keystore data.

A DKS keystore is stored by passing a DomainLoadStoreParameter to the alternative store method:

final void store(KeyStore.LoadStoreParameter param)

Algorithm Parameters Classes

Like Keys and Keyspecs, an algorithm's initialization parameters are represented by either AlgorithmParameters or AlgorithmParameterSpecs. Depending on the use situation, algorithms can use the parameters directly, or the parameters might need to be converted into a more portable format for transmission or storage.

A transparent representation of a set of parameters (via AlgorithmParameterSpec) means that you can access each parameter value in the set individually. You can access these values through one of the get methods defined in the corresponding specification class (e.g., DSAParameterSpec defines getP, getQ, and getG methods, to access p, q, and g, respectively).

In contrast, the AlgorithmParameters class supplies an opaque representation, in which you have no direct access to the parameter fields. You can only get the name of the algorithm associated with the parameter set (via getAlgorithm) and some kind of encoding for the parameter set (via getEncoded).

The AlgorithmParameterSpec Interface

AlgorithmParameterSpec is an interface to a transparent specification of cryptographic parameters. This interface contains no methods or constants. Its only purpose is to group (and provide type safety for) all parameter specifications. All parameter specifications must implement this interface.

The algorithm parameter specification interfaces and classes in the java.security.spec and javax.crypto.spec packages are described in the JDK javadocs:

  • DHParameterSpec
  • DHGenParameterSpec
  • DSAParameterSpec
  • ECGenParameterSpec
  • ECParameterSpec
  • GCMParameterSpec
  • IvParameterSpec
  • MGF1ParameterSpec
  • OAEPParameterSpec
  • PBEParameterSpec
  • PSSParameterSpec
  • RC2ParameterSpec
  • RC5ParameterSpec
  • RSAKeyGenParameterSpec

The following algorithm parameter specs are used specifically for digital signatures, as part of JSR 105.

  • C14NMethodParameterSpec
  • DigestMethodParameterSpec
  • SignatureMethodParameterSpec
  • TransformParameterSpec
  • ExcC14NParameterSpec
  • HMACParameterSpec
  • XPathFilter2ParameterSpec
  • XPathFilterParameterSpec
  • XSLTTransformParameterSpec

The AlgorithmParameters Class

The AlgorithmParameters class is an engine class that provides an opaque representation of cryptographic parameters. You can initialize the AlgorithmParameters class using a specific AlgorithmParameterSpec object, or by encoding the parameters in a recognized format. You can retrieve the resulting specification with the getParameterSpec method (see the following section).

Creating an AlgorithmParameters Object

AlgorithmParameters objects are obtained by using one of the AlgorithmParameters getInstance() static factory methods.

Initializing an AlgorithmParameters Object

Once an AlgorithmParameters object is instantiated, it must be initialized via a call to init, using an appropriate parameter specification or parameter encoding:

void init(AlgorithmParameterSpec paramSpec)
void init(byte[] params)
void init(byte[] params, String format)

In these init methods, params is an array containing the encoded parameters, and format is the name of the decoding format. In the init method with a params argument but no format argument, the primary decoding format for parameters is used. The primary decoding format is ASN.1, if an ASN.1 specification for the parameters exists.

NOTE: AlgorithmParameters objects can be initialized only once. They are not reusable.

Obtaining the Encoded Parameters

A byte encoding of the parameters represented in an AlgorithmParameters object may be obtained via a call to getEncoded:

byte[] getEncoded()

This method returns the parameters in their primary encoding format. The primary encoding format for parameters is ASN.1, if an ASN.1 specification for this type of parameters exists.

If you want the parameters returned in a specified encoding format, use

byte[] getEncoded(String format)
If format is null, the primary encoding format for parameters is used, as in the other getEncoded method.
NOTE: In the default AlgorithmParameters implementation, supplied by the SUN provider, the format argument is currently ignored.

Converting an AlgorithmParameters Object to a Transparent Specification

A transparent parameter specification for the algorithm parameters may be obtained from an AlgorithmParameters object via a call to getParameterSpec:

AlgorithmParameterSpec getParameterSpec(Class paramSpec)

paramSpec identifies the specification class in which the parameters should be returned. The specification class could be, for example, DSAParameterSpec.class to indicate that the parameters should be returned in an instance of the DSAParameterSpec class. (This class is in the java.security.spec package.)

The AlgorithmParameterGenerator Class

The AlgorithmParameterGenerator class is an engine class used to generate a set of brand-new parameters suitable for a certain algorithm (the algorithm is specified when an AlgorithmParameterGenerator instance is created). This object is used when you do not have an existing set of algorithm parameters, and want to generate one from scratch.

Creating an AlgorithmParameterGenerator Object

AlgorithmParameterGenerator objects are obtained by using one of the AlgorithmParameterGenerator getInstance() static factory methods.

Initializing an AlgorithmParameterGenerator Object

The AlgorithmParameterGenerator object can be initialized in two different ways: an algorithm-independent manner or an algorithm-specific manner.

The algorithm-independent approach uses the fact that all parameter generators share the concept of a "size" and a source of randomness. The measure of size is universally shared by all algorithm parameters, though it is interpreted differently for different algorithms. For example, in the case of parameters for the DSA algorithm, "size" corresponds to the size of the prime modulus, in bits. (See the Standard Names document for information about the sizes for specific algorithms.) When using this approach, algorithm-specific parameter generation values--if any--default to some standard values. One init method that takes these two universally shared types of arguments:

void init(int size, SecureRandom random);

Another init method takes only a size argument and uses a system-provided source of randomness:

void init(int size)

A third approach initializes a parameter generator object using algorithm-specific semantics, which are represented by a set of algorithm-specific parameter generation values supplied in an AlgorithmParameterSpec object:

void init(AlgorithmParameterSpec genParamSpec,
                          SecureRandom random)

void init(AlgorithmParameterSpec genParamSpec)

To generate Diffie-Hellman system parameters, for example, the parameter generation values usually consist of the size of the prime modulus and the size of the random exponent, both specified in number of bits.

Generating Algorithm Parameters

Once you have created and initialized an AlgorithmParameterGenerator object, you can use the generateParameters method to generate the algorithm parameters:

AlgorithmParameters generateParameters()

The CertificateFactory Class

The CertificateFactory class is an engine class that defines the functionality of a certificate factory, which is used to generate certificate and certificate revocation list (CRL) objects from their encodings.

A certificate factory for X.509 must return certificates that are an instance of java.security.cert.X509Certificate, and CRLs that are an instance of java.security.cert.X509CRL.

Creating a CertificateFactory Object

CertificateFactory objects are obtained by using one of the getInstance() static factory methods.

Generating Certificate Objects

To generate a certificate object and initialize it with the data read from an input stream, use the generateCertificate method:

final Certificate generateCertificate(InputStream inStream)

To return a (possibly empty) collection view of the certificates read from a given input stream, use the generateCertificates method:

final Collection generateCertificates(InputStream inStream)

Generating CRL Objects

To generate a certificate revocation list (CRL) object and initialize it with the data read from an input stream, use the generateCRL method:

final CRL generateCRL(InputStream inStream)
To return a (possibly empty) collection view of the CRLs read from a given input stream, use the generateCRLs method:
final Collection generateCRLs(InputStream inStream)

Generating CertPath Objects

The certificate path builder and validator for PKIX is defined by the Internet X.509 Public Key Infrastructure Certificate and CRL Profile, RFC 3280.

A certificate store implementation for retrieving certificates and CRLs from Collection and LDAP directories, using the PKIX LDAP V2 Schema is also available from the IETF as RFC 2587.

To generate a CertPath object and initialize it with data read from an input stream, use one of the following generateCertPath methods (with or without specifying the encoding to be used for the data):

final CertPath generateCertPath(InputStream inStream)

final CertPath generateCertPath(InputStream inStream,
                                String encoding)

To generate a CertPath object and initialize it with a list of certificates, use the following method:

final CertPath generateCertPath(List certificates)

To retrieve a list of the CertPath encodings supported by this certificate factory, you can call the getCertPathEncodings method:

final Iterator getCertPathEncodings()
The default encoding will be listed first.

How the JCA Might Be Used in a SSL/TLS Implementation

With an understanding of the JCA classes, consider how these classes might be combined to implement an advanced network protocol like SSL/TLS. The SSL/TLS Overview section in the JSSE Reference Guide describes at a high level how the protocols work. As asymmetric (public key) cipher operations are much slower than symmetric operations (secret key), public key cryptography is used to establish secret keys which are then used to protect the actual application data. Vastly simplified, the SSL/TLS handshake involves exchanging initialization data, performing some public key operations to arrive at a secret key, and then using that key to encrypt further traffic.

NOTE: The details presented here simply show how some of the above classes might be employed. This section will not present sufficient information for building a SSL/TLS implementation. For more details, please see the JSSE Reference Guide and RFC 2246: The TLS Protocol.

Assume that this SSL/TLS implementation will be made available as a JSSE provider. A concrete implementation of the Provider class is first written that will eventually be registered in the Security class' list of providers. This provider mainly provides a mapping from algorithm names to actual implementation classes. (that is: "SSLContext.TLS"->"com.foo.TLSImpl") When an application requests an "TLS" instance (via SSLContext.getInstance("TLS"), the provider's list is consulted for the requested algorithm, and an appropriate instance is created.

Before discussing details of the actual handshake, a quick review of some of the JSSE's architecture is needed. The heart of the JSSE architecture is the SSLContext. The context eventually creates end objects (SSLSocket and SSLEngine) which actually implement the SSL/TLS protocol. SSLContexts are initialized with two callback classes, KeyManager and TrustManager, which allow applications to first select authentication material to send and second to verify credentials sent by a peer.

A JSSE KeyManager is responsible for choosing which credentials to present to a peer. Many algorithms are possible, but a common strategy is to maintain a RSA or DSA public/private key pair along with a X509Certificate in a KeyStore backed by a disk file. When a KeyStore object is initialized and loaded from the file, the file's raw bytes are converted into PublicKey and PrivateKey objects using a KeyFactory, and a certificate chain's bytes are converted using a CertificateFactory. When a credential is needed, the KeyManager simply consults this KeyStore object and determines which credentials to present.

A KeyStore's contents might have originally been created using a utility such as keytool. keytool creates a RSA or DSA KeyPairGenerator and initializes it with an appropriate keysize. This generator is then used to create a KeyPair which keytool would store along with the newly-created certificate in the KeyStore, which is eventually written to disk.

A JSSE TrustManager is responsible for verifying the credentials received from a peer. There are many ways to verify credentials: one of them is to create a CertPath object, and let the JDK's built-in Public Key Infrastructure (PKI) framework handle the validation. Internally, the CertPath implementation might create a Signature object, and use that to verify that the each of the signatures in the certificate chain.

With this basic understanding of the architecture, we can look at some of the steps in the SSL/TLS handshake. The client begins by sending a ClientHello message to the server. The server selects a ciphersuite to use, and sends that back in a ServerHello message, and begins creating JCA objects based on the suite selection. We'll use server-only authentication in the following examples.

SSL Messages

Description of Figure SSL Messages

In the first example, the server tries to use a RSA-based ciphersuite such as TLS_RSA_WITH_AES_128_CBC_SHA. The server's KeyManager is queried, and returns an appropriate RSA entry. The server's credentials (that is: certificate/public key) are sent in the server's Certificate message. The client's TrustManager verifies the server's certificate, and if accepted, the client generates some random bytes using a SecureRandom object. This is then encrypted using an encrypting asymmetric RSA Cipher object that has been initialized with the PublicKey found in the server's certificate. This encrypted data is sent in a Client Key Exchange message. The server would use its corresponding PrivateKey to recover the bytes using a similar Cipher in decrypt mode. These bytes are then used to establish the actual encryption keys.

In a different example, an ephemeral Diffie-Hellman key agreement algorithm along with the DSA signature algorithm is chosen, such as TLS_DHE_DSS_WITH_AES_128_CBC_SHA. The two sides must each establish a new temporary DH public/private keypair using a KeyPairGenerator. Each generator creates DH keys which can then be further converted into pieces using the KeyFactory and DHPublicKeySpec classes. Each side then creates a KeyAgreement object and initializes it with their respective DH PrivateKeys. The server sends its public key pieces in a ServerKeyExchange message (protected by the DSA signature algorithm, and the client sends its public key in a ClientKeyExchange message. When the public keys are reassembled using another KeyFactory, they are fed into the agreement objects. The KeyAgreement objects then generate agreed-upon bytes that are then used to establish the actual encryption keys.

Once the actual encryption keys have been established, the secret key is used to initialize a symmetric Cipher object, and this cipher is used to protect all data in transit. To help determine if the data has been modified, a MessageDigest is created and receives a copy of the data destined for the network. When the packet is complete, the digest (hash) is appended to data, and the entire packet is encrypted by the Cipher. If a block cipher such as AES is used, the data must be padded to make a complete block. On the remote side, the steps are simply reversed.

Again, this is vastly simplified, but gives one an idea of how these classes might be combined to create a higher level protocol.

How to Make Applications "Exempt" from Cryptographic Restrictions

Note 1: This section should be ignored by most application developers. It is only for people whose applications may be exported to those few countries whose governments mandate cryptographic restrictions, if it is desired that such applications have fewer cryptographic restrictions than those mandated. Note 2: Throughout this section, the term "application" is meant to encompass both applications and applets.]

The JCA framework includes an ability to enforce restrictions regarding the cryptographic algorithms and maximum cryptographic strengths available to applets/applications in different jurisdiction contexts (locations). Any such restrictions are specified in "jurisdiction policy files".

Due to import control restrictions by the governments of a few countries, the jurisdiction policy files shipped with the Java SE Development Kit 6 specify that "strong" but limited cryptography may be used. An "unlimited strength" version of these files indicating no restrictions on cryptographic strengths is available for those living in eligible countries (which is most countries). But only the "strong" version can be imported into those countries whose governments mandate restrictions. The JCA framework will enforce the restrictions specified in the installed jurisdiction policy files.

It is possible that the governments of some or all such countries may allow certain applications to become exempt from some or all cryptographic restrictions. For example, they may consider certain types of applications as "special" and thus exempt. Or they may exempt any application that utilizes an "exemption mechanism," such as key recovery. Applications deemed to be exempt could get access to stronger cryptography than that allowed for non-exempt applications in such countries.

In order for an application to be recognized as "exempt" at runtime, it must meet the following conditions:

  • It must have a permission policy file bundled with it in a JAR file. The permission policy file specifies what cryptography-related permissions the application has, and under what conditions (if any).
  • The JAR file containing the application and the permission policy file must have been signed using a code-signing certificate issued after the application was accepted as exempt.

Below are sample steps required in order to make an application exempt from some or all cryptographic restrictions. This is a basic outline that includes information about what is required by JCA in order to recognize and treat applications as being exempt. You will need to know the exemption requirements of the particular country or countries in which you would like your application to be able to be run but whose governments require cryptographic restrictions. You will also need to know the requirements of a JCA framework vendor that has a process in place for handling exempt applications. Consult such a vendor for further information. (NOTE: The SunJCE provider does not supply an implementation of the ExemptionMechanismSpi class.)

  • Step 1: Write and Compile Your Application Code
  • Step 2: Create a Permission Policy File Granting Appropriate Cryptographic Permissions
  • Step 3: Prepare for Testing
    • Step 3a: Apply for Government Approval From the Government Mandating Restrictions.
    • Step 3b: Get a Code-Signing Certificate
    • Step 3c: Bundle the Application and Permission Policy File into a JAR file
    • Step 3d: Sign the JAR file
    • Step 3e: Set Up Your Environment Like That of a User in a Restricted Country
    • Step 3f: (only for applications using exemption mechanisms) Install a Provider Implementing the Exemption Mechanism Specified by the entry in the Permission Policy File
  • Step 4: Test Your Application
  • Step 5: Apply for U.S. Government Export Approval If Required
  • Step 6: Deploy Your Application

Special Code Requirements for Applications that Use Exemption Mechanisms

When an application has a permission policy file associated with it (in the same JAR file) and that permission policy file specifies an exemption mechanism, then when the Cipher getInstance method is called to instantiate a Cipher, the JCA code searches the installed providers for one that implements the specified exemption mechanism. If it finds such a provider, JCA instantiates an ExemptionMechanism API object associated with the provider's implementation, and then associates the ExemptionMechanism object with the Cipher returned by getInstance.

After instantiating a Cipher, and prior to initializing it (via a call to the Cipher init method), your code must call the following Cipher method:

    public ExemptionMechanism getExemptionMechanism()

This call returns the ExemptionMechanism object associated with the Cipher. You must then initialize the exemption mechanism implementation by calling the following method on the returned ExemptionMechanism:

    public final void init(Key key)

The argument you supply should be the same as the argument of the same types that you will subsequently supply to a Cipher init method.

Once you have initialized the ExemptionMechanism, you can proceed as usual to initialize and use the Cipher.

Permission Policy Files

In order for an application to be recognized at runtime as being "exempt" from some or all cryptographic restrictions, it must have a permission policy file bundled with it in a JAR file. The permission policy file specifies what cryptography-related permissions the application has, and under what conditions (if any).

NOTE: The permission policy file bundled with an application must be named cryptoPerms.

The format of a permission entry in a permission policy file that accompanies an exempt application is the same as the format for a jurisdiction policy file downloaded with the JDK, which is:

    permission <crypto permission class name>[ <alg_name>
        [[, <exemption mechanism name>][, <maxKeySize>
        [, <AlgorithmParameterSpec class name>,
        <parameters for constructing an AlgorithmParameterSpec object>
        ]]]];

See Appendix B for more information about the jurisdiction policy file format.

Permission Policy Files for Exempt Applications

Some applications may be allowed to be completely unrestricted. Thus, the permission policy file that accompanies such an application usually just needs to contain the following:

    grant {
        // There are no restrictions to any algorithms.
        permission javax.crypto.CryptoAllPermission;
    };

If an application just uses a single algorithm (or several specific algorithms), then the permission policy file could simply mention that algorithm (or algorithms) explicitly, rather than granting CryptoAllPermission. For example, if an application just uses the Blowfish algorithm, the permission policy file doesn't have to grant CryptoAllPermission to all algorithms. It could just specify that there is no cryptographic restriction if the Blowfish algorithm is used. In order to do this, the permission policy file would look like the following:

    grant {
        permission javax.crypto.CryptoPermission "Blowfish";
    };

Permission Policy Files for Applications Exempt Due to Exemption Mechanisms

If an application is considered "exempt" if an exemption mechanism is enforced, then the permission policy file that accompanies the application must specify one or more exemption mechanisms. At runtime, the application will be considered exempt if any of those exemption mechanisms is enforced. Each exemption mechanism must be specified in a permission entry that looks like the following:

    // No algorithm restrictions if specified
    // exemption mechanism is enforced.
    permission javax.crypto.CryptoPermission *,
        "<ExemptionMechanismName>";

where <ExemptionMechanismName> specifies the name of an exemption mechanism. The list of possible exemption mechanism names includes:

  • KeyRecovery
  • KeyEscrow
  • KeyWeakening
As an example, suppose your application is exempt if either key recovery or key escrow is enforced. Then your permission policy file should contain the following:
    grant {
        // No algorithm restrictions if KeyRecovery is enforced.
        permission javax.crypto.CryptoPermission *,
            "KeyRecovery";
        // No algorithm restrictions if KeyEscrow is enforced.
        permission javax.crypto.CryptoPermission *,
            "KeyEscrow";
    };

NOTE: Permission entries that specify exemption mechanisms should not also specify maximum key sizes. The allowed key sizes are actually determined from the installed exempt jurisdiction policy files, as described in the next section.

How Bundled Permission Policy Files Affect Cryptographic Permissions

At runtime, when an application instantiates a Cipher (via a call to its getInstance method) and that application has an associated permission policy file, JCA checks to see whether the permission policy file has an entry that applies to the algorithm specified in the getInstance call. If it does, and the entry grants CryptoAllPermission or does not specify that an exemption mechanism must be enforced, it means there is no cryptographic restriction for this particular algorithm.

If the permission policy file has an entry that applies to the algorithm specified in the getInstance call and the entry does specify that an exemption mechanism must be enforced, then the exempt jurisdiction policy file(s) are examined. If the exempt permissions include an entry for the relevant algorithm and exemption mechanism, and that entry is implied by the permissions in the permission policy file bundled with the application, and if there is an implementation of the specified exemption mechanism available from one of the registered providers, then the maximum key size and algorithm parameter values for the Cipher are determined from the exempt permission entry.

If there is no exempt permission entry implied by the relevant entry in the permission policy file bundled with the application, or if there is no implementation of the specified exemption mechanism available from any of the registered providers, then the application is only allowed the standard default cryptographic permissions.

Code Examples

Here are some short examples which illustrate use of several of the JCA mechanisms. In addition, complete working examples can be found in Appendix D.

Computing a MessageDigest Object

First create the message digest object, as in the following example:

MessageDigest sha = MessageDigest.getInstance("SHA-1");
This call assigns a properly initialized message digest object to the sha variable. The implementation implements the Secure Hash Algorithm (SHA-1), as defined in the National Institute for Standards and Technology's (NIST) FIPS 180-2 document. See Appendix A for a complete discussion of standard names and algorithms.

Next, suppose we have three byte arrays, i1, i2 and i3, which form the total input whose message digest we want to compute. This digest (or "hash") could be calculated via the following calls:

sha.update(i1);
sha.update(i2);
sha.update(i3);
byte[] hash = sha.digest();

An equivalent alternative series of calls would be:

sha.update(i1);
sha.update(i2);
byte[] hash = sha.digest(i3);
After the message digest has been calculated, the message digest object is automatically reset and ready to receive new data and calculate its digest. All former state (i.e., the data supplied to update calls) is lost.

Some hash implementations may support intermediate hashes through cloning. Suppose we want to calculate separate hashes for:

  • i1
  • i1 and i2
  • i1, i2, and i3

A way to do it is:

/* compute the hash for i1 */
sha.update(i1);
byte[] i1Hash = sha.clone().digest();

/* compute the hash for i1 and i2 */
sha.update(i2);
byte[] i12Hash = sha.clone().digest();

/* compute the hash for i1, i2 and i3 */
sha.update(i3);
byte[] i123hash = sha.digest();
This code works only if the SHA-1 implementation is cloneable. While some implementations of message digests are cloneable, others are not. To determine whether or not cloning is possible, attempt to clone the MessageDigest object and catch the potential exception as follows:
try {
    // try and clone it
    /* compute the hash for i1 */
    sha.update(i1);
    byte[] i1Hash = sha.clone().digest();
    // ...
    byte[] i123hash = sha.digest();
} catch (CloneNotSupportedException cnse) {
    // do something else, such as the code shown below
}
If a message digest is not cloneable, the other, less elegant way to compute intermediate digests is to create several digests. In this case, the number of intermediate digests to be computed must be known in advance:
MessageDigest sha1 = MessageDigest.getInstance("SHA-1");
MessageDigest sha12 = MessageDigest.getInstance("SHA-1");
MessageDigest sha123 = MessageDigest.getInstance("SHA-1");

byte[] i1Hash = sha1.digest(i1);

sha12.update(i1);
byte[] i12Hash = sha12.digest(i2);

sha123.update(i1);
sha123.update(i2);
byte[] i123Hash = sha123.digest(i3);

Generating a Pair of Keys

In this example we will generate a public-private key pair for the algorithm named "DSA" (Digital Signature Algorithm), and use this keypair in future examples. We will generate keys with a 1024-bit modulus. We don't care which provider supplies the algorithm implementation.

Creating the Key Pair Generator

The first step is to get a key pair generator object for generating keys for the DSA algorithm:

KeyPairGenerator keyGen = KeyPairGenerator.getInstance("DSA");

Initializing the Key Pair Generator

The next step is to initialize the key pair generator. In most cases, algorithm-independent initialization is sufficient, but in some cases, algorithm-specific initialization is used.

Algorithm-Independent Initialization

All key pair generators share the concepts of a keysize and a source of randomness. The KeyPairGenerator class initialization methods at a minimum needs a keysize. If the source of randomness is not explicitly provided, a SecureRandom implementation of the highest-priority installed provider will be used. Thus to generate keys with a keysize of 1024, simply call:

SecureRandom random = SecureRandom.getInstance("SHA1PRNG", "SUN");
keyGen.initialize(1024, random);
The following code illustrates how to use a specific, additionally seeded SecureRandom object:
SecureRandom random = SecureRandom.getInstance("SHA1PRNG", "SUN");
random.setSeed(userSeed);
keyGen.initialize(1024, random);
Since no other parameters are specified when you call the above algorithm-independent initialize method, it is up to the provider what to do about the algorithm-specific parameters (if any) to be associated with each of the keys. The provider may use precomputed parameter values or may generate new values.

Algorithm-Specific Initialization

For situations where a set of algorithm-specific parameters already exists (such as "community parameters" in DSA), there are two initialize methods that have an AlgorithmParameterSpec argument. Suppose your key pair generator is for the "DSA" algorithm, and you have a set of DSA-specific parameters, p, q, and g, that you would like to use to generate your key pair. You could execute the following code to initialize your key pair generator (recall that DSAParameterSpec is an AlgorithmParameterSpec):

DSAParameterSpec dsaSpec = new DSAParameterSpec(p, q, g);
SecureRandom random = SecureRandom.getInstance("SHA1PRNG", "SUN");
random.setSeed(userSeed);
keyGen.initialize(dsaSpec, random);
NOTE: The parameter named p is a prime number whose length is the modulus length ("size"). Therefore, you don't need to call any other method to specify the modulus length.

Generating the Pair of Keys

The final step is actually generating the key pair. No matter which type of initialization was used (algorithm-independent or algorithm-specific), the same code is used to generate the key pair:

KeyPair pair = keyGen.generateKeyPair();

Generating and Verifying a Signature Using Generated Keys

The following signature generation and verification examples use the KeyPair generated in the key pair example above.

Generating a Signature

We first create a signature object:

Signature dsa = Signature.getInstance("SHA1withDSA");

Next, using the key pair generated in the key pair example, we initialize the object with the private key, then sign a byte array called data.

/* Initializing the object with a private key */
PrivateKey priv = pair.getPrivate();
dsa.initSign(priv);

/* Update and sign the data */
dsa.update(data);
byte[] sig = dsa.sign();

Verifying a Signature

Verifying the signature is straightforward. (Note that here we also use the key pair generated in the key pair example.)

/* Initializing the object with the public key */
PublicKey pub = pair.getPublic();
dsa.initVerify(pub);

/* Update and verify the data */
dsa.update(data);
boolean verifies = dsa.verify(sig);
System.out.println("signature verifies: " + verifies);

Generating/Verifying Signatures Using Key Specifications and KeyFactory

Suppose that, rather than having a public/private key pair (as, for example, was generated in the key pair example above), you simply have the components of your DSA private key: x (the private key), p (the prime), q (the sub-prime), and g (the base).

Further suppose you want to use your private key to digitally sign some data, which is in a byte array named someData. You would do the following steps, which also illustrate creating a key specification and using a key factory to obtain a PrivateKey from the key specification (initSign requires a PrivateKey):

DSAPrivateKeySpec dsaPrivKeySpec = new DSAPrivateKeySpec(x, p, q, g);

KeyFactory keyFactory = KeyFactory.getInstance("DSA");
PrivateKey privKey = keyFactory.generatePrivate(dsaPrivKeySpec);

Signature sig = Signature.getInstance("SHA1withDSA");
sig.initSign(privKey);
sig.update(someData);
byte[] signature = sig.sign();

Suppose Alice wants to use the data you signed. In order for her to do so, and to verify your signature, you need to send her three things:

  1. the data,
  2. the signature, and
  3. the public key corresponding to the private key you used to sign the data.

You can store the someData bytes in one file, and the signature bytes in another, and send those to Alice.

For the public key, assume, as in the signing example above, you have the components of the DSA public key corresponding to the DSA private key used to sign the data. Then you can create a DSAPublicKeySpec from those components:

DSAPublicKeySpec dsaPubKeySpec = new DSAPublicKeySpec(y, p, q, g);

You still need to extract the key bytes so that you can put them in a file. To do so, you can first call the generatePublic method on the DSA key factory already created in the example above:

PublicKey pubKey = keyFactory.generatePublic(dsaPubKeySpec);
Then you can extract the (encoded) key bytes via the following:
byte[] encKey = pubKey.getEncoded();

You can now store these bytes in a file, and send it to Alice along with the files containing the data and the signature.

Now, assume Alice has received these files, and she copied the data bytes from the data file to a byte array named data, the signature bytes from the signature file to a byte array named signature, and the encoded public key bytes from the public key file to a byte array named encodedPubKey.

Alice can now execute the following code to verify the signature. The code also illustrates how to use a key factory in order to instantiate a DSA public key from its encoding (initVerify requires a PublicKey).

    X509EncodedKeySpec pubKeySpec = new X509EncodedKeySpec(encodedPubKey);

    KeyFactory keyFactory = KeyFactory.getInstance("DSA");
    PublicKey pubKey = keyFactory.generatePublic(pubKeySpec);

    Signature sig = Signature.getInstance("SHA1withDSA");
    sig.initVerify(pubKey);
    sig.update(data);
    sig.verify(signature);
NOTE: In the above, Alice needed to generate a PublicKey from the encoded key bits, since initVerify requires a PublicKey. Once she has a PublicKey, she could also use the KeyFactory getKeySpec method to convert it to a DSAPublicKeySpec so that she can access the components, if desired, as in:
    DSAPublicKeySpec dsaPubKeySpec =
        (DSAPublicKeySpec)keyFactory.getKeySpec(pubKey,
            DSAPublicKeySpec.class)

Now she can access the DSA public key components y, p, q, and g through the corresponding "get" methods on the DSAPublicKeySpec class (getY, getP, getQ, and getG).

Determining If Two Keys Are Equal

In many cases you would like to know if two keys are equal; however, the default method java.lang.Object.equals may not give the desired result. The most provider-independent approach is to compare the encoded keys. If this comparison isn't appropriate (for example, when comparing an RSAPrivateKey and an RSAPrivateCrtKey), you should compare each component. The following code demonstrates this idea:

static boolean keysEqual(Key key1, Key key2) {
    if (key1.equals(key2)) {
        return true;
    }

    if (Arrays.equals(key1.getEncoded(), key2.getEncoded())) {
        return true;
    }

    // More code for different types of keys here.
    // For example, the following code can check if
    // an RSAPrivateKey and an RSAPrivateCrtKey are equal:
    // if ((key1 instanceof RSAPrivateKey) &&
    //     (key2 instanceof RSAPrivateKey)) {
    //     if ((key1.getModulus().equals(key2.getModulus())) &&
    //         (key1.getPrivateExponent().equals(
    //                                      key2.getPrivateExponent()))) {
    //         return true;
    //     }
    // }

    return false;
}

Reading Base64-Encoded Certificates

The following example reads a file with Base64-encoded certificates, which are each bounded at the beginning by

-----BEGIN CERTIFICATE-----
and at the end by
-----END CERTIFICATE-----
We convert the FileInputStream (which does not support mark and reset) to a ByteArrayInputStream (which supports those methods), so that each call to generateCertificate consumes only one certificate, and the read position of the input stream is positioned to the next certificate in the file:
FileInputStream fis = new FileInputStream(filename);
BufferedInputStream bis = new BufferedInputStream(fis);

CertificateFactory cf = CertificateFactory.getInstance("X.509");

while (bis.available() > 0) {
    Certificate cert = cf.generateCertificate(bis);
    System.out.println(cert.toString());
}

Parsing a Certificate Reply

The following example parses a PKCS7-formatted certificate reply stored in a file and extracts all the certificates from it:

FileInputStream fis = new FileInputStream(filename);
CertificateFactory cf = CertificateFactory.getInstance("X.509");
Collection c = cf.generateCertificates(fis);
Iterator i = c.iterator();
while (i.hasNext()) {
   Certificate cert = (Certificate)i.next();
   System.out.println(cert);
}

Using Encryption

This section takes the user through the process of generating a key, creating and initializing a cipher object, encrypting a file, and then decrypting it. Throughout this example, we use the Advanced Encryption Standard (AES).

Generating a Key

To create an AES key, we have to instantiate a KeyGenerator for AES. We do not specify a provider, because we do not care about a particular AES key generation implementation. Since we do not initialize the KeyGenerator, a system-provided source of randomness and a default keysize will be used to create the AES key:

    KeyGenerator keygen = KeyGenerator.getInstance("AES");
    SecretKey aesKey = keygen.generateKey();

After the key has been generated, the same KeyGenerator object can be re-used to create further keys.

Creating a Cipher

The next step is to create a Cipher instance. To do this, we use one of the getInstance factory methods of the Cipher class. We must specify the name of the requested transformation, which includes the following components, separated by slashes (/):

  • the algorithm name
  • the mode (optional)
  • the padding scheme (optional)

In this example, we create an AES cipher in Electronic Codebook mode, with PKCS5-style padding. We do not specify a provider, because we do not care about a particular implementation of the requested transformation.

The standard algorithm name for AES is "AES", the standard name for the Electronic Codebook mode is "ECB", and the standard name for PKCS5-style padding is "PKCS5Padding":

    Cipher aesCipher;

    // Create the cipher
    aesCipher = Cipher.getInstance("AES/ECB/PKCS5Padding");

We use the generated aesKey from above to initialize the Cipher object for encryption:

    // Initialize the cipher for encryption
    aesCipher.init(Cipher.ENCRYPT_MODE, aesKey);

    // Our cleartext
    byte[] cleartext = "This is just an example".getBytes();

    // Encrypt the cleartext
    byte[] ciphertext = aesCipher.doFinal(cleartext);

    // Initialize the same cipher for decryption
    aesCipher.init(Cipher.DECRYPT_MODE, aesKey);

    // Decrypt the ciphertext
    byte[] cleartext1 = aesCipher.doFinal(ciphertext);

cleartext and cleartext1 are identical.

Using Password-Based Encryption

In this example, we prompt the user for a password from which we derive an encryption key.

It would seem logical to collect and store the password in an object of type java.lang.String. However, here's the caveat: Objects of type String are immutable, i.e., there are no methods defined that allow you to change (overwrite) or zero out the contents of a String after usage. This feature makes String objects unsuitable for storing security sensitive information such as user passwords. You should always collect and store security sensitive information in a char array instead.

For that reason, the javax.crypto.spec.PBEKeySpec class takes (and returns) a password as a char array. See the ReadPassword class in the sample code in Appendix D for one possible way of reading character array passwords from an input stream.

In order to use Password-Based Encryption (PBE) as defined in PKCS5, we have to specify a salt and an iteration count. The same salt and iteration count that are used for encryption must be used for decryption. Newer PBE algorithms use an iteration count of atleast 1000.

            PBEKeySpec pbeKeySpec;
            PBEParameterSpec pbeParamSpec;
            SecretKeyFactory keyFac;

            // Salt
            byte[] salt = {
                (byte)0xc7, (byte)0x73, (byte)0x21, (byte)0x8c,
                (byte)0x7e, (byte)0xc8, (byte)0xee, (byte)0x99
            };

            // Iteration count
            int count = 1000;

            // Create PBE parameter set
            pbeParamSpec = new PBEParameterSpec(salt, count);

            // Prompt user for encryption password.
            // Collect user password as char array (using the
            // "readPassword" method from above), and convert
            // it into a SecretKey object, using a PBE key
            // factory.
            System.out.print("Enter encryption password:  ");
            System.out.flush();
            pbeKeySpec = new PBEKeySpec(readPassword(System.in));
            keyFac = SecretKeyFactory.getInstance("PBEWithHmacSHA256AndAES_256");
            SecretKey pbeKey = keyFac.generateSecret(pbeKeySpec);

            // Create PBE Cipher
            Cipher pbeCipher = Cipher.getInstance("PBEWithHmacSHA256AndAES_256");

            // Initialize PBE Cipher with key and parameters
            pbeCipher.init(Cipher.ENCRYPT_MODE, pbeKey, pbeParamSpec);

            // Our cleartext
            byte[] cleartext = "This is another example".getBytes();

            // Encrypt the cleartext
            byte[] ciphertext = pbeCipher.doFinal(cleartext);

Using Key Agreement

Please refer to Appendix D for sample programs exercising the Diffie-Hellman key exchange between 2 and 3 parties.

Appendix A: Standard Names

The JDK Security API requires and uses a set of standard names for algorithms, certificate and keystore types. The specification names previously found here in Appendix A and in the other security specifications (JSSE/CertPath/etc.) have been combined in the Standard Names document. This document also contains more information about the algorithm specifications. Specific provider information can be found in the Sun Provider Documentation.

Cryptographic implementations in the JDK are distributed through several different providers primarily for historical reasons (Sun, SunJSSE, SunJCE, SunRsaSign). Note these providers may not be available on all JDK implementations, and therefore, truly portable applications should call getInstance() without specifying specific providers. Applications specifying a particular provider may not be able to take advantage of native providers tuned for an underlying operating environment (such as PKCS or Microsoft's CAPI).

The SunPKCS11 provider itself does not contain any cryptographic algorithms, but instead, directs requests into an underlying PKCS11 implementation. The PKCS11 Reference Guide and the underlying PKCS11 implementation should be consulted to determine if a desired algorithm will be available through the PKCS11 provider. Likewise, on Windows systems, the SunMSCAPI provider does not provide any cryptographic functionality, but instead routes requests to the underlying Operating System for handling.

Appendix B: Jurisdiction Policy File Format

JCA represents its jurisdiction policy files as Java style policy files with corresponding permission statements. As described in Default Policy Implementation and Policy File Syntax, a Java policy file specifies what permissions are allowed for code from specified code sources. A permission represents access to a system resource. In the case of JCA, the "resources" are cryptography algorithms, and code sources do not need to be specified, because the cryptographic restrictions apply to all code.

A jurisdiction policy file consists of a very basic "grant entry" containing one or more "permission entries."

grant {
    <permission entries>;
};

The format of a permission entry in a jurisdiction policy file is:

permission <crypto permission class name>[ <alg_name>
    [[, <exemption mechanism name>][, <maxKeySize>
    [, <AlgorithmParameterSpec class name>,
    <parameters for constructing an
        AlgorithmParameterSpec object>]]]];

A sample jurisdiction policy file that includes restricting the "Blowfish" algorithm to maximum key sizes of 64 bits is:

    grant {
        permission javax.crypto.CryptoPermission "Blowfish", 64;
        // ...
    };

A permission entry must begin with the word permission. The <crypto permission class name> in the template above would actually be a specific permission class name, such as javax.crypto.CryptoPermission. A crypto permission class reflects the ability of an application/applet to use certain algorithms with certain key sizes in certain environments. There are two crypto permission classes: CryptoPermission and CryptoAllPermission. The special CryptoAllPermission class implies all cryptography-related permissions, that is, it specifies that there are no cryptography-related restrictions.

The <alg_name>, when utilized, is a quoted string specifying the standard name (see Appendix A) of a cryptography algorithm, such as "DES" or "RSA".

The <exemption mechanism name>, when specified, is a quoted string indicating an exemption mechanism which, if enforced, enables a reduction in cryptographic restrictions. Exemption mechanism names that can be used include "KeyRecovery" "KeyEscrow", and "KeyWeakening".

<maxKeySize> is an integer specifying the maximum key size (in bits) allowed for the specified algorithm.

For some algorithms it may not be sufficient to specify the algorithm strength in terms of just a key size. For example, in the case of the "RC5" algorithm, the number of rounds must also be considered. For algorithms whose strength needs to be expressed as more than a key size, the permission entry should also specify an AlgorithmParameterSpec class name (such as javax.crypto.spec.RC5ParameterSpec) and a list of parameters for constructing the specified AlgorithmParameterSpec object.

Items that appear in a permission entry must appear in the specified order. An entry is terminated with a semicolon.

Case is unimportant for the identifiers (grant, permission) but is significant for the <crypto permission class name> or for any string that is passed in as a value.

NOTE: An "*" can be used as a wildcard for any permission entry option. For example, an "*" (without the quotes) for an <alg_name> option means "all algorithms."

Appendix C: Maximum Key Sizes Allowed by "Strong" Jurisdiction Policy Files

Due to import control restrictions, the jurisdiction policy files shipped with the Java SE Development Kit allow "strong" but limited cryptography to be used. For more info, please see Import Limits on Cryptographic Algorithms.

Appendix D: Sample Programs

Diffie-Hellman Key Exchange between 2 Parties

/*
 * Copyright (c) 1997, 2001, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.io.*;
import java.math.BigInteger;
import java.security.*;
import java.security.spec.*;
import java.security.interfaces.*;
import javax.crypto.*;
import javax.crypto.spec.*;
import javax.crypto.interfaces.*;
import com.sun.crypto.provider.SunJCE;

/**
 * This program executes the Diffie-Hellman key agreement protocol
 * between 2 parties: Alice and Bob.
 *
 * By default, preconfigured parameters (1024-bit prime modulus and base
 * generator used by SKIP) are used.
 * If this program is called with the "-gen" option, a new set of
 * parameters is created.
 */

public class DHKeyAgreement2 {

    private DHKeyAgreement2() {}

    public static void main(String argv[]) {
        try {
            String mode = "USE_SKIP_DH_PARAMS";

            DHKeyAgreement2 keyAgree = new DHKeyAgreement2();

            if (argv.length > 1) {
                keyAgree.usage();
                throw new Exception("Wrong number of command options");
            } else if (argv.length == 1) {
                if (!(argv[0].equals("-gen"))) {
                    keyAgree.usage();
                    throw new Exception("Unrecognized flag: " + argv[0]);
                }
                mode = "GENERATE_DH_PARAMS";
            }

            keyAgree.run(mode);
        } catch (Exception e) {
            System.err.println("Error: " + e);
            System.exit(1);
        }
    }

    private void run(String mode) throws Exception {

        DHParameterSpec dhSkipParamSpec;

        if (mode.equals("GENERATE_DH_PARAMS")) {
            // Some central authority creates new DH parameters
            System.out.println
                ("Creating Diffie-Hellman parameters (takes VERY long) ...");
            AlgorithmParameterGenerator paramGen
                = AlgorithmParameterGenerator.getInstance("DH");
            paramGen.init(512);
            AlgorithmParameters params = paramGen.generateParameters();
            dhSkipParamSpec = (DHParameterSpec)params.getParameterSpec
                (DHParameterSpec.class);
        } else {
            // use some pre-generated, default DH parameters
            System.out.println("Using SKIP Diffie-Hellman parameters");
            dhSkipParamSpec = new DHParameterSpec(skip1024Modulus,
                                                  skip1024Base);
        }

        /*
         * Alice creates her own DH key pair, using the DH parameters from
         * above
         */
        System.out.println("ALICE: Generate DH keypair ...");
        KeyPairGenerator aliceKpairGen = KeyPairGenerator.getInstance("DH");
        aliceKpairGen.initialize(dhSkipParamSpec);
        KeyPair aliceKpair = aliceKpairGen.generateKeyPair();

        // Alice creates and initializes her DH KeyAgreement object
        System.out.println("ALICE: Initialization ...");
        KeyAgreement aliceKeyAgree = KeyAgreement.getInstance("DH");
        aliceKeyAgree.init(aliceKpair.getPrivate());

        // Alice encodes her public key, and sends it over to Bob.
        byte[] alicePubKeyEnc = aliceKpair.getPublic().getEncoded();

        /*
         * Let's turn over to Bob. Bob has received Alice's public key
         * in encoded format.
         * He instantiates a DH public key from the encoded key material.
         */
        KeyFactory bobKeyFac = KeyFactory.getInstance("DH");
        X509EncodedKeySpec x509KeySpec = new X509EncodedKeySpec
            (alicePubKeyEnc);
        PublicKey alicePubKey = bobKeyFac.generatePublic(x509KeySpec);

        /*
         * Bob gets the DH parameters associated with Alice's public key.
         * He must use the same parameters when he generates his own key
         * pair.
         */
        DHParameterSpec dhParamSpec = ((DHPublicKey)alicePubKey).getParams();

        // Bob creates his own DH key pair
        System.out.println("BOB: Generate DH keypair ...");
        KeyPairGenerator bobKpairGen = KeyPairGenerator.getInstance("DH");
        bobKpairGen.initialize(dhParamSpec);
        KeyPair bobKpair = bobKpairGen.generateKeyPair();

        // Bob creates and initializes his DH KeyAgreement object
        System.out.println("BOB: Initialization ...");
        KeyAgreement bobKeyAgree = KeyAgreement.getInstance("DH");
        bobKeyAgree.init(bobKpair.getPrivate());

        // Bob encodes his public key, and sends it over to Alice.
        byte[] bobPubKeyEnc = bobKpair.getPublic().getEncoded();

        /*
         * Alice uses Bob's public key for the first (and only) phase
         * of her version of the DH
         * protocol.
         * Before she can do so, she has to instantiate a DH public key
         * from Bob's encoded key material.
         */
        KeyFactory aliceKeyFac = KeyFactory.getInstance("DH");
        x509KeySpec = new X509EncodedKeySpec(bobPubKeyEnc);
        PublicKey bobPubKey = aliceKeyFac.generatePublic(x509KeySpec);
        System.out.println("ALICE: Execute PHASE1 ...");
        aliceKeyAgree.doPhase(bobPubKey, true);

        /*
         * Bob uses Alice's public key for the first (and only) phase
         * of his version of the DH
         * protocol.
         */
        System.out.println("BOB: Execute PHASE1 ...");
        bobKeyAgree.doPhase(alicePubKey, true);

        /*
         * At this stage, both Alice and Bob have completed the DH key
         * agreement protocol.
         * Both generate the (same) shared secret.
         */
        byte[] aliceSharedSecret = aliceKeyAgree.generateSecret();
        int aliceLen = aliceSharedSecret.length;

        byte[] bobSharedSecret = new byte[aliceLen];
        int bobLen;
        try {
            // show example of what happens if you
            // provide an output buffer that is too short
            bobLen = bobKeyAgree.generateSecret(bobSharedSecret, 1);
        } catch (ShortBufferException e) {
            System.out.println(e.getMessage());
        }
        // provide output buffer of required size
        bobLen = bobKeyAgree.generateSecret(bobSharedSecret, 0);

        System.out.println("Alice secret: " +
          toHexString(aliceSharedSecret));
        System.out.println("Bob secret: " +
          toHexString(bobSharedSecret));

        if (!java.util.Arrays.equals(aliceSharedSecret, bobSharedSecret))
            throw new Exception("Shared secrets differ");
        System.out.println("Shared secrets are the same");

        /*
         * Now let's return the shared secret as a SecretKey object
         * and use it for encryption. First, we generate SecretKeys for the
         * "DES" algorithm (based on the raw shared secret data) and
         * then we use DES in ECB mode
         * as the encryption algorithm. DES in ECB mode does not require any
         * parameters.
         *
         * Then we use DES in CBC mode, which requires an initialization
         * vector (IV) parameter. In CBC mode, you need to initialize the
         * Cipher object with an IV, which can be supplied using the
         * javax.crypto.spec.IvParameterSpec class. Note that you have to use
         * the same IV for encryption and decryption: If you use a different
         * IV for decryption than you used for encryption, decryption will
         * fail.
         *
         * NOTE: If you do not specify an IV when you initialize the
         * Cipher object for encryption, the underlying implementation
         * will generate a random one, which you have to retrieve using the
         * javax.crypto.Cipher.getParameters() method, which returns an
         * instance of java.security.AlgorithmParameters. You need to transfer
         * the contents of that object (e.g., in encoded format, obtained via
         * the AlgorithmParameters.getEncoded() method) to the party who will
         * do the decryption. When initializing the Cipher for decryption,
         * the (reinstantiated) AlgorithmParameters object must be passed to
         * the Cipher.init() method.
         */
        System.out.println("Return shared secret as SecretKey object ...");
        // Bob
        // NOTE: The call to bobKeyAgree.generateSecret above reset the key
        // agreement object, so we call doPhase again prior to another
        // generateSecret call
        bobKeyAgree.doPhase(alicePubKey, true);
        SecretKey bobDesKey = bobKeyAgree.generateSecret("DES");

        // Alice
        // NOTE: The call to aliceKeyAgree.generateSecret above reset the key
        // agreement object, so we call doPhase again prior to another
        // generateSecret call
        aliceKeyAgree.doPhase(bobPubKey, true);
        SecretKey aliceDesKey = aliceKeyAgree.generateSecret("DES");

        /*
         * Bob encrypts, using DES in ECB mode
         */
        Cipher bobCipher = Cipher.getInstance("DES/ECB/PKCS5Padding");
        bobCipher.init(Cipher.ENCRYPT_MODE, bobDesKey);

        byte[] cleartext = "This is just an example".getBytes();
        byte[] ciphertext = bobCipher.doFinal(cleartext);

        /*
         * Alice decrypts, using DES in ECB mode
         */
        Cipher aliceCipher = Cipher.getInstance("DES/ECB/PKCS5Padding");
        aliceCipher.init(Cipher.DECRYPT_MODE, aliceDesKey);
        byte[] recovered = aliceCipher.doFinal(ciphertext);

        if (!java.util.Arrays.equals(cleartext, recovered))
            throw new Exception("DES in CBC mode recovered text is " +
              "different from cleartext");
        System.out.println("DES in ECB mode recovered text is " +
            "same as cleartext");

        /*
         * Bob encrypts, using DES in CBC mode
         */
        bobCipher = Cipher.getInstance("DES/CBC/PKCS5Padding");
        bobCipher.init(Cipher.ENCRYPT_MODE, bobDesKey);

        cleartext = "This is just an example".getBytes();
        ciphertext = bobCipher.doFinal(cleartext);
        // Retrieve the parameter that was used, and transfer it to Alice in
        // encoded format
        byte[] encodedParams = bobCipher.getParameters().getEncoded();

        /*
         * Alice decrypts, using DES in CBC mode
         */
        // Instantiate AlgorithmParameters object from parameter encoding
        // obtained from Bob
        AlgorithmParameters params = AlgorithmParameters.getInstance("DES");
        params.init(encodedParams);
        aliceCipher = Cipher.getInstance("DES/CBC/PKCS5Padding");
        aliceCipher.init(Cipher.DECRYPT_MODE, aliceDesKey, params);
        recovered = aliceCipher.doFinal(ciphertext);

        if (!java.util.Arrays.equals(cleartext, recovered))
            throw new Exception("DES in CBC mode recovered text is " +
              "different from cleartext");
        System.out.println("DES in CBC mode recovered text is " +
            "same as cleartext");
    }

    /*
     * Converts a byte to hex digit and writes to the supplied buffer
     */
    private void byte2hex(byte b, StringBuffer buf) {
        char[] hexChars = { '0', '1', '2', '3', '4', '5', '6', '7', '8',
                            '9', 'A', 'B', 'C', 'D', 'E', 'F' };
        int high = ((b & 0xf0) >> 4);
        int low = (b & 0x0f);
        buf.append(hexChars[high]);
        buf.append(hexChars[low]);
    }

    /*
     * Converts a byte array to hex string
     */
    private String toHexString(byte[] block) {
        StringBuffer buf = new StringBuffer();

        int len = block.length;

        for (int i = 0; i < len; i++) {
             byte2hex(block[i], buf);
             if (i < len-1) {
                 buf.append(":");
             }
        }
        return buf.toString();
    }

    /*
     * Prints the usage of this test.
     */
    private void usage() {
        System.err.print("DHKeyAgreement usage: ");
        System.err.println("[-gen]");
    }

    // The 1024 bit Diffie-Hellman modulus values used by SKIP
    private static final byte skip1024ModulusBytes[] = {
        (byte)0xF4, (byte)0x88, (byte)0xFD, (byte)0x58,
        (byte)0x4E, (byte)0x49, (byte)0xDB, (byte)0xCD,
        (byte)0x20, (byte)0xB4, (byte)0x9D, (byte)0xE4,
        (byte)0x91, (byte)0x07, (byte)0x36, (byte)0x6B,
        (byte)0x33, (byte)0x6C, (byte)0x38, (byte)0x0D,
        (byte)0x45, (byte)0x1D, (byte)0x0F, (byte)0x7C,
        (byte)0x88, (byte)0xB3, (byte)0x1C, (byte)0x7C,
        (byte)0x5B, (byte)0x2D, (byte)0x8E, (byte)0xF6,
        (byte)0xF3, (byte)0xC9, (byte)0x23, (byte)0xC0,
        (byte)0x43, (byte)0xF0, (byte)0xA5, (byte)0x5B,
        (byte)0x18, (byte)0x8D, (byte)0x8E, (byte)0xBB,
        (byte)0x55, (byte)0x8C, (byte)0xB8, (byte)0x5D,
        (byte)0x38, (byte)0xD3, (byte)0x34, (byte)0xFD,
        (byte)0x7C, (byte)0x17, (byte)0x57, (byte)0x43,
        (byte)0xA3, (byte)0x1D, (byte)0x18, (byte)0x6C,
        (byte)0xDE, (byte)0x33, (byte)0x21, (byte)0x2C,
        (byte)0xB5, (byte)0x2A, (byte)0xFF, (byte)0x3C,
        (byte)0xE1, (byte)0xB1, (byte)0x29, (byte)0x40,
        (byte)0x18, (byte)0x11, (byte)0x8D, (byte)0x7C,
        (byte)0x84, (byte)0xA7, (byte)0x0A, (byte)0x72,
        (byte)0xD6, (byte)0x86, (byte)0xC4, (byte)0x03,
        (byte)0x19, (byte)0xC8, (byte)0x07, (byte)0x29,
        (byte)0x7A, (byte)0xCA, (byte)0x95, (byte)0x0C,
        (byte)0xD9, (byte)0x96, (byte)0x9F, (byte)0xAB,
        (byte)0xD0, (byte)0x0A, (byte)0x50, (byte)0x9B,
        (byte)0x02, (byte)0x46, (byte)0xD3, (byte)0x08,
        (byte)0x3D, (byte)0x66, (byte)0xA4, (byte)0x5D,
        (byte)0x41, (byte)0x9F, (byte)0x9C, (byte)0x7C,
        (byte)0xBD, (byte)0x89, (byte)0x4B, (byte)0x22,
        (byte)0x19, (byte)0x26, (byte)0xBA, (byte)0xAB,
        (byte)0xA2, (byte)0x5E, (byte)0xC3, (byte)0x55,
        (byte)0xE9, (byte)0x2F, (byte)0x78, (byte)0xC7
    };

    // The SKIP 1024 bit modulus
    private static final BigInteger skip1024Modulus
    = new BigInteger(1, skip1024ModulusBytes);

    // The base used with the SKIP 1024 bit modulus
    private static final BigInteger skip1024Base = BigInteger.valueOf(2);
}

Diffie-Hellman Key Exchange between 3 Parties

/*
 * Copyright (c) 1997, 2001, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.io.*;
import java.math.BigInteger;
import java.security.*;
import java.security.spec.*;
import java.security.interfaces.*;
import javax.crypto.*;
import javax.crypto.spec.*;
import javax.crypto.interfaces.*;
import com.sun.crypto.provider.SunJCE;

/**
 * This program executes the Diffie-Hellman key agreement protocol
 * between 3 parties: Alice, Bob, and Carol.
 *
 * We use the same 1024-bit prime modulus and base generator that are
 * used by SKIP.
 */

public class DHKeyAgreement3 {

    private DHKeyAgreement3() {}

    public static void main(String argv[]) {
        try {
            DHKeyAgreement3 keyAgree = new DHKeyAgreement3();
            keyAgree.run();
        } catch (Exception e) {
            System.err.println("Error: " + e);
            System.exit(1);
        }
    }

    private void run() throws Exception {

        DHParameterSpec dhSkipParamSpec;

        System.out.println("Using SKIP Diffie-Hellman parameters");
        dhSkipParamSpec = new DHParameterSpec(skip1024Modulus, skip1024Base);

        // Alice creates her own DH key pair
        System.out.println("ALICE: Generate DH keypair ...");
        KeyPairGenerator aliceKpairGen = KeyPairGenerator.getInstance("DH");
        aliceKpairGen.initialize(dhSkipParamSpec);
        KeyPair aliceKpair = aliceKpairGen.generateKeyPair();

        // Bob creates his own DH key pair
        System.out.println("BOB: Generate DH keypair ...");
        KeyPairGenerator bobKpairGen = KeyPairGenerator.getInstance("DH");
        bobKpairGen.initialize(dhSkipParamSpec);
        KeyPair bobKpair = bobKpairGen.generateKeyPair();

        // Carol creates her own DH key pair
        System.out.println("CAROL: Generate DH keypair ...");
        KeyPairGenerator carolKpairGen = KeyPairGenerator.getInstance("DH");
        carolKpairGen.initialize(dhSkipParamSpec);
        KeyPair carolKpair = carolKpairGen.generateKeyPair();

        // Alice initialize
        System.out.println("ALICE: Initialize ...");
        KeyAgreement aliceKeyAgree = KeyAgreement.getInstance("DH");
        aliceKeyAgree.init(aliceKpair.getPrivate());

        // Bob initialize
        System.out.println("BOB: Initialize ...");
        KeyAgreement bobKeyAgree = KeyAgreement.getInstance("DH");
        bobKeyAgree.init(bobKpair.getPrivate());

        // Carol initialize
        System.out.println("CAROL: Initialize ...");
        KeyAgreement carolKeyAgree = KeyAgreement.getInstance("DH");
        carolKeyAgree.init(carolKpair.getPrivate());

        // Alice uses Carol's public key
        Key ac = aliceKeyAgree.doPhase(carolKpair.getPublic(), false);

        // Bob uses Alice's public key
        Key ba = bobKeyAgree.doPhase(aliceKpair.getPublic(), false);

        // Carol uses Bob's public key
        Key cb = carolKeyAgree.doPhase(bobKpair.getPublic(), false);

        // Alice uses Carol's result from above
        aliceKeyAgree.doPhase(cb, true);

        // Bob uses Alice's result from above
        bobKeyAgree.doPhase(ac, true);

        // Carol uses Bob's result from above
        carolKeyAgree.doPhase(ba, true);

        // Alice, Bob and Carol compute their secrets
        byte[] aliceSharedSecret = aliceKeyAgree.generateSecret();
        System.out.println("Alice secret: " + toHexString(aliceSharedSecret));

        byte[] bobSharedSecret = bobKeyAgree.generateSecret();
        System.out.println("Bob secret: " + toHexString(bobSharedSecret));

        byte[] carolSharedSecret = carolKeyAgree.generateSecret();
        System.out.println("Carol secret: " + toHexString(carolSharedSecret));

        // Compare Alice and Bob
        if (!java.util.Arrays.equals(aliceSharedSecret, bobSharedSecret))
            throw new Exception("Alice and Bob differ");
        System.out.println("Alice and Bob are the same");

        // Compare Bob and Carol
        if (!java.util.Arrays.equals(bobSharedSecret, carolSharedSecret))
            throw new Exception("Bob and Carol differ");
        System.out.println("Bob and Carol are the same");
    }

    /*
     * Converts a byte to hex digit and writes to the supplied buffer
     */
    private void byte2hex(byte b, StringBuffer buf) {
        char[] hexChars = { '0', '1', '2', '3', '4', '5', '6', '7', '8',
                            '9', 'A', 'B', 'C', 'D', 'E', 'F' };
        int high = ((b & 0xf0) >> 4);
        int low = (b & 0x0f);
        buf.append(hexChars[high]);
        buf.append(hexChars[low]);
    }

    /*
     * Converts a byte array to hex string
     */
    private String toHexString(byte[] block) {
        StringBuffer buf = new StringBuffer();

        int len = block.length;

        for (int i = 0; i < len; i++) {
             byte2hex(block[i], buf);
             if (i < len-1) {
                 buf.append(":");
             }
        }
        return buf.toString();
    }

    /*
     * Prints the usage of this test.
     */
    private void usage() {
        System.err.print("DHKeyAgreement usage: ");
        System.err.println("[-gen]");
    }

    // The 1024 bit Diffie-Hellman modulus values used by SKIP
    private static final byte skip1024ModulusBytes[] = {
        (byte)0xF4, (byte)0x88, (byte)0xFD, (byte)0x58,
        (byte)0x4E, (byte)0x49, (byte)0xDB, (byte)0xCD,
        (byte)0x20, (byte)0xB4, (byte)0x9D, (byte)0xE4,
        (byte)0x91, (byte)0x07, (byte)0x36, (byte)0x6B,
        (byte)0x33, (byte)0x6C, (byte)0x38, (byte)0x0D,
        (byte)0x45, (byte)0x1D, (byte)0x0F, (byte)0x7C,
        (byte)0x88, (byte)0xB3, (byte)0x1C, (byte)0x7C,
        (byte)0x5B, (byte)0x2D, (byte)0x8E, (byte)0xF6,
        (byte)0xF3, (byte)0xC9, (byte)0x23, (byte)0xC0,
        (byte)0x43, (byte)0xF0, (byte)0xA5, (byte)0x5B,
        (byte)0x18, (byte)0x8D, (byte)0x8E, (byte)0xBB,
        (byte)0x55, (byte)0x8C, (byte)0xB8, (byte)0x5D,
        (byte)0x38, (byte)0xD3, (byte)0x34, (byte)0xFD,
        (byte)0x7C, (byte)0x17, (byte)0x57, (byte)0x43,
        (byte)0xA3, (byte)0x1D, (byte)0x18, (byte)0x6C,
        (byte)0xDE, (byte)0x33, (byte)0x21, (byte)0x2C,
        (byte)0xB5, (byte)0x2A, (byte)0xFF, (byte)0x3C,
        (byte)0xE1, (byte)0xB1, (byte)0x29, (byte)0x40,
        (byte)0x18, (byte)0x11, (byte)0x8D, (byte)0x7C,
        (byte)0x84, (byte)0xA7, (byte)0x0A, (byte)0x72,
        (byte)0xD6, (byte)0x86, (byte)0xC4, (byte)0x03,
        (byte)0x19, (byte)0xC8, (byte)0x07, (byte)0x29,
        (byte)0x7A, (byte)0xCA, (byte)0x95, (byte)0x0C,
        (byte)0xD9, (byte)0x96, (byte)0x9F, (byte)0xAB,
        (byte)0xD0, (byte)0x0A, (byte)0x50, (byte)0x9B,
        (byte)0x02, (byte)0x46, (byte)0xD3, (byte)0x08,
        (byte)0x3D, (byte)0x66, (byte)0xA4, (byte)0x5D,
        (byte)0x41, (byte)0x9F, (byte)0x9C, (byte)0x7C,
        (byte)0xBD, (byte)0x89, (byte)0x4B, (byte)0x22,
        (byte)0x19, (byte)0x26, (byte)0xBA, (byte)0xAB,
        (byte)0xA2, (byte)0x5E, (byte)0xC3, (byte)0x55,
        (byte)0xE9, (byte)0x2F, (byte)0x78, (byte)0xC7
    };

    // The SKIP 1024 bit modulus
    private static final BigInteger skip1024Modulus
    = new BigInteger(1, skip1024ModulusBytes);

    // The base used with the SKIP 1024 bit modulus
    private static final BigInteger skip1024Base = BigInteger.valueOf(2);
}

Blowfish Cipher Example

/*
 * Copyright (c) 1997, 2001, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.security.*;
import javax.crypto.*;
import javax.crypto.spec.*;

/**
 * This program generates a Blowfish key, retrieves its raw bytes, and
 * then reinstantiates a Blowfish key from the key bytes.
 * The reinstantiated key is used to initialize a Blowfish cipher for
 * encryption.
 */

public class BlowfishKey {

    public static void main(String[] args) throws Exception {

        KeyGenerator kgen = KeyGenerator.getInstance("Blowfish");
        SecretKey skey = kgen.generateKey();
        byte[] raw = skey.getEncoded();
        SecretKeySpec skeySpec = new SecretKeySpec(raw, "Blowfish");

        Cipher cipher = Cipher.getInstance("Blowfish");
        cipher.init(Cipher.ENCRYPT_MODE, skeySpec);
        byte[] encrypted =
            cipher.doFinal("This is just an example".getBytes());
    }
}

HMAC-MD5 Example

/*
 * Copyright (c) 1997, 2001, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

import java.security.*;
import javax.crypto.*;

/**
 * This program demonstrates how to generate a secret-key object for
 * HMAC-MD5, and initialize an HMAC-MD5 object with it.
 */

public class initMac {

    public static void main(String[] args) throws Exception {

        // Generate secret key for HMAC-MD5
        KeyGenerator kg = KeyGenerator.getInstance("HmacMD5");
        SecretKey sk = kg.generateKey();

        // Get instance of Mac object implementing HMAC-MD5, and
        // initialize it with the above secret key
        Mac mac = Mac.getInstance("HmacMD5");
        mac.init(sk);
        byte[] result = mac.doFinal("Hi There".getBytes());
    }
}

Reading ASCII Passwords From an InputStream Example

/*
 * @(#)ReadPassword.java  1.1 06/06/07
 *
 * Copyright (c) 2006, Oracle and/or its affiliates. All rights reserved.
 * ORACLE PROPRIETARY/CONFIDENTIAL. Use is subject to license terms.
 */

import java.util.*;
import java.io.*;
import java.security.*;

public class ReadPassword {
    /**
     * Read a password from the InputStream "in".
     * <p>
     * As Strings are immutable, passwords should be stored as an array
     * of characters, which can be blanked out when no longer needed.
     * <p>
     * If the provided InputStream is the System's Console, this method
     * uses the non-echoing readPassword() method of java.io.Console
     * (new to JDK 6).  If not, a fallback implementation is used.
     * <p>
     * NOTE:  For expository purposes, and because some applications do
     * not understand multi-byte characters, only 8-bit ASCII passwords
     * are handled here.
     * <p>
     * NOTE:  If a SecurityManager is used, the default standard
     * java.policy file found in the JDK (i.e.
     * <java-home>/lib/security/java.policy) allows reading the
     * line.separator property.  If your environment is different, this
     * code will need to be granted the appropriate privilege.
     *
     * @param   in
     *          the InputStream used to obtain the password.
     *
     * @return  A character array containing the password or passphrase,
     *          not including the line-termination characters,
     *          or null if an end of stream has been reached.
     *
     * @throws  IOException
     *          if an I/O problem occurs
     */
    public static final char[] readPassword(InputStream in)
            throws IOException {

        /*
         * If available, directly use the java.io.Console class to
         * avoid character echoing.
         */
        if (in == System.in && System.console() != null) {
            // readPassword returns "" if you just print ENTER,
            return System.console().readPassword();
        }

        /*
         * If a console is not available, read the InputStream
         * directly.  This approach may cause password echoing.
         *
         * Since different operating systems have different End-Of-Line
         * (EOL) sequences, this algorithm should allow for
         * platform-independent implementations.  Typical EOL sequences
         * are a single line feed ('\n'), or a carriage return/linefeed
         * combination ('\r\n').  However, some OS's use a single
         * a carriage return ('\r'), which complicates portability.
         *
         * Since we may not have the ability to push bytes back into the
         * InputStream, another approach is used here.  The javadoc for
         * <code>java.lang.System.getProperties()</code> specifies that
         * the set of system properties will contain a system-specific
         * value for the "line.separator".  Scan for this character
         * sequence instead of hard-coding a particular sequence.
         */

        /*
         * Enclose the getProperty in a doPrivileged block to minimize
         * the call stack permission required.
         */
        char [] EOL = AccessController.doPrivileged(
            new PrivilegedAction<char[]>() {
                public char[] run() {
                    String s = System.getProperty("line.separator");
                    // Shouldn't happen.
                    if (s == null) {
                        throw new RuntimeException(
                            "line.separator not defined");
                    }
                    return s.toCharArray();
                }
            });

        char [] buffer = new char[128];
        try {
            int len = 0;                // len of data in buffer.
            boolean done = false;       // found the EOL sequence
            int b;                      // byte read

            while (!done) {
                /*
                 * realloc if necessary
                 */
                if (len >= buffer.length) {
                    char [] newbuffer = new char[len + 128];
                    System.arraycopy(buffer, 0, newbuffer, 0, len);
                    Arrays.fill(buffer, ' ');
                    buffer = newbuffer;
                }

                /*
                 * End-of-Stream?
                 */
                if ((b = in.read()) == -1) {
                    // Return as much as we have, null otherwise.
                    if (len == 0) {
                        return null;
                    }
                    break;
                } else {
                    /*
                     * NOTE:  In the simple PBE example here,
                     * only 8 bit ASCII characters are handled.
                     */
                    buffer[len++] = (char) b;
                }

                /*
                 * check for the EOL sequence.  Do we have enough bytes?
                 */
                if (len >= EOL.length) {
                    int i = 0;
                    for (i = 0; i < EOL.length; i++) {
                        if (buffer[len - EOL.length + i] != EOL[i]) {
                            break;
                        }
                    }
                    done = (i == EOL.length);
                }
            }

            /*
             * If we found the EOL, strip the EOL chars.
             */
            char [] result = new char[done ? len - EOL.length : len];
            System.arraycopy(buffer, 0, result, 0, result.length);

            return result;
        } finally {
            /*
             * Zero out the buffer.
             */
            if (buffer != null) {
                Arrays.fill(buffer, ' ');
            }
        }
    }
}
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface org.w3c.dom.css.CSS2Properties (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSS2Properties

No usage of org.w3c.dom.css.CSS2Properties
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSCharsetRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSCharsetRule

No usage of org.w3c.dom.css.CSSCharsetRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSFontFaceRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSFontFaceRule

No usage of org.w3c.dom.css.CSSFontFaceRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSImportRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSImportRule

No usage of org.w3c.dom.css.CSSImportRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSMediaRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSMediaRule

No usage of org.w3c.dom.css.CSSMediaRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSPageRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSPageRule

No usage of org.w3c.dom.css.CSSPageRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSPrimitiveValue (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSPrimitiveValue

  • Packages that use CSSPrimitiveValue
    Package Description
    org.w3c.dom.css

    • Uses of CSSPrimitiveValue in org.w3c.dom.css

      Methods in org.w3c.dom.css that return CSSPrimitiveValue
      Modifier and Type Method and Description
      CSSPrimitiveValue RGBColor.getBlue()
      This attribute is used for the blue value of the RGB color.
      CSSPrimitiveValue Rect.getBottom()
      This attribute is used for the bottom of the rect.
      CSSPrimitiveValue RGBColor.getGreen()
      This attribute is used for the green value of the RGB color.
      CSSPrimitiveValue Rect.getLeft()
      This attribute is used for the left of the rect.
      CSSPrimitiveValue RGBColor.getRed()
      This attribute is used for the red value of the RGB color.
      CSSPrimitiveValue Rect.getRight()
      This attribute is used for the right of the rect.
      CSSPrimitiveValue Rect.getTop()
      This attribute is used for the top of the rect.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSRule

  • Packages that use CSSRule
    Package Description
    org.w3c.dom.css

    • Uses of CSSRule in org.w3c.dom.css

      Subinterfaces of CSSRule in org.w3c.dom.css
      Modifier and Type Interface and Description
      interface  CSSCharsetRule
      The CSSCharsetRule interface represents a @charset rule in a CSS style sheet.
      interface  CSSFontFaceRule
      The CSSFontFaceRule interface represents a @font-face rule in a CSS style sheet.
      interface  CSSImportRule
      The CSSImportRule interface represents a @import rule within a CSS style sheet.
      interface  CSSMediaRule
      The CSSMediaRule interface represents a @media rule in a CSS style sheet.
      interface  CSSPageRule
      The CSSPageRule interface represents a @page rule within a CSS style sheet.
      interface  CSSStyleRule
      The CSSStyleRule interface represents a single rule set in a CSS style sheet.
      interface  CSSUnknownRule
      The CSSUnknownRule interface represents an at-rule not supported by this user agent.
      Methods in org.w3c.dom.css that return CSSRule
      Modifier and Type Method and Description
      CSSRule CSSStyleSheet.getOwnerRule()
      If this style sheet comes from an @import rule, the ownerRule attribute will contain the CSSImportRule.
      CSSRule CSSRule.getParentRule()
      If this rule is contained inside another rule (e.g.
      CSSRule CSSStyleDeclaration.getParentRule()
      The CSS rule that contains this declaration block or null if this CSSStyleDeclaration is not attached to a CSSRule.
      CSSRule CSSRuleList.item(int index)
      Used to retrieve a CSS rule by ordinal index.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSRuleList (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSRuleList

  • Packages that use CSSRuleList
    Package Description
    org.w3c.dom.css

    • Uses of CSSRuleList in org.w3c.dom.css

      Methods in org.w3c.dom.css that return CSSRuleList
      Modifier and Type Method and Description
      CSSRuleList CSSStyleSheet.getCssRules()
      The list of all CSS rules contained within the style sheet.
      CSSRuleList CSSMediaRule.getCssRules()
      A list of all CSS rules contained within the media block.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSStyleDeclaration (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSStyleDeclaration

  • Packages that use CSSStyleDeclaration
    Package Description
    org.w3c.dom.css

    • Uses of CSSStyleDeclaration in org.w3c.dom.css

      Methods in org.w3c.dom.css that return CSSStyleDeclaration
      Modifier and Type Method and Description
      CSSStyleDeclaration ViewCSS.getComputedStyle(Element elt, String pseudoElt)
      This method is used to get the computed style as it is defined in [CSS2].
      CSSStyleDeclaration DocumentCSS.getOverrideStyle(Element elt, String pseudoElt)
      This method is used to retrieve the override style declaration for a specified element and a specified pseudo-element.
      CSSStyleDeclaration CSSStyleRule.getStyle()
      The declaration-block of this rule set.
      CSSStyleDeclaration CSSFontFaceRule.getStyle()
      The declaration-block of this rule.
      CSSStyleDeclaration ElementCSSInlineStyle.getStyle()
      The style attribute.
      CSSStyleDeclaration CSSPageRule.getStyle()
      The declaration-block of this rule.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSStyleRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSStyleRule

No usage of org.w3c.dom.css.CSSStyleRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSStyleSheet (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSStyleSheet

  • Packages that use CSSStyleSheet
    Package Description
    org.w3c.dom.css

    • Uses of CSSStyleSheet in org.w3c.dom.css

      Methods in org.w3c.dom.css that return CSSStyleSheet
      Modifier and Type Method and Description
      CSSStyleSheet DOMImplementationCSS.createCSSStyleSheet(String title, String media)
      Creates a new CSSStyleSheet.
      CSSStyleSheet CSSRule.getParentStyleSheet()
      The style sheet that contains this rule.
      CSSStyleSheet CSSImportRule.getStyleSheet()
      The style sheet referred to by this rule, if it has been loaded.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSUnknownRule (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSUnknownRule

No usage of org.w3c.dom.css.CSSUnknownRule
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSValue (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSValue

  • Packages that use CSSValue
    Package Description
    org.w3c.dom.css

    • Uses of CSSValue in org.w3c.dom.css

      Subinterfaces of CSSValue in org.w3c.dom.css
      Modifier and Type Interface and Description
      interface  CSSPrimitiveValue
      The CSSPrimitiveValue interface represents a single CSS value .
      interface  CSSValueList
      The CSSValueList interface provides the abstraction of an ordered collection of CSS values.
      Methods in org.w3c.dom.css that return CSSValue
      Modifier and Type Method and Description
      CSSValue CSSStyleDeclaration.getPropertyCSSValue(String propertyName)
      Used to retrieve the object representation of the value of a CSS property if it has been explicitly set within this declaration block.
      CSSValue CSSValueList.item(int index)
      Used to retrieve a CSSValue by ordinal index.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.CSSValueList (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.CSSValueList

No usage of org.w3c.dom.css.CSSValueList
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Description of the illustration custom_progress_jws.jpg

Documentation Contents

Custom progress indicator shown when starting a Java Web Start application.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Customizing the Loading Experience

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

14 Customizing the Loading Experience

This topic describes how the startup experience for Java applets and Java Web Start applications can be customized. Custom splash screens and custom progress indicators can be used.

This topic contains the following sections:

  • The RIA Loading Experience

  • The RIA Loading Process

  • Customization Options

  • Best Practices and Tips

14.1 The RIA Loading Experience

Java Rich Internet applications (RIAs) are downloaded over the internet and displayed to the end user. The speed of the download may vary depending on various criteria such as the size of the RIA JAR file, any external dependencies, and the speed of the internet connection.

When the RIA is being downloaded, by default, the RIA software (Java Plug-in and Java Web Start software) will display the standard progress indicators, such as the spinning Java logo and progress bars. End users may get impatient when confronted with large downloads. With improvements in RIA software technology in the Java SE 6 update 18 and Java SE 6 update 21 releases, you can keep the end user engaged by providing a creative, captivating, and meaningful RIA loading experience. You can customize the RIA loading experience in several ways as described next.

  • By providing a splash screen

  • By creating a customized loading progress indicator

  • By leveraging one progress indicator to reflect progress of RIA download and the loading of RIA-specific data

You can also use a combination of the above options to accomodate older versions of the Java Runtime Environment (JRE) software on the client machine.

Note: Certain customization options are specific to applets or to Java Web Start applications. Such cases will be identified in this topic.

14.2 The RIA Loading Process

This section describes the process by which RIAs are loaded.

RIA software initiates a series of steps to download, validate, and execute a RIA. The RIA loading process can be broadly broken down into the following stages. RIA software provides varying levels of progress-related feedback during these stages.

  • Initialization - During this stage, RIA software performs an assessment of the resources required to launch the RIA. The amount of work required to download, validate, and execute the RIA is indeterminate at this time.

  • Loading and validation - RIA software downloads the required resources (JAR files) over the Internet, if necessary. If the RIA has been previously cached, RIA software loads the resources from the local cache. RIA software validates the resources. Deterministic feedback is communicated by the RIA software during the resource loading and validation process. Deterministic feedback implies that percent completion rates are calculated and communicated by the RIA software.

  • RIA Execution - During this stage, RIA software executes the RIA. The RIA is now fully functional. The RIA can load application-specific data at this time.

14.3 Customization Options

To customize the appearance of your application, you can provide your own splash screen and progress indicator to be shown when the application is started.

14.3.1 Adding a Splash Screen

The simplest way to customize a RIA's loading experience is to provide a splash screen. Specify the image that should be displayed in the splash screen. No changes are required in the RIA itself. RIA software displays the splash screen when the RIA is being loaded and hides it when the RIA's resources have been downloaded and validated. See the following topics for more information:

  • Creating a Splash Screen for an Applet topic in the Java Tutorials to view an example

  • Java Web Start FAQ and the resources Element in JNLP File Syntax for information about adding a splash screen for a Java Web Start application

14.3.2 Implementing a Customized Loading Progress Indicator

You can replace the default loading progress indicator with a custom implementation that provides regular feedback about how the RIA is loading. Don't feel constrained by rectangular boxes or the use of the Swing JProgressBar component. You can develop a customized loading progress indicator that is meaningful to your RIA or web site. The loading progress indicator can use visual or non-visual means to keep the end user interested and engaged while the RIA is loading in the background.

See Customizing the Loading Experience topic in the Java Tutorials for step-by-step instructions and detailed examples. A few screenshots of loading progress indicators are shown next.

Default loading progress indicator for Java Web Start application

Figure 14-1 Default Progress Indicator

Description of Figure 14-1 follows
Description of "Figure 14-1 Default Progress Indicator"

Customized loading progress indicator for Java Web Start application

Figure 14-2 Custom Progress Indicator

Description of Figure 14-2 follows
Description of "Figure 14-2 Custom Progress Indicator"

Customized loading progress indicator for the Reversi JavaFX applet (black balls turn white as loading progresses)

Figure 14-3 Progress Indicator for Reversi Applet

Description of Figure 14-3 follows
Description of "Figure 14-3 Progress Indicator for Reversi Applet"

The following features enable varied customizations of the loading progress indicator for a RIA that is deployed by using JNLP technology:

  • The customized loading progress indicator can provide deterministic or non-deterministic feedback.

  • The customized loading progress indicator can provide visual or non-visual cues to communicate progress.

  • A single loading progress indicator can be developed to support applets and Java Web Start applications.

  • Multiple loading progress indicators can be defined as Java Network Launch Protocol (JNLP) extensions. The loading progress indicator specified in the RIA's main JNLP file takes precedence, if one is specified. Specify the extension to be displayed to avoid indeterministic behavior.

  • The customized loading progress indicator can be leveraged to also display progress when loading application-specific data. For example, if a RIA invokes web services to load initial application data, you can use the progress range of 0 - 75% to indicate status of RIA download, and use the range of 76% - 100% to indicate progress of a web service invocation that fetches application data.

  • Loading progress indicators for applets can perform the following operations:

    • Receive a reference to an instance of the java.applet.AppletStub class. This allows the loading progress indicator code to access the java.applet.AppletContext object to retrieve the applet's parameters.

    • Invoke JavaScript code in the applet's parent web page. A reference to the window can be retrieved as shown next.

      JSObject window = JSObject.getWindow(null);
window.call("someJavaScriptFunction", args);

The next few sections describe technical details about implementing a loading progress indicator.

14.3.3 The javax.jnlp.DownloadServiceListener Interface

A loading progress indicator class should implement the javax.jnlp.DownloadServiceListener interface.

14.3.4 Constructors of the Loading Progress Indicator Class

Specify the following constructors in the loading progress indicator class. The RIA software invokes the appropriate constructor depending on the capabilities of the JRE software on the client machine. In some cases, RIA software might not instantiate the loading progress indicator class if all resources are up-to-date.

  • Constructor without any parameters - This constructor should be specified in the loading progress indicator class for a Java Web Start application. This constructor can also be specified in the loading progress indicator class for an applet. If the RIA software invokes this constructor, the loading progress indicator UI will be displayed in a top level window such as a javax.swing.JFrame object.

  • Constructor with one parameter - This constructor has one parameter of type java.lang.Object. The Object argument can be typecast to an instance of the java.awt.Container class. This constructor is relevant to loading progress indicators for applets. If the RIA software (in this case, Java Plug-in software) invokes this constructor, the loading progress indicator UI will be displayed in the applet's container.

  • Constructor with two parameters - This constructor has two parameters of type java.lang.Object. The first Object argument can be typecast to an instance of the java.awt.Container class. The second Object argument can be typecast to an instance of the java.applet.AppletStub class. If the RIA software (in this case, Java Plug-in software) invokes this constructor, the loading progress indicator UI will be displayed in the applet's container. The loading progress indicator can access the java.applet.AppletContext object to customize the loading progress indicator further. This constructor is relevant to loading progress indicators for applets.

    When specifying the constructor with two parameters, it is better to also specify the single-parameter constructor to accomodate older versions of the client JRE software. The constructor with two parameters is invoked only when the client JRE software version is at least Java SE 6 update 21.

14.3.5 Methods of the javax.jnlp.DownloadServiceListener Interface

The loading progress indicator class should implement the following methods of the interface to receive and convey the latest progress information.

  • progress(URL url, String version, long readSoFar, long total, int overallPercent)

  • upgradingArchive(java.net.URL url, java.lang.String version, int patchPercent, int overallPercent)

  • validating(java.net.URL url, java.lang.String version, long entry, long total, int overallPercent) - When the loading progress indicator class is instantiated, this method is always invoked with an overallPercent value of 100.

Update progress information in the loading progress indicator based on the overallPercent values received in these methods.

14.3.6 Specifying the Custom Progress Indicator in the JNLP File

Include the following information in the RIA's Java Network Launch Protocol (JNLP) file to specify a loading progress indicator:

  • download="progress" attribute to indicate which JAR file contains the loading progress indicator class

  • progress-class attribute containing fully qualified name of the loading progress indicator class. This attribute can be defined as a part of the <applet-desc>, <application-desc>, or <component-desc> depending on how the RIA and the loading progress indicator are deployed.

A sample JNLP file for an applet is shown next.

<jnlp spec="1.0+" codebase="" href="">
...
 <resources>
 ...
 <jar href="MyApplet.jar" main="true" />
<jar href="CustomProgressIndicator.jar" download="progress" />
 </resources>

 <applet-desc
 name="MyFavoriteApplet"
 main-class="myAppletPackage.MyFavoriteApplet"
 progress-class="myCustomProgressPackage.MyCustomProgressIndicator"
 width="600"
 height="200">
 </applet-desc>
...
</jnlp>

14.3.7 How the RIA Software Communicates Progress

RIA software communicates progress information as follows:

  • RIA software instantiates loading progress indicator, if necessary. In some cases, when all resources are cached and up-to-date, the loading progress indicator may not be instantiated at all.

  • RIA software invokes the progress, upgradingArchive, validating methods several times with increasing values of overallPercent.

  • In some cases, when the resources are already cached and validated, RIA software may just invoke the constructor followed by a 100% completion message.

  • RIA software will always send a 100% completion message to the loading progress indicator.

14.4 Best Practices and Tips

  • Consider the fact that a splash screen or loading screen might not be displayed at all when a RIA is partially or completely cached.

  • When developing a customized loading progress indicator, consider the following items:

    • Keep the size of the loading progress indicator JAR file small. RIA resources are downloaded concurrently. If the loading progress indicator JAR file is large, then it might be downloaded at approximately the same time as other resources. In this case, the loading progress indicator might be displayed for a very short time or might not be displayed at all.

    • Limit the amount of resources required by the loading progress indicator. Avoid using ImageIO or service lookups as this can cause other resources to be downloaded.

    • A loading progress indicator can use the same top level window as the Java Web Start application itself. In this case, limit the amount of resources that are used when the application's constructor is invoked. Specify resource lookups in the application's main method instead.

    • A loading progress indicator can be integrated into the applet's UI. In this case, create a top level container, such as a javax.swing.JPanel object, and add it to the surfaceContainer object described previously. After the applet's resources have been completely downloaded, remove the top level container from the surfaceContainer object and add it to the applet itself.

    • A signed loading progress indicator implementation is required for a signed RIA.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Customizing the RIA Loading Experience

Documentation Contents

Customizing the Rich Internet Application Loading Experience

See Customizing the Loading Experience in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Rich Internet Applications Decision Guide

Documentation Contents

Rich Internet Applications Decision Guide

See Rich Internet Applications Decision Guide in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration default_progress_jws.jpg

Documentation Contents

Default progress indicator shown when starting a Java Web Start application.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration deploy_file_struc.png

Documentation Contents

Image shows the directory structure in two columns for the files and folders in a package for web deployment. The first column shows the folder named dist with a subfolder named web-files. The second column shows the names of files in the web-files folder: ColorfulCircles.html, ColorfulCircles.jar, and ColorfulCircles.jnlp.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Application Execution Modes

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

3 Application Execution Modes

This topic explains the different application execution modes that are available for deploying your Java and JavaFX applications.

One of the main features of the Java application model is that you can write one application and easily deploy it several different ways. The user can experience the same application running on the desktop, in a browser, or starting from a link in a browser.

However, differences exist among the execution modes and need to be considered while developing the application.

This topic contains the following sections:

  • Execution Modes

  • Understanding Feature Differences

3.1 Execution Modes

Table 3-1 describes the execution modes in which Java applications can be deployed.

Table 3-1 Java Execution Modes

Execution Mode | Description
Run as a standalone program | The application package is available on a local drive. Users launch it using a Java launcher, such as java -jar MyApp.jar, or by double-clicking the application JAR file.
Launched from a remote server using Java Web Start | Users click a link in a web page to start the application from a remote web server. Once downloaded, a Java Web Start application can also be started from a desktop shortcut.
Embedded in a browser | Java content is embedded in the web page and hosted on a remote web server.
Launched as a self-contained application | Application is installed on the local drive and runs as a standalone program using a private copy of the JRE. The application can be launched in the same way as other native applications for that operating system, for example, using a desktop shortcut or menu entry.

Each execution environment has its drawbacks. For example, for remote applications the loading phase can be very long because the application has to be loaded from the network. This is less of an issue for applications that run on a local drive.

3.2 Understanding Feature Differences

Figure 3-1 lists some of the features that behave differently in the different environments. The following sections describe the figure in more detail.

Figure 3-1 Features of Deployment Types

Description of Figure 3-1 follows
Description of "Figure 3-1 Features of Deployment Types"

3.2.1 Preloader Support for JavaFX Applications

The preloader is a small JavaFX application that receives notifications about application loading and initialization progress. The preloader is used with all execution modes, but depending on the execution mode, the preloader implementation receives a different set of events and optimal behavior may be different.

For example, in self-contained application or standalone execution mode or when launched from a shortcut, the preloader does not get any loading progress events, because there is nothing to load. See Chapter 13, "Preloaders for JavaFX Applications" for information about preloader implementation and differences in behavior.

3.2.2 Built-In Proxy Support

Properly packaged Java applications have proxy settings initialized according to JRE configuration settings. By default, proxy settings are taken from the current browser, if the application is embedded in a web page. Otherwise, system proxy settings are used. Proxy settings are initialized by default in all execution modes.

3.2.3 Desktop Integration via Shortcut

Most of the operating systems allow applications to simplify subsequent launches and integrate with the user's desktop by creating a desktop shortcut or adding a link to the programs menu or dock.

Built-in support for desktop shortcuts is available for self-contained and web-deployed applications.

3.2.4 Run in Sandbox

By default, Java applications that are launched from a browser or are embedded in a web page run in a restricted environment, known as a sandbox. Restricting applications to the sandbox provides the following benefits:

  • Users are protected against malicious code that could affect local files.

  • Enterprises are protected against code that could attempt to access or destroy data on networks.

Applications that are restricted to the sandbox cannot perform the following operations:

  • Access client resources such as the local file system, executable files, system clipboard, and printers.

  • Connect to or retrieve resources from any third-party server (in other words, any server other than the server it originated from).

  • Load native libraries.

  • Change the SecurityManager.

  • Create a ClassLoader.

  • Read certain system properties. See System Properties for a list of forbidden system properties.

3.2.5 Auto-Updates

Java applications that run in a browser or were earlier installed from a web page automatically check for updates to the application at the original location where the application is loaded. This check is made every time an application starts, and, by default, the update runs in the background. The application is automatically updated if updates are detected.

For standalone and self-contained applications, you are responsible for handling updates.

3.2.6 Deployment Toolkit

The Deployment Toolkit performs two important functions:

  • Simplifies web deployment of Java applications by managing updates.

  • Improves the user's experience while waiting for applications to start.

These two functions are connected, because the application startup phase is a critical component of user satisfaction. For example, the Deployment Toolkit verifies that the user has the JRE installed, and if not, it offers to install it before trying to run the application, requiring little effort on the user's part.

The Deployment Toolkit provides a JavaScript API and is only available for applications embedded in a web page or launched from a browser.

For more information about the Deployment Toolkit, see Chapter 19, "Deployment in the Browser."

3.2.7 Communicate to the Host Web Page

Applications that are embedded in a web page can communicate with the web page using JavaScript. To initiate communication, a JavaFX application must get the web context from the JavaFX HostServices API. For any other execution environment, an attempt to get a reference to web context returns null.

Example 3-1 shows an example of using JavaScript to go to a new page:

Example 3-1 Using JavaScript to Go to a New Page

final HostServices services = getHostServices();
JSObject js = services.getWebContext();
js.eval("window.location='http://javafx.com'");

For JavaFX applications, see Chapter 16, "Java and JavaScript" for information about using JavaScript to communicate with the browser.

For Java applets, see Invoking JavaScript Code From an Applet for information about using JavaScript to communicate with the browser.

3.2.8 Managing Platform Dependencies

To run Java content, a recent version of the JRE is required. Unless the application is self-contained, the JRE must be installed on the user's system.

If users do not have the required version of the JRE, they are directed to install it. However, situations exist in which system installations of the JRE and the auto-update functionality are not sufficient, for example:

  • The user does not have admin permissions to install the JRE.

  • The user requires an older version of the JRE for other applications.

  • You want to set the exact version of the JRE to be used by your application.

  • Your distribution channel disallows dependencies on external frameworks.

Deploying your application as a self-contained application resolves these issues. The JRE is included in the application package, and users do not need to install it separately. The self-contained application package can be as simple as a .zip file distribution, or it can be wrapped into an installable package using technology that is native to the target operating system. See the topic Section 5, "Packaging Basics" for more details about self-contained application packages.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

2 Getting Started

This topic describes the basics of deploying your Java and JavaFX applications.

This topic contains the following sections:

  • Basic Steps

  • Choose the Execution Environment

  • Create the Package

  • Create the Web Page

  • Distribute Your Application

  • Beyond the Basics

2.1 Basic Steps

Have an application ready to publish? Follow these steps for basic deployment:

  1. Decide how you want users to access and run your application.

    Applications can be deployed on a user's desktop, embedded in a web page, or launched from a browser.

  2. Create the application package.

    The application package consists of the JAR files needed to run your application, and the deployment descriptor or JNLP file for applications that are embedded in a web page or are launched from a browser. If your application is embedded in a web page or is launched from a browser, the JAR files must be signed with a valid signing certificate. A self-contained application package also includes the JRE needed.

  3. Set up the web page, if your application is embedded in a web page or is launched from a browser.

    The web page needs either HTML elements or JavaScript code to run an application embedded in the page. JavaScript code is needed to launch an application from the browser. The Java packaging tools generate JavaScript code for both types of execution, which you can copy into your web page.

  4. Copy the package to the location from which you want users to access it.

    A web server is typically used for applications embedded in a web page or launched from a browser. Desktop applications can be delivered directly to users or made available through an app store.

2.2 Choose the Execution Environment

Java and JavaFX applications can be run in multiple execution environments. How you want users to access your application determines how you deploy it. The following options are available:

  • Launch as a desktop application

    Users can start the application from the command line using the Java launcher, or by double-clicking the JAR file for the application.

  • Launch from a browser

    Users can download and start the application by clicking a link in the browser.

  • View in a web page

    The application starts when the web page is loaded.

Each environment has advantages and disadvantages. See Section 3.1, "Execution Modes" for more information.

2.3 Create the Package

By default, the Java packaging tools generate the following collection of files needed to run the application:

  • An application JAR file (or multiple JAR files for large applications)

    Applications that are embedded in a web page or launched from a browser must be signed with a valid signing certificate. The packaging tools or the jar command can be used to sign the JAR file.

  • A JNLP file with a deployment descriptor

    A deployment descriptor is an XML file that describes application components, platform requirements, and launch rules.

  • An HTML file containing JavaScript code to embed or launch applications from the web page

Applications can also be packaged as a platform-specific, self-contained application. Self-contained applications include all application resources, the JRE, and a launcher. These applications provide the same install and launch experience as native applications for the operating system.

Self-contained applications can be distributed as zip files or as installable packages: EXE or MSI for Windows; DMG, PKG, or mac.appStore for OS X, or RPM or DEB for Linux.

Self-contained applications provide the following benefits:

  • They resemble native applications for the target platform.

    Users install the application with an installer that is familiar to them, and launch it in the usual way.

  • They offer no-hassle compatibility.

    The version of JRE that is used by the application is controlled by the application developer.

  • They are easily deployed on fresh systems with no requirement for the JRE to be installed.

  • Deployment occurs with no need for admin permissions when using ZIP or user-level installers.

For more information, see Chapter 7, "Self-Contained Application Packaging."

2.3.1 Packaging Tools

Three different tools are available for packaging your application:

  • Section 2.3.1.1, "NetBeans IDE"

  • Section 2.3.1.2, "Ant Tasks"

  • Section 2.3.1.3, "Java Packager Command-Line Tool"

For more information about Java packaging, see Chapter 6, "Packaging Basics."

2.3.1.1 NetBeans IDE

If you use Netbeans IDE, then much of the work is done for you. Open Project Properties to specify preferred dimensions for your JavaFX application scene. Build the project with Clean and Build. The application package is generated in the dist folder. To test your application, open this folder in Windows Explorer and double-click the HTML, JNLP, or JAR file, depending on your execution environment.

To package a self-contained application, customize the build.xml script in the NetBeans IDE. For more information, see Section 7.3.2, "Basic Build."

2.3.1.2 Ant Tasks

If you are using another IDE, then you can add Java packaging as a post-build step, using Ant tasks that are included in the JDK. Example 2-1 shows an Ant package task for the JavaFX example Colorful Circles. Download the ColorfulCircles.zip file for the complete Colorful Circles example.

When you add the nativeBundles="all" attribute into the <fx:deploy> Ant task, all possible packages are created: a standalone application package, one or more self-contained application packages for the platform on which you are running, and a web deployment package. Installable packages are created based on the third-party software that is available at packaging time. For example, if you have both Inno Setup and WiX on Windows, then you get three packages: a folder with the application, an .exe installer file, and an .msi installer file. For more information, see Chapter 5, "Packaging Basics." A simple Ant task with the nativeBundles attribute is shown in Example 2-1.

Example 2-1 Ant Task to Produce All Packages for the ColorfulCircles Application

<taskdef resource="com/sun/javafx/tools/ant/antlib.xml"
        uri="javafx:com.sun.javafx.tools.ant"
        classpath="${javafx.sdk.path}/lib/ant-javafx.jar"/>

<fx:jar destfile="dist-web/ColorfulCircles.jar">
    <fx:application mainClass="colorfulcircles.ColorfulCircles"/>
    <fileset dir="build/classes/">
        <include name="**"/>
    </fileset>
</fx:jar>

<fx:deploy width="800" height="600" outdir="dist-web"
        outfile="ColorfulCircles" nativeBundles="all">
    <fx:info title="Colorful Circles"/>
    <fx:application name="Colorful Circles example"
            mainClass="colorfulcircles.ColorfulCircles"/>
    <fx:resources>
        <fx:fileset dir="dist-web" includes="ColorfulCircles.jar"/>
    </fx:resources>
</fx:deploy>

If your application will be embedded in a web page or launched from a browser, include the required JAR mainfest attributes in the <fx:jar> task and include an <fx:signjar> task.

2.3.1.3 Java Packager Command-Line Tool

If you cannot use Ant and prefer command-line tools, use the Java Packager tool that comes with the JDK. The Java Packager tool has several commands for packaging applications, described in Chapter 9, "The Java Packager Tool." For a quick test build, you can use the javapackager -makeall command, such as the one in Example 2-2. This command compiles source code and combines the javapackager -createjar and javapackager -deploy commands, with simplified options.

Example 2-2 javapackager -makeall Command to Build an Application

javapackager -makeall -appclass colorfulcircles.ColorfulCircles
    -name "Colorful Circles" -width 800 -height 600

As a command intended only to help to build simple projects quickly, the -makeall command supports a limited set of options to customize the command behavior. The -makeall command makes the following assumptions about input and output files:

  • Source and other resource files must be in a directory named src under the main project directory.

  • The resulting package is always generated to a directory named dist, and file names all start with the dist prefix.

  • By default, the -makeall command tries to build a self-contained application package. If this is not possible, the JAR, HTML, and JNLP files are generated so you can deploy to other execution modes.

Note:

For JavaFX applications that are embedded in a web page, stage width and height must always be specified.

When your application is ready to go live, use the -createjar and -deploy commands instead of the -makeall command. The -createjar and -deploy commands have considerably more options. Also use the -signjar command if your application is embedded in a web page or launched from a browser. You can create a self-contained application package with the -deploy command plus the -native option, for example:

javapackager -deploy -native -outdir packages -outfile ColorfulCircles
    -srcdir dist -srcfiles ColorfulCircles.jar
    -appclass colorfulcircles.ColorfulCircles

For more information, see Section Section 5.3.1, "Java Packaging Tools."

Tip:

For even more flexibility of options, use an Ant task instead of the Java Packager tool.

2.4 Create the Web Page

If your application is embedded in a web page or launched from a browser, you need to set up the web page that provides users with access to your application. The Java Plug-in is used to run an application embedded in the web page. Java Web Start is used to run an application that is launched from the browser.

You can use an <applet> or <object> element or JavaScript code for applications that are embedded in a web page and use the Java Plug-In to run. Use JavaScript code to create the link or button that calls Java Web Start to launch an application from the browser. The Java packaging tools generate JavaScript code for both types of execution, which you can copy into your web page.

The HTML page generated by the packaging tools is a simple test page for your application. It includes sample JavaScript code to launch and embed your application, which you can copy to your own web page. To avoid manual copying, consider using HTML templates for application packaging to insert the JavaScript code into an existing web page. For more information, see Section 5.7.4, "Web Page Templates."

2.5 Distribute Your Application

When you have your application package and any web pages that you are using, copy them to the appropriate location to make your application available to users.

  • If your application is embedded in a web page or launched from a browser, copy your package and the web page to the web server from which they will be loaded.

  • If your application is a desktop application, copy the application to the location from which users will download it. Self-contained applications provide installable packages and the required JRE, which makes it easier for users to install and run your application.

2.6 Beyond the Basics

This topic provides the minimum information needed to deploy a simple application, which makes use of the default processing that is provided by the packaging tools. More advanced applications could have additional requirements, for example:

  • Include a custom splash screen that is shown when your application is loaded.

  • Include a custom progress bar that is shown while your application is loading.

  • Use JavaScript code to communicate between your application and the web page in which it is embedded.

  • Deploy Swing and SWT Applications with Embedded JavaFX Content

  • Minimize the number of security dialogs and the warnings contained within the dialogs to help ensure users that it is safe to run your application.

The Deployment trail in the Java Tutorials also provides information to help you deploy applications embedded in a web page or launched from a browser.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JavaFX in Swing Applications

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

6 JavaFX in Swing Applications

You can create Swing applications with embedded JavaFX content. This page describes how to deploy such applications.

This topic contains the following sections:

  • Overview

  • Packaging with JavaFX Ant Tasks

  • Packaging without the Packaging Tools

6.1 Overview

Developers working on existing Swing applications can take advantage of JavaFX features by integrating JavaFX content into their Swing applications. See the tutorial JavaFX and Swing Applications for more information.

Not all of the techniques discussed in this guide are applicable to Swing applications with JavaFX content, however, the following techniques are relevant:

  • The same packaging tools can be used to package your Swing applications.

  • The Deployment Toolkit can be used to embed your Swing application in a web page or launch it from a browser.

  • Your application can be bundled and packaged as an installable package, using the same technique as for self-contained applications.

Deployment of a Swing application with embedded JavaFX content on the web is similar to deployment of a regular Swing application as a Java Web Start application or applet. See the Java Tutorials lessons on Java applets and Java Web Start applications.

However, to use JavaFX, the deployment descriptor of your application (JNLP file) needs to express a dependency on the JRE.

Ant tasks are recommended for packaging hybrid applications, as described in Section 6.2, "Packaging with JavaFX Ant Tasks."). Alternatively, you can modify your existing packaging process manually, as described in Section 6.3, "Packaging without the Packaging Tools."

6.2 Packaging with JavaFX Ant Tasks

You can use same set of Ant tasks (see Chapter 5, "Packaging Basics") to package Swing applications with integrated JavaFX content. You only need to mark that the application's primary UI toolkit is Swing, using the toolkit="swing" attribute of <fx:application>.

The resulting package is similar to the package for pure JavaFX applications. See Section 5.2, "Base Application Package." The only difference is that there are two deployment descriptors - one for deploying as a Swing applet, and another for launching your application using Java Web Start.

Example 6-1 shows a sample Ant task for a Swing application that contains JavaFX code and uses the toolkit="swing" attribute.

Example 6-1 Using JavaFX Ant Tasks to Package a Swing Application with Integrated JavaFX Content

<taskdef resource="com/sun/javafx/tools/ant/antlib.xml"
        uri="javafx:com.sun.javafx.tools.ant"
        classpath="${javafx.sdk.path}/lib/ant-javafx.jar"/>

<fx:jar destfile="dist-web/ColorfulCircles.jar">
    <fx:application refid="myapp"/>
    <fileset dir="build/classes/">
        <include name="**"/>
    </fileset>
</fx:jar>

<fx:deploy width="800" height="600" outdir="dist-web"
        outfile="SwingInterop">
    <fx:info title="Swing Interop"/>
    <!-- Mark application as a Swing app -->
    <fx:application id="myapp"
            mainClass="swinginterop.SwingInterop"
            toolkit="swing"/>
    <fx:resources>
        <fx:fileset dir="dist-web" includes="SwingInterop.jar"/>
    </fx:resources>
</fx:deploy>

6.2.1 Enabling an HTML Splash Screen

Swing applications do not have a default preloader, so there is no code to hide the HTML splash screen when the application is ready. Therefore, by default, the generated HTML page does not use an HTML splash screen.

To enable a splash screen, do both of the following tasks:

  • Explicitly define a code splash callback onGetSplash. For example; add the markup in Example 6-2 to Example 6-1:

    Example 6-2 Defining a Code Splash Callback onGetSplash

    <fx:callbacks>
    <!-- force use of default splash handler -->
    <fx:callback name="onGetSplash">
            (new dtjava.Callbacks()).onGetSplash
    </fx:callback>
</fx:callbacks>

    See Section 19.2, "Callbacks" for more information about callbacks and <fx:callbacks> for further details on the use of <fx:callbacks>.

  • Add code to explicitly hide the HTML splash screen when your application is ready, by using LiveConnect to call the JavaScript function dtjava.hideSplash() from Java code, as shown in Example 6-3.

Example 6-3 Hide the HTML Splash Screen When the Application is Ready

Applet myApplet = ...;
//appId is id used in the dtjava.embed() call String appId = "sampleApp";

JSObject window = JSObject.getWindow(myApplet);
try {
        window.eval("dtjava.hideSplash('"+appId+"');");
    } catch(Throwable t) {
    ...
}

6.3 Packaging without the Packaging Tools

If your project already has existing support for packaging as a Java Web Start application or applet, then it might be easier to modify the template of the JNLP file directly.

To express the dependency on the JavaFX Runtime, make the following changes in the JNLP file:

  • Define the JavaFX namespace with jfx:.

  • Specify that the minimum required version of the JRE is JRE 7 update 6 or later

Example 6-4 shows an example of these modifications to the deployment descriptor.

Example 6-4 Modify the Deployment Descriptor

<?xml version="1.0" encoding="utf-8"?>
<jnlp spec="1.0"
        xmlns:jfx="http://javafx.com"
        href="SwingAppWithJavaFXContent.jnlp"
        ...>
     ....
    <resources>
        <j2se version="1.7.0_06+"
            href="http://java.sun.com/products/autodl/j2se"/>
    </resources>
    ...
</jnlp>

No changes are required on the HTML side. However, you can also use the Deployment Toolkit to integrate your content with the web page, as shown in the examples in the following sections.

6.3.1 Using the Deployment Toolkit

It is recommended that you use the Deployment Toolkit to deploy your application as an applet or launch it from a browser. The Deployment Toolkit simplifies deployment routines, such as ensuring that required JRE is available. The Deployment Toolkit also has several bonus features, such as:

  • Passing JVM options or arguments to your application dynamically. See Section 19.3.4, "Specify Platform Requirements and Pass JVM Options" and Section 19.3.3, "Pass Parameters to a Web Application."

  • Usage procedures are almost the same as for JavaFX applications. The only requirement is to specify the Swing toolkit as one of the platform requirements.

For example, Example 6-5 shows web page code for launching a Swing Java Web Start application. This code is the same as that used to launch JavaFX applications.

Example 6-5 Scripts and Markup in HTML Page for a Java Web Start Application

<html>
    <head>
            <SCRIPT src="https://java.com/js/dtjava.js"></SCRIPT>
            <script>
                function launchApplication(jnlpfile) {
                dtjava.launch(
                    {     url : jnlpfile,
                      toolkit : 'swing'
                    }
                    {
                        javafx : '2.2+'
                    },
                    {}
                );
                return false;
            }
        </script>
    </head>
    <body>
        <h2>Test page</h2>
        <a href='SampleApp.jnlp'
        onclick="return launchApplication('SampleApp.jnlp');">Click</a>
        to launch test app.
    </body>
</html>

Example 6-5 is simplistic, but you can use other features of the dtjava.launch() method in the Deployment Toolkit for Swing applications, as needed. For example, you can embed the JNLP file into the web page for faster startup.

For applets, the approach is similar. Applets can be embedded into a web page using the dtjava.embed() function. You must also specify the swing toolkit to indicate a preference of application type for the Deployment Toolkit.

Another caveat concerns built-in HTML splash support in the Deployment Toolkit. Swing applications do not have a default preloader, so there is no code to hide the HTML splash screen when the application is ready. To address this difference, use either of the following methods:

  • Add code to explicitly hide the HTML splash screen when your application is ready, by using LiveConnect to call the JavaScript function dtjava.hideSplash() from Java code, as shown in Example 6-6.

    Example 6-6 Hide the HTML Splash Screen When the Application is Ready

    Applet myApplet = ...;
//appId is id used in the dtjava.embed() call String appId = "sampleApp";

JSObject window = JSObject.getWindow(myApplet);
try {
        window.eval("dtjava.hideSplash('"+appId+"');");
    } catch(Throwable t) {
    ...
}

  • Provide a custom splash callback that does nothing, as shown in Example 6-7 and in Section 19.3.6, "Disable the HTML Splash Screen".

Example 6-7 Custom Callback to Disable the HTML Splash Screen

<html>
    <head>
        <SCRIPT src="https://java.com/js/dtjava.js"></SCRIPT>
        <script>
            function embedApp() {
                dtjava.embed(
                    {
                                 id : 'sampleApp',
                                url : 'SampleApp_browser.jnlp',
                        placeholder : 'app-placeholder',
                              width : 960,
                             height : 720,
                            toolkit : 'swing'
                    },
                    {
                        javafx : '2.2+'
                    },
                    {   onGetSplash: function() {} } //disable splash
                );
            }
            <!-- Embed Swing application into web page after page is loaded -->
            dtjava.addOnloadCallback(embedApp);
        </script>
    </head>
    <body>
        <h2>Test page</h2>
        <!-- Applet will be inserted here -->
        <div id='javafx-app-placeholder'></div>
    </body>
</html>
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration deploy_type_properties.gif

Documentation Contents

This diagram shows features associated with four deployment types: standalone applications; self-contained applications; Java Web Start applications; and applications embedded in a web page.

Eight features are displayed, which span one or more columns. The features are named here and described in the following sections of the document.

Feature 1: Preloader: Applies to all deployment types, JavaFX applications only.

Feature 2: Built-in proxy support: Applies to self-contained applications, Java Web Start applications, and applications embedded in a web page.

Feature 3: Desktop integration via shortcut or menu. Applies to self-contained applications, Java Web Start applications, and applications embedded in a web page.

Feature 4: Auto-updates: Applies to Java Web Start applications and applications embedded in a web page, also to applications that were earlier downloaded from the web using either of these execution modes.

Feature 5. Fine-tune user experience with Deployment Toolkit: Applies to Java Web Start applications and applications embedded in a web page.

Feature 6: Communicate via JavaScript: Applies to applications embedded in a web page.

Feature 7: No system installation of Java required: Applies to self-contained applications.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Application Startup

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

4 Application Startup

This topic provides information about the application startup process, user experience, and customization options.

The user experience is an important factor in making an application successful. The deployment of an application creates a user's first impression, and impacts the user's satisfaction with the application.

In this topic, the default experience for users of Java and JavaFX applications is explained, and the options for customizing the user experience are presented. This topic contains the following sections:

  • User Experience Considerations

  • Application Startup Process, Experience, and Customization

  • Helping Users Start the Application

4.1 User Experience Considerations

Users are easily annoyed if they are unable to start an application, do not understand what are the next steps, perceive the application as slow or hung, and for many other reasons.

Default Java packaging takes care of many problem areas including:

  • Ensuring the user has the required JRE installed

  • Auto installing missing dependencies or offering to install them as needed

  • Providing visual feedback to the user while the application is being loaded

  • Showing descriptive error messages

For example, when users do not have Java installed and double-click the JAR file for your application, they see a dialog box explaining that they need to download and install the JRE.

Developers have a wide range of options on how to tune the experience for their users, such as:

  • Show your own splash screen

  • Use a custom loading progress indicator

  • For Java FX applications, customize the messaging (for example, explain to users why they need to install the JRE in a language other than English)

4.2 Application Startup Process, Experience, and Customization

The following sections describe the transition phases of application startup, how users experience those phases, and how the default visual feedback to the user can be customized.

4.2.1 Startup Process

Between the time an application is started and the time the user sees the main dialog, a sequence of events occurs on screen while operations are carried out in the background. Figure 4-1 shows these activities and describes them in the following paragraphs. This startup sequence partially depends on the execution mode and on the speed with which the background operations complete. Figure 4-1 shows a series of boxes that depict the background operations over time, including screen shots of what the user sees as these operations occur for a JavaFX application.

Figure 4-1 Background Operations and Screen Events During Application Startup

Description of Figure 4-1 follows
Description of "Figure 4-1 Background Operations and Screen Events During Application Startup"

The application startup process has the following phases:

  • Phase 1: Initialization

    Initialization of the JRE and an initial examination of the application identifies components that must be loaded and executed before starting the application. The initialization phase is shown in the first two boxes in the upper row in Figure 4-1.

  • Phase 2: Loading and preparation

    The required resources are loaded from either the network or a disk cache, and validation procedures occur. For JavaFX applications, all execution modes show either the default or a custom progress bar. This phase is shown in the third box in the upper row in Figure 4-1.

  • Phase 3: Application-specific initialization

    The application is started, but additional resources might need to be loaded or other lengthy preparations performed before the application becomes fully functional. For example, it might be necessary to check if elevated permissions are needed and to display the appropriate request for permission to the user.

  • Phase 4: Application execution

    The application is shown and is ready to use after the background operations shown in Figure 4-1 are finished.

4.2.1.1 Visual Feedback During Phase One Initialization

Options to provide visual feedback during the first phase of initialization are limited. At that moment, it is not yet known what must be done to launch the application, and the Java platform has not initialized yet. Visual feedback must be provided using external means, for example using JavaScript or HTML if the application is embedded into the web page. By default, a splash screen is displayed during this phase, as described in Section 4.2.2, "Default User Experience."

4.2.1.2 Visual Feedback After Initialization

To provide visual feedback after the initialization phase of a JavaFX application, JavaFX provides a preloader, which gets notifications about the loading progress and can also get application-specific notifications. By default, a preloader with a progress bar is displayed during this phase, as described in Section 4.2.2, "Default User Experience."

You can customize the default preloader, as described in Section 4.2.3, "Customization Options for JavaFX Applications." You can also create your own preloaders to customize the display and messaging. See Chapter 13, "Preloaders for JavaFX Applications" for information.

For Java applets, a custom progress bar can be provided. See Section 14.3.2, "Implementing a Customized Loading Progress Indicator" for information.

4.2.2 Default User Experience

A properly packaged application provides default visual feedback to the user for the first two phases for all execution modes. The actual behavior depends on the execution mode and type of application.

When launched in standalone mode, most applications start quickly, and no visual feedback is required.

Table 4-1 summarizes the default behavior according to execution mode when the application is launched for the first time and is loaded from the network.

Table 4-1 Default Behavior During First-Time Launch

Startup Phase | Java Web Start Launch | Embedded in a Web Page
Phase 1 Initialization | Splash screen: Description of java8_splash.gif follows Description of the illustration java8_splash.gif | Splash screen, JavaFX applications: Description of html_splash_75.gif follows Description of the illustration html_splash_75.gif Splash screen, Java applications: Description of html_splash_se8.gif follows Description of the illustration html_splash_se8.gif
Phase 2 Loading Code | Progress window, JavaFX applications: Description of ws_load.png follows Description of the illustration ws_load.png | Progress window, JavaFX applications: Description of progress_dialog2_40.gif follows Description of the illustration progress_dialog2_40.gif
Phase 3 Transition to Application | Hide progress window | Fade-out progress window, JavaFX applications

Table 4-2 summarizes the default behavior for subsequent launches, in which the JAR files are loaded from the cache. In this case, the process has fewer visual transitions because nothing needs to be loaded from the network during the Loading Code phase, so launch time is substantially shorter.

Table 4-2 Default Startup Behavior During Subsequent Launches

 | Java Web Start Launch or Launch from Shortcut | Embedded into Web Page
Phase 1 Initialization | Splash screen: Description of java8_splash.gif follows Description of the illustration java8_splash.gif | Splash screen, JavaFX applications: Description of html_splash_75.gif follows Description of the illustration html_splash_75.gif Splash screen, Java applications: Description of html_splash_se8.gif follows Description of the illustration html_splash_se8.gif
Phase 2 Loading Code | Splash screen: Description of java8_splash.gif follows Description of the illustration java8_splash.gif | Splash screen, JavaFX applications: Description of html_splash_75.gif follows Description of the illustration html_splash_75.gif Splash screen, Java applications: Description of html_splash_se8.gif follows Description of the illustration html_splash_se8.gif
Phase 3 Transition to Application | Hide splash screen | Hide splash screen

4.2.3 Customization Options for JavaFX Applications

The splash screen for embedded applications is displayed in the web page and can be easily customized by using an onGetSplash callback, as shown in Section 19.2.3, "onGetSplash."

The default JavaFX preloader can be customized by using a CSS style sheet, similar to other JavaFX components. Pass the customized style data using the javafx.default.preloader.stylesheet parameter for your application. The following items are valid for the parameter:

  • Absolute or relative URI of the CSS style sheet, either as a text file with a .css extension, or in binary form with a .bss extension. For more information about binary conversion, see Section 5.4, "Style Sheet Conversion."

  • Actual CSS code.

To customize the preloader, use the .default-preloader class. In addition to standard CSS keys, the preloader has the following special keys:

  • -fx-preloader-status-text

    Status text shown in the preloader

  • -fx-preloader-graphic

    Absolute or relative URI of the image used by the preloader

Example 4-1 shows an example of CSS file my.css:

Example 4-1 Example CSS Class to Customize the JavaFX Preloader

.default-preloader {
    -fx-background-color: yellow;
    -fx-text-fill: red;
    -fx-preloader-graphic: url("http://host.domain/duke.gif");
    -fx-preloader-text: "Loading, loading, LOADING!";
}

Add the style sheet to the <fx:deploy> Ant task as shown in Example 4-2:

Example 4-2 Adding a JavaFX Preloader Stylesheet to the <fx:deploy> Ant Task

<fx:deploy ...>
    <fx:application ...>
        <fx:htmlParam  name="javafx.default.preloader.stylesheet"
                value="my.css"/>
    <fx:application>
</fx:deploy>

If only a few customizations are needed, pass CSS code instead of a file name, to avoid the overhead of downloading a file. Example 4-3 shows how to change the background color to yellow.

Example 4-3 Changing the Default JavaFX Preloader Background Color

<fx:deploy ...>
    <fx:application ...>
    <!-- Using fx:param here, so it will be applicable to all web
            execution environemnts -->
        <fx:param  name="javafx.default.preloader.stylesheet"
                value=".default-preloader { -fx-background-color: yellow; }"/>
    <fx:application>
</fx:deploy>

To add a company logo to the default JavaFX preloader, you could pass the following string as a value of the javafx.default.preloader.stylesheet parameter :

".default-preloader { -fx-preloader-graphic:url
('http://my.company/logo.gif'); }"

If customizing the default JavaFX preloader is not enough and you need a different visualization or behavior, see Chapter 13, "Preloaders for JavaFX Applications" for information about how to implement your own preloader, and see Chapter 5, "Packaging Basics" for information about how to add the custom preloader to your package.

4.2.4 Customization Options for Java Applets

Custom splash screens can be used with Java applets by passing in additional parameters when you deploy the applet. See Section 14.3.1, "Adding a Splash Screen" for information.

To add a custom progress bar to your applet, create a class that implements the DownloadServiceListener interface. See Displaying a Customized Loading Progress Indicator for instructions.

4.3 Helping Users Start the Application

In some cases, a user might have difficulty getting your application to run. For example, the following situations could cause an application to fail:

  • The user has an unsupported platform.

  • The user's system does not have the JRE installed.

  • Java is not configured correctly, for example the proxy information is not set.

  • The user declined to grant permissions to an application.

  • The application does not meet current security requirements.

It is important to plan for users who experience problems, by either providing guidance to resolve the issue or having the application fail gracefully and explaining to the user why it cannot be resolved.

The following sections describe methods for handling some common issues.

4.3.1 No JRE

If the user does not have the JRE installed, then the application cannot start. The application package includes several hooks to improve the user experience in this case.

You can customize the default behavior described in the following sections. See Chapter 19, "Deployment in the Browser" for information about how to customize prompts to install the JRE, and error handling for web applications.

4.3.1.1 Standalone Launch

The main application JAR file includes a launcher program, which is used to detect the JRE. If the JRE is not found, then a dialog box is shown that explains where to get the JRE.

4.3.1.2 Launch with the Deployment Toolkit

If the application is embedded in a web page or launched from a browser using the Deployment Toolkit, which is described in Chapter 19, "Deployment in the Browser," then the Deployment Toolkit handles the detection of the JRE before trying to launch the application. If the JRE is missing, the Deployment Toolkit initiates installation by offering the user a link to the installer. By default, automatic download only occurs when the user launches an application using Java Web Start and has a recent version of the JRE.

4.3.2 Runtime Errors

An application can fail to launch due to various runtime errors or user mistakes, such as the absence of a network connection needed to load some of the application JAR files.

One of the most common errors is when the user does not grant permissions to the application. In that case, the application fails, and the user has to restart the application and then grant permissions to get it to run. In a case like this, it is helpful to explain to the user why the application failed and what the user must do to restart it successfully. By default, an error message is shown, either in a dialog box or inside the web page in the location where the application is embedded.

If the Deployment Toolkit is used, then the onDeployError handler can be used to display an error message in the application area in the web page. You can also consider including some instructions in the splash screen to alert users about granting permissions. For more information, see Chapter 19, "Deployment in the Browser."

For JavaFX applications, you can also include a custom preloader to get notifications about errors, unless the error occurs while launching the preloader. For more information about JavaFX preloaders and code examples, see Chapter 13, "Preloaders for JavaFX Applications."

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Rich Internet Applications Deployment Advice

See Rich Internet Applications Deployment Advice in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Rich Internet Application Deployment Process

See Rich Internet Application Deployment Process in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Networking

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

30 Networking

This topic provides information on setting up a proxy, and using the Pack200 tool for your Java applications.

This topic includes the following sections:

  • Proxy Configuration

  • Deploying JAR Files Compressed with Pack200

  • Compression Formats for Network Deployment

30.1 Proxy Configuration

For enterprise customers it is important to be able to set up secure computing environments within their companies, and proxy configuration is an essential part of doing that. Proxy configuration acts as a security barrier; it ensures that the proxy server monitors all traffic between the Internet and the intranet.

Proxy configuration is normally an integral part of security enforcement in corporate firewalls within intranets. Enterprise customers who want to use Java Plug-in to deploy applets, or Java Web Start to run applications on their intranet web pages can also set up proxy support. This support is required for Java Plug-in and Java Web Start to work in an intranet environment and can be set up through the Java Control Panel.

30.1.1 Java Control Panel

The Java Control Panel provides four proxy options through the Network Setting dialog, which is accessed by clicking Network Settings in the General tab:

  • Use browser settings

  • Use proxy server

  • Use automatic proxy configuration script

  • Direct connection

30.1.1.1 Use browser settings

If Use browser settings is selected, then proxy information is obtained entirely through the browser. To change proxy information, see the documentation for your browser:

  • Internet Explorer:

    • Change proxy settings in Internet Explorer (Windows Vista, Windows 7, Windows 8)

    • Configure Proxy Settings for Internet Explorer (Windows Server 2008 R2)

  • Firefox: Change proxy settings in the Options window - Advanced panel

  • Chrome: Chrome uses the same connection and proxy settings as Windows; follow the same steps as you would with Internet Explorer

30.1.1.2 Use proxy Server

If you select Use proxy server in the Java Control Panel, you have two choices:

  1. Set the Address and the Port for a proxy server with the option to bypass it for local addresses.

  2. Individually set the proxy server for HTTP, Secure, FTP, and Socks connections. You can also provide a list of addresses for which you do not want to use a proxy server.

30.1.1.3 Use automatic proxy configuration script

If you select Use automatic proxy configuration script, then you must enter the URL for the location of the JavaScript method called FindProxyForURL(URL url) that returns the proxy server to be used for a URL. Support for this script is the same as described in Section 30.1.4, "Automatic Proxy Configuration."

30.1.1.4 Direct connection

Direct connection does not use a proxy. For certain situations, such as when mobile users connect to the company through a modem, direct connection to the intranet environment is required, and proxies should not be used in these cases.

30.1.2 How Java Plug-in and Java Web Start Obtain Proxy Information From the Browser

Because browsers on different platforms store proxy information differently, there is no generic mechanism to obtain proxy information. Here is how proxy information is obtained from Internet Explorer and Firefox on Windows:

  • Internet Explorer: Internet Explorer obtains proxy information from the same set of keys in the Windows registry. Java Plug-in and Java Web Start extract this information directly from the registry.

  • Firefox: Firefox stores proxy information in a preference file under the user profile directory on the local machine. Firefox also has public APIs available for determining proxy information. Java Plug-in uses these public APIs to obtain the proxy information; Java Web Start obtains the proxy information through reading and parsing the preference file.

Java Plug-in and Java Web Start obtain proxy information at startup time. If you change the proxy settings after Java Plug-in or Java Web Start have started, you may force reloading of the proxy information from the browser through the p option in the Java Console. Java Web Start is restarted for each application, so new proxy information will be used automatically on subsequent launches.

30.1.3 Manual Proxy Configuration

Internet Explorer, Firefox, and Chrome support manual proxy configuration. Users can specify the proxy server and port for each protocol. Users can also specify one proxy server and port for all protocols. To minimize the workload of the proxy server, some sites might bypass the proxy server completely when a machine is connecting to another machine inside the intranet environment. To do this, network administrators and users can specify a proxy server bypass list in the browser's proxy setting.

Internet Explorer: Java Plug-in and Java Web Start recognize and supports the proxy server and port setting associated with the protocol. IE supports various syntaxes in the proxy server bypass list, as follows:

  • IP address/host name only

  • IP address/host name with wildcard

  • IP address/host name with protocol

For example, if you specify "203.0.113.0;*.eng;http://*.com" in the proxy server bypass list, then the browser bypasses the proxy whenever one of the following occurs:

  • "203.0.113.0" is requested

  • the URL host name ends with .eng

  • the URL protocol is HTTP and the URL host name ends with .com

Currently Java Plug-in and Java Web Start support the first two syntaxes in the proxy server bypass list in IE. IE also supports bypassing the proxy server for local (intranet) addresses without using the proxy server bypass list. Java Plug-in and Java Web Start support this option by bypassing the proxy server if the URL host name contains no dot (.).

Firefox: Java Plug-in and Java Web Start recognize and supports the proxy server and port setting associated with the protocol. For example, if you specify .eng,.sun.com in the proxy server bypass list in Firefox, it bypasses the proxy whenever the URL hostname ends with .eng or .sun.com. Java Plug-in and Java Web Start fully support this syntax in the proxy server bypass list in Firefox.

For more information about manual proxy configuration in your browser, consult the user guide for your browser.

30.1.4 Automatic Proxy Configuration

Automatic proxy configuration is supported in the browser by setting a particular URL that contains a JavaScript file with .pac or .js extension. This file contains a function called FindProxyForURL that contains the logic to determine which proxy server to use when the browser receives a connection request. This function is written by the system administrator for the particular intranet environment. When the browser starts up, it recognizes the URL of the JavaScript file and downloads the file to the local machine using direct connection. Then whenever it needs to make a new connection, the browser executes the JavaScript function FindProxyForURL in the file to obtain the proxy information to set up the connection.

Java Plug-in

  • Internet Explorer: During startup, Java Plug-in downloads the JavaScript file to the local machine using direct connection. Then whenever it needs to make a new connection, it executes the FindProxyForURL function to obtain the proxy information using the JavaScript engine in Internet Explorer.

  • Firefox: During startup, Java Plug-in downloads the JavaScript file to the local machine using direct connection. Then whenever it needs to make a new connection, it executes the FindProxyForURL function to obtain the proxy information by using the JavaScript engine in Firefox.

Java Web Start

  • Windows: During startup, Java Web Start downloads the JavaScript file to the local machine using direct connection. Then whenever it needs to make a new connection, it executes the FindProxyForURL function to obtain the proxy information using the JavaScript engine in Internet Explorer.

  • Linux, Solaris, OS X: During startup, Java Web Start downloads the JavaScript file to the local machine using direct connection. Then whenever it needs to make a new connection, it will parse the FindProxyForURL function and try its best guess to obtain the proxy information.

Notes on FindProxyForURL

Given a JavaScript engine, the following is applicable to Java Plug-in on all platforms and to Java Web Start on Windows only.

  1. There are a number of JavaScript helper functions which can be called from the JavaScript function FindProxyForURL. Java Plug-in and Java Web Start provide their own implementations of these functions to completely emulate automatic proxy configuration. Regarding the implementation of these helper function, note the following:

    • Function dnsResolve always returns an empty string if the host is not an IP address.

    • Function isResolvable always returns false if the host is not an IP address.

    • Function isInNet always returns false if the host is not an IP address.

  2. Executing the function FindProxyForURL always returns proxy information as a string. Java Plug-in and Java Web Start extract the setting in the following way:

    • If DIRECT is in the string, Java Plug-in and Java Web Start assume direct connection.

    • If PROXY is in the string, they use the first proxy setting for the connection.

    • If SOCKS is in the string, they use the SOCKS v4 for the connection.

    • Otherwise, the proxy information in the string is incorrect. In this case, Java Plug-in and Java Web Start assume direct connection.

30.1.5 java.net.ProxySelector API

Developers sometimes might need to determine the proxy configuration of a given host. By knowing the proxy configuration, they can write more intelligent code to connect to the host through the proper proxy server. The java.net.ProxySelector class provides configuration support. Here is a simple code example:

Example 30-1 ProxySelector Usage Example

private Proxy findProxy(URI uri)
{
     try
     {
          ProxySelector selector = ProxySelector.getDefault();
          List<Proxy> proxyList = selector.select(uri);
          if (proxyList.size() > 1)
               return proxyList.get(0);
     }
     catch (IllegalArgumentException e)
     {
     }
     return Proxy.NO_PROXY;
}

30.2 Deploying JAR Files Compressed with Pack200

When the Java system property jnlp.packEnabled is set to true in a JNLP file or an applet tag, Java Plug-in or Java Web Start downloads the JAR file compressed by the Pack200 tool. If the compressed version is not available, Java Plug-in or Java Web Start looks for the uncompressed version.

Note:

Pack200 compressed JAR files must have the extension pack.gz. For example, if your JAR file is named sampleApp.jar, then the Pack200 compressed version of this file must be named sampleApp.jar.pack.gz.

30.2.1 Usage in a JNLP File

Use the property tag to specify jnlp.packEnabled to true within the resources tags, for example:

<jnlp ...>
 ...
 <resources>
 <property name="jnlp.packEnabled" value="true"/>
 <java version="1.7+" href="http://http://java.sun.com/products/autodl/j2se"/>
 <jar href="sampleApp.jar" main="true" download="eager"/>
</resources>
 ...
</jnlp>

In this example, Java Web Start and the Java Plug-in first look for sampleApp.jar.pack.gz. If the file is not found, they look for the original, sampleApp.jar.

30.2.2 Usage in Applet Tag

Pass the -Djnlp.packEnabled VM argument by using java_arguments, for example:

<HTML>
 ...
 <APPLET CODE="HelloWorld.class" WIDTH=150 HEIGHT=25>
 <PARAM NAME = "cache_archive" VALUE = "HelloWorld.jar"/>
 <PARAM NAME="java_arguments" VALUE="-Djnlp.packEnabled=true"/>
 </APPLET>
 ...
</HTML>

The Java Plug-in looks for HelloWorld.jar.pack.gz; if this file is not available, it looks for HelloWorld.jar.

30.3 Compression Formats for Network Deployment

To increase server and network availability and bandwidth, two compression formats are available to Java deployment of applications and applets: gzip and Pack200. With both techniques, the compressed JAR files are transmitted over the network and the receiving application uncompresses and restores them.

See Reducing the Download Time in the Java Tutorials to create and deploy a compressed JAR file for a rich Internet application.

The following sections describes the technical details of how a web server handles a compressed JAR file.

30.3.1 Background

Hypertext Transfer Protocol -- HTTP 1.1 (RFC 2616) discusses HTTP compression. HTTP Compression allows applications JAR files to be deployed as compressed JAR files. The supported compression techniques are gzip, compress, and deflate.

As of JDK version 5.0, HTTP compression is implemented in Java Web Start and Java Plug-in in compliance with RFC 2616. The supported techniques are gzip and pack200-gzip.

The requesting application can send an HTTP request to the server indicating its ability to handle compressed versions of the file. The following example shows the HTTP request created when the Dynamic Tree Demo applet, whose JAR file has been compressed with Pack200, is loaded:

Example 30-2 Sample HTTP Request

GET http://www.example.com/DynamicTreeDemo.jar.pack.gz HTTP/1.1
accept-encoding: pack200-gzip,gzip
User-Agent: Mozilla/4.0 (Windows 7 6.1) Java/1.8.0
Host: example.com
Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
Connection: keep-alive

The following examples shows the HTTP response from the server:

Example 30-3 Sample HTTP Response

HTTP/1.1 200 OK
Date: Wed, 21 Mar 2012 20:13:22 GMT
Server: Apache/2.2.11 (Solaris, Linux, or OS X) mod_ssl/2.2.11 OpenSSL/0.9.8k SVN/1.6.2 DAV/2
Last-Modified: Thu, 08 Mar 2012 03:48:34 GMT
ETag: "489ee5-112d-4bab326774e43"
Accept-Ranges: bytes
Content-Length: 4397
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Content-Type: application/x-gzip
Content-Encoding: gzip

For more information about the Dynamic Tree Demo applet, see Deploying an Applet in the Java Tutorials.

The Accept-Encoding field specifies what the client can accept, which is set by the client. The Content-Encoding field indicates what is being sent, which is set by the server. The Content-Type field indicates what the client should expect when the transformation or decoding is done.

In this example, the Accept-Encoding field is set to pack200-gzip and gzip, indicating to the server that the application (in this case, Mozilla Firefox running in Windows 7 with the Java Plug-in that comes with JRE 7) can handle pack200-gzip and gzip formats.

The server searches for the requested JAR file with a .pack.gz or .gz file extension and responds with the located file. The server sets the response header Content-Encoding field to pack200-gzip, gzip, or NULL depending on the type of file that is being sent, and optionally may set the Content-Type to application/x-java-archive. Therefore, by inspecting the Content-Encoding field, the requesting application can apply the corresponding transformation to restore the original JAR file.

Figure 30-1 Packed or Compressed JAR Returned

Description of Figure 30-1 follows
Description of "Figure 30-1 Packed or Compressed JAR Returned"

In Figure 30-1, the client requests the file foo.jar with the Accept-Encoding field pack200-gzip,gzip. The server searches for the file foo.jar.pack.gz. If the server finds the file, it sends the file to the client and sets the Content-Encoding field to pack200-gzip.

Figure 30-2 Packed or Compressed JAR File Not Found

Description of Figure 30-2 follows
Description of "Figure 30-2 Packed or Compressed JAR File Not Found"

In Figure 30-2, if the file foo.jar.pack.gz is not found, the server responds with the file foo.jar.gz, if it is found, and sets the Content-Encoding field to gzip.

Figure 30-3 Packed or Compressed JAR FIle and Standard gzip File Not Found

Description of Figure 30-3 follows
Description of "Figure 30-3 Packed or Compressed JAR FIle and Standard gzip File Not Found"

In Figure 30-3, if the files foo.jar.pack.gz and foo.jar.gz are not found, then the server responds with the file foo.jar and either does not set the Content-Encoding field or sets it to NULL.

Figure 30-4 Legacy Application Requesting JAR File

Description of Figure 30-4 follows
Description of "Figure 30-4 Legacy Application Requesting JAR File"

In Figure 30-4, a legacy application (an application without HTTP or Pack200 compressions) requests the file foo.jar; consequently this application will continue to work seamlessly. Therefore, it is recommended that you host all three files foo.jar, foo.jar.gz, and foo.jar.jar.gz.

30.3.2 GZIP Compression

gzip is a freely available compressor available within the JRE and the SDK as java.util.zip.GZIPInputStream and java.util.zip.GZIPOutputStream.

The command line versions are available with most Solaris, Linux, or OS X operating systems, Windows UNIX toolkits (Cygwin and MKS Toolkit), or from http://www.gzip.org/.

You can get the highest degree of compression using gzip to compress an uncompressed JAR file versus compressing a compressed JAR file. The downside is that the JAR file may be stored uncompressed on target systems.

For example, the following table shows the results of using gzip to compress the Notepad.jar file.

Type of JAR File | Size Before Compression with gzip | Size After Compression with gzip
JAR file that contains individual deflated entries | Notepad.jar: 46.25 KB | Notepad.jar.gz: 43.00 KB
JAR file that contains stored entries, which are not compressed | Notepad.jar: 987.47 KB | Notepad.jar.gz: 32.47 KB

As you can see, the download size can be reduced by 14% by compressing an uncompressed JAR file compared to 3% by compressing a compressed JAR file.

30.3.3 Pack200 Compression

Pack200 compresses large files very efficiently, depending on the density and size of the class files in the JAR file. You can expect compression to one-ninth the size of the JAR file if it contains only class files and is in the order of several megabytes.

Using the same JAR file in the previous example:

  • Notepad.jar: 46.25 kb

  • Notepad.jar.pack.gz: 22.58 kb

In this case, the same JAR file can be reduced by 50%.

Pack200 works most efficiently on Java class files. It uses several techniques to efficiently reduce the size of JAR files:

  • Merges and sorts the constant-pool data in the class files and co-locates them in the archive.

  • Removes redundant class attributes.

  • Stores internal data structures.

  • Uses delta and variable length encoding.

  • Chooses optimum coding types for secondary compression.

Compress and uncompress JAR files with the command line interfaces pack200 and unpack200 in the bin directory of your SDK or JRE directory.

You can also programmatically invoke Pack200 interfaces; see java.util.jar.Pack200.

30.3.3.1 Steps to Pack a file

  1. Consider the size of the JAR file, the contents of the JAR file, and the bandwidth of your target audience.

    All these factors play into choosing a compression technique. The unpack200 tool is designed to be as efficient as possible, and it takes little time to restore the original file. If you have large JAR files (2 MB or more) comprised mostly of class files, Pack200 is the preferred compression technique. If you have large JAR files which are comprised of resource files (JPEG, GIF, data, etc.), then gzip is the preferred compression technique.

  2. Specify the segment limit for Pack200 compression.

    Pack200 loads the entire compressed file into memory. However, when target systems are memory and resource constrained, setting the Pack200.Packer.SEGMENT_LIMIT to a lower value will reduce the memory requirements during compression and uncompression.

    As a special case, a value of -1 will produce a single large segment with all input files, while a value of 0 will produce one segment for each class. Larger archive segments result in less fragmentation and better compression, but processing them requires more memory.

    The default is -1, which means pack200 will always create a single segment output file. In cases where extremely large output files are generated, you are are strongly encouraged to use segmenting or break up the input file into smaller JARs.

    For example, a 10 MB JAR packed without this limit will typically pack about 10% smaller, but pack200 may require a larger Java heap (about ten times the segment limit).

  3. Sign the JAR files.

    Pack200 rearranges the contents of the resulting JAR file. The jarsigner tool hashes the contents of the class file and stores the hash in an encrypted digest in the manifest. When unpack200 uncompresses a file, the contents of the classes will be rearranged and thus invalidate the signature. Therefore, the JAR file must be normalized first using pack200 and unpack200, and thereafter signed.

    Here's why this works: Any reordering pack200 does on any class file structures is idempotent, so the second time it is compressed, it does not change the orderings produced by the first compression. Also, unpack200 is guaranteed by the JSR 200 specification to produce a specific bytewise image for any given transmission ordering of archive elements.

    For example, suppose you want to use HelloWorld.jar:

    1. Recompress, or repack, the file to normalize the JAR file; repacking uncompresses and compresses the JAR file in one step.

      % pack200 --repack HelloWorld.jar

    2. Sign the JAR.

      % jarsigner -keystore myKeystore HelloWorld.jar user_name

      Note:

      You must sign the repacked file with the same key that was used when building the original JAR file. Alternatively, delete all signature files found in the META-INF directory before repacking, re-signing and verifying. The signature files are named MANIFEST.MF, *.DSA and *.SF.

      Verify the just signed JAR file to ensure the signing worked.

      % jarsigner -verify HelloWorld.jar
jar verified.

      Ensure the JAR file still works.

      % Java -jar HelloWorld.jar
HelloWorld

    3. Compress the JAR file with pack200.

      % pack200 HelloWorld.jar.pack.gz HelloWorld.jar

      Note:

      You must compress the JAR file with the same options that you used to repack the file to normalize the JAR file, as demonstrated in Step a. Additionally, you must set the segment limit to -1 (unlimited) for all packing steps when using JDK 6 and earlier releases to prevent accidental variations of segment boundaries; class file sizes can change slightly under these circumstances, thus disrupting signatures. The default segment limit for JDK 7 and later is -1.

    4. Uncompress the file with unpack200

      % unpack200 HelloWorld.jar.pack.gz HelloT1.jar

    5. Verify the JAR file.

      % jarsigner -verify HelloT1.jar
jar verified.

      Test the JAR file.

      % Java -jar HelloT1.jar
HelloWorld

    After verification, you can deploy the compressed pack file HelloWorld.jar.pack.gz.

  4. Apply reduction techniques.

    Pack200 by default behaves in a High Fidelity (Hi-Fi) mode, meaning all the original attributes present in the classes as well as the attributes of each individual entry in a JAR file is retained. These typically tend to add to the packed file size. Use the following techniques to further reduce the size of the download:

    • Modification times: If modification time of the individual entries in a JAR file is not a concern, specify the option Pack200.Packer.MODIFICATION_TIME="LATEST". This will allow one modification time to be transmitted in the pack file for each segment. The latest time will be the latest time of any entry within that segment.

    • Deflation hint: Similar to setting the modification time to "LATEST", if the compression state of the individual entries in the archive is not required, set Pack200.Packer.DEFLATION_HINT="false". This will fractionally reduce the download size, as individual compression hints will not be transmitted. However, the JAR file when recomposed will contain "stored" entries and hence may consume more disk space on the target system.

      For example:

      pack200 --modification-time=latest --deflate-hint="true"
tools-md.jar.pack.gz tools.jar

      Note:

      The above optimizations will yield better results with a JAR file containing thousands of entries.

    • Attributes: Several class attributes are not required when deploying JAR files. These attributes can be stripped out of class files, significantly reducing download size. However, care must be taken to ensure that required runtime attributes are maintained.

      Debugging attributes: If debugging information, such as Line Numbers and Source File, is not required (typically in applications stack traces), then these attributes can be discarded by specifying Pack200.Packer.STRIP_DEBUG=true.This typically reduces the packed file by about 10%.

      Example:

      pack200 --strip-debug tools-stripped.jar.pack.gz tools.jar

      Other attributes: Advanced users can use some of the other strip-related properties to strip out additional attributes. However, extreme caution should be used when doing so, the resultant JAR file must be tested on all possible Java runtime systems to ensure that the runtime does not depend on the stripped attributes.

  5. Handle unknown attributes.

    Pack200 deals with standard attributes defined by the Java Virtual Machine Specification; however compilers are free to introduce custom attributes. When such attributes are present, by default, Pack200 passes through the class, emitting a warning message. These "passed-through" class files may contribute to bloating of packed files. If the unknown attributes are prevalent in the classes of a JAR file, this may lead to a very large bloat in the compressed output. In such cases, consider the following strategies:

    • Strip the attribute if the attribute is deemed to be redundant at runtime; this can be achieved by setting the property Pack200.Packer.UNKNOWN_ATTRIBUTE=STRIP:

      pack200 --unknown-attribute=strip
foo.pack.gz foo.jar

    • If the attributes are required at runtime, and they do contribute to inflation in the size of the compressed file, then identify the attribute from the warning message and apply a suitable layout for these as described in the Pack200 JSR 200 specification, and the Java API reference section for the interface Pack200.Packer.

    • It is possible that a compiler could define an attribute not implemented in the layout specification of Pack200, and may cause the pack200 to malfunction. In such cases, an entire class file or class files can be "passed through", as if it were a resource by virtue of its name and can be specified as follows:

      pack200 --pass-file="com/acme/foo/bar/baz.class" foo.pack.gz foo.jar

      The following passes through an entire directory and its contents,

      pack200 --pass-file="com/acme/foo/bar/" foo.pack.gz foo.jar

    Note:

    When signing large JAR files, this step might fail with a security error. A likely cause is bug 5078608. Use one of the following workarounds:

    • Specify --segment-limit=-1 during repacking and packing.

    • Follow these repacking and signing steps:

      1. pack200 --repack b.jar a.jar

      2. Sign b.jar.

      3. pack200 --repack c.jar b.jar

      4. Sign c.jar.

      5. pack200 out.jar.pack.gz c.jar

      6. Deploy out.jar.pack.gz.

  6. Take advantage of Pack200 in your installation program.

    You may wish to take advantage of the Pack200 technology in your installation program, whereby a product's JAR files may need to compressed using Pack200 and uncompressed during installation. If the JRE or SDK is bundled in the installation, you are free to use the unpack200 (Solaris, Linux, or OS X) or unpack200.exe (Windows) tool in the distribution bin directory. This implementation is a pure C++ application requiring no Java runtime to be present for it to run.

    Windows: Installers may use a better algorithm than the one in GZIP to compress entries. In such cases, one will get better compression using the Installer's intrinsic compression, by using the pack200 tool as follows:

    pack200 --no-gzip foo.jar.pack foo.jar

    This will prevent the output file from being gzip compressed.

    unpack200 is a Windows console application; i.e. it will display a MS-DOS window during the install. To suppress this, use a launcher with a WinMain, which will suppress this window, as shown below.

    Sample Code:

    #include "windows.h"
#include <stdio.h>

int APIENTRY WinMain(HINSTANCE hInstance,
                     HINSTANCE hPrevInstance,
                     LPSTR     lpCmdLine,
                     int       nCmdShow) {
  STARTUPINFO si;
  memset(&si, 0, sizeof(si));
  si.cb = sizeof(si);

  PROCESS_INFORMATION pi;
  memset(&pi, 0, sizeof(pi));

  //Test
  //lpCmdLine = "c:/build/windows-i586/bin/unpack200 -l c:/Temp/log c:/Temp/rt.pack c:/Temp/rt.jar";
  int ret = CreateProcess(NULL,                 /* Exec. name */
                          lpCmdLine,            /* cmd line */
                          NULL,                 /* proc. sec. attr. */
                          NULL,                 /* thread sec. attr */
                          TRUE,                 /* inherit file handle */
                          CREATE_NO_WINDOW | DETACHED_PROCESS, /* detach the process/suppress console */
                          NULL,                 /* env block */
                          NULL,                 /* inherit cwd */
                          &si,                      /* startup info */
                          &pi);                     /* process info */
  if ( ret == 0) ExitProcess(255);

  // Wait until child process exits.
  WaitForSingleObject( pi.hProcess, INFINITE );

  DWORD exit_val;

  // Be conservative and return
  if (GetExitCodeProcess(pi.hProcess, &exit_val) == 0) ExitProcess(255);

  ExitProcess(exit_val); // Return the error code of the child process

  return -1;
}

30.3.4 Testing

It is required that all JAR files, compressed and uncompressed, be tested for correctness with your applications test qualifiers. When using the command line interface pack200, the output file will be compressed using gzip with default values. A user may create a simple pack file and compress using gzip with user-specified options or using some other compressor.

30.3.5 More Information

For more information, see pack200 and unpack200 in Java Deployment Tools.

30.3.6 Updates in Java Standard Edition 8

In Java SE 8, the Java class file format has been updated because of JSR 292, Java Virtual Machine Support for Non-Java Languages. Consequently, the Pack200 engine has been updated accordingly to ensure that Java SE 8 class files are compressed effectively. In particular, the Pack200 engine now recognizes constant pool entries and new bytecodes introduced by JSR 292.

Pack200 has been updated to support the following, JSR-308 (Type Annotations) and JSR 335 (Lambda Expressions for the Java TM Programming Language)

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration deployment_process.png

Documentation Contents

Flow diagram that shows the deployment process. The diagram is described in the text that follows.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Deployment Rule Set

See Deployment Rule Set in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Deployment in the Browser

Documentation Contents
Java Platform, Standard Edition Deployment Guide
Contents Previous Next

19 Deployment in the Browser

This topic explains how to deploy Java and JavaFX applications in the browser using the Deployment Toolkit, dtjava.js. An API overview, information about the callback methods, and typical examples of use are provided.

Use the Deployment Toolkit library to embed a Java or JavaFX application in a web page or launch it from a browser. The Deployment Toolkit provides a JavaScript API to simplify web deployment of applications and improve the end user experience when starting the application.

In addition to providing functionality to add HTML tags needed to insert Java or JavaFX applications into the web page, the Deployment Toolkit also provides the following actions:

  • Detects if the user's environment is supported

  • Offers to install the JRE, if needed

  • Provides visual feedback to the user while the application is loaded

  • Reports unexpected errors to the user

  • Provides other helper APIs to the developer, which can be used to simplify deployment and integration with the web page

To use the Deployment Toolkit, import the Deployment Toolkit JavaScript file from the shared location at https://java.com/js/dtjava.js.

This way your application always uses the latest recommended way to integrate into a web page. If you cannot use the shared location, you can include the necessary files with your application by using the includeDT option in the <fx:deploy> Ant task.

Note that for the majority of simple use cases, the code needed for deployment is generated by the Java packaging tools (see Section 5.3.1, "Java Packaging Tools.") You can use callbacks to tune the default behavior further. If you need more flexibility, you can use the Deployment Toolkit APIs directly.

This topic contains the following sections:

  • API Overview

  • Callbacks

  • Examples

19.1 API Overview

The Deployment Toolkit API provides the following important methods:

  • dtjava.embed(app, platform, callbacks)

    Embeds the application into the browser based on a given application descriptor. If JRE installation is required, by default the Deployment Toolkit prompts the user to install the JRE or redirects to the page where the installer can be downloaded.

  • dtjava.launch(app, platform, callbacks)

    Launches applications that are deployed outside of the browser, based on a given application descriptor. If JRE installation is required, then by default the Deployment Toolkit performs the following actions:

    • Attempts to start the JRE installer.

    • If automated installation of the Runtime is not possible, presents a popup request for the user to install manually.

  • dtjava.install(platform, callbacks)

    Initiates installation of required components according to platform requirements.

  • dtjava.validate(platform)

    Validates that the user's environment satisfies platform requirements, for example, verifies that the required version of the JRE is available. Returns PlatformMismatchEvent describing problems, if any.

  • dtjava.hideSplash(id)

    Hides the HTML splash screen for an application with a given ID. If the splash screen does not exist, this method has no effect. For JavaFX applications, this method is called automatically after the application is ready.

See the following sections for more information about arguments taken by these methods.

19.1.1 Application Descriptor (dtjava.App)

The application launch descriptor is an instance of the dtjava.App object. The launch descriptor contains all of the details describing what needs to be launched. The dtjava.App constructor takes the following parameters:

dtjava.App(url, {attribute_map});

The first parameter is the required url attribute, which contains a URL or a relative link to the JNLP file. The second parameter is a subset of the attributes that are described in the following list:

  • id

    Identifier of the application. The identifier is expected to be unique on the web page. If the identifier is null, then an identifier is autogenerated. Later, the identifier can be used to get the handle of the application in JavaScript code.

  • jnlp_content

    (optional) Content of the JNLP file in BASE64 encoding.

  • params

    The set of named parameters to pass to an application, if any. This attribute takes the following form:

    params: { variable: 'value' }

  • width and height

    Dimensions used to reserve space for an embedded application. The values can be absolute in pixels, or relative, for example, 50 or 50%.

  • placeholder

    Reference to a DOM node, or an identifier of a DOM node, in which to embed an application.

  • toolkit

    Identifies the UI toolkit used. Use fx for JavaFX applications, use swing for Swing applications. If no value is specified, the parameter defaults to fx.

Note:

The width, height, and placeholder attributes are required for applications that run in the browser (in other words, applications that use the dtjava.embed() method, but not for other types of deployment, such as applications that use the dtjava.launch() method).

Example 19-1 shows an example of application launch descriptor code for an application that runs in the browser.

Example 19-1 Creating a dtjava.App Object

var app = new dtjava.App(
        'ssh.jnlp',
    {
        id: 'SSH',
        width: 100,
        height: 25,
        placeholder: 'SSH_application_container',
        params: {
            config: 'ssh_application.conf',
        }
    }
);

19.1.2 Platform (dtjava.Platform)

Platform requirements for an application to launch are defined by the dtjava.Platform object. The following attributes are supported:

  • javafx

    The minimum JavaFX version needed. Default is null.

  • jvm

    Minimum version of the JRe needed. The default is 1.6+.

  • jvmargs

    List of requested JVM arguments. The default is null.

Version strings are treated according to the following rules:

  • The null version string is treated as if there is no requirement to have it installed. Validation passes whether this component is installed or not.

  • The version pattern strings are of the form #[.#[.#[_#]]][+|*], which includes strings such as "1.7", "2.2*", and "1.7.0_25+".

  • An asterisk (*) means any version within this family, where family is defined by a prefix.

  • A plus sign (+) means any version greater or equal to the specified version.

  • If the version pattern does not include all four version components but does not end with an asterisk or plus sign, it will be treated as if it ended with an asterisk.

To clarify the differences, consider the following examples:

  • "1.6.0*" matches 1.6.0_25 but not 1.7.0_01, whereas "1.6.0+" or "1.*" matches both.

  • "2.1" is equivalent to "2.1*",and matches any version number beginning with "2.1".

  • Both asterisk and plus sign patterns match any installed version of the component. However, if the component is not installed, then validation fails.

Example 19-2 shows a dtjava.Platform object:

Example 19-2 Example of a dtjava.Platform Object

var platform = new dtjava.Platform({
                    javafx: "2.2+",
                   jvmargs: "-Dapp.property= ? -Xmx1024m"
                 });

If platform requirements are not met, then dtjava.PlatformMismatchEvent is returned, either as a return value from the validate() method or passed to the onDeployError callback. This object provides the following helper methods to identify root causes:

  • javafxStatus()

    Returns ok if the error was not due to a missing JavaFX Runtime. Otherwise, this method returns one of the following error codes characterizing the problem:

    • none

      No JavaFX runtime is detected on the system.

    • old

      A version of JavaFX Runtime is detected, but it does not match the platform requirements.

    • disabled

      A matching version of JavaFX Runtime is detected, but it is disabled.

    • unsupported

      JavaFX is not supported on this platform.

  • jreStatus()

    Returns ok if the error was not due to a missing JRE. Otherwise, this method returns one of the following error codes characterizing the problem:

    • none

      No JRE was detected on the system.

    • old

      A version of the JRE is detected, but it does not match the platform requirements.

    • oldplugin

      A matching JRE was found, but it is configured to use a deprecated Java plug-in.

  • canAutoInstall()

    Returns true if the installation of missing components can be triggered automatically or if there are no missing components.

  • isRelaunchNeeded()

    Returns true if a browser must be restarted before the application can be loaded. This often is true in conjunction with the need to perform an installation.

  • isUnsupportedBrowser()

    Returns true if the current browser is not supported, for example, when the browser is out of date.

  • isUnsupportedPlatform()

    Returns true if this platform does not satisfy the supported platform requirements. For example, a JavaFX application attempts to launch on Solaris, which is not supported.

  • javafxInstallerURL (locale)

    Returns the URL of a page to download and install the required version of the JRE manually. If a matching JRE is already installed or not supported, then the return value is null.

  • jreInstallerURL (locale)

    Returns the URL of a page to visit to install the required version of Java. If a matching JRE is already installed or not supported, then the return value is null.

19.2 Callbacks

The Deployment Toolkit provides a set of hooks that can be used to customize startup behavior. To use the hook, the developer must provide a callback function. The following hooks are supported:

  • onDeployError: function(app, mismatchEvent)

    Called when platform requirements are not met.

  • onInstallFinished: function(placeholder, component, status, relaunchNeeded)

    Called after the installation of a required component is completed, unless installation was started manually.

  • onInstallNeeded: function(app, platform, cb, isAutoinstall, needRelaunch, launchFunc)

    Called if embedding or launching an application needs additional components to be installed.

  • onInstallStarted - function(placeholder, component, isAuto, restartNeeded)

    Called before installation of the required component is triggered.

The following hooks are specific to embedded applications:

  • onGetNoPluginMessage function(app)

    Called to get content shown in the application area if the Java Plug-in is not installed and none of the callbacks have helped.

  • onGetSplash: function(app)

    For embedded applications, called to get the content of the splash screen.

  • onJavascriptReady: function(id)

    Called after the application is ready to accept JavaScript calls.

  • onRuntimeError: function(id)

    Called if the application failed to launch.

19.2.1 onDeployError

This handler can be utilized to customize error handling behavior, such as showing messages in the user's language. See the example in Section 19.3.8, "Create a Handler for an Unsupported Platform" for an example of the onDeployError handler.

A callback function is called if the application cannot be deployed because the current platform does not match the given platform requirements. It is also called if a request to install missing components cannot be completed due to platform incompatibility.

Function signature:

onDeployError : function(app, mismatchEvent)

The problem can be a fatal error or a transient issue, such as a required relaunch. Further details can be extracted from the mismatchEvent that is provided. Here are some typical combinations:

  • The browser is not supported by Java.

    mismatchEvent.isUnsupportedBrowser() returns true

  • The browser must be restarted before the application can be launched.

    mismatchEvent.isRelaunchNeeded() returns true

JRE-specific codes:

  • JRE is not supported on this platform.

    mismatchEvent.jreStatus() == "unsupported"

  • JRE is not detected and must be installed.

    mismatchEvent.jreStatus() == "none"

  • The installed version of JRE does not match application requirements.

    mimatchEvent.jreStatus() == "old"

  • A matching JRE is detected, but a deprecated Java Plug-in is used.

    mimatchEvent.jreStatus() == "oldplugin"

JavaFX-specific codes:

  • JavaFX is not supported on this platform.

    mismatchEvent.javafxStatus() == "unsupported"

  • JavaFX Runtime is missing and must be installed manually.

    mismatchEvent.javafxStatus() == "none"

  • The installed version of JavaFX Runtime does not match application requirements.

    mismatchEvent.javafxStatus() == "old"

  • JavaFX Runtime is installed but is disabled.

    mismatchEvent.javafxStatus() == "disabled"

The default error handler handles both application launch errors and embedded content.

19.2.2 onGetNoPluginMessage

This handler is called to get content to be shown in the application area if the Java Plug-in is not installed and none of the callbacks helped to resolve the situation.

Function signature:

onGetNoPluginMessag : function(app)

19.2.3 onGetSplash

This handler gets the content of the splash screen when the application is embedded in a browser.

Function signature:

onGetSplash: function(app)

Gets the application launch descriptor as input. If null is returned, then the splash screen is disabled. A non-null return value is expected to be a HTML code to be added into the splash overlay. Note that the splash overlay does not enforce any specific size. You must ensure that the custom splash image is sized to fit the area in which the application will run.

For examples of customizing the splash screen, see Section 19.3.7, "Add a Custom HTML Splash Screen" and Section 19.3.6, "Disable the HTML Splash Screen."

Note:

Automatically hiding the splash screen is only supported by JavaFX applications. If you are deploying a Swing applet, then the application must call dtjava.hideSplash() explicitly to hide the splash screen. See Example 6-6 on the Swing deployment page.

19.2.4 onInstallFinished

This handler is called after the installation of a required component is completed. This method is not called if the installation is performed in manual mode.

Function signature:

onInstallFinished: function(placeholder, component, status, relaunchNeeded)

Parameters:

  • placeholder: A DOM element that was passed to onInstallStarted to insert visual feedback.

  • component: String "jre" or "javafx"

  • status: String that categorizes the status of the installation, for example, "success", "error:generic", "error:download" or "error:canceled".

  • relaunchNeeded: Boolean value to specify if a browser restart is required to complete the installation.

19.2.5 onInstallNeeded

This handler is called if the embedding or launching application needs additional components to be installed. This callback is responsible for handling situations such as reporting to the user the need to install something, initiating installation using install(), and hiding the splash screen for embedded applications, if needed. After installation is complete, the callback implementation can retry the attempt to launch the application using the provided launch function.

This method is not called if the platform requirement could not be met, for example, if the platform is not supported or if installation is not possible.

The default handler provides a click-to-install solution for applications embedded in a browser and attempts to perform installation without additional questions for applications that have been started using launch().

If the handler is null, then it is treated as a no-op handler.

Function signature:

onInstallNeeded: function(app, platform, cb, isAutoinstall, needRelaunch, launchFunc)

Parameters:

  • app: Application launch descriptor. For embedded applications, app.placeholder refers to the root of the embedded application area in the DOM tree, which is used for visual feedback.

  • platform: Application platform requirements.

  • cb: The set of callbacks to be used during the installation process.

  • isAutoinstall: True, if the installation can be launched automatically.

  • needRestart: True, if restarting the browser is required after installation is complete.

  • launchFunction: Function to be executed to retry launching the application after the installation is finished.

19.2.6 onInstallStarted

This handler is called before the installation of the required component is triggered. For a manual installation scenario, it is called before the installation page is opened.

This hook can be used to provide visual feedback to the user during the installation. The placeholder points to the area that can be used for visualization. For embedded applications, this is the area into which the application will be embedded. If null, then the object called must find a place for display on its own.

In case of automatic launch of the installation, onInstallFinished is called after installation is complete, successfully or not.

If the handler is null, then it is treated as no-op handler.

Function signature:

onInstallStarted: function(placeholder, component, isAuto, restartNeeded)

Parameters:

  • placeholder: The DOM element to insert visual feedback into. If null, then the object called must add visual feedback to the document on its own, for example, embedding the application into a web page.

  • component: String "Java", "JavaFX", or "Java bundle".

  • isAutoInstall: True, if the installer is launched automatically.

  • restartNeeded: Boolean value to specify if a browser restart is required.

19.2.7 onJavascriptReady

This handler is called after the embedded application is ready to accept JavaScript calls.

Function signature:

onJavascriptReady: function(id)

19.2.8 onRuntimeError

This handler is called if the embedded application fails to launch.

Function signature:

onRuntimeError: function(id)

19.3 Examples

This section shows examples of deployment that use the Deployment Toolkit.

Note:

Some of the Deployment Toolkit methods might not be fully operational if used before the web page body is loaded, because the Deployment Toolkit plug-ins cannot be instantiated. If you intend to use the Deployment Toolkit before the web page DOM tree is constructed, then dtjava.js must be loaded inside the <body> element of the page and called before any other Deployment Toolkit APIs.

To initiate deployment, use onload handlers to add the application after the HTML content is loaded, for the following reasons:

  • The DOM tree must exist when the application content is inserted. The DOM tree is created after the HTML content page loads.

  • The Deployment Toolkit's detection code does not prevent loading of the HTML page.

  • The Deployment Toolkit avoids loading concurrently with other resources that are needed for the page.

19.3.1 Embedded Application Starts After the DOM Tree Is Constructed

Example 19-3 shows the default deployment scenario for applications embedded in a web page. The application is added to the web page in the deployIt() function. This function is called after the page is loaded and its DOM tree is constructed. The position of the application in the DOM tree is determined by the value of the placeholder parameter. In this case, the application is inserted into a <div> tag with id="place".

Adding the application to a web page after the main page is loaded helps to get a complete web page, including the embedded application, to load faster, because the application starts concurrently with loading other resources required by the web page.

Note that the value of the placeholder element can be a string or a JavaScript variable pointing to the container DOM node. If that node is detached from the document DOM tree, then the application is not initialized until the parent node is attached to the DOM tree.

Example 19-3 Insert the Application into the HTML Body with a Placeholder

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function deployIt() {
            dtjava.embed(
                    {         id: "myApp",
                             url: "Fish.jnlp",
                           width: 300,
                          height: 200,
                     placeholder: "place"
                    },
                    { javafx: "2.2+" },
                    {}
            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

19.3.2 Launch a Web Start Application from a Web Page

The canonical form for the link to launch a Java Web Start application is shown in Example 19-4. Either relative or absolute links are acceptable.

Example 19-4 Canonical Link to Launch a Web Start Application

<a href="my.jnlp"
   onclick="dtjava.launch(new dtjava.App('my.jnlp'));
   return false;">Launch me!</a>

An alternative simplified syntax is shown in Example 19-5.

Example 19-5 Link to Launch a Web Start Application, Simplified

<a href="my.jnlp"
   onclick="dtjava.launch({url: 'my.jnlp'});
   return false;">Launch me!</a>

A third form for simple applications is shown in the following example.

Example 19-6 Link to Launch a Web Start Application, Third Example

<a href="my.jnlp"
   onclick="dtjava.launch('my.jnlp');
   return false;">Launch me!</a>

If JavaScript is disabled in the browser, the Deployment Toolkit does not work. In this case, the browser tries to use the href attribute. If the JRE is installed, then the application launches. The return false; statement ensures that the browser does not leave the current page if the launch is successful.

19.3.3 Pass Parameters to a Web Application

You can pass dynamic parameters to applications from a web page. For this you need to add a set of named parameters as the params attribute of the application descriptor.

In Example 19-7, the embedded application gets two dynamic parameters from the web page. Note that the "zip" parameter is assigned with the value of the JavaScript variable.

Example 19-7 Pass Parameters to an Embedded Application

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function deployIt() {
            var zipcode = 95054;

            dtjava.embed(
                {            id: "myApp",
                            url: "Map.jnlp",
                          width: 300,
                         height: 200,
                    placeholder: "place",
                    params: {
                              mode: "streetview",
                              zip: zipcode
                    }
                },
                { javafx: "2.2+" },
                {}
            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

The same approach works for Java Web Start applications if the user has JRE 7u6 or later. Here is an example:

Example 19-8 Pass Parameters to a Web Start Application

<script>
    var zipcode = 95054;

    function launchApp() {
        dtjava.launch(
            {   url: 'my.jnlp',
                params: {
                           mode: "streetview",
                           zip: zipcode
                }
            },
            {   javafx : '2.2+'  },
            {}
        );
        return false;
    }
</script>

<a href="my.jnlp" onclick="launchApp(); return false;">
    Launch me!
</a>

To access parameters in the application code, use the getParameters() method of the Application class, for example:

String zipcode = app.getParameters().getNamed("zip");

19.3.4 Specify Platform Requirements and Pass JVM Options

Use the second argument group of the dtjava.embed() function to specify platform requirements for the application.

In Example 19-9, JRE 1.7 or later is specified in the jvm parameter; JavaFX 2.2 or later is specified in the javafx parameter; and the jvmargs parameter indicates that the application should be executed in the Java Virtual Machine (JVM) with a 1 gigabyte heap size and given options.

Example 19-9 Specify Platform Requirements and Passing JVM Properties

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function deployIt() {
            dtjava.embed(
                {            id: "my",
                            url: "app.jnlp",
                          width: 300,
                         height: 200,
                    placeholder: "place"
                },
                {
                        jvm: "1.7.0+",
                     javafx: "2.2+",
                    jvmargs: "-Dapp.property=somevalue -Xmx1024m"
                }
            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

19.3.5 Access Your Code from JavaScript

To access a Java or JavaFX application from JavaScript, you must get a reference to the JavaScript object representing the application. Specify an id parameter in the first argument group of the dtjava.embed() function, as shown in Example 19-3.

For example, if an id parameter is set to my, then a public method of the application can be accessed with the script shown in Example 19-10.

Example 19-10 Access an Application Method with an id Parameter

<script>
    var a = document.getElementById("my");
    a.java_method();
</script>

Attempts to call application methods might not work until the application finishes the initialization phase. For a description of startup phases, see Section 4.2, "Application Startup Process, Experience, and Customization." To access an application while it is loading, use an onJavascriptReady callback, as shown in Example 19-11.

Example 19-11 Access an Application Method While the Application Is Loading

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function callApp(id) {
            //it is safe to call now
            var a = document.getElementById(id);
            a.java_method();
        }
        function deployIt() {
            dtjava.embed(
                {            id: "my",
                            url: "fxapp.jnlp",
                          width: 300,
                         height: 200,
                    placeholder: "place"
                    },
                    {},
                    {
                        onJavascriptReady: callApp
                    }

            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

19.3.6 Disable the HTML Splash Screen

To disable the HTML splash screen for a JavaFX application, add an onGetSplash handler that returns null:, as shown in Example 19-12. For information about application startup phases, see Section 4.2, "Application Startup Process, Experience, and Customization."

Example 19-12 Disable the HTML Splash Screen

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function deployIt() {
            dtjava.embed(
                {            id: "my",
                            url: "app.jnlp",
                          width: 300,
                         height: 200,
                    placeholder: "place"
                },
                {
                       jvm: "1.7.0+",
                    javafx: "2.2+",
                },
                {
                    onGetSplash: function(app) {return null;}
                }
            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

If you are deploying a Swing applet, then the application must call dtjava.hideSplash() explicitly to hide the splash screen.

19.3.7 Add a Custom HTML Splash Screen

Example 19-13 shows how to replace the default HTML splash screen with a green rectangle, defined in a JavaScript function.

Example 19-13 Replace the Splash Screen with a Custom One

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function getSplash(app) {
            //custom splash - green rectangle
            var p = document.createElement('div');
            p.style.width  = app.width;
            p.style.height = app.height;
            p.style.background="green";
            return p;
        }

        function deployIt() {
            dtjava.embed(
                {            id: "my",
                            url: "app.jnlp",
                          width: 300,
                         height: 200,
                    placeholder: "place"
                },
                {
                       jvm: "1.7.0+",
                    javafx: "2.2+",
                },
                {
                    onGetSplash: getSplash
                }
            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

19.3.8 Create a Handler for an Unsupported Platform

Example 19-14 shows the use of JavaScript to handle an unsupported browser.

Example 19-14 Handle an Unsupported Browser with JavaScript

<head>
    <script type="text/javascript" src="https://java.com/js/dtjava.js"></script>
    <script>
        function reportError(app, r) {
            //ovewrite behavior for unsupported browser
            var a = app.placeholder;
            if (a != null && r.isUnsupportedBrowser()) {
                var p = document.createElement('div');
                p.id = "splash";
                p.style.width  = app.width;
                p.style.height = app.height;
                p.style.background="red";
                p.appendChild(
                  document.createTextNode("This browser is not supported."));

                //clear embedded application placeholder
                while(a.hasChildNodes()) a.removeChild(a.firstChild);

                //show custom message
                a.appendChild(p);
            } else {
                //use default handlers otherwise
                var def = new dtjava.Callbacks();
                return def.onDeployError(app, r);
            }
        }

        function deployIt() {
            dtjava.embed(
                {       id: "my",
                       url: "app.jnlp",
                     width: 300,
                    height: 200
                },
                {
                       jvm: "1.7.0+",
                    javafx: "2.2+",
                },
                {
                    onDeployError: reportError
                }
            );
        }
        dtjava.addOnloadCallback(deployIt);
    </script>
</head>
<body>
    <div id="place"></div>
</body>

19.3.9 Check for Presence of JavaFX Runtime

Example 19-15 shows the use of JavaScript to replace the default text offering to install JavaFX. It is replaced with an offer to start the application only if the correct version of JavaFX is found on the user's system.

Example 19-15 Launch Only If JavaFX Is Installed

<html>
    <head>
        <script type="text/javascript"
                src="https://java.com/js/dtjava.js"></script>
        <script>
            function mayBeOfferLaunch() {
                var platform = new dtjava.Platform({'javafx' : '2.2+'});

                //check if validate find any problems
                if (dtjava.validate(platform) == null) {
                    var t = document.getElementById("text");
                    t.innerHTML = "<a href='my.jnlp' " +
                    "onclick='dtjava.launch({url: 'my.jnlp'}); return false;'>" +
                    "Launch me!</a>";
                }
            }
            dtjava.addOnloadCallback(mayBeOfferLaunch);
        </script>
    </head>
    <body>
        <div id="text">To view this content you need
       <a href="http://javafx.com">to install
           JavaFX Runtime 2.2</a>.</div>
    </body>
</html>
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.doctree.DeprecatedTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.DeprecatedTree

  • Packages that use DeprecatedTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DeprecatedTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DeprecatedTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitDeprecated(DeprecatedTree node, P p)

    • Uses of DeprecatedTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type DeprecatedTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitDeprecated(DeprecatedTree node, P p)
      R | DocTreeScanner.visitDeprecated(DeprecatedTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


How and When To Deprecate APIs

  • What "Deprecated" Means
  • When to Deprecate
  • How to Deprecate
    • Using the @Deprecated Annotation
    • Using the @deprecated Javadoc Tag

What "Deprecated" Means

You may have heard the term, "self-deprecating humor," or humor that minimizes the speaker's importance. A deprecated class or method is like that. It is no longer important. It is so unimportant, in fact, that you should no longer use it, since it has been superseded and may cease to exist in the future.

Java provides a way to express deprecation because, as a class evolves, its API (application programming interface) inevitably changes: methods are renamed for consistency, new and better methods are added, and fields change. But such changes introduce a problem. You need to keep the old API around until developers make the transition to the new one, but you don't want them to continue programming to the old API.

The ability to deprecate a class, method, or member field solves the problem. Java supports two mechanisms for deprecation: and an annotation, (supported starting with J2SE 5.0) and a Javadoc tag (supported since 1.1). Existing calls to the old API continue to work, but the annotation causes the compiler to issue a warning when it finds references to deprecated program elements. The Javadoc tag and associated comments warn users against using the deprecated item and tell them what to use instead.

When to Deprecate

When you design an API, carefully consider whether it supersedes an old API. If it does, and you wish to encourage developers (users of the API) to migrate to the new API, then deprecate the old API. Valid reasons to deprecate an API include:

  • It is insecure, buggy, or highly inefficient
  • It is going away in a future release
  • It encourages bad coding practices

Deprecation is a reasonable choice in all these cases because it preserves "backward compatibility" while encouraging developers to change to the new API. Also, the deprecation comments help developers decide when to move to the new API, and so should briefly mention the technical reasons for deprecation.

It is not necessary to deprecate individual member fields (properties) of a deprecated class, unless of course you want to explain a specific point about a property.

How to Deprecate

Starting with J2SE 5.0, you deprecate a class, method, or field by using the @Deprecated annotation. Additionally, you can use the @deprecated Javadoc tag tell developers what to use instead.

Using the annotation causes the Java compiler to generate warnings when the deprecated class, method, or field is used. The compiler suppresses deprecation warnings if a deprecated item is used within an entity which itself is deprecated or is used within the same outermost class or is used in an entity that is annotated to suppress the warning.

You are strongly recommended to use the Javadoc @deprecated tag with appropriate comments explaining how to use the new API. This ensures developers will have a workable migration path from the old API to the new API. For more information, see Using the @deprecated Javadoc Tag.

NOTE: The Java Language Specification requires compilers to issue warnings when classes, methods, or fields marked with the @Deprecated annotation are used. Compilers are not required by the Java Language Specification to issue warnings when classes, methods, or fields marked with the @deprecated Javadoc tag are accessed, although the Sun compilers currently do so. However, there is no guarantee that the Sun compiler will always issue such warnings.

Using the @Deprecated Annotation

J2SE 5.0 introduces a new language feature called annotations (also called metadata). One of the Java language's built-in annotations is the @Deprecated annotation. To use it, you simply precede the class, method, or member declaration with "@Deprecated."

Using the @Deprecated annotation to deprecate a class, method, or field ensures that all compilers will issue warnings when code uses that program element. In contrast, there is no guarantee that all compilers will always issue warnings based on the @deprecated Javadoc tag, though the Sun compilers currently do so. Other compilers may not issue such warnings. Thus, using the @Deprecated annotation to generate warnings is more portable that relying on the @deprecated Javadoc tag.

In addition, the @Deprecated annotation causes the javadoc-generated documentation to be marked "Deprecated" wherever that program element appears.

NOTE: Deprecation applies to classes and to individual methods or properties, not to their names. It is possible for a single method to have deprecated and non-deprecated overloadings. It is possible for a non-deprecated property to hide or override a deprecated one, which removes deprecation. As developer of an API, it is your responsibility to deprecate overrides of a deprecated method, if in fact they should be deprecated.

Example

The following is a simple example of using the @Deprecated annotation from java.lang.Thread:

public
class Thread implements Runnable {
...
@Deprecated
    public final void stop() {
  synchronized (this) {
...

Using the @deprecated Javadoc Tag

You can use the @deprecated tag to make Javadoc show a program element as deprecated. The @deprecated tag must be followed by a space or newline. In the paragraph following the @deprecated tag, explain why the item has been deprecated and suggest what to use instead.

Javadoc generates special HTML based on @deprecated tags: it moves the paragraph following the @deprecated tag to the front of the description, placing it in italics and preceding it with a warning, "Note: foo is deprecated", in bold. It also adds "Deprecated" in bold to any index entries mentioning the deprecated entity.

The tagged paragraph can be empty, but empty deprecation paragraphs are bad form, because they do not help the user fix the warnings that arise from the deprecation. Include paragraphs marked with @link or @see tags that refer to the new versions of the same functionality. It is usually not a good idea to mention a timetable for phase-out of the deprecated API; this is a business decision that is best communicated other ways.

For more information on using the @deprecated Javadoc tag, see Javadoc - The Java API Documentation Generator.

Example

The following examples show how to use the @deprecated Javadoc tag. They also illustrate the @Deprecated annotation, to emphasize that the two should be used together.

Here is an example of the most common form of a deprecated method (for Javadoc 1.2 and later):

/**
 * @deprecated  As of release 1.3, replaced by {@link #getPreferredSize()}
 */
@Deprecated public Dimension preferredSize() {
return getPreferredSize();
}

If the API reorganization was more than renaming, the deprecation may be more complex. Here is an example of a method that is being retracted:

/**
 * Delete multiple items from the list.
 *
 * @deprecated  Not for public use.
 *    This method is expected to be retained only as a package
 *    private method.  Replaced by
 *    {@link #remove(int)} and {@link #removeAll()}
 */
@Deprecated public synchronized void delItems(int start, int end) {
...
}
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of Java Conceptual Diagram

The Java conceptual diagram categorizes Java component technologies in levels. The following lists these levels, from top to bottom, and the technologies that are part of each one. Technologies that are part of a lower level serve as a foundation for those that are part of a higher level.

  • Java Language
  • Tools & Tool APIs
    • java
    • javac
    • javadoc
    • jar
    • javap
    • JPDA
    • JConsole
    • Java VisualVM
    • Java DB
    • Security
    • Int'l
    • RMI
    • IDL
    • Deploy
    • Monitoring
    • Troubleshoot
    • Scripting
    • JVM TI
    • Web Services
  • Deployment
    • Java Web Start
    • Applet / Java Plug-in
  • User Interface Toolkits
    • JavaFX
    • AWT
    • Swing
    • Java 2D
    • Accessibility
    • Drag and Drop
    • Input Methods
    • Image I/O
    • Print Service
    • Sound
  • Integration Libraries
    • IDL
    • JDBC
    • JNDI
    • RMI
    • RMI-IIOP
    • Scripting
  • Other Base Libraries
    • Beans
    • Int'l Support
    • Input/Output
    • JMX
    • JNI
    • Math
    • Networking
    • Override Mechanism
    • Security
    • Serialization
    • Extension Mechanism
    • XML JAXP
  • lang and util Base Libraries
    • lang and util
    • Collections
    • Concurrency Utilities
    • JAR
    • Logging
    • Management
    • Preferences API
    • Ref Objects
    • Reflection
    • Regular Expressions
    • Versioning
    • Zip
    • Instrumentation
  • Java Virtual Machine
    • Java Hotspot Client and Server VM

The JDK consists of all levels.

The JRE consists of the following levels:

  • Deployment
  • User Interface Toolkits
  • Integration Libraries
  • Other Base Libraries
  • lang and util Base Libraries
  • Java Virtual Machine

The Java SE API consists of the following levels:

  • User Interface Toolkits except JavaFX
  • Integration Libraries
  • Other Base Libraries
  • lang and util Base Libraries

Compact Profiles consists of the following levels:

  • Integration Libraries
  • Other Base Libraries
  • lang and util Base Libraries
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Design Overview

Documentation Contents
Contents | Previous | Next

Chapter 2: Design Overview

This chapter focuses on major design issues in the JNI. Most design issues in this section are related to native methods. The design of the Invocation API is covered in Chapter 5: The Invocation API.

This chapter covers the following topics:

  • JNI Interface Functions and Pointers
  • Compiling, Loading and Linking Native Methods
    • Resolving Native Method Names
    • Native Method Arguments
  • Referencing Java Objects
    • Global and Local References
    • Implementing Local References
  • Accessing Java Objects
    • Accessing Primitive Arrays
    • Accessing Fields and Methods
  • Java Exceptions
    • Exceptions and Error Codes
    • Asynchronous Exceptions
    • Exception Handling

JNI Interface Functions and Pointers

Native code accesses Java VM features by calling JNI functions. JNI functions are available through an interface pointer. An interface pointer is a pointer to a pointer. This pointer points to an array of pointers, each of which points to an interface function. Every interface function is at a predefined offset inside the array. The following figure, Interface Pointer, illustrates the organization of an interface pointer.

Description of Figure Interface Pointer

The JNI interface is organized like a C++ virtual function table or a COM interface. The advantage to using an interface table, rather than hard-wired function entries, is that the JNI name space becomes separate from the native code. A VM can easily provide multiple versions of JNI function tables. For example, the VM may support two JNI function tables:

  • one performs thorough illegal argument checks, and is suitable for debugging;
  • the other performs the minimal amount of checking required by the JNI specification, and is therefore more efficient.

The JNI interface pointer is only valid in the current thread. A native method, therefore, must not pass the interface pointer from one thread to another. A VM implementing the JNI may allocate and store thread-local data in the area pointed to by the JNI interface pointer.

Native methods receive the JNI interface pointer as an argument. The VM is guaranteed to pass the same interface pointer to a native method when it makes multiple calls to the native method from the same Java thread. However, a native method can be called from different Java threads, and therefore may receive different JNI interface pointers.

Compiling, Loading and Linking Native Methods

Since the Java VM is multithreaded, native libraries should also be compiled and linked with multithread aware native compilers. For example, the -mt flag should be used for C++ code compiled with the Sun Studio compiler. For code complied with the GNU gcc compiler, the flags -D_REENTRANT or -D_POSIX_C_SOURCE should be used. For more information please refer to the native compiler documentation.

Native methods are loaded with the System.loadLibrary method. In the following example, the class initialization method loads a platform-specific native library in which the native method f is defined:

package pkg;

class Cls {
    native double f(int i, String s);
    static {
        System.loadLibrary(“pkg_Cls”);
    }
}

The argument to System.loadLibrary is a library name chosen arbitrarily by the programmer. The system follows a standard, but platform-specific, approach to convert the library name to a native library name. For example, a Solaris system converts the name pkg_Cls to libpkg_Cls.so, while a Win32 system converts the same pkg_Cls name to pkg_Cls.dll.

The programmer may use a single library to store all the native methods needed by any number of classes, as long as these classes are to be loaded with the same class loader. The VM internally maintains a list of loaded native libraries for each class loader. Vendors should choose native library names that minimize the chance of name clashes.

A native library may be statically linked with the VM. The manner in which the library and VM image are combined is implementation dependent. A System.loadLibrary or equivalent API must succeed for this library to be considered loaded.

A library L whose image has been combined with the VM is defined as statically linked if and only if the library exports a function called JNI_OnLoad_L.

If a statically linked library L exports a function called JNI_OnLoad_L and a function called JNI_OnLoad, the JNI_OnLoad function will be ignored.

If a library L is statically linked, then upon the first invocation of System.loadLibrary("L") or equivalent API, a JNI_OnLoad_L function will be invoked with the same arguments and expected return value as specified for the JNI_OnLoad function.

A library L that is statically linked will prohibit a library of the same name from being loaded dynamically.

When the class loader containing a statically linked native library L is garbage collected, the VM will invoke the JNI_OnUnload_L function of the library if such a function is exported.

If a statically linked library L exports a function called JNI_OnUnLoad_L and a function called JNI_OnUnLoad, the JNI_OnUnLoad function will be ignored.

The programmer can also call the JNI function RegisterNatives() to register the native methods associated with a class. The RegisterNatives() function is particularly useful with statically linked functions.

Resolving Native Method Names

Dynamic linkers resolve entries based on their names. A native method name is concatenated from the following components:

  • the prefix Java_
  • a mangled fully-qualified class name
  • an underscore (“_”) separator
  • a mangled method name
  • for overloaded native methods, two underscores (“__”) followed by the mangled argument signature

The VM checks for a method name match for methods that reside in the native library. The VM looks first for the short name; that is, the name without the argument signature. It then looks for the long name, which is the name with the argument signature. Programmers need to use the long name only when a native method is overloaded with another native method. However, this is not a problem if the native method has the same name as a nonnative method. A nonnative method (a Java method) does not reside in the native library.

In the following example, the native method g does not have to be linked using the long name because the other method g is not a native method, and thus is not in the native library.

class Cls1 {
    int g(int i);
    native int g(double d);
}

We adopted a simple name-mangling scheme to ensure that all Unicode characters translate into valid C function names. We use the underscore (“_”) character as the substitute for the slash (“/”) in fully qualified class names. Since a name or type descriptor never begins with a number, we can use _0, ..., _9 for escape sequences, as the following table illustrates:

Unicode Character Translation
Escape Sequence | Denotes
_0XXXX | a Unicode character XXXX. Note that lower case is used to represent non-ASCII Unicode characters, for example, _0abcd as opposed to _0ABCD.
_1 | the character “_”
_2 | the character “;” in signatures
_3 | the character “[“ in signatures

Both the native methods and the interface APIs follow the standard library-calling convention on a given platform. For example, UNIX systems use the C calling convention, while Win32 systems use __stdcall.

Native Method Arguments

The JNI interface pointer is the first argument to native methods. The JNI interface pointer is of type JNIEnv. The second argument differs depending on whether the native method is static or nonstatic. The second argument to a nonstatic native method is a reference to the object. The second argument to a static native method is a reference to its Java class.

The remaining arguments correspond to regular Java method arguments. The native method call passes its result back to the calling routine via the return value. Chapter 3: JNI Types and Data Structures describes the mapping between Java and C types.

The following code example illustrates using a C function to implement the native method f. The native method f is declared as follows:

package pkg;

class Cls {
    native double f(int i, String s);
    // ...
}

The C function with the long mangled name Java_pkg_Cls_f_ILjava_lang_String_2 implements native method f:

jdouble Java_pkg_Cls_f__ILjava_lang_String_2 (
     JNIEnv *env,        /* interface pointer */
     jobject obj,        /* "this" pointer */
     jint i,             /* argument #1 */
     jstring s)          /* argument #2 */
{
     /* Obtain a C-copy of the Java string */
     const char *str = (*env)->GetStringUTFChars(env, s, 0);

     /* process the string */
     ...

     /* Now we are done with str */
     (*env)->ReleaseStringUTFChars(env, s, str);

     return ...
}

Note that we always manipulate Java objects using the interface pointer env. Using C++, you can write a slightly cleaner version of the code, as shown in the following code example:

extern "C" /* specify the C calling convention */

jdouble Java_pkg_Cls_f__ILjava_lang_String_2 (

     JNIEnv *env,        /* interface pointer */
     jobject obj,        /* "this" pointer */
     jint i,             /* argument #1 */
     jstring s)          /* argument #2 */

{
     const char *str = env->GetStringUTFChars(s, 0);

     // ...

     env->ReleaseStringUTFChars(s, str);

     // return ...
}

With C++, the extra level of indirection and the interface pointer argument disappear from the source code. However, the underlying mechanism is exactly the same as with C. In C++, JNI functions are defined as inline member functions that expand to their C counterparts.

Referencing Java Objects

Primitive types, such as integers, characters, and so on, are copied between Java and native code. Arbitrary Java objects, on the other hand, are passed by reference. The VM must keep track of all objects that have been passed to the native code, so that these objects are not freed by the garbage collector. The native code, in turn, must have a way to inform the VM that it no longer needs the objects. In addition, the garbage collector must be able to move an object referred to by the native code.

Global and Local References

The JNI divides object references used by the native code into two categories: local and global references. Local references are valid for the duration of a native method call, and are automatically freed after the native method returns. Global references remain valid until they are explicitly freed.

Objects are passed to native methods as local references. All Java objects returned by JNI functions are local references. The JNI allows the programmer to create global references from local references. JNI functions that expect Java objects accept both global and local references. A native method may return a local or global reference to the VM as its result.

In most cases, the programmer should rely on the VM to free all local references after the native method returns. However, there are times when the programmer should explicitly free a local reference. Consider, for example, the following situations:

  • A native method accesses a large Java object, thereby creating a local reference to the Java object. The native method then performs additional computation before returning to the caller. The local reference to the large Java object will prevent the object from being garbage collected, even if the object is no longer used in the remainder of the computation.
  • A native method creates a large number of local references, although not all of them are used at the same time. Since the VM needs a certain amount of space to keep track of a local reference, creating too many local references may cause the system to run out of memory. For example, a native method loops through a large array of objects, retrieves the elements as local references, and operates on one element at each iteration. After each iteration, the programmer no longer needs the local reference to the array element.

The JNI allows the programmer to manually delete local references at any point within a native method. To ensure that programmers can manually free local references, JNI functions are not allowed to create extra local references, except for references they return as the result.

Local references are only valid in the thread in which they are created. The native code must not pass local references from one thread to another.

Implementing Local References

To implement local references, the Java VM creates a registry for each transition of control from Java to a native method. A registry maps nonmovable local references to Java objects, and keeps the objects from being garbage collected. All Java objects passed to the native method (including those that are returned as the results of JNI function calls) are automatically added to the registry. The registry is deleted after the native method returns, allowing all of its entries to be garbage collected.

There are different ways to implement a registry, such as using a table, a linked list, or a hash table. Although reference counting may be used to avoid duplicated entries in the registry, a JNI implementation is not obliged to detect and collapse duplicate entries.

Note that local references cannot be faithfully implemented by conservatively scanning the native stack. The native code may store local references into global or heap data structures.

Accessing Java Objects

The JNI provides a rich set of accessor functions on global and local references. This means that the same native method implementation works no matter how the VM represents Java objects internally. This is a crucial reason why the JNI can be supported by a wide variety of VM implementations.

The overhead of using accessor functions through opaque references is higher than that of direct access to C data structures. We believe that, in most cases, Java programmers use native methods to perform nontrivial tasks that overshadow the overhead of this interface.

Accessing Primitive Arrays

This overhead is not acceptable for large Java objects containing many primitive data types, such as integer arrays and strings. (Consider native methods that are used to perform vector and matrix calculations.) It would be grossly inefficient to iterate through a Java array and retrieve every element with a function call.

One solution introduces a notion of “pinning” so that the native method can ask the VM to pin down the contents of an array. The native method then receives a direct pointer to the elements. This approach, however, has two implications:

  • The garbage collector must support pinning.
  • The VM must lay out primitive arrays contiguously in memory. Although this is the most natural implementation for most primitive arrays, boolean arrays can be implemented as packed or unpacked. Therefore, native code that relies on the exact layout of boolean arrays will not be portable.

We adopt a compromise that overcomes both of the above problems.

First, we provide a set of functions to copy primitive array elements between a segment of a Java array and a native memory buffer. Use these functions if a native method needs access to only a small number of elements in a large array.

Second, programmers can use another set of functions to retrieve a pinned-down version of array elements. Keep in mind that these functions may require the Java VM to perform storage allocation and copying. Whether these functions in fact copy the array depends on the VM implementation, as follows:

  • If the garbage collector supports pinning, and the layout of the array is the same as expected by the native method, then no copying is needed.
  • Otherwise, the array is copied to a nonmovable memory block (for example, in the C heap) and the necessary format conversion is performed. A pointer to the copy is returned.

Lastly, the interface provides functions to inform the VM that the native code no longer needs to access the array elements. When you call these functions, the system either unpins the array, or it reconciles the original array with its non-movable copy and frees the copy.

Our approach provides flexibility. A garbage collector algorithm can make separate decisions about copying or pinning for each given array. For example, the garbage collector may copy small objects, but pin the larger objects.

A JNI implementation must ensure that native methods running in multiple threads can simultaneously access the same array. For example, the JNI may keep an internal counter for each pinned array so that one thread does not unpin an array that is also pinned by another thread. Note that the JNI does not need to lock primitive arrays for exclusive access by a native method. Simultaneously updating a Java array from different threads leads to nondeterministic results.

Accessing Fields and Methods

The JNI allows native code to access the fields and to call the methods of Java objects. The JNI identifies methods and fields by their symbolic names and type signatures. A two-step process factors out the cost of locating the field or method from its name and signature. For example, to call the method f in class cls, the native code first obtains a method ID, as follows:

jmethodID mid = env->GetMethodID(cls, “f”, “(ILjava/lang/String;)D”);

The native code can then use the method ID repeatedly without the cost of method lookup, as follows:

jdouble result = env->CallDoubleMethod(obj, mid, 10, str);

A field or method ID does not prevent the VM from unloading the class from which the ID has been derived. After the class is unloaded, the method or field ID becomes invalid. The native code, therefore, must make sure to:

  • keep a live reference to the underlying class, or
  • recompute the method or field ID

if it intends to use a method or field ID for an extended period of time.

The JNI does not impose any restrictions on how field and method IDs are implemented internally.

Reporting Programming Errors

The JNI does not check for programming errors such as passing in NULL pointers or illegal argument types. Illegal argument types includes such things as using a normal Java object instead of a Java class object. The JNI does not check for these programming errors for the following reasons:

  • Forcing JNI functions to check for all possible error conditions degrades the performance of normal (correct) native methods.
  • In many cases, there is not enough runtime type information to perform such checking.

Most C library functions do not guard against programming errors. The printf() function, for example, usually causes a runtime error, rather than returning an error code, when it receives an invalid address. Forcing C library functions to check for all possible error conditions would likely result in such checks to be duplicated--once in the user code, and then again in the library.

The programmer must not pass illegal pointers or arguments of the wrong type to JNI functions. Doing so could result in arbitrary consequences, including a corrupted system state or VM crash.

Java Exceptions

The JNI allows native methods to raise arbitrary Java exceptions. The native code may also handle outstanding Java exceptions. The Java exceptions left unhandled are propagated back to the VM.

Exceptions and Error Codes

Certain JNI functions use the Java exception mechanism to report error conditions. In most cases, JNI functions report error conditions by returning an error code and throwing a Java exception. The error code is usually a special return value (such as NULL) that is outside of the range of normal return values. Therefore, the programmer can:

  • quickly check the return value of the last JNI call to determine if an error has occurred, and
  • call a function, ExceptionOccurred(), to obtain the exception object that contains a more detailed description of the error condition.

There are two cases where the programmer needs to check for exceptions without being able to first check an error code:

  • The JNI functions that invoke a Java method return the result of the Java method. The programmer must call ExceptionOccurred() to check for possible exceptions that occurred during the execution of the Java method.
  • Some of the JNI array access functions do not return an error code, but may throw an ArrayIndexOutOfBoundsException or ArrayStoreException.

In all other cases, a non-error return value guarantees that no exceptions have been thrown.

Asynchronous Exceptions

In cases of multiple threads, threads other than the current thread may post an asynchronous exception. An asynchronous exception does not immediately affect the execution of the native code in the current thread, until:

  • the native code calls one of the JNI functions that could raise synchronous exceptions, or
  • the native code uses ExceptionOccurred() to explicitly check for synchronous and asynchronous exceptions.

Note that only those JNI function that could potentially raise synchronous exceptions check for asynchronous exceptions.

Native methods should insert ExceptionOccurred()checks in necessary places (such as in a tight loop without other exception checks) to ensure that the current thread responds to asynchronous exceptions in a reasonable amount of time.

Exception Handling

There are two ways to handle an exception in native code:

  • The native method can choose to return immediately, causing the exception to be thrown in the Java code that initiated the native method call.
  • The native code can clear the exception by calling ExceptionClear(), and then execute its own exception-handling code.

After an exception has been raised, the native code must first clear the exception before making other JNI calls. When there is a pending exception, the JNI functions that are safe to call are:

ExceptionOccurred()
ExceptionDescribe()
ExceptionClear()
ExceptionCheck()
ReleaseStringChars()
ReleaseStringUTFChars()
ReleaseStringCritical()
Release<Type>ArrayElements()
ReleasePrimitiveArrayCritical()
DeleteLocalRef()
DeleteGlobalRef()
DeleteWeakGlobalRef()
MonitorExit()
PushLocalFrame()
PopLocalFrame()
Contents | Previous | Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of Figure Interface Pointer

Link to Figure Interface Pointer

This figure consists of three elements appearing from left to right, as well as three ovals labeled "an interface function":

  • Text: "JNI interface pointer"
  • Table of one column and two rows:
    • First row: "Pointer"
    • Second row: "per-thread JNI data structure"
  • Table of one column and four rows titled "Array of pointers to JNI functions":
    • First row: "Pointer." An arrow points from this table cell to an oval labeled "an interface function." No other arrows point to this oval.
    • Second row: "Pointer." An arrow points from this table cell to an oval labeled "an interface function." No other arrows point to this oval.
    • Third row: "Pointer." An arrow points from this table cell to an oval labeled "an interface function." No other arrows point to this oval.
    • Fourth row: "..." (an ellipsis)

Arrows connect these three elements:

  • From the text "JNI interace pointer" to the table cell "Pointer" from the table of one column and two rows
  • From the table cell "Pointer" from the table of one column and two rows to the first row (with the text "Pointer") of the table "Array of pointers to JNI functions"
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Preferences API Design FAQ

Design FAQ

Following is a collection of frequently asked questions concerning the design of the Preferences API.

  1. How does this Preferences API relate to Properties API?

    It is intended to replace most common uses of Properties, rectifying many of its deficiencies, while retaining its light weight. When using Properties, the programmer must explicitly specify a pathname for each properties file, but there is no standard location or naming convention. Properties files are "brittle", as they are hand-editable but easily corrupted by careless editing. Support for non-string data types in properties is non-existent. Properties cannot easily be used with a persistence mechanism other than the file system. In sum, the Properties facility does not scale.

  2. How does Preferences API relate to JNDI?

    Like JNDI, it provides back-end neutral access to persistent key-value data. JNDI, however, is far more powerful, and correspondingly heavyweight. JNDI is appropriate for enterprise applications that need its power. Preferences API is intended as a simple, ubiquitous, back-end neutral preferences-management facility, enabling any Java application to easily tailor its behavior to user preferences and maintain small amounts of state from run to run.

  3. Why do all of the get methods require the caller to pass in a default?

    This forces the application authors to provide reasonable default values, so that applications have a reasonable chance of running even if the repository is unavailable.

  4. How was it decided which methods should throw BackingStoreException?

    Only methods whose semantics absolutely require the ability to communicate with the backing store throw this exception. Typical applications will have no need to call these methods. As long as these methods are avoided, applications will be able to run even if the backing store is unavailable, which was an explicit design goal.

  5. Why doesn't this API provide stronger guarantees concerning concurrent access by multiple VMs? Similarly, why doesn't the API allow multiple Preferences updates to be combined into a single "transaction", with all or nothing semantics?

    While the API does provide rudimentary persistent data storage, it is not intended as a substitute for a database. It is critical that it be possible to implement this API atop standard preference/configuration repositories, most of which do not provide database-like guarantees and functionality. Such repositories have proven adequate for the purposes for which this API is intended.

  6. Why does this API have case-sensitive keys and node-names, while other APIs playing in a similar space (such as the Microsoft Windows Registry and LDAP) do not?

    In the Java programming universe, case-sensitive String keys are ubiquitous. In particular, they are provided by the Properties class, which this API is intended to replace. It is not uncommon for people to use Properties in a fashion that demands case-sensitivity. For example, Java package names (which are case-sensitive) are sometimes used as keys. It is recognized that this design decision complicates the life of the systems programmer who implements Preferences atop a backing store with case-insensitive keys, but this is considered an acceptable price to pay, as far more programmers will use the Preferences API than will implement it.

  7. Why doesn't this API use the Java 2 Collections Framework?

    This API is designed for a very particular purpose, and is optimized for that purpose. In the absence of generic types (see JSR-14), the API would be less convenient for typical users. It would lack compile-time type safety, if forced to conform to the Map API. Also, it is not anticipated that interoperability with other Map implementations will be required (though it would be straightforward to implement an adapter class if this assumption turned out to be wrong). Preferences API is, by design, so similar to Map that programmers familiar with the latter should have no difficulties using the former.

  8. Why don't the put and remove methods return the old values?

    It is desirable that both of these methods be executable even if the backing store is unavailable. This would not be possible if they were required to return the old value. Further, it would have negative performance impact if the API were implemented atop some common back-end data stores.

  9. Why does the API permit, but not require, stored defaults?

    This functionality is required in enterprise settings for scalable, cost-effective administration of preferences across the enterprise, but would be overkill in a self-administered single-user setting.

  10. Why doesn't this API contain methods to read and write arbitrary serializable objects?

    Serialized objects are somewhat fragile: if the version of the program that reads such a property differs from the version that wrote it, the object may not deserialize properly (or at all). It is not impossible to store serialized objects using this API, but we do not encourage it, and have not provided a convenience method.

  11. Why is Preferences an abstract class rather than an interface?

    It was decided that the ability to add new methods in an upward compatible fashion outweighed the disadvantage that Preferences cannot be used as a "mixin" (That is to say, arbitrary classes cannot also be made to serve as Preferences objects.) Also, this obviates the need for a separate class for the static methods. (Interfaces cannot contain static methods.)

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration desktop-overview.gif

Documentation Contents

This diagram shows an overview of the Java SE desktop technologies within the context of the Java platform. It consists of a number of colored rectangular boxes.

The top element of the diagram is a green box labeled User Application.

Below it, in the middle of the diagram, is a grey box labeled Desktop Technologies which contains five smaller yellow boxes. The leftmost of the yellow boxes is labeled Deployment and the rightmost is labeled Media APIs. Between them, a box labeled Swing is placed above two smaller yellow boxes labeled AWT and Java 2D.

The bottom element of the diagram is a blue box labeled Core Tools and Libraries.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Application Development Considerations

This chapter includes the following topics:

  • Introduction
  • Retrieving Resources from JAR files
  • Accessing the Client Using JNLP API
  • Security and Code Signing
  • Signing JAR Files With a Test Certificate
  • How to Encode JNLP Files
  • Dynamic Download of HTTPS Certificates

Introduction

Developing applications for deployment with Java Web Start is generally the same as developing stand-alone applications for the Java(TM) Platform Standard Edition. For instance, the entry point for the application is the standard public static void main(String[] argv).

However, in order to support Web deployment—automatic download and launching of an application—and to ensure that an application can run in a secure sandbox, there are some additional considerations:

  • An application must be delivered as a set of JAR files.
  • All application resources, such as files and images must be stored in JAR files; and they must be referenced using the getResource mechanism in the Java(TM) Platform Standard Edition (see below).
  • If an application is written to run in a secure sandbox, it must follow these restrictions:
    • No access to local disk.
    • All JAR files must be downloaded from the same host.
    • Network connections are enabled only to the host from which the JAR files are downloaded.
    • No security manager can be installed.
    • No native libraries may be used.
    • Limited access to system properties. The application has read/write access to all system properties defined in the JNLP File, as well as read-only access to the same set of properties that an Applet has access to.
    Some of these restrictions can be overcome by the use of JNLP API to access the file system and other system resources.
  • An application is allowed to use the System.exit call.
  • An application that needs unrestricted access to the system will need to be delivered in a set of signed JAR files. All entries in each JAR file must be signed.

Retrieving Resources from JAR files

Java Web Start only transfers JAR files from the Web server to the client machine. It determines where to store the JAR files on the local machine. Thus, an application cannot use disk-relative references to resources such as images and configuration files.

All application resources must be retrieved from the JAR files specified in the resources section of the JNLP file, or retrieved explicitly using an HTTP request to the Web server. Storing resources in JAR files is recommended, since they will be cached on the local machine by Java Web Start.

The following code example shows how to retrieve images from a JAR file:

// Get current classloader
ClassLoader cl = this.getClass().getClassLoader();
// Create icons
Icon saveIcon  = new ImageIcon(cl.getResource("images/save.gif"));
Icon cutIcon   = new ImageIcon(cl.getResource("images/cut.gif"));
...

The example assumes that the following entries exist in one of the JAR files for the application:

images/save.gif
images/cut.gif

Accessing the Client Using JNLP API

JNLP API can be used to access the client's file system and other resources. See the following topics for more information about using JNLPI API to access the client:

  • JNLP API Examples
  • Accessing Client the Using JNLP API (Topic in the Deployment Trail of the Java Tutorials. Although the sample shown is an applet, the information applies to Java Web Start applications also.)

Security and Code Signing

Java Web Start addresses the security issues:

  • Protecting users against malicious code (intentional & unintentional) that may affect local files;
  • Protecting enterprises against code that may attempt to access or destroy data on networks.

Applications launched with Java Web Start are, by default, run in a restricted environment where they have limited access to local computing resources, such as storage devices and the local network. In this sandbox environment, Java Web Start can guarantee that a downloaded and potentially untrusted application cannot compromise the security of the local files or the network.

An additional security feature supported by Java Web Start is digital code signing. If an application being invoked is delivered in one or more signed JAR files, Java Web Start will verify that the contents of the JAR file have not been modified since they were signed. If verification of a digital signature fails, Java Web Start will not run the application, since it may have been compromised by a third-party.

The support for code signing is important for both users and for application service providers. This service makes it possible for users to verify that an application comes from a trusted source. Because the application service provider signs the code, both can be ensured that no other party can impersonate the application on the Web. A signed application that is trusted by the user can also request additional system privileges, such as access to a local disk.

Java Web Start presents a dialog displaying the application's origin, based on the signer's certificate, before the application is launched. This allows the user to make an informed decision about whether or not to grant additional privileges to the downloaded code.

By including the following settings in the JNLP file, an application can request full access to a client system if all its JAR files are signed :

<security>
   <all-permissions/>
</security>

The implementation of code signing in Java Web Start is based on the security API in the core Java(TM) Platform Standard Edition. The Java 2 SE JRE 1.4.2 supports code signing with the SHA1withDSA and MD5withRSA algorithms.

Developers sign code for use with Java Web Start in the same way as for Java Applets—by using the standard jarsigner tool from the Java(TM) Platform Standard Edition. The jarsigner tool documentation provides examples of how to sign code and create test certificates, and it discusses other issues related to signing.

Signing JAR Files With a Test Certificate

Here are the steps needed to sign a JAR file with a test certificate:

1. Make sure that you have an SDK 1.4.2 keytool and jarsigner in your path. These tools are located in the SDK bin directory.

2. Create a new key in a new keystore as follows:

keytool -genkey -keystore myKeystore -alias myself

You will get prompted for a information about the new key, such as password, name, etc. This will create the myKeystore file on disk.

3. Then create a self-signed test certificate as follows:

keytool -selfcert -alias myself -keystore myKeystore

This will prompt for the password. Generating the certificate may take a few minutes.

4. Check to make sure that everything is okay. To list the contents of the keystore, use this command:

keytool -list -keystore myKeystore

It should list something like:

Keystore type: jks
Keystore provider: SUN

Your keystore contains 1 entry:

myself, Tue Jan 23 19:29:32 PST 2001, keyEntry,
Certificate fingerprint (MD5):
C2:E9:BF:F9:D3:DF:4C:8F:3C:5F:22:9E:AF:0B:42:9D

5. Finally, sign the JAR file with the test certificate as follows:

jarsigner -keystore myKeystore test.jar myself

Repeat this step with all of your JAR files.

Note that a self-signed test certificate should only be used for internal testing, since it does not guarantee the identity of the user and therefore cannot be trusted. A trust-worthy certificate can be obtained from a certificate authority, such as VeriSign or Thawte, and should be used when the application is put into production.

How to Encode JNLP Files

Beginning with Java Web Start version 1.2, JNLP files may be encoded in any character encoding supported by the Java(TM) Platform Standard Edition. (See the Java(TM) Platform Standard Edition documentation for a list of supported encodings.)

To encode a JNLP file, specify an encoding in the XML prolog of that file. For example, the following line indicates that the JNLP file will be encoded in UTF-16.

<?xml version="1.0" encoding="utf-16"?>

The XML prolog itself must be UTF-8-encoded.

Dynamic Download of HTTPS Certificates

Beginning with 1.4.2, Java Web Start dynamically imports certificates in much the same way as browsers do. In order to make this work, Java Web Start now sets its own https handler, using the java.protocol.handler.pkgs system properties, to initialize defaults for SSLSocketFactory and HostnameVerifier. It sets the defaults with HttpsURLConnection.setDefaultSSLSocketFactory and HttpsURLConnection.setDefaultHostnameVerifier.

If your application uses those two method, make sure they are called after the Java Web Start https handler is initialized, otherwise your custom handler will be replaced by the Java Web Start default handler. You can ensure that your own customized SSLSocketFactory and HostnameVerifiter are used by doing either of the following:

  1. Installing your own https handler, which will completely replace the Java Web Start https handler;
  2. Calling HttpsURLConnection.setDefaultSSLSocketFactory or HttpsURLConnection.setDefaultHostnameVerifier only after the first https url object is created, which will execute the Java Web Start https handler initialization code first.

For information on creating a download servlet see the next chapter, JnlpDownloadServlet Guide.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.management.DiagnosticCommandMBean (Monitoring and Management Interface for the Java Platform )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.management.DiagnosticCommandMBean

No usage of com.sun.management.DiagnosticCommandMBean
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2003, 2015, Oracle and/or its affiliates. All rights reserved.


Description of the illustration dialog_trusted.png

Documentation Contents

Screen shot of a security dialog that prompts the user for permission to run the application. The dialog contains the name, the publisher, and the location of the application. A notice that the application is requesting limited access to the user's computer and personal information is provided. An option to not show the dialog again for this application and other applications from the same publisher and location is available. A link for more information is provided in the lower left corner. The lower right corner contains two buttons. The left button is labeled Run. The right button is labeled Cancel.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.security.auth.callback.DialogCallbackHandler (Java Authentication and Authorization Service )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Authentication and Authorization Service
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.security.auth.callback.DialogCallbackHandler

No usage of com.sun.security.auth.callback.DialogCallbackHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Authentication and Authorization Service
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Swing Data Transfer

For the Java 2 Platform, Standard Edition, v 1.4 release, Swing has added support for data transfer between applications. A drag and drop operation is a data transfer request that has been specified by a gesture with a graphical pointing device. In the case of copy/paste, data transfer is often initiated with the keyboard. The ability to transfer data takes two forms:

  • Drag and drop (DnD) support
  • Clipboard transfer via cut/copy/paste
When adding data transfer support to Swing, the goal was to make it easy for developers using Swing components to add clipboard transfer as well as drag and drop to an application. Previous AWT support for drag and drop provided a great deal of flexibility, but also a fair amount of complexity, to implement. Also, AWT support for clipboard transfer had not been integrated into Swing in a natural way. For this release, data transfer support has been implemented so that the developer may take advantage of these powerful features with minimal effort.

Because the state of each Swing component is independent of the definition of the data model, it was easy to implement a mechanism for moving the data between components without worrying about the details of the data itself. The data transfer amounts to transferring part of one model to another model. (In the case of cut/copy/paste, the data is transferred between the model and the clipboard.) To support data transfer, we:

  • Added a small amount of API to enable data transfer with a few method calls.
  • Made it possible to disable the Swing DnD implementation so that the user can use the support provided by AWT to customize any special behavior.
  • Implemented the necessary changes in the look and feel implementations we provide.

Quick Reference: Components That Support DnD

Component | Supports Drag | Supports Drop
JColorChooser | Yes | Yes
JEditorPane | Yes | Yes
JFileChooser | Yes | No
JFormattedTextField | Yes | Yes
JLabel | see here | see here
JList | Yes | No
JPasswordField | No | Yes
JTable | Yes | No
JTextArea | Yes | Yes
JTextField | Yes | Yes
JTextPane | Yes | Yes
JTree | Yes | No

This document has the following sections:

  • Data Transfer Support
    • Default TransferHandler Support
    • Example of Adding Support to JLabel
  • Drag Support
    • Default Drag Support
    • Adding Drag Support to Subclasses of Swing Classes
    • Operation of TransferHandler.exportAsDrag
  • Drop Support
    • Default Drop Support
    • Using the Drop Support in Subclasses of Swing Classes
  • Clipboard Transfer Support
    • Default Clipboard Transfer
    • Using the Clipboard Transfer Support in Subclasses of Swing Classes
  • Implementation Details
  • Changes Since Beta
  • Known Bugs

Data Transfer Support

The foundation of data transfer is support for handling the transfer of data into and out of a component. With this functionality available on the component, the mechanics of managing a drag and drop can be provided automatically. In addition, support for cut/copy/paste can also be provided automatically. The crux of this implementation is the new class TransferHandler. The JComponent property methods, setTransferHandler and getTransferHandler, provide an entrypoint to the data transfer mechanism for any component which extends JComponent.

The table below details the extent of the cut, copy, paste, and drop support for each of the components when a non-null TransferHandler is installed. Note that this support is enabled by the look and feel code. Support for dragging is initially disabled, but may be enabled by calling setDragEnabled(true) on the component. If the component doesn't have such a method, the drag may be enabled by binding some kind of gesture to it.

Default TransferHandler Support

For the components listed below, Swing installs default implementations of TransferHandler. For those components that have default Swing support, the TransferHandler is installed by the ComponentUI if the value of the transferHandler property is null or marked by the presence of the UIResource interface. The default TransferHandler implementation installed by the ComponentUI is marked by the UIResource interface, enabling developers to override the default TransferHandler. The following table shows the support provided.

Components That Support DnD

Component | Exports (Drag, Cut, Copy) | Imports (Drop, Paste)
JColorChooser | The selected color is offered through the JavaBeans property handling of TransferHandler. The flavor offered is application/x-java-jvm-local-objectref; class=java.awt.Color. The value transferred is determined by getColor. | Accepts inserts of type Color. The data is imported by using setColor (from the bean property handling). Any flavor having class=java.awt.Color (or a subclass of java.awt.Color) is accepted.
JEditorPane | 1.4: If the content-type of the JEditorPane is text/plain, the selected text is offered as text/plain through the write method of the EditorKit. If the content-type is OTHER, it is exported both as text/plain using the getSelectedText method, and as OTHER using the write method of the EditorKit. 1.4.1: The selected text, as returned by the getSelectedText method, is exported as text/plain. In addition, if the content-type of the JEditorPane is other than text/plain, the selected content is also offered in that other flavor using the EditorKit's write method. | 1.4: Accepts inserts of type text/plain and whatever the current type returned by getContentType. If a type is found matching the current type (including text/plain), it is imported using the EditorKit's read method. Otherwise, text/plain is imported through the component's replaceSelection method. Paste: the contents of the selection, if any, are replaced. Drop: the data is inserted at the caret position. 1.4.1: Accepts inserts of type text/plain and whatever the current type returned by getContentType. If a type is found matching the current type (excluding text/plain), it is imported using the EditorKit's read method. Otherwise, text/plain is imported through the component's replaceSelection method. Paste: the contents of the selection, if any, are replaced. Drop: the data is inserted at the caret position.
JFileChooser | The selection is offered in the same manner as those from the native file chooser. | Imports not accepted. As the mouse is moved over the list, the potential drop point is indicated by highlighting the file/directory under the cursor. See Default Drop Support.
JFormattedTextField | The selected text is offered as text/plain. | Accepts inserts of type text/plain. Paste: the contents of the selection, if any, are replaced; otherwise the data is inserted at the caret position. Drop: the data is inserted at the caret position. Note that paste and drop employ the same code paths as typing from the keyboard, therefore code validation is preserved.
JList | If the selection is a single item, it is offered as text/plain. If multiple items are selected, they are offered as text/html. The format of the text/html is a <UL> tag followed by the selected list items each starting with an <LI> tag. | Imports not accepted. As the mouse is moved over the list, the potential drop point is indicated by highlighting the list item under the cursor. See Default Drop Support.
JPasswordField | For security reasons, cut, copy, and drag are not supported. | Accepts inserts of type text/plain. Paste: the contents of the selection, if any, are replaced; otherwise the data is inserted at the caret position. Drop: the data is inserted at the caret position.
JTable | If the selection is a single item, it is offered as text/plain. If multiple items are selected, they are offered as text/html. The format of the text/html is a <TABLE> tag followed by a <TR> tag for each row and a <TD> tag for each cell. | Imports not accepted. As the mouse is moved over the table, the potential drop point is indicated by highlighting the cell under the cursor. See Default Drop Support.
JTextArea | The selected text is offered as text/plain. | Accepts inserts of type text/plain. Paste: the contents of the selection, if any, are replaced; otherwise the data is inserted at the caret position. Drop: the data is inserted at the caret position.
JTextField | The selected text is offered as text/plain. | Accepts inserts of type text/plain. Paste: the contents of the selection, if any, are replaced; otherwise the data is inserted at the caret position. Drop: the data is inserted at the caret position.
JTextPane | Same as JEditorPane. | Same as JEditorPane.
JTree | If the selection is a single item, it is offered as text/plain. If multiple items are selected, they are offered as text/html. The format of the text/html is nested lists, similar to the format used for JList. | Imports not accepted. As the mouse is moved over the table, the potential drop point is indicated by highlighting the tree node under the cursor. See Default Drop Support.

Example of Adding Support to JLabel

The JLabel component does not support DnD by default. The following code fragment creates a JLabel that supports drag and drop on the "text" property (a String):

JLabel componentType = new JLabel();
componentType.setTransferHandler(new TransferHandler("text"));
MouseListener ml = new MouseAdapter() {
    public void mousePressed(MouseEvent e) {
        JComponent c = (JComponent)e.getSource();
        TransferHandler th = c.getTransferHandler();
        th.exportAsDrag(c, e, TransferHandler.COPY);
    }
};
componentType.addMouseListener(ml);

We have included a small example that implements drag and drop using a JTextField and a JLabel. You can type a value into the text field, highlight the text, then hold the mouse button down over the textfield and drag a few pixels. An icon appears under the cursor. Release the icon over the JLabel and see the text replace the "Drop Here" text. Simultaneously with the drop, the text is removed from the source textfield. The default behavior for drag and drop is MOVE. To change the behavior to COPY, hold down the CONTROL key while selecting the text. On Windows, a plus sign appears in the icon. When the text is released on the target, it is left intact in the source. You can likewise drag from the JLabel to the text field. Note that JLabel does not have bindings for copy/paste and is unable to get the focus that is required to support this feature.

See the JLabelDragNDrop.java example here.

Drag Support

Some components, such as text fields, support selections. For those kinds of components, a drag operation is typically initiated by dragging an existing selection with the mouse. A controller for this type of component can recognize this condition and initiate a drag. For those components that don't have selections, Swing can't automatically initiate the drag, but Swing can handle the mechanics of the drag if told that a drag attempt has been initiated as shown in the JLabel example.

With this level of drag support, the Swing developer can focus on implementing a TransferHandler that represents the desired transfer, and setting properties on the Swing component. This greatly simplifies the burden to the Swing developer wanting to support dragging in an application.

Note that we are currently investigating providing different visual appearances of the drag, hence the reference to Icon in the API. Stay tuned for future developments.

Default Drag Support

The simplest level of support is to set a flag that indicates the developer would like the default support enabled. The components that offer default support for dragging are described in the Exports column of the Components That Support DnD table; but to summarize, the classes that directly implement setDragEnabled and getDragEnabled are: JColorChooser, JFileChooser, JList, JTable, JTree, and JTextComponent. The drag gesture is defined as the press of the first mouse button over a selection and dragging a few pixels. Setting the dragEnabled property to true therefore has a subtle effect on mouse behavior.

When dragging is enabled on a component, the Swing controller (in the corresponding ComponentUI subclass) begins looking for a drag gesture, and if the transferHandler property is null, or marked by the presence of the UIResource interface, a default implementation is installed. The implementation provided by Swing is marked with the UIResource interface, so a developer can insert a new TransferHandler by replacing the default TransferHandler property with a custom implementation. When a drag gesture is recognized, the exportAsDrag method is called on the TransferHandler which initiates the drag mechanism. The actual transfer is handled by the java.awt.dnd mechanism, requiring no further effort from the developer.

Adding Drag Support to Subclasses of Swing Classes

The drag support provided by Swing is activated by the TransferHandler.exportAsDrag method. This makes adding drag support as easy as:

  1. Installing a TransferHandler implementation (so there is something to drag) by calling the setTransferHandler method.
  2. Recognizing a drag gesture.
  3. Calling the exportAsDrag method.

Some scenarios for accomplishing this are:

  • Add a MouseListener that watches for the desired gesture, then call getTransferHandler on the component and call the exportAsDrag method when the desired gesture is found. See the JLabel example.
  • Reimplement the processMouseEvent method in a subclass and call the exportAsDrag method on the ComponentUI variable when a drag gesture is seen, otherwise execute the superclass behavior.
  • In a component with a custom UI implementation, have the controller call exportAsDrag when a drag gesture has been seen.

Operation of TransferHandler.exportAsDrag

When the exportAsDrag method is called on TransferHandler, the drag is handled by Swing provided functionality. When this method is called, it is assumed that a valid drag gesture has been recognized. The method performs the following steps:

  1. A Swing implementation of a DragSource and DragListener is used to start the drag using the Transferable implementation returned by createTransferable as data transfer object.
  2. When the drop has completed, the exportDone method is called on the TransferHandler. For some operations, such as MOVE, it may be necessary to remove the data from the source. The default behavior for text-based components, for example, is that a standard drag implements MOVE behavior (following the drop the selected text is removed from the source component). The user may override this behavior by holding down the control key when the text is selected for dragging. On Windows, the drag icon visually reflects this behavior with a small plus-sign.

Drop Support

The primary support for handling a drop is the same as for a paste operation, the importData method on the TransferHandler. The semantics of inserting data into a component are generally more meaningful at the application level than the toolkit level. Users of an application can drop all kinds of Transferable implementations on components that are completely unknown to the Swing toolkit. It is up to the Swing developer to provide a TransferHandler with meaningful import semantics if the default TransferHandler is insufficient.

A drop operation does have some differences from a paste however:

  • Typically a potential drop site provides feedback of where the data would be accepted.
  • For components with selection capabilities, the insertion point is moved to indicate where the data would be placed.

Default Drop Support

To assist Swing developers in adding drop support to an application, Swing provides DropTarget implementations that use the TransferHandler property on the Swing component. For those components that have a non-null TransferHandler property, the drop target is installed by the ComponentUI if the value of the dropTarget property is null or marked by the presence of the UIResource interface. The default DropTarget implementations installed by the ComponentUI is marked by the UIResource interface, enabling developers to override the default DropTarget.

The components that provide a complete drop implementation by default are indicated in the Imports column of the Components That Support DnD table. There are four components that provide only some support for drop. JFileChooser, JList, JTable, and JTree by default have an installed DropTarget that indicates a potential insertion point. However, to fully support imports of data the developer must write and install a custom TransferHandler.

Using the Drop Support in Subclasses of Swing Classes

A well behaved DropTarget implementation uses the transferHandler property on JComponent to perform the drop. The Swing developer automatically gets a simple DropTarget implementation that links the drop to the TransferHandler when the transferHandler property is set and the dropTarget property is null.

Clipboard Transfer Support

Cut, copy, and paste operations perform data transfer in a manner that is more useful to those without a mouse, as they are typically initiated via a keyboard gesture. These operations can use the same TransferHandler services as the drag and drop support. This improves the accessibility of the data transfers, and enables Swing to provide keyboard bindings for these operations even though Swing may not know how to actually transfer the data to/from the clipboard. The keyboard bindings for clipboard transfer are dependent upon the current look and feel that is installed.

Default Clipboard Transfer

As with drag and drop, clipboard transfers are the most useful for those components that support selections. The list of components shown in the Exports column of the Components That Support DnD table have cut, copy, and paste actions in the component action map, along with a LAF dependent set of keyboard bindings in the input map of the component. Having Swing provide these bindings frees the developer from trying to track the current look and feel and change the bindings.

Using the Clipboard Transfer Support in Subclasses of Swing Classes

A well behaved cut, copy, and paste implementation uses the transferHandler property on JComponent to perform the transfer. When the transferHandler property is set on a JComponent, a simple Action implementation that links the transfer of between a Clipboard and TransferHandler is installed in the component's action map under the keys cut, copy, and paste if there is no action currently installed.

Implementation Details

Note: The following information outlines private implementation details and is subject to change. We are providing this information only to satisfy the curiosity of those who have access to the source code and feel compelled to thump the tires and peek under the hood.

If a TransferHandler is installed on a JComponent, the look and feel then enables cut, copy, and paste using the following TransferHandler methods:

  • getCutAction
  • getCopyAction
  • getPasteAction
If you bind some event to TransferHandler.exportAsDrag you also get drag support. This plumbing is located in package-private nested classes inside of the TransferHandler class.

The following package-private classes were added to the javax.swing.plaf.basic package for creating the default support:

BasicTransferable
The basis of the various Transferable implementations.
BasicDropTargetListener
Adds scrolling support and drop target feedback for those components supporting selection.
BasicDragGestureRecognizer
Supports the "select and move a few pixels" drag gesture recognition.

Each of the ComponentUI classes that support DnD then have some additional nested classes:

BasicTreeUI:

TreeTransferHandler
Default import/export support.
TreeTransferable
The actual tree data.
TreeDragGestureRecognizer
Tree drag gesture recognition, enabled by JTree.setDragEnabled.
TreeDropHandler
Shows drop target location.

BasicListUI, BasicTableUI, BasicTextUI all have a pattern similar to as BasicTreeUI.

BasicFileChooserUI
Uses the list support, but has a FileTransferHandler that produces the FileTransferable that extends the ListTransferable with the flavor used for file transfers.
BasicColorChooserUI
Uses the TransferHandler bean support and binds the "color" property. A mouse listener is added to the preview area to bind a mouse press to the exportAsDrag method on the TransferHandler.

Changes Since Beta

TransferHandler Actions Should be Registered by UI

The bugtraq report that corresponds to this change is: 4460011.

To implement drag and drop, bindings were provided in the Action class to support copying and pasting the data. In order for a look and feel, or other code, to override these Actions, the UI must install them - Actions are no longer automatically installed by the TransferHandler. The package-private methods getCutAction, getCopyAction, and getPasteAction in TransferHandler are now made public.

Ability to Disable DropTarget

The bugtraq report that corresponds to this change is: 4485914.

The drag and drop implementation causes a DropTarget to be added to a JComponent if that component has a TransferHandler installed. This may affect applications that are manually adding DropTargets. Therefore the System property suppressSwingDropSupport has been added. The JComponent methods setTransferHandler(TransferHandler) and getTransferHandler can be used to enable or disable this property.

Known Bugs

Drop Clobbers Selected Text in JTextComponent

The bugtraq report that corresponds to this problem is: 4513715.

Selecting text and then dragging and dropping that text within the selected region of the same text component causes the selected text to be clobbered and nothing to be pasted. This bug is fixed in release 1.4.1.

Occasional Errors in Restoring Caret when Exiting a Component

The bugtraq report that corresponds to this problem is: 4513720.

With the built-in drop support, Swing text components respond to DnD dragovers by setting the Caret to visible and using it to display the potential insert location. When the drag exits the component, the Caret's visibility is restored. Unfortunately, since the Caret uses the same "visible" property to represent the usual meaning of visible as well as when it is in mid-flash, we sometimes restore the Caret's visibility incorrectly.

Cut/Copy/Drag Broken for JEditorPane with RTFEditorKit

The bugtraq report that corresponds to this problem is: 4513638.

When using an RTFEditorKit set explicitly on a JEditorPane using setEditorKit, or by setting the content-type to text/rtf, cut, copy and drag no longer work. Note that this bug, filed against release 1.4, is fixed in release 1.4.1.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Drag and Drop Subsystem for the Java 2 Platform Standard Edition 5.0

This document has these sections:

  • 1.0 Requirements
  • 2.0 API
  • 2.1 Overview
  • 2.2 Drag Gesture Recognition
    • 2.2.1 DragGestureRecognizer
  • 2.3 Drag Source
    • 2.3.1 The DragSource Definition
    • 2.3.2 The DragSourceContext Definition
    • 2.3.3 The DragSourceListener Definition
    • 2.3.4 The DragSourceEvent Definition
    • 2.3.5 The DragSourceDragEvent Definition
    • 2.3.6 The DragSourceDropEvent Definition
  • 2.4 Drop Target
    • 2.4.1 java.awt.Component additions for DropTarget (de)registration
    • 2.4.2 The DropTarget Definition
    • 2.4.3 The DropTargetContext Definition
    • 2.4.4 The DropTargetListener Definition
    • 2.4.5 The DropTargetDragEvent and DropTargetDropEvent Definitions
    • 2.4.6 Autoscrolling Support
  • 2.5 Data Transfer Phase
    • 2.5.1 FlavorMap and SystemFlavorMap
    • 2.5.2 Transferring Data across the JVM boundary
    • 2.5.3 Transferring lists of files across the JVM boundary
    • 2.5.4 Transferring java.rmi.Remote references across the JVM boundary
  • 3.0 Issues
    • 3.0.1 What are the implications of the various platform protocol engines?
    • 3.0.2 Inter/Intra VM transfers?
    • 3.0.3 Lifetime of the Transferable(s)?
    • 3.0.4 Implications of ACTION_MOVE semantics on source objects exposed via Transferable?
    • 3.0.5 Semantics of ACTION_REFERENCE operation
  • Appendix A: DropTargetPeer definition
  • Appendix B: DragSourceContextPeer definition
  • Appendix C: DropTargetContextPeer definition

1.0 Requirements

This specification defines the API for the drag and drop facilities for the Java 2 Platform.

The primary requirements that this specification addresses, are:

  1. Provision of a platform-independent drag and drop facility for Java GUI clients implemented through AWT and Swing classes.
  2. Integration with platform dependent drag and drop facilities, permitting Java clients to be able to participate in DnD operation with native applications using:
    • OLE (Win32) DnD
    • XDND protocol
    • CDE/Motif dynamic protocol
    • MacOS
    • OS/2
  3. Support for 100% pure JavaOS/Java implementation.
  4. Leverages the existing java.awt.datatransfer.* package to enable the transfer of data, described by an extensible data type system based on the MIME standard.
  5. Does not preclude the use of "accessibility" features where available.
  6. Extensible to support diverse input devices.

The specification derives from the previous work mentioned above, but incorporates significant differences from that original work as a result of the advent of the JavaBeans event model, lightweight (Swing) components, and an increasing understanding of the cross-platform integration and interoperability issues.

2.0 API

The following sections cover the drag and drop API.

2.1 Overview

Drag and drop is a direct manipulation gesture found in many graphical user interface systems that provides a mechanism to transfer information between two entities logically associated with presentation elements in the GUI. Normally driven by a physical gesture of a human user using an appropriate input device, drag and drop provides both a mechanism to enable continuous feedback regarding the possible outcome of any subsequent data transfer to the user during navigation over the presentation elements in the GUI, and the facilities to provide for any subsequent data negotiation and transfer.

A typical drag and drop operation can be decomposed into the following states (not entirely sequentially):

  • A DragSource comes into existence, associated with some presentation element (Component) in the GUI, to initiate a drag and drop of some potentially Transferable data.
  • 1 or more DropTargets come into/go out of existence, associated with presentation elements in the GUI (Components), potentially capable of consuming Transferable data types.
  • A DragGestureRecognizer is obtained from the DragSource and is associated with a Component in order to track and identify any drag initiating gesture by the user over the Component.
  • A human user makes a drag gesture over the Component, which the registered DragGestureRecognizer detects, and notifies its DragGestureListener of.

    Note: Although the body of this document consistently refers to the stimulus for a drag and drop operation being a physical gesture by a human user this does not preclude a programmatically driven DnD operation given the appropriate implementation of a DragSource.

  • The DragGestureListener causes the DragSource to initiate the drag and drop operation on behalf of the user, perhaps animating the GUI Cursor and/or rendering an Image of the item(s) that are the subject of the operation.
  • As the user gestures navigate over Component(s) in the GUI with associated DropTarget(s), the DragSource receives notifications in order to provide "Drag Over" feedback effects, and the DropTarget(s) receive notifications in order to provide "Drag Under" feedback effects based upon the operation(s) supported and the data type(s) involved.

    The gesture itself moves a logical cursor across the GUI hierarchy, intersecting the geometry of GUI Component(s), possibly resulting in the logical "Drag" cursor entering, crossing, and subsequently leaving Component(s) and associated DropTarget(s).

    The DragSource object manifests "Drag Over" feedback to the user, in the typical case by animating the GUI Cursor associated with the logical cursor.

    DropTarget objects manifest "Drag Under" feedback to the user, in the typical case, by rendering animations into their associated GUI Component(s) under the GUI Cursor.

  • The determination of the feedback effects, and the ultimate success or failure of the data transfer, should one occur, is parameterized as follows:
  • By the transfer "operation" selected by the user, and supported by both the DragSource and DropTarget: Copy, Move or Reference(link).
  • By the intersection of the set of data types provided by the DragSource and the set of data types comprehensible by the DropTarget.
  • When the user terminates the drag operation, normally resulting in a successful Drop, both the DragSource and DropTarget receive notifications that include, and result in the type negotiation and transfer of, the information associated with the DragSource via a Transferable object.

The remainder of this document details the proposed API changes to support this model.

2.2 Drag Gesture Recognition

The gesture(s) that can initiate a drag and drop operation vary, not only per platform, but also per Component, and per device. Therefore a mechanism is required in order to encapsulate these dependencies, thus making the task of the author of a Component that wishes to initiate a drag and drop operation much simpler.

2.2.1 DragGestureRecognizer

The DragGestureRecognizer is an abstract base class for all device/platform/Component specific drag and drop gesture recognizers, and is defined as:

public abstract DragGestureRecognizer {
    protected DragGestureRecognizer(
        DragSource  ds,
        Component c,
        int  srcActions,
        DragGestureListener dgl
    );
    public Component getComponent();
    public void      setComponent(Component c);
    public int  getSourceActions();
    public void setSourceActions(int actions);
    public java.awt.InputEvent getTriggerEvent();
    public void resetRecognizer();
    public void addDragGestureListener(
        DragGestureListener dgl
    ) throws TooManyListenerExceptions;
    public void removeDragGestureListener(
       DragGestureListener dgl
    );
    protected abstract void registerListeners();
    protected abstract void unregisterListeners();
    protected void fireDragGestureRecognized(
       int dragAction
    );
    protected void appendEvent(InputEvent awtie);
}

An appropriate concrete subclasses of DragGestureRecognizer for a particular may be obtained in a variety of ways; from a DragSource instance, from the Toolkit, or by other means. Concrete implementation subclasses are obtained through standard APIs' by specifying a Class reference to an abstract DragGestureRecognizer superclass, an instance of a concrete subclass of this actual parameter is instantiated and returned to the requestor.

Once a DragGestureRecognizer instance is associated with a Component and a DragSource it registers its own particular set of EventListeners' with the target Component in order to monitor the appropriate events being delivered to that Component to detect an initiating gesture. (Using registerListeners and unregisterListeners to add/remove these monitoring EventListeners').

Note that a DragGestureRecognizer may throw either an IllegalStateException or an IllegalArgumentException if either the Component or DragSource specified is either not in the correct state for, or is not interoperable with, that DragGestureRecognizer.

When a concrete DragGestureRecognizer instance detects a drag-initiating user gesture on the Component it is associated with, it will fire a DragGestureEvent to the DragGestureListener registered on its unicast event source for DragGestureListener events. This DragGestureListener is responsible for causing the associated DragSource to start the drag and drop operation (if appropriate).

The implementation provides (at least) an abstract subclass for recognizing mouse device gestures MouseDragGestureRecognizer. Other abstract subclasses may be provided by the platform to support other input devices or particular Component class semantics. Concrete superclasses of this MouseDragGestureRecognizer that encapsulate platform dependent mouse based gestures are available from the Toolkit object via its createDragGestureRecognizer(Class adgrc, DragSource ds, Component c, int sa, DragGestureListener dgl) method. This Toolkit API provides platform dependent concrete implementations that extend particular platform independent abstract definitions (classes).

The MouseDragGestureRecognizer abstract class is defined as:

public abstract   MouseDragGestureRecognizer
       extends    DragGestureRecognizer
          implements MouseListener, MouseMotionListener {

    public MouseDragGestureRecognizer(
        DragSource  ds,
        Component   c,
        int  sa,
        DragGestureListener dsl
    );
    //...
}

The DragGestureListener is defined as:

public interface DragGestureListener extends EventListener {
    void dragGestureRecognized(DragGestureEvent dge);
}

Usually the dragGestureRecognized() method will simply, via the DragGestureEvent's convenience API startDrag, start a drag and drop operation on the associated DragSource.

Note that per Component (class or instance) behavior that may effect the initiating gesture would usually be implemented in this DragGestureListener method, or in the DragGestureRecognizer subclass where appropriate or possible.

The DragGestureEvent is defined as:

publc class DragGestureEvent extends EventObject {
        public DragGestureEvent(DragGestureRecognizer dgr,
             int  dragAction,
             java.util.List  events
     );
    public DragGestureRecognizer getSourceAsDragGestureRecognizer();
    public Component  getComponent();
    public DragSource getDragSource();
    public java.util.Iterator iterator();
    public Object[] toArray();
    public Object[] toArray(Object[] array);
    public int getDragAction();
    public startDrag(Cursor             dragCursor,
                     Transferable       t,
                     DragSourceListener dsl
    );
    public startDrag(Cursor             dragCursor,
                     Image              dragImage,
                     Point              imageOffset,
                     Transferable       t,
                     DragSourceListener dsl
    );
    //...
}

The DragGestureEvent encapsulates all the information regarding the nature of the gesture that has just been recognized, including:

  • The DragGestureRecognizer that recognized the gesture
  • The Component that the gesture occurred on
  • The DragSource that will process the operation
  • The List of InputEvent objects that comprise the gesture.
  • The action (ACTION_COPY, ACTION_MOVE or ACTION_LINK, selected by the user's gesture.

2.3 Drag Source

The DragSource is the entity responsible for the initiation of the drag and drop operation:

2.3.1 The DragSource definition

The DragSource and associated constant interfaces are defined as follows:

The DnDConstants class defines the operations that may be applied to the subject of the transfer:

public final class java.awt.dnd.DnDConstants {
     public static int ACTION_NONE = 0x0;
     public static int ACTION_COPY = 0x1;
     public static int ACTION_MOVE = 0x2;
     public static int ACTION_COPY_OR_MOVE= ACTION_COPY | ACTION_MOVE;
     public static int ACTION_REFERENCE = 0x40000000;
}

public class java.awt.dnd.DragSource {
     public static Cursor     DefaultCopyDrop;
     public static Cursor     DefaultMoveDrop;
     public static Cursor     DefaultLinkDrop;
     public static Cursor     DefaultCopyNoDrop;
     public static Cursor     DefaultMoveNoDrop;
     public static Cursor     DefaultLinkNoDrop;
     public static DragSource getDefaultDragSource();
     public static boolean isDragImageSupported();
     public void startDrag(DragGestureEvent trigger,
                        Cursor             dragCursor,
                        Image              dragImage,
                        Point              dragImageOffset,
                        Transferable       transferable,
                        DragSourceListener dsl,
                        FlavorMap          fm)
                  throws InvalidDnDOperationException;
     protected DragSourceContext  createDragSourceContext(
                        DragSourceContextPeer dscp,
                        DragGestureEvent      trigger,
                        Cursor                dragCursor,
                        Image                 dragImage,
                        Point                 dragImageOffset,
                        Transferable          transferable,
                        DragSourceListener    dsl
      );
      public FlavorMap getFlavorMap();
      public DragGestureRecongizer createDragGestureRecognizer(
              Class               abstractRecognizerClass,
              Component           c,
              int                 srcActions,
              DragGestureListener dgl
     );
     public DragGestureRecongizer createDefaultDragGestureRecognizer(
              Component           c,
              int                 srcActions,
              DragGestureListener dgl
     );
     //...
}

The DragSource may be used in a number of scenarios:

  • 1 default instance per JVM for the lifetime of that JVM. (defined by this spec)
  • 1 instance per class of potential Drag Initiator object (e.g TextField). [implementation dependent]
  • 1 per instance of a particular Component, or application specific object associated with a Component instance in the GUI. [implementation dependent]
  • some other arbitrary association. [implementation dependent]

A controlling object, shall obtain a DragSource instance prior to a user's gesture, effecting an associated Component, in order to process the operation. Once obtained a DragGestureRecognizer should be obtained and used to associate the DragSource with a Component.

The initial interpretation of the user's gesture, and the subsequent starting of the drag operation are the responsibility of the implementing Component, this is usually implemented by a DragGestureRecognizer.

When a gesture occurs, the DragSource's startDrag method shall be invoked in order to cause processing of the user's navigational gestures and delivery of drag and drop protocol notifications. A DragSource shall only permit a single drag and drop operation to be current at any one time, and shall reject any further startDrag requests by throwing an IllegalDnDOperationException until such time as the extant operation is complete.

In order to start a drag operation the caller of the startDrag method shall provide the following parameters:

  • The DragGestureEvent for the gesture.
  • A Cursor representing the initial "Drag Over" feedback for the operation(s) specified. (This shall be a Cursor that provides "No Drop" visual feedback to the user).
  • An (optional) Image to visually represent the item, or item(s) that are the subject(s) of the operation.

  • On platforms that can support this feature, a "Drag" image may be associated with the operation to enhance the fidelity of the "Drag Over" feedback. This image would typically be a small "iconic" representation of the object, or objects being dragged, and would be rendered by the underlying system, tracking the movement of, and coincident with, but typically in addition to the Cursor animation.

    Where this facility is not available, or where the image is not of a suitable type to be rendered by the underlying system, this parameter is ignored and only Cursor "Drag Over" animation results, so applications should not depend upon this feature. The presence of the facility on a particular platform may be tested by invoking the static method isDragImageSupported.

  • Where an Image is provided; a Point (in the co-ordinate space of the Component) specifying the initial origin of that Image relative to the co-ordinates of the "hotspot" of the drag "Cursor", in the co-ordinate space of the Component, at the time of the initial gesture, for the purposes of initiating a correctly positioned "Drag Over" animation of that Image relative to that "hotspot".
  • A Transferable that describes the various DataFlavor(s) that represent the subject(s) of any subsequent data transfer that may result from a successful Drop.

    The Transferable instance associated with the DragSource at the start of the drag operation, represents the object(s) or data that are the operand(s), or the subject(s), of the Drag and Drop operation, that is the information that will subsequently be passed from the DragSource to the DropTarget as a result of a successful Drop on the Component associated with that DropTarget.

    Note that multiple (collections) of either homogeneous, or heterogeneous, objects may be subject of a Drag and Drop operation, by creating a container object, that is the subject of the transfer, and implements Transferable. However it should be noted that since none of the targeted native platforms systems support a standard mechanism for describing and thus transferring such collections it is not possible to implement such transfers in a transparent, or platform portable fashion.

  • A DragSourceListener instance, which will subsequently receive events notifying it of changes in the state of the ongoing operation in order to provide the "Drag Over" feedback to the user.

As stated above, the primary role of the startDrag method is to initiate a Drag on behalf of the user. In order to accomplish this, the startDrag method must create a DragSourceContext instance to track the operation itself, and more importantly it must initiate the operation itself in the underlying platform implementation. In order to accomplish this, the DragSource must first obtain a DragSourceContextPeer from the underlying system (usually via an invocation of java.awt.Toolkit.createDragSourceContextPeer method) and subsequently associate this newly created DragSourceContextPeer (which provides a platform independent interface to the underlying systems capabilities) with a DragSourceContext.The startDrag method invokes the createDragSourceContext method to instantiate an appropriate DragSourceContext and associate the DragSourceContextPeer with that.

If the drag and drop system is unable to initiate a drag operation for some reason the startDrag method shall throw a java.awt.dnd.InvalidDnDOperationException to signal such a condition. Typically this exception is thrown when the underlying platform system is either not in a state to initiate a drag, or the parameters specified are invalid.

Note that during the drag neither the set of operations the source exposed at the start of the drag operation may change for the duration of the operation, in other words the operation(s) and are constant for the duration of the operation with respect to the DragSource.

The getFlavorMap method is used by the underlying system to obtain a FlavorMap object in order to map the DataFlavors exposed by the Transferable to data type names of the underlying DnD platform. [see later for details of the FlavorMap]

A "private" FlavorMap may be provided to the startDrag() method of the DragSource, or null, in which case the "default" FlavorMap for that DragSource class or instance is used.

2.3.2 The DragSourceContext Definition

As a result of a DragSource's startDrag method being successfully invoked an instance of the DragSourceContext class is created. This instance is responsible for tracking the state of the operation on behalf of the DragSource and dispatching state changes to the DragSourceListener.

The DragSourceContext class is defined as follows:

public class DragSourceContext implements DragSourceListener {
        public DragSourceContext(
                DragSourceContextPeer dscp,
                DragGestureEvent  trigger,
                Cursor  dragCursor,
                Image  dragImage,
                Point  dragOffset,
                Transferable  transferable,
                DragSourceListener  dsl
        );
        public DragSource  getDragSource();
        public Component  getComponent();
        public DragGestureEvent getTrigger();
        public Image     getDragImage();
        public Point     getDragImageOffset();
        public void transferablesFlavorsChanged();
        public int getSourceActions();
        public Cursor getCursor();
        pbulic void   setCursor(Cursor Cursor)
                    throws InvalidDnDOperationException;
        public void addDragSourceListener(DragSourceListener dsl)
                    throws TooManyListenersException;
        public void removeDragSourceListener(DragSourceListener dsl);
        protected updateCurrentCursor(int dropOperation,
                                   int targetActions,
                                   int status
        );
        // values for status parameter above.
        protected static final int DEFAULT = 0;
        protected static final int ENTER   = 1;
        protected static final int OVER    = 2;
        protected static final int CHANGED = 3;

        //...
}

Note that the DragSourceContext itself implements DragSourceListener, this is to allow the platform peer, the DragSourceContextPeer instance, created by the DragSource, to notify the DragSourceContext of changes in state in the ongoing operation, and thus allows the DragSourceContext to interpose itself between the platform and the DragSourceListener provided by the initiator of the operation.

The state machine the platform exposes, with respect to the source, or initiator of the Drag and Drop operation is detailed below:

Following context describes this graphic

Notifications of changes in state with respect to the initiator during a drag and drop operation, as illustrated above, are delivered from the DragSourceContextPeer, to the appropriate DragSourceContext, which delegates notifications, via a unicast JavaBeans compliant EventListener subinterface, to an arbitrary object that implements DragSourceListener registered with the DragSource via startDrag.

The primary responsibility of the DragSourceListener is to monitor the progress of the user's navigation during the drag and drop operation and provide the "Drag-Over" effects feedback to the user. Typically this is accomplished via changes to the "Drag Cursor".

Every drag operation has 2 logical cursor states (Drag Cursors) associated with it:

  • The Drop Cursor, the cursor displayed when dragging over a valid DropTarget.
  • The NoDrop Cursor, the cursor displayed when dragging over everything else (the initial state of the cursor at the start of a drag).

The state of the Cursor may be modified by calling the setCursor method of the DragSourceContext.

2.3.3 The DragSourceListener Definition

The DragSourceListener interface is defined as follows:

public interface java.awt.dnd.DragSourceListener
        extends java.util.EventListener {
        void dragEnter  (DragSourceDragEvent dsde);
        void dragOver   (DragSourceDragEvent dsde);
        void dropActionChanged (DragSourceDragEvent dsde);
        void dragExit   (DragSourceEvent     dse);
        void dragDropEnd  (DragSourceDropEvent dsde);
}

As the drag operation progresses, the DragSourceListener's dragEnter, dragOver, and dragExit methods shall be invoked as a result of the user's navigation of the logical "Drag" cursor's location intersecting the geometry of GUI Component(s) with associated DropTarget(s). [See below for details of the DropTarget's protocol interactions].

The DragSourceListener's dragEnter method is invoked when the following conditions are true:

  • The logical cursor's hotspot initially intersects a GUI Component's visible geometry.
  • That Component has an active DropTarget associated.

The DropTarget's registered DropTargetListener dragEnter method is invoked and returns successfully.

The registered DropTargetListener invokes the DropTargetDragEvent's acceptDrag method to accept the drag based upon interrogation of the source's potential drop actions and available data types (DataFlavors).

The DragSourceListener's dragOver method is invoked when the following conditions are true:

  • The cursor's logical hotspot has moved but still intersects the visible geometry of the Component associated with the previous dragEnter invocation.
  • That Component still has a DropTarget associated.
  • That DropTarget is still active.
  • The DropTarget's registered DropTargetListener dragOver method is invoked and returns successfully.
  • The DropTarget does not reject the drag via rejectDrag.

The DragSourceListener's dragExit method is invoked when one of the following conditions is true:

  • The cursor's logical hotspot no longer intersects the visible geometry of the Component associated with the previous dragEnter invocation.

    Or:

  • The Component that the logical cursor's hotspot intersected that resulted in the previous dragEnter invocation, no longer has an active DropTarget (or DropTargetListener) associated.

    Or:

  • The current DropTarget's DropTargetListener has invoked rejectDrag since the last dragEnter or dragOver invocation.

The DragSourceListener's dropActionChanged() method is invoked when the state of the input device(s), typically the mouse buttons or keyboard modifiers, that the user is interacting with in order to perform the drag operation, changes.

The dragDropEnd() method is invoked to signify that the operation is completed. The getDropSuccess method of the DragSourceDropEvent can be used to determine the termination state. The getDropAction method returns the operation that the DropTarget selected (via the DropTargetDropEvent acceptDrop parameter) to apply to the drop operation.

Once this method is complete the current DragSourceContext and the associated resources are invalid.

2.3.4 The DragSourceEvent Definition

The DragSourceEvent class is the root Event class for all events pertaining to the DragSource, and is defined as follows:

public class   java.awt.dnd.DragSourceEvent extends java.util.EventObject {
        public DragSourceEvent(DragSourceContext dsc);
        public DragSourceContext getDragSourceContext();
        //...
};

An instance of this event is passed to the DragSourceListener dragExit method.

2.3.5 The DragSourceDragEvent Definition

The DragSourceDragEvent class is defined as follows:

public class java.awt.dnd.DragSourceDragEvent extends DragSourceEvent {
        public int getTargetActions();
        public int getUserAction();
        public int getGestureModifiers();
        public int getGestureModifiersEx();
        public int getDropAction();
}

An instance of the above class is passed to a DragSourceListener's dragEnter, dragOver, and dragGestureChanged methods.

The getDragSourceContext method returns the DragSourceContext associated with the current drag and drop operation.

The getUserAction method returns the action that is currently selected by the user's gesture.

The getTargetActions method returns the drop action selected by the current drop target if this drop action is supported by the drag source or DnDConstants.ACTION_NONE if this drop action is not supported by the drag source.

The logical intersection of these two results and the set of drop actions supported by the drag source defines the actual effect of a drop and is returned via getDropAction.

The getGestureModifiers method returns the current state of the input device modifiers, usually the mouse buttons and keyboard modifiers, associated with the user's gesture.

The getGestureModifiersEx method returns the current state of the input device extended modifiers associated with the user's gesture.

2.3.6 The DragSourceDropEvent Definition

The DragSourceDropEvent class is defined as follows:

public public class java.awt.dnd.DragSourceDropEvent
                        extends java.util.EventObject {
       public DragSourceDropEvent(DragSourceContext dsc);
       public DragSourceDropEvent(DragSourceContext dsc,
                                int  action,
                                boolean success);
       public boolean getDropSuccess();
       public int getDropAction();
}

An instance of the above class is passed to a DragSourceListener's dragDropEnd method. This event encapsulates the termination state of the drag and drop operation for the DragSource.

If the drop occurs, then the participating DropTarget will signal the success or failure of the data transfer via the DropTargetContext's dropComplete method, this status is made available to the initiator via the getDropSuccess method. The operation that the destination DropTarget selected to perform on the subject of the drag (passed by the DropTarget's acceptDrop method) is returned via the getDropAction method.

If the drag operation was aborted for any reason prior to a drop occurring, for example if the user ends the gesture outside a DropTarget, or if the DropTarget invokes rejectDrop, the getDropSuccess method will return false, otherwise true.

2.4 Drop Target

2.4.1 java.awt.Component additions for DropTarget (de)registration.

The java.awt.Component class has two additional methods added to allow the (dis)association with a DropTarget. In particular:

public class java.awt.Component /* ... */ {
        //...
        public synchronized void setDropTarget(DropTarget dt);
        public synchronized DropTarget getDropTarget(DropTarget df);
        //...
}

To associate a DropTarget with a Component one may invoke either; DropTarget.setCompononent or Component.setDropTarget methods. Thus conforming implementations of both methods are required to guard against mutual recursive invocations.

To disassociate a DropTarget with a
Component one may invoke either;
DropTarget.setCompononent(null) or
Component.setDropTarget(null) methods.

Conformant implementations of both setter methods in DropTarget and Component should be implemented in terms of each other to ensure proper maintenance of each other's state.

The setDropTarget method throws IllegalArgumentException if the DropTarget actual parameter is not suitable for use with this class/instance of Component. It may also throw UnsupportedOperationException if, for instance, the Component does not support external setting of a DropTarget.

2.4.2 The DropTarget Definition

A DropTarget encapsulates all of the platform-specific handling of the Drag and Drop protocol with respect to the role of the recipient or destination of the operation.

A single DropTarget instance may typically be associated with any arbitrary instance of java.awt.Component. Establishing such a relationship exports the associated Components geometry to the client desktop as being receptive to drag and drop operations when the coordinates of the logical cursor intersects that visible geometry.

The DropTarget class is defined as follows:

public class java.awt.dnd.DropTarget
       implements DropTargetListener, Serializable {

        public DropTarget(Component          c,
                       int                actions,
                       DropTargetListener dsl,
                       boolean            isActive,
                       FlavorMap          fm
        );
        public DropTarget();
        public DropTarget(Component c);
        public DropTarget(Component c, DropTargetListener dsl);
        public Component getComponent();
        public void      setComponent(Component c);
        public DropTargetContext getDropTargetContext();
        public void addDropTargetListener(DropTargetListener dte)
                  throws TooManyListenersException;
        public void removeDropTargetListener(DropTargetListener dte);
        public void setActive(boolean active);
        public boolean isActive();
        public FlavorMap getFlavorMap();
        public void      setFlavorMap(FlavorMap fm);
        public void setDefaultActions(int actions);
        public int  getDefaultActions();
        protected DropTargetContext createDropTargetContext();
        public void addNotify(ComponentPeer cp);
        public void removeNotify(ComponentPeer cp);
        // ...
}

The setComponent method throws IllegalArgumentException if the Component actual parameter is not appropriate for use with this class/instance of DropTarget, and may also throw UnsupportedOperationException if the Component specified disallows the external setting of a DropTarget.

The addDropTargetListener and removeDropTargetListener methods allow the unicast DropTargetListener to be changed.

The setActive and isActive methods allow the DropTarget to be made active or otherwise and for its current state to be determined.

The getFlavorMap methods is used to obtain the FlavorMap associated with this DropTarget for the purposes of mapping any platform dependent type names to/from their corresponding platform independent DataFlavors.

The setFlavorMap method allows a new FlavorMap to be assigned to the DropTarget, a parameter of null causes a "default" FlavorMap to be installed for the DropTarget.

The createDropTargetContext method is only invoked to provide the underlying platform dependent peer with an instantiation of a new DropTargetContext as a Drag operation initially encounters the Component associated with the DropTarget. If no DropTargetContext is currently associated with a DropTarget, a permitted side-effect of an invocation of getDropTargetContext is to instantiate a new DropTargetContext.

The addNotify and removeNotify methods are only called from Component to notify the DropTarget of the Component's (dis)association with its ComponentPeer.

Note that the DropTarget itself implements DropTargetListener, this is to allow the platform peer, the DropTargetContextPeer instance, created by the platform, to notify the DropTarget of changes in state in the ongoing operation, and thus allows the DropTarget to interpose itself between the platform and the DropTargetListener registered with the DropTarget.

2.4.3 The DropTargetContext Definition

As the logical cursor associated with an ongoing drag and drop operation first intersects the visible geometry of a Component with an associated DropTarget, the DropTargetContext associated with the DropTarget is the interface, through which, access to, and control over state of the recipient protocol is achieved from the DropTargetListener.

A DropTargetContext is created by a DropTarget, via it's createDropTargetContext method, as a side effect of a call to a DropTarget's getDropTargetContext method, if no <>DropTargetContext currently exists for that DropTarget.

The DropTargetContext interface is defined as follows:

public class DropTargetContext {
        public DropTarget getDropTarget();
        public Component getComponent();
        public void  dropComplete(boolean success)
                                throws InvalidDnDOperationException;
        public void acceptDrag(int dropAction);
        public void rejectDrag();
        public void acceptDrop(int dropAction);
        public void rejectDrop();
        public void addNotify(DropTargetContextPeer dtcp);
        public void removeNotify();
        protected Transferable createTransferableProxy(Transferable t,
                   boolean isLocal
        );
        protected void setTargetActions(int actions);
        protected int  getTargetActions();
        protected DataFlavor[] getCurrentDataFlavors();
        protected List getCurrentDataFlavorsAsList();
        protected boolean isDataFlavorSupported(DataFlavor df);
        protected Transferable getTransferable();
        // ...
}

Most of the access and control methods are protected, since public access to their state is usually achieved by calling through a particular DropTargetEvent subclass that delegates the request to the DropTargetContext.

The getDropTarget() method return the DropTarget that created this DropTargetContext.

The getComponent method returns the Component associated with the DropTarget that created this DropTargetContext.

The acceptDrag method is delegated from the similar method on DropTargetDragEvent and is invoked from one of the DropTargetListener's methods; dragEnter(), dragOver or dropActionChanged to signify that the recipient is prepared to accept a drop with the operation specified, which is usually the user's currently selected action.

The rejectDrag method is delegated from the similar method on DropTargetDragEvent and is invoked from one of the DropTargetListener's methods; dragEnter, dragOver or dropActionChanged to signify that the recipient is unable to accept a drop with the user's currently selected action.

The acceptDrop method is delegated from the similar method on DropTargetDropEvent and is invoked from the DropTargetListener's drop method to signify that the recipient is prepared to accept a drop with the operation specified, which is usually the user's currently selected action.

The rejectDrop method is delegated from the similar method on DropTargetDropEvent and is invoked from the DropTargetListener's drop method to signify that the recipient is unable to accept a drop with the user's currently selected action. This terminates a drag and drop operation without a data transfer.

The dropComplete method signals to the originating DragSource that the DropTargetListener has completed the transfer(s) that comprise the subject of the drag and drop operation and that the operation is complete. The success (or failure) of the transfer(s) and the subsequent application of the operation specified is signaled by the value of the actual parameter.

The getDataFlavors method returns an array of the DataFlavors available from the DragSource.

The getTransferable method returns a Transferable (not necessarily the one the DragSource registered, it may be a proxy, and certainly shall be in the inter-JVM case) to enable data transfers to occur via its getTransferData method. Note that it is illegal to invoke getTransferable without first invoking an acceptDrop.

The addNotify and removeNotify methods are exclusively called by the underlying platform's DropTargetContextPeer in order to notify the DropTargetContext that a drag and drop operation is occurring/ceasing on the DropTargetContext and associated DropTarget.

The createTransferableProxy method enables a DropTargetContext implementation to interpose a Transferable between the DropTargetListener and the Transferable provided by the caller, which is typically the underlying platform DropTargetContextPeer.

2.4.4 The DropTargetListener Definition

Providing the appropriate "Drag-under" feedback semantics, and processing of any subsequent Drop, is enabled through the DropTargetListener asssociated with a DropTarget.

The DropTargetListener determines the appropriate "Drag-under" feedback and its response to the DragSource regarding drop eligibility by inspecting the sources suggested actions, the data types available and the data itself.

A particular DropTargetListener instance may be associated with a DropTarget via addDropTargetListener and removed via removeDropTargetListener methods.

public interface java.awt.dnd.DropTargetListener
        extends java.util.EventListener {
        void dragEnter            (DropTargetDragEvent dtde);
        void dragOver             (DropTargetDragEvent dtde);
        void dropActionChanged    (DropTargetDragEvent dtde);
        void dragExit             (DropTargetDragEvent dtde);
        void drop                 (DropTargetDropEvent dtde);
}

The following context describes this graphic.

The dragEnter method of the DropTargetListener is invoked when the hotspot of the logical "Drag" Cursor intersects a visible portion of the DropTarget's associated Component's geometry. The DropTargetListener, upon receipt of this notification, shall interrogate the operations or actions, and the types of the data (DataFlavors) and the data itself as supplied by the DragSource to determine the appropriate actions and "Drag-under" feedback to respond with invocation of either acceptDrag or rejectDrag.

The dragOver method of the DropTargetListener is invoked while the hotspot of the logical "Drag" Cursor, in motion, continues to intersect a visible portion of the DropTarget's associated Component's geometry. The DropTargetListener, upon receipt of this notification, shall interrogate the operation "actions" the types of the data and the data itself as supplied by the DragSource to determine the appropriate "actions" and "Drag-under" feedback to respond with an invocation of either acceptDrag or rejectDrag.

The dragExit method of the DropTargetListener is invoked when the hotspot of the logical "Drag" Cursor ceases to intersect a visible portion of the DropTarget's associated Component's geometry, or immediately prior to a drop notification. The DropTargetListener, upon receipt of this notification, shall undo any "Drag-under" feedback effects it has previously applied. Note that the DropTargetContext associated with the DropTarget is invalidated as a side-effect.

The drop method of the DropTargetListener is invoked as a result of the user terminating their drag gesture while intersecting. The DropTargetListener, upon receipt of this notification, shall perform the operation specified by the return value of the getSourceActions method on the DropTargetDropEvent object, upon the Transferable object returned from the getTransferable method, and subsequently invoke the dropComplete method of the associated DropTargetContext to signal the success, or otherwise, of the operation.

2.4.5 The DropTargetDragEvent and DropTargetDropEvent Definitions

The DropTargetEvent and DropTargetDragEvent are defined as follows:

public abstract class java.awt.dnd.DropTargetEvent
          extends java.util.EventObject {

        public DropTargetContext getDropTargetContext();
        //...
}

A DropTargetEvent is passed to the DropTargetListener's dragExit method.

public class   java.awt.dnd.DropTargetDragEvent
                         extends java.awt.dnd.DropTargetEvent {
        public Transferable getTransferable();
        public Point  getLocation();
        public int   getSourceActions();
        public getDropAction();
        public DataFlavor[] getCurrentDataFlavors();
        public List  getCurrentDataFlavorsAsList();
        public boolean isDataFlavorSupported();
        public void acceptDrag(int operation);
        public void rejectDrag();
        //...
}

A DropTargetDragEvent is passed to the DropTargetListener's dragEnter, dragOver and dropActionChanged methods.

The getLocation method return the current co-ordinates, relative to the associated Component's origin, of the hotspot of the logical "Drag" cursor.

The getSourceActions method returns the current "actions", or operations (ACTION_MOVE, ACTION_COPY, or ACTION_REFERENCE) the DragSource associates with the current drag and drop gesture.

The return value of the getDropAction method is the action that is selected by the user's gesture.

The getCurrentDataFlavors, getCurrentDataFlavorsAsList and isDataFlavorSupported methods are provided in order for the recipient to interrogate the list of types available from the source.

The getTransferable method is provided in order for the recipient to interrogate the data available from the source. Note that getTransferable on the DropTargetDragEvent instance should only be called within the respective DropTargetListener's method, and all the necessary data should be retrieved from the returned Transferable before that method returns.

The DropTargetDropEvent is defined as follows:

public class java.awt.dnd.DropTargetDropEvent
          extends java.awt.dnd.DropTargetEvent {

        public Point      getLocation();
        public int getSourceActions();
        public int getDropAction();
        public void acceptDrop(int dropAction);
        public void rejectDrop();
        public boolean isLocalTransfer();
        public DataFlavor[] getCurrentDataFlavors();
        public List  getCurrentDataFlavorsAsList();
        public boolean isDataFlavorSupported(DataFlavor df);
        public Transferable getTransferable();
        public void dropComplete(boolean success);
        //...
}

A DropTargetDropEvent is passed to the DropTargetListener's drop method, as the drop occurs. The DropTargetDropEvent provides the DropTargetListener with access to the data associated with the operation, via the Transferable returned from the getTransferable method.

The return value of the getSourceActions method is defined to be the action(s) defined by the source at the time at which the drop occurred.

The return value of the getDropAction method is the action that is selected by the user's gesture.

The return value of the getLocation method is defined to be the location at which the drop occurred.

The getCurrentDataFlavors, getCurrentDataFlavorsAsList, and isDataFlavorSupported, methods are provided in order for the recipient to interrogate the list of types available from the source for subsequent transfer via the getTransferData method of the Transferable.

A typical implementation of the drop method will inspect the actions and the DataFlavors' available to determine if a successful exchange can occur or not.

When an exchange may occur, a DropTargetListener.drop implementation shall invoke acceptDrop with the selected operation as an actual parameter, prior to any invocation of getTransferable. Calling getTransferable prior to acceptDrop shall result in an InvalidDnDOperationException.

The rejectDrop shall be called to reject the drop operation. Once called no further interaction can occur between the two participants, therefore it is typical to return from the drop method immediately after calling this.

The isLocalTransfer method shall return true, if the source of the drag and drop operation resides within the same physical JVM as the recipient of the drop notification, and false otherwise.

This distinction is significant to the recipient when it receives object references back from invoking Transferable.getTransferData in the local case, since in this case the object reference it receives is the same object reference held by the source (i.e it is not a copy, proxy or distinct object) thus the recipient must treat such a shared object reference differently in the local case as follows:

  • If the action is ACTION_COPY then the recipient shall, depending upon the nature of the object(s) and data transferred, either take a copy of; the object itself, the data encapsulated within, or both.
  • If the action is ACTION_MOVE, then the recipient shall not modify the state of the object or the data encapsulated within until after it has signalled to the source, via an invocation of dropCompete that the transfer is effected. (Note that a source is also prohibited from modifying the state of such an object after it has returned such an object from it's getTransferData method, until such time as it receives a dragDropEnd notification.)
  • If the action is ACTION_LINK, neither the recipient nor the source shall alter the state of either the object exchanged or any data contained therein until after the dropComplete and dragDropEnd methods have been processed. Thereafter the sharing semantics are implementation dependent upon the object(s) shared.

The dropComplete method signals the end of the associated drag and drop operation, and indicates the success (or failure) of the transfers performed by the recipient. Invoking this method results in the DragSourceListener's dragDropEnd method being called with the appropriate state available from it's DragSourceDropEvent. Failure to invoke this method will result in the drag and drop operation failing to terminate properly.

2.4.6 Autoscrolling Support

Many GUI Components present a scrollable "viewport" over a (potentially) large dataset. During a drag and drop operation it is desirable to be able to "autoscroll" such "viewports" to allow a user to navigate over such a dataset, scrolling to locate a particular member (initially not visible through the "viewport") that they wish to drop the subject of the operation upon.

Components that are scrollable provide drag "autoscrolling" support to their DropTarget by implementing the following interface:

public interface Autoscroll {
        Insets getAutoscrollInsets();
        void autoScrollContent(Point cursorLocn);
}

An implementing DropTarget shall periodically call the autoscroll method of its associated Component (if present), passing the current logical cursor location in Component co-ordinates, when the following conditions are met:

  • If the logical cursor's hotspot intersects with the associated Component's visible geometry and the boundary region described by the Insets returned by the getAutoscrollInsets method.
  • If the logical cursor's hotspot has not moved (subject to the next condition below) for an implementation defined period (millisecs)
  • If any cursor movement subsequent to the initial triggering occurrence does not exceed a platform dependent hysteresis value (pixels).

Should any of the above conditions cease to be valid, autoscrolling shall terminate until the next triggering condition occurs.

Both the initial delay prior to autoscrolling commencing, the interval between autoscrolling notifications, and the pixel hysteresis value are externally configurable and can be queried from the Toolkit.getDesktopProperty method.

2.5 Data Transfer Phase

In the case where a valid drop occurs, the DropTargetListener's drop method is responsible for undertaking the transfer of the data associated with the gesture. The DropTargetDropEvent provides a means to obtain a Transferable object that represent that data object(s) to be transferred.

From the drop method, the DropTargetListener shall initially either rejectDrop (immediately returning thereafter) or acceptDrop specifying the selected operation from those returned by getSourceActions.

Subsequent to an acceptDrop, but not before, getTransferable may be invoked, and any data transfers performed via the returned Transferable's getTransferData method. Finally, once the destination of the drop has completed the transfer(s) of the objects from the source it shall signal the success, or immediate failure, of the transfer(s) via an invocation of DropTargetContext.dropComplete.

Upon returning from the DropTargetContext.dropComplete method the Transferable and DragSourceContext instances are no longer guaranteed to be valid and all references to them shall be discarded by the recipient to allow them to be subsequently garbage collected.

When using the ACTION_REFERENCE operation the source and destination should take care to agree upon the object and the associated semantics of the transfer. Typically in intra-JVM transfers a live object reference would be passed between source and destination, but in the case of inter-JVM transfers, or transfers between native and Java applications, live object references do not make sense, so some other ‘reference' type should be exchanged such as a URI for example. Both the DragSource and DropTarget can detect if the transfer is intra-JVM or not.

2.5.1 FlavorMap and SystemFlavorMap

All the target DnD platforms represent their transfer data types using a similar mechanism, however the representations do differ. The Java platform uses MIME types encapsulated within a DataFlavor to represent its data types. Unfortunately in order to permit the transfer of data between Java and platform native applications the existence of these platform names need to be exposed, thus a mechanism is required in order to create an extensible (platform independent) mapping between these platform dependent type names, their representations, and the Java MIME based DataFlavors.

The implementation will provide a mechanism to externally specify a mapping between platform native data types (strings) and MIME types (strings) used to construct DataFlavors. This external mapping will be used by the underlying platform specific implementation code in order to expose the appropriate DataFlavors (MIME types), exported by the source, to the destination, via the underlying platform DnD mechanisms.

Both the DragSource and DropTarget classes provide access for the underlying system to map platform dependent names to and from DataFlavors.

public interface java.awt.datatransfer.FlavorMap {
        java.util.Map getNativesForFlavors(DataFlavor[] dfs);
        java.util.Map getFlavorsForNatives(String[] natives);
}

The getNativesForFlavors method takes an array of DataFlavors and returns a Map object containing zero or more keys of type DataFlavor, from the actual parameter dfs, with associated values of type String, which correspond to the platform-dependent type name for that MIME type.

The getFlavorsForNatives method takes an array of String types and returns a Map object containing zero or more keys of type String, from the actual parameter natives, with associated values of type DataFlavor, which correspond to the platform-independent type for that platform-dependent type name.

The Map object returned by both methods may be mutable but is not required to be.

If NULL is passed to either of these methods they should return their current map of all keys and values known to the implementation at the time of the call.

For example on Win32 the Clipboard Format Name for simple text is "CF_TEXT" (actually it is the integer 1) and on Motif it is the X11 Atom named "STRING", the MIME type one may use to represent this would be "text/plain;charset=us-ascii". Therefore a platform portable FlavorMap would map between these names; CF_TEXT on win32 and STRING on Motif/X11.

Typically, as implemented in the SystemFlavorMap these mappings are held in an external persistent configuration format (a properties file or URL) and are loaded from the platform to configure the FlavorMap appropriately for a given platform.

The SystemFlavorMap class is provided to implement a simple, platform configurable mechanism for specifying a system-wide set of common mappings, and is defined as follows:

public class  java.awt.datatransfer.SystemFlavorMap implements FlavorMap, FlavorTable {
        public static FlavorMap getSystemFlavorMap();
        public synchronized Map getNativesForFlavors(DataFlavor[] dfs);
        public synchronized Map getFlavorsForNatives(String[] natives);
        public static String encodeDataFlavor(DataFlavor flav);
        public static String encodeJavaMIMEType(String mimeType);
        public static boolean isJavaMIMEType(String mimeStr);
        public static String decodeJavaMIMEType(String nat);
        public static DataFlavor decodeDataFlavor(String nat);
        //...
}

The SystemFlavorMap class provides a simple implementation, using a properties file (see java.awt.Properties), of a persistent platform FlavorMap. Using the value of the AWT property "AWT.flavorMapFileURL" (see Toolkit.getProperty) or the default file location of System.getProperty("java.home") + File.separator + "lib" + File.separator + "flavormap.properties", this class creates the appropriate Maps from the properties found therein.

In addition the class provides several static convenience functions used to encode and decode Java MimeTypes to and from a platform dependent namespace. The syntax of the properties file is:

{ <platform_type_name> ‘=' <IETF_MIME_RFC_conformant_specification> <nl> } *

The default implementations of DragSource and DropTarget return the SystemFlavorMap from their getFlavorMap method, unless they have been provided with an overriding implementation.

2.5.2 Transferring Data across the JVM boundary

Since one of the primary goals of this API is to allow drag and drop of data between Java and native applications this has some significant consequences upon the method and mechanism of the actual data encoding and exchange when data is passed across the boundary of the Java Virtual Machine.

Since one of the participants in such an exchange may be a native application, and thus has no knowledge of the Java type system, the drag and drop system cannot just exchange a Java object reference since the other participant may have no knowledge of, or capability to manipulate such a type.

When any exchange occurs, it can only do so, regardless of the implementation of the participants, if and only if both participants are agreed upon a familiar data type and encoding. Thus, sadly the burden of the exchange is born mostly by the participants themselves.

What this means in practical terms is that for "native" data formats, such as platform-dependent image, document, or other "Content-Types" the encoding and decoding of their associated external data format is the responsibility of the source and destination of the transfer.

The drag and drop system shall expose the external representation of such "native" data types across the boundary of the Java Virtual Machine as encapsulated within a java.io.InputStream or a subclass thereof.

This means that any DataFlavor with a representation class that extends java.io.InputStream can be transferred, and will be exposed for transfer, across the Java Virtual Machine boundary.

To implement the exchange of such a native data type, a developer would define a DataFlavor with a MIME "Content-Type" that describes the nature of the "native" data type, with a representation class that extends a java.io.InputStream class that encodes the data encapsulated into a stream of bytes.

In particular such InputStream subclasses shall implement the following semantics:

  • Provide a public constructor with a single argument of type java.io.InputStream.

    Provision of this constructor by a subclass of java.io.InputStream will allow the drag and drop system (associated with the DropTarget) to automatically re-construct an instance of the representation class specified by the requested DataFlavor, and initialize it with an InputStream containing the encapsulated data formatted according to the expectations of that subclass. Once initialized this instance is returned to the caller of the Transferable.getTransferData method, thus allowing the caller to subsequently re-read and interpret the formatted content of the data stream transferred.

  • Provide an implementation of InputStream.read(byte b[], int off, int len).

Provision of this method (or inheriting a superclasses implementation) enables the drag and drop system (associated with the DragSource) to automatically extract an encoded stream of the encapsulated data from the Transferable, thus enabling the transfer of the data across the JVM boundary as a simple byte stream to the requestor of the particular DataFlavor.

2.5.3 Transferring lists of files across the JVM boundary.

A typical subject of a Drag and Drop transfer is a list of one or more platform dependent filenames. In order to ease the programming task of developers either producing or consuming such lists the drag and drop system treats them as a special case.

If a DataFlavor is specified with a MIME "Content-Type" of application/x-java-file-list;class=java.util.List the drag and drop system will expect the list elements to be a homogeneous list of objects of type java.io.File. Thus a source shall, if supporting the transfer of a list of files, construct such a List of File objects when such a DataFlavor is requested, and a recipient shall expect such a List of File objects if it requests such a valid DataFlavor from its source. This special case provides a simple mechanism for the transfer of lists of files between source and target.

2.5.4 Transferring java.rmi.Remote references across the JVM boundary.

It is possible to Drag and Drop object references between JVMs' by using the facilities of the RMI mechanism. The Drag and Drop system will automatically arrange for the transfer of any object reference that adheres to these requirements:

  • The representation class of interface associated with the requested DataFlavor implements both java.rmi.Remote and java.io.Serializable.

    (the MIME "Content-Type" can be any suitable, arbitrary type or application/x-java-remote-object)

    (effectively the object implementation class transferred should be extended from java.rmi.server.UnicastRemoteObject since the RMI system implements some required initialization, without which the transfer will not complete properly).

  • The drop action is ACTION_LINK.

If these conditions are met, then if an appropriate DataFlavor is requested, then the object returned to the requestor (if it is in a difference JVM from the source) will be an RMI reference to an instance of the Remote object subinterface specified as the representation class of the DataFlavor.

3.0 Issues

3.0.1 What are the implications of the various platform protocol engines?

Due to limitations of particular underlying platform drag and drop and window system implementations, the interaction of a drag operation, and the event delivery semantics to AWT Components is platform dependent. Therefore during a drag operation a DragSource may process platform Window System Events pertaining to that drag to the exclusion of normal event processing.

Due to interactions between the single-threaded design center of the platform native DnD systems, and the native window system event dispatching implementations in AWT, "callbacks" into DropTargetListener and DragSourceListener will occur either on, or synchronized with the AWT system event dispatch thread. This behavior is highly undesirable for security reasons but is an implementation, not architectural feature, and is unavoidable.

3.0.2 Inter/Intra VM transfers?

To enable intra-JVM Drag and Drop Transfers the existing DataFlavor class will be extended to enable it to represent the type of a "live" object reference, as opposed to a Serialized (persistent) representation of one. Such objects may be transferred between source and destination within the same JVM and ClassLoader context.

The MIME Content-Type shall be application/x-java-local-objectref.

3.0.3 Lifetime of the Transferable(s)?

Transferable objects, their associated DataFlavors', and the objects that encapsulate the underlying data specified as the operand(s) of a drag and drop operation shall remain valid until, at least, the DragSourceListener associated with the DragSource controlling the operation, receives a dragDropEnd. The lifetime of the subject(s) of the operation, transferred between source and target is implementation defined beyond that point in time.

3.0.4 Implications of ACTION_MOVE semantics on source objects exposed via Transferable?

The "source" of a successful Drag and Drop (ACTION_MOVE) operation is required to delete/relinquish all references to the object(s) that are the subject of the Transferable immediately after transfer has been successfully completed. That is before returning from the DragSourceListener.dragDropEnd notification.

3.0.5 Semantics of ACTION_REFERENCE operation.

As a result of significant input from developers to an earlier version of the specification an additional operation/action tag; ACTION_REFERENCE was added to include existing platform Drag and Drop"Link" semantics.

It is believed that Reference, or Link, semantics are already sufficiently poorly specified for the platform native Drag and Drop to render it essentially useless even between native applications, thus between native and platform independent Java applications it is not recommended.

For Java to Java usage the required semantic; within the same JVM/ClassLoader, is defined such that the destination shall obtain a Java object reference to the subject(s) of the transfer. Between Java JVM's or ClassLoaders, the semantic is implementation defined, but could be implemented through transferring either a URL from the source to the destination or an RMI Remote reference.

Appendix A : DropTargetPeer definition

Although not a normative part of this specification this definition is included for clarity:

public interface DropTargetPeer {
        void addDropTarget(DropTarget dt);
        void removeDropTarget(DropTarget dt);
}

Appendix B : DragSourceContextPeer definition

Although not a normative part of this specification this definition is included for clarity:

public interface DragSourceContextPeer {
    void startDrag(DragSourceContext dsc,
                   Cursor            c,
                   Image             di,
                   Point             ioff
    ) throws InvalidDnDOperationException;
    Cursor getCursor();
    void   setCursor(Cursor c) throws InvalidDnDOperationException;
    void transferablesFlavorsChanged();
}

Appendix C : DropTargetContextPeer definition

Although not a normative part of this specification this definition is included for clarity:

public interface DropTargetContextPeer {
    int  getTargetActions();
    void setTargetActions(int actions);
    DropTarget getDropTarget();
    DataFlavor[] getTransferDataFlavors();
    Transferable getTransferable() throws InvalidDnDOperationException;
    boolean isTransferableJVMLocal();
    void acceptDrag(int dragAction);
    void rejectDrag();
    void acceptDrop(int dropAction);
    void rejectDrop();
    void dropComplete(boolean success);
}
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.javadoc.Doc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.Doc

    • Uses of Doc in com.sun.javadoc

      Subinterfaces of Doc in com.sun.javadoc
      Modifier and Type Interface and Description
      interface  AnnotationTypeDoc
      Represents an annotation type.
      interface  AnnotationTypeElementDoc
      Represents an element of an annotation type.
      interface  ClassDoc
      Represents a java class or interface and provides access to information about the class, the class's comment and tags, and the members of the class.
      interface  ConstructorDoc
      Represents a constructor of a java class.
      interface  ExecutableMemberDoc
      Represents a method or constructor of a java class.
      interface  FieldDoc
      Represents a field in a java class.
      interface  MemberDoc
      Represents a member of a java class: field, constructor, or method.
      interface  MethodDoc
      Represents a method of a java class.
      interface  PackageDoc
      Represents a java package.
      interface  ProgramElementDoc
      Represents a java program element: class, interface, field, constructor, or method.
      interface  RootDoc
      Represents the root of the program structure information for one run of javadoc.
      Methods in com.sun.javadoc that return Doc
      Modifier and Type Method and Description
      Doc Tag.holder()
      Return the containing Doc of this Tag element.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible to all users, including users that are disabled. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by the disabled community. Accessibility standards will continue to evolve over time, and Oracle is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For more information, visit the Oracle Accessibility Program Web site at http://www.oracle.com/us/corporate/accessibility/index.html.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, some screen readers may not always read a line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.

Access to Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/support/contact.html or visit http://www.oracle.com/accessibility/support.html if you are hearing impaired.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.doctree.DocCommentTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.DocCommentTree

  • Packages that use DocCommentTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocCommentTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DocCommentTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitDocComment(DocCommentTree node, P p)

    • Uses of DocCommentTree in com.sun.source.util

      Methods in com.sun.source.util that return DocCommentTree
      Modifier and Type Method and Description
      DocCommentTree DocTreePath.getDocComment()
      Get the DocCommentTree associated with this path.
      abstract DocCommentTree DocTrees.getDocCommentTree(TreePath path)
      Gets the doc comment tree, if any, for the Tree node identified by a given TreePath.
      Methods in com.sun.source.util with parameters of type DocCommentTree
      Modifier and Type | Method and Description
      long DocSourcePositions.getEndPosition(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      Gets the ending position of the tree within the comment within the file.
      static DocTreePath DocTreePath.getPath(TreePath treePath, DocCommentTree doc, DocTree target)
      Gets a documentation tree path for a tree node within a compilation unit.
      long DocSourcePositions.getStartPosition(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      Gets the starting position of the tree within the comment within the file.
      abstract void DocTrees.printMessage(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      Prints a message of the specified kind at the location of the tree within the provided compilation unit
      R | SimpleDocTreeVisitor.visitDocComment(DocCommentTree node, P p)
      R | DocTreeScanner.visitDocComment(DocCommentTree node, P p)
      Constructors in com.sun.source.util with parameters of type DocCommentTree
      Constructor and Description
      DocTreePath(TreePath treePath, DocCommentTree t)
      Creates a DocTreePath for a root node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.javadoc.DocErrorReporter (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.DocErrorReporter

    • Uses of DocErrorReporter in com.sun.javadoc

      Subinterfaces of DocErrorReporter in com.sun.javadoc
      Modifier and Type Interface and Description
      interface  RootDoc
      Represents the root of the program structure information for one run of javadoc.
      Methods in com.sun.javadoc with parameters of type DocErrorReporter
      Modifier and Type Method and Description
      static boolean Doclet.validOptions(String[][] options, DocErrorReporter reporter)
      Check that options have the correct arguments.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Java Print Service API User Guide: 3 - Specifying Document Types

Documentation Contents
CONTENTS | PREV | NEXT
CHAPTER 3

Specifying Document Types

From the user's perspective, a document can take many different forms, including: a PDF file, an image from a digital camera, an email, a word processor document, or a web page. Before printing a document of a particular format, the client needs to ensure that the printer can understand the format. Sometimes a printer can directly print documents of a given format: photo printers can directly print images of various formats, and PostScript printers can directly print a PostScript document. However, there are few printers that can directly print a wide range of formats; most printers require some higher-level software support to translate the source document into a format they can print.

A printing API needs to provide a way to describe document types so that:

  • The printer can report what formats it can print.
  • The client can describe the format of the data it wants to print.
  • The client can describe the encoding of text data.
The Java Print Service API describes document types using the DocFlavor class. A DocFlavor is comprised of:
  • A MIME type that tells the printer how to interpret the data.
  • A representation class name indicating the Java class that describes how the data is sent to the printer.
To describe an HTML page to a print service, a client might choose to use a DocFlavor with a MIME type string of "text/html; charset=utf-16" and a representation class name of "java.io.InputStream". The client can obtain this DocFlavor in one of two ways:
  • Construct a DocFlavor:DocFlavor htmlStreamFlavor = new DocFlavor("text/html; charset=utf-16", "java.io.InputStream");
  • Use the pre-defined instance that represents this type of DocFlavor:DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16 . The Java Print Service API provides a set of pre-defined instances for common doc flavors as a convenience.
Because the HTML page contains text data, the MIME type String includes the text encoding, which is charset=utf-16 in this example. The client is responsible for accurately describing the print data to the print service. The section, Client-Formatted Print Data, explains how to properly construct a DocFlavor to accomplish this. If the text encoding is not included in the MIME type, unexpected results can occur, as explained in the section, Importance of Character Encoding. The client can allow the service to determine the format of data that the client supplies as a Java object. The Service-Formatted Print Data section describes using a DocFlavor to represent service-formatted print data.

Keep in mand that, just because the DocFlavor API has a pre-declared doc flavor, this doesn't mean that an implementation of the particular flavor is available. For example, even if you use the pre-defined DocFlavor representing HTML text in UTF-16, you won't be able to print the HTML unless you have a print service that supports printing HTML. Again, it is the user's responsibility to ensure that a printer supports a particular format.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 3 - Specifying Document Types

Documentation Contents
CONTENTS | PREV | NEXT

Client-Formatted Print Data

The client uses the DocFlavor to describe the print data format and to indicate how the data will be delivered to the print service. The MIME type specifies the data format. The representation class name specifies how the data will be delivered to the printer.

The DocFlavor class has an inner class for each of the common representation class names. Each inner class contains a set of DocFlavor object constants representing formats that can be delivered using the representation class. For example, an input stream can stream many different kinds of print data formats, including GIF, represented by DocFlavor.INPUT_STREAM.GIF, and PostScript, represented by DocFlavor.INPUT_STREAM.POSTSCRIPT. If one of the DocFlavor object constants accurately describes the format of a given piece of print data, the client can use this constant instead of constructing a DocFlavor.

If the appropriate DocFlavor is not already defined in the JPS API, a client can create it with the DocFlavor constructor. The client can use the MIME types and representation class names explained in the next two sections to construct the DocFlavor.

MIME Types for Preformatted Data

The four most common types of preformatted data are: text data, page description language documents, image data, and autosense print data. This section describes each one of these data types and lists their corresponding MIME types.

Text Data

Preformatted text data is usually provided in a character-oriented representation class, such as a character array, String, or Reader, or in a byte-oriented representation class, such as a byte array, input stream, or URL. Plain text and HTML are two common forms of preformatted text data. You can use these MIME type strings to represent the format of the data when constructing a DocFlavor:

MIME type | Format of data
"text/plain" | Plain text in the default character set US-ASCII
"text/plain;charset=xxx" | Plain text in character set xxx
"text/html" | HyperText Markup Languge in the default character set (US-ASCII)
"text/html;charset=xxx" | HyperText Markup Languge in the character set xxx

Page Description Language Documents

Preformatted page description language (PDL) documents are usually provided in a byte-oriented representation class, such as byte array, InputStream, or URL. You can use these MIME type strings to represent the format of the data when constructing a DocFlavor:

MIME type | Format of data
"application/pdf" | Portable Document Format document
"application/postscript" | PostScript document
"application/vnd.hp-PCL" | Printer Control Language document

Image Data

Preformatted image data is provided in a byte-oriented representation class: byte array, InputStream, or URL. You can use these MIME type strings to represent the format of the data when constructing a DocFlavor:

MIME type | Format of data
"image/gif" | Graphics Interchange Format image
"image/jpeg" | Joint Photographic Experts Group image
"image/png" | Portable Network Graphics image

Autosense Print Data

Preformatted autosense print data allows the printer to decide how to interpret the print data. This type of data is usually provided in a byte-oriented representation class. You can use this MIME type string to represent the format of the data when constructing a DocFlavor:

"application/octet-stream"

Representation Classes

For client-formatted print data, the print data representation class is usually one of the following:

Print data representation class | Description
Character array (char[]) | The print data consists of the Unicode characters in the array. This representation class can provide text data and PDL data.
java.lang.String | The print data consists of the Unicode characters in the string. This representation class can provide text data.
A Character stream represented by java.io.Reader | The print data consists of the Unicode characters read from the stream up to the end-of-stream. This representation class can provide text data.
Byte array (byte[]) | The print data consists of the bytes in the array. The bytes are encoded in the character set specified by the doc flavor's MIME type. If the MIME type does not specify a character set, the default character set is US-ASCII. This representation class can provide text data, PDL documents, and image data.
A Byte stream represented by java.io.InputStream | The print data consists of the bytes read from the stream up to the end-of-stream. The bytes are encoded in the character set specified by the doc flavor's MIME type. If the MIME type does not specify a character set, the default character set is US-ASCII. This representation class can provide text data, PDL documents, and image data.
Uniform Resource Locator, java.net.URL | The print data consists of the bytes read from the URL location. The bytes are encoded in the character set specified by the doc flavor's MIME type. If the MIME type does not specify a character set, the default character set is US-ASCII. This representation class can provide text data, PDL documents, and image data. To print documents to a network print service that might not have access to the URL, open an input stream on the URL and use an input stream data flavor instead.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 3 - Specifying Document Types

Documentation Contents
CONTENTS | PREV | NEXT

Importance of Character Encoding

If a MIME type for byte print data does not include a charset parameter, indicating the encoding, the Java Print Service assumes a character set of US-ASCII. This behavior is different than that of the Java runtime, which always assumes the default encodi ng for the user's locale on the underlying operating system, which might be different than US-ASCII.

Every instance of the Java Virtual Machine* has a default character encoding determined during virtual-machine startup that usually depends upon the locale and charset used by the underlying operating system. In a distributed environment, two JVM's might n ot share the same default encoding. Thus clients who want to stream platform-encoded text data from the host platform to a Java Print Service instance must explicitly declare the charset and not rely on defaults.

For these reasons, applications that stream text data should always specify the charset in the MIME type. To specify a MIME type, an application needs to determine the host platform's encoding, which it does by calling the DocFlavor.hostEncoding metho d. The MIME type returned from this method is guaranteed to be understood by the current JVM.

See character encodings for more information on the character encodings supported on the Java platform.

*As used on this web site, the terms "Java Virtual Machine" or "JVM" mean a virtual machine for the Java platform.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 3 - Specifying Document Types

Documentation Contents
CONTENTS | PREV | NEXT

Service-Formatted Print Data

Rather than the client describing the print data format with a MIME type, the client can supply a Java object from which a print service determines the print data format. For example, the Java object can encapsulate a PostScript document. Instead of the client explicitly describing the document as PostScript with a MIME type, the client can wrap a reference to the document in a Java object, which the print service inspects to determine that the format is PostScript. Because the print data is delivered to the print service through the Java object, the class that the Java object implements is the representation class.

The DocFlavor class has an inner class called DocFlavor.SERVICE_FORMATTED that contains DocFlavor object constants representing service-formatted print data. Each of these constants has a MIME type of "application/x-java-jvm-local-objectref", which indicates that the client will supply a reference to a Java object implementing the interface named as the representation class.

The three DocFlavor object constants contained in DocFlavor.SERVICE_FORMATTED each represent a common representation class name used with service-formatted print data:

  • DocFlavor.SERVICE_FORMATTED.PAGEABLE:The client supplies an object that implements thejava.awt.print.Pageable interface, which represents a set of pages to be printed. The printer calls methods in that interface to obtain the pages to be printed, one by one. For each page, the printer supplies a graphics context and prints whatever the client draws in that graphics context.
  • DocFlavor.SERVICE_FORMATTED.PRINTABLE:The client supplies an object that implements the java.awt.print.Printable interface, which is responsible for drawing the contents of each page. The printer calls methods in that interface to obtain the pages to be printed, one by one. For each page, the printer supplies a graphics context and prints whatever the client draws in that graphics context.
  • DocFlavor.SERVICE_FORMATTED.RENDERABLE_IMAGE:The client supplies an object that implements interface java.awt.image.renderable.RenderableImage, which represents an image that can be manipulated in a rendering-independent manner and can be rendered to various contexts, such as a printer, without compromising quality. The printer calls methods in the interface to obtain the image to be printed.
  • As stated in the Introduction, applications that wrap 2D graphics into a Java object can use the service-formatted print data DocFlavor constants. See Printing and Streaming 2D Graphics for more information.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Print Service API User Guide: 3 - Specifying Document Types

Documentation Contents
CONTENTS | PREV | NEXT

How to Use DocFlavor

These steps illustrate the role of the DocFlavor in a typical application:
  1. A client determines the format of the print data and decides how to present the data to the printer. The client then creates or obtains a DocFlavorrepresenting the format:DocFlavor flavor = DocFlavor.INPUT_STREAM.GIF;
  2. The client uses the DocFlavor to find printers that can understand the format specified by the DocFlavor and has the capabilities specified in the client's attribute set:PrintService[] services = PrintServiceLookup.lookupPrintServices(flavor, aset);
  3. From a print service, the client creates a print job, represented by a DocPrintJob object:DocPrintJob printJob = services[0].createPrintJob();
  4. The client creates a Doc representing the document to be printed:Doc doc = new InputStreamDoc("duke.gif", flavor);
  5. The client prints the document by calling the print method of the DocPrintJob object:printJob.print(doc, aset);When the client passes the Doc object to the print method, the DocPrintJob object obtains the print data from the Doc object and determines the doc flavor that the client can supply. The doc flavor's representation class is a conduit for the DocPrintJob to obtain a sequence of characters or bytes from the client.
The Printing and Streaming Documents chapter demonstrates a complete printing application.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.javadoc.Doclet (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.javadoc.Doclet

No usage of com.sun.javadoc.Doclet
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.source.doctree.DocRootTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.DocRootTree

  • Packages that use DocRootTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocRootTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DocRootTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitDocRoot(DocRootTree node, P p)

    • Uses of DocRootTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type DocRootTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitDocRoot(DocRootTree node, P p)
      R | DocTreeScanner.visitDocRoot(DocRootTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.util.DocSourcePositions (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.util.DocSourcePositions

  • Packages that use DocSourcePositions
    Package Description
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocSourcePositions in com.sun.source.util

      Methods in com.sun.source.util that return DocSourcePositions
      Modifier and Type | Method and Description
      abstract DocSourcePositions | DocTrees.getSourcePositions()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.doctree.DocTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.DocTree

  • Packages that use DocTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocTree in com.sun.source.doctree

      Subinterfaces of DocTree in com.sun.source.doctree
      Modifier and Type Interface and Description
      interface  AttributeTree
      A tree node for an attribute in an HTML element.
      interface  AuthorTree
      A tree node for an @author block tag.
      interface  BlockTagTree
      A tree node used as the base class for the different types of block tags.
      interface  CommentTree
      An embedded HTML comment.
      interface  DeprecatedTree
      A tree node for an @deprecated block tag.
      interface  DocCommentTree
      The top level representation of a documentation comment.
      interface  DocRootTree
      A tree node for an @docroot inline tag.
      interface  EndElementTree
      A tree node for the end of an HTML element.
      interface  EntityTree
      A tree node for an HTML entity.
      interface  ErroneousTree
      A tree node to stand in for a malformed text
      interface  IdentifierTree
      An identifier in a documentation comment.
      interface  InheritDocTree
      A tree node for an @inheritDoc inline tag.
      interface  InlineTagTree
      A tree node used as the base class for the different types of inline tags.
      interface  LinkTree
      A tree node for an @link or @linkplain inline tag.
      interface  LiteralTree
      A tree node for an @literal or @code inline tag.
      interface  ParamTree
      A tree node for an @param block tag.
      interface  ReferenceTree
      A tree node to a reference to a Java language element.
      interface  ReturnTree
      A tree node for an @return block tag.
      interface  SeeTree
      A tree node for an @see block tag.
      interface  SerialDataTree
      A tree node for an @serialData block tag.
      interface  SerialFieldTree
      A tree node for an @serialData block tag.
      interface  SerialTree
      A tree node for an @serial block tag.
      interface  SinceTree
      A tree node for an @since block tag.
      interface  StartElementTree
      A tree node for the start of an HTML element.
      interface  TextTree
      A tree node for plain text.
      interface  ThrowsTree
      A tree node for an @exception or @throws block tag.
      interface  UnknownBlockTagTree
      A tree node for an unrecognized inline tag.
      interface  UnknownInlineTagTree
      A tree node for an unrecognized inline tag.
      interface  ValueTree
      A tree node for an @value inline tag.
      interface  VersionTree
      A tree node for an @version block tag.
      Methods in com.sun.source.doctree that return types with arguments of type DocTree
      Modifier and Type | Method and Description
      List<? extends DocTree> | StartElementTree.getAttributes()
      List<? extends DocTree> | DocCommentTree.getBlockTags()
      List<? extends DocTree> | DeprecatedTree.getBody()
      List<? extends DocTree> | DocCommentTree.getBody()
      List<? extends DocTree> | VersionTree.getBody()
      List<? extends DocTree> | SinceTree.getBody()
      List<? extends DocTree> | UnknownInlineTagTree.getContent()
      List<? extends DocTree> | UnknownBlockTagTree.getContent()
      List<? extends DocTree> | ThrowsTree.getDescription()
      List<? extends DocTree> | SerialDataTree.getDescription()
      List<? extends DocTree> | ParamTree.getDescription()
      List<? extends DocTree> | SerialTree.getDescription()
      List<? extends DocTree> | SerialFieldTree.getDescription()
      List<? extends DocTree> | ReturnTree.getDescription()
      List<? extends DocTree> | DocCommentTree.getFirstSentence()
      List<? extends DocTree> | LinkTree.getLabel()
      List<? extends DocTree> | AuthorTree.getName()
      List<? extends DocTree> | SeeTree.getReference()
      List<? extends DocTree> | AttributeTree.getValue()
      Methods in com.sun.source.doctree with parameters of type DocTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitOther(DocTree node, P p)

    • Uses of DocTree in com.sun.source.util

      Methods in com.sun.source.util that return DocTree
      Modifier and Type Method and Description
      DocTree DocTreePath.getLeaf()
      Get the leaf node for this path.
      Methods in com.sun.source.util that return types with arguments of type DocTree
      Modifier and Type | Method and Description
      Iterator<DocTree> | DocTreePath.iterator()
      Methods in com.sun.source.util with parameters of type DocTree
      Modifier and Type | Method and Description
      protected R | SimpleDocTreeVisitor.defaultAction(DocTree node, P p)
      long DocSourcePositions.getEndPosition(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      Gets the ending position of the tree within the comment within the file.
      static DocTreePath DocTreePath.getPath(DocTreePath path, DocTree target)
      Gets a documentation tree path for a tree node within a subtree identified by a DocTreePath object.
      static DocTreePath DocTreePath.getPath(TreePath treePath, DocCommentTree doc, DocTree target)
      Gets a documentation tree path for a tree node within a compilation unit.
      long DocSourcePositions.getStartPosition(CompilationUnitTree file, DocCommentTree comment, DocTree tree)
      Gets the starting position of the tree within the comment within the file.
      abstract void DocTrees.printMessage(Diagnostic.Kind kind, CharSequence msg, DocTree t, DocCommentTree c, CompilationUnitTree root)
      Prints a message of the specified kind at the location of the tree within the provided compilation unit
      R DocTreePathScanner.scan(DocTree tree, P p)
      Scan a single node.
      R DocTreeScanner.scan(DocTree node, P p)
      Scan a single node.
      R | SimpleDocTreeVisitor.visit(DocTree node, P p)
      R | SimpleDocTreeVisitor.visitOther(DocTree node, P p)
      R | DocTreeScanner.visitOther(DocTree node, P p)
      Method parameters in com.sun.source.util with type arguments of type DocTree
      Modifier and Type | Method and Description
      R DocTreeScanner.scan(Iterable<? extends DocTree> nodes, P p)
      Scan a list of nodes.
      R | SimpleDocTreeVisitor.visit(Iterable<? extends DocTree> nodes, P p)
      Constructors in com.sun.source.util with parameters of type DocTree
      Constructor and Description
      DocTreePath(DocTreePath p, DocTree t)
      Creates a DocTreePath for a child node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.source.doctree.DocTree.Kind (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.source.doctree.DocTree.Kind

  • Packages that use DocTree.Kind
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).

    • Uses of DocTree.Kind in com.sun.source.doctree

      Methods in com.sun.source.doctree that return DocTree.Kind
      Modifier and Type Method and Description
      DocTree.Kind DocTree.getKind()
      Gets the kind of this tree.
      static DocTree.Kind DocTree.Kind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DocTree.Kind[] DocTree.Kind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.source.util.DocTreePath (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.source.util.DocTreePath

  • Packages that use DocTreePath
    Package Description
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocTreePath in com.sun.source.util

      Methods in com.sun.source.util that return DocTreePath
      Modifier and Type Method and Description
      DocTreePath DocTreePathScanner.getCurrentPath()
      Get the current path for the node, as built up by the currently active set of scan calls.
      DocTreePath DocTreePath.getParentPath()
      Get the path for the enclosing node, or null if there is no enclosing node.
      static DocTreePath DocTreePath.getPath(DocTreePath path, DocTree target)
      Gets a documentation tree path for a tree node within a subtree identified by a DocTreePath object.
      static DocTreePath DocTreePath.getPath(TreePath treePath, DocCommentTree doc, DocTree target)
      Gets a documentation tree path for a tree node within a compilation unit.
      Methods in com.sun.source.util with parameters of type DocTreePath
      Modifier and Type Method and Description
      abstract Element DocTrees.getElement(DocTreePath path)
      Gets the language model element referred to by the leaf node of the given DocTreePath, or null if unknown.
      static DocTreePath DocTreePath.getPath(DocTreePath path, DocTree target)
      Gets a documentation tree path for a tree node within a subtree identified by a DocTreePath object.
      R DocTreePathScanner.scan(DocTreePath path, P p)
      Scan a tree from a position identified by a TreePath.
      Constructors in com.sun.source.util with parameters of type DocTreePath
      Constructor and Description
      DocTreePath(DocTreePath p, DocTree t)
      Creates a DocTreePath for a child node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.source.util.DocTreePathScanner (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.source.util.DocTreePathScanner

No usage of com.sun.source.util.DocTreePathScanner
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.source.util.DocTrees (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.source.util.DocTrees

  • Packages that use DocTrees
    Package Description
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocTrees in com.sun.source.util

      Methods in com.sun.source.util that return DocTrees
      Modifier and Type Method and Description
      static DocTrees DocTrees.instance(JavaCompiler.CompilationTask task)
      Gets a DocTrees object for a given CompilationTask.
      static DocTrees DocTrees.instance(ProcessingEnvironment env)
      Gets a DocTrees object for a given ProcessingEnvironment.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.source.util.DocTreeScanner (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.source.util.DocTreeScanner

  • Packages that use DocTreeScanner
    Package Description
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocTreeScanner in com.sun.source.util

      Subclasses of DocTreeScanner in com.sun.source.util
      Modifier and Type Class and Description
      class  DocTreePathScanner<R,P>
      A DocTreeVisitor that visits all the child tree nodes, and provides support for maintaining a path for the parent nodes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.doctree.DocTreeVisitor (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.DocTreeVisitor

  • Packages that use DocTreeVisitor
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DocTreeVisitor in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type DocTreeVisitor
      Modifier and Type Method and Description
      <R,D> R DocTree.accept(DocTreeVisitor<R,D> visitor, D data)
      Accept method used to implement the visitor pattern.

    • Uses of DocTreeVisitor in com.sun.source.util

      Classes in com.sun.source.util that implement DocTreeVisitor
      Modifier and Type Class and Description
      class  DocTreePathScanner<R,P>
      A DocTreeVisitor that visits all the child tree nodes, and provides support for maintaining a path for the parent nodes.
      class  DocTreeScanner<R,P>
      A TreeVisitor that visits all the child tree nodes.
      class  SimpleDocTreeVisitor<R,P>
      A simple visitor for tree nodes.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Document (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Document

  • Packages that use Document
    Package Description
    com.sun.java.browser.dom
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.html
    org.w3c.dom.ls

    • Uses of Document in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom that return Document
      Modifier and Type Method and Description
      Document DOMAccessor.getDocument(Object obj)
      Returns the Document object of the DOM.
      abstract Document DOMServiceProvider.getDocument(Object obj)
      Returns the Document object of the DOM.

    • Uses of Document in org.w3c.dom

      Methods in org.w3c.dom that return Document
      Modifier and Type Method and Description
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      Document Node.getOwnerDocument()
      The Document object associated with this node.

    • Uses of Document in org.w3c.dom.html

      Subinterfaces of Document in org.w3c.dom.html
      Modifier and Type Interface and Description
      interface  HTMLDocument
      An HTMLDocument is the root of the HTML hierarchy and holds the entire content.
      Methods in org.w3c.dom.html that return Document
      Modifier and Type Method and Description
      Document HTMLIFrameElement.getContentDocument()
      The document this frame contains, if there is any and it is available, or null otherwise.
      Document HTMLFrameElement.getContentDocument()
      The document this frame contains, if there is any and it is available, or null otherwise.
      Document HTMLObjectElement.getContentDocument()
      The document this object contains, if there is any and it is available, or null otherwise.

    • Uses of Document in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Document
      Modifier and Type Method and Description
      Document LSLoadEvent.getNewDocument()
      The document that finished loading.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.DocumentCSS (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.DocumentCSS

No usage of org.w3c.dom.css.DocumentCSS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.events.DocumentEvent (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.DocumentEvent

No usage of org.w3c.dom.events.DocumentEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DocumentFragment (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DocumentFragment

  • Packages that use DocumentFragment
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.ranges
    Document Object Model Level 2 Traversal and Range is a platform and language-neutral interfaces that allow programs and scripts to dynamically traverse and identify a range of content in a document.

    • Uses of DocumentFragment in org.w3c.dom

      Methods in org.w3c.dom that return DocumentFragment
      Modifier and Type Method and Description
      DocumentFragment Document.createDocumentFragment()
      Creates an empty DocumentFragment object.

    • Uses of DocumentFragment in org.w3c.dom.ranges

      Methods in org.w3c.dom.ranges that return DocumentFragment
      Modifier and Type Method and Description
      DocumentFragment Range.cloneContents()
      Duplicates the contents of a Range
      DocumentFragment Range.extractContents()
      Moves the contents of a Range from the containing document or document fragment to a new DocumentFragment.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.ranges.DocumentRange (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ranges.DocumentRange

No usage of org.w3c.dom.ranges.DocumentRange
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.stylesheets.DocumentStyle (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.stylesheets.DocumentStyle

  • Packages that use DocumentStyle
    Package Description
    org.w3c.dom.css

    • Uses of DocumentStyle in org.w3c.dom.css

      Subinterfaces of DocumentStyle in org.w3c.dom.css
      Modifier and Type Interface and Description
      interface  DocumentCSS
      This interface represents a document with a CSS view.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.traversal.DocumentTraversal (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.traversal.DocumentTraversal

No usage of org.w3c.dom.traversal.DocumentTraversal
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DocumentType (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DocumentType

  • Packages that use DocumentType
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DocumentType in org.w3c.dom

      Methods in org.w3c.dom that return DocumentType
      Modifier and Type Method and Description
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      DocumentType Document.getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Methods in org.w3c.dom with parameters of type DocumentType
      Modifier and Type Method and Description
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.views.DocumentView (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.views.DocumentView

  • Packages that use DocumentView
    Package Description
    org.w3c.dom.views

    • Uses of DocumentView in org.w3c.dom.views

      Methods in org.w3c.dom.views that return DocumentView
      Modifier and Type Method and Description
      DocumentView AbstractView.getDocument()
      The source DocumentView of which this is an AbstractView.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class com.sun.java.browser.dom.DOMAccessException (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.java.browser.dom.DOMAccessException

  • Packages that use DOMAccessException
    Package Description
    com.sun.java.browser.dom

    • Uses of DOMAccessException in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom that throw DOMAccessException
      Modifier and Type Method and Description
      abstract Object DOMService.invokeAndWait(DOMAction action)
      Causes action.run() to be executed synchronously on the DOM action dispatching thread.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.java.browser.dom.DOMAccessor (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.java.browser.dom.DOMAccessor

  • Packages that use DOMAccessor
    Package Description
    com.sun.java.browser.dom

    • Uses of DOMAccessor in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom with parameters of type DOMAccessor
      Modifier and Type Method and Description
      Object DOMAction.run(DOMAccessor accessor)
      When an object implementing interface DOMAction is passed to DOMService.invokeAndWait() or DOMService.invokeLater(), run method is called in the DOM access dispatch thread.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.java.browser.dom.DOMAction (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.java.browser.dom.DOMAction

  • Packages that use DOMAction
    Package Description
    com.sun.java.browser.dom

    • Uses of DOMAction in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom with parameters of type DOMAction
      Modifier and Type Method and Description
      abstract Object DOMService.invokeAndWait(DOMAction action)
      Causes action.run() to be executed synchronously on the DOM action dispatching thread.
      abstract void DOMService.invokeLater(DOMAction action)
      Causes action.run() to be executed asynchronously on the DOM action dispatching thread.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMConfiguration (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMConfiguration

  • Packages that use DOMConfiguration
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.ls

    • Uses of DOMConfiguration in org.w3c.dom

      Methods in org.w3c.dom that return DOMConfiguration
      Modifier and Type Method and Description
      DOMConfiguration Document.getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.

    • Uses of DOMConfiguration in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return DOMConfiguration
      Modifier and Type Method and Description
      DOMConfiguration LSParser.getDomConfig()
      The DOMConfiguration object used when parsing an input source.
      DOMConfiguration LSSerializer.getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMError (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMError

  • Packages that use DOMError
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DOMError in org.w3c.dom

      Methods in org.w3c.dom with parameters of type DOMError
      Modifier and Type Method and Description
      boolean DOMErrorHandler.handleError(DOMError error)
      This method is called on the error handler when an error occurs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMErrorHandler (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMErrorHandler

No usage of org.w3c.dom.DOMErrorHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class org.w3c.dom.DOMException (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.DOMException

  • Packages that use DOMException
    Package Description
    com.sun.java.browser.dom
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.css
    org.w3c.dom.events
    org.w3c.dom.html
    org.w3c.dom.ls
    org.w3c.dom.ranges
    Document Object Model Level 2 Traversal and Range is a platform and language-neutral interfaces that allow programs and scripts to dynamically traverse and identify a range of content in a document.
    org.w3c.dom.stylesheets
    org.w3c.dom.traversal

    • Uses of DOMException in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom that throw DOMException
      Modifier and Type Method and Description
      Document DOMAccessor.getDocument(Object obj)
      Returns the Document object of the DOM.

    • Uses of DOMException in org.w3c.dom

      Methods in org.w3c.dom that throw DOMException
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      void CharacterData.appendData(String arg)
      Append the string to the end of the character data of the node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      void CharacterData.deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String Element.getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      String CharacterData.getData()
      The character data of the node that implements this interface.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      String Node.getNodeValue()
      The value of this node, depending on its type; see the table above.
      Object DOMConfiguration.getParameter(String name)
      Return the value of a parameter if known.
      String Node.getTextContent()
      This attribute returns the text content of this node and its descendants.
      boolean Element.hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      void CharacterData.insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void Element.removeAttribute(String name)
      Removes an attribute by name.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void Element.removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void CharacterData.replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      void Element.setAttribute(String name, String value)
      Adds a new attribute.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void CharacterData.setData(String data)
      The character data of the node that implements this interface.
      void ProcessingInstruction.setData(String data)
      The content of this processing instruction.
      void Element.setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      void Node.setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void DOMConfiguration.setParameter(String name, Object value)
      Set the value of a parameter.
      void Node.setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void Node.setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      void Attr.setValue(String value)
      On retrieval, the value of the attribute is returned as a string.
      void Document.setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void Document.setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
      String CharacterData.substringData(int offset, int count)
      Extracts a range of data from the node.

    • Uses of DOMException in org.w3c.dom.css

      Methods in org.w3c.dom.css that throw DOMException
      Modifier and Type Method and Description
      CSSStyleSheet DOMImplementationCSS.createCSSStyleSheet(String title, String media)
      Creates a new CSSStyleSheet.
      void CSSStyleSheet.deleteRule(int index)
      Used to delete a rule from the style sheet.
      void CSSMediaRule.deleteRule(int index)
      Used to delete a rule from the media block.
      Counter CSSPrimitiveValue.getCounterValue()
      This method is used to get the Counter value.
      float CSSPrimitiveValue.getFloatValue(short unitType)
      This method is used to get a float value in a specified unit.
      Rect CSSPrimitiveValue.getRectValue()
      This method is used to get the Rect value.
      RGBColor CSSPrimitiveValue.getRGBColorValue()
      This method is used to get the RGB color.
      String CSSPrimitiveValue.getStringValue()
      This method is used to get the string value.
      int CSSStyleSheet.insertRule(String rule, int index)
      Used to insert a new rule into the style sheet.
      int CSSMediaRule.insertRule(String rule, int index)
      Used to insert a new rule into the media block.
      String CSSStyleDeclaration.removeProperty(String propertyName)
      Used to remove a CSS property if it has been explicitly set within this declaration block.
      void CSS2Properties.setAzimuth(String azimuth)
      See the azimuth property definition in CSS2.
      void CSS2Properties.setBackground(String background)
      See the background property definition in CSS2.
      void CSS2Properties.setBackgroundAttachment(String backgroundAttachment)
      See the background-attachment property definition in CSS2.
      void CSS2Properties.setBackgroundColor(String backgroundColor)
      See the background-color property definition in CSS2.
      void CSS2Properties.setBackgroundImage(String backgroundImage)
      See the background-image property definition in CSS2.
      void CSS2Properties.setBackgroundPosition(String backgroundPosition)
      See the background-position property definition in CSS2.
      void CSS2Properties.setBackgroundRepeat(String backgroundRepeat)
      See the background-repeat property definition in CSS2.
      void CSS2Properties.setBorder(String border)
      See the border property definition in CSS2.
      void CSS2Properties.setBorderBottom(String borderBottom)
      See the border-bottom property definition in CSS2.
      void CSS2Properties.setBorderBottomColor(String borderBottomColor)
      See the border-bottom-color property definition in CSS2.
      void CSS2Properties.setBorderBottomStyle(String borderBottomStyle)
      See the border-bottom-style property definition in CSS2.
      void CSS2Properties.setBorderBottomWidth(String borderBottomWidth)
      See the border-bottom-width property definition in CSS2.
      void CSS2Properties.setBorderCollapse(String borderCollapse)
      See the border-collapse property definition in CSS2.
      void CSS2Properties.setBorderColor(String borderColor)
      See the border-color property definition in CSS2.
      void CSS2Properties.setBorderLeft(String borderLeft)
      See the border-left property definition in CSS2.
      void CSS2Properties.setBorderLeftColor(String borderLeftColor)
      See the border-left-color property definition in CSS2.
      void CSS2Properties.setBorderLeftStyle(String borderLeftStyle)
      See the border-left-style property definition in CSS2.
      void CSS2Properties.setBorderLeftWidth(String borderLeftWidth)
      See the border-left-width property definition in CSS2.
      void CSS2Properties.setBorderRight(String borderRight)
      See the border-right property definition in CSS2.
      void CSS2Properties.setBorderRightColor(String borderRightColor)
      See the border-right-color property definition in CSS2.
      void CSS2Properties.setBorderRightStyle(String borderRightStyle)
      See the border-right-style property definition in CSS2.
      void CSS2Properties.setBorderRightWidth(String borderRightWidth)
      See the border-right-width property definition in CSS2.
      void CSS2Properties.setBorderSpacing(String borderSpacing)
      See the border-spacing property definition in CSS2.
      void CSS2Properties.setBorderStyle(String borderStyle)
      See the border-style property definition in CSS2.
      void CSS2Properties.setBorderTop(String borderTop)
      See the border-top property definition in CSS2.
      void CSS2Properties.setBorderTopColor(String borderTopColor)
      See the border-top-color property definition in CSS2.
      void CSS2Properties.setBorderTopStyle(String borderTopStyle)
      See the border-top-style property definition in CSS2.
      void CSS2Properties.setBorderTopWidth(String borderTopWidth)
      See the border-top-width property definition in CSS2.
      void CSS2Properties.setBorderWidth(String borderWidth)
      See the border-width property definition in CSS2.
      void CSS2Properties.setBottom(String bottom)
      See the bottom property definition in CSS2.
      void CSS2Properties.setCaptionSide(String captionSide)
      See the caption-side property definition in CSS2.
      void CSS2Properties.setClear(String clear)
      See the clear property definition in CSS2.
      void CSS2Properties.setClip(String clip)
      See the clip property definition in CSS2.
      void CSS2Properties.setColor(String color)
      See the color property definition in CSS2.
      void CSS2Properties.setContent(String content)
      See the content property definition in CSS2.
      void CSS2Properties.setCounterIncrement(String counterIncrement)
      See the counter-increment property definition in CSS2.
      void CSS2Properties.setCounterReset(String counterReset)
      See the counter-reset property definition in CSS2.
      void CSS2Properties.setCssFloat(String cssFloat)
      See the float property definition in CSS2.
      void CSSRule.setCssText(String cssText)
      The parsable textual representation of the rule.
      void CSSValue.setCssText(String cssText)
      A string representation of the current value.
      void CSSStyleDeclaration.setCssText(String cssText)
      The parsable textual representation of the declaration block (excluding the surrounding curly braces).
      void CSS2Properties.setCue(String cue)
      See the cue property definition in CSS2.
      void CSS2Properties.setCueAfter(String cueAfter)
      See the cue-after property definition in CSS2.
      void CSS2Properties.setCueBefore(String cueBefore)
      See the cue-before property definition in CSS2.
      void CSS2Properties.setCursor(String cursor)
      See the cursor property definition in CSS2.
      void CSS2Properties.setDirection(String direction)
      See the direction property definition in CSS2.
      void CSS2Properties.setDisplay(String display)
      See the display property definition in CSS2.
      void CSS2Properties.setElevation(String elevation)
      See the elevation property definition in CSS2.
      void CSS2Properties.setEmptyCells(String emptyCells)
      See the empty-cells property definition in CSS2.
      void CSSCharsetRule.setEncoding(String encoding)
      The encoding information used in this @charset rule.
      void CSSPrimitiveValue.setFloatValue(short unitType, float floatValue)
      A method to set the float value with a specified unit.
      void CSS2Properties.setFont(String font)
      See the font property definition in CSS2.
      void CSS2Properties.setFontFamily(String fontFamily)
      See the font-family property definition in CSS2.
      void CSS2Properties.setFontSize(String fontSize)
      See the font-size property definition in CSS2.
      void CSS2Properties.setFontSizeAdjust(String fontSizeAdjust)
      See the font-size-adjust property definition in CSS2.
      void CSS2Properties.setFontStretch(String fontStretch)
      See the font-stretch property definition in CSS2.
      void CSS2Properties.setFontStyle(String fontStyle)
      See the font-style property definition in CSS2.
      void CSS2Properties.setFontVariant(String fontVariant)
      See the font-variant property definition in CSS2.
      void CSS2Properties.setFontWeight(String fontWeight)
      See the font-weight property definition in CSS2.
      void CSS2Properties.setHeight(String height)
      See the height property definition in CSS2.
      void CSS2Properties.setLeft(String left)
      See the left property definition in CSS2.
      void CSS2Properties.setLetterSpacing(String letterSpacing)
      See the letter-spacing property definition in CSS2.
      void CSS2Properties.setLineHeight(String lineHeight)
      See the line-height property definition in CSS2.
      void CSS2Properties.setListStyle(String listStyle)
      See the list-style property definition in CSS2.
      void CSS2Properties.setListStyleImage(String listStyleImage)
      See the list-style-image property definition in CSS2.
      void CSS2Properties.setListStylePosition(String listStylePosition)
      See the list-style-position property definition in CSS2.
      void CSS2Properties.setListStyleType(String listStyleType)
      See the list-style-type property definition in CSS2.
      void CSS2Properties.setMargin(String margin)
      See the margin property definition in CSS2.
      void CSS2Properties.setMarginBottom(String marginBottom)
      See the margin-bottom property definition in CSS2.
      void CSS2Properties.setMarginLeft(String marginLeft)
      See the margin-left property definition in CSS2.
      void CSS2Properties.setMarginRight(String marginRight)
      See the margin-right property definition in CSS2.
      void CSS2Properties.setMarginTop(String marginTop)
      See the margin-top property definition in CSS2.
      void CSS2Properties.setMarkerOffset(String markerOffset)
      See the marker-offset property definition in CSS2.
      void CSS2Properties.setMarks(String marks)
      See the marks property definition in CSS2.
      void CSS2Properties.setMaxHeight(String maxHeight)
      See the max-height property definition in CSS2.
      void CSS2Properties.setMaxWidth(String maxWidth)
      See the max-width property definition in CSS2.
      void CSS2Properties.setMinHeight(String minHeight)
      See the min-height property definition in CSS2.
      void CSS2Properties.setMinWidth(String minWidth)
      See the min-width property definition in CSS2.
      void CSS2Properties.setOrphans(String orphans)
      See the orphans property definition in CSS2.
      void CSS2Properties.setOutline(String outline)
      See the outline property definition in CSS2.
      void CSS2Properties.setOutlineColor(String outlineColor)
      See the outline-color property definition in CSS2.
      void CSS2Properties.setOutlineStyle(String outlineStyle)
      See the outline-style property definition in CSS2.
      void CSS2Properties.setOutlineWidth(String outlineWidth)
      See the outline-width property definition in CSS2.
      void CSS2Properties.setOverflow(String overflow)
      See the overflow property definition in CSS2.
      void CSS2Properties.setPadding(String padding)
      See the padding property definition in CSS2.
      void CSS2Properties.setPaddingBottom(String paddingBottom)
      See the padding-bottom property definition in CSS2.
      void CSS2Properties.setPaddingLeft(String paddingLeft)
      See the padding-left property definition in CSS2.
      void CSS2Properties.setPaddingRight(String paddingRight)
      See the padding-right property definition in CSS2.
      void CSS2Properties.setPaddingTop(String paddingTop)
      See the padding-top property definition in CSS2.
      void CSS2Properties.setPage(String page)
      See the page property definition in CSS2.
      void CSS2Properties.setPageBreakAfter(String pageBreakAfter)
      See the page-break-after property definition in CSS2.
      void CSS2Properties.setPageBreakBefore(String pageBreakBefore)
      See the page-break-before property definition in CSS2.
      void CSS2Properties.setPageBreakInside(String pageBreakInside)
      See the page-break-inside property definition in CSS2.
      void CSS2Properties.setPause(String pause)
      See the pause property definition in CSS2.
      void CSS2Properties.setPauseAfter(String pauseAfter)
      See the pause-after property definition in CSS2.
      void CSS2Properties.setPauseBefore(String pauseBefore)
      See the pause-before property definition in CSS2.
      void CSS2Properties.setPitch(String pitch)
      See the pitch property definition in CSS2.
      void CSS2Properties.setPitchRange(String pitchRange)
      See the pitch-range property definition in CSS2.
      void CSS2Properties.setPlayDuring(String playDuring)
      See the play-during property definition in CSS2.
      void CSS2Properties.setPosition(String position)
      See the position property definition in CSS2.
      void CSSStyleDeclaration.setProperty(String propertyName, String value, String priority)
      Used to set a property value and priority within this declaration block.
      void CSS2Properties.setQuotes(String quotes)
      See the quotes property definition in CSS2.
      void CSS2Properties.setRichness(String richness)
      See the richness property definition in CSS2.
      void CSS2Properties.setRight(String right)
      See the right property definition in CSS2.
      void CSSStyleRule.setSelectorText(String selectorText)
      The textual representation of the selector for the rule set.
      void CSSPageRule.setSelectorText(String selectorText)
      The parsable textual representation of the page selector for the rule.
      void CSS2Properties.setSize(String size)
      See the size property definition in CSS2.
      void CSS2Properties.setSpeak(String speak)
      See the speak property definition in CSS2.
      void CSS2Properties.setSpeakHeader(String speakHeader)
      See the speak-header property definition in CSS2.
      void CSS2Properties.setSpeakNumeral(String speakNumeral)
      See the speak-numeral property definition in CSS2.
      void CSS2Properties.setSpeakPunctuation(String speakPunctuation)
      See the speak-punctuation property definition in CSS2.
      void CSS2Properties.setSpeechRate(String speechRate)
      See the speech-rate property definition in CSS2.
      void CSS2Properties.setStress(String stress)
      See the stress property definition in CSS2.
      void CSSPrimitiveValue.setStringValue(short stringType, String stringValue)
      A method to set the string value with the specified unit.
      void CSS2Properties.setTableLayout(String tableLayout)
      See the table-layout property definition in CSS2.
      void CSS2Properties.setTextAlign(String textAlign)
      See the text-align property definition in CSS2.
      void CSS2Properties.setTextDecoration(String textDecoration)
      See the text-decoration property definition in CSS2.
      void CSS2Properties.setTextIndent(String textIndent)
      See the text-indent property definition in CSS2.
      void CSS2Properties.setTextShadow(String textShadow)
      See the text-shadow property definition in CSS2.
      void CSS2Properties.setTextTransform(String textTransform)
      See the text-transform property definition in CSS2.
      void CSS2Properties.setTop(String top)
      See the top property definition in CSS2.
      void CSS2Properties.setUnicodeBidi(String unicodeBidi)
      See the unicode-bidi property definition in CSS2.
      void CSS2Properties.setVerticalAlign(String verticalAlign)
      See the vertical-align property definition in CSS2.
      void CSS2Properties.setVisibility(String visibility)
      See the visibility property definition in CSS2.
      void CSS2Properties.setVoiceFamily(String voiceFamily)
      See the voice-family property definition in CSS2.
      void CSS2Properties.setVolume(String volume)
      See the volume property definition in CSS2.
      void CSS2Properties.setWhiteSpace(String whiteSpace)
      See the white-space property definition in CSS2.
      void CSS2Properties.setWidows(String widows)
      See the widows property definition in CSS2.
      void CSS2Properties.setWidth(String width)
      See the width property definition in CSS2.
      void CSS2Properties.setWordSpacing(String wordSpacing)
      See the word-spacing property definition in CSS2.
      void CSS2Properties.setZIndex(String zIndex)
      See the z-index property definition in CSS2.

    • Uses of DOMException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw DOMException
      Modifier and Type | Method and Description
      Event | DocumentEvent.createEvent(String eventType)

    • Uses of DOMException in org.w3c.dom.html

      Methods in org.w3c.dom.html that throw DOMException
      Modifier and Type Method and Description
      void HTMLSelectElement.add(HTMLElement element, HTMLElement before)
      Add a new element to the collection of OPTION elements for this SELECT .
      void HTMLTableRowElement.deleteCell(int index)
      Delete a cell from the current row.
      void HTMLTableElement.deleteRow(int index)
      Delete a table row.
      void HTMLTableSectionElement.deleteRow(int index)
      Delete a row from this section.
      HTMLElement HTMLTableRowElement.insertCell(int index)
      Insert an empty TD cell into this row.
      HTMLElement HTMLTableElement.insertRow(int index)
      Insert a new empty row in the table.
      HTMLElement HTMLTableSectionElement.insertRow(int index)
      Insert a row into this section.

    • Uses of DOMException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw DOMException
      Modifier and Type Method and Description
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.

    • Uses of DOMException in org.w3c.dom.ranges

      Methods in org.w3c.dom.ranges that throw DOMException
      Modifier and Type Method and Description
      DocumentFragment Range.cloneContents()
      Duplicates the contents of a Range
      Range Range.cloneRange()
      Produces a new Range whose boundary-points are equal to the boundary-points of the Range.
      void Range.collapse(boolean toStart)
      Collapse a Range onto one of its boundary-points
      short Range.compareBoundaryPoints(short how, Range sourceRange)
      Compare the boundary-points of two Ranges in a document.
      void Range.deleteContents()
      Removes the contents of a Range from the containing document or document fragment without returning a reference to the removed content.
      void Range.detach()
      Called to indicate that the Range is no longer in use and that the implementation may relinquish any resources associated with this Range.
      DocumentFragment Range.extractContents()
      Moves the contents of a Range from the containing document or document fragment to a new DocumentFragment.
      boolean Range.getCollapsed()
      TRUE if the Range is collapsed
      Node Range.getCommonAncestorContainer()
      The deepest common ancestor container of the Range's two boundary-points.
      Node Range.getEndContainer()
      Node within which the Range ends
      int Range.getEndOffset()
      Offset within the ending node of the Range.
      Node Range.getStartContainer()
      Node within which the Range begins
      int Range.getStartOffset()
      Offset within the starting node of the Range.
      void Range.insertNode(Node newNode)
      Inserts a node into the Document or DocumentFragment at the start of the Range.
      void Range.selectNode(Node refNode)
      Select a node and its contents
      void Range.selectNodeContents(Node refNode)
      Select the contents within a node
      void Range.setEnd(Node refNode, int offset)
      Sets the attributes describing the end of a Range.
      void Range.setEndAfter(Node refNode)
      Sets the end of a Range to be after a node
      void Range.setEndBefore(Node refNode)
      Sets the end position to be before a node.
      void Range.setStart(Node refNode, int offset)
      Sets the attributes describing the start of the Range.
      void Range.setStartAfter(Node refNode)
      Sets the start position to be after a node
      void Range.setStartBefore(Node refNode)
      Sets the start position to be before a node
      void Range.surroundContents(Node newParent)
      Reparents the contents of the Range to the given node and inserts the node at the position of the start of the Range.
      String Range.toString()
      Returns the contents of a Range as a string.

    • Uses of DOMException in org.w3c.dom.stylesheets

      Methods in org.w3c.dom.stylesheets that throw DOMException
      Modifier and Type Method and Description
      void MediaList.appendMedium(String newMedium)
      Adds the medium newMedium to the end of the list.
      void MediaList.deleteMedium(String oldMedium)
      Deletes the medium indicated by oldMedium from the list.
      void MediaList.setMediaText(String mediaText)
      The parsable textual representation of the media list.

    • Uses of DOMException in org.w3c.dom.traversal

      Methods in org.w3c.dom.traversal that throw DOMException
      Modifier and Type Method and Description
      NodeIterator DocumentTraversal.createNodeIterator(Node root, int whatToShow, NodeFilter filter, boolean entityReferenceExpansion)
      Create a new NodeIterator over the subtree rooted at the specified node.
      TreeWalker DocumentTraversal.createTreeWalker(Node root, int whatToShow, NodeFilter filter, boolean entityReferenceExpansion)
      Create a new TreeWalker over the subtree rooted at the specified node.
      Node NodeIterator.nextNode()
      Returns the next node in the set and advances the position of the NodeIterator in the set.
      Node NodeIterator.previousNode()
      Returns the previous node in the set and moves the position of the NodeIterator backwards in the set.
      void TreeWalker.setCurrentNode(Node currentNode)
      The node at which the TreeWalker is currently positioned.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMImplementation (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementation

  • Packages that use DOMImplementation
    Package Description
    com.sun.java.browser.dom
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.bootstrap
    org.w3c.dom.css
    org.w3c.dom.html

    • Uses of DOMImplementation in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMAccessor.getDOMImplementation()
      Returns a DOMImplementation object.
      abstract DOMImplementation DOMServiceProvider.getDOMImplementation()
      Returns the DOMImplemenation object of the DOM.

    • Uses of DOMImplementation in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMImplementationSource.getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementation Document.getImplementation()
      The DOMImplementation object that handles this document.
      DOMImplementation DOMImplementationList.item(int index)
      Returns the indexth item in the collection.

    • Uses of DOMImplementation in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMImplementationRegistry.getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.

    • Uses of DOMImplementation in org.w3c.dom.css

      Subinterfaces of DOMImplementation in org.w3c.dom.css
      Modifier and Type Interface and Description
      interface  DOMImplementationCSS
      This interface allows the DOM user to create a CSSStyleSheet outside the context of a document.

    • Uses of DOMImplementation in org.w3c.dom.html

      Subinterfaces of DOMImplementation in org.w3c.dom.html
      Modifier and Type Interface and Description
      interface  HTMLDOMImplementation
      The HTMLDOMImplementation interface extends the DOMImplementation interface with a method for creating an HTML document instance.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.DOMImplementationCSS (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.DOMImplementationCSS

No usage of org.w3c.dom.css.DOMImplementationCSS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMImplementationList (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementationList

  • Packages that use DOMImplementationList
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationList in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementationList
      Modifier and Type Method and Description
      DOMImplementationList DOMImplementationSource.getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • Uses of DOMImplementationList in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationList
      Modifier and Type Method and Description
      DOMImplementationList DOMImplementationRegistry.getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.ls.DOMImplementationLS (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.DOMImplementationLS

No usage of org.w3c.dom.ls.DOMImplementationLS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class org.w3c.dom.bootstrap.DOMImplementationRegistry (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.bootstrap.DOMImplementationRegistry

  • Packages that use DOMImplementationRegistry
    Package Description
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationRegistry in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationRegistry
      Modifier and Type Method and Description
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
      Obtain a new instance of a DOMImplementationRegistry.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMImplementationSource (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementationSource

  • Packages that use DOMImplementationSource
    Package Description
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationSource in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap with parameters of type DOMImplementationSource
      Modifier and Type Method and Description
      void DOMImplementationRegistry.addSource(DOMImplementationSource s)
      Register an implementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMLocator (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMLocator

  • Packages that use DOMLocator
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DOMLocator in org.w3c.dom

      Methods in org.w3c.dom that return DOMLocator
      Modifier and Type Method and Description
      DOMLocator DOMError.getLocation()
      The location of the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class com.sun.java.browser.dom.DOMService (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.java.browser.dom.DOMService

  • Packages that use DOMService
    Package Description
    com.sun.java.browser.dom

    • Uses of DOMService in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom that return DOMService
      Modifier and Type Method and Description
      static DOMService DOMService.getService(Object obj)
      Returns new instance of a DOMService.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class com.sun.java.browser.dom.DOMServiceProvider (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.java.browser.dom.DOMServiceProvider

No usage of com.sun.java.browser.dom.DOMServiceProvider
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.DOMStringList (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMStringList

  • Packages that use DOMStringList
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of DOMStringList in org.w3c.dom

      Methods in org.w3c.dom that return DOMStringList
      Modifier and Type Method and Description
      DOMStringList DOMConfiguration.getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class com.sun.java.browser.dom.DOMUnsupportedException (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.java.browser.dom.DOMUnsupportedException

  • Packages that use DOMUnsupportedException
    Package Description
    com.sun.java.browser.dom

    • Uses of DOMUnsupportedException in com.sun.java.browser.dom

      Methods in com.sun.java.browser.dom that throw DOMUnsupportedException
      Modifier and Type Method and Description
      abstract Document DOMServiceProvider.getDocument(Object obj)
      Returns the Document object of the DOM.
      static DOMService DOMService.getService(Object obj)
      Returns new instance of a DOMService.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


API for Privileged Blocks

This document provides background information about what privileged code is and what it is used for, followed by illustrations of the use of the API. It covers the following topics:

  • What It Means to Have Privileged Code
  • Using the doPrivileged API
    • No Return Value, No Exception Thrown
    • Returning Values
    • Accessing Local Variables
    • Handling Exceptions
    • Asserting a Subset of Privileges
      • Least Privilege
      • More Privilege
  • Reflection

What It Means to Have Privileged Code

The policy for a JDK installation specifies what permissions — which types of system resource accesses — are allowed for code from specified code sources. A code source (of type CodeSource) essentially consists of the code location (URL) and a reference to the certificates containing the public keys corresponding to the private keys used to sign the code (if it was signed).

The policy is represented by a Policy object. More specifically, it is represented by a Policy subclass providing an implementation of the abstract methods in the Policy class (which is in the java.security package).

The source location for the policy information used by the Policy object depends on the Policy implementation. The Policy reference implementation obtains its information from policy configuration files. See Default Policy Implementation and Policy File Syntax for information about the Policy reference implementation and the syntax that must be used in policy files it reads. For information about using the Policy Tool to create a policy file (without needing to know the required syntax), see the Policy Tool documentation (for Unix) (for Windows).

A protection domain encompasses a CodeSource instance and the permissions granted to code from that CodeSource, as determined by the security policy currently in effect. Thus, classes signed by the same keys and from the same URL are typically placed in the same domain, and a class belongs to one and only one protection domain. (However, classes signed by the same keys and from the same URL but loaded by separate class loader instances are typically placed in separate domains.) Classes that have the same permissions but are from different code sources belong to different domains.

Currently, all classes shipped with the JDK are loaded with all permissions (this may change in future releases). Most of these classes are placed in a unique system domain. In addition, the extension class loader loads code from JAR files contained in the $JAVA_HOME/jre/lib/ext directory into separate domains (because the code in these JAR files have unique URLs), but these domains are separate from the unique system domain reserved for classes shipped with the JDK.

Each applet or application runs in its appropriate domain, determined by its code source. For an applet (or an application running under a security manager) to be allowed to perform a secured action (such as reading or writing a file), the applet or application must be granted permission for that particular action.

More specifically, whenever a resource access is attempted, all code traversed by the execution thread up to that point must have permission for that resource access, unless some code on the thread has been marked as privileged. That is, suppose that access control checking occurs in a thread of execution that has a chain of multiple callers. (Think of this as multiple method calls that potentially cross the protection domain boundaries.) When the AccessController.checkPermission method is invoked by the most recent caller, the basic algorithm for deciding whether to allow or deny the requested access is as follows: If the code for any caller in the call chain does not have the requested permission, then an AccessControlException is thrown, unless the following is true: a caller whose code is granted the said permission has been marked as privileged, and all parties subsequently called by this caller (directly or indirectly) have the said permission.

Note that the method AccessController.checkPermission is normally invoked indirectly through invocations of specific SecurityManager methods that begin with the word check such as checkConnect or through the method SecurityManager.checkPermission. Normally, these checks only occur if a SecurityManager has been installed; code checked by the AccessController.checkPermission method first checks if the method System.getSecurityManager returns null.

Marking code as privileged enables a piece of trusted code to temporarily enable access to more resources than are available directly to the code that called it. This is necessary in some situations. For example, an application might not be allowed direct access to files that contain fonts, but the system utility to display a document must obtain those fonts, on behalf of the user. The system utility must become privileged in order to obtain the fonts.

Using the doPrivileged API

The use of the privileged feature is described in the following sections.

No Return Value, No Exception Thrown

If you do not need to return a value from within the privileged block, your call to doPrivileged can look like the following example, which specifies privileged code three ways: in a class that implements the interface PrivilegedAction, in an anonymous class, and in a lambda expression:

import java.security.*;

public class NoReturnNoException {

    class MyAction implements PrivilegedAction<Void> {
        public Void run() {
            // Privileged code goes here, for example:
            System.loadLibrary("awt");
            return null; // nothing to return
        }
    }

    public void somemethod() {

        MyAction mya = new MyAction();

        // Become privileged:
        AccessController.doPrivileged(mya);

        // Anonymous class
        AccessController.doPrivileged(new PrivilegedAction<Void>() {
            public Void run() {
                // Privileged code goes here, for example:
                System.loadLibrary("awt");
                return null; // nothing to return
            }
        });

        // Lambda expression
        AccessController.doPrivileged((PrivilegedAction<Void>)
            () -> {
                // Privileged code goes here, for example:
                System.loadLibrary("awt");
                return null; // nothing to return
            }
        );
    }

    public static void main(String... args) {
        NoReturnNoException myApplication = new NoReturnNoException();
        myApplication.somemethod();
    }
}

The AccessController.doPrivileged method takes an object of type java.security.PrivilegedAction and invokes its run method in privileged mode. The implementation guarantees that privileges will be revoked after the run method is executed, even if execution of doPrivileged is interrupted by an asynchronous exception. Note that the invocation of doPrivileged with a lambda expression explicitly casts the lambda expression as of type PrivilegedAction<Void>. Another version of the method doPrivileged exists that takes an object of type PrivilegedExceptionAction; see Handling Exceptions for more information about this version.

PrivilegedAction is a functional interface with a single abstract method, named run, that returns a value of type specified by its type parameter.

Note that this example ignores the return value of the run method. Also, depending on what privileged code actually consists of, you might have to make some changes due to the way inner classes work. For example, if privileged code throws an exception or attempts to access local variables, then you will have to make some changes, which is described later.

Be very careful in your use of the privileged construct, and always remember to make the privileged code section as small as possible. That is, try to limit the code within the run method to only what needs to be run with privileges, and do more general things outside the run method. Also note that the call to doPrivileged should be made in the code that wants to enable its privileges. Do not be tempted to write a utility class that itself calls doPrivileged as that could lead to security holes. You can write utility classes for PrivilegedAction classes though, as shown in the preceding example. See Guideline 9-3: Safely invoke java.security.AccessController.doPrivileged in Secure Coding Guidelines for the Java Programming Language for more information.

Returning Values

If you need to return a value, then you can do something like the following:

System.out.println(
    AccessController.doPrivileged((PrivilegedAction<String>)
        () -> System.getProperty("user.name")
    )
);

Accessing Local Variables

If you are using a lambda expression or anonymous inner class, then any local variables you access must be final or effectively final. For example:

String lib = "awt";
AccessController.doPrivileged((PrivilegedAction<Void>)
    () -> {
        System.loadLibrary(lib);
        return null; // nothing to return
    }
);

AccessController.doPrivileged(new PrivilegedAction<Void>() {
    public Object run() {
        System.loadLibrary(lib);
        return null; // nothing to return
    }
});

The variable lib is effectively final because its value has not been modified. For example, suppose you add the following assignment statement after the declaration of the variable lib:

lib = "swing";

The compiler generates the following errors when it encounters the invocation System.loadLibrary both in the lambda expression and the anonymous class:

  • error: local variables referenced from a lambda expression must be final or effectively final
  • error: local variables referenced from an inner class must be final or effectively final

See Accessing Members of an Enclosing Class in Local Classes for more information.

If there are cases where you cannot make an existing variable effectively final (because it gets set multiple times), then you can create a new final variable right before invoking the doPrivileged method, and set that variable equal to the other variable. For example:

String lib;

// The lib variable gets set multiple times so you can't make it
// effectively final.

// Create a final String that you can use inside of the run method
final String fLib = lib;

AccessController.doPrivileged((PrivilegedAction<Void>)
    () -> {
        System.loadLibrary(fLib);
        return null; // nothing to return
    }
);

Handling Exceptions

If the action performed in your run method could throw a checked exception (one that must be listed in the throws clause of a method), then you need to use the PrivilegedExceptionAction interface instead of the PrivilegedAction interface:

public void processSomefile() throws IOException {

    try {
        Path path = FileSystems.getDefault().getPath("somefile");
        BufferedReader br = AccessController.doPrivileged(
            (PrivilegedExceptionAction<BufferedReader>)
                () -> Files.newBufferedReader(path)
        );
        // ... read from file and do something
    } catch (PrivilegedActionException e) {

        // e.getException() should be an instance of IOException
        // as only checked exceptions will be wrapped in a
        // PrivilegedActionException.
        throw (IOException) e.getException();
    }
}

If a checked exception is thrown during execution of the run method, then it is placed in a PrivilegedActionException wrapper exception that is then thrown and should be caught by your code, as illustrated in this example.

Asserting a Subset of Privileges

As of JDK 8, a variant of AccessController.doPrivileged is available that enables code to assert a subset of its privileges, without preventing the full traversal of the stack to check for other permissions. This variant of the doPrivileged variant has three parameters, one of which you use to specify this subset of privileges. For example, the following excerpt asserts a privilege to retrieve system properties:

// Returns the value of the specified property. All code
// is allowed to read the app.version and app.vendor
// properties.

public String getProperty(final String prop) {
    return AccessController.doPrivileged(
        (PrivilegedAction<String>) () -> System.getProperty(prop),
        null,
        new java.util.PropertyPermission("app.version", "read"),
        new java.util.PropertyPermission("app.vendor", "read")
    );
}

The first parameter of this version of doPrivileged is of type java.security.PrivilegedAction. In this example, the first parameter is a lambda expression that implements the functional interface PrivilegedAction whose run method returns the value of the system property specified by the parameter prop.

The second parameter of this version of doPrivileged is of type AccessControlContext. Sometimes you need to perform an additional security check within a different context, such as a worker thread. You can obtain an AccessControlContext instance from a particular calling context with the method AccessControlContext.getContext. If you specify null for this parameter (as in this example), then the invocation of doPrivileged does not perform any additional security checks.

The third parameter of this version of doPrivileged is of type Permission..., which is a varargs parameter. This means that you can specify one or more Permission parameters or an array of Permission objects, as in Permission[]. In this example, the invocation of doPrivileged can retrieve the properties app.version and app.vendor.

You can use this three parameter variant of doPrivileged in a mode of least privilege or a mode of more privilege.

Least Privilege

The typical use case of the doPrivileged method is to enable the method that invokes it to perform one or more actions that require permission checks without requiring the callers of the current method to have all the necessary permissions. For example, the current method might need to open a file or make a network request for its own internal implementation purposes.

Before JDK 8, calls to doPrivileged methods had only two parameters. They worked by granting temporary privileges to the calling method and stopping the normal full traversal of the stack for access checking when it reached that class, rather than continuing up the call stack where it might reach a method whose defining class does not have the required permission. Typically, the class that is calling doPrivileged might have additional permissions that are not required in that code path and which might also be missing from some caller classes.

Normally, these extra permissions are not exercised at runtime. Not elevating them through use of doPrivileged helps to block exploitation of any incorrect code that could perform unintended actions. This is especially true when the PrivilegedAction is more complex than usual, or when it calls code outside the class or package boundary that might evolve independently over time.

The three-parameter variant of doPrivileged is generally safer to use because it avoids unnecessarily elevating permissions that are not intended to be required. However, it executes less efficiently so simple or performance-critical code paths might choose not to use it.

More Privilege

Sometimes when coding the current method, you want to temporarily extend the permission of the calling method to perform an action. For example, a framework I/O API might have a general purpose method for opening files of a particular data format. This API would take a normal file path parameter and use it to open an underlying FileInputStream using the calling code's permissions. However, this might also allow any caller to open the data files in a special directory that contains some standard demonstration samples.

The callers of this API could be directly granted a FilePermission for read access. However, it might not be convenient or possible for the security policy of the calling code to be updated. For example, the calling code could be a sandboxed applet.

One way to implement this is for the code to check the incoming path and determine if it refers to a file in the special directory. If it does, then it would call doPrivileged, enabling all permissions, then open the file inside the PrivilegedAction. If the file was not in the special directory, the code would open the file without using doPrivileged.

This technique requires the implementation to carefully handle the requested file path to determine if it refers to the special shared directory. The file path must be canonicalized before calling doPrivileged so that any relative path will be processed (and permission to read the user.dir system property will be checked) prior to determining if the path refers to a file in the special directory. It must also prevent malicious "../" path elements meant to escape out of the special directory.

A simpler and better implementation would use the variant of doPrivileged with the third parameter. It would pass a FilePermission with read access to the special directory as the third parameter. Then any manipulation of the file would be inside the PrivilegedAction. This implementation is simpler and much less prone to contain a security flaw.

Reflection

One subtlety that must be considered is the interaction of this API with reflection. The doPrivileged method can be invoked reflectively using java.lang.reflect.Method.invoke. In this case, the privileges granted in privileged mode are not those of Method.invoke but of the non-reflective code that invoked it. Otherwise, system privileges could erroneously (or maliciously) be conferred on user code. Note that similar requirements exist when using reflection in the existing API.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.DoubleType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.DoubleType

No usage of com.sun.jdi.DoubleType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.DoubleValue (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.DoubleValue

  • Packages that use DoubleValue
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of DoubleValue in com.sun.jdi

      Methods in com.sun.jdi that return DoubleValue
      Modifier and Type Method and Description
      DoubleValue VirtualMachine.mirrorOf(double value)
      Creates a DoubleValue for the given value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.DoWhileLoopTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.DoWhileLoopTree

  • Packages that use DoWhileLoopTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of DoWhileLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type DoWhileLoopTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitDoWhileLoop(DoWhileLoopTree node, P p)

    • Uses of DoWhileLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type DoWhileLoopTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitDoWhileLoop(DoWhileLoopTree node, P p)
      R | TreeScanner.visitDoWhileLoop(DoWhileLoopTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


DownloadService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface DownloadService

  • public interface DownloadService
    DownloadService service allows an application to control how its own resources are cached, to determine which of its resources are currently cached, to force resources to be cached, and to remove resources from the cache. The JNLP Client is responsible for providing a specific implementation of this service.
    Since:
    1.4.2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DownloadServiceListener getDefaultProgressWindow()
      Return a default DownloadServiceListener implementation which, when passed to a load method, should pop up and update a progress window as the load progresses.
      boolean isExtensionPartCached(java.net.URL ref, java.lang.String version, java.lang.String part)
      Returns true if the given part of the given extension is cached, and the extension and part are mentioned in the JNLP file for the application.
      boolean isExtensionPartCached(java.net.URL ref, java.lang.String version, java.lang.String[] parts)
      Returns true if the given parts of the given extension are cached, and the extension and parts are mentioned in the JNLP file for the application.
      boolean isPartCached(java.lang.String part)
      Returns true if the part referred to by the given string is cached, and that part is mentioned in the JNLP file for the application.
      boolean isPartCached(java.lang.String[] parts)
      Returns true if the parts referred to by the given array are cached, and those parts are mentioned in the JNLP file for the application.
      boolean isResourceCached(java.net.URL ref, java.lang.String version)
      Returns true if the resource referred to by the given URL and version is cached, and that resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or the calling application has been granted all-permissions.
      void loadExtensionPart(java.net.URL ref, java.lang.String version, java.lang.String[] parts, DownloadServiceListener progress)
      Downloads the given parts of the given extension, if the parts and the extension are mentioned in the JNLP file for the application.
      void loadExtensionPart(java.net.URL ref, java.lang.String version, java.lang.String part, DownloadServiceListener progress)
      Downloads the given part of the given extension, if the part and the extension are mentioned in the JNLP file for the application.
      void loadPart(java.lang.String[] parts, DownloadServiceListener progress)
      Downloads the given parts, if the parts are mentioned in the JNLP file for the application.
      void loadPart(java.lang.String part, DownloadServiceListener progress)
      Downloads the given part, if the part is mentioned in the JNLP file for the application.
      void loadResource(java.net.URL ref, java.lang.String version, DownloadServiceListener progress)
      Downloads the given resource, if the resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or if the calling application has been granted all-permissions.
      void removeExtensionPart(java.net.URL ref, java.lang.String version, java.lang.String part)
      Removes the given part of the given extension from the cache, if the part and the extension are mentioned in the JNLP file for the application.
      void removeExtensionPart(java.net.URL ref, java.lang.String version, java.lang.String[] parts)
      Removes the given parts of the given extension from the cache, if the parts and the extension are mentioned in the JNLP file for the application.
      void removePart(java.lang.String part)
      Removes the given part from the cache, if the part is mentioned in the JNLP file for the application.
      void removePart(java.lang.String[] parts)
      Removes the given parts from the cache, if the parts are mentioned in the JNLP file for the application.
      void removeResource(java.net.URL ref, java.lang.String version)
      Removes the given resource from the cache, if the resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or if the calling application has been granted all-permissions.

    • Method Detail

      • isResourceCached

        boolean isResourceCached(java.net.URL ref,
                         java.lang.String version)
        Returns true if the resource referred to by the given URL and version is cached, and that resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or the calling application has been granted all-permissions. .
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        Returns:
        true if the above conditions are met, and false otherwise.

      • isPartCached

        boolean isPartCached(java.lang.String part)
        Returns true if the part referred to by the given string is cached, and that part is mentioned in the JNLP file for the application.
        Parameters:
        part - The name of the part.
        Returns:
        true if the above conditions are met, and false otherwise.

      • isPartCached

        boolean isPartCached(java.lang.String[] parts)
        Returns true if the parts referred to by the given array are cached, and those parts are mentioned in the JNLP file for the application.
        Parameters:
        parts - An array of part names.
        Returns:
        true if the above conditions are met, and false otherwise.

      • isExtensionPartCached

        boolean isExtensionPartCached(java.net.URL ref,
                              java.lang.String version,
                              java.lang.String part)
        Returns true if the given part of the given extension is cached, and the extension and part are mentioned in the JNLP file for the application.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        part - The name of the part.
        Returns:
        true if the above conditions are met, and false otherwise.

      • isExtensionPartCached

        boolean isExtensionPartCached(java.net.URL ref,
                              java.lang.String version,
                              java.lang.String[] parts)
        Returns true if the given parts of the given extension are cached, and the extension and parts are mentioned in the JNLP file for the application.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        parts - An array of part names.
        Returns:
        true if the above conditions are met, and false otherwise.

      • loadResource

        void loadResource(java.net.URL ref,
                  java.lang.String version,
                  DownloadServiceListener progress)
           throws java.io.IOException
        Downloads the given resource, if the resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or if the calling application has been granted all-permissions. This method will block until the download is completed or an exception occurs.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        progress - Download progress callback object.
        Throws:
        java.io.IOException

      • loadPart

        void loadPart(java.lang.String part,
              DownloadServiceListener progress)
       throws java.io.IOException
        Downloads the given part, if the part is mentioned in the JNLP file for the application. This method will block until the download is completed or an exception occurs.
        Parameters:
        part - The name of the part.
        progress - Download progress callback object.
        Throws:
        java.io.IOException

      • loadPart

        void loadPart(java.lang.String[] parts,
              DownloadServiceListener progress)
       throws java.io.IOException
        Downloads the given parts, if the parts are mentioned in the JNLP file for the application. This method will block until the download is completed or an exception occurs.
        Parameters:
        parts - An array of part names.
        progress - Download progress callback object.
        Throws:
        java.io.IOException

      • loadExtensionPart

        void loadExtensionPart(java.net.URL ref,
                       java.lang.String version,
                       java.lang.String part,
                       DownloadServiceListener progress)
                throws java.io.IOException
        Downloads the given part of the given extension, if the part and the extension are mentioned in the JNLP file for the application. This method will block until the download is completed or an exception occurs.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        part - The name of the part.
        progress - Download progress callback object.
        Throws:
        java.io.IOException

      • loadExtensionPart

        void loadExtensionPart(java.net.URL ref,
                       java.lang.String version,
                       java.lang.String[] parts,
                       DownloadServiceListener progress)
                throws java.io.IOException
        Downloads the given parts of the given extension, if the parts and the extension are mentioned in the JNLP file for the application. This method will block until the download is completed or an exception occurs.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        parts - An array of part names to load.
        progress - Download progress callback object.
        Throws:
        java.io.IOException

      • removeResource

        void removeResource(java.net.URL ref,
                    java.lang.String version)
             throws java.io.IOException
        Removes the given resource from the cache, if the resource is either mentioned in the calling applications JNLP file, is within the codebase of the calling applications JNLP file, or if the calling application has been granted all-permissions.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        Throws:
        java.io.IOException

      • removePart

        void removePart(java.lang.String part)
         throws java.io.IOException
        Removes the given part from the cache, if the part is mentioned in the JNLP file for the application.
        Parameters:
        part - The name of the part.
        Throws:
        java.io.IOException

      • removePart

        void removePart(java.lang.String[] parts)
         throws java.io.IOException
        Removes the given parts from the cache, if the parts are mentioned in the JNLP file for the application.
        Parameters:
        parts - An array of part names.
        Throws:
        java.io.IOException

      • removeExtensionPart

        void removeExtensionPart(java.net.URL ref,
                         java.lang.String version,
                         java.lang.String part)
                  throws java.io.IOException
        Removes the given part of the given extension from the cache, if the part and the extension are mentioned in the JNLP file for the application.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        part - The name of the part.
        Throws:
        java.io.IOException

      • removeExtensionPart

        void removeExtensionPart(java.net.URL ref,
                         java.lang.String version,
                         java.lang.String[] parts)
                  throws java.io.IOException
        Removes the given parts of the given extension from the cache, if the parts and the extension are mentioned in the JNLP file for the application.
        Parameters:
        ref - The URL for the resource.
        version - The version string, or null for no version.
        parts - An array of part names.
        Throws:
        java.io.IOException

      • getDefaultProgressWindow

        DownloadServiceListener getDefaultProgressWindow()
        Return a default DownloadServiceListener implementation which, when passed to a load method, should pop up and update a progress window as the load progresses.
        Returns:
        A DownloadServiceListener object representing a download progress listener.
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


DownloadService2 (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface DownloadService2

  • public interface DownloadService2
    Provides cache query services to JNLP applications. Together with methods in DownloadService, this allows for advanced programmatic cache management.
    Since:
    6.0.18

    • Nested Class Summary

      Nested Classes
      Modifier and Type Interface and Description
      static class  DownloadService2.ResourceSpec
      Specifies patterns for resource queries as arguments and holds results in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int ALL
      Matches all resources in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
      static int APPLET
      Matches applets in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
      static int APPLICATION
      Matches applications in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
      static int CLASS
      Matches class files in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
      static int EXTENSION
      Matches extensions in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
      static int IMAGE
      Matches image files in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
      static int JAR
      Matches JARs in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DownloadService2.ResourceSpec[] getCachedResources(DownloadService2.ResourceSpec spec)
      Returns all resources in the cache that match one of the specified resource specs.
      DownloadService2.ResourceSpec[] getUpdateAvailableResources(DownloadService2.ResourceSpec spec)
      Returns all resources in the cache that match one of the specified resource specs AND have an update available from their server.

    • Field Detail

      • ALL

        static final int ALL
        Matches all resources in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

      • APPLICATION

        static final int APPLICATION
        Matches applications in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

      • APPLET

        static final int APPLET
        Matches applets in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

      • EXTENSION

        static final int EXTENSION
        Matches extensions in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

      • JAR

        static final int JAR
        Matches JARs in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

      • IMAGE

        static final int IMAGE
        Matches image files in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

      • CLASS

        static final int CLASS
        Matches class files in getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        See Also:
        Constant Field Values

    • Method Detail

      • getCachedResources

        DownloadService2.ResourceSpec[] getCachedResources(DownloadService2.ResourceSpec spec)
        Returns all resources in the cache that match one of the specified resource specs.
        For supported patterns in the query arguments, see DownloadService2.ResourceSpec. The returned ResourceSpec objects have specific URL and version properties (i.e. no patterns).
        Parameters:
        spec - the spec to match resources against
        Returns:
        all resources that match one of the specs
        Throws:
        java.lang.IllegalArgumentException -
        if the ResourceSpec is null, or
        if the ResourceSpec contains a null or empty URL string, or
        if the ResourceSpec contains invalid regular expressions.
        if the ResourceSpec contains a type that is not one of:
        ALL, APPLICATION, APPLET, EXTENSION, JAR, IMAGE, or CLASS.

      • getUpdateAvailableResources

        DownloadService2.ResourceSpec[] getUpdateAvailableResources(DownloadService2.ResourceSpec spec)
                                                     throws java.io.IOException
        Returns all resources in the cache that match one of the specified resource specs AND have an update available from their server.
        For supported patterns in the query arguments, see DownloadService2.ResourceSpec. The returned ResourceSpec objects have specific URL and version properties (i.e. no patterns).
        NOTE: This call may attempt HTTP GET request to check for update.
        Parameters:
        spec - the spec to match resources against
        Returns:
        all resources for which an update is available that match one of the specs
        Throws:
        java.io.IOException - if something went wrong during update checks
        java.lang.IllegalArgumentException -
        if the ResourceSpec is null, or
        if the ResourceSpec contains a null or empty URL string, or
        if the ResourceSpec contains invalid regular expressions.
        if the ResourceSpec contains a type that is not one of:
        ALL, APPLICATION, APPLET, EXTENSION, JAR, IMAGE, or CLASS.
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


DownloadService2.ResourceSpec (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Class DownloadService2.ResourceSpec

  • java.lang.Object
    • javax.jnlp.DownloadService2.ResourceSpec
  • Enclosing interface:
    DownloadService2

    public static class DownloadService2.ResourceSpec
extends java.lang.Object
    Specifies patterns for resource queries as arguments and holds results in DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) and DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
    For the url and version properties, standard regular expressions as documented in {code java.util.regex} are supported.

    • Constructor Summary

      Constructors
      Constructor and Description
      ResourceSpec(java.lang.String url, java.lang.String version, int type)
      Creates a new ResourceSpec instance.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      long getExpirationDate()
      Returns the time of expiration of the resource.
      long getLastModified()
      Returns the time of last modification of the resource.
      long getSize()
      Returns the size of a resource.
      int getType()
      Returns the type of this resource.
      java.lang.String getUrl()
      Returns the URL of this resource.
      java.lang.String getVersion()
      Returns the version of this resource.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ResourceSpec

        public ResourceSpec(java.lang.String url,
                    java.lang.String version,
                    int type)
        Creates a new ResourceSpec instance.
        Parameters:
        url - the URL pattern
        version - the version pattern
        type - the resource type. This should be one of the following constants defined in DownloadService2: ALL, APPLICATION, APPLET, EXTENSION, JAR, IMAGE, or CLASS.

    • Method Detail

      • getUrl

        public java.lang.String getUrl()
        Returns the URL of this resource.
        Returns:
        the URL of this resource

      • getVersion

        public java.lang.String getVersion()
        Returns the version of this resource.
        Returns:
        the version of this resource

      • getType

        public int getType()
        Returns the type of this resource.
        Returns:
        the type of this resource

      • getSize

        public long getSize()
        Returns the size of a resource. This is only useful for ResourceSpecs that have been returned as a result of DownloadService2.getCachedResources(javax.jnlp.DownloadService2.ResourceSpec) or DownloadService2.getUpdateAvailableResources(javax.jnlp.DownloadService2.ResourceSpec).
        Returns:
        the size of a resource

      • getLastModified

        public long getLastModified()
        Returns the time of last modification of the resource.
        The returned value has the same semantics as the return value of System.currentTimeMillis().
        A value of 0 means unknown.
        Returns:
        the time of last modification of the resource

      • getExpirationDate

        public long getExpirationDate()
        Returns the time of expiration of the resource.
        The returned value has the same semantics as the return value of System.currentTimeMillis().
        A value of 0 means unknown.
        Returns:
        the time of expiration of the resource
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


DownloadServiceListener (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface DownloadServiceListener

  • public interface DownloadServiceListener
    The DownloadServiceListener provides an interface for a callback object implementation, which may be used by a DownloadService implementation. The DownloadServiceListener implementation's methods should be invoked by the DownloadService implementation at various stages of the download, allowing an application that uses the JNLP API to display a progress bar during a DownloadService download.
    Since:
    1.4.2
    See Also:
    DownloadService

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void downloadFailed(java.net.URL url, java.lang.String version)
      A JNLP client's DownloadService implementation should call this method if a download fails or aborts unexpectedly.
      void progress(java.net.URL url, java.lang.String version, long readSoFar, long total, int overallPercent)
      A JNLP client's DownloadService implementation should call this method several times during a download.
      void upgradingArchive(java.net.URL url, java.lang.String version, int patchPercent, int overallPercent)
      A JNLP client's DownloadService implementation should call this method at least several times when applying an incremental update to an in-cache resource.
      void validating(java.net.URL url, java.lang.String version, long entry, long total, int overallPercent)
      A JNLP client's DownloadService implementation should call this method at least several times during validation of a download.

    • Method Detail

      • progress

        void progress(java.net.URL url,
              java.lang.String version,
              long readSoFar,
              long total,
              int overallPercent)
        A JNLP client's DownloadService implementation should call this method several times during a download. A DownloadServiceListener implementation may display a progress bar and / or update information based on the parameters.
        Parameters:
        url - The URL representing the resource being downloaded.
        version - The version of the resource being downloaded.
        readSoFar - The number of bytes downloaded so far.
        total - The total number of bytes to be downloaded, or -1 if the number is unknown.
        overallPercent - The percentage of the overall update operation that is complete, or -1 if the percentage is unknown.

      • validating

        void validating(java.net.URL url,
                java.lang.String version,
                long entry,
                long total,
                int overallPercent)
        A JNLP client's DownloadService implementation should call this method at least several times during validation of a download. Validation often includes ensuring that downloaded resources are authentic (appropriately signed). A DownloadServiceListener implementation may display a progress bar and / or update information based on the parameters.
        Parameters:
        url - The URL representing the resource being validated.
        version - The version of the resource being validated.
        entry - The number of JAR entries validated so far.
        total - The total number of entries to be validated.
        overallPercent - The percentage of the overall update operation that is complete, or -1 if the percentage is unknown.

      • upgradingArchive

        void upgradingArchive(java.net.URL url,
                      java.lang.String version,
                      int patchPercent,
                      int overallPercent)
        A JNLP client's DownloadService implementation should call this method at least several times when applying an incremental update to an in-cache resource. A DownloadServiceListener implementation may display a progress bar and / or update information based on the parameters.
        Parameters:
        url - The URL representing the resource being patched.
        version - The version of the resource being patched.
        patchPercent - The percentage of the patch operation that is complete, or -1 if the percentage is unknown.
        overallPercent - The percentage of the overall update operation that is complete, or -1 if the percentage is unknown.

      • downloadFailed

        void downloadFailed(java.net.URL url,
                    java.lang.String version)
        A JNLP client's DownloadService implementation should call this method if a download fails or aborts unexpectedly. In response, a DownloadServiceListener implementation may display update information to the user to reflect this.
        Parameters:
        url - The URL representing the resource for which the download failed.
        version - The version of the resource for which the download failed.
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


JnlpDownloadServlet Guide

Table of Contents

Introduction
Using JnlpDownloadServlet
Substitutions
Version, Extension, and Platform Requests
Incremental Updates with JARDiff
Faster Downloads with Pack200
Other Features
Building JnlpDownloadServlet
Reference

Introduction

JnlpDownloadServlet is a servlet that simplifies the process of deploying Java Web Start applications on a web server as well as providing enhanced functionality. JnlpDownloadServlet is available in the sample/jnlp/servlet directory of the JDK, both as compiled JAR files and as source code.

In the simplest case of JNLP deployment, you put your application files and a JNLP file on a web server. After you configure the web server for the JNLP MIME type, you have basic JNLP functionality — the user clicks on a JNLP file link in a browser and your application is downloaded and run.

However, this approach has some drawbacks. First, the explicit URL of the application codebase must appear in the JNLP file. This means it must be changed if you decide to host your application elsewhere, or if you're moving from a local test server to a more public production server. In addition, the file system time stamp on your application files will be used to report the time stamp of your application, which might not be what you want. Finally, only the most basic parts of the JNLP protocol are implemented through HTTP. Versioning and other features are not supported.

Features

JnlpDownloadServlet acts as a liaison between your application files and the client. It provides the following features:

  • You do not have to hardcode codebase URLs in the JNLP file. This simplifies moving from one server to another.
  • You can specify an explicit time stamp for your application files, instead of relying on file system time stamps.
  • The servlet supports the full set of download protocols defined by the JNLP specification.
  • Version information can be specified per file or per directory.
  • The servlet generates JARDiff files.
  • The servlet supports Pack200 compression for application files.

Baseline Example

To understand the useful features that JnlpDownloadServlet brings to application deployment, you must first understand the simplest way an application can be distributed using JNLP and Java Web Start.

The app1 example (in the sample/jnlp/servlet directory of the JDK) contains a simple application and, perhaps more valuable, an Ant build script that builds the application and bundles it in a WAR file for distribution on a web server.

The application itself consists of a single class, Pie, and an image file, key-lime.jpg, which are packaged into the pie.jar JAR file.

The pie.jar archive is packaged into a web application file, app1.war, which has these contents:

WEB-INF/web.xml
index.html
pie.jnlp
pie.jar

The JNLP file describes the application, assuming it is deployed on a server at http://localhost:8080/, which works for a locally installed Tomcat server.

<?xml version="1.0" encoding="UTF-8"?>
<jnlp spec="1.0+" codebase="http://localhost:8080/app1">
    <information>
        <title>Pie</title>
        <vendor>Example Vendor</vendor>
    </information>
    <resources>
        <j2se version="1.2+"/>
        <jar href="pie.jar" main="true" />
    </resources>
    <application-desc/>
</jnlp>

Consider the interaction between client and server as a dialog:

[User clicks a link in the browser.]

Client browser: May I please have pie.jnlp?

Server: Yes, here you go.

Client browser: I notice the MIME type is application/x-java-jnlp-file. Java Web Start, would you please handle pie.jnlp for me?

Client Java Web Start: Let me see what resources are required for this application. Hey Server, can I please have pie.jar?

Server: Here you go.

Client Java Web Start: Now I'll launch the JAR file using its Main-class manifest attribute.

[Application appears on the user's screen.]

Other Examples

The app2 example shows how to bundle JnlpDownloadServlet with an application and how to use it to perform simple substitutions in a JNLP file.

The app3 example shows how a versioned resource request is handled by JnlpDownloadServlet.

Both app2 and app3 will be referenced from the following sections.

Using JnlpDownloadServlet

To take advantage of JnlpDownloadServlet, perform these steps.

  1. Package JnlpDownloadServlet in your web application WAR file. You must use two JAR files to have the full functionality, jnlp-servlet.jar and jardiff.jar. These two JAR files are put in the WEB-INF/lib directory of your WAR file.
  2. Map requests for *.jnlp and *.jar to JnlpDownloadServlet using your web application's web.xml file. It must contain lines that identify JnlpDownloadServlet and makes it the handler for JNLP and JAR files. Here is a complete example:
    <?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    "http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>

  <servlet>
    <servlet-name>JnlpDownloadServlet</servlet-name>
    <servlet-class>jnlp.sample.servlet.JnlpDownloadServlet</servlet-class>
  </servlet>

  <servlet-mapping>
    <servlet-name>JnlpDownloadServlet</servlet-name>
    <url-pattern>*.jnlp</url-pattern>
  </servlet-mapping>

  <servlet-mapping>
    <servlet-name>JnlpDownloadServlet</servlet-name>
    <url-pattern>*.jar</url-pattern>
  </servlet-mapping>

</web-app>

The app2 and app3 examples show how to package JnlpDownloadServlet in a web application. Review the Ant build script app2/build.xml or app3/build.xml for more information.

Substitutions

JnlpDownloadServlet makes convenient substitutions in your JNLP files. When the client requests a JNLP file, the servlet reads the original file, substitutes values, and returns the results.

Time Stamp

If the first line of your JNLP file contains a time stamp, JnlpDownloadServlet uses the value as a time stamp for your application. If you do not specify a time stamp, JnlpDownloadServlet uses the last modified time stamp from the file system.

Using an explicit time stamp is useful if you copy a JNLP file to multiple servers for load balancing. The explicit time stamp ensures that clients see consistent results, regardless of which server they consult.

To use an explicit time stamp, add a line to the top of your JNLP file. Begin the line with TS:. The rest of the line must contain a time stamp in ISO 8601 format, which has this basic format:

YYYY-MM-DD hh:mm:ss

Here is one example:

TS: 2010-08-07 21:19:05

Consult the Reference section for a more complete description of the time stamp string.

Codebase and Other Values

JnlpDownloadServlet makes substitutions for strings that begin with two dollar signs. For example, consider this line in a JNLP file:

<jnlp spec="1.0+" codebase="$$codebase">

When a client requests the JNLP file, JnlpDownloadServlet substitutes the correct value for $$codebase, wherever it is deployed. This is convenient because you do not have to hardcode this value in the JNLP file, making it easier to move from server to server.

The full list of substitutions is shown in the following table:

Name | Substituted value
$$codebase | The URL of the request except for the name of the JNLP file
$$name | The name of the JNLP file
$$context | The base URL of the web application
$$site | The web server address
$$hostname | The name of the server

For example, suppose the app2 example is deployed at example.com. The values of each substitution would be as follows:

Name | Substituted value
$$codebase | http://example.com/app2/
$$name | pie.jnlp
$$context | http://example.com/app2
$$site | http://example.com
$$hostname | example.com

The app2/pie.jnlp and app3/pie.jnlp examples use only $$codebase.

Version, Extension, and Platform Requests

The JNLP specification supports requesting application resources with explicit version numbers or resources for certain locales, operating systems, and system architectures. This means that you can deploy an application that has different libraries for different operating systems or different resource files for different locales.

JnlpDownloadServlet provides support for special requests with two different mechanisms. The first is a scheme for naming resource files where locales, operating systems, and other parameters are embedded in the file name. The second mechanism involves an XML file that describes the parameters of resource files in the same directory.

File Naming Convention

JnlpDownloadServlet enables you to specify information about files by embedding it in a file name. If the file name contains two underscores in a row, the file name is treated as containing attributes. A prefix letter specifies the attribute information, as shown here:

Prefix | Meaning
V | Version number
O | Operating system
A | Architecture
L | Locale

Only one version is allowed per file, but a file can be associated with multiple operating system, architecture, or locale attributes. For example, application__V1.2__Len_US__Len.jar means that the resource application.jar has a version of 1.2, and associated locales of en_US and en.

For example, consider a JNLP file that contains this resource line:

<jar href="app-lib.jar" version="2.0" />

When Java Web Start encounters this line in the JNLP file, it sends a request to the server for version 2.0 of app-lib.jar. If you have placed a file app-lib__V2.0.jar in your web application, JnlpDownloadServlet returns it to the client as version 2.0 of app-lib.jar. Note how the actual file name in your web application gets remapped to be visible to the client as app-lib.jar.

XML Version File

The file naming convention can be cumbersome, especially if you have multiple resource files that each have multiple associations for operating systems, architectures, or locales.

JnlpDownloadServlet supports an alternate mechanism, where all attributes are described in a separate XML file. The servlet looks for a version.xml file in the same directory as the resource. The version.xml file contains information about the other files in the same directory.

For example, the following version.xml file describes a resource that is available to a client as application.jar. The actual file is stored in the same directory as application-1_2-us.jar.

<jnlp-versions>
  <resource>
    <pattern>
      <name>application.jar</name>
      <version-id>1.2</version-id>
      <locale>en_US</locale>
      <locale>en</locale>
    </pattern>
    <file>application-1_2-us.jar</file>
  </resource>
</jnlp-versions>

The app3 example shows how to respond to a versioned request for a resource using the XML version file. In particular, the JNLP file contains this resource line:

<jar href="app-lib.jar" version="2.0" />

The WAR file contains the library, app-lib.jar, and this XML version file version.xml that describes the library:

<jnlp-versions>
  <resource>
    <pattern>
      <name>app-lib.jar</name>
      <version-id>2.0</version-id>
    </pattern>
    <file>app-lib-2.0.jar</file>
  </resource>
</jnlp-versions>

Note how the actual name of the file, app-lib-2.0.jar, is remapped so that the file name visible from the client is app-lib.jar.

Incremental Updates with JARDiff

JnlpDownloadServlet generates and returns incremental updates to JAR files, if possible. If the current-version-id parameter is included in the request, and the servlet can find both a match on the current-version-id and the requested version, and the request is for a JAR file, then a JARDiff file is generated by the servlet. The JARDiff file is returned if its size is less than that of the requested version.

The JARDiff file is generated and stored in a temporary directory that is specific to the web container. The servlet finds the temporary working directory using the javax.servlet.context.tempdir context attribute.

Faster Downloads with Pack200

Pack200 is an efficient compression technology for JAR files. Download and installation times for applications are important factors in how users perceive applications. Making your application resources as small as possible reduces the amount of time users must wait for your application to download.

JnlpDownloadServlet can supply resources for clients, such as Java Web Start, that support GZIP and Pack200 downloads. Place *.jar.pack.gz or *.jar.gz files together with your original *.jar files on the server. For example, JnlpDownloadServlet chooses the best of the following files, based upon what the client supports:

pie.jar
pie.jar.gz
pie.jar.pack.gz

You can create Pack200 files using the pack200 tool that is included with the Java Development Kit. The app3 example creates a Pack200 version of the pie.jar file. Look at build.xml to see how the Pack200 file is created. Because pie.jar is simple, the Pack200 file is negligibly smaller; however, for a larger JAR file, the compression is much greater.

Other Features

JNLP substitutions, Pack200 support, and file attribute support are the most useful features of JnlpDownloadServlet. The servlet also supports a logging system and MIME type mapping.

Logging

The servlet has logging capabilities that enable you to monitor its behavior. Logging messages are generated in different categories:

  • FATAL means a malfunction or internal error occurred inside the servlet.
  • WARNING indicates an error processing some of the information in the WAR file or parsing the version.xml file.
  • INFORMATIONAL logs all requests, replies, directory scanning, and so on.
  • DEBUG displays detailed internal information about how a request is processed.

Logging output is controlled by two servlet initialization parameters, logLevel and logPath. The log level can be set to either NONE, FATAL, WARNING, INFORMATIONAL, or DEBUG. The log path specifies a file where the output is written. If no path is specified, logging is done to the standard log for servlets (using ServletContext.log()). Here is an example:

<servlet>
  <servlet-name>
    JnlpDownloadServlet
  </servlet-name>
  <servlet-class>
    jnlp.sample.servlet.JnlpDownloadServlet
  </servlet-class>

  <init-param>
    <param-name>
      logLevel
    </param-name>

    <param-value>
      DEBUG
    </param-value>
  </init-param>

  <init-param>
    <param-name>
      logPath
    </param-name>

    <param-value>
      /logs/jnlpdownloadservlet.log
    </param-value>
  </init-param>

</servlet>

MIME Types

The servlet treats JNLP and JAR files specially. Substitutions are made in JNLP files as desribed in Substitutions. A version-based request for a JAR file can result in the generation of an incremental update. The servlet uses extensions to determine if a file is a JNLP or JAR file. The default extension of JNLP files is .jnlp and for JAR files is .jar. These default extensions can be overwritten by the initialization parameters: jnlp-extension and jar-extension. Here is an example:

<init-param>
  <param-name>
    jnlp-extension
  </param-name>

  <param-value>
    .xjnlp
  </param-value>
</init-param>

The MIME type that is returned for a file is also based on its extension. The MIME type is looked up in the configuration files for the web container and the WAR file. If no mapping is specified, the default MIME types are assigned:

Extension | Default MIME Type
.jnlp | application/x-java-jnlp-file
.jar | application/x-java-archive
.jardiff | application/x-java-archive-diff

To change the MIME type JnlpDownloadServlet returns, use the <mime-type> element in the web.xml file. Here is an example:

<web-app>
   ...
   <mime-mapping>
      <extension>jnlp</extension>
      <mime-type>text/ascii</mime-type>
   </mime-mapping>
   ...
</web-app>

Building JnlpDownloadServlet

Most of the time, you will use JnlpDownloadServlet directly. In rare cases, you might want to add functionality to JnlpDownloadServlet. The full source code is available, and the build is relatively straightforward.

You must have GNU make, a Java Development Kit (JDK), and you must define environment variables. Here is one example on a Linux system.

$ export CLASS_PATH=/home/edmond/Applications/apache-tomcat-7.0.2/lib/servlet-api.jar
$ export FILE_SEPARATOR=:
$ export TMPDIR=/tmp
$ export SDK_HOME=/home/edmond/jdk1.7.0
$ make
.
.
.

The output of the build is lib/jnlp-servlet.jar and lib/jardiff.jar.

Reference

More Information About ISO 8601 Time Stamps

The general format of a time stamp is:

   YYYY-MM-DD hh:mm:ss

The dashes, colons, and seconds are optional:

   YYYYMMDDhhmm

The hh is in 24-hour notation. By default, the local time zone is used. Universal Time (UTC), also known as GMT time, can be specified by appending the capital letter Z to a time:

     23:59:59Z or 235959Z

The strings +hh:mm, +hhmm, or +hh can be added to the time to indicate that the local time zone is hh hours and mm minutes ahead of UTC. For time zones west of the zero meridian, which are behind UTC, the notation -hh:mm, -hhmm, or -hh is used instead. For example, Central European Time (CET) is +0100 and U.S./Canadian Eastern Standard Time (EST) is -0500. The following strings all indicate the same point in time:

     12:00Z = 13:00+01:00 = 0700-0500

Specification of the XML Version File

The complete document type definition (DTD) for the version.xml file is shown here:

<!ELEMENT jnlp-versions <resource*, platform*)>
<!ELEMENT resource (pattern, file)>
<!ELEMENT platform (pattern, file, product-version-id)>
<!ELEMENT pattern (name, version-id, os*, arch*, locale*)>
<!ELEMENT name (#PCDATA)>
<!ELEMENT version-id (#PCDATA)>
<!ELEMENT os (#PCDATA)>
<!ELEMENT arch (#PCDATA)>
<!ELEMENT locale (#PCDATA)>
<!ELEMENT file (#PCDATA)>
<!ELEMENT product-version-id (#PCDATA)>
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


DTrace Probes in HotSpot VM

  • Overview
  • The hotspot Provider
    • VM Lifecycle Probes
    • Thread Lifecycle Probes
    • Classloading Probes
    • Garbage Collection Probes
    • Method Compilation Probes
    • Monitor Probes
    • Application Tracking Probes
  • The hotspot_jni Provider
  • Reference

Overview

With the introduction of DTrace on Solaris 10, DTrace support has been added to the Java SE 6 HotSpot VM. The hotspot and hotspot_jni providers make available probes that can be used to monitor JVM internal state and activities as well as the Java application that is running. All of the probes are USDT probes and are accessed using the process-id of the JVM process. The probe details are listed in the next section, and the API is provided in the reference section.

The hotspot Provider

The hotspot provider makes available probes that can be used to track the lifespan of the VM, thread start and stop events, GC and memory pool statistics, method compilations, and monitor activity. With a startup flag, additional probes are enabled which can be used to monitor the running Java program, such as method enter and return probes, and object allocations. All of the hotspot probes originate in the VM library (libjvm.so), so they are also provided from programs which embed the VM.

Many of the probes in the provider have arguments that can be examined to provide further details on the state of the VM. Many of these probes' arguments are opaque IDs which can be used to link probe firings to each other, however strings and other data are also provided. When string values are provided, they are always present as a pair: a pointer to unterminated modified UTF-8 data (see JVM spec :4.4.7) , and a length value which indicates the extent of that data. Because the string data (even when none of the characters are outside the ASCII range) is not guaranteed to be terminated by a NUL character, it is necessary to use the length-terminated copyinstr() intrinsic to read the string data from the process.

VM Life-cycle Probes

The probes that relate to the VM life-cycle are indicated below. None have any arguments at this time.

Probe | Description
vm-init-begin | Probe that fires just as the VM initialization begins
vm-init-end | Probe that fires when the VM initialization finishes, and the VM is ready to start running application code
vm-shutdown | Probe that fires as the VM is shutting down due to program termination or an error

Thread Lifecycle Probes

Two probes are available for tracking thread start and stop events.

Probe | Description
thread-start | Probe that fires when a thread is started. Provides the arguments listed below
thread-stop | Probe that fires when the thread has completed. Provides the arguments listed below

Each of these probes has the following arguments:

Probe Arguments | Description
args[0] | A pointer to UTF-8 string data which contains the thread name
args[1] | The length of the thread name data (in bytes)
args[2] | The Java thread ID. This is the value that will match other HotSpot VM probes which contain a thread argument
args[3] | The native/OS thread ID. This is the ID assigned by the host operating system
args[4] | A boolean value which indicates if this thread is a daemon or not. A value of 0 indicates a non-daemon thread

Classloading Probes

Two probes are available for tracking class loading and unloading activity.

Probe | Description
class-loaded | Probe that fires when a class has been loaded
class-unloaded | Probe that fires when a class has been unloaded from the system

Each of these probes has the following arguments:

Probe Arguments | Description
args[0] | A pointer to UTF-8 string data which contains the name of the class that was loaded
args[1] | The length of the class name data (in bytes)
args[2] | The class loader ID, which is a unique identifier for a class loader in the VM. This is the class loader that loaded the class
args[3] | A boolean value which indicates if the class is a shared class (if the class was loaded from the shared archive)

Garbage Collection Probes

Probes are available that can be used to measure the duration of a system-wide garbage collection cycle (for those garbage collectors that have a defined begin and end). Each memory pool can be tracked independently. The probes for individual pools pass the memory manager's name, the pool name, and pool usage information at both the begin and end of pool collection.

The provided GC-related probes are:

Probe | Description
gc-begin | Probe that fires when a system-wide collection is about to start. It's one argument (arg[0]) is a boolean value which indicates if this is to be a Full GC.
gc-end | Probe that fires when a system-wide collection has completed. No arguments.
mem-pool-gc-begin | Probe that fires when an individual memory pool is about to be collected. Provides the arguments listed below
mem-pool-gc-end | Probe that fires after an individual memory pool has been collected. Provides the arguments listed below

Memory pool probe arguments:

Probe Arguments | Description
args[0] | A pointer to UTF-8 string data which contains the name of the manager which manages this memory pool
args[1] | The length of the manager name data (in bytes)
args[2] | A pointer to UTF-8 string data which contains the name of the memory pool
args[3] | The length of the memory pool name data (in bytes)
args[4] | The initial size of the memory pool (in bytes)
args[5] | The amount of memory in use in the memory pool (in bytes)
args[6] | The number of committed pages in the memory pool
args[7] | The maximum size of the memory pool

Method Compilation Probes

Probes are available to indicate which methods are being compiled and by which compiler. Probes are also available to track the installing and uninstalling of compiled methods.

Probes that mark the begin and end of method compilation:

Probe | Description
method-compile-begin | Probe that fires as method compilation begins. Provides the arguments listed below
method-compile-end | Probe that fires when method compilation completes. In addition to the arguments listed below, argv[8] is a boolean value which indicates if the compilation was successful

Method compilation probe arguments:

Probe Arguments | Description
args[0] | A pointer to UTF-8 string data which contains the name of the compiler which is compiling this method
args[1] | The length of the compiler name data (in bytes)
args[2] | A pointer to UTF-8 string data which contains the name of the class of the method being compiled
args[3] | The length of the class name data (in bytes)
args[4] | A pointer to UTF-8 string data which contains the name of the method being compiled
args[5] | The length of the method name data (in bytes)
args[6] | A pointer to UTF-8 string data which contains the signature of the method being compiled
args[7] | The length of the signature data (in bytes)

When compiled methods are installed for execution or uninstalled, the following probes are fired:

Probe | Description
compiled-method-load | Probe that fires when a compiled method is installed. In addition to the arguments listed below, argv[6] contains a pointer to the compiled code, and argv[7] is the size of the compiled code
compiled-method-unload | Probe that fires when a compiled method is uninstalled. Provides the arguments listed below

Compiled method loading probe arguments:

Probe Arguments | Description
args[0] | A pointer to UTF-8 string data which contains the name of the class of the method being installed
args[1] | The length of the class name data (in bytes)
args[2] | A pointer to UTF-8 string data which contains the name of the method being installed
args[3] | The length of the method name data (in bytes)
args[4] | A pointer to UTF-8 string data which contains the signature of the method being installed
args[5] | The length of the signature data (in bytes)

Monitor Probes

As the Java application runs, threads will enter and exit monitors, wait on monitors, and perform notifications. Probes are available for all wait and notification events, as well as for contended monitor entry and exit events. A contended monitor entry is the situation where a thread attempts to enter a monitor when another thread is already in the monitor. A contended monitor exit event occurs when a thread leaves a monitor and other threads are waiting to enter to the monitor. Thus, contended enter and contended exit events may not match up to each other in relation to the thread that encounters these events, though it is expected that a contended exit from one thread should match up to a contended enter on another thread (the thread waiting to enter the monitor).

All monitor events provide the thread ID, a monitor ID, and the type of the class of the object as arguments. It is expected that the thread and the class will help map back to the Java program, while the monitor ID can provide matching information between probe firings.

Since the existence of these probes in the VM causes performance degradation, they will only fire if the VM flag -XX:+ExtendedDTraceProbes is set on the java command line. This flag can be turned on and off dynamically at runtime by using the jinfo utility.

If the above flag is off, the monitor probes are still present in the probe listing obtainable from dtrace, but will remain dormant and will never fire. It is intended that this restriction be removed in future releases of the VM, where these probes will be enabled all the time with no impact to performance.

The available probes:

Probe | Description
monitor-contended-enter | Probe that fires as a thread attempts to enter a contended monitor
monitor-contended-entered | Probe that fires when a thread successfully enters the contended monitor
monitor-contended-exit | Probe that fires when a thread leaves a monitor and other threads are waiting to enter
monitor-wait | Probe that fires as a thread begins a wait on a monitor via Object.wait(). The probe has an additional argument, args[4] which is a 'long' value which indicates the timeout being used.
monitor-waited | Probe that fires when a thread completes an Object.wait().
monitor-notify | Probe that fires when a thread calls Object.notify() to notify waiters on a monitor
monitor-notifyAll | Probe that fires when a thread calls Object.notifyAll() to notify waiters on a monitor

Monitor probe arguments:

Probe Arguments | Description
args[0] | The Java thread identifier for the thread performing the monitor operation
args[1] | A unique, but opaque identifier for the specific monitor that the action is performed upon
args[2] | A pointer to UTF-8 string data which contains the class name of the object being acted upon
args[3] | The length of the class name data (in bytes)

Application Tracking Probes

A few probes are provided to allow fine-grained examination of Java thread execution. These consist of probes that fire anytime a method is entered or returned from, as well as a probe that fires whenever a Java object has been allocated.

Since the existence of these probes in the VM causes performance degradation, they will only fire if the VM has the ExtendedDTraceProbes flag enabled. By default the probes are all present in any listing of the probes in the VM, but are dormant without the appropriate flag. It is intended that this restriction be removed in future releases of the VM, where these probes will be enabled all the time with no impact to performance.

The method entry and return probes:

Probe | Description
method-entry | Probe that fires when a method is being entered.
method-return | Probe that fires when a method returns, either normally or due to an exception.

Method probe arguments:

Probe Arguments | Description
args[0] | The Java thread ID of the thread that is entering or leaving the method
args[1] | A pointer to UTF-8 string data which contains the name of the class of the method
args[2] | The length of the class name data (in bytes)
args[3] | A pointer to UTF-8 string data which contains the name of the method
args[4] | The length of the method name data (in bytes)
args[5] | A pointer to UTF-8 string data which contains the signature of the method
args[6] | The length of the signature data (in bytes)

The available allocation probe:

Probe | Description
object-alloc | Probe that fires when any object is allocated, provided that the ExtendedDTraceProbes flag is enabled.

The object allocation probe has the following arguments:

Probe Arguments | Description
args[0] | The Java thread ID of the thread that is allocating the object
args[1] | A pointer to UTF-8 string data which contains the class name of the object being allocated
args[2] | The length of the class name data (in bytes)
args[3] | The size of the object being allocated

The hotspot_jni Provider

In order to call from native code to Java code, due to embedding of the VM in an application or execution of native code within a Java application, the native code must make a call through the JNI interface. The JNI interface provides a number of methods for invoking Java code and examining the state of the VM. DTrace probes are provided at the entry point and return point for each of these methods. The probes are provided by the hotspot_jni provider. The name of the probe is the name of the JNI method, appended with "-entry" for entry probes, and "-return" for return probes. The arguments available at each entry probe are the arguments that were provided to the function (with the exception of the Invoke* methods, which omit the arguments that are passed to the Java method). The return probes have the return value of the method as an argument (if available).

Reference

provider hotspot {
  probe vm-init-begin();
  probe vm-init-end();
  probe vm-shutdown();
  probe class-loaded(
      char* class_name, uintptr_t class_name_len, uintptr_t class_loader_id, bool is_shared);
  probe class-unloaded(
      char* class_name, uintptr_t class_name_len, uintptr_t class_loader_id, bool is_shared);
  probe gc-begin(bool is_full);
  probe gc-end();
  probe mem-pool-gc-begin(
      char* mgr_name, uintptr_t mgr_name_len, char* pool_name, uintptr_t pool_name_len,
      uintptr_t initial_size, uintptr_t used, uintptr_t committed, uintptr_t max_size);
  probe mem-pool-gc-end(
      char* mgr_name, uintptr_t mgr_name_len, char* pool_name, uintptr_t pool_name_len,
      uintptr_t initial_size, uintptr_t used, uintptr_t committed, uintptr_t max_size);
  probe thread-start(
      char* thread_name, uintptr_t thread_name_length,
      uintptr_t java_thread_id, uintptr_t native_thread_id, bool is_daemon);
  probe thread-stop(
      char* thread_name, uintptr_t thread_name_length,
      uintptr_t java_thread_id, uintptr_t native_thread_id, bool is_daemon);
  probe method-compile-begin(
      char* class_name, uintptr_t class_name_len,
      char* method_name, uintptr_t method_name_len,
      char* signature, uintptr_t signature_len);
  probe method-compile-end(
      char* class_name, uintptr_t class_name_len,
      char* method_name, uintptr_t method_name_len,
      char* signature, uintptr_t signature_len,
      bool is_success);
  probe compiled-method-load(
      char* class_name, uintptr_t class_name_len,
      char* method_name, uintptr_t method_name_len,
      char* signature, uintptr_t signature_len,
      void* code, uintptr_t code_size);
  probe compiled-method-unload(
      char* class_name, uintptr_t class_name_len,
      char* method_name, uintptr_t method_name_len,
      char* signature, uintptr_t signature_len);
  probe monitor-contended-enter(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len);
  probe monitor-contended-entered(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len);
  probe monitor-contended-exit(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len);
  probe monitor-wait(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len,
      uintptr_t timeout);
  probe monitor-waited(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len);
  probe monitor-notify(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len);
  probe monitor-notifyAll(
      uintptr_t java_thread_id, uintptr_t monitor_id,
      char* class_name, uintptr_t class_name_len);
  probe method-entry(
      uintptr_t java_thread_id, char* class_name, uintptr_t class_name_len,
      char* method_name, uintptr_t method_name_len,
      char* signature, uintptr_t signature_len);
  probe method-return(
      uintptr_t java_thread_id, char* class_name, uintptr_t class_name_len,
      char* method_name, uintptr_t method_name_len,
      char* signature, uintptr_t signature_len);
  probe object-alloc(
      uintptr_t java_thread_id, char* class_name, uintptr_t class_name_len,
      uintptr_t size);
};

provider hotspot_jni {
  probe AllocObject-entry(void*, void*);
  probe AllocObject-return(void*);
  probe AttachCurrentThreadAsDaemon-entry(void*, void**, void*);
  probe AttachCurrentThreadAsDaemon-return(uint32_t);
  probe AttachCurrentThread-entry(void*, void**, void*);
  probe AttachCurrentThread-return(uint32_t);
  probe CallBooleanMethodA-entry(void*, void*, uintptr_t);
  probe CallBooleanMethodA-return(uintptr_t);
  probe CallBooleanMethod-entry(void*, void*, uintptr_t);
  probe CallBooleanMethod-return(uintptr_t);
  probe CallBooleanMethodV-entry(void*, void*, uintptr_t);
  probe CallBooleanMethodV-return(uintptr_t);
  probe CallByteMethodA-entry(void*, void*, uintptr_t);
  probe CallByteMethodA-return(char);
  probe CallByteMethod-entry(void*, void*, uintptr_t);
  probe CallByteMethod-return(char);
  probe CallByteMethodV-entry(void*, void*, uintptr_t);

  probe CallByteMethodV-return(char);
  probe CallCharMethodA-entry(void*, void*, uintptr_t);
  probe CallCharMethodA-return(uint16_t);
  probe CallCharMethod-entry(void*, void*, uintptr_t);
  probe CallCharMethod-return(uint16_t);
  probe CallCharMethodV-entry(void*, void*, uintptr_t);
  probe CallCharMethodV-return(uint16_t);
  probe CallDoubleMethodA-entry(void*, void*, uintptr_t);
  probe CallDoubleMethodA-return(double);
  probe CallDoubleMethod-entry(void*, void*, uintptr_t);
  probe CallDoubleMethod-return(double);
  probe CallDoubleMethodV-entry(void*, void*, uintptr_t);
  probe CallDoubleMethodV-return(double);
  probe CallFloatMethodA-entry(void*, void*, uintptr_t);
  probe CallFloatMethodA-return(float);
  probe CallFloatMethod-entry(void*, void*, uintptr_t);
  probe CallFloatMethod-return(float);
  probe CallFloatMethodV-entry(void*, void*, uintptr_t);
  probe CallFloatMethodV-return(float);
  probe CallIntMethodA-entry(void*, void*, uintptr_t);
  probe CallIntMethodA-return(uint32_t);
  probe CallIntMethod-entry(void*, void*, uintptr_t);
  probe CallIntMethod-return(uint32_t);
  probe CallIntMethodV-entry(void*, void*, uintptr_t);
  probe CallIntMethodV-return(uint32_t);
  probe CallLongMethodA-entry(void*, void*, uintptr_t);
  probe CallLongMethodA-return(uintptr_t);
  probe CallLongMethod-entry(void*, void*, uintptr_t);
  probe CallLongMethod-return(uintptr_t);
  probe CallLongMethodV-entry(void*, void*, uintptr_t);
  probe CallLongMethodV-return(uintptr_t);
  probe CallNonvirtualBooleanMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualBooleanMethodA-return(uintptr_t);
  probe CallNonvirtualBooleanMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualBooleanMethod-return(uintptr_t);
  probe CallNonvirtualBooleanMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualBooleanMethodV-return(uintptr_t);
  probe CallNonvirtualByteMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualByteMethodA-return(char);
  probe CallNonvirtualByteMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualByteMethod-return(char);
  probe CallNonvirtualByteMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualByteMethodV-return(char);
  probe CallNonvirtualCharMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualCharMethodA-return(uint16_t);
  probe CallNonvirtualCharMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualCharMethod-return(uint16_t);
  probe CallNonvirtualCharMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualCharMethodV-return(uint16_t);
  probe CallNonvirtualDoubleMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualDoubleMethodA-return(double);
  probe CallNonvirtualDoubleMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualDoubleMethod-return(double);
  probe CallNonvirtualDoubleMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualDoubleMethodV-return(double);
  probe CallNonvirtualFloatMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualFloatMethodA-return(float);
  probe CallNonvirtualFloatMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualFloatMethod-return(float);
  probe CallNonvirtualFloatMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualFloatMethodV-return(float);
  probe CallNonvirtualIntMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualIntMethodA-return(uint32_t);
  probe CallNonvirtualIntMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualIntMethod-return(uint3t);
  probe CallNonvirtualIntMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualIntMethodV-return(uint32_t);
  probe CallNonvirtualLongMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualLongMethodA-return(uintptr_t);
  probe CallNonvirtualLongMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualLongMethod-return(uintptr_t);
  probe CallNonvirtualLongMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualLongMethodV-return(uintptr_t);
  probe CallNonvirtualObjectMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualObjectMethodA-return(void*);
  probe CallNonvirtualObjectMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualObjectMethod-return(void*);
  probe CallNonvirtualObjectMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualObjectMethodV-return(void*);
  probe CallNonvirtualShortMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualShortMethodA-return(uint16_t);
  probe CallNonvirtualShortMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualShortMethod-return(uint16_t);
  probe CallNonvirtualShortMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualShortMethodV-return(uint16_t);
  probe CallNonvirtualVoidMethodA-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualVoidMethodA-return();
  probe CallNonvirtualVoidMethod-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualVoidMethod-return();
  probe CallNonvirtualVoidMethodV-entry(void*, void*, void*, uintptr_t);
  probe CallNonvirtualVoidMethodV-return();
  probe CallObjectMethodA-entry(void*, void*, uintptr_t);
  probe CallObjectMethodA-return(void*);
  probe CallObjectMethod-entry(void*, void*, uintptr_t);
  probe CallObjectMethod-return(void*);
  probe CallObjectMethodV-entry(void*, void*, uintptr_t);
  probe CallObjectMethodV-return(void*);
  probe CallShortMethodA-entry(void*, void*, uintptr_t);
  probe CallShortMethodA-return(uint16_t);
  probe CallShortMethod-entry(void*, void*, uintptr_t);
  probe CallShortMethod-return(uint16_t);
  probe CallShortMethodV-entry(void*, void*, uintptr_t);
  probe CallShortMethodV-return(uint16_t);
  probe CallStaticBooleanMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticBooleanMethodA-return(uintptr_t);
  probe CallStaticBooleanMethod-entry(void*, void*, uintptr_t);
  probe CallStaticBooleanMethod-return(uintptr_t);
  probe CallStaticBooleanMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticBooleanMethodV-return(uintptr_t);
  probe CallStaticByteMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticByteMethodA-return(char);
  probe CallStaticByteMethod-entry(void*, void*, uintptr_t);
  probe CallStaticByteMethod-return(char);
  probe CallStaticByteMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticByteMethodV-return(char);
  probe CallStaticCharMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticCharMethodA-return(uint16_t);
  probe CallStaticCharMethod-entry(void*, void*, uintptr_t);
  probe CallStaticCharMethod-return(uint16_t);
  probe CallStaticCharMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticCharMethodV-return(uint16_t);
  probe CallStaticDoubleMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticDoubleMethodA-return(double);
  probe CallStaticDoubleMethod-entry(void*, void*, uintptr_t);
  probe CallStaticDoubleMethod-return(double);
  probe CallStaticDoubleMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticDoubleMethodV-return(double);
  probe CallStaticFloatMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticFloatMethodA-return(float);
  probe CallStaticFloatMethod-entry(void*, void*, uintptr_t);
  probe CallStaticFloatMethod-return(float);
  probe CallStaticFloatMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticFloatMethodV-return(float);
  probe CallStaticIntMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticIntMethodA-return(uint32_t);
  probe CallStaticIntMethod-entry(void*, void*, uintptr_t);
  probe CallStaticIntMethod-return(uint32_t);
  probe CallStaticIntMethodentry(void*, void*, uintptr_t);
  probe CallStaticIntMethodV-return(uint32_t);
  probe CallStaticLongMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticLongMethodA-return(uintptr_t);
  probe CallStaticLongMethod-entry(void*, void*, uintptr_t);
  probe CallStaticLongMethod-return(uintptr_t);
  probe CallStaticLongMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticLongMethodV-return(uintptr_t);
  probe CallStaticObjectMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticObjectMethodA-return(void*);
  probe CallStaticObjectMethod-entry(void*, void*, uintptr_t);
  probe CallStaticObjectMethod-return(void*);
  probe CallStaticObjectMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticObjectMethodV-return(void*);
  probe CallStaticShortMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticShortMethodA-return(uint16_t);
  probe CallStaticShortMethod-entry(void*, void*, uintptr_t);
  probe CallStaticShortMethod-return(uint16_t);
  probe CallStaticShortMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticShortMethodV-return(uint16_t);
  probe CallStaticVoidMethodA-entry(void*, void*, uintptr_t);
  probe CallStaticVoidMethodA-return();
  probe CallStaticVoidMethod-entry(void*, void*, uintptr_t);
  probe CallStaticVoidMethod-return();
  probe CallStaticVoidMethodV-entry(void*, void*, uintptr_t);
  probe CallStaticVoidMethodV-return();
  probe CallVoidMethodA-entry(void*, void*, uintptr_t);
  probe CallVoidMethodA-return();
  probe CallVoidMethod-entry(void*, void*, uintptr_t);
  probe CallVoidMethod-return();
  probe CallVoidMethodV-entry(void*, void*, uintptr_t);
  probe CallVoidMethodV-return();
  probe CreateJavaVM-entry(void**, void**, void*);
  probe CreateJavaVM-return(uint32_t);
  probe DefineClass-entry(void*, const char*, void*, char, uintptr_t);
  probe DefineClass-return(void*);
  probe DeleteGlobalRef-entry(void*, void*);
  probe DeleteGlobalRef-return();
  probe DeleteLocalRef-entry(void*, void*);
  probe DeleteLocalRef-return();
  probe DeleteWeakGlobalRef-entry(void*, void*);
  probe DeleteWeakGlobalRef-return();
  probe DestroyJavaVM-entry(void*);
  probe DestroyJavaVM-return(uint32_t);
  probe DetachCurrentThread-entry(void*);
  probe DetachCurrentThread-return(uint32_t);
  probe EnsureLocalCapacity-entry(void*, uint32_t);
  probe EnsureLocalCapacity-return(uint32_t);
  probe ExceptionCheck-entry(void*);
  probe ExceptionCheck-return(uintptr_t);
  probe ExceptionClear-entry(void*);
  probe ExceptionClear-return();
  probe ExceptionDescribe-entry(void*);
  probe ExceptionDescribe-return();
  probe ExceptionOccurred-entry(void*);
  probe ExceptionOccurred-return(void*);
  probe FatalError-entry(void* env, const char*);
  probe FindClass-entry(void*, const char*);
  probe FindClass-return(void*);
  probe FromReflectedField-entry(void*, void*);
  probe FromReflectedField-return(uintptr_t);
  probe FromReflectedMethod-entry(void*, void*);
  probe FromReflectedMethod-return(uintptr_t);
  probe GetArrayLength-entry(void*, void*);
  probe GetArrayLength-return(uintptr_t);
  probe GetBooleanArrayElements-entry(void*, void*, uintptr_t*);
  probe GetBooleanArrayElements-return(uintptr_t*);
  probe GetBooleanArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, uintptr_t*);
  probe GetBooleanArrayRegion-return();
  probe GetBooleanField-entry(void*, void*, uintptr_t);
  probe GetBooleanField-return(uintptr_t);
  probe GetByteArrayElements-entry(void*, void*, uintptr_t*);
  probe GetByteArrayElements-return(char*);
  probe GetByteArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, char*);
  probe GetByteArrayRegion-return();
  probe GetByteField-entry(void*, void*, uintptr_t);
  probe GetByteField-return(char);
  probe GetCharArrayElements-entry(void*, void*, uintptr_t*);
  probe GetCharArrayElements-return(uint16_t*);
  probe GetCharArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, uint16_t*);
  probe GetCharArrayRegion-return();
  probe GetCharField-entry(void*, void*, uintptr_t);
  probe GetCharField-return(uint16_t);
  probe GetCreatedJavaVMs-eintptr_t*);
  probe GetCreatedJavaVMs-return(uintptr_t);
  probe GetCreateJavaVMs-entry(void*, uintptr_t, uintptr_t*);
  probe GetCreateJavaVMs-return(uint32_t);
  probe GetDefaultJavaVMInitArgs-entry(void*);
  probe GetDefaultJavaVMInitArgs-return(uint32_t);
  probe GetDirectBufferAddress-entry(void*, void*);
  probe GetDirectBufferAddress-return(void*);
  probe GetDirectBufferCapacity-entry(void*, void*);
  probe GetDirectBufferCapacity-return(uintptr_t);
  probe GetDoubleArrayElements-entry(void*, void*, uintptr_t*);
  probe GetDoubleArrayElements-return(double*);
  probe GetDoubleArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, double*);
  probe GetDoubleArrayRegion-return();
  probe GetDoubleField-entry(void*, void*, uintptr_t);
  probe GetDoubleField-return(double);
  probe GetEnv-entry(void*, void*, void*);
  probe GetEnv-return(uint32_t);
  probe GetFieldID-entry(void*, void*, const char*, const char*);
  probe GetFieldID-return(uintptr_t);
  probe GetFloatArrayElements-entry(void*, void*, uintptr_t*);
  probe GetFloatArrayElements-return(float*);
  probe GetFloatArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, float*);
  probe GetFloatArrayRegion-return();
  probe GetFloatField-entry(void*, void*, uintptr_t);
  probe GetFloatField-return(float);
  probe GetIntArrayElements-entry(void*, void*, uintptr_t*);
  probe GetIntArrayElements-return(uint32_t*);
  probe GetIntArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, uint32_t*);
  probe GetIntArrayRegion-return();
  probe GetIntField-entry(void*, void*, uintptr_t);
  probe GetIntField-return(uint32_t);
  probe GetJavaVM-entry(void*, void**);
  probe GetJavaVM-return(uint32_t);
  probe GetLongArrayElements-entry(void*, void*, uintptr_t*);
  probe GetLongArrayElements-return(uintptr_t*);
  probe GetLongArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, uintptr_t*);
  probe GetLongArrayRegion-return();
  probe GetLongField-entry(void*, void*, uintptr_t);
  probe GetLongField-return(uintptr_t);
  probe GetMethodID-entry(void*, void*, const char*, const char*);
  probe GetMethodID-return(uintptr_t);
  probe GetObjectArrayElement-entry(void*, void*, uintptr_t);
  probe GetObjectArrayElement-return(void*);
  probe GetObjectClass-entry(void*, void*);
  probe GetObjectClass-return(void*);
  probe GetObjectField-entry(void*, void*, uintptr_t);
  probe GetObjectField-return(void*);
  probe GetObjectRefType-entry(void*, void*);
  probe GetObjectRefType-return(void*);
  probe GetPrimitiveArrayCritical-entry(void*, void*, uintptr_t*);
  probe GetPrimitiveArrayCritical-return(void*);
  probe GetShortArrayElements-entry(void*, void*, uintptr_t*);
  probe GetShortArrayElements-return(uint16_t*);
  probe GetShortArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, uint16_t*);
  probe GetShortArrayRegion-return();
  probe GetShortField-entry(void*, void*, uintptr_t);
  probe GetShortField-return(uint16_t);
  probe GetStaticBooleanField-entry(void*, void*, uintptr_t);
  probe GetStaticBooleanField-return(uintptr_t);
  probe GetStaticByteField-entry(void*, void*, uintptr_t);
  probe GetStaticByteField-return(char);
  probe GetStaticCharField-entry(void*, void*, uintptr_t);
  probe GetStaticCharField-return(uint16_t);
  probe GetStaticDoubleField-entry(void*, void*, uintptr_t);
  probe GetStaticDoubleField-return(double);
  probe GetStaticFieldID-entry(void*, void*, const char*, const char*);
  probe GetStaticFieldID-return(uintptr_t);
  probe GetStaticFloatField-entry(void*, void*, uintptr_t);
  probe GetStaticFloatField-return(float);
  probe GetStaticIntField-entry(void*, void*, uintptr_t);
  probe GetStaticIntField-return(uint32_t);
  probe GetStaticLongField-entry(void*, void*, uintptr_t);
  probe GetStaticLongField-return(uintptr_t);
  probe GetStaticMethodID-entry(void*, void*, const char*, const char*);
  probe GetStaticMethodID-return(uintptr_t);
  probe GetStaticObjectField-entry(void*, void*, uintptr_t);
  probe GetStaticObjectField-return(void*);
  probe GetStaticShortField-entry(void*, void*, uintptr_t);
  probe GetStaticShortField-return(uint16_t);
  pro GetStringChars-entry(void*, void*, uintptr_t*);
  probe GetStringChars-return(const uint16_t*);
  probe GetStringCritical-entry(void*, void*, uintptr_t*);
  probe GetStringCritical-return(const uint16_t*);
  probe GetStringLength-entry(void*, void*);
  probe GetStringLength-return(uintptr_t);
  probe GetStringRegion-entry(void*, void*, uintptr_t, uintptr_t, uint16_t*);
  probe GetStringRegion-return();
  probe GetStringUTFChars-entry(void*, void*, uintptr_t*);
  probe GetStringUTFChars-return(const char*);
  probe GetStringUTFLength-entry(void*, void*);
  probe GetStringUTFLength-return(uintptr_t);
  probe GetStringUTFRegion-entry(void*, void*, uintptr_t, uintptr_t, char*);
  probe GetStringUTFRegion-return();
  probe GetSuperclass-entry(void*, void*);
  probe GetSuperclass-return(void*);
  probe GetVersion-entry(void*);
  probe GetVersion-return(uint32_t);
  probe IsAssignableFrom-entry(void*, void*, void*);
  probe IsAssignableFrom-return(uintptr_t);
  probe IsInstanceOf-entry(void*, void*, void*);
  probe IsInstanceOf-return(uintptr_t);
  probe IsSameObject-entry(void*, void*, void*);
  probe IsSameObject-return(uintptr_t);
  probe MonitorEnter-entry(void*, void*);
  probe MonitorEnter-return(uint32_t);
  probe MonitorExit-entry(void*, void*);
  probe MonitorExit-return(uint32_t);
  probe NewBooleanArray-entry(void*, uintptr_t);
  probe NewBooleanArray-return(void*);
  probe NewByteArray-entry(void*, uintptr_t);
  probe NewByteArray-return(void*);
  probe NewCharArray-entry(void*, uintptr_t);
  probe NewCharArray-return(void*);
  probe NewDirectByteBuffer-entry(void*, void*, uintptr_t);
  probe NewDirectByteBuffer-return(void*);
  probe NewDoubleArray-entry(void*, uintptr_t);
  probe NewDoubleArray-return(void*);
  probe NewFloatArray-entry(void*, uintptr_t);
  probe NewFloatArray-return(void*);
  probe NewGlobalRef-entry(void*, void*);
  probe NewGlobalRef-return(void*);
  probe NewIntArray-entry(void*, uintptr_t);
  probe NewIntArray-return(void*);
  probe NewLocalRef-entry(void*, void*);
  probe NewLocalRef-return(void*);
  probe NewLongArray-entry(void*, uintptr_t);
  probe NewLongArray-return(void*);
  probe NewObjectA-entry(void*, void*, uintptr_t);
  probe NewObjectA-return(void*);
  probe NewObjectArray-entry(void*, uintptr_t, void*, void*);
  probe NewObjectArray-return(void*);
  probe NewObject-entry(void*, void*, uintptr_t);
  probe NewObject-return(void*);
  probe NewObjectV-entry(void*, void*, uintptr_t);
  probe NewObjectV-return(void*);
  probe NewShortArray-entry(void*, uintptr_t);
  probe NewShortArray-return(void*);
  probe NewString-entry(void*, const uint16_t*, uintptr_t);
  probe NewString-return(void*);
  probe NewStringUTF-entry(void*, const char*);
  probe NewStringUTF-return(void*);
  probe NewWeakGlobalRef-entry(void*, void*);
  probe NewWeakGlobalRef-return(void*);
  probe PopLocalFrame-entry(void*, void*);
  probe PopLocalFrame-return(void*);
  probe PushLocalFrame-entry(void*, uint32_t);
  probe PushLocalFrame-return(uint32_t);
  probe RegisterNatives-entry(void*, void*, const void*, uint32_t);
  probe RegisterNatives-return(uint32_t);
  probe ReleaseBooleanArrayElements-entry(void*, void*, uintptr_t*, uint32_t);
  probe ReleaseBooleanArrayElements-return();
  probe ReleaseByteArrayElements-entry(void*, void*, char*, uint32_t);
  probe ReleaseByteArrayElements-return();
  probe ReleaseCharArrayElements-entry(void*, void*, uint16_t*, uint32_t);
  probe ReleaseCharArrayElements-return();
  probe ReleaseDoubleArrayElements-entry(void*, void*, double*, uint32_t);
  probe ReleaseDoubleArrayElements-return();
  probe ReleaseFloatArrayElements-entry(void*, void*, float*, uint32_t);
  probe ReleaseFloatArrayElements-return();
  probe ReleaseIntArrayElements-entry(void*, void*, uint32_t*, uint32_t);
  probe ReleaseIntArrayElements-return();
  probe ReleaseLongArrayElements-entry(void*, void*, uintptr_t*, uint32_t);
  probe ReleaseLongArrayElements-return();
  probe ReleaseObjectArrayElements-entry(void*, void*, void**, uint32_t);
  probe ReleaseObjectArrayElements-return();
  probe Releasey(void*, void*, void*, uint32_t);
  probe ReleasePrimitiveArrayCritical-return();
  probe ReleaseShortArrayElements-entry(void*, void*, uint16_t*, uint32_t);
  probe ReleaseShortArrayElements-return();
  probe ReleaseStringChars-entry(void*, void*, const uint16_t*);
  probe ReleaseStringChars-return();
  probe ReleaseStringCritical-entry(void*, void*, const uint16_t*);
  probe ReleaseStringCritical-return();
  probe ReleaseStringUTFChars-entry(void*, void*, const char*);
  probe ReleaseStringUTFChars-return();
  probe SetBooleanArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const uintptr_t*);
  probe SetBooleanArrayRegion-return();
  probe SetBooleanField-entry(void*, void*, uintptr_t, uintptr_t);
  probe SetBooleanField-return();
  probe SetByteArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const char*);
  probe SetByteArrayRegion-return();
  probe SetByteField-entry(void*, void*, uintptr_t, char);
  probe SetByteField-return();
  probe SetCharArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const uint16_t*);
  probe SetCharArrayRegion-return();
  probe SetCharField-entry(void*, void*, uintptr_t, uint16_t);
  probe SetCharField-return();
  probe SetDoubleArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const double*);
  probe SetDoubleArrayRegion-return();
  probe SetDoubleField-entry(void*, void*, uintptr_t, double);
  probe SetDoubleField-return();
  probe SetFloatArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const float*);
  probe SetFloatArrayRegion-return();
  probe SetFloatField-entry(void*, void*, uintptr_t, float);
  probe SetFloatField-return();
  probe SetIntArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const uint32_t*);
  probe SetIntArrayRegion-return();
  probe SetIntField-entry(void*, void*, uintptr_t, uint32_t);
  probe SetIntField-return();
  probe SetLongArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const uintptr_t*);
  probe SetLongArrayRegion-return();
  probe SetLongField-entry(void*, void*, uintptr_t, uintptr_t);
  probe SetLongField-return();
  probe SetObjectArrayElement-entry(void*, void*, uintptr_t, void*);
  probe SetObjectArrayElement-return();
  probe SetObjectField-entry(void*, void*, uintptr_t, void*);
  probe SetObjectField-return();
  probe SetShortArrayRegion-entry(void*, void*, uintptr_t, uintptr_t, const uint16_t*);
  probe SetShortArrayRegion-return();
  probe SetShortField-entry(void*, void*, uintptr_t, uint16_t);
  probe SetShortField-return();
  probe SetStaticBooleanField-entry(void*, void*, uintptr_t, uintptr_t);
  probe SetStaticBooleanField-return();
  probe SetStaticByteField-entry(void*, void*, uintptr_t, char);
  probe SetStaticByteField-return();
  probe SetStaticCharField-entry(void*, void*, uintptr_t, uint16_t);
  probe SetStaticCharField-return();
  probe SetStaticDoubleField-entry(void*, void*, uintptr_t, double);
  probe SetStaticDoubleField-return();
  probe SetStaticFloatField-entry(void*, void*, uintptr_t, float);
  probe SetStaticFloatField-return();
  probe SetStaticIntField-entry(void*, void*, uintptr_t, uint32_t);
  probe SetStaticIntField-return();
  probe SetStaticLongField-entry(void*, void*, uintptr_t, uintptr_t);
  probe SetStaticLongField-return();
  probe SetStaticObjectField-entry(void*, void*, uintptr_t, void*);
  probe SetStaticObjectField-return();
  probe SetStaticShortField-entry(void*, void*, uintptr_t, uint16_t);
  probe SetStaticShortField-return();
  probe Throw-entry(void*, void*);
  probe ThrowNew-entry(void*, void*, const char*);
  probe ThrowNew-return(uint32_t);
  probe Throw-return(uint32_t);
  probe ToReflectedField-entry(void*, void*, uintptr_t, uintptr_t);
  probe ToReflectedField-return(void*);
  probe ToReflectedMethod-entry(void*, void*, uintptr_t, uintptr_t);
  probe ToReflectedMethod-return(void*);
  probe UnregisterNatives-entry(void*, void*);
  probe UnregisterNatives-return(uint32_t);
};
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.jdi.request.DuplicateRequestException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.request.DuplicateRequestException

No usage of com.sun.jdi.request.DuplicateRequestException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.Element (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Element

  • Packages that use Element
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).
    org.w3c.dom.css
    org.w3c.dom.html
    org.w3c.dom.ls

    • Uses of Element in org.w3c.dom

      Methods in org.w3c.dom that return Element
      Modifier and Type Method and Description
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      Element Document.getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      Element Document.getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      Element Attr.getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.

    • Uses of Element in org.w3c.dom.css

      Methods in org.w3c.dom.css with parameters of type Element
      Modifier and Type Method and Description
      CSSStyleDeclaration ViewCSS.getComputedStyle(Element elt, String pseudoElt)
      This method is used to get the computed style as it is defined in [CSS2].
      CSSStyleDeclaration DocumentCSS.getOverrideStyle(Element elt, String pseudoElt)
      This method is used to retrieve the override style declaration for a specified element and a specified pseudo-element.

    • Uses of Element in org.w3c.dom.html

      Subinterfaces of Element in org.w3c.dom.html
      Modifier and Type Interface and Description
      interface  HTMLAnchorElement
      The anchor element.
      interface  HTMLAppletElement
      An embedded Java applet.
      interface  HTMLAreaElement
      Client-side image map area definition.
      interface  HTMLBaseElement
      Document base URI.
      interface  HTMLBaseFontElement
      Base font.
      interface  HTMLBodyElement
      The HTML document body.
      interface  HTMLBRElement
      Force a line break.
      interface  HTMLButtonElement
      Push button.
      interface  HTMLDirectoryElement
      Directory list.
      interface  HTMLDivElement
      Generic block container.
      interface  HTMLDListElement
      Definition list.
      interface  HTMLElement
      All HTML element interfaces derive from this class.
      interface  HTMLFieldSetElement
      Organizes form controls into logical groups.
      interface  HTMLFontElement
      Local change to font.
      interface  HTMLFormElement
      The FORM element encompasses behavior similar to a collection and an element.
      interface  HTMLFrameElement
      Create a frame.
      interface  HTMLFrameSetElement
      Create a grid of frames.
      interface  HTMLHeadElement
      Document head information.
      interface  HTMLHeadingElement
      For the H1 to H6 elements.
      interface  HTMLHRElement
      Create a horizontal rule.
      interface  HTMLHtmlElement
      Root of an HTML document.
      interface  HTMLIFrameElement
      Inline subwindows.
      interface  HTMLImageElement
      Embedded image.
      interface  HTMLInputElement
      Form control.
      interface  HTMLIsIndexElement
      This element is used for single-line text input.
      interface  HTMLLabelElement
      Form field label text.
      interface  HTMLLegendElement
      Provides a caption for a FIELDSET grouping.
      interface  HTMLLIElement
      List item.
      interface  HTMLLinkElement
      The LINK element specifies a link to an external resource, and defines this document's relationship to that resource (or vice versa).
      interface  HTMLMapElement
      Client-side image map.
      interface  HTMLMenuElement
      Menu list.
      interface  HTMLMetaElement
      This contains generic meta-information about the document.
      interface  HTMLModElement
      Notice of modification to part of a document.
      interface  HTMLObjectElement
      Generic embedded object.
      interface  HTMLOListElement
      Ordered list.
      interface  HTMLOptGroupElement
      Group options together in logical subdivisions.
      interface  HTMLOptionElement
      A selectable choice.
      interface  HTMLParagraphElement
      Paragraphs.
      interface  HTMLParamElement
      Parameters fed to the OBJECT element.
      interface  HTMLPreElement
      Preformatted text.
      interface  HTMLQuoteElement
      For the Q and BLOCKQUOTE elements.
      interface  HTMLScriptElement
      Script statements.
      interface  HTMLSelectElement
      The select element allows the selection of an option.
      interface  HTMLStyleElement
      Style information.
      interface  HTMLTableCaptionElement
      Table caption See the CAPTION element definition in HTML 4.0.
      interface  HTMLTableCellElement
      The object used to represent the TH and TD elements.
      interface  HTMLTableColElement
      Regroups the COL and COLGROUP elements.
      interface  HTMLTableElement
      The create* and delete* methods on the table allow authors to construct and modify tables.
      interface  HTMLTableRowElement
      A row in a table.
      interface  HTMLTableSectionElement
      The THEAD , TFOOT , and TBODY elements.
      interface  HTMLTextAreaElement
      Multi-line text field.
      interface  HTMLTitleElement
      The document title.
      interface  HTMLUListElement
      Unordered list.

    • Uses of Element in org.w3c.dom.ls

      Methods in org.w3c.dom.ls with parameters of type Element
      Modifier and Type Method and Description
      short LSParserFilter.startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.css.ElementCSSInlineStyle (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.css.ElementCSSInlineStyle

No usage of org.w3c.dom.css.ElementCSSInlineStyle
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Description of the illustration embedded_jnlp_advantage.gif

Documentation Contents

Image of a pair of diagrams, one above the other, that show an example of how embedding JNLP content into the HTML page reduces the number of network connections and results in faster startup time. Each diagram has an x-axis that shows time. (The x-axis has no values.)

The upper diagram shows an example of separate HTML and JNLP files. Along the time continuum, the HTML file starts up first, followed by the JNLP file, then the JAR files, resulting in the start of the application.

The lower diagram shows the performance improvement that results when JNLP content is embedded in the HTML file. The HTML files starts up, followed by the JAR files. There is no need for a separate network connection for the JNLP, so the application starts sooner.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.EmptyStatementTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.EmptyStatementTree

  • Packages that use EmptyStatementTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of EmptyStatementTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type EmptyStatementTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitEmptyStatement(EmptyStatementTree node, P p)

    • Uses of EmptyStatementTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type EmptyStatementTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitEmptyStatement(EmptyStatementTree node, P p)
      R | TreeScanner.visitEmptyStatement(EmptyStatementTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Enabling and Testing Java Access Bridge

Java Accessibility Guide > Enabling and Testing Java Access Bridge

Java Access Bridge is a technology that enables Java applications and applets that implement the Java Accessibility API to be visible to assistive technologies on Microsoft Windows systems. See Java SE Desktop Accessibility for more information.

The following topics are covered:

  • Enabling and Disabling Java Access Bridge
    • Enabling Java Access Bridge
    • Disabling Java Access Bridge
  • Testing Java Access Bridge
  • Obtaining Java Access Bridge Testing Tools
  • Troubleshooting

Enabling and Disabling Java Access Bridge

Java Access Bridge is included with Java SE Runtime Environment (JRE) Release 7 Update 6 (7u6) and later. Java Access Bridge 2.0.3 is included with JRE 7u6. By default, Java Access Bridge is not enabled.

Enabling Java Access Bridge

To enable Java Access Bridge, run the following command (where %JRE_HOME% is the directory of your JRE):

%JRE_HOME%\bin\jabswitch -enable

Alternatively, in Windows Vista and later, you can enable Java Access Bridge through the Control Panel:

  1. Go to Start > Control Panel > Ease of Access > Ease of Access Center. Alternatively, press Windows logo key+u to access the Ease of Access Center.
  2. Select Use the computer without a display.
  3. In the section Other programs installed, select the check box Enable Java Access Bridge (you may have to scroll down).

Note: After enabling Java Access Bridge, you must restart your assistive technology software and Java applications that use the accessibility API.

Disabling Java Access Bridge

To disable Java Access Bridge, run the following command:

%JRE_HOME%\bin\jabswitch -disable

Note: You cannot disable Java Access Bridge through the Windows Ease of Access Center.

Testing Java Access Bridge

To test Java Access Bridge, follow these steps:

  1. Ensure that Java Access Bridge is enabled.
  2. Install an assistive technology product that supports Java Access Bridge such as one of the following products:
    • JAWS
    • NonVisual Desktop Access (NVDA)
    • SuperNova
    • Window-Eyes
    • ZoomText
  3. Run a Java application that uses the accessibility API such as the SwingSet2 demonstration program. Ensure that your assistive technology product works properly with the Java application.

Obtaining Java Access Bridge Testing Tools

The Java Access Bridge testing tools Java Monkey and Java Ferret are not shipped with the JDK. These tools are included in Java Access Bridge 2.0.2. Download this version from Java Access Bridge Downloads.

Troubleshooting

Using Assistive Technologies on 64-Bit Operating Systems

The following lists the minimum version requirements of some assistive technologies for 64-bit operating systems:

  • JAWS: Version 13 and later
  • NVDA: Version 2011.3 and later
  • SuperNova: Version 13 and later
  • Window-Eyes: Version 8.2 and later
  • ZoomText: Version 10.1.5 and later

Note: It is recommend that you install both the 32-bit and 64-bit versions of the JRE. The 32-bit version only adds support for 32-bit assistive technology, and the 64-bit version only adds support for 64-bit assistive technology.

Using Java Access Bridge with Only the Private JRE

The JDK contains a private JRE. This is required to run tools included with the JDK. If you do not install the public JRE either as an option when installing the JDK or by installing the JRE by itself, and you intend to use the private JRE of the JDK, you will need to manually copy files as specified in the following table:

Dynamic-Link Library (DLL) Files to Copy from Private JRE to Windows Directory
JDK | Windows Operating System | File to Copy | Destination Directory
32-bit | 32-bit | <path to the JDK install directory>\jre\bin\WindowsAccessBridge.dll | C:\Windows\System32
32-bit | 64-bit | <path to the JDK install directory>\jre\bin\WindowsAccessBridge-32.dll | C:\Windows\SysWOW64
64-bit | 64-bit | <path to the JDK install directory>\jre\bin\WindowsAccessBridge-64.dll | C:\Windows\System32
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Supported Encodings

The java.io.InputStreamReader, java.io.OutputStreamWriter, java.lang.String classes, and classes in the java.nio.charset package can convert between Unicode and a number of other character encodings. The supported encodings vary between different implementations of the Java Platform, Standard Edition 7 (Java SE 7). The class description for java.nio.charset.Charset lists the encodings that any implementation of the Java Platform, Standard Edition 7 is required to support.

Oracle's Java SE Development Kit 7 (Java SE 7) for all platforms (Solaris, Linux, and Microsoft Windows) and the Java SE Runtime Environment 7 (JRE 7) for Solaris and Linux support all encodings shown on this page. Oracle's JRE 7 for Microsoft Windows may be installed as a complete international version or as a European languages version. By default, the JRE 7 installer installs a European languages version if it recognizes that the host operating system only supports European languages. If the installer recognizes that any other language is needed, or if the user requests support for non-European languages in a customized installation, a complete international version is installed. The European languages version only supports the encodings shown in the following Basic Encoding Set table. The international version (which includes the lib/charsets.jar file) supports all encodings shown on this page.

The following tables show the encoding sets supported by Java SE 7. The canonical names used by the new java.nio APIs are in many cases not the same as those used in the java.io and java.lang APIs.

Basic Encoding Set (contained in lib/rt.jar)

Canonical Name for java.nio API | Canonical Name for java.io API and java.lang API | Description
IBM00858 | Cp858 | Variant of Cp850 with Euro character
IBM437 | Cp437 | MS-DOS United States, Australia, New Zealand, South Africa
IBM775 | Cp775 | PC Baltic
IBM850 | Cp850 | MS-DOS Latin-1
IBM852 | Cp852 | MS-DOS Latin-2
IBM855 | Cp855 | IBM Cyrillic
IBM857 | Cp857 | IBM Turkish
IBM862 | Cp862 | PC Hebrew
IBM866 | Cp866 | MS-DOS Russian
ISO-8859-1 | ISO8859_1 | ISO-8859-1, Latin Alphabet No. 1
ISO-8859-2 | ISO8859_2 | Latin Alphabet No. 2
ISO-8859-4 | ISO8859_4 | Latin Alphabet No. 4
ISO-8859-5 | ISO8859_5 | Latin/Cyrillic Alphabet
ISO-8859-7 | ISO8859_7 | Latin/Greek Alphabet (ISO-8859-7:2003)
ISO-8859-9 | ISO8859_9 | Latin Alphabet No. 5
ISO-8859-13 | ISO8859_13 | Latin Alphabet No. 7
ISO-8859-15 | ISO8859_15 | Latin Alphabet No. 9
KOI8-R | KOI8_R | KOI8-R, Russian
KOI8-U | KOI8_U | KOI8-U, Ukrainian
US-ASCII | ASCII | American Standard Code for Information Interchange
UTF-8 | UTF8 | Eight-bit Unicode (or UCS) Transformation Format
UTF-16 | UTF-16 | Sixteen-bit Unicode (or UCS) Transformation Format, byte order identified by an optional byte-order mark
UTF-16BE | UnicodeBigUnmarked | Sixteen-bit Unicode (or UCS) Transformation Format, big-endian byte order
UTF-16LE | UnicodeLittleUnmarked | Sixteen-bit Unicode (or UCS) Transformation Format, little-endian byte order
UTF-32 | UTF_32 | 32-bit Unicode (or UCS) Transformation Format, byte order identified by an optional byte-order mark
UTF-32BE | UTF_32BE | 32-bit Unicode (or UCS) Transformation Format, big-endian byte order
UTF-32LE | UTF_32LE | 32-bit Unicode (or UCS) Transformation Format, little-endian byte order
x-UTF-32BE-BOM | UTF_32BE_BOM | 32-bit Unicode (or UCS) Transformation Format, big-endian byte order, with byte-order mark
x-UTF-32LE-BOM | UTF_32LE_BOM | 32-bit Unicode (or UCS) Transformation Format, little-endian byte order, with byte-order mark
windows-1250 | Cp1250 | Windows Eastern European
windows-1251 | Cp1251 | Windows Cyrillic
windows-1252 | Cp1252 | Windows Latin-1
windows-1253 | Cp1253 | Windows Greek
windows-1254 | Cp1254 | Windows Turkish
windows-1257 | Cp1257 | Windows Baltic
Not available | UnicodeBig | Sixteen-bit Unicode (or UCS) Transformation Format, big-endian byte order, with byte-order mark
x-IBM737 | Cp737 | PC Greek
x-IBM874 | Cp874 | IBM Thai
x-UTF-16LE-BOM | UnicodeLittle | Sixteen-bit Unicode (or UCS) Transformation Format, little-endian byte order, with byte-order mark

Extended Encoding Set (contained in lib/charsets.jar)

Canonical Name for java.nio API | Canonical Name for java.io API and java.lang API | Description
Big5 | Big5 | Big5, Traditional Chinese
Big5-HKSCS | Big5_HKSCS | Big5 with Hong Kong extensions, Traditional Chinese (incorporating 2001 revision)
EUC-JP | EUC_JP | JISX 0201, 0208 and 0212, EUC encoding Japanese
EUC-KR | EUC_KR | KS C 5601, EUC encoding, Korean
GB18030 | GB18030 | Simplified Chinese, PRC standard
GB2312 | EUC_CN | GB2312, EUC encoding, Simplified Chinese
GBK | GBK | GBK, Simplified Chinese
IBM-Thai | Cp838 | IBM Thailand extended SBCS
IBM01140 | Cp1140 | Variant of Cp037 with Euro character
IBM01141 | Cp1141 | Variant of Cp273 with Euro character
IBM01142 | Cp1142 | Variant of Cp277 with Euro character
IBM01143 | Cp1143 | Variant of Cp278 with Euro character
IBM01144 | Cp1144 | Variant of Cp280 with Euro character
IBM01145 | Cp1145 | Variant of Cp284 with Euro character
IBM01146 | Cp1146 | Variant of Cp285 with Euro character
IBM01147 | Cp1147 | Variant of Cp297 with Euro character
IBM01148 | Cp1148 | Variant of Cp500 with Euro character
IBM01149 | Cp1149 | Variant of Cp871 with Euro character
IBM037 | Cp037 | USA, Canada (Bilingual, French), Netherlands, Portugal, Brazil, Australia
IBM1026 | Cp1026 | IBM Latin-5, Turkey
IBM1047 | Cp1047 | Latin-1 character set for EBCDIC hosts
IBM273 | Cp273 | IBM Austria, Germany
IBM277 | Cp277 | IBM Denmark, Norway
IBM278 | Cp278 | IBM Finland, Sweden
IBM280 | Cp280 | IBM Italy
IBM284 | Cp284 | IBM Catalan/Spain, Spanish Latin America
IBM285 | Cp285 | IBM United Kingdom, Ireland
IBM297 | Cp297 | IBM France
IBM420 | Cp420 | IBM Arabic
IBM424 | Cp424 | IBM Hebrew
IBM500 | Cp500 | EBCDIC 500V1
IBM860 | Cp860 | MS-DOS Portuguese
IBM861 | Cp861 | MS-DOS Icelandic
IBM863 | Cp863 | MS-DOS Canadian French
IBM864 | Cp864 | PC Arabic
IBM865 | Cp865 | MS-DOS Nordic
IBM868 | Cp868 | MS-DOS Pakistan
IBM869 | Cp869 | IBM Modern Greek
IBM870 | Cp870 | IBM Multilingual Latin-2
IBM871 | Cp871 | IBM Iceland
IBM918 | Cp918 | IBM Pakistan (Urdu)
ISO-2022-CN | ISO2022CN | GB2312 and CNS11643 in ISO 2022 CN form, Simplified and Traditional Chinese (conversion to Unicode only)
ISO-2022-JP | ISO2022JP | JIS X 0201, 0208, in ISO 2022 form, Japanese
ISO-2022-KR | ISO2022KR | ISO 2022 KR, Korean
ISO-8859-3 | ISO8859_3 | Latin Alphabet No. 3
ISO-8859-6 | ISO8859_6 | Latin/Arabic Alphabet
ISO-8859-8 | ISO8859_8 | Latin/Hebrew Alphabet
JIS_X0201 | JIS_X0201 | JIS X 0201
JIS_X0212-1990 | JIS_X0212-1990 | JIS X 0212
Shift_JIS | SJIS | Shift-JIS, Japanese
TIS-620 | TIS620 | TIS620, Thai
windows-1255 | Cp1255 | Windows Hebrew
windows-1256 | Cp1256 | Windows Arabic
windows-1258 | Cp1258 | Windows Vietnamese
windows-31j | MS932 | Windows Japanese
x-Big5-Solaris | Big5_Solaris | Big5 with seven additional Hanzi ideograph character mappings for the Solaris zh_TW.BIG5 locale
x-euc-jp-linux | EUC_JP_LINUX | JISX 0201, 0208, EUC encoding Japanese
x-EUC-TW | EUC_TW | CNS11643 (Plane 1-7,15), EUC encoding, Traditional Chinese
x-eucJP-Open | EUC_JP_Solaris | JISX 0201, 0208, 0212, EUC encoding Japanese
x-IBM1006 | Cp1006 | IBM AIX Pakistan (Urdu)
x-IBM1025 | Cp1025 | IBM Multilingual Cyrillic: Bulgaria, Bosnia, Herzegovinia, Macedonia (FYR)
x-IBM1046 | Cp1046 | IBM Arabic - Windows
x-IBM1097 | Cp1097 | IBM Iran (Farsi)/Persian
x-IBM1098 | Cp1098 | IBM Iran (Farsi)/Persian (PC)
x-IBM1112 | Cp1112 | IBM Latvia, Lithuania
x-IBM1122 | Cp1122 | IBM Estonia
x-IBM1123 | Cp1123 | IBM Ukraine
x-IBM1124 | Cp1124 | IBM AIX Ukraine
x-IBM1381 | Cp1381 | IBM OS/2, DOS People's Republic of China (PRC)
x-IBM1383 | Cp1383 | IBM AIX People's Republic of China (PRC)
x-IBM33722 | Cp33722 | IBM-eucJP - Japanese (superset of 5050)
x-IBM834 | Cp834 | IBM EBCDIC DBCS-only Korean
x-IBM856 | Cp856 | IBM Hebrew
x-IBM875 | Cp875 | IBM Greek
x-IBM921 | Cp921 | IBM Latvia, Lithuania (AIX, DOS)
x-IBM922 | Cp922 | IBM Estonia (AIX, DOS)
x-IBM930 | Cp930 | Japanese Katakana-Kanji mixed with 4370 UDC, superset of 5026
x-IBM933 | Cp933 | Korean Mixed with 1880 UDC, superset of 5029
x-IBM935 | Cp935 | Simplified Chinese Host mixed with 1880 UDC, superset of 5031
x-IBM937 | Cp937 | Traditional Chinese Host miexed with 6204 UDC, superset of 5033
x-IBM939 | Cp939 | Japanese Latin Kanji mixed with 4370 UDC, superset of 5035
x-IBM942 | Cp942 | IBM OS/2 Japanese, superset of Cp932
x-IBM942C | Cp942C | Variant of Cp942
x-IBM943 | Cp943 | IBM OS/2 Japanese, superset of Cp932 and Shift-JIS
x-IBM943C | Cp943C | Variant of Cp943
x-IBM948 | Cp948 | OS/2 Chinese (Taiwan) superset of 938
x-IBM949 | Cp949 | PC Korean
x-IBM949C | Cp949C | Variant of Cp949
x-IBM950 | Cp950 | PC Chinese (Hong Kong, Taiwan)
x-IBM964 | Cp964 | AIX Chinese (Taiwan)
x-IBM970 | Cp970 | AIX Korean
x-ISCII91 | ISCII91 | ISCII91 encoding of Indic scripts
x-ISO2022-CN-CNS | ISO2022_CN_CNS | CNS11643 in ISO 2022 CN form, Traditional Chinese (conversion from Unicode only)
x-ISO2022-CN-GB | ISO2022_CN_GB | GB2312 in ISO 2022 CN form, Simplified Chinese (conversion from Unicode only)
x-iso-8859-11 | x-iso-8859-11 | Latin/Thai Alphabet
x-JIS0208 | x-JIS0208 | JIS X 0208
x-JISAutoDetect | JISAutoDetect | Detects and converts from Shift-JIS, EUC-JP, ISO 2022 JP (conversion to Unicode only)
x-Johab | x-Johab | Korean, Johab character set
x-MacArabic | MacArabic | Macintosh Arabic
x-MacCentralEurope | MacCentralEurope | Macintosh Latin-2
x-MacCroatian | MacCroatian | Macintosh Croatian
x-MacCyrillic | MacCyrillic | Macintosh Cyrillic
x-MacDingbat | MacDingbat | Macintosh Dingbat
x-MacGreek | MacGreek | Macintosh Greek
x-MacHebrew | MacHebrew | Macintosh Hebrew
x-MacIceland | MacIceland | Macintosh Iceland
x-MacRoman | MacRoman | Macintosh Roman
x-MacRomania | MacRomania | Macintosh Romania
x-MacSymbol | MacSymbol | Macintosh Symbol
x-MacThai | MacThai | Macintosh Thai
x-MacTurkish | MacTurkish | Macintosh Turkish
x-MacUkraine | MacUkraine | Macintosh Ukraine
x-MS950-HKSCS | MS950_HKSCS | Windows Traditional Chinese with Hong Kong extensions
x-mswin-936 | MS936 | Windows Simplified Chinese
x-PCK | PCK | Solaris version of Shift_JIS
x-SJIS_0213 | x-SJIS_0213 | Shift_JISX0213
x-windows-50220 | Cp50220 | Windows Codepage 50220 (7-bit implementation)
x-windows-50221 | Cp50221 | Windows Codepage 50221 (7-bit implementation)
x-windows-874 | MS874 | Windows Thai
x-windows-949 | MS949 | Windows Korean
x-windows-950 | MS950 | Windows Traditional Chinese
x-windows-iso2022jp | x-windows-iso2022jp | Variant ISO-2022-JP (MS932 based)
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.doctree.EndElementTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.EndElementTree

  • Packages that use EndElementTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of EndElementTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type EndElementTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitEndElement(EndElementTree node, P p)

    • Uses of EndElementTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type EndElementTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitEndElement(EndElementTree node, P p)
      R | DocTreeScanner.visitEndElement(EndElementTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.EnhancedForLoopTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.EnhancedForLoopTree

  • Packages that use EnhancedForLoopTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of EnhancedForLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type EnhancedForLoopTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitEnhancedForLoop(EnhancedForLoopTree node, P p)

    • Uses of EnhancedForLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type EnhancedForLoopTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitEnhancedForLoop(EnhancedForLoopTree node, P p)
      R | TreeScanner.visitEnhancedForLoop(EnhancedForLoopTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Java Attach API Enhancements

  • Enhancements in Java SE 6
  • Enhancements in Java SE 5
  • Enhancements in Java SE 1.4
  • Previous Enhancements

Enhancements in Java SE 6

No changes to report.

Enhancements in Java SE 5.0

No changes to report.

Enhancements in Java SE 1.4

No changes to report.

Previous Enhancements

No changes to report.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JPDA Enhancements

Documentation Contents

Java Platform Debugger Architecture
Java SE 1.4 Enhancements

The version 1.4 family of the JDK includes the following JPDA enhancements:
  • Full Speed Debugging
  • Enable "HotSwap" Class File Replacement
  • Instance Filters
  • Support For Debugging Other Languages
  • VMDeathRequests

Full Speed Debugging

The Java HotSpot virtual machine now uses "full-speed debugging". In the previous version of HotSpot, when debugging was enabled, the program executed using only the interpreter. Now, the full performance advantage of HotSpot Technology is available to programs running with debugging enabled. The improved performance allows long running programs to be more easily debugged. It also allows testing to proceed at full speed and the launch of a debugger to occur on an exception:

        -Xrunjdwp:transport=dt_socket,server=y,onuncaught=y,launch=myDebuggerLaunchScript

For details on launch "onthrow" and launch "onuncaught", see Connection and Invocation Details. Setting a breakpoint only inhibits compilation (full speed execution) for the method containing the breakpoint. Execution reverts to the interpreter during some debug operations such as single-stepping and when method entry/exit or watchpoints are set.

As of version 1.4.1, full-speed debugging is available with both the Java HotSpot Client VM (default) and Java HotSpot Server VM (invoked with the -server command-line flag). In the JDK 1.4.0, full-speed debugging was available only with the Java HotSpot Client VM.

Enable "HotSwap" Class File Replacement

This new feature encapsulates the ability to substitute modified code in a running application through the debugger APIs. For example, one can recompile a single class and replace the old instance with the new instance.

This change was made to address these issues:

  • Tool (IDE) vendors want the ability to do fix-and-continue debugging. That is, while debugging, identify a problem, fix it, and continue debugging with fixed code.
  • Organizations deploying long running servers wish to be able to fix bugs without taking down the server.

HotSwap adds functionality to the Java Platform Debugger Architecture (JPDA) to allow a class to be updated while under the control of a debugger. The two central components of this functionality are RedefineClasses which replaces the class definitions and PopFrame which pops frames off the stack allowing a method which has been redefined to be re-executed.

In the reference implementation, this functionality is implemented at the Java Virtual Machine Debug Interface (JVMDI) layer and made available through the higher layers of JPDA - the Java Debug Wire Protocol (JDWP) and the Java Debug Interface (JDI).

Redefinition Functionality
JDI | VirtualMachine.redefineClasses(Map classToBytes)
JDWP | RedefineClasses (Cmd 18) in VirtualMachine (CmdSet 1)
JVMDI | RedefineClasses(jint classCount, JVMDI_class_definition *classDefs)

Pop Frame Functionality
JDI | ThreadReference.popFrames(StackFrame frame)
JDWP | PopFrames (Cmd 4) in StackFrame (CmdSet 16)
JVMDI | PopFrame(jthread thread)

All functionality at each layer is independently optional. The GetCapabilities function at the JVMDI layer; the CapabilitiesNew command at the JDWP layer; and the canRedefineClasses, canAddMethod, canUnrestrictedlyRedefineClasses, and canPopFrames, methods at the JDI layer describe what functionality is implemented.

The bug report associated with this change is 4287595.

Instance Filters

BreakpointRequest, MethodExitRequest, ExceptionRequest, StepRequest, WatchpointRequest and MethodEntryRequest classes now have the capability of adding instance filters by using the addInstanceFilter method. Instance filters restrict the events generated by a request to those in which the currently executing instance is the object specified.

Support For Debugging Other Languages

The Java Platform Debugger Architecture has been extended so that non-Java programming language source, which is translated to Java programming language source, can be debugged in the future. The table below describes the new APIs and APIs with comments that have changed. This information is based on the SourceDebugExtension.

Package | New APIs | APIs with Changed Comments
JVMDI | GetSourceDebugExtension |
JDWP - ReferenceType (2) Command Set | SourceDebugExtension Command (12) |
JDWP - VirtualMachine (1) Command Set | SetDefaultStratum Command (19) |
JDK - VirtualMachine I/F | void setDefaultStratum(String stratum) |
JDK - VirtualMachine I/F | String getDefaultStratum() |
JDI - ReferenceType I/F | String sourceNames(String stratum) | String sourceName()
JDI - ReferenceType I/F | String sourcePaths(String stratum) |
JDI - ReferenceType I/F | List allLineLocations(String stratum, String sourceName) | List allLineLocations()
JDI - ReferenceType I/F | List locationsOfLine(String stratum, String sourceName, int lineNumber) | List locationsOfLine(int lineNumber)
JDI - ReferenceType I/F | List availableStrata() |
JDI - ReferenceType I/F | String defaultStratum() |
JDI - ReferenceType I/F | String sourceDebugExtension() |
JDK - Method I/F | List allLineLocations(String stratum, String sourceName) | List allLineLocations()
JDK - Method I/F | List locationsOfLine(String stratum, String sourceName, int lineNumber) | List locationsOfLine(int lineNumber)
JDI - Location I/F |  | class comment (strata defined)
JDI - Location I/F | int lineNumber(String stratum) | int lineNumber()
JDI - Location I/F | String sourceName(String stratum) | String sourceName()
JDI - Location I/F | String sourcePath(String stratum) |
JDI - Location I/F | String sourcePath() |

VMDeathRequests

Using class VMDeathRequest, a request can be made for notification when the target VM terminates. When an enabled VMDeathRequest is satisfied, an EventSet containing a VMDeathEvent will be placed on the EventQueue.

Even without creating a VMDeathRequest, a single unsolicited VMDeathEvent will be sent with a suspend policy of SUSPEND_NONE.

This request would typically be created so that a VMDeathEvent with a suspend policy of SUSPEND_ALL will be sent. This event can be used to assure completion of any processing which requires the VM to be alive (e.g. event processing). Note: the unsolicited VMDeathEvent will still be sent.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JPDA Enhancements

Documentation Contents

Java Platform Debugger Architecture
Java SE 1.5 Enhancements

The version 5.0 family of the JDK includes the following JPDA enhancements:

  • Addition of JVMTI
  • JPDA now supports generics
  • JPDA now supports enums
  • JPDA now supports varargs
  • JPDA pluggable connections and transports
  • JDWP Allow machine to be specified on address param for server
  • Read-only subset of JDI
  • Tool to generate/analyze core files from a crashed JVM
  • Need a way to timeout or test for connection with LinsteningConnector.accept()

Addition of JVMTI

The Java Virtual Machine Tool Interface (JVMTI) is a new native programming interface for use by development and monitoring tools, which replaces JVMPI and JVMDI. It provides both a way to inspect the state and to control the execution of applications running in the Java virtual machine (VM). JVMTI is intended to provide a VM interface for the full breadth of tools that need access to VM state, including but not limited to: profiling, debugging, monitoring, thread analysis, and coverage analysis tools.

Note: JVMPI and JVMDI will be removed in the next major release of Java SE.

JPDA Now Supports Generics

Generics is a new feature in the Java programming langauge, and the JPDA interfaces now allow debuggers to access generic information. This change adds interface elements to the JDWP and JDI components of JPDA. These elements allow generic information to be accessed by JDI clients as Strings containing the actual contents of the Signature attributes from .class files.

JDWP changes

The following are new commands to JDWP. These are the similar to the previously-existing commands, but return generic signatures if they exist, in addition to the JNI signatures.

  • AllClassesWithGeneric: Similar to AllClasses but also returns the generic signature for each class
  • SignatureWithGeneric: Similar to the ReferenceType.Signature command but also returns the generic signature.
  • FieldsWithGeneric: Similar to the Fields command but also returns the generic signature for each field.
  • MethodsWithGeneric: Similar to the Methods command but also returns the generic signature for each method.
  • VariableTableWithGeneric: Similar to the VariableTable command but also includes a new generic signature value for each variable.

JDI changes

New methods:

  • LocalVariable.genericSignature()
  • ReferenceType.genericSignature()
  • TypeComponent.genericSignature()
  • Method.isBridge()

JPDA Now Supports Enums

Enumeration types are a new feature in the Java programming langauge, and the JPDA interfaces now allow debuggers to access information about enumeration types.

New methods:

  • com.sun.jdi.ClassType.isEnum()
  • com.sun.jdi.Field.isEnumConstant()

JPDA Now Supports Varargs

The ability to declare a method as accepting a variable number of agruments is a new feature in the Java programming langauge. The JDI now allows a debugger to query whether or not a method accepts a variable number of arguments. This change also modifies the three JDI methods that allow a method to be called to accept varargs.

New method in com.sun.jdi.Method:

  • boolean isVarargs();

Specification update for the following methods:

  • com.sun.jdi.Method.argumentTypes()
  • com.sun.jdi.Method.arguments()
  • com.sun.jdi.ClassType.invokeMethod
  • com.sun.jdi.ClassType.newInstance
  • com.sun.jdi.ObjectReference.invokeMethod

JPDA Pluggable Connections and Transports

The Java Debug Interface (JDI) previously lacked a provider interface to allow tool vendors to develop and deploy their own Connectors. A Connector is the means by which a Java debugger connects to a target virtual machine.

The JDK ships with 6 Connectors. Two of these are LaunchingConnectors, which are used to launch and establish a debugging session with a target VM. The other four Connectors encapsulate transports for remote debugging. The creation of these 6 Connectors was previously hardcoded into the Oracle JDI implementation of VirtualMachineManager and there was no means for tool vendors to develop or deploy additional Connectors.

Related to the above is that the Java Platform Debugger Architecture (JPDA) previously lacked a means for tool vendors to plug-in their own transport implementations. There was no supported way to debug over non-Oracle provided transports. The JDK ships with 2 transports - a TCP transport (for Solaris, Linux, and Windows) and a shared memory transport (Windows only).

There are two components to this enhancement:

  1. Extend the Java Debug Interface (JDI) with specification and a provider interface to allow 3rd party Connectors and Transport Services be developed and deployed
  2. Develop a VM/debuggee-side native interface to allow 3rd party transport libraries to be located and loaded by the debugging agent running in the VM

Specification updates for 5 existing classes/interfaces :

  • com.sun.jdi.Bootstrap
  • com.sun.jdi.VirtualMachineManager
  • com.sun.jdi.connect.AttachingConnector
  • com.sun.jdi.connect.ListeningConnector
  • com.sun.jdi.connect.Transport

Two new methods added com.sun.jdi.VirtualMachineManager:

  • VirtualMachine createVirtualMachine(Connection connection, Process process) throws IOException
  • VirtualMachine createVirtualMachine(Connection connection) throws IOException;

Four new classes :

  • com.sun.jdi.connect.spi.TransportService
  • com.sun.jdi.connect.spi.TransportService.Capabilities (inner class)
  • com.sun.jdi.connect.spi.TransportService.ListenKey (inner class)
  • com.sun.jdi.connect.spi.Connection

Two new exceptions :

  • com.sun.jdi.connect.TransportTimeoutException
  • com.sun.jdi.connect.spi.ClosedConnectionException

Native transport interface (defined by jdwpTransport.h)

New Connector arguments have been added as follows :

A "timeout" Connector argument has been added to the following Connectors (note that these are Connector names and not class names) :

  • com.sun.jdi.SocketAttach
  • com.sun.jdi.SocketListen
  • com.sun.jdi.SharedMemoryAttach
  • com.sun.jdi.SharedMemoryListen

The timeout argument is optional and specifies the attach or accept timeout (in milliseconds) to use when establishing a connection to the debuggee.

A "localAddress" Connector argument has been added to com.sun.jdi.SocketListen. This Connector argument specifies the local address to bind to when waiting to accept a connection from the debuggee.

Also, the options string to the JDWP agent has been amended to include a timeout option. The timeout argument specifies the timeout (in milliseconds) when establishing the connection to the debugger :

-agentlib:jdwp=...,...,timeout=<timeout>

In addition the address string for the dt_socket transport has been amended to take a local address when running in server mode. For example:

-agentlib:jdwp=transport=dt_socket,address=127.0.0.1:4000,server=y

indicates that the debugee bind to loopback address, port 4000 and wait for the debugger to connect.

JDWP Allow machine to be specified on address param for server

One of the JPDA options is the "address=" parameter, which has the format of:

JPDA Server: address=port

JPDA Client: address=machine:port

This change allows the server to accept a machine name, for cases where the JPDA server is running on a computer with more than one network card and address. The SunCommandLineLauncher, which is the default LaunchingConnector returned by Bootstrap.virtualMachineManager().defaultConnector(), now has a localAddress connector argument so that the local address can be specified. Also, the JDWP options string on the debugee-side can now accept a local address in addition to a port.

Read-only subset of JDI

When using JDI to debug a 'debuggee' that is unmodifiable (such as when the debuggee is represented by a corefile), the JDI client needs to know which JDI methods it can call and which it cannot. This change adds a method to the VirtualMachine interface that allows the JDI client to determine if that VM is read-only. It also defines various JDI methods as throwing a new exception if called on a read-only VM.

New method in com.sun.jdi.VirtualMachine.

  • boolean canBeModified()

New exception class:

  • com.sun.jdi.VMCannotBeModified.

The clause: @throws VMCannotBeModifiedException if the VirtualMachine is read-only - see {@link VirtualMachine#canBeModified()}. has been added to the specification of the following methods:

com.sun.jdi.ArrayReference

  • void setValue(int index, Value value)
  • void setValues(List values)
  • void setValues(int index, List values, int srcIndex, int length)

com.sun.jdi.ArrayType

  • ArrayReference newInstance(int length);

com.sun.jdi.ClassType

  • void setValue(Field field, Value value)
  • Value invokeMethod(ThreadReference thread, Method method, List arguments, int options)
  • ObjectReference newInstance(ThreadReference thread, Method method, List arguments, int options)

com.sun.jdi.ObjectReference

  • ArrayReference newInstance(int length);

com.sun.jdi.ClassType

  • void setValue(Field field, Value value)
  • Value invokeMethod(ThreadReference thread, Method method, List arguments, int options)
  • ObjectReference newInstance(ThreadReference thread, Method method, List arguments, int options)

com.sun.jdi.ObjectReference

  • void setValue(Field field, Value value)
  • Value invokeMethod(ThreadReference thread, Method method,
  • List arguments, int options)

com.sun.jdi.StackFrame

  • void setValue(LocalVariable variable, Value value)

com.sun.jdi.ThreadGroupReference

  • void suspend();
  • void resume();

com.sun.jdi.ThreadReference

  • void suspend();
  • void resume();
  • void stop(ObjectReference throwable);
  • void interrupt();
  • void popFrames(StackFrame frame)

com.sun.jdi.VirtualMachine

  • void redefineClasses(Map classToBytes);
  • void suspend();
  • void resume();
  • EventQueue eventQueue();
  • EventRequestManager eventRequestManager();
  • void exit(int exitCode);

Tool to generate/analyze core files from a crashed JVM

When a JVM crashes, developers want to be able to look at a core file and understand what their code was doing when the crash occured. JDI, the Java Debug Interface, defines interfaces for 'connectors'. A connector is an implementation of one of these interfaces. Connectors are used to establish a connection between a debugger process and a debuggee. Java SE ships with several connectors that allow a debugger process to launch a debuggee, attach to an already running debuggee, or listen for incoming connections from a debuggee which has not yet run. These connectors are not part of the JDI specification but are part of the implementation of JDI on a platform. Other vendors are free to include whatever connectors they choose. In addition, users themselves can create their own connectors.

This feature adds three new connectors to the Oracle implementation. Each connector has a set of arguments that the JDI user can/must set in order to use the connector.

The interface summary below lists the class names of these three new connectors. This solution uses a Solaris private interface in libproc.h.

This will add three new attaching connectors to our release of Java SE:

  • sun.jvm.hotspot.jdi.SACoreAttachingConnector
  • sun.jvm.hotspot.jdi.SAPIDAttachingConnector
  • sun.jvm.hotspot.jdi.SADebugServerAttachingConnector

These connectors will be contained in the list of connectors returned to a JDI client by the JDI methods:

  • VirtualMachineManager.allConnectors()
  • VirtualMachineManager.attachingConnectors()

These connectors are used by a JDI client in the same way that the other JDI attaching connectors are used.

The JDI VirtualMachine objects returned by these connectors' attach() methods are 'read-only'. This means that VirtualMachine.canBeModified() will return false. This in turn means that the methods defined in JDI as throwing VMCannotBeModifiedException if the VirtualMachine is read-only should not be called by the JDI client. These connectors can only be used to debug processes and corefiles that use the Oracle Hotspot Virtual Machine. These connectors are not available on Windows nor on Linux Itanium.

Need a way to timeout or test for connection with ListeningConnector.accept()

The method com.sun.jdi.connect.ListeningConnector.attach() previously waited indefinitely for a connection, with no way to set a timeout or interrupt the wait. This made it fairly dangerous to use in an integrated debugger. This change makes it possible to set a timeout, instantly test for a connection, or interrupt another thread.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JPDA Enhancements

Documentation Contents

Java Platform Debugger Architecture
Java SE 1.6 Enhancements

Following is a short summary of the enhancements to JPDA that have been added in Java SE 6. The documentation for these features is available in the JDI Specification.

Not shown here are the equivalent commands in JDWP. The documentation for these features is available in the JDWP Specification.

  • JVMDI has been deleted. See its replacement, JVM TI
  • heap walking
    • 5024119 Add ReferenceType.getAllInstances () method to JDI.
    • 5089849 Add support for backtracking reference graph.

    New methods:

              VirtualMachine:
           boolean canGetInstanceInfo();
           long[] instanceCounts(List<?extends ReferenceType?> refTypes);

         ReferenceType:
           List<ObjectReference> instances(long maxInstances);

         ObjectReference:
           List<ObjectReference> referringObjects(long maxReferrers);
  • 5024104 Allow access to Constant Pool in ClassType

    New methods:

  •
        VirtualMachine:
           boolean canGetClassFileVersion();
           boolean canGetConstantPool();

         ReferenceType:
           int majorVersion();
           int minorVersion();
           int constantPoolCount();
           byte[] constantPool();
  • 4836939 JDI add addSourceFileFilter to ClassPrepareRequestb

    New methods:

  •           VirtualMachine:
            boolean canUseSourceNameFilters();

          ClassPrepareRequest:
            void addSourceNameFilter(String sourceNamePattern);
  • 4490824 JDI: provide arguments when no debug attributes present

    New methods:

  •          StackFrame:
           List<Value> getArgumentValues();
  • 4195445 JDWP, JDI: Add return value to Method Exit Event

    New methods:

  •          VirtualMachine:
           boolean canGetMethodReturnValues();

         MethodExitEvent:
           Value returnValue();
  • 6175634 Allow early return from method

    New methods:

  •          VirtualMachine:
           boolean canForceEarlyReturn();

         ThreadReference:
           void forceEarlyReturn(Value value) throws InvalidTypeException,
                                              ClassNotLoadedException,
                                              IncompatibleThreadStateException;
  • 4401399 Request for breakpoints for monitor acquisitions and releases

    New methods:

  •          VirtualMachine
           boolean canRequestMonitorEvents();

         EventRequestManager:
           List<MonitorContendedEnterRequest> monitorContendedEnterRequests();
           List<MonitorContendedEnteredRequest> monitorContendedEnteredRequests();
           List<MonitorWaitRequest> monitorWaitRequests();
           List<MonitorWaitedRequest> monitorWaitedRequests();

    New classes:

           public interface MonitorContendedEnterRequest extends EventRequest
         public interface MonitorContendedEnteredRequest extends EventRequest
         public interface MonitorWaitRequest extends EventRequest
         public interface MonitorWaitedRequest extends EventRequest

         public interface MonitorContendedEnterEvent extends LocatableEvent
         public interface MonitorContendedEnteredEvent extends LocatableEvent
         public interface MonitorWaitEvent extends LocatableEvent
         public interface MonitorWaitedEvent extends LocatableEvent
  • 6230699 Need to be able to get the location at which a monitor was acquired

    New methods:

  •          VirtualMachine
           boolean canGetMonitorFrameInfo();

         ThreadReference
           List<MonitorInfo> ownedMonitorsAndFrames()
                           throws IncompatibleThreadStateException;

    New classes:

         public interface MonitorInfo extends Mirror
  • 4527279: Need a better way to find out the port number on which JPDA is listening

    New Connector:

  • com.sun.tools.jdi.ProcessAttach, with arguments pid and timeout. This allows a debugger to attach to a debuggee started in debug mode via process id instead of transport address.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


enhancements

Documentation Contents

Java Web Start enhancements in version 6

  • JNLP Specification addition of the <update> element with its "policy" and "check" attributes.

The new <update> element with its "policy" and "check" attributes is now supported. The update element describes the applications preferences on how Java Web Start should check for updates on the web, and what to do when it is known before launching that an update is available.
In the previous versions of Java Web Start, the <offline-allowed> element was overloaded to mean two things. First, it meant that the application was allowed to run in "offline" mode. (An application can be run in offline mode either from the command line by adding the "-offline" argument, or from the Cache Viewer.) Second, it meant that attempts to check for update before launching an application (when not run in offline mode) could time out. When a check for update times out, the application would be launched from the cache while the update check continued in the background.
With the advent of the <update> element and its check attribute in 6.0, the <offline-allowed> element no longer has this second meaning. The default values: <update check="timeout"/>. which is the same behavior as previous versions where <offline-allowed> was specified. For the behavior that previously used whenever <offline-allowed> was omitted, you need to specify <update check="always"/>. A third value <update check="background"/> can be specified to always immediately launch from the cache while spawning a check for update in the background. The second attribute, "policy", is used to determine what to do when it is known before starting the application that there is an update available. You can either always get the update, or prompt the user. The policy attribute values can be either "always" (this is default) , "prompt-update" or "prompt-run".

  • JNLP Specification relaxation of requirements for the DownloadService API.

In the previous versions, the URLs passed as arguments to all of the APIs were restricted to be URLs to resources listed in the jnlp file(s) of the running application. This restriction is changed such that there are no restrictions for signed and trusted code, and the restriction on untrusted code is not that it be listed in the jnlp file(s), but only that it be from the same codebase.
Further, URLs to jnlp file(s) themselves are allowed, so that calling DownloadService.removeResource() can now be used to remove a whole application from the cache, and DownloadService.loadResource() can be used to import an application.
One effect of this change is that resources not listed in any jnlp file can now be used in an application. For example, after determining the locale is set to en_xx, an application can then load resources_en_xx.jar using the DownloadService, without listing all the available resource jars in the jnlp file. (Allowing you to dynamically add support for more locales without changing the jnlp file).

  • Implementation of a SocketService

Another significant specification change is a clarification in the definition of the sandbox, that it is only the default sandbox, and that the implementation is free to prompt the user to allow actions that wouldn't be allowed by the sandbox. You already saw in 1.5.0 that this was done for printing, so that just by using the normal printing api in awt, you could expand the sandbox to allow the application to access the printer (if the user agreed). In 6.0 this is also done for socket connections, so that if an untrusted application attempts to connect to a url, the user can be prompted to allow the connection.

  • New <java> element in jnlp file to replace <j2se> element.

For jnlp files that will be used only with Java Web Start version 6.0 or later, the <java> element can be used to replace the <j2se> tag. (This is mainly because the Java Platform Standard Edition is no longer called j2se.) For backward compatibility, the <j2se> tag will continue to work. The <java> element will be identical to the <j2se> element..

  • The <association> element now may contain the <icon> and <description> sub-elements.

When creating file extension and mime type associations with your Java Web Start application, you can now specify a separate icon to be used for each association (as opposed to using the default icon for the application). Now, you can also specify a description.

  • Jar Indexing is fully supported now, and the JNLPClassLoader is now an instance of the URLClassLoader.

The JNLPClassLoader was rewritten to extend URLClassLoader. This gives several powerful advantages.
First, Jar Indexing is now fully supported. If you have several jar files, and create a jar index in the main jar file that indexes all the jar files, you can then mark each additional jar as lazy, and it will not be downloaded until and unless a resource or class in it is referenced. This makes the old part and package elements unnecessary for insuring that lazy jars are not downloaded prematurely.
Second, since the JNLPClassLoader now extends URLClassLoader, an Application can call getURLs() to get a list of the jar elements that are listed in the jnlp files (or have been downloaded using the DownloadService API, even if not listed in any jnlp file, see above).
Finally, the URL returned for calls to ClassLoader.getResource() is now the proper JAR URL of the item on the net. In previous versions, this URL returned was a jar url of the file url item in the cache. By extending URLClassLoader, the cached location (if it exists) is meaningless, and it allows Java Web Start to operate without caching.

  • Enhanced icon support.

Java Web Start now supports two new icon formats, ".png", and ".ico". This allows you to specify an icon that will not need to be translated into a different format depending on its use. You can also now specify kind="shortcut", and Java Web Start will now honor the width and height hints. This means if you specify:
<icon kind="shortcut" href="menushortcut.ico" width="16" height="16"/>
<icon kind="shortcut" href="desktopshortcut.ico" width="32" height="32"/>
you can specify separate images for any desktop and menu shortcuts that are created. (note: for desktop shortcuts, Java Web Start will use the icon whose size is closer to 32X32, and for menu shortcuts Java Web Start will use the icon whose size is closer to 16X16 )

  • Enhanced support for Add/Remove program entries on Windows.

The Windows Add/Remove program entries for Java Web Start applications will now include the publisher, publisher web site, install date, and application icon from the information block of the jnlp file.

  • Desktop shortcut tooltips.

Desktop shortcuts created by Java Web Start will now use the <description> element in the jnlp file to create a toolkit describing the application.

  • JNLPDownloadServlet enhancements.

The JnlpDownloadServlet now contains both a $$hostname and a $$site macro. The $$hostname macro is expanded to contain the host name. The $$site macro is expanded to contain the web site address without the WAR context portion.

  • The list of safe vm args and safe properties has been expanded.

See the developers guide for the current list of safe properties and vm args.

  • Several Command Line Interface (CLI) items have been changed or added. See the developers guide for the current Javaws CLI.

Enhancements Common to Java Web Start and Java Plug-in

  • All dialogs have been redesigned to be more user friendly.

All of the dialogs and screens shown by Java Web Start and Java Plug-in have been redesigned with help from the User Experience team to be more user friendly, intuitive, and accessible.

  • DownloadEngine and cache consolidation and redesign.

The entire caching mechanism and download engine has been redesigned and consolidated between Java Web Start and Java Plug-in.
This brings several new features to Java Web Start, previously available only in Java Plug-in and vice versa.

  • Caching can be disabled now entirely via the Java Control Panel.

  • The cache max size set in the JCP is now honored in Java Web Start, and a cleanup thread may be started by Java Web Start to removed LRU items from the cache when it is approaching the max size set by the user.
  • The "cache-control: no-cache" HTTP header is now supported. "no-cache" means cached contents cannot be used without re-validation. When the no-cache directive is used , an update check is always made to make sure the cached content is the same as the server copy pointed to, by the resource URL. If so, cached copy can be used. If not, server copy will be downloaded. Expiration field is ignored, which means that even if the cached resource is not expired yet, update check will still be performed.
  • The expiration-date will be honored. If a downloaded resource contains an expiration date, it will not be used after that date.

Note: The format of the cache is completely changed and should never be assumed. Any existing code that assumed the previous format of the cache, for either Java Web Start or Java Plug-in will no longer work. Existing applications in the Java Web Start cache will be upgraded and converted to the new cache format the first time you run a Java Web Start application, or if you launch the cache viewer using "javaws -viewer". Likewise, the system cache will be upgraded and converted to the new format the first time you launch Java Web Start in system mode, or if you just launch "javaws -system".

  • The Java Console is now excluded from modality.

By using the new modality features added by AWT in Java 6, you can interact with the Java Console even when the Application displays a modal Dialog.

  • New support for OCSP/CRL

Java Web Start and Java Java Plug-in support CRL (Certificate Revocation Lists) and OCSP (Online Certificate Status Protocol) for verifying the certificates.

  • New Support for SSL/TSL

An Option has been added to the Java Control Panel to select the default SSL handshaking protocol.
The default is set to SSLv3 and SSLv2, but then user or enterprise can change it to TSL.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Networking Features

Documentation Contents

Networking Features and Enhancements

in Java SE version 1.4

IPv6 (Internet Protocol version 6)

Java SE 1.4 supports IPv6 in TCP and UDP-based applications, including multicast, and will support most end-user applications in use today. See the IPv6 User Guide.

HTTP Digest Authentication

The HTTP digest authentication implementation has been updated to support proxies as well as origin servers, and has also been updated to provide all capabilities defined in RFC2617, except for the auth-int mode.

A number of system properties have been added which modify the behavior of the digest authentication mechanism. These are identified in the Networking Properties document.

Unconnected/Unbound Socket Support

Allows more flexible socket creation, binding, and connection. Enables manipulation of socket options before establishing or accepting connections. In addition a timeout can be specified when establishing a connection.

New class javax.net.ssl.SSLSocket is a subclass of java.net.Socket that provides security through encryption. The mechanism is called the Java Secure Socket Extension (JSSE), and it provides encryption for data sent via sockets. See the JSSE Reference Guide for further information.

Connected UDP Socket Support

The DatagramSocket.connect method now establishes the address association at native level. Where supported, this allows an application to have visibility of ICMP port unreachable messages as an indication that the remote application is unavailable.

Uniform Resource Indentifier (URI)

Class java.net.URI is new in Java SE 1.4. It allows URI construction and parsing without the presence of a protocol handler, which is not possible with the URL class. The URI class is compliant with RFC 2396 and RFC 2732.

FTP Protocol Handler

Significant overhaul to make the functionality conform as much as possible to the current standards (RFC 1738 and 959). This enhancement fixes several bugs associated with FTP functionality. For example, passive mode for FTP works in Java SE 1.4.

JNDI DNS SP Support in InetAddress

This enhancement in class java.net.InetAddress enables applications to configure a pure Java name service provider by using a DNS name service provider through JNDI. See JNDI DNS service provider settings in the Network Properties document for information on enabling this support.

URLEncoder and URLDecoder Improvements

Methods URLEncoder.encode(String s, String enc) and URLDecoder.decode(String s, String enc) have been added to enable applications to use other character encoding/decoding schemes.

TCP Out-of-Band Data

Two new methods in class java.net.Socket, sendUrgentData() and getOOBInline(), provide limited support for TCP urgent data for support certain legacy applications. Urgent data may be sent on any TCP socket. However, only partial support for receiving urgent data is provided.

SOCKS

Full V5 (RFC 1928) & V4 TCP support with autonegociation with the proxy of which version to use. See the SOCKS protocol support settings in the Network Properties document for information about using properties to specify the SOCKS proxy server.

NetworkInterface

Class java.net.NetworkInterface is new in Java SE 1.4. It allows enumeration of interfaces and addresses. This new class should be useful to applications deployed on multihomed and machines with multiple network interfaces.

Other Major Improvements

Java SE 1.4 also offers the following.

  • Improved Http streaming performance.
  • Request and response headers processing functionality in the form of these new methods in class java.net.URLConnection"

    addRequestProperty
    getRequestProperties
    getHeaderFields

  • Improved error handling implementation for method HttpURLConnection.getErrorStream().

New Classes

Here are links to the API specifications for the new classes and exceptions in the java.net package.

  • Inet4Address
  • Inet6Address
  • InetSocketAddress
  • NetworkInterface
  • SocketAddress
  • URI
  • PortUnreachableException
  • SocketTimeoutException
  • URISyntaxException
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Image I/O Enhancements in Java SE 6.0

Major Features
  • A writer plug-in for the GIF image format
  • New methods for file formats filtering
Fixed Bugs
  • API and doc changes
  • BMP plugin improvements
  • Performance and resource management
  • Robustness
  • Quality
  • Miscellaneous

Major Features

A writer plug-in for the GIF file format

While reading capabilities for the GIF file format have been available since Java SE 1.4, the com.sun.media.imageio.plugins.gif package lacked a writer. The newly added GIF image writer enables writing images which satisfy the following requirements:

  • The number of bands is 1
  • The number of bits per sample is not greater than 8
  • The size of a color component is not greater than 8

Additionally, the GIF images writer supports the animated GIF images creation through the standard methods defined in the ImageWriter class. See more details about the GIF images writer in the Standard plug-in for GIF image format notes.

New methods for file formats filtering

Two new methods were introduced in the ImageIO class that obtain file suffixes to be filtered. The getReaderFileSuffixes() and getWriterFileSuffixes methods return an array of Strings listing all of the file suffixes associated with the formats recognized by the current set of registered readers and writers.

Fixed Bugs

API and doc changes

4953566 The mark() or reset() methods of the ImageInputStream class do not work properly with PNG ImageReader:

The following note was added to the ImageInputStream class specification to clarify that ImageReader classes are allowed to call the flushBefore() as part of the decoding process:

Note that it is valid for an ImageReader to call flushBefore as part of a read operation. Therefore, if an application calls the mark prior to passing that stream to an ImageReader, the application should not assume that the marked position will remain valid after the read operation has completed.

5068322 The javax.imageio.plugins.jpeg.JPEGQTable.toString() method produces incorrect description:

The toString() method of the JPEGQTable class in the package javax.imageio.plugins.jpeg was supposed to return a String object containing the values of the table, but instead repeated only the first line of the table. The performed fix eliminate this error.

6359957 Wrong doc URL reference for PNG specification:

The link to the PNG specification in the javax.imageio.metadata package was corrected to the following URL:

http://www.libpng.org/pub/png/spec/

6457035 javadoc for ImageInputStreamImpl.read() method is missing:

The ImageInputStreamImpl.java file had a missing '*' character at the beginning of the javadoc for the abstract read() method definition.The fix fills in the missing character.

BMP plugin improvements

6294920 The BMPImageReader class fails to read 3BYTE_BGR images encoded using BMP Writer with BI_JPEG compression:

While attempting to write an image of the BI_JPEG compression type, the java.io.EOFException was thrown by the BMPImageReader class. The problem was that the BMPImageReader class did not process embedded images both of BI_JPEG and BI_PNG types. To resolve this problem, the embedded image handling is moved to separate code.

6297016 Output BMP image is distorted when writing TYPE_3BYTE_BGR buffered image with BI_BITFIELDS compression:

While attempting to write a buffered image of the TYPE_3BYTE_BGR type to a file using the BMPWriter class and the BI_BITFIELDS compression type, the output image was distorted and unusable. This problem was caused by the bitfileds masks which were applied to a bmp image. However, an image data layout was not changed according to the BMP format requirements. To fix this problem the writePixels() method is used to copy image data correctly.

5076878 ImageIO BMP Writer writes 32 bit files for 24 bit images:

The ImageIO.write method presented a BMP file as a 32 bit image even if the source image had 24 bits per pixel presentation. The fix enables the writePixels procedure whenever the number of bits per pixel is smaller than the size of a databuffer type (for example, with TYPE_INT_RGB, the actual number of bits per pixel is 24 while the size of the databuffer type is 32).

6332480 The BMPReader class fails to read the TYPE_BYTE_GRAY image encoded by the BMPWriter class with BI_RLE8 compression:

The BMPReader class did not properly read the TYPE_BYTE_GRAY image written with the BMPWriter class using the BI_RLE8 compression. The problem was that the RLE decoding procedures (both RLE4 and RLE8) mistakenly used the width of the destination region instead of the height to calculate the range of image lines for copying. The performed fix uses the height of the destination region to calculate the range.

6399660 Using subsampling with compression alters the colors for some of the image types for BMP:

While using all the supported compression types for BMP, different affects on image were detected including blurring, a different color appearance, and slight image corruption. The performed fix separates processing BI_RGB compression and BI_RGB compression as follows:

  • For BI_RGB compression the BGR order of raster data should be used (except the case of 16bpp images where RGB data order is defined by the BMP spec)
  • For BI_BITFIELDS compression the order of raster data should be defined using corresponding masks. The RGB order of raster data is used for the default bitfields masks.

Performance and resource management

6299405 The ImageInputStreamImpl class still uses the finalize() method which causes the java.lang.OutOfMemoryError:

The finalize() method had to be emptied and its functionality (closing the stream) must be replaced with a more prompt mechanism. The finalize() method cannot be easily emptied at the ImageInputStreamImpl level, since third-party IISI subclasses may rely on the finalize() method calling their close() method as per the spec. However, for ImageInputStreamImpl subclasses under Oracle control, the finalize() methods can be emptied. The Java2D Disposer mechanism is used instead.

6266748 The JPEGImageWriter.write() method makes a copy of the raster:

The write() method of the JPEGImageWriter class contained memory-inefficient code. The suggested fix helps to improve performance for simple rendered images.

6336804 The javax.imageio.ImageIO class can handle leaks in some methods:

Some of the read() and write() convenience methods in the javax.imageio.ImageIO class did not properly close streams and dispose reader or writer instances in a try and finally blocks. As a fix the appropriate notes were added to each method's javadocs indicating whether it is the caller's responsibility to close the provided stream or not.

6347575 FileImageInputStream.readInt() and similar methods are inefficient:

Calling the read() method of the FileImageInputStream 4x was much more expensive than making a single call to the read(byte[]) method with a cached byte array. This fact had a profound impact on performance of reading small PNG and other images. The fixes were performed for the readShort() and readInt() methods of the ImageInputStreamImpl class.

6348744 The PNGImageReader class should skip metadata if the ignoreMetadata flag has the true value:

Before JDK 6, the PNGImageReader class read all image metadata, even if the ignoreMetadata flag was set. The fix reduces overhead and improves performance when reading small PNG images by skipping metadata blocks if the ignoreMetadata flag is true.

6354056 The JPEGImageReader class could be optimized:

The JPEG image reader copied decoded data into memory, but not in an optimized way. The performed fix improves this operation by using the memcpy() method instead of copying one byte at a time.

6354112 Increase compiler optimization level for libjpeg to improve runtime performance:

The libjpeg library in the JDK was built with default compiler optimization flags. The values of these flags are increased to a higher level to enable the native IJG JPEG libraries to run faster.

6404011 IllegalArgumentException: "Invalid ICC Profile Data" when reading a certain JPEG image:

This bug was an unchecked exception and could cause a system crash on some platforms. The fix catches the IllegalArgumentException, which is thrown by ICC_Profile, and handles images without taking into account invalid color profiles.

Robustness

6291034 The IFileCacheImageInputStream and FileCacheImageOutputStream should avoid using the File.deleteOnExit method:

Both the FileCacheImageInputStream and FileCacheImageOutputStream classes used the functionality of the deleteOnExit method of the File class. The fix has replaced the File.deleteOnExit() functionality with the shutdown hook that closes streams that are still open before the VM shutdown.

4892630 The ImageReader class does not validate the image index which is passed to some of the methods:

The getWidth(imgIndex), getHeight(imgIndex), and getAspectRatio(imgIndex) methods of the ImageReader class did not throw the IndexOutOfBoundsException if the given PNG image index was out of range. The performed fix resolves this issue by throwing the exception appropriately.

4895547 JPEGImageMetadata obtained from reader throws NullPointerException when calling the mergeTree() method:

The list of parent attributes did not contain attributes related to the child node and this fact caused the NullPointerException in the MarkerSegment.getAttributeValue() method while trying to get child related attribute. The performed fix obtains the attribute list from the child node.

4528643 Native JPEG code makes JNI calls in scope of GetPrimitiveArrayCritical:

Running any application that reads or writes JPEG images with the non-standard -Xcheck:jni flag caused the following error in several methods of the JPEGImageReader class:

Calling other JNI functions in the scope of Get/ReleasePrimitiveArrayCritical or Get/ReleaseStringCritical

In the fix, the affected methods are surrounded with the RELEASE/GET_ARRAYS macros.

5076692 Installed Extensions Image I/O reader-writer plug-ins unusable in applet context:

The problem was that the imageio registry initialization code did not have read access to jars in the java.ext.dirs when the registry code was called from applet context. Therefore, the imageio plugins installed to java.ext.dirs were not available in case of applets. The fix idea is to register plugins from java.ext.dirs in the privileged action block.

6342404 The ImageIO plugin failure causes all readers to fail:

Removing an ImageIO plugin's code from the classpath, but still including an entry for the plugin's ImageReader in META-INF/services made using any of the ImageIO plugins impossible. To fix this bug, a 'try and catch' block was added to the IIORegistry.registerApplicationClasspathSpis() method to catch the ServiceConfigurationError.

6395551 Setting the destination type to type specifier returned by redr.getImageTypes() throws exception for JPG:

The problem was that a new ColorSpace instance was re-created for embedded color profiles whenever an image header was read. In addition, there was no means for correct comparison of ColorSpace and ICC_Profile classes. This omission made comparing instances of ImageTypeSpecifier class impossible. The proposed workaround for this problem is as follows: to detect the case when the iccCS instance contains the same profile data as a newly read. If so, the 'old' instance is left; otherwise (if the profile data seems to be different) a new color space instance is created for the embedded color profile.

6399616 PIT: JPGReader throws an exception when using the TYPE_CUSTOM TypeSpecifier returned by the Reader.getImageTypes method:

The regression was caused by the fix for 4705399, where color conversion was removed (JPEGImageReader.java lines 783 -786) because it caused extra color conversion for images with embedded color profiles. However, this conversion was required when the destination type defined different color spaces for images that do not contain embedded profiles. The fix for this case converts image data from sRGB (produced by the decoder) to the color space used in the destination image.

Quality

5028259 Setting the destination image type for jpeg images increases the size of the result file:

If the write parameter with the destination type was used explicitly to write a jpeg image, then the size of the result file was bigger than if the same destination type was used implicitly. The problem was revealed when the destination type was specified but the corresponding metadata object was not specified. The fix creates the metadata object using the given destination type in order to build a SOF marker object, which will be used to change the default values of the QtableSelectors.

4881314 ImageIO does not correctly read certain standard JPG files:

The ImageIO incorrectly reads some JPG files. The result was a red or green image that looked like a photographic negative. The fix eliminates color space conversion for EXIF images. To detect EXIF images, the check for the APP1 marker in the image header is added.

5098176 Some PNG images fail to load with the ImageIO class:

The PNGImageReader failed to create the ImageTypeSpecifier instance corresponding to the indexed PNG image if the length of the image palette in smaller than 2 bitDepth. To avoid this limitation new palette arrays of the appropriate power of 2 size were created. These arrays are padded with the last value from original arrays in order to avoid the appearance of colors that do not exist in the original palette.

6372769 The ImageIO.read method improperly decodes Nikon Jpegs:

The ImageIO jpeg reader performed extra color conversion if an image contained the embedded color profile. The bug was fixed by removing the extra color conversion operation.

Miscellaneous

4972087 Quality Desc and Quality Values arrays are of the same length for JPG:

The JPEGImageWriteParam class was updated so that the getCompressionQualityValues() method returns an array whose length is one larger than the array returned by getCompressionQualityDescriptions(), as per the specification.

6195593 REGRESSION: The javax/imageio/IRPTest.java file fails:

The problem was caused by the fix for the bug 5039494. Starting with this fix, the ImageReader.computeRegion() method was used to calculate the destination region. In order to avoid discrepancies between calculated destination regions and destinations offset from the parameter, the destinationOffset is updated according to the calculated values.

6304433 Test bug: the regression test for the bug 6291034 fails on all platforms:

The regression test failure was caused by the creation of an output image file. This file was created after counting the existing files in the work directory and was not deleted on regression test finish. So, after regression test execution, the work directory always contained one extra file, although all temporary files were deleted upon VM exit. The solution is to use byte array input or output streams instead of file input or output streams in order to avoid creating extra files in the work directory.

6356926 PIT: The regression test javax/imageio/stream/DeleteOnExit.sh is failing:

The problem was caused by the fix for the bug 6299405. The affected code is fixed and the corresponding comment has been added.

6459309 The NoAPP0Test.java regression test failed on all platforms:

The difference in pixel values is caused by using new version of sRGB profile that was updated as part of fix for 6279846. New profile was integrated in the b92 build.

6363748 The close() method of the FileCacheImageInputStream class fails:

The problem was caused by the fix for the bug 6299405. As a part of that fix the FileCacheImageInputStream.close() method was changed so that it nulled out its reference to the cache object. To eliminate this issue the FCIIS.read() method is updated to call the checkClosed() method as it is supposed to do.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Enhancements in Java SE 7

The following topics are covered:

  • XRender-Based Rendering Pipeline
  • Support for OpenType/CFF Fonts
  • TextLayout now Supports Tibetan Script
  • Better Support for Linux Fonts

XRender-Based Rendering Pipeline

A new XRender-based Java 2D rendering pipeline is supported for modern X11-based desktops, offering improved graphics performance. The pipeline is disabled by default, but may be enabled by setting the command line property -Dsun.java2d.xrender=true. Older X11 configurations may not be able to support XRender. The verbose form, -Dsun.java2d.xrender=True, can be used to enable a message to stdout indicating whether the pipeline was actually enabled.

This flag is listed in the System Properties for Java 2D Technology page.

Support for OpenType/CFF Fonts

The JDK now enumerates and displays installed OpenType/CFF fonts through methods such as GraphicsEnvironment.getAvailableFontFamilyNames; these fonts are also recognized by the Font.createFont method. See Selecting a Font in The Java Tutorials.

TextLayout Support for Tibetan Script

The TextLayout class supports Tibetan script.

Support for Linux Fonts

For Solaris and Windows, the logical fonts for the JDK are statically specified in the fontconfig.properties file. On various implementations of Linux, there is no assurance of the presence of particular fonts to support particular locales. As of Java SE 7, libfontconfig is used to select fonts to use for the logical fonts for "unrecognized" Linux platforms. See Fontconfig for more information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents

Java™ Virtual Machine Enhancements

Enhancements in Java SE 1.4.2

  • Runtime Performance

    The following are enhancements to runtime performance in 1.4.2. Also see Virtual Machine release notes for issues.

    • The interpreter-only Itanium version of 1.4.1 has been enhanced by the addition of the server compiler. Performance is up to thirty times faster than for 1.4.1.
    • The performance of applications that make heavy use of Class.forName and related methods has been significantly improved.
    • Java Native Interface usage checking via the -Xcheck:jni switch is more extensive and robust than in 1.4.1.
    • Third-party memory managers now work properly when using JVMPI and JVMDI.

  • Client HotSpot Compiler

    The following are enhancements to the client HotSpot compiler in 1.4.2. Also see Virtual Machine release notes for issues.

    • Improvements in compile speed and footprint.

  • Server HotSpot Compiler

    The following are enhancements to the server HotSpot compiler in 1.4.2. Also see Virtual Machine release notes for issues.

    • Use of SSE and SSE2 instructions on IA32 platforms when they are supported by the processor and operating system.
    • Faster integer division by constants.
    • Faster floating-point division by powers of 2.
    • Faster NullPointerException handling.

Enhancements in Java SE 1.4.1

  • Java SE 1.4.1 is available in versions that support the 64-bit Intel Itanium processor on Linux Red Hat 7.2 and Windows XP 64-bit edition. Look for the downloads for these versions on the Java SE 1.4.1 download page.

    In this release, these 64-bit versions have the following limitations.

    • Applications can be run only in interpreted mode. The platform will run in interpreted mode by default, with no need to supply the -Xint flag on the command line when launching an application. When using the 64-bit versions of the Java SE 1.4.1 platform, the command java MyApp will launch and execute MyApp by interpreting the bytecode. Java HotSpot-technology-based dynamic compilers for 64-bit support is planned for a future release of the Java SE platform.
    • The 64-bit versions of Java SE 1.4.1 do not include the Java Plug-in and Java Web Start products.
    • The 64-bit versions of Java SE 1.4.1 do not have an installer application. These versions are available only as a tar bundle.
    The 32-bit versions of the Java SE 1.4.1 will not work on Intel Itanium machines.
  • A deadlock detection utility has been added to the Java HotSpot VM. The utility is invoked by a Ctrl+\ on the command line while an application is running. The utility detects Java-platform-level deadlocks, including locking done from the Java Native Interface (JNI), the Java Virtual Machine Profiler Interface (JVMPI), and Java Virtual Machine Debug Interface (JVMDI).

    When invoked, the utility displays a thread dump to standard out and indicates any Java-platform-level deadlocks it detects. Refer to this sample output. If the application is deadlocked because two or more threads are involved in a cylce to acquire monitors, then the list of such threads and monitors involved in the deadlocks are displayed. Note, however, that this will not find deadlocks involving threads waiting on monitors on which no signal will be forthcoming.

Enhancements in Java SE 1.4.0

  • Signal chaining
  • Error-reporting mechanism
  • The new -Xloggc:file option reports on each garbage-collection event, as with -verbose:gc, but logs this data to file. In addition to the information -verbose:gc provides, each reported event is preceeded by the time (in seconds) since the first garbage-collection event.
  • Beginning with J2SDK 1.4.0, the Classic Virtual Machine is no longer shipped as part of the Java 2 SDK. (On Solaris platforms, the Classic VM was removed in J2SDK 1.3.0.) If you have been running your applications on the Classic VM by using the -classic command-line option, you will need to use either the Java HotSpot Client VM (invoked by default or by using the -client option) or Java HotSpot Server VM (invoked with the -server option). Attempting to launch an application with the -classic option will result in this message: Error: Classic VM no longer supported.

  • The Solaris-SPARC platform edition of J2SDK 1.4.0 will support 64-bit operation on 64-bit Sparc-v9 platforms when using the Java HotSpot Server VM. With a 64-bit address space, more than four gigabytes of heap memory is available. The Java HotSpot Server VM includes support for both 32-bit and 64-bit operations, and users can select either 32-bit or 64-bit operation by using command-line flags -d32 or -d64, respectively.
    • Users of the Java Native Interface will need to recompile their code to be able to run it on the 64-bit VM.
    • There is no 64-bit support for the Java HotSpot Client VM. Only the Java HotSpot Server VM provides for optional 64-bit operation.
    • Users must install 64-bit Solaris support in order to run the virtual machine in 64-bit mode.
    • On older Sparcv9 systems, users must modify the file /platform/sun4u/boot.conf in order to enable 64-bit programs. See the text in the boot.conf file for more information.
  • The new -Xcheck:jni command-line option performs additional checks for Java Native Interface (JNI) functions. Specifically, the Java Virtual Machine validates the parameters passed to the JNI function as well as the runtime environment data before processing the JNI request. Any invalid data encountered indicates a problem in the native code, and the Java Virtual Machine will terminate with a fatal error in such cases. Expect a performance degradation when this option is used.
  • The Java SE 1.4.0 platform accepts class file versions in the range 45.3 to 48.0.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Swing API changes in JDK 5.0

The API changes in Swing for Java SE 5.0 are broken down into the following sections:

  1. Major Changes
  2. Text Changes
  3. Miscellaneous Changes
  4. Incompatibilities

Major Swing Changes

4607364: Improve default look and feel of Swing

Description:

This is the most visible change to Swing in 5.0. If you use the Java look and feel your application will automatically get a new look, called Ocean, in 5.0. Ocean was designed with compatibility in mind so that we did not change the preferred size of any of the widgets, only the look and a small portion of the feel has changed. The old look can be obtained by setting the system property swing.metalTheme=steel.

Ocean is implemented as a custom MetalTheme that is currently private. The advantage of this approach is that if you have created a custom MetalTheme you will not be affected at all by Ocean, that is, your application will look as it did in 1.4.

Specification

Disabled Icons for AbstractButton subclasses are now generated from the UI. This resulted in revising the specification of getDisabledIcon to:

    /**
     * Returns the icon used by the button when it's disabled.
     * If no disabled icon has been set this will forward the call to
     * the ui to construct an appropriate disabled Icon.
     * <p>
     * Some types of look and feel might not render the disabled Icon, in which
     * case they will ignore this.
     *
     * @return the <code>disabledIcon</code> property
     * @see #getPressedIcon
     * @see #setDisabledIcon
     * @see javax.swing.plaf.ButtonUI#getDisabledIcon
     */
    public Icon getDisabledIcon();

And adding the method getDisabledIcon to ButtonUI.

    /**
     * Returns the icon to display when the developer has not specified
     * a disabled icon.
     * <p>
     * Some look and feels might not render the disabled Icon, in which
     * case they will ignore this.
     *
     * @param button AbstractButton requesting the Icon
     * @return Disabled icon, or null.
     * @see javax.swing.AbstractButton#setIcon
     * @see javax.swing.AbstractButton#setDisabledIcon
     * @throws NullPointerException if <code>button</code> is null
     * @since 1.5
     */
    public Icon getDisabledIcon(AbstractButton button);

To customize the look of disabled icons for JButton MetalButtonUI will override getDisabledIcon.

    /**
     * Returns the icon to display when the button is disabled.
     *
     * @param button AbstractButton requesting the Icon
     * @return Disabled icon, or null.
     * @see javax.swing.AbstractButton#setIcon
     * @see javax.swing.AbstractButton#setDisabledIcon
     * @throws NullPointerException if <code>button</code> is null
     * @since 1.5
     */
    public Icon getDisabledIcon(AbstractButton button);

To customize the look of JComboBox MetalCombBoxUI will override the following methods:

    /**
     * If necessary paints the currently selected item.
     *
     * @param g Graphics to paint to
     * @param bounds Region to paint current value to
     * @param hasFocus whether or not the JComboBox has focus
     * @throws NullPointerException if any of the arguments are null.
     * @since 1.5
     */
    public void paintCurrentValue(Graphics g, Rectangle bounds,
                                  boolean hasFocus);

    /**
     * If necessary paints the background of the currently selected item.
     *
     * @param g Graphics to paint to
     * @param bounds Region to paint background to
     * @param hasFocus whether or not the JComboBox has focus
     * @throws NullPointerException if any of the arguments are null.
     * @since 1.5
     */
    public void paintCurrentValueBackground(Graphics g, Rectangle bounds,
                                            boolean hasFocus);

To customize the look of JButton MetalButtonUI will override the following methods:

    /**
     * If necessary paints the background of the component, then
     * invokes <code>paint</code>.
     *
     * @param g Graphics to paint to
     * @param c JComponent painting on
     * @throws NullPointerException if <code>g</code> or <code>c</code> is
     *         null
     * @see javax.swing.plaf.ComponentUI#update
     * @see javax.swing.plaf.ComponentUI#paint
     * @since 1.5
     */
    public void update(Graphics g, JComponent c);

To customize the look of JMenuBar metal will now provide MetalMenuBarUI.

To customize the look of JToolBar MetalToolBarUI will now override update.

    /**
     * If necessary paints the background of the component, then invokes
     * <code>paint</code>.
     *
     * @param g Graphics to paint to
     * @param c JComponent painting on
     * @throws NullPointerException if <code>g</code> or <code>c</code> is
     *         null
     * @see javax.swing.plaf.ComponentUI#update
     * @see javax.swing.plaf.ComponentUI#paint
     * @since 1.5
     */
    public void update(Graphics g, JComponent c);

To customize the look of JToggleButton MetalToggleButtonUI will now override the following methods:

    /**
     * If necessary paints the background of the component, then invokes
     * <code>paint</code>.
     *
     * @param g Graphics to paint to
     * @param c JComponent painting on
     * @throws NullPointerException if <code>g</code> or <code>c</code> is
     *         null
     * @see javax.swing.plaf.ComponentUI#update
     * @see javax.swing.plaf.ComponentUI#paint
     * @since 1.5
     */
    public void update(Graphics g, JComponent c);

    /**
     * Paints the appropriate icon of the button <code>b</code> in the
     * space <code>iconRect</code>.
     *
     * @param g Graphics to paint to
     * @param b Button to render for
     * @param iconRect space to render in
     * @throws NullPointerException if any of the arguments are null.
     * @since 1.5
     */
    protected void paintIcon(Graphics g, AbstractButton b, Rectangle iconRect);

    /**
     * Returns the icon to display when the button is disabled.
     *
     * @param button AbstractButton requesting the Icon
     * @return Disabled icon, or null.
     * @see javax.swing.AbstractButton#setIcon
     * @see javax.swing.AbstractButton#setDisabledIcon
     * @throws NullPointerException if <code>button</code> is null
     * @since 1.5
     */
    public Icon getDisabledIcon(AbstractButton button);

4632193: Swing Skins Look and Feel

Description:

One of Swing's early design goals was the ability for an application to support a multitude of look and feels without changing code. This feature allows developers to seamlessly run their applications with numerous look and feels. While there have been a handful of custom look and feels, most notably the Alloy Look and Feel and L2F's Skinnable Look and Feel, creating a new look and feel requires programming and an extensive knowledge of Swing's pluggable look-and-feel architecture, limiting this feature mostly to experts. In 5.0, a skinnable look and feel, named Synth, has been added to Swing which can be completely customized without writing code, enabling even non-programmers to create new look and feels.

Synth lives in the javax.swing.plaf.synth package. The package level javadoc gives a brief overview of Synth. Synth can be customized by way of a file. To enable Synth to extend javax.swing.plaf.basic the following changes were made:

The following methods were unnecessary (implementation identical to that of the superclass) and have been removed: BasicOptionPaneUI's getMinimumSize BasicOptionPaneUI's getMaximumSize BasicTabbedPaneUI's getPreferredSize BasicMenuBarUI's getPreferredSize BasicPopupMenuUI's getMinimumSize BasicPopupMenuUI's getPreferredSize BasicPopupMenuUI's getMaximumSize BasicScrollPaneUI's getPreferredSize BasicScrollPaneUI's getMinimumSize BasicListUI's getMinimumSize BasicListUI's getMaximumSize BasicScrollBarUI's getMinimumSize BasicToolBarSeparatorUI's getMinimumSize BasicToolBarSeparatorUI's getMaximumSize BasicToolBarUI's getMinimumSize BasicToolBarUI's getPreferredSize BasicToolBarUI's getMaximumSize.

Many of the JComponent subclasses have primitive properties. As the UIs need to install a value for these properties they have no way to determine if the property was set by the developer and may end up resetting the value a developer has specified. To enable the UI to only set a value if the developer hasn't specified we will route all primitive setters through a method in LookAndFeel:

    /**
     * Convenience method for installing a property with the specified name
     * and value on a component if that property has not already been set
     * by the client program.  This method is intended to be used by
     * UI delegate instances that need to specify a default value for a
     * property of primitive type (boolean, int, ..), but do not wish
     * to override a value set by the client.  Since primitive property
     * values cannot be wrapped with the UIResource marker, this method
     * uses private state to determine whether the property has been set
     * by the client.
     * @throws IllegalArgumentException if the specified property is not
     *         one which can be set using this method
     * @throws ClassCastException May be thrown if the propertyValue is not
     *         of the expected type.
     * @throws NullPointerException May be thrown if the JComponent is null,
     *         or the propertyValue is null.
     * @param c the target component for installing the property
     * @param propertyName String containing the name of the property to be set
     * @param propertyValue Object containing the value of the property
     * @since 1.5
     */
    public static void installProperty(JComponent c,
                                       String propertyName, Object propertyValue)

To allow subclasses of BasicTabbedPaneUI to create their own buttons the following method was added:

    /**
     * Creates and returns a JButton that will provide the user
     * with a way to scroll the tabs in a particular direction. The
     * returned JButton must be instance of UIResource.
     *
     * @param direction One of the SwingConstants constants:
     * SOUTH, NORTH, EAST or WEST
     * @return Widget for user to
     * @see javax.swing.JTabbedPane#setTabPlacement
     * @see javax.swing.SwingConstants
     * @throws IllegalArgumentException if direction is not one of
     *         NORTH, SOUTH, EAST or WEST
     * @since 1.5
     */
    protected JButton createScrollButton(int direction);

To allow subclasses of BasicTabbedPaneUI to determine which tab has focus the following was added:

    /**
     * Returns the index of the tab that has focus.
     *
     * @return index of tab that has focus
     * @since 1.5
     */
    protected int getFocusIndex();

To allow subclasses of BasicTabbedPaneUI to provide a rollover effect the following was added:

    /**
     * Sets the tab the mouse is currently over to index.
     * index will be -1 if the mouse is no longer over any
     * tab. No checking is done to ensure the passed in index identifies a
     * valid tab.
     *
     * @param index Index of the tab the mouse is over.
     * @since 1.5
     */
    protected void setRolloverTab(int index);

    /**
     * Returns the tab the mouse is currently over, or -1 if the mouse is no
     * longer over any tab.
     *
     * @param index Index of the tab the mouse is over.
     * @since 1.5
     */
    protected int getRolloverTab();

The following field was added to BasicColorChooserUI:

    /**
     * JColorChooser this BasicColorChooserUI is installed on.
     *
     * @since 1.5
     */
    protected JColorChooser chooser;

To allow BasicSpinnerUI subclasses to install their own keyboard actions the following method was added:

    /**
     * Installs the keyboard Actions onto the JSpinner.
     *
     * @since 1.5
     */
    protected void installKeyboardActions();

To allow BasicSpinnerUI subclasses to provide their own spin buttons the following methods were added:

    /**
     * Installs the necessary listeners on the next button, c,
     * to update the JSpinner in response to a user gesture.
     *
     * @param c Component to install the listeners on
     * @throws NullPointerException if c is null.
     * @see #createNextButton
     * @since 1.5
     */
    protected void installNextButtonListeners(Component c);

    /**
     * Installs the necessary listeners on the previous button, c,
     * to update the JSpinner in response to a user gesture.
     *
     * @param c Component to install the listeners on.
     * @throws NullPointerException if c is null.
     * @see #createPreviousButton
     * @since 1.5
     */
    protected void installPreviousButtonListeners(Component c);

To allow subclasses of BasicScrollBarUI to provide rollover feedback the following method were added:

    /**
     * Sets whether or not the mouse is currently over the thumb.
     *
     * @param active True indicates the thumb is currently active.
     * @since 1.5
     */
    protected void setThumbRollover(boolean active);

    /**
     * Returns true if the mouse is currently over the thumb.
     *
     * @return true if the thumb is currently active
     * @since 1.5
     */
    public boolean isThumbRollover();

    /**
     * Indicates whether the user can absolutely position the thumb with
     * a mouse gesture (usually the middle mouse button).
     *
     * @return true if a mouse gesture can absolutely position the thumb
     * @since 1.5
     */
    public boolean getSupportsAbsolutePositioning();

To cut down on class loads the following was added to BasicComboPopup:

    /**
     * Gets the AccessibleContext associated with this BasicComboPopup.
     * The AccessibleContext will have its parent set to the ComboBox.
     *
     * @return an AccessibleContext for the BasicComboPopup
     * @since 1.5
     */
    public AccessibleContext getAccessibleContext();

To enable subclasses of BasicSplitPaneDivider to provide mouse over feedback the following was added:

    /**
     * Sets whether or not the mouse is currently over the divider.
     *
     * @param mouseOver whether or not the mouse is currently over the divider
     * @since 1.5
     */
    protected void setMouseOver(boolean mouseOver);

    /**
     * Returns whether or not the mouse is currently over the divider
     *
     * @param Returns whether or not the mouse is currently over the divider
     */
    public boolean isMouseOver();

To allow subclasses of BasicTreeUI to alter the location of a particular row the following had been added:

    /**
     * Returns the location, along the x-axis, to render a particular row
     * at. The return value does not include any Insets specified on the JTree.
     * This does not check for the validity of the row or depth, it is assumed
     * to be correct and will not throw an Exception if the row or depth
     * doesn't match that of the tree.
     *
     * @param row Row to return x location for
     * @param depth Depth of the row
     * @return amount to indent the given row.
     * @since 1.5
     */
    protected int getRowX(int row, int depth);

To allow subclasses of BasicProgressBarUI to alter the size of the progress bar the following was added:

    /**
     * Used to hold the location and size of the bouncing box (returned
     * by getBox) to be painted.
     *
     * @since 1.5
     */
    protected Rectangle boxRect;

    /**
     * Returns the length
     * of the "bouncing box" to be painted.
     * This method is invoked by the
     * default implementation of <code>paintIndeterminate</code>
     * to get the width (if the progress bar is horizontal)
     * or height (if vertical) of the box.
     * For example:
     * <blockquote>
     * <pre>
     *boxRect.width = getBoxLength(componentInnards.width,
     *                             componentInnards.height);
     * </pre>
     * </blockquote>
     *
     * @param availableLength  the amount of space available
     *                         for the bouncing box to move in;
     *                         for a horizontal progress bar,
     *                         for example,
     *                         this should be
     *                         the inside width of the progress bar
     *                         (the component width minus borders)
     * @param otherDimension   for a horizontal progress bar, this should be
     *                         the inside height of the progress bar; this
     *                         value might be used to constrain or determine
     *                         the return value
     *
     * @return the size of the box dimension being determined;
     *         must be no larger than <code>availableLength</code>
     *
     * @see javax.swing.SwingUtilities#calculateInnerArea
     * @since 1.5
     */
    protected int getBoxLength(int availableLength, int otherDimension);

To enable subclasses of BasicSliderUI to specialize painting based on the state of the slider the following was added:

    /**
     * Returns true if the user is dragging the slider.
     *
     * @return true if the user is dragging the slider
     * @since 1.5
     */
    protected boolean isDragging();

To allow subclasses of BasicToolBarUI to specialize how the window used for dragging is painted the following was added:

    /**
     * Paints the contents of the window used for dragging.
     *
     * @param g Graphics to paint to.
     * @throws NullPointerException is g is null
     * @since 1.5
     */
    protected void paintDragWindow(Graphics g);

To allow subclasses of BasicDesktopIconUI to get a handle to the iconPane the following was added:

    /**
     * The title pane component used in the desktop icon.
     *
     * @since 1.5
     */
    protected JComponent iconPane;

4634626: Implement context popup menus for components

Description:

JPopupMenu allows for creating a popup menu. Prior to 5.0, developers using a JPopupMenu would have to install the necessary listeners and register the appropriate key bindings to show the JPopupMenu. In 5.0 we added a mechanism to take care of registering the appropriate listeners and key bindings. This resulted in the following methods being added to JComponent:

    /**
     * Sets whether or not <code>getComponentPopupMenu</code> should delegate
     * to the parent if this component does not have a <code>JPopupMenu</code>
     * assigned to it.
     * <p>
     * The default value for this is false, but some <code>JComponent</code>
     * subclasses that are implemented as a number of <code>JComponent</code>s
     * may set this to true.
     * <p>
     * This is a bound property.
     *
     * @param value whether or not the JPopupMenu is inherited
     * @see #setComponentPopupMenu
     * @beaninfo
     *        bound: true
     *  description: Whether or not the JPopupMenu is inherited
     * @since 1.5
     */
    public void setInheritsPopupMenu(boolean value);

    /**
     * Returns true if the JPopupMenu should be inherited from the parent.
     *
     * @see #setComponentPopupMenu
     * @since 1.5
     */
    public boolean getInheritsPopupMenu();

    /**
     * Sets the <code>JPopupMenu</code> for this <code>JComponent</code>.
     * The UI is responsible for registering bindings and adding the necessary
     * listeners such that the <code>JPopupMenu</code> will be shown at
     * the appropriate time. When the <code>JPopupMenu</code> is shown
     * depends upon the look and feel: some may show it on a mouse event,
     * some may enable a key binding.
     * <p>
     * If <code>popup</code> is null, and <code>getInheritsPopupMenu</code>
     * returns true, then <code>getComponentPopupMenu</code> will be delegated
     * to the parent. This provides for a way to make all child components
     * inherit the popupmenu of the parent.
     * <p>
     * This is a bound property.
     *
     * @param popup - the popup that will be assigned to this component
     *                may be null
     * @see #getComponentPopupMenu
     * @beaninfo
     *        bound: true
     *    preferred: true
     *  description: Popup to show
     * @since 1.5
     */
    public void setComponentPopupMenu(JPopupMenu popup);

    /**
     * Returns <code>JPopupMenu</code> that assigned for this component.
     * If this component does not have a <code>JPopupMenu</code> assigned
     * to it and <code>getInheritsPopupMenu</code> is true, this
     * will return <code>getParent().getComponentPopupMenu()</code> (assuming
     * the parent is valid.)
     *
     * @return <code>JPopupMenu</code> assigned for this component
     *         or <code>null</code> if no popup assigned
     * @see #setComponentPopupMenu
     * @since 1.5
     */
    public JPopupMenu getComponentPopupMenu();

The following was added to BasicLookAndFeel:

     /**
      * UIManager.setLookAndFeel calls this method before the first call
      * (and typically the only call) to getDefaults().
      *
      * @since 1.5
      */
     public void initialize() {

     /**
      * UIManager.setLookAndFeel calls this method just
      * before we're replaced by a new default look and feel.
      *
      * @since 1.5
      */
     public void uninitialize() {

4791650: JTable needs printing support

Description:

Synopsis says it all. The following has been added to JTable:

    /**
     * Printing modes, used in printing <code>JTable</code>s.
     *
     * @see #print(JTable.PrintMode, MessageFormat, MessageFormat,
     *             boolean, PrintRequestAttributeSet, boolean)
     * @see #getPrintable
     * @since 1.5
     */
    public enum PrintMode {

        /**
         * Printing mode that prints the table at its current size,
         * spreading both columns and rows across multiple pages if necessary.
         */
        NORMAL,

        /**
         * Printing mode that scales the output smaller, if necessary,
         * to fit the table's entire width (and thereby all columns) on each page;
         * Rows are spread across multiple pages as necessary.
         */
        FIT_WIDTH
    }
    /**
     * A convenience method that displays a printing dialog, and then prints
     * this <code>JTable</code> in mode <code>PrintMode.FIT_WIDTH</code>,
     * with no header or footer text. A modal progress dialog, with an abort
     * option, will be shown for the duration of printing.
     * <p>
     * Note: In headless mode, no dialogs will be shown.
     *
     * @return true, unless printing is cancelled by the user
     * @throws PrinterException if an error in the print system causes the job
     *                          to be aborted
     * @see #print(JTable.PrintMode, MessageFormat, MessageFormat,
     *             boolean, PrintRequestAttributeSet, boolean)
     * @see #getPrintable
     *
     * @since 1.5
     */
    public boolean print() throws PrinterException;

    /**
     * A convenience method that displays a printing dialog, and then prints
     * this <code>JTable</code> in the given printing mode,
     * with no header or footer text. A modal progress dialog, with an abort
     * option, will be shown for the duration of printing.
     * <p>
     * Note: In headless mode, no dialogs will be shown.
     *
     * @param  printMode        the printing mode that the printable should use
     * @return true, unless printing is cancelled by the user
     * @throws PrinterException if an error in the print system causes the job
     *                          to be aborted
     * @see #print(JTable.PrintMode, MessageFormat, MessageFormat,
     *             boolean, PrintRequestAttributeSet, boolean)
     * @see #getPrintable
     *
     * @since 1.5
     */
    public boolean print(PrintMode printMode) throws PrinterException;

    /**
     * A convenience method that displays a printing dialog, and then prints
     * this <code>JTable</code> in the given printing mode,
     * with the specified header and footer text. A modal progress dialog,
     * with an abort option, will be shown for the duration of printing.
     * <p>
     * Note: In headless mode, no dialogs will be shown.
     *
     * @param  printMode        the printing mode that the printable should use
     * @param  headerFormat     a <code>MessageFormat</code> specifying the text
     *                          to be used in printing a header,
     *                          or null for none
     * @param  footerFormat     a <code>MessageFormat</code> specifying the text
     *                          to be used in printing a footer,
     *                          or null for none
     * @return true, unless printing is cancelled by the user
     * @throws PrinterException if an error in the print system causes the job
     *                          to be aborted
     * @see #print(JTable.PrintMode, MessageFormat, MessageFormat,
     *             boolean, PrintRequestAttributeSet, boolean)
     * @see #getPrintable
     *
     * @since 1.5
     */
    public boolean print(PrintMode printMode,
                         MessageFormat headerFormat,
                         MessageFormat footerFormat) throws PrinterException;

    /**
     * Print this <code>JTable</code>. Takes steps that the majority of
     * developers would take in order to print a <code>JTable</code>.
     * In short, it prepares the table, calls <code>getPrintable</code> to
     * fetch an appropriate <code>Printable</code>, and then sends it to the
     * printer.
     * <p>
     * A <code>boolean</code> parameter allows you to specify whether or not
     * a printing dialog is displayed to the user. When it is, the user may
     * use the dialog to change printing attributes or even cancel the print.
     * Another parameter allows for printing attributes to be specified
     * directly. This can be used either to provide the initial values for the
     * print dialog, or to supply any needed attributes when the dialog is not
     * shown.
     * <p>
     * A second <code>boolean</code> parameter allows you to specify whether
     * or not to perform printing in an interactive mode. If <code>true</code>,
     * a modal progress dialog, with an abort option, is displayed for the
     * duration of printing . This dialog also prevents any user action which
     * may affect the table. However, it can not prevent the table from being
     * modified by code (for example, another thread that posts updates using
     * <code>SwingUtilities.invokeLater</code>). It is therefore the
     * responsibility of the developer to ensure that no other code modifies
     * the table in any way during printing (invalid modifications include
     * changes in: size, renderers, or underlying data). Printing behavior is
     * undefined when the table is changed during printing.
     * <p>
     * If <code>false</code> is specified for this parameter, no dialog will
     * be displayed and printing will begin immediately on the event-dispatch
     * thread. This blocks any other events, including repaints, from being
     * processed until printing is complete. Although this effectively prevents
     * the table from being changed, it doesn't provide a good user experience.
     * For this reason, specifying <code>false</code> is only recommended when
     * printing from an application with no visible GUI.
     * <p>
     * Note: Attempting to show the printing dialog or run interactively, while
     * in headless mode, will result in a <code>HeadlessException</code>.
     * <p>
     * Before fetching the printable, this method prepares the table in order
     * to get the most desirable printed result. If the table is currently
     * in an editing mode, it terminates the editing as gracefully as
     * possible. It also ensures that the table's current selection and
     * focused cell are not indicated in the printed output. This is handled on
     * the view level, and only for the duration of the printing, thus no
     * notification needs to be sent to the selection models.
     * <p>
     * See {@link #getPrintable} for further description on how the
     * table is printed.
     *
     * @param  printMode        the printing mode that the printable should use
     * @param  headerFormat     a <code>MessageFormat</code> specifying the text
     *                          to be used in printing a header,
     *                          or null for none
     * @param  footerFormat     a <code>MessageFormat</code> specifying the text
     *                          to be used in printing a footer,
     *                          or null for none
     * @param  showPrintDialog  whether or not to display a print dialog
     * @param  attr             a <code>PrintRequestAttributeSet</code>
     *                          specifying any printing attributes,
     *                          or null for none
     * @param  interactive      whether or not to print in an interactive mode
     * @return true, unless printing is cancelled by the user
     * @throws PrinterException if an error in the print system causes the job
     *                          to be aborted
     * @throws HeadlessException if the method is asked to show a printing
     *                           dialog or run interactively, and
     *                           <code>GraphicsEnvironment.isHeadless</code>
     *                           returns true
     * @see #getPrintable
     * @see java.awt.GraphicsEnvironment#isHeadless
     *
     * @since 1.5
     */
    public boolean print(PrintMode printMode,
                         MessageFormat headerFormat,
                         MessageFormat footerFormat,
                         boolean showPrintDialog,
                         PrintRequestAttributeSet attr,
                         boolean interactive) throws PrinterException,
                                                     HeadlessException;
    /**
     * Return a <code>Printable</code> for use in printing this JTable.
     * <p>
     * The <code>Printable</code> can be requested in one of two printing modes.
     * In both modes, it spreads table rows naturally in sequence across
     * multiple pages, fitting as many rows as possible per page.
     * <code>PrintMode.NORMAL</code> specifies that the table be
     * printed at its current size. In this mode, there may be a need to spread
     * columns across pages in a similar manner to that of the rows. When the
     * need arises, columns are distributed in an order consistent with the
     * table's <code>ComponentOrientation</code>.
     * <code>PrintMode.FIT_WIDTH</code> specifies that the output be
     * scaled smaller, if necessary, to fit the table's entire width
     * (and thereby all columns) on each page. Width and height are scaled
     * equally, maintaining the aspect ratio of the output.
     * <p>
     * The <code>Printable</code> heads the portion of table on each page
     * with the appropriate section from the table's <code>JTableHeader</code>,
     * if it has one.
     * <p>
     * Header and footer text can be added to the output by providing
     * <code>MessageFormat</code> arguments. The printing code requests
     * Strings from the formats, providing a single item which may be included
     * in the formatted string: an <code>Integer</code> representing the current
     * page number.
     * <p>
     * You are encouraged to read the documentation for
     * <code>MessageFormat</code> as some characters, such as single-quote,
     * are special and need to be escaped.
     * <p>
     * Here's an example of creating a <code>MessageFormat</code> that can be
     * used to print "Duke's Table: Page - " and the current page number:
     * <p>
     * <pre>
     *     // notice the escaping of the single quote
     *     // notice how the page number is included with "{0}"
     *     MessageFormat format = new MessageFormat("Duke''s Table: Page - {0}");
     * </pre>
     * <p>
     * The <code>Printable</code> constrains what it draws to the printable
     * area of each page that it prints. Under certain circumstances, it may
     * find it impossible to fit all of a page's content into that area. In
     * these cases the output may be clipped, but the implementation
     * makes an effort to do something reasonable. Here are a few situations
     * where this is known to occur, and how they may be handled by this
     * particular implementation:
     * <ul>
     *   <li>In any mode, when the header or footer text is too wide to fit
     *       completely in the printable area -- print as much of the text as
     *       possible starting from the beginning, as determined by the table's
     *       <code>ComponentOrientation</code>.
     *   <li>In any mode, when a row is too tall to fit in the
     *       printable area -- print the upper-most portion of the row
     *       and paint no lower border on the table.
     *   <li>In <code>PrintMode.NORMAL</code> when a column
     *       is too wide to fit in the printable area -- print the center
     *       portion of the column and leave the left and right borders
     *       off the table.
     * </ul>
     * <p>
     * It is entirely valid for this <code>Printable</code> to be wrapped
     * inside another in order to create complex reports and documents. You may
     * even request that different pages be rendered into different sized
     * printable areas. The implementation must be prepared to handle this
     * (possibly by doing its layout calculations on the fly). However,
     * providing different heights to each page will likely not work well
     * with <code>PrintMode.NORMAL</code> when it has to spread columns
     * across pages.
     * <p>
     * It is important to note that this <code>Printable</code> prints the
     * table at its current visual state, using the table's existing renderers.
     * <i>Before</i> calling this method, you may wish to <i>first</i> modify
     * the state of the table (such as to change the renderers, cancel editing,
     * or hide the selection).
     * <p>
     * You must not, however, modify the table in any way <i>after</i>
     * this <code>Printable</code> is fetched (invalid modifications include
     * changes in: size, renderers, or underlying data). The behavior of the
     * returned <code>Printable</code> is undefined once the table has been
     * changed.
     * <p>
     * Here's a simple example that calls this method to fetch a
     * <code>Printable</code>, shows a cross-platform print dialog, and then
     * prints the <code>Printable</code> unless the user cancels the dialog:
     * <p>
     * <pre>
     *     // prepare the table for printing here first (for example, hide selection)
     *
     *     // wrap in a try/finally so table can be restored even if something fails
     *     try {
     *         // fetch the printable
     *         Printable printable = table.getPrintable(JTable.PrintMode.FIT_WIDTH,
     *                                                  new MessageFormat("My Table"),
     *                                                  new MessageFormat("Page - {0}"));
     *
     *         // fetch a PrinterJob
     *         PrinterJob job = PrinterJob.getPrinterJob();
     *
     *         // set the Printable on the PrinterJob
     *         job.setPrintable(printable);
     *
     *         // create an attribute set to store attributes from the print dialog
     *         PrintRequestAttributeSet attr = new HashPrintRequestAttributeSet();
     *
     *         // display a print dialog and record whether or not the user cancels it
     *         boolean printAccepted = job.printDialog(attr);
     *
     *         // if the user didn't cancel the dialog
     *         if (printAccepted) {
     *             // do the printing (may need to handle PrinterException)
     *             job.print(attr);
     *         }
     *     } finally {
     *         // restore the original table state here (for example, restore selection)
     *     }
     * </pre>
     *
     * @param  printMode     the printing mode that the printable should use
     * @param  headerFormat  a <code>MessageFormat</code> specifying the text to
     *                       be used in printing a header, or null for none
     * @param  footerFormat  a <code>MessageFormat</code> specifying the text to
     *                       be used in printing a footer, or null for none
     * @return a <code>Printable</code> for printing this JTable
     * @see Printable
     * @see PrinterJob
     *
     * @since 1.5
     */
    public Printable getPrintable(PrintMode printMode,
                                  MessageFormat headerFormat,
                                  MessageFormat footerFormat);

Changes to Swing's text classes

4201999: JTextArea's don't automatically scroll when appending() to them.

Description:

Some of Swing's text component methods are thread safe; particularly those that modify the content of the text component. Prior to 5.0 the location of the caret would only be updated if the modification happens on the event dispatching thread. In certain situations it is desirable to update the location regardless of what thread the modification happens on. In order to accomodate this the updatePolicy property was added to DefaultCaret. This property allows the developer to specify when the location should change when the content changes. For backward compatibility the policy is still to only update the location if the modification happens on the event dispatching thread.

The results in the following fields and methods being added to DefaultCaret.

     /**
      * Indicates that the caret position is to be updated only when
      * document changes are performed on the Event Dispatching Thread.
      * @see #setUpdatePolicy
      * @see #getUpdatePolicy
      * @since 1.5
      */
     public static final int UPDATE_WHEN_ON_EDT = 0;

     /**
      * Indicates that the caret should remain at the same
      * absolute position in the document regardless of any document
      * updates, except when the document length becomes less than
      * the current caret position due to removal. In that case the caret
      * position is adjusted to the end of the document.
      *
      * @see #setUpdatePolicy
      * @see #getUpdatePolicy
      * @since 1.5
      */
     public static final int NEVER_UPDATE = 1;

     /**
      * Indicates that the caret position is to be <b>always</b>
      * updated accordingly to the document changes regardless whether
      * the document updates are performed on the Event Dispatching Thread
      * or not.
      *
      * @see #setUpdatePolicy
      * @see #getUpdatePolicy
      * @since 1.5
      */
     public static final int ALWAYS_UPDATE = 2;

     /**
      * Sets the caret movement policy on the document updates. Normally
      * the caret updates its absolute position within the document on
      * insertions occurred before or at the caret position and
      * on removals before the caret position. 'Absolute position'
      * means here the position relative to the start of the document.
      * For example if
      * a character is typed within editable text component it is inserted
      * at the caret position and the caret moves to the next absolute
      * position within the document due to insertion and if
      * <code>BACKSPACE</code> is typed then caret decreases its absolute
      * position due to removal of a character before it. Sometimes
      * it may be useful to turn off the caret position updates so that
      * the caret stays at the same absolute position within the
      * document position regardless of any document updates.
      * <p>
      * The following update policies are allowed:
      * <ul>
      *   <li><code>NEVER_UPDATE</code>: the caret stays at the same
      *       absolute position in the document regardless of any document
      *       updates, except when document length becomes less than
      *       the current caret position due to removal. In that case caret
      *       position is adjusted to the end of the document.
      *       The caret doesn't try to keep itself visible by scrolling
      *       the associated view when using this policy. </li>
      *   <li><code>ALWAYS_UPDATE</code>: the caret always tracks document
      *       changes. For regular changes it increases its position
      *       if an insertion occurs before or at its current position,
      *       and decreases position if a removal occurs before
      *       its current position. For undo/redo updates it is always
      *       moved to the position where update occurred. The caret
      *       also tries to keep itself visible by calling
      *       <code>adjustVisibility</code> method.</li>
      *   <li><code>UPDATE_WHEN_ON_EDT</code>: acts like <code>ALWAYS_UPDATE</code>
      *       if the document updates are performed on the Event Dispatching Thread
      *       and like <code>NEVER_UPDATE</code> if updates are performed on
      *       other thread. </li>
      * </ul> <p>
      * The default property value is <code>UPDATE_WHEN_ON_EDT</code>.
      *
      * @param policy one of the following values : <code>UPDATE_WHEN_ON_EDT</code>,
      * <code>NEVER_UPDATE</code>, <code>ALWAYS_UPDATE</code>
      * @throws IllegalArgumentException if invalid value is passed
      *
      * @see #getUpdatePolicy
      * @see #adjustVisibility
      * @see #UPDATE_WHEN_ON_EDT
      * @see #NEVER_UPDATE
      * @see #ALWAYS_UPDATE
      *
      * @since 1.5
      */
     public void setUpdatePolicy(int policy)

     /**
      * Gets the caret movement policy on document updates.
      *
      * @return one of the following values : <code>UPDATE_WHEN_ON_EDT</code>,
      * <code>NEVER_UPDATE</code>, <code>ALWAYS_UPDATE</code>
      *
      * @see #getUpdatePolicy
      * @see #UPDATE_WHEN_ON_EDT
      * @see #NEVER_UPDATE
      * @see #ALWAYS_UPDATE
      *
      * @since 1.5
      */
     public int getUpdatePolicy()

4473401: Forms should generate a hyperlink event, not directly post/get the data

Description:

JEditorPane can be used to display HTML text. When a user clicks on a link an event is generated the allows the developer to customize what will happen. Currently if a HTML page has forms in it and the user triggers a submission the post happens automatically without allowing the developer to alter the behavior. To allow developers to customize the behavior the following methods have been added to HTMLEditorKit:

    /**
     * Indicates whether an html form submission is processed automatically
     * or only <code>FormSubmitEvent</code> is fired.
     *
     * @return true  if html form submission is processed automatically,
     *         false otherwise.
     *
     * @see #setAutoFormSubmission
     * @since 1.5
     */
    public boolean isAutoFormSubmission();

    /**
     * Specifies if an html form submission is processed
     * automatically or only <code>FormSubmitEvent</code> is fired.
     * By default it the property is set to true.
     *
     * @see #isAutoFormSubmission
     * @see FormSubmitEvent
     * @since 1.5
     */
    public void setAutoFormSubmission(boolean isAuto);

A crucial part of this work was making the class FormSubmitEvent public, refer to 4954126 for details on this.

4513720: DefaultCaret visibility should be separate from blinking

Description:

There is currently no way to determine if the caret in active and blinking. The isVisible method was intended for this purpose, but the implementation returns whether the caret is painted at the moment it is invoked, i.e. if the caret is blinking isVisible changes between true and false as the caret blinks. To maintain backward compatibility the interpretation of the isVisible method has been left the same, and an isActive property was added that tells if the caret is active but not necessarily visible at the time the method is invoked.

The following methods have been added to DefaultCaret:

    /**
     * Determines if the caret is currently active.
     * <p>
     * This method returns whether or not the <code>Caret</code>
     * is currently in a blinking state. It does not provide
     * information as to whether it is currently blinked on or off.
     * To determine if the caret is currently painted use the
     * <code>isVisible</code> method.
     *
     * @return <code>true</code> if active else <code>false</code>
     * @see #isVisible
     *
     * @since 1.5
     */
    public boolean isActive()

     * Sets the caret visibility, and repaints the caret.
     * It is important to understand the relationship between this method,
     * <code>isVisible</code> and <code>isActive</code>.
     * Calling this method with a value of <code>true</code> activates the
     * caret blinking. Setting it to <code>false</code> turns it completely off.
     * To determine whether the blinking is active, you should call
     * <code>isActive</code>. In effect, <code>isActive</code> is an
     * appropriate corresponding "getter" method for this one.
     * <code>isVisible</code> can be used to fetch the current
     * visibility status of the caret, meaning whether or not it is currently
     * painted. This status will change as the caret blinks on and off.
     * <p>
     * Here's a list showing the potential return values of both
     * <code>isActive</code> and <code>isVisible</code>
     * after calling this method:
     * <p>
     * <b><code>setVisible(true)</code></b>:
     * <ul>
     *     <li>isActive(): true</li>
     *     <li>isVisible(): true or false depending on whether
     *         or not the caret is blinked on or off</li>
     * </ul>
     * <p>
     * <b><code>setVisible(false)</code></b>:
     * <ul>
     *     <li>isActive(): false</li>
     *     <li>isVisible(): false</li>
     * </ul>
     *
     * @param e the visibility specifier
     * @see #isActive
     * @see Caret#setVisible
     */
    public void setVisible(boolean e)

The documentation for DefaultCaret's isVisible method has been updated to indicate the distinction between the two properties:

    /**
     * Indicates whether or not the caret is currently visible. As the
     * caret flashes on and off the return value of this will change
     * between true, when the caret is painted, and false, when the
     * caret is not painted. <code>isActive</code> indicates whether
     * or not the caret is in a blinking state, such that it <b>can</b>
     * be visible, and <code>isVisible</code> indicates whether or not
     * the caret <b>is</b> actually visible.
     * <p>
     * Subclasses that wish to render a different flashing caret
     * should override paint and only paint the caret if this method
     * returns true.
     *
     * @return true if visible else false
     * @see Caret#isVisible
     * @see #isActive
     */
    public boolean isVisible()

4530474: background-color CSS attribute in HTML font tag works in style but not class

Description:

The background attribute from css style sheet is ignored when rendering HTML text. To get this to work we added the following method to LabelView:

    /**
     * Sets the background color for the view. This method is typically
     * invoked as part of configuring this <code>View</code>. If you need
     * to customize the background color you should override
     * <code>setPropertiesFromAttributes</code> and invoke this method. A
     * value of null indicates no background should be rendered, so that the
     * background of the parent <code>View</code> will show through.
     *
     * @param bg background color, or null
     * @see #setPropertiesFromAttributes
     * @since 1.5
     */
    protected void setBackground(Color bg);

4829622: TabSet class does not override equals

Description:

The TabSet does not override the equals method, which causes comparisons to fail if the TabStop array does contain the same TabStops. It causes AttributeSet not to be equal, even though the only difference is another object instance of TabSet.

TabSet will now override equals and hashCode:

/**
* Indicates whether this <code>TabSet</code> is equal to another one.
* @param o the <code>TabSet</code> instance which this instance
* should be compared to.
* @return <code>true</code> if <code>o</code> is the instance of
* <code>TabSet</code>, has the same number of <code>TabStop</code>s
* and they are all equal, <code>false</code> otherwise.
*
* @since 1.5
*/
public boolean equals(Object o)

/**
* Returns a hashcode for this set of TabStops.
* @return a hashcode value for this set of TabStops.
*
* @since 1.5
*/
public int hashCode()

4838730: REGRESSION: In JTextArea setEditable(...) breaks focus traversal keys

Description:

Invoking JTextArea.setEditable resets the focus traversal keys. This is problmatic for developers that want to provide a custom set of focus traversal keys and conditionally change the editable property.

To fix this JComponent now overrides the following:

    /**
     * Sets the focus traversal keys for a given traversal operation for this
     * Component.
     * Refer to
     * {@link java.awt.Component#setFocusTraversalKeys}
     * for a complete description of this method.
     *
     * @param id one of KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS,
     *        KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, or
     *        KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS
     * @param keystrokes the Set of AWTKeyStroke for the specified operation
     * @see java.awt.KeyboardFocusManager#FORWARD_TRAVERSAL_KEYS
     * @see java.awt.KeyboardFocusManager#BACKWARD_TRAVERSAL_KEYS
     * @see java.awt.KeyboardFocusManager#UP_CYCLE_TRAVERSAL_KEYS
     * @throws IllegalArgumentException if id is not one of
     *         KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS,
     *         KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, or
     *         KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS, or if keystrokes
     *         contains null, or if any Object in keystrokes is not an
     *         AWTKeyStroke, or if any keystroke represents a KEY_TYPED event,
     *         or if any keystroke already maps to another focus traversal
     *         operation for this Component
     * @since 1.5
     * @beaninfo
     *       bound: true
     */
    public void setFocusTraversalKeys(int id, Set keystrokes);

4954126: Make FormSubmitEvent class and its accessor methods public

Description:

As requested FormSubmitEvent is not public.

Miscellaneous Swing Changes

4198834: ListDataEvent.getIndex0() should be <= getIndex1()

Description:

ListDataEvent's constructor has been changed to swap the two indices it is passed so that the return value from getIndex0() is always <= the return value from getIndex1.

Specification

   /**
    * Constructs a ListDataEvent object. If index0 is >
    * index1, index0 and index1 will be swapped such that
    * index0 will always be <= index1.
    *
    * @param source  the source Object (typically <code>this</code>)
    * @param type    an int specifying {@link #CONTENTS_CHANGED},
    *                {@link #INTERVAL_ADDED}, or {@link #INTERVAL_REMOVED}
    * @param index0  one end of the new interval
    * @param index1  the other end of the new interval
    */
public ListDataEvent(Object source, int type, int index0, int index1) {

4303294: Implement discontinuous selection from the keyboard for list-like components

Description:

JTable and JList currently provide no way to make discontinuous selections using the keyboard. To enable this the following was added to DefaultListSelectionModel:

/**
 * Set the lead selection index, leaving all selection values unchanged.
 * If leadAnchorNotificationEnabled is true, send a notification covering
 * the old and new lead cells.
 *
 * @param leadIndex the new lead selection index
 *
 * @see #setAnchorSelectionIndex
 * @see #setLeadSelectionIndex
 * @see #getLeadSelectionIndex
 *
 * @since 1.5
 */
public void moveLeadSelectionIndex(int leadIndex)

Additionally DefaultListSelectionModel's isLeadAnchorNotificationEnabled and changeSelection methods were revised.

4621323: Some swing constants are not constant.

Description:

The following static fields are now static final: JDesktopPane.LIVE_DRAG_MODE, JDesktopPane.OUTLINE_DRAG_MODE and DTD.FILE_VERSION.

4664885: Shadow colors are swapped depending on whether BevelBorder is raised/lowered

Description:

Bevel borders interchange their shadowInner and shadowOuter colors depending on whether they are raised or lowered. However, the BorderFactory and BevelBorder don't say this - it's written for a raised bevel border only. This resulted in adding the following to BevelBorder's constructor and BorderFactory's createBevelBorder method:

     * Note: The shadow inner and outer colors are
     * switched for a lowered bevel border.

4665148: javadoc for javax.swing.JScrollPane.isValidateRoot is completely wrong

Description:

Javadoc for JScrollPane.isValidateRoot is completely wrong and misleading and has been changed to:
    /**
     * Overridden to return true so that any calls to <code>revalidate</code>
     * on any descendants of this <code>JScrollPane</code> will cause the
     * entire tree beginning with this <code>JScrollPane</code> to be
     * validated.
     *
     * @return true
     * @see java.awt.Container#validate
     * @see JComponent#revalidate
     * @see JComponent#isValidateRoot
     *
     * @beaninfo
     *    hidden: true
     */

4682386: Refactoring SwingPropertyChangeSupport and PropertyChangeSupport

Description:

The PropertyChangeSupport class is a utility that makes it easy to register and fire PropertyChangeEvents - which is a notification that a JavaBean property has been modified. SwingPropertyChangeSupport is a subclass of PropertyChangeSupport and has a lot of redundant methods. Furthermore, in the 1.2 timeframe, support for property changes was added to Component. Rather than introduce a dependency on SwingPropertyChangeSupport, Component uses PropertyChangeSupport. JComponent maintains an instance of SwingPropertyChangeSupport and Component maintains an instance of PropertyChangeSupport. The results is every JComponent having two instances of PropertyChangeSupport - one of which is dormant. To cut down on the overlap between Component and JComponent as well as PropertyChangeSupport and SwingPropertyChangeSupport the following changes were made:

Promote the following methods from JComponent to Component:

    /**
     * Reports a bound property change.
     *
     * @param propertyName the programmatic name of the property
     *               that was changed
     * @param oldValue the old value of the property (as a byte)
     * @param newValue the new value of the property (as a byte)
     * @see #firePropertyChange(java.lang.String, java.lang.Object,
     *               java.lang.Object)
     * @since 1.5
     */
    public void firePropertyChange(String propertyName, byte oldValue, byte newValue);

    /**
     * Reports a bound property change.
     *
     * @param propertyName the programmatic name of the property
     *               that was changed
     * @param oldValue the old value of the property (as a char)
     * @param newValue the new value of the property (as a char)
     * @see #firePropertyChange(java.lang.String, java.lang.Object,
     *               java.lang.Object)
     * @since 1.5
     */
     public void firePropertyChange(String propertyName, char oldValue, char newValue);

    /**
     * Reports a bound property change.
     *
     * @param propertyName the programmatic name of the property
     *               that was changed
     * @param oldValue the old value of the property (as a short)
     * @param newValue the old value of the property (as a short)
     * @see #firePropertyChange(java.lang.String, java.lang.Object,
     *               java.lang.Object)
     * @since 1.5
     */
    public void firePropertyChange(String propertyName, short oldValue, short newValue);

    /**
     * Reports a bound property change.
     *
     * @param propertyName the programmatic name of the property
     *               that was changed
     * @param oldValue the old value of the property (as a long)
     * @param newValue the new value of the property (as a long)
     * @see #firePropertyChange(java.lang.String, java.lang.Object,
     *               java.lang.Object)
     * @since 1.5
     */
    public void firePropertyChange(String propertyName, long oldValue, long newValue);

    /**
     * Reports a bound property change.
     *
     * @param propertyName the programmatic name of the property
     *               that was changed
     * @param oldValue the old value of the property (as a float)
     * @param newValue the new value of the property (as a float)
     * @see #firePropertyChange(java.lang.String, java.lang.Object,
     *               java.lang.Object)
     * @since 1.5
     */
    public void firePropertyChange(String propertyName, float oldValue, float newValue);

    /**
     * Reports a bound property change.
     *
     * @param propertyName the programmatic name of the property
     *               that was changed
     * @param oldValue the old value of the property (as a double)
     * @param newValue the new value of the property (as a double)
     * @see #firePropertyChange(java.lang.String, java.lang.Object,
     *               java.lang.Object)
     * @since 1.5
     */
    public void firePropertyChange(String propertyName, double oldValue, double newValue);

The corresponding methods in JComponent have been removed.

All the methods from SwingPropertyChangeSupport have been removed, only the constructor remains.

4706356: Swing's default CellRenderers should override more methods for improved perf

Description:

Swing's cell rendenders override a handful of methods to do nothing as they are not needed for cell renderers. They should override a couple of methods that are now being called to do nothing.

The following methods were added to DefaultTableCellRenderer, DefaultListCellRenderer and DefaultTreeCellRenderer

    /**
     * Overridden for performance reasons.
     * See the <a href="#override">Implementation Note</a>
     * for more information.
     *
     * @since 1.5
     */
    public void invalidate();
    /**
     * Overridden for performance reasons.
     * See the <a href="#override">Implementation Note</a>
     * for more information.
     *
     * @since 1.5
     */
    public void repaint();

4716935: Invoking JLayeredPane.removeAll can result in a leak

Description:

JLayeredPane maintains a HashTable of the Components it contains. It does not currently override removeAll to update the HashTable, resulting in a possible leak. JLayeredPane will now override removeAll to do the necessary cleanup:

    /**
     * Removes all the components from this container.
     *
     * @since 1.5
     */
    public void removeAll();

4717180: Swing should document that UIs may change visual properties when installed

Description:

Swing classes document the default value of many properties. Custom look and feels may change these values so that it appears that the default isn't valid, this needs to be clarified. To document this, the following was added to JComponent's class level javadoc:

     * <code>JComponent</code> and its subclasses document default values
     * for certain properties.  For example, <code>JTable</code> documents the
     * default row height as 16.  Each <code>JComponent</code> subclass
     * that has a <code>ComponentUI</code> will create the
     * <code>ComponentUI</code> as part of its constructor.  In order
     * to provide a particular look and feel each
     * <code>ComponentUI</code> may set properties back on the
     * <code>JComponent</code> that created it.  For example, a custom
     * look and feel may require <code>JTable</code>s to have a row
     * height of 24. The documented defaults are the value of a property
     * BEFORE the <code>ComponentUI</code> has been installed.  If you
     * need a specific value for a particular property you should
     * explicitly set it.

4723745: Metal & Windows FileChooserUI classes cannot be used without ShellFolder

Description:

Since 1.4, the JFileChooser code has too strong a dependence on the native layer. An attempt was made to bypass this class for programs that use a customized "virtual" filesystem, but the algorithm is not 100% reliable. To toggle this behavior, use the client property FileChooser.useShellFolder, for example, to turn off use of the native set this to false:

    jFileChooser.putClientProperty("FileChooser.useShellFolder", Boolean.FALSE);

4749723: Spring and SpringLayout need some ease of methods methods

Description:

It is currently rather difficult to construct some common layouts with SpringLayout. Builders have requested a couple methods to make it easier to create common layouts with SpringLayout, as well as to make it easier to persist SpringLayout.

The following has been added to Spring:

    /**
     * Returns a spring whose <em>minimum</em>, <em>preferred</em>, <em>maximum</em>
     * and <em>value</em> properties are each multiples of the properties of the
     * argument spring, <code>s</code>. Minimum and maximum properties are
     * swapped when <code>factor</code> is negative (in accordance with the
     * rules of interval arithmetic).
     * <p>
     * When factor is, for example, 0.5f the result represents 'the mid-point'
     * of its input - an operation that is useful for centering components in
     * a container.
     *
     * @param s the spring to scale
     * @param factor amount to scale by.
     * @return  a spring whose properties are those of the input spring <code>s</code>
     * multiplied by <code>factor</code>
     * @throws NullPointerException if <code>s</code> is null
     * @since 1.5
     */
    public static Spring scale(Spring s, float factor);

    /**
     * Returns a spring whose <em>minimum</em>, <em>preferred</em>, <em>maximum</em>
     * and <em>value</em> properties are defined by the widths of the <em>minimumSize</em>,
     * <em>preferredSize</em>, <em>maximumSize</em> and <em>size</em> properties
     * of the supplied component. The returned spring is a 'wrapper' implementation
     * whose methods call the appropriate size methods of the supplied component.
     * The minimum, preferred, maximum and value properties of the returned spring
     * therefore report the current state of the appropriate properties in the
     * component and track them as they change.
     *
     * @param c Component used for calculating size
     * @return  a spring whose properties are defined by the horizontal component
     * of the component's size methods.
     * @throws NullPointerException if <code>c</code> is null
     * @since 1.5
     */
    public static Spring width(Component c);

    /**
     * Returns a spring whose <em>minimum</em>, <em>preferred</em>, <em>maximum</em>
     * and <em>value</em> properties are defined by the heights of the <em>minimumSize</em>,
     * <em>preferredSize</em>, <em>maximumSize</em> and <em>size</em> properties
     * of the supplied component. The returned spring is a 'wrapper' implementation
     * whose methods call the appropriate size methods of the supplied component.
     * The minimum, preferred, maximum and value properties of the returned spring
     * therefore report the current state of the appropriate properties in the
     * component and track them as they change.
     *
     * @param c Component used for calculating size
     * @return  a spring whose properties are defined by the vertical component
     * of the component's size methods.
     * @throws NullPointerException if <code>c</code> is null
     * @since 1.5
     */
    public static Spring height(Component c);

And the following has been added to SpringLayout.Constraints:

        /**
         * Creates a <code>Constraints</code> object with
         * suitable <code>x</code>, <code>y</code>, <code>width</code> and
         * <code>height</code> springs for component, <code>c</code>.
         * The <code>x</code> and <code>y</code> springs are constant
         * springs  initialised with the component's location at
         * the time this method is called. The <code>width</code> and
         * <code>height</code> springs are special springs, created by
         * the <code>Spring.width()</code> and <code>Spring.height()</code>
         * methods, which track the size characteristics of the component
         * when they change.
         *
         * @param c  the component whose characteristics will be reflected by this Constraints object
         * @throws NullPointerException if <code>c</code> is null.
         * @since 1.5
         */
        public Constraints(Component c);

4753342: Swing's top level component should redirect add/remove methods to ContentPane

Description:

Contrary to AWT programming, JFrame/JDialg/JWindow/JApplet/JInternalFrame do not allow you to add Components to it, instead you must learn about JRootPane and add children Components to it. This adds needless confusion to new developers.

Prior to 5.0, attempting to add or remove a Component from one of these top level Components would result in an exception be thrown. In 5.0, no exception will be thrown, instead the Component will be added or removed from the content pane. This resulted in several revisions to the javadoc of JFrame, JDialog, JWindow, JApplet and JInternalFrame. This has been summarized in RootPaneContainer's javadoc:

     * For conveniance
     * <code>JFrame</code>, <code>JDialog</code>, <code>JWindow</code>,
     * <code>JApplet</code> and <code>JInternalFrame</code>, by default,
     * forward all calls to <code>add</code> and its variants,
     * <code>remove</code> and <code>setLayout</code> to the
     * <code>contentPane</code>. This means rather than writing:
     * <pre>
     * rootPaneContainer.getContentPane().add(component);
     * </pre>
     * you can do:
     * <pre>
     * rootPaneContainer.add(component);
     * </pre>
     * <p>
     * The behavior of <code>add</code> and its variants and
     * <code>setLayout</code> for
     * <code>JFrame</code>, <code>JDialog</code>, <code>JWindow</code>,
     * <code>JApplet</code> and <code>JInternalFrame</code> is controlled by
     * the <code>rootPaneCheckingEnabled</code> property. If this property is
     * true, the default, then <code>add</code> and its variants and
     * <code>setLayout</code> are
     * forwarded to the <code>contentPane</code>, if it is false, then these
     * methods operate directly on the <code>RootPaneContainer</code>. This
     * property is only intended for subclasses, and is therefor protected.

4789491: JFileChooser doesn't say how to choose directories

Description:

The documentation for JFileChooser is not clear on where to tell the file chooser whether files, directories or both are to be selected. This resulted in revising the documentation for the following methods:

    /**
     * Adds a filter to the list of user choosable file filters.
     * For information on setting the file selection mode, see
     * {@link #setFileSelectionMode setFileSelectionMode}.
     *
     * @param filter the <code>FileFilter</code> to add to the choosable file
     *               filter list
     *
     * @beaninfo
     *   preferred: true
     *       bound: true
     * description: Adds a filter to the list of user choosable file filters.
     *
     * @see #getChoosableFileFilters
     * @see #removeChoosableFileFilter
     * @see #resetChoosableFileFilters
     * @see #setFileSelectionMode
     */
    public void addChoosableFileFilter(FileFilter filter);

    /**
     * Sets the <code>JFileChooser</code> to allow the user to just
     * select files, just select
     * directories, or select both files and directories.  The default is
     * <code>JFilesChooser.FILES_ONLY</code>.
     *
     * @param mode the type of files to be displayed:
     * <ul>
     * <li>JFileChooser.FILES_ONLY
     * <li>JFileChooser.DIRECTORIES_ONLY
     * <li>JFileChooser.FILES_AND_DIRECTORIES
     * </ul>
     *
     * @exception IllegalArgumentException  if <code>mode</code> is an
     *                          illegal file selection mode
     * @beaninfo
     *   preferred: true
     *       bound: true
     * description: Sets the types of files that the JFileChooser can choose.
     *        enum: FILES_ONLY JFileChooser.FILES_ONLY
     *              DIRECTORIES_ONLY JFileChooser.DIRECTORIES_ONLY
     *              FILES_AND_DIRECTORIES JFileChooser.FILES_AND_DIRECTORIES
     *
     *
     * @see #getFileSelectionMode
     */
    public void setFileSelectionMode(int mode);

4831322: JDesktopPane.setDesktopManager should update the desktop manager at the UI.

Description:

Invoking JDesktopPane.setDesktopManager does not take affect until the UI is reloaded.

To fix this BasicDesktopPaneUI will not override the following methods:

    /**
     * Installs the <code>PropertyChangeListener</code> returned from
     * <code>createPropertyChangeListener</code> on the <code>JDesktopPane</code>.
     *
     * @since 1.5
     * @see #createPropertyChangeListener
     */
    protected void installListeners()

    /**
     * Uninstalls the <code>PropertyChangeListener</code> returned from
     * <code>createPropertyChangeListener</code> from the <code>JDesktopPane</code>.
     *
     * @since 1.5
     * @see #createPropertyChangeListener
     */
    protected void uninstallListeners()

    /*
     * Returns the <code>PropertyChangeListener</code> to install on
     * the <code>JDesktopPane</code>.
     *
     * @since 1.5
     * @return The PropertyChangeListener that will be added to track
     * changes in the desktop pane.
     */
    protected PropertyChangeListener createPropertyChangeListener()

4864304: Improve memory consumption of Swing apps

Description:

To cut down on the per instance size of various JComponent subclasses the following changes have been made.

To avoid duplicate storage of the preferred, minimum and maximum size of JComponent's the following methods have been promoted to Component:

    /**
     * Sets the preferred size of this component to a constant
     * value.  Subsequent calls to <code>getPreferredSize</code> will always
     * return this value.  Setting the preferred size to <code>null</code>
     * restores the default behavior.
     *
     * @param preferredSize The new preferred size, or null
     * @see #getPreferredSize
     * @see #isPreferredSizeSet
     * @since 1.5
     */
    public void setPreferredSize(Dimension preferredSize);

    /**
     * Returns true if the preferred size has been set to a
     * non-<code>null</code> value otherwise returns false.
     *
     * @return true if <code>setPreferredSize</code> has been invoked
     *         with a non-null value.
     * @since 1.5
     */
    public boolean isPreferredSizeSet();

    /**
     * Sets the minimum size of this component to a constant
     * value.  Subsequent calls to <code>getMinimumSize</code> will always
     * return this value.  Setting the minimum size to <code>null</code>
     * restores the default behavior.
     *
     * @param minimumSize the new minimum size of this component
     * @see #getMinimumSize
     * @see #isMinimumSizeSet
     * @since 1.5
     */
    public void setMinimumSize(Dimension minimumSize);

    /**
     * Returns whether or not <code>setMinimumSize</code> has been
     * invoked with a non-null value.
     *
     * @return true if <code>setMinimumSize</code> has been invoked with a
     *              non-null value.
     * @since 1.5
     */
    public boolean isMinimumSizeSet();

    /**
     * Sets the maximum size of this component to a constant
     * value.  Subsequent calls to <code>getMaximumSize</code> will always
     * return this value.  Setting the maximum size to <code>null</code>
     * restores the default behavior.
     *
     * @param maximumSize a <code>Dimension</code> containing the
     *               desired maximum allowable size
     * @see #getMaximumSize
     * @see #isMaximumSizeSet
     * @since 1.5
     */
    public void setMaximumSize(Dimension maximumSize);

    /**
     * Returns true if the maximum size has been set to a non-<code>null</code>
     * value otherwise returns false.
     *
     * @return true if <code>maximumSize</code> is non-<code>null</code>,
     *               false otherwise
     * @since 1.5
     */
    public boolean isMaximumSizeSet();

To improve memory needed for autoscrolling JComponent will now override the following method:

    /**
     * Processes mouse events occurring on this component by
     * dispatching them to any registered
     * <code>MouseListener</code> objects, refer to
     * {@link java.awt.Component#processMouseEvent(MouseEvent)}
     * for a complete description of this method.
     *
     * @param       e the mouse event
     * @see         java.awt.Component#processMouseEvent
     * @since 1.5
     */
    protected void processMouseEvent(MouseEvent e);

To reduce the size of AbstractButton's the following methods will be overriden:

    /**
     * Adds the specified component to this container at the specified
     * index, refer to
     * {@link java.awt.Container#addImpl(Component, Object, int)}
     * for a complete description of this method.
     *
     * @param     comp the component to be added
     * @param     constraints an object expressing layout constraints
     *                 for this component
     * @param     index the position in the container's list at which to
     *                 insert the component, where <code>-1</code>
     *                 means append to the end
     * @exception IllegalArgumentException if <code>index</code> is invalid
     * @exception IllegalArgumentException if adding the container's parent
     *                  to itself
     * @exception IllegalArgumentException if adding a window to a container
     * @since 1.5
     */
    protected void addImpl(Component comp, Object constraints, int index);

    /**
     * Sets the layout manager for this container, refer to
     * {@link java.awt.Container#setLayout(LayoutManager)}
     * for a complete description of this method.
     *
     * @param mgr the specified layout manager
     * @since 1.5
     */
    public void setLayout(LayoutManager mgr);

4905905: Swing's key binding mapping documentation if out of date.

Description:

Swing documents the key bindings for various components in the files Key-Index.html, Key-Metal.html, Key-Motif.html and Key-Windows.html. These files are in the directory src/share/classes/javax/swing/doc-files and are referenced by a handful of Swing widgets. These files are extremely dated and never really documented all of Swing's key bindings, they have been removed along with all references to them.

4908889: GTKLookAndFeel should be the system look and feel for Solaris w/Gnome

Description:

Swing's UIManager class is used, among other things, to find out the name of the class that can be used to provide the look and feel for the current system. On Solaris w/Gnome the call getSystemLookAndFeelClassName should return the package name for the GTK look and feel.

This resulted in the following changes to UIManager:

    /**
     * Returns the name of the <code>LookAndFeel</code> class that implements
     * the native systems look and feel if there is one, otherwise
     * the name of the default cross platform <code>LookAndFeel</code>
     * class. If the system property <code>swing.systemlaf</code> has been
     * defined, it's value will be returned.
     *
     * @return the <code>String</code> of the <code>LookAndFeel</code>
     *               class
     *
     * @see #setLookAndFeel
     * @see #getCrossPlatformLookAndFeelClassName
     */
    public static String getSystemLookAndFeelClassName();

    /**
     * Returns the name of the <code>LookAndFeel</code> class that implements
     * the default cross platform look and feel -- the Java
     * Look and Feel (JLF).  If the system property
     * <code>swing.crossplatformlaf</code> has been
     * defined, it's value will be returned.
     *
     * @return  a string with the JLF implementation-class
     * @see #setLookAndFeel
     * @see #getSystemLookAndFeelClassName
     */
    public static String getCrossPlatformLookAndFeelClassName();

As part of this work we also created the WindowsClassicLookAndFeel. This class is useful to force the windows classic look to be used even if you are running XP.

4953840: Add override of getFontMetrics to JComponent

Description:

As a precursor to providing antialiased text in Swing JComponent will now override the following method:

    /**
     * Gets the <code>FontMetrics</code> for the specified <code>Font</code>.
     *
     * @param font the font for which font metrics is to be
     *          obtained
     * @return the font metrics for <code>font</code>
     * @throws NullPointerException if <code>font</code> is null
     * @since 1.5
     */
    public FontMetrics getFontMetrics(Font font);

Potential Incompatibilities

A handful of these API changes have introduced potential incompatibilities between 5.0 and previous releases. Very few developers will be affected by these changes. The possible incompatibilities are listed below:

4607364

Ocean draws a gradient on buttons. The gradient will only be drawn if the contentAreaFilled property is true, or the background property is an instance of UIResource. If you do not want the gradient, either set the contentAreaFilled property to false, or set the background to a non-UIResource. In most cases this is a simple as:

    button.setBackground(Color.RED);

If, for some reason, you are picking up a UIResource you need to create a new Color that is not a UIResource, for example:

    button.setBackground(new Color(oldColor));

4303294

JTree and JList interpret cursor movement relative to the lead. For example, if the lead is on row four in a JTree and you press the up key the selection changes to row three. Similarly, JTree and JList pass an argument to their renderers indicating whether the item being rendered has the focus; this is based on whether the item being rendered is the lead. Prior to 5.0, JTable used the anchor for these situations; in 5.0, JTable uses the lead. This could affect developers that were assuming the anchor was the cell that has the focus and could result in rendering a focus indicator in the wrong situations.

4864304

To render the popup for a JComboBox Sun's look and feels use an instance of JScrollPane. The JScrollPane is configured to never have a horizontal scroll bar. In 5.0 setHorizontalScrollBar(null) is now invoked.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java SE 5 Network Enhancements

Documentation Contents

Networking Features and Enhancements

in Java SE 5.0

  • Complete support for IPv6 on Windows XP (SP1) and 2003 server has been provided in this release. (4608529)
  • The networking API now provides a way of setting timeouts on connect and read operations for protocol handlers. This will benefit any HTTP client application that must behave robustly in the event of server failure. (4700777)
  • A new API provides a mean for Java applications, which includes RMI applications, to be launched via inetd. (4295885, 4673940)
  • The InetAddress class now provides an API to allow testing for the reachability of a host. This features provides a ping-like capability in Java. (4639861)
  • Cookie support has been improved. Applications and web containers can provide Cookie management by implementing the new CookieHandler API. (4696506)
  • Proxy server configuration has been improved. It can now be dynamic and controlable by web containers and applications through the ProxySelector API, which can also handle failures to connect to the proxy. (4696512)
  • A new framework provides a way for protocol handlers to access a file caching mechanism implemented by the platform or by a third party. (4837267)
  • The specification of the URL class now mandates a minimum set of URL protocol handlers that are guaranteed to be present in Java SE. They are http, https, file, jar and ftp. (4180636)
  • There have been a number of enhancements for JSSE (SSL/TLS). For more information, please see: Java SE 5 Security Enhancements

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


AWT Enhancements in Java SE 6.0

Documentation Contents

AWT Enhancements in the Java Standard Edition 6.0

java.awt

Major Features

  • Modality
  • Desktop
  • Splash Screen
  • System Tray
  • Enhancements to Layouting Components
  • Enhancements of the Window class
Fixed Bugs
Known Bugs and Issues

Major Features

The following features were introduced in the Java SE 6.0:

Modality

The new modality model was introduced to handle modality blocking of a dialog box. This model comprises four modality types: modeless, application-modal, document-modal, and toolkit-modal.

public Dialog(Window owner, String title,
                           Dialog.ModalityType modalityType,GraphicsConfiguration gc)

The modalityTypes parameter specifies whether a dialog box blocks input to other windows when shown. The null value and unsupported modality types are equivalent to the modeless type. The getModalityType and setModalityType methods of the Dialog class allows you accordingly to return and set the modality type for the dialog box.

Any top-level window can be marked so it will not be blocked by modal dialogs. This property enables you to set up the modal exclusion mode. The setModalExclusionType method of the Window class specifies one of the following modal exclusion modes: APPLICATION_EXCLUDE, TOOLKIT_EXCLUDE, or NO_EXCLUDE.

See the How to Use Modality in Dialogs section of the Swing tutorial for more information about modality.

Desktop

The Desktop API (java.awt.Desktop) API is provided to allow Java applications to interact with default applications associated with specific file types. All provided actions are represented as a Desktop.Action enumeration instance:

  • BROWSE — Represents a browse action performed by the host's default browser.
  • MAIL — Represents a mail action performed by the host's default email client.
  • OPEN — Represents an open action performed by an application associated with opening a specific file type.
  • EDIT — Represents an edit action performed by an application associated with editing a specific file type
  • PRINT — Represents a print action performed by an application associated with printing a specific file type.

Use the isSupported method of the Desktop class to check whether an action is supported on the current platform.

See the How to Integrate with the Desktop Class section of the Swing tutorial for more information about using the Desktop class.

Splash Screen

There is a new solution that allows the application to display the splash screen before the virtual machine starts has been introduced. Although the SplashScreen class cannot be sued to create a splash screen, a Java application can close the splash screen, change the splash screen image, get the image position/size and paint in the splash screen. An instance of the SplashScreen class can be obtained using the getSplashScreen() static method.

To run an application with the splash screen from the command line use the following command:

java -splash:<file name> <class name>

See the How to Create a Splash Screen section of the Swing Tutorial for more information about splash screen.

System Tray

The SystemTray class is intended to represent the system tray for a desktop. The system tray can be accessed by calling the getSystemTray() static method. The system tray may contain one or more tray icons represented by the TrayIcon class objects. However, the TrayIcon class functionality is not limited to creating a tray icon. It also includes a text tooltip, a pop-up menu, and balloon messages:

TrayIcon trayIcon = new TrayIcon(createImage("icon.gif", "tray icon"));

trayIcon.displayMessage("Sun TrayIcon Demo",
                        "This is an info message", TrayIcon.MessageType.INFO);
trayIcon.setToolTip("Sun TrayIcon");

Note: The current implementation of the TrayIcon class provides limited support of the Swing components. The workaround proposal for this issue is described in the Bug Database, see Bug ID 6285881.

See the How to Use the System Tray section of the Swing Tutorial for more information about the system tray and tray icons.

Enhancements to Layouting Components

Two new methods of the java.awt.Component class enable to obtain the baseline measured from the top of the component and to handle the baseline change as the size of the component changes:

  • public int getBaseline(int width int height)
  • public Component.BaselineResizeBehavior getBaselineResizeBehavior()

FlowLayout:

Two methods were introduced to control vertical components' alignment along their baseline:

  • getAlignOnBaseline()
  • setAlignOnBaseline(boolean)
GridBagLayout:

The following constraints were added to the GridBagConstraints class to enhance lay outing components with the GridBagLayout class:

  • BASELINE
  • BASELINE_LEADING
  • BASELINE_TRAILING
  • ABOVE_BASELINE
  • ABOVE_BASELINE_LEADING
  • ABOVE_BASELINE_TRAILING
  • BELOW_BASELINE
  • BELOW_BASELINE_LEADING
  • BELOW_BASELINE_TRAILING

Additionally the GridBagLayoutInfo class was introduced to store align, size, and baseline parameters for every component within a container while lay outing components using GridBagLayout.

Enhancements the Window class

New methods were added to the Window class to handle images that are displayed as the icon for the window. While the setIconImage(Image image) method sets the only one image, the setIconImages(List<? extends Image> icons) method supports the sequence of images of different dimensions to be applied depending on the platform capabilities.

In Java SE 6 a Window or Dialog object can be created without a parent frame, the owner parameter in constructors of such objects equals null.

Fixed Bugs

Here is a list of the key bug fixes:

6404008 Delivery of mouse events depends on drag sensitivity:

Mouse dragged events were received after the drag sensitivity setting of the operating system is reached. In the proposed solution the drag distance parameter of the operating system is ignored. Java drag events will be ganerated on the first movement of the mouse.

6242833 A mouse cursor does not behave properly after maximizing a window on Linux/JDS 3:

Some events essential for cursor update were not delivered while maximazing a window. The fix comprises x-crossing event handling within XWindow.

4841881: Tabbing by using Alt+Tab on Windows L&F moves focus to the application menu bar

Using Alt+Tab to navigate from a Java window to a native application window and back to the Java window resulted in the focus being moved to the first menu item of the Java window. The proposed fix allows to keep the focus on the initially focused component of the Java window.

6291992: All editable fields get frozen

Editable fields became unable to be edited or to get the focus (JTextField, JTextArea, etc), even in fields that have been previously edited. Other components as combo boxes, tables, radio buttons remain editable.

6176814: Multi-click handling

The XWindow.java code lacks multi click handling. So, when the user dragged the mouse on the screen onto the Linux box, double clicks occurred when the user expected single clicks. Likewise, single clicks occurred when the user expected no clicks at all. The fix includes the AWT_MULTICLICK_SMUDGE variable to apply a smudge factor so that moving the mouse by a small amount does not wipe out the multi-click state variables.

5051557: The applet does not respond to keyboard commands

The applet itself did not get the focus, which apparently went to the embedded frame.This incompatibility was caused by a focus rearchitecture introduced in Java SE 1.4. The fix restores initial proper behavior.

4320050: Minimum size for a Frame object is not being enforced

The Window.setMinimumSize() method has been modified to restrict user-resizing of top-level windows below specified dimensions. Previously, minimum size set for toplevel windows was ignored by platform, so this change can impact code that uses the minimumSize property of top-level windows for its own needs.

6199167: Live resizing

Native applications on Windows had the property to dynamically relayout and repaint during resizing. This property was controlled through system desktop settings. Java disables this property by default. In Java SE 6 the required property is enables by default.

4360364: Cyrillic input is not supported

If a locale was defined incorrectly, a native Input Method did not process keysyms and passed them as is to AWT handleKeyEvent routine. In the fix a conversion table is added and key event handling generally streamlined in non Input Method situations.

Known Bugs and Issues

Here is a list of known problems you may encounter in release 6.0.

5070056: The JWindow component stays on top of all other windows

The JWindow component stays up on top of all other windows hiding other windows behind it on Solaris and Linux. To workaround, you can use an undecorated frame.

6387273: The JVM crash

In some synthetic situations (such as repeated showing/disposing of a toplevel) the JVM may crash.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Networking Features

Documentation Contents

Networking Features and Enhancements

in Java SE 6

Enhancement to Network Interface

Provides a number of new methods for accessing state and configuration information relating to a system's network adapters. This includes information such as the broadcast address, subnet mask, MAC addresses, and MTU size. See java.net.NetworkInterface

The new class java.net.InterfaceAddress encapsulates all information about a NetworkInterface's IP addresses, including the broadcast address, and subnet prefix length (subnet mask)

Support for Internationalized Domain Names

RFCs 3490, 3491, 3492, 3454 define a mechanism where domain names comprised of characters in alphabets other than US ASCII can be stored in the DNS. An algorithm is defined which provides a conversion from arbitrary Unicode strings to and from a "mangled" ASCII form. This feature provides a new class java.net.IDN, which allows applications to do this conversion so that IDNs can be looked up via java.net.InetAddress.

HTTP Negotiate authentication

This adds support for the "Negotiate" HTTP authentication scheme defined by Microsoft. Negotiate allows multiple underlying authentication mechanisms to be supported, and in each instance, one of these mechanisms is chosen for use. Currently, Kerberos is the only supported mechanism. This feature is described in more detail in the guide to Http Authentication.

Cross platform NTLM

Previously, the Microsoft defined NTLM authentication protocol for HTTP was only supported on Windows. Now, this protocol is supported on all platforms.

Default CookieManager implementation

The CookieHandler class was added in 1.5, but no implementation was provided in java.net. This feature provides a simple extensible implementation which separates the storage of cookies from the policy surrounding their acceptance. The default manager provides a number of standard policies and a simple in-memory storage mechanism. User defined policies and storage mechanisms can be used with this implementation. The following are the new classes related to this feature:

  • java.net.CookieManager
  • java.net.CookiePolicy
  • java.net.CookieStore
  • java.net.HttpCookie

Light-weight HTTP server

This provides a simple set of classes and interfaces for building light-weight HTTP server applications. The feature defines two new packages com.sun.net.httpserver and com.sun.net.httpserver.spi. The server supports HTTP and HTTPS.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Rich Internet Applications Enhancements in Java SE 7

Documentation Contents

Java Rich Internet Applications Enhancements in JDK 7

See Java Rich Internet Applications Enhancements in Java SE 7 in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Networking Enhancements in Java SE 7

The URLClassLoader.close method has been added. This method effectively eliminates the problem of how to support updated implementations of the classes and resources loaded from a particular codebase, and in particular from JAR files. See Closing a URLClassLoader for more information.

The Sockets Direct Protocol (SDP) provides access to high performance network connections; see Understanding the Sockets Direct Protocol in The Java Tutorial.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Rich Internet Applications Enhancement in JDK 8

See What's New in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Networking Enhancements in Java SE 8

  • A new class java.net.URLPermission has been added. URLPermission represents a permission for accessing a resource (or set of resources) defined by a given URL, and for a given set of user-settable request methods and request headers.
  • The jdk.net package has been added that contains platform specific socket options and a mechanism for setting these options on all of the standard socket types. The socket options are defined in jdk.net.ExtendedSocketOptions and the first one to be defined is SO_FLOW_SLA, which is an option for establishing socket flows for multitennant applications. The class jdk.net.Sockets provides the mechanism for setting and getting these extended options.
  • In class HttpURLConnection, if a security manager is installed, and if a method is called which results in an attempt to open a connection, the caller must possess either:
    • a "connect" SocketPermission to the host/port combination of the destination URL or
    • a URLPermission that permits this request.

    If automatic redirection is enabled, and this request is redirected to another destination, then the caller must also have permission to connect to the redirected host/URL.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Internationalization Enhancements in Java SE 6

This page provides an overview of internationalization enhancements in Java SE Development Kit 6 (JDK):

  • Core Java Internationalization
  • Desktop Java Internationalization

Core Java Internationalization

Locale Sensitive Services SPIs

To enable plug-in of locale sensitive data (e.g., date format strings) and services (e.g., date formatters), some Service Provider Interfaces (SPIs) for locale-sensitive classes in the java.text and java.util packages have been added. These SPIs make it much easier for developers to provide support of more locales in addition to the currently available locales in Java SE. For example, your own implementation of BreakIterator for Chinese could become available through the BreakIterator.getSentenceInstance factory in the Java runtime.

Unicode Normalizer API

The new java.text.Normalizer class supports the Unicode text normalization defined in Unicode Standard Annex #15.

Internationalized Domain Names Support

The new java.net.IDN class provides Internationalized Domain Names (IDNs) support based on RFC 3490, 3491, 3454, and 3492.

Japanese Imperial Calendar Support

A new Calendar implementation has been added to support the Japanese imperial era-based year numbering, such as Heisei 17 for 2005 (Gregorian). An instance of this Japanese imperial calendar can be created through the Calendar.getInstance factory by specifying a Locale("ja", "JP", "JP"). The java.text.SimpleDateFormat class now supports calendar specific eras and date formats for non-Gregorian calendar systems. Refer to the Supported Calendars documentation for details.

ResourceBundle Enhancements

The new nested java.util.ResourceBundle.Control class has been added to give applications more control over the resource bundle loading process. The class defines a set of callback methods that are invoked by the ResourceBundle.getBundle factory during the resource bundle loading. Applications can override those callback methods to change the factory method behavior.

Additional Locales Support

The following locales are now available.

  • zh_SG - Chinese (Simplified), Singapore
  • en_MT - English, Malta
  • en_PH - English, Philippines
  • en_SG - English, Singapore
  • el_CY - Greek, Cyprus
  • id_ID - Indonesian, Indonesia
  • ga_IE - Irish, Ireland
  • ms_MY - Malay, Malaysia
  • mt_MT - Maltese, Malta
  • pt_BR - Portuguese, Brazil
  • pt_PT - Portuguese, Portugal
  • es_US - Spanish, United States

Refer to the Supported Locales documentation for details.

Desktop Java Internationalization

Key Input in non-English Locales

The keyboard related AWT code has been re-architected to fix various problems on key input in non-English locales for Solaris and Linux operating systems.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Internationalization Enhancements in Java SE 7

The Internationalization enhancements for Java SE 7 include the following:

  • New Scripts and Characters from Unicode 6.0.0
  • Extensible Support for ISO 4217 Currency Codes
  • Category Locale Support
  • Locale Class Supports BCP47 and UTR35
  • New NumericShaper Methods
  • Unicode 6.0 Support in Regular Expressions API

New Scripts and Characters from Unicode 6.0.0

Early versions of the Java SE 7 release added support for Unicode 5.1.0. The final version of the Java SE 7 release supports Unicode 6.0.0. Unicode 6.0.0 is a major version of the Unicode Standard and adds support for over 2000 additional characters, as well as support for properties and data files.

The Java Tutorial has a new section that discusses Unicode.

Extensible Support for ISO 4217 Currency Codes

Currencies are identified by their ISO 4217 codes. These codes maintained by an external agency and are released independent of the Java SE platform. As of Java SE 7, it is possible to accommodate new currencies without requiring a new release of the JDK.

To supersede the default currency at runtime, create a properties file named <JAVA_HOME>/lib/currency.properties. This file contains the key/value pairs of the ISO 3166 country code, and the ISO 4217 currency data. The value part consists of three comma-separated ISO 4217 currency values: an alphabetic code, a numeric code, and a minor unit. Any lines beginning with the hash character, #, are treated as comment lines. For example:

# Sample currency property for Japan
JP=JPZ,999,0

The new API for this feature includes the following methods, all in the Currency class:

  • getAvailableCurrencies – Returns the set of available currencies.
  • getNumericCode – Returns the ISO 4217 numeric code of this currency
  • getDisplayName – Gets the name suitable for displaying this currency for the default locale.
  • getDisplayName(Locale) – Gets the name suitable for displaying the specified locale.

Category Locale Support

The default locale can be independently set for two types of uses: the format setting is used for formatting resources, and the display setting is used in menus and dialogs. The new getDefault(Locale.Category) method takes a Locale.Category parameter. Passing the FORMAT enum to the method returns the default locale for formatting resources. Similarly, passing the DISPLAY enum returns the default locale used by the UI. The setDefault(Locale.Category, Locale) method is used to set the locale for the specified category. The no-argument getDefault method returns the DISPLAY default value.

On Microsoft Windows, these default values are initialized according to the "Standard and Formats" and "Display Language" settings in the Windows control panel.

Locale Class Supports BCP47 and UTR35

The Locale class has been updated to implement identifiers interchangeable with BCP 47 (IETF BCP 47, "Tags for Identifying Languages"), with support for the LDML (UTS#35, "Unicode Locale Data Markup Language") BCP 47-compatible extensions for locale data exchange.

The following nested classes have been added to the Locale class in this release:

  • Locale.Builder can be used to create a Locale instance and to configure that instance using setter methods.

The following methods have been added to the Locale class:

  • getExtensionKeys()
  • getExtension(char)
  • getUnicodeLocaleType(String
  • getUnicodeLocaleKeys()
  • getUnicodeLocaleAttributes()
  • forLanguageTag(String)
  • toLanguageTag()
  • getScript()
  • getDisplayScript()
  • getDisplayScript(Locale)

The following constants have been added to the LOCALE class:

  • UNICODE_LOCALE_EXTENSION
  • PRIVATE_USE_EXTENSION

For more information, see the Creating a Locale and BCP 47 Extensions lessons in the Java Tutorial.

New NumericShaper Methods

The NumericShaper class is used to convert Latin-1 (European) digits to other Unicode decimal digits. For the Java SE 7 release, the NumericShaper.Range enum has been added to represent a Unicode range of a script having its own decimal digits. The following methods, using the NumericShaper.Range enum have been added to the Java SE 7 release:

  • getShaper(NumericShaper.Range) - returns a shaper for the provided Unicode range.
  • getContextualShaper(Set<NumericShaper.Range>) - returns a contextual shaper for the provided Unicode range(s). The shaper assumes European as the starting context.
  • getContextualShaper(Set<NumericShaper.Range> NumericShaper.Range) - returns a contextual shaper for the provided Unicode range(s). The shaper uses the defaultContext as the starting context.
  • shape(char[], int, int, NumericShaper.Range) - converts the digits in the text that occur between start and start + count, using the provided context.

For more information, see the Converting Latin Digits to Other Unicode Digits lesson in the Java Tutorial.

Unicode 6.0 Support in Regular Expressions API

The Regular Expressions pattern matching functionality has been expanded to support Unicode 6.0. You can match Unicode code points using either the \u or the \x escape sequence.

The Unicode Support page in the Java Tutorial has more information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Internationalization Enhancements in JDK 8

The Internationalization enhancements for JDK 8 include the following:

  • Unicode Enhancements
  • Adoption of Unicode CLDR Data and the java.locale.providers System Property
  • New Calendar and Locale APIs
  • Ability to Install a Custom Resource Bundle as an Extension

Unicode Enhancements

The JDK 8 release includes support for Unicode 6.2.0. Since the release of JDK 7, which supported Unicode 6.0, the Unicode 6.1.0 and 6.2.0 specs introduced the following new features that are now included in JDK 8:

  • 733 new characters including Turkish Lira sign
  • 7 new scripts:

    • Meroitic Hieroglyphs
    • Meroitic Cursive
    • Sora Sompeng
    • Chakma
    • Sharada
    • Takri
    • Miao

  • 11 new blocks - including 7 blocks for the new scripts listed above and 4 blocks for the following existing scripts:

    • Arabic Extended-A
    • Sundanese Supplement
    • Meetei Mayek Extensions
    • Arabic Mathematical Alphabetical Symbols

The Java Tutorial has a section that discusses Unicode.

Adoption of Unicode CLDR Data and the java.locale.providers System Property

The Unicode Consortium has released the Common Locale Data Repository (CLDR) project to "support the world's languages, with the largest and most extensive standard repository of locale data available." The CLDR is becoming the de-facto standard for locale data.

The CLDR's XML-based locale data has been incorporated into the JDK 8 release, however it is disabled by default.

There are now four distinct sources for locale data:

  • CLDR represents the locale data provided by the Unicode CLDR project.
  • HOST represents the current user's customization of the underlying operating system's settings. It works only with the user's default locale, and the customizable settings may vary depending on the OS, but primarily Date, Time, Number, and Currency formats are supported.
  • SPI represents the locale sensitive services implemented in the installed SPI providers.
  • JRE represents the locale data that is compatible with the prior JRE releases.

To select the desired locale data source, use the java.locale.providers system property, listing the data sources in the preferred order. For example:

java.locale.providers=HOST,SPI,CLDR,JRE

The default behavior is equivalent to the following setting:

java.locale.providers=JRE,SPI

For further information, see the API specification page for java.util.spi.LocaleServiceProvider and the "JDK 8 and JRE 8 Supported Locales" page, which becomes available after the release of Oracle JDK 8.

New Calendar and Locale APIs

As the Unicode Common Locale Data Repository (CLDR) project continues to evolve, the Java SE API is updated. The JDK 8 release includes two new classes, several new methods, and a new return value for an existing static method:

  • The DecimalFormatSymbols.getInstance(Locale) static method is now able to recognize Locale.UNICODE_LOCALE_EXTENSION for the numbering system.
  • Two new abstract classes for service providers are added to the java.util.spi package. The CalendarDataProvider abstract class provides localized week parameters. The CalendarNameProvider abstract class provides field values names for displaying a calendar's name. This class recognizes the following calendar type strings:
    • "gregory" - Gregorian/Julian hybrid
    • "buddhist" - Thai Buddhist
    • "japanese" - Japanese Imperial
  • The new method, LocaleServiceProvider.html#isSupportedLocale(Locale), returns true if the specified locale is supported by the locale service provider.
  • The new Calendar.getCalendarType() method returns the calendar type string ("gregory", "buddhist", "japanese").
  • New style specifiers, used by the Calendar.getDisplayName and Calendar.getDisplayNames methods, determine the format of the Calendar name:
    • Calendar.SHORT_FORMAT
    • Calendar.LONG_FORMAT
    • Calendar.SHORT_STANDALONE
    • Calendar.LONG_STANDALONE
  • Two new Locale methods for dealing with a locale's (optional) extensions:
    • Locale.hasExtensions()
    • Locale.stripExtensions()
    For more information, see BCP 47 Extensions in the Java Tutorial.
  • Two new Locale.filter methods return a list of Locale instances that match the specified criteria, as defined in RFC 4647:
    • Locale.filter(List<Local.LanguageRange>, Collection<Locale>)
    • Locale.filter(List<Locale.LanguageRange>, Collection<Locale>, Locale.FilteringMode)
  • Two new Locale.filterTags methods return a list of language tags that match the specified criteria, as defined in RFC 4647:
    • Locale.filterTags(List<Locale.LanguageRange>, Collection<String>)
    • Locale.filterTags(List<Locale.LanguageRange>, Collection<String>, Locale.FilteringMode)
  • Two new lookup methods return the best-matching locale or language tag using the lookup mechanism defined in RFC 4647:
    • Locale.lookup(List<Local.LanguageRange>, Collection)
    • Locale.lookupTag(List<Locale.LanguageRange>, Collection<String>)

Ability to Install a Custom Resource Bundle as an Extension

JDK 8 introduces the java.util.spi.ResourceBundleControlProvider interface, which is a service provider interface (SPI). SPIs enable you to create extensible applications, which are those that you can extend easily without modifying their original code base. This SPI enables you to change how the method ResourceBundle getBundle(String baseName, Locale targetLocale) loads resource bundles. Note that this method does not require an instance of the ResourceBundle.Control class. An installed implementation of the ResourceBundleControlProvider SPI replaces the default ResourceBundle.Control class, which defines the default bundle loading process. See Installing a Custom Resource Bundle as an Extension for more information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Sound Enhancements in JDK 5.0

The following enhancements took effect at JDK 5.0.

  • Ports are available on all platforms (RFE 4782900).
  • MIDI device i/o is available on all platforms (RFE's 4812168, 4782924).
  • Optimized direct audio access is implemented on all platforms (RFEs 4908240 and 4908879). It is enabled by default on systems which offer native mixing (i.e. Linux ALSA with hardware mixing, Solaris Mixer enabled, Windows DirectSound).
  • The new real-time Sequencer works with all MIDI devices and allows unlimited Transmitters (RFE 4773012).
  • The sound.properties configuration file allows choice of default devices (RFE 4776511). For details, see MidiSystem and AudioSystem for details.
  • MidiDevices can query connected Receivers and Transmitters (RFE 4931387, methods MidiDevice.getReceiver and MidiDevice.getTransmitter).
  • AudioFormat, AudioFileFormat, and MidiFileFormat now have properties that allow further description and qualification of the format (RFEs 4925767 and 4666845).
  • A set of ease-of-use methods allow easier retrieval of lines from AudioSystem (RFE 4896221).
  • The Sequencer interface is extended with loop methods, for seamless looping of specific portions of a MIDI sequence (RFE 4204105).
  • Java Sound no longer prevents the VM from exiting (bug 4735740).
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Sound Enhancements in JDK 7

The following enhancement took effect in JDK 7:

New Software Synthesizer Implementation

Gervill, a software synthesizer implementation, has replaced the Java Sound software synthesizer implementation. Gervill has the following advantages over the old software synthesizer implementation:

  • Open source: The old software synthesizer implementation is part of a licensed library, which cannot be released as open source
  • Supports DLS and SF2: Gervill supports the standards DLS (Downloadable Sounds) Level 2.2 and SF2 (SoundFont) 2.04, both of which are widely used and whose file formats are publicly available; the old software synthesizer uses a proprietary soundbank file format (GM), which is not widely used
  • Supports extended General MIDI standards: Gervill supports General MIDI Level 2 (GM2) and MIDI Tuning; the old software synthesizer supports only GM1
  • Support for resampling (sample rate conversion): A new audio format conversion provider (which supports resampling) was developed as part of the Gervill project

Because Java SE 7 uses Gervill, the following features are not available:

  • GM soundbank support
  • RMF file playback support
  • OSS (Open Sound System) support on Linux

See RFE 6702956.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface org.w3c.dom.Entity (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Entity

No usage of org.w3c.dom.Entity
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.EntityReference (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.EntityReference

  • Packages that use EntityReference
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM).

    • Uses of EntityReference in org.w3c.dom

      Methods in org.w3c.dom that return EntityReference
      Modifier and Type Method and Description
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.source.doctree.EntityTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.doctree.EntityTree

  • Packages that use EntityTree
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of EntityTree in com.sun.source.doctree

      Methods in com.sun.source.doctree with parameters of type EntityTree
      Modifier and Type | Method and Description
      R | DocTreeVisitor.visitEntity(EntityTree node, P p)

    • Uses of EntityTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type EntityTree
      Modifier and Type | Method and Description
      R | SimpleDocTreeVisitor.visitEntity(EntityTree node, P p)
      R | DocTreeScanner.visitEntity(EntityTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Enums

In prior releases, the standard way to represent an enumerated type was the int Enum pattern:
// int Enum Pattern - has severe problems!
public static final int SEASON_WINTER = 0;
public static final int SEASON_SPRING = 1;
public static final int SEASON_SUMMER = 2;
public static final int SEASON_FALL   = 3;
This pattern has many problems, such as:
  • Not typesafe - Since a season is just an int you can pass in any other int value where a season is required, or add two seasons together (which makes no sense).
  • No namespace - You must prefix constants of an int enum with a string (in this case SEASON_) to avoid collisions with other int enum types.
  • Brittleness - Because int enums are compile-time constants, they are compiled into clients that use them. If a new constant is added between two existing constants or the order is changed, clients must be recompiled. If they are not, they will still run, but their behavior will be undefined.
  • Printed values are uninformative - Because they are just ints, if you print one out all you get is a number, which tells you nothing about what it represents, or even what type it is.
It is possible to get around these problems by using the Typesafe Enum pattern (see Effective Java Item 21), but this pattern has its own problems: It is quite verbose, hence error prone, and its enum constants cannot be used in switch statements.

In 5.0, the Java™ programming language gets linguistic support for enumerated types. In their simplest form, these enums look just like their C, C++, and C# counterparts:

enum Season { WINTER, SPRING, SUMMER, FALL }

But appearances can be deceiving. Java programming language enums are far more powerful than their counterparts in other languages, which are little more than glorified integers. The new enum declaration defines a full-fledged class (dubbed an enum type). In addition to solving all the problems mentioned above, it allows you to add arbitrary methods and fields to an enum type, to implement arbitrary interfaces, and more. Enum types provide high-quality implementations of all the Object methods. They are Comparable and Serializable, and the serial form is designed to withstand arbitrary changes in the enum type.

Here is an example of a playing card class built atop a couple of simple enum types. The Card class is immutable, and only one instance of each Card is created, so it need not override equals or hashCode:

import java.util.*;

public class Card {
    public enum Rank { DEUCE, THREE, FOUR, FIVE, SIX,
        SEVEN, EIGHT, NINE, TEN, JACK, QUEEN, KING, ACE }

    public enum Suit { CLUBS, DIAMONDS, HEARTS, SPADES }

    private final Rank rank;
    private final Suit suit;
    private Card(Rank rank, Suit suit) {
        this.rank = rank;
        this.suit = suit;
    }

    public Rank rank() { return rank; }
    public Suit suit() { return suit; }
    public String toString() { return rank + " of " + suit; }

    private static final List<Card> protoDeck = new ArrayList<Card>();

    // Initialize prototype deck
    static {
        for (Suit suit : Suit.values())
            for (Rank rank : Rank.values())
                protoDeck.add(new Card(rank, suit));
    }

    public static ArrayList<Card> newDeck() {
        return new ArrayList<Card>(protoDeck); // Return copy of prototype deck
    }
}
The toString method for Card takes advantage of the toString methods for Rank and Suit. Note that the Card class is short (about 25 lines of code). If the typesafe enums (Rank and Suit) had been built by hand, each of them would have been significantly longer than the entire Card class.

The (private) constructor of Card takes two parameters, a Rank and a Suit. If you accidentally invoke the constructor with the parameters reversed, the compiler will politely inform you of your error. Contrast this to the int enum pattern, in which the program would fail at run time.

Note that each enum type has a static values method that returns an array containing all of the values of the enum type in the order they are declared. This method is commonly used in combination with the for-each loop to iterate over the values of an enumerated type.

The following example is a simple program called Deal that exercises Card. It reads two numbers from the command line, representing the number of hands to deal and the number of cards per hand. Then it creates a new deck of cards, shuffles it, and deals and prints the requested hands.

import java.util.*;

public class Deal {
    public static void main(String args[]) {
        int numHands = Integer.parseInt(args[0]);
        int cardsPerHand = Integer.parseInt(args[1]);
        List<Card> deck  = Card.newDeck();
        Collections.shuffle(deck);
        for (int i=0; i < numHands; i++)
            System.out.println(deal(deck, cardsPerHand));
    }

    public static ArrayList<Card> deal(List<Card> deck, int n) {
         int deckSize = deck.size();
         List<Card> handView = deck.subList(deckSize-n, deckSize);
         ArrayList<Card> hand = new ArrayList<Card>(handView);
         handView.clear();
         return hand;
     }
}

$ java Deal 4 5
[FOUR of HEARTS, NINE of DIAMONDS, QUEEN of SPADES, ACE of SPADES, NINE of SPADES]
[DEUCE of HEARTS, EIGHT of SPADES, JACK of DIAMONDS, TEN of CLUBS, SEVEN of SPADES]
[FIVE of HEARTS, FOUR of DIAMONDS, SIX of DIAMONDS, NINE of CLUBS, JACK of CLUBS]
[SEVEN of HEARTS, SIX of CLUBS, DEUCE of DIAMONDS, THREE of SPADES, EIGHT of CLUBS]

Suppose you want to add data and behavior to an enum. For example consider the planets of the solar system. Each planet knows its mass and radius, and can calculate its surface gravity and the weight of an object on the planet. Here is how it looks:

public enum Planet {
    MERCURY (3.303e+23, 2.4397e6),
    VENUS   (4.869e+24, 6.0518e6),
    EARTH   (5.976e+24, 6.37814e6),
    MARS    (6.421e+23, 3.3972e6),
    JUPITER (1.9e+27,   7.1492e7),
    SATURN  (5.688e+26, 6.0268e7),
    URANUS  (8.686e+25, 2.5559e7),
    NEPTUNE (1.024e+26, 2.4746e7),
    PLUTO   (1.27e+22,  1.137e6);

    private final double mass;   // in kilograms
    private final double radius; // in meters
    Planet(double mass, double radius) {
        this.mass = mass;
        this.radius = radius;
    }
    public double mass()   { return mass; }
    public double radius() { return radius; }

    // universal gravitational constant  (m3 kg-1 s-2)
    public static final double G = 6.67300E-11;

    public double surfaceGravity() {
        return G * mass / (radius * radius);
    }
    public double surfaceWeight(double otherMass) {
        return otherMass * surfaceGravity();
    }
}

The enum type Planet contains a constructor, and each enum constant is declared with parameters to be passed to the constructor when it is created.

Here is a sample program that takes your weight on earth (in any unit) and calculates and prints your weight on all of the planets (in the same unit):

    public static void main(String[] args) {
        double earthWeight = Double.parseDouble(args[0]);
        double mass = earthWeight/EARTH.surfaceGravity();
        for (Planet p : Planet.values())
           System.out.printf("Your weight on %s is %f%n",
                             p, p.surfaceWeight(mass));
    }

$ java Planet 175
Your weight on MERCURY is 66.107583
Your weight on VENUS is 158.374842
Your weight on EARTH is 175.000000
Your weight on MARS is 66.279007
Your weight on JUPITER is 442.847567
Your weight on SATURN is 186.552719
Your weight on URANUS is 158.397260
Your weight on NEPTUNE is 199.207413
Your weight on PLUTO is 11.703031

The idea of adding behavior to enum constants can be taken one step further. You can give each enum constant a different behavior for some method. One way to do this by switching on the enumeration constant. Here is an example with an enum whose constants represent the four basic arithmetic operations, and whose eval method performs the operation:

public enum Operation {
    PLUS, MINUS, TIMES, DIVIDE;

    // Do arithmetic op represented by this constant
    double eval(double x, double y){
        switch(this) {
            case PLUS:   return x + y;
            case MINUS:  return x - y;
            case TIMES:  return x * y;
            case DIVIDE: return x / y;
        }
        throw new AssertionError("Unknown op: " + this);
    }
}
This works fine, but it will not compile without the throw statement, which is not terribly pretty. Worse, you must remember to add a new case to the switch statement each time you add a new constant to Operation. If you forget, the eval method with fail, executing the aforementioned throw statement

There is another way give each enum constant a different behavior for some method that avoids these problems. You can declare the method abstract in the enum type and override it with a concrete method in each constant. Such methods are known as constant-specific methods. Here is the previous example redone using this technique:

public enum Operation {
  PLUS   { double eval(double x, double y) { return x + y; } },
  MINUS  { double eval(double x, double y) { return x - y; } },
  TIMES  { double eval(double x, double y) { return x * y; } },
  DIVIDE { double eval(double x, double y) { return x / y; } };

  // Do arithmetic op represented by this constant
  abstract double eval(double x, double y);
}

Here is a sample program that exercises the Operation class. It takes two operands from the command line, iterates over all the operations, and for each operation, performs the operation and prints the resulting equation:

    public static void main(String args[]) {
        double x = Double.parseDouble(args[0]);
        double y = Double.parseDouble(args[1]);
        for (Operation op : Operation.values())
            System.out.printf("%f %s %f = %f%n", x, op, y, op.eval(x, y));
    }

$ java Operation 4 2
4.000000 PLUS 2.000000 = 6.000000
4.000000 MINUS 2.000000 = 2.000000
4.000000 TIMES 2.000000 = 8.000000
4.000000 DIVIDE 2.000000 = 2.000000
Constant-specific methods are reasonably sophisticated, and many programmers will never need to use them, but it is nice to know that they are there if you need them.

Two classes have been added to java.util in support of enums: special-purpose Set and Map implementations called EnumSet and EnumMap. EnumSet is a high-performance Set implementation for enums. All of the members of an enum set must be of the same enum type. Internally, it is represented by a bit-vector, typically a single long. Enum sets support iteration over ranges of enum types. For example given the following enum declaration:

    enum Day { SUNDAY, MONDAY, TUESDAY, WEDNESDAY, THURSDAY, FRIDAY, SATURDAY }
you can iterate over the weekdays. The EnumSet class provides a static factory that makes it easy:
    for (Day d : EnumSet.range(Day.MONDAY, Day.FRIDAY))
        System.out.println(d);
Enum sets also provide a rich, typesafe replacement for traditional bit flags:
    EnumSet.of(Style.BOLD, Style.ITALIC)

Similarly, EnumMap is a high-performance Map implementation for use with enum keys, internally implemented as an array. Enum maps combine the richness and safety of the Map interface with speed approaching that of an array. If you want to map an enum to a value, you should always use an EnumMap in preference to an array.

The Card class, above, contains a static factory that returns a deck, but there is no way to get an individual card from its rank and suit. Merely exposing the constructor would destroy the singleton property (that only a single instance of each card is allowed to exist). Here is how to write a static factory that preserves the singleton property, using a nested EnumMap:

private static Map<Suit, Map<Rank, Card>> table =
    new EnumMap<Suit, Map<Rank, Card>>(Suit.class);
static {
    for (Suit suit : Suit.values()) {
        Map<Rank, Card> suitTable = new EnumMap<Rank, Card>(Rank.class);
        for (Rank rank : Rank.values())
            suitTable.put(rank, new Card(rank, suit));
        table.put(suit, suitTable);
    }
}

public static Card valueOf(Rank rank, Suit suit) {
    return table.get(suit).get(rank);
}
The EnumMap (table) maps each suit to an EnumMap that maps each rank to a card. The lookup performed by the valueOf method is internally implemented as two array accesses, but the code is much clearer and safer. In order to preserve the singleton property, it is imperative that the constructor invocation in the prototype deck initialization in Card be replaced by a call to the new static factory:
    // Initialize prototype deck
    static {
        for (Suit suit : Suit.values())
            for (Rank rank : Rank.values())
                protoDeck.add(Card.valueOf(rank, suit));
    }
It is also imperative that the initialization of table be placed above the initialization of protoDeck, as the latter depends on the former.

So when should you use enums? Any time you need a fixed set of constants. That includes natural enumerated types (like the planets, days of the week, and suits in a card deck) as well as other sets where you know all possible values at compile time, such as choices on a menu, rounding modes, command line flags, and the like. It is not necessary that the set of constants in an enum type stay fixed for all time. The feature was specifically designed to allow for binary compatible evolution of enum types.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Environment Variables and System Properties

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

C Environment Variables and System Properties

This appendix describes environment variables and system properties that can be useful for troubleshooting problems with the Java HotSpot VM.

Submit a Bug Report contains information on collecting environment variables in Environment Variables.

This appendix contains the following sections:

  • The JAVA_HOME Environment Variable

  • The JAVA_TOOL_OPTIONS Environment Variable

  • The java.security.debug System Property

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


The JAVA_HOME Environment Variable

This variable indicates the directory where the Java Development Kit (JDK) software is installed.

 Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


The JAVA_TOOL_OPTIONS Environment Variable

In many environments the command line is not readily accessible to start the application with necessary command-line options. This often arises with applications that use embedded VMs (meaning they use the Java Native Interface (JNI) Invocation API to start the VM), or where the startup is deeply nested in scripts. In these environments the JAVA_TOOL_OPTIONS environment variable can be useful to augment a command line.

When this environment variable is set, the JNI_CreateJavaVM function (in the JNI Invocation API) prepends the value of the environment variable to the options supplied in its JavaVMInitArgs argument.

Note:

In some cases this option is disabled for security reasons (for example, on Oracle Solaris operating system this option is disabled when the effective user or group ID differs from the real ID).

This environment variable allows you to specify the initialization of tools, specifically the launching of native or Java programming language agents using the -agentlib or -javaagent options. In the following example the environment variable is set so that the HPROF profiler is launched when the application is started:

$ export JAVA_TOOL_OPTIONS="-agentlib:hprof"

This variable can also be used to augment the command line with other options for diagnostic purposes. For example, you can supply the -XX:OnError option to specify a script or command to be executed when a fatal error occurs.

Since this environment variable is examined at the time the JNI_CreateJavaVM function is called, it cannot be used to augment the command line with options that would normally be handled by the launcher, for example, VM selection using the -client option or the -server option.

For more information on JAVA_TOOL_OPTIONS environment variable, see Java tool options from JVM Tool Interface documentation.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


The java.security.debug System Property

This system property controls whether the security system of the Java Runtime Environment (JRE) prints trace messages during execution. This option can be useful when diagnosing an issue involving a security manager when a SecurityException is thrown.

The java.security.debug property can have the following values:

  • access

    Print all checkPermission results.

    The following additional options can be specified with the access option:

    • stack

      Include stack trace.

    • domain

      Dump all domains in context.

    • failure

      Before throwing an exception, dump the stack and domain that did not have permission.

  • jar

    Print JAR verification information.

  • policy

    Print permissions that SecureClassLoader assigns.

  • scl

    For example, to print all checkPermission results and trace all domains in context, set the java.security.debug property to access,stack. To trace access failures, set the property to access,failure.

    Example C-1 shows the output of a checkPermission failure.

    Example C-1 Program for checkPermission Failure

    $ java -Djava.security.debug="access,failure" MyApp
access denied (java.net.SocketPermission server.foobar.com resolve
)
java.lang.Exception: Stack trace
    at java.lang.Thread.dumpStack(Thread.java:1158)
    at java.security.AccessControlContext.checkPermission
                          (AccessControlContext.java:253)
    at java.security.AccessController.checkPermission(AccessController.java:427)
    at java.lang.SecurityManager.checkPermission(SecurityManager.java:532)
    at java.lang.SecurityManager.checkConnect(SecurityManager.java:1031)
    at java.net.InetAddress.getAllByName0(InetAddress.java:1117)
    at java.net.InetAddress.getAllByName0(InetAddress.java:1098)
    at java.net.InetAddress.getAllByName(InetAddress.java:1061)
    at java.net.InetAddress.getByName(InetAddress.java:958)
    at java.net.InetSocketAddress.<init>(InetSocketAddress.java:124)
    at java.net.Socket.<init>(Socket.java:178)
    at MyApp.main(MyApp.java:7)

    For more information on java.security.debug system property, see Troubleshooting Security from Java SE Security documentation.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Ergonomics

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

2 Ergonomics

Ergonomics is the process by which the Java Virtual Machine (JVM) and garbage collection tuning, such as behavior-based tuning, improve application performance. The JVM provides platform-dependent default selections for the garbage collector, heap size, and runtime compiler. These selections match the needs of different types of applications while requiring less command-line tuning. In addition, behavior-based tuning dynamically tunes the sizes of the heap to meet a specified behavior of the application.

This section describes these default selections and behavior-based tuning. Use these defaults first before using the more detailed controls described in subsequent sections.

Garbage Collector, Heap, and Runtime Compiler Default Selections

A class of machine referred to as a server-class machine has been defined as a machine with the following:

  • 2 or more physical processors

  • 2 or more GB of physical memory

On server-class machines, the following are selected by default:

  • Throughput garbage collector

  • Initial heap size of 1/64 of physical memory up to 1 GB

  • Maximum heap size of 1/4 of physical memory up to 1 GB

  • Server runtime compiler

For initial heap and maximum heap sizes for 64-bit systems, see the section Default Heap Size in The Parallel Collector.

The definition of a server-class machine applies to all platforms with the exception of 32-bit platforms running a version of the Windows operating system. Table 2-1, "Default Runtime Compiler", shows the choices made for the runtime compiler for different platforms.

Table 2-1 Default Runtime Compiler

Platform | Operating System | DefaultFoot1 | Default if Server-ClassFootref1
i586 | Linux | Client | Server
i586 | Windows | Client | ClientFoot2
SPARC (64-bit) | Solaris | Server | ServerFoot3
AMD (64-bit) | Linux | Server | ServerFootref3
AMD (64-bit) | Windows | Server | ServerFootref3

Footnote1Client means the client runtime compiler is used. Server means the server runtime compiler is used.

Footnote2The policy was chosen to use the client runtime compiler even on a server class machine. This choice was made because historically client applications (for example, interactive applications) were run more often on this combination of platform and operating system.

Footnote3Only the server runtime compiler is supported.

Behavior-Based Tuning

For the parallel collector, Java SE provides two garbage collection tuning parameters that are based on achieving a specified behavior of the application: maximum pause time goal and application throughput goal; see the section The Parallel Collector. (These two options are not available in the other collectors.) Note that these behaviors cannot always be met. The application requires a heap large enough to at least hold all of the live data. In addition, a minimum heap size may preclude reaching these desired goals.

Maximum Pause Time Goal

The pause time is the duration during which the garbage collector stops the application and recovers space that is no longer in use. The intent of the maximum pause time goal is to limit the longest of these pauses. An average time for pauses and a variance on that average is maintained by the garbage collector. The average is taken from the start of the execution but is weighted so that more recent pauses count more heavily. If the average plus the variance of the pause times is greater than the maximum pause time goal, then the garbage collector considers that the goal is not being met.

The maximum pause time goal is specified with the command-line option -XX:MaxGCPauseMillis=<nnn>. This is interpreted as a hint to the garbage collector that pause times of <nnn> milliseconds or less are desired. The garbage collector will adjust the Java heap size and other parameters related to garbage collection in an attempt to keep garbage collection pauses shorter than <nnn> milliseconds. By default there is no maximum pause time goal. These adjustments may cause garbage collector to occur more frequently, reducing the overall throughput of the application. The garbage collector tries to meet any pause time goal before the throughput goal. In some cases, though, the desired pause time goal cannot be met.

Throughput Goal

The throughput goal is measured in terms of the time spent collecting garbage and the time spent outside of garbage collection (referred to as application time). The goal is specified by the command-line option -XX:GCTimeRatio=<nnn>. The ratio of garbage collection time to application time is 1 / (1 + <nnn>). For example, -XX:GCTimeRatio=19 sets a goal of 1/20th or 5% of the total time for garbage collection.

The time spent in garbage collection is the total time for both the young generation and old generation collections combined. If the throughput goal is not being met, then the sizes of the generations are increased in an effort to increase the time that the application can run between collections.

Footprint Goal

If the throughput and maximum pause time goals have been met, then the garbage collector reduces the size of the heap until one of the goals (invariably the throughput goal) cannot be met. The goal that is not being met is then addressed.

Tuning Strategy

Do not choose a maximum value for the heap unless you know that you need a heap greater than the default maximum heap size. Choose a throughput goal that is sufficient for your application.

The heap will grow or shrink to a size that will support the chosen throughput goal. A change in the application's behavior can cause the heap to grow or shrink. For example, if the application starts allocating at a higher rate, the heap will grow to maintain the same throughput.

If the heap grows to its maximum size and the throughput goal is not being met, the maximum heap size is too small for the throughput goal. Set the maximum heap size to a value that is close to the total physical memory on the platform but which does not cause swapping of the application. Execute the application again. If the throughput goal is still not met, then the goal for the application time is too high for the available memory on the platform.

If the throughput goal can be met, but there are pauses that are too long, then select a maximum pause time goal. Choosing a maximum pause time goal may mean that your throughput goal will not be met, so choose values that are an acceptable compromise for the application.

It is typical that the size of the heap will oscillate as the garbage collector tries to satisfy competing goals. This is true even if the application has reached a steady state. The pressure to achieve a throughput goal (which may require a larger heap) competes with the goals for a maximum pause time and a minimum footprint (which both may require a small heap).

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.ErroneousTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ErroneousTree

  • Packages that use ErroneousTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ErroneousTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ErroneousTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitErroneous(ErroneousTree node, P p)

    • Uses of ErroneousTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ErroneousTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitErroneous(ErroneousTree node, P p)
      R | TreeScanner.visitErroneous(ErroneousTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION occurred at PC=0xe6a1067
Function name=Java_NativeSEGV_foo
Library=D:\testcases\NativeSEGV\NativeSEGV.dll
Source file = NativeSEGV.c : 7

Current Java thread:
    at NativeSEGV.foo(Native Method)
    at NativeSEGV.main(NativeSEGV.java:26)

Dynamic libraries:
0x00400000 - 0x00405000 	d:\jdk1.3.1\bin\java.exe
0x77F60000 - 0x77FBE000 	C:\WINNT\System32\ntdll.dll
0x77DC0000 - 0x77DFF000 	C:\WINNT\system32\ADVAPI32.dll
0x77F00000 - 0x77F5E000 	C:\WINNT\system32\KERNEL32.dll
0x77E70000 - 0x77EC4000 	C:\WINNT\system32\USER32.dll
0x77ED0000 - 0x77EFC000 	C:\WINNT\system32\GDI32.dll
0x77E10000 - 0x77E67000 	C:\WINNT\system32\RPCRT4.dll
0x78000000 - 0x78040000 	C:\WINNT\system32\MSVCRT.dll
0x10000000 - 0x10018000 	C:\WINNT\System32\NVDESK32.DLL
0x08000000 - 0x08273000 	d:\jdk1.3.1\jre\bin\server\jvm.dll
0x77FD0000 - 0x77FFA000 	C:\WINNT\System32\WINMM.dll
0x4FA00000 - 0x4FA77000 	C:\WINNT\System32\cwcmmsys.dll
0x50220000 - 0x50227000 	d:\jdk1.3.1\jre\bin\hpi.dll
0x503B0000 - 0x503BD000 	d:\jdk1.3.1\jre\bin\verify.dll
0x50250000 - 0x50266000 	d:\jdk1.3.1\jre\bin\java.dll
0x503C0000 - 0x503CD000 	d:\jdk1.3.1\jre\bin\zip.dll
0x0E6A0000 - 0x0E6C2000 	D:\testcases\NativeSEGV\NativeSEGV.dll
0x77920000 - 0x77942000 	C:\WINNT\System32\imagehlp.dll
0x72A00000 - 0x72A2D000 	C:\WINNT\System32\DBGHELP.dll
0x731B0000 - 0x731BA000 	C:\WINNT\System32\PSAPI.DLL

Local Time = Fri Dec 15 17:14:02 2000
Elapsed Time = 1
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Server VM (internal-release mixed mode)
#
# An error report file has been saved as hs_err_pid102.log.
# Please refer to the file for further information.
#


Error Reporting

When the Java Virtual Machine (JVM) detects a crash in native code such as JNI code written by the developer or when the JVM itself crashes, it will print debug information about the crash. This error message normally will include information such as the function name, library name, source-file name and line number at which the error occurred. (Currently, information about file name and line number are available only available on Microsoft Windows platforms.) For an example of a message emitted by the error handler, see JNI Error example.

The information provided by the new error-reporting mechanism will allow developers to more easily and efficiently debug their applications. If an error message indicates a problem in the JVM code itself, it will allow a developer to submit a more accurate and helpful bug report.

Sometimes the error-reporting mechanism won't be able to determine the information that might be helpful in locating the source of a crash. To get the most out of the error handler, developers should be aware of the following guidelines and limitations.

Compile in debug mode

In some circumstances, the error-reporting mechanism won't be able to determine symbol names. The most common reason for this is that the binary code that crashed was not compiled in debug mode and therefore doesn't have symbol tables. Developers should compile their code in debug mode to ensure that it contains the necessary debug information. In Visual Studio, for example, this means choosing "Debug" rather than "Release" as the project's build mode. When using gcc or cc on Linux or on the Solaris operating environment, compile using the -g command-line option.

Non-exported functions

Even without debug information in the binary code, the error handler can still print the function name of the crash site. However, the function name might not be correct if the problematic function is not "exported" from the dynamic library. On Linux and Solaris, all functions are exported except those declared static. On Microsoft Windows platforms, no functions are exported unless explicitly declared so (using JNIEXPORT or __declspec(dllexport)).

Visual Studio limitation on Windows 98 and Windows NT

On Windows 98 and Windows NT platforms, the error handler uses the system's imagehlp.dll file to help determine the function name, source file, and line number of a crash site. (Windows 2000 and Windows ME use two files, imagehlp.dll and debughlp.dll to perform this task.) However, the imagehlp.dll file in Windows 98 and Windows NT does not work well with binary code and DLLs generated by Visual Studio 6.0.

This problem may cause the error handler to generate error messages with incorrect information about the function name, source file and line number of the crash site, though other information in the error message will be correct.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Skip navigation bar
Contents | Previous | Next Java Management Extensions (JMX) Technology Tutorial

Chapter 2

Essentials of the JMX API

This chapter introduces the fundamental notion of the Java Management Extensions (JMX) API, namely managed beans, or MBeans.

An MBean is a managed Java object, similar to a JavaBeanTM, that follows the design patterns set forth in the instrumentation level of the JMX specification. An MBean can represent a device, an application, or any resource that needs to be managed. MBeans expose a management interface: a set of readable and/or writable attributes and a set of invokable operations, along with a self-description. The management interface does not change throughout the life of an MBean instance. MBeans can also emit notifications when certain defined events occur.

The JMX specification defines four types of MBean: standard MBeans, dynamic MBeans, open MBeans and model MBeans. The examples in this chapter demonstrate the simplest type of MBean, namely standard MBeans.

Standard MBeans

A standard MBean is defined by writing a Java interface called SomethingMBean and a Java class called Something that implements that interface. Every method in the interface defines either an attribute or an operation in the MBean. By default every method defines an operation. Attributes and operations are simply methods which follow certain design patterns. A standard MBean is composed of the MBean interface which lists the methods for all exposed attributes and operations, and the class which implements this interface and provides the functionality of the instrumented resource.

The following sections dissect an example standard MBean, and a simple JMX agent that manages the MBean. The code samples are taken from the directory work_dir/jmx_examples/Essential/com/example/mbeans.

MBean Interface

An example of a very basic MBean interface, named HelloMBean, is shown in CODE EXAMPLE 2-1.

CODE EXAMPLE 2-1 Example MBean Interface, HelloMBean

package com.example.mbeans;

public interface HelloMBean {

    public void sayHello();
    public int add(int x, int y);

    public String getName();

    public int getCacheSize();
    public void setCacheSize(int size);
}

As stated previously, by convention an MBean interface takes the name of the Java class that implements it, with the suffix MBean added. So, in this case, the interface is called HelloMBean. The Hello class that implements this interface is described in Section "MBean Implementation".

According to the JMX specification, an MBean interface consists of named and typed attributes that are readable and possibly writable, and named and typed operations that can be invoked by the applications that are managed by the MBean. The HelloMBean interface shown in CODE EXAMPLE 2-1, declares two operations: the Java methods add() and sayHello().

Of the two attributes that are declared by HelloMbean, Name is a read-only string, and CacheSize is an integer that can be both read and written. Getter and setter methods are declared, to allow the managed application to access and possibly change the attribute values. As defined by the JMX specification, a getter is any public method whose name begins with get and which does not return void. A getter enables a manager to read the value of the attribute, whose type is that of the returned object. A setter is any public method whose name begins with set and which takes a single parameter. A setter enables a manager to write a new value in the attribute, whose type is the same as that of the parameter.

The implementation of these operations and attributes is shown in the following section.

MBean Implementation

The Hello class shown in CODE EXAMPLE 2-1 implements HelloMBean.

CODE EXAMPLE 2-1 Example MBean Implementation Class, Hello

package com.example.mbeans;

public class Hello implements HelloMBean {
    public void sayHello() {
        System.out.println("hello, world");
    }

    public int add(int x, int y) {
        return x + y;
    }

    public String getName() {
        return this.name;
    }

    public int getCacheSize() {
        return this.cacheSize;
    }

    public synchronized void setCacheSize(int size) {
        this.cacheSize = size;

        System.out.println("Cache size now " + this.cacheSize);
    }

    private final String name = "Reginald";
    private int cacheSize = DEFAULT_CACHE_SIZE;
    private static final int DEFAULT_CACHE_SIZE = 200;
}

The straightforward Java class Hello provides the definitions of the operations and attributes declared by HelloMBean. As you can see, the sayHello() and add() operations are extremely simple, but real-life operations can be as simple or as sophisticated as you like.

Methods to get the Name attribute and to get and set the cacheSize attribute are also defined. In this example, the Name attribute value never changes, but in a real scenario it might change as the managed resource runs. For example, the attribute might represent statistics such as uptime or memory usage. Here, it is merely the name “Reginald”.

Calling the setCacheSize method allows you to alter the cacheSize attribute from its declared default value of 200. In reality, changing the cacheSize attribute could require other operations to be performed, such as discarding entries or allocating new ones. This example merely prints a message to confirm that the cache size has changed, but more sophisticated operations could be defined in the place of the simple call to println().

With the simple Hello MBean and its interface thus defined, they can now be used to manage the resource they represent, as shown in the following section.

Managing a Resource

As presented in the Java Management Extensions (JMX) Technology Overview, once a resource has been instrumented by MBeans, the management of that resource is performed by a JMX agent.

The core component of a JMX agent is the MBean server, a managed object server in which MBeans are registered (see the API documentation for the MBeanServer interface for details of the MBean server implementation). A JMX agent also includes a set of services to manage MBeans.

CODE EXAMPLE 2-1 presents a basic JMX agent, named Main.

CODE EXAMPLE 2-1 Creating a JMX Agent

package com.example.mbeans;

import java.lang.management.*;
import javax.management.*;

public class Main {

   public static void main(String[] args) throws Exception {

      MBeanServer mbs = ManagementFactory.getPlatformMBeanServer();

      ObjectName name = new ObjectName("com.example.mbeans:type=Hello");

      Hello mbean = new Hello();

      mbs.registerMBean(mbean, name);

      System.out.println("Waiting forever...");
      Thread.sleep(Long.MAX_VALUE);
   }
}

The JMX agent Main begins by obtaining any MBean server that is running on the platform, by calling the getPlatformMBeanServer() method of the java.lang.management.ManagementFactory class. If there is no MBean server already running on the platform, then getPlatformMBeanServer() creates one automatically by calling the JMX method MBeanServerFactory.createMBeanServer(). The MBeanServer instance obtained by Main is named mbs.

Next, Main defines an object name for the MBean instance it will create. Every JMX MBean must have an object name. The object name is an instance of the JMX class ObjectName, and must conform to the syntax defined by the JMX specification, namely it must comprise a domain, and a list of key-properties (see the API documentation for the ObjectName class for details of this syntax). In the object name defined by Main, name, the domain is com.example.mbeans (the package in which the example MBeans are contained) and the key-property declares that this object is of the type Hello.

An instance of a Hello object is created, named mbean. This Hello object is itself an instance of the MBean Hello that was defined in Section "MBean Implementation".

The Hello object named mbean is then registered as an MBean in the MBean server mbs with the object name name, by passing the object and the object name into a call to the JMX method MBeanServer.registerMBean().

With the Hello MBean registered in the MBean server, Main will simply wait for management operations to be performed on Hello. In the scope of this example, these management operations are invoking sayHello(), and add(), and getting and setting the attribute values.

Running the Standard MBean Example

Having examined the example classes, you can now run the example. The Java Platform, Standard Edition comes with a management and monitoring console, named JConsole, that is used to interact with the MBean in this example. JConsole is located in JavaSE_HOME/bin/jconsole, in which JavaSE_HOME is the installation directory of the Java Platform, Standard Edition (Java SE platform).

To run the example, follow the steps below, or see the README file:

  2. If you have not done so already, open work_dir/jmx_examples/Essential.

    $ cd work_dir/jmx_examples/Essential

  3. Compile the example Java classes.

    $ javac com/example/mbeans/*.java

  4. Start the Main application.

    $ java com.example.mbeans.Main

    You will see confirmation that Main is waiting for something to happen.

  5. Start JConsole in a different terminal window on the same machine.

    $ jconsole

    You will see the JConsole tool open, presenting a list of running JMX agents that you can connect to.

  6. Select com.example.mbeans.Main from the list in the “New Connection” window, and click on “Connect”.

    You will see a summary of your platform’s current activity.

  7. Click on the “MBeans” tab.

    This panel shows you all the MBeans currently registered in the MBean server.

  8. In the left-hand frame, expand the com.example.mbeans node in the MBean tree.

    You will see the example MBean Hello, that was created and registered by Main. If you click on Hello, you will see its associated Attributes and Operations nodes in the MBean tree.

  9. Click on the Hello MBean node in the MBean tree.

    The Hello MBean’s metadata and its associated Descriptor will be displayed.

  10. Click on the Attributes node of the Hello MBean in the MBean tree.

    This displays the MBean attributes that were defined by the Hello class.

  11. Change the value of the CacheSize attribute to 150

    In the terminal window in which you started Main, you will see confirmation of this change of attribute.

  12. Click on the Operations node of the Hello MBean in the MBean tree.

    Here you will see the two operations declared by the Hello MBean, sayHello() and add().

  13. Invoke the sayHello() operation, by clicking on the sayHello button.

    A JConsole dialogue box will inform you that the method was invoked successfully, and you will see the message “hello, world” in the terminal window in which Main is running.

  14. Provide two integers for the add() operation to add up, and click on the add button.

    You will be informed of the answer in a JConsole dialogue box.

  15. Click on “Connection” and then “Exit”, to exit JConsole.

Sending Notifications

MBeans can generate notifications, for example to signal a state change, a detected event, or a problem.

For an MBean to generate notifications, it must implement the interface NotificationBroadcaster, or its subinterface NotificationEmitter. All you need to do to send a notification is to construct an instance of the class javax.management.Notification or a subclass (such as AttributeChangedNotification), and pass it to NotificationBroadcasterSupport.sendNotification.

Every notification has a source. The source is the object name of the MBean that emitted the notification.

Every notification has a sequence number. This number can be used to order notifications coming from the same source when order matters and there is a danger of the notifications being handled in the wrong order. It is all right for the sequence number to be zero, but it is better for it to increment for each notification from a given MBean.

There is an example of a standard MBean that emits notifications in the directory work_dir/jmx_examples/Notification/com/example/mbeans. This example is essentially the same as the example seen in Section "Standard MBeans", except that the Hello MBean implements the NotificationBroadcaster interface.

NotificationBroadcaster Interface

As stated above, the only difference between this example and the one presented in Section "Standard MBeans" is the fact that the MBean implementation allows for the sending of notifications.

Notifications are activated by implementing the NotificationBroadcaster interface, as shown in CODE EXAMPLE 2-1.

CODE EXAMPLE 2-1 Implementing MBean Notifications

package com.example.mbeans;

import javax.management.*;

public class Hello
        extends NotificationBroadcasterSupport implements HelloMBean {

    public void sayHello() {
        System.out.println("hello, world");
    }

    public int add(int x, int y) {
        return x + y;
    }

    public String getName() {
        return this.name;
    }

    public int getCacheSize() {
        return this.cacheSize;
    }

    public synchronized void setCacheSize(int size) {
        int oldSize = this.cacheSize;
        this.cacheSize = size;

        System.out.println("Cache size now " + this.cacheSize);

        Notification n =
            new AttributeChangeNotification(this,
                                            sequenceNumber++,
                                            System.currentTimeMillis(),
                                            "CacheSize changed",
                                            "CacheSize",
                                            "int",
                                            oldSize,
                                            this.cacheSize);

        sendNotification(n);
    }

    @Override
    public MBeanNotificationInfo[] getNotificationInfo() {
        String[] types = new String[] {
            AttributeChangeNotification.ATTRIBUTE_CHANGE
        };
        String name = AttributeChangeNotification.class.getName();
        String description = "An attribute of this MBean has changed";
        MBeanNotificationInfo info =
            new MBeanNotificationInfo(types, name, description);
        return new MBeanNotificationInfo[] {info};
    }

    private final String name = "Reginald";
    private int cacheSize = DEFAULT_CACHE_SIZE;
    private static final int DEFAULT_CACHE_SIZE = 200;

    private long sequenceNumber = 1;
}

As you can see in CODE EXAMPLE 2-1, this Hello MBean implementation extends the NotificationBroadcasterSupport class, that itself implements the NotificationEmitter interface.

The operations and attributes are set in the same way as before, with the only exception that the cacheSize attribute’s setter method now defines a new value oldSize, which records the cacheSize attribute’s value prior to the set operation.

The notification is constructed from an instance, n, of the JMX class AttributeChangeNotification, which extends javax.management.Notification. The notification is constructed within the definition of the setCacheSize() method, from the following information, that is passed to AttributeChangeNotification as parameters:

  • The object name of the source of the notification, namely the Hello MBean, represented simply by this
  • A sequence number, which in this example is a long named sequenceNumber, that is set at 1 and that increases incrementally
  • A timestamp
  • The content of the notification message
  • The name of the attribute that has changed, in this case cacheSize
  • The type of attribute that has changed
  • The old attribute value, in this case oldSize
  • The new attribute value, in this case this.cacheSize

The notification n is then passed to the NotificationBroadcasterSupport.sendNotification() method.

Finally, the MBeanNotification is defined to describe the characteristics of the different notification instances emitted by the MBean for a given Java class of notification, which in this case is AttributeChangeNotification notifications.

The MBean interface, HelloMBean, and the JMX agent Main are identical to those used in the previous example.

Running the MBean Notification Example

Having examined the example classes, you can now run the example. This example again uses JConsole to interact with the Hello MBean.To run the example, follow the steps below, or see the README file:

  2. If you have not done so already, open work_dir/jmx_examples/Notification.

    $ cd work_dir/jmx_examples/Notification

  3. Compile the example Java classes.

    $ javac com/example/mbeans/*.java

  4. Start the Main application.

    $ java com.example.mbeans.Main

    You will see confirmation that Main is waiting for something to happen.

  5. Start JConsole in a different terminal window on the same machine.

    $ jconsole

    You will see the JConsole tool open, presenting a list of running JMX agents that you can connect to.

  6. Select com.example.mbeans.Main from the list in the “New Connection” window, and click on “Connect”.

    You will see a summary of your platform’s current activity.

  7. Click on the “MBeans” tab.

    This panel shows you all the MBeans currently registered in the MBean server.

  8. In the left-hand frame, expand the com.example.mbeans node in the MBean tree.

    You will see the example MBean Hello, that was created and registered by Main. If you click on Hello, you will see its associated Attributes, Operations and Notifications nodes in the MBean tree.

  9. Click on the Hello MBean node in the MBean tree.

    This displays the MBean’s metadata and its associated Descriptor.

  10. Click on the Notifications node of the Hello MBean in the MBean tree.

    You will see that the panel is blank.

  11. Click on the “Subscribe” button.

    The current number of notifications received (0), will be displayed in the Notifications node label.

  12. Click on the Attributes node of the Hello MBean in the MBean tree, and change the value of the CacheSize attribute to 150

    In the terminal window in which you started Main, you will see confirmation of this change of attribute. You will also see that the number of notifications received displayed in the Notifications node has changed to 1.

  13. Click on the Notifications node of the Hello MBean in the MBean tree again.

    You will see the details of the notification that was sent.

  14. Click on “Connection” and then “Exit”, to exit JConsole.

Introducing MXBeans

An MXBean is a new type of MBean that provides a simple way to code an MBean that only references a pre-defined set of types. In this way, you can be sure that your MBean will be usable by any client, including remote clients, without any requirement that the client have access to model-specific classes representing the types of your MBeans. MXBeans provide a convenient way to bundle related values together without requiring clients to be specially configured to handle the bundles.

In the same way as for standard MBeans, an MXBean is defined by writing a Java interface called Something MXBean and a Java class that implements that interface. However, unlike standard MBeans, MXBeans do not require the Java class to be called Something. Every method in the interface defines either an attribute or an operation in the MXBean. The annotation @MXBean can be also used to annotate the Java interface instead of requiring the interface’s name to be followed by the MXBean suffix.

MXBeans provide a convenient way to bundle related values together in an MBean without requiring clients to be specially configured to handle the bundles when interacting with that MBean. MXBeans already existed in the Java 2 Platform, Standard Edition (J2SE) 5.0, in the package java.lang.management. With the Java SE 6 platform, users can now define their own MXBeans, in addition to the standard set defined in java.lang.management.

The key idea behind MXBeans is that types such as java.lang.management.MemoryUsage that are referenced in the MXBean interface, java.lang.management.MemoryMXBean in this case, are mapped into a standard set of types, the so-called Open Types that are defined in the package javax.management.openmbean. The exact mapping rules appear in the MXBean specification, but to oversimplify we could say that simple types like int or String are unchanged, while complex types like MemoryUsage get mapped to the standard type CompositeDataSupport.

The operation of MXBeans is demonstrated by example programs that you will find in the directory work_dir/jmx_examples/MXBean/com/example/mxbeans after you have downloaded and unzipped the jmx_examples.zip file. The MXBean example contains the following files:

  • QueueSamplerMXBean interface.
  • QueueSampler class that implements the MXBean interface.
  • QueueSample Java type returned by the getQueueSample() method in the MXBean interface.
  • Main, the program that sets up and runs the example.

The MXBean example performs the following actions.

  • Defines a simple MXBean that manages a resource of type Queue<String>.
  • Declares a getter, getQueueSample, in the MXBean that takes a snapshot of the queue when invoked and returns a Java class QueueSample that bundles the following values together:
  • The time the snapshot was taken.
  • The queue size.
  • The head of the queue at that given time.
  • Registers the MXBean in an MBean server.

QueueSamplerMXBean Interface

CODE EXAMPLE 2-1 shows the code of the sample QueueSamplerMXBean interface.

CODE EXAMPLE 2-1 QueueSamplerMXBean interface

package com.example.mxbeans;

public interface QueueSamplerMXBean {
    public QueueSample getQueueSample();
    public void clearQueue();
}

As you can see, you declare an MXBean interface in exactly the same way as you declare a standard MBean. The QueueSamplerMXBean interface declares two operations, getQueueSample and clearQueue.

QueueSampler Class

The QueueSampler class implements the QueueSamplerMXBean interface, as shown in CODE EXAMPLE 2-1.

CODE EXAMPLE 2-1 QueueSampler Class
package com.example.mxbeans;

import java.util.Date;
import java.util.Queue;

public class QueueSampler implements QueueSamplerMXBean {

    private Queue<String> queue;

    public QueueSampler(Queue<String> queue) {
       this.queue = queue;
    }

    public QueueSample getQueueSample() {
        synchronized (queue) {
            return new QueueSample(new Date(), queue.size(), queue.peek());
        }
    }

    public void clearQueue() {
        synchronized (queue) {
            queue.clear();
        }
    }
}

The MXBean operations getQueueSample() and clearQueue() declared by the MXBean interface are defined in QueueSampler. The getQueueSample() operation simply returns an instance of the QueueSample Java type, created with the values returned by the java.util.Queue methods peek() and size() and an instance of java.util.Date.

QueueSample Class

The QueueSample instance returned by QueueSampler is defined in the QueueSample class shown in CODE EXAMPLE 2-1.

CODE EXAMPLE 2-1 QueueSample Class
package com.example.mxbeans;

import java.beans.ConstructorProperties;
import java.util.Date;

public class QueueSample {

    private final Date date;
    private final int size;
    private final String head;

    @ConstructorProperties({"date", "size", "head"})
    public QueueSample(Date date, int size, String head) {
        this.date = date;
        this.size = size;
        this.head = head;
    }

    public Date getDate() {
        return date;
    }

    public int getSize() {
        return size;
    }

    public String getHead() {
        return head;
    }
}

In QueueSample class, the MXBean framework calls all the getters in QueueSample to convert the given instance into a CompositeData and uses the @ConstructorProperties annotation to reconstruct a QueueSample instance from a CompositeData.

Creating and Registering the MXBean in the MBean Server

Having defined an MXBean interface and the class that implements it, as well as the Java type that is returned, the MXBean must now be created and registered in an MBean server. These actions are performed by the example class Main.

CODE EXAMPLE 2-1 MXBean example Main class
package com.example.mxbeans;

import java.lang.management.ManagementFactory;
import java.util.Queue;
import java.util.concurrent.ArrayBlockingQueue;
import javax.management.MBeanServer;
import javax.management.ObjectName;

public class Main {

    public static void main(String[] args) throws Exception {
        MBeanServer mbs = ManagementFactory.getPlatformMBeanServer();

        ObjectName name =
                new ObjectName("com.example.mxbeans:type=QueueSampler");

        Queue<String> queue = new ArrayBlockingQueue<String>(10);
        queue.add("Request-1");
        queue.add("Request-2");
        queue.add("Request-3");
        QueueSampler mxbean = new QueueSampler(queue);

        mbs.registerMBean(mxbean, name);

        System.out.println("Waiting...");
        Thread.sleep(Long.MAX_VALUE);
    }
}

The Main class gets the platform MBean server, creates an object name for the MXBean QueueSampler, creates a Queue instance for the QueueSampler MXBean to process, and feeds this Queue instance to a newly created QueueSampler MXBean. The MXBean is then registered in the MBean server in exactly the same way as a standard MBean.

Running the MXBean Example

To run the example, follow the steps below, or see the README file:

  2. If you have not done so already, open work_dir/jmx_examples/MXBean.

    $ cd work_dir/jmx_examples/MXBean

  3. Compile the example Java classes.

    $ javac com/example/mxbeans/*.java

  4. Start the Main application.

    $ java com.example.mxbeans.Main

    You will see confirmation that Main is waiting for something to happen.

  5. Start JConsole in a different terminal window on the same machine.

    $ jconsole

    You will see the JConsole tool open, presenting a list of running JMX agents that you can connect to.

  6. Select com.example.mxbeans.Main from the list in the “New Connection” window, and click on “Connect”.

    You will see a summary of your platform’s current activity.

  7. Click on the “MBeans” tab.

    This panel shows you all the MBeans currently registered in the MBean server.

  8. In the left-hand frame, expand the com.example.mxbeans node in the MBean tree.

    You will see the example MBean QueueSampler, that was created and registered by Main. If you click on QueueSampler, you will see its associated Attributes and Operations nodes in the MBean tree.

  9. Select the Attributes node.

    You will see the QueueSample attribute appear in the right-hand pane, with its value of javax.management.openmbean.CompositeDataSupport.

  10. Double-click on the CompositeDataSupport value.

    You can see the QueueSample values date, head and size because the MXBean framework has converted the QueueSample instance into CompositeData. If you had defined QueueSampler as a Standard MBean rather than as an MXBean, JConsole would not have found the QueueSample class because it would not be in its class path. If QueueSampler had been a standard MBean, you would have received a ClassNotFoundException when retrieving the QueueSample attribute value. This demonstrates the usefulness of using MXBeans when connecting to JMX agents through generic JMX clients, like JConsole.

  11. Select the Operations node.

    You will see a button to invoke the clearQueue operation.

  12. Click on the clearQueue button.

    You will be informed that the method was invoked successfully.

  13. Select the Attributes node again and double click on the CompositeDataSupport value.

    The queue has been reset now.

  14. Click on “Connection” and then “Exit”, to exit JConsole.

In this example JConsole has been used as the JMX client but if you were to access your MXBean programmatically in a JMX client you write yourself, then you could do so in one of two ways:

  • Generically, using the following code.
CODE EXAMPLE 2-1 Accessing an MXBean directly

MBeanServer mbs = ...whatever...;
ObjectName name = new ObjectName("com.example.mxbeans:type=QueueSampler");
CompositeData queueSample = (CompositeData) mbs.getAttribute(name,
                             "QueueSample");
int size = (Integer) queueSample.get("size");
  • Via a proxy, using the following code.
CODE EXAMPLE 2-2 Accessing an MXBean via a proxy

MBeanServer mbs = ...whatever...;
ObjectName name = new ObjectName("com.example.mxbeans:type=QueueSampler");
QueueSamplerMXBean proxy = JMX.newMXBeanProxy(mbs, name,
                                              QueueSamplerMXBean.class);
QueueSample queueSample = proxy.getQueueSample();
int size = queueSample.getSize();

CODE EXAMPLE 2-2 uses the newMXBeanProxy method to create the MXBean proxy. An equivalent method, newMBeanProxy, exists to create proxies for other types of MBeans. The newMBeanProxy and newMXBeanProxy methods are used in exactly the same way.

MBean Descriptors

Descriptors allow you to give additional information about MBeans to management clients. For example, a Descriptor on an MBean attribute might say what units it is measured in, or what its minimum and maximum possible values are. As of Java SE 6, Descriptors are an integrated part of the JMX API and are available in all types of MBeans.

Descriptors give you a convenient way to attach arbitrary extra metadata to your MBeans. Descriptors have always existed in the JMX API, but until Java SE 6 they were only available in conjunction with Model MBeans.

For most constructors in the classes MBean*Info (MBeanInfo, MBeanAttributeInfo, and so on), a parallel constructor exists with the same parameters plus an additional javax.management.Descriptor parameter. The same is true for OpenMBean*InfoSupport. The MBean*Info and OpenMBean*InfoSupport classes contain a getDescriptor() method.

Open MBeans return information about default and legal values from the getDefaultValue(), getLegalValues(), getMaxValue(), getMinValue() methods of OpenMBeanParameterInfo and OpenMBeanAttributeInfo. This information is now also present in the corresponding Descriptors, and other types of MBean can also return the information in their Descriptors.

MBean Descriptors are demonstrated in the example classes you will find in the directory work_dir/jmx_examples/Descriptors/com/example/mxbeans after you have downloaded and unzipped the jmx_examples.zip file. The MBean Descriptor example contains the following files.

  • Author, an annotation the supplies the name of the author of the MBean interface.
  • DisplayName, an annotation that supplies a display name for methods in the MBean interface.
  • Main, the program that sets up and runs the example.
  • QueueSamplerMXBean interface.
  • QueueSampler class that implements the MXBean interface.
  • QueueSample Java type returned by the getQueueSample() method in the MXBean interface.
  • Version, an annotation that supplies the current version of the MBean interface.

The QueueSampler MXBean in this example basically performs the same actions as the MXBean example presented in Chapter 2, "Introducing MXBeans", except with the addition of MBean Descriptors. This example shows how the DescriptorKey meta-annotation can be used to add new descriptor items to the Descriptors for a standard MBean (or an MXBean) via annotations in the standard MBean (or MXBean) interface.

DescriptorKey Annotations

A new annotation DescriptorKey can be used to add information to the Descriptors for a standard MBean (or MXBean) via annotations in the Standard MBean (or MXBean) interface. This makes it possible for a tool that generates standard MBeans from an existing management model to include information from the model in the generated MBean interfaces, rather than in separate files.

CODE EXAMPLE 2-1 shows the definition of the annotation Author.

CODE EXAMPLE 2-1 Author Annotation

package com.example.mxbeans;

import java.lang.annotation.Documented;
import java.lang.annotation.ElementType;
import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;
import java.lang.annotation.Target;
import javax.management.DescriptorKey;

@Documented
@Target(ElementType.TYPE)
@Retention(RetentionPolicy.RUNTIME)
public @interface Author {
    @DescriptorKey("author")
    String value();
}

This annotation supplies the name of the creator of the MBean interface. A new field author will be added to the MBeanInfo Descriptor with the value defined by the @Author annotation. The files Version and DisplayName define annotations of those names in exactly the same way as for Author above. In each of Version and DisplayName, the @DescriptorKey value is “version” and “displayname” respectively.

In the case of Version, a new field version will be added to the MBeanInfo Descriptor with the value defined by the @Version annotation.

For DisplayName, new field displayName will be added to the MBeanAttributeInfo Descriptor or the MBeanOperationInfo Descriptor with the value defined by the @DisplayName annotation depending on whether the annotated method is a getter/setter or an operation, respectively.

Using MBean Descriptors

The QueueSamplerMXBean interface used in this example is slightly different from the one used in the MXBeans example, in as much as it implements MBean Descriptors to publish some of its information.

CODE EXAMPLE 2-1 QueueSamplerMXBean with Descriptors.

package com.example.mxbeans;

@Author("Mr Bean")
@Version("1.0")
public interface QueueSamplerMXBean {
    @DisplayName("GETTER: QueueSample")
    public QueueSample getQueueSample();
    @DisplayName("OPERATION: clearQueue")
    public void clearQueue();
}

Here, you see that the @Author annotation is set to Mr. Bean, the @Version annotation is set to 1.0, and the @DisplayName is set to the names either of the attribute QueueSample or the operation clearQueue.

Running the MBean Descriptors Example

To run the example, follow the steps below, or see the README file:

  2. If you have not done so already, open work_dir/jmx_examples/Descriptors.

    $ cd work_dir/jmx_examples/Descriptors

  3. Compile the example Java classes.

    $ javac com/example/mxbeans/*.java

  4. Start the Main application.

    $ java com.example.mxbeans.Main

    You will see confirmation that Main is waiting for something to happen.

  5. Start JConsole in a different terminal window on the same machine.

    $ jconsole

    You will see the JConsole tool open, presenting a list of running JMX agents that you can connect to.

  6. Select com.example.mxbeans.Main from the list in the “New Connection” window, and click on “Connect”.

    You will see a summary of your platform’s current activity.

  7. Click on the “MBeans” tab.

    This panel shows you all the MBeans currently registered in the MBean server.

  8. In the left-hand frame, expand the com.example.mxbeans node in the MBean tree.

    You will see the example MBean QueueSampler, that was created and registered by Main. If you click on QueueSampler, you will see its associated Attributes and Operations nodes in the MBean tree.You will also see the fields author and version in the MBeanInfo Descriptor table.

  9. Expand the Attributes and Operations nodes under the QueueSampler MBean node.

    You will see the individual Attributes and Operations.

  10. Select the QueueSample node.

    You will see the field displayName in the MBeanAttributeInfo Descriptor table.

  11. Select the clearQueue node.

    You will see the field displayName in the MBeanOperationInfo Descriptor table.

  12. Click on “Connection” and then “Exit”, to exit JConsole.

Contents | Previous | Next

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface org.w3c.dom.events.Event (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.Event

  • Packages that use Event
    Package Description
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Event in org.w3c.dom.events

      Subinterfaces of Event in org.w3c.dom.events
      Modifier and Type Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
      interface  MutationEvent
      The MutationEvent interface provides specific contextual information associated with Mutation events.
      interface  UIEvent
      The UIEvent interface provides specific contextual information associated with User Interface events.
      Methods in org.w3c.dom.events that return Event
      Modifier and Type | Method and Description
      Event | DocumentEvent.createEvent(String eventType)
      Methods in org.w3c.dom.events with parameters of type Event
      Modifier and Type Method and Description
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void EventListener.handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • Uses of Event in org.w3c.dom.ls

      Subinterfaces of Event in org.w3c.dom.ls
      Modifier and Type Interface and Description
      interface  LSLoadEvent
      This interface represents a load event object that signals the completion of a document load.
      interface  LSProgressEvent
      This interface represents a progress event object that notifies the application about progress as a document is parsed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class org.w3c.dom.events.EventException (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.events.EventException

  • Packages that use EventException
    Package Description
    org.w3c.dom.events

    • Uses of EventException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw EventException
      Modifier and Type Method and Description
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.jdi.event.EventIterator (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.EventIterator

  • Packages that use EventIterator
    Package Description
    com.sun.jdi.event
    This package defines JDI events and event processing.

    • Uses of EventIterator in com.sun.jdi.event

      Methods in com.sun.jdi.event that return EventIterator
      Modifier and Type Method and Description
      EventIterator EventSet.eventIterator()
      Return an iterator specific to Event objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.EventListener (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.EventListener

  • Packages that use EventListener
    Package Description
    org.w3c.dom.events

    • Uses of EventListener in org.w3c.dom.events

      Methods in org.w3c.dom.events with parameters of type EventListener
      Modifier and Type Method and Description
      void EventTarget.addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      void EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface com.sun.jdi.event.EventQueue (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.EventQueue

  • Packages that use EventQueue
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of EventQueue in com.sun.jdi

      Methods in com.sun.jdi that return EventQueue
      Modifier and Type Method and Description
      EventQueue VirtualMachine.eventQueue()
      Returns the event queue for this virtual machine.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.EventRequest (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.EventRequest

  • Packages that use EventRequest
    Package Description
    com.sun.jdi.event
    This package defines JDI events and event processing.
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of EventRequest in com.sun.jdi.event

      Methods in com.sun.jdi.event that return EventRequest
      Modifier and Type | Method and Description
      EventRequest | Event.request()

    • Uses of EventRequest in com.sun.jdi.request

      Subinterfaces of EventRequest in com.sun.jdi.request
      Modifier and Type Interface and Description
      interface  AccessWatchpointRequest
      Request for notification when the contents of a field are accessed in the target VM.
      interface  BreakpointRequest
      Identifies a Location in the target VM at which execution should be stopped.
      interface  ClassPrepareRequest
      Request for notification when a class is prepared in the target VM.
      interface  ClassUnloadRequest
      Request for notification when a class is unloaded in the target VM.
      interface  ExceptionRequest
      Request for notification when an exception occurs in the target VM.
      interface  MethodEntryRequest
      Request for notification when a method is invoked in the target VM.
      interface  MethodExitRequest
      Request for notification when a method returns in the target VM.
      interface  ModificationWatchpointRequest
      Request for notification when a field is set.
      interface  MonitorContendedEnteredRequest
      Request for notification of a thread in the target VM entering a monitor after waiting for it to be released by another thread.
      interface  MonitorContendedEnterRequest
      Request for notification of a thread in the target VM attempting to enter a monitor already acquired by another thread.
      interface  MonitorWaitedRequest
      Request for notification when a thread in the target VM has finished waiting on a monitor object.
      interface  MonitorWaitRequest
      Request for notification when a thread in the target VM is about to wait on a monitor object.
      interface  StepRequest
      Request for notification when a step occurs in the target VM.
      interface  ThreadDeathRequest
      Request for notification when a thread terminates in the target VM.
      interface  ThreadStartRequest
      Request for notification when a thread starts execution in the target VM.
      interface  VMDeathRequest
      Request for notification when the target VM terminates.
      interface  WatchpointRequest
      Identifies a Field in the target VM being watched.
      Methods in com.sun.jdi.request with parameters of type EventRequest
      Modifier and Type Method and Description
      void EventRequestManager.deleteEventRequest(EventRequest eventRequest)
      Removes an eventRequest.
      Method parameters in com.sun.jdi.request with type arguments of type EventRequest
      Modifier and Type Method and Description
      void EventRequestManager.deleteEventRequests(List<? extends EventRequest> eventRequests)
      Removes a list of EventRequests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.EventRequestManager (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.EventRequestManager

  • Packages that use EventRequestManager
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of EventRequestManager in com.sun.jdi

      Methods in com.sun.jdi that return EventRequestManager
      Modifier and Type Method and Description
      EventRequestManager VirtualMachine.eventRequestManager()
      Returns the event request manager for this virtual machine.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.event.EventSet (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.EventSet

  • Packages that use EventSet
    Package Description
    com.sun.jdi.event
    This package defines JDI events and event processing.

    • Uses of EventSet in com.sun.jdi.event

      Methods in com.sun.jdi.event that return EventSet
      Modifier and Type Method and Description
      EventSet EventQueue.remove()
      Waits forever for the next available event.
      EventSet EventQueue.remove(long timeout)
      Waits a specified time for the next available event.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface org.w3c.dom.events.EventTarget (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.EventTarget

  • Packages that use EventTarget
    Package Description
    org.w3c.dom.events

    • Uses of EventTarget in org.w3c.dom.events

      Methods in org.w3c.dom.events that return EventTarget
      Modifier and Type Method and Description
      EventTarget Event.getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      EventTarget MouseEvent.getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      EventTarget Event.getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      Methods in org.w3c.dom.events with parameters of type EventTarget
      Modifier and Type Method and Description
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Legal Notices

Documentation Contents

Java IDL Examples License

See Legal Notices

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java IDL: Tutorial

Documentation Contents

Tutorial

Hello World Tutorial

Home Concepts Programming Reference Tutorial
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Exception Site List

See Exception Site List in the Java Platform, Standard Edition Deployment Guide for the most current information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.event.ExceptionEvent (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.event.ExceptionEvent

No usage of com.sun.jdi.event.ExceptionEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.request.ExceptionRequest (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.request.ExceptionRequest

  • Packages that use ExceptionRequest
    Package Description
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of ExceptionRequest in com.sun.jdi.request

      Methods in com.sun.jdi.request that return ExceptionRequest
      Modifier and Type Method and Description
      ExceptionRequest EventRequestManager.createExceptionRequest(ReferenceType refType, boolean notifyCaught, boolean notifyUncaught)
      Creates a new disabled ExceptionRequest.
      Methods in com.sun.jdi.request that return types with arguments of type ExceptionRequest
      Modifier and Type Method and Description
      List<ExceptionRequest> EventRequestManager.exceptionRequests()
      Return an unmodifiable list of the enabled and disabled exception requests.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Java Object Serialization Specification: - Exceptions In Object Serialization

CONTENTS | PREV | NEXT Java Object Serialization Specification
version 6.0

Exceptions In Object Serialization

APPENDIX B

All exceptions thrown by serialization classes are subclasses of ObjectStreamException which is a subclass of IOException.

Exception | Description
ObjectStreamException | Superclass of all serialization exceptions.
InvalidClassException Thrown when a class cannot be used to restore objects for any of these reasons:
  • The class does not match the serial version of the class in the stream.
  • The class contains fields with invalid primitive data types.
  • The Externalizable class does not have a public no-arg constructor.
  • The Serializable class can not access the no-arg constructor of its closest non-Serializable superclass.
NotSerializableException | Thrown by a readObject or writeObject method to terminate serialization or deserialization.
StreamCorruptedException Thrown:
  • If the stream header is invalid.
  • If control information not found.
  • If control information is invalid.
  • JDK 1.1.5 or less attempts to call readExternal on a PROTOCOL_VERSION_2 stream.
NotActiveException

Thrown if writeObject state is invalid within the following ObjectOutputStream methods:

  • defaultWriteObject
  • putFields
  • writeFields

Thrown if readObject state is invalid within the following ObjectInputStream methods:

  • defaultReadObject
  • readFields
  • registerValidation
InvalidObjectException | Thrown when a restored object cannot be made valid.
OptionalDataException | Thrown by readObject when there is primitive data in the stream and an object is expected. The length field of the exception indicates the number of bytes that are available in the current block.
WriteAbortedException | Thrown when reading a stream terminated by an exception that occurred while the stream was being written.
CONTENTS | PREV | NEXT
Copyright © 2005, 2010, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.javadoc.ExecutableMemberDoc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.ExecutableMemberDoc

    • Uses of ExecutableMemberDoc in com.sun.javadoc

      Subinterfaces of ExecutableMemberDoc in com.sun.javadoc
      Modifier and Type Interface and Description
      interface  AnnotationTypeElementDoc
      Represents an element of an annotation type.
      interface  ConstructorDoc
      Represents a constructor of a java class.
      interface  MethodDoc
      Represents a method of a java class.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Class jdk.Exported (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
jdk.Exported

  • Packages that use Exported
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).
    jdk
  • Packages with annotations of type Exported
    Package Description
    com.sun.source.doctree
    Provides interfaces to represent documentation comments as abstract syntax trees (AST).
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of Exported in com.sun.source.doctree

      Classes in com.sun.source.doctree with annotations of type Exported
      Modifier and Type | Interface and Description
      interface  AttributeTree
      A tree node for an attribute in an HTML element.
      static class  | AttributeTree.ValueKind
      interface  AuthorTree
      A tree node for an @author block tag.
      interface  BlockTagTree
      A tree node used as the base class for the different types of block tags.
      interface  CommentTree
      An embedded HTML comment.
      interface  DeprecatedTree
      A tree node for an @deprecated block tag.
      interface  DocCommentTree
      The top level representation of a documentation comment.
      interface  DocRootTree
      A tree node for an @docroot inline tag.
      interface  DocTree
      Common interface for all nodes in a documentation syntax tree.
      static class  | DocTree.Kind
      interface  DocTreeVisitor<R,P>
      A visitor of trees, in the style of the visitor design pattern.
      interface  EndElementTree
      A tree node for the end of an HTML element.
      interface  EntityTree
      A tree node for an HTML entity.
      interface  ErroneousTree
      A tree node to stand in for a malformed text
      interface  IdentifierTree
      An identifier in a documentation comment.
      interface  InheritDocTree
      A tree node for an @inheritDoc inline tag.
      interface  InlineTagTree
      A tree node used as the base class for the different types of inline tags.
      interface  LinkTree
      A tree node for an @link or @linkplain inline tag.
      interface  LiteralTree
      A tree node for an @literal or @code inline tag.
      interface  ParamTree
      A tree node for an @param block tag.
      interface  ReferenceTree
      A tree node to a reference to a Java language element.
      interface  ReturnTree
      A tree node for an @return block tag.
      interface  SeeTree
      A tree node for an @see block tag.
      interface  SerialDataTree
      A tree node for an @serialData block tag.
      interface  SerialFieldTree
      A tree node for an @serialData block tag.
      interface  SerialTree
      A tree node for an @serial block tag.
      interface  SinceTree
      A tree node for an @since block tag.
      interface  StartElementTree
      A tree node for the start of an HTML element.
      interface  TextTree
      A tree node for plain text.
      interface  ThrowsTree
      A tree node for an @exception or @throws block tag.
      interface  UnknownBlockTagTree
      A tree node for an unrecognized inline tag.
      interface  UnknownInlineTagTree
      A tree node for an unrecognized inline tag.
      interface  ValueTree
      A tree node for an @value inline tag.
      interface  VersionTree
      A tree node for an @version block tag.

    • Uses of Exported in com.sun.source.tree

      Classes in com.sun.source.tree with annotations of type Exported
      Modifier and Type Interface and Description
      interface  AnnotatedTypeTree
      A tree node for an annotated type For example:
      interface  AnnotationTree
      A tree node for an annotation.
      interface  ArrayAccessTree
      A tree node for an array access expression.
      interface  ArrayTypeTree
      A tree node for an array type.
      interface  AssertTree
      A tree node for an 'assert' statement.
      interface  AssignmentTree
      A tree node for an assignment expression.
      interface  BinaryTree
      A tree node for a binary expression.
      interface  BlockTree
      A tree node for a statement block.
      interface  BreakTree
      A tree node for a 'break' statement.
      interface  CaseTree
      A tree node for a 'case' in a 'switch' statement.
      interface  CatchTree
      A tree node for a 'catch' block in a 'try' statement.
      interface  ClassTree
      A tree node for a class, interface, enum, or annotation type declaration.
      interface  CompilationUnitTree
      Represents the abstract syntax tree for compilation units (source files) and package declarations (package-info.java).
      interface  CompoundAssignmentTree
      A tree node for compound assignment operator.
      interface  ConditionalExpressionTree
      A tree node for the conditional operator ? :.
      interface  ContinueTree
      A tree node for a 'continue' statement.
      interface  DoWhileLoopTree
      A tree node for a 'do' statement.
      interface  EmptyStatementTree
      A tree node for an empty (skip) statement.
      interface  EnhancedForLoopTree
      A tree node for an "enhanced" 'for' loop statement.
      interface  ErroneousTree
      A tree node to stand in for a malformed expression.
      interface  ExpressionStatementTree
      A tree node for an expression statement.
      interface  ExpressionTree
      A tree node used as the base class for the different types of expressions.
      interface  ForLoopTree
      A tree node for a basic 'for' loop statement.
      interface  IdentifierTree
      A tree node for an identifier expression.
      interface  IfTree
      A tree node for an 'if' statement.
      interface  ImportTree
      A tree node for an import statement.
      interface  InstanceOfTree
      A tree node for an 'instanceof' expression.
      interface  IntersectionTypeTree
      A tree node for an intersection type in a cast expression.
      interface  LabeledStatementTree
      A tree node for a labeled statement.
      interface  LambdaExpressionTree
      A tree node for a lambda expression.
      static class  LambdaExpressionTree.BodyKind
      Lambda expressions come in two forms: (i) expression lambdas, whose body is an expression, and (ii) statement lambdas, whose body is a block
      interface  LineMap
      Provides methods to convert between character positions and line numbers for a compilation unit.
      interface  LiteralTree
      A tree node for a literal expression.
      interface  MemberReferenceTree
      A tree node for a member reference expression.
      static class  MemberReferenceTree.ReferenceMode
      There are two kinds of member references: (i) method references and (ii) constructor references
      interface  MemberSelectTree
      A tree node for a member access expression.
      interface  MethodInvocationTree
      A tree node for a method invocation expression.
      interface  MethodTree
      A tree node for a method or annotation type element declaration.
      interface  ModifiersTree
      A tree node for the modifiers, including annotations, for a declaration.
      interface  NewArrayTree
      A tree node for an expression to create a new instance of an array.
      interface  NewClassTree
      A tree node to declare a new instance of a class.
      interface  ParameterizedTypeTree
      A tree node for a type expression involving type parameters.
      interface  ParenthesizedTree
      A tree node for a parenthesized expression.
      interface  PrimitiveTypeTree
      A tree node for a primitive type.
      interface  ReturnTree
      A tree node for a 'return' statement.
      interface  Scope
      Interface for determining locally available program elements, such as local variables and imports.
      interface  StatementTree
      A tree node used as the base class for the different kinds of statements.
      interface  SwitchTree
      A tree node for a 'switch' statement.
      interface  SynchronizedTree
      A tree node for a 'synchronized' statement.
      interface  ThrowTree
      A tree node for a 'throw' statement.
      interface  Tree
      Common interface for all nodes in an abstract syntax tree.
      static class  Tree.Kind
      Enumerates all kinds of trees.
      interface  TreeVisitor<R,P>
      A visitor of trees, in the style of the visitor design pattern.
      interface  TryTree
      A tree node for a 'try' statement.
      interface  TypeCastTree
      A tree node for a type cast expression.
      interface  TypeParameterTree
      A tree node for a type parameter.
      interface  UnaryTree
      A tree node for postfix and unary expressions.
      interface  UnionTypeTree
      A tree node for a union type expression in a multicatch var declaration.
      interface  VariableTree
      A tree node for a variable declaration.
      interface  WhileLoopTree
      A tree node for a 'while' loop statement.
      interface  WildcardTree
      A tree node for a wildcard type argument.

    • Uses of Exported in com.sun.source.util

      Classes in com.sun.source.util with annotations of type Exported
      Modifier and Type Interface and Description
      interface  DocSourcePositions
      Provides methods to obtain the position of a DocTree within a javadoc comment.
      class  DocTreePath
      A path of tree nodes, typically used to represent the sequence of ancestor nodes of a tree node up to the top level DocCommentTree node.
      class  DocTreePathScanner<R,P>
      A DocTreeVisitor that visits all the child tree nodes, and provides support for maintaining a path for the parent nodes.
      class  DocTrees
      Provides access to syntax trees for doc comments.
      class  DocTreeScanner<R,P>
      A TreeVisitor that visits all the child tree nodes.
      class  JavacTask
      Provides access to functionality specific to the JDK Java Compiler, javac.
      interface  Plugin
      The interface for a javac plug-in.
      class  SimpleDocTreeVisitor<R,P>
      A simple visitor for tree nodes.
      class  SimpleTreeVisitor<R,P>
      A simple visitor for tree nodes.
      interface  SourcePositions
      Provides methods to obtain the position of a Tree within a CompilationUnit.
      class  TaskEvent
      Provides details about work that has been done by the JDK Java Compiler, javac.
      static class  TaskEvent.Kind
      Kind of task event.
      interface  TaskListener
      Provides a listener to monitor the activity of the JDK Java Compiler, javac.
      class  TreePath
      A path of tree nodes, typically used to represent the sequence of ancestor nodes of a tree node up to the top level CompilationUnitTree node.
      class  TreePathScanner<R,P>
      A TreeVisitor that visits all the child tree nodes, and provides support for maintaining a path for the parent nodes.
      class  Trees
      Bridges JSR 199, JSR 269, and the Tree API.
      class  TreeScanner<R,P>
      A TreeVisitor that visits all the child tree nodes.

    • Uses of Exported in jdk

      Classes in jdk with annotations of type Exported
      Modifier and Type Class and Description
      interface  Exported
      Indicates whether or not a JDK specific type or package is an exported part of the JDK suitable for use outside of the JDK implementation itself.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.ExpressionStatementTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ExpressionStatementTree

  • Packages that use ExpressionStatementTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ExpressionStatementTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type ExpressionStatementTree
      Modifier and Type | Method and Description
      List<? extends ExpressionStatementTree> | ForLoopTree.getUpdate()
      Methods in com.sun.source.tree with parameters of type ExpressionStatementTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitExpressionStatement(ExpressionStatementTree node, P p)

    • Uses of ExpressionStatementTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ExpressionStatementTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitExpressionStatement(ExpressionStatementTree node, P p)
      R | TreeScanner.visitExpressionStatement(ExpressionStatementTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.source.tree.ExpressionTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ExpressionTree

  • Packages that use ExpressionTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).

    • Uses of ExpressionTree in com.sun.source.tree

      Subinterfaces of ExpressionTree in com.sun.source.tree
      Modifier and Type Interface and Description
      interface  AnnotatedTypeTree
      A tree node for an annotated type For example:
      interface  AnnotationTree
      A tree node for an annotation.
      interface  ArrayAccessTree
      A tree node for an array access expression.
      interface  AssignmentTree
      A tree node for an assignment expression.
      interface  BinaryTree
      A tree node for a binary expression.
      interface  CompoundAssignmentTree
      A tree node for compound assignment operator.
      interface  ConditionalExpressionTree
      A tree node for the conditional operator ? :.
      interface  ErroneousTree
      A tree node to stand in for a malformed expression.
      interface  IdentifierTree
      A tree node for an identifier expression.
      interface  InstanceOfTree
      A tree node for an 'instanceof' expression.
      interface  LambdaExpressionTree
      A tree node for a lambda expression.
      interface  LiteralTree
      A tree node for a literal expression.
      interface  MemberReferenceTree
      A tree node for a member reference expression.
      interface  MemberSelectTree
      A tree node for a member access expression.
      interface  MethodInvocationTree
      A tree node for a method invocation expression.
      interface  NewArrayTree
      A tree node for an expression to create a new instance of an array.
      interface  NewClassTree
      A tree node to declare a new instance of a class.
      interface  ParenthesizedTree
      A tree node for a parenthesized expression.
      interface  TypeCastTree
      A tree node for a type cast expression.
      interface  UnaryTree
      A tree node for postfix and unary expressions.
      Methods in com.sun.source.tree that return ExpressionTree
      Modifier and Type | Method and Description
      ExpressionTree | AssertTree.getCondition()
      ExpressionTree | WhileLoopTree.getCondition()
      ExpressionTree | ForLoopTree.getCondition()
      ExpressionTree | ConditionalExpressionTree.getCondition()
      ExpressionTree | IfTree.getCondition()
      ExpressionTree | DoWhileLoopTree.getCondition()
      ExpressionTree | AssertTree.getDetail()
      ExpressionTree | NewClassTree.getEnclosingExpression()
      ExpressionTree | ParenthesizedTree.getExpression()
      ExpressionTree | SynchronizedTree.getExpression()
      ExpressionTree | InstanceOfTree.getExpression()
      ExpressionTree | EnhancedForLoopTree.getExpression()
      ExpressionTree | AssignmentTree.getExpression()
      ExpressionTree | ExpressionStatementTree.getExpression()
      ExpressionTree | CaseTree.getExpression()
      ExpressionTree | MemberSelectTree.getExpression()
      ExpressionTree | ArrayAccessTree.getExpression()
      ExpressionTree | ReturnTree.getExpression()
      ExpressionTree | ThrowTree.getExpression()
      ExpressionTree | SwitchTree.getExpression()
      ExpressionTree | UnaryTree.getExpression()
      ExpressionTree | CompoundAssignmentTree.getExpression()
      ExpressionTree | TypeCastTree.getExpression()
      ExpressionTree | ConditionalExpressionTree.getFalseExpression()
      ExpressionTree | NewClassTree.getIdentifier()
      ExpressionTree | ArrayAccessTree.getIndex()
      ExpressionTree | VariableTree.getInitializer()
      ExpressionTree | BinaryTree.getLeftOperand()
      ExpressionTree | MethodInvocationTree.getMethodSelect()
      ExpressionTree | VariableTree.getNameExpression()
      ExpressionTree | CompilationUnitTree.getPackageName()
      ExpressionTree | MemberReferenceTree.getQualifierExpression()
      ExpressionTree | BinaryTree.getRightOperand()
      ExpressionTree | ConditionalExpressionTree.getTrueExpression()
      ExpressionTree | AnnotatedTypeTree.getUnderlyingType()
      ExpressionTree | AssignmentTree.getVariable()
      ExpressionTree | CompoundAssignmentTree.getVariable()
      Methods in com.sun.source.tree that return types with arguments of type ExpressionTree
      Modifier and Type | Method and Description
      List<? extends ExpressionTree> | MethodInvocationTree.getArguments()
      List<? extends ExpressionTree> | NewClassTree.getArguments()
      List<? extends ExpressionTree> | AnnotationTree.getArguments()
      List<? extends ExpressionTree> | NewArrayTree.getDimensions()
      List<? extends ExpressionTree> | NewArrayTree.getInitializers()
      List<? extends ExpressionTree> | MethodTree.getThrows()
      List<? extends ExpressionTree> | MemberReferenceTree.getTypeArguments()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


extcheck

Detects version conflicts between a target Java Archive (JAR) file and currently installed extension JAR files.

Synopsis

extcheck [options] targetfile.jar

options

The command-line options. See Options.

targetfile.jar

The target JAR file against which the currently installed extension JAR files are compared to detect version conflicts.

Description

The extcheck command checks a specified JAR file for title and version conflicts with any extensions installed in the Java SE SDK. Before installing an extension, you can use this utility to see whether the same or a more recent version of the extension is already installed.

The extcheck command compares the Specification-title and Specification-version headers in the manifest of the targetfile.jar file against the corresponding headers in all JAR files currently installed in the extension directory. By default, the extension directory is jre/lib/ext on Oracle Solaris and \jre\lib\ext on Windows. The extcheck command compares version numbers in the same way as the java.lang.Package.isCompatibleWith method.

If no conflict is detected, then the return code is 0.

If the manifest of any JAR file in the extensions directory has the same Specification-title and the same or a newer Specification-version number, then a non-zero error code is returned. A non-zero error code is also returned when targetfile.jar does not have the Specification-title or Specification-version attributes in its manifest file.

Options

-verbose

Lists JAR files in the extension directory as they are checked. Additionally, manifest attributes of the target JAR file and any conflicting JAR files are also reported.

-Joption

Passes option to the Java Virtual Machine (JVM), where option is one of the options described on the reference page for the Java launcher. For example, -J-Xms48m sets the startup memory to 48 MB. See java(1).

See Also

  • jar(1)

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.security.jgss.ExtendedGSSContext (Java GSS-API Utilities )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.security.jgss.ExtendedGSSContext

No usage of com.sun.security.jgss.ExtendedGSSContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2000, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.security.jgss.ExtendedGSSCredential (Java GSS-API Utilities )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.security.jgss.ExtendedGSSCredential

No usage of com.sun.security.jgss.ExtendedGSSCredential
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2000, 2015, Oracle and/or its affiliates. All rights reserved.


ExtendedService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface ExtendedService

  • public interface ExtendedService
    ExtendedService provides additional support to the current JNLP API, to allow applications to open a specific file or files in the client's file system.
    Since:
    1.5

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      FileContents openFile(java.io.File file)
      Allows the application to open the specified file, even if the application is running in the untrusted execution environment.
      FileContents[] openFiles(java.io.File[] files)
      Allows the application to open the specified files, even if the application is running in the untrusted execution environment.

    • Method Detail

      • openFile

        FileContents openFile(java.io.File file)
               throws java.io.IOException
        Allows the application to open the specified file, even if the application is running in the untrusted execution environment. If the application would not otherwise have permission to access the file, the JNLP CLient should warn user of the potential security risk. The contents of the file is returned as a FileContents object.
        Parameters:
        file - the file object
        Returns:
        A FileContents object with information about the opened file
        Throws:
        java.io.IOException - - if there is any I/O error

      • openFiles

        FileContents[] openFiles(java.io.File[] files)
                  throws java.io.IOException
        Allows the application to open the specified files, even if the application is running in the untrusted execution environment. If the application would not otherwise have permission to access the files, the JNLP CLient should warn user of the potential security risk. The contents of each file is returned as a FileContents object in the FileContents array.
        Parameters:
        files - the array of files
        Returns:
        A FileContents[] object with information about each opened file
        Throws:
        java.io.IOException - - if there is any I/O error
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class jdk.net.ExtendedSocketOptions (jdk.net API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
jdk.net API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
jdk.net.ExtendedSocketOptions

No usage of jdk.net.ExtendedSocketOptions
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
jdk.net API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2014, 2015, Oracle and/or its affiliates. All rights reserved.


Using Activation: Extending Activatable

This tutorial describes how to implement an activatable remote object by extending the class java.rmi.activation.Activatable. This tutorial uses a Setup program (described in the tutorial Using Activation: the Setup Program) that registers information about an activatable remote object with the Java Remote Method Invocation (Java RMI) activation system daemon (rmid) and then binds a stub for that remote object in an rmiregistry so that clients can look it up. You may want to read that tutorial before this one.

This tutorial has the following steps:

  • Implement the activatable remote object
  • Implement the client
  • Compile the source files
  • Run the Setup program
  • Run the client

The files needed for this tutorial are:

  • MyRemoteInterface.java - a simple remote interface
  • ExtendsActivatable.java - an "activatable" implementation of the remote interface
  • Client.java - a client that uses the remote interface
  • client.policy - the security policy file for the client

Implement the activatable remote object

There are a few basic ways to implement an activatable remote object. This tutorial describes how to implement an activatable remote object by extending the class java.rmi.activation.Activatable which exports an activatable remote object during construction.

A remote object is activated when a client invokes a remote method on a stub for an activatable remote object. A stub for an activatable remote object contains the remote object's activation ID and information on how to contact the Java RMI activation system daemon (rmid) for the remote object. If the stub cannot connect to the last-known address (i.e., host/port) for the remote object, the stub will contact the remote object's activator (rmid) to activate the object. When rmid receives an activation request, it starts the remote object's activation group (or container) VM if the group is not already executing, and then rmid asks the group to make an instance of the remote object. Once the group constructs the remote object, it returns the remote object's stub to rmid which, in turn, returns the actual stub to the initiating stub so that the initiating stub can update its information on how to contact the remote object in the future.

Before any of this activation can take place, an application must register information about the activatable remote objects it needs to use. The following separate tutorial describes the information needed to activatate a remote object and how to register this information with rmid:

  • Using Activation: the Setup program

In this example, the activatable remote object implements the following remote interface examples.activation.MyRemoteInterface:

package examples.activation;

import java.rmi.*;

public interface MyRemoteInterface extends Remote {
    Object remoteMethod(Object obj) throws RemoteException;
}

The implementation class, examples.activation.ExtendsActivatable, for the activatable remote object is as follows:

package examples.activation;

import java.rmi.*;
import java.rmi.activation.*;

public class ExtendsActivatable
        extends Activatable
        implements MyRemoteInterface
{

    public ExtendsActivatable(ActivationID id, MarshalledObject data)
        throws RemoteException
    {
        super(id, 0);
    }

    public Object remoteMethod(Object obj) {
        return obj;
    }
}

The class ExtendsActivatable extends the class Activatable and implements the remote interface MyRemoteInterface.

The class ExtendsActivatable declares a special "activation" constructor that an activation group calls to construct an instance during the activation process. This special constructor takes two parameters:

  • The first parameter, ActivationID, is an identifier for the activatable remote object. When an application registers an activation descriptor with rmid, rmid assigns it an activation ID, which refers to the information associated with the descriptor. This same activation ID (also contained in the remote object's stub) is passed to this constructor when the remote object is activated.
  • The second parameter is a MarshalledObject that contains initialization data pre-registered with rmid. This initialization data may be a filename for the object's persistent state, for example. This example does not require any initialization data to construct the remote object.

The constructor simply calls a constructor in the superclass (Activatable) to export the object on an anoymous port.

Finally, the class implements the remote interface's single method, remoteMethod to return the object passed as an argument.

Implement the client

The Client program looks up a remote object's stub (one that implements the remote interface MyRemoteInterface) in the registry on the host supplied as the optional first argument, and then invokes the stub's remoteMethod method. When this client invokes a remote method on the stub acquired from the registry, the remote object will activate if not already active.

The source for the program is as follows:

package examples.activation;

import java.rmi.*;
import java.rmi.registry.*;

public class Client {

    public static void main(String args[])  throws Exception {

        String hostname = "localhost";
        if (args.length < 1) {
            System.err.println(
                "usage: java [options] examples.activation.Client <hostname>");
            System.exit(1);
        } else {
            hostname = args[0];
        }

        if (System.getSecurityManager() == null) {
            System.setSecurityManager(new SecurityManager());
        }

        String name = System.getProperty("examples.activation.name");
        Registry registry = LocateRegistry.getRegistry(hostname);
        MyRemoteInterface stub =
            (MyRemoteInterface) registry.lookup(name);
        System.err.println("Obtained stub from the registry.");

        System.err.println("Invoking remote method...");
        String result = (String) stub.remoteMethod("hello there!");
        System.err.println("Returned from remote call.");
        System.err.println("Result: " + result);
    }
}

This program should be run as follows:

java -cp clientDir                               \
     -Djava.security.policy=client.policy        \
     -Dexamples.activation.client.codebase=clientCodebase   \
     -Dexamples.activation.name=name             \
     examples.activation.Client [host]

where:

  • clientDir is the root directory for the client program (its class path),
  • client.policy is the security policy file for this program,
  • clientCodebase is the location (URL) for this program's class (used in granting permissions to this program in the client.policy file)
  • name is the name for the object's stub in the registry
  • host is the server's host

Note: rmid must be running on its default port, and rmiregistry must be running on its default port (both on the remote host) prior to running this program.

The following is an example client.policy file that grants the appropriate permissions for the activation examples:

grant codeBase "${examples.activation.client.codebase}" {

    // permissions to read system properties required by the client
    permission java.util.PropertyPermission "examples.activation.name","read";

    // permission to connect to the registry, activation system, and remote host
    permission java.net.SocketPermission "*:1024-","connect";
};

The codebase to which permissions are granted is a file URL specifying the location of the client's classes. This file URL is the value of the examples.activation.client.codebase system property, defined when the client program is run. The client needs two permissions:

  • java.util.PropertyPermission - to read the system property examples.activation.name that specifies the name for the stub in the registry
  • java.net.SocketPermission - to connect to the registry, activation system, and remote object's host

Compile the source files

The source files for this example can be compiled as follows:

javac -d implDir MyRemoteInterface.java ExtendsActivatable.java
javac -d clientDir MyRemoteInterface.java Client.java

where implDir is the destination directory to put the implementation's class files the class files in, and clientDir is the destination directory to put the client's class files in.

Run the Setup program

Once your implementation phase is complete, you need to register information about the activatable object so a client can use it. The Setup program, described by the tutorial Using Activation: the Setup Program, registers an activation descriptor for an activatable object with rmid, and then binds the remote object's stub in an rmiregistry so that clients can look it up.

To run the Setup program for this example, see the section Start rmid, rmiregistry, and the Setup program in the setup program tutorial, which describes how to start rmid, rmiregistry, and the Setup program itself.

After you run rmid and rmiregistry as instructed in the Setup tutorial, you will need to run the Setup program to register an activation descriptor for an activatable object that implements the class examples.activation.ExtendsActivatable. The following command line runs the Setup program, supplying an appropriate file URL for each codebase used:

java -cp setupDir:implDir                       \
     -Djava.security.policy=setup.policy                      \
     -Djava.rmi.server.codebase=file:/implDir/                \
     -Dexamples.activation.setup.codebase=file:/setupDir/     \
     -Dexamples.activation.impl.codebase=file:/impDir/        \
     -Dexamples.activation.name=examples.activation.MyRemoteInterface       \
     -Dexamples.activation.policy=group.policy                \
     examples.activation.Setup examples.activation.ExtendsActivatable

where:

  • setupDir is the root directory for the Setup program's class
  • implDir is the root directory for the implementation's classes
  • setup.policy is the security policy file for the Setup program
  • group.policy is the security policy file for the activation group

Note that the examples.activation.file system property does not need to be specified, because the ExtendsActivatable implementation class does not use it. Also note that each file URL above has the required trailing slash. Examples of group and setup policy files, suitable for this tutorial, are described in the setup tutorial, and are also listed below:

  • setup.policy
  • group.policy

The output from the Setup program should look like this:

Activation group descriptor registered.
Activation descriptor registered.
Stub bound in registry.

Run the client

Once you have successfully registered an activation descriptor for an ExtendsActivatable implementation, you can run the client program, which, during its first execution, will cause the activatable object to activate.

The following command line illustrates how to run the client program, specifying a file URL for the client codebase:

java -cp clientDir                                              \
     -Djava.security.policy=client.policy                       \
     -Dexamples.activation.client.codebase=file:/clientDir/     \
     -Dexamples.activation.name=examples.activation.MyRemoteInterface         \
     examples.activation.Client [host]

where:

  • clientDir is the root directory for the client program (its class path),
  • client.policy is the security policy file for this program,
  • name is the name for the object's stub in the registry
  • host is the server's host

Notes:

  • The client codebase must have a trailing slash.
  • The name must match the name supplied to the Setup program. In this example, we used the name examples.activation.MyRemoteInterface.
  • rmid and rmiregistry must be running on the server's host. If the server's host is not the local host, the host argument must specify the remote host that they are running on.

The output from the client should look like this:

Obtained stub from the registry.
Invoking remote method...
Returned from remote call.
Result: hello there!
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 4 - Writing Image I/O Plug-ins

Documentation Contents
CONTENTS | PREV | NEXT

CHAPTER 4

Writing Image I/O Plug-ins

4.1 The Plug-in Concept

The Image I/O API is designed as a pluggable framework into which any developer may add their own "plug-ins." A plug-in is defined as a set of Java language classes which may be loaded into the API at run-time and which add functionality to the AP I. In the context of the Java Image I/O API, a plug-in may provide the ability to read image data from a new file format, to write image data in a new format, to "transcode" non-image metadata between two formats, or to read or write streaming dat a from or to a new data source or sink. A plug-in may also provide support for the same format as another plug-in, perhaps providing better performance, more features, or a different view of the data stored by the format.

In order for plug-ins to be added to a running Java Virtual Machine, they must be compiled into Java bytecode files (class files). These class files will contain the code for subclasses of various classes defined by the API. For example, a plug-in that pr ovides the capability to read images will include a new subclass of the abstract javax.imageio.ImageReader class defined by the API. The usual reversed Internet domain name convention may be used to guarantee uniqueness of class names.

Because loading and instantiating an entire plug-in may be expensive, an additional class is used as a "stand-in" to provide information about the plug-in. This class may be used, for example, to determine what formats are handled by the plug-in p rior to actually instantiating the plug-in.

The "stand-in" object is lightweight enough that it can be loaded and a single instance instantiated every time the API is used within a given invocation of the Java virtual machine. This pattern, in which a small class is used to provide informat ion about an available service, is referred to as a "service provider interface."

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 4 - Writing Image I/O Plug-ins

Documentation Contents
CONTENTS | PREV | NEXT

4.2 Embedding Plug-ins in JAR Files

Since a plug-in consists of several classes, the JAR file mechanism is used to allow them to be combined into a single file. In addition to class files, JAR files may contain additional files used to describe their contents. In particular, a JAR file may contain a META-INF/services directory that is used to list any service providers that are contained in the file. For each service provider interface that is implemented by a class stored in the JAR file, a file whose name is the fully-qualified class name of the service provider interface is placed within the services directory. The file should contain the fully-qualified class names of the implementation classes present in the JAR file, one per line. For example, if the JAR file contains a service provider class named com.mycompany.mypackage.MyImageReaderSpi, which implements the javax.imageio.spi.ImageReaderSpi interface, there should be a file named META-INF/services/javax.imageio.spi.ImageReaderSpi containing the line com.mycompany.mypackage.MyImageReaderSpi.

The Image I/O API will automatically examine any JAR files that are found on the class path, and identify those that contain Image I/O plug-ins. For each plug-in found, a single instance of its service provider class will be instantiated and stored in a run-time registry class, javax.iamgeio.spi.IIORegistry.

JAR files on the application class path (i.e., the path set using the CLASSPATH variable), or elsewhere (e.g., available via a network URL) may be loaded by the application. They are not loaded by default in order to minimize startup time.

The javax.imageio.spi.IIORegistry class may also be used at run-time to deregister installed plug-ins and to register new ones. In particular, it is possible to use a ClassLoader to load a plug-in over the network, which may then be registered and used exactly like a locally installed plug-in.

Most applications should not need to deal directly with the registry. Instead, they may make use of convenience methods contained within the javax.imageio.ImageIO class that search for appropriate plug-ins automatically.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 4 - Writing Image I/O Plug-ins

Documentation Contents
CONTENTS | PREV | NEXT

4.3 Writing Reader Plug-Ins

A minimal reader plug-in consists of an ImageReaderSpi subclass, and an ImageReader subclass. Optionally, it may contain implementations of the IIOMetadata interface representing the stream and image metadata, and an IIOMetadataFormat object describing the structure of the metadata.

In the following sections, we will sketch out the implementation of a simple reader plug-in for a hypothetical format called "MyFormat". It will consist of the classes MyFormatImageReaderSpi, MyFormatImageReader, and MyFormatMetadata.

The format itself is defined to begin with the characters `myformat\n', followed by two four-byte integers representing the width, height, and a single byte indicating the color type of the image, which may be either gray or RGB. Next, after a newline character, metadata values may stored as alternating lines containing a keyword and a value, terminated by the special keyword `END'. The string values are stored using UTF8 encoding followed by a newline. Finally, the image samples are stored in left-to-right, top-to-bottom order as either byte grayscale values, or three bytes representing red, green, and blue.

MyFormatImageReaderSpi The MyFormatImageReaderSpi class provides information about the plug-in, including the vendor name, plug-in version string and description, format name, file suffixes associated with the format, MIME types associated with the format, input source classes that the plug-in can handle, and the ImageWriterSpis of plug-ins that are able to interoperate specially with the reader. It also must provide an implementation of the canDecodeInput method, which is used to locate plug-ins based on the contents of a source image file.

The ImageReaderSpi class provides implementations of most of its methods. These methods mainly return the value of various protected instance variables, which the MyFormatImageReaderSpi may set directly or via the superclass constructor, as in the example below:

package com.mycompany.imageio;

import java.io.IOException;
import java.util.Locale;
import javax.imageio.ImageReader;
import javax.imageio.spi.ImageReaderSpi;
import javax.imageio.stream.ImageInputStream;

public class MyFormatImageReaderSpi extends ImageReaderSpi {

        static final String vendorName = "My Company";
        static final String version = "1.0_beta33_build9467";
        static final String readerClassName =
                "com.mycompany.imageio.MyFormatImageReader";
        static final String[] names = { "myformat" };
        static final String[] suffixes = { "myf" };
        static final String[] MIMETypes = {
                "image/x-myformat" };
        static final String[] writerSpiNames = {
                "com.mycompany.imageio.MyFormatImageWriterSpi" };

        // Metadata formats, more information below
        static final boolean supportsStandardStreamMetadataFormat = false;
        static final String nativeStreamMetadataFormatName = null
        static final String nativeStreamMetadataFormatClassName = null;
        static final String[] extraStreamMetadataFormatNames = null;
        static final String[] extraStreamMetadataFormatClassNames = null;
        static final boolean supportsStandardImageMetadataFormat = false;
        static final String nativeImageMetadataFormatName =
                "com.mycompany.imageio.MyFormatMetadata_1.0";
        static final String nativeImageMetadataFormatClassName =
                "com.mycompany.imageio.MyFormatMetadata";
        static final String[] extraImageMetadataFormatNames = null;
        static final String[] extraImageMetadataFormatClassNames = null;

        public MyFormatImageReaderSpi() {
                super(vendorName, version,
                      names, suffixes, MIMETypes,
                      readerClassName,
                      STANDARD_INPUT_TYPE, // Accept ImageInputStreams
                      writerSpiNames,
                      supportsStandardStreamMetadataFormat,
                      nativeStreamMetadataFormatName,
                      nativeStreamMetadataFormatClassName,
                      extraStreamMetadataFormatNames,
                      extraStreamMetadataFormatClassNames,
                      supportsStandardImageMetadataFormat,
                      nativeImageMetadataFormatName,
                      extraImageMetadataFormatNames,
                      extraImageMetadataFormatClassNames);
                }

                public String getDescription(Locale locale) {
                        // Localize as appropriate
                        return "Description goes here";
                }

                public boolean canDecodeInput(Object input)
                        throws IOException {
                        // see below
                }

            public ImageReader createReaderInstance(Object extension) {
                return new MyFormatImageReader(this);
            }
        }
Most plug-ins need read only from ImageInputStream sources, since it is possible to "wrap" most other types of input with an appropriate ImageInputStream. However, it is possible for a plug-in to work directly with other Objects, for example an Object that provides an interface to a digital camera or scanner. This interface need not provide a "stream" view of the device at all. Rather, a plug-in that is aware of the interface may use it to drive the device directly.

The plug-in advertises which input classes it can handle via its getInputTypes method, which returns an array of Class objects. An implementation of getInputTypes is provided in the superclass, which returns the value of the inputTypes instance variable, which in turn is set by the seventh argument to the superclass constructor. The value used in the example above, STANDARD_INPUT_TYPE, is shorthand for an array containing the single element javax.imageio.stream.ImageInputStream.class, indicating that the plug-in accepts only ImageInputStreams.

The canDecodeInput method is responsible for determining two things: first, whether the input parameter is an instance of a class that the plug-in can understand, and second, whether the file contents appear to be in the format handled by the plug-in. It must leave its input in the same state as it was when it was passed in. For an ImageInputStream input source, the mark and reset methods may be used. For example, since files in the "MyFormat" format all begin with the characters `myformat', canDecodeInput may be implemented as:

public boolean canDecodeInput(Object input) {
        if (!(input instanceof ImageInputStream)) {
                return false;
        }

        ImageInputStream stream = (ImageInputStream)input;
        byte[] b = new byte[8];
        try {
                stream.mark();
                stream.readFully(b);
                stream.reset();
        } catch (IOException e) {
                return false;
        }

        // Cast unsigned character constants prior to comparison
        return (b[0] == (byte)'m' && b[1] == (byte)'y' &&
                b[2] == (byte)'f' && b[3] == (byte)'o' &&
                b[4] == (byte)'r' && b[5] == (byte)'m' &&
                b[6] == (byte)'a' && b[7] == (byte)'t');
}
MyFormatImageReader The heart of a reader plug-in is its extension of the ImageReader class. This class is responsible for responding to queries about the images actually stored in an input file or stream, as well as the actual reading of images, thumbnails, and metadata. For simplicity, we will ignore thumbnail images in this example.

A sketch of some of the methods of a hypothetical MyFormatImageReader class is shown below:

package com.mycompany.imageio;

public class MyFormatImageReader extends ImageReader {

        ImageInputStream stream = null;
        int width, height;
        int colorType;

        // Constants enumerating the values of colorType
        static final int COLOR_TYPE_GRAY = 0;
        static final int COLOR_TYPE_RGB = 1;

        boolean gotHeader = false;

        public MyFormatImageReader(ImageReaderSpi originatingProvider) {
                super(originatingProvider);
        }

        public void setInput(Object input, boolean isStreamable) {
                super.setInput(input, isStreamable);
                if (input == null) {
                        this.stream = null;
                        return;
                }
                if (input instanceof ImageInputStream) {
                        this.stream = (ImageInputStream)input;
                } else {
                        throw new IllegalArgumentException("bad input");
                }
        }

        public int getNumImages(boolean allowSearch)
                throws IIOException {
                return 1; // format can only encode a single image
        }

        private void checkIndex(int imageIndex) {
                if (imageIndex != 0) {
                        throw new IndexOutOfBoundsException("bad index");
                }
        }

        public int getWidth(int imageIndex)
                throws IIOException {
                checkIndex(imageIndex); // must throw an exception if != 0
                readHeader();
                return width;
        }

        public int getHeight(int imageIndex)
                throws IIOException {
                checkIndex(imageIndex);
                readHeader();
                return height;
        }
The getImageTypes Method The reader is responsible for indicating what sorts of images may be used to hold the decoded output. The ImageTypeSpecifier class is used to hold a SampleModel and ColorModel indicating a legal image layout. The getImageTypes method returns an Iterator of ImageTypeSpecifiers:
        public Iterator getImageTypes(int imageIndex)
                throws IIOException {
                checkIndex(imageIndex);
                readHeader();

                ImageTypeSpecifier imageType = null;
                int datatype = DataBuffer.TYPE_BYTE;
                java.util.List l = new ArrayList();
                switch (colorType) {
                case COLOR_TYPE_GRAY:
                        imageType = ImageTypeSpecifier.createGrayscale(8,
                                                                       datatype,
                                                                       false);
                        break;

                case COLOR_TYPE_RGB:
                        ColorSpace rgb =
                                ColorSpace.getInstance(ColorSpace.CS_sRGB);
                        int[] bandOffsets = new int[3];
                        bandOffsets[0] = 0;
                        bandOffsets[1] = 1;
                        bandOffsets[2] = 2;
                        imageType =
                                ImageTypeSpecifier.createInterleaved(rgb,
                                                                     bandOffsets,
                                                                     datatype,
                                                                     false,
                                                                     false);
                        break;
                }
                l.add(imageType);
                return l.iterator();
        }
Parsing the Image Header Several of the methods above depend on a readHeader method, which is responsible for reading enough of the input stream to determine the width, height, and layout of the image. readHeader is defined so it is safe to be called multiple times (note that we are not concerned with multi-threaded access):
        public void readHeader() {
                if (gotHeader) {
                        return;
                }
                gotHeader = true;

                if (stream == null) {
                        throw new IllegalStateException("No input stream");
                }

                // Read `myformat\n' from the stream
                byte[] signature = new byte[9];
                try {
                        stream.readFully(signature);
                } catch (IOException e) {
                        throw new IIOException("Error reading signature", e);
                }
                if (signature[0] != (byte)'m' || ...) { // etc.
                        throw new IIOException("Bad file signature!");
                }
                // Read width, height, color type, newline
                try {
                        this.width = stream.readInt();
                        this.height = stream.readInt();
                        this.colorType = stream.readUnsignedByte();
                        stream.readUnsignedByte(); // skip newline character
                } catch (IOException e) {
                        throw new IIOException("Error reading header", e)
                }
        }
The actual reading of the image is handled by the read method:
        public BufferedImage read(int imageIndex, ImageReadParam param)
                throws IIOException {
                readMetadata(); // Stream is positioned at start of image data
Handling the ImageReadParam The first section of the method is concerned with using a supplied ImageReadParam object to determine what region of the source image is to be read, what sort of subsampling is to be applied, the selection and rearrangement of bands, and the offset in the destination:

        // Compute initial source region, clip against destination later
        Rectangle sourceRegion = getSourceRegion(param, width, height);

        // Set everything to default values
        int sourceXSubsampling = 1;
        int sourceYSubsampling = 1;
        int[] sourceBands = null;
        int[] destinationBands = null;
        Point destinationOffset = new Point(0, 0);

        // Get values from the ImageReadParam, if any
        if (param != null) {
                sourceXSubsampling = param.getSourceXSubsampling();
                sourceYSubsampling = param.getSourceYSubsampling();
                sourceBands = param.getSourceBands();
                destinationBands = param.getDestinationBands();
                destinationOffset = param.getDestinationOffset();
        }
At this point, the region of interest, subsampling, band selection, and destination offset have been initialized. The next step is to create a suitable destination image. The ImageReader.getDestination method will return any image that was specified using ImageReadParam.setDestination, or else will create a suitable destination image using a supplied ImageTypeSpecifier, in this case determined by calling getImageTypes(0):
        // Get the specified detination image or create a new one
        BufferedImage dst = getDestination(param,
                                           getImageTypes(0),
                                           width, height);
        // Enure band settings from param are compatible with images
        int inputBands = (colorType == COLOR_TYPE_RGB) ? 3 : 1;
        checkReadParamBandSettings(param, inputBands,
                                   dst.getSampleModel().getNumBands());
To reduce the amount of code we have to write, we create a Raster to hold a row's worth of data, and copy the pixels from that Raster into the actual image. In this way, band selection and the details of pixel formatting are taken care of, at the expense of an additional copy.
        int[] bandOffsets = new int[inputBands];
        for (int i = 0; i < inputBands; i++) {
                bandOffsets[i] = i;
        }
        int bytesPerRow = width*inputBands;
        DataBufferByte rowDB = new DataBufferByte(bytesPerRow);
        WritableRaster rowRas =
                Raster.createInterleavedRaster(rowDB,
                                               width, 1, bytesPerRow,
                                               inputBands, bandOffsets,
                                               new Point(0, 0));
        byte[] rowBuf = rowDB.getData();

        // Create an int[] that can a single pixel
        int[] pixel = rowRas.getPixel(0, 0, (int[])null);
Now we have a byte array, rowBuf, which can be filled in from the input data, and which is also the source of pixel data for the Raster rowRaster. We extract the (single) tile of the destination image, and determine its extent. Then we create child rasters of both the source and destination that select and order their bands according to the settings previously extracted from the ImageReadParam:

        WritableRaster imRas = dst.getWritableTile(0, 0);
        int dstMinX = imRas.getMinX();
        int dstMaxX = dstMinX + imRas.getWidth() - 1;
        int dstMinY = imRas.getMinY();
        int dstMaxY = dstMinY + imRas.getHeight() - 1;

        // Create a child raster exposing only the desired source bands
        if (sourceBands != null) {
                rowRas = rowRas.createWritableChild(0, 0,
                                                    width, 1,
                                                    0, 0,
                                                    sourceBands);
        }

        // Create a child raster exposing only the desired dest bands
        if (destinationBands != null) {
                imRas = imRas.createWritableChild(0, 0,
                                                  imRas.getWidth(),
                                                  imRas.getHeight(),
                                                  0, 0,
                                                  destinationBands);
        }
Reading the Pixel Data Now we are ready to begin read pixel data from the image. We will read whole rows, and perform subsampling and destination clipping as we proceed. The horizontal clipping is complicated by the need to take subsampling into account. Here we perform per-pixel clipping; a more sophisticated reader could perform horizontal clipping once:
        for (int srcY = 0; srcY < height; srcY++) {
                // Read the row
                try {
                        stream.readFully(rowBuf);
                } catch (IOException e) {
                        throw new IIOException("Error reading line " + srcY, e);
                }

                // Reject rows that lie outside the source region,
                // or which aren't part of the subsampling
                if ((srcY < sourceRegion.y) ||
                    (srcY >= sourceRegion.y + sourceRegion.height) ||
                    (((srcY - sourceRegion.y) %
                      sourceYSubsampling) != 0)) {
                        continue;
                }

                // Determine where the row will go in the destination
                int dstY = destinationOffset.y +
                        (srcY - sourceRegion.y)/sourceYSubsampling;
                if (dstY < dstMinY) {
                        continue; // The row is above imRas
                }
                if (dstY > dstMaxY) {
                        break; // We're done with the image
                }

                // Copy each (subsampled) source pixel into imRas
                for (int srcX = sourceRegion.x;
                     srcX < sourceRegion.x + sourceRegion.width;
                     srcX++) {
                        if (((srcX - sourceRegion.x) % sourceXSubsampling) != 0) {
                                continue;
                        }
                        int dstX = destinationOffset.x +
                                (srcX - sourceRegion.x)/sourceXSubsampling;
                        if (dstX < dstMinX) {
                                continue;  // The pixel is to the left of imRas
                        }
                        if (dstX > dstMaxX) {
                                break; // We're done with the row
                        }

                        // Copy the pixel, sub-banding is done automatically
                        rowRas.getPixel(srcX, 0, pixel);
                        imRas.setPixel(dstX, dstY, pixel);
                }
        }
        return dst;
For performance, the case where sourceXSubsampling is equal to 1 may be broken out separately, since it is possible to copy multiple pixels at once:
        // Create an int[] that can hold a row's worth of pixels
        int[] pixels = rowRas.getPixels(0, 0, width, 1, (int[])null);

        // Clip against the left and right edges of the destination image
        int srcMinX =
                Math.max(sourceRegion.x,
                     dstMinX - destinationOffset.x + sourceRegion.x);
      int srcMaxX =
                Math.min(sourceRegion.x + sourceRegion.width - 1,
                         dstMaxX - destinationOffset.x + sourceRegion.x);
        int dstX = destinationOffset.x + (srcMinX - sourceRegion.x);
        int w = srcMaxX - srcMinX + 1;
        rowRas.getPixels(srcMinX, 0, w, 1, pixels);
        imRas.setPixels(dstX, dstY, w, 1, pixels);
There are several additional features that readers should implement, namely informing listeners of the progress of the read, and allowing the read process to be aborted from another thread. Listeners There are three types of listeners that may be attached to a reader: IIOReadProgressListener, IIOReadUpdateListener, and IIOReadWarningListener. Any number of each type may be attached to a reader by means of various add and remove methods that are implemented in the ImageReader superclass. ImageReader also contains various process methods that broadcast information to all of the attached listeners of a given type. For example, when the image read begins, the method processImageStarted(imageIndex) should be called to inform all attached IIOReadProgressListeners of the event.

A reader plug-in is normally responsible for calling processImageStarted and processImageComplete at the beginning and end of its read method, respectively. processImageProgress should be called at least every few scanlines with an estimate of the percentage completion of the read. It is important that this percentage never decrease during the read of a single image. If the reader supports thumbnails, the corresponsing thumbnail progress methods should be called as well. The processSequenceStarted and processSequenceComplete methods of IIOReadProgressListener only need to be called if the plug-in overrides the superclass implementation of readAll.

More advanced readers that process incoming data in multiple passes may choose to support IIOReadUpdateListeners, which receive more detauled information about which pixels have been read so far. Applications may use this information to perform selective updates of an on-screen image, for example, or to re-encode image data in a streaming fashion.

Aborting the Read Process While one thread performs an image read, another thread may call the reader's abort method asynchronously. The reading thread should poll the reader's status periodically using the abortRequested method, and attempt to cut the decoding short. The partially decoded image should still be returned, although the reader need not make any guarantees about its contents. For example, it could contain compressed or encrypted data in its DataBuffer that does not make sense visually. IIOReadProgressListener Example A typical set of IIOReadProgressListener calls might look like this:

public BufferedImage read(int imageIndex, ImageReadParam param)
        throws IOException {
        // Clear any previous abort request
        boolean aborted = false;
        clearAbortRequested();

        // Inform IIOReadProgressListeners of the start of the image
        processImageStarted(imageIndex);

        // Compute xMin, yMin, xSkip, ySkip from the ImageReadParam
        // ...

        // Create a suitable image
        BufferedImage theImage = new BufferedImage(...);

        // Compute factors for use in reporting percentages
        int pixelsPerRow = (width - xMin + xSkip - 1)/xSkip;
        int rows = (height - yMin + ySkip - 1)/ySkip;
        long pixelsDecoded = 0L;
        long totalPixels = rows*pixelsPerRow;

        for (int y = yMin; y < height; y += yskip) {
                // Decode a (subsampled) scanline of the image
                // ...

                // Update the percentage estimate
                // This may be done only every few rows if desired
                pixelsDecoded += pixelsPerRow;
                processImageProgress(100.0F*pixelsDecoded/totalPixels);

                // Check for an asynchronous abort request
                if (abortRequested()) {
                        aborted = true;
                        break;
                }
        }

        // Handle the end of decoding
        if (aborted) {
                processImageAborted();
        } else {
                processImageComplete(imageIndex);
        }

        // If the read was aborted, we still return a partially decoded image
        return theImage;
}
Metadata The next set of methods in MyFormatImageReader deal with metadata. Because our hypothetical format only encodes a single image, we may ignore the concept of "stream" metadata, and use "image" metadata only:
        MyFormatMetadata metadata = null; // class defined below

        public IIOMetadata getStreamMetadata()
                throws IIOException {
                return null;
        }

        public IIOMetadata getImageMetadata(int imageIndex)
                throws IIOException {
                if (imageIndex != 0) {
                        throw new IndexOutOfBoundsException("imageIndex != 0!");
                }
                readMetadata();
                return metadata;
        }
The actual work is done by a format-specific method readMetadata, which for this format fills in the keyword/value pairs of the metadata object,
        public void readMetadata() throws IIOException {
                if (metadata != null) {
                        return;
                }
                readHeader();
                this.metadata = new MyFormatMetadata();
                try {
                        while (true) {
                                String keyword = stream.readUTF();
                                stream.readUnsignedByte();
                                if (keyword.equals("END")) {
                                        break;
                                }
                                String value = stream.readUTF();
                                stream.readUnsignedByte();

                                metadata.keywords.add(keyword);
                                metadata.values.add(value);
                        } catch (IIOException e) {
                                throw new IIOException("Exception reading metadata",
                                                       e);
                        }
                }
        }
MyFormatMetadata Finally, the various interfaces for extracting and editing metadata must be defined. We define a class called MyFormatMetadata that extends the IIOMetadata class, and additionally can store the keyword/value pairs that are allowed in the file format:
package com.mycompany.imageio;

import org.w3c.dom.*;
import javax.xml.parsers.*; // Package name may change in JDK 1.4

import java.util.ArrayList;
import java.util.Iterator;
import java.util.List;
import javax.imageio.metadata.IIOInvalidTreeException;
import javax.imageio.metadata.IIOMetadata;
import javax.imageio.metadata.IIOMetadataFormat;
import javax.imageio.metadata.IIOMetadataNode;

public class MyFormatMetadata extends IIOMetadata {

        static final boolean standardMetadataFormatSupported = false;
        static final String nativeMetadataFormatName =
                "com.mycompany.imageio.MyFormatMetadata_1.0";
        static final String nativeMetadataFormatClassName =
                "com.mycompany.imageio.MyFormatMetadata";
        static final String[] extraMetadataFormatNames = null;
        static final String[] extraMetadataFormatClassNames = null;

        // Keyword/value pairs
        List keywords = new ArrayList();
        List values = new ArrayList();
The first set of methods are common to most IIOMetadata implementations:
        public MyFormatMetadata() {
                super(standardMetadataFormatSupported,
                      nativeMetadataFormatName,
                      nativeMetadataFormatClassName,
                      extraMetadataFormatNames,
                      extraMetadataFormatClassNames);
        }

        public IIOMetadataFormat getMetadataFormat(String formatName) {
                if (!formatName.equals(nativeMetadataFormatName)) {
                        throw new IllegalArgumentException("Bad format name!");
                }
                return MyFormatMetadataFormat.getDefaultInstance();
        }
The most important method for reader plug-ins is getAsTree:
        public Node getAsTree(String formatName) {
                if (!formatName.equals(nativeMetadataFormatName)) {
                        throw new IllegalArgumentException("Bad format name!");
                }

                // Create a root node
                IIOMetadataNode root =
                        new IIOMetadataNode(nativeMetadataFormatName);

                // Add a child to the root node for each keyword/value pair
                Iterator keywordIter = keywords.iterator();
                Iterator valueIter = values.iterator();
                while (keywordIter.hasNext()) {
                        IIOMetadataNode node =
                                new IIOMetadataNode("KeywordValuePair");
                        node.setAttribute("keyword", (String)keywordIter.next());
                        node.setAttribute("value", (String)valueIter.next());
                        root.appendChild(node);
                }

                return root;
        }
For writer plug-ins, the ability to edit metadata values is obtained by implementing the isReadOnly, reset, and mergeTree methods:
        public boolean isReadOnly() {
            return false;
        }

        public void reset() {
            this.keywords = new ArrayList();
            this.values = new ArrayList();
        }

        public void mergeTree(String formatName, Node root)
                throws IIOInvalidTreeException {
                if (!formatName.equals(nativeMetadataFormatName)) {
                        throw new IllegalArgumentException("Bad format name!");
                }

                Node node = root;
                if (!node.getNodeName().equals(nativeMetadataFormatName)) {
                        fatal(node, "Root must be " + nativeMetadataFormatName);
                }
                node = node.getFirstChild();
                while (node != null) {
                        if (!node.getNodeName().equals("KeywordValuePair")) {
                                fatal(node, "Node name not KeywordValuePair!");
                        }
                        NamedNodeMap attributes = node.getAttributes();
                        Node keywordNode = attributes.getNamedItem("keyword");
                        Node valueNode = attributes.getNamedItem("value");
                        if (keywordNode == null || valueNode == null) {
                                fatal(node, "Keyword or value missing!");
                        }

                        // Store keyword and value
                        keywords.add((String)keywordNode.getNodeValue());
                        values.add((String)valueNode.getNodeValue());

                        // Move to the next sibling
                        node = node.getNextSibling();
                }
        }

        private void fatal(Node node, String reason)
                throws IIOInvalidTreeException {
                throw new IIOInvalidTreeException(reason, node);
        }
}
MyFormatMetadataFormat The tree structure of the metadata may be described using the IIOMetadataFormat interface. An implementation class, IIOMetadataFormatImpl, takes care of maintaining the "database" of information about elements, their attributes, and the parent-child relationships between them:
package com.mycompany.imageio;

import javax.imageio.ImageTypeSpecifier;
import javax.imageio.metadata.IIOMetadataFormatImpl;

public class MyFormatMetadataFormat extends IIOMetadataFormatImpl {

        // Create a single instance of this class (singleton pattern)
        private static MyFormatMetadataFormat defaultInstance =
                new MyFormatMetadataFormat();

        // Make constructor private to enforce the singleton pattern
        private MyFormatMetadataFormat() {
                // Set the name of the root node
                // The root node has a single child node type that may repeat
                super("com.mycompany.imageio.MyFormatMetadata_1.0",
                      CHILD_POLICY_REPEAT);

                // Set up the "KeywordValuePair" node, which has no children
                addElement("KeywordValuePair",
                           "com.mycompany.imageio.MyFormatMetadata_1.0",
                           CHILD_POLICY_EMPTY);

                // Set up attribute "keyword" which is a String that is required
                // and has no default value
                addAttribute("KeywordValuePair", "keyword", DATATYPE_STRING,
                             true, null);
                // Set up attribute "value" which is a String that is required
                // and has no default value
                addAttribute("KeywordValuePair", "value", DATATYPE_STRING,
                             true, null);
        }

        // Check for legal element name
        public boolean canNodeAppear(String elementName,
                                     ImageTypeSpecifier imageType) {
                return elementName.equals("KeywordValuePair");
        }

        // Return the singleton instance
        public static MyFormatMetadataFormat getDefaultInstance() {
                return defaultInstance;
        }
}

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 4 - Writing Image I/O Plug-ins

Documentation Contents
CONTENTS | PREV | NEXT

4.4 Writing Writer Plug-ins

MyFormatImageWriterSpi The MyFormatImageWriterSpi call plays a similar role to the MyFormatImageReaderSpi class discussed in the previous section. However, instead of being responsible for determining whether a given stream can be read, it must deterine whether an image in memory can be written. Rather than inspecting the image itself, an ImageTypeSpecifier is used so that writers may be selected before an actual image is available.
package com.mycompany.imageio;

import java.io.IOException;
import java.util.Locale;
import javax.imageio.ImageWriter;
import javax.imageio.ImageTypeSpecifier;
import javax.imageio.spi.ImageWriterSpi;
import javax.imageio.stream.ImageInputStream;

public class MyFormatImageWriterSpi extends ImageWriterSpi {

        static final String vendorName = "My Company";
        static final String version = "1.0_beta33_build9467";
        static final String writerClassName =
                "com.mycompany.imageio.MyFormatImageWriter";
        static final String[] names = { "myformat" };
        static final String[] suffixes = { "myf" };
        static final String[] MIMETypes = { "image/x-myformat" };
        static final String[] readerSpiNames = {
                "com.mycompany.imageio.MyFormatImageReaderSpi" };

        static final boolean supportsStandardStreamMetadataFormat = false;
        static final String nativeStreamMetadataFormatName = null;
        static final String nativeStreamMetadataFormatClassName = null;
        static final String[] extraStreamMetadataFormatNames = null;
        static final String[] extraStreamMetadataFormatClassNames = null;
        static final boolean supportsStandardImageMetadataFormat = false;
        static final String nativeImageMetadataFormatName =
                "com.mycompany.imageio.MyFormatMetadata_1.0";
        static final String nativeImageMetadataFormatClassName =
                "com.mycompany.imageio.MyFormatMetadata";
        static final String[] extraImageMetadataFormatNames = null;
        static final String[] extraImageMetadataFormatClassNames = null;

        public MyFormatImageWriterSpi() {
                super(vendorName, version,
                      names, suffixes, MIMETypes,
                      writerClassName,
                      STANDARD_OUTPUT_TYPE, // Write to ImageOutputStreams
                      readerSpiNames,
                      supportsStandardStreamMetadataFormat,
                      nativeStreamMetadataFormatName,
                      nativeStreamMetadataFormatClassName,
                      extraStreamMetadataFormatNames,
                      extraStreamMetadataFormatClassNames,
                      supportsStandardImageMetadataFormat,
                      nativeImageMetadataFormatName,
                      nativeImageMetadataFormatClassName,
                      extraImageMetadataFormatNames,
                      extraImageMetadataFormatClassNames);
        }

        public boolean canEncodeImage(ImageTypeSpecifier imageType) {
                int bands = imageType.getNumBands();
                return bands == 1 || bands == 3;
        }

        public String getDescription(Locale locale) {
                // Localize as appropriate
                return "Description goes here";
        }

        public ImageWriter createWriterInstance(Object extension) {
            return new MyFormatImageWriter(this);
        }
}
MyFormatImageWriter
package com.mycompany.imageio;

import java.awt.Rectangle;
import java.awt.image.Raster;
import java.awt.image.RenderedImage;
import java.io.IOException;
import java.util.Iterator;
import javax.imageio.IIOException;
import javax.imageio.IIOImage;
import javax.imageio.ImageTypeSpecifier;
import javax.imageio.ImageWriteParam;
import javax.imageio.ImageWriter;
import javax.imageio.metadata.IIOMetadata;
import javax.imageio.spi.ImageWriterSpi;
import javax.imageio.stream.ImageOutputStream;

public class MyFormatImageWriter extends ImageWriter {

        ImageOutputStream stream = null;

        public MyFormatImageWriter(ImageWriterSpi originatingProvider) {
                super(originatingProvider);
        }

        public void setOutput(Object output) {
                super.setOutput(output);
                if (output != null) {
                        if (!(output instanceof ImageOutputStream)) {
                                throw new IllegalArgumentException
                                        ("output not an ImageOutputStream!");
                        }
                        this.stream = (ImageOutputStream)output;
                } else {
                        this.stream = null;
                }
        }
The ImageWriteParam returned by getDefaultWriteParam must be customized based on the writer's capabilities. Since this writer does not support tiling, progessive encoding, or compression, we pass in values of false or null as appropriate:
        // Tiling, progressive encoding, compression are disabled by default
        public ImageWriteParam getDefaultWriteParam() {
                return new ImageWriteParam(getLocale());
        }
The format only handles image metadata. The convertImageMetadata method does very little; it could be defined to interpret the metadata classes used by other plug-ins.

  public IIOMetadata getDefaultStreamMetadata(ImageWriteParam param) {
                return null;
        }

        public IIOMetadata
                getDefaultImageMetadata(ImageTypeSpecifier imageType,
                                        ImageWriteParam param) {
                return new MyFormatMetadata();
        }

        public IIOMetadata convertStreamMetadata(IIOMetadata inData,
                                                 ImageWriteParam param) {
                return null;
        }

        public IIOMetadata convertImageMetadata(IIOMetadata inData,
                                                ImageTypeSpecifier imageType,
                                                ImageWriteParam param) {
                // We only understand our own metadata
                if (inData instanceof MyFormatMetadata) {
                        return inData;
                } else {
                        return null;
                }
        }
The actual writing of the image requires first applying the source region, source bands, and subsampling factors from the ImageWriteParam. The source region and source bands may be handled by creating a child Raster. For simplicity, we extract a single Raster from the source image. If the source image is tiled, we can save memory by extracting smaller Rasters as needed.
        public void write(IIOMetadata streamMetadata,
                          IIOImage image,
                          ImageWriteParam param) throws IIOException {
                RenderedImage im = image.getRenderedImage();

                Rectangle sourceRegion =
                        new Rectangle(0, 0, im.getWidth(), im.getHeight());
                int sourceXSubsampling = 1;
                int sourceYSubsampling = 1;
                int[] sourceBands = null;
                if (param != null) {
                        sourceRegion =
                                sourceRegion.intersection(param.getSourceRegion());
                        sourceXSubsampling = param.getSourceXSubsampling();
                        sourceYSubsampling = param.getSourceYSubsampling();
                        sourceBands = param.getSourceBands();

                        int subsampleXOffset = param.getSubsamplingXOffset();
                        int subsampleYOffset = param.getSubsamplingYOffset();
                        sourceRegion.x += subsampleXOffset;
                        sourceRegion.y += subsampleYOffset;
                        sourceRegion.width -= subsampleXOffset;
                        sourceRegion.height -= subsampleYOffset;
                }

                // Grab a Raster containing the region of interest
                int width = sourceRegion.width;
                int height = sourceRegion.height;
                Raster imRas = im.getData(sourceRegion);
                int numBands = imRas.getNumBands();

                // Check that sourceBands values are in range
                if (sourceBands != null) {
                        for (int i = 0; i < sourceBands.length; i++) {
                                if (sourceBands[i] >= numBands) {
                                        throw new IllegalArgumentException("bad band!");
                                }
                        }
                }

                // Translate imRas to start at (0, 0) and subset the bands
                imRas = imRas.createChild(sourceRegion.x, sourceRegion.y,
                                          width, height,
                                          0, 0,
                                          sourceBands);

                // Reduce width and height according to subsampling factors
                width = (width + sourceXSubsampling - 1)/sourceXSubsampling;
                height = (height + sourceYSubsampling - 1)/sourceYSubsampling;

                // Assume 1 band image is grayscale, 3 band image is RGB
                int colorType;
                if (numBands == 1) {
                        colorType = MyFormatImageReader.COLOR_TYPE_GRAY;
                } else if (numBands == 3) {
                        colorType = MyFormatImageReader.COLOR_TYPE_RGB;
                } else {
                        throw new IIOException("Image must have 1 or 3 bands!");
                }
Once the image dimensions and color type of the image have been ascertained, the plug-in is ready to write the file header:
                try {
                        byte[] signature = {
                                (byte)'m', (byte)'y',  (byte)'f', (byte)'o',
                                (byte)'r', (byte)'m',  (byte)'a', (byte)'t'
                        };
                        // Output header information
                        stream.write(signature);
                        stream.write(`\n');
                        stream.writeInt(width);
                        stream.writeInt(height);
                        stream.writeByte(colorType);
                        stream.write(`\n');
Next, the plug-in extracts the image metadata from the write method's IIOImage argument, and attempts to convert it into a MyFormatMetadata object by calling convertImageMetadata. If the result is non-null, the keywords and values are extracted from the metadata and written to the output:
                        // Attempt to convert metadata, if present
                        IIOMetadata imd = image.getMetadata();
                        MyFormatMetadata metadata = null;
                        if (imd != null) {
                                ImageTypeSpecifier type =
                                        ImageTypeSpecifier.createFromRenderedImage(im);
                                metadata =
                                        (MyFormatMetadata)convertImageMetadata(imd,
                                                                               type,
                                                                               null);
                        }

                        // Output metadata if present
                        if (metadata != null) {
                                Iterator keywordIter = metadata.keywords.iterator();
                                Iterator valueIter = metadata.values.iterator();
                                while (keywordIter.hasNext()) {
                                        String keyword = (String)keywordIter.next();
                                        String value = (String)valueIter.next();

                                        stream.writeUTF(keyword);
                                        stream.write(`\n');
                                        stream.writeUTF(value);
                                        stream.write(`\n');
                                }
                        }
                        stream.writeUTF("END");
                        stream.write(`\n');
Finally, the plug-in is ready to begin writing the pixel data. The image Raster is copied into an int array, one row at a time using the getPixels method. Then these values are subsampled using the horizontal subsampling factor, and copied into a byte array, which is written to the output with a single write call. The source row is then incremented by the vertical subsampling factor until the end of the source region is reached, and the output stream is flushed:
                        // Output (subsampled) pixel values
                        int rowLength = width*numBands;
                        int xSkip = sourceXSubsampling*numBands;
                        int[] rowPixels = imRas.getPixels(0, 0, width, 1,
                                                          (int[])null);
                        byte[] rowSamples = new byte[rowLength];

                        // Output every (sourceYSubsampling)^th row
                        for (int y = 0; y < height; y += sourceYSubsampling) {
                                imRas.getPixels(0, y, width, 1, rowPixels);

                                // Subsample horizontally and convert to bytes
                                int count = 0;
                                for (int x = 0; x < width; x += xSkip) {
                                        if (colorType ==
                                                MyFormatImageReader.COLOR_TYPE_GRAY) {
                                                rowSamples[count++] = (byte)rowPixels[x];
                                        } else {
                                                rowSamples[count++] = (byte)rowPixels[x];
                                                rowSamples[count++] =
                                                        (byte)rowPixels[x + 1];
                                                rowSamples[count++] =
                                                        (byte)rowPixels[x + 2];
                                        }
                                }

                                // Output a row's worth of bytes
                                stream.write(rowSamples, 0, width*numBands);
                        }
                        stream.flush();
                } catch (IOException e) {
                        throw new IIOException("I/O error!", e);
                }
        }
}

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 4 - Writing Image I/O Plug-ins

Documentation Contents
CONTENTS | PREV | NEXT

4.5 Writing Transcoder Plug-ins

A transcoder plug-in consists of an ImageTranscoderSpi, which performs the same functions as do the Spi classes for other plug-ins, and an object that implements the ImageTranscoder interface:
IIOMetadata convertStreamMetadata(IIOMetadata inData,
                                  ImageWriteParam param);

IIOMetadata convertImageMetadata(IIOMetadata inData,
                                 ImageTypeSpecifier imageType,
                                 ImageWriteParam param);
The ImageTranscoder may use the standard interfaces to unpack the incoming metadata, or it may make use of interfaces that are specific to the actual object at hand. For example, it could access the keywords and values instance variables of the MyFormatMetadata class defined above; these were made public, but not documented, precisely in order to allow a transcoder plug-in developer to access them without having to go through a DOM representation.
CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 4 - Writing Image I/O Plug-ins

Documentation Contents
CONTENTS | PREV | NEXT

4.6 Writing Stream Plug-ins

The standard classes in the javax.imageio.stream package are able to create ImageInputStreams and ImageOutputStreams that:
  • Read from a File
  • Read from an InputStream, using a temporary File as a cache
  • Read from an InputStream, using a byte array in memory as a cache
  • Write to a File
  • Write to an OutputStream, using a temporary File as a cache
  • Write to an OutputStream, using a byte array in memory as a cache
It is possible to write new implementations of ImageInputStream and InmageOutputStream that interface with other I/O primitives (for example, databases or future fast I/O interfaces). The ImageInputStreamImpl and ImageOutputStreamImpl classes provide a base for subclassing. Only a handful of methods are required to be implemented by the subclass, although it is possible to implement more for greater efficiency:
  • int read()
  • int read(byte[] b, int off, int len)
  • write(int b)
  • write(byte[] b, int off, int len)
  • seek(long pos)

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Extending Sockets in JDK 1.1

Some of the improvements to the java.net classes in JDK 1.1 allow sockets (Socket/ServerSocket) to be non-final, extendable classes. The basic goal is to allow extended sockets to be used whereever a base class Socket is used without rewriting application code. So for example an already-existing email client could be handed a subclass of Socket that does peer authentication or encryption, which the Socket subclass would handle transparently. Other examples include sockets that transparently use compression, or which add functionality such as mirroring traffic to multiple servers (e.g. using reliable ordered multicast).

This document has the following sections:

  • JDK 1.0: SocketImpl
  • JDK 1.1: Non-Final Socket and ServerSocket Classes
  • Socket: How to extend Socket
  • ServerSocket: How to extend ServerSocket

JDK 1.0: SocketImpl and SocketImplFactory

JDK 1.0 allows licensees to extend socket functionality in one very particular way: they can subclass java.net.SocketImpl , and provide an enhanced java.net.SocketImplFactory() which returns such classes as needed.

The SocketImpl/SocketImplFactory scheme is useful for, and was designed for, java apps/applications to be portable across environments that use different transport mechanisms. A client application that uses a java.net.Socket can work in the general case (where the runtime uses a PlainSocketImpl), as well as in environments where network connections must do something particular. For example, a java program should be able to work behind a firewall where connections to the Internet must be done through a proxy protocol, like SOCKS, assuming the right kind of SocketImpl is set for the java runtime in that environment.

Though the SocketImpl is useful for things like transparently providing proxy support to java apps, its utility is limited as a way to provide added functionality of network transport, or for layering other protocols on top of TCP. Additionally, it's only possible to have a single type of SocketImpl installed for a java runtime, which limits large-scale applications. It's cleaner and more intuitive to make ServerSocket and Socket extendable.

Note that the SocketImpl mechanism is designed to be orthogonal to the functionality provided by a subclass of Socket: for example, a subclass of Socket that is capable of doing compression on its streams would still want to use the system-default SocketImpl to get proxy support behind certain kinds of firewalls. The system-default SocketImpl can be thought of as an extension of the transport layer that applications needn't be aware of, and subclasses of Socket/ServerSocket provide richer functionality at the application layer.

Change in JDK 1.1

In JDK 1.1, Socket and ServerSocket are made non-final, which is a pretty simple change. The one basic caveat is that subclasses do not have direct access to the underlying SocketImpl in the base classes, primarily for security reasons. But other than that, subclasses of Socket/ServerSocket inherit and can override methods from their superclass.

The JDK changed by:

  • Removing the final modifier from the Socket and ServerSocket classes.
  • Reattaching that final modifier only to methods where it is needed to avoid bypassing security manager calls.
  • Defining a new method in ServerSocket with signature: protected final void implAccept(Socket client) to use when initializing a newly accepted socket.
  • Exposing a default Socket constructor so that Socket subclasses could initialize their superclass without doing an actual connection in the superclass. This is also required so that a ServerSocket subclasses can return the correct Socket subclass from accept() (e.g., FooServerSocket.accept() returns a FooSocket)

Changes to Socket

The public constructors to Socket of the general form:

        Socket(String host, int port) {
          ...
        }

can be used by subclasses to initialize the superclass, but they will also create a system-default SocketImpl and connect it to the specified host, port. Socket also has two protected constructors to initialize the superclass without connecting the Socket:

        protected Socket() {
          /* install system-default SocketImpl */
          ...
        }

        protected Socket(SocketImpl impl) {
          this.impl = impl;
        }

The first constructor installs a system-default SocketImpl (either from the factory or a PlainSocketImpl). The second allows for a subclass of Socket to install its own impl if need be. If the Socket subclass doesn't need the default SocketImpl, it's perfectly valid to use the second constructor and pass it null. (But in this case the subclass should of course override all the base class methods, since they all rely on the underlying SocketImpl).

Changes to ServerSocket

Subclasses of ServerSocket also have a protected constructor exposed to them that creates a default SocketImpl in the base class, but doesn't otherwise initialize it (e.g., doesn't call impl.create(), impl.bind() or impl.listen()). The public constructors of ServerSocket will initialize the underlying SocketImpl.

        protected ServerSocket() {
          /* install system-default SocketImpl */
          ...
        }

The only other thing about extending ServerSocket that should be explained is how to override accept() when the underlying SocketImpl for Socket/ServerSocket isn't accesible to subclasses. Since the base class can do this, ServerSocket has a method to make the necessary calls on the underlying SocketImpl's on behalf of subclasses:

public class ServerSocket {
        ...
        protected final void implAccept(Socket s) throws IOException {
           ...
           // on return from this call s will be connected to a client
        }
        ...

Note that subclasses of Socket/ServerSocket that don't use a SocketImpl needn't use this method. As an example of how this works, here's what some SSL code might look like.

class SSLServerSocket extends ServerSocket {
    ...
    public Socket accept () throws IOException
    {
        SSLSocket s = new SSLSocket (certChain, privateKey);
        // create an unconnected client SSLSocket, that we'll
        // return from accept

        implAccept (s);
        s.handshake ();
        return s;
    }
    ...
}

class SSLSocket extends java.net.Socket {
    ...
    public SSLSocket(CertChain c, PrivateKey k) {
        super();
        ...
    }
    ...
}
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


ExtensionInstallerService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface ExtensionInstallerService

  • public interface ExtensionInstallerService
    The ExtensionInstallerService is used by an extension installer to communicate with the JNLP Client. It provides the following type of functionality:
    • Access to prefered installation location, and other information about the JNLP Client
    • Manipulation of the JNLP Client's download screen
    • Methods for updating the JNLP Client with the installed code

    The normal sequence of events for an installer is:

    1. Get service using ServiceManager.lookup("javax.jnlp.ExtensionInstallerService").
    2. Update status, heading, and progress as install progresses (setStatus, setHeading and updateProgress).
    3. Invoke either setJREInfo or setNativeLibraryInfo depending on if a JRE or a library is installed
    4. If successful invoke installSucceeded, otherwise invoke installFailed.
    Since:
    1.4.2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      java.net.URL getExtensionLocation()
      Returns the location of the extension being installed
      java.lang.String getExtensionVersion()
      Returns the version of the extension being installed
      java.lang.String getInstalledJRE(java.net.URL url, java.lang.String version)
      Returns the path to the executable for the given JRE.
      java.lang.String getInstallPath()
      Returns the directory where the installer is recommended to install the extension in.
      void hideProgressBar()
      Hides the progress bar.
      void hideStatusWindow()
      Hides the status window.
      void installFailed()
      This should be invoked if the install fails.
      void installSucceeded(boolean needsReboot)
      Installers should invoke this upon a succesful installation of the extension.
      void setHeading(java.lang.String heading)
      Updates the status of the installer process.
      void setJREInfo(java.lang.String platformVersion, java.lang.String jrePath)
      Informs the JNLP Client of the path to the executable for the JRE, if this is an installer for a JRE, and about platform-version this JRE implements.
      void setNativeLibraryInfo(java.lang.String path)
      Informs the JNLP Client of a directory where it should search for native libraries.
      void setStatus(java.lang.String status)
      Updates the status of the installer process.
      void updateProgress(int value)
      Updates the progress bar.

    • Method Detail

      • getInstallPath

        java.lang.String getInstallPath()
        Returns the directory where the installer is recommended to install the extension in. It is not required that the installer install in this directory, this is merely a suggested path.

      • getExtensionVersion

        java.lang.String getExtensionVersion()
        Returns the version of the extension being installed

      • getExtensionLocation

        java.net.URL getExtensionLocation()
        Returns the location of the extension being installed

      • hideProgressBar

        void hideProgressBar()
        Hides the progress bar. Any subsequent calls to updateProgress will force it to be visible.

      • hideStatusWindow

        void hideStatusWindow()
        Hides the status window. You should only invoke this if you are going to provide your own feedback to the user as to the progress of the install.

      • setHeading

        void setHeading(java.lang.String heading)
        Updates the status of the installer process.

      • setStatus

        void setStatus(java.lang.String status)
        Updates the status of the installer process.

      • updateProgress

        void updateProgress(int value)
        Updates the progress bar.
        Parameters:
        value - progress bar value - should be between 0 and 100.

      • installSucceeded

        void installSucceeded(boolean needsReboot)
        Installers should invoke this upon a succesful installation of the extension. This will cause the JNLP Client to regain control and continue its normal operation.
        Parameters:
        needsReboot - If true, a reboot is needed

      • installFailed

        void installFailed()
        This should be invoked if the install fails. The JNLP Client will continue its operation, and inform the user that the install has failed.

      • setJREInfo

        void setJREInfo(java.lang.String platformVersion,
                java.lang.String jrePath)
        Informs the JNLP Client of the path to the executable for the JRE, if this is an installer for a JRE, and about platform-version this JRE implements.

      • setNativeLibraryInfo

        void setNativeLibraryInfo(java.lang.String path)
        Informs the JNLP Client of a directory where it should search for native libraries.

      • getInstalledJRE

        java.lang.String getInstalledJRE(java.net.URL url,
                                 java.lang.String version)
        Returns the path to the executable for the given JRE. This method can be used by extensions that needs to find information in a given JRE, or enhance a given JRE.
        Parameters:
        url - product location of the JRE
        version - product version of the JRE
        Returns:
        The path to the executable for the given JRE, or null if the JRE is not installed.
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Optional Package Overview

Documentation Contents

Optional Packages - An Overview

Contents

  • What an optional package is
  • Installed optional packages
  • Download optional packages

What an optional package is

Note: Optional packages were formerly known as standard extensions or just extensions.

Optional packages are packages of Java classes and associated native code that application developers can use to extend the functionality of the core platform. The extension mechanism allows the Java virtual machine (VM) to use the optional-package classes in much the same way as the VM uses bootstrap classes. (Bootstrap classes are those implementing the core platform, contained in jre/lib/rt.jar and several other important jar files. These include classes of the public API such as java.lang, java.io, etc., and classes supporting the platform's internationalization/localization features.). Like bootstrap classes, classes in optional packages do not have to be placed on the class path. The extension mechanism also provides a way for needed optional packages to be retrieved from specified URLs when they are not already installed in the Java 2 Runtime Environment or JDK.

Optional packages are embodied in JAR files, and every JAR file is a potential optional package. A JAR file can be made to play the role of an optional package in two ways:

  • by being placed in a special location in the Java 2 Runtime Environment or JDK directory structure - in which case it is an installed optional package.
  • by being referenced in a specified way from the manifest of the JAR file of an applet or application - in which case it is a download optional package.

When the VM is searching for a class of a particular name, it will first look among the bootstrap classes. If it fails to find the desired class there, it will next look for the class among any installed optional packages. If it doesn't find the class among either the bootstrap classes or the installed optional packages, the VM will search among any download optional packages referenced by the application or applet. The VM only searches the class path if it fails to find a class among the bootstrap classes or optional package classes.

Installed optional packages

Deprecated: Support for installed optional packages has been deprecated and may be removed in a future release.

Installed optional packages are JAR files in the following directories:

  • lib/ext (in the JRE)
  • jre/lib/ext (in the JDK)

Classes within JAR files in this directory can be used by applets and applications much as if they were part of the set of bootstrap classes, without having to explicitly include them in the class path.

An installed optional package's native code binaries, if any, are placed in

  • jre\bin (Microsoft Windows)
  • jre/lib/<arch> (Solaris operating environment)

where <arch> is the Solaris processor architecture, either sparc or i386. Native libraries may also be placed in jre/lib/ext/<arch> for both Microsoft Windows and the Solaris operating environment, where <arch> will be i386 on Microsoft Windows systems. The jre/lib/ext/<arch> directory is searched after jre\bin or jre/lib/<arch>.

When the Java VM encounters a class name, it looks first for the class in the runtime environment. If it fails to find the desired class among the classes that are part of the standard runtime environment, the VM will search for the class in any JAR files in the optional packages directory.

Note that there is nothing special about any particular JAR file itself or the classes it contains that makes it an installed optional package. It is an installed optional package by virtue of its location in jre/lib/ext.

The manifest of an installed optional package's JAR file should contain version and vendor information for use by applets that need to use the optional packages classes. The attributes that specify the version and vendor information are described in Optional Package Versioning. Here is an example of what such a manifest might look like:

Manifest-version: 1.0
Extension-Name: javax.extension
Specification-Version: 1.0
Specification Vendor: Oracle Corporation.
Implementation-Vendor: Oracle Corporation.
Implementation-Vendor-Id: com.sun
Sealed: true

This version and vendor information can be used by the Java Plug-in when running an applet to see if optional packages needed by the applet are installed, are up to date, and are from the vendor requested by the applet. If not, the Java Plug-in can prompt the applet user to download the proper optional package. See Optional Package Versioning for more information.

If a class is not found after searching both the system classes and the classes in the installed optional packages, the extension mechanism will search for the class in a download optional package....

Download optional packages

A download optional package is a JAR files that is specified in the Class-Path header field in the manifest of another JAR files. Classes in download optional packages may be used by classes in the referencing JAR file. In a typical situation, an applet will be bundled in a JAR file whose manifest references a JAR file (or several JAR files) that will serve as an optional package for the purposes of that applet. Optional packages may reference each other in the same way.

A Class-Path header might look like this, for example:

Class-Path: servlet.jar infobus.jar acme/beans.jar

This specifies that the classes in the files servlet.jar, infobus.jar, and acme/beans.jar will serve as optional pakcages for purposes of the classes in the JAR file whose manifest contains this header. The URLs in the Class-Path field are given relative to the URL of the JAR file of the applet or application.

Unlike the case of installed optional packages, the location of the JAR files that serve as download optional packages is irrelevent. A download optional package is an optional package because it is specified as the value of the Class-Path header in another JAR file's manifest, not because it has any particular location.

Another difference between installed and download optional packages is that only applets and applications bundled in a JAR file can make use of download optional packages. Applets and applications not bundled in a JAR file don't have a manifest from which to reference download optional packages.

When searching for a class, the VM first searches among the classes in the system classes and in any installed optional packages. If the class is not found in either the system classes or in the installed optional packages, the VM will search for the class in any download optional packages referenced by the manifest of the application or applet. A download optional package will not be downloaded if a desired class is found among the installed optional packages, even if the download optional package is referenced by the manifest file of the applet or application.

The extension mechanism will not install a download optional package in the JRE or JDK directory structure. Download optional packages do not become installed extentions after they have once been downloaded.

Unlike installed optional packages, download optional packages cannot have any native code.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Applying the Factory Pattern to Java RMI

What is a "factory" and why would you want to use one? A factory, in this context, is a piece of software that implements one of the "factory" design patterns. In general, a factory implementation is useful when you need one object to control the creation of and/or access to other objects.By using a factory in Java Remote Method Invocation (Java RMI), you can reduce the number of objects that you need to register with the Java RMI registry.

Examples of Factories in the Real World:

The Bank

When you go to the bank to make a deposit to your account, you don't walk up to a vault, pull out a drawer with your name on it, drop in your money, shut the drawer and leave. Think about how you originally established, or opened, the account. You probably went to the bank, spoke with an Account Manager, and signed some papers. In return, they gave you some checks, a passbook, or a bank card so you could access your account in the future.

The Account Manager is an example of a factory. The person or Automated Teller Machine (ATM) that acts as account manager controls the creation of and/or access to individual accounts.

The Library

Let's think about how a book, compact disk, or video tape gets from the library shelf into your home. Before you can check out any material, you must first get a library card from the librarian. In this case, the librarian could be viewed as a library card factory because the librarian controls the creation of new library card instances.

Once you have a library card, you can go into the library, and without any further fuss, just walk out with all your materials, right? Of course not. Before you can walk out of the library without setting off the alarm system, you must check out the book, CD, or video tape you wish to take home. So you present your library card to, you guessed it, the librarian, who will use your card to access the library database to see if you owe any late fees, and to register these new materials as having been leased to you. In this case, the librarian could be seen as a book factory because the librarian controls your access to the books.

How Does a Factory Work in Java RMI?

Just like any other Java RMI program, there are a few basic players: a server that produces one or more remote objects, each of which implements a remote interface; a client that accesses a name server (the rmiregistry) to get a reference to one of the remote objects; and the rmiregistry, which facilitates the client's initial contact with the server.

For the picture below and the steps that follow, you may make the following assumptions:

  • There are two remote interfaces that the client understands, Factory and Product
  • The FactoryImpl implements the Factory interface and the ProductImpl implements the Product interface
Illustrates the 6 actions listed below.

  2. The FactoryImpl registers, or is registered, with the rmiregistry
  3. The client requests a reference to a Factory
  4. The rmiregistry returns a remote reference to a FactoryImpl
  5. The client invokes a remote method on the FactoryImpl to obtain a remote reference to a ProductImpl
  6. The FactoryImpl returns a remote reference to an existing ProductImpl or to one that it just created, based on the client request
  7. The client invokes a remote method on the ProductImpl

How Could the Bank and Library be Implemented in Java RMI?

The Bank

In code, AccountManager would be a remote interface with one or more remote methods. These methods would return objects that implement the Account interface. In a similar fashion, Account would be an interface that declared all of the operations a person could perform on an account instance, such as depositing or withdrawing money, getting an account balance, or listing the most recent account transactions.

In Java RMI, only the instance of the AccountManager implementation would be registered with the Java RMI registry. The AccountManager implementation would be the factory, returning remote references to (or serialized instances of) Account implementations, like your savings account.

The Library

In the library example, the Librarian would be a remote interface with one or more methods that would return objects that implement the LibraryCard interface. In addition, the Librarian interface would have methods to allow you access to books, CDs, or videotapes that implemented the Loanable interface.

In Java RMI, only the instance of the Librarian implementation would be registered with the Java RMI registry. The Librarian implementation would be the factory, returning remote references to (or serialized instances of) LibraryCard implementations and Loanable object implementations.

While the bank and library examples presented here may not be entirely complete they are not designed to be complete, but rather instructionally useful in describing the factory pattern in Java RMI.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Frequently Asked Questions (JConsole and Remote Management)

Documentation Contents

Frequently Asked Questions
JConsole and Remote Management

JConsole and JMX Remote Management

  1. I run JConsole on Windows. Why does the Local tab in Connect dialog not list any Java processes?
  2. JDK 5 jconsole and jps commands do not work if your username contains '_' (underscore) on Windows. JConsole is unable to find your Java processes.
  3. How to secure the password file on Windows systems?
  4. JConsole fails to connect to an application remotely or locally running on the same machine using the Remote Tab. However, it works when connecting to it using the Local Tab on the same machine.
  5. I am having problem using JConsole to connect to a JVM running on Linux. Connecting to JVM running on Windows and Solaris works fine.
  6. My application has remote management enabled with SSL. How to setup JConsole to connect to my application?
  7. Can I use JConsole to monitor an application through a firewall?

SNMP Based Management

  1. Where is the standard MIB for SNMP management of the Java virtual machine? What version of SNMP protocol does it require?
  2. I'm not able to see all objects the JVM MIB tree. For example, the jvmMemoryHeapUsed OID is missing. Is it a known problem?

JConsole and JMX Remote Management

  1. I run JConsole on Windows. Why does the Local tab in Connect dialog not list any Java process?

    The problem is most likely that your default Windows temporary directory is on a FAT file system. If your TMP file system is NTFS and JConsole does not show your processes, check your username as described in FAQ #2.

    For security reasons, local monitoring and management is only supported if your default Windows temporary directory is on a file system that supports setting permissions on files and directories (for example, on an NTFS file system). It is not supported on a FAT file system that provide insufficient access controls.

    A potential workaround for this issue:
    Set the TMP environment variable to refer to a directory on an NTFS file system, or any file system that supports setting permissions on files and directories before you run your application with local or remote management enabled. Note that this file system should be local to the machine. Setting this option for target applications is application specific. To set this variable in a command prompt or in a batch script, simply enter the following:

    set TMP=path

    The environment variable can be set globally by adding it to the list of environment variables in the System Properties (Control Panel->System, select the "Advanced" tab and click on the "Environment Variables" button). Through this interface, you can choose to set the variable for all processes run by the current user or globally as a system variable for all processes run by the system.

  2. JDK 5 jconsole and jps commands do not work if your username contains '_' (underscore) on Windows. JConsole is unable to find your Java processes.

    It is a known problem in JDK 5 that jconsole and jps commands do not work on Windows if your username contains '_' (underscore). Bug 6301562 will be fixed in a future release.

  3. How to secure the password file on Windows systems?

    Please see the "How to secure a password file on Windows systems" document for details.

  4. JConsole fails to connect to an application remotely or locally running on the same machine using the Remote Tab. However, it works when connecting to it using the Local Tab on the same machine.

    It is most likely a configuration problem. First, make sure your application was started with remote management enabled. (See details from the "Monitoring and Management using JMX" document.) Second, check if SSL is enabled in the management properties to enable remote management and if it is configured properly.

    SSL is enabled by default when the remote management is enabled. You can disable SSL by setting com.sun.management.jmxremote.ssl property to false. If your application is not set up with SSL properly but SSL is enabled for remote management, JConsole will fail to connect to the application. Please see "Using SSL" section in the "Monitoring and Management Using JMX" document for information about using SSL for remote management.

    If the connection failure problem occurs only when your application runs on Linux, please see FAQ #5.

  5. I am having problem using JConsole to connect to a JVM running on Linux. Connecting to JVM running on Windows and Solaris works fine.

    This is most likely a configuration problem on the Linux machine or the management properties specified to run the application. Please also see FAQ #a4 about using SSL.

    You should check the following:

    • Check if the hostname correctly resolves to the host address.

      Run "hostname -i" command. If it reports 127.0.0.1, JConsole would not be able to connect to the JVM running on that Linux machine. To fix this issue, edit /etc/hosts so that the hostname resolves to the host address.

    • Check if the Linux machine is configured to accept packets from the host where JConsole runs on to connect to the application.

      Packet filtering is built in the Linux kernel. You can run "/sbin/iptables --list" to determine if an external client is allowed to connect to the JMX agent created for remote management. You can use the following command to add a rule to allow an external client such as JConsole to connect:

      /usr/sbin/iptables -I INPUT -s jconsole-host -p tcp --destination-port jmxremote-port -j ACCEPT

      where jconsole-host is either the hostname or the host address on which JConsole runs on and jmxremote-port is the port number set for com.sun.management.jmxremote.port for remote management.

  6. My application has remote management enabled with SSL. How to setup JConsole to connect to my application?

    When you enable the application for remote management with SSL, you have set up a digital certificate on the system where the JMX agent (MBean server) is running and configured SSL properly.

    Assuming you created a keystore as described in the JSSE Guide and started your application (Server) as follows:

    % java -Djavax.net.ssl.keyStore=keystore \
      -Djavax.net.ssl.keyStorePassword=password Server

    To connect to this application, you need to run jconsole as follows:

    % jconsole -J-Djavax.net.ssl.trustStore=truststore \
      -J-Djavax.net.ssl.trustStorePassword=trustword
    The above configuration authenticates the server only. If client authentication is set up, you will need to provide a similar keystore for the JConsole's keys, and an appropriate truststore for the application.
  7. Can I use JConsole to monitor an application through a firewall?

    The com.sun.management.jmxremote.port management property specifies the port where the RMI Registry can be reached but the ports where the RMIServer and RMIConnection remote objects are exported is chosen by the RMI stack. To export the remote objects (RMIServer and RMIConnection) on a given port you need to create your own RMI connector server programmatically, as described in the section Mimicking Out-of-the-Box Management Using the JMX Remote API in the Java SE Monitoring and Management Guide. You must specify the JMXServiceURL as follows:

    JMXServiceURL url = new
JMXServiceURL("service:jmx:rmi://localhost:" + port1 +
"/jndi/rmi://localhost:" + port2 +
"/jmxrmi");
    In the command above, port1 is the port number on which the RMIServer and RMIConnection remote objects are exported and port2 is the port number of the RMI Registry.

SNMP Based Management

  1. Where can I find the standard MIB for SNMP management of the Java virtual machine? What version of SNMP protocol does it require?

    The file JVM-MANAGEMENT-MIB.mib is the standard MIB for the Java virtual machine. Some objects exposed in the JVM MIB are 64-bit quantities. To see these objects, you need to use the SNMP v2 protocol. If you can walk the JVM MIB using SNMP v1 protocol, the 64-bit objects are skipped.

  2. I'm not able to see all objects the JVM MIB tree. For example, the jvmMemoryHeapUsed OID is missing. Is it a known problem?

    The JVM MIB includes 64-bit objects which require to use the SNMP v2 protocol. All the 64-bit objects are skipped if you walk the JVM MIB using SNMP v1.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Fatal Error Log

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

A Fatal Error Log

This appendix describes the fatal error log, its location and contents.

The fatal error log is created when a fatal error occurs. It contains information and the state obtained at the time of the fatal error.

Note:

The format of this file can change slightly in update releases.

This appendix contains the following sections:

  • Location of Fatal Error Log

  • Description of Fatal Error Log

  • Header Format

  • Thread Section Format

  • Process Section Format

  • System Section Format

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Location of Fatal Error Log

To specify where the log file will be created, use the product flag -XX:ErrorFile=file, where file represents the full path for the log file location. The substring %% in the file variable is converted to %, and the substring %p is converted to the PID of the process.

In the following example, the error log file will be written to the directory /var/log/java and will be named java_errorpid.log:

java -XX:ErrorFile=/var/log/java/java_error%p.log

If the -XX:ErrorFile=file flag is not specified, the default log file name is hs_err_pid.log, where pid is the PID of the process.

In addition, if the -XX:ErrorFile=file flag is not specified, the system attempts to create the file in the working directory of the process. In the event that the file cannot be created in the working directory (insufficient space, permission problem, or other issue), the file is created in the temporary directory for the operating system. On Oracle Solaris and Linux operating systems the temporary directory is /tmp. On Windows the temporary directory is specified by the value of the TMP environment variable; if that environment variable is not defined, the value of the TEMP environment variable is used.

 Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of Fatal Error Log

The error log contains information obtained at the time of the fatal error, including the following information, where possible:

  • The operating exception or signal that provoked the fatal error

  • Version and configuration information

  • Details on the thread that provoked the fatal error and thread's stack trace

  • The list of running threads and their state

  • Summary information about the heap

  • The list of native libraries loaded

  • Command line arguments

  • Environment variables

  • Details about the operating system and CPU

Note:

In some cases only a subset of this information is output to the error log. This can happen when a fatal error is of such severity that the error handler is unable to recover and report all details.

The error log is a text file consisting of the following sections:

  • A header that provides a brief description of the crash. See Header Format.

  • A section with thread information. See Thread Section Format.

  • A section with process information. See Process Section Format.

  • A section with system information. See System Section Format.

Note:

The format of the fatal error log described here is based on Java SE 6. The format might be different with other releases.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Header Format

The header section at the beginning of every fatal error log file contains a brief description of the problem. The header is also printed to standard output and may show up in the application's output log.

The header includes a link to the HotSpot Virtual Machine Error Reporting Page, where the user can submit a bug report.

Example A-1 Sample Header from a Crash

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x417789d7, pid=21139, tid=1024
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0-rc-b63 mixed mode, sharing)
# Problematic frame:
# C  [libNativeSEGV.so+0x9d7]

#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#

Example A-1 shows that the VM crashed on an unexpected signal.

The next line describes the signal type, program counter (pc) that caused the signal, process ID and thread ID, as shown in Example A-2.

Example A-2 Header Format Second Line

#  SIGSEGV (0xb) at pc=0x417789d7, pid=21139, tid=1024
      |      |           |             |         +--- thread id
      |      |           |             +------------- process id
      |      |           +--------------------------- program counter
      |      |                                        (instruction pointer)
      |      +--------------------------------------- signal number
      +---------------------------------------------- signal name

The next line contains the VM version (Client VM or Server VM), an indication whether the application was run in mixed or interpreted mode, and an indication whether class file sharing was enabled as shown in Example A-3.

Example A-3 Header Format Third Line

# Java VM: Java HotSpot(TM) Client VM (1.6.0-rc-b63 mixed mode, sharing)

The next information is the function frame that caused the crash, as shown in Example A-4.

Example A-4 Header Format Fourth Line

# Problematic frame:
# C  [libNativeSEGV.so+0x9d7]
  |              +-- Same as pc, but represented as library name and offset.
  |                  For position-independent libraries (JVM and most shared
  |                  libraries), it is possible to inspect the instructions
  |                  that caused the crash without a debugger or core file
  |                  by using a disassembler to dump instructions near the
  |                  offset.
  +----------------- Frame type

In this example, the "C" frame type indicates a native C frame. Table A-1 shows the possible frame types.

Table A-1 Frame Types

Frame Type | Description
C | Native C frame
j | Interpreted Java frame
V | VM frame
v | VM-generated stub frame
J | Other frame types, including compiled Java frames

Internal errors will cause the VM error handler to generate a similar error dump. However, the header format is different. Examples of internal errors are guarantee() failure, assertion failure, ShouldNotReachHere(), and so forth. Example A-5 shows the header format for an internal error.

Example A-5 Header Format for an Internal Error

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# Internal Error (4F533F4C494E55583F491418160E43505000F5), pid=10226, tid=16384
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0-rc-b63 mixed mode)

In the above header, there is no signal name or signal number. Instead the second line now contains Internal Error and a long hexadecimal string. This hexadecimal string encodes the source module and line number where the error was detected. In general this "error string" is useful only to engineers working on the HotSpot Virtual Machine.

The error string encodes a line number and therefore it changes with each code change and release. A crash with a given error string in one release (for example, 1.6.0) might not correspond to the same crash in an update release (for example, 1.6.0_01), even if the strings match.

Note:

Do not assume that a workaround or solution that worked in one situation associated with a given error string will work in another situation associated with that same error string. Note the following facts:

  • Errors with the same root cause might have different error strings.

  • Errors with the same error string might have completely different root causes.

Therefore, the error string should not be used as the sole criterion when troubleshooting bugs.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Thread Section Format

This section contains information about the thread that just crashed. If multiple threads crash at the same time, only one thread is printed.

Thread Information

The first part of the thread section shows the thread that provoked the fatal error, as shown in Example A-6.

Example A-6 Thread Section in the Error Log

Current thread (0x0805ac88):  JavaThread "main" [_thread_in_native, id=21139]
                    |             |         |            |          +-- ID
                    |             |         |            +------------- state
                    |             |         +-------------------------- name
                    |             +------------------------------------ type
                    +-------------------------------------------------- pointer

The thread pointer is the pointer to the Java VM internal thread structure. It is generally of no interest unless you are debugging a live Java VM or core file.

The following list shows possible thread types.

  • JavaThread

  • VMThread

  • CompilerThread

  • GCTaskThread

  • WatcherThread

  • ConcurrentMarkSweepThread

Table A-2 shows the important thread states.

Table A-2 Thread States

Thread State | Description
_thread_uninitialized | Thread is not created. This occurs only in the case of memory corruption.
_thread_new | Thread has been created but it has not yet started.
_thread_in_native | Thread is running native code. The error is probably a bug in native code.
_thread_in_vm | Thread is running VM code.
_thread_in_Java | Thread is running either interpreted or compiled Java code.
_thread_blocked | Thread is blocked.
..._trans | If any of the above states is followed by the string _trans, that means that the thread is changing to a different state.

The thread ID in the output is the native thread identifier.

If a Java thread is a daemon thread, then the string daemon is printed before the thread state.

Signal Information

The next information in the error log describes the unexpected signal that caused the VM to terminate. On a Windows system the output appears as shown in Example A-7.

Example A-7 Unexpected Signal Section in the Error Log

siginfo: ExceptionCode=0xc0000005, reading address 0xd8ffecf1

In the above example, the exception code is 0xc0000005 (ACCESS_VIOLATION), and the exception occurred when the thread attempted to read address 0xd8ffecf1.

On Oracle Solaris and Linux operating systems the signal number (si_signo) and signal code (si_code) are used to identify the exception, as follows:

siginfo:si_signo=11, si_errno=0, si_code=1, si_addr=0x00004321

Register Context

The next information in the error log shows the register context at the time of the fatal error. The exact format of this output is processor-dependent. Example A-8 shows output for the Intel (IA32) processor.

Example A-8 Register Context in the Fatal Error

Registers:
EAX=0x00004321, EBX=0x41779dc0, ECX=0x080b8d28, EDX=0x00000000
ESP=0xbfffc1e0, EBP=0xbfffc1f8, ESI=0x4a6b9278, EDI=0x0805ac88
EIP=0x417789d7, CR2=0x00004321, EFLAGS=0x00010216

The register values might be useful when combined with instructions, as described below.

Machine Instructions

After the register values, Example A-9 the error log that contains the top of stack followed by 32 bytes of instructions (opcodes) near the program counter (PC) when the system crashed. These opcodes can be decoded with a disassembler to produce the instructions around the location of the crash. Note: IA32 and AMD64 instructions are variable in length, and so it is not always possible to reliably decode instructions before the crash PC.

Example A-9 Top Stack in the Error Log

Top of Stack: (sp=0xbfffc1e0)
0xbfffc1e0:   00000000 00000000 0818d068 00000000
0xbfffc1f0:   00000044 4a6b9278 bfffd208 41778a10
0xbfffc200:   00004321 00000000 00000cd8 0818d328
0xbfffc210:   00000000 00000000 00000004 00000003
0xbfffc220:   00000000 4000c78c 00000004 00000000
0xbfffc230:   00000000 00000000 00180003 00000000
0xbfffc240:   42010322 417786ec 00000000 00000000
0xbfffc250:   4177864c 40045250 400131e8 00000000
Instructions: (pc=0x417789d7)
0x417789c7:   ec 14 e8 72 ff ff ff 81 c3 f2 13 00 00 8b 45 08
0x417789d7:   0f b6 00 88 45 fb 8d 83 6f ee ff ff 89 04 24 e8

Thread Stack

Where possible, the next output in the error log is the thread stack, as shown in Example A-10. This includes the addresses of the base and the top of the stack, the current stack pointer, and the amount of unused stack available to the thread. This is followed, where possible, by the stack frames, and up to 100 frames are printed. For C/C++ frames the library name may also be printed. Note: In some fatal error conditions the stack may be corrupt, and in such case this detail may not be available.

Example A-10 Thread Stack in the Error Log

Stack: [0x00040000,0x00080000),  sp=0x0007f9f8,  free space=254k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V  [jvm.dll+0x83d77]
C  [App.dll+0x1047]
j  Test.foo()V+0
j  Test.main([Ljava/lang/String;)V+0
v  ~StubRoutines::call_stub
V  [jvm.dll+0x80f13]
V  [jvm.dll+0xd3842]
V  [jvm.dll+0x80de4]
C  [java.exe+0x14c0]
C  [java.exe+0x64cd]
C  [kernel32.dll+0x214c7]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  Test.foo()V+0
j  Test.main([Ljava/lang/String;)V+0
v  ~StubRoutines::call_stub

The log contains two thread stacks.

  • The first thread stack is Native frames, which prints the native thread showing all function calls. However this thread stack does not take into account the Java methods that are inlined by the runtime compiler; if methods are inlined they appear to be part of the parent's stack frame.

    The information in the thread stack for native frames provides important information about the cause of the crash. By analyzing the libraries in the list from the top down, you can generally determine which library might have caused the problem and report it to the appropriate organization responsible for that library.

  • The second thread stack is Java frames, which prints the Java frames including the inlined methods, skipping the native frames. Depending on the crash it might not be possible to print the native thread stack but it might be possible to print the Java frames.

Further Details

If the error occurred in the VM thread or in a compiler thread, then further details may be seen from Example A-11. For example, in the case of the VM thread, the VM operation is printed if the VM thread is executing a VM operation at the time of the fatal error. In the following output example, the compiler thread provoked the fatal error. The task is a compiler task and the HotSpot Client VM is compiling method hs101t004Thread.ackermann.

Example A-11 VM Thread or Compile Thread in the Error Log

Current CompileTask:
HotSpot Client Compiler:754   b
nsk.jvmti.scenarios.hotswap.HS101.hs101t004Thread.ackermann(IJ)J (42 bytes)

For the HotSpot Server VM the output for the compiler task is slightly different but will also include the full class name and method.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Process Section Format

The process section is printed after the thread section. It contains information about the whole process, including thread list and memory usage of the process.

Thread List

The thread list includes the threads that the VM is aware of, as shown in Example A-12. This includes all Java threads and some VM internal threads, but does not include any native threads created by the user application that have not attached to the VM a shown in Example A-13.

Example A-12 First Line from Thread List Format

=>0x0805ac88 JavaThread "main" [_thread_in_native, id=21139]
|      |         |        |             |             +----- ID
|      |         |        |             +------------------- state
|      |         |        |                                  (JavaThread only)
|      |         |        +--------------------------------- name
|      |         +------------------------------------------ type
|      +---------------------------------------------------- pointer
+------------------------------------------------------ "=>" current thread

Example A-13 VM Internal Threads in the Error Log

Java Threads: ( => current thread )
  0x080c8da0 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=21147]
  0x080c7988 JavaThread "CompilerThread0" daemon [_thread_blocked, id=21146]
  0x080c6a48 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=21145]
  0x080bb5f8 JavaThread "Finalizer" daemon [_thread_blocked, id=21144]
  0x080ba940 JavaThread "Reference Handler" daemon [_thread_blocked, id=21143]
=>0x0805ac88 JavaThread "main" [_thread_in_native, id=21139]

Other Threads:
  0x080b6070 VMThread [id=21142]
  0x080ca088 WatcherThread [id=21148]

The thread type and thread state are described in Thread Section Format.

VM State

The next information is the VM state, which indicates the overall state of the virtual machine. Table A-3 describes the general states.

Table A-3 VM States

General VM State | Description
not at a safepoint | Normal execution.
at safepoint | All threads are blocked in the VM waiting for a special VM operation to complete.
synchronizing | A special VM operation is required and the VM is waiting for all threads in the VM to block.

The VM state output is a single line in the error log, as follows:

VM state:not at safepoint (normal execution)

Mutexes and Monitors

The next information in the error log is a list of mutexes and monitors that are currently owned by a thread, as shown in Example A-14. These mutexes are VM internal locks rather than monitors associated with Java objects. Below is an example to show how the output might look when a crash happens when VM locks are held. For each lock the log contains the name of the lock, its owner, and the addresses of a VM internal mutex structure and its OS lock. In general this information is useful only to those who are very familiar with the HotSpot VM. The owner thread can be cross-referenced to the thread list.

Example A-14 List of Mutexes and Monitors in the Error Log

VM Mutex/Monitor currently owned by a thread:
([mutex/lock_event])[0x007357b0/0x0000031c] Threads_lock - owner thread: 0x00996318
[0x00735978/0x000002e0] Heap_lock - owner thread: 0x00736218

Heap Summary

The next information is a summary of the heap, as shown in Example A-15. The output depends on the garbage collection (GC) configuration. In this example the serial collector is used, class data sharing is disabled, and the tenured generation is empty. This probably indicates that the fatal error occurred early or during start-up and a GC has not yet promoted any objects into the tenured generation.

Example A-15 Heap Summary in the Error Log

Heap
 def new generation   total 576K, used 161K [0x46570000, 0x46610000, 0x46a50000)
  eden space 512K,  31% used [0x46570000, 0x46598768, 0x465f0000)
  from space 64K,   0% used [0x465f0000, 0x465f0000, 0x46600000)
  to   space 64K,   0% used [0x46600000, 0x46600000, 0x46610000)
 tenured generation   total 1408K, used 0K [0x46a50000, 0x46bb0000, 0x4a570000)
   the space 1408K,   0% used [0x46a50000, 0x46a50000, 0x46a50200, 0x46bb0000)
 compacting perm gen  total 8192K, used 1319K [0x4a570000, 0x4ad70000, 0x4e570000)
   the space 8192K,  16% used [0x4a570000, 0x4a6b9d48, 0x4a6b9e00, 0x4ad70000)
No shared spaces configured.

Memory Map

The next information in the log is a list of virtual memory regions at the time of the crash. This list can be long in the case of large applications. The memory map can be very useful when debugging some crashes, as it can tell you what libraries are actually being used, their location in memory, as well as the location of heap, stack, and guard pages.

The format of the memory map is operating-system-specific. On the Oracle Solaris operating system, the base address and library name are printed. On the Linux system the process memory map (/proc/pid/maps) is printed. On the Windows system, the base and end addresses of each library are printed. Example A-16 shows the output generated on Linux/x86. Note: Most of the lines have been omitted from the example for the sake of brevity.

Example A-16 List of Virtual Memory Regions in the Error Log

Dynamic libraries:
08048000-08056000 r-xp 00000000 03:05 259171     /h/jdk6/bin/java
08056000-08058000 rw-p 0000d000 03:05 259171     /h/jdk6/bin/java
08058000-0818e000 rwxp 00000000 00:00 0
40000000-40013000 r-xp 00000000 03:0a 400046     /lib/ld-2.2.5.so
40013000-40014000 rw-p 00013000 03:0a 400046     /lib/ld-2.2.5.so
40014000-40015000 r--p 00000000 00:00 0
Lines omitted.
4123d000-4125a000 rwxp 00001000 00:00 0
4125a000-4125f000 rwxp 00000000 00:00 0
4125f000-4127b000 rwxp 00023000 00:00 0
4127b000-4127e000 ---p 00003000 00:00 0
4127e000-412fb000 rwxp 00006000 00:00 0
412fb000-412fe000 ---p 00083000 00:00 0
412fe000-4137b000 rwxp 00086000 00:00 0
Lines omitted.
44600000-46570000 rwxp 00090000 00:00 0
46570000-46610000 rwxp 00000000 00:00 0
46610000-46a50000 rwxp 020a0000 00:00 0
46a50000-46bb0000 rwxp 00000000 00:00 0
46bb0000-4a570000 rwxp 02640000 00:00 0
Lines omitted.

Example A-17 Format of Memory Map in the Error Log

40049000-4035c000 r-xp 00000000 03:05 824473 /jdk1.5/jre/lib/i386/client/libjvm.so
|<------------->|  ^      ^       ^     ^    |<--------------------------------->|
  Memory region    |      |       |     |                      |
                   |      |       |     |                      |
  Permission   --- +      |       |     |                      |
    r: read               |       |     |                      |
    w: write              |       |     |                      |
    x: execute            |       |     |                      |
    p: private            |       |     |                      |
    s: share              |       |     |                      |
                          |       |     |                      |
  File offset   ----------+       |     |                      |
                                  |     |                      |
  Major ID and minor ID of -------+     |                      |
  the device where the file             |                      |
  is located (i.e. /dev/hda5)           |                      |
                                        |                      |
  inode number  ------------------------+                      |
                                                               |
  File name  --------------------------------------------------+

Example A-17 shows the memory map output, each library has two virtual memory regions: one for code and one for data. The permission for the code segment is marked with r-xp (readable, executable, private), and the permission for the data segment is rw-p (readable, writable, private).

The Java heap is already included in the heap summary earlier in the output, but it can be useful to verify that the actual memory regions reserved for heap match the values in the heap summary and that the attributes are set to rwxp.

Thread stacks usually show up in the memory map as two back-to-back regions, one with permission ---p (guard page) and one with permission rwxp (actual stack space). In addition, it is useful to know the guard page size or stack size. For example, in this memory map, the stack is located from 4127b000 to 412fb000.

On a Windows system, the memory map output is the load and end address of each loaded module, as shown in Example A-18.

Example A-18 Memory Map on Windows

Dynamic libraries:
0x00400000 - 0x0040c000     c:\jdk6\bin\java.exe
0x77f50000 - 0x77ff7000     C:\WINDOWS\System32\ntdll.dll
0x77e60000 - 0x77f46000     C:\WINDOWS\system32\kernel32.dll
0x77dd0000 - 0x77e5d000     C:\WINDOWS\system32\ADVAPI32.dll
0x78000000 - 0x78087000     C:\WINDOWS\system32\RPCRT4.dll
0x77c10000 - 0x77c63000     C:\WINDOWS\system32\MSVCRT.dll
0x08000000 - 0x08183000     c:\jdk6\jre\bin\client\jvm.dll
0x77d40000 - 0x77dcc000     C:\WINDOWS\system32\USER32.dll
0x7e090000 - 0x7e0d1000     C:\WINDOWS\system32\GDI32.dll
0x76b40000 - 0x76b6c000     C:\WINDOWS\System32\WINMM.dll
0x6d2f0000 - 0x6d2f8000     c:\jdk6\jre\bin\hpi.dll
0x76bf0000 - 0x76bfb000     C:\WINDOWS\System32\PSAPI.DLL
0x6d680000 - 0x6d68c000     c:\jdk6\jre\bin\verify.dll
0x6d370000 - 0x6d38d000     c:\jdk6\jre\bin\java.dll
0x6d6a0000 - 0x6d6af000     c:\jdk6\jre\bin\zip.dll
0x10000000 - 0x10032000     C:\bugs\crash2\App.dll

VM Arguments and Environment Variables

The next information in the error log is a list of VM arguments, followed by a list of environment variables, as shown in Example A-19.

Example A-19 List of VM Arguments and Environment Variables

VM Arguments:
java_command: NativeSEGV 2

Environment Variables:
JAVA_HOME=/h/jdk
PATH=/h/jdk/bin:.:/h/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:
     /usr/dist/local/exe:/usr/dist/exe:/bin:/usr/sbin:/usr/ccs/bin:
     /usr/ucb:/usr/bsd:/usr/etc:/etc:/usr/dt/bin:/usr/openwin/bin:
     /usr/sbin:/sbin:/h:/net/prt-web/prt/bin
USERNAME=user
LD_LIBRARY_PATH=/h/jdk6/jre/lib/i386/client:/h/jdk6/jre/lib/i386:
     /h/jdk6/jre/../lib/i386:/h/bugs/NativeSEGV
SHELL=/bin/tcsh
DISPLAY=:0.0
HOSTTYPE=i386-linux
OSTYPE=linux
ARCH=Linux
MACHTYPE=i386

Note:

The list of environment variables is not the full list but rather a subset of the environment variables that are applicable to the Java VM.

Signal Handlers

On Oracle Solaris and Linux operating systems, the next information in the error log is the list of signal handlers, as shown in Example A-20.

Example A-20 List of Signal Handlers in the Error Log

Signal Handlers:
SIGSEGV: [libjvm.so+0x3aea90], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGBUS: [libjvm.so+0x3aea90], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGFPE: [libjvm.so+0x304e70], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGPIPE: [libjvm.so+0x304e70], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGILL: [libjvm.so+0x304e70], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGUSR1: SIG_DFL, sa_mask[0]=0x00000000, sa_flags=0x00000000
SIGUSR2: [libjvm.so+0x306e80], sa_mask[0]=0x80000000, sa_flags=0x10000004
SIGHUP: [libjvm.so+0x3068a0], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGINT: [libjvm.so+0x3068a0], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGQUIT: [libjvm.so+0x3068a0], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGTERM: [libjvm.so+0x3068a0], sa_mask[0]=0xfffbfeff, sa_flags=0x10000004
SIGUSR2: [libjvm.so+0x306e80], sa_mask[0]=0x80000000, sa_flags=0x10000004
Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


System Section Format

The final section in the error log is the system information. The output is operating-system-specific but in general includes the operating system version, CPU information, and summary information about the memory configuration.

Example A-21 shows output on a Oracle Solaris 9 operating system.

Example A-21 System Information in the Error Log

---------------  S Y S T E M  ---------------

OS:                       Oracle Solaris 9 12/05 s9s_u5wos_08b SPARC
           Copyright 2005 Sun Microsystems, Inc.  All Rights Reserved.
                        Use is subject to license terms.
                           Assembled 21 November 2005

uname:SunOS 5.9 Generic_112233-10 sun4u  (T2 libthread)
rlimit: STACK 8192k, CORE infinity, NOFILE 65536, AS infinity
load average:0.41 0.14 0.09

CPU:total 2 has_v8, has_v9, has_vis1, has_vis2, is_ultra3

Memory: 8k page, physical 2097152k(1394472k free)

vm_info: Java HotSpot(TM) Client VM (1.5-internal) for Oracle Solaris-sparc,
built on Aug 12 2005 10:22:32 by unknown with unknown Workshop:0x550

On Oracle Solaris and Linux, the operating system information is contained in the file /etc/*release. This file describes the kind of system the application is running on, and in some cases the information string might include the patch level. Some system upgrades are not reflected in the /etc/*release file. This is especially true on the Linux system, where the user can rebuild any part of the system.

On Oracle Solaris operating system the uname system call is used to get the name for the kernel. The thread library (T1 or T2) is also printed.

On the Linux system the uname system call is also used to get the kernel name. The libc version and the thread library type are also printed, as shown in Example A-22.

Example A-22 Thread Library Type in the Error Log

uname:Linux 2.4.18-3smp #1 SMP Thu Apr 18 07:27:31 EDT 2002 i686
libc:glibc 2.2.5 stable linuxthreads (floating stack)
    |<- glibc version ->|<--  pthread type       -->|

On Linux there are three possible thread types, namely linuxthreads (fixed stack), linuxthreads (floating stack), and NPTL. They are normally installed in /lib, /lib/i686, and /lib/tls.

It is useful to know the thread type. For example, if the crash appears to be related to pthread, then you might be able to work around the issue by selecting a different pthread library. A different pthread library (and libc) can be selected by setting LD_LIBRARY_PATH or LD_ASSUME_KERNEL.

The glibc version usually does not include the patch level. The command rpm -q glibc might provide more detailed version information.

On Oracle Solaris and Linux operating systems, the next information is the rlimit information. Note: The default stack size of the VM is usually smaller than the system limit, as shown in Example A-23.

Example A-23 rlimit Information in the Error Log

rlimit: STACK 8192k, CORE 0k, NPROC 4092, NOFILE 1024, AS infinity
             |          |         |           |           virtual memory (-v)
             |          |         |           +--- max open files (ulimit -n)
             |          |         +----------- max user processes (ulimit -u)
             |          +------------------------- core dump size (ulimit -c)
             +---------------------------------------- stack size (ulimit -s)
load average:0.04 0.05 0.02

The next information specifies the CPU architecture and capabilities identified by the VM at start-up, as shown in the Example A-24 .

Example A-24 CPU Architecture and Capabilities in the Error Log

CPU:total 2 family 6, cmov, cx8, fxsr, mmx, sse
          |        | |<----- CPU features ---->|
          |        |
          |        +--- processor family (IA32 only):
          |                3 - i386
          |                4 - i486
          |                5 - Pentium
          |                6 - PentiumPro, PII, PIII
          |               15 - Pentium 4
          +------------ Total number of CPUs

Table A-4 shows the possible CPU features on a SPARC system.

Table A-4 SPARC Features

SPARC Feature | Description
has_v8 | Supports v8 instructions.
has_v9 | Supports v9 instructions.
has_vis1 | Supports visualization instructions.
has_vis2 | Supports visualization instructions.
is_ultra3 | UltraSparc III.
no-muldiv | No hardware integer multiply and divide.
no-fsmuld | No multiply-add and multiply-subtract instructions.

Table A-5 shows the possible CPU features on an Intel/IA32 system.

Table A-5 Intel/IA32 Features

Intel/IA32 Feature | Description
cmov | Supports cmov instruction.
cx8 | Supports cmpxchg8b instruction.
fxsr | Supports fxsave and fxrstor.
mmx | Supports MMX.
sse | Supports SSE extensions.
sse2 | Supports SSE2 extensions.
ht | Supports Hyper-Threading Technology.

Table A-6 shows the possible CPU features on an AMD64/EM64T system.

Table A-6 AMD64/EM64T Features

AMD64/EM64T Feature | Description
amd64 | AMD Opteron, Athlon64, and so forth.
em64t | Intel EM64T processor.
3dnow | Supports 3DNow extension.
ht | Supports Hyper-Threading Technology.

The next information in the error log is memory information, as shown in Example A-25.

Example A-25 Memory information in the Error Log

                                                  unused swap space
                              total amount of swap space        |
                   unused physical memory            |          |
total amount of physical memory       |              |          |
     page size              |         |              |          |
           v                v         v              v          v
Memory: 4k page, physical 513604k(11228k free), swap 530104k(497504k free)

Some systems require swap space to be at lease twice the size of real physical memory, whereas other systems do not have any such requirements. As a general rule, if both physical memory and swap space are almost full, there is good reason to suspect that the crash was due to insufficient memory.

On Linux systems the kernel may convert most of unused physical memory to file cache. When there is a need for more memory, the Linux kernel will give the cache memory back to the application. This is handled transparently by the kernel, but it does mean the amount of unused physical memory reported by fatal error handler could be close to zero when there is still sufficient physical memory available.

The final information in the SYSTEM section of the error log is vm_info, which is a version string embedded in libjvm.so/jvm.dll. Every Java VM has its own unique vm_info string. If you are in doubt about whether the fatal error log was generated by a particular Java VM, check the version string.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.Field (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.Field

  • Packages that use Field
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.
    com.sun.jdi.event
    This package defines JDI events and event processing.
    com.sun.jdi.request
    This package is used to request that a JDI event be sent under specified conditions.

    • Uses of Field in com.sun.jdi

      Methods in com.sun.jdi that return Field
      Modifier and Type Method and Description
      Field ReferenceType.fieldByName(String fieldName)
      Finds the visible Field with the given non-ambiguous name.
      Methods in com.sun.jdi that return types with arguments of type Field
      Modifier and Type Method and Description
      List<Field> ReferenceType.allFields()
      Returns a list containing each Field declared in this type, and its superclasses, implemented interfaces, and/or superinterfaces.
      List<Field> ReferenceType.fields()
      Returns a list containing each Field declared in this type.
      Map<Field,Value> ReferenceType.getValues(List<? extends Field> fields)
      Returns a map containing the Value of each static Field in the given list.
      Map<Field,Value> ObjectReference.getValues(List<? extends Field> fields)
      Gets the value of multiple instance and/or static fields in this object.
      List<Field> ReferenceType.visibleFields()
      Returns a list containing each unhidden and unambiguous Field in this type.
      Methods in com.sun.jdi with parameters of type Field
      Modifier and Type Method and Description
      Value ReferenceType.getValue(Field field)
      Gets the Value of a given static Field in this type.
      Value ObjectReference.getValue(Field sig)
      Gets the value of a given instance or static field in this object.
      void ObjectReference.setValue(Field field, Value value)
      Sets the value of a given instance or static field in this object.
      void ClassType.setValue(Field field, Value value)
      Assigns a value to a static field.
      Method parameters in com.sun.jdi with type arguments of type Field
      Modifier and Type Method and Description
      Map<Field,Value> ReferenceType.getValues(List<? extends Field> fields)
      Returns a map containing the Value of each static Field in the given list.
      Map<Field,Value> ObjectReference.getValues(List<? extends Field> fields)
      Gets the value of multiple instance and/or static fields in this object.

    • Uses of Field in com.sun.jdi.event

      Methods in com.sun.jdi.event that return Field
      Modifier and Type Method and Description
      Field WatchpointEvent.field()
      Returns the field that is about to be accessed/modified.

    • Uses of Field in com.sun.jdi.request

      Methods in com.sun.jdi.request that return Field
      Modifier and Type Method and Description
      Field WatchpointRequest.field()
      Gets the Field being watched by this WatchpointRequest.
      Methods in com.sun.jdi.request with parameters of type Field
      Modifier and Type Method and Description
      AccessWatchpointRequest EventRequestManager.createAccessWatchpointRequest(Field field)
      Creates a new disabled watchpoint which watches accesses to the specified field.
      ModificationWatchpointRequest EventRequestManager.createModificationWatchpointRequest(Field field)
      Creates a new disabled watchpoint which watches accesses to the specified field.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.javadoc.FieldDoc (Doclet API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.javadoc.FieldDoc

    • Uses of FieldDoc in com.sun.javadoc

      Methods in com.sun.javadoc that return FieldDoc
      Modifier and Type Method and Description
      FieldDoc[] ClassDoc.enumConstants()
      Return the enum constants if this is an enum type.
      FieldDoc[] ClassDoc.fields()
      Return included fields in this class or interface.
      FieldDoc[] ClassDoc.fields(boolean filter)
      Return fields in this class or interface, filtered to the specified access modifier option.
      FieldDoc[] ClassDoc.serializableFields()
      Return the Serializable fields of this class or interface.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Doclet API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


FileContents (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface FileContents

  • public interface FileContents
    FileContents objects encapsulate the name and contents of a file. An implementation of this class is used by the FileOpenService, FileSaveService, and PersistenceService.

    The FileContents implementation returned by PersistenceService.get(java.net.URL), FileOpenService, and FileSaveService should never truncate a file if the maximum file length is set to be less that the current file length.

    Since:
    1.4.2
    See Also:
    FileOpenService, FileSaveService

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean canRead()
      Returns whether the file can be read.
      boolean canWrite()
      Returns whether the file can be written to.
      java.io.InputStream getInputStream()
      Gets an InputStream from the file.
      long getLength()
      Gets the length of the file.
      long getMaxLength()
      Gets the maximum file length for the file, as set by the creator of this object.
      java.lang.String getName()
      Gets the file name as a String.
      java.io.OutputStream getOutputStream(boolean overwrite)
      Gets an OutputStream to the file.
      JNLPRandomAccessFile getRandomAccessFile(java.lang.String mode)
      Returns a JNLPRandomAccessFile representing a random access interface to the file's contents.
      long setMaxLength(long maxlength)
      Sets the maximum file length for the file.

    • Method Detail

      • getName

        java.lang.String getName()
                  throws java.io.IOException
        Gets the file name as a String.
        Returns:
        a string containing the file name.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • getInputStream

        java.io.InputStream getInputStream()
                            throws java.io.IOException
        Gets an InputStream from the file.
        Returns:
        an InputStream to the file.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • getOutputStream

        java.io.OutputStream getOutputStream(boolean overwrite)
                              throws java.io.IOException
        Gets an OutputStream to the file. A JNLP client may implement this interface to return an OutputStream subclass which restricts the amount of data that can be written to the stream.
        Returns:
        an OutputStream from the file.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • getLength

        long getLength()
        throws java.io.IOException
        Gets the length of the file.
        Returns:
        the length of the file as a long.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • canRead

        boolean canRead()
         throws java.io.IOException
        Returns whether the file can be read.
        Returns:
        true if the file can be read, false otherwise.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • canWrite

        boolean canWrite()
          throws java.io.IOException
        Returns whether the file can be written to.
        Returns:
        true if the file can be read, false otherwise.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • getRandomAccessFile

        JNLPRandomAccessFile getRandomAccessFile(java.lang.String mode)
                                  throws java.io.IOException
        Returns a JNLPRandomAccessFile representing a random access interface to the file's contents. The mode argument must either be equal to "r" or "rw", indicating the file is to be opened for input only or for both input and output, respectively. An IllegalArgumentException will be thrown if the mode is not equal to "r" or "rw".
        Parameters:
        mode - the access mode.
        Returns:
        a JNLPRandomAccessFile.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • getMaxLength

        long getMaxLength()
           throws java.io.IOException
        Gets the maximum file length for the file, as set by the creator of this object.
        Returns:
        the maximum length of the file.
        Throws:
        java.io.IOException - if an I/O exception occurs.

      • setMaxLength

        long setMaxLength(long maxlength)
           throws java.io.IOException
        Sets the maximum file length for the file. A JNLP client may enforce restrictions on setting the maximum file length. A JNLP client should not truncate a file if the maximum file length is set that is less than the current file size, but it also should not allow further writes to that file.
        Parameters:
        maxlength - the requested new maximum file length.
        Returns:
        the maximum file length that was granted.
        Throws:
        java.io.IOException - if an I/O exception occurs.
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


FileOpenService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface FileOpenService

  • public interface FileOpenService
    FileOpenService service allows the user to choose a file from the local file system, even for applications that are running in the untrusted execution environment. The JNLP Client is the mediator and is therefore responsible for providing the specific implementation of this, if any.

    This service provides a similar function as the file input field for HTML-based forms.

    Since:
    1.4.2
    See Also:
    FileSaveService, FileContents

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      FileContents openFileDialog(java.lang.String pathHint, java.lang.String[] extensions)
      Asks the user to choose a single file.
      FileContents[] openMultiFileDialog(java.lang.String pathHint, java.lang.String[] extensions)
      Asks the user to choose one or more files.

    • Method Detail

      • openFileDialog

        FileContents openFileDialog(java.lang.String pathHint,
                            java.lang.String[] extensions)
                     throws java.io.IOException
        Asks the user to choose a single file. The contents of a potential selected file is returned as a FileContents object. The returned FileContents object contains the contents along with the name of the file. The full path is not returned.
        Parameters:
        pathHint - A hint from the application to the initial directory for the file chooser. This might be ignored by the JNLP Client.
        extensions - A list of default extensions to show in the file chooser. For example, String[] { "txt", "java" }. This might be ignored by the JNLP Client.
        Returns:
        A FileContent object with information about the chosen file, or null if the user did not choose a file.
        Throws:
        java.io.IOException - if the request failed in any way other than the user did not choose to select a file.

      • openMultiFileDialog

        FileContents[] openMultiFileDialog(java.lang.String pathHint,
                                   java.lang.String[] extensions)
                            throws java.io.IOException
        Asks the user to choose one or more files. Otherwise similar to openFileDialog(java.lang.String, java.lang.String[])
        Throws:
        java.io.IOException
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


FileSaveService (JNLP API Reference 1.8.0_51)

Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
javax.jnlp

Interface FileSaveService

  • public interface FileSaveService
    FileSaveService service allows the user to save a file to the local file system, even for applications that are running in the untrusted execution environment. The JNLP Client is the mediator and is therefore responsible for providing the specific implementation of this, if any.

    This service provides similar functionatlity as the Save as... functionality provided by most browsers.

    Since:
    1.4.2
    See Also:
    FileOpenService, FileContents

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      FileContents saveAsFileDialog(java.lang.String pathHint, java.lang.String[] extensions, FileContents contents)
      Asks the users to save a file.
      FileContents saveFileDialog(java.lang.String pathHint, java.lang.String[] extensions, java.io.InputStream stream, java.lang.String name)
      Asks the users to save a file.

    • Method Detail

      • saveFileDialog

        FileContents saveFileDialog(java.lang.String pathHint,
                            java.lang.String[] extensions,
                            java.io.InputStream stream,
                            java.lang.String name)
                     throws java.io.IOException
        Asks the users to save a file.
        Parameters:
        pathHint - A hint from the application to the default directory to be used. This might be ignored by the JNLP Client.
        extensions - A list of default extensions to show in the file chooser. For example, String[] { "txt", "java" }. These might be ignored by the JNLP Client.
        stream - The content of the file to save along represented as an InputStream
        name - The suggested filename, which might be ignored by the JNLP client
        Returns:
        A FileContents object for the saved file if the save was successfully, or null if the user canceled the request.
        Throws:
        IOException - if the requested failed in any way other than the user chose not to save the file
        java.io.IOException

      • saveAsFileDialog

        FileContents saveAsFileDialog(java.lang.String pathHint,
                              java.lang.String[] extensions,
                              FileContents contents)
                       throws java.io.IOException
        Asks the users to save a file.
        Parameters:
        pathHint - A hint from the application to the default directory to be used. This might be ignored by the JNLP Client.
        extensions - A list of default extensions to show in the file chooser. For example, String[] { "txt", "java" }. These might be ignored by the JNLP Client.
        contents - The content of the file to save along with the suggested filename. The suggested filename might be ignored by the JNLP Client.
        Returns:
        A FileContents object for the saved file if the save was successfully, or null if the user canceled the request.
        Throws:
        IOException - if the requested failed in any way other than the user chose not to save the file
        java.io.IOException
Skip navigation links
  • Package
  • Class
  • Tree
  • Index
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Copyright © 1998, 2015, Oracle and/or its affiliates. All rights reserved.


Developing a Custom File System Provider

Introduction

The NIO.2 API introduced in the Java SE 7 release provides the ability to develop a custom file system provider that can be used to manage file system objects. A file system is essentially a container with organized, homogenous elements referred to as file system objects. A file system provides access to file system objects. A file system object can be a file store, file, or directory. A file store is a volume or partition in which files are stored. For example, in a native file system such as on the Windows platform, commonly known drives like c: or d: are file stores. On the Solaris operating system, / (root) and mounted directories are considered file stores.

The java.nio.file.spi.FileSystemProvider class allows you to develop a custom file system provider. A custom file system provider is useful in the following situations:

  • Developing a memory-based or zip-file-based file system
  • Developing a fault-tolerant distributed file system
  • Replacing or supplementing the default file system provider. The custom provider can augment the default provider by performing specific operations, such as logging all system operations, and delegate to the default provider for other routine operations.

Overview of the java.nio.file.spi.FileSystemProvider Class

A custom file system provider must implement the java.nio.file.spi.FileSystemProvider class. A file system provider is identified by a URI scheme such as file, jar, memory, cd.

An implementation of the java.nio.file.spi.FileSystemProvider class is a factory for instances of the java.nio.file.FileSystem class. A file system's URI has a URI scheme that matches the URI scheme of the file system provider that created it.

The newFileSystem method is used to create a file system and the getFileSystem method is used to retrieve a reference to an existing file system.

Implementing a Custom File System Provider

This section describes the high-level steps necessary to create a custom file system provider using the java.nio.file.spi.FileSystemProvider API. The ZipFileSystemProvider class that is shipped in the demo/nio/zipfs of your JDK installation is an example of a custom file system provider. See Resources for information about the zip file system provider.

Implementing the Custom File System Provider Class

Implementing the custom file system provider class involves the following operations:

  • Create a custom file system provider class, such as MyFileSystemProvider, that extends the java.nio.file.spi.FileSystemProvider class.
  • Define a URI scheme such as jar for the file system provider. The getScheme method should return the URI scheme of this provider.
  • Create an internal cache to keep track of file systems created by this provider.
  • Implement the newFileSystem method. The method will create a new custom file system at the specified path and add the file system to cache. This method should throw a java.nio.file.FileSystemAlreadyExistsException exception if a file system already exists at the specified path.
  • Implement the getFileSystem method. This method should search the cache and return a previously created instance of a file system that corresponds to the given URI.
  • Implement the newFileChannel method or the newAsynchronousFileChannel method depending on the requirements of your file system provider. This method should return a FileChannel object that allows a file to be read or written in the file system.

Implementing the Custom File System Class

Implementing the custom file system class involves the following operations:

  • Create a class, such as MyFileSystem, that extends the java.nio.file.FileSystem class.
  • Implement the methods of your file system class depending on the characteristics of the desired file system. Some characteristics of a file system are as follows:
    • Number of roots – A file system can have a single hierarchy of files with one root, or multiple hierarchies.
    • Read and write access – A file system can be read-only or read/write.
    • File store – A file system requires an underlying file store. The attributes that can be set for a file will vary depending on the underlying file store.

Resources

  • Zip File System Provider
  • Zip File System Properties
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.net.httpserver.Filter (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Filter

  • Packages that use Filter
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of Filter in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return types with arguments of type Filter
      Modifier and Type Method and Description
      abstract List<Filter> HttpContext.getFilters()
      returns this context's list of Filters.
      Constructor parameters in com.sun.net.httpserver with type arguments of type Filter
      Constructor and Description
      Chain(List<Filter> filters, HttpHandler handler)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.Filter.Chain (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Filter.Chain

  • Packages that use Filter.Chain
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of Filter.Chain in com.sun.net.httpserver

      Methods in com.sun.net.httpserver with parameters of type Filter.Chain
      Modifier and Type Method and Description
      abstract void Filter.doFilter(HttpExchange exchange, Filter.Chain chain)
      Asks this filter to pre/post-process the given exchange.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


How Classes are Found

Documentation Contents
Java Platform, Standard Edition Tools Reference
Contents Previous Next

1 How Classes are Found

The java command is called the Java launcher because it launches Java applications. When the Java launcher is called, it gathers input from the user and the user's environment (such as the class path and the boot class path), interfaces with the Virtual Machine (VM), and gets it started via some bootstrapping. The Java Virtual Machine (JVM) does the rest of the work.

This chapter covers the following topics:

  • How the Java Runtime Finds Classes

  • How the javac and javadoc Commands Find Classes

  • Class Loading and Security Policies

How the Java Runtime Finds Classes

The JVM searches for and loads classes in this order:

  1. Bootstrap classes, which are classes that comprise the Java platform, including the classes in rt.jar and several other important JAR files.

  2. Extension classes, which use the Java Extension mechanism. These classes are bundled as JAR files and located in the extensions directory.

  3. User classes are classes that are defined by developers and third parties and that do not take advantage of the extension mechanism. You identify the location of these classes with the -classpath option on the command line (preferred) or with the CLASSPATH environment variable. See Setting the Class Path.

In effect, the three search paths together form a simple class path. This is similar to the flat class path previously used, but the current model has the following improvements:

  • It is relatively difficult to accidentally hide or omit the bootstrap classes.

  • In general, you only have to specify the location of user classes. Bootstrap classes and extension classes are found automatically.

  • The tools classes are now in a separate archive (tools.jar) and can only be used if included in the user class path described in How the Java Runtime Finds Bootstrap Classes.

How the Java Runtime Finds Bootstrap Classes

Bootstrap classes are the classes that implement Java SE. Bootstrap classes are in the rt.jar file and several other JAR files in the jre/lib directory. These archives are specified by the value of the bootstrap class path that is stored in the sun.boot.class.path system property. This system property is for reference only and should not be directly modified.It is unlikely that you will need to redefine the bootstrap class path. The nonstandard option, -Xbootclasspath, allows you to do so in those rare circumstances in which it is necessary to use a different set of core classes.

Note that the classes that implement the JDK tools are in a separate archive from the bootstrap classes. The tools archive is the JDK /lib/tools.jar file. The development tools add this archive to the user class path when invoking the launcher. However, this augmented user class path is only used to execute the tool. The tools that process source code, the javac command, and the javadoc command, use the original class path, not the augmented version. For more information, see How the javac and javadoc Commands Find Classes.

How the Java Runtime Finds Extension Classes

Extension classes are classes that extend the Java platform. Every .jar file in the extension directory, jre/lib/ext, is assumed to be an extension and is loaded with the Java Extension Framework. Loose class files in the extension directory are not found. They must be contained in a JAR file or Zip file. There is no option provided for changing the location of the extension directory.

If the jre/lib/ext directory contains multiple JAR files, and those files contain classes with the same name such as in the following example, the class that actually gets loaded is undefined.

smart-extension1_0.jar contains class smart.extension.Smart

smart-extension1_1.jar contains class smart.extension.Smart

How the Java Runtime Finds User Classes

To find user classes, the launcher refers to the user class path, which is a list of directories, JAR files, and Zip files that contain class files.

A class file has a subpath name that reflects the fully-qualified name of the class. For example, if the class com.mypackage.MyClass is stored under myclasses, then myclasses must be in the user class path, and the full path to the class file must be /myclasses/com/mypackage/MyClass.class on Oracle Solaris or in \myclasses\com\mypackage\MyClass.class on Windows.

If the class is stored in an archive named myclasses.jar, then myclasses.jar must be in the user class path, and the class file must be stored in the archive as com/mypackage/MyClass.class on Windows or in com\mypackage\MyClass.class on Oracle Solaris.

The user class path is specified as a string, with a colon (:) to separate the class path entries on Oracle Solaris, and a semicolon (;) to separate the entries on Windows systems. The Java launcher puts the user class path string in the java.class.path system property. The possible sources of this value are:

  • The default value, *.*, which means that user class files are all the class files in or under the current directory.

  • The value of the CLASSPATH environment variable that overrides the default value.

  • The value of the -cp or -classpath command-line option that overrides both the default value and the CLASSPATH value.

  • The JAR archive specified by the -jar option overrides all other values if it contains a Class-Path entry in its manifest. If this option is used, all user classes must come from the specified archive.

How the Java Runtime Finds JAR-class-path Classes

A JAR file usually contains a manifest, which is a file that lists the contents of the JAR file. The manifest can define a JAR class path, which further extends the class path, but only while loading classes from that JAR file. Classes accessed by a JAR class path are found in the following order:

  1. In general, classes referenced by a JAR class path entry are found as though they are part of the JAR file. The JAR files that appear in the JAR-class-path are searched after any earlier class path entries and before any entries that appear later in the class path.

  2. If the JAR class path points to a JAR file that was already searched, for example, an extension or a JAR file that was listed earlier in the class path, then that JAR file is not searched again. This optimization improves efficiency and prevents circular searches. This type of JAR file is searched at the point that it appears, which is earlier in the class path.

  3. If a JAR file is installed as an extension, then any JAR class path it defines is ignored. All of the classes required by an extension are presumed to be part of the JDK or to have been installed as extension.

How the javac and javadoc Commands Find Classes

The javac and javadoc commands use class files in the following two ways:

  • To run, the javac and javadoc commands must load various class files.

  • To process the source code they operate on, the javac and javadoc commands must obtain information on object types used in the source code.

The class files used to resolve source code references are mostly the same class files used to run the javac and javadoc commands. But there are some important exceptions, as follows:

  • Both the javac and javadoc commands often resolve references to classes and interfaces that have nothing to do with the implementation of the javac or javadoc commands. Information on referenced user classes and interfaces might be present in the form of class files, source code files, or both.

  • The tools classes in the tools.jar file are only used to run the javac and javadoc commands. The tools classes are not used to resolve source code references unless the tools.jar file is in the user class path.

  • A programmer might want to resolve boot class or extension class references with an alternative Java platform implementation. Both the javac and javadoc commands support this with their -bootclasspath and -extdirs options. Use of these options does not modify the set of class files used to run the javac or javadoc commands themselves.

If a referenced class is defined in both a class file and a source file, the javadoc command always uses the source file. The javadoc command never compiles source files. In the same situation the javac command uses class files, but automatically recompiles any class files it determines to be out of date. The rules for automatic recompilation are documented in javac(1).

By default, the javac and javadoc commands search the user class path for both class files and source code files. If the -sourcepath option is specified, the javac and javadoc commands search for source files only on the specified source file path, while still searching the user class path for class files.

Class Loading and Security Policies

To be used, a class or interface must be loaded by a class loader. Use of a particular class loader determines a security policy associated with the class loader.

A program can load a class or interface by calling the loadClass method of a class loader object. But usually a program loads a class or interface by referring to it. This invokes an internal class loader, which can apply a security policy to extension and user classes. If the security policy has not been enabled, all classes are trusted. Even if the security policy is enabled, it does not apply to bootstrap classes, which are always trusted.

When enabled, security policy is configured by system and user policy files. The Java platform SDK includes a system policy file that grants trusted status to extension classes and places basic restrictions on user classes.

To enable or configure the security policy, refer to Security Features.

Note: Some security programming techniques that worked with earlier releases of Java SE are incompatible with the class loading model of the current release.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


System Properties for Java 2D Technology

This document describes several unsupported properties that you can use to customize how the 2D painting system operates. You might use these properties to improve performance, fix incorrect rendering, or avoid system crashes under certain configurations. For example, on a small set of Microsoft Windows computers with bad DirectDraw or Direct3D drivers, the use of hardware-accelerated rendering might cause system crashes. You can use properties to specify that on these computers, the Java 2D system shouldn't use DirectDraw or Direct3D.

Warning: Take care when using these properties. Some of them are unsupported for very practical reasons. For example, some behaviors are disabled by default due to driver instabilities; enabling such behaviors could cause system instabilities on some configurations.

Since these properties have the sole purpose of enabling or disabling implementation-specific behaviors, they are subject to change or removal without notification. Some properties might work only on the exact product releases for which they are documented.

2D properties have the prefix sun.java2d.. To specify them, you can use either command-line flags or the _JAVA_OPTIONS environment variable. For example, you can specify the 2D trace property with a flag when running an application, like this:

java -Dsun.java2d.trace=log SomeApp
Or you can specify it by setting _JAVA_OPTIONS before running the application, like this:
export _JAVA_OPTIONS='-Dsun.java2d.trace=log' (Solaris, Linux, or Mac OS X bash shell)
java SomeApp

Some system properties are also settable using environment variables. For example, the d3d property has the equivalent environment variable J2D_D3D. The property description lists the equivalent environment variable, if one exists.

Note: See the High Performance Graphics White Paper for explanations of terms used in property descriptions.

This document lists the following properties:

  • System Properties for All Platforms
    • opengl
    • trace
    • awt.useSystemAAFontSettings
  • System Properties for Microsoft Windows Platforms
    • accthreshold
    • d3d
    • d3dtexbpp
    • ddforcevram
    • ddoffscreen
    • ddscale
    • noddraw
    • translaccel
  • System Properties for Linux and Solaris Platforms
    • NO_J2D_DGA
    • J2D_PIXMAPS
    • xrender
    • pmoffscreen

System Properties for All Platforms

opengl

Intended use: To enable the OpenGL-based pipeline, which provides hardware acceleration.
Introduced: 1.5 Beta 1 (Solaris/Linux); 1.5 Beta 2 (Microsoft Windows)
Default value: false
How to use: To silently enable the OpenGL-based pipeline, set this property to true:

-Dsun.java2d.opengl=true

To receive verbose console output about whether the OpenGL-based pipeline is initialized successfully for a particular screen, set this property to True (note the uppercase T):

-Dsun.java2d.opengl=True

An OpenGL-based pipeline for Java 2D was introduced in 1.5 Beta 1 for Solaris/Linux and 1.5 Beta 2 for Microsoft Windows platforms. This pipeline is currently disabled by default. It provides hardware acceleration for simple rendering operations (text, images, lines, and filled primitives) as well as those that involve complex transforms, paints, composites, and clips.

For more information: The OpenGL section of New Java 2D Features in the Java 2 SDK, v1.5.

trace

Intended use: To help determine the source of less-than-desirable graphics performance.
Introduced: 1.4
How to use: If your application is experiencing less-than-desirable performance, the trace runtime flag can help you determine the source of the problem. The flag is specified with a list of options:

    -Dsun.java2d.trace=[log[,timestamp]],[count],[out:<filename>],[help],[verbose]

The options are:

log
print out the name of each primitive as it is executed
timestamp
precede each log entry with the currentTimeMillis()
count
at exit, print out a count of each primitive used
out:<filename>
send output (logging and counts) to the indicated file
help
print out a short usage statement
verbose
print out a summary of the options chosen for this run

If you use the log option, the Java runtime will print the executed primitives' names, most of which will be in this format:

    <classname>.<methodname>(<src>,<composite>,<dst>)

The methodname represents the basic graphics operation that is used to do the actual rendering work of a Graphics method invocation. These method names will not necessarily map directly to methods on the Graphics object, nor will the number of calls made on the Graphics object map directly to the number of primitive operations performed.

The src and dst represent the type of surfaces or source data involved in the operation.

The composite names match the names in the AlphaComposite class fairly closely with the suffix "NoEa" meaning that the AlphaComposite instance had an "extra alpha" attribute of 1.0. The "SrcNoEa" type is the most commonly used composite type and represents the simplest way of transferring pixels with no blending required. "SrcNoEa" is often used behind the scenes even though the default composite is "SrcOver" when opaque colors and images are rendered because the two operations are indistinguishable for opaque source pixels.

Platform rendering pipelines are sometimes used for doing opaque operations on surfaces accessible by a platform renderer, such as X11, GDI, or DirectDraw. Their names currently use a simplified naming format, which has a prefix for the platform renderer and the name of the operation but without any classname or operand type list. Examples are "X11DrawLine", "GDIFillOval", and "DXFillRect". In the future these names should more closely approximate the names of the other primitives.

awt.useSystemAAFontSettings

Intended use:To override what text anti-aliasing settings are identified as being "desktop settings".
Introduced: 1.6
Default value:true.
How to use:Set on the command line or in a webstart jnlp file as one of the specified values below to control rendering hints used by Swing text.

Strictly this flag doesn't control Java 2D but is documented here because the values all directly map to Java 2D text antialiasing rendering hints values.

What the flag really does is override what the JRE reads from the user's desktop settings as the user's desktop antialiased text preferences. Swing instructs Java 2D to render Swing text to match that preference, so by overriding it you can control Swing text. This applies to standard Swing components (like JTextArea, JButton) in the Metal L&F (aka Java L&F) and native (Windows, GTK) Swing L&Fs. It should also apply to any custom component or L&F which picks up the same property.

For information on the desktop setting this overrides see AWT Desktop Properties

There aren't many reasons for you to specify this property but a couple are

  • The desktop setting you want isn't supported on your desktop (eg you want LCD text on Windows 2000)
  • JRE doesn't recognise your desktop setting (eg KDE)
  • You are automating testing under each of these conditions
System Property Value   | java.awt.RenderingHint value
"off"|"false"|"default" : VALUE_TEXT_ANTIALIAS_DEFAULT
"on"                    : VALUE_TEXT_ANTIALIAS_ON
"gasp"                  : VALUE_TEXT_ANTIALIAS_GASP
"lcd"|"lcd_hrgb"        : VALUE_TEXT_ANTIALIAS_LCD_HRGB
"lcd_hbgr"              : VALUE_TEXT_ANTIALIAS_LCD_HBGR
"lcd_vrgb"              : VALUE_TEXT_ANTIALIAS_LCD_VRGB
"lcd_vbgr"              : VALUE_TEXT_ANTIALIAS_LCD_VBGR

System Properties for Microsoft Windows Platforms

accthreshold

Obsoleted in: Java SE 6 Update 10
Intended use: To determine how many copies from managed images will occur before a VRAM version of the image is automatically created.
Introduced: 1.4.1_02
Default value: 1
How to use: To force accelerated surfaces to be created during image initialization, set the value to 0, as follows:

-Dsun.java2d.accthreshold=0

This property can be used to eliminate the initial delay in rendering when the images are being copied to the VRAM after the first few copies. Instead, the delay is effectively shifted to the image creation time.

This could be useful behavior when you know that your application will be able to take advantage of image management; just get the overhead of the copy over with at the start instead of incurring some number of slower copies to begin with and then having the copy overhead at some later time.

d3d

Intended use: To turn off the Java 2D system's use of Direct3D.
Introduced: 1.4.1_02
Equivalent environment variable: J2D_D3D
How to use: On a small subset of Windows 2000 systems with buggy Direct3D drivers, the use of Direct3D can cause a system crash. To turn off the use of Direct3D, set this property to false:
-Dsun.java2d.d3d=false
If problems persist, try setting the ddoffscreen property to false. If that doesn't solve the problems, try setting noddraw to true.

d3dtexbpp

Obsoleted in: Java SE 6 Update 10
Intended use: To specify that accelerated surfaces for managed or translucent images should be in 16-bit (4444) format, which saves VRAM and system memory but at the cost of decreased quality.
Introduced: 1.4.1_02
Default value: 32
How to use: To turn on 4444 format, set this property to 16:

-Dsun.java2d.d3dtexbpp=16
Note: The d3dtexbpp property has no effect if the OpenGL pipeline is in use.

When this property is set to 16, it forces the accelerated surfaces for managed images (created with GraphicsConfiguration.createCompatibleImage(w,h, TRANSLUCENT)) or translucent images loaded with Toolkit.getImage to be in 4444 format. The system memory surface for these images will be in 4444 format as well.

This option is useful when you have lots of images to be stored in VRAM. The downside is poorer quality.

This option is also useful for computers with video boards (such as 3dfx Voodoo3) that don't support 32-bit textures. When the Java 2D system uses 32-bit textures, as it does by default, then when it encounters a card without 32-bit texture support it disables support for accelerated translucent images. If you want acceleration of translucent images on a video board that doesn't support 32-bit textures, set the d3dtexbpp property to 16.

ddforcevram

Obsoleted in: Java SE 6 Update 10
Intended use: To specify whether VolatileImages should be kept in VRAM.
Introduced: 1.4.1_02
Default value: false in 1.4; as of 1.5 Beta 1, true if translaccel is true, and otherwise false
How to use: Normally, if the 2D system is using the DirectDraw/Direct3D pipeline and detects that an image in video memory is being read from too often (an expensive operation), it punts it to a system memory surface, which is faster to read from. Later, if the system detects that the user is copying from this surface to an accelerated surface again, it promotes it to the video memory. Setting this property to true disables the punting mechanism and always keeps the image in video memory.

Note: The ddforcevram property has no effect if the OpenGL pipeline is in use.

Although this property is often used with the translaccel property, it can be used separately. To set this property to true, either set translaccel to true in a 1.5 release, or set it separately:

-Dsun.java2d.ddforcevram=true

ddoffscreen

Obsoleted in: Java SE 6 Update 10, which contains a new implementation of D3D support. Setting sun.java2d.ddoffscreen=false is now interpreted exactly the same as disabling that via sun.java2d.d3d=false.
Intended use: To turn off the Java 2D system's use of DirectDraw and Direct3D for offscreen surfaces such as the Swing back buffer.
Introduced: 1.4
Default value: true
How to use: Setting this flag to false turns off DirectDraw offscreen surfaces acceleration.

ddscale

Obsoleted in: Java SE 6 Update 10
Intended use: To turn on hardware-accelerated scaling when the DirectDraw/Direct3D pipeline is in use.
Introduced: 1.2
Default value: false
How to use: Setting this flag to true enables hardware-accelerated scaling if the DirectDraw/Direct3D pipeline is in use. DirectDraw/Direct3D hardware scaling is disabled by default to avoid rendering artifacts in existing applications. These rendering artifacts are caused by possible inconsistencies between the scale method that the software scaling operation uses (nearest neighbor) and the different scale methods that video cards use. Certain events that occur while an application is running might cause a scaled image to be rendered partially with hardware scaling operations and partially with software scaling operations, resulting in an inconsistent appearance. For now, you can enable acceleration by setting the ddscale flag to true.

Note: The ddscale property has no effect if the OpenGL pipeline is in use.

For more information: High Performance Graphics White Paper

noddraw

Obsoleted in: Java SE 6 Update 10, which contains a new implementation of D3D support. Setting sun.java2d.noddraw=true is now interpreted exactly the same as disabling that via sun.java2d.d3d=false.
Intended use: To turn off the Java 2D system's use of DirectDraw and Direct3D completely.
Introduced: 1.2
Default value: false
How to use: Setting this flag to true turns off DirectDraw usage, which sometimes helps to get rid of rendering problems on Win32.

translaccel

Obsoleted in: Java SE 6 Update 10
Intended use: To specify whether translucent images should be hardware-accelerated when the DirectDraw/Direct3D pipeline is in use.
Introduced: 1.4.1_02
Default value: false
How to use: When the DirectDraw/Direct3D pipeline is being used, both translaccel and ddforcevram must be true for translucent images to be accelerated.

Note: The translaccel property has no effect if the OpenGL pipeline is in use.

To turn on acceleration of translucent images in 1.4 and 1.5:

-Dsun.java2d.translaccel=true
-Dsun.java2d.ddforcevram=true //unnecessary as of 1.5 Beta 1

When both these properties are true, the Java 2D system attempts to put translucent images into VRAM and use Direct3D for rendering (compositing) them to the screen or to a VolatileImage. Only translation transforms are supported (no rotation, scaling, and so on). Before 1.5, to be accelerated a translucent image had to be created in one of the following ways:

  • GraphicsConfiguration.createCompatibleImage(w,h, Transparency.TRANSLUCENT)
  • Images loaded with Toolkit.getImage() that have a translucent color model
As of 1.5, translucent images created with a BufferedImage constructor can also be accelerated. To find out whether an image can be accelerated on a particular device, you can use the Image getCapabilities method to get an ImageCapabilities object, which you can query using the isAccelerated method. Note that a managed image gets accelerated only after a certain number of copies to the screen or to another accelerated surface.

The following code fragment illustrates the use of accelerated images. The fragment assumes that back buffer is a VolatileImage. BufferStrategy can be used as well.

Image translucentImage = gc.createCompatibleImage(w, h, Transparency.TRANSLUCENT);
//...
Graphics2D g2 = (Grahics2D)backBuffer.getGraphics();
g2.drawImage(translucentImage, x, y, null);

Compositing with extra alpha with SRC_OVER rule (which is the default Graphics2D compositing rule) is accelerated, so the following code will allow the use of hardware for compositing: Code:

Image translucentImage = gc.createCompatibleImage(w, h, Transparency.TRANSLUCENT);
// ...
float ea = 0.5;
Graphics2D g2 = (Grahics2D)backBuffer.getGraphics();
g2.setComposite(AlphaComposite.getInstance(AlphaComposite.SRC_OVER, ea));
g2.drawImage(translucentImage, x, y, null);

System Properties for Linux and Solaris Platforms

NO_J2D_DGA

Intended use: To turn off DGA support and hardware acceleration on Solaris Sparc, which sometimes helps to reduce rendering artifacts.
Introduced: 1.2
Default value: (unset)
How to use: This property is settable only as an environment variable; it has no command-line flag equivalent. To turn off DGA support and hardware acceleration on Solaris Sparc, define the variable:
setenv NO_J2D_DGA

Setting this variable automatically enables the use of pixmaps, in effect setting pmoffscreen to true. The reverse, however, is not true: setting pmoffscreen to true doesn't disable DGA.

J2D_PIXMAPS

Intended use: To determine whether the 2D system uses shared memory pixmaps in the local display environment for storing images that experience frequent reads.
Introduced: 1.4 Beta 3
Default value: (unset)
How to use: This property is settable only as an environment variable; it has no command-line flag equivalent. As of 1.4 Beta 3, Java 2D starts out using normal pixmaps to store images, but changes the storage of frequently read images to use Shared Memory Pixmaps in the local display environment. You can override this default behavior, and force only one type of pixmap to be used, with J2D_PIXMAPS environment flag:
    setenv J2D_PIXMAPS=shared
    setenv J2D_PIXMAPS=server

If you set this flag to shared, all images are stored in Shared Memory Pixmaps if you are working in a local display environment. Conversely, if you set this flag to server, all images are stored in normal pixmaps, not Shared Memory Pixmaps; the normal pixmaps can be stored in VRAM at the discretion of the device driver.

For more information: High Performance Graphics White Paper

xrender

Intended use: To enable the XRender-based Java 2D rendering pipeline for modern X11-based desktops, offering improved graphics performance.
Introduced: Java SE 7
Default value: false
How to use: The pipeline is disabled by default, but may be enabled by setting the command line property -Dsun.java2d.xrender=true. Older X11 configurations may not be able to support XRender. The verbose form, -Dsun.java2d.xrender=True, can be used to enable a message to stdout indicating whether the pipeline was actually enabled.

pmoffscreen

Intended use: To determine whether Java 2D stores images in pixmaps by default when DGA is not available.
Introduced: 1.4 Beta 3
Default value: (unset)
How to use: As of 1.4 Beta 3, Java 2D stores images in pixmaps by default when DGA is not available, whether you are working in a local or remote display environment. You can override this behavior with the pmoffscreen flag:

    -Dsun.java2d.pmoffscreen=true
    -Dsun.java2d.pmoffscreen=false

Setting this flag to false disables offscreen pixmap support, which can solve some rendering problems. When the flag is true, offscreen pixmap support is enabled even if DGA is available.

For more information: High Performance Graphics White Paper

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.jdi.FloatType (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.FloatType

No usage of com.sun.jdi.FloatType
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.jdi.FloatValue (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.jdi.FloatValue

  • Packages that use FloatValue
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of FloatValue in com.sun.jdi

      Methods in com.sun.jdi that return FloatValue
      Modifier and Type Method and Description
      FloatValue VirtualMachine.mirrorOf(float value)
      Creates a FloatValue for the given value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Focus API changes

This document outlines the API changes that have been done to AWT and Swing to accomodate the new focus model. For a general overview of the changes, you may want to first read this.

Modifications to existing classes:

  • java.awt.AWTEvent
  • java.awt.Component
  • java.awt.Container
  • java.awt.Window
  • java.awt.Frame
  • java.awt.Dialog
  • java.awt.FocusEvent
  • java.awt.event.WindowEvent
  • java.awt.event.WindowListener
  • java.awt.event.WindowAdapter
  • java.awt.AWTEventMulticaster
  • javax.swing.FocusManager
  • javax.swing.DefaultFocusManager
  • javax.swing.JComponent
  • javax.swing.JInternalFrame
  • javax.swing.KeyStroke
  • javax.swing.SwingUtilities

New classes:

  • java.awt.KeyboardFocusManager
  • java.awt.KeyEventDispatcher
  • java.awt.DefaultKeyboardFocusManager
  • java.awt.FocusTraversalPolicy
  • java.awt.ContainerOrderFocusTraversalPolicy
  • java.awt.DefaultFocusTraversalPolicy
  • java.awt.AWTKeyStroke
  • java.awt.event.WindowFocusListener
  • javax.swing.SortingFocusTraversalPolicy
  • javax.swing.LayoutFocusTraversalPolicy
  • javax.swing.InternalFrameFocusTraversalPolicy

Add the following to java.awt.AWTEvent:

    public void setSource(Object newSource)

Changes to java.awt.Component:

    public boolean isFocusTraversable()

    public boolean isFocusable()

    public void setFocusable(boolean focusable)

    public void setFocusTraversalKeys(int id, Set keystroke)

    public Set getFocusTraversalKeys(int id)

    public void setFocusTraversalKeysEnabled(boolean focusTraversalKeysEnabled)

    public boolean getFocusTraversalKeysEnabled()

    public void requestFocus()

    protected boolean requestFocus(boolean temporary)

    public boolean requestFocusInWindow()

    protected boolean requestFocusInWindow(boolean temporary)

    public void transferFocus()

    public void transferFocusBackward()

    public void transferFocusUpCycle()

    public Container getFocusCycleRootAncestor()

    public boolean isFocusCycleRoot(Container container)

    public boolean hasFocus()

    public boolean isFocusOwner()

    public void addPropertyChangeListener(PropertyChangeListener listener)

    public void removePropertyChangeListener(PropertyChangeListener listener)

    public void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)

    public void removePropertyChangeListener(String propertyName, PropertyChangeListener listener)

    public void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)

    public void firePropertyChange(String propertyName, int oldValue, int newValue)

    public boolean isFontSet()

    public boolean isBackgroundSet()

    public boolean isForegroundSet()

    public boolean isCursorSet()

    public boolean areFocusTraversalKeysSet(int id)

Changes to java.awt.Container:

    public void setFocusTraversalKeys(int id, Set keystroke)

    public Set getFocusTraversalKeys(int id)

    public void setFocusTraversalPolicy(FocusTraversalPolicy policy)

    public FocusTraversalPolicy getFocusTraversalPolicy()

    public void setFocusCycleRoot(boolean focusCycleRoot)

    public boolean isFocusCycleRoot()

    public boolean isFocusCycleRoot(Container container)

    public void transferFocusDownCycle()

    public void addPropertyChangeListener(PropertyChangeListener listener)

    public void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)

    public boolean areFocusTraversalKeysSet(int id)

    public boolean isFocusTraversalPolicySet()

Changes to java.awt.Window:

    public void toFront()

    public void toBack()

    public Component getFocusOwner()

    public Component getMostRecentFocusOwner()

    public boolean isActive()

    public boolean isFocused()

    public final void setFocusCycleRoot(boolean focusCycleRoot)

    public final boolean isFocusCycleRoot()

    public final Container getFocusCycleRootAncestor()

    public boolean isFocusableWindow()

    public void setFocusableWindowState(boolean focusableWindowState)

    public void addPropertyChangeListener(PropertyChangeListener listener)

    public void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)

Add the following to the javadoc of java.awt.Frame:

/**
 * Frames are capable of generating the following types of WindowEvents:
 * WindowOpened, WindowClosing, WindowClosed, WindowIconified,
 * WindowDeiconified, WindowActivated, WindowDeactivated, WindowGainedFocus,
 * WindowLostFocus.
 */

Add the following to the javadoc of java.awt.Dialog:

/**
 * Dialogs are capable of generating the following WindowEvents:
 * WindowOpened, WindowClosing, WindowClosed, WindowActivated,
 * WindowDeactivated, WindowGainedFocus, WindowLostFocus.
 */

Add the following to java.awt.event.FocusEvent:

    public FocusEvent(Component source, int id, boolean temporary, Component opposite)

    public Component getOppositeComponent()

Add the following to the javadoc of java.awt.event.WindowEvent:

/**
 * A low-level event that indicates that a window has changed its status. This
 * low-level event is generated by a Window object when it is opened, closed,
 * activated, deactivated, iconified, or deiconified, or when focus is
 * transfered into or out of the Window.
 */

Add the following to java.awt.event.WindowEvent:

    public static final int WINDOW_ACTIVATED

    public static final int WINDOW_DEACTIVATED

    public static final int WINDOW_GAINED_FOCUS

    public static final int WINDOW_LOST_FOCUS

    public WindowEvent(Window source, int id, Window opposite)

    public Window getOppositeWindow()

Add the following to java.awt.event.WindowListener:

    public void windowActivated(WindowEvent e)

    public void windowDeactivated(WindowEvent e)

Add the following to java.awt.event.WindowAdapter:

    public void windowGainedFocus(WindowEvent e)

    public void windowLostFocus(WindowEvent e)

Add the following to java.awt.AWTEventMulticaster:

    public void windowGainedFocus(WindowEvent e)

    public void windowLostFocus(WindowEvent e)

Modifications to javax.swing.FocusManager

This class has been obsoleted. New applications should use java.awt.KeyboardFocusManager exclusively. Nevertheless, we have preserved backward compatibility for existing applications (but not applets) which define their own FocusManager.

The Swing FocusManager has been changed to be a subclass of the new, AWT KeyboardFocusManager. FocusManager.setCurrentManager(FocusManager) and FocusManager.getCurrentManager() have been changed to wrappers around KeyboardFocusManager.setCurrentKeyboardFocusManager(KeyboardFocusManager) and KeyboardFocusManager.getCurrentKeyboardFocusManager(), respectively.

There was much discussion over these changes because KeyboardFocusManager.setCurrentKeyboardFocusManager(KeyboardFocusManager) will throw a SecurityException if the calling thread was not granted the "replaceKeyboardFocusManager" permission. Previously, FocusManager.setCurrentManager(FocusManager) would never throw a SecurityException. Although we were able to design a convoluted class organization which avoided this problem, we felt that the elegance and simplicity of the proposed design outweighed the rather small backward compatibility concern.

disableSwingFocusManager() and isFocusManagerEnabled() should not be used. Disabling the Swing FocusManager now has the semantics of reverting the default FocusTraversalPolicy from the Swing default of javax.swing.LayoutFocusTraversalPolicy to the AWT default of java.awt.DefaultFocusTraversalPolicy.

Modifications to javax.swing.DefaultFocusManager

This class has been obsoleted. New applications should use java.awt.KeyboardFocusManager exclusively. Nevertheless, we have preserved backward compatibility for existing applications (but not applets) which define their own DefaultFocusManager.

If client code installs a legacy DefaultFocusManager, we provide backward compatibility by installing a non-public LegacyGlueFocusTraversalPolicy which routes FocusTraversalPolicy method invocations to the corresponding methods on DefaultFocusManager.

Modifications to javax.swing.JComponent

isManagingFocus: This method has been obsoleted. It changed a JComponent's focus traversal keys from TAB and SHIFT-TAB to CTRL-TAB and CTRL-SHIFT-TAB. It also marked the JComponent in such a way that focus traversal would not automatically enter the JComponent. This was similar to, but different from, marking a JComponent as a focus cycle root. Its functionality is superseded by the FocusTraversalPolicy class, per-Component focus traversal keys, and the ability to disable a Component's focus traversal keys en masse.

setNextFocusableComponent/getNextFocusableComponents: These methods have been obsoleted FocusTraversalPolicies are more reliable because they allow an algorithmic expression of focus traversal. These methods force applications to hard-code focus traversal Component by Component.

The spec for setRequestFocusEnabled/isRequestFocusEnabled has changed, such that the requestFocusEnabled property is now a hint to the current look and feel.

requestDefaultFocus: This method has been obsoleted. Its functionality is superseded by FocusTraversalPolicy.getDefaultComponent(Container).requestFocus().

Modifications to javax.swing.JInternalFrame

getMostRecentFocusOwner: Like java.awt.Window, JInternalFrame has a getFocusOwner() method left over from before centralization of focus management in java.awt.KeyboardFocusManager. To round out the API, and to remain consistent with Window, getMostRecentFocusOwner() has been added to JInternalFrame with the same specification as the corresponding method on Window.

setFocusCycleRoot/isFocusCycleRoot: These methods give JInternalFrames similar semantics to top-level Windows in AWT. Since a JInternalFrame must always be a focus cycle root, these methods are overridden and declared final to enforce that restriction. However, unlike an AWT Window, a JInternalFrame can have a focus-cycle-root ancestor, such as a JDesktopPane. Thus, Component.getFocusCycleRootAncestor() is not declared final in JInternalFrame as it is in Window.

Modifications to javax.swing.KeyStroke

Because the existing KeyStroke class was useful for designing per-Component focus traversal key APIs, this class was promoted with minor modifications to AWT as java.awt.AWTKeyStroke. The Swing class is now a subclass of the AWT class.

The one deprecated method in KeyStroke, getKeyStroke(char, boolean), was not promoted to AWT. Because of this, there is no simple way for this method to participate in the standard AWTKeyStroke caching scheme. The specification of this method has been changed to note that implementations need not cache the instances returned by this method.

Modifications to javax.swing.SwingUtilities

findFocusOwner: This method has been obsoleted. Its functionality is superseded by KeyboardFocusManager.getFocusOwner().

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Supported Fonts

The set of supported fonts varies between different implementations of the Java platform. For the terminology used, see the Font class description.

  • Support for Physical Fonts
  • Support for Logical Fonts
  • The Lucida Fonts

Support for Physical Fonts

The JRE supports TrueType and PostScript Type 1 fonts.

Physical fonts need to be installed in locations known to the Java runtime environment. The JRE looks in two locations: the lib/fonts directory within the JRE itself, and the normal font location(s) defined by the host operating system. If fonts with the same name exist in both locations, the one in the lib/fonts directory is used.

Users can add physical fonts that use a supported font technology by installing them either in the lib/fonts directory within the JRE, or by installing them in a way supported by the host operating system. The recommended location to add per-user fonts on Solaris or Linux is the $HOME/.fonts directory which is searched by the platform's libfontconfig, and which is in turn used by the JDK.

Support for Logical Fonts

Logical font names are mapped to physical fonts in implementation dependent ways. Typically one logical font name maps to several physical fonts in order to cover a large range of characters. The JRE uses font configuration files to define the mapping.

Users can add a physical font as a fallback font to logical fonts used in Java 2D rendering by installing it in the lib/fonts/fallback directory within the JRE.

The Lucida Fonts

The JDK and the JRE bundle several physical fonts of the "Lucida" design family. These fonts are also licensed for use in other implementations of the Java Platform. These fonts are physical fonts, but since they come with the Java SE Runtime, they don't depend on the host operating system. Using them provides the benefit of a consistent look and feel across platforms and implementations for a large set of languages.

There are three different type families: "Lucida Sans", "Lucida Sans Typewriter", and"Lucida Bright". Each family has plain, bold, italic, and bold-italic styles. Not all of these are present in all Java SE implementations. For example, the default download bundle of the JRE for Windows only contains the Lucida Sans plain font (but note that application developers can include all Lucida fonts with a Java runtime environment that they redistribute with an application).

The following table shows which Unicode character blocks are covered by each font family:

Unicode Block | Lucida Sans | Lucida Sans Typewriter | Lucida Bright
Basic Latin | yes | yes | yes
Latin-1 Supplement | yes | yes | yes
Latin Extended-A | yes | yes | yes
Latin Extended-B | partial | partial | partial
IPA Extensions | partial | no | no
Spacing Modifier Letter | partial | partial | partial
Combining Diacritical Marks | partial | no | partial
Greek | yes | yes | yes
Cyrillic | partial | partial | partial
Hebrew | yes | yes | no
Arabic | partial | partial | partial
Devanagari | yes | no | no
Thai | yes | yes | no
General Punctuation | partial | partial | partial
Superscripts and Subscripts | partial | partial | partial
Currency Symbols | partial | partial | partial
Letterlike Symbols | partial | partial | partial
Number Forms | partial | partial | no
Arrows | partial | partial | partial
Mathematical Operators | yes | partial | yes
Enclosed Alphanumerics | partial | no | no
Box Drawings | partial | partial | no
Block Elements | partial | partial | no
Geometric Shapes | partial | partial | partial
Miscellaneous Symbols | partial | partial | no
Dingbats | yes | no | no
Alphabetic Presentation Forms | partial | partial | no
Arabic Presentation Forms-A | partial | partial | partial
Arabic Presentation Forms-B | yes | yes | yes

Note that of the writing systems that are generally fully supported by the JRE, the Lucida fonts do not support Chinese (Simplified), Chinese (Traditional), Japanese, and Korean. (See JDK 8 and JRE 8 Supported Locales.)

The fonts are installed in the Java SE Runtime Environment's lib/fonts directory as the following files (not all of them may be present):

LucidaSansDemiBold.ttf
LucidaSansRegular.ttf
LucidaTypewriterBold.ttf
LucidaTypewriterRegular.ttf
LucidaBrightDemiBold.ttf
LucidaBrightDemiItalic.ttf
LucidaBrightItalic.ttf
LucidaBrightRegular.ttf
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration font2dtest.png

Documentation Contents

This illustration shows a screenshot of the Font2DTest tool window. The menu bar at the top of the window contains two menus: File and Option.

Below the menu bar, the top half of the window contains four rows of various controls. The first row contains a drop-down list labeled Font with the Microsoft Sans Serif item selected, a text field labeled Size with 12 specified, and another drop-down list labeled Font Transform with the None item selected. The second row contains a grayed out drop-down list labeled Range with the Basic Latin item selected, a drop-down list labeled Style with the Plain item selected, and another drop-down list labeled Graphics Transform with the None item selected. The third row contains a grayed out drop-down list labeled Method with the drawGlyphVector item selected and another drop-down list labeled Text to use with the All Glyphs item selected. The fourth row contains a grayed out slider labeled LCD contrast with the value of 140 selected, a drop-down list labeled Antialiasing with the OFF item selected, and another drop-down list labeled Fractional metrics with the OFF item selected.

The bottom half of the window contains a table with a separate cell for each glyph of the selected font. There are 36 columns and 9 rows with a scrollbar on the right. Text under the table reads: Displaying Glyph Code 0000 to 0143.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Font Configuration Files

The Java Platform defines five logical font names that every implementation must support: Serif, SansSerif, Monospaced, Dialog, and DialogInput. These logical font names are mapped to physical fonts in implementation dependent ways.

Sun's Java SE Runtime Environments use font configuration files to map logical font names to physical fonts. There are several files to support different mappings depending on the host operating system version. The files are located in the lib directory within the JRE installation. Users can edit or create their own font configuration files to adjust the mappings to their particular system setup. Note however that this is a modification of the JRE, and Sun does not support modified JREs.

Font configuration files come in two formats: A properties format and a binary format. The properties format is described in detail in this document and can be used for user-defined configurations. The binary format is undocumented and used only for the JRE's predefined configurations; the corresponding files in properties format are available for reference as files with the ".properties.src" extension.

Note that font configuration files are implementation dependent. Not all implementations of the Java Platform use them, and the format and content vary between different runtime environments as well as between releases. This document describes the format used by version 6 of Sun's Java SE Runtime Environments.

  1. Loading Font Configuration Files
  2. Names Used in Font Configuration Files
  3. Properties for All Platforms
  4. Properties for Windows
  5. Properties for Solaris and Linux

Loading Font Configuration Files

To find the appropriate font configuration file for a host operating system, the following information is used:

  • JavaHome - the JRE's directory, as given by the "java.home" system property.
  • OS - a string identifying an operating system variant:
    • For Windows, "98", "2000", "Me", "XP", "2003".
    • For Solaris, empty.
    • For Linux, "Sun", "RedHat", "Turbo", "SuSE".
  • Version - a string identifying the operating system version.

The runtime uses the first of the following files it finds:

        JavaHome/lib/fontconfig.OS.Version.properties
        JavaHome/lib/fontconfig.OS.Version.bfc
        JavaHome/lib/fontconfig.OS.properties
        JavaHome/lib/fontconfig.OS.bfc
        JavaHome/lib/fontconfig.Version.properties
        JavaHome/lib/fontconfig.Version.bfc
        JavaHome/lib/fontconfig.properties
        JavaHome/lib/fontconfig.bfc

Files with a ".properties" suffix are assumed to be properties files as specified by the Properties class and are loaded through that class. Files without this suffix are assumed to be in binary format.

Names Used in Font Configuration Files

Throughout the font configuration files, a number of different names are used:

  • LogicalFontName - one of the five logical font names: serif, sansserif, monospaced, dialog, and dialoginput. In font configuration files, these names are always in lowercase.
  • StyleName - one of the four standard font styles: plain, bold, italic, and bolditalic. Again, these names are always in lowercase.
  • PlatformFontName - the name of a physical font, in a format typically used on the platform:
    • On Windows, a font face name, such as "Courier New" or "\uad74\ub9bc".
    • On Solaris and Linux, an xlfd name, such as "-monotype-times new roman-regular-r---*-%d-*-*-p-*-iso8859-1". Note that "%d" is used for the font size - the actual font size is filled in at runtime.
  • CharacterSubsetName - a name for a subset of the Unicode character set which certain component fonts can render. For Windows, the following names are predefined: alphabetic, arabic, chinese-ms936, chinese-gb18030, chinese-ms950, chinese-hkscs, cyrillic-iso8859-5, cyrillic-cp1251, cyrillic-koi8-r, devanagari, dingbats, greek, hebrew, japanese, korean, latin, symbol, thai. For Solaris and Linux, the following names are predefined: arabic, chinese-gb2312, chinese-gbk, chinese-gb18030-0, chinese-gb18030-1, chinese-cns11643-1, chinese-cns11643-2, chinese-cns11643-3, chinese-big5, chinese-hkscs, cyrillic, devanagari, dingbats, greek, hebrew, japanese-x0201, japanese-x0208, japanese-x0212, korean, korean-johab, latin-1, latin-2, latin-4, latin-5, latin-7, latin-9, symbol,thai. A font configuration file may define additional names to identify additional character subsets.
  • Encoding - the canonical name of the default encoding, as provided by java.nio.charset.Charset.defaultCharset().name().
  • Language - the language of the initial default locale.
  • Country - the country of the initial default locale.

Properties for All Platforms

Version Property

The version property identifies the font configuration format version. This document specifies version 1.

The complete property has the form:

version=1

Component Font Mappings

Component font mapping properties describe which physical font to use to render characters from a given character subset with a given logical font in a given style.

The keys have the forms:

        allfonts.CharacterSubsetName
        LogicalFontName.StyleName.CharacterSubsetName

The first form is used if the same font is used for a character subset independent of logical font and style (in this case, the font rendering engines apply algorithmic styles to the font). The second form is used if different physical fonts are used for a character subset for different logical fonts and styles. In this case, properties must be specified for each combination of logical font and style, so 20 properties for one character subset. If a property of the first form is present for a character subset, then properties of the second form for the same character subset are ignored.

The values are platform font names, as described above.

Since the character subsets supported by given fonts often overlap, separate search sequence properties are used to define in which order to try the fonts when rendering a character.

Search Sequences

The Java runtime uses sequence properties to determine search sequences for the five logical fonts. However, a font configuration file may specify properties that are specific to a combination of encoding, language, and country, and the runtime will then use a lookup to determine the search sequence property for each logical font.

The keys have the form:

     sequence.allfonts.Encoding.Language.Country
        sequence.LogicalFontName.Encoding.Language.Country
        sequence.allfonts.Encoding.Language
        sequence.LogicalFontName.Encoding.Language
        sequence.allfonts.Encoding
        sequence.LogicalFontName.Encoding
        sequence.allfonts
        sequence.LogicalFontName

The allfonts forms are used if the sequence is used for all five logical fonts. The forms specifying logical font names are used if different sequences are used for different logical fonts.

For each logical font, the Java runtime uses the property value with the first of the above keys. This property determines the primary search sequence for the logical font.

The file may also define a single fallback search sequence. The key for the fallback search sequence property is:

     sequence.fallback

The values of all search sequence properties have the form:

SearchSequenceValue:
        CharacterSubsetName
        CharacterSubsetName , SearchSequenceValue

The primary search sequence properties specify character subset names for required fonts, which are used for both AWT and 2D font rendering. The fallback search sequence property gives character subset names for optional fonts, which are used as fallbacks for all logical fonts, but only for 2D font rendering. The runtime automatically adds the Lucida Sans Regular font as a fallback font for 2D rendering if it's not already specified. If the runtime environment has a directory lib/fonts/fallback and this directory contains valid TrueType or Type 1 fonts, the runtime automatically adds these fonts as fallback fonts for 2D rendering. On Windows, if there is a system EUDC (End User Defined Characters) font registered with Windows, the runtime automatically adds this font as well as a fallback font for 2D rendering.

The sequence properties determine in which sequence component fonts are tried to render a given character. For example, given the following properties:

sequence.monospaced=japanese,alphabetic
sequence.fallback=korean
monospaced.plain.alphabetic=Arial
monospaced.plain.japanese=MSGothic
monospaced.plain.korean=Gulim

the runtime will first attempt to render a character with the MSGothic font. If that font doesn't provide a glyph for the character, it will attempt the Arial font. For 2D rendering, it will also try the Gulim and the Lucida Sans Regular font as well as any TrueType or Type 1 fonts in the runtime's lib/fonts/fallback directory. For 2D rendering on Windows, if there is a system EUDC font registered with Windows, the runtime will finally try this EUDC font.

When calculating font metrics for a logical font without reference to a string, only the required fonts are taken into consideration. For the example above, the FontMetrics.getMaxDescent method would return results based on the MSGothic and Arial fonts, but not the Gulim and Lucida Sans fonts. In this way, simple user interface elements such as buttons, which sometimes calculate their size based on font metrics, are not affected by an extended list of component fonts which their labels usually don't use. On the other hand, text components typically calculate metrics based on the text they contain and thus will obtain correct results.

The sequence properties that the runtime obtains for the five logical fonts should list the same character subsets, but may list them in different order.

Exclusion Ranges

The exclusion range properties specify Unicode character ranges which should be excluded from being rendered with the fonts corresponding to a given character subset. This is used if a font with a large character repertoire needs to be placed early in the search sequence (for example, for performance reasons), but some characters that it supports should be drawn with a different font instead. These properties are optional, so there's at most one per character subset.

The keys have the form:

     exclusion.CharacterSubsetName

The values have the form:

ExclusionRangeValue:
        Range
        Range , ExclusionRangeValue

Range:
        Char - Char

Char:
        HexDigit HexDigit HexDigit HexDigit
        HexDigit HexDigit HexDigit HexDigit HexDigit HexDigit

A Char is a Unicode character represented as a hexadecimal value.

Proportional Fonts

The proportional font properties describe the relationship between proportional and non-proportional variants of otherwise equivalent fonts. These properties are used to implement preferences specified by the GraphicsEnvironment.preferProportionalFonts method.

The keys have the form:

     proportional.PlatformFontName

Space characters in the platform font name must be replaced with underscore characters ("_").

The values have the form:

     PlatformFontName

In values, space characters are left unmodified.

Each property indicates that the font named in the value is the proportional equivalent of the font named in the key, and also that the font named in the key is the non-proportional equivalent of the font named in the value.

Font File Names

Font file name properties provide the names of the files containing the physical fonts used in the font configuration file. File names are required for all physical fonts on Windows and recommended for all physical fonts on Solaris and Linux.

The keys have the form:

     filename.PlatformFontName

Space characters in the platform font name must be replaced with underscore characters ("_").

The values are the file names of the files containing the fonts. On Windows, simple file names are used; and the runtime environment looks for each file first in its own lib/fonts directory, then in the Windows fonts directory. On Solaris and Linux, absolute path names, path names starting with "$JRE_LIB_FONTS" for the runtime environment's own lib/fonts directory, or xlfd names are used.

Appended Font Path

The Java runtime can automatically determine a number of directories that contain font files, such as its own lib/fonts directory or the Windows fonts folder. Additional directories can be specified to be appended to the font path.

The key has the form:

     appendedfontpath

The value has the form:

AppendedFontPathValue:
        Directory
        Directory PathSeparator AppendedFontPathValue

The path separator is the platform dependent value of java.io.File.pathSeparator.

Properties for Windows

There are no platform-specific properties for Windows. However, there is a special form of the character subset name used in search sequences. The name "alphabetic" can take a suffix indicating the character encoding associated with the subset:

     alphabetic
        alphabetic/default
        alphabetic/1252

This information is only used for AWT, not for 2D. The "/default" suffix restricts use of the component fonts for this character subset to the character set of the default encoding; the "/1252" suffix to the Windows-1252 character set. For accessing component font mappings and exclusion ranges, the character encoding suffix is omitted. For all other character subsets, the AWT character encoding is determined internally by the Java runtime.

Properties for Solaris and Linux

Motif Component Font Mappings

The AWT text components, which rely on Motif-based peers for text rendering, cannot always use the same platform fonts as other AWT components and 2D. When looking up component fonts for these components, additional keys are recognized. The complete set of keys looked up in this case is:

     allfonts.CharacterSubsetName.motif
        LogicalFontName.StyleName.CharacterSubsetName.motif
        allfonts.CharacterSubsetName
        LogicalFontName.StyleName.CharacterSubsetName

AWT X11 Font Path

The AWT font path properties specify platform directories which should be added to the X11 server font path. The keys have the form:

   awtfontpath.CharacterSubsetName

The values have the form:

AWTFontPathValue:
        Directory
        Directory : AWTFontPathValue

The directories must be valid X11 font directories. The Java runtime ensures that the directories for all character subsets of a primary search sequence found by the search sequence lookup are part of the X11 font path. The implementation assumes that all logical fonts use the same set of character subsets for a given environment of encoding, language, and country.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


The For-Each Loop

Iterating over a collection is uglier than it needs to be. Consider the following method, which takes a collection of timer tasks and cancels them:
void cancelAll(Collection<TimerTask> c) {
    for (Iterator<TimerTask> i = c.iterator(); i.hasNext(); )
        i.next().cancel();
}

The iterator is just clutter. Furthermore, it is an opportunity for error. The iterator variable occurs three times in each loop: that is two chances to get it wrong. The for-each construct gets rid of the clutter and the opportunity for error. Here is how the example looks with the for-each construct:

void cancelAll(Collection<TimerTask> c) {
    for (TimerTask t : c)
        t.cancel();
}

When you see the colon (:) read it as "in." The loop above reads as "for each TimerTask t in c." As you can see, the for-each construct combines beautifully with generics. It preserves all of the type safety, while removing the remaining clutter. Because you don't have to declare the iterator, you don't have to provide a generic declaration for it. (The compiler does this for you behind your back, but you need not concern yourself with it.)

Here is a common mistake people make when they are trying to do nested iteration over two collections:

List suits = ...;
List ranks = ...;
List sortedDeck = new ArrayList();

// BROKEN - throws NoSuchElementException!
for (Iterator i = suits.iterator(); i.hasNext(); )
    for (Iterator j = ranks.iterator(); j.hasNext(); )
        sortedDeck.add(new Card(i.next(), j.next()));

Can you spot the bug? Don't feel bad if you can't. Many expert programmers have made this mistake at one time or another. The problem is that the next method is being called too many times on the "outer" collection (suits). It is being called in the inner loop for both the outer and inner collections, which is wrong. In order to fix it, you have to add a variable in the scope of the outer loop to hold the suit:

// Fixed, though a bit ugly
for (Iterator i = suits.iterator(); i.hasNext(); ) {
    Suit suit = (Suit) i.next();
    for (Iterator j = ranks.iterator(); j.hasNext(); )
        sortedDeck.add(new Card(suit, j.next()));
}

So what does all this have to do with the for-each construct? It is tailor-made for nested iteration! Feast your eyes:

for (Suit suit : suits)
    for (Rank rank : ranks)
        sortedDeck.add(new Card(suit, rank));

The for-each construct is also applicable to arrays, where it hides the index variable rather than the iterator. The following method returns the sum of the values in an int array:

>// Returns the sum of the elements of a>
int sum(int[] a) {
    int result = 0;
    for (int i : a)
        result += i;
    return result;
}

So when should you use the for-each loop? Any time you can. It really beautifies your code. Unfortunately, you cannot use it everywhere. Consider, for example, the expurgate method. The program needs access to the iterator in order to remove the current element. The for-each loop hides the iterator, so you cannot call remove. Therefore, the for-each loop is not usable for filtering. Similarly it is not usable for loops where you need to replace elements in a list or array as you traverse it. Finally, it is not usable for loops that must iterate over multiple collections in parallel. These shortcomings were known by the designers, who made a conscious decision to go with a clean, simple construct that would cover the great majority of cases.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.ForLoopTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ForLoopTree

  • Packages that use ForLoopTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ForLoopTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type ForLoopTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitForLoop(ForLoopTree node, P p)

    • Uses of ForLoopTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ForLoopTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitForLoop(ForLoopTree node, P p)
      R | TreeScanner.visitForLoop(ForLoopTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Formatted Text Fields

This document outlines the Swing implementation of formatted text fields. Formatted text fields provide a way for developers to specify the legal set of characters that can be input into a text component. This document is arranged in the following sections:

  • Using JFormattedTextField
  • How JFormattedTextField Works
  • Filtering Input
  • Filtering Navigation
  • JFormattedTextField.AbstractFormatter
  • JFormattedTextField.AbstractFormatterFactory
  • DefaultFormatter
  • AbstractFormatter implementations
  • java.text.Format changes
  • JavaDoc

Using JFormattedTextField

JFormattedTextField will allow formatting of dates, numbers, Strings and arbitrary Objects. JFormattedTextField will rely on the java.text.Format classes to handle formatting of dates and numbers. To create a JFormattedTextField to input dates in the current locale-specific format:

    new JFormattedTextField(new Date());

If you need to display the dates in a specific format, you can use one of the SimpleDateFormat constructors:

    new JFormattedTextField(new SimpleDateFormat("MM/dd/yy"));

Numbers will be handled by an instance of java.text.NumberFormat. The following shows several ways to create a JFormattedTextField to edit numbers.

   new JFormattedTextField(new Number(1000));
   new JFormattedTextField(new DecimalFormat("#,###"));
   new JFormattedTextField(new DecimalFormat("0.###E0"));

JFormattedTextField will also support editing of strings given a mask that specifies what the legal characters are at a given character position. To create a JFormattedTextField to edit US phone numbers the following could be used:

   new JFormattedTextField(new MaskFormatter("(###) ###-####"));

How JFormattedTextField Works

JFormattedTextField itself exposes a minimal amount of API in addition to that of its super class, JTextField. In its simplest terms, JFormattedTextField can be thought of as a JTextField with an additional value property (of type Object) and an object to handle the formatting (instance of AbstractFormatter).

As the value property is of type Object, it is necessary for the developer to cast the return type based on how the JFormattedTextField has been configured. The following shows a typical scenario of using a JFormattedTextField with dates:

  JFormattedTextField ftf = new JFormattedTextField();
  ftf.setValue(new Date());
  ...
  Date date = (Date)ftf.getValue();

A typical session for editing numbers looks like:

  JFormattedTextField ftf = new JFormattedTextField();
  ftf.setValue(new Integer(1000));
  ...
  int intValue = ((Number)ftf.getValue()).intValue();

Filtering Input

Constraining the input into a text component previously required creating a subclass of Document. This is a rather heavy operation for such a simple, and common, usage. To make this task easier, we have created a class, DocumentFilter, that can be plugged into a Document (Document is an interface, which has not changed, instead AbstractDocument now has a setter/getter for a DocumentFilter, and a property is set for Documents that do not descend from AbstractDocument so that others can support DocumentFilter should they want to). When a Document with a DocumentFilter is messaged to remove or insert content, the Document invokes the corresponding method on the DocumentFilter. It is the DocumentFilter's responsibility to issue a callback if the operation should proceed. In this manner the DocumentFilter has total control over how the Document can be mutated. DocumentFilter is defined by:

  public void remove(FilterBypass fb, int offset, int length) throws BadLocationException;
  public void insertString(FilterBypass fb, int offset, String string, AttributeSet attr) throws BadLocationException;
  public void replace(FilterBypass fb, int offset, int length, String string, AttributeSet attr) throws BadLocationException;

If the DocumentFilter wants to mutate the Document from inside the remove or insertString methods, it should either invoke super's implementation, or invoke the method on the FilterBypass. Invoking the method on super or FilterBypass provides a way to circumvent the filter so that the caller doesn't get stuck in stack recursion. The DocumentFilter is not limited to only invoking one method back on the FilterBypass. It can invoke any of the methods exposed by FilterBypass, and can invoke them as many times as it wishes (within the scope of one of DocumentFilter's methods). FilterBypass is defined by:

  public abstract Document getDocument();
  public abstract void remove(int offset, int length) throws BadLocationException;
  public abstract void insertString(int offset, String string, AttributeSet attr) throws BadLocationException;
  public abstract void replace(int offset, int length, String string, AttributeSet attr) throws BadLocationException;

The following example illustrates creating a DocumentFilter that maps lower case to upper case letters:

   DocumentFilter upperDF = new DocumentFilter() {
      public void insertString(FilterBypass fb, int offset, String string, AttributeSet attr) throws BadLocationException {
          super.insertString(fb, offset, string.toUpperCase(), attr);
      }

      public void replace(FilterBypass fb, int offset, int length, String string, AttributeSet attr) throws BadLocationException {
          if (string != null) {
              string = text.toUpperCase();
          }
          super.replace(fb, offset, length, string, attr);
      }
   };

Filtering Navigation

Similar to DocumentFilter, a new class, NavigationFilter, allows for filtering where the selection can be placed. NavigationFilter is called by the navigation actions (such as left, right, center) to determine the next position to place the selection from a given position. NavigationFilter is a property on JTextComponent, and is defined by:

    public void setDot(FilterBypass fb, int dot, Position.Bias bias);
    public void moveDot(FilterBypass fb, int dot, Position.Bias bias);
    public int getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) throws BadLocationException;

Note that getNextVisualPositionFrom is defined in View; for consistency, the method in NavigationFilter is named the same.

Similar to DocumentFilter, NavigationFilter is passed a FilterBypass that should be invoked to handle the actual mutation. NavigationFilter.FilterBypass is defined by:

    public abstract Caret getCaret();
    public abstract void setDot(int dot, Position.Bias bias);
    public abstract void moveDot(int dot, Position.Bias bias);

JFormattedTextField.AbstractFormatter

As previously mentioned, an instance of AbstractFormatter is used to format a particular Object value. AbstractFormatter can also impose an editing policy by defining a DocumentFilter; it can also impose a navigation policy by defining a NavigationFilter. AbstractFormatter is defined by:

    public void install(JFormattedTextField ftf);
    public void uninstall();
    public abstract Object stringToValue(String text) throws ParseException;
    public abstract String valueToString(Object value) throws ParseException;
    protected JFormattedTextField getFormattedTextField();
    protected void setEditValid(boolean valid);
    protected void invalidEdit();
    protected Action[] getActions();
    protected DocumentFilter getDocumentFilter();
    protected NavigationFilter getNavigationFilter();

Once JFormattedTextField is ready to use an AbstractFormatter it invokes install. AbstractFormatter.install performs the following:

  1. Sets the text of the JFormattedTextField to the return value of valueToString (if a ParseException is thrown, an empty String is used and setEditValid(false) is invoked).
  2. Installs the DocumentFilter returned from getDocumentFilter onto the JFormattedTextField's Document.
  3. Installs the NavigationFilter returned from getNavigationFilter onto the JFormattedTextField.
  4. Installs the Actions returned from getActions onto the JFormattedTextField's ActionMap.

Subclasses will typically only override install if they need to install additional Listeners beyond the DocumentFilter and NavigationFilter, or perhaps place the caret at an initial location.

Some AbstractFormatters allow the JFormattedTextField to contain an invalid value when editing. To allow the JFormattedTextField to provide an indication of this, the AbstractFormatter should invoke setEditValid(false) when the user enters an invalid value, and then invoke setEditValid(true) when the value is valid again.

When JFormattedTextField is done with an AbstractFormatter, it invokes uninstall. uninstall removes the previously installed Listeners.

JFormattedTextField.AbstractFormatterFactory

JFormattedTextField delegates the creation of AbstractFormatters to an instance of AbstractFormatterFactory (a public static inner class of JFormattedTextField). This makes it easy for developers to provide different formatters for different states of the JFormattedTextField. For example, you could provide a special AbstractFormatter if the current value is null, or one formatter when editing and another when displaying. AbstractFormatterFactory is defined by:

    public abstract AbstractFormatter getFormatter(JFormattedTextField ftf);

If the developer has not supplied an AbstractFormatterFactory, one will be created based on the Class of the value.

DefaultFormatter

DefaultFormatter extends JFormattedTextField.AbstractFormatter and is the superclass for all of the formatter implementations we provide. DefaultFormatter formats Objects using toString and creates the Object using the constructor that takes a String. DefaultFormatter allows a number of configuration options:

Option | Description
CommitsOnValidEdit | Determines when edits are published back to the JFormattedTextField. If true, commitEdit is invoked on the JFormattedTextField after every successful edit, otherwise commitEdit is invoked only when return is pressed.
OverwriteMode | Configures the behavior when inserting characters. If overwriteMode is true (the default), new characters overwrite existing characters in the model as they are inserted.
AllowsInvalid | Determines whether the value being edited is allowed to be invalid. It is often convenient to allow the user to enter invalid values until a commit is attempted.

AbstractFormatter implementations

The following table lists the AbstractFormatter implementations that we provide, as well as intended use:

AbstractFormatter | Object Type | Notes
DefaultFormatter | Object | valueToString uses Object.toString(), and stringToValue uses the single argument constructor that takes a String.
MaskFormatter | Strings | Behavior is dictated by a per character mask that specifies legal values (e.g. "###-####").
InternationalFormatter | Objects | Uses an instance of java.text.Format to handle valueToString and stringToValue.
NumberFormatter | Numbers | Uses an instance of NumberFormat to handle formatting, descends from InternationalFormatter.
DateFormatter | Date | Uses an instance of DateFormat to handle formatting, descends from InternationalFormatter.

java.text.Format changes

The Swing support for formatted dates and numbers made extensive use of the Format classes in the java.text package. The following problems were encountered using the previous API:

  • You could only get the limits of one field at a time. If you wanted more, you had to invoke format repeatedly.
  • The previous field constants were not sufficient to describe the entire text of the formatted strings. One glaring omission was the exponential part of formatted numbers.
  • Using integer IDs for a set of constants that pretended to be extensible wasn't very elegant. When new constants were added, there could potentially be a conflict with any Format subclasses out there that we didn't know about. Note that the constants for DateFormat and NumberFormat already overlap, so a NumberFormat would have happily interpreted YEAR_FIELD as FRACTION_FIELD. The problem was exacerbated by the existence of the polymorphic Format.format(Object, StringBuffer, FieldPosition) method.
  • The specification didn't define the behavior if a field didn't exist in a formatted string, and the actual results varied between different releases.
  • The specification didn't define the behavior if a field wasn't recognized by a formatter; for example, if I asked a NumberFormat for the MONTH_FIELD (the actual implementation of this case returned 0 for both begin index and end index).
  • Because of that, a caller could not find out which fields a Format subclass actually supported unless it knew the specific subclass. This, along with the fact that not all characters in a formatted string are part of fields, makes the implementation of a generic method that returns all fields impossible.

These issues have largely been addressed by adding the following method to java.text.Format:

    public AttributedCharacterIterator formatToCharacterIterator(Object obj);

Each Format class uses a type safe enumeration for the constants it supports.

JavaDoc

New Classes

The following classes are new to the 1.4 release:

  • JFormattedTextField
  • DocumentFilter
  • NavigationFilter
  • JFormattedTextField.AbstractFormatter
  • JFormattedTextField.AbstractFormatterFactory
  • DefaultFormatterFactory
  • DefaultFormatter
  • MaskFormatter
  • InternationalFormatter
  • Number Formatter
  • DateFormatter

Constants are renamed to conform to Java naming conventions

The bugtraq report that corresponds to this change is: 4468474.

The following constants have been replaced to conform Java to naming conventions:

  • CommitValueOnFocusLost has been replaced with COMMIT.
  • CommitOrRevertValueOnFocusLost has been replaced with COMMIT_OR_REVERT.
  • RevertValueOnFocusLost has been replaced with REVERT.
  • PersistValueOnFocusLost has been replaced with PERSIST.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JNI Functions

Documentation Contents
Contents | Previous | Next

Chapter 4: JNI Functions

This chapter serves as the reference section for the JNI functions. It provides a complete listing of all the JNI functions. It also presents the exact layout of the JNI function table.

Note the use of the term “must” to describe restrictions on JNI programmers. For example, when you see that a certain JNI function must receive a non-NULL object, it is your responsibility to ensure that NULL is not passed to that JNI function. As a result, a JNI implementation does not need to perform NULL pointer checks in that JNI function.

A portion of this chapter is adapted from Netscape’s JRI documentation.

The reference material groups functions by their usage. The reference section is organized by the following functional areas:

  • Interface Function Table
  • Version Information
    • GetVersion
    • Constants
  • Class Operations
    • DefineClass
    • FindClass
    • GetSuperclass
    • IsAssignableFrom
  • Exceptions
    • Throw
    • ThrowNew
    • ExceptionOccurred
    • ExceptionDescribe
    • ExceptionClear
    • FatalError
    • ExceptionCheck
  • Global and Local References
    • Global References
    • NewGlobalRef
    • DeleteGlobalRef
    • Local References
    • DeleteLocalRef
    • EnsureLocalCapacity
    • PushLocalFrame
    • PopLocalFrame
    • NewLocalRef
  • Weak Global References
    • NewWeakGlobalRef
    • DeleteWeakGlobalRef
  • Object Operations
    • AllocObject
    • NewObject, NewObjectA, NewObjectV
    • GetObjectClass
    • GetObjectRefType
    • IsInstanceOf
    • IsSameObject
  • Accessing Fields of Objects
    • GetFieldID
    • Get<type>Field Routines
    • Set<type>Field Routines
  • Calling Instance Methods
    • GetMethodID
    • Call<type>Method Routines, Call<type>MethodA Routines, Call<type>MethodV Routines
    • CallNonvirtual<type>Method Routines, CallNonvirtual<type>MethodA Routines, CallNonvirtual<type>MethodV Routines
  • Accessing Static Fields
    • GetStaticFieldID
    • GetStatic<type>Field Routines
    • SetStatic<type>Field Routines
  • Calling Static Methods
    • GetStaticMethodID
    • CallStatic<type>Method Routines, CallStatic<type>MethodA Routines, CallStatic<type>MethodV Routines
  • String Operations
    • NewString
    • GetStringLength
    • GetStringChars
    • ReleaseStringChars
    • NewStringUTF
    • GetStringUTFLength
    • GetStringUTFChars
    • ReleaseStringUTFChars
    • GetStringRegion
    • GetStringUTFRegion
    • GetStringCritical, ReleaseStringCritical
  • Array Operations
    • GetArrayLength
    • NewObjectArray
    • GetObjectArrayElement
    • SetObjectArrayElement
    • New<PrimitiveType>Array Routines
    • Get<PrimitiveType>ArrayElements Routines
    • Release<PrimitiveType>ArrayElements Routines
    • Get<PrimitiveType>ArrayRegion Routines
    • Set<PrimitiveType>ArrayRegion Routines
    • GetPrimitiveArrayCritical, ReleasePrimitiveArrayCritical
  • Registering Native Methods
    • RegisterNatives
    • UnregisterNatives
  • Monitor Operations
    • MonitorEnter
    • MonitorExit
  • NIO Support
    • NewDirectByteBuffer
    • GetDirectBufferAddress
    • GetDirectBufferCapacity
  • Reflection Support
    • FromReflectedMethod
    • FromReflectedField
    • ToReflectedMethod
    • ToReflectedField
  • Java VM Interface
    • GetJavaVM

Interface Function Table

Each function is accessible at a fixed offset through the JNIEnv argument. The JNIEnv type is a pointer to a structure storing all JNI function pointers. It is defined as follows:

typedef const struct JNINativeInterface *JNIEnv;

The VM initializes the function table, as shown by the following code example. Note that the first three entries are reserved for future compatibility with COM. In addition, we reserve a number of additional NULL entries near the beginning of the function table, so that, for example, a future class-related JNI operation can be added after FindClass, rather than at the end of the table.

Note that the function table can be shared among all JNI interface pointers.

const struct JNINativeInterface ... = {

    NULL,
    NULL,
    NULL,
    NULL,
    GetVersion,

    DefineClass,
    FindClass,

    FromReflectedMethod,
    FromReflectedField,
    ToReflectedMethod,

    GetSuperclass,
    IsAssignableFrom,

    ToReflectedField,

    Throw,
    ThrowNew,
    ExceptionOccurred,
    ExceptionDescribe,
    ExceptionClear,
    FatalError,

    PushLocalFrame,
    PopLocalFrame,

    NewGlobalRef,
    DeleteGlobalRef,
    DeleteLocalRef,
    IsSameObject,
    NewLocalRef,
    EnsureLocalCapacity,

    AllocObject,
    NewObject,
    NewObjectV,
    NewObjectA,

    GetObjectClass,
    IsInstanceOf,

    GetMethodID,

    CallObjectMethod,
    CallObjectMethodV,
    CallObjectMethodA,
    CallBooleanMethod,
    CallBooleanMethodV,
    CallBooleanMethodA,
    CallByteMethod,
    CallByteMethodV,
    CallByteMethodA,
    CallCharMethod,
    CallCharMethodV,
    CallCharMethodA,
    CallShortMethod,
    CallShortMethodV,
    CallShortMethodA,
    CallIntMethod,
    CallIntMethodV,
    CallIntMethodA,
    CallLongMethod,
    CallLongMethodV,
    CallLongMethodA,
    CallFloatMethod,
    CallFloatMethodV,
    CallFloatMethodA,
    CallDoubleMethod,
    CallDoubleMethodV,
    CallDoubleMethodA,
    CallVoidMethod,
    CallVoidMethodV,
    CallVoidMethodA,

    CallNonvirtualObjectMethod,
    CallNonvirtualObjectMethodV,
    CallNonvirtualObjectMethodA,
    CallNonvirtualBooleanMethod,
    CallNonvirtualBooleanMethodV,
    CallNonvirtualBooleanMethodA,
    CallNonvirtualByteMethod,
    CallNonvirtualByteMethodV,
    CallNonvirtualByteMethodA,
    CallNonvirtualCharMethod,
    CallNonvirtualCharMethodV,
    CallNonvirtualCharMethodA,
    CallNonvirtualShortMethod,
    CallNonvirtualShortMethodV,
    CallNonvirtualShortMethodA,
    CallNonvirtualIntMethod,
    CallNonvirtualIntMethodV,
    CallNonvirtualIntMethodA,
    CallNonvirtualLongMethod,
    CallNonvirtualLongMethodV,
    CallNonvirtualLongMethodA,
    CallNonvirtualFloatMethod,
    CallNonvirtualFloatMethodV,
    CallNonvirtualFloatMethodA,
    CallNonvirtualDoubleMethod,
    CallNonvirtualDoubleMethodV,
    CallNonvirtualDoubleMethodA,
    CallNonvirtualVoidMethod,
    CallNonvirtualVoidMethodV,
    CallNonvirtualVoidMethodA,

    GetFieldID,

    GetObjectField,
    GetBooleanField,
    GetByteField,
    GetCharField,
    GetShortField,
    GetIntField,
    GetLongField,
    GetFloatField,
    GetDoubleField,
    SetObjectField,
    SetBooleanField,
    SetByteField,
    SetCharField,
    SetShortField,
    SetIntField,
    SetLongField,
    SetFloatField,
    SetDoubleField,

    GetStaticMethodID,

    CallStaticObjectMethod,
    CallStaticObjectMethodV,
    CallStaticObjectMethodA,
    CallStaticBooleanMethod,
    CallStaticBooleanMethodV,
    CallStaticBooleanMethodA,
    CallStaticByteMethod,
    CallStaticByteMethodV,
    CallStaticByteMethodA,
    CallStaticCharMethod,
    CallStaticCharMethodV,
    CallStaticCharMethodA,
    CallStaticShortMethod,
    CallStaticShortMethodV,
    CallStaticShortMethodA,
    CallStaticIntMethod,
    CallStaticIntMethodV,
    CallStaticIntMethodA,
    CallStaticLongMethod,
    CallStaticLongMethodV,
    CallStaticLongMethodA,
    CallStaticFloatMethod,
    CallStaticFloatMethodV,
    CallStaticFloatMethodA,
    CallStaticDoubleMethod,
    CallStaticDoubleMethodV,
    CallStaticDoubleMethodA,
    CallStaticVoidMethod,
    CallStaticVoidMethodV,
    CallStaticVoidMethodA,

    GetStaticFieldID,

    GetStaticObjectField,
    GetStaticBooleanField,
    GetStaticByteField,
    GetStaticCharField,
    GetStaticShortField,
    GetStaticIntField,
    GetStaticLongField,
    GetStaticFloatField,
    GetStaticDoubleField,

    SetStaticObjectField,
    SetStaticBooleanField,
    SetStaticByteField,
    SetStaticCharField,
    SetStaticShortField,
    SetStaticIntField,
    SetStaticLongField,
    SetStaticFloatField,
    SetStaticDoubleField,

    NewString,

    GetStringLength,
    GetStringChars,
    ReleaseStringChars,

    NewStringUTF,
    GetStringUTFLength,
    GetStringUTFChars,
    ReleaseStringUTFChars,

    GetArrayLength,

    NewObjectArray,
    GetObjectArrayElement,
    SetObjectArrayElement,

    NewBooleanArray,
    NewByteArray,
    NewCharArray,
    NewShortArray,
    NewIntArray,
    NewLongArray,
    NewFloatArray,
    NewDoubleArray,

    GetBooleanArrayElements,
    GetByteArrayElements,
    GetCharArrayElements,
    GetShortArrayElements,
    GetIntArrayElements,
    GetLongArrayElements,
    GetFloatArrayElements,
    GetDoubleArrayElements,

    ReleaseBooleanArrayElements,
    ReleaseByteArrayElements,
    ReleaseCharArrayElements,
    ReleaseShortArrayElements,
    ReleaseIntArrayElements,
    ReleaseLongArrayElements,
    ReleaseFloatArrayElements,
    ReleaseDoubleArrayElements,

    GetBooleanArrayRegion,
    GetByteArrayRegion,
    GetCharArrayRegion,
    GetShortArrayRegion,
    GetIntArrayRegion,
    GetLongArrayRegion,
    GetFloatArrayRegion,
    GetDoubleArrayRegion,
    SetBooleanArrayRegion,
    SetByteArrayRegion,
    SetCharArrayRegion,
    SetShortArrayRegion,
    SetIntArrayRegion,
    SetLongArrayRegion,
    SetFloatArrayRegion,
    SetDoubleArrayRegion,

    RegisterNatives,
    UnregisterNatives,

    MonitorEnter,
    MonitorExit,

    GetJavaVM,

    GetStringRegion,
    GetStringUTFRegion,

    GetPrimitiveArrayCritical,
    ReleasePrimitiveArrayCritical,

    GetStringCritical,
    ReleaseStringCritical,

    NewWeakGlobalRef,
    DeleteWeakGlobalRef,

    ExceptionCheck,

    NewDirectByteBuffer,
    GetDirectBufferAddress,
    GetDirectBufferCapacity,

    GetObjectRefType
  };

Version Information

GetVersion

jint GetVersion(JNIEnv *env);

Returns the version of the native method interface.

LINKAGE:

Index 4 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

RETURNS:

Returns the major version number in the higher 16 bits and the minor version number in the lower 16 bits.

In JDK/JRE 1.1, GetVersion() returns 0x00010001.

In JDK/JRE 1.2, GetVersion() returns 0x00010002.

In JDK/JRE 1.4, GetVersion() returns 0x00010004.

In JDK/JRE 1.6, GetVersion() returns 0x00010006.

Constants

SINCE JDK/JRE 1.2:

#define JNI_VERSION_1_1 0x00010001
#define JNI_VERSION_1_2 0x00010002

/* Error codes */
#define JNI_EDETACHED    (-2)              /* thread detached from the VM */
#define JNI_EVERSION     (-3)              /* JNI version error

SINCE JDK/JRE 1.4:

    #define JNI_VERSION_1_4 0x00010004

SINCE JDK/JRE 1.6:

    #define JNI_VERSION_1_6 0x00010006

Class Operations

DefineClass

jclass DefineClass(JNIEnv *env, const char *name, jobject loader,
const jbyte *buf, jsize bufLen);

Loads a class from a buffer of raw class data. The buffer containing the raw class data is not referenced by the VM after the DefineClass call returns, and it may be discarded if desired.

LINKAGE:

Index 5 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

name: the name of the class or interface to be defined. The string is encoded in modified UTF-8.

loader: a class loader assigned to the defined class.

buf: buffer containing the .class file data.

bufLen: buffer length.

RETURNS:

Returns a Java class object or NULL if an error occurs.

THROWS:

ClassFormatError: if the class data does not specify a valid class.

ClassCircularityError: if a class or interface would be its own superclass or superinterface.

OutOfMemoryError: if the system runs out of memory.

SecurityException: if the caller attempts to define a class in the "java" package tree.

FindClass

jclass FindClass(JNIEnv *env, const char *name);

In JDK release 1.1, this function loads a locally-defined class. It searches the directories and zip files specified by the CLASSPATH environment variable for the class with the specified name.

Since Java 2 SDK release 1.2, the Java security model allows non-system classes to load and call native methods. FindClass locates the class loader associated with the current native method; that is, the class loader of the class that declared the native method. If the native method belongs to a system class, no class loader will be involved. Otherwise, the proper class loader will be invoked to load and link the named class.

Since Java 2 SDK release 1.2, when FindClass is called through the Invocation Interface, there is no current native method or its associated class loader. In that case, the result of ClassLoader.getSystemClassLoader is used. This is the class loader the virtual machine creates for applications, and is able to locate classes listed in the java.class.path property.

The name argument is a fully-qualified class name or an array type signature . For example, the fully-qualified class name for the java.lang.String class is:

                   "java/lang/String"

The array type signature of the array class java.lang.Object[] is:

                   "[Ljava/lang/Object;"

LINKAGE:

Index 6 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

name: a fully-qualified class name (that is, a package name, delimited by “/”, followed by the class name). If the name begins with “[“ (the array signature character), it returns an array class. The string is encoded in modified UTF-8.

RETURNS:

Returns a class object from a fully-qualified name, or NULL if the class cannot be found.

THROWS:

ClassFormatError: if the class data does not specify a valid class.

ClassCircularityError: if a class or interface would be its own superclass or superinterface.

NoClassDefFoundError: if no definition for a requested class or interface can be found.

OutOfMemoryError: if the system runs out of memory.

GetSuperclass

jclass GetSuperclass(JNIEnv *env, jclass clazz);

If clazz represents any class other than the class Object, then this function returns the object that represents the superclass of the class specified by clazz.

If clazz specifies the class Object, or clazz represents an interface, this function returns NULL.

LINKAGE:

Index 10 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

RETURNS:

Returns the superclass of the class represented by clazz, or NULL.

IsAssignableFrom

jboolean IsAssignableFrom(JNIEnv *env, jclass clazz1,
jclass clazz2);

Determines whether an object of clazz1 can be safely cast to clazz2.

LINKAGE:

Index 11 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz1: the first class argument.

clazz2: the second class argument.

RETURNS:

Returns JNI_TRUE if either of the following is true:

  • The first and second class arguments refer to the same Java class.
  • The first class is a subclass of the second class.
  • The first class has the second class as one of its interfaces.

Exceptions

Throw

jint Throw(JNIEnv *env, jthrowable obj);

Causes a java.lang.Throwable object to be thrown.

LINKAGE:

Index 13 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a java.lang.Throwable object.

RETURNS:

Returns 0 on success; a negative value on failure.

THROWS:

the java.lang.Throwable object obj.

ThrowNew

jint ThrowNew(JNIEnv *env, jclass clazz,
const char *message);

Constructs an exception object from the specified class with the message specified by message and causes that exception to be thrown.

LINKAGE:

Index 14 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a subclass of java.lang.Throwable.

message: the message used to construct the java.lang.Throwable object. The string is encoded in modified UTF-8.

RETURNS:

Returns 0 on success; a negative value on failure.

THROWS:

the newly constructed java.lang.Throwable object.

ExceptionOccurred

jthrowable ExceptionOccurred(JNIEnv *env);

Determines if an exception is being thrown. The exception stays being thrown until either the native code calls ExceptionClear(), or the Java code handles the exception.

LINKAGE:

Index 15 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

RETURNS:

Returns the exception object that is currently in the process of being thrown, or NULL if no exception is currently being thrown.

ExceptionDescribe

void ExceptionDescribe(JNIEnv *env);

Prints an exception and a backtrace of the stack to a system error-reporting channel, such as stderr. This is a convenience routine provided for debugging.

LINKAGE:

Index 16 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

ExceptionClear

void ExceptionClear(JNIEnv *env);

Clears any exception that is currently being thrown. If no exception is currently being thrown, this routine has no effect.

LINKAGE:

Index 17 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

FatalError

void FatalError(JNIEnv *env, const char *msg);

Raises a fatal error and does not expect the VM to recover. This function does not return.

LINKAGE:

Index 18 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

msg: an error message. The string is encoded in modified UTF-8.

ExceptionCheck

We introduce a convenience function to check for pending exceptions without creating a local reference to the exception object.

jboolean ExceptionCheck(JNIEnv *env);

Returns JNI_TRUE when there is a pending exception; otherwise, returns JNI_FALSE.

LINKAGE:

Index 228 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

Global and Local References

Global References

NewGlobalRef

jobject NewGlobalRef(JNIEnv *env, jobject obj);

Creates a new global reference to the object referred to by the obj argument. The obj argument may be a global or local reference. Global references must be explicitly disposed of by calling DeleteGlobalRef().

LINKAGE:

Index 21 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a global or local reference.

RETURNS:

Returns a global reference, or NULL if the system runs out of memory.

DeleteGlobalRef

void DeleteGlobalRef(JNIEnv *env, jobject globalRef);

Deletes the global reference pointed to by globalRef.

LINKAGE:

Index 22 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

globalRef: a global reference.

Local References

Local references are valid for the duration of a native method call. They are freed automatically after the native method returns. Each local reference costs some amount of Java Virtual Machine resource. Programmers need to make sure that native methods do not excessively allocate local references. Although local references are automatically freed after the native method returns to Java, excessive allocation of local references may cause the VM to run out of memory during the execution of a native method.

DeleteLocalRef

void DeleteLocalRef(JNIEnv *env, jobject localRef);

Deletes the local reference pointed to by localRef.

LINKAGE:

Index 23 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

localRef: a local reference.

Note: JDK/JRE 1.1 provides the DeleteLocalRef function above so that programmers can manually delete local references. For example, if native code iterates through a potentially large array of objects and uses one element in each iteration, it is a good practice to delete the local reference to the no-longer-used array element before a new local reference is created in the next iteration.

As of JDK/JRE 1.2 an additional set of functions are provided for local reference lifetime management. They are the four functions listed below.

EnsureLocalCapacity

jint EnsureLocalCapacity(JNIEnv *env, jint capacity);

Ensures that at least a given number of local references can be created in the current thread. Returns 0 on success; otherwise returns a negative number and throws an OutOfMemoryError.

Before it enters a native method, the VM automatically ensures that at least 16 local references can be created.

For backward compatibility, the VM allocates local references beyond the ensured capacity. (As a debugging support, the VM may give the user warnings that too many local references are being created. In the JDK, the programmer can supply the -verbose:jni command line option to turn on these messages.) The VM calls FatalError if no more local references can be created beyond the ensured capacity.

LINKAGE:

Index 26 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

PushLocalFrame

jint PushLocalFrame(JNIEnv *env, jint capacity);

Creates a new local reference frame, in which at least a given number of local references can be created. Returns 0 on success, a negative number and a pending OutOfMemoryError on failure.

Note that local references already created in previous local frames are still valid in the current local frame.

LINKAGE:

Index 19 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

PopLocalFrame

jobject PopLocalFrame(JNIEnv *env, jobject result);

Pops off the current local reference frame, frees all the local references, and returns a local reference in the previous local reference frame for the given result object.

Pass NULL as result if you do not need to return a reference to the previous frame.

LINKAGE:

Index 20 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

NewLocalRef

jobject NewLocalRef(JNIEnv *env, jobject ref);

Creates a new local reference that refers to the same object as ref. The given ref may be a global or local reference. Returns NULL if ref refers to null.

LINKAGE:

Index 25 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

Weak Global References

Weak global references are a special kind of global reference. Unlike normal global references, a weak global reference allows the underlying Java object to be garbage collected. Weak global references may be used in any situation where global or local references are used. When the garbage collector runs, it frees the underlying object if the object is only referred to by weak references. A weak global reference pointing to a freed object is functionally equivalent to NULL. Programmers can detect whether a weak global reference points to a freed object by using IsSameObject to compare the weak reference against NULL.

Weak global references in JNI are a simplified version of the Java Weak References, available as part of the Java 2 Platform API ( java.lang.ref package and its classes).

Clarification (added June 2001)

Since garbage collection may occur while native methods are running, objects referred to by weak global references can be freed at any time. While weak global references can be used where global references are used, it is generally inappropriate to do so, as they may become functionally equivalent to NULL without notice.

While IsSameObject can be used to determine whether a weak global reference refers to a freed object, it does not prevent the object from being freed immediately thereafter. Consequently, programmers may not rely on this check to determine whether a weak global reference may used (as a non-NULL reference) in any future JNI function call.

To overcome this inherent limitation, it is recommended that a standard (strong) local or global reference to the same object be acquired using the JNI functions NewLocalRef or NewGlobalRef, and that this strong reference be used to access the intended object. These functions will return NULL if the object has been freed, and otherwise will return a strong reference (which will prevent the object from being freed). The new reference should be explicitly deleted when immediate access to the object is no longer required, allowing the object to be freed.

The weak global reference is weaker than other types of weak references (Java objects of the SoftReference or WeakReference classes). A weak global reference to a specific object will not become functionally equivalent to NULL until after SoftReference or WeakReference objects referring to that same specific object have had their references cleared.

The weak global reference is weaker than Java's internal references to objects requiring finalization. A weak global reference will not become functionally equivalent to NULL until after the completion of the finalizer for the referenced object, if present.

Interactions between weak global references and PhantomReferences are undefined. In particular, implementations of a Java VM may (or may not) process weak global references after PhantomReferences, and it may (or may not) be possible to use weak global references to hold on to objects which are also referred to by PhantomReference objects. This undefined use of weak global references should be avoided.

NewWeakGlobalRef

jweak NewWeakGlobalRef(JNIEnv *env, jobject obj);

Creates a new weak global reference. Returns NULL if obj refers to null, or if the VM runs out of memory. If the VM runs out of memory, an OutOfMemoryError will be thrown.

LINKAGE:

Index 226 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

DeleteWeakGlobalRef

void DeleteWeakGlobalRef(JNIEnv *env, jweak obj);

Delete the VM resources needed for the given weak global reference.

LINKAGE:

Index 227 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

Object Operations

AllocObject

jobject AllocObject(JNIEnv *env, jclass clazz);

Allocates a new Java object without invoking any of the constructors for the object. Returns a reference to the object.

The clazz argument must not refer to an array class.

LINKAGE:

Index 27 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

RETURNS:

Returns a Java object, or NULL if the object cannot be constructed.

THROWS:

InstantiationException: if the class is an interface or an abstract class.

OutOfMemoryError: if the system runs out of memory.

NewObject, NewObjectA, NewObjectV

jobject NewObject(JNIEnv *env, jclass clazz,
jmethodID methodID, ...);

jobject NewObjectA(JNIEnv *env, jclass clazz,
jmethodID methodID, const jvalue *args);

jobject NewObjectV(JNIEnv *env, jclass clazz,
jmethodID methodID, va_list args);

Constructs a new Java object. The method ID indicates which constructor method to invoke. This ID must be obtained by calling GetMethodID() with <init> as the method name and void (V) as the return type.

The clazz argument must not refer to an array class.

NewObject

Programmers place all arguments that are to be passed to the constructor immediately following the methodID argument. NewObject() accepts these arguments and passes them to the Java method that the programmer wishes to invoke.

LINKAGE:

Index 28 in the JNIEnv interface function table.

NewObjectA

Programmers place all arguments that are to be passed to the constructor in an args array of jvalues that immediately follows the methodID argument. NewObjectA() accepts the arguments in this array, and, in turn, passes them to the Java method that the programmer wishes to invoke.

LINKAGE:

Index 30 in the JNIEnv interface function table.

NewObjectV

Programmers place all arguments that are to be passed to the constructor in an args argument of type va_list that immediately follows the methodID argument. NewObjectV() accepts these arguments, and, in turn, passes them to the Java method that the programmer wishes to invoke.

LINKAGE:

Index 29 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

methodID: the method ID of the constructor.

Additional Parameter for NewObject:

arguments to the constructor.

Additional Parameter for NewObjectA:

args: an array of arguments to the constructor.

Additional Parameter for NewObjectV:

args: a va_list of arguments to the constructor.

RETURNS:

Returns a Java object, or NULL if the object cannot be constructed.

THROWS:

InstantiationException: if the class is an interface or an abstract class.

OutOfMemoryError: if the system runs out of memory.

Any exceptions thrown by the constructor.

GetObjectClass

jclass GetObjectClass(JNIEnv *env, jobject obj);

Returns the class of an object.

LINKAGE:

Index 31 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a Java object (must not be NULL).

RETURNS:

Returns a Java class object.

GetObjectRefType

jobjectRefType GetObjectRefType(JNIEnv* env, jobject obj);

Returns the type of the object referred to by the obj argument. The argument obj can either be a local, global or weak global reference.

LINKAGE:

Index 232 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a local, global or weak global reference.

vm: the virtual machine instance from which the interface will be retrieved.

env: pointer to the location where the JNI interface pointer for the current thread will be placed.

version: the requested JNI version.

RETURNS:

The function GetObjectRefType returns one of the following enumerated values defined as a jobjectRefType:

JNIInvalidRefType = 0,
JNILocalRefType = 1,
JNIGlobalRefType = 2,
JNIWeakGlobalRefType = 3

If the argument obj is a weak global reference type, the return will be JNIWeakGlobalRefType.

If the argument obj is a global reference type, the return value will be JNIGlobalRefType.

If the argument obj is a local reference type, the return will be JNILocalRefType.

If the obj argument is not a valid reference, the return value for this function will be JNIInvalidRefType.

An invalid reference is a reference which is not a valid handle. That is, the obj pointer address does not point to a location in memory which has been allocated from one of the Ref creation functions or returned from a JNI function.

As such, NULL would be an invalid reference and GetObjectRefType(env,NULL) would return JNIInvalidRefType.

On the other hand, a null reference, which is a reference that points to a null, would return the type of reference that the null reference was originally created as.

GetObjectRefType cannot be used on deleted references.

Since references are typically implemented as pointers to memory data structures that can potentially be reused by any of the reference allocation services in the VM, once deleted, it is not specified what value the GetObjectRefType will return.

SINCE:

JDK/JRE 1.6

IsInstanceOf

jboolean IsInstanceOf(JNIEnv *env, jobject obj,
jclass clazz);

Tests whether an object is an instance of a class.

LINKAGE:

Index 32 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a Java object.

clazz: a Java class object.

RETURNS:

Returns JNI_TRUE if obj can be cast to clazz; otherwise, returns JNI_FALSE. A NULL object can be cast to any class.

IsSameObject

jboolean IsSameObject(JNIEnv *env, jobject ref1,
jobject ref2);

Tests whether two references refer to the same Java object.

LINKAGE:

Index 24 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

ref1: a Java object.

ref2: a Java object.

RETURNS:

Returns JNI_TRUE if ref1 and ref2 refer to the same Java object, or are both NULL; otherwise, returns JNI_FALSE.

Accessing Fields of Objects

GetFieldID

jfieldID GetFieldID(JNIEnv *env, jclass clazz,
const char *name, const char *sig);

Returns the field ID for an instance (nonstatic) field of a class. The field is specified by its name and signature. The Get<type>Field and Set<type>Field families of accessor functions use field IDs to retrieve object fields.

GetFieldID() causes an uninitialized class to be initialized.

GetFieldID() cannot be used to obtain the length field of an array. Use GetArrayLength() instead.

LINKAGE:

Index 94 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

name: the field name in a 0-terminated modified UTF-8 string.

sig: the field signature in a 0-terminated modified UTF-8 string.

RETURNS:

Returns a field ID, or NULL if the operation fails.

THROWS:

NoSuchFieldError: if the specified field cannot be found.

ExceptionInInitializerError: if the class initializer fails due to an exception.

OutOfMemoryError: if the system runs out of memory.

Get<type>Field Routines

NativeType Get<type>Field(JNIEnv *env, jobject obj,
jfieldID fieldID);

This family of accessor routines returns the value of an instance (nonstatic) field of an object. The field to access is specified by a field ID obtained by calling GetFieldID().

The following table describes the Get<type>Field routine name and result type. You should replace type in Get<type>Field with the Java type of the field, or use one of the actual routine names from the table, and replace NativeType with the corresponding native type for that routine.

Get<type>Field Family of Accessor Routines
Get<type>Field Routine Name | Native Type
GetObjectField() | jobject
GetBooleanField() | jboolean
GetByteField() | jbyte
GetCharField() | jchar
GetShortField() | jshort
GetIntField() | jint
GetLongField() | jlong
GetFloatField() | jfloat
GetDoubleField() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table:

Get<type>Field Family of Accessor Routines
Get<type>Field Routine Name | Index
GetObjectField() | 95
GetBooleanField() | 96
GetByteField() | 97
GetCharField() | 98
GetShortField() | 99
GetIntField() | 100
GetLongField() | 101
GetFloatField() | 102
GetDoubleField() | 103

PARAMETERS:

env: the JNI interface pointer.

obj: a Java object (must not be NULL).

fieldID: a valid field ID.

RETURNS:

Returns the content of the field.

Set<type>Field Routines

void Set<type>Field(JNIEnv *env, jobject obj, jfieldID fieldID,
 NativeType value);

This family of accessor routines sets the value of an instance (nonstatic) field of an object. The field to access is specified by a field ID obtained by calling GetFieldID().

The following table describes the Set<type>Field routine name and value type. You should replace type in Set<type>Field with the Java type of the field, or use one of the actual routine names from the table, and replace NativeType with the corresponding native type for that routine.

Set<type>Field Family of Accessor Routines
Set<type>Field Routine | Native Type
SetObjectField() | jobject
SetBooleanField() | jboolean
SetByteField() | jbyte
SetCharField() | jchar
SetShortField() | jshort
SetIntField() | jint
SetLongField() | jlong
SetFloatField() | jfloat
SetDoubleField() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

Set<type>Field Family of Accessor Routines
Set<type>Field Routine | Index
SetObjectField() | 104
SetBooleanField() | 105
SetByteField() | 106
SetCharField() | 107
SetShortField() | 108
SetIntField() | 109
SetLongField() | 110
SetFloatField() | 111
SetDoubleField() | 112

PARAMETERS:

env: the JNI interface pointer.

obj: a Java object (must not be NULL).

fieldID: a valid field ID.

value: the new value of the field.

Calling Instance Methods

GetMethodID

jmethodID GetMethodID(JNIEnv *env, jclass clazz,
const char *name, const char *sig);

Returns the method ID for an instance (nonstatic) method of a class or interface. The method may be defined in one of the clazz’s superclasses and inherited by clazz. The method is determined by its name and signature.

GetMethodID() causes an uninitialized class to be initialized.

To obtain the method ID of a constructor, supply <init> as the method name and void (V) as the return type.

LINKAGE:

Index 33 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

name: the method name in a 0-terminated modified UTF-8 string.

sig: the method signature in 0-terminated modified UTF-8 string.

RETURNS:

Returns a method ID, or NULL if the specified method cannot be found.

THROWS:

NoSuchMethodError: if the specified method cannot be found.

ExceptionInInitializerError: if the class initializer fails due to an exception.

OutOfMemoryError: if the system runs out of memory.

Call<type>Method Routines, Call<type>MethodA Routines, Call<type>MethodV Routines

NativeType Call<type>Method(JNIEnv *env, jobject obj,
jmethodID methodID, ...);

NativeType Call<type>MethodA(JNIEnv *env, jobject obj,
jmethodID methodID, const jvalue *args);

NativeType Call<type>MethodV(JNIEnv *env, jobject obj,
jmethodID methodID, va_list args);

Methods from these three families of operations are used to call a Java instance method from a native method.They only differ in their mechanism for passing parameters to the methods that they call.

These families of operations invoke an instance (nonstatic) method on a Java object, according to the specified method ID. The methodID argument must be obtained by calling GetMethodID().

When these functions are used to call private methods and constructors, the method ID must be derived from the real class of obj, not from one of its superclasses.

Call<type>Method Routines

Programmers place all arguments that are to be passed to the method immediately following the methodID argument. The Call<type>Method routine accepts these arguments and passes them to the Java method that the programmer wishes to invoke.

Call<type>MethodA Routines

Programmers place all arguments to the method in an args array of jvalues that immediately follows the methodID argument. The Call<type>MethodA routine accepts the arguments in this array, and, in turn, passes them to the Java method that the programmer wishes to invoke.

Call<type>MethodV Routines

Programmers place all arguments to the method in an args argument of type va_list that immediately follows the methodID argument. The Call<type>MethodV routine accepts the arguments, and, in turn, passes them to the Java method that the programmer wishes to invoke.

The following table describes each of the method calling routines according to their result type. You should replace type in Call<type>Method with the Java type of the method you are calling (or use one of the actual method calling routine names from the table) and replace NativeType with the corresponding native type for that routine.

Instance Method Calling Routines
Call<type>Method Routine Name | Native Type
CallVoidMethod() CallVoidMethodA() CallVoidMethodV() | void
CallObjectMethod() CallObjectMethodA() CallObjectMethodV() | jobject
CallBooleanMethod() CallBooleanMethodA() CallBooleanMethodV() | jboolean
CallByteMethod() CallByteMethodA() CallByteMethodV() | jbyte
CallCharMethod() CallCharMethodA() CallCharMethodV() | jchar
CallShortMethod() CallShortMethodA() CallShortMethodV() | jshort
CallIntMethod() CallIntMethodA() CallIntMethodV() | jint
CallLongMethod() CallLongMethodA() CallLongMethodV() | jlong
CallFloatMethod() CallFloatMethodA() CallFloatMethodV() | jfloat
CallDoubleMethod() CallDoubleMethodA() CallDoubleMethodV() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table:

Instance Method Calling Routines
Call<type>Method Routine Name | Index
CallVoidMethod() CallVoidMethodA() CallVoidMethodV() | 61 63 62
CallObjectMethod() CallObjectMethodA() CallObjectMethodV() | 34 36 35
CallBooleanMethod() CallBooleanMethodA() CallBooleanMethodV() | 37 39 38
CallByteMethod() CallByteMethodA() CallByteMethodV() | 40 42 41
CallCharMethod() CallCharMethodA() CallCharMethodV() | 43 45 44
CallShortMethod() CallShortMethodA() CallShortMethodV() | 46 48 47
CallIntMethod() CallIntMethodA() CallIntMethodV() | 49 51 50
CallLongMethod() CallLongMethodA() CallLongMethodV() | 52 54 53
CallFloatMethod() CallFloatMethodA() CallFloatMethodV() | 55 57 56
CallDoubleMethod() CallDoubleMethodA() CallDoubleMethodV() | 58 60 59

PARAMETERS:

env: the JNI interface pointer.

obj: a Java object.

methodID: a method ID.

Additional Parameter for Call<type>Method Routines:

arguments to the Java method.

Additional Parameter for Call<type>MethodA Routines:

args: an array of arguments.

Additional Parameter for Call<type>MethodV Routines:

args: a va_list of arguments.

RETURNS:

Returns the result of calling the Java method.

THROWS:

Exceptions raised during the execution of the Java method.

CallNonvirtual<type>Method Routines, CallNonvirtual<type>MethodA Routines, CallNonvirtual<type>MethodV Routines

NativeType CallNonvirtual<type>Method(JNIEnv *env, jobject obj,
jclass clazz, jmethodID methodID, ...);

NativeType CallNonvirtual<type>MethodA(JNIEnv *env, jobject obj,
jclass clazz, jmethodID methodID, const jvalue *args);

NativeType CallNonvirtual<type>MethodV(JNIEnv *env, jobject obj,
jclass clazz, jmethodID methodID, va_list args);

These families of operations invoke an instance (nonstatic) method on a Java object, according to the specified class and method ID. The methodID argument must be obtained by calling GetMethodID() on the class clazz.

The CallNonvirtual<type>Method families of routines and the Call<type>Method families of routines are different. Call<type>Method routines invoke the method based on the class of the object, while CallNonvirtual<type>Method routines invoke the method based on the class, designated by the clazz parameter, from which the method ID is obtained. The method ID must be obtained from the real class of the object or from one of its superclasses.

CallNonvirtual<type>Method Routines

Programmers place all arguments that are to be passed to the method immediately following the methodID argument. The CallNonvirtual<type>Method routine accepts these arguments and passes them to the Java method that the programmer wishes to invoke.

CallNonvirtual<type>MethodA Routines

Programmers place all arguments to the method in an args array of jvalues that immediately follows the methodID argument. The CallNonvirtual<type>MethodA routine accepts the arguments in this array, and, in turn, passes them to the Java method that the programmer wishes to invoke.

CallNonvirtual<type>MethodV Routines

Programmers place all arguments to the method in an args argument of type va_list that immediately follows the methodID argument. The CallNonvirtualMethodV routine accepts the arguments, and, in turn, passes them to the Java method that the programmer wishes to invoke.

The following table describes each of the method calling routines according to their result type. You should replace type in CallNonvirtual<type>Method with the Java type of the method, or use one of the actual method calling routine names from the table, and replace NativeType with the corresponding native type for that routine.

CallNonvirtual<type>Method Routines
CallNonvirtual<type>Method Routine Name | Native Type
CallNonvirtualVoidMethod() CallNonvirtualVoidMethodA() CallNonvirtualVoidMethodV() | void
CallNonvirtualObjectMethod() CallNonvirtualObjectMethodA() CallNonvirtualObjectMethodV() | jobject
CallNonvirtualBooleanMethod() CallNonvirtualBooleanMethodA() CallNonvirtualBooleanMethodV() | jboolean
CallNonvirtualByteMethod() CallNonvirtualByteMethodA() CallNonvirtualByteMethodV() | jbyte
CallNonvirtualCharMethod() CallNonvirtualCharMethodA() CallNonvirtualCharMethodV() | jchar
CallNonvirtualShortMethod() CallNonvirtualShortMethodA() CallNonvirtualShortMethodV() | jshort
CallNonvirtualIntMethod() CallNonvirtualIntMethodA() CallNonvirtualIntMethodV() | jint
CallNonvirtualLongMethod() CallNonvirtualLongMethodA() CallNonvirtualLongMethodV() | jlong
CallNonvirtualFloatMethod() CallNonvirtualFloatMethodA() CallNonvirtualFloatMethodV() | jfloat
CallNonvirtualDoubleMethod() CallNonvirtualDoubleMethodA() CallNonvirtualDoubleMethodV() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

CallNonvirtual<type>Method Routines
CallNonvirtual<type>Method Routine Name | Index
CallNonvirtualVoidMethod() CallNonvirtualVoidMethodA() CallNonvirtualVoidMethodV() | 91 93 92
CallNonvirtualObjectMethod() CallNonvirtualObjectMethodA() CallNonvirtualObjectMethodV() | 64 66 65
CallNonvirtualBooleanMethod() CallNonvirtualBooleanMethodA() CallNonvirtualBooleanMethodV() | 67 69 68
CallNonvirtualByteMethod() CallNonvirtualByteMethodA() CallNonvirtualByteMethodV() | 70 72 71
CallNonvirtualCharMethod() CallNonvirtualCharMethodA() CallNonvirtualCharMethodV() | 73 75 74
CallNonvirtualShortMethod() CallNonvirtualShortMethodA() CallNonvirtualShortMethodV() | 76 78 77
CallNonvirtualIntMethod() CallNonvirtualIntMethodA() CallNonvirtualIntMethodV() | 79 81 80
CallNonvirtualLongMethod() CallNonvirtualLongMethodA() CallNonvirtualLongMethodV() | 82 84 83
CallNonvirtualFloatMethod() CallNonvirtualFloatMethodA() CallNonvirtualFloatMethodV() | 85 87 86
CallNonvirtualDoubleMethod() CallNonvirtualDoubleMethodA() CallNonvirtualDoubleMethodV() | 88 90 89

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class.

obj: a Java object.

methodID: a method ID.

Additional Parameter for CallNonvirtual<type>Method Routines:

arguments to the Java method.

Additional Parameter for CallNonvirtual<type>MethodA Routines:

args: an array of arguments.

Additional Parameter for CallNonvirtual<type>MethodV Routines:

args: a va_list of arguments.

RETURNS:

Returns the result of calling the Java method.

THROWS:

Exceptions raised during the execution of the Java method.

Accessing Static Fields

GetStaticFieldID

jfieldID GetStaticFieldID(JNIEnv *env, jclass clazz,
const char *name, const char *sig);

Returns the field ID for a static field of a class. The field is specified by its name and signature. The GetStatic<type>Field and SetStatic<type>Field families of accessor functions use field IDs to retrieve static fields.

GetStaticFieldID() causes an uninitialized class to be initialized.

LINKAGE:

Index 144 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

name: the static field name in a 0-terminated modified UTF-8 string.

sig: the field signature in a 0-terminated modified UTF-8 string.

RETURNS:

Returns a field ID, or NULL if the specified static field cannot be found.

THROWS:

NoSuchFieldError: if the specified static field cannot be found.

ExceptionInInitializerError: if the class initializer fails due to an exception.

OutOfMemoryError: if the system runs out of memory.

GetStatic<type>Field Routines

NativeType GetStatic<type>Field(JNIEnv *env, jclass clazz,
jfieldID fieldID);

This family of accessor routines returns the value of a static field of an object. The field to access is specified by a field ID, which is obtained by calling GetStaticFieldID().

The following table describes the family of get routine names and result types. You should replace type in GetStatic<type>Field with the Java type of the field, or one of the actual static field accessor routine names from the table, and replace NativeType with the corresponding native type for that routine.

GetStatic<type>Field Family of Accessor Routines
GetStatic<type>Field Routine Name | Native Type
GetStaticObjectField() | jobject
GetStaticBooleanField() | jboolean
GetStaticByteField() | jbyte
GetStaticCharField() | jchar
GetStaticShortField() | jshort
GetStaticIntField() | jint
GetStaticLongField() | jlong
GetStaticFloatField() | jfloat
GetStaticDoubleField() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

GetStatic<type>Field Family of Accessor Routines
GetStatic<type>Field Routine Name | Index
GetStaticObjectField() | 145
GetStaticBooleanField() | 146
GetStaticByteField() | 147
GetStaticCharField() | 148
GetStaticShortField() | 149
GetStaticIntField() | 150
GetStaticLongField() | 151
GetStaticFloatField() | 152
GetStaticDoubleField() | 153

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

fieldID: a static field ID.

RETURNS:

Returns the content of the static field.

SetStatic<type>Field Routines

void SetStatic<type>Field(JNIEnv *env, jclass clazz,
jfieldID fieldID, NativeType value);

This family of accessor routines sets the value of a static field of an object. The field to access is specified by a field ID, which is obtained by calling GetStaticFieldID().

The following table describes the set routine name and value types. You should replace type in SetStatic<type>Field with the Java type of the field, or one of the actual set static field routine names from the table, and replace NativeType with the corresponding native type for that routine.

SetStatic<type>Field Family of Accessor Routines
SetStatic<type>Field Routine Name | NativeType
SetStaticObjectField() | jobject
SetStaticBooleanField() | jboolean
SetStaticByteField() | jbyte
SetStaticCharField() | jchar
SetStaticShortField() | jshort
SetStaticIntField() | jint
SetStaticLongField() | jlong
SetStaticFloatField() | jfloat
SetStaticDoubleField() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

SetStatic<type>Field Family of Accessor Routines
SetStatic<type>Field Routine Name | Index
SetStaticObjectField() | 154
SetStaticBooleanField() | 155
SetStaticByteField() | 156
SetStaticCharField() | 157
SetStaticShortField() | 158
SetStaticIntField() | 159
SetStaticLongField() | 160
SetStaticFloatField() | 161
SetStaticDoubleField() | 162

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

fieldID: a static field ID.

value: the new value of the field.

Calling Static Methods

GetStaticMethodID

jmethodID GetStaticMethodID(JNIEnv *env, jclass clazz,
const char *name, const char *sig);

Returns the method ID for a static method of a class. The method is specified by its name and signature.

GetStaticMethodID() causes an uninitialized class to be initialized.

LINKAGE:

Index 113 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

name: the static method name in a 0-terminated modified UTF-8 string.

sig: the method signature in a 0-terminated modified UTF-8 string.

RETURNS:

Returns a method ID, or NULL if the operation fails.

THROWS:

NoSuchMethodError: if the specified static method cannot be found.

ExceptionInInitializerError: if the class initializer fails due to an exception.

OutOfMemoryError: if the system runs out of memory.

CallStatic<type>Method Routines, CallStatic<type>MethodA Routines, CallStatic<type>MethodV Routines

NativeType CallStatic<type>Method(JNIEnv *env, jclass clazz,
jmethodID methodID, ...);

NativeType CallStatic<type>MethodA(JNIEnv *env, jclass clazz,
jmethodID methodID, jvalue *args);

NativeType CallStatic<type>MethodV(JNIEnv *env, jclass clazz,
jmethodID methodID, va_list args);

This family of operations invokes a static method on a Java object, according to the specified method ID. The methodID argument must be obtained by calling GetStaticMethodID().

The method ID must be derived from clazz, not from one of its superclasses.

CallStatic<type>Method Routines

Programmers should place all arguments that are to be passed to the method immediately following the methodID argument. The CallStatic<type>Method routine accepts these arguments and passes them to the Java method that the programmer wishes to invoke.

CallStatic<type>MethodA Routines

Programmers should place all arguments to the method in an args array of jvalues that immediately follows the methodID argument. The CallStaticMethodA routine accepts the arguments in this array, and, in turn, passes them to the Java method that the programmer wishes to invoke.

CallStatic<type>MethodV Routines

Programmers should place all arguments to the method in an args argument of type va_list that immediately follows the methodID argument. The CallStaticMethodV routine accepts the arguments, and, in turn, passes them to the Java method that the programmer wishes to invoke.

The following table describes each of the method calling routines according to their result types. You should replace type in CallStatic<type>Method with the Java type of the method, or one of the actual method calling routine names from the table, and replace NativeType with the corresponding native type for that routine.

CallStatic<type>Method Calling Routines
CallStatic<type>Method Routine Name | Native Type
CallStaticVoidMethod() CallStaticVoidMethodA() CallStaticVoidMethodV() | void
CallStaticObjectMethod() CallStaticObjectMethodA() CallStaticObjectMethodV() | jobject
CallStaticBooleanMethod() CallStaticBooleanMethodA() CallStaticBooleanMethodV() | jboolean
CallStaticByteMethod() CallStaticByteMethodA() CallStaticByteMethodV() | jbyte
CallStaticCharMethod() CallStaticCharMethodA() CallStaticCharMethodV() | jchar
CallStaticShortMethod() CallStaticShortMethodA() CallStaticShortMethodV() | jshort
CallStaticIntMethod() CallStaticIntMethodA() CallStaticIntMethodV() | jint
CallStaticLongMethod() CallStaticLongMethodA() CallStaticLongMethodV() | jlong
CallStaticFloatMethod() CallStaticFloatMethodA() CallStaticFloatMethodV() | jfloat
CallStaticDoubleMethod() CallStaticDoubleMethodA() CallStaticDoubleMethodV() | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

CallStatic<type>Method Calling Routines
CallStatic<type>Method Routine Name | Index
CallStaticVoidMethod() CallStaticVoidMethodA() CallStaticVoidMethodV() | 141 143 142
CallStaticObjectMethod() CallStaticObjectMethodA() CallStaticObjectMethodV() | 114 116 115
CallStaticBooleanMethod() CallStaticBooleanMethodA() CallStaticBooleanMethodV() | 117 119 118
CallStaticByteMethod() CallStaticByteMethodA() CallStaticByteMethodV() | 120 122 121
CallStaticCharMethod() CallStaticCharMethodA() CallStaticCharMethodV() | 123 125 124
CallStaticShortMethod() CallStaticShortMethodA() CallStaticShortMethodV() | 126 128 127
CallStaticIntMethod() CallStaticIntMethodA() CallStaticIntMethodV() | 129 131 130
CallStaticLongMethod() CallStaticLongMethodA() CallStaticLongMethodV() | 132 134 133
CallStaticFloatMethod() CallStaticFloatMethodA() CallStaticFloatMethodV() | 135 137 136
CallStaticDoubleMethod() CallStaticDoubleMethodA() CallStaticDoubleMethodV() | 138 140 139

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

methodID: a static method ID.

Additional Parameter for CallStatic<type>Method Routines:

arguments to the static method.

Additional Parameter for CallStatic<type>MethodA Routines:

args: an array of arguments.

Additional Parameter for CallStatic<type>MethodV Routines:

args: a va_list of arguments.

RETURNS:

Returns the result of calling the static Java method.

THROWS:

Exceptions raised during the execution of the Java method.

String Operations

NewString

jstring NewString(JNIEnv *env, const jchar *unicodeChars,
jsize len);

Constructs a new java.lang.String object from an array of Unicode characters.

LINKAGE:

Index 163 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

unicodeChars: pointer to a Unicode string.

len: length of the Unicode string.

RETURNS:

Returns a Java string object, or NULL if the string cannot be constructed.

THROWS:

OutOfMemoryError: if the system runs out of memory.

GetStringLength

jsize GetStringLength(JNIEnv *env, jstring string);

Returns the length (the count of Unicode characters) of a Java string.

LINKAGE:

Index 164 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

string: a Java string object.

RETURNS:

Returns the length of the Java string.

GetStringChars

const jchar * GetStringChars(JNIEnv *env, jstring string,
jboolean *isCopy);

Returns a pointer to the array of Unicode characters of the string. This pointer is valid until ReleaseStringChars() is called.

If isCopy is not NULL, then *isCopy is set to JNI_TRUE if a copy is made; or it is set to JNI_FALSE if no copy is made.

LINKAGE:

Index 165 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

string: a Java string object.

isCopy: a pointer to a boolean.

RETURNS:

Returns a pointer to a Unicode string, or NULL if the operation fails.

ReleaseStringChars

void ReleaseStringChars(JNIEnv *env, jstring string,
const jchar *chars);

Informs the VM that the native code no longer needs access to chars. The chars argument is a pointer obtained from string using GetStringChars().

LINKAGE:

Index 166 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

string: a Java string object.

chars: a pointer to a Unicode string.

NewStringUTF

jstring NewStringUTF(JNIEnv *env, const char *bytes);

Constructs a new java.lang.String object from an array of characters in modified UTF-8 encoding.

LINKAGE:

Index 167 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

bytes: the pointer to a modified UTF-8 string.

RETURNS:

Returns a Java string object, or NULL if the string cannot be constructed.

THROWS:

OutOfMemoryError: if the system runs out of memory.

GetStringUTFLength

jsize GetStringUTFLength(JNIEnv *env, jstring string);

Returns the length in bytes of the modified UTF-8 representation of a string.

LINKAGE:

Index 168 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

string: a Java string object.

RETURNS:

Returns the UTF-8 length of the string.

GetStringUTFChars

const char * GetStringUTFChars(JNIEnv *env, jstring string,
jboolean *isCopy);

Returns a pointer to an array of bytes representing the string in modified UTF-8 encoding. This array is valid until it is released by ReleaseStringUTFChars().

If isCopy is not NULL, then *isCopy is set to JNI_TRUE if a copy is made; or it is set to JNI_FALSE if no copy is made.

LINKAGE:

Index 169 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

string: a Java string object.

isCopy: a pointer to a boolean.

RETURNS:

Returns a pointer to a modified UTF-8 string, or NULL if the operation fails.

ReleaseStringUTFChars

void ReleaseStringUTFChars(JNIEnv *env, jstring string,
const char *utf);

Informs the VM that the native code no longer needs access to utf. The utf argument is a pointer derived from string using GetStringUTFChars().

LINKAGE:

Index 170 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

string: a Java string object.

utf: a pointer to a modified UTF-8 string.

Note: In JDK/JRE 1.1, programmers can get primitive array elements in a user-supplied buffer. As of JDK/JRE 1.2 additional set of functions are provided allowing native code to obtain characters in Unicode (UTF-16) or modified UTF-8 encoding in a user-supplied buffer. See the functions below.

GetStringRegion

void GetStringRegion(JNIEnv *env, jstring str, jsize start, jsize len, jchar *buf);

Copies len number of Unicode characters beginning at offset start to the given buffer buf.

Throws StringIndexOutOfBoundsException on index overflow.

LINKAGE:

Index 220 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

GetStringUTFRegion

< void GetStringUTFRegion(JNIEnv *env, jstring str, jsize start, jsize len, char *buf);

Translates len number of Unicode characters beginning at offset start into modified UTF-8 encoding and place the result in the given buffer buf.

Throws StringIndexOutOfBoundsException on index overflow.

LINKAGE:

Index 221 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

GetStringCritical, ReleaseStringCritical

const jchar * GetStringCritical(JNIEnv *env, jstring string, jboolean *isCopy);
void ReleaseStringCritical(JNIEnv *env, jstring string, const jchar *carray);

The semantics of these two functions are similar to the existing Get/ReleaseStringChars functions. If possible, the VM returns a pointer to string elements; otherwise, a copy is made. However, there are significant restrictions on how these functions can be used. In a code segment enclosed by Get/ReleaseStringCritical calls, the native code must not issue arbitrary JNI calls, or cause the current thread to block.

The restrictions on Get/ReleaseStringCritical are similar to those on Get/ReleasePrimitiveArrayCritical.

LINKAGE (GetStringCritical):

Index 224 in the JNIEnv interface function table.

LINKAGE (ReleaseStingCritical):

Index 225 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

Array Operations

GetArrayLength

jsize GetArrayLength(JNIEnv *env, jarray array);

Returns the number of elements in the array.

LINKAGE:

Index 171 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

array: a Java array object.

RETURNS:

Returns the length of the array.

NewObjectArray

jobjectArray NewObjectArray(JNIEnv *env, jsize length,
jclass elementClass, jobject initialElement);

Constructs a new array holding objects in class elementClass. All elements are initially set to initialElement.

LINKAGE:

Index 172 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

length: array size.

elementClass: array element class.

initialElement: initialization value.

RETURNS:

Returns a Java array object, or NULL if the array cannot be constructed.

THROWS:

OutOfMemoryError: if the system runs out of memory.

GetObjectArrayElement

jobject GetObjectArrayElement(JNIEnv *env,
jobjectArray array, jsize index);

Returns an element of an Object array.

LINKAGE:

Index 173 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

array: a Java array.

index: array index.

RETURNS:

Returns a Java object.

THROWS:

ArrayIndexOutOfBoundsException: if index does not specify a valid index in the array.

SetObjectArrayElement

void SetObjectArrayElement(JNIEnv *env, jobjectArray array,
jsize index, jobject value);

Sets an element of an Object array.

LINKAGE:

Index 174 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

array: a Java array.

index: array index.

value: the new value.

THROWS:

ArrayIndexOutOfBoundsException: if index does not specify a valid index in the array.

ArrayStoreException: if the class of value is not a subclass of the element class of the array.

New<PrimitiveType>Array Routines

ArrayType New<PrimitiveType>Array(JNIEnv *env, jsize length);

A family of operations used to construct a new primitive array object. The following table describes the specific primitive array constructors. You should replace New<PrimitiveType>Array with one of the actual primitive array constructor routine names from this table, and replace ArrayType with the corresponding array type for that routine.

New<PrimitiveType>Array Family of Array Constructors
New<PrimitiveType>Array Routines | Array Type
NewBooleanArray() | jbooleanArray
NewByteArray() | jbyteArray
NewCharArray() | jcharArray
NewShortArray() | jshortArray
NewIntArray() | jintArray
NewLongArray() | jlongArray
NewFloatArray() | jfloatArray
NewDoubleArray() | jdoubleArray

LINKAGE:

Indices in the JNIEnv interface function table.

New<PrimitiveType>Array Family of Array Constructors
New<PrimitiveType>Array Routines | Index
NewBooleanArray() | 175
NewByteArray() | 176
NewCharArray() | 177
NewShortArray() | 178
NewIntArray() | 179
NewLongArray() | 180
NewFloatArray() | 181
NewDoubleArray() | 182

PARAMETERS:

env: the JNI interface pointer.

length: the array length.

RETURNS:

Returns a Java array, or NULL if the array cannot be constructed.

Get<PrimitiveType>ArrayElements Routines

NativeType *Get<PrimitiveType>ArrayElements(JNIEnv *env,
 ArrayType array, jboolean *isCopy);

A family of functions that returns the body of the primitive array. The result is valid until the corresponding Release<PrimitiveType>ArrayElements() function is called. Since the returned array may be a copy of the Java array, changes made to the returned array will not necessarily be reflected in the original array until Release<PrimitiveType>ArrayElements() is called.

If isCopy is not NULL, then *isCopy is set to JNI_TRUE if a copy is made; or it is set to JNI_FALSE if no copy is made.

The following table describes the specific primitive array element accessors. You should make the following substitutions:

  • Replace Get<PrimitiveType>ArrayElements with one of the actual primitive element accessor routine names from the following table.
  • Replace ArrayType with the corresponding array type.
  • Replace NativeType with the corresponding native type for that routine.

Regardless of how boolean arrays are represented in the Java VM, GetBooleanArrayElements() always returns a pointer to jbooleans, with each byte denoting an element (the unpacked representation). All arrays of other types are guaranteed to be contiguous in memory.

Get<PrimitiveType>ArrayElements Family of Accessor Routines
Get<PrimitiveType>ArrayElements Routines | Array Type | Native Type
GetBooleanArrayElements() | jbooleanArray | jboolean
GetByteArrayElements() | jbyteArray | jbyte
GetCharArrayElements() | jcharArray | jchar
GetShortArrayElements() | jshortArray | jshort
GetIntArrayElements() | jintArray | jint
GetLongArrayElements() | jlongArray | jlong
GetFloatArrayElements() | jfloatArray | jfloat
GetDoubleArrayElements() | jdoubleArray | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

Get<PrimitiveType>ArrayElements Family of Accessor Routines
Get<PrimitiveType>ArrayElements Routines | Index
GetBooleanArrayElements() | 183
GetByteArrayElements() | 184
GetCharArrayElements() | 185
GetShortArrayElements() | 186
GetIntArrayElements() | 187
GetLongArrayElements() | 188
GetFloatArrayElements() | 189
GetDoubleArrayElements() | 190

PARAMETERS:

env: the JNI interface pointer.

array: a Java string object.

isCopy: a pointer to a boolean.

RETURNS:

Returns a pointer to the array elements, or NULL if the operation fails.

Release<PrimitiveType>ArrayElements Routines

void Release<PrimitiveType>ArrayElements(JNIEnv *env,
 ArrayType array, NativeType *elems, jint mode);

A family of functions that informs the VM that the native code no longer needs access to elems. The elems argument is a pointer derived from array using the corresponding Get<PrimitiveType>ArrayElements() function. If necessary, this function copies back all changes made to elems to the original array.

The mode argument provides information on how the array buffer should be released. mode has no effect if elems is not a copy of the elements in array. Otherwise, mode has the following impact, as shown in the following table:

Primitive Array Release Modes
mode | actions
0 | copy back the content and free the elems buffer
JNI_COMMIT | copy back the content but do not free the elems buffer
JNI_ABORT | free the buffer without copying back the possible changes

In most cases, programmers pass “0” to the mode argument to ensure consistent behavior for both pinned and copied arrays. The other options give the programmer more control over memory management and should be used with extreme care.

The next table describes the specific routines that comprise the family of primitive array disposers. You should make the following substitutions:

  • Replace Release<PrimitiveType>ArrayElements with one of the actual primitive array disposer routine names from the following table.
  • Replace ArrayType with the corresponding array type.
  • Replace NativeType with the corresponding native type for that routine.
Release<PrimitiveType>ArrayElements Family of Array Routines
Release<PrimitiveType>ArrayElements Routines | Array Type | Native Type
ReleaseBooleanArrayElements() | jbooleanArray | jboolean
ReleaseByteArrayElements() | jbyteArray | jbyte
ReleaseCharArrayElements() | jcharArray | jchar
ReleaseShortArrayElements() | jshortArray | jshort
ReleaseIntArrayElements() | jintArray | jint
ReleaseLongArrayElements() | jlongArray | jlong
ReleaseFloatArrayElements() | jfloatArray | jfloat
ReleaseDoubleArrayElements() | jdoubleArray | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

Release<PrimitiveType>ArrayElements Family of Array Routines
Release<PrimitiveType>ArrayElements Routines | Index
ReleaseBooleanArrayElements() | 191
ReleaseByteArrayElements() | 192
ReleaseCharArrayElements() | 193
ReleaseShortArrayElements() | 194
ReleaseIntArrayElements() | 195
ReleaseLongArrayElements() | 196
ReleaseFloatArrayElements() | 197
ReleaseDoubleArrayElements() | 198

PARAMETERS:

env: the JNI interface pointer.

array: a Java array object.

elems: a pointer to array elements.

mode: the release mode.

Get<PrimitiveType>ArrayRegion Routines

void Get<PrimitiveType>ArrayRegion(JNIEnv *env, ArrayType array,
jsize start, jsize len, NativeType *buf);

A family of functions that copies a region of a primitive array into a buffer.

The following table describes the specific primitive array element accessors. You should do the following substitutions:

  • Replace Get<PrimitiveType>ArrayRegion with one of the actual primitive element accessor routine names from the following table.
  • Replace ArrayType with the corresponding array type.
  • Replace NativeType with the corresponding native type for that routine.
Get<PrimitiveType>ArrayRegion Family of Array Accessor Routines
Get<PrimitiveType>ArrayRegion Routine | Array Type | Native Type
GetBooleanArrayRegion() | jbooleanArray | jboolean
GetByteArrayRegion() | jbyteArray | jbyte
GetCharArrayRegion() | jcharArray | jchar
GetShortArrayRegion() | jshortArray | jhort
GetIntArrayRegion() | jintArray | jint
GetLongArrayRegion() | jlongArray | jlong
GetFloatArrayRegion() | jfloatArray | jloat
GetDoubleArrayRegion() | jdoubleArray | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

Get<PrimitiveType>ArrayRegion Family of Array Accessor Routines
Get<PrimitiveType>ArrayRegion Routine | Index
GetBooleanArrayRegion() | 199
GetByteArrayRegion() | 200
GetCharArrayRegion() | 201
GetShortArrayRegion() | 202
GetIntArrayRegion() | 203
GetLongArrayRegion() | 204
GetFloatArrayRegion() | 205
GetDoubleArrayRegion() | 206

PARAMETERS:

env: the JNI interface pointer.

array: a Java array.

start: the starting index.

len: the number of elements to be copied.

buf: the destination buffer.

THROWS:

ArrayIndexOutOfBoundsException: if one of the indexes in the region is not valid.

Set<PrimitiveType>ArrayRegion Routines

void Set<PrimitiveType>ArrayRegion(JNIEnv *env, ArrayType array,
jsize start, jsize len, const NativeType *buf);

A family of functions that copies back a region of a primitive array from a buffer.

The following table describes the specific primitive array element accessors. You should make the following replacements:

  • Replace Set<PrimitiveType>ArrayRegion with one of the actual primitive element accessor routine names from the following table.
  • Replace ArrayType with the corresponding array type.
  • Replace NativeType with the corresponding native type for that routine.
Set<PrimitiveType>ArrayRegion Family of Array Accessor Routines
Set<PrimitiveType>ArrayRegion Routine | Array Type | Native Type
SetBooleanArrayRegion() | jbooleanArray | jboolean
SetByteArrayRegion() | jbyteArray | jbyte
SetCharArrayRegion() | jcharArray | jchar
SetShortArrayRegion() | jshortArray | jshort
SetIntArrayRegion() | jintArray | jint
SetLongArrayRegion() | jlongArray | jlong
SetFloatArrayRegion() | jfloatArray | jfloat
SetDoubleArrayRegion() | jdoubleArray | jdouble

LINKAGE:

Indices in the JNIEnv interface function table.

Set<PrimitiveType>ArrayRegion Family of Array Accessor Routines
Set<PrimitiveType>ArrayRegion Routine | Index
SetBooleanArrayRegion() | 207
SetByteArrayRegion() | 208
SetCharArrayRegion() | 209
SetShortArrayRegion() | 210
SetIntArrayRegion() | 211
SetLongArrayRegion() | 212
SetFloatArrayRegion() | 213
SetDoubleArrayRegion() | 214

PARAMETERS:

env: the JNI interface pointer.

array: a Java array.

start: the starting index.

len: the number of elements to be copied.

buf: the source buffer.

THROWS:

ArrayIndexOutOfBoundsException: if one of the indexes in the region is not valid.

Note: As of JDK/JRE 1.1, programmers can use Get/Release<primitivetype>ArrayElements functions to obtain a pointer to primitive array elements. If the VM supports pinning, the pointer to the original data is returned; otherwise, a copy is made.

New functions introduced as of JDK/JRE 1.3 allow native code to obtain a direct pointer to array elements even if the VM does not support pinning.

GetPrimitiveArrayCritical, ReleasePrimitiveArrayCritical

void * GetPrimitiveArrayCritical(JNIEnv *env, jarray array, jboolean *isCopy);
void ReleasePrimitiveArrayCritical(JNIEnv *env, jarray array, void *carray, jint mode);

The semantics of these two functions are very similar to the existing Get/Release<primitivetype>ArrayElements functions. If possible, the VM returns a pointer to the primitive array; otherwise, a copy is made. However, there are significant restrictions on how these functions can be used.

After calling GetPrimitiveArrayCritical, the native code should not run for an extended period of time before it calls ReleasePrimitiveArrayCritical. We must treat the code inside this pair of functions as running in a "critical region." Inside a critical region, native code must not call other JNI functions, or any system call that may cause the current thread to block and wait for another Java thread. (For example, the current thread must not call read on a stream being written by another Java thread.)

These restrictions make it more likely that the native code will obtain an uncopied version of the array, even if the VM does not support pinning. For example, a VM may temporarily disable garbage collection when the native code is holding a pointer to an array obtained via GetPrimitiveArrayCritical.

Multiple pairs of GetPrimtiveArrayCritical and ReleasePrimitiveArrayCritical may be nested. For example:

  jint len = (*env)->GetArrayLength(env, arr1);
  jbyte *a1 = (*env)->GetPrimitiveArrayCritical(env, arr1, 0);
  jbyte *a2 = (*env)->GetPrimitiveArrayCritical(env, arr2, 0);
  /* We need to check in case the VM tried to make a copy. */
  if (a1 == NULL || a2 == NULL) {
    ... /* out of memory exception thrown */
  }
  memcpy(a1, a2, len);
  (*env)->ReleasePrimitiveArrayCritical(env, arr2, a2, 0);
  (*env)->ReleasePrimitiveArrayCritical(env, arr1, a1, 0);

Note that GetPrimitiveArrayCritical might still make a copy of the array if the VM internally represents arrays in a different format. Therefore we need to check its return value against NULL for possible out of memory situations.

LINKAGE (GetPrimitiveArrayCritical):

Linkage Index 222 in the JNIEnv interface function table.

LINKAGE (ReleasePrimitiveArrayCritical):

Linkage Index 223 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

Registering Native Methods

RegisterNatives

jint RegisterNatives(JNIEnv *env, jclass clazz,
const JNINativeMethod *methods, jint nMethods);

Registers native methods with the class specified by the clazz argument. The methods parameter specifies an array of JNINativeMethod structures that contain the names, signatures, and function pointers of the native methods. The name and signature fields of the JNINativeMethod structure are pointers to modified UTF-8 strings. The nMethods parameter specifies the number of native methods in the array. The JNINativeMethod structure is defined as follows:

typedef struct {

    char *name;

    char *signature;

    void *fnPtr;

} JNINativeMethod;

The function pointers nominally must have the following signature:

ReturnType (*fnPtr)(JNIEnv *env, jobject objectOrClass, ...);

LINKAGE:

Index 215 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

methods: the native methods in the class.

nMethods: the number of native methods in the class.

RETURNS:

Returns “0” on success; returns a negative value on failure.

THROWS:

NoSuchMethodError: if a specified method cannot be found or if the method is not native.

UnregisterNatives

jint UnregisterNatives(JNIEnv *env, jclass clazz);

Unregisters native methods of a class. The class goes back to the state before it was linked or registered with its native method functions.

This function should not be used in normal native code. Instead, it provides special programs a way to reload and relink native libraries.

LINKAGE:

Index 216 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

clazz: a Java class object.

RETURNS:

Returns “0” on success; returns a negative value on failure.

Monitor Operations

MonitorEnter

jint MonitorEnter(JNIEnv *env, jobject obj);

Enters the monitor associated with the underlying Java object referred to by obj.

Enters the monitor associated with the object referred to by obj. The obj reference must not be NULL.

Each Java object has a monitor associated with it. If the current thread already owns the monitor associated with obj, it increments a counter in the monitor indicating the number of times this thread has entered the monitor. If the monitor associated with obj is not owned by any thread, the current thread becomes the owner of the monitor, setting the entry count of this monitor to 1. If another thread already owns the monitor associated with obj, the current thread waits until the monitor is released, then tries again to gain ownership.

A monitor entered through a MonitorEnter JNI function call cannot be exited using the monitorexit Java virtual machine instruction or a synchronized method return. A MonitorEnter JNI function call and a monitorenter Java virtual machine instruction may race to enter the monitor associated with the same object.

To avoid deadlocks, a monitor entered through a MonitorEnter JNI function call must be exited using the MonitorExit JNI call, unless the DetachCurrentThread call is used to implicitly release JNI monitors.

LINKAGE:

Index 217 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a normal Java object or class object.

RETURNS:

Returns “0” on success; returns a negative value on failure.

MonitorExit

jint MonitorExit(JNIEnv *env, jobject obj);

The current thread must be the owner of the monitor associated with the underlying Java object referred to by obj. The thread decrements the counter indicating the number of times it has entered this monitor. If the value of the counter becomes zero, the current thread releases the monitor.

Native code must not use MonitorExit to exit a monitor entered through a synchronized method or a monitorenter Java virtual machine instruction.

LINKAGE:

Index 218 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

obj: a normal Java object or class object.

RETURNS:

Returns “0” on success; returns a negative value on failure.

EXCEPTIONS:

IllegalMonitorStateException: if the current thread does not own the monitor.

NIO Support

The NIO-related entry points allow native code to access java.nio direct buffers. The contents of a direct buffer can, potentially, reside in native memory outside of the ordinary garbage-collected heap. For information about direct buffers, please see New I/O APIs and the specification of the java.nio.ByteBuffer class.

Three new functions introduced in JDK/JRE 1.4 allow JNI code to create, examine, and manipulate direct buffers:
  • NewDirectByteBuffer
  • GetDirectBufferAddress
  • GetDirectBufferCapacity

Every implementation of the Java virtual machine must support these functions, but not every implementation is required to support JNI access to direct buffers. If a JVM does not support such access then the NewDirectByteBuffer and GetDirectBufferAddress functions must always return NULL, and the GetDirectBufferCapacity function must always return -1. If a JVM does support such access then these three functions must be implemented to return the appropriate values.

NewDirectByteBuffer

jobject NewDirectByteBuffer(JNIEnv* env, void* address, jlong capacity);

Allocates and returns a direct java.nio.ByteBuffer referring to the block of memory starting at the memory address address and extending capacity bytes.

Native code that calls this function and returns the resulting byte-buffer object to Java-level code should ensure that the buffer refers to a valid region of memory that is accessible for reading and, if appropriate, writing. An attempt to access an invalid memory location from Java code will either return an arbitrary value, have no visible effect, or cause an unspecified exception to be thrown.

LINKAGE:

Index 229 in the JNIEnv interface function table.

PARAMETERS:

env: the JNIEnv interface pointer

address: the starting address of the memory region (must not be NULL)

capacity: the size in bytes of the memory region (must be positive)

RETURNS:

Returns a local reference to the newly-instantiated java.nio.ByteBuffer object. Returns NULL if an exception occurs, or if JNI access to direct buffers is not supported by this virtual machine.

EXCEPTIONS:

OutOfMemoryError: if allocation of the ByteBuffer object fails

SINCE:

JDK/JRE 1.4

GetDirectBufferAddress

void* GetDirectBufferAddress(JNIEnv* env, jobject buf);

Fetches and returns the starting address of the memory region referenced by the given direct java.nio.Buffer.

This function allows native code to access the same memory region that is accessible to Java code via the buffer object.

LINKAGE:

Index 230 in the JNIEnv interface function table.

PARAMETERS:

env: the JNIEnv interface pointer

buf: a direct java.nio.Buffer object (must not be NULL)

RETURNS:

Returns the starting address of the memory region referenced by the buffer. Returns NULL if the memory region is undefined, if the given object is not a direct java.nio.Buffer, or if JNI access to direct buffers is not supported by this virtual machine.

SINCE:

JDK/JRE 1.4

GetDirectBufferCapacity

jlong GetDirectBufferCapacity(JNIEnv* env, jobject buf);

Fetches and returns the capacity of the memory region referenced by the given direct java.nio.Buffer. The capacity is the number of elements that the memory region contains.

LINKAGE:

Index 231 in the JNIEnv interface function table.

PARAMETERS:

env: the JNIEnv interface pointer

buf: a direct java.nio.Buffer object (must not be NULL)

RETURNS:

Returns the capacity of the memory region associated with the buffer. Returns -1 if the given object is not a direct java.nio.Buffer, if the object is an unaligned view buffer and the processor architecture does not support unaligned access, or if JNI access to direct buffers is not supported by this virtual machine.

SINCE:

JDK/JRE 1.4

Reflection Support

Programmers can use the JNI to call Java methods or access Java fields if they know the name and type of the methods or fields. The Java Core Reflection API allows programmers to introspect Java classes at runtime. JNI provides a set of conversion functions between field and method IDs used in the JNI to field and method objects used in the Java Core Reflection API.

FromReflectedMethod

jmethodID FromReflectedMethod(JNIEnv *env, jobject method);

Converts a java.lang.reflect.Method or java.lang.reflect.Constructor object to a method ID.

LINKAGE:

Index 7 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

FromReflectedField

jfieldID FromReflectedField(JNIEnv *env, jobject field);

Converts a java.lang.reflect.Field to a field ID.

LINKAGE:

Index 8 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

ToReflectedMethod

jobject ToReflectedMethod(JNIEnv *env, jclass cls,
   jmethodID methodID, jboolean isStatic);

Converts a method ID derived from cls to a java.lang.reflect.Method or java.lang.reflect.Constructor object. isStatic must be set to JNI_TRUE if the method ID refers to a static field, and JNI_FALSE otherwise.

Throws OutOfMemoryError and returns 0 if fails.

LINKAGE:

Index 9 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

ToReflectedField

jobject ToReflectedField(JNIEnv *env, jclass cls,
   jfieldID fieldID, jboolean isStatic);

Converts a field ID derived from cls to a java.lang.reflect.Field object. isStatic must be set to JNI_TRUE if fieldID refers to a static field, and JNI_FALSE otherwise.

Throws OutOfMemoryError and returns 0 if fails.

LINKAGE:

Index 12 in the JNIEnv interface function table.

SINCE:

JDK/JRE 1.2

Java VM Interface

GetJavaVM

jint GetJavaVM(JNIEnv *env, JavaVM **vm);

Returns the Java VM interface (used in the Invocation API) associated with the current thread. The result is placed at the location pointed to by the second argument, vm.

LINKAGE:

Index 219 in the JNIEnv interface function table.

PARAMETERS:

env: the JNI interface pointer.

vm: a pointer to where the result should be placed.

RETURNS:

Returns “0” on success; returns a negative value on failure.

Contents | Previous | Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java IDL: Concepts

Documentation Contents

Concepts

  • Distributed Application Concepts
  • CORBA and the Java Platform
  • Glossary
Home Concepts Programming Reference Tutorial
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JavaFX Script Application Examples

Documentation Contents
Java Platform, Standard Edition Nashorn User's Guide
Contents Previous

A JavaFX Script Application Examples

This appendix provides examples of JavaFX script applications.

For more information about writing JavaFX applications as scripts interpreted by the Nashorn engine, see Chapter 3, "Nashorn and JavaFX".

Example A-1 JavaFX 3-D

This example demonstrates how a complex task (in this case, rendering 3-D graphics with JavaFX) can be done with relatively little code using the Nashorn script engine capabilities. When you run this example, a window with three green shapes is shown: a box, a sphere, and a cylinder.

load("fx:base.js");
load("fx:controls.js");
load("fx:graphics.js");

var material = new PhongMaterial();
material.diffuseColor = Color.LIGHTGREEN;
material.specularColor = Color.rgb(30, 30, 30);

var meshView = Java.to([
    new Box(200, 200, 200),
    new Sphere(100),
    new Cylinder(100, 200)
], "javafx.scene.shape.Shape3D[]");

for (var i = 0; i != 3; i++) {
    meshView[i].material = material;
    meshView[i].translateX = (i + 1) * 220;
    meshView[i].translateY = 200;
    meshView[i].translateZ = 20;
    meshView[i].drawMode = DrawMode.FILL;
    meshView[i].cullFace = CullFace.BACK;
};

var pointLight = new PointLight(Color.WHITE);
pointLight.translateX = 800;
pointLight.translateY = -200;
pointLight.translateZ = -1000;

var root = new Group(meshView);
root.children.add(pointLight);

var scene = new Scene(root, 800, 400, true);
scene.fill = Color.rgb(127, 127, 127);
scene.camera = new PerspectiveCamera(false);
$STAGE.scene = scene;
$STAGE.show();

Example A-2 JavaFX Animation

This example demonstrates how to create a JavaFX animation using the Nashorn script engine capabilities. When you run this example, a window with colorful circles moving around is shown.

load("fx:base.js");
load("fx:controls.js");
load("fx:graphics.js");

var WIDTH = 500;
var HEIGHT = 600;
var animation;

function setup(primaryStage) {
 var root = new Group();
 primaryStage.resizable = false;
 var scene = new Scene(root, WIDTH, HEIGHT);
 scene.title = "Colourful Circles";
 primaryStage.scene = scene;

 // create first list of circles
 var layer1 = new Group();
 for(var i = 0; i < 15; i++) {
  var circle = new Circle(200, Color.web("white", 0.05));
  circle.strokeType = StrokeType.OUTSIDE;
  circle.stroke = Color.web("white", 0.2);
  circle.strokeWidth = 4;
  layer1.children.add(circle);
 }

 // create second list of circles
 var layer2 = new Group();
 for(var i = 0; i < 20; i++) {
  var circle = new Circle(70, Color.web("white", 0.05));
  circle.strokeType = StrokeType.OUTSIDE;
  circle.stroke = Color.web("white", 0.1);
  circle.strokeWidth = 2;
  layer2.children.add(circle);
 }

 // create third list of circles
 var layer3 = new Group();
 for(var i = 0; i < 10; i++) {
  var circle = new Circle(150, Color.web("white", 0.05));
  circle.strokeType = StrokeType.OUTSIDE;
  circle.stroke = Color.web("white", 0.16);
  circle.strokeWidth = 4;
  layer3.children.add(circle);
 }

 // set a blur effect on each layer
 layer1.effect = new BoxBlur(30, 30, 3);
 layer2.effect = new BoxBlur(2, 2, 2);
 layer3.effect = new BoxBlur(10, 10, 3);

 // create a rectangle size of window with colored gradient
 var colors = new Rectangle(WIDTH, HEIGHT,
   new LinearGradient(0, 1, 1, 0, true, CycleMethod.NO_CYCLE,
      new Stop(0,   Color.web("#f8bd55")),
      new Stop(0.14, Color.web("#c0fe56")),
      new Stop(0.28, Color.web("#5dfbc1")),
      new Stop(0.43, Color.web("#64c2f8")),
      new Stop(0.57, Color.web("#be4af7")),
      new Stop(0.71, Color.web("#ed5fc2")),
      new Stop(0.85, Color.web("#ef504c")),
      new Stop(1,   Color.web("#f2660f"))));
 colors.blendMode = BlendMode.OVERLAY;

 // create main content
 var group = new Group(new Rectangle(WIDTH, HEIGHT, Color.BLACK),
        layer1,
        layer2,
        layer3,
        colors);
 var clip = new Rectangle(WIDTH, HEIGHT);
 clip.smooth = false;
 group.clip = clip;
 root.children.add(group);

 // create list of all circles
 var allCircles = new java.util.ArrayList();
 allCircles.addAll(layer1.children);
 allCircles.addAll(layer2.children);
 allCircles.addAll(layer3.children);

 // Create a animation to randomly move every circle in allCircles
 animation = new Timeline();
 for each (var circle in allCircles) {
  animation.getKeyFrames().addAll(
     new KeyFrame(Duration.ZERO, // set start position at 0s
         new KeyValue(circle.translateXProperty(),
Math.random() * WIDTH),
         new KeyValue(circle.translateYProperty(),
Math.random() * HEIGHT)),
     new KeyFrame(new Duration(20000), // set end position at 20s
         new KeyValue(circle.translateXProperty(),
Math.random() * WIDTH),
         new KeyValue(circle.translateYProperty(),
Math.random() * HEIGHT))
     );
 }
 animation.autoReverse = true;
 animation.cycleCount = Animation.INDEFINITE;
}

function stop() {
 animation.stop();
}

function play() {
 animation.play();
}

function start(primaryStage) {
 setup(primaryStage);
 primaryStage.show();
 play();
}
Contents Previous
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Garbage-First Collector

Introduction

The Garbage-First (G1) garbage collector is fully supported in Oracle JDK 7 update 4 and later releases. The G1 collector is a server-style garbage collector, targeted for multi-processor machines with large memories. It meets garbage collection (GC) pause time goals with high probability, while achieving high throughput. Whole-heap operations, such as global marking, are performed concurrently with the application threads. This prevents interruptions proportional to heap or live-data size.

Technical description

The G1 collector achieves high performance and pause time goals through several techniques.

The heap is partitioned into a set of equal-sized heap regions, each a contiguous range of virtual memory. G1 performs a concurrent global marking phase to determine the liveness of objects throughout the heap. After the mark phase completes, G1 knows which regions are mostly empty. It collects in these regions first, which usually yields a large amount of free space. This is why this method of garbage collection is called Garbage-First. As the name suggests, G1 concentrates its collection and compaction activity on the areas of the heap that are likely to be full of reclaimable objects, that is, garbage. G1 uses a pause prediction model to meet a user-defined pause time target and selects the number of regions to collect based on the specified pause time target.

The regions identified by G1 as ripe for reclamation are garbage collected using evacuation. G1 copies objects from one or more regions of the heap to a single region on the heap, and in the process both compacts and frees up memory. This evacuation is performed in parallel on multi-processors, to decrease pause times and increase throughput. Thus, with each garbage collection, G1 continuously works to reduce fragmentation, working within the user defined pause times. This is beyond the capability of both the previous methods. CMS (Concurrent Mark Sweep ) garbage collection does not do compaction. ParallelOld garbage collection performs only whole-heap compaction, which results in considerable pause times.

It is important to note that G1 is not a real-time collector. It meets the set pause time target with high probability but not absolute certainty. Based on data from previous collections, G1 does an estimate of how many regions can be collected within the user specified target time. Thus, the collector has a reasonably accurate model of the cost of collecting the regions, and it uses this model to determine which and how many regions to collect while staying within the pause time target.

Recommended Use Cases for G1

The first focus of G1 is to provide a solution for users running applications that require large heaps with limited GC latency. This means heap sizes of around 6GB or larger, and stable and predictable pause time below 0.5 seconds.

Applications running today with either the CMS or the ParallelOld garbage collector would benefit switching to G1 if the application has one or more of the following traits.

  • More than 50% of the Java heap is occupied with live data.
  • The rate of object allocation rate or promotion varies significantly.
  • Undesired long garbage collection or compaction pauses (longer than 0.5 to 1 second)

Future

G1 is planned as the long term replacement for the Concurrent Mark-Sweep Collector (CMS). Comparing G1 with CMS, there are differences that make G1 a better solution. One difference is that G1 is a compacting collector. G1 compacts sufficiently to completely avoid the use of fine-grained free lists for allocation, and instead relies on regions. This considerably simplifies parts of the collector, and mostly eliminates potential fragmentation issues. Also, G1 offers more predictable garbage collection pauses than the CMS collector, and allows users to specify desired pause targets.

If you are interested in helping improving G1, please try it and give feedback via OpenJDK and the hotspot-gc-use@openjdk.java.net mailing list.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Garbage-First Garbage Collector

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

9 Garbage-First Garbage Collector

The Garbage-First (G1) garbage collector is a server-style garbage collector, targeted for multiprocessor machines with large memories. It attempts to meet garbage collection (GC) pause time goals with high probability while achieving high throughput. Whole-heap operations, such as global marking, are performed concurrently with the application threads. This prevents interruptions proportional to heap or live-data size.

The G1 collector achieves high performance and pause time goals through several techniques.

The heap is partitioned into a set of equally sized heap regions, each a contiguous range of virtual memory. G1 performs a concurrent global marking phase to determine the liveness of objects throughout the heap. After the marking phase completes, G1 knows which regions are mostly empty. It collects these regions first, which often yields a large amount of free space. This is why this method of garbage collection is called Garbage-First. As the name suggests, G1 concentrates its collection and compaction activity on the areas of the heap that are likely to be full of reclaimable objects, that is, garbage. G1 uses a pause prediction model to meet a user-defined pause time target and selects the number of regions to collect based on the specified pause time target.

G1 copies objects from one or more regions of the heap to a single region on the heap, and in the process both compacts and frees up memory. This evacuation is performed in parallel on multiprocessors to decrease pause times and increase throughput. Thus, with each garbage collection, G1 continuously works to reduce fragmentation. This is beyond the capability of both of the previous methods. CMS (Concurrent Mark Sweep) garbage collection does not do compaction. Parallel compaction performs only whole-heap compaction, which results in considerable pause times.

It is important to note that G1 is not a real-time collector. It meets the set pause time target with high probability but not absolute certainty. Based on data from previous collections, G1 estimates how many regions can be collected within the target time. Thus, the collector has a reasonably accurate model of the cost of collecting the regions, and it uses this model to determine which and how many regions to collect while staying within the pause time target.

The first focus of G1 is to provide a solution for users running applications that require large heaps with limited GC latency. This means heap sizes of around 6 GB or larger, and a stable and predictable pause time below 0.5 seconds.

Applications running today with either the CMS or the with parallel compaction would benefit from switching to G1 if the application has one or more of the following traits.

  • More than 50% of the Java heap is occupied with live data.

  • The rate of object allocation rate or promotion varies significantly.

  • The application is experiencing undesired long garbage collection or compaction pauses (longer than 0.5 to 1 second).

G1 is planned as the long-term replacement for the Concurrent Mark-Sweep Collector (CMS). Comparing G1 with CMS reveals differences that make G1 a better solution. One difference is that G1 is a compacting collector. Also, G1 offers more predictable garbage collection pauses than the CMS collector, and allows users to specify desired pause targets.

As with CMS, G1 is designed for applications that require shorter GC pauses.

G1 divides the heap into fixed-sized regions (the gray boxes) as in Figure 9-1, "Heap Division by G1".

Figure 9-1 Heap Division by G1

Description of Figure 9-1 follows
Description of "Figure 9-1 Heap Division by G1"

G1 is generational in a logical sense. A set of empty regions is designated as the logical young generation. In the figure, the young generation is light blue. Allocations are done out of that logical young generation, and when the young generation is full, that set of regions is garbage collected (a young collection). In some cases, regions outside the set of young regions (old regions in dark blue) can be garbage collected at the same time. This is referred to as a mixed collection. In the figure, the regions being collected are marked by red boxes. The figure illustrates a mixed collection because both young regions and old regions are being collected. The garbage collection is a compacting collection that copies live objects to selected, initially empty regions. Based on the age of a surviving object, the object can be copied to a survivor region (marked by "S") or to an old region (not specifically shown). The regions marked by "H" contain humongous objects that are larger than half a region and are treated specially; see the section Humongous Objects and Humongous Allocations in Garbage-First Garbage Collector.

Allocation (Evacuation) Failure

As with CMS, the G1 collector runs parts of its collection while the application continues to run and there is a risk that the application will allocate objects faster than the garbage collector can recover free space. See the section Concurrent Mode Failure in Concurrent Mark Sweep (CMS) Collector for the analogous CMS behavior. In G1, the failure (exhaustion of the Java heap) occurs while G1 is copying live data out of one region (evacuating) into another region. The copying is done to compact the live data. If a free (empty) region cannot be found during the evacuation of a region being garbage collected, then an allocation failure occurs (because there is no space to allocate the live objects from the region being evacuated) and a stop-the-world (STW) full collection is done.

Floating Garbage

Objects can die during a G1 collection and not be collected. G1 uses a technique called snapshot-at-the-beginning (SATB) to guarantee that all live objects are found by the garbage collector. SATB states that any object that is live at the start of the concurrent marking (a marking over the entire heap) is considered live for the purpose of the collection. SATB allows floating garbage in a way analogous to that of a CMS incremental update.

Pauses

G1 pauses the application to copy live objects to new regions. These pauses can either be young collection pauses where only young regions are collected or mixed collection pauses where young and old regions are evacuated. As with CMS there is a final marking or remark pause to complete the marking while the application is stopped. Whereas CMS also had an initial marking pause, G1 does the initial marking work as part of an evacuation pause. G1 has a cleanup phase at the end of a collection which is partly STW and partly concurrent. The STW part of the cleanup phase identifies empty regions and determines old regions that are candidates for the next collection.

Card Tables and Concurrent Phases

If a garbage collector does not collect the entire heap (an incremental collection), the garbage collector needs to know where there are pointers from the uncollected part of the heap into the part of the heap that is being collected. This is typically for a generational garbage collector in which the uncollected part of the heap is usually the old generation, and the collected part of the heap is the young generation. The data structure for keeping this information (old generation pointers to young generation objects), is a remembered set. A card table is a particular type of remembered set. Java HotSpot VM uses an array of bytes as a card table. Each byte is referred to as a card. A card corresponds to a range of addresses in the heap. Dirtying a card means changing the value of the byte to a dirty value; a dirty value might contain a new pointer from the old generation to the young generation in the address range covered by the card.

Processing a card means looking at the card to see if there is an old generation to young generation pointer and perhaps doing something with that information such as transferring it to another data structure.

G1 has concurrent marking phase which marks live objects found from the application. The concurrent marking extends from the end of a evacuation pause (where the initial marking work is done) to the remark. The concurrent cleanup phase adds regions emptied by the collection to the list of free regions and clears the remembered sets of those regions. In addition, a concurrent refinement thread runs as needed to process card table entries that have been dirtied by application writes and which may have cross region references.

Starting a Concurrent Collection Cycle

As mentioned previously, both young and old regions are garbage collected in a mixed collection. To collect old regions, G1 does a complete marking of the live objects in the heap. Such a marking is done by a concurrent marking phase. A concurrent marking phase is started when the occupancy of the entire Java heap reaches the value of the parameter InitiatingHeapOccupancyPercent. Set the value of this parameter with the command-line option -XX:InitiatingHeapOccupancyPercent=<NN>. The default value of InitiatingHeapOccupancyPercent is 45.

Pause Time Goal

Set a pause time goal for G1 with the flag MaxGCPauseMillis. G1 uses a prediction model to decide how much garbage collection work can be done within that target pause time. At the end of a collection, G1 chooses the regions to be collected in the next collection (the collection set). The collection set will contain young regions (the sum of whose sizes determines the size of the logical young generation). It is partly through the selection of the number of young regions in the collection set that G1 exerts control over the length of the GC pauses. You can specify the size of the young generation on the command line as with the other garbage collectors, but doing so may hamper the ability of G1 to attain the target pause time. In addition to the pause time goal, you can specify the length of the time period during which the pause can occur. You can specify the minimum mutator usage with this time span (GCPauseIntervalMillis) along with the pause time goal. The default value for MaxGCPauseMillis is 200 milliseconds. The default value for GCPauseIntervalMillis (0) is the equivalent of no requirement on the time span.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Garbage-First Garbage Collector Tuning

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

10 Garbage-First Garbage Collector Tuning

This section describes how to adapt and tune the Garbage-First garbage collector (G1 GC) for evaluation, analysis and performance.

As described in the section Garbage-First Garbage Collector, the G1 GC is a regionalized and generational garbage collector, which means that the Java object heap (heap) is divided into a number of equally sized regions. Upon startup, the Java Virtual Machine (JVM) sets the region size. The region sizes can vary from 1 MB to 32 MB depending on the heap size. The goal is to have no more than 2048 regions. The eden, survivor, and old generations are logical sets of these regions and are not contiguous.

The G1 GC has a pause time target that it tries to meet (soft real time). During young collections, the G1 GC adjusts its young generation (eden and survivor sizes) to meet the soft real-time target. See the sections Pauses and Pause Time Goal in Garbage-First Garbage Collector for information about why the G1 GC takes pauses and how to set pause time targets.

During mixed collections, the G1 GC adjusts the number of old regions that are collected based on a target number of mixed garbage collections, the percentage of live objects in each region of the heap, and the overall acceptable heap waste percentage.

The G1 GC reduces heap fragmentation by incremental parallel copying of live objects from one or more sets of regions (called Collection Sets (CSet)s) into one or more different new regions to achieve compaction. The goal is to reclaim as much heap space as possible, starting with those regions that contain the most reclaimable space, while attempting to not exceed the pause time goal (garbage first).

The G1 GC uses independent Remembered Sets (RSets) to track references into regions. Independent RSets enable parallel and independent collection of regions because only a region's RSet must be scanned for references into that region, instead of the whole heap. The G1 GC uses a post-write barrier to record changes to the heap and update the RSets.

Garbage Collection Phases

Apart from evacuation pauses (see the section Allocation (Evacuation) Failure in Garbage-First Garbage Collector) that compose the stop-the-world (STW) young and mixed garbage collections, the G1 GC also has parallel, concurrent, and multiphase marking cycles. G1 GC uses the snapshot-at-the-beginning (SATB) algorithm, which logically takes a snapshot of the set of live objects in the heap at the start of a marking cycle. The set of live objects also includes objects allocated since the start of the marking cycle. The G1 GC marking algorithm uses a pre-write barrier to record and mark objects that are part of the logical snapshot.

Young Garbage Collections

The G1 GC satisfies most allocation requests from regions added to the eden set of regions. During a young garbage collection, the G1 GC collects both the eden regions and the survivor regions from the previous garbage collection. The live objects from the eden and survivor regions are copied, or evacuated, to a new set of regions. The destination region for a particular object depends upon the object's age; an object that has aged sufficiently evacuates to an old generation region (that is, it is promoted); otherwise, the object evacuates to a survivor region and will be included in the CSet of the next young or mixed garbage collection.

Mixed Garbage Collections

Upon successful completion of a concurrent marking cycle, the G1 GC switches from performing young garbage collections to performing mixed garbage collections. In a mixed garbage collection, the G1 GC optionally adds some old regions to the set of eden and survivor regions that will be collected. The exact number of old regions added is controlled by a number of flags (see "Taming Mixed Garbage Collectors" in the section Recommendations). After the G1 GC collects a sufficient number of old regions (over multiple mixed garbage collections), G1 reverts to performing young garbage collections until the next marking cycle completes.

Phases of the Marking Cycle

The marking cycle has the following phases:

  • Initial marking phase: The G1 GC marks the roots during this phase. This phase is piggybacked on a normal (STW) young garbage collection.

  • Root region scanning phase: The G1 GC scans survivor regions marked during the initial marking phase for references to the old generation and marks the referenced objects. This phase runs concurrently with the application (not STW) and must complete before the next STW young garbage collection can start.

  • Concurrent marking phase: The G1 GC finds reachable (live) objects across the entire heap. This phase happens concurrently with the application, and can be interrupted by STW young garbage collections.

  • Remark phase: This phase is STW collection and helps the completion of the marking cycle. G1 GC drains SATB buffers, traces unvisited live objects, and performs reference processing.

  • Cleanup phase: In this final phase, the G1 GC performs the STW operations of accounting and RSet scrubbing. During accounting, the G1 GC identifies completely free regions and mixed garbage collection candidates. The cleanup phase is partly concurrent when it resets and returns the empty regions to the free list.

Important Defaults

The G1 GC is an adaptive garbage collector with defaults that enable it to work efficiently without modification. Table 10-1, "Default Values of Important Options for G1 Garbage Collector" lists of important options and their default values in Java HotSpot VM, build 24. You can adapt and tune the G1 GC to your application performance needs by entering the options in Table 10-1, "Default Values of Important Options for G1 Garbage Collector" with changed settings on the JVM command line.

Table 10-1 Default Values of Important Options for G1 Garbage Collector

Option and Default Value Option

-XX:G1HeapRegionSize=n

Sets the size of a G1 region. The value will be a power of two and can range from 1 MB to 32 MB. The goal is to have around 2048 regions based on the minimum Java heap size.

-XX:MaxGCPauseMillis=200

Sets a target value for desired maximum pause time. The default value is 200 milliseconds. The specified value does not adapt to your heap size.

-XX:G1NewSizePercent=5

Sets the percentage of the heap to use as the minimum for the young generation size. The default value is 5 percent of your Java heap.Foot1

This is an experimental flag. See How to Unlock Experimental VM Flags for an example. This setting replaces the -XX:DefaultMinNewGenPercent setting.

-XX:G1MaxNewSizePercent=60

Sets the percentage of the heap size to use as the maximum for young generation size. The default value is 60 percent of your Java heap.Footref1

This is an experimental flag. See How to Unlock Experimental VM Flags for an example. This setting replaces the -XX:DefaultMaxNewGenPercent setting.

-XX:ParallelGCThreads=n

Sets the value of the STW worker threads. Sets the value of n to the number of logical processors. The value of n is the same as the number of logical processors up to a value of 8.

If there are more than eight logical processors, sets the value of n to approximately 5/8 of the logical processors. This works in most cases except for larger SPARC systems where the value of n can be approximately 5/16 of the logical processors.

-XX:ConcGCThreads=n

Sets the number of parallel marking threads. Sets n to approximately 1/4 of the number of parallel garbage collection threads (ParallelGCThreads).

-XX:InitiatingHeapOccupancyPercent=45

Sets the Java heap occupancy threshold that triggers a marking cycle. The default occupancy is 45 percent of the entire Java heap.

-XX:G1MixedGCLiveThresholdPercent=85

Sets the occupancy threshold for an old region to be included in a mixed garbage collection cycle. The default occupancy is 85 percent.Footref1

This is an experimental flag. See How to Unlock Experimental VM Flags for an example. This setting replaces the -XX:G1OldCSetRegionLiveThresholdPercent setting.

-XX:G1HeapWastePercent=5

Sets the percentage of heap that you are willing to waste. The Java HotSpot VM does not initiate the mixed garbage collection cycle when the reclaimable percentage is less than the heap waste percentage. The default is 5 percent.Footref1

-XX:G1MixedGCCountTarget=8

Sets the target number of mixed garbage collections after a marking cycle to collect old regions with at most G1MixedGCLIveThresholdPercent live data. The default is 8 mixed garbage collections. The goal for mixed collections is to be within this target number.Footref1

-XX:G1OldCSetRegionThresholdPercent=10

Sets an upper limit on the number of old regions to be collected during a mixed garbage collection cycle. The default is 10 percent of the Java heap.Footref1

-XX:G1ReservePercent=10

Sets the percentage of reserve memory to keep free so as to reduce the risk of to-space overflows. The default is 10 percent. When you increase or decrease the percentage, make sure to adjust the total Java heap by the same amount.Footref1

Footnote1This setting is not available in Java HotSpot VM build 23 or earlier.

How to Unlock Experimental VM Flags

To change the value of experimental flags, you must unlock them first. You can do this by setting -XX:+UnlockExperimentalVMOptions explicitly on the command line before any experimental flags. For example:

java -XX:+UnlockExperimentalVMOptions -XX:G1NewSizePercent=10 -XX:G1MaxNewSizePercent=75 G1test.jar

Recommendations

When you evaluate and fine-tune G1 GC, keep the following recommendations in mind:

  • Young Generation Size: Avoid explicitly setting young generation size with the -Xmn option or any or other related option such as -XX:NewRatio. Fixing the size of the young generation overrides the target pause-time goal.

  • Pause Time Goals: When you evaluate or tune any garbage collection, there is always a latency versus throughput trade-off. The G1 GC is an incremental garbage collector with uniform pauses, but also more overhead on the application threads. The throughput goal for the G1 GC is 90 percent application time and 10 percent garbage collection time. Compare this to the Java HotSpot VM parallel collector. The throughput goal of the parallel collector is 99 percent application time and 1 percent garbage collection time. Therefore, when you evaluate the G1 GC for throughput, relax your pause time target. Setting too aggressive a goal indicates that you are willing to bear an increase in garbage collection overhead, which has a direct effect on throughput. When you evaluate the G1 GC for latency, you set your desired (soft) real-time goal, and the G1 GC will try to meet it. As a side effect, throughput may suffer. See the section Pause Time Goal in Garbage-First Garbage Collector for additional information.

  • Taming Mixed Garbage Collections: Experiment with the following options when you tune mixed garbage collections. See the section Important Defaults for information about these options:

    • -XX:InitiatingHeapOccupancyPercent: Use to change the marking threshold.

    • -XX:G1MixedGCLiveThresholdPercent and -XX:G1HeapWastePercent: Use to change the mixed garbage collection decisions.

    • -XX:G1MixedGCCountTarget and -XX:G1OldCSetRegionThresholdPercent: Use to adjust the CSet for old regions.

Overflow and Exhausted Log Messages

When you see to-space overflow or to-space exhausted messages in your logs, the G1 GC does not have enough memory for either survivor or promoted objects, or for both. The Java heap cannot because it is already at its maximum. Example messages:

  • 924.897: [GC pause (G1 Evacuation Pause) (mixed) (to-space exhausted), 0.1957310 secs]

  • 924.897: [GC pause (G1 Evacuation Pause) (mixed) (to-space overflow), 0.1957310 secs]

To alleviate the problem, try the following adjustments:

  • Increase the value of the -XX:G1ReservePercent option (and the total heap accordingly) to increase the amount of reserve memory for "to-space".

  • Start the marking cycle earlier by reducing the value of -XX:InitiatingHeapOccupancyPercent.

  • Increase the value of the -XX:ConcGCThreads option to increase the number of parallel marking threads.

See the section Important Defaults for a description of these options.

Humongous Objects and Humongous Allocations

For G1 GC, any object that is more than half a region size is considered a humongous object. Such an object is allocated directly in the old generation into humongous regions. These humongous regions are a contiguous set of regions. StartsHumongous marks the start of the contiguous set and ContinuesHumongous marks the continuation of the set.

Before allocating any humongous region, the marking threshold is checked, initiating a concurrent cycle, if necessary.

Dead humongous objects are freed at the end of the marking cycle during the cleanup phase and also during a full garbage collection cycle.

To reduce copying overhead, the humongous objects are not included in any evacuation pause. A full garbage collection cycle compacts humongous objects in place.

Because each individual set of StartsHumongous and ContinuesHumongous regions contains just one humongous object, the space between the end of the humongous object and the end of the last region spanned by the object is unused. For objects that are just slightly larger than a multiple of the heap region size, this unused space can cause the heap to become fragmented.

If you see back-to-back concurrent cycles initiated due to humongous allocations and if such allocations are fragmenting your old generation, then increase the value of -XX:G1HeapRegionSize such that previous humongous objects are no longer humongous and will follow the regular allocation path.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.management.GarbageCollectionNotificationInfo (Monitoring and Management Interface for the Java Platform )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.management.GarbageCollectionNotificationInfo

    • Uses of GarbageCollectionNotificationInfo in com.sun.management

      Methods in com.sun.management that return GarbageCollectionNotificationInfo
      Modifier and Type Method and Description
      static GarbageCollectionNotificationInfo GarbageCollectionNotificationInfo.from(CompositeData cd)
      Returns a GarbageCollectionNotificationInfo object represented by the given CompositeData.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2003, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.management.GarbageCollectorMXBean (Monitoring and Management Interface for the Java Platform )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.management.GarbageCollectorMXBean

No usage of com.sun.management.GarbageCollectorMXBean
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2003, 2015, Oracle and/or its affiliates. All rights reserved.


Garbage Collection Ergonomics

Documentation Contents

Garbage Collector Ergonomics

Note: For Java SE 8 and later, see Java HotSpot Virtual Machine Garbage Collection Tuning Guide.

The following changes take effect with Java SE 5.0.

Garbage Collector of Server VM Changed to Parallel Garbage Collector

On server-class machines running the server VM, the garbage collector (GC) has changed from the previous serial collector (-XX:+UseSerialGC) to a parallel collector (-XX:+UseParallelGC). You can override this default by using the -XX:+UseSerialGC command-line option to the java command.

Initial Heap Size and Maximum Heap Size Changed for Parallel Garbage Collector

On server-class machines running either VM (client or server) with the parallel garbage collector (-XX:+UseParallelGC) the initial heap size and maximum heap size have changed as follows.

initial heap size

Larger of 1/64th of the machine's physical memory on the machine or some reasonable minimum. Before Java SE 5.0, the default initial heap size was a reasonable minimum, which varies by platform. You can override this default using the -Xms command-line option.

maximum heap size

Smaller of 1/4th of the physical memory or 1GB. Before Java SE 5.0, the default maximum heap size was 64MB. You can override this default using the -Xmx command-line option.

Note: The boundaries and fractions given for the heap size are correct for Java SE 5.0. They are likely to be different in subsequent releases as computers get more powerful.

Parallel Garbage Collector Throws Exception if Excessive Amount of Time Spent Collecting Small Amount of Heap

The parallel garbage collector (UseParallelGC) throws an out-of-memory exception if an excessive amount of time is being spent collecting a small amount of the heap. To avoid this exception, you can increase the size of the heap. You can also set the parameters -XX:GCTimeLimit=time-limit and -XX:GCHeapFreeLimit=space-limit where:

time-limit:

The upper limit on the amount of time spent in garbage collection in percent of total time (default is 98).

space-limit:

The lower limit on the amount of space freed during a garbage collection in percent of the maximum heap (default is 2).

Implementation of -XX:+UseAdaptiveSizePolicy Used by Parallel Garbage Collector Changed

The implementation of -XX:+UseAdaptiveSizePolicy used by default with the -XX:+UseParallelGC garbage collector has changed to consider three goals:
  • a desired maximum GC pause goal
  • a desired application throughput goal
  • minimum footprint

The implementation checks (in this order):

  1. If the GC pause time is greater than the pause time goal then reduce the generations sizes to better attain the goal.
  2. If the pause time goal is being met then consider the application's throughput goal. If the application's throughput goal is not being met, then increase the sizes of the generations to better attain the goal.
  3. If both the pause time goal and the throughput goal are being met, then the size of the generations are decreased to reduce footprint.

Flags

-XX:MaxGCPauseMillis=nnn
A hint to the virtual machine that pause times of nnn milliseconds or less are desired. The VM will adjust the java heap size and other GC-related parameters in an attempt to keep GC-induced pauses shorter than nnn milliseconds. Note that this may cause the VM to reduce overall throughput, and in some cases the VM will not be able to meet the desired pause time goal.

By default there is no pause time goal. There are definite limitations on how well a pause time goal can be met. The pause time for a GC depends on the amount of live data in the heap. The minor and major collections depend in different ways on the amount of live data. This parameter should be used with caution. A value that is too small will cause the system to spend an excessive amount of time doing garbage collection.

-XX:GCTimeRatio=nnn
A hint to the virtual machine that it's desirable that not more than 1 / (1 + nnn) of the application execution time be spent in the collector.

For example -XX:GCTimeRatio=19 sets a goal of 5% of the total time for GC and throughput goal of 95%. That is, the application should get 19 times as much time as the collector.

By default the value is 99, meaning the application should get at least 99 times as much time as the collector. That is, the collector should run for not more than 1% of the total time. This was selected as a good choice for server applications. A value that is too high will cause the size of the heap to grow to its maximum.

Suggested strategy

Do not choose a maximum value for the heap unless you know that the heap is greater than the default maximum heap size. Choose a throughput goal that is sufficient for your application.

In an ideal situation the heap will grow to a value (less than the maximum) that will support the chosen throughput goal.

If the heap grows to its maximum, the throughput cannot be met within that maximum. Set the maximum heap as large as you can, but no larger than the size of physical memory on the platform, and execute the application again. If the throughput goal can still not be met, then it is too high for the available memory on the platform.

If the throughput goal can be met but there are pauses that are too long, select a pause time goal. This will likely mean that your throughput goal will not be met, so choose values that are an acceptable compromise for the application.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.management.GcInfo (Monitoring and Management Interface for the Java Platform )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.management.GcInfo

    • Uses of GcInfo in com.sun.management

      Methods in com.sun.management that return GcInfo
      Modifier and Type Method and Description
      static GcInfo GcInfo.from(CompositeData cd)
      Returns a GcInfo object represented by the given CompositeData.
      GcInfo GarbageCollectionNotificationInfo.getGcInfo()
      Returns the GC information related to the last garbage collection
      GcInfo GarbageCollectorMXBean.getLastGcInfo()
      Returns the GC information about the most recent GC.
      Constructors in com.sun.management with parameters of type GcInfo
      Constructor and Description
      GarbageCollectionNotificationInfo(String gcName, String gcAction, String gcCause, GcInfo gcInfo)
      Constructs a GarbageCollectionNotificationInfo object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2003, 2015, Oracle and/or its affiliates. All rights reserved.


JAAS Authorization Tutorial

This tutorial expands the program and policy file developed in the JAAS Authentication tutorial to demonstrate the JAAS authorization component, which ensures the authenticated caller has the access control rights (permissions) required to do subsequent security-sensitive operations. Since the authorization component requires that the user authentication first be completed, please read the JAAS Authentication tutorial first if you have not already done so.

The rest of this tutorial consists of the following sections:

  • What is JAAS Authorization?
  • How is JAAS Authorization Performed?
    • How Do You Make Principal-Based Policy File Statements?
    • How Do You Associate a Subject with an Access Control Context?
  • The Authorization Tutorial Code
  • The Login Configuration File
  • The Policy File
  • Running the Authorization Tutorial Code

If you want to first see the tutorial code in action, you can skip directly to Running the Authorization Tutorial Code and then go back to the other sections to learn more.

What is JAAS Authorization?

JAAS authorization extends the existing Java security architecture that uses a security policy to specify what access rights are granted to executing code. That architecture, introduced in the Java 2 platform, is code-centric. That is, the permissions are granted based on code characteristics: where the code is coming from and whether it is digitally signed and if so by whom. We saw an example of this in the sampleacn.policy file used in the JAAS Authentication tutorial. That file contains the following:

grant codebase "file:./SampleAcn.jar" {

   permission javax.security.auth.AuthPermission
                    "createLoginContext.Sample";
};

This grants the code in the SampleAcn.jar file, located in the current directory, the specified permission. (No signer is specified, so it doesn't matter whether the code is signed or not.)

JAAS authorization augments the existing code-centric access controls with new user-centric access controls. Permissions can be granted based not just on what code is running but also on who is running it.

When an application uses JAAS authentication to authenticate the user (or other entity such as a service), a Subject is created as a result. The purpose of the Subject is to represent the authenticated user. A Subject is comprised of a set of Principals, where each Principal represents an identity for that user. For example, a Subject could have a name Principal ("Susan Smith") and a Social Security Number Principal ("987-65-4321"), thereby distinguishing this Subject from other Subjects.

Permissions can be granted in the policy to specific Principals. After the user has been authenticated, the application can associate the Subject with the current access control context. For each subsequent security-checked operation (a local file access, for example), the Java runtime will automatically determine whether the policy grants the required permission only to a specific Principal and if so, the operation will be allowed only if the Subject associated with the access control context contains the designated Principal.

How is JAAS Authorization Performed?

To make JAAS authorization take place, the following is required:

  • The user must be authenticated, as described in the JAAS Authentication tutorial.
  • Principal-based entries must be configured in the security policy.
  • The Subject that is the result of authentication must be associated with the current access control context.

How Do You Make Principal-Based Policy File Statements?

Policy file grant statements can now optionally include one or more Principal fields. Inclusion of a Principal field indicates that the user or other entity represented by the specified Principal, executing the specified code, has the designated permissions.

Thus, the basic format of a grant statement is now

grant <signer(s) field>, <codeBase URL>
  <Principal field(s)> {
    permission perm_class_name "target_name", "action";
    ....
    permission perm_class_name "target_name", "action";
  };
where each of the signer, codeBase and Principal fields is optional and the order between the fields doesn't matter.

A Principal field looks like the following:

Principal Principal_class "principal_name"

That is, it is the word "Principal" (where case doesn't matter) followed by the (fully qualified) name of a Principal class and a principal name.

A Principal class is a class that implements the java.security.Principal interface. All Principal objects have an associated name that can be obtained by calling their getName method. The format used for the name is dependent on each Principal implementation.

The type of Principal placed in the Subject created by the basic authentication mechanism used by this tutorial is SamplePrincipal, so that is what should be used as the Principal_class part of our grant statement's Principal designation. User names for SamplePrincipals are of the form "name", and the only user name accepted for this tutorial is "testUser", so the principal_name designation to use in the grant statement is "testUser".

It is possible to include more than one Principal field in a grant statement. If multiple Principal fields are specified, then the permissions in that grant statement are granted only if the Subject associated with the current access control context contains all of those Principals.

To grant the same set of permissions to different Principals, create multiple grant statements where each lists the permissions and contains a single Principal field designating one of the Principals.

The policy file for this tutorial includes one grant statement with a Principal field:

grant codebase "file:./SampleAction.jar",
        Principal sample.principal.SamplePrincipal "testUser" {

   permission java.util.PropertyPermission "java.home", "read";
   permission java.util.PropertyPermission "user.home", "read";
   permission java.io.FilePermission "foo.txt", "read";
};

This specifies that the indicated permissions are granted to the specified principal executing the code in SampleAction.jar. (Note: the SamplePrincipal class is in the sample.principal package.)

How Do You Associate a Subject with an Access Control Context?

To create and associate a Subject with the current access control context, you need the following:

  • The user must first be authenticated, as described in JAAS Authentication.
  • The static doAs method from the Subject class must be called, passing it an authenticated Subject and a java.security.PrivilegedAction or java.security.PrivilegedExceptionAction. (See API for Privileged Blocks for a comparison of PrivilegedAction and PrivilegedExceptionAction.) The doAs method associates the provided Subject with the current access control context and then invokes the run method from the action. The run method implementation contains all the code to be executed as the specified Subject. The action thus executes as the specified Subject.

    The static doAsPrivileged method from the Subject class may be called instead of the doAs method, as will be done for this tutorial. In addition to the parameters passed to doAs, doAsPrivileged requires a third parameter: an AccessControlContext. Unlike doAs, which associates the provided Subject with the current access control context, doAsPrivileged associates the Subject with the provided access control context or with an empty access control context if the parameter passed in is null, as is the case for this tutorial. See doAs vs. doAsPrivileged in the JAAS Reference Guide for a comparison of those methods.

The Authorization Tutorial Code

The code for this tutorial consists of four files:

  • SampleAzn.java is exactly the same as the SampleAcn.java application file from the JAAS Authentication tutorial except for the additional code needed to call Subject.doAsPrivileged.
  • SampleAction.java contains the SampleAction class. This class implements PrivilegedAction and has a run method that contains all the code we want to be executed with Principal-based authorization checks.
  • SampleLoginModule.java is the class specified by the tutorial's login configuration file as the class implementing the desired underlying authentication. SampleLoginModule's user authentication consists of simply verifying that the name and password specified by the user have specific values. This class was also used by the JAAS Authentication tutorial and will not be discussed further here.
  • SamplePrincipal.java is a sample class implementing the java.security.Principal interface. It is used by SampleLoginModule. This class was also used by the JAAS Authentication tutorial and will not be discussed further here.

The SampleLoginModule.java and SamplePrincipal.java files were also used in the JAAS Authentication tutorial, so they are not described further here. The other source files are described below.

SampleAzn.java

Like SampleAcn, the SampleAzn class instantiates a LoginContext lc and calls its login method to perform the authentication. If successful, the authenticated Subject (which includes a SamplePrincipal representing the user) is obtained by calling the LoginContext's getSubject method:

Subject mySubject = lc.getSubject();

After providing the user some information about the Subject, such as which Principals it has, the main method then calls Subject.doAsPrivileged, passing it the authenticated Subject mySubject, a PrivilegedAction (SampleAction) and a null AccessControlContext, as described in the following.

The SampleAction class is instantiated via the following:

PrivilegedAction action = new SampleAction();

The call to Subject.doAsPrivileged is performed via:

Subject.doAsPrivileged(mySubject, action, null);

The doAsPrivileged method invokes execution of the run method in the PrivilegedAction action (SampleAction) to initiate execution of the rest of the code, which is considered to be executed on behalf of the Subject mySubject.

Passing null as the AccessControlContext (third) argument to doAsPrivileged indicates that mySubject should be associated with a new empty AccessControlContext. The result is that security checks occurring during execution of SampleAction will only require permissions for the SampleAction code itself (or other code it invokes), running as mySubject. Note that the caller of doAsPrivileged (and the callers on the execution stack at the time doAsPrivileged was called) do not require any permissions while the action executes.

SampleAction.java

SampleAction.java contains the SampleAction class. This class implements java.security.PrivilegedAction and has a run method that contains all the code we want to be executed as the Subject mySubject. For this tutorial, we will perform three operations, each of which cannot be done unless code has been granted required permissions. We will:

  • Read and print the value of the java.home system property,
  • Read and print the value of the user.home system property, and
  • Determine whether or not a file named foo.txt exists in the current directory.

Here is the code:

package sample;

import java.io.File;
import java.security.PrivilegedAction;

public class SampleAction implements PrivilegedAction {

  public Object run() {

    System.out.println("\nYour java.home property value is: "
                + System.getProperty("java.home"));

    System.out.println("\nYour user.home property value is: "
                + System.getProperty("user.home"));

    File f = new File("foo.txt");
    System.out.print("\nfoo.txt does ");
    if (!f.exists())
        System.out.print("not ");
    System.out.println("exist in the current working directory.");
    return null;
  }
}

The Login Configuration File

The login configuration file used for this tutorial can be exactly the same as that used by the JAAS Authentication tutorial. Thus we can use sample_jaas.config, which contains just one entry:

Sample {
  sample.module.SampleLoginModule required debug=true;
};

This entry is named "Sample" and that is the name that both our tutorial applications SampleAcn and SampleAzn use to refer to it. The entry specifies that the LoginModule to be used to do the user authentication is the SampleLoginModule in the sample.module package and that this SampleLoginModule is required to "succeed" in order for authentication to be considered successful. The SampleLoginModule succeeds only if the name and password supplied by the user are the one it expects ("testUser" and "testPassword", respectively).

The SampleLoginModule also defines a "debug" option that can be set to true as shown. If this option is set to true, SampleLoginModule outputs extra information about the progress of authentication.

The Policy File

The application for this authorization tutorial consists of two classes, SampleAzn and SampleAction. The code in each class contains some security-sensitive operations and thus relevant permissions are required in a policy file in order for the operations to be executed.

The LoginModule used by this tutorial, SampleLoginModule, also contains an operation requiring a permission.

The permissions required by each of these classes are described below, followed by a link to the full policy file.

Permissions Required by SampleAzn

The main method of the SampleAzn class does two operations for which permissions are required. It

  • creates a LoginContext, and
  • calls the doAsPrivileged static method of the Subject class.

The LoginContext creation is exactly the same as was done in the authentication tutorial, and it thus needs the same javax.security.auth.AuthPermission permission with target "createLoginContext.Sample".

In order to call the doAsPrivileged method of the Subject class, you need to have a javax.security.auth.AuthPermission with target "doAsPrivileged".

Assuming the SampleAzn class is placed in a JAR file named SampleAzn.jar, these permissions can be granted to the SampleAzn code via the following grant statement in the policy file:

grant codebase "file:./SampleAzn.jar" {
   permission javax.security.auth.AuthPermission
                    "createLoginContext.Sample";
   permission javax.security.auth.AuthPermission "doAsPrivileged";
};

Permissions Required by SampleAction

The SampleAction code does three operations for which permissions are required. It

  • reads the value of the "java.home" system property.
  • reads the value of the "user.home" system property.
  • checks to see whether or not a file named foo.txt exists in the current directory.

The permissions required for these operations are the following:

permission java.util.PropertyPermission "java.home", "read";
permission java.util.PropertyPermission "user.home", "read";
permission java.io.FilePermission "foo.txt", "read";

We need to grant these permissions to the code in SampleAction.class, which we will place in a JAR file named SampleAction.jar. However, for this particular grant statement we want to grant the permissions not just to the code but to a specific user executing the code, to demonstrate how to restrict access to a particular user.

Thus, as explained in How Do You Make Principal-Based Policy File Statements?, our grant statement looks like the following:

grant codebase "file:./SampleAction.jar",
        Principal sample.principal.SamplePrincipal "testUser" {

   permission java.util.PropertyPermission "java.home", "read";
   permission java.util.PropertyPermission "user.home", "read";
   permission java.io.FilePermission "foo.txt", "read";
};

Permissions Required by SampleLoginModule

The SampleLoginModule code does one operation for which permissions are required. It needs a javax.security.auth.AuthPermission with target "modifyPrincipals" in order to populate a Subject with a Principal. The grant statement is the following:

grant codebase "file:./SampleLM.jar" {
    permission javax.security.auth.AuthPermission "modifyPrincipals";
};

The Full Policy File

The full policy file is sampleazn.policy.

Running the Authorization Tutorial Code

To execute our JAAS authorization tutorial code, all you have to do is

  1. Place the following files into a directory:
    • The sample_jaas.config login configuration file.
    • The sampleazn.policy policy file.
  2. Create a subdirectory named "sample" of that top-level directory, and place the following into it (note the SampleAzn and SampleAction classes are in a package named sample):
    • The SampleAzn.java source file.
    • The SampleAction.java source file.
  3. Create a subdirectory of the "sample" directory and name it "module". Place the following into it (note the SampleLoginModule class is in a package named sample.module):
    • the SampleLoginModule.java source file
  4. Create another subdirectory of the "sample" directory and name it "principal". Place the following into it (note the SamplePrincipal class is in a package named sample.principal):
    • the SamplePrincipal.java source file
  5. While in the top-level directory, compile all the source files:
    javac sample/SampleAction.java sample/SampleAzn.java
sample/module/SampleLoginModule.java sample/principal/SamplePrincipal.java
    (Type all that on one line.)
  6. Create a JAR file named SampleAzn.jar containing SampleAzn.class and MyCallbackHandler.class (Note the sources for both these classes are in SampleAzn.java):
    jar -cvf SampleAzn.jar sample/SampleAzn.class
sample/MyCallbackHandler.class

    (Type all that on one line.)

  7. Create a JAR file named SampleAction.jar containing SampleAction.class:
    jar -cvf SampleAction.jar sample/SampleAction.class
  8. Create a JAR file containing SampleLoginModule.class and SamplePrincipal.class:
    jar -cvf SampleLM.jar sample/module/SampleLoginModule.class
sample/principal/SamplePrincipal.class
  9. Execute the SampleAzn application, specifying
    1. by an appropriate -classpath clause that classes should be searched for in the SampleAzn.jar, SampleAction.jar, and SampleLM.jar JAR files,
    2. by -Djava.security.manager that a security manager should be installed,
    3. by -Djava.security.policy==sampleazn.policy that the policy file to be used is sampleazn.policy, and
    4. by -Djava.security.auth.login.config==sample_jaas.config that the login configuration file to be used is sample_jaas.config.

    Below are the full commands to use for both Microsoft Windows and Solaris, Linux, and Mac OS X systems. The only difference is that on Windows systems you use semicolons to separate classpath items, while you use colons for that purpose on Solaris, Linux, and Mac OS X systems.

    Here is the full command for Windows systems:

    java -classpath SampleAzn.jar;SampleAction.jar;SampleLM.jar
 -Djava.security.manager
 -Djava.security.policy==sampleazn.policy
 -Djava.security.auth.login.config==sample_jaas.config sample.SampleAzn

    Here is the full command for Solaris, Linux, and Mac OS X systems:

    java -classpath SampleAzn.jar:SampleAction.jar:SampleLM.jar
 -Djava.security.manager
 -Djava.security.policy==sampleazn.policy
 -Djava.security.auth.login.config==sample_jaas.config sample.SampleAzn

    Type the full command on one line. Multiple lines are used here for legibility. If the command is too long for your system, you may need to place it in a .bat file (for Windows) or a .sh file (for Solaris, Linux, and Mac OS X) and then run that file to execute the command.

    You will be prompted for a user name and password (use "testUser" and "testPassword"), and the SampleLoginModule specified in the login configuration file will check the name and password. If your login is successful, you will see the message "Authentication succeeded!" and if not, you will see "Authentication failed:" followed by a reason for the failure.

    Once authentication is successfully completed, the rest of the program (in SampleAction) will be executed on behalf of you, the user, requiring you to have been granted appropriate permissions. The sampleazn.policy policy file grants you the required permissions, so you will see a display of the values of your java.home and user.home system properties and a statement as to whether or not you have a file named foo.txt in the current directory.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


JAAS Authentication Tutorial

The Java Authentication and Authorization Service (JAAS) was introduced as an optional package in Java SE 1.3. JAAS was integrated into the JDK starting with JDK 1.4.

JAAS can be used for two purposes:

  • for authentication of users, to reliably and securely determine who is currently executing Java code, regardless of whether the code is running as an application, an applet, a bean, or a servlet; and
  • for authorization of users to ensure they have the access control rights (permissions) required to do the actions performed.

This section provides a basic tutorial for the authentication component. The authorization component will be described in the JAAS Authorization Tutorial.

JAAS authentication is performed in a pluggable fashion. This permits Java applications to remain independent from underlying authentication technologies. New or updated technologies can be plugged in without requiring modifications to the application itself. An implementation for a particular authentication technology to be used is determined at runtime. The implementation is specified in a login configuration file. The authentication technology used for this tutorial is very basic, just ensuring that the user specifies a particular name and password.

The rest of this tutorial consists of the following sections:

  1. The Authentication Tutorial Code
  2. The Login Configuration
  3. Running the Code
  4. Running the Code with a Security Manager

If you want to first see the tutorial code in action, you can skip directly to Running the Code and then go back to the other sections to learn about coding and configuration file details.

The Authentication Tutorial Code

The code for this tutorial consists of three files:

  • SampleAcn.java contains the sample application class (SampleAcn) and another class used to handle user input (MyCallbackHandler). The code in this file is the only code you need to understand for this tutorial. Your application will only indirectly use the other source files.
  • SampleLoginModule.java is the class specified by the tutorial's login configuration file as the class implementing the desired underlying authentication. SampleLoginModule's user authentication consists of simply verifying that the name and password specified by the user have specific values.
  • SamplePrincipal.java is a sample class implementing the java.security.Principal interface. It is used by SampleLoginModule.

SampleAcn.java

Our authentication tutorial application code is contained in a single source file, SampleAcn.java. That file contains two classes:

  • The SampleAcn Class
  • The MyCallbackHandler Class

The SampleAcn Class

The main method of the SampleAcn class performs the authentication and then reports whether or not authentication succeeded.

The code for authenticating the user is very simple, consisting of just two steps:

  1. Instantiate a LoginContext.
  2. Call the LoginContext's login method.

First the basic code is shown, followed by a complete listing of the SampleAcn class, complete with the import statement it requires and error handling.

Instantiating a LoginContext

In order to authenticate a user, you first need a javax.security.auth.login.LoginContext. Here is the basic way to instantiate a LoginContext:

import javax.security.auth.login.*;
. . .
LoginContext lc =
    new LoginContext(<config file entry name>,
           <CallbackHandler to be used for user interaction>);
and here is the specific way our tutorial code does the instantiation:
import javax.security.auth.login.*;
. . .
LoginContext lc =
    new LoginContext("Sample",
          new MyCallbackHandler());

The arguments are the following:

  1. The name of an entry in the JAAS login configuration file

    This is the name for the LoginContext to use to look up an entry for this application in the JAAS login configuration file, described here. Such an entry specifies the class(es) that implement the desired underlying authentication technology(ies). The class(es) must implement the LoginModule interface, which is in the javax.security.auth.spi package.

    In our sample code, we use the SampleLoginModule supplied with this tutorial. The SampleLoginModule performs authentication by ensuring that the user types a particular name and password.

    The entry in the login configuration file we use for this tutorial (see sample_jaas.config) has the name "Sample", so that is the name we specify as the first argument to the LoginContext constructor.

  2. A CallbackHandler instance.

    When a LoginModule needs to communicate with the user, for example to ask for a user name and password, it does not do so directly. That is because there are various ways of communicating with a user, and it is desirable for LoginModules to remain independent of the different types of user interaction. Rather, the LoginModule invokes a javax.security.auth.callback.CallbackHandler to perform the user interaction and obtain the requested information, such as the user name and password.

    An instance of the particular CallbackHandler to be used is specified as the second argument to the LoginContext constructor. The LoginContext forwards that instance to the underlying LoginModule (in our case SampleLoginModule). An application typically provides its own CallbackHandler implementation. A simple CallbackHandler, TextCallbackHandler, is provided in the com.sun.security.auth.callback package to output information to and read input from the command line. However, we instead demonstrate the more typical case of an application providing its own CallbackHandler implementation, described in The MyCallbackHandler Class.

Calling the LoginContext's login Method

Once we have a LoginContext lc, we can call its login method to carry out the authentication process:

lc.login();

The LoginContext instantiates a new empty javax.security.auth.Subject object (which represents the user or service being authenticated). The LoginContext constructs the configured LoginModule (in our case SampleLoginModule) and initializes it with this new Subject and MyCallbackHandler.

The LoginContext's login method then calls methods in the SampleLoginModule to perform the login and authentication. The SampleLoginModule will utilize the MyCallbackHandler to obtain the user name and password. Then the SampleLoginModule will check that the name and password are the ones it expects.

If authentication is successful, the SampleLoginModule populates the Subject with a Principal representing the user. The Principal the SampleLoginModule places in the Subject is an instance of SamplePrincipal, which is a sample class implementing the java.security.Principal interface.

See Subjects, Principals, Authentication, and Credentials for information on these terms.

The calling application can subsequently retrieve the authenticated Subject by calling the LoginContext's getSubject method, although doing so is not necessary for this tutorial.

The Complete SampleAcn Class Code

Now that you have seen the basic code required to authenticate the user, we can put it all together into the full class in SampleAcn.java, which includes relevant import statements and error handling:

package sample;

import javax.security.auth.login.*;
// . . . other import statements needed by MyCallbackHandler . . .

/**
 * This Sample application attempts to authenticate a user
 * and reports whether or not the authentication was
 * successful.
 */
public class SampleAcn {

   /**
    * Attempt to authenticate the user.
    *
    * @param args input arguments for this application.
    * These are ignored.
    */
    public static void main(String[] args) {

      // Obtain a LoginContext, needed for authentication.
      // Tell it to use the LoginModule implementation
      // specified by the entry named "Sample" in the
      // JAAS login configuration file and to also use the
      // specified CallbackHandler.
      LoginContext lc = null;
      try {
          lc = new LoginContext("Sample",
                          new MyCallbackHandler());
      } catch (LoginException le) {
          System.err.println("Cannot create LoginContext. "
              + le.getMessage());
          System.exit(-1);
      } catch (SecurityException se) {
          System.err.println("Cannot create LoginContext. "
              + se.getMessage());
          System.exit(-1);
      }

      // the user has 3 attempts to authenticate successfully
      int i;
      for (i = 0; i < 3; i++) {
          try {

              // attempt authentication
              lc.login();

              // if we return with no exception,
              // authentication succeeded
              break;

          } catch (LoginException le) {

              System.err.println("Authentication failed:");
              System.err.println("  " + le.getMessage());
              try {
                  Thread.currentThread().sleep(3000);
              } catch (Exception e) {
                  // ignore
              }

          }
      }

      // did they fail three times?
      if (i == 3) {
          System.out.println("Sorry");
          System.exit(-1);
      }

      System.out.println("Authentication succeeded!");

    }
}

The MyCallbackHandler Class

In some cases a LoginModule must communicate with the user to obtain authentication information. LoginModules use a javax.security.auth.callback.CallbackHandler for this purpose. An application can either use one of the sample implementations provided in the com.sun.security.auth.callback package or, more typically, write a CallbackHandler implementation. The application passes the CallbackHandler as an argument to the LoginContext instantiation. The LoginContext forwards the CallbackHandler directly to the underlying LoginModules.

The tutorial sample code supplies its own CallbackHandler implementation, the MyCallbackHandler class in SampleAcn.java.

CallbackHandler is an interface with one method to implement:

     void handle(Callback[] callbacks)
         throws java.io.IOException, UnsupportedCallbackException;

The LoginModule passes the CallbackHandler handle method an array of appropriate javax.security.auth.callback.Callbacks, for example a NameCallback for the user name and a PasswordCallback for the password, and the CallbackHandler performs the requested user interaction and sets appropriate values in the Callbacks.

The MyCallbackHandler handle method is structured as follows:

public void handle(Callback[] callbacks)
  throws IOException, UnsupportedCallbackException {

  for (int i = 0; i < callbacks.length; i++) {
    if (callbacks[i] instanceof TextOutputCallback) {

      // display a message according to a specified type
      . . .

    } else if (callbacks[i] instanceof NameCallback) {

      // prompt the user for a username
      . . .

    } else if (callbacks[i] instanceof PasswordCallback) {

      // prompt the user for a password
      . . .

    } else {
        throw new UnsupportedCallbackException
         (callbacks[i], "Unrecognized Callback");
    }
  }
}

A CallbackHandler handle method is passed an array of Callback instances, each of a particular type (NameCallback, PasswordCallback, etc.). It must handle each Callback, performing user interaction in a way that is appropriate for the executing application.

MyCallbackHandler handles three types of Callbacks: NameCallback to prompt the user for a user name, PasswordCallback to prompt for a password, and TextOutputCallback to report any error, warning, or other messages the SampleLoginModule wishes to send to the user.

The handle method handles a TextOutputCallback by extracting the message to be reported and then printing it to System.out, optionally preceded by additional wording that depends on the message type. The message to be reported is determined by calling the TextOutputCallback's getMessage method and the type by calling its getMessageType method. Here is the code for handling a TextOutputCallback:

if (callbacks[i] instanceof TextOutputCallback) {

  // display the message according to the specified type
  TextOutputCallback toc = (TextOutputCallback)callbacks[i];
  switch (toc.getMessageType()) {
     case TextOutputCallback.INFORMATION:
        System.out.println(toc.getMessage());
        break;
     case TextOutputCallback.ERROR:
        System.out.println("ERROR: " + toc.getMessage());
        break;
     case TextOutputCallback.WARNING:
        System.out.println("WARNING: " + toc.getMessage());
        break;
     default:
        throw new IOException("Unsupported message type: " +
            toc.getMessageType());
   }

The handle method handles a NameCallback by prompting the user for a user name. It does this by printing the prompt to System.err. It then sets the name for use by the SampleLoginModule by calling the NameCallback's setName method, passing it the name typed by the user:

} else if (callbacks[i] instanceof NameCallback) {

  // prompt the user for a username
  NameCallback nc = (NameCallback)callbacks[i];

  System.err.print(nc.getPrompt());
  System.err.flush();
  nc.setName((new BufferedReader
      (new InputStreamReader(System.in))).readLine());

Similarly, the handle method handles a PasswordCallback by printing a prompt to System.err to prompt the user for a password. It then sets the password for use by the SampleLoginModule by calling the PasswordCallback's setPassword method, passing it the password typed by the user, which it reads by calling the readPassword method (shown below):

} else if (callbacks[i] instanceof PasswordCallback) {

  // prompt the user for sensitive information
  PasswordCallback pc = (PasswordCallback)callbacks[i];

  System.err.print(pc.getPrompt());
  System.err.flush();
  pc.setPassword(readPassword(System.in));

The readPassword method is a basic method for reading a password from an InputStream:

private char[] readPassword(InputStream in) throws IOException {

    char[] lineBuffer;
    char[] buf;
    int i;

    buf = lineBuffer = new char[128];

    int room = buf.length;
    int offset = 0;
    int c;

  loop:
    while (true) {
      switch (c = in.read()) {
         case -1:
         case '\n':
            break loop;

         case '\r':
             int c2 = in.read();
             if ((c2 != '\n') && (c2 != -1)) {
                 if (!(in instanceof PushbackInputStream)) {
                     in = new PushbackInputStream(in);
                 }
                 ((PushbackInputStream)in).unread(c2);
             } else
                 break loop;

         default:
             if (--room < 0) {
                 buf = new char[offset + 128];
                 room = buf.length - offset - 1;
                 System.arraycopy(lineBuffer, 0, buf, 0, offset);
                 Arrays.fill(lineBuffer, ' ');
                 lineBuffer = buf;
             }
             buf[offset++] = (char) c;
             break;
        }
    }

    if (offset == 0) {
        return null;
    }

    char[] ret = new char[offset];
    System.arraycopy(buf, 0, ret, 0, offset);
    Arrays.fill(buf, ' ');

    return ret;
  }
}

SampleLoginModule.java and SamplePrincipal.java

SampleLoginModule.java implements the LoginModule interface. SampleLoginModule is the class specified by the tutorial's login configuration file as the class implementing the desired underlying authentication. SampleLoginModule's user authentication consists of simply verifying that the name and password specified by the user have specific values. This SampleLoginModule is specified by the tutorial's login configuration file as the LoginModule to use because (1) It performs a basic type of authentication suitable for any environment and thus is appropriate for a tutorial for all users, and (2) It provides an example LoginModule implementation for experienced programmers who require the ability to write a LoginModule implementing an authentication technology.

SamplePrincipal.java is a sample class implementing the java.security.Principal interface. If authentication is successful, the SampleLoginModule populates a Subject with a SamplePrincipal representing the user.

Important: If you are an application writer, you do not need to know how to write a LoginModule or a Principal implementation. You do not need to examine the SampleLoginModule or SamplePrincipal code. All you have to know is how to write your application and specify configuration information (such as in a login configuration file) such that the application will be able to utilize the LoginModule specified by the configuration to authenticate the user. You need to determine which LoginModule(s) you want to use and read the LoginModule's documentation to learn about what options you can specify values for (in the configuration) to control the LoginModule's behavior.

Any vendor can provide a LoginModule implementation that you can use. Some implementations are supplied with the JRE from Sun Microsystems, as listed in the JAAS Login Configuration File document.

Information for programmers who want to write a LoginModule can be found in the JAAS LoginModule Developer's Guide.

The Login Configuration

JAAS authentication is performed in a pluggable fashion, so applications can remain independent from underlying authentication technologies. A system administrator determines the authentication technologies, or LoginModules, to be used for each application and configures them in a login Configuration. The source of the configuration information (for example, a file or a database) is up to the current javax.security.auth.login.Configuration implementation. The default Configuration implementation from Sun Microsystems reads configuration information from configuration files, as described in com.sun.security.auth.login.ConfigFile.html.

See JAAS Login Configuration File for information as to what a login configuration file is, what it contains, and how to specify which login configuration file should be used.

The Login Configuration File for This Tutorial

As noted, the login configuration file we use for this tutorial, sample_jaas.config, contains just one entry, which is

Sample {
  sample.module.SampleLoginModule required debug=true;
};

This entry is named "Sample" and that is the name that our tutorial application, SampleAcn, uses to refer to this entry. The entry specifies that the LoginModule to be used to do the user authentication is the SampleLoginModule in the sample.module package and that this SampleLoginModule is required to "succeed" in order for authentication to be considered successful. The SampleLoginModule succeeds only if the name and password supplied by the user are the one it expects ("testUser" and "testPassword", respectively).

The SampleLoginModule also defines a "debug" option that can be set to true as shown. If this option is set to true, SampleLoginModule outputs extra information about the progress of authentication. A LoginModule can define as many options as it wants. The LoginModule documentation should specify the possible option names and values you can set in your configuration file.

Running the Code

To execute our JAAS authentication tutorial code, all you have to do is

  1. Place the following file into a directory:
    • the sample_jaas.config login configuration file
  2. Create a subdirectory named "sample" of that top-level directory, and place the following into it (note the SampleAcn and MyCallbackHandler classes, both in SampleAcn.java, are in a package named sample):
    • the SampleAcn.java application source file
  3. Create a subdirectory of the "sample" directory and name it "module". Place the following into it (note the SampleLoginModule class is in a package named sample.module):
    • the SampleLoginModule.java source file
  4. Create another subdirectory of the "sample" directory and name it "principal". Place the following into it (note the SamplePrincipal class is in a package named sample.principal):
    • the SamplePrincipal.java source file
  5. While in the top-level directory, compile SampleAcn.java, SampleLoginModule.java, and SamplePrincipal.java:
    javac sample/SampleAcn.java sample/module/SampleLoginModule.java
sample/principal/SamplePrincipal.java
    (Type all that on one line.)
  6. Execute the SampleAcn application, specifying
    • by -Djava.security.auth.login.config==sample_jaas.config that the login configuration file to be used is sample_jaas.config.

The full command is below.

java -Djava.security.auth.login.config==sample_jaas.config sample.SampleAcn

You will be prompted for your user name and password, and the SampleLoginModule specified in the login configuration file will check to ensure these are correct. The SampleLoginModule expects "testUser" for the user name and "testPassword" for the password.

You will see some messages output by SampleLoginModule as a result of the debug option being set to true in the login configuration file. Then, if your login is successful, you will see the following message output by SampleAcn:

Authentication succeeded!
If the login is not successful (for example, if you misspell the password), you will see
Authentication failed:
followed by a reason for the failure. For example, if you mistype the password, you may see a message like the following:
Authentication failed:
  Password Incorrect

SampleAcn gives you three chances to successfully log in.

Running the Code with a Security Manager

When a Java program is run with a security manager installed, the program is not allowed to access resources or otherwise perform security-sensitive operations unless it is explicitly granted permission to do so by the security policy in effect. The permission must be granted by an entry in a policy file.

Most browsers install a security manager, so applets typically run under the scrutiny of a security manager. Applications, on the other hand, do not, since a security manager is not automatically installed when an application is running. Thus an application, like our SampleAcn application, by default has full access to resources.

To run an application with a security manager, simply invoke the interpreter with a -Djava.security.manager argument included on the command line.

If you try invoking SampleAcn with a security manager but without specifying any policy file, you will get the following (unless you have a default policy setup elsewhere that grants the required permissions or grants AllPermission):

% java -Djava.security.manager \
 -Djava.security.auth.login.config==sample_jaas.config sample.SampleAcn
Exception in thread "main" java.security.AccessControlException:
  access denied (
  javax.security.auth.AuthPermission createLoginContext.Sample)

As you can see, you get an AccessControlException, because we haven't created and used a policy file granting our code the permission that is required in order to be allowed to create a LoginContext.

Here are the complete steps required in order to be able to run our SampleAcn application with a security manager installed. You can skip the first five steps if you have already done them, as described in Running the Code.

  1. Place the following file into a directory:
    • the sample_jaas.config login configuration file
  2. Create a subdirectory named "sample" of that top-level directory, and place the following into it (note the SampleAcn and MyCallbackHandler classes, both in SampleAcn.java, are in a package named sample):
    • the SampleAcn.java application source file
  3. Create a subdirectory of the "sample" directory and name it "module". Place the following into it (note the SampleLoginModule class is in a package named sample.module):
    • the SampleLoginModule.java source file
  4. Create another subdirectory of the "sample" directory and name it "principal". Place the following into it (note the SamplePrincipal class is in a package named sample.principal):
    • the SamplePrincipal.java source file
  5. While in the top-level directory, compile SampleAcn.java, SampleLoginModule.java, and SamplePrincipal.java:
    javac sample/SampleAcn.java sample/module/SampleLoginModule.java
sample/principal/SamplePrincipal.java
    (Type all that on one line.)
  6. Create a JAR file containing SampleAcn.class and MyCallbackHandler.class:
    jar -cvf SampleAcn.jar sample/SampleAcn.class
sample/MyCallbackHandler.class

    (Type all that on one line.) This command creates a JAR file, SampleAcn.jar, and places the SampleAcn.class and MyCallbackHandler.class files inside it.

  7. Create a JAR file containing SampleLoginModule.class and SamplePrincipal.class:
    jar -cvf SampleLM.jar sample/module/SampleLoginModule.class
sample/principal/SamplePrincipal.class
  8. Create a policy file granting the required permissions.

    The permission that is needed by code attempting to instantiate a LoginContext is a javax.security.auth.AuthPermission with target "createLoginContext.<entry name>". Here, <entry name> refers to the name of the login configuration file entry that the application references in its instantiation of LoginContext. The name used by our SampleAcn application's LoginContext instantiation is "Sample", as you can see in the code:

    LoginContext lc =
    new LoginContext("Sample",
          new MyCallbackHandler());

    Thus, the permission that needs to be granted to SampleAcn.jar is

    permission javax.security.auth.AuthPermission
  "createLoginContext.Sample";

    The SampleLM.jar file also needs to be granted a permission. The documentation for a LoginModule should tell you what permissions it needs to be granted. In the case of SampleLoginModule, it needs a javax.security.auth.AuthPermission with target "modifyPrincipals" in order to populate a Subject with a Principal:

    permission javax.security.auth.AuthPermission
  "modifyPrincipals";

    Copy the policy file sampleacn.policy to the same directory as that in which you stored SampleAcn.java, etc. The policy file contains the following grant statement to grant SampleAcn.jar (in the current directory) its required permission:

    grant codebase "file:./SampleAcn.jar" {
   permission javax.security.auth.AuthPermission
                    "createLoginContext.Sample";
};

    The policy file also contains the following grant statement to grant SampleLM.jar (also in the current directory) its required permission:

    grant codebase "file:./SampleLM.jar" {
   permission javax.security.auth.AuthPermission
                    "modifyPrincipals";
};

    Note: Policy files and the structure of entries within them are described in Default Policy Implementation and Policy File Syntax. Permissions are described here.

  9. Execute the SampleAcn application, specifying
    1. by an appropriate -classpath clause that classes should be searched for in the SampleAcn.jar and SampleLM.jar JAR files,
    2. by -Djava.security.manager that a security manager should be installed,
    3. by -Djava.security.policy==sampleacn.policy that the policy file to be used is sampleacn.policy, and
    4. by -Djava.security.auth.login.config==sample_jaas.config that the login configuration file to be used is sample_jaas.config.

    Below are the full commands to use for both Microsoft Windows and Solaris, Linux, and Mac OS X systems. The only difference is that on Microsoft Windows systems you use semicolons to separate classpath items, while you use colons for that purpose on Solaris, Linux, and Mac OS X systems.

    Here is the full command for Microsoft Windows systems:

    java -classpath SampleAcn.jar;SampleLM.jar
 -Djava.security.manager
 -Djava.security.policy==sampleacn.policy \
 -Djava.security.auth.login.config==sample_jaas.config \
 sample.SampleAcn

    Here is the full command for Solaris, Linux, and Mac OS X systems:

    java -classpath SampleAcn.jar:SampleLM.jar
 -Djava.security.manager
 -Djava.security.policy==sampleacn.policy \
 -Djava.security.auth.login.config==sample_jaas.config \
 sample.SampleAcn

    Type all that on one line. Multiple lines are used here for legibility. If the command is too long for your system, you may need to place it in a .bat file (for Microsoft Windows) or a .sh file (for Solaris, Linux, and Mac OS X) and then run that file to execute the command.

    Since the specified policy file contains an entry granting the code the required permissions, execution should proceed without any exceptions indicating a required permission was not granted. You will be prompted for a user name and password (use "testUser" and "testPassword"), and the SampleLoginModule specified in the login configuration file will check the name and password. If your login is successful, you will see the message "Authentication succeeded!" and if not, you will see "Authentication failed:" followed by a reason for the failure.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

Part I

General Java Troubleshooting

This part describes general Java troubleshooting techniques and contains the following topics.

  • Prepare Java for Troubleshooting

    Provides guidelines for setting up both Java and a Java application for better troubleshooting techniques. These proactive Java setups help debug and narrow down issues with Java and a Java application.

  • Diagnostic Tools

    Describes various diagnostic and monitoring tools used with Java Development Kit (JDK). Further describes the troubleshooting tools available for JDK 8 and explains custom tools development using application programming interfaces (APIs).

  • Troubleshoot Memory Leaks

    Provides suggestions for diagnosing problems involving possible memory leaks.

  • Troubleshoot Performance Issues Using JFR

    Identifies performance issues with a Java application and debugs issues using the Java Flight Recorder.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Generations

Documentation Contents
Java Platform, Standard Edition HotSpot Virtual Machine Garbage Collection Tuning Guide
Contents Previous Next

3 Generations

One strength of the Java SE platform is that it shields the developer from the complexity of memory allocation and garbage collection. However, when garbage collection is the principal bottleneck, it is useful to understand some aspects of this hidden implementation. Garbage collectors make assumptions about the way applications use objects, and these are reflected in tunable parameters that can be adjusted for improved performance without sacrificing the power of the abstraction.

An object is considered garbage when it can no longer be reached from any pointer in the running program. The most straightforward garbage collection algorithms iterate over every reachable object. Any objects left over are considered garbage. The time this approach takes is proportional to the number of live objects, which is prohibitive for large applications maintaining lots of live data.

The virtual machine incorporates a number of different garbage collection algorithms that are combined using generational collection. While naive garbage collection examines every live object in the heap, generational collection exploits several empirically observed properties of most applications to minimize the work required to reclaim unused (garbage) objects. The most important of these observed properties is the weak generational hypothesis, which states that most objects survive for only a short period of time.

The blue area in Figure 3-1, "Typical Distribution for Lifetimes of Objects" is a typical distribution for the lifetimes of objects. The x-axis is object lifetimes measured in bytes allocated. The byte count on the y-axis is the total bytes in objects with the corresponding lifetime. The sharp peak at the left represents objects that can be reclaimed (in other words, have "died") shortly after being allocated. Iterator objects, for example, are often alive for the duration of a single loop.

Figure 3-1 Typical Distribution for Lifetimes of Objects

Description of Figure 3-1 follows
Description of "Figure 3-1 Typical Distribution for Lifetimes of Objects"

Some objects do live longer, and so the distribution stretches out to the right. For instance, there are typically some objects allocated at initialization that live until the process exits. Between these two extremes are objects that live for the duration of some intermediate computation, seen here as the lump to the right of the initial peak. Some applications have very different looking distributions, but a surprisingly large number possess this general shape. Efficient collection is made possible by focusing on the fact that a majority of objects "die young."

To optimize for this scenario, memory is managed in generations (memory pools holding objects of different ages). Garbage collection occurs in each generation when the generation fills up. The vast majority of objects are allocated in a pool dedicated to young objects (the young generation), and most objects die there. When the young generation fills up, it causes a minor collection in which only the young generation is collected; garbage in other generations is not reclaimed. Minor collections can be optimized, assuming that the weak generational hypothesis holds and most objects in the young generation are garbage and can be reclaimed. The costs of such collections are, to the first order, proportional to the number of live objects being collected; a young generation full of dead objects is collected very quickly. Typically, some fraction of the surviving objects from the young generation are moved to the tenured generation during each minor collection. Eventually, the tenured generation will fill up and must be collected, resulting in a major collection, in which the entire heap is collected. Major collections usually last much longer than minor collections because a significantly larger number of objects are involved.

As noted in the section Ergonomics, ergonomics selects the garbage collector dynamically to provide good performance on a variety of applications. The serial garbage collector is designed for applications with small data sets, and its default parameters were chosen to be effective for most small applications. The parallel or throughput garbage collector is meant to be used with applications that have medium to large data sets. The heap size parameters selected by ergonomics plus the features of the adaptive size policy are meant to provide good performance for server applications. These choices work well in most, but not all, cases, which leads to the central tenet of this document:

Note:

If garbage collection becomes a bottleneck, you will most likely have to customize the total heap size as well as the sizes of the individual generations. Check the verbose garbage collector output and then explore the sensitivity of your individual performance metric to the garbage collector parameters.

Figure 3-2, "Default Arrangement of Generations, Except for Parallel Collector and G1" shows the default arrangement of generations (for all collectors with the exception of the parallel collector and G1):

Figure 3-2 Default Arrangement of Generations, Except for Parallel Collector and G1

Description of Figure 3-2 follows
Description of "Figure 3-2 Default Arrangement of Generations, Except for Parallel Collector and G1"

At initialization, a maximum address space is virtually reserved but not allocated to physical memory unless it is needed. The complete address space reserved for object memory can be divided into the young and tenured generations.

The young generation consists of eden and two survivor spaces. Most objects are initially allocated in eden. One survivor space is empty at any time, and serves as the destination of any live objects in eden; the other survivor space is the destination during the next copying collection. Objects are copied between survivor spaces in this way until they are old enough to be tenured (copied to the tenured generation).

Performance Considerations

There are two primary measures of garbage collection performance:

  • Throughput is the percentage of total time not spent in garbage collection considered over long periods of time. Throughput includes time spent in allocation (but tuning for speed of allocation is generally not needed).

  • Pauses are the times when an application appears unresponsive because garbage collection is occurring.

Users have different requirements of garbage collection. For example, some consider the right metric for a web server to be throughput because pauses during garbage collection may be tolerable or simply obscured by network latencies. However, in an interactive graphics program, even short pauses may negatively affect the user experience.

Some users are sensitive to other considerations. Footprint is the working set of a process, measured in pages and cache lines. On systems with limited physical memory or many processes, footprint may dictate scalability. Promptness is the time between when an object becomes dead and when the memory becomes available, an important consideration for distributed systems, including Remote Method Invocation (RMI).

In general, choosing the size for a particular generation is a trade-off between these considerations. For example, a very large young generation may maximize throughput, but does so at the expense of footprint, promptness, and pause times. Young generation pauses can be minimized by using a small young generation at the expense of throughput. The sizing of one generation does not affect the collection frequency and pause times for another generation.

There is no one right way to choose the size of a generation. The best choice is determined by the way the application uses memory as well as user requirements. Thus the virtual machine's choice of a garbage collector is not always optimal and may be overridden with command-line options described in the section Sizing the Generations.

Measurement

Throughput and footprint are best measured using metrics particular to the application. For example, the throughput of a web server may be tested using a client load generator, whereas the footprint of the server may be measured on the Solaris operating system using the pmap command. However, pauses due to garbage collection are easily estimated by inspecting the diagnostic output of the virtual machine itself.

The command-line option -verbose:gc causes information about the heap and garbage collection to be printed at each collection. For example, here is output from a large server application:

[GC 325407K->83000K(776768K), 0.2300771 secs]
[GC 325816K->83372K(776768K), 0.2454258 secs]
[Full GC 267628K->83769K(776768K), 1.8479984 secs]

The output shows two minor collections followed by one major collection. The numbers before and after the arrow (for example, 325407K->83000K from the first line) indicate the combined size of live objects before and after garbage collection, respectively. After minor collections, the size includes some objects that are garbage (no longer alive) but cannot be reclaimed. These objects are either contained in the tenured generation or referenced from the tenured generation.

The next number in parentheses (for example, (776768K) again from the first line) is the committed size of the heap: the amount of space usable for Java objects without requesting more memory from the operating system. Note that this number only includes one of the survivor spaces. Except during a garbage collection, only one survivor space will be used at any given time to store objects.

The last item on the line (for example, 0.2300771 secs) indicates the time taken to perform the collection, which is in this case approximately a quarter of a second.

The format for the major collection in the third line is similar.

Note:

The format of the output produced by -verbose:gc is subject to change in future releases.

The command-line option -XX:+PrintGCDetails causes additional information about the collections to be printed. An example of the output with -XX:+PrintGCDetails using the serial garbage collector is shown here.

[GC [DefNew: 64575K->959K(64576K), 0.0457646 secs] 196016K->133633K(261184K), 0.0459067 secs]

This indicates that the minor collection recovered about 98% of the young generation, DefNew: 64575K->959K(64576K) and took 0.0457646 secs (about 45 milliseconds).

The usage of the entire heap was reduced to about 51% (196016K->133633K(261184K)), and there was some slight additional overhead for the collection (over and above the collection of the young generation) as indicated by the final time of 0.0459067 secs.

Note:

The format of the output produced by -XX:+PrintGCDetails is subject to change in future releases.

The option -XX:+PrintGCTimeStamps adds a time stamp at the start of each collection. This is useful to see how frequently garbage collections occur.

111.042: [GC 111.042: [DefNew: 8128K->8128K(8128K), 0.0000505 secs]111.042: [Tenured: 18154K->2311K(24576K), 0.1290354 secs] 26282K->2311K(32704K), 0.1293306 secs]

The collection starts about 111 seconds into the execution of the application. The minor collection starts at about the same time. Additionally, the information is shown for a major collection delineated by Tenured. The tenured generation usage was reduced to about 10% (18154K->2311K(24576K)) and took 0.1290354 secs (approximately 130 milliseconds).

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of Figure Differences Between Generators and Factories

Link to figure Differences Between Generators and Factories

This figure consists of two diagrams:

Generators

This diagram contains the following caption: Generators — Generate new objects based on initialization parameters

It consists of boxes labeled as follows:

  • Initialization Parameters (Key Length)
  • Generator
  • Object Secret Key

Unlabeled arrows connect these boxes:

  • From Initialization Parameters (Key Length) to Generator
  • From Generator to Object Secret Key

Factories

This diagram contains the following caption: Factories — Transform existing specific objects into other object types

It consists of boxes labeled as follows:

  • Type 1 Key Spec
  • Factory
  • Type 2 Secret Key

Unlabeled arrows connect these boxes:

  • From Type 1 Key Spec to Factory
  • From Factory to Type 2 Secret Key
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Generics

When you take an element out of a Collection, you must cast it to the type of element that is stored in the collection. Besides being inconvenient, this is unsafe. The compiler does not check that your cast is the same as the collection's type, so the cast can fail at run time.

Generics provides a way for you to communicate the type of a collection to the compiler, so that it can be checked. Once the compiler knows the element type of the collection, the compiler can check that you have used the collection consistently and can insert the correct casts on values being taken out of the collection.

Here is a simple example taken from the existing Collections tutorial:

// Removes 4-letter words from c. Elements must be strings
static void expurgate(Collection c) {
    for (Iterator i = c.iterator(); i.hasNext(); )
      if (((String) i.next()).length() == 4)
        i.remove();
}

Here is the same example modified to use generics:

// Removes the 4-letter words from c
static void expurgate(Collection<String> c) {
    for (Iterator<String> i = c.iterator(); i.hasNext(); )
      if (i.next().length() == 4)
        i.remove();
}

When you see the code <Type>, read it as "of Type"; the declaration above reads as "Collection of String c." The code using generics is clearer and safer. We have eliminated an unsafe cast and a number of extra parentheses. More importantly, we have moved part of the specification of the method from a comment to its signature, so the compiler can verify at compile time that the type constraints are not violated at run time. Because the program compiles without warnings, we can state with certainty that it will not throw a ClassCastException at run time. The net effect of using generics, especially in large programs, is improved readability and robustness.

To paraphrase Generics Specification Lead Gilad Bracha, when we declare c to be of type Collection<String>, this tells us something about the variable c that holds true wherever and whenever it is used, and the compiler guarantees it (assuming the program compiles without warnings). A cast, on the other hand, tells us something the programmer thinks is true at a single point in the code, and the VM checks whether the programmer is right only at run time.

While the primary use of generics is collections, there are many other uses. "Holder classes," such as WeakReference and ThreadLocal, have all been generified, that is, they have been retrofitted to make use of generics. More surprisingly, class Class has been generified. Class literals now function as type tokens, providing both run-time and compile-time type information. This enables a style of static factories exemplified by the getAnnotation method in the new AnnotatedElement interface:

    <T extends Annotation> T getAnnotation(Class<T> annotationType);
This is a generic method. It infers the value of its type parameter T from its argument, and returns an appropriate instance of T, as illustrated by the following snippet:
    Author a = Othello.class.getAnnotation(Author.class);
Prior to generics, you would have had to cast the result to Author. Also you would have had no way to make the compiler check that the actual parameter represented a subclass of Annotation.

Generics are implemented by type erasure: generic type information is present only at compile time, after which it is erased by the compiler. The main advantage of this approach is that it provides total interoperability between generic code and legacy code that uses non-parameterized types (which are technically known as raw types). The main disadvantages are that parameter type information is not available at run time, and that automatically generated casts may fail when interoperating with ill-behaved legacy code. There is, however, a way to achieve guaranteed run-time type safety for generic collections even when interoperating with ill-behaved legacy code.

The java.util.Collections class has been outfitted with wrapper classes that provide guaranteed run-time type safety. They are similar in structure to the synchronized and unmodifiable wrappers. These "checked collection wrappers" are very useful for debugging. Suppose you have a set of strings, s, into which some legacy code is mysteriously inserting an integer. Without the wrapper, you will not find out about the problem until you read the problem element from the set, and an automatically generated cast to String fails. At this point, it is too late to determine the source of the problem. If, however, you replace the declaration:

    Set<String> s = new HashSet<String>();
with this declaration:
    Set<String> s = Collections.checkedSet(new HashSet<String>(), String.class);
the collection will throw a ClassCastException at the point where the legacy code attempts to insert the integer. The resulting stack trace will allow you to diagnose and repair the problem.

You should use generics everywhere you can. The extra effort in generifying code is well worth the gains in clarity and type safety. It is straightforward to use a generic library, but it requires some expertise to write a generic library, or to generify an existing library. There is one caveat: You may not use generics (or any other Tiger features) if you intend to deploy the compiled code on a pre-5.0 virtual machine.

If you are familiar with C++'s template mechanism, you might think that generics are similar, but the similarity is superficial. Generics do not generate a new class for each specialization, nor do they permit "template metaprogramming."

There is much more to learn about generics. See the Generics lesson in the Java Tutorials.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Subjects, Principals, Authentication, and Credentials

To authorize access to resources, applications first need to authenticate the source of the request. The JAAS framework defines the term subject to represent the source of a request. A subject may be any entity, such as a person or service. A subject is represented by the javax.security.auth.Subject class.

Authentication represents the process by which the identity of a subject is verified, and must be performed in a secure fashion; otherwise a perpetrator may impersonate others to gain access to a system. Authentication typically involves the subject demonstrating some form of evidence to prove its identity. Such evidence may be information only the subject would likely know or have (such as a password or fingerprint), or it may be information only the subject could produce (such as signed data using a private key).

Once authenticated, a Subject is populated with associated identities, or Principals (of type java.security.Principal). A Subject may have many Principals. For example, a person may have a name Principal ("John Doe") and an SSN Principal ("123-45-6789"), which distinguish it from other Subjects.

In addition to associated Principals, a Subject may own security-related attributes, which are referred to as credentials. A credential may contain information used to authenticate the subject to new services. Such credentials include passwords, Kerberos tickets, and public key certificates. Credentials might also contain data that simply enables the subject to perform certain activities. Cryptographic keys, for example, represent credentials that enable the subject to sign or encrypt data. Public and private credential classes are not part of the core JAAS class library. Any class, therefore, can represent a credential.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 2 - Goals

Documentation Contents
CONTENTS | PREV | NEXT

CHAPTER 2

Goals

2.1 API Goals

The design of the Image I/O API was influenced by the desire to support a number of primary goals. Each goal provides the justification for a particular set of API features. These goals may be divided into those motivated mainly by the needs of client-side applications, and those motivated by the needs of server applications. Naturally, these primary goals represent only a fraction of the capabilities of the API. They are listed here in order to provide a sense of the motivations that went into the design of the API.

As a general rule of thumb, whenever a tradeoff between ease of use for application developers and plug-in developers was identified, the application developer was given a higher priority. Since relatively few users of the API are expected to write plug-ins, and even those developers who do write plug-ins will typically write no more than a handful in order to support formats of immediate use to them, it makes sense to push complexity into the plug-ins rather than into applications.

To ameliorate the complexity of plug-in development, some utility methods and implementation classes are provided that perform common functions. However, it is not possible to provide implementation classes to cover every situation, and providing an excessive number of utility classes and methods would increase the footprint for all API users even if they did not use non-standard plug-ins. We expect that plug-in developers will be able to incorporate source code from existing plug-ins and sample code into their plug-ins. While this might lead to some redundancy when using multiple, independently developed plug-ins, most users will probably use only a small number of plug-ins at a time in any case. Thus, we believe the cost of having to load code that might theoretically be shared but actually is not will tend to outweight the cost of loading some redundant code when many plug-ins are used.

2.1.1 Client-Side Application Goals

Pluggability An application written to use the Image I/O API should be able to automatically take advantage of new plug-ins without any rewriting or recompilation. This requires that plug-ins follow, as much as possible, a set of format-neutral interfaces. However, every image format has unique properties and capabilities, which plug-ins must be able to expose to applications. This is accomplished by allowing plug-ins to extend a number of interfaces within the API. Applications that are unaware of the plug-in specific extensions may continue to make use of the normal plug-in capabilities, while aware applications may use the extended interfaces.

Both generic and plug-in specific access to metadata (non-image data) is supported by allowing plug-ins to provide access to metadata in multiple formats. These may include plug-in specific formats, a plug-in neutral format defined by the API, and industry standard formats.

Automatic and Manual Plug-in Installation and Selection For simple applications that wish to load images without user intervention, it is important to allow a reader plug-in to be selected automatically based on file contents. However, it is desirable to avoid the loading and instantiation of complex classes unless they are needed. A plug-in must be able to determine whether it can handle a particular image without loading all of its code. In order to meet this goal, plug-ins are instantiated via a service provider interface mechanism that allows simple queries to be performed without loading the main body of plug-in code.

All of the bytecode (.class) files associated with a plug-in may be combined into a JAR file, which may be installed permanently into a Java Runtime Environment, or loaded dynamically using the application CLASSPATH mechanism.

Manual Plug-in Selection Although automatic plug-in selection is convenient for many applications, it must be possible for more sophisticated applications to exercise greater control over the plug-in selection process. This is accomplished by means of a run-time registry of plug-ins that may be queried and manipulated by an application.

Network, Disk-based, and Direct I/O Increasingly, applications must deal with both disk-based and network-based data. In many cases, even disk-based data must be dealt with in the form of an InputStream due to the needs of other APIs. The Image I/O API offers a set of interfaces that allow data from Files, InputStreams, or other sources to be handled in a unified manner while preserving the ability to seek backwards and forwards. The API is future-proofed to allow new I/O interfaces, including direct interfaces to image acquisition and output devices, to be used without rewriting application code.

Access to Metadata The metadata stored alongside an image may be as important as the image data. The Java Image I/O API provides thorough yet flexible access to metadata. Since metadata may take many forms, and contain very specialized information, it is difficult to provide direct access to such metadata in a general-purpose API. Instead, the API requires plug-ins to cast their metadata into the form of an XML Document structure, possibly enhanced with Object references in addition to textual data. Once this has been done, the metadata may be accessed and edited using standard XML DOM (Document Object Model) interfaces. The syntax of the Documents will vary from plug-in to plug-in, but the structure may be traversed, displayed, and edited without specific knowledge of the plug-in being used.

Support for Advanced Applications In order to support advanced applications, the API must provide access to features such as "thumbnail" images, multiple images stored in a file, muli-resolution imagery, and tiled imagery. It must provide the capability to decode portions of a larger image, and to perform subsampling during decoding in order to allow panning over very large images. When writing images, it must be possible to write image data piece-by-piece, without storing the entire image in memory at once.

2.1.2 Server Use Cases

Dynamic image generation Modern web servers typically generate a large portion of their content dynamically. The Java Servlet and Java Server Pages (JSP) APIs provide portable ways to generate HTML pages in response to requests from web browsers. Just as unique, custom HTML may be generated for each user, it is possible to customize image content.

In many cases, image content must be generated dynamically. For example, consider supplying stock price charts. While it might be possible to generate and store a limited set of charts for each listed stock in advance, if the user is allowed to add customizations such as the time interval over which the price should be displayed, or a set of indices or other stocks against which the stock price should be compared, the number of possible images grows exponentially. Only a dynamic approach can possibly allow such customization.

Image Customization Web images are typically one-size-fits-all, with the same image data being delivered regardless of the display capabilities of the receiver. The increasing use of wireless and handheld devices will require images that are customized for their limited bandwidth and display capabilities. Desktop computers have seen increases in their display resolution, causing many web images to appear too small. The lack of scalable images also causes problems for visually impaired users. Server-side image customization can be used to provide optimal images for all users, with the image resolution and color characteristics being chosen based on user preferences.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Java Image I/O API Guide: 2 - Goals

Documentation Contents
CONTENTS | PREV | NEXT

2.2 Non-Goals

Thread Safety A particular instance of an ImageReader or ImageWriter is not required to support re-entrant (simultaneous) calls to its methods (with the exception of the abort method that requests current read or writes to halt). However, it must be possible for multiple instances of the same plug-in class to operate simultaneously. For the sake of brevity, we will only discuss reader plug-ins below.

Supporting full re-entrancy would require that the reader bundle all of its state information (e.g., the current input source) into a separate state object, which would allow methods in progress to continue to work with the settings that were in effect at the time they began, while allowing a separate thread to modify the state to be used by the next operation.

Rather than forcing each ImageReader to keep track of its state in this way, it is simpler to require the application to instantiate multiple instances of the same ImageReader class if it wishes to perform multithreaded processing. This means that the state of an ImageReader must be maintained using non-static instance variables only, which should not be a burden for plug-in developers.

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started with Java IDL: Developing a Client Application

This topic introduces the basics of writing a CORBA client application. Included in this lesson are:

  1. Creating HelloClient.java
  2. Understanding HelloClient.java
  3. Compiling HelloClient.java

Creating HelloClient.java

To create HelloClient.java,

  1. Start your text editor and create a file named HelloClient.java in your main project directory, Hello.
  2. Enter the following code for HelloClient.java in the text file. The following section, Understanding HelloClient.java, explains each line of code in some detail.

    HelloClient.java

    // Copyright and License

import HelloApp.*;
import org.omg.CosNaming.*;
import org.omg.CosNaming.NamingContextPackage.*;
import org.omg.CORBA.*;

public class HelloClient
{
  static Hello helloImpl;

  public static void main(String args[])
    {
      try{
        // create and initialize the ORB
        ORB orb = ORB.init(args, null);

        // get the root naming context
        org.omg.CORBA.Object objRef =
            orb.resolve_initial_references("NameService");
        // Use NamingContextExt instead of NamingContext. This is
        // part of the Interoperable naming Service.
        NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

        // resolve the Object Reference in Naming
        String name = "Hello";
        helloImpl = HelloHelper.narrow(ncRef.resolve_str(name));

        System.out.println("Obtained a handle on server object: " + helloImpl);
        System.out.println(helloImpl.sayHello());
        helloImpl.shutdown();

        } catch (Exception e) {
          System.out.println("ERROR : " + e) ;
          e.printStackTrace(System.out);
          }
    }

}

  3. Save and close HelloClient.java.

Understanding HelloClient.java

This section explains each line of HelloClient.java, describing what the code does, as well as why it is needed for this application.

Performing Basic Setup

The basic shell of a CORBA client is the same as many Java applications: You import required library packages, declare the application class, define a main method, and handle exceptions.

Importing Required Packages

First, we import the packages required for the client class:

import HelloApp.*; // the package containing our stubs
import org.omg.CosNaming.*; // HelloClient will use the Naming Service
import org.omg.CosNaming.NamingContextPackage.*;
import org.omg.CORBA.*; // All CORBA applications need these classes

Declaring the Client Class

The next step is to declare the client class:

public class HelloClient
{
  // The main() method goes here.
}

Defining a main() Method

Every Java application needs a main() method. It is declared within the scope of the HelloClient class, as follows:

  public static void main(String args[])
  {
    // The try-catch block goes here.
  }

Handling CORBA System Exceptions

Because all CORBA programs can throw CORBA system exceptions at runtime, all of the main() functionality is placed within a try-catch block. CORBA programs throw system exceptions whenever trouble occurs during any of the processes (marshaling, unmarshaling, upcall) involved in invocation.

Our exception handler simply prints the name of the exception and its stack trace to standard output so you can see what kind of thing has gone wrong.

The try-catch block is set up inside main(),

    try{

      // Add the rest of the HelloClient code here.

    } catch(Exception e) {
        System.out.println("ERROR : " + e);
        e.printStackTrace(System.out);
      }

Creating an ORB Object

A CORBA client needs a local ORB object to perform all of its marshaling and IIOP work. Every client instantiates an org.omg.CORBA.ORB object and initializes it by passing to the object certain information about itself.

The ORB variable is declared and initialized inside the try-catch block.

        ORB orb = ORB.init(args, null);

The call to the ORB's init() method passes in your application's command line arguments, allowing you to set certain properties at runtime.

Finding the Hello Server

Now that the application has an ORB, it can ask the ORB to locate the actual service it needs, in this case the Hello server. There are a number of ways for a CORBA client to get an initial object reference; our client application will use the COS Naming Service specified by OMG and provided with Java IDL. See Using Stringified Object References for information on how to get an initial object reference when there is no naming service available.

The two options for Naming Services are orbd (Solaris, Linux, or Mac OS X or Windows), which is a daemon process containing a Bootstrap Service, a Transient Naming Service, a Persistent Naming Service, and a Server Manager, and tnameserv, a transient naming service. This example uses orbd.

Obtaining the Initial Naming Context

The first step in using the naming service is to get the initial naming context. In the try-catch block, below your ORB initialization, you call orb.resolve_initial_references() to get an object reference to the name server:

        org.omg.CORBA.Object objRef =
            orb.resolve_initial_references("NameService");

The string "NameService" is defined for all CORBA ORBs. When you pass in that string, the ORB returns the initial naming context, an object reference to the name service. The string "NameService" indicates:

  • The persistent naming service will be used when using ORBD as the naming service.
  • The transient naming service will be used when using tnameserv as the naming service.

The string "TNameService" indicates that the transient naming service will be used when ORBD is the naming service. In this example, we are using the persistent naming service that is a part of orbd.

Narrowing the Object Reference

As with all CORBA object references, objRef is a generic CORBA object. To use it as a NamingContextExt object, you must narrow it to its proper type.

        NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

Here we see the use of an idlj-generated helper class, similar in function to HelloHelper. The ncRef object is now an org.omg.CosNaming.NamingContextExt and you can use it to access the naming service and find other services. You will do that in the next step.

The NamingContextExt object is new to J2SE v.1.4, and is part of the Interoperable Naming Service.

Resolve the Object Reference in Naming

To publish a reference in the Naming Service to the Hello object implementing the Hello interface, you first need an identifying string for the Hello object.

      String name = "Hello";

Finally, we pass name to the naming service's resolve_str() method to get an object reference to the Hello server and narrow it to a Hello object:

        helloImpl = HelloHelper.narrow(ncRef.resolve-str(name));
        System.out.println("Obtained a handle on server object: " + helloImpl);

Here you see the HelloHelper helper class at work. The resolve-str() method returns a generic CORBA object as you saw above when locating the name service itself. Therefore, you immediately narrow it to a Hello object, which is the object reference you need to perform the rest of your work. Then, you send a message to the screen confirming that the object reference has been obtained.

Invoking the sayHello() Operation

CORBA invocations look like a method call on a local object. The complications of marshaling parameters to the wire, routing them to the server-side ORB, unmarshaling, and placing the upcall to the server method are completely transparent to the client programmer. Because so much is done for you by generated code, invocation is really the easiest part of CORBA programming.

Finally, we print the results of the invocation to standard output and explicitly shutdown the ORB:

        System.out.println(helloImpl.sayHello());
        helloImpl.shutdown();

Compiling HelloClient.java

Now we will compile HelloClient.java so that we can correct any errors before continuing with this tutorial.

Windows users note that you should substitute backslashes (\) for the slashes (/) in all paths in this document.

To compile HelloClient.java,

  1. Change to the Hello directory.
  2. Run the Java compiler on HelloClient.java:
    javac HelloClient.java HelloApp/*.java
  3. Correct any errors in your file and recompile if necessary.
  4. The HelloClient.class is generated to the Hello directory.

Running the Client Application

Running the Hello World application is covered in Running the Hello World Application.

For More Information

Developing Clients
Covers topics of interest to CORBA client programmers
Exceptions: System Exceptions
Explains how CORBA system exceptions work and provides details on the minor codes of Java IDL's system exceptions
Naming Service
Covers the COS Naming Service in greater detail
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started with Java IDL: Running the Hello World Application

Documentation Contents

Getting Started with Java IDL
Running the Hello World Application

This topic walks you through running the server and client program that together make up the "Hello World" application.

Running the Hello World Application

Despite its simple design, the Hello World program lets you learn and experiment with all the tasks required to develop almost any CORBA program that uses static invocation.

This example requires a naming service to make the servant object's operations available to clients. The server needs an object reference to the naming service so that it can publish the references to the objects implementing various interfaces. These object references are used by the clients for invoking methods. The two options for Naming Services shipped with Java SE are tnameserv, a transient naming service, and orbd (a href= "../../../tools/unix/orbd.html">Solaris, Linux, or Mac OS X or Windows), which is a daemon process containing a Bootstrap Service, a Transient Naming Service, a Persistent Naming Service, and a Server Manager. This example uses orbd.

When running this example, remember that, when using Solaris software, you must become root to start a process on a port under 1024. For this reason, we recommend that you use a port number greater than or equal to 1024. The -ORBInitialPort option is used to override the default port number in this example. The following instructions assume you can use port 1050 for the Java IDL Object Request Broker Daemon, orbd. You can substitute a different port if necessary. When running these examples on a Windows machine, subtitute a backslash (\) in path names.

To run this client-server application on your development machine:

  1. Start orbd.

    To start orbd from a Solaris, Linux, or Mac OS X command shell, enter:

      orbd -ORBInitialPort 1050 -ORBInitialHost localhost&

    From an MS-DOS system prompt (Windows), enter:

      start orbd -ORBInitialPort 1050 -ORBInitialHost localhost

    Note that 1050 is the port on which you want the name server to run. -ORBInitialPort is a required command-line argument. Note that when using Solaris software, you must become root to start a process on a port under 1024. For this reason, we recommend that you use a port number greater than or equal to 1024.

    Note that -ORBInitialHost is also a required command-line argument. For this example, since both client and server on running on the development machine, we have set the host to localhost. When developing on more than one machine, you will replace this with the name of the host. For an example of how to run this program on two machines, see The Hello World Example on Two Machines.

  2. Start the Hello server.

    To start the Hello server from a Solaris, Linux, or Mac OS X command shell, enter:

      java HelloServer -ORBInitialPort 1050 -ORBInitialHost localhost&

    From an MS-DOS system prompt (Windows), enter:

      start java HelloServer -ORBInitialPort 1050 -ORBInitialHost localhost

    For this example, you can omit -ORBInitialHost localhost since the name server is running on the same host as the Hello server. If the name server is running on a different host, use -ORBInitialHost nameserverhost to specify the host on which the IDL name server is running.

    Specify the name server (orbd) port as done in the previous step, for example, -ORBInitialPort 1050.

  3. Run the client application:
      java HelloClient -ORBInitialPort 1050 -ORBInitialHost localhost

    For this example, you can omit -ORBInitialHost localhost since the name server is running on the same host as the Hello client. If the name server is running on a different host, use -ORBInitialHost nameserverhost to specify the host on which the IDL name server is running.

    Specify the name server (orbd) port as done in the previous step, for example, -ORBInitialPort 1050.

  4. The client prints the string from the server to the command line:
    Hello world!!

The name server, like many CORBA servers, runs until you explicitly stop it. To avoid having many servers running, kill the name server process after the client application returns successfully. To do this from a DOS prompt, select the window that is running the server and enter Ctrl+C to shut it down. To do this from a Solaris, Linux, or Mac OS X shell, find the process, and kill it.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started with Java IDL

Java IDL is a technology for distributed objects – that is, objects interacting on different platforms across a network. Java IDL enables objects to interact regardless of whether they're written in the Java programming language or another language such as C, C++, COBOL, or others.

This is possible because Java IDL is based on the Common Object Request Brokerage Architecture (CORBA), an industry-standard distributed object model. A key feature of CORBA is IDL, a language-neutral Interface Definition Language. Each language that supports CORBA has its own IDL mapping--and as its name implies, Java IDL supports the mapping for Java. To learn more about the IDL-to-Java language mapping, see IDL-to-Java Language Mapping.

To support interaction between objects in separate programs, Java IDL provides an Object Request Broker, or ORB. The ORB is a class library that enables low-level communication between Java IDL applications and other CORBA-compliant applications.

This tutorial teaches the basic tasks needed to build a CORBA distributed application using Java IDL. You will build the classic "Hello World" program as a distributed application. The Hello World program has a single operation that returns a string to be printed.

Any relationship between distributed objects has two sides: the client and the server. The server provides a remote interface, and the client calls a remote interface. These relationships are common to most distributed object standards, including Java Remote Method Invocation (RMI, RMI-IIOP) and CORBA. Note that in this context, the terms client and server define object-level rather than application-level interaction--any application could be a server for some objects and a client of others. In fact, a single object could be the client of an interface provided by a remote object and at the same time implement an interface to be called remotely by other objects.

This figure shows how a one-method distributed object is shared between a CORBA client and server to implement the classic "Hello World" application.

A one-method distributed object shared between a CORBA client and server.

On the client side, the application includes a reference for the remote object. The object reference has a stub method, which is a stand-in for the method being called remotely. The stub is actually wired into the ORB, so that calling it invokes the ORB's connection capabilities, which forwards the invocation to the server.

On the server side, the ORB uses skeleton code to translate the remote invocation into a method call on the local object. The skeleton translates the call and any parameters to their implementation-specific format and calls the method being invoked. When the method returns, the skeleton code transforms results or errors, and sends them back to the client via the ORBs.

Between the ORBs, communication proceeds by means of a shared protocol, IIOP--the Internet Inter-ORB Protocol. IIOP, which is based on the standard TCP/IP internet protocol, defines how CORBA-compliant ORBs pass information back and forth. Like CORBA and IDL, the IIOP standard is defined by OMG, the Object Management Group.

The Java IDL Development Process and the Hello World Tutorial

This tutorial teaches the basic tasks in building a CORBA distributed application using Java IDL. You will build the classic "Hello World" program as a distributed application. The "Hello World" program has a single operation that returns a string to be printed.

Despite its simple design, the Hello World program lets you learn and experiment with all the tasks required to develop almost any CORBA program that uses static invocation. The following steps provide a general guide to designing and developing a distributed object application with Java IDL. Links to the relevant steps of the tutorial will guide you through creating this sample application.

  1. Define the remote interface

    You define the interface for the remote object using the OMG's Interface Definition Langauge (IDL). You use IDL instead of the Java language because the idlj compiler automatically maps from IDL, generating all Java language stub and skeleton source files, along with the infrastructure code for connecting to the ORB. Also, by using IDL, you make it possible for developers to implement clients and servers in any other CORBA-compliant language.

    Note that if you're implementing a client for an existing CORBA service, or a server for an existing client, you would get the IDL interfaces from the implementer--such as a service provider or vendor. You would then run the idlj compiler over those interfaces and follow these steps.

    Writing the IDL file in this tutorial walks you through defining the remote interface for the simple "Hello World" example.

  2. Compile the remote interface

    When you run the idlj compiler over your interface definition file, it generates the Java version of the interface, as well as the class code files for the stubs and skeletons that enable your applications to hook into the ORB.

    Mapping Hello.idl to Java in this tutorial walks you through these steps for the simple "Hello World" example.

  3. Implement the server

    Once you run the idlj compiler, you can use the skeletons it generates to put together your server application. In addition to implementing the methods of the remote interface, your server code includes a mechanism to start the ORB and wait for invocation from a remote client.

    Developing the Hello World Server walks you through writing a simple server for the "Hello World" application.

  4. Implement the client

    Similarly, you use the stubs generated by the idlj compiler as the basis of your client application. The client code builds on the stubs to start its ORB, look up the server using the name service provided with Java IDL, obtain a reference for the remote object, and call its method.

    Developing a Client Application walks you through writing a simple client application.

  5. Start the applications

    Once you implement a server and a client, you can start the name service, then start the server, then run the client.

    Running the Hello World Application walks you through running the server and client program that together make up the "Hello World" application, and the name service that enables them to find one another.

Using Stringified Object References walks you through making an object reference when there is no naming service.

Running the Hello World Application on Two Machines describes one way of distributing the simple application across two machines - a client and a server.

For More Information

Although concepts are explained as they are introduced in the tutorial, you will find more information in the Concepts section. New terms are linked to their definitions throughout the tutorial.

The Object Management Group no longer maintains this site, but the CORBA for Beginnners page contains links to web pages that provide introductory CORBA information.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started with Java IDL: Writing the Interface Definition

Documentation Contents

Getting Started with Java IDL:
Writing the Interface Definition

Before you start working with Java IDL, you need to install version 1.4 (or later) of the Java platform. Version 1.4 (and later) provides the Application Programming Interface (API) and Object Request Broker (ORB) needed to enable CORBA-based distributed object interaction, as well as the idlj compiler. The idlj compiler uses the IDL-to-Java language mapping to convert IDL interface definitions to corresponding Java interfaces, classes, and methods, which you can then use to implement your client and server code.

This section teaches you how to write a simple IDL interface definition and how to translate the IDL interface to Java. It also describes the purpose of each file generated by the idlj compiler.

These topics are included in this section:

  1. Writing Hello.idl
  2. Understanding the IDL file
  3. Mapping Hello.idl to Java
  4. Understanding the idlj Compiler Output

Writing Hello.idl

To create the Hello.idl file,
  1. Create a new directory, named Hello, for this application.
  2. Start your favorite text editor and create a file named Hello.idl in this directory.
  3. In your file, enter the code for the interface definition, Hello.idl:
    module HelloApp
{
  interface Hello
  {
    string sayHello();
    oneway void shutdown();
  };
};
  4. Save the file.

Understanding the IDL file

OMG IDL is the language used to describe the interfaces that client objects call and object implementations provide. An interface definition written in OMG IDL completely defines the interface and fully specifies each operation's parameters. An OMG IDL interface provides the information needed to develop clients that use the interface's operations.

Clients are written in languages for which mappings from OMG IDL concepts have been defined. The mapping of an OMG IDL concept to a client language construct will depend on the facilities available in the client language. OMG specifies a mapping from IDL to several different programming languages, including C, C++, Smalltalk, COBOL, Ada, Lisp, Python, and Java. When mapped, each statement in OMG IDL is translated to a corresponding statement in the programming language of choice.

For example, you could use the tool idlj to map an IDL interface to Java and implement the client class. When you mapped the same IDL to C++ and implemented the server in that language, the Java client (through the Java ORB) and C++ server (through the C++ ORB) interoperate as though they were written in the same language.

The IDL for "Hello World" is extremely simple; its single interface has but two operations. You need perform only three steps:

  1. Declare the CORBA IDL module
  2. Declare the interface
  3. Declare the operations

Declaring the CORBA IDL Module

A CORBA module is a namespace that acts as a container for related interfaces and declarations. It corresponds closely to a Java package. Each module statement in an IDL file is mapped to a Java package statement.

The module statement looks like this:

module HelloApp
{
    // Subsequent lines of code here.
};

When you compile the IDL, the module statement will generate a package statement in the Java code.

Declaring the Interface

Like Java interfaces, CORBA interfaces declare the API contract an object has with other objects. Each interface statement in the IDL maps to a Java interface statement when mapped.

In your Hello.idl file, the interface statement looks like this:

module HelloApp
{
  interface Hello  // These lines
  {                // declare the
                   // interface
  };               // statement.
};

When you compile the IDL, this statement will generate an interface statement in the Java code.

Declaring the Operations

CORBA operations are the behavior that servers promise to perform on behalf of clients that invoke them. Each operation statement in the IDL generates a corresponding method statement in the generated Java interface.

In your Hello.idl file, the operation statement looks like this:

module HelloApp
{
  interface Hello
  {
    string sayHello();        // This line is an operation statement.
    oneway void shutdown();   // This line is another
  };
};
The interface definition for our little "Hello World" application is now complete.

Mapping Hello.idl to Java

The tool idlj reads OMG IDL files and creates the required Java files. The idlj compiler defaults to generating only the client-side bindings. If you need both client-side bindings and server-side skeletons (as you do for our "Hello World" program), you must use the -fall option when running the idlj compiler. For more information on compiler options, see the idlj man page (Solaris, Linux, or Mac OS X or Windows).

The default server-side mapping generated when either the -fall or -fserver arguments are used conform to Chapter 11, Portable Object Adapter (POA) of the CORBA 2.3.1 Specification (formal/99-10-07). For more information on the POA, see Portable Object Adapter.

The advantages of using the Portable Object Adaptor (POA) are:

  • Allow programmers to construct object implementations that are portable between different ORB products.
  • Provide support for objects with persistent identities.
  • Provide support for transparent activation of objects.
  • Allow a single servant to support multiple object identities simultaneously.
  1. Make sure that the jdk/bin directory (or the directory containing idlj, java, javac, and orbd) are in your path.
  2. Go to a command line prompt.
  3. Change to the directory containing your Hello.idl file.
  4. Enter the compiler command:

        idlj -fall Hello.idl

If you list the contents of the directory, you will see that a directory called HelloApp has been created and that it contains six files. Open Hello.java in your text editor. Hello.java is the signature interface and is used as the signature type in method declarations when interfaces of the specified type are used in other interfaces. It looks like this:

//Hello.java
package HelloApp;

/**
* HelloApp/Hello.java
* Generated by the IDL-to-Java compiler (portable), version "3.0"
* from Hello.idl
*/

public interface Hello extends HelloOperations, org.omg.CORBA.Object,
org.omg.CORBA.portable.IDLEntity
{
} // interface Hello

With an interface this simple, it is easy to see how the IDL statements map to the generated Java statements.

IDL Statement | Java Statement
module HelloApp | package HelloApp;
interface Hello | public interface Hello

The single surprising item is the extends statement. All CORBA objects are derived from org.omg.CORBA.Object to ensure required CORBA functionality. The required code is generated by idlj; you do not need to do any mapping yourself.

In previous versions of the idlj compiler (known as idltojava), the operations defined on the IDL interface would exist in this file as well. Starting with J2SDK v1.3.0, in conformance with the CORBA 2.3.1 Specification (formal/99-10-07), the IDL-to-Java mapping puts all of the operations defined on the IDL interface in the operations interface, HelloOperations.java. The operations interface is used in the server-side mapping and as a mechanism for providing optimized calls for co-located clients and servers. For Hello.idl, this file looks like this:

//HelloOperations.java
package HelloApp;

/**
* HelloApp/HelloOperations.java
* Generated by the IDL-to-Java compiler (portable), version "3.0"
* from Hello.idl
*/

public interface HelloOperations
{
  String sayHello ();
  void Shutdown ();
} // interface HelloOperations

Because there are only two operations defined in this interface, it is easy to see how the IDL statements map to the generated Java statements.

IDL Statement | Java Statement
string sayHello(); | String sayHello();
oneway void shutdown(); | void Shutdown ();

Understanding the idlj Compiler Output

The idlj compiler generates a number of files. The actual number of files generated depends on the options selected when the IDL file is compiled. The generated files provide standard functionality, so you can ignore them until it is time to deploy and run your program. Under J2SE v.1.4, the files generated by the idlj compiler for Hello.idl, with the -fall command line option, are:

  • HelloPOA.java

    This abstract class is the stream-based server skeleton, providing basic CORBA functionality for the server. It extends org.omg.PortableServer.Servant, and implements the InvokeHandler interface and the HelloOperations interface. The server class, HelloServant, extends HelloPOA.

  • _HelloStub.java

    This class is the client stub, providing CORBA functionality for the client. It extends org.omg.CORBA.portable.ObjectImpl and implements the Hello.java interface.

  • Hello.java

    This interface contains the Java version of our IDL interface. The Hello.java interface extends org.omg.CORBA.Object, providing standard CORBA object functionality. It also extends the HelloOperations interface and org.omg.CORBA.portable.IDLEntity.

  • HelloHelper.java

    This class provides auxiliary functionality, notably the narrow() method required to cast CORBA object references to their proper types. The Helper class is responsible for reading and writing the data type to CORBA streams, and inserting and extracting the data type from Anys. The Holder class delegates to the methods in the Helper class for reading and writing.

  • HelloHolder.java

    This final class holds a public instance member of type Hello. Whenever the IDL type is an out or an inout parameter, the Holder class is used. It provides operations for org.omg.CORBA.portable.OutputStream and org.omg.CORBA.portable.InputStream arguments, which CORBA allows, but which do not map easily to Java's semantics. The Holder class delegates to the methods in the Helper class for reading and writing. It implements org.omg.CORBA.portable.Streamable.

  • HelloOperations.java

    This interface contains the methods sayHello() and shutdown(). The IDL-to-Java mapping puts all of the operations defined on the IDL interface into this file, which is shared by both the stubs and skeletons.

When you write the IDL interface, you do all the programming required to generate all these files for your distributed application. The next steps are to implement the client and server classes. In the steps that follow, you will create the HelloClient.java client class and the HelloServer.java server class.

Troubleshooting

  • Error Message: "idlj" not found

    If you try to run idlj on the file Hello.idl and the system cannot find idlj, it is most likely not in your path. Make certain that the location of idlj (the JDK bin directory) is in your path, and try again.

For More Information

  • IDL to Java Language Mapping Overview

    Provides the basics for mapping IDL constructs to the corresponding Java statements.

  • Chapter 3 of the OMG CORBA 2.3.1 specification, formal/99-10-07

    Provides the complete specification for OMG Interface Definition Language. The specification can be downloaded from formal/99-10-07.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started with Java IDL: Developing the Hello World Server

Documentation Contents

Getting Started with Java IDL:
Developing the Hello World Server

The example server consists of two classes, the servant and the server. The servant, HelloImpl, is the implementation of the Hello IDL interface; each Hello instance is implemented by a HelloImpl instance. The servant is a subclass of HelloPOA, which is generated by the idlj compiler from the example IDL.

The servant contains one method for each IDL operation, in this example, the sayHello() and shutdown() methods. Servant methods are just like ordinary Java methods; the extra code to deal with the ORB, with marshaling arguments and results, and so on, is provided by the skeleton.

The server class has the server's main() method, which:

  • Creates and initializes an ORB instance
  • Gets a reference to the root POA and activates the POAManager
  • Creates a servant instance (the implementation of one CORBA Hello object) and tells the ORB about it
  • Gets a CORBA object reference for a naming context in which to register the new CORBA object
  • Gets the root naming context
  • Registers the new object in the naming context under the name "Hello"
  • Waits for invocations of the new object from the client

This lesson introduces the basics of writing a CORBA server. For an example of the "Hello World" program with a persistent object server, see Example 2: Hello World with Persistent State. For more discussion of CORBA servers, see Developing Servers.

The steps in this lesson cover:

  1. Creating HelloServer.java
  2. Understanding HelloServer.java
  3. Compiling the Hello World Server

Creating HelloServer.java

To create HelloServer.java,

  1. Start your text editor and create a file named HelloServer.java in your main project directory, Hello.
  2. Enter the following code for HelloServer.java in the text file. The following section, Understanding HelloServer.java, explains each line of code in some detail.
    // HelloServer.java
import HelloApp.*;
import org.omg.CosNaming.*;
import org.omg.CosNaming.NamingContextPackage.*;
import org.omg.CORBA.*;
import org.omg.PortableServer.*;
import org.omg.PortableServer.POA;

import java.util.Properties;

class HelloImpl extends HelloPOA {
  private ORB orb;

  public void setORB(ORB orb_val) {
    orb = orb_val;
  }

  // implement sayHello() method
  public String sayHello() {
    return "\nHello world !!\n";
  }

  // implement shutdown() method
  public void shutdown() {
    orb.shutdown(false);
  }
}

public class HelloServer {

  public static void main(String args[]) {
    try{
      // create and initialize the ORB
      ORB orb = ORB.init(args, null);

      // get reference to rootpoa and activate the POAManager
      POA rootpoa = POAHelper.narrow(orb.resolve_initial_references("RootPOA"));
      rootpoa.the_POAManager().activate();

      // create servant and register it with the ORB
      HelloImpl helloImpl = new HelloImpl();
      helloImpl.setORB(orb);

      // get object reference from the servant
      org.omg.CORBA.Object ref = rootpoa.servant_to_reference(helloImpl);
      Hello href = HelloHelper.narrow(ref);

      // get the root naming context
      org.omg.CORBA.Object objRef =
          orb.resolve_initial_references("NameService");
      // Use NamingContextExt which is part of the Interoperable
      // Naming Service (INS) specification.
      NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

      // bind the Object Reference in Naming
      String name = "Hello";
      NameComponent path[] = ncRef.to_name( name );
      ncRef.rebind(path, href);

      System.out.println("HelloServer ready and waiting ...");

      // wait for invocations from clients
      orb.run();
    }

      catch (Exception e) {
        System.err.println("ERROR: " + e);
        e.printStackTrace(System.out);
      }

      System.out.println("HelloServer Exiting ...");

  }
}

  3. Save and close HelloServer.java.

Understanding HelloServer.java

This section explains each line of HelloServer.java, describing what the code does, as well as why it is needed for this application.

Performing Basic Setup

The structure of a CORBA server program is the same as most Java applications: You import required library packages, declare the server class, define a main() method, and handle exceptions.

Importing Required Packages

First, we import the packages required for the server class:

// The package containing our stubs
import HelloApp.*;

// HelloServer will use the naming service
import org.omg.CosNaming.*;

// The package containing special exceptions thrown by the name service
import org.omg.CosNaming.NamingContextPackage.*;

// All CORBA applications need these classes
import org.omg.CORBA.*;

// Classes needed for the Portable Server Inheritance Model
import org.omg.PortableServer.*;
import org.omg.PortableServer.POA;

// Properties to initiate the ORB
import java.util.Properties;

Defining the Servant Class

In this example, we are defining the class for the servant object within HelloServer.java, but outside the HelloServer class.

class HelloImpl extends HelloPOA
{
  // The sayHello() and shutdown() methods go here.
}

The servant is a subclass of HelloPOA so that it inherits the general CORBA functionality generated for it by the compiler.

First, we create a private variable, orb that is used in the setORB(ORB) method. The setORB method is a private method defined by the application developer so that they can set the ORB value with the servant. This ORB value is used to invoke shutdown() on that specific ORB in response to the shutdown() method invocation from the client.

  private ORB orb;

  public void setORB(ORB orb_val) {
    orb = orb_val;
  }

Next, we declare and implement the required sayHello() method:

  public String sayHello()
  {
    return "\nHello world!!\n";
  }

And last of all, we implement the shutdown() method in a similar way. The shutdown() method calls the org.omg.CORBA.ORB.shutdown(boolean) method for the ORB. The shutdown(false) operation indicate that the ORB should shut down immediately, without waiting for processing to complete.

  public void shutdown() {
    orb.shutdown(false);
  }

Declaring the Server Class

The next step is to declare the server class:

public class HelloServer
{
  // The main() method goes here.
}

Defining the main() Method

Every Java application needs a main method. It is declared within the scope of the HelloServer class:

  public static void main(String args[])
  {
    // The try-catch block goes here.
  }

Handling CORBA System Exceptions

Because all CORBA programs can throw CORBA system exceptions at runtime, all of the main() functionality is placed within a try-catch block. CORBA programs throw runtime exceptions whenever trouble occurs during any of the processes (marshaling, unmarshaling, upcall) involved in invocation. The exception handler simply prints the exception and its stack trace to standard output so you can see what kind of thing has gone wrong.

The try-catch block is set up inside main(), as shown:

    try{

      // The rest of the HelloServer code goes here.

    } catch(Exception e) {
        System.err.println("ERROR: " + e);
        e.printStackTrace(System.out);
      }

Creating and Initializing an ORB Object

A CORBA server needs a local ORB object, as does the CORBA client. Every server instantiates an ORB and registers its servant objects so that the ORB can find the server when it receives an invocation for it.

The ORB variable is declared and initialized inside the try-catch block.

      ORB orb = ORB.init(args, null);

The call to the ORB's init() method passes in the server's command line arguments, allowing you to set certain properties at runtime.

Get a Reference to the Root POA and Activate the POAManager

The ORB obtains the initial object references to services such as the Name Service using the method resolve_initial_references.

The reference to the root POA is retrieved and the POAManager is activated from within the try-catch block.

      POA rootpoa = POAHelper.narrow(orb.resolve_initial_references("RootPOA"));
      rootpoa.the_POAManager().activate();

The activate() operation changes the state of the POA manager to active, causing associated POAs to start processing requests. The POA manager encapsulates the processing state of the POAs with which it is associated. Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects.

Managing the Servant Object

A server is a process that instantiates one or more servant objects. The servant inherits from the interface generated by idlj and actually performs the work of the operations on that interface. Our HelloServer needs a HelloImpl.

Instantiating the Servant Object

We instantiate the servant object inside the try-catch block, just after activating the POA manager, as shown:

      HelloImpl helloImpl = new HelloImpl();

The section of code describing the servant class was explained previously.

In the next line of code, setORB(orb) is defined on the servant so that ORB.shutdown() can be called as part of the shutdown operation. This step is required because of the shutdown() method defined in Hello.idl.

      helloImpl.setORB(orb);

There are other options for implementing the shutdown operation. In this example, the shutdown() method called on the Object takes care of shutting down an ORB. In another implementation, the shutdown method implementation could have simply set a flag, which the server could have checked and called shutdown().

The next set of code is used to get the object reference associated with the servant. The narrow() method is required to cast CORBA object references to their proper types.

      org.omg.CORBA.Object ref = rootpoa.servant_to_reference(helloImpl);
      Hello href = HelloHelper.narrow(ref);

Working with COS Naming

The HelloServer works with the Common Object Services (COS) Naming Service to make the servant object's operations available to clients. The server needs an object reference to the naming service so that it can publish the references to the objects implementing various interfaces. These object references are used by the clients for invoking methods. Another way a servant can make the objects available to clients for invocations is by stringifying the object references to a file.

The two options for Naming Services are:

  • orbd (Solaris, Linux, or Mac OS X or Windows), which includes both a Transient Naming Service and a Persistent Naming Service, in addition to a Server Manager.
  • tnameserv (Solaris, Linux, or Mac OS X or Windows) - a Transient Naming Service.

This example uses orbd.

Obtaining the Initial Naming Context

In the try-catch block, below getting the object reference for the servant, we call orb.resolve_initial_references() to get an object reference to the name server:

      org.omg.CORBA.Object objRef =
          orb.resolve_initial_references("NameService");

The string "NameService" is defined for all CORBA ORBs. When you pass in that string, the ORB returns a naming context object that is an object reference for the name service. The string "NameService" indicates:

  • The naming service will be persistent when using ORBD's naming service, as we do in this example.
  • The naming service will be transient when using tnameserv.

The proprietary string "TNameService" indicates that the naming service will be transient when using ORBD's naming service.

Narrowing the Object Reference

As with all CORBA object references, objRef is a generic CORBA object. To use it as a NamingContextExt object, you must narrow it to its proper type. The call to narrow() is just below the previous statement:

      NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

Here you see the use of an idlj-generated helper class, similar in function to HelloHelper. The ncRef object is now an org.omg.CosNaming.NamingContextExt and you can use it to access the naming service and register the server, as shown in the next topic.

The NamingContextExt object is part of the Interoperable Naming Service specification.

Registering the Servant with the Name Server

Just below the call to narrow(), we create a new NameComponent array. Because the path to Hello has a single element, we create the single-element array that NamingContext.resolve requires for its work:

      String name = "Hello";
      NameComponent path[] = ncRef.to_name( name );

Finally, we pass path and the servant object to the naming service, binding the servant object to the "Hello" id:

      ncRef.rebind(path, href);

Now, when the client calls resolve("Hello") on the initial naming context, the naming service returns an object reference to the Hello servant.

Waiting for Invocation

The previous sections describe the code that makes the server ready; the next section explains the code that enables it to simply wait around for a client to request its service. The following code, which is at the end of (but within) the try-catch block, shows how to accomplish this.

      orb.run();

When called by the main thread, ORB.run() enables the ORB to perform work using the main thread, waiting until an invocation comes from the ORB. Because of its placement in main(), after an invocation completes and sayHello() returns, the server will wait again. This is the reason that the HelloClient explicitly shuts down the ORB after completing its task.

Compiling the Hello World Server

Now we will compile the HelloServer.java so that we can correct any errors before continuing with this tutorial.

Windows users note that you should substitute backslashes (\) for the slashes (/) in all paths in this document.

To compile HelloServer.java,

  1. Change to the Hello directory.
  2. Run the Java compiler on HelloServer.java:
    javac HelloServer.java HelloApp/*.java
  3. Correct any errors in your file and recompile if necessary.
  4. The files HelloServer.class and HelloImpl.class are generated in the Hello directory.

Running the Hello World Server

Running the Hello World Application discusses running HelloServer and the rest of the application.

Understanding The Server-Side Implementation Models

CORBA supports at least two different server-side mappings for implementing an IDL interface:

  • The Inheritance Model

    Using the Inheritance Model, you implement the IDL interface using an implementation class that also extends the compiler-generated skeleton.

    Inheritance models include:

    • The OMG-standard, POA. Given an interface My defined in My.idl, the file MyPOA.java is generated by the idlj compiler. You must provide the implementation for My and it must inherit from MyPOA, a stream-based skeleton that extends org.omg.PortableServer.Servant, which serves as the base class for all POA servant implementations.

      The default server-side mapping generated when either the -fall or -fserver arguments are used conform to Chapter 11, Portable Object Adapter (POA) of the CORBA 2.3.1 Specification (formal/99-10-07). For more information on the POA, see Portable Object Adapter.

      The advantages of using the Portable Object Adaptor (POA) are:

      • Allow programmers to construct object implementations that are portable between different ORB products.
      • Provide support for objects with persistent identities.
      • Provide support for transparent activation of objects.
      • Allow a single servant to support multiple object identities simultaneously.
    • ImplBase. Given an interface My defined in My.idl, the file _MyImplBase.java is generated. You must provide the implementation for My and it must inherit from _MyImplBase.

      NOTE: ImplBase is obsoleted in favor of the POA model, but is provided to allow compatibility with servers written in J2SE 1.3 and prior. We do not recommend creating new servers using this nonstandard model.

  • The Delegation Model

    Using the Delegation Model, you implement the IDL interface using two classes:

    • An IDL-generated Tie class that inherits from the compiler-generated skeleton, but delegates all calls to an implementation class.
    • A class that implements the IDL-generated operations interface (such as HelloOperations), which defines the IDL function.

    The Delegation model is also known as the Tie model, or the Tie Delegation model. It inherits from either the POA or ImplBase compiler-generated skeleton, so the models will be described as POA/Tie or ImplBase/Tie models in this document.

This tutorial presents the POA Inheritance model for server-side implementation. For tutorials using the other server-side implementations, see the following documents:

  • Java IDL: The "Hello World" Example with the POA/Tie Server-Side Model

    You might want to use the Tie model instead of the typical Inheritance model if your implementation must inherit from some other implementation. Java allows any number of interface inheritance, but there is only one slot for class inheritance. If you use the inheritance model, that slot is used up . By using the Tie Model, that slot is freed up for your own use. The drawback is that it introduces a level of indirection: one extra method call occurs when invoking a method.

  • Java IDL: The "Hello World" Example with the ImplBase Server-Side Model

    The ImplBase server-side model is an Inheritance Model, as is the POA model. Use the idlj compiler with the -oldImplBase flag to generate server-side bindings that are compatible with older version of Java IDL (prior to J2SE 1.4).

    Note that using the -oldImplBase flag is non-standard: these APIs are obsoleted. You would use this flag ONLY for compatibility with existing servers written in J2SE 1.3 or earlier. In that case, you would need to modify an existing MAKEFILE to add the -oldImplBase flag to the idlj compiler, otherwise POA-based server-side mappings will be generated.

For More Information

Exceptions: System Exceptions
Explains how CORBA system exceptions work and provides details on the minor codes of Java IDL's system exceptions
Developing Servers
Covers topics of interest to CORBA server programmers
Java IDL Naming Service
Covers the COS Naming Service in greater detail
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started with Java IDL: Using Stringified Object References

This document was not updated for this release.

To invoke an operation on a CORBA object, a client application needs a reference to the object. You can get such references in a number of ways, such as calling ORB.resolve_initial_references() or using another CORBA object (like the name service). In previous sections of this tutorial, you used both of these methods to get an initial object reference.

Often, however, there is no naming service available in the distributed environment. In that situation, CORBA clients use a stringified object reference to find their first object.

When updated, this lesson will teach you how to create a stringified object reference as a part of the server startup, and how the client gets that reference and destringifies it for use as a real object reference.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.security.jgss.GSSUtil (Java GSS-API Utilities )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.security.jgss.GSSUtil

No usage of com.sun.security.jgss.GSSUtil
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java GSS-API Utilities
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2000, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.HandlerResult (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.HandlerResult

    • Uses of HandlerResult in com.sun.nio.sctp

      Methods in com.sun.nio.sctp that return HandlerResult
      Modifier and Type Method and Description
      HandlerResult AbstractNotificationHandler.handleNotification(AssociationChangeNotification notification, T attachment)
      Invoked when an AssociationChangeNotification is received from the SCTP stack.
      HandlerResult NotificationHandler.handleNotification(Notification notification, T attachment)
      Invoked when a notification is received from the SCTP stack.
      HandlerResult AbstractNotificationHandler.handleNotification(Notification notification, T attachment)
      Invoked when an implementation specific notification is received from the SCTP stack.
      HandlerResult AbstractNotificationHandler.handleNotification(PeerAddressChangeNotification notification, T attachment)
      Invoked when an PeerAddressChangeNotification is received from the SCTP stack.
      HandlerResult AbstractNotificationHandler.handleNotification(SendFailedNotification notification, T attachment)
      Invoked when an SendFailedNotification is received from the SCTP stack.
      HandlerResult AbstractNotificationHandler.handleNotification(ShutdownNotification notification, T attachment)
      Invoked when an ShutdownNotification is received from the SCTP stack.
      static HandlerResult HandlerResult.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static HandlerResult[] HandlerResult.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Troubleshoot Process Hangs and Loops

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

6 Troubleshoot Process Hangs and Loops

This chapter provides information and guidance on some specific procedures for troubleshooting hanging or looping processes.

Problems can occur that involve hanging or looping processes. A hang can occur for many reasons but often stems from a deadlock in application code, API code, or library code. A hang can even be due to a bug in the Java HotSpot VM.

Sometimes an apparent hang turns out to be, in fact, a loop. For example, a bug in a VM process that causes one or more threads to go into an infinite loop can consume all available CPU cycles.

The initial step when diagnosing a hang is to find out if the VM process is idle or consuming all available CPU cycles. You can do this using a native operating system (OS) utility. If the process appears to be busy and is consuming all available CPU cycles then it is likely that the issue is a looping thread rather than a deadlock. On Oracle Solaris operating system, for example, the command prstat -L -p pid can be used to report the statistics for all lightweight processes (LWPs) in the target process and thus will identify the threads that are consuming a lot of CPU cycles.

This chapter contains the following sections:

  • Diagnose a Loop Process

  • Diagnose a Hung Process

  • Oracle Solaris 8 Thread Library

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Diagnose a Loop Process

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

6.1 Diagnose a Loop Process

If a VM process appears to be looping, the first step is to try to get a thread dump. If a thread dump can be obtained, it will often be clear which thread is looping. If the looping thread can be identified, then the trace stack in the thread dump can provide direction on where (and maybe why) the thread is looping.

If the application console (standard input/output) is available, then press the Control+\ key combination (on Oracle Solaris or Linux) or the Control+Break key combination (on Windows) to cause the HotSpot VM to print a thread dump, including thread state. On Oracle Solaris and Linux operating systems the thread dump can also be obtained by sending a SIGQUIT to the process (command kill -QUIT pid). In this case the thread dump is printed to the standard output of the target process. The output might be directed to a file, depending on how the process was started.

If the Java process is started with the -XX:+PrintClassHistogram command-line option, then the Control+Break handler will produce a heap histogram.

If a thread dump can be obtained, then a good place to start is the thread stacks of the threads that are in the RUNNABLE state. See Thread Dump for information on the format of the thread dump, as well as a table of the possible thread states in the thread dump. In some cases it might be necessary to get a sequence of thread dumps in order to determine which threads appear to be continuously busy.

If the application console is not available (for example, the process is running in the background, or the VM output is directed to an unknown location), then the jstack utility can be used to obtain the stack thread. Use the jstack -F pid command to force a stack dump of the looping process. See The jstack Utility for information on the output of this utility. The jstack utility should also be used if the thread dump does not provide any evidence that a Java thread is looping.

When reviewing the output of the jstack utility, focus initially on the threads that are in the RUNNABLE state. This is the most likely state for threads that are busy and possibly looping. It might be necessary to execute jstack a number of times to get a more complete picture of which threads are looping. If a thread appears to be always in the RUNNABLE state, then the -m option can be used to print the native frames and provide a further hint on what the thread is doing. If a thread appears to be looping continuously while in the RUNNABLE state, this situation can indicate a potential HotSpot VM bug that needs further investigation.

If the VM does not respond to Control+\, this could indicate a VM bug rather than an issue with application or library code. In this case use jstack with the -m option (in addition to the -F option) to get a thread stack for all threads. The output will include the thread stacks for VM internal threads. In this stack trace, identify threads that do not appear to be waiting. For example, on Oracle Solaris operating system you identify the threads that are not in functions such as __lwp_cond_wait, __lwp_park, ___pollsys, or other blocking functions. If it appears that the looping is caused by a VM bug, then collect as much data as possible and submit a bug report. See Submit a Bug Report for more details on data collection.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Diagnose a Hung Process

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

6.2 Diagnose a Hung Process

If the application appears to be hung and the process appears to be idle, then the first step is to try to obtain a thread dump. If the application console is available, then press Control+\ (on Oracle Solaris or Linux), or Control+Break (on Windows) to cause the HotSpot VM to print a thread dump. On Oracle Solaris and Linux operating systems the thread dump can also be obtained by sending a SIGQUIT to the process (command kill -QUIT pid). If the hung process is capable of generating a thread dump, then the output is printed to the standard output of the target process.

After printing the thread dump, the HotSpot VM executes a deadlock detection algorithm.

The following sections describe various situations for a hung process.

  • Deadlock Detected

  • Deadlock Not Detected

  • No Thread Dump

6.2.1 Deadlock Detected

If a deadlock is detected it will be printed along with the stack trace of the threads involved in the deadlock. Example 6-1 shows the stack trace for this situation.

Example 6-1 Stack Trace for a Deadlock

Found one Java-level deadlock:
=============================
"AWT-EventQueue-0":
  waiting to lock monitor 0x000ffbf8 (object 0xf0c30560, a java.awt.Component$AWTTreeLock),
  which is held by "main"
"main":
  waiting to lock monitor 0x000ffe38 (object 0xf0c41ec8, a java.util.Vector),
  which is held by "AWT-EventQueue-0"

Java stack information for the threads listed above:
===================================================
"AWT-EventQueue-0":
        at java.awt.Container.removeNotify(Container.java:2503)
        - waiting to lock <0xf0c30560> (a java.awt.Component$AWTTreeLock)
        at java.awt.Window$1DisposeAction.run(Window.java:604)
        at java.awt.Window.doDispose(Window.java:617)
        at java.awt.Dialog.doDispose(Dialog.java:625)
        at java.awt.Window.dispose(Window.java:574)
        at java.awt.Window.disposeImpl(Window.java:584)
        at java.awt.Window$1DisposeAction.run(Window.java:598)
        - locked <0xf0c41ec8> (a java.util.Vector)
        at java.awt.Window.doDispose(Window.java:617)
        at java.awt.Window.dispose(Window.java:574)
        at javax.swing.SwingUtilities$SharedOwnerFrame.dispose(SwingUtilities.java:1743)
        at javax.swing.SwingUtilities$SharedOwnerFrame.windowClosed(SwingUtilities.java:1722)
        at java.awt.Window.processWindowEvent(Window.java:1173)
        at javax.swing.JDialog.processWindowEvent(JDialog.java:407)
        at java.awt.Window.processEvent(Window.java:1128)
        at java.awt.Component.dispatchEventImpl(Component.java:3922)
        at java.awt.Container.dispatchEventImpl(Container.java:2009)
        at java.awt.Window.dispatchEventImpl(Window.java:1746)
        at java.awt.Component.dispatchEvent(Component.java:3770)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:214)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
"main":
        at java.awt.Window.getOwnedWindows(Window.java:844)
        - waiting to lock <0xf0c41ec8> (a java.util.Vector)
        at javax.swing.SwingUtilities$SharedOwnerFrame.installListeners(SwingUtilities.java:1697)
        at javax.swing.SwingUtilities$SharedOwnerFrame.addNotify(SwingUtilities.java:1690)
        at java.awt.Dialog.addNotify(Dialog.java:370)
        - locked <0xf0c30560> (a java.awt.Component$AWTTreeLock)
        at java.awt.Dialog.conditionalShow(Dialog.java:441)
        - locked <0xf0c30560> (a java.awt.Component$AWTTreeLock)
        at java.awt.Dialog.show(Dialog.java:499)
        at java.awt.Component.show(Component.java:1287)
        at java.awt.Component.setVisible(Component.java:1242)
        at test01.main(test01.java:10)

Found 1 deadlock.

The default deadlock detection works with locks that are obtained using the synchronized keyword, as well as with locks that are obtained using the java.util.concurrent package. If the Java VM flag -XX:+PrintConcurrentLocks is set, then the stack trace also shows a list of lock owners.

If a deadlock is detected, then you must examine the output in more detail in order to understand the deadlock. In the above example the thread main is locking object 0xf0c30560 and is waiting to enter 0xf0c41ec8, which is locked by thread AWT-EventQueue-0. However, thread AWT-EventQueue-0 is waiting to enter 0xf0c30560, which is locked by main.

The detail in the stack traces provides information to help find the deadlock.

6.2.2 Deadlock Not Detected

If the thread dump is printed and no deadlocks are found, then the issue might be a bug in which a thread waiting on a monitor that is never notified. This could be a timing issue or a general logic bug.

To find out more about the issue, examine each of the threads in the thread dump and each thread that is blocked in Object.wait(). The caller frame in the stack trace indicates the class and method that is invoking the wait() method. If the code was compiled with line number information (the default), then this provides direction as to the code to examine. In most cases you must have some knowledge of the application logic or library in order to diagnose this issue further. In general you must understand how the synchronization works in the application and in particular the details and conditions for when and where monitors are notified.

6.2.3 No Thread Dump

If the VM does not respond to Control+\ or Control+Break, then it is possible that the VM is deadlocked or hung for some other reason. In that case use The jstack Utility to obtain a thread dump. Use the jstack -F pid command to force a stack dump of the hung process. This also applies in the case when the application is not accessible or the output is directed to an unknown location.

In the jstack output, examine each of the threads in the BLOCKED state. The top frame can sometimes indicate why the thread is blocked (for example, Object.wait or Thread.sleep). The rest of the stack will give an indication of what the thread is doing. This is particularly true when the source has been compiled with line number information (the default) and you can cross reference the source code.

If a thread is in the BLOCKED state and the reason is not clear, then use the -m option to get a mixed stack. With the mixed stack output, it should be possible to identify why the thread is blocked. If a thread is blocked trying to enter a synchronized method or block, then you will see frames such as ObjectMonitor::enter near the top of the stack. Example 6-2 shows a sample mixed stack output.

Example 6-2 Mixed Stack Trace in the Thread Blocked State

----------------- t@13 -----------------
0xff31e8b8      ___lwp_cond_wait + 0x4
0xfea8c810      void ObjectMonitor::EnterI(Thread*) + 0x2b8
0xfeac86b8      void ObjectMonitor::enter2(Thread*) + 0x250
:

Threads in the RUNNABLE state might also be blocked. The top frames in the mixed stack should indicate what the thread is doing.

One specific thread to check is VMThread. This is the special thread used to execute operations like garbage collection (GC). It can be identified as the thread that is executing VMThread::run() in its initial frames. On Oracle Solaris it is typically t@4. On Linux it should be identifiable using the C++ mangled name _ZN8VMThread4loopEv.

In general the VM thread is in one of three states: waiting to execute a VM operation, synchronizing all threads in preparation for a VM operation, or executing a VM operation. If you suspect that a hang is a HotSpot VM bug rather than an application or class library deadlock, then pay special attention to the VM thread.

If the VM thread appears to be stuck in SafepointSynchronize::begin, then this could indicate an issue bringing the VM to a safepoint. A safepoint indicates that all threads executing in the VM are blocked and waiting for a special operation, such as GC, to complete.

If the VM thread appears to be stuck in function, where function ends in doit, then this could also indicate a VM problem.

In general, if you can execute the application from the command line, and you get to a state where the VM does not respond to Control+\ or Control+Break, it is more likely that you have uncovered a VM bug, a thread library issue, or a bug in another library. When this occurs, obtain a crash dump. See Collect Core Dumps for instructions to gather as much information as possible, and submit a bug report or support call.

One other tool to mention in the context of hung processes is the pstack utility on Oracle Solaris operating system. On Oracle Solaris 8 and 9 operating systems, this utility prints the thread stacks for LWPs in the target process. On Oracle Solaris 10 operating system and starting with the JDK 5.0 release, the output of pstack is similar, though not identical, to the output from jstack -m. As with jstack, the Oracle Solaris 10 operating system implementation of pstack prints the fully qualified class name, method name, and bytecode index (BCI). It will also print line numbers for cases where the source was compiled with line number information (the default). This is useful for developers and administrators who are familiar with the other utilities on Oracle Solaris operating system that exercise features of the /proc file system.

The equivalent tool of pstack on Linux is lsstack. This utility is included in some distributions and otherwise obtained from sourceforge. At the time of this writing, lsstack reported native frames only.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Oracle Solaris 8 Thread Library

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

6.3 Oracle Solaris 8 Thread Library

The default thread library on Oracle Solaris 8 operating system is often referred to as the T1 library. This thread library implemented the m:n threading model, where m user threads are mapped to n kernel-level threads (LWPs). Oracle Solaris 8 operating system also shipped with an alternative and newer thread library in /usr/lib/lwp. The alternative thread library is often referred to as the T2 library, and it became the default thread library in Oracle Solaris 9 and 10 operating systems. In older releases of J2SE (pre-1.4.0 in particular) there were a number of issues with the default thread library (for example, bugs in the thread library, LWP synchronization problems, or LWP starvation). LWP starvation is a scenario in which there are user threads in the RUNNABLE state but there are no kernel level threads available.

Although the issues cited are historical, it should be noted that when the JDK software is deployed on Oracle Solaris 8 operating system, it still uses the T1 library by default. LWP starvation type issues do not arise because the JDK release uses "bound threads" so that each user thread is bound to a kernel thread. However in the event that you encounter an issue, such as a hang, which you believe is a thread library issue, then you can instruct the HotSpot VM to use the T2 library by adding /usr/lib/lwp to the LD_LIBRARY_PATH. To check if the T2 library is in use, issue the command pldd pid to list the libraries loaded by the specified process.

 Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.net.httpserver.Headers (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.Headers

  • Packages that use Headers
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of Headers in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return Headers
      Modifier and Type Method and Description
      abstract Headers HttpExchange.getRequestHeaders()
      Returns an immutable Map containing the HTTP headers that were included with this request.
      abstract Headers HttpExchange.getResponseHeaders()
      Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Java VisualVM

Documentation Contents

Java VisualVM - Browsing a Heap Dump

You can use Java VisualVM to browse the contents of a heap dump file and quickly see the allocated objects in the heap. Heap dumps are displayed in the heap dump sub-tab in the main window. You can open binary format heap dump files (.hprof) saved on your local system or use Java VisualVM to take heap dumps of running applications.

A heap dump is a snapshot of all the objects in the Java Virtual Machine (JVM) heap at a certain point in time. The JVM software allocates memory for objects from the heap for all class instances and arrays. The garbage collector reclaims the heap memory when an object is no longer needed and there are no references to the object. By examining the heap you can locate where objects are created and find the references to those objects in the source. If the JVM software is failing to remove unneeded objects from the heap, Java VisualVM can help you locate the nearest garbage collecting root for the object.

Opening a Heap Dump File

If you have a heap dump file saved on your local system, you can open the file in Java VisualVM by choosing File > Load from the main menu. Java VisualVM can open heap dumps saved in the .hprof file format. When you open a saved heap dump, the heap dump opens as a tab in the main window.

Taking a Heap Dump

You can use Java VisualVM to take a heap dump of a local running application. When you use Java VisualVM to take a heap dump, the file is only temporary until you explicitly save it. If you do not save the file, the file will be deleted when the application terminates.

You can take a heap dump by doing either of the following:

  • Right-click the application in the Applications window and choose Heap Dump.
  • Click Heap Dump in the Monitor tab of the application.

Heap dumps for a local application open as sub-tabs in the application's tab. The heap dump also appears as a time-stamped heap dump node under the application node in the Applications window. To save a heap dump to your local system, right-click the heap dump in the Applications window and choose Save As.

Browsing a Heap Dump

Java VisualVM enables you to visually browse heap dumps in the following views:

Summary View

When you open a heap dump, Java VisualVM displays the Summary view by default. The Summary view displays the running environment where the heap dump was taken and other system properties.

screenshot of Summary view of heap dump

Classes View

The Classes view displays a list of classes and the number and percentage of instances referenced by that class. You can view a list of the instances of a specific class by right-clicking the name and choosing Show in Instances View.

You can sort how results are displayed by clicking a column heading. You can use the filter below the list to filter the classes by name or limit the displayed results to sub-classes of a class by right-clicking a class name and choosing Show Only Subclasses.

screenshot of Classes view of heap dump

Instances View

The Instance view displays object instances for a selected class. When you select an instance from the Instance pane, Java VisualVM displays the fields of that class and references to that class in the respective panes. In the References pane, you can right-click an item and choose Show Nearest GC Root to display the nearest garbage collection root object.

screenshot of Instances view of heap dump
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Getting Started Using Java RMI

This tutorial shows you the steps to follow to create a distributed version of the classic Hello World program using Java Remote Method Invocation (Java RMI). While you work through this example, you will probably come up with a number of related questions. You may find answers in the Java RMI FAQ.

The distributed Hello World example uses a simple client to make a remote method invocation to a server which may be running on a remote host. The client receives the "Hello, world!" message from the server.

This tutorial has the following steps:

  • Define the remote interface
  • Implement the server
  • Implement the client
  • Compile the source files
  • Start the Java RMI registry, server, and client
The files needed for this tutorial are:
  • Hello.java - a remote interface
  • Server.java - a remote object implementation that implements the remote interface
  • Client.java - a simple client that invokes a method of the remote interface
Note: For the remainder of this tutorial, the terms "remote object implementation" and "implementation class" are used interchangeably to refer to the class example.hello.Server, which implements a remote interface.

Define the remote interface

A remote object is an instance of a class that implements a remote interface. A remote interface extends the interface java.rmi.Remote and declares a set of remote methods. Each remote method must declare java.rmi.RemoteException (or a superclass of RemoteException) in its throws clause, in addition to any application-specific exceptions.

Here is the interface definition for the remote interface used in this example, example.hello.Hello. It declares just one method, sayHello, which returns a string to the caller:

package example.hello;

import java.rmi.Remote;
import java.rmi.RemoteException;

public interface Hello extends Remote {
    String sayHello() throws RemoteException;
}
Remote method invocations can fail in many additional ways compared to local method invocations (such as network-related communication problems and server problems), and remote methods will report such failures by throwing a java.rmi.RemoteException.

Implement the server

A "server" class, in this context, is the class which has a main method that creates an instance of the remote object implementation, exports the remote object, and then binds that instance to a name in a Java RMI registry. The class that contains this main method could be the implementation class itself, or another class entirely.

In this example, the main method for the server is defined in the class Server which also implements the remote interface Hello. The server's main method does the following:

  • Create and export a remote object
  • Register the remote object with a Java RMI registry
Here is the source code for the class Server. Descriptions for writing this server class follow the source code:
package example.hello;

import java.rmi.registry.Registry;
import java.rmi.registry.LocateRegistry;
import java.rmi.RemoteException;
import java.rmi.server.UnicastRemoteObject;

public class Server implements Hello {

    public Server() {}

    public String sayHello() {
        return "Hello, world!";
    }

    public static void main(String args[]) {

        try {
            Server obj = new Server();
            Hello stub = (Hello) UnicastRemoteObject.exportObject(obj, 0);

            // Bind the remote object's stub in the registry
            Registry registry = LocateRegistry.getRegistry();
            registry.bind("Hello", stub);

            System.err.println("Server ready");
        } catch (Exception e) {
            System.err.println("Server exception: " + e.toString());
            e.printStackTrace();
        }
    }
}

The implementation class Server implements the remote interface Hello, providing an implementation for the remote method sayHello. The method sayHello does not need to declare that it throws any exception because the method implementation itself does not throw RemoteException nor does it throw any other checked exceptions.

Note: A class can define methods not specified in the remote interface, but those methods can only be invoked within the virtual machine running the service and cannot be invoked remotely.

Create and export a remote object

The main method of the server needs to create the remote object that provides the service. Additionally, the remote object must be exported to the Java RMI runtime so that it may receive incoming remote calls. This can be done as follows:
Server obj = new Server();
Hello stub = (Hello) UnicastRemoteObject.exportObject(obj, 0);
The static method UnicastRemoteObject.exportObject exports the supplied remote object to receive incoming remote method invocations on an anonymous TCP port and returns the stub for the remote object to pass to clients. As a result of the exportObject call, the runtime may begin to listen on a new server socket or may use a shared server socket to accept incoming remote calls for the remote object. The returned stub implements the same set of remote interfaces as the remote object's class and contains the host name and port over which the remote object can be contacted.

Note: For details on how to generate stub classes, see the tools documentation for rmic [UNIX, Windows]. For details on how to deploy your application along with pregenerated stub classes, see the codebase tutorial.

Register the remote object with a Java RMI registry

For a caller (client, peer, or applet) to be able to invoke a method on a remote object, that caller must first obtain a stub for the remote object. For bootstrapping, Java RMI provides a registry API for applications to bind a name to a remote object's stub and for clients to look up remote objects by name in order to obtain their stubs.

A Java RMI registry is a simplified name service that allows clients to get a reference (a stub) to a remote object. In general, a registry is used (if at all) only to locate the first remote object a client needs to use. Then, typically, that first object would in turn provide application-specific support for finding other objects. For example, the reference can be obtained as a parameter to, or a return value from, another remote method call. For a discussion on how this works, please take a look at Applying the Factory Pattern to Java RMI.

Once a remote object is registered on the server, callers can look up the object by name, obtain a remote object reference, and then invoke remote methods on the object.

The following code in the server obtains a stub for a registry on the local host and default registry port and then uses the registry stub to bind the name "Hello" to the remote object's stub in that registry:

Registry registry = LocateRegistry.getRegistry();
registry.bind("Hello", stub);
The static method LocateRegistry.getRegistry that takes no arguments returns a stub that implements the remote interface java.rmi.registry.Registry and sends invocations to the registry on server's local host on the default registry port of 1099. The bind method is then invoked on the registry stub in order to bind the remote object's stub to the name "Hello" in the registry.

Note: The call to LocateRegistry.getRegistry simply returns an appropriate stub for a registry. The call does not check to see if a registry is actually running. If no registry is running on TCP port 1099 of the local host when the bind method is invoked, the server will fail with a RemoteException.

Implement the client

The client program obtains a stub for the registry on the server's host, looks up the remote object's stub by name in the registry, and then invokes the sayHello method on the remote object using the stub.

Here is the source code for the client:

package example.hello;

import java.rmi.registry.LocateRegistry;
import java.rmi.registry.Registry;

public class Client {

    private Client() {}

    public static void main(String[] args) {

        String host = (args.length < 1) ? null : args[0];
        try {
            Registry registry = LocateRegistry.getRegistry(host);
            Hello stub = (Hello) registry.lookup("Hello");
            String response = stub.sayHello();
            System.out.println("response: " + response);
        } catch (Exception e) {
            System.err.println("Client exception: " + e.toString());
            e.printStackTrace();
        }
    }
}

This client first obtains the stub for the registry by invoking the static LocateRegistry.getRegistry method with the hostname specified on the command line. If no hostname is specified, then null is used as the hostname indicating that the local host address should be used.

Next, the client invokes the remote method lookup on the registry stub to obtain the stub for the remote object from the server's registry.

Finally, the client invokes the sayHello method on the remote object's stub, which causes the following actions to happen:

  • The client-side runtime opens a connection to the server using the host and port information in the remote object's stub and then serializes the call data.
  • The server-side runtime accepts the incoming call, dispatches the call to the remote object, and serializes the result (the reply string "Hello, world!") to the client.
  • The client-side runtime receives, deserializes, and returns the result to the caller.

The response message returned from the remote invocation on the remote object is then printed to System.out.

Compile the source files

The source files for this example can be compiled as follows:

javac -d destDir Hello.java Server.java Client.java
where destDir is the destination directory to put the class files in.

Note: For details on how to deploy your application along with pregenerated stub classes, see the codebase tutorial.

Start the Java RMI registry, server, and client

To run this example, you will need to do the following:

  • Start the Java RMI registry
  • Start the server
  • Run the client

Start the Java RMI registry

To start the registry, run the rmiregistry command on the server's host. This command produces no output (when successful) and is typically run in the background. For more information, see the tools documentation for rmiregistry [UNIX, Windows].

For example, on the Solaris Operating System:

rmiregistry &

Or, on Windows platforms:

start rmiregistry

By default, the registry runs on TCP port 1099. To start a registry on a different port, specify the port number from the command line. For example, to start the registry on port 2001 on a Windows platform:

start rmiregistry 2001

If the registry will be running on a port other than 1099, you'll need to specify the port number in the calls to LocateRegistry.getRegistry in the Server and Client classes. For example, if the registry is running on port 2001 in this example, the call to getRegistry in the server would be:

Registry registry = LocateRegistry.getRegistry(2001);

Start the server

To start the server, run the Server class using the java command as follows:

On the Solaris Operating System:

java -classpath classDir -Djava.rmi.server.codebase=file:classDir/ example.hello.Server &

On Windows platforms:

start java -classpath classDir -Djava.rmi.server.codebase=file:classDir/ example.hello.Server

where classDir is the root directory of the class file tree. Setting the java.rmi.server.codebase system property ensures that the registry can load the remote interface definition (note that the trailing slash is important); for more information about using this property, see the codebase tutorial.

The output from the server should look like this:

Server ready

The server remains running until the process is terminated by the user (typically by killing the process).

Run the client

Once the server is ready, the client can be run as follows:

java  -classpath classDir example.hello.Client

where classDir is the root directory of the class file tree.

The output from the client is the following message:

response: Hello, world!

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Design of Shutdown Hooks API

Documentation Contents

Design of the Shutdown Hooks API

The following Q&A addresses some of the design issues of the Shutdown Hooks API.

Why don't you provide information as to why the VM is shutting down?

On some platforms a native process can't distinguish a shutdown due to exit from a shutdown due to termination. Other platforms provide much richer capabilities, in some cases including notification of system suspension and restart or of imminent power failure. In short, it's impossible to generalize such information in a portable way.

Will shutdown hooks be run if the VM crashes?

If the VM crashes due to an error in native code then no guarantee can be made about whether or not the hooks will be run.

Why are shutdown hooks run concurrently? Wouldn't it make more sense to run them in reverse order of registration?

Invoking shutdown hooks in their reverse order of registration is certainly intuitive, and is in fact how the C runtime library's atexit procedure works. This technique really only makes sense, however, in a single-threaded system. In a multi-threaded system such as Java platform the order in which hooks are registered is in general undetermined and therefore implies nothing about which hooks ought to be run before which other hooks. Invoking hooks in any particular sequential order also increases the possibility of deadlocks. Note that if a particular subsystem needs to invoke shutdown actions in a particular order then it is free to synchronize them internally.

Why are hooks just threads, and unstarted ones at that? Wouldn't it be simpler to use Runnable objects, or Beans-style event and listener patterns?

The approach taken here has two advantages over the more obvious, and more frequently suggested, callback-oriented designs based upon Runnable objects or Beans-style event listeners.

First, it gives the user complete control over the thread upon which a shutdown action is executed. The thread can be created in the proper thread group, given the correct priority, context, and privileges, and so forth.

Second, it simplifies both the specification and the implementation by isolating the VM from the hooks themselves. If shutdown actions were executed as callbacks then a robust implementation would wind up having to create a separate thread for each hook anyway in order for them to run concurrently. The specification would also have to include explicit language about how the threads that execute the callbacks are created.

Aren't threads pretty expensive things to keep around, especially if they won't be started until the VM shuts down?

Most implementations of the Java platform don't actually allocate resources to a thread until it's started, so maintaining a set of unstarted threads is actually very cheap. If you look at the internals of java.lang.Thread you can see that its various constructors just do security checks and initialize private fields. The native start() method does the real work of allocating a thread stack, etc., to get things going.

What about Personal and Embedded Java? Won't starting threads during shutdown be too expensive on those platforms?

This API may not be suitable for the smaller Java platforms. Threads in the Java 2 Platform carry more information than threads in JDK 1.1 and p/eJava. A thread has a class loader, it may have some inherited thread-local variables, and, in the case of GUI apps, it may be associated with a specific application context. Threads will come to carry even more information as the platform evolves; for example, the security team is planning to introduce a notion of per-thread user identity in their upcoming authentication framework.

Because of all this contextual information, shutdown hooks would be harder to write and maintain if they were just Runnable objects or Beans-style event listeners. Suppose that a Runnable shutdown hook, or an equivalent event listener, needed a specific bit of thread-contextual information in order to carry out its operations. Such information could be saved in some shared location before the hook is registered. While this is merely awkward, suppose further that threads acquire some new type of contextual information in a future release. If an operation invoked by the hook also evolves to need that information then the code that registers the hook would have to be amended to save that information as well. Making hooks be threads instead of Runnables or event listeners insulates them from this sort of future change.

Okay, but won't I have to write a lot of code just to register a simple shutdown hook?

No. Simple shutdown hooks can often be written as anonymous inner classes, as in this example:
Runtime.getRuntime().addShutdownHook(new Thread() {
    public void run() { database.close(); }
});
This idiom is fine as long as you'll never need to cancel the hook, in which case you'd need to save a reference to the hook when you create it.

What about security? Can an untrusted applet register a shutdown hook?

If there is a security manager installed then the addShutdownHook and removeShutdownHook methods check that the caller's security context permits RuntimePermission("shutdownHooks"). An untrusted applet will not have this permission, and will therefore not be able to register or de-register a shutdown hook.

What happens if a shutdown hook throws an exception and the exception is not caught?

Uncaught exceptions are handled in shutdown hooks just as in any other thread, by invoking the uncaughtException method of the thread's ThreadGroup object. The default implementation of this method prints the exception's stack trace to System.err and terminates the thread. Note that uncaught exceptions do not cause the VM to exit; this happens only when all non-daemon threads have finished or when the Runtime.exit method is invoked.

Why did you add the Runtime.halt method? Isn't it pretty dangerous?

The halt method is certainly powerful, and it should be used with the utmost caution. It's provided so that applications can insulate themselves from shutdown hooks that deadlock or run for inordinate amounts of time. It also allows applications to force a quick exit in situations where that is necessary.

What happens if finalization-on-exit is enabled? Will finalizers be run before, during, or after shutdown hooks?

Finalization-on-exit processing is done after all shutdown hooks have finished. Otherwise a hook may fail if some live objects are finalized prematurely.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.management.HotSpotDiagnosticMXBean (Monitoring and Management Interface for the Java Platform )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.management.HotSpotDiagnosticMXBean

No usage of com.sun.management.HotSpotDiagnosticMXBean
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Monitoring and Management Interface for the Java Platform
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2003, 2015, Oracle and/or its affiliates. All rights reserved.


How to Implement a Provider in the Java Cryptography Architecture

Skip Table of Contents
  • Introduction
    • Who Should Read This Document
    • Related Documentation
      • Notes on Terminology
  • Engine Classes and Corresponding SPI Classes
  • Steps to Implement and Integrate a Provider
    • Step 1: Write your Service Implementation Code
      • Step 1.1: Additional JCA Provider Requirements and Recommendations for Encryption Implementations
    • Step 2: Give your Provider a Name
    • Step 3: Write your Master Class, a subclass of Provider
      • Step 3.1: Additional Steps for Cipher Implementations
    • Step 4: Compile your Code
    • Step 5: Place your Provider in a Jar File
    • Step 6: Sign your JAR File
      • Step 6.1: Get a Code-Signing Certificate
      • Step 6.2: Sign Your Provider
    • Step 7: Prepare for Testing
      • Step 7.1: Install the Provider
      • Step 7.2: Set Provider Permissions
    • Step 8: Write and Compile your Test Programs
    • Step 9: Run your Test Programs
    • Step 10: Apply for U.S. Government Export Approval if Required
    • Step 11: Document your Provider and its Supported Services
      • Message Digests and MACs
    • Step 12: Make your Class Files and Documentation Available to Clients
  • How a Provider Can Do Self-Integrity Checking
    • Notes on the Sample Code
    • Finding the Provider JAR File: Basics
      • Determining the Provider's JAR File URL
      • Creating a JarFile Referring to the JAR File
    • Verifying the Provider JAR File: Basics
      • Verification Setup
      • JAR File Signature Check
      • Verifying Signatures
      • Ensuring Signers Are Trusted
        • Getting the List of Certificates
        • Identifying Each of the Signers and Determining If One is Trusted
    • Verifying Signatures
    • Ensuring Signers Are Trusted
      • Getting the List of Certificates
      • Identifying Each of the Signers and Determining If One is Trusted
      • Notes on myJCE Sample Code
  • Further Implementation Details and Requirements
    • Alias Names
    • Service Interdependencies
    • Default Initializations
    • Default Key Pair Generator Parameter Requirements
    • The Provider.Service Class
    • Signature Formats
    • DSA Interfaces and their Required Implementations
    • RSA Interfaces and their Required Implementations
    • Diffie-Hellman Interfaces and their Required Implementations
    • Interfaces for Other Algorithm Types
    • Algorithm Parameter Specification Interfaces and Classes
    • Key Specification Interfaces and Classes Required by Key Factories
    • Secret-Key Generation
    • Ensuring Exportability
  • Appendix A: The Sun Provider Master Class
  • Appendix B: The SunJCE Provider Master Class
  • Appendix C: The java.security Properties File

Introduction

The Java platform defines a set of APIs spanning major security areas, including cryptography, public key infrastructure, authentication, secure communication, and access control. These APIs allow developers to easily integrate security into their application code. They were designed around the following principles:

  1. Implementation independence

    Applications do not need to implement security themselves. Rather, they can request security services from the Java platform. Security services are implemented in providers (see below), which are plugged into the Java platform via a standard interface. An application may rely on multiple independent providers for security functionality.

  2. Implementation interoperability

    Providers are interoperable across applications. Specifically, an application is not bound to a specific provider, and a provider is not bound to a specific application.

  3. Algorithm extensibility

    The Java platform includes a number of built-in providers that implement a basic set of security services that are widely used today. However, some applications may rely on emerging standards not yet implemented, or on proprietary services. The Java platform supports the installation of custom providers that implement such services.

A Cryptographic Service Provider (provider) refers to a package (or a set of packages) that supply a concrete implementation of a subset of the cryptography aspects of the JDK Security API.

The java.security.Provider class encapsulates the notion of a security provider in the Java platform. It specifies the provider's name and lists the security services it implements. Multiple providers may be configured at the same time, and are listed in order of preference. When a security service is requested, the highest priority provider that implements that service is selected.

The following figure illustrate these options for requesting an MD5 message digest implementation. The figure consists of two diagrams, both of which show three providers that implement message digest algorithms. The providers are ordered by preference from left to right (1-3). In the diagram to the left, an application requests an MD5 algorithm implementation without specifying a provider name. The providers are searched in preference order and the implementation from the first provider supplying that particular algorithm, ProviderB, is returned. In the diagram to the right, the application requests the MD5 algorithm implementation from a specific provider, ProviderC. This time the implementation from that provider is returned, even though a provider with a higher preference order, ProviderB, also supplies an MD5 implementation.

MD5 Message Digest Implementation

Description of Figure Options for Requesting an MD5 Message Digest Implementation

Each installation has one or more provider packages installed. Clients may configure their runtimes with different providers, and specify a preference order for each of them. The preference order is the order in which providers are searched for requested algorithms when no particular provider is requested.

The Oracle version of the Java runtime environment (JRE) comes standard with a default provider, named "SUN". Other Java runtime environments may not necessarily supply the "SUN" provider.

Who Should Read This Document

Programmers that only need to use the Java Security API to access existing cryptography algorithms and other services do not need to read this document.

This document is intended for experienced programmers wishing to create their own provider packages supplying cryptographic service implementations. It documents what you need to do in order to integrate your provider into Java so that your algorithms and other services can be found when Java Security API clients request them.

Related Documentation

This document assumes you have already read the Java Cryptography Architecture Reference Guide.

It documents the packages which contain the various classes and interfaces in the Security API.

  • java.security
  • java.security.spec
  • java.security.interfaces
  • javax.crypto
  • javax.crypto.spec
  • javax.crypto.interfaces

Notes on Terminology

  • Prior to JDK 1.4, the JCE was an unbundled product, and as such, the JCA and JCE were regularly referred to as separate, distinct components. As JCE is now bundled in JDK, the distinction is becoming less apparent. Since the JCE uses the same architecture as the JCA, the JCE should be more properly thought of as a subset of the JCA.
  • The JCA within the JDK includes two software components:
    • the framework that defines and supports cryptographic services for which providers supply implementations. This framework includes packages such as java.security, javax.crypto, javax.crypto.spec, and javax.crypto.interfaces.
    • the actual providers such as Sun, SunRsaSign, SunJCE, which contain the actual cryptographic implementations.

Throughout this document, the terms JCA by itself refers to the JCA framework. Whenever this document notes a specific JCA provider, it will be referred to explicitly by the provider name.

Engine Classes and Corresponding Service Provider Interface Classes

An engine class defines a cryptographic service in an abstract fashion (without a concrete implementation).

A cryptographic service is always associated with a particular algorithm or type. It either provides cryptographic operations (like those for digital signatures or message digests, ciphers or key agreement protocols); generates or supplies the cryptographic material (keys or parameters) required for cryptographic operations; or generates data objects (keystores or certificates) that encapsulate cryptographic keys (which can be used in a cryptographic operation) in a secure fashion.

For example, here are four engine classes:

  • The Signature class provides access to the functionality of a digital signature algorithm.
  • A DSA KeyFactory class supplies a DSA private or public key (from its encoding or transparent specification) in a format usable by the initSign or initVerify methods, respectively, of a DSA Signature object.
  • The Cipher class provides access to the functionality of an encryption algorithm (such as DES)
  • the KeyAgreement class provides access to the functionality of a key agreement protocol (such as Diffie-Hellman)

The Java Cryptography Architecture encompasses the classes comprising the Security package that relate to cryptography, including the engine classes. Users of the API request and utilize instances of the engine classes to carry out corresponding operations. The JDK defines the following engine classes:

  • MessageDigest - used to calculate the message digest (hash) of specified data.
  • Signature - used to sign data and verify digital signatures.
  • KeyPairGenerator - used to generate a pair of public and private keys suitable for a specified algorithm.
  • KeyFactory - used to convert opaque cryptographic keys of type Key into key specifications (transparent representations of the underlying key material), and vice versa.
  • KeyStore - used to create and manage a keystore. A keystore is a database of keys. Private keys in a keystore have a certificate chain associated with them, which authenticates the corresponding public key. A keystore also contains certificates from trusted entities.
  • CertificateFactory - used to create public key certificates and Certificate Revocation Lists (CRLs).
  • AlgorithmParameters - used to manage the parameters for a particular algorithm, including parameter encoding and decoding.
  • AlgorithmParameterGenerator - used to generate a set of parameters suitable for a specified algorithm.
  • SecureRandom - used to generate random or pseudo-random numbers.
  • Cipher: used to encrypt or decrypt some specified data.
  • KeyAgreement: used to execute a key agreement (key exchange) protocol between 2 or more parties.
  • KeyGenerator: used to generate a secret (symmetric) key suitable for a specified algorithm.
  • Mac: used to compute the message authentication code of some specified data.
  • SecretKeyFactory: used to convert opaque cryptographic keys of type SecretKey into key specifications (transparent representations of the underlying key material), and vice versa.
  • ExemptionMechanism: used to provide the functionality of an exemption mechanism such as key recovery, key weakening, key escrow, or any other (custom) exemption mechanism. Applications or applets that use an exemption mechanism may be granted stronger encryption capabilities than those which don't. However, please note that cryptographic restrictions are no longer required for most countries, and thus exemption mechanisms may only be useful in those few countries whose governments mandate restrictions.

Note: A generator creates objects with brand-new contents, whereas a factory creates objects from existing material (for example, an encoding).

An engine class provides the interface to the functionality of a specific type of cryptographic service (independent of a particular cryptographic algorithm). It defines Application Programming Interface (API) methods that allow applications to access the specific type of cryptographic service it provides. The actual implementations (from one or more providers) are those for specific algorithms. For example, the Signature engine class provides access to the functionality of a digital signature algorithm. The actual implementation supplied in a SignatureSpi subclass (see next paragraph) would be that for a specific kind of signature algorithm, such as SHA1 with DSA, SHA1 with RSA, or MD5 with RSA.

The application interfaces supplied by an engine class are implemented in terms of a Service Provider Interface (SPI). That is, for each engine class, there is a corresponding abstract SPI class, which defines the Service Provider Interface methods that cryptographic service providers must implement.

Architecture of Service Provider Interface

Description of Architecture of Service Provider Interface

An instance of an engine class, the "API object", encapsulates (as a private field) an instance of the corresponding SPI class, the "SPI object". All API methods of an API object are declared "final", and their implementations invoke the corresponding SPI methods of the encapsulated SPI object. An instance of an engine class (and of its corresponding SPI class) is created by a call to the getInstance factory method of the engine class.

The name of each SPI class is the same as that of the corresponding engine class, followed by "Spi". For example, the SPI class corresponding to the Signature engine class is the SignatureSpi class.

Each SPI class is abstract. To supply the implementation of a particular type of service and for a specific algorithm, a provider must subclass the corresponding SPI class and provide implementations for all the abstract methods.

Another example of an engine class is the MessageDigest class, which provides access to a message digest algorithm. Its implementations, in MessageDigestSpi subclasses, may be those of various message digest algorithms such as SHA-1, MD5, or MD2.

As a final example, the KeyFactory engine class supports the conversion from opaque keys to transparent key specifications, and vice versa. See Key Specification Interfaces and Classes Required by Key Factories for details. The actual implementation supplied in a KeyFactorySpi subclass would be that for a specific type of keys, e.g., DSA public and private keys.

Steps to Implement and Integrate a Provider

Follow the steps below to implement a provider and integrate it into the JCA framework:

  • Step 1: Write your Service Implementation Code
    • Step 1.1: Additional JCA Provider Requirements and Recommendations for Encryption Implementations
  • Step 2: Give your Provider a Name
  • Step 3: Write your Master Class, a subclass of Provider
    • Step 3.1: Additional Steps for Cipher Implementations
  • Step 4: Compile your Code
  • Step 5: Place your Provider in a Jar File
  • Step 6: Sign your JAR File
    • Step 6.1: Get a Code-Signing Certificate
    • Step 6.2: Sign Your Provider
  • Step 7: Prepare for Testing
    • Step 7.1: Install the Provider
    • Step 7.2: Set Provider Permissions
  • Step 8: Write and Compile your Test Programs
  • Step 9: Run your Test Programs
  • Step 10: Apply for U.S. Government Export Approval if Required
  • Step 11: Document your Provider and its Supported Services
    • Message Digests and MACs
  • Step 12: Make your Class Files and Documentation Available to Clients

Step 1: Write your Service Implementation Code

The first thing you need to do is to write the code that provides algorithm-specific implementations of the cryptographic services you want to support.

Note that your provider may supply implementations of cryptographic services already available in one or more of the security components of the JDK.

For cryptographic services not defined in JCA (For example; signatures and message digests), please refer to Java Cryptography Architecture Reference Guide.

For each cryptographic service you wish to implement, create a subclass of the appropriate SPI class. JCA defines the following engine classes:

  • SignatureSpi
  • MessageDigestSpi
  • KeyPairGeneratorSpi
  • SecureRandomSpi
  • AlgorithmParameterGeneratorSpi
  • AlgorithmParametersSpi
  • KeyFactorySpi
  • CertificateFactorySpi
  • KeyStoreSpi
  • CipherSpi
  • KeyAgreementSpi
  • KeyGeneratorSpi
  • MacSpi
  • SecretKeyFactorySpi
  • ExemptionMechanismSpi

(See Engine Classes and Corresponding SPI Classes in this document for information on the JCA and other cryptographic classes.)

In your subclass, you need to:

  1. Supply implementations for the abstract methods, whose names usually begin with engine. See Further Implementation Details and Requirements for additional information.
  2. Ensure there is a public constructor without any arguments. Here's why: When one of your services is requested, Java Security looks up the subclass implementing that service, as specified by a property in your "master class" (see Step 3). Java Security then creates the Class object associated with your subclass, and creates an instance of your subclass by calling the newInstance method on that Class object. newInstance requires your subclass to have a public constructor without any parameters.
  3. A default constructor without arguments will automatically be generated if your subclass doesn't have any constructors. But if your subclass defines any constructors, you must explicitly define a public constructor without arguments.

Step 1.1: Additional JCA Provider Requirements and Recommendations for Encryption Implementations

When instantiating a provider's implementation (class) of a Cipher, KeyAgreement, KeyGenerator, MAC or SecretKey factory, the framework will determine the provider's codebase (JAR file) and verify its signature. In this way, JCA authenticates the provider and ensures that only providers signed by a trusted entity can be plugged into JCA. Thus, one requirement for encryption providers is that they must be signed, as described in later steps.

In addition, each provider should perform self-integrity checking to ensure that the JAR file containing its code has not been manipulated in an attempt to invoke provider methods directly rather than through JCA. For further information, see How a Provider Can Do Self-Integrity Checking.

In order for provider classes to become unusable if instantiated by an application directly, bypassing JCA, providers should implement the following:

  • All SPI implementation classes in a provider package should be declared final (so that they cannot be subclassed), and their (SPI) implementation methods should be declared protected.
  • All crypto-related helper classes in a provider package should have package-private scope, so that they cannot be accessed from outside the provider package.

For providers that may be exported outside the U.S., CipherSpi implementations must include an implementation of the engineGetKeySize method which, given a Key, returns the key size. If there are restrictions on available cryptographic strength specified in jurisdiction policy files, each Cipher initialization method calls engineGetKeySize and then compares the result with the maximum allowable key size for the particular location and circumstances of the applet or application being run. If the key size is too large, the initialization method throws an exception.

Additional optional features that providers may implement are

  • the engineWrap and engineUnwrap methods of CipherSpi. Wrapping a key enables secure transfer of the key from one place to another. Information about wrapping and unwrapping keys is provided in the Wrapping and Unwrapping Keys section of the Java Cryptography Architecture Reference Guide.
  • one or more exemption mechanisms. An exemption mechanism is something such as key recovery, key escrow, or key weakening which, if implemented and enforced, may enable reduced cryptographic restrictions for an application (or applet) that uses it. For information on the requirements for apps that utilize exemption mechanisms, see How to Make Applications "Exempt" from Cryptographic Restrictions in the Java Cryptography Architecture Reference Guide.

Step 2: Give your Provider a Name

Decide on a name for your provider. This is the name to be used by client applications to refer to your provider.

Step 3: Write your Master Class, a subclass of Provider

The third step is to create a subclass of the java.security.Provider class.

Your subclass should be a final class, and its constructor should

  • call super, specifying the provider name (see Step 2), version number, and a string of information about the provider and algorithms it supports. For example:
        super("CryptoX", 1.0, "CryptoX provider v1.0, implementing " +
        "RSA encryption and key pair generation, and DES encryption.");
  • set the values of various properties that are required for the Java Security API to look up the cryptographic services implemented by the provider. For each service implemented by the provider, there must be a property whose name is the type of service (for example; Signature, MessageDigest, Cipher, KeyAgreement) Signature, MessageDigest, KeyPairGenerator, SecureRandom, KeyFactory, KeyStore, CertificateFactory, AlgorithmParameterGenerator, AlgorithmParameters, Cipher, KeyAgreement, KeyGenerator, Mac, SecretKeyFactory, or ExemptionMechanism) followed by a period and the name of the algorithm to which the service applies. The property value must specify the fully qualified name of the class implementing the service.

  • The list below shows the various types of JCA services, where the actual algorithm name is substitued for algName:

    • Signature.algName
    • MessageDigest.algName
    • KeyPairGenerator.algName
    • SecureRandom.algName
    • AlgorithmParameterGenerator.algName
    • AlgorithmParameters.algName
    • KeyFactory.algName
    • CertificateFactory.algName
    • KeyStore.algName
    • Cipher.algName
    • KeyAgreement.algName
    • KeyGenerator.algName
    • Mac.algName
    • SecretKeyFactory.algName
    • ExemptionMechanism.algName

    In all of these except ExemptionMechanism and Cipher, algName, certType , or storeType is the "standard" name of the algorithm, certificate type, or keystore type. See Appendix A of the Java Cryptography Architecture Reference Guide for the standard names that should be used.)

    In the case of ExemptionMechanism, algName refers to the name of the exemption mechanism, which can be one of the following: KeyRecovery, KeyEscrow, or KeyWeakening. Case does not matter.

    In the case of Cipher, algName may actually represent a transformation, and may be composed of an algorithm name, a particular mode, and a padding scheme. See Appendix A of the Java Cryptography Architecture Reference Guide for details.

    The value of each property must be the fully qualified name of the class implementing the specified algorithm, certificate type, or keystore type. That is, it must be the package name followed by the class name, where the two are separated by a period.

    As an example, the default provider named SUN implements the Digital Signature Algorithm (whose standard name is SHA1withDSA) in a class named DSA in the sun.security.provider package. Its subclass of Provider (which is the Sun class in the sun.security.provider package) sets the Signature.SHA1withDSA property to have the value sun.security.provider.DSA via the following:

        put("Signature.SHA1withDSA", "sun.security.provider.DSA")

    The list below shows more properties that can be defined for the various types of services, where the actual algorithm name is substitued for algName, certificate type for certType, keystore type for storeType, and attribute name for attrName:

    • Signature.algName [one or more spaces] attrName
    • MessageDigest.algName [one or more spaces] attrName
    • KeyPairGenerator.algName [one or more spaces] attrName
    • SecureRandom.algName [one or more spaces] attrName
    • KeyFactory.algName [one or more spaces] attrName
    • CertificateFactory.certType [one or more spaces] attrName
    • KeyStore.storeType [one or more spaces] attrName
    • AlgorithmParameterGenerator.algName [one or more spaces] attrName
    • AlgorithmParameters.algName [one or more spaces] attrName
    • Cipher.algName [one or more spaces] attrName
    • KeyAgreement.algName [one or more spaces] attrName
    • KeyGenerator.algName [one or more spaces] attrName
    • Mac.algName [one or more spaces] attrName
    • SecretKeyFactory.algName [one or more spaces] attrName
    • ExemptionMechanism.algName [one or more spaces] attrName

In each of these, algName, certType, storeType, or attrName is the "standard" name of the algorithm, certificate type, keystore type, or attribute. (See Appendix A of the Java Cryptography Architecture Reference Guide for the standard names that should be used.)

For a property in the above format, the value of the property must be the value for the corresponding attribute. (See Appendix A of the Java Cryptography Architecture API Specification & Reference for the definition of each standard attribute.)

As an example, the default provider named "SUN" implements the SHA1withDSA Digital Signature Algorithm in software. In the master class for the provider "SUN", it sets the Signature.SHA1withDSA ImplementedIn to have the value Software via the following:

    put("Signature.SHA1withDSA ImplementedIn", "Software")

For further master class property setting examples, see Appendix A to view the current Sun.java source file or Appendix B to see the SunJCE provider. These files show how the Sun and SunJCE providers set properties.

Step 3.1: Additional Steps for Cipher Implementations

As mentioned above, in the case of a Cipher property, algName may actually represent a transformation. A transformation is a string that describes the operation (or set of operations) to be performed by a Cipher object on some given input. A transformation always includes the name of a cryptographic algorithm (e.g., DES), and may be followed by a mode and a padding scheme.

A transformation is of the form:

  • algorithm/mode/padding, or
  • algorithm

(In the latter case, provider-specific default values for the mode and padding scheme are used). For example, the following is a valid transformation:

    Cipher c = Cipher.getInstance("DES/CBC/PKCS5Padding");

When requesting a block cipher in stream cipher mode (for example; DES in CFB or OFB mode), a client may optionally specify the number of bits to be processed at a time, by appending this number to the mode name as shown in the following sample transformations:

    Cipher c1 = Cipher.getInstance("DES/CFB8/NoPadding");
    Cipher c2 = Cipher.getInstance("DES/OFB32/PKCS5Padding");

If a number does not follow a stream cipher mode, a provider-specific default is used. (For example, the SunJCE provider uses a default of 64 bits.)

A provider may supply a separate class for each combination of algorithm/mode/padding. Alternatively, a provider may decide to provide more generic classes representing sub-transformations corresponding to algorithm or algorithm/mode or algorithm//padding (note the double slashes); in this case the requested mode and/or padding are set automatically by the getInstance methods of Cipher, which invoke the engineSetMode and engineSetPadding methods of the provider's subclass of CipherSpi.

That is, a Cipher property in a provider master class may have one of the formats shown in the table below.

Cipher Property Format | Description
Cipher.algName | A provider's subclass of CipherSpi implements algName with pluggable mode and padding
Cipher.algName/mode | A provider's subclass of CipherSpi implements algName in the specified mode, with pluggable padding
Cipher.algName//padding | A provider's subclass of CipherSpi implements algName with the specified padding, with pluggable mode
Cipher.algName/mode/padding | A provider's subclass of CipherSpi implements algName with the specified mode and padding

(See Appendix A of the Java Cryptography Architecture Reference Guide for the standard algorithm names, modes, and padding schemes that should be used.)

For example, a provider may supply a subclass of CipherSpi that implements DES/ECB/PKCS5Padding, one that implements DES/CBC/PKCS5Padding, one that implements DES/CFB/PKCS5Padding, and yet another one that implements DES/OFB/PKCS5Padding. That provider would have the following Cipher properties in its master class:

  • Cipher.DES/ECB/PKCS5Padding
  • Cipher.DES/CBC/PKCS5Padding
  • Cipher.DES/CFB/PKCS5Padding
  • Cipher.DES/OFB/PKCS5Padding

Another provider may implement a class for each of the above modes (i.e., one class for ECB, one for CBC, one for CFB, and one for OFB), one class for PKCS5Padding, and a generic DES class that subclasses from CipherSpi. That provider would have the following Cipher properties in its master class:

  • Cipher.DES
  • Cipher.DES SupportedModes
    Example: "ECB|CBC|CFB|OFB"
  • Cipher.DES SupportedPaddings
    Example: "NOPADDING|PKCS5Padding"

The getInstance factory method of the Cipher engine class follows these rules in order to instantiate a provider's implementation of CipherSpi for a transformation of the form "algorithm":

  1. Check if the provider has registered a subclass of CipherSpi for the specified "algorithm".

    If the answer is YES, instantiate this class, for whose mode and padding scheme default values (as supplied by the provider) are used.

    If the answer is NO, throw a NoSuchAlgorithmException exception.

The getInstance factory method of the Cipher engine class follows these rules in order to instantiate a provider's implementation of CipherSpi for a transformation of the form "algorithm/mode/padding":

  1. Check if the provider has registered a subclass of CipherSpi for the specified "algorithm/mode/padding" transformation.

    If the answer is YES, instantiate it.

    If the answer is NO, go to the next step.
  2. Check if the provider has registered a subclass of CipherSpi for the sub-transformation "algorithm/mode".

    If the answer is YES, instantiate it, and call engineSetPadding(padding) on the new instance.

    If the answer is NO, go to the next step.
  3. Check if the provider has registered a subclass of CipherSpi for the sub-transformation "algorithm//padding" (note the double slashes).

    If the answer is YES, instantiate it, and call engineSetMode(mode) on the new instance.

    If the answer is NO, go to the next step.
  4. Check if the provider has registered a subclass of CipherSpi for the sub-transformation "algorithm".

    If the answer is YES, instantiate it, and call engineSetMode(mode) and engineSetPadding(padding) on the new instance.

    If the answer is NO, throw a NoSuchAlgorithmException exception.

Step 4: Compile your Code

After you have created your implementation code (Step 1), given your provider a name (Step 2), and created the master class (Step 3), use the Java compiler to compile your files.

Step 5: Place Your Provider in a JAR File

Place your provider code in a JAR file, in preparation for signing it in the next step. For more information on the jar tool, see jar (for Solaris, Linux, or Mac OS X) (for Microsoft Windows).

    jar cvf <JAR file name> <list of classes, separated by spaces>

This command creates a JAR file with the specified name containing the specified classes.

Step 6: Sign your JAR File

If your provider is supplying encryption algorithms through the Cipher KeyAgreement, KeyGenerator, Mac, or SecretKeyFactory classes, you will need to sign your JAR file so that the JCA can authenticate the code at runtime. For details, see Step 1a. If you are NOT providing an implementation of this type you can skip this step.

Step 6.1: Get a Code-Signing Certificate

The next step is to request a code-signing certificate so that you can use it to sign your provider prior to testing. The certificate will be good for both testing and production. It will be valid for 5 years.

Below are the steps you should use to get a code-signing certificate. For more information on the keytool tool, see keytool (for Solaris, Linux, or Mac OS X) (for Microsoft Windows).

  1. Use keytool to generate a DSA keypair, using DSA algorithm as an example:
        keytool -genkeypair -alias <alias> \
        -keyalg DSA -keysize 1024 \
        -dname "cn=<Company Name>, \
        ou=Java Software Code Signing,\
        o=Sun Microsystems Inc" \
        -keystore <keystore file name>\
        -storepass <keystore password>

    This will generate a DSA keypair (a public key and an associated private key) and store it in an entry in the specified keystore. The public key is stored in a self-signed certificate. The keystore entry can subsequently be accessed using the specified alias.

    The option values in angle brackets ("<" and ">") represent the actual values that must be supplied. For example, <alias> must be replaced with whatever alias name you wish to be used to refer to the newly-generated keystore entry in the future, and <keystore file name> must be replaced with the name of the keystore to be used. Note: Do not surround actual values with angle brackets. For example, if you want your alias to be myTestAlias, specify the -alias option as follows:

        -alias myTestAlias
    If you specify a keystore that doesn't yet exist, it will be created.

    Note: If command lines you type are not allowed to be as long as the keytool -genkeypair command you want to execute (for example, if you are typing to a Microsoft Windows DOS prompt), you can create and execute a plain-text batch file containing the command. That is, create a new text file that contains nothing but the full keytool -genkeypair command. (Remember to type it all on one line.) Save the file with a .bat extension. Then in your DOS window, type the file name (with its path, if necessary). This will cause the command in the batch file to be executed.

  2. Use keytool to generate a certificate signing request.
        keytool -certreq -alias <alias> \
        -file <csr file name> \
        -keystore <keystore file name> \
        -storepass <keystore password>
    Here, <alias> is the alias for the DSA keypair entry created in the previous step. This command generates a Certificate Signing Request (CSR), using the PKCS#10 format. It stores the CSR in the file whose name is specified in <csr file name>.
  3. Send the CSR, contact information, and other required documentation to the JCA Code Signing Certification Authority. See JCA Code Signing Certification Authority for contact info.
  4. After the JCA Code Signing Certification Authority has received your email message, they will send you a request number via email. Once you receive this request number, you should print, fill out and send the Certification Form for CSPs. See Sending Certification Form for CSPs for contact information.
  5. Use keytool to import the certificates received from the CA.

    Once you have received the two certificates from the JCA Code Signing Certification Authority, you can use keytool to import them into your keystore.

    First import the CA's certificate as a "trusted certificate":
        keytool -import -alias <alias for the CA cert> \
        -file <CA cert file name> \
        -keystore <keystore file name> \
        -storepass <keystore password>
    Then import the code-signing certificate:
        keytool -import -alias <alias> \
        -file <code-signing cert file name> \
        -keystore <keystore file name> \
        -storepass <keystore password>
    Here, <alias> is the same alias as that which you created in step 1 where you generated a DSA keypair. This command replaces the self-signed certificate in the keystore entry specified by <alias> with the one signed by the JCA Code Signing Certification Authority.

Now that you have in your keystore a certificate from an entity trusted by JCA (the JCA Code Signing Certification Authority), you can place your provider code in a JAR file (Step 5) and then use that certificate to sign the JAR file (Step 6.2).

Step 6.2: Sign Your Provider

Sign the JAR file created in step five with the code-signing certificate obtained in Step 6. For more information on the jarsigner tool, see jarsigner (for Solaris, Linux, or Mac OS X) (for Microsoft Windows).

    jarsigner -keystore <keystore file name> \
        -storepass <keystore password> \
        <JAR file name> <alias>

Here, <alias> is the alias into the keystore for the entry containing the code-signing certificate received from the JCA Code Signing Certification Authority (the same alias as that specified in the commands in Step 6.1).

You can test verification of the signature via the following:

    jarsigner -verify <JAR file name>

The text "jar verified" will be displayed if the verification was successful.

Note: If you bundle a signed JCE provider as part of an RIA (applet or webstart application), for the best user experience, you should apply a second signature to the JCE provider JAR with the same certificate/key that you used to sign the applet or webstart application. See the Java Platform, Standard Edition Deployment Guide for more information on deploying RIAs, and the jarsigner (Solaris, Linux, or Mac OS X or Windows) man page for information on applying multiple signatures to a JAR file.

Step 7: Prepare for Testing

The next steps describe how to install and configure your new provider so that it is available via the JCA.

Step 7.1: Install the Provider

In order to prepare for testing your provider, you must install it in the same manner as will be done by clients wishing to use it. The installation enables Java Security to find your algorithm implementations when clients request them.

Installing a provider is done in two steps: installing the provider package classes, and configuring the provider.

Installing the Provider Classes

The first thing you must do is make your classes available so that they can be found when requested. You ship your provider classes as a JAR (Java ARchive) file.

There are a two possible ways to install provider classes:

  • Install the JAR file containing the provider classes as an installed or bundled extension.
  • Place the JAR file containing the provider classes in your CLASSPATH.

The provider JAR file will be considered an installed extension if it is placed in the standard place for the JAR files of an installed extension:

  • Solaris, Linux, or Mac OS X: <java-home>/lib/ext
  • Windows: <java-home>\lib\ext

Here <java-home> refers to the directory where the runtime software is installed, which is the top-level directory of the Java Runtime Environment (JRE) or the jre directory in the Java SE (JDK) software. For example, if you have the JDK installed on Solaris, Linux, or Mac OS X in a directory named /home/user1/jdk, or on Microsoft Windows in a directory named C:\jdk, then you need to install the JAR file in the following directory:

  • Solaris, Linux, or Mac OS X: /home/user1/jdk/jre/lib/ext
  • Windows: C:\jdk\jre\lib\ext

Similarly, if you have the JRE installed on Solaris, Linux, or Mac OS X in a directory named /home/user1/jre, or on Microsoft Windows in a directory named C:\jre, you need to install the JAR file in the following directory:

  • Solaris, Linux, or Mac OS X: /home/user1/jre/lib/ext
  • Windows: C:\jre\lib\ext

For more information on installed extensions, see Installed Extensions.

For more information on bundled extensions, see Bundled Extensions.

Configuring the Provider

The next step is to add the provider to your list of approved providers. This is done statically by editing the security properties file

  • Solaris, Linux, or Mac OS X: <java-home>/lib/security/java.security
  • Windows: <java-home>\lib\security\java.security

Here <java-home> refers to the directory where the JRE was installed. For example, if you have the JDK installed on Solaris, Linux, or Mac OS X in a directory named /home/user1/jdk, or on Microsoft Windows in a directory named C:\jdk, then you need to edit the following file:

  • Solaris, Linux, or Mac OS X: /home/user1/jdk/jre/lib/security/java.security
  • Windows: C:\jdk\jre\lib\security\java.security

Similarly, if you have the JRE installed on Solaris, Linux, or Mac OS X in a directory named /home/user1/jre, or on Windows in a directory named C:\jre, then you need to edit this file:

  • Solaris, Linux, or Mac OS X: /home/user1/jre/lib/security/java.security
  • Windows: C:\jre\lib\security\java.security

For each provider, this file should have a statement of the following form:

    security.provider.n=masterClassName

This declares a provider, and specifies its preference order n. The preference order is the order in which providers are searched for requested algorithms when no specific provider is requested. The order is 1-based; 1 is the most preferred, followed by 2, and so on.

masterClassName must specify the fully qualified name of the provider's "master class", which you implemented in Step 3. This class is always a subclass of the Provider class.

Java comes standard with providers named SUN, SunRsaSign, and SunJCE which are automatically configured as a static provider in the java.security properties file, as follows:

    security.provider.2=sun.security.provider.Sun
    security.provider.3=sun.security.rsa.SunRsaSign
    security.provider.4=sun.security.provider.SunJCE

(The Sun provider's master class is the Sun class in the sun.security.provider package.)

The JCA provider SunJCE and other security-related providers shipped with the Java platform are also automatically configured as static providers.

To utilize another JCA provider, add a line registering the alternate provider, giving it a lower preference order than the SUN and SunRsaSign providers.

Suppose that your master class is the CryptoX class in the com.cryptox.provider package, and that you would like to make your provider the fourth preferred provider. To do so, edit the java.security file as seen below:

    security.provider.2=sun.security.provider.Sun
    security.provider.3=sun.security.rsa.SunRsaSign
    security.provider.4=com.cryptox.provider.CryptoX
    security.provider.5=sun.security.provider.SunJCE

Note: Providers may also be registered dynamically. To do so, a program (such as your test program, to be written in Step 8) can call either the addProvider or insertProviderAt method in the Security class. This type of registration is not persistent and can only be done by code which is granted the following permission:

    java.security.SecurityPermission "insertProvider.{name}"

where {name} is replaced by the actual provider name.

For example, if the provider name is "MyJCE" and if the provider's code is in the myjce_provider.jar file in the /localWork directory, then here is a sample policy file grant statement granting that permission:

    grant codeBase "file:/localWork/myjce_provider.jar" {
        permission java.security.SecurityPermission
            "insertProvider.MyJCE";
    };

Step 7.2: Set Provider Permissions

Whenever providers are not installed extensions, permissions must be granted for when applets or applications are run while a security manager is installed. There is typically a security manager installed whenever an applet is running, and a security manager may be installed for an application either via code in the application itself or via a command-line argument. Permissions do not need to be granted to installed extensions, since the default system policy file grants all permissions to installed extensions.

Whenever a client does not install your provider as an installed extension, your provider may need the following permissions granted to it in the client environment:

  • java.lang.RuntimePermission to get class protection domains. The provider may need to get its own protection domain in the process of doing self-integrity checking.
  • java.security.SecurityPermission to set provider properties.

To ensure your provider works when a security manager is installed and the provider is not an installed extension, you need to test such an installation and execution environment. In addition, prior to testing you need to grant appropriate permissions to your provider and to any other providers it uses. For example, a sample statement granting permissions to a provider whose name is "MyJCE" and whose code is in myjce_provider.jar appears below. Such a statement could appear in a policy file. In this example, the myjce_provider.jar file is assumed to be in the /localWork directory.

    grant codeBase "file:/localWork/myjce_provider.jar" {
        permission java.lang.RuntimePermission "getProtectionDomain";
        permission java.security.SecurityPermission
            "putProviderProperty.MyJCE";
    };

Step 8: Write and Compile your Test Programs

Write and compile one or more test programs that test your provider's incorporation into the Security API as well as the correctness of its algorithm(s). Create any supporting files needed, such as those for test data to be encrypted.

The first tests your program should perform are ones to ensure that your provider is found, and that its name, version number, and additional information is as expected. To do so, you could write code like the following, substituting your provider name for MyPro:

    import java.security.*;

    Provider p = Security.getProvider("MyPro");

    System.out.println("MyPro provider name is " + p.getName());
    System.out.println("MyPro provider version # is " + p.getVersion());
    System.out.println("MyPro provider info is " + p.getInfo());

Next, you should ensure that your services are found. For instance, if you implemented the DES encryption algorithm, you could check to ensure it's found when requested by using the following code (again substituting your provider name for "MyPro"):

    Cipher c = Cipher.getInstance("DES", "MyPro");

    System.out.println("My Cipher algorithm name is " + c.getAlgorithm());

If you don't specify a provider name in the call to getInstance, all registered providers will be searched, in preference order (see Configuring the Provider), until one implementing the algorithm is found.

If your provider implements an exemption mechanism, you should write a test applet or application that uses the exemption mechanism. Such an applet/application also needs to be signed, and needs to have a "permission policy file" bundled with it. See How to Make Applications "Exempt" from Cryptographic Restrictions in the Java Cryptography Architecture Reference Guide for complete information on creating and testing such an application.

Step 9: Run your Test Programs

Run your test program(s). Debug your code and continue testing as needed. If the Java Security API cannot seem to find one of your algorithms, review the steps above and ensure they are all completed.

Be sure to include testing of your programs using different installation options (e.g. making the provider an installed extension or placing it on the class path) and execution environments (with or without a security manager running). Installation options are discussed in Step 7.1. In particular, you need to ensure your provider works when a security manager is installed and the provider is not an installed extension -- and thus the provider must have permissions granted to it; therefore, you need to test such an installation and execution environment, after granting required permissions to your provider and to any other providers it uses, as described in Step 7.2.

If you find during testing that your code needs modification, make the changes, recompile (Step 4), place the updated provider code in a JAR file (Step 6), sign the JAR file if necessary (Step 6.2), re-install the provider (Step 7.1), if needed fix or add to the permissions (Step 7.2), and then re-test your programs. Repeat these steps as needed.

Step 10: Apply for U.S. Government Export Approval If Required

All U.S. vendors whose providers may be exported outside the U.S. should apply to the Bureau of Industry and Security in the U.S. Department of Commerce for export approval. Please consult your export counsel for more information.

Note: If your provider calls Cipher.getInstance() and the returned Cipher object needs to perform strong cryptography regardless of what cryptographic strength is allowed by the user's downloaded jurisdiction policy files, you should include a copy of the cryptoPerms permission policy file which you intend to bundle in the JAR file for your provider and which specifies an appropriate permission for the required cryptographic strength. The necessity for this file is just like the requirement that applets and applications "exempt" from cryptographic restrictions must include a cryptoPerms permission policy file in their JAR file. For more information on the creation and inclusion of such a file, see How to Make Applications "Exempt" from Cryptographic Restrictions in the Java Cryptography Architecture Reference Guide.

Here are two URLs that may be useful:

  • U.S. Department of Commerce: http://www.commerce.gov
  • Bureau of Industry and Security: http://www.bis.doc.gov

Step 11: Document your Provider and its Supported Services

The next step is to write documentation for your clients. At the minimum, you need to specify:

  • the name programs should use to refer to your provider. Note: As of this writing, provider name searches are case-sensitive. That is, if your master class specifies your provider name as "CryptoX" but a user requests "CRYPTOx", your provider will not be found. This behavior may change in the future, but for now be sure to warn your clients to use the exact case you specify.
  • the types of algorithms and other services implemented by your provider.
  • instructions for installing the provider, similar to those provided in Step 7.1, except that the information and examples should be specific to your provider.
  • the permissions your provider will require if it is not installed as an installed extension and if a security manager is run, as described in Step 7.2.

In addition, your documentation should specify anything else of interest to clients, such as any default algorithm parameters.

Message Digests and MACs

For each Message Digest and MAC algorithm, indicate whether or not your implementation is cloneable. This is not technically necessary, but it may save clients some time and coding by telling them whether or not intermediate Message Digests or MACs may be possible through cloning. Clients who do not know whether or not a MessageDigest or Mac implementation is cloneable can find out by attempting to clone the object and catching the potential exception, as illustrated by the following example:

    try {
        // try and clone it
        /* compute the MAC for i1 */
        mac.update(i1);
        byte[] i1Mac = mac.clone().doFinal();

        /* compute the MAC for i1 and i2 */
        mac.update(i2);
        byte[] i12Mac = mac.clone().doFinal();

        /* compute the MAC for i1, i2 and i3 */
        mac.update(i3);
        byte[] i123Mac = mac.doFinal();
    } catch (CloneNotSupportedException cnse) {
        // have to use an approach not involving cloning
    }

where:

  • mac is the MAC object they received when they requested one via a call to Mac.getInstance,
  • i1, i2 and i3 are input byte arrays, and
  • they want to calculate separate hashes for:
    • i1
    • i1 and i2
    • i1, i2, and i3

Key Pair Generators

For a key pair generator algorithm, in case the client does not explicitly initialize the key pair generator (via a call to an initialize method), each provider must supply and document a default initialization. For example, the Diffie-Hellman key pair generator supplied by the SunJCE provider uses a default prime modulus size (keysize) of 1024 bits.

Key Factories

A provider should document all the key specifications supported by its (secret-)key factory.

Algorithm Parameter Generators

In case the client does not explicitly initialize the algorithm parameter generator (via a call to an init method in the AlgorithmParameterGenerator engine class), each provider must supply and document a default initialization. For example, the SunJCE provider uses a default prime modulus size (keysize) of 1024 bits for the generation of Diffie-Hellman parameters, the Sun provider a default modulus prime size of 1024 bits for the generation of DSA parameters.

Signature Algorithms

If you implement a signature algorithm, you should document the format in which the signature (generated by one of the sign methods) is encoded. For example, the SHA1withDSA signature algorithm supplied by the "SUN" provider encodes the signature as a standard ASN.1 SEQUENCE of two integers, r and s.

Random Number Generation (SecureRandom) Algorithms

For a random number generation algorithm, provide information regarding how "random" the numbers generated are, and the quality of the seed when the random number generator is self-seeding. Also note what happens when a SecureRandom object (and its encapsulated SecureRandomSpi implementation object) is deserialized: If subsequent calls to the nextBytes method (which invokes the engineNextBytes method of the encapsulated SecureRandomSpi object) of the restored object yield the exact same (random) bytes as the original object would, then let users know that if this behaviour is undesirable, they should seed the restored random object by calling its setSeed method.

Certificate Factories

A provider should document what types of certificates (and their version numbers, if relevant), can be created by the factory.

Keystores

A provider should document any relevant information regarding the keystore implementation, such as its underlying data format.

Step 12: Make your Class Files and Documentation Available to Clients

After writing, configuring, testing, installing and documenting your provider software, make documentation available to your customers.

How a Provider Can Do Self-Integrity Checking

Each provider should do self-integrity checking to ensure that the JAR file containing its code has not been tampered with, for example in an attempt to invoke provider methods directly rather than through JCA. Providers that provide implementations for encryption services (Cipher, KeyAgreement, KeyGenerator, MAC or SecretKey factory) must be digitally signed and should be signed with a certificate issued by "trusted" Certification Authorities. Currently, the following two Certification Authorities are considered "trusted":

  • Sun Microsystems' JCA Code Signing CA, and
  • IBM JCA Code Signing CA.

Please refer to Step 6.2 for detailed information on how to get a code-signing certificate from Sun Microsystems' JCA Code Signing CA and the certificate of that CA.

After getting the signing certificate from above Certification Authority, provider packages should embed within themselves the bytes for its own signing certificate, for example in an array like the bytesOfProviderCert array referred to in the Identifying Each of the Signers and Determining If One is Trusted section below. At runtime, the embedded certificate will be used in determining whether or not the provider code is authentic.

The basic approach a provider can use to check its own integrity is:

  1. Determine the URL of the JAR file containing the provider code, and
  2. Verify the JAR file's digital signatures to ensure that at least one signer of each entry of the JAR file is trusted.

Each of these steps is described in the following sections:

  • Notes on the Sample Code
  • Finding the Provider JAR File: Basics
    • Determining the Provider's JAR File URL
    • Creating a JarFile Referring to the JAR File
  • Verifying the Provider JAR File: Basics
    • Verification Setup
    • JAR File Signature Check
    • Verifying Signatures
    • Ensuring Signers Are Trusted
      • Getting the List of Certificates
      • Identifying Each of the Signers and Determining If One is Trusted
  • Verifying Signatures
  • Ensuring Signers Are Trusted
    • Getting the List of Certificates
    • Identifying Each of the Signers and Determining If One is Trusted
    • Notes on myJCE Sample Code
Notes on the Sample Code

Note: The sample code MyJCE.java is a complete code example that implements these steps. You can download this code for your reference. The Notes on the Sample Code section traces how these concepts are implemented in the sample code.

IMPORTANT NOTE: In the unbundled version of JCE 1.2.x, (used with JDKs 1.2.x and 1.3.x), providers needed to include code to authenticate the JCA framework to assure themselves of the integrity and authenticity of the JCA that they plugged into. In JDK 6 and later, this is no longer necessary.

One implication is that a provider written just for JCE 1.2.2 will not work in JDK 6 because the provider's JCE framework authentication check will not work; the JCE framework code is no longer where the provider expects it to be. If you want your provider to work only with JDK 6, it should not have code to authenticate the JCE framework. On the other hand, if you want your provider to work both with JCE 1.2.2 and with JDK 6, then add a conditional statement. This way the provider code to authenticate the JCE framework is executed only when the provider is run with JCE 1.2.2. The following is sample code:

    Class cipherCls = Class.forName("javax.crypto.Cipher");

    CodeSource cs = cipherCls.getProtectionDomain().getCodeSource();
    if (cs != null) {
        // Authenticate JCE framework
         . . .
    }

Finding the Provider JAR File: Basics

Determining the Provider's JAR File URL

The URL for the provider's JAR file can be obtained by determining the provider's CodeSource and then calling the getLocation method on the CodeSource.

    URL providerURL = (URL) AccessController.doPrivileged(
        new PrivilegedAction) {
            public Object run() {
                CodeSource cs =
                    MyJCE.class.getProtectionDomain().getCodeSource();
                return cs.getLocation();
            }
        });

Creating a JarFile Referring to the JAR File

Once you have the URL for the provider's JAR file, you can create a java.util.jar.JarFile referring to the JAR file. This instance is needed in the step for verifying the Provider JAR file.

To create the JAR file, first open a connection to the specified URL by calling its openConnection method. Since the URL is a JAR URL, the type is java.net.JarURLConnection. Here's the basic code:

    // Prep the url with the appropriate protocol.
    jarURL =
        url.getProtocol().equalsIgnoreCase("jar") ? url :
            new URL("jar:" + url.toString() + "!/");

    // Retrieve the jar file using JarURLConnection
    JarFile jf = (JarFile) AccessController.doPrivileged(
        new PrivilegedExceptionAction() {
            public Object run() throws Exception {
                JarURLConnection conn =
                    (JarURLConnection) jarURL.openConnection();
        ...

Now that you have a JarURLConnection, you can call its getJarFile method to get the JAR file:

    // Always get a fresh copy, so we don't have to
    // worry about the stale file handle when the
    // cached jar is closed by some other application.
    conn.setUseCaches(false);
    jf = conn.getJarFile();

Verifying the Provider JAR File: Basics

Once you have determined the URL for your provider JAR file and you have created a JarFile referring to the JAR file, as shown in the steps above, you can then verify the file.

The basic approach is:

  1. Ensure that at least one of each entry's signer's certificates is equal to the provider's own code signing certificate.
  2. Go through all the entries in the JAR file and ensure the signature on each one verifies correctly.
  3. Ensure that at least one of each entry's signer's certificates can be traced back to a trusted Certification Authority.

Sample code for each of these steps is presented and described in the following sections:

  • Verification Setup
  • JAR File Signature Check
  • Verifying Signatures
  • Ensuring Signers Are Trusted
    • Getting the List of Certificates
    • Identifying Each of the Signers and Determining If One is Trusted

Verification Setup

Our approach is to define a class JarVerifier to handle the retrieval of a JAR file from a given URL and verify whether the JAR file is signed with the specified certificate.

The constructor of JarVerifier takes the provider URL as a parameter which will be used to retrieve the JAR file later.

The actual jar verification is implemented in the verify method which takes the provider code signing certificate as a parameter.

    public void verify(X509Certificate targetCert) throws IOException {
        // variable 'jarFile' is a JarFile object created
        // from the provider's Jar URL.
        ...
        Vector entriesVec = new Vector();

Basically the verify method will go through the JAR file entries twice: the first time checking the signature on each entry and the second time verifying the signer is trusted.

Note: In our code snippets the jarFile variable is the JarFile object of the provider's jar file.

JAR File Signature Check

An authentic provider JAR file is signed. So the JAR file has been tampered with if it isn't signed:

    // Ensure the jar file is signed.
    Manifest man = jarFile.getManifest();
    if (man == null) {
        throw new SecurityException("The provider is not signed");
    }

Verifying Signatures

The next step is to go through all the entries in the JAR file and ensure the signature on each one verifies correctly. One possible way to verify the signature on a JAR file entry is to simply read the file. If a JAR file is signed, the read method itself automatically performs the signature verification. Here is sample code:

    // Ensure all the entries' signatures verify correctly
    byte[] buffer = new byte[8192];
    Enumeration entries = jarFile.entries();

    while (entries.hasMoreElements()) {
        JarEntry je = (JarEntry) entries.nextElement();

        // Skip directories.
        if (je.isDirectory())
            continue;

        entriesVec.addElement(je);
        InputStream is = jarFile.getInputStream(je);

        // Read in each jar entry. A security exception will
        // be thrown if a signature/digest check fails.
        int n;
        while ((n = is.read(buffer, 0, buffer.length)) != -1) {
            // Don't care
        }
        is.close();
    }

Ensuring Signers Are Trusted

The code in the previous section verified the signatures of all the provider JAR file entries. The fact that they all verify correctly is a requirement, but it is not sufficient to verify the authenticity of the JAR file. A final requirement is that the signatures were generated by the same entity as the one that developed this provider. To test that the signatures are trusted, we can again go through each entry in the JAR file (this time using the entriesVec built in the previous step), and for each entry that must be signed (that is, each entry that is not a directory and that is not in the META-INF directory):

  1. Get the list of signer certificates for the entry.
  2. Identify each of the certificate chains and determine whether any of the certificate chains are trusted. At least one of the certificate chains must be trusted.

The loop setup is the following:

    Enumeration e = entriesVec.elements();
    while (e.hasMoreElements()) {
        JarEntry je = (JarEntry) e.nextElement();
        ...
    }

Getting the List of Certificates

The certificates for the signers of a JAR file entry JarEntry can be obtained simply by calling the JarEntry getCertificates method:

    Certificate[] certs = je.getCertificates();

Adding this line of code to the previous loop setup code, and adding code to ignore directories and files in the META-INF directory gives us:

    while (e.hasMoreElements()) {
        JarEntry je = (JarEntry) e.nextElement();

        // Every file must be signed except files in META-INF.
        Certificate[] certs = je.getCertificates();
        if ((certs == null) || (certs.length == 0)) {
            if (!je.getName().startsWith("META-INF"))
                throw new SecurityException(
                    "The provider has unsigned class files.");
            } else {
                // Check whether the file is signed by the expected
                // signer. The jar may be signed by multiple signers.
                // See if one of the signers is 'targetCert'.
                ...
            }
        ...

Identifying Each of the Signers and Determining If One is Trusted

The certificate array returned by the JarEntry getCertificates method contains one or more certificate chains. There is one chain per signer of the entry. Each chain contains one or more certificates. Each certificate in a chain authenticates the public key in the previous certificate.

The first certificate in a chain is the signer's certificate which contains the public key corresponding to the private key actually used to sign the entry. Each subsequent certificate is a certificate for the issuer of the previous certificate. Since the self-integrity check is based on whether the JAR file is signed with the provider's signing cert, the trust decision will be made upon only the first certificate, the signer's certificate.

We need to go through the array of certificate chains and check each chain and the associated signers until we find a trusted entity. For each JAR file entry, at least one of the signers must be trusted. A signer is considered "trusted" if and only if its certificate is equals to the embedded provider signing certificate.

The following sample code loops through all the certificate chains, compares the first certificate in a chain to the embedded provider signing certificate, and only returns true if a match is found.

    int startIndex = 0;
    X509Certificate[] certChain;
    boolean signedAsExpected = false;

    while ((certChain = getAChain(certs, startIndex)) != null) {
        if (certChain[0].equals(targetCert)) {
            // Stop since one trusted signer is found.
            signedAsExpected = true;
            break;
        }

        // Proceed to the next chain.
        startIndex += certChain.length;
    }

    if (!signedAsExpected) {
        throw new SecurityException(
            "The provider is not signed by a trusted signer");
    }

The getAChain method is defined as follows:

    /**
     * Extracts ONE certificate chain from the specified certificate array
     * which may contain multiple certificate chains, starting from index
     * 'startIndex'.
     */
    private static X509Certificate[] getAChain(
            Certificate[] certs, int startIndex) {

        if (startIndex > certs.length - 1)
            return null;

        int i;
        // Keep going until the next certificate is not the
        // issuer of this certificate.
        for (i = startIndex; i < certs.length - 1; i++) {
            if (!((X509Certificate)certs[i + 1]).getSubjectDN().
                    equals(((X509Certificate)certs[i]).getIssuerDN())) {
                break;
            }
        }

        // Construct and return the found certificate chain.
        int certChainSize = (i-startIndex) + 1;
        X509Certificate[] ret = new X509Certificate[certChainSize];
        for (int j = 0; j < certChainSize; j++ ) {
            ret[j] = (X509Certificate) certs[startIndex + j];
        }
        return ret;
    }

Notes on the myJCE Code Sample

The sample code, MyJCE.java, is a sample provider which has a method selfIntegrityChecking which performs self-integrity checking. It first determines the URL of its own provider JAR file and then verifies that the provider JAR file is signed with the embedded code-signing certificate.

Note: The method selfIntegrityChecking should be called by all the constructors of its cryptographic engine classes to ensure that its integrity is not compromised.

Provider MyJCE performs self-integrity checking in the following steps:

  1. Determine the URL to access the provider JAR file using its own class, MyJCE.class.
  2. Instantiate a JarVerifier object with the provider URL in Step 1.
  3. Create a X509Certificate object from the embedded byte array bytesOfProviderCert.
  4. Call the JarVerifier.verify method to verify all entries in the provider JAR file are signed and are signed with the same certificate instantiated in Step 3.

Note: The class JarVerifier will retrieve the JAR file from the given URL, make sure the JAR file is signed, all entries have valid signatures, and that entries are signed with the specified X509Certificate.

A security exception is thrown by JarVerifier.verify in several cases:

  • The certificate passed to verify is null (invalid).
  • When unable to retrieve JAR file from the given URL.
  • The provider is not signed. (The jar has no manifest.)
  • The provider has unsigned class files.
  • The provider is not signed with the specified certificate.

The MyJCE.java sample code is comprised of the code snippets shown above. In addition, it includes error handling, sample code signing certificate bytes, and code for instantiating a X509Certificate object from the embedded sample code signing certificate bytes.

Regarding the use of AccessController.doPrivileged, please see API For Privileged Blocks for information on the use of doPrivileged.

Further Implementation Details and Requirements

Alias Names

For many cryptographic algorithms and types, there is a single official "standard name" defined in Appendix A of the Java Cryptography Architecture Reference Guide.

For example, "MD5" is the standard name for the RSA-MD5 Message Digest algorithm defined by RSA DSI in RFC 1321. DiffieHellman is the standard for the Diffie-Hellman key agreement algorithm defined in PKCS3.

In the JDK, there is an aliasing scheme that enables clients to use aliases when referring to algorithms or types, rather than their standard names. For example, the "SUN" provider's master class (Sun.java) defines the alias "SHA1/DSA" for the algorithm whose standard name is "SHA1withDSA". Thus, the following statements are equivalent:

    Signature sig = Signature.getInstance("SHA1withDSA", "SUN");

    Signature sig = Signature.getInstance("SHA1/DSA", "SUN");

Aliases can be defined in your "master class" (see Step 3). To define an alias, create a property named

    Alg.Alias.engineClassName.aliasName

where engineClassName is the name of an engine class (e.g., Signature), and aliasName is your alias name. The value of the property must be the standard algorithm (or type) name for the algorithm (or type) being aliased.

As an example, the "SUN" provider defines the alias "SHA1/DSA" for the signature algorithm whose standard name is "SHA1withDSA" by setting a property named Alg.Alias.Signature.SHA1/DSA to have the value SHA1withDSA via the following:

    put("Alg.Alias.Signature.SHA1/DSA", "SHA1withDSA");

Note that aliases defined by one provider are available only to that provider and not to any other providers. Thus, aliases defined by the SunJCE provider are available only to the SunJCE provider.

Service Interdependencies

Some algorithms require the use of other types of algorithms. For example, a PBE algorithm usually needs to use a message digest algorithm in order to transform a password into a key.

If you are implementing one type of algorithm that requires another, you can do one of the following:

  1. Provide your own implementations for both.
  2. Let your implementation of one algorithm use an instance of the other type of algorithm, as supplied by the default Sun provider that is included with every Java SE Platform installation. For example, if you are implementing a PBE algorithm that requires a message digest algorithm, you can obtain an instance of a class implementing the MD5 message digest algorithm by calling
        MessageDigest.getInstance("MD5", "SUN")
  3. Let your implementation of one algorithm use an instance of the other type of algorithm, as supplied by another specific provider. This is only appropriate if you are sure that all clients who will use your provider will also have the other provider installed.
  4. Let your implementation of one algorithm use an instance of the other type of algorithm, as supplied by another (unspecified) provider. That is, you can request an algorithm by name, but without specifying any particular provider, as in
        MessageDigest.getInstance("MD5")
    This is only appropriate if you are sure that there will be at least one implementation of the requested algorithm (in this case, MD5) installed on each Java platform where your provider will be used.

Here are some common types of algorithm interdependencies:

Signature and Message Digest Algorithms

A signature algorithm often requires use of a message digest algorithm. For example, the SHA1withDSA signature algorithm requires the SHA-1 message digest algorithm.

Signature and (Pseudo-)Random Number Generation Algorithms

A signature algorithm often requires use of a (pseudo-)random number generation algorithm. For example, such an algorithm is required in order to generate a DSA signature.

Key Pair Generation and Message Digest Algorithms

A key pair generation algorithm often requires use of a message digest algorithm. For example, DSA keys are generated using the SHA-1 message digest algorithm.

Algorithm Parameter Generation and Message Digest Algorithms

An algorithm parameter generator often requires use of a message digest algorithm. For example, DSA parameters are generated using the SHA-1 message digest algorithm.

KeyStores and Message Digest Algorithms

A keystore implementation will often utilize a message digest algorithm to compute keyed hashes (where the key is a user-provided password) to check the integrity of a keystore and make sure that the keystore has not been tampered with.

Key Pair Generation Algorithms and Algorithm Parameter Generators

A key pair generation algorithm sometimes needs to generate a new set of algorithm parameters. It can either generate the parameters directly, or use an algorithm parameter generator.

Key Pair Generation, Algorithm Parameter Generation, and (Pseudo-)Random Number Generation Algorithms

A key pair generation algorithm may require a source of randomness in order to generate a new key pair and possibly a new set of parameters associated with the keys. That source of randomness is represented by a SecureRandom object. The implementation of the key pair generation algorithm may generate the key parameters itself, or may use an algorithm parameter generator to generate them, in which case it may or may not initialize the algorithm parameter generator with a source of randomness.

Algorithm Parameter Generators and Algorithm Parameters

An algorithm parameter generator's engineGenerateParameters method must return an AlgorithmParameters instance.

Signature and Key Pair Generation Algorithms or Key Factories

If you are implementing a signature algorithm, your implementation's engineInitSign and engineInitVerify methods will require passed-in keys that are valid for the underlying algorithm (e.g., DSA keys for the DSS algorithm). You can do one of the following:

  1. Also create your own classes implementing appropriate interfaces (e.g. classes implementing the DSAPrivateKey and DSAPublicKey interfaces from the package java.security.interfaces), and create your own key pair generator and/or key factory returning keys of those types. Require the keys passed to engineInitSign and engineInitVerify to be the types of keys you have implemented, that is, keys generated from your key pair generator or key factory. Or you can,
  2. Accept keys from other key pair generators or other key factories, as long as they are instances of appropriate interfaces that enable your signature implementation to obtain the information it needs (such as the private and public keys and the key parameters). For example, the engineInitSign method for a DSS Signature class could accept any private keys that are instances of java.security.interfaces.DSAPrivateKey.

KeyStores and Key and Certificate Factories

A keystore implementation will often utilize a key factory to parse the keys stored in the keystore, and a certificate factory to parse the certificates stored in the keystore.

Default Initializations

In case the client does not explicitly initialize a key pair generator or an algorithm parameter generator, each provider of such a service must supply (and document) a default initialization. For example, the Sun provider uses a default modulus size (strength) of 1024 bits for the generation of DSA parameters, and the "SunJCE" provider uses a default modulus size (keysize) of 1024 bits for the generation of Diffie-Hellman parameters.

Default Key Pair Generator Parameter Requirements

If you implement a key pair generator, your implementation should supply default parameters that are used when clients don't specify parameters. The documentation you supply (Step 11) should state what the default parameters are.

For example, the DSA key pair generator in the Sun provider supplies a set of pre-computed p, q, and g default values for the generation of 512, 768, and 1024-bit key pairs. The following p, q, and g values are used as the default values for the generation of 1024-bit DSA key pairs:

p = fd7f5381 1d751229 52df4a9c 2eece4e7 f611b752 3cef4400 c31e3f80
    b6512669 455d4022 51fb593d 8d58fabf c5f5ba30 f6cb9b55 6cd7813b
    801d346f f26660b7 6b9950a5 a49f9fe8 047b1022 c24fbba9 d7feb7c6
    1bf83b57 e7c6a8a6 150f04fb 83f6d3c5 1ec30235 54135a16 9132f675
    f3ae2b61 d72aeff2 2203199d d14801c7

q = 9760508f 15230bcc b292b982 a2eb840b f0581cf5

g = f7e1a085 d69b3dde cbbcab5c 36b857b9 7994afbb fa3aea82 f9574c0b
    3d078267 5159578e bad4594f e6710710 8180b449 167123e8 4c281613
    b7cf0932 8cc8a6e1 3c167a8b 547c8d28 e0a3ae1e 2bb3a675 916ea37f
    0bfa2135 62f1fb62 7a01243b cca4f1be a8519089 a883dfe1 5ae59f06
    928b665e 807b5525 64014c3b fecf492a

(The p and q values given here were generated by the prime generation standard, using the 160-bit

SEED:  8d515589 4229d5e6 89ee01e6 018a237e 2cae64cd

With this seed, the algorithm found p and q when the counter was at 92.)

The Provider.Service Class

Since its introduction, security providers have published their service information via appropriately formatted key-value String pairs they put in their Hashtable entries. While this mechanism is simple and convenient, it limits the amount customization possible. As a result, JDK 5.0 introduced a second option, the Provider.Service class. It offers an alternative way for providers to advertise their services and supports additional features as described below. Note that this addition is fully compatible with the older method of using String valued Hashtable entries. A provider on JDK 5.0 can choose either method as it prefers, or even use both at the same time.

A Provider.Service object encapsulates all information about a service. This is the provider that offers the service, its type (e.g. MessageDigest or Signature), the algorithm name, and the name of the class that implements the service. Optionally, it also includes a list of alternate algorithm names for this service (aliases) and attributes, which are a map of (name, value) String pairs. In addition, it defines the methods newInstance() and supportsParameter(). They have default implementations, but can be overridden by providers if needed, as may be the case with providers that interface with hardware security tokens.

The newInstance() method is used by the security framework when it needs to construct new implementation instances. The default implementation uses reflection to invoke the standard constructor for the respective type of service. For all standard services except CertStore, this is the no-args constructor. The constructorParameter to newInstance() must be null in theses cases. For services of type CertStore, the constructor that takes a CertStoreParameters object is invoked, and constructorParameter must be a non-null instance of CertStoreParameters. A security provider can override the newInstance() method to implement instantiation as appropriate for that implementation. It could use direct invocation or call a constructor that passes additional information specific to the Provider instance or token. For example, if multiple Smartcard readers are present on the system, it might pass information about which reader the newly created service is to be associated with. However, despite customization all implementations must follow the conventions about constructorParameter described above.

The supportsParameter() tests whether the Service can use the specified parameter. It returns false if this service cannot use the parameter. It returns true if this service can use the parameter, if a fast test is infeasible, or if the status is unknown. It is used by the security framework with some types of services to quickly exclude non-matching implementations from consideration. It is currently only defined for the following standard services: Signature, Cipher, Mac, and KeyAgreement. The parameter must be an instance of Key in these cases. For example, for Signature services, the framework tests whether the service can use the supplied Key before instantiating the service. The default implementation examines the attributes SupportedKeyFormats and SupportedKeyClasses as described below. Again, a provider may override this methods to implement additional tests.

The SupportedKeyFormats attribute is a list of the supported formats for encoded keys (as returned by key.getFormat()) separated by the "|" (pipe) character. For example, X.509|PKCS#8. The SupportedKeyClasses attribute is a list of the names of classes of interfaces separated by the "|" character. A key object is considered to be acceptable if it is assignable to at least one of those classes or interfaces named. In other words, if the class of the key object is a subclass of one of the listed classes (or the class itself) or if it implements the listed interface. An example value is "java.security.interfaces.RSAPrivateKey|java.security.interfaces.RSAPublicKey" .

Four methods have been added to the Provider class for adding and looking up Services. As mentioned earlier, the implementation of those methods and also of the existing Properties methods have been specifically designed to ensure compatibility with existing Provider subclasses. This is achieved as follows:

If legacy Properties methods are used to add entries, the Provider class makes sure that the property strings are parsed into equivalent Service objects prior to lookup via getService(). Similarly, if the putService() method is used, equivalent property strings are placed into the provider's hashtable at the same time. If a provider implementation overrides any of the methods in the Provider class, it has to ensure that its implementation does not interfere with this conversion. To avoid problems, we recommend that implementations do not override any of the methods in the Provider class.

Signature Formats

If you implement a signature algorithm, the documentation you supply (Step 11) should specify the format in which the signature (generated by one of the sign methods) is encoded.

For example, the SHA1withDSA signature algorithm supplied by the Sun provider encodes the signature as a standard ASN.1 sequence of two ASN.1 INTEGER values: r and s, in that order:

SEQUENCE ::= {
        r INTEGER,
        s INTEGER }

DSA Interfaces and their Required Implementations

The Java Security API contains the following interfaces (in the java.security.interfaces package) for the convenience of programmers implementing DSA services:

  • DSAKey
  • DSAKeyPairGenerator
  • DSAParams
  • DSAPrivateKey
  • DSAPublicKey

The following sections discuss requirements for implementations of these interfaces.

DSAKeyPairGenerator

The interface DSAKeyPairGenerator is obsolete. It used to be needed to enable clients to provide DSA-specific parameters to be used rather than the default parameters your implementation supplies. However, in Java it is no longer necessary; a new KeyPairGenerator initialize method that takes an AlgorithmParameterSpec parameter enables clients to indicate algorithm-specific parameters.

DSAParams Implementation

If you are implementing a DSA key pair generator, you need a class implementing DSAParams for holding and returning the p, q, and g parameters.

A DSAParams implementation is also required if you implement the DSAPrivateKey and DSAPublicKey interfaces. DSAPublicKey and DSAPrivateKey both extend the DSAKey interface, which contains a getParams method that must return a DSAParams object. See DSAPrivateKey and DSAPublicKey Implementations for more information.

Note: there is a DSAParams implementation built into the JDK: the java.security.spec.DSAParameterSpec class.

DSAPrivateKey and DSAPublicKey Implementations

If you implement a DSA key pair generator or key factory, you need to create classes implementing the DSAPrivateKey and DSAPublicKey interfaces.

If you implement a DSA key pair generator, your generateKeyPair method (in your KeyPairGeneratorSpi subclass) will return instances of your implementations of those interfaces.

If you implement a DSA key factory, your engineGeneratePrivate method (in your KeyFactorySpi subclass) will return an instance of your DSAPrivateKey implementation, and your engineGeneratePublic method will return an instance of your DSAPublicKey implementation.

Also, your engineGetKeySpec and engineTranslateKey methods will expect the passed-in key to be an instance of a DSAPrivateKey or DSAPublicKey implementation. The getParams method provided by the interface implementations is useful for obtaining and extracting the parameters from the keys and then using the parameters, for example as parameters to the DSAParameterSpec constructor called to create a parameter specification from parameter values that could be used to initialize a KeyPairGenerator object for DSA.

If you implement a DSA signature algorithm, your engineInitSign method (in your SignatureSpi subclass) will expect to be passed a DSAPrivateKey and your engineInitVerify method will expect to be passed a DSAPublicKey.

Please note: The DSAPublicKey and DSAPrivateKey interfaces define a very generic, provider-independent interface to DSA public and private keys, respectively. The engineGetKeySpec and engineTranslateKey methods (in your KeyFactorySpi subclass) could additionally check if the passed-in key is actually an instance of their provider's own implementation of DSAPrivateKey or DSAPublicKey, e.g., to take advantage of provider-specific implementation details. The same is true for the DSA signature algorithm engineInitSign and engineInitVerify methods (in your SignatureSpi subclass).

To see what methods need to be implemented by classes that implement the DSAPublicKey and DSAPrivateKey interfaces, first note the following interface signatures:

In the java.security.interfaces package:

   public interface DSAPrivateKey extends DSAKey,
                java.security.PrivateKey

   public interface DSAPublicKey extends DSAKey,
                java.security.PublicKey

   public interface DSAKey

In the java.security package:

   public interface PrivateKey extends Key

   public interface PublicKey extends Key

   public interface Key extends java.io.Serializable

In order to implement the DSAPrivateKey and DSAPublicKey interfaces, you must implement the methods they define as well as those defined by interfaces they extend, directly or indirectly.

Thus, for private keys, you need to supply a class that implements

  • the getX method from the DSAPrivateKey interface.
  • the getParams method from the java.security.interfaces.DSAKey interface, since DSAPrivateKey extends DSAKey. Note: The getParams method returns a DSAParams object, so you must also have a DSAParams implementation.
  • the getAlgorithm, getEncoded, and getFormat methods from the java.security.Key interface, since DSAPrivateKey extends java.security.PrivateKey, and PrivateKey extends Key.

    Similarly, for public DSA keys, you need to supply a class that implements:

    • the getY method from the DSAPublicKey interface.
    • the getParams method from the java.security.interfaces.DSAKey interface, since DSAPublicKey extends DSAKey. Note: The getParams method returns a DSAParams object, so you must also have a DSAParams implementation.
    • the getAlgorithm, getEncoded, and getFormat methods from the java.security.Key interface, since DSAPublicKey extends java.security.PublicKey, and PublicKey extends Key.

RSA Interfaces and their Required Implementations

The Java Security API contains the following interfaces (in the java.security.interfaces package) for the convenience of programmers implementing RSA services:

  • RSAPrivateKey
  • RSAPrivateCrtKey
  • RSAPublicKey

The following sections discuss requirements for implementations of these interfaces.

RSAPrivateKey, RSAPrivateCrtKey, and RSAPublicKey Implementations

If you implement an RSA key pair generator or key factory, you need to create classes implementing the RSAPrivateKey (and/or RSAPrivateCrtKey) and RSAPublicKey interfaces. (RSAPrivateCrtKey is the interface to an RSA private key, using the Chinese Remainder Theorem (CRT) representation.)

If you implement an RSA key pair generator, your generateKeyPair method (in your KeyPairGeneratorSpi subclass) will return instances of your implementations of those interfaces.

If you implement an RSA key factory, your engineGeneratePrivate method (in your KeyFactorySpi subclass) will return an instance of your RSAPrivateKey (or RSAPrivateCrtKey) implementation, and your engineGeneratePublic method will return an instance of your RSAPublicKey implementation.

Also, your engineGetKeySpec and engineTranslateKey methods will expect the passed-in key to be an instance of an RSAPrivateKey, RSAPrivateCrtKey, or RSAPublicKey implementation.

If you implement an RSA signature algorithm, your engineInitSign method (in your SignatureSpi subclass) will expect to be passed either an RSAPrivateKey or an RSAPrivateCrtKey, and your engineInitVerify method will expect to be passed an RSAPublicKey.

Please note: The RSAPublicKey, RSAPrivateKey, and RSAPrivateCrtKey interfaces define a very generic, provider-independent interface to RSA public and private keys. The engineGetKeySpec and engineTranslateKey methods (in your KeyFactorySpi subclass) could additionally check if the passed-in key is actually an instance of their provider's own implementation of RSAPrivateKey, RSAPrivateCrtKey, or RSAPublicKey, e.g., to take advantage of provider-specific implementation details. The same is true for the RSA signature algorithm engineInitSign and engineInitVerify methods (in your SignatureSpi subclass).

To see what methods need to be implemented by classes that implement the RSAPublicKey, RSAPrivateKey, and RSAPrivateCrtKey interfaces, first note the following interface signatures:

In the java.security.interfaces package:

    public interface RSAPrivateKey extends java.security.PrivateKey

    public interface RSAPrivateCrtKey extends RSAPrivateKey

    public interface RSAPublicKey extends java.security.PublicKey

In the java.security package:

    public interface PrivateKey extends Key

    public interface PublicKey extends Key

    public interface Key extends java.io.Serializable

In order to implement the RSAPrivateKey, RSAPrivateCrtKey, and RSAPublicKey interfaces, you must implement the methods they define as well as those defined by interfaces they extend, directly or indirectly.

Thus, for RSA private keys, you need to supply a class that implements:

  • the getModulus and getPrivateExponent methods from the RSAPrivateKey interface.
  • the getAlgorithm, getEncoded, and getFormat methods from the java.security.Key interface, since RSAPrivateKey extends java.security.PrivateKey, and PrivateKey extends Key.

Similarly, for RSA private keys using the Chinese Remainder Theorem (CRT) representation, you need to supply a class that implements:

  • all the methods listed above for RSA private keys, since RSAPrivateCrtKey extends java.security.interfaces.RSAPrivateKey.
  • the getPublicExponent, getPrimeP, getPrimeQ, getPrimeExponentP, getPrimeExponentQ, and getCrtCoefficient methods from the RSAPrivateKey interface.

For public RSA keys, you need to supply a class that implements:

  • the getModulus and getPublicExponent methods from the RSAPublicKey interface.
  • the getAlgorithm, getEncoded, and getFormat methods from the java.security.Key interface, since RSAPublicKey extends java.security.PublicKey, and PublicKey extends Key.

JCA contains a number of AlgorithmParameterSpec implementations for the most frequently used cipher and key agreement algorithm parameters. If you are operating on algorithm parameters that should be for a different type of algorithm not provided by JCA, you will need to supply your own AlgorithmParameterSpec implementation appropriate for that type of algorithm.

Diffie-Hellman Interfaces and their Required Implementations

JCA contains the following interfaces (in the javax.crypto.interfaces package) for the convenience of programmers implementing Diffie-Hellman services:

  • DHKey
  • DHPrivateKey
  • DHPublicKey

The following sections discuss requirements for implementations of these interfaces.

DHPrivateKey and DHPublicKey Implementations

If you implement a Diffie-Hellman key pair generator or key factory, you need to create classes implementing the DHPrivateKey and DHPublicKey interfaces.

If you implement a Diffie-Hellman key pair generator, your generateKeyPair method (in your KeyPairGeneratorSpi subclass) will return instances of your implementations of those interfaces.

If you implement a Diffie-Hellman key factory, your engineGeneratePrivate method (in your KeyFactorySpi subclass) will return an instance of your DHPrivateKey implementation, and your engineGeneratePublic method will return an instance of your DHPublicKey implementation.

Also, your engineGetKeySpec and engineTranslateKey methods will expect the passed-in key to be an instance of a DHPrivateKey or DHPublicKey implementation. The getParams method provided by the interface implementations is useful for obtaining and extracting the parameters from the keys. You can then use the parameters, for example, as parameters to the DHParameterSpec constructor called to create a parameter specification from parameter values used to initialize a KeyPairGenerator object for Diffie-Hellman.

If you implement the Diffie-Hellman key agreement algorithm, your engineInit method (in your KeyAgreementSpi subclass) will expect to be passed a DHPrivateKey and your engineDoPhase method will expect to be passed a DHPublicKey.

Note: The DHPublicKey and DHPrivateKey interfaces define a very generic, provider-independent interface to Diffie-Hellman public and private keys, respectively. The engineGetKeySpec and engineTranslateKey methods (in your KeyFactorySpi subclass) could additionally check if the passed-in key is actually an instance of their provider's own implementation of DHPrivateKey or DHPublicKey, e.g., to take advantage of provider-specific implementation details. The same is true for the Diffie-Hellman algorithm engineInit and engineDoPhase methods (in your KeyAgreementSpi subclass).

To see what methods need to be implemented by classes that implement the DHPublicKey and DHPrivateKey interfaces, first note the following interface signatures:

In the javax.crypto.interfaces package:

    public interface DHPrivateKey extends DHKey, java.security.PrivateKey

    public interface DHPublicKey extends DHKey, java.security.PublicKey

    public interface DHKey

In the java.security package:

    public interface PrivateKey extends Key

    public interface PublicKey extends Key

    public interface Key extends java.io.Serializable

To implement the DHPrivateKey and DHPublicKey interfaces, you must implement the methods they define as well as those defined by interfaces they extend, directly or indirectly.

Thus, for private keys, you need to supply a class that implements:

  • the getX method from the DHPrivateKey interface.
  • the getParams method from the javax.crypto.interfaces.DHKey interface, since DHPrivateKey extends DHKey.
  • the getAlgorithm, getEncoded, and getFormat methods from the java.security.Key interface, since DHPrivateKey extends java.security.PrivateKey, and PrivateKey extends Key.

Similarly, for public Diffie-Hellman keys, you need to supply a class that implements:

  • the getY method from the DHPublicKey interface.
  • the getParams method from the javax.crypto.interfaces.DHKey interface, since DHPublicKey extends DHKey.
  • the getAlgorithm, getEncoded, and getFormat methods from the java.security.Key interface, since DHPublicKey extends java.security.PublicKey, and PublicKey extends Key.

Interfaces for Other Algorithm Types

As noted above, the Java Security API contains interfaces for the convenience of programmers implementing services like DSA, RSA and ECC. If there are services without API support, you need to define your own APIs.

If you are implementing a key pair generator for a different algorithm, you should create an interface with one or more initialize methods that clients can call when they want to provide algorithm-specific parameters to be used rather than the default parameters your implementation supplies. Your subclass of KeyPairGeneratorSpi should implement this interface.

For algorithms without direct API support, it is recommended that you create similar interfaces and provide implementation classes. Your public key interface should extend the PublicKey interface. Similarly, your private key interface should extend the PrivateKey interface.

Algorithm Parameter Specification Interfaces and Classes

An algorithm parameter specification is a transparent representation of the sets of parameters used with an algorithm.

A transparent representation of parameters means that you can access each value individually, through one of the get methods defined in the corresponding specification class (e.g., DSAParameterSpec defines getP, getQ, and getG methods, to access the p, q, and g parameters, respectively).

This is contrasted with an opaque representation, as supplied by the AlgorithmParameters engine class, in which you have no direct access to the key material values; you can only get the name of the algorithm associated with the parameter set (via getAlgorithm) and some kind of encoding for the parameter set (via getEncoded).

If you supply an AlgorithmParametersSpi, AlgorithmParameterGeneratorSpi, or KeyPairGeneratorSpi implementation, you must utilize the AlgorithmParameterSpec interface, since each of those classes contain methods that take an AlgorithmParameterSpec parameter. Such methods need to determine which actual implementation of that interface has been passed in, and act accordingly.

JCA contains a number of AlgorithmParameterSpec implementations for the most frequently used signature, cipher and key agreement algorithm parameters. If you are operating on algorithm parameters that should be for a different type of algorithm not provided by JCA, you will need to supply your own AlgorithmParameterSpec implementation appropriate for that type of algorithm.

Java defines the following algorithm parameter specification interfaces and classes in the java.security.spec and javax.crypto.spec packages:

The AlgorithmParameterSpec Interface

AlgorithmParameterSpec is an interface to a transparent specification of cryptographic parameters.

This interface contains no methods or constants. Its only purpose is to group (and provide type safety for) all parameter specifications. All parameter specifications must implement this interface.

The DSAParameterSpec Class

This class (which implements the AlgorithmParameterSpec and DSAParams interfaces) specifies the set of parameters used with the DSA algorithm. It has the following methods:

    public BigInteger getP()

    public BigInteger getQ()

    public BigInteger getG()

These methods return the DSA algorithm parameters: the prime p, the sub-prime q, and the base g.

Many types of DSA services will find this class useful - for example, it is utilized by the DSA signature, key pair generator, algorithm parameter generator, and algorithm parameters classes implemented by the Sun provider. As a specific example, an algorithm parameters implementation must include an implementation for the getParameterSpec method, which returns an AlgorithmParameterSpec. The DSA algorithm parameters implementation supplied by Sun returns an instance of the DSAParameterSpec class.

The IvParameterSpec Class

This class (which implements the AlgorithmParameterSpec interface) specifies the initialization vector (IV) used with a cipher in feedback mode.

Method in IvParameterSpec
Method | Description
byte[] getIV() | Returns the initialization vector (IV).

The OAEPParameterSpec Class

This class specifies the set of parameters used with OAEP Padding, as defined in the PKCS #1 standard.

Methods in OAEPParameterSpec
Method | Description
String getDigestAlgorithm() | Returns the message digest algorithm name.
String getMGFAlgorithm() | Returns the mask generation function algorithm name.
AlgorithmParameterSpec getMGFParameters() | Returns the parameters for the mask generation function.
PSource getPSource() | Returns the source of encoding input P.

The PBEParameterSpec Class

This class (which implements the AlgorithmParameterSpec interface) specifies the set of parameters used with a password-based encryption (PBE) algorithm.

Methods in PBEParameterSpec
Method | Description
int getIterationCount() | Returns the iteration count.
byte[] getSalt() | Returns the salt.

The RC2ParameterSpec Class

This class (which implements the AlgorithmParameterSpec interface) specifies the set of parameters used with the RC2 algorithm.

Methods in RC2ParameterSpec
Method | Description
boolean equals(Object obj) | Tests for equality between the specified object and this object.
int getEffectiveKeyBits() | Returns the effective key size in bits.
byte[] getIV() | Returns the IV or null if this parameter set does not contain an IV.
int hashCode() | Calculates a hash code value for the object.

The RC5ParameterSpec Class

This class (which implements the AlgorithmParameterSpec interface) specifies the set of parameters used with the RC5 algorithm.

Methods in RC5ParameterSpec
Method | Description
boolean equals(Object obj) | Tests for equality between the specified object and this object.
byte[] getIV() | Returns the IV or null if this parameter set does not contain an IV.
int getRounds() | Returns the number of rounds.
int getVersion() | Returns the version.
int getWordSize() | Returns the word size in bits.
int hashCode() | Calculates a hash code value for the object.

The DHParameterSpec Class

This class (which implements the AlgorithmParameterSpec interface) specifies the set of parameters used with the Diffie-Hellman algorithm.

Methods in DHParameterSpec
Method | Description
BigInteger getG() | Returns the base generator g.
int getL() | Returns the size in bits, l, of the random exponent (private value).
BigInteger getP() | Returns the prime modulus p.

Many types of Diffie-Hellman services will find this class useful; for example, it is used by the Diffie-Hellman key agreement, key pair generator, algorithm parameter generator, and algorithm parameters classes implemented by the "SunJCE" provider. As a specific example, an algorithm parameters implementation must include an implementation for the getParameterSpec method, which returns an AlgorithmParameterSpec. The Diffie-Hellman algorithm parameters implementation supplied by "SunJCE" returns an instance of the DHParameterSpec class.

Key Specification Interfaces and Classes Required by Key Factories

A key factory provides bi-directional conversions between opaque keys (of type Key) and key specifications. If you implement a key factory, you thus need to understand and utilize key specifications. In some cases, you also need to implement your own key specifications.

Further information about key specifications, the interfaces and classes supplied in Java, and key factory requirements with respect to specifications, is provided below.

Key specifications are transparent representations of the key material that constitutes a key. If the key is stored on a hardware device, its specification may contain information that helps identify the key on the device.

A transparent representation of keys means that you can access each key material value individually, through one of the get methods defined in the corresponding specification class. For example, java.security.spec.DSAPrivateKeySpec defines getX, getP, getQ, and getG methods, to access the private key x, and the DSA algorithm parameters used to calculate the key: the prime p, the sub-prime q, and the base g.

This is contrasted with an opaque representation, as defined by the Key interface, in which you have no direct access to the parameter fields. In other words, an "opaque" representation gives you limited access to the key - just the three methods defined by the Key interface: getAlgorithm, getFormat, and getEncoded.

A key may be specified in an algorithm-specific way, or in an algorithm-independent encoding format (such as ASN.1). For example, a DSA private key may be specified by its components x, p, q, and g (see DSAPrivateKeySpec), or it may be specified using its DER encoding (see PKCS8EncodedKeySpec).

Java defines the following key specification interfaces and classes in the java.security.spec and javax.crypto.spec packages:

The KeySpec Interface

This interface contains no methods or constants. Its only purpose is to group (and provide type safety for) all key specifications. All key specifications must implement this interface.

Java supplies several classes implementing the KeySpec interface: DSAPrivateKeySpec, DSAPublicKeySpec, RSAPrivateKeySpec, RSAPublicKeySpec, EncodedKeySpec, PKCS8EncodedKeySpec, and X509EncodedKeySpec.

If your provider uses key types (e.g., Your_PublicKey_type and Your_PrivateKey_type) for which the JDK does not already provide corresponding KeySpec classes, there are two possible scenarios, one of which requires that you implement your own key specifications:

  1. If your users will never have to access specific key material values of your key type, you will not have to provide any KeySpec classes for your key type.

    In this scenario, your users will always create Your_PublicKey_type and Your_PrivateKey_type keys through the appropriate KeyPairGenerator supplied by your provider for that key type. If they want to store the generated keys for later usage, they retrieve the keys' encodings (using the getEncoded method of the Key interface). When they want to create an Your_PublicKey_type or Your_PrivateKey_type key from the encoding (e.g., in order to initialize a Signature object for signing or verification), they create an instance of X509EncodedKeySpec or PKCS8EncodedKeySpec from the encoding, and feed it to the appropriate KeyFactory supplied by your provider for that algorithm, whose generatePublic and generatePrivate methods will return the requested PublicKey (an instance of Your_PublicKey_type) or PrivateKey (an instance of Your_PrivateKey_type) object, respectively.
  2. If you anticipate a need for users to access specific key material values of your key type, or to construct a key of your key type from key material and associated parameter values, rather than from its encoding (as in the above case), you have to specify new KeySpec classes (classes that implement the KeySpec interface) with the appropriate constructor methods and get methods for returning key material fields and associated parameter values for your key type. You will specify those classes in a similar manner as is done by the DSAPrivateKeySpec and DSAPublicKeySpec classes. You need to ship those classes along with your provider classes, for example, as part of your provider JAR file.

The DSAPrivateKeySpec Class

This class (which implements the KeySpec Interface) specifies a DSA private key with its associated parameters. It has the following methods:

Method in DSAPrivateKeySpec | Description
public BigInteger getX() | Returns the private key x.
public BigInteger getP() | Returns the prime p.
public BigInteger getQ() | Returns the sub-prime q.
public BigInteger getG() | Returns the base g.

These methods return the private key x, and the DSA algorithm parameters used to calculate the key: the prime p, the sub-prime q, and the base g.

The DSAPublicKeySpec Class

This class (which implements the KeySpec Interface) specifies a DSA public key with its associated parameters. It has the following methods:

Method in DSAPublicKeySpec | Description
public BigInteger getY() | returns the public key y.
public BigInteger getP() | Returns the prime p.
public BigInteger getQ() | Returns the sub-prime q.
public BigInteger getG() | Returns the base g.

These methods return the public key y, and the DSA algorithm parameters used to calculate the key: the prime p, the sub-prime q, and the base g.

The RSAPrivateKeySpec Class

This class (which implements the KeySpec Interface) specifies an RSA private key. It has the following methods:

Method in RSAPrivateKeySpec | Description
public BigInteger getModulus() | Returns the modulus.
public BigInteger getPrivateExponent() | Returns the private exponent.

These methods return the RSA modulus n and private exponent d values that constitute the RSA private key.

The RSAPrivateCrtKeySpec Class

This class (which extends the RSAPrivateKeySpec class) specifies an RSA private key, as defined in the PKCS#1 standard, using the Chinese Remainder Theorem (CRT) information values. It has the following methods (in addition to the methods inherited from its superclass RSAPrivateKeySpec ):

Method in RSAPrivateCrtKeySpec | Description
public BigInteger getPublicExponent() | Returns the public exponent.
public BigInteger getPrimeP() | Returns the prime P.
public BigInteger getPrimeQ() | Returns the prime Q.
public BigInteger getPrimeExponentP() | Returns the primeExponentP.
public BigInteger getPrimeExponentQ() | Returns the primeExponentQ.
public BigInteger getCrtCoefficient() | Returns the crtCoefficient.

These methods return the public exponent e and the CRT information integers: the prime factor p of the modulus n, the prime factor q of n, the exponent d mod (p-1), the exponent d mod (q-1), and the Chinese Remainder Theorem coefficient (inverse of q) mod p.

An RSA private key logically consists of only the modulus and the private exponent. The presence of the CRT values is intended for efficiency.

The RSAPublicKeySpec Class

This class (which implements the KeySpec Interface) specifies an RSA public key. It has the following methods:

Method in RSAPublicKeySpec | Description
public BigInteger getModulus() | Returns the modulus.
public BigInteger getPublicExponent() | Returns the public exponent.

These methods return the RSA modulus n and public exponent e values that constitute the RSA public key.

The EncodedKeySpec Class

This abstract class (which implements the KeySpec Interface) represents a public or private key in encoded format.

Method in EncodedKeySpec | Description
public abstract byte[] getEncoded() | Returns the encoded key.
public abstract String getFormat() | Returns the name of the encoding format.

The JDK supplies two classes implementing the EncodedKeySpec interface: PKCS8EncodedKeySpec and X509EncodedKeySpec. If desired, you can supply your own EncodedKeySpec implementations for those or other types of key encodings.

The PKCS8EncodedKeySpec Class

This class, which is a subclass of EncodedKeySpec, represents the DER encoding of a private key, according to the format specified in the PKCS #8 standard.

Its getEncoded method returns the key bytes, encoded according to the PKCS #8 standard. Its getFormat method returns the string "PKCS#8".

The X509EncodedKeySpec Class

This class, which is a subclass of EncodedKeySpec, represents the DER encoding of a public or private key, according to the format specified in the X.509 standard.

Its getEncoded method returns the key bytes, encoded according to the X.509 standard. Its getFormat method returns the string "X.509". DHPrivateKeySpec, DHPublicKeySpec, DESKeySpec, DESedeKeySpec, PBEKeySpec, and SecretKeySpec.

The DHPrivateKeySpec Class

This class (which implements the KeySpec interface) specifies a Diffie-Hellman private key with its associated parameters.

Method in DHPrivateKeySpec | Description
BigInteger getG() | Returns the base generator g.
BigInteger getP() | Returns the prime modulus p.
BigInteger getX() | Returns the private value x.

The DHPublicKeySpec Class

This class (which implements the KeySpec interface) specifies a Diffie-Hellman public key with its associated parameters.

Method in DHPublicKeySpec | Description
BigInteger getG() | Returns the base generator g.
BigInteger getP() | Returns the prime modulus p.
BigInteger getY() | Returns the public value y.

The DESKeySpec Class

This class (which implements the KeySpec interface) specifies a DES key.

Method in DESKeySpec | Description
byte[] getKey() | Returns the DES key bytes.
static boolean isParityAdjusted(byte[] key, int offset) | Checks if the given DES key material is parity-adjusted.
static boolean isWeak(byte[] key, int offset) | Checks if the given DES key material is weak or semi-weak.

The DESedeKeySpec Class

This class (which implements the KeySpec interface) specifies a DES-EDE (Triple DES) key.

Method in DESedeKeySpec | Description
byte[] getKey() | Returns the DES-EDE key.
static boolean isParityAdjusted(byte[] key, int offset) | Checks if the given DES-EDE key is parity-adjusted.

The PBEKeySpec Class

This class implements the KeySpec interface. A user-chosen password can be used with password-based encryption (PBE); the password can be viewed as a type of raw key material. An encryption mechanism that uses this class can derive a cryptographic key from the raw key material.

Method in PBEKeySpec | Description
void clearPassword | Clears the internal copy of the password.
int getIterationCount | Returns the iteration count or 0 if not specified.
int getKeyLength | Returns the to-be-derived key length or 0 if not specified.
char[] getPassword | Returns a copy of the password.
byte[] getSalt | Returns a copy of the salt or null if not specified.

The SecretKeySpec Class

This class implements the KeySpec interface. Since it also implements the SecretKey interface, it can be used to construct a SecretKey object in a provider-independent fashion, i.e., without having to go through a provider-based SecretKeyFactory.

Method in SecretKeySpec | Description
boolean equals (Object obj) | Indicates whether some other object is "equal to" this one.
String getAlgorithm() | Returns the name of the algorithm associated with this secret key.
byte[] getEncoded() | Returns the key material of this secret key.
String getFormat() | Returns the name of the encoding format for this secret key.
int hashCode() | Calculates a hash code value for the object.

Secret-Key Generation

If you provide a secret-key generator (subclass of javax.crypto.KeyGeneratorSpi) for a particular secret-key algorithm, you may return the generated secret-key object (which must be an instance of javax.crypto.SecretKey, see engineGenerateKey) in one of the following ways:

  • You implement a class whose instances represent secret-keys of the algorithm associated with your key generator. Your key generator implementation returns instances of that class. This approach is useful if the keys generated by your key generator have provider-specific properties.
  • Your key generator returns an instance of SecretKeySpec, which already implements the javax.crypto.SecretKey interface. You pass the (raw) key bytes and the name of the secret-key algorithm associated with your key generator to the SecretKeySpec constructor. This approach is useful if the underlying (raw) key bytes can be represented as a byte array and have no key-parameters associated with them.

Adding New Object Identifiers

The following information applies to providers who supply an algorithm that is not listed as one of the standard algorithms in Appendix A of the Java Cryptography Architecture Reference Guide.

Mapping from OID to Name

Sometimes the JCA needs to instantiate a cryptographic algorithm implementation from an algorithm identifier (for example, as encoded in a certificate), which by definition includes the object identifier (OID) of the algorithm. For example, in order to verify the signature on an X.509 certificate, the JCA determines the signature algorithm from the signature algorithm identifier that is encoded in the certificate, instantiates a Signature object for that algorithm, and initializes the Signature object for verification.

For the JCA to find your algorithm, you must provide the object identifier of your algorithm as an alias entry for your algorithm in the provider master file.

    put("Alg.Alias.<engine_type>.1.2.3.4.5.6.7.8",
        "<algorithm_alias_name>");

Note that if your algorithm is known under more than one object identifier, you need to create an alias entry for each object identifier under which it is known.

An example of where the JCA needs to perform this type of mapping is when your algorithm ("Foo") is a signature algorithm and users run the keytool command and specify your (signature) algorithm alias.

    % keytool -genkeypair -sigalg 1.2.3.4.5.6.7.8

In this case, your provider master file should contain the following entries:

    put("Signature.Foo", "com.xyz.MyFooSignatureImpl");
    put("Alg.Alias.Signature.1.2.3.4.5.6.7.8", "Foo");

Other examples of where this type of mapping is performed are (1) when your algorithm is a keytype algorithm and your program parses a certificate (using the X.509 implementation of the SUN provider) and extracts the public key from the certificate in order to initialize a Signature object for verification, and (2) when keytool users try to access a private key of your keytype (for example, to perform a digital signature) after having generated the corresponding keypair. In these cases, your provider master file should contain the following entries:

    put("KeyFactory.Foo", "com.xyz.MyFooKeyFactoryImpl");
    put("Alg.Alias.KeyFactory.1.2.3.4.5.6.7.8", "Foo");

Mapping from Name to OID

If the JCA needs to perform the inverse mapping (that is, from your algorithm name to its associated OID), you need to provide an alias entry of the following form for one of the OIDs under which your algorithm should be known:

    put("Alg.Alias.Signature.OID.1.2.3.4.5.6.7.8", "MySigAlg");

If your algorithm is known under more than one object identifier, prefix the preferred one with "OID."

An example of where the JCA needs to perform this kind of mapping is when users run keytool in any mode that takes a -sigalg option. For example, when the -genkeypair and -certreq commands are invoked, the user can specify your (signature) algorithm with the -sigalg option.

Ensuring Exportability

A key feature of JCA is the exportability of the JCA framework and of the provider cryptography implementations if certain conditions are met.

Due to import control restrictions by the governments of a few countries, the jurisdiction policy files shipped with the JDK specify that "strong" but limited cryptography may be used. An "unlimited" version of these files indicating no restrictions on cryptographic strengths is available for those living in eligible countries (which is most countries). But only the "strong" version can be imported into those countries whose governments mandate restrictions. The JCA framework will enforce the restrictions specified in the installed jurisdiction policy files.

As noted elsewhere, you can write just one version of your provider software, implementing cryptography of maximum strength. It is up to JCA, not your provider, to enforce any jurisdiction policy file-mandated restrictions regarding the cryptographic algorithms and maximum cryptographic strengths available to applets/applications in different locations.

The conditions that must be met by your provider in order to enable it to be plugged into JCA are the following:

  • The constructor of each SPI implementation class should do self-integrity checking, as described in How a Provider Can Do Self-Integrity Checking.
  • The provider code should be written in such a way that provider classes become unusable if instantiated by an application directly, bypassing JCA. See Step 1: Write Your Service Implementation Code in the Steps to Implement and Integrate a Provider section.
  • The provider package must be signed by an entity trusted by the JCA framework. (See Step 6.1 through Step 6.2.) U.S. vendors whose providers may be exported outside the U.S. first need to apply for U.S. government export approval. (See Step 10.)

Appendix A: The Sun Provider Master Class

Below is an edited version of the Sun.java file, which contains a class named Sun that is the master class for the provider named Sun.

As with all master classes, this class is a subclass of Provider. It specifies the class names and package locations of all service implementations supplied by the Sun provider. This information is used by the getInstance methods of the engine classes to look up the various algorithms and other services when they are requested.

This code is supplied as an example of a provider master class.

/*
 * @(#)Sun.java 1.28 99/05/27
 *
 * Copyright (c) 1996, 1998, Oracle and/or its affiliates. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 *   - Redistributions of source code must retain the above copyright
 *     notice, this list of conditions and the following disclaimer.
 *
 *   - Redistributions in binary form must reproduce the above copyright
 *     notice, this list of conditions and the following disclaimer in the
 *     documentation and/or other materials provided with the distribution.
 *
 *   - Neither the name of Oracle nor the names of its
 *     contributors may be used to endorse or promote products derived
 *     from this software without specific prior written permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
 * IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
 * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR
 * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 * PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 */

package sun.security.provider;

import java.io.*;
import java.util.*;
import java.security.*;

/**
 * The SUN Security Provider.
 *
 * @author Benjamin Renaud
 *
 * @version 1.28, 05/27/99
 */

/**
 * Defines the SUN provider.
 *
 * Algorithms supported, and their names:
 *
 * - SHA is the message digest scheme described in FIPS 180-1.
 *   Aliases for SHA are SHA-1 and SHA1.
 *
 * - SHA1withDSA is the signature scheme described in FIPS 186.
 *   (SHA used in DSA is SHA-1: FIPS 186 with Change No 1.)
 *   Aliases for SHA1withDSA are DSA, DSS, SHA/DSA, SHA-1/DSA, SHA1/DSA,
 *   SHAwithDSA, DSAWithSHA1, and the object
 *   identifier strings "OID.1.3.14.3.2.13", "OID.1.3.14.3.2.27" and
 *   "OID.1.2.840.10040.4.3".
 *
 * - DSA is the key generation scheme as described in FIPS 186.
 *   Aliases for DSA include the OID strings "OID.1.3.14.3.2.12"
 *   and "OID.1.2.840.10040.4.1".
 *
 * - MD5 is the message digest scheme described in RFC 1321.
 *   There are no aliases for MD5.
 */

public final class Sun extends Provider {

    private static final String INFO = "SUN " +
    "(DSA key/parameter generation; DSA signing; " +
    "SHA-1, MD5 digests; SecureRandom; X.509 certificates; JKS keystore)";

    public Sun() {
        /* We are the SUN provider */
        super("SUN", 1.2, INFO);

        AccessController.doPrivileged(new java.security.PrivilegedAction() {
            public Object run() {

                /*
                 * Signature engines
                 */
                put("Signature.SHA1withDSA", "sun.security.provider.DSA");

                put("Alg.Alias.Signature.DSA", "SHA1withDSA");
                put("Alg.Alias.Signature.DSS", "SHA1withDSA");
                put("Alg.Alias.Signature.SHA/DSA", "SHA1withDSA");
                put("Alg.Alias.Signature.SHA-1/DSA", "SHA1withDSA");
                put("Alg.Alias.Signature.SHA1/DSA", "SHA1withDSA");
                put("Alg.Alias.Signature.SHAwithDSA", "SHA1withDSA");
                put("Alg.Alias.Signature.DSAWithSHA1", "SHA1withDSA");
                put("Alg.Alias.Signature.OID.1.2.840.10040.4.3",
                    "SHA1withDSA");
                put("Alg.Alias.Signature.1.2.840.10040.4.3", "SHA1withDSA");
                put("Alg.Alias.Signature.1.3.14.3.2.13", "SHA1withDSA");
                put("Alg.Alias.Signature.1.3.14.3.2.27", "SHA1withDSA");

                /*
                 *  Key Pair Generator engines
                 */
                put("KeyPairGenerator.DSA",
                    "sun.security.provider.DSAKeyPairGenerator");
                put("Alg.Alias.KeyPairGenerator.OID.1.2.840.10040.4.1", "DSA");
                put("Alg.Alias.KeyPairGenerator.1.2.840.10040.4.1", "DSA");
                put("Alg.Alias.KeyPairGenerator.1.3.14.3.2.12", "DSA");

                /*
                 * Digest engines
                 */
                put("MessageDigest.MD5", "sun.security.provider.MD5");
                put("MessageDigest.SHA", "sun.security.provider.SHA");

                put("Alg.Alias.MessageDigest.SHA-1", "SHA");
                put("Alg.Alias.MessageDigest.SHA1", "SHA");

                /*
                 * Algorithm Parameter Generator engines
                 */
                put("AlgorithmParameterGenerator.DSA",
                    "sun.security.provider.DSAParameterGenerator");

                /*
                 * Algorithm Parameter engines
                 */
                put("AlgorithmParameters.DSA",
                    "sun.security.provider.DSAParameters");
                put("Alg.Alias.AlgorithmParameters.1.3.14.3.2.12", "DSA");
                put("Alg.Alias.AlgorithmParameters.1.2.840.10040.4.1", "DSA");

                /*
                 * Key factories
                 */
                put("KeyFactory.DSA", "sun.security.provider.DSAKeyFactory");
                put("Alg.Alias.KeyFactory.1.3.14.3.2.12", "DSA");
                put("Alg.Alias.KeyFactory.1.2.840.10040.4.1", "DSA");

                /*
                 * SecureRandom
                 */
                 put("SecureRandom.SHA1PRNG",
                     "sun.security.provider.SecureRandom");

                /*
                 * Certificates
                 */
                put("CertificateFactory.X509",
                    "sun.security.provider.X509Factory");
                put("Alg.Alias.CertificateFactory.X.509", "X509");

                /*
                 * KeyStore
                 */
                put("KeyStore.JKS", "sun.security.provider.JavaKeyStore");

                /*
                 * KeySize
                 */
                put("Signature.SHA1withDSA KeySize", "1024");
                put("KeyPairGenerator.DSA KeySize", "1024");
                put("AlgorithmParameterGenerator.DSA KeySize", "1024");

                /*
                 * Implementation type: software or hardware
                 */
                put("Signature.SHA1withDSA ImplementedIn", "Software");
                put("KeyPairGenerator.DSA ImplementedIn", "Software");
                put("MessageDigest.MD5 ImplementedIn", "Software");
                put("MessageDigest.SHA ImplementedIn", "Software");
                put("AlgorithmParameterGenerator.DSA ImplementedIn",
                    "Software");
                put("AlgorithmParameters.DSA ImplementedIn", "Software");
                put("KeyFactory.DSA ImplementedIn", "Software");
                put("SecureRandom.SHA1PRNG ImplementedIn", "Software");
                put("CertificateFactory.X509 ImplementedIn", "Software");
                put("KeyStore.JKS ImplementedIn", "Software");

                return null;
            }
        });
    }
}

Appendix B: The SunJCE Provider Master Class

Below is an edited version of the SunJCE.java file, which contains a class named SunJCE that is the master class for the provider named SunJCE.

As with all master classes, this class is a subclass of Provider. It specifies the class names and package locations of all the cryptographic service implementations supplied by the SunJCE provider. This information is used by the getInstance methods of the engine classes to look up the various algorithms and other services when they are requested.

This code is supplied as an example of a provider master class.

/*
 * @(#)SunJCE.java      1.73 05/12/13
 *
 * Copyright (c) 2006, Oracle and/or its affiliates. All rights reserved.
 * ORACLE PROPRIETARY/CONFIDENTIAL. Use is subject to license terms.
 */

package com.sun.crypto.provider;

import java.security.*;
import java.security.cert.*;
import java.net.URL;
import java.io.ByteArrayInputStream;

/**
 * The "SunJCE" Cryptographic Service Provider.
 *
 * @author Jan Luehe
 * @author Sharon Liu
 *
 * @version 1.73, 12/13/05
 */

/**
 * Defines the "SunJCE" provider.
 *
 * Supported algorithms and their names:
 *
 * ...edited for space...
 *
 */

public final class SunJCE extends Provider {

    private static final String info = "SunJCE Provider " +
    "(implements RSA, DES, Triple DES, AES, Blowfish, ARCFOUR, RC2, PBE, "
    + "Diffie-Hellman, HMAC)";

    private static final String OID_PKCS5_MD5_DES = "1.2.840.113549.1.5.3";
    private static final String OID_PKCS3 = "1.2.840.113549.1.3.1";

    public SunJCE() {
        /* We are the "SunJCE" provider */
        super("SunJCE", 1.6d, info);

        final String BLOCK_MODES = "ECB|CBC|PCBC|CTR|CTS|CFB|OFB" +
            "|CFB8|CFB16|CFB24|CFB32|CFB40|CFB48|CFB56|CFB64" +
            "|OFB8|OFB16|OFB24|OFB32|OFB40|OFB48|OFB56|OFB64";
        final String BLOCK_MODES128 = BLOCK_MODES +
            "|CFB72|CFB80|CFB88|CFB96|CFB104|CFB112|CFB120|CFB128" +
            "|OFB72|OFB80|OFB88|OFB96|OFB104|OFB112|OFB120|OFB128";
        final String BLOCK_PADS = "NOPADDING|PKCS5PADDING|ISO10126PADDING";

        AccessController.doPrivileged(new java.security.PrivilegedAction() {
                public Object run() {

                /*
                 * Cipher engines
                 */
                put("Cipher.RSA", "com.sun.crypto.provider.RSACipher");
                put("Cipher.RSA SupportedModes", "ECB");
                put("Cipher.RSA SupportedPaddings",
                        "NOPADDING|PKCS1PADDING|OAEPWITHMD5ANDMGF1PADDING"
                        + "|OAEPWITHSHA1ANDMGF1PADDING"
                        + "|OAEPWITHSHA-1ANDMGF1PADDING"
                        + "|OAEPWITHSHA-256ANDMGF1PADDING"
                        + "|OAEPWITHSHA-384ANDMGF1PADDING"
                        + "|OAEPWITHSHA-512ANDMGF1PADDING");
                put("Cipher.RSA SupportedKeyClasses",
                        "java.security.interfaces.RSAPublicKey" +
                        "|java.security.interfaces.RSAPrivateKey");

                put("Cipher.PBEWithMD5AndDES",
                    "com.sun.crypto.provider.PBEWithMD5AndDESCipher");
                put("Alg.Alias.Cipher.OID."+OID_PKCS5_MD5_DES,
                    "PBEWithMD5AndDES");
                put("Alg.Alias.Cipher."+OID_PKCS5_MD5_DES,
                    "PBEWithMD5AndDES");

                put("Cipher.AES", "com.sun.crypto.provider.AESCipher");
                put("Alg.Alias.Cipher.Rijndael", "AES");
                put("Cipher.AES SupportedModes", BLOCK_MODES128);
                put("Cipher.AES SupportedPaddings", BLOCK_PADS);
                put("Cipher.AES SupportedKeyFormats", "RAW");

                put("Cipher.AESWrap", "com.sun.crypto.provider.AESWrapCipher");
                put("Cipher.AESWrap SupportedModes", "ECB");
                put("Cipher.AESWrap SupportedPaddings", "NOPADDING");
                put("Cipher.AESWrap SupportedKeyFormats", "RAW");

                put("Cipher.ARCFOUR",
                    "com.sun.crypto.provider.ARCFOURCipher");
                put("Alg.Alias.Cipher.RC4", "ARCFOUR");
                put("Cipher.ARCFOUR SupportedModes", "ECB");
                put("Cipher.ARCFOUR SupportedPaddings", "NOPADDING");
                put("Cipher.ARCFOUR SupportedKeyFormats", "RAW");

                /*
                 *  Key(pair) Generator engines
                 */
                put("KeyGenerator.AES",
                    "com.sun.crypto.provider.AESKeyGenerator");
                put("Alg.Alias.KeyGenerator.Rijndael", "AES");

                put("KeyGenerator.ARCFOUR",
                    "com.sun.crypto.provider.KeyGeneratorCore$" +
                    "ARCFOURKeyGenerator");
                put("Alg.Alias.KeyGenerator.RC4", "ARCFOUR");

                put("KeyGenerator.HmacMD5",
                    "com.sun.crypto.provider.HmacMD5KeyGenerator");

                put("KeyGenerator.HmacSHA256",
                    "com.sun.crypto.provider.KeyGeneratorCore$HmacSHA256KG");

                put("KeyPairGenerator.DiffieHellman",
                    "com.sun.crypto.provider.DHKeyPairGenerator");
                put("Alg.Alias.KeyPairGenerator.DH", "DiffieHellman");
                put("Alg.Alias.KeyPairGenerator.OID."+OID_PKCS3,
                    "DiffieHellman");
                put("Alg.Alias.KeyPairGenerator."+OID_PKCS3,
                    "DiffieHellman");

                /*
                 * Algorithm parameter generation engines
                 */
                put("AlgorithmParameterGenerator.DiffieHellman",
                    "com.sun.crypto.provider.DHParameterGenerator");
                put("Alg.Alias.AlgorithmParameterGenerator.DH",
                    "DiffieHellman");
                put("Alg.Alias.AlgorithmParameterGenerator.OID."+OID_PKCS3,
                    "DiffieHellman");
                put("Alg.Alias.AlgorithmParameterGenerator."+OID_PKCS3,
                    "DiffieHellman");

                /*
                 * Key Agreement engines
                 */
                put("KeyAgreement.DiffieHellman",
                    "com.sun.crypto.provider.DHKeyAgreement");
                put("Alg.Alias.KeyAgreement.DH", "DiffieHellman");
                put("Alg.Alias.KeyAgreement.OID."+OID_PKCS3, "DiffieHellman");
                put("Alg.Alias.KeyAgreement."+OID_PKCS3, "DiffieHellman");

                put("KeyAgreement.DiffieHellman SupportedKeyClasses",
                    "javax.crypto.interfaces.DHPublicKey" +
                    "|javax.crypto.interfaces.DHPrivateKey");

                /*
                 * Algorithm Parameter engines
                 */
                put("AlgorithmParameters.DiffieHellman",
                    "com.sun.crypto.provider.DHParameters");
                put("Alg.Alias.AlgorithmParameters.DH", "DiffieHellman");
                put("Alg.Alias.AlgorithmParameters.OID."+OID_PKCS3,
                    "DiffieHellman");
                put("Alg.Alias.AlgorithmParameters."+OID_PKCS3,
                    "DiffieHellman");

                put("AlgorithmParameters.PBEWithMD5AndDES",
                    "com.sun.crypto.provider.PBEParameters");
                put("Alg.Alias.AlgorithmParameters.OID."+OID_PKCS5_MD5_DES,
                    "PBEWithMD5AndDES");
                put("Alg.Alias.AlgorithmParameters."+OID_PKCS5_MD5_DES,
                    "PBEWithMD5AndDES");

                put("AlgorithmParameters.OAEP",
                    "com.sun.crypto.provider.OAEPParameters");

                /*
                 * Key factories
                 */
                put("KeyFactory.DiffieHellman",
                    "com.sun.crypto.provider.DHKeyFactory");
                put("Alg.Alias.KeyFactory.DH", "DiffieHellman");
                put("Alg.Alias.KeyFactory.OID."+OID_PKCS3,
                    "DiffieHellman");
                put("Alg.Alias.KeyFactory."+OID_PKCS3, "DiffieHellman");

                /*
                 * Secret-key factories
                 */
                put("SecretKeyFactory.PBEWithMD5AndDES",
                    "com.sun.crypto.provider.PBEKeyFactory$PBEWithMD5AndDES"
                    );
                put("Alg.Alias.SecretKeyFactory.OID."+OID_PKCS5_MD5_DES,
                    "PBEWithMD5AndDES");
                put("Alg.Alias.SecretKeyFactory."+OID_PKCS5_MD5_DES,
                    "PBEWithMD5AndDES");

                /*
                 * MAC
                 */
                put("Mac.HmacMD5", "com.sun.crypto.provider.HmacMD5");
                put("Mac.HmacSHA256",
                    "com.sun.crypto.provider.HmacCore$HmacSHA256");

                put("Mac.HmacMD5 SupportedKeyFormats", "RAW");
                put("Mac.HmacSHA256 SupportedKeyFormats", "RAW");

                /*
                 * KeyStore
                 */
                put("KeyStore.JCEKS", "com.sun.crypto.provider.JceKeyStore");

                return null;
            }
        });
    }
}

Appendix C: The java.security.properties File

Below is part of the java.security file that shows the default list of installed providers. It appears in every JRE installation. The file also contains other entries, but for brevity, we show only part of the file here. See the complete file at:

  • Solaris, Linux, or Mac OS X: <java-home>/lib/security/java.security
  • Windows: <java-home>\lib\security\java.security

Here <java-home> refers to the directory where the JRE was installed.

See Step 5 for an example of adding information about your provider to this file.

#
# This is the "master security properties file".
#
# In this file, various security properties are set for use by
# java.security classes. This is where users can statically register
# Cryptography Package Providers ("providers" for short). The term
# "provider" refers to a package or set of packages that supply a
# concrete implementation of a subset of the cryptography aspects of
# the Java Security API. A provider may, for example, implement one or
# more digital signature algorithms or message digest algorithms.
#
# Each provider must implement a subclass of the Provider class.
# To register a provider in this master security properties file,
# specify the Provider subclass name and priority in the format
#
#    security.provider.<n>=<className>
#
# This declares a provider, and specifies its preference
# order n. The preference order is the order in which providers are
# searched for requested algorithms (when no specific provider is
# requested). The order is 1-based; 1 is the most preferred, followed
# by 2, and so on.
#
# <className> must specify the subclass of the Provider class whose
# constructor sets the values of various properties that are required
# for the Java Security API to look up the algorithms or other
# facilities implemented by the provider.
#
# There must be at least one provider specification in java.security.
# There is a default provider that comes standard with the JDK. It
# is called the "SUN" provider, and its Provider subclass
# named Sun appears in the sun.security.provider package. Thus, the
# "SUN" provider is registered via the following:
#
#    security.provider.1=sun.security.provider.Sun
#
# (The number 1 is used for the default provider.)
#
# Note: Providers can be dynamically registered instead by calls to
# either the addProvider or insertProviderAt method in the Security
# class.

#
# List of providers and their preference orders (see above):
#

security.provider.1=sun.security.pkcs11.SunPKCS11 \
    ${java.home}/lib/security/sunpkcs11-solaris.cfg
security.provider.2=sun.security.provider.Sun
security.provider.3=sun.security.rsa.SunRsaSign
security.provider.4=com.sun.net.ssl.internal.ssl.Provider
security.provider.5=com.sun.crypto.provider.SunJCE
security.provider.6=sun.security.jgss.SunProvider
security.provider.7=com.sun.security.sasl.Provider
security.provider.8=org.jcp.xml.dsig.internal.dom.XMLDSigRI
security.provider.9=sun.security.smartcardio.SunPCSC

# Rest of file deleted
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration html_splash_75.gif

Documentation Contents

Splash screen for JavaFX applications in a web page. The image is a series of small circles arranged in a circle, half are blue and half ar white to indicate that the application is in the process of loading.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Description of the illustration html_splash_se8.gif

Documentation Contents

Splash screen for Java applications in a web page. The image is a series of small squares arranged in a circle around the Java logo. The squares fade from dark blue to light blue to indicate that the application is in the process of loading.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface org.w3c.dom.html.HTMLAnchorElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLAnchorElement

No usage of org.w3c.dom.html.HTMLAnchorElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLAppletElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLAppletElement

No usage of org.w3c.dom.html.HTMLAppletElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLAreaElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLAreaElement

No usage of org.w3c.dom.html.HTMLAreaElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLBaseElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLBaseElement

No usage of org.w3c.dom.html.HTMLBaseElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLBaseFontElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLBaseFontElement

No usage of org.w3c.dom.html.HTMLBaseFontElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLBodyElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLBodyElement

No usage of org.w3c.dom.html.HTMLBodyElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLBRElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLBRElement

No usage of org.w3c.dom.html.HTMLBRElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLButtonElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLButtonElement

No usage of org.w3c.dom.html.HTMLButtonElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLCollection (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLCollection

  • Packages that use HTMLCollection
    Package Description
    org.w3c.dom.html

    • Uses of HTMLCollection in org.w3c.dom.html

      Methods in org.w3c.dom.html that return HTMLCollection
      Modifier and Type Method and Description
      HTMLCollection HTMLDocument.getAnchors()
      A collection of all the anchor (A ) elements in a document with a value for the name attribute.
      HTMLCollection HTMLDocument.getApplets()
      A collection of all the OBJECT elements that include applets and APPLET ( deprecated ) elements in a document.
      HTMLCollection HTMLMapElement.getAreas()
      The list of areas defined for the image map.
      HTMLCollection HTMLTableRowElement.getCells()
      The collection of cells in this row.
      HTMLCollection HTMLFormElement.getElements()
      Returns a collection of all control elements in the form.
      HTMLCollection HTMLDocument.getForms()
      A collection of all the forms of a document.
      HTMLCollection HTMLDocument.getImages()
      A collection of all the IMG elements in a document.
      HTMLCollection HTMLDocument.getLinks()
      A collection of all AREA elements and anchor ( A ) elements in a document with a value for the href attribute.
      HTMLCollection HTMLSelectElement.getOptions()
      The collection of OPTION elements contained by this element.
      HTMLCollection HTMLTableElement.getRows()
      Returns a collection of all the rows in the table, including all in THEAD , TFOOT , all TBODY elements.
      HTMLCollection HTMLTableSectionElement.getRows()
      The collection of rows in this table section.
      HTMLCollection HTMLTableElement.getTBodies()
      Returns a collection of the defined table bodies.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLDirectoryElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLDirectoryElement

No usage of org.w3c.dom.html.HTMLDirectoryElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLDivElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLDivElement

No usage of org.w3c.dom.html.HTMLDivElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLDListElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLDListElement

No usage of org.w3c.dom.html.HTMLDListElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLDocument (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLDocument

  • Packages that use HTMLDocument
    Package Description
    org.w3c.dom.html

    • Uses of HTMLDocument in org.w3c.dom.html

      Methods in org.w3c.dom.html that return HTMLDocument
      Modifier and Type Method and Description
      HTMLDocument HTMLDOMImplementation.createHTMLDocument(String title)
      Creates an HTMLDocument object with the minimal tree made of the following elements: HTML , HEAD , TITLE , and BODY .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLDOMImplementation (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLDOMImplementation

No usage of org.w3c.dom.html.HTMLDOMImplementation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLElement

  • Packages that use HTMLElement
    Package Description
    org.w3c.dom.html

    • Uses of HTMLElement in org.w3c.dom.html

      Subinterfaces of HTMLElement in org.w3c.dom.html
      Modifier and Type Interface and Description
      interface  HTMLAnchorElement
      The anchor element.
      interface  HTMLAppletElement
      An embedded Java applet.
      interface  HTMLAreaElement
      Client-side image map area definition.
      interface  HTMLBaseElement
      Document base URI.
      interface  HTMLBaseFontElement
      Base font.
      interface  HTMLBodyElement
      The HTML document body.
      interface  HTMLBRElement
      Force a line break.
      interface  HTMLButtonElement
      Push button.
      interface  HTMLDirectoryElement
      Directory list.
      interface  HTMLDivElement
      Generic block container.
      interface  HTMLDListElement
      Definition list.
      interface  HTMLFieldSetElement
      Organizes form controls into logical groups.
      interface  HTMLFontElement
      Local change to font.
      interface  HTMLFormElement
      The FORM element encompasses behavior similar to a collection and an element.
      interface  HTMLFrameElement
      Create a frame.
      interface  HTMLFrameSetElement
      Create a grid of frames.
      interface  HTMLHeadElement
      Document head information.
      interface  HTMLHeadingElement
      For the H1 to H6 elements.
      interface  HTMLHRElement
      Create a horizontal rule.
      interface  HTMLHtmlElement
      Root of an HTML document.
      interface  HTMLIFrameElement
      Inline subwindows.
      interface  HTMLImageElement
      Embedded image.
      interface  HTMLInputElement
      Form control.
      interface  HTMLIsIndexElement
      This element is used for single-line text input.
      interface  HTMLLabelElement
      Form field label text.
      interface  HTMLLegendElement
      Provides a caption for a FIELDSET grouping.
      interface  HTMLLIElement
      List item.
      interface  HTMLLinkElement
      The LINK element specifies a link to an external resource, and defines this document's relationship to that resource (or vice versa).
      interface  HTMLMapElement
      Client-side image map.
      interface  HTMLMenuElement
      Menu list.
      interface  HTMLMetaElement
      This contains generic meta-information about the document.
      interface  HTMLModElement
      Notice of modification to part of a document.
      interface  HTMLObjectElement
      Generic embedded object.
      interface  HTMLOListElement
      Ordered list.
      interface  HTMLOptGroupElement
      Group options together in logical subdivisions.
      interface  HTMLOptionElement
      A selectable choice.
      interface  HTMLParagraphElement
      Paragraphs.
      interface  HTMLParamElement
      Parameters fed to the OBJECT element.
      interface  HTMLPreElement
      Preformatted text.
      interface  HTMLQuoteElement
      For the Q and BLOCKQUOTE elements.
      interface  HTMLScriptElement
      Script statements.
      interface  HTMLSelectElement
      The select element allows the selection of an option.
      interface  HTMLStyleElement
      Style information.
      interface  HTMLTableCaptionElement
      Table caption See the CAPTION element definition in HTML 4.0.
      interface  HTMLTableCellElement
      The object used to represent the TH and TD elements.
      interface  HTMLTableColElement
      Regroups the COL and COLGROUP elements.
      interface  HTMLTableElement
      The create* and delete* methods on the table allow authors to construct and modify tables.
      interface  HTMLTableRowElement
      A row in a table.
      interface  HTMLTableSectionElement
      The THEAD , TFOOT , and TBODY elements.
      interface  HTMLTextAreaElement
      Multi-line text field.
      interface  HTMLTitleElement
      The document title.
      interface  HTMLUListElement
      Unordered list.
      Methods in org.w3c.dom.html that return HTMLElement
      Modifier and Type Method and Description
      HTMLElement HTMLTableElement.createCaption()
      Create a new table caption object or return an existing one.
      HTMLElement HTMLTableElement.createTFoot()
      Create a table footer row or return an existing one.
      HTMLElement HTMLTableElement.createTHead()
      Create a table header row or return an existing one.
      HTMLElement HTMLDocument.getBody()
      The element that contains the content for the document.
      HTMLElement HTMLTableRowElement.insertCell(int index)
      Insert an empty TD cell into this row.
      HTMLElement HTMLTableElement.insertRow(int index)
      Insert a new empty row in the table.
      HTMLElement HTMLTableSectionElement.insertRow(int index)
      Insert a row into this section.
      Methods in org.w3c.dom.html with parameters of type HTMLElement
      Modifier and Type | Method and Description
      void HTMLSelectElement.add(HTMLElement element, HTMLElement before)
      Add a new element to the collection of OPTION elements for this SELECT .
      void | HTMLDocument.setBody(HTMLElement body)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLFieldSetElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLFieldSetElement

No usage of org.w3c.dom.html.HTMLFieldSetElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLFontElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLFontElement

No usage of org.w3c.dom.html.HTMLFontElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLFormElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLFormElement

  • Packages that use HTMLFormElement
    Package Description
    org.w3c.dom.html

    • Uses of HTMLFormElement in org.w3c.dom.html

      Methods in org.w3c.dom.html that return HTMLFormElement
      Modifier and Type Method and Description
      HTMLFormElement HTMLTextAreaElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLLegendElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLSelectElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLObjectElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLOptionElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLIsIndexElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLFieldSetElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLInputElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLLabelElement.getForm()
      Returns the FORM element containing this control.
      HTMLFormElement HTMLButtonElement.getForm()
      Returns the FORM element containing this control.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLFrameElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLFrameElement

No usage of org.w3c.dom.html.HTMLFrameElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLFrameSetElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLFrameSetElement

No usage of org.w3c.dom.html.HTMLFrameSetElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLHeadElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLHeadElement

No usage of org.w3c.dom.html.HTMLHeadElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLHeadingElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLHeadingElement

No usage of org.w3c.dom.html.HTMLHeadingElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLHRElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLHRElement

No usage of org.w3c.dom.html.HTMLHRElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLHtmlElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLHtmlElement

No usage of org.w3c.dom.html.HTMLHtmlElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLIFrameElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLIFrameElement

No usage of org.w3c.dom.html.HTMLIFrameElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLImageElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLImageElement

No usage of org.w3c.dom.html.HTMLImageElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLInputElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLInputElement

No usage of org.w3c.dom.html.HTMLInputElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLIsIndexElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLIsIndexElement

No usage of org.w3c.dom.html.HTMLIsIndexElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLLabelElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLLabelElement

No usage of org.w3c.dom.html.HTMLLabelElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLLegendElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLLegendElement

No usage of org.w3c.dom.html.HTMLLegendElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLLIElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLLIElement

No usage of org.w3c.dom.html.HTMLLIElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLLinkElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLLinkElement

No usage of org.w3c.dom.html.HTMLLinkElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLMapElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLMapElement

No usage of org.w3c.dom.html.HTMLMapElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLMenuElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLMenuElement

No usage of org.w3c.dom.html.HTMLMenuElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLMetaElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLMetaElement

No usage of org.w3c.dom.html.HTMLMetaElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLModElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLModElement

No usage of org.w3c.dom.html.HTMLModElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLObjectElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLObjectElement

No usage of org.w3c.dom.html.HTMLObjectElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLOListElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLOListElement

No usage of org.w3c.dom.html.HTMLOListElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLOptGroupElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLOptGroupElement

No usage of org.w3c.dom.html.HTMLOptGroupElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLOptionElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLOptionElement

No usage of org.w3c.dom.html.HTMLOptionElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLParagraphElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLParagraphElement

No usage of org.w3c.dom.html.HTMLParagraphElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLParamElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLParamElement

No usage of org.w3c.dom.html.HTMLParamElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLPreElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLPreElement

No usage of org.w3c.dom.html.HTMLPreElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLQuoteElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLQuoteElement

No usage of org.w3c.dom.html.HTMLQuoteElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLScriptElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLScriptElement

No usage of org.w3c.dom.html.HTMLScriptElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLSelectElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLSelectElement

No usage of org.w3c.dom.html.HTMLSelectElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLStyleElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLStyleElement

No usage of org.w3c.dom.html.HTMLStyleElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTableCaptionElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTableCaptionElement

  • Packages that use HTMLTableCaptionElement
    Package Description
    org.w3c.dom.html

    • Uses of HTMLTableCaptionElement in org.w3c.dom.html

      Methods in org.w3c.dom.html that return HTMLTableCaptionElement
      Modifier and Type Method and Description
      HTMLTableCaptionElement HTMLTableElement.getCaption()
      Returns the table's CAPTION , or void if none exists.
      Methods in org.w3c.dom.html with parameters of type HTMLTableCaptionElement
      Modifier and Type | Method and Description
      void | HTMLTableElement.setCaption(HTMLTableCaptionElement caption)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTableCellElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTableCellElement

No usage of org.w3c.dom.html.HTMLTableCellElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTableColElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTableColElement

No usage of org.w3c.dom.html.HTMLTableColElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTableElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTableElement

No usage of org.w3c.dom.html.HTMLTableElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTableRowElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTableRowElement

No usage of org.w3c.dom.html.HTMLTableRowElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTableSectionElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTableSectionElement

  • Packages that use HTMLTableSectionElement
    Package Description
    org.w3c.dom.html

    • Uses of HTMLTableSectionElement in org.w3c.dom.html

      Methods in org.w3c.dom.html that return HTMLTableSectionElement
      Modifier and Type Method and Description
      HTMLTableSectionElement HTMLTableElement.getTFoot()
      Returns the table's TFOOT , or null if none exists.
      HTMLTableSectionElement HTMLTableElement.getTHead()
      Returns the table's THEAD , or null if none exists.
      Methods in org.w3c.dom.html with parameters of type HTMLTableSectionElement
      Modifier and Type | Method and Description
      void | HTMLTableElement.setTFoot(HTMLTableSectionElement tFoot)
      void | HTMLTableElement.setTHead(HTMLTableSectionElement tHead)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTextAreaElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTextAreaElement

No usage of org.w3c.dom.html.HTMLTextAreaElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLTitleElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLTitleElement

No usage of org.w3c.dom.html.HTMLTitleElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Uses of Interface org.w3c.dom.html.HTMLUListElement (Common DOM API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.html.HTMLUListElement

No usage of org.w3c.dom.html.HTMLUListElement
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Common DOM API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Submit a bug or feature
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 2005, 2015, Oracle and/or its affiliates. 500 Oracle Parkway
Redwood Shores, CA 94065 USA. All rights reserved.


Http Authentication

Overview

The HTTP protocol handler implements a number of authentication schemes. JDK 6 supports the following:
  • HTTP Basic authentication (RFC2617)
  • HTTP Digest authentication (RFC2617)
  • NTLM (defined by Microsoft)
  • Http SPNEGO Negotiate (defined by Microsoft), with the following underlying mechanisms:
    • Kerberos
    • NTLM
Each of these schemes is described in more detail below, but they are typically used by application code in much the same way. The java.net.Authenticator class is used to enable authentication and to provide access to a store of usernames and passwords which are then used in the respective authentication schemes.

Generally, all authentication schemes work with both proxies and servers. Some (basic and digest) can be used simultaneously with proxies and servers. See below for how to distinguish between proxy and server authentication.

How to use the Authenticator class

Authenticator is an abstract class which is extended by applications and once installed, is invoked to obtain usernames and passwords for authentication interactions.

Extending java.net.Authenticator

Application code must override the getPasswordAuthentication() method. Note, the method is not abstract, and the default implementation does nothing. The following is a minimal example:
    class MyAuthenticator extends Authenticator {

        public PasswordAuthentication getPasswordAuthentication () {
            return new PasswordAuthentication ("user", "password".toCharArray());
        }
    }

This simple example returns the username "user" and a password for every HTTP authentication interaction. A more realistic example would use the other methods of java.net.Authenticator to get more information about the HTTP request that needs to be authenticated. Any of the following methods may be called by the implementation of getPasswordAuthentication() in order to decide how to handle each request for credentials.

  • getRequestingHost()
  • getRequestingPort()
  • getRequestingPrompt()
  • getRequestingProtocol()
  • getRequestingScheme()
  • getRequestingURL()
  • getRequestingSite()
  • getRequestorType(). Returns whether requestor is a proxy or server.

Enabling authentication

Having defined a suitable authenticator implementation class, authentication is enabled by calling
        Authenticator.setDefault (authinstance);

where authinstance is an instance of the declared implementation class. If this is not called, then authentication is disabled, and server authentication errors will be returned to user code via IOException objects. Once installed, the http implementation will try to authenticate automatically where possible (via cached credentials, or credentials that can be acquired from the system). If the correct credentials are not available then the user's authenticator is invoked to provide them.

Controlling which authentication scheme is used

When a server needs a client to authenticate, it may propose a number of schemes to the client (for example digest and ntlm) and the client may choose from among them. Normally, applications do not care which scheme is used to and the implementation automatically chooses the strongest (most secure) protocol transparently.

If the user needs to ensure that a particular scheme is used, then the following system property can be set to modify the default behavior.

        -Dhttp.auth.preference="scheme"

-D is specified if the property is being set on the command line. "http.auth.preference" is the property name, and scheme is the name of the scheme to use. If the server does not include this scheme in its list of proposed schemes, then the default choice is made.

Details of each authentication scheme

Http Basic

Basic authentication is a simple and not very secure authentication scheme which is defined in RFC 2317. The username and password are encoded in base 64 and are therefore easily obtainable by anyone who has access to the packet data. The security of basic authentication can be improved when used with HTTPS, thus encrypting the request and response.

The getRequestingPrompt() method returns the Basic authentication realm as provided by the server.

Http digest

Digest is a relatively secure scheme based on cryptographic hashes of the username and password, using the MD5 hash algorithm. Digest also provides the ability for the server to prove to the client that it also knows the shared secret (password). This behavior is normally disabled, because not all servers support it. This can be switched on with the following system properties:
        -Dhttp.auth.digest.validateServer="true"
        -Dhttp.auth.digest.validateProxy="true"

The getRequestingPrompt() method returns the Digest authentication realm as provided by the server.

NTLM

NTLM is a scheme defined by Microsoft. It is more secure scheme than Basic, but less secure than Digest. NTLM can be used with proxies or servers, but not with both at the same time. If a proxy is being used, then it cannot be used for server authentication. This is because the protocol actually authenticates the TCP connection rather than the individual HTTP interactions.

On Microsoft Windows platforms, NTLM authentication attempts to acquire the user credentials from the system without prompting the user's authenticator object. If these credentials are not accepted by the server then the user's authenticator will be called.

Because the Authenticator class was defined prior to NTLM being supported, it was not possible to add support in the API for the NTLM domain field. There are three options for specifying the domain:

  1. Do not specify it. In some environments, the domain is not actually required and the application need not specify it.
  2. The domain name can be encoded within the username by prefixing the domain name followed by a back-slash '\' before the username. With this method, existing applications that use the Authenticator class do not need to be modified, so long as users are made aware that this notation must be used.
  3. If a domain name is not specified as in method 2) and the system property "http.auth.ntlm.domain" is defined, then the value of this property will be used as the domain name.

Http Negotiate (SPNEGO)

Negotiate is a scheme which potentially allows any GSS authentication mechanism to be used as a HTTP authentication protocol. Currently, the scheme only supports Kerberos and NTLM. NTLM has already been described above, so this section only describes how to set up Kerberos for Http authentication.

Kerberos 5 Configuration

Since the SPNEGO mechanism will call JGSS, which in turns calls the Kerberos V5 login module to do real works. Kerberos 5 configurations are needed. which includes:
  • Some way to provide Kerberos configurations. This can be achieved with the Java system property java.security.krb5.conf. For example:
            java -Djava.security.krb5.conf=krb5.conf \
                 -Djavax.security.auth.useSubjectCredsOnly=false \
                 ClassName
  • A JAAS config file denoting what login module to use. HTTP SPNEGO codes will look for the standard entry named com.sun.security.jgss.krb5.initiate.
For example, you can provide a file spnegoLogin.conf:
          com.sun.security.jgss.krb5.initiate {
              com.sun.security.auth.module.Krb5LoginModule
                  required useTicketCache=true;
          };
and run java with:
            java -Djava.security.krb5.conf=krb5.conf \
                 -Djava.security.auth.login.config=spnegoLogin.conf \
                 -Djavax.security.auth.useSubjectCredsOnly=false \
                 ClassName

Username and Password Retrieval

Just like any other HTTP authentication scheme, the client can provide a customized java.net.Authenticator to feed username and password to the HTTP SPNEGO module if they are needed (i.e. there is no credential cache available). The only authentication information needed to be checked in your Authenticator is the scheme which can be retrieved with getRequestingScheme(). The value should be "Negotiate". This means your Authenticator implementation will look like:
    class MyAuthenticator extends Authenticator {

        public PasswordAuthentication getPasswordAuthentication () {
            if (getRequestingScheme().equalsIgnoreCase("negotiate")) {
                String krb5user;
                char[] krb5pass;
                // get krb5user and krb5pass in your own way
                ....
                return (new PasswordAuthentication (krb5user,
                            krb5pass));
            } else {
                ....
            }
        }
    }
Attention : According to the specification of java.net.Authenticator, it's designed to get the username and password at the same time, so do not specify principal=xxx in the JAAS config file.

Scheme Preference

The client can still provide system property http.auth.preference to denote that a certain scheme should always be used as long as the server request for it. You can use "SPNEGO" or "Kerberos" for this system property. "SPNEGO" means you prefer to response the Negotiate scheme using the GSS/SPNEGO mechanism; "Kerberos" means you prefer to response the Negotiate scheme using the GSS/Kerberos mechanism. Normally, when authenticating against a Microsoft product, you can use "SPNEGO". The value "Kerberos" also works for Microsoft servers. It's only needed when you encounter a server which knows Negotiate but doesn't know about SPNEGO. If http.auth.preference is not set, the internal order choosen is:
  • GSS/SPNEGO -> Digest -> NTLM -> Basic
Noticed that Kerberos does not appear in this list, since whenever Negotiate is supported, GSS/SPNEGO is always chosen.

Fallback

If the server has provided more than one authentication schemes (including Negotiate), according to the processing order mentioned in the last section, Java will try to challenge the Negotiate scheme. However, if the protocol cannot be established successfully (e.g. The kerberos configuration is not correct, or the server's hostname is not recorded in the KDC principal DB, or the username and password provided by Authenticator is wrong), then the 2nd strongest scheme will be automatically used. Attention : If http.auth.preference is set to SPNEGO or Kerberos, then we assume you only want to try the Negotiate scheme even if it fails. we won't fallback to any other scheme and your program will result in throwing an IOException saying it receives a 401 or 407 error from the HTTP response.

Example

Suppose you have an IIS Server running on a Windows Server within an Active Directory. A web page on this server is configured to be protected by Integrated Windows Authentication. This means the server will prompt for both Negotiate and NTLM authentication.

You need to prepare these files to get the protected file:

Code listing for RunHttpSpnego.java

import java.io.BufferedReader;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.net.Authenticator;
import java.net.PasswordAuthentication;
import java.net.URL;

public class RunHttpSpnego {

    static final String kuser = "username"; // your account name
    static final String kpass = password; // retrieve password for your account

    static class MyAuthenticator extends Authenticator {
        public PasswordAuthentication getPasswordAuthentication() {
            // I haven't checked getRequestingScheme() here, since for NTLM
            // and Negotiate, the usrname and password are all the same.
            System.err.println("Feeding username and password for " + getRequestingScheme());
            return (new PasswordAuthentication(kuser, kpass.toCharArray()));
        }
    }

    public static void main(String[] args) throws Exception {
        Authenticator.setDefault(new MyAuthenticator());
        URL url = new URL(args[0]);
        InputStream ins = url.openConnection().getInputStream();
        BufferedReader reader = new BufferedReader(new InputStreamReader(ins));
        String str;
        while((str = reader.readLine()) != null)
            System.out.println(str);
    }
}

Code listing for krb5.conf

[libdefaults]
    default_realm = AD.LOCAL
[realms]
    AD.LOCAL = {
        kdc = kdc.ad.local
    }

Code listing for login.conf

com.sun.security.jgss.krb5.initiate {
  com.sun.security.auth.module.Krb5LoginModule required doNotPrompt=false useTicketCache=true;
};

Then, compile RunHttpSpnego.java and run:

java -Djava.security.krb5.conf=krb5.conf \
    -Djava.security.auth.login.config=login.conf \
    -Djavax.security.auth.useSubjectCredsOnly=false \
    RunHttpSpnego \
    http://www.ad.local/hello/hello.html

You will see:

Feeding username and password for Negotiate
<h1>Hello, You got me!</h1>

In fact, if you are running on a Windows machine as a domain user, or, you are running on a Linux or Solaris machine that has already issued the kinit command and got the credential cache. The class MyAuthenticator will be completely ignored, and the output will be simply

<h1>Hello, You got me!</h1>
which shows the username and password are not consulted. This is the so-called Single Sign-On. Also, You can just run
java RunHttpSpnego \
    http://www.ad.local/hello/hello.html
to see how the fallback is done, in which case you will see
Feeding username and password for ntlm
<h1>Hello, You got me!</h1>
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


URLConnection caching API

HTTP is typically used for distributed information systems, where performance can be improved by the use of response caches. While HTTP proxy servers normally caches recently visited web resources, it is sometimes also desirable to have a local cache. Examples are browser caches.

In Tiger, a new framework provides a way for protocol handlers to access a response caching mechanism implemented by the platform or by a third party.

Here is the API:

We have introduced three abstract classes in the java.net package. They are:

  • ResponseCache
  • CacheRequest
  • CacheResponse

A concrete subclass of ResponseCache represents the URLConnection cache itself. An instance of such a class can be registered with the system by calling ResponseCache.setDefault(), and the system will call this object in order to:

  • store resource data which has been retrieved from an external source into the cache;
  • try to fetch a requested resource that may have been stored in the cache.

ResponseCache has two methods: get() returns a CacheResponse based on URI and request headers; and put() allows cache to decide if resource should be cached, returns a CacheRequest.

A concrete subclass of CacheRequest is used to write an entry in the ResponseCache. Instances of such a class provide an OutputStream object which is called by protocol handlers to store the resource data into the cache, and also an abort() method which allows a cache store operation to be interrupted and abandoned.

CacheRequest class has two methods: getBody() returns a stream for writing the request body into cache; and abort() abandons a cache write.

A concrete subclass of CacheResponse returns an entry from the ResponseCache. Instances of such a class provide an InputStream that returns the entity body, and also a getHeaders() method which returns the associated response headers.

CacheResponse class has two methods: getBody() returns a stream for reading the request body from cache; and getHeaders() returns the headers stored.

Caching logic flow

The following example shows a simple file based caching. However, it is equally viable to use other mechanisms such as a database for caching.

MyCacheResponse class is an implementation of CacheResponse. What it does is to take a file name and retrieve the HTTP response headers and body from it.

class MyCacheResponse extends CacheResponse {
FileInputStream fis;
Map<String, List<String>> headers;
public MyCacheResponse(String filename) {
        try {
         fis = new FileInputStream(new File(filename));
         ObjectInputStream ois = new ObjectInputStream (fis);
         headers = (Map<String, List<String>>)  ois.readObject();
   } catch (IOException ex) {
        // handle exception
   }
}

public InputStream getBody() throws IOException {
   return fis;
}

 public Map getHeaders() throws IOException {
   return headers;
 }
}

MyCacheRequest is an implementation of the CacheRequest. It takes a filename and the response headers and stores the headers in the file and also returns an outputstream directed to the same file so that any response body can be cached there.

class MyCacheRequest extends CacheRequest {
FileOutputStream fos;
public MyCacheRequest(String filename,
   Map<String, List<String>> rspHeaders) {
   try {
        File file = new File(filename);
        fos = new FileOutputStream(file);
        ObjectOutputStream oos = new ObjectOutputStream(fos);
        oos.writeObject(rspHeaders);
   } catch (Exception ex) {
        throw new RuntimeException(ex.getMessage());
   }
}
public OutputStream getBody() throws IOException {
   return fos;
}

public void abort() {
   // we abandon the cache by close the stream,
   // and delete the file
   fos.close();
   file.delete();
 }
}

Finally, we can tie it altogether with our implementation of the ResponseCache, it checks the URI for the network resource that is being retrieved or to be cached and returns the appropriate instantiations of our implementations of CacheResponse or CacheRequest. In this example, we only handles the case when the URI is equal to uri1 for retrieving from the cache, and for URI equals uri2 for storing to the cache. But it is easily expanded to handle a more complicated file based cache.

class MyResponseCache extends ResponseCache {
 public CacheResponse
 get(URI uri, String rqstMethod, Map rqstHeaders)
   throws IOException {
   // get the response from a cached file if available
   if (uri.equals(ParseUtil.toURI(uri1))) {
        return new MyCacheResponse(FNPrefix+"file1.cache");
   }
   return null;

public CacheRequest put(URI uri, URLConnection conn)
   throws IOException {
   // save cache to a file
   // 1. serialize headers into file2.cache
   // 2. write data to file2.cache
   if (uri.equals(ParseUtil.toURI(uri2))) {
       return new MyCacheRequest(OutFNPrefix+"file2.cache",
        conn.getHeaderFields());
   }
   return null;
 }
}

Once we have developed our own ResponseCache implementation, all left to be done is to register it and the JVM will use it.

public static void main(String args[]) throws Exception {
        ......
        ResponseCache.setDefault(new MyResponseCache());
        HttpURLConnection http = (HttpURLConnection)url1.openConnection();
        InputStream is = null;
        ......
}

There is no default implementation of URLConnection caching in the Java 2 Standard Edition. However, Java Plugin and Java WebStart do provide one out of the box.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Cookie Management

Introduction

The HTTP state management mechanism specifies a way to create a stateful session with HTTP requests and responses. The specification for it can be found in RFC 2965: HTTP State Management Mechanism at http://www.ietf.org/rfc/rfc2965.txt?number=2965.

Prior to JDK 5.0 support

Prior to JDK 5.0, it was possible to add Cookie management to applications. But the supporting API was somewhat rudimentary. There was no single point of hook up with cookie management. Each application had to handle cookies for each HTTP request/response separately by using the following two methods from java.net.URLConnection class:

setRequestProperty()
getHeaderFields()

The first method should be called before sending out a HTTP request in order to set the appropriate cookies for the current URL in the HTTP headers. The second method should be used to retrieve the cookies from the response headers sent by the HTTP server.

Although doable, adding Cookie support in this way results in fragmented code, which is error prone and incurs high maintenance.

What's new in JDK 5.0?

JDK 5.0 introduced a new callback mechanism via an abstract class to hook up a HTTP state management policy implementation into the HTTP protocol handler. Applications and web containers can introduce Cookie management by providing a concrete subclass of the new API.

The new abstract class is called java.net.CookieHandler. It provides a mechanism to register and retrieve the current CookieHandler for the JVM, as well as methods to retrieve and record relevant cookies for a specific URI.

There are two static methods in CookieHandler getDefault() and setDefault() for retrieving and registering the default CookieHandler in the VM. As well as two instance methods get() and put() for returning a list of cookies based on a URL and stores a list of cookies from the response headers, respectively.

Cookies are represented as Map<String,List<String>>, a Map from the header field name for cookies to a list of cookies represented by Strings. There are two state management headers defined so far, "Set-Cookie2" and "Cookie". The former is used for returning cookies in response headers; while the latter is for setting cookies in HTTP request headers.

Here is an example from RFC2965:

1. User Agent -> Server

POST /acme/login HTTP/1.1
[form data]

2. Server -> User Agent

HTTP/1.1 200 OK
Set-Cookie2: Customer="WILE_E_COYOTE"; Version="1"; Path="/acme"

3. User Agent -> Server

POST /acme/pickitem HTTP/1.1
Cookie: $Version="1"; Customer="WILE_E_COYOTE"; $Path="/acme"
[form data]

A simple Example

Here's a simple example of a CookieHandler implementation. Basically there are two methods to implement, given a request URI and request headers (except the cookie headers), retrieve all the relevant cookies from your cookie cache; and record the applicable cookies to your cookie cache given the request URI and the response headers.

class MyCookieHandler extends CookieHandler {
        public Map<String, List<String>>
                get(URI uri, Map<String, List<String>> requestHeaders)
                throws IOException {
                // the cookies will be included in request
                Map<String, List<String>> map = new HashMap<String, List<String>>();
                List<String> l = retrieveCookies(uri, rqstHdrs);
                map.put("Cookie",l);
                return Collections.unmodifiableMap(map);
        }

        public void
                put(URI uri, Map responseHeaders)
                throws IOException {
            // check response has cookies[1]
                List l = (List)responseHeaders.get("Set-Cookie2");
            if (l != null) {
                        // save the cookies in a cookie cache
                 storeCookies(uri, l);
            }
        }
}

The methods retrieveCookies() and storeCookies() are "magic" functions for interacting with a backend cookie management facility, which is omitted in this example.

Once it is registered with the VM, it will take effect when you issue HTTP transactions.

public static void main(String args[]) throws Exception {
        ......
        CookieHandler.setDefault(new MyCookieHandler());
        HttpURLConnection http = (HttpURLConnection)url.openConnection();

        int respCode = http.getResponseCode();
        http.disconnect();
        ......
}

There is no default implementation of a cookie manager in Java SE. However, this may change in the future. Java Plugin and Java WebStart provides a default CookieHandler in their environment.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


HTTP Persistent Connections

Documentation Contents

Persistent Connections

What is HTTP Persistent Connections?

HTTP persistent connections, also called HTTP keep-alive, or HTTP connection reuse, is the idea of using the same TCP connection to send and receive multiple HTTP requests/responses, as opposed to opening a new one for every single request/response pair. Using persistent connections is very important for improving HTTP performance.

There are several advantages of using persistent connections, including:

  • Network friendly. Less network traffic due to fewer setting up and tearing down of TCP connections.
  • Reduced latency on subsequent request. Due to avoidance of initial TCP handshake
  • Long lasting connections allowing TCP sufficient time to determine the congestion state of the network, thus to react appropriately.

The advantages are even more obvious with HTTPS or HTTP over SSL/TLS. There, persistent connections may reduce the number of costly SSL/TLS handshake to establish security associations, in addition to the initial TCP connection set up.

In HTTP/1.1, persistent connections are the default behavior of any connection. That is, unless otherwise indicated, the client SHOULD assume that the server will maintain a persistent connection, even after error responses from the server. However, the protocol provides means for a client and a server to signal the closing of a TCP connection.

What makes a connection reusable?

Since TCP by its nature is a stream based protocol, in order to reuse an existing connection, the HTTP protocol has to have a way to indicate the end of the previous response and the beginning of the next one. Thus, it is required that all messages on the connection MUST have a self-defined message length (i.e., one not defined by closure of the connection). Self demarcation is achieved by either setting the Content-Length header, or in the case of chunked transfer encoded entity body, each chunk starts with a size, and the response body ends with a special last chunk.

What happens if there are proxy servers in between?

Since persistent connections applies to only one transport link, it is important that proxy servers correctly signal persistent/or-non-persistent connections separately with its clients and the origin servers (or to other proxy servers). From a HTTP client or server's perspective, as far as persistence connection is concerned, the presence or absence of proxy servers is transparent.

What does the current JDK do for Keep-Alive?

The JDK supports both HTTP/1.1 and HTTP/1.0 persistent connections.

When the application finishes reading the response body or when the application calls close() on the InputStream returned by URLConnection.getInputStream(), the JDK's HTTP protocol handler will try to clean up the connection and if successful, put the connection into a connection cache for reuse by future HTTP requests.

The support for HTTP keep-Alive is done transparently. However, it can be controlled by system properties http.keepAlive, and http.maxConnections, as well as by HTTP/1.1 specified request and response headers.

The system properties that control the behavior of Keep-Alive are:

http.keepAlive=<boolean>
default: true

Indicates if keep alive (persistent) connections should be supported.

http.maxConnections=<int>
default: 5

Indicates the maximum number of connections per destination to be kept alive at any given time

HTTP header that influences connection persistence is:

Connection: close

If the "Connection" header is specified with the value "close" in either the request or the response header fields, it indicates that the connection should not be considered 'persistent' after the current request/response is complete.

The current implementation doesn't buffer the response body. Which means that the application has to finish reading the response body or call close() to abandon the rest of the response body, in order for that connection to be reused. Furthermore, current implementation will not try block-reading when cleaning up the connection, meaning if the whole response body is not available, the connection will not be reused.

What's new in JDK 5?

When the application encounters a HTTP 400 or 500 response, it may ignore the IOException and then may issue another HTTP request. In this case, the underlying TCP connection won't be Kept-Alive because the response body is still there to be consumed, so the socket connection is not cleared, therefore not available for reuse. What the application needs to do is call HttpURLConnection.getErrorStream() after catching the IOException , read the response body, then close the stream. However, some existing applications are not doing this. As a result, they do not benefit from persistent connections. To address this problem, we have introduced a workaround.

The workaround involves buffering the response body if the response is >=400, up to a certain amount and within a time limit, thus freeing up the underlying socket connection for reuse. The rationale behind this is that when the server responds with a >=400 error (client error or server error. One example is "404: File Not Found" error), the server usually sends a small response body to explain whom to contact and what to do to recover.

Several new Oracle JDK implementation specific properties are introduced to help clean up the connections after error response from the server.

The major one is:

sun.net.http.errorstream.enableBuffering=<boolean>
default: false

With the above system property set to true (default is false), when the response code is >=400, the HTTP handler will try to buffer the response body. Thus freeing up the underlying socket connection for reuse. Thus, even if the application doesn't call getErrorStream(), read the response body, and then call close(), the underlying socket connection may still be kept-alive and reused.

The following two system properties provide further control to the error stream buffering behavior:

sun.net.http.errorstream.timeout=<int> in millisecond
default: 300 millisecond

sun.net.http.errorstream.bufferSize=<int> in bytes
default: 4096 bytes

What can you do to help with Keep-Alive?

Do not abandon a connection by ignoring the response body. Doing so may results in idle TCP connections. That needs to be garbage collected when they are no longer referenced.

If getInputStream() successfully returns, read the entire response body.

When calling getInputStream() from HttpURLConnection, if an IOException occurs, catch the exception and call getErrorStream() to get the response body (if there is any).

Reading the response body cleans up the connection even if you are not interested in the response content itself. But if the response body is long and you are not interested in the rest of it after seeing the beginning, you can close the InputStream. But you need to be aware that more data could be on its way. Thus the connection may not be cleared for reuse.

Here's a code example that complies to the above recommendation:

try {
        URL a = new URL(args[0]);
        URLConnection urlc = a.openConnection();
        is = conn.getInputStream();
        int ret = 0;
        while ((ret = is.read(buf)) > 0) {
          processBuf(buf);
        }
        // close the inputstream
        is.close();
} catch (IOException e) {
        try {
                respCode = ((HttpURLConnection)conn).getResponseCode();
                es = ((HttpURLConnection)conn).getErrorStream();
                int ret = 0;
                // read the response body
                while ((ret = es.read(buf)) > 0) {
                        processBuf(buf);
                }
                // close the errorstream
                es.close();
        } catch(IOException ex) {
                // deal with the exception
        }
}

If you know ahead of time that you won't be interested in the response body, you should issue a HEAD request instead of a GET request. For example when you are only interested in the meta info of the web resource or when testing for its validity, accessibility and recent modification. Here's a code snippet:

URL a = new URL(args[0]);
URLConnection urlc = a.openConnection();
HttpURLConnection httpc = (HttpURLConnection)urlc;
// only interested in the length of the resource
httpc.setRequestMethod("HEAD");
int len = httpc.getContentLength();

Changes in JDK 6

Prior to JDK 6, if an application closes a HTTP InputStream when more than a small amount of data remains to be read, then the connection had to be closed, rather than being cached. Now in JDK 6, the behavior is to read up to 512 Kbytes off the connection in a background thread, thus allowing the connection to be reused. The exact amount of data which may be read is configurable through the http.KeepAlive.remainingData system property.
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Class com.sun.net.httpserver.HttpContext (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpContext

  • Packages that use HttpContext
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of HttpContext in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpContext
      Modifier and Type Method and Description
      abstract HttpContext HttpServer.createContext(String path)
      Creates a HttpContext without initially specifying a handler.
      abstract HttpContext HttpServer.createContext(String path, HttpHandler handler)
      Creates a HttpContext.
      abstract HttpContext HttpExchange.getHttpContext()
      Get the HttpContext for this exchange
      Methods in com.sun.net.httpserver with parameters of type HttpContext
      Modifier and Type Method and Description
      abstract void HttpServer.removeContext(HttpContext context)
      Removes the given context from the server.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpExchange (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpExchange

  • Packages that use HttpExchange
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of HttpExchange in com.sun.net.httpserver

      Subclasses of HttpExchange in com.sun.net.httpserver
      Modifier and Type Class and Description
      class  HttpsExchange
      This class encapsulates a HTTPS request received and a response to be generated in one exchange and defines the extensions to HttpExchange that are specific to the HTTPS protocol.
      Methods in com.sun.net.httpserver with parameters of type HttpExchange
      Modifier and Type | Method and Description
      abstract Authenticator.Result Authenticator.authenticate(HttpExchange exch)
      called to authenticate each incoming request.
      Authenticator.Result | BasicAuthenticator.authenticate(HttpExchange t)
      void Filter.Chain.doFilter(HttpExchange exchange)
      calls the next filter in the chain, or else the users exchange handler, if this is the final filter in the chain.
      abstract void Filter.doFilter(HttpExchange exchange, Filter.Chain chain)
      Asks this filter to pre/post-process the given exchange.
      void HttpHandler.handle(HttpExchange exchange)
      Handle the given request and generate an appropriate response.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Interface com.sun.net.httpserver.HttpHandler (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.net.httpserver.HttpHandler

  • Packages that use HttpHandler
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of HttpHandler in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpHandler
      Modifier and Type Method and Description
      abstract HttpHandler HttpContext.getHandler()
      returns the handler for this context
      Methods in com.sun.net.httpserver with parameters of type HttpHandler
      Modifier and Type Method and Description
      abstract HttpContext HttpServer.createContext(String path, HttpHandler handler)
      Creates a HttpContext.
      abstract void HttpContext.setHandler(HttpHandler h)
      Sets the handler for this context, if not already set.
      Constructors in com.sun.net.httpserver with parameters of type HttpHandler
      Constructor and Description
      Chain(List<Filter> filters, HttpHandler handler)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpPrincipal (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpPrincipal

  • Packages that use HttpPrincipal
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of HttpPrincipal in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpPrincipal
      Modifier and Type Method and Description
      abstract HttpPrincipal HttpExchange.getPrincipal()
      If an authenticator is set on the HttpContext that owns this exchange, then this method will return the HttpPrincipal that represents the authenticated user for this HttpExchange.
      HttpPrincipal Authenticator.Success.getPrincipal()
      returns the authenticated user Principal
      Constructors in com.sun.net.httpserver with parameters of type HttpPrincipal
      Constructor and Description
      Success(HttpPrincipal p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpsConfigurator (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpsConfigurator

  • Packages that use HttpsConfigurator
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of HttpsConfigurator in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpsConfigurator
      Modifier and Type Method and Description
      abstract HttpsConfigurator HttpsServer.getHttpsConfigurator()
      Gets this server's HttpsConfigurator object, if it has been set.
      abstract HttpsConfigurator HttpsParameters.getHttpsConfigurator()
      Returns the HttpsConfigurator for this HttpsParameters.
      Methods in com.sun.net.httpserver with parameters of type HttpsConfigurator
      Modifier and Type Method and Description
      abstract void HttpsServer.setHttpsConfigurator(HttpsConfigurator config)
      Sets this server's HttpsConfigurator object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpServer (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpServer

  • Packages that use HttpServer
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.
    com.sun.net.httpserver.spi
    Provides a pluggable service provider interface, which allows the HTTP server implementation to be replaced with other implementations.

    • Uses of HttpServer in com.sun.net.httpserver

      Subclasses of HttpServer in com.sun.net.httpserver
      Modifier and Type Class and Description
      class  HttpsServer
      This class is an extension of HttpServer which provides support for HTTPS.
      Methods in com.sun.net.httpserver that return HttpServer
      Modifier and Type Method and Description
      static HttpServer HttpServer.create()
      creates a HttpServer instance which is initially not bound to any local address/port.
      static HttpServer HttpServer.create(InetSocketAddress addr, int backlog)
      Create a HttpServer instance which will bind to the specified InetSocketAddress (IP address and port number) A maximum backlog can also be specified.
      abstract HttpServer HttpContext.getServer()
      returns the server this context was created with

    • Uses of HttpServer in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that return HttpServer
      Modifier and Type Method and Description
      abstract HttpServer HttpServerProvider.createHttpServer(InetSocketAddress addr, int backlog)
      creates a HttpServer from this provider
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.spi.HttpServerProvider (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.spi.HttpServerProvider

  • Packages that use HttpServerProvider
    Package Description
    com.sun.net.httpserver.spi
    Provides a pluggable service provider interface, which allows the HTTP server implementation to be replaced with other implementations.

    • Uses of HttpServerProvider in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that return HttpServerProvider
      Modifier and Type Method and Description
      static HttpServerProvider HttpServerProvider.provider()
      Returns the system wide default HttpServerProvider for this invocation of the Java virtual machine.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpsExchange (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpsExchange

No usage of com.sun.net.httpserver.HttpsExchange
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpsParameters (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpsParameters

  • Packages that use HttpsParameters
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.

    • Uses of HttpsParameters in com.sun.net.httpserver

      Methods in com.sun.net.httpserver with parameters of type HttpsParameters
      Modifier and Type Method and Description
      void HttpsConfigurator.configure(HttpsParameters params)
      Called by the HttpsServer to configure the parameters for a https connection currently being established.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.net.httpserver.HttpsServer (Java HTTP Server )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.net.httpserver.HttpsServer

  • Packages that use HttpsServer
    Package Description
    com.sun.net.httpserver
    Provides a simple high-level Http server API, which can be used to build embedded HTTP servers.
    com.sun.net.httpserver.spi
    Provides a pluggable service provider interface, which allows the HTTP server implementation to be replaced with other implementations.

    • Uses of HttpsServer in com.sun.net.httpserver

      Methods in com.sun.net.httpserver that return HttpsServer
      Modifier and Type Method and Description
      static HttpsServer HttpsServer.create()
      creates a HttpsServer instance which is initially not bound to any local address/port.
      static HttpsServer HttpsServer.create(InetSocketAddress addr, int backlog)
      Create a HttpsServer instance which will bind to the specified InetSocketAddress (IP address and port number) A maximum backlog can also be specified.

    • Uses of HttpsServer in com.sun.net.httpserver.spi

      Methods in com.sun.net.httpserver.spi that return HttpsServer
      Modifier and Type Method and Description
      abstract HttpsServer HttpServerProvider.createHttpsServer(InetSocketAddress addr, int backlog)
      creates a HttpsServer from this provider
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
Java HTTP Server
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Internationalization

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

14 Internationalization

This chapter provides information and guidance on troubleshooting issues that might be found in the area of internationalization support.

For detailed information, visit the Java Internationalization site.

This chapter describes troubleshooting techniques for Internationalization and Localization.

  • Troubleshoot Internationalization and Localization

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Troubleshoot Internationalization and Localization

Documentation Contents
Java Platform, Standard Edition Troubleshooting Guide
Contents Previous Next

14.1 Troubleshoot Internationalization and Localization

Before troubleshooting, make sure that you understand the difference between internationalization and localization:

  • Internationalization is the process of designing software so that it can be adapted (localized) to various languages and regions easily, in a cost-effective way, and without changes to the software. This process generally involves isolating the parts of a program that are dependent on language and culture. For example, the text of error messages are kept separate from program source code because the messages must be translated during localization. For more details refer to Java Internationalization Support.

  • Localization is the process of adapting a program for use in a specific locale. A locale is a geographic or political region that shares the same language and customs. Localization includes the translation of text such as user interface labels, error messages, and online help. It also includes the culture-specific formatting of data items such as monetary values, times, dates, and numbers.

The user interface libraries in the Java SE platform enable the development of rich interactive applications. The internationalization aspects include text input, text display, and user interface layout. The following descriptions show the relationship between internationalization and the functionality provided by the AWT, Java 2D, and Swing APIs:

  • Text input is the process of entering new text into a document, whether by typing on a keyboard or through front-end software such as input methods, handwriting recognition, or speech input.

  • Text display is a multistep process that includes selecting a font, arranging text into paragraphs and lines, selecting glyphs for characters or character sequences, and rendering these glyphs. Some writing systems require bidirectional text layout or complex character-to-glyph mappings. Text display is handled by the Java 2D graphics system and the Swing toolkit for lightweight user interface components and by AWT for peered user interface components.

  • User interface layout needs to accommodate text expansion or shrinkage caused by localization, and match the direction of the user's writing system.

For details, see Internationalization Tools and Internationalization Enhancements in JDK 8.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.IdentifierTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.IdentifierTree

  • Packages that use IdentifierTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of IdentifierTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type IdentifierTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitIdentifier(IdentifierTree node, P p)

    • Uses of IdentifierTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type IdentifierTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitIdentifier(IdentifierTree node, P p)
      R | TreeScanner.visitIdentifier(IdentifierTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


idlj

Generates Java bindings for a specified Interface Definition Language (IDL) file.

Synopsis

idlj [ options ] idlfile

options

The command-line options. See Options. Options can appear in any order, but must precede the idlfile.

idlfile

The name of a file that contains Interface Definition Language (IDL) definitions.

Description

The IDL-to-Java Compiler generates the Java bindings for a specified IDL file. For binding details, see Java IDL: IDL to Java Language Mapping at
http://docs.oracle.com/javase/8/docs/technotes/guides/idl/mapping/jidlMapping.html

Some earlier releases of the IDL-to-Java compiler were named idltojava.

Emit Client and Server Bindings

The following idlj command generates an IDL file named My.idl with client-side bindings.

idlj My.idl

The previous syntax is equivalent to the following:

idlj -fclient My.idl

The next example generates the server-side bindings, and includes the client-side bindings plus the skeleton, all of which are POA (Inheritance Model).

idlg -fserver My.idl

If you want to generate both client and server-side bindings, then use one of the following (equivalent) commands:

idlj -fclient -fserver My.idl
idlj -fall My.idl

There are two possible server-side models: the Portal Servant Inheritance Model and the Tie Model. See Tie Delegation Model.

Portable Servant Inheritance Model

The default server-side model is the Portable Servant Inheritance Model. Given an interface My defined in My.idl, the file MyPOA.java is generated. You must provide the implementation for the My interface, and the My interface must inherit from the MyPOA class. MyPOA.java is a stream-based skeleton that extends the org.omg.PortableServer.Servant class at
http://docs.oracle.com/javase/8/docs/api/org/omg/PortableServer/Servant.html

The My interface implements the callHandler interface and the operations interface associated with the IDL interface the skeleton implements.

The PortableServer module for the Portable Object Adapter (POA) defines the native Servant type. See Portable Object Adapter (POA) at
http://docs.oracle.com/javase/8/docs/technotes/guides/idl/POA.html

In the Java programming language, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that can be called by the application programmer, and methods that are called by the POA and that can be overridden by the user to control aspects of servant behavior.

Another option for the Inheritance Model is to use the -oldImplBase flag to generate server-side bindings that are compatible with releases of the Java programming language before Java SE 1.4. The -oldImplBase flag is nonstandard, and these APIs are deprecated. You would use this flag only for compatibility with existing servers written in Java SE 1.3. In that case, you would need to modify an existing make file to add the -oldImplBase flag to the idlj compiler. Otherwise POA-based server-side mappings are generated. To generate server-side bindings that are backward compatible, do the following:

idlj -fclient -fserver -oldImplBase My.idl
idlj -fall -oldImplBase My.idl

Given an interface My defined in My.idl, the file _MyImplBase.java is generated. You must provide the implementation for the My interface, and the My interface must inherit from the _MyImplBase class.

Tie Delegation Model

The other server-side model is called the Tie Model. This is a delegation model. Because it is not possible to generate ties and skeletons at the same time, they must be generated separately. The following commands generate the bindings for the Tie Model:

idlj -fall My.idl
idlj -fallTIE My.idl

For the My interface, the second command generates MyPOATie.java. The constructor to the MyPOATie class takes a delegate. In this example, using the default POA model, the constructor also needs a POA. You must provide the implementation for the delegate, but it does not have to inherit from any other class, only the interface MyOperations. To use it with the ORB, you must wrap your implementation within the MyPOATie class, for example:

ORB orb = ORB.init(args, System.getProperties());

// Get reference to rootpoa & activate the POAManager
POA rootpoa = (POA)orb.resolve_initial_references("RootPOA");
rootpoa.the_POAManager().activate();

// create servant and register it with the ORB
MyServant myDelegate = new MyServant();
myDelegate.setORB(orb);

// create a tie, with servant being the delegate.
MyPOATie tie = new MyPOATie(myDelegate, rootpoa);

// obtain the objectRef for the tie
My ref = tie._this(orb);

You might want to use the Tie model instead of the typical Inheritance model when your implementation must inherit from some other implementation. Java allows any number of interface inheritance, but there is only one slot for class inheritance. If you use the inheritance model, then that slot is used up. With the Tie Model, that slot is freed up for your own use. The drawback is that it introduces a level of indirection: one extra method call occurs when a method is called.

For server-side generation, Tie model bindings that are compatible with versions of the IDL to Java language mapping in versions earlier than Java SE 1.4.

idlj -oldImplBase -fall My.idl
idlj -oldImplBase -fallTIE My.idl

For the My interface, the this generates My_Tie.java. The constructor to the My_Tie class takes an impl object. You must provide the implementation for impl, but it does not have to inherit from any other class, only the interface HelloOperations. But to use it with the ORB, you must wrap your implementation within My_Tie, for example:

ORB orb = ORB.init(args, System.getProperties());

// create servant and register it with the ORB
MyServant myDelegate = new MyServant();
myDelegate.setORB(orb);

// create a tie, with servant being the delegate.
MyPOATie tie = new MyPOATie(myDelegate);

// obtain the objectRef for the tie
My ref = tie._this(orb);

Specify Alternate Locations for Emitted Files

If you want to direct the emitted files to a directory other than the current directory, then call the compiler this way: idlj -td /altdir My.idl.

For the My interface, the bindings are emitted to /altdir/My.java, etc., instead of ./My.java.

Specify Alternate Locations for Include Files

If the My.idl file includes another idl file, MyOther.idl, then the compiler assumes that the MyOther.idl file resides in the local directory. If it resides in /includes, for example, then you call the compiler with the following command:

idlj -i /includes My.idl

If My.idl also included Another.idl that resided in /moreIncludes, for example, then you call the compiler with the following command:

idlj -i /includes -i /moreIncludes My.idl

Because this form of include can become long, another way to indicate to the compiler where to search for included files is provided. This technique is similar to the idea of an environment variable. Create a file named idl.config in a directory that is listed in your CLASSPATH variable. Inside of idl.config, provide a line with the following form:

includes=/includes;/moreIncludes

The compiler will find this file and read in the includes list. Note that in this example the separator character between the two directories is a semicolon (;). This separator character is platform dependent. On the Windows platform, use a semicolon; on the Solaris, Linux, and OS X platforms, use a colon.

Emit Bindings for Include Files

By default, only those interfaces, structures, and so on, that are defined in the idl file on the command line have Java bindings generated for them. The types defined in included files are not generated. For example, assume the following two idl files:

My.idl file:

#include <MyOther.idl>
interface My
{
};

MyOther.idl file:

interface MyOther
{
};

There is a caveat to the default rule. Any #include statements that appear at the global scope are treated as described. These #include statements can be thought of as import statements. The #include statements that appear within an enclosed scope are treated as true #include statements, which means that the code within the included file is treated as though it appeared in the original file and, therefore, Java bindings are emitted for it. Here is an example:

My.idl file:

#include <MyOther.idl>
interface My
{
  #include <Embedded.idl>
};

MyOther.idl file:

interface MyOther
{
};

Embedded.idl

enum E {one, two, three};

Run idlj My.idl to generate the following list of Java files. Notice that MyOther.java is not generated because it is defined in an import-like #include. But E.java was generated because it was defined in a true #include. Notice that because the Embedded.idl file is included within the scope of the interface My, it appears within the scope of My (in MyPackage). If the -emitAll flag had been used, then all types in all included files would have been emitted.

./MyHolder.java
./MyHelper.java
./_MyStub.java
./MyPackage
./MyPackage/EHolder.java
./MyPackage/EHelper.java
./MyPackage/E.java
./My.java

Insert Package Prefixes

Suppose that you work for a company named ABC that has constructed the following IDL file:

Widgets.idl file:

module Widgets
{
  interface W1 {...};
  interface W2 {...};
};

If you run this file through the IDL-to-Java compiler, then the Java bindings for W1 and W2 are placed within the Widgets package. There is an industry convention that states that a company's packages should reside within a package named com.<company name>. To follow this convention, the package name should be com.abc.Widgets. To place this package prefix onto the Widgets module, execute the following:

idlj -pkgPrefix Widgets com.abc Widgets.idl

If you have an IDL file that includes Widgets.idl, then the -pkgPrefix flag must appear in that command also. If it does not, then your IDL file will be looking for a Widgets package rather than a com.abc.Widgets package.

If you have a number of these packages that require prefixes, then it might be easier to place them into the idl.config file described previously. Each package prefix line should be of the form: PkgPrefix.<type>=<prefix>. The line for the previous example would be PkgPrefix.Widgets=com.abc. This option does not affect the Repository ID.

Define Symbols Before Compilation

You might need to define a symbol for compilation that is not defined within the IDL file, perhaps to include debugging code in the bindings. The command idlj -d MYDEF My.idl is equivalent to putting the line #define MYDEF inside My.idl.

Preserve Preexisting Bindings

If the Java binding files already exist, then the -keep flag keeps the compiler from overwriting them. The default is to generate all files without considering that they already exist. If you have customized those files (which you should not do unless you are very comfortable with their contents), then the -keep option is very useful. The command idlj -keep My.idl emits all client-side bindings that do not already exist.

View Compilation Progress

The IDL-to-Java compiler generates status messages as it progresses through its phases of execution. Use the -v option to activate the verbose mode: idlj -v My.idl.

By default the compiler does not operate in verbose mode

Display Version Information

To display the build version of the IDL-to-Java compiler, specify the -version option on the command-line: idlj -version.

Version information also appears within the bindings generated by the compiler. Any additional options appearing on the command-line are ignored.

Options

-d symbol

This is equivalent to the following line in an IDL file:

#define symbol
-demitAll

Emit all types, including those found in #include files.

-fside

Defines what bindings to emit. The side parameter can be client, server, serverTIE, all, or allTIE. The -fserverTIE and -fallTIE options cause delegate model skeletons to be emitted. Defaults to -fclient when the flag is not specified.

-i include-path

By default, the current directory is scanned for included files. This option adds another directory.

-i keep

If a file to be generated already exists, then do not overwrite it. By default it is overwritten.

-noWarn

Suppress warning messages.

-oldImplBase

Generates skeletons compatible with pre-1.4 JDK ORBs. By default, the POA Inheritance Model server-side bindings are generated. This option provides backward-compatibility with earlier releases of the Java programming language by generating server-side bindings that are ImplBase Inheritance Model classes.

-pkgPrefix type prefix

Wherever type is encountered at file scope, prefix the generated Java package name with prefix for all files generated for that type. The type is the simple name of either a top-level module, or an IDL type defined outside of any module.

-pkgTranslate type package

Whenever the module name type is encountered in an identifier, replace it in the identifier with package for all files in the generated Java package. Note that pkgPrefix changes are made first. The type value is the simple name of either a top-level module, or an IDL type defined outside of any module and must match the full package name exactly.

If more than one translation matches an identifier, then the longest match is chosen as shown in the following example:

Command:

pkgTranslate type pkg -pkgTranslate type2.baz pkg2.fizz

Resulting Translation:

type => pkg
type.ext => pkg.ext
type.baz => pkg2.fizz
type2.baz.pkg => pkg2.fizz.pkg

The following package names org, org.omg, or any subpackages of org.omg cannot be translated. Any attempt to translate these packages results in uncompilable code, and the use of these packages as the first argument after -pkgTranslate is treated as an error.

-skeletonName xxx%yyy

Use xxx%yyy as the pattern for naming the skeleton. The defaults are: %POA for the POA base class (-fserver or -fall), and _%ImplBase for the oldImplBase class (-oldImplBase) and (-fserver or -fall)).

-td dir

Use dir for the output directory instead of the current directory.

-tieName xxx%yyy

Use xxx%yyy according to the pattern. The defaults are: %POA for the POA base class (-fserverTie or -fallTie), and _%Tie for the oldImplBase tie class (-oldImplBase) and (-fserverTie or -fallTie))

-nowarn, -verbose

Displays release information and terminates.

-version

Displays release information and terminates.

Restrictions

Escaped identifiers in the global scope cannot have the same spelling as IDL primitive types, Object, or ValueBase. This is because the symbol table is preloaded with these identifiers. Allowing them to be redefined would overwrite their original definitions. Possible permanent restriction.

The fixed IDL type is not supported.

Known Problems

No import is generated for global identifiers. If you call an unexported local impl object, then you do get an exception, but it seems to be due to a NullPointerException in the ServerDelegate DSI code.

Contents Previous Next
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.IfTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.IfTree

  • Packages that use IfTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of IfTree in com.sun.source.tree

      Methods in com.sun.source.tree with parameters of type IfTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitIf(IfTree node, P p)

    • Uses of IfTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type IfTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitIf(IfTree node, P p)
      R | TreeScanner.visitIf(IfTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.connect.IllegalConnectorArgumentsException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.connect.IllegalConnectorArgumentsException

  • Packages that use IllegalConnectorArgumentsException
    Package Description
    com.sun.jdi.connect
    This package defines connections between the virtual machine using the JDI and the target virtual machine.

    • Uses of IllegalConnectorArgumentsException in com.sun.jdi.connect

      Methods in com.sun.jdi.connect that throw IllegalConnectorArgumentsException
      Modifier and Type Method and Description
      VirtualMachine ListeningConnector.accept(Map<String,? extends Connector.Argument> arguments)
      Waits for a target VM to attach to this connector.
      VirtualMachine AttachingConnector.attach(Map<String,? extends Connector.Argument> arguments)
      Attaches to a running application and and returns a mirror of its VM.
      VirtualMachine LaunchingConnector.launch(Map<String,? extends Connector.Argument> arguments)
      Launches an application and connects to its VM.
      String ListeningConnector.startListening(Map<String,? extends Connector.Argument> arguments)
      Listens for one or more connections initiated by target VMs.
      void ListeningConnector.stopListening(Map<String,? extends Connector.Argument> arguments)
      Cancels listening for connections.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.IllegalReceiveException (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.IllegalReceiveException

No usage of com.sun.nio.sctp.IllegalReceiveException
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.nio.sctp.IllegalUnbindException (SCTP API )

Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.nio.sctp.IllegalUnbindException

No usage of com.sun.nio.sctp.IllegalUnbindException
Skip navigation links
  • Package
  • Class
  • Use
  • Tree
  • Index
  • Help
SCTP API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2009, 2015, Oracle and/or its affiliates. All rights reserved.


Java Image I/O API Guide

Documentation Contents
PREV | NEXT

1. Introduction
1.1 The Java Image I/O API
1.2 About This Document
1.3 Platforms
1.4 Target Audience
1.5 Acknowledgements
2. Goals
2.1 API Goals
2.1.1 Client-Side Application Goals
2.1.2 Server Use Cases
2.2 Non-Goals
3. Writing Image I/O Applications
3.1 Reading and Writing Images
3.2 Going Further
3.3 ImageReader
3.3.1 ImageReadParam
3.3.2 IIOParamController
3.3.3 Reading From Multi-Image Files
3.3.4 Reading "Thumbnail" Images
3.4 The ImageWriter Class
3.4.1 Writing Multiple Images
3.5 Handling Metadata
3.5.1 The IIOMetadataFormat Interface
3.6 Transcoding
3.7 Listening for Events
3.7.1 The IIOReadProgressListener Interface
3.7.2 The IIOReadUpdateListener Interface
3.7.3 The IIOReadWarningListener Interface
3.7.4 The IIOWriteProgressListener and IIOWriteWarningListener Interfaces
3.8 Handling Errors using IIOException
4. Writing Image I/O Plug-ins
4.1 The Plug-in Concept
4.2 Embedding Plug-ins in JAR Files
4.3 Writing Reader Plug-Ins
4.4 Writing Writer Plug-ins
4.5 Writing Transcoder Plug-ins
4.6 Writing Stream Plug-ins

CONTENTS | PREV | NEXT
Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Input Method Framework Demo

Download and install the Java Runtime Environment (JRE) to view the applet.

This applet contains four text components that show the different ways of interacting with input methods in the Java SE platform. This applet can be run in two ways:
  • On a platform/locale that uses native input methods. Examples: Japanese Windows NT, Macintosh with Chinese Language Kit, Solaris with Korean locale.
  • With an input method installed that's implemented in the Java programming language. The Java runtime environment may be running on a platform/locale that does not support native input methods.

The first three components are lightweight components, i.e., they handle events and render text using Java APIs. The last one is a peered component, that is, event handling and text rendering are handled by a text editing engine provided by the underlying platform. Peered components were used widely in JDK 1.0 AWT, while lightweight components were introduced in JDK 1.1 and are the basis of the Swing class library.

The lightweight components have different capabilities:

  • The active client uses the input method framework API to implement on-the-spot (also called "inline") text composition.
  • The passive client works with input methods in the simplest way - it relies on the input method framework to handle all composition and only accepts committed text.
  • The non-client refuses to work with input methods.

To test with the different components with native Japanese input methods, click into the components to focus on them, turn on an input method (Alt-` on Windows, choosing from the keyboard menu on Macintosh, Control-Space on Solaris), then type "nihongo". The behavior you should see is:

  • Active client: The word is entered in the component directly and gets converted to four hiragana characters as you type.
  • Passive client: A separate window shows up, the word is entered in that window and gets converted to four hiragana characters as you type.
  • Non-client: The text "nihongo" is entered into the component.
  • Peered component: The behavior depends on the platform, but most likely it's similar to the active client (the text may be drawn over the pre-existing text or push it to the right).

For all components except the non-client, you can now convert the text (Space on Windows and Macintosh, Control-N or Space on Solaris) and then commit it (Enter on all three platforms - how could that happen?). Conversion should result in three kanji characters, which after committing are shown in the component without highlight.

To test with the different components with the sample input method implemented in the Java programming language, "City Input Method", install the input method's JAR file into the extensions directory of the Java runtime environment before running the applet. Then click into the components to focus on them, and select the input method. The selection mechanism is implementation dependent; on Oracle's Java runtime environments, choose the "Select Input Method" menu item from the system menu in the top left corner of the window, then choose the input method from the pop-up menu that comes up. Then type "TYO". The behavior you should see:

  • Active client: The text is entered in the component directly and is highlighted.
  • Passive client: A separate window shows up, the text is entered in that window and is highlighted.
  • Non-client: The text is entered into the component, but not highlighted.
  • Peered component: The behavior depends on the platform.

For all components except the non-client and, on some platforms, the peered component, you can now convert the text using the Space key. The conversion result depends on your default language - it's the name "Tokyo" in Japanese, Japanese yomi, English, German, simplified or traditional Chinese. To see all options, press Space again - this time, you'll get a look-up window showing all the possibilities. You can use Space to go through all possible selections, or type the number of the conversion you like. Pressing the Enter key will commit the selected conversion and remove the highlight.

Oracle and/or its affiliates Copyright © 1993, 2015, Oracle and/or its affiliates. All rights reserved.
Contact Us


Uses of Interface com.sun.source.tree.ImportTree (Compiler Tree API )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
com.sun.source.tree.ImportTree

  • Packages that use ImportTree
    Package Description
    com.sun.source.tree
    Provides interfaces to represent source code as abstract syntax trees (AST).
    com.sun.source.util
    Provides utilities for operations on abstract syntax trees (AST).

    • Uses of ImportTree in com.sun.source.tree

      Methods in com.sun.source.tree that return types with arguments of type ImportTree
      Modifier and Type | Method and Description
      List<? extends ImportTree> | CompilationUnitTree.getImports()
      Methods in com.sun.source.tree with parameters of type ImportTree
      Modifier and Type | Method and Description
      R | TreeVisitor.visitImport(ImportTree node, P p)

    • Uses of ImportTree in com.sun.source.util

      Methods in com.sun.source.util with parameters of type ImportTree
      Modifier and Type | Method and Description
      R | SimpleTreeVisitor.visitImport(ImportTree node, P p)
      R | TreeScanner.visitImport(ImportTree node, P p)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Compiler Tree API
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 2005, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.IncompatibleThreadStateException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.IncompatibleThreadStateException

  • Packages that use IncompatibleThreadStateException
    Package Description
    com.sun.jdi
    This is the core package of the Java Debug Interface (JDI), it defines mirrors for values, types, and the target VirtualMachine itself - as well bootstrapping facilities.

    • Uses of IncompatibleThreadStateException in com.sun.jdi

      Methods in com.sun.jdi that throw IncompatibleThreadStateException
      Modifier and Type Method and Description
      ObjectReference ThreadReference.currentContendedMonitor()
      Returns an ObjectReference for the monitor, if any, for which this thread is currently waiting.
      int ObjectReference.entryCount()
      Returns the number times this object's monitor has been entered by the current owning thread.
      void ThreadReference.forceEarlyReturn(Value value)
      Force a method to return before it reaches a return statement.
      StackFrame ThreadReference.frame(int index)
      Returns the StackFrame at the given index in the thread's current call stack.
      int ThreadReference.frameCount()
      Returns the number of stack frames in the thread's current call stack.
      List<StackFrame> ThreadReference.frames()
      Returns a List containing each StackFrame in the thread's current call stack.
      List<StackFrame> ThreadReference.frames(int start, int length)
      Returns a List containing a range of StackFrame mirrors from the thread's current call stack.
      Value ObjectReference.invokeMethod(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Invokes the specified Method on this object in the target VM.
      Value ClassType.invokeMethod(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Invokes the specified static Method in the target VM.
      default Value InterfaceType.invokeMethod(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Invokes the specified static Method in the target VM.
      ObjectReference ClassType.newInstance(ThreadReference thread, Method method, List<? extends Value> arguments, int options)
      Constructs a new instance of this type, using the given constructor Method in the target VM.
      List<ObjectReference> ThreadReference.ownedMonitors()
      Returns a List containing an ObjectReference for each monitor owned by the thread.
      List<MonitorInfo> ThreadReference.ownedMonitorsAndFrames()
      Returns a List containing a MonitorInfo object for each monitor owned by the thread.
      ThreadReference ObjectReference.owningThread()
      Returns an ThreadReference for the thread, if any, which currently owns this object's monitor.
      void ThreadReference.popFrames(StackFrame frame)
      Pop stack frames.
      List<ThreadReference> ObjectReference.waitingThreads()
      Returns a List containing a ThreadReference for each thread currently waiting for this object's monitor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


Uses of Class com.sun.jdi.InconsistentDebugInfoException (Java Debug Interface )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
com.sun.jdi.InconsistentDebugInfoException

No usage of com.sun.jdi.InconsistentDebugInfoException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java Debug Interface
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Copyright © 1999, 2015, Oracle and/or its affiliates. All rights reserved.


_ACTIVE

_ACTIVE o7planning.org
  • State._ACTIVE


_ADD_OVERRIDE

_ADD_OVERRIDE o7planning.org
  • SetOverrideType._ADD_OVERRIDE


_all_interfaces

_all_interfaces o7planning.org
  • BindingIteratorPOA._all_interfaces(POA, byte[])
  • NamingContextExtPOA._all_interfaces(POA, byte[])
  • NamingContextPOA._all_interfaces(POA, byte[])
  • Servant._all_interfaces(POA, byte[])
  • ServantActivatorPOA._all_interfaces(POA, byte[])
  • ServantLocatorPOA._all_interfaces(POA, byte[])


_BindingIteratorImplBase

_BindingIteratorImplBase o7planning.org
  • _BindingIteratorImplBase._BindingIteratorImplBase()


_BindingIteratorStub

_BindingIteratorStub o7planning.org
  • _BindingIteratorStub._BindingIteratorStub()


_COMPLETED_MAYBE

_COMPLETED_MAYBE o7planning.org
  • CompletionStatus._COMPLETED_MAYBE


_COMPLETED_NO

_COMPLETED_NO o7planning.org
  • CompletionStatus._COMPLETED_NO


_COMPLETED_YES

_COMPLETED_YES o7planning.org
  • CompletionStatus._COMPLETED_YES


_create_request

_create_request o7planning.org
  • LocalObject._create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList)
  • LocalObject._create_request(Context, String, NVList, NamedValue)
  • Object._create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList)
  • Object._create_request(Context, String, NVList, NamedValue)
  • ObjectImpl._create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList)
  • ObjectImpl._create_request(Context, String, NVList, NamedValue)


_default_POA

_default_POA o7planning.org
  • Servant._default_POA()


_DISCARDING

_DISCARDING o7planning.org
  • State._DISCARDING


_dk_AbstractInterface

_dk_AbstractInterface o7planning.org
  • DefinitionKind._dk_AbstractInterface


_dk_Alias

_dk_Alias o7planning.org
  • DefinitionKind._dk_Alias


_dk_all

_dk_all o7planning.org
  • DefinitionKind._dk_all


_dk_Array

_dk_Array o7planning.org
  • DefinitionKind._dk_Array


_dk_Attribute

_dk_Attribute o7planning.org
  • DefinitionKind._dk_Attribute


_dk_Constant

_dk_Constant o7planning.org
  • DefinitionKind._dk_Constant


_dk_Enum

_dk_Enum o7planning.org
  • DefinitionKind._dk_Enum


_dk_Exception

_dk_Exception o7planning.org
  • DefinitionKind._dk_Exception


_dk_Fixed

_dk_Fixed o7planning.org
  • DefinitionKind._dk_Fixed


_dk_Interface

_dk_Interface o7planning.org
  • DefinitionKind._dk_Interface


_dk_Module

_dk_Module o7planning.org
  • DefinitionKind._dk_Module


_dk_Native

_dk_Native o7planning.org
  • DefinitionKind._dk_Native


_dk_none

_dk_none o7planning.org
  • DefinitionKind._dk_none


_dk_Operation

_dk_Operation o7planning.org
  • DefinitionKind._dk_Operation


_dk_Primitive

_dk_Primitive o7planning.org
  • DefinitionKind._dk_Primitive


_dk_Repository

_dk_Repository o7planning.org
  • DefinitionKind._dk_Repository


_dk_Sequence

_dk_Sequence o7planning.org
  • DefinitionKind._dk_Sequence


_dk_String

_dk_String o7planning.org
  • DefinitionKind._dk_String


_dk_Struct

_dk_Struct o7planning.org
  • DefinitionKind._dk_Struct


_dk_Typedef

_dk_Typedef o7planning.org
  • DefinitionKind._dk_Typedef


_dk_Union

_dk_Union o7planning.org
  • DefinitionKind._dk_Union


_dk_Value

_dk_Value o7planning.org
  • DefinitionKind._dk_Value


_dk_ValueBox

_dk_ValueBox o7planning.org
  • DefinitionKind._dk_ValueBox


_dk_ValueMember

_dk_ValueMember o7planning.org
  • DefinitionKind._dk_ValueMember


_dk_Wstring

_dk_Wstring o7planning.org
  • DefinitionKind._dk_Wstring


_duplicate

_duplicate o7planning.org
  • LocalObject._duplicate()
  • Object._duplicate()
  • ObjectImpl._duplicate()


_DynAnyFactoryStub

_DynAnyFactoryStub o7planning.org
  • _DynAnyFactoryStub._DynAnyFactoryStub()


_DynAnyStub

_DynAnyStub o7planning.org
  • _DynAnyStub._DynAnyStub()


_DynArrayStub

_DynArrayStub o7planning.org
  • _DynArrayStub._DynArrayStub()


_DynEnumStub

_DynEnumStub o7planning.org
  • _DynEnumStub._DynEnumStub()


_DynFixedStub

_DynFixedStub o7planning.org
  • _DynFixedStub._DynFixedStub()


_DynSequenceStub

_DynSequenceStub o7planning.org
  • _DynSequenceStub._DynSequenceStub()


_DynStructStub

_DynStructStub o7planning.org
  • _DynStructStub._DynStructStub()


_DynUnionStub

_DynUnionStub o7planning.org
  • _DynUnionStub._DynUnionStub()


_DynValueStub

_DynValueStub o7planning.org
  • _DynValueStub._DynValueStub()


_get_codebase

_get_codebase o7planning.org
  • ObjectImpl._get_codebase()


_get_delegate

_get_delegate o7planning.org
  • ObjectImpl._get_delegate()
  • Servant._get_delegate()


_get_domain_managers

_get_domain_managers o7planning.org
  • LocalObject._get_domain_managers()
  • Object._get_domain_managers()
  • ObjectImpl._get_domain_managers()


_get_interface

_get_interface o7planning.org
  • LocalObject._get_interface()


_get_interface_def

_get_interface_def o7planning.org
  • LocalObject._get_interface_def()
  • Object._get_interface_def()
  • ObjectImpl._get_interface_def()
  • Servant._get_interface_def()


_get_policy

_get_policy o7planning.org
  • LocalObject._get_policy(int)
  • Object._get_policy(int)
  • ObjectImpl._get_policy(int)


_hash

_hash o7planning.org
  • LocalObject._hash(int)
  • Object._hash(int)
  • ObjectImpl._hash(int)


_HOLDING

_HOLDING o7planning.org
  • State._HOLDING


_IDLTypeStub

_IDLTypeStub o7planning.org
  • _IDLTypeStub._IDLTypeStub(Delegate)
  • _IDLTypeStub._IDLTypeStub()


_ids

_ids o7planning.org
  • DynamicImplementation._ids()
  • ObjectImpl._ids()
  • _BindingIteratorImplBase._ids()
  • _BindingIteratorStub._ids()
  • _DynAnyFactoryStub._ids()
  • _DynAnyStub._ids()
  • _DynArrayStub._ids()
  • _DynEnumStub._ids()
  • _DynFixedStub._ids()
  • _DynSequenceStub._ids()
  • _DynStructStub._ids()
  • _DynUnionStub._ids()
  • _DynValueStub._ids()
  • _IDLTypeStub._ids()
  • _NamingContextExtStub._ids()
  • _NamingContextImplBase._ids()
  • _NamingContextStub._ids()
  • _PolicyStub._ids()
  • _Remote_Stub._ids()
  • _ServantActivatorStub._ids()
  • _ServantLocatorStub._ids()


_IMPLICIT_ACTIVATION

_IMPLICIT_ACTIVATION o7planning.org
  • ImplicitActivationPolicyValue._IMPLICIT_ACTIVATION


_INACTIVE

_INACTIVE o7planning.org
  • State._INACTIVE


_invoke

_invoke o7planning.org
  • BindingIteratorPOA._invoke(String, InputStream, ResponseHandler)
  • InvokeHandler._invoke(String, InputStream, ResponseHandler)
  • LocalObject._invoke(OutputStream)
  • NamingContextExtPOA._invoke(String, InputStream, ResponseHandler)
  • NamingContextPOA._invoke(String, InputStream, ResponseHandler)
  • ObjectImpl._invoke(OutputStream)
  • ServantActivatorPOA._invoke(String, InputStream, ResponseHandler)
  • ServantLocatorPOA._invoke(String, InputStream, ResponseHandler)


_is_a

_is_a o7planning.org
  • LocalObject._is_a(String)
  • Object._is_a(String)
  • ObjectImpl._is_a(String)
  • Servant._is_a(String)


_is_equivalent

_is_equivalent o7planning.org
  • LocalObject._is_equivalent(Object)
  • Object._is_equivalent(Object)
  • ObjectImpl._is_equivalent(Object)


_is_local

_is_local o7planning.org
  • LocalObject._is_local()
  • ObjectImpl._is_local()


_missing_node

_missing_node o7planning.org
  • NotFoundReason._missing_node


_MULTIPLE_ID

_MULTIPLE_ID o7planning.org
  • IdUniquenessPolicyValue._MULTIPLE_ID


_NamingContextExtStub

_NamingContextExtStub o7planning.org
  • _NamingContextExtStub._NamingContextExtStub()


_NamingContextImplBase

_NamingContextImplBase o7planning.org
  • _NamingContextImplBase._NamingContextImplBase()


_NamingContextStub

_NamingContextStub o7planning.org
  • _NamingContextStub._NamingContextStub()


_ncontext

_ncontext o7planning.org
  • BindingType._ncontext


_NO_IMPLICIT_ACTIVATION

_NO_IMPLICIT_ACTIVATION o7planning.org
  • ImplicitActivationPolicyValue._NO_IMPLICIT_ACTIVATION


_nobject

_nobject o7planning.org
  • BindingType._nobject


_non_existent

_non_existent o7planning.org
  • LocalObject._non_existent()
  • Object._non_existent()
  • ObjectImpl._non_existent()
  • Servant._non_existent()


_NON_RETAIN

_NON_RETAIN o7planning.org
  • ServantRetentionPolicyValue._NON_RETAIN


_not_context

_not_context o7planning.org
  • NotFoundReason._not_context


_not_object

_not_object o7planning.org
  • NotFoundReason._not_object


_object_id

_object_id o7planning.org
  • Servant._object_id()


_opsClass

_opsClass o7planning.org
  • _DynAnyFactoryStub._opsClass
  • _DynAnyStub._opsClass
  • _DynArrayStub._opsClass
  • _DynEnumStub._opsClass
  • _DynFixedStub._opsClass
  • _DynSequenceStub._opsClass
  • _DynStructStub._opsClass
  • _DynUnionStub._opsClass
  • _DynValueStub._opsClass
  • _ServantActivatorStub._opsClass
  • _ServantLocatorStub._opsClass


_orb

_orb o7planning.org
  • LocalObject._orb()
  • ObjectImpl._orb()
  • Servant._orb()


_ORB_CTRL_MODEL

_ORB_CTRL_MODEL o7planning.org
  • ThreadPolicyValue._ORB_CTRL_MODEL


_PARAM_IN

_PARAM_IN o7planning.org
  • ParameterMode._PARAM_IN


_PARAM_INOUT

_PARAM_INOUT o7planning.org
  • ParameterMode._PARAM_INOUT


_PARAM_OUT

_PARAM_OUT o7planning.org
  • ParameterMode._PARAM_OUT


_PERSISTENT

_PERSISTENT o7planning.org
  • LifespanPolicyValue._PERSISTENT


_poa

_poa o7planning.org
  • Servant._poa()


_PolicyStub

_PolicyStub o7planning.org
  • _PolicyStub._PolicyStub(Delegate)
  • _PolicyStub._PolicyStub()


_postEdit

_postEdit o7planning.org
  • UndoableEditSupport._postEdit(UndoableEdit)


_read

_read o7planning.org
  • AlreadyBoundHolder._read(InputStream)
  • AnyHolder._read(InputStream)
  • AnySeqHolder._read(InputStream)
  • BindingHolder._read(InputStream)
  • BindingIteratorHolder._read(InputStream)
  • BindingListHolder._read(InputStream)
  • BindingTypeHolder._read(InputStream)
  • BooleanHolder._read(InputStream)
  • BooleanSeqHolder._read(InputStream)
  • ByteHolder._read(InputStream)
  • CannotProceedHolder._read(InputStream)
  • CharHolder._read(InputStream)
  • CharSeqHolder._read(InputStream)
  • CookieHolder._read(InputStream)
  • CurrentHolder._read(InputStream)
  • DoubleHolder._read(InputStream)
  • DoubleSeqHolder._read(InputStream)
  • FixedHolder._read(InputStream)
  • FloatHolder._read(InputStream)
  • FloatSeqHolder._read(InputStream)
  • IORHolder._read(InputStream)
  • IORInterceptor_3_0Holder._read(InputStream)
  • IntHolder._read(InputStream)
  • InvalidAddressHolder._read(InputStream)
  • InvalidNameHolder._read(InputStream)
  • LongHolder._read(InputStream)
  • LongLongSeqHolder._read(InputStream)
  • LongSeqHolder._read(InputStream)
  • MultipleComponentProfileHolder._read(InputStream)
  • NameComponentHolder._read(InputStream)
  • NameHolder._read(InputStream)
  • NamingContextExtHolder._read(InputStream)
  • NamingContextHolder._read(InputStream)
  • NotEmptyHolder._read(InputStream)
  • NotFoundHolder._read(InputStream)
  • NotFoundReasonHolder._read(InputStream)
  • ObjectHolder._read(InputStream)
  • ObjectReferenceFactoryHolder._read(InputStream)
  • ObjectReferenceTemplateHolder._read(InputStream)
  • ObjectReferenceTemplateSeqHolder._read(InputStream)
  • OctetSeqHolder._read(InputStream)
  • ParameterModeHolder._read(InputStream)
  • PolicyErrorHolder._read(InputStream)
  • PolicyHolder._read(InputStream)
  • PolicyListHolder._read(InputStream)
  • PrincipalHolder._read(InputStream)
  • ServiceContextHolder._read(InputStream)
  • ServiceContextListHolder._read(InputStream)
  • ServiceInformationHolder._read(InputStream)
  • ShortHolder._read(InputStream)
  • ShortSeqHolder._read(InputStream)
  • Streamable._read(InputStream)
  • StringHolder._read(InputStream)
  • StringSeqHolder._read(InputStream)
  • TaggedComponentHolder._read(InputStream)
  • TaggedProfileHolder._read(InputStream)
  • TypeCodeHolder._read(InputStream)
  • ULongLongSeqHolder._read(InputStream)
  • ULongSeqHolder._read(InputStream)
  • UShortSeqHolder._read(InputStream)
  • UnknownUserExceptionHolder._read(InputStream)
  • ValueBaseHolder._read(InputStream)
  • WCharSeqHolder._read(InputStream)
  • WStringSeqHolder._read(InputStream)
  • WrongTransactionHolder._read(InputStream)


_release

_release o7planning.org
  • LocalObject._release()
  • Object._release()
  • ObjectImpl._release()


_releaseReply

_releaseReply o7planning.org
  • LocalObject._releaseReply(InputStream)
  • ObjectImpl._releaseReply(InputStream)


_Remote_Stub

_Remote_Stub o7planning.org
  • _Remote_Stub._Remote_Stub()


_request

_request o7planning.org
  • LocalObject._request(String, boolean)
  • LocalObject._request(String)
  • Object._request(String)
  • ObjectImpl._request(String, boolean)
  • ObjectImpl._request(String)


_RETAIN

_RETAIN o7planning.org
  • ServantRetentionPolicyValue._RETAIN


_servant_postinvoke

_servant_postinvoke o7planning.org
  • LocalObject._servant_postinvoke(ServantObject)
  • ObjectImpl._servant_postinvoke(ServantObject)


_servant_preinvoke

_servant_preinvoke o7planning.org
  • LocalObject._servant_preinvoke(String, Class)
  • ObjectImpl._servant_preinvoke(String, Class)


_ServantActivatorStub

_ServantActivatorStub o7planning.org
  • _ServantActivatorStub._ServantActivatorStub()


_ServantLocatorStub

_ServantLocatorStub o7planning.org
  • _ServantLocatorStub._ServantLocatorStub()


_set_delegate

_set_delegate o7planning.org
  • ObjectImpl._set_delegate(Delegate)
  • Servant._set_delegate(Delegate)


_SET_OVERRIDE

_SET_OVERRIDE o7planning.org
  • SetOverrideType._SET_OVERRIDE


_set_policy_override

_set_policy_override o7planning.org
  • LocalObject._set_policy_override(Policy[], SetOverrideType)
  • Object._set_policy_override(Policy[], SetOverrideType)
  • ObjectImpl._set_policy_override(Policy[], SetOverrideType)


_SINGLE_THREAD_MODEL

_SINGLE_THREAD_MODEL o7planning.org
  • ThreadPolicyValue._SINGLE_THREAD_MODEL


_SYSTEM_ID

_SYSTEM_ID o7planning.org
  • IdAssignmentPolicyValue._SYSTEM_ID


_this

_this o7planning.org
  • BindingIteratorPOA._this(ORB)
  • BindingIteratorPOA._this()
  • NamingContextExtPOA._this(ORB)
  • NamingContextExtPOA._this()
  • NamingContextPOA._this(ORB)
  • NamingContextPOA._this()
  • ServantActivatorPOA._this(ORB)
  • ServantActivatorPOA._this()
  • ServantLocatorPOA._this(ORB)
  • ServantLocatorPOA._this()


_this_object

_this_object o7planning.org
  • Servant._this_object(ORB)
  • Servant._this_object()


_tk_abstract_interface

_tk_abstract_interface o7planning.org
  • TCKind._tk_abstract_interface


_tk_alias

_tk_alias o7planning.org
  • TCKind._tk_alias


_tk_any

_tk_any o7planning.org
  • TCKind._tk_any


_tk_array

_tk_array o7planning.org
  • TCKind._tk_array


_tk_boolean

_tk_boolean o7planning.org
  • TCKind._tk_boolean


_tk_char

_tk_char o7planning.org
  • TCKind._tk_char


_tk_double

_tk_double o7planning.org
  • TCKind._tk_double


_tk_enum

_tk_enum o7planning.org
  • TCKind._tk_enum


_tk_except

_tk_except o7planning.org
  • TCKind._tk_except


_tk_fixed

_tk_fixed o7planning.org
  • TCKind._tk_fixed


_tk_float

_tk_float o7planning.org
  • TCKind._tk_float


_tk_long

_tk_long o7planning.org
  • TCKind._tk_long


_tk_longdouble

_tk_longdouble o7planning.org
  • TCKind._tk_longdouble


_tk_longlong

_tk_longlong o7planning.org
  • TCKind._tk_longlong


_tk_native

_tk_native o7planning.org
  • TCKind._tk_native


_tk_null

_tk_null o7planning.org
  • TCKind._tk_null


_tk_objref

_tk_objref o7planning.org
  • TCKind._tk_objref


_tk_octet

_tk_octet o7planning.org
  • TCKind._tk_octet


_tk_Principal

_tk_Principal o7planning.org
  • TCKind._tk_Principal


_tk_sequence

_tk_sequence o7planning.org
  • TCKind._tk_sequence


_tk_short

_tk_short o7planning.org
  • TCKind._tk_short


_tk_string

_tk_string o7planning.org
  • TCKind._tk_string


_tk_struct

_tk_struct o7planning.org
  • TCKind._tk_struct


_tk_TypeCode

_tk_TypeCode o7planning.org
  • TCKind._tk_TypeCode


_tk_ulong

_tk_ulong o7planning.org
  • TCKind._tk_ulong


_tk_ulonglong

_tk_ulonglong o7planning.org
  • TCKind._tk_ulonglong


_tk_union

_tk_union o7planning.org
  • TCKind._tk_union


_tk_ushort

_tk_ushort o7planning.org
  • TCKind._tk_ushort


_tk_value

_tk_value o7planning.org
  • TCKind._tk_value


_tk_value_box

_tk_value_box o7planning.org
  • TCKind._tk_value_box


_tk_void

_tk_void o7planning.org
  • TCKind._tk_void


_tk_wchar

_tk_wchar o7planning.org
  • TCKind._tk_wchar


_tk_wstring

_tk_wstring o7planning.org
  • TCKind._tk_wstring


_TRANSIENT

_TRANSIENT o7planning.org
  • LifespanPolicyValue._TRANSIENT


_truncatable_ids

_truncatable_ids o7planning.org
  • ValueBase._truncatable_ids()


_type

_type o7planning.org
  • AlreadyBoundHolder._type()
  • AnyHolder._type()
  • AnySeqHolder._type()
  • BindingHolder._type()
  • BindingIteratorHolder._type()
  • BindingListHolder._type()
  • BindingTypeHolder._type()
  • BooleanHolder._type()
  • BooleanSeqHolder._type()
  • ByteHolder._type()
  • CannotProceedHolder._type()
  • CharHolder._type()
  • CharSeqHolder._type()
  • CookieHolder._type()
  • CurrentHolder._type()
  • DoubleHolder._type()
  • DoubleSeqHolder._type()
  • FixedHolder._type()
  • FloatHolder._type()
  • FloatSeqHolder._type()
  • IORHolder._type()
  • IORInterceptor_3_0Holder._type()
  • IntHolder._type()
  • InvalidAddressHolder._type()
  • InvalidNameHolder._type()
  • LongHolder._type()
  • LongLongSeqHolder._type()
  • LongSeqHolder._type()
  • MultipleComponentProfileHolder._type()
  • NameComponentHolder._type()
  • NameHolder._type()
  • NamingContextExtHolder._type()
  • NamingContextHolder._type()
  • NotEmptyHolder._type()
  • NotFoundHolder._type()
  • NotFoundReasonHolder._type()
  • ObjectHolder._type()
  • ObjectReferenceFactoryHolder._type()
  • ObjectReferenceTemplateHolder._type()
  • ObjectReferenceTemplateSeqHolder._type()
  • OctetSeqHolder._type()
  • ParameterModeHolder._type()
  • PolicyErrorHolder._type()
  • PolicyHolder._type()
  • PolicyListHolder._type()
  • PrincipalHolder._type()
  • ServiceContextHolder._type()
  • ServiceContextListHolder._type()
  • ServiceInformationHolder._type()
  • ShortHolder._type()
  • ShortSeqHolder._type()
  • Streamable._type()
  • StringHolder._type()
  • StringSeqHolder._type()
  • TaggedComponentHolder._type()
  • TaggedProfileHolder._type()
  • TypeCodeHolder._type()
  • ULongLongSeqHolder._type()
  • ULongSeqHolder._type()
  • UShortSeqHolder._type()
  • UnknownUserExceptionHolder._type()
  • ValueBaseHolder._type()
  • WCharSeqHolder._type()
  • WStringSeqHolder._type()
  • WrongTransactionHolder._type()


_UNIQUE_ID

_UNIQUE_ID o7planning.org
  • IdUniquenessPolicyValue._UNIQUE_ID


_USE_ACTIVE_OBJECT_MAP_ONLY

_USE_ACTIVE_OBJECT_MAP_ONLY o7planning.org
  • RequestProcessingPolicyValue._USE_ACTIVE_OBJECT_MAP_ONLY


_USE_DEFAULT_SERVANT

_USE_DEFAULT_SERVANT o7planning.org
  • RequestProcessingPolicyValue._USE_DEFAULT_SERVANT


_USE_SERVANT_MANAGER

_USE_SERVANT_MANAGER o7planning.org
  • RequestProcessingPolicyValue._USE_SERVANT_MANAGER


_USER_ID

_USER_ID o7planning.org
  • IdAssignmentPolicyValue._USER_ID


_write

_write o7planning.org
  • AlreadyBoundHolder._write(OutputStream)
  • AnyHolder._write(OutputStream)
  • AnySeqHolder._write(OutputStream)
  • BindingHolder._write(OutputStream)
  • BindingIteratorHolder._write(OutputStream)
  • BindingListHolder._write(OutputStream)
  • BindingTypeHolder._write(OutputStream)
  • BooleanHolder._write(OutputStream)
  • BooleanSeqHolder._write(OutputStream)
  • ByteHolder._write(OutputStream)
  • CannotProceedHolder._write(OutputStream)
  • CharHolder._write(OutputStream)
  • CharSeqHolder._write(OutputStream)
  • CookieHolder._write(OutputStream)
  • CurrentHolder._write(OutputStream)
  • DoubleHolder._write(OutputStream)
  • DoubleSeqHolder._write(OutputStream)
  • FixedHolder._write(OutputStream)
  • FloatHolder._write(OutputStream)
  • FloatSeqHolder._write(OutputStream)
  • IORHolder._write(OutputStream)
  • IORInterceptor_3_0Holder._write(OutputStream)
  • IntHolder._write(OutputStream)
  • InvalidAddressHolder._write(OutputStream)
  • InvalidNameHolder._write(OutputStream)
  • LongHolder._write(OutputStream)
  • LongLongSeqHolder._write(OutputStream)
  • LongSeqHolder._write(OutputStream)
  • MultipleComponentProfileHolder._write(OutputStream)
  • NameComponentHolder._write(OutputStream)
  • NameHolder._write(OutputStream)
  • NamingContextExtHolder._write(OutputStream)
  • NamingContextHolder._write(OutputStream)
  • NotEmptyHolder._write(OutputStream)
  • NotFoundHolder._write(OutputStream)
  • NotFoundReasonHolder._write(OutputStream)
  • ObjectHolder._write(OutputStream)
  • ObjectReferenceFactoryHolder._write(OutputStream)
  • ObjectReferenceTemplateHolder._write(OutputStream)
  • ObjectReferenceTemplateSeqHolder._write(OutputStream)
  • OctetSeqHolder._write(OutputStream)
  • ParameterModeHolder._write(OutputStream)
  • PolicyErrorHolder._write(OutputStream)
  • PolicyHolder._write(OutputStream)
  • PolicyListHolder._write(OutputStream)
  • PrincipalHolder._write(OutputStream)
  • ServiceContextHolder._write(OutputStream)
  • ServiceContextListHolder._write(OutputStream)
  • ServiceInformationHolder._write(OutputStream)
  • ShortHolder._write(OutputStream)
  • ShortSeqHolder._write(OutputStream)
  • Streamable._write(OutputStream)
  • StringHolder._write(OutputStream)
  • StringSeqHolder._write(OutputStream)
  • TaggedComponentHolder._write(OutputStream)
  • TaggedProfileHolder._write(OutputStream)
  • TypeCodeHolder._write(OutputStream)
  • ULongLongSeqHolder._write(OutputStream)
  • ULongSeqHolder._write(OutputStream)
  • UShortSeqHolder._write(OutputStream)
  • UnknownUserExceptionHolder._write(OutputStream)
  • ValueBaseHolder._write(OutputStream)
  • WCharSeqHolder._write(OutputStream)
  • WStringSeqHolder._write(OutputStream)
  • WrongTransactionHolder._write(OutputStream)


A0

A0 o7planning.org
  • MediaSize.ISO.A0
  • PageAttributes.MediaType.A0


A1

A1 o7planning.org
  • MediaSize.ISO.A1
  • PageAttributes.MediaType.A1


A2

A2 o7planning.org
  • MediaSize.ISO.A2
  • PageAttributes.MediaType.A2


A3

A3 o7planning.org
  • MediaSize.ISO.A3
  • PageAttributes.MediaType.A3


A4

A4 o7planning.org
  • MediaSize.ISO.A4
  • PageAttributes.MediaType.A4


A5

A5 o7planning.org
  • MediaSize.ISO.A5
  • PageAttributes.MediaType.A5


A6

A6 o7planning.org
  • MediaSize.ISO.A6
  • PageAttributes.MediaType.A6


A7

A7 o7planning.org
  • MediaSize.ISO.A7
  • PageAttributes.MediaType.A7


A8

A8 o7planning.org
  • MediaSize.ISO.A8
  • PageAttributes.MediaType.A8


A9

A9 o7planning.org
  • MediaSize.ISO.A9
  • PageAttributes.MediaType.A9


A10

A10 o7planning.org
  • MediaSize.ISO.A10
  • PageAttributes.MediaType.A10


a

a o7planning.org
  • AWTEventMulticaster.a


A

A o7planning.org
  • HTML.Tag.A
  • MediaSize.Engineering.A
  • MediaSizeName.A
  • PageAttributes.MediaType.A


ABORT

ABORT o7planning.org
  • ImageObserver.ABORT


abort

abort o7planning.org
  • CacheRequest.abort()
  • Connection.abort(Executor)
  • ImageReader.abort()
  • ImageWriter.abort()
  • LSParser.abort()
  • LoginModule.abort()


ABORTED

ABORTED o7planning.org
  • JobState.ABORTED
  • MediaTracker.ABORTED


ABORTED_BY_SYSTEM

ABORTED_BY_SYSTEM o7planning.org
  • JobStateReason.ABORTED_BY_SYSTEM


abortGrabbing

abortGrabbing o7planning.org
  • PixelGrabber.abortGrabbing()


AbortPolicy

AbortPolicy o7planning.org
  • ThreadPoolExecutor.AbortPolicy.AbortPolicy()


abortRequested

abortRequested o7planning.org
  • ImageReader.abortRequested()
  • ImageWriter.abortRequested()


ABOUT_UIROLE

ABOUT_UIROLE o7planning.org
  • ServiceUIFactory.ABOUT_UIROLE


ABOVE_BASELINE

ABOVE_BASELINE o7planning.org
  • GridBagConstraints.ABOVE_BASELINE


ABOVE_BASELINE_LEADING

ABOVE_BASELINE_LEADING o7planning.org
  • GridBagConstraints.ABOVE_BASELINE_LEADING


ABOVE_BASELINE_TRAILING

ABOVE_BASELINE_TRAILING o7planning.org
  • GridBagConstraints.ABOVE_BASELINE_TRAILING


ABOVE_BOTTOM

ABOVE_BOTTOM o7planning.org
  • TitledBorder.ABOVE_BOTTOM


ABOVE_TOP

ABOVE_TOP o7planning.org
  • TitledBorder.ABOVE_TOP


abs

abs o7planning.org
  • BigDecimal.abs(MathContext)
  • BigDecimal.abs()
  • BigInteger.abs()
  • Duration.abs()
  • Math.abs(double)
  • Math.abs(float)
  • Math.abs(long)
  • Math.abs(int)
  • StrictMath.abs(double)
  • StrictMath.abs(float)
  • StrictMath.abs(long)
  • StrictMath.abs(int)


absolute

absolute o7planning.org
  • ResultSet.absolute(int)


absolutePath

absolutePath o7planning.org
  • AbstractPreferences.absolutePath()
  • Preferences.absolutePath()


ABSTRACT

ABSTRACT o7planning.org
  • Modifier.ABSTRACT


AbstractAction

AbstractAction o7planning.org
  • AbstractAction.AbstractAction(String, Icon)
  • AbstractAction.AbstractAction(String)
  • AbstractAction.AbstractAction()


AbstractAnnotationValueVisitor6

AbstractAnnotationValueVisitor6 o7planning.org
  • AbstractAnnotationValueVisitor6.AbstractAnnotationValueVisitor6()


AbstractAnnotationValueVisitor7

AbstractAnnotationValueVisitor7 o7planning.org
  • AbstractAnnotationValueVisitor7.AbstractAnnotationValueVisitor7()


AbstractAnnotationValueVisitor8

AbstractAnnotationValueVisitor8 o7planning.org
  • AbstractAnnotationValueVisitor8.AbstractAnnotationValueVisitor8()


AbstractBorder

AbstractBorder o7planning.org
  • AbstractBorder.AbstractBorder()


AbstractButton

AbstractButton o7planning.org
  • AbstractButton.AbstractButton()


AbstractCellEditor

AbstractCellEditor o7planning.org
  • AbstractCellEditor.AbstractCellEditor()


AbstractChronology

AbstractChronology o7planning.org
  • AbstractChronology.AbstractChronology()


AbstractCollection

AbstractCollection o7planning.org
  • AbstractCollection.AbstractCollection()


AbstractColorChooserPanel

AbstractColorChooserPanel o7planning.org
  • AbstractColorChooserPanel.AbstractColorChooserPanel()


AbstractDocument

AbstractDocument o7planning.org
  • AbstractDocument.AbstractDocument(AbstractDocument.Content, AbstractDocument.AttributeContext)
  • AbstractDocument.AbstractDocument(AbstractDocument.Content)


AbstractDoubleSpliterator

AbstractDoubleSpliterator o7planning.org
  • Spliterators.AbstractDoubleSpliterator.AbstractDoubleSpliterator(long, int)


AbstractElement

AbstractElement o7planning.org
  • AbstractDocument.AbstractElement.AbstractElement(Element, AttributeSet)


AbstractElementVisitor6

AbstractElementVisitor6 o7planning.org
  • AbstractElementVisitor6.AbstractElementVisitor6()


AbstractElementVisitor7

AbstractElementVisitor7 o7planning.org
  • AbstractElementVisitor7.AbstractElementVisitor7()


AbstractElementVisitor8

AbstractElementVisitor8 o7planning.org
  • AbstractElementVisitor8.AbstractElementVisitor8()


AbstractExecutorService

AbstractExecutorService o7planning.org
  • AbstractExecutorService.AbstractExecutorService()


AbstractFormatter

AbstractFormatter o7planning.org
  • JFormattedTextField.AbstractFormatter.AbstractFormatter()


AbstractFormatterFactory

AbstractFormatterFactory o7planning.org
  • JFormattedTextField.AbstractFormatterFactory.AbstractFormatterFactory()


AbstractInterruptibleChannel

AbstractInterruptibleChannel o7planning.org
  • AbstractInterruptibleChannel.AbstractInterruptibleChannel()


AbstractIntSpliterator

AbstractIntSpliterator o7planning.org
  • Spliterators.AbstractIntSpliterator.AbstractIntSpliterator(long, int)


AbstractLayoutCache

AbstractLayoutCache o7planning.org
  • AbstractLayoutCache.AbstractLayoutCache()


AbstractList

AbstractList o7planning.org
  • AbstractList.AbstractList()


AbstractListModel

AbstractListModel o7planning.org
  • AbstractListModel.AbstractListModel()


AbstractLongSpliterator

AbstractLongSpliterator o7planning.org
  • Spliterators.AbstractLongSpliterator.AbstractLongSpliterator(long, int)


AbstractMap

AbstractMap o7planning.org
  • AbstractMap.AbstractMap()


AbstractMarshallerImpl

AbstractMarshallerImpl o7planning.org
  • AbstractMarshallerImpl.AbstractMarshallerImpl()


AbstractMethodError

AbstractMethodError o7planning.org
  • AbstractMethodError.AbstractMethodError(String)
  • AbstractMethodError.AbstractMethodError()


AbstractOwnableSynchronizer

AbstractOwnableSynchronizer o7planning.org
  • AbstractOwnableSynchronizer.AbstractOwnableSynchronizer()


AbstractPreferences

AbstractPreferences o7planning.org
  • AbstractPreferences.AbstractPreferences(AbstractPreferences, String)


AbstractProcessor

AbstractProcessor o7planning.org
  • AbstractProcessor.AbstractProcessor()


AbstractQueue

AbstractQueue o7planning.org
  • AbstractQueue.AbstractQueue()


AbstractQueuedLongSynchronizer

AbstractQueuedLongSynchronizer o7planning.org
  • AbstractQueuedLongSynchronizer.AbstractQueuedLongSynchronizer()


AbstractQueuedSynchronizer

AbstractQueuedSynchronizer o7planning.org
  • AbstractQueuedSynchronizer.AbstractQueuedSynchronizer()


AbstractRegionPainter

AbstractRegionPainter o7planning.org
  • AbstractRegionPainter.AbstractRegionPainter()


AbstractScriptEngine

AbstractScriptEngine o7planning.org
  • AbstractScriptEngine.AbstractScriptEngine(Bindings)
  • AbstractScriptEngine.AbstractScriptEngine()


AbstractSelectableChannel

AbstractSelectableChannel o7planning.org
  • AbstractSelectableChannel.AbstractSelectableChannel(SelectorProvider)


AbstractSelectionKey

AbstractSelectionKey o7planning.org
  • AbstractSelectionKey.AbstractSelectionKey()


AbstractSelector

AbstractSelector o7planning.org
  • AbstractSelector.AbstractSelector(SelectorProvider)


AbstractSequentialList

AbstractSequentialList o7planning.org
  • AbstractSequentialList.AbstractSequentialList()


AbstractSet

AbstractSet o7planning.org
  • AbstractSet.AbstractSet()


AbstractSpinnerModel

AbstractSpinnerModel o7planning.org
  • AbstractSpinnerModel.AbstractSpinnerModel()


AbstractSpliterator

AbstractSpliterator o7planning.org
  • Spliterators.AbstractSpliterator.AbstractSpliterator(long, int)


AbstractTableModel

AbstractTableModel o7planning.org
  • AbstractTableModel.AbstractTableModel()


AbstractTypeVisitor6

AbstractTypeVisitor6 o7planning.org
  • AbstractTypeVisitor6.AbstractTypeVisitor6()


AbstractTypeVisitor7

AbstractTypeVisitor7 o7planning.org
  • AbstractTypeVisitor7.AbstractTypeVisitor7()


AbstractTypeVisitor8

AbstractTypeVisitor8 o7planning.org
  • AbstractTypeVisitor8.AbstractTypeVisitor8()


AbstractUndoableEdit

AbstractUndoableEdit o7planning.org
  • AbstractUndoableEdit.AbstractUndoableEdit()


AbstractUnmarshallerImpl

AbstractUnmarshallerImpl o7planning.org
  • AbstractUnmarshallerImpl.AbstractUnmarshallerImpl()


AbstractWriter

AbstractWriter o7planning.org
  • AbstractWriter.AbstractWriter(Writer, Element, int, int)
  • AbstractWriter.AbstractWriter(Writer, Element)
  • AbstractWriter.AbstractWriter(Writer, Document, int, int)
  • AbstractWriter.AbstractWriter(Writer, Document)


accelerationPriority

accelerationPriority o7planning.org
  • Image.accelerationPriority


ACCELERATOR_KEY

ACCELERATOR_KEY o7planning.org
  • Action.ACCELERATOR_KEY


acceleratorDelimiter

acceleratorDelimiter o7planning.org
  • BasicMenuItemUI.acceleratorDelimiter


acceleratorFont

acceleratorFont o7planning.org
  • BasicMenuItemUI.acceleratorFont


acceleratorForeground

acceleratorForeground o7planning.org
  • BasicMenuItemUI.acceleratorForeground


acceleratorSelectionForeground

acceleratorSelectionForeground o7planning.org
  • BasicMenuItemUI.acceleratorSelectionForeground


accept

accept o7planning.org
  • AnnotationValue.accept(AnnotationValueVisitor<R, P>, P)
  • AsynchronousServerSocketChannel.accept()
  • AsynchronousServerSocketChannel.accept(A, CompletionHandler<AsynchronousSocketChannel, ? super A>)
  • BasicFileChooserUI.AcceptAllFileFilter.accept(File)
  • BiConsumer.accept(T, U)
  • Consumer.accept(T)
  • ContainerOrderFocusTraversalPolicy.accept(Component)
  • DefaultFocusTraversalPolicy.accept(Component)
  • DirectoryStream.Filter.accept(T)
  • DoubleConsumer.accept(double)
  • DoubleStream.Builder.accept(double)
  • DoubleSummaryStatistics.accept(double)
  • Element.accept(ElementVisitor<R, P>, P)
  • EventFilter.accept(XMLEvent)
  • FileFilter.accept(File)
  • FileFilter.accept(File)
  • FileNameExtensionFilter.accept(File)
  • FilenameFilter.accept(File, String)
  • IntConsumer.accept(int)
  • IntStream.Builder.accept(int)
  • IntSummaryStatistics.accept(int)
  • JFileChooser.accept(File)
  • LayoutFocusTraversalPolicy.accept(Component)
  • LongConsumer.accept(long)
  • LongStream.Builder.accept(long)
  • LongSummaryStatistics.accept(long)
  • LongSummaryStatistics.accept(int)
  • ObjDoubleConsumer.accept(T, double)
  • ObjIntConsumer.accept(T, int)
  • ObjLongConsumer.accept(T, long)
  • ServerSocket.accept()
  • ServerSocketChannel.accept()
  • SocketImpl.accept(SocketImpl)
  • SortingFocusTraversalPolicy.accept(Component)
  • Stream.Builder.accept(T)
  • StreamFilter.accept(XMLStreamReader)
  • TypeMirror.accept(TypeVisitor<R, P>, P)


ACCEPT_ALL

ACCEPT_ALL o7planning.org
  • CookiePolicy.ACCEPT_ALL


ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY

ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY o7planning.org
  • JFileChooser.ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY


ACCEPT_NONE

ACCEPT_NONE o7planning.org
  • CookiePolicy.ACCEPT_NONE


ACCEPT_ONLY

ACCEPT_ONLY o7planning.org
  • GSSCredential.ACCEPT_ONLY


ACCEPT_ORIGINAL_SERVER

ACCEPT_ORIGINAL_SERVER o7planning.org
  • CookiePolicy.ACCEPT_ORIGINAL_SERVER


AcceptAllFileFilter

AcceptAllFileFilter o7planning.org
  • BasicFileChooserUI.AcceptAllFileFilter.AcceptAllFileFilter()


acceptChanges

acceptChanges o7planning.org
  • CachedRowSet.acceptChanges(Connection)
  • CachedRowSet.acceptChanges()


acceptDrag

acceptDrag o7planning.org
  • DropTargetContext.acceptDrag(int)
  • DropTargetDragEvent.acceptDrag(int)


acceptDrop

acceptDrop o7planning.org
  • DropTargetContext.acceptDrop(int)
  • DropTargetDropEvent.acceptDrop(int)


acceptEither

acceptEither o7planning.org
  • CompletableFuture.acceptEither(CompletionStage<? extends T>, Consumer<? super T>)
  • CompletionStage.acceptEither(CompletionStage<? extends T>, Consumer<? super T>)


acceptEitherAsync

acceptEitherAsync o7planning.org
  • CompletableFuture.acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>, Executor)
  • CompletableFuture.acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>)
  • CompletionStage.acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>, Executor)
  • CompletionStage.acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>)


ACCEPTING_JOBS

ACCEPTING_JOBS o7planning.org
  • PrinterIsAcceptingJobs.ACCEPTING_JOBS


acceptNode

acceptNode o7planning.org
  • LSParserFilter.acceptNode(Node)


AcceptPendingException

AcceptPendingException o7planning.org
  • AcceptPendingException.AcceptPendingException()


acceptSecContext

acceptSecContext o7planning.org
  • GSSContext.acceptSecContext(InputStream, OutputStream)
  • GSSContext.acceptSecContext(byte[], int, int)


acceptsURL

acceptsURL o7planning.org
  • Driver.acceptsURL(String)


access

access o7planning.org
  • ValueMember.access


ACCESS_EXTERNAL_DTD

ACCESS_EXTERNAL_DTD o7planning.org
  • XMLConstants.ACCESS_EXTERNAL_DTD


ACCESS_EXTERNAL_SCHEMA

ACCESS_EXTERNAL_SCHEMA o7planning.org
  • XMLConstants.ACCESS_EXTERNAL_SCHEMA


ACCESS_EXTERNAL_STYLESHEET

ACCESS_EXTERNAL_STYLESHEET o7planning.org
  • XMLConstants.ACCESS_EXTERNAL_STYLESHEET


AccessControlContext

AccessControlContext o7planning.org
  • AccessControlContext.AccessControlContext(AccessControlContext, DomainCombiner)
  • AccessControlContext.AccessControlContext(ProtectionDomain[])


AccessControlException

AccessControlException o7planning.org
  • AccessControlException.AccessControlException(String, Permission)
  • AccessControlException.AccessControlException(String)


AccessDeniedException

AccessDeniedException o7planning.org
  • AccessDeniedException.AccessDeniedException(String, String, String)
  • AccessDeniedException.AccessDeniedException(String)


AccessException

AccessException o7planning.org
  • AccessException.AccessException(String, Exception)
  • AccessException.AccessException(String)


ACCESSIBLE_ACTION_PROPERTY

ACCESSIBLE_ACTION_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_ACTION_PROPERTY


ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY

ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY


ACCESSIBLE_CARET_PROPERTY

ACCESSIBLE_CARET_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_CARET_PROPERTY


ACCESSIBLE_CHILD_PROPERTY

ACCESSIBLE_CHILD_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_CHILD_PROPERTY


ACCESSIBLE_COMPONENT_BOUNDS_CHANGED

ACCESSIBLE_COMPONENT_BOUNDS_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_COMPONENT_BOUNDS_CHANGED


ACCESSIBLE_DESCRIPTION_PROPERTY

ACCESSIBLE_DESCRIPTION_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY


ACCESSIBLE_HYPERTEXT_OFFSET

ACCESSIBLE_HYPERTEXT_OFFSET o7planning.org
  • AccessibleContext.ACCESSIBLE_HYPERTEXT_OFFSET


ACCESSIBLE_INVALIDATE_CHILDREN

ACCESSIBLE_INVALIDATE_CHILDREN o7planning.org
  • AccessibleContext.ACCESSIBLE_INVALIDATE_CHILDREN


ACCESSIBLE_NAME_PROPERTY

ACCESSIBLE_NAME_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_NAME_PROPERTY


ACCESSIBLE_SELECTION_PROPERTY

ACCESSIBLE_SELECTION_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY


ACCESSIBLE_STATE_PROPERTY

ACCESSIBLE_STATE_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_STATE_PROPERTY


ACCESSIBLE_TABLE_CAPTION_CHANGED

ACCESSIBLE_TABLE_CAPTION_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_CAPTION_CHANGED


ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED

ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED


ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED

ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED


ACCESSIBLE_TABLE_MODEL_CHANGED

ACCESSIBLE_TABLE_MODEL_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_MODEL_CHANGED


ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED

ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED


ACCESSIBLE_TABLE_ROW_HEADER_CHANGED

ACCESSIBLE_TABLE_ROW_HEADER_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_ROW_HEADER_CHANGED


ACCESSIBLE_TABLE_SUMMARY_CHANGED

ACCESSIBLE_TABLE_SUMMARY_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TABLE_SUMMARY_CHANGED


ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED

ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED o7planning.org
  • AccessibleContext.ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED


ACCESSIBLE_TEXT_PROPERTY

ACCESSIBLE_TEXT_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_TEXT_PROPERTY


ACCESSIBLE_VALUE_PROPERTY

ACCESSIBLE_VALUE_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_VALUE_PROPERTY


ACCESSIBLE_VISIBLE_DATA_PROPERTY

ACCESSIBLE_VISIBLE_DATA_PROPERTY o7planning.org
  • AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY


AccessibleAbstractButton

AccessibleAbstractButton o7planning.org
  • AbstractButton.AccessibleAbstractButton.AccessibleAbstractButton()


AccessibleApplet

AccessibleApplet o7planning.org
  • Applet.AccessibleApplet.AccessibleApplet()


AccessibleAttributeSequence

AccessibleAttributeSequence o7planning.org
  • AccessibleAttributeSequence.AccessibleAttributeSequence(int, int, AttributeSet)


AccessibleAWTButton

AccessibleAWTButton o7planning.org
  • Button.AccessibleAWTButton.AccessibleAWTButton()


AccessibleAWTCanvas

AccessibleAWTCanvas o7planning.org
  • Canvas.AccessibleAWTCanvas.AccessibleAWTCanvas()


AccessibleAWTCheckbox

AccessibleAWTCheckbox o7planning.org
  • Checkbox.AccessibleAWTCheckbox.AccessibleAWTCheckbox()


AccessibleAWTCheckboxMenuItem

AccessibleAWTCheckboxMenuItem o7planning.org
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.AccessibleAWTCheckboxMenuItem()


AccessibleAWTChoice

AccessibleAWTChoice o7planning.org
  • Choice.AccessibleAWTChoice.AccessibleAWTChoice()


AccessibleAWTComponent

AccessibleAWTComponent o7planning.org
  • Component.AccessibleAWTComponent.AccessibleAWTComponent()


accessibleAWTComponentHandler

accessibleAWTComponentHandler o7planning.org
  • Component.AccessibleAWTComponent.accessibleAWTComponentHandler


AccessibleAWTComponentHandler

AccessibleAWTComponentHandler o7planning.org
  • Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.AccessibleAWTComponentHandler()


AccessibleAWTContainer

AccessibleAWTContainer o7planning.org
  • Container.AccessibleAWTContainer.AccessibleAWTContainer()


AccessibleAWTDialog

AccessibleAWTDialog o7planning.org
  • Dialog.AccessibleAWTDialog.AccessibleAWTDialog()


accessibleAWTFocusHandler

accessibleAWTFocusHandler o7planning.org
  • Component.AccessibleAWTComponent.accessibleAWTFocusHandler


AccessibleAWTFocusHandler

AccessibleAWTFocusHandler o7planning.org
  • Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.AccessibleAWTFocusHandler()


AccessibleAWTFrame

AccessibleAWTFrame o7planning.org
  • Frame.AccessibleAWTFrame.AccessibleAWTFrame()


AccessibleAWTLabel

AccessibleAWTLabel o7planning.org
  • Label.AccessibleAWTLabel.AccessibleAWTLabel()


AccessibleAWTList

AccessibleAWTList o7planning.org
  • List.AccessibleAWTList.AccessibleAWTList()


AccessibleAWTListChild

AccessibleAWTListChild o7planning.org
  • List.AccessibleAWTList.AccessibleAWTListChild.AccessibleAWTListChild(List, int)


AccessibleAWTMenu

AccessibleAWTMenu o7planning.org
  • Menu.AccessibleAWTMenu.AccessibleAWTMenu()


AccessibleAWTMenuBar

AccessibleAWTMenuBar o7planning.org
  • MenuBar.AccessibleAWTMenuBar.AccessibleAWTMenuBar()


AccessibleAWTMenuComponent

AccessibleAWTMenuComponent o7planning.org
  • MenuComponent.AccessibleAWTMenuComponent.AccessibleAWTMenuComponent()


AccessibleAWTMenuItem

AccessibleAWTMenuItem o7planning.org
  • MenuItem.AccessibleAWTMenuItem.AccessibleAWTMenuItem()


AccessibleAWTPanel

AccessibleAWTPanel o7planning.org
  • Panel.AccessibleAWTPanel.AccessibleAWTPanel()


AccessibleAWTPopupMenu

AccessibleAWTPopupMenu o7planning.org
  • PopupMenu.AccessibleAWTPopupMenu.AccessibleAWTPopupMenu()


AccessibleAWTScrollBar

AccessibleAWTScrollBar o7planning.org
  • Scrollbar.AccessibleAWTScrollBar.AccessibleAWTScrollBar()


AccessibleAWTScrollPane

AccessibleAWTScrollPane o7planning.org
  • ScrollPane.AccessibleAWTScrollPane.AccessibleAWTScrollPane()


AccessibleAWTTextArea

AccessibleAWTTextArea o7planning.org
  • TextArea.AccessibleAWTTextArea.AccessibleAWTTextArea()


AccessibleAWTTextComponent

AccessibleAWTTextComponent o7planning.org
  • TextComponent.AccessibleAWTTextComponent.AccessibleAWTTextComponent()


AccessibleAWTTextField

AccessibleAWTTextField o7planning.org
  • TextField.AccessibleAWTTextField.AccessibleAWTTextField()


AccessibleAWTWindow

AccessibleAWTWindow o7planning.org
  • Window.AccessibleAWTWindow.AccessibleAWTWindow()


AccessibleBox

AccessibleBox o7planning.org
  • Box.AccessibleBox.AccessibleBox()


AccessibleBoxFiller

AccessibleBoxFiller o7planning.org
  • Box.Filler.AccessibleBoxFiller.AccessibleBoxFiller()


AccessibleBundle

AccessibleBundle o7planning.org
  • AccessibleBundle.AccessibleBundle()


AccessibleCellRendererPane

AccessibleCellRendererPane o7planning.org
  • CellRendererPane.AccessibleCellRendererPane.AccessibleCellRendererPane()


accessibleContainerHandler

accessibleContainerHandler o7planning.org
  • Container.AccessibleAWTContainer.accessibleContainerHandler


AccessibleContainerHandler

AccessibleContainerHandler o7planning.org
  • Container.AccessibleAWTContainer.AccessibleContainerHandler.AccessibleContainerHandler()
  • JComponent.AccessibleJComponent.AccessibleContainerHandler.AccessibleContainerHandler()


accessibleContext

accessibleContext o7planning.org
  • CellRendererPane.accessibleContext
  • JApplet.accessibleContext
  • JColorChooser.accessibleContext
  • JDialog.accessibleContext
  • JFileChooser.accessibleContext
  • JFrame.accessibleContext
  • JWindow.accessibleContext
  • ProgressMonitor.accessibleContext


AccessibleContext

AccessibleContext o7planning.org
  • AccessibleContext.AccessibleContext()


accessibleDescription

accessibleDescription o7planning.org
  • AccessibleContext.accessibleDescription


accessibleFocusHandler

accessibleFocusHandler o7planning.org
  • JComponent.AccessibleJComponent.accessibleFocusHandler


AccessibleFocusHandler

AccessibleFocusHandler o7planning.org
  • JComponent.AccessibleJComponent.AccessibleFocusHandler.AccessibleFocusHandler()


AccessibleHyperlink

AccessibleHyperlink o7planning.org
  • AccessibleHyperlink.AccessibleHyperlink()


AccessibleImageIcon

AccessibleImageIcon o7planning.org
  • ImageIcon.AccessibleImageIcon.AccessibleImageIcon()


AccessibleJApplet

AccessibleJApplet o7planning.org
  • JApplet.AccessibleJApplet.AccessibleJApplet()


AccessibleJButton

AccessibleJButton o7planning.org
  • JButton.AccessibleJButton.AccessibleJButton()


AccessibleJCheckBox

AccessibleJCheckBox o7planning.org
  • JCheckBox.AccessibleJCheckBox.AccessibleJCheckBox()


AccessibleJCheckBoxMenuItem

AccessibleJCheckBoxMenuItem o7planning.org
  • JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem.AccessibleJCheckBoxMenuItem()


AccessibleJColorChooser

AccessibleJColorChooser o7planning.org
  • JColorChooser.AccessibleJColorChooser.AccessibleJColorChooser()


AccessibleJComboBox

AccessibleJComboBox o7planning.org
  • JComboBox.AccessibleJComboBox.AccessibleJComboBox()


AccessibleJComponent

AccessibleJComponent o7planning.org
  • JComponent.AccessibleJComponent.AccessibleJComponent()


AccessibleJDesktopIcon

AccessibleJDesktopIcon o7planning.org
  • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.AccessibleJDesktopIcon()


AccessibleJDesktopPane

AccessibleJDesktopPane o7planning.org
  • JDesktopPane.AccessibleJDesktopPane.AccessibleJDesktopPane()


AccessibleJDialog

AccessibleJDialog o7planning.org
  • JDialog.AccessibleJDialog.AccessibleJDialog()


AccessibleJEditorPane

AccessibleJEditorPane o7planning.org
  • JEditorPane.AccessibleJEditorPane.AccessibleJEditorPane()


AccessibleJEditorPaneHTML

AccessibleJEditorPaneHTML o7planning.org
  • JEditorPane.AccessibleJEditorPaneHTML.AccessibleJEditorPaneHTML()


AccessibleJFileChooser

AccessibleJFileChooser o7planning.org
  • JFileChooser.AccessibleJFileChooser.AccessibleJFileChooser()


AccessibleJFrame

AccessibleJFrame o7planning.org
  • JFrame.AccessibleJFrame.AccessibleJFrame()


AccessibleJInternalFrame

AccessibleJInternalFrame o7planning.org
  • JInternalFrame.AccessibleJInternalFrame.AccessibleJInternalFrame()


AccessibleJLabel

AccessibleJLabel o7planning.org
  • JLabel.AccessibleJLabel.AccessibleJLabel()


AccessibleJLayeredPane

AccessibleJLayeredPane o7planning.org
  • JLayeredPane.AccessibleJLayeredPane.AccessibleJLayeredPane()


AccessibleJList

AccessibleJList o7planning.org
  • JList.AccessibleJList.AccessibleJList()


AccessibleJListChild

AccessibleJListChild o7planning.org
  • JList.AccessibleJList.AccessibleJListChild.AccessibleJListChild(JList<E>, int)


AccessibleJMenu

AccessibleJMenu o7planning.org
  • JMenu.AccessibleJMenu.AccessibleJMenu()


AccessibleJMenuBar

AccessibleJMenuBar o7planning.org
  • JMenuBar.AccessibleJMenuBar.AccessibleJMenuBar()


AccessibleJOptionPane

AccessibleJOptionPane o7planning.org
  • JOptionPane.AccessibleJOptionPane.AccessibleJOptionPane()


AccessibleJPanel

AccessibleJPanel o7planning.org
  • JPanel.AccessibleJPanel.AccessibleJPanel()


AccessibleJPasswordField

AccessibleJPasswordField o7planning.org
  • JPasswordField.AccessibleJPasswordField.AccessibleJPasswordField()


AccessibleJPopupMenu

AccessibleJPopupMenu o7planning.org
  • JPopupMenu.AccessibleJPopupMenu.AccessibleJPopupMenu()


AccessibleJProgressBar

AccessibleJProgressBar o7planning.org
  • JProgressBar.AccessibleJProgressBar.AccessibleJProgressBar()


AccessibleJRadioButton

AccessibleJRadioButton o7planning.org
  • JRadioButton.AccessibleJRadioButton.AccessibleJRadioButton()


AccessibleJRadioButtonMenuItem

AccessibleJRadioButtonMenuItem o7planning.org
  • JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem.AccessibleJRadioButtonMenuItem()


AccessibleJRootPane

AccessibleJRootPane o7planning.org
  • JRootPane.AccessibleJRootPane.AccessibleJRootPane()


AccessibleJScrollBar

AccessibleJScrollBar o7planning.org
  • JScrollBar.AccessibleJScrollBar.AccessibleJScrollBar()


AccessibleJScrollPane

AccessibleJScrollPane o7planning.org
  • JScrollPane.AccessibleJScrollPane.AccessibleJScrollPane()


AccessibleJSeparator

AccessibleJSeparator o7planning.org
  • JSeparator.AccessibleJSeparator.AccessibleJSeparator()


AccessibleJSlider

AccessibleJSlider o7planning.org
  • JSlider.AccessibleJSlider.AccessibleJSlider()


AccessibleJSpinner

AccessibleJSpinner o7planning.org
  • JSpinner.AccessibleJSpinner.AccessibleJSpinner()


AccessibleJSplitPane

AccessibleJSplitPane o7planning.org
  • JSplitPane.AccessibleJSplitPane.AccessibleJSplitPane()


AccessibleJTabbedPane

AccessibleJTabbedPane o7planning.org
  • JTabbedPane.AccessibleJTabbedPane.AccessibleJTabbedPane()


AccessibleJTable

AccessibleJTable o7planning.org
  • JTable.AccessibleJTable.AccessibleJTable()


AccessibleJTableCell

AccessibleJTableCell o7planning.org
  • JTable.AccessibleJTable.AccessibleJTableCell.AccessibleJTableCell(JTable, int, int, int)


AccessibleJTableHeader

AccessibleJTableHeader o7planning.org
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeader()


AccessibleJTableHeaderEntry

AccessibleJTableHeaderEntry o7planning.org
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.AccessibleJTableHeaderEntry(int, JTableHeader, JTable)


AccessibleJTableModelChange

AccessibleJTableModelChange o7planning.org
  • JTable.AccessibleJTable.AccessibleJTableModelChange.AccessibleJTableModelChange(int, int, int, int, int)


AccessibleJTextArea

AccessibleJTextArea o7planning.org
  • JTextArea.AccessibleJTextArea.AccessibleJTextArea()


AccessibleJTextComponent

AccessibleJTextComponent o7planning.org
  • JTextComponent.AccessibleJTextComponent.AccessibleJTextComponent()


AccessibleJTextField

AccessibleJTextField o7planning.org
  • JTextField.AccessibleJTextField.AccessibleJTextField()


AccessibleJToggleButton

AccessibleJToggleButton o7planning.org
  • JToggleButton.AccessibleJToggleButton.AccessibleJToggleButton()


AccessibleJToolBar

AccessibleJToolBar o7planning.org
  • JToolBar.AccessibleJToolBar.AccessibleJToolBar()


AccessibleJToolTip

AccessibleJToolTip o7planning.org
  • JToolTip.AccessibleJToolTip.AccessibleJToolTip()


AccessibleJTree

AccessibleJTree o7planning.org
  • JTree.AccessibleJTree.AccessibleJTree()


AccessibleJTreeNode

AccessibleJTreeNode o7planning.org
  • JTree.AccessibleJTree.AccessibleJTreeNode.AccessibleJTreeNode(JTree, TreePath, Accessible)


AccessibleJViewport

AccessibleJViewport o7planning.org
  • JViewport.AccessibleJViewport.AccessibleJViewport()


AccessibleJWindow

AccessibleJWindow o7planning.org
  • JWindow.AccessibleJWindow.AccessibleJWindow()


accessibleName

accessibleName o7planning.org
  • AccessibleContext.accessibleName


AccessibleObject

AccessibleObject o7planning.org
  • AccessibleObject.AccessibleObject()


accessibleParent

accessibleParent o7planning.org
  • AccessibleContext.accessibleParent


AccessibleProgressMonitor

AccessibleProgressMonitor o7planning.org
  • ProgressMonitor.AccessibleProgressMonitor.AccessibleProgressMonitor()


AccessibleRelation

AccessibleRelation o7planning.org
  • AccessibleRelation.AccessibleRelation(String, Object[])
  • AccessibleRelation.AccessibleRelation(String, Object)
  • AccessibleRelation.AccessibleRelation(String)


AccessibleRelationSet

AccessibleRelationSet o7planning.org
  • AccessibleRelationSet.AccessibleRelationSet(AccessibleRelation[])
  • AccessibleRelationSet.AccessibleRelationSet()


AccessibleResourceBundle

AccessibleResourceBundle o7planning.org
  • AccessibleResourceBundle.AccessibleResourceBundle()


AccessibleRole

AccessibleRole o7planning.org
  • AccessibleRole.AccessibleRole(String)


AccessibleState

AccessibleState o7planning.org
  • AccessibleState.AccessibleState(String)


AccessibleStateSet

AccessibleStateSet o7planning.org
  • AccessibleStateSet.AccessibleStateSet(AccessibleState[])
  • AccessibleStateSet.AccessibleStateSet()


AccessibleTextSequence

AccessibleTextSequence o7planning.org
  • AccessibleTextSequence.AccessibleTextSequence(int, int, String)


ACCESSORY_CHANGED_PROPERTY

ACCESSORY_CHANGED_PROPERTY o7planning.org
  • JFileChooser.ACCESSORY_CHANGED_PROPERTY


AccountException

AccountException o7planning.org
  • AccountException.AccountException(String)
  • AccountException.AccountException()


AccountExpiredException

AccountExpiredException o7planning.org
  • AccountExpiredException.AccountExpiredException(String)
  • AccountExpiredException.AccountExpiredException()


AccountLockedException

AccountLockedException o7planning.org
  • AccountLockedException.AccountLockedException(String)
  • AccountLockedException.AccountLockedException()


AccountNotFoundException

AccountNotFoundException o7planning.org
  • AccountNotFoundException.AccountNotFoundException(String)
  • AccountNotFoundException.AccountNotFoundException()


accumulate

accumulate o7planning.org
  • DoubleAccumulator.accumulate(double)
  • LongAccumulator.accumulate(long)


accumulateAndGet

accumulateAndGet o7planning.org
  • AtomicInteger.accumulateAndGet(int, IntBinaryOperator)
  • AtomicIntegerArray.accumulateAndGet(int, int, IntBinaryOperator)
  • AtomicIntegerFieldUpdater.accumulateAndGet(T, int, IntBinaryOperator)
  • AtomicLong.accumulateAndGet(long, LongBinaryOperator)
  • AtomicLongArray.accumulateAndGet(int, long, LongBinaryOperator)
  • AtomicLongFieldUpdater.accumulateAndGet(T, long, LongBinaryOperator)
  • AtomicReference.accumulateAndGet(V, BinaryOperator<V>)
  • AtomicReferenceArray.accumulateAndGet(int, E, BinaryOperator<E>)
  • AtomicReferenceFieldUpdater.accumulateAndGet(T, V, BinaryOperator<V>)


accumulator

accumulator o7planning.org
  • Collector.accumulator()


AclNotFoundException

AclNotFoundException o7planning.org
  • AclNotFoundException.AclNotFoundException()


acos

acos o7planning.org
  • Math.acos(double)
  • StrictMath.acos(double)


acquire

acquire o7planning.org
  • AbstractQueuedLongSynchronizer.acquire(long)
  • AbstractQueuedSynchronizer.acquire(int)
  • Semaphore.acquire(int)
  • Semaphore.acquire()


acquiredBy

acquiredBy o7planning.org
  • FileLock.acquiredBy()


acquireInterruptibly

acquireInterruptibly o7planning.org
  • AbstractQueuedLongSynchronizer.acquireInterruptibly(long)
  • AbstractQueuedSynchronizer.acquireInterruptibly(int)


acquireShared

acquireShared o7planning.org
  • AbstractQueuedLongSynchronizer.acquireShared(long)
  • AbstractQueuedSynchronizer.acquireShared(int)


acquireSharedInterruptibly

acquireSharedInterruptibly o7planning.org
  • AbstractQueuedLongSynchronizer.acquireSharedInterruptibly(long)
  • AbstractQueuedSynchronizer.acquireSharedInterruptibly(int)


acquireUninterruptibly

acquireUninterruptibly o7planning.org
  • Semaphore.acquireUninterruptibly(int)
  • Semaphore.acquireUninterruptibly()


action

action o7planning.org
  • Component.action(Event, Object)


ACTION

ACTION o7planning.org
  • HTML.Attribute.ACTION
  • MBeanOperationInfo.ACTION


ACTION_APPEND_AS_CHILDREN

ACTION_APPEND_AS_CHILDREN o7planning.org
  • LSParser.ACTION_APPEND_AS_CHILDREN


ACTION_COMMAND_KEY

ACTION_COMMAND_KEY o7planning.org
  • Action.ACTION_COMMAND_KEY


ACTION_COPY

ACTION_COPY o7planning.org
  • DnDConstants.ACTION_COPY


ACTION_COPY_OR_MOVE

ACTION_COPY_OR_MOVE o7planning.org
  • DnDConstants.ACTION_COPY_OR_MOVE


ACTION_EVENT

ACTION_EVENT o7planning.org
  • Event.ACTION_EVENT


ACTION_EVENT_MASK

ACTION_EVENT_MASK o7planning.org
  • AWTEvent.ACTION_EVENT_MASK


ACTION_FIRST

ACTION_FIRST o7planning.org
  • ActionEvent.ACTION_FIRST


ACTION_INFO

ACTION_INFO o7planning.org
  • MBeanOperationInfo.ACTION_INFO


ACTION_INSERT_AFTER

ACTION_INSERT_AFTER o7planning.org
  • LSParser.ACTION_INSERT_AFTER


ACTION_INSERT_BEFORE

ACTION_INSERT_BEFORE o7planning.org
  • LSParser.ACTION_INSERT_BEFORE


ACTION_LAST

ACTION_LAST o7planning.org
  • ActionEvent.ACTION_LAST


ACTION_LINK

ACTION_LINK o7planning.org
  • DnDConstants.ACTION_LINK


ACTION_MOVE

ACTION_MOVE o7planning.org
  • DnDConstants.ACTION_MOVE


ACTION_NONE

ACTION_NONE o7planning.org
  • DnDConstants.ACTION_NONE


ACTION_PERFORMED

ACTION_PERFORMED o7planning.org
  • ActionEvent.ACTION_PERFORMED


ACTION_REFERENCE

ACTION_REFERENCE o7planning.org
  • DnDConstants.ACTION_REFERENCE


ACTION_REPLACE

ACTION_REPLACE o7planning.org
  • LSParser.ACTION_REPLACE


ACTION_REPLACE_CHILDREN

ACTION_REPLACE_CHILDREN o7planning.org
  • LSParser.ACTION_REPLACE_CHILDREN


actionCommand

actionCommand o7planning.org
  • DefaultButtonModel.actionCommand
  • JComboBox.actionCommand


ActionEvent

ActionEvent o7planning.org
  • ActionEvent.ActionEvent(Object, int, String, long, int)
  • ActionEvent.ActionEvent(Object, int, String, int)
  • ActionEvent.ActionEvent(Object, int, String)


actionListener

actionListener o7planning.org
  • AbstractButton.actionListener


ActionMap

ActionMap o7planning.org
  • ActionMap.ActionMap()


ActionMapUIResource

ActionMapUIResource o7planning.org
  • ActionMapUIResource.ActionMapUIResource()


actionName

actionName o7planning.org
  • JTextComponent.KeyBinding.actionName


actionPerformed

actionPerformed o7planning.org
  • AWTEventMulticaster.actionPerformed(ActionEvent)
  • ActionListener.actionPerformed(ActionEvent)
  • BasicDesktopPaneUI.CloseAction.actionPerformed(ActionEvent)
  • BasicDesktopPaneUI.MaximizeAction.actionPerformed(ActionEvent)
  • BasicDesktopPaneUI.MinimizeAction.actionPerformed(ActionEvent)
  • BasicDesktopPaneUI.NavigateAction.actionPerformed(ActionEvent)
  • BasicDesktopPaneUI.OpenAction.actionPerformed(ActionEvent)
  • BasicFileChooserUI.ApproveSelectionAction.actionPerformed(ActionEvent)
  • BasicFileChooserUI.CancelSelectionAction.actionPerformed(ActionEvent)
  • BasicFileChooserUI.ChangeToParentDirectoryAction.actionPerformed(ActionEvent)
  • BasicFileChooserUI.GoHomeAction.actionPerformed(ActionEvent)
  • BasicFileChooserUI.NewFolderAction.actionPerformed(ActionEvent)
  • BasicFileChooserUI.UpdateAction.actionPerformed(ActionEvent)
  • BasicInternalFrameTitlePane.CloseAction.actionPerformed(ActionEvent)
  • BasicInternalFrameTitlePane.IconifyAction.actionPerformed(ActionEvent)
  • BasicInternalFrameTitlePane.MaximizeAction.actionPerformed(ActionEvent)
  • BasicInternalFrameTitlePane.MoveAction.actionPerformed(ActionEvent)
  • BasicInternalFrameTitlePane.RestoreAction.actionPerformed(ActionEvent)
  • BasicInternalFrameTitlePane.SizeAction.actionPerformed(ActionEvent)
  • BasicOptionPaneUI.ButtonActionListener.actionPerformed(ActionEvent)
  • BasicScrollBarUI.ScrollListener.actionPerformed(ActionEvent)
  • BasicSliderUI.ActionScroller.actionPerformed(ActionEvent)
  • BasicSliderUI.ScrollListener.actionPerformed(ActionEvent)
  • BasicSplitPaneUI.KeyboardDownRightHandler.actionPerformed(ActionEvent)
  • BasicSplitPaneUI.KeyboardEndHandler.actionPerformed(ActionEvent)
  • BasicSplitPaneUI.KeyboardHomeHandler.actionPerformed(ActionEvent)
  • BasicSplitPaneUI.KeyboardResizeToggleHandler.actionPerformed(ActionEvent)
  • BasicSplitPaneUI.KeyboardUpLeftHandler.actionPerformed(ActionEvent)
  • BasicTreeUI.ComponentHandler.actionPerformed(ActionEvent)
  • BasicTreeUI.TreeCancelEditingAction.actionPerformed(ActionEvent)
  • BasicTreeUI.TreeHomeAction.actionPerformed(ActionEvent)
  • BasicTreeUI.TreeIncrementAction.actionPerformed(ActionEvent)
  • BasicTreeUI.TreePageAction.actionPerformed(ActionEvent)
  • BasicTreeUI.TreeToggleAction.actionPerformed(ActionEvent)
  • BasicTreeUI.TreeTraverseAction.actionPerformed(ActionEvent)
  • DefaultCellEditor.EditorDelegate.actionPerformed(ActionEvent)
  • DefaultEditorKit.BeepAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.CopyAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.CutAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.DefaultKeyTypedAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.InsertBreakAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.InsertContentAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.InsertTabAction.actionPerformed(ActionEvent)
  • DefaultEditorKit.PasteAction.actionPerformed(ActionEvent)
  • DefaultTreeCellEditor.actionPerformed(ActionEvent)
  • DropTarget.DropTargetAutoScroller.actionPerformed(ActionEvent)
  • FormView.actionPerformed(ActionEvent)
  • HTMLEditorKit.InsertHTMLTextAction.actionPerformed(ActionEvent)
  • JComboBox.actionPerformed(ActionEvent)
  • List.AccessibleAWTList.actionPerformed(ActionEvent)
  • MetalFileChooserUI.DirectoryComboBoxAction.actionPerformed(ActionEvent)
  • StyledEditorKit.AlignmentAction.actionPerformed(ActionEvent)
  • StyledEditorKit.BoldAction.actionPerformed(ActionEvent)
  • StyledEditorKit.FontFamilyAction.actionPerformed(ActionEvent)
  • StyledEditorKit.FontSizeAction.actionPerformed(ActionEvent)
  • StyledEditorKit.ForegroundAction.actionPerformed(ActionEvent)
  • StyledEditorKit.ItalicAction.actionPerformed(ActionEvent)
  • StyledEditorKit.UnderlineAction.actionPerformed(ActionEvent)
  • ToolTipManager.insideTimerAction.actionPerformed(ActionEvent)
  • ToolTipManager.outsideTimerAction.actionPerformed(ActionEvent)
  • ToolTipManager.stillInsideTimerAction.actionPerformed(ActionEvent)


actionPropertyChanged

actionPropertyChanged o7planning.org
  • AbstractButton.actionPropertyChanged(Action, String)
  • JComboBox.actionPropertyChanged(Action, String)
  • JMenuItem.actionPropertyChanged(Action, String)
  • JTextField.actionPropertyChanged(Action, String)


ActionScroller

ActionScroller o7planning.org
  • BasicSliderUI.ActionScroller.ActionScroller(JSlider, int, boolean)


Activatable

Activatable o7planning.org
  • Activatable.Activatable(ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory)
  • Activatable.Activatable(ActivationID, int)
  • Activatable.Activatable(String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory)
  • Activatable.Activatable(String, MarshalledObject<?>, boolean, int)


activate

activate o7planning.org
  • ActivationID.activate(boolean)
  • Activator.activate(ActivationID, boolean)
  • AppletInitializer.activate(Applet)
  • IIOMetadataController.activate(IIOMetadata)
  • IIOParamController.activate(IIOParam)
  • InputMethod.activate()
  • POAManagerOperations.activate()


activate_object

activate_object o7planning.org
  • POAOperations.activate_object(Servant)


activate_object_with_id

activate_object_with_id o7planning.org
  • POAOperations.activate_object_with_id(byte[], Servant)


activateController

activateController o7planning.org
  • IIOMetadata.activateController()
  • IIOParam.activateController()


ACTIVATED

ACTIVATED o7planning.org
  • HyperlinkEvent.EventType.ACTIVATED


ActivateFailedException

ActivateFailedException o7planning.org
  • ActivateFailedException.ActivateFailedException(String, Exception)
  • ActivateFailedException.ActivateFailedException(String)


activateFrame

activateFrame o7planning.org
  • BasicInternalFrameUI.activateFrame(JInternalFrame)
  • DefaultDesktopManager.activateFrame(JInternalFrame)
  • DesktopManager.activateFrame(JInternalFrame)


activateLink

activateLink o7planning.org
  • HTMLEditorKit.LinkController.activateLink(int, JEditorPane)


ActivationDataFlavor

ActivationDataFlavor o7planning.org
  • ActivationDataFlavor.ActivationDataFlavor(String, String)
  • ActivationDataFlavor.ActivationDataFlavor(Class, String)
  • ActivationDataFlavor.ActivationDataFlavor(Class, String, String)


ActivationDesc

ActivationDesc o7planning.org
  • ActivationDesc.ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>, boolean)
  • ActivationDesc.ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>)
  • ActivationDesc.ActivationDesc(String, String, MarshalledObject<?>, boolean)
  • ActivationDesc.ActivationDesc(String, String, MarshalledObject<?>)


ActivationException

ActivationException o7planning.org
  • ActivationException.ActivationException(String, Throwable)
  • ActivationException.ActivationException(String)
  • ActivationException.ActivationException()


ActivationGroup

ActivationGroup o7planning.org
  • ActivationGroup.ActivationGroup(ActivationGroupID)


ActivationGroup_Stub

ActivationGroup_Stub o7planning.org
  • ActivationGroup_Stub.ActivationGroup_Stub(RemoteRef)


ActivationGroupDesc

ActivationGroupDesc o7planning.org
  • ActivationGroupDesc.ActivationGroupDesc(String, String, MarshalledObject<?>, Properties, ActivationGroupDesc.CommandEnvironment)
  • ActivationGroupDesc.ActivationGroupDesc(Properties, ActivationGroupDesc.CommandEnvironment)


ActivationGroupID

ActivationGroupID o7planning.org
  • ActivationGroupID.ActivationGroupID(ActivationSystem)


ActivationID

ActivationID o7planning.org
  • ActivationID.ActivationID(Activator)


ACTIVATOR_ID

ACTIVATOR_ID o7planning.org
  • ObjID.ACTIVATOR_ID


ACTIVE

ACTIVE o7planning.org
  • State.ACTIVE


active

active o7planning.org
  • VoiceStatus.active


ACTIVE_CAPTION

ACTIVE_CAPTION o7planning.org
  • SystemColor.ACTIVE_CAPTION


ACTIVE_CAPTION_BORDER

ACTIVE_CAPTION_BORDER o7planning.org
  • SystemColor.ACTIVE_CAPTION_BORDER


ACTIVE_CAPTION_TEXT

ACTIVE_CAPTION_TEXT o7planning.org
  • SystemColor.ACTIVE_CAPTION_TEXT


ACTIVE_SENSING

ACTIVE_SENSING o7planning.org
  • ShortMessage.ACTIVE_SENSING


activeCaption

activeCaption o7planning.org
  • SystemColor.activeCaption


activeCaptionBorder

activeCaptionBorder o7planning.org
  • SystemColor.activeCaptionBorder


activeCaptionText

activeCaptionText o7planning.org
  • SystemColor.activeCaptionText


activeCount

activeCount o7planning.org
  • Thread.activeCount()
  • ThreadGroup.activeCount()


activeGroup

activeGroup o7planning.org
  • ActivationSystem.activeGroup(ActivationGroupID, ActivationInstantiator, long)


activeGroupCount

activeGroupCount o7planning.org
  • ThreadGroup.activeGroupCount()


activeObject

activeObject o7planning.org
  • ActivationGroup.activeObject(ActivationID, MarshalledObject<? extends Remote>)
  • ActivationGroup.activeObject(ActivationID, Remote)
  • ActivationMonitor.activeObject(ActivationID, MarshalledObject<? extends Remote>)


ACTIVITY_COMPLETED

ACTIVITY_COMPLETED o7planning.org
  • ACTIVITY_COMPLETED.ACTIVITY_COMPLETED(String, int, CompletionStatus)
  • ACTIVITY_COMPLETED.ACTIVITY_COMPLETED(int, CompletionStatus)
  • ACTIVITY_COMPLETED.ACTIVITY_COMPLETED(String)
  • ACTIVITY_COMPLETED.ACTIVITY_COMPLETED()


ACTIVITY_REQUIRED

ACTIVITY_REQUIRED o7planning.org
  • ACTIVITY_REQUIRED.ACTIVITY_REQUIRED(String, int, CompletionStatus)
  • ACTIVITY_REQUIRED.ACTIVITY_REQUIRED(int, CompletionStatus)
  • ACTIVITY_REQUIRED.ACTIVITY_REQUIRED(String)
  • ACTIVITY_REQUIRED.ACTIVITY_REQUIRED()


ActivityCompletedException

ActivityCompletedException o7planning.org
  • ActivityCompletedException.ActivityCompletedException(String, Throwable)
  • ActivityCompletedException.ActivityCompletedException(Throwable)
  • ActivityCompletedException.ActivityCompletedException(String)
  • ActivityCompletedException.ActivityCompletedException()


ActivityRequiredException

ActivityRequiredException o7planning.org
  • ActivityRequiredException.ActivityRequiredException(String, Throwable)
  • ActivityRequiredException.ActivityRequiredException(Throwable)
  • ActivityRequiredException.ActivityRequiredException(String)
  • ActivityRequiredException.ActivityRequiredException()


AD

AD o7planning.org
  • GregorianCalendar.AD


adapt

adapt o7planning.org
  • ForkJoinTask.adapt(Callable<? extends T>)
  • ForkJoinTask.adapt(Runnable, T)
  • ForkJoinTask.adapt(Runnable)


adapter_id

adapter_id o7planning.org
  • ServerRequestInfoOperations.adapter_id()


adapter_manager_state_changed

adapter_manager_state_changed o7planning.org
  • IORInterceptor_3_0Operations.adapter_manager_state_changed(int, short)


adapter_name

adapter_name o7planning.org
  • ObjectReferenceTemplate.adapter_name()
  • ServerRequestInfoOperations.adapter_name()


adapter_state_changed

adapter_state_changed o7planning.org
  • IORInterceptor_3_0Operations.adapter_state_changed(ObjectReferenceTemplate[], short)


adapter_template

adapter_template o7planning.org
  • IORInfoOperations.adapter_template()


AdapterAlreadyExists

AdapterAlreadyExists o7planning.org
  • AdapterAlreadyExists.AdapterAlreadyExists(String)
  • AdapterAlreadyExists.AdapterAlreadyExists()


AdapterAlreadyExistsHelper

AdapterAlreadyExistsHelper o7planning.org
  • AdapterAlreadyExistsHelper.AdapterAlreadyExistsHelper()


AdapterInactive

AdapterInactive o7planning.org
  • AdapterInactive.AdapterInactive(String)
  • AdapterInactive.AdapterInactive()


AdapterInactiveHelper

AdapterInactiveHelper o7planning.org
  • AdapterInactiveHelper.AdapterInactiveHelper()


AdapterManagerIdHelper

AdapterManagerIdHelper o7planning.org
  • AdapterManagerIdHelper.AdapterManagerIdHelper()


AdapterNameHelper

AdapterNameHelper o7planning.org
  • AdapterNameHelper.AdapterNameHelper()


AdapterNonExistent

AdapterNonExistent o7planning.org
  • AdapterNonExistent.AdapterNonExistent(String)
  • AdapterNonExistent.AdapterNonExistent()


AdapterNonExistentHelper

AdapterNonExistentHelper o7planning.org
  • AdapterNonExistentHelper.AdapterNonExistentHelper()


AdapterStateHelper

AdapterStateHelper o7planning.org
  • AdapterStateHelper.AdapterStateHelper()


add

add o7planning.org
  • AWTEventMulticaster.add(MouseWheelListener, MouseWheelListener)
  • AWTEventMulticaster.add(HierarchyBoundsListener, HierarchyBoundsListener)
  • AWTEventMulticaster.add(HierarchyListener, HierarchyListener)
  • AWTEventMulticaster.add(InputMethodListener, InputMethodListener)
  • AWTEventMulticaster.add(TextListener, TextListener)
  • AWTEventMulticaster.add(AdjustmentListener, AdjustmentListener)
  • AWTEventMulticaster.add(ItemListener, ItemListener)
  • AWTEventMulticaster.add(ActionListener, ActionListener)
  • AWTEventMulticaster.add(WindowFocusListener, WindowFocusListener)
  • AWTEventMulticaster.add(WindowStateListener, WindowStateListener)
  • AWTEventMulticaster.add(WindowListener, WindowListener)
  • AWTEventMulticaster.add(MouseMotionListener, MouseMotionListener)
  • AWTEventMulticaster.add(MouseListener, MouseListener)
  • AWTEventMulticaster.add(KeyListener, KeyListener)
  • AWTEventMulticaster.add(FocusListener, FocusListener)
  • AWTEventMulticaster.add(ContainerListener, ContainerListener)
  • AWTEventMulticaster.add(ComponentListener, ComponentListener)
  • AbstractCollection.add(E)
  • AbstractList.add(int, E)
  • AbstractList.add(E)
  • AbstractQueue.add(E)
  • AbstractSequentialList.add(int, E)
  • AccessibleRelationSet.add(AccessibleRelation)
  • AccessibleStateSet.add(AccessibleState)
  • Area.add(Area)
  • ArrayBlockingQueue.add(E)
  • ArrayDeque.add(E)
  • ArrayList.add(int, E)
  • ArrayList.add(E)
  • Attribute.add(int, Object)
  • Attribute.add(Object)
  • AttributeList.add(int, Object)
  • AttributeList.add(Object)
  • AttributeList.add(int, Attribute)
  • AttributeList.add(Attribute)
  • AttributeSet.add(Attribute)
  • BasicAttribute.add(int, Object)
  • BasicAttribute.add(Object)
  • BeanContextSupport.add(Object)
  • BigDecimal.add(BigDecimal, MathContext)
  • BigDecimal.add(BigDecimal)
  • BigInteger.add(BigInteger)
  • BlockingDeque.add(E)
  • BlockingQueue.add(E)
  • ButtonGroup.add(AbstractButton)
  • Calendar.add(int, int)
  • Choice.add(String)
  • Collection.add(E)
  • Component.add(PopupMenu)
  • CompositeName.add(int, String)
  • CompositeName.add(String)
  • CompoundName.add(int, String)
  • CompoundName.add(String)
  • ConcurrentHashMap.KeySetView.add(K)
  • ConcurrentLinkedDeque.add(E)
  • ConcurrentLinkedQueue.add(E)
  • ConcurrentSkipListSet.add(E)
  • Container.add(Component, Object, int)
  • Container.add(Component, Object)
  • Container.add(Component, int)
  • Container.add(String, Component)
  • Container.add(Component)
  • ContextList.add(String)
  • CookieStore.add(URI, HttpCookie)
  • CopyOnWriteArrayList.add(int, E)
  • CopyOnWriteArrayList.add(E)
  • CopyOnWriteArraySet.add(E)
  • DefaultListModel.add(int, E)
  • DefaultMutableTreeNode.add(MutableTreeNode)
  • DelayQueue.add(E)
  • Deque.add(E)
  • DocAttributeSet.add(Attribute)
  • DoubleAdder.add(double)
  • DoubleStream.Builder.add(double)
  • Duration.add(Duration)
  • EventListenerList.add(Class<T>, T)
  • ExceptionList.add(TypeCode)
  • GSSCredential.add(GSSName, int, int, Oid, int)
  • GregorianCalendar.add(int, int)
  • HashAttributeSet.add(Attribute)
  • HashSet.add(E)
  • IntStream.Builder.add(int)
  • JMenu.add(Action)
  • JMenu.add(String)
  • JMenu.add(Component, int)
  • JMenu.add(Component)
  • JMenu.add(JMenuItem)
  • JMenuBar.add(JMenu)
  • JPopupMenu.add(Action)
  • JPopupMenu.add(String)
  • JPopupMenu.add(JMenuItem)
  • JTabbedPane.add(Component, Object, int)
  • JTabbedPane.add(Component, Object)
  • JTabbedPane.add(Component, int)
  • JTabbedPane.add(String, Component)
  • JTabbedPane.add(Component)
  • JToolBar.add(Action)
  • JobStateReasons.add(JobStateReason)
  • LdapName.add(int, Rdn)
  • LdapName.add(int, String)
  • LdapName.add(Rdn)
  • LdapName.add(String)
  • LinkedBlockingDeque.add(E)
  • LinkedList.add(int, E)
  • LinkedList.add(E)
  • LinkedTransferQueue.add(E)
  • List.add(int, E)
  • List.add(E)
  • List.add(String, int)
  • List.add(String)
  • ListIterator.add(E)
  • LongAdder.add(long)
  • LongStream.Builder.add(long)
  • Menu.add(String)
  • Menu.add(MenuItem)
  • MenuBar.add(Menu)
  • NVList.add(int)
  • Name.add(int, String)
  • Name.add(String)
  • ParameterBlock.add(double)
  • ParameterBlock.add(float)
  • ParameterBlock.add(long)
  • ParameterBlock.add(int)
  • ParameterBlock.add(short)
  • ParameterBlock.add(char)
  • ParameterBlock.add(byte)
  • ParameterBlock.add(Object)
  • PermissionCollection.add(Permission)
  • Permissions.add(Permission)
  • PrintJobAttributeSet.add(Attribute)
  • PrintRequestAttributeSet.add(Attribute)
  • PrintServiceAttributeSet.add(Attribute)
  • PriorityBlockingQueue.add(E)
  • PriorityQueue.add(E)
  • Queue.add(E)
  • Rectangle.add(Rectangle)
  • Rectangle.add(Point)
  • Rectangle.add(int, int)
  • Rectangle2D.add(Rectangle2D)
  • Rectangle2D.add(Point2D)
  • Rectangle2D.add(double, double)
  • Reference.add(int, RefAddr)
  • Reference.add(RefAddr)
  • RenderingHints.add(RenderingHints)
  • RoleList.add(int, Object)
  • RoleList.add(Object)
  • RoleList.add(int, Role)
  • RoleList.add(Role)
  • RoleUnresolvedList.add(int, Object)
  • RoleUnresolvedList.add(Object)
  • RoleUnresolvedList.add(int, RoleUnresolved)
  • RoleUnresolvedList.add(RoleUnresolved)
  • Set.add(E)
  • Stream.Builder.add(T)
  • StringJoiner.add(CharSequence)
  • SystemTray.add(TrayIcon)
  • Track.add(MidiEvent)
  • TreeSet.add(E)
  • Vector.add(int, E)
  • Vector.add(E)
  • XMLEventConsumer.add(XMLEvent)
  • XMLEventWriter.add(XMLEventReader)
  • XMLEventWriter.add(XMLEvent)
  • XMLGregorianCalendar.add(Duration)


ADD_ATTRIBUTE

ADD_ATTRIBUTE o7planning.org
  • DirContext.ADD_ATTRIBUTE


add_client_request_interceptor

add_client_request_interceptor o7planning.org
  • ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor)


ADD_FILE

ADD_FILE o7planning.org
  • AclEntryPermission.ADD_FILE


add_in_arg

add_in_arg o7planning.org
  • Request.add_in_arg()


add_inout_arg

add_inout_arg o7planning.org
  • Request.add_inout_arg()


add_ior_component

add_ior_component o7planning.org
  • IORInfoOperations.add_ior_component(TaggedComponent)


add_ior_component_to_profile

add_ior_component_to_profile o7planning.org
  • IORInfoOperations.add_ior_component_to_profile(TaggedComponent, int)


add_ior_interceptor

add_ior_interceptor o7planning.org
  • ORBInitInfoOperations.add_ior_interceptor(IORInterceptor)


add_item

add_item o7planning.org
  • NVList.add_item(String, int)


add_named_in_arg

add_named_in_arg o7planning.org
  • Request.add_named_in_arg(String)


add_named_inout_arg

add_named_inout_arg o7planning.org
  • Request.add_named_inout_arg(String)


add_named_out_arg

add_named_out_arg o7planning.org
  • Request.add_named_out_arg(String)


add_out_arg

add_out_arg o7planning.org
  • Request.add_out_arg()


ADD_OVERRIDE

ADD_OVERRIDE o7planning.org
  • SetOverrideType.ADD_OVERRIDE


add_reply_service_context

add_reply_service_context o7planning.org
  • ServerRequestInfoOperations.add_reply_service_context(ServiceContext, boolean)


add_request_service_context

add_request_service_context o7planning.org
  • ClientRequestInfoOperations.add_request_service_context(ServiceContext, boolean)


add_server_request_interceptor

add_server_request_interceptor o7planning.org
  • ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor)


ADD_SUBDIRECTORY

ADD_SUBDIRECTORY o7planning.org
  • AclEntryPermission.ADD_SUBDIRECTORY


add_value

add_value o7planning.org
  • NVList.add_value(String, Any, int)


addAccessibleSelection

addAccessibleSelection o7planning.org
  • AccessibleSelection.addAccessibleSelection(int)
  • JComboBox.AccessibleJComboBox.addAccessibleSelection(int)
  • JList.AccessibleJList.addAccessibleSelection(int)
  • JMenu.AccessibleJMenu.addAccessibleSelection(int)
  • JMenuBar.AccessibleJMenuBar.addAccessibleSelection(int)
  • JTabbedPane.AccessibleJTabbedPane.addAccessibleSelection(int)
  • JTable.AccessibleJTable.addAccessibleSelection(int)
  • JTree.AccessibleJTree.addAccessibleSelection(int)
  • JTree.AccessibleJTree.AccessibleJTreeNode.addAccessibleSelection(int)
  • List.AccessibleAWTList.addAccessibleSelection(int)
  • MenuComponent.AccessibleAWTMenuComponent.addAccessibleSelection(int)


addActionForKeyStroke

addActionForKeyStroke o7planning.org
  • Keymap.addActionForKeyStroke(KeyStroke, Action)


addActionListener

addActionListener o7planning.org
  • AbstractButton.addActionListener(ActionListener)
  • BasicComboBoxEditor.addActionListener(ActionListener)
  • Button.addActionListener(ActionListener)
  • ButtonModel.addActionListener(ActionListener)
  • ComboBoxEditor.addActionListener(ActionListener)
  • DefaultButtonModel.addActionListener(ActionListener)
  • JComboBox.addActionListener(ActionListener)
  • JFileChooser.addActionListener(ActionListener)
  • JTextField.addActionListener(ActionListener)
  • List.addActionListener(ActionListener)
  • MenuItem.addActionListener(ActionListener)
  • TextField.addActionListener(ActionListener)
  • Timer.addActionListener(ActionListener)
  • TrayIcon.addActionListener(ActionListener)


addAdjustmentListener

addAdjustmentListener o7planning.org
  • Adjustable.addAdjustmentListener(AdjustmentListener)
  • JScrollBar.addAdjustmentListener(AdjustmentListener)
  • ScrollPaneAdjustable.addAdjustmentListener(AdjustmentListener)
  • Scrollbar.addAdjustmentListener(AdjustmentListener)


addAll

addAll o7planning.org
  • AbstractCollection.addAll(Collection<? extends E>)
  • AbstractList.addAll(int, Collection<? extends E>)
  • AbstractQueue.addAll(Collection<? extends E>)
  • AbstractSequentialList.addAll(int, Collection<? extends E>)
  • AccessibleRelationSet.addAll(AccessibleRelation[])
  • AccessibleStateSet.addAll(AccessibleState[])
  • ArrayList.addAll(int, Collection<? extends E>)
  • ArrayList.addAll(Collection<? extends E>)
  • AttributeList.addAll(int, Collection<?>)
  • AttributeList.addAll(Collection<?>)
  • AttributeList.addAll(int, AttributeList)
  • AttributeList.addAll(AttributeList)
  • AttributeSet.addAll(AttributeSet)
  • BeanContextSupport.addAll(Collection)
  • Collection.addAll(Collection<? extends E>)
  • Collections.addAll(Collection<? super T>, T...)
  • CompositeName.addAll(int, Name)
  • CompositeName.addAll(Name)
  • CompoundName.addAll(int, Name)
  • CompoundName.addAll(Name)
  • ConcurrentHashMap.KeySetView.addAll(Collection<? extends K>)
  • ConcurrentLinkedDeque.addAll(Collection<? extends E>)
  • ConcurrentLinkedQueue.addAll(Collection<? extends E>)
  • CopyOnWriteArrayList.addAll(int, Collection<? extends E>)
  • CopyOnWriteArrayList.addAll(Collection<? extends E>)
  • CopyOnWriteArraySet.addAll(Collection<? extends E>)
  • DocAttributeSet.addAll(AttributeSet)
  • HashAttributeSet.addAll(AttributeSet)
  • LdapName.addAll(int, List<Rdn>)
  • LdapName.addAll(int, Name)
  • LdapName.addAll(List<Rdn>)
  • LdapName.addAll(Name)
  • LinkedList.addAll(int, Collection<? extends E>)
  • LinkedList.addAll(Collection<? extends E>)
  • List.addAll(int, Collection<? extends E>)
  • List.addAll(Collection<? extends E>)
  • Name.addAll(int, Name)
  • Name.addAll(Name)
  • PrintJobAttributeSet.addAll(AttributeSet)
  • PrintRequestAttributeSet.addAll(AttributeSet)
  • PrintServiceAttributeSet.addAll(AttributeSet)
  • RoleList.addAll(int, Collection<?>)
  • RoleList.addAll(Collection<?>)
  • RoleList.addAll(int, RoleList)
  • RoleList.addAll(RoleList)
  • RoleUnresolvedList.addAll(int, Collection<?>)
  • RoleUnresolvedList.addAll(Collection<?>)
  • RoleUnresolvedList.addAll(int, RoleUnresolvedList)
  • RoleUnresolvedList.addAll(RoleUnresolvedList)
  • Set.addAll(Collection<? extends E>)
  • TreeSet.addAll(Collection<? extends E>)
  • Vector.addAll(int, Collection<? extends E>)
  • Vector.addAll(Collection<? extends E>)


addAllAbsent

addAllAbsent o7planning.org
  • CopyOnWriteArrayList.addAllAbsent(Collection<? extends E>)


addAncestorListener

addAncestorListener o7planning.org
  • JComponent.addAncestorListener(AncestorListener)


addAndGet

addAndGet o7planning.org
  • AtomicInteger.addAndGet(int)
  • AtomicIntegerArray.addAndGet(int, int)
  • AtomicIntegerFieldUpdater.addAndGet(T, int)
  • AtomicLong.addAndGet(long)
  • AtomicLongArray.addAndGet(int, long)
  • AtomicLongFieldUpdater.addAndGet(T, long)


addAttachmentPart

addAttachmentPart o7planning.org
  • SOAPMessage.addAttachmentPart(AttachmentPart)


addAttribute

addAttribute o7planning.org
  • AbstractDocument.AbstractElement.addAttribute(Object, Object)
  • AbstractDocument.AttributeContext.addAttribute(AttributeSet, Object, Object)
  • AttributeListImpl.addAttribute(String, String, String)
  • AttributedString.addAttribute(AttributedCharacterIterator.Attribute, Object, int, int)
  • AttributedString.addAttribute(AttributedCharacterIterator.Attribute, Object)
  • Attributes2Impl.addAttribute(String, String, String, String, String)
  • AttributesImpl.addAttribute(String, String, String, String, String)
  • IIOMetadataFormatImpl.addAttribute(String, String, int, boolean, int, int)
  • IIOMetadataFormatImpl.addAttribute(String, String, int, boolean, String, String, String, boolean, boolean)
  • IIOMetadataFormatImpl.addAttribute(String, String, int, boolean, String, List<String>)
  • IIOMetadataFormatImpl.addAttribute(String, String, int, boolean, String)
  • MutableAttributeSet.addAttribute(Object, Object)
  • SOAPElement.addAttribute(QName, String)
  • SOAPElement.addAttribute(Name, String)
  • SimpleAttributeSet.addAttribute(Object, Object)
  • StyleContext.addAttribute(AttributeSet, Object, Object)
  • StyleContext.NamedStyle.addAttribute(Object, Object)
  • StyleSheet.addAttribute(AttributeSet, Object, Object)


addAttributeChangeNotificationListener

addAttributeChangeNotificationListener o7planning.org
  • ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener, String, Object)
  • RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener, String, Object)


addAttributes

addAttributes o7planning.org
  • AbstractDocument.AbstractElement.addAttributes(AttributeSet)
  • AbstractDocument.AttributeContext.addAttributes(AttributeSet, AttributeSet)
  • AttributedString.addAttributes(Map<? extends AttributedCharacterIterator.Attribute, ?>, int, int)
  • MutableAttributeSet.addAttributes(AttributeSet)
  • SimpleAttributeSet.addAttributes(AttributeSet)
  • StyleContext.addAttributes(AttributeSet, AttributeSet)
  • StyleContext.NamedStyle.addAttributes(AttributeSet)
  • StyleSheet.addAttributes(AttributeSet, AttributeSet)


addAuxiliaryLookAndFeel

addAuxiliaryLookAndFeel o7planning.org
  • UIManager.addAuxiliaryLookAndFeel(LookAndFeel)


addAWTEventListener

addAWTEventListener o7planning.org
  • Toolkit.addAWTEventListener(AWTEventListener, long)


addBatch

addBatch o7planning.org
  • PreparedStatement.addBatch()
  • Statement.addBatch(String)


addBeanContextMembershipListener

addBeanContextMembershipListener o7planning.org
  • BeanContext.addBeanContextMembershipListener(BeanContextMembershipListener)
  • BeanContextSupport.addBeanContextMembershipListener(BeanContextMembershipListener)


addBeanContextServicesListener

addBeanContextServicesListener o7planning.org
  • BeanContextServices.addBeanContextServicesListener(BeanContextServicesListener)
  • BeanContextServicesSupport.addBeanContextServicesListener(BeanContextServicesListener)


addBody

addBody o7planning.org
  • SOAPEnvelope.addBody()


addBodyElement

addBodyElement o7planning.org
  • SOAPBody.addBodyElement(QName)
  • SOAPBody.addBodyElement(Name)


addBooleanAttribute

addBooleanAttribute o7planning.org
  • IIOMetadataFormatImpl.addBooleanAttribute(String, String, boolean, boolean)


addButtonComponents

addButtonComponents o7planning.org
  • BasicOptionPaneUI.addButtonComponents(Container, Object[], int)


addCaretListener

addCaretListener o7planning.org
  • JTextComponent.addCaretListener(CaretListener)


addCellEditorListener

addCellEditorListener o7planning.org
  • AbstractCellEditor.addCellEditorListener(CellEditorListener)
  • CellEditor.addCellEditorListener(CellEditorListener)
  • DefaultTreeCellEditor.addCellEditorListener(CellEditorListener)


addCertificate

addCertificate o7planning.org
  • Identity.addCertificate(Certificate)


addCertPathChecker

addCertPathChecker o7planning.org
  • PKIXParameters.addCertPathChecker(PKIXCertPathChecker)


addCertStore

addCertStore o7planning.org
  • PKIXParameters.addCertStore(CertStore)


addChangeListener

addChangeListener o7planning.org
  • AbstractButton.addChangeListener(ChangeListener)
  • AbstractSpinnerModel.addChangeListener(ChangeListener)
  • BoundedRangeModel.addChangeListener(ChangeListener)
  • ButtonModel.addChangeListener(ChangeListener)
  • Caret.addChangeListener(ChangeListener)
  • ColorSelectionModel.addChangeListener(ChangeListener)
  • DefaultBoundedRangeModel.addChangeListener(ChangeListener)
  • DefaultButtonModel.addChangeListener(ChangeListener)
  • DefaultCaret.addChangeListener(ChangeListener)
  • DefaultColorSelectionModel.addChangeListener(ChangeListener)
  • DefaultSingleSelectionModel.addChangeListener(ChangeListener)
  • JProgressBar.addChangeListener(ChangeListener)
  • JSlider.addChangeListener(ChangeListener)
  • JSpinner.addChangeListener(ChangeListener)
  • JTabbedPane.addChangeListener(ChangeListener)
  • JViewport.addChangeListener(ChangeListener)
  • MenuSelectionManager.addChangeListener(ChangeListener)
  • SingleSelectionModel.addChangeListener(ChangeListener)
  • SpinnerModel.addChangeListener(ChangeListener)
  • Style.addChangeListener(ChangeListener)
  • StyleContext.addChangeListener(ChangeListener)
  • StyleContext.NamedStyle.addChangeListener(ChangeListener)


addChildElement

addChildElement o7planning.org
  • IIOMetadataFormatImpl.addChildElement(String, String)
  • SOAPElement.addChildElement(SOAPElement)
  • SOAPElement.addChildElement(String, String, String)
  • SOAPElement.addChildElement(String, String)
  • SOAPElement.addChildElement(String)
  • SOAPElement.addChildElement(QName)
  • SOAPElement.addChildElement(Name)


addChoosableFileFilter

addChoosableFileFilter o7planning.org
  • JFileChooser.addChoosableFileFilter(FileFilter)


addChooserPanel

addChooserPanel o7planning.org
  • JColorChooser.addChooserPanel(AbstractColorChooserPanel)


addColumn

addColumn o7planning.org
  • DefaultTableColumnModel.addColumn(TableColumn)
  • DefaultTableModel.addColumn(Object, Object[])
  • DefaultTableModel.addColumn(Object, Vector)
  • DefaultTableModel.addColumn(Object)
  • JTable.addColumn(TableColumn)
  • TableColumnModel.addColumn(TableColumn)


addColumnModelListener

addColumnModelListener o7planning.org
  • DefaultTableColumnModel.addColumnModelListener(TableColumnModelListener)
  • TableColumnModel.addColumnModelListener(TableColumnModelListener)


addColumnSelectionInterval

addColumnSelectionInterval o7planning.org
  • JTable.addColumnSelectionInterval(int, int)


addComponent

addComponent o7planning.org
  • GroupLayout.Group.addComponent(Component, int, int, int)
  • GroupLayout.Group.addComponent(Component)
  • GroupLayout.ParallelGroup.addComponent(Component, GroupLayout.Alignment, int, int, int)
  • GroupLayout.ParallelGroup.addComponent(Component, GroupLayout.Alignment)
  • GroupLayout.ParallelGroup.addComponent(Component, int, int, int)
  • GroupLayout.ParallelGroup.addComponent(Component)
  • GroupLayout.SequentialGroup.addComponent(boolean, Component, int, int, int)
  • GroupLayout.SequentialGroup.addComponent(Component, int, int, int)
  • GroupLayout.SequentialGroup.addComponent(boolean, Component)
  • GroupLayout.SequentialGroup.addComponent(Component)


addComponentListener

addComponentListener o7planning.org
  • Component.addComponentListener(ComponentListener)


addConnectionEventListener

addConnectionEventListener o7planning.org
  • PooledConnection.addConnectionEventListener(ConnectionEventListener)


addConnectionNotificationListener

addConnectionNotificationListener o7planning.org
  • JMXConnector.addConnectionNotificationListener(NotificationListener, NotificationFilter, Object)
  • RMIConnector.addConnectionNotificationListener(NotificationListener, NotificationFilter, Object)


addConsumer

addConsumer o7planning.org
  • FilteredImageSource.addConsumer(ImageConsumer)
  • ImageProducer.addConsumer(ImageConsumer)
  • MemoryImageSource.addConsumer(ImageConsumer)
  • RenderableImageProducer.addConsumer(ImageConsumer)


addContainerGap

addContainerGap o7planning.org
  • GroupLayout.SequentialGroup.addContainerGap(int, int)
  • GroupLayout.SequentialGroup.addContainerGap()


addContainerListener

addContainerListener o7planning.org
  • Container.addContainerListener(ContainerListener)


addContent

addContent o7planning.org
  • HTMLDocument.HTMLReader.addContent(char[], int, int, boolean)
  • HTMLDocument.HTMLReader.addContent(char[], int, int)


addControlButtons

addControlButtons o7planning.org
  • MetalFileChooserUI.addControlButtons()


addControllerEventListener

addControllerEventListener o7planning.org
  • Sequencer.addControllerEventListener(ControllerEventListener, int[])


addCSSAttribute

addCSSAttribute o7planning.org
  • StyleSheet.addCSSAttribute(MutableAttributeSet, CSS.Attribute, String)


addCSSAttributeFromHTML

addCSSAttributeFromHTML o7planning.org
  • StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet, CSS.Attribute, String)


addCustomEntriesToTable

addCustomEntriesToTable o7planning.org
  • MetalTheme.addCustomEntriesToTable(UIDefaults)
  • OceanTheme.addCustomEntriesToTable(UIDefaults)


addDetail

addDetail o7planning.org
  • SOAPFault.addDetail()


addDetailEntry

addDetailEntry o7planning.org
  • Detail.addDetailEntry(QName)
  • Detail.addDetailEntry(Name)


addDirtyRegion

addDirtyRegion o7planning.org
  • RepaintManager.addDirtyRegion(Applet, int, int, int, int)
  • RepaintManager.addDirtyRegion(Window, int, int, int, int)
  • RepaintManager.addDirtyRegion(JComponent, int, int, int, int)


addDocument

addDocument o7planning.org
  • SOAPBody.addDocument(Document)


addDocumentListener

addDocumentListener o7planning.org
  • AbstractDocument.addDocumentListener(DocumentListener)
  • DefaultStyledDocument.addDocumentListener(DocumentListener)
  • Document.addDocumentListener(DocumentListener)


addDragGestureListener

addDragGestureListener o7planning.org
  • DragGestureRecognizer.addDragGestureListener(DragGestureListener)


addDragSourceListener

addDragSourceListener o7planning.org
  • DragSource.addDragSourceListener(DragSourceListener)
  • DragSourceContext.addDragSourceListener(DragSourceListener)


addDragSourceMotionListener

addDragSourceMotionListener o7planning.org
  • DragSource.addDragSourceMotionListener(DragSourceMotionListener)


addDropTargetListener

addDropTargetListener o7planning.org
  • DropTarget.addDropTargetListener(DropTargetListener)


addEdit

addEdit o7planning.org
  • AbstractDocument.DefaultDocumentEvent.addEdit(UndoableEdit)
  • AbstractUndoableEdit.addEdit(UndoableEdit)
  • CompoundEdit.addEdit(UndoableEdit)
  • UndoManager.addEdit(UndoableEdit)
  • UndoableEdit.addEdit(UndoableEdit)


addEditor

addEditor o7planning.org
  • BasicComboBoxUI.addEditor()


addElement

addElement o7planning.org
  • DefaultComboBoxModel.addElement(E)
  • DefaultListModel.addElement(E)
  • IIOMetadataFormatImpl.addElement(String, String, int, int)
  • IIOMetadataFormatImpl.addElement(String, String, int)
  • MutableComboBoxModel.addElement(E)
  • Vector.addElement(E)


addEntry

addEntry o7planning.org
  • Acl.addEntry(Principal, AclEntry)


addEventListener

addEventListener o7planning.org
  • EventTarget.addEventListener(String, EventListener, boolean)


addExact

addExact o7planning.org
  • Math.addExact(long, long)
  • Math.addExact(int, int)
  • StrictMath.addExact(long, long)
  • StrictMath.addExact(int, int)


addFault

addFault o7planning.org
  • SOAPBody.addFault(QName, String)
  • SOAPBody.addFault(Name, String)
  • SOAPBody.addFault(QName, String, Locale)
  • SOAPBody.addFault(Name, String, Locale)
  • SOAPBody.addFault()


addFaultReasonText

addFaultReasonText o7planning.org
  • SOAPFault.addFaultReasonText(String, Locale)


addFirst

addFirst o7planning.org
  • ArrayDeque.addFirst(E)
  • BlockingDeque.addFirst(E)
  • ConcurrentLinkedDeque.addFirst(E)
  • Deque.addFirst(E)
  • LinkedBlockingDeque.addFirst(E)
  • LinkedList.addFirst(E)


addFlavorForUnencodedNative

addFlavorForUnencodedNative o7planning.org
  • SystemFlavorMap.addFlavorForUnencodedNative(String, DataFlavor)


addFlavorListener

addFlavorListener o7planning.org
  • Clipboard.addFlavorListener(FlavorListener)


addFocusListener

addFocusListener o7planning.org
  • AccessibleComponent.addFocusListener(FocusListener)
  • Component.addFocusListener(FocusListener)
  • Component.AccessibleAWTComponent.addFocusListener(FocusListener)
  • JList.AccessibleJList.AccessibleJListChild.addFocusListener(FocusListener)
  • JTable.AccessibleJTable.AccessibleJTableCell.addFocusListener(FocusListener)
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addFocusListener(FocusListener)
  • JTree.AccessibleJTree.AccessibleJTreeNode.addFocusListener(FocusListener)
  • List.AccessibleAWTList.AccessibleAWTListChild.addFocusListener(FocusListener)
  • MenuComponent.AccessibleAWTMenuComponent.addFocusListener(FocusListener)


addGap

addGap o7planning.org
  • GroupLayout.Group.addGap(int, int, int)
  • GroupLayout.Group.addGap(int)
  • GroupLayout.ParallelGroup.addGap(int, int, int)
  • GroupLayout.ParallelGroup.addGap(int)
  • GroupLayout.SequentialGroup.addGap(int, int, int)
  • GroupLayout.SequentialGroup.addGap(int)


addGroup

addGroup o7planning.org
  • GroupLayout.Group.addGroup(GroupLayout.Group)
  • GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment, GroupLayout.Group)
  • GroupLayout.ParallelGroup.addGroup(GroupLayout.Group)
  • GroupLayout.SequentialGroup.addGroup(boolean, GroupLayout.Group)
  • GroupLayout.SequentialGroup.addGroup(GroupLayout.Group)


addHandler

addHandler o7planning.org
  • Logger.addHandler(Handler)


addHandshakeCompletedListener

addHandshakeCompletedListener o7planning.org
  • SSLSocket.addHandshakeCompletedListener(HandshakeCompletedListener)


addHeader

addHeader o7planning.org
  • MimeHeaders.addHeader(String, String)
  • SOAPEnvelope.addHeader()


addHeaderElement

addHeaderElement o7planning.org
  • SOAPHeader.addHeaderElement(QName)
  • SOAPHeader.addHeaderElement(Name)


addHierarchyBoundsListener

addHierarchyBoundsListener o7planning.org
  • Component.addHierarchyBoundsListener(HierarchyBoundsListener)


addHierarchyListener

addHierarchyListener o7planning.org
  • Component.addHierarchyListener(HierarchyListener)


addHighlight

addHighlight o7planning.org
  • DefaultHighlighter.addHighlight(int, int, Highlighter.HighlightPainter)
  • Highlighter.addHighlight(int, int, Highlighter.HighlightPainter)


addHyperlinkListener

addHyperlinkListener o7planning.org
  • JEditorPane.addHyperlinkListener(HyperlinkListener)


addIcon

addIcon o7planning.org
  • BasicOptionPaneUI.addIcon(Container)


addIdentity

addIdentity o7planning.org
  • IdentityScope.addIdentity(Identity)


addIfAbsent

addIfAbsent o7planning.org
  • CopyOnWriteArrayList.addIfAbsent(E)


addIIOReadProgressListener

addIIOReadProgressListener o7planning.org
  • ImageReader.addIIOReadProgressListener(IIOReadProgressListener)


addIIOReadUpdateListener

addIIOReadUpdateListener o7planning.org
  • ImageReader.addIIOReadUpdateListener(IIOReadUpdateListener)


addIIOReadWarningListener

addIIOReadWarningListener o7planning.org
  • ImageReader.addIIOReadWarningListener(IIOReadWarningListener)


addIIOWriteProgressListener

addIIOWriteProgressListener o7planning.org
  • ImageWriter.addIIOWriteProgressListener(IIOWriteProgressListener)


addIIOWriteWarningListener

addIIOWriteWarningListener o7planning.org
  • ImageWriter.addIIOWriteWarningListener(IIOWriteWarningListener)


addImage

addImage o7planning.org
  • MediaTracker.addImage(Image, int, int, int)
  • MediaTracker.addImage(Image, int)


addImpl

addImpl o7planning.org
  • AbstractButton.addImpl(Component, Object, int)
  • CellRendererPane.addImpl(Component, Object, int)
  • Container.addImpl(Component, Object, int)
  • JApplet.addImpl(Component, Object, int)
  • JDesktopPane.addImpl(Component, Object, int)
  • JDialog.addImpl(Component, Object, int)
  • JFrame.addImpl(Component, Object, int)
  • JInternalFrame.addImpl(Component, Object, int)
  • JLayer.addImpl(Component, Object, int)
  • JLayeredPane.addImpl(Component, Object, int)
  • JRootPane.addImpl(Component, Object, int)
  • JSplitPane.addImpl(Component, Object, int)
  • JToolBar.addImpl(Component, Object, int)
  • JViewport.addImpl(Component, Object, int)
  • JWindow.addImpl(Component, Object, int)
  • ScrollPane.addImpl(Component, Object, int)


addInputMethodListener

addInputMethodListener o7planning.org
  • Component.addInputMethodListener(InputMethodListener)
  • JTextComponent.addInputMethodListener(InputMethodListener)


addInternal

addInternal o7planning.org
  • AWTEventMulticaster.addInternal(EventListener, EventListener)


addInternalFrameListener

addInternalFrameListener o7planning.org
  • JInternalFrame.addInternalFrameListener(InternalFrameListener)


addInvalidComponent

addInvalidComponent o7planning.org
  • RepaintManager.addInvalidComponent(JComponent)


addIssuer

addIssuer o7planning.org
  • X509CRLSelector.addIssuer(X500Principal)


addIssuerName

addIssuerName o7planning.org
  • X509CRLSelector.addIssuerName(byte[])
  • X509CRLSelector.addIssuerName(String)


addItem

addItem o7planning.org
  • Choice.addItem(String)
  • JComboBox.addItem(E)
  • List.addItem(String, int)
  • List.addItem(String)


addItemListener

addItemListener o7planning.org
  • AbstractButton.addItemListener(ItemListener)
  • ButtonModel.addItemListener(ItemListener)
  • Checkbox.addItemListener(ItemListener)
  • CheckboxMenuItem.addItemListener(ItemListener)
  • Choice.addItemListener(ItemListener)
  • DefaultButtonModel.addItemListener(ItemListener)
  • ItemSelectable.addItemListener(ItemListener)
  • JComboBox.addItemListener(ItemListener)
  • List.addItemListener(ItemListener)


ADDITION

ADDITION o7planning.org
  • MutationEvent.ADDITION


AdditionalComments

AdditionalComments o7planning.org
  • HTMLDocument.AdditionalComments


addKeyEventDispatcher

addKeyEventDispatcher o7planning.org
  • KeyboardFocusManager.addKeyEventDispatcher(KeyEventDispatcher)


addKeyEventPostProcessor

addKeyEventPostProcessor o7planning.org
  • KeyboardFocusManager.addKeyEventPostProcessor(KeyEventPostProcessor)


addKeyListener

addKeyListener o7planning.org
  • Component.addKeyListener(KeyListener)


addKeymap

addKeymap o7planning.org
  • JTextComponent.addKeymap(String, Keymap)


addLast

addLast o7planning.org
  • ArrayDeque.addLast(E)
  • BlockingDeque.addLast(E)
  • ConcurrentLinkedDeque.addLast(E)
  • Deque.addLast(E)
  • LinkedBlockingDeque.addLast(E)
  • LinkedList.addLast(E)


addLayoutComponent

addLayoutComponent o7planning.org
  • BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent(String, Component)
  • BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent(String, Component)
  • BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent(String, Component)
  • BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent(String, Component)
  • BasicScrollBarUI.addLayoutComponent(String, Component)
  • BasicSplitPaneDivider.DividerLayout.addLayoutComponent(String, Component)
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(Component, Object)
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(String, Component)
  • BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent(String, Component)
  • BorderLayout.addLayoutComponent(String, Component)
  • BorderLayout.addLayoutComponent(Component, Object)
  • BoxLayout.addLayoutComponent(Component, Object)
  • BoxLayout.addLayoutComponent(String, Component)
  • CardLayout.addLayoutComponent(String, Component)
  • CardLayout.addLayoutComponent(Component, Object)
  • FlowLayout.addLayoutComponent(String, Component)
  • GridBagLayout.addLayoutComponent(Component, Object)
  • GridBagLayout.addLayoutComponent(String, Component)
  • GridLayout.addLayoutComponent(String, Component)
  • GroupLayout.addLayoutComponent(Component, Object)
  • GroupLayout.addLayoutComponent(String, Component)
  • JRootPane.RootLayout.addLayoutComponent(Component, Object)
  • JRootPane.RootLayout.addLayoutComponent(String, Component)
  • JSpinner.DefaultEditor.addLayoutComponent(String, Component)
  • LayoutManager.addLayoutComponent(String, Component)
  • LayoutManager2.addLayoutComponent(Component, Object)
  • OverlayLayout.addLayoutComponent(Component, Object)
  • OverlayLayout.addLayoutComponent(String, Component)
  • ScrollPaneLayout.addLayoutComponent(String, Component)
  • SpringLayout.addLayoutComponent(Component, Object)
  • SpringLayout.addLayoutComponent(String, Component)
  • ViewportLayout.addLayoutComponent(String, Component)


addLineListener

addLineListener o7planning.org
  • Line.addLineListener(LineListener)


addListDataListener

addListDataListener o7planning.org
  • AbstractListModel.addListDataListener(ListDataListener)
  • ListModel.addListDataListener(ListDataListener)


addListSelectionListener

addListSelectionListener o7planning.org
  • DefaultListSelectionModel.addListSelectionListener(ListSelectionListener)
  • JList.addListSelectionListener(ListSelectionListener)
  • ListSelectionModel.addListSelectionListener(ListSelectionListener)


addLogger

addLogger o7planning.org
  • LogManager.addLogger(Logger)


addMailcap

addMailcap o7planning.org
  • MailcapCommandMap.addMailcap(String)


addMember

addMember o7planning.org
  • Group.addMember(Principal)


addMenuDragMouseListener

addMenuDragMouseListener o7planning.org
  • JMenuItem.addMenuDragMouseListener(MenuDragMouseListener)


addMenuKeyListener

addMenuKeyListener o7planning.org
  • JMenuItem.addMenuKeyListener(MenuKeyListener)
  • JPopupMenu.addMenuKeyListener(MenuKeyListener)


addMenuListener

addMenuListener o7planning.org
  • JMenu.addMenuListener(MenuListener)


addMessageComponents

addMessageComponents o7planning.org
  • BasicOptionPaneUI.addMessageComponents(Container, GridBagConstraints, Object, int, boolean)


addMetaEventListener

addMetaEventListener o7planning.org
  • Sequencer.addMetaEventListener(MetaEventListener)


addMimeHeader

addMimeHeader o7planning.org
  • AttachmentPart.addMimeHeader(String, String)
  • SOAPPart.addMimeHeader(String, String)


addMimeTypes

addMimeTypes o7planning.org
  • MimetypesFileTypeMap.addMimeTypes(String)


addMouseListener

addMouseListener o7planning.org
  • Component.addMouseListener(MouseListener)
  • TrayIcon.addMouseListener(MouseListener)


addMouseMotionListener

addMouseMotionListener o7planning.org
  • Component.addMouseMotionListener(MouseMotionListener)
  • TrayIcon.addMouseMotionListener(MouseMotionListener)


addMouseWheelListener

addMouseWheelListener o7planning.org
  • Component.addMouseWheelListener(MouseWheelListener)


addMtomAttachment

addMtomAttachment o7planning.org
  • AttachmentMarshaller.addMtomAttachment(byte[], int, int, String, String, String)
  • AttachmentMarshaller.addMtomAttachment(DataHandler, String, String)


addNamespaceDeclaration

addNamespaceDeclaration o7planning.org
  • SOAPElement.addNamespaceDeclaration(String, String)


addNamingListener

addNamingListener o7planning.org
  • EventContext.addNamingListener(String, int, NamingListener)
  • EventContext.addNamingListener(Name, int, NamingListener)
  • EventDirContext.addNamingListener(String, String, Object[], SearchControls, NamingListener)
  • EventDirContext.addNamingListener(Name, String, Object[], SearchControls, NamingListener)
  • EventDirContext.addNamingListener(String, String, SearchControls, NamingListener)
  • EventDirContext.addNamingListener(Name, String, SearchControls, NamingListener)


addNodeChangeListener

addNodeChangeListener o7planning.org
  • AbstractPreferences.addNodeChangeListener(NodeChangeListener)
  • Preferences.addNodeChangeListener(NodeChangeListener)


addNotification

addNotification o7planning.org
  • Timer.addNotification(String, String, Object, Date)
  • Timer.addNotification(String, String, Object, Date, long)
  • Timer.addNotification(String, String, Object, Date, long, long)
  • Timer.addNotification(String, String, Object, Date, long, long, boolean)
  • TimerMBean.addNotification(String, String, Object, Date)
  • TimerMBean.addNotification(String, String, Object, Date, long)
  • TimerMBean.addNotification(String, String, Object, Date, long, long)
  • TimerMBean.addNotification(String, String, Object, Date, long, long, boolean)


addNotificationListener

addNotificationListener o7planning.org
  • MBeanServer.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)
  • MBeanServer.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)
  • MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)
  • MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)
  • MBeanServerDelegate.addNotificationListener(NotificationListener, NotificationFilter, Object)
  • NotificationBroadcaster.addNotificationListener(NotificationListener, NotificationFilter, Object)
  • NotificationBroadcasterSupport.addNotificationListener(NotificationListener, NotificationFilter, Object)
  • RMIConnection.addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)
  • RMIConnectionImpl.addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)
  • RMIConnectionImpl_Stub.addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)
  • RequiredModelMBean.addNotificationListener(NotificationListener, NotificationFilter, Object)
  • StandardEmitterMBean.addNotificationListener(NotificationListener, NotificationFilter, Object)


addNotificationListeners

addNotificationListeners o7planning.org
  • RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[])
  • RMIConnectionImpl.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[])
  • RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[])


addNotify

addNotify o7planning.org
  • Button.addNotify()
  • Canvas.addNotify()
  • Checkbox.addNotify()
  • CheckboxMenuItem.addNotify()
  • Choice.addNotify()
  • Component.addNotify()
  • Container.addNotify()
  • Dialog.addNotify()
  • DropTarget.addNotify(ComponentPeer)
  • DropTargetContext.addNotify(DropTargetContextPeer)
  • FileDialog.addNotify()
  • Frame.addNotify()
  • JComponent.addNotify()
  • JLayer.addNotify()
  • JMenuBar.addNotify()
  • JRootPane.addNotify()
  • JTable.addNotify()
  • Label.addNotify()
  • List.addNotify()
  • Menu.addNotify()
  • MenuBar.addNotify()
  • MenuItem.addNotify()
  • MetalInternalFrameTitlePane.addNotify()
  • Panel.addNotify()
  • PopupMenu.addNotify()
  • ScrollPane.addNotify()
  • Scrollbar.addNotify()
  • TextArea.addNotify()
  • TextComponent.addNotify()
  • TextField.addNotify()
  • Window.addNotify()


addNotUnderstoodHeaderElement

addNotUnderstoodHeaderElement o7planning.org
  • SOAPHeader.addNotUnderstoodHeaderElement(QName)


addObjectValue

addObjectValue o7planning.org
  • IIOMetadataFormatImpl.addObjectValue(String, Class<?>, int, int)
  • IIOMetadataFormatImpl.addObjectValue(String, Class<T>, T, Comparable<? super T>, Comparable<? super T>, boolean, boolean)
  • IIOMetadataFormatImpl.addObjectValue(String, Class<T>, boolean, T, List<? extends T>)
  • IIOMetadataFormatImpl.addObjectValue(String, Class<T>, boolean, T)


addObservedObject

addObservedObject o7planning.org
  • Monitor.addObservedObject(ObjectName)
  • MonitorMBean.addObservedObject(ObjectName)


addObserver

addObserver o7planning.org
  • Observable.addObserver(Observer)


addOwner

addOwner o7planning.org
  • Owner.addOwner(Principal, Principal)


addPathToName

addPathToName o7planning.org
  • X509CertSelector.addPathToName(int, byte[])
  • X509CertSelector.addPathToName(int, String)


addPermission

addPermission o7planning.org
  • AclEntry.addPermission(Permission)


addPoint

addPoint o7planning.org
  • Polygon.addPoint(int, int)


addPopupMenuListener

addPopupMenuListener o7planning.org
  • JComboBox.addPopupMenuListener(PopupMenuListener)
  • JPopupMenu.addPopupMenuListener(PopupMenuListener)


addPort

addPort o7planning.org
  • Service.addPort(QName, String, String)
  • ServiceDelegate.addPort(QName, String, String)


addPreferenceChangeListener

addPreferenceChangeListener o7planning.org
  • AbstractPreferences.addPreferenceChangeListener(PreferenceChangeListener)
  • Preferences.addPreferenceChangeListener(PreferenceChangeListener)


addPreferredGap

addPreferredGap o7planning.org
  • GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement, int, int)
  • GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement)
  • GroupLayout.SequentialGroup.addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, int)
  • GroupLayout.SequentialGroup.addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement)


addPrintJobAttributeListener

addPrintJobAttributeListener o7planning.org
  • DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener, PrintJobAttributeSet)


addPrintJobListener

addPrintJobListener o7planning.org
  • DocPrintJob.addPrintJobListener(PrintJobListener)


addPrintServiceAttributeListener

addPrintServiceAttributeListener o7planning.org
  • PrintService.addPrintServiceAttributeListener(PrintServiceAttributeListener)


addPropertyChangeListener

addPropertyChangeListener o7planning.org
  • AbstractAction.addPropertyChangeListener(PropertyChangeListener)
  • AccessibleContext.addPropertyChangeListener(PropertyChangeListener)
  • Action.addPropertyChangeListener(PropertyChangeListener)
  • BasicDirectoryModel.addPropertyChangeListener(PropertyChangeListener)
  • BeanContextChild.addPropertyChangeListener(String, PropertyChangeListener)
  • BeanContextChildSupport.addPropertyChangeListener(String, PropertyChangeListener)
  • Component.addPropertyChangeListener(String, PropertyChangeListener)
  • Component.addPropertyChangeListener(PropertyChangeListener)
  • Component.AccessibleAWTComponent.addPropertyChangeListener(PropertyChangeListener)
  • Container.addPropertyChangeListener(String, PropertyChangeListener)
  • Container.addPropertyChangeListener(PropertyChangeListener)
  • Container.AccessibleAWTContainer.addPropertyChangeListener(PropertyChangeListener)
  • Customizer.addPropertyChangeListener(PropertyChangeListener)
  • DefaultTreeSelectionModel.addPropertyChangeListener(PropertyChangeListener)
  • JComponent.AccessibleJComponent.addPropertyChangeListener(PropertyChangeListener)
  • JList.AccessibleJList.AccessibleJListChild.addPropertyChangeListener(PropertyChangeListener)
  • JTable.AccessibleJTable.AccessibleJTableCell.addPropertyChangeListener(PropertyChangeListener)
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addPropertyChangeListener(PropertyChangeListener)
  • JTree.AccessibleJTree.AccessibleJTreeNode.addPropertyChangeListener(PropertyChangeListener)
  • JTree.EmptySelectionModel.addPropertyChangeListener(PropertyChangeListener)
  • KeyboardFocusManager.addPropertyChangeListener(String, PropertyChangeListener)
  • KeyboardFocusManager.addPropertyChangeListener(PropertyChangeListener)
  • LayerUI.addPropertyChangeListener(String, PropertyChangeListener)
  • LayerUI.addPropertyChangeListener(PropertyChangeListener)
  • LogManager.addPropertyChangeListener(PropertyChangeListener)
  • Pack200.Packer.addPropertyChangeListener(PropertyChangeListener)
  • Pack200.Unpacker.addPropertyChangeListener(PropertyChangeListener)
  • PropertyChangeSupport.addPropertyChangeListener(String, PropertyChangeListener)
  • PropertyChangeSupport.addPropertyChangeListener(PropertyChangeListener)
  • PropertyEditor.addPropertyChangeListener(PropertyChangeListener)
  • PropertyEditorSupport.addPropertyChangeListener(PropertyChangeListener)
  • SwingWorker.addPropertyChangeListener(PropertyChangeListener)
  • SystemTray.addPropertyChangeListener(String, PropertyChangeListener)
  • TableColumn.addPropertyChangeListener(PropertyChangeListener)
  • Toolkit.addPropertyChangeListener(String, PropertyChangeListener)
  • TreeSelectionModel.addPropertyChangeListener(PropertyChangeListener)
  • UIDefaults.addPropertyChangeListener(PropertyChangeListener)
  • UIManager.addPropertyChangeListener(PropertyChangeListener)
  • Window.addPropertyChangeListener(String, PropertyChangeListener)
  • Window.addPropertyChangeListener(PropertyChangeListener)


addProvider

addProvider o7planning.org
  • Security.addProvider(Provider)


addProviderAtEnd

addProviderAtEnd o7planning.org
  • GSSManager.addProviderAtEnd(Provider, Oid)


addProviderAtFront

addProviderAtFront o7planning.org
  • GSSManager.addProviderAtFront(Provider, Oid)


addRelation

addRelation o7planning.org
  • RelationService.addRelation(ObjectName)
  • RelationServiceMBean.addRelation(ObjectName)


addRelationType

addRelationType o7planning.org
  • RelationService.addRelationType(RelationType)
  • RelationServiceMBean.addRelationType(RelationType)


addRenderingHints

addRenderingHints o7planning.org
  • Graphics2D.addRenderingHints(Map<?, ?>)


addRequestProperty

addRequestProperty o7planning.org
  • URLConnection.addRequestProperty(String, String)


addResourceBundle

addResourceBundle o7planning.org
  • UIDefaults.addResourceBundle(String)


addResponseHeader

addResponseHeader o7planning.org
  • HttpExchange.addResponseHeader(String, String)


address

address o7planning.org
  • W3CEndpointReferenceBuilder.address(String)


ADDRESS

ADDRESS o7planning.org
  • HTML.Tag.ADDRESS


AddressHelper

AddressHelper o7planning.org
  • AddressHelper.AddressHelper()


AddressingFeature

AddressingFeature o7planning.org
  • AddressingFeature.AddressingFeature(boolean, boolean, AddressingFeature.Responses)
  • AddressingFeature.AddressingFeature(boolean, boolean)
  • AddressingFeature.AddressingFeature(boolean)
  • AddressingFeature.AddressingFeature()


addRoleInfo

addRoleInfo o7planning.org
  • RelationTypeSupport.addRoleInfo(RoleInfo)


addRow

addRow o7planning.org
  • DefaultTableModel.addRow(Object[])
  • DefaultTableModel.addRow(Vector)


addRowSelectionInterval

addRowSelectionInterval o7planning.org
  • JTable.addRowSelectionInterval(int, int)


addRowSet

addRowSet o7planning.org
  • JoinRowSet.addRowSet(RowSet[], String[])
  • JoinRowSet.addRowSet(RowSet[], int[])
  • JoinRowSet.addRowSet(RowSet, String)
  • JoinRowSet.addRowSet(RowSet, int)
  • JoinRowSet.addRowSet(Joinable)


addRowSetListener

addRowSetListener o7planning.org
  • BaseRowSet.addRowSetListener(RowSetListener)
  • RowSet.addRowSetListener(RowSetListener)


addRowSorterListener

addRowSorterListener o7planning.org
  • RowSorter.addRowSorterListener(RowSorterListener)


addrs

addrs o7planning.org
  • Reference.addrs


addrType

addrType o7planning.org
  • RefAddr.addrType


addRule

addRule o7planning.org
  • StyleSheet.addRule(String)


addSelectionInterval

addSelectionInterval o7planning.org
  • DefaultListSelectionModel.addSelectionInterval(int, int)
  • JList.addSelectionInterval(int, int)
  • JTree.addSelectionInterval(int, int)
  • ListSelectionModel.addSelectionInterval(int, int)


addSelectionPath

addSelectionPath o7planning.org
  • DefaultTreeSelectionModel.addSelectionPath(TreePath)
  • JTree.addSelectionPath(TreePath)
  • TreeSelectionModel.addSelectionPath(TreePath)


addSelectionPaths

addSelectionPaths o7planning.org
  • DefaultTreeSelectionModel.addSelectionPaths(TreePath[])
  • JTree.addSelectionPaths(TreePath[])
  • JTree.EmptySelectionModel.addSelectionPaths(TreePath[])
  • TreeSelectionModel.addSelectionPaths(TreePath[])


addSelectionRow

addSelectionRow o7planning.org
  • JTree.addSelectionRow(int)


addSelectionRows

addSelectionRows o7planning.org
  • JTree.addSelectionRows(int[])


addSeparator

addSeparator o7planning.org
  • JMenu.addSeparator()
  • JPopupMenu.addSeparator()
  • JToolBar.addSeparator(Dimension)
  • JToolBar.addSeparator()
  • Menu.addSeparator()


addService

addService o7planning.org
  • BeanContextServices.addService(Class, BeanContextServiceProvider)
  • BeanContextServicesSupport.addService(Class, BeanContextServiceProvider, boolean)
  • BeanContextServicesSupport.addService(Class, BeanContextServiceProvider)


addShutdownHook

addShutdownHook o7planning.org
  • Runtime.addShutdownHook(Thread)


addSingletonComponent

addSingletonComponent o7planning.org
  • ScrollPaneLayout.addSingletonComponent(Component, Component)


addSource

addSource o7planning.org
  • DOMImplementationRegistry.addSource(DOMImplementationSource)
  • ParameterBlock.addSource(Object)


addSpecialElement

addSpecialElement o7planning.org
  • HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag, MutableAttributeSet)


addStatementEventListener

addStatementEventListener o7planning.org
  • PooledConnection.addStatementEventListener(StatementEventListener)


addStyle

addStyle o7planning.org
  • DefaultStyledDocument.addStyle(String, Style)
  • JTextPane.addStyle(String, Style)
  • StyleContext.addStyle(String, Style)
  • StyledDocument.addStyle(String, Style)


addStyleSheet

addStyleSheet o7planning.org
  • StyleSheet.addStyleSheet(StyleSheet)


addSubComponents

addSubComponents o7planning.org
  • BasicInternalFrameTitlePane.addSubComponents()
  • MetalInternalFrameTitlePane.addSubComponents()


addSubjectAlternativeName

addSubjectAlternativeName o7planning.org
  • X509CertSelector.addSubjectAlternativeName(int, byte[])
  • X509CertSelector.addSubjectAlternativeName(int, String)


addSuppressed

addSuppressed o7planning.org
  • Throwable.addSuppressed(Throwable)


addSwaRefAttachment

addSwaRefAttachment o7planning.org
  • AttachmentMarshaller.addSwaRefAttachment(DataHandler)


addSystemMenuItems

addSystemMenuItems o7planning.org
  • BasicInternalFrameTitlePane.addSystemMenuItems(JMenu)
  • MetalInternalFrameTitlePane.addSystemMenuItems(JMenu)


addTab

addTab o7planning.org
  • JTabbedPane.addTab(String, Component)
  • JTabbedPane.addTab(String, Icon, Component)
  • JTabbedPane.addTab(String, Icon, Component, String)


addTableModelListener

addTableModelListener o7planning.org
  • AbstractTableModel.addTableModelListener(TableModelListener)
  • TableModel.addTableModelListener(TableModelListener)


addTag

addTag o7planning.org
  • HTMLEditorKit.InsertHTMLTextAction.addTag


addTask

addTask o7planning.org
  • LayoutQueue.addTask(Runnable)


addTextListener

addTextListener o7planning.org
  • TextComponent.addTextListener(TextListener)


addTextNode

addTextNode o7planning.org
  • SOAPElement.addTextNode(String)


addTileObserver

addTileObserver o7planning.org
  • BufferedImage.addTileObserver(TileObserver)
  • WritableRenderedImage.addTileObserver(TileObserver)


addTo

addTo o7planning.org
  • ChronoPeriod.addTo(Temporal)
  • ChronoUnit.addTo(R, long)
  • Duration.addTo(Date)
  • Duration.addTo(Calendar)
  • Duration.addTo(Temporal)
  • Period.addTo(Temporal)
  • TemporalAmount.addTo(Temporal)
  • TemporalUnit.addTo(R, long)


addToEnvironment

addToEnvironment o7planning.org
  • Context.addToEnvironment(String, Object)
  • InitialContext.addToEnvironment(String, Object)


addToPendingCount

addToPendingCount o7planning.org
  • CountedCompleter.addToPendingCount(int)


addTransformer

addTransformer o7planning.org
  • Instrumentation.addTransformer(ClassFileTransformer)
  • Instrumentation.addTransformer(ClassFileTransformer, boolean)


addTreeExpansionListener

addTreeExpansionListener o7planning.org
  • JTree.addTreeExpansionListener(TreeExpansionListener)


addTreeModelListener

addTreeModelListener o7planning.org
  • DefaultTreeModel.addTreeModelListener(TreeModelListener)
  • TreeModel.addTreeModelListener(TreeModelListener)


addTreeSelectionListener

addTreeSelectionListener o7planning.org
  • DefaultTreeSelectionModel.addTreeSelectionListener(TreeSelectionListener)
  • JTree.addTreeSelectionListener(TreeSelectionListener)
  • JTree.EmptySelectionModel.addTreeSelectionListener(TreeSelectionListener)
  • TreeSelectionModel.addTreeSelectionListener(TreeSelectionListener)


addTreeWillExpandListener

addTreeWillExpandListener o7planning.org
  • JTree.addTreeWillExpandListener(TreeWillExpandListener)


addUndoableEditListener

addUndoableEditListener o7planning.org
  • AbstractDocument.addUndoableEditListener(UndoableEditListener)
  • Document.addUndoableEditListener(UndoableEditListener)
  • UndoableEditSupport.addUndoableEditListener(UndoableEditListener)


addUnencodedNativeForFlavor

addUnencodedNativeForFlavor o7planning.org
  • SystemFlavorMap.addUnencodedNativeForFlavor(DataFlavor, String)


addUnicodeLocaleAttribute

addUnicodeLocaleAttribute o7planning.org
  • Locale.Builder.addUnicodeLocaleAttribute(String)


addUpgradeHeaderElement

addUpgradeHeaderElement o7planning.org
  • SOAPHeader.addUpgradeHeaderElement(String)
  • SOAPHeader.addUpgradeHeaderElement(String[])
  • SOAPHeader.addUpgradeHeaderElement(Iterator)


addURL

addURL o7planning.org
  • MLet.addURL(String)
  • MLet.addURL(URL)
  • MLetMBean.addURL(String)
  • MLetMBean.addURL(URL)
  • URLClassLoader.addURL(URL)


addVetoableChangeListener

addVetoableChangeListener o7planning.org
  • BeanContextChild.addVetoableChangeListener(String, VetoableChangeListener)
  • BeanContextChildSupport.addVetoableChangeListener(String, VetoableChangeListener)
  • JComponent.addVetoableChangeListener(VetoableChangeListener)
  • KeyboardFocusManager.addVetoableChangeListener(String, VetoableChangeListener)
  • KeyboardFocusManager.addVetoableChangeListener(VetoableChangeListener)
  • VetoableChangeSupport.addVetoableChangeListener(String, VetoableChangeListener)
  • VetoableChangeSupport.addVetoableChangeListener(VetoableChangeListener)


addWindowFocusListener

addWindowFocusListener o7planning.org
  • Window.addWindowFocusListener(WindowFocusListener)


addWindowListener

addWindowListener o7planning.org
  • Window.addWindowListener(WindowListener)


addWindowStateListener

addWindowStateListener o7planning.org
  • Window.addWindowStateListener(WindowStateListener)


adjustAllocation

adjustAllocation o7planning.org
  • FieldView.adjustAllocation(Shape)


adjustForGravity

adjustForGravity o7planning.org
  • GridBagLayout.adjustForGravity(GridBagConstraints, Rectangle)


AdjustForGravity

AdjustForGravity o7planning.org
  • GridBagLayout.AdjustForGravity(GridBagConstraints, Rectangle)


adjustInto

adjustInto o7planning.org
  • ChronoField.adjustInto(R, long)
  • ChronoLocalDate.adjustInto(Temporal)
  • ChronoLocalDateTime.adjustInto(Temporal)
  • DayOfWeek.adjustInto(Temporal)
  • Era.adjustInto(Temporal)
  • Instant.adjustInto(Temporal)
  • LocalDate.adjustInto(Temporal)
  • LocalDateTime.adjustInto(Temporal)
  • LocalTime.adjustInto(Temporal)
  • Month.adjustInto(Temporal)
  • MonthDay.adjustInto(Temporal)
  • OffsetDateTime.adjustInto(Temporal)
  • OffsetTime.adjustInto(Temporal)
  • TemporalAdjuster.adjustInto(Temporal)
  • TemporalField.adjustInto(R, long)
  • Year.adjustInto(Temporal)
  • YearMonth.adjustInto(Temporal)
  • ZoneOffset.adjustInto(Temporal)


ADJUSTMENT_EVENT_MASK

ADJUSTMENT_EVENT_MASK o7planning.org
  • AWTEvent.ADJUSTMENT_EVENT_MASK


ADJUSTMENT_FIRST

ADJUSTMENT_FIRST o7planning.org
  • AdjustmentEvent.ADJUSTMENT_FIRST


ADJUSTMENT_LAST

ADJUSTMENT_LAST o7planning.org
  • AdjustmentEvent.ADJUSTMENT_LAST


ADJUSTMENT_VALUE_CHANGED

ADJUSTMENT_VALUE_CHANGED o7planning.org
  • AdjustmentEvent.ADJUSTMENT_VALUE_CHANGED


AdjustmentEvent

AdjustmentEvent o7planning.org
  • AdjustmentEvent.AdjustmentEvent(Adjustable, int, int, int, boolean)
  • AdjustmentEvent.AdjustmentEvent(Adjustable, int, int, int)


adjustmentValueChanged

adjustmentValueChanged o7planning.org
  • AWTEventMulticaster.adjustmentValueChanged(AdjustmentEvent)
  • AdjustmentListener.adjustmentValueChanged(AdjustmentEvent)


adjustRow

adjustRow o7planning.org
  • FlowView.FlowStrategy.adjustRow(FlowView, int, int, int)


adjustSizes

adjustSizes o7planning.org
  • SizeRequirements.adjustSizes(int, SizeRequirements[])


adjustVisibility

adjustVisibility o7planning.org
  • DefaultCaret.adjustVisibility(Rectangle)


Adler32

Adler32 o7planning.org
  • Adler32.Adler32()


ADMIN_UIROLE

ADMIN_UIROLE o7planning.org
  • ServiceUIFactory.ADMIN_UIROLE


adoptNode

adoptNode o7planning.org
  • Document.adoptNode(Node)


AEADBadTagException

AEADBadTagException o7planning.org
  • AEADBadTagException.AEADBadTagException(String)
  • AEADBadTagException.AEADBadTagException()


AEGEAN_NUMBERS

AEGEAN_NUMBERS o7planning.org
  • Character.UnicodeBlock.AEGEAN_NUMBERS


AffineTransform

AffineTransform o7planning.org
  • AffineTransform.AffineTransform(double[])
  • AffineTransform.AffineTransform(double, double, double, double, double, double)
  • AffineTransform.AffineTransform(float[])
  • AffineTransform.AffineTransform(float, float, float, float, float, float)
  • AffineTransform.AffineTransform(AffineTransform)
  • AffineTransform.AffineTransform()


AffineTransformOp

AffineTransformOp o7planning.org
  • AffineTransformOp.AffineTransformOp(AffineTransform, int)
  • AffineTransformOp.AffineTransformOp(AffineTransform, RenderingHints)


after

after o7planning.org
  • Calendar.after(Object)
  • Date.after(Date)
  • Timestamp.after(Timestamp)


AFTER_LAST_LINE

AFTER_LAST_LINE o7planning.org
  • BorderLayout.AFTER_LAST_LINE


AFTER_LINE_ENDS

AFTER_LINE_ENDS o7planning.org
  • BorderLayout.AFTER_LINE_ENDS


afterExecute

afterExecute o7planning.org
  • ThreadPoolExecutor.afterExecute(Runnable, Throwable)


afterLast

afterLast o7planning.org
  • ResultSet.afterLast()


afterMarshal

afterMarshal o7planning.org
  • Marshaller.Listener.afterMarshal(Object)


afterOffset

afterOffset o7planning.org
  • TextHitInfo.afterOffset(int)


afterUnmarshal

afterUnmarshal o7planning.org
  • Unmarshaller.Listener.afterUnmarshal(Object, Object)


AIFC

AIFC o7planning.org
  • AudioFileFormat.Type.AIFC


AIFF

AIFF o7planning.org
  • AudioFileFormat.Type.AIFF


ALAW

ALAW o7planning.org
  • AudioFormat.Encoding.ALAW


ALCHEMICAL_SYMBOLS

ALCHEMICAL_SYMBOLS o7planning.org
  • Character.UnicodeBlock.ALCHEMICAL_SYMBOLS


ALERT

ALERT o7planning.org
  • AccessibleRole.ALERT


AlgorithmParameterGenerator

AlgorithmParameterGenerator o7planning.org
  • AlgorithmParameterGenerator.AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi, Provider, String)


AlgorithmParameterGeneratorSpi

AlgorithmParameterGeneratorSpi o7planning.org
  • AlgorithmParameterGeneratorSpi.AlgorithmParameterGeneratorSpi()


AlgorithmParameters

AlgorithmParameters o7planning.org
  • AlgorithmParameters.AlgorithmParameters(AlgorithmParametersSpi, Provider, String)


AlgorithmParametersSpi

AlgorithmParametersSpi o7planning.org
  • AlgorithmParametersSpi.AlgorithmParametersSpi()


aliases

aliases o7planning.org
  • Charset.aliases()
  • KeyStore.aliases()


ALIGN

ALIGN o7planning.org
  • HTML.Attribute.ALIGN


ALIGN_BAR

ALIGN_BAR o7planning.org
  • TabStop.ALIGN_BAR


ALIGN_CENTER

ALIGN_CENTER o7planning.org
  • StyleConstants.ALIGN_CENTER
  • TabStop.ALIGN_CENTER


ALIGN_DECIMAL

ALIGN_DECIMAL o7planning.org
  • TabStop.ALIGN_DECIMAL


ALIGN_JUSTIFIED

ALIGN_JUSTIFIED o7planning.org
  • StyleConstants.ALIGN_JUSTIFIED


ALIGN_LEFT

ALIGN_LEFT o7planning.org
  • StyleConstants.ALIGN_LEFT
  • TabStop.ALIGN_LEFT


ALIGN_RIGHT

ALIGN_RIGHT o7planning.org
  • StyleConstants.ALIGN_RIGHT
  • TabStop.ALIGN_RIGHT


alignment

alignment o7planning.org
  • SizeRequirements.alignment


Alignment

Alignment o7planning.org
  • StyleConstants.Alignment


AlignmentAction

AlignmentAction o7planning.org
  • StyledEditorKit.AlignmentAction.AlignmentAction(String, int)


ALINK

ALINK o7planning.org
  • HTML.Attribute.ALINK


ALL

ALL o7planning.org
  • JobAttributes.DefaultSelectionType.ALL
  • Level.ALL


ALL_COLUMNS

ALL_COLUMNS o7planning.org
  • TableModelEvent.ALL_COLUMNS


ALL_RANGES

ALL_RANGES o7planning.org
  • NumericShaper.ALL_RANGES


ALL_STYLES

ALL_STYLES o7planning.org
  • Calendar.ALL_STYLES


ALLBITS

ALLBITS o7planning.org
  • ImageObserver.ALLBITS


allHtmlFlavor

allHtmlFlavor o7planning.org
  • DataFlavor.allHtmlFlavor


allKeys

allKeys o7planning.org
  • ActionMap.allKeys()
  • InputMap.allKeys()


allMatch

allMatch o7planning.org
  • DoubleStream.allMatch(DoublePredicate)
  • IntStream.allMatch(IntPredicate)
  • LongStream.allMatch(LongPredicate)
  • Stream.allMatch(Predicate<? super T>)


allNotesOff

allNotesOff o7planning.org
  • MidiChannel.allNotesOff()


allocate

allocate o7planning.org
  • ByteBuffer.allocate(int)
  • CharBuffer.allocate(int)
  • DoubleBuffer.allocate(int)
  • FloatBuffer.allocate(int)
  • IntBuffer.allocate(int)
  • LongBuffer.allocate(int)
  • ShortBuffer.allocate(int)
  • XMLEventAllocator.allocate(XMLStreamReader, XMLEventConsumer)
  • XMLEventAllocator.allocate(XMLStreamReader)


allocate_slot_id

allocate_slot_id o7planning.org
  • ORBInitInfoOperations.allocate_slot_id()


allocateArray

allocateArray o7planning.org
  • GapContent.allocateArray(int)


allocateDirect

allocateDirect o7planning.org
  • ByteBuffer.allocateDirect(int)


ALLOCATOR

ALLOCATOR o7planning.org
  • XMLInputFactory.ALLOCATOR


allOf

allOf o7planning.org
  • CompletableFuture.allOf(CompletableFuture<?>...)
  • EnumSet.allOf(Class<E>)


ALLOW_UNASSIGNED

ALLOW_UNASSIGNED o7planning.org
  • IDN.ALLOW_UNASSIGNED


allowCoreThreadTimeOut

allowCoreThreadTimeOut o7planning.org
  • ThreadPoolExecutor.allowCoreThreadTimeOut(boolean)


ALLOWED_CLASSNAMES

ALLOWED_CLASSNAMES o7planning.org
  • OpenType.ALLOWED_CLASSNAMES


ALLOWED_CLASSNAMES_LIST

ALLOWED_CLASSNAMES_LIST o7planning.org
  • OpenType.ALLOWED_CLASSNAMES_LIST


allowMultipleSelections

allowMultipleSelections o7planning.org
  • ChoiceCallback.allowMultipleSelections()


allowsChildren

allowsChildren o7planning.org
  • DefaultMutableTreeNode.allowsChildren


allowsCoreThreadTimeOut

allowsCoreThreadTimeOut o7planning.org
  • ThreadPoolExecutor.allowsCoreThreadTimeOut()


allowsMultipleSelections

allowsMultipleSelections o7planning.org
  • List.allowsMultipleSelections()


allowThreadSuspension

allowThreadSuspension o7planning.org
  • ThreadGroup.allowThreadSuspension(boolean)


allowUserInteraction

allowUserInteraction o7planning.org
  • URLConnection.allowUserInteraction


AllPermission

AllPermission o7planning.org
  • AllPermission.AllPermission(String, String)
  • AllPermission.AllPermission()


allProceduresAreCallable

allProceduresAreCallable o7planning.org
  • DatabaseMetaData.allProceduresAreCallable()


allRowsChanged

allRowsChanged o7planning.org
  • DefaultRowSorter.allRowsChanged()
  • RowSorter.allRowsChanged()


allSoundOff

allSoundOff o7planning.org
  • MidiChannel.allSoundOff()


allTablesAreSelectable

allTablesAreSelectable o7planning.org
  • DatabaseMetaData.allTablesAreSelectable()


ALPHABETIC_PRESENTATION_FORMS

ALPHABETIC_PRESENTATION_FORMS o7planning.org
  • Character.UnicodeBlock.ALPHABETIC_PRESENTATION_FORMS


AlreadyBound

AlreadyBound o7planning.org
  • AlreadyBound.AlreadyBound(String)
  • AlreadyBound.AlreadyBound()


AlreadyBoundException

AlreadyBoundException o7planning.org
  • AlreadyBoundException.AlreadyBoundException(String)
  • AlreadyBoundException.AlreadyBoundException()
  • AlreadyBoundException.AlreadyBoundException()


AlreadyBoundHelper

AlreadyBoundHelper o7planning.org
  • AlreadyBoundHelper.AlreadyBoundHelper()


AlreadyBoundHolder

AlreadyBoundHolder o7planning.org
  • AlreadyBoundHolder.AlreadyBoundHolder(AlreadyBound)
  • AlreadyBoundHolder.AlreadyBoundHolder()


AlreadyConnectedException

AlreadyConnectedException o7planning.org
  • AlreadyConnectedException.AlreadyConnectedException()


alreadyNotified

alreadyNotified o7planning.org
  • Monitor.alreadyNotified


alreadyNotifieds

alreadyNotifieds o7planning.org
  • Monitor.alreadyNotifieds


ALT

ALT o7planning.org
  • HTML.Attribute.ALT


ALT_DOWN_MASK

ALT_DOWN_MASK o7planning.org
  • InputEvent.ALT_DOWN_MASK


ALT_GRAPH_DOWN_MASK

ALT_GRAPH_DOWN_MASK o7planning.org
  • InputEvent.ALT_GRAPH_DOWN_MASK


ALT_GRAPH_MASK

ALT_GRAPH_MASK o7planning.org
  • InputEvent.ALT_GRAPH_MASK


ALT_MASK

ALT_MASK o7planning.org
  • ActionEvent.ALT_MASK
  • Event.ALT_MASK
  • InputEvent.ALT_MASK


ALTERNATE

ALTERNATE o7planning.org
  • FormattableFlags.ALTERNATE


alternateAddTag

alternateAddTag o7planning.org
  • HTMLEditorKit.InsertHTMLTextAction.alternateAddTag


alternateParentTag

alternateParentTag o7planning.org
  • HTMLEditorKit.InsertHTMLTextAction.alternateParentTag


altMetafactory

altMetafactory o7planning.org
  • LambdaMetafactory.altMetafactory(MethodHandles.Lookup, String, MethodType, Object...)


altName

altName o7planning.org
  • CannotProceedException.altName


altNameCtx

altNameCtx o7planning.org
  • CannotProceedException.altNameCtx


ALWAYS_UPDATE

ALWAYS_UPDATE o7planning.org
  • DefaultCaret.ALWAYS_UPDATE


AM

AM o7planning.org
  • Calendar.AM


AM_PM

AM_PM o7planning.org
  • Calendar.AM_PM
  • DateFormat.Field.AM_PM


AM_PM_FIELD

AM_PM_FIELD o7planning.org
  • DateFormat.AM_PM_FIELD


ANCESTOR_ADDED

ANCESTOR_ADDED o7planning.org
  • AncestorEvent.ANCESTOR_ADDED


ANCESTOR_MOVED

ANCESTOR_MOVED o7planning.org
  • AncestorEvent.ANCESTOR_MOVED
  • HierarchyEvent.ANCESTOR_MOVED


ANCESTOR_REMOVED

ANCESTOR_REMOVED o7planning.org
  • AncestorEvent.ANCESTOR_REMOVED


ANCESTOR_RESIZED

ANCESTOR_RESIZED o7planning.org
  • HierarchyEvent.ANCESTOR_RESIZED


ancestorAdded

ancestorAdded o7planning.org
  • AncestorListener.ancestorAdded(AncestorEvent)


AncestorEvent

AncestorEvent o7planning.org
  • AncestorEvent.AncestorEvent(JComponent, int, Container, Container)


ancestorMoved

ancestorMoved o7planning.org
  • AWTEventMulticaster.ancestorMoved(HierarchyEvent)
  • AncestorListener.ancestorMoved(AncestorEvent)
  • HierarchyBoundsAdapter.ancestorMoved(HierarchyEvent)
  • HierarchyBoundsListener.ancestorMoved(HierarchyEvent)


ancestorRemoved

ancestorRemoved o7planning.org
  • AncestorListener.ancestorRemoved(AncestorEvent)


ancestorResized

ancestorResized o7planning.org
  • AWTEventMulticaster.ancestorResized(HierarchyEvent)
  • HierarchyBoundsAdapter.ancestorResized(HierarchyEvent)
  • HierarchyBoundsListener.ancestorResized(HierarchyEvent)


anchor

anchor o7planning.org
  • GridBagConstraints.anchor


ANCHOR_SELECTION_PATH_PROPERTY

ANCHOR_SELECTION_PATH_PROPERTY o7planning.org
  • JTree.ANCHOR_SELECTION_PATH_PROPERTY


ANCIENT_GREEK_MUSICAL_NOTATION

ANCIENT_GREEK_MUSICAL_NOTATION o7planning.org
  • Character.UnicodeBlock.ANCIENT_GREEK_MUSICAL_NOTATION


ANCIENT_GREEK_NUMBERS

ANCIENT_GREEK_NUMBERS o7planning.org
  • Character.UnicodeBlock.ANCIENT_GREEK_NUMBERS


ANCIENT_SYMBOLS

ANCIENT_SYMBOLS o7planning.org
  • Character.UnicodeBlock.ANCIENT_SYMBOLS


and

and o7planning.org
  • BiPredicate.and(BiPredicate<? super T, ? super U>)
  • BigInteger.and(BigInteger)
  • BitSet.and(BitSet)
  • DoublePredicate.and(DoublePredicate)
  • IntPredicate.and(IntPredicate)
  • LongPredicate.and(LongPredicate)
  • Predicate.and(Predicate<? super T>)
  • Query.and(QueryExp, QueryExp)


andFilter

andFilter o7planning.org
  • RowFilter.andFilter(Iterable<? extends RowFilter<? super M, ? super I>>)


andNot

andNot o7planning.org
  • BigInteger.andNot(BigInteger)
  • BitSet.andNot(BitSet)


andThen

andThen o7planning.org
  • BiConsumer.andThen(BiConsumer<? super T, ? super U>)
  • BiFunction.andThen(Function<? super R, ? extends V>)
  • Consumer.andThen(Consumer<? super T>)
  • DoubleConsumer.andThen(DoubleConsumer)
  • DoubleUnaryOperator.andThen(DoubleUnaryOperator)
  • Function.andThen(Function<? super R, ? extends V>)
  • IntConsumer.andThen(IntConsumer)
  • IntUnaryOperator.andThen(IntUnaryOperator)
  • LongConsumer.andThen(LongConsumer)
  • LongUnaryOperator.andThen(LongUnaryOperator)


annotateClass

annotateClass o7planning.org
  • ObjectOutputStream.annotateClass(Class<?>)


annotateProxyClass

annotateProxyClass o7planning.org
  • ObjectOutputStream.annotateProxyClass(Class<?>)


Annotation

Annotation o7planning.org
  • Annotation.Annotation(Object)


AnnotationFormatError

AnnotationFormatError o7planning.org
  • AnnotationFormatError.AnnotationFormatError(Throwable)
  • AnnotationFormatError.AnnotationFormatError(String, Throwable)
  • AnnotationFormatError.AnnotationFormatError(String)


annotationType

annotationType o7planning.org
  • Annotation.annotationType()
  • IncompleteAnnotationException.annotationType()


AnnotationTypeMismatchException

AnnotationTypeMismatchException o7planning.org
  • AnnotationTypeMismatchException.AnnotationTypeMismatchException(Method, String)


ANY

ANY o7planning.org
  • DTDConstants.ANY


Any

Any o7planning.org
  • Any.Any()


AnyHolder

AnyHolder o7planning.org
  • AnyHolder.AnyHolder(Any)
  • AnyHolder.AnyHolder()


anyMatch

anyMatch o7planning.org
  • DoubleStream.anyMatch(DoublePredicate)
  • IntStream.anyMatch(IntPredicate)
  • LongStream.anyMatch(LongPredicate)
  • Stream.anyMatch(Predicate<? super T>)


anyOf

anyOf o7planning.org
  • CompletableFuture.anyOf(CompletableFuture<?>...)


AnySeqHelper

AnySeqHelper o7planning.org
  • AnySeqHelper.AnySeqHelper()
  • AnySeqHelper.AnySeqHelper()


AnySeqHolder

AnySeqHolder o7planning.org
  • AnySeqHolder.AnySeqHolder(Any[])
  • AnySeqHolder.AnySeqHolder()


anySubString

anySubString o7planning.org
  • Query.anySubString(AttributeValueExp, StringValueExp)


AppConfigurationEntry

AppConfigurationEntry o7planning.org
  • AppConfigurationEntry.AppConfigurationEntry(String, AppConfigurationEntry.LoginModuleControlFlag, Map<String, ?>)


append

append o7planning.org
  • Appendable.append(char)
  • Appendable.append(CharSequence, int, int)
  • Appendable.append(CharSequence)
  • Book.append(Printable, PageFormat, int)
  • Book.append(Printable, PageFormat)
  • CharArrayWriter.append(char)
  • CharArrayWriter.append(CharSequence, int, int)
  • CharArrayWriter.append(CharSequence)
  • CharBuffer.append(char)
  • CharBuffer.append(CharSequence, int, int)
  • CharBuffer.append(CharSequence)
  • DateTimeFormatterBuilder.append(DateTimeFormatter)
  • JTextArea.append(String)
  • Path2D.append(PathIterator, boolean)
  • Path2D.append(Shape, boolean)
  • Path2D.Double.append(PathIterator, boolean)
  • Path2D.Float.append(PathIterator, boolean)
  • PrintStream.append(char)
  • PrintStream.append(CharSequence, int, int)
  • PrintStream.append(CharSequence)
  • PrintWriter.append(char)
  • PrintWriter.append(CharSequence, int, int)
  • PrintWriter.append(CharSequence)
  • StringBuffer.append(double)
  • StringBuffer.append(float)
  • StringBuffer.append(long)
  • StringBuffer.append(int)
  • StringBuffer.append(char)
  • StringBuffer.append(boolean)
  • StringBuffer.append(char[], int, int)
  • StringBuffer.append(char[])
  • StringBuffer.append(CharSequence, int, int)
  • StringBuffer.append(CharSequence)
  • StringBuffer.append(StringBuffer)
  • StringBuffer.append(String)
  • StringBuffer.append(Object)
  • StringBuilder.append(double)
  • StringBuilder.append(float)
  • StringBuilder.append(long)
  • StringBuilder.append(int)
  • StringBuilder.append(char)
  • StringBuilder.append(boolean)
  • StringBuilder.append(char[], int, int)
  • StringBuilder.append(char[])
  • StringBuilder.append(CharSequence, int, int)
  • StringBuilder.append(CharSequence)
  • StringBuilder.append(StringBuffer)
  • StringBuilder.append(String)
  • StringBuilder.append(Object)
  • StringWriter.append(char)
  • StringWriter.append(CharSequence, int, int)
  • StringWriter.append(CharSequence)
  • TextArea.append(String)
  • View.append(View)
  • Writer.append(char)
  • Writer.append(CharSequence, int, int)
  • Writer.append(CharSequence)


appendChild

appendChild o7planning.org
  • IIOMetadataNode.appendChild(Node)
  • Node.appendChild(Node)


appendChronologyId

appendChronologyId o7planning.org
  • DateTimeFormatterBuilder.appendChronologyId()


appendChronologyText

appendChronologyText o7planning.org
  • DateTimeFormatterBuilder.appendChronologyText(TextStyle)


appendCodePoint

appendCodePoint o7planning.org
  • StringBuffer.appendCodePoint(int)
  • StringBuilder.appendCodePoint(int)


appendData

appendData o7planning.org
  • CharacterData.appendData(String)


appendEvent

appendEvent o7planning.org
  • DragGestureRecognizer.appendEvent(InputEvent)


appendFaultSubcode

appendFaultSubcode o7planning.org
  • SOAPFault.appendFaultSubcode(QName)


appendFraction

appendFraction o7planning.org
  • DateTimeFormatterBuilder.appendFraction(TemporalField, int, int, boolean)


appendInstant

appendInstant o7planning.org
  • DateTimeFormatterBuilder.appendInstant(int)
  • DateTimeFormatterBuilder.appendInstant()


appendLiteral

appendLiteral o7planning.org
  • DateTimeFormatterBuilder.appendLiteral(String)
  • DateTimeFormatterBuilder.appendLiteral(char)


appendLocalized

appendLocalized o7planning.org
  • DateTimeFormatterBuilder.appendLocalized(FormatStyle, FormatStyle)


appendLocalizedOffset

appendLocalizedOffset o7planning.org
  • DateTimeFormatterBuilder.appendLocalizedOffset(TextStyle)


appendOffset

appendOffset o7planning.org
  • DateTimeFormatterBuilder.appendOffset(String, String)


appendOffsetId

appendOffsetId o7planning.org
  • DateTimeFormatterBuilder.appendOffsetId()


appendOptional

appendOptional o7planning.org
  • DateTimeFormatterBuilder.appendOptional(DateTimeFormatter)


appendParameterTypes

appendParameterTypes o7planning.org
  • MethodType.appendParameterTypes(List<Class<?>>)
  • MethodType.appendParameterTypes(Class<?>...)


appendPattern

appendPattern o7planning.org
  • DateTimeFormatterBuilder.appendPattern(String)


appendRemainingComponent

appendRemainingComponent o7planning.org
  • NamingException.appendRemainingComponent(String)
  • ResolveResult.appendRemainingComponent(String)


appendRemainingName

appendRemainingName o7planning.org
  • NamingException.appendRemainingName(Name)
  • ResolveResult.appendRemainingName(Name)


appendReplacement

appendReplacement o7planning.org
  • Matcher.appendReplacement(StringBuffer, String)


appendTail

appendTail o7planning.org
  • Matcher.appendTail(StringBuffer)


appendText

appendText o7planning.org
  • DateTimeFormatterBuilder.appendText(TemporalField, Map<Long, String>)
  • DateTimeFormatterBuilder.appendText(TemporalField, TextStyle)
  • DateTimeFormatterBuilder.appendText(TemporalField)
  • TextArea.appendText(String)


appendTo

appendTo o7planning.org
  • ProcessBuilder.Redirect.appendTo(File)


appendToBootstrapClassLoaderSearch

appendToBootstrapClassLoaderSearch o7planning.org
  • Instrumentation.appendToBootstrapClassLoaderSearch(JarFile)


appendToSystemClassLoaderSearch

appendToSystemClassLoaderSearch o7planning.org
  • Instrumentation.appendToSystemClassLoaderSearch(JarFile)


appendValue

appendValue o7planning.org
  • DateTimeFormatterBuilder.appendValue(TemporalField, int, int, SignStyle)
  • DateTimeFormatterBuilder.appendValue(TemporalField, int)
  • DateTimeFormatterBuilder.appendValue(TemporalField)


appendValueReduced

appendValueReduced o7planning.org
  • DateTimeFormatterBuilder.appendValueReduced(TemporalField, int, int, ChronoLocalDate)
  • DateTimeFormatterBuilder.appendValueReduced(TemporalField, int, int, int)


appendZoneId

appendZoneId o7planning.org
  • DateTimeFormatterBuilder.appendZoneId()


appendZoneOrOffsetId

appendZoneOrOffsetId o7planning.org
  • DateTimeFormatterBuilder.appendZoneOrOffsetId()


appendZoneRegionId

appendZoneRegionId o7planning.org
  • DateTimeFormatterBuilder.appendZoneRegionId()


appendZoneText

appendZoneText o7planning.org
  • DateTimeFormatterBuilder.appendZoneText(TextStyle, Set<ZoneId>)
  • DateTimeFormatterBuilder.appendZoneText(TextStyle)


Applet

Applet o7planning.org
  • Applet.Applet()


APPLET

APPLET o7planning.org
  • Context.APPLET
  • HTML.Tag.APPLET


applet

applet o7planning.org
  • DTD.applet


appletResize

appletResize o7planning.org
  • AppletStub.appletResize(int, int)


ApplicationException

ApplicationException o7planning.org
  • ApplicationException.ApplicationException(String, InputStream)


apply

apply o7planning.org
  • AttributeValueExp.apply(ObjectName)
  • BiFunction.apply(T, U)
  • DoubleFunction.apply(double)
  • Function.apply(T)
  • IntFunction.apply(int)
  • LongFunction.apply(long)
  • ObjectName.apply(ObjectName)
  • QueryExp.apply(ObjectName)
  • StringValueExp.apply(ObjectName)
  • ValueExp.apply(ObjectName)


APPLY_REVERB

APPLY_REVERB o7planning.org
  • BooleanControl.Type.APPLY_REVERB


applyAsDouble

applyAsDouble o7planning.org
  • DoubleBinaryOperator.applyAsDouble(double, double)
  • DoubleUnaryOperator.applyAsDouble(double)
  • IntToDoubleFunction.applyAsDouble(int)
  • LongToDoubleFunction.applyAsDouble(long)
  • ToDoubleBiFunction.applyAsDouble(T, U)
  • ToDoubleFunction.applyAsDouble(T)


applyAsInt

applyAsInt o7planning.org
  • DoubleToIntFunction.applyAsInt(double)
  • IntBinaryOperator.applyAsInt(int, int)
  • IntUnaryOperator.applyAsInt(int)
  • LongToIntFunction.applyAsInt(long)
  • ToIntBiFunction.applyAsInt(T, U)
  • ToIntFunction.applyAsInt(T)


applyAsLong

applyAsLong o7planning.org
  • DoubleToLongFunction.applyAsLong(double)
  • IntToLongFunction.applyAsLong(int)
  • LongBinaryOperator.applyAsLong(long, long)
  • LongUnaryOperator.applyAsLong(long)
  • ToLongBiFunction.applyAsLong(T, U)
  • ToLongFunction.applyAsLong(T)


applyComponentOrientation

applyComponentOrientation o7planning.org
  • Component.applyComponentOrientation(ComponentOrientation)
  • Container.applyComponentOrientation(ComponentOrientation)
  • JMenu.applyComponentOrientation(ComponentOrientation)


applyLocalizedPattern

applyLocalizedPattern o7planning.org
  • DecimalFormat.applyLocalizedPattern(String)
  • SimpleDateFormat.applyLocalizedPattern(String)


applyPattern

applyPattern o7planning.org
  • ChoiceFormat.applyPattern(String)
  • DecimalFormat.applyPattern(String)
  • MessageFormat.applyPattern(String)
  • SimpleDateFormat.applyPattern(String)


applyPropertyChange

applyPropertyChange o7planning.org
  • LayerUI.applyPropertyChange(PropertyChangeEvent, JLayer<? extends V>)


applyResourceBundle

applyResourceBundle o7planning.org
  • Window.applyResourceBundle(String)
  • Window.applyResourceBundle(ResourceBundle)


applyToEither

applyToEither o7planning.org
  • CompletableFuture.applyToEither(CompletionStage<? extends T>, Function<? super T, U>)
  • CompletionStage.applyToEither(CompletionStage<? extends T>, Function<? super T, U>)


applyToEitherAsync

applyToEitherAsync o7planning.org
  • CompletableFuture.applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>, Executor)
  • CompletableFuture.applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>)
  • CompletionStage.applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>, Executor)
  • CompletionStage.applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>)


appRandom

appRandom o7planning.org
  • SignatureSpi.appRandom


APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY

APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY o7planning.org
  • JFileChooser.APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY


APPROVE_BUTTON_TEXT_CHANGED_PROPERTY

APPROVE_BUTTON_TEXT_CHANGED_PROPERTY o7planning.org
  • JFileChooser.APPROVE_BUTTON_TEXT_CHANGED_PROPERTY


APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY

APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY o7planning.org
  • JFileChooser.APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY


APPROVE_OPTION

APPROVE_OPTION o7planning.org
  • JFileChooser.APPROVE_OPTION


APPROVE_SELECTION

APPROVE_SELECTION o7planning.org
  • JFileChooser.APPROVE_SELECTION


approveSelection

approveSelection o7planning.org
  • JFileChooser.approveSelection()


ApproveSelectionAction

ApproveSelectionAction o7planning.org
  • BasicFileChooserUI.ApproveSelectionAction.ApproveSelectionAction()


APRIL

APRIL o7planning.org
  • Calendar.APRIL
  • DatatypeConstants.APRIL


ARABIC

ARABIC o7planning.org
  • Character.UnicodeBlock.ARABIC
  • NumericShaper.ARABIC


ARABIC_EXTENDED_A

ARABIC_EXTENDED_A o7planning.org
  • Character.UnicodeBlock.ARABIC_EXTENDED_A


ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS

ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS o7planning.org
  • Character.UnicodeBlock.ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS


ARABIC_PRESENTATION_FORMS_A

ARABIC_PRESENTATION_FORMS_A o7planning.org
  • Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_A


ARABIC_PRESENTATION_FORMS_B

ARABIC_PRESENTATION_FORMS_B o7planning.org
  • Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_B


ARABIC_SUPPLEMENT

ARABIC_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.ARABIC_SUPPLEMENT


Arc2D

Arc2D o7planning.org
  • Arc2D.Arc2D(int)
  • Arc2D.Arc2D()


archeight

archeight o7planning.org
  • RoundRectangle2D.Double.archeight
  • RoundRectangle2D.Float.archeight


ARCHIVE

ARCHIVE o7planning.org
  • HTML.Attribute.ARCHIVE


arcwidth

arcwidth o7planning.org
  • RoundRectangle2D.Double.arcwidth
  • RoundRectangle2D.Float.arcwidth


Area

Area o7planning.org
  • Area.Area(Shape)
  • Area.Area()


AREA

AREA o7planning.org
  • HTML.Tag.AREA


AreaAveragingScaleFilter

AreaAveragingScaleFilter o7planning.org
  • AreaAveragingScaleFilter.AreaAveragingScaleFilter(int, int)


areExtraMouseButtonsEnabled

areExtraMouseButtonsEnabled o7planning.org
  • Toolkit.areExtraMouseButtonsEnabled()


areFieldsSet

areFieldsSet o7planning.org
  • Calendar.areFieldsSet


areFocusTraversalKeysSet

areFocusTraversalKeysSet o7planning.org
  • Component.areFocusTraversalKeysSet(int)
  • Container.areFocusTraversalKeysSet(int)


areNew

areNew o7planning.org
  • TreeSelectionEvent.areNew


arePathsContiguous

arePathsContiguous o7planning.org
  • DefaultTreeSelectionModel.arePathsContiguous(TreePath[])


areTablesSet

areTablesSet o7planning.org
  • JPEGImageReadParam.areTablesSet()
  • JPEGImageWriteParam.areTablesSet()


arg

arg o7planning.org
  • Event.arg


ARGUMENT

ARGUMENT o7planning.org
  • MessageFormat.Field.ARGUMENT


argument

argument o7planning.org
  • Parameter.argument


arguments

arguments o7planning.org
  • ORBInitInfoOperations.arguments()
  • Request.arguments()
  • RequestInfoOperations.arguments()
  • ServerRequest.arguments(NVList)


ARGV

ARGV o7planning.org
  • ScriptEngine.ARGV


ArithmeticException

ArithmeticException o7planning.org
  • ArithmeticException.ArithmeticException(String)
  • ArithmeticException.ArithmeticException()


ARMED

ARMED o7planning.org
  • AccessibleState.ARMED
  • DefaultButtonModel.ARMED


ARMENIAN

ARMENIAN o7planning.org
  • Character.UnicodeBlock.ARMENIAN


arrangeGrid

arrangeGrid o7planning.org
  • GridBagLayout.arrangeGrid(Container)


ArrangeGrid

ArrangeGrid o7planning.org
  • GridBagLayout.ArrangeGrid(Container)


array

array o7planning.org
  • Segment.array


ARRAY

ARRAY o7planning.org
  • Types.ARRAY


ArrayBlockingQueue

ArrayBlockingQueue o7planning.org
  • ArrayBlockingQueue.ArrayBlockingQueue(int, boolean, Collection<? extends E>)
  • ArrayBlockingQueue.ArrayBlockingQueue(int, boolean)
  • ArrayBlockingQueue.ArrayBlockingQueue(int)


arraycopy

arraycopy o7planning.org
  • System.arraycopy(Object, int, Object, int, int)


ArrayDeque

ArrayDeque o7planning.org
  • ArrayDeque.ArrayDeque(Collection<? extends E>)
  • ArrayDeque.ArrayDeque(int)
  • ArrayDeque.ArrayDeque()


arrayElementGetter

arrayElementGetter o7planning.org
  • MethodHandles.arrayElementGetter(Class<?>)


arrayElementSetter

arrayElementSetter o7planning.org
  • MethodHandles.arrayElementSetter(Class<?>)


ArrayIndexOutOfBoundsException

ArrayIndexOutOfBoundsException o7planning.org
  • ArrayIndexOutOfBoundsException.ArrayIndexOutOfBoundsException(String)
  • ArrayIndexOutOfBoundsException.ArrayIndexOutOfBoundsException(int)
  • ArrayIndexOutOfBoundsException.ArrayIndexOutOfBoundsException()


ArrayList

ArrayList o7planning.org
  • ArrayList.ArrayList(Collection<? extends E>)
  • ArrayList.ArrayList()
  • ArrayList.ArrayList(int)


arrayOffset

arrayOffset o7planning.org
  • Buffer.arrayOffset()
  • ByteBuffer.arrayOffset()
  • CharBuffer.arrayOffset()
  • DoubleBuffer.arrayOffset()
  • FloatBuffer.arrayOffset()
  • IntBuffer.arrayOffset()
  • LongBuffer.arrayOffset()
  • ShortBuffer.arrayOffset()


ArrayStoreException

ArrayStoreException o7planning.org
  • ArrayStoreException.ArrayStoreException(String)
  • ArrayStoreException.ArrayStoreException()


ArrayType

ArrayType o7planning.org
  • ArrayType.ArrayType(SimpleType<?>, boolean)
  • ArrayType.ArrayType(int, OpenType<?>)


arrive

arrive o7planning.org
  • Phaser.arrive()


arriveAndAwaitAdvance

arriveAndAwaitAdvance o7planning.org
  • Phaser.arriveAndAwaitAdvance()


arriveAndDeregister

arriveAndDeregister o7planning.org
  • Phaser.arriveAndDeregister()


ARROW_BUTTON

ARROW_BUTTON o7planning.org
  • Region.ARROW_BUTTON


arrowButton

arrowButton o7planning.org
  • BasicComboBoxUI.arrowButton


ArrowButtonListener

ArrowButtonListener o7planning.org
  • BasicScrollBarUI.ArrowButtonListener.ArrowButtonListener()


arrowIcon

arrowIcon o7planning.org
  • BasicMenuItemUI.arrowIcon


ARROWS

ARROWS o7planning.org
  • Character.UnicodeBlock.ARROWS


asCharacters

asCharacters o7planning.org
  • XMLEvent.asCharacters()


asCharBuffer

asCharBuffer o7planning.org
  • ByteBuffer.asCharBuffer()


ASCII_STREAM_PARAM

ASCII_STREAM_PARAM o7planning.org
  • BaseRowSet.ASCII_STREAM_PARAM


asciiStream

asciiStream o7planning.org
  • BaseRowSet.asciiStream


asCollector

asCollector o7planning.org
  • MethodHandle.asCollector(Class<?>, int)


asDoubleBuffer

asDoubleBuffer o7planning.org
  • ByteBuffer.asDoubleBuffer()


asDoubleStream

asDoubleStream o7planning.org
  • IntStream.asDoubleStream()
  • LongStream.asDoubleStream()


asElement

asElement o7planning.org
  • DeclaredType.asElement()
  • TypeVariable.asElement()
  • Types.asElement(TypeMirror)


asEndElement

asEndElement o7planning.org
  • XMLEvent.asEndElement()


asFileAttribute

asFileAttribute o7planning.org
  • PosixFilePermissions.asFileAttribute(Set<PosixFilePermission>)


asFixedArity

asFixedArity o7planning.org
  • MethodHandle.asFixedArity()


asFloatBuffer

asFloatBuffer o7planning.org
  • ByteBuffer.asFloatBuffer()


asin

asin o7planning.org
  • Math.asin(double)
  • StrictMath.asin(double)


asIntBuffer

asIntBuffer o7planning.org
  • ByteBuffer.asIntBuffer()


asInterfaceInstance

asInterfaceInstance o7planning.org
  • MethodHandleProxies.asInterfaceInstance(Class<T>, MethodHandle)


asksAllowsChildren

asksAllowsChildren o7planning.org
  • DefaultTreeModel.asksAllowsChildren()
  • DefaultTreeModel.asksAllowsChildren


asLifoQueue

asLifoQueue o7planning.org
  • Collections.asLifoQueue(Deque<T>)


asList

asList o7planning.org
  • Arrays.asList(T...)
  • AttributeList.asList()
  • RoleList.asList()
  • RoleUnresolvedList.asList()


asLongBuffer

asLongBuffer o7planning.org
  • ByteBuffer.asLongBuffer()


asLongStream

asLongStream o7planning.org
  • IntStream.asLongStream()


asMemberOf

asMemberOf o7planning.org
  • Types.asMemberOf(DeclaredType, Element)


asNormal

asNormal o7planning.org
  • TextStyle.asNormal()


asPredicate

asPredicate o7planning.org
  • Pattern.asPredicate()


asReadLock

asReadLock o7planning.org
  • StampedLock.asReadLock()


asReadOnlyBuffer

asReadOnlyBuffer o7planning.org
  • ByteBuffer.asReadOnlyBuffer()
  • CharBuffer.asReadOnlyBuffer()
  • DoubleBuffer.asReadOnlyBuffer()
  • FloatBuffer.asReadOnlyBuffer()
  • IntBuffer.asReadOnlyBuffer()
  • LongBuffer.asReadOnlyBuffer()
  • ShortBuffer.asReadOnlyBuffer()


asReadWriteLock

asReadWriteLock o7planning.org
  • StampedLock.asReadWriteLock()


assembleSystemMenu

assembleSystemMenu o7planning.org
  • BasicInternalFrameTitlePane.assembleSystemMenu()
  • MetalInternalFrameTitlePane.assembleSystemMenu()


AssertionError

AssertionError o7planning.org
  • AssertionError.AssertionError(String, Throwable)
  • AssertionError.AssertionError(double)
  • AssertionError.AssertionError(float)
  • AssertionError.AssertionError(long)
  • AssertionError.AssertionError(int)
  • AssertionError.AssertionError(char)
  • AssertionError.AssertionError(boolean)
  • AssertionError.AssertionError(Object)
  • AssertionError.AssertionError()


asShortBuffer

asShortBuffer o7planning.org
  • ByteBuffer.asShortBuffer()


assign

assign o7planning.org
  • DynAny.assign(DynAny)
  • DynAnyOperations.assign(DynAny)
  • _DynAnyStub.assign(DynAny)
  • _DynArrayStub.assign(DynAny)
  • _DynEnumStub.assign(DynAny)
  • _DynFixedStub.assign(DynAny)
  • _DynSequenceStub.assign(DynAny)
  • _DynStructStub.assign(DynAny)
  • _DynUnionStub.assign(DynAny)
  • _DynValueStub.assign(DynAny)


asSpreader

asSpreader o7planning.org
  • MethodHandle.asSpreader(Class<?>, int)


asStandalone

asStandalone o7planning.org
  • TextStyle.asStandalone()


asStartElement

asStartElement o7planning.org
  • XMLEvent.asStartElement()


asSubclass

asSubclass o7planning.org
  • Class.asSubclass(Class<U>)


assureRectsCreated

assureRectsCreated o7planning.org
  • BasicTabbedPaneUI.assureRectsCreated(int)


asType

asType o7planning.org
  • Element.asType()
  • MethodHandle.asType(MethodType)


asVarargsCollector

asVarargsCollector o7planning.org
  • MethodHandle.asVarargsCollector(Class<?>)


asWriteLock

asWriteLock o7planning.org
  • StampedLock.asWriteLock()


AsyncBoxView

AsyncBoxView o7planning.org
  • AsyncBoxView.AsyncBoxView(Element, int)


AsynchronousChannelGroup

AsynchronousChannelGroup o7planning.org
  • AsynchronousChannelGroup.AsynchronousChannelGroup(AsynchronousChannelProvider)


AsynchronousChannelProvider

AsynchronousChannelProvider o7planning.org
  • AsynchronousChannelProvider.AsynchronousChannelProvider()


AsynchronousCloseException

AsynchronousCloseException o7planning.org
  • AsynchronousCloseException.AsynchronousCloseException()


AsynchronousFileChannel

AsynchronousFileChannel o7planning.org
  • AsynchronousFileChannel.AsynchronousFileChannel()


AsynchronousServerSocketChannel

AsynchronousServerSocketChannel o7planning.org
  • AsynchronousServerSocketChannel.AsynchronousServerSocketChannel(AsynchronousChannelProvider)


AsynchronousSocketChannel

AsynchronousSocketChannel o7planning.org
  • AsynchronousSocketChannel.AsynchronousSocketChannel(AsynchronousChannelProvider)


AT_TARGET

AT_TARGET o7planning.org
  • Event.AT_TARGET


atan2

atan2 o7planning.org
  • Math.atan2(double, double)
  • StrictMath.atan2(double, double)


atan

atan o7planning.org
  • Math.atan(double)
  • StrictMath.atan(double)


atDate

atDate o7planning.org
  • LocalTime.atDate(LocalDate)
  • OffsetTime.atDate(LocalDate)


atDay

atDay o7planning.org
  • Year.atDay(int)
  • YearMonth.atDay(int)


atEndOfMonth

atEndOfMonth o7planning.org
  • YearMonth.atEndOfMonth()


atMonth

atMonth o7planning.org
  • Year.atMonth(int)
  • Year.atMonth(Month)


atMonthDay

atMonthDay o7planning.org
  • Year.atMonthDay(MonthDay)


atOffset

atOffset o7planning.org
  • Instant.atOffset(ZoneOffset)
  • LocalDateTime.atOffset(ZoneOffset)
  • LocalTime.atOffset(ZoneOffset)


AtomicBoolean

AtomicBoolean o7planning.org
  • AtomicBoolean.AtomicBoolean()
  • AtomicBoolean.AtomicBoolean(boolean)


AtomicInteger

AtomicInteger o7planning.org
  • AtomicInteger.AtomicInteger()
  • AtomicInteger.AtomicInteger(int)


AtomicIntegerArray

AtomicIntegerArray o7planning.org
  • AtomicIntegerArray.AtomicIntegerArray(int[])
  • AtomicIntegerArray.AtomicIntegerArray(int)


AtomicIntegerFieldUpdater

AtomicIntegerFieldUpdater o7planning.org
  • AtomicIntegerFieldUpdater.AtomicIntegerFieldUpdater()


AtomicLong

AtomicLong o7planning.org
  • AtomicLong.AtomicLong()
  • AtomicLong.AtomicLong(long)


AtomicLongArray

AtomicLongArray o7planning.org
  • AtomicLongArray.AtomicLongArray(long[])
  • AtomicLongArray.AtomicLongArray(int)


AtomicLongFieldUpdater

AtomicLongFieldUpdater o7planning.org
  • AtomicLongFieldUpdater.AtomicLongFieldUpdater()


AtomicMarkableReference

AtomicMarkableReference o7planning.org
  • AtomicMarkableReference.AtomicMarkableReference(V, boolean)


AtomicMoveNotSupportedException

AtomicMoveNotSupportedException o7planning.org
  • AtomicMoveNotSupportedException.AtomicMoveNotSupportedException(String, String, String)


AtomicReference

AtomicReference o7planning.org
  • AtomicReference.AtomicReference()
  • AtomicReference.AtomicReference(V)


AtomicReferenceArray

AtomicReferenceArray o7planning.org
  • AtomicReferenceArray.AtomicReferenceArray(E[])
  • AtomicReferenceArray.AtomicReferenceArray(int)


AtomicReferenceFieldUpdater

AtomicReferenceFieldUpdater o7planning.org
  • AtomicReferenceFieldUpdater.AtomicReferenceFieldUpdater()


AtomicStampedReference

AtomicStampedReference o7planning.org
  • AtomicStampedReference.AtomicStampedReference(V, int)


atStartOfDay

atStartOfDay o7planning.org
  • LocalDate.atStartOfDay(ZoneId)
  • LocalDate.atStartOfDay()


attach

attach o7planning.org
  • SelectionKey.attach(Object)


attachment

attachment o7planning.org
  • SelectionKey.attachment()


AttachmentMarshaller

AttachmentMarshaller o7planning.org
  • AttachmentMarshaller.AttachmentMarshaller()


AttachmentPart

AttachmentPart o7planning.org
  • AttachmentPart.AttachmentPart()


AttachmentUnmarshaller

AttachmentUnmarshaller o7planning.org
  • AttachmentUnmarshaller.AttachmentUnmarshaller()


ATTEMPTED

ATTEMPTED o7planning.org
  • PDLOverrideSupported.ATTEMPTED


attemptMark

attemptMark o7planning.org
  • AtomicMarkableReference.attemptMark(V, boolean)


attemptStamp

attemptStamp o7planning.org
  • AtomicStampedReference.attemptStamp(V, int)


atTime

atTime o7planning.org
  • ChronoLocalDate.atTime(LocalTime)
  • HijrahDate.atTime(LocalTime)
  • JapaneseDate.atTime(LocalTime)
  • LocalDate.atTime(OffsetTime)
  • LocalDate.atTime(int, int, int, int)
  • LocalDate.atTime(int, int, int)
  • LocalDate.atTime(int, int)
  • LocalDate.atTime(LocalTime)
  • MinguoDate.atTime(LocalTime)
  • ThaiBuddhistDate.atTime(LocalTime)


attr

attr o7planning.org
  • Query.attr(String, String)
  • Query.attr(String)


Attribute

Attribute o7planning.org
  • Attribute.Attribute(String, Object)
  • AttributedCharacterIterator.Attribute.Attribute(String)


ATTRIBUTE

ATTRIBUTE o7planning.org
  • XMLStreamConstants.ATTRIBUTE


attribute

attribute o7planning.org
  • W3CEndpointReferenceBuilder.attribute(QName, String)


ATTRIBUTE_CHANGE

ATTRIBUTE_CHANGE o7planning.org
  • AttributeChangeNotification.ATTRIBUTE_CHANGE


ATTRIBUTE_NODE

ATTRIBUTE_NODE o7planning.org
  • Node.ATTRIBUTE_NODE


ATTRIBUTE_RUN

ATTRIBUTE_RUN o7planning.org
  • AccessibleExtendedText.ATTRIBUTE_RUN


AttributeChangeNotification

AttributeChangeNotification o7planning.org
  • AttributeChangeNotification.AttributeChangeNotification(Object, long, long, String, String, String, Object, Object)


AttributeChangeNotificationFilter

AttributeChangeNotificationFilter o7planning.org
  • AttributeChangeNotificationFilter.AttributeChangeNotificationFilter()


attributeDecl

attributeDecl o7planning.org
  • DeclHandler.attributeDecl(String, String, String, String, String)
  • DefaultHandler2.attributeDecl(String, String, String, String, String)


AttributedString

AttributedString o7planning.org
  • AttributedString.AttributedString(AttributedCharacterIterator, int, int, AttributedCharacterIterator.Attribute[])
  • AttributedString.AttributedString(AttributedCharacterIterator, int, int)
  • AttributedString.AttributedString(AttributedCharacterIterator)
  • AttributedString.AttributedString(String, Map<? extends AttributedCharacterIterator.Attribute, ?>)
  • AttributedString.AttributedString(String)


AttributeInUseException

AttributeInUseException o7planning.org
  • AttributeInUseException.AttributeInUseException()
  • AttributeInUseException.AttributeInUseException(String)


AttributeList

AttributeList o7planning.org
  • AttributeList.AttributeList(String, int, int, String, Vector<?>, AttributeList)
  • AttributeList.AttributeList(String)
  • AttributeList.AttributeList(List<Attribute>)
  • AttributeList.AttributeList(AttributeList)
  • AttributeList.AttributeList(int)
  • AttributeList.AttributeList()


AttributeListImpl

AttributeListImpl o7planning.org
  • AttributeListImpl.AttributeListImpl(AttributeList)
  • AttributeListImpl.AttributeListImpl()


AttributeModificationException

AttributeModificationException o7planning.org
  • AttributeModificationException.AttributeModificationException()
  • AttributeModificationException.AttributeModificationException(String)


attributeNames

attributeNames o7planning.org
  • FeatureDescriptor.attributeNames()


attributeNoNulls

attributeNoNulls o7planning.org
  • DatabaseMetaData.attributeNoNulls


AttributeNotFoundException

AttributeNotFoundException o7planning.org
  • AttributeNotFoundException.AttributeNotFoundException(String)
  • AttributeNotFoundException.AttributeNotFoundException()


attributeNullable

attributeNullable o7planning.org
  • DatabaseMetaData.attributeNullable


attributeNullableUnknown

attributeNullableUnknown o7planning.org
  • DatabaseMetaData.attributeNullableUnknown


Attributes2Impl

Attributes2Impl o7planning.org
  • Attributes2Impl.Attributes2Impl(Attributes)
  • Attributes2Impl.Attributes2Impl()


Attributes

Attributes o7planning.org
  • Attributes.Attributes(Attributes)
  • Attributes.Attributes(int)
  • Attributes.Attributes()


attributes

attributes o7planning.org
  • AccessibleAttributeSequence.attributes


AttributesImpl

AttributesImpl o7planning.org
  • AttributesImpl.AttributesImpl(Attributes)
  • AttributesImpl.AttributesImpl()


AttributeUndoableEdit

AttributeUndoableEdit o7planning.org
  • DefaultStyledDocument.AttributeUndoableEdit.AttributeUndoableEdit(Element, AttributeSet, boolean)


attributeUpdate

attributeUpdate o7planning.org
  • PrintJobAttributeListener.attributeUpdate(PrintJobAttributeEvent)
  • PrintServiceAttributeListener.attributeUpdate(PrintServiceAttributeEvent)


AttributeValueExp

AttributeValueExp o7planning.org
  • AttributeValueExp.AttributeValueExp(String)
  • AttributeValueExp.AttributeValueExp()


attrID

attrID o7planning.org
  • BasicAttribute.attrID


atts

atts o7planning.org
  • Element.atts


atYear

atYear o7planning.org
  • MonthDay.atYear(int)


atZone

atZone o7planning.org
  • ChronoLocalDateTime.atZone(ZoneId)
  • Instant.atZone(ZoneId)
  • LocalDateTime.atZone(ZoneId)


atZoneSameInstant

atZoneSameInstant o7planning.org
  • OffsetDateTime.atZoneSameInstant(ZoneId)


atZoneSimilarLocal

atZoneSimilarLocal o7planning.org
  • OffsetDateTime.atZoneSimilarLocal(ZoneId)


AU

AU o7planning.org
  • AudioFileFormat.Type.AU


AudioFileFormat

AudioFileFormat o7planning.org
  • AudioFileFormat.AudioFileFormat(AudioFileFormat.Type, AudioFormat, int, Map<String, Object>)
  • AudioFileFormat.AudioFileFormat(AudioFileFormat.Type, AudioFormat, int)
  • AudioFileFormat.AudioFileFormat(AudioFileFormat.Type, int, AudioFormat, int)


AudioFileReader

AudioFileReader o7planning.org
  • AudioFileReader.AudioFileReader()


AudioFileWriter

AudioFileWriter o7planning.org
  • AudioFileWriter.AudioFileWriter()


AudioFormat

AudioFormat o7planning.org
  • AudioFormat.AudioFormat(float, int, int, boolean, boolean)
  • AudioFormat.AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean, Map<String, Object>)
  • AudioFormat.AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean)


AudioInputStream

AudioInputStream o7planning.org
  • AudioInputStream.AudioInputStream(TargetDataLine)
  • AudioInputStream.AudioInputStream(InputStream, AudioFormat, long)


AudioPermission

AudioPermission o7planning.org
  • AudioPermission.AudioPermission(String, String)
  • AudioPermission.AudioPermission(String)


augmentList

augmentList o7planning.org
  • TextAction.augmentList(Action[], Action[])


AUGUST

AUGUST o7planning.org
  • Calendar.AUGUST
  • DatatypeConstants.AUGUST


authenticate

authenticate o7planning.org
  • JMXAuthenticator.authenticate(Object)


AuthenticationException

AuthenticationException o7planning.org
  • AuthenticationException.AuthenticationException(String, Throwable)
  • AuthenticationException.AuthenticationException(String)
  • AuthenticationException.AuthenticationException()
  • AuthenticationException.AuthenticationException()
  • AuthenticationException.AuthenticationException(String)


AuthenticationNotSupportedException

AuthenticationNotSupportedException o7planning.org
  • AuthenticationNotSupportedException.AuthenticationNotSupportedException()
  • AuthenticationNotSupportedException.AuthenticationNotSupportedException(String)


Authenticator

Authenticator o7planning.org
  • Authenticator.Authenticator()


AUTHENTICATOR

AUTHENTICATOR o7planning.org
  • JMXConnectorServer.AUTHENTICATOR


AUTHORITATIVE

AUTHORITATIVE o7planning.org
  • Context.AUTHORITATIVE


AuthorizeCallback

AuthorizeCallback o7planning.org
  • AuthorizeCallback.AuthorizeCallback(String, String)


AuthPermission

AuthPermission o7planning.org
  • AuthPermission.AuthPermission(String, String)
  • AuthPermission.AuthPermission(String)


AuthProvider

AuthProvider o7planning.org
  • AuthProvider.AuthProvider(String, double, String)


AUTO_RESIZE_ALL_COLUMNS

AUTO_RESIZE_ALL_COLUMNS o7planning.org
  • JTable.AUTO_RESIZE_ALL_COLUMNS


AUTO_RESIZE_LAST_COLUMN

AUTO_RESIZE_LAST_COLUMN o7planning.org
  • JTable.AUTO_RESIZE_LAST_COLUMN


AUTO_RESIZE_NEXT_COLUMN

AUTO_RESIZE_NEXT_COLUMN o7planning.org
  • JTable.AUTO_RESIZE_NEXT_COLUMN


AUTO_RESIZE_OFF

AUTO_RESIZE_OFF o7planning.org
  • JTable.AUTO_RESIZE_OFF


AUTO_RESIZE_SUBSEQUENT_COLUMNS

AUTO_RESIZE_SUBSEQUENT_COLUMNS o7planning.org
  • JTable.AUTO_RESIZE_SUBSEQUENT_COLUMNS


autoCommitFailureClosesAllResultSets

autoCommitFailureClosesAllResultSets o7planning.org
  • DatabaseMetaData.autoCommitFailureClosesAllResultSets()


autoCreateColumnsFromModel

autoCreateColumnsFromModel o7planning.org
  • JTable.autoCreateColumnsFromModel


autoResizeMode

autoResizeMode o7planning.org
  • JTable.autoResizeMode


autoscroll

autoscroll o7planning.org
  • Autoscroll.autoscroll(Point)


autoScrollDown

autoScrollDown o7planning.org
  • BasicComboPopup.autoScrollDown()


autoscrollTimer

autoscrollTimer o7planning.org
  • BasicComboPopup.autoscrollTimer


autoScrollUp

autoScrollUp o7planning.org
  • BasicComboPopup.autoScrollUp()


AUTOSENSE

AUTOSENSE o7planning.org
  • DocFlavor.BYTE_ARRAY.AUTOSENSE
  • DocFlavor.INPUT_STREAM.AUTOSENSE
  • DocFlavor.URL.AUTOSENSE


AUX_RETURN

AUX_RETURN o7planning.org
  • FloatControl.Type.AUX_RETURN


AUX_SEND

AUX_SEND o7planning.org
  • FloatControl.Type.AUX_SEND


available

available o7planning.org
  • AudioInputStream.available()
  • BufferedInputStream.available()
  • ByteArrayInputStream.available()
  • CipherInputStream.available()
  • DataLine.available()
  • DeflaterInputStream.available()
  • FileInputStream.available()
  • FilterInputStream.available()
  • InflaterInputStream.available()
  • InputStream.available()
  • LineNumberInputStream.available()
  • ObjectInput.available()
  • ObjectInputStream.available()
  • PipedInputStream.available()
  • PushbackInputStream.available()
  • SequenceInputStream.available()
  • SocketImpl.available()
  • StringBufferInputStream.available()
  • ZipInputStream.available()


availableCharsets

availableCharsets o7planning.org
  • Charset.availableCharsets()


availableLocales

availableLocales o7planning.org
  • ImageReader.availableLocales
  • ImageWriter.availableLocales


availablePermits

availablePermits o7planning.org
  • Semaphore.availablePermits()


availableProcessors

availableProcessors o7planning.org
  • Runtime.availableProcessors()


average

average o7planning.org
  • DoubleStream.average()
  • IntStream.average()
  • LongStream.average()


averageBytesPerChar

averageBytesPerChar o7planning.org
  • CharsetEncoder.averageBytesPerChar()


averageCharsPerByte

averageCharsPerByte o7planning.org
  • CharsetDecoder.averageCharsPerByte()


averagingDouble

averagingDouble o7planning.org
  • Collectors.averagingDouble(ToDoubleFunction<? super T>)


averagingInt

averagingInt o7planning.org
  • Collectors.averagingInt(ToIntFunction<? super T>)


averagingLong

averagingLong o7planning.org
  • Collectors.averagingLong(ToLongFunction<? super T>)


AVESTAN

AVESTAN o7planning.org
  • Character.UnicodeBlock.AVESTAN


avoidingGui

avoidingGui o7planning.org
  • BeanContextSupport.avoidingGui()
  • Visibility.avoidingGui()


await

await o7planning.org
  • AbstractQueuedLongSynchronizer.ConditionObject.await(long, TimeUnit)
  • AbstractQueuedLongSynchronizer.ConditionObject.await()
  • AbstractQueuedSynchronizer.ConditionObject.await(long, TimeUnit)
  • AbstractQueuedSynchronizer.ConditionObject.await()
  • Condition.await(long, TimeUnit)
  • Condition.await()
  • CountDownLatch.await(long, TimeUnit)
  • CountDownLatch.await()
  • CyclicBarrier.await(long, TimeUnit)
  • CyclicBarrier.await()


awaitAdvance

awaitAdvance o7planning.org
  • Phaser.awaitAdvance(int)


awaitAdvanceInterruptibly

awaitAdvanceInterruptibly o7planning.org
  • Phaser.awaitAdvanceInterruptibly(int, long, TimeUnit)
  • Phaser.awaitAdvanceInterruptibly(int)


awaitNanos

awaitNanos o7planning.org
  • AbstractQueuedLongSynchronizer.ConditionObject.awaitNanos(long)
  • AbstractQueuedSynchronizer.ConditionObject.awaitNanos(long)
  • Condition.awaitNanos(long)


awaitQuiescence

awaitQuiescence o7planning.org
  • ForkJoinPool.awaitQuiescence(long, TimeUnit)


awaitTermination

awaitTermination o7planning.org
  • AsynchronousChannelGroup.awaitTermination(long, TimeUnit)
  • ExecutorService.awaitTermination(long, TimeUnit)
  • ForkJoinPool.awaitTermination(long, TimeUnit)
  • ThreadPoolExecutor.awaitTermination(long, TimeUnit)


awaitUninterruptibly

awaitUninterruptibly o7planning.org
  • AbstractQueuedLongSynchronizer.ConditionObject.awaitUninterruptibly()
  • AbstractQueuedSynchronizer.ConditionObject.awaitUninterruptibly()
  • Condition.awaitUninterruptibly()


awaitUntil

awaitUntil o7planning.org
  • AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil(Date)
  • AbstractQueuedSynchronizer.ConditionObject.awaitUntil(Date)
  • Condition.awaitUntil(Date)


AWT_COMPONENT

AWT_COMPONENT o7planning.org
  • AccessibleRole.AWT_COMPONENT


AWTError

AWTError o7planning.org
  • AWTError.AWTError(String)


AWTEvent

AWTEvent o7planning.org
  • AWTEvent.AWTEvent(Object, int)
  • AWTEvent.AWTEvent(Event)


AWTEventListenerProxy

AWTEventListenerProxy o7planning.org
  • AWTEventListenerProxy.AWTEventListenerProxy(long, AWTEventListener)


AWTEventMulticaster

AWTEventMulticaster o7planning.org
  • AWTEventMulticaster.AWTEventMulticaster(EventListener, EventListener)


AWTException

AWTException o7planning.org
  • AWTException.AWTException(String)


AWTKeyStroke

AWTKeyStroke o7planning.org
  • AWTKeyStroke.AWTKeyStroke(char, int, int, boolean)
  • AWTKeyStroke.AWTKeyStroke()


AWTPermission

AWTPermission o7planning.org
  • AWTPermission.AWTPermission(String, String)
  • AWTPermission.AWTPermission(String)


B0

B0 o7planning.org
  • MediaSize.ISO.B0
  • MediaSize.JIS.B0
  • PageAttributes.MediaType.B0


B1

B1 o7planning.org
  • MediaSize.ISO.B1
  • MediaSize.JIS.B1
  • PageAttributes.MediaType.B1


B2

B2 o7planning.org
  • MediaSize.ISO.B2
  • MediaSize.JIS.B2
  • PageAttributes.MediaType.B2


B3

B3 o7planning.org
  • MediaSize.ISO.B3
  • MediaSize.JIS.B3
  • PageAttributes.MediaType.B3


B4

B4 o7planning.org
  • MediaSize.ISO.B4
  • MediaSize.JIS.B4
  • PageAttributes.MediaType.B4


B5

B5 o7planning.org
  • MediaSize.ISO.B5
  • MediaSize.JIS.B5
  • PageAttributes.MediaType.B5


B6

B6 o7planning.org
  • MediaSize.ISO.B6
  • MediaSize.JIS.B6
  • PageAttributes.MediaType.B6


B7

B7 o7planning.org
  • MediaSize.ISO.B7
  • MediaSize.JIS.B7
  • PageAttributes.MediaType.B7


B8

B8 o7planning.org
  • MediaSize.ISO.B8
  • MediaSize.JIS.B8
  • PageAttributes.MediaType.B8


B9

B9 o7planning.org
  • MediaSize.ISO.B9
  • MediaSize.JIS.B9
  • PageAttributes.MediaType.B9


B10

B10 o7planning.org
  • MediaSize.ISO.B10
  • MediaSize.JIS.B10
  • PageAttributes.MediaType.B10


b

b o7planning.org
  • AWTEventMulticaster.b


B

B o7planning.org
  • HTML.Tag.B
  • MediaSize.Engineering.B
  • MediaSizeName.B
  • PageAttributes.MediaType.B


BACK_SPACE

BACK_SPACE o7planning.org
  • Event.BACK_SPACE


backBuffers

backBuffers o7planning.org
  • Component.BltBufferStrategy.backBuffers


BACKGROUND

BACKGROUND o7planning.org
  • BufferCapabilities.FlipContents.BACKGROUND
  • CSS.Attribute.BACKGROUND
  • ColorType.BACKGROUND
  • HTML.Attribute.BACKGROUND
  • TextAttribute.BACKGROUND


Background

Background o7planning.org
  • StyleConstants.Background


BACKGROUND_ATTACHMENT

BACKGROUND_ATTACHMENT o7planning.org
  • CSS.Attribute.BACKGROUND_ATTACHMENT


BACKGROUND_COLOR

BACKGROUND_COLOR o7planning.org
  • CSS.Attribute.BACKGROUND_COLOR


BACKGROUND_IMAGE

BACKGROUND_IMAGE o7planning.org
  • CSS.Attribute.BACKGROUND_IMAGE


BACKGROUND_POSITION

BACKGROUND_POSITION o7planning.org
  • CSS.Attribute.BACKGROUND_POSITION


BACKGROUND_REPEAT

BACKGROUND_REPEAT o7planning.org
  • CSS.Attribute.BACKGROUND_REPEAT


backgroundNonSelectionColor

backgroundNonSelectionColor o7planning.org
  • DefaultTreeCellRenderer.backgroundNonSelectionColor


backgroundSelectionColor

backgroundSelectionColor o7planning.org
  • DefaultTreeCellRenderer.backgroundSelectionColor


backingStore

backingStore o7planning.org
  • JViewport.backingStore


BACKINGSTORE_SCROLL_MODE

BACKINGSTORE_SCROLL_MODE o7planning.org
  • JViewport.BACKINGSTORE_SCROLL_MODE


BackingStoreException

BackingStoreException o7planning.org
  • BackingStoreException.BackingStoreException(Throwable)
  • BackingStoreException.BackingStoreException(String)


backingStoreImage

backingStoreImage o7planning.org
  • JViewport.backingStoreImage


Backward

Backward o7planning.org
  • Position.Bias.Backward


BACKWARD_TRAVERSAL_KEYS

BACKWARD_TRAVERSAL_KEYS o7planning.org
  • KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS


backwardAction

backwardAction o7planning.org
  • DefaultEditorKit.backwardAction


BAD_BINDINGS

BAD_BINDINGS o7planning.org
  • GSSException.BAD_BINDINGS


BAD_CONTEXT

BAD_CONTEXT o7planning.org
  • BAD_CONTEXT.BAD_CONTEXT(String, int, CompletionStatus)
  • BAD_CONTEXT.BAD_CONTEXT(int, CompletionStatus)
  • BAD_CONTEXT.BAD_CONTEXT(String)
  • BAD_CONTEXT.BAD_CONTEXT()


BAD_INV_ORDER

BAD_INV_ORDER o7planning.org
  • BAD_INV_ORDER.BAD_INV_ORDER(String, int, CompletionStatus)
  • BAD_INV_ORDER.BAD_INV_ORDER(int, CompletionStatus)
  • BAD_INV_ORDER.BAD_INV_ORDER(String)
  • BAD_INV_ORDER.BAD_INV_ORDER()


BAD_LOCATION

BAD_LOCATION o7planning.org
  • AbstractDocument.BAD_LOCATION


BAD_MECH

BAD_MECH o7planning.org
  • GSSException.BAD_MECH


BAD_MIC

BAD_MIC o7planning.org
  • GSSException.BAD_MIC


BAD_NAME

BAD_NAME o7planning.org
  • GSSException.BAD_NAME


BAD_NAMETYPE

BAD_NAMETYPE o7planning.org
  • GSSException.BAD_NAMETYPE


BAD_OPERATION

BAD_OPERATION o7planning.org
  • BAD_OPERATION.BAD_OPERATION(String, int, CompletionStatus)
  • BAD_OPERATION.BAD_OPERATION(int, CompletionStatus)
  • BAD_OPERATION.BAD_OPERATION(String)
  • BAD_OPERATION.BAD_OPERATION()


BAD_PARAM

BAD_PARAM o7planning.org
  • BAD_PARAM.BAD_PARAM(String, int, CompletionStatus)
  • BAD_PARAM.BAD_PARAM(int, CompletionStatus)
  • BAD_PARAM.BAD_PARAM(String)
  • BAD_PARAM.BAD_PARAM()


BAD_QOP

BAD_QOP o7planning.org
  • GSSException.BAD_QOP


BAD_QOS

BAD_QOS o7planning.org
  • BAD_QOS.BAD_QOS(String, int, CompletionStatus)
  • BAD_QOS.BAD_QOS(int, CompletionStatus)
  • BAD_QOS.BAD_QOS(String)
  • BAD_QOS.BAD_QOS()


BAD_STATUS

BAD_STATUS o7planning.org
  • GSSException.BAD_STATUS


BAD_TYPECODE

BAD_TYPECODE o7planning.org
  • BAD_TYPECODE.BAD_TYPECODE(String, int, CompletionStatus)
  • BAD_TYPECODE.BAD_TYPECODE(int, CompletionStatus)
  • BAD_TYPECODE.BAD_TYPECODE(String)
  • BAD_TYPECODE.BAD_TYPECODE()


BadAttributeValueExpException

BadAttributeValueExpException o7planning.org
  • BadAttributeValueExpException.BadAttributeValueExpException(Object)


BadBinaryOpValueExpException

BadBinaryOpValueExpException o7planning.org
  • BadBinaryOpValueExpException.BadBinaryOpValueExpException(ValueExp)


BadBreakWeight

BadBreakWeight o7planning.org
  • View.BadBreakWeight


BadKind

BadKind o7planning.org
  • BadKind.BadKind(String)
  • BadKind.BadKind()


BadLocationException

BadLocationException o7planning.org
  • BadLocationException.BadLocationException(String, int)


BadPaddingException

BadPaddingException o7planning.org
  • BadPaddingException.BadPaddingException(String)
  • BadPaddingException.BadPaddingException()


BadStringOperationException

BadStringOperationException o7planning.org
  • BadStringOperationException.BadStringOperationException(String)


BALANCE

BALANCE o7planning.org
  • FloatControl.Type.BALANCE


BALINESE

BALINESE o7planning.org
  • Character.UnicodeBlock.BALINESE


BAMUM

BAMUM o7planning.org
  • Character.UnicodeBlock.BAMUM


BAMUM_SUPPLEMENT

BAMUM_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.BAMUM_SUPPLEMENT


BandCombineOp

BandCombineOp o7planning.org
  • BandCombineOp.BandCombineOp(float[][], RenderingHints)


BandedSampleModel

BandedSampleModel o7planning.org
  • BandedSampleModel.BandedSampleModel(int, int, int, int, int[], int[])
  • BandedSampleModel.BandedSampleModel(int, int, int, int)


bandOffsets

bandOffsets o7planning.org
  • ComponentSampleModel.bandOffsets


bank

bank o7planning.org
  • VoiceStatus.bank


bankIndices

bankIndices o7planning.org
  • ComponentSampleModel.bankIndices


banks

banks o7planning.org
  • DataBuffer.banks


BASE64

BASE64 o7planning.org
  • Transform.BASE64


BASE

BASE o7planning.org
  • HTML.Tag.BASE


base

base o7planning.org
  • DTD.base


BASEFONT

BASEFONT o7planning.org
  • HTML.Tag.BASEFONT


baseIsLeftToRight

baseIsLeftToRight o7planning.org
  • Bidi.baseIsLeftToRight()


BASELINE

BASELINE o7planning.org
  • GridBagConstraints.BASELINE
  • SpringLayout.BASELINE


BASELINE_LEADING

BASELINE_LEADING o7planning.org
  • GridBagConstraints.BASELINE_LEADING


BASELINE_TRAILING

BASELINE_TRAILING o7planning.org
  • GridBagConstraints.BASELINE_TRAILING


baselineLayout

baselineLayout o7planning.org
  • BoxView.baselineLayout(int, int, int[], int[])


baselineRequirements

baselineRequirements o7planning.org
  • BoxView.baselineRequirements(int, SizeRequirements)


BaseRowSet

BaseRowSet o7planning.org
  • BaseRowSet.BaseRowSet()


baseWireHandle

baseWireHandle o7planning.org
  • ObjectStreamConstants.baseWireHandle


BASIC_ISO_DATE

BASIC_ISO_DATE o7planning.org
  • DateTimeFormatter.BASIC_ISO_DATE


BASIC_LATIN

BASIC_LATIN o7planning.org
  • Character.UnicodeBlock.BASIC_LATIN


BasicArrowButton

BasicArrowButton o7planning.org
  • BasicArrowButton.BasicArrowButton(int)
  • BasicArrowButton.BasicArrowButton(int, Color, Color, Color, Color)


BasicAttribute

BasicAttribute o7planning.org
  • BasicAttribute.BasicAttribute(String, Object, boolean)
  • BasicAttribute.BasicAttribute(String, boolean)
  • BasicAttribute.BasicAttribute(String, Object)
  • BasicAttribute.BasicAttribute(String)


BasicAttributes

BasicAttributes o7planning.org
  • BasicAttributes.BasicAttributes(String, Object, boolean)
  • BasicAttributes.BasicAttributes(String, Object)
  • BasicAttributes.BasicAttributes(boolean)
  • BasicAttributes.BasicAttributes()


BasicBorders

BasicBorders o7planning.org
  • BasicBorders.BasicBorders()


BasicButtonListener

BasicButtonListener o7planning.org
  • BasicButtonListener.BasicButtonListener(AbstractButton)


BasicButtonUI

BasicButtonUI o7planning.org
  • BasicButtonUI.BasicButtonUI()


BasicCaret

BasicCaret o7planning.org
  • BasicTextUI.BasicCaret.BasicCaret()


BasicCheckBoxMenuItemUI

BasicCheckBoxMenuItemUI o7planning.org
  • BasicCheckBoxMenuItemUI.BasicCheckBoxMenuItemUI()


BasicCheckBoxUI

BasicCheckBoxUI o7planning.org
  • BasicCheckBoxUI.BasicCheckBoxUI()


BasicColorChooserUI

BasicColorChooserUI o7planning.org
  • BasicColorChooserUI.BasicColorChooserUI()


BasicComboBoxEditor

BasicComboBoxEditor o7planning.org
  • BasicComboBoxEditor.BasicComboBoxEditor()


BasicComboBoxRenderer

BasicComboBoxRenderer o7planning.org
  • BasicComboBoxRenderer.BasicComboBoxRenderer()


BasicComboBoxUI

BasicComboBoxUI o7planning.org
  • BasicComboBoxUI.BasicComboBoxUI()


BasicComboPopup

BasicComboPopup o7planning.org
  • BasicComboPopup.BasicComboPopup(JComboBox)


BasicControl

BasicControl o7planning.org
  • BasicControl.BasicControl(String, boolean, byte[])
  • BasicControl.BasicControl(String)


BasicDesktopIconUI

BasicDesktopIconUI o7planning.org
  • BasicDesktopIconUI.BasicDesktopIconUI()


BasicDesktopPaneUI

BasicDesktopPaneUI o7planning.org
  • BasicDesktopPaneUI.BasicDesktopPaneUI()


BasicDirectoryModel

BasicDirectoryModel o7planning.org
  • BasicDirectoryModel.BasicDirectoryModel(JFileChooser)


BasicEditorPaneUI

BasicEditorPaneUI o7planning.org
  • BasicEditorPaneUI.BasicEditorPaneUI()


BasicFileChooserUI

BasicFileChooserUI o7planning.org
  • BasicFileChooserUI.BasicFileChooserUI(JFileChooser)


BasicFileView

BasicFileView o7planning.org
  • BasicFileChooserUI.BasicFileView.BasicFileView()


BasicFormattedTextFieldUI

BasicFormattedTextFieldUI o7planning.org
  • BasicFormattedTextFieldUI.BasicFormattedTextFieldUI()


BasicGraphicsUtils

BasicGraphicsUtils o7planning.org
  • BasicGraphicsUtils.BasicGraphicsUtils()


BasicHighlighter

BasicHighlighter o7planning.org
  • BasicTextUI.BasicHighlighter.BasicHighlighter()


BasicHTML

BasicHTML o7planning.org
  • BasicHTML.BasicHTML()


BasicIconFactory

BasicIconFactory o7planning.org
  • BasicIconFactory.BasicIconFactory()


BasicInternalFrameListener

BasicInternalFrameListener o7planning.org
  • BasicInternalFrameUI.BasicInternalFrameListener.BasicInternalFrameListener()


BasicInternalFrameTitlePane

BasicInternalFrameTitlePane o7planning.org
  • BasicInternalFrameTitlePane.BasicInternalFrameTitlePane(JInternalFrame)


BasicInternalFrameUI

BasicInternalFrameUI o7planning.org
  • BasicInternalFrameUI.BasicInternalFrameUI(JInternalFrame)


BasicLabelUI

BasicLabelUI o7planning.org
  • BasicLabelUI.BasicLabelUI()


BasicListUI

BasicListUI o7planning.org
  • BasicListUI.BasicListUI()


BasicLookAndFeel

BasicLookAndFeel o7planning.org
  • BasicLookAndFeel.BasicLookAndFeel()


BasicMenuBarUI

BasicMenuBarUI o7planning.org
  • BasicMenuBarUI.BasicMenuBarUI()


BasicMenuItemUI

BasicMenuItemUI o7planning.org
  • BasicMenuItemUI.BasicMenuItemUI()


BasicMenuUI

BasicMenuUI o7planning.org
  • BasicMenuUI.BasicMenuUI()


BasicOptionPaneUI

BasicOptionPaneUI o7planning.org
  • BasicOptionPaneUI.BasicOptionPaneUI()


BasicPanelUI

BasicPanelUI o7planning.org
  • BasicPanelUI.BasicPanelUI()


BasicPasswordFieldUI

BasicPasswordFieldUI o7planning.org
  • BasicPasswordFieldUI.BasicPasswordFieldUI()


BasicPermission

BasicPermission o7planning.org
  • BasicPermission.BasicPermission(String, String)
  • BasicPermission.BasicPermission(String)


BasicPopupMenuSeparatorUI

BasicPopupMenuSeparatorUI o7planning.org
  • BasicPopupMenuSeparatorUI.BasicPopupMenuSeparatorUI()


BasicPopupMenuUI

BasicPopupMenuUI o7planning.org
  • BasicPopupMenuUI.BasicPopupMenuUI()


BasicProgressBarUI

BasicProgressBarUI o7planning.org
  • BasicProgressBarUI.BasicProgressBarUI()


BasicRadioButtonMenuItemUI

BasicRadioButtonMenuItemUI o7planning.org
  • BasicRadioButtonMenuItemUI.BasicRadioButtonMenuItemUI()


BasicRadioButtonUI

BasicRadioButtonUI o7planning.org
  • BasicRadioButtonUI.BasicRadioButtonUI()


BasicRootPaneUI

BasicRootPaneUI o7planning.org
  • BasicRootPaneUI.BasicRootPaneUI()


BasicScrollBarUI

BasicScrollBarUI o7planning.org
  • BasicScrollBarUI.BasicScrollBarUI()


BasicScrollPaneUI

BasicScrollPaneUI o7planning.org
  • BasicScrollPaneUI.BasicScrollPaneUI()


BasicSeparatorUI

BasicSeparatorUI o7planning.org
  • BasicSeparatorUI.BasicSeparatorUI()


BasicSliderUI

BasicSliderUI o7planning.org
  • BasicSliderUI.BasicSliderUI(JSlider)


BasicSpinnerUI

BasicSpinnerUI o7planning.org
  • BasicSpinnerUI.BasicSpinnerUI()


BasicSplitPaneDivider

BasicSplitPaneDivider o7planning.org
  • BasicSplitPaneDivider.BasicSplitPaneDivider(BasicSplitPaneUI)


BasicSplitPaneUI

BasicSplitPaneUI o7planning.org
  • BasicSplitPaneUI.BasicSplitPaneUI()


BasicStroke

BasicStroke o7planning.org
  • BasicStroke.BasicStroke()
  • BasicStroke.BasicStroke(float)
  • BasicStroke.BasicStroke(float, int, int)
  • BasicStroke.BasicStroke(float, int, int, float)
  • BasicStroke.BasicStroke(float, int, int, float, float[], float)


BasicTabbedPaneUI

BasicTabbedPaneUI o7planning.org
  • BasicTabbedPaneUI.BasicTabbedPaneUI()


BasicTableHeaderUI

BasicTableHeaderUI o7planning.org
  • BasicTableHeaderUI.BasicTableHeaderUI()


BasicTableUI

BasicTableUI o7planning.org
  • BasicTableUI.BasicTableUI()


BasicTextAreaUI

BasicTextAreaUI o7planning.org
  • BasicTextAreaUI.BasicTextAreaUI()


BasicTextFieldUI

BasicTextFieldUI o7planning.org
  • BasicTextFieldUI.BasicTextFieldUI()


BasicTextPaneUI

BasicTextPaneUI o7planning.org
  • BasicTextPaneUI.BasicTextPaneUI()


BasicTextUI

BasicTextUI o7planning.org
  • BasicTextUI.BasicTextUI()


BasicToggleButtonUI

BasicToggleButtonUI o7planning.org
  • BasicToggleButtonUI.BasicToggleButtonUI()


BasicToolBarSeparatorUI

BasicToolBarSeparatorUI o7planning.org
  • BasicToolBarSeparatorUI.BasicToolBarSeparatorUI()


BasicToolBarUI

BasicToolBarUI o7planning.org
  • BasicToolBarUI.BasicToolBarUI()


BasicToolTipUI

BasicToolTipUI o7planning.org
  • BasicToolTipUI.BasicToolTipUI()


BasicTreeUI

BasicTreeUI o7planning.org
  • BasicTreeUI.BasicTreeUI()


BasicVerticalLayoutManager

BasicVerticalLayoutManager o7planning.org
  • BasicSplitPaneUI.BasicVerticalLayoutManager.BasicVerticalLayoutManager()


BasicViewportUI

BasicViewportUI o7planning.org
  • BasicViewportUI.BasicViewportUI()


BATAK

BATAK o7planning.org
  • Character.UnicodeBlock.BATAK


BATCHSIZE

BATCHSIZE o7planning.org
  • Context.BATCHSIZE


BatchUpdateException

BatchUpdateException o7planning.org
  • BatchUpdateException.BatchUpdateException(String, String, int, long[], Throwable)
  • BatchUpdateException.BatchUpdateException(String, String, int, int[], Throwable)
  • BatchUpdateException.BatchUpdateException(String, String, int[], Throwable)
  • BatchUpdateException.BatchUpdateException(String, int[], Throwable)
  • BatchUpdateException.BatchUpdateException(int[], Throwable)
  • BatchUpdateException.BatchUpdateException(Throwable)
  • BatchUpdateException.BatchUpdateException()
  • BatchUpdateException.BatchUpdateException(int[])
  • BatchUpdateException.BatchUpdateException(String, int[])
  • BatchUpdateException.BatchUpdateException(String, String, int[])
  • BatchUpdateException.BatchUpdateException(String, String, int, int[])


BC

BC o7planning.org
  • GregorianCalendar.BC


bcmListeners

bcmListeners o7planning.org
  • BeanContextSupport.bcmListeners


bcsChildren

bcsChildren o7planning.org
  • BeanContextSupport.bcsChildren()


bcsListeners

bcsListeners o7planning.org
  • BeanContextServicesSupport.bcsListeners


bcsPreDeserializationHook

bcsPreDeserializationHook o7planning.org
  • BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream)
  • BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream)


bcsPreSerializationHook

bcsPreSerializationHook o7planning.org
  • BeanContextServicesSupport.bcsPreSerializationHook(ObjectOutputStream)
  • BeanContextSupport.bcsPreSerializationHook(ObjectOutputStream)


beanContext

beanContext o7planning.org
  • BeanContextChildSupport.beanContext


beanContextChildPeer

beanContextChildPeer o7planning.org
  • BeanContextChildSupport.beanContextChildPeer


BeanContextChildSupport

BeanContextChildSupport o7planning.org
  • BeanContextChildSupport.BeanContextChildSupport(BeanContextChild)
  • BeanContextChildSupport.BeanContextChildSupport()


BeanContextEvent

BeanContextEvent o7planning.org
  • BeanContextEvent.BeanContextEvent(BeanContext)


BeanContextMembershipEvent

BeanContextMembershipEvent o7planning.org
  • BeanContextMembershipEvent.BeanContextMembershipEvent(BeanContext, Object[])
  • BeanContextMembershipEvent.BeanContextMembershipEvent(BeanContext, Collection)


BeanContextServiceAvailableEvent

BeanContextServiceAvailableEvent o7planning.org
  • BeanContextServiceAvailableEvent.BeanContextServiceAvailableEvent(BeanContextServices, Class)


BeanContextServiceRevokedEvent

BeanContextServiceRevokedEvent o7planning.org
  • BeanContextServiceRevokedEvent.BeanContextServiceRevokedEvent(BeanContextServices, Class, boolean)


BeanContextServicesSupport

BeanContextServicesSupport o7planning.org
  • BeanContextServicesSupport.BeanContextServicesSupport()
  • BeanContextServicesSupport.BeanContextServicesSupport(BeanContextServices)
  • BeanContextServicesSupport.BeanContextServicesSupport(BeanContextServices, Locale)
  • BeanContextServicesSupport.BeanContextServicesSupport(BeanContextServices, Locale, boolean)
  • BeanContextServicesSupport.BeanContextServicesSupport(BeanContextServices, Locale, boolean, boolean)


BeanContextSupport

BeanContextSupport o7planning.org
  • BeanContextSupport.BeanContextSupport()
  • BeanContextSupport.BeanContextSupport(BeanContext)
  • BeanContextSupport.BeanContextSupport(BeanContext, Locale)
  • BeanContextSupport.BeanContextSupport(BeanContext, Locale, boolean)
  • BeanContextSupport.BeanContextSupport(BeanContext, Locale, boolean, boolean)


BeanDescriptor

BeanDescriptor o7planning.org
  • BeanDescriptor.BeanDescriptor(Class<?>, Class<?>)
  • BeanDescriptor.BeanDescriptor(Class<?>)


Beans

Beans o7planning.org
  • Beans.Beans()


beep

beep o7planning.org
  • Toolkit.beep()


beepAction

beepAction o7planning.org
  • DefaultEditorKit.beepAction


BeepAction

BeepAction o7planning.org
  • DefaultEditorKit.BeepAction.BeepAction()


before

before o7planning.org
  • Calendar.before(Object)
  • Date.before(Date)
  • Timestamp.before(Timestamp)


BEFORE_FIRST_LINE

BEFORE_FIRST_LINE o7planning.org
  • BorderLayout.BEFORE_FIRST_LINE


BEFORE_LINE_BEGINS

BEFORE_LINE_BEGINS o7planning.org
  • BorderLayout.BEFORE_LINE_BEGINS


beforeExecute

beforeExecute o7planning.org
  • ThreadPoolExecutor.beforeExecute(Thread, Runnable)


beforeFirst

beforeFirst o7planning.org
  • ResultSet.beforeFirst()


beforeMarshal

beforeMarshal o7planning.org
  • Marshaller.Listener.beforeMarshal(Object)


beforeOffset

beforeOffset o7planning.org
  • TextHitInfo.beforeOffset(int)


beforeUnmarshal

beforeUnmarshal o7planning.org
  • Unmarshaller.Listener.beforeUnmarshal(Object, Object)


begin

begin o7planning.org
  • AbstractInterruptibleChannel.begin()
  • AbstractSelector.begin()


beginAction

beginAction o7planning.org
  • DefaultEditorKit.beginAction


beginDragDividerLocation

beginDragDividerLocation o7planning.org
  • BasicSplitPaneUI.beginDragDividerLocation


beginDraggingFrame

beginDraggingFrame o7planning.org
  • DefaultDesktopManager.beginDraggingFrame(JComponent)
  • DesktopManager.beginDraggingFrame(JComponent)


beginHandshake

beginHandshake o7planning.org
  • SSLEngine.beginHandshake()


beginLineAction

beginLineAction o7planning.org
  • DefaultEditorKit.beginLineAction


beginParagraphAction

beginParagraphAction o7planning.org
  • DefaultEditorKit.beginParagraphAction


beginResizingFrame

beginResizingFrame o7planning.org
  • DefaultDesktopManager.beginResizingFrame(JComponent, int)
  • DesktopManager.beginResizingFrame(JComponent, int)


beginUpdate

beginUpdate o7planning.org
  • UndoableEditSupport.beginUpdate()


beginWordAction

beginWordAction o7planning.org
  • DefaultEditorKit.beginWordAction


BELOW_BASELINE

BELOW_BASELINE o7planning.org
  • GridBagConstraints.BELOW_BASELINE


BELOW_BASELINE_LEADING

BELOW_BASELINE_LEADING o7planning.org
  • GridBagConstraints.BELOW_BASELINE_LEADING


BELOW_BASELINE_TRAILING

BELOW_BASELINE_TRAILING o7planning.org
  • GridBagConstraints.BELOW_BASELINE_TRAILING


BELOW_BOTTOM

BELOW_BOTTOM o7planning.org
  • TitledBorder.BELOW_BOTTOM


BELOW_TOP

BELOW_TOP o7planning.org
  • TitledBorder.BELOW_TOP


BENGALI

BENGALI o7planning.org
  • Character.UnicodeBlock.BENGALI
  • NumericShaper.BENGALI


BEST_COMPRESSION

BEST_COMPRESSION o7planning.org
  • Deflater.BEST_COMPRESSION


BEST_SPEED

BEST_SPEED o7planning.org
  • Deflater.BEST_SPEED


bestRowNotPseudo

bestRowNotPseudo o7planning.org
  • DatabaseMetaData.bestRowNotPseudo


bestRowPseudo

bestRowPseudo o7planning.org
  • DatabaseMetaData.bestRowPseudo


bestRowSession

bestRowSession o7planning.org
  • DatabaseMetaData.bestRowSession


bestRowTemporary

bestRowTemporary o7planning.org
  • DatabaseMetaData.bestRowTemporary


bestRowTransaction

bestRowTransaction o7planning.org
  • DatabaseMetaData.bestRowTransaction


bestRowUnknown

bestRowUnknown o7planning.org
  • DatabaseMetaData.bestRowUnknown


between

between o7planning.org
  • ChronoPeriod.between(ChronoLocalDate, ChronoLocalDate)
  • ChronoUnit.between(Temporal, Temporal)
  • Duration.between(Temporal, Temporal)
  • Period.between(LocalDate, LocalDate)
  • Query.between(ValueExp, ValueExp, ValueExp)
  • TemporalUnit.between(Temporal, Temporal)


BevelBorder

BevelBorder o7planning.org
  • BevelBorder.BevelBorder(int, Color, Color, Color, Color)
  • BevelBorder.BevelBorder(int, Color, Color)
  • BevelBorder.BevelBorder(int)


BevelBorderUIResource

BevelBorderUIResource o7planning.org
  • BorderUIResource.BevelBorderUIResource.BevelBorderUIResource(int, Color, Color, Color, Color)
  • BorderUIResource.BevelBorderUIResource.BevelBorderUIResource(int, Color, Color)
  • BorderUIResource.BevelBorderUIResource.BevelBorderUIResource(int)


bevelType

bevelType o7planning.org
  • BevelBorder.bevelType


BGCOLOR

BGCOLOR o7planning.org
  • HTML.Attribute.BGCOLOR


Bidi

Bidi o7planning.org
  • Bidi.Bidi(char[], int, byte[], int, int, int)
  • Bidi.Bidi(AttributedCharacterIterator)
  • Bidi.Bidi(String, int)


BIDI_EMBEDDING

BIDI_EMBEDDING o7planning.org
  • TextAttribute.BIDI_EMBEDDING


BidiElementName

BidiElementName o7planning.org
  • AbstractDocument.BidiElementName


BidiLevel

BidiLevel o7planning.org
  • StyleConstants.BidiLevel


BIG

BIG o7planning.org
  • HTML.Tag.BIG


BIG_ENDIAN

BIG_ENDIAN o7planning.org
  • ByteOrder.BIG_ENDIAN


BigDecimal

BigDecimal o7planning.org
  • BigDecimal.BigDecimal(long, MathContext)
  • BigDecimal.BigDecimal(long)
  • BigDecimal.BigDecimal(int, MathContext)
  • BigDecimal.BigDecimal(int)
  • BigDecimal.BigDecimal(BigInteger, int, MathContext)
  • BigDecimal.BigDecimal(BigInteger, int)
  • BigDecimal.BigDecimal(BigInteger, MathContext)
  • BigDecimal.BigDecimal(BigInteger)
  • BigDecimal.BigDecimal(double, MathContext)
  • BigDecimal.BigDecimal(double)
  • BigDecimal.BigDecimal(String, MathContext)
  • BigDecimal.BigDecimal(String)
  • BigDecimal.BigDecimal(char[], MathContext)
  • BigDecimal.BigDecimal(char[])
  • BigDecimal.BigDecimal(char[], int, int, MathContext)
  • BigDecimal.BigDecimal(char[], int, int)


BIGDECIMAL

BIGDECIMAL o7planning.org
  • SimpleType.BIGDECIMAL


bigEndian

bigEndian o7planning.org
  • AudioFormat.bigEndian


BIGINT

BIGINT o7planning.org
  • Types.BIGINT


BigInteger

BigInteger o7planning.org
  • BigInteger.BigInteger(int, int, Random)
  • BigInteger.BigInteger(int, Random)
  • BigInteger.BigInteger(String)
  • BigInteger.BigInteger(String, int)
  • BigInteger.BigInteger(int, byte[])
  • BigInteger.BigInteger(byte[])


BIGINTEGER

BIGINTEGER o7planning.org
  • SimpleType.BIGINTEGER


BINARY

BINARY o7planning.org
  • Types.BINARY


BINARY_STREAM_PARAM

BINARY_STREAM_PARAM o7planning.org
  • BaseRowSet.BINARY_STREAM_PARAM


BinaryRefAddr

BinaryRefAddr o7planning.org
  • BinaryRefAddr.BinaryRefAddr(String, byte[], int, int)
  • BinaryRefAddr.BinaryRefAddr(String, byte[])


binarySearch

binarySearch o7planning.org
  • Arrays.binarySearch(T[], int, int, T, Comparator<? super T>)
  • Arrays.binarySearch(T[], T, Comparator<? super T>)
  • Arrays.binarySearch(Object[], int, int, Object)
  • Arrays.binarySearch(Object[], Object)
  • Arrays.binarySearch(float[], int, int, float)
  • Arrays.binarySearch(float[], float)
  • Arrays.binarySearch(double[], int, int, double)
  • Arrays.binarySearch(double[], double)
  • Arrays.binarySearch(byte[], int, int, byte)
  • Arrays.binarySearch(byte[], byte)
  • Arrays.binarySearch(char[], int, int, char)
  • Arrays.binarySearch(char[], char)
  • Arrays.binarySearch(short[], int, int, short)
  • Arrays.binarySearch(short[], short)
  • Arrays.binarySearch(int[], int, int, int)
  • Arrays.binarySearch(int[], int)
  • Arrays.binarySearch(long[], int, int, long)
  • Arrays.binarySearch(long[], long)
  • Collections.binarySearch(List<? extends T>, T, Comparator<? super T>)
  • Collections.binarySearch(List<? extends Comparable<? super T>>, T)


binaryStream

binaryStream o7planning.org
  • BaseRowSet.binaryStream


bind

bind o7planning.org
  • NamingContextOperations.bind(NameComponent[], Object)
  • _NamingContextExtStub.bind(NameComponent[], Object)
  • _NamingContextStub.bind(NameComponent[], Object)


BIND

BIND o7planning.org
  • Finishings.BIND


bind_context

bind_context o7planning.org
  • NamingContextOperations.bind_context(NameComponent[], NamingContext)
  • _NamingContextExtStub.bind_context(NameComponent[], NamingContext)
  • _NamingContextStub.bind_context(NameComponent[], NamingContext)


bind_new_context

bind_new_context o7planning.org
  • NamingContextOperations.bind_new_context(NameComponent[])
  • _NamingContextExtStub.bind_new_context(NameComponent[])
  • _NamingContextStub.bind_new_context(NameComponent[])


Binder

Binder o7planning.org
  • Binder.Binder()


BindException

BindException o7planning.org
  • BindException.BindException()
  • BindException.BindException(String)


Binding

Binding o7planning.org
  • Binding.Binding(NameComponent[], BindingType)
  • Binding.Binding()
  • Binding.Binding(String, String, Object, boolean)
  • Binding.Binding(String, String, Object)
  • Binding.Binding(String, Object, boolean)
  • Binding.Binding(String, Object)


binding_name

binding_name o7planning.org
  • Binding.binding_name


binding_type

binding_type o7planning.org
  • Binding.binding_type


BindingHelper

BindingHelper o7planning.org
  • BindingHelper.BindingHelper()


BindingHolder

BindingHolder o7planning.org
  • BindingHolder.BindingHolder(Binding)
  • BindingHolder.BindingHolder()


BindingIteratorHelper

BindingIteratorHelper o7planning.org
  • BindingIteratorHelper.BindingIteratorHelper()


BindingIteratorHolder

BindingIteratorHolder o7planning.org
  • BindingIteratorHolder.BindingIteratorHolder(BindingIterator)
  • BindingIteratorHolder.BindingIteratorHolder()


BindingIteratorPOA

BindingIteratorPOA o7planning.org
  • BindingIteratorPOA.BindingIteratorPOA()


BindingListHelper

BindingListHelper o7planning.org
  • BindingListHelper.BindingListHelper()


BindingListHolder

BindingListHolder o7planning.org
  • BindingListHolder.BindingListHolder(Binding[])
  • BindingListHolder.BindingListHolder()


BindingType

BindingType o7planning.org
  • BindingType.BindingType(int)


BindingTypeHelper

BindingTypeHelper o7planning.org
  • BindingTypeHelper.BindingTypeHelper()


BindingTypeHolder

BindingTypeHolder o7planning.org
  • BindingTypeHolder.BindingTypeHolder(BindingType)
  • BindingTypeHolder.BindingTypeHolder()


bindTo

bindTo o7planning.org
  • MethodHandle.bindTo(Object)


BIT

BIT o7planning.org
  • Types.BIT


BIT_DEPTH_MULTI

BIT_DEPTH_MULTI o7planning.org
  • DisplayMode.BIT_DEPTH_MULTI


bitCount

bitCount o7planning.org
  • BigInteger.bitCount()
  • Integer.bitCount(int)
  • Long.bitCount(long)


bitLength

bitLength o7planning.org
  • BigInteger.bitLength()


BITMASK

BITMASK o7planning.org
  • Transparency.BITMASK


bitOffset

bitOffset o7planning.org
  • ImageInputStreamImpl.bitOffset


BitSet

BitSet o7planning.org
  • BitSet.BitSet(int)
  • BitSet.BitSet()


black

black o7planning.org
  • Color.black


BLACK

BLACK o7planning.org
  • Color.BLACK


BLIT_SCROLL_MODE

BLIT_SCROLL_MODE o7planning.org
  • JViewport.BLIT_SCROLL_MODE


BLOB

BLOB o7planning.org
  • Types.BLOB


block

block o7planning.org
  • ForkJoinPool.ManagedBlocker.block()
  • MembershipKey.block(InetAddress)


BLOCK_DECREMENT

BLOCK_DECREMENT o7planning.org
  • AdjustmentEvent.BLOCK_DECREMENT


BLOCK_ELEMENTS

BLOCK_ELEMENTS o7planning.org
  • Character.UnicodeBlock.BLOCK_ELEMENTS


BLOCK_INCREMENT

BLOCK_INCREMENT o7planning.org
  • AdjustmentEvent.BLOCK_INCREMENT


BlockAction

BlockAction o7planning.org
  • HTMLDocument.HTMLReader.BlockAction.BlockAction()


blockClose

blockClose o7planning.org
  • HTMLDocument.HTMLReader.blockClose(HTML.Tag)


BlockElement

BlockElement o7planning.org
  • HTMLDocument.BlockElement.BlockElement(Element, AttributeSet)


blockIncrement

blockIncrement o7planning.org
  • JScrollBar.blockIncrement


blockingLock

blockingLock o7planning.org
  • AbstractSelectableChannel.blockingLock()
  • SelectableChannel.blockingLock()


blockOpen

blockOpen o7planning.org
  • HTMLDocument.HTMLReader.blockOpen(HTML.Tag, MutableAttributeSet)


BLOCKQUOTE

BLOCKQUOTE o7planning.org
  • HTML.Tag.BLOCKQUOTE


BlockView

BlockView o7planning.org
  • BlockView.BlockView(Element, int)


BltBufferStrategy

BltBufferStrategy o7planning.org
  • Component.BltBufferStrategy.BltBufferStrategy(int, BufferCapabilities)


blue

blue o7planning.org
  • Color.blue


BLUE

BLUE o7planning.org
  • Color.BLUE


BLUECOMPONENT

BLUECOMPONENT o7planning.org
  • ICC_ProfileRGB.BLUECOMPONENT


BMPImageWriteParam

BMPImageWriteParam o7planning.org
  • BMPImageWriteParam.BMPImageWriteParam()
  • BMPImageWriteParam.BMPImageWriteParam(Locale)


BODY

BODY o7planning.org
  • HTML.Tag.BODY


body

body o7planning.org
  • DTD.body


BOLD

BOLD o7planning.org
  • Font.BOLD


Bold

Bold o7planning.org
  • StyleConstants.Bold


BOLD_ACTION

BOLD_ACTION o7planning.org
  • HTMLEditorKit.BOLD_ACTION


BoldAction

BoldAction o7planning.org
  • StyledEditorKit.BoldAction.BoldAction()


Book

Book o7planning.org
  • Book.Book()


Boolean

Boolean o7planning.org
  • Boolean.Boolean(String)
  • Boolean.Boolean(boolean)


BOOLEAN

BOOLEAN o7planning.org
  • SimpleType.BOOLEAN
  • Types.BOOLEAN
  • XPathConstants.BOOLEAN


BooleanControl

BooleanControl o7planning.org
  • BooleanControl.BooleanControl(BooleanControl.Type, boolean)
  • BooleanControl.BooleanControl(BooleanControl.Type, boolean, String, String)


BooleanHolder

BooleanHolder o7planning.org
  • BooleanHolder.BooleanHolder(boolean)
  • BooleanHolder.BooleanHolder()


BooleanSeqHelper

BooleanSeqHelper o7planning.org
  • BooleanSeqHelper.BooleanSeqHelper()


BooleanSeqHolder

BooleanSeqHolder o7planning.org
  • BooleanSeqHolder.BooleanSeqHolder(boolean[])
  • BooleanSeqHolder.BooleanSeqHolder()


booleanValue

booleanValue o7planning.org
  • Boolean.booleanValue()


BootstrapMethodError

BootstrapMethodError o7planning.org
  • BootstrapMethodError.BootstrapMethodError(Throwable)
  • BootstrapMethodError.BootstrapMethodError(String, Throwable)
  • BootstrapMethodError.BootstrapMethodError(String)
  • BootstrapMethodError.BootstrapMethodError()


BOPOMOFO

BOPOMOFO o7planning.org
  • Character.UnicodeBlock.BOPOMOFO


BOPOMOFO_EXTENDED

BOPOMOFO_EXTENDED o7planning.org
  • Character.UnicodeBlock.BOPOMOFO_EXTENDED


border

border o7planning.org
  • DefaultTreeCellEditor.DefaultTextField.border


BORDER

BORDER o7planning.org
  • CSS.Attribute.BORDER
  • HTML.Attribute.BORDER


BORDER_BOTTOM

BORDER_BOTTOM o7planning.org
  • CSS.Attribute.BORDER_BOTTOM


BORDER_BOTTOM_COLOR

BORDER_BOTTOM_COLOR o7planning.org
  • CSS.Attribute.BORDER_BOTTOM_COLOR


BORDER_BOTTOM_STYLE

BORDER_BOTTOM_STYLE o7planning.org
  • CSS.Attribute.BORDER_BOTTOM_STYLE


BORDER_BOTTOM_WIDTH

BORDER_BOTTOM_WIDTH o7planning.org
  • CSS.Attribute.BORDER_BOTTOM_WIDTH


BORDER_COLOR

BORDER_COLOR o7planning.org
  • CSS.Attribute.BORDER_COLOR


BORDER_LEFT

BORDER_LEFT o7planning.org
  • CSS.Attribute.BORDER_LEFT


BORDER_LEFT_COLOR

BORDER_LEFT_COLOR o7planning.org
  • CSS.Attribute.BORDER_LEFT_COLOR


BORDER_LEFT_STYLE

BORDER_LEFT_STYLE o7planning.org
  • CSS.Attribute.BORDER_LEFT_STYLE


BORDER_LEFT_WIDTH

BORDER_LEFT_WIDTH o7planning.org
  • CSS.Attribute.BORDER_LEFT_WIDTH


BORDER_PAINTED_CHANGED_PROPERTY

BORDER_PAINTED_CHANGED_PROPERTY o7planning.org
  • AbstractButton.BORDER_PAINTED_CHANGED_PROPERTY


BORDER_PAINTED_FLAT_CHANGED_PROPERTY

BORDER_PAINTED_FLAT_CHANGED_PROPERTY o7planning.org
  • JCheckBox.BORDER_PAINTED_FLAT_CHANGED_PROPERTY


BORDER_RIGHT

BORDER_RIGHT o7planning.org
  • CSS.Attribute.BORDER_RIGHT


BORDER_RIGHT_COLOR

BORDER_RIGHT_COLOR o7planning.org
  • CSS.Attribute.BORDER_RIGHT_COLOR


BORDER_RIGHT_STYLE

BORDER_RIGHT_STYLE o7planning.org
  • CSS.Attribute.BORDER_RIGHT_STYLE


BORDER_RIGHT_WIDTH

BORDER_RIGHT_WIDTH o7planning.org
  • CSS.Attribute.BORDER_RIGHT_WIDTH


BORDER_STYLE

BORDER_STYLE o7planning.org
  • CSS.Attribute.BORDER_STYLE


BORDER_TOP

BORDER_TOP o7planning.org
  • CSS.Attribute.BORDER_TOP


BORDER_TOP_COLOR

BORDER_TOP_COLOR o7planning.org
  • CSS.Attribute.BORDER_TOP_COLOR


BORDER_TOP_STYLE

BORDER_TOP_STYLE o7planning.org
  • CSS.Attribute.BORDER_TOP_STYLE


BORDER_TOP_WIDTH

BORDER_TOP_WIDTH o7planning.org
  • CSS.Attribute.BORDER_TOP_WIDTH


BORDER_WIDTH

BORDER_WIDTH o7planning.org
  • CSS.Attribute.BORDER_WIDTH


borderInsets

borderInsets o7planning.org
  • MetalBorders.ButtonBorder.borderInsets
  • MetalBorders.MenuBarBorder.borderInsets
  • MetalBorders.MenuItemBorder.borderInsets
  • MetalBorders.PopupMenuBorder.borderInsets


BorderLayout

BorderLayout o7planning.org
  • BorderLayout.BorderLayout(int, int)
  • BorderLayout.BorderLayout()


borderListener

borderListener o7planning.org
  • BasicInternalFrameUI.borderListener


BorderListener

BorderListener o7planning.org
  • BasicInternalFrameUI.BorderListener.BorderListener()


borderSelectionColor

borderSelectionColor o7planning.org
  • DefaultTreeCellEditor.borderSelectionColor
  • DefaultTreeCellRenderer.borderSelectionColor


BorderUIResource

BorderUIResource o7planning.org
  • BorderUIResource.BorderUIResource(Border)


BOTH

BOTH o7planning.org
  • GridBagConstraints.BOTH


bottom

bottom o7planning.org
  • EmptyBorder.bottom


BOTTOM

BOTTOM o7planning.org
  • JSplitPane.BOTTOM
  • SwingConstants.BOTTOM
  • TitledBorder.BOTTOM


BOTTOM_ALIGNMENT

BOTTOM_ALIGNMENT o7planning.org
  • Component.BOTTOM_ALIGNMENT
  • GraphicAttribute.BOTTOM_ALIGNMENT


BOUND_SERVER_NAME

BOUND_SERVER_NAME o7planning.org
  • Sasl.BOUND_SERVER_NAME


bounds

bounds o7planning.org
  • Component.bounds()
  • Polygon.bounds


Bounds

Bounds o7planning.org
  • Bounds.Bounds(String)
  • Bounds.Bounds()
  • Bounds.Bounds(String)
  • Bounds.Bounds()


Box

Box o7planning.org
  • Box.Box(int)


BOX_DRAWING

BOX_DRAWING o7planning.org
  • Character.UnicodeBlock.BOX_DRAWING


boxed

boxed o7planning.org
  • DoubleStream.boxed()
  • IntStream.boxed()
  • LongStream.boxed()


boxedClass

boxedClass o7planning.org
  • Types.boxedClass(PrimitiveType)


BoxLayout

BoxLayout o7planning.org
  • BoxLayout.BoxLayout(Container, int)


boxRect

boxRect o7planning.org
  • BasicProgressBarUI.boxRect


BoxView

BoxView o7planning.org
  • BoxView.BoxView(Element, int)


BR

BR o7planning.org
  • HTML.Tag.BR


BRAHMI

BRAHMI o7planning.org
  • Character.UnicodeBlock.BRAHMI


BRAILLE_PATTERNS

BRAILLE_PATTERNS o7planning.org
  • Character.UnicodeBlock.BRAILLE_PATTERNS


BranchElement

BranchElement o7planning.org
  • AbstractDocument.BranchElement.BranchElement(Element, AttributeSet)


breadthFirstEnumeration

breadthFirstEnumeration o7planning.org
  • DefaultMutableTreeNode.breadthFirstEnumeration()


BreakIterator

BreakIterator o7planning.org
  • BreakIterator.BreakIterator()


BreakIteratorProvider

BreakIteratorProvider o7planning.org
  • BreakIteratorProvider.BreakIteratorProvider()


breaksFlow

breaksFlow o7planning.org
  • HTML.Tag.breaksFlow()
  • TagElement.breaksFlow()


breakView

breakView o7planning.org
  • GlyphView.breakView(int, int, float, float)
  • InlineView.breakView(int, int, float, float)
  • ParagraphView.breakView(int, float, Shape)
  • View.breakView(int, int, float, float)


BRIEF

BRIEF o7planning.org
  • LogStream.BRIEF


brighter

brighter o7planning.org
  • Color.brighter()


BrokenBarrierException

BrokenBarrierException o7planning.org
  • BrokenBarrierException.BrokenBarrierException(String)
  • BrokenBarrierException.BrokenBarrierException()


browse

browse o7planning.org
  • Desktop.browse(URI)


BUBBLING_PHASE

BUBBLING_PHASE o7planning.org
  • Event.BUBBLING_PHASE


buf

buf o7planning.org
  • BufferedInputStream.buf
  • BufferedOutputStream.buf
  • ByteArrayInputStream.buf
  • ByteArrayOutputStream.buf
  • CharArrayReader.buf
  • CharArrayWriter.buf
  • DeflaterInputStream.buf
  • DeflaterOutputStream.buf
  • InflaterInputStream.buf
  • InflaterOutputStream.buf
  • PushbackInputStream.buf


buffer

buffer o7planning.org
  • DefaultStyledDocument.buffer
  • PipedInputStream.buffer
  • StringBufferInputStream.buffer


BUFFER_SIZE_DEFAULT

BUFFER_SIZE_DEFAULT o7planning.org
  • DefaultStyledDocument.BUFFER_SIZE_DEFAULT


BufferCapabilities

BufferCapabilities o7planning.org
  • BufferCapabilities.BufferCapabilities(ImageCapabilities, ImageCapabilities, BufferCapabilities.FlipContents)


BUFFERED_OPTION

BUFFERED_OPTION o7planning.org
  • DebugGraphics.BUFFERED_OPTION


BufferedImage

BufferedImage o7planning.org
  • BufferedImage.BufferedImage(ColorModel, WritableRaster, boolean, Hashtable<?, ?>)
  • BufferedImage.BufferedImage(int, int, int, IndexColorModel)
  • BufferedImage.BufferedImage(int, int, int)


BufferedImageFilter

BufferedImageFilter o7planning.org
  • BufferedImageFilter.BufferedImageFilter(BufferedImageOp)


BufferedInputStream

BufferedInputStream o7planning.org
  • BufferedInputStream.BufferedInputStream(InputStream, int)
  • BufferedInputStream.BufferedInputStream(InputStream)


BufferedOutputStream

BufferedOutputStream o7planning.org
  • BufferedOutputStream.BufferedOutputStream(OutputStream, int)
  • BufferedOutputStream.BufferedOutputStream(OutputStream)


BufferedReader

BufferedReader o7planning.org
  • BufferedReader.BufferedReader(Reader)
  • BufferedReader.BufferedReader(Reader, int)


BufferedWriter

BufferedWriter o7planning.org
  • BufferedWriter.BufferedWriter(Writer, int)
  • BufferedWriter.BufferedWriter(Writer)


BufferOverflowException

BufferOverflowException o7planning.org
  • BufferOverflowException.BufferOverflowException()


BufferStrategy

BufferStrategy o7planning.org
  • BufferStrategy.BufferStrategy()


BufferUnderflowException

BufferUnderflowException o7planning.org
  • BufferUnderflowException.BufferUnderflowException()


BUGINESE

BUGINESE o7planning.org
  • Character.UnicodeBlock.BUGINESE


BUHID

BUHID o7planning.org
  • Character.UnicodeBlock.BUHID


build

build o7planning.org
  • AclEntry.Builder.build()
  • Calendar.Builder.build()
  • CertPathBuilder.build(CertPathParameters)
  • DoubleStream.Builder.build()
  • IntStream.Builder.build()
  • Locale.Builder.build()
  • LongStream.Builder.build()
  • Stream.Builder.build()
  • W3CEndpointReferenceBuilder.build()


buildChooser

buildChooser o7planning.org
  • AbstractColorChooserPanel.buildChooser()


Builder

Builder o7planning.org
  • Calendar.Builder.Builder()
  • KeyStore.Builder.Builder()
  • Locale.Builder.Builder()


builder

builder o7planning.org
  • DoubleStream.builder()
  • IntStream.builder()
  • LongStream.builder()
  • Stream.builder()


bulkRegister

bulkRegister o7planning.org
  • Phaser.bulkRegister(int)


bumps

bumps o7planning.org
  • MetalBorders.ToolBarBorder.bumps
  • MetalScrollBarUI.bumps


burstStringInto

burstStringInto o7planning.org
  • BasicOptionPaneUI.burstStringInto(Container, String, int)


BUSY

BUSY o7planning.org
  • AccessibleState.BUSY


BUTTON1

BUTTON1 o7planning.org
  • MouseEvent.BUTTON1


BUTTON1_DOWN_MASK

BUTTON1_DOWN_MASK o7planning.org
  • InputEvent.BUTTON1_DOWN_MASK


BUTTON1_MASK

BUTTON1_MASK o7planning.org
  • InputEvent.BUTTON1_MASK


BUTTON2

BUTTON2 o7planning.org
  • MouseEvent.BUTTON2


BUTTON2_DOWN_MASK

BUTTON2_DOWN_MASK o7planning.org
  • InputEvent.BUTTON2_DOWN_MASK


BUTTON2_MASK

BUTTON2_MASK o7planning.org
  • InputEvent.BUTTON2_MASK


BUTTON3

BUTTON3 o7planning.org
  • MouseEvent.BUTTON3


BUTTON3_DOWN_MASK

BUTTON3_DOWN_MASK o7planning.org
  • InputEvent.BUTTON3_DOWN_MASK


BUTTON3_MASK

BUTTON3_MASK o7planning.org
  • InputEvent.BUTTON3_MASK


Button

Button o7planning.org
  • Button.Button(String)
  • Button.Button()


BUTTON

BUTTON o7planning.org
  • Region.BUTTON


ButtonActionListener

ButtonActionListener o7planning.org
  • BasicOptionPaneUI.ButtonActionListener.ButtonActionListener(int)


ButtonAreaLayout

ButtonAreaLayout o7planning.org
  • BasicOptionPaneUI.ButtonAreaLayout.ButtonAreaLayout(boolean, int)


ButtonBorder

ButtonBorder o7planning.org
  • BasicBorders.ButtonBorder.ButtonBorder(Color, Color, Color, Color)
  • MetalBorders.ButtonBorder.ButtonBorder()


ButtonGroup

ButtonGroup o7planning.org
  • ButtonGroup.ButtonGroup()


buttonIndex

buttonIndex o7planning.org
  • BasicOptionPaneUI.ButtonActionListener.buttonIndex


buttonListener

buttonListener o7planning.org
  • BasicScrollBarUI.buttonListener


buttons

buttons o7planning.org
  • ButtonGroup.buttons


ButtonUI

ButtonUI o7planning.org
  • ButtonUI.ButtonUI()


Byte

Byte o7planning.org
  • Byte.Byte(String)
  • Byte.Byte(byte)


BYTE

BYTE o7planning.org
  • SimpleType.BYTE


BYTE_ARRAY

BYTE_ARRAY o7planning.org
  • DocFlavor.BYTE_ARRAY.BYTE_ARRAY(String)


ByteArrayInputStream

ByteArrayInputStream o7planning.org
  • ByteArrayInputStream.ByteArrayInputStream(byte[], int, int)
  • ByteArrayInputStream.ByteArrayInputStream(byte[])


ByteArrayOutputStream

ByteArrayOutputStream o7planning.org
  • ByteArrayOutputStream.ByteArrayOutputStream(int)
  • ByteArrayOutputStream.ByteArrayOutputStream()


ByteHolder

ByteHolder o7planning.org
  • ByteHolder.ByteHolder(byte)
  • ByteHolder.ByteHolder()


byteLength

byteLength o7planning.org
  • MidiFileFormat.byteLength


ByteLookupTable

ByteLookupTable o7planning.org
  • ByteLookupTable.ByteLookupTable(int, byte[])
  • ByteLookupTable.ByteLookupTable(int, byte[][])


byteOrder

byteOrder o7planning.org
  • ImageInputStreamImpl.byteOrder


BYTES

BYTES o7planning.org
  • Byte.BYTES
  • Character.BYTES
  • Double.BYTES
  • Float.BYTES
  • Integer.BYTES
  • Long.BYTES
  • Short.BYTES


bytesConsumed

bytesConsumed o7planning.org
  • SSLEngineResult.bytesConsumed()


bytesProduced

bytesProduced o7planning.org
  • SSLEngineResult.bytesProduced()


bytesTransferred

bytesTransferred o7planning.org
  • InterruptedIOException.bytesTransferred


bytesWidth

bytesWidth o7planning.org
  • FontMetrics.bytesWidth(byte[], int, int)


byteValue

byteValue o7planning.org
  • Byte.byteValue()
  • Double.byteValue()
  • Float.byteValue()
  • Integer.byteValue()
  • Long.byteValue()
  • Number.byteValue()
  • Short.byteValue()


byteValueExact

byteValueExact o7planning.org
  • BigDecimal.byteValueExact()
  • BigInteger.byteValueExact()


BYZANTINE_MUSICAL_SYMBOLS

BYZANTINE_MUSICAL_SYMBOLS o7planning.org
  • Character.UnicodeBlock.BYZANTINE_MUSICAL_SYMBOLS


C0

C0 o7planning.org
  • PageAttributes.MediaType.C0


C1

C1 o7planning.org
  • PageAttributes.MediaType.C1


C2

C2 o7planning.org
  • PageAttributes.MediaType.C2


C3

C3 o7planning.org
  • MediaSize.ISO.C3
  • PageAttributes.MediaType.C3


C4

C4 o7planning.org
  • MediaSize.ISO.C4
  • PageAttributes.MediaType.C4


C5

C5 o7planning.org
  • MediaSize.ISO.C5
  • PageAttributes.MediaType.C5


C6

C6 o7planning.org
  • MediaSize.ISO.C6
  • PageAttributes.MediaType.C6


C7

C7 o7planning.org
  • PageAttributes.MediaType.C7


C8

C8 o7planning.org
  • PageAttributes.MediaType.C8


C9

C9 o7planning.org
  • PageAttributes.MediaType.C9


C10

C10 o7planning.org
  • PageAttributes.MediaType.C10


C

C o7planning.org
  • MediaSize.Engineering.C
  • MediaSizeName.C
  • PageAttributes.MediaType.C


cachedChildren

cachedChildren o7planning.org
  • AbstractPreferences.cachedChildren()


cachedMinimumSize

cachedMinimumSize o7planning.org
  • BasicComboBoxUI.cachedMinimumSize


cacheIcon

cacheIcon o7planning.org
  • BasicFileChooserUI.BasicFileView.cacheIcon(File, Icon)


cacheMBeanInfo

cacheMBeanInfo o7planning.org
  • StandardMBean.cacheMBeanInfo(MBeanInfo)


CacheRequest

CacheRequest o7planning.org
  • CacheRequest.CacheRequest()


CacheResponse

CacheResponse o7planning.org
  • CacheResponse.CacheResponse()


calcRect

calcRect o7planning.org
  • BasicTabbedPaneUI.calcRect


calculateAlignedPositions

calculateAlignedPositions o7planning.org
  • SizeRequirements.calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean)
  • SizeRequirements.calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[])


calculateBreakPosition

calculateBreakPosition o7planning.org
  • WrappedPlainView.calculateBreakPosition(int, int)


calculateContentRect

calculateContentRect o7planning.org
  • BasicSliderUI.calculateContentRect()


calculateFocusRect

calculateFocusRect o7planning.org
  • BasicSliderUI.calculateFocusRect()


calculateGeometry

calculateGeometry o7planning.org
  • BasicSliderUI.calculateGeometry()
  • SynthSliderUI.calculateGeometry()


calculateIndex

calculateIndex o7planning.org
  • TabularData.calculateIndex(CompositeData)
  • TabularDataSupport.calculateIndex(CompositeData)


calculateInnerArea

calculateInnerArea o7planning.org
  • SwingUtilities.calculateInnerArea(JComponent, Rectangle)


calculateLabelRect

calculateLabelRect o7planning.org
  • BasicSliderUI.calculateLabelRect()


calculateLayoutInfo

calculateLayoutInfo o7planning.org
  • BasicTabbedPaneUI.TabbedPaneLayout.calculateLayoutInfo()


calculateMajorAxisRequirements

calculateMajorAxisRequirements o7planning.org
  • BlockView.calculateMajorAxisRequirements(int, SizeRequirements)
  • BoxView.calculateMajorAxisRequirements(int, SizeRequirements)


calculateMaxTabHeight

calculateMaxTabHeight o7planning.org
  • BasicTabbedPaneUI.calculateMaxTabHeight(int)
  • MetalTabbedPaneUI.calculateMaxTabHeight(int)
  • SynthTabbedPaneUI.calculateMaxTabHeight(int)


calculateMaxTabWidth

calculateMaxTabWidth o7planning.org
  • BasicTabbedPaneUI.calculateMaxTabWidth(int)
  • SynthTabbedPaneUI.calculateMaxTabWidth(int)


calculateMinorAxisRequirements

calculateMinorAxisRequirements o7planning.org
  • BlockView.calculateMinorAxisRequirements(int, SizeRequirements)
  • BoxView.calculateMinorAxisRequirements(int, SizeRequirements)
  • FlowView.calculateMinorAxisRequirements(int, SizeRequirements)
  • ParagraphView.calculateMinorAxisRequirements(int, SizeRequirements)
  • ParagraphView.calculateMinorAxisRequirements(int, SizeRequirements)
  • TableView.calculateMinorAxisRequirements(int, SizeRequirements)


calculateSize

calculateSize o7planning.org
  • BasicTabbedPaneUI.TabbedPaneLayout.calculateSize(boolean)


calculateTabAreaHeight

calculateTabAreaHeight o7planning.org
  • BasicTabbedPaneUI.calculateTabAreaHeight(int, int, int)


calculateTabAreaWidth

calculateTabAreaWidth o7planning.org
  • BasicTabbedPaneUI.calculateTabAreaWidth(int, int, int)


calculateTabHeight

calculateTabHeight o7planning.org
  • BasicTabbedPaneUI.calculateTabHeight(int, int, int)


calculateTabRects

calculateTabRects o7planning.org
  • BasicTabbedPaneUI.TabbedPaneLayout.calculateTabRects(int, int)


calculateTabWidth

calculateTabWidth o7planning.org
  • BasicTabbedPaneUI.calculateTabWidth(int, int, FontMetrics)
  • SynthTabbedPaneUI.calculateTabWidth(int, int, FontMetrics)


calculateThumbLocation

calculateThumbLocation o7planning.org
  • BasicSliderUI.calculateThumbLocation()
  • SynthSliderUI.calculateThumbLocation()


calculateThumbSize

calculateThumbSize o7planning.org
  • BasicSliderUI.calculateThumbSize()


calculateTickRect

calculateTickRect o7planning.org
  • BasicSliderUI.calculateTickRect()


calculateTiledPositions

calculateTiledPositions o7planning.org
  • SizeRequirements.calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean)
  • SizeRequirements.calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[])


calculateTrackBuffer

calculateTrackBuffer o7planning.org
  • BasicSliderUI.calculateTrackBuffer()


calculateTrackRect

calculateTrackRect o7planning.org
  • BasicSliderUI.calculateTrackRect()


calendar

calendar o7planning.org
  • DateFormat.calendar


Calendar

Calendar o7planning.org
  • Calendar.Calendar(TimeZone, Locale)
  • Calendar.Calendar()


CalendarDataProvider

CalendarDataProvider o7planning.org
  • CalendarDataProvider.CalendarDataProvider()


CalendarNameProvider

CalendarNameProvider o7planning.org
  • CalendarNameProvider.CalendarNameProvider()


call

call o7planning.org
  • Callable.call()
  • DocumentationTool.DocumentationTask.call()
  • JavaCompiler.CompilationTask.call()
  • SOAPConnection.call(SOAPMessage, Object)


callable

callable o7planning.org
  • Executors.callable(PrivilegedExceptionAction<?>)
  • Executors.callable(PrivilegedAction<?>)
  • Executors.callable(Runnable)
  • Executors.callable(Runnable, T)


CallbackHandlerProtection

CallbackHandlerProtection o7planning.org
  • KeyStore.CallbackHandlerProtection.CallbackHandlerProtection(CallbackHandler)


CallerRunsPolicy

CallerRunsPolicy o7planning.org
  • ThreadPoolExecutor.CallerRunsPolicy.CallerRunsPolicy()


CANADA

CANADA o7planning.org
  • Locale.CANADA


CANADA_FRENCH

CANADA_FRENCH o7planning.org
  • Locale.CANADA_FRENCH


cancel

cancel o7planning.org
  • SwingWorker.cancel(boolean)


CANCEL

CANCEL o7planning.org
  • ConfirmationCallback.CANCEL


CANCEL_OPTION

CANCEL_OPTION o7planning.org
  • JFileChooser.CANCEL_OPTION
  • JOptionPane.CANCEL_OPTION


CANCEL_SELECTION

CANCEL_SELECTION o7planning.org
  • JFileChooser.CANCEL_SELECTION


cancelButtonMnemonic

cancelButtonMnemonic o7planning.org
  • BasicFileChooserUI.cancelButtonMnemonic


cancelButtonText

cancelButtonText o7planning.org
  • BasicFileChooserUI.cancelButtonText


cancelButtonToolTipText

cancelButtonToolTipText o7planning.org
  • BasicFileChooserUI.cancelButtonToolTipText


cancelCellEditing

cancelCellEditing o7planning.org
  • AbstractCellEditor.cancelCellEditing()
  • CellEditor.cancelCellEditing()
  • DefaultCellEditor.cancelCellEditing()
  • DefaultCellEditor.EditorDelegate.cancelCellEditing()
  • DefaultTreeCellEditor.cancelCellEditing()


CANCELED

CANCELED o7planning.org
  • JobState.CANCELED


cancelEditing

cancelEditing o7planning.org
  • BasicTreeUI.cancelEditing(JTree)
  • JTree.cancelEditing()
  • MultiTreeUI.cancelEditing(JTree)
  • TreeUI.cancelEditing(JTree)


cancelLatestCommittedText

cancelLatestCommittedText o7planning.org
  • InputMethodRequests.cancelLatestCommittedText(AttributedCharacterIterator.Attribute[])


CancellationException

CancellationException o7planning.org
  • CancellationException.CancellationException(String)
  • CancellationException.CancellationException()


CancelledKeyException

CancelledKeyException o7planning.org
  • CancelledKeyException.CancelledKeyException()


cancelledKeys

cancelledKeys o7planning.org
  • AbstractSelector.cancelledKeys()


cancelRowUpdates

cancelRowUpdates o7planning.org
  • ResultSet.cancelRowUpdates()


cancelSelection

cancelSelection o7planning.org
  • JFileChooser.cancelSelection()


CancelSelectionAction

CancelSelectionAction o7planning.org
  • BasicFileChooserUI.CancelSelectionAction.CancelSelectionAction()


canDecodeInput

canDecodeInput o7planning.org
  • ImageReaderSpi.canDecodeInput(Object)


canDisplay

canDisplay o7planning.org
  • Font.canDisplay(int)
  • Font.canDisplay(char)


canDisplayUpTo

canDisplayUpTo o7planning.org
  • Font.canDisplayUpTo(CharacterIterator, int, int)
  • Font.canDisplayUpTo(char[], int, int)
  • Font.canDisplayUpTo(String)


canDock

canDock o7planning.org
  • BasicToolBarUI.canDock(Component, Point)


canEdit

canEdit o7planning.org
  • DefaultTreeCellEditor.canEdit


canEditImmediately

canEditImmediately o7planning.org
  • DefaultTreeCellEditor.canEditImmediately(EventObject)


canEncode

canEncode o7planning.org
  • Charset.canEncode()
  • CharsetEncoder.canEncode(CharSequence)
  • CharsetEncoder.canEncode(char)


canEncodeImage

canEncodeImage o7planning.org
  • ImageWriterSpi.canEncodeImage(RenderedImage)
  • ImageWriterSpi.canEncodeImage(ImageTypeSpecifier)


canExecute

canExecute o7planning.org
  • File.canExecute()


canFilterIndexColorModel

canFilterIndexColorModel o7planning.org
  • RGBImageFilter.canFilterIndexColorModel


canImport

canImport o7planning.org
  • TransferHandler.canImport(JComponent, DataFlavor[])
  • TransferHandler.canImport(TransferHandler.TransferSupport)


canInsertEmpty

canInsertEmpty o7planning.org
  • ImageWriter.canInsertEmpty(int)


canInsertImage

canInsertImage o7planning.org
  • ImageWriter.canInsertImage(int)


canNodeAppear

canNodeAppear o7planning.org
  • IIOMetadataFormat.canNodeAppear(String, ImageTypeSpecifier)
  • IIOMetadataFormatImpl.canNodeAppear(String, ImageTypeSpecifier)


CannotProceed

CannotProceed o7planning.org
  • CannotProceed.CannotProceed(String, NamingContext, NameComponent[])
  • CannotProceed.CannotProceed(NamingContext, NameComponent[])
  • CannotProceed.CannotProceed()


CannotProceedException

CannotProceedException o7planning.org
  • CannotProceedException.CannotProceedException()
  • CannotProceedException.CannotProceedException(String)


CannotProceedHelper

CannotProceedHelper o7planning.org
  • CannotProceedHelper.CannotProceedHelper()


CannotProceedHolder

CannotProceedHolder o7planning.org
  • CannotProceedHolder.CannotProceedHolder(CannotProceed)
  • CannotProceedHolder.CannotProceedHolder()


CannotRedoException

CannotRedoException o7planning.org
  • CannotRedoException.CannotRedoException()


CannotUndoException

CannotUndoException o7planning.org
  • CannotUndoException.CannotUndoException()


canOffsetTiles

canOffsetTiles o7planning.org
  • ImageWriteParam.canOffsetTiles()
  • ImageWriteParam.canOffsetTiles


CANON_EQ

CANON_EQ o7planning.org
  • Pattern.CANON_EQ


CANONICAL

CANONICAL o7planning.org
  • X500Principal.CANONICAL


CANONICAL_DECOMPOSITION

CANONICAL_DECOMPOSITION o7planning.org
  • Collator.CANONICAL_DECOMPOSITION


canonicalize

canonicalize o7planning.org
  • GSSName.canonicalize(Oid)


canPathsBeAdded

canPathsBeAdded o7planning.org
  • DefaultTreeSelectionModel.canPathsBeAdded(TreePath[])


canPathsBeRemoved

canPathsBeRemoved o7planning.org
  • DefaultTreeSelectionModel.canPathsBeRemoved(TreePath[])


canRead

canRead o7planning.org
  • File.canRead()


canReadRaster

canReadRaster o7planning.org
  • ImageReader.canReadRaster()


canRedo

canRedo o7planning.org
  • AbstractUndoableEdit.canRedo()
  • CompoundEdit.canRedo()
  • UndoManager.canRedo()
  • UndoableEdit.canRedo()


canRemoveImage

canRemoveImage o7planning.org
  • ImageWriter.canRemoveImage(int)


canReplaceImageMetadata

canReplaceImageMetadata o7planning.org
  • ImageWriter.canReplaceImageMetadata(int)


canReplacePixels

canReplacePixels o7planning.org
  • ImageWriter.canReplacePixels(int)


canReplaceStreamMetadata

canReplaceStreamMetadata o7planning.org
  • ImageWriter.canReplaceStreamMetadata()


canSetParameter

canSetParameter o7planning.org
  • DOMConfiguration.canSetParameter(String, Object)


canSetSourceRenderSize

canSetSourceRenderSize o7planning.org
  • ImageReadParam.canSetSourceRenderSize()
  • ImageReadParam.canSetSourceRenderSize


canUndo

canUndo o7planning.org
  • AbstractUndoableEdit.canUndo()
  • CompoundEdit.canUndo()
  • UndoManager.canUndo()
  • UndoableEdit.canUndo()


canUndoOrRedo

canUndoOrRedo o7planning.org
  • UndoManager.canUndoOrRedo()


canUseCacheFile

canUseCacheFile o7planning.org
  • ImageInputStreamSpi.canUseCacheFile()
  • ImageOutputStreamSpi.canUseCacheFile()


Canvas

Canvas o7planning.org
  • Canvas.Canvas(GraphicsConfiguration)
  • Canvas.Canvas()


CANVAS

CANVAS o7planning.org
  • AccessibleRole.CANVAS


canWrite

canWrite o7planning.org
  • File.canWrite()


canWriteCompressed

canWriteCompressed o7planning.org
  • ImageWriteParam.canWriteCompressed()
  • ImageWriteParam.canWriteCompressed


canWriteEmpty

canWriteEmpty o7planning.org
  • ImageWriter.canWriteEmpty()


canWriteProgressive

canWriteProgressive o7planning.org
  • ImageWriteParam.canWriteProgressive()
  • ImageWriteParam.canWriteProgressive


canWriteRasters

canWriteRasters o7planning.org
  • ImageWriter.canWriteRasters()


canWriteSequence

canWriteSequence o7planning.org
  • ImageWriter.canWriteSequence()


canWriteTiles

canWriteTiles o7planning.org
  • ImageWriteParam.canWriteTiles()
  • ImageWriteParam.canWriteTiles


CAP_BUTT

CAP_BUTT o7planning.org
  • BasicStroke.CAP_BUTT


CAP_ROUND

CAP_ROUND o7planning.org
  • BasicStroke.CAP_ROUND


CAP_SQUARE

CAP_SQUARE o7planning.org
  • BasicStroke.CAP_SQUARE


capacity

capacity o7planning.org
  • Buffer.capacity()
  • DefaultListModel.capacity()
  • StringBuffer.capacity()
  • Vector.capacity()


capacityIncrement

capacityIncrement o7planning.org
  • Monitor.capacityIncrement
  • Vector.capacityIncrement


caps

caps o7planning.org
  • Component.BltBufferStrategy.caps
  • Component.FlipBufferStrategy.caps


CAPS_LOCK

CAPS_LOCK o7planning.org
  • Event.CAPS_LOCK


CAPTION

CAPTION o7planning.org
  • HTML.Tag.CAPTION


capture

capture o7planning.org
  • Types.capture(TypeMirror)


CAPTURING_PHASE

CAPTURING_PHASE o7planning.org
  • Event.CAPTURING_PHASE


cardinality

cardinality o7planning.org
  • BitSet.cardinality()


CardLayout

CardLayout o7planning.org
  • CardLayout.CardLayout(int, int)
  • CardLayout.CardLayout()


CARET_POSITION_CHANGED

CARET_POSITION_CHANGED o7planning.org
  • InputMethodEvent.CARET_POSITION_CHANGED


CaretEvent

CaretEvent o7planning.org
  • CaretEvent.CaretEvent(Object)


CaretPolicy

CaretPolicy o7planning.org
  • TextLayout.CaretPolicy.CaretPolicy()


caretPositionChanged

caretPositionChanged o7planning.org
  • AWTEventMulticaster.caretPositionChanged(InputMethodEvent)
  • InputMethodListener.caretPositionChanged(InputMethodEvent)


caretUpdate

caretUpdate o7planning.org
  • CaretListener.caretUpdate(CaretEvent)
  • JTextComponent.AccessibleJTextComponent.caretUpdate(CaretEvent)


CARIAN

CARIAN o7planning.org
  • Character.UnicodeBlock.CARIAN


CASE_INSENSITIVE

CASE_INSENSITIVE o7planning.org
  • Pattern.CASE_INSENSITIVE


CASE_INSENSITIVE_ORDER

CASE_INSENSITIVE_ORDER o7planning.org
  • String.CASE_INSENSITIVE_ORDER


cast

cast o7planning.org
  • Class.cast(Object)


catchException

catchException o7planning.org
  • MethodHandles.catchException(MethodHandle, Class<? extends Throwable>, MethodHandle)


catchExceptions

catchExceptions o7planning.org
  • InvocationEvent.catchExceptions


cbrt

cbrt o7planning.org
  • Math.cbrt(double)
  • StrictMath.cbrt(double)


CDATA

CDATA o7planning.org
  • DTDConstants.CDATA
  • XMLStreamConstants.CDATA


CDATA_SECTION_ELEMENTS

CDATA_SECTION_ELEMENTS o7planning.org
  • OutputKeys.CDATA_SECTION_ELEMENTS


CDATA_SECTION_NODE

CDATA_SECTION_NODE o7planning.org
  • Node.CDATA_SECTION_NODE


ceil

ceil o7planning.org
  • Math.ceil(double)
  • StrictMath.ceil(double)


ceiling

ceiling o7planning.org
  • ConcurrentSkipListSet.ceiling(E)
  • NavigableSet.ceiling(E)
  • TreeSet.ceiling(E)


ceilingEntry

ceilingEntry o7planning.org
  • ConcurrentSkipListMap.ceilingEntry(K)
  • NavigableMap.ceilingEntry(K)
  • TreeMap.ceilingEntry(K)


ceilingKey

ceilingKey o7planning.org
  • ConcurrentSkipListMap.ceilingKey(K)
  • NavigableMap.ceilingKey(K)
  • TreeMap.ceilingKey(K)


CELL_EDITOR_PROPERTY

CELL_EDITOR_PROPERTY o7planning.org
  • JTree.CELL_EDITOR_PROPERTY


CELL_RENDERER_PROPERTY

CELL_RENDERER_PROPERTY o7planning.org
  • JTree.CELL_RENDERER_PROPERTY
  • TableColumn.CELL_RENDERER_PROPERTY


cellEditor

cellEditor o7planning.org
  • BasicTreeUI.cellEditor
  • JTable.cellEditor
  • JTree.cellEditor
  • TableColumn.cellEditor


CellEditorHandler

CellEditorHandler o7planning.org
  • BasicTreeUI.CellEditorHandler.CellEditorHandler()


cellHeight

cellHeight o7planning.org
  • BasicListUI.cellHeight


cellHeights

cellHeights o7planning.org
  • BasicListUI.cellHeights


CELLPADDING

CELLPADDING o7planning.org
  • HTML.Attribute.CELLPADDING


cellRenderer

cellRenderer o7planning.org
  • JTree.cellRenderer
  • TableColumn.cellRenderer


cellRendererChanged

cellRendererChanged o7planning.org
  • BasicListUI.cellRendererChanged


CellRendererPane

CellRendererPane o7planning.org
  • CellRendererPane.CellRendererPane()


cellSelectionEnabled

cellSelectionEnabled o7planning.org
  • JTable.cellSelectionEnabled


CELLSPACING

CELLSPACING o7planning.org
  • HTML.Attribute.CELLSPACING


cellWidth

cellWidth o7planning.org
  • BasicListUI.cellWidth


CENTER

CENTER o7planning.org
  • BorderLayout.CENTER
  • FlowLayout.CENTER
  • GridBagConstraints.CENTER
  • HTML.Tag.CENTER
  • Label.CENTER
  • SwingConstants.CENTER
  • TitledBorder.CENTER


CENTER_ALIGNMENT

CENTER_ALIGNMENT o7planning.org
  • Component.CENTER_ALIGNMENT


CENTER_BASELINE

CENTER_BASELINE o7planning.org
  • Font.CENTER_BASELINE
  • GraphicAttribute.CENTER_BASELINE


centersChildren

centersChildren o7planning.org
  • BasicOptionPaneUI.ButtonAreaLayout.centersChildren


Certificate

Certificate o7planning.org
  • Certificate.Certificate()
  • Certificate.Certificate(String)


CertificateEncodingException

CertificateEncodingException o7planning.org
  • CertificateEncodingException.CertificateEncodingException(String)
  • CertificateEncodingException.CertificateEncodingException()
  • CertificateEncodingException.CertificateEncodingException(Throwable)
  • CertificateEncodingException.CertificateEncodingException(String, Throwable)
  • CertificateEncodingException.CertificateEncodingException(String)
  • CertificateEncodingException.CertificateEncodingException()


CertificateException

CertificateException o7planning.org
  • CertificateException.CertificateException(String)
  • CertificateException.CertificateException()
  • CertificateException.CertificateException(Throwable)
  • CertificateException.CertificateException(String, Throwable)
  • CertificateException.CertificateException(String)
  • CertificateException.CertificateException()


CertificateExpiredException

CertificateExpiredException o7planning.org
  • CertificateExpiredException.CertificateExpiredException(String)
  • CertificateExpiredException.CertificateExpiredException()
  • CertificateExpiredException.CertificateExpiredException(String)
  • CertificateExpiredException.CertificateExpiredException()


CertificateFactory

CertificateFactory o7planning.org
  • CertificateFactory.CertificateFactory(CertificateFactorySpi, Provider, String)


CertificateFactorySpi

CertificateFactorySpi o7planning.org
  • CertificateFactorySpi.CertificateFactorySpi()


CertificateNotYetValidException

CertificateNotYetValidException o7planning.org
  • CertificateNotYetValidException.CertificateNotYetValidException(String)
  • CertificateNotYetValidException.CertificateNotYetValidException()
  • CertificateNotYetValidException.CertificateNotYetValidException(String)
  • CertificateNotYetValidException.CertificateNotYetValidException()


CertificateParsingException

CertificateParsingException o7planning.org
  • CertificateParsingException.CertificateParsingException(String)
  • CertificateParsingException.CertificateParsingException()
  • CertificateParsingException.CertificateParsingException(Throwable)
  • CertificateParsingException.CertificateParsingException(String, Throwable)
  • CertificateParsingException.CertificateParsingException(String)
  • CertificateParsingException.CertificateParsingException()


CertificateRep

CertificateRep o7planning.org
  • Certificate.CertificateRep.CertificateRep(String, byte[])


CertificateRevokedException

CertificateRevokedException o7planning.org
  • CertificateRevokedException.CertificateRevokedException(Date, CRLReason, X500Principal, Map<String, Extension>)


certificates

certificates o7planning.org
  • Identity.certificates()


CertPath

CertPath o7planning.org
  • CertPath.CertPath(String)


CertPathBuilder

CertPathBuilder o7planning.org
  • CertPathBuilder.CertPathBuilder(CertPathBuilderSpi, Provider, String)


CertPathBuilderException

CertPathBuilderException o7planning.org
  • CertPathBuilderException.CertPathBuilderException(String, Throwable)
  • CertPathBuilderException.CertPathBuilderException(Throwable)
  • CertPathBuilderException.CertPathBuilderException(String)
  • CertPathBuilderException.CertPathBuilderException()


CertPathBuilderSpi

CertPathBuilderSpi o7planning.org
  • CertPathBuilderSpi.CertPathBuilderSpi()


CertPathRep

CertPathRep o7planning.org
  • CertPath.CertPathRep.CertPathRep(String, byte[])


CertPathTrustManagerParameters

CertPathTrustManagerParameters o7planning.org
  • CertPathTrustManagerParameters.CertPathTrustManagerParameters(CertPathParameters)


CertPathValidator

CertPathValidator o7planning.org
  • CertPathValidator.CertPathValidator(CertPathValidatorSpi, Provider, String)


CertPathValidatorException

CertPathValidatorException o7planning.org
  • CertPathValidatorException.CertPathValidatorException(String, Throwable, CertPath, int, CertPathValidatorException.Reason)
  • CertPathValidatorException.CertPathValidatorException(String, Throwable, CertPath, int)
  • CertPathValidatorException.CertPathValidatorException(String, Throwable)
  • CertPathValidatorException.CertPathValidatorException(Throwable)
  • CertPathValidatorException.CertPathValidatorException(String)
  • CertPathValidatorException.CertPathValidatorException()


CertPathValidatorSpi

CertPathValidatorSpi o7planning.org
  • CertPathValidatorSpi.CertPathValidatorSpi()


CertStore

CertStore o7planning.org
  • CertStore.CertStore(CertStoreSpi, Provider, String, CertStoreParameters)


CertStoreException

CertStoreException o7planning.org
  • CertStoreException.CertStoreException(String, Throwable)
  • CertStoreException.CertStoreException(Throwable)
  • CertStoreException.CertStoreException(String)
  • CertStoreException.CertStoreException()


CertStoreSpi

CertStoreSpi o7planning.org
  • CertStoreSpi.CertStoreSpi(CertStoreParameters)


CHAKMA

CHAKMA o7planning.org
  • Character.UnicodeBlock.CHAKMA


CHAM

CHAM o7planning.org
  • Character.UnicodeBlock.CHAM


CHANGE

CHANGE o7planning.org
  • DocumentEvent.EventType.CHANGE


change

change o7planning.org
  • DefaultStyledDocument.ElementBuffer.change(int, int, AbstractDocument.DefaultDocumentEvent)


CHANGED

CHANGED o7planning.org
  • DragSourceContext.CHANGED


ChangedCharSetException

ChangedCharSetException o7planning.org
  • ChangedCharSetException.ChangedCharSetException(String, boolean)


changedUpdate

changedUpdate o7planning.org
  • BlockView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • DocumentListener.changedUpdate(DocumentEvent)
  • FlowView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • FlowView.FlowStrategy.changedUpdate(FlowView, DocumentEvent, Rectangle)
  • GlyphView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • ImageView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • InlineView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • JTextComponent.AccessibleJTextComponent.changedUpdate(DocumentEvent)
  • LabelView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • ParagraphView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • PlainView.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • View.changedUpdate(DocumentEvent, Shape, ViewFactory)
  • WrappedPlainView.changedUpdate(DocumentEvent, Shape, ViewFactory)


changeEvent

changeEvent o7planning.org
  • DefaultCaret.changeEvent
  • DefaultTableColumnModel.changeEvent
  • JProgressBar.changeEvent
  • JSlider.changeEvent
  • JTabbedPane.changeEvent
  • MenuSelectionManager.changeEvent
  • StyleContext.NamedStyle.changeEvent


ChangeEvent

ChangeEvent o7planning.org
  • ChangeEvent.ChangeEvent(Object)


ChangeHandler

ChangeHandler o7planning.org
  • BasicMenuUI.ChangeHandler.ChangeHandler(JMenu, BasicMenuUI)
  • BasicProgressBarUI.ChangeHandler.ChangeHandler()
  • BasicSliderUI.ChangeHandler.ChangeHandler()


changeHighlight

changeHighlight o7planning.org
  • DefaultHighlighter.changeHighlight(Object, int, int)
  • Highlighter.changeHighlight(Object, int, int)


changeInfo

changeInfo o7planning.org
  • NamingEvent.changeInfo


changeListener

changeListener o7planning.org
  • AbstractButton.changeListener
  • BasicMenuBarUI.changeListener
  • BasicMenuUI.changeListener
  • BasicProgressBarUI.changeListener
  • BasicSliderUI.changeListener
  • JProgressBar.changeListener
  • JSlider.changeListener
  • JTabbedPane.changeListener


changeParameterType

changeParameterType o7planning.org
  • MethodType.changeParameterType(int, Class<?>)


changeReturnType

changeReturnType o7planning.org
  • MethodType.changeReturnType(Class<?>)


changeSelection

changeSelection o7planning.org
  • JTable.changeSelection(int, int, boolean, boolean)


changeShape

changeShape o7planning.org
  • Box.Filler.changeShape(Dimension, Dimension, Dimension)


changeSupport

changeSupport o7planning.org
  • AbstractAction.changeSupport
  • DefaultTreeSelectionModel.changeSupport


changeToParentDirectory

changeToParentDirectory o7planning.org
  • JFileChooser.changeToParentDirectory()


ChangeToParentDirectoryAction

ChangeToParentDirectoryAction o7planning.org
  • BasicFileChooserUI.ChangeToParentDirectoryAction.ChangeToParentDirectoryAction()


changeUpdate

changeUpdate o7planning.org
  • DefaultStyledDocument.ElementBuffer.changeUpdate()


channel

channel o7planning.org
  • FileLock.channel()
  • MembershipKey.channel()
  • SelectionKey.channel()
  • VoiceStatus.channel


CHANNEL_PRESSURE

CHANNEL_PRESSURE o7planning.org
  • ShortMessage.CHANNEL_PRESSURE


ChannelBinding

ChannelBinding o7planning.org
  • ChannelBinding.ChannelBinding(byte[])
  • ChannelBinding.ChannelBinding(InetAddress, InetAddress, byte[])


channels

channels o7planning.org
  • AudioFormat.channels


CHAR

CHAR o7planning.org
  • Types.CHAR


CHAR_ARRAY

CHAR_ARRAY o7planning.org
  • DocFlavor.CHAR_ARRAY.CHAR_ARRAY(String)


CHAR_REPLACEMENT

CHAR_REPLACEMENT o7planning.org
  • TextAttribute.CHAR_REPLACEMENT


CHAR_UNDEFINED

CHAR_UNDEFINED o7planning.org
  • KeyEvent.CHAR_UNDEFINED


Character

Character o7planning.org
  • Character.Character(char)


CHARACTER

CHARACTER o7planning.org
  • AccessibleText.CHARACTER
  • SimpleType.CHARACTER


CHARACTER_SET_ENCODING

CHARACTER_SET_ENCODING o7planning.org
  • SOAPMessage.CHARACTER_SET_ENCODING


CharacterAction

CharacterAction o7planning.org
  • HTMLDocument.HTMLReader.CharacterAction.CharacterAction()


CharacterCodingException

CharacterCodingException o7planning.org
  • CharacterCodingException.CharacterCodingException()


characteristics

characteristics o7planning.org
  • Collector.characteristics()
  • Spliterator.characteristics()
  • Spliterators.AbstractDoubleSpliterator.characteristics()
  • Spliterators.AbstractIntSpliterator.characteristics()
  • Spliterators.AbstractLongSpliterator.characteristics()
  • Spliterators.AbstractSpliterator.characteristics()


CHARACTERS

CHARACTERS o7planning.org
  • XMLStreamConstants.CHARACTERS


characters

characters o7planning.org
  • ContentHandler.characters(char[], int, int)
  • DefaultHandler.characters(char[], int, int)
  • DocumentHandler.characters(char[], int, int)
  • HandlerBase.characters(char[], int, int)
  • ParserAdapter.characters(char[], int, int)
  • XMLFilterImpl.characters(char[], int, int)
  • XMLReaderAdapter.characters(char[], int, int)


CharArrayReader

CharArrayReader o7planning.org
  • CharArrayReader.CharArrayReader(char[], int, int)
  • CharArrayReader.CharArrayReader(char[])


CharArrayWriter

CharArrayWriter o7planning.org
  • CharArrayWriter.CharArrayWriter(int)
  • CharArrayWriter.CharArrayWriter()


charAt

charAt o7planning.org
  • CharBuffer.charAt(int)
  • CharSequence.charAt(int)
  • Segment.charAt(int)
  • String.charAt(int)
  • StringBuffer.charAt(int)


charAttr

charAttr o7planning.org
  • HTMLDocument.HTMLReader.charAttr


CharConversionException

CharConversionException o7planning.org
  • CharConversionException.CharConversionException(String)
  • CharConversionException.CharConversionException()


charCount

charCount o7planning.org
  • Character.charCount(int)


CharHolder

CharHolder o7planning.org
  • CharHolder.CharHolder(char)
  • CharHolder.CharHolder()


chars

chars o7planning.org
  • CharBuffer.chars()
  • CharSequence.chars()


CharSeqHelper

CharSeqHelper o7planning.org
  • CharSeqHelper.CharSeqHelper()


CharSeqHolder

CharSeqHolder o7planning.org
  • CharSeqHolder.CharSeqHolder(char[])
  • CharSeqHolder.CharSeqHolder()


Charset

Charset o7planning.org
  • Charset.Charset(String, String[])


charset

charset o7planning.org
  • CharsetDecoder.charset()
  • CharsetEncoder.charset()


CharsetDecoder

CharsetDecoder o7planning.org
  • CharsetDecoder.CharsetDecoder(Charset, float, float)


CharsetEncoder

CharsetEncoder o7planning.org
  • CharsetEncoder.CharsetEncoder(Charset, float, float)
  • CharsetEncoder.CharsetEncoder(Charset, float, float, byte[])


charsetForName

charsetForName o7planning.org
  • CharsetProvider.charsetForName(String)


CharsetProvider

CharsetProvider o7planning.org
  • CharsetProvider.CharsetProvider()


charsets

charsets o7planning.org
  • CharsetProvider.charsets()


charStream

charStream o7planning.org
  • BaseRowSet.charStream


charsWidth

charsWidth o7planning.org
  • FontMetrics.charsWidth(char[], int, int)


charValue

charValue o7planning.org
  • Character.charValue()


charWidth

charWidth o7planning.org
  • FontMetrics.charWidth(char)
  • FontMetrics.charWidth(int)


check

check o7planning.org
  • CertPathChecker.check(Certificate)
  • MLet.check(String, URL, String, MLetContent)
  • PKIXCertPathChecker.check(Certificate)
  • PKIXCertPathChecker.check(Certificate, Collection<String>)


CHECK_BOX

CHECK_BOX o7planning.org
  • AccessibleRole.CHECK_BOX
  • Region.CHECK_BOX


CHECK_BOX_MENU_ITEM

CHECK_BOX_MENU_ITEM o7planning.org
  • Region.CHECK_BOX_MENU_ITEM


checkAccept

checkAccept o7planning.org
  • SecurityManager.checkAccept(String, int)


checkAccess

checkAccess o7planning.org
  • FileSystemProvider.checkAccess(Path, AccessMode...)
  • LogManager.checkAccess()
  • SecurityManager.checkAccess(ThreadGroup)
  • SecurityManager.checkAccess(Thread)
  • Thread.checkAccess()
  • ThreadGroup.checkAccess()


checkAll

checkAll o7planning.org
  • MediaTracker.checkAll(boolean)
  • MediaTracker.checkAll()


checkAwtEventQueueAccess

checkAwtEventQueueAccess o7planning.org
  • SecurityManager.checkAwtEventQueueAccess()


Checkbox

Checkbox o7planning.org
  • Checkbox.Checkbox(String, CheckboxGroup, boolean)
  • Checkbox.Checkbox(String, boolean, CheckboxGroup)
  • Checkbox.Checkbox(String, boolean)
  • Checkbox.Checkbox(String)
  • Checkbox.Checkbox()


CheckboxGroup

CheckboxGroup o7planning.org
  • CheckboxGroup.CheckboxGroup()


CheckboxMenuItem

CheckboxMenuItem o7planning.org
  • CheckboxMenuItem.CheckboxMenuItem(String, boolean)
  • CheckboxMenuItem.CheckboxMenuItem(String)
  • CheckboxMenuItem.CheckboxMenuItem()


checkClientTrusted

checkClientTrusted o7planning.org
  • X509ExtendedTrustManager.checkClientTrusted(X509Certificate[], String, SSLEngine)
  • X509ExtendedTrustManager.checkClientTrusted(X509Certificate[], String, Socket)
  • X509TrustManager.checkClientTrusted(X509Certificate[], String)


checkClosed

checkClosed o7planning.org
  • ImageInputStreamImpl.checkClosed()


checkConnect

checkConnect o7planning.org
  • SecurityManager.checkConnect(String, int, Object)
  • SecurityManager.checkConnect(String, int)


checkCreateClassLoader

checkCreateClassLoader o7planning.org
  • SecurityManager.checkCreateClassLoader()


checkDelete

checkDelete o7planning.org
  • SecurityManager.checkDelete(String)


CHECKED

CHECKED o7planning.org
  • AccessibleState.CHECKED
  • HTML.Attribute.CHECKED


checkedCollection

checkedCollection o7planning.org
  • Collections.checkedCollection(Collection<E>, Class<E>)


CheckedInputStream

CheckedInputStream o7planning.org
  • CheckedInputStream.CheckedInputStream(InputStream, Checksum)


checkedList

checkedList o7planning.org
  • Collections.checkedList(List<E>, Class<E>)


checkedMap

checkedMap o7planning.org
  • Collections.checkedMap(Map<K, V>, Class<K>, Class<V>)


checkedNavigableMap

checkedNavigableMap o7planning.org
  • Collections.checkedNavigableMap(NavigableMap<K, V>, Class<K>, Class<V>)


checkedNavigableSet

checkedNavigableSet o7planning.org
  • Collections.checkedNavigableSet(NavigableSet<E>, Class<E>)


CheckedOutputStream

CheckedOutputStream o7planning.org
  • CheckedOutputStream.CheckedOutputStream(OutputStream, Checksum)


checkedQueue

checkedQueue o7planning.org
  • Collections.checkedQueue(Queue<E>, Class<E>)


checkedSet

checkedSet o7planning.org
  • Collections.checkedSet(Set<E>, Class<E>)


checkedSortedMap

checkedSortedMap o7planning.org
  • Collections.checkedSortedMap(SortedMap<K, V>, Class<K>, Class<V>)


checkedSortedSet

checkedSortedSet o7planning.org
  • Collections.checkedSortedSet(SortedSet<E>, Class<E>)


checkError

checkError o7planning.org
  • PrintStream.checkError()
  • PrintWriter.checkError()


checkExec

checkExec o7planning.org
  • SecurityManager.checkExec(String)


checkExit

checkExit o7planning.org
  • SecurityManager.checkExit(int)


checkForClickInExpandControl

checkForClickInExpandControl o7planning.org
  • BasicTreeUI.checkForClickInExpandControl(TreePath, int, int)


checkGuard

checkGuard o7planning.org
  • Guard.checkGuard(Object)
  • Permission.checkGuard(Object)


checkHorizontalKey

checkHorizontalKey o7planning.org
  • AbstractButton.checkHorizontalKey(int, String)
  • JLabel.checkHorizontalKey(int, String)


checkIcon

checkIcon o7planning.org
  • BasicMenuItemUI.checkIcon


checkID

checkID o7planning.org
  • MediaTracker.checkID(int, boolean)
  • MediaTracker.checkID(int)


checkImage

checkImage o7planning.org
  • Component.checkImage(Image, int, int, ImageObserver)
  • Component.checkImage(Image, ImageObserver)
  • Toolkit.checkImage(Image, int, int, ImageObserver)


checkLink

checkLink o7planning.org
  • SecurityManager.checkLink(String)


checkListen

checkListen o7planning.org
  • SecurityManager.checkListen(int)


checkMaxDegree

checkMaxDegree o7planning.org
  • RoleInfo.checkMaxDegree(int)


checkMemberAccess

checkMemberAccess o7planning.org
  • SecurityManager.checkMemberAccess(Class<?>, int)


checkMinDegree

checkMinDegree o7planning.org
  • RoleInfo.checkMinDegree(int)


checkMulticast

checkMulticast o7planning.org
  • SecurityManager.checkMulticast(InetAddress, byte)
  • SecurityManager.checkMulticast(InetAddress)


checkOpacity

checkOpacity o7planning.org
  • BasicButtonListener.checkOpacity(AbstractButton)


checkPackageAccess

checkPackageAccess o7planning.org
  • SecurityManager.checkPackageAccess(String)


checkPackageDefinition

checkPackageDefinition o7planning.org
  • SecurityManager.checkPackageDefinition(String)


checkPainter

checkPainter o7planning.org
  • GlyphView.checkPainter()


checkPermission

checkPermission o7planning.org
  • AccessControlContext.checkPermission(Permission)
  • AccessController.checkPermission(Permission)
  • Acl.checkPermission(Principal, Permission)
  • AclEntry.checkPermission(Permission)
  • SecurityManager.checkPermission(Permission, Object)
  • SecurityManager.checkPermission(Permission)


checkPrintJobAccess

checkPrintJobAccess o7planning.org
  • SecurityManager.checkPrintJobAccess()


checkPropertiesAccess

checkPropertiesAccess o7planning.org
  • SecurityManager.checkPropertiesAccess()


checkPropertyAccess

checkPropertyAccess o7planning.org
  • SecurityManager.checkPropertyAccess(String)


checkRead

checkRead o7planning.org
  • SecurityManager.checkRead(String, Object)
  • SecurityManager.checkRead(String)
  • SecurityManager.checkRead(FileDescriptor)


checkReadParamBandSettings

checkReadParamBandSettings o7planning.org
  • ImageReader.checkReadParamBandSettings(ImageReadParam, int, int)


checkRoleReading

checkRoleReading o7planning.org
  • RelationService.checkRoleReading(String, String)
  • RelationServiceMBean.checkRoleReading(String, String)


checkRoleWriting

checkRoleWriting o7planning.org
  • RelationService.checkRoleWriting(Role, String, Boolean)
  • RelationServiceMBean.checkRoleWriting(Role, String, Boolean)


checkSecurityAccess

checkSecurityAccess o7planning.org
  • SecurityManager.checkSecurityAccess(String)


checkServerTrusted

checkServerTrusted o7planning.org
  • X509ExtendedTrustManager.checkServerTrusted(X509Certificate[], String, SSLEngine)
  • X509ExtendedTrustManager.checkServerTrusted(X509Certificate[], String, Socket)
  • X509TrustManager.checkServerTrusted(X509Certificate[], String)


checkSetFactory

checkSetFactory o7planning.org
  • SecurityManager.checkSetFactory()


checkSystemClipboardAccess

checkSystemClipboardAccess o7planning.org
  • SecurityManager.checkSystemClipboardAccess()


checkTopLevelWindow

checkTopLevelWindow o7planning.org
  • SecurityManager.checkTopLevelWindow(Object)


checkValidIntValue

checkValidIntValue o7planning.org
  • ChronoField.checkValidIntValue(long)
  • ValueRange.checkValidIntValue(long, TemporalField)


checkValidity

checkValidity o7planning.org
  • X509Certificate.checkValidity(Date)
  • X509Certificate.checkValidity()
  • X509Certificate.checkValidity(Date)
  • X509Certificate.checkValidity()


checkValidValue

checkValidValue o7planning.org
  • ChronoField.checkValidValue(long)
  • ValueRange.checkValidValue(long, TemporalField)


checkVerticalKey

checkVerticalKey o7planning.org
  • AbstractButton.checkVerticalKey(int, String)
  • JLabel.checkVerticalKey(int, String)


checkWrite

checkWrite o7planning.org
  • SecurityManager.checkWrite(String)
  • SecurityManager.checkWrite(FileDescriptor)


CHEROKEE

CHEROKEE o7planning.org
  • Character.UnicodeBlock.CHEROKEE


CHILD_NODE_OF

CHILD_NODE_OF o7planning.org
  • AccessibleRelation.CHILD_NODE_OF


CHILD_NODE_OF_PROPERTY

CHILD_NODE_OF_PROPERTY o7planning.org
  • AccessibleRelation.CHILD_NODE_OF_PROPERTY


CHILD_POLICY_ALL

CHILD_POLICY_ALL o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_ALL


CHILD_POLICY_CHOICE

CHILD_POLICY_CHOICE o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_CHOICE


CHILD_POLICY_EMPTY

CHILD_POLICY_EMPTY o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_EMPTY


CHILD_POLICY_MAX

CHILD_POLICY_MAX o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_MAX


CHILD_POLICY_REPEAT

CHILD_POLICY_REPEAT o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_REPEAT


CHILD_POLICY_SEQUENCE

CHILD_POLICY_SEQUENCE o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_SEQUENCE


CHILD_POLICY_SOME

CHILD_POLICY_SOME o7planning.org
  • IIOMetadataFormat.CHILD_POLICY_SOME


childAdded

childAdded o7planning.org
  • NodeChangeListener.childAdded(NodeChangeEvent)


childAlloc

childAlloc o7planning.org
  • AsyncBoxView.ChildLocator.childAlloc


childAllocation

childAllocation o7planning.org
  • BoxView.childAllocation(int, Rectangle)
  • CompositeView.childAllocation(int, Rectangle)


childChanged

childChanged o7planning.org
  • AsyncBoxView.ChildLocator.childChanged(AsyncBoxView.ChildState)


childDeserializedHook

childDeserializedHook o7planning.org
  • BeanContextSupport.childDeserializedHook(Object, BeanContextSupport.BCSChild)


childIndices

childIndices o7planning.org
  • TreeModelEvent.childIndices


childJustAddedHook

childJustAddedHook o7planning.org
  • BeanContextSupport.childJustAddedHook(Object, BeanContextSupport.BCSChild)


childJustRemovedHook

childJustRemovedHook o7planning.org
  • BeanContextServicesSupport.childJustRemovedHook(Object, BeanContextSupport.BCSChild)
  • BeanContextSupport.childJustRemovedHook(Object, BeanContextSupport.BCSChild)


ChildLocator

ChildLocator o7planning.org
  • AsyncBoxView.ChildLocator.ChildLocator()


childRemoved

childRemoved o7planning.org
  • NodeChangeListener.childRemoved(NodeChangeEvent)


children

children o7planning.org
  • AbstractDocument.AbstractElement.children()
  • AbstractDocument.BranchElement.children()
  • AbstractDocument.LeafElement.children()
  • BeanContextMembershipEvent.children
  • BeanContextSupport.children
  • DefaultMutableTreeNode.children()
  • DefaultMutableTreeNode.children
  • JTree.DynamicUtilTreeNode.children()
  • TreeModelEvent.children
  • TreeNode.children()


childrenAdded

childrenAdded o7planning.org
  • BeanContextMembershipListener.childrenAdded(BeanContextMembershipEvent)


childrenNames

childrenNames o7planning.org
  • AbstractPreferences.childrenNames()
  • Preferences.childrenNames()


childrenNamesSpi

childrenNamesSpi o7planning.org
  • AbstractPreferences.childrenNamesSpi()


childrenRemoved

childrenRemoved o7planning.org
  • BeanContextMembershipListener.childrenRemoved(BeanContextMembershipEvent)


childSpi

childSpi o7planning.org
  • AbstractPreferences.childSpi(String)


ChildState

ChildState o7planning.org
  • AsyncBoxView.ChildState.ChildState(View)


childValue

childValue o7planning.org
  • InheritableThreadLocal.childValue(T)
  • JTree.DynamicUtilTreeNode.childValue


CHINA

CHINA o7planning.org
  • Locale.CHINA


CHINESE

CHINESE o7planning.org
  • Locale.CHINESE


Choice

Choice o7planning.org
  • Choice.Choice()


ChoiceCallback

ChoiceCallback o7planning.org
  • ChoiceCallback.ChoiceCallback(String, String[], int, boolean)


ChoiceFormat

ChoiceFormat o7planning.org
  • ChoiceFormat.ChoiceFormat(double[], String[])
  • ChoiceFormat.ChoiceFormat(String)


choices

choices o7planning.org
  • DriverPropertyInfo.choices


CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY

CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY o7planning.org
  • JFileChooser.CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY


chooseClientAlias

chooseClientAlias o7planning.org
  • X509KeyManager.chooseClientAlias(String[], Principal[], Socket)


chooseEngineClientAlias

chooseEngineClientAlias o7planning.org
  • X509ExtendedKeyManager.chooseEngineClientAlias(String[], Principal[], SSLEngine)


chooseEngineServerAlias

chooseEngineServerAlias o7planning.org
  • X509ExtendedKeyManager.chooseEngineServerAlias(String, Principal[], SSLEngine)


chooser

chooser o7planning.org
  • BasicColorChooserUI.chooser


CHOOSER_PANELS_PROPERTY

CHOOSER_PANELS_PROPERTY o7planning.org
  • JColorChooser.CHOOSER_PANELS_PROPERTY


chooseServerAlias

chooseServerAlias o7planning.org
  • X509KeyManager.chooseServerAlias(String, Principal[], Socket)


CHORD

CHORD o7planning.org
  • Arc2D.CHORD


CHOU_1

CHOU_1 o7planning.org
  • MediaSize.JIS.CHOU_1


CHOU_2

CHOU_2 o7planning.org
  • MediaSize.JIS.CHOU_2


CHOU_3

CHOU_3 o7planning.org
  • MediaSize.JIS.CHOU_3


CHOU_4

CHOU_4 o7planning.org
  • MediaSize.JIS.CHOU_4


CHOU_30

CHOU_30 o7planning.org
  • MediaSize.JIS.CHOU_30


CHOU_40

CHOU_40 o7planning.org
  • MediaSize.JIS.CHOU_40


Chromaticity

Chromaticity o7planning.org
  • Chromaticity.Chromaticity(int)


chronology

chronology o7planning.org
  • TemporalQueries.chronology()


chunkLength

chunkLength o7planning.org
  • HttpURLConnection.chunkLength


Cipher

Cipher o7planning.org
  • Cipher.Cipher(CipherSpi, Provider, String)


CipherInputStream

CipherInputStream o7planning.org
  • CipherInputStream.CipherInputStream(InputStream)
  • CipherInputStream.CipherInputStream(InputStream, Cipher)


CipherOutputStream

CipherOutputStream o7planning.org
  • CipherOutputStream.CipherOutputStream(OutputStream)
  • CipherOutputStream.CipherOutputStream(OutputStream, Cipher)


CipherSpi

CipherSpi o7planning.org
  • CipherSpi.CipherSpi()


CITE

CITE o7planning.org
  • HTML.Tag.CITE


CJK_COMPATIBILITY

CJK_COMPATIBILITY o7planning.org
  • Character.UnicodeBlock.CJK_COMPATIBILITY


CJK_COMPATIBILITY_FORMS

CJK_COMPATIBILITY_FORMS o7planning.org
  • Character.UnicodeBlock.CJK_COMPATIBILITY_FORMS


CJK_COMPATIBILITY_IDEOGRAPHS

CJK_COMPATIBILITY_IDEOGRAPHS o7planning.org
  • Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS


CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT

CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT


CJK_RADICALS_SUPPLEMENT

CJK_RADICALS_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.CJK_RADICALS_SUPPLEMENT


CJK_STROKES

CJK_STROKES o7planning.org
  • Character.UnicodeBlock.CJK_STROKES


CJK_SYMBOLS_AND_PUNCTUATION

CJK_SYMBOLS_AND_PUNCTUATION o7planning.org
  • Character.UnicodeBlock.CJK_SYMBOLS_AND_PUNCTUATION


CJK_UNIFIED_IDEOGRAPHS

CJK_UNIFIED_IDEOGRAPHS o7planning.org
  • Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS


CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A o7planning.org
  • Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A


CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B o7planning.org
  • Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B


CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C o7planning.org
  • Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C


CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D o7planning.org
  • Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D


CLASS

CLASS o7planning.org
  • HTML.Attribute.CLASS


CLASS_ABSTRACT

CLASS_ABSTRACT o7planning.org
  • ICC_Profile.CLASS_ABSTRACT


CLASS_ATTRIBUTE_PFX

CLASS_ATTRIBUTE_PFX o7planning.org
  • Pack200.Packer.CLASS_ATTRIBUTE_PFX


CLASS_COLORSPACECONVERSION

CLASS_COLORSPACECONVERSION o7planning.org
  • ICC_Profile.CLASS_COLORSPACECONVERSION


CLASS_DEVICELINK

CLASS_DEVICELINK o7planning.org
  • ICC_Profile.CLASS_DEVICELINK


CLASS_DISPLAY

CLASS_DISPLAY o7planning.org
  • ICC_Profile.CLASS_DISPLAY


CLASS_INPUT

CLASS_INPUT o7planning.org
  • ICC_Profile.CLASS_INPUT


CLASS_LOADING_MXBEAN_NAME

CLASS_LOADING_MXBEAN_NAME o7planning.org
  • ManagementFactory.CLASS_LOADING_MXBEAN_NAME


CLASS_NAMEDCOLOR

CLASS_NAMEDCOLOR o7planning.org
  • ICC_Profile.CLASS_NAMEDCOLOR


CLASS_OUTPUT

CLASS_OUTPUT o7planning.org
  • ICC_Profile.CLASS_OUTPUT


CLASS_PATH

CLASS_PATH o7planning.org
  • Attributes.Name.CLASS_PATH


classattr

classattr o7planning.org
  • Query.classattr()


ClassCastException

ClassCastException o7planning.org
  • ClassCastException.ClassCastException(String)
  • ClassCastException.ClassCastException()


ClassCircularityError

ClassCircularityError o7planning.org
  • ClassCircularityError.ClassCircularityError(String)
  • ClassCircularityError.ClassCircularityError()


ClassDefinition

ClassDefinition o7planning.org
  • ClassDefinition.ClassDefinition(Class<?>, byte[])


classDepth

classDepth o7planning.org
  • SecurityManager.classDepth(String)


ClassDesc

ClassDesc o7planning.org
  • ClassDesc.ClassDesc()


classEquals

classEquals o7planning.org
  • BeanContextSupport.classEquals(Class, Class)


classFactory

classFactory o7planning.org
  • Reference.classFactory


classFactoryLocation

classFactoryLocation o7planning.org
  • Reference.classFactoryLocation


ClassFormatError

ClassFormatError o7planning.org
  • ClassFormatError.ClassFormatError(String)
  • ClassFormatError.ClassFormatError()


CLASSID

CLASSID o7planning.org
  • HTML.Attribute.CLASSID


ClassLoader

ClassLoader o7planning.org
  • ClassLoader.ClassLoader()
  • ClassLoader.ClassLoader(ClassLoader)


classLoaderDepth

classLoaderDepth o7planning.org
  • SecurityManager.classLoaderDepth()


classModifiers

classModifiers o7planning.org
  • Modifier.classModifiers()


classname

classname o7planning.org
  • InvalidClassException.classname


className

className o7planning.org
  • Reference.className


ClassNotFoundException

ClassNotFoundException o7planning.org
  • ClassNotFoundException.ClassNotFoundException(String, Throwable)
  • ClassNotFoundException.ClassNotFoundException(String)
  • ClassNotFoundException.ClassNotFoundException()


ClassValue

ClassValue o7planning.org
  • ClassValue.ClassValue()


clean

clean o7planning.org
  • DGC.clean(ObjID[], long, VMID, boolean)


CLEAR

CLEAR o7planning.org
  • CSS.Attribute.CLEAR
  • HTML.Attribute.CLEAR


Clear

Clear o7planning.org
  • AlphaComposite.Clear


clear

clear o7planning.org
  • AttributeListImpl.clear()
  • AttributesImpl.clear()
  • Environment.clear()
  • XMLGregorianCalendar.clear()


clearAbortRequest

clearAbortRequest o7planning.org
  • ImageReader.clearAbortRequest()
  • ImageWriter.clearAbortRequest()


clearAccessibleSelection

clearAccessibleSelection o7planning.org
  • AccessibleSelection.clearAccessibleSelection()
  • JComboBox.AccessibleJComboBox.clearAccessibleSelection()
  • JList.AccessibleJList.clearAccessibleSelection()
  • JMenu.AccessibleJMenu.clearAccessibleSelection()
  • JMenuBar.AccessibleJMenuBar.clearAccessibleSelection()
  • JTabbedPane.AccessibleJTabbedPane.clearAccessibleSelection()
  • JTable.AccessibleJTable.clearAccessibleSelection()
  • JTree.AccessibleJTree.clearAccessibleSelection()
  • JTree.AccessibleJTree.AccessibleJTreeNode.clearAccessibleSelection()
  • List.AccessibleAWTList.clearAccessibleSelection()
  • MenuComponent.AccessibleAWTMenuComponent.clearAccessibleSelection()


clearAssertionStatus

clearAssertionStatus o7planning.org
  • ClassLoader.clearAssertionStatus()


clearAutoscroll

clearAutoscroll o7planning.org
  • DropTarget.clearAutoscroll()


clearBatch

clearBatch o7planning.org
  • Statement.clearBatch()


clearBit

clearBit o7planning.org
  • BigInteger.clearBit(int)


clearCache

clearCache o7planning.org
  • ResourceBundle.clearCache(ClassLoader)
  • ResourceBundle.clearCache()


clearChanged

clearChanged o7planning.org
  • Observable.clearChanged()


clearContent

clearContent o7planning.org
  • AttachmentPart.clearContent()


clearError

clearError o7planning.org
  • PrintStream.clearError()
  • PrintWriter.clearError()


clearExtensions

clearExtensions o7planning.org
  • Locale.Builder.clearExtensions()


clearFocusOwner

clearFocusOwner o7planning.org
  • KeyboardFocusManager.clearFocusOwner()


clearGlobalFocusOwner

clearGlobalFocusOwner o7planning.org
  • KeyboardFocusManager.clearGlobalFocusOwner()


clearIconCache

clearIconCache o7planning.org
  • BasicFileChooserUI.clearIconCache()
  • BasicFileChooserUI.BasicFileView.clearIconCache()


clearParameters

clearParameters o7planning.org
  • BaseRowSet.clearParameters()
  • PreparedStatement.clearParameters()
  • RowSet.clearParameters()
  • Transformer.clearParameters()


clearPassword

clearPassword o7planning.org
  • PBEKeySpec.clearPassword()
  • PasswordCallback.clearPassword()


clearProperty

clearProperty o7planning.org
  • System.clearProperty(String)


clearRect

clearRect o7planning.org
  • DebugGraphics.clearRect(int, int, int, int)
  • Graphics.clearRect(int, int, int, int)


clearSelectedPath

clearSelectedPath o7planning.org
  • MenuSelectionManager.clearSelectedPath()


clearSelection

clearSelection o7planning.org
  • ButtonGroup.clearSelection()
  • DefaultListSelectionModel.clearSelection()
  • DefaultSingleSelectionModel.clearSelection()
  • DefaultTreeSelectionModel.clearSelection()
  • JList.clearSelection()
  • JTable.clearSelection()
  • JTree.clearSelection()
  • ListSelectionModel.clearSelection()
  • SingleSelectionModel.clearSelection()
  • TreeSelectionModel.clearSelection()


clearTextShiftOffset

clearTextShiftOffset o7planning.org
  • BasicButtonUI.clearTextShiftOffset()


clearToggledPaths

clearToggledPaths o7planning.org
  • JTree.clearToggledPaths()


clearWarnings

clearWarnings o7planning.org
  • Connection.clearWarnings()
  • ResultSet.clearWarnings()
  • Statement.clearWarnings()


CLICK

CLICK o7planning.org
  • AccessibleAction.CLICK


clickCount

clickCount o7planning.org
  • Event.clickCount


clickCountToStart

clickCountToStart o7planning.org
  • DefaultCellEditor.clickCountToStart


clientClosed

clientClosed o7planning.org
  • RMIServerImpl.clientClosed(RMIConnection)


clip

clip o7planning.org
  • Graphics2D.clip(Shape)


Clipboard

Clipboard o7planning.org
  • Clipboard.Clipboard(String)


clipRect

clipRect o7planning.org
  • DebugGraphics.clipRect(int, int, int, int)
  • Graphics.clipRect(int, int, int, int)


CLOB

CLOB o7planning.org
  • Types.CLOB


Clock

Clock o7planning.org
  • Clock.Clock()


clockSequence

clockSequence o7planning.org
  • UUID.clockSequence()


clone

clone o7planning.org
  • AbstractAction.clone()
  • AbstractMap.clone()
  • AclEntry.clone()
  • AffineTransform.clone()
  • Area.clone()
  • ArrayDeque.clone()
  • ArrayList.clone()
  • Attribute.clone()
  • Attributes.clone()
  • Attributes.clone()
  • BasicAttribute.clone()
  • BasicAttributes.clone()
  • BitSet.clone()
  • BreakIterator.clone()
  • BufferCapabilities.clone()
  • CRLSelector.clone()
  • Calendar.clone()
  • CertPathBuilderResult.clone()
  • CertPathParameters.clone()
  • CertPathValidatorResult.clone()
  • CertSelector.clone()
  • CertStoreParameters.clone()
  • CharacterIterator.clone()
  • ChoiceFormat.clone()
  • Collator.clone()
  • CollectionCertStoreParameters.clone()
  • CompositeName.clone()
  • CompoundName.clone()
  • ConcurrentSkipListMap.clone()
  • ConcurrentSkipListSet.clone()
  • CopyOnWriteArrayList.clone()
  • CubicCurve2D.clone()
  • DataFlavor.clone()
  • Date.clone()
  • DateFormat.clone()
  • DateFormatSymbols.clone()
  • DecimalFormat.clone()
  • DecimalFormatSymbols.clone()
  • DefaultFormatter.clone()
  • DefaultListSelectionModel.clone()
  • DefaultMutableTreeNode.clone()
  • DefaultStyledDocument.ElementBuffer.clone(Element, Element)
  • DefaultTreeSelectionModel.clone()
  • Descriptor.clone()
  • DescriptorSupport.clone()
  • Dimension2D.clone()
  • EditorKit.clone()
  • ElementIterator.clone()
  • Enum.clone()
  • EnumMap.clone()
  • EnumSet.clone()
  • EnumSyntax.clone()
  • Format.clone()
  • GlyphView.clone()
  • GregorianCalendar.clone()
  • GridBagConstraints.clone()
  • HTMLEditorKit.clone()
  • HashMap.clone()
  • HashSet.clone()
  • Hashtable.clone()
  • HttpCookie.clone()
  • IdentityHashMap.clone()
  • ImageCapabilities.clone()
  • ImageFilter.clone()
  • ImmutableDescriptor.clone()
  • Insets.clone()
  • InternationalFormatter.clone()
  • JFormattedTextField.AbstractFormatter.clone()
  • JobAttributes.clone()
  • Kernel.clone()
  • LDAPCertStoreParameters.clone()
  • LdapName.clone()
  • Line2D.clone()
  • LinkedList.clone()
  • Locale.clone()
  • MBeanAttributeInfo.clone()
  • MBeanConstructorInfo.clone()
  • MBeanInfo.clone()
  • MBeanNotificationInfo.clone()
  • MBeanOperationInfo.clone()
  • MBeanParameterInfo.clone()
  • Mac.clone()
  • MacSpi.clone()
  • Manifest.clone()
  • MessageDigest.clone()
  • MessageDigestSpi.clone()
  • MessageFormat.clone()
  • MetaMessage.clone()
  • MidiMessage.clone()
  • ModelMBeanAttributeInfo.clone()
  • ModelMBeanConstructorInfo.clone()
  • ModelMBeanInfo.clone()
  • ModelMBeanInfoSupport.clone()
  • ModelMBeanNotificationInfo.clone()
  • ModelMBeanOperationInfo.clone()
  • Name.clone()
  • NumberFormat.clone()
  • Object.clone()
  • PKIXCertPathChecker.clone()
  • PKIXCertPathValidatorResult.clone()
  • PKIXParameters.clone()
  • PKIXRevocationChecker.clone()
  • PageAttributes.clone()
  • PageFormat.clone()
  • Paper.clone()
  • ParameterBlock.clone()
  • Path2D.clone()
  • Path2D.Double.clone()
  • Path2D.Float.clone()
  • Point2D.clone()
  • QuadCurve2D.clone()
  • RectangularShape.clone()
  • Reference.clone()
  • RenderContext.clone()
  • RenderingHints.clone()
  • Role.clone()
  • RoleUnresolved.clone()
  • RuleBasedCollator.clone()
  • Segment.clone()
  • SerialArray.clone()
  • SerialBlob.clone()
  • SerialClob.clone()
  • SerialDatalink.clone()
  • SerialJavaObject.clone()
  • SerialRef.clone()
  • SerialStruct.clone()
  • ShortMessage.clone()
  • Signature.clone()
  • SignatureSpi.clone()
  • SimpleAttributeSet.clone()
  • SimpleDateFormat.clone()
  • SimpleTimeZone.clone()
  • StringCharacterIterator.clone()
  • StyleContext.SmallAttributeSet.clone()
  • StyledEditorKit.clone()
  • SysexMessage.clone()
  • TabularDataSupport.clone()
  • TextLayout.clone()
  • TextMeasurer.clone()
  • Thread.clone()
  • TimeZone.clone()
  • TreeMap.clone()
  • TreeSet.clone()
  • UnicastRemoteObject.clone()
  • Vector.clone()
  • X509CRLSelector.clone()
  • X509CertSelector.clone()
  • XMLGregorianCalendar.clone()
  • ZipEntry.clone()


cloneNode

cloneNode o7planning.org
  • IIOMetadataNode.cloneNode(boolean)
  • Node.cloneNode(boolean)


CloneNotSupportedException

CloneNotSupportedException o7planning.org
  • CloneNotSupportedException.CloneNotSupportedException(String)
  • CloneNotSupportedException.CloneNotSupportedException()


cloneWithSource

cloneWithSource o7planning.org
  • TreeSelectionEvent.cloneWithSource(Object)


closable

closable o7planning.org
  • JInternalFrame.closable


close

close o7planning.org
  • EventReaderDelegate.close()
  • ForwardingJavaFileManager.close()
  • Handler.close(MessageContext)
  • HttpExchange.close()
  • JavaFileManager.close()
  • PooledConnection.close()
  • ProgressMonitor.close()
  • ProgressMonitorInputStream.close()
  • SOAPConnection.close()
  • StreamReaderDelegate.close()
  • XMLEventReader.close()
  • XMLEventWriter.close()
  • XMLStreamReader.close()
  • XMLStreamWriter.close()


CLOSE

CLOSE o7planning.org
  • LineEvent.Type.CLOSE


CLOSE_ALL_RESULTS

CLOSE_ALL_RESULTS o7planning.org
  • Statement.CLOSE_ALL_RESULTS


CLOSE_CMD

CLOSE_CMD o7planning.org
  • BasicInternalFrameTitlePane.CLOSE_CMD


CLOSE_CURRENT_RESULT

CLOSE_CURRENT_RESULT o7planning.org
  • Statement.CLOSE_CURRENT_RESULT


CLOSE_CURSORS_AT_COMMIT

CLOSE_CURSORS_AT_COMMIT o7planning.org
  • ResultSet.CLOSE_CURSORS_AT_COMMIT


CLOSE_FAILURE

CLOSE_FAILURE o7planning.org
  • ErrorManager.CLOSE_FAILURE


CloseAction

CloseAction o7planning.org
  • BasicInternalFrameTitlePane.CloseAction.CloseAction()


closeAction

closeAction o7planning.org
  • BasicInternalFrameTitlePane.closeAction


closeButton

closeButton o7planning.org
  • BasicInternalFrameTitlePane.closeButton


closeClient

closeClient o7planning.org
  • RMIIIOPServerImpl.closeClient(RMIConnection)
  • RMIJRMPServerImpl.closeClient(RMIConnection)
  • RMIServerImpl.closeClient(RMIConnection)


CLOSED

CLOSED o7planning.org
  • JMXConnectionNotification.CLOSED


CLOSED_OPTION

CLOSED_OPTION o7planning.org
  • JOptionPane.CLOSED_OPTION


ClosedByInterruptException

ClosedByInterruptException o7planning.org
  • ClosedByInterruptException.ClosedByInterruptException()


ClosedChannelException

ClosedChannelException o7planning.org
  • ClosedChannelException.ClosedChannelException()


ClosedDirectoryStreamException

ClosedDirectoryStreamException o7planning.org
  • ClosedDirectoryStreamException.ClosedDirectoryStreamException()


ClosedFileSystemException

ClosedFileSystemException o7planning.org
  • ClosedFileSystemException.ClosedFileSystemException()


closedIcon

closedIcon o7planning.org
  • DefaultTreeCellRenderer.closedIcon


ClosedSelectorException

ClosedSelectorException o7planning.org
  • ClosedSelectorException.ClosedSelectorException()


ClosedWatchServiceException

ClosedWatchServiceException o7planning.org
  • ClosedWatchServiceException.ClosedWatchServiceException()


closeEntry

closeEntry o7planning.org
  • ZipInputStream.closeEntry()
  • ZipOutputStream.closeEntry()


closeFrame

closeFrame o7planning.org
  • BasicInternalFrameUI.closeFrame(JInternalFrame)
  • DefaultDesktopManager.closeFrame(JInternalFrame)
  • DesktopManager.closeFrame(JInternalFrame)


closeIcon

closeIcon o7planning.org
  • BasicInternalFrameTitlePane.closeIcon


closeInbound

closeInbound o7planning.org
  • SSLEngine.closeInbound()


closeKey

closeKey o7planning.org
  • BasicDesktopPaneUI.closeKey


closeOnCompletion

closeOnCompletion o7planning.org
  • Statement.closeOnCompletion()


closeOutbound

closeOutbound o7planning.org
  • SSLEngine.closeOutbound()


closeOutUnwantedEmbeddedTags

closeOutUnwantedEmbeddedTags o7planning.org
  • HTMLWriter.closeOutUnwantedEmbeddedTags(AttributeSet)


closePath

closePath o7planning.org
  • Path2D.closePath()


closeServer

closeServer o7planning.org
  • RMIIIOPServerImpl.closeServer()
  • RMIJRMPServerImpl.closeServer()
  • RMIServerImpl.closeServer()


CMMException

CMMException o7planning.org
  • CMMException.CMMException(String)


coalesceEvents

coalesceEvents o7planning.org
  • Component.coalesceEvents(AWTEvent, AWTEvent)


CODE

CODE o7planning.org
  • HTML.Attribute.CODE
  • HTML.Tag.CODE


code

code o7planning.org
  • DOMException.code
  • EventException.code
  • LSException.code


CODE_ATTRIBUTE_PFX

CODE_ATTRIBUTE_PFX o7planning.org
  • Pack200.Packer.CODE_ATTRIBUTE_PFX


CODEBASE

CODEBASE o7planning.org
  • HTML.Attribute.CODEBASE


codec_factory

codec_factory o7planning.org
  • ORBInitInfoOperations.codec_factory()


CodecFactoryHelper

CodecFactoryHelper o7planning.org
  • CodecFactoryHelper.CodecFactoryHelper()


codePointAt

codePointAt o7planning.org
  • Character.codePointAt(char[], int, int)
  • Character.codePointAt(char[], int)
  • Character.codePointAt(CharSequence, int)
  • String.codePointAt(int)
  • StringBuffer.codePointAt(int)


codePointBefore

codePointBefore o7planning.org
  • Character.codePointBefore(char[], int, int)
  • Character.codePointBefore(char[], int)
  • Character.codePointBefore(CharSequence, int)
  • String.codePointBefore(int)
  • StringBuffer.codePointBefore(int)


codePointCount

codePointCount o7planning.org
  • Character.codePointCount(char[], int, int)
  • Character.codePointCount(CharSequence, int, int)
  • String.codePointCount(int, int)
  • StringBuffer.codePointCount(int, int)


codePoints

codePoints o7planning.org
  • CharSequence.codePoints()


CoderMalfunctionError

CoderMalfunctionError o7planning.org
  • CoderMalfunctionError.CoderMalfunctionError(Exception)


CODESET_INCOMPATIBLE

CODESET_INCOMPATIBLE o7planning.org
  • CODESET_INCOMPATIBLE.CODESET_INCOMPATIBLE(String, int, CompletionStatus)
  • CODESET_INCOMPATIBLE.CODESET_INCOMPATIBLE(int, CompletionStatus)
  • CODESET_INCOMPATIBLE.CODESET_INCOMPATIBLE(String)
  • CODESET_INCOMPATIBLE.CODESET_INCOMPATIBLE()


CodeSigner

CodeSigner o7planning.org
  • CodeSigner.CodeSigner(CertPath, Timestamp)


CodeSource

CodeSource o7planning.org
  • CodeSource.CodeSource(URL, CodeSigner[])
  • CodeSource.CodeSource(URL, Certificate[])


CODETYPE

CODETYPE o7planning.org
  • HTML.Attribute.CODETYPE


coerceData

coerceData o7planning.org
  • BufferedImage.coerceData(boolean)
  • ColorModel.coerceData(WritableRaster, boolean)
  • ComponentColorModel.coerceData(WritableRaster, boolean)
  • DirectColorModel.coerceData(WritableRaster, boolean)


colHead

colHead o7planning.org
  • ScrollPaneLayout.colHead


COLLAPSED

COLLAPSED o7planning.org
  • AccessibleState.COLLAPSED


collapsedIcon

collapsedIcon o7planning.org
  • BasicTreeUI.collapsedIcon


CollapsedStringAdapter

CollapsedStringAdapter o7planning.org
  • CollapsedStringAdapter.CollapsedStringAdapter()


collapsePath

collapsePath o7planning.org
  • JTree.collapsePath(TreePath)


collapseRow

collapseRow o7planning.org
  • JTree.collapseRow(int)


COLLATED

COLLATED o7planning.org
  • SheetCollate.COLLATED


CollationKey

CollationKey o7planning.org
  • CollationKey.CollationKey(String)


Collator

Collator o7planning.org
  • Collator.Collator()


CollatorProvider

CollatorProvider o7planning.org
  • CollatorProvider.CollatorProvider()


collect

collect o7planning.org
  • DoubleStream.collect(Supplier<R>, ObjDoubleConsumer<R>, BiConsumer<R, R>)
  • IntStream.collect(Supplier<R>, ObjIntConsumer<R>, BiConsumer<R, R>)
  • LongStream.collect(Supplier<R>, ObjLongConsumer<R>, BiConsumer<R, R>)
  • Stream.collect(Collector<? super T, A, R>)
  • Stream.collect(Supplier<R>, BiConsumer<R, ? super T>, BiConsumer<R, R>)


collectArguments

collectArguments o7planning.org
  • MethodHandles.collectArguments(MethodHandle, int, MethodHandle)


collectingAndThen

collectingAndThen o7planning.org
  • Collectors.collectingAndThen(Collector<T, A, R>, Function<R, RR>)


CollectionCertStoreParameters

CollectionCertStoreParameters o7planning.org
  • CollectionCertStoreParameters.CollectionCertStoreParameters()
  • CollectionCertStoreParameters.CollectionCertStoreParameters(Collection<?>)


Color

Color o7planning.org
  • Color.Color(ColorSpace, float[], float)
  • Color.Color(float, float, float, float)
  • Color.Color(float, float, float)
  • Color.Color(int, boolean)
  • Color.Color(int)
  • Color.Color(int, int, int, int)
  • Color.Color(int, int, int)


COLOR

COLOR o7planning.org
  • CSS.Attribute.COLOR
  • HTML.Attribute.COLOR


color

color o7planning.org
  • MatteBorder.color


COLOR_ACTION

COLOR_ACTION o7planning.org
  • HTMLEditorKit.COLOR_ACTION


COLOR_CHOOSER

COLOR_CHOOSER o7planning.org
  • AccessibleRole.COLOR_CHOOSER
  • Region.COLOR_CHOOSER


COLOR_CHOOSER_DIALOG

COLOR_CHOOSER_DIALOG o7planning.org
  • JRootPane.COLOR_CHOOSER_DIALOG


ColorChooserUI

ColorChooserUI o7planning.org
  • ColorChooserUI.ColorChooserUI()


ColorConvertOp

ColorConvertOp o7planning.org
  • ColorConvertOp.ColorConvertOp(ICC_Profile[], RenderingHints)
  • ColorConvertOp.ColorConvertOp(ColorSpace, ColorSpace, RenderingHints)
  • ColorConvertOp.ColorConvertOp(ColorSpace, RenderingHints)
  • ColorConvertOp.ColorConvertOp(RenderingHints)


ColorModel

ColorModel o7planning.org
  • ColorModel.ColorModel(int, int[], ColorSpace, boolean, boolean, int, int)
  • ColorModel.ColorModel(int)


colorModel

colorModel o7planning.org
  • ImageTypeSpecifier.colorModel


ColorSpace

ColorSpace o7planning.org
  • ColorSpace.ColorSpace(int, int)


ColorSupported

ColorSupported o7planning.org
  • ColorSupported.ColorSupported(int)


ColorType

ColorType o7planning.org
  • ColorType.ColorType(String)


ColorUIResource

ColorUIResource o7planning.org
  • ColorUIResource.ColorUIResource(Color)
  • ColorUIResource.ColorUIResource(float, float, float)
  • ColorUIResource.ColorUIResource(int)
  • ColorUIResource.ColorUIResource(int, int, int)


COLS

COLS o7planning.org
  • HTML.Attribute.COLS


COLSPAN

COLSPAN o7planning.org
  • HTML.Attribute.COLSPAN


column

column o7planning.org
  • TableModelEvent.column


COLUMN_HEADER

COLUMN_HEADER o7planning.org
  • AccessibleRole.COLUMN_HEADER
  • ScrollPaneConstants.COLUMN_HEADER


COLUMN_WIDTH_PROPERTY

COLUMN_WIDTH_PROPERTY o7planning.org
  • TableColumn.COLUMN_WIDTH_PROPERTY


columnAdded

columnAdded o7planning.org
  • JTable.columnAdded(TableColumnModelEvent)
  • JTable.AccessibleJTable.columnAdded(TableColumnModelEvent)
  • JTableHeader.columnAdded(TableColumnModelEvent)
  • TableColumnModelListener.columnAdded(TableColumnModelEvent)


columnAtPoint

columnAtPoint o7planning.org
  • JTable.columnAtPoint(Point)
  • JTableHeader.columnAtPoint(Point)


columnHeader

columnHeader o7planning.org
  • JScrollPane.columnHeader


columnIdentifiers

columnIdentifiers o7planning.org
  • DefaultTableModel.columnIdentifiers


columnMargin

columnMargin o7planning.org
  • DefaultTableColumnModel.columnMargin


columnMarginChanged

columnMarginChanged o7planning.org
  • JTable.columnMarginChanged(ChangeEvent)
  • JTable.AccessibleJTable.columnMarginChanged(ChangeEvent)
  • JTableHeader.columnMarginChanged(ChangeEvent)
  • TableColumnModelListener.columnMarginChanged(ChangeEvent)


columnModel

columnModel o7planning.org
  • JTable.columnModel
  • JTableHeader.columnModel


columnMoved

columnMoved o7planning.org
  • JTable.columnMoved(TableColumnModelEvent)
  • JTable.AccessibleJTable.columnMoved(TableColumnModelEvent)
  • JTableHeader.columnMoved(TableColumnModelEvent)
  • TableColumnModelListener.columnMoved(TableColumnModelEvent)


columnNoNulls

columnNoNulls o7planning.org
  • DatabaseMetaData.columnNoNulls
  • ResultSetMetaData.columnNoNulls


columnNullable

columnNullable o7planning.org
  • DatabaseMetaData.columnNullable
  • ResultSetMetaData.columnNullable


columnNullableUnknown

columnNullableUnknown o7planning.org
  • DatabaseMetaData.columnNullableUnknown
  • ResultSetMetaData.columnNullableUnknown


columnRemoved

columnRemoved o7planning.org
  • JTable.columnRemoved(TableColumnModelEvent)
  • JTable.AccessibleJTable.columnRemoved(TableColumnModelEvent)
  • JTableHeader.columnRemoved(TableColumnModelEvent)
  • TableColumnModelListener.columnRemoved(TableColumnModelEvent)


columnSelectionAllowed

columnSelectionAllowed o7planning.org
  • DefaultTableColumnModel.columnSelectionAllowed


columnSelectionChanged

columnSelectionChanged o7planning.org
  • JTable.columnSelectionChanged(ListSelectionEvent)
  • JTable.AccessibleJTable.columnSelectionChanged(ListSelectionEvent)
  • JTableHeader.columnSelectionChanged(ListSelectionEvent)
  • TableColumnModelListener.columnSelectionChanged(ListSelectionEvent)


columnUpdated

columnUpdated o7planning.org
  • CachedRowSet.columnUpdated(String)
  • CachedRowSet.columnUpdated(int)


columnWeights

columnWeights o7planning.org
  • GridBagLayout.columnWeights


columnWidths

columnWidths o7planning.org
  • GridBagLayout.columnWidths


combine

combine o7planning.org
  • DomainCombiner.combine(ProtectionDomain[], ProtectionDomain[])
  • DoubleSummaryStatistics.combine(DoubleSummaryStatistics)
  • IntSummaryStatistics.combine(IntSummaryStatistics)
  • LongSummaryStatistics.combine(LongSummaryStatistics)
  • SubjectDomainCombiner.combine(ProtectionDomain[], ProtectionDomain[])


combiner

combiner o7planning.org
  • Collector.combiner()


COMBINING

COMBINING o7planning.org
  • GlyphMetrics.COMBINING


COMBINING_DIACRITICAL_MARKS

COMBINING_DIACRITICAL_MARKS o7planning.org
  • Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS


COMBINING_DIACRITICAL_MARKS_SUPPLEMENT

COMBINING_DIACRITICAL_MARKS_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS_SUPPLEMENT


COMBINING_HALF_MARKS

COMBINING_HALF_MARKS o7planning.org
  • Character.UnicodeBlock.COMBINING_HALF_MARKS


COMBINING_MARKS_FOR_SYMBOLS

COMBINING_MARKS_FOR_SYMBOLS o7planning.org
  • Character.UnicodeBlock.COMBINING_MARKS_FOR_SYMBOLS


COMBINING_SPACING_MARK

COMBINING_SPACING_MARK o7planning.org
  • Character.COMBINING_SPACING_MARK


COMBO_BOX

COMBO_BOX o7planning.org
  • AccessibleRole.COMBO_BOX
  • Region.COMBO_BOX


comboBox

comboBox o7planning.org
  • BasicComboBoxUI.comboBox
  • BasicComboPopup.comboBox
  • MetalComboBoxButton.comboBox


ComboBoxLayoutManager

ComboBoxLayoutManager o7planning.org
  • BasicComboBoxUI.ComboBoxLayoutManager.ComboBoxLayoutManager()


ComboBoxUI

ComboBoxUI o7planning.org
  • ComboBoxUI.ComboBoxUI()


comboIcon

comboIcon o7planning.org
  • MetalComboBoxButton.comboIcon


COMM_FAILURE

COMM_FAILURE o7planning.org
  • COMM_FAILURE.COMM_FAILURE(String, int, CompletionStatus)
  • COMM_FAILURE.COMM_FAILURE(int, CompletionStatus)
  • COMM_FAILURE.COMM_FAILURE(String)
  • COMM_FAILURE.COMM_FAILURE()


command

command o7planning.org
  • Compiler.command(Object)
  • ProcessBuilder.command()
  • ProcessBuilder.command(String...)
  • ProcessBuilder.command(List<String>)


CommandEnvironment

CommandEnvironment o7planning.org
  • ActivationGroupDesc.CommandEnvironment.CommandEnvironment(String, String[])


CommandInfo

CommandInfo o7planning.org
  • CommandInfo.CommandInfo(String, String)


CommandMap

CommandMap o7planning.org
  • CommandMap.CommandMap()


COMMENT

COMMENT o7planning.org
  • XMLStreamConstants.COMMENT


comment

comment o7planning.org
  • DefaultHandler2.comment(char[], int, int)
  • LexicalHandler.comment(char[], int, int)


COMMENT_NODE

COMMENT_NODE o7planning.org
  • Node.COMMENT_NODE


commentChar

commentChar o7planning.org
  • StreamTokenizer.commentChar(int)


COMMENTS

COMMENTS o7planning.org
  • Pattern.COMMENTS


commit

commit o7planning.org
  • XAResource.commit(Xid, boolean)


COMMIT

COMMIT o7planning.org
  • JFormattedTextField.COMMIT


COMMIT_ON_ACCEPT_CHANGES

COMMIT_ON_ACCEPT_CHANGES o7planning.org
  • CachedRowSet.COMMIT_ON_ACCEPT_CHANGES


COMMIT_OR_REVERT

COMMIT_OR_REVERT o7planning.org
  • JFormattedTextField.COMMIT_OR_REVERT


commitEdit

commitEdit o7planning.org
  • JFormattedTextField.commitEdit()
  • JSpinner.commitEdit()
  • JSpinner.DefaultEditor.commitEdit()


COMMON

COMMON o7planning.org
  • DialogTypeSelection.COMMON
  • JobAttributes.DialogType.COMMON


COMMON_INDIC_NUMBER_FORMS

COMMON_INDIC_NUMBER_FORMS o7planning.org
  • Character.UnicodeBlock.COMMON_INDIC_NUMBER_FORMS


commonPool

commonPool o7planning.org
  • ForkJoinPool.commonPool()


CommunicationException

CommunicationException o7planning.org
  • CommunicationException.CommunicationException()
  • CommunicationException.CommunicationException(String)


compact

compact o7planning.org
  • ByteBuffer.compact()
  • CharBuffer.compact()
  • DoubleBuffer.compact()
  • FloatBuffer.compact()
  • IntBuffer.compact()
  • LongBuffer.compact()
  • ShortBuffer.compact()


COMPACT

COMPACT o7planning.org
  • HTML.Attribute.COMPACT


COMPACT_DISC

COMPACT_DISC o7planning.org
  • Port.Info.COMPACT_DISC


comparator

comparator o7planning.org
  • ConcurrentSkipListMap.comparator()
  • ConcurrentSkipListSet.comparator()
  • PriorityBlockingQueue.comparator()
  • PriorityQueue.comparator()
  • SortedMap.comparator()
  • SortedSet.comparator()
  • TreeMap.comparator()
  • TreeSet.comparator()


compare

compare o7planning.org
  • Boolean.compare(boolean, boolean)
  • Byte.compare(byte, byte)
  • Character.compare(char, char)
  • Collator.compare(Object, Object)
  • Collator.compare(String, String)
  • Comparator.compare(T, T)
  • Double.compare(double, double)
  • Duration.compare(Duration)
  • Float.compare(float, float)
  • Integer.compare(int, int)
  • Long.compare(long, long)
  • Objects.compare(T, T, Comparator<? super T>)
  • RuleBasedCollator.compare(String, String)
  • Short.compare(short, short)
  • XMLGregorianCalendar.compare(XMLGregorianCalendar)


compareAndSet

compareAndSet o7planning.org
  • AtomicBoolean.compareAndSet(boolean, boolean)
  • AtomicInteger.compareAndSet(int, int)
  • AtomicIntegerArray.compareAndSet(int, int, int)
  • AtomicIntegerFieldUpdater.compareAndSet(T, int, int)
  • AtomicLong.compareAndSet(long, long)
  • AtomicLongArray.compareAndSet(int, long, long)
  • AtomicLongFieldUpdater.compareAndSet(T, long, long)
  • AtomicMarkableReference.compareAndSet(V, V, boolean, boolean)
  • AtomicReference.compareAndSet(V, V)
  • AtomicReferenceArray.compareAndSet(int, E, E)
  • AtomicReferenceFieldUpdater.compareAndSet(T, V, V)
  • AtomicStampedReference.compareAndSet(V, V, int, int)


compareAndSetForkJoinTaskTag

compareAndSetForkJoinTaskTag o7planning.org
  • ForkJoinTask.compareAndSetForkJoinTaskTag(short, short)


compareAndSetPendingCount

compareAndSetPendingCount o7planning.org
  • CountedCompleter.compareAndSetPendingCount(int, int)


compareAndSetState

compareAndSetState o7planning.org
  • AbstractQueuedLongSynchronizer.compareAndSetState(long, long)
  • AbstractQueuedSynchronizer.compareAndSetState(int, int)


compareDocumentPosition

compareDocumentPosition o7planning.org
  • IIOMetadataNode.compareDocumentPosition(Node)
  • Node.compareDocumentPosition(Node)


compareTabOrder

compareTabOrder o7planning.org
  • DefaultFocusManager.compareTabOrder(Component, Component)


compareTo

compareTo o7planning.org
  • AbstractChronology.compareTo(Chronology)
  • BigDecimal.compareTo(BigDecimal)
  • BigInteger.compareTo(BigInteger)
  • Boolean.compareTo(Boolean)
  • Byte.compareTo(Byte)
  • ByteBuffer.compareTo(ByteBuffer)
  • Calendar.compareTo(Calendar)
  • CharBuffer.compareTo(CharBuffer)
  • Character.compareTo(Character)
  • Charset.compareTo(Charset)
  • ChronoLocalDate.compareTo(ChronoLocalDate)
  • ChronoLocalDateTime.compareTo(ChronoLocalDateTime<?>)
  • ChronoZonedDateTime.compareTo(ChronoZonedDateTime<?>)
  • Chronology.compareTo(Chronology)
  • CollationKey.compareTo(CollationKey)
  • Comparable.compareTo(T)
  • CompositeName.compareTo(Object)
  • CompoundName.compareTo(Object)
  • Date.compareTo(Date)
  • Double.compareTo(Double)
  • DoubleBuffer.compareTo(DoubleBuffer)
  • Duration.compareTo(Duration)
  • Enum.compareTo(E)
  • File.compareTo(File)
  • FileTime.compareTo(FileTime)
  • Float.compareTo(Float)
  • FloatBuffer.compareTo(FloatBuffer)
  • Instant.compareTo(Instant)
  • IntBuffer.compareTo(IntBuffer)
  • Integer.compareTo(Integer)
  • LdapName.compareTo(Object)
  • LocalDate.compareTo(ChronoLocalDate)
  • LocalDateTime.compareTo(ChronoLocalDateTime<?>)
  • LocalTime.compareTo(LocalTime)
  • Long.compareTo(Long)
  • LongBuffer.compareTo(LongBuffer)
  • MonthDay.compareTo(MonthDay)
  • Name.compareTo(Object)
  • ObjectName.compareTo(ObjectName)
  • ObjectStreamField.compareTo(Object)
  • OffsetDateTime.compareTo(OffsetDateTime)
  • OffsetTime.compareTo(OffsetTime)
  • Path.compareTo(Path)
  • Rdn.compareTo(Object)
  • Short.compareTo(Short)
  • ShortBuffer.compareTo(ShortBuffer)
  • String.compareTo(String)
  • Timestamp.compareTo(Date)
  • Timestamp.compareTo(Timestamp)
  • URI.compareTo(URI)
  • UUID.compareTo(UUID)
  • Year.compareTo(Year)
  • YearMonth.compareTo(YearMonth)
  • ZoneOffset.compareTo(ZoneOffset)
  • ZoneOffsetTransition.compareTo(ZoneOffsetTransition)


compareToIgnoreCase

compareToIgnoreCase o7planning.org
  • String.compareToIgnoreCase(String)


compareUnsigned

compareUnsigned o7planning.org
  • Integer.compareUnsigned(int, int)
  • Long.compareUnsigned(long, long)


comparing

comparing o7planning.org
  • Comparator.comparing(Function<? super T, ? extends U>)
  • Comparator.comparing(Function<? super T, ? extends U>, Comparator<? super U>)


comparingByKey

comparingByKey o7planning.org
  • Map.Entry.comparingByKey(Comparator<? super K>)
  • Map.Entry.comparingByKey()


comparingByValue

comparingByValue o7planning.org
  • Map.Entry.comparingByValue(Comparator<? super V>)
  • Map.Entry.comparingByValue()


comparingDouble

comparingDouble o7planning.org
  • Comparator.comparingDouble(ToDoubleFunction<? super T>)


comparingInt

comparingInt o7planning.org
  • Comparator.comparingInt(ToIntFunction<? super T>)


comparingLong

comparingLong o7planning.org
  • Comparator.comparingLong(ToLongFunction<? super T>)


COMPILATION_MXBEAN_NAME

COMPILATION_MXBEAN_NAME o7planning.org
  • ManagementFactory.COMPILATION_MXBEAN_NAME


compile

compile o7planning.org
  • Compilable.compile(Reader)
  • Compilable.compile(String)
  • Pattern.compile(String, int)
  • Pattern.compile(String)
  • XPath.compile(String)


compileClass

compileClass o7planning.org
  • Compiler.compileClass(Class<?>)


compileClasses

compileClasses o7planning.org
  • Compiler.compileClasses(String)


CompiledScript

CompiledScript o7planning.org
  • CompiledScript.CompiledScript()


complementOf

complementOf o7planning.org
  • EnumSet.complementOf(EnumSet<E>)


CompletableFuture

CompletableFuture o7planning.org
  • CompletableFuture.CompletableFuture()


COMPLETE

COMPLETE o7planning.org
  • MediaTracker.COMPLETE


complete

complete o7planning.org
  • Calendar.complete()
  • CompletableFuture.complete(T)
  • CountedCompleter.complete(T)
  • ForkJoinTask.complete(V)


completed

completed o7planning.org
  • SystemException.completed


COMPLETED

COMPLETED o7planning.org
  • JobState.COMPLETED


COMPLETED_MAYBE

COMPLETED_MAYBE o7planning.org
  • CompletionStatus.COMPLETED_MAYBE


COMPLETED_NO

COMPLETED_NO o7planning.org
  • CompletionStatus.COMPLETED_NO


COMPLETED_YES

COMPLETED_YES o7planning.org
  • CompletionStatus.COMPLETED_YES


completedFuture

completedFuture o7planning.org
  • CompletableFuture.completedFuture(U)


completeDrag

completeDrag o7planning.org
  • BasicSplitPaneDivider.DragController.completeDrag(MouseEvent)
  • BasicSplitPaneDivider.DragController.completeDrag(int, int)


completeEditing

completeEditing o7planning.org
  • BasicTreeUI.completeEditing(boolean, boolean, boolean)
  • BasicTreeUI.completeEditing()


completeExceptionally

completeExceptionally o7planning.org
  • CompletableFuture.completeExceptionally(Throwable)
  • ForkJoinTask.completeExceptionally(Throwable)


COMPLETESCANLINES

COMPLETESCANLINES o7planning.org
  • ImageConsumer.COMPLETESCANLINES


completeUIInstall

completeUIInstall o7planning.org
  • BasicTreeUI.completeUIInstall()


completeUIUninstall

completeUIUninstall o7planning.org
  • BasicTreeUI.completeUIUninstall()


CompletionException

CompletionException o7planning.org
  • CompletionException.CompletionException(Throwable)
  • CompletionException.CompletionException(String, Throwable)
  • CompletionException.CompletionException(String)
  • CompletionException.CompletionException()


CompletionStatusHelper

CompletionStatusHelper o7planning.org
  • CompletionStatusHelper.CompletionStatusHelper()


Component

Component o7planning.org
  • Component.Component()


component

component o7planning.org
  • ImageIcon.component


COMPONENT

COMPONENT o7planning.org
  • GlyphMetrics.COMPONENT


COMPONENT_ADDED

COMPONENT_ADDED o7planning.org
  • ContainerEvent.COMPONENT_ADDED


component_count

component_count o7planning.org
  • DynAnyOperations.component_count()
  • _DynAnyStub.component_count()
  • _DynArrayStub.component_count()
  • _DynEnumStub.component_count()
  • _DynFixedStub.component_count()
  • _DynSequenceStub.component_count()
  • _DynStructStub.component_count()
  • _DynUnionStub.component_count()
  • _DynValueStub.component_count()


component_data

component_data o7planning.org
  • TaggedComponent.component_data


COMPONENT_EVENT_MASK

COMPONENT_EVENT_MASK o7planning.org
  • AWTEvent.COMPONENT_EVENT_MASK


COMPONENT_FIRST

COMPONENT_FIRST o7planning.org
  • ComponentEvent.COMPONENT_FIRST


COMPONENT_HIDDEN

COMPONENT_HIDDEN o7planning.org
  • ComponentEvent.COMPONENT_HIDDEN


COMPONENT_LAST

COMPONENT_LAST o7planning.org
  • ComponentEvent.COMPONENT_LAST


COMPONENT_MOVED

COMPONENT_MOVED o7planning.org
  • ComponentEvent.COMPONENT_MOVED


COMPONENT_REMOVED

COMPONENT_REMOVED o7planning.org
  • ContainerEvent.COMPONENT_REMOVED


COMPONENT_RESIZED

COMPONENT_RESIZED o7planning.org
  • ComponentEvent.COMPONENT_RESIZED


COMPONENT_SHOWN

COMPONENT_SHOWN o7planning.org
  • ComponentEvent.COMPONENT_SHOWN


ComponentAdapter

ComponentAdapter o7planning.org
  • ComponentAdapter.ComponentAdapter()


componentAdded

componentAdded o7planning.org
  • AWTEventMulticaster.componentAdded(ContainerEvent)
  • BasicToolBarUI.ToolBarContListener.componentAdded(ContainerEvent)
  • Container.AccessibleAWTContainer.AccessibleContainerHandler.componentAdded(ContainerEvent)
  • ContainerAdapter.componentAdded(ContainerEvent)
  • ContainerListener.componentAdded(ContainerEvent)
  • JComponent.AccessibleJComponent.AccessibleContainerHandler.componentAdded(ContainerEvent)


ComponentAttribute

ComponentAttribute o7planning.org
  • StyleConstants.ComponentAttribute


ComponentColorModel

ComponentColorModel o7planning.org
  • ComponentColorModel.ComponentColorModel(ColorSpace, boolean, boolean, int, int)
  • ComponentColorModel.ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int)


ComponentElementName

ComponentElementName o7planning.org
  • StyleConstants.ComponentElementName


ComponentEvent

ComponentEvent o7planning.org
  • ComponentEvent.ComponentEvent(Component, int)


componentForPoint

componentForPoint o7planning.org
  • MenuSelectionManager.componentForPoint(Component, Point)


ComponentHandler

ComponentHandler o7planning.org
  • BasicInternalFrameUI.ComponentHandler.ComponentHandler()
  • BasicSliderUI.ComponentHandler.ComponentHandler()
  • BasicTreeUI.ComponentHandler.ComponentHandler()


componentHidden

componentHidden o7planning.org
  • AWTEventMulticaster.componentHidden(ComponentEvent)
  • BasicInternalFrameUI.ComponentHandler.componentHidden(ComponentEvent)
  • Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentHidden(ComponentEvent)
  • ComponentAdapter.componentHidden(ComponentEvent)
  • ComponentListener.componentHidden(ComponentEvent)


ComponentIdHelper

ComponentIdHelper o7planning.org
  • ComponentIdHelper.ComponentIdHelper()


ComponentInputMap

ComponentInputMap o7planning.org
  • ComponentInputMap.ComponentInputMap(JComponent)


ComponentInputMapUIResource

ComponentInputMapUIResource o7planning.org
  • ComponentInputMapUIResource.ComponentInputMapUIResource(JComponent)


componentListener

componentListener o7planning.org
  • BasicInternalFrameUI.componentListener
  • BasicSliderUI.componentListener


componentMoved

componentMoved o7planning.org
  • AWTEventMulticaster.componentMoved(ComponentEvent)
  • BasicInternalFrameUI.ComponentHandler.componentMoved(ComponentEvent)
  • BasicTreeUI.ComponentHandler.componentMoved(ComponentEvent)
  • Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentMoved(ComponentEvent)
  • ComponentAdapter.componentMoved(ComponentEvent)
  • ComponentListener.componentMoved(ComponentEvent)


componentRemoved

componentRemoved o7planning.org
  • AWTEventMulticaster.componentRemoved(ContainerEvent)
  • BasicToolBarUI.ToolBarContListener.componentRemoved(ContainerEvent)
  • Container.AccessibleAWTContainer.AccessibleContainerHandler.componentRemoved(ContainerEvent)
  • ContainerAdapter.componentRemoved(ContainerEvent)
  • ContainerListener.componentRemoved(ContainerEvent)
  • JComponent.AccessibleJComponent.AccessibleContainerHandler.componentRemoved(ContainerEvent)


componentResized

componentResized o7planning.org
  • AWTEventMulticaster.componentResized(ComponentEvent)
  • BasicInternalFrameUI.ComponentHandler.componentResized(ComponentEvent)
  • BasicSliderUI.ComponentHandler.componentResized(ComponentEvent)
  • Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentResized(ComponentEvent)
  • ComponentAdapter.componentResized(ComponentEvent)
  • ComponentListener.componentResized(ComponentEvent)
  • JViewport.ViewListener.componentResized(ComponentEvent)


components

components o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.components


components_established

components_established o7planning.org
  • IORInterceptor_3_0Operations.components_established(IORInfo)


ComponentSampleModel

ComponentSampleModel o7planning.org
  • ComponentSampleModel.ComponentSampleModel(int, int, int, int, int, int[], int[])
  • ComponentSampleModel.ComponentSampleModel(int, int, int, int, int, int[])


componentShown

componentShown o7planning.org
  • AWTEventMulticaster.componentShown(ComponentEvent)
  • BasicInternalFrameUI.ComponentHandler.componentShown(ComponentEvent)
  • Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentShown(ComponentEvent)
  • ComponentAdapter.componentShown(ComponentEvent)
  • ComponentListener.componentShown(ComponentEvent)


ComponentUI

ComponentUI o7planning.org
  • ComponentUI.ComponentUI()


ComponentView

ComponentView o7planning.org
  • ComponentView.ComponentView(Element)


compose

compose o7planning.org
  • CompositeContext.compose(Raster, Raster, WritableRaster)
  • DoubleUnaryOperator.compose(DoubleUnaryOperator)
  • Function.compose(Function<? super V, ? extends T>)
  • IntUnaryOperator.compose(IntUnaryOperator)
  • LongUnaryOperator.compose(LongUnaryOperator)


ComposedTextAttribute

ComposedTextAttribute o7planning.org
  • StyleConstants.ComposedTextAttribute


composeName

composeName o7planning.org
  • Context.composeName(String, String)
  • Context.composeName(Name, Name)
  • InitialContext.composeName(Name, Name)
  • InitialContext.composeName(String, String)


CompositeDataInvocationHandler

CompositeDataInvocationHandler o7planning.org
  • CompositeDataInvocationHandler.CompositeDataInvocationHandler(CompositeData)


CompositeDataSupport

CompositeDataSupport o7planning.org
  • CompositeDataSupport.CompositeDataSupport(CompositeType, Map<String, ?>)
  • CompositeDataSupport.CompositeDataSupport(CompositeType, String[], Object[])


CompositeName

CompositeName o7planning.org
  • CompositeName.CompositeName()
  • CompositeName.CompositeName(String)
  • CompositeName.CompositeName(Enumeration<String>)


CompositeType

CompositeType o7planning.org
  • CompositeType.CompositeType(String, String, String[], String[], OpenType<?>[])


CompositeView

CompositeView o7planning.org
  • CompositeView.CompositeView(Element)


CompoundBorder

CompoundBorder o7planning.org
  • CompoundBorder.CompoundBorder(Border, Border)
  • CompoundBorder.CompoundBorder()


CompoundBorderUIResource

CompoundBorderUIResource o7planning.org
  • BorderUIResource.CompoundBorderUIResource.CompoundBorderUIResource(Border, Border)


CompoundControl

CompoundControl o7planning.org
  • CompoundControl.CompoundControl(CompoundControl.Type, Control[])


CompoundEdit

CompoundEdit o7planning.org
  • CompoundEdit.CompoundEdit()


compoundEdit

compoundEdit o7planning.org
  • UndoableEditSupport.compoundEdit


CompoundName

CompoundName o7planning.org
  • CompoundName.CompoundName(String, Properties)
  • CompoundName.CompoundName(Enumeration<String>, Properties)


COMPRESS

COMPRESS o7planning.org
  • Compression.COMPRESS


Compression

Compression o7planning.org
  • Compression.Compression(int)


COMPRESSION_ERROR

COMPRESSION_ERROR o7planning.org
  • JobStateReason.COMPRESSION_ERROR


compressionMode

compressionMode o7planning.org
  • ImageWriteParam.compressionMode


compressionQuality

compressionQuality o7planning.org
  • ImageWriteParam.compressionQuality


compressionType

compressionType o7planning.org
  • ImageWriteParam.compressionType


compressionTypes

compressionTypes o7planning.org
  • ImageWriteParam.compressionTypes


comptable

comptable o7planning.org
  • GridBagLayout.comptable


compute

compute o7planning.org
  • ConcurrentHashMap.compute(K, BiFunction<? super K, ? super V, ? extends V>)
  • ConcurrentMap.compute(K, BiFunction<? super K, ? super V, ? extends V>)
  • ConcurrentSkipListMap.compute(K, BiFunction<? super K, ? super V, ? extends V>)
  • CountedCompleter.compute()
  • HashMap.compute(K, BiFunction<? super K, ? super V, ? extends V>)
  • Hashtable.compute(K, BiFunction<? super K, ? super V, ? extends V>)
  • Map.compute(K, BiFunction<? super K, ? super V, ? extends V>)
  • Provider.compute(Object, BiFunction<? super Object, ? super Object, ? extends Object>)
  • RecursiveAction.compute()
  • RecursiveTask.compute()


computeBlit

computeBlit o7planning.org
  • JViewport.computeBlit(int, int, Point, Point, Dimension, Rectangle)


computeDifference

computeDifference o7planning.org
  • SwingUtilities.computeDifference(Rectangle, Rectangle)


computeFields

computeFields o7planning.org
  • Calendar.computeFields()
  • GregorianCalendar.computeFields()


computeIfAbsent

computeIfAbsent o7planning.org
  • ConcurrentHashMap.computeIfAbsent(K, Function<? super K, ? extends V>)
  • ConcurrentMap.computeIfAbsent(K, Function<? super K, ? extends V>)
  • ConcurrentSkipListMap.computeIfAbsent(K, Function<? super K, ? extends V>)
  • HashMap.computeIfAbsent(K, Function<? super K, ? extends V>)
  • Hashtable.computeIfAbsent(K, Function<? super K, ? extends V>)
  • Map.computeIfAbsent(K, Function<? super K, ? extends V>)
  • Provider.computeIfAbsent(Object, Function<? super Object, ? extends Object>)


computeIfPresent

computeIfPresent o7planning.org
  • ConcurrentHashMap.computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>)
  • ConcurrentMap.computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>)
  • ConcurrentSkipListMap.computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>)
  • HashMap.computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>)
  • Hashtable.computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>)
  • Map.computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>)
  • Provider.computeIfPresent(Object, BiFunction<? super Object, ? super Object, ? extends Object>)


computeIntersection

computeIntersection o7planning.org
  • SwingUtilities.computeIntersection(int, int, int, int, Rectangle)


computePopupBounds

computePopupBounds o7planning.org
  • BasicComboPopup.computePopupBounds(int, int, int, int)


computeRegions

computeRegions o7planning.org
  • ImageReader.computeRegions(ImageReadParam, int, int, BufferedImage, Rectangle, Rectangle)


computerIcon

computerIcon o7planning.org
  • BasicFileChooserUI.computerIcon


computeStringWidth

computeStringWidth o7planning.org
  • SwingUtilities.computeStringWidth(FontMetrics, String)
  • SynthGraphicsUtils.computeStringWidth(SynthContext, Font, FontMetrics, String)


computeTime

computeTime o7planning.org
  • Calendar.computeTime()
  • GregorianCalendar.computeTime()


computeUnion

computeUnion o7planning.org
  • SwingUtilities.computeUnion(int, int, int, int, Rectangle)


computeValue

computeValue o7planning.org
  • ClassValue.computeValue(Class<?>)


computeVisibleRect

computeVisibleRect o7planning.org
  • JComponent.computeVisibleRect(Rectangle)


concat

concat o7planning.org
  • DoubleStream.concat(DoubleStream, DoubleStream)
  • IntStream.concat(IntStream, IntStream)
  • LongStream.concat(LongStream, LongStream)
  • Stream.concat(Stream<? extends T>, Stream<? extends T>)
  • String.concat(String)


concatenate

concatenate o7planning.org
  • AffineTransform.concatenate(AffineTransform)


concatenateTransform

concatenateTransform o7planning.org
  • RenderContext.concatenateTransform(AffineTransform)


concetenateTransform

concetenateTransform o7planning.org
  • RenderContext.concetenateTransform(AffineTransform)


concrete_base_type

concrete_base_type o7planning.org
  • TypeCode.concrete_base_type()


CONCUR_READ_ONLY

CONCUR_READ_ONLY o7planning.org
  • ResultSet.CONCUR_READ_ONLY


CONCUR_UPDATABLE

CONCUR_UPDATABLE o7planning.org
  • ResultSet.CONCUR_UPDATABLE


CONCURRENT

CONCURRENT o7planning.org
  • Spliterator.CONCURRENT


ConcurrentHashMap

ConcurrentHashMap o7planning.org
  • ConcurrentHashMap.ConcurrentHashMap(int, float, int)
  • ConcurrentHashMap.ConcurrentHashMap(int, float)
  • ConcurrentHashMap.ConcurrentHashMap(Map<? extends K, ? extends V>)
  • ConcurrentHashMap.ConcurrentHashMap(int)
  • ConcurrentHashMap.ConcurrentHashMap()


ConcurrentLinkedDeque

ConcurrentLinkedDeque o7planning.org
  • ConcurrentLinkedDeque.ConcurrentLinkedDeque(Collection<? extends E>)
  • ConcurrentLinkedDeque.ConcurrentLinkedDeque()


ConcurrentLinkedQueue

ConcurrentLinkedQueue o7planning.org
  • ConcurrentLinkedQueue.ConcurrentLinkedQueue(Collection<? extends E>)
  • ConcurrentLinkedQueue.ConcurrentLinkedQueue()


ConcurrentModificationException

ConcurrentModificationException o7planning.org
  • ConcurrentModificationException.ConcurrentModificationException(String, Throwable)
  • ConcurrentModificationException.ConcurrentModificationException(Throwable)
  • ConcurrentModificationException.ConcurrentModificationException(String)
  • ConcurrentModificationException.ConcurrentModificationException()


ConcurrentSkipListMap

ConcurrentSkipListMap o7planning.org
  • ConcurrentSkipListMap.ConcurrentSkipListMap(SortedMap<K, ? extends V>)
  • ConcurrentSkipListMap.ConcurrentSkipListMap(Map<? extends K, ? extends V>)
  • ConcurrentSkipListMap.ConcurrentSkipListMap(Comparator<? super K>)
  • ConcurrentSkipListMap.ConcurrentSkipListMap()


ConcurrentSkipListSet

ConcurrentSkipListSet o7planning.org
  • ConcurrentSkipListSet.ConcurrentSkipListSet(SortedSet<E>)
  • ConcurrentSkipListSet.ConcurrentSkipListSet(Collection<? extends E>)
  • ConcurrentSkipListSet.ConcurrentSkipListSet(Comparator<? super E>)
  • ConcurrentSkipListSet.ConcurrentSkipListSet()


ConditionObject

ConditionObject o7planning.org
  • AbstractQueuedLongSynchronizer.ConditionObject.ConditionObject()
  • AbstractQueuedSynchronizer.ConditionObject.ConditionObject()


CONFIG

CONFIG o7planning.org
  • Level.CONFIG


config

config o7planning.org
  • Logger.config(Supplier<String>)
  • Logger.config(String)


Configuration

Configuration o7planning.org
  • Configuration.Configuration()


ConfigurationException

ConfigurationException o7planning.org
  • ConfigurationException.ConfigurationException()
  • ConfigurationException.ConfigurationException(String)


ConfigurationSpi

ConfigurationSpi o7planning.org
  • ConfigurationSpi.ConfigurationSpi()


configureArrowButton

configureArrowButton o7planning.org
  • BasicComboBoxUI.configureArrowButton()


configureBlocking

configureBlocking o7planning.org
  • AbstractSelectableChannel.configureBlocking(boolean)
  • SelectableChannel.configureBlocking(boolean)


configureEditor

configureEditor o7planning.org
  • BasicComboBoxUI.configureEditor()
  • JComboBox.configureEditor(ComboBoxEditor, Object)
  • MetalComboBoxUI.configureEditor()


configureEnclosingScrollPane

configureEnclosingScrollPane o7planning.org
  • JTable.configureEnclosingScrollPane()


configureGraphics

configureGraphics o7planning.org
  • AbstractRegionPainter.configureGraphics(Graphics2D)


configureLayoutCache

configureLayoutCache o7planning.org
  • BasicTreeUI.configureLayoutCache()


configureList

configureList o7planning.org
  • BasicComboPopup.configureList()


configurePopup

configurePopup o7planning.org
  • BasicComboPopup.configurePopup()


configurePropertiesFromAction

configurePropertiesFromAction o7planning.org
  • AbstractButton.configurePropertiesFromAction(Action)
  • JComboBox.configurePropertiesFromAction(Action)
  • JMenuItem.configurePropertiesFromAction(Action)
  • JTextField.configurePropertiesFromAction(Action)


configureScrollBarColors

configureScrollBarColors o7planning.org
  • BasicScrollBarUI.configureScrollBarColors()
  • MetalScrollBarUI.configureScrollBarColors()
  • SynthScrollBarUI.configureScrollBarColors()


configureScroller

configureScroller o7planning.org
  • BasicComboPopup.configureScroller()


ConfirmationCallback

ConfirmationCallback o7planning.org
  • ConfirmationCallback.ConfirmationCallback(String, int, String[], int)
  • ConfirmationCallback.ConfirmationCallback(String, int, int, int)
  • ConfirmationCallback.ConfirmationCallback(int, String[], int)
  • ConfirmationCallback.ConfirmationCallback(int, int, int)


connect

connect o7planning.org
  • AsynchronousSocketChannel.connect(SocketAddress)
  • AsynchronousSocketChannel.connect(SocketAddress, A, CompletionHandler<Void, ? super A>)
  • DatagramChannel.connect(SocketAddress)
  • DatagramSocket.connect(SocketAddress)
  • DatagramSocket.connect(InetAddress, int)
  • DatagramSocketImpl.connect(InetAddress, int)
  • Driver.connect(String, Properties)
  • JMXConnector.connect(Map<String, ?>)
  • JMXConnector.connect()
  • JMXConnectorFactory.connect(JMXServiceURL, Map<String, ?>)
  • JMXConnectorFactory.connect(JMXServiceURL)
  • ORB.connect(Object)
  • PipedInputStream.connect(PipedOutputStream)
  • PipedOutputStream.connect(PipedInputStream)
  • PipedReader.connect(PipedWriter)
  • PipedWriter.connect(PipedReader)
  • PortableRemoteObject.connect(Remote, Remote)
  • PortableRemoteObjectDelegate.connect(Remote, Remote)
  • RMIConnector.connect(Map<String, ?>)
  • RMIConnector.connect()
  • Socket.connect(SocketAddress, int)
  • Socket.connect(SocketAddress)
  • SocketChannel.connect(SocketAddress)
  • SocketImpl.connect(SocketAddress, int)
  • SocketImpl.connect(InetAddress, int)
  • SocketImpl.connect(String, int)
  • Stub.connect(ORB)
  • StubDelegate.connect(Stub, ORB)
  • URLConnection.connect()


connected

connected o7planning.org
  • URLConnection.connected


ConnectException

ConnectException o7planning.org
  • ConnectException.ConnectException(String, Exception)
  • ConnectException.ConnectException(String)
  • ConnectException.ConnectException()
  • ConnectException.ConnectException(String)


connectFailed

connectFailed o7planning.org
  • ProxySelector.connectFailed(URI, SocketAddress, IOException)


CONNECTING_TO_DEVICE

CONNECTING_TO_DEVICE o7planning.org
  • PrinterStateReason.CONNECTING_TO_DEVICE


ConnectIOException

ConnectIOException o7planning.org
  • ConnectIOException.ConnectIOException(String, Exception)
  • ConnectIOException.ConnectIOException(String)


connectionClosed

connectionClosed o7planning.org
  • ConnectionEventListener.connectionClosed(ConnectionEvent)
  • JMXConnectorServer.connectionClosed(String, String, Object)
  • RMIConnectorServer.connectionClosed(String, String, Object)


connectionErrorOccurred

connectionErrorOccurred o7planning.org
  • ConnectionEventListener.connectionErrorOccurred(ConnectionEvent)


ConnectionEvent

ConnectionEvent o7planning.org
  • ConnectionEvent.ConnectionEvent(PooledConnection, SQLException)
  • ConnectionEvent.ConnectionEvent(PooledConnection)


connectionFailed

connectionFailed o7planning.org
  • JMXConnectorServer.connectionFailed(String, String, Object)
  • RMIConnectorServer.connectionFailed(String, String, Object)


connectionOpened

connectionOpened o7planning.org
  • JMXConnectorServer.connectionOpened(String, String, Object)
  • RMIConnectorServer.connectionOpened(String, String, Object)


ConnectionPendingException

ConnectionPendingException o7planning.org
  • ConnectionPendingException.ConnectionPendingException()


CONNECTOR_PUNCTUATION

CONNECTOR_PUNCTUATION o7planning.org
  • Character.CONNECTOR_PUNCTUATION


CONREF

CONREF o7planning.org
  • DTDConstants.CONREF


console

console o7planning.org
  • System.console()


ConsoleHandler

ConsoleHandler o7planning.org
  • ConsoleHandler.ConsoleHandler()


constant

constant o7planning.org
  • MethodHandles.constant(Class<?>, Object)
  • Spring.constant(int, int, int)
  • Spring.constant(int)


ConstantCallSite

ConstantCallSite o7planning.org
  • ConstantCallSite.ConstantCallSite(MethodType, MethodHandle)
  • ConstantCallSite.ConstantCallSite(MethodHandle)


constantName

constantName o7planning.org
  • EnumConstantNotPresentException.constantName()


constraintBeforeFloating

constraintBeforeFloating o7planning.org
  • BasicToolBarUI.constraintBeforeFloating


Constraints

Constraints o7planning.org
  • SpringLayout.Constraints.Constraints(Component)
  • SpringLayout.Constraints.Constraints(Spring, Spring, Spring, Spring)
  • SpringLayout.Constraints.Constraints(Spring, Spring)
  • SpringLayout.Constraints.Constraints()


constructorModifiers

constructorModifiers o7planning.org
  • Modifier.constructorModifiers()


constructorsIn

constructorsIn o7planning.org
  • ElementFilter.constructorsIn(Set<? extends Element>)
  • ElementFilter.constructorsIn(Iterable<? extends Element>)


consume

consume o7planning.org
  • AWTEvent.consume()
  • InputEvent.consume()
  • InputMethodEvent.consume()


consumed

consumed o7planning.org
  • AWTEvent.consumed


consumer

consumer o7planning.org
  • ImageFilter.consumer


containedIn

containedIn o7planning.org
  • Oid.containedIn(Oid[])


Container

Container o7planning.org
  • Container.Container()


CONTAINER_EVENT_MASK

CONTAINER_EVENT_MASK o7planning.org
  • AWTEvent.CONTAINER_EVENT_MASK


CONTAINER_FIRST

CONTAINER_FIRST o7planning.org
  • ContainerEvent.CONTAINER_FIRST


CONTAINER_LAST

CONTAINER_LAST o7planning.org
  • ContainerEvent.CONTAINER_LAST


ContainerAdapter

ContainerAdapter o7planning.org
  • ContainerAdapter.ContainerAdapter()


ContainerEvent

ContainerEvent o7planning.org
  • ContainerEvent.ContainerEvent(Component, int, Component)


containerListener

containerListener o7planning.org
  • BasicMenuBarUI.containerListener


ContainerOrderFocusTraversalPolicy

ContainerOrderFocusTraversalPolicy o7planning.org
  • ContainerOrderFocusTraversalPolicy.ContainerOrderFocusTraversalPolicy()


contains

contains o7planning.org
  • AbstractCollection.contains(Object)
  • AccessibleComponent.contains(Point)
  • AccessibleRelationSet.contains(String)
  • AccessibleStateSet.contains(AccessibleState)
  • Arc2D.contains(Rectangle2D)
  • Arc2D.contains(double, double, double, double)
  • Arc2D.contains(double, double)
  • Area.contains(Rectangle2D)
  • Area.contains(double, double, double, double)
  • Area.contains(Point2D)
  • Area.contains(double, double)
  • ArrayBlockingQueue.contains(Object)
  • ArrayDeque.contains(Object)
  • ArrayList.contains(Object)
  • Attribute.contains(Object)
  • BasicAttribute.contains(Object)
  • BasicDirectoryModel.contains(Object)
  • BeanContextMembershipEvent.contains(Object)
  • BeanContextSupport.contains(Object)
  • BlockingDeque.contains(Object)
  • BlockingQueue.contains(Object)
  • Charset.contains(Charset)
  • Collection.contains(Object)
  • Component.contains(Point)
  • Component.contains(int, int)
  • Component.AccessibleAWTComponent.contains(Point)
  • ComponentUI.contains(JComponent, int, int)
  • ConcurrentHashMap.contains(Object)
  • ConcurrentHashMap.KeySetView.contains(Object)
  • ConcurrentLinkedDeque.contains(Object)
  • ConcurrentLinkedQueue.contains(Object)
  • ConcurrentSkipListSet.contains(Object)
  • CopyOnWriteArrayList.contains(Object)
  • CopyOnWriteArraySet.contains(Object)
  • CubicCurve2D.contains(Rectangle2D)
  • CubicCurve2D.contains(double, double, double, double)
  • CubicCurve2D.contains(Point2D)
  • CubicCurve2D.contains(double, double)
  • DOMStringList.contains(String)
  • DefaultListModel.contains(Object)
  • Deque.contains(Object)
  • Ellipse2D.contains(double, double, double, double)
  • Ellipse2D.contains(double, double)
  • HashSet.contains(Object)
  • Hashtable.contains(Object)
  • JComponent.contains(int, int)
  • JList.AccessibleJList.AccessibleJListChild.contains(Point)
  • JTable.AccessibleJTable.AccessibleJTableCell.contains(Point)
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.contains(Point)
  • JTree.AccessibleJTree.AccessibleJTreeNode.contains(Point)
  • Line2D.contains(Rectangle2D)
  • Line2D.contains(double, double, double, double)
  • Line2D.contains(Point2D)
  • Line2D.contains(double, double)
  • LinkedBlockingDeque.contains(Object)
  • LinkedBlockingQueue.contains(Object)
  • LinkedList.contains(Object)
  • LinkedTransferQueue.contains(Object)
  • List.contains(Object)
  • List.AccessibleAWTList.AccessibleAWTListChild.contains(Point)
  • MenuComponent.AccessibleAWTMenuComponent.contains(Point)
  • MultiButtonUI.contains(JComponent, int, int)
  • MultiColorChooserUI.contains(JComponent, int, int)
  • MultiComboBoxUI.contains(JComponent, int, int)
  • MultiDesktopIconUI.contains(JComponent, int, int)
  • MultiDesktopPaneUI.contains(JComponent, int, int)
  • MultiFileChooserUI.contains(JComponent, int, int)
  • MultiInternalFrameUI.contains(JComponent, int, int)
  • MultiLabelUI.contains(JComponent, int, int)
  • MultiListUI.contains(JComponent, int, int)
  • MultiMenuBarUI.contains(JComponent, int, int)
  • MultiMenuItemUI.contains(JComponent, int, int)
  • MultiOptionPaneUI.contains(JComponent, int, int)
  • MultiPanelUI.contains(JComponent, int, int)
  • MultiPopupMenuUI.contains(JComponent, int, int)
  • MultiProgressBarUI.contains(JComponent, int, int)
  • MultiRootPaneUI.contains(JComponent, int, int)
  • MultiScrollBarUI.contains(JComponent, int, int)
  • MultiScrollPaneUI.contains(JComponent, int, int)
  • MultiSeparatorUI.contains(JComponent, int, int)
  • MultiSliderUI.contains(JComponent, int, int)
  • MultiSpinnerUI.contains(JComponent, int, int)
  • MultiSplitPaneUI.contains(JComponent, int, int)
  • MultiTabbedPaneUI.contains(JComponent, int, int)
  • MultiTableHeaderUI.contains(JComponent, int, int)
  • MultiTableUI.contains(JComponent, int, int)
  • MultiTextUI.contains(JComponent, int, int)
  • MultiToolBarUI.contains(JComponent, int, int)
  • MultiToolTipUI.contains(JComponent, int, int)
  • MultiTreeUI.contains(JComponent, int, int)
  • MultiViewportUI.contains(JComponent, int, int)
  • NameList.contains(String)
  • Path2D.contains(Rectangle2D)
  • Path2D.contains(double, double, double, double)
  • Path2D.contains(PathIterator, Rectangle2D)
  • Path2D.contains(PathIterator, double, double, double, double)
  • Path2D.contains(Point2D)
  • Path2D.contains(double, double)
  • Path2D.contains(PathIterator, Point2D)
  • Path2D.contains(PathIterator, double, double)
  • Polygon.contains(Rectangle2D)
  • Polygon.contains(double, double, double, double)
  • Polygon.contains(Point2D)
  • Polygon.contains(double, double)
  • Polygon.contains(int, int)
  • Polygon.contains(Point)
  • PriorityBlockingQueue.contains(Object)
  • PriorityQueue.contains(Object)
  • QuadCurve2D.contains(Rectangle2D)
  • QuadCurve2D.contains(double, double, double, double)
  • QuadCurve2D.contains(Point2D)
  • QuadCurve2D.contains(double, double)
  • Rectangle.contains(int, int, int, int)
  • Rectangle.contains(Rectangle)
  • Rectangle.contains(int, int)
  • Rectangle.contains(Point)
  • Rectangle2D.contains(double, double, double, double)
  • Rectangle2D.contains(double, double)
  • RectangularShape.contains(Rectangle2D)
  • RectangularShape.contains(Point2D)
  • RoundRectangle2D.contains(double, double, double, double)
  • RoundRectangle2D.contains(double, double)
  • ServiceRegistry.contains(Object)
  • Set.contains(Object)
  • SetOfIntegerSyntax.contains(IntegerSyntax)
  • SetOfIntegerSyntax.contains(int)
  • Shape.contains(Rectangle2D)
  • Shape.contains(double, double, double, double)
  • Shape.contains(Point2D)
  • Shape.contains(double, double)
  • String.contains(CharSequence)
  • SynchronousQueue.contains(Object)
  • TreeSet.contains(Object)
  • Types.contains(TypeMirror, TypeMirror)
  • Vector.contains(Object)


containsAlias

containsAlias o7planning.org
  • KeyStore.containsAlias(String)


containsAll

containsAll o7planning.org
  • AbstractCollection.containsAll(Collection<?>)
  • BeanContextSupport.containsAll(Collection)
  • Collection.containsAll(Collection<?>)
  • CopyOnWriteArrayList.containsAll(Collection<?>)
  • CopyOnWriteArraySet.containsAll(Collection<?>)
  • List.containsAll(Collection<?>)
  • Set.containsAll(Collection<?>)
  • SynchronousQueue.containsAll(Collection<?>)
  • Vector.containsAll(Collection<?>)


containsAngle

containsAngle o7planning.org
  • Arc2D.containsAngle(double)


containsAttribute

containsAttribute o7planning.org
  • AbstractDocument.AbstractElement.containsAttribute(Object, Object)
  • AttributeSet.containsAttribute(Object, Object)
  • SimpleAttributeSet.containsAttribute(Object, Object)
  • StyleContext.NamedStyle.containsAttribute(Object, Object)
  • StyleContext.SmallAttributeSet.containsAttribute(Object, Object)


containsAttributes

containsAttributes o7planning.org
  • AbstractDocument.AbstractElement.containsAttributes(AttributeSet)
  • AttributeSet.containsAttributes(AttributeSet)
  • SimpleAttributeSet.containsAttributes(AttributeSet)
  • StyleContext.NamedStyle.containsAttributes(AttributeSet)
  • StyleContext.SmallAttributeSet.containsAttributes(AttributeSet)


containsCustomComponents

containsCustomComponents o7planning.org
  • BasicOptionPaneUI.containsCustomComponents(JOptionPane)
  • MultiOptionPaneUI.containsCustomComponents(JOptionPane)
  • OptionPaneUI.containsCustomComponents(JOptionPane)


containsKey

containsKey o7planning.org
  • AbstractMap.containsKey(Object)
  • AttributeSet.containsKey(Class<?>)
  • Attributes.containsKey(Object)
  • BeanContextSupport.containsKey(Object)
  • Bindings.containsKey(Object)
  • CompositeData.containsKey(String)
  • CompositeDataSupport.containsKey(String)
  • CompositeType.containsKey(String)
  • ConcurrentHashMap.containsKey(Object)
  • ConcurrentSkipListMap.containsKey(Object)
  • EnumMap.containsKey(Object)
  • HashAttributeSet.containsKey(Class<?>)
  • HashMap.containsKey(Object)
  • Hashtable.containsKey(Object)
  • IdentityHashMap.containsKey(Object)
  • Map.containsKey(Object)
  • RenderingHints.containsKey(Object)
  • ResourceBundle.containsKey(String)
  • SimpleBindings.containsKey(Object)
  • TabularData.containsKey(Object[])
  • TabularDataSupport.containsKey(Object[])
  • TabularDataSupport.containsKey(Object)
  • TreeMap.containsKey(Object)
  • WeakHashMap.containsKey(Object)


containsNS

containsNS o7planning.org
  • NameList.containsNS(String, String)


containsObservedObject

containsObservedObject o7planning.org
  • Monitor.containsObservedObject(ObjectName)
  • MonitorMBean.containsObservedObject(ObjectName)


containsValue

containsValue o7planning.org
  • AbstractMap.containsValue(Object)
  • AttributeSet.containsValue(Attribute)
  • Attributes.containsValue(Object)
  • CompositeData.containsValue(Object)
  • CompositeDataSupport.containsValue(Object)
  • ConcurrentHashMap.containsValue(Object)
  • ConcurrentSkipListMap.containsValue(Object)
  • EnumMap.containsValue(Object)
  • HashAttributeSet.containsValue(Attribute)
  • HashMap.containsValue(Object)
  • Hashtable.containsValue(Object)
  • IdentityHashMap.containsValue(Object)
  • LinkedHashMap.containsValue(Object)
  • Map.containsValue(Object)
  • RenderingHints.containsValue(Object)
  • SimpleBindings.containsValue(Object)
  • TabularData.containsValue(CompositeData)
  • TabularDataSupport.containsValue(Object)
  • TabularDataSupport.containsValue(CompositeData)
  • TreeMap.containsValue(Object)
  • WeakHashMap.containsValue(Object)


CONTENT

CONTENT o7planning.org
  • HTML.Attribute.CONTENT
  • HTML.Tag.CONTENT


content

content o7planning.org
  • ContentModel.content
  • Element.content


CONTENT_AREA_FILLED_CHANGED_PROPERTY

CONTENT_AREA_FILLED_CHANGED_PROPERTY o7planning.org
  • AbstractButton.CONTENT_AREA_FILLED_CHANGED_PROPERTY


CONTENT_PANE_PROPERTY

CONTENT_PANE_PROPERTY o7planning.org
  • JInternalFrame.CONTENT_PANE_PROPERTY


CONTENT_TYPE

CONTENT_TYPE o7planning.org
  • Attributes.Name.CONTENT_TYPE


content_type

content_type o7planning.org
  • TypeCode.content_type()


contentBorderInsets

contentBorderInsets o7planning.org
  • BasicTabbedPaneUI.contentBorderInsets


ContentElementName

ContentElementName o7planning.org
  • AbstractDocument.ContentElementName


contentEquals

contentEquals o7planning.org
  • Name.contentEquals(CharSequence)
  • String.contentEquals(CharSequence)
  • String.contentEquals(StringBuffer)


ContentHandler

ContentHandler o7planning.org
  • ContentHandler.ContentHandler()


ContentModel

ContentModel o7planning.org
  • ContentModel.ContentModel(int, Object, ContentModel)
  • ContentModel.ContentModel(int, ContentModel)
  • ContentModel.ContentModel(Element)
  • ContentModel.ContentModel()


contentPane

contentPane o7planning.org
  • JRootPane.contentPane


contentRect

contentRect o7planning.org
  • BasicSliderUI.contentRect


contents

contents o7planning.org
  • Clipboard.contents


CONTENTS_CHANGED

CONTENTS_CHANGED o7planning.org
  • ListDataEvent.CONTENTS_CHANGED


contentsChanged

contentsChanged o7planning.org
  • BasicComboBoxUI.ListDataHandler.contentsChanged(ListDataEvent)
  • BasicComboPopup.ListDataHandler.contentsChanged(ListDataEvent)
  • BasicListUI.ListDataHandler.contentsChanged(ListDataEvent)
  • JComboBox.contentsChanged(ListDataEvent)
  • JList.AccessibleJList.contentsChanged(ListDataEvent)
  • ListDataListener.contentsChanged(ListDataEvent)


contentsLost

contentsLost o7planning.org
  • BufferStrategy.contentsLost()
  • Component.BltBufferStrategy.contentsLost()
  • Component.FlipBufferStrategy.contentsLost()
  • VolatileImage.contentsLost()


contentsRestored

contentsRestored o7planning.org
  • BufferStrategy.contentsRestored()
  • Component.BltBufferStrategy.contentsRestored()
  • Component.FlipBufferStrategy.contentsRestored()


ContentType

ContentType o7planning.org
  • DefaultStyledDocument.ElementSpec.ContentType


context

context o7planning.org
  • AbstractScriptEngine.context
  • DropTargetEvent.context
  • WatchEvent.context()


Context

Context o7planning.org
  • Context.Context()


context_data

context_data o7planning.org
  • ServiceContext.context_data


CONTEXT_EXPIRED

CONTEXT_EXPIRED o7planning.org
  • GSSException.CONTEXT_EXPIRED


context_id

context_id o7planning.org
  • ServiceContext.context_id


context_name

context_name o7planning.org
  • Context.context_name()


ContextList

ContextList o7planning.org
  • ContextList.ContextList()


ContextNotEmptyException

ContextNotEmptyException o7planning.org
  • ContextNotEmptyException.ContextNotEmptyException()
  • ContextNotEmptyException.ContextNotEmptyException(String)


contexts

contexts o7planning.org
  • Request.contexts()
  • RequestInfoOperations.contexts()


CONTIGUOUS_TREE_SELECTION

CONTIGUOUS_TREE_SELECTION o7planning.org
  • TreeSelectionModel.CONTIGUOUS_TREE_SELECTION


CONTINUE

CONTINUE o7planning.org
  • ShortMessage.CONTINUE


continueDrag

continueDrag o7planning.org
  • BasicSplitPaneDivider.DragController.continueDrag(MouseEvent)
  • BasicSplitPaneDivider.DragController.continueDrag(int, int)


CONTINUOUS_LAYOUT_PROPERTY

CONTINUOUS_LAYOUT_PROPERTY o7planning.org
  • JSplitPane.CONTINUOUS_LAYOUT_PROPERTY


continuousLayout

continuousLayout o7planning.org
  • JSplitPane.continuousLayout


contListener

contListener o7planning.org
  • MetalToolBarUI.contListener


CONTROL

CONTROL o7planning.org
  • Character.CONTROL


control

control o7planning.org
  • SystemColor.control


Control

Control o7planning.org
  • Control.Control(Control.Type)
  • ResourceBundle.Control.Control()


CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY

CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY o7planning.org
  • JFileChooser.CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY


CONTROL_CHANGE

CONTROL_CHANGE o7planning.org
  • ShortMessage.CONTROL_CHANGE


CONTROL_DK_SHADOW

CONTROL_DK_SHADOW o7planning.org
  • SystemColor.CONTROL_DK_SHADOW


CONTROL_FACTORIES

CONTROL_FACTORIES o7planning.org
  • LdapContext.CONTROL_FACTORIES


CONTROL_HIGHLIGHT

CONTROL_HIGHLIGHT o7planning.org
  • SystemColor.CONTROL_HIGHLIGHT


CONTROL_LT_HIGHLIGHT

CONTROL_LT_HIGHLIGHT o7planning.org
  • SystemColor.CONTROL_LT_HIGHLIGHT


CONTROL_PICTURES

CONTROL_PICTURES o7planning.org
  • Character.UnicodeBlock.CONTROL_PICTURES


CONTROL_SHADOW

CONTROL_SHADOW o7planning.org
  • SystemColor.CONTROL_SHADOW


CONTROL_TEXT

CONTROL_TEXT o7planning.org
  • SystemColor.CONTROL_TEXT


controlChange

controlChange o7planning.org
  • ControllerEventListener.controlChange(ShortMessage)
  • MidiChannel.controlChange(int, int)


controlDkShadow

controlDkShadow o7planning.org
  • SystemColor.controlDkShadow


controlDown

controlDown o7planning.org
  • Event.controlDown()


ControlFactory

ControlFactory o7planning.org
  • ControlFactory.ControlFactory()


controlHighlight

controlHighlight o7planning.org
  • SystemColor.controlHighlight


CONTROLLED_BY

CONTROLLED_BY o7planning.org
  • AccessibleRelation.CONTROLLED_BY


CONTROLLED_BY_PROPERTY

CONTROLLED_BY_PROPERTY o7planning.org
  • AccessibleRelation.CONTROLLED_BY_PROPERTY


controller

controller o7planning.org
  • IIOMetadata.controller
  • IIOParam.controller


CONTROLLER_FOR

CONTROLLER_FOR o7planning.org
  • AccessibleRelation.CONTROLLER_FOR


CONTROLLER_FOR_PROPERTY

CONTROLLER_FOR_PROPERTY o7planning.org
  • AccessibleRelation.CONTROLLER_FOR_PROPERTY


controlLtHighlight

controlLtHighlight o7planning.org
  • SystemColor.controlLtHighlight


controlShadow

controlShadow o7planning.org
  • SystemColor.controlShadow


controlText

controlText o7planning.org
  • SystemColor.controlText


convert

convert o7planning.org
  • TimeUnit.convert(long, TimeUnit)


convertColumnIndexToModel

convertColumnIndexToModel o7planning.org
  • JTable.convertColumnIndexToModel(int)


convertColumnIndexToView

convertColumnIndexToView o7planning.org
  • JTable.convertColumnIndexToView(int)


CONVERTED_TEXT

CONVERTED_TEXT o7planning.org
  • InputMethodHighlight.CONVERTED_TEXT


convertImageMetadata

convertImageMetadata o7planning.org
  • ImageTranscoder.convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam)
  • ImageWriter.convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam)


convertMouseEvent

convertMouseEvent o7planning.org
  • BasicComboPopup.convertMouseEvent(MouseEvent)
  • SwingUtilities.convertMouseEvent(Component, MouseEvent, Component)


convertPoint

convertPoint o7planning.org
  • SwingUtilities.convertPoint(Component, int, int, Component)
  • SwingUtilities.convertPoint(Component, Point, Component)


convertPointFromScreen

convertPointFromScreen o7planning.org
  • SwingUtilities.convertPointFromScreen(Point, Component)


convertPointToScreen

convertPointToScreen o7planning.org
  • SwingUtilities.convertPointToScreen(Point, Component)


convertPreviousRowIndexToModel

convertPreviousRowIndexToModel o7planning.org
  • RowSorterEvent.convertPreviousRowIndexToModel(int)


convertRectangle

convertRectangle o7planning.org
  • SwingUtilities.convertRectangle(Component, Rectangle, Component)


convertRowIndexToModel

convertRowIndexToModel o7planning.org
  • DefaultRowSorter.convertRowIndexToModel(int)
  • JTable.convertRowIndexToModel(int)
  • RowSorter.convertRowIndexToModel(int)


convertRowIndexToView

convertRowIndexToView o7planning.org
  • DefaultRowSorter.convertRowIndexToView(int)
  • JTable.convertRowIndexToView(int)
  • RowSorter.convertRowIndexToView(int)


convertRowToY

convertRowToY o7planning.org
  • BasicListUI.convertRowToY(int)


convertStreamMetadata

convertStreamMetadata o7planning.org
  • ImageTranscoder.convertStreamMetadata(IIOMetadata, ImageWriteParam)
  • ImageWriter.convertStreamMetadata(IIOMetadata, ImageWriteParam)


convertToIntDiscrete

convertToIntDiscrete o7planning.org
  • IndexColorModel.convertToIntDiscrete(Raster, boolean)


convertToVector

convertToVector o7planning.org
  • DefaultTableModel.convertToVector(Object[][])
  • DefaultTableModel.convertToVector(Object[])


convertValueToText

convertValueToText o7planning.org
  • JTree.convertValueToText(Object, boolean, boolean, boolean, int, boolean)


convertYToRow

convertYToRow o7planning.org
  • BasicListUI.convertYToRow(int)


ConvolveOp

ConvolveOp o7planning.org
  • ConvolveOp.ConvolveOp(Kernel)
  • ConvolveOp.ConvolveOp(Kernel, int, RenderingHints)


CookieHandler

CookieHandler o7planning.org
  • CookieHandler.CookieHandler()


CookieHolder

CookieHolder o7planning.org
  • CookieHolder.CookieHolder(Object)
  • CookieHolder.CookieHolder()


CookieManager

CookieManager o7planning.org
  • CookieManager.CookieManager(CookieStore, CookiePolicy)
  • CookieManager.CookieManager()


COORDS

COORDS o7planning.org
  • HTML.Attribute.COORDS


COPIED

COPIED o7planning.org
  • BufferCapabilities.FlipContents.COPIED


Copies

Copies o7planning.org
  • Copies.Copies(int)


CopiesSupported

CopiesSupported o7planning.org
  • CopiesSupported.CopiesSupported(int, int)
  • CopiesSupported.CopiesSupported(int)


COPTIC

COPTIC o7planning.org
  • Character.UnicodeBlock.COPTIC


copy

copy o7planning.org
  • DynAny.copy()
  • DynAnyOperations.copy()
  • PolicyOperations.copy()
  • _DynAnyStub.copy()
  • _DynArrayStub.copy()
  • _DynEnumStub.copy()
  • _DynFixedStub.copy()
  • _DynSequenceStub.copy()
  • _DynStructStub.copy()
  • _DynUnionStub.copy()
  • _DynValueStub.copy()
  • _PolicyStub.copy()


COPY

COPY o7planning.org
  • TransferHandler.COPY


COPY_OR_MOVE

COPY_OR_MOVE o7planning.org
  • TransferHandler.COPY_OR_MOVE


copyAction

copyAction o7planning.org
  • DefaultEditorKit.copyAction


CopyAction

CopyAction o7planning.org
  • DefaultEditorKit.CopyAction.CopyAction()


copyArea

copyArea o7planning.org
  • DebugGraphics.copyArea(int, int, int, int, int, int)
  • Graphics.copyArea(int, int, int, int, int, int)


copyAttributes

copyAttributes o7planning.org
  • AbstractDocument.AbstractElement.copyAttributes()
  • AttributeSet.copyAttributes()
  • SimpleAttributeSet.copyAttributes()
  • StyleContext.NamedStyle.copyAttributes()
  • StyleContext.SmallAttributeSet.copyAttributes()


copyChildren

copyChildren o7planning.org
  • BeanContextSupport.copyChildren()


copyData

copyData o7planning.org
  • BufferedImage.copyData(WritableRaster)
  • RenderedImage.copyData(WritableRaster)


copyInto

copyInto o7planning.org
  • DefaultListModel.copyInto(Object[])
  • Vector.copyInto(Object[])


copyObject

copyObject o7planning.org
  • Util.copyObject(Object, ORB)
  • UtilDelegate.copyObject(Object, ORB)


copyObjects

copyObjects o7planning.org
  • Util.copyObjects(Object[], ORB)
  • UtilDelegate.copyObjects(Object[], ORB)


copyOf

copyOf o7planning.org
  • Arrays.copyOf(boolean[], int)
  • Arrays.copyOf(double[], int)
  • Arrays.copyOf(float[], int)
  • Arrays.copyOf(char[], int)
  • Arrays.copyOf(long[], int)
  • Arrays.copyOf(int[], int)
  • Arrays.copyOf(short[], int)
  • Arrays.copyOf(byte[], int)
  • Arrays.copyOf(U[], int, Class<? extends T[]>)
  • Arrays.copyOf(T[], int)
  • EnumSet.copyOf(Collection<E>)
  • EnumSet.copyOf(EnumSet<E>)


copyOfRange

copyOfRange o7planning.org
  • Arrays.copyOfRange(boolean[], int, int)
  • Arrays.copyOfRange(double[], int, int)
  • Arrays.copyOfRange(float[], int, int)
  • Arrays.copyOfRange(char[], int, int)
  • Arrays.copyOfRange(long[], int, int)
  • Arrays.copyOfRange(int[], int, int)
  • Arrays.copyOfRange(short[], int, int)
  • Arrays.copyOfRange(byte[], int, int)
  • Arrays.copyOfRange(U[], int, int, Class<? extends T[]>)
  • Arrays.copyOfRange(T[], int, int)


CopyOnWriteArrayList

CopyOnWriteArrayList o7planning.org
  • CopyOnWriteArrayList.CopyOnWriteArrayList(E[])
  • CopyOnWriteArrayList.CopyOnWriteArrayList(Collection<? extends E>)
  • CopyOnWriteArrayList.CopyOnWriteArrayList()


CopyOnWriteArraySet

CopyOnWriteArraySet o7planning.org
  • CopyOnWriteArraySet.CopyOnWriteArraySet(Collection<? extends E>)
  • CopyOnWriteArraySet.CopyOnWriteArraySet()


copySign

copySign o7planning.org
  • Math.copySign(float, float)
  • Math.copySign(double, double)
  • StrictMath.copySign(float, float)
  • StrictMath.copySign(double, double)


copyValueOf

copyValueOf o7planning.org
  • String.copyValueOf(char[])
  • String.copyValueOf(char[], int, int)


cos

cos o7planning.org
  • Math.cos(double)
  • StrictMath.cos(double)


cosh

cosh o7planning.org
  • Math.cosh(double)
  • StrictMath.cosh(double)


count

count o7planning.org
  • BufferedInputStream.count
  • BufferedOutputStream.count
  • ByteArrayInputStream.count
  • ByteArrayOutputStream.count
  • CharArrayReader.count
  • CharArrayWriter.count
  • ContextList.count()
  • DoubleStream.count()
  • ExceptionList.count()
  • IntStream.count()
  • LongStream.count()
  • NVList.count()
  • Segment.count
  • Stream.count()
  • StringBufferInputStream.count
  • WatchEvent.count()


countAttachments

countAttachments o7planning.org
  • SOAPMessage.countAttachments()


countComponents

countComponents o7planning.org
  • Container.countComponents()


countDown

countDown o7planning.org
  • CountDownLatch.countDown()


CountDownLatch

CountDownLatch o7planning.org
  • CountDownLatch.CountDownLatch(int)


CountedCompleter

CountedCompleter o7planning.org
  • CountedCompleter.CountedCompleter()
  • CountedCompleter.CountedCompleter(CountedCompleter<?>)
  • CountedCompleter.CountedCompleter(CountedCompleter<?>, int)


CounterMonitor

CounterMonitor o7planning.org
  • CounterMonitor.CounterMonitor()


counting

counting o7planning.org
  • Collectors.counting()


COUNTING_ROD_NUMERALS

COUNTING_ROD_NUMERALS o7planning.org
  • Character.UnicodeBlock.COUNTING_ROD_NUMERALS


countItems

countItems o7planning.org
  • Choice.countItems()
  • List.countItems()
  • Menu.countItems()


countMenus

countMenus o7planning.org
  • MenuBar.countMenus()


countObservers

countObservers o7planning.org
  • Observable.countObservers()


countStackFrames

countStackFrames o7planning.org
  • Thread.countStackFrames()


countTokens

countTokens o7planning.org
  • StringTokenizer.countTokens()


COVER

COVER o7planning.org
  • Finishings.COVER


COVER_OPEN

COVER_OPEN o7planning.org
  • PrinterStateReason.COVER_OPEN


CPE

CPE o7planning.org
  • NamingManager.CPE


CRC32

CRC32 o7planning.org
  • CRC32.CRC32()


crc

crc o7planning.org
  • GZIPInputStream.crc
  • GZIPOutputStream.crc


create

create o7planning.org
  • BasicPasswordFieldUI.create(Element)
  • BasicTextAreaUI.create(Element)
  • BasicTextFieldUI.create(Element)
  • BasicTextUI.create(Element, int, int)
  • BasicTextUI.create(Element)
  • ContextualRenderedImageFactory.create(RenderContext, ParameterBlock)
  • DatagramSocketImpl.create()
  • DebugGraphics.create(int, int, int, int)
  • DebugGraphics.create()
  • DefaultStyledDocument.create(DefaultStyledDocument.ElementSpec[])
  • Endpoint.create(String, Object, WebServiceFeature...)
  • Endpoint.create(String, Object)
  • Endpoint.create(Object, WebServiceFeature...)
  • Endpoint.create(Object)
  • EventHandler.create(Class<T>, Object, String, String, String)
  • EventHandler.create(Class<T>, Object, String, String)
  • EventHandler.create(Class<T>, Object, String)
  • Graphics.create(int, int, int, int)
  • Graphics.create()
  • HTMLDocument.create(DefaultStyledDocument.ElementSpec[])
  • HTMLEditorKit.HTMLFactory.create(Element)
  • RenderedImageFactory.create(ParameterBlock, RenderingHints)
  • SOAPElementFactory.create(String, String, String)
  • SOAPElementFactory.create(String)
  • SOAPElementFactory.create(Name)
  • Service.create(QName, WebServiceFeature...)
  • Service.create(QName)
  • Service.create(URL, QName, WebServiceFeature...)
  • Service.create(URL, QName)
  • SocketImpl.create(boolean)
  • SynthPasswordFieldUI.create(Element)
  • URI.create(String)
  • ViewFactory.create(Element)


create_abstract_interface_tc

create_abstract_interface_tc o7planning.org
  • ORB.create_abstract_interface_tc(String, String)


create_alias_tc

create_alias_tc o7planning.org
  • ORB.create_alias_tc(String, String, TypeCode)


create_any

create_any o7planning.org
  • ORB.create_any()


create_array_tc

create_array_tc o7planning.org
  • ORB.create_array_tc(int, TypeCode)


create_basic_dyn_any

create_basic_dyn_any o7planning.org
  • ORB.create_basic_dyn_any(TypeCode)


create_child

create_child o7planning.org
  • Context.create_child(String)


create_codec

create_codec o7planning.org
  • CodecFactoryOperations.create_codec(Encoding)


create_context_list

create_context_list o7planning.org
  • ORB.create_context_list()


create_dyn_any

create_dyn_any o7planning.org
  • DynAnyFactoryOperations.create_dyn_any(Any)
  • ORB.create_dyn_any(Any)
  • _DynAnyFactoryStub.create_dyn_any(Any)


create_dyn_any_from_type_code

create_dyn_any_from_type_code o7planning.org
  • DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode)
  • _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode)


create_dyn_array

create_dyn_array o7planning.org
  • ORB.create_dyn_array(TypeCode)


create_dyn_enum

create_dyn_enum o7planning.org
  • ORB.create_dyn_enum(TypeCode)


create_dyn_sequence

create_dyn_sequence o7planning.org
  • ORB.create_dyn_sequence(TypeCode)


create_dyn_struct

create_dyn_struct o7planning.org
  • ORB.create_dyn_struct(TypeCode)


create_dyn_union

create_dyn_union o7planning.org
  • ORB.create_dyn_union(TypeCode)


create_enum_tc

create_enum_tc o7planning.org
  • ORB.create_enum_tc(String, String, String[])


create_environment

create_environment o7planning.org
  • ORB.create_environment()


create_exception_list

create_exception_list o7planning.org
  • ORB.create_exception_list()


create_exception_tc

create_exception_tc o7planning.org
  • ORB.create_exception_tc(String, String, StructMember[])


create_fixed_tc

create_fixed_tc o7planning.org
  • ORB.create_fixed_tc(short, short)


create_id_assignment_policy

create_id_assignment_policy o7planning.org
  • POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue)


create_id_uniqueness_policy

create_id_uniqueness_policy o7planning.org
  • POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue)


create_implicit_activation_policy

create_implicit_activation_policy o7planning.org
  • POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue)


create_input_stream

create_input_stream o7planning.org
  • Any.create_input_stream()
  • OutputStream.create_input_stream()


create_interface_tc

create_interface_tc o7planning.org
  • ORB.create_interface_tc(String, String)


create_lifespan_policy

create_lifespan_policy o7planning.org
  • POAOperations.create_lifespan_policy(LifespanPolicyValue)


create_list

create_list o7planning.org
  • ORB.create_list(int)


create_named_value

create_named_value o7planning.org
  • ORB.create_named_value(String, Any, int)


create_native_tc

create_native_tc o7planning.org
  • ORB.create_native_tc(String, String)


create_operation_list

create_operation_list o7planning.org
  • ORB.create_operation_list(Object)


create_output_stream

create_output_stream o7planning.org
  • Any.create_output_stream()
  • ORB.create_output_stream()


create_POA

create_POA o7planning.org
  • POAOperations.create_POA(String, POAManager, Policy[])


create_policy

create_policy o7planning.org
  • ORB.create_policy(int, Any)
  • PolicyFactoryOperations.create_policy(int, Any)


create_recursive_sequence_tc

create_recursive_sequence_tc o7planning.org
  • ORB.create_recursive_sequence_tc(int, int)


create_recursive_tc

create_recursive_tc o7planning.org
  • ORB.create_recursive_tc(String)


create_reference

create_reference o7planning.org
  • POAOperations.create_reference(String)


create_reference_with_id

create_reference_with_id o7planning.org
  • POAOperations.create_reference_with_id(byte[], String)


create_request

create_request o7planning.org
  • Delegate.create_request(Object, Context, String, NVList, NamedValue, ExceptionList, ContextList)
  • Delegate.create_request(Object, Context, String, NVList, NamedValue)


create_request_processing_policy

create_request_processing_policy o7planning.org
  • POAOperations.create_request_processing_policy(RequestProcessingPolicyValue)


create_sequence_tc

create_sequence_tc o7planning.org
  • ORB.create_sequence_tc(int, TypeCode)


create_servant_retention_policy

create_servant_retention_policy o7planning.org
  • POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue)


create_string_tc

create_string_tc o7planning.org
  • ORB.create_string_tc(int)


create_struct_tc

create_struct_tc o7planning.org
  • ORB.create_struct_tc(String, String, StructMember[])


create_thread_policy

create_thread_policy o7planning.org
  • POAOperations.create_thread_policy(ThreadPolicyValue)


create_union_tc

create_union_tc o7planning.org
  • ORB.create_union_tc(String, String, TypeCode, UnionMember[])


create_value_box_tc

create_value_box_tc o7planning.org
  • ORB.create_value_box_tc(String, String, TypeCode)


create_value_tc

create_value_tc o7planning.org
  • ORB.create_value_tc(String, String, short, TypeCode, ValueMember[])


create_wstring_tc

create_wstring_tc o7planning.org
  • ORB.create_wstring_tc(int)


createActionChangeListener

createActionChangeListener o7planning.org
  • JMenu.createActionChangeListener(JMenuItem)
  • JPopupMenu.createActionChangeListener(JMenuItem)
  • JToolBar.createActionChangeListener(JButton)


createActionComponent

createActionComponent o7planning.org
  • JMenu.createActionComponent(Action)
  • JPopupMenu.createActionComponent(Action)
  • JToolBar.createActionComponent(Action)


createActionListener

createActionListener o7planning.org
  • AbstractButton.createActionListener()


createActionMap

createActionMap o7planning.org
  • MetalFileChooserUI.createActionMap()


createActionPropertyChangeListener

createActionPropertyChangeListener o7planning.org
  • AbstractButton.createActionPropertyChangeListener(Action)
  • JComboBox.createActionPropertyChangeListener(Action)
  • JTextField.createActionPropertyChangeListener(Action)


createActions

createActions o7planning.org
  • BasicInternalFrameTitlePane.createActions()


createAndPublishEndpoint

createAndPublishEndpoint o7planning.org
  • Provider.createAndPublishEndpoint(String, Object, WebServiceFeature...)
  • Provider.createAndPublishEndpoint(String, Object)


createArrayOf

createArrayOf o7planning.org
  • Connection.createArrayOf(String, Object[])


createArrowButton

createArrowButton o7planning.org
  • BasicComboBoxUI.createArrowButton()
  • MetalComboBoxUI.createArrowButton()
  • SynthComboBoxUI.createArrowButton()


createArrowButtonListener

createArrowButtonListener o7planning.org
  • BasicScrollBarUI.createArrowButtonListener()


createAttachmentPart

createAttachmentPart o7planning.org
  • SOAPMessage.createAttachmentPart(Object, String)
  • SOAPMessage.createAttachmentPart(DataHandler)
  • SOAPMessage.createAttachmentPart()


createAttribute

createAttribute o7planning.org
  • Document.createAttribute(String)
  • XMLEventFactory.createAttribute(QName, String)
  • XMLEventFactory.createAttribute(String, String)
  • XMLEventFactory.createAttribute(String, String, String, String)


createAttributeNS

createAttributeNS o7planning.org
  • Document.createAttributeNS(String, String)


createAudioAction

createAudioAction o7planning.org
  • BasicLookAndFeel.createAudioAction(Object)


createBackBuffers

createBackBuffers o7planning.org
  • Component.BltBufferStrategy.createBackBuffers(int)


createBanded

createBanded o7planning.org
  • ImageTypeSpecifier.createBanded(ColorSpace, int[], int[], int, boolean, boolean)


createBandedRaster

createBandedRaster o7planning.org
  • Raster.createBandedRaster(DataBuffer, int, int, int, int[], int[], Point)
  • Raster.createBandedRaster(int, int, int, int, int[], int[], Point)
  • Raster.createBandedRaster(int, int, int, int, Point)


createBaselineGroup

createBaselineGroup o7planning.org
  • GroupLayout.createBaselineGroup(boolean, boolean)


createBCSChild

createBCSChild o7planning.org
  • BeanContextServicesSupport.createBCSChild(Object, Object)
  • BeanContextSupport.createBCSChild(Object, Object)


createBCSSServiceProvider

createBCSSServiceProvider o7planning.org
  • BeanContextServicesSupport.createBCSSServiceProvider(Class, BeanContextServiceProvider)


createBevelBorder

createBevelBorder o7planning.org
  • BorderFactory.createBevelBorder(int, Color, Color, Color, Color)
  • BorderFactory.createBevelBorder(int, Color, Color)
  • BorderFactory.createBevelBorder(int)


createBinder

createBinder o7planning.org
  • JAXBContext.createBinder()
  • JAXBContext.createBinder(Class<T>)


createBindings

createBindings o7planning.org
  • ScriptEngine.createBindings()


createBlackLineBorder

createBlackLineBorder o7planning.org
  • LineBorder.createBlackLineBorder()


createBlob

createBlob o7planning.org
  • Connection.createBlob()


createBorderListener

createBorderListener o7planning.org
  • BasicInternalFrameUI.createBorderListener(JInternalFrame)
  • MetalInternalFrameUI.createBorderListener(JInternalFrame)


createBranchElement

createBranchElement o7planning.org
  • AbstractDocument.createBranchElement(Element, AttributeSet)
  • HTMLDocument.createBranchElement(Element, AttributeSet)


createBufferedImage

createBufferedImage o7planning.org
  • ImageTypeSpecifier.createBufferedImage(int, int)


createBuffers

createBuffers o7planning.org
  • Component.FlipBufferStrategy.createBuffers(int, BufferCapabilities)


createBufferStrategy

createBufferStrategy o7planning.org
  • Canvas.createBufferStrategy(int, BufferCapabilities)
  • Canvas.createBufferStrategy(int)
  • Window.createBufferStrategy(int, BufferCapabilities)
  • Window.createBufferStrategy(int)


createButton

createButton o7planning.org
  • Toolkit.createButton(Button)


createButtonActionListener

createButtonActionListener o7planning.org
  • BasicOptionPaneUI.createButtonActionListener(int)


createButtonArea

createButtonArea o7planning.org
  • BasicOptionPaneUI.createButtonArea()


createButtonListener

createButtonListener o7planning.org
  • BasicButtonUI.createButtonListener(AbstractButton)
  • MetalButtonUI.createButtonListener(AbstractButton)


createButtons

createButtons o7planning.org
  • BasicInternalFrameTitlePane.createButtons()
  • MetalInternalFrameTitlePane.createButtons()


createCachedRowSet

createCachedRowSet o7planning.org
  • RowSetFactory.createCachedRowSet()


createCanvas

createCanvas o7planning.org
  • Toolkit.createCanvas(Canvas)


createCaret

createCaret o7planning.org
  • BasicTextUI.createCaret()
  • DefaultEditorKit.createCaret()
  • EditorKit.createCaret()


createCData

createCData o7planning.org
  • XMLEventFactory.createCData(String)


createCDATASection

createCDATASection o7planning.org
  • Document.createCDATASection(String)


createCellEditorListener

createCellEditorListener o7planning.org
  • BasicTreeUI.createCellEditorListener()


createCellRendererPane

createCellRendererPane o7planning.org
  • BasicTreeUI.createCellRendererPane()


createChangeListener

createChangeListener o7planning.org
  • AbstractButton.createChangeListener()
  • BasicMenuBarUI.createChangeListener()
  • BasicMenuUI.createChangeListener(JComponent)
  • BasicSliderUI.createChangeListener(JSlider)
  • BasicTabbedPaneUI.createChangeListener()
  • JProgressBar.createChangeListener()
  • JSlider.createChangeListener()
  • JTabbedPane.createChangeListener()


createCharacters

createCharacters o7planning.org
  • XMLEventFactory.createCharacters(String)


createCheckbox

createCheckbox o7planning.org
  • Toolkit.createCheckbox(Checkbox)


createCheckboxMenuItem

createCheckboxMenuItem o7planning.org
  • Toolkit.createCheckboxMenuItem(CheckboxMenuItem)


createChild

createChild o7planning.org
  • Raster.createChild(int, int, int, int, int, int, int[])


createChildren

createChildren o7planning.org
  • JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode, Object)


createChildState

createChildState o7planning.org
  • AsyncBoxView.createChildState(View)


createChoice

createChoice o7planning.org
  • Toolkit.createChoice(Choice)


createClassFile

createClassFile o7planning.org
  • Filer.createClassFile(CharSequence, Element...)


createClob

createClob o7planning.org
  • Connection.createClob()


createComment

createComment o7planning.org
  • Document.createComment(String)
  • XMLEventFactory.createComment(String)


createCompatibleDestImage

createCompatibleDestImage o7planning.org
  • AffineTransformOp.createCompatibleDestImage(BufferedImage, ColorModel)
  • BufferedImageOp.createCompatibleDestImage(BufferedImage, ColorModel)
  • ColorConvertOp.createCompatibleDestImage(BufferedImage, ColorModel)
  • ConvolveOp.createCompatibleDestImage(BufferedImage, ColorModel)
  • LookupOp.createCompatibleDestImage(BufferedImage, ColorModel)
  • RescaleOp.createCompatibleDestImage(BufferedImage, ColorModel)


createCompatibleDestRaster

createCompatibleDestRaster o7planning.org
  • AffineTransformOp.createCompatibleDestRaster(Raster)
  • BandCombineOp.createCompatibleDestRaster(Raster)
  • ColorConvertOp.createCompatibleDestRaster(Raster)
  • ConvolveOp.createCompatibleDestRaster(Raster)
  • LookupOp.createCompatibleDestRaster(Raster)
  • RasterOp.createCompatibleDestRaster(Raster)
  • RescaleOp.createCompatibleDestRaster(Raster)


createCompatibleImage

createCompatibleImage o7planning.org
  • GraphicsConfiguration.createCompatibleImage(int, int, int)
  • GraphicsConfiguration.createCompatibleImage(int, int)


createCompatibleSampleModel

createCompatibleSampleModel o7planning.org
  • BandedSampleModel.createCompatibleSampleModel(int, int)
  • ColorModel.createCompatibleSampleModel(int, int)
  • ComponentColorModel.createCompatibleSampleModel(int, int)
  • ComponentSampleModel.createCompatibleSampleModel(int, int)
  • IndexColorModel.createCompatibleSampleModel(int, int)
  • MultiPixelPackedSampleModel.createCompatibleSampleModel(int, int)
  • PackedColorModel.createCompatibleSampleModel(int, int)
  • PixelInterleavedSampleModel.createCompatibleSampleModel(int, int)
  • SampleModel.createCompatibleSampleModel(int, int)
  • SinglePixelPackedSampleModel.createCompatibleSampleModel(int, int)


createCompatibleVolatileImage

createCompatibleVolatileImage o7planning.org
  • GraphicsConfiguration.createCompatibleVolatileImage(int, int, ImageCapabilities, int)
  • GraphicsConfiguration.createCompatibleVolatileImage(int, int, ImageCapabilities)
  • GraphicsConfiguration.createCompatibleVolatileImage(int, int, int)
  • GraphicsConfiguration.createCompatibleVolatileImage(int, int)


createCompatibleWritableRaster

createCompatibleWritableRaster o7planning.org
  • ColorModel.createCompatibleWritableRaster(int, int)
  • ComponentColorModel.createCompatibleWritableRaster(int, int)
  • DirectColorModel.createCompatibleWritableRaster(int, int)
  • IndexColorModel.createCompatibleWritableRaster(int, int)
  • Raster.createCompatibleWritableRaster(int, int, int, int)
  • Raster.createCompatibleWritableRaster(Rectangle)
  • Raster.createCompatibleWritableRaster(int, int)
  • Raster.createCompatibleWritableRaster()


createComponent

createComponent o7planning.org
  • ComponentView.createComponent()
  • FormView.createComponent()
  • ObjectView.createComponent()
  • Toolkit.createComponent(Component)


createComponentListener

createComponentListener o7planning.org
  • BasicInternalFrameUI.createComponentListener()
  • BasicSliderUI.createComponentListener(JSlider)
  • BasicTreeUI.createComponentListener()
  • SynthInternalFrameUI.createComponentListener()


createCompoundBorder

createCompoundBorder o7planning.org
  • BorderFactory.createCompoundBorder(Border, Border)
  • BorderFactory.createCompoundBorder()


createCompoundEdit

createCompoundEdit o7planning.org
  • UndoableEditSupport.createCompoundEdit()


createConnection

createConnection o7planning.org
  • SOAPConnectionFactory.createConnection()


createContainer

createContainer o7planning.org
  • DefaultTreeCellEditor.createContainer()


createContainerListener

createContainerListener o7planning.org
  • BasicMenuBarUI.createContainerListener()
  • MetalToolBarUI.createContainerListener()


createContentHandler

createContentHandler o7planning.org
  • ContentHandlerFactory.createContentHandler(String)


createContentPane

createContentPane o7planning.org
  • JRootPane.createContentPane()


createContext

createContext o7planning.org
  • AlphaComposite.createContext(ColorModel, ColorModel, RenderingHints)
  • Color.createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints)
  • Composite.createContext(ColorModel, ColorModel, RenderingHints)
  • GSSManager.createContext(byte[])
  • GSSManager.createContext(GSSCredential)
  • GSSManager.createContext(GSSName, Oid, GSSCredential, int)
  • GradientPaint.createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints)
  • LinearGradientPaint.createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints)
  • Paint.createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints)
  • RadialGradientPaint.createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints)
  • TexturePaint.createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints)


createCopy

createCopy o7planning.org
  • CachedRowSet.createCopy()


createCopyNoConstraints

createCopyNoConstraints o7planning.org
  • CachedRowSet.createCopyNoConstraints()


createCopySchema

createCopySchema o7planning.org
  • CachedRowSet.createCopySchema()


createCredential

createCredential o7planning.org
  • GSSManager.createCredential(GSSName, int, Oid[], int)
  • GSSManager.createCredential(GSSName, int, Oid, int)
  • GSSManager.createCredential(int)


createCustomCursor

createCustomCursor o7planning.org
  • Toolkit.createCustomCursor(Image, Point, String)


createDashedBorder

createDashedBorder o7planning.org
  • BorderFactory.createDashedBorder(Paint, float, float, float, boolean)
  • BorderFactory.createDashedBorder(Paint, float, float)
  • BorderFactory.createDashedBorder(Paint)


createDataBuffer

createDataBuffer o7planning.org
  • BandedSampleModel.createDataBuffer()
  • ComponentSampleModel.createDataBuffer()
  • MultiPixelPackedSampleModel.createDataBuffer()
  • SampleModel.createDataBuffer()
  • SinglePixelPackedSampleModel.createDataBuffer()


createDataContentHandler

createDataContentHandler o7planning.org
  • CommandMap.createDataContentHandler(String, DataSource)
  • CommandMap.createDataContentHandler(String)
  • DataContentHandlerFactory.createDataContentHandler(String)
  • MailcapCommandMap.createDataContentHandler(String)


createDatagramSocketImpl

createDatagramSocketImpl o7planning.org
  • DatagramSocketImplFactory.createDatagramSocketImpl()


createDateTime

createDateTime o7planning.org
  • ZoneOffsetTransitionRule.TimeDefinition.createDateTime(LocalDateTime, ZoneOffset, ZoneOffset)


createdCellEditor

createdCellEditor o7planning.org
  • BasicTreeUI.createdCellEditor


createDecreaseButton

createDecreaseButton o7planning.org
  • BasicScrollBarUI.createDecreaseButton(int)
  • MetalScrollBarUI.createDecreaseButton(int)
  • SynthScrollBarUI.createDecreaseButton(int)


createDefaultCellEditor

createDefaultCellEditor o7planning.org
  • BasicTreeUI.createDefaultCellEditor()
  • SynthTreeUI.createDefaultCellEditor()


createDefaultCellRenderer

createDefaultCellRenderer o7planning.org
  • BasicTreeUI.createDefaultCellRenderer()
  • SynthTreeUI.createDefaultCellRenderer()


createDefaultChoosers

createDefaultChoosers o7planning.org
  • BasicColorChooserUI.createDefaultChoosers()
  • SynthColorChooserUI.createDefaultChoosers()


createDefaultColumnModel

createDefaultColumnModel o7planning.org
  • JTable.createDefaultColumnModel()
  • JTableHeader.createDefaultColumnModel()


createDefaultColumnsFromModel

createDefaultColumnsFromModel o7planning.org
  • JTable.createDefaultColumnsFromModel()


createDefaultDataModel

createDefaultDataModel o7planning.org
  • JTable.createDefaultDataModel()


createDefaultDivider

createDefaultDivider o7planning.org
  • BasicSplitPaneUI.createDefaultDivider()
  • MetalSplitPaneUI.createDefaultDivider()
  • SynthSplitPaneUI.createDefaultDivider()


createDefaultDocument

createDefaultDocument o7planning.org
  • DefaultEditorKit.createDefaultDocument()
  • EditorKit.createDefaultDocument()
  • HTMLEditorKit.createDefaultDocument()
  • StyledEditorKit.createDefaultDocument()


createDefaultDragGestureRecognizer

createDefaultDragGestureRecognizer o7planning.org
  • DragSource.createDefaultDragGestureRecognizer(Component, int, DragGestureListener)


createDefaultEditorKit

createDefaultEditorKit o7planning.org
  • JEditorPane.createDefaultEditorKit()
  • JTextPane.createDefaultEditorKit()


createDefaultEditors

createDefaultEditors o7planning.org
  • JTable.createDefaultEditors()


createDefaultHeaderRenderer

createDefaultHeaderRenderer o7planning.org
  • TableColumn.createDefaultHeaderRenderer()


createDefaultKeySelectionManager

createDefaultKeySelectionManager o7planning.org
  • JComboBox.createDefaultKeySelectionManager()


createDefaultModel

createDefaultModel o7planning.org
  • JTextArea.createDefaultModel()
  • JTextField.createDefaultModel()


createDefaultNonContinuousLayoutDivider

createDefaultNonContinuousLayoutDivider o7planning.org
  • BasicSplitPaneUI.createDefaultNonContinuousLayoutDivider()
  • SynthSplitPaneUI.createDefaultNonContinuousLayoutDivider()


createDefaultRenderer

createDefaultRenderer o7planning.org
  • JTableHeader.createDefaultRenderer()


createDefaultRenderers

createDefaultRenderers o7planning.org
  • JTable.createDefaultRenderers()


createDefaultRendering

createDefaultRendering o7planning.org
  • RenderableImage.createDefaultRendering()
  • RenderableImageOp.createDefaultRendering()


createDefaultRoot

createDefaultRoot o7planning.org
  • DefaultStyledDocument.createDefaultRoot()
  • HTMLDocument.createDefaultRoot()
  • PlainDocument.createDefaultRoot()


createDefaultSelectionModel

createDefaultSelectionModel o7planning.org
  • JTable.createDefaultSelectionModel()


createDefaultTableHeader

createDefaultTableHeader o7planning.org
  • JTable.createDefaultTableHeader()


createDefaultTheme

createDefaultTheme o7planning.org
  • MetalLookAndFeel.createDefaultTheme()


createDesktopManager

createDesktopManager o7planning.org
  • BasicInternalFrameUI.createDesktopManager()


createDesktopPeer

createDesktopPeer o7planning.org
  • Toolkit.createDesktopPeer(Desktop)


createDetail

createDetail o7planning.org
  • SOAPFactory.createDetail()


createDetailsView

createDetailsView o7planning.org
  • MetalFileChooserUI.createDetailsView(JFileChooser)


createDialog

createDialog o7planning.org
  • JColorChooser.createDialog(Component, String, boolean, JColorChooser, ActionListener, ActionListener)
  • JFileChooser.createDialog(Component)
  • JOptionPane.createDialog(String)
  • JOptionPane.createDialog(Component, String)
  • Toolkit.createDialog(Dialog)


createDirectories

createDirectories o7planning.org
  • Files.createDirectories(Path, FileAttribute<?>...)


createDirectory

createDirectory o7planning.org
  • FileSystemProvider.createDirectory(Path, FileAttribute<?>...)
  • Files.createDirectory(Path, FileAttribute<?>...)


createDirectoryComboBoxModel

createDirectoryComboBoxModel o7planning.org
  • MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser)


createDirectoryComboBoxRenderer

createDirectoryComboBoxRenderer o7planning.org
  • MetalFileChooserUI.createDirectoryComboBoxRenderer(JFileChooser)


createDisabledImage

createDisabledImage o7planning.org
  • GrayFilter.createDisabledImage(Image)


createDispatch

createDispatch o7planning.org
  • Service.createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...)
  • Service.createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...)
  • Service.createDispatch(QName, JAXBContext, Service.Mode)
  • Service.createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...)
  • Service.createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...)
  • Service.createDispatch(QName, Class<T>, Service.Mode)
  • ServiceDelegate.createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...)
  • ServiceDelegate.createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...)
  • ServiceDelegate.createDispatch(QName, JAXBContext, Service.Mode)
  • ServiceDelegate.createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...)
  • ServiceDelegate.createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...)
  • ServiceDelegate.createDispatch(QName, Class<T>, Service.Mode)


createDockingListener

createDockingListener o7planning.org
  • BasicToolBarUI.createDockingListener()
  • MetalToolBarUI.createDockingListener()


createDocument

createDocument o7planning.org
  • DOMImplementation.createDocument(String, String, DocumentType)


createDocumentFragment

createDocumentFragment o7planning.org
  • Document.createDocumentFragment()


createDocumentType

createDocumentType o7planning.org
  • DOMImplementation.createDocumentType(String, String, String)


createDoubleClickListener

createDoubleClickListener o7planning.org
  • BasicFileChooserUI.createDoubleClickListener(JFileChooser, JList)


createDragGestureRecognizer

createDragGestureRecognizer o7planning.org
  • DragSource.createDragGestureRecognizer(Class<T>, Component, int, DragGestureListener)
  • Toolkit.createDragGestureRecognizer(Class<T>, DragSource, Component, int, DragGestureListener)


createDragSourceContext

createDragSourceContext o7planning.org
  • DragSource.createDragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener)


createDragSourceContextPeer

createDragSourceContextPeer o7planning.org
  • Toolkit.createDragSourceContextPeer(DragGestureEvent)


createDragWindow

createDragWindow o7planning.org
  • BasicToolBarUI.createDragWindow(JToolBar)


createdRenderer

createdRenderer o7planning.org
  • BasicTreeUI.createdRenderer


createDropTargetAutoScroller

createDropTargetAutoScroller o7planning.org
  • DropTarget.createDropTargetAutoScroller(Component, Point)


createDropTargetContext

createDropTargetContext o7planning.org
  • DropTarget.createDropTargetContext()


createDTD

createDTD o7planning.org
  • ParserDelegator.createDTD(DTD, String)
  • XMLEventFactory.createDTD(String)


createEastPane

createEastPane o7planning.org
  • BasicInternalFrameUI.createEastPane(JInternalFrame)


createEditor

createEditor o7planning.org
  • BasicComboBoxUI.createEditor()
  • BasicSpinnerUI.createEditor()
  • JSpinner.createEditor(SpinnerModel)
  • MetalComboBoxUI.createEditor()
  • SynthComboBoxUI.createEditor()
  • SynthSpinnerUI.createEditor()


createEditorComponent

createEditorComponent o7planning.org
  • BasicComboBoxEditor.createEditorComponent()


createEditorKitForContentType

createEditorKitForContentType o7planning.org
  • JEditorPane.createEditorKitForContentType(String)


createElement

createElement o7planning.org
  • Document.createElement(String)
  • SOAPFactory.createElement(String, String, String)
  • SOAPFactory.createElement(String)
  • SOAPFactory.createElement(QName)
  • SOAPFactory.createElement(Name)
  • SOAPFactory.createElement(Element)


createElementNS

createElementNS o7planning.org
  • Document.createElementNS(String, String)


createEmptyBorder

createEmptyBorder o7planning.org
  • BorderFactory.createEmptyBorder(int, int, int, int)
  • BorderFactory.createEmptyBorder()


createEmptyFrameIcon

createEmptyFrameIcon o7planning.org
  • BasicIconFactory.createEmptyFrameIcon()


createEndDocument

createEndDocument o7planning.org
  • XMLEventFactory.createEndDocument()


createEndElement

createEndElement o7planning.org
  • XMLEventFactory.createEndElement(String, String, String, Iterator)
  • XMLEventFactory.createEndElement(String, String, String)
  • XMLEventFactory.createEndElement(QName, Iterator)


createEndpoint

createEndpoint o7planning.org
  • Provider.createEndpoint(String, Class<?>, Invoker, WebServiceFeature...)
  • Provider.createEndpoint(String, Object, WebServiceFeature...)
  • Provider.createEndpoint(String, Object)


createEntityReference

createEntityReference o7planning.org
  • Document.createEntityReference(String)
  • XMLEventFactory.createEntityReference(String, EntityDeclaration)


createEtchedBorder

createEtchedBorder o7planning.org
  • BorderFactory.createEtchedBorder(int, Color, Color)
  • BorderFactory.createEtchedBorder(int)
  • BorderFactory.createEtchedBorder(Color, Color)
  • BorderFactory.createEtchedBorder()


createEvent

createEvent o7planning.org
  • DocumentEvent.createEvent(String)


createExceptionReply

createExceptionReply o7planning.org
  • ResponseHandler.createExceptionReply()


createExtendedResponse

createExtendedResponse o7planning.org
  • ExtendedRequest.createExtendedResponse(String, byte[], int, int)
  • StartTlsRequest.createExtendedResponse(String, byte[], int, int)


createFault

createFault o7planning.org
  • SOAPFactory.createFault()
  • SOAPFactory.createFault(String, QName)


createFile

createFile o7planning.org
  • Files.createFile(Path, FileAttribute<?>...)


createFileDialog

createFileDialog o7planning.org
  • Toolkit.createFileDialog(FileDialog)


createFileObject

createFileObject o7planning.org
  • FileSystemView.createFileObject(String)
  • FileSystemView.createFileObject(File, String)


createFileSystemRoot

createFileSystemRoot o7planning.org
  • FileSystemView.createFileSystemRoot(File)


createFilterComboBoxModel

createFilterComboBoxModel o7planning.org
  • MetalFileChooserUI.createFilterComboBoxModel()


createFilterComboBoxRenderer

createFilterComboBoxRenderer o7planning.org
  • MetalFileChooserUI.createFilterComboBoxRenderer()


createFilteredReader

createFilteredReader o7planning.org
  • XMLInputFactory.createFilteredReader(XMLEventReader, EventFilter)
  • XMLInputFactory.createFilteredReader(XMLStreamReader, StreamFilter)


createFilteredRowSet

createFilteredRowSet o7planning.org
  • RowSetFactory.createFilteredRowSet()


createFloatingFrame

createFloatingFrame o7planning.org
  • BasicToolBarUI.createFloatingFrame(JToolBar)


createFloatingWindow

createFloatingWindow o7planning.org
  • BasicToolBarUI.createFloatingWindow(JToolBar)


createFocusListener

createFocusListener o7planning.org
  • BasicComboBoxUI.createFocusListener()
  • BasicListUI.createFocusListener()
  • BasicSliderUI.createFocusListener(JSlider)
  • BasicSplitPaneUI.createFocusListener()
  • BasicTabbedPaneUI.createFocusListener()
  • BasicTableUI.createFocusListener()
  • BasicTreeUI.createFocusListener()


createFont

createFont o7planning.org
  • Font.createFont(int, File)
  • Font.createFont(int, InputStream)


createFragment

createFragment o7planning.org
  • GlyphView.createFragment(int, int)
  • View.createFragment(int, int)


createFrame

createFrame o7planning.org
  • Toolkit.createFrame(Frame)


createFrameListener

createFrameListener o7planning.org
  • BasicToolBarUI.createFrameListener()


createFromBufferedImageType

createFromBufferedImageType o7planning.org
  • ImageTypeSpecifier.createFromBufferedImageType(int)


createFromRenderedImage

createFromRenderedImage o7planning.org
  • ImageTypeSpecifier.createFromRenderedImage(RenderedImage)


createGlassPane

createGlassPane o7planning.org
  • JLayer.createGlassPane()
  • JRootPane.createGlassPane()


createGlassPaneDispatcher

createGlassPaneDispatcher o7planning.org
  • BasicInternalFrameUI.createGlassPaneDispatcher()


createGlue

createGlue o7planning.org
  • Box.createGlue()


createGlyphVector

createGlyphVector o7planning.org
  • Font.createGlyphVector(FontRenderContext, int[])
  • Font.createGlyphVector(FontRenderContext, CharacterIterator)
  • Font.createGlyphVector(FontRenderContext, char[])
  • Font.createGlyphVector(FontRenderContext, String)


createGraphics

createGraphics o7planning.org
  • BufferedImage.createGraphics()
  • GraphicsEnvironment.createGraphics(BufferedImage)
  • SplashScreen.createGraphics()
  • VolatileImage.createGraphics()


createGrayLineBorder

createGrayLineBorder o7planning.org
  • LineBorder.createGrayLineBorder()


createGrayscale

createGrayscale o7planning.org
  • ImageTypeSpecifier.createGrayscale(int, int, boolean, boolean)
  • ImageTypeSpecifier.createGrayscale(int, int, boolean)


createGroup

createGroup o7planning.org
  • ActivationGroup.createGroup(ActivationGroupID, ActivationGroupDesc, long)


createHandler

createHandler o7planning.org
  • XMLDecoder.createHandler(Object, ExceptionListener, ClassLoader)


createHighlighter

createHighlighter o7planning.org
  • BasicTextUI.createHighlighter()


createHorizontalBox

createHorizontalBox o7planning.org
  • Box.createHorizontalBox()


createHorizontalGlue

createHorizontalGlue o7planning.org
  • Box.createHorizontalGlue()


createHorizontalScrollBar

createHorizontalScrollBar o7planning.org
  • JScrollPane.createHorizontalScrollBar()


createHorizontalStrut

createHorizontalStrut o7planning.org
  • Box.createHorizontalStrut(int)


createHSBChangeListener

createHSBChangeListener o7planning.org
  • BasicScrollPaneUI.createHSBChangeListener()


createHTMLView

createHTMLView o7planning.org
  • BasicHTML.createHTMLView(JComponent, String)


createIgnorableSpace

createIgnorableSpace o7planning.org
  • XMLEventFactory.createIgnorableSpace(String)


createImage

createImage o7planning.org
  • Component.createImage(int, int)
  • Component.createImage(ImageProducer)
  • Toolkit.createImage(byte[], int, int)
  • Toolkit.createImage(byte[])
  • Toolkit.createImage(ImageProducer)
  • Toolkit.createImage(URL)
  • Toolkit.createImage(String)


createImageInputStream

createImageInputStream o7planning.org
  • ImageIO.createImageInputStream(Object)


createImageOutputStream

createImageOutputStream o7planning.org
  • ImageIO.createImageOutputStream(Object)


createIncreaseButton

createIncreaseButton o7planning.org
  • BasicScrollBarUI.createIncreaseButton(int)
  • MetalScrollBarUI.createIncreaseButton(int)
  • SynthScrollBarUI.createIncreaseButton(int)


createIndexed

createIndexed o7planning.org
  • ImageTypeSpecifier.createIndexed(byte[], byte[], byte[], byte[], int, int)


createInitialContextFactory

createInitialContextFactory o7planning.org
  • InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?, ?>)


createInputAttributes

createInputAttributes o7planning.org
  • HTMLEditorKit.createInputAttributes(Element, MutableAttributeSet)
  • StyledEditorKit.createInputAttributes(Element, MutableAttributeSet)


createInputMethod

createInputMethod o7planning.org
  • InputMethodDescriptor.createInputMethod()


createInputMethodJFrame

createInputMethodJFrame o7planning.org
  • InputMethodContext.createInputMethodJFrame(String, boolean)


createInputMethodWindow

createInputMethodWindow o7planning.org
  • InputMethodContext.createInputMethodWindow(String, boolean)


createInputStreamInstance

createInputStreamInstance o7planning.org
  • ImageInputStreamSpi.createInputStreamInstance(Object)
  • ImageInputStreamSpi.createInputStreamInstance(Object, boolean, File)


createInterleaved

createInterleaved o7planning.org
  • ImageTypeSpecifier.createInterleaved(ColorSpace, int[], int, boolean, boolean)


createInterleavedRaster

createInterleavedRaster o7planning.org
  • Raster.createInterleavedRaster(DataBuffer, int, int, int, int, int[], Point)
  • Raster.createInterleavedRaster(int, int, int, int, int, int[], Point)
  • Raster.createInterleavedRaster(int, int, int, int, Point)


createInternalFrame

createInternalFrame o7planning.org
  • JOptionPane.createInternalFrame(Component, String)


createInternalFrameListener

createInternalFrameListener o7planning.org
  • BasicInternalFrameUI.createInternalFrameListener()


createIntersection

createIntersection o7planning.org
  • Rectangle.createIntersection(Rectangle2D)
  • Rectangle2D.createIntersection(Rectangle2D)
  • Rectangle2D.Double.createIntersection(Rectangle2D)
  • Rectangle2D.Float.createIntersection(Rectangle2D)


createInverse

createInverse o7planning.org
  • AffineTransform.createInverse()


createItemListener

createItemListener o7planning.org
  • AbstractButton.createItemListener()
  • BasicComboBoxUI.createItemListener()
  • BasicComboPopup.createItemListener()


createJAXBIntrospector

createJAXBIntrospector o7planning.org
  • JAXBContext.createJAXBIntrospector()


createJdbcRowSet

createJdbcRowSet o7planning.org
  • RowSetFactory.createJdbcRowSet()


createJoinRowSet

createJoinRowSet o7planning.org
  • RowSetFactory.createJoinRowSet()


createKeyboardDownRightListener

createKeyboardDownRightListener o7planning.org
  • BasicSplitPaneUI.createKeyboardDownRightListener()


createKeyboardEndListener

createKeyboardEndListener o7planning.org
  • BasicSplitPaneUI.createKeyboardEndListener()


createKeyboardHomeListener

createKeyboardHomeListener o7planning.org
  • BasicSplitPaneUI.createKeyboardHomeListener()


createKeyboardResizeToggleListener

createKeyboardResizeToggleListener o7planning.org
  • BasicSplitPaneUI.createKeyboardResizeToggleListener()


createKeyboardUpLeftListener

createKeyboardUpLeftListener o7planning.org
  • BasicSplitPaneUI.createKeyboardUpLeftListener()


createKeyListener

createKeyListener o7planning.org
  • BasicComboBoxUI.createKeyListener()
  • BasicComboPopup.createKeyListener()
  • BasicTableUI.createKeyListener()
  • BasicTreeUI.createKeyListener()


createKeymap

createKeymap o7planning.org
  • BasicTextUI.createKeymap()


createLabel

createLabel o7planning.org
  • Toolkit.createLabel(Label)


createLargeAttributeSet

createLargeAttributeSet o7planning.org
  • StyleContext.createLargeAttributeSet(AttributeSet)
  • StyleSheet.createLargeAttributeSet(AttributeSet)


createLayeredPane

createLayeredPane o7planning.org
  • JRootPane.createLayeredPane()


createLayout

createLayout o7planning.org
  • BasicInternalFrameTitlePane.createLayout()
  • BasicSpinnerUI.createLayout()
  • MetalInternalFrameTitlePane.createLayout()
  • SynthSpinnerUI.createLayout()
  • SynthToolBarUI.createLayout()


createLayoutCache

createLayoutCache o7planning.org
  • BasicTreeUI.createLayoutCache()


createLayoutManager

createLayoutManager o7planning.org
  • BasicComboBoxUI.createLayoutManager()
  • BasicInternalFrameUI.createLayoutManager()
  • BasicOptionPaneUI.createLayoutManager()
  • BasicTabbedPaneUI.createLayoutManager()
  • JViewport.createLayoutManager()
  • MetalComboBoxUI.createLayoutManager()
  • MetalTabbedPaneUI.createLayoutManager()
  • SynthTabbedPaneUI.createLayoutManager()


createLeafElement

createLeafElement o7planning.org
  • AbstractDocument.createLeafElement(Element, AttributeSet, int, int)
  • HTMLDocument.createLeafElement(Element, AttributeSet, int, int)


createLeftOneTouchButton

createLeftOneTouchButton o7planning.org
  • BasicSplitPaneDivider.createLeftOneTouchButton()


createLineBidi

createLineBidi o7planning.org
  • Bidi.createLineBidi(int, int)


createLineBorder

createLineBorder o7planning.org
  • BorderFactory.createLineBorder(Color, int, boolean)
  • BorderFactory.createLineBorder(Color, int)
  • BorderFactory.createLineBorder(Color)


createLink

createLink o7planning.org
  • FileSystemProvider.createLink(Path, Path)
  • Files.createLink(Path, Path)


createList

createList o7planning.org
  • BasicComboPopup.createList()
  • MetalFileChooserUI.createList(JFileChooser)
  • Toolkit.createList(List)


createListDataListener

createListDataListener o7planning.org
  • BasicComboBoxUI.createListDataListener()
  • BasicComboPopup.createListDataListener()
  • BasicListUI.createListDataListener()


createListMouseListener

createListMouseListener o7planning.org
  • BasicComboPopup.createListMouseListener()


createListMouseMotionListener

createListMouseMotionListener o7planning.org
  • BasicComboPopup.createListMouseMotionListener()


createListSelectionListener

createListSelectionListener o7planning.org
  • BasicComboPopup.createListSelectionListener()
  • BasicFileChooserUI.createListSelectionListener(JFileChooser)
  • BasicListUI.createListSelectionListener()
  • MetalFileChooserUI.createListSelectionListener(JFileChooser)


createLoweredBevelBorder

createLoweredBevelBorder o7planning.org
  • BorderFactory.createLoweredBevelBorder()


createLoweredSoftBevelBorder

createLoweredSoftBevelBorder o7planning.org
  • BorderFactory.createLoweredSoftBevelBorder()


createLSInput

createLSInput o7planning.org
  • DOMImplementationLS.createLSInput()


createLSOutput

createLSOutput o7planning.org
  • DOMImplementationLS.createLSOutput()


createLSParser

createLSParser o7planning.org
  • DOMImplementationLS.createLSParser(short, String)


createLSSerializer

createLSSerializer o7planning.org
  • DOMImplementationLS.createLSSerializer()


createMarshaller

createMarshaller o7planning.org
  • JAXBContext.createMarshaller()


createMatteBorder

createMatteBorder o7planning.org
  • BorderFactory.createMatteBorder(int, int, int, int, Icon)
  • BorderFactory.createMatteBorder(int, int, int, int, Color)


createMBean

createMBean o7planning.org
  • MBeanServer.createMBean(String, ObjectName, ObjectName, Object[], String[])
  • MBeanServer.createMBean(String, ObjectName, Object[], String[])
  • MBeanServer.createMBean(String, ObjectName, ObjectName)
  • MBeanServer.createMBean(String, ObjectName)
  • MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[])
  • MBeanServerConnection.createMBean(String, ObjectName, Object[], String[])
  • MBeanServerConnection.createMBean(String, ObjectName, ObjectName)
  • MBeanServerConnection.createMBean(String, ObjectName)
  • RMIConnection.createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject)
  • RMIConnection.createMBean(String, ObjectName, MarshalledObject, String[], Subject)
  • RMIConnection.createMBean(String, ObjectName, ObjectName, Subject)
  • RMIConnection.createMBean(String, ObjectName, Subject)
  • RMIConnectionImpl.createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject)
  • RMIConnectionImpl.createMBean(String, ObjectName, MarshalledObject, String[], Subject)
  • RMIConnectionImpl.createMBean(String, ObjectName, ObjectName, Subject)
  • RMIConnectionImpl.createMBean(String, ObjectName, Subject)
  • RMIConnectionImpl_Stub.createMBean(String, ObjectName, Subject)
  • RMIConnectionImpl_Stub.createMBean(String, ObjectName, ObjectName, Subject)
  • RMIConnectionImpl_Stub.createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject)
  • RMIConnectionImpl_Stub.createMBean(String, ObjectName, MarshalledObject, String[], Subject)


createMBeanServer

createMBeanServer o7planning.org
  • MBeanServerFactory.createMBeanServer(String)
  • MBeanServerFactory.createMBeanServer()


createMenu

createMenu o7planning.org
  • Toolkit.createMenu(Menu)


createMenuBar

createMenuBar o7planning.org
  • Toolkit.createMenuBar(MenuBar)


createMenuDragMouseListener

createMenuDragMouseListener o7planning.org
  • BasicMenuItemUI.createMenuDragMouseListener(JComponent)
  • BasicMenuUI.createMenuDragMouseListener(JComponent)


createMenuItem

createMenuItem o7planning.org
  • Toolkit.createMenuItem(MenuItem)


createMenuKeyListener

createMenuKeyListener o7planning.org
  • BasicMenuItemUI.createMenuKeyListener(JComponent)
  • BasicMenuUI.createMenuKeyListener(JComponent)


createMenuListener

createMenuListener o7planning.org
  • BasicMenuUI.createMenuListener(JComponent)


createMessage

createMessage o7planning.org
  • MessageFactory.createMessage(MimeHeaders, InputStream)
  • MessageFactory.createMessage()


createMessageArea

createMessageArea o7planning.org
  • BasicOptionPaneUI.createMessageArea()
  • SynthOptionPaneUI.createMessageArea()


createModel

createModel o7planning.org
  • BasicFileChooserUI.createModel()


createModelListener

createModelListener o7planning.org
  • BasicScrollBarUI.createModelListener()


createMouseInputListener

createMouseInputListener o7planning.org
  • BasicDesktopIconUI.createMouseInputListener()
  • BasicListUI.createMouseInputListener()
  • BasicMenuItemUI.createMouseInputListener(JComponent)
  • BasicMenuUI.createMouseInputListener(JComponent)
  • BasicTableHeaderUI.createMouseInputListener()
  • BasicTableUI.createMouseInputListener()


createMouseListener

createMouseListener o7planning.org
  • BasicComboPopup.createMouseListener()
  • BasicTabbedPaneUI.createMouseListener()
  • BasicTreeUI.createMouseListener()
  • SynthTabbedPaneUI.createMouseListener()


createMouseMotionListener

createMouseMotionListener o7planning.org
  • BasicComboPopup.createMouseMotionListener()


createMouseWheelListener

createMouseWheelListener o7planning.org
  • BasicScrollPaneUI.createMouseWheelListener()


createMultiDocPrintJob

createMultiDocPrintJob o7planning.org
  • MultiDocPrintService.createMultiDocPrintJob()


createName

createName o7planning.org
  • GSSManager.createName(byte[], Oid, Oid)
  • GSSManager.createName(String, Oid, Oid)
  • GSSManager.createName(byte[], Oid)
  • GSSManager.createName(String, Oid)
  • SOAPEnvelope.createName(String)
  • SOAPEnvelope.createName(String, String, String)
  • SOAPFactory.createName(String)
  • SOAPFactory.createName(String, String, String)


createNamespace

createNamespace o7planning.org
  • XMLEventFactory.createNamespace(String, String)
  • XMLEventFactory.createNamespace(String)


createNClob

createNClob o7planning.org
  • Connection.createNClob()


createNewFile

createNewFile o7planning.org
  • File.createNewFile()


createNewFolder

createNewFolder o7planning.org
  • FileSystemView.createNewFolder(File)


createNextButton

createNextButton o7planning.org
  • BasicSpinnerUI.createNextButton()
  • SynthSpinnerUI.createNextButton()


createNodeDimensions

createNodeDimensions o7planning.org
  • BasicTreeUI.createNodeDimensions()


createNonRolloverBorder

createNonRolloverBorder o7planning.org
  • BasicToolBarUI.createNonRolloverBorder()
  • MetalToolBarUI.createNonRolloverBorder()


createNorthPane

createNorthPane o7planning.org
  • BasicInternalFrameUI.createNorthPane(JInternalFrame)
  • MetalInternalFrameUI.createNorthPane(JInternalFrame)
  • SynthInternalFrameUI.createNorthPane(JInternalFrame)


createObjectFactory

createObjectFactory o7planning.org
  • ObjectFactoryBuilder.createObjectFactory(Object, Hashtable<?, ?>)


createOutput

createOutput o7planning.org
  • SchemaOutputResolver.createOutput(String, String)


createOutputStreamInstance

createOutputStreamInstance o7planning.org
  • ImageOutputStreamSpi.createOutputStreamInstance(Object)
  • ImageOutputStreamSpi.createOutputStreamInstance(Object, boolean, File)


createPacked

createPacked o7planning.org
  • ImageTypeSpecifier.createPacked(ColorSpace, int, int, int, int, int, boolean)


createPackedRaster

createPackedRaster o7planning.org
  • Raster.createPackedRaster(DataBuffer, int, int, int, Point)
  • Raster.createPackedRaster(DataBuffer, int, int, int, int[], Point)
  • Raster.createPackedRaster(int, int, int, int, int, Point)
  • Raster.createPackedRaster(int, int, int, int[], Point)


createPanel

createPanel o7planning.org
  • Toolkit.createPanel(Panel)


createParallelGroup

createParallelGroup o7planning.org
  • GroupLayout.createParallelGroup(GroupLayout.Alignment, boolean)
  • GroupLayout.createParallelGroup(GroupLayout.Alignment)
  • GroupLayout.createParallelGroup()


createPopup

createPopup o7planning.org
  • BasicComboBoxUI.createPopup()
  • MetalComboBoxUI.createPopup()
  • SynthComboBoxUI.createPopup()


createPopupMenu

createPopupMenu o7planning.org
  • Toolkit.createPopupMenu(PopupMenu)


createPosition

createPosition o7planning.org
  • AbstractDocument.createPosition(int)
  • AbstractDocument.Content.createPosition(int)
  • Document.createPosition(int)
  • GapContent.createPosition(int)
  • StringContent.createPosition(int)


createPreviousButton

createPreviousButton o7planning.org
  • BasicSpinnerUI.createPreviousButton()
  • SynthSpinnerUI.createPreviousButton()


createPrintJob

createPrintJob o7planning.org
  • PrintService.createPrintJob()


createProcessingInstruction

createProcessingInstruction o7planning.org
  • Document.createProcessingInstruction(String, String)
  • XMLEventFactory.createProcessingInstruction(String, String)


createPropertyChangeListener

createPropertyChangeListener o7planning.org
  • BasicColorChooserUI.createPropertyChangeListener()
  • BasicComboBoxUI.createPropertyChangeListener()
  • BasicComboPopup.createPropertyChangeListener()
  • BasicDesktopPaneUI.createPropertyChangeListener()
  • BasicFileChooserUI.createPropertyChangeListener(JFileChooser)
  • BasicInternalFrameTitlePane.createPropertyChangeListener()
  • BasicInternalFrameUI.createPropertyChangeListener()
  • BasicListUI.createPropertyChangeListener()
  • BasicMenuItemUI.createPropertyChangeListener(JComponent)
  • BasicMenuUI.createPropertyChangeListener(JComponent)
  • BasicOptionPaneUI.createPropertyChangeListener()
  • BasicScrollBarUI.createPropertyChangeListener()
  • BasicScrollPaneUI.createPropertyChangeListener()
  • BasicSliderUI.createPropertyChangeListener(JSlider)
  • BasicSpinnerUI.createPropertyChangeListener()
  • BasicSplitPaneUI.createPropertyChangeListener()
  • BasicTabbedPaneUI.createPropertyChangeListener()
  • BasicTreeUI.createPropertyChangeListener()
  • MetalComboBoxUI.createPropertyChangeListener()
  • MetalFileChooserUI.createPropertyChangeListener(JFileChooser)
  • MetalInternalFrameTitlePane.createPropertyChangeListener()
  • MetalScrollBarUI.createPropertyChangeListener()
  • MetalSliderUI.createPropertyChangeListener(JSlider)


createPropertyEditor

createPropertyEditor o7planning.org
  • PropertyDescriptor.createPropertyEditor(Object)


createPropertyListener

createPropertyListener o7planning.org
  • BasicToolBarUI.createPropertyListener()


createQName

createQName o7planning.org
  • SOAPElement.createQName(String, String)


createRaisedBevelBorder

createRaisedBevelBorder o7planning.org
  • BorderFactory.createRaisedBevelBorder()


createRaisedSoftBevelBorder

createRaisedSoftBevelBorder o7planning.org
  • BorderFactory.createRaisedSoftBevelBorder()


createRaster

createRaster o7planning.org
  • Raster.createRaster(SampleModel, DataBuffer, Point)


createReaderInstance

createReaderInstance o7planning.org
  • ImageReaderSpi.createReaderInstance(Object)
  • ImageReaderSpi.createReaderInstance()


createRegistry

createRegistry o7planning.org
  • LocateRegistry.createRegistry(int, RMIClientSocketFactory, RMIServerSocketFactory)
  • LocateRegistry.createRegistry(int)


createRelation

createRelation o7planning.org
  • RelationService.createRelation(String, String, RoleList)
  • RelationServiceMBean.createRelation(String, String, RoleList)


createRelationType

createRelationType o7planning.org
  • RelationService.createRelationType(String, RoleInfo[])
  • RelationServiceMBean.createRelationType(String, RoleInfo[])


createRenderer

createRenderer o7planning.org
  • BasicComboBoxUI.createRenderer()
  • SynthComboBoxUI.createRenderer()


createRendering

createRendering o7planning.org
  • RenderableImage.createRendering(RenderContext)
  • RenderableImageOp.createRendering(RenderContext)


createReply

createReply o7planning.org
  • ResponseHandler.createReply()


createResource

createResource o7planning.org
  • Filer.createResource(JavaFileManager.Location, CharSequence, CharSequence, Element...)


createRightOneTouchButton

createRightOneTouchButton o7planning.org
  • BasicSplitPaneDivider.createRightOneTouchButton()


createRigidArea

createRigidArea o7planning.org
  • Box.createRigidArea(Dimension)


createRolloverBorder

createRolloverBorder o7planning.org
  • BasicToolBarUI.createRolloverBorder()
  • MetalToolBarUI.createRolloverBorder()


createRolloverListener

createRolloverListener o7planning.org
  • MetalToolBarUI.createRolloverListener()


createRootLayout

createRootLayout o7planning.org
  • JRootPane.createRootLayout()


createRootPane

createRootPane o7planning.org
  • JApplet.createRootPane()
  • JDialog.createRootPane()
  • JFrame.createRootPane()
  • JInternalFrame.createRootPane()
  • JWindow.createRootPane()


createRow

createRow o7planning.org
  • FlowView.createRow()
  • ParagraphView.createRow()


createSaslClient

createSaslClient o7planning.org
  • Sasl.createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler)
  • SaslClientFactory.createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler)


createSaslServer

createSaslServer o7planning.org
  • Sasl.createSaslServer(String, String, String, Map<String, ?>, CallbackHandler)
  • SaslServerFactory.createSaslServer(String, String, String, Map<String, ?>, CallbackHandler)


createScaledRendering

createScaledRendering o7planning.org
  • RenderableImage.createScaledRendering(int, int, RenderingHints)
  • RenderableImageOp.createScaledRendering(int, int, RenderingHints)


createScreenCapture

createScreenCapture o7planning.org
  • Robot.createScreenCapture(Rectangle)


createScrollbar

createScrollbar o7planning.org
  • Toolkit.createScrollbar(Scrollbar)


createScrollBarSwapListener

createScrollBarSwapListener o7planning.org
  • MetalScrollPaneUI.createScrollBarSwapListener()


createScrollButton

createScrollButton o7planning.org
  • BasicTabbedPaneUI.createScrollButton(int)
  • SynthTabbedPaneUI.createScrollButton(int)


createScroller

createScroller o7planning.org
  • BasicComboPopup.createScroller()


createScrollListener

createScrollListener o7planning.org
  • BasicScrollBarUI.createScrollListener()
  • BasicSliderUI.createScrollListener(JSlider)


createScrollPane

createScrollPane o7planning.org
  • Toolkit.createScrollPane(ScrollPane)


createScrollPaneForTable

createScrollPaneForTable o7planning.org
  • JTable.createScrollPaneForTable(JTable)


createSecondaryLoop

createSecondaryLoop o7planning.org
  • EventQueue.createSecondaryLoop()


createSelectionModel

createSelectionModel o7planning.org
  • DefaultTableColumnModel.createSelectionModel()
  • JList.createSelectionModel()


createSelectionModelPropertyChangeListener

createSelectionModelPropertyChangeListener o7planning.org
  • BasicTreeUI.createSelectionModelPropertyChangeListener()


createSeparator

createSeparator o7planning.org
  • BasicOptionPaneUI.createSeparator()
  • SynthOptionPaneUI.createSeparator()


createSequentialGroup

createSequentialGroup o7planning.org
  • GroupLayout.createSequentialGroup()


createServerSocket

createServerSocket o7planning.org
  • RMIServerSocketFactory.createServerSocket(int)
  • RMISocketFactory.createServerSocket(int)
  • ServerSocketFactory.createServerSocket(int, int, InetAddress)
  • ServerSocketFactory.createServerSocket(int, int)
  • ServerSocketFactory.createServerSocket(int)
  • ServerSocketFactory.createServerSocket()
  • SslRMIServerSocketFactory.createServerSocket(int)


createServiceDelegate

createServiceDelegate o7planning.org
  • Provider.createServiceDelegate(URL, QName, Class<? extends Service>, WebServiceFeature...)
  • Provider.createServiceDelegate(URL, QName, Class<? extends Service>)


createShared

createShared o7planning.org
  • CachedRowSet.createShared()


createSmallAttributeSet

createSmallAttributeSet o7planning.org
  • StyleContext.createSmallAttributeSet(AttributeSet)
  • StyleSheet.createSmallAttributeSet(AttributeSet)


createSNIMatcher

createSNIMatcher o7planning.org
  • SNIHostName.createSNIMatcher(String)


createSocket

createSocket o7planning.org
  • RMIClientSocketFactory.createSocket(String, int)
  • RMISocketFactory.createSocket(String, int)
  • SSLSocketFactory.createSocket(Socket, InputStream, boolean)
  • SSLSocketFactory.createSocket(Socket, String, int, boolean)
  • SocketFactory.createSocket(InetAddress, int, InetAddress, int)
  • SocketFactory.createSocket(InetAddress, int)
  • SocketFactory.createSocket(String, int, InetAddress, int)
  • SocketFactory.createSocket(String, int)
  • SocketFactory.createSocket()
  • SslRMIClientSocketFactory.createSocket(String, int)


createSocketImpl

createSocketImpl o7planning.org
  • SocketImplFactory.createSocketImpl()


createSoftBevelBorder

createSoftBevelBorder o7planning.org
  • BorderFactory.createSoftBevelBorder(int, Color, Color, Color, Color)
  • BorderFactory.createSoftBevelBorder(int, Color, Color)
  • BorderFactory.createSoftBevelBorder(int)


createSourceFile

createSourceFile o7planning.org
  • Filer.createSourceFile(CharSequence, Element...)


createSouthPane

createSouthPane o7planning.org
  • BasicInternalFrameUI.createSouthPane(JInternalFrame)


createSpace

createSpace o7planning.org
  • XMLEventFactory.createSpace(String)


createSQLXML

createSQLXML o7planning.org
  • Connection.createSQLXML()


createSSLEngine

createSSLEngine o7planning.org
  • SSLContext.createSSLEngine(String, int)
  • SSLContext.createSSLEngine()


createStandardLabels

createStandardLabels o7planning.org
  • JSlider.createStandardLabels(int, int)
  • JSlider.createStandardLabels(int)


createStartDocument

createStartDocument o7planning.org
  • XMLEventFactory.createStartDocument(String)
  • XMLEventFactory.createStartDocument(String, String)
  • XMLEventFactory.createStartDocument(String, String, boolean)
  • XMLEventFactory.createStartDocument()


createStartElement

createStartElement o7planning.org
  • XMLEventFactory.createStartElement(String, String, String, Iterator, Iterator, NamespaceContext)
  • XMLEventFactory.createStartElement(String, String, String, Iterator, Iterator)
  • XMLEventFactory.createStartElement(String, String, String)
  • XMLEventFactory.createStartElement(QName, Iterator, Iterator)


createStatement

createStatement o7planning.org
  • Connection.createStatement(int, int, int)
  • Connection.createStatement(int, int)
  • Connection.createStatement()


createStrokeBorder

createStrokeBorder o7planning.org
  • BorderFactory.createStrokeBorder(BasicStroke, Paint)
  • BorderFactory.createStrokeBorder(BasicStroke)


createStrokedShape

createStrokedShape o7planning.org
  • BasicStroke.createStrokedShape(Shape)
  • Stroke.createStrokedShape(Shape)


createStruct

createStruct o7planning.org
  • Connection.createStruct(String, Object[])


createSubcontext

createSubcontext o7planning.org
  • Context.createSubcontext(String)
  • Context.createSubcontext(Name)
  • DirContext.createSubcontext(String, Attributes)
  • DirContext.createSubcontext(Name, Attributes)
  • InitialContext.createSubcontext(Name)
  • InitialContext.createSubcontext(String)
  • InitialDirContext.createSubcontext(Name, Attributes)
  • InitialDirContext.createSubcontext(String, Attributes)


createSubsetSampleModel

createSubsetSampleModel o7planning.org
  • BandedSampleModel.createSubsetSampleModel(int[])
  • ComponentSampleModel.createSubsetSampleModel(int[])
  • MultiPixelPackedSampleModel.createSubsetSampleModel(int[])
  • PixelInterleavedSampleModel.createSubsetSampleModel(int[])
  • SampleModel.createSubsetSampleModel(int[])
  • SinglePixelPackedSampleModel.createSubsetSampleModel(int[])


createSymbolicLink

createSymbolicLink o7planning.org
  • FileSystemProvider.createSymbolicLink(Path, Path, FileAttribute<?>...)
  • Files.createSymbolicLink(Path, Path, FileAttribute<?>...)


createSystemMenu

createSystemMenu o7planning.org
  • BasicInternalFrameTitlePane.createSystemMenu()


createSystemMenuBar

createSystemMenuBar o7planning.org
  • BasicInternalFrameTitlePane.createSystemMenuBar()


createTableCell

createTableCell o7planning.org
  • TableView.createTableCell(Element)


createTableRow

createTableRow o7planning.org
  • TableView.createTableRow(Element)


createTempDirectory

createTempDirectory o7planning.org
  • Files.createTempDirectory(String, FileAttribute<?>...)
  • Files.createTempDirectory(Path, String, FileAttribute<?>...)


createTempFile

createTempFile o7planning.org
  • File.createTempFile(String, String)
  • File.createTempFile(String, String, File)
  • Files.createTempFile(String, String, FileAttribute<?>...)
  • Files.createTempFile(Path, String, String, FileAttribute<?>...)


createTextArea

createTextArea o7planning.org
  • Toolkit.createTextArea(TextArea)


createTextField

createTextField o7planning.org
  • Toolkit.createTextField(TextField)


createTextNode

createTextNode o7planning.org
  • Document.createTextNode(String)


createTitledBorder

createTitledBorder o7planning.org
  • BorderFactory.createTitledBorder(Border, String, int, int, Font, Color)
  • BorderFactory.createTitledBorder(Border, String, int, int, Font)
  • BorderFactory.createTitledBorder(Border, String, int, int)
  • BorderFactory.createTitledBorder(Border, String)
  • BorderFactory.createTitledBorder(Border)
  • BorderFactory.createTitledBorder(String)


createToolBarContListener

createToolBarContListener o7planning.org
  • BasicToolBarUI.createToolBarContListener()


createToolBarFocusListener

createToolBarFocusListener o7planning.org
  • BasicToolBarUI.createToolBarFocusListener()


createToolTip

createToolTip o7planning.org
  • JComponent.createToolTip()


createTrack

createTrack o7planning.org
  • Sequence.createTrack()


createTrackListener

createTrackListener o7planning.org
  • BasicScrollBarUI.createTrackListener()
  • BasicSliderUI.createTrackListener(JSlider)
  • SynthSliderUI.createTrackListener(JSlider)


createTranscoderInstance

createTranscoderInstance o7planning.org
  • ImageTranscoderSpi.createTranscoderInstance()


createTransferable

createTransferable o7planning.org
  • TransferHandler.createTransferable(JComponent)


createTransferableProxy

createTransferableProxy o7planning.org
  • DropTargetContext.createTransferableProxy(Transferable, boolean)


createTransformedArea

createTransformedArea o7planning.org
  • Area.createTransformedArea(AffineTransform)


createTransformedShape

createTransformedShape o7planning.org
  • AffineTransform.createTransformedShape(Shape)
  • Path2D.createTransformedShape(AffineTransform)


createTransition

createTransition o7planning.org
  • ZoneOffsetTransitionRule.createTransition(int)


createTranslatedChild

createTranslatedChild o7planning.org
  • Raster.createTranslatedChild(int, int)


createTreeCellEditor

createTreeCellEditor o7planning.org
  • DefaultTreeCellEditor.createTreeCellEditor()


createTreeExpansionListener

createTreeExpansionListener o7planning.org
  • BasicTreeUI.createTreeExpansionListener()


createTreeModel

createTreeModel o7planning.org
  • JTree.createTreeModel(Object)


createTreeModelListener

createTreeModelListener o7planning.org
  • BasicTreeUI.createTreeModelListener()
  • JTree.createTreeModelListener()


createTreeSelectionListener

createTreeSelectionListener o7planning.org
  • BasicTreeUI.createTreeSelectionListener()


createUI

createUI o7planning.org
  • BasicButtonUI.createUI(JComponent)
  • BasicCheckBoxMenuItemUI.createUI(JComponent)
  • BasicCheckBoxUI.createUI(JComponent)
  • BasicColorChooserUI.createUI(JComponent)
  • BasicComboBoxUI.createUI(JComponent)
  • BasicDesktopIconUI.createUI(JComponent)
  • BasicDesktopPaneUI.createUI(JComponent)
  • BasicEditorPaneUI.createUI(JComponent)
  • BasicFileChooserUI.createUI(JComponent)
  • BasicFormattedTextFieldUI.createUI(JComponent)
  • BasicInternalFrameUI.createUI(JComponent)
  • BasicLabelUI.createUI(JComponent)
  • BasicListUI.createUI(JComponent)
  • BasicMenuBarUI.createUI(JComponent)
  • BasicMenuItemUI.createUI(JComponent)
  • BasicMenuUI.createUI(JComponent)
  • BasicOptionPaneUI.createUI(JComponent)
  • BasicPanelUI.createUI(JComponent)
  • BasicPasswordFieldUI.createUI(JComponent)
  • BasicPopupMenuSeparatorUI.createUI(JComponent)
  • BasicPopupMenuUI.createUI(JComponent)
  • BasicProgressBarUI.createUI(JComponent)
  • BasicRadioButtonMenuItemUI.createUI(JComponent)
  • BasicRadioButtonUI.createUI(JComponent)
  • BasicRootPaneUI.createUI(JComponent)
  • BasicScrollBarUI.createUI(JComponent)
  • BasicScrollPaneUI.createUI(JComponent)
  • BasicSeparatorUI.createUI(JComponent)
  • BasicSliderUI.createUI(JComponent)
  • BasicSpinnerUI.createUI(JComponent)
  • BasicSplitPaneUI.createUI(JComponent)
  • BasicTabbedPaneUI.createUI(JComponent)
  • BasicTableHeaderUI.createUI(JComponent)
  • BasicTableUI.createUI(JComponent)
  • BasicTextAreaUI.createUI(JComponent)
  • BasicTextFieldUI.createUI(JComponent)
  • BasicTextPaneUI.createUI(JComponent)
  • BasicToggleButtonUI.createUI(JComponent)
  • BasicToolBarSeparatorUI.createUI(JComponent)
  • BasicToolBarUI.createUI(JComponent)
  • BasicToolTipUI.createUI(JComponent)
  • BasicTreeUI.createUI(JComponent)
  • BasicViewportUI.createUI(JComponent)
  • ComponentUI.createUI(JComponent)
  • MetalButtonUI.createUI(JComponent)
  • MetalCheckBoxUI.createUI(JComponent)
  • MetalComboBoxUI.createUI(JComponent)
  • MetalDesktopIconUI.createUI(JComponent)
  • MetalFileChooserUI.createUI(JComponent)
  • MetalInternalFrameUI.createUI(JComponent)
  • MetalLabelUI.createUI(JComponent)
  • MetalMenuBarUI.createUI(JComponent)
  • MetalPopupMenuSeparatorUI.createUI(JComponent)
  • MetalProgressBarUI.createUI(JComponent)
  • MetalRadioButtonUI.createUI(JComponent)
  • MetalRootPaneUI.createUI(JComponent)
  • MetalScrollBarUI.createUI(JComponent)
  • MetalScrollPaneUI.createUI(JComponent)
  • MetalSeparatorUI.createUI(JComponent)
  • MetalSliderUI.createUI(JComponent)
  • MetalSplitPaneUI.createUI(JComponent)
  • MetalTabbedPaneUI.createUI(JComponent)
  • MetalTextFieldUI.createUI(JComponent)
  • MetalToggleButtonUI.createUI(JComponent)
  • MetalToolBarUI.createUI(JComponent)
  • MetalToolTipUI.createUI(JComponent)
  • MetalTreeUI.createUI(JComponent)
  • MultiButtonUI.createUI(JComponent)
  • MultiColorChooserUI.createUI(JComponent)
  • MultiComboBoxUI.createUI(JComponent)
  • MultiDesktopIconUI.createUI(JComponent)
  • MultiDesktopPaneUI.createUI(JComponent)
  • MultiFileChooserUI.createUI(JComponent)
  • MultiInternalFrameUI.createUI(JComponent)
  • MultiLabelUI.createUI(JComponent)
  • MultiListUI.createUI(JComponent)
  • MultiMenuBarUI.createUI(JComponent)
  • MultiMenuItemUI.createUI(JComponent)
  • MultiOptionPaneUI.createUI(JComponent)
  • MultiPanelUI.createUI(JComponent)
  • MultiPopupMenuUI.createUI(JComponent)
  • MultiProgressBarUI.createUI(JComponent)
  • MultiRootPaneUI.createUI(JComponent)
  • MultiScrollBarUI.createUI(JComponent)
  • MultiScrollPaneUI.createUI(JComponent)
  • MultiSeparatorUI.createUI(JComponent)
  • MultiSliderUI.createUI(JComponent)
  • MultiSpinnerUI.createUI(JComponent)
  • MultiSplitPaneUI.createUI(JComponent)
  • MultiTabbedPaneUI.createUI(JComponent)
  • MultiTableHeaderUI.createUI(JComponent)
  • MultiTableUI.createUI(JComponent)
  • MultiTextUI.createUI(JComponent)
  • MultiToolBarUI.createUI(JComponent)
  • MultiToolTipUI.createUI(JComponent)
  • MultiTreeUI.createUI(JComponent)
  • MultiViewportUI.createUI(JComponent)
  • SynthButtonUI.createUI(JComponent)
  • SynthCheckBoxMenuItemUI.createUI(JComponent)
  • SynthCheckBoxUI.createUI(JComponent)
  • SynthColorChooserUI.createUI(JComponent)
  • SynthComboBoxUI.createUI(JComponent)
  • SynthDesktopIconUI.createUI(JComponent)
  • SynthDesktopPaneUI.createUI(JComponent)
  • SynthEditorPaneUI.createUI(JComponent)
  • SynthFormattedTextFieldUI.createUI(JComponent)
  • SynthInternalFrameUI.createUI(JComponent)
  • SynthLabelUI.createUI(JComponent)
  • SynthListUI.createUI(JComponent)
  • SynthLookAndFeel.createUI(JComponent)
  • SynthMenuBarUI.createUI(JComponent)
  • SynthMenuItemUI.createUI(JComponent)
  • SynthMenuUI.createUI(JComponent)
  • SynthOptionPaneUI.createUI(JComponent)
  • SynthPanelUI.createUI(JComponent)
  • SynthPasswordFieldUI.createUI(JComponent)
  • SynthPopupMenuUI.createUI(JComponent)
  • SynthProgressBarUI.createUI(JComponent)
  • SynthRadioButtonMenuItemUI.createUI(JComponent)
  • SynthRadioButtonUI.createUI(JComponent)
  • SynthRootPaneUI.createUI(JComponent)
  • SynthScrollBarUI.createUI(JComponent)
  • SynthScrollPaneUI.createUI(JComponent)
  • SynthSeparatorUI.createUI(JComponent)
  • SynthSliderUI.createUI(JComponent)
  • SynthSpinnerUI.createUI(JComponent)
  • SynthSplitPaneUI.createUI(JComponent)
  • SynthTabbedPaneUI.createUI(JComponent)
  • SynthTableHeaderUI.createUI(JComponent)
  • SynthTableUI.createUI(JComponent)
  • SynthTextAreaUI.createUI(JComponent)
  • SynthTextFieldUI.createUI(JComponent)
  • SynthTextPaneUI.createUI(JComponent)
  • SynthToggleButtonUI.createUI(JComponent)
  • SynthToolBarUI.createUI(JComponent)
  • SynthToolTipUI.createUI(JComponent)
  • SynthTreeUI.createUI(JComponent)
  • SynthViewportUI.createUI(JComponent)


createUIs

createUIs o7planning.org
  • MultiLookAndFeel.createUIs(ComponentUI, Vector, JComponent)


createUnion

createUnion o7planning.org
  • Rectangle.createUnion(Rectangle2D)
  • Rectangle2D.createUnion(Rectangle2D)
  • Rectangle2D.Double.createUnion(Rectangle2D)
  • Rectangle2D.Float.createUnion(Rectangle2D)


createUnmarshalException

createUnmarshalException o7planning.org
  • AbstractUnmarshallerImpl.createUnmarshalException(SAXException)


createUnmarshaller

createUnmarshaller o7planning.org
  • DomHandler.createUnmarshaller(ValidationEventHandler)
  • JAXBContext.createUnmarshaller()
  • W3CDomHandler.createUnmarshaller(ValidationEventHandler)


createUnresolved

createUnresolved o7planning.org
  • InetSocketAddress.createUnresolved(String, int)


createURLStreamHandler

createURLStreamHandler o7planning.org
  • URLStreamHandlerFactory.createURLStreamHandler(String)


createValidator

createValidator o7planning.org
  • JAXBContext.createValidator()


createValue

createValue o7planning.org
  • UIDefaults.ActiveValue.createValue(UIDefaults)
  • UIDefaults.LazyInputMap.createValue(UIDefaults)
  • UIDefaults.LazyValue.createValue(UIDefaults)
  • UIDefaults.ProxyLazyValue.createValue(UIDefaults)


createValueHandler

createValueHandler o7planning.org
  • Util.createValueHandler()
  • UtilDelegate.createValueHandler()


createVerticalBox

createVerticalBox o7planning.org
  • Box.createVerticalBox()


createVerticalGlue

createVerticalGlue o7planning.org
  • Box.createVerticalGlue()


createVerticalScrollBar

createVerticalScrollBar o7planning.org
  • JScrollPane.createVerticalScrollBar()


createVerticalStrut

createVerticalStrut o7planning.org
  • Box.createVerticalStrut(int)


createView

createView o7planning.org
  • FlowView.FlowStrategy.createView(FlowView, int, int, int)


createViewListener

createViewListener o7planning.org
  • JViewport.createViewListener()


createViewport

createViewport o7planning.org
  • JScrollPane.createViewport()


createViewportChangeListener

createViewportChangeListener o7planning.org
  • BasicScrollPaneUI.createViewportChangeListener()


createVolatileImage

createVolatileImage o7planning.org
  • Component.createVolatileImage(int, int, ImageCapabilities)
  • Component.createVolatileImage(int, int)


createVSBChangeListener

createVSBChangeListener o7planning.org
  • BasicScrollPaneUI.createVSBChangeListener()


createW3CEndpointReference

createW3CEndpointReference o7planning.org
  • Provider.createW3CEndpointReference(String, QName, QName, QName, List<Element>, String, List<Element>, List<Element>, Map<QName, String>)
  • Provider.createW3CEndpointReference(String, QName, QName, List<Element>, String, List<Element>)


createWebRowSet

createWebRowSet o7planning.org
  • RowSetFactory.createWebRowSet()


createWestPane

createWestPane o7planning.org
  • BasicInternalFrameUI.createWestPane(JInternalFrame)


createWindow

createWindow o7planning.org
  • Toolkit.createWindow(Window)


createWinListener

createWinListener o7planning.org
  • JMenu.createWinListener(JPopupMenu)


createWritableChild

createWritableChild o7planning.org
  • WritableRaster.createWritableChild(int, int, int, int, int, int, int[])


createWritableRaster

createWritableRaster o7planning.org
  • Raster.createWritableRaster(SampleModel, DataBuffer, Point)
  • Raster.createWritableRaster(SampleModel, Point)


createWritableTranslatedChild

createWritableTranslatedChild o7planning.org
  • WritableRaster.createWritableTranslatedChild(int, int)


createWriterInstance

createWriterInstance o7planning.org
  • ImageWriterSpi.createWriterInstance(Object)
  • ImageWriterSpi.createWriterInstance()


createXMLEventReader

createXMLEventReader o7planning.org
  • XMLInputFactory.createXMLEventReader(String, InputStream)
  • XMLInputFactory.createXMLEventReader(InputStream, String)
  • XMLInputFactory.createXMLEventReader(InputStream)
  • XMLInputFactory.createXMLEventReader(Source)
  • XMLInputFactory.createXMLEventReader(XMLStreamReader)
  • XMLInputFactory.createXMLEventReader(String, Reader)
  • XMLInputFactory.createXMLEventReader(Reader)


createXMLEventWriter

createXMLEventWriter o7planning.org
  • XMLOutputFactory.createXMLEventWriter(Writer)
  • XMLOutputFactory.createXMLEventWriter(OutputStream, String)
  • XMLOutputFactory.createXMLEventWriter(OutputStream)
  • XMLOutputFactory.createXMLEventWriter(Result)


createXMLReader

createXMLReader o7planning.org
  • XMLReaderFactory.createXMLReader(String)
  • XMLReaderFactory.createXMLReader()


createXMLStreamReader

createXMLStreamReader o7planning.org
  • XMLInputFactory.createXMLStreamReader(String, Reader)
  • XMLInputFactory.createXMLStreamReader(String, InputStream)
  • XMLInputFactory.createXMLStreamReader(InputStream, String)
  • XMLInputFactory.createXMLStreamReader(InputStream)
  • XMLInputFactory.createXMLStreamReader(Source)
  • XMLInputFactory.createXMLStreamReader(Reader)


createXMLStreamWriter

createXMLStreamWriter o7planning.org
  • XMLOutputFactory.createXMLStreamWriter(Result)
  • XMLOutputFactory.createXMLStreamWriter(OutputStream, String)
  • XMLOutputFactory.createXMLStreamWriter(OutputStream)
  • XMLOutputFactory.createXMLStreamWriter(Writer)


createZipEntry

createZipEntry o7planning.org
  • JarInputStream.createZipEntry(String)
  • ZipInputStream.createZipEntry(String)


createZone

createZone o7planning.org
  • ZoneView.createZone(int, int)


creationTime

creationTime o7planning.org
  • BasicFileAttributes.creationTime()


CredentialException

CredentialException o7planning.org
  • CredentialException.CredentialException(String)
  • CredentialException.CredentialException()


CredentialExpiredException

CredentialExpiredException o7planning.org
  • CredentialExpiredException.CredentialExpiredException(String)
  • CredentialExpiredException.CredentialExpiredException()


CredentialNotFoundException

CredentialNotFoundException o7planning.org
  • CredentialNotFoundException.CredentialNotFoundException(String)
  • CredentialNotFoundException.CredentialNotFoundException()


CREDENTIALS

CREDENTIALS o7planning.org
  • JMXConnector.CREDENTIALS
  • Sasl.CREDENTIALS


CREDENTIALS_EXPIRED

CREDENTIALS_EXPIRED o7planning.org
  • GSSException.CREDENTIALS_EXPIRED


CRITICAL

CRITICAL o7planning.org
  • Control.CRITICAL


criticality

criticality o7planning.org
  • BasicControl.criticality


CRL

CRL o7planning.org
  • CRL.CRL(String)


CRLException

CRLException o7planning.org
  • CRLException.CRLException(Throwable)
  • CRLException.CRLException(String, Throwable)
  • CRLException.CRLException(String)
  • CRLException.CRLException()


CropImageFilter

CropImageFilter o7planning.org
  • CropImageFilter.CropImageFilter(int, int, int, int)


CROSS_JOIN

CROSS_JOIN o7planning.org
  • JoinRowSet.CROSS_JOIN


CROSSHAIR_CURSOR

CROSSHAIR_CURSOR o7planning.org
  • Cursor.CROSSHAIR_CURSOR
  • Frame.CROSSHAIR_CURSOR


CS_CIEXYZ

CS_CIEXYZ o7planning.org
  • ColorSpace.CS_CIEXYZ


CS_GRAY

CS_GRAY o7planning.org
  • ColorSpace.CS_GRAY


CS_LINEAR_RGB

CS_LINEAR_RGB o7planning.org
  • ColorSpace.CS_LINEAR_RGB


CS_PYCC

CS_PYCC o7planning.org
  • ColorSpace.CS_PYCC


CS_sRGB

CS_sRGB o7planning.org
  • ColorSpace.CS_sRGB


CSS

CSS o7planning.org
  • CSS.CSS()


CTRL_DOWN_MASK

CTRL_DOWN_MASK o7planning.org
  • InputEvent.CTRL_DOWN_MASK


CTRL_MASK

CTRL_MASK o7planning.org
  • ActionEvent.CTRL_MASK
  • Event.CTRL_MASK
  • InputEvent.CTRL_MASK


ctrlx1

ctrlx1 o7planning.org
  • CubicCurve2D.Double.ctrlx1
  • CubicCurve2D.Float.ctrlx1


ctrlx2

ctrlx2 o7planning.org
  • CubicCurve2D.Double.ctrlx2
  • CubicCurve2D.Float.ctrlx2


ctrlx

ctrlx o7planning.org
  • QuadCurve2D.Double.ctrlx
  • QuadCurve2D.Float.ctrlx


ctrly1

ctrly1 o7planning.org
  • CubicCurve2D.Double.ctrly1
  • CubicCurve2D.Float.ctrly1


ctrly2

ctrly2 o7planning.org
  • CubicCurve2D.Double.ctrly2
  • CubicCurve2D.Float.ctrly2


ctrly

ctrly o7planning.org
  • QuadCurve2D.Double.ctrly
  • QuadCurve2D.Float.ctrly


ctx

ctx o7planning.org
  • Request.ctx(Context)
  • Request.ctx()
  • ServerRequest.ctx()


CubicCurve2D

CubicCurve2D o7planning.org
  • CubicCurve2D.CubicCurve2D()


CUNEIFORM

CUNEIFORM o7planning.org
  • Character.UnicodeBlock.CUNEIFORM


CUNEIFORM_NUMBERS_AND_PUNCTUATION

CUNEIFORM_NUMBERS_AND_PUNCTUATION o7planning.org
  • Character.UnicodeBlock.CUNEIFORM_NUMBERS_AND_PUNCTUATION


CURRENCY

CURRENCY o7planning.org
  • NumberFormat.Field.CURRENCY


CURRENCY_SYMBOL

CURRENCY_SYMBOL o7planning.org
  • Character.CURRENCY_SYMBOL


CURRENCY_SYMBOLS

CURRENCY_SYMBOLS o7planning.org
  • Character.UnicodeBlock.CURRENCY_SYMBOLS


CurrencyNameProvider

CurrencyNameProvider o7planning.org
  • CurrencyNameProvider.CurrencyNameProvider()


current

current o7planning.org
  • Segment.current()


CURRENT

CURRENT o7planning.org
  • DTDConstants.CURRENT


current_component

current_component o7planning.org
  • DynAny.current_component()
  • DynAnyOperations.current_component()
  • _DynAnyStub.current_component()
  • _DynArrayStub.current_component()
  • _DynEnumStub.current_component()
  • _DynFixedStub.current_component()
  • _DynSequenceStub.current_component()
  • _DynStructStub.current_component()
  • _DynUnionStub.current_component()
  • _DynValueStub.current_component()


current_factory

current_factory o7planning.org
  • IORInfoOperations.current_factory(ObjectReferenceFactory)
  • IORInfoOperations.current_factory()


current_member_kind

current_member_kind o7planning.org
  • DynStruct.current_member_kind()
  • DynStructOperations.current_member_kind()
  • DynValue.current_member_kind()
  • DynValueOperations.current_member_kind()
  • _DynStructStub.current_member_kind()
  • _DynValueStub.current_member_kind()


current_member_name

current_member_name o7planning.org
  • DynStruct.current_member_name()
  • DynStructOperations.current_member_name()
  • DynValue.current_member_name()
  • DynValueOperations.current_member_name()
  • _DynStructStub.current_member_name()
  • _DynValueStub.current_member_name()


currentCellRenderer

currentCellRenderer o7planning.org
  • BasicTreeUI.currentCellRenderer


currentClassLoader

currentClassLoader o7planning.org
  • SecurityManager.currentClassLoader()


currentGroupID

currentGroupID o7planning.org
  • ActivationGroup.currentGroupID()


CurrentHelper

CurrentHelper o7planning.org
  • CurrentHelper.CurrentHelper()
  • CurrentHelper.CurrentHelper()
  • CurrentHelper.CurrentHelper()


CurrentHolder

CurrentHolder o7planning.org
  • CurrentHolder.CurrentHolder(Current)
  • CurrentHolder.CurrentHolder()


currentLoadedClass

currentLoadedClass o7planning.org
  • SecurityManager.currentLoadedClass()


currentManager

currentManager o7planning.org
  • RepaintManager.currentManager(JComponent)
  • RepaintManager.currentManager(Component)


currentMouseX

currentMouseX o7planning.org
  • BasicScrollBarUI.TrackListener.currentMouseX
  • BasicSliderUI.TrackListener.currentMouseX


currentMouseY

currentMouseY o7planning.org
  • BasicScrollBarUI.TrackListener.currentMouseY
  • BasicSliderUI.TrackListener.currentMouseY


currentSegment

currentSegment o7planning.org
  • FlatteningPathIterator.currentSegment(double[])
  • FlatteningPathIterator.currentSegment(float[])
  • PathIterator.currentSegment(double[])
  • PathIterator.currentSegment(float[])


currentThread

currentThread o7planning.org
  • Thread.currentThread()


currentTimeMillis

currentTimeMillis o7planning.org
  • System.currentTimeMillis()


currentValuePane

currentValuePane o7planning.org
  • BasicComboBoxUI.currentValuePane


Cursor

Cursor o7planning.org
  • Cursor.Cursor(String)
  • Cursor.Cursor(int)


cursorMoved

cursorMoved o7planning.org
  • RowSetListener.cursorMoved(RowSetEvent)


curveTo

curveTo o7planning.org
  • Path2D.curveTo(double, double, double, double, double, double)
  • Path2D.Double.curveTo(double, double, double, double, double, double)
  • Path2D.Float.curveTo(float, float, float, float, float, float)
  • Path2D.Float.curveTo(double, double, double, double, double, double)


CUSTOM_CURSOR

CUSTOM_CURSOR o7planning.org
  • Cursor.CUSTOM_CURSOR


CUSTOM_DIALOG

CUSTOM_DIALOG o7planning.org
  • JFileChooser.CUSTOM_DIALOG


cut

cut o7planning.org
  • AccessibleEditableText.cut(int, int)
  • JPasswordField.cut()
  • JSpinner.AccessibleJSpinner.cut(int, int)
  • JTextComponent.cut()
  • JTextComponent.AccessibleJTextComponent.cut(int, int)


cutAction

cutAction o7planning.org
  • DefaultEditorKit.cutAction


CutAction

CutAction o7planning.org
  • DefaultEditorKit.CutAction.CutAction()


cxt

cxt o7planning.org
  • CannotProceed.cxt


cyan

cyan o7planning.org
  • Color.cyan


CYAN

CYAN o7planning.org
  • Color.CYAN


CyclicBarrier

CyclicBarrier o7planning.org
  • CyclicBarrier.CyclicBarrier(int)
  • CyclicBarrier.CyclicBarrier(int, Runnable)


CYPRIOT_SYLLABARY

CYPRIOT_SYLLABARY o7planning.org
  • Character.UnicodeBlock.CYPRIOT_SYLLABARY


CYRILLIC

CYRILLIC o7planning.org
  • Character.UnicodeBlock.CYRILLIC


CYRILLIC_EXTENDED_A

CYRILLIC_EXTENDED_A o7planning.org
  • Character.UnicodeBlock.CYRILLIC_EXTENDED_A


CYRILLIC_EXTENDED_B

CYRILLIC_EXTENDED_B o7planning.org
  • Character.UnicodeBlock.CYRILLIC_EXTENDED_B


CYRILLIC_SUPPLEMENTARY

CYRILLIC_SUPPLEMENTARY o7planning.org
  • Character.UnicodeBlock.CYRILLIC_SUPPLEMENTARY


D

D o7planning.org
  • MediaSize.Engineering.D
  • MediaSizeName.D
  • PageAttributes.MediaType.D


damage

damage o7planning.org
  • DefaultCaret.damage(Rectangle)


damageLineRange

damageLineRange o7planning.org
  • PlainView.damageLineRange(int, int, Shape, Component)


damageRange

damageRange o7planning.org
  • BasicTextUI.damageRange(JTextComponent, int, int, Position.Bias, Position.Bias)
  • BasicTextUI.damageRange(JTextComponent, int, int)
  • MultiTextUI.damageRange(JTextComponent, int, int, Position.Bias, Position.Bias)
  • MultiTextUI.damageRange(JTextComponent, int, int)
  • TextUI.damageRange(JTextComponent, int, int, Position.Bias, Position.Bias)
  • TextUI.damageRange(JTextComponent, int, int)


DARK

DARK o7planning.org
  • MetalIconFactory.DARK


DARK_GRAY

DARK_GRAY o7planning.org
  • Color.DARK_GRAY


darker

darker o7planning.org
  • Color.darker()


darkGray

darkGray o7planning.org
  • Color.darkGray


darkShadow

darkShadow o7planning.org
  • BasicBorders.ButtonBorder.darkShadow
  • BasicBorders.FieldBorder.darkShadow
  • BasicTabbedPaneUI.darkShadow


darkShadowColor

darkShadowColor o7planning.org
  • MetalSliderUI.darkShadowColor


DASH_PUNCTUATION

DASH_PUNCTUATION o7planning.org
  • Character.DASH_PUNCTUATION


data

data o7planning.org
  • Element.data
  • Entity.data


DATA

DATA o7planning.org
  • HTML.Attribute.DATA


DATA_CONVERSION

DATA_CONVERSION o7planning.org
  • DATA_CONVERSION.DATA_CONVERSION(String, int, CompletionStatus)
  • DATA_CONVERSION.DATA_CONVERSION(int, CompletionStatus)
  • DATA_CONVERSION.DATA_CONVERSION(String)
  • DATA_CONVERSION.DATA_CONVERSION()


DATA_TRANSFER_COMPLETE

DATA_TRANSFER_COMPLETE o7planning.org
  • PrintJobEvent.DATA_TRANSFER_COMPLETE


DataBindingException

DataBindingException o7planning.org
  • DataBindingException.DataBindingException(Throwable)
  • DataBindingException.DataBindingException(String, Throwable)


DataBuffer

DataBuffer o7planning.org
  • DataBuffer.DataBuffer(int, int, int, int[])
  • DataBuffer.DataBuffer(int, int, int, int)
  • DataBuffer.DataBuffer(int, int, int)
  • DataBuffer.DataBuffer(int, int)


dataBuffer

dataBuffer o7planning.org
  • Raster.dataBuffer


DataBufferByte

DataBufferByte o7planning.org
  • DataBufferByte.DataBufferByte(byte[][], int, int[])
  • DataBufferByte.DataBufferByte(byte[][], int)
  • DataBufferByte.DataBufferByte(byte[], int, int)
  • DataBufferByte.DataBufferByte(byte[], int)
  • DataBufferByte.DataBufferByte(int, int)
  • DataBufferByte.DataBufferByte(int)


DataBufferDouble

DataBufferDouble o7planning.org
  • DataBufferDouble.DataBufferDouble(double[][], int, int[])
  • DataBufferDouble.DataBufferDouble(double[][], int)
  • DataBufferDouble.DataBufferDouble(double[], int, int)
  • DataBufferDouble.DataBufferDouble(double[], int)
  • DataBufferDouble.DataBufferDouble(int, int)
  • DataBufferDouble.DataBufferDouble(int)


DataBufferFloat

DataBufferFloat o7planning.org
  • DataBufferFloat.DataBufferFloat(float[][], int, int[])
  • DataBufferFloat.DataBufferFloat(float[][], int)
  • DataBufferFloat.DataBufferFloat(float[], int, int)
  • DataBufferFloat.DataBufferFloat(float[], int)
  • DataBufferFloat.DataBufferFloat(int, int)
  • DataBufferFloat.DataBufferFloat(int)


DataBufferInt

DataBufferInt o7planning.org
  • DataBufferInt.DataBufferInt(int[][], int, int[])
  • DataBufferInt.DataBufferInt(int[][], int)
  • DataBufferInt.DataBufferInt(int[], int, int)
  • DataBufferInt.DataBufferInt(int[], int)
  • DataBufferInt.DataBufferInt(int, int)
  • DataBufferInt.DataBufferInt(int)


DataBufferShort

DataBufferShort o7planning.org
  • DataBufferShort.DataBufferShort(short[][], int, int[])
  • DataBufferShort.DataBufferShort(short[][], int)
  • DataBufferShort.DataBufferShort(short[], int, int)
  • DataBufferShort.DataBufferShort(short[], int)
  • DataBufferShort.DataBufferShort(int, int)
  • DataBufferShort.DataBufferShort(int)


DataBufferUShort

DataBufferUShort o7planning.org
  • DataBufferUShort.DataBufferUShort(short[][], int, int[])
  • DataBufferUShort.DataBufferUShort(short[][], int)
  • DataBufferUShort.DataBufferUShort(short[], int, int)
  • DataBufferUShort.DataBufferUShort(short[], int)
  • DataBufferUShort.DataBufferUShort(int, int)
  • DataBufferUShort.DataBufferUShort(int)


dataDefinitionCausesTransactionCommit

dataDefinitionCausesTransactionCommit o7planning.org
  • DatabaseMetaData.dataDefinitionCausesTransactionCommit()


dataDefinitionIgnoredInTransactions

dataDefinitionIgnoredInTransactions o7planning.org
  • DatabaseMetaData.dataDefinitionIgnoredInTransactions()


DataFlavor

DataFlavor o7planning.org
  • DataFlavor.DataFlavor(String)
  • DataFlavor.DataFlavor(String, String, ClassLoader)
  • DataFlavor.DataFlavor(String, String)
  • DataFlavor.DataFlavor(Class<?>, String)
  • DataFlavor.DataFlavor()


DataFormatException

DataFormatException o7planning.org
  • DataFormatException.DataFormatException(String)
  • DataFormatException.DataFormatException()


DatagramChannel

DatagramChannel o7planning.org
  • DatagramChannel.DatagramChannel(SelectorProvider)


DatagramPacket

DatagramPacket o7planning.org
  • DatagramPacket.DatagramPacket(byte[], int, SocketAddress)
  • DatagramPacket.DatagramPacket(byte[], int, InetAddress, int)
  • DatagramPacket.DatagramPacket(byte[], int, int, SocketAddress)
  • DatagramPacket.DatagramPacket(byte[], int, int, InetAddress, int)
  • DatagramPacket.DatagramPacket(byte[], int)
  • DatagramPacket.DatagramPacket(byte[], int, int)


DatagramSocket

DatagramSocket o7planning.org
  • DatagramSocket.DatagramSocket(int, InetAddress)
  • DatagramSocket.DatagramSocket(int)
  • DatagramSocket.DatagramSocket(SocketAddress)
  • DatagramSocket.DatagramSocket(DatagramSocketImpl)
  • DatagramSocket.DatagramSocket()


DatagramSocketImpl

DatagramSocketImpl o7planning.org
  • DatagramSocketImpl.DatagramSocketImpl()


DataHandler

DataHandler o7planning.org
  • DataHandler.DataHandler(URL)
  • DataHandler.DataHandler(Object, String)
  • DataHandler.DataHandler(DataSource)


DataInputStream

DataInputStream o7planning.org
  • DataInputStream.DataInputStream(InputStream)


DATALINK

DATALINK o7planning.org
  • Types.DATALINK


dataModel

dataModel o7planning.org
  • JComboBox.dataModel
  • JTable.dataModel


DataOutputStream

DataOutputStream o7planning.org
  • DataOutputStream.DataOutputStream(OutputStream)


DATASOURCE_DB_LOCK

DATASOURCE_DB_LOCK o7planning.org
  • SyncProvider.DATASOURCE_DB_LOCK


DATASOURCE_NO_LOCK

DATASOURCE_NO_LOCK o7planning.org
  • SyncProvider.DATASOURCE_NO_LOCK


DATASOURCE_ROW_LOCK

DATASOURCE_ROW_LOCK o7planning.org
  • SyncProvider.DATASOURCE_ROW_LOCK


DATASOURCE_TABLE_LOCK

DATASOURCE_TABLE_LOCK o7planning.org
  • SyncProvider.DATASOURCE_TABLE_LOCK


DataTruncation

DataTruncation o7planning.org
  • DataTruncation.DataTruncation(int, boolean, boolean, int, int, Throwable)
  • DataTruncation.DataTruncation(int, boolean, boolean, int, int)


dataType

dataType o7planning.org
  • DataBuffer.dataType
  • SampleModel.dataType


DATATYPE_BOOLEAN

DATATYPE_BOOLEAN o7planning.org
  • IIOMetadataFormat.DATATYPE_BOOLEAN


DATATYPE_DOUBLE

DATATYPE_DOUBLE o7planning.org
  • IIOMetadataFormat.DATATYPE_DOUBLE


DATATYPE_FLOAT

DATATYPE_FLOAT o7planning.org
  • IIOMetadataFormat.DATATYPE_FLOAT


DATATYPE_INTEGER

DATATYPE_INTEGER o7planning.org
  • IIOMetadataFormat.DATATYPE_INTEGER


DATATYPE_STRING

DATATYPE_STRING o7planning.org
  • IIOMetadataFormat.DATATYPE_STRING


DatatypeConfigurationException

DatatypeConfigurationException o7planning.org
  • DatatypeConfigurationException.DatatypeConfigurationException(Throwable)
  • DatatypeConfigurationException.DatatypeConfigurationException(String, Throwable)
  • DatatypeConfigurationException.DatatypeConfigurationException(String)
  • DatatypeConfigurationException.DatatypeConfigurationException()


DatatypeFactory

DatatypeFactory o7planning.org
  • DatatypeFactory.DatatypeFactory()


DATATYPEFACTORY_IMPLEMENTATION_CLASS

DATATYPEFACTORY_IMPLEMENTATION_CLASS o7planning.org
  • DatatypeFactory.DATATYPEFACTORY_IMPLEMENTATION_CLASS


DATATYPEFACTORY_PROPERTY

DATATYPEFACTORY_PROPERTY o7planning.org
  • DatatypeFactory.DATATYPEFACTORY_PROPERTY


dataVector

dataVector o7planning.org
  • DefaultTableModel.dataVector


Date

Date o7planning.org
  • Date.Date(String)
  • Date.Date(int, int, int, int, int, int)
  • Date.Date(int, int, int, int, int)
  • Date.Date(int, int, int)
  • Date.Date(long)
  • Date.Date()


DATE

DATE o7planning.org
  • DatatypeConstants.DATE
  • SimpleType.DATE


date

date o7planning.org
  • Chronology.date(TemporalAccessor)
  • Chronology.date(int, int, int)
  • Chronology.date(Era, int, int, int)
  • HijrahChronology.date(TemporalAccessor)
  • HijrahChronology.date(int, int, int)
  • HijrahChronology.date(Era, int, int, int)
  • IsoChronology.date(TemporalAccessor)
  • IsoChronology.date(int, int, int)
  • IsoChronology.date(Era, int, int, int)
  • JapaneseChronology.date(TemporalAccessor)
  • JapaneseChronology.date(int, int, int)
  • JapaneseChronology.date(Era, int, int, int)
  • MinguoChronology.date(TemporalAccessor)
  • MinguoChronology.date(int, int, int)
  • MinguoChronology.date(Era, int, int, int)
  • ThaiBuddhistChronology.date(TemporalAccessor)
  • ThaiBuddhistChronology.date(int, int, int)
  • ThaiBuddhistChronology.date(Era, int, int, int)


DATE_EDITOR

DATE_EDITOR o7planning.org
  • AccessibleRole.DATE_EDITOR


DATE_FIELD

DATE_FIELD o7planning.org
  • DateFormat.DATE_FIELD


DateEditor

DateEditor o7planning.org
  • JSpinner.DateEditor.DateEditor(JSpinner, String)
  • JSpinner.DateEditor.DateEditor(JSpinner)


dateEpochDay

dateEpochDay o7planning.org
  • Chronology.dateEpochDay(long)
  • HijrahChronology.dateEpochDay(long)
  • IsoChronology.dateEpochDay(long)
  • JapaneseChronology.dateEpochDay(long)
  • MinguoChronology.dateEpochDay(long)
  • ThaiBuddhistChronology.dateEpochDay(long)


dateFilter

dateFilter o7planning.org
  • RowFilter.dateFilter(RowFilter.ComparisonType, Date, int...)


DateFormat

DateFormat o7planning.org
  • DateFormat.DateFormat()


DateFormatProvider

DateFormatProvider o7planning.org
  • DateFormatProvider.DateFormatProvider()


DateFormatSymbols

DateFormatSymbols o7planning.org
  • DateFormatSymbols.DateFormatSymbols(Locale)
  • DateFormatSymbols.DateFormatSymbols()


DateFormatSymbolsProvider

DateFormatSymbolsProvider o7planning.org
  • DateFormatSymbolsProvider.DateFormatSymbolsProvider()


DateFormatter

DateFormatter o7planning.org
  • DateFormatter.DateFormatter(DateFormat)
  • DateFormatter.DateFormatter()


dateNow

dateNow o7planning.org
  • Chronology.dateNow(Clock)
  • Chronology.dateNow(ZoneId)
  • Chronology.dateNow()
  • HijrahChronology.dateNow(Clock)
  • HijrahChronology.dateNow(ZoneId)
  • HijrahChronology.dateNow()
  • IsoChronology.dateNow(Clock)
  • IsoChronology.dateNow(ZoneId)
  • IsoChronology.dateNow()
  • JapaneseChronology.dateNow(Clock)
  • JapaneseChronology.dateNow(ZoneId)
  • JapaneseChronology.dateNow()
  • MinguoChronology.dateNow(Clock)
  • MinguoChronology.dateNow(ZoneId)
  • MinguoChronology.dateNow()
  • ThaiBuddhistChronology.dateNow(Clock)
  • ThaiBuddhistChronology.dateNow(ZoneId)
  • ThaiBuddhistChronology.dateNow()


DATETIME

DATETIME o7planning.org
  • DatatypeConstants.DATETIME


DateTimeAtCompleted

DateTimeAtCompleted o7planning.org
  • DateTimeAtCompleted.DateTimeAtCompleted(Date)


DateTimeAtCreation

DateTimeAtCreation o7planning.org
  • DateTimeAtCreation.DateTimeAtCreation(Date)


DateTimeAtProcessing

DateTimeAtProcessing o7planning.org
  • DateTimeAtProcessing.DateTimeAtProcessing(Date)


DateTimeException

DateTimeException o7planning.org
  • DateTimeException.DateTimeException(String, Throwable)
  • DateTimeException.DateTimeException(String)


DateTimeFormatterBuilder

DateTimeFormatterBuilder o7planning.org
  • DateTimeFormatterBuilder.DateTimeFormatterBuilder()


DateTimeParseException

DateTimeParseException o7planning.org
  • DateTimeParseException.DateTimeParseException(String, CharSequence, int, Throwable)
  • DateTimeParseException.DateTimeParseException(String, CharSequence, int)


DateTimeSyntax

DateTimeSyntax o7planning.org
  • DateTimeSyntax.DateTimeSyntax(Date)


dateYearDay

dateYearDay o7planning.org
  • Chronology.dateYearDay(int, int)
  • Chronology.dateYearDay(Era, int, int)
  • HijrahChronology.dateYearDay(int, int)
  • HijrahChronology.dateYearDay(Era, int, int)
  • IsoChronology.dateYearDay(int, int)
  • IsoChronology.dateYearDay(Era, int, int)
  • JapaneseChronology.dateYearDay(int, int)
  • JapaneseChronology.dateYearDay(Era, int, int)
  • MinguoChronology.dateYearDay(int, int)
  • MinguoChronology.dateYearDay(Era, int, int)
  • ThaiBuddhistChronology.dateYearDay(int, int)
  • ThaiBuddhistChronology.dateYearDay(Era, int, int)


DAY_OF_MONTH

DAY_OF_MONTH o7planning.org
  • Calendar.DAY_OF_MONTH
  • DateFormat.Field.DAY_OF_MONTH


DAY_OF_QUARTER

DAY_OF_QUARTER o7planning.org
  • IsoFields.DAY_OF_QUARTER


DAY_OF_WEEK

DAY_OF_WEEK o7planning.org
  • Calendar.DAY_OF_WEEK
  • DateFormat.Field.DAY_OF_WEEK


DAY_OF_WEEK_FIELD

DAY_OF_WEEK_FIELD o7planning.org
  • DateFormat.DAY_OF_WEEK_FIELD


DAY_OF_WEEK_IN_MONTH

DAY_OF_WEEK_IN_MONTH o7planning.org
  • Calendar.DAY_OF_WEEK_IN_MONTH
  • DateFormat.Field.DAY_OF_WEEK_IN_MONTH


DAY_OF_WEEK_IN_MONTH_FIELD

DAY_OF_WEEK_IN_MONTH_FIELD o7planning.org
  • DateFormat.DAY_OF_WEEK_IN_MONTH_FIELD


DAY_OF_YEAR

DAY_OF_YEAR o7planning.org
  • Calendar.DAY_OF_YEAR
  • DateFormat.Field.DAY_OF_YEAR


DAY_OF_YEAR_FIELD

DAY_OF_YEAR_FIELD o7planning.org
  • DateFormat.DAY_OF_YEAR_FIELD


dayOfWeek

dayOfWeek o7planning.org
  • WeekFields.dayOfWeek()


dayOfWeekInMonth

dayOfWeekInMonth o7planning.org
  • TemporalAdjusters.dayOfWeekInMonth(int, DayOfWeek)


DAYS

DAYS o7planning.org
  • DatatypeConstants.DAYS


dbgTag

dbgTag o7planning.org
  • Monitor.dbgTag


DD

DD o7planning.org
  • HTML.Tag.DD


deactivate

deactivate o7planning.org
  • InputMethod.deactivate(boolean)
  • POAManagerOperations.deactivate(boolean, boolean)
  • Tie.deactivate()


deactivate_object

deactivate_object o7planning.org
  • POAOperations.deactivate_object(byte[])


deactivateFrame

deactivateFrame o7planning.org
  • BasicInternalFrameUI.deactivateFrame(JInternalFrame)
  • DefaultDesktopManager.deactivateFrame(JInternalFrame)
  • DesktopManager.deactivateFrame(JInternalFrame)


DebugGraphics

DebugGraphics o7planning.org
  • DebugGraphics.DebugGraphics(Graphics)
  • DebugGraphics.DebugGraphics(Graphics, JComponent)
  • DebugGraphics.DebugGraphics()


decapitalize

decapitalize o7planning.org
  • Introspector.decapitalize(String)


DECEMBER

DECEMBER o7planning.org
  • Calendar.DECEMBER
  • DatatypeConstants.DECEMBER


DECIMAL32

DECIMAL32 o7planning.org
  • MathContext.DECIMAL32


DECIMAL64

DECIMAL64 o7planning.org
  • MathContext.DECIMAL64


DECIMAL128

DECIMAL128 o7planning.org
  • MathContext.DECIMAL128


DECIMAL

DECIMAL o7planning.org
  • Types.DECIMAL


DECIMAL_DIGIT_NUMBER

DECIMAL_DIGIT_NUMBER o7planning.org
  • Character.DECIMAL_DIGIT_NUMBER


DECIMAL_SEPARATOR

DECIMAL_SEPARATOR o7planning.org
  • NumberFormat.Field.DECIMAL_SEPARATOR


DecimalFormat

DecimalFormat o7planning.org
  • DecimalFormat.DecimalFormat(String, DecimalFormatSymbols)
  • DecimalFormat.DecimalFormat(String)
  • DecimalFormat.DecimalFormat()


DecimalFormatSymbols

DecimalFormatSymbols o7planning.org
  • DecimalFormatSymbols.DecimalFormatSymbols(Locale)
  • DecimalFormatSymbols.DecimalFormatSymbols()


DecimalFormatSymbolsProvider

DecimalFormatSymbolsProvider o7planning.org
  • DecimalFormatSymbolsProvider.DecimalFormatSymbolsProvider()


DECLARE

DECLARE o7planning.org
  • HTML.Attribute.DECLARE


DECLARED

DECLARED o7planning.org
  • Member.DECLARED


declaredType

declaredType o7planning.org
  • JAXBElement.declaredType


declarePrefix

declarePrefix o7planning.org
  • NamespaceSupport.declarePrefix(String, String)


decode

decode o7planning.org
  • Base64.Decoder.decode(ByteBuffer)
  • Base64.Decoder.decode(byte[], byte[])
  • Base64.Decoder.decode(String)
  • Base64.Decoder.decode(byte[])
  • Byte.decode(String)
  • Certificate.decode(InputStream)
  • Charset.decode(ByteBuffer)
  • CharsetDecoder.decode(ByteBuffer)
  • CharsetDecoder.decode(ByteBuffer, CharBuffer, boolean)
  • CodecOperations.decode(byte[])
  • Color.decode(String)
  • Font.decode(String)
  • Integer.decode(String)
  • Long.decode(String)
  • Short.decode(String)
  • URLDecoder.decode(String, String)
  • URLDecoder.decode(String)


decode_value

decode_value o7planning.org
  • CodecOperations.decode_value(byte[], TypeCode)


decodeAnchorX

decodeAnchorX o7planning.org
  • AbstractRegionPainter.decodeAnchorX(float, float)


decodeAnchorY

decodeAnchorY o7planning.org
  • AbstractRegionPainter.decodeAnchorY(float, float)


decodeColor

decodeColor o7planning.org
  • AbstractRegionPainter.decodeColor(Color, Color, float)
  • AbstractRegionPainter.decodeColor(String, float, float, float, int)


decodeDataFlavor

decodeDataFlavor o7planning.org
  • SystemFlavorMap.decodeDataFlavor(String)


decodeGradient

decodeGradient o7planning.org
  • AbstractRegionPainter.decodeGradient(float, float, float, float, float[], Color[])


decodeJavaMIMEType

decodeJavaMIMEType o7planning.org
  • SystemFlavorMap.decodeJavaMIMEType(String)


decodeLineStyle

decodeLineStyle o7planning.org
  • MetalTreeUI.decodeLineStyle(Object)


decodeLoop

decodeLoop o7planning.org
  • CharsetDecoder.decodeLoop(ByteBuffer, CharBuffer)


decodeRadialGradient

decodeRadialGradient o7planning.org
  • AbstractRegionPainter.decodeRadialGradient(float, float, float, float[], Color[])


decodeX

decodeX o7planning.org
  • AbstractRegionPainter.decodeX(float)


decodeY

decodeY o7planning.org
  • AbstractRegionPainter.decodeY(float)


decorateTask

decorateTask o7planning.org
  • ScheduledThreadPoolExecutor.decorateTask(Callable<V>, RunnableScheduledFuture<V>)
  • ScheduledThreadPoolExecutor.decorateTask(Runnable, RunnableScheduledFuture<V>)


decrButton

decrButton o7planning.org
  • BasicScrollBarUI.decrButton


DECREASE_HIGHLIGHT

DECREASE_HIGHLIGHT o7planning.org
  • BasicScrollBarUI.DECREASE_HIGHLIGHT


decreaseButton

decreaseButton o7planning.org
  • MetalScrollBarUI.decreaseButton


decrement

decrement o7planning.org
  • LongAdder.decrement()


DECREMENT

DECREMENT o7planning.org
  • AccessibleAction.DECREMENT


decrementAndGet

decrementAndGet o7planning.org
  • AtomicInteger.decrementAndGet()
  • AtomicIntegerArray.decrementAndGet(int)
  • AtomicIntegerFieldUpdater.decrementAndGet(T)
  • AtomicLong.decrementAndGet()
  • AtomicLongArray.decrementAndGet(int)
  • AtomicLongFieldUpdater.decrementAndGet(T)


decrementExact

decrementExact o7planning.org
  • Math.decrementExact(long)
  • Math.decrementExact(int)


decrementPendingCountUnlessZero

decrementPendingCountUnlessZero o7planning.org
  • CountedCompleter.decrementPendingCountUnlessZero()


decrGap

decrGap o7planning.org
  • BasicScrollBarUI.decrGap


decrIndent

decrIndent o7planning.org
  • AbstractWriter.decrIndent()


DECRYPT

DECRYPT o7planning.org
  • KeySelector.Purpose.DECRYPT


DECRYPT_MODE

DECRYPT_MODE o7planning.org
  • Cipher.DECRYPT_MODE


deepEquals

deepEquals o7planning.org
  • Arrays.deepEquals(Object[], Object[])
  • Objects.deepEquals(Object, Object)


deepHashCode

deepHashCode o7planning.org
  • Arrays.deepHashCode(Object[])


deepToString

deepToString o7planning.org
  • Arrays.deepToString(Object[])


def

def o7planning.org
  • DeflaterInputStream.def
  • DeflaterOutputStream.def


def_kind

def_kind o7planning.org
  • IRObjectOperations.def_kind()
  • _IDLTypeStub.def_kind()


defAttributeList

defAttributeList o7planning.org
  • DTD.defAttributeList(String, int, int, String, String, AttributeList)


DEFAULT

DEFAULT o7planning.org
  • Action.DEFAULT
  • DTDConstants.DEFAULT
  • DateFormat.DEFAULT
  • DragSourceContext.DEFAULT
  • ExcC14NParameterSpec.DEFAULT
  • OAEPParameterSpec.DEFAULT
  • PSSParameterSpec.DEFAULT
  • PSource.PSpecified.DEFAULT
  • SynthConstants.DEFAULT
  • XmlElement.DEFAULT.DEFAULT()
  • XmlElementRef.DEFAULT.DEFAULT()
  • XmlJavaTypeAdapter.DEFAULT.DEFAULT()
  • XmlSchemaType.DEFAULT.DEFAULT()
  • XmlType.DEFAULT.DEFAULT()


DEFAULT_CARET_POLICY

DEFAULT_CARET_POLICY o7planning.org
  • TextLayout.DEFAULT_CARET_POLICY


DEFAULT_CLASS_LOADER

DEFAULT_CLASS_LOADER o7planning.org
  • JMXConnectorFactory.DEFAULT_CLASS_LOADER
  • JMXConnectorServerFactory.DEFAULT_CLASS_LOADER


DEFAULT_CLASS_LOADER_NAME

DEFAULT_CLASS_LOADER_NAME o7planning.org
  • JMXConnectorServerFactory.DEFAULT_CLASS_LOADER_NAME


DEFAULT_COMPRESSION

DEFAULT_COMPRESSION o7planning.org
  • Deflater.DEFAULT_COMPRESSION


DEFAULT_CSS

DEFAULT_CSS o7planning.org
  • HTMLEditorKit.DEFAULT_CSS


DEFAULT_CURSOR

DEFAULT_CURSOR o7planning.org
  • Cursor.DEFAULT_CURSOR
  • Frame.DEFAULT_CURSOR


default_index

default_index o7planning.org
  • TypeCode.default_index()


DEFAULT_JUSTIFICATION

DEFAULT_JUSTIFICATION o7planning.org
  • TitledBorder.DEFAULT_JUSTIFICATION


DEFAULT_KEYMAP

DEFAULT_KEYMAP o7planning.org
  • JTextComponent.DEFAULT_KEYMAP


DEFAULT_LAYER

DEFAULT_LAYER o7planning.org
  • JLayeredPane.DEFAULT_LAYER


DEFAULT_LIFETIME

DEFAULT_LIFETIME o7planning.org
  • GSSContext.DEFAULT_LIFETIME
  • GSSCredential.DEFAULT_LIFETIME


DEFAULT_MODALITY_TYPE

DEFAULT_MODALITY_TYPE o7planning.org
  • Dialog.DEFAULT_MODALITY_TYPE


DEFAULT_NS_PREFIX

DEFAULT_NS_PREFIX o7planning.org
  • XMLConstants.DEFAULT_NS_PREFIX


DEFAULT_OBJECT_MODEL_URI

DEFAULT_OBJECT_MODEL_URI o7planning.org
  • XPathFactory.DEFAULT_OBJECT_MODEL_URI


DEFAULT_OPTION

DEFAULT_OPTION o7planning.org
  • JOptionPane.DEFAULT_OPTION


default_POA

default_POA o7planning.org
  • Delegate.default_POA(Servant)


DEFAULT_POSITION

DEFAULT_POSITION o7planning.org
  • TitledBorder.DEFAULT_POSITION


DEFAULT_PROPERTY_NAME

DEFAULT_PROPERTY_NAME o7planning.org
  • XPathFactory.DEFAULT_PROPERTY_NAME


DEFAULT_SIZE

DEFAULT_SIZE o7planning.org
  • GroupLayout.DEFAULT_SIZE


DEFAULT_SOAP_PROTOCOL

DEFAULT_SOAP_PROTOCOL o7planning.org
  • SOAPConstants.DEFAULT_SOAP_PROTOCOL


DEFAULT_STRATEGY

DEFAULT_STRATEGY o7planning.org
  • Deflater.DEFAULT_STRATEGY


DEFAULT_STYLE

DEFAULT_STYLE o7planning.org
  • StyleContext.DEFAULT_STYLE


DEFAULT_VALUE

DEFAULT_VALUE o7planning.org
  • ElementScanner6.DEFAULT_VALUE
  • SimpleAnnotationValueVisitor6.DEFAULT_VALUE
  • SimpleElementVisitor6.DEFAULT_VALUE
  • SimpleTypeVisitor6.DEFAULT_VALUE


DEFAULT_VALUE_FIELD

DEFAULT_VALUE_FIELD o7planning.org
  • JMX.DEFAULT_VALUE_FIELD


defaultAction

defaultAction o7planning.org
  • SimpleAnnotationValueVisitor6.defaultAction(Object, P)
  • SimpleElementVisitor6.defaultAction(Element, P)
  • SimpleTypeVisitor6.defaultAction(TypeMirror, P)


DefaultBoundedRangeModel

DefaultBoundedRangeModel o7planning.org
  • DefaultBoundedRangeModel.DefaultBoundedRangeModel(int, int, int, int)
  • DefaultBoundedRangeModel.DefaultBoundedRangeModel()


defaultButton

defaultButton o7planning.org
  • JRootPane.defaultButton


DefaultButtonModel

DefaultButtonModel o7planning.org
  • DefaultButtonModel.DefaultButtonModel()


DefaultCaret

DefaultCaret o7planning.org
  • DefaultCaret.DefaultCaret()


DefaultCellEditor

DefaultCellEditor o7planning.org
  • DefaultCellEditor.DefaultCellEditor(JComboBox)
  • DefaultCellEditor.DefaultCellEditor(JCheckBox)
  • DefaultCellEditor.DefaultCellEditor(JTextField)


defaultCharset

defaultCharset o7planning.org
  • Charset.defaultCharset()


defaultChoosers

defaultChoosers o7planning.org
  • BasicColorChooserUI.defaultChoosers


DefaultColorSelectionModel

DefaultColorSelectionModel o7planning.org
  • DefaultColorSelectionModel.DefaultColorSelectionModel(Color)
  • DefaultColorSelectionModel.DefaultColorSelectionModel()


DefaultComboBoxModel

DefaultComboBoxModel o7planning.org
  • DefaultComboBoxModel.DefaultComboBoxModel(Vector<E>)
  • DefaultComboBoxModel.DefaultComboBoxModel(E[])
  • DefaultComboBoxModel.DefaultComboBoxModel()


defaultConstraints

defaultConstraints o7planning.org
  • GridBagLayout.defaultConstraints


defaultController

defaultController o7planning.org
  • IIOMetadata.defaultController
  • IIOParam.defaultController


DefaultCopyDrop

DefaultCopyDrop o7planning.org
  • DragSource.DefaultCopyDrop


DefaultCopyNoDrop

DefaultCopyNoDrop o7planning.org
  • DragSource.DefaultCopyNoDrop


DefaultDesktopManager

DefaultDesktopManager o7planning.org
  • DefaultDesktopManager.DefaultDesktopManager()


DefaultDocumentEvent

DefaultDocumentEvent o7planning.org
  • AbstractDocument.DefaultDocumentEvent.DefaultDocumentEvent(int, int, DocumentEvent.EventType)


defaulted

defaulted o7planning.org
  • ObjectInputStream.GetField.defaulted(String)


DefaultEditor

DefaultEditor o7planning.org
  • JSpinner.DefaultEditor.DefaultEditor(JSpinner)


DefaultEditorKit

DefaultEditorKit o7planning.org
  • DefaultEditorKit.DefaultEditorKit()


defaultEditorsByColumnClass

defaultEditorsByColumnClass o7planning.org
  • JTable.defaultEditorsByColumnClass


DefaultFocusManager

DefaultFocusManager o7planning.org
  • DefaultFocusManager.DefaultFocusManager()


DefaultFocusTraversalPolicy

DefaultFocusTraversalPolicy o7planning.org
  • DefaultFocusTraversalPolicy.DefaultFocusTraversalPolicy()


defaultForkJoinWorkerThreadFactory

defaultForkJoinWorkerThreadFactory o7planning.org
  • ForkJoinPool.defaultForkJoinWorkerThreadFactory


DefaultFormatter

DefaultFormatter o7planning.org
  • DefaultFormatter.DefaultFormatter()


DefaultFormatterFactory

DefaultFormatterFactory o7planning.org
  • DefaultFormatterFactory.DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter)
  • DefaultFormatterFactory.DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter)
  • DefaultFormatterFactory.DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter)
  • DefaultFormatterFactory.DefaultFormatterFactory(JFormattedTextField.AbstractFormatter)
  • DefaultFormatterFactory.DefaultFormatterFactory()


DefaultHandler2

DefaultHandler2 o7planning.org
  • DefaultHandler2.DefaultHandler2()


DefaultHandler

DefaultHandler o7planning.org
  • DefaultHandler.DefaultHandler()


DefaultHighlighter

DefaultHighlighter o7planning.org
  • DefaultHighlighter.DefaultHighlighter()


DefaultHighlightPainter

DefaultHighlightPainter o7planning.org
  • DefaultHighlighter.DefaultHighlightPainter.DefaultHighlightPainter(Color)


defaultInitCtx

defaultInitCtx o7planning.org
  • InitialContext.defaultInitCtx


DefaultKeyboardFocusManager

DefaultKeyboardFocusManager o7planning.org
  • DefaultKeyboardFocusManager.DefaultKeyboardFocusManager()


defaultKeyTypedAction

defaultKeyTypedAction o7planning.org
  • DefaultEditorKit.defaultKeyTypedAction


DefaultKeyTypedAction

DefaultKeyTypedAction o7planning.org
  • DefaultEditorKit.DefaultKeyTypedAction.DefaultKeyTypedAction()


DefaultLinkDrop

DefaultLinkDrop o7planning.org
  • DragSource.DefaultLinkDrop


DefaultLinkNoDrop

DefaultLinkNoDrop o7planning.org
  • DragSource.DefaultLinkNoDrop


DefaultListCellRenderer

DefaultListCellRenderer o7planning.org
  • DefaultListCellRenderer.DefaultListCellRenderer()


DefaultListModel

DefaultListModel o7planning.org
  • DefaultListModel.DefaultListModel()


DefaultListSelectionModel

DefaultListSelectionModel o7planning.org
  • DefaultListSelectionModel.DefaultListSelectionModel()


DefaultLoaderRepository

DefaultLoaderRepository o7planning.org
  • DefaultLoaderRepository.DefaultLoaderRepository()
  • DefaultLoaderRepository.DefaultLoaderRepository()


defaultManager

defaultManager o7planning.org
  • MenuSelectionManager.defaultManager()


DefaultMenuLayout

DefaultMenuLayout o7planning.org
  • DefaultMenuLayout.DefaultMenuLayout(Container, int)


DefaultMetalTheme

DefaultMetalTheme o7planning.org
  • DefaultMetalTheme.DefaultMetalTheme()


DefaultMoveDrop

DefaultMoveDrop o7planning.org
  • DragSource.DefaultMoveDrop


DefaultMoveNoDrop

DefaultMoveNoDrop o7planning.org
  • DragSource.DefaultMoveNoDrop


DefaultMutableTreeNode

DefaultMutableTreeNode o7planning.org
  • DefaultMutableTreeNode.DefaultMutableTreeNode(Object, boolean)
  • DefaultMutableTreeNode.DefaultMutableTreeNode(Object)
  • DefaultMutableTreeNode.DefaultMutableTreeNode()


defaultPage

defaultPage o7planning.org
  • PrinterJob.defaultPage()
  • PrinterJob.defaultPage(PageFormat)


DefaultPainter

DefaultPainter o7planning.org
  • DefaultHighlighter.DefaultPainter


DefaultPersistenceDelegate

DefaultPersistenceDelegate o7planning.org
  • DefaultPersistenceDelegate.DefaultPersistenceDelegate(String[])
  • DefaultPersistenceDelegate.DefaultPersistenceDelegate()


defaultPressAction

defaultPressAction o7planning.org
  • JRootPane.defaultPressAction


defaultReadObject

defaultReadObject o7planning.org
  • ObjectInputStream.defaultReadObject()


defaultReleaseAction

defaultReleaseAction o7planning.org
  • JRootPane.defaultReleaseAction


defaultRenderersByColumnClass

defaultRenderersByColumnClass o7planning.org
  • JTable.defaultRenderersByColumnClass


DefaultRowSorter

DefaultRowSorter o7planning.org
  • DefaultRowSorter.DefaultRowSorter()


defaults

defaults o7planning.org
  • Properties.defaults


DefaultSingleSelectionModel

DefaultSingleSelectionModel o7planning.org
  • DefaultSingleSelectionModel.DefaultSingleSelectionModel()


DefaultStyledDocument

DefaultStyledDocument o7planning.org
  • DefaultStyledDocument.DefaultStyledDocument()
  • DefaultStyledDocument.DefaultStyledDocument(StyleContext)
  • DefaultStyledDocument.DefaultStyledDocument(AbstractDocument.Content, StyleContext)


DefaultTableCellRenderer

DefaultTableCellRenderer o7planning.org
  • DefaultTableCellRenderer.DefaultTableCellRenderer()


DefaultTableColumnModel

DefaultTableColumnModel o7planning.org
  • DefaultTableColumnModel.DefaultTableColumnModel()


DefaultTableModel

DefaultTableModel o7planning.org
  • DefaultTableModel.DefaultTableModel(Object[][], Object[])
  • DefaultTableModel.DefaultTableModel(Vector, Vector)
  • DefaultTableModel.DefaultTableModel(Object[], int)
  • DefaultTableModel.DefaultTableModel(Vector, int)
  • DefaultTableModel.DefaultTableModel(int, int)
  • DefaultTableModel.DefaultTableModel()


DefaultTextField

DefaultTextField o7planning.org
  • DefaultTreeCellEditor.DefaultTextField.DefaultTextField(Border)


defaultTextIconGap

defaultTextIconGap o7planning.org
  • BasicButtonUI.defaultTextIconGap
  • BasicMenuItemUI.defaultTextIconGap


defaultTextShiftOffset

defaultTextShiftOffset o7planning.org
  • BasicButtonUI.defaultTextShiftOffset


DefaultTextUI

DefaultTextUI o7planning.org
  • DefaultTextUI.DefaultTextUI()


defaultThreadFactory

defaultThreadFactory o7planning.org
  • Executors.defaultThreadFactory()


DefaultTreeCellEditor

DefaultTreeCellEditor o7planning.org
  • DefaultTreeCellEditor.DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer, TreeCellEditor)
  • DefaultTreeCellEditor.DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer)


DefaultTreeCellRenderer

DefaultTreeCellRenderer o7planning.org
  • DefaultTreeCellRenderer.DefaultTreeCellRenderer()


DefaultTreeModel

DefaultTreeModel o7planning.org
  • DefaultTreeModel.DefaultTreeModel(TreeNode, boolean)
  • DefaultTreeModel.DefaultTreeModel(TreeNode)


DefaultTreeSelectionModel

DefaultTreeSelectionModel o7planning.org
  • DefaultTreeSelectionModel.DefaultTreeSelectionModel()


DefaultValidationEventHandler

DefaultValidationEventHandler o7planning.org
  • DefaultValidationEventHandler.DefaultValidationEventHandler()


defaultWriteObject

defaultWriteObject o7planning.org
  • ObjectOutputStream.defaultWriteObject()


defContentModel

defContentModel o7planning.org
  • DTD.defContentModel(int, Object, ContentModel)


DEFECTIVE_CREDENTIAL

DEFECTIVE_CREDENTIAL o7planning.org
  • GSSException.DEFECTIVE_CREDENTIAL


DEFECTIVE_TOKEN

DEFECTIVE_TOKEN o7planning.org
  • GSSException.DEFECTIVE_TOKEN


defElement

defElement o7planning.org
  • DTD.defElement(String, int, boolean, boolean, ContentModel, String[], String[], AttributeList)


defEntity

defEntity o7planning.org
  • DTD.defEntity(String, int, String)
  • DTD.defEntity(String, int, int)


defineAttributes

defineAttributes o7planning.org
  • DTD.defineAttributes(String, AttributeList)


defineClass

defineClass o7planning.org
  • ClassLoader.defineClass(String, ByteBuffer, ProtectionDomain)
  • ClassLoader.defineClass(String, byte[], int, int, ProtectionDomain)
  • ClassLoader.defineClass(String, byte[], int, int)
  • ClassLoader.defineClass(byte[], int, int)
  • SecureClassLoader.defineClass(String, ByteBuffer, CodeSource)
  • SecureClassLoader.defineClass(String, byte[], int, int, CodeSource)


defined_in

defined_in o7planning.org
  • ValueMember.defined_in


defineElement

defineElement o7planning.org
  • DTD.defineElement(String, int, boolean, boolean, ContentModel, BitSet, BitSet, AttributeList)


defineEntity

defineEntity o7planning.org
  • DTD.defineEntity(String, int, char[])


definePackage

definePackage o7planning.org
  • ClassLoader.definePackage(String, String, String, String, String, String, String, URL)
  • URLClassLoader.definePackage(String, Manifest, URL)


DefinitionKind

DefinitionKind o7planning.org
  • DefinitionKind.DefinitionKind(int)


DefinitionKindHelper

DefinitionKindHelper o7planning.org
  • DefinitionKindHelper.DefinitionKindHelper()


deflate

deflate o7planning.org
  • Deflater.deflate(byte[], int, int, int)
  • Deflater.deflate(byte[])
  • Deflater.deflate(byte[], int, int)
  • DeflaterOutputStream.deflate()


DEFLATE

DEFLATE o7planning.org
  • Compression.DEFLATE


DEFLATE_HINT

DEFLATE_HINT o7planning.org
  • Pack200.Packer.DEFLATE_HINT
  • Pack200.Unpacker.DEFLATE_HINT


DEFLATED

DEFLATED o7planning.org
  • Deflater.DEFLATED
  • ZipEntry.DEFLATED
  • ZipOutputStream.DEFLATED


Deflater

Deflater o7planning.org
  • Deflater.Deflater()
  • Deflater.Deflater(int)
  • Deflater.Deflater(int, boolean)


DeflaterInputStream

DeflaterInputStream o7planning.org
  • DeflaterInputStream.DeflaterInputStream(InputStream, Deflater, int)
  • DeflaterInputStream.DeflaterInputStream(InputStream, Deflater)
  • DeflaterInputStream.DeflaterInputStream(InputStream)


DeflaterOutputStream

DeflaterOutputStream o7planning.org
  • DeflaterOutputStream.DeflaterOutputStream(OutputStream)
  • DeflaterOutputStream.DeflaterOutputStream(OutputStream, boolean)
  • DeflaterOutputStream.DeflaterOutputStream(OutputStream, Deflater)
  • DeflaterOutputStream.DeflaterOutputStream(OutputStream, Deflater, boolean)
  • DeflaterOutputStream.DeflaterOutputStream(OutputStream, Deflater, int)
  • DeflaterOutputStream.DeflaterOutputStream(OutputStream, Deflater, int, boolean)


deiconifyFrame

deiconifyFrame o7planning.org
  • BasicInternalFrameUI.deiconifyFrame(JInternalFrame)
  • DefaultDesktopManager.deiconifyFrame(JInternalFrame)
  • DesktopManager.deiconifyFrame(JInternalFrame)


deiconize

deiconize o7planning.org
  • BasicDesktopIconUI.deiconize()


deinstall

deinstall o7planning.org
  • Caret.deinstall(JTextComponent)
  • DefaultCaret.deinstall(JTextComponent)
  • DefaultHighlighter.deinstall(JTextComponent)
  • EditorKit.deinstall(JEditorPane)
  • HTMLEditorKit.deinstall(JEditorPane)
  • Highlighter.deinstall(JTextComponent)
  • StyledEditorKit.deinstall(JEditorPane)


deinstallMouseHandlers

deinstallMouseHandlers o7planning.org
  • BasicInternalFrameUI.deinstallMouseHandlers(JComponent)


delay

delay o7planning.org
  • Robot.delay(int)


DelayQueue

DelayQueue o7planning.org
  • DelayQueue.DelayQueue(Collection<? extends E>)
  • DelayQueue.DelayQueue()


delegate

delegate o7planning.org
  • DefaultCellEditor.delegate


Delegate

Delegate o7planning.org
  • Delegate.Delegate()
  • Delegate.Delegate()


DELEGATE_NAME

DELEGATE_NAME o7planning.org
  • MBeanServerDelegate.DELEGATE_NAME


delegateFocus

delegateFocus o7planning.org
  • BasicComboPopup.delegateFocus(MouseEvent)
  • MetalComboBoxUI.MetalComboPopup.delegateFocus(MouseEvent)


DelegationPermission

DelegationPermission o7planning.org
  • DelegationPermission.DelegationPermission(String, String)
  • DelegationPermission.DelegationPermission(String)


DELETE

DELETE o7planning.org
  • AccessibleTableModelChange.DELETE
  • TableModelEvent.DELETE


delete

delete o7planning.org
  • FileObject.delete()
  • ForwardingFileObject.delete()
  • JSpinner.AccessibleJSpinner.delete(int, int)
  • JTextComponent.AccessibleJTextComponent.delete(int, int)
  • SimpleJavaFileObject.delete()


DELETE_ROW_CONFLICT

DELETE_ROW_CONFLICT o7planning.org
  • SyncResolver.DELETE_ROW_CONFLICT


delete_values

delete_values o7planning.org
  • Context.delete_values(String)


deleteChar

deleteChar o7planning.org
  • LineBreakMeasurer.deleteChar(AttributedCharacterIterator, int)
  • TextMeasurer.deleteChar(AttributedCharacterIterator, int)


deleteCharAt

deleteCharAt o7planning.org
  • StringBuffer.deleteCharAt(int)
  • StringBuilder.deleteCharAt(int)


deleteData

deleteData o7planning.org
  • CharacterData.deleteData(int, int)


deleteDirectory

deleteDirectory o7planning.org
  • SecureDirectoryStream.deleteDirectory(T)


deleteEntry

deleteEntry o7planning.org
  • KeyStore.deleteEntry(String)


deleteFile

deleteFile o7planning.org
  • SecureDirectoryStream.deleteFile(T)


deleteIfExists

deleteIfExists o7planning.org
  • FileSystemProvider.deleteIfExists(Path)
  • Files.deleteIfExists(Path)


deleteNextCharAction

deleteNextCharAction o7planning.org
  • DefaultEditorKit.deleteNextCharAction


deleteNextWordAction

deleteNextWordAction o7planning.org
  • DefaultEditorKit.deleteNextWordAction


deleteObserver

deleteObserver o7planning.org
  • Observable.deleteObserver(Observer)


deleteObservers

deleteObservers o7planning.org
  • Observable.deleteObservers()


deleteOnExit

deleteOnExit o7planning.org
  • File.deleteOnExit()


deleteOwner

deleteOwner o7planning.org
  • Owner.deleteOwner(Principal, Principal)


deletePrevCharAction

deletePrevCharAction o7planning.org
  • DefaultEditorKit.deletePrevCharAction


deletePrevWordAction

deletePrevWordAction o7planning.org
  • DefaultEditorKit.deletePrevWordAction


deleteRow

deleteRow o7planning.org
  • ResultSet.deleteRow()


deletesAreDetected

deletesAreDetected o7planning.org
  • DatabaseMetaData.deletesAreDetected(int)


deleteShortcut

deleteShortcut o7planning.org
  • MenuBar.deleteShortcut(MenuShortcut)
  • MenuItem.deleteShortcut()


deleteTrack

deleteTrack o7planning.org
  • Sequence.deleteTrack(Track)


delimiter

delimiter o7planning.org
  • Scanner.delimiter()


delItem

delItem o7planning.org
  • List.delItem(int)


delItems

delItems o7planning.org
  • List.delItems(int, int)


deliverEvent

deliverEvent o7planning.org
  • Component.deliverEvent(Event)
  • Container.deliverEvent(Event)


deltaTransform

deltaTransform o7planning.org
  • AffineTransform.deltaTransform(double[], int, double[], int, int)
  • AffineTransform.deltaTransform(Point2D, Point2D)


depth

depth o7planning.org
  • ElementIterator.depth()


depthFirstEnumeration

depthFirstEnumeration o7planning.org
  • DefaultMutableTreeNode.depthFirstEnumeration()


depthOffset

depthOffset o7planning.org
  • BasicTreeUI.depthOffset


dequeueKeyEvents

dequeueKeyEvents o7planning.org
  • DefaultKeyboardFocusManager.dequeueKeyEvents(long, Component)
  • KeyboardFocusManager.dequeueKeyEvents(long, Component)


dereference

dereference o7planning.org
  • RetrievalMethod.dereference(XMLCryptoContext)
  • URIDereferencer.dereference(URIReference, XMLCryptoContext)


deregister

deregister o7planning.org
  • AbstractSelector.deregister(AbstractSelectionKey)
  • DriverAction.deregister()


deregisterAll

deregisterAll o7planning.org
  • ServiceRegistry.deregisterAll()
  • ServiceRegistry.deregisterAll(Class<?>)


deregisterDriver

deregisterDriver o7planning.org
  • DriverManager.deregisterDriver(Driver)


deregisterServiceProvider

deregisterServiceProvider o7planning.org
  • ServiceRegistry.deregisterServiceProvider(Object)
  • ServiceRegistry.deregisterServiceProvider(T, Class<T>)


DERIVATION_EXTENSION

DERIVATION_EXTENSION o7planning.org
  • TypeInfo.DERIVATION_EXTENSION


DERIVATION_LIST

DERIVATION_LIST o7planning.org
  • TypeInfo.DERIVATION_LIST


DERIVATION_RESTRICTION

DERIVATION_RESTRICTION o7planning.org
  • TypeInfo.DERIVATION_RESTRICTION


DERIVATION_UNION

DERIVATION_UNION o7planning.org
  • TypeInfo.DERIVATION_UNION


derive

derive o7planning.org
  • AlphaComposite.derive(float)
  • AlphaComposite.derive(int)


deriveFont

deriveFont o7planning.org
  • Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute, ?>)
  • Font.deriveFont(int)
  • Font.deriveFont(AffineTransform)
  • Font.deriveFont(float)
  • Font.deriveFont(int, AffineTransform)
  • Font.deriveFont(int, float)


deriveMMFont

deriveMMFont o7planning.org
  • MultipleMaster.deriveMMFont(float[], float, float, float, float)
  • MultipleMaster.deriveMMFont(float[])


DES_EDE_KEY_LEN

DES_EDE_KEY_LEN o7planning.org
  • DESedeKeySpec.DES_EDE_KEY_LEN


DES_KEY_LEN

DES_KEY_LEN o7planning.org
  • DESKeySpec.DES_KEY_LEN


descendingIterator

descendingIterator o7planning.org
  • ArrayDeque.descendingIterator()
  • ConcurrentLinkedDeque.descendingIterator()
  • ConcurrentSkipListSet.descendingIterator()
  • Deque.descendingIterator()
  • LinkedBlockingDeque.descendingIterator()
  • LinkedList.descendingIterator()
  • NavigableSet.descendingIterator()
  • TreeSet.descendingIterator()


descendingKeySet

descendingKeySet o7planning.org
  • ConcurrentNavigableMap.descendingKeySet()
  • ConcurrentSkipListMap.descendingKeySet()
  • NavigableMap.descendingKeySet()
  • TreeMap.descendingKeySet()


descendingMap

descendingMap o7planning.org
  • ConcurrentNavigableMap.descendingMap()
  • ConcurrentSkipListMap.descendingMap()
  • NavigableMap.descendingMap()
  • TreeMap.descendingMap()


descendingSet

descendingSet o7planning.org
  • ConcurrentSkipListSet.descendingSet()
  • NavigableSet.descendingSet()
  • TreeSet.descendingSet()


description

description o7planning.org
  • DriverPropertyInfo.description
  • MBeanFeatureInfo.description


DescriptorSupport

DescriptorSupport o7planning.org
  • DescriptorSupport.DescriptorSupport(String...)
  • DescriptorSupport.DescriptorSupport(String[], Object[])
  • DescriptorSupport.DescriptorSupport(String)
  • DescriptorSupport.DescriptorSupport(DescriptorSupport)
  • DescriptorSupport.DescriptorSupport(int)
  • DescriptorSupport.DescriptorSupport()


DESedeKeySpec

DESedeKeySpec o7planning.org
  • DESedeKeySpec.DESedeKeySpec(byte[], int)
  • DESedeKeySpec.DESedeKeySpec(byte[])


deselect

deselect o7planning.org
  • List.deselect(int)


DESELECTED

DESELECTED o7planning.org
  • ItemEvent.DESELECTED


DESERET

DESERET o7planning.org
  • Character.UnicodeBlock.DESERET


deserialize

deserialize o7planning.org
  • BeanContextSupport.deserialize(ObjectInputStream, Collection)
  • MBeanServer.deserialize(String, ObjectName, byte[])
  • MBeanServer.deserialize(String, byte[])
  • MBeanServer.deserialize(ObjectName, byte[])


DESIGNATED_LONG

DESIGNATED_LONG o7planning.org
  • MediaSize.ISO.DESIGNATED_LONG


designTime

designTime o7planning.org
  • BeanContextSupport.designTime


desiredAssertionStatus

desiredAssertionStatus o7planning.org
  • Class.desiredAssertionStatus()


DESKeySpec

DESKeySpec o7planning.org
  • DESKeySpec.DESKeySpec(byte[], int)
  • DESKeySpec.DESKeySpec(byte[])


DESKTOP

DESKTOP o7planning.org
  • SystemColor.DESKTOP


desktop

desktop o7planning.org
  • BasicDesktopPaneUI.desktop
  • SystemColor.desktop


DESKTOP_ICON

DESKTOP_ICON o7planning.org
  • AccessibleRole.DESKTOP_ICON
  • Region.DESKTOP_ICON


DESKTOP_PANE

DESKTOP_PANE o7planning.org
  • AccessibleRole.DESKTOP_PANE
  • Region.DESKTOP_PANE


desktopIcon

desktopIcon o7planning.org
  • BasicDesktopIconUI.desktopIcon
  • JInternalFrame.desktopIcon


DesktopIconUI

DesktopIconUI o7planning.org
  • DesktopIconUI.DesktopIconUI()


desktopManager

desktopManager o7planning.org
  • BasicDesktopPaneUI.desktopManager


DesktopPaneUI

DesktopPaneUI o7planning.org
  • DesktopPaneUI.DesktopPaneUI()


desktopProperties

desktopProperties o7planning.org
  • Toolkit.desktopProperties


desktopPropsSupport

desktopPropsSupport o7planning.org
  • Toolkit.desktopPropsSupport


destHeight

destHeight o7planning.org
  • ReplicateScaleFilter.destHeight


destination

destination o7planning.org
  • BasicTreeUI.MouseInputHandler.destination


Destination

Destination o7planning.org
  • Destination.Destination(URI)


destinationBands

destinationBands o7planning.org
  • ImageReadParam.destinationBands


destinationOffset

destinationOffset o7planning.org
  • IIOParam.destinationOffset


destinationType

destinationType o7planning.org
  • IIOParam.destinationType


destroy

destroy o7planning.org
  • Applet.destroy()
  • BindingIteratorOperations.destroy()
  • Destroyable.destroy()
  • DynAny.destroy()
  • DynAnyOperations.destroy()
  • IRObjectOperations.destroy()
  • InterceptorOperations.destroy()
  • KerberosKey.destroy()
  • KerberosTicket.destroy()
  • KeyStore.PasswordProtection.destroy()
  • NamingContextOperations.destroy()
  • ORB.destroy()
  • POAOperations.destroy(boolean, boolean)
  • PolicyOperations.destroy()
  • Process.destroy()
  • Thread.destroy()
  • ThreadGroup.destroy()
  • X500PrivateCredential.destroy()
  • _BindingIteratorStub.destroy()
  • _DynAnyStub.destroy()
  • _DynArrayStub.destroy()
  • _DynEnumStub.destroy()
  • _DynFixedStub.destroy()
  • _DynSequenceStub.destroy()
  • _DynStructStub.destroy()
  • _DynUnionStub.destroy()
  • _DynValueStub.destroy()
  • _IDLTypeStub.destroy()
  • _NamingContextExtStub.destroy()
  • _NamingContextStub.destroy()
  • _PolicyStub.destroy()


destroyBuffers

destroyBuffers o7planning.org
  • Component.FlipBufferStrategy.destroyBuffers()


DestroyFailedException

DestroyFailedException o7planning.org
  • DestroyFailedException.DestroyFailedException(String)
  • DestroyFailedException.DestroyFailedException()


destroyForcibly

destroyForcibly o7planning.org
  • Process.destroyForcibly()


destroySubcontext

destroySubcontext o7planning.org
  • Context.destroySubcontext(String)
  • Context.destroySubcontext(Name)
  • InitialContext.destroySubcontext(Name)
  • InitialContext.destroySubcontext(String)


destWidth

destWidth o7planning.org
  • ReplicateScaleFilter.destWidth


detachNode

detachNode o7planning.org
  • Node.detachNode()


detail

detail o7planning.org
  • ActivationException.detail
  • RemoteException.detail
  • ServerCloneException.detail
  • WriteAbortedException.detail


detailsViewIcon

detailsViewIcon o7planning.org
  • BasicFileChooserUI.detailsViewIcon


detectedCharset

detectedCharset o7planning.org
  • CharsetDecoder.detectedCharset()


determineOffset

determineOffset o7planning.org
  • DefaultTreeCellEditor.determineOffset(JTree, Object, boolean, boolean, boolean, int)


DEVANAGARI

DEVANAGARI o7planning.org
  • Character.UnicodeBlock.DEVANAGARI
  • NumericShaper.DEVANAGARI


DEVANAGARI_EXTENDED

DEVANAGARI_EXTENDED o7planning.org
  • Character.UnicodeBlock.DEVANAGARI_EXTENDED


DEVELOPER_EMPTY

DEVELOPER_EMPTY o7planning.org
  • PrinterStateReason.DEVELOPER_EMPTY


DEVELOPER_LOW

DEVELOPER_LOW o7planning.org
  • PrinterStateReason.DEVELOPER_LOW


DFN

DFN o7planning.org
  • HTML.Tag.DFN


DGC_ID

DGC_ID o7planning.org
  • ObjID.DGC_ID


DHGenParameterSpec

DHGenParameterSpec o7planning.org
  • DHGenParameterSpec.DHGenParameterSpec(int, int)


DHParameterSpec

DHParameterSpec o7planning.org
  • DHParameterSpec.DHParameterSpec(BigInteger, BigInteger, int)
  • DHParameterSpec.DHParameterSpec(BigInteger, BigInteger)


DHPrivateKeySpec

DHPrivateKeySpec o7planning.org
  • DHPrivateKeySpec.DHPrivateKeySpec(BigInteger, BigInteger, BigInteger)


DHPublicKeySpec

DHPublicKeySpec o7planning.org
  • DHPublicKeySpec.DHPublicKeySpec(BigInteger, BigInteger, BigInteger)


DiagnosticCollector

DiagnosticCollector o7planning.org
  • DiagnosticCollector.DiagnosticCollector()


Dialog

Dialog o7planning.org
  • Dialog.Dialog(Window, String, Dialog.ModalityType, GraphicsConfiguration)
  • Dialog.Dialog(Window, String, Dialog.ModalityType)
  • Dialog.Dialog(Window, Dialog.ModalityType)
  • Dialog.Dialog(Window, String)
  • Dialog.Dialog(Window)
  • Dialog.Dialog(Dialog, String, boolean, GraphicsConfiguration)
  • Dialog.Dialog(Dialog, String, boolean)
  • Dialog.Dialog(Dialog, String)
  • Dialog.Dialog(Dialog)
  • Dialog.Dialog(Frame, String, boolean, GraphicsConfiguration)
  • Dialog.Dialog(Frame, String, boolean)
  • Dialog.Dialog(Frame, String)
  • Dialog.Dialog(Frame, boolean)
  • Dialog.Dialog(Frame)


DIALOG

DIALOG o7planning.org
  • AccessibleRole.DIALOG
  • Font.DIALOG


DIALOG_INPUT

DIALOG_INPUT o7planning.org
  • Font.DIALOG_INPUT


DIALOG_TITLE_CHANGED_PROPERTY

DIALOG_TITLE_CHANGED_PROPERTY o7planning.org
  • JFileChooser.DIALOG_TITLE_CHANGED_PROPERTY


DIALOG_TYPE_CHANGED_PROPERTY

DIALOG_TYPE_CHANGED_PROPERTY o7planning.org
  • JFileChooser.DIALOG_TYPE_CHANGED_PROPERTY


DIALOG_UI

DIALOG_UI o7planning.org
  • ServiceUIFactory.DIALOG_UI


dialogInit

dialogInit o7planning.org
  • JDialog.dialogInit()


DialogTypeSelection

DialogTypeSelection o7planning.org
  • DialogTypeSelection.DialogTypeSelection(int)


Dictionary

Dictionary o7planning.org
  • Dictionary.Dictionary()


die

die o7planning.org
  • AbstractUndoableEdit.die()
  • CompoundEdit.die()
  • UndoableEdit.die()


digest

digest o7planning.org
  • DigestInputStream.digest
  • DigestOutputStream.digest
  • MessageDigest.digest(byte[])
  • MessageDigest.digest(byte[], int, int)
  • MessageDigest.digest()


DigestException

DigestException o7planning.org
  • DigestException.DigestException(Throwable)
  • DigestException.DigestException(String, Throwable)
  • DigestException.DigestException(String)
  • DigestException.DigestException()


DigestInputStream

DigestInputStream o7planning.org
  • DigestInputStream.DigestInputStream(InputStream, MessageDigest)


DigestOutputStream

DigestOutputStream o7planning.org
  • DigestOutputStream.DigestOutputStream(OutputStream, MessageDigest)


digit

digit o7planning.org
  • Character.digit(int, int)
  • Character.digit(char, int)


Dimension2D

Dimension2D o7planning.org
  • Dimension2D.Dimension2D()


Dimension

Dimension o7planning.org
  • Dimension.Dimension(int, int)
  • Dimension.Dimension(Dimension)
  • Dimension.Dimension()


DimensionUIResource

DimensionUIResource o7planning.org
  • DimensionUIResource.DimensionUIResource(int, int)


DINGBATS

DINGBATS o7planning.org
  • Character.UnicodeBlock.DINGBATS


DIR

DIR o7planning.org
  • HTML.Attribute.DIR
  • HTML.Tag.DIR


DirectColorModel

DirectColorModel o7planning.org
  • DirectColorModel.DirectColorModel(ColorSpace, int, int, int, int, int, boolean, int)
  • DirectColorModel.DirectColorModel(int, int, int, int, int)
  • DirectColorModel.DirectColorModel(int, int, int, int)


direction

direction o7planning.org
  • BasicArrowButton.direction
  • BasicTreeUI.TreeHomeAction.direction
  • BasicTreeUI.TreeIncrementAction.direction
  • BasicTreeUI.TreePageAction.direction
  • BasicTreeUI.TreeTraverseAction.direction


DIRECTION_DEFAULT_LEFT_TO_RIGHT

DIRECTION_DEFAULT_LEFT_TO_RIGHT o7planning.org
  • Bidi.DIRECTION_DEFAULT_LEFT_TO_RIGHT


DIRECTION_DEFAULT_RIGHT_TO_LEFT

DIRECTION_DEFAULT_RIGHT_TO_LEFT o7planning.org
  • Bidi.DIRECTION_DEFAULT_RIGHT_TO_LEFT


DIRECTION_LEFT_TO_RIGHT

DIRECTION_LEFT_TO_RIGHT o7planning.org
  • Bidi.DIRECTION_LEFT_TO_RIGHT


DIRECTION_RIGHT_TO_LEFT

DIRECTION_RIGHT_TO_LEFT o7planning.org
  • Bidi.DIRECTION_RIGHT_TO_LEFT


DIRECTIONALITY_ARABIC_NUMBER

DIRECTIONALITY_ARABIC_NUMBER o7planning.org
  • Character.DIRECTIONALITY_ARABIC_NUMBER


DIRECTIONALITY_BOUNDARY_NEUTRAL

DIRECTIONALITY_BOUNDARY_NEUTRAL o7planning.org
  • Character.DIRECTIONALITY_BOUNDARY_NEUTRAL


DIRECTIONALITY_COMMON_NUMBER_SEPARATOR

DIRECTIONALITY_COMMON_NUMBER_SEPARATOR o7planning.org
  • Character.DIRECTIONALITY_COMMON_NUMBER_SEPARATOR


DIRECTIONALITY_EUROPEAN_NUMBER

DIRECTIONALITY_EUROPEAN_NUMBER o7planning.org
  • Character.DIRECTIONALITY_EUROPEAN_NUMBER


DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR

DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR o7planning.org
  • Character.DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR


DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR

DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR o7planning.org
  • Character.DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR


DIRECTIONALITY_LEFT_TO_RIGHT

DIRECTIONALITY_LEFT_TO_RIGHT o7planning.org
  • Character.DIRECTIONALITY_LEFT_TO_RIGHT


DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING

DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING o7planning.org
  • Character.DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING


DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE

DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE o7planning.org
  • Character.DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE


DIRECTIONALITY_NONSPACING_MARK

DIRECTIONALITY_NONSPACING_MARK o7planning.org
  • Character.DIRECTIONALITY_NONSPACING_MARK


DIRECTIONALITY_OTHER_NEUTRALS

DIRECTIONALITY_OTHER_NEUTRALS o7planning.org
  • Character.DIRECTIONALITY_OTHER_NEUTRALS


DIRECTIONALITY_PARAGRAPH_SEPARATOR

DIRECTIONALITY_PARAGRAPH_SEPARATOR o7planning.org
  • Character.DIRECTIONALITY_PARAGRAPH_SEPARATOR


DIRECTIONALITY_POP_DIRECTIONAL_FORMAT

DIRECTIONALITY_POP_DIRECTIONAL_FORMAT o7planning.org
  • Character.DIRECTIONALITY_POP_DIRECTIONAL_FORMAT


DIRECTIONALITY_RIGHT_TO_LEFT

DIRECTIONALITY_RIGHT_TO_LEFT o7planning.org
  • Character.DIRECTIONALITY_RIGHT_TO_LEFT


DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC

DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC o7planning.org
  • Character.DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC


DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING

DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING o7planning.org
  • Character.DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING


DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE

DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE o7planning.org
  • Character.DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE


DIRECTIONALITY_SEGMENT_SEPARATOR

DIRECTIONALITY_SEGMENT_SEPARATOR o7planning.org
  • Character.DIRECTIONALITY_SEGMENT_SEPARATOR


DIRECTIONALITY_UNDEFINED

DIRECTIONALITY_UNDEFINED o7planning.org
  • Character.DIRECTIONALITY_UNDEFINED


DIRECTIONALITY_WHITESPACE

DIRECTIONALITY_WHITESPACE o7planning.org
  • Character.DIRECTIONALITY_WHITESPACE


DIRECTORIES_ONLY

DIRECTORIES_ONLY o7planning.org
  • JFileChooser.DIRECTORIES_ONLY


directory

directory o7planning.org
  • ProcessBuilder.directory(File)
  • ProcessBuilder.directory()


DIRECTORY_CHANGED_PROPERTY

DIRECTORY_CHANGED_PROPERTY o7planning.org
  • JFileChooser.DIRECTORY_CHANGED_PROPERTY


DIRECTORY_PANE

DIRECTORY_PANE o7planning.org
  • AccessibleRole.DIRECTORY_PANE


DirectoryComboBoxAction

DirectoryComboBoxAction o7planning.org
  • MetalFileChooserUI.DirectoryComboBoxAction.DirectoryComboBoxAction()


DirectoryComboBoxModel

DirectoryComboBoxModel o7planning.org
  • MetalFileChooserUI.DirectoryComboBoxModel.DirectoryComboBoxModel()


directoryIcon

directoryIcon o7planning.org
  • BasicFileChooserUI.directoryIcon


DirectoryIteratorException

DirectoryIteratorException o7planning.org
  • DirectoryIteratorException.DirectoryIteratorException(IOException)


DirectoryNotEmptyException

DirectoryNotEmptyException o7planning.org
  • DirectoryNotEmptyException.DirectoryNotEmptyException(String)


directoryOpenButtonMnemonic

directoryOpenButtonMnemonic o7planning.org
  • BasicFileChooserUI.directoryOpenButtonMnemonic


directoryOpenButtonText

directoryOpenButtonText o7planning.org
  • BasicFileChooserUI.directoryOpenButtonText


directoryOpenButtonToolTipText

directoryOpenButtonToolTipText o7planning.org
  • BasicFileChooserUI.directoryOpenButtonToolTipText


directSupertypes

directSupertypes o7planning.org
  • Types.directSupertypes(TypeMirror)


dirty

dirty o7planning.org
  • DGC.dirty(ObjID[], long, Lease)


disable

disable o7planning.org
  • Compiler.disable()
  • Component.disable()
  • JComponent.disable()
  • MenuItem.disable()


disableAllAttributes

disableAllAttributes o7planning.org
  • AttributeChangeNotificationFilter.disableAllAttributes()


disableAllObjectNames

disableAllObjectNames o7planning.org
  • MBeanServerNotificationFilter.disableAllObjectNames()


disableAllTypes

disableAllTypes o7planning.org
  • NotificationFilterSupport.disableAllTypes()


disableAttribute

disableAttribute o7planning.org
  • AttributeChangeNotificationFilter.disableAttribute(String)


DISABLED

DISABLED o7planning.org
  • SynthConstants.DISABLED


DISABLED_ICON_CHANGED_PROPERTY

DISABLED_ICON_CHANGED_PROPERTY o7planning.org
  • AbstractButton.DISABLED_ICON_CHANGED_PROPERTY


DISABLED_SELECTED_ICON_CHANGED_PROPERTY

DISABLED_SELECTED_ICON_CHANGED_PROPERTY o7planning.org
  • AbstractButton.DISABLED_SELECTED_ICON_CHANGED_PROPERTY


disabledForeground

disabledForeground o7planning.org
  • BasicMenuItemUI.disabledForeground


disabledTextColor

disabledTextColor o7planning.org
  • MetalButtonUI.disabledTextColor
  • MetalRadioButtonUI.disabledTextColor
  • MetalToggleButtonUI.disabledTextColor


disableEvents

disableEvents o7planning.org
  • Component.disableEvents(long)
  • MenuItem.disableEvents(long)


disableObjectName

disableObjectName o7planning.org
  • MBeanServerNotificationFilter.disableObjectName(ObjectName)


disableResizedPosting

disableResizedPosting o7planning.org
  • TableColumn.disableResizedPosting()


disableSwingFocusManager

disableSwingFocusManager o7planning.org
  • FocusManager.disableSwingFocusManager()


disableType

disableType o7planning.org
  • NotificationFilterSupport.disableType(String)


discard_requests

discard_requests o7planning.org
  • POAManagerOperations.discard_requests(boolean)


discardAllEdits

discardAllEdits o7planning.org
  • UndoManager.discardAllEdits()


DISCARDING

DISCARDING o7planning.org
  • State.DISCARDING


discardKeyEvents

discardKeyEvents o7planning.org
  • DefaultKeyboardFocusManager.discardKeyEvents(Component)
  • KeyboardFocusManager.discardKeyEvents(Component)


DiscardOldestPolicy

DiscardOldestPolicy o7planning.org
  • ThreadPoolExecutor.DiscardOldestPolicy.DiscardOldestPolicy()


DiscardPolicy

DiscardPolicy o7planning.org
  • ThreadPoolExecutor.DiscardPolicy.DiscardPolicy()


disconnect

disconnect o7planning.org
  • DatagramChannel.disconnect()
  • DatagramSocket.disconnect()
  • DatagramSocketImpl.disconnect()
  • HttpURLConnection.disconnect()
  • ORB.disconnect(Object)


DISCONTIGUOUS_TREE_SELECTION

DISCONTIGUOUS_TREE_SELECTION o7planning.org
  • TreeSelectionModel.DISCONTIGUOUS_TREE_SELECTION


discriminator

discriminator o7planning.org
  • DynUnion.discriminator()


discriminator_kind

discriminator_kind o7planning.org
  • DynUnion.discriminator_kind()
  • DynUnionOperations.discriminator_kind()
  • _DynUnionStub.discriminator_kind()


discriminator_type

discriminator_type o7planning.org
  • TypeCode.discriminator_type()


disjoint

disjoint o7planning.org
  • Collections.disjoint(Collection<?>, Collection<?>)


dismiss

dismiss o7planning.org
  • JSpinner.DefaultEditor.dismiss(JSpinner)


dispatch

dispatch o7planning.org
  • ActiveEvent.dispatch()
  • InvocationEvent.dispatch()
  • NamingEvent.dispatch(NamingListener)
  • NamingExceptionEvent.dispatch(NamingListener)
  • Skeleton.dispatch(Remote, RemoteCall, int, long)
  • UnsolicitedNotificationEvent.dispatch(UnsolicitedNotificationListener)


dispatchEvent

dispatchEvent o7planning.org
  • Component.dispatchEvent(AWTEvent)
  • DefaultKeyboardFocusManager.dispatchEvent(AWTEvent)
  • EventQueue.dispatchEvent(AWTEvent)
  • EventTarget.dispatchEvent(Event)
  • InputContext.dispatchEvent(AWTEvent)
  • InputMethod.dispatchEvent(AWTEvent)
  • KeyboardFocusManager.dispatchEvent(AWTEvent)
  • MenuComponent.dispatchEvent(AWTEvent)


dispatchInputMethodEvent

dispatchInputMethodEvent o7planning.org
  • InputMethodContext.dispatchInputMethodEvent(int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo)


dispatchKeyEvent

dispatchKeyEvent o7planning.org
  • DefaultKeyboardFocusManager.dispatchKeyEvent(KeyEvent)
  • KeyEventDispatcher.dispatchKeyEvent(KeyEvent)
  • KeyboardFocusManager.dispatchKeyEvent(KeyEvent)


DISPLAY

DISPLAY o7planning.org
  • CSS.Attribute.DISPLAY


DISPLAYABILITY_CHANGED

DISPLAYABILITY_CHANGED o7planning.org
  • HierarchyEvent.DISPLAYABILITY_CHANGED


DISPLAYED_MNEMONIC_INDEX_KEY

DISPLAYED_MNEMONIC_INDEX_KEY o7planning.org
  • Action.DISPLAYED_MNEMONIC_INDEX_KEY


displayMessage

displayMessage o7planning.org
  • TrayIcon.displayMessage(String, String, TrayIcon.MessageType)


DisplayMode

DisplayMode o7planning.org
  • DisplayMode.DisplayMode(int, int, int, int)


displayName

displayName o7planning.org
  • Charset.displayName(Locale)
  • Charset.displayName()


dispose

dispose o7planning.org
  • BufferStrategy.dispose()
  • Component.BltBufferStrategy.dispose()
  • Component.FlipBufferStrategy.dispose()
  • CompositeContext.dispose()
  • DebugGraphics.dispose()
  • GSSContext.dispose()
  • GSSCredential.dispose()
  • Graphics.dispose()
  • ImageReader.dispose()
  • ImageWriter.dispose()
  • InputContext.dispose()
  • InputMethod.dispose()
  • JInternalFrame.dispose()
  • PaintContext.dispose()
  • SaslClient.dispose()
  • SaslServer.dispose()
  • StreamPrintService.dispose()
  • Window.dispose()


DISPOSE_ON_CLOSE

DISPOSE_ON_CLOSE o7planning.org
  • WindowConstants.DISPOSE_ON_CLOSE


distance

distance o7planning.org
  • Point2D.distance(Point2D)
  • Point2D.distance(double, double)
  • Point2D.distance(double, double, double, double)


distanceSq

distanceSq o7planning.org
  • Point2D.distanceSq(Point2D)
  • Point2D.distanceSq(double, double)
  • Point2D.distanceSq(double, double, double, double)


DISTINCT

DISTINCT o7planning.org
  • Spliterator.DISTINCT
  • Types.DISTINCT


distinct

distinct o7planning.org
  • DoubleStream.distinct()
  • IntStream.distinct()
  • LongStream.distinct()
  • Stream.distinct()


DIV

DIV o7planning.org
  • HTML.Tag.DIV


div

div o7planning.org
  • Query.div(ValueExp, ValueExp)


divide

divide o7planning.org
  • BigDecimal.divide(BigDecimal, MathContext)
  • BigDecimal.divide(BigDecimal)
  • BigDecimal.divide(BigDecimal, RoundingMode)
  • BigDecimal.divide(BigDecimal, int)
  • BigDecimal.divide(BigDecimal, int, RoundingMode)
  • BigDecimal.divide(BigDecimal, int, int)
  • BigInteger.divide(BigInteger)


divideAndRemainder

divideAndRemainder o7planning.org
  • BigDecimal.divideAndRemainder(BigDecimal, MathContext)
  • BigDecimal.divideAndRemainder(BigDecimal)
  • BigInteger.divideAndRemainder(BigInteger)


dividedBy

dividedBy o7planning.org
  • Duration.dividedBy(long)


DIVIDER

DIVIDER o7planning.org
  • JSplitPane.DIVIDER


divider

divider o7planning.org
  • BasicSplitPaneUI.divider


DIVIDER_LOCATION_PROPERTY

DIVIDER_LOCATION_PROPERTY o7planning.org
  • JSplitPane.DIVIDER_LOCATION_PROPERTY


DIVIDER_SIZE_PROPERTY

DIVIDER_SIZE_PROPERTY o7planning.org
  • JSplitPane.DIVIDER_SIZE_PROPERTY


DividerLayout

DividerLayout o7planning.org
  • BasicSplitPaneDivider.DividerLayout.DividerLayout()


dividerResizeToggleKey

dividerResizeToggleKey o7planning.org
  • BasicSplitPaneUI.dividerResizeToggleKey


dividerSize

dividerSize o7planning.org
  • BasicSplitPaneDivider.dividerSize
  • BasicSplitPaneUI.dividerSize
  • JSplitPane.dividerSize


divideToIntegralValue

divideToIntegralValue o7planning.org
  • BigDecimal.divideToIntegralValue(BigDecimal, MathContext)
  • BigDecimal.divideToIntegralValue(BigDecimal)


divideUnsigned

divideUnsigned o7planning.org
  • Integer.divideUnsigned(int, int)
  • Long.divideUnsigned(long, long)


divisionType

divisionType o7planning.org
  • MidiFileFormat.divisionType
  • Sequence.divisionType


dk_AbstractInterface

dk_AbstractInterface o7planning.org
  • DefinitionKind.dk_AbstractInterface


dk_Alias

dk_Alias o7planning.org
  • DefinitionKind.dk_Alias


dk_all

dk_all o7planning.org
  • DefinitionKind.dk_all


dk_Array

dk_Array o7planning.org
  • DefinitionKind.dk_Array


dk_Attribute

dk_Attribute o7planning.org
  • DefinitionKind.dk_Attribute


dk_Constant

dk_Constant o7planning.org
  • DefinitionKind.dk_Constant


dk_Enum

dk_Enum o7planning.org
  • DefinitionKind.dk_Enum


dk_Exception

dk_Exception o7planning.org
  • DefinitionKind.dk_Exception


dk_Fixed

dk_Fixed o7planning.org
  • DefinitionKind.dk_Fixed


dk_Interface

dk_Interface o7planning.org
  • DefinitionKind.dk_Interface


dk_Module

dk_Module o7planning.org
  • DefinitionKind.dk_Module


dk_Native

dk_Native o7planning.org
  • DefinitionKind.dk_Native


dk_none

dk_none o7planning.org
  • DefinitionKind.dk_none


dk_Operation

dk_Operation o7planning.org
  • DefinitionKind.dk_Operation


dk_Primitive

dk_Primitive o7planning.org
  • DefinitionKind.dk_Primitive


dk_Repository

dk_Repository o7planning.org
  • DefinitionKind.dk_Repository


dk_Sequence

dk_Sequence o7planning.org
  • DefinitionKind.dk_Sequence


dk_String

dk_String o7planning.org
  • DefinitionKind.dk_String


dk_Struct

dk_Struct o7planning.org
  • DefinitionKind.dk_Struct


dk_Typedef

dk_Typedef o7planning.org
  • DefinitionKind.dk_Typedef


dk_Union

dk_Union o7planning.org
  • DefinitionKind.dk_Union


dk_Value

dk_Value o7planning.org
  • DefinitionKind.dk_Value


dk_ValueBox

dk_ValueBox o7planning.org
  • DefinitionKind.dk_ValueBox


dk_ValueMember

dk_ValueMember o7planning.org
  • DefinitionKind.dk_ValueMember


dk_Wstring

dk_Wstring o7planning.org
  • DefinitionKind.dk_Wstring


DL

DL o7planning.org
  • HTML.Tag.DL


DNS_URL

DNS_URL o7planning.org
  • Context.DNS_URL


DO_NOTHING_ON_CLOSE

DO_NOTHING_ON_CLOSE o7planning.org
  • WindowConstants.DO_NOTHING_ON_CLOSE


doAccessibleAction

doAccessibleAction o7planning.org
  • AbstractButton.AccessibleAbstractButton.doAccessibleAction(int)
  • AccessibleAction.doAccessibleAction(int)
  • AccessibleHyperlink.doAccessibleAction(int)
  • Button.AccessibleAWTButton.doAccessibleAction(int)
  • Checkbox.AccessibleAWTCheckbox.doAccessibleAction(int)
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.doAccessibleAction(int)
  • Choice.AccessibleAWTChoice.doAccessibleAction(int)
  • JComboBox.AccessibleJComboBox.doAccessibleAction(int)
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.doAccessibleAction(int)
  • JSpinner.AccessibleJSpinner.doAccessibleAction(int)
  • JTextComponent.AccessibleJTextComponent.doAccessibleAction(int)
  • JTree.AccessibleJTree.AccessibleJTreeNode.doAccessibleAction(int)
  • MenuItem.AccessibleAWTMenuItem.doAccessibleAction(int)


doAs

doAs o7planning.org
  • Subject.doAs(Subject, PrivilegedExceptionAction<T>)
  • Subject.doAs(Subject, PrivilegedAction<T>)


doAsPrivileged

doAsPrivileged o7planning.org
  • Subject.doAsPrivileged(Subject, PrivilegedExceptionAction<T>, AccessControlContext)
  • Subject.doAsPrivileged(Subject, PrivilegedAction<T>, AccessControlContext)


DocFlavor

DocFlavor o7planning.org
  • DocFlavor.DocFlavor(String, String)


dockingBorderColor

dockingBorderColor o7planning.org
  • BasicToolBarUI.dockingBorderColor


dockingColor

dockingColor o7planning.org
  • BasicToolBarUI.dockingColor


dockingListener

dockingListener o7planning.org
  • BasicToolBarUI.dockingListener


DockingListener

DockingListener o7planning.org
  • BasicToolBarUI.DockingListener.DockingListener(JToolBar)


doClick

doClick o7planning.org
  • AbstractButton.doClick(int)
  • AbstractButton.doClick()
  • BasicMenuItemUI.doClick(MenuSelectionManager)
  • JMenu.doClick(int)


DOCTYPE_PUBLIC

DOCTYPE_PUBLIC o7planning.org
  • OutputKeys.DOCTYPE_PUBLIC


DOCTYPE_SYSTEM

DOCTYPE_SYSTEM o7planning.org
  • OutputKeys.DOCTYPE_SYSTEM


DOCUMENT_ACCESS_ERROR

DOCUMENT_ACCESS_ERROR o7planning.org
  • JobStateReason.DOCUMENT_ACCESS_ERROR


DOCUMENT_FORMAT_ERROR

DOCUMENT_FORMAT_ERROR o7planning.org
  • JobStateReason.DOCUMENT_FORMAT_ERROR


DOCUMENT_FRAGMENT_NODE

DOCUMENT_FRAGMENT_NODE o7planning.org
  • Node.DOCUMENT_FRAGMENT_NODE


DOCUMENT_NODE

DOCUMENT_NODE o7planning.org
  • Node.DOCUMENT_NODE


DOCUMENT_POSITION_CONTAINED_BY

DOCUMENT_POSITION_CONTAINED_BY o7planning.org
  • Node.DOCUMENT_POSITION_CONTAINED_BY


DOCUMENT_POSITION_CONTAINS

DOCUMENT_POSITION_CONTAINS o7planning.org
  • Node.DOCUMENT_POSITION_CONTAINS


DOCUMENT_POSITION_DISCONNECTED

DOCUMENT_POSITION_DISCONNECTED o7planning.org
  • Node.DOCUMENT_POSITION_DISCONNECTED


DOCUMENT_POSITION_FOLLOWING

DOCUMENT_POSITION_FOLLOWING o7planning.org
  • Node.DOCUMENT_POSITION_FOLLOWING


DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC

DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC o7planning.org
  • Node.DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC


DOCUMENT_POSITION_PRECEDING

DOCUMENT_POSITION_PRECEDING o7planning.org
  • Node.DOCUMENT_POSITION_PRECEDING


DOCUMENT_TYPE_NODE

DOCUMENT_TYPE_NODE o7planning.org
  • Node.DOCUMENT_TYPE_NODE


documentBaseKey

documentBaseKey o7planning.org
  • BasicHTML.documentBaseKey


DocumentBuilder

DocumentBuilder o7planning.org
  • DocumentBuilder.DocumentBuilder()


DocumentBuilderFactory

DocumentBuilderFactory o7planning.org
  • DocumentBuilderFactory.DocumentBuilderFactory()


DocumentFilter

DocumentFilter o7planning.org
  • DocumentFilter.DocumentFilter()


DocumentName

DocumentName o7planning.org
  • DocumentName.DocumentName(String, Locale)


DocumentParser

DocumentParser o7planning.org
  • DocumentParser.DocumentParser(DTD)


doDefaultCloseAction

doDefaultCloseAction o7planning.org
  • JInternalFrame.doDefaultCloseAction()


doesMaxRowSizeIncludeBlobs

doesMaxRowSizeIncludeBlobs o7planning.org
  • DatabaseMetaData.doesMaxRowSizeIncludeBlobs()


doFinal

doFinal o7planning.org
  • Cipher.doFinal(ByteBuffer, ByteBuffer)
  • Cipher.doFinal(byte[], int, int, byte[], int)
  • Cipher.doFinal(byte[], int, int, byte[])
  • Cipher.doFinal(byte[], int, int)
  • Cipher.doFinal(byte[])
  • Cipher.doFinal(byte[], int)
  • Cipher.doFinal()
  • Mac.doFinal(byte[])
  • Mac.doFinal(byte[], int)
  • Mac.doFinal()


doInBackground

doInBackground o7planning.org
  • SwingWorker.doInBackground()


doInput

doInput o7planning.org
  • URLConnection.doInput


doLayout

doLayout o7planning.org
  • Component.doLayout()
  • Container.doLayout()
  • DefaultTreeCellEditor.EditorContainer.doLayout()
  • JLayer.doLayout()
  • JTable.doLayout()
  • LayerUI.doLayout(JLayer<? extends V>)
  • ScrollPane.doLayout()


doLookup

doLookup o7planning.org
  • InitialContext.doLookup(String)
  • InitialContext.doLookup(Name)


DOM_OBJECT_MODEL

DOM_OBJECT_MODEL o7planning.org
  • XPathConstants.DOM_OBJECT_MODEL


DomainLoadStoreParameter

DomainLoadStoreParameter o7planning.org
  • DomainLoadStoreParameter.DomainLoadStoreParameter(URI, Map<String, KeyStore.ProtectionParameter>)


domainMatches

domainMatches o7planning.org
  • HttpCookie.domainMatches(String, String)


DOMCryptoContext

DOMCryptoContext o7planning.org
  • DOMCryptoContext.DOMCryptoContext()


DOMException

DOMException o7planning.org
  • DOMException.DOMException(short, String)


DOMINO_TILES

DOMINO_TILES o7planning.org
  • Character.UnicodeBlock.DOMINO_TILES


DOMResult

DOMResult o7planning.org
  • DOMResult.DOMResult(Node, Node, String)
  • DOMResult.DOMResult(Node, Node)
  • DOMResult.DOMResult(Node, String)
  • DOMResult.DOMResult(Node)
  • DOMResult.DOMResult()


DOMSignContext

DOMSignContext o7planning.org
  • DOMSignContext.DOMSignContext(KeySelector, Node, Node)
  • DOMSignContext.DOMSignContext(KeySelector, Node)
  • DOMSignContext.DOMSignContext(Key, Node, Node)
  • DOMSignContext.DOMSignContext(Key, Node)


DOMSource

DOMSource o7planning.org
  • DOMSource.DOMSource(Node, String)
  • DOMSource.DOMSource(Node)
  • DOMSource.DOMSource()


DOMSTRING_SIZE_ERR

DOMSTRING_SIZE_ERR o7planning.org
  • DOMException.DOMSTRING_SIZE_ERR


DOMStructure

DOMStructure o7planning.org
  • DOMStructure.DOMStructure(Node)


DOMValidateContext

DOMValidateContext o7planning.org
  • DOMValidateContext.DOMValidateContext(Key, Node)
  • DOMValidateContext.DOMValidateContext(KeySelector, Node)


done

done o7planning.org
  • FutureTask.done()
  • SwingWorker.done()


DONE

DONE o7planning.org
  • BreakIterator.DONE
  • CharacterIterator.DONE


dontUseGui

dontUseGui o7planning.org
  • BeanContextSupport.dontUseGui()
  • Visibility.dontUseGui()


DOOR_OPEN

DOOR_OPEN o7planning.org
  • PrinterStateReason.DOOR_OPEN


doOutput

doOutput o7planning.org
  • URLConnection.doOutput


doPaint

doPaint o7planning.org
  • AbstractRegionPainter.doPaint(Graphics2D, JComponent, int, int, Object[])


doPhase

doPhase o7planning.org
  • KeyAgreement.doPhase(Key, boolean)


doPrivileged

doPrivileged o7planning.org
  • AccessController.doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext, Permission...)
  • AccessController.doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext)
  • AccessController.doPrivileged(PrivilegedExceptionAction<T>)
  • AccessController.doPrivileged(PrivilegedAction<T>, AccessControlContext, Permission...)
  • AccessController.doPrivileged(PrivilegedAction<T>, AccessControlContext)
  • AccessController.doPrivileged(PrivilegedAction<T>)


doPrivilegedWithCombiner

doPrivilegedWithCombiner o7planning.org
  • AccessController.doPrivilegedWithCombiner(PrivilegedExceptionAction<T>, AccessControlContext, Permission...)
  • AccessController.doPrivilegedWithCombiner(PrivilegedExceptionAction<T>)
  • AccessController.doPrivilegedWithCombiner(PrivilegedAction<T>, AccessControlContext, Permission...)
  • AccessController.doPrivilegedWithCombiner(PrivilegedAction<T>)


DOTALL

DOTALL o7planning.org
  • Pattern.DOTALL


Double

Double o7planning.org
  • Arc2D.Double.Double(Rectangle2D, double, double, int)
  • Arc2D.Double.Double(double, double, double, double, double, double, int)
  • Arc2D.Double.Double(int)
  • Arc2D.Double.Double()
  • CubicCurve2D.Double.Double(double, double, double, double, double, double, double, double)
  • CubicCurve2D.Double.Double()
  • Double.Double(String)
  • Double.Double(double)
  • Ellipse2D.Double.Double(double, double, double, double)
  • Ellipse2D.Double.Double()
  • Line2D.Double.Double(Point2D, Point2D)
  • Line2D.Double.Double(double, double, double, double)
  • Line2D.Double.Double()
  • Path2D.Double.Double(Shape, AffineTransform)
  • Path2D.Double.Double(Shape)
  • Path2D.Double.Double(int, int)
  • Path2D.Double.Double(int)
  • Path2D.Double.Double()
  • Point2D.Double.Double(double, double)
  • Point2D.Double.Double()
  • QuadCurve2D.Double.Double(double, double, double, double, double, double)
  • QuadCurve2D.Double.Double()
  • Rectangle2D.Double.Double(double, double, double, double)
  • Rectangle2D.Double.Double()
  • RoundRectangle2D.Double.Double(double, double, double, double, double, double)
  • RoundRectangle2D.Double.Double()


DOUBLE

DOUBLE o7planning.org
  • SimpleType.DOUBLE
  • Types.DOUBLE


DoubleAccumulator

DoubleAccumulator o7planning.org
  • DoubleAccumulator.DoubleAccumulator(DoubleBinaryOperator, double)


DoubleAdder

DoubleAdder o7planning.org
  • DoubleAdder.DoubleAdder()


DoubleClickListener

DoubleClickListener o7planning.org
  • BasicFileChooserUI.DoubleClickListener.DoubleClickListener(JList)


DoubleHolder

DoubleHolder o7planning.org
  • DoubleHolder.DoubleHolder(double)
  • DoubleHolder.DoubleHolder()


doubles

doubles o7planning.org
  • Random.doubles(double, double)
  • Random.doubles(long, double, double)
  • Random.doubles()
  • Random.doubles(long)
  • SplittableRandom.doubles(double, double)
  • SplittableRandom.doubles(long, double, double)
  • SplittableRandom.doubles()
  • SplittableRandom.doubles(long)
  • ThreadLocalRandom.doubles(double, double)
  • ThreadLocalRandom.doubles(long, double, double)
  • ThreadLocalRandom.doubles()
  • ThreadLocalRandom.doubles(long)


DoubleSeqHelper

DoubleSeqHelper o7planning.org
  • DoubleSeqHelper.DoubleSeqHelper()


DoubleSeqHolder

DoubleSeqHolder o7planning.org
  • DoubleSeqHolder.DoubleSeqHolder(double[])
  • DoubleSeqHolder.DoubleSeqHolder()


doubleStream

doubleStream o7planning.org
  • StreamSupport.doubleStream(Supplier<? extends Spliterator.OfDouble>, int, boolean)
  • StreamSupport.doubleStream(Spliterator.OfDouble, boolean)


DoubleSummaryStatistics

DoubleSummaryStatistics o7planning.org
  • DoubleSummaryStatistics.DoubleSummaryStatistics()


doubleToLongBits

doubleToLongBits o7planning.org
  • Double.doubleToLongBits(double)


doubleToRawLongBits

doubleToRawLongBits o7planning.org
  • Double.doubleToRawLongBits(double)


doubleValue

doubleValue o7planning.org
  • AtomicInteger.doubleValue()
  • AtomicLong.doubleValue()
  • BigDecimal.doubleValue()
  • BigInteger.doubleValue()
  • Byte.doubleValue()
  • Double.doubleValue()
  • DoubleAccumulator.doubleValue()
  • DoubleAdder.doubleValue()
  • Float.doubleValue()
  • Integer.doubleValue()
  • Long.doubleValue()
  • LongAccumulator.doubleValue()
  • LongAdder.doubleValue()
  • Number.doubleValue()
  • Short.doubleValue()


DOWN

DOWN o7planning.org
  • Event.DOWN


DOWN_CYCLE_TRAVERSAL_KEYS

DOWN_CYCLE_TRAVERSAL_KEYS o7planning.org
  • KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS


downAction

downAction o7planning.org
  • DefaultEditorKit.downAction


downFocusCycle

downFocusCycle o7planning.org
  • DefaultKeyboardFocusManager.downFocusCycle(Container)
  • KeyboardFocusManager.downFocusCycle()
  • KeyboardFocusManager.downFocusCycle(Container)


downKey

downKey o7planning.org
  • BasicSplitPaneUI.downKey
  • BasicTabbedPaneUI.downKey
  • BasicToolBarUI.downKey


DPCM

DPCM o7planning.org
  • ResolutionSyntax.DPCM


DPI

DPI o7planning.org
  • ResolutionSyntax.DPI


DRAFT

DRAFT o7planning.org
  • PageAttributes.PrintQualityType.DRAFT
  • PrintQuality.DRAFT


DRAG_LAYER

DRAG_LAYER o7planning.org
  • JLayeredPane.DRAG_LAYER


DragController

DragController o7planning.org
  • BasicSplitPaneDivider.DragController.DragController(MouseEvent)


dragDividerTo

dragDividerTo o7planning.org
  • BasicSplitPaneDivider.dragDividerTo(int)
  • BasicSplitPaneUI.dragDividerTo(int)


dragDropEnd

dragDropEnd o7planning.org
  • DragSourceAdapter.dragDropEnd(DragSourceDropEvent)
  • DragSourceContext.dragDropEnd(DragSourceDropEvent)
  • DragSourceListener.dragDropEnd(DragSourceDropEvent)


dragEnter

dragEnter o7planning.org
  • DragSourceAdapter.dragEnter(DragSourceDragEvent)
  • DragSourceContext.dragEnter(DragSourceDragEvent)
  • DragSourceListener.dragEnter(DragSourceDragEvent)
  • DropTarget.dragEnter(DropTargetDragEvent)
  • DropTargetAdapter.dragEnter(DropTargetDragEvent)
  • DropTargetListener.dragEnter(DropTargetDragEvent)


dragExit

dragExit o7planning.org
  • DragSourceAdapter.dragExit(DragSourceEvent)
  • DragSourceContext.dragExit(DragSourceEvent)
  • DragSourceListener.dragExit(DragSourceEvent)
  • DropTarget.dragExit(DropTargetEvent)
  • DropTargetAdapter.dragExit(DropTargetEvent)
  • DropTargetListener.dragExit(DropTargetEvent)


dragFrame

dragFrame o7planning.org
  • DefaultDesktopManager.dragFrame(JComponent, int, int)
  • DesktopManager.dragFrame(JComponent, int, int)


draggedColumn

draggedColumn o7planning.org
  • JTableHeader.draggedColumn


draggedDistance

draggedDistance o7planning.org
  • JTableHeader.draggedDistance


dragger

dragger o7planning.org
  • BasicSplitPaneDivider.dragger


DragGestureEvent

DragGestureEvent o7planning.org
  • DragGestureEvent.DragGestureEvent(DragGestureRecognizer, int, Point, List<? extends InputEvent>)


dragGestureListener

dragGestureListener o7planning.org
  • DragGestureRecognizer.dragGestureListener


dragGestureRecognized

dragGestureRecognized o7planning.org
  • DragGestureListener.dragGestureRecognized(DragGestureEvent)


DragGestureRecognizer

DragGestureRecognizer o7planning.org
  • DragGestureRecognizer.DragGestureRecognizer(DragSource)
  • DragGestureRecognizer.DragGestureRecognizer(DragSource, Component)
  • DragGestureRecognizer.DragGestureRecognizer(DragSource, Component, int)
  • DragGestureRecognizer.DragGestureRecognizer(DragSource, Component, int, DragGestureListener)


draggingHW

draggingHW o7planning.org
  • BasicSplitPaneUI.draggingHW


dragMouseMoved

dragMouseMoved o7planning.org
  • DragSourceAdapter.dragMouseMoved(DragSourceDragEvent)
  • DragSourceContext.dragMouseMoved(DragSourceDragEvent)
  • DragSourceMotionListener.dragMouseMoved(DragSourceDragEvent)


dragOver

dragOver o7planning.org
  • DragSourceAdapter.dragOver(DragSourceDragEvent)
  • DragSourceContext.dragOver(DragSourceDragEvent)
  • DragSourceListener.dragOver(DragSourceDragEvent)
  • DropTarget.dragOver(DropTargetDragEvent)
  • DropTargetAdapter.dragOver(DropTargetDragEvent)
  • DropTargetListener.dragOver(DropTargetDragEvent)


dragSource

dragSource o7planning.org
  • DragGestureRecognizer.dragSource


DragSource

DragSource o7planning.org
  • DragSource.DragSource()


DragSourceAdapter

DragSourceAdapter o7planning.org
  • DragSourceAdapter.DragSourceAdapter()


DragSourceContext

DragSourceContext o7planning.org
  • DragSourceContext.DragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener)


DragSourceDragEvent

DragSourceDragEvent o7planning.org
  • DragSourceDragEvent.DragSourceDragEvent(DragSourceContext, int, int, int, int, int)
  • DragSourceDragEvent.DragSourceDragEvent(DragSourceContext, int, int, int)


DragSourceDropEvent

DragSourceDropEvent o7planning.org
  • DragSourceDropEvent.DragSourceDropEvent(DragSourceContext)
  • DragSourceDropEvent.DragSourceDropEvent(DragSourceContext, int, boolean, int, int)
  • DragSourceDropEvent.DragSourceDropEvent(DragSourceContext, int, boolean)


DragSourceEvent

DragSourceEvent o7planning.org
  • DragSourceEvent.DragSourceEvent(DragSourceContext, int, int)
  • DragSourceEvent.DragSourceEvent(DragSourceContext)


dragTo

dragTo o7planning.org
  • BasicToolBarUI.dragTo(Point, Point)


dragWindow

dragWindow o7planning.org
  • BasicToolBarUI.dragWindow


drain

drain o7planning.org
  • DataLine.drain()
  • ObjectOutputStream.drain()


drainPermits

drainPermits o7planning.org
  • Semaphore.drainPermits()


drainTasksTo

drainTasksTo o7planning.org
  • ForkJoinPool.drainTasksTo(Collection<? super ForkJoinTask<?>>)


drainTo

drainTo o7planning.org
  • ArrayBlockingQueue.drainTo(Collection<? super E>, int)
  • ArrayBlockingQueue.drainTo(Collection<? super E>)
  • BlockingQueue.drainTo(Collection<? super E>, int)
  • BlockingQueue.drainTo(Collection<? super E>)
  • DelayQueue.drainTo(Collection<? super E>, int)
  • DelayQueue.drainTo(Collection<? super E>)
  • LinkedBlockingDeque.drainTo(Collection<? super E>, int)
  • LinkedBlockingDeque.drainTo(Collection<? super E>)
  • LinkedBlockingQueue.drainTo(Collection<? super E>, int)
  • LinkedBlockingQueue.drainTo(Collection<? super E>)
  • LinkedTransferQueue.drainTo(Collection<? super E>, int)
  • LinkedTransferQueue.drainTo(Collection<? super E>)
  • PriorityBlockingQueue.drainTo(Collection<? super E>, int)
  • PriorityBlockingQueue.drainTo(Collection<? super E>)
  • SynchronousQueue.drainTo(Collection<? super E>, int)
  • SynchronousQueue.drainTo(Collection<? super E>)


draw3DRect

draw3DRect o7planning.org
  • DebugGraphics.draw3DRect(int, int, int, int, boolean)
  • Graphics.draw3DRect(int, int, int, int, boolean)
  • Graphics2D.draw3DRect(int, int, int, int, boolean)


draw

draw o7planning.org
  • GraphicAttribute.draw(Graphics2D, float, float)
  • Graphics2D.draw(Shape)
  • ImageGraphicAttribute.draw(Graphics2D, float, float)
  • ShapeGraphicAttribute.draw(Graphics2D, float, float)
  • TextLayout.draw(Graphics2D, float, float)


drawArc

drawArc o7planning.org
  • DebugGraphics.drawArc(int, int, int, int, int, int)
  • Graphics.drawArc(int, int, int, int, int, int)


drawBezel

drawBezel o7planning.org
  • BasicGraphicsUtils.drawBezel(Graphics, int, int, int, int, boolean, boolean, Color, Color, Color, Color)


drawBuffer

drawBuffer o7planning.org
  • Component.FlipBufferStrategy.drawBuffer


drawBytes

drawBytes o7planning.org
  • DebugGraphics.drawBytes(byte[], int, int, int, int)
  • Graphics.drawBytes(byte[], int, int, int, int)


drawCentered

drawCentered o7planning.org
  • BasicTreeUI.drawCentered(Component, Graphics, Icon, int, int)
  • SynthTreeUI.drawCentered(Component, Graphics, Icon, int, int)


drawChars

drawChars o7planning.org
  • DebugGraphics.drawChars(char[], int, int, int, int)
  • Graphics.drawChars(char[], int, int, int, int)


drawCheck

drawCheck o7planning.org
  • MetalCheckBoxIcon.drawCheck(Component, Graphics, int, int)


drawDashedHorizontalLine

drawDashedHorizontalLine o7planning.org
  • BasicTreeUI.drawDashedHorizontalLine(Graphics, int, int, int)


drawDashedRect

drawDashedRect o7planning.org
  • BasicGraphicsUtils.drawDashedRect(Graphics, int, int, int, int)


drawDashedVerticalLine

drawDashedVerticalLine o7planning.org
  • BasicTreeUI.drawDashedVerticalLine(Graphics, int, int, int)


drawEchoCharacter

drawEchoCharacter o7planning.org
  • PasswordView.drawEchoCharacter(Graphics, int, int, char)


drawEtchedRect

drawEtchedRect o7planning.org
  • BasicGraphicsUtils.drawEtchedRect(Graphics, int, int, int, int, Color, Color, Color, Color)


drawGlyphVector

drawGlyphVector o7planning.org
  • Graphics2D.drawGlyphVector(GlyphVector, float, float)


drawGroove

drawGroove o7planning.org
  • BasicGraphicsUtils.drawGroove(Graphics, int, int, int, int, Color, Color)


drawImage

drawImage o7planning.org
  • DebugGraphics.drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver)
  • DebugGraphics.drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver)
  • DebugGraphics.drawImage(Image, int, int, int, int, Color, ImageObserver)
  • DebugGraphics.drawImage(Image, int, int, Color, ImageObserver)
  • DebugGraphics.drawImage(Image, int, int, int, int, ImageObserver)
  • DebugGraphics.drawImage(Image, int, int, ImageObserver)
  • Graphics.drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver)
  • Graphics.drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver)
  • Graphics.drawImage(Image, int, int, int, int, Color, ImageObserver)
  • Graphics.drawImage(Image, int, int, Color, ImageObserver)
  • Graphics.drawImage(Image, int, int, int, int, ImageObserver)
  • Graphics.drawImage(Image, int, int, ImageObserver)
  • Graphics2D.drawImage(BufferedImage, BufferedImageOp, int, int)
  • Graphics2D.drawImage(Image, AffineTransform, ImageObserver)


drawingCache

drawingCache o7planning.org
  • BasicTreeUI.drawingCache


drawInverted

drawInverted o7planning.org
  • BasicSliderUI.drawInverted()


drawLine

drawLine o7planning.org
  • DebugGraphics.drawLine(int, int, int, int)
  • Graphics.drawLine(int, int, int, int)
  • PlainView.drawLine(int, Graphics, int, int)
  • SynthGraphicsUtils.drawLine(SynthContext, Object, Graphics, int, int, int, int, Object)
  • SynthGraphicsUtils.drawLine(SynthContext, Object, Graphics, int, int, int, int)
  • WrappedPlainView.drawLine(int, int, Graphics, int, int)


drawLoweredBezel

drawLoweredBezel o7planning.org
  • BasicGraphicsUtils.drawLoweredBezel(Graphics, int, int, int, int, Color, Color, Color, Color)


drawOval

drawOval o7planning.org
  • DebugGraphics.drawOval(int, int, int, int)
  • Graphics.drawOval(int, int, int, int)


drawPolygon

drawPolygon o7planning.org
  • DebugGraphics.drawPolygon(int[], int[], int)
  • Graphics.drawPolygon(Polygon)
  • Graphics.drawPolygon(int[], int[], int)


drawPolyline

drawPolyline o7planning.org
  • DebugGraphics.drawPolyline(int[], int[], int)
  • Graphics.drawPolyline(int[], int[], int)


drawRect

drawRect o7planning.org
  • DebugGraphics.drawRect(int, int, int, int)
  • Graphics.drawRect(int, int, int, int)


drawRenderableImage

drawRenderableImage o7planning.org
  • Graphics2D.drawRenderableImage(RenderableImage, AffineTransform)


drawRenderedImage

drawRenderedImage o7planning.org
  • Graphics2D.drawRenderedImage(RenderedImage, AffineTransform)


drawRoundRect

drawRoundRect o7planning.org
  • DebugGraphics.drawRoundRect(int, int, int, int, int, int)
  • Graphics.drawRoundRect(int, int, int, int, int, int)


drawSelectedText

drawSelectedText o7planning.org
  • PasswordView.drawSelectedText(Graphics, int, int, int, int)
  • PlainView.drawSelectedText(Graphics, int, int, int, int)
  • WrappedPlainView.drawSelectedText(Graphics, int, int, int, int)


drawString

drawString o7planning.org
  • BasicGraphicsUtils.drawString(Graphics, String, int, int, int)
  • DebugGraphics.drawString(AttributedCharacterIterator, int, int)
  • DebugGraphics.drawString(String, int, int)
  • Graphics.drawString(AttributedCharacterIterator, int, int)
  • Graphics.drawString(String, int, int)
  • Graphics2D.drawString(AttributedCharacterIterator, float, float)
  • Graphics2D.drawString(AttributedCharacterIterator, int, int)
  • Graphics2D.drawString(String, float, float)
  • Graphics2D.drawString(String, int, int)


drawStringUnderlineCharAt

drawStringUnderlineCharAt o7planning.org
  • BasicGraphicsUtils.drawStringUnderlineCharAt(Graphics, String, int, int, int)


drawTabbedText

drawTabbedText o7planning.org
  • Utilities.drawTabbedText(Segment, int, int, Graphics, TabExpander, int)


drawUnselectedText

drawUnselectedText o7planning.org
  • PasswordView.drawUnselectedText(Graphics, int, int, int, int)
  • PlainView.drawUnselectedText(Graphics, int, int, int, int)
  • WrappedPlainView.drawUnselectedText(Graphics, int, int, int, int)


drawVBuffer

drawVBuffer o7planning.org
  • Component.FlipBufferStrategy.drawVBuffer


DriverPropertyInfo

DriverPropertyInfo o7planning.org
  • DriverPropertyInfo.DriverPropertyInfo(String, String)


drop

drop o7planning.org
  • DropTarget.drop(DropTargetDropEvent)
  • DropTargetListener.drop(DropTargetDropEvent)
  • MembershipKey.drop()


dropActionChanged

dropActionChanged o7planning.org
  • DragSourceAdapter.dropActionChanged(DragSourceDragEvent)
  • DragSourceContext.dropActionChanged(DragSourceDragEvent)
  • DragSourceListener.dropActionChanged(DragSourceDragEvent)
  • DropTarget.dropActionChanged(DropTargetDragEvent)
  • DropTargetAdapter.dropActionChanged(DropTargetDragEvent)
  • DropTargetListener.dropActionChanged(DropTargetDragEvent)


dropArguments

dropArguments o7planning.org
  • MethodHandles.dropArguments(MethodHandle, int, Class<?>...)
  • MethodHandles.dropArguments(MethodHandle, int, List<Class<?>>)


dropComplete

dropComplete o7planning.org
  • DropTargetContext.dropComplete(boolean)
  • DropTargetDropEvent.dropComplete(boolean)


DropLocation

DropLocation o7planning.org
  • TransferHandler.DropLocation.DropLocation(Point)


dropParameterTypes

dropParameterTypes o7planning.org
  • MethodType.dropParameterTypes(int, int)


DropTarget

DropTarget o7planning.org
  • DropTarget.DropTarget(Component, int, DropTargetListener)
  • DropTarget.DropTarget(Component, DropTargetListener)
  • DropTarget.DropTarget()
  • DropTarget.DropTarget(Component, int, DropTargetListener, boolean)
  • DropTarget.DropTarget(Component, int, DropTargetListener, boolean, FlavorMap)


DropTargetAdapter

DropTargetAdapter o7planning.org
  • DropTargetAdapter.DropTargetAdapter()


DropTargetAutoScroller

DropTargetAutoScroller o7planning.org
  • DropTarget.DropTargetAutoScroller.DropTargetAutoScroller(Component, Point)


DropTargetDragEvent

DropTargetDragEvent o7planning.org
  • DropTargetDragEvent.DropTargetDragEvent(DropTargetContext, Point, int, int)


DropTargetDropEvent

DropTargetDropEvent o7planning.org
  • DropTargetDropEvent.DropTargetDropEvent(DropTargetContext, Point, int, int, boolean)
  • DropTargetDropEvent.DropTargetDropEvent(DropTargetContext, Point, int, int)


DropTargetEvent

DropTargetEvent o7planning.org
  • DropTargetEvent.DropTargetEvent(DropTargetContext)


DSA_SHA1

DSA_SHA1 o7planning.org
  • SignatureMethod.DSA_SHA1


DSA_TYPE

DSA_TYPE o7planning.org
  • KeyValue.DSA_TYPE


DSAGenParameterSpec

DSAGenParameterSpec o7planning.org
  • DSAGenParameterSpec.DSAGenParameterSpec(int, int, int)
  • DSAGenParameterSpec.DSAGenParameterSpec(int, int)


DSAParameterSpec

DSAParameterSpec o7planning.org
  • DSAParameterSpec.DSAParameterSpec(BigInteger, BigInteger, BigInteger)


DSAPrivateKeySpec

DSAPrivateKeySpec o7planning.org
  • DSAPrivateKeySpec.DSAPrivateKeySpec(BigInteger, BigInteger, BigInteger, BigInteger)


DSAPublicKeySpec

DSAPublicKeySpec o7planning.org
  • DSAPublicKeySpec.DSAPublicKeySpec(BigInteger, BigInteger, BigInteger, BigInteger)


DST

DST o7planning.org
  • AlphaComposite.DST


Dst

Dst o7planning.org
  • AlphaComposite.Dst


DST_ATOP

DST_ATOP o7planning.org
  • AlphaComposite.DST_ATOP


DST_IN

DST_IN o7planning.org
  • AlphaComposite.DST_IN


DST_OFFSET

DST_OFFSET o7planning.org
  • Calendar.DST_OFFSET


DST_OUT

DST_OUT o7planning.org
  • AlphaComposite.DST_OUT


DST_OVER

DST_OVER o7planning.org
  • AlphaComposite.DST_OVER


DstAtop

DstAtop o7planning.org
  • AlphaComposite.DstAtop


DstIn

DstIn o7planning.org
  • AlphaComposite.DstIn


DstOut

DstOut o7planning.org
  • AlphaComposite.DstOut


DstOver

DstOver o7planning.org
  • AlphaComposite.DstOver


DT

DT o7planning.org
  • HTML.Tag.DT


DTD

DTD o7planning.org
  • XMLStreamConstants.DTD


dtd

dtd o7planning.org
  • Parser.dtd


DUMMY

DUMMY o7planning.org
  • HTML.Attribute.DUMMY


dump

dump o7planning.org
  • AbstractDocument.dump(PrintStream)
  • AbstractDocument.AbstractElement.dump(PrintStream, int)


dumpAllThreads

dumpAllThreads o7planning.org
  • ThreadMXBean.dumpAllThreads(boolean, boolean)


dumpStack

dumpStack o7planning.org
  • Thread.dumpStack()


DUPLEX

DUPLEX o7planning.org
  • Sides.DUPLEX


duplicate

duplicate o7planning.org
  • ByteBuffer.duplicate()
  • CharBuffer.duplicate()
  • Delegate.duplicate(Object)
  • DoubleBuffer.duplicate()
  • FloatBuffer.duplicate()
  • IntBuffer.duplicate()
  • LongBuffer.duplicate()
  • ShortBuffer.duplicate()


DUPLICATE_ELEMENT

DUPLICATE_ELEMENT o7planning.org
  • GSSException.DUPLICATE_ELEMENT


DUPLICATE_TOKEN

DUPLICATE_TOKEN o7planning.org
  • GSSException.DUPLICATE_TOKEN


DuplicateFormatFlagsException

DuplicateFormatFlagsException o7planning.org
  • DuplicateFormatFlagsException.DuplicateFormatFlagsException(String)


DuplicateName

DuplicateName o7planning.org
  • DuplicateName.DuplicateName(String, String)
  • DuplicateName.DuplicateName(String)
  • DuplicateName.DuplicateName()


DuplicateNameHelper

DuplicateNameHelper o7planning.org
  • DuplicateNameHelper.DuplicateNameHelper()


DURATION

DURATION o7planning.org
  • DatatypeConstants.DURATION


Duration

Duration o7planning.org
  • Duration.Duration()


DURATION_DAYTIME

DURATION_DAYTIME o7planning.org
  • DatatypeConstants.DURATION_DAYTIME


DURATION_YEARMONTH

DURATION_YEARMONTH o7planning.org
  • DatatypeConstants.DURATION_YEARMONTH


DYNAMIC_SOAP_PROTOCOL

DYNAMIC_SOAP_PROTOCOL o7planning.org
  • SOAPConstants.DYNAMIC_SOAP_PROTOCOL


DynamicImplementation

DynamicImplementation o7planning.org
  • DynamicImplementation.DynamicImplementation()
  • DynamicImplementation.DynamicImplementation()


dynamicInvoker

dynamicInvoker o7planning.org
  • CallSite.dynamicInvoker()
  • ConstantCallSite.dynamicInvoker()
  • MutableCallSite.dynamicInvoker()
  • VolatileCallSite.dynamicInvoker()


DynamicUtilTreeNode

DynamicUtilTreeNode o7planning.org
  • JTree.DynamicUtilTreeNode.DynamicUtilTreeNode(Object, Object)


DynAnyFactoryHelper

DynAnyFactoryHelper o7planning.org
  • DynAnyFactoryHelper.DynAnyFactoryHelper()


DynAnyHelper

DynAnyHelper o7planning.org
  • DynAnyHelper.DynAnyHelper()


DynAnySeqHelper

DynAnySeqHelper o7planning.org
  • DynAnySeqHelper.DynAnySeqHelper()


DynArrayHelper

DynArrayHelper o7planning.org
  • DynArrayHelper.DynArrayHelper()


DynEnumHelper

DynEnumHelper o7planning.org
  • DynEnumHelper.DynEnumHelper()


DynFixedHelper

DynFixedHelper o7planning.org
  • DynFixedHelper.DynFixedHelper()


DynSequenceHelper

DynSequenceHelper o7planning.org
  • DynSequenceHelper.DynSequenceHelper()


DynStructHelper

DynStructHelper o7planning.org
  • DynStructHelper.DynStructHelper()


DynUnionHelper

DynUnionHelper o7planning.org
  • DynUnionHelper.DynUnionHelper()


DynValueHelper

DynValueHelper o7planning.org
  • DynValueHelper.DynValueHelper()


E

E o7planning.org
  • Math.E
  • MediaSize.Engineering.E
  • MediaSizeName.E
  • PageAttributes.MediaType.E
  • StrictMath.E


E_RESIZE_CURSOR

E_RESIZE_CURSOR o7planning.org
  • Cursor.E_RESIZE_CURSOR
  • Frame.E_RESIZE_CURSOR


EAST

EAST o7planning.org
  • BorderLayout.EAST
  • GridBagConstraints.EAST
  • SpringLayout.EAST
  • SwingConstants.EAST


EASTERN_ARABIC

EASTERN_ARABIC o7planning.org
  • NumericShaper.EASTERN_ARABIC


eastPane

eastPane o7planning.org
  • BasicInternalFrameUI.eastPane


ECFieldF2m

ECFieldF2m o7planning.org
  • ECFieldF2m.ECFieldF2m(int, int[])
  • ECFieldF2m.ECFieldF2m(int, BigInteger)
  • ECFieldF2m.ECFieldF2m(int)


ECFieldFp

ECFieldFp o7planning.org
  • ECFieldFp.ECFieldFp(BigInteger)


ECGenParameterSpec

ECGenParameterSpec o7planning.org
  • ECGenParameterSpec.ECGenParameterSpec(String)


echoCharIsSet

echoCharIsSet o7planning.org
  • JPasswordField.echoCharIsSet()
  • TextField.echoCharIsSet()


ECParameterSpec

ECParameterSpec o7planning.org
  • ECParameterSpec.ECParameterSpec(EllipticCurve, ECPoint, BigInteger, int)


ECPoint

ECPoint o7planning.org
  • ECPoint.ECPoint(BigInteger, BigInteger)


ECPrivateKeySpec

ECPrivateKeySpec o7planning.org
  • ECPrivateKeySpec.ECPrivateKeySpec(BigInteger, ECParameterSpec)


ECPublicKeySpec

ECPublicKeySpec o7planning.org
  • ECPublicKeySpec.ECPublicKeySpec(ECPoint, ECParameterSpec)


EDGE_NO_OP

EDGE_NO_OP o7planning.org
  • ConvolveOp.EDGE_NO_OP


EDGE_SPACING

EDGE_SPACING o7planning.org
  • TitledBorder.EDGE_SPACING


EDGE_STITCH

EDGE_STITCH o7planning.org
  • Finishings.EDGE_STITCH


EDGE_STITCH_BOTTOM

EDGE_STITCH_BOTTOM o7planning.org
  • Finishings.EDGE_STITCH_BOTTOM


EDGE_STITCH_LEFT

EDGE_STITCH_LEFT o7planning.org
  • Finishings.EDGE_STITCH_LEFT


EDGE_STITCH_RIGHT

EDGE_STITCH_RIGHT o7planning.org
  • Finishings.EDGE_STITCH_RIGHT


EDGE_STITCH_TOP

EDGE_STITCH_TOP o7planning.org
  • Finishings.EDGE_STITCH_TOP


EDGE_ZERO_FILL

EDGE_ZERO_FILL o7planning.org
  • ConvolveOp.EDGE_ZERO_FILL


edit

edit o7planning.org
  • Desktop.edit(File)


EDITABLE

EDITABLE o7planning.org
  • AccessibleState.EDITABLE


editable

editable o7planning.org
  • JTree.editable


EDITABLE_PROPERTY

EDITABLE_PROPERTY o7planning.org
  • JTree.EDITABLE_PROPERTY


editablePropertyChanged

editablePropertyChanged o7planning.org
  • MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent)


EDITBAR

EDITBAR o7planning.org
  • AccessibleRole.EDITBAR


editCellAt

editCellAt o7planning.org
  • JTable.editCellAt(int, int, EventObject)
  • JTable.editCellAt(int, int)


editingCanceled

editingCanceled o7planning.org
  • BasicTreeUI.CellEditorHandler.editingCanceled(ChangeEvent)
  • CellEditorListener.editingCanceled(ChangeEvent)
  • JTable.editingCanceled(ChangeEvent)
  • JTable.AccessibleJTable.editingCanceled(ChangeEvent)


editingColumn

editingColumn o7planning.org
  • JTable.editingColumn


editingComponent

editingComponent o7planning.org
  • BasicTreeUI.editingComponent
  • DefaultTreeCellEditor.editingComponent


editingContainer

editingContainer o7planning.org
  • DefaultTreeCellEditor.editingContainer


editingIcon

editingIcon o7planning.org
  • DefaultTreeCellEditor.editingIcon


editingPath

editingPath o7planning.org
  • BasicTreeUI.editingPath


editingRow

editingRow o7planning.org
  • BasicTreeUI.editingRow
  • JTable.editingRow


editingStopped

editingStopped o7planning.org
  • BasicTreeUI.CellEditorHandler.editingStopped(ChangeEvent)
  • CellEditorListener.editingStopped(ChangeEvent)
  • JTable.editingStopped(ChangeEvent)
  • JTable.AccessibleJTable.editingStopped(ChangeEvent)


editor

editor o7planning.org
  • BasicComboBoxEditor.editor
  • BasicComboBoxUI.editor
  • JComboBox.editor


EDITOR_PANE

EDITOR_PANE o7planning.org
  • Region.EDITOR_PANE


editorBorderInsets

editorBorderInsets o7planning.org
  • MetalBorders.TableHeaderBorder.editorBorderInsets
  • MetalComboBoxEditor.editorBorderInsets


editorComp

editorComp o7planning.org
  • JTable.editorComp


editorComponent

editorComponent o7planning.org
  • DefaultCellEditor.editorComponent


EditorContainer

EditorContainer o7planning.org
  • DefaultTreeCellEditor.EditorContainer.EditorContainer()
  • DefaultTreeCellEditor.EditorContainer.EditorContainer()


EditorDelegate

EditorDelegate o7planning.org
  • DefaultCellEditor.EditorDelegate.EditorDelegate()


editorHasDifferentSize

editorHasDifferentSize o7planning.org
  • BasicTreeUI.editorHasDifferentSize


EditorKit

EditorKit o7planning.org
  • EditorKit.EditorKit()


edits

edits o7planning.org
  • CompoundEdit.edits


editToBeRedone

editToBeRedone o7planning.org
  • UndoManager.editToBeRedone()


editToBeUndone

editToBeUndone o7planning.org
  • UndoManager.editToBeUndone()


effective_profile

effective_profile o7planning.org
  • ClientRequestInfoOperations.effective_profile()


effective_target

effective_target o7planning.org
  • ClientRequestInfoOperations.effective_target()


EFFORT

EFFORT o7planning.org
  • Pack200.Packer.EFFORT


EGYPTIAN_HIEROGLYPHS

EGYPTIAN_HIEROGLYPHS o7planning.org
  • Character.UnicodeBlock.EGYPTIAN_HIEROGLYPHS


element

element o7planning.org
  • AbstractQueue.element()
  • AnnotationTypeMismatchException.element()
  • ArrayDeque.element()
  • BlockingDeque.element()
  • ConcurrentLinkedDeque.element()
  • DefaultStyledDocument.AttributeUndoableEdit.element
  • Deque.element()
  • LinkedBlockingDeque.element()
  • LinkedList.element()
  • Queue.element()
  • W3CEndpointReferenceBuilder.element(Element)


ELEMENT_NODE

ELEMENT_NODE o7planning.org
  • Node.ELEMENT_NODE


elementAt

elementAt o7planning.org
  • DefaultListModel.elementAt(int)
  • Vector.elementAt(int)


ElementBuffer

ElementBuffer o7planning.org
  • DefaultStyledDocument.ElementBuffer.ElementBuffer(Element)


elementCount

elementCount o7planning.org
  • Monitor.elementCount
  • Vector.elementCount


elementCountToTag

elementCountToTag o7planning.org
  • HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument, int, HTML.Tag)


elementData

elementData o7planning.org
  • Vector.elementData


elementDecl

elementDecl o7planning.org
  • DeclHandler.elementDecl(String, String)
  • DefaultHandler2.elementDecl(String, String)


ElementEdit

ElementEdit o7planning.org
  • AbstractDocument.ElementEdit.ElementEdit(Element, int, Element[], Element[])


elementHash

elementHash o7planning.org
  • DTD.elementHash


ElementIterator

ElementIterator o7planning.org
  • ElementIterator.ElementIterator(Element)
  • ElementIterator.ElementIterator(Document)


ElementKindVisitor6

ElementKindVisitor6 o7planning.org
  • ElementKindVisitor6.ElementKindVisitor6(R)
  • ElementKindVisitor6.ElementKindVisitor6()


ElementKindVisitor7

ElementKindVisitor7 o7planning.org
  • ElementKindVisitor7.ElementKindVisitor7(R)
  • ElementKindVisitor7.ElementKindVisitor7()


ElementKindVisitor8

ElementKindVisitor8 o7planning.org
  • ElementKindVisitor8.ElementKindVisitor8(R)
  • ElementKindVisitor8.ElementKindVisitor8()


elementName

elementName o7planning.org
  • IncompleteAnnotationException.elementName()


ElementNameAttribute

ElementNameAttribute o7planning.org
  • AbstractDocument.ElementNameAttribute


elements

elements o7planning.org
  • ConcurrentHashMap.elements()
  • DTD.elements
  • DefaultListModel.elements()
  • Dictionary.elements()
  • Hashtable.elements()
  • PermissionCollection.elements()
  • Permissions.elements()
  • Provider.elements()
  • Vector.elements()


ElementScanner6

ElementScanner6 o7planning.org
  • ElementScanner6.ElementScanner6(R)
  • ElementScanner6.ElementScanner6()


ElementScanner7

ElementScanner7 o7planning.org
  • ElementScanner7.ElementScanner7(R)
  • ElementScanner7.ElementScanner7()


ElementScanner8

ElementScanner8 o7planning.org
  • ElementScanner8.ElementScanner8(R)
  • ElementScanner8.ElementScanner8()


ElementSpec

ElementSpec o7planning.org
  • DefaultStyledDocument.ElementSpec.ElementSpec(AttributeSet, short, char[], int, int)
  • DefaultStyledDocument.ElementSpec.ElementSpec(AttributeSet, short, int)
  • DefaultStyledDocument.ElementSpec.ElementSpec(AttributeSet, short)


Ellipse2D

Ellipse2D o7planning.org
  • Ellipse2D.Ellipse2D()


EllipticCurve

EllipticCurve o7planning.org
  • EllipticCurve.EllipticCurve(ECField, BigInteger, BigInteger, byte[])
  • EllipticCurve.EllipticCurve(ECField, BigInteger, BigInteger)


EM

EM o7planning.org
  • HTML.Tag.EM


EMBEDDED_BY

EMBEDDED_BY o7planning.org
  • AccessibleRelation.EMBEDDED_BY


EMBEDDED_BY_PROPERTY

EMBEDDED_BY_PROPERTY o7planning.org
  • AccessibleRelation.EMBEDDED_BY_PROPERTY


EMBEDS

EMBEDS o7planning.org
  • AccessibleRelation.EMBEDS


EMBEDS_PROPERTY

EMBEDS_PROPERTY o7planning.org
  • AccessibleRelation.EMBEDS_PROPERTY


EMOTICONS

EMOTICONS o7planning.org
  • Character.UnicodeBlock.EMOTICONS


empty

empty o7planning.org
  • ContentModel.empty()
  • DoubleStream.empty()
  • IntStream.empty()
  • LongStream.empty()
  • Optional.empty()
  • OptionalDouble.empty()
  • OptionalInt.empty()
  • OptionalLong.empty()
  • Stack.empty()
  • Stream.empty()


EMPTY

EMPTY o7planning.org
  • DTDConstants.EMPTY
  • SimpleAttributeSet.EMPTY


EMPTY_DESCRIPTOR

EMPTY_DESCRIPTOR o7planning.org
  • ImmutableDescriptor.EMPTY_DESCRIPTOR


EMPTY_ENUMERATION

EMPTY_ENUMERATION o7planning.org
  • DefaultMutableTreeNode.EMPTY_ENUMERATION


EMPTY_LIST

EMPTY_LIST o7planning.org
  • Collections.EMPTY_LIST


EMPTY_MAP

EMPTY_MAP o7planning.org
  • Collections.EMPTY_MAP


EMPTY_SET

EMPTY_SET o7planning.org
  • Collections.EMPTY_SET


EmptyBorder

EmptyBorder o7planning.org
  • EmptyBorder.EmptyBorder(Insets)
  • EmptyBorder.EmptyBorder(int, int, int, int)


EmptyBorderUIResource

EmptyBorderUIResource o7planning.org
  • BorderUIResource.EmptyBorderUIResource.EmptyBorderUIResource(Insets)
  • BorderUIResource.EmptyBorderUIResource.EmptyBorderUIResource(int, int, int, int)


emptyDoubleSpliterator

emptyDoubleSpliterator o7planning.org
  • Spliterators.emptyDoubleSpliterator()


emptyEnumeration

emptyEnumeration o7planning.org
  • Collections.emptyEnumeration()


emptyIntSpliterator

emptyIntSpliterator o7planning.org
  • Spliterators.emptyIntSpliterator()


emptyIterator

emptyIterator o7planning.org
  • Collections.emptyIterator()


emptyList

emptyList o7planning.org
  • Collections.emptyList()


emptyListIterator

emptyListIterator o7planning.org
  • Collections.emptyListIterator()


emptyLongSpliterator

emptyLongSpliterator o7planning.org
  • Spliterators.emptyLongSpliterator()


emptyMap

emptyMap o7planning.org
  • Collections.emptyMap()


emptyNavigableMap

emptyNavigableMap o7planning.org
  • Collections.emptyNavigableMap()


emptyNavigableSet

emptyNavigableSet o7planning.org
  • Collections.emptyNavigableSet()


EmptySelectionModel

EmptySelectionModel o7planning.org
  • JTree.EmptySelectionModel.EmptySelectionModel()


emptySet

emptySet o7planning.org
  • Collections.emptySet()


emptySortedMap

emptySortedMap o7planning.org
  • Collections.emptySortedMap()


emptySortedSet

emptySortedSet o7planning.org
  • Collections.emptySortedSet()


emptySpliterator

emptySpliterator o7planning.org
  • Spliterators.emptySpliterator()


EmptyStackException

EmptyStackException o7planning.org
  • EmptyStackException.EmptyStackException()


emptyTag

emptyTag o7planning.org
  • HTMLWriter.emptyTag(Element)


enable

enable o7planning.org
  • Compiler.enable()
  • Component.enable(boolean)
  • Component.enable()
  • JComponent.enable()
  • MenuItem.enable(boolean)
  • MenuItem.enable()


enableActions

enableActions o7planning.org
  • BasicInternalFrameTitlePane.enableActions()


enableAllObjectNames

enableAllObjectNames o7planning.org
  • MBeanServerNotificationFilter.enableAllObjectNames()


enableAttribute

enableAttribute o7planning.org
  • AttributeChangeNotificationFilter.enableAttribute(String)


enableClientWindowNotification

enableClientWindowNotification o7planning.org
  • InputMethodContext.enableClientWindowNotification(InputMethod, boolean)


ENABLED

ENABLED o7planning.org
  • DefaultButtonModel.ENABLED
  • SynthConstants.ENABLED


enabled

enabled o7planning.org
  • WebServiceFeature.enabled


enableEvents

enableEvents o7planning.org
  • Component.enableEvents(long)
  • MenuItem.enableEvents(long)


enableInputMethods

enableInputMethods o7planning.org
  • Component.enableInputMethods(boolean)
  • TextComponent.enableInputMethods(boolean)


enableObjectName

enableObjectName o7planning.org
  • MBeanServerNotificationFilter.enableObjectName(ObjectName)


enableReplaceObject

enableReplaceObject o7planning.org
  • ObjectOutputStream.enableReplaceObject(boolean)


enableResizedPosting

enableResizedPosting o7planning.org
  • TableColumn.enableResizedPosting()


enableResolveObject

enableResolveObject o7planning.org
  • ObjectInputStream.enableResolveObject(boolean)


enableType

enableType o7planning.org
  • NotificationFilterSupport.enableType(String)


ENCLOSED_ALPHANUMERIC_SUPPLEMENT

ENCLOSED_ALPHANUMERIC_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.ENCLOSED_ALPHANUMERIC_SUPPLEMENT


ENCLOSED_ALPHANUMERICS

ENCLOSED_ALPHANUMERICS o7planning.org
  • Character.UnicodeBlock.ENCLOSED_ALPHANUMERICS


ENCLOSED_CJK_LETTERS_AND_MONTHS

ENCLOSED_CJK_LETTERS_AND_MONTHS o7planning.org
  • Character.UnicodeBlock.ENCLOSED_CJK_LETTERS_AND_MONTHS


ENCLOSED_IDEOGRAPHIC_SUPPLEMENT

ENCLOSED_IDEOGRAPHIC_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.ENCLOSED_IDEOGRAPHIC_SUPPLEMENT


ENCLOSING_MARK

ENCLOSING_MARK o7planning.org
  • Character.ENCLOSING_MARK


encode

encode o7planning.org
  • Base64.Encoder.encode(ByteBuffer)
  • Base64.Encoder.encode(byte[], byte[])
  • Base64.Encoder.encode(byte[])
  • Certificate.encode(OutputStream)
  • Charset.encode(String)
  • Charset.encode(CharBuffer)
  • CharsetEncoder.encode(CharBuffer)
  • CharsetEncoder.encode(CharBuffer, ByteBuffer, boolean)
  • CodecOperations.encode(Any)
  • Extension.encode(OutputStream)
  • URLEncoder.encode(String, String)
  • URLEncoder.encode(String)


encode_value

encode_value o7planning.org
  • CodecOperations.encode_value(Any)


encodeDataFlavor

encodeDataFlavor o7planning.org
  • SystemFlavorMap.encodeDataFlavor(DataFlavor)


EncodedKeySpec

EncodedKeySpec o7planning.org
  • EncodedKeySpec.EncodedKeySpec(byte[])


encodedParams

encodedParams o7planning.org
  • SealedObject.encodedParams


encodeJavaMIMEType

encodeJavaMIMEType o7planning.org
  • SystemFlavorMap.encodeJavaMIMEType(String)


encodeLoop

encodeLoop o7planning.org
  • CharsetEncoder.encodeLoop(CharBuffer, ByteBuffer)


Encoder

Encoder o7planning.org
  • Encoder.Encoder()


encodeToString

encodeToString o7planning.org
  • Base64.Encoder.encodeToString(byte[])


encoding

encoding o7planning.org
  • AudioFormat.encoding


Encoding

Encoding o7planning.org
  • Encoding.Encoding(short, byte, byte)
  • Encoding.Encoding()


ENCODING

ENCODING o7planning.org
  • OutputKeys.ENCODING


encodingSet

encodingSet o7planning.org
  • StartDocument.encodingSet()


ENCRYPT

ENCRYPT o7planning.org
  • KeySelector.Purpose.ENCRYPT


ENCRYPT_MODE

ENCRYPT_MODE o7planning.org
  • Cipher.ENCRYPT_MODE


EncryptedPrivateKeyInfo

EncryptedPrivateKeyInfo o7planning.org
  • EncryptedPrivateKeyInfo.EncryptedPrivateKeyInfo(AlgorithmParameters, byte[])
  • EncryptedPrivateKeyInfo.EncryptedPrivateKeyInfo(String, byte[])
  • EncryptedPrivateKeyInfo.EncryptedPrivateKeyInfo(byte[])


ENCTYPE

ENCTYPE o7planning.org
  • HTML.Attribute.ENCTYPE


END

END o7planning.org
  • Event.END


end

end o7planning.org
  • AbstractInterruptibleChannel.end(boolean)
  • AbstractSelector.end()
  • CompoundEdit.end()
  • Deflater.end()
  • HTMLDocument.HTMLReader.BlockAction.end(HTML.Tag)
  • HTMLDocument.HTMLReader.CharacterAction.end(HTML.Tag)
  • HTMLDocument.HTMLReader.FormAction.end(HTML.Tag)
  • HTMLDocument.HTMLReader.HiddenAction.end(HTML.Tag)
  • HTMLDocument.HTMLReader.ParagraphAction.end(HTML.Tag)
  • HTMLDocument.HTMLReader.PreAction.end(HTML.Tag)
  • HTMLDocument.HTMLReader.TagAction.end(HTML.Tag)
  • Inflater.end()
  • MatchResult.end(int)
  • MatchResult.end()
  • Matcher.end(String)
  • Matcher.end(int)
  • Matcher.end()
  • PrintJob.end()
  • StateEdit.end()
  • UndoManager.end()
  • XAResource.end(Xid, int)


END_DOCUMENT

END_DOCUMENT o7planning.org
  • XMLStreamConstants.END_DOCUMENT


END_ELEMENT

END_ELEMENT o7planning.org
  • XMLStreamConstants.END_ELEMENT


END_OF_EXCLUSIVE

END_OF_EXCLUSIVE o7planning.org
  • ShortMessage.END_OF_EXCLUSIVE


END_PUNCTUATION

END_PUNCTUATION o7planning.org
  • Character.END_PUNCTUATION


end_value

end_value o7planning.org
  • ValueInputStream.end_value()
  • ValueOutputStream.end_value()


endAction

endAction o7planning.org
  • DefaultEditorKit.endAction


endCDATA

endCDATA o7planning.org
  • DefaultHandler2.endCDATA()
  • LexicalHandler.endCDATA()


endComposition

endComposition o7planning.org
  • InputContext.endComposition()
  • InputMethod.endComposition()


endDocument

endDocument o7planning.org
  • ContentHandler.endDocument()
  • DefaultHandler.endDocument()
  • DocumentHandler.endDocument()
  • HandlerBase.endDocument()
  • ParserAdapter.endDocument()
  • XMLFilterImpl.endDocument()
  • XMLReaderAdapter.endDocument()


endDraggingFrame

endDraggingFrame o7planning.org
  • DefaultDesktopManager.endDraggingFrame(JComponent)
  • DesktopManager.endDraggingFrame(JComponent)


endDTD

endDTD o7planning.org
  • DefaultHandler2.endDTD()
  • LexicalHandler.endDTD()


endElement

endElement o7planning.org
  • ContentHandler.endElement(String, String, String)
  • DefaultHandler.endElement(String, String, String)
  • DocumentHandler.endElement(String)
  • HandlerBase.endElement(String)
  • ParserAdapter.endElement(String)
  • XMLFilterImpl.endElement(String, String, String)
  • XMLReaderAdapter.endElement(String, String, String)


endEntity

endEntity o7planning.org
  • DefaultHandler2.endEntity(String)
  • LexicalHandler.endEntity(String)


endFontTag

endFontTag o7planning.org
  • MinimalHTMLWriter.endFontTag()


endIndex

endIndex o7planning.org
  • AccessibleAttributeSequence.endIndex
  • AccessibleTextSequence.endIndex


endInsertEmpty

endInsertEmpty o7planning.org
  • ImageWriter.endInsertEmpty()


endKey

endKey o7planning.org
  • BasicSplitPaneUI.endKey


endLineAction

endLineAction o7planning.org
  • DefaultEditorKit.endLineAction


EndOfLineStringProperty

EndOfLineStringProperty o7planning.org
  • DefaultEditorKit.EndOfLineStringProperty


endParagraphAction

endParagraphAction o7planning.org
  • DefaultEditorKit.endParagraphAction


Endpoint

Endpoint o7planning.org
  • Endpoint.Endpoint()


ENDPOINT_ADDRESS_PROPERTY

ENDPOINT_ADDRESS_PROPERTY o7planning.org
  • BindingProvider.ENDPOINT_ADDRESS_PROPERTY


EndpointContext

EndpointContext o7planning.org
  • EndpointContext.EndpointContext()


endpointName

endpointName o7planning.org
  • W3CEndpointReferenceBuilder.endpointName(QName)


EndpointReference

EndpointReference o7planning.org
  • EndpointReference.EndpointReference()


endPrefixMapping

endPrefixMapping o7planning.org
  • ContentHandler.endPrefixMapping(String)
  • DefaultHandler.endPrefixMapping(String)
  • XMLFilterImpl.endPrefixMapping(String)
  • XMLReaderAdapter.endPrefixMapping(String)


endReplacePixels

endReplacePixels o7planning.org
  • ImageWriter.endReplacePixels()


endResizingFrame

endResizingFrame o7planning.org
  • DefaultDesktopManager.endResizingFrame(JComponent)
  • DesktopManager.endResizingFrame(JComponent)


endsWith

endsWith o7planning.org
  • CompositeName.endsWith(Name)
  • CompoundName.endsWith(Name)
  • LdapName.endsWith(List<Rdn>)
  • LdapName.endsWith(Name)
  • Name.endsWith(Name)
  • Path.endsWith(String)
  • Path.endsWith(Path)
  • String.endsWith(String)


ENDTAG

ENDTAG o7planning.org
  • DTDConstants.ENDTAG


endTag

endTag o7planning.org
  • Parser.endTag(boolean)


EndTagType

EndTagType o7planning.org
  • DefaultStyledDocument.ElementSpec.EndTagType


endUpdate

endUpdate o7planning.org
  • UndoableEditSupport.endUpdate()


endWordAction

endWordAction o7planning.org
  • DefaultEditorKit.endWordAction


endWriteEmpty

endWriteEmpty o7planning.org
  • ImageWriter.endWriteEmpty()


endWriteSequence

endWriteSequence o7planning.org
  • ImageWriter.endWriteSequence()


ENGINE

ENGINE o7planning.org
  • ScriptEngine.ENGINE


ENGINE_SCOPE

ENGINE_SCOPE o7planning.org
  • ScriptContext.ENGINE_SCOPE


ENGINE_VERSION

ENGINE_VERSION o7planning.org
  • ScriptEngine.ENGINE_VERSION


engineAliases

engineAliases o7planning.org
  • KeyStoreSpi.engineAliases()


engineBuild

engineBuild o7planning.org
  • CertPathBuilderSpi.engineBuild(CertPathParameters)


engineContainsAlias

engineContainsAlias o7planning.org
  • KeyStoreSpi.engineContainsAlias(String)


engineCreateSSLEngine

engineCreateSSLEngine o7planning.org
  • SSLContextSpi.engineCreateSSLEngine(String, int)
  • SSLContextSpi.engineCreateSSLEngine()


engineDeleteEntry

engineDeleteEntry o7planning.org
  • KeyStoreSpi.engineDeleteEntry(String)


engineDigest

engineDigest o7planning.org
  • MessageDigestSpi.engineDigest(byte[], int, int)
  • MessageDigestSpi.engineDigest()


engineDoFinal

engineDoFinal o7planning.org
  • CipherSpi.engineDoFinal(ByteBuffer, ByteBuffer)
  • CipherSpi.engineDoFinal(byte[], int, int, byte[], int)
  • CipherSpi.engineDoFinal(byte[], int, int)
  • MacSpi.engineDoFinal()


engineDoPhase

engineDoPhase o7planning.org
  • KeyAgreementSpi.engineDoPhase(Key, boolean)


engineEntryInstanceOf

engineEntryInstanceOf o7planning.org
  • KeyStoreSpi.engineEntryInstanceOf(String, Class<? extends KeyStore.Entry>)


engineGenerateCertificate

engineGenerateCertificate o7planning.org
  • CertificateFactorySpi.engineGenerateCertificate(InputStream)


engineGenerateCertificates

engineGenerateCertificates o7planning.org
  • CertificateFactorySpi.engineGenerateCertificates(InputStream)


engineGenerateCertPath

engineGenerateCertPath o7planning.org
  • CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate>)
  • CertificateFactorySpi.engineGenerateCertPath(InputStream, String)
  • CertificateFactorySpi.engineGenerateCertPath(InputStream)


engineGenerateCRL

engineGenerateCRL o7planning.org
  • CertificateFactorySpi.engineGenerateCRL(InputStream)


engineGenerateCRLs

engineGenerateCRLs o7planning.org
  • CertificateFactorySpi.engineGenerateCRLs(InputStream)


engineGenerateKey

engineGenerateKey o7planning.org
  • KeyGeneratorSpi.engineGenerateKey()


engineGenerateParameters

engineGenerateParameters o7planning.org
  • AlgorithmParameterGeneratorSpi.engineGenerateParameters()


engineGeneratePrivate

engineGeneratePrivate o7planning.org
  • KeyFactorySpi.engineGeneratePrivate(KeySpec)


engineGeneratePublic

engineGeneratePublic o7planning.org
  • KeyFactorySpi.engineGeneratePublic(KeySpec)


engineGenerateSecret

engineGenerateSecret o7planning.org
  • KeyAgreementSpi.engineGenerateSecret(String)
  • KeyAgreementSpi.engineGenerateSecret(byte[], int)
  • KeyAgreementSpi.engineGenerateSecret()
  • SecretKeyFactorySpi.engineGenerateSecret(KeySpec)


engineGenerateSeed

engineGenerateSeed o7planning.org
  • SecureRandomSpi.engineGenerateSeed(int)


engineGenExemptionBlob

engineGenExemptionBlob o7planning.org
  • ExemptionMechanismSpi.engineGenExemptionBlob(byte[], int)
  • ExemptionMechanismSpi.engineGenExemptionBlob()


engineGetAppConfigurationEntry

engineGetAppConfigurationEntry o7planning.org
  • ConfigurationSpi.engineGetAppConfigurationEntry(String)


engineGetBlockSize

engineGetBlockSize o7planning.org
  • CipherSpi.engineGetBlockSize()


engineGetCertificate

engineGetCertificate o7planning.org
  • KeyStoreSpi.engineGetCertificate(String)


engineGetCertificateAlias

engineGetCertificateAlias o7planning.org
  • KeyStoreSpi.engineGetCertificateAlias(Certificate)


engineGetCertificateChain

engineGetCertificateChain o7planning.org
  • KeyStoreSpi.engineGetCertificateChain(String)


engineGetCertificates

engineGetCertificates o7planning.org
  • CertStoreSpi.engineGetCertificates(CertSelector)


engineGetCertPathEncodings

engineGetCertPathEncodings o7planning.org
  • CertificateFactorySpi.engineGetCertPathEncodings()


engineGetClientSessionContext

engineGetClientSessionContext o7planning.org
  • SSLContextSpi.engineGetClientSessionContext()


engineGetCreationDate

engineGetCreationDate o7planning.org
  • KeyStoreSpi.engineGetCreationDate(String)


engineGetCRLs

engineGetCRLs o7planning.org
  • CertStoreSpi.engineGetCRLs(CRLSelector)


engineGetDefaultSSLParameters

engineGetDefaultSSLParameters o7planning.org
  • SSLContextSpi.engineGetDefaultSSLParameters()


engineGetDigestLength

engineGetDigestLength o7planning.org
  • MessageDigestSpi.engineGetDigestLength()


engineGetEncoded

engineGetEncoded o7planning.org
  • AlgorithmParametersSpi.engineGetEncoded(String)
  • AlgorithmParametersSpi.engineGetEncoded()


engineGetEntry

engineGetEntry o7planning.org
  • KeyStoreSpi.engineGetEntry(String, KeyStore.ProtectionParameter)


engineGetIV

engineGetIV o7planning.org
  • CipherSpi.engineGetIV()


engineGetKey

engineGetKey o7planning.org
  • KeyStoreSpi.engineGetKey(String, char[])


engineGetKeyManagers

engineGetKeyManagers o7planning.org
  • KeyManagerFactorySpi.engineGetKeyManagers()


engineGetKeySize

engineGetKeySize o7planning.org
  • CipherSpi.engineGetKeySize(Key)


engineGetKeySpec

engineGetKeySpec o7planning.org
  • KeyFactorySpi.engineGetKeySpec(Key, Class<T>)
  • SecretKeyFactorySpi.engineGetKeySpec(SecretKey, Class<?>)


engineGetMacLength

engineGetMacLength o7planning.org
  • MacSpi.engineGetMacLength()


engineGetOutputSize

engineGetOutputSize o7planning.org
  • CipherSpi.engineGetOutputSize(int)
  • ExemptionMechanismSpi.engineGetOutputSize(int)


engineGetParameter

engineGetParameter o7planning.org
  • SignatureSpi.engineGetParameter(String)


engineGetParameters

engineGetParameters o7planning.org
  • CipherSpi.engineGetParameters()
  • SignatureSpi.engineGetParameters()


engineGetParameterSpec

engineGetParameterSpec o7planning.org
  • AlgorithmParametersSpi.engineGetParameterSpec(Class<T>)


engineGetPermissions

engineGetPermissions o7planning.org
  • PolicySpi.engineGetPermissions(ProtectionDomain)
  • PolicySpi.engineGetPermissions(CodeSource)


engineGetRevocationChecker

engineGetRevocationChecker o7planning.org
  • CertPathBuilderSpi.engineGetRevocationChecker()
  • CertPathValidatorSpi.engineGetRevocationChecker()


engineGetServerSessionContext

engineGetServerSessionContext o7planning.org
  • SSLContextSpi.engineGetServerSessionContext()


engineGetServerSocketFactory

engineGetServerSocketFactory o7planning.org
  • SSLContextSpi.engineGetServerSocketFactory()


engineGetSocketFactory

engineGetSocketFactory o7planning.org
  • SSLContextSpi.engineGetSocketFactory()


engineGetSupportedSSLParameters

engineGetSupportedSSLParameters o7planning.org
  • SSLContextSpi.engineGetSupportedSSLParameters()


engineGetTrustManagers

engineGetTrustManagers o7planning.org
  • TrustManagerFactorySpi.engineGetTrustManagers()


engineImplies

engineImplies o7planning.org
  • PolicySpi.engineImplies(ProtectionDomain, Permission)


engineInit

engineInit o7planning.org
  • AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec, SecureRandom)
  • AlgorithmParameterGeneratorSpi.engineInit(int, SecureRandom)
  • AlgorithmParametersSpi.engineInit(byte[], String)
  • AlgorithmParametersSpi.engineInit(byte[])
  • AlgorithmParametersSpi.engineInit(AlgorithmParameterSpec)
  • CipherSpi.engineInit(int, Key, AlgorithmParameters, SecureRandom)
  • CipherSpi.engineInit(int, Key, AlgorithmParameterSpec, SecureRandom)
  • CipherSpi.engineInit(int, Key, SecureRandom)
  • ExemptionMechanismSpi.engineInit(Key, AlgorithmParameters)
  • ExemptionMechanismSpi.engineInit(Key, AlgorithmParameterSpec)
  • ExemptionMechanismSpi.engineInit(Key)
  • KeyAgreementSpi.engineInit(Key, AlgorithmParameterSpec, SecureRandom)
  • KeyAgreementSpi.engineInit(Key, SecureRandom)
  • KeyGeneratorSpi.engineInit(int, SecureRandom)
  • KeyGeneratorSpi.engineInit(AlgorithmParameterSpec, SecureRandom)
  • KeyGeneratorSpi.engineInit(SecureRandom)
  • KeyManagerFactorySpi.engineInit(ManagerFactoryParameters)
  • KeyManagerFactorySpi.engineInit(KeyStore, char[])
  • MacSpi.engineInit(Key, AlgorithmParameterSpec)
  • SSLContextSpi.engineInit(KeyManager[], TrustManager[], SecureRandom)
  • TrustManagerFactorySpi.engineInit(ManagerFactoryParameters)
  • TrustManagerFactorySpi.engineInit(KeyStore)


engineInitSign

engineInitSign o7planning.org
  • SignatureSpi.engineInitSign(PrivateKey, SecureRandom)
  • SignatureSpi.engineInitSign(PrivateKey)


engineInitVerify

engineInitVerify o7planning.org
  • SignatureSpi.engineInitVerify(PublicKey)


engineIsCertificateEntry

engineIsCertificateEntry o7planning.org
  • KeyStoreSpi.engineIsCertificateEntry(String)


engineIsKeyEntry

engineIsKeyEntry o7planning.org
  • KeyStoreSpi.engineIsKeyEntry(String)


engineLoad

engineLoad o7planning.org
  • KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter)
  • KeyStoreSpi.engineLoad(InputStream, char[])


engineNextBytes

engineNextBytes o7planning.org
  • SecureRandomSpi.engineNextBytes(byte[])


engineRefresh

engineRefresh o7planning.org
  • ConfigurationSpi.engineRefresh()
  • PolicySpi.engineRefresh()


engineReset

engineReset o7planning.org
  • MacSpi.engineReset()
  • MessageDigestSpi.engineReset()


engineScope

engineScope o7planning.org
  • SimpleScriptContext.engineScope


engineSetCertificateEntry

engineSetCertificateEntry o7planning.org
  • KeyStoreSpi.engineSetCertificateEntry(String, Certificate)


engineSetEntry

engineSetEntry o7planning.org
  • KeyStoreSpi.engineSetEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter)


engineSetKeyEntry

engineSetKeyEntry o7planning.org
  • KeyStoreSpi.engineSetKeyEntry(String, byte[], Certificate[])
  • KeyStoreSpi.engineSetKeyEntry(String, Key, char[], Certificate[])


engineSetMode

engineSetMode o7planning.org
  • CipherSpi.engineSetMode(String)


engineSetPadding

engineSetPadding o7planning.org
  • CipherSpi.engineSetPadding(String)


engineSetParameter

engineSetParameter o7planning.org
  • SignatureSpi.engineSetParameter(AlgorithmParameterSpec)
  • SignatureSpi.engineSetParameter(String, Object)


engineSetSeed

engineSetSeed o7planning.org
  • SecureRandomSpi.engineSetSeed(byte[])


engineSign

engineSign o7planning.org
  • SignatureSpi.engineSign(byte[], int, int)
  • SignatureSpi.engineSign()


engineSize

engineSize o7planning.org
  • KeyStoreSpi.engineSize()


engineStore

engineStore o7planning.org
  • KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter)
  • KeyStoreSpi.engineStore(OutputStream, char[])


engineToString

engineToString o7planning.org
  • AlgorithmParametersSpi.engineToString()


engineTranslateKey

engineTranslateKey o7planning.org
  • KeyFactorySpi.engineTranslateKey(Key)
  • SecretKeyFactorySpi.engineTranslateKey(SecretKey)


engineUnwrap

engineUnwrap o7planning.org
  • CipherSpi.engineUnwrap(byte[], String, int)


engineUpdate

engineUpdate o7planning.org
  • CipherSpi.engineUpdate(ByteBuffer, ByteBuffer)
  • CipherSpi.engineUpdate(byte[], int, int, byte[], int)
  • CipherSpi.engineUpdate(byte[], int, int)
  • MacSpi.engineUpdate(ByteBuffer)
  • MacSpi.engineUpdate(byte[], int, int)
  • MacSpi.engineUpdate(byte)
  • MessageDigestSpi.engineUpdate(ByteBuffer)
  • MessageDigestSpi.engineUpdate(byte[], int, int)
  • MessageDigestSpi.engineUpdate(byte)
  • SignatureSpi.engineUpdate(ByteBuffer)
  • SignatureSpi.engineUpdate(byte[], int, int)
  • SignatureSpi.engineUpdate(byte)


engineUpdateAAD

engineUpdateAAD o7planning.org
  • CipherSpi.engineUpdateAAD(ByteBuffer)
  • CipherSpi.engineUpdateAAD(byte[], int, int)


engineValidate

engineValidate o7planning.org
  • CertPathValidatorSpi.engineValidate(CertPath, CertPathParameters)


engineVerify

engineVerify o7planning.org
  • SignatureSpi.engineVerify(byte[], int, int)
  • SignatureSpi.engineVerify(byte[])


engineWrap

engineWrap o7planning.org
  • CipherSpi.engineWrap(Key)


ENGLISH

ENGLISH o7planning.org
  • Locale.ENGLISH


enqueue

enqueue o7planning.org
  • Reference.enqueue()


enqueueKeyEvents

enqueueKeyEvents o7planning.org
  • DefaultKeyboardFocusManager.enqueueKeyEvents(long, Component)
  • KeyboardFocusManager.enqueueKeyEvents(long, Component)


ensureCapacity

ensureCapacity o7planning.org
  • ArrayList.ensureCapacity(int)
  • DefaultListModel.ensureCapacity(int)
  • StringBuffer.ensureCapacity(int)
  • Vector.ensureCapacity(int)


ensureFileIsVisible

ensureFileIsVisible o7planning.org
  • BasicFileChooserUI.ensureFileIsVisible(JFileChooser, File)
  • FileChooserUI.ensureFileIsVisible(JFileChooser, File)
  • JFileChooser.ensureFileIsVisible(File)
  • MetalFileChooserUI.ensureFileIsVisible(JFileChooser, File)
  • MultiFileChooserUI.ensureFileIsVisible(JFileChooser, File)


ensureIndexIsVisible

ensureIndexIsVisible o7planning.org
  • JList.ensureIndexIsVisible(int)


ensureRowsAreVisible

ensureRowsAreVisible o7planning.org
  • BasicTreeUI.ensureRowsAreVisible(int, int)


ENTER

ENTER o7planning.org
  • DragSourceContext.ENTER
  • Event.ENTER


enter

enter o7planning.org
  • SecondaryLoop.enter()


ENTERED

ENTERED o7planning.org
  • HyperlinkEvent.EventType.ENTERED


entering

entering o7planning.org
  • Logger.entering(String, String, Object[])
  • Logger.entering(String, String, Object)
  • Logger.entering(String, String)


ENTITIES

ENTITIES o7planning.org
  • DTDConstants.ENTITIES


ENTITY

ENTITY o7planning.org
  • DTDConstants.ENTITY


Entity

Entity o7planning.org
  • Entity.Entity(String, int, char[])


ENTITY_DECLARATION

ENTITY_DECLARATION o7planning.org
  • XMLStreamConstants.ENTITY_DECLARATION


ENTITY_NODE

ENTITY_NODE o7planning.org
  • Node.ENTITY_NODE


ENTITY_REFERENCE

ENTITY_REFERENCE o7planning.org
  • XMLStreamConstants.ENTITY_REFERENCE


ENTITY_REFERENCE_NODE

ENTITY_REFERENCE_NODE o7planning.org
  • Node.ENTITY_REFERENCE_NODE


entityHash

entityHash o7planning.org
  • DTD.entityHash


entries

entries o7planning.org
  • Acl.entries()
  • JarFile.entries()
  • ZipFile.entries()


Entry

Entry o7planning.org
  • RowFilter.Entry.Entry()


ENTRY_CREATE

ENTRY_CREATE o7planning.org
  • StandardWatchEventKinds.ENTRY_CREATE


ENTRY_DELETE

ENTRY_DELETE o7planning.org
  • StandardWatchEventKinds.ENTRY_DELETE


ENTRY_MODIFY

ENTRY_MODIFY o7planning.org
  • StandardWatchEventKinds.ENTRY_MODIFY


entryInstanceOf

entryInstanceOf o7planning.org
  • KeyStore.entryInstanceOf(String, Class<? extends KeyStore.Entry>)


entrySet

entrySet o7planning.org
  • AbstractMap.entrySet()
  • Attributes.entrySet()
  • ConcurrentHashMap.entrySet()
  • ConcurrentSkipListMap.entrySet()
  • EnumMap.entrySet()
  • HashMap.entrySet()
  • Hashtable.entrySet()
  • IdentityHashMap.entrySet()
  • LinkedHashMap.entrySet()
  • Map.entrySet()
  • Provider.entrySet()
  • RenderingHints.entrySet()
  • SimpleBindings.entrySet()
  • SortedMap.entrySet()
  • TabularDataSupport.entrySet()
  • TreeMap.entrySet()
  • WeakHashMap.entrySet()


Enum

Enum o7planning.org
  • Enum.Enum(String, int)


EnumConstantNotPresentException

EnumConstantNotPresentException o7planning.org
  • EnumConstantNotPresentException.EnumConstantNotPresentException(Class<? extends Enum>, String)


EnumControl

EnumControl o7planning.org
  • EnumControl.EnumControl(EnumControl.Type, Object[], Object)


enumerate

enumerate o7planning.org
  • Thread.enumerate(Thread[])
  • ThreadGroup.enumerate(ThreadGroup[], boolean)
  • ThreadGroup.enumerate(ThreadGroup[])
  • ThreadGroup.enumerate(Thread[], boolean)
  • ThreadGroup.enumerate(Thread[])


enumeration

enumeration o7planning.org
  • Collections.enumeration(Collection<T>)


EnumMap

EnumMap o7planning.org
  • EnumMap.EnumMap(Map<K, ? extends V>)
  • EnumMap.EnumMap(EnumMap<K, ? extends V>)
  • EnumMap.EnumMap(Class<K>)


EnumSyntax

EnumSyntax o7planning.org
  • EnumSyntax.EnumSyntax(int)


enumType

enumType o7planning.org
  • EnumConstantNotPresentException.enumType()


ENV_6X9

ENV_6X9 o7planning.org
  • PageAttributes.MediaType.ENV_6X9


ENV_7X9

ENV_7X9 o7planning.org
  • PageAttributes.MediaType.ENV_7X9


ENV_9

ENV_9 o7planning.org
  • PageAttributes.MediaType.ENV_9


ENV_9X11

ENV_9X11 o7planning.org
  • PageAttributes.MediaType.ENV_9X11


ENV_9X12

ENV_9X12 o7planning.org
  • PageAttributes.MediaType.ENV_9X12


ENV_10

ENV_10 o7planning.org
  • PageAttributes.MediaType.ENV_10


ENV_10X13

ENV_10X13 o7planning.org
  • PageAttributes.MediaType.ENV_10X13


ENV_10X14

ENV_10X14 o7planning.org
  • PageAttributes.MediaType.ENV_10X14


ENV_10X15

ENV_10X15 o7planning.org
  • PageAttributes.MediaType.ENV_10X15


ENV_11

ENV_11 o7planning.org
  • PageAttributes.MediaType.ENV_11


ENV_12

ENV_12 o7planning.org
  • PageAttributes.MediaType.ENV_12


ENV_14

ENV_14 o7planning.org
  • PageAttributes.MediaType.ENV_14


env

env o7planning.org
  • Request.env()


ENV_INVITE

ENV_INVITE o7planning.org
  • PageAttributes.MediaType.ENV_INVITE


ENV_ITALY

ENV_ITALY o7planning.org
  • PageAttributes.MediaType.ENV_ITALY


ENV_MONARCH

ENV_MONARCH o7planning.org
  • PageAttributes.MediaType.ENV_MONARCH


ENV_PERSONAL

ENV_PERSONAL o7planning.org
  • PageAttributes.MediaType.ENV_PERSONAL


ENVELOPE

ENVELOPE o7planning.org
  • MediaTray.ENVELOPE


ENVELOPED

ENVELOPED o7planning.org
  • Transform.ENVELOPED


environment

environment o7planning.org
  • CannotProceedException.environment
  • ProcessBuilder.environment()


Environment

Environment o7planning.org
  • Environment.Environment()


eof

eof o7planning.org
  • OptionalDataException.eof


EOFException

EOFException o7planning.org
  • EOFException.EOFException(String)
  • EOFException.EOFException()


eolIsSignificant

eolIsSignificant o7planning.org
  • StreamTokenizer.eolIsSignificant(boolean)


eos

eos o7planning.org
  • GZIPInputStream.eos


EPOCH

EPOCH o7planning.org
  • Instant.EPOCH


EQ

EQ o7planning.org
  • Query.EQ


eq

eq o7planning.org
  • Query.eq(ValueExp, ValueExp)


EQUAL

EQUAL o7planning.org
  • DatatypeConstants.EQUAL


equal

equal o7planning.org
  • Any.equal(Any)
  • DynAnyOperations.equal(DynAny)
  • TypeCode.equal(TypeCode)
  • _DynAnyStub.equal(DynAny)
  • _DynArrayStub.equal(DynAny)
  • _DynEnumStub.equal(DynAny)
  • _DynFixedStub.equal(DynAny)
  • _DynSequenceStub.equal(DynAny)
  • _DynStructStub.equal(DynAny)
  • _DynUnionStub.equal(DynAny)
  • _DynValueStub.equal(DynAny)


equals

equals o7planning.org
  • AWTKeyStroke.equals(Object)
  • AbstractChronology.equals(Object)
  • AbstractList.equals(Object)
  • AbstractMap.equals(Object)
  • AbstractMap.SimpleEntry.equals(Object)
  • AbstractMap.SimpleImmutableEntry.equals(Object)
  • AbstractSet.equals(Object)
  • AccessControlContext.equals(Object)
  • AclEntry.equals(Object)
  • ActivationDataFlavor.equals(DataFlavor)
  • ActivationDesc.equals(Object)
  • ActivationGroupDesc.equals(Object)
  • ActivationGroupDesc.CommandEnvironment.equals(Object)
  • ActivationGroupID.equals(Object)
  • ActivationID.equals(Object)
  • AffineTransform.equals(Object)
  • AllPermission.equals(Object)
  • AlphaComposite.equals(Object)
  • Annotation.equals(Object)
  • Arc2D.equals(Object)
  • Area.equals(Area)
  • ArrayType.equals(Object)
  • Arrays.equals(Object[], Object[])
  • Arrays.equals(float[], float[])
  • Arrays.equals(double[], double[])
  • Arrays.equals(boolean[], boolean[])
  • Arrays.equals(byte[], byte[])
  • Arrays.equals(char[], char[])
  • Arrays.equals(short[], short[])
  • Arrays.equals(int[], int[])
  • Arrays.equals(long[], long[])
  • Attribute.equals(Object)
  • AttributeSet.equals(Object)
  • AttributedCharacterIterator.Attribute.equals(Object)
  • Attributes.equals(Object)
  • Attributes.Name.equals(Object)
  • AudioFileFormat.Type.equals(Object)
  • AudioFormat.Encoding.equals(Object)
  • BasicAttribute.equals(Object)
  • BasicAttributes.equals(Object)
  • BasicPermission.equals(Object)
  • BasicStroke.equals(Object)
  • BigDecimal.equals(Object)
  • BigInteger.equals(Object)
  • BinaryRefAddr.equals(Object)
  • BitSet.equals(Object)
  • Boolean.equals(Object)
  • Byte.equals(Object)
  • ByteBuffer.equals(Object)
  • Calendar.equals(Object)
  • CertPath.equals(Object)
  • Certificate.equals(Object)
  • Certificate.equals(Object)
  • ChannelBinding.equals(Object)
  • CharBuffer.equals(Object)
  • Character.equals(Object)
  • Character.Subset.equals(Object)
  • Charset.equals(Object)
  • ChoiceFormat.equals(Object)
  • ChronoLocalDate.equals(Object)
  • ChronoLocalDateTime.equals(Object)
  • ChronoPeriod.equals(Object)
  • ChronoZonedDateTime.equals(Object)
  • Chronology.equals(Object)
  • Clock.equals(Object)
  • CodeSigner.equals(Object)
  • CodeSource.equals(Object)
  • Collator.equals(Object)
  • Collator.equals(String, String)
  • Collection.equals(Object)
  • Color.equals(Object)
  • ColorModel.equals(Object)
  • Comparator.equals(Object)
  • ComponentColorModel.equals(Object)
  • ComponentSampleModel.equals(Object)
  • CompositeData.equals(Object)
  • CompositeDataSupport.equals(Object)
  • CompositeName.equals(Object)
  • CompositeType.equals(Object)
  • CompoundName.equals(Object)
  • ConcurrentHashMap.equals(Object)
  • ConcurrentHashMap.KeySetView.equals(Object)
  • ConcurrentSkipListMap.equals(Object)
  • ConcurrentSkipListSet.equals(Object)
  • Constructor.equals(Object)
  • Control.Type.equals(Object)
  • Copies.equals(Object)
  • CopiesSupported.equals(Object)
  • CopyOnWriteArrayList.equals(Object)
  • CopyOnWriteArraySet.equals(Object)
  • DataFlavor.equals(String)
  • DataFlavor.equals(DataFlavor)
  • DataFlavor.equals(Object)
  • Date.equals(Object)
  • DateFormat.equals(Object)
  • DateFormatSymbols.equals(Object)
  • DateTimeAtCompleted.equals(Object)
  • DateTimeAtCreation.equals(Object)
  • DateTimeAtProcessing.equals(Object)
  • DateTimeSyntax.equals(Object)
  • DecimalFormat.equals(Object)
  • DecimalFormatSymbols.equals(Object)
  • DecimalStyle.equals(Object)
  • DefaultCaret.equals(Object)
  • Delegate.equals(Object, Object)
  • DelegationPermission.equals(Object)
  • Descriptor.equals(Object)
  • DescriptorSupport.equals(Object)
  • Destination.equals(Object)
  • Dimension.equals(Object)
  • DisplayMode.equals(Object)
  • DisplayMode.equals(DisplayMode)
  • DocFlavor.equals(Object)
  • DocumentName.equals(Object)
  • Double.equals(Object)
  • DoubleBuffer.equals(Object)
  • Duration.equals(Object)
  • Duration.equals(Object)
  • ECFieldF2m.equals(Object)
  • ECFieldFp.equals(Object)
  • ECPoint.equals(Object)
  • Element.equals(Object)
  • Ellipse2D.equals(Object)
  • EllipticCurve.equals(Object)
  • Enum.equals(Object)
  • EnumMap.equals(Object)
  • Field.equals(Object)
  • FieldPosition.equals(Object)
  • File.equals(Object)
  • FilePermission.equals(Object)
  • FileTime.equals(Object)
  • Float.equals(Object)
  • FloatBuffer.equals(Object)
  • Font.equals(Object)
  • FontRenderContext.equals(FontRenderContext)
  • FontRenderContext.equals(Object)
  • GSSCredential.equals(Object)
  • GSSName.equals(Object)
  • GSSName.equals(GSSName)
  • GlyphVector.equals(GlyphVector)
  • GregorianCalendar.equals(Object)
  • HTML.UnknownTag.equals(Object)
  • HashAttributeSet.equals(Object)
  • Hashtable.equals(Object)
  • HijrahDate.equals(Object)
  • HttpCookie.equals(Object)
  • Identity.equals(Object)
  • IdentityHashMap.equals(Object)
  • ImageGraphicAttribute.equals(ImageGraphicAttribute)
  • ImageGraphicAttribute.equals(Object)
  • ImageTypeSpecifier.equals(Object)
  • ImmutableDescriptor.equals(Object)
  • IndexedPropertyDescriptor.equals(Object)
  • Inet4Address.equals(Object)
  • Inet6Address.equals(Object)
  • InetAddress.equals(Object)
  • InetSocketAddress.equals(Object)
  • Insets.equals(Object)
  • Instant.equals(Object)
  • IntBuffer.equals(Object)
  • Integer.equals(Object)
  • IntegerSyntax.equals(Object)
  • InterfaceAddress.equals(Object)
  • JMXPrincipal.equals(Object)
  • JMXServiceURL.equals(Object)
  • JapaneseDate.equals(Object)
  • JobAttributes.equals(Object)
  • JobHoldUntil.equals(Object)
  • JobImpressions.equals(Object)
  • JobImpressionsCompleted.equals(Object)
  • JobImpressionsSupported.equals(Object)
  • JobKOctets.equals(Object)
  • JobKOctetsProcessed.equals(Object)
  • JobKOctetsSupported.equals(Object)
  • JobMediaSheets.equals(Object)
  • JobMediaSheetsCompleted.equals(Object)
  • JobMediaSheetsSupported.equals(Object)
  • JobMessageFromOperator.equals(Object)
  • JobName.equals(Object)
  • JobOriginatingUserName.equals(Object)
  • JobPriority.equals(Object)
  • JobPrioritySupported.equals(Object)
  • KerberosKey.equals(Object)
  • KerberosPrincipal.equals(Object)
  • KerberosTicket.equals(Object)
  • KeyTab.equals(Object)
  • LdapName.equals(Object)
  • Level.equals(Object)
  • LineEvent.Type.equals(Object)
  • List.equals(Object)
  • LocalDate.equals(Object)
  • LocalDateTime.equals(Object)
  • LocalTime.equals(Object)
  • Locale.equals(Object)
  • Locale.LanguageRange.equals(Object)
  • Long.equals(Object)
  • LongBuffer.equals(Object)
  • MBeanAttributeInfo.equals(Object)
  • MBeanConstructorInfo.equals(Object)
  • MBeanFeatureInfo.equals(Object)
  • MBeanInfo.equals(Object)
  • MBeanNotificationInfo.equals(Object)
  • MBeanOperationInfo.equals(Object)
  • MBeanParameterInfo.equals(Object)
  • MBeanPermission.equals(Object)
  • MBeanServerPermission.equals(Object)
  • Manifest.equals(Object)
  • Map.equals(Object)
  • Map.Entry.equals(Object)
  • MarshalledObject.equals(Object)
  • MathContext.equals(Object)
  • Media.equals(Object)
  • MediaPrintableArea.equals(Object)
  • MediaSize.equals(Object)
  • MenuShortcut.equals(Object)
  • MenuShortcut.equals(MenuShortcut)
  • MessageFormat.equals(Object)
  • Method.equals(Object)
  • MethodType.equals(Object)
  • MidiDevice.Info.equals(Object)
  • MinguoDate.equals(Object)
  • Mixer.Info.equals(Object)
  • MonthDay.equals(Object)
  • MultiPixelPackedSampleModel.equals(Object)
  • Name.equals(Object)
  • NetworkInterface.equals(Object)
  • NumberFormat.equals(Object)
  • NumberOfDocuments.equals(Object)
  • NumberOfInterveningJobs.equals(Object)
  • NumberUp.equals(Object)
  • NumberUpSupported.equals(Object)
  • NumericShaper.equals(Object)
  • ObjID.equals(Object)
  • Object.equals(Object)
  • ObjectImpl.equals(Object)
  • ObjectInstance.equals(Object)
  • ObjectName.equals(Object)
  • Objects.equals(Object, Object)
  • OffsetDateTime.equals(Object)
  • OffsetTime.equals(Object)
  • Oid.equals(Object)
  • OpenMBeanAttributeInfo.equals(Object)
  • OpenMBeanAttributeInfoSupport.equals(Object)
  • OpenMBeanConstructorInfo.equals(Object)
  • OpenMBeanConstructorInfoSupport.equals(Object)
  • OpenMBeanInfo.equals(Object)
  • OpenMBeanInfoSupport.equals(Object)
  • OpenMBeanOperationInfo.equals(Object)
  • OpenMBeanOperationInfoSupport.equals(Object)
  • OpenMBeanParameterInfo.equals(Object)
  • OpenMBeanParameterInfoSupport.equals(Object)
  • OpenType.equals(Object)
  • Optional.equals(Object)
  • OptionalDouble.equals(Object)
  • OptionalInt.equals(Object)
  • OptionalLong.equals(Object)
  • OutputDeviceAssigned.equals(Object)
  • PKCS12Attribute.equals(Object)
  • PackedColorModel.equals(Object)
  • PageAttributes.equals(Object)
  • PageRanges.equals(Object)
  • PagesPerMinute.equals(Object)
  • PagesPerMinuteColor.equals(Object)
  • Parameter.equals(Object)
  • ParsePosition.equals(Object)
  • Path.equals(Object)
  • Period.equals(Object)
  • Permission.equals(Object)
  • Permission.equals(Object)
  • Point.equals(Object)
  • Point2D.equals(Object)
  • Port.Info.equals(Object)
  • Principal.equals(Object)
  • PrintService.equals(Object)
  • PrinterInfo.equals(Object)
  • PrinterLocation.equals(Object)
  • PrinterMakeAndModel.equals(Object)
  • PrinterMessageFromOperator.equals(Object)
  • PrinterMoreInfo.equals(Object)
  • PrinterMoreInfoManufacturer.equals(Object)
  • PrinterName.equals(Object)
  • PrinterResolution.equals(Object)
  • PrinterURI.equals(Object)
  • PrivateCredentialPermission.equals(Object)
  • ProcessBuilder.Redirect.equals(Object)
  • PropertyDescriptor.equals(Object)
  • PropertyPermission.equals(Object)
  • Proxy.equals(Object)
  • QName.equals(Object)
  • QueuedJobCount.equals(Object)
  • RC2ParameterSpec.equals(Object)
  • RC5ParameterSpec.equals(Object)
  • Rdn.equals(Object)
  • Rectangle.equals(Object)
  • Rectangle2D.equals(Object)
  • RefAddr.equals(Object)
  • Reference.equals(Object)
  • RemoteObject.equals(Object)
  • RenderingHints.equals(Object)
  • RenderingHints.Key.equals(Object)
  • RequestingUserName.equals(Object)
  • ResolutionSyntax.equals(Object)
  • ReverbType.equals(Object)
  • RoundRectangle2D.equals(Object)
  • RowId.equals(Object)
  • RowSorter.SortKey.equals(Object)
  • RuleBasedCollator.equals(Object)
  • SNIHostName.equals(Object)
  • SNIServerName.equals(Object)
  • SecretKeySpec.equals(Object)
  • Sequencer.SyncMode.equals(Object)
  • SerialArray.equals(Object)
  • SerialBlob.equals(Object)
  • SerialClob.equals(Object)
  • SerialDatalink.equals(Object)
  • SerialJavaObject.equals(Object)
  • SerialRef.equals(Object)
  • SerialStruct.equals(Object)
  • ServicePermission.equals(Object)
  • Set.equals(Object)
  • SetOfIntegerSyntax.equals(Object)
  • ShapeGraphicAttribute.equals(ShapeGraphicAttribute)
  • ShapeGraphicAttribute.equals(Object)
  • Short.equals(Object)
  • ShortBuffer.equals(Object)
  • SimpleAttributeSet.equals(Object)
  • SimpleDateFormat.equals(Object)
  • SimpleTimeZone.equals(Object)
  • SimpleType.equals(Object)
  • SinglePixelPackedSampleModel.equals(Object)
  • Size2DSyntax.equals(Object)
  • SocketPermission.equals(Object)
  • SslRMIClientSocketFactory.equals(Object)
  • SslRMIServerSocketFactory.equals(Object)
  • StackTraceElement.equals(Object)
  • String.equals(Object)
  • StringCharacterIterator.equals(Object)
  • Stub.equals(Object)
  • StubDelegate.equals(Stub, Object)
  • StyleContext.SmallAttributeSet.equals(Object)
  • Subject.equals(Object)
  • TabSet.equals(Object)
  • TabStop.equals(Object)
  • TabularData.equals(Object)
  • TabularDataSupport.equals(Object)
  • TabularType.equals(Object)
  • TextHitInfo.equals(TextHitInfo)
  • TextHitInfo.equals(Object)
  • TextLayout.equals(TextLayout)
  • TextLayout.equals(Object)
  • TextSyntax.equals(Object)
  • ThaiBuddhistDate.equals(Object)
  • Timestamp.equals(Object)
  • Timestamp.equals(Timestamp)
  • Timestamp.equals(Object)
  • TransformAttribute.equals(Object)
  • TreePath.equals(Object)
  • TypeMirror.equals(Object)
  • UID.equals(Object)
  • URI.equals(Object)
  • URISyntax.equals(Object)
  • URL.equals(Object)
  • URLPermission.equals(Object)
  • URLStreamHandler.equals(URL, URL)
  • UUID.equals(Object)
  • UnresolvedPermission.equals(Object)
  • VMID.equals(Object)
  • ValueRange.equals(Object)
  • Vector.equals(Object)
  • WeekFields.equals(Object)
  • X500Principal.equals(Object)
  • X509CRL.equals(Object)
  • X509CRLEntry.equals(Object)
  • XMLGregorianCalendar.equals(Object)
  • Year.equals(Object)
  • YearMonth.equals(Object)
  • ZoneId.equals(Object)
  • ZoneOffset.equals(Object)
  • ZoneOffsetTransition.equals(Object)
  • ZoneOffsetTransitionRule.equals(Object)
  • ZoneRules.equals(Object)
  • ZonedDateTime.equals(Object)


equalsIgnoreCase

equalsIgnoreCase o7planning.org
  • String.equalsIgnoreCase(String)


equivalent

equivalent o7planning.org
  • TypeCode.equivalent(TypeCode)


ERA

ERA o7planning.org
  • Calendar.ERA
  • DateFormat.Field.ERA


ERA_FIELD

ERA_FIELD o7planning.org
  • DateFormat.ERA_FIELD


eraOf

eraOf o7planning.org
  • Chronology.eraOf(int)
  • HijrahChronology.eraOf(int)
  • IsoChronology.eraOf(int)
  • JapaneseChronology.eraOf(int)
  • MinguoChronology.eraOf(int)
  • ThaiBuddhistChronology.eraOf(int)


eras

eras o7planning.org
  • Chronology.eras()
  • HijrahChronology.eras()
  • IsoChronology.eras()
  • JapaneseChronology.eras()
  • MinguoChronology.eras()
  • ThaiBuddhistChronology.eras()


erase

erase o7planning.org
  • MethodType.erase()


erasure

erasure o7planning.org
  • Types.erasure(TypeMirror)


err

err o7planning.org
  • FileDescriptor.err
  • System.err


ERROR

ERROR o7planning.org
  • ValidationEvent.ERROR


Error

Error o7planning.org
  • Error.Error(String, Throwable, boolean, boolean)
  • Error.Error(Throwable)
  • Error.Error(String, Throwable)
  • Error.Error(String)
  • Error.Error()


error

error o7planning.org
  • DefaultHandler.error(SAXParseException)
  • ErrorHandler.error(SAXParseException)
  • ErrorListener.error(TransformerException)
  • HandlerBase.error(SAXParseException)
  • XMLFilterImpl.error(SAXParseException)


ERROR_DIALOG

ERROR_DIALOG o7planning.org
  • JRootPane.ERROR_DIALOG


ERROR_MESSAGE

ERROR_MESSAGE o7planning.org
  • JOptionPane.ERROR_MESSAGE


ERROR_OPTION

ERROR_OPTION o7planning.org
  • JFileChooser.ERROR_OPTION


errorCode

errorCode o7planning.org
  • XAException.errorCode


ERRORED

ERRORED o7planning.org
  • MediaTracker.ERRORED


ErrorManager

ErrorManager o7planning.org
  • ErrorManager.ErrorManager()


errorRaised

errorRaised o7planning.org
  • RoundEnvironment.errorRaised()


errorWriter

errorWriter o7planning.org
  • SimpleScriptContext.errorWriter


ESCAPE

ESCAPE o7planning.org
  • Event.ESCAPE


escapeValue

escapeValue o7planning.org
  • Rdn.escapeValue(Object)


establish_components

establish_components o7planning.org
  • IORInterceptorOperations.establish_components(IORInfo)


estimateSize

estimateSize o7planning.org
  • Spliterator.estimateSize()
  • Spliterators.AbstractDoubleSpliterator.estimateSize()
  • Spliterators.AbstractIntSpliterator.estimateSize()
  • Spliterators.AbstractLongSpliterator.estimateSize()
  • Spliterators.AbstractSpliterator.estimateSize()


EtchedBorder

EtchedBorder o7planning.org
  • EtchedBorder.EtchedBorder(int, Color, Color)
  • EtchedBorder.EtchedBorder(Color, Color)
  • EtchedBorder.EtchedBorder(int)
  • EtchedBorder.EtchedBorder()


EtchedBorderUIResource

EtchedBorderUIResource o7planning.org
  • BorderUIResource.EtchedBorderUIResource.EtchedBorderUIResource(int, Color, Color)
  • BorderUIResource.EtchedBorderUIResource.EtchedBorderUIResource(Color, Color)
  • BorderUIResource.EtchedBorderUIResource.EtchedBorderUIResource(int)
  • BorderUIResource.EtchedBorderUIResource.EtchedBorderUIResource()


etchType

etchType o7planning.org
  • EtchedBorder.etchType


etherealize

etherealize o7planning.org
  • ServantActivatorOperations.etherealize(byte[], POA, Servant, boolean, boolean)
  • _ServantActivatorStub.etherealize(byte[], POA, Servant, boolean, boolean)


ETHIOPIC

ETHIOPIC o7planning.org
  • Character.UnicodeBlock.ETHIOPIC
  • NumericShaper.ETHIOPIC


ETHIOPIC_EXTENDED

ETHIOPIC_EXTENDED o7planning.org
  • Character.UnicodeBlock.ETHIOPIC_EXTENDED


ETHIOPIC_EXTENDED_A

ETHIOPIC_EXTENDED_A o7planning.org
  • Character.UnicodeBlock.ETHIOPIC_EXTENDED_A


ETHIOPIC_SUPPLEMENT

ETHIOPIC_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.ETHIOPIC_SUPPLEMENT


EUROPEAN

EUROPEAN o7planning.org
  • NumericShaper.EUROPEAN


eval

eval o7planning.org
  • AbstractScriptEngine.eval(String)
  • AbstractScriptEngine.eval(Reader)
  • AbstractScriptEngine.eval(String, Bindings)
  • AbstractScriptEngine.eval(Reader, Bindings)
  • CompiledScript.eval()
  • CompiledScript.eval(Bindings)
  • CompiledScript.eval(ScriptContext)
  • ScriptEngine.eval(Reader, Bindings)
  • ScriptEngine.eval(String, Bindings)
  • ScriptEngine.eval(Reader)
  • ScriptEngine.eval(String)
  • ScriptEngine.eval(Reader, ScriptContext)
  • ScriptEngine.eval(String, ScriptContext)


evaluate

evaluate o7planning.org
  • Predicate.evaluate(Object, String)
  • Predicate.evaluate(Object, int)
  • Predicate.evaluate(RowSet)
  • XPath.evaluate(String, InputSource)
  • XPath.evaluate(String, InputSource, QName)
  • XPath.evaluate(String, Object)
  • XPath.evaluate(String, Object, QName)
  • XPathExpression.evaluate(InputSource)
  • XPathExpression.evaluate(InputSource, QName)
  • XPathExpression.evaluate(Object)
  • XPathExpression.evaluate(Object, QName)
  • XPathFunction.evaluate(List)


evaluateChallenge

evaluateChallenge o7planning.org
  • SaslClient.evaluateChallenge(byte[])


evaluateResponse

evaluateResponse o7planning.org
  • SaslServer.evaluateResponse(byte[])


Event

Event o7planning.org
  • Event.Event(Object, int, Object)
  • Event.Event(Object, long, int, int, int, int, int)
  • Event.Event(Object, long, int, int, int, int, int, Object)


event

event o7planning.org
  • ExpandVetoException.event


eventDispatched

eventDispatched o7planning.org
  • AWTEventListener.eventDispatched(AWTEvent)
  • AWTEventListenerProxy.eventDispatched(AWTEvent)
  • LayerUI.eventDispatched(AWTEvent, JLayer<? extends V>)


EventException

EventException o7planning.org
  • EventException.EventException(short, String)


EventHandler

EventHandler o7planning.org
  • EventHandler.EventHandler(Object, String, String, String)


EventListenerList

EventListenerList o7planning.org
  • EventListenerList.EventListenerList()


EventListenerProxy

EventListenerProxy o7planning.org
  • EventListenerProxy.EventListenerProxy(T)


EventObject

EventObject o7planning.org
  • EventObject.EventObject(Object)


EventQueue

EventQueue o7planning.org
  • EventQueue.EventQueue()


EventReaderDelegate

EventReaderDelegate o7planning.org
  • EventReaderDelegate.EventReaderDelegate(XMLEventReader)
  • EventReaderDelegate.EventReaderDelegate()


events

events o7planning.org
  • DragGestureRecognizer.events


EventSetDescriptor

EventSetDescriptor o7planning.org
  • EventSetDescriptor.EventSetDescriptor(String, Class<?>, MethodDescriptor[], Method, Method)
  • EventSetDescriptor.EventSetDescriptor(String, Class<?>, Method[], Method, Method, Method)
  • EventSetDescriptor.EventSetDescriptor(String, Class<?>, Method[], Method, Method)
  • EventSetDescriptor.EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String, String)
  • EventSetDescriptor.EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String)
  • EventSetDescriptor.EventSetDescriptor(Class<?>, String, Class<?>, String)


eventTypeEnabled

eventTypeEnabled o7planning.org
  • ScrollPane.eventTypeEnabled(int)


evt

evt o7planning.org
  • Event.evt


exactInvoker

exactInvoker o7planning.org
  • MethodHandles.exactInvoker(MethodType)


examineAllHeaderElements

examineAllHeaderElements o7planning.org
  • SOAPHeader.examineAllHeaderElements()


examineHeaderElements

examineHeaderElements o7planning.org
  • SOAPHeader.examineHeaderElements(String)


examineMustUnderstandHeaderElements

examineMustUnderstandHeaderElements o7planning.org
  • SOAPHeader.examineMustUnderstandHeaderElements(String)


ExcC14NParameterSpec

ExcC14NParameterSpec o7planning.org
  • ExcC14NParameterSpec.ExcC14NParameterSpec(List)
  • ExcC14NParameterSpec.ExcC14NParameterSpec()


ExcellentBreakWeight

ExcellentBreakWeight o7planning.org
  • View.ExcellentBreakWeight


except

except o7planning.org
  • ServerRequest.except(Any)
  • UnknownUserException.except


Exception

Exception o7planning.org
  • Exception.Exception(String, Throwable, boolean, boolean)
  • Exception.Exception(Throwable)
  • Exception.Exception(String, Throwable)
  • Exception.Exception(String)
  • Exception.Exception()


exception

exception o7planning.org
  • Environment.exception(Exception)
  • Environment.exception()


exceptionally

exceptionally o7planning.org
  • CompletableFuture.exceptionally(Function<Throwable, ? extends T>)
  • CompletionStage.exceptionally(Function<Throwable, ? extends T>)


ExceptionInInitializerError

ExceptionInInitializerError o7planning.org
  • ExceptionInInitializerError.ExceptionInInitializerError(String)
  • ExceptionInInitializerError.ExceptionInInitializerError(Throwable)
  • ExceptionInInitializerError.ExceptionInInitializerError()


ExceptionList

ExceptionList o7planning.org
  • ExceptionList.ExceptionList()


exceptions

exceptions o7planning.org
  • Request.exceptions()
  • RequestInfoOperations.exceptions()


exceptionThrown

exceptionThrown o7planning.org
  • ExceptionListener.exceptionThrown(Exception)


exchange

exchange o7planning.org
  • Exchanger.exchange(V, long, TimeUnit)
  • Exchanger.exchange(V)


Exchanger

Exchanger o7planning.org
  • Exchanger.Exchanger()


exclusions

exclusions o7planning.org
  • Element.exclusions


EXCLUSIVE

EXCLUSIVE o7planning.org
  • CanonicalizationMethod.EXCLUSIVE


EXCLUSIVE_WITH_COMMENTS

EXCLUSIVE_WITH_COMMENTS o7planning.org
  • CanonicalizationMethod.EXCLUSIVE_WITH_COMMENTS


exclusiveOr

exclusiveOr o7planning.org
  • Area.exclusiveOr(Area)


exec

exec o7planning.org
  • CountedCompleter.exec()
  • ForkJoinTask.exec()
  • RecursiveAction.exec()
  • RecursiveTask.exec()
  • Runtime.exec(String[], String[], File)
  • Runtime.exec(String[], String[])
  • Runtime.exec(String[])
  • Runtime.exec(String, String[], File)
  • Runtime.exec(String, String[])
  • Runtime.exec(String)


execute

execute o7planning.org
  • CachedRowSet.execute(Connection)
  • Executor.execute(Runnable)
  • Expression.execute()
  • ForkJoinPool.execute(Runnable)
  • ForkJoinPool.execute(ForkJoinTask<?>)
  • PreparedStatement.execute()
  • RowSet.execute()
  • ScheduledThreadPoolExecutor.execute(Runnable)
  • Statement.execute(String, String[])
  • Statement.execute(String, int[])
  • Statement.execute(String, int)
  • Statement.execute(String)
  • Statement.execute()
  • SwingWorker.execute()
  • ThreadPoolExecutor.execute(Runnable)


EXECUTE_FAILED

EXECUTE_FAILED o7planning.org
  • Statement.EXECUTE_FAILED


executeBatch

executeBatch o7planning.org
  • Statement.executeBatch()


executeCall

executeCall o7planning.org
  • RemoteCall.executeCall()


executeLargeBatch

executeLargeBatch o7planning.org
  • Statement.executeLargeBatch()


executeLargeUpdate

executeLargeUpdate o7planning.org
  • PreparedStatement.executeLargeUpdate()
  • Statement.executeLargeUpdate(String, String[])
  • Statement.executeLargeUpdate(String, int[])
  • Statement.executeLargeUpdate(String, int)
  • Statement.executeLargeUpdate(String)


executeQuery

executeQuery o7planning.org
  • PreparedStatement.executeQuery()
  • Statement.executeQuery(String)


executeUpdate

executeUpdate o7planning.org
  • PreparedStatement.executeUpdate()
  • Statement.executeUpdate(String, String[])
  • Statement.executeUpdate(String, int[])
  • Statement.executeUpdate(String, int)
  • Statement.executeUpdate(String)


ExecutionException

ExecutionException o7planning.org
  • ExecutionException.ExecutionException(Throwable)
  • ExecutionException.ExecutionException(String, Throwable)
  • ExecutionException.ExecutionException(String)
  • ExecutionException.ExecutionException()


EXECUTIVE

EXECUTIVE o7planning.org
  • MediaSize.Other.EXECUTIVE
  • MediaSizeName.EXECUTIVE
  • PageAttributes.MediaType.EXECUTIVE


ExecutorCompletionService

ExecutorCompletionService o7planning.org
  • ExecutorCompletionService.ExecutorCompletionService(Executor, BlockingQueue<Future<V>>)
  • ExecutorCompletionService.ExecutorCompletionService(Executor)


ExemptionMechanism

ExemptionMechanism o7planning.org
  • ExemptionMechanism.ExemptionMechanism(ExemptionMechanismSpi, Provider, String)


ExemptionMechanismException

ExemptionMechanismException o7planning.org
  • ExemptionMechanismException.ExemptionMechanismException(String)
  • ExemptionMechanismException.ExemptionMechanismException()


ExemptionMechanismSpi

ExemptionMechanismSpi o7planning.org
  • ExemptionMechanismSpi.ExemptionMechanismSpi()


exists

exists o7planning.org
  • File.exists()
  • Files.exists(Path, LinkOption...)
  • KeyTab.exists()


exit

exit o7planning.org
  • Runtime.exit(int)
  • SecondaryLoop.exit()
  • System.exit(int)


EXIT_ON_CLOSE

EXIT_ON_CLOSE o7planning.org
  • JFrame.EXIT_ON_CLOSE
  • WindowConstants.EXIT_ON_CLOSE


EXITED

EXITED o7planning.org
  • HyperlinkEvent.EventType.EXITED


exiting

exiting o7planning.org
  • Logger.exiting(String, String, Object)
  • Logger.exiting(String, String)


exitValue

exitValue o7planning.org
  • Process.exitValue()


exp

exp o7planning.org
  • Math.exp(double)
  • StrictMath.exp(double)


EXPANDABLE

EXPANDABLE o7planning.org
  • AccessibleState.EXPANDABLE


EXPANDED

EXPANDED o7planning.org
  • AccessibleState.EXPANDED


expandedIcon

expandedIcon o7planning.org
  • BasicTreeUI.expandedIcon


expandPath

expandPath o7planning.org
  • JTree.expandPath(TreePath)


expandRow

expandRow o7planning.org
  • JTree.expandRow(int)


EXPANDS_SELECTED_PATHS_PROPERTY

EXPANDS_SELECTED_PATHS_PROPERTY o7planning.org
  • JTree.EXPANDS_SELECTED_PATHS_PROPERTY


expandTabRunsArray

expandTabRunsArray o7planning.org
  • BasicTabbedPaneUI.expandTabRunsArray()


ExpandVetoException

ExpandVetoException o7planning.org
  • ExpandVetoException.ExpandVetoException(TreeExpansionEvent, String)
  • ExpandVetoException.ExpandVetoException(TreeExpansionEvent)


explicitCastArguments

explicitCastArguments o7planning.org
  • MethodHandles.explicitCastArguments(MethodHandle, MethodType)


expm1

expm1 o7planning.org
  • Math.expm1(double)
  • StrictMath.expm1(double)


EXPONENT

EXPONENT o7planning.org
  • NumberFormat.Field.EXPONENT


EXPONENT_SIGN

EXPONENT_SIGN o7planning.org
  • NumberFormat.Field.EXPONENT_SIGN


EXPONENT_SYMBOL

EXPONENT_SYMBOL o7planning.org
  • NumberFormat.Field.EXPONENT_SYMBOL


export

export o7planning.org
  • GSSContext.export()
  • GSSName.export()
  • RMIIIOPServerImpl.export()
  • RMIJRMPServerImpl.export()
  • RMIServerImpl.export()


exportAsDrag

exportAsDrag o7planning.org
  • TransferHandler.exportAsDrag(JComponent, InputEvent, int)


exportDone

exportDone o7planning.org
  • TransferHandler.exportDone(JComponent, Transferable, int)


ExportException

ExportException o7planning.org
  • ExportException.ExportException(String, Exception)
  • ExportException.ExportException(String)


exportNode

exportNode o7planning.org
  • AbstractPreferences.exportNode(OutputStream)
  • Preferences.exportNode(OutputStream)


exportObject

exportObject o7planning.org
  • Activatable.exportObject(Remote, ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory)
  • Activatable.exportObject(Remote, ActivationID, int)
  • Activatable.exportObject(Remote, String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory)
  • Activatable.exportObject(Remote, String, MarshalledObject<?>, boolean, int)
  • PortableRemoteObject.exportObject(Remote)
  • PortableRemoteObjectDelegate.exportObject(Remote)
  • ServerRef.exportObject(Remote, Object)
  • UnicastRemoteObject.exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory)
  • UnicastRemoteObject.exportObject(Remote, int)
  • UnicastRemoteObject.exportObject(Remote)


exportSubtree

exportSubtree o7planning.org
  • AbstractPreferences.exportSubtree(OutputStream)
  • Preferences.exportSubtree(OutputStream)


exportToClipboard

exportToClipboard o7planning.org
  • TransferHandler.exportToClipboard(JComponent, Clipboard, int)


Expression

Expression o7planning.org
  • Expression.Expression(Object, Object, String, Object[])
  • Expression.Expression(Object, String, Object[])


extendedOperation

extendedOperation o7planning.org
  • InitialLdapContext.extendedOperation(ExtendedRequest)
  • LdapContext.extendedOperation(ExtendedRequest)


ExtendedSSLSession

ExtendedSSLSession o7planning.org
  • ExtendedSSLSession.ExtendedSSLSession()


extension

extension o7planning.org
  • JavaFileObject.Kind.extension


EXTENSION_INSTALLATION

EXTENSION_INSTALLATION o7planning.org
  • Attributes.Name.EXTENSION_INSTALLATION


EXTENSION_LIST

EXTENSION_LIST o7planning.org
  • Attributes.Name.EXTENSION_LIST


EXTENSION_NAME

EXTENSION_NAME o7planning.org
  • Attributes.Name.EXTENSION_NAME


extent

extent o7planning.org
  • Arc2D.Double.extent
  • Arc2D.Float.extent


externalEntityDecl

externalEntityDecl o7planning.org
  • DeclHandler.externalEntityDecl(String, String, String)
  • DefaultHandler2.externalEntityDecl(String, String, String)


extract

extract o7planning.org
  • AdapterAlreadyExistsHelper.extract(Any)
  • AdapterInactiveHelper.extract(Any)
  • AdapterManagerIdHelper.extract(Any)
  • AdapterNameHelper.extract(Any)
  • AdapterNonExistentHelper.extract(Any)
  • AdapterStateHelper.extract(Any)
  • AddressHelper.extract(Any)
  • AlreadyBoundHelper.extract(Any)
  • AnySeqHelper.extract(Any)
  • AnySeqHelper.extract(Any)
  • BindingHelper.extract(Any)
  • BindingIteratorHelper.extract(Any)
  • BindingListHelper.extract(Any)
  • BindingTypeHelper.extract(Any)
  • BooleanSeqHelper.extract(Any)
  • CannotProceedHelper.extract(Any)
  • CharSeqHelper.extract(Any)
  • CodecFactoryHelper.extract(Any)
  • CompletionStatusHelper.extract(Any)
  • ComponentIdHelper.extract(Any)
  • CurrentHelper.extract(Any)
  • CurrentHelper.extract(Any)
  • CurrentHelper.extract(Any)
  • DefinitionKindHelper.extract(Any)
  • DoubleSeqHelper.extract(Any)
  • DuplicateNameHelper.extract(Any)
  • DynAnyFactoryHelper.extract(Any)
  • DynAnyHelper.extract(Any)
  • DynAnySeqHelper.extract(Any)
  • DynArrayHelper.extract(Any)
  • DynEnumHelper.extract(Any)
  • DynFixedHelper.extract(Any)
  • DynSequenceHelper.extract(Any)
  • DynStructHelper.extract(Any)
  • DynUnionHelper.extract(Any)
  • DynValueHelper.extract(Any)
  • FieldNameHelper.extract(Any)
  • FieldNameHelper.extract(Any)
  • FloatSeqHelper.extract(Any)
  • FormatMismatchHelper.extract(Any)
  • ForwardRequestHelper.extract(Any)
  • ForwardRequestHelper.extract(Any)
  • IDLTypeHelper.extract(Any)
  • IORHelper.extract(Any)
  • IORInterceptor_3_0Helper.extract(Any)
  • IdentifierHelper.extract(Any)
  • InconsistentTypeCodeHelper.extract(Any)
  • InvalidAddressHelper.extract(Any)
  • InvalidNameHelper.extract(Any)
  • InvalidNameHelper.extract(Any)
  • InvalidPolicyHelper.extract(Any)
  • InvalidSlotHelper.extract(Any)
  • InvalidTypeForEncodingHelper.extract(Any)
  • InvalidValueHelper.extract(Any)
  • IstringHelper.extract(Any)
  • LongLongSeqHelper.extract(Any)
  • LongSeqHelper.extract(Any)
  • MultipleComponentProfileHelper.extract(Any)
  • NameComponentHelper.extract(Any)
  • NameDynAnyPairHelper.extract(Any)
  • NameDynAnyPairSeqHelper.extract(Any)
  • NameHelper.extract(Any)
  • NameValuePairHelper.extract(Any)
  • NameValuePairHelper.extract(Any)
  • NameValuePairSeqHelper.extract(Any)
  • NamingContextExtHelper.extract(Any)
  • NamingContextHelper.extract(Any)
  • NoContextHelper.extract(Any)
  • NoServantHelper.extract(Any)
  • NotEmptyHelper.extract(Any)
  • NotFoundHelper.extract(Any)
  • NotFoundReasonHelper.extract(Any)
  • ORBIdHelper.extract(Any)
  • ObjectAlreadyActiveHelper.extract(Any)
  • ObjectHelper.extract(Any)
  • ObjectIdHelper.extract(Any)
  • ObjectIdHelper.extract(Any)
  • ObjectNotActiveHelper.extract(Any)
  • ObjectReferenceFactoryHelper.extract(Any)
  • ObjectReferenceTemplateHelper.extract(Any)
  • ObjectReferenceTemplateSeqHelper.extract(Any)
  • OctetSeqHelper.extract(Any)
  • POAHelper.extract(Any)
  • ParameterModeHelper.extract(Any)
  • PolicyErrorCodeHelper.extract(Any)
  • PolicyErrorHelper.extract(Any)
  • PolicyHelper.extract(Any)
  • PolicyListHelper.extract(Any)
  • PolicyTypeHelper.extract(Any)
  • ProfileIdHelper.extract(Any)
  • RepositoryIdHelper.extract(Any)
  • ServantActivatorHelper.extract(Any)
  • ServantAlreadyActiveHelper.extract(Any)
  • ServantLocatorHelper.extract(Any)
  • ServantNotActiveHelper.extract(Any)
  • ServerIdHelper.extract(Any)
  • ServiceContextHelper.extract(Any)
  • ServiceContextListHelper.extract(Any)
  • ServiceDetailHelper.extract(Any)
  • ServiceIdHelper.extract(Any)
  • ServiceInformationHelper.extract(Any)
  • SetOverrideTypeHelper.extract(Any)
  • ShortSeqHelper.extract(Any)
  • StringNameHelper.extract(Any)
  • StringSeqHelper.extract(Any)
  • StringValueHelper.extract(Any)
  • StructMemberHelper.extract(Any)
  • SyncScopeHelper.extract(Any)
  • TaggedComponentHelper.extract(Any)
  • TaggedProfileHelper.extract(Any)
  • TypeMismatchHelper.extract(Any)
  • TypeMismatchHelper.extract(Any)
  • ULongLongSeqHelper.extract(Any)
  • ULongSeqHelper.extract(Any)
  • URLStringHelper.extract(Any)
  • UShortSeqHelper.extract(Any)
  • UnionMemberHelper.extract(Any)
  • UnknownEncodingHelper.extract(Any)
  • UnknownUserExceptionHelper.extract(Any)
  • ValueBaseHelper.extract(Any)
  • ValueMemberHelper.extract(Any)
  • VersionSpecHelper.extract(Any)
  • VisibilityHelper.extract(Any)
  • WCharSeqHelper.extract(Any)
  • WStringSeqHelper.extract(Any)
  • WStringValueHelper.extract(Any)
  • WrongAdapterHelper.extract(Any)
  • WrongPolicyHelper.extract(Any)
  • WrongTransactionHelper.extract(Any)


extract_any

extract_any o7planning.org
  • Any.extract_any()


extract_boolean

extract_boolean o7planning.org
  • Any.extract_boolean()


extract_char

extract_char o7planning.org
  • Any.extract_char()


extract_double

extract_double o7planning.org
  • Any.extract_double()


extract_fixed

extract_fixed o7planning.org
  • Any.extract_fixed()


extract_float

extract_float o7planning.org
  • Any.extract_float()


extract_long

extract_long o7planning.org
  • Any.extract_long()


extract_longlong

extract_longlong o7planning.org
  • Any.extract_longlong()


extract_Object

extract_Object o7planning.org
  • Any.extract_Object()


extract_octet

extract_octet o7planning.org
  • Any.extract_octet()


extract_Principal

extract_Principal o7planning.org
  • Any.extract_Principal()


extract_short

extract_short o7planning.org
  • Any.extract_short()


extract_Streamable

extract_Streamable o7planning.org
  • Any.extract_Streamable()


extract_string

extract_string o7planning.org
  • Any.extract_string()


extract_TypeCode

extract_TypeCode o7planning.org
  • Any.extract_TypeCode()


extract_ulong

extract_ulong o7planning.org
  • Any.extract_ulong()


extract_ulonglong

extract_ulonglong o7planning.org
  • Any.extract_ulonglong()


extract_ushort

extract_ushort o7planning.org
  • Any.extract_ushort()


extract_Value

extract_Value o7planning.org
  • Any.extract_Value()


extract_wchar

extract_wchar o7planning.org
  • Any.extract_wchar()


extract_wstring

extract_wstring o7planning.org
  • Any.extract_wstring()


extractAllHeaderElements

extractAllHeaderElements o7planning.org
  • SOAPHeader.extractAllHeaderElements()


extractContentAsDocument

extractContentAsDocument o7planning.org
  • SOAPBody.extractContentAsDocument()


extractHeaderElements

extractHeaderElements o7planning.org
  • SOAPHeader.extractHeaderElements(String)


extraImageMetadataFormatClassNames

extraImageMetadataFormatClassNames o7planning.org
  • ImageReaderWriterSpi.extraImageMetadataFormatClassNames


extraImageMetadataFormatNames

extraImageMetadataFormatNames o7planning.org
  • ImageReaderWriterSpi.extraImageMetadataFormatNames


extraMetadataFormatClassNames

extraMetadataFormatClassNames o7planning.org
  • IIOMetadata.extraMetadataFormatClassNames


extraMetadataFormatNames

extraMetadataFormatNames o7planning.org
  • IIOMetadata.extraMetadataFormatNames


extraStreamMetadataFormatClassNames

extraStreamMetadataFormatClassNames o7planning.org
  • ImageReaderWriterSpi.extraStreamMetadataFormatClassNames


extraStreamMetadataFormatNames

extraStreamMetadataFormatNames o7planning.org
  • ImageReaderWriterSpi.extraStreamMetadataFormatNames


F0

F0 o7planning.org
  • RSAKeyGenParameterSpec.F0


F1

F1 o7planning.org
  • Event.F1


F2

F2 o7planning.org
  • Event.F2


F3

F3 o7planning.org
  • Event.F3


F4

F4 o7planning.org
  • Event.F4
  • RSAKeyGenParameterSpec.F4


F5

F5 o7planning.org
  • Event.F5


F6

F6 o7planning.org
  • Event.F6


F7

F7 o7planning.org
  • Event.F7


F8

F8 o7planning.org
  • Event.F8


F9

F9 o7planning.org
  • Event.F9


F10

F10 o7planning.org
  • Event.F10


F11

F11 o7planning.org
  • Event.F11


F12

F12 o7planning.org
  • Event.F12


FACE

FACE o7planning.org
  • HTML.Attribute.FACE


FactoryConfigurationError

FactoryConfigurationError o7planning.org
  • FactoryConfigurationError.FactoryConfigurationError(String)
  • FactoryConfigurationError.FactoryConfigurationError(String, Exception)
  • FactoryConfigurationError.FactoryConfigurationError(Exception, String)
  • FactoryConfigurationError.FactoryConfigurationError(Exception)
  • FactoryConfigurationError.FactoryConfigurationError()
  • FactoryConfigurationError.FactoryConfigurationError(Exception, String)
  • FactoryConfigurationError.FactoryConfigurationError(Exception)
  • FactoryConfigurationError.FactoryConfigurationError(String)
  • FactoryConfigurationError.FactoryConfigurationError()


failed

failed o7planning.org
  • CompletionHandler.failed(Throwable, A)


FAILED

FAILED o7planning.org
  • JMXConnectionNotification.FAILED


FailedLoginException

FailedLoginException o7planning.org
  • FailedLoginException.FailedLoginException(String)
  • FailedLoginException.FailedLoginException()


failure

failure o7planning.org
  • RMIFailureHandler.failure(Exception)


FAILURE

FAILURE o7planning.org
  • GSSException.FAILURE


FALSE

FALSE o7planning.org
  • Boolean.FALSE
  • Pack200.Packer.FALSE
  • Pack200.Unpacker.FALSE


FAMILY

FAMILY o7planning.org
  • TextAttribute.FAMILY


Family

Family o7planning.org
  • StyleConstants.Family


FATAL_ERROR

FATAL_ERROR o7planning.org
  • ValidationEvent.FATAL_ERROR


fatalError

fatalError o7planning.org
  • DefaultHandler.fatalError(SAXParseException)
  • ErrorHandler.fatalError(SAXParseException)
  • ErrorListener.fatalError(TransformerException)
  • HandlerBase.fatalError(SAXParseException)
  • XMLFilterImpl.fatalError(SAXParseException)


fd

fd o7planning.org
  • DatagramSocketImpl.fd
  • SocketImpl.fd


FEATURE

FEATURE o7planning.org
  • DOMResult.FEATURE
  • DOMSource.FEATURE
  • SAXResult.FEATURE
  • SAXSource.FEATURE
  • SAXTransformerFactory.FEATURE
  • StAXResult.FEATURE
  • StAXSource.FEATURE
  • StreamResult.FEATURE
  • StreamSource.FEATURE


FEATURE_SECURE_PROCESSING

FEATURE_SECURE_PROCESSING o7planning.org
  • XMLConstants.FEATURE_SECURE_PROCESSING


FEATURE_XMLFILTER

FEATURE_XMLFILTER o7planning.org
  • SAXTransformerFactory.FEATURE_XMLFILTER


FeatureDescriptor

FeatureDescriptor o7planning.org
  • FeatureDescriptor.FeatureDescriptor()


FEBRUARY

FEBRUARY o7planning.org
  • Calendar.FEBRUARY
  • DatatypeConstants.FEBRUARY


FETCH_FORWARD

FETCH_FORWARD o7planning.org
  • ResultSet.FETCH_FORWARD


FETCH_REVERSE

FETCH_REVERSE o7planning.org
  • ResultSet.FETCH_REVERSE


FETCH_UNKNOWN

FETCH_UNKNOWN o7planning.org
  • ResultSet.FETCH_UNKNOWN


fetchNotifications

fetchNotifications o7planning.org
  • RMIConnection.fetchNotifications(long, int, long)
  • RMIConnectionImpl.fetchNotifications(long, int, long)
  • RMIConnectionImpl_Stub.fetchNotifications(long, int, long)


fictional

fictional o7planning.org
  • TagElement.fictional()


Fidelity

Fidelity o7planning.org
  • Fidelity.Fidelity(int)


FIDELITY_FALSE

FIDELITY_FALSE o7planning.org
  • Fidelity.FIDELITY_FALSE


FIDELITY_TRUE

FIDELITY_TRUE o7planning.org
  • Fidelity.FIDELITY_TRUE


Field

Field o7planning.org
  • DateFormat.Field.Field(String, int)
  • Format.Field.Field(String)
  • MessageFormat.Field.Field(String)
  • NumberFormat.Field.Field(String)


FIELD_ATTRIBUTE_PFX

FIELD_ATTRIBUTE_PFX o7planning.org
  • Pack200.Packer.FIELD_ATTRIBUTE_PFX


FIELD_COUNT

FIELD_COUNT o7planning.org
  • Calendar.FIELD_COUNT


FIELD_UNDEFINED

FIELD_UNDEFINED o7planning.org
  • DatatypeConstants.FIELD_UNDEFINED


FieldBorder

FieldBorder o7planning.org
  • BasicBorders.FieldBorder.FieldBorder(Color, Color, Color, Color)


fieldModifiers

fieldModifiers o7planning.org
  • Modifier.fieldModifiers()


FieldNameHelper

FieldNameHelper o7planning.org
  • FieldNameHelper.FieldNameHelper()
  • FieldNameHelper.FieldNameHelper()


FieldPosition

FieldPosition o7planning.org
  • FieldPosition.FieldPosition(Format.Field, int)
  • FieldPosition.FieldPosition(Format.Field)
  • FieldPosition.FieldPosition(int)


fields

fields o7planning.org
  • Calendar.fields


fieldsIn

fieldsIn o7planning.org
  • ElementFilter.fieldsIn(Set<? extends Element>)
  • ElementFilter.fieldsIn(Iterable<? extends Element>)


FieldView

FieldView o7planning.org
  • FieldView.FieldView(Element)


FILE

FILE o7planning.org
  • ReferenceUriSchemesSupported.FILE


File

File o7planning.org
  • File.File(URI)
  • File.File(File, String)
  • File.File(String, String)
  • File.File(String)


file

file o7planning.org
  • ProcessBuilder.Redirect.file()


FILE_CHOOSER

FILE_CHOOSER o7planning.org
  • AccessibleRole.FILE_CHOOSER
  • Region.FILE_CHOOSER


FILE_CHOOSER_DIALOG

FILE_CHOOSER_DIALOG o7planning.org
  • JRootPane.FILE_CHOOSER_DIALOG


FILE_FILTER_CHANGED_PROPERTY

FILE_FILTER_CHANGED_PROPERTY o7planning.org
  • JFileChooser.FILE_FILTER_CHANGED_PROPERTY


FILE_HIDING_CHANGED_PROPERTY

FILE_HIDING_CHANGED_PROPERTY o7planning.org
  • JFileChooser.FILE_HIDING_CHANGED_PROPERTY


FILE_SELECTION_MODE_CHANGED_PROPERTY

FILE_SELECTION_MODE_CHANGED_PROPERTY o7planning.org
  • JFileChooser.FILE_SELECTION_MODE_CHANGED_PROPERTY


FILE_SYSTEM_VIEW_CHANGED_PROPERTY

FILE_SYSTEM_VIEW_CHANGED_PROPERTY o7planning.org
  • JFileChooser.FILE_SYSTEM_VIEW_CHANGED_PROPERTY


FILE_VERSION

FILE_VERSION o7planning.org
  • DTD.FILE_VERSION


FILE_VIEW_CHANGED_PROPERTY

FILE_VIEW_CHANGED_PROPERTY o7planning.org
  • JFileChooser.FILE_VIEW_CHANGED_PROPERTY


FileAlreadyExistsException

FileAlreadyExistsException o7planning.org
  • FileAlreadyExistsException.FileAlreadyExistsException(String, String, String)
  • FileAlreadyExistsException.FileAlreadyExistsException(String)


FileCacheImageInputStream

FileCacheImageInputStream o7planning.org
  • FileCacheImageInputStream.FileCacheImageInputStream(InputStream, File)


FileCacheImageOutputStream

FileCacheImageOutputStream o7planning.org
  • FileCacheImageOutputStream.FileCacheImageOutputStream(OutputStream, File)


FileChannel

FileChannel o7planning.org
  • FileChannel.FileChannel()


FileChooserUI

FileChooserUI o7planning.org
  • FileChooserUI.FileChooserUI()


FileDataSource

FileDataSource o7planning.org
  • FileDataSource.FileDataSource(String)
  • FileDataSource.FileDataSource(File)


FileDescriptor

FileDescriptor o7planning.org
  • FileDescriptor.FileDescriptor()


FileDialog

FileDialog o7planning.org
  • FileDialog.FileDialog(Dialog, String, int)
  • FileDialog.FileDialog(Dialog, String)
  • FileDialog.FileDialog(Dialog)
  • FileDialog.FileDialog(Frame, String, int)
  • FileDialog.FileDialog(Frame, String)
  • FileDialog.FileDialog(Frame)


FileFilter

FileFilter o7planning.org
  • FileFilter.FileFilter()


FileHandler

FileHandler o7planning.org
  • FileHandler.FileHandler(String, int, int, boolean)
  • FileHandler.FileHandler(String, int, int)
  • FileHandler.FileHandler(String, boolean)
  • FileHandler.FileHandler(String)
  • FileHandler.FileHandler()


FileIcon16

FileIcon16 o7planning.org
  • MetalIconFactory.FileIcon16.FileIcon16()


fileIcon

fileIcon o7planning.org
  • BasicFileChooserUI.fileIcon


FileImageInputStream

FileImageInputStream o7planning.org
  • FileImageInputStream.FileImageInputStream(RandomAccessFile)
  • FileImageInputStream.FileImageInputStream(File)


FileImageOutputStream

FileImageOutputStream o7planning.org
  • FileImageOutputStream.FileImageOutputStream(RandomAccessFile)
  • FileImageOutputStream.FileImageOutputStream(File)


FileInputStream

FileInputStream o7planning.org
  • FileInputStream.FileInputStream(FileDescriptor)
  • FileInputStream.FileInputStream(File)
  • FileInputStream.FileInputStream(String)


fileKey

fileKey o7planning.org
  • BasicFileAttributes.fileKey()


FileLock

FileLock o7planning.org
  • FileLock.FileLock(AsynchronousFileChannel, long, long, boolean)
  • FileLock.FileLock(FileChannel, long, long, boolean)


FileLockInterruptionException

FileLockInterruptionException o7planning.org
  • FileLockInterruptionException.FileLockInterruptionException()


fileManager

fileManager o7planning.org
  • ForwardingJavaFileManager.fileManager


FILENAME

FILENAME o7planning.org
  • ScriptEngine.FILENAME


FileNameExtensionFilter

FileNameExtensionFilter o7planning.org
  • FileNameExtensionFilter.FileNameExtensionFilter(String, String...)


FileNotFoundException

FileNotFoundException o7planning.org
  • FileNotFoundException.FileNotFoundException(String)
  • FileNotFoundException.FileNotFoundException()


fileObject

fileObject o7planning.org
  • ForwardingFileObject.fileObject


FileOutputStream

FileOutputStream o7planning.org
  • FileOutputStream.FileOutputStream(FileDescriptor)
  • FileOutputStream.FileOutputStream(File, boolean)
  • FileOutputStream.FileOutputStream(File)
  • FileOutputStream.FileOutputStream(String, boolean)
  • FileOutputStream.FileOutputStream(String)


FilePermission

FilePermission o7planning.org
  • FilePermission.FilePermission(String, String)


FileReader

FileReader o7planning.org
  • FileReader.FileReader(FileDescriptor)
  • FileReader.FileReader(File)
  • FileReader.FileReader(String)


FileRenderer

FileRenderer o7planning.org
  • MetalFileChooserUI.FileRenderer.FileRenderer()


FilerException

FilerException o7planning.org
  • FilerException.FilerException(String)


FILES_AND_DIRECTORIES

FILES_AND_DIRECTORIES o7planning.org
  • JFileChooser.FILES_AND_DIRECTORIES


FILES_ONLY

FILES_ONLY o7planning.org
  • JFileChooser.FILES_ONLY


FileStore

FileStore o7planning.org
  • FileStore.FileStore()


FileSystem

FileSystem o7planning.org
  • FileSystem.FileSystem()


FileSystemAlreadyExistsException

FileSystemAlreadyExistsException o7planning.org
  • FileSystemAlreadyExistsException.FileSystemAlreadyExistsException(String)
  • FileSystemAlreadyExistsException.FileSystemAlreadyExistsException()


FileSystemException

FileSystemException o7planning.org
  • FileSystemException.FileSystemException(String, String, String)
  • FileSystemException.FileSystemException(String)


FileSystemLoopException

FileSystemLoopException o7planning.org
  • FileSystemLoopException.FileSystemLoopException(String)


FileSystemNotFoundException

FileSystemNotFoundException o7planning.org
  • FileSystemNotFoundException.FileSystemNotFoundException(String)
  • FileSystemNotFoundException.FileSystemNotFoundException()


FileSystemProvider

FileSystemProvider o7planning.org
  • FileSystemProvider.FileSystemProvider()


FileSystemView

FileSystemView o7planning.org
  • FileSystemView.FileSystemView()


FileTypeDetector

FileTypeDetector o7planning.org
  • FileTypeDetector.FileTypeDetector()


FileTypeMap

FileTypeMap o7planning.org
  • FileTypeMap.FileTypeMap()


FileView

FileView o7planning.org
  • FileView.FileView()


FileWriter

FileWriter o7planning.org
  • FileWriter.FileWriter(FileDescriptor)
  • FileWriter.FileWriter(File, boolean)
  • FileWriter.FileWriter(File)
  • FileWriter.FileWriter(String, boolean)
  • FileWriter.FileWriter(String)


fill3DRect

fill3DRect o7planning.org
  • DebugGraphics.fill3DRect(int, int, int, int, boolean)
  • Graphics.fill3DRect(int, int, int, int, boolean)
  • Graphics2D.fill3DRect(int, int, int, int, boolean)


FILL

FILL o7planning.org
  • ShapeGraphicAttribute.FILL


fill

fill o7planning.org
  • Arrays.fill(Object[], int, int, Object)
  • Arrays.fill(Object[], Object)
  • Arrays.fill(float[], int, int, float)
  • Arrays.fill(float[], float)
  • Arrays.fill(double[], int, int, double)
  • Arrays.fill(double[], double)
  • Arrays.fill(boolean[], int, int, boolean)
  • Arrays.fill(boolean[], boolean)
  • Arrays.fill(byte[], int, int, byte)
  • Arrays.fill(byte[], byte)
  • Arrays.fill(char[], int, int, char)
  • Arrays.fill(char[], char)
  • Arrays.fill(short[], int, int, short)
  • Arrays.fill(short[], short)
  • Arrays.fill(int[], int, int, int)
  • Arrays.fill(int[], int)
  • Arrays.fill(long[], int, int, long)
  • Arrays.fill(long[], long)
  • Collections.fill(List<? super T>, T)
  • Graphics2D.fill(Shape)
  • GridBagConstraints.fill
  • InflaterInputStream.fill()


fillArc

fillArc o7planning.org
  • DebugGraphics.fillArc(int, int, int, int, int, int)
  • Graphics.fillArc(int, int, int, int, int, int)


filledSlider

filledSlider o7planning.org
  • MetalSliderUI.filledSlider


FILLER

FILLER o7planning.org
  • AccessibleRole.FILLER


Filler

Filler o7planning.org
  • Box.Filler.Filler(Dimension, Dimension, Dimension)


fillInStackTrace

fillInStackTrace o7planning.org
  • Throwable.fillInStackTrace()


fillOval

fillOval o7planning.org
  • DebugGraphics.fillOval(int, int, int, int)
  • Graphics.fillOval(int, int, int, int)


fillPolygon

fillPolygon o7planning.org
  • DebugGraphics.fillPolygon(int[], int[], int)
  • Graphics.fillPolygon(Polygon)
  • Graphics.fillPolygon(int[], int[], int)


fillRect

fillRect o7planning.org
  • DebugGraphics.fillRect(int, int, int, int)
  • Graphics.fillRect(int, int, int, int)


fillRoundRect

fillRoundRect o7planning.org
  • DebugGraphics.fillRoundRect(int, int, int, int, int, int)
  • Graphics.fillRoundRect(int, int, int, int, int, int)


filter

filter o7planning.org
  • AffineTransformOp.filter(Raster, WritableRaster)
  • AffineTransformOp.filter(BufferedImage, BufferedImage)
  • BandCombineOp.filter(Raster, WritableRaster)
  • BufferedImageOp.filter(BufferedImage, BufferedImage)
  • ColorConvertOp.filter(Raster, WritableRaster)
  • ColorConvertOp.filter(BufferedImage, BufferedImage)
  • ConvolveOp.filter(Raster, WritableRaster)
  • ConvolveOp.filter(BufferedImage, BufferedImage)
  • DoubleStream.filter(DoublePredicate)
  • IntStream.filter(IntPredicate)
  • Locale.filter(List<Locale.LanguageRange>, Collection<Locale>)
  • Locale.filter(List<Locale.LanguageRange>, Collection<Locale>, Locale.FilteringMode)
  • LongStream.filter(LongPredicate)
  • LookupOp.filter(Raster, WritableRaster)
  • LookupOp.filter(BufferedImage, BufferedImage)
  • Optional.filter(Predicate<? super T>)
  • RasterOp.filter(Raster, WritableRaster)
  • RescaleOp.filter(Raster, WritableRaster)
  • RescaleOp.filter(BufferedImage, BufferedImage)
  • ServiceRegistry.Filter.filter(Object)
  • Stream.filter(Predicate<? super T>)


FILTER_ACCEPT

FILTER_ACCEPT o7planning.org
  • LSParserFilter.FILTER_ACCEPT


FILTER_INTERRUPT

FILTER_INTERRUPT o7planning.org
  • LSParserFilter.FILTER_INTERRUPT


FILTER_REJECT

FILTER_REJECT o7planning.org
  • LSParserFilter.FILTER_REJECT


FILTER_SKIP

FILTER_SKIP o7planning.org
  • LSParserFilter.FILTER_SKIP


filterArguments

filterArguments o7planning.org
  • MethodHandles.filterArguments(MethodHandle, int, MethodHandle...)


FilterBypass

FilterBypass o7planning.org
  • DocumentFilter.FilterBypass.FilterBypass()
  • NavigationFilter.FilterBypass.FilterBypass()


FilterComboBoxModel

FilterComboBoxModel o7planning.org
  • MetalFileChooserUI.FilterComboBoxModel.FilterComboBoxModel()


FilterComboBoxRenderer

FilterComboBoxRenderer o7planning.org
  • MetalFileChooserUI.FilterComboBoxRenderer.FilterComboBoxRenderer()


FILTERED

FILTERED o7planning.org
  • Deflater.FILTERED


FilteredImageSource

FilteredImageSource o7planning.org
  • FilteredImageSource.FilteredImageSource(ImageProducer, ImageFilter)


filterIndexColorModel

filterIndexColorModel o7planning.org
  • RGBImageFilter.filterIndexColorModel(IndexColorModel)


FilterInputStream

FilterInputStream o7planning.org
  • FilterInputStream.FilterInputStream(InputStream)


FilterOutputStream

FilterOutputStream o7planning.org
  • FilterOutputStream.FilterOutputStream(OutputStream)


FilterReader

FilterReader o7planning.org
  • FilterReader.FilterReader(Reader)


filterReturnValue

filterReturnValue o7planning.org
  • MethodHandles.filterReturnValue(MethodHandle, MethodHandle)


filterRGB

filterRGB o7planning.org
  • GrayFilter.filterRGB(int, int, int)
  • RGBImageFilter.filterRGB(int, int, int)


filterRGBPixels

filterRGBPixels o7planning.org
  • RGBImageFilter.filterRGBPixels(int, int, int, int, int[], int, int)


filters

filters o7planning.org
  • MetalFileChooserUI.FilterComboBoxModel.filters


filterTags

filterTags o7planning.org
  • Locale.filterTags(List<Locale.LanguageRange>, Collection<String>)
  • Locale.filterTags(List<Locale.LanguageRange>, Collection<String>, Locale.FilteringMode)


FilterWriter

FilterWriter o7planning.org
  • FilterWriter.FilterWriter(Writer)


FINAL

FINAL o7planning.org
  • Modifier.FINAL


FINAL_QUOTE_PUNCTUATION

FINAL_QUOTE_PUNCTUATION o7planning.org
  • Character.FINAL_QUOTE_PUNCTUATION


finalize

finalize o7planning.org
  • ColorModel.finalize()
  • Deflater.finalize()
  • Enum.finalize()
  • ExemptionMechanism.finalize()
  • FileCacheImageInputStream.finalize()
  • FileImageInputStream.finalize()
  • FileImageOutputStream.finalize()
  • FileInputStream.finalize()
  • FileOutputStream.finalize()
  • Graphics.finalize()
  • ICC_Profile.finalize()
  • ImageInputStreamImpl.finalize()
  • IndexColorModel.finalize()
  • Inflater.finalize()
  • MemoryCacheImageInputStream.finalize()
  • Object.finalize()
  • PrintJob.finalize()
  • ServiceRegistry.finalize()
  • ThreadPoolExecutor.finalize()
  • ZipFile.finalize()


finalSubString

finalSubString o7planning.org
  • Query.finalSubString(AttributeValueExp, StringValueExp)


find

find o7planning.org
  • Files.find(Path, int, BiPredicate<Path, BasicFileAttributes>, FileVisitOption...)
  • Matcher.find(int)
  • Matcher.find()


find_POA

find_POA o7planning.org
  • POAOperations.find_POA(String, boolean)


findAny

findAny o7planning.org
  • DoubleStream.findAny()
  • IntStream.findAny()
  • LongStream.findAny()
  • Stream.findAny()


findAssociatedMBeans

findAssociatedMBeans o7planning.org
  • RelationService.findAssociatedMBeans(ObjectName, String, String)
  • RelationServiceMBean.findAssociatedMBeans(ObjectName, String, String)


findClass

findClass o7planning.org
  • ClassLoader.findClass(String)
  • MLet.findClass(String)
  • URLClassLoader.findClass(String)


findColumn

findColumn o7planning.org
  • AbstractTableModel.findColumn(String)
  • ResultSet.findColumn(String)


findComponentAt

findComponentAt o7planning.org
  • Container.findComponentAt(Point)
  • Container.findComponentAt(int, int)


findConstructor

findConstructor o7planning.org
  • MethodHandles.Lookup.findConstructor(Class<?>, MethodType)


findDeadlockedThreads

findDeadlockedThreads o7planning.org
  • ThreadMXBean.findDeadlockedThreads()


findEditor

findEditor o7planning.org
  • PropertyEditorManager.findEditor(Class<?>)


findElementMatchingTag

findElementMatchingTag o7planning.org
  • HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument, int, HTML.Tag)


findFirst

findFirst o7planning.org
  • DoubleStream.findFirst()
  • IntStream.findFirst()
  • LongStream.findFirst()
  • Stream.findFirst()


findFocusOwner

findFocusOwner o7planning.org
  • SwingUtilities.findFocusOwner(Component)


findGetter

findGetter o7planning.org
  • MethodHandles.Lookup.findGetter(Class<?>, String, Class<?>)


findInLine

findInLine o7planning.org
  • Scanner.findInLine(Pattern)
  • Scanner.findInLine(String)


findLibrary

findLibrary o7planning.org
  • ClassLoader.findLibrary(String)
  • MLet.findLibrary(String)


findLoadedClass

findLoadedClass o7planning.org
  • ClassLoader.findLoadedClass(String)


findMBeanServer

findMBeanServer o7planning.org
  • MBeanServerFactory.findMBeanServer(String)


findMedia

findMedia o7planning.org
  • MediaSize.findMedia(float, float, int)


findMonitorDeadlockedThreads

findMonitorDeadlockedThreads o7planning.org
  • ThreadMXBean.findMonitorDeadlockedThreads()


findOffsetToCharactersInString

findOffsetToCharactersInString o7planning.org
  • ParagraphView.findOffsetToCharactersInString(char[], int)


findReferencingRelations

findReferencingRelations o7planning.org
  • RelationService.findReferencingRelations(ObjectName, String, String)
  • RelationServiceMBean.findReferencingRelations(ObjectName, String, String)


findRelationsOfType

findRelationsOfType o7planning.org
  • RelationService.findRelationsOfType(String)
  • RelationServiceMBean.findRelationsOfType(String)


findResource

findResource o7planning.org
  • ClassLoader.findResource(String)
  • URLClassLoader.findResource(String)


findResources

findResources o7planning.org
  • ClassLoader.findResources(String)
  • URLClassLoader.findResources(String)


findSetter

findSetter o7planning.org
  • MethodHandles.Lookup.findSetter(Class<?>, String, Class<?>)


findSpecial

findSpecial o7planning.org
  • MethodHandles.Lookup.findSpecial(Class<?>, String, MethodType, Class<?>)


findStatic

findStatic o7planning.org
  • MethodHandles.Lookup.findStatic(Class<?>, String, MethodType)


findStaticGetter

findStaticGetter o7planning.org
  • MethodHandles.Lookup.findStaticGetter(Class<?>, String, Class<?>)


findStaticSetter

findStaticSetter o7planning.org
  • MethodHandles.Lookup.findStaticSetter(Class<?>, String, Class<?>)


findSystemClass

findSystemClass o7planning.org
  • ClassLoader.findSystemClass(String)


findVirtual

findVirtual o7planning.org
  • MethodHandles.Lookup.findVirtual(Class<?>, String, MethodType)


findWithinHorizon

findWithinHorizon o7planning.org
  • Scanner.findWithinHorizon(Pattern, int)
  • Scanner.findWithinHorizon(String, int)


FINE

FINE o7planning.org
  • Level.FINE


fine

fine o7planning.org
  • Logger.fine(Supplier<String>)
  • Logger.fine(String)


FINER

FINER o7planning.org
  • Level.FINER


finer

finer o7planning.org
  • Logger.finer(Supplier<String>)
  • Logger.finer(String)


FINEST

FINEST o7planning.org
  • Level.FINEST


finest

finest o7planning.org
  • Logger.finest(Supplier<String>)
  • Logger.finest(String)


finish

finish o7planning.org
  • Deflater.finish()
  • DeflaterOutputStream.finish()
  • GZIPOutputStream.finish()
  • InflaterOutputStream.finish()
  • ZipOutputStream.finish()


finishConnect

finishConnect o7planning.org
  • SocketChannel.finishConnect()


finishDraggingTo

finishDraggingTo o7planning.org
  • BasicSplitPaneDivider.finishDraggingTo(int)
  • BasicSplitPaneUI.finishDraggingTo(int)


finished

finished o7planning.org
  • Deflater.finished()
  • Inflater.finished()


finishedPaintingChildren

finishedPaintingChildren o7planning.org
  • BasicSplitPaneUI.finishedPaintingChildren(JSplitPane, Graphics)
  • MultiSplitPaneUI.finishedPaintingChildren(JSplitPane, Graphics)
  • SplitPaneUI.finishedPaintingChildren(JSplitPane, Graphics)
  • SynthSplitPaneUI.finishedPaintingChildren(JSplitPane, Graphics)


finisher

finisher o7planning.org
  • Collector.finisher()


Finishings

Finishings o7planning.org
  • Finishings.Finishings(int)


fireActionEvent

fireActionEvent o7planning.org
  • JComboBox.fireActionEvent()


fireActionPerformed

fireActionPerformed o7planning.org
  • AbstractButton.fireActionPerformed(ActionEvent)
  • DefaultButtonModel.fireActionPerformed(ActionEvent)
  • JFileChooser.fireActionPerformed(String)
  • JTextField.fireActionPerformed()
  • Timer.fireActionPerformed(ActionEvent)


fireAdjustmentValueChanged

fireAdjustmentValueChanged o7planning.org
  • JScrollBar.fireAdjustmentValueChanged(int, int, int)


fireCaretUpdate

fireCaretUpdate o7planning.org
  • JTextComponent.fireCaretUpdate(CaretEvent)


fireChangedUpdate

fireChangedUpdate o7planning.org
  • AbstractDocument.fireChangedUpdate(DocumentEvent)
  • HTMLDocument.fireChangedUpdate(DocumentEvent)


fireChildrenAdded

fireChildrenAdded o7planning.org
  • BeanContextSupport.fireChildrenAdded(BeanContextMembershipEvent)


fireChildrenRemoved

fireChildrenRemoved o7planning.org
  • BeanContextSupport.fireChildrenRemoved(BeanContextMembershipEvent)


fireColumnAdded

fireColumnAdded o7planning.org
  • DefaultTableColumnModel.fireColumnAdded(TableColumnModelEvent)


fireColumnMarginChanged

fireColumnMarginChanged o7planning.org
  • DefaultTableColumnModel.fireColumnMarginChanged()


fireColumnMoved

fireColumnMoved o7planning.org
  • DefaultTableColumnModel.fireColumnMoved(TableColumnModelEvent)


fireColumnRemoved

fireColumnRemoved o7planning.org
  • DefaultTableColumnModel.fireColumnRemoved(TableColumnModelEvent)


fireColumnSelectionChanged

fireColumnSelectionChanged o7planning.org
  • DefaultTableColumnModel.fireColumnSelectionChanged(ListSelectionEvent)


fireContentsChanged

fireContentsChanged o7planning.org
  • AbstractListModel.fireContentsChanged(Object, int, int)
  • BasicDirectoryModel.fireContentsChanged()


fireDragGestureRecognized

fireDragGestureRecognized o7planning.org
  • DragGestureRecognizer.fireDragGestureRecognized(int, Point)


fireEditingCanceled

fireEditingCanceled o7planning.org
  • AbstractCellEditor.fireEditingCanceled()


fireEditingStopped

fireEditingStopped o7planning.org
  • AbstractCellEditor.fireEditingStopped()


fireHyperlinkUpdate

fireHyperlinkUpdate o7planning.org
  • JEditorPane.fireHyperlinkUpdate(HyperlinkEvent)


fireIndexedPropertyChange

fireIndexedPropertyChange o7planning.org
  • PropertyChangeSupport.fireIndexedPropertyChange(String, int, boolean, boolean)
  • PropertyChangeSupport.fireIndexedPropertyChange(String, int, int, int)
  • PropertyChangeSupport.fireIndexedPropertyChange(String, int, Object, Object)


fireInsertUpdate

fireInsertUpdate o7planning.org
  • AbstractDocument.fireInsertUpdate(DocumentEvent)


fireInternalFrameEvent

fireInternalFrameEvent o7planning.org
  • JInternalFrame.fireInternalFrameEvent(int)


fireIntervalAdded

fireIntervalAdded o7planning.org
  • AbstractListModel.fireIntervalAdded(Object, int, int)


fireIntervalRemoved

fireIntervalRemoved o7planning.org
  • AbstractListModel.fireIntervalRemoved(Object, int, int)


fireItemStateChanged

fireItemStateChanged o7planning.org
  • AbstractButton.fireItemStateChanged(ItemEvent)
  • DefaultButtonModel.fireItemStateChanged(ItemEvent)
  • JComboBox.fireItemStateChanged(ItemEvent)


fireMenuCanceled

fireMenuCanceled o7planning.org
  • JMenu.fireMenuCanceled()


fireMenuDeselected

fireMenuDeselected o7planning.org
  • JMenu.fireMenuDeselected()


fireMenuDragMouseDragged

fireMenuDragMouseDragged o7planning.org
  • JMenuItem.fireMenuDragMouseDragged(MenuDragMouseEvent)


fireMenuDragMouseEntered

fireMenuDragMouseEntered o7planning.org
  • JMenuItem.fireMenuDragMouseEntered(MenuDragMouseEvent)


fireMenuDragMouseExited

fireMenuDragMouseExited o7planning.org
  • JMenuItem.fireMenuDragMouseExited(MenuDragMouseEvent)


fireMenuDragMouseReleased

fireMenuDragMouseReleased o7planning.org
  • JMenuItem.fireMenuDragMouseReleased(MenuDragMouseEvent)


fireMenuKeyPressed

fireMenuKeyPressed o7planning.org
  • JMenuItem.fireMenuKeyPressed(MenuKeyEvent)


fireMenuKeyReleased

fireMenuKeyReleased o7planning.org
  • JMenuItem.fireMenuKeyReleased(MenuKeyEvent)


fireMenuKeyTyped

fireMenuKeyTyped o7planning.org
  • JMenuItem.fireMenuKeyTyped(MenuKeyEvent)


fireMenuSelected

fireMenuSelected o7planning.org
  • JMenu.fireMenuSelected()


firePopupMenuCanceled

firePopupMenuCanceled o7planning.org
  • BasicComboPopup.firePopupMenuCanceled()
  • JComboBox.firePopupMenuCanceled()
  • JPopupMenu.firePopupMenuCanceled()


firePopupMenuWillBecomeInvisible

firePopupMenuWillBecomeInvisible o7planning.org
  • BasicComboPopup.firePopupMenuWillBecomeInvisible()
  • JComboBox.firePopupMenuWillBecomeInvisible()
  • JPopupMenu.firePopupMenuWillBecomeInvisible()


firePopupMenuWillBecomeVisible

firePopupMenuWillBecomeVisible o7planning.org
  • BasicComboPopup.firePopupMenuWillBecomeVisible()
  • JComboBox.firePopupMenuWillBecomeVisible()
  • JPopupMenu.firePopupMenuWillBecomeVisible()


firePropertyChange

firePropertyChange o7planning.org
  • AbstractAction.firePropertyChange(String, Object, Object)
  • AccessibleContext.firePropertyChange(String, Object, Object)
  • BasicDirectoryModel.firePropertyChange(String, Object, Object)
  • BeanContextChildSupport.firePropertyChange(String, Object, Object)
  • Component.firePropertyChange(String, double, double)
  • Component.firePropertyChange(String, float, float)
  • Component.firePropertyChange(String, long, long)
  • Component.firePropertyChange(String, short, short)
  • Component.firePropertyChange(String, char, char)
  • Component.firePropertyChange(String, byte, byte)
  • Component.firePropertyChange(String, int, int)
  • Component.firePropertyChange(String, boolean, boolean)
  • Component.firePropertyChange(String, Object, Object)
  • DefaultListCellRenderer.firePropertyChange(String, boolean, boolean)
  • DefaultListCellRenderer.firePropertyChange(String, double, double)
  • DefaultListCellRenderer.firePropertyChange(String, float, float)
  • DefaultListCellRenderer.firePropertyChange(String, long, long)
  • DefaultListCellRenderer.firePropertyChange(String, int, int)
  • DefaultListCellRenderer.firePropertyChange(String, short, short)
  • DefaultListCellRenderer.firePropertyChange(String, char, char)
  • DefaultListCellRenderer.firePropertyChange(String, byte, byte)
  • DefaultListCellRenderer.firePropertyChange(String, Object, Object)
  • DefaultTableCellRenderer.firePropertyChange(String, boolean, boolean)
  • DefaultTableCellRenderer.firePropertyChange(String, Object, Object)
  • DefaultTreeCellRenderer.firePropertyChange(String, boolean, boolean)
  • DefaultTreeCellRenderer.firePropertyChange(String, double, double)
  • DefaultTreeCellRenderer.firePropertyChange(String, float, float)
  • DefaultTreeCellRenderer.firePropertyChange(String, long, long)
  • DefaultTreeCellRenderer.firePropertyChange(String, int, int)
  • DefaultTreeCellRenderer.firePropertyChange(String, short, short)
  • DefaultTreeCellRenderer.firePropertyChange(String, char, char)
  • DefaultTreeCellRenderer.firePropertyChange(String, byte, byte)
  • DefaultTreeCellRenderer.firePropertyChange(String, Object, Object)
  • JComponent.firePropertyChange(String, char, char)
  • JComponent.firePropertyChange(String, int, int)
  • JComponent.firePropertyChange(String, boolean, boolean)
  • JViewport.firePropertyChange(String, Object, Object)
  • KeyboardFocusManager.firePropertyChange(String, Object, Object)
  • LayerUI.firePropertyChange(String, Object, Object)
  • PropertyChangeSupport.firePropertyChange(PropertyChangeEvent)
  • PropertyChangeSupport.firePropertyChange(String, boolean, boolean)
  • PropertyChangeSupport.firePropertyChange(String, int, int)
  • PropertyChangeSupport.firePropertyChange(String, Object, Object)
  • PropertyEditorSupport.firePropertyChange()
  • SwingPropertyChangeSupport.firePropertyChange(PropertyChangeEvent)
  • SwingWorker.firePropertyChange(String, Object, Object)
  • UIDefaults.firePropertyChange(String, Object, Object)


fireRemoveUpdate

fireRemoveUpdate o7planning.org
  • AbstractDocument.fireRemoveUpdate(DocumentEvent)


fireRowSorterChanged

fireRowSorterChanged o7planning.org
  • RowSorter.fireRowSorterChanged(int[])


fireSelectionValueChanged

fireSelectionValueChanged o7planning.org
  • JList.fireSelectionValueChanged(int, int, boolean)


fireServiceAdded

fireServiceAdded o7planning.org
  • BeanContextServicesSupport.fireServiceAdded(BeanContextServiceAvailableEvent)
  • BeanContextServicesSupport.fireServiceAdded(Class)


fireServiceRevoked

fireServiceRevoked o7planning.org
  • BeanContextServicesSupport.fireServiceRevoked(Class, boolean)
  • BeanContextServicesSupport.fireServiceRevoked(BeanContextServiceRevokedEvent)


fireSortOrderChanged

fireSortOrderChanged o7planning.org
  • RowSorter.fireSortOrderChanged()


fireStateChanged

fireStateChanged o7planning.org
  • AbstractButton.fireStateChanged()
  • AbstractSpinnerModel.fireStateChanged()
  • DefaultBoundedRangeModel.fireStateChanged()
  • DefaultButtonModel.fireStateChanged()
  • DefaultCaret.fireStateChanged()
  • DefaultColorSelectionModel.fireStateChanged()
  • DefaultSingleSelectionModel.fireStateChanged()
  • JProgressBar.fireStateChanged()
  • JSlider.fireStateChanged()
  • JSpinner.fireStateChanged()
  • JTabbedPane.fireStateChanged()
  • JViewport.fireStateChanged()
  • MenuSelectionManager.fireStateChanged()
  • StyleContext.NamedStyle.fireStateChanged()


fireTableCellUpdated

fireTableCellUpdated o7planning.org
  • AbstractTableModel.fireTableCellUpdated(int, int)


fireTableChanged

fireTableChanged o7planning.org
  • AbstractTableModel.fireTableChanged(TableModelEvent)


fireTableDataChanged

fireTableDataChanged o7planning.org
  • AbstractTableModel.fireTableDataChanged()


fireTableRowsDeleted

fireTableRowsDeleted o7planning.org
  • AbstractTableModel.fireTableRowsDeleted(int, int)


fireTableRowsInserted

fireTableRowsInserted o7planning.org
  • AbstractTableModel.fireTableRowsInserted(int, int)


fireTableRowsUpdated

fireTableRowsUpdated o7planning.org
  • AbstractTableModel.fireTableRowsUpdated(int, int)


fireTableStructureChanged

fireTableStructureChanged o7planning.org
  • AbstractTableModel.fireTableStructureChanged()


fireTreeCollapsed

fireTreeCollapsed o7planning.org
  • JTree.fireTreeCollapsed(TreePath)


fireTreeExpanded

fireTreeExpanded o7planning.org
  • JTree.fireTreeExpanded(TreePath)


fireTreeNodesChanged

fireTreeNodesChanged o7planning.org
  • DefaultTreeModel.fireTreeNodesChanged(Object, Object[], int[], Object[])


fireTreeNodesInserted

fireTreeNodesInserted o7planning.org
  • DefaultTreeModel.fireTreeNodesInserted(Object, Object[], int[], Object[])


fireTreeNodesRemoved

fireTreeNodesRemoved o7planning.org
  • DefaultTreeModel.fireTreeNodesRemoved(Object, Object[], int[], Object[])


fireTreeStructureChanged

fireTreeStructureChanged o7planning.org
  • DefaultTreeModel.fireTreeStructureChanged(Object, Object[], int[], Object[])


fireTreeWillCollapse

fireTreeWillCollapse o7planning.org
  • JTree.fireTreeWillCollapse(TreePath)


fireTreeWillExpand

fireTreeWillExpand o7planning.org
  • JTree.fireTreeWillExpand(TreePath)


fireUndoableEditUpdate

fireUndoableEditUpdate o7planning.org
  • AbstractDocument.fireUndoableEditUpdate(UndoableEditEvent)
  • HTMLDocument.fireUndoableEditUpdate(UndoableEditEvent)


fireValueChanged

fireValueChanged o7planning.org
  • DefaultListSelectionModel.fireValueChanged(int, int, boolean)
  • DefaultListSelectionModel.fireValueChanged(int, int)
  • DefaultListSelectionModel.fireValueChanged(boolean)
  • DefaultTreeSelectionModel.fireValueChanged(TreeSelectionEvent)
  • JTree.fireValueChanged(TreeSelectionEvent)


fireVetoableChange

fireVetoableChange o7planning.org
  • BeanContextChildSupport.fireVetoableChange(String, Object, Object)
  • JComponent.fireVetoableChange(String, Object, Object)
  • KeyboardFocusManager.fireVetoableChange(String, Object, Object)
  • VetoableChangeSupport.fireVetoableChange(PropertyChangeEvent)
  • VetoableChangeSupport.fireVetoableChange(String, boolean, boolean)
  • VetoableChangeSupport.fireVetoableChange(String, int, int)
  • VetoableChangeSupport.fireVetoableChange(String, Object, Object)


fireVisibleDataPropertyChange

fireVisibleDataPropertyChange o7planning.org
  • JTree.AccessibleJTree.fireVisibleDataPropertyChange()


first

first o7planning.org
  • BreakIterator.first()
  • CardLayout.first(Container)
  • CharacterIterator.first()
  • ConcurrentSkipListSet.first()
  • ContentModel.first()
  • ContentModel.first(Object)
  • ElementIterator.first()
  • ResultSet.first()
  • Segment.first()
  • SortedSet.first()
  • StringCharacterIterator.first()
  • TreeSet.first()


FIRST_LINE_END

FIRST_LINE_END o7planning.org
  • GridBagConstraints.FIRST_LINE_END


FIRST_LINE_START

FIRST_LINE_START o7planning.org
  • GridBagConstraints.FIRST_LINE_START


firstColumn

firstColumn o7planning.org
  • JTable.AccessibleJTable.AccessibleJTableModelChange.firstColumn


firstComplete

firstComplete o7planning.org
  • CountedCompleter.firstComplete()


firstDayOfMonth

firstDayOfMonth o7planning.org
  • TemporalAdjusters.firstDayOfMonth()


firstDayOfNextMonth

firstDayOfNextMonth o7planning.org
  • TemporalAdjusters.firstDayOfNextMonth()


firstDayOfNextYear

firstDayOfNextYear o7planning.org
  • TemporalAdjusters.firstDayOfNextYear()


firstDayOfYear

firstDayOfYear o7planning.org
  • Month.firstDayOfYear(boolean)
  • TemporalAdjusters.firstDayOfYear()


firstElement

firstElement o7planning.org
  • DefaultListModel.firstElement()
  • Vector.firstElement()


firstEntry

firstEntry o7planning.org
  • ConcurrentSkipListMap.firstEntry()
  • NavigableMap.firstEntry()
  • TreeMap.firstEntry()


firstInMonth

firstInMonth o7planning.org
  • TemporalAdjusters.firstInMonth(DayOfWeek)


firstKey

firstKey o7planning.org
  • ConcurrentSkipListMap.firstKey()
  • SortedMap.firstKey()
  • TreeMap.firstKey()


firstLineIndent

firstLineIndent o7planning.org
  • ParagraphView.firstLineIndent


FirstLineIndent

FirstLineIndent o7planning.org
  • StyleConstants.FirstLineIndent


firstMonthOfQuarter

firstMonthOfQuarter o7planning.org
  • Month.firstMonthOfQuarter()


firstRow

firstRow o7planning.org
  • JTable.AccessibleJTable.AccessibleJTableModelChange.firstRow
  • TableModelEvent.firstRow


fixed

fixed o7planning.org
  • Clock.fixed(Instant, ZoneId)


FIXED

FIXED o7planning.org
  • DTDConstants.FIXED


fixed_digits

fixed_digits o7planning.org
  • TypeCode.fixed_digits()


fixed_scale

fixed_scale o7planning.org
  • TypeCode.fixed_scale()


fixedCellHeightChanged

fixedCellHeightChanged o7planning.org
  • BasicListUI.fixedCellHeightChanged


fixedCellWidthChanged

fixedCellWidthChanged o7planning.org
  • BasicListUI.fixedCellWidthChanged


fixedContentLength

fixedContentLength o7planning.org
  • HttpURLConnection.fixedContentLength


fixedContentLengthLong

fixedContentLengthLong o7planning.org
  • HttpURLConnection.fixedContentLengthLong


FixedHeightLayoutCache

FixedHeightLayoutCache o7planning.org
  • FixedHeightLayoutCache.FixedHeightLayoutCache()


FixedHolder

FixedHolder o7planning.org
  • FixedHolder.FixedHolder(BigDecimal)
  • FixedHolder.FixedHolder()


FLAG_BRIDGES

FLAG_BRIDGES o7planning.org
  • LambdaMetafactory.FLAG_BRIDGES


FLAG_COMPLEX_GLYPHS

FLAG_COMPLEX_GLYPHS o7planning.org
  • GlyphVector.FLAG_COMPLEX_GLYPHS


FLAG_HAS_POSITION_ADJUSTMENTS

FLAG_HAS_POSITION_ADJUSTMENTS o7planning.org
  • GlyphVector.FLAG_HAS_POSITION_ADJUSTMENTS


FLAG_HAS_TRANSFORMS

FLAG_HAS_TRANSFORMS o7planning.org
  • GlyphVector.FLAG_HAS_TRANSFORMS


FLAG_MARKERS

FLAG_MARKERS o7planning.org
  • LambdaMetafactory.FLAG_MARKERS


FLAG_MASK

FLAG_MASK o7planning.org
  • GlyphVector.FLAG_MASK


FLAG_RUN_RTL

FLAG_RUN_RTL o7planning.org
  • GlyphVector.FLAG_RUN_RTL


FLAG_SERIALIZABLE

FLAG_SERIALIZABLE o7planning.org
  • LambdaMetafactory.FLAG_SERIALIZABLE


flags

flags o7planning.org
  • AclEntry.flags()
  • NamedValue.flags()
  • Pattern.flags()


FLASH_OPTION

FLASH_OPTION o7planning.org
  • DebugGraphics.FLASH_OPTION


flashColor

flashColor o7planning.org
  • DebugGraphics.flashColor()


flashCount

flashCount o7planning.org
  • DebugGraphics.flashCount()


flashTime

flashTime o7planning.org
  • DebugGraphics.flashTime()


flatMap

flatMap o7planning.org
  • DoubleStream.flatMap(DoubleFunction<? extends DoubleStream>)
  • IntStream.flatMap(IntFunction<? extends IntStream>)
  • LongStream.flatMap(LongFunction<? extends LongStream>)
  • Optional.flatMap(Function<? super T, Optional<U>>)
  • Stream.flatMap(Function<? super T, ? extends Stream<? extends R>>)


flatMapToDouble

flatMapToDouble o7planning.org
  • Stream.flatMapToDouble(Function<? super T, ? extends DoubleStream>)


flatMapToInt

flatMapToInt o7planning.org
  • Stream.flatMapToInt(Function<? super T, ? extends IntStream>)


flatMapToLong

flatMapToLong o7planning.org
  • Stream.flatMapToLong(Function<? super T, ? extends LongStream>)


FlatteningPathIterator

FlatteningPathIterator o7planning.org
  • FlatteningPathIterator.FlatteningPathIterator(PathIterator, double, int)
  • FlatteningPathIterator.FlatteningPathIterator(PathIterator, double)


FlavorEvent

FlavorEvent o7planning.org
  • FlavorEvent.FlavorEvent(Clipboard)


flavorsChanged

flavorsChanged o7planning.org
  • FlavorListener.flavorsChanged(FlavorEvent)


flip

flip o7planning.org
  • BitSet.flip(int, int)
  • BitSet.flip(int)
  • Buffer.flip()
  • Component.FlipBufferStrategy.flip(BufferCapabilities.FlipContents)


flipBit

flipBit o7planning.org
  • BigInteger.flipBit(int)


FlipBufferStrategy

FlipBufferStrategy o7planning.org
  • Component.FlipBufferStrategy.FlipBufferStrategy(int, BufferCapabilities)


flipEastAndWestAtEnds

flipEastAndWestAtEnds o7planning.org
  • BoxView.flipEastAndWestAtEnds(int, Position.Bias)
  • CompositeView.flipEastAndWestAtEnds(int, Position.Bias)
  • ParagraphView.flipEastAndWestAtEnds(int, Position.Bias)


Float

Float o7planning.org
  • Arc2D.Float.Float(Rectangle2D, float, float, int)
  • Arc2D.Float.Float(float, float, float, float, float, float, int)
  • Arc2D.Float.Float(int)
  • Arc2D.Float.Float()
  • CubicCurve2D.Float.Float(float, float, float, float, float, float, float, float)
  • CubicCurve2D.Float.Float()
  • Ellipse2D.Float.Float(float, float, float, float)
  • Ellipse2D.Float.Float()
  • Float.Float(String)
  • Float.Float(double)
  • Float.Float(float)
  • Line2D.Float.Float(Point2D, Point2D)
  • Line2D.Float.Float(float, float, float, float)
  • Line2D.Float.Float()
  • Path2D.Float.Float(Shape, AffineTransform)
  • Path2D.Float.Float(Shape)
  • Path2D.Float.Float(int, int)
  • Path2D.Float.Float(int)
  • Path2D.Float.Float()
  • Point2D.Float.Float(float, float)
  • Point2D.Float.Float()
  • QuadCurve2D.Float.Float(float, float, float, float, float, float)
  • QuadCurve2D.Float.Float()
  • Rectangle2D.Float.Float(float, float, float, float)
  • Rectangle2D.Float.Float()
  • RoundRectangle2D.Float.Float(float, float, float, float, float, float)
  • RoundRectangle2D.Float.Float()


FLOAT

FLOAT o7planning.org
  • CSS.Attribute.FLOAT
  • SimpleType.FLOAT
  • Types.FLOAT


floatAt

floatAt o7planning.org
  • BasicToolBarUI.floatAt(Point, Point)


FloatControl

FloatControl o7planning.org
  • FloatControl.FloatControl(FloatControl.Type, float, float, float, int, float, String)
  • FloatControl.FloatControl(FloatControl.Type, float, float, float, int, float, String, String, String, String)


FloatHolder

FloatHolder o7planning.org
  • FloatHolder.FloatHolder(float)
  • FloatHolder.FloatHolder()


floatingBorderColor

floatingBorderColor o7planning.org
  • BasicToolBarUI.floatingBorderColor


floatingColor

floatingColor o7planning.org
  • BasicToolBarUI.floatingColor


FloatSeqHelper

FloatSeqHelper o7planning.org
  • FloatSeqHelper.FloatSeqHelper()


FloatSeqHolder

FloatSeqHolder o7planning.org
  • FloatSeqHolder.FloatSeqHolder(float[])
  • FloatSeqHolder.FloatSeqHolder()


floatToIntBits

floatToIntBits o7planning.org
  • Float.floatToIntBits(float)


floatToRawIntBits

floatToRawIntBits o7planning.org
  • Float.floatToRawIntBits(float)


floatValue

floatValue o7planning.org
  • AtomicInteger.floatValue()
  • AtomicLong.floatValue()
  • BigDecimal.floatValue()
  • BigInteger.floatValue()
  • Byte.floatValue()
  • Double.floatValue()
  • DoubleAccumulator.floatValue()
  • DoubleAdder.floatValue()
  • Float.floatValue()
  • Integer.floatValue()
  • Long.floatValue()
  • LongAccumulator.floatValue()
  • LongAdder.floatValue()
  • Number.floatValue()
  • Short.floatValue()


floor

floor o7planning.org
  • ConcurrentSkipListSet.floor(E)
  • Math.floor(double)
  • NavigableSet.floor(E)
  • StrictMath.floor(double)
  • TreeSet.floor(E)


floorDiv

floorDiv o7planning.org
  • Math.floorDiv(long, long)
  • Math.floorDiv(int, int)
  • StrictMath.floorDiv(long, long)
  • StrictMath.floorDiv(int, int)


floorEntry

floorEntry o7planning.org
  • ConcurrentSkipListMap.floorEntry(K)
  • NavigableMap.floorEntry(K)
  • TreeMap.floorEntry(K)


floorKey

floorKey o7planning.org
  • ConcurrentSkipListMap.floorKey(K)
  • NavigableMap.floorKey(K)
  • TreeMap.floorKey(K)


floorMod

floorMod o7planning.org
  • Math.floorMod(long, long)
  • Math.floorMod(int, int)
  • StrictMath.floorMod(long, long)
  • StrictMath.floorMod(int, int)


floppyDriveIcon

floppyDriveIcon o7planning.org
  • BasicFileChooserUI.floppyDriveIcon


FlowLayout

FlowLayout o7planning.org
  • FlowLayout.FlowLayout(int, int, int)
  • FlowLayout.FlowLayout(int)
  • FlowLayout.FlowLayout()


FLOWS_FROM

FLOWS_FROM o7planning.org
  • AccessibleRelation.FLOWS_FROM


FLOWS_FROM_PROPERTY

FLOWS_FROM_PROPERTY o7planning.org
  • AccessibleRelation.FLOWS_FROM_PROPERTY


FLOWS_TO

FLOWS_TO o7planning.org
  • AccessibleRelation.FLOWS_TO


FLOWS_TO_PROPERTY

FLOWS_TO_PROPERTY o7planning.org
  • AccessibleRelation.FLOWS_TO_PROPERTY


FlowStrategy

FlowStrategy o7planning.org
  • FlowView.FlowStrategy.FlowStrategy()


FlowView

FlowView o7planning.org
  • FlowView.FlowView(Element, int)


Flush3DBorder

Flush3DBorder o7planning.org
  • MetalBorders.Flush3DBorder.Flush3DBorder()


flush

flush o7planning.org
  • AbstractPreferences.flush()
  • BufferedOutputStream.flush()
  • BufferedWriter.flush()
  • CharArrayWriter.flush()
  • CharsetDecoder.flush(CharBuffer)
  • CharsetEncoder.flush(ByteBuffer)
  • CipherOutputStream.flush()
  • Console.flush()
  • DataLine.flush()
  • DataOutputStream.flush()
  • DeflaterOutputStream.flush()
  • FilterOutputStream.flush()
  • FilterWriter.flush()
  • Flushable.flush()
  • Formatter.flush()
  • ForwardingJavaFileManager.flush()
  • HTMLDocument.HTMLReader.flush()
  • HTMLEditorKit.ParserCallback.flush()
  • Handler.flush()
  • Image.flush()
  • ImageInputStream.flush()
  • ImageInputStreamImpl.flush()
  • InflaterOutputStream.flush()
  • JavaFileManager.flush()
  • MemoryHandler.flush()
  • ObjectOutput.flush()
  • ObjectOutputStream.flush()
  • OutputStream.flush()
  • OutputStreamWriter.flush()
  • PipedOutputStream.flush()
  • PipedWriter.flush()
  • Preferences.flush()
  • PrintStream.flush()
  • PrintWriter.flush()
  • StreamHandler.flush()
  • StringWriter.flush()
  • Writer.flush()
  • XMLEncoder.flush()
  • XMLEventWriter.flush()
  • XMLStreamWriter.flush()


FLUSH_FAILURE

FLUSH_FAILURE o7planning.org
  • ErrorManager.FLUSH_FAILURE


flushAttributes

flushAttributes o7planning.org
  • Parser.flushAttributes()


flushBefore

flushBefore o7planning.org
  • FileCacheImageOutputStream.flushBefore(long)
  • ImageInputStream.flushBefore(long)
  • ImageInputStreamImpl.flushBefore(long)
  • ImageOutputStream.flushBefore(long)
  • MemoryCacheImageInputStream.flushBefore(long)
  • MemoryCacheImageOutputStream.flushBefore(long)


flushBits

flushBits o7planning.org
  • ImageOutputStreamImpl.flushBits()


flushCaches

flushCaches o7planning.org
  • Introspector.flushCaches()


flushedPos

flushedPos o7planning.org
  • ImageInputStreamImpl.flushedPos


flushFromCaches

flushFromCaches o7planning.org
  • Introspector.flushFromCaches(Class<?>)


flushRequirementChanges

flushRequirementChanges o7planning.org
  • AsyncBoxView.flushRequirementChanges()


flushSpi

flushSpi o7planning.org
  • AbstractPreferences.flushSpi()


focus

focus o7planning.org
  • BasicTabbedPaneUI.focus


FOCUS

FOCUS o7planning.org
  • ColorType.FOCUS


FOCUS_ACCELERATOR_KEY

FOCUS_ACCELERATOR_KEY o7planning.org
  • JTextComponent.FOCUS_ACCELERATOR_KEY


FOCUS_EVENT_MASK

FOCUS_EVENT_MASK o7planning.org
  • AWTEvent.FOCUS_EVENT_MASK


FOCUS_FIRST

FOCUS_FIRST o7planning.org
  • FocusEvent.FOCUS_FIRST


FOCUS_GAINED

FOCUS_GAINED o7planning.org
  • FocusEvent.FOCUS_GAINED


FOCUS_LAST

FOCUS_LAST o7planning.org
  • FocusEvent.FOCUS_LAST


FOCUS_LOST

FOCUS_LOST o7planning.org
  • FocusEvent.FOCUS_LOST


FOCUS_MANAGER_CLASS_PROPERTY

FOCUS_MANAGER_CLASS_PROPERTY o7planning.org
  • FocusManager.FOCUS_MANAGER_CLASS_PROPERTY


FOCUS_PAINTED_CHANGED_PROPERTY

FOCUS_PAINTED_CHANGED_PROPERTY o7planning.org
  • AbstractButton.FOCUS_PAINTED_CHANGED_PROPERTY


FOCUSABLE

FOCUSABLE o7planning.org
  • AccessibleState.FOCUSABLE


FocusAdapter

FocusAdapter o7planning.org
  • FocusAdapter.FocusAdapter()


focusColor

focusColor o7planning.org
  • MetalButtonUI.focusColor
  • MetalRadioButtonUI.focusColor
  • MetalToggleButtonUI.focusColor


FOCUSED

FOCUSED o7planning.org
  • AccessibleState.FOCUSED
  • SynthConstants.FOCUSED


focusedCompIndex

focusedCompIndex o7planning.org
  • BasicToolBarUI.focusedCompIndex


FocusEvent

FocusEvent o7planning.org
  • FocusEvent.FocusEvent(Component, int)
  • FocusEvent.FocusEvent(Component, int, boolean)
  • FocusEvent.FocusEvent(Component, int, boolean, Component)


focusGained

focusGained o7planning.org
  • AWTEventMulticaster.focusGained(FocusEvent)
  • BasicButtonListener.focusGained(FocusEvent)
  • BasicComboBoxEditor.focusGained(FocusEvent)
  • BasicComboBoxUI.FocusHandler.focusGained(FocusEvent)
  • BasicListUI.FocusHandler.focusGained(FocusEvent)
  • BasicSliderUI.FocusHandler.focusGained(FocusEvent)
  • BasicSplitPaneUI.FocusHandler.focusGained(FocusEvent)
  • BasicTabbedPaneUI.FocusHandler.focusGained(FocusEvent)
  • BasicTableUI.FocusHandler.focusGained(FocusEvent)
  • BasicToolBarUI.ToolBarFocusListener.focusGained(FocusEvent)
  • BasicTreeUI.FocusHandler.focusGained(FocusEvent)
  • Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusGained(FocusEvent)
  • DefaultCaret.focusGained(FocusEvent)
  • FocusAdapter.focusGained(FocusEvent)
  • FocusListener.focusGained(FocusEvent)
  • JComponent.AccessibleJComponent.AccessibleFocusHandler.focusGained(FocusEvent)


FocusHandler

FocusHandler o7planning.org
  • BasicComboBoxUI.FocusHandler.FocusHandler()
  • BasicListUI.FocusHandler.FocusHandler()
  • BasicSliderUI.FocusHandler.FocusHandler()
  • BasicSplitPaneUI.FocusHandler.FocusHandler()
  • BasicTabbedPaneUI.FocusHandler.FocusHandler()
  • BasicTableUI.FocusHandler.FocusHandler()
  • BasicTreeUI.FocusHandler.FocusHandler()


focusInsets

focusInsets o7planning.org
  • BasicSliderUI.focusInsets


focusListener

focusListener o7planning.org
  • BasicComboBoxUI.focusListener
  • BasicListUI.focusListener
  • BasicSliderUI.focusListener
  • BasicSplitPaneUI.focusListener
  • BasicTabbedPaneUI.focusListener
  • BasicTableUI.focusListener


focusLost

focusLost o7planning.org
  • AWTEventMulticaster.focusLost(FocusEvent)
  • BasicButtonListener.focusLost(FocusEvent)
  • BasicComboBoxEditor.focusLost(FocusEvent)
  • BasicComboBoxUI.FocusHandler.focusLost(FocusEvent)
  • BasicListUI.FocusHandler.focusLost(FocusEvent)
  • BasicSliderUI.FocusHandler.focusLost(FocusEvent)
  • BasicSplitPaneUI.FocusHandler.focusLost(FocusEvent)
  • BasicTabbedPaneUI.FocusHandler.focusLost(FocusEvent)
  • BasicTableUI.FocusHandler.focusLost(FocusEvent)
  • BasicToolBarUI.ToolBarFocusListener.focusLost(FocusEvent)
  • BasicTreeUI.FocusHandler.focusLost(FocusEvent)
  • Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusLost(FocusEvent)
  • DefaultCaret.focusLost(FocusEvent)
  • FocusAdapter.focusLost(FocusEvent)
  • FocusListener.focusLost(FocusEvent)
  • JComponent.AccessibleJComponent.AccessibleFocusHandler.focusLost(FocusEvent)


FocusManager

FocusManager o7planning.org
  • FocusManager.FocusManager()


focusNextComponent

focusNextComponent o7planning.org
  • DefaultKeyboardFocusManager.focusNextComponent(Component)
  • KeyboardFocusManager.focusNextComponent()
  • KeyboardFocusManager.focusNextComponent(Component)


focusPreviousComponent

focusPreviousComponent o7planning.org
  • DefaultKeyboardFocusManager.focusPreviousComponent(Component)
  • KeyboardFocusManager.focusPreviousComponent()
  • KeyboardFocusManager.focusPreviousComponent(Component)


focusRect

focusRect o7planning.org
  • BasicSliderUI.focusRect


FocusTraversalPolicy

FocusTraversalPolicy o7planning.org
  • FocusTraversalPolicy.FocusTraversalPolicy()


foldArguments

foldArguments o7planning.org
  • MethodHandles.foldArguments(MethodHandle, MethodHandle)


FolderIcon16

FolderIcon16 o7planning.org
  • MetalIconFactory.FolderIcon16.FolderIcon16()


FOLIO

FOLIO o7planning.org
  • MediaSize.Other.FOLIO
  • MediaSizeName.FOLIO
  • PageAttributes.MediaType.FOLIO


following

following o7planning.org
  • BreakIterator.following(int)


Font

Font o7planning.org
  • Font.Font(Font)
  • Font.Font(Map<? extends AttributedCharacterIterator.Attribute, ?>)
  • Font.Font(String, int, int)


FONT

FONT o7planning.org
  • CSS.Attribute.FONT
  • HTML.Tag.FONT


font

font o7planning.org
  • DefaultTreeCellEditor.font


FONT_CHANGE_BIGGER

FONT_CHANGE_BIGGER o7planning.org
  • HTMLEditorKit.FONT_CHANGE_BIGGER


FONT_CHANGE_SMALLER

FONT_CHANGE_SMALLER o7planning.org
  • HTMLEditorKit.FONT_CHANGE_SMALLER


FONT_CHOOSER

FONT_CHOOSER o7planning.org
  • AccessibleRole.FONT_CHOOSER


FONT_FAMILY

FONT_FAMILY o7planning.org
  • CSS.Attribute.FONT_FAMILY


FONT_SIZE

FONT_SIZE o7planning.org
  • CSS.Attribute.FONT_SIZE


FONT_STYLE

FONT_STYLE o7planning.org
  • CSS.Attribute.FONT_STYLE


FONT_VARIANT

FONT_VARIANT o7planning.org
  • CSS.Attribute.FONT_VARIANT


FONT_WEIGHT

FONT_WEIGHT o7planning.org
  • CSS.Attribute.FONT_WEIGHT


fontChanged

fontChanged o7planning.org
  • BasicListUI.fontChanged


FontFamily

FontFamily o7planning.org
  • StyleConstants.FontFamily


FontFamilyAction

FontFamilyAction o7planning.org
  • StyledEditorKit.FontFamilyAction.FontFamilyAction(String, String)


FontFormatException

FontFormatException o7planning.org
  • FontFormatException.FontFormatException(String)


FontMetrics

FontMetrics o7planning.org
  • FontMetrics.FontMetrics(Font)


FontRenderContext

FontRenderContext o7planning.org
  • FontRenderContext.FontRenderContext(AffineTransform, Object, Object)
  • FontRenderContext.FontRenderContext(AffineTransform, boolean, boolean)
  • FontRenderContext.FontRenderContext()


FontSize

FontSize o7planning.org
  • StyleConstants.FontSize


FontSizeAction

FontSizeAction o7planning.org
  • StyledEditorKit.FontSizeAction.FontSizeAction(String, int)


FontUIResource

FontUIResource o7planning.org
  • FontUIResource.FontUIResource(Font)
  • FontUIResource.FontUIResource(String, int, int)


FOOTER

FOOTER o7planning.org
  • AccessibleRole.FOOTER


force

force o7planning.org
  • AsynchronousFileChannel.force(boolean)
  • FileChannel.force(boolean)
  • MappedByteBuffer.force()


ForcedBreakWeight

ForcedBreakWeight o7planning.org
  • View.ForcedBreakWeight


forceTermination

forceTermination o7planning.org
  • Phaser.forceTermination()


forClass

forClass o7planning.org
  • ObjectStreamClass.forClass()


forDigit

forDigit o7planning.org
  • Character.forDigit(int, int)


forEach

forEach o7planning.org
  • ArrayList.forEach(Consumer<? super E>)
  • ConcurrentHashMap.forEach(long, BiFunction<? super K, ? super V, ? extends U>, Consumer<? super U>)
  • ConcurrentHashMap.forEach(long, BiConsumer<? super K, ? super V>)
  • ConcurrentHashMap.forEach(BiConsumer<? super K, ? super V>)
  • ConcurrentHashMap.KeySetView.forEach(Consumer<? super K>)
  • ConcurrentMap.forEach(BiConsumer<? super K, ? super V>)
  • ConcurrentSkipListMap.forEach(BiConsumer<? super K, ? super V>)
  • CopyOnWriteArrayList.forEach(Consumer<? super E>)
  • CopyOnWriteArraySet.forEach(Consumer<? super E>)
  • DoubleStream.forEach(DoubleConsumer)
  • HashMap.forEach(BiConsumer<? super K, ? super V>)
  • Hashtable.forEach(BiConsumer<? super K, ? super V>)
  • IdentityHashMap.forEach(BiConsumer<? super K, ? super V>)
  • IntStream.forEach(IntConsumer)
  • Iterable.forEach(Consumer<? super T>)
  • LinkedHashMap.forEach(BiConsumer<? super K, ? super V>)
  • LongStream.forEach(LongConsumer)
  • Map.forEach(BiConsumer<? super K, ? super V>)
  • Provider.forEach(BiConsumer<? super Object, ? super Object>)
  • Stream.forEach(Consumer<? super T>)
  • TreeMap.forEach(BiConsumer<? super K, ? super V>)
  • Vector.forEach(Consumer<? super E>)
  • WeakHashMap.forEach(BiConsumer<? super K, ? super V>)


forEachEntry

forEachEntry o7planning.org
  • ConcurrentHashMap.forEachEntry(long, Function<Map.Entry<K, V>, ? extends U>, Consumer<? super U>)
  • ConcurrentHashMap.forEachEntry(long, Consumer<? super Map.Entry<K, V>>)


forEachKey

forEachKey o7planning.org
  • ConcurrentHashMap.forEachKey(long, Function<? super K, ? extends U>, Consumer<? super U>)
  • ConcurrentHashMap.forEachKey(long, Consumer<? super K>)


forEachOrdered

forEachOrdered o7planning.org
  • DoubleStream.forEachOrdered(DoubleConsumer)
  • IntStream.forEachOrdered(IntConsumer)
  • LongStream.forEachOrdered(LongConsumer)
  • Stream.forEachOrdered(Consumer<? super T>)


forEachRemaining

forEachRemaining o7planning.org
  • Iterator.forEachRemaining(Consumer<? super E>)
  • PrimitiveIterator.forEachRemaining(T_CONS)
  • PrimitiveIterator.OfDouble.forEachRemaining(Consumer<? super Double>)
  • PrimitiveIterator.OfDouble.forEachRemaining(DoubleConsumer)
  • PrimitiveIterator.OfInt.forEachRemaining(Consumer<? super Integer>)
  • PrimitiveIterator.OfInt.forEachRemaining(IntConsumer)
  • PrimitiveIterator.OfLong.forEachRemaining(Consumer<? super Long>)
  • PrimitiveIterator.OfLong.forEachRemaining(LongConsumer)
  • Spliterator.forEachRemaining(Consumer<? super T>)
  • Spliterator.OfDouble.forEachRemaining(Consumer<? super Double>)
  • Spliterator.OfDouble.forEachRemaining(DoubleConsumer)
  • Spliterator.OfInt.forEachRemaining(Consumer<? super Integer>)
  • Spliterator.OfInt.forEachRemaining(IntConsumer)
  • Spliterator.OfLong.forEachRemaining(Consumer<? super Long>)
  • Spliterator.OfLong.forEachRemaining(LongConsumer)
  • Spliterator.OfPrimitive.forEachRemaining(T_CONS)


forEachValue

forEachValue o7planning.org
  • ConcurrentHashMap.forEachValue(long, Function<? super V, ? extends U>, Consumer<? super U>)
  • ConcurrentHashMap.forEachValue(long, Consumer<? super V>)


FOREGROUND

FOREGROUND o7planning.org
  • ColorType.FOREGROUND
  • TextAttribute.FOREGROUND


Foreground

Foreground o7planning.org
  • StyleConstants.Foreground


ForegroundAction

ForegroundAction o7planning.org
  • StyledEditorKit.ForegroundAction.ForegroundAction(String, Color)


forget

forget o7planning.org
  • XAResource.forget(Xid)


fork

fork o7planning.org
  • ForkJoinTask.fork()


ForkJoinPool

ForkJoinPool o7planning.org
  • ForkJoinPool.ForkJoinPool(int, ForkJoinPool.ForkJoinWorkerThreadFactory, Thread.UncaughtExceptionHandler, boolean)
  • ForkJoinPool.ForkJoinPool(int)
  • ForkJoinPool.ForkJoinPool()


ForkJoinTask

ForkJoinTask o7planning.org
  • ForkJoinTask.ForkJoinTask()


ForkJoinWorkerThread

ForkJoinWorkerThread o7planning.org
  • ForkJoinWorkerThread.ForkJoinWorkerThread(ForkJoinPool)


forLanguageTag

forLanguageTag o7planning.org
  • Locale.forLanguageTag(String)


FORM

FORM o7planning.org
  • HTML.Tag.FORM


FormAction

FormAction o7planning.org
  • HTMLDocument.HTMLReader.FormAction.FormAction()


format

format o7planning.org
  • AudioInputStream.format
  • ChronoLocalDate.format(DateTimeFormatter)
  • ChronoLocalDateTime.format(DateTimeFormatter)
  • ChronoZonedDateTime.format(DateTimeFormatter)
  • DateTimeFormatter.format(TemporalAccessor)
  • Encoding.format
  • Format.format(Object, StringBuffer, FieldPosition)
  • Format.format(Object)
  • Formatter.format(LogRecord)
  • Formatter.format(Locale, String, Object...)
  • Formatter.format(String, Object...)
  • LocalDate.format(DateTimeFormatter)
  • LocalDateTime.format(DateTimeFormatter)
  • LocalTime.format(DateTimeFormatter)
  • MessageFormat.format(Object, StringBuffer, FieldPosition)
  • MessageFormat.format(String, Object...)
  • MessageFormat.format(Object[], StringBuffer, FieldPosition)
  • MonthDay.format(DateTimeFormatter)
  • NumberFormat.format(long, StringBuffer, FieldPosition)
  • NumberFormat.format(double, StringBuffer, FieldPosition)
  • NumberFormat.format(long)
  • NumberFormat.format(double)
  • NumberFormat.format(Object, StringBuffer, FieldPosition)
  • OffsetDateTime.format(DateTimeFormatter)
  • OffsetTime.format(DateTimeFormatter)
  • SimpleDateFormat.format(Date, StringBuffer, FieldPosition)
  • SimpleFormatter.format(LogRecord)
  • XMLFormatter.format(LogRecord)
  • Year.format(DateTimeFormatter)
  • YearMonth.format(DateTimeFormatter)
  • ZonedDateTime.format(DateTimeFormatter)


FORMAT

FORMAT o7planning.org
  • Character.FORMAT


Format

Format o7planning.org
  • Format.Format()


FORMAT_CLASS

FORMAT_CLASS o7planning.org
  • ResourceBundle.Control.FORMAT_CLASS


FORMAT_DEFAULT

FORMAT_DEFAULT o7planning.org
  • ResourceBundle.Control.FORMAT_DEFAULT


FORMAT_FAILURE

FORMAT_FAILURE o7planning.org
  • ErrorManager.FORMAT_FAILURE


FORMAT_PROPERTIES

FORMAT_PROPERTIES o7planning.org
  • ResourceBundle.Control.FORMAT_PROPERTIES


FormatConversionProvider

FormatConversionProvider o7planning.org
  • FormatConversionProvider.FormatConversionProvider()


FormatFlagsConversionMismatchException

FormatFlagsConversionMismatchException o7planning.org
  • FormatFlagsConversionMismatchException.FormatFlagsConversionMismatchException(String, char)


formatMessage

formatMessage o7planning.org
  • Formatter.formatMessage(LogRecord)


FormatMismatch

FormatMismatch o7planning.org
  • FormatMismatch.FormatMismatch(String)
  • FormatMismatch.FormatMismatch()


FormatMismatchHelper

FormatMismatchHelper o7planning.org
  • FormatMismatchHelper.FormatMismatchHelper()


FORMATTED_TEXT_FIELD

FORMATTED_TEXT_FIELD o7planning.org
  • Region.FORMATTED_TEXT_FIELD


Formatter

Formatter o7planning.org
  • Formatter.Formatter()
  • Formatter.Formatter(OutputStream, String, Locale)
  • Formatter.Formatter(OutputStream, String)
  • Formatter.Formatter(OutputStream)
  • Formatter.Formatter(PrintStream)
  • Formatter.Formatter(File, String, Locale)
  • Formatter.Formatter(File, String)
  • Formatter.Formatter(File)
  • Formatter.Formatter(String, String, Locale)
  • Formatter.Formatter(String, String)
  • Formatter.Formatter(String)
  • Formatter.Formatter(Appendable, Locale)
  • Formatter.Formatter(Locale)
  • Formatter.Formatter(Appendable)
  • Formatter.Formatter()


FormatterClosedException

FormatterClosedException o7planning.org
  • FormatterClosedException.FormatterClosedException()


formatTo

formatTo o7planning.org
  • DateTimeFormatter.formatTo(TemporalAccessor, Appendable)
  • Formattable.formatTo(Formatter, int, int, int)


formatToCharacterIterator

formatToCharacterIterator o7planning.org
  • DecimalFormat.formatToCharacterIterator(Object)
  • Format.formatToCharacterIterator(Object)
  • MessageFormat.formatToCharacterIterator(Object)
  • SimpleDateFormat.formatToCharacterIterator(Object)


FormView

FormView o7planning.org
  • FormView.FormView(Element)


forName

forName o7planning.org
  • Character.UnicodeBlock.forName(String)
  • Character.UnicodeScript.forName(String)
  • Charset.forName(String)
  • Class.forName(String, boolean, ClassLoader)
  • Class.forName(String)


Forward

Forward o7planning.org
  • Position.Bias.Forward


forward

forward o7planning.org
  • ForwardRequest.forward


forward_reference

forward_reference o7planning.org
  • ForwardRequest.forward_reference
  • RequestInfoOperations.forward_reference()


FORWARD_TRAVERSAL_KEYS

FORWARD_TRAVERSAL_KEYS o7planning.org
  • KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS


forwardAction

forwardAction o7planning.org
  • DefaultEditorKit.forwardAction


ForwardingFileObject

ForwardingFileObject o7planning.org
  • ForwardingFileObject.ForwardingFileObject(F)


ForwardingJavaFileManager

ForwardingJavaFileManager o7planning.org
  • ForwardingJavaFileManager.ForwardingJavaFileManager(M)


ForwardingJavaFileObject

ForwardingJavaFileObject o7planning.org
  • ForwardingJavaFileObject.ForwardingJavaFileObject(F)


ForwardRequest

ForwardRequest o7planning.org
  • ForwardRequest.ForwardRequest(String, Object)
  • ForwardRequest.ForwardRequest(Object)
  • ForwardRequest.ForwardRequest()
  • ForwardRequest.ForwardRequest(String, Object)
  • ForwardRequest.ForwardRequest(Object)
  • ForwardRequest.ForwardRequest()


ForwardRequestHelper

ForwardRequestHelper o7planning.org
  • ForwardRequestHelper.ForwardRequestHelper()
  • ForwardRequestHelper.ForwardRequestHelper()


forwardUpdate

forwardUpdate o7planning.org
  • BoxView.forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory)
  • TableView.forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory)
  • View.forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory)


forwardUpdateToView

forwardUpdateToView o7planning.org
  • View.forwardUpdateToView(View, DocumentEvent, Shape, ViewFactory)


foundType

foundType o7planning.org
  • AnnotationTypeMismatchException.foundType()


FRACTION

FRACTION o7planning.org
  • NumberFormat.Field.FRACTION


FRACTION_FIELD

FRACTION_FIELD o7planning.org
  • NumberFormat.FRACTION_FIELD


fragmentHtmlFlavor

fragmentHtmlFlavor o7planning.org
  • DataFlavor.fragmentHtmlFlavor


Frame

Frame o7planning.org
  • Frame.Frame(String, GraphicsConfiguration)
  • Frame.Frame(String)
  • Frame.Frame(GraphicsConfiguration)
  • Frame.Frame()


FRAME

FRAME o7planning.org
  • HTML.Tag.FRAME


frame

frame o7planning.org
  • BasicDesktopIconUI.frame
  • BasicInternalFrameTitlePane.frame
  • BasicInternalFrameUI.frame


FRAME_CONTENT_LAYER

FRAME_CONTENT_LAYER o7planning.org
  • JLayeredPane.FRAME_CONTENT_LAYER


FRAME_ICON_PROPERTY

FRAME_ICON_PROPERTY o7planning.org
  • JInternalFrame.FRAME_ICON_PROPERTY


FRAMEBITS

FRAMEBITS o7planning.org
  • ImageObserver.FRAMEBITS


FRAMEBORDER

FRAMEBORDER o7planning.org
  • HTML.Attribute.FRAMEBORDER


frameIcon

frameIcon o7planning.org
  • JInternalFrame.frameIcon


frameInit

frameInit o7planning.org
  • JFrame.frameInit()


frameLength

frameLength o7planning.org
  • AudioInputStream.frameLength


FrameListener

FrameListener o7planning.org
  • BasicToolBarUI.FrameListener.FrameListener()


framePos

framePos o7planning.org
  • AudioInputStream.framePos


frameRate

frameRate o7planning.org
  • AudioFormat.frameRate


FRAMESET

FRAMESET o7planning.org
  • HTML.Tag.FRAMESET


frameSize

frameSize o7planning.org
  • AudioFormat.frameSize
  • AudioInputStream.frameSize


FRANCE

FRANCE o7planning.org
  • Locale.FRANCE


free

free o7planning.org
  • Array.free()
  • Blob.free()
  • Clob.free()
  • SQLXML.free()
  • SerialArray.free()
  • SerialBlob.free()
  • SerialClob.free()


FREE_MEM

FREE_MEM o7planning.org
  • FREE_MEM.FREE_MEM(String, int, CompletionStatus)
  • FREE_MEM.FREE_MEM(int, CompletionStatus)
  • FREE_MEM.FREE_MEM(String)
  • FREE_MEM.FREE_MEM()


FREE_STANDING_PROP

FREE_STANDING_PROP o7planning.org
  • MetalScrollBarUI.FREE_STANDING_PROP


freeMemory

freeMemory o7planning.org
  • Runtime.freeMemory()


FRENCH

FRENCH o7planning.org
  • Locale.FRENCH


frequency

frequency o7planning.org
  • Collections.frequency(Collection<?>, Object)


FRIDAY

FRIDAY o7planning.org
  • Calendar.FRIDAY


from

from o7planning.org
  • ChronoLocalDate.from(TemporalAccessor)
  • ChronoLocalDateTime.from(TemporalAccessor)
  • ChronoZonedDateTime.from(TemporalAccessor)
  • Chronology.from(TemporalAccessor)
  • Date.from(Instant)
  • DayOfWeek.from(TemporalAccessor)
  • Duration.from(TemporalAmount)
  • FileTime.from(Instant)
  • FileTime.from(long, TimeUnit)
  • GregorianCalendar.from(ZonedDateTime)
  • HijrahDate.from(TemporalAccessor)
  • Instant.from(TemporalAccessor)
  • JapaneseDate.from(TemporalAccessor)
  • LocalDate.from(TemporalAccessor)
  • LocalDateTime.from(TemporalAccessor)
  • LocalTime.from(TemporalAccessor)
  • LockInfo.from(CompositeData)
  • MemoryNotificationInfo.from(CompositeData)
  • MemoryUsage.from(CompositeData)
  • MinguoDate.from(TemporalAccessor)
  • MonitorInfo.from(CompositeData)
  • Month.from(TemporalAccessor)
  • MonthDay.from(TemporalAccessor)
  • OffsetDateTime.from(TemporalAccessor)
  • OffsetTime.from(TemporalAccessor)
  • Period.from(TemporalAmount)
  • ProcessBuilder.Redirect.from(File)
  • ThaiBuddhistDate.from(TemporalAccessor)
  • ThreadInfo.from(CompositeData)
  • Timestamp.from(Instant)
  • Year.from(TemporalAccessor)
  • YearMonth.from(TemporalAccessor)
  • ZoneId.from(TemporalAccessor)
  • ZoneOffset.from(TemporalAccessor)
  • ZonedDateTime.from(TemporalAccessor)


from_any

from_any o7planning.org
  • DynAny.from_any(Any)
  • DynAnyOperations.from_any(Any)
  • _DynAnyStub.from_any(Any)
  • _DynArrayStub.from_any(Any)
  • _DynEnumStub.from_any(Any)
  • _DynFixedStub.from_any(Any)
  • _DynSequenceStub.from_any(Any)
  • _DynStructStub.from_any(Any)
  • _DynUnionStub.from_any(Any)
  • _DynValueStub.from_any(Any)


from_int

from_int o7planning.org
  • BindingType.from_int(int)
  • CompletionStatus.from_int(int)
  • DefinitionKind.from_int(int)
  • IdAssignmentPolicyValue.from_int(int)
  • IdUniquenessPolicyValue.from_int(int)
  • ImplicitActivationPolicyValue.from_int(int)
  • LifespanPolicyValue.from_int(int)
  • NotFoundReason.from_int(int)
  • ParameterMode.from_int(int)
  • RequestProcessingPolicyValue.from_int(int)
  • ServantRetentionPolicyValue.from_int(int)
  • SetOverrideType.from_int(int)
  • State.from_int(int)
  • TCKind.from_int(int)
  • ThreadPolicyValue.from_int(int)


fromCIEXYZ

fromCIEXYZ o7planning.org
  • ColorSpace.fromCIEXYZ(float[])
  • ICC_ColorSpace.fromCIEXYZ(float[])


fromIndex

fromIndex o7planning.org
  • TableColumnModelEvent.fromIndex


fromMethodDescriptorString

fromMethodDescriptorString o7planning.org
  • MethodType.fromMethodDescriptorString(String, ClassLoader)


fromMillis

fromMillis o7planning.org
  • FileTime.fromMillis(long)


fromRGB

fromRGB o7planning.org
  • ColorSpace.fromRGB(float[])
  • ICC_ColorSpace.fromRGB(float[])


fromString

fromString o7planning.org
  • PosixFilePermissions.fromString(String)
  • UUID.fromString(String)


FTP

FTP o7planning.org
  • ReferenceUriSchemesSupported.FTP


FULL

FULL o7planning.org
  • DateFormat.FULL


FULL_DECOMPOSITION

FULL_DECOMPOSITION o7planning.org
  • Collator.FULL_DECOMPOSITION


FULL_FLUSH

FULL_FLUSH o7planning.org
  • Deflater.FULL_FLUSH


FULL_JOIN

FULL_JOIN o7planning.org
  • JoinRowSet.FULL_JOIN


FULLWIDTH_DIGITS

FULLWIDTH_DIGITS o7planning.org
  • InputSubset.FULLWIDTH_DIGITS


FULLWIDTH_LATIN

FULLWIDTH_LATIN o7planning.org
  • InputSubset.FULLWIDTH_LATIN


functionColumnIn

functionColumnIn o7planning.org
  • DatabaseMetaData.functionColumnIn


functionColumnInOut

functionColumnInOut o7planning.org
  • DatabaseMetaData.functionColumnInOut


functionColumnOut

functionColumnOut o7planning.org
  • DatabaseMetaData.functionColumnOut


functionColumnResult

functionColumnResult o7planning.org
  • DatabaseMetaData.functionColumnResult


functionColumnUnknown

functionColumnUnknown o7planning.org
  • DatabaseMetaData.functionColumnUnknown


functionNoNulls

functionNoNulls o7planning.org
  • DatabaseMetaData.functionNoNulls


functionNoTable

functionNoTable o7planning.org
  • DatabaseMetaData.functionNoTable


functionNullable

functionNullable o7planning.org
  • DatabaseMetaData.functionNullable


functionNullableUnknown

functionNullableUnknown o7planning.org
  • DatabaseMetaData.functionNullableUnknown


functionResultUnknown

functionResultUnknown o7planning.org
  • DatabaseMetaData.functionResultUnknown


functionReturn

functionReturn o7planning.org
  • DatabaseMetaData.functionReturn


functionReturnsTable

functionReturnsTable o7planning.org
  • DatabaseMetaData.functionReturnsTable


FUSER_OVER_TEMP

FUSER_OVER_TEMP o7planning.org
  • PrinterStateReason.FUSER_OVER_TEMP


FUSER_UNDER_TEMP

FUSER_UNDER_TEMP o7planning.org
  • PrinterStateReason.FUSER_UNDER_TEMP


FutureTask

FutureTask o7planning.org
  • FutureTask.FutureTask(Runnable, V)
  • FutureTask.FutureTask(Callable<V>)


GAP_TOKEN

GAP_TOKEN o7planning.org
  • GSSException.GAP_TOKEN


GapContent

GapContent o7planning.org
  • GapContent.GapContent(int)
  • GapContent.GapContent()


GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE

GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE o7planning.org
  • ManagementFactory.GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE


GaugeMonitor

GaugeMonitor o7planning.org
  • GaugeMonitor.GaugeMonitor()


gc

gc o7planning.org
  • MemoryMXBean.gc()
  • Runtime.gc()
  • System.gc()


gcd

gcd o7planning.org
  • BigInteger.gcd(BigInteger)


GCMParameterSpec

GCMParameterSpec o7planning.org
  • GCMParameterSpec.GCMParameterSpec(int, byte[], int, int)
  • GCMParameterSpec.GCMParameterSpec(int, byte[])


GDAY

GDAY o7planning.org
  • DatatypeConstants.GDAY


GE

GE o7planning.org
  • Query.GE


GENERAL

GENERAL o7planning.org
  • DTDConstants.GENERAL


GENERAL_PUNCTUATION

GENERAL_PUNCTUATION o7planning.org
  • Character.UnicodeBlock.GENERAL_PUNCTUATION


GeneralPath

GeneralPath o7planning.org
  • GeneralPath.GeneralPath(Shape)
  • GeneralPath.GeneralPath(int, int)
  • GeneralPath.GeneralPath(int)
  • GeneralPath.GeneralPath()


GeneralSecurityException

GeneralSecurityException o7planning.org
  • GeneralSecurityException.GeneralSecurityException(Throwable)
  • GeneralSecurityException.GeneralSecurityException(String, Throwable)
  • GeneralSecurityException.GeneralSecurityException(String)
  • GeneralSecurityException.GeneralSecurityException()


generate

generate o7planning.org
  • DoubleStream.generate(DoubleSupplier)
  • IntStream.generate(IntSupplier)
  • LongStream.generate(LongSupplier)
  • Stream.generate(Supplier<T>)


generateCertificate

generateCertificate o7planning.org
  • CertificateFactory.generateCertificate(InputStream)


generateCertificates

generateCertificates o7planning.org
  • CertificateFactory.generateCertificates(InputStream)


generateCertPath

generateCertPath o7planning.org
  • CertificateFactory.generateCertPath(List<? extends Certificate>)
  • CertificateFactory.generateCertPath(InputStream, String)
  • CertificateFactory.generateCertPath(InputStream)


generateCRL

generateCRL o7planning.org
  • CertificateFactory.generateCRL(InputStream)


generateCRLs

generateCRLs o7planning.org
  • CertificateFactory.generateCRLs(InputStream)


generatedKeyAlwaysReturned

generatedKeyAlwaysReturned o7planning.org
  • DatabaseMetaData.generatedKeyAlwaysReturned()


generateKey

generateKey o7planning.org
  • KeyGenerator.generateKey()


generateKeyPair

generateKeyPair o7planning.org
  • KeyPairGenerator.generateKeyPair()
  • KeyPairGeneratorSpi.generateKeyPair()


generateParameters

generateParameters o7planning.org
  • AlgorithmParameterGenerator.generateParameters()


generatePrivate

generatePrivate o7planning.org
  • KeyFactory.generatePrivate(KeySpec)


generatePublic

generatePublic o7planning.org
  • KeyFactory.generatePublic(KeySpec)


generateSchema

generateSchema o7planning.org
  • JAXBContext.generateSchema(SchemaOutputResolver)


generateSecret

generateSecret o7planning.org
  • KeyAgreement.generateSecret(String)
  • KeyAgreement.generateSecret(byte[], int)
  • KeyAgreement.generateSecret()
  • SecretKeyFactory.generateSecret(KeySpec)


generateSeed

generateSeed o7planning.org
  • SecureRandom.generateSeed(int)


generic

generic o7planning.org
  • MethodType.generic()


GENERIC_FAILURE

GENERIC_FAILURE o7planning.org
  • ErrorManager.GENERIC_FAILURE


genericMethodType

genericMethodType o7planning.org
  • MethodType.genericMethodType(int)
  • MethodType.genericMethodType(int, boolean)


GenericSignatureFormatError

GenericSignatureFormatError o7planning.org
  • GenericSignatureFormatError.GenericSignatureFormatError(String)
  • GenericSignatureFormatError.GenericSignatureFormatError()


genExemptionBlob

genExemptionBlob o7planning.org
  • ExemptionMechanism.genExemptionBlob(byte[], int)
  • ExemptionMechanism.genExemptionBlob(byte[])
  • ExemptionMechanism.genExemptionBlob()


genKeyPair

genKeyPair o7planning.org
  • KeyPairGenerator.genKeyPair()


GEOMETRIC_SHAPES

GEOMETRIC_SHAPES o7planning.org
  • Character.UnicodeBlock.GEOMETRIC_SHAPES


GEORGIAN

GEORGIAN o7planning.org
  • Character.UnicodeBlock.GEORGIAN


GEORGIAN_SUPPLEMENT

GEORGIAN_SUPPLEMENT o7planning.org
  • Character.UnicodeBlock.GEORGIAN_SUPPLEMENT


geq

geq o7planning.org
  • Query.geq(ValueExp, ValueExp)


GERMAN

GERMAN o7planning.org
  • Locale.GERMAN


GERMANY

GERMANY o7planning.org
  • Locale.GERMANY


get2DigitYearStart

get2DigitYearStart o7planning.org
  • SimpleDateFormat.get2DigitYearStart()


get

get o7planning.org
  • AbstractList.get(int)
  • AbstractMap.get(Object)
  • AbstractPreferences.get(String, String)
  • AbstractScriptEngine.get(String)
  • AbstractSequentialList.get(int)
  • AccessibleRelationSet.get(String)
  • ActionMap.get(Object)
  • Array.get(Object, int)
  • ArrayList.get(int)
  • AtomicBoolean.get()
  • AtomicInteger.get()
  • AtomicIntegerArray.get(int)
  • AtomicIntegerFieldUpdater.get(T)
  • AtomicLong.get()
  • AtomicLongArray.get(int)
  • AtomicLongFieldUpdater.get(T)
  • AtomicMarkableReference.get(boolean[])
  • AtomicReference.get()
  • AtomicReferenceArray.get(int)
  • AtomicReferenceFieldUpdater.get(T)
  • AtomicStampedReference.get(int[])
  • Attribute.get(int)
  • Attribute.get()
  • AttributeSet.get(Class<?>)
  • Attributes.get(String)
  • Attributes.get(Object)
  • BasicAttribute.get(int)
  • BasicAttribute.get()
  • BasicAttributes.get(String)
  • Bindings.get(Object)
  • BitSet.get(int, int)
  • BitSet.get(int)
  • ByteBuffer.get(byte[])
  • ByteBuffer.get(byte[], int, int)
  • ByteBuffer.get(int)
  • ByteBuffer.get()
  • Calendar.get(int)
  • CharBuffer.get(char[])
  • CharBuffer.get(char[], int, int)
  • CharBuffer.get(int)
  • CharBuffer.get()
  • ChronoPeriod.get(TemporalUnit)
  • ChronoZonedDateTime.get(TemporalField)
  • ClassValue.get(Class<?>)
  • CompletableFuture.get(long, TimeUnit)
  • CompletableFuture.get()
  • CompositeData.get(String)
  • CompositeDataSupport.get(String)
  • CompositeName.get(int)
  • CompoundName.get(int)
  • ConcurrentHashMap.get(Object)
  • ConcurrentSkipListMap.get(Object)
  • CookieHandler.get(URI, Map<String, List<String>>)
  • CookieManager.get(URI, Map<String, List<String>>)
  • CookieStore.get(URI)
  • CopyOnWriteArrayList.get(int)
  • DOMCryptoContext.get(Object)
  • DayOfWeek.get(TemporalField)
  • DefaultListModel.get(int)
  • Dictionary.get(Object)
  • DoubleAccumulator.get()
  • DoubleBuffer.get(double[])
  • DoubleBuffer.get(double[], int, int)
  • DoubleBuffer.get(int)
  • DoubleBuffer.get()
  • Duration.get(TemporalUnit)
  • Encoder.get(Object)
  • EnumMap.get(Object)
  • Era.get(TemporalField)
  • Field.get(Object)
  • FloatBuffer.get(float[])
  • FloatBuffer.get(float[], int, int)
  • FloatBuffer.get(int)
  • FloatBuffer.get()
  • ForkJoinTask.get(long, TimeUnit)
  • ForkJoinTask.get()
  • Future.get(long, TimeUnit)
  • Future.get()
  • FutureTask.get(long, TimeUnit)
  • FutureTask.get()
  • HashAttributeSet.get(Class<?>)
  • HashMap.get(Object)
  • Hashtable.get(Object)
  • IdentityHashMap.get(Object)
  • InputMap.get(KeyStroke)
  • Instant.get(TemporalField)
  • IntBuffer.get(int[])
  • IntBuffer.get(int[], int, int)
  • IntBuffer.get(int)
  • IntBuffer.get()
  • LdapName.get(int)
  • LinkedHashMap.get(Object)
  • LinkedList.get(int)
  • List.get(int)
  • LocalDate.get(TemporalField)
  • LocalDateTime.get(TemporalField)
  • LocalTime.get(TemporalField)
  • LongAccumulator.get()
  • LongBuffer.get(long[])
  • LongBuffer.get(long[], int, int)
  • LongBuffer.get(int)
  • LongBuffer.get()
  • Map.get(Object)
  • MarshalledObject.get()
  • MimeTypeParameterList.get(String)
  • Month.get(TemporalField)
  • MonthDay.get(TemporalField)
  • Name.get(int)
  • NimbusStyle.get(SynthContext, Object)
  • ObjectInputStream.GetField.get(String, Object)
  • ObjectInputStream.GetField.get(String, double)
  • ObjectInputStream.GetField.get(String, float)
  • ObjectInputStream.GetField.get(String, long)
  • ObjectInputStream.GetField.get(String, int)
  • ObjectInputStream.GetField.get(String, short)
  • ObjectInputStream.GetField.get(String, char)
  • ObjectInputStream.GetField.get(String, byte)
  • ObjectInputStream.GetField.get(String, boolean)
  • OffsetDateTime.get(TemporalField)
  • OffsetTime.get(TemporalField)
  • Optional.get()
  • Paths.get(URI)
  • Paths.get(String, String...)
  • Period.get(TemporalUnit)
  • PhantomReference.get()
  • Preferences.get(String, String)
  • Provider.get(Object)
  • Reference.get(int)
  • Reference.get(String)
  • Reference.get()
  • RenderingHints.get(Object)
  • ResponseCache.get(URI, String, Map<String, List<String>>)
  • SOAPConnection.get(Object)
  • ScriptEngine.get(String)
  • ScriptEngineManager.get(String)
  • ShortBuffer.get(short[])
  • ShortBuffer.get(short[], int, int)
  • ShortBuffer.get(int)
  • ShortBuffer.get()
  • SimpleBindings.get(Object)
  • SoftReference.get()
  • Supplier.get()
  • SwingWorker.get(long, TimeUnit)
  • SwingWorker.get()
  • SynthStyle.get(SynthContext, Object)
  • TabularData.get(Object[])
  • TabularDataSupport.get(Object[])
  • TabularDataSupport.get(Object)
  • TemporalAccessor.get(TemporalField)
  • TemporalAmount.get(TemporalUnit)
  • ThreadLocal.get()
  • Track.get(int)
  • TreeMap.get(Object)
  • UIDefaults.get(Object, Locale)
  • UIDefaults.get(Object)
  • UIManager.get(Object, Locale)
  • UIManager.get(Object)
  • Vector.get(int)
  • WeakHashMap.get(Object)
  • XMLCryptoContext.get(Object)
  • Year.get(TemporalField)
  • YearMonth.get(TemporalField)
  • ZoneOffset.get(TemporalField)
  • ZonedDateTime.get(TemporalField)


get_any

get_any o7planning.org
  • DynAny.get_any()
  • DynAnyOperations.get_any()
  • _DynAnyStub.get_any()
  • _DynArrayStub.get_any()
  • _DynEnumStub.get_any()
  • _DynFixedStub.get_any()
  • _DynSequenceStub.get_any()
  • _DynStructStub.get_any()
  • _DynUnionStub.get_any()
  • _DynValueStub.get_any()


get_as_string

get_as_string o7planning.org
  • DynEnumOperations.get_as_string()
  • _DynEnumStub.get_as_string()


get_as_ulong

get_as_ulong o7planning.org
  • DynEnumOperations.get_as_ulong()
  • _DynEnumStub.get_as_ulong()


get_boolean

get_boolean o7planning.org
  • DynAny.get_boolean()
  • DynAnyOperations.get_boolean()
  • _DynAnyStub.get_boolean()
  • _DynArrayStub.get_boolean()
  • _DynEnumStub.get_boolean()
  • _DynFixedStub.get_boolean()
  • _DynSequenceStub.get_boolean()
  • _DynStructStub.get_boolean()
  • _DynUnionStub.get_boolean()
  • _DynValueStub.get_boolean()


get_boxed_value

get_boxed_value o7planning.org
  • DynValueBoxOperations.get_boxed_value()


get_boxed_value_as_dyn_any

get_boxed_value_as_dyn_any o7planning.org
  • DynValueBoxOperations.get_boxed_value_as_dyn_any()


get_char

get_char o7planning.org
  • DynAny.get_char()
  • DynAnyOperations.get_char()
  • _DynAnyStub.get_char()
  • _DynArrayStub.get_char()
  • _DynEnumStub.get_char()
  • _DynFixedStub.get_char()
  • _DynSequenceStub.get_char()
  • _DynStructStub.get_char()
  • _DynUnionStub.get_char()
  • _DynValueStub.get_char()


get_codebase

get_codebase o7planning.org
  • Delegate.get_codebase(Object)


get_compact_typecode

get_compact_typecode o7planning.org
  • TypeCode.get_compact_typecode()


get_current

get_current o7planning.org
  • ORB.get_current()


get_default_context

get_default_context o7planning.org
  • ORB.get_default_context()


get_discriminator

get_discriminator o7planning.org
  • DynUnionOperations.get_discriminator()
  • _DynUnionStub.get_discriminator()


get_domain_managers

get_domain_managers o7planning.org
  • Delegate.get_domain_managers(Object)


get_domain_policy

get_domain_policy o7planning.org
  • DomainManagerOperations.get_domain_policy(int)


get_double

get_double o7planning.org
  • DynAny.get_double()
  • DynAnyOperations.get_double()
  • _DynAnyStub.get_double()
  • _DynArrayStub.get_double()
  • _DynEnumStub.get_double()
  • _DynFixedStub.get_double()
  • _DynSequenceStub.get_double()
  • _DynStructStub.get_double()
  • _DynUnionStub.get_double()
  • _DynValueStub.get_double()


get_dyn_any

get_dyn_any o7planning.org
  • DynAnyOperations.get_dyn_any()
  • _DynAnyStub.get_dyn_any()
  • _DynArrayStub.get_dyn_any()
  • _DynEnumStub.get_dyn_any()
  • _DynFixedStub.get_dyn_any()
  • _DynSequenceStub.get_dyn_any()
  • _DynStructStub.get_dyn_any()
  • _DynUnionStub.get_dyn_any()
  • _DynValueStub.get_dyn_any()


get_effective_component

get_effective_component o7planning.org
  • ClientRequestInfoOperations.get_effective_component(int)


get_effective_components

get_effective_components o7planning.org
  • ClientRequestInfoOperations.get_effective_components(int)


get_effective_policy

get_effective_policy o7planning.org
  • IORInfoOperations.get_effective_policy(int)


get_elements

get_elements o7planning.org
  • DynArray.get_elements()
  • DynArrayOperations.get_elements()
  • DynSequence.get_elements()
  • DynSequenceOperations.get_elements()
  • _DynArrayStub.get_elements()
  • _DynSequenceStub.get_elements()


get_elements_as_dyn_any

get_elements_as_dyn_any o7planning.org
  • DynArrayOperations.get_elements_as_dyn_any()
  • DynSequenceOperations.get_elements_as_dyn_any()
  • _DynArrayStub.get_elements_as_dyn_any()
  • _DynSequenceStub.get_elements_as_dyn_any()


get_float

get_float o7planning.org
  • DynAny.get_float()
  • DynAnyOperations.get_float()
  • _DynAnyStub.get_float()
  • _DynArrayStub.get_float()
  • _DynEnumStub.get_float()
  • _DynFixedStub.get_float()
  • _DynSequenceStub.get_float()
  • _DynStructStub.get_float()
  • _DynUnionStub.get_float()
  • _DynValueStub.get_float()


get_id

get_id o7planning.org
  • BoxedValueHelper.get_id()
  • StringValueHelper.get_id()
  • WStringValueHelper.get_id()


get_interface_def

get_interface_def o7planning.org
  • Delegate.get_interface_def(Servant)
  • Delegate.get_interface_def(Object)


get_length

get_length o7planning.org
  • DynSequenceOperations.get_length()
  • _DynSequenceStub.get_length()


get_long

get_long o7planning.org
  • DynAny.get_long()
  • DynAnyOperations.get_long()
  • _DynAnyStub.get_long()
  • _DynArrayStub.get_long()
  • _DynEnumStub.get_long()
  • _DynFixedStub.get_long()
  • _DynSequenceStub.get_long()
  • _DynStructStub.get_long()
  • _DynUnionStub.get_long()
  • _DynValueStub.get_long()


get_longlong

get_longlong o7planning.org
  • DynAny.get_longlong()
  • DynAnyOperations.get_longlong()
  • _DynAnyStub.get_longlong()
  • _DynArrayStub.get_longlong()
  • _DynEnumStub.get_longlong()
  • _DynFixedStub.get_longlong()
  • _DynSequenceStub.get_longlong()
  • _DynStructStub.get_longlong()
  • _DynUnionStub.get_longlong()
  • _DynValueStub.get_longlong()


get_members

get_members o7planning.org
  • DynStruct.get_members()
  • DynStructOperations.get_members()
  • DynValue.get_members()
  • DynValueOperations.get_members()
  • _DynStructStub.get_members()
  • _DynValueStub.get_members()


get_members_as_dyn_any

get_members_as_dyn_any o7planning.org
  • DynStructOperations.get_members_as_dyn_any()
  • DynValueOperations.get_members_as_dyn_any()
  • _DynStructStub.get_members_as_dyn_any()
  • _DynValueStub.get_members_as_dyn_any()


get_next_response

get_next_response o7planning.org
  • ORB.get_next_response()


get_object_id

get_object_id o7planning.org
  • CurrentOperations.get_object_id()


get_octet

get_octet o7planning.org
  • DynAny.get_octet()
  • DynAnyOperations.get_octet()
  • _DynAnyStub.get_octet()
  • _DynArrayStub.get_octet()
  • _DynEnumStub.get_octet()
  • _DynFixedStub.get_octet()
  • _DynSequenceStub.get_octet()
  • _DynStructStub.get_octet()
  • _DynUnionStub.get_octet()
  • _DynValueStub.get_octet()


get_POA

get_POA o7planning.org
  • CurrentOperations.get_POA()


get_policy

get_policy o7planning.org
  • Delegate.get_policy(Object, int)


get_primitive_tc

get_primitive_tc o7planning.org
  • ORB.get_primitive_tc(TCKind)


get_reference

get_reference o7planning.org
  • DynAny.get_reference()
  • DynAnyOperations.get_reference()
  • _DynAnyStub.get_reference()
  • _DynArrayStub.get_reference()
  • _DynEnumStub.get_reference()
  • _DynFixedStub.get_reference()
  • _DynSequenceStub.get_reference()
  • _DynStructStub.get_reference()
  • _DynUnionStub.get_reference()
  • _DynValueStub.get_reference()


get_reply_service_context

get_reply_service_context o7planning.org
  • RequestInfoOperations.get_reply_service_context(int)


get_request_policy

get_request_policy o7planning.org
  • ClientRequestInfoOperations.get_request_policy(int)


get_request_service_context

get_request_service_context o7planning.org
  • RequestInfoOperations.get_request_service_context(int)


get_response

get_response o7planning.org
  • Request.get_response()


get_servant

get_servant o7planning.org
  • POAOperations.get_servant()


get_servant_manager

get_servant_manager o7planning.org
  • POAOperations.get_servant_manager()


get_server_policy

get_server_policy o7planning.org
  • ServerRequestInfoOperations.get_server_policy(int)


get_service_information

get_service_information o7planning.org
  • ORB.get_service_information(short, ServiceInformationHolder)


get_short

get_short o7planning.org
  • DynAny.get_short()
  • DynAnyOperations.get_short()
  • _DynAnyStub.get_short()
  • _DynArrayStub.get_short()
  • _DynEnumStub.get_short()
  • _DynFixedStub.get_short()
  • _DynSequenceStub.get_short()
  • _DynStructStub.get_short()
  • _DynUnionStub.get_short()
  • _DynValueStub.get_short()


get_slot

get_slot o7planning.org
  • CurrentOperations.get_slot(int)
  • RequestInfoOperations.get_slot(int)


get_state

get_state o7planning.org
  • POAManagerOperations.get_state()


get_string

get_string o7planning.org
  • DynAny.get_string()
  • DynAnyOperations.get_string()
  • _DynAnyStub.get_string()
  • _DynArrayStub.get_string()
  • _DynEnumStub.get_string()
  • _DynFixedStub.get_string()
  • _DynSequenceStub.get_string()
  • _DynStructStub.get_string()
  • _DynUnionStub.get_string()
  • _DynValueStub.get_string()


get_typecode

get_typecode o7planning.org
  • DynAny.get_typecode()
  • DynAnyOperations.get_typecode()
  • _DynAnyStub.get_typecode()
  • _DynArrayStub.get_typecode()
  • _DynEnumStub.get_typecode()
  • _DynFixedStub.get_typecode()
  • _DynSequenceStub.get_typecode()
  • _DynStructStub.get_typecode()
  • _DynUnionStub.get_typecode()
  • _DynValueStub.get_typecode()


get_ulong

get_ulong o7planning.org
  • DynAny.get_ulong()
  • DynAnyOperations.get_ulong()
  • _DynAnyStub.get_ulong()
  • _DynArrayStub.get_ulong()
  • _DynEnumStub.get_ulong()
  • _DynFixedStub.get_ulong()
  • _DynSequenceStub.get_ulong()
  • _DynStructStub.get_ulong()
  • _DynUnionStub.get_ulong()
  • _DynValueStub.get_ulong()


get_ulonglong

get_ulonglong o7planning.org
  • DynAny.get_ulonglong()
  • DynAnyOperations.get_ulonglong()
  • _DynAnyStub.get_ulonglong()
  • _DynArrayStub.get_ulonglong()
  • _DynEnumStub.get_ulonglong()
  • _DynFixedStub.get_ulonglong()
  • _DynSequenceStub.get_ulonglong()
  • _DynStructStub.get_ulonglong()
  • _DynUnionStub.get_ulonglong()
  • _DynValueStub.get_ulonglong()


get_ushort

get_ushort o7planning.org
  • DynAny.get_ushort()
  • DynAnyOperations.get_ushort()
  • _DynAnyStub.get_ushort()
  • _DynArrayStub.get_ushort()
  • _DynEnumStub.get_ushort()
  • _DynFixedStub.get_ushort()
  • _DynSequenceStub.get_ushort()
  • _DynStructStub.get_ushort()
  • _DynUnionStub.get_ushort()
  • _DynValueStub.get_ushort()


get_val

get_val o7planning.org
  • DynAny.get_val()
  • DynAnyOperations.get_val()
  • _DynAnyStub.get_val()
  • _DynArrayStub.get_val()
  • _DynEnumStub.get_val()
  • _DynFixedStub.get_val()
  • _DynSequenceStub.get_val()
  • _DynStructStub.get_val()
  • _DynUnionStub.get_val()
  • _DynValueStub.get_val()


get_value

get_value o7planning.org
  • DynFixed.get_value()
  • DynFixedOperations.get_value()
  • _DynFixedStub.get_value()


get_value_def

get_value_def o7planning.org
  • ORB.get_value_def(String)


get_values

get_values o7planning.org
  • Context.get_values(String, int, String)


get_wchar

get_wchar o7planning.org
  • DynAny.get_wchar()
  • DynAnyOperations.get_wchar()
  • _DynAnyStub.get_wchar()
  • _DynArrayStub.get_wchar()
  • _DynEnumStub.get_wchar()
  • _DynFixedStub.get_wchar()
  • _DynSequenceStub.get_wchar()
  • _DynStructStub.get_wchar()
  • _DynUnionStub.get_wchar()
  • _DynValueStub.get_wchar()


get_wstring

get_wstring o7planning.org
  • DynAny.get_wstring()
  • DynAnyOperations.get_wstring()
  • _DynAnyStub.get_wstring()
  • _DynArrayStub.get_wstring()
  • _DynEnumStub.get_wstring()
  • _DynFixedStub.get_wstring()
  • _DynSequenceStub.get_wstring()
  • _DynStructStub.get_wstring()
  • _DynUnionStub.get_wstring()
  • _DynValueStub.get_wstring()


getA

getA o7planning.org
  • EllipticCurve.getA()


getAbsoluteFile

getAbsoluteFile o7planning.org
  • File.getAbsoluteFile()


getAbsolutePath

getAbsolutePath o7planning.org
  • File.getAbsolutePath()


getAccelerationPriority

getAccelerationPriority o7planning.org
  • Image.getAccelerationPriority()


getAccelerator

getAccelerator o7planning.org
  • JMenuItem.getAccelerator()


getAcceleratorForeground

getAcceleratorForeground o7planning.org
  • MetalLookAndFeel.getAcceleratorForeground()
  • MetalTheme.getAcceleratorForeground()


getAcceleratorSelectedForeground

getAcceleratorSelectedForeground o7planning.org
  • MetalLookAndFeel.getAcceleratorSelectedForeground()
  • MetalTheme.getAcceleratorSelectedForeground()


getAcceleratorString

getAcceleratorString o7planning.org
  • MetalToolTipUI.getAcceleratorString()


getAcceptAllFileFilter

getAcceptAllFileFilter o7planning.org
  • BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser)
  • FileChooserUI.getAcceptAllFileFilter(JFileChooser)
  • JFileChooser.getAcceptAllFileFilter()
  • MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser)


getAcceptedIssuers

getAcceptedIssuers o7planning.org
  • X509TrustManager.getAcceptedIssuers()


getAcceptorAddress

getAcceptorAddress o7planning.org
  • ChannelBinding.getAcceptorAddress()


getAccessibleAction

getAccessibleAction o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleAction()
  • AccessibleContext.getAccessibleAction()
  • Button.AccessibleAWTButton.getAccessibleAction()
  • Checkbox.AccessibleAWTCheckbox.getAccessibleAction()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleAction()
  • Choice.AccessibleAWTChoice.getAccessibleAction()
  • JComboBox.AccessibleJComboBox.getAccessibleAction()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleAction()
  • JSpinner.AccessibleJSpinner.getAccessibleAction()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAction()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAction()
  • JTextComponent.AccessibleJTextComponent.getAccessibleAction()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAction()
  • MenuItem.AccessibleAWTMenuItem.getAccessibleAction()


getAccessibleActionAnchor

getAccessibleActionAnchor o7planning.org
  • AccessibleHyperlink.getAccessibleActionAnchor(int)
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionAnchor(int)


getAccessibleActionCount

getAccessibleActionCount o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleActionCount()
  • AccessibleAction.getAccessibleActionCount()
  • AccessibleHyperlink.getAccessibleActionCount()
  • Button.AccessibleAWTButton.getAccessibleActionCount()
  • Checkbox.AccessibleAWTCheckbox.getAccessibleActionCount()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleActionCount()
  • Choice.AccessibleAWTChoice.getAccessibleActionCount()
  • JComboBox.AccessibleJComboBox.getAccessibleActionCount()
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionCount()
  • JSpinner.AccessibleJSpinner.getAccessibleActionCount()
  • JTextComponent.AccessibleJTextComponent.getAccessibleActionCount()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleActionCount()
  • MenuItem.AccessibleAWTMenuItem.getAccessibleActionCount()


getAccessibleActionDescription

getAccessibleActionDescription o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleActionDescription(int)
  • AccessibleAction.getAccessibleActionDescription(int)
  • AccessibleHyperlink.getAccessibleActionDescription(int)
  • Button.AccessibleAWTButton.getAccessibleActionDescription(int)
  • Checkbox.AccessibleAWTCheckbox.getAccessibleActionDescription(int)
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleActionDescription(int)
  • Choice.AccessibleAWTChoice.getAccessibleActionDescription(int)
  • JComboBox.AccessibleJComboBox.getAccessibleActionDescription(int)
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionDescription(int)
  • JSpinner.AccessibleJSpinner.getAccessibleActionDescription(int)
  • JTextComponent.AccessibleJTextComponent.getAccessibleActionDescription(int)
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleActionDescription(int)
  • MenuItem.AccessibleAWTMenuItem.getAccessibleActionDescription(int)


getAccessibleActionObject

getAccessibleActionObject o7planning.org
  • AccessibleHyperlink.getAccessibleActionObject(int)
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionObject(int)


getAccessibleAt

getAccessibleAt o7planning.org
  • AccessibleComponent.getAccessibleAt(Point)
  • AccessibleTable.getAccessibleAt(int, int)
  • Component.AccessibleAWTComponent.getAccessibleAt(Point)
  • Container.AccessibleAWTContainer.getAccessibleAt(Point)
  • JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt(Point)
  • JList.AccessibleJList.getAccessibleAt(Point)
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleAt(Point)
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleAt(Point)
  • JTable.AccessibleJTable.getAccessibleAt(int, int)
  • JTable.AccessibleJTable.getAccessibleAt(Point)
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt(Point)
  • JTableHeader.AccessibleJTableHeader.getAccessibleAt(Point)
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt(Point)
  • JTree.AccessibleJTree.getAccessibleAt(Point)
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt(Point)
  • List.AccessibleAWTList.getAccessibleAt(Point)
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt(Point)
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt(Point)
  • SwingUtilities.getAccessibleAt(Component, Point)


getAccessibleCaption

getAccessibleCaption o7planning.org
  • AccessibleTable.getAccessibleCaption()
  • JTable.AccessibleJTable.getAccessibleCaption()


getAccessibleChild

getAccessibleChild o7planning.org
  • AccessibleContext.getAccessibleChild(int)
  • BasicComboBoxUI.getAccessibleChild(JComponent, int)
  • Component.AccessibleAWTComponent.getAccessibleChild(int)
  • ComponentUI.getAccessibleChild(JComponent, int)
  • Container.AccessibleAWTContainer.getAccessibleChild(int)
  • ImageIcon.AccessibleImageIcon.getAccessibleChild(int)
  • JComboBox.AccessibleJComboBox.getAccessibleChild(int)
  • JComponent.AccessibleJComponent.getAccessibleChild(int)
  • JEditorPane.AccessibleJEditorPaneHTML.getAccessibleChild(int)
  • JList.AccessibleJList.getAccessibleChild(int)
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleChild(int)
  • JMenu.AccessibleJMenu.getAccessibleChild(int)
  • JRootPane.AccessibleJRootPane.getAccessibleChild(int)
  • JSpinner.AccessibleJSpinner.getAccessibleChild(int)
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleChild(int)
  • JTable.AccessibleJTable.getAccessibleChild(int)
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleChild(int)
  • JTableHeader.AccessibleJTableHeader.getAccessibleChild(int)
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleChild(int)
  • JTree.AccessibleJTree.getAccessibleChild(int)
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleChild(int)
  • List.AccessibleAWTList.getAccessibleChild(int)
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleChild(int)
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleChild(int)
  • MultiButtonUI.getAccessibleChild(JComponent, int)
  • MultiColorChooserUI.getAccessibleChild(JComponent, int)
  • MultiComboBoxUI.getAccessibleChild(JComponent, int)
  • MultiDesktopIconUI.getAccessibleChild(JComponent, int)
  • MultiDesktopPaneUI.getAccessibleChild(JComponent, int)
  • MultiFileChooserUI.getAccessibleChild(JComponent, int)
  • MultiInternalFrameUI.getAccessibleChild(JComponent, int)
  • MultiLabelUI.getAccessibleChild(JComponent, int)
  • MultiListUI.getAccessibleChild(JComponent, int)
  • MultiMenuBarUI.getAccessibleChild(JComponent, int)
  • MultiMenuItemUI.getAccessibleChild(JComponent, int)
  • MultiOptionPaneUI.getAccessibleChild(JComponent, int)
  • MultiPanelUI.getAccessibleChild(JComponent, int)
  • MultiPopupMenuUI.getAccessibleChild(JComponent, int)
  • MultiProgressBarUI.getAccessibleChild(JComponent, int)
  • MultiRootPaneUI.getAccessibleChild(JComponent, int)
  • MultiScrollBarUI.getAccessibleChild(JComponent, int)
  • MultiScrollPaneUI.getAccessibleChild(JComponent, int)
  • MultiSeparatorUI.getAccessibleChild(JComponent, int)
  • MultiSliderUI.getAccessibleChild(JComponent, int)
  • MultiSpinnerUI.getAccessibleChild(JComponent, int)
  • MultiSplitPaneUI.getAccessibleChild(JComponent, int)
  • MultiTabbedPaneUI.getAccessibleChild(JComponent, int)
  • MultiTableHeaderUI.getAccessibleChild(JComponent, int)
  • MultiTableUI.getAccessibleChild(JComponent, int)
  • MultiTextUI.getAccessibleChild(JComponent, int)
  • MultiToolBarUI.getAccessibleChild(JComponent, int)
  • MultiToolTipUI.getAccessibleChild(JComponent, int)
  • MultiTreeUI.getAccessibleChild(JComponent, int)
  • MultiViewportUI.getAccessibleChild(JComponent, int)
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleChild(int)
  • SwingUtilities.getAccessibleChild(Component, int)


getAccessibleChildrenCount

getAccessibleChildrenCount o7planning.org
  • AccessibleContext.getAccessibleChildrenCount()
  • BasicComboBoxUI.getAccessibleChildrenCount(JComponent)
  • Component.AccessibleAWTComponent.getAccessibleChildrenCount()
  • ComponentUI.getAccessibleChildrenCount(JComponent)
  • Container.AccessibleAWTContainer.getAccessibleChildrenCount()
  • ImageIcon.AccessibleImageIcon.getAccessibleChildrenCount()
  • JComboBox.AccessibleJComboBox.getAccessibleChildrenCount()
  • JComponent.AccessibleJComponent.getAccessibleChildrenCount()
  • JEditorPane.AccessibleJEditorPaneHTML.getAccessibleChildrenCount()
  • JList.AccessibleJList.getAccessibleChildrenCount()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleChildrenCount()
  • JMenu.AccessibleJMenu.getAccessibleChildrenCount()
  • JRootPane.AccessibleJRootPane.getAccessibleChildrenCount()
  • JSpinner.AccessibleJSpinner.getAccessibleChildrenCount()
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleChildrenCount()
  • JTable.AccessibleJTable.getAccessibleChildrenCount()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleChildrenCount()
  • JTableHeader.AccessibleJTableHeader.getAccessibleChildrenCount()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleChildrenCount()
  • JTree.AccessibleJTree.getAccessibleChildrenCount()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleChildrenCount()
  • List.AccessibleAWTList.getAccessibleChildrenCount()
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleChildrenCount()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleChildrenCount()
  • MultiButtonUI.getAccessibleChildrenCount(JComponent)
  • MultiColorChooserUI.getAccessibleChildrenCount(JComponent)
  • MultiComboBoxUI.getAccessibleChildrenCount(JComponent)
  • MultiDesktopIconUI.getAccessibleChildrenCount(JComponent)
  • MultiDesktopPaneUI.getAccessibleChildrenCount(JComponent)
  • MultiFileChooserUI.getAccessibleChildrenCount(JComponent)
  • MultiInternalFrameUI.getAccessibleChildrenCount(JComponent)
  • MultiLabelUI.getAccessibleChildrenCount(JComponent)
  • MultiListUI.getAccessibleChildrenCount(JComponent)
  • MultiMenuBarUI.getAccessibleChildrenCount(JComponent)
  • MultiMenuItemUI.getAccessibleChildrenCount(JComponent)
  • MultiOptionPaneUI.getAccessibleChildrenCount(JComponent)
  • MultiPanelUI.getAccessibleChildrenCount(JComponent)
  • MultiPopupMenuUI.getAccessibleChildrenCount(JComponent)
  • MultiProgressBarUI.getAccessibleChildrenCount(JComponent)
  • MultiRootPaneUI.getAccessibleChildrenCount(JComponent)
  • MultiScrollBarUI.getAccessibleChildrenCount(JComponent)
  • MultiScrollPaneUI.getAccessibleChildrenCount(JComponent)
  • MultiSeparatorUI.getAccessibleChildrenCount(JComponent)
  • MultiSliderUI.getAccessibleChildrenCount(JComponent)
  • MultiSpinnerUI.getAccessibleChildrenCount(JComponent)
  • MultiSplitPaneUI.getAccessibleChildrenCount(JComponent)
  • MultiTabbedPaneUI.getAccessibleChildrenCount(JComponent)
  • MultiTableHeaderUI.getAccessibleChildrenCount(JComponent)
  • MultiTableUI.getAccessibleChildrenCount(JComponent)
  • MultiTextUI.getAccessibleChildrenCount(JComponent)
  • MultiToolBarUI.getAccessibleChildrenCount(JComponent)
  • MultiToolTipUI.getAccessibleChildrenCount(JComponent)
  • MultiTreeUI.getAccessibleChildrenCount(JComponent)
  • MultiViewportUI.getAccessibleChildrenCount(JComponent)
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleChildrenCount()
  • SwingUtilities.getAccessibleChildrenCount(Component)


getAccessibleColumn

getAccessibleColumn o7planning.org
  • AccessibleExtendedTable.getAccessibleColumn(int)
  • JTable.AccessibleJTable.getAccessibleColumn(int)


getAccessibleColumnAtIndex

getAccessibleColumnAtIndex o7planning.org
  • JTable.AccessibleJTable.getAccessibleColumnAtIndex(int)


getAccessibleColumnCount

getAccessibleColumnCount o7planning.org
  • AccessibleTable.getAccessibleColumnCount()
  • JTable.AccessibleJTable.getAccessibleColumnCount()


getAccessibleColumnDescription

getAccessibleColumnDescription o7planning.org
  • AccessibleTable.getAccessibleColumnDescription(int)
  • JTable.AccessibleJTable.getAccessibleColumnDescription(int)


getAccessibleColumnExtentAt

getAccessibleColumnExtentAt o7planning.org
  • AccessibleTable.getAccessibleColumnExtentAt(int, int)
  • JTable.AccessibleJTable.getAccessibleColumnExtentAt(int, int)


getAccessibleColumnHeader

getAccessibleColumnHeader o7planning.org
  • AccessibleTable.getAccessibleColumnHeader()
  • JTable.AccessibleJTable.getAccessibleColumnHeader()


getAccessibleComponent

getAccessibleComponent o7planning.org
  • AccessibleContext.getAccessibleComponent()
  • Component.AccessibleAWTComponent.getAccessibleComponent()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleComponent()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleComponent()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleComponent()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleComponent()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleComponent()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleComponent()


getAccessibleContext

getAccessibleContext o7planning.org
  • Accessible.getAccessibleContext()
  • Applet.getAccessibleContext()
  • BasicComboPopup.getAccessibleContext()
  • Box.getAccessibleContext()
  • Box.Filler.getAccessibleContext()
  • Button.getAccessibleContext()
  • Canvas.getAccessibleContext()
  • CellRendererPane.getAccessibleContext()
  • Checkbox.getAccessibleContext()
  • CheckboxMenuItem.getAccessibleContext()
  • Choice.getAccessibleContext()
  • Component.getAccessibleContext()
  • Dialog.getAccessibleContext()
  • Frame.getAccessibleContext()
  • HTMLEditorKit.getAccessibleContext()
  • ImageIcon.getAccessibleContext()
  • JApplet.getAccessibleContext()
  • JButton.getAccessibleContext()
  • JCheckBox.getAccessibleContext()
  • JCheckBoxMenuItem.getAccessibleContext()
  • JColorChooser.getAccessibleContext()
  • JComboBox.getAccessibleContext()
  • JDesktopPane.getAccessibleContext()
  • JDialog.getAccessibleContext()
  • JEditorPane.getAccessibleContext()
  • JFileChooser.getAccessibleContext()
  • JFrame.getAccessibleContext()
  • JInternalFrame.getAccessibleContext()
  • JInternalFrame.JDesktopIcon.getAccessibleContext()
  • JLabel.getAccessibleContext()
  • JLayer.getAccessibleContext()
  • JLayeredPane.getAccessibleContext()
  • JList.getAccessibleContext()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleContext()
  • JMenu.getAccessibleContext()
  • JMenuBar.getAccessibleContext()
  • JMenuItem.getAccessibleContext()
  • JOptionPane.getAccessibleContext()
  • JPanel.getAccessibleContext()
  • JPasswordField.getAccessibleContext()
  • JPopupMenu.getAccessibleContext()
  • JProgressBar.getAccessibleContext()
  • JRadioButton.getAccessibleContext()
  • JRadioButtonMenuItem.getAccessibleContext()
  • JRootPane.getAccessibleContext()
  • JScrollBar.getAccessibleContext()
  • JScrollPane.getAccessibleContext()
  • JSeparator.getAccessibleContext()
  • JSlider.getAccessibleContext()
  • JSpinner.getAccessibleContext()
  • JSplitPane.getAccessibleContext()
  • JTabbedPane.getAccessibleContext()
  • JTable.getAccessibleContext()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleContext()
  • JTableHeader.getAccessibleContext()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleContext()
  • JTextArea.getAccessibleContext()
  • JTextComponent.getAccessibleContext()
  • JTextField.getAccessibleContext()
  • JToggleButton.getAccessibleContext()
  • JToolBar.getAccessibleContext()
  • JToolTip.getAccessibleContext()
  • JTree.getAccessibleContext()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleContext()
  • JViewport.getAccessibleContext()
  • JWindow.getAccessibleContext()
  • Label.getAccessibleContext()
  • List.getAccessibleContext()
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleContext()
  • Menu.getAccessibleContext()
  • MenuBar.getAccessibleContext()
  • MenuComponent.getAccessibleContext()
  • MenuItem.getAccessibleContext()
  • Panel.getAccessibleContext()
  • PopupMenu.getAccessibleContext()
  • ProgressMonitor.getAccessibleContext()
  • ScrollPane.getAccessibleContext()
  • Scrollbar.getAccessibleContext()
  • TextArea.getAccessibleContext()
  • TextComponent.getAccessibleContext()
  • TextField.getAccessibleContext()
  • Window.getAccessibleContext()


getAccessibleDescription

getAccessibleDescription o7planning.org
  • AccessibleContext.getAccessibleDescription()
  • Component.AccessibleAWTComponent.getAccessibleDescription()
  • JComponent.AccessibleJComponent.getAccessibleDescription()
  • JEditorPane.AccessibleJEditorPane.getAccessibleDescription()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleDescription()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleDescription()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleDescription()
  • JToolTip.AccessibleJToolTip.getAccessibleDescription()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleDescription()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleDescription()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleDescription()


getAccessibleEditableText

getAccessibleEditableText o7planning.org
  • AccessibleContext.getAccessibleEditableText()
  • JTextComponent.AccessibleJTextComponent.getAccessibleEditableText()


getAccessibleIcon

getAccessibleIcon o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleIcon()
  • AccessibleContext.getAccessibleIcon()
  • JLabel.AccessibleJLabel.getAccessibleIcon()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleIcon()


getAccessibleIconDescription

getAccessibleIconDescription o7planning.org
  • AccessibleIcon.getAccessibleIconDescription()
  • ImageIcon.AccessibleImageIcon.getAccessibleIconDescription()


getAccessibleIconHeight

getAccessibleIconHeight o7planning.org
  • AccessibleIcon.getAccessibleIconHeight()
  • ImageIcon.AccessibleImageIcon.getAccessibleIconHeight()


getAccessibleIconWidth

getAccessibleIconWidth o7planning.org
  • AccessibleIcon.getAccessibleIconWidth()
  • ImageIcon.AccessibleImageIcon.getAccessibleIconWidth()


getAccessibleIndex

getAccessibleIndex o7planning.org
  • AccessibleExtendedTable.getAccessibleIndex(int, int)
  • JTable.AccessibleJTable.getAccessibleIndex(int, int)


getAccessibleIndexAt

getAccessibleIndexAt o7planning.org
  • JTable.AccessibleJTable.getAccessibleIndexAt(int, int)


getAccessibleIndexInParent

getAccessibleIndexInParent o7planning.org
  • AccessibleContext.getAccessibleIndexInParent()
  • Component.AccessibleAWTComponent.getAccessibleIndexInParent()
  • ImageIcon.AccessibleImageIcon.getAccessibleIndexInParent()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleIndexInParent()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleIndexInParent()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleIndexInParent()
  • JTree.AccessibleJTree.getAccessibleIndexInParent()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleIndexInParent()
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleIndexInParent()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleIndexInParent()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleIndexInParent()
  • SwingUtilities.getAccessibleIndexInParent(Component)


getAccessibleKeyBinding

getAccessibleKeyBinding o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleKeyBinding()
  • AccessibleExtendedComponent.getAccessibleKeyBinding()
  • AccessibleKeyBinding.getAccessibleKeyBinding(int)
  • JComponent.AccessibleJComponent.getAccessibleKeyBinding()
  • JLabel.AccessibleJLabel.getAccessibleKeyBinding()


getAccessibleKeyBindingCount

getAccessibleKeyBindingCount o7planning.org
  • AccessibleKeyBinding.getAccessibleKeyBindingCount()


getAccessibleName

getAccessibleName o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleName()
  • AccessibleContext.getAccessibleName()
  • Button.AccessibleAWTButton.getAccessibleName()
  • Component.AccessibleAWTComponent.getAccessibleName()
  • JComponent.AccessibleJComponent.getAccessibleName()
  • JDialog.AccessibleJDialog.getAccessibleName()
  • JFrame.AccessibleJFrame.getAccessibleName()
  • JInternalFrame.AccessibleJInternalFrame.getAccessibleName()
  • JLabel.AccessibleJLabel.getAccessibleName()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleName()
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleName()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleName()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleName()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleName()
  • Label.AccessibleAWTLabel.getAccessibleName()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleName()
  • MenuItem.AccessibleAWTMenuItem.getAccessibleName()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleName()


getAccessibleParent

getAccessibleParent o7planning.org
  • AccessibleContext.getAccessibleParent()
  • Component.AccessibleAWTComponent.getAccessibleParent()
  • ImageIcon.AccessibleImageIcon.getAccessibleParent()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleParent()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleParent()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleParent()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleParent()


getAccessibleRelationSet

getAccessibleRelationSet o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleRelationSet()
  • AccessibleContext.getAccessibleRelationSet()
  • JLabel.AccessibleJLabel.getAccessibleRelationSet()


getAccessibleRole

getAccessibleRole o7planning.org
  • AccessibleContext.getAccessibleRole()
  • Applet.AccessibleApplet.getAccessibleRole()
  • Box.AccessibleBox.getAccessibleRole()
  • Box.Filler.AccessibleBoxFiller.getAccessibleRole()
  • Button.AccessibleAWTButton.getAccessibleRole()
  • Canvas.AccessibleAWTCanvas.getAccessibleRole()
  • CellRendererPane.AccessibleCellRendererPane.getAccessibleRole()
  • Checkbox.AccessibleAWTCheckbox.getAccessibleRole()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleRole()
  • Choice.AccessibleAWTChoice.getAccessibleRole()
  • Component.AccessibleAWTComponent.getAccessibleRole()
  • Dialog.AccessibleAWTDialog.getAccessibleRole()
  • Frame.AccessibleAWTFrame.getAccessibleRole()
  • ImageIcon.AccessibleImageIcon.getAccessibleRole()
  • JButton.AccessibleJButton.getAccessibleRole()
  • JCheckBox.AccessibleJCheckBox.getAccessibleRole()
  • JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem.getAccessibleRole()
  • JColorChooser.AccessibleJColorChooser.getAccessibleRole()
  • JComboBox.AccessibleJComboBox.getAccessibleRole()
  • JComponent.AccessibleJComponent.getAccessibleRole()
  • JDesktopPane.AccessibleJDesktopPane.getAccessibleRole()
  • JFileChooser.AccessibleJFileChooser.getAccessibleRole()
  • JInternalFrame.AccessibleJInternalFrame.getAccessibleRole()
  • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleRole()
  • JLabel.AccessibleJLabel.getAccessibleRole()
  • JLayeredPane.AccessibleJLayeredPane.getAccessibleRole()
  • JList.AccessibleJList.getAccessibleRole()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleRole()
  • JMenu.AccessibleJMenu.getAccessibleRole()
  • JMenuBar.AccessibleJMenuBar.getAccessibleRole()
  • JMenuItem.AccessibleJMenuItem.getAccessibleRole()
  • JOptionPane.AccessibleJOptionPane.getAccessibleRole()
  • JPanel.AccessibleJPanel.getAccessibleRole()
  • JPasswordField.AccessibleJPasswordField.getAccessibleRole()
  • JPopupMenu.AccessibleJPopupMenu.getAccessibleRole()
  • JProgressBar.AccessibleJProgressBar.getAccessibleRole()
  • JRadioButton.AccessibleJRadioButton.getAccessibleRole()
  • JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem.getAccessibleRole()
  • JRootPane.AccessibleJRootPane.getAccessibleRole()
  • JScrollBar.AccessibleJScrollBar.getAccessibleRole()
  • JScrollPane.AccessibleJScrollPane.getAccessibleRole()
  • JSeparator.AccessibleJSeparator.getAccessibleRole()
  • JSlider.AccessibleJSlider.getAccessibleRole()
  • JSpinner.AccessibleJSpinner.getAccessibleRole()
  • JSplitPane.AccessibleJSplitPane.getAccessibleRole()
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleRole()
  • JTable.AccessibleJTable.getAccessibleRole()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleRole()
  • JTableHeader.AccessibleJTableHeader.getAccessibleRole()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleRole()
  • JTextComponent.AccessibleJTextComponent.getAccessibleRole()
  • JToggleButton.AccessibleJToggleButton.getAccessibleRole()
  • JToolBar.AccessibleJToolBar.getAccessibleRole()
  • JToolTip.AccessibleJToolTip.getAccessibleRole()
  • JTree.AccessibleJTree.getAccessibleRole()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleRole()
  • JViewport.AccessibleJViewport.getAccessibleRole()
  • Label.AccessibleAWTLabel.getAccessibleRole()
  • List.AccessibleAWTList.getAccessibleRole()
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleRole()
  • Menu.AccessibleAWTMenu.getAccessibleRole()
  • MenuBar.AccessibleAWTMenuBar.getAccessibleRole()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleRole()
  • MenuItem.AccessibleAWTMenuItem.getAccessibleRole()
  • Panel.AccessibleAWTPanel.getAccessibleRole()
  • PopupMenu.AccessibleAWTPopupMenu.getAccessibleRole()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleRole()
  • ScrollPane.AccessibleAWTScrollPane.getAccessibleRole()
  • Scrollbar.AccessibleAWTScrollBar.getAccessibleRole()
  • TextComponent.AccessibleAWTTextComponent.getAccessibleRole()
  • Window.AccessibleAWTWindow.getAccessibleRole()


getAccessibleRow

getAccessibleRow o7planning.org
  • AccessibleExtendedTable.getAccessibleRow(int)
  • JTable.AccessibleJTable.getAccessibleRow(int)


getAccessibleRowAtIndex

getAccessibleRowAtIndex o7planning.org
  • JTable.AccessibleJTable.getAccessibleRowAtIndex(int)


getAccessibleRowCount

getAccessibleRowCount o7planning.org
  • AccessibleTable.getAccessibleRowCount()
  • JTable.AccessibleJTable.getAccessibleRowCount()


getAccessibleRowDescription

getAccessibleRowDescription o7planning.org
  • AccessibleTable.getAccessibleRowDescription(int)
  • JTable.AccessibleJTable.getAccessibleRowDescription(int)


getAccessibleRowExtentAt

getAccessibleRowExtentAt o7planning.org
  • AccessibleTable.getAccessibleRowExtentAt(int, int)
  • JTable.AccessibleJTable.getAccessibleRowExtentAt(int, int)


getAccessibleRowHeader

getAccessibleRowHeader o7planning.org
  • AccessibleTable.getAccessibleRowHeader()
  • JTable.AccessibleJTable.getAccessibleRowHeader()


getAccessibleSelection

getAccessibleSelection o7planning.org
  • AccessibleContext.getAccessibleSelection()
  • AccessibleSelection.getAccessibleSelection(int)
  • JComboBox.AccessibleJComboBox.getAccessibleSelection(int)
  • JComboBox.AccessibleJComboBox.getAccessibleSelection()
  • JList.AccessibleJList.getAccessibleSelection(int)
  • JList.AccessibleJList.getAccessibleSelection()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleSelection()
  • JMenu.AccessibleJMenu.getAccessibleSelection(int)
  • JMenu.AccessibleJMenu.getAccessibleSelection()
  • JMenuBar.AccessibleJMenuBar.getAccessibleSelection(int)
  • JMenuBar.AccessibleJMenuBar.getAccessibleSelection()
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection(int)
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection()
  • JTable.AccessibleJTable.getAccessibleSelection(int)
  • JTable.AccessibleJTable.getAccessibleSelection()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleSelection()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleSelection()
  • JTree.AccessibleJTree.getAccessibleSelection(int)
  • JTree.AccessibleJTree.getAccessibleSelection()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection(int)
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection()
  • List.AccessibleAWTList.getAccessibleSelection(int)
  • List.AccessibleAWTList.getAccessibleSelection()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection(int)
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection()


getAccessibleSelectionCount

getAccessibleSelectionCount o7planning.org
  • AccessibleSelection.getAccessibleSelectionCount()
  • JComboBox.AccessibleJComboBox.getAccessibleSelectionCount()
  • JList.AccessibleJList.getAccessibleSelectionCount()
  • JMenu.AccessibleJMenu.getAccessibleSelectionCount()
  • JMenuBar.AccessibleJMenuBar.getAccessibleSelectionCount()
  • JTabbedPane.AccessibleJTabbedPane.getAccessibleSelectionCount()
  • JTable.AccessibleJTable.getAccessibleSelectionCount()
  • JTree.AccessibleJTree.getAccessibleSelectionCount()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelectionCount()
  • List.AccessibleAWTList.getAccessibleSelectionCount()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelectionCount()


getAccessibleStateSet

getAccessibleStateSet o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleStateSet()
  • AccessibleContext.getAccessibleStateSet()
  • Applet.AccessibleApplet.getAccessibleStateSet()
  • Checkbox.AccessibleAWTCheckbox.getAccessibleStateSet()
  • Component.AccessibleAWTComponent.getAccessibleStateSet()
  • Dialog.AccessibleAWTDialog.getAccessibleStateSet()
  • Frame.AccessibleAWTFrame.getAccessibleStateSet()
  • ImageIcon.AccessibleImageIcon.getAccessibleStateSet()
  • JComboBox.AccessibleJComboBox.getAccessibleStateSet()
  • JComponent.AccessibleJComponent.getAccessibleStateSet()
  • JDialog.AccessibleJDialog.getAccessibleStateSet()
  • JEditorPane.AccessibleJEditorPane.getAccessibleStateSet()
  • JFrame.AccessibleJFrame.getAccessibleStateSet()
  • JList.AccessibleJList.getAccessibleStateSet()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleStateSet()
  • JMenuBar.AccessibleJMenuBar.getAccessibleStateSet()
  • JProgressBar.AccessibleJProgressBar.getAccessibleStateSet()
  • JScrollBar.AccessibleJScrollBar.getAccessibleStateSet()
  • JSlider.AccessibleJSlider.getAccessibleStateSet()
  • JSplitPane.AccessibleJSplitPane.getAccessibleStateSet()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleStateSet()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleStateSet()
  • JTextArea.AccessibleJTextArea.getAccessibleStateSet()
  • JTextComponent.AccessibleJTextComponent.getAccessibleStateSet()
  • JTextField.AccessibleJTextField.getAccessibleStateSet()
  • JToolBar.AccessibleJToolBar.getAccessibleStateSet()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleStateSet()
  • List.AccessibleAWTList.getAccessibleStateSet()
  • List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleStateSet()
  • MenuComponent.AccessibleAWTMenuComponent.getAccessibleStateSet()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleStateSet()
  • Scrollbar.AccessibleAWTScrollBar.getAccessibleStateSet()
  • SwingUtilities.getAccessibleStateSet(Component)
  • TextArea.AccessibleAWTTextArea.getAccessibleStateSet()
  • TextComponent.AccessibleAWTTextComponent.getAccessibleStateSet()
  • TextField.AccessibleAWTTextField.getAccessibleStateSet()
  • Window.AccessibleAWTWindow.getAccessibleStateSet()


getAccessibleSummary

getAccessibleSummary o7planning.org
  • AccessibleTable.getAccessibleSummary()
  • JTable.AccessibleJTable.getAccessibleSummary()


getAccessibleTable

getAccessibleTable o7planning.org
  • AccessibleContext.getAccessibleTable()
  • JTable.AccessibleJTable.getAccessibleTable()


getAccessibleText

getAccessibleText o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleText()
  • AccessibleContext.getAccessibleText()
  • JEditorPane.AccessibleJEditorPaneHTML.getAccessibleText()
  • JLabel.AccessibleJLabel.getAccessibleText()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleText()
  • JPasswordField.AccessibleJPasswordField.getAccessibleText()
  • JSpinner.AccessibleJSpinner.getAccessibleText()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleText()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleText()
  • JTextComponent.AccessibleJTextComponent.getAccessibleText()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleText()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleText()
  • TextComponent.AccessibleAWTTextComponent.getAccessibleText()


getAccessibleValue

getAccessibleValue o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAccessibleValue()
  • AccessibleContext.getAccessibleValue()
  • Button.AccessibleAWTButton.getAccessibleValue()
  • Checkbox.AccessibleAWTCheckbox.getAccessibleValue()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleValue()
  • JInternalFrame.AccessibleJInternalFrame.getAccessibleValue()
  • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleValue()
  • JList.AccessibleJList.AccessibleJListChild.getAccessibleValue()
  • JProgressBar.AccessibleJProgressBar.getAccessibleValue()
  • JScrollBar.AccessibleJScrollBar.getAccessibleValue()
  • JSlider.AccessibleJSlider.getAccessibleValue()
  • JSpinner.AccessibleJSpinner.getAccessibleValue()
  • JSplitPane.AccessibleJSplitPane.getAccessibleValue()
  • JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleValue()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleValue()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleValue()
  • MenuItem.AccessibleAWTMenuItem.getAccessibleValue()
  • ProgressMonitor.AccessibleProgressMonitor.getAccessibleValue()
  • Scrollbar.AccessibleAWTScrollBar.getAccessibleValue()


getAccessLevel

getAccessLevel o7planning.org
  • ForwardingJavaFileObject.getAccessLevel()
  • JavaFileObject.getAccessLevel()
  • SimpleJavaFileObject.getAccessLevel()


getAccessory

getAccessory o7planning.org
  • JFileChooser.getAccessory()


getAccessoryPanel

getAccessoryPanel o7planning.org
  • BasicFileChooserUI.getAccessoryPanel()


getACHuffmanTables

getACHuffmanTables o7planning.org
  • JPEGImageReadParam.getACHuffmanTables()
  • JPEGImageWriteParam.getACHuffmanTables()


getAcl

getAcl o7planning.org
  • AclFileAttributeView.getAcl()


getAction

getAction o7planning.org
  • AbstractButton.getAction()
  • EventHandler.getAction()
  • JComboBox.getAction()
  • JTextField.getAction()
  • Keymap.getAction(KeyStroke)


getActionCommand

getActionCommand o7planning.org
  • AbstractButton.getActionCommand()
  • ActionEvent.getActionCommand()
  • Button.getActionCommand()
  • ButtonModel.getActionCommand()
  • DefaultButtonModel.getActionCommand()
  • JComboBox.getActionCommand()
  • MenuItem.getActionCommand()
  • Timer.getActionCommand()
  • TrayIcon.getActionCommand()


getActionForKeyStroke

getActionForKeyStroke o7planning.org
  • JComponent.getActionForKeyStroke(KeyStroke)


getActionListeners

getActionListeners o7planning.org
  • AbstractButton.getActionListeners()
  • Button.getActionListeners()
  • DefaultButtonModel.getActionListeners()
  • JComboBox.getActionListeners()
  • JFileChooser.getActionListeners()
  • JTextField.getActionListeners()
  • List.getActionListeners()
  • MenuItem.getActionListeners()
  • TextField.getActionListeners()
  • Timer.getActionListeners()
  • TrayIcon.getActionListeners()


getActionMap

getActionMap o7planning.org
  • JComponent.getActionMap()
  • MetalFileChooserUI.getActionMap()


getActions

getActions o7planning.org
  • AllPermission.getActions()
  • BasicPermission.getActions()
  • DefaultEditorKit.getActions()
  • EditorKit.getActions()
  • FilePermission.getActions()
  • HTMLEditorKit.getActions()
  • InternationalFormatter.getActions()
  • JFormattedTextField.getActions()
  • JFormattedTextField.AbstractFormatter.getActions()
  • JTextComponent.getActions()
  • JTextField.getActions()
  • MBeanPermission.getActions()
  • Permission.getActions()
  • PrivateCredentialPermission.getActions()
  • PropertyPermission.getActions()
  • ServicePermission.getActions()
  • SocketPermission.getActions()
  • StyledEditorKit.getActions()
  • URLPermission.getActions()
  • UnresolvedPermission.getActions()


getActivationDesc

getActivationDesc o7planning.org
  • ActivationSystem.getActivationDesc(ActivationID)


getActivationGroupDesc

getActivationGroupDesc o7planning.org
  • ActivationSystem.getActivationGroupDesc(ActivationGroupID)


getActiveCount

getActiveCount o7planning.org
  • ThreadPoolExecutor.getActiveCount()


getActiveThreadCount

getActiveThreadCount o7planning.org
  • ForkJoinPool.getActiveThreadCount()


getActiveWindow

getActiveWindow o7planning.org
  • KeyboardFocusManager.getActiveWindow()


getActor

getActor o7planning.org
  • SOAPHeaderElement.getActor()


getActualMaximum

getActualMaximum o7planning.org
  • Calendar.getActualMaximum(int)
  • GregorianCalendar.getActualMaximum(int)


getActualMinimum

getActualMinimum o7planning.org
  • Calendar.getActualMinimum(int)
  • GregorianCalendar.getActualMinimum(int)


getActualTypeArguments

getActualTypeArguments o7planning.org
  • ParameterizedType.getActualTypeArguments()


getAdapter

getAdapter o7planning.org
  • AbstractMarshallerImpl.getAdapter(Class<A>)
  • AbstractUnmarshallerImpl.getAdapter(Class<A>)
  • Marshaller.getAdapter(Class<A>)
  • Unmarshaller.getAdapter(Class<A>)


getAdditionalBeanInfo

getAdditionalBeanInfo o7planning.org
  • BeanInfo.getAdditionalBeanInfo()
  • SimpleBeanInfo.getAdditionalBeanInfo()


getAdditionalHeight

getAdditionalHeight o7planning.org
  • MetalIconFactory.FileIcon16.getAdditionalHeight()
  • MetalIconFactory.FolderIcon16.getAdditionalHeight()
  • MetalIconFactory.TreeFolderIcon.getAdditionalHeight()
  • MetalIconFactory.TreeLeafIcon.getAdditionalHeight()


getAddListenerMethod

getAddListenerMethod o7planning.org
  • EventSetDescriptor.getAddListenerMethod()


getAddress

getAddress o7planning.org
  • DatagramPacket.getAddress()
  • Inet4Address.getAddress()
  • Inet6Address.getAddress()
  • InetAddress.getAddress()
  • InetSocketAddress.getAddress()
  • InterfaceAddress.getAddress()
  • JMXAddressable.getAddress()
  • JMXConnectorServerMBean.getAddress()
  • RMIConnector.getAddress()
  • RMIConnectorServer.getAddress()


getAdjustable

getAdjustable o7planning.org
  • AdjustmentEvent.getAdjustable()


getAdjustmentListeners

getAdjustmentListeners o7planning.org
  • JScrollBar.getAdjustmentListeners()
  • ScrollPaneAdjustable.getAdjustmentListeners()
  • Scrollbar.getAdjustmentListeners()


getAdjustmentType

getAdjustmentType o7planning.org
  • AdjustmentEvent.getAdjustmentType()


getAdler

getAdler o7planning.org
  • Deflater.getAdler()
  • Inflater.getAdler()


getAdvance

getAdvance o7planning.org
  • GlyphMetrics.getAdvance()
  • GraphicAttribute.getAdvance()
  • ImageGraphicAttribute.getAdvance()
  • ShapeGraphicAttribute.getAdvance()
  • TextLayout.getAdvance()


getAdvanceBetween

getAdvanceBetween o7planning.org
  • TextMeasurer.getAdvanceBetween(int, int)


getAdvanceX

getAdvanceX o7planning.org
  • GlyphMetrics.getAdvanceX()


getAdvanceY

getAdvanceY o7planning.org
  • GlyphMetrics.getAdvanceY()


getAffineX

getAffineX o7planning.org
  • ECPoint.getAffineX()


getAffineY

getAffineY o7planning.org
  • ECPoint.getAffineY()


getAfterIndex

getAfterIndex o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAfterIndex(int, int)
  • AccessibleText.getAfterIndex(int, int)
  • JLabel.AccessibleJLabel.getAfterIndex(int, int)
  • JPasswordField.AccessibleJPasswordField.getAfterIndex(int, int)
  • JSpinner.AccessibleJSpinner.getAfterIndex(int, int)
  • JTextComponent.AccessibleJTextComponent.getAfterIndex(int, int)
  • ProgressMonitor.AccessibleProgressMonitor.getAfterIndex(int, int)
  • TextComponent.AccessibleAWTTextComponent.getAfterIndex(int, int)


getAlgName

getAlgName o7planning.org
  • EncryptedPrivateKeyInfo.getAlgName()


getAlgorithm

getAlgorithm o7planning.org
  • AlgorithmMethod.getAlgorithm()
  • AlgorithmParameterGenerator.getAlgorithm()
  • AlgorithmParameters.getAlgorithm()
  • CertPathBuilder.getAlgorithm()
  • CertPathValidator.getAlgorithm()
  • Cipher.getAlgorithm()
  • KerberosKey.getAlgorithm()
  • Key.getAlgorithm()
  • KeyAgreement.getAlgorithm()
  • KeyFactory.getAlgorithm()
  • KeyGenerator.getAlgorithm()
  • KeyManagerFactory.getAlgorithm()
  • KeyPairGenerator.getAlgorithm()
  • Mac.getAlgorithm()
  • MessageDigest.getAlgorithm()
  • PSource.getAlgorithm()
  • Provider.Service.getAlgorithm()
  • SealedObject.getAlgorithm()
  • SecretKeyFactory.getAlgorithm()
  • SecretKeySpec.getAlgorithm()
  • SecureRandom.getAlgorithm()
  • Signature.getAlgorithm()
  • SignedObject.getAlgorithm()
  • TransformService.getAlgorithm()
  • TrustManagerFactory.getAlgorithm()


getAlgorithmConstraints

getAlgorithmConstraints o7planning.org
  • SSLParameters.getAlgorithmConstraints()


getAlgorithmProperty

getAlgorithmProperty o7planning.org
  • Security.getAlgorithmProperty(String, String)


getAlgorithms

getAlgorithms o7planning.org
  • Security.getAlgorithms(String)


getAlgParameters

getAlgParameters o7planning.org
  • EncryptedPrivateKeyInfo.getAlgParameters()


getAlias

getAlias o7planning.org
  • X500PrivateCredential.getAlias()


getAlignedSizeRequirements

getAlignedSizeRequirements o7planning.org
  • SizeRequirements.getAlignedSizeRequirements(SizeRequirements[])


getAlignment

getAlignment o7planning.org
  • BlockView.getAlignment(int)
  • BoxView.getAlignment(int)
  • ComponentView.getAlignment(int)
  • FlowLayout.getAlignment()
  • GlyphView.getAlignment(int)
  • GraphicAttribute.getAlignment()
  • IconView.getAlignment(int)
  • ImageView.getAlignment(int)
  • Label.getAlignment()
  • ListView.getAlignment(int)
  • ParagraphView.getAlignment(int)
  • StyleConstants.getAlignment(AttributeSet)
  • TabStop.getAlignment()
  • View.getAlignment(int)


getAlignmentX

getAlignmentX o7planning.org
  • Component.getAlignmentX()
  • Container.getAlignmentX()
  • JComponent.getAlignmentX()


getAlignmentY

getAlignmentY o7planning.org
  • Component.getAlignmentY()
  • Container.getAlignmentY()
  • JComponent.getAlignmentY()


getAlignOnBaseline

getAlignOnBaseline o7planning.org
  • FlowLayout.getAlignOnBaseline()


getAll

getAll o7planning.org
  • Attribute.getAll()
  • Attributes.getAll()
  • BasicAttribute.getAll()
  • BasicAttributes.getAll()
  • CompositeData.getAll(String[])
  • CompositeDataSupport.getAll(String[])
  • CompositeName.getAll()
  • CompoundName.getAll()
  • LdapName.getAll()
  • Name.getAll()
  • Reference.getAll()


getAllAnnotationMirrors

getAllAnnotationMirrors o7planning.org
  • Elements.getAllAnnotationMirrors(Element)


getAllAttributeKeys

getAllAttributeKeys o7planning.org
  • AttributedCharacterIterator.getAllAttributeKeys()
  • CSS.getAllAttributeKeys()
  • HTML.getAllAttributeKeys()


getAllAttributes

getAllAttributes o7planning.org
  • SOAPElement.getAllAttributes()


getAllAttributesAsQNames

getAllAttributesAsQNames o7planning.org
  • SOAPElement.getAllAttributesAsQNames()


getAllByName

getAllByName o7planning.org
  • InetAddress.getAllByName(String)


getAllCommands

getAllCommands o7planning.org
  • CommandMap.getAllCommands(String, DataSource)
  • CommandMap.getAllCommands(String)
  • DataHandler.getAllCommands()
  • MailcapCommandMap.getAllCommands(String)


getAllFonts

getAllFonts o7planning.org
  • GraphicsEnvironment.getAllFonts()


getAllFrames

getAllFrames o7planning.org
  • JDesktopPane.getAllFrames()


getAllFramesInLayer

getAllFramesInLayer o7planning.org
  • JDesktopPane.getAllFramesInLayer(int)


getAllHeaders

getAllHeaders o7planning.org
  • MimeHeaders.getAllHeaders()


getAllLoadedClasses

getAllLoadedClasses o7planning.org
  • Instrumentation.getAllLoadedClasses()


getAllMembers

getAllMembers o7planning.org
  • Elements.getAllMembers(TypeElement)


getAllMimeHeaders

getAllMimeHeaders o7planning.org
  • AttachmentPart.getAllMimeHeaders()
  • SOAPPart.getAllMimeHeaders()


getAllNotificationIDs

getAllNotificationIDs o7planning.org
  • Timer.getAllNotificationIDs()
  • TimerMBean.getAllNotificationIDs()


getAllowsChildren

getAllowsChildren o7planning.org
  • AbstractDocument.AbstractElement.getAllowsChildren()
  • AbstractDocument.BranchElement.getAllowsChildren()
  • AbstractDocument.LeafElement.getAllowsChildren()
  • DefaultMutableTreeNode.getAllowsChildren()
  • TreeNode.getAllowsChildren()


getAllowsInvalid

getAllowsInvalid o7planning.org
  • DefaultFormatter.getAllowsInvalid()


getAllowUserInteraction

getAllowUserInteraction o7planning.org
  • URLConnection.getAllowUserInteraction()


getAllRelationIds

getAllRelationIds o7planning.org
  • RelationService.getAllRelationIds()
  • RelationServiceMBean.getAllRelationIds()


getAllRelationTypeNames

getAllRelationTypeNames o7planning.org
  • RelationService.getAllRelationTypeNames()
  • RelationServiceMBean.getAllRelationTypeNames()


getAllRoles

getAllRoles o7planning.org
  • Relation.getAllRoles()
  • RelationService.getAllRoles(String)
  • RelationServiceMBean.getAllRoles(String)
  • RelationSupport.getAllRoles()


getAllStackTraces

getAllStackTraces o7planning.org
  • Thread.getAllStackTraces()


getAllTags

getAllTags o7planning.org
  • HTML.getAllTags()


getAllThreadIds

getAllThreadIds o7planning.org
  • ThreadMXBean.getAllThreadIds()


getAlpha

getAlpha o7planning.org
  • AlphaComposite.getAlpha()
  • Color.getAlpha()
  • ColorModel.getAlpha(Object)
  • ColorModel.getAlpha(int)
  • ComponentColorModel.getAlpha(Object)
  • ComponentColorModel.getAlpha(int)
  • DirectColorModel.getAlpha(Object)
  • DirectColorModel.getAlpha(int)
  • IndexColorModel.getAlpha(int)


getAlphaMask

getAlphaMask o7planning.org
  • DirectColorModel.getAlphaMask()


getAlphaRaster

getAlphaRaster o7planning.org
  • BufferedImage.getAlphaRaster()
  • ColorModel.getAlphaRaster(WritableRaster)
  • ComponentColorModel.getAlphaRaster(WritableRaster)
  • PackedColorModel.getAlphaRaster(WritableRaster)


getAlphas

getAlphas o7planning.org
  • IndexColorModel.getAlphas(byte[])


getAlternatives

getAlternatives o7planning.org
  • UnionType.getAlternatives()


getAltKey

getAltKey o7planning.org
  • MouseEvent.getAltKey()


getAltName

getAltName o7planning.org
  • CannotProceedException.getAltName()


getAltNameCtx

getAltNameCtx o7planning.org
  • CannotProceedException.getAltNameCtx()


getAltText

getAltText o7planning.org
  • ImageView.getAltText()


getAmountFull

getAmountFull o7planning.org
  • BasicProgressBarUI.getAmountFull(Insets, int, int)


getAmPmStrings

getAmPmStrings o7planning.org
  • DateFormatSymbols.getAmPmStrings()


getAncestor

getAncestor o7planning.org
  • AncestorEvent.getAncestor()


getAncestorListeners

getAncestorListeners o7planning.org
  • JComponent.getAncestorListeners()


getAncestorNamed

getAncestorNamed o7planning.org
  • SwingUtilities.getAncestorNamed(String, Component)


getAncestorOfClass

getAncestorOfClass o7planning.org
  • SwingUtilities.getAncestorOfClass(Class<?>, Component)


getAncestorParent

getAncestorParent o7planning.org
  • AncestorEvent.getAncestorParent()


getAnchorRect

getAnchorRect o7planning.org
  • TexturePaint.getAnchorRect()


getAnchorSelectionIndex

getAnchorSelectionIndex o7planning.org
  • DefaultListSelectionModel.getAnchorSelectionIndex()
  • JList.getAnchorSelectionIndex()
  • ListSelectionModel.getAnchorSelectionIndex()


getAnchorSelectionPath

getAnchorSelectionPath o7planning.org
  • JTree.getAnchorSelectionPath()


getAndAccumulate

getAndAccumulate o7planning.org
  • AtomicInteger.getAndAccumulate(int, IntBinaryOperator)
  • AtomicIntegerArray.getAndAccumulate(int, int, IntBinaryOperator)
  • AtomicIntegerFieldUpdater.getAndAccumulate(T, int, IntBinaryOperator)
  • AtomicLong.getAndAccumulate(long, LongBinaryOperator)
  • AtomicLongArray.getAndAccumulate(int, long, LongBinaryOperator)
  • AtomicLongFieldUpdater.getAndAccumulate(T, long, LongBinaryOperator)
  • AtomicReference.getAndAccumulate(V, BinaryOperator<V>)
  • AtomicReferenceArray.getAndAccumulate(int, E, BinaryOperator<E>)
  • AtomicReferenceFieldUpdater.getAndAccumulate(T, V, BinaryOperator<V>)


getAndAdd

getAndAdd o7planning.org
  • AtomicInteger.getAndAdd(int)
  • AtomicIntegerArray.getAndAdd(int, int)
  • AtomicIntegerFieldUpdater.getAndAdd(T, int)
  • AtomicLong.getAndAdd(long)
  • AtomicLongArray.getAndAdd(int, long)
  • AtomicLongFieldUpdater.getAndAdd(T, long)


getAndDecrement

getAndDecrement o7planning.org
  • AtomicInteger.getAndDecrement()
  • AtomicIntegerArray.getAndDecrement(int)
  • AtomicIntegerFieldUpdater.getAndDecrement(T)
  • AtomicLong.getAndDecrement()
  • AtomicLongArray.getAndDecrement(int)
  • AtomicLongFieldUpdater.getAndDecrement(T)


getAndIncrement

getAndIncrement o7planning.org
  • AtomicInteger.getAndIncrement()
  • AtomicIntegerArray.getAndIncrement(int)
  • AtomicIntegerFieldUpdater.getAndIncrement(T)
  • AtomicLong.getAndIncrement()
  • AtomicLongArray.getAndIncrement(int)
  • AtomicLongFieldUpdater.getAndIncrement(T)


getAndSet

getAndSet o7planning.org
  • AtomicBoolean.getAndSet(boolean)
  • AtomicInteger.getAndSet(int)
  • AtomicIntegerArray.getAndSet(int, int)
  • AtomicIntegerFieldUpdater.getAndSet(T, int)
  • AtomicLong.getAndSet(long)
  • AtomicLongArray.getAndSet(int, long)
  • AtomicLongFieldUpdater.getAndSet(T, long)
  • AtomicReference.getAndSet(V)
  • AtomicReferenceArray.getAndSet(int, E)
  • AtomicReferenceFieldUpdater.getAndSet(T, V)


getAndUpdate

getAndUpdate o7planning.org
  • AtomicInteger.getAndUpdate(IntUnaryOperator)
  • AtomicIntegerArray.getAndUpdate(int, IntUnaryOperator)
  • AtomicIntegerFieldUpdater.getAndUpdate(T, IntUnaryOperator)
  • AtomicLong.getAndUpdate(LongUnaryOperator)
  • AtomicLongArray.getAndUpdate(int, LongUnaryOperator)
  • AtomicLongFieldUpdater.getAndUpdate(T, LongUnaryOperator)
  • AtomicReference.getAndUpdate(UnaryOperator<V>)
  • AtomicReferenceArray.getAndUpdate(int, UnaryOperator<E>)
  • AtomicReferenceFieldUpdater.getAndUpdate(T, UnaryOperator<V>)


getAngleExtent

getAngleExtent o7planning.org
  • Arc2D.getAngleExtent()
  • Arc2D.Double.getAngleExtent()
  • Arc2D.Float.getAngleExtent()


getAngleStart

getAngleStart o7planning.org
  • Arc2D.getAngleStart()
  • Arc2D.Double.getAngleStart()
  • Arc2D.Float.getAngleStart()


getAnimationIndex

getAnimationIndex o7planning.org
  • BasicProgressBarUI.getAnimationIndex()


getAnnotatedActualTypeArguments

getAnnotatedActualTypeArguments o7planning.org
  • AnnotatedParameterizedType.getAnnotatedActualTypeArguments()


getAnnotatedBounds

getAnnotatedBounds o7planning.org
  • AnnotatedTypeVariable.getAnnotatedBounds()
  • TypeVariable.getAnnotatedBounds()


getAnnotatedExceptionTypes

getAnnotatedExceptionTypes o7planning.org
  • Executable.getAnnotatedExceptionTypes()


getAnnotatedGenericComponentType

getAnnotatedGenericComponentType o7planning.org
  • AnnotatedArrayType.getAnnotatedGenericComponentType()


getAnnotatedInterfaces

getAnnotatedInterfaces o7planning.org
  • Class.getAnnotatedInterfaces()


getAnnotatedLowerBounds

getAnnotatedLowerBounds o7planning.org
  • AnnotatedWildcardType.getAnnotatedLowerBounds()


getAnnotatedParameterTypes

getAnnotatedParameterTypes o7planning.org
  • Executable.getAnnotatedParameterTypes()


getAnnotatedReceiverType

getAnnotatedReceiverType o7planning.org
  • Constructor.getAnnotatedReceiverType()
  • Executable.getAnnotatedReceiverType()


getAnnotatedReturnType

getAnnotatedReturnType o7planning.org
  • Constructor.getAnnotatedReturnType()
  • Executable.getAnnotatedReturnType()
  • Method.getAnnotatedReturnType()


getAnnotatedSuperclass

getAnnotatedSuperclass o7planning.org
  • Class.getAnnotatedSuperclass()


getAnnotatedType

getAnnotatedType o7planning.org
  • Field.getAnnotatedType()
  • Parameter.getAnnotatedType()


getAnnotatedUpperBounds

getAnnotatedUpperBounds o7planning.org
  • AnnotatedWildcardType.getAnnotatedUpperBounds()


getAnnotation

getAnnotation o7planning.org
  • AccessibleObject.getAnnotation(Class<T>)
  • AnnotatedConstruct.getAnnotation(Class<A>)
  • AnnotatedElement.getAnnotation(Class<T>)
  • Class.getAnnotation(Class<A>)
  • Constructor.getAnnotation(Class<T>)
  • Element.getAnnotation(Class<A>)
  • Executable.getAnnotation(Class<T>)
  • Field.getAnnotation(Class<T>)
  • Method.getAnnotation(Class<T>)
  • Package.getAnnotation(Class<A>)
  • Parameter.getAnnotation(Class<T>)


getAnnotationMirrors

getAnnotationMirrors o7planning.org
  • AnnotatedConstruct.getAnnotationMirrors()
  • Element.getAnnotationMirrors()


getAnnotations

getAnnotations o7planning.org
  • AccessibleObject.getAnnotations()
  • AnnotatedElement.getAnnotations()
  • Class.getAnnotations()
  • Package.getAnnotations()
  • Parameter.getAnnotations()


getAnnotationsByType

getAnnotationsByType o7planning.org
  • AccessibleObject.getAnnotationsByType(Class<T>)
  • AnnotatedConstruct.getAnnotationsByType(Class<A>)
  • AnnotatedElement.getAnnotationsByType(Class<T>)
  • Class.getAnnotationsByType(Class<A>)
  • Executable.getAnnotationsByType(Class<T>)
  • Field.getAnnotationsByType(Class<T>)
  • Package.getAnnotationsByType(Class<A>)
  • Parameter.getAnnotationsByType(Class<T>)


getAnnotationType

getAnnotationType o7planning.org
  • AnnotationMirror.getAnnotationType()


getAnonymityState

getAnonymityState o7planning.org
  • GSSContext.getAnonymityState()


getAnonymousLogger

getAnonymousLogger o7planning.org
  • Logger.getAnonymousLogger(String)
  • Logger.getAnonymousLogger()


getAntiAliasingHint

getAntiAliasingHint o7planning.org
  • FontRenderContext.getAntiAliasingHint()


getAppConfigurationEntry

getAppConfigurationEntry o7planning.org
  • Configuration.getAppConfigurationEntry(String)


getApplet

getApplet o7planning.org
  • AppletContext.getApplet(String)


getAppletContext

getAppletContext o7planning.org
  • Applet.getAppletContext()
  • AppletStub.getAppletContext()


getAppletInfo

getAppletInfo o7planning.org
  • Applet.getAppletInfo()


getApplets

getApplets o7planning.org
  • AppletContext.getApplets()


getApplicationBufferSize

getApplicationBufferSize o7planning.org
  • SSLSession.getApplicationBufferSize()


getApplicationData

getApplicationData o7planning.org
  • ChannelBinding.getApplicationData()


getApproveButton

getApproveButton o7planning.org
  • BasicFileChooserUI.getApproveButton(JFileChooser)
  • MetalFileChooserUI.getApproveButton(JFileChooser)


getApproveButtonMnemonic

getApproveButtonMnemonic o7planning.org
  • BasicFileChooserUI.getApproveButtonMnemonic(JFileChooser)
  • JFileChooser.getApproveButtonMnemonic()


getApproveButtonText

getApproveButtonText o7planning.org
  • BasicFileChooserUI.getApproveButtonText(JFileChooser)
  • FileChooserUI.getApproveButtonText(JFileChooser)
  • JFileChooser.getApproveButtonText()
  • MultiFileChooserUI.getApproveButtonText(JFileChooser)


getApproveButtonToolTipText

getApproveButtonToolTipText o7planning.org
  • BasicFileChooserUI.getApproveButtonToolTipText(JFileChooser)
  • JFileChooser.getApproveButtonToolTipText()


getApproveSelectionAction

getApproveSelectionAction o7planning.org
  • BasicFileChooserUI.getApproveSelectionAction()


getArch

getArch o7planning.org
  • OperatingSystemMXBean.getArch()


getArcHeight

getArcHeight o7planning.org
  • RoundRectangle2D.getArcHeight()
  • RoundRectangle2D.Double.getArcHeight()
  • RoundRectangle2D.Float.getArcHeight()


getArcType

getArcType o7planning.org
  • Arc2D.getArcType()


getArcWidth

getArcWidth o7planning.org
  • RoundRectangle2D.getArcWidth()
  • RoundRectangle2D.Double.getArcWidth()
  • RoundRectangle2D.Float.getArcWidth()


getAreaOfInterest

getAreaOfInterest o7planning.org
  • RenderContext.getAreaOfInterest()


getArgument

getArgument o7planning.org
  • UnknownAnnotationValueException.getArgument()
  • UnknownElementException.getArgument()
  • UnknownTypeException.getArgument()


getArgumentClass

getArgumentClass o7planning.org
  • IllegalFormatConversionException.getArgumentClass()


getArguments

getArguments o7planning.org
  • Statement.getArguments()


getArray

getArray o7planning.org
  • Array.getArray(long, int, Map<String, Class<?>>)
  • Array.getArray(long, int)
  • Array.getArray(Map<String, Class<?>>)
  • Array.getArray()
  • CallableStatement.getArray(String)
  • CallableStatement.getArray(int)
  • DefaultStyledDocument.ElementSpec.getArray()
  • ResultSet.getArray(String)
  • ResultSet.getArray(int)
  • SerialArray.getArray(long, int, Map<String, Class<?>>)
  • SerialArray.getArray(long, int)
  • SerialArray.getArray(Map<String, Class<?>>)
  • SerialArray.getArray()


getArrayLength

getArrayLength o7planning.org
  • GapContent.getArrayLength()


getArrayType

getArrayType o7planning.org
  • ArrayType.getArrayType(OpenType<E>)
  • Types.getArrayType(TypeMirror)


getArrivedParties

getArrivedParties o7planning.org
  • Phaser.getArrivedParties()


getAsBoolean

getAsBoolean o7planning.org
  • BooleanSupplier.getAsBoolean()


getAscent

getAscent o7planning.org
  • FontMetrics.getAscent()
  • GlyphView.GlyphPainter.getAscent(GlyphView)
  • GraphicAttribute.getAscent()
  • ImageGraphicAttribute.getAscent()
  • LineMetrics.getAscent()
  • ShapeGraphicAttribute.getAscent()
  • TextLayout.getAscent()


getAsciiName

getAsciiName o7planning.org
  • SNIHostName.getAsciiName()


getAsciiStream

getAsciiStream o7planning.org
  • Clob.getAsciiStream()
  • ResultSet.getAsciiStream(String)
  • ResultSet.getAsciiStream(int)
  • SerialClob.getAsciiStream()


getAsDouble

getAsDouble o7planning.org
  • DoubleSupplier.getAsDouble()
  • OptionalDouble.getAsDouble()


getAsInt

getAsInt o7planning.org
  • IntSupplier.getAsInt()
  • OptionalInt.getAsInt()


getAsLong

getAsLong o7planning.org
  • LongSupplier.getAsLong()
  • OptionalLong.getAsLong()


getAspectRatio

getAspectRatio o7planning.org
  • ImageReader.getAspectRatio(int)


getAssociatedStylesheet

getAssociatedStylesheet o7planning.org
  • TransformerFactory.getAssociatedStylesheet(Source, String, String, String)


getAsText

getAsText o7planning.org
  • PropertyEditor.getAsText()
  • PropertyEditorSupport.getAsText()


getAsTree

getAsTree o7planning.org
  • IIOMetadata.getAsTree(String)


getAsync

getAsync o7planning.org
  • LSParser.getAsync()


getAsynchronousLoadPriority

getAsynchronousLoadPriority o7planning.org
  • AbstractDocument.getAsynchronousLoadPriority()


getAsyncMode

getAsyncMode o7planning.org
  • ForkJoinPool.getAsyncMode()


getAtIndex

getAtIndex o7planning.org
  • AbstractButton.AccessibleAbstractButton.getAtIndex(int, int)
  • AccessibleText.getAtIndex(int, int)
  • JLabel.AccessibleJLabel.getAtIndex(int, int)
  • JPasswordField.AccessibleJPasswordField.getAtIndex(int, int)
  • JSpinner.AccessibleJSpinner.getAtIndex(int, int)
  • JTextComponent.AccessibleJTextComponent.getAtIndex(int, int)
  • ProgressMonitor.AccessibleProgressMonitor.getAtIndex(int, int)
  • TextComponent.AccessibleAWTTextComponent.getAtIndex(int, int)


getAttachment

getAttachment o7planning.org
  • SOAPMessage.getAttachment(SOAPElement)


getAttachmentAsByteArray

getAttachmentAsByteArray o7planning.org
  • AttachmentUnmarshaller.getAttachmentAsByteArray(String)


getAttachmentAsDataHandler

getAttachmentAsDataHandler o7planning.org
  • AttachmentUnmarshaller.getAttachmentAsDataHandler(String)


getAttachmentMarshaller

getAttachmentMarshaller o7planning.org
  • AbstractMarshallerImpl.getAttachmentMarshaller()
  • Marshaller.getAttachmentMarshaller()


getAttachments

getAttachments o7planning.org
  • SOAPMessage.getAttachments(MimeHeaders)
  • SOAPMessage.getAttachments()


getAttachmentUnmarshaller

getAttachmentUnmarshaller o7planning.org
  • AbstractUnmarshallerImpl.getAttachmentUnmarshaller()
  • Unmarshaller.getAttachmentUnmarshaller()


getAttrChange

getAttrChange o7planning.org
  • MutationEvent.getAttrChange()


getAttribute

getAttribute o7planning.org
  • AbstractDocument.AbstractElement.getAttribute(Object)
  • AttributeSet.getAttribute(Object)
  • AttributeValueExp.getAttribute(ObjectName)
  • AttributedCharacterIterator.getAttribute(AttributedCharacterIterator.Attribute)
  • CSS.getAttribute(String)
  • DocumentBuilderFactory.getAttribute(String)
  • DynamicMBean.getAttribute(String)
  • Element.getAttribute(String)
  • Element.getAttribute(String)
  • FileStore.getAttribute(String)
  • Files.getAttribute(Path, String, LinkOption...)
  • HttpContext.getAttribute(String)
  • HttpExchange.getAttribute(String)
  • IIOMetadataNode.getAttribute(String)
  • MBeanServer.getAttribute(ObjectName, String)
  • MBeanServerConnection.getAttribute(ObjectName, String)
  • ModelMBeanInfo.getAttribute(String)
  • ModelMBeanInfoSupport.getAttribute(String)
  • ModificationItem.getAttribute()
  • PrintService.getAttribute(Class<T>)
  • Provider.Service.getAttribute(String)
  • RMIConnection.getAttribute(ObjectName, String, Subject)
  • RMIConnectionImpl.getAttribute(ObjectName, String, Subject)
  • RMIConnectionImpl_Stub.getAttribute(ObjectName, String, Subject)
  • RequiredModelMBean.getAttribute(String)
  • ScriptContext.getAttribute(String)
  • ScriptContext.getAttribute(String, int)
  • SimpleAttributeSet.getAttribute(Object)
  • SimpleScriptContext.getAttribute(String, int)
  • SimpleScriptContext.getAttribute(String)
  • StandardMBean.getAttribute(String)
  • StyleContext.NamedStyle.getAttribute(Object)
  • StyleContext.SmallAttributeSet.getAttribute(Object)
  • TransformerFactory.getAttribute(String)


getAttributeByName

getAttributeByName o7planning.org
  • StartElement.getAttributeByName(QName)


getAttributeByValue

getAttributeByValue o7planning.org
  • Element.getAttributeByValue(String)


getAttributeContext

getAttributeContext o7planning.org
  • AbstractDocument.getAttributeContext()


getAttributeCount

getAttributeCount o7planning.org
  • AbstractDocument.AbstractElement.getAttributeCount()
  • AttributeSet.getAttributeCount()
  • SimpleAttributeSet.getAttributeCount()
  • StreamReaderDelegate.getAttributeCount()
  • StyleContext.NamedStyle.getAttributeCount()
  • StyleContext.SmallAttributeSet.getAttributeCount()
  • XMLStreamReader.getAttributeCount()


getAttributeDataType

getAttributeDataType o7planning.org
  • IIOMetadataFormat.getAttributeDataType(String, String)
  • IIOMetadataFormatImpl.getAttributeDataType(String, String)


getAttributeDefaultValue

getAttributeDefaultValue o7planning.org
  • IIOMetadataFormat.getAttributeDefaultValue(String, String)
  • IIOMetadataFormatImpl.getAttributeDefaultValue(String, String)


getAttributeDefinition

getAttributeDefinition o7planning.org
  • Attribute.getAttributeDefinition()
  • BasicAttribute.getAttributeDefinition()


getAttributeDescription

getAttributeDescription o7planning.org
  • IIOMetadataFormat.getAttributeDescription(String, String, Locale)
  • IIOMetadataFormatImpl.getAttributeDescription(String, String, Locale)


getAttributeEnumerations

getAttributeEnumerations o7planning.org
  • IIOMetadataFormat.getAttributeEnumerations(String, String)
  • IIOMetadataFormatImpl.getAttributeEnumerations(String, String)


getAttributeID

getAttributeID o7planning.org
  • SortKey.getAttributeID()
  • SortResponseControl.getAttributeID()


getAttributeKey

getAttributeKey o7planning.org
  • HTML.getAttributeKey(String)


getAttributeListMaxLength

getAttributeListMaxLength o7planning.org
  • IIOMetadataFormat.getAttributeListMaxLength(String, String)
  • IIOMetadataFormatImpl.getAttributeListMaxLength(String, String)


getAttributeListMinLength

getAttributeListMinLength o7planning.org
  • IIOMetadataFormat.getAttributeListMinLength(String, String)
  • IIOMetadataFormatImpl.getAttributeListMinLength(String, String)


getAttributeLocalName

getAttributeLocalName o7planning.org
  • StreamReaderDelegate.getAttributeLocalName(int)
  • XMLStreamReader.getAttributeLocalName(int)


getAttributeMaxValue

getAttributeMaxValue o7planning.org
  • IIOMetadataFormat.getAttributeMaxValue(String, String)
  • IIOMetadataFormatImpl.getAttributeMaxValue(String, String)


getAttributeMinValue

getAttributeMinValue o7planning.org
  • IIOMetadataFormat.getAttributeMinValue(String, String)
  • IIOMetadataFormatImpl.getAttributeMinValue(String, String)


getAttributeName

getAttributeName o7planning.org
  • AttributeChangeNotification.getAttributeName()
  • AttributeValueExp.getAttributeName()
  • StreamReaderDelegate.getAttributeName(int)
  • XMLStreamReader.getAttributeName(int)


getAttributeNames

getAttributeNames o7planning.org
  • AbstractDocument.AbstractElement.getAttributeNames()
  • AttributeSet.getAttributeNames()
  • HttpContext.getAttributeNames()
  • HttpExchange.getAttributeNames()
  • IIOMetadataFormat.getAttributeNames(String)
  • IIOMetadataFormatImpl.getAttributeNames(String)
  • SimpleAttributeSet.getAttributeNames()
  • StyleContext.NamedStyle.getAttributeNames()
  • StyleContext.SmallAttributeSet.getAttributeNames()


getAttributeNamespace

getAttributeNamespace o7planning.org
  • StreamReaderDelegate.getAttributeNamespace(int)
  • XMLStreamReader.getAttributeNamespace(int)


getAttributeNode

getAttributeNode o7planning.org
  • Element.getAttributeNode(String)
  • IIOMetadataNode.getAttributeNode(String)


getAttributeNodeNS

getAttributeNodeNS o7planning.org
  • Element.getAttributeNodeNS(String, String)
  • IIOMetadataNode.getAttributeNodeNS(String, String)


getAttributeNS

getAttributeNS o7planning.org
  • Element.getAttributeNS(String, String)
  • IIOMetadataNode.getAttributeNS(String, String)


getAttributePrefix

getAttributePrefix o7planning.org
  • StreamReaderDelegate.getAttributePrefix(int)
  • XMLStreamReader.getAttributePrefix(int)


getAttributes

getAttributes o7planning.org
  • AbstractDocument.AbstractElement.getAttributes()
  • AttributedCharacterIterator.getAttributes()
  • BlockView.getAttributes()
  • DatabaseMetaData.getAttributes(String, String, String, String)
  • DefaultStyledDocument.ElementSpec.getAttributes()
  • DirContext.getAttributes(String, String[])
  • DirContext.getAttributes(Name, String[])
  • DirContext.getAttributes(String)
  • DirContext.getAttributes(Name)
  • DirStateFactory.Result.getAttributes()
  • Doc.getAttributes()
  • DocPrintJob.getAttributes()
  • DynamicMBean.getAttributes(String[])
  • Element.getAttributes()
  • Element.getAttributes()
  • Font.getAttributes()
  • HTMLDocument.Iterator.getAttributes()
  • IIOMetadataNode.getAttributes()
  • ImageView.getAttributes()
  • InitialDirContext.getAttributes(Name, String[])
  • InitialDirContext.getAttributes(Name)
  • InitialDirContext.getAttributes(String, String[])
  • InitialDirContext.getAttributes(String)
  • InlineView.getAttributes()
  • JMXConnectorServerMBean.getAttributes()
  • JarEntry.getAttributes()
  • JarURLConnection.getAttributes()
  • KeyStore.Entry.getAttributes()
  • KeyStore.PrivateKeyEntry.getAttributes()
  • KeyStore.SecretKeyEntry.getAttributes()
  • KeyStore.TrustedCertificateEntry.getAttributes()
  • MBeanInfo.getAttributes()
  • MBeanServer.getAttributes(ObjectName, String[])
  • MBeanServerConnection.getAttributes(ObjectName, String[])
  • MLetContent.getAttributes()
  • Manifest.getAttributes(String)
  • ModelMBeanInfo.getAttributes()
  • Node.getAttributes()
  • OpenMBeanInfo.getAttributes()
  • Option.getAttributes()
  • ParagraphView.getAttributes()
  • Parser.getAttributes()
  • PrintJobAttributeEvent.getAttributes()
  • PrintService.getAttributes()
  • PrintServiceAttributeEvent.getAttributes()
  • RMIConnection.getAttributes(ObjectName, String[], Subject)
  • RMIConnectionImpl.getAttributes(ObjectName, String[], Subject)
  • RMIConnectionImpl_Stub.getAttributes(ObjectName, String[], Subject)
  • RMIConnectorServer.getAttributes()
  • RequiredModelMBean.getAttributes(String[])
  • SearchResult.getAttributes()
  • SerialStruct.getAttributes(Map<String, Class<?>>)
  • SerialStruct.getAttributes()
  • SimpleDoc.getAttributes()
  • StandardMBean.getAttributes(String[])
  • StartElement.getAttributes()
  • Struct.getAttributes(Map<String, Class<?>>)
  • Struct.getAttributes()
  • View.getAttributes()


getAttributesScope

getAttributesScope o7planning.org
  • ScriptContext.getAttributesScope(String)
  • SimpleScriptContext.getAttributesScope(String)


getAttributeSyntaxDefinition

getAttributeSyntaxDefinition o7planning.org
  • Attribute.getAttributeSyntaxDefinition()
  • BasicAttribute.getAttributeSyntaxDefinition()


getAttributeType

getAttributeType o7planning.org
  • AttributeChangeNotification.getAttributeType()
  • StreamReaderDelegate.getAttributeType(int)
  • XMLStreamReader.getAttributeType(int)


getAttributeTypeInfo

getAttributeTypeInfo o7planning.org
  • TypeInfoProvider.getAttributeTypeInfo(int)


getAttributeValue

getAttributeValue o7planning.org
  • SOAPElement.getAttributeValue(QName)
  • SOAPElement.getAttributeValue(Name)
  • StreamReaderDelegate.getAttributeValue(int)
  • StreamReaderDelegate.getAttributeValue(String, String)
  • XMLStreamReader.getAttributeValue(int)
  • XMLStreamReader.getAttributeValue(String, String)


getAttributeValueType

getAttributeValueType o7planning.org
  • IIOMetadataFormat.getAttributeValueType(String, String)
  • IIOMetadataFormatImpl.getAttributeValueType(String, String)


getAttrName

getAttrName o7planning.org
  • MutationEvent.getAttrName()


getAudioActionMap

getAudioActionMap o7planning.org
  • BasicLookAndFeel.getAudioActionMap()


getAudioClip

getAudioClip o7planning.org
  • Applet.getAudioClip(URL, String)
  • Applet.getAudioClip(URL)
  • AppletContext.getAudioClip(URL)


getAudioFileFormat

getAudioFileFormat o7planning.org
  • AudioFileReader.getAudioFileFormat(File)
  • AudioFileReader.getAudioFileFormat(URL)
  • AudioFileReader.getAudioFileFormat(InputStream)
  • AudioSystem.getAudioFileFormat(File)
  • AudioSystem.getAudioFileFormat(URL)
  • AudioSystem.getAudioFileFormat(InputStream)


getAudioFileTypes

getAudioFileTypes o7planning.org
  • AudioFileWriter.getAudioFileTypes(AudioInputStream)
  • AudioFileWriter.getAudioFileTypes()
  • AudioSystem.getAudioFileTypes(AudioInputStream)
  • AudioSystem.getAudioFileTypes()


getAudioInputStream

getAudioInputStream o7planning.org
  • AudioFileReader.getAudioInputStream(File)
  • AudioFileReader.getAudioInputStream(URL)
  • AudioFileReader.getAudioInputStream(InputStream)
  • AudioSystem.getAudioInputStream(File)
  • AudioSystem.getAudioInputStream(URL)
  • AudioSystem.getAudioInputStream(InputStream)
  • AudioSystem.getAudioInputStream(AudioFormat, AudioInputStream)
  • AudioSystem.getAudioInputStream(AudioFormat.Encoding, AudioInputStream)
  • FormatConversionProvider.getAudioInputStream(AudioFormat, AudioInputStream)
  • FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding, AudioInputStream)


getAuthenticationID

getAuthenticationID o7planning.org
  • AuthorizeCallback.getAuthenticationID()


getAuthority

getAuthority o7planning.org
  • URI.getAuthority()
  • URL.getAuthority()


getAuthorityKeyIdentifier

getAuthorityKeyIdentifier o7planning.org
  • X509CertSelector.getAuthorityKeyIdentifier()


getAuthorityName

getAuthorityName o7planning.org
  • CertificateRevokedException.getAuthorityName()


getAuthorizationID

getAuthorizationID o7planning.org
  • AuthorizeCallback.getAuthorizationID()
  • SaslServer.getAuthorizationID()


getAuthorizedID

getAuthorizedID o7planning.org
  • AuthorizeCallback.getAuthorizedID()


getAuthTime

getAuthTime o7planning.org
  • KerberosTicket.getAuthTime()


getAutoCommit

getAutoCommit o7planning.org
  • Connection.getAutoCommit()
  • JdbcRowSet.getAutoCommit()


getAutoCreateColumnsFromModel

getAutoCreateColumnsFromModel o7planning.org
  • JTable.getAutoCreateColumnsFromModel()


getAutoCreateContainerGaps

getAutoCreateContainerGaps o7planning.org
  • GroupLayout.getAutoCreateContainerGaps()


getAutoCreateGaps

getAutoCreateGaps o7planning.org
  • GroupLayout.getAutoCreateGaps()


getAutoCreateRowSorter

getAutoCreateRowSorter o7planning.org
  • JTable.getAutoCreateRowSorter()


getAutoDelay

getAutoDelay o7planning.org
  • Robot.getAutoDelay()


getAutoResizeMode

getAutoResizeMode o7planning.org
  • JTable.getAutoResizeMode()


getAutoscrollInsets

getAutoscrollInsets o7planning.org
  • Autoscroll.getAutoscrollInsets()


getAutoscrolls

getAutoscrolls o7planning.org
  • JComponent.getAutoscrolls()


getAuxiliaryLookAndFeels

getAuxiliaryLookAndFeels o7planning.org
  • UIManager.getAuxiliaryLookAndFeels()


getAvailableAcceleratedMemory

getAvailableAcceleratedMemory o7planning.org
  • GraphicsDevice.getAvailableAcceleratedMemory()


getAvailableAttributes

getAvailableAttributes o7planning.org
  • Font.getAvailableAttributes()


getAvailableCalendarTypes

getAvailableCalendarTypes o7planning.org
  • Calendar.getAvailableCalendarTypes()


getAvailableChronologies

getAvailableChronologies o7planning.org
  • Chronology.getAvailableChronologies()


getAvailableCurrencies

getAvailableCurrencies o7planning.org
  • Currency.getAvailableCurrencies()


getAvailableDataFlavors

getAvailableDataFlavors o7planning.org
  • Clipboard.getAvailableDataFlavors()


getAvailableFontFamilyNames

getAvailableFontFamilyNames o7planning.org
  • GraphicsEnvironment.getAvailableFontFamilyNames(Locale)
  • GraphicsEnvironment.getAvailableFontFamilyNames()


getAvailableIDs

getAvailableIDs o7planning.org
  • TimeZone.getAvailableIDs()
  • TimeZone.getAvailableIDs(int)


getAvailableInstruments

getAvailableInstruments o7planning.org
  • Synthesizer.getAvailableInstruments()


getAvailableLocales

getAvailableLocales o7planning.org
  • BreakIterator.getAvailableLocales()
  • Calendar.getAvailableLocales()
  • Collator.getAvailableLocales()
  • DateFormat.getAvailableLocales()
  • DateFormatSymbols.getAvailableLocales()
  • DecimalFormatSymbols.getAvailableLocales()
  • DecimalStyle.getAvailableLocales()
  • ImageReader.getAvailableLocales()
  • ImageWriter.getAvailableLocales()
  • InputMethodDescriptor.getAvailableLocales()
  • Locale.getAvailableLocales()
  • LocaleServiceProvider.getAvailableLocales()
  • NumberFormat.getAvailableLocales()


getAvailableProcessors

getAvailableProcessors o7planning.org
  • OperatingSystemMXBean.getAvailableProcessors()


getAvailableSize

getAvailableSize o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize(Dimension, Insets)


getAvailableZoneIds

getAvailableZoneIds o7planning.org
  • ZoneId.getAvailableZoneIds()
  • ZoneRulesProvider.getAvailableZoneIds()


getAverage

getAverage o7planning.org
  • DoubleSummaryStatistics.getAverage()
  • IntSummaryStatistics.getAverage()
  • LongSummaryStatistics.getAverage()


getAWTEventListeners

getAWTEventListeners o7planning.org
  • Toolkit.getAWTEventListeners(long)
  • Toolkit.getAWTEventListeners()


getAWTKeyStroke

getAWTKeyStroke o7planning.org
  • AWTKeyStroke.getAWTKeyStroke(String)
  • AWTKeyStroke.getAWTKeyStroke(int, int)
  • AWTKeyStroke.getAWTKeyStroke(int, int, boolean)
  • AWTKeyStroke.getAWTKeyStroke(Character, int)
  • AWTKeyStroke.getAWTKeyStroke(char)


getAWTKeyStrokeForEvent

getAWTKeyStrokeForEvent o7planning.org
  • AWTKeyStroke.getAWTKeyStrokeForEvent(KeyEvent)


getAxis

getAxis o7planning.org
  • BoxLayout.getAxis()
  • BoxView.getAxis()


getB

getB o7planning.org
  • EllipticCurve.getB()


getBackBuffer

getBackBuffer o7planning.org
  • Component.FlipBufferStrategy.getBackBuffer()


getBackBufferCapabilities

getBackBufferCapabilities o7planning.org
  • BufferCapabilities.getBackBufferCapabilities()


getBackground

getBackground o7planning.org
  • AccessibleComponent.getBackground()
  • Component.getBackground()
  • Component.AccessibleAWTComponent.getBackground()
  • DefaultStyledDocument.getBackground(AttributeSet)
  • GlyphView.getBackground()
  • Graphics2D.getBackground()
  • JList.AccessibleJList.AccessibleJListChild.getBackground()
  • JTable.AccessibleJTable.AccessibleJTableCell.getBackground()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBackground()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getBackground()
  • LabelView.getBackground()
  • List.AccessibleAWTList.AccessibleAWTListChild.getBackground()
  • MenuComponent.AccessibleAWTMenuComponent.getBackground()
  • StyleConstants.getBackground(AttributeSet)
  • StyleContext.getBackground(AttributeSet)
  • StyleSheet.getBackground(AttributeSet)
  • StyledDocument.getBackground(AttributeSet)
  • TextComponent.getBackground()
  • Window.getBackground()


getBackgroundAt

getBackgroundAt o7planning.org
  • JTabbedPane.getBackgroundAt(int)


getBackgroundNonSelectionColor

getBackgroundNonSelectionColor o7planning.org
  • DefaultTreeCellRenderer.getBackgroundNonSelectionColor()


getBackgroundPainter

getBackgroundPainter o7planning.org
  • NimbusStyle.getBackgroundPainter(SynthContext)


getBackgroundSelectionColor

getBackgroundSelectionColor o7planning.org
  • DefaultTreeCellRenderer.getBackgroundSelectionColor()


getBandOffsets

getBandOffsets o7planning.org
  • ComponentSampleModel.getBandOffsets()


getBank

getBank o7planning.org
  • Patch.getBank()


getBankData

getBankData o7planning.org
  • DataBufferByte.getBankData()
  • DataBufferDouble.getBankData()
  • DataBufferFloat.getBankData()
  • DataBufferInt.getBankData()
  • DataBufferShort.getBankData()
  • DataBufferUShort.getBankData()


getBankIndices

getBankIndices o7planning.org
  • ComponentSampleModel.getBankIndices()


getBase64Content

getBase64Content o7planning.org
  • AttachmentPart.getBase64Content()


getBase

getBase o7planning.org
  • HTMLDocument.getBase()
  • StyleSheet.getBase()


getBaseBundleName

getBaseBundleName o7planning.org
  • ResourceBundle.getBaseBundleName()


getBaseLevel

getBaseLevel o7planning.org
  • Bidi.getBaseLevel()


getBaseline

getBaseline o7planning.org
  • AbstractBorder.getBaseline(Component, int, int)
  • BasicButtonUI.getBaseline(JComponent, int, int)
  • BasicComboBoxUI.getBaseline(JComponent, int, int)
  • BasicLabelUI.getBaseline(JComponent, int, int)
  • BasicListUI.getBaseline(JComponent, int, int)
  • BasicPanelUI.getBaseline(JComponent, int, int)
  • BasicProgressBarUI.getBaseline(JComponent, int, int)
  • BasicScrollPaneUI.getBaseline(JComponent, int, int)
  • BasicSliderUI.getBaseline(JComponent, int, int)
  • BasicSpinnerUI.getBaseline(JComponent, int, int)
  • BasicTabbedPaneUI.getBaseline(int)
  • BasicTabbedPaneUI.getBaseline(JComponent, int, int)
  • BasicTableHeaderUI.getBaseline(JComponent, int, int)
  • BasicTableUI.getBaseline(JComponent, int, int)
  • BasicTextAreaUI.getBaseline(JComponent, int, int)
  • BasicTextFieldUI.getBaseline(JComponent, int, int)
  • BasicTreeUI.getBaseline(JComponent, int, int)
  • Component.getBaseline(int, int)
  • ComponentUI.getBaseline(JComponent, int, int)
  • JComponent.getBaseline(int, int)
  • JSpinner.DefaultEditor.getBaseline(int, int)
  • LayerUI.getBaseline(JComponent, int, int)
  • MetalComboBoxUI.getBaseline(JComponent, int, int)
  • SynthButtonUI.getBaseline(JComponent, int, int)
  • SynthLabelUI.getBaseline(JComponent, int, int)
  • SynthProgressBarUI.getBaseline(JComponent, int, int)
  • SynthSliderUI.getBaseline(JComponent, int, int)
  • SynthTabbedPaneUI.getBaseline(int)
  • TextLayout.getBaseline()
  • TitledBorder.getBaseline(Component, int, int)


getBaselineFor

getBaselineFor o7planning.org
  • Font.getBaselineFor(char)


getBaselineIndex

getBaselineIndex o7planning.org
  • LineMetrics.getBaselineIndex()


getBaselineOffset

getBaselineOffset o7planning.org
  • BasicTabbedPaneUI.getBaselineOffset()
  • MetalTabbedPaneUI.getBaselineOffset()


getBaselineOffsets

getBaselineOffsets o7planning.org
  • LineMetrics.getBaselineOffsets()
  • TextLayout.getBaselineOffsets()


getBaselineResizeBehavior

getBaselineResizeBehavior o7planning.org
  • AbstractBorder.getBaselineResizeBehavior(Component)
  • BasicButtonUI.getBaselineResizeBehavior(JComponent)
  • BasicComboBoxUI.getBaselineResizeBehavior(JComponent)
  • BasicLabelUI.getBaselineResizeBehavior(JComponent)
  • BasicListUI.getBaselineResizeBehavior(JComponent)
  • BasicPanelUI.getBaselineResizeBehavior(JComponent)
  • BasicProgressBarUI.getBaselineResizeBehavior(JComponent)
  • BasicScrollPaneUI.getBaselineResizeBehavior(JComponent)
  • BasicSliderUI.getBaselineResizeBehavior(JComponent)
  • BasicSpinnerUI.getBaselineResizeBehavior(JComponent)
  • BasicTabbedPaneUI.getBaselineResizeBehavior(JComponent)
  • BasicTableUI.getBaselineResizeBehavior(JComponent)
  • BasicTextAreaUI.getBaselineResizeBehavior(JComponent)
  • BasicTextFieldUI.getBaselineResizeBehavior(JComponent)
  • BasicTreeUI.getBaselineResizeBehavior(JComponent)
  • Component.getBaselineResizeBehavior()
  • ComponentUI.getBaselineResizeBehavior(JComponent)
  • JComponent.getBaselineResizeBehavior()
  • JSpinner.DefaultEditor.getBaselineResizeBehavior()
  • LayerUI.getBaselineResizeBehavior(JComponent)
  • TitledBorder.getBaselineResizeBehavior(Component)


getBaseType

getBaseType o7planning.org
  • Array.getBaseType()
  • MimeType.getBaseType()
  • SerialArray.getBaseType()


getBaseTypeName

getBaseTypeName o7planning.org
  • Array.getBaseTypeName()
  • Ref.getBaseTypeName()
  • SerialArray.getBaseTypeName()
  • SerialRef.getBaseTypeName()


getBaseUnit

getBaseUnit o7planning.org
  • ChronoField.getBaseUnit()
  • TemporalField.getBaseUnit()


getBaseURI

getBaseURI o7planning.org
  • DOMCryptoContext.getBaseURI()
  • EntityDeclaration.getBaseURI()
  • IIOMetadataNode.getBaseURI()
  • LSInput.getBaseURI()
  • Node.getBaseURI()
  • XMLCryptoContext.getBaseURI()


getBasicConstraints

getBasicConstraints o7planning.org
  • X509CertSelector.getBasicConstraints()
  • X509Certificate.getBasicConstraints()


getBasicSplitPaneUI

getBasicSplitPaneUI o7planning.org
  • BasicSplitPaneDivider.getBasicSplitPaneUI()


getBean

getBean o7planning.org
  • DataHandler.getBean(CommandInfo)


getBeanClass

getBeanClass o7planning.org
  • BeanDescriptor.getBeanClass()


getBeanContext

getBeanContext o7planning.org
  • BeanContextChild.getBeanContext()
  • BeanContextChildSupport.getBeanContext()
  • BeanContextEvent.getBeanContext()


getBeanContextChildPeer

getBeanContextChildPeer o7planning.org
  • BeanContextChildSupport.getBeanContextChildPeer()


getBeanContextPeer

getBeanContextPeer o7planning.org
  • BeanContextSupport.getBeanContextPeer()


getBeanContextProxy

getBeanContextProxy o7planning.org
  • BeanContextProxy.getBeanContextProxy()


getBeanContextServicesPeer

getBeanContextServicesPeer o7planning.org
  • BeanContextServicesSupport.getBeanContextServicesPeer()


getBeanDescriptor

getBeanDescriptor o7planning.org
  • BeanInfo.getBeanDescriptor()
  • SimpleBeanInfo.getBeanDescriptor()


getBeanInfo

getBeanInfo o7planning.org
  • Introspector.getBeanInfo(Class<?>, Class<?>, int)
  • Introspector.getBeanInfo(Class<?>, Class<?>)
  • Introspector.getBeanInfo(Class<?>, int)
  • Introspector.getBeanInfo(Class<?>)


getBeanInfoSearchPath

getBeanInfoSearchPath o7planning.org
  • Introspector.getBeanInfoSearchPath()


getBeforeIndex

getBeforeIndex o7planning.org
  • AbstractButton.AccessibleAbstractButton.getBeforeIndex(int, int)
  • AccessibleText.getBeforeIndex(int, int)
  • JLabel.AccessibleJLabel.getBeforeIndex(int, int)
  • JPasswordField.AccessibleJPasswordField.getBeforeIndex(int, int)
  • JSpinner.AccessibleJSpinner.getBeforeIndex(int, int)
  • JTextComponent.AccessibleJTextComponent.getBeforeIndex(int, int)
  • ProgressMonitor.AccessibleProgressMonitor.getBeforeIndex(int, int)
  • TextComponent.AccessibleAWTTextComponent.getBeforeIndex(int, int)


getBeginIndex

getBeginIndex o7planning.org
  • CharacterIterator.getBeginIndex()
  • FieldPosition.getBeginIndex()
  • Segment.getBeginIndex()
  • StringCharacterIterator.getBeginIndex()


getBestConfiguration

getBestConfiguration o7planning.org
  • GraphicsConfigTemplate.getBestConfiguration(GraphicsConfiguration[])
  • GraphicsDevice.getBestConfiguration(GraphicsConfigTemplate)


getBestCursorSize

getBestCursorSize o7planning.org
  • Toolkit.getBestCursorSize(int, int)


getBestRowIdentifier

getBestRowIdentifier o7planning.org
  • DatabaseMetaData.getBestRowIdentifier(String, String, String, int, boolean)


getBevelType

getBevelType o7planning.org
  • BevelBorder.getBevelType()


getBias

getBias o7planning.org
  • JTextComponent.DropLocation.getBias()


getBidiLevel

getBidiLevel o7planning.org
  • StyleConstants.getBidiLevel(AttributeSet)


getBidiRootElement

getBidiRootElement o7planning.org
  • AbstractDocument.getBidiRootElement()


getBigDecimal

getBigDecimal o7planning.org
  • CallableStatement.getBigDecimal(String)
  • CallableStatement.getBigDecimal(int)
  • CallableStatement.getBigDecimal(int, int)
  • ResultSet.getBigDecimal(String)
  • ResultSet.getBigDecimal(int)
  • ResultSet.getBigDecimal(String, int)
  • ResultSet.getBigDecimal(int, int)


getBinaryName

getBinaryName o7planning.org
  • Elements.getBinaryName(TypeElement)


getBinaryStream

getBinaryStream o7planning.org
  • Blob.getBinaryStream(long, long)
  • Blob.getBinaryStream()
  • ResultSet.getBinaryStream(String)
  • ResultSet.getBinaryStream(int)
  • SQLXML.getBinaryStream()
  • SerialBlob.getBinaryStream(long, long)
  • SerialBlob.getBinaryStream()


getBinding

getBinding o7planning.org
  • BindingProvider.getBinding()
  • Endpoint.getBinding()


getBindingID

getBindingID o7planning.org
  • Binding.getBindingID()
  • PortInfo.getBindingID()


getBindings

getBindings o7planning.org
  • AbstractScriptEngine.getBindings(int)
  • ScriptContext.getBindings(int)
  • ScriptEngine.getBindings(int)
  • ScriptEngineManager.getBindings()
  • SimpleScriptContext.getBindings(int)


getBitDepth

getBitDepth o7planning.org
  • DisplayMode.getBitDepth()


getBitMasks

getBitMasks o7planning.org
  • SinglePixelPackedSampleModel.getBitMasks()


getBitOffset

getBitOffset o7planning.org
  • ImageInputStream.getBitOffset()
  • ImageInputStreamImpl.getBitOffset()
  • MultiPixelPackedSampleModel.getBitOffset(int)


getBitOffsets

getBitOffsets o7planning.org
  • SinglePixelPackedSampleModel.getBitOffsets()


getBitRate

getBitRate o7planning.org
  • ImageWriteParam.getBitRate(float)


getBitsPerBand

getBitsPerBand o7planning.org
  • ImageTypeSpecifier.getBitsPerBand(int)


getBlack

getBlack o7planning.org
  • MetalLookAndFeel.getBlack()
  • MetalTheme.getBlack()
  • OceanTheme.getBlack()


getBlackBoxBounds

getBlackBoxBounds o7planning.org
  • TextLayout.getBlackBoxBounds(int, int)


getBlackLineBorderUIResource

getBlackLineBorderUIResource o7planning.org
  • BorderUIResource.getBlackLineBorderUIResource()


getBlinkRate

getBlinkRate o7planning.org
  • Caret.getBlinkRate()
  • DefaultCaret.getBlinkRate()


getBlob

getBlob o7planning.org
  • CallableStatement.getBlob(String)
  • CallableStatement.getBlob(int)
  • ResultSet.getBlob(String)
  • ResultSet.getBlob(int)


getBlockedCount

getBlockedCount o7planning.org
  • ThreadInfo.getBlockedCount()


getBlockedTime

getBlockedTime o7planning.org
  • ThreadInfo.getBlockedTime()


getBlocker

getBlocker o7planning.org
  • LockSupport.getBlocker(Thread)


getBlockIncrement

getBlockIncrement o7planning.org
  • Adjustable.getBlockIncrement()
  • JScrollBar.getBlockIncrement()
  • JScrollBar.getBlockIncrement(int)
  • JScrollPane.ScrollBar.getBlockIncrement(int)
  • ScrollPaneAdjustable.getBlockIncrement()
  • Scrollbar.getBlockIncrement()


getBlockSize

getBlockSize o7planning.org
  • Cipher.getBlockSize()


getBlue

getBlue o7planning.org
  • Color.getBlue()
  • ColorModel.getBlue(Object)
  • ColorModel.getBlue(int)
  • ComponentColorModel.getBlue(Object)
  • ComponentColorModel.getBlue(int)
  • DirectColorModel.getBlue(Object)
  • DirectColorModel.getBlue(int)
  • IndexColorModel.getBlue(int)


getBlueMask

getBlueMask o7planning.org
  • DirectColorModel.getBlueMask()


getBlues

getBlues o7planning.org
  • IndexColorModel.getBlues(byte[])


getBody

getBody o7planning.org
  • CacheRequest.getBody()
  • CacheResponse.getBody()
  • SOAPEnvelope.getBody()


getBoolean

getBoolean o7planning.org
  • AbstractPreferences.getBoolean(String, boolean)
  • Array.getBoolean(Object, int)
  • Boolean.getBoolean(String)
  • CallableStatement.getBoolean(String)
  • CallableStatement.getBoolean(int)
  • Field.getBoolean(Object)
  • Preferences.getBoolean(String, boolean)
  • ResultSet.getBoolean(String)
  • ResultSet.getBoolean(int)
  • SynthStyle.getBoolean(SynthContext, Object, boolean)
  • UIDefaults.getBoolean(Object, Locale)
  • UIDefaults.getBoolean(Object)
  • UIManager.getBoolean(Object, Locale)
  • UIManager.getBoolean(Object)


getBootClassPath

getBootClassPath o7planning.org
  • RuntimeMXBean.getBootClassPath()


getBorder

getBorder o7planning.org
  • BasicSplitPaneDivider.getBorder()
  • DefaultTreeCellEditor.DefaultTextField.getBorder()
  • JComponent.getBorder()
  • TitledBorder.getBorder()
  • UIDefaults.getBorder(Object, Locale)
  • UIDefaults.getBorder(Object)
  • UIManager.getBorder(Object, Locale)
  • UIManager.getBorder(Object)


getBorderColor

getBorderColor o7planning.org
  • BasicToolBarUI.DragWindow.getBorderColor()


getBorderInsets

getBorderInsets o7planning.org
  • AbstractBorder.getBorderInsets(Component, Insets)
  • AbstractBorder.getBorderInsets(Component)
  • BasicBorders.ButtonBorder.getBorderInsets(Component, Insets)
  • BasicBorders.FieldBorder.getBorderInsets(Component, Insets)
  • BasicBorders.MarginBorder.getBorderInsets(Component, Insets)
  • BasicBorders.MenuBarBorder.getBorderInsets(Component, Insets)
  • BasicBorders.RadioButtonBorder.getBorderInsets(Component, Insets)
  • BasicBorders.SplitPaneBorder.getBorderInsets(Component)
  • BasicBorders.ToggleButtonBorder.getBorderInsets(Component, Insets)
  • BevelBorder.getBorderInsets(Component, Insets)
  • Border.getBorderInsets(Component)
  • BorderUIResource.getBorderInsets(Component)
  • CompoundBorder.getBorderInsets(Component, Insets)
  • EmptyBorder.getBorderInsets()
  • EmptyBorder.getBorderInsets(Component, Insets)
  • EtchedBorder.getBorderInsets(Component, Insets)
  • LineBorder.getBorderInsets(Component, Insets)
  • MatteBorder.getBorderInsets()
  • MatteBorder.getBorderInsets(Component, Insets)
  • MetalBorders.ButtonBorder.getBorderInsets(Component, Insets)
  • MetalBorders.Flush3DBorder.getBorderInsets(Component, Insets)
  • MetalBorders.InternalFrameBorder.getBorderInsets(Component, Insets)
  • MetalBorders.MenuBarBorder.getBorderInsets(Component, Insets)
  • MetalBorders.MenuItemBorder.getBorderInsets(Component, Insets)
  • MetalBorders.OptionDialogBorder.getBorderInsets(Component, Insets)
  • MetalBorders.PaletteBorder.getBorderInsets(Component, Insets)
  • MetalBorders.PopupMenuBorder.getBorderInsets(Component, Insets)
  • MetalBorders.ScrollPaneBorder.getBorderInsets(Component, Insets)
  • MetalBorders.TableHeaderBorder.getBorderInsets(Component, Insets)
  • MetalBorders.ToolBarBorder.getBorderInsets(Component, Insets)
  • SoftBevelBorder.getBorderInsets(Component, Insets)
  • StrokeBorder.getBorderInsets(Component, Insets)
  • TitledBorder.getBorderInsets(Component, Insets)


getBorderPainter

getBorderPainter o7planning.org
  • NimbusStyle.getBorderPainter(SynthContext)


getBorderSelectionColor

getBorderSelectionColor o7planning.org
  • DefaultTreeCellEditor.getBorderSelectionColor()
  • DefaultTreeCellRenderer.getBorderSelectionColor()


getBorderTitle

getBorderTitle o7planning.org
  • JComponent.AccessibleJComponent.getBorderTitle(Border)


getBottomComponent

getBottomComponent o7planning.org
  • JSplitPane.getBottomComponent()


getBottomInset

getBottomInset o7planning.org
  • AsyncBoxView.getBottomInset()
  • CompositeView.getBottomInset()


getBottomPanel

getBottomPanel o7planning.org
  • MetalFileChooserUI.getBottomPanel()


getBoundActions

getBoundActions o7planning.org
  • Keymap.getBoundActions()


getBoundedPosition

getBoundedPosition o7planning.org
  • GlyphView.GlyphPainter.getBoundedPosition(GlyphView, int, float, float)


getBoundingBox

getBoundingBox o7planning.org
  • Polygon.getBoundingBox()


getBoundKeyStrokes

getBoundKeyStrokes o7planning.org
  • Keymap.getBoundKeyStrokes()


getBounds2D

getBounds2D o7planning.org
  • AffineTransformOp.getBounds2D(Raster)
  • AffineTransformOp.getBounds2D(BufferedImage)
  • Arc2D.getBounds2D()
  • Area.getBounds2D()
  • BandCombineOp.getBounds2D(Raster)
  • BufferedImageOp.getBounds2D(BufferedImage)
  • ColorConvertOp.getBounds2D(Raster)
  • ColorConvertOp.getBounds2D(BufferedImage)
  • ContextualRenderedImageFactory.getBounds2D(ParameterBlock)
  • ConvolveOp.getBounds2D(Raster)
  • ConvolveOp.getBounds2D(BufferedImage)
  • CubicCurve2D.Double.getBounds2D()
  • CubicCurve2D.Float.getBounds2D()
  • Ellipse2D.Double.getBounds2D()
  • Ellipse2D.Float.getBounds2D()
  • GlyphMetrics.getBounds2D()
  • Line2D.Double.getBounds2D()
  • Line2D.Float.getBounds2D()
  • LookupOp.getBounds2D(Raster)
  • LookupOp.getBounds2D(BufferedImage)
  • Path2D.Double.getBounds2D()
  • Path2D.Float.getBounds2D()
  • Polygon.getBounds2D()
  • QuadCurve2D.Double.getBounds2D()
  • QuadCurve2D.Float.getBounds2D()
  • RasterOp.getBounds2D(Raster)
  • Rectangle.getBounds2D()
  • Rectangle2D.getBounds2D()
  • Rectangle2D.Double.getBounds2D()
  • Rectangle2D.Float.getBounds2D()
  • RescaleOp.getBounds2D(Raster)
  • RescaleOp.getBounds2D(BufferedImage)
  • RoundRectangle2D.Double.getBounds2D()
  • RoundRectangle2D.Float.getBounds2D()
  • Shape.getBounds2D()


getBounds

getBounds o7planning.org
  • AbstractLayoutCache.getBounds(TreePath, Rectangle)
  • AccessibleComponent.getBounds()
  • Area.getBounds()
  • Component.getBounds(Rectangle)
  • Component.getBounds()
  • Component.AccessibleAWTComponent.getBounds()
  • CubicCurve2D.getBounds()
  • FixedHeightLayoutCache.getBounds(TreePath, Rectangle)
  • GraphicAttribute.getBounds()
  • GraphicsConfiguration.getBounds()
  • ImageGraphicAttribute.getBounds()
  • IntersectionType.getBounds()
  • JComponent.getBounds(Rectangle)
  • JList.AccessibleJList.AccessibleJListChild.getBounds()
  • JTable.AccessibleJTable.AccessibleJTableCell.getBounds()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBounds()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getBounds()
  • Line2D.getBounds()
  • List.AccessibleAWTList.AccessibleAWTListChild.getBounds()
  • MenuComponent.AccessibleAWTMenuComponent.getBounds()
  • Path2D.getBounds()
  • Polygon.getBounds()
  • QuadCurve2D.getBounds()
  • Raster.getBounds()
  • Rectangle.getBounds()
  • RectangularShape.getBounds()
  • Shape.getBounds()
  • ShapeGraphicAttribute.getBounds()
  • SplashScreen.getBounds()
  • TextLayout.getBounds()
  • TypeParameterElement.getBounds()
  • TypeVariable.getBounds()
  • VariableHeightLayoutCache.getBounds(TreePath, Rectangle)


getBoundsAt

getBoundsAt o7planning.org
  • JTabbedPane.getBoundsAt(int)


getBoundsForIconOf

getBoundsForIconOf o7planning.org
  • DefaultDesktopManager.getBoundsForIconOf(JInternalFrame)


getBox

getBox o7planning.org
  • BasicProgressBarUI.getBox(Rectangle)
  • SynthProgressBarUI.getBox(Rectangle)


getBoxLength

getBoxLength o7planning.org
  • BasicProgressBarUI.getBoxLength(int, int)


getBoxPainter

getBoxPainter o7planning.org
  • StyleSheet.getBoxPainter(AttributeSet)


getBranchQualifier

getBranchQualifier o7planning.org
  • Xid.getBranchQualifier()


getBreakLocation

getBreakLocation o7planning.org
  • Utilities.getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int)


getBreakWeight

getBreakWeight o7planning.org
  • GlyphView.getBreakWeight(int, float, float)
  • InlineView.getBreakWeight(int, float, float)
  • ParagraphView.getBreakWeight(int, float)
  • View.getBreakWeight(int, float, float)


getBroadcast

getBroadcast o7planning.org
  • DatagramSocket.getBroadcast()
  • InterfaceAddress.getBroadcast()


getBubbles

getBubbles o7planning.org
  • Event.getBubbles()


getBuffer

getBuffer o7planning.org
  • StringWriter.getBuffer()


getBufferCapabilities

getBufferCapabilities o7planning.org
  • GraphicsConfiguration.getBufferCapabilities()


getBufferedImageOp

getBufferedImageOp o7planning.org
  • BufferedImageFilter.getBufferedImageOp()


getBufferedImageType

getBufferedImageType o7planning.org
  • ImageTypeSpecifier.getBufferedImageType()


getBufferSize

getBufferSize o7planning.org
  • DataLine.getBufferSize()


getBufferStrategy

getBufferStrategy o7planning.org
  • Canvas.getBufferStrategy()
  • Window.getBufferStrategy()


getBuilder

getBuilder o7planning.org
  • W3CDomHandler.getBuilder()


getBundle

getBundle o7planning.org
  • ResourceBundle.getBundle(String, Locale, ClassLoader, ResourceBundle.Control)
  • ResourceBundle.getBundle(String, Locale, ClassLoader)
  • ResourceBundle.getBundle(String, Locale, ResourceBundle.Control)
  • ResourceBundle.getBundle(String, Locale)
  • ResourceBundle.getBundle(String, ResourceBundle.Control)
  • ResourceBundle.getBundle(String)


getBusy

getBusy o7planning.org
  • LSParser.getBusy()


getButton

getButton o7planning.org
  • MouseEvent.getButton()
  • MouseEvent.getButton()


getButtonBorder

getButtonBorder o7planning.org
  • BasicBorders.getButtonBorder()
  • MetalBorders.getButtonBorder()


getButtonCount

getButtonCount o7planning.org
  • ButtonGroup.getButtonCount()


getButtonPanel

getButtonPanel o7planning.org
  • MetalFileChooserUI.getButtonPanel()


getButtons

getButtons o7planning.org
  • BasicOptionPaneUI.getButtons()


getButtonWidth

getButtonWidth o7planning.org
  • MetalScrollButton.getButtonWidth()


getByAddress

getByAddress o7planning.org
  • Inet6Address.getByAddress(String, byte[], int)
  • Inet6Address.getByAddress(String, byte[], NetworkInterface)
  • InetAddress.getByAddress(byte[])
  • InetAddress.getByAddress(String, byte[])


getByIndex

getByIndex o7planning.org
  • NetworkInterface.getByIndex(int)


getByInetAddress

getByInetAddress o7planning.org
  • NetworkInterface.getByInetAddress(InetAddress)


getByName

getByName o7planning.org
  • InetAddress.getByName(String)
  • NetworkInterface.getByName(String)


getByte

getByte o7planning.org
  • Array.getByte(Object, int)
  • CallableStatement.getByte(String)
  • CallableStatement.getByte(int)
  • Field.getByte(Object)
  • ResultSet.getByte(String)
  • ResultSet.getByte(int)


getByteArray

getByteArray o7planning.org
  • AbstractPreferences.getByteArray(String, byte[])
  • Preferences.getByteArray(String, byte[])


getByteLength

getByteLength o7planning.org
  • AudioFileFormat.getByteLength()
  • MidiFileFormat.getByteLength()


getByteOffset

getByteOffset o7planning.org
  • DOMLocator.getByteOffset()


getByteOrder

getByteOrder o7planning.org
  • ImageInputStream.getByteOrder()
  • ImageInputStreamImpl.getByteOrder()


getByteParameter

getByteParameter o7planning.org
  • ParameterBlock.getByteParameter(int)


getBytes

getBytes o7planning.org
  • Blob.getBytes(long, int)
  • CallableStatement.getBytes(String)
  • CallableStatement.getBytes(int)
  • ResultSet.getBytes(String)
  • ResultSet.getBytes(int)
  • RowId.getBytes()
  • SerialBlob.getBytes(long, int)
  • String.getBytes()
  • String.getBytes(Charset)
  • String.getBytes(String)
  • String.getBytes(int, int, byte[], int)


getBytesRead

getBytesRead o7planning.org
  • Deflater.getBytesRead()
  • Inflater.getBytesRead()


getByteStream

getByteStream o7planning.org
  • InputSource.getByteStream()
  • LSInput.getByteStream()
  • LSOutput.getByteStream()


getBytesWritten

getBytesWritten o7planning.org
  • Deflater.getBytesWritten()
  • Inflater.getBytesWritten()


getCA

getCA o7planning.org
  • TrustAnchor.getCA()


getCachedIcon

getCachedIcon o7planning.org
  • BasicFileChooserUI.BasicFileView.getCachedIcon(File)


getCacheDirectory

getCacheDirectory o7planning.org
  • ImageIO.getCacheDirectory()


getCachedMBeanInfo

getCachedMBeanInfo o7planning.org
  • StandardMBean.getCachedMBeanInfo()


getCalculatedDigestValue

getCalculatedDigestValue o7planning.org
  • Reference.getCalculatedDigestValue()


getCalendar

getCalendar o7planning.org
  • DateFormat.getCalendar()


getCalendarField

getCalendarField o7planning.org
  • DateFormat.Field.getCalendarField()
  • SpinnerDateModel.getCalendarField()


getCalendarType

getCalendarType o7planning.org
  • Calendar.getCalendarType()
  • Chronology.getCalendarType()
  • GregorianCalendar.getCalendarType()
  • HijrahChronology.getCalendarType()
  • IsoChronology.getCalendarType()
  • JapaneseChronology.getCalendarType()
  • MinguoChronology.getCalendarType()
  • ThaiBuddhistChronology.getCalendarType()


getCallback

getCallback o7planning.org
  • UnsupportedCallbackException.getCallback()


getCallbackHandler

getCallbackHandler o7planning.org
  • KeyStore.CallbackHandlerProtection.getCallbackHandler()


getCAName

getCAName o7planning.org
  • TrustAnchor.getCAName()


getCancelable

getCancelable o7planning.org
  • Event.getCancelable()


getCancelSelectionAction

getCancelSelectionAction o7planning.org
  • BasicFileChooserUI.getCancelSelectionAction()


getCandidateLocales

getCandidateLocales o7planning.org
  • ResourceBundle.Control.getCandidateLocales(String, Locale)


getCanonicalFile

getCanonicalFile o7planning.org
  • File.getCanonicalFile()


getCanonicalHostName

getCanonicalHostName o7planning.org
  • InetAddress.getCanonicalHostName()


getCanonicalizationMethod

getCanonicalizationMethod o7planning.org
  • SignedInfo.getCanonicalizationMethod()


getCanonicalizedData

getCanonicalizedData o7planning.org
  • SignedInfo.getCanonicalizedData()


getCanonicalKeyPropertyListString

getCanonicalKeyPropertyListString o7planning.org
  • ObjectName.getCanonicalKeyPropertyListString()


getCanonicalName

getCanonicalName o7planning.org
  • Class.getCanonicalName()
  • ObjectName.getCanonicalName()


getCanonicalPath

getCanonicalPath o7planning.org
  • File.getCanonicalPath()


getCanWrapLines

getCanWrapLines o7planning.org
  • AbstractWriter.getCanWrapLines()


getCapabilities

getCapabilities o7planning.org
  • BufferStrategy.getCapabilities()
  • Component.BltBufferStrategy.getCapabilities()
  • Component.FlipBufferStrategy.getCapabilities()
  • Image.getCapabilities(GraphicsConfiguration)
  • VolatileImage.getCapabilities()


getCapturedArg

getCapturedArg o7planning.org
  • SerializedLambda.getCapturedArg(int)


getCapturedArgCount

getCapturedArgCount o7planning.org
  • SerializedLambda.getCapturedArgCount()


getCapturingClass

getCapturingClass o7planning.org
  • SerializedLambda.getCapturingClass()


getCAPublicKey

getCAPublicKey o7planning.org
  • TrustAnchor.getCAPublicKey()


getCaret

getCaret o7planning.org
  • InputMethodEvent.getCaret()
  • JTextComponent.getCaret()
  • NavigationFilter.FilterBypass.getCaret()


getCaretColor

getCaretColor o7planning.org
  • JTextComponent.getCaretColor()


getCaretInfo

getCaretInfo o7planning.org
  • TextLayout.getCaretInfo(TextHitInfo)
  • TextLayout.getCaretInfo(TextHitInfo, Rectangle2D)


getCaretListeners

getCaretListeners o7planning.org
  • JTextComponent.getCaretListeners()


getCaretPosition

getCaretPosition o7planning.org
  • AbstractButton.AccessibleAbstractButton.getCaretPosition()
  • AccessibleText.getCaretPosition()
  • JLabel.AccessibleJLabel.getCaretPosition()
  • JSpinner.AccessibleJSpinner.getCaretPosition()
  • JTextComponent.getCaretPosition()
  • JTextComponent.AccessibleJTextComponent.getCaretPosition()
  • ProgressMonitor.AccessibleProgressMonitor.getCaretPosition()
  • TextComponent.getCaretPosition()
  • TextComponent.AccessibleAWTTextComponent.getCaretPosition()


getCaretShape

getCaretShape o7planning.org
  • TextLayout.getCaretShape(TextHitInfo)
  • TextLayout.getCaretShape(TextHitInfo, Rectangle2D)


getCaretShapes

getCaretShapes o7planning.org
  • TextLayout.getCaretShapes(int)
  • TextLayout.getCaretShapes(int, Rectangle2D)
  • TextLayout.getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy)


getCatalog

getCatalog o7planning.org
  • Connection.getCatalog()


getCatalogName

getCatalogName o7planning.org
  • ResultSetMetaData.getCatalogName(int)
  • RowSetMetaDataImpl.getCatalogName(int)


getCatalogs

getCatalogs o7planning.org
  • DatabaseMetaData.getCatalogs()


getCatalogSeparator

getCatalogSeparator o7planning.org
  • DatabaseMetaData.getCatalogSeparator()


getCatalogTerm

getCatalogTerm o7planning.org
  • DatabaseMetaData.getCatalogTerm()


getCategories

getCategories o7planning.org
  • ServiceRegistry.getCategories()


getCategory

getCategory o7planning.org
  • Attribute.getCategory()
  • Chromaticity.getCategory()
  • ColorSupported.getCategory()
  • Compression.getCategory()
  • Copies.getCategory()
  • CopiesSupported.getCategory()
  • DateTimeAtCompleted.getCategory()
  • DateTimeAtCreation.getCategory()
  • DateTimeAtProcessing.getCategory()
  • Destination.getCategory()
  • DialogTypeSelection.getCategory()
  • DocumentName.getCategory()
  • Fidelity.getCategory()
  • Finishings.getCategory()
  • JobHoldUntil.getCategory()
  • JobImpressions.getCategory()
  • JobImpressionsCompleted.getCategory()
  • JobImpressionsSupported.getCategory()
  • JobKOctets.getCategory()
  • JobKOctetsProcessed.getCategory()
  • JobKOctetsSupported.getCategory()
  • JobMediaSheets.getCategory()
  • JobMediaSheetsCompleted.getCategory()
  • JobMediaSheetsSupported.getCategory()
  • JobMessageFromOperator.getCategory()
  • JobName.getCategory()
  • JobOriginatingUserName.getCategory()
  • JobPriority.getCategory()
  • JobPrioritySupported.getCategory()
  • JobSheets.getCategory()
  • JobState.getCategory()
  • JobStateReason.getCategory()
  • JobStateReasons.getCategory()
  • Media.getCategory()
  • MediaPrintableArea.getCategory()
  • MediaSize.getCategory()
  • MultipleDocumentHandling.getCategory()
  • NumberOfDocuments.getCategory()
  • NumberOfInterveningJobs.getCategory()
  • NumberUp.getCategory()
  • NumberUpSupported.getCategory()
  • OrientationRequested.getCategory()
  • OutputDeviceAssigned.getCategory()
  • PDLOverrideSupported.getCategory()
  • PageRanges.getCategory()
  • PagesPerMinute.getCategory()
  • PagesPerMinuteColor.getCategory()
  • PresentationDirection.getCategory()
  • PrintQuality.getCategory()
  • PrinterInfo.getCategory()
  • PrinterIsAcceptingJobs.getCategory()
  • PrinterLocation.getCategory()
  • PrinterMakeAndModel.getCategory()
  • PrinterMessageFromOperator.getCategory()
  • PrinterMoreInfo.getCategory()
  • PrinterMoreInfoManufacturer.getCategory()
  • PrinterName.getCategory()
  • PrinterResolution.getCategory()
  • PrinterState.getCategory()
  • PrinterStateReason.getCategory()
  • PrinterStateReasons.getCategory()
  • PrinterURI.getCategory()
  • QueuedJobCount.getCategory()
  • ReferenceUriSchemesSupported.getCategory()
  • RequestingUserName.getCategory()
  • Severity.getCategory()
  • SheetCollate.getCategory()
  • Sides.getCategory()


getCause

getCause o7planning.org
  • ActivationException.getCause()
  • ClassNotFoundException.getCause()
  • DirectoryIteratorException.getCause()
  • ExceptionInInitializerError.getCause()
  • FactoryConfigurationError.getCause()
  • FactoryConfigurationError.getCause()
  • InvocationTargetException.getCause()
  • JAXBException.getCause()
  • JMXProviderException.getCause()
  • JMXServerErrorException.getCause()
  • KeySelectorException.getCause()
  • MBeanException.getCause()
  • MarshalException.getCause()
  • NamingException.getCause()
  • NoSuchMechanismException.getCause()
  • PrinterIOException.getCause()
  • PrivilegedActionException.getCause()
  • ReflectionException.getCause()
  • RemoteException.getCause()
  • RuntimeErrorException.getCause()
  • RuntimeMBeanException.getCause()
  • RuntimeOperationsException.getCause()
  • SAXException.getCause()
  • SOAPException.getCause()
  • SaslException.getCause()
  • ServerCloneException.getCause()
  • Throwable.getCause()
  • TransformException.getCause()
  • TransformerException.getCause()
  • TransformerFactoryConfigurationError.getCause()
  • URIReferenceException.getCause()
  • UncheckedIOException.getCause()
  • UndeclaredThrowableException.getCause()
  • WriteAbortedException.getCause()
  • XMLSignatureException.getCause()
  • XPathException.getCause()


getCellBounds

getCellBounds o7planning.org
  • BasicListUI.getCellBounds(JList, int, int)
  • JList.getCellBounds(int, int)
  • ListUI.getCellBounds(JList, int, int)
  • MultiListUI.getCellBounds(JList, int, int)


getCellEditor

getCellEditor o7planning.org
  • BasicTreeUI.getCellEditor()
  • JTable.getCellEditor(int, int)
  • JTable.getCellEditor()
  • JTree.getCellEditor()
  • TableColumn.getCellEditor()


getCellEditorListeners

getCellEditorListeners o7planning.org
  • AbstractCellEditor.getCellEditorListeners()
  • DefaultTreeCellEditor.getCellEditorListeners()


getCellEditorValue

getCellEditorValue o7planning.org
  • CellEditor.getCellEditorValue()
  • DefaultCellEditor.getCellEditorValue()
  • DefaultCellEditor.EditorDelegate.getCellEditorValue()
  • DefaultTreeCellEditor.getCellEditorValue()


getCellLength

getCellLength o7planning.org
  • BasicProgressBarUI.getCellLength()


getCellRect

getCellRect o7planning.org
  • JTable.getCellRect(int, int, boolean)


getCellRenderer

getCellRenderer o7planning.org
  • BasicTreeUI.getCellRenderer()
  • JList.getCellRenderer()
  • JTable.getCellRenderer(int, int)
  • JTree.getCellRenderer()
  • TableColumn.getCellRenderer()


getCellSelectionEnabled

getCellSelectionEnabled o7planning.org
  • JTable.getCellSelectionEnabled()


getCellSpacing

getCellSpacing o7planning.org
  • BasicProgressBarUI.getCellSpacing()


getCenterPoint

getCenterPoint o7planning.org
  • GraphicsEnvironment.getCenterPoint()
  • RadialGradientPaint.getCenterPoint()


getCentersChildren

getCentersChildren o7planning.org
  • BasicOptionPaneUI.ButtonAreaLayout.getCentersChildren()


getCenterX

getCenterX o7planning.org
  • RectangularShape.getCenterX()


getCenterY

getCenterY o7planning.org
  • RectangularShape.getCenterY()


getCertificate

getCertificate o7planning.org
  • KeyStore.getCertificate(String)
  • KeyStore.PrivateKeyEntry.getCertificate()
  • X500PrivateCredential.getCertificate()
  • X509CertSelector.getCertificate()


getCertificateAlias

getCertificateAlias o7planning.org
  • KeyStore.getCertificateAlias(Certificate)


getCertificateChain

getCertificateChain o7planning.org
  • KeyStore.getCertificateChain(String)
  • KeyStore.PrivateKeyEntry.getCertificateChain()
  • X509KeyManager.getCertificateChain(String)


getCertificateChecking

getCertificateChecking o7planning.org
  • X509CRLSelector.getCertificateChecking()


getCertificateIssuer

getCertificateIssuer o7planning.org
  • X509CRLEntry.getCertificateIssuer()


getCertificates

getCertificates o7planning.org
  • CertPath.getCertificates()
  • CertStore.getCertificates(CertSelector)
  • CodeSource.getCertificates()
  • JarEntry.getCertificates()
  • JarURLConnection.getCertificates()


getCertificateValid

getCertificateValid o7planning.org
  • X509CertSelector.getCertificateValid()


getCertifiedText

getCertifiedText o7planning.org
  • LSInput.getCertifiedText()


getCertPath

getCertPath o7planning.org
  • CertPathBuilderResult.getCertPath()
  • CertPathValidatorException.getCertPath()
  • PKIXCertPathBuilderResult.getCertPath()


getCertPathCheckers

getCertPathCheckers o7planning.org
  • PKIXParameters.getCertPathCheckers()


getCertPathEncodings

getCertPathEncodings o7planning.org
  • CertificateFactory.getCertPathEncodings()


getCertStoreParameters

getCertStoreParameters o7planning.org
  • CertStore.getCertStoreParameters()


getCertStores

getCertStores o7planning.org
  • PKIXParameters.getCertStores()


getChange

getChange o7planning.org
  • AbstractDocument.DefaultDocumentEvent.getChange(Element)
  • DocumentEvent.getChange(Element)


getChanged

getChanged o7planning.org
  • HierarchyEvent.getChanged()


getChangedParent

getChangedParent o7planning.org
  • HierarchyEvent.getChangedParent()


getChangeFlags

getChangeFlags o7planning.org
  • HierarchyEvent.getChangeFlags()


getChangeInfo

getChangeInfo o7planning.org
  • NamingEvent.getChangeInfo()


getChangeListeners

getChangeListeners o7planning.org
  • AbstractButton.getChangeListeners()
  • AbstractSpinnerModel.getChangeListeners()
  • DefaultBoundedRangeModel.getChangeListeners()
  • DefaultButtonModel.getChangeListeners()
  • DefaultCaret.getChangeListeners()
  • DefaultColorSelectionModel.getChangeListeners()
  • DefaultSingleSelectionModel.getChangeListeners()
  • JProgressBar.getChangeListeners()
  • JSlider.getChangeListeners()
  • JSpinner.getChangeListeners()
  • JTabbedPane.getChangeListeners()
  • JViewport.getChangeListeners()
  • MenuSelectionManager.getChangeListeners()
  • StyleContext.getChangeListeners()
  • StyleContext.NamedStyle.getChangeListeners()


getChangeToParentDirectoryAction

getChangeToParentDirectoryAction o7planning.org
  • BasicFileChooserUI.getChangeToParentDirectoryAction()


getChannel

getChannel o7planning.org
  • DatagramSocket.getChannel()
  • FileInputStream.getChannel()
  • FileOutputStream.getChannel()
  • RandomAccessFile.getChannel()
  • ServerSocket.getChannel()
  • ShortMessage.getChannel()
  • Socket.getChannel()


getChannelPressure

getChannelPressure o7planning.org
  • MidiChannel.getChannelPressure()


getChannels

getChannels o7planning.org
  • AudioFormat.getChannels()
  • Synthesizer.getChannels()


getChar

getChar o7planning.org
  • Array.getChar(Object, int)
  • ByteBuffer.getChar(int)
  • ByteBuffer.getChar()
  • Field.getChar(Object)


getCharacterAttribute

getCharacterAttribute o7planning.org
  • AbstractButton.AccessibleAbstractButton.getCharacterAttribute(int)
  • AccessibleText.getCharacterAttribute(int)
  • JLabel.AccessibleJLabel.getCharacterAttribute(int)
  • JSpinner.AccessibleJSpinner.getCharacterAttribute(int)
  • JTextComponent.AccessibleJTextComponent.getCharacterAttribute(int)
  • ProgressMonitor.AccessibleProgressMonitor.getCharacterAttribute(int)
  • TextComponent.AccessibleAWTTextComponent.getCharacterAttribute(int)


getCharacterAttributeRun

getCharacterAttributeRun o7planning.org
  • StyledEditorKit.getCharacterAttributeRun()


getCharacterAttributes

getCharacterAttributes o7planning.org
  • JTextPane.getCharacterAttributes()


getCharacterBounds

getCharacterBounds o7planning.org
  • AbstractButton.AccessibleAbstractButton.getCharacterBounds(int)
  • AccessibleText.getCharacterBounds(int)
  • JLabel.AccessibleJLabel.getCharacterBounds(int)
  • JSpinner.AccessibleJSpinner.getCharacterBounds(int)
  • JTextComponent.AccessibleJTextComponent.getCharacterBounds(int)
  • ProgressMonitor.AccessibleProgressMonitor.getCharacterBounds(int)
  • TextComponent.AccessibleAWTTextComponent.getCharacterBounds(int)


getCharacterCount

getCharacterCount o7planning.org
  • TextLayout.getCharacterCount()


getCharacterElement

getCharacterElement o7planning.org
  • DefaultStyledDocument.getCharacterElement(int)
  • StyledDocument.getCharacterElement(int)


getCharacterEncodingScheme

getCharacterEncodingScheme o7planning.org
  • StartDocument.getCharacterEncodingScheme()
  • StreamReaderDelegate.getCharacterEncodingScheme()
  • XMLStreamReader.getCharacterEncodingScheme()


getCharacterInstance

getCharacterInstance o7planning.org
  • BreakIterator.getCharacterInstance(Locale)
  • BreakIterator.getCharacterInstance()
  • BreakIteratorProvider.getCharacterInstance(Locale)


getCharacterLevel

getCharacterLevel o7planning.org
  • TextLayout.getCharacterLevel(int)


getCharacterOffset

getCharacterOffset o7planning.org
  • Location.getCharacterOffset()


getCharacterStream

getCharacterStream o7planning.org
  • CallableStatement.getCharacterStream(String)
  • CallableStatement.getCharacterStream(int)
  • Clob.getCharacterStream(long, long)
  • Clob.getCharacterStream()
  • InputSource.getCharacterStream()
  • LSInput.getCharacterStream()
  • LSOutput.getCharacterStream()
  • ResultSet.getCharacterStream(String)
  • ResultSet.getCharacterStream(int)
  • SQLXML.getCharacterStream()
  • SerialClob.getCharacterStream(long, long)
  • SerialClob.getCharacterStream()


getCharContent

getCharContent o7planning.org
  • FileObject.getCharContent(boolean)
  • ForwardingFileObject.getCharContent(boolean)
  • SimpleJavaFileObject.getCharContent(boolean)


getCharCount

getCharCount o7planning.org
  • AbstractButton.AccessibleAbstractButton.getCharCount()
  • AccessibleText.getCharCount()
  • JLabel.AccessibleJLabel.getCharCount()
  • JSpinner.AccessibleJSpinner.getCharCount()
  • JTextComponent.AccessibleJTextComponent.getCharCount()
  • ProgressMonitor.AccessibleProgressMonitor.getCharCount()
  • TextComponent.AccessibleAWTTextComponent.getCharCount()


getCharIndex

getCharIndex o7planning.org
  • TextHitInfo.getCharIndex()


getCharParameter

getCharParameter o7planning.org
  • ParameterBlock.getCharParameter(int)


getChars

getChars o7planning.org
  • AbstractDocument.Content.getChars(int, int, Segment)
  • GapContent.getChars(int, int, Segment)
  • String.getChars(int, int, char[], int)
  • StringBuffer.getChars(int, int, char[], int)
  • StringContent.getChars(int, int, Segment)


getCharsetName

getCharsetName o7planning.org
  • IllegalCharsetNameException.getCharsetName()
  • UnsupportedCharsetException.getCharsetName()


getCharSetSpec

getCharSetSpec o7planning.org
  • ChangedCharSetException.getCharSetSpec()


getCheckboxGroup

getCheckboxGroup o7planning.org
  • Checkbox.getCheckboxGroup()


getCheckBoxIcon

getCheckBoxIcon o7planning.org
  • BasicIconFactory.getCheckBoxIcon()
  • MetalIconFactory.getCheckBoxIcon()


getCheckBoxMenuItemIcon

getCheckBoxMenuItemIcon o7planning.org
  • BasicIconFactory.getCheckBoxMenuItemIcon()
  • MetalIconFactory.getCheckBoxMenuItemIcon()


getChecksum

getChecksum o7planning.org
  • CheckedInputStream.getChecksum()
  • CheckedOutputStream.getChecksum()


getChild

getChild o7planning.org
  • AbstractPreferences.getChild(String)
  • ContainerEvent.getChild()
  • DefaultTreeModel.getChild(Object, int)
  • FileSystemView.getChild(File, String)
  • NodeChangeEvent.getChild()
  • TreeModel.getChild(Object, int)


getChildAfter

getChildAfter o7planning.org
  • DefaultMutableTreeNode.getChildAfter(TreeNode)


getChildAllocation

getChildAllocation o7planning.org
  • AsyncBoxView.getChildAllocation(int, Shape)
  • AsyncBoxView.ChildLocator.getChildAllocation(int)
  • AsyncBoxView.ChildLocator.getChildAllocation(int, Shape)
  • BoxView.getChildAllocation(int, Shape)
  • CompositeView.getChildAllocation(int, Shape)
  • View.getChildAllocation(int, Shape)


getChildAt

getChildAt o7planning.org
  • AbstractDocument.AbstractElement.getChildAt(int)
  • DefaultMutableTreeNode.getChildAt(int)
  • JTree.DynamicUtilTreeNode.getChildAt(int)
  • TreeNode.getChildAt(int)


getChildBeanContextChild

getChildBeanContextChild o7planning.org
  • BeanContextSupport.getChildBeanContextChild(Object)


getChildBeanContextMembershipListener

getChildBeanContextMembershipListener o7planning.org
  • BeanContextSupport.getChildBeanContextMembershipListener(Object)


getChildBeanContextServicesListener

getChildBeanContextServicesListener o7planning.org
  • BeanContextServicesSupport.getChildBeanContextServicesListener(Object)


getChildBefore

getChildBefore o7planning.org
  • DefaultMutableTreeNode.getChildBefore(TreeNode)


getChildCount

getChildCount o7planning.org
  • AbstractDocument.AbstractElement.getChildCount()
  • DefaultMutableTreeNode.getChildCount()
  • DefaultTreeModel.getChildCount(Object)
  • JTree.DynamicUtilTreeNode.getChildCount()
  • TreeModel.getChildCount(Object)
  • TreeNode.getChildCount()


getChildElements

getChildElements o7planning.org
  • SOAPElement.getChildElements(QName)
  • SOAPElement.getChildElements(Name)
  • SOAPElement.getChildElements()


getChildIndex

getChildIndex o7planning.org
  • JTree.DropLocation.getChildIndex()


getChildIndices

getChildIndices o7planning.org
  • TreeModelEvent.getChildIndices()


getChildNames

getChildNames o7planning.org
  • IIOMetadataFormat.getChildNames(String)
  • IIOMetadataFormatImpl.getChildNames(String)


getChildNodes

getChildNodes o7planning.org
  • IIOMetadataNode.getChildNodes()
  • Node.getChildNodes()


getChildPolicy

getChildPolicy o7planning.org
  • IIOMetadataFormat.getChildPolicy(String)
  • IIOMetadataFormatImpl.getChildPolicy(String)


getChildPropertyChangeListener

getChildPropertyChangeListener o7planning.org
  • BeanContextSupport.getChildPropertyChangeListener(Object)


getChildren

getChildren o7planning.org
  • PolicyNode.getChildren()
  • TreeModelEvent.getChildren()


getChildrenAdded

getChildrenAdded o7planning.org
  • AbstractDocument.ElementEdit.getChildrenAdded()
  • DocumentEvent.ElementChange.getChildrenAdded()


getChildrenRemoved

getChildrenRemoved o7planning.org
  • AbstractDocument.ElementEdit.getChildrenRemoved()
  • DocumentEvent.ElementChange.getChildrenRemoved()


getChildSerializable

getChildSerializable o7planning.org
  • BeanContextSupport.getChildSerializable(Object)


getChildState

getChildState o7planning.org
  • AsyncBoxView.getChildState(int)


getChildVetoableChangeListener

getChildVetoableChangeListener o7planning.org
  • BeanContextSupport.getChildVetoableChangeListener(Object)


getChildView

getChildView o7planning.org
  • AsyncBoxView.ChildState.getChildView()


getChildVisibility

getChildVisibility o7planning.org
  • BeanContextSupport.getChildVisibility(Object)


getChoices

getChoices o7planning.org
  • ChoiceCallback.getChoices()


getChoosableFileFilters

getChoosableFileFilters o7planning.org
  • JFileChooser.getChoosableFileFilters()


getChooserPanels

getChooserPanels o7planning.org
  • JColorChooser.getChooserPanels()


getChronology

getChronology o7planning.org
  • ChronoLocalDate.getChronology()
  • ChronoLocalDateTime.getChronology()
  • ChronoPeriod.getChronology()
  • ChronoZonedDateTime.getChronology()
  • DateTimeFormatter.getChronology()
  • HijrahDate.getChronology()
  • JapaneseDate.getChronology()
  • LocalDate.getChronology()
  • MinguoDate.getChronology()
  • Period.getChronology()
  • ThaiBuddhistDate.getChronology()


getCipherSuite

getCipherSuite o7planning.org
  • HandshakeCompletedEvent.getCipherSuite()
  • HttpsURLConnection.getCipherSuite()
  • SSLSession.getCipherSuite()
  • SecureCacheResponse.getCipherSuite()


getCipherSuites

getCipherSuites o7planning.org
  • SSLParameters.getCipherSuites()


getClass

getClass o7planning.org
  • Object.getClass()


getClassAnnotation

getClassAnnotation o7planning.org
  • RMIClassLoader.getClassAnnotation(Class<?>)
  • RMIClassLoaderSpi.getClassAnnotation(Class<?>)


getClassContext

getClassContext o7planning.org
  • SecurityManager.getClassContext()


getClasses

getClasses o7planning.org
  • Class.getClasses()


getClassLoader

getClassLoader o7planning.org
  • Class.getClassLoader()
  • ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location)
  • JavaFileManager.getClassLoader(JavaFileManager.Location)
  • MBeanServer.getClassLoader(ObjectName)
  • ProtectionDomain.getClassLoader()
  • RMIClassLoader.getClassLoader(String)
  • RMIClassLoaderSpi.getClassLoader(String)


getClassLoaderFor

getClassLoaderFor o7planning.org
  • MBeanServer.getClassLoaderFor(ObjectName)


getClassLoaderRepository

getClassLoaderRepository o7planning.org
  • MBeanServer.getClassLoaderRepository()
  • MBeanServerFactory.getClassLoaderRepository(MBeanServer)
  • RequiredModelMBean.getClassLoaderRepository()


getClassLoadingLock

getClassLoadingLock o7planning.org
  • ClassLoader.getClassLoadingLock(String)


getClassLoadingMXBean

getClassLoadingMXBean o7planning.org
  • ManagementFactory.getClassLoadingMXBean()


getClassName

getClassName o7planning.org
  • ActivationDesc.getClassName()
  • ActivationGroupDesc.getClassName()
  • Binding.getClassName()
  • LockInfo.getClassName()
  • MBeanInfo.getClassName()
  • MissingResourceException.getClassName()
  • ModelMBeanInfo.getClassName()
  • NameClassPair.getClassName()
  • ObjectInstance.getClassName()
  • OpenMBeanInfo.getClassName()
  • OpenType.getClassName()
  • Provider.Service.getClassName()
  • Reference.getClassName()
  • StackTraceElement.getClassName()
  • StandardMBean.getClassName(MBeanInfo)
  • UIManager.LookAndFeelInfo.getClassName()


getClassPath

getClassPath o7planning.org
  • RuntimeMXBean.getClassPath()


getClickCount

getClickCount o7planning.org
  • MouseEvent.getClickCount()


getClickCountToStart

getClickCountToStart o7planning.org
  • DefaultCellEditor.getClickCountToStart()


getClient

getClient o7planning.org
  • KerberosTicket.getClient()


getClientAddresses

getClientAddresses o7planning.org
  • KerberosTicket.getClientAddresses()


getClientAliases

getClientAliases o7planning.org
  • X509KeyManager.getClientAliases(String, Principal[])


getClientHost

getClientHost o7planning.org
  • RemoteServer.getClientHost()
  • ServerRef.getClientHost()


getClientInfo

getClientInfo o7planning.org
  • Connection.getClientInfo()
  • Connection.getClientInfo(String)


getClientInfoProperties

getClientInfoProperties o7planning.org
  • DatabaseMetaData.getClientInfoProperties()


getClientProperty

getClientProperty o7planning.org
  • JComponent.getClientProperty(Object)


getClientSessionContext

getClientSessionContext o7planning.org
  • SSLContext.getClientSessionContext()


getClientX

getClientX o7planning.org
  • MouseEvent.getClientX()


getClientY

getClientY o7planning.org
  • MouseEvent.getClientY()


getClip

getClip o7planning.org
  • AudioSystem.getClip(Mixer.Info)
  • AudioSystem.getClip()
  • DebugGraphics.getClip()
  • Graphics.getClip()


getClipBounds

getClipBounds o7planning.org
  • DebugGraphics.getClipBounds()
  • Graphics.getClipBounds(Rectangle)
  • Graphics.getClipBounds()


getClipRect

getClipRect o7planning.org
  • Graphics.getClipRect()


getClob

getClob o7planning.org
  • CallableStatement.getClob(String)
  • CallableStatement.getClob(int)
  • ResultSet.getClob(String)
  • ResultSet.getClob(int)


getClosedIcon

getClosedIcon o7planning.org
  • DefaultTreeCellRenderer.getClosedIcon()


getClosestPathForLocation

getClosestPathForLocation o7planning.org
  • BasicTreeUI.getClosestPathForLocation(JTree, int, int)
  • JTree.getClosestPathForLocation(int, int)
  • MultiTreeUI.getClosestPathForLocation(JTree, int, int)
  • TreeUI.getClosestPathForLocation(JTree, int, int)


getClosestPositionTo

getClosestPositionTo o7planning.org
  • ParagraphView.getClosestPositionTo(int, Position.Bias, Shape, int, Position.Bias[], int, int)


getClosestRowForLocation

getClosestRowForLocation o7planning.org
  • JTree.getClosestRowForLocation(int, int)


getCode

getCode o7planning.org
  • Diagnostic.getCode()
  • MLetContent.getCode()


getCodeBase

getCodeBase o7planning.org
  • Applet.getCodeBase()
  • AppletStub.getCodeBase()
  • MLetContent.getCodeBase()


getCodebase

getCodebase o7planning.org
  • Util.getCodebase(Class)
  • UtilDelegate.getCodebase(Class)


getCodePoint

getCodePoint o7planning.org
  • IllegalFormatCodePointException.getCodePoint()


getCodeSigners

getCodeSigners o7planning.org
  • CodeSource.getCodeSigners()
  • JarEntry.getCodeSigners()


getCodeSource

getCodeSource o7planning.org
  • ProtectionDomain.getCodeSource()


getCofactor

getCofactor o7planning.org
  • ECParameterSpec.getCofactor()


getCollapsedIcon

getCollapsedIcon o7planning.org
  • BasicTreeUI.getCollapsedIcon()


getCollationElementIterator

getCollationElementIterator o7planning.org
  • RuleBasedCollator.getCollationElementIterator(CharacterIterator)
  • RuleBasedCollator.getCollationElementIterator(String)


getCollationKey

getCollationKey o7planning.org
  • Collator.getCollationKey(String)
  • RuleBasedCollator.getCollationKey(String)


getCollection

getCollection o7planning.org
  • CollectionCertStoreParameters.getCollection()


getCollectionCount

getCollectionCount o7planning.org
  • GarbageCollectorMXBean.getCollectionCount()


getCollectionTime

getCollectionTime o7planning.org
  • GarbageCollectorMXBean.getCollectionTime()


getCollectionUsage

getCollectionUsage o7planning.org
  • MemoryPoolMXBean.getCollectionUsage()


getCollectionUsageThreshold

getCollectionUsageThreshold o7planning.org
  • MemoryPoolMXBean.getCollectionUsageThreshold()


getCollectionUsageThresholdCount

getCollectionUsageThresholdCount o7planning.org
  • MemoryPoolMXBean.getCollectionUsageThresholdCount()


getColor1

getColor1 o7planning.org
  • GradientPaint.getColor1()


getColor2

getColor2 o7planning.org
  • GradientPaint.getColor2()


getColor

getColor o7planning.org
  • Color.getColor(String, int)
  • Color.getColor(String, Color)
  • Color.getColor(String)
  • DebugGraphics.getColor()
  • DefaultHighlighter.DefaultHighlightPainter.getColor()
  • Graphics.getColor()
  • JColorChooser.getColor()
  • PageAttributes.getColor()
  • SynthStyle.getColor(SynthContext, ColorType)
  • UIDefaults.getColor(Object, Locale)
  • UIDefaults.getColor(Object)
  • UIManager.getColor(Object, Locale)
  • UIManager.getColor(Object)


getColorComponents

getColorComponents o7planning.org
  • Color.getColorComponents(ColorSpace, float[])
  • Color.getColorComponents(float[])


getColorForGap

getColorForGap o7planning.org
  • MetalTabbedPaneUI.getColorForGap(int, int, int)


getColorForState

getColorForState o7planning.org
  • NimbusStyle.getColorForState(SynthContext, ColorType)
  • SynthStyle.getColorForState(SynthContext, ColorType)


getColorFromModel

getColorFromModel o7planning.org
  • AbstractColorChooserPanel.getColorFromModel()


getColorModel

getColorModel o7planning.org
  • BufferedImage.getColorModel()
  • Component.getColorModel()
  • GraphicsConfiguration.getColorModel(int)
  • GraphicsConfiguration.getColorModel()
  • ImageTypeSpecifier.getColorModel()
  • PaintContext.getColorModel()
  • PixelGrabber.getColorModel()
  • RenderedImage.getColorModel()
  • Toolkit.getColorModel()


getColors

getColors o7planning.org
  • MultipleGradientPaint.getColors()


getColorSelectionModel

getColorSelectionModel o7planning.org
  • AbstractColorChooserPanel.getColorSelectionModel()


getColorSpace

getColorSpace o7planning.org
  • Color.getColorSpace()
  • ColorModel.getColorSpace()
  • MultipleGradientPaint.getColorSpace()


getColorSpaceType

getColorSpaceType o7planning.org
  • ICC_Profile.getColorSpaceType()


getColumn

getColumn o7planning.org
  • DefaultTableColumnModel.getColumn(int)
  • JTable.getColumn(Object)
  • JTable.DropLocation.getColumn()
  • RowSorter.SortKey.getColumn()
  • TableColumnModel.getColumn(int)
  • TableModelEvent.getColumn()


getColumnClass

getColumnClass o7planning.org
  • AbstractTableModel.getColumnClass(int)
  • JTable.getColumnClass(int)
  • TableModel.getColumnClass(int)


getColumnClassName

getColumnClassName o7planning.org
  • ResultSetMetaData.getColumnClassName(int)
  • RowSetMetaDataImpl.getColumnClassName(int)


getColumnCount

getColumnCount o7planning.org
  • DefaultRowSorter.ModelWrapper.getColumnCount()
  • DefaultTableColumnModel.getColumnCount()
  • DefaultTableModel.getColumnCount()
  • JTable.getColumnCount()
  • ResultSetMetaData.getColumnCount()
  • RowSetMetaDataImpl.getColumnCount()
  • TableColumnModel.getColumnCount()
  • TableModel.getColumnCount()
  • TableView.TableCell.getColumnCount()


getColumnDisplaySize

getColumnDisplaySize o7planning.org
  • ResultSetMetaData.getColumnDisplaySize(int)
  • RowSetMetaDataImpl.getColumnDisplaySize(int)


getColumnHeader

getColumnHeader o7planning.org
  • JScrollPane.getColumnHeader()
  • ScrollPaneLayout.getColumnHeader()


getColumnIndex

getColumnIndex o7planning.org
  • DefaultTableColumnModel.getColumnIndex(Object)
  • TableColumnModel.getColumnIndex(Object)


getColumnIndexAtX

getColumnIndexAtX o7planning.org
  • DefaultTableColumnModel.getColumnIndexAtX(int)
  • TableColumnModel.getColumnIndexAtX(int)


getColumnLabel

getColumnLabel o7planning.org
  • ResultSetMetaData.getColumnLabel(int)
  • RowSetMetaDataImpl.getColumnLabel(int)


getColumnMargin

getColumnMargin o7planning.org
  • DefaultTableColumnModel.getColumnMargin()
  • TableColumnModel.getColumnMargin()


getColumnModel

getColumnModel o7planning.org
  • JTable.getColumnModel()
  • JTableHeader.getColumnModel()


getColumnModelListeners

getColumnModelListeners o7planning.org
  • DefaultTableColumnModel.getColumnModelListeners()


getColumnName

getColumnName o7planning.org
  • AbstractTableModel.getColumnName(int)
  • DefaultTableModel.getColumnName(int)
  • JTable.getColumnName(int)
  • ResultSetMetaData.getColumnName(int)
  • RowSetMetaDataImpl.getColumnName(int)
  • TableModel.getColumnName(int)


getColumnNumber

getColumnNumber o7planning.org
  • DOMLocator.getColumnNumber()
  • Diagnostic.getColumnNumber()
  • Location.getColumnNumber()
  • Locator.getColumnNumber()
  • LocatorImpl.getColumnNumber()
  • SAXParseException.getColumnNumber()
  • ScriptException.getColumnNumber()
  • SourceLocator.getColumnNumber()
  • ValidationEventLocator.getColumnNumber()
  • ValidationEventLocatorImpl.getColumnNumber()


getColumnPrivileges

getColumnPrivileges o7planning.org
  • DatabaseMetaData.getColumnPrivileges(String, String, String, String)


getColumns

getColumns o7planning.org
  • DatabaseMetaData.getColumns(String, String, String, String)
  • DefaultTableColumnModel.getColumns()
  • GridLayout.getColumns()
  • JTextArea.getColumns()
  • JTextField.getColumns()
  • TableColumnModel.getColumns()
  • TextArea.getColumns()
  • TextField.getColumns()


getColumnSelectionAllowed

getColumnSelectionAllowed o7planning.org
  • DefaultTableColumnModel.getColumnSelectionAllowed()
  • JTable.getColumnSelectionAllowed()
  • TableColumnModel.getColumnSelectionAllowed()


getColumnType

getColumnType o7planning.org
  • ResultSetMetaData.getColumnType(int)
  • RowSetMetaDataImpl.getColumnType(int)


getColumnTypeName

getColumnTypeName o7planning.org
  • ResultSetMetaData.getColumnTypeName(int)
  • RowSetMetaDataImpl.getColumnTypeName(int)


getColumnWidth

getColumnWidth o7planning.org
  • JTextArea.getColumnWidth()
  • JTextField.getColumnWidth()


getComboBox

getComboBox o7planning.org
  • MetalComboBoxButton.getComboBox()


getComboIcon

getComboIcon o7planning.org
  • MetalComboBoxButton.getComboIcon()


getCommand

getCommand o7planning.org
  • BaseRowSet.getCommand()
  • CommandMap.getCommand(String, String, DataSource)
  • CommandMap.getCommand(String, String)
  • DataHandler.getCommand(String)
  • MailcapCommandMap.getCommand(String, String)
  • RowSet.getCommand()
  • ShortMessage.getCommand()


getCommandClass

getCommandClass o7planning.org
  • CommandInfo.getCommandClass()


getCommandEnvironment

getCommandEnvironment o7planning.org
  • ActivationGroupDesc.getCommandEnvironment()


getCommandName

getCommandName o7planning.org
  • CommandInfo.getCommandName()


getCommandObject

getCommandObject o7planning.org
  • CommandInfo.getCommandObject(DataHandler, ClassLoader)


getCommandOptions

getCommandOptions o7planning.org
  • ActivationGroupDesc.CommandEnvironment.getCommandOptions()


getCommandPath

getCommandPath o7planning.org
  • ActivationGroupDesc.CommandEnvironment.getCommandPath()


getComment

getComment o7planning.org
  • HttpCookie.getComment()
  • ZipEntry.getComment()
  • ZipFile.getComment()


getCommentURL

getCommentURL o7planning.org
  • HttpCookie.getCommentURL()


getCommitsOnValidEdit

getCommitsOnValidEdit o7planning.org
  • DefaultFormatter.getCommitsOnValidEdit()


getCommitted

getCommitted o7planning.org
  • MemoryUsage.getCommitted()


getCommittedCharacterCount

getCommittedCharacterCount o7planning.org
  • InputMethodEvent.getCommittedCharacterCount()


getCommittedText

getCommittedText o7planning.org
  • InputMethodRequests.getCommittedText(int, int, AttributedCharacterIterator.Attribute[])


getCommittedTextLength

getCommittedTextLength o7planning.org
  • InputMethodRequests.getCommittedTextLength()


getCommonPoolParallelism

getCommonPoolParallelism o7planning.org
  • ForkJoinPool.getCommonPoolParallelism()


getComparator

getComparator o7planning.org
  • DefaultRowSorter.getComparator(int)
  • SortingFocusTraversalPolicy.getComparator()
  • Spliterator.getComparator()
  • TableRowSorter.getComparator(int)


getCompilationMXBean

getCompilationMXBean o7planning.org
  • ManagementFactory.getCompilationMXBean()


getCompletedTaskCount

getCompletedTaskCount o7planning.org
  • ThreadPoolExecutor.getCompletedTaskCount()


getCompleter

getCompleter o7planning.org
  • CountedCompleter.getCompleter()


getCompletions

getCompletions o7planning.org
  • AbstractProcessor.getCompletions(Element, AnnotationMirror, ExecutableElement, String)
  • Processor.getCompletions(Element, AnnotationMirror, ExecutableElement, String)


getComponent

getComponent o7planning.org
  • AncestorEvent.getComponent()
  • BasicTextUI.getComponent()
  • BeanContextChildComponentProxy.getComponent()
  • ComponentEvent.getComponent()
  • ComponentInputMap.getComponent()
  • ComponentView.getComponent()
  • Container.getComponent(int)
  • DefaultCaret.getComponent()
  • DefaultCellEditor.getComponent()
  • DragGestureEvent.getComponent()
  • DragGestureRecognizer.getComponent()
  • DragSourceContext.getComponent()
  • DropTarget.getComponent()
  • DropTargetContext.getComponent()
  • HierarchyEvent.getComponent()
  • JMenu.getComponent()
  • JMenuBar.getComponent()
  • JMenuItem.getComponent()
  • JPopupMenu.getComponent()
  • JToolTip.getComponent()
  • MenuElement.getComponent()
  • Renderer.getComponent()
  • StyleConstants.getComponent(AttributeSet)
  • SynthContext.getComponent()
  • TransferHandler.TransferSupport.getComponent()


getComponentAfter

getComponentAfter o7planning.org
  • ContainerOrderFocusTraversalPolicy.getComponentAfter(Container, Component)
  • DefaultFocusManager.getComponentAfter(Container, Component)
  • FocusTraversalPolicy.getComponentAfter(Container, Component)
  • LayoutFocusTraversalPolicy.getComponentAfter(Container, Component)
  • SortingFocusTraversalPolicy.getComponentAfter(Container, Component)


getComponentAt

getComponentAt o7planning.org
  • Component.getComponentAt(Point)
  • Component.getComponentAt(int, int)
  • Container.getComponentAt(Point)
  • Container.getComponentAt(int, int)
  • JTabbedPane.getComponentAt(int)


getComponentAtIndex

getComponentAtIndex o7planning.org
  • JMenuBar.getComponentAtIndex(int)
  • JPopupMenu.getComponentAtIndex(int)
  • JToolBar.getComponentAtIndex(int)


getComponentBefore

getComponentBefore o7planning.org
  • ContainerOrderFocusTraversalPolicy.getComponentBefore(Container, Component)
  • DefaultFocusManager.getComponentBefore(Container, Component)
  • FocusTraversalPolicy.getComponentBefore(Container, Component)
  • LayoutFocusTraversalPolicy.getComponentBefore(Container, Component)
  • SortingFocusTraversalPolicy.getComponentBefore(Container, Component)


getComponentColor

getComponentColor o7planning.org
  • AbstractRegionPainter.getComponentColor(JComponent, String, Color, float, float, int)


getComponentCount

getComponentCount o7planning.org
  • Container.getComponentCount()


getComponentCountInLayer

getComponentCountInLayer o7planning.org
  • JLayeredPane.getComponentCountInLayer(int)


getComponentGraphics

getComponentGraphics o7planning.org
  • JComponent.getComponentGraphics(Graphics)


getComponentIndex

getComponentIndex o7planning.org
  • JMenuBar.getComponentIndex(Component)
  • JPopupMenu.getComponentIndex(Component)
  • JToolBar.getComponentIndex(Component)


getComponentListeners

getComponentListeners o7planning.org
  • Component.getComponentListeners()


getComponentOrientation

getComponentOrientation o7planning.org
  • Component.getComponentOrientation()


getComponentPopupMenu

getComponentPopupMenu o7planning.org
  • JComponent.getComponentPopupMenu()


getComponents

getComponents o7planning.org
  • Color.getComponents(ColorSpace, float[])
  • Color.getComponents(float[])
  • ColorModel.getComponents(Object, int[], int)
  • ColorModel.getComponents(int, int[], int)
  • ComponentColorModel.getComponents(Object, int[], int)
  • ComponentColorModel.getComponents(int, int[], int)
  • Container.getComponents()
  • DirectColorModel.getComponents(Object, int[], int)
  • DirectColorModel.getComponents(int, int[], int)
  • IndexColorModel.getComponents(Object, int[], int)
  • IndexColorModel.getComponents(int, int[], int)


getComponentsInLayer

getComponentsInLayer o7planning.org
  • JLayeredPane.getComponentsInLayer(int)


getComponentSize

getComponentSize o7planning.org
  • ColorModel.getComponentSize()
  • ColorModel.getComponentSize(int)
  • IndexColorModel.getComponentSize()


getComponentState

getComponentState o7planning.org
  • SynthContext.getComponentState()


getComponentToLayer

getComponentToLayer o7planning.org
  • JLayeredPane.getComponentToLayer()


getComponentType

getComponentType o7planning.org
  • ArrayType.getComponentType()
  • Class.getComponentType()


getComponentZOrder

getComponentZOrder o7planning.org
  • Container.getComponentZOrder(Component)


getComposite

getComposite o7planning.org
  • Graphics2D.getComposite()


getCompositeData

getCompositeData o7planning.org
  • CompositeDataInvocationHandler.getCompositeData()


getCompositeType

getCompositeType o7planning.org
  • CompositeData.getCompositeType()
  • CompositeDataSupport.getCompositeType()


getCompressedSize

getCompressedSize o7planning.org
  • ZipEntry.getCompressedSize()


getCompressionMode

getCompressionMode o7planning.org
  • ImageWriteParam.getCompressionMode()


getCompressionQuality

getCompressionQuality o7planning.org
  • ImageWriteParam.getCompressionQuality()


getCompressionQualityDescriptions

getCompressionQualityDescriptions o7planning.org
  • ImageWriteParam.getCompressionQualityDescriptions()
  • JPEGImageWriteParam.getCompressionQualityDescriptions()


getCompressionQualityValues

getCompressionQualityValues o7planning.org
  • ImageWriteParam.getCompressionQualityValues()
  • JPEGImageWriteParam.getCompressionQualityValues()


getCompressionThreshold

getCompressionThreshold o7planning.org
  • StyleContext.getCompressionThreshold()


getCompressionType

getCompressionType o7planning.org
  • ImageWriteParam.getCompressionType()


getCompressionTypes

getCompressionTypes o7planning.org
  • ImageWriteParam.getCompressionTypes()


getConcurrency

getConcurrency o7planning.org
  • BaseRowSet.getConcurrency()
  • ResultSet.getConcurrency()


getConditionForKeyStroke

getConditionForKeyStroke o7planning.org
  • JComponent.getConditionForKeyStroke(KeyStroke)


getConfiguration

getConfiguration o7planning.org
  • Configuration.getConfiguration()
  • DomainLoadStoreParameter.getConfiguration()


getConfigurations

getConfigurations o7planning.org
  • GraphicsDevice.getConfigurations()


getConflictValue

getConflictValue o7planning.org
  • SyncResolver.getConflictValue(String)
  • SyncResolver.getConflictValue(int)


getConfState

getConfState o7planning.org
  • GSSContext.getConfState()


getConnectControls

getConnectControls o7planning.org
  • InitialLdapContext.getConnectControls()
  • LdapContext.getConnectControls()


getConnection

getConnection o7planning.org
  • DataSource.getConnection(String, String)
  • DataSource.getConnection()
  • DatabaseMetaData.getConnection()
  • DriverManager.getConnection(String)
  • DriverManager.getConnection(String, String, String)
  • DriverManager.getConnection(String, Properties)
  • PooledConnection.getConnection()
  • RowSetInternal.getConnection()
  • Statement.getConnection()


getConnectionId

getConnectionId o7planning.org
  • JMXConnectionNotification.getConnectionId()
  • JMXConnector.getConnectionId()
  • RMIConnection.getConnectionId()
  • RMIConnectionImpl.getConnectionId()
  • RMIConnectionImpl_Stub.getConnectionId()
  • RMIConnector.getConnectionId()


getConnectionIds

getConnectionIds o7planning.org
  • JMXConnectorServer.getConnectionIds()
  • JMXConnectorServerMBean.getConnectionIds()


getConnectTimeout

getConnectTimeout o7planning.org
  • URLConnection.getConnectTimeout()


getConstantExpression

getConstantExpression o7planning.org
  • Elements.getConstantExpression(Object)


getConstantValue

getConstantValue o7planning.org
  • VariableElement.getConstantValue()


getConstraint

getConstraint o7planning.org
  • SpringLayout.getConstraint(String, Component)
  • SpringLayout.Constraints.getConstraint(String)


getConstraints

getConstraints o7planning.org
  • BorderLayout.getConstraints(Component)
  • GridBagLayout.getConstraints(Component)
  • SpringLayout.getConstraints(Component)


getConstructor

getConstructor o7planning.org
  • Class.getConstructor(Class<?>...)
  • ModelMBeanInfoSupport.getConstructor(String)


getConstructors

getConstructors o7planning.org
  • Class.getConstructors()
  • MBeanInfo.getConstructors()
  • ModelMBeanInfo.getConstructors()
  • OpenMBeanInfo.getConstructors()
  • StandardMBean.getConstructors(MBeanConstructorInfo[], Object)


getContainer

getContainer o7planning.org
  • BeanContextContainerProxy.getContainer()
  • ContainerEvent.getContainer()
  • View.getContainer()


getContainerGap

getContainerGap o7planning.org
  • LayoutStyle.getContainerGap(JComponent, int, Container)


getContainerListeners

getContainerListeners o7planning.org
  • Container.getContainerListeners()


getContent

getContent o7planning.org
  • AbstractDocument.getContent()
  • AttachmentPart.getContent()
  • BinaryRefAddr.getContent()
  • ContentHandler.getContent(URLConnection, Class[])
  • ContentHandler.getContent(URLConnection)
  • DataContentHandler.getContent(DataSource)
  • DataHandler.getContent()
  • Element.getContent()
  • KeyInfo.getContent()
  • RefAddr.getContent()
  • SOAPPart.getContent()
  • SignatureProperty.getContent()
  • StringRefAddr.getContent()
  • URL.getContent(Class[])
  • URL.getContent()
  • URLConnection.getContent(Class[])
  • URLConnection.getContent()
  • X509Data.getContent()
  • XMLObject.getContent()


getContentBorderInsets

getContentBorderInsets o7planning.org
  • BasicTabbedPaneUI.getContentBorderInsets(int)


getContentDescription

getContentDescription o7planning.org
  • SOAPMessage.getContentDescription()


getContentEncoding

getContentEncoding o7planning.org
  • URLConnection.getContentEncoding()


getContentHandler

getContentHandler o7planning.org
  • ParserAdapter.getContentHandler()
  • ValidatorHandler.getContentHandler()
  • XMLFilterImpl.getContentHandler()
  • XMLReader.getContentHandler()


getContentId

getContentId o7planning.org
  • AttachmentPart.getContentId()
  • SOAPPart.getContentId()


getContentLength

getContentLength o7planning.org
  • URLConnection.getContentLength()


getContentLengthLong

getContentLengthLong o7planning.org
  • URLConnection.getContentLengthLong()


getContentLocation

getContentLocation o7planning.org
  • AttachmentPart.getContentLocation()
  • SOAPPart.getContentLocation()


getContentPane

getContentPane o7planning.org
  • JApplet.getContentPane()
  • JDialog.getContentPane()
  • JFrame.getContentPane()
  • JInternalFrame.getContentPane()
  • JRootPane.getContentPane()
  • JWindow.getContentPane()
  • RootPaneContainer.getContentPane()


getContents

getContents o7planning.org
  • AccessibleResourceBundle.getContents()
  • Clipboard.getContents(Object)
  • ListResourceBundle.getContents()


getContentType

getContentType o7planning.org
  • AttachmentPart.getContentType()
  • DataHandler.getContentType()
  • DataSource.getContentType()
  • DefaultEditorKit.getContentType()
  • EditorKit.getContentType()
  • FileDataSource.getContentType()
  • FileTypeMap.getContentType(String)
  • FileTypeMap.getContentType(File)
  • HTMLEditorKit.getContentType()
  • JEditorPane.getContentType()
  • MimetypesFileTypeMap.getContentType(String)
  • MimetypesFileTypeMap.getContentType(File)
  • RTFEditorKit.getContentType()
  • URLConnection.getContentType()
  • URLDataSource.getContentType()


getContentTypeFor

getContentTypeFor o7planning.org
  • FileNameMap.getContentTypeFor(String)


getContext

getContext o7planning.org
  • AbstractScriptEngine.getContext()
  • AccessController.getContext()
  • Response.getContext()
  • ScriptEngine.getContext()
  • SynthButtonUI.getContext(JComponent)
  • SynthColorChooserUI.getContext(JComponent)
  • SynthComboBoxUI.getContext(JComponent)
  • SynthDesktopIconUI.getContext(JComponent)
  • SynthDesktopPaneUI.getContext(JComponent)
  • SynthEditorPaneUI.getContext(JComponent)
  • SynthInternalFrameUI.getContext(JComponent)
  • SynthLabelUI.getContext(JComponent)
  • SynthListUI.getContext(JComponent)
  • SynthMenuBarUI.getContext(JComponent)
  • SynthMenuItemUI.getContext(JComponent)
  • SynthMenuUI.getContext(JComponent)
  • SynthOptionPaneUI.getContext(JComponent)
  • SynthPanelUI.getContext(JComponent)
  • SynthPopupMenuUI.getContext(JComponent)
  • SynthProgressBarUI.getContext(JComponent)
  • SynthRootPaneUI.getContext(JComponent)
  • SynthScrollBarUI.getContext(JComponent)
  • SynthScrollPaneUI.getContext(JComponent)
  • SynthSeparatorUI.getContext(JComponent)
  • SynthSliderUI.getContext(JComponent)
  • SynthSpinnerUI.getContext(JComponent)
  • SynthSplitPaneUI.getContext(JComponent)
  • SynthTabbedPaneUI.getContext(JComponent)
  • SynthTableHeaderUI.getContext(JComponent)
  • SynthTableUI.getContext(JComponent)
  • SynthTextAreaUI.getContext(JComponent)
  • SynthTextFieldUI.getContext(JComponent)
  • SynthToolBarUI.getContext(JComponent)
  • SynthToolTipUI.getContext(JComponent)
  • SynthTreeUI.getContext(JComponent)
  • SynthUI.getContext(JComponent)
  • SynthViewportUI.getContext(JComponent)


getContextClassLoader

getContextClassLoader o7planning.org
  • Thread.getContextClassLoader()


getContextPath

getContextPath o7planning.org
  • HttpExchange.getContextPath()


getContextualShaper

getContextualShaper o7planning.org
  • NumericShaper.getContextualShaper(Set<NumericShaper.Range>, NumericShaper.Range)
  • NumericShaper.getContextualShaper(int, int)
  • NumericShaper.getContextualShaper(Set<NumericShaper.Range>)
  • NumericShaper.getContextualShaper(int)


getContinuationContext

getContinuationContext o7planning.org
  • NamingManager.getContinuationContext(CannotProceedException)


getContinuationDirContext

getContinuationDirContext o7planning.org
  • DirectoryManager.getContinuationDirContext(CannotProceedException)


getContinueExistingPeriodicTasksAfterShutdownPolicy

getContinueExistingPeriodicTasksAfterShutdownPolicy o7planning.org
  • ScheduledThreadPoolExecutor.getContinueExistingPeriodicTasksAfterShutdownPolicy()


getControl

getControl o7planning.org
  • Line.getControl(Control.Type)
  • MetalLookAndFeel.getControl()
  • MetalTheme.getControl()
  • ResourceBundle.Control.getControl(List<String>)
  • ResourceBundleControlProvider.getControl(String)


getControlButtonsAreShown

getControlButtonsAreShown o7planning.org
  • JFileChooser.getControlButtonsAreShown()


getControlDarkShadow

getControlDarkShadow o7planning.org
  • MetalLookAndFeel.getControlDarkShadow()
  • MetalTheme.getControlDarkShadow()


getControlDisabled

getControlDisabled o7planning.org
  • MetalLookAndFeel.getControlDisabled()
  • MetalTheme.getControlDisabled()


getControlFlag

getControlFlag o7planning.org
  • AppConfigurationEntry.getControlFlag()


getControlHighlight

getControlHighlight o7planning.org
  • MetalLookAndFeel.getControlHighlight()
  • MetalTheme.getControlHighlight()


getControlInfo

getControlInfo o7planning.org
  • MetalLookAndFeel.getControlInfo()
  • MetalTheme.getControlInfo()


getControlInstance

getControlInstance o7planning.org
  • ControlFactory.getControlInstance(Control, Context, Hashtable<?, ?>)
  • ControlFactory.getControlInstance(Control)


getController

getController o7planning.org
  • IIOMetadata.getController()
  • IIOParam.getController()
  • MidiChannel.getController(int)


getControlObject

getControlObject o7planning.org
  • InputMethod.getControlObject()


getControls

getControls o7planning.org
  • HasControls.getControls()
  • Line.getControls()


getControlShadow

getControlShadow o7planning.org
  • MetalLookAndFeel.getControlShadow()
  • MetalTheme.getControlShadow()


getControlSize

getControlSize o7planning.org
  • MetalCheckBoxIcon.getControlSize()


getControlTextColor

getControlTextColor o7planning.org
  • MetalLookAndFeel.getControlTextColor()
  • MetalTheme.getControlTextColor()
  • OceanTheme.getControlTextColor()


getControlTextFont

getControlTextFont o7planning.org
  • DefaultMetalTheme.getControlTextFont()
  • MetalLookAndFeel.getControlTextFont()
  • MetalTheme.getControlTextFont()


getConversion

getConversion o7planning.org
  • FormatFlagsConversionMismatchException.getConversion()
  • IllegalFormatConversionException.getConversion()
  • UnknownFormatConversionException.getConversion()


getCookie

getCookie o7planning.org
  • PagedResultsResponseControl.getCookie()


getCookies

getCookies o7planning.org
  • CookieStore.getCookies()


getCookieStore

getCookieStore o7planning.org
  • CookieManager.getCookieStore()


getCopies

getCopies o7planning.org
  • JobAttributes.getCopies()
  • PrinterJob.getCopies()


getCopyAction

getCopyAction o7planning.org
  • TransferHandler.getCopyAction()


getCorePoolSize

getCorePoolSize o7planning.org
  • ThreadPoolExecutor.getCorePoolSize()


getCorner

getCorner o7planning.org
  • JScrollPane.getCorner(String)
  • ScrollPaneLayout.getCorner(String)


getCount

getCount o7planning.org
  • BufferPoolMXBean.getCount()
  • CountDownLatch.getCount()
  • DoubleSummaryStatistics.getCount()
  • IntSummaryStatistics.getCount()
  • LongSummaryStatistics.getCount()
  • MemoryNotificationInfo.getCount()


getCountLimit

getCountLimit o7planning.org
  • SearchControls.getCountLimit()


getCountry

getCountry o7planning.org
  • Locale.getCountry()


getCrc

getCrc o7planning.org
  • ZipEntry.getCrc()


getCreationDate

getCreationDate o7planning.org
  • KeyStore.getCreationDate(String)


getCreationTime

getCreationTime o7planning.org
  • SSLSession.getCreationTime()
  • ZipEntry.getCreationTime()


getCredDelegState

getCredDelegState o7planning.org
  • GSSContext.getCredDelegState()


getCredentialClass

getCredentialClass o7planning.org
  • PrivateCredentialPermission.getCredentialClass()


getCriticalExtensionOIDs

getCriticalExtensionOIDs o7planning.org
  • X509Extension.getCriticalExtensionOIDs()


getCRLs

getCRLs o7planning.org
  • CertStore.getCRLs(CRLSelector)


getCrossFeedResolution

getCrossFeedResolution o7planning.org
  • ResolutionSyntax.getCrossFeedResolution(int)


getCrossFeedResolutionDphi

getCrossFeedResolutionDphi o7planning.org
  • ResolutionSyntax.getCrossFeedResolutionDphi()


getCrossPlatformLookAndFeelClassName

getCrossPlatformLookAndFeelClassName o7planning.org
  • UIManager.getCrossPlatformLookAndFeelClassName()


getCrossReference

getCrossReference o7planning.org
  • DatabaseMetaData.getCrossReference(String, String, String, String, String, String)


getCrtCoefficient

getCrtCoefficient o7planning.org
  • RSAMultiPrimePrivateCrtKey.getCrtCoefficient()
  • RSAMultiPrimePrivateCrtKeySpec.getCrtCoefficient()
  • RSAOtherPrimeInfo.getCrtCoefficient()
  • RSAPrivateCrtKey.getCrtCoefficient()
  • RSAPrivateCrtKeySpec.getCrtCoefficient()


getCtrlKey

getCtrlKey o7planning.org
  • MouseEvent.getCtrlKey()


getCtrlP1

getCtrlP1 o7planning.org
  • CubicCurve2D.getCtrlP1()
  • CubicCurve2D.Double.getCtrlP1()
  • CubicCurve2D.Float.getCtrlP1()


getCtrlP2

getCtrlP2 o7planning.org
  • CubicCurve2D.getCtrlP2()
  • CubicCurve2D.Double.getCtrlP2()
  • CubicCurve2D.Float.getCtrlP2()


getCtrlPt

getCtrlPt o7planning.org
  • QuadCurve2D.getCtrlPt()
  • QuadCurve2D.Double.getCtrlPt()
  • QuadCurve2D.Float.getCtrlPt()


getCtrlX1

getCtrlX1 o7planning.org
  • CubicCurve2D.getCtrlX1()
  • CubicCurve2D.Double.getCtrlX1()
  • CubicCurve2D.Float.getCtrlX1()


getCtrlX2

getCtrlX2 o7planning.org
  • CubicCurve2D.getCtrlX2()
  • CubicCurve2D.Double.getCtrlX2()
  • CubicCurve2D.Float.getCtrlX2()


getCtrlX

getCtrlX o7planning.org
  • QuadCurve2D.getCtrlX()
  • QuadCurve2D.Double.getCtrlX()
  • QuadCurve2D.Float.getCtrlX()


getCtrlY1

getCtrlY1 o7planning.org
  • CubicCurve2D.getCtrlY1()
  • CubicCurve2D.Double.getCtrlY1()
  • CubicCurve2D.Float.getCtrlY1()


getCtrlY2

getCtrlY2 o7planning.org
  • CubicCurve2D.getCtrlY2()
  • CubicCurve2D.Double.getCtrlY2()
  • CubicCurve2D.Float.getCtrlY2()


getCtrlY

getCtrlY o7planning.org
  • QuadCurve2D.getCtrlY()
  • QuadCurve2D.Double.getCtrlY()
  • QuadCurve2D.Float.getCtrlY()


getCurrency

getCurrency o7planning.org
  • DecimalFormat.getCurrency()
  • DecimalFormatSymbols.getCurrency()
  • NumberFormat.getCurrency()


getCurrencyCode

getCurrencyCode o7planning.org
  • Currency.getCurrencyCode()


getCurrencyInstance

getCurrencyInstance o7planning.org
  • NumberFormat.getCurrencyInstance(Locale)
  • NumberFormat.getCurrencyInstance()
  • NumberFormatProvider.getCurrencyInstance(Locale)


getCurrencySymbol

getCurrencySymbol o7planning.org
  • DecimalFormatSymbols.getCurrencySymbol()


getCurrent

getCurrent o7planning.org
  • CheckboxGroup.getCurrent()


getCurrentAccessibleContext

getCurrentAccessibleContext o7planning.org
  • JTable.AccessibleJTable.AccessibleJTableCell.getCurrentAccessibleContext()


getCurrentAccessibleValue

getCurrentAccessibleValue o7planning.org
  • AbstractButton.AccessibleAbstractButton.getCurrentAccessibleValue()
  • AccessibleValue.getCurrentAccessibleValue()
  • Button.AccessibleAWTButton.getCurrentAccessibleValue()
  • Checkbox.AccessibleAWTCheckbox.getCurrentAccessibleValue()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getCurrentAccessibleValue()
  • JInternalFrame.AccessibleJInternalFrame.getCurrentAccessibleValue()
  • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getCurrentAccessibleValue()
  • JProgressBar.AccessibleJProgressBar.getCurrentAccessibleValue()
  • JScrollBar.AccessibleJScrollBar.getCurrentAccessibleValue()
  • JSlider.AccessibleJSlider.getCurrentAccessibleValue()
  • JSpinner.AccessibleJSpinner.getCurrentAccessibleValue()
  • JSplitPane.AccessibleJSplitPane.getCurrentAccessibleValue()
  • MenuItem.AccessibleAWTMenuItem.getCurrentAccessibleValue()
  • Scrollbar.AccessibleAWTScrollBar.getCurrentAccessibleValue()


getCurrentComponent

getCurrentComponent o7planning.org
  • JTable.AccessibleJTable.AccessibleJTableCell.getCurrentComponent()


getCurrentDataFlavors

getCurrentDataFlavors o7planning.org
  • DropTargetContext.getCurrentDataFlavors()
  • DropTargetDragEvent.getCurrentDataFlavors()
  • DropTargetDropEvent.getCurrentDataFlavors()


getCurrentDataFlavorsAsList

getCurrentDataFlavorsAsList o7planning.org
  • DropTargetContext.getCurrentDataFlavorsAsList()
  • DropTargetDragEvent.getCurrentDataFlavorsAsList()
  • DropTargetDropEvent.getCurrentDataFlavorsAsList()


getCurrentDirectory

getCurrentDirectory o7planning.org
  • JFileChooser.getCurrentDirectory()


getCurrentEvent

getCurrentEvent o7planning.org
  • EventQueue.getCurrentEvent()


getCurrentFocusCycleRoot

getCurrentFocusCycleRoot o7planning.org
  • KeyboardFocusManager.getCurrentFocusCycleRoot()


getCurrentKeyboardFocusManager

getCurrentKeyboardFocusManager o7planning.org
  • KeyboardFocusManager.getCurrentKeyboardFocusManager()


getCurrentLine

getCurrentLine o7planning.org
  • Parser.getCurrentLine()


getCurrentLineLength

getCurrentLineLength o7planning.org
  • AbstractWriter.getCurrentLineLength()


getCurrentManager

getCurrentManager o7planning.org
  • FocusManager.getCurrentManager()


getCurrentPoint

getCurrentPoint o7planning.org
  • Path2D.getCurrentPoint()


getCurrentPos

getCurrentPos o7planning.org
  • Parser.getCurrentPos()


getCurrentServiceClasses

getCurrentServiceClasses o7planning.org
  • BeanContextServices.getCurrentServiceClasses()
  • BeanContextServicesSupport.getCurrentServiceClasses()


getCurrentServiceSelectors

getCurrentServiceSelectors o7planning.org
  • BeanContextServiceAvailableEvent.getCurrentServiceSelectors()
  • BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices, Class)
  • BeanContextServices.getCurrentServiceSelectors(Class)
  • BeanContextServicesSupport.getCurrentServiceSelectors(Class)
  • BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices, Class)


getCurrentTarget

getCurrentTarget o7planning.org
  • Event.getCurrentTarget()


getCurrentTheme

getCurrentTheme o7planning.org
  • MetalLookAndFeel.getCurrentTheme()


getCurrentThreadCpuTime

getCurrentThreadCpuTime o7planning.org
  • ThreadMXBean.getCurrentThreadCpuTime()


getCurrentThreadUserTime

getCurrentThreadUserTime o7planning.org
  • ThreadMXBean.getCurrentThreadUserTime()


getCurrentWriter

getCurrentWriter o7planning.org
  • AbstractDocument.getCurrentWriter()


getCursor

getCursor o7planning.org
  • AccessibleComponent.getCursor()
  • Component.getCursor()
  • Component.AccessibleAWTComponent.getCursor()
  • DragSourceContext.getCursor()
  • JList.AccessibleJList.AccessibleJListChild.getCursor()
  • JTable.AccessibleJTable.AccessibleJTableCell.getCursor()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getCursor()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getCursor()
  • List.AccessibleAWTList.AccessibleAWTListChild.getCursor()
  • MenuComponent.AccessibleAWTMenuComponent.getCursor()


getCursorName

getCursorName o7planning.org
  • ResultSet.getCursorName()


getCursorType

getCursorType o7planning.org
  • Frame.getCursorType()


getCurve

getCurve o7planning.org
  • ECParameterSpec.getCurve()


getCustomEditor

getCustomEditor o7planning.org
  • PropertyEditor.getCustomEditor()
  • PropertyEditorSupport.getCustomEditor()


getCustomizerClass

getCustomizerClass o7planning.org
  • BeanDescriptor.getCustomizerClass()


getCutAction

getCutAction o7planning.org
  • TransferHandler.getCutAction()


getCycleMethod

getCycleMethod o7planning.org
  • MultipleGradientPaint.getCycleMethod()


getDaemonThreadCount

getDaemonThreadCount o7planning.org
  • ThreadMXBean.getDaemonThreadCount()


getDashArray

getDashArray o7planning.org
  • BasicStroke.getDashArray()


getDashPhase

getDashPhase o7planning.org
  • BasicStroke.getDashPhase()


getData1

getData1 o7planning.org
  • ShortMessage.getData1()


getData2

getData2 o7planning.org
  • ShortMessage.getData2()


getData

getData o7planning.org
  • ActivationDesc.getData()
  • ActivationGroupDesc.getData()
  • BufferedImage.getData(Rectangle)
  • BufferedImage.getData()
  • CharacterData.getData()
  • Characters.getData()
  • Clipboard.getData(DataFlavor)
  • DataBufferByte.getData(int)
  • DataBufferByte.getData()
  • DataBufferDouble.getData(int)
  • DataBufferDouble.getData()
  • DataBufferFloat.getData(int)
  • DataBufferFloat.getData()
  • DataBufferInt.getData(int)
  • DataBufferInt.getData()
  • DataBufferShort.getData(int)
  • DataBufferShort.getData()
  • DataBufferUShort.getData(int)
  • DataBufferUShort.getData()
  • DatagramPacket.getData()
  • Entity.getData()
  • FormSubmitEvent.getData()
  • ICC_Profile.getData(int)
  • ICC_Profile.getData()
  • IIOByteBuffer.getData()
  • MetaMessage.getData()
  • ProcessingInstruction.getData()
  • ProcessingInstruction.getData()
  • RenderedImage.getData(Rectangle)
  • RenderedImage.getData()
  • SoundbankResource.getData()
  • SysexMessage.getData()


getDatabaseMajorVersion

getDatabaseMajorVersion o7planning.org
  • DatabaseMetaData.getDatabaseMajorVersion()


getDatabaseMinorVersion

getDatabaseMinorVersion o7planning.org
  • DatabaseMetaData.getDatabaseMinorVersion()


getDatabaseProductName

getDatabaseProductName o7planning.org
  • DatabaseMetaData.getDatabaseProductName()


getDatabaseProductVersion

getDatabaseProductVersion o7planning.org
  • DatabaseMetaData.getDatabaseProductVersion()


getDataBitOffset

getDataBitOffset o7planning.org
  • MultiPixelPackedSampleModel.getDataBitOffset()


getDataBuffer

getDataBuffer o7planning.org
  • Raster.getDataBuffer()


getDataClass

getDataClass o7planning.org
  • SoundbankResource.getDataClass()


getDataElement

getDataElement o7planning.org
  • ColorModel.getDataElement(float[], int)
  • ColorModel.getDataElement(int[], int)
  • ComponentColorModel.getDataElement(float[], int)
  • ComponentColorModel.getDataElement(int[], int)
  • DirectColorModel.getDataElement(int[], int)
  • IndexColorModel.getDataElement(int[], int)


getDataElements

getDataElements o7planning.org
  • BandedSampleModel.getDataElements(int, int, Object, DataBuffer)
  • ColorModel.getDataElements(float[], int, Object)
  • ColorModel.getDataElements(int[], int, Object)
  • ColorModel.getDataElements(int, Object)
  • ComponentColorModel.getDataElements(float[], int, Object)
  • ComponentColorModel.getDataElements(int[], int, Object)
  • ComponentColorModel.getDataElements(int, Object)
  • ComponentSampleModel.getDataElements(int, int, Object, DataBuffer)
  • DirectColorModel.getDataElements(int[], int, Object)
  • DirectColorModel.getDataElements(int, Object)
  • IndexColorModel.getDataElements(int[], int, Object)
  • IndexColorModel.getDataElements(int, Object)
  • MultiPixelPackedSampleModel.getDataElements(int, int, Object, DataBuffer)
  • Raster.getDataElements(int, int, int, int, Object)
  • Raster.getDataElements(int, int, Object)
  • SampleModel.getDataElements(int, int, int, int, Object, DataBuffer)
  • SampleModel.getDataElements(int, int, Object, DataBuffer)
  • SinglePixelPackedSampleModel.getDataElements(int, int, Object, DataBuffer)


getDataFlavors

getDataFlavors o7planning.org
  • TransferHandler.TransferSupport.getDataFlavors()


getDataHandler

getDataHandler o7planning.org
  • AttachmentPart.getDataHandler()


getDataLength

getDataLength o7planning.org
  • ShortMessage.getDataLength(int)


getDatalink

getDatalink o7planning.org
  • SerialDatalink.getDatalink()


getDataSize

getDataSize o7planning.org
  • DataTruncation.getDataSize()


getDataSource

getDataSource o7planning.org
  • DataHandler.getDataSource()


getDataSourceLock

getDataSourceLock o7planning.org
  • SyncProvider.getDataSourceLock()


getDataSourceName

getDataSourceName o7planning.org
  • BaseRowSet.getDataSourceName()
  • RowSet.getDataSourceName()


getDataType

getDataType o7planning.org
  • DataBuffer.getDataType()
  • SampleModel.getDataType()


getDataTypeSize

getDataTypeSize o7planning.org
  • DataBuffer.getDataTypeSize(int)


getDataVector

getDataVector o7planning.org
  • DefaultTableModel.getDataVector()


getDate

getDate o7planning.org
  • CallableStatement.getDate(String, Calendar)
  • CallableStatement.getDate(String)
  • CallableStatement.getDate(int, Calendar)
  • CallableStatement.getDate(int)
  • Date.getDate()
  • PKIXParameters.getDate()
  • ResultSet.getDate(String, Calendar)
  • ResultSet.getDate(int, Calendar)
  • ResultSet.getDate(String)
  • ResultSet.getDate(int)
  • SpinnerDateModel.getDate()
  • Time.getDate()
  • Timer.getDate(Integer)
  • TimerMBean.getDate(Integer)
  • URLConnection.getDate()


getDateAndTime

getDateAndTime o7planning.org
  • X509CRLSelector.getDateAndTime()


getDateFormatSymbols

getDateFormatSymbols o7planning.org
  • SimpleDateFormat.getDateFormatSymbols()


getDateInstance

getDateInstance o7planning.org
  • DateFormat.getDateInstance(int, Locale)
  • DateFormat.getDateInstance(int)
  • DateFormat.getDateInstance()
  • DateFormatProvider.getDateInstance(int, Locale)


getDateTimeAfter

getDateTimeAfter o7planning.org
  • ZoneOffsetTransition.getDateTimeAfter()


getDateTimeBefore

getDateTimeBefore o7planning.org
  • ZoneOffsetTransition.getDateTimeBefore()


getDateTimeInstance

getDateTimeInstance o7planning.org
  • DateFormat.getDateTimeInstance(int, int, Locale)
  • DateFormat.getDateTimeInstance(int, int)
  • DateFormat.getDateTimeInstance()
  • DateFormatProvider.getDateTimeInstance(int, int, Locale)


getDay

getDay o7planning.org
  • Date.getDay()
  • Time.getDay()
  • XMLGregorianCalendar.getDay()


getDaylightSavings

getDaylightSavings o7planning.org
  • ZoneRules.getDaylightSavings(Instant)


getDayOfMonth

getDayOfMonth o7planning.org
  • LocalDate.getDayOfMonth()
  • LocalDateTime.getDayOfMonth()
  • MonthDay.getDayOfMonth()
  • OffsetDateTime.getDayOfMonth()
  • ZonedDateTime.getDayOfMonth()


getDayOfMonthIndicator

getDayOfMonthIndicator o7planning.org
  • ZoneOffsetTransitionRule.getDayOfMonthIndicator()


getDayOfWeek

getDayOfWeek o7planning.org
  • LocalDate.getDayOfWeek()
  • LocalDateTime.getDayOfWeek()
  • OffsetDateTime.getDayOfWeek()
  • ZoneOffsetTransitionRule.getDayOfWeek()
  • ZonedDateTime.getDayOfWeek()


getDayOfYear

getDayOfYear o7planning.org
  • LocalDate.getDayOfYear()
  • LocalDateTime.getDayOfYear()
  • OffsetDateTime.getDayOfYear()
  • ZonedDateTime.getDayOfYear()


getDays

getDays o7planning.org
  • Duration.getDays()
  • Period.getDays()


getDCHuffmanTables

getDCHuffmanTables o7planning.org
  • JPEGImageReadParam.getDCHuffmanTables()
  • JPEGImageWriteParam.getDCHuffmanTables()


getDebugGraphicsOptions

getDebugGraphicsOptions o7planning.org
  • JComponent.getDebugGraphicsOptions()


getDebugOptions

getDebugOptions o7planning.org
  • DebugGraphics.getDebugOptions()


getDecayTime

getDecayTime o7planning.org
  • ReverbType.getDecayTime()


getDecimalFormatSymbols

getDecimalFormatSymbols o7planning.org
  • DecimalFormat.getDecimalFormatSymbols()


getDecimalSeparator

getDecimalSeparator o7planning.org
  • DecimalFormatSymbols.getDecimalSeparator()
  • DecimalStyle.getDecimalSeparator()


getDecimalStyle

getDecimalStyle o7planning.org
  • DateTimeFormatter.getDecimalStyle()


getDeclaration

getDeclaration o7planning.org
  • EntityReference.getDeclaration()
  • StyleSheet.getDeclaration(String)


getDeclaredAnnotation

getDeclaredAnnotation o7planning.org
  • AccessibleObject.getDeclaredAnnotation(Class<T>)
  • AnnotatedElement.getDeclaredAnnotation(Class<T>)
  • Class.getDeclaredAnnotation(Class<A>)
  • Package.getDeclaredAnnotation(Class<A>)
  • Parameter.getDeclaredAnnotation(Class<T>)


getDeclaredAnnotations

getDeclaredAnnotations o7planning.org
  • AccessibleObject.getDeclaredAnnotations()
  • AnnotatedElement.getDeclaredAnnotations()
  • Class.getDeclaredAnnotations()
  • Constructor.getDeclaredAnnotations()
  • Executable.getDeclaredAnnotations()
  • Field.getDeclaredAnnotations()
  • Method.getDeclaredAnnotations()
  • Package.getDeclaredAnnotations()
  • Parameter.getDeclaredAnnotations()


getDeclaredAnnotationsByType

getDeclaredAnnotationsByType o7planning.org
  • AccessibleObject.getDeclaredAnnotationsByType(Class<T>)
  • AnnotatedElement.getDeclaredAnnotationsByType(Class<T>)
  • Class.getDeclaredAnnotationsByType(Class<A>)
  • Package.getDeclaredAnnotationsByType(Class<A>)
  • Parameter.getDeclaredAnnotationsByType(Class<T>)


getDeclaredClasses

getDeclaredClasses o7planning.org
  • Class.getDeclaredClasses()


getDeclaredConstructor

getDeclaredConstructor o7planning.org
  • Class.getDeclaredConstructor(Class<?>...)


getDeclaredConstructors

getDeclaredConstructors o7planning.org
  • Class.getDeclaredConstructors()


getDeclaredField

getDeclaredField o7planning.org
  • Class.getDeclaredField(String)


getDeclaredFields

getDeclaredFields o7planning.org
  • Class.getDeclaredFields()


getDeclaredMethod

getDeclaredMethod o7planning.org
  • Class.getDeclaredMethod(String, Class<?>...)


getDeclaredMethods

getDeclaredMethods o7planning.org
  • Class.getDeclaredMethods()


getDeclaredPrefixes

getDeclaredPrefixes o7planning.org
  • NamespaceSupport.getDeclaredPrefixes()


getDeclaredType

getDeclaredType o7planning.org
  • JAXBElement.getDeclaredType()
  • Types.getDeclaredType(DeclaredType, TypeElement, TypeMirror...)
  • Types.getDeclaredType(TypeElement, TypeMirror...)


getDeclaringClass

getDeclaringClass o7planning.org
  • Class.getDeclaringClass()
  • Constructor.getDeclaringClass()
  • Enum.getDeclaringClass()
  • Executable.getDeclaringClass()
  • Field.getDeclaringClass()
  • Member.getDeclaringClass()
  • Method.getDeclaringClass()
  • MethodHandleInfo.getDeclaringClass()


getDeclaringExecutable

getDeclaringExecutable o7planning.org
  • Parameter.getDeclaringExecutable()


getDecoder

getDecoder o7planning.org
  • Base64.getDecoder()


getDecomposition

getDecomposition o7planning.org
  • Collator.getDecomposition()


getDeepestComponentAt

getDeepestComponentAt o7planning.org
  • SwingUtilities.getDeepestComponentAt(Component, int, int)


getDefault

getDefault o7planning.org
  • CookieHandler.getDefault()
  • FileSystems.getDefault()
  • Locale.getDefault(Locale.Category)
  • Locale.getDefault()
  • ProxySelector.getDefault()
  • ResponseCache.getDefault()
  • SSLContext.getDefault()
  • SSLServerSocketFactory.getDefault()
  • SSLSocketFactory.getDefault()
  • ServerSocketFactory.getDefault()
  • SocketFactory.getDefault()
  • TimeZone.getDefault()


getDefaultAction

getDefaultAction o7planning.org
  • Keymap.getDefaultAction()


getDefaultActions

getDefaultActions o7planning.org
  • DropTarget.getDefaultActions()


getDefaultAlgorithm

getDefaultAlgorithm o7planning.org
  • KeyManagerFactory.getDefaultAlgorithm()
  • TrustManagerFactory.getDefaultAlgorithm()


getDefaultAllowUserInteraction

getDefaultAllowUserInteraction o7planning.org
  • URLConnection.getDefaultAllowUserInteraction()


getDefaultAttributeValue

getDefaultAttributeValue o7planning.org
  • PrintService.getDefaultAttributeValue(Class<? extends Attribute>)


getDefaultButton

getDefaultButton o7planning.org
  • BasicFileChooserUI.getDefaultButton(JFileChooser)
  • FileChooserUI.getDefaultButton(JFileChooser)
  • JRootPane.getDefaultButton()


getDefaultChoice

getDefaultChoice o7planning.org
  • ChoiceCallback.getDefaultChoice()


getDefaultChooserPanels

getDefaultChooserPanels o7planning.org
  • ColorChooserComponentFactory.getDefaultChooserPanels()


getDefaultCipherSuites

getDefaultCipherSuites o7planning.org
  • SSLServerSocketFactory.getDefaultCipherSuites()
  • SSLSocketFactory.getDefaultCipherSuites()


getDefaultClassLoader

getDefaultClassLoader o7planning.org
  • RMIServerImpl.getDefaultClassLoader()


getDefaultClosedIcon

getDefaultClosedIcon o7planning.org
  • DefaultTreeCellRenderer.getDefaultClosedIcon()


getDefaultCloseOperation

getDefaultCloseOperation o7planning.org
  • JDialog.getDefaultCloseOperation()
  • JFrame.getDefaultCloseOperation()
  • JInternalFrame.getDefaultCloseOperation()


getDefaultCommandMap

getDefaultCommandMap o7planning.org
  • CommandMap.getDefaultCommandMap()


getDefaultComponent

getDefaultComponent o7planning.org
  • ContainerOrderFocusTraversalPolicy.getDefaultComponent(Container)
  • FocusTraversalPolicy.getDefaultComponent(Container)
  • SortingFocusTraversalPolicy.getDefaultComponent(Container)


getDefaultConfiguration

getDefaultConfiguration o7planning.org
  • GraphicsDevice.getDefaultConfiguration()


getDefaultController

getDefaultController o7planning.org
  • IIOMetadata.getDefaultController()
  • IIOParam.getDefaultController()


getDefaultCursor

getDefaultCursor o7planning.org
  • Cursor.getDefaultCursor()
  • HTMLEditorKit.getDefaultCursor()


getDefaultDirectory

getDefaultDirectory o7planning.org
  • FileSystemView.getDefaultDirectory()


getDefaultDomain

getDefaultDomain o7planning.org
  • MBeanServer.getDefaultDomain()
  • MBeanServerConnection.getDefaultDomain()
  • RMIConnection.getDefaultDomain(Subject)
  • RMIConnectionImpl.getDefaultDomain(Subject)
  • RMIConnectionImpl_Stub.getDefaultDomain(Subject)


getDefaultDragSource

getDefaultDragSource o7planning.org
  • DragSource.getDefaultDragSource()


getDefaultEditor

getDefaultEditor o7planning.org
  • JTable.getDefaultEditor(Class<?>)


getDefaultEventIndex

getDefaultEventIndex o7planning.org
  • BeanInfo.getDefaultEventIndex()
  • SimpleBeanInfo.getDefaultEventIndex()


getDefaultFileTypeMap

getDefaultFileTypeMap o7planning.org
  • FileTypeMap.getDefaultFileTypeMap()


getDefaultFlavorMap

getDefaultFlavorMap o7planning.org
  • SystemFlavorMap.getDefaultFlavorMap()


getDefaultFocusTraversalKeys

getDefaultFocusTraversalKeys o7planning.org
  • KeyboardFocusManager.getDefaultFocusTraversalKeys(int)


getDefaultFocusTraversalPolicy

getDefaultFocusTraversalPolicy o7planning.org
  • KeyboardFocusManager.getDefaultFocusTraversalPolicy()


getDefaultFormatter

getDefaultFormatter o7planning.org
  • DefaultFormatterFactory.getDefaultFormatter()


getDefaultFractionDigits

getDefaultFractionDigits o7planning.org
  • Currency.getDefaultFractionDigits()


getDefaultHostnameVerifier

getDefaultHostnameVerifier o7planning.org
  • HttpsURLConnection.getDefaultHostnameVerifier()


getDefaultIcon

getDefaultIcon o7planning.org
  • BasicRadioButtonUI.getDefaultIcon()
  • SynthButtonUI.getDefaultIcon(AbstractButton)


getDefaultImageMetadata

getDefaultImageMetadata o7planning.org
  • ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier, ImageWriteParam)


getDefaultInitCtx

getDefaultInitCtx o7planning.org
  • InitialContext.getDefaultInitCtx()


getDefaultInstance

getDefaultInstance o7planning.org
  • IIORegistry.getDefaultInstance()


getDefaultLeafIcon

getDefaultLeafIcon o7planning.org
  • DefaultTreeCellRenderer.getDefaultLeafIcon()


getDefaultLightWeightPopupEnabled

getDefaultLightWeightPopupEnabled o7planning.org
  • JPopupMenu.getDefaultLightWeightPopupEnabled()


getDefaultLocale

getDefaultLocale o7planning.org
  • JComponent.getDefaultLocale()
  • UIDefaults.getDefaultLocale()


getDefaultName

getDefaultName o7planning.org
  • NameCallback.getDefaultName()


getDefaultNamespacePrefix

getDefaultNamespacePrefix o7planning.org
  • DOMCryptoContext.getDefaultNamespacePrefix()
  • XMLCryptoContext.getDefaultNamespacePrefix()


getDefaultOpenIcon

getDefaultOpenIcon o7planning.org
  • DefaultTreeCellRenderer.getDefaultOpenIcon()


getDefaultOption

getDefaultOption o7planning.org
  • ConfirmationCallback.getDefaultOption()


getDefaultPort

getDefaultPort o7planning.org
  • URL.getDefaultPort()
  • URLStreamHandler.getDefaultPort()


getDefaultPrintService

getDefaultPrintService o7planning.org
  • PrintServiceLookup.getDefaultPrintService()


getDefaultPropertyIndex

getDefaultPropertyIndex o7planning.org
  • BeanInfo.getDefaultPropertyIndex()
  • SimpleBeanInfo.getDefaultPropertyIndex()


getDefaultProviderInstance

getDefaultProviderInstance o7planning.org
  • RMIClassLoader.getDefaultProviderInstance()


getDefaultQueue

getDefaultQueue o7planning.org
  • LayoutQueue.getDefaultQueue()


getDefaultReadParam

getDefaultReadParam o7planning.org
  • ImageReader.getDefaultReadParam()


getDefaultRenderer

getDefaultRenderer o7planning.org
  • JTable.getDefaultRenderer(Class<?>)
  • JTableHeader.getDefaultRenderer()


getDefaultRepresentationClass

getDefaultRepresentationClass o7planning.org
  • DataFlavor.getDefaultRepresentationClass()


getDefaultRepresentationClassAsString

getDefaultRepresentationClassAsString o7planning.org
  • DataFlavor.getDefaultRepresentationClassAsString()


getDefaultRequestProperty

getDefaultRequestProperty o7planning.org
  • URLConnection.getDefaultRequestProperty(String)


getDefaultRootElement

getDefaultRootElement o7planning.org
  • AbstractDocument.getDefaultRootElement()
  • DefaultStyledDocument.getDefaultRootElement()
  • Document.getDefaultRootElement()
  • PlainDocument.getDefaultRootElement()


getDefaults

getDefaults o7planning.org
  • BasicLookAndFeel.getDefaults()
  • LookAndFeel.getDefaults()
  • MetalLookAndFeel.getDefaults()
  • MultiLookAndFeel.getDefaults()
  • NimbusLookAndFeel.getDefaults()
  • SynthLookAndFeel.getDefaults()
  • UIManager.getDefaults()


getDefaultScreenDevice

getDefaultScreenDevice o7planning.org
  • GraphicsEnvironment.getDefaultScreenDevice()


getDefaultSelection

getDefaultSelection o7planning.org
  • JobAttributes.getDefaultSelection()


getDefaultSize

getDefaultSize o7planning.org
  • BasicComboBoxUI.getDefaultSize()
  • SynthComboBoxUI.getDefaultSize()


getDefaultSocketFactory

getDefaultSocketFactory o7planning.org
  • RMISocketFactory.getDefaultSocketFactory()


getDefaultSoundbank

getDefaultSoundbank o7planning.org
  • Synthesizer.getDefaultSoundbank()


getDefaultSSLParameters

getDefaultSSLParameters o7planning.org
  • SSLContext.getDefaultSSLParameters()


getDefaultSSLSocketFactory

getDefaultSSLSocketFactory o7planning.org
  • HttpsURLConnection.getDefaultSSLSocketFactory()


getDefaultStream

getDefaultStream o7planning.org
  • LogStream.getDefaultStream()


getDefaultStreamMetadata

getDefaultStreamMetadata o7planning.org
  • ImageWriter.getDefaultStreamMetadata(ImageWriteParam)


getDefaultStyleContext

getDefaultStyleContext o7planning.org
  • StyleContext.getDefaultStyleContext()


getDefaultText

getDefaultText o7planning.org
  • TextInputCallback.getDefaultText()


getDefaultTextIconGap

getDefaultTextIconGap o7planning.org
  • BasicButtonUI.getDefaultTextIconGap(AbstractButton)


getDefaultToolkit

getDefaultToolkit o7planning.org
  • Toolkit.getDefaultToolkit()


getDefaultTransactionIsolation

getDefaultTransactionIsolation o7planning.org
  • DatabaseMetaData.getDefaultTransactionIsolation()


getDefaultTransform

getDefaultTransform o7planning.org
  • GraphicsConfiguration.getDefaultTransform()


getDefaultTreeModel

getDefaultTreeModel o7planning.org
  • JTree.getDefaultTreeModel()


getDefaultType

getDefaultType o7planning.org
  • CertPathBuilder.getDefaultType()
  • CertPathValidator.getDefaultType()
  • CertStore.getDefaultType()
  • KeyStore.getDefaultType()


getDefaultUncaughtExceptionHandler

getDefaultUncaughtExceptionHandler o7planning.org
  • Thread.getDefaultUncaughtExceptionHandler()


getDefaultUseCaches

getDefaultUseCaches o7planning.org
  • URLConnection.getDefaultUseCaches()


getDefaultValue

getDefaultValue o7planning.org
  • CSS.Attribute.getDefaultValue()
  • ExecutableElement.getDefaultValue()
  • Method.getDefaultValue()
  • OpenMBeanAttributeInfoSupport.getDefaultValue()
  • OpenMBeanParameterInfo.getDefaultValue()
  • OpenMBeanParameterInfoSupport.getDefaultValue()


getDefaultView

getDefaultView o7planning.org
  • DocumentView.getDefaultView()


getDefaultWriteParam

getDefaultWriteParam o7planning.org
  • ImageWriter.getDefaultWriteParam()


getDefinitionClass

getDefinitionClass o7planning.org
  • ClassDefinition.getDefinitionClass()


getDefinitionClassFile

getDefinitionClassFile o7planning.org
  • ClassDefinition.getDefinitionClassFile()


getDelay

getDelay o7planning.org
  • Delayed.getDelay(TimeUnit)
  • JMenu.getDelay()
  • Timer.getDelay()


getDelegatedTask

getDelegatedTask o7planning.org
  • SSLEngine.getDelegatedTask()


getDelegCred

getDelegCred o7planning.org
  • GSSContext.getDelegCred()


getDepth

getDepth o7planning.org
  • DefaultMutableTreeNode.getDepth()
  • MetalFileChooserUI.DirectoryComboBoxModel.getDepth(int)
  • PolicyNode.getDepth()


getDER

getDER o7planning.org
  • Oid.getDER()


getDereferencedData

getDereferencedData o7planning.org
  • Reference.getDereferencedData()


getDerefLinkFlag

getDerefLinkFlag o7planning.org
  • SearchControls.getDerefLinkFlag()


getDerivedColor

getDerivedColor o7planning.org
  • NimbusLookAndFeel.getDerivedColor(Color, Color, float)
  • NimbusLookAndFeel.getDerivedColor(Color, Color, float, boolean)
  • NimbusLookAndFeel.getDerivedColor(String, float, float, float, int, boolean)


getDerivedGauge

getDerivedGauge o7planning.org
  • CounterMonitor.getDerivedGauge()
  • CounterMonitor.getDerivedGauge(ObjectName)
  • CounterMonitorMBean.getDerivedGauge(ObjectName)
  • CounterMonitorMBean.getDerivedGauge()
  • GaugeMonitor.getDerivedGauge()
  • GaugeMonitor.getDerivedGauge(ObjectName)
  • GaugeMonitorMBean.getDerivedGauge(ObjectName)
  • GaugeMonitorMBean.getDerivedGauge()
  • MonitorNotification.getDerivedGauge()
  • StringMonitor.getDerivedGauge()
  • StringMonitor.getDerivedGauge(ObjectName)
  • StringMonitorMBean.getDerivedGauge(ObjectName)
  • StringMonitorMBean.getDerivedGauge()


getDerivedGaugeTimeStamp

getDerivedGaugeTimeStamp o7planning.org
  • CounterMonitor.getDerivedGaugeTimeStamp()
  • CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)
  • CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
  • CounterMonitorMBean.getDerivedGaugeTimeStamp()
  • GaugeMonitor.getDerivedGaugeTimeStamp()
  • GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)
  • GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
  • GaugeMonitorMBean.getDerivedGaugeTimeStamp()
  • StringMonitor.getDerivedGaugeTimeStamp()
  • StringMonitor.getDerivedGaugeTimeStamp(ObjectName)
  • StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
  • StringMonitorMBean.getDerivedGaugeTimeStamp()


getDescendantToggledPaths

getDescendantToggledPaths o7planning.org
  • JTree.getDescendantToggledPaths(TreePath)


getDescent

getDescent o7planning.org
  • FontMetrics.getDescent()
  • GlyphView.GlyphPainter.getDescent(GlyphView)
  • GraphicAttribute.getDescent()
  • ImageGraphicAttribute.getDescent()
  • LineMetrics.getDescent()
  • ShapeGraphicAttribute.getDescent()
  • TextLayout.getDescent()


getDescription

getDescription o7planning.org
  • BasicFileChooserUI.AcceptAllFileFilter.getDescription()
  • BasicFileChooserUI.BasicFileView.getDescription(File)
  • CompositeType.getDescription(String)
  • FileFilter.getDescription()
  • FileNameExtensionFilter.getDescription()
  • FileView.getDescription(File)
  • HyperlinkEvent.getDescription()
  • IIOServiceProvider.getDescription(Locale)
  • ImageIcon.getDescription()
  • JFileChooser.getDescription(File)
  • LookAndFeel.getDescription()
  • MBeanFeatureInfo.getDescription()
  • MBeanInfo.getDescription()
  • MetalLookAndFeel.getDescription()
  • MidiDevice.Info.getDescription()
  • Mixer.Info.getDescription()
  • ModelMBeanInfo.getDescription()
  • MultiLookAndFeel.getDescription()
  • NimbusLookAndFeel.getDescription()
  • OpenMBeanConstructorInfo.getDescription()
  • OpenMBeanInfo.getDescription()
  • OpenMBeanOperationInfo.getDescription()
  • OpenMBeanParameterInfo.getDescription()
  • OpenType.getDescription()
  • PatternSyntaxException.getDescription()
  • RoleInfo.getDescription()
  • Soundbank.getDescription()
  • StandardMBean.getDescription(MBeanOperationInfo, MBeanParameterInfo, int)
  • StandardMBean.getDescription(MBeanOperationInfo)
  • StandardMBean.getDescription(MBeanConstructorInfo, MBeanParameterInfo, int)
  • StandardMBean.getDescription(MBeanConstructorInfo)
  • StandardMBean.getDescription(MBeanAttributeInfo)
  • StandardMBean.getDescription(MBeanFeatureInfo)
  • StandardMBean.getDescription(MBeanInfo)
  • SynthLookAndFeel.getDescription()


getDescriptor

getDescriptor o7planning.org
  • DescriptorRead.getDescriptor()
  • MBeanFeatureInfo.getDescriptor()
  • MBeanInfo.getDescriptor()
  • ModelMBeanAttributeInfo.getDescriptor()
  • ModelMBeanConstructorInfo.getDescriptor()
  • ModelMBeanInfo.getDescriptor(String, String)
  • ModelMBeanInfoSupport.getDescriptor()
  • ModelMBeanInfoSupport.getDescriptor(String, String)
  • ModelMBeanInfoSupport.getDescriptor(String)
  • ModelMBeanNotificationInfo.getDescriptor()
  • ModelMBeanOperationInfo.getDescriptor()


getDescriptors

getDescriptors o7planning.org
  • ModelMBeanInfo.getDescriptors(String)
  • ModelMBeanInfoSupport.getDescriptors(String)


getDesignAxisDefaults

getDesignAxisDefaults o7planning.org
  • MultipleMaster.getDesignAxisDefaults()


getDesignAxisNames

getDesignAxisNames o7planning.org
  • MultipleMaster.getDesignAxisNames()


getDesignAxisRanges

getDesignAxisRanges o7planning.org
  • MultipleMaster.getDesignAxisRanges()


getDesktop

getDesktop o7planning.org
  • Desktop.getDesktop()


getDesktopColor

getDesktopColor o7planning.org
  • MetalLookAndFeel.getDesktopColor()
  • MetalTheme.getDesktopColor()
  • OceanTheme.getDesktopColor()


getDesktopIcon

getDesktopIcon o7planning.org
  • JInternalFrame.getDesktopIcon()


getDesktopIconBorder

getDesktopIconBorder o7planning.org
  • MetalBorders.getDesktopIconBorder()


getDesktopManager

getDesktopManager o7planning.org
  • BasicInternalFrameUI.getDesktopManager()
  • JDesktopPane.getDesktopManager()


getDesktopPane

getDesktopPane o7planning.org
  • JInternalFrame.getDesktopPane()
  • JInternalFrame.JDesktopIcon.getDesktopPane()


getDesktopPaneForComponent

getDesktopPaneForComponent o7planning.org
  • JOptionPane.getDesktopPaneForComponent(Component)


getDesktopProperty

getDesktopProperty o7planning.org
  • Toolkit.getDesktopProperty(String)


getDesktopPropertyValue

getDesktopPropertyValue o7planning.org
  • LookAndFeel.getDesktopPropertyValue(String, Object)


getDestination

getDestination o7planning.org
  • ImageReadParam.getDestination()
  • ImageReader.getDestination(ImageReadParam, Iterator<ImageTypeSpecifier>, int, int)
  • JobAttributes.getDestination()


getDestinationBands

getDestinationBands o7planning.org
  • ImageReadParam.getDestinationBands()


getDestinationOffset

getDestinationOffset o7planning.org
  • IIOParam.getDestinationOffset()


getDestinationType

getDestinationType o7planning.org
  • IIOParam.getDestinationType()


getDetail

getDetail o7planning.org
  • SOAPFault.getDetail()
  • UIEvent.getDetail()


getDetailEntries

getDetailEntries o7planning.org
  • Detail.getDetailEntries()


getDeterminant

getDeterminant o7planning.org
  • AffineTransform.getDeterminant()


getDevice

getDevice o7planning.org
  • GraphicsConfiguration.getDevice()
  • MidiDeviceProvider.getDevice(MidiDevice.Info)
  • PointerInfo.getDevice()


getDeviceConfiguration

getDeviceConfiguration o7planning.org
  • Graphics2D.getDeviceConfiguration()


getDeviceInfo

getDeviceInfo o7planning.org
  • MidiDevice.getDeviceInfo()
  • MidiDeviceProvider.getDeviceInfo()


getDiagnostics

getDiagnostics o7planning.org
  • DiagnosticCollector.getDiagnostics()


getDialog

getDialog o7planning.org
  • JobAttributes.getDialog()


getDialogTitle

getDialogTitle o7planning.org
  • BasicFileChooserUI.getDialogTitle(JFileChooser)
  • FileChooserUI.getDialogTitle(JFileChooser)
  • JFileChooser.getDialogTitle()
  • MultiFileChooserUI.getDialogTitle(JFileChooser)


getDialogType

getDialogType o7planning.org
  • JFileChooser.getDialogType()


getDifferenceMode

getDifferenceMode o7planning.org
  • CounterMonitor.getDifferenceMode()
  • CounterMonitorMBean.getDifferenceMode()
  • GaugeMonitor.getDifferenceMode()
  • GaugeMonitorMBean.getDifferenceMode()


getDigestAlgorithm

getDigestAlgorithm o7planning.org
  • MGF1ParameterSpec.getDigestAlgorithm()
  • OAEPParameterSpec.getDigestAlgorithm()
  • PSSParameterSpec.getDigestAlgorithm()


getDigestInputStream

getDigestInputStream o7planning.org
  • Reference.getDigestInputStream()


getDigestLength

getDigestLength o7planning.org
  • MessageDigest.getDigestLength()


getDigestMethod

getDigestMethod o7planning.org
  • Reference.getDigestMethod()


getDigestValue

getDigestValue o7planning.org
  • Reference.getDigestValue()


getDigit

getDigit o7planning.org
  • DecimalFormatSymbols.getDigit()


getDimension

getDimension o7planning.org
  • ArrayType.getDimension()
  • UIDefaults.getDimension(Object, Locale)
  • UIDefaults.getDimension(Object)
  • UIManager.getDimension(Object, Locale)
  • UIManager.getDimension(Object)


getDirection

getDirection o7planning.org
  • BasicArrowButton.getDirection()
  • DefaultStyledDocument.ElementSpec.getDirection()


getDirectionality

getDirectionality o7planning.org
  • Character.getDirectionality(int)
  • Character.getDirectionality(char)


getDirectories

getDirectories o7planning.org
  • BasicDirectoryModel.getDirectories()


getDirectory

getDirectory o7planning.org
  • BasicFileChooserUI.getDirectory()
  • FileDialog.getDirectory()


getDirectoryName

getDirectoryName o7planning.org
  • BasicFileChooserUI.getDirectoryName()
  • MetalFileChooserUI.getDirectoryName()


getDirtyRegion

getDirtyRegion o7planning.org
  • RepaintManager.getDirtyRegion(JComponent)


getDisabledIcon

getDisabledIcon o7planning.org
  • AbstractButton.getDisabledIcon()
  • JLabel.getDisabledIcon()
  • LookAndFeel.getDisabledIcon(JComponent, Icon)
  • MetalLookAndFeel.getDisabledIcon(JComponent, Icon)
  • NimbusLookAndFeel.getDisabledIcon(JComponent, Icon)


getDisabledIconAt

getDisabledIconAt o7planning.org
  • JTabbedPane.getDisabledIconAt(int)


getDisabledObjectNames

getDisabledObjectNames o7planning.org
  • MBeanServerNotificationFilter.getDisabledObjectNames()


getDisabledSelectedIcon

getDisabledSelectedIcon o7planning.org
  • AbstractButton.getDisabledSelectedIcon()
  • LookAndFeel.getDisabledSelectedIcon(JComponent, Icon)
  • MetalLookAndFeel.getDisabledSelectedIcon(JComponent, Icon)


getDisabledTextColor

getDisabledTextColor o7planning.org
  • JTextComponent.getDisabledTextColor()
  • MetalButtonUI.getDisabledTextColor()
  • MetalRadioButtonUI.getDisabledTextColor()
  • MetalToggleButtonUI.getDisabledTextColor()


getDiscard

getDiscard o7planning.org
  • HttpCookie.getDiscard()


getDismissDelay

getDismissDelay o7planning.org
  • ToolTipManager.getDismissDelay()


getDisplayCountry

getDisplayCountry o7planning.org
  • Locale.getDisplayCountry(Locale)
  • Locale.getDisplayCountry()
  • LocaleNameProvider.getDisplayCountry(String, Locale)


getDisplayedMnemonic

getDisplayedMnemonic o7planning.org
  • JLabel.getDisplayedMnemonic()


getDisplayedMnemonicIndex

getDisplayedMnemonicIndex o7planning.org
  • AbstractButton.getDisplayedMnemonicIndex()
  • AbstractColorChooserPanel.getDisplayedMnemonicIndex()
  • JLabel.getDisplayedMnemonicIndex()


getDisplayedMnemonicIndexAt

getDisplayedMnemonicIndexAt o7planning.org
  • JTabbedPane.getDisplayedMnemonicIndexAt(int)


getDisplayFormatter

getDisplayFormatter o7planning.org
  • DefaultFormatterFactory.getDisplayFormatter()


getDisplayLanguage

getDisplayLanguage o7planning.org
  • Locale.getDisplayLanguage(Locale)
  • Locale.getDisplayLanguage()
  • LocaleNameProvider.getDisplayLanguage(String, Locale)


getDisplayMode

getDisplayMode o7planning.org
  • GraphicsDevice.getDisplayMode()


getDisplayModes

getDisplayModes o7planning.org
  • GraphicsDevice.getDisplayModes()


getDisplayName

getDisplayName o7planning.org
  • AbstractColorChooserPanel.getDisplayName()
  • Calendar.getDisplayName(int, int, Locale)
  • CalendarNameProvider.getDisplayName(String, int, int, int, Locale)
  • ChronoField.getDisplayName(Locale)
  • Chronology.getDisplayName(TextStyle, Locale)
  • Currency.getDisplayName(Locale)
  • Currency.getDisplayName()
  • CurrencyNameProvider.getDisplayName(String, Locale)
  • DayOfWeek.getDisplayName(TextStyle, Locale)
  • Era.getDisplayName(TextStyle, Locale)
  • FeatureDescriptor.getDisplayName()
  • Locale.getDisplayName(Locale)
  • Locale.getDisplayName()
  • Month.getDisplayName(TextStyle, Locale)
  • NetworkInterface.getDisplayName()
  • TemporalField.getDisplayName(Locale)
  • TimeZone.getDisplayName(boolean, int, Locale)
  • TimeZone.getDisplayName(boolean, int)
  • TimeZone.getDisplayName(Locale)
  • TimeZone.getDisplayName()
  • TimeZoneNameProvider.getDisplayName(String, boolean, int, Locale)
  • ZoneId.getDisplayName(TextStyle, Locale)


getDisplayNames

getDisplayNames o7planning.org
  • Calendar.getDisplayNames(int, int, Locale)
  • CalendarNameProvider.getDisplayNames(String, int, int, Locale)


getDisplayScript

getDisplayScript o7planning.org
  • Locale.getDisplayScript(Locale)
  • Locale.getDisplayScript()
  • LocaleNameProvider.getDisplayScript(String, Locale)


getDisplaySize

getDisplaySize o7planning.org
  • BasicComboBoxUI.getDisplaySize()


getDisplayVariant

getDisplayVariant o7planning.org
  • Locale.getDisplayVariant(Locale)
  • Locale.getDisplayVariant()
  • LocaleNameProvider.getDisplayVariant(String, Locale)


getDivider

getDivider o7planning.org
  • BasicSplitPaneUI.getDivider()


getDividerBorderSize

getDividerBorderSize o7planning.org
  • BasicSplitPaneUI.getDividerBorderSize()


getDividerLocation

getDividerLocation o7planning.org
  • BasicSplitPaneUI.getDividerLocation(JSplitPane)
  • JSplitPane.getDividerLocation()
  • MultiSplitPaneUI.getDividerLocation(JSplitPane)
  • SplitPaneUI.getDividerLocation(JSplitPane)


getDividerSize

getDividerSize o7planning.org
  • BasicSplitPaneDivider.getDividerSize()
  • JSplitPane.getDividerSize()


getDivisionType

getDivisionType o7planning.org
  • MidiFileFormat.getDivisionType()
  • Sequence.getDivisionType()


getDoc

getDoc o7planning.org
  • MultiDoc.getDoc()


getDocComment

getDocComment o7planning.org
  • Elements.getDocComment(Element)


getDocFlavor

getDocFlavor o7planning.org
  • Doc.getDocFlavor()
  • SimpleDoc.getDocFlavor()


getDockingColor

getDockingColor o7planning.org
  • BasicToolBarUI.getDockingColor()


getDoctype

getDoctype o7planning.org
  • Document.getDoctype()


getDocument

getDocument o7planning.org
  • AbstractDocument.AbstractElement.getDocument()
  • AbstractDocument.DefaultDocumentEvent.getDocument()
  • AbstractView.getDocument()
  • AbstractWriter.getDocument()
  • DocumentEvent.getDocument()
  • DocumentFilter.FilterBypass.getDocument()
  • Element.getDocument()
  • JTextComponent.getDocument()
  • View.getDocument()


getDocumentBase

getDocumentBase o7planning.org
  • Applet.getDocumentBase()
  • AppletStub.getDocumentBase()
  • MLetContent.getDocumentBase()


getDocumentElement

getDocumentElement o7planning.org
  • Document.getDocumentElement()


getDocumentFilter

getDocumentFilter o7planning.org
  • AbstractDocument.getDocumentFilter()
  • DefaultFormatter.getDocumentFilter()
  • JFormattedTextField.AbstractFormatter.getDocumentFilter()


getDocumentListeners

getDocumentListeners o7planning.org
  • AbstractDocument.getDocumentListeners()


getDocumentProperties

getDocumentProperties o7planning.org
  • AbstractDocument.getDocumentProperties()


getDocumentTypeDeclaration

getDocumentTypeDeclaration o7planning.org
  • DTD.getDocumentTypeDeclaration()


getDocumentURI

getDocumentURI o7planning.org
  • Document.getDocumentURI()


getDoInput

getDoInput o7planning.org
  • URLConnection.getDoInput()


getDomain

getDomain o7planning.org
  • HttpCookie.getDomain()
  • ObjectName.getDomain()


getDomainCombiner

getDomainCombiner o7planning.org
  • AccessControlContext.getDomainCombiner()


getDomains

getDomains o7planning.org
  • MBeanServer.getDomains()
  • MBeanServerConnection.getDomains()
  • RMIConnection.getDomains(Subject)
  • RMIConnectionImpl.getDomains(Subject)
  • RMIConnectionImpl_Stub.getDomains(Subject)


getDomConfig

getDomConfig o7planning.org
  • Document.getDomConfig()
  • LSParser.getDomConfig()
  • LSSerializer.getDomConfig()


getDOMImplementation

getDOMImplementation o7planning.org
  • DOMImplementationRegistry.getDOMImplementation(String)
  • DOMImplementationSource.getDOMImplementation(String)
  • DocumentBuilder.getDOMImplementation()


getDOMImplementationList

getDOMImplementationList o7planning.org
  • DOMImplementationRegistry.getDOMImplementationList(String)
  • DOMImplementationSource.getDOMImplementationList(String)


getDoOutput

getDoOutput o7planning.org
  • URLConnection.getDoOutput()


getDot

getDot o7planning.org
  • Caret.getDot()
  • CaretEvent.getDot()
  • DefaultCaret.getDot()


getDotBias

getDotBias o7planning.org
  • DefaultCaret.getDotBias()


getDouble

getDouble o7planning.org
  • AbstractPreferences.getDouble(String, double)
  • Array.getDouble(Object, int)
  • ByteBuffer.getDouble(int)
  • ByteBuffer.getDouble()
  • CallableStatement.getDouble(String)
  • CallableStatement.getDouble(int)
  • Field.getDouble(Object)
  • Preferences.getDouble(String, double)
  • ResultSet.getDouble(String)
  • ResultSet.getDouble(int)


getDoubleBufferMaximumSize

getDoubleBufferMaximumSize o7planning.org
  • RepaintManager.getDoubleBufferMaximumSize()


getDoubleParameter

getDoubleParameter o7planning.org
  • ParameterBlock.getDoubleParameter(int)


getDragAction

getDragAction o7planning.org
  • DragGestureEvent.getDragAction()


getDragEnabled

getDragEnabled o7planning.org
  • JColorChooser.getDragEnabled()
  • JFileChooser.getDragEnabled()
  • JList.getDragEnabled()
  • JTable.getDragEnabled()
  • JTextComponent.getDragEnabled()
  • JTree.getDragEnabled()


getDraggedColumn

getDraggedColumn o7planning.org
  • JTableHeader.getDraggedColumn()


getDraggedDistance

getDraggedDistance o7planning.org
  • JTableHeader.getDraggedDistance()


getDragImage

getDragImage o7planning.org
  • TransferHandler.getDragImage()


getDragImageOffset

getDragImageOffset o7planning.org
  • TransferHandler.getDragImageOffset()


getDragMode

getDragMode o7planning.org
  • JDesktopPane.getDragMode()


getDragOrigin

getDragOrigin o7planning.org
  • DragGestureEvent.getDragOrigin()


getDragSource

getDragSource o7planning.org
  • DragGestureEvent.getDragSource()
  • DragGestureRecognizer.getDragSource()
  • DragSourceContext.getDragSource()


getDragSourceContext

getDragSourceContext o7planning.org
  • DragSourceEvent.getDragSourceContext()


getDragSourceListeners

getDragSourceListeners o7planning.org
  • DragSource.getDragSourceListeners()


getDragSourceMotionListeners

getDragSourceMotionListeners o7planning.org
  • DragSource.getDragSourceMotionListeners()


getDragThreshold

getDragThreshold o7planning.org
  • DragSource.getDragThreshold()


getDrawGraphics

getDrawGraphics o7planning.org
  • BufferStrategy.getDrawGraphics()
  • Component.BltBufferStrategy.getDrawGraphics()
  • Component.FlipBufferStrategy.getDrawGraphics()


getDrawsLayeredHighlights

getDrawsLayeredHighlights o7planning.org
  • DefaultHighlighter.getDrawsLayeredHighlights()


getDriver

getDriver o7planning.org
  • DriverManager.getDriver(String)


getDriverMajorVersion

getDriverMajorVersion o7planning.org
  • DatabaseMetaData.getDriverMajorVersion()


getDriverMinorVersion

getDriverMinorVersion o7planning.org
  • DatabaseMetaData.getDriverMinorVersion()


getDriverName

getDriverName o7planning.org
  • DatabaseMetaData.getDriverName()


getDrivers

getDrivers o7planning.org
  • DriverManager.getDrivers()


getDriverVersion

getDriverVersion o7planning.org
  • DatabaseMetaData.getDriverVersion()


getDropAction

getDropAction o7planning.org
  • DragSourceDragEvent.getDropAction()
  • DragSourceDropEvent.getDropAction()
  • DropTargetDragEvent.getDropAction()
  • DropTargetDropEvent.getDropAction()
  • TransferHandler.TransferSupport.getDropAction()


getDropLineRect

getDropLineRect o7planning.org
  • BasicTreeUI.getDropLineRect(JTree.DropLocation)


getDropLocation

getDropLocation o7planning.org
  • JList.getDropLocation()
  • JTable.getDropLocation()
  • JTextComponent.getDropLocation()
  • JTree.getDropLocation()
  • TransferHandler.TransferSupport.getDropLocation()


getDropMode

getDropMode o7planning.org
  • JList.getDropMode()
  • JTable.getDropMode()
  • JTextComponent.getDropMode()
  • JTree.getDropMode()


getDropPoint

getDropPoint o7planning.org
  • TransferHandler.DropLocation.getDropPoint()


getDropSuccess

getDropSuccess o7planning.org
  • DragSourceDropEvent.getDropSuccess()


getDropTarget

getDropTarget o7planning.org
  • Component.getDropTarget()
  • DropTargetContext.getDropTarget()


getDropTargetContext

getDropTargetContext o7planning.org
  • DropTarget.getDropTargetContext()
  • DropTargetEvent.getDropTargetContext()


getDSTSavings

getDSTSavings o7planning.org
  • SimpleTimeZone.getDSTSavings()
  • TimeZone.getDSTSavings()


getDTD

getDTD o7planning.org
  • DTD.getDTD(String)


getDTDHandler

getDTDHandler o7planning.org
  • ParserAdapter.getDTDHandler()
  • XMLFilterImpl.getDTDHandler()
  • XMLReader.getDTDHandler()


getDTDType

getDTDType o7planning.org
  • Attribute.getDTDType()


getDuration

getDuration o7planning.org
  • ChronoUnit.getDuration()
  • TemporalUnit.getDuration()
  • ZoneOffsetTransition.getDuration()


getEarliestSequenceNumber

getEarliestSequenceNumber o7planning.org
  • NotificationResult.getEarliestSequenceNumber()


getEarlyReflectionDelay

getEarlyReflectionDelay o7planning.org
  • ReverbType.getEarlyReflectionDelay()


getEarlyReflectionIntensity

getEarlyReflectionIntensity o7planning.org
  • ReverbType.getEarlyReflectionIntensity()


getEastPane

getEastPane o7planning.org
  • BasicInternalFrameUI.getEastPane()


getEchoChar

getEchoChar o7planning.org
  • JPasswordField.getEchoChar()
  • TextField.getEchoChar()


getEdgeCondition

getEdgeCondition o7planning.org
  • ConvolveOp.getEdgeCondition()


getEdit

getEdit o7planning.org
  • UndoableEditEvent.getEdit()


getEditFormatter

getEditFormatter o7planning.org
  • DefaultFormatterFactory.getEditFormatter()


getEditingColumn

getEditingColumn o7planning.org
  • JTable.getEditingColumn()


getEditingPath

getEditingPath o7planning.org
  • BasicTreeUI.getEditingPath(JTree)
  • JTree.getEditingPath()
  • MultiTreeUI.getEditingPath(JTree)
  • TreeUI.getEditingPath(JTree)


getEditingRow

getEditingRow o7planning.org
  • JTable.getEditingRow()


getEditor

getEditor o7planning.org
  • JComboBox.getEditor()
  • JSpinner.getEditor()
  • StyledEditorKit.StyledTextAction.getEditor(ActionEvent)


getEditorComponent

getEditorComponent o7planning.org
  • BasicComboBoxEditor.getEditorComponent()
  • ComboBoxEditor.getEditorComponent()
  • JTable.getEditorComponent()


getEditorKit

getEditorKit o7planning.org
  • BasicEditorPaneUI.getEditorKit(JTextComponent)
  • BasicTextUI.getEditorKit(JTextComponent)
  • JEditorPane.getEditorKit()
  • MultiTextUI.getEditorKit(JTextComponent)
  • TextUI.getEditorKit(JTextComponent)


getEditorKitClassNameForContentType

getEditorKitClassNameForContentType o7planning.org
  • JEditorPane.getEditorKitClassNameForContentType(String)


getEditorKitForContentType

getEditorKitForContentType o7planning.org
  • JEditorPane.getEditorKitForContentType(String)


getEditorSearchPath

getEditorSearchPath o7planning.org
  • PropertyEditorManager.getEditorSearchPath()


getEffectiveKeyBits

getEffectiveKeyBits o7planning.org
  • RC2ParameterSpec.getEffectiveKeyBits()


getElem

getElem o7planning.org
  • DataBuffer.getElem(int, int)
  • DataBuffer.getElem(int)
  • DataBufferByte.getElem(int, int)
  • DataBufferByte.getElem(int)
  • DataBufferDouble.getElem(int, int)
  • DataBufferDouble.getElem(int)
  • DataBufferFloat.getElem(int, int)
  • DataBufferFloat.getElem(int)
  • DataBufferInt.getElem(int, int)
  • DataBufferInt.getElem(int)
  • DataBufferShort.getElem(int, int)
  • DataBufferShort.getElem(int)
  • DataBufferUShort.getElem(int, int)
  • DataBufferUShort.getElem(int)


getElemDouble

getElemDouble o7planning.org
  • DataBuffer.getElemDouble(int, int)
  • DataBuffer.getElemDouble(int)
  • DataBufferDouble.getElemDouble(int, int)
  • DataBufferDouble.getElemDouble(int)
  • DataBufferFloat.getElemDouble(int, int)
  • DataBufferFloat.getElemDouble(int)


getElement

getElement o7planning.org
  • AbstractDocument.AbstractElement.getElement(int)
  • AbstractDocument.BranchElement.getElement(int)
  • AbstractDocument.ElementEdit.getElement()
  • AbstractDocument.LeafElement.getElement(int)
  • DTD.getElement(int)
  • DTD.getElement(String)
  • DocumentEvent.ElementChange.getElement()
  • DomHandler.getElement(ResultT)
  • Element.getElement(int)
  • HTMLDocument.getElement(Element, Object, Object)
  • HTMLDocument.getElement(String)
  • TagElement.getElement()
  • View.getElement()
  • W3CDomHandler.getElement(DOMResult)


getElementAt

getElementAt o7planning.org
  • BasicDirectoryModel.getElementAt(int)
  • DefaultComboBoxModel.getElementAt(int)
  • DefaultListModel.getElementAt(int)
  • ListModel.getElementAt(int)
  • MetalFileChooserUI.DirectoryComboBoxModel.getElementAt(int)
  • MetalFileChooserUI.FilterComboBoxModel.getElementAt(int)


getElementById

getElementById o7planning.org
  • DOMCryptoContext.getElementById(String)
  • Document.getElementById(String)


getElementCount

getElementCount o7planning.org
  • AbstractDocument.AbstractElement.getElementCount()
  • AbstractDocument.BranchElement.getElementCount()
  • AbstractDocument.LeafElement.getElementCount()
  • Element.getElementCount()


getElementDescription

getElementDescription o7planning.org
  • IIOMetadataFormat.getElementDescription(String, Locale)
  • IIOMetadataFormatImpl.getElementDescription(String, Locale)


getElementIndex

getElementIndex o7planning.org
  • AbstractDocument.AbstractElement.getElementIndex(int)
  • AbstractDocument.BranchElement.getElementIndex(int)
  • AbstractDocument.LeafElement.getElementIndex(int)
  • Element.getElementIndex(int)


getElementIterator

getElementIterator o7planning.org
  • AbstractWriter.getElementIterator()


getElementMaxChildren

getElementMaxChildren o7planning.org
  • IIOMetadataFormat.getElementMaxChildren(String)
  • IIOMetadataFormatImpl.getElementMaxChildren(String)


getElementMinChildren

getElementMinChildren o7planning.org
  • IIOMetadataFormat.getElementMinChildren(String)
  • IIOMetadataFormatImpl.getElementMinChildren(String)


getElementName

getElementName o7planning.org
  • JAXBIntrospector.getElementName(Object)
  • SOAPElement.getElementName()


getElementOpenType

getElementOpenType o7planning.org
  • ArrayType.getElementOpenType()


getElementQName

getElementQName o7planning.org
  • SOAPElement.getElementQName()


getElements

getElements o7planning.org
  • ButtonGroup.getElements()
  • ContentModel.getElements(Vector<Element>)


getElementsAnnotatedWith

getElementsAnnotatedWith o7planning.org
  • RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation>)
  • RoundEnvironment.getElementsAnnotatedWith(TypeElement)


getElementsAt

getElementsAt o7planning.org
  • HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument, int)


getElementsByTagName

getElementsByTagName o7planning.org
  • Document.getElementsByTagName(String)
  • Element.getElementsByTagName(String)
  • IIOMetadataNode.getElementsByTagName(String)


getElementsByTagNameNS

getElementsByTagNameNS o7planning.org
  • Document.getElementsByTagNameNS(String, String)
  • Element.getElementsByTagNameNS(String, String)
  • IIOMetadataNode.getElementsByTagNameNS(String, String)


getElementText

getElementText o7planning.org
  • EventReaderDelegate.getElementText()
  • StreamReaderDelegate.getElementText()
  • XMLEventReader.getElementText()
  • XMLStreamReader.getElementText()


getElementTypeInfo

getElementTypeInfo o7planning.org
  • TypeInfoProvider.getElementTypeInfo()


getElementUtils

getElementUtils o7planning.org
  • ProcessingEnvironment.getElementUtils()


getElementValues

getElementValues o7planning.org
  • AnnotationMirror.getElementValues()


getElementValuesWithDefaults

getElementValuesWithDefaults o7planning.org
  • Elements.getElementValuesWithDefaults(AnnotationMirror)


getElemFloat

getElemFloat o7planning.org
  • DataBuffer.getElemFloat(int, int)
  • DataBuffer.getElemFloat(int)
  • DataBufferDouble.getElemFloat(int, int)
  • DataBufferDouble.getElemFloat(int)
  • DataBufferFloat.getElemFloat(int, int)
  • DataBufferFloat.getElemFloat(int)


getEmptySet

getEmptySet o7planning.org
  • AbstractDocument.AttributeContext.getEmptySet()
  • StyleContext.getEmptySet()


getEnabledAttributes

getEnabledAttributes o7planning.org
  • AttributeChangeNotificationFilter.getEnabledAttributes()


getEnabledCipherSuites

getEnabledCipherSuites o7planning.org
  • SSLEngine.getEnabledCipherSuites()
  • SSLServerSocket.getEnabledCipherSuites()
  • SSLSocket.getEnabledCipherSuites()
  • SslRMIServerSocketFactory.getEnabledCipherSuites()


getEnabledObjectNames

getEnabledObjectNames o7planning.org
  • MBeanServerNotificationFilter.getEnabledObjectNames()


getEnabledProtocols

getEnabledProtocols o7planning.org
  • SSLEngine.getEnabledProtocols()
  • SSLServerSocket.getEnabledProtocols()
  • SSLSocket.getEnabledProtocols()
  • SslRMIServerSocketFactory.getEnabledProtocols()


getEnabledTypes

getEnabledTypes o7planning.org
  • NotificationFilterSupport.getEnabledTypes()


getEnableSessionCreation

getEnableSessionCreation o7planning.org
  • SSLEngine.getEnableSessionCreation()
  • SSLServerSocket.getEnableSessionCreation()
  • SSLSocket.getEnableSessionCreation()


getEnclosedElements

getEnclosedElements o7planning.org
  • Element.getEnclosedElements()
  • PackageElement.getEnclosedElements()
  • TypeElement.getEnclosedElements()


getEnclosingClass

getEnclosingClass o7planning.org
  • Class.getEnclosingClass()


getEnclosingConstructor

getEnclosingConstructor o7planning.org
  • Class.getEnclosingConstructor()


getEnclosingElement

getEnclosingElement o7planning.org
  • Element.getEnclosingElement()
  • PackageElement.getEnclosingElement()
  • TypeElement.getEnclosingElement()
  • TypeParameterElement.getEnclosingElement()
  • VariableElement.getEnclosingElement()


getEnclosingMethod

getEnclosingMethod o7planning.org
  • Class.getEnclosingMethod()


getEnclosingType

getEnclosingType o7planning.org
  • DeclaredType.getEnclosingType()


getEncoded

getEncoded o7planning.org
  • AlgorithmParameters.getEncoded(String)
  • AlgorithmParameters.getEncoded()
  • CertPath.getEncoded(String)
  • CertPath.getEncoded()
  • Certificate.getEncoded()
  • Certificate.getEncoded()
  • EncodedKeySpec.getEncoded()
  • EncryptedPrivateKeyInfo.getEncoded()
  • KerberosKey.getEncoded()
  • KerberosTicket.getEncoded()
  • Key.getEncoded()
  • PKCS12Attribute.getEncoded()
  • PKCS8EncodedKeySpec.getEncoded()
  • PolicyQualifierInfo.getEncoded()
  • SNIServerName.getEncoded()
  • SecretKeySpec.getEncoded()
  • X500Principal.getEncoded()
  • X509CRL.getEncoded()
  • X509CRLEntry.getEncoded()
  • X509EncodedKeySpec.getEncoded()


getEncodedValue

getEncodedValue o7planning.org
  • BasicControl.getEncodedValue()
  • Control.getEncodedValue()
  • ExtendedRequest.getEncodedValue()
  • ExtendedResponse.getEncodedValue()
  • StartTlsRequest.getEncodedValue()
  • StartTlsResponse.getEncodedValue()


getEncoder

getEncoder o7planning.org
  • Base64.getEncoder()


getEncoding

getEncoding o7planning.org
  • AbstractMarshallerImpl.getEncoding()
  • AudioFormat.getEncoding()
  • Handler.getEncoding()
  • InputSource.getEncoding()
  • InputStreamReader.getEncoding()
  • LSInput.getEncoding()
  • LSOutput.getEncoding()
  • Locator2.getEncoding()
  • Locator2Impl.getEncoding()
  • OutputStreamWriter.getEncoding()
  • StreamReaderDelegate.getEncoding()
  • XMLObject.getEncoding()
  • XMLStreamReader.getEncoding()


getEncodings

getEncodings o7planning.org
  • CertPath.getEncodings()


getEncodingStyle

getEncodingStyle o7planning.org
  • SOAPElement.getEncodingStyle()


getEncryptedData

getEncryptedData o7planning.org
  • EncryptedPrivateKeyInfo.getEncryptedData()


getEnd

getEnd o7planning.org
  • SpinnerDateModel.getEnd()


getEndCap

getEndCap o7planning.org
  • BasicStroke.getEndCap()


getEndIndex

getEndIndex o7planning.org
  • AccessibleHyperlink.getEndIndex()
  • CharacterIterator.getEndIndex()
  • FieldPosition.getEndIndex()
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getEndIndex()
  • Segment.getEndIndex()
  • StringCharacterIterator.getEndIndex()


getEndOffset

getEndOffset o7planning.org
  • AbstractDocument.AbstractElement.getEndOffset()
  • AbstractDocument.BranchElement.getEndOffset()
  • AbstractDocument.LeafElement.getEndOffset()
  • AbstractWriter.getEndOffset()
  • Element.getEndOffset()
  • GlyphView.getEndOffset()
  • HTMLDocument.Iterator.getEndOffset()
  • Highlighter.Highlight.getEndOffset()
  • View.getEndOffset()


getEndPoint

getEndPoint o7planning.org
  • Arc2D.getEndPoint()
  • LinearGradientPaint.getEndPoint()


getEndpointIdentificationAlgorithm

getEndpointIdentificationAlgorithm o7planning.org
  • SSLParameters.getEndpointIdentificationAlgorithm()


getEndpointReference

getEndpointReference o7planning.org
  • BindingProvider.getEndpointReference(Class<T>)
  • BindingProvider.getEndpointReference()
  • Endpoint.getEndpointReference(Class<T>, Element...)
  • Endpoint.getEndpointReference(Element...)
  • WebServiceContext.getEndpointReference(Class<T>, Element...)
  • WebServiceContext.getEndpointReference(Element...)


getEndpoints

getEndpoints o7planning.org
  • EndpointContext.getEndpoints()


getEndPosition

getEndPosition o7planning.org
  • AbstractDocument.getEndPosition()
  • Diagnostic.getEndPosition()
  • Document.getEndPosition()


getEndTime

getEndTime o7planning.org
  • KerberosTicket.getEndTime()


getEngine

getEngine o7planning.org
  • CompiledScript.getEngine()


getEngineByExtension

getEngineByExtension o7planning.org
  • ScriptEngineManager.getEngineByExtension(String)


getEngineByMimeType

getEngineByMimeType o7planning.org
  • ScriptEngineManager.getEngineByMimeType(String)


getEngineByName

getEngineByName o7planning.org
  • ScriptEngineManager.getEngineByName(String)


getEngineFactories

getEngineFactories o7planning.org
  • ScriptEngineManager.getEngineFactories()


getEngineName

getEngineName o7planning.org
  • ScriptEngineFactory.getEngineName()


getEngineVersion

getEngineVersion o7planning.org
  • ScriptEngineFactory.getEngineVersion()


getEntities

getEntities o7planning.org
  • DTD.getEntities()
  • DocumentType.getEntities()


getEntity

getEntity o7planning.org
  • DTD.getEntity(int)
  • DTD.getEntity(String)


getEntityResolver

getEntityResolver o7planning.org
  • ParserAdapter.getEntityResolver()
  • XMLFilterImpl.getEntityResolver()
  • XMLReader.getEntityResolver()


getEntries

getEntries o7planning.org
  • Manifest.getEntries()


getEntry

getEntry o7planning.org
  • JarFile.getEntry(String)
  • KeyStore.getEntry(String, KeyStore.ProtectionParameter)
  • ZipFile.getEntry(String)


getEntryName

getEntryName o7planning.org
  • JarURLConnection.getEntryName()


getEnumConstants

getEnumConstants o7planning.org
  • Class.getEnumConstants()


getEnumValueTable

getEnumValueTable o7planning.org
  • Chromaticity.getEnumValueTable()
  • ColorSupported.getEnumValueTable()
  • Compression.getEnumValueTable()
  • DialogTypeSelection.getEnumValueTable()
  • EnumSyntax.getEnumValueTable()
  • Fidelity.getEnumValueTable()
  • Finishings.getEnumValueTable()
  • JobSheets.getEnumValueTable()
  • JobState.getEnumValueTable()
  • JobStateReason.getEnumValueTable()
  • MediaName.getEnumValueTable()
  • MediaSizeName.getEnumValueTable()
  • MediaTray.getEnumValueTable()
  • MultipleDocumentHandling.getEnumValueTable()
  • OrientationRequested.getEnumValueTable()
  • PDLOverrideSupported.getEnumValueTable()
  • PresentationDirection.getEnumValueTable()
  • PrintQuality.getEnumValueTable()
  • PrinterIsAcceptingJobs.getEnumValueTable()
  • PrinterState.getEnumValueTable()
  • PrinterStateReason.getEnumValueTable()
  • ReferenceUriSchemesSupported.getEnumValueTable()
  • Severity.getEnumValueTable()
  • SheetCollate.getEnumValueTable()
  • Sides.getEnumValueTable()


getenv

getenv o7planning.org
  • System.getenv()
  • System.getenv(String)


getEnvelope

getEnvelope o7planning.org
  • SOAPPart.getEnvelope()


getEnvironment

getEnvironment o7planning.org
  • CannotProceedException.getEnvironment()
  • Context.getEnvironment()
  • InitialContext.getEnvironment()


getEon

getEon o7planning.org
  • XMLGregorianCalendar.getEon()


getEonAndYear

getEonAndYear o7planning.org
  • XMLGregorianCalendar.getEonAndYear()


getEpochSecond

getEpochSecond o7planning.org
  • Instant.getEpochSecond()


getEra

getEra o7planning.org
  • ChronoLocalDate.getEra()
  • HijrahDate.getEra()
  • JapaneseDate.getEra()
  • LocalDate.getEra()
  • MinguoDate.getEra()
  • ThaiBuddhistDate.getEra()


getEras

getEras o7planning.org
  • DateFormatSymbols.getEras()


getErrorCode

getErrorCode o7planning.org
  • JAXBException.getErrorCode()
  • SQLException.getErrorCode()
  • TypeConstraintException.getErrorCode()


getErrorHandler

getErrorHandler o7planning.org
  • ParserAdapter.getErrorHandler()
  • SchemaFactory.getErrorHandler()
  • Validator.getErrorHandler()
  • ValidatorHandler.getErrorHandler()
  • XMLFilterImpl.getErrorHandler()
  • XMLReader.getErrorHandler()


getErrorIndex

getErrorIndex o7planning.org
  • DateTimeParseException.getErrorIndex()
  • IllformedLocaleException.getErrorIndex()
  • ParsePosition.getErrorIndex()


getErrorListener

getErrorListener o7planning.org
  • Transformer.getErrorListener()
  • TransformerFactory.getErrorListener()


getErrorManager

getErrorManager o7planning.org
  • Handler.getErrorManager()


getErrorOffset

getErrorOffset o7planning.org
  • ParseException.getErrorOffset()


getErrorsAny

getErrorsAny o7planning.org
  • MediaTracker.getErrorsAny()


getErrorsID

getErrorsID o7planning.org
  • MediaTracker.getErrorsID(int)


getErrorStream

getErrorStream o7planning.org
  • HttpURLConnection.getErrorStream()
  • Process.getErrorStream()


getErrorWriter

getErrorWriter o7planning.org
  • ScriptContext.getErrorWriter()
  • SimpleScriptContext.getErrorWriter()


getEscapeProcessing

getEscapeProcessing o7planning.org
  • BaseRowSet.getEscapeProcessing()
  • RowSet.getEscapeProcessing()


getEstimatedMajorSpan

getEstimatedMajorSpan o7planning.org
  • AsyncBoxView.getEstimatedMajorSpan()


getEtchedBorderUIResource

getEtchedBorderUIResource o7planning.org
  • BorderUIResource.getEtchedBorderUIResource()


getEtchedInsets

getEtchedInsets o7planning.org
  • BasicGraphicsUtils.getEtchedInsets()


getEtchType

getEtchType o7planning.org
  • EtchedBorder.getEtchType()


getEventAllocator

getEventAllocator o7planning.org
  • XMLInputFactory.getEventAllocator()


getEventContext

getEventContext o7planning.org
  • NamingEvent.getEventContext()
  • NamingExceptionEvent.getEventContext()


getEventHandler

getEventHandler o7planning.org
  • AbstractMarshallerImpl.getEventHandler()
  • AbstractUnmarshallerImpl.getEventHandler()
  • Binder.getEventHandler()
  • Marshaller.getEventHandler()
  • Unmarshaller.getEventHandler()
  • Validator.getEventHandler()


getEventMask

getEventMask o7planning.org
  • AWTEventListenerProxy.getEventMask()


getEventPhase

getEventPhase o7planning.org
  • Event.getEventPhase()


getEventPropertyName

getEventPropertyName o7planning.org
  • EventHandler.getEventPropertyName()


getEvents

getEvents o7planning.org
  • ValidationEventCollector.getEvents()


getEventSetDescriptors

getEventSetDescriptors o7planning.org
  • BeanInfo.getEventSetDescriptors()
  • SimpleBeanInfo.getEventSetDescriptors()


getEventType

getEventType o7planning.org
  • HyperlinkEvent.getEventType()
  • StreamReaderDelegate.getEventType()
  • XMLEvent.getEventType()
  • XMLStreamReader.getEventType()


getExactSizeIfKnown

getExactSizeIfKnown o7planning.org
  • Spliterator.getExactSizeIfKnown()


getException

getException o7planning.org
  • ClassNotFoundException.getException()
  • ExceptionInInitializerError.getException()
  • FactoryConfigurationError.getException()
  • FactoryConfigurationError.getException()
  • ForkJoinTask.getException()
  • InvocationEvent.getException()
  • NamingExceptionEvent.getException()
  • PrivilegedActionException.getException()
  • SAXException.getException()
  • SortResponseControl.getException()
  • TransformerException.getException()
  • TransformerFactoryConfigurationError.getException()
  • UnsolicitedNotification.getException()


getExceptionListener

getExceptionListener o7planning.org
  • Encoder.getExceptionListener()
  • XMLDecoder.getExceptionListener()


getExceptionTypes

getExceptionTypes o7planning.org
  • Constructor.getExceptionTypes()
  • Executable.getExceptionTypes()
  • Method.getExceptionTypes()


getExclusiveOwnerThread

getExclusiveOwnerThread o7planning.org
  • AbstractOwnableSynchronizer.getExclusiveOwnerThread()


getExclusiveQueuedThreads

getExclusiveQueuedThreads o7planning.org
  • AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads()
  • AbstractQueuedSynchronizer.getExclusiveQueuedThreads()


getExecuteExistingDelayedTasksAfterShutdownPolicy

getExecuteExistingDelayedTasksAfterShutdownPolicy o7planning.org
  • ScheduledThreadPoolExecutor.getExecuteExistingDelayedTasksAfterShutdownPolicy()


getExecutor

getExecutor o7planning.org
  • Endpoint.getExecutor()
  • Service.getExecutor()
  • ServiceDelegate.getExecutor()


getExemptionMechanism

getExemptionMechanism o7planning.org
  • Cipher.getExemptionMechanism()


getExp

getExp o7planning.org
  • BadBinaryOpValueExpException.getExp()


getExpandedDescendants

getExpandedDescendants o7planning.org
  • JTree.getExpandedDescendants(TreePath)


getExpandedIcon

getExpandedIcon o7planning.org
  • BasicTreeUI.getExpandedIcon()
  • SynthTreeUI.getExpandedIcon()


getExpandedState

getExpandedState o7planning.org
  • AbstractLayoutCache.getExpandedState(TreePath)
  • FixedHeightLayoutCache.getExpandedState(TreePath)
  • VariableHeightLayoutCache.getExpandedState(TreePath)


getExpandsSelectedPaths

getExpandsSelectedPaths o7planning.org
  • JTree.getExpandsSelectedPaths()


getExpectedPolicies

getExpectedPolicies o7planning.org
  • PolicyNode.getExpectedPolicies()


getExpiration

getExpiration o7planning.org
  • URLConnection.getExpiration()


getExplanation

getExplanation o7planning.org
  • NamingException.getExplanation()


getExponent

getExponent o7planning.org
  • Math.getExponent(double)
  • Math.getExponent(float)
  • RSAOtherPrimeInfo.getExponent()
  • StrictMath.getExponent(double)
  • StrictMath.getExponent(float)


getExponentSeparator

getExponentSeparator o7planning.org
  • DecimalFormatSymbols.getExponentSeparator()


getExponentSize

getExponentSize o7planning.org
  • DHGenParameterSpec.getExponentSize()


getExportedKeys

getExportedKeys o7planning.org
  • DatabaseMetaData.getExportedKeys(String, String, String)


getExpression

getExpression o7planning.org
  • XPathType.getExpression()


getExtendedCacheKeys

getExtendedCacheKeys o7planning.org
  • AbstractRegionPainter.getExtendedCacheKeys(JComponent)


getExtendedKeyCode

getExtendedKeyCode o7planning.org
  • KeyEvent.getExtendedKeyCode()


getExtendedKeyCodeForChar

getExtendedKeyCodeForChar o7planning.org
  • KeyEvent.getExtendedKeyCodeForChar(int)


getExtendedKeyUsage

getExtendedKeyUsage o7planning.org
  • X509CertSelector.getExtendedKeyUsage()
  • X509Certificate.getExtendedKeyUsage()


getExtendedState

getExtendedState o7planning.org
  • Frame.getExtendedState()


getExtendsBound

getExtendsBound o7planning.org
  • WildcardType.getExtendsBound()


getExtension

getExtension o7planning.org
  • AudioFileFormat.Type.getExtension()
  • Locale.getExtension(char)


getExtensionKeys

getExtensionKeys o7planning.org
  • Locale.getExtensionKeys()


getExtensions

getExtensions o7planning.org
  • CertificateRevokedException.getExtensions()
  • FileNameExtensionFilter.getExtensions()
  • ScriptEngineFactory.getExtensions()


getExtensionValue

getExtensionValue o7planning.org
  • X509Extension.getExtensionValue(String)


getExtent

getExtent o7planning.org
  • BoundedRangeModel.getExtent()
  • DefaultBoundedRangeModel.getExtent()
  • JSlider.getExtent()


getExtentSize

getExtentSize o7planning.org
  • JViewport.getExtentSize()


getExternalElements

getExternalElements o7planning.org
  • PGPData.getExternalElements()


getExternalSubset

getExternalSubset o7planning.org
  • DefaultHandler2.getExternalSubset(String, String)
  • EntityResolver2.getExternalSubset(String, String)


getExtra

getExtra o7planning.org
  • ZipEntry.getExtra()


getExtraImageMetadataFormatNames

getExtraImageMetadataFormatNames o7planning.org
  • ImageReaderWriterSpi.getExtraImageMetadataFormatNames()


getExtraMetadataFormatNames

getExtraMetadataFormatNames o7planning.org
  • IIOMetadata.getExtraMetadataFormatNames()


getExtraNameCharacters

getExtraNameCharacters o7planning.org
  • DatabaseMetaData.getExtraNameCharacters()


getExtraStreamMetadataFormatNames

getExtraStreamMetadataFormatNames o7planning.org
  • ImageReaderWriterSpi.getExtraStreamMetadataFormatNames()


getFactory

getFactory o7planning.org
  • ForkJoinPool.getFactory()
  • ScriptEngine.getFactory()


getFactoryClassLocation

getFactoryClassLocation o7planning.org
  • Reference.getFactoryClassLocation()


getFactoryClassName

getFactoryClassName o7planning.org
  • Reference.getFactoryClassName()


getFailedProperties

getFailedProperties o7planning.org
  • SQLClientInfoException.getFailedProperties()


getFailureHandler

getFailureHandler o7planning.org
  • RMISocketFactory.getFailureHandler()


getFallbackLocale

getFallbackLocale o7planning.org
  • ResourceBundle.Control.getFallbackLocale(String, Locale)


getFamily

getFamily o7planning.org
  • Font.getFamily(Locale)
  • Font.getFamily()


getFault

getFault o7planning.org
  • SOAPBody.getFault()
  • SOAPFaultException.getFault()


getFaultActor

getFaultActor o7planning.org
  • SOAPFault.getFaultActor()


getFaultCode

getFaultCode o7planning.org
  • SOAPFault.getFaultCode()


getFaultCodeAsName

getFaultCodeAsName o7planning.org
  • SOAPFault.getFaultCodeAsName()


getFaultCodeAsQName

getFaultCodeAsQName o7planning.org
  • SOAPFault.getFaultCodeAsQName()


getFaultNode

getFaultNode o7planning.org
  • SOAPFault.getFaultNode()


getFaultReasonLocales

getFaultReasonLocales o7planning.org
  • SOAPFault.getFaultReasonLocales()


getFaultReasonText

getFaultReasonText o7planning.org
  • SOAPFault.getFaultReasonText(Locale)


getFaultReasonTexts

getFaultReasonTexts o7planning.org
  • SOAPFault.getFaultReasonTexts()


getFaultRole

getFaultRole o7planning.org
  • SOAPFault.getFaultRole()


getFaultString

getFaultString o7planning.org
  • SOAPFault.getFaultString()


getFaultStringLocale

getFaultStringLocale o7planning.org
  • SOAPFault.getFaultStringLocale()


getFaultSubcodes

getFaultSubcodes o7planning.org
  • SOAPFault.getFaultSubcodes()


getFD

getFD o7planning.org
  • FileInputStream.getFD()
  • FileOutputStream.getFD()
  • RandomAccessFile.getFD()


getFeature

getFeature o7planning.org
  • DOMImplementation.getFeature(String, String)
  • DocumentBuilderFactory.getFeature(String)
  • IIOMetadataNode.getFeature(String, String)
  • Node.getFeature(String, String)
  • ParserAdapter.getFeature(String)
  • SAXParserFactory.getFeature(String)
  • SchemaFactory.getFeature(String)
  • TransformerFactory.getFeature(String)
  • Validator.getFeature(String)
  • ValidatorHandler.getFeature(String)
  • XMLFilterImpl.getFeature(String)
  • XMLReader.getFeature(String)
  • XPathFactory.getFeature(String)


getFeedResolution

getFeedResolution o7planning.org
  • ResolutionSyntax.getFeedResolution(int)


getFeedResolutionDphi

getFeedResolutionDphi o7planning.org
  • ResolutionSyntax.getFeedResolutionDphi()


getFetchDirection

getFetchDirection o7planning.org
  • BaseRowSet.getFetchDirection()
  • ResultSet.getFetchDirection()
  • Statement.getFetchDirection()


getFetchSize

getFetchSize o7planning.org
  • BaseRowSet.getFetchSize()
  • ResultSet.getFetchSize()
  • Statement.getFetchSize()


GetField

GetField o7planning.org
  • ObjectInputStream.GetField.GetField()


getField

getField o7planning.org
  • Class.getField(String)
  • Duration.getField(DatatypeConstants.Field)
  • EllipticCurve.getField()
  • FieldPosition.getField()
  • ObjectStreamClass.getField(String)


getFieldAttribute

getFieldAttribute o7planning.org
  • FieldPosition.getFieldAttribute()


getFieldNames

getFieldNames o7planning.org
  • Descriptor.getFieldNames()
  • DescriptorSupport.getFieldNames()
  • ImmutableDescriptor.getFieldNames()


getFields

getFields o7planning.org
  • Class.getFields()
  • Descriptor.getFields()
  • DescriptorSupport.getFields()
  • ImmutableDescriptor.getFields()
  • InternationalFormatter.getFields(int)
  • ObjectStreamClass.getFields()
  • SerialJavaObject.getFields()


getFieldSize

getFieldSize o7planning.org
  • ECField.getFieldSize()
  • ECFieldF2m.getFieldSize()
  • ECFieldFp.getFieldSize()


getFieldValue

getFieldValue o7planning.org
  • Descriptor.getFieldValue(String)
  • DescriptorSupport.getFieldValue(String)
  • ImmutableDescriptor.getFieldValue(String)


getFieldValues

getFieldValues o7planning.org
  • Descriptor.getFieldValues(String...)
  • DescriptorSupport.getFieldValues(String...)
  • ImmutableDescriptor.getFieldValues(String...)


getFile

getFile o7planning.org
  • FileDataSource.getFile()
  • FileDialog.getFile()
  • FileSystemException.getFile()
  • URL.getFile()


getFileAttributeView

getFileAttributeView o7planning.org
  • FileSystemProvider.getFileAttributeView(Path, Class<V>, LinkOption...)
  • Files.getFileAttributeView(Path, Class<V>, LinkOption...)
  • SecureDirectoryStream.getFileAttributeView(T, Class<V>, LinkOption...)
  • SecureDirectoryStream.getFileAttributeView(Class<V>)


getFileChooser

getFileChooser o7planning.org
  • BasicFileChooserUI.getFileChooser()


getFileChooserDetailViewIcon

getFileChooserDetailViewIcon o7planning.org
  • MetalIconFactory.getFileChooserDetailViewIcon()


getFileChooserHomeFolderIcon

getFileChooserHomeFolderIcon o7planning.org
  • MetalIconFactory.getFileChooserHomeFolderIcon()


getFileChooserListViewIcon

getFileChooserListViewIcon o7planning.org
  • MetalIconFactory.getFileChooserListViewIcon()


getFileChooserNewFolderIcon

getFileChooserNewFolderIcon o7planning.org
  • MetalIconFactory.getFileChooserNewFolderIcon()


getFileChooserUpFolderIcon

getFileChooserUpFolderIcon o7planning.org
  • MetalIconFactory.getFileChooserUpFolderIcon()


getFileDescriptor

getFileDescriptor o7planning.org
  • DatagramSocketImpl.getFileDescriptor()
  • SocketImpl.getFileDescriptor()


getFileFilter

getFileFilter o7planning.org
  • JFileChooser.getFileFilter()


getFileForInput

getFileForInput o7planning.org
  • ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location, String, String)
  • JavaFileManager.getFileForInput(JavaFileManager.Location, String, String)


getFileForOutput

getFileForOutput o7planning.org
  • ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location, String, String, FileObject)
  • JavaFileManager.getFileForOutput(JavaFileManager.Location, String, String, FileObject)


getFileName

getFileName o7planning.org
  • BasicFileChooserUI.getFileName()
  • JobAttributes.getFileName()
  • MetalFileChooserUI.getFileName()
  • Path.getFileName()
  • ScriptException.getFileName()
  • StackTraceElement.getFileName()


getFilenameFilter

getFilenameFilter o7planning.org
  • FileDialog.getFilenameFilter()


getFileNameMap

getFileNameMap o7planning.org
  • URLConnection.getFileNameMap()


getFilePointer

getFilePointer o7planning.org
  • RandomAccessFile.getFilePointer()


getFiler

getFiler o7planning.org
  • ProcessingEnvironment.getFiler()


getFiles

getFiles o7planning.org
  • BasicDirectoryModel.getFiles()
  • FileDialog.getFiles()
  • FileSystemView.getFiles(File, boolean)


getFileSelectionMode

getFileSelectionMode o7planning.org
  • JFileChooser.getFileSelectionMode()


getFileStore

getFileStore o7planning.org
  • FileSystemProvider.getFileStore(Path)
  • Files.getFileStore(Path)


getFileStoreAttributeView

getFileStoreAttributeView o7planning.org
  • FileStore.getFileStoreAttributeView(Class<V>)


getFileStores

getFileStores o7planning.org
  • FileSystem.getFileStores()


getFileSuffixes

getFileSuffixes o7planning.org
  • ImageReaderWriterSpi.getFileSuffixes()


getFileSystem

getFileSystem o7planning.org
  • FileSystemProvider.getFileSystem(URI)
  • FileSystems.getFileSystem(URI)
  • Path.getFileSystem()


getFileSystemView

getFileSystemView o7planning.org
  • FileSystemView.getFileSystemView()
  • JFileChooser.getFileSystemView()


getFileView

getFileView o7planning.org
  • BasicFileChooserUI.getFileView(JFileChooser)
  • FileChooserUI.getFileView(JFileChooser)
  • JFileChooser.getFileView()
  • MultiFileChooserUI.getFileView(JFileChooser)


getFillsViewportHeight

getFillsViewportHeight o7planning.org
  • JTable.getFillsViewportHeight()


getFilter

getFilter o7planning.org
  • FilteredRowSet.getFilter()
  • Handler.getFilter()
  • LSParser.getFilter()
  • LSSerializer.getFilter()
  • Logger.getFilter()
  • XPathType.getFilter()


getFilterInstance

getFilterInstance o7planning.org
  • ImageFilter.getFilterInstance(ImageConsumer)


getFirst

getFirst o7planning.org
  • ArrayDeque.getFirst()
  • ConcurrentLinkedDeque.getFirst()
  • Deque.getFirst()
  • LinkedBlockingDeque.getFirst()
  • LinkedList.getFirst()


getFirstChild

getFirstChild o7planning.org
  • DefaultMutableTreeNode.getFirstChild()
  • IIOMetadataNode.getFirstChild()
  • Node.getFirstChild()


getFirstColumn

getFirstColumn o7planning.org
  • AccessibleTableModelChange.getFirstColumn()
  • JTable.AccessibleJTable.AccessibleJTableModelChange.getFirstColumn()


getFirstComponent

getFirstComponent o7planning.org
  • ContainerOrderFocusTraversalPolicy.getFirstComponent(Container)
  • DefaultFocusManager.getFirstComponent(Container)
  • FocusTraversalPolicy.getFirstComponent(Container)
  • LayoutFocusTraversalPolicy.getFirstComponent(Container)
  • SortingFocusTraversalPolicy.getFirstComponent(Container)


getFirstDayOfWeek

getFirstDayOfWeek o7planning.org
  • Calendar.getFirstDayOfWeek()
  • CalendarDataProvider.getFirstDayOfWeek(Locale)
  • WeekFields.getFirstDayOfWeek()


getFirstIndex

getFirstIndex o7planning.org
  • ListSelectionEvent.getFirstIndex()


getFirstLeaf

getFirstLeaf o7planning.org
  • DefaultMutableTreeNode.getFirstLeaf()


getFirstLineIndent

getFirstLineIndent o7planning.org
  • StyleConstants.getFirstLineIndent(AttributeSet)


getFirstQueuedThread

getFirstQueuedThread o7planning.org
  • AbstractQueuedLongSynchronizer.getFirstQueuedThread()
  • AbstractQueuedSynchronizer.getFirstQueuedThread()


getFirstRow

getFirstRow o7planning.org
  • AccessibleTableModelChange.getFirstRow()
  • JTable.AccessibleJTable.AccessibleJTableModelChange.getFirstRow()
  • TableModelEvent.getFirstRow()


getFirstVisibleIndex

getFirstVisibleIndex o7planning.org
  • JList.getFirstVisibleIndex()


getFixedCellHeight

getFixedCellHeight o7planning.org
  • JList.getFixedCellHeight()


getFixedCellWidth

getFixedCellWidth o7planning.org
  • JList.getFixedCellWidth()


getFixedRate

getFixedRate o7planning.org
  • Timer.getFixedRate(Integer)
  • TimerMBean.getFixedRate(Integer)


getFlags

getFlags o7planning.org
  • DuplicateFormatFlagsException.getFlags()
  • FormatFlagsConversionMismatchException.getFlags()
  • IllegalFormatFlagsException.getFlags()
  • KerberosTicket.getFlags()
  • UnknownFormatFlagsException.getFlags()


getFlatness

getFlatness o7planning.org
  • CubicCurve2D.getFlatness()
  • CubicCurve2D.getFlatness(double[], int)
  • CubicCurve2D.getFlatness(double, double, double, double, double, double, double, double)
  • FlatteningPathIterator.getFlatness()
  • QuadCurve2D.getFlatness()
  • QuadCurve2D.getFlatness(double[], int)
  • QuadCurve2D.getFlatness(double, double, double, double, double, double)


getFlatnessSq

getFlatnessSq o7planning.org
  • CubicCurve2D.getFlatnessSq()
  • CubicCurve2D.getFlatnessSq(double[], int)
  • CubicCurve2D.getFlatnessSq(double, double, double, double, double, double, double, double)
  • QuadCurve2D.getFlatnessSq()
  • QuadCurve2D.getFlatnessSq(double[], int)
  • QuadCurve2D.getFlatnessSq(double, double, double, double, double, double)


getFlavorListeners

getFlavorListeners o7planning.org
  • Clipboard.getFlavorListeners()


getFlavorMap

getFlavorMap o7planning.org
  • DragSource.getFlavorMap()
  • DropTarget.getFlavorMap()


getFlavorsForNative

getFlavorsForNative o7planning.org
  • FlavorTable.getFlavorsForNative(String)
  • SystemFlavorMap.getFlavorsForNative(String)


getFlavorsForNatives

getFlavorsForNatives o7planning.org
  • FlavorMap.getFlavorsForNatives(String[])
  • SystemFlavorMap.getFlavorsForNatives(String[])


getFlipContents

getFlipContents o7planning.org
  • BufferCapabilities.getFlipContents()


getFloat

getFloat o7planning.org
  • AbstractPreferences.getFloat(String, float)
  • Array.getFloat(Object, int)
  • ByteBuffer.getFloat(int)
  • ByteBuffer.getFloat()
  • CallableStatement.getFloat(String)
  • CallableStatement.getFloat(int)
  • Field.getFloat(Object)
  • Preferences.getFloat(String, float)
  • ResultSet.getFloat(String)
  • ResultSet.getFloat(int)


getFloatingColor

getFloatingColor o7planning.org
  • BasicToolBarUI.getFloatingColor()


getFloatParameter

getFloatParameter o7planning.org
  • ParameterBlock.getFloatParameter(int)


getFlowAxis

getFlowAxis o7planning.org
  • FlowView.getFlowAxis()


getFlowSpan

getFlowSpan o7planning.org
  • FlowView.getFlowSpan(int)
  • ParagraphView.getFlowSpan(int)


getFlowStart

getFlowStart o7planning.org
  • FlowView.getFlowStart(int)
  • ParagraphView.getFlowStart(int)


getFlushedPosition

getFlushedPosition o7planning.org
  • ImageInputStream.getFlushedPosition()
  • ImageInputStreamImpl.getFlushedPosition()


getFocusableWindowState

getFocusableWindowState o7planning.org
  • Window.getFocusableWindowState()


getFocusAccelerator

getFocusAccelerator o7planning.org
  • JTextComponent.getFocusAccelerator()


getFocusColor

getFocusColor o7planning.org
  • BasicSliderUI.getFocusColor()
  • MetalButtonUI.getFocusColor()
  • MetalLookAndFeel.getFocusColor()
  • MetalRadioButtonUI.getFocusColor()
  • MetalTheme.getFocusColor()
  • MetalToggleButtonUI.getFocusColor()


getFocusCycleRootAncestor

getFocusCycleRootAncestor o7planning.org
  • Component.getFocusCycleRootAncestor()
  • JInternalFrame.getFocusCycleRootAncestor()
  • Window.getFocusCycleRootAncestor()


getFocusedComponent

getFocusedComponent o7planning.org
  • TextAction.getFocusedComponent()


getFocusedWindow

getFocusedWindow o7planning.org
  • KeyboardFocusManager.getFocusedWindow()


getFocusIndex

getFocusIndex o7planning.org
  • BasicTabbedPaneUI.getFocusIndex()


getFocusListeners

getFocusListeners o7planning.org
  • Component.getFocusListeners()


getFocusLostBehavior

getFocusLostBehavior o7planning.org
  • JFormattedTextField.getFocusLostBehavior()


getFocusOwner

getFocusOwner o7planning.org
  • JInternalFrame.getFocusOwner()
  • KeyboardFocusManager.getFocusOwner()
  • Window.getFocusOwner()


getFocusPoint

getFocusPoint o7planning.org
  • RadialGradientPaint.getFocusPoint()


getFocusTraversalKeys

getFocusTraversalKeys o7planning.org
  • Component.getFocusTraversalKeys(int)
  • Container.getFocusTraversalKeys(int)
  • Window.getFocusTraversalKeys(int)


getFocusTraversalKeysEnabled

getFocusTraversalKeysEnabled o7planning.org
  • Component.getFocusTraversalKeysEnabled()


getFocusTraversalPolicy

getFocusTraversalPolicy o7planning.org
  • Container.getFocusTraversalPolicy()


getFollowRedirects

getFollowRedirects o7planning.org
  • HttpURLConnection.getFollowRedirects()


getFont

getFont o7planning.org
  • AccessibleComponent.getFont()
  • Component.getFont()
  • Component.AccessibleAWTComponent.getFont()
  • DebugGraphics.getFont()
  • DefaultStyledDocument.getFont(AttributeSet)
  • DefaultTreeCellEditor.getFont()
  • DefaultTreeCellEditor.DefaultTextField.getFont()
  • DefaultTreeCellRenderer.getFont()
  • Font.getFont(String, Font)
  • Font.getFont(String)
  • Font.getFont(Map<? extends AttributedCharacterIterator.Attribute, ?>)
  • FontMetrics.getFont()
  • GlyphVector.getFont()
  • GlyphView.getFont()
  • Graphics.getFont()
  • JList.AccessibleJList.AccessibleJListChild.getFont()
  • JTable.AccessibleJTable.AccessibleJTableCell.getFont()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFont()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getFont()
  • LabelView.getFont()
  • List.AccessibleAWTList.AccessibleAWTListChild.getFont()
  • MenuComponent.getFont()
  • MenuComponent.AccessibleAWTMenuComponent.getFont()
  • MenuContainer.getFont()
  • StyleContext.getFont(String, int, int)
  • StyleContext.getFont(AttributeSet)
  • StyleSheet.getFont(AttributeSet)
  • StyledDocument.getFont(AttributeSet)
  • SynthStyle.getFont(SynthContext)
  • TitledBorder.getFont(Component)
  • UIDefaults.getFont(Object, Locale)
  • UIDefaults.getFont(Object)
  • UIManager.getFont(Object, Locale)
  • UIManager.getFont(Object)


getFontFamily

getFontFamily o7planning.org
  • StyleConstants.getFontFamily(AttributeSet)


getFontForState

getFontForState o7planning.org
  • NimbusStyle.getFontForState(SynthContext)
  • SynthStyle.getFontForState(SynthContext)


getFontList

getFontList o7planning.org
  • Toolkit.getFontList()


getFontMetrics

getFontMetrics o7planning.org
  • AccessibleComponent.getFontMetrics(Font)
  • BasicTabbedPaneUI.getFontMetrics()
  • Component.getFontMetrics(Font)
  • Component.AccessibleAWTComponent.getFontMetrics(Font)
  • DebugGraphics.getFontMetrics(Font)
  • DebugGraphics.getFontMetrics()
  • FieldView.getFontMetrics()
  • Graphics.getFontMetrics(Font)
  • Graphics.getFontMetrics()
  • JComponent.getFontMetrics(Font)
  • JList.AccessibleJList.AccessibleJListChild.getFontMetrics(Font)
  • JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics(Font)
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics(Font)
  • JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics(Font)
  • LabelView.getFontMetrics()
  • List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics(Font)
  • MenuComponent.AccessibleAWTMenuComponent.getFontMetrics(Font)
  • StyleContext.getFontMetrics(Font)
  • SynthTabbedPaneUI.getFontMetrics()
  • Toolkit.getFontMetrics(Font)


getFontName

getFontName o7planning.org
  • Font.getFontName(Locale)
  • Font.getFontName()


getFontPeer

getFontPeer o7planning.org
  • Toolkit.getFontPeer(String, int)


getFontRenderContext

getFontRenderContext o7planning.org
  • FontMetrics.getFontRenderContext()
  • GlyphVector.getFontRenderContext()
  • Graphics2D.getFontRenderContext()


getFontSize

getFontSize o7planning.org
  • StyleConstants.getFontSize(AttributeSet)


getFontTable

getFontTable o7planning.org
  • OpenType.getFontTable(String, int, int)
  • OpenType.getFontTable(int, int, int)
  • OpenType.getFontTable(String)
  • OpenType.getFontTable(int)


getFontTableSize

getFontTableSize o7planning.org
  • OpenType.getFontTableSize(String)
  • OpenType.getFontTableSize(int)


getForeground

getForeground o7planning.org
  • AccessibleComponent.getForeground()
  • Component.getForeground()
  • Component.AccessibleAWTComponent.getForeground()
  • DefaultStyledDocument.getForeground(AttributeSet)
  • GlyphView.getForeground()
  • JList.AccessibleJList.AccessibleJListChild.getForeground()
  • JTable.AccessibleJTable.AccessibleJTableCell.getForeground()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getForeground()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getForeground()
  • LabelView.getForeground()
  • List.AccessibleAWTList.AccessibleAWTListChild.getForeground()
  • MenuComponent.AccessibleAWTMenuComponent.getForeground()
  • StyleConstants.getForeground(AttributeSet)
  • StyleContext.getForeground(AttributeSet)
  • StyleSheet.getForeground(AttributeSet)
  • StyledDocument.getForeground(AttributeSet)


getForegroundAt

getForegroundAt o7planning.org
  • JTabbedPane.getForegroundAt(int)


getForegroundPainter

getForegroundPainter o7planning.org
  • NimbusStyle.getForegroundPainter(SynthContext)


getForkJoinTaskTag

getForkJoinTaskTag o7planning.org
  • ForkJoinTask.getForkJoinTaskTag()


getFormat

getFormat o7planning.org
  • AudioFileFormat.getFormat()
  • AudioInputStream.getFormat()
  • Certificate.getFormat()
  • DataLine.getFormat()
  • EncodedKeySpec.getFormat()
  • InternationalFormatter.getFormat()
  • JSpinner.DateEditor.getFormat()
  • JSpinner.NumberEditor.getFormat()
  • KerberosKey.getFormat()
  • Key.getFormat()
  • PKCS8EncodedKeySpec.getFormat()
  • SecretKeySpec.getFormat()
  • X509EncodedKeySpec.getFormat()


getFormatId

getFormatId o7planning.org
  • Xid.getFormatId()


getFormatName

getFormatName o7planning.org
  • ImageReader.getFormatName()


getFormatNames

getFormatNames o7planning.org
  • ImageReaderWriterSpi.getFormatNames()


getFormats

getFormats o7planning.org
  • ChoiceFormat.getFormats()
  • DataLine.Info.getFormats()
  • MessageFormat.getFormats()
  • ResourceBundle.Control.getFormats(String)


getFormatsByArgumentIndex

getFormatsByArgumentIndex o7planning.org
  • MessageFormat.getFormatsByArgumentIndex()


getFormatSpecifier

getFormatSpecifier o7planning.org
  • MissingFormatArgumentException.getFormatSpecifier()
  • MissingFormatWidthException.getFormatSpecifier()


getFormattedTextField

getFormattedTextField o7planning.org
  • JFormattedTextField.AbstractFormatter.getFormattedTextField()


getFormatter

getFormatter o7planning.org
  • DefaultFormatterFactory.getFormatter(JFormattedTextField)
  • Handler.getFormatter()
  • JFormattedTextField.getFormatter()
  • JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField)


getFormatterFactory

getFormatterFactory o7planning.org
  • JFormattedTextField.getFormatterFactory()


getFractionalMetricsHint

getFractionalMetricsHint o7planning.org
  • FontRenderContext.getFractionalMetricsHint()


getFractionalSecond

getFractionalSecond o7planning.org
  • XMLGregorianCalendar.getFractionalSecond()


getFractions

getFractions o7planning.org
  • MultipleGradientPaint.getFractions()


getFragment

getFragment o7planning.org
  • URI.getFragment()


getFrame

getFrame o7planning.org
  • RectangularShape.getFrame()


getFrameCount

getFrameCount o7planning.org
  • BasicProgressBarUI.getFrameCount()


getFrameForComponent

getFrameForComponent o7planning.org
  • JOptionPane.getFrameForComponent(Component)


getFrameIcon

getFrameIcon o7planning.org
  • JInternalFrame.getFrameIcon()


getFrameLength

getFrameLength o7planning.org
  • AudioFileFormat.getFrameLength()
  • AudioInputStream.getFrameLength()
  • Clip.getFrameLength()


getFramePosition

getFramePosition o7planning.org
  • DataLine.getFramePosition()
  • LineEvent.getFramePosition()


getFrameRate

getFrameRate o7planning.org
  • AudioFormat.getFrameRate()


getFrames

getFrames o7planning.org
  • Frame.getFrames()


getFrameSize

getFrameSize o7planning.org
  • AudioFormat.getFrameSize()


getFreeSpace

getFreeSpace o7planning.org
  • File.getFreeSpace()


getFrom

getFrom o7planning.org
  • ChronoField.getFrom(TemporalAccessor)
  • TemporalField.getFrom(TemporalAccessor)


getFromIndex

getFromIndex o7planning.org
  • TableColumnModelEvent.getFromIndex()


getFromPage

getFromPage o7planning.org
  • JobAttributes.getFromPage()


getFrontBufferCapabilities

getFrontBufferCapabilities o7planning.org
  • BufferCapabilities.getFrontBufferCapabilities()


getFullScreenWindow

getFullScreenWindow o7planning.org
  • GraphicsDevice.getFullScreenWindow()


getFunctionalInterfaceClass

getFunctionalInterfaceClass o7planning.org
  • SerializedLambda.getFunctionalInterfaceClass()


getFunctionalInterfaceMethodName

getFunctionalInterfaceMethodName o7planning.org
  • SerializedLambda.getFunctionalInterfaceMethodName()


getFunctionalInterfaceMethodSignature

getFunctionalInterfaceMethodSignature o7planning.org
  • SerializedLambda.getFunctionalInterfaceMethodSignature()


getFunctionColumns

getFunctionColumns o7planning.org
  • DatabaseMetaData.getFunctionColumns(String, String, String, String)


getFunctions

getFunctions o7planning.org
  • DatabaseMetaData.getFunctions(String, String, String)


getG

getG o7planning.org
  • DHParameterSpec.getG()
  • DHPrivateKeySpec.getG()
  • DHPublicKeySpec.getG()
  • DSAParameterSpec.getG()
  • DSAParams.getG()
  • DSAPrivateKeySpec.getG()
  • DSAPublicKeySpec.getG()


getGamma

getGamma o7planning.org
  • ICC_ProfileGray.getGamma()
  • ICC_ProfileRGB.getGamma(int)


getGarbageCollectorMXBeans

getGarbageCollectorMXBeans o7planning.org
  • ManagementFactory.getGarbageCollectorMXBeans()


getGeneratedKeys

getGeneratedKeys o7planning.org
  • Statement.getGeneratedKeys()


getGenerator

getGenerator o7planning.org
  • ECParameterSpec.getGenerator()


getGenericComponentType

getGenericComponentType o7planning.org
  • GenericArrayType.getGenericComponentType()


getGenericDeclaration

getGenericDeclaration o7planning.org
  • TypeVariable.getGenericDeclaration()


getGenericDisplayName

getGenericDisplayName o7planning.org
  • TimeZoneNameProvider.getGenericDisplayName(String, int, Locale)


getGenericElement

getGenericElement o7planning.org
  • TypeParameterElement.getGenericElement()


getGenericExceptionTypes

getGenericExceptionTypes o7planning.org
  • Constructor.getGenericExceptionTypes()
  • Executable.getGenericExceptionTypes()
  • Method.getGenericExceptionTypes()


getGenericInterfaces

getGenericInterfaces o7planning.org
  • Class.getGenericInterfaces()


getGenericParameterTypes

getGenericParameterTypes o7planning.org
  • Constructor.getGenericParameterTypes()
  • Executable.getGenericParameterTypes()
  • Method.getGenericParameterTypes()


getGenericReturnType

getGenericReturnType o7planning.org
  • Method.getGenericReturnType()


getGenericSuperclass

getGenericSuperclass o7planning.org
  • Class.getGenericSuperclass()


getGenericType

getGenericType o7planning.org
  • Field.getGenericType()


getGestureModifiers

getGestureModifiers o7planning.org
  • DragSourceDragEvent.getGestureModifiers()


getGestureModifiersEx

getGestureModifiersEx o7planning.org
  • DragSourceDragEvent.getGestureModifiersEx()


getGetListenerMethod

getGetListenerMethod o7planning.org
  • EventSetDescriptor.getGetListenerMethod()


getGlassPane

getGlassPane o7planning.org
  • JApplet.getGlassPane()
  • JDialog.getGlassPane()
  • JFrame.getGlassPane()
  • JInternalFrame.getGlassPane()
  • JLayer.getGlassPane()
  • JRootPane.getGlassPane()
  • JWindow.getGlassPane()
  • RootPaneContainer.getGlassPane()


getGlobal

getGlobal o7planning.org
  • Logger.getGlobal()


getGlobalActiveWindow

getGlobalActiveWindow o7planning.org
  • KeyboardFocusManager.getGlobalActiveWindow()


getGlobalCurrentFocusCycleRoot

getGlobalCurrentFocusCycleRoot o7planning.org
  • KeyboardFocusManager.getGlobalCurrentFocusCycleRoot()


getGlobalFocusedWindow

getGlobalFocusedWindow o7planning.org
  • KeyboardFocusManager.getGlobalFocusedWindow()


getGlobalFocusOwner

getGlobalFocusOwner o7planning.org
  • KeyboardFocusManager.getGlobalFocusOwner()


getGlobalPermanentFocusOwner

getGlobalPermanentFocusOwner o7planning.org
  • KeyboardFocusManager.getGlobalPermanentFocusOwner()


getGlobalTransactionId

getGlobalTransactionId o7planning.org
  • Xid.getGlobalTransactionId()


getGlyphCharIndex

getGlyphCharIndex o7planning.org
  • GlyphVector.getGlyphCharIndex(int)


getGlyphCharIndices

getGlyphCharIndices o7planning.org
  • GlyphVector.getGlyphCharIndices(int, int, int[])


getGlyphCode

getGlyphCode o7planning.org
  • GlyphVector.getGlyphCode(int)


getGlyphCodes

getGlyphCodes o7planning.org
  • GlyphVector.getGlyphCodes(int, int, int[])


getGlyphJustificationInfo

getGlyphJustificationInfo o7planning.org
  • GlyphVector.getGlyphJustificationInfo(int)


getGlyphLogicalBounds

getGlyphLogicalBounds o7planning.org
  • GlyphVector.getGlyphLogicalBounds(int)


getGlyphMetrics

getGlyphMetrics o7planning.org
  • GlyphVector.getGlyphMetrics(int)


getGlyphOutline

getGlyphOutline o7planning.org
  • GlyphVector.getGlyphOutline(int, float, float)
  • GlyphVector.getGlyphOutline(int)


getGlyphPainter

getGlyphPainter o7planning.org
  • GlyphView.getGlyphPainter()


getGlyphPixelBounds

getGlyphPixelBounds o7planning.org
  • GlyphVector.getGlyphPixelBounds(int, FontRenderContext, float, float)


getGlyphPosition

getGlyphPosition o7planning.org
  • GlyphVector.getGlyphPosition(int)


getGlyphPositions

getGlyphPositions o7planning.org
  • GlyphVector.getGlyphPositions(int, int, float[])


getGlyphTransform

getGlyphTransform o7planning.org
  • GlyphVector.getGlyphTransform(int)


getGlyphVisualBounds

getGlyphVisualBounds o7planning.org
  • GlyphVector.getGlyphVisualBounds(int)


getGoHomeAction

getGoHomeAction o7planning.org
  • BasicFileChooserUI.getGoHomeAction()


getGranularityPeriod

getGranularityPeriod o7planning.org
  • Monitor.getGranularityPeriod()
  • MonitorMBean.getGranularityPeriod()


getGraphics

getGraphics o7planning.org
  • BufferedImage.getGraphics()
  • Component.getGraphics()
  • Image.getGraphics()
  • JApplet.getGraphics()
  • JComponent.getGraphics()
  • JDialog.getGraphics()
  • JFrame.getGraphics()
  • JWindow.getGraphics()
  • PrintJob.getGraphics()
  • View.getGraphics()
  • VolatileImage.getGraphics()


getGraphicsConfiguration

getGraphicsConfiguration o7planning.org
  • Component.getGraphicsConfiguration()


getGraphicsUtils

getGraphicsUtils o7planning.org
  • SynthStyle.getGraphicsUtils(SynthContext)


getGreatestMinimum

getGreatestMinimum o7planning.org
  • Calendar.getGreatestMinimum(int)
  • GregorianCalendar.getGreatestMinimum(int)


getGreen

getGreen o7planning.org
  • Color.getGreen()
  • ColorModel.getGreen(Object)
  • ColorModel.getGreen(int)
  • ComponentColorModel.getGreen(Object)
  • ComponentColorModel.getGreen(int)
  • DirectColorModel.getGreen(Object)
  • DirectColorModel.getGreen(int)
  • IndexColorModel.getGreen(int)


getGreenMask

getGreenMask o7planning.org
  • DirectColorModel.getGreenMask()


getGreens

getGreens o7planning.org
  • IndexColorModel.getGreens(byte[])


getGregorianChange

getGregorianChange o7planning.org
  • GregorianCalendar.getGregorianChange()


getGridColor

getGridColor o7planning.org
  • JTable.getGridColor()


getGridColumn

getGridColumn o7planning.org
  • TableView.TableCell.getGridColumn()


getGridRow

getGridRow o7planning.org
  • TableView.TableCell.getGridRow()


getGrooveInsets

getGrooveInsets o7planning.org
  • BasicGraphicsUtils.getGrooveInsets()


getGroup

getGroup o7planning.org
  • DefaultButtonModel.getGroup()


getGroupID

getGroupID o7planning.org
  • ActivationDesc.getGroupID()


getGroupingSeparator

getGroupingSeparator o7planning.org
  • DecimalFormatSymbols.getGroupingSeparator()


getGroupingSize

getGroupingSize o7planning.org
  • DecimalFormat.getGroupingSize()


getGuarantor

getGuarantor o7planning.org
  • Certificate.getGuarantor()


getHAdjustable

getHAdjustable o7planning.org
  • ScrollPane.getHAdjustable()


getHandler

getHandler o7planning.org
  • SAXResult.getHandler()


getHandlerChain

getHandlerChain o7planning.org
  • Binding.getHandlerChain()
  • HandlerResolver.getHandlerChain(PortInfo)


getHandlerResolver

getHandlerResolver o7planning.org
  • Service.getHandlerResolver()
  • ServiceDelegate.getHandlerResolver()


getHandlers

getHandlers o7planning.org
  • Logger.getHandlers()


getHandshakeSession

getHandshakeSession o7planning.org
  • SSLEngine.getHandshakeSession()
  • SSLSocket.getHandshakeSession()


getHandshakeStatus

getHandshakeStatus o7planning.org
  • SSLEngine.getHandshakeStatus()
  • SSLEngineResult.getHandshakeStatus()


getHardwareAddress

getHardwareAddress o7planning.org
  • NetworkInterface.getHardwareAddress()


getHashColor

getHashColor o7planning.org
  • BasicTreeUI.getHashColor()


getHead

getHead o7planning.org
  • Formatter.getHead(Handler)
  • XMLFormatter.getHead(Handler)


getHeader

getHeader o7planning.org
  • MimeHeaders.getHeader(String)
  • SOAPEnvelope.getHeader()


getHeaderField

getHeaderField o7planning.org
  • HttpURLConnection.getHeaderField(int)
  • URLConnection.getHeaderField(int)
  • URLConnection.getHeaderField(String)


getHeaderFieldDate

getHeaderFieldDate o7planning.org
  • HttpURLConnection.getHeaderFieldDate(String, long)
  • URLConnection.getHeaderFieldDate(String, long)


getHeaderFieldInt

getHeaderFieldInt o7planning.org
  • URLConnection.getHeaderFieldInt(String, int)


getHeaderFieldKey

getHeaderFieldKey o7planning.org
  • HttpURLConnection.getHeaderFieldKey(int)
  • URLConnection.getHeaderFieldKey(int)


getHeaderFieldLong

getHeaderFieldLong o7planning.org
  • URLConnection.getHeaderFieldLong(String, long)


getHeaderFields

getHeaderFields o7planning.org
  • URLConnection.getHeaderFields()


getHeaderRect

getHeaderRect o7planning.org
  • JTableHeader.getHeaderRect(int)


getHeaderRenderer

getHeaderRenderer o7planning.org
  • TableColumn.getHeaderRenderer()


getHeaders

getHeaders o7planning.org
  • CacheResponse.getHeaders()
  • SOAPHandler.getHeaders()
  • SOAPMessageContext.getHeaders(QName, JAXBContext, boolean)


getHeaderValue

getHeaderValue o7planning.org
  • TableColumn.getHeaderValue()


getHeapMemoryUsage

getHeapMemoryUsage o7planning.org
  • MemoryMXBean.getHeapMemoryUsage()


getHeight

getHeight o7planning.org
  • Arc2D.Double.getHeight()
  • Arc2D.Float.getHeight()
  • BoxView.getHeight()
  • BufferedImage.getHeight(ImageObserver)
  • BufferedImage.getHeight()
  • Component.getHeight()
  • Dimension.getHeight()
  • Dimension2D.getHeight()
  • DisplayMode.getHeight()
  • Ellipse2D.Double.getHeight()
  • Ellipse2D.Float.getHeight()
  • FontMetrics.getHeight()
  • GlyphView.GlyphPainter.getHeight(GlyphView)
  • Image.getHeight(ImageObserver)
  • ImageReader.getHeight(int)
  • JComponent.getHeight()
  • Kernel.getHeight()
  • LineMetrics.getHeight()
  • MediaPrintableArea.getHeight(int)
  • PageFormat.getHeight()
  • Paper.getHeight()
  • PixelGrabber.getHeight()
  • Raster.getHeight()
  • Rectangle.getHeight()
  • Rectangle2D.Double.getHeight()
  • Rectangle2D.Float.getHeight()
  • RectangularShape.getHeight()
  • RenderableImage.getHeight()
  • RenderableImageOp.getHeight()
  • RenderedImage.getHeight()
  • RoundRectangle2D.Double.getHeight()
  • RoundRectangle2D.Float.getHeight()
  • SampleModel.getHeight()
  • SpringLayout.Constraints.getHeight()
  • VolatileImage.getHeight()


getHeightOfHighValueLabel

getHeightOfHighValueLabel o7planning.org
  • BasicSliderUI.getHeightOfHighValueLabel()


getHeightOfLowValueLabel

getHeightOfLowValueLabel o7planning.org
  • BasicSliderUI.getHeightOfLowValueLabel()


getHeightOfTallestLabel

getHeightOfTallestLabel o7planning.org
  • BasicSliderUI.getHeightOfTallestLabel()


getHelpMenu

getHelpMenu o7planning.org
  • JMenuBar.getHelpMenu()
  • MenuBar.getHelpMenu()


getHere

getHere o7planning.org
  • DOMURIReference.getHere()


getHgap

getHgap o7planning.org
  • BorderLayout.getHgap()
  • CardLayout.getHgap()
  • FlowLayout.getHgap()
  • GridLayout.getHgap()


getHideActionText

getHideActionText o7planning.org
  • AbstractButton.getHideActionText()


getHierarchyBoundsListeners

getHierarchyBoundsListeners o7planning.org
  • Component.getHierarchyBoundsListeners()


getHierarchyListeners

getHierarchyListeners o7planning.org
  • Component.getHierarchyListeners()


getHighestValue

getHighestValue o7planning.org
  • BasicSliderUI.getHighestValue()


getHighestValueLabel

getHighestValueLabel o7planning.org
  • BasicSliderUI.getHighestValueLabel()


getHighlightColor

getHighlightColor o7planning.org
  • BasicSliderUI.getHighlightColor()
  • EtchedBorder.getHighlightColor()
  • EtchedBorder.getHighlightColor(Component)


getHighlightedTextColor

getHighlightedTextColor o7planning.org
  • MetalLookAndFeel.getHighlightedTextColor()
  • MetalTheme.getHighlightedTextColor()


getHighlighter

getHighlighter o7planning.org
  • JTextComponent.getHighlighter()


getHighlightInnerColor

getHighlightInnerColor o7planning.org
  • BevelBorder.getHighlightInnerColor()
  • BevelBorder.getHighlightInnerColor(Component)


getHighlightOuterColor

getHighlightOuterColor o7planning.org
  • BevelBorder.getHighlightOuterColor()
  • BevelBorder.getHighlightOuterColor(Component)


getHighlights

getHighlights o7planning.org
  • DefaultHighlighter.getHighlights()
  • Highlighter.getHighlights()


getHighThreshold

getHighThreshold o7planning.org
  • GaugeMonitor.getHighThreshold()
  • GaugeMonitorMBean.getHighThreshold()


getHoldability

getHoldability o7planning.org
  • Connection.getHoldability()
  • ResultSet.getHoldability()


getHoldCount

getHoldCount o7planning.org
  • ReentrantLock.getHoldCount()
  • ReentrantReadWriteLock.WriteLock.getHoldCount()


getHomeDirectory

getHomeDirectory o7planning.org
  • FileSystemView.getHomeDirectory()


getHonorsVisibility

getHonorsVisibility o7planning.org
  • GroupLayout.getHonorsVisibility()


getHorizontalAlignment

getHorizontalAlignment o7planning.org
  • AbstractButton.getHorizontalAlignment()
  • JLabel.getHorizontalAlignment()
  • JTextField.getHorizontalAlignment()


getHorizontalLegBuffer

getHorizontalLegBuffer o7planning.org
  • BasicTreeUI.getHorizontalLegBuffer()
  • MetalTreeUI.getHorizontalLegBuffer()


getHorizontalScrollBar

getHorizontalScrollBar o7planning.org
  • JScrollPane.getHorizontalScrollBar()
  • ScrollPaneLayout.getHorizontalScrollBar()


getHorizontalScrollBarPolicy

getHorizontalScrollBarPolicy o7planning.org
  • JScrollPane.getHorizontalScrollBarPolicy()
  • ScrollPaneLayout.getHorizontalScrollBarPolicy()


getHorizontalSliderThumbIcon

getHorizontalSliderThumbIcon o7planning.org
  • MetalIconFactory.getHorizontalSliderThumbIcon()


getHorizontalTextPosition

getHorizontalTextPosition o7planning.org
  • AbstractButton.getHorizontalTextPosition()
  • JLabel.getHorizontalTextPosition()


getHorizontalVisibility

getHorizontalVisibility o7planning.org
  • JTextField.getHorizontalVisibility()


getHost

getHost o7planning.org
  • JMXServiceURL.getHost()
  • URI.getHost()
  • URL.getHost()


getHostAddress

getHostAddress o7planning.org
  • Inet4Address.getHostAddress()
  • Inet6Address.getHostAddress()
  • InetAddress.getHostAddress()
  • URLStreamHandler.getHostAddress(URL)


getHostName

getHostName o7planning.org
  • InetAddress.getHostName()
  • InetSocketAddress.getHostName()


getHostnameVerifier

getHostnameVerifier o7planning.org
  • HttpsURLConnection.getHostnameVerifier()


getHostString

getHostString o7planning.org
  • InetSocketAddress.getHostString()


getHour

getHour o7planning.org
  • LocalDateTime.getHour()
  • LocalTime.getHour()
  • OffsetDateTime.getHour()
  • OffsetTime.getHour()
  • XMLGregorianCalendar.getHour()
  • ZonedDateTime.getHour()


getHours

getHours o7planning.org
  • Date.getHours()
  • Date.getHours()
  • Duration.getHours()


getHSBColor

getHSBColor o7planning.org
  • Color.getHSBColor(float, float, float)


getHScrollbarHeight

getHScrollbarHeight o7planning.org
  • ScrollPane.getHScrollbarHeight()


getHTMLBaseline

getHTMLBaseline o7planning.org
  • BasicHTML.getHTMLBaseline(View, int, int)


getHTMLDocument

getHTMLDocument o7planning.org
  • HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane)


getHTMLEditorKit

getHTMLEditorKit o7planning.org
  • HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane)


getHTMLTag

getHTMLTag o7planning.org
  • TagElement.getHTMLTag()


getHttpContext

getHttpContext o7planning.org
  • HttpExchange.getHttpContext()


getHumanPresentableName

getHumanPresentableName o7planning.org
  • ActivationDataFlavor.getHumanPresentableName()
  • DataFlavor.getHumanPresentableName()


getHyperlinkListeners

getHyperlinkListeners o7planning.org
  • JEditorPane.getHyperlinkListeners()


getICC_Profiles

getICC_Profiles o7planning.org
  • ColorConvertOp.getICC_Profiles()


getIcon

getIcon o7planning.org
  • AbstractButton.getIcon()
  • BasicFileChooserUI.BasicFileView.getIcon(File)
  • BasicOptionPaneUI.getIcon()
  • BeanInfo.getIcon(int)
  • FileView.getIcon(File)
  • JFileChooser.getIcon(File)
  • JLabel.getIcon()
  • JOptionPane.getIcon()
  • SimpleBeanInfo.getIcon(int)
  • StyleConstants.getIcon(AttributeSet)
  • SynthButtonUI.getIcon(AbstractButton)
  • SynthStyle.getIcon(SynthContext, Object)
  • UIDefaults.getIcon(Object, Locale)
  • UIDefaults.getIcon(Object)
  • UIManager.getIcon(Object, Locale)
  • UIManager.getIcon(Object)


getIconAt

getIconAt o7planning.org
  • JTabbedPane.getIconAt(int)


getIconForTab

getIconForTab o7planning.org
  • BasicTabbedPaneUI.getIconForTab(int)


getIconForType

getIconForType o7planning.org
  • BasicOptionPaneUI.getIconForType(int)


getIconHeight

getIconHeight o7planning.org
  • Icon.getIconHeight()
  • IconUIResource.getIconHeight()
  • ImageIcon.getIconHeight()
  • MetalCheckBoxIcon.getIconHeight()
  • MetalComboBoxIcon.getIconHeight()
  • MetalIconFactory.FileIcon16.getIconHeight()
  • MetalIconFactory.FolderIcon16.getIconHeight()
  • MetalIconFactory.PaletteCloseIcon.getIconHeight()
  • MetalIconFactory.TreeControlIcon.getIconHeight()


getIconImage

getIconImage o7planning.org
  • Frame.getIconImage()


getIconImages

getIconImages o7planning.org
  • Window.getIconImages()


getIconTextGap

getIconTextGap o7planning.org
  • AbstractButton.getIconTextGap()
  • JLabel.getIconTextGap()


getIconWidth

getIconWidth o7planning.org
  • Icon.getIconWidth()
  • IconUIResource.getIconWidth()
  • ImageIcon.getIconWidth()
  • MetalCheckBoxIcon.getIconWidth()
  • MetalComboBoxIcon.getIconWidth()
  • MetalIconFactory.FileIcon16.getIconWidth()
  • MetalIconFactory.FolderIcon16.getIconWidth()
  • MetalIconFactory.PaletteCloseIcon.getIconWidth()
  • MetalIconFactory.TreeControlIcon.getIconWidth()


getID

getID o7planning.org
  • AddressingFeature.getID()
  • MTOMFeature.getID()
  • RespectBindingFeature.getID()
  • WebServiceFeature.getID()


getId

getId o7planning.org
  • ApplicationException.getId()


getIdentifier

getIdentifier o7planning.org
  • DefaultRowSorter.ModelWrapper.getIdentifier(int)
  • RowFilter.Entry.getIdentifier()
  • TableColumn.getIdentifier()


getIdentifierQuoteString

getIdentifierQuoteString o7planning.org
  • DatabaseMetaData.getIdentifierQuoteString()


getIdentity

getIdentity o7planning.org
  • IdentityScope.getIdentity(PublicKey)
  • IdentityScope.getIdentity(Principal)
  • IdentityScope.getIdentity(String)


getIdentityHashCode

getIdentityHashCode o7planning.org
  • LockInfo.getIdentityHashCode()


getIDs

getIDs o7planning.org
  • Attributes.getIDs()
  • BasicAttributes.getIDs()


getIds

getIds o7planning.org
  • SSLSessionContext.getIds()


getIDstring

getIDstring o7planning.org
  • GraphicsDevice.getIDstring()


getIfModifiedSince

getIfModifiedSince o7planning.org
  • URLConnection.getIfModifiedSince()


getIgnoreRepaint

getIgnoreRepaint o7planning.org
  • Component.getIgnoreRepaint()


getImage

getImage o7planning.org
  • Applet.getImage(URL, String)
  • Applet.getImage(URL)
  • AppletContext.getImage(URL)
  • ImageIcon.getImage()
  • ImageView.getImage()
  • TexturePaint.getImage()
  • Toolkit.getImage(URL)
  • Toolkit.getImage(String)
  • TrayIcon.getImage()


getImageableHeight

getImageableHeight o7planning.org
  • PageFormat.getImageableHeight()
  • Paper.getImageableHeight()


getImageableWidth

getImageableWidth o7planning.org
  • PageFormat.getImageableWidth()
  • Paper.getImageableWidth()


getImageableX

getImageableX o7planning.org
  • PageFormat.getImageableX()
  • Paper.getImageableX()


getImageableY

getImageableY o7planning.org
  • PageFormat.getImageableY()
  • Paper.getImageableY()


getImageCapabilities

getImageCapabilities o7planning.org
  • GraphicsConfiguration.getImageCapabilities()


getImageLoadStatus

getImageLoadStatus o7planning.org
  • ImageIcon.getImageLoadStatus()


getImageMetadata

getImageMetadata o7planning.org
  • ImageReader.getImageMetadata(int, String, Set<String>)
  • ImageReader.getImageMetadata(int)


getImageMetadataFormat

getImageMetadataFormat o7planning.org
  • ImageReaderWriterSpi.getImageMetadataFormat(String)


getImageObserver

getImageObserver o7planning.org
  • ImageIcon.getImageObserver()


getImageReader

getImageReader o7planning.org
  • ImageIO.getImageReader(ImageWriter)


getImageReaders

getImageReaders o7planning.org
  • ImageIO.getImageReaders(Object)


getImageReadersByFormatName

getImageReadersByFormatName o7planning.org
  • ImageIO.getImageReadersByFormatName(String)


getImageReadersByMIMEType

getImageReadersByMIMEType o7planning.org
  • ImageIO.getImageReadersByMIMEType(String)


getImageReadersBySuffix

getImageReadersBySuffix o7planning.org
  • ImageIO.getImageReadersBySuffix(String)


getImageReaderSpiNames

getImageReaderSpiNames o7planning.org
  • ImageWriterSpi.getImageReaderSpiNames()


getImageTranscoders

getImageTranscoders o7planning.org
  • ImageIO.getImageTranscoders(ImageReader, ImageWriter)


getImageTypes

getImageTypes o7planning.org
  • ImageReader.getImageTypes(int)


getImageURL

getImageURL o7planning.org
  • ImageView.getImageURL()
  • SplashScreen.getImageURL()


getImageWriter

getImageWriter o7planning.org
  • ImageIO.getImageWriter(ImageReader)


getImageWriters

getImageWriters o7planning.org
  • ImageIO.getImageWriters(ImageTypeSpecifier, String)


getImageWritersByFormatName

getImageWritersByFormatName o7planning.org
  • ImageIO.getImageWritersByFormatName(String)


getImageWritersByMIMEType

getImageWritersByMIMEType o7planning.org
  • ImageIO.getImageWritersByMIMEType(String)


getImageWritersBySuffix

getImageWritersBySuffix o7planning.org
  • ImageIO.getImageWritersBySuffix(String)


getImageWriterSpiNames

getImageWriterSpiNames o7planning.org
  • ImageReaderSpi.getImageWriterSpiNames()


getImpact

getImpact o7planning.org
  • MBeanOperationInfo.getImpact()
  • OpenMBeanOperationInfo.getImpact()
  • StandardMBean.getImpact(MBeanOperationInfo)


getImplClass

getImplClass o7planning.org
  • SerializedLambda.getImplClass()


getImplementation

getImplementation o7planning.org
  • Document.getImplementation()
  • StandardMBean.getImplementation()


getImplementationClass

getImplementationClass o7planning.org
  • StandardMBean.getImplementationClass()


getImplementationName

getImplementationName o7planning.org
  • MBeanServerDelegate.getImplementationName()
  • MBeanServerDelegateMBean.getImplementationName()


getImplementationTitle

getImplementationTitle o7planning.org
  • Package.getImplementationTitle()


getImplementationVendor

getImplementationVendor o7planning.org
  • MBeanServerDelegate.getImplementationVendor()
  • MBeanServerDelegateMBean.getImplementationVendor()
  • Package.getImplementationVendor()


getImplementationVersion

getImplementationVersion o7planning.org
  • MBeanServerDelegate.getImplementationVersion()
  • MBeanServerDelegateMBean.getImplementationVersion()
  • Package.getImplementationVersion()


getImplementor

getImplementor o7planning.org
  • Endpoint.getImplementor()


getImplicitDownCycleTraversal

getImplicitDownCycleTraversal o7planning.org
  • ContainerOrderFocusTraversalPolicy.getImplicitDownCycleTraversal()
  • SortingFocusTraversalPolicy.getImplicitDownCycleTraversal()


getImplMethodKind

getImplMethodKind o7planning.org
  • SerializedLambda.getImplMethodKind()


getImplMethodName

getImplMethodName o7planning.org
  • SerializedLambda.getImplMethodName()


getImplMethodSignature

getImplMethodSignature o7planning.org
  • SerializedLambda.getImplMethodSignature()


getImportedKeys

getImportedKeys o7planning.org
  • DatabaseMetaData.getImportedKeys(String, String, String)


getInactiveControlTextColor

getInactiveControlTextColor o7planning.org
  • MetalLookAndFeel.getInactiveControlTextColor()
  • MetalTheme.getInactiveControlTextColor()
  • OceanTheme.getInactiveControlTextColor()


getInactiveSystemTextColor

getInactiveSystemTextColor o7planning.org
  • MetalLookAndFeel.getInactiveSystemTextColor()
  • MetalTheme.getInactiveSystemTextColor()


getInCheck

getInCheck o7planning.org
  • SecurityManager.getInCheck()


getIndentLevel

getIndentLevel o7planning.org
  • AbstractWriter.getIndentLevel()


getIndentSpace

getIndentSpace o7planning.org
  • AbstractWriter.getIndentSpace()


getIndex0

getIndex0 o7planning.org
  • ListDataEvent.getIndex0()


getIndex1

getIndex1 o7planning.org
  • ListDataEvent.getIndex1()


getIndex

getIndex o7planning.org
  • AbstractDocument.AbstractElement.getIndex(TreeNode)
  • AbstractDocument.ElementEdit.getIndex()
  • Attributes.getIndex(String)
  • Attributes.getIndex(String, String)
  • AttributesImpl.getIndex(String)
  • AttributesImpl.getIndex(String, String)
  • CertPathValidatorException.getIndex()
  • CharacterIterator.getIndex()
  • DataTruncation.getIndex()
  • DefaultMutableTreeNode.getIndex(TreeNode)
  • DocumentEvent.ElementChange.getIndex()
  • Element.getIndex()
  • IndexedPropertyChangeEvent.getIndex()
  • InvalidPathException.getIndex()
  • JList.DropLocation.getIndex()
  • JTextComponent.DropLocation.getIndex()
  • NetworkInterface.getIndex()
  • ParsePosition.getIndex()
  • PatternSyntaxException.getIndex()
  • Segment.getIndex()
  • SizeSequence.getIndex(int)
  • StringCharacterIterator.getIndex()
  • TreeNode.getIndex(TreeNode)
  • URISyntaxException.getIndex()


getIndexAtPoint

getIndexAtPoint o7planning.org
  • AbstractButton.AccessibleAbstractButton.getIndexAtPoint(Point)
  • AccessibleText.getIndexAtPoint(Point)
  • JLabel.AccessibleJLabel.getIndexAtPoint(Point)
  • JSpinner.AccessibleJSpinner.getIndexAtPoint(Point)
  • JTextComponent.AccessibleJTextComponent.getIndexAtPoint(Point)
  • ProgressMonitor.AccessibleProgressMonitor.getIndexAtPoint(Point)
  • TextComponent.AccessibleAWTTextComponent.getIndexAtPoint(Point)


getIndexedPropertyType

getIndexedPropertyType o7planning.org
  • IndexedPropertyDescriptor.getIndexedPropertyType()


getIndexedReadMethod

getIndexedReadMethod o7planning.org
  • IndexedPropertyDescriptor.getIndexedReadMethod()


getIndexedWriteMethod

getIndexedWriteMethod o7planning.org
  • IndexedPropertyDescriptor.getIndexedWriteMethod()


getIndexInfo

getIndexInfo o7planning.org
  • DatabaseMetaData.getIndexInfo(String, String, String, boolean, boolean)


getIndexNames

getIndexNames o7planning.org
  • TabularType.getIndexNames()


getIndexOf

getIndexOf o7planning.org
  • DefaultComboBoxModel.getIndexOf(Object)
  • JLayeredPane.getIndexOf(Component)


getIndexOfChild

getIndexOfChild o7planning.org
  • DefaultTreeModel.getIndexOfChild(Object, Object)
  • TreeModel.getIndexOfChild(Object, Object)


getIndexOfSize

getIndexOfSize o7planning.org
  • StyleSheet.getIndexOfSize(float)


getInetAddress

getInetAddress o7planning.org
  • DatagramSocket.getInetAddress()
  • ServerSocket.getInetAddress()
  • Socket.getInetAddress()
  • SocketImpl.getInetAddress()


getInetAddresses

getInetAddresses o7planning.org
  • NetworkInterface.getInetAddresses()


getInfinity

getInfinity o7planning.org
  • DecimalFormatSymbols.getInfinity()


getInfo

getInfo o7planning.org
  • Identity.getInfo()
  • Provider.getInfo()


getInheritsPopupMenu

getInheritsPopupMenu o7planning.org
  • JComponent.getInheritsPopupMenu()


getInit

getInit o7planning.org
  • MemoryUsage.getInit()


getInitialComponent

getInitialComponent o7planning.org
  • FocusTraversalPolicy.getInitialComponent(Window)
  • InternalFrameFocusTraversalPolicy.getInitialComponent(JInternalFrame)


getInitialContext

getInitialContext o7planning.org
  • InitialContextFactory.getInitialContext(Hashtable<?, ?>)
  • NamingManager.getInitialContext(Hashtable<?, ?>)


getInitialDelay

getInitialDelay o7planning.org
  • Timer.getInitialDelay()
  • ToolTipManager.getInitialDelay()


getInitialLocation

getInitialLocation o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getInitialLocation(Insets)


getInitialPolicies

getInitialPolicies o7planning.org
  • PKIXParameters.getInitialPolicies()


getInitialSelectionValue

getInitialSelectionValue o7planning.org
  • JOptionPane.getInitialSelectionValue()


getInitialValue

getInitialValue o7planning.org
  • JOptionPane.getInitialValue()


getInitialValueIndex

getInitialValueIndex o7planning.org
  • BasicOptionPaneUI.getInitialValueIndex()


getInitiatedClasses

getInitiatedClasses o7planning.org
  • Instrumentation.getInitiatedClasses(ClassLoader)


getInitiatorAddress

getInitiatorAddress o7planning.org
  • ChannelBinding.getInitiatorAddress()


getInitThreshold

getInitThreshold o7planning.org
  • CounterMonitor.getInitThreshold()
  • CounterMonitorMBean.getInitThreshold()


getInput

getInput o7planning.org
  • ImageReader.getInput()
  • InvalidPathException.getInput()
  • LSLoadEvent.getInput()
  • LSProgressEvent.getInput()
  • URISyntaxException.getInput()


getInputArguments

getInputArguments o7planning.org
  • RuntimeMXBean.getInputArguments()


getInputAttributes

getInputAttributes o7planning.org
  • HTMLEditorKit.getInputAttributes()
  • JTextPane.getInputAttributes()
  • StyledEditorKit.getInputAttributes()


getInputClass

getInputClass o7planning.org
  • ImageInputStreamSpi.getInputClass()


getInputContext

getInputContext o7planning.org
  • Component.getInputContext()
  • Window.getInputContext()


getInputEncoding

getInputEncoding o7planning.org
  • Document.getInputEncoding()
  • Entity.getInputEncoding()


getInputEvent

getInputEvent o7planning.org
  • HyperlinkEvent.getInputEvent()


getInputLength

getInputLength o7planning.org
  • MalformedInputException.getInputLength()
  • UnmappableCharacterException.getInputLength()


getInputMap

getInputMap o7planning.org
  • JComponent.getInputMap()
  • JComponent.getInputMap(int)


getInputMethodControlObject

getInputMethodControlObject o7planning.org
  • InputContext.getInputMethodControlObject()


getInputMethodDisplayName

getInputMethodDisplayName o7planning.org
  • InputMethodDescriptor.getInputMethodDisplayName(Locale, Locale)


getInputMethodIcon

getInputMethodIcon o7planning.org
  • InputMethodDescriptor.getInputMethodIcon(Locale)


getInputMethodListeners

getInputMethodListeners o7planning.org
  • Component.getInputMethodListeners()


getInputMethodRequests

getInputMethodRequests o7planning.org
  • Component.getInputMethodRequests()
  • JTextComponent.getInputMethodRequests()
  • TextComponent.getInputMethodRequests()


getInputSource

getInputSource o7planning.org
  • SAXSource.getInputSource()


getInputStream

getInputStream o7planning.org
  • ApplicationException.getInputStream()
  • DataHandler.getInputStream()
  • DataSource.getInputStream()
  • FileDataSource.getInputStream()
  • JarFile.getInputStream(ZipEntry)
  • Process.getInputStream()
  • RemoteCall.getInputStream()
  • Socket.getInputStream()
  • SocketImpl.getInputStream()
  • StreamSource.getInputStream()
  • URLConnection.getInputStream()
  • URLDataSource.getInputStream()
  • ZipFile.getInputStream(ZipEntry)


getInputTypes

getInputTypes o7planning.org
  • ImageReaderSpi.getInputTypes()


getInputValue

getInputValue o7planning.org
  • JOptionPane.getInputValue()


getInputVerifier

getInputVerifier o7planning.org
  • JComponent.getInputVerifier()


getInsertionIndex

getInsertionIndex o7planning.org
  • TextHitInfo.getInsertionIndex()


getInsertPositionOffset

getInsertPositionOffset o7planning.org
  • InputMethodRequests.getInsertPositionOffset()


getInset

getInset o7planning.org
  • StyleSheet.BoxPainter.getInset(int, View)


getInsets

getInsets o7planning.org
  • BasicComboBoxUI.getInsets()
  • BasicDesktopIconUI.getInsets(JComponent)
  • BasicSplitPaneDivider.getInsets()
  • BasicSplitPaneUI.getInsets(JComponent)
  • BasicToolBarUI.DragWindow.getInsets()
  • Container.getInsets()
  • JComponent.getInsets(Insets)
  • JComponent.getInsets()
  • JViewport.getInsets(Insets)
  • JViewport.getInsets()
  • NimbusStyle.getInsets(SynthContext, Insets)
  • SynthStyle.getInsets(SynthContext, Insets)
  • UIDefaults.getInsets(Object, Locale)
  • UIDefaults.getInsets(Object)
  • UIManager.getInsets(Object, Locale)
  • UIManager.getInsets(Object)


getInsetSpan

getInsetSpan o7planning.org
  • AsyncBoxView.getInsetSpan(int)


getInsideAllocation

getInsideAllocation o7planning.org
  • CompositeView.getInsideAllocation(Shape)


getInsideBorder

getInsideBorder o7planning.org
  • CompoundBorder.getInsideBorder()


getInstalledLookAndFeels

getInstalledLookAndFeels o7planning.org
  • UIManager.getInstalledLookAndFeels()


getInstance

getInstance o7planning.org
  • AlgorithmParameterGenerator.getInstance(String, Provider)
  • AlgorithmParameterGenerator.getInstance(String, String)
  • AlgorithmParameterGenerator.getInstance(String)
  • AlgorithmParameters.getInstance(String, Provider)
  • AlgorithmParameters.getInstance(String, String)
  • AlgorithmParameters.getInstance(String)
  • AlphaComposite.getInstance(int, float)
  • AlphaComposite.getInstance(int)
  • Calendar.getInstance(TimeZone, Locale)
  • Calendar.getInstance(Locale)
  • Calendar.getInstance(TimeZone)
  • Calendar.getInstance()
  • CertPathBuilder.getInstance(String, Provider)
  • CertPathBuilder.getInstance(String, String)
  • CertPathBuilder.getInstance(String)
  • CertPathValidator.getInstance(String, Provider)
  • CertPathValidator.getInstance(String, String)
  • CertPathValidator.getInstance(String)
  • CertStore.getInstance(String, CertStoreParameters, Provider)
  • CertStore.getInstance(String, CertStoreParameters, String)
  • CertStore.getInstance(String, CertStoreParameters)
  • CertificateFactory.getInstance(String, Provider)
  • CertificateFactory.getInstance(String, String)
  • CertificateFactory.getInstance(String)
  • Cipher.getInstance(String, Provider)
  • Cipher.getInstance(String, String)
  • Cipher.getInstance(String)
  • Collator.getInstance(Locale)
  • Collator.getInstance()
  • CollatorProvider.getInstance(Locale)
  • ColorSpace.getInstance(int)
  • Configuration.getInstance(String, Configuration.Parameters, Provider)
  • Configuration.getInstance(String, Configuration.Parameters, String)
  • Configuration.getInstance(String, Configuration.Parameters)
  • Currency.getInstance(Locale)
  • Currency.getInstance(String)
  • DateFormat.getInstance()
  • DateFormatSymbols.getInstance(Locale)
  • DateFormatSymbols.getInstance()
  • DateFormatSymbolsProvider.getInstance(Locale)
  • DecimalFormatSymbols.getInstance(Locale)
  • DecimalFormatSymbols.getInstance()
  • DecimalFormatSymbolsProvider.getInstance(Locale)
  • ExemptionMechanism.getInstance(String, Provider)
  • ExemptionMechanism.getInstance(String, String)
  • ExemptionMechanism.getInstance(String)
  • GSSManager.getInstance()
  • ICC_Profile.getInstance(InputStream)
  • ICC_Profile.getInstance(String)
  • ICC_Profile.getInstance(int)
  • ICC_Profile.getInstance(byte[])
  • InputContext.getInstance()
  • KeyAgreement.getInstance(String, Provider)
  • KeyAgreement.getInstance(String, String)
  • KeyAgreement.getInstance(String)
  • KeyFactory.getInstance(String, Provider)
  • KeyFactory.getInstance(String, String)
  • KeyFactory.getInstance(String)
  • KeyGenerator.getInstance(String, Provider)
  • KeyGenerator.getInstance(String, String)
  • KeyGenerator.getInstance(String)
  • KeyInfoFactory.getInstance()
  • KeyInfoFactory.getInstance(String, String)
  • KeyInfoFactory.getInstance(String, Provider)
  • KeyInfoFactory.getInstance(String)
  • KeyManagerFactory.getInstance(String, Provider)
  • KeyManagerFactory.getInstance(String, String)
  • KeyManagerFactory.getInstance(String)
  • KeyPairGenerator.getInstance(String, Provider)
  • KeyPairGenerator.getInstance(String, String)
  • KeyPairGenerator.getInstance(String)
  • KeyStore.getInstance(String, Provider)
  • KeyStore.getInstance(String, String)
  • KeyStore.getInstance(String)
  • KeyTab.getInstance(KerberosPrincipal)
  • KeyTab.getInstance()
  • KeyTab.getInstance(KerberosPrincipal, File)
  • KeyTab.getInstance(File)
  • LayoutStyle.getInstance()
  • Mac.getInstance(String, Provider)
  • Mac.getInstance(String, String)
  • Mac.getInstance(String)
  • MessageDigest.getInstance(String, Provider)
  • MessageDigest.getInstance(String, String)
  • MessageDigest.getInstance(String)
  • NumberFormat.getInstance(Locale)
  • NumberFormat.getInstance()
  • ObjectName.getInstance(ObjectName)
  • ObjectName.getInstance(String, Hashtable<String, String>)
  • ObjectName.getInstance(String, String, String)
  • ObjectName.getInstance(String)
  • Policy.getInstance(String, Policy.Parameters, Provider)
  • Policy.getInstance(String, Policy.Parameters, String)
  • Policy.getInstance(String, Policy.Parameters)
  • SSLContext.getInstance(String, Provider)
  • SSLContext.getInstance(String, String)
  • SSLContext.getInstance(String)
  • SecretKeyFactory.getInstance(String, Provider)
  • SecretKeyFactory.getInstance(String, String)
  • SecretKeyFactory.getInstance(String)
  • SecureRandom.getInstance(String, Provider)
  • SecureRandom.getInstance(String, String)
  • SecureRandom.getInstance(String)
  • Signature.getInstance(String, Provider)
  • Signature.getInstance(String, String)
  • Signature.getInstance(String)
  • SyncFactory.getInstance(String)
  • TransformService.getInstance(String, String, String)
  • TransformService.getInstance(String, String, Provider)
  • TransformService.getInstance(String, String)
  • TrustManagerFactory.getInstance(String, Provider)
  • TrustManagerFactory.getInstance(String, String)
  • TrustManagerFactory.getInstance(String)
  • X509Certificate.getInstance(byte[])
  • X509Certificate.getInstance(InputStream)
  • XMLSignatureFactory.getInstance()
  • XMLSignatureFactory.getInstance(String, String)
  • XMLSignatureFactory.getInstance(String, Provider)
  • XMLSignatureFactory.getInstance(String)


getInstanceFollowRedirects

getInstanceFollowRedirects o7planning.org
  • HttpURLConnection.getInstanceFollowRedirects()


getInstanceOf

getInstanceOf o7planning.org
  • Beans.getInstanceOf(Object, Class<?>)


getInstanceStrong

getInstanceStrong o7planning.org
  • SecureRandom.getInstanceStrong()


getInstant

getInstant o7planning.org
  • ZoneOffsetTransition.getInstant()


getInstantiatedMethodType

getInstantiatedMethodType o7planning.org
  • SerializedLambda.getInstantiatedMethodType()


getInstrument

getInstrument o7planning.org
  • Soundbank.getInstrument(Patch)


getInstruments

getInstruments o7planning.org
  • Soundbank.getInstruments()


getInt

getInt o7planning.org
  • AbstractPreferences.getInt(String, int)
  • Array.getInt(Object, int)
  • ByteBuffer.getInt(int)
  • ByteBuffer.getInt()
  • CallableStatement.getInt(String)
  • CallableStatement.getInt(int)
  • Field.getInt(Object)
  • Preferences.getInt(String, int)
  • ResultSet.getInt(String)
  • ResultSet.getInt(int)
  • SynthStyle.getInt(SynthContext, Object, int)
  • UIDefaults.getInt(Object, Locale)
  • UIDefaults.getInt(Object)
  • UIManager.getInt(Object, Locale)
  • UIManager.getInt(Object)


getInteger

getInteger o7planning.org
  • Integer.getInteger(String, Integer)
  • Integer.getInteger(String, int)
  • Integer.getInteger(String)


getIntegerAttributeValue

getIntegerAttributeValue o7planning.org
  • HTML.getIntegerAttributeValue(AttributeSet, HTML.Attribute, int)


getIntegerInstance

getIntegerInstance o7planning.org
  • NumberFormat.getIntegerInstance(Locale)
  • NumberFormat.getIntegerInstance()
  • NumberFormatProvider.getIntegerInstance(Locale)


getIntegState

getIntegState o7planning.org
  • GSSContext.getIntegState()


getIntercellSpacing

getIntercellSpacing o7planning.org
  • JTable.getIntercellSpacing()


getInterface

getInterface o7planning.org
  • Invocable.getInterface(Object, Class<T>)
  • Invocable.getInterface(Class<T>)
  • MulticastSocket.getInterface()


getInterfaceAddresses

getInterfaceAddresses o7planning.org
  • NetworkInterface.getInterfaceAddresses()


getInterfaces

getInterfaces o7planning.org
  • Class.getInterfaces()
  • TypeElement.getInterfaces()


getInteriorRectangle

getInteriorRectangle o7planning.org
  • AbstractBorder.getInteriorRectangle(Component, Border, int, int, int, int)
  • AbstractBorder.getInteriorRectangle(Component, int, int, int, int)


getInternalFrame

getInternalFrame o7planning.org
  • InternalFrameEvent.getInternalFrame()
  • JInternalFrame.JDesktopIcon.getInternalFrame()


getInternalFrameAltMaximizeIcon

getInternalFrameAltMaximizeIcon o7planning.org
  • MetalIconFactory.getInternalFrameAltMaximizeIcon(int)


getInternalFrameBorder

getInternalFrameBorder o7planning.org
  • BasicBorders.getInternalFrameBorder()


getInternalFrameCloseIcon

getInternalFrameCloseIcon o7planning.org
  • MetalIconFactory.getInternalFrameCloseIcon(int)


getInternalFrameDefaultMenuIcon

getInternalFrameDefaultMenuIcon o7planning.org
  • MetalIconFactory.getInternalFrameDefaultMenuIcon()


getInternalFrameListeners

getInternalFrameListeners o7planning.org
  • JInternalFrame.getInternalFrameListeners()


getInternalFrameMaximizeIcon

getInternalFrameMaximizeIcon o7planning.org
  • MetalIconFactory.getInternalFrameMaximizeIcon(int)


getInternalFrameMinimizeIcon

getInternalFrameMinimizeIcon o7planning.org
  • MetalIconFactory.getInternalFrameMinimizeIcon(int)


getInternalSubset

getInternalSubset o7planning.org
  • DocumentType.getInternalSubset()


getInternationalCurrencySymbol

getInternationalCurrencySymbol o7planning.org
  • DecimalFormatSymbols.getInternationalCurrencySymbol()


getInterpolationType

getInterpolationType o7planning.org
  • AffineTransformOp.getInterpolationType()


getIntParameter

getIntParameter o7planning.org
  • ParameterBlock.getIntParameter(int)


getInvalidCharacters

getInvalidCharacters o7planning.org
  • MaskFormatter.getInvalidCharacters()


getInvalidityDate

getInvalidityDate o7planning.org
  • CertificateRevokedException.getInvalidityDate()


getInverted

getInverted o7planning.org
  • JSlider.getInverted()


getInvocationHandler

getInvocationHandler o7planning.org
  • Proxy.getInvocationHandler(Object)


getInvoker

getInvoker o7planning.org
  • JPopupMenu.getInvoker()


getInvokesStopCellEditing

getInvokesStopCellEditing o7planning.org
  • JTree.getInvokesStopCellEditing()


getIOException

getIOException o7planning.org
  • PrinterIOException.getIOException()


getISO3Country

getISO3Country o7planning.org
  • Locale.getISO3Country()


getISO3Language

getISO3Language o7planning.org
  • Locale.getISO3Language()


getISOCountries

getISOCountries o7planning.org
  • Locale.getISOCountries()


getISOLanguages

getISOLanguages o7planning.org
  • Locale.getISOLanguages()


getIssuer

getIssuer o7planning.org
  • X509CertSelector.getIssuer()


getIssuerAlternativeNames

getIssuerAlternativeNames o7planning.org
  • X509Certificate.getIssuerAlternativeNames()


getIssuerAsBytes

getIssuerAsBytes o7planning.org
  • X509CertSelector.getIssuerAsBytes()


getIssuerAsString

getIssuerAsString o7planning.org
  • X509CertSelector.getIssuerAsString()


getIssuerDN

getIssuerDN o7planning.org
  • X509CRL.getIssuerDN()
  • X509Certificate.getIssuerDN()
  • X509Certificate.getIssuerDN()


getIssuerName

getIssuerName o7planning.org
  • X509IssuerSerial.getIssuerName()


getIssuerNames

getIssuerNames o7planning.org
  • X509CRLSelector.getIssuerNames()


getIssuers

getIssuers o7planning.org
  • X509CRLSelector.getIssuers()


getIssuerUniqueID

getIssuerUniqueID o7planning.org
  • X509Certificate.getIssuerUniqueID()


getIssuerX500Principal

getIssuerX500Principal o7planning.org
  • X509CRL.getIssuerX500Principal()
  • X509Certificate.getIssuerX500Principal()


getItalicAngle

getItalicAngle o7planning.org
  • Font.getItalicAngle()


getItem

getItem o7planning.org
  • BasicComboBoxEditor.getItem()
  • Choice.getItem(int)
  • ComboBoxEditor.getItem()
  • ItemEvent.getItem()
  • JMenu.getItem(int)
  • List.getItem(int)
  • Menu.getItem(int)


getItemAt

getItemAt o7planning.org
  • JComboBox.getItemAt(int)


getItemCount

getItemCount o7planning.org
  • Choice.getItemCount()
  • JComboBox.getItemCount()
  • JMenu.getItemCount()
  • List.getItemCount()
  • Menu.getItemCount()


getItemListeners

getItemListeners o7planning.org
  • AbstractButton.getItemListeners()
  • Checkbox.getItemListeners()
  • CheckboxMenuItem.getItemListeners()
  • Choice.getItemListeners()
  • DefaultButtonModel.getItemListeners()
  • JComboBox.getItemListeners()
  • List.getItemListeners()


getItems

getItems o7planning.org
  • List.getItems()


getItemSelectable

getItemSelectable o7planning.org
  • ItemEvent.getItemSelectable()


getIterationCount

getIterationCount o7planning.org
  • PBEKey.getIterationCount()
  • PBEKeySpec.getIterationCount()
  • PBEParameterSpec.getIterationCount()


getIterator

getIterator o7planning.org
  • AttributedString.getIterator(AttributedCharacterIterator.Attribute[], int, int)
  • AttributedString.getIterator(AttributedCharacterIterator.Attribute[])
  • AttributedString.getIterator()
  • HTMLDocument.getIterator(HTML.Tag)


getIV

getIV o7planning.org
  • Cipher.getIV()
  • GCMParameterSpec.getIV()
  • IvParameterSpec.getIV()
  • RC2ParameterSpec.getIV()
  • RC5ParameterSpec.getIV()


getJarEntry

getJarEntry o7planning.org
  • JarFile.getJarEntry(String)
  • JarURLConnection.getJarEntry()


getJarFile

getJarFile o7planning.org
  • JarURLConnection.getJarFile()


getJarFiles

getJarFiles o7planning.org
  • MLetContent.getJarFiles()


getJarFileURL

getJarFileURL o7planning.org
  • JarURLConnection.getJarFileURL()


getJavaEncoding

getJavaEncoding o7planning.org
  • AbstractMarshallerImpl.getJavaEncoding(String)


getJavaFileForInput

getJavaFileForInput o7planning.org
  • ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind)
  • JavaFileManager.getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind)


getJavaFileForOutput

getJavaFileForOutput o7planning.org
  • ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject)
  • JavaFileManager.getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject)


getJavaFileObjects

getJavaFileObjects o7planning.org
  • StandardJavaFileManager.getJavaFileObjects(String...)
  • StandardJavaFileManager.getJavaFileObjects(File...)


getJavaFileObjectsFromFiles

getJavaFileObjectsFromFiles o7planning.org
  • StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File>)


getJavaFileObjectsFromStrings

getJavaFileObjectsFromStrings o7planning.org
  • StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String>)


getJavaInitializationString

getJavaInitializationString o7planning.org
  • PropertyEditor.getJavaInitializationString()
  • PropertyEditorSupport.getJavaInitializationString()


getJAXBNode

getJAXBNode o7planning.org
  • Binder.getJAXBNode(XmlNode)


getJDBCMajorVersion

getJDBCMajorVersion o7planning.org
  • DatabaseMetaData.getJDBCMajorVersion()


getJDBCMinorVersion

getJDBCMinorVersion o7planning.org
  • DatabaseMetaData.getJDBCMinorVersion()


getJMenuBar

getJMenuBar o7planning.org
  • JApplet.getJMenuBar()
  • JDialog.getJMenuBar()
  • JFrame.getJMenuBar()
  • JInternalFrame.getJMenuBar()
  • JRootPane.getJMenuBar()


getJobName

getJobName o7planning.org
  • PrinterJob.getJobName()


getJoinType

getJoinType o7planning.org
  • JoinRowSet.getJoinType()


getJustificationInfo

getJustificationInfo o7planning.org
  • GraphicAttribute.getJustificationInfo()


getJustifiedLayout

getJustifiedLayout o7planning.org
  • TextLayout.getJustifiedLayout(float)


getKeepAlive

getKeepAlive o7planning.org
  • Socket.getKeepAlive()


getKeepAliveTime

getKeepAliveTime o7planning.org
  • ThreadPoolExecutor.getKeepAliveTime(TimeUnit)


getKernel

getKernel o7planning.org
  • ConvolveOp.getKernel()


getKernelData

getKernelData o7planning.org
  • Kernel.getKernelData(float[])


getKey

getKey o7planning.org
  • AbstractMap.SimpleEntry.getKey()
  • AbstractMap.SimpleImmutableEntry.getKey()
  • AccessibleRelation.getKey()
  • DESKeySpec.getKey()
  • DESedeKeySpec.getKey()
  • KeySelectorResult.getKey()
  • KeyStore.getKey(String, char[])
  • Map.Entry.getKey()
  • MenuShortcut.getKey()
  • MissingResourceException.getKey()
  • PreferenceChangeEvent.getKey()


getKeyChar

getKeyChar o7planning.org
  • AWTKeyStroke.getKeyChar()
  • KeyEvent.getKeyChar()


getKeyCode

getKeyCode o7planning.org
  • AWTKeyStroke.getKeyCode()
  • KeyEvent.getKeyCode()


getKeyColumns

getKeyColumns o7planning.org
  • CachedRowSet.getKeyColumns()


getKeyEventDispatchers

getKeyEventDispatchers o7planning.org
  • KeyboardFocusManager.getKeyEventDispatchers()


getKeyEventPostProcessors

getKeyEventPostProcessors o7planning.org
  • KeyboardFocusManager.getKeyEventPostProcessors()


getKeyEventType

getKeyEventType o7planning.org
  • AWTKeyStroke.getKeyEventType()


getKeyId

getKeyId o7planning.org
  • PGPData.getKeyId()


getKeyInfo

getKeyInfo o7planning.org
  • XMLSignature.getKeyInfo()


getKeyInfoFactory

getKeyInfoFactory o7planning.org
  • XMLSignatureFactory.getKeyInfoFactory()


getKeyLength

getKeyLength o7planning.org
  • PBEKeySpec.getKeyLength()


getKeyListener

getKeyListener o7planning.org
  • BasicComboPopup.getKeyListener()
  • ComboPopup.getKeyListener()


getKeyListeners

getKeyListeners o7planning.org
  • Component.getKeyListeners()


getKeyLocation

getKeyLocation o7planning.org
  • KeyEvent.getKeyLocation()


getKeyManagers

getKeyManagers o7planning.org
  • KeyManagerFactory.getKeyManagers()


getKeymap

getKeymap o7planning.org
  • JTextComponent.getKeymap(String)
  • JTextComponent.getKeymap()


getKeymapName

getKeymapName o7planning.org
  • BasicTextUI.getKeymapName()


getKeyModifiersText

getKeyModifiersText o7planning.org
  • KeyEvent.getKeyModifiersText(int)


getKeyPacket

getKeyPacket o7planning.org
  • PGPData.getKeyPacket()


getKeyProperty

getKeyProperty o7planning.org
  • ObjectName.getKeyProperty(String)


getKeyPropertyList

getKeyPropertyList o7planning.org
  • ObjectName.getKeyPropertyList()


getKeyPropertyListString

getKeyPropertyListString o7planning.org
  • ObjectName.getKeyPropertyListString()


getKeys

getKeys o7planning.org
  • AbstractAction.getKeys()
  • KeyTab.getKeys(KerberosPrincipal)
  • ListResourceBundle.getKeys()
  • PropertyResourceBundle.getKeys()
  • ResourceBundle.getKeys()


getKeySelectionManager

getKeySelectionManager o7planning.org
  • JComboBox.getKeySelectionManager()


getKeySelector

getKeySelector o7planning.org
  • DOMCryptoContext.getKeySelector()
  • XMLCryptoContext.getKeySelector()


getKeySelectorResult

getKeySelectorResult o7planning.org
  • XMLSignature.getKeySelectorResult()


getKeysize

getKeysize o7planning.org
  • RSAKeyGenParameterSpec.getKeysize()


getKeySpec

getKeySpec o7planning.org
  • EncryptedPrivateKeyInfo.getKeySpec(Key, Provider)
  • EncryptedPrivateKeyInfo.getKeySpec(Key, String)
  • EncryptedPrivateKeyInfo.getKeySpec(Key)
  • EncryptedPrivateKeyInfo.getKeySpec(Cipher)
  • KeyFactory.getKeySpec(Key, Class<T>)
  • SecretKeyFactory.getKeySpec(SecretKey, Class<?>)


getKeyStore

getKeyStore o7planning.org
  • KeyStore.Builder.getKeyStore()


getKeyStroke

getKeyStroke o7planning.org
  • KeyStroke.getKeyStroke(String)
  • KeyStroke.getKeyStroke(int, int)
  • KeyStroke.getKeyStroke(int, int, boolean)
  • KeyStroke.getKeyStroke(Character, int)
  • KeyStroke.getKeyStroke(char, boolean)
  • KeyStroke.getKeyStroke(char)


getKeyStrokeForEvent

getKeyStrokeForEvent o7planning.org
  • KeyStroke.getKeyStrokeForEvent(KeyEvent)


getKeyStrokesForAction

getKeyStrokesForAction o7planning.org
  • Keymap.getKeyStrokesForAction(Action)


getKeyText

getKeyText o7planning.org
  • KeyEvent.getKeyText(int)


getKeyType

getKeyType o7planning.org
  • KerberosKey.getKeyType()


getKeyUsage

getKeyUsage o7planning.org
  • X509CertSelector.getKeyUsage()
  • X509Certificate.getKeyUsage()


getKind

getKind o7planning.org
  • Diagnostic.getKind()
  • Element.getKind()
  • ForwardingJavaFileObject.getKind()
  • JavaFileObject.getKind()
  • SimpleJavaFileObject.getKind()
  • TypeMirror.getKind()


getL

getL o7planning.org
  • DHParameterSpec.getL()


getLabel

getLabel o7planning.org
  • AbstractButton.getLabel()
  • Button.getLabel()
  • Checkbox.getLabel()
  • JPopupMenu.getLabel()
  • MenuItem.getLabel()
  • Option.getLabel()


getLabelFor

getLabelFor o7planning.org
  • JLabel.getLabelFor()


getLabelTable

getLabelTable o7planning.org
  • JSlider.getLabelTable()


getLanguage

getLanguage o7planning.org
  • Locale.getLanguage()


getLanguageName

getLanguageName o7planning.org
  • ScriptEngineFactory.getLanguageName()


getLanguageVersion

getLanguageVersion o7planning.org
  • ScriptEngineFactory.getLanguageVersion()


getLargeDisplayIcon

getLargeDisplayIcon o7planning.org
  • AbstractColorChooserPanel.getLargeDisplayIcon()


getLargeMaxRows

getLargeMaxRows o7planning.org
  • Statement.getLargeMaxRows()


getLargestMinimum

getLargestMinimum o7planning.org
  • ValueRange.getLargestMinimum()


getLargestPoolSize

getLargestPoolSize o7planning.org
  • ThreadPoolExecutor.getLargestPoolSize()


getLargeUpdateCount

getLargeUpdateCount o7planning.org
  • Statement.getLargeUpdateCount()


getLargeUpdateCounts

getLargeUpdateCounts o7planning.org
  • BatchUpdateException.getLargeUpdateCounts()


getLast

getLast o7planning.org
  • ArrayDeque.getLast()
  • ConcurrentLinkedDeque.getLast()
  • Deque.getLast()
  • LinkedBlockingDeque.getLast()
  • LinkedList.getLast()


getLastAccessedTime

getLastAccessedTime o7planning.org
  • SSLSession.getLastAccessedTime()


getLastAccessTime

getLastAccessTime o7planning.org
  • ZipEntry.getLastAccessTime()


getLastChild

getLastChild o7planning.org
  • DefaultMutableTreeNode.getLastChild()
  • IIOMetadataNode.getLastChild()
  • Node.getLastChild()


getLastChildPath

getLastChildPath o7planning.org
  • BasicTreeUI.getLastChildPath(TreePath)


getLastColumn

getLastColumn o7planning.org
  • AccessibleTableModelChange.getLastColumn()
  • JTable.AccessibleJTable.AccessibleJTableModelChange.getLastColumn()


getLastComponent

getLastComponent o7planning.org
  • ContainerOrderFocusTraversalPolicy.getLastComponent(Container)
  • DefaultFocusManager.getLastComponent(Container)
  • FocusTraversalPolicy.getLastComponent(Container)
  • LayoutFocusTraversalPolicy.getLastComponent(Container)
  • SortingFocusTraversalPolicy.getLastComponent(Container)


getLastCursor

getLastCursor o7planning.org
  • JInternalFrame.getLastCursor()


getLastDividerLocation

getLastDividerLocation o7planning.org
  • JSplitPane.getLastDividerLocation()


getLastDragLocation

getLastDragLocation o7planning.org
  • BasicSplitPaneUI.getLastDragLocation()


getLastIndex

getLastIndex o7planning.org
  • ListSelectionEvent.getLastIndex()


getLastLeaf

getLastLeaf o7planning.org
  • DefaultMutableTreeNode.getLastLeaf()


getLastModified

getLastModified o7planning.org
  • FileObject.getLastModified()
  • ForwardingFileObject.getLastModified()
  • SimpleJavaFileObject.getLastModified()
  • URLConnection.getLastModified()


getLastModifiedTime

getLastModifiedTime o7planning.org
  • Files.getLastModifiedTime(Path, LinkOption...)
  • ZipEntry.getLastModifiedTime()


getLastPathComponent

getLastPathComponent o7planning.org
  • TreePath.getLastPathComponent()


getLastRow

getLastRow o7planning.org
  • AccessibleTableModelChange.getLastRow()
  • JTable.AccessibleJTable.AccessibleJTableModelChange.getLastRow()
  • TableModelEvent.getLastRow()


getLastSelectedPathComponent

getLastSelectedPathComponent o7planning.org
  • JTree.getLastSelectedPathComponent()


getLastVisibleIndex

getLastVisibleIndex o7planning.org
  • JList.getLastVisibleIndex()


getLatency

getLatency o7planning.org
  • Synthesizer.getLatency()


getLateReflectionDelay

getLateReflectionDelay o7planning.org
  • ReverbType.getLateReflectionDelay()


getLateReflectionIntensity

getLateReflectionIntensity o7planning.org
  • ReverbType.getLateReflectionIntensity()


getLayer

getLayer o7planning.org
  • JInternalFrame.getLayer()
  • JLayeredPane.getLayer(Component)
  • JLayeredPane.getLayer(JComponent)


getLayeredPane

getLayeredPane o7planning.org
  • JApplet.getLayeredPane()
  • JDialog.getLayeredPane()
  • JFrame.getLayeredPane()
  • JInternalFrame.getLayeredPane()
  • JRootPane.getLayeredPane()
  • JWindow.getLayeredPane()
  • RootPaneContainer.getLayeredPane()


getLayeredPaneAbove

getLayeredPaneAbove o7planning.org
  • JLayeredPane.getLayeredPaneAbove(Component)


getLayerEventMask

getLayerEventMask o7planning.org
  • JLayer.getLayerEventMask()


getLayout

getLayout o7planning.org
  • Container.getLayout()
  • TextMeasurer.getLayout(int, int)


getLayoutAlignmentX

getLayoutAlignmentX o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentX(Container)
  • BorderLayout.getLayoutAlignmentX(Container)
  • BoxLayout.getLayoutAlignmentX(Container)
  • CardLayout.getLayoutAlignmentX(Container)
  • GridBagLayout.getLayoutAlignmentX(Container)
  • GroupLayout.getLayoutAlignmentX(Container)
  • JRootPane.RootLayout.getLayoutAlignmentX(Container)
  • LayoutManager2.getLayoutAlignmentX(Container)
  • OverlayLayout.getLayoutAlignmentX(Container)
  • SpringLayout.getLayoutAlignmentX(Container)


getLayoutAlignmentY

getLayoutAlignmentY o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentY(Container)
  • BorderLayout.getLayoutAlignmentY(Container)
  • BoxLayout.getLayoutAlignmentY(Container)
  • CardLayout.getLayoutAlignmentY(Container)
  • GridBagLayout.getLayoutAlignmentY(Container)
  • GroupLayout.getLayoutAlignmentY(Container)
  • JRootPane.RootLayout.getLayoutAlignmentY(Container)
  • LayoutManager2.getLayoutAlignmentY(Container)
  • OverlayLayout.getLayoutAlignmentY(Container)
  • SpringLayout.getLayoutAlignmentY(Container)


getLayoutComponent

getLayoutComponent o7planning.org
  • BorderLayout.getLayoutComponent(Container, Object)
  • BorderLayout.getLayoutComponent(Object)


getLayoutDimensions

getLayoutDimensions o7planning.org
  • GridBagLayout.getLayoutDimensions()


getLayoutFlags

getLayoutFlags o7planning.org
  • GlyphVector.getLayoutFlags()


getLayoutInfo

getLayoutInfo o7planning.org
  • GridBagLayout.getLayoutInfo(Container, int)


GetLayoutInfo

GetLayoutInfo o7planning.org
  • GridBagLayout.GetLayoutInfo(Container, int)


getLayoutOrientation

getLayoutOrientation o7planning.org
  • JList.getLayoutOrientation()


getLayoutOrigin

getLayoutOrigin o7planning.org
  • GridBagLayout.getLayoutOrigin()


getLayoutPath

getLayoutPath o7planning.org
  • TextLayout.getLayoutPath()


getLayoutQueue

getLayoutQueue o7planning.org
  • AsyncBoxView.getLayoutQueue()


getLayoutStyle

getLayoutStyle o7planning.org
  • GroupLayout.getLayoutStyle()
  • LookAndFeel.getLayoutStyle()
  • MetalLookAndFeel.getLayoutStyle()


getLayoutView

getLayoutView o7planning.org
  • ParagraphView.getLayoutView(int)


getLayoutViewCount

getLayoutViewCount o7planning.org
  • ParagraphView.getLayoutViewCount()


getLayoutWeights

getLayoutWeights o7planning.org
  • GridBagLayout.getLayoutWeights()


getLeader

getLeader o7planning.org
  • TabStop.getLeader()


getLeading

getLeading o7planning.org
  • FontMetrics.getLeading()
  • LineMetrics.getLeading()
  • TextLayout.getLeading()


getLeadSelectionIndex

getLeadSelectionIndex o7planning.org
  • DefaultListSelectionModel.getLeadSelectionIndex()
  • JList.getLeadSelectionIndex()
  • ListSelectionModel.getLeadSelectionIndex()


getLeadSelectionPath

getLeadSelectionPath o7planning.org
  • DefaultTreeSelectionModel.getLeadSelectionPath()
  • JTree.getLeadSelectionPath()
  • TreeSelectionModel.getLeadSelectionPath()


getLeadSelectionRow

getLeadSelectionRow o7planning.org
  • BasicTreeUI.getLeadSelectionRow()
  • DefaultTreeSelectionModel.getLeadSelectionRow()
  • JTree.getLeadSelectionRow()
  • TreeSelectionModel.getLeadSelectionRow()


getLeafCount

getLeafCount o7planning.org
  • DefaultMutableTreeNode.getLeafCount()


getLeafIcon

getLeafIcon o7planning.org
  • DefaultTreeCellRenderer.getLeafIcon()


getLeastMaximum

getLeastMaximum o7planning.org
  • Calendar.getLeastMaximum(int)
  • GregorianCalendar.getLeastMaximum(int)


getLeastSignificantBits

getLeastSignificantBits o7planning.org
  • UUID.getLeastSignificantBits()


getLeftChildIndent

getLeftChildIndent o7planning.org
  • BasicTreeUI.getLeftChildIndent()


getLeftComponent

getLeftComponent o7planning.org
  • JSplitPane.getLeftComponent()


getLeftIndent

getLeftIndent o7planning.org
  • StyleConstants.getLeftIndent(AttributeSet)


getLeftInset

getLeftInset o7planning.org
  • AsyncBoxView.getLeftInset()
  • CompositeView.getLeftInset()


getLegalValues

getLegalValues o7planning.org
  • OpenMBeanAttributeInfoSupport.getLegalValues()
  • OpenMBeanParameterInfo.getLegalValues()
  • OpenMBeanParameterInfoSupport.getLegalValues()


getLength

getLength o7planning.org
  • AbstractDocument.getLength()
  • AbstractDocument.DefaultDocumentEvent.getLength()
  • Array.getLength(Object)
  • AttributeList.getLength()
  • AttributeListImpl.getLength()
  • Attributes.getLength()
  • AttributesImpl.getLength()
  • Bidi.getLength()
  • CharacterData.getLength()
  • DOMImplementationList.getLength()
  • DOMStringList.getLength()
  • DatagramPacket.getLength()
  • DefaultStyledDocument.ElementSpec.getLength()
  • Document.getLength()
  • DocumentEvent.getLength()
  • IIOByteBuffer.getLength()
  • IIOMetadataNode.getLength()
  • MidiMessage.getLength()
  • NameList.getLength()
  • NamedNodeMap.getLength()
  • NodeList.getLength()


getLengths

getLengths o7planning.org
  • JPEGHuffmanTable.getLengths()


getLevel

getLevel o7planning.org
  • DataLine.getLevel()
  • DefaultMutableTreeNode.getLevel()
  • Handler.getLevel()
  • LogRecord.getLevel()
  • Logger.getLevel()


getLevelAt

getLevelAt o7planning.org
  • Bidi.getLevelAt(int)


getLexicalHandler

getLexicalHandler o7planning.org
  • SAXResult.getLexicalHandler()


getLibraryDirectory

getLibraryDirectory o7planning.org
  • MLet.getLibraryDirectory()
  • MLetMBean.getLibraryDirectory()


getLibraryPath

getLibraryPath o7planning.org
  • RuntimeMXBean.getLibraryPath()


getLifetime

getLifetime o7planning.org
  • GSSContext.getLifetime()


getLimit

getLimit o7planning.org
  • UndoManager.getLimit()


getLimits

getLimits o7planning.org
  • ChoiceFormat.getLimits()


getLine

getLine o7planning.org
  • AudioSystem.getLine(Line.Info)
  • LineEvent.getLine()
  • Mixer.getLine(Line.Info)


getLineBreakIndex

getLineBreakIndex o7planning.org
  • TextMeasurer.getLineBreakIndex(int, float)


getLineBuffer

getLineBuffer o7planning.org
  • PlainView.getLineBuffer()
  • WrappedPlainView.getLineBuffer()


getLineClass

getLineClass o7planning.org
  • Line.Info.getLineClass()


getLineColor

getLineColor o7planning.org
  • LineBorder.getLineColor()


getLineCount

getLineCount o7planning.org
  • JTextArea.getLineCount()


getLineEndOffset

getLineEndOffset o7planning.org
  • JTextArea.getLineEndOffset(int)


getLineIncrement

getLineIncrement o7planning.org
  • Scrollbar.getLineIncrement()


getLineInfo

getLineInfo o7planning.org
  • Line.getLineInfo()


getLineInstance

getLineInstance o7planning.org
  • BreakIterator.getLineInstance(Locale)
  • BreakIterator.getLineInstance()
  • BreakIteratorProvider.getLineInstance(Locale)


getLineJoin

getLineJoin o7planning.org
  • BasicStroke.getLineJoin()


getLineLength

getLineLength o7planning.org
  • AbstractWriter.getLineLength()


getLineMetrics

getLineMetrics o7planning.org
  • Font.getLineMetrics(CharacterIterator, int, int, FontRenderContext)
  • Font.getLineMetrics(char[], int, int, FontRenderContext)
  • Font.getLineMetrics(String, int, int, FontRenderContext)
  • Font.getLineMetrics(String, FontRenderContext)
  • FontMetrics.getLineMetrics(CharacterIterator, int, int, Graphics)
  • FontMetrics.getLineMetrics(char[], int, int, Graphics)
  • FontMetrics.getLineMetrics(String, int, int, Graphics)
  • FontMetrics.getLineMetrics(String, Graphics)


getLineNumber

getLineNumber o7planning.org
  • DOMLocator.getLineNumber()
  • Diagnostic.getLineNumber()
  • LineNumberInputStream.getLineNumber()
  • LineNumberReader.getLineNumber()
  • Location.getLineNumber()
  • Locator.getLineNumber()
  • LocatorImpl.getLineNumber()
  • SAXParseException.getLineNumber()
  • ScriptException.getLineNumber()
  • SourceLocator.getLineNumber()
  • StackTraceElement.getLineNumber()
  • ValidationEventLocator.getLineNumber()
  • ValidationEventLocatorImpl.getLineNumber()


getLineOfOffset

getLineOfOffset o7planning.org
  • JTextArea.getLineOfOffset(int)


getLineSeparator

getLineSeparator o7planning.org
  • AbstractWriter.getLineSeparator()


getLineSpacing

getLineSpacing o7planning.org
  • StyleConstants.getLineSpacing(AttributeSet)


getLineStartOffset

getLineStartOffset o7planning.org
  • JTextArea.getLineStartOffset(int)


getLineWidth

getLineWidth o7planning.org
  • BasicStroke.getLineWidth()


getLineWrap

getLineWrap o7planning.org
  • JTextArea.getLineWrap()


getLink

getLink o7planning.org
  • AccessibleHypertext.getLink(int)
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.getLink(int)


getLinkCount

getLinkCount o7planning.org
  • AccessibleHypertext.getLinkCount()
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.getLinkCount()


getLinkCursor

getLinkCursor o7planning.org
  • HTMLEditorKit.getLinkCursor()


getLinkedException

getLinkedException o7planning.org
  • JAXBException.getLinkedException()
  • TypeConstraintException.getLinkedException()
  • ValidationEvent.getLinkedException()
  • ValidationEventImpl.getLinkedException()


getLinkExplanation

getLinkExplanation o7planning.org
  • LinkException.getLinkExplanation()


getLinkIndex

getLinkIndex o7planning.org
  • AccessibleHypertext.getLinkIndex(int)
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.getLinkIndex(int)


getLinkName

getLinkName o7planning.org
  • LinkRef.getLinkName()


getLinkRemainingName

getLinkRemainingName o7planning.org
  • LinkException.getLinkRemainingName()


getLinkResolvedName

getLinkResolvedName o7planning.org
  • LinkException.getLinkResolvedName()


getLinkResolvedObj

getLinkResolvedObj o7planning.org
  • LinkException.getLinkResolvedObj()


getLinkText

getLinkText o7planning.org
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.getLinkText(int)


getList

getList o7planning.org
  • BasicComboPopup.getList()
  • ComboPopup.getList()
  • SpinnerListModel.getList()


getListCellRendererComponent

getListCellRendererComponent o7planning.org
  • BasicComboBoxRenderer.getListCellRendererComponent(JList, Object, int, boolean, boolean)
  • DefaultListCellRenderer.getListCellRendererComponent(JList<?>, Object, int, boolean, boolean)
  • ListCellRenderer.getListCellRendererComponent(JList<? extends E>, E, int, boolean, boolean)
  • MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList, Object, int, boolean, boolean)


getListDataListeners

getListDataListeners o7planning.org
  • AbstractListModel.getListDataListeners()


getListener

getListener o7planning.org
  • AbstractMarshallerImpl.getListener()
  • AbstractUnmarshallerImpl.getListener()
  • EventListenerProxy.getListener()
  • Marshaller.getListener()
  • Unmarshaller.getListener()


getListenerCount

getListenerCount o7planning.org
  • EventListenerList.getListenerCount(Class<?>)
  • EventListenerList.getListenerCount()


getListenerID

getListenerID o7planning.org
  • TargetedNotification.getListenerID()


getListenerList

getListenerList o7planning.org
  • EventListenerList.getListenerList()


getListenerMethodDescriptors

getListenerMethodDescriptors o7planning.org
  • EventSetDescriptor.getListenerMethodDescriptors()


getListenerMethodName

getListenerMethodName o7planning.org
  • EventHandler.getListenerMethodName()


getListenerMethods

getListenerMethods o7planning.org
  • EventSetDescriptor.getListenerMethods()


getListeners

getListeners o7planning.org
  • AWTEventMulticaster.getListeners(EventListener, Class<T>)
  • AbstractDocument.getListeners(Class<T>)
  • AbstractListModel.getListeners(Class<T>)
  • AbstractSpinnerModel.getListeners(Class<T>)
  • AbstractTableModel.getListeners(Class<T>)
  • Button.getListeners(Class<T>)
  • Checkbox.getListeners(Class<T>)
  • CheckboxMenuItem.getListeners(Class<T>)
  • Choice.getListeners(Class<T>)
  • Component.getListeners(Class<T>)
  • Container.getListeners(Class<T>)
  • DefaultBoundedRangeModel.getListeners(Class<T>)
  • DefaultButtonModel.getListeners(Class<T>)
  • DefaultCaret.getListeners(Class<T>)
  • DefaultListSelectionModel.getListeners(Class<T>)
  • DefaultSingleSelectionModel.getListeners(Class<T>)
  • DefaultTableColumnModel.getListeners(Class<T>)
  • DefaultTreeModel.getListeners(Class<T>)
  • DefaultTreeSelectionModel.getListeners(Class<T>)
  • DragSource.getListeners(Class<T>)
  • EventListenerList.getListeners(Class<T>)
  • JComponent.getListeners(Class<T>)
  • List.getListeners(Class<T>)
  • MenuItem.getListeners(Class<T>)
  • Scrollbar.getListeners(Class<T>)
  • StyleContext.NamedStyle.getListeners(Class<T>)
  • TextComponent.getListeners(Class<T>)
  • TextField.getListeners(Class<T>)
  • Timer.getListeners(Class<T>)
  • Window.getListeners(Class<T>)


getListenerType

getListenerType o7planning.org
  • EventSetDescriptor.getListenerType()


getListPainter

getListPainter o7planning.org
  • StyleSheet.getListPainter(AttributeSet)


getListSelectionListeners

getListSelectionListeners o7planning.org
  • DefaultListSelectionModel.getListSelectionListeners()
  • JList.getListSelectionListeners()


getLoadedClassCount

getLoadedClassCount o7planning.org
  • ClassLoadingMXBean.getLoadedClassCount()


getLoadedInstruments

getLoadedInstruments o7planning.org
  • Synthesizer.getLoadedInstruments()


getLoadingImageIcon

getLoadingImageIcon o7planning.org
  • ImageView.getLoadingImageIcon()


getLoadsSynchronously

getLoadsSynchronously o7planning.org
  • ImageView.getLoadsSynchronously()


getLocalAddress

getLocalAddress o7planning.org
  • AsynchronousServerSocketChannel.getLocalAddress()
  • AsynchronousSocketChannel.getLocalAddress()
  • DatagramChannel.getLocalAddress()
  • DatagramSocket.getLocalAddress()
  • HttpExchange.getLocalAddress()
  • NetworkChannel.getLocalAddress()
  • ServerSocketChannel.getLocalAddress()
  • Socket.getLocalAddress()
  • SocketChannel.getLocalAddress()


getLocalBounds

getLocalBounds o7planning.org
  • SwingUtilities.getLocalBounds(Component)


getLocalCertificateChain

getLocalCertificateChain o7planning.org
  • SecureCacheResponse.getLocalCertificateChain()


getLocalCertificates

getLocalCertificates o7planning.org
  • HandshakeCompletedEvent.getLocalCertificates()
  • HttpsURLConnection.getLocalCertificates()
  • SSLSession.getLocalCertificates()


getLocale

getLocale o7planning.org
  • AccessibleContext.getLocale()
  • Applet.getLocale()
  • BeanContextSupport.getLocale()
  • Component.getLocale()
  • Component.AccessibleAWTComponent.getLocale()
  • DateTimeFormatter.getLocale()
  • ImageIcon.AccessibleImageIcon.getLocale()
  • ImageReader.getLocale()
  • ImageWriteParam.getLocale()
  • ImageWriter.getLocale()
  • InputContext.getLocale()
  • InputMethod.getLocale()
  • JList.AccessibleJList.AccessibleJListChild.getLocale()
  • JTable.AccessibleJTable.AccessibleJTableCell.getLocale()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocale()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getLocale()
  • LanguageCallback.getLocale()
  • List.AccessibleAWTList.AccessibleAWTListChild.getLocale()
  • MenuComponent.AccessibleAWTMenuComponent.getLocale()
  • MessageFormat.getLocale()
  • ProcessingEnvironment.getLocale()
  • ProgressMonitor.AccessibleProgressMonitor.getLocale()
  • ResourceBundle.getLocale()
  • TextSyntax.getLocale()
  • Window.getLocale()


getLocalGraphicsEnvironment

getLocalGraphicsEnvironment o7planning.org
  • GraphicsEnvironment.getLocalGraphicsEnvironment()


getLocalHost

getLocalHost o7planning.org
  • InetAddress.getLocalHost()


getLocalizedCompressionTypeName

getLocalizedCompressionTypeName o7planning.org
  • ImageWriteParam.getLocalizedCompressionTypeName()


getLocalizedDateTimePattern

getLocalizedDateTimePattern o7planning.org
  • DateTimeFormatterBuilder.getLocalizedDateTimePattern(FormatStyle, FormatStyle, Chronology, Locale)


getLocalizedInputStream

getLocalizedInputStream o7planning.org
  • Runtime.getLocalizedInputStream(InputStream)


getLocalizedMessage

getLocalizedMessage o7planning.org
  • Throwable.getLocalizedMessage()


getLocalizedName

getLocalizedName o7planning.org
  • Level.getLocalizedName()


getLocalizedOutputStream

getLocalizedOutputStream o7planning.org
  • Runtime.getLocalizedOutputStream(OutputStream)


getLocalName

getLocalName o7planning.org
  • Attributes.getLocalName(int)
  • AttributesImpl.getLocalName(int)
  • IIOMetadataNode.getLocalName()
  • Name.getLocalName()
  • Node.getLocalName()
  • StreamReaderDelegate.getLocalName()
  • XMLStreamReader.getLocalName()


getLocalPart

getLocalPart o7planning.org
  • QName.getLocalPart()


getLocalPatternChars

getLocalPatternChars o7planning.org
  • DateFormatSymbols.getLocalPatternChars()


getLocalPort

getLocalPort o7planning.org
  • DatagramSocket.getLocalPort()
  • DatagramSocketImpl.getLocalPort()
  • ServerSocket.getLocalPort()
  • Socket.getLocalPort()
  • SocketImpl.getLocalPort()


getLocalPrincipal

getLocalPrincipal o7planning.org
  • HandshakeCompletedEvent.getLocalPrincipal()
  • HttpsURLConnection.getLocalPrincipal()
  • SSLSession.getLocalPrincipal()
  • SecureCacheResponse.getLocalPrincipal()


getLocalSocketAddress

getLocalSocketAddress o7planning.org
  • DatagramSocket.getLocalSocketAddress()
  • ServerSocket.getLocalSocketAddress()
  • Socket.getLocalSocketAddress()


getLocalSupportedSignatureAlgorithms

getLocalSupportedSignatureAlgorithms o7planning.org
  • ExtendedSSLSession.getLocalSupportedSignatureAlgorithms()


getLocalTime

getLocalTime o7planning.org
  • ZoneOffsetTransitionRule.getLocalTime()


getLocation

getLocation o7planning.org
  • AccessibleComponent.getLocation()
  • ActivationDesc.getLocation()
  • ActivationGroupDesc.getLocation()
  • CodeSource.getLocation()
  • Component.getLocation(Point)
  • Component.getLocation()
  • Component.AccessibleAWTComponent.getLocation()
  • DOMError.getLocation()
  • DragSourceEvent.getLocation()
  • DropTargetDragEvent.getLocation()
  • DropTargetDropEvent.getLocation()
  • HttpRetryException.getLocation()
  • JComponent.getLocation(Point)
  • JList.AccessibleJList.AccessibleJListChild.getLocation()
  • JTable.AccessibleJTable.AccessibleJTableCell.getLocation()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocation()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getLocation()
  • List.AccessibleAWTList.AccessibleAWTListChild.getLocation()
  • MenuComponent.AccessibleAWTMenuComponent.getLocation()
  • Point.getLocation()
  • PointerInfo.getLocation()
  • Rectangle.getLocation()
  • StandardJavaFileManager.getLocation(JavaFileManager.Location)
  • StreamReaderDelegate.getLocation()
  • XMLEvent.getLocation()
  • XMLStreamException.getLocation()
  • XMLStreamReader.getLocation()


getLocationAsString

getLocationAsString o7planning.org
  • TransformerException.getLocationAsString()


getLocationInJTree

getLocationInJTree o7planning.org
  • JTree.AccessibleJTree.AccessibleJTreeNode.getLocationInJTree()


getLocationOffset

getLocationOffset o7planning.org
  • InputMethodRequests.getLocationOffset(int, int)


getLocationOnScreen

getLocationOnScreen o7planning.org
  • AccessibleComponent.getLocationOnScreen()
  • Component.getLocationOnScreen()
  • Component.AccessibleAWTComponent.getLocationOnScreen()
  • JList.AccessibleJList.AccessibleJListChild.getLocationOnScreen()
  • JTable.AccessibleJTable.AccessibleJTableCell.getLocationOnScreen()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocationOnScreen()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getLocationOnScreen()
  • List.AccessibleAWTList.AccessibleAWTListChild.getLocationOnScreen()
  • MenuComponent.AccessibleAWTMenuComponent.getLocationOnScreen()
  • MouseEvent.getLocationOnScreen()


getLocator

getLocator o7planning.org
  • TransformerException.getLocator()
  • ValidationEvent.getLocator()
  • ValidationEventImpl.getLocator()


getLockedMonitors

getLockedMonitors o7planning.org
  • ThreadInfo.getLockedMonitors()


getLockedStackDepth

getLockedStackDepth o7planning.org
  • MonitorInfo.getLockedStackDepth()


getLockedStackFrame

getLockedStackFrame o7planning.org
  • MonitorInfo.getLockedStackFrame()


getLockedSynchronizers

getLockedSynchronizers o7planning.org
  • ThreadInfo.getLockedSynchronizers()


getLockInfo

getLockInfo o7planning.org
  • ThreadInfo.getLockInfo()


getLockingKeyState

getLockingKeyState o7planning.org
  • Toolkit.getLockingKeyState(int)


getLockName

getLockName o7planning.org
  • ThreadInfo.getLockName()


getLockOwnerId

getLockOwnerId o7planning.org
  • ThreadInfo.getLockOwnerId()


getLockOwnerName

getLockOwnerName o7planning.org
  • ThreadInfo.getLockOwnerName()


getLog

getLog o7planning.org
  • RemoteServer.getLog()


getLogger

getLogger o7planning.org
  • LogManager.getLogger(String)
  • Logger.getLogger(String, String)
  • Logger.getLogger(String)
  • SyncFactory.getLogger()


getLoggerLevel

getLoggerLevel o7planning.org
  • LoggingMXBean.getLoggerLevel(String)
  • PlatformLoggingMXBean.getLoggerLevel(String)


getLoggerName

getLoggerName o7planning.org
  • LogRecord.getLoggerName()


getLoggerNames

getLoggerNames o7planning.org
  • LogManager.getLoggerNames()
  • LoggingMXBean.getLoggerNames()
  • PlatformLoggingMXBean.getLoggerNames()


getLoggingMXBean

getLoggingMXBean o7planning.org
  • LogManager.getLoggingMXBean()


getLogicalBounds

getLogicalBounds o7planning.org
  • GlyphVector.getLogicalBounds()


getLogicalHighlightShape

getLogicalHighlightShape o7planning.org
  • TextLayout.getLogicalHighlightShape(int, int)
  • TextLayout.getLogicalHighlightShape(int, int, Rectangle2D)


getLogicalRangesForVisualSelection

getLogicalRangesForVisualSelection o7planning.org
  • TextLayout.getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo)


getLogicalStyle

getLogicalStyle o7planning.org
  • DefaultStyledDocument.getLogicalStyle(int)
  • JTextPane.getLogicalStyle()
  • StyledDocument.getLogicalStyle(int)


getLogicalView

getLogicalView o7planning.org
  • FlowView.FlowStrategy.getLogicalView(FlowView)


getLoginModuleName

getLoginModuleName o7planning.org
  • AppConfigurationEntry.getLoginModuleName()


getLoginTimeout

getLoginTimeout o7planning.org
  • CommonDataSource.getLoginTimeout()
  • DriverManager.getLoginTimeout()


getLogManager

getLogManager o7planning.org
  • LogManager.getLogManager()


getLogStream

getLogStream o7planning.org
  • DriverManager.getLogStream()


getLogTimers

getLogTimers o7planning.org
  • Timer.getLogTimers()


getLogWriter

getLogWriter o7planning.org
  • CommonDataSource.getLogWriter()
  • DriverManager.getLogWriter()


getLong

getLong o7planning.org
  • AbstractPreferences.getLong(String, long)
  • Array.getLong(Object, int)
  • ByteBuffer.getLong(int)
  • ByteBuffer.getLong()
  • CallableStatement.getLong(String)
  • CallableStatement.getLong(int)
  • ChronoZonedDateTime.getLong(TemporalField)
  • DayOfWeek.getLong(TemporalField)
  • Era.getLong(TemporalField)
  • Field.getLong(Object)
  • HijrahDate.getLong(TemporalField)
  • Instant.getLong(TemporalField)
  • JapaneseDate.getLong(TemporalField)
  • LocalDate.getLong(TemporalField)
  • LocalDateTime.getLong(TemporalField)
  • LocalTime.getLong(TemporalField)
  • Long.getLong(String, Long)
  • Long.getLong(String, long)
  • Long.getLong(String)
  • MinguoDate.getLong(TemporalField)
  • Month.getLong(TemporalField)
  • MonthDay.getLong(TemporalField)
  • OffsetDateTime.getLong(TemporalField)
  • OffsetTime.getLong(TemporalField)
  • Preferences.getLong(String, long)
  • ResultSet.getLong(String)
  • ResultSet.getLong(int)
  • TemporalAccessor.getLong(TemporalField)
  • ThaiBuddhistDate.getLong(TemporalField)
  • Year.getLong(TemporalField)
  • YearMonth.getLong(TemporalField)
  • ZoneOffset.getLong(TemporalField)
  • ZonedDateTime.getLong(TemporalField)


getLongFramePosition

getLongFramePosition o7planning.org
  • DataLine.getLongFramePosition()


getLongParameter

getLongParameter o7planning.org
  • ParameterBlock.getLongParameter(int)


getLookAndFeel

getLookAndFeel o7planning.org
  • UIManager.getLookAndFeel()


getLookAndFeelDefaults

getLookAndFeelDefaults o7planning.org
  • UIManager.getLookAndFeelDefaults()


getLoopbackAddress

getLoopbackAddress o7planning.org
  • InetAddress.getLoopbackAddress()


getLoopbackMode

getLoopbackMode o7planning.org
  • MulticastSocket.getLoopbackMode()


getLoopCount

getLoopCount o7planning.org
  • Sequencer.getLoopCount()


getLoopEndPoint

getLoopEndPoint o7planning.org
  • Sequencer.getLoopEndPoint()


getLoopStartPoint

getLoopStartPoint o7planning.org
  • Sequencer.getLoopStartPoint()


getLowerBound

getLowerBound o7planning.org
  • TypeVariable.getLowerBound()


getLowerBounds

getLowerBounds o7planning.org
  • WildcardType.getLowerBounds()


getLoweredBevelBorderUIResource

getLoweredBevelBorderUIResource o7planning.org
  • BorderUIResource.getLoweredBevelBorderUIResource()


getLowestSetBit

getLowestSetBit o7planning.org
  • BigInteger.getLowestSetBit()


getLowestValue

getLowestValue o7planning.org
  • BasicSliderUI.getLowestValue()


getLowestValueLabel

getLowestValueLabel o7planning.org
  • BasicSliderUI.getLowestValueLabel()


getLowThreshold

getLowThreshold o7planning.org
  • GaugeMonitor.getLowThreshold()
  • GaugeMonitorMBean.getLowThreshold()


getLSB

getLSB o7planning.org
  • GlyphMetrics.getLSB()


getM

getM o7planning.org
  • ECFieldF2m.getM()


getMacLength

getMacLength o7planning.org
  • Mac.getMacLength()


getMagicCaretPosition

getMagicCaretPosition o7planning.org
  • Caret.getMagicCaretPosition()
  • DefaultCaret.getMagicCaretPosition()


getMainAttributes

getMainAttributes o7planning.org
  • JarURLConnection.getMainAttributes()
  • Manifest.getMainAttributes()


getMajor

getMajor o7planning.org
  • GSSException.getMajor()


getMajorAxis

getMajorAxis o7planning.org
  • AsyncBoxView.getMajorAxis()


getMajorOffset

getMajorOffset o7planning.org
  • AsyncBoxView.ChildState.getMajorOffset()


getMajorSpan

getMajorSpan o7planning.org
  • AsyncBoxView.ChildState.getMajorSpan()


getMajorString

getMajorString o7planning.org
  • GSSException.getMajorString()


getMajorTickSpacing

getMajorTickSpacing o7planning.org
  • JSlider.getMajorTickSpacing()


getMajorVersion

getMajorVersion o7planning.org
  • Driver.getMajorVersion()
  • ICC_Profile.getMajorVersion()


getManagementSpecVersion

getManagementSpecVersion o7planning.org
  • RuntimeMXBean.getManagementSpecVersion()


getManifest

getManifest o7planning.org
  • JarFile.getManifest()
  • JarInputStream.getManifest()
  • JarURLConnection.getManifest()


getMappedValue

getMappedValue o7planning.org
  • ConcurrentHashMap.KeySetView.getMappedValue()


getMapSize

getMapSize o7planning.org
  • IndexColorModel.getMapSize()


getMargin

getMargin o7planning.org
  • AbstractButton.getMargin()
  • JMenuBar.getMargin()
  • JPopupMenu.getMargin()
  • JTextComponent.getMargin()
  • JToolBar.getMargin()


getMark

getMark o7planning.org
  • Caret.getMark()
  • CaretEvent.getMark()
  • DefaultCaret.getMark()


getMarkBias

getMarkBias o7planning.org
  • DefaultCaret.getMarkBias()


getMask

getMask o7planning.org
  • MaskFormatter.getMask()
  • PackedColorModel.getMask(int)


getMaskForButton

getMaskForButton o7planning.org
  • InputEvent.getMaskForButton(int)


getMasks

getMasks o7planning.org
  • PackedColorModel.getMasks()


getMasterSyncMode

getMasterSyncMode o7planning.org
  • Sequencer.getMasterSyncMode()


getMasterSyncModes

getMasterSyncModes o7planning.org
  • Sequencer.getMasterSyncModes()


getMatchAllSubjectAltNames

getMatchAllSubjectAltNames o7planning.org
  • X509CertSelector.getMatchAllSubjectAltNames()


getMatchColumnIndexes

getMatchColumnIndexes o7planning.org
  • Joinable.getMatchColumnIndexes()


getMatchColumnNames

getMatchColumnNames o7planning.org
  • Joinable.getMatchColumnNames()


getMatchingHeaders

getMatchingHeaders o7planning.org
  • MimeHeaders.getMatchingHeaders(String[])


getMatchingMimeHeaders

getMatchingMimeHeaders o7planning.org
  • AttachmentPart.getMatchingMimeHeaders(String[])
  • SOAPPart.getMatchingMimeHeaders(String[])


getMatchingRuleID

getMatchingRuleID o7planning.org
  • SortKey.getMatchingRuleID()


getMatrix

getMatrix o7planning.org
  • AffineTransform.getMatrix(double[])
  • BandCombineOp.getMatrix()
  • ICC_ProfileRGB.getMatrix()
  • PageFormat.getMatrix()


getMatteColor

getMatteColor o7planning.org
  • MatteBorder.getMatteColor()


getMax

getMax o7planning.org
  • DoubleSummaryStatistics.getMax()
  • IntSummaryStatistics.getMax()
  • LongSummaryStatistics.getMax()
  • MemoryUsage.getMax()


getMaxAdvance

getMaxAdvance o7planning.org
  • FontMetrics.getMaxAdvance()


getMaxAge

getMaxAge o7planning.org
  • HttpCookie.getMaxAge()


getMaxAllowedKeyLength

getMaxAllowedKeyLength o7planning.org
  • Cipher.getMaxAllowedKeyLength(String)


getMaxAllowedParameterSpec

getMaxAllowedParameterSpec o7planning.org
  • Cipher.getMaxAllowedParameterSpec(String)


getMaxAscent

getMaxAscent o7planning.org
  • FontMetrics.getMaxAscent()


getMaxBinaryLiteralLength

getMaxBinaryLiteralLength o7planning.org
  • DatabaseMetaData.getMaxBinaryLiteralLength()


getMaxBufferSize

getMaxBufferSize o7planning.org
  • DataLine.Info.getMaxBufferSize()


getMaxCatalogNameLength

getMaxCatalogNameLength o7planning.org
  • DatabaseMetaData.getMaxCatalogNameLength()


getMaxCharactersPerLineCount

getMaxCharactersPerLineCount o7planning.org
  • BasicOptionPaneUI.getMaxCharactersPerLineCount()
  • JOptionPane.getMaxCharactersPerLineCount()


getMaxCharBounds

getMaxCharBounds o7planning.org
  • Font.getMaxCharBounds(FontRenderContext)
  • FontMetrics.getMaxCharBounds(Graphics)


getMaxCharLiteralLength

getMaxCharLiteralLength o7planning.org
  • DatabaseMetaData.getMaxCharLiteralLength()


getMaxColumnNameLength

getMaxColumnNameLength o7planning.org
  • DatabaseMetaData.getMaxColumnNameLength()


getMaxColumnsInGroupBy

getMaxColumnsInGroupBy o7planning.org
  • DatabaseMetaData.getMaxColumnsInGroupBy()


getMaxColumnsInIndex

getMaxColumnsInIndex o7planning.org
  • DatabaseMetaData.getMaxColumnsInIndex()


getMaxColumnsInOrderBy

getMaxColumnsInOrderBy o7planning.org
  • DatabaseMetaData.getMaxColumnsInOrderBy()


getMaxColumnsInSelect

getMaxColumnsInSelect o7planning.org
  • DatabaseMetaData.getMaxColumnsInSelect()


getMaxColumnsInTable

getMaxColumnsInTable o7planning.org
  • DatabaseMetaData.getMaxColumnsInTable()


getMaxConnections

getMaxConnections o7planning.org
  • DatabaseMetaData.getMaxConnections()


getMaxCRL

getMaxCRL o7planning.org
  • X509CRLSelector.getMaxCRL()


getMaxCursorNameLength

getMaxCursorNameLength o7planning.org
  • DatabaseMetaData.getMaxCursorNameLength()


getMaxDecent

getMaxDecent o7planning.org
  • FontMetrics.getMaxDecent()


getMaxDegree

getMaxDegree o7planning.org
  • RoleInfo.getMaxDegree()


getMaxDescent

getMaxDescent o7planning.org
  • FontMetrics.getMaxDescent()


getMaxExpansion

getMaxExpansion o7planning.org
  • CollationElementIterator.getMaxExpansion(int)


getMaxFieldSize

getMaxFieldSize o7planning.org
  • BaseRowSet.getMaxFieldSize()
  • RowSet.getMaxFieldSize()
  • Statement.getMaxFieldSize()


getMaximizedBounds

getMaximizedBounds o7planning.org
  • Frame.getMaximizedBounds()


getMaximum

getMaximum o7planning.org
  • Adjustable.getMaximum()
  • BoundedRangeModel.getMaximum()
  • Calendar.getMaximum(int)
  • DefaultBoundedRangeModel.getMaximum()
  • FloatControl.getMaximum()
  • GregorianCalendar.getMaximum(int)
  • InternationalFormatter.getMaximum()
  • JProgressBar.getMaximum()
  • JScrollBar.getMaximum()
  • JSlider.getMaximum()
  • ProgressMonitor.getMaximum()
  • ScrollPaneAdjustable.getMaximum()
  • Scrollbar.getMaximum()
  • SpinnerNumberModel.getMaximum()
  • ValueRange.getMaximum()


getMaximumAccessibleValue

getMaximumAccessibleValue o7planning.org
  • AbstractButton.AccessibleAbstractButton.getMaximumAccessibleValue()
  • AccessibleValue.getMaximumAccessibleValue()
  • Button.AccessibleAWTButton.getMaximumAccessibleValue()
  • Checkbox.AccessibleAWTCheckbox.getMaximumAccessibleValue()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMaximumAccessibleValue()
  • JInternalFrame.AccessibleJInternalFrame.getMaximumAccessibleValue()
  • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMaximumAccessibleValue()
  • JProgressBar.AccessibleJProgressBar.getMaximumAccessibleValue()
  • JScrollBar.AccessibleJScrollBar.getMaximumAccessibleValue()
  • JSlider.AccessibleJSlider.getMaximumAccessibleValue()
  • JSpinner.AccessibleJSpinner.getMaximumAccessibleValue()
  • JSplitPane.AccessibleJSplitPane.getMaximumAccessibleValue()
  • MenuItem.AccessibleAWTMenuItem.getMaximumAccessibleValue()
  • Scrollbar.AccessibleAWTScrollBar.getMaximumAccessibleValue()


getMaximumCharHeight

getMaximumCharHeight o7planning.org
  • SynthGraphicsUtils.getMaximumCharHeight(SynthContext)


getMaximumCursorColors

getMaximumCursorColors o7planning.org
  • Toolkit.getMaximumCursorColors()


getMaximumDividerLocation

getMaximumDividerLocation o7planning.org
  • BasicSplitPaneUI.getMaximumDividerLocation(JSplitPane)
  • JSplitPane.getMaximumDividerLocation()
  • MultiSplitPaneUI.getMaximumDividerLocation(JSplitPane)
  • SplitPaneUI.getMaximumDividerLocation(JSplitPane)


getMaximumFractionDigits

getMaximumFractionDigits o7planning.org
  • DecimalFormat.getMaximumFractionDigits()
  • NumberFormat.getMaximumFractionDigits()


getMaximumIntegerDigits

getMaximumIntegerDigits o7planning.org
  • DecimalFormat.getMaximumIntegerDigits()
  • NumberFormat.getMaximumIntegerDigits()


getMaximumPoolSize

getMaximumPoolSize o7planning.org
  • ThreadPoolExecutor.getMaximumPoolSize()


getMaximumRowCount

getMaximumRowCount o7planning.org
  • JComboBox.getMaximumRowCount()


getMaximumSize

getMaximumSize o7planning.org
  • BasicArrowButton.getMaximumSize()
  • BasicButtonUI.getMaximumSize(JComponent)
  • BasicComboBoxUI.getMaximumSize(JComponent)
  • BasicDesktopIconUI.getMaximumSize(JComponent)
  • BasicDesktopPaneUI.getMaximumSize(JComponent)
  • BasicInternalFrameUI.getMaximumSize(JComponent)
  • BasicLabelUI.getMaximumSize(JComponent)
  • BasicMenuBarUI.getMaximumSize(JComponent)
  • BasicMenuItemUI.getMaximumSize(JComponent)
  • BasicMenuUI.getMaximumSize(JComponent)
  • BasicProgressBarUI.getMaximumSize(JComponent)
  • BasicScrollBarUI.getMaximumSize(JComponent)
  • BasicScrollPaneUI.getMaximumSize(JComponent)
  • BasicSeparatorUI.getMaximumSize(JComponent)
  • BasicSliderUI.getMaximumSize(JComponent)
  • BasicSplitPaneUI.getMaximumSize(JComponent)
  • BasicTabbedPaneUI.getMaximumSize(JComponent)
  • BasicTableHeaderUI.getMaximumSize(JComponent)
  • BasicTableUI.getMaximumSize(JComponent)
  • BasicTextUI.getMaximumSize(JComponent)
  • BasicToolTipUI.getMaximumSize(JComponent)
  • BasicTreeUI.getMaximumSize(JComponent)
  • Component.getMaximumSize()
  • ComponentUI.getMaximumSize(JComponent)
  • Container.getMaximumSize()
  • JComponent.getMaximumSize()
  • JScrollBar.getMaximumSize()
  • JToolBar.Separator.getMaximumSize()
  • LayerUI.getMaximumSize(JComponent)
  • MetalDesktopIconUI.getMaximumSize(JComponent)
  • MetalFileChooserUI.getMaximumSize(JComponent)
  • MetalScrollButton.getMaximumSize()
  • MultiButtonUI.getMaximumSize(JComponent)
  • MultiColorChooserUI.getMaximumSize(JComponent)
  • MultiComboBoxUI.getMaximumSize(JComponent)
  • MultiDesktopIconUI.getMaximumSize(JComponent)
  • MultiDesktopPaneUI.getMaximumSize(JComponent)
  • MultiFileChooserUI.getMaximumSize(JComponent)
  • MultiInternalFrameUI.getMaximumSize(JComponent)
  • MultiLabelUI.getMaximumSize(JComponent)
  • MultiListUI.getMaximumSize(JComponent)
  • MultiMenuBarUI.getMaximumSize(JComponent)
  • MultiMenuItemUI.getMaximumSize(JComponent)
  • MultiOptionPaneUI.getMaximumSize(JComponent)
  • MultiPanelUI.getMaximumSize(JComponent)
  • MultiPopupMenuUI.getMaximumSize(JComponent)
  • MultiProgressBarUI.getMaximumSize(JComponent)
  • MultiRootPaneUI.getMaximumSize(JComponent)
  • MultiScrollBarUI.getMaximumSize(JComponent)
  • MultiScrollPaneUI.getMaximumSize(JComponent)
  • MultiSeparatorUI.getMaximumSize(JComponent)
  • MultiSliderUI.getMaximumSize(JComponent)
  • MultiSpinnerUI.getMaximumSize(JComponent)
  • MultiSplitPaneUI.getMaximumSize(JComponent)
  • MultiTabbedPaneUI.getMaximumSize(JComponent)
  • MultiTableHeaderUI.getMaximumSize(JComponent)
  • MultiTableUI.getMaximumSize(JComponent)
  • MultiTextUI.getMaximumSize(JComponent)
  • MultiToolBarUI.getMaximumSize(JComponent)
  • MultiToolTipUI.getMaximumSize(JComponent)
  • MultiTreeUI.getMaximumSize(JComponent)
  • MultiViewportUI.getMaximumSize(JComponent)
  • SynthButtonUI.getMaximumSize(JComponent)
  • SynthGraphicsUtils.getMaximumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int)
  • SynthLabelUI.getMaximumSize(JComponent)
  • SynthSeparatorUI.getMaximumSize(JComponent)


getMaximumSpan

getMaximumSpan o7planning.org
  • AsyncBoxView.getMaximumSpan(int)
  • BlockView.getMaximumSpan(int)
  • BoxView.getMaximumSpan(int)
  • ComponentView.getMaximumSpan(int)
  • FormView.getMaximumSpan(int)
  • ParagraphView.getMaximumSpan(int)
  • View.getMaximumSpan(int)
  • WrappedPlainView.getMaximumSpan(int)


getMaximumStreamFormatVersion

getMaximumStreamFormatVersion o7planning.org
  • ValueHandlerMultiFormat.getMaximumStreamFormatVersion()


getMaximumThumbSize

getMaximumThumbSize o7planning.org
  • BasicScrollBarUI.getMaximumThumbSize()


getMaximumValue

getMaximumValue o7planning.org
  • Spring.getMaximumValue()


getMaximumWindowBounds

getMaximumWindowBounds o7planning.org
  • GraphicsEnvironment.getMaximumWindowBounds()


getMaximumZoneSize

getMaximumZoneSize o7planning.org
  • ZoneView.getMaximumZoneSize()


getMaxIndexLength

getMaxIndexLength o7planning.org
  • DatabaseMetaData.getMaxIndexLength()


getMaxLabel

getMaxLabel o7planning.org
  • FloatControl.getMaxLabel()


getMaxLines

getMaxLines o7planning.org
  • Mixer.getMaxLines(Line.Info)


getMaxLogicalLobSize

getMaxLogicalLobSize o7planning.org
  • DatabaseMetaData.getMaxLogicalLobSize()


getMaxPage

getMaxPage o7planning.org
  • JobAttributes.getMaxPage()


getMaxPathLength

getMaxPathLength o7planning.org
  • PKIXBuilderParameters.getMaxPathLength()


getMaxPolyphony

getMaxPolyphony o7planning.org
  • Synthesizer.getMaxPolyphony()


getMaxPriority

getMaxPriority o7planning.org
  • ThreadGroup.getMaxPriority()


getMaxProcedureNameLength

getMaxProcedureNameLength o7planning.org
  • DatabaseMetaData.getMaxProcedureNameLength()


getMaxReceivers

getMaxReceivers o7planning.org
  • MidiDevice.getMaxReceivers()


getMaxRows

getMaxRows o7planning.org
  • BaseRowSet.getMaxRows()
  • RowSet.getMaxRows()
  • Statement.getMaxRows()


getMaxRowSize

getMaxRowSize o7planning.org
  • DatabaseMetaData.getMaxRowSize()


getMaxSchemaNameLength

getMaxSchemaNameLength o7planning.org
  • DatabaseMetaData.getMaxSchemaNameLength()


getMaxSelectionIndex

getMaxSelectionIndex o7planning.org
  • DefaultListSelectionModel.getMaxSelectionIndex()
  • JList.getMaxSelectionIndex()
  • ListSelectionModel.getMaxSelectionIndex()


getMaxSelectionRow

getMaxSelectionRow o7planning.org
  • DefaultTreeSelectionModel.getMaxSelectionRow()
  • JTree.getMaxSelectionRow()
  • TreeSelectionModel.getMaxSelectionRow()


getMaxSortKeys

getMaxSortKeys o7planning.org
  • DefaultRowSorter.getMaxSortKeys()


getMaxStatementLength

getMaxStatementLength o7planning.org
  • DatabaseMetaData.getMaxStatementLength()


getMaxStatements

getMaxStatements o7planning.org
  • DatabaseMetaData.getMaxStatements()


getMaxTableNameLength

getMaxTableNameLength o7planning.org
  • DatabaseMetaData.getMaxTableNameLength()


getMaxTablesInSelect

getMaxTablesInSelect o7planning.org
  • DatabaseMetaData.getMaxTablesInSelect()


getMaxTransmitters

getMaxTransmitters o7planning.org
  • MidiDevice.getMaxTransmitters()


getMaxUserNameLength

getMaxUserNameLength o7planning.org
  • DatabaseMetaData.getMaxUserNameLength()


getMaxValue

getMaxValue o7planning.org
  • ColorSpace.getMaxValue(int)
  • ICC_ColorSpace.getMaxValue(int)
  • OpenMBeanAttributeInfoSupport.getMaxValue()
  • OpenMBeanParameterInfo.getMaxValue()
  • OpenMBeanParameterInfoSupport.getMaxValue()


getMaxWidth

getMaxWidth o7planning.org
  • TableColumn.getMaxWidth()


getMaxX

getMaxX o7planning.org
  • RectangularShape.getMaxX()


getMaxY

getMaxY o7planning.org
  • RectangularShape.getMaxY()


getMaxZonesLoaded

getMaxZonesLoaded o7planning.org
  • ZoneView.getMaxZonesLoaded()


getMBeanCount

getMBeanCount o7planning.org
  • MBeanServer.getMBeanCount()
  • MBeanServerConnection.getMBeanCount()
  • RMIConnection.getMBeanCount(Subject)
  • RMIConnectionImpl.getMBeanCount(Subject)
  • RMIConnectionImpl_Stub.getMBeanCount(Subject)


getMBeanDescriptor

getMBeanDescriptor o7planning.org
  • ModelMBeanInfo.getMBeanDescriptor()
  • ModelMBeanInfoSupport.getMBeanDescriptor()


getMBeanInfo

getMBeanInfo o7planning.org
  • DynamicMBean.getMBeanInfo()
  • MBeanServer.getMBeanInfo(ObjectName)
  • MBeanServerConnection.getMBeanInfo(ObjectName)
  • RMIConnection.getMBeanInfo(ObjectName, Subject)
  • RMIConnectionImpl.getMBeanInfo(ObjectName, Subject)
  • RMIConnectionImpl_Stub.getMBeanInfo(ObjectName, Subject)
  • RequiredModelMBean.getMBeanInfo()
  • StandardMBean.getMBeanInfo()


getMBeanInterface

getMBeanInterface o7planning.org
  • StandardMBean.getMBeanInterface()


getMBeanName

getMBeanName o7planning.org
  • MBeanServerNotification.getMBeanName()


getMBeanServer

getMBeanServer o7planning.org
  • JMXConnectorServer.getMBeanServer()
  • MBeanServerForwarder.getMBeanServer()
  • QueryEval.getMBeanServer()
  • RMIServerImpl.getMBeanServer()


getMBeanServerConnection

getMBeanServerConnection o7planning.org
  • JMXConnector.getMBeanServerConnection(Subject)
  • JMXConnector.getMBeanServerConnection()
  • MBeanServerInvocationHandler.getMBeanServerConnection()
  • RMIConnector.getMBeanServerConnection(Subject)
  • RMIConnector.getMBeanServerConnection()


getMBeanServerId

getMBeanServerId o7planning.org
  • MBeanServerDelegate.getMBeanServerId()
  • MBeanServerDelegateMBean.getMBeanServerId()


getMBeansFromURL

getMBeansFromURL o7planning.org
  • MLet.getMBeansFromURL(String)
  • MLet.getMBeansFromURL(URL)
  • MLetMBean.getMBeansFromURL(URL)
  • MLetMBean.getMBeansFromURL(String)


getMBeansToUnregister

getMBeansToUnregister o7planning.org
  • RelationNotification.getMBeansToUnregister()


getMech

getMech o7planning.org
  • GSSContext.getMech()


getMechanismName

getMechanismName o7planning.org
  • SaslClient.getMechanismName()
  • SaslServer.getMechanismName()


getMechanismNames

getMechanismNames o7planning.org
  • SaslClientFactory.getMechanismNames(Map<String, ?>)
  • SaslServerFactory.getMechanismNames(Map<String, ?>)


getMechanismType

getMechanismType o7planning.org
  • KeyInfoFactory.getMechanismType()
  • TransformService.getMechanismType()
  • XMLSignatureFactory.getMechanismType()


getMechs

getMechs o7planning.org
  • GSSCredential.getMechs()
  • GSSManager.getMechs()


getMechsForName

getMechsForName o7planning.org
  • GSSManager.getMechsForName(Oid)


getMedia

getMedia o7planning.org
  • PageAttributes.getMedia()


getMediaSizeForName

getMediaSizeForName o7planning.org
  • MediaSize.getMediaSizeForName(MediaSizeName)


getMediaSizeName

getMediaSizeName o7planning.org
  • MediaSize.getMediaSizeName()


getMediaSubtype

getMediaSubtype o7planning.org
  • DocFlavor.getMediaSubtype()


getMediaType

getMediaType o7planning.org
  • DocFlavor.getMediaType()


getMediaWhitePoint

getMediaWhitePoint o7planning.org
  • ICC_ProfileGray.getMediaWhitePoint()
  • ICC_ProfileRGB.getMediaWhitePoint()


getMemberControls

getMemberControls o7planning.org
  • CompoundControl.getMemberControls()


getMembers

getMembers o7planning.org
  • SetOfIntegerSyntax.getMembers()


getMemoryManagerMXBeans

getMemoryManagerMXBeans o7planning.org
  • ManagementFactory.getMemoryManagerMXBeans()


getMemoryManagerNames

getMemoryManagerNames o7planning.org
  • MemoryPoolMXBean.getMemoryManagerNames()


getMemoryMXBean

getMemoryMXBean o7planning.org
  • ManagementFactory.getMemoryMXBean()


getMemoryPoolMXBeans

getMemoryPoolMXBeans o7planning.org
  • ManagementFactory.getMemoryPoolMXBeans()


getMemoryPoolNames

getMemoryPoolNames o7planning.org
  • MemoryManagerMXBean.getMemoryPoolNames()


getMemoryUsed

getMemoryUsed o7planning.org
  • BufferPoolMXBean.getMemoryUsed()


getMenu

getMenu o7planning.org
  • JMenuBar.getMenu(int)
  • MenuBar.getMenu(int)


getMenuArrowIcon

getMenuArrowIcon o7planning.org
  • BasicIconFactory.getMenuArrowIcon()
  • MetalIconFactory.getMenuArrowIcon()


getMenuBackground

getMenuBackground o7planning.org
  • MetalLookAndFeel.getMenuBackground()
  • MetalTheme.getMenuBackground()


getMenuBar

getMenuBar o7planning.org
  • Frame.getMenuBar()
  • JInternalFrame.getMenuBar()
  • JRootPane.getMenuBar()


getMenuBarBorder

getMenuBarBorder o7planning.org
  • BasicBorders.getMenuBarBorder()


getMenuComponent

getMenuComponent o7planning.org
  • JMenu.getMenuComponent(int)


getMenuComponentCount

getMenuComponentCount o7planning.org
  • JMenu.getMenuComponentCount()


getMenuComponents

getMenuComponents o7planning.org
  • JMenu.getMenuComponents()


getMenuCount

getMenuCount o7planning.org
  • JMenuBar.getMenuCount()
  • MenuBar.getMenuCount()


getMenuDisabledForeground

getMenuDisabledForeground o7planning.org
  • MetalLookAndFeel.getMenuDisabledForeground()
  • MetalTheme.getMenuDisabledForeground()
  • OceanTheme.getMenuDisabledForeground()


getMenuDragMouseListeners

getMenuDragMouseListeners o7planning.org
  • JMenuItem.getMenuDragMouseListeners()


getMenuForeground

getMenuForeground o7planning.org
  • MetalLookAndFeel.getMenuForeground()
  • MetalTheme.getMenuForeground()


getMenuItemArrowIcon

getMenuItemArrowIcon o7planning.org
  • BasicIconFactory.getMenuItemArrowIcon()
  • MetalIconFactory.getMenuItemArrowIcon()


getMenuItemCheckIcon

getMenuItemCheckIcon o7planning.org
  • BasicIconFactory.getMenuItemCheckIcon()
  • MetalIconFactory.getMenuItemCheckIcon()


getMenuKeyListeners

getMenuKeyListeners o7planning.org
  • JMenuItem.getMenuKeyListeners()
  • JPopupMenu.getMenuKeyListeners()


getMenuListeners

getMenuListeners o7planning.org
  • JMenu.getMenuListeners()


getMenuSelectedBackground

getMenuSelectedBackground o7planning.org
  • MetalLookAndFeel.getMenuSelectedBackground()
  • MetalTheme.getMenuSelectedBackground()


getMenuSelectedForeground

getMenuSelectedForeground o7planning.org
  • MetalLookAndFeel.getMenuSelectedForeground()
  • MetalTheme.getMenuSelectedForeground()


getMenuSelectionManager

getMenuSelectionManager o7planning.org
  • MenuDragMouseEvent.getMenuSelectionManager()
  • MenuKeyEvent.getMenuSelectionManager()


getMenuShortcutKeyMask

getMenuShortcutKeyMask o7planning.org
  • Toolkit.getMenuShortcutKeyMask()


getMenuTextFont

getMenuTextFont o7planning.org
  • DefaultMetalTheme.getMenuTextFont()
  • MetalLookAndFeel.getMenuTextFont()
  • MetalTheme.getMenuTextFont()


getMessage

getMessage o7planning.org
  • ActivationException.getMessage()
  • BasicOptionPaneUI.getMessage()
  • CertificateRevokedException.getMessage()
  • Completion.getMessage()
  • DOMError.getMessage()
  • Diagnostic.getMessage(Locale)
  • DuplicateFormatFlagsException.getMessage()
  • FactoryConfigurationError.getMessage()
  • FactoryConfigurationError.getMessage()
  • FileSystemException.getMessage()
  • FormatFlagsConversionMismatchException.getMessage()
  • GSSException.getMessage()
  • HeadlessException.getMessage()
  • IllegalFormatCodePointException.getMessage()
  • IllegalFormatConversionException.getMessage()
  • IllegalFormatFlagsException.getMessage()
  • IllegalFormatPrecisionException.getMessage()
  • IllegalFormatWidthException.getMessage()
  • InvalidClassException.getMessage()
  • InvalidPathException.getMessage()
  • JOptionPane.getMessage()
  • LogRecord.getMessage()
  • LogicalMessageContext.getMessage()
  • MalformedInputException.getMessage()
  • MidiEvent.getMessage()
  • MidiMessage.getMessage()
  • MissingFormatArgumentException.getMessage()
  • MissingFormatWidthException.getMessage()
  • Notification.getMessage()
  • PatternSyntaxException.getMessage()
  • RemoteException.getMessage()
  • SAXException.getMessage()
  • SOAPException.getMessage()
  • SOAPMessageContext.getMessage()
  • ScriptException.getMessage()
  • ServerCloneException.getMessage()
  • TextOutputCallback.getMessage()
  • Throwable.getMessage()
  • TransformerFactoryConfigurationError.getMessage()
  • URISyntaxException.getMessage()
  • UnknownFormatConversionException.getMessage()
  • UnknownFormatFlagsException.getMessage()
  • UnmappableCharacterException.getMessage()
  • ValidationEvent.getMessage()
  • ValidationEventImpl.getMessage()
  • WriteAbortedException.getMessage()


getMessageAndLocation

getMessageAndLocation o7planning.org
  • TransformerException.getMessageAndLocation()


getMessageContext

getMessageContext o7planning.org
  • WebServiceContext.getMessageContext()


getMessageDigest

getMessageDigest o7planning.org
  • DigestInputStream.getMessageDigest()
  • DigestOutputStream.getMessageDigest()


getMessageFactory

getMessageFactory o7planning.org
  • SOAPBinding.getMessageFactory()


getMessager

getMessager o7planning.org
  • ProcessingEnvironment.getMessager()


getMessageType

getMessageType o7planning.org
  • ConfirmationCallback.getMessageType()
  • JOptionPane.getMessageType()
  • TextOutputCallback.getMessageType()


getMetaData

getMetaData o7planning.org
  • Connection.getMetaData()
  • PreparedStatement.getMetaData()
  • ResultSet.getMetaData()


getMetadata

getMetadata o7planning.org
  • Endpoint.getMetadata()
  • IIOImage.getMetadata()


getMetadataFormat

getMetadataFormat o7planning.org
  • IIOMetadata.getMetadataFormat(String)


getMetadataFormatNames

getMetadataFormatNames o7planning.org
  • IIOMetadata.getMetadataFormatNames()


getMetaKey

getMetaKey o7planning.org
  • MouseEvent.getMetaKey()


getMethod

getMethod o7planning.org
  • Class.getMethod(String, Class<?>...)
  • FormSubmitEvent.getMethod()
  • MethodDescriptor.getMethod()
  • ZipEntry.getMethod()


getMethodCallSyntax

getMethodCallSyntax o7planning.org
  • ScriptEngineFactory.getMethodCallSyntax(String, String, String...)


getMethodDescriptors

getMethodDescriptors o7planning.org
  • BeanInfo.getMethodDescriptors()
  • SimpleBeanInfo.getMethodDescriptors()


getMethodName

getMethodName o7planning.org
  • StackTraceElement.getMethodName()
  • Statement.getMethodName()


getMethods

getMethods o7planning.org
  • Class.getMethods()


getMethodType

getMethodType o7planning.org
  • MethodHandleInfo.getMethodType()


getMGFAlgorithm

getMGFAlgorithm o7planning.org
  • OAEPParameterSpec.getMGFAlgorithm()
  • PSSParameterSpec.getMGFAlgorithm()


getMGFParameters

getMGFParameters o7planning.org
  • OAEPParameterSpec.getMGFParameters()
  • PSSParameterSpec.getMGFParameters()


getMIC

getMIC o7planning.org
  • GSSContext.getMIC(InputStream, OutputStream, MessageProp)
  • GSSContext.getMIC(byte[], int, int, MessageProp)


getMicrosecondLength

getMicrosecondLength o7planning.org
  • Clip.getMicrosecondLength()
  • MidiFileFormat.getMicrosecondLength()
  • Sequence.getMicrosecondLength()
  • Sequencer.getMicrosecondLength()


getMicrosecondPosition

getMicrosecondPosition o7planning.org
  • DataLine.getMicrosecondPosition()
  • MidiDevice.getMicrosecondPosition()
  • Sequencer.getMicrosecondPosition()


getMidiDevice

getMidiDevice o7planning.org
  • MidiDeviceReceiver.getMidiDevice()
  • MidiDeviceTransmitter.getMidiDevice()
  • MidiSystem.getMidiDevice(MidiDevice.Info)


getMidiDeviceInfo

getMidiDeviceInfo o7planning.org
  • MidiSystem.getMidiDeviceInfo()


getMidiFileFormat

getMidiFileFormat o7planning.org
  • MidiFileReader.getMidiFileFormat(File)
  • MidiFileReader.getMidiFileFormat(URL)
  • MidiFileReader.getMidiFileFormat(InputStream)
  • MidiSystem.getMidiFileFormat(File)
  • MidiSystem.getMidiFileFormat(URL)
  • MidiSystem.getMidiFileFormat(InputStream)


getMidiFileTypes

getMidiFileTypes o7planning.org
  • MidiFileWriter.getMidiFileTypes(Sequence)
  • MidiFileWriter.getMidiFileTypes()
  • MidiSystem.getMidiFileTypes(Sequence)
  • MidiSystem.getMidiFileTypes()


getMidLabel

getMidLabel o7planning.org
  • FloatControl.getMidLabel()


getMidTermsOfReductionPolynomial

getMidTermsOfReductionPolynomial o7planning.org
  • ECFieldF2m.getMidTermsOfReductionPolynomial()


getMillis

getMillis o7planning.org
  • LogRecord.getMillis()


getMillisecond

getMillisecond o7planning.org
  • XMLGregorianCalendar.getMillisecond()


getMillisToDecideToPopup

getMillisToDecideToPopup o7planning.org
  • ProgressMonitor.getMillisToDecideToPopup()


getMillisToPopup

getMillisToPopup o7planning.org
  • ProgressMonitor.getMillisToPopup()


getMimeDecoder

getMimeDecoder o7planning.org
  • Base64.getMimeDecoder()


getMimeEncoder

getMimeEncoder o7planning.org
  • Base64.getMimeEncoder(int, byte[])
  • Base64.getMimeEncoder()


getMimeHeader

getMimeHeader o7planning.org
  • AttachmentPart.getMimeHeader(String)
  • SOAPPart.getMimeHeader(String)


getMimeHeaders

getMimeHeaders o7planning.org
  • SOAPMessage.getMimeHeaders()


getMimeType

getMimeType o7planning.org
  • ActivationDataFlavor.getMimeType()
  • DataFlavor.getMimeType()
  • DocFlavor.getMimeType()
  • OctetStreamData.getMimeType()
  • XMLObject.getMimeType()


getMimeTypes

getMimeTypes o7planning.org
  • ScriptEngineFactory.getMimeTypes()


getMIMETypes

getMIMETypes o7planning.org
  • ImageReaderWriterSpi.getMIMETypes()


getMin

getMin o7planning.org
  • DoubleSummaryStatistics.getMin()
  • IntSummaryStatistics.getMin()
  • LongSummaryStatistics.getMin()


getMinBufferSize

getMinBufferSize o7planning.org
  • DataLine.Info.getMinBufferSize()


getMinCRL

getMinCRL o7planning.org
  • X509CRLSelector.getMinCRL()


getMinDegree

getMinDegree o7planning.org
  • RoleInfo.getMinDegree()


getMinimalDaysInFirstWeek

getMinimalDaysInFirstWeek o7planning.org
  • Calendar.getMinimalDaysInFirstWeek()
  • CalendarDataProvider.getMinimalDaysInFirstWeek(Locale)
  • WeekFields.getMinimalDaysInFirstWeek()


getMinimum

getMinimum o7planning.org
  • Adjustable.getMinimum()
  • BoundedRangeModel.getMinimum()
  • Calendar.getMinimum(int)
  • DefaultBoundedRangeModel.getMinimum()
  • FloatControl.getMinimum()
  • GregorianCalendar.getMinimum(int)
  • InternationalFormatter.getMinimum()
  • JProgressBar.getMinimum()
  • JScrollBar.getMinimum()
  • JSlider.getMinimum()
  • ProgressMonitor.getMinimum()
  • ScrollPaneAdjustable.getMinimum()
  • Scrollbar.getMinimum()
  • SpinnerNumberModel.getMinimum()
  • ValueRange.getMinimum()


getMinimumAccessibleValue

getMinimumAccessibleValue o7planning.org
  • AbstractButton.AccessibleAbstractButton.getMinimumAccessibleValue()
  • AccessibleValue.getMinimumAccessibleValue()
  • Button.AccessibleAWTButton.getMinimumAccessibleValue()
  • Checkbox.AccessibleAWTCheckbox.getMinimumAccessibleValue()
  • CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMinimumAccessibleValue()
  • JInternalFrame.AccessibleJInternalFrame.getMinimumAccessibleValue()
  • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMinimumAccessibleValue()
  • JProgressBar.AccessibleJProgressBar.getMinimumAccessibleValue()
  • JScrollBar.AccessibleJScrollBar.getMinimumAccessibleValue()
  • JSlider.AccessibleJSlider.getMinimumAccessibleValue()
  • JSpinner.AccessibleJSpinner.getMinimumAccessibleValue()
  • JSplitPane.AccessibleJSplitPane.getMinimumAccessibleValue()
  • MenuItem.AccessibleAWTMenuItem.getMinimumAccessibleValue()
  • Scrollbar.AccessibleAWTScrollBar.getMinimumAccessibleValue()


getMinimumDividerLocation

getMinimumDividerLocation o7planning.org
  • BasicSplitPaneUI.getMinimumDividerLocation(JSplitPane)
  • JSplitPane.getMinimumDividerLocation()
  • MultiSplitPaneUI.getMinimumDividerLocation(JSplitPane)
  • SplitPaneUI.getMinimumDividerLocation(JSplitPane)


getMinimumFractionDigits

getMinimumFractionDigits o7planning.org
  • DecimalFormat.getMinimumFractionDigits()
  • NumberFormat.getMinimumFractionDigits()


getMinimumHorizontalSize

getMinimumHorizontalSize o7planning.org
  • BasicSliderUI.getMinimumHorizontalSize()


getMinimumIntegerDigits

getMinimumIntegerDigits o7planning.org
  • DecimalFormat.getMinimumIntegerDigits()
  • NumberFormat.getMinimumIntegerDigits()


getMinimumOptionPaneSize

getMinimumOptionPaneSize o7planning.org
  • BasicOptionPaneUI.getMinimumOptionPaneSize()


getMinimumSize

getMinimumSize o7planning.org
  • BasicArrowButton.getMinimumSize()
  • BasicButtonUI.getMinimumSize(JComponent)
  • BasicComboBoxUI.getMinimumSize(JComponent)
  • BasicDesktopIconUI.getMinimumSize(JComponent)
  • BasicDesktopPaneUI.getMinimumSize(JComponent)
  • BasicInternalFrameUI.getMinimumSize(JComponent)
  • BasicLabelUI.getMinimumSize(JComponent)
  • BasicMenuBarUI.getMinimumSize(JComponent)
  • BasicMenuItemUI.getMinimumSize(JComponent)
  • BasicProgressBarUI.getMinimumSize(JComponent)
  • BasicSeparatorUI.getMinimumSize(JComponent)
  • BasicSliderUI.getMinimumSize(JComponent)
  • BasicSplitPaneDivider.getMinimumSize()
  • BasicSplitPaneUI.getMinimumSize(JComponent)
  • BasicTabbedPaneUI.getMinimumSize(JComponent)
  • BasicTableHeaderUI.getMinimumSize(JComponent)
  • BasicTableUI.getMinimumSize(JComponent)
  • BasicTextAreaUI.getMinimumSize(JComponent)
  • BasicTextUI.getMinimumSize(JComponent)
  • BasicToolTipUI.getMinimumSize(JComponent)
  • BasicTreeUI.getMinimumSize(JComponent)
  • Component.getMinimumSize()
  • ComponentUI.getMinimumSize(JComponent)
  • Container.getMinimumSize()
  • JComponent.getMinimumSize()
  • JScrollBar.getMinimumSize()
  • JToolBar.Separator.getMinimumSize()
  • LayerUI.getMinimumSize(JComponent)
  • List.getMinimumSize()
  • List.getMinimumSize(int)
  • MetalComboBoxButton.getMinimumSize()
  • MetalComboBoxUI.getMinimumSize(JComponent)
  • MetalDesktopIconUI.getMinimumSize(JComponent)
  • MetalFileChooserUI.getMinimumSize(JComponent)
  • MetalScrollButton.getMinimumSize()
  • MultiButtonUI.getMinimumSize(JComponent)
  • MultiColorChooserUI.getMinimumSize(JComponent)
  • MultiComboBoxUI.getMinimumSize(JComponent)
  • MultiDesktopIconUI.getMinimumSize(JComponent)
  • MultiDesktopPaneUI.getMinimumSize(JComponent)
  • MultiFileChooserUI.getMinimumSize(JComponent)
  • MultiInternalFrameUI.getMinimumSize(JComponent)
  • MultiLabelUI.getMinimumSize(JComponent)
  • MultiListUI.getMinimumSize(JComponent)
  • MultiMenuBarUI.getMinimumSize(JComponent)
  • MultiMenuItemUI.getMinimumSize(JComponent)
  • MultiOptionPaneUI.getMinimumSize(JComponent)
  • MultiPanelUI.getMinimumSize(JComponent)
  • MultiPopupMenuUI.getMinimumSize(JComponent)
  • MultiProgressBarUI.getMinimumSize(JComponent)
  • MultiRootPaneUI.getMinimumSize(JComponent)
  • MultiScrollBarUI.getMinimumSize(JComponent)
  • MultiScrollPaneUI.getMinimumSize(JComponent)
  • MultiSeparatorUI.getMinimumSize(JComponent)
  • MultiSliderUI.getMinimumSize(JComponent)
  • MultiSpinnerUI.getMinimumSize(JComponent)
  • MultiSplitPaneUI.getMinimumSize(JComponent)
  • MultiTabbedPaneUI.getMinimumSize(JComponent)
  • MultiTableHeaderUI.getMinimumSize(JComponent)
  • MultiTableUI.getMinimumSize(JComponent)
  • MultiTextUI.getMinimumSize(JComponent)
  • MultiToolBarUI.getMinimumSize(JComponent)
  • MultiToolTipUI.getMinimumSize(JComponent)
  • MultiTreeUI.getMinimumSize(JComponent)
  • MultiViewportUI.getMinimumSize(JComponent)
  • SynthButtonUI.getMinimumSize(JComponent)
  • SynthGraphicsUtils.getMinimumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int)
  • SynthLabelUI.getMinimumSize(JComponent)
  • SynthSeparatorUI.getMinimumSize(JComponent)
  • SynthSliderUI.getMinimumSize(JComponent)
  • TextArea.getMinimumSize()
  • TextArea.getMinimumSize(int, int)
  • TextField.getMinimumSize()
  • TextField.getMinimumSize(int)
  • TitledBorder.getMinimumSize(Component)


getMinimumSpan

getMinimumSpan o7planning.org
  • AsyncBoxView.getMinimumSpan(int)
  • BlockView.getMinimumSpan(int)
  • BoxView.getMinimumSpan(int)
  • ComponentView.getMinimumSpan(int)
  • GlyphView.getMinimumSpan(int)
  • ParagraphView.getMinimumSpan(int)
  • View.getMinimumSpan(int)
  • WrappedPlainView.getMinimumSpan(int)


getMinimumThumbSize

getMinimumThumbSize o7planning.org
  • BasicScrollBarUI.getMinimumThumbSize()
  • MetalScrollBarUI.getMinimumThumbSize()
  • SynthScrollBarUI.getMinimumThumbSize()


getMinimumValue

getMinimumValue o7planning.org
  • Spring.getMinimumValue()


getMinimumVerticalSize

getMinimumVerticalSize o7planning.org
  • BasicSliderUI.getMinimumVerticalSize()


getMinIndex

getMinIndex o7planning.org
  • ImageReader.getMinIndex()


getMinLabel

getMinLabel o7planning.org
  • FloatControl.getMinLabel()


getMinor

getMinor o7planning.org
  • GSSException.getMinor()


getMinorAxis

getMinorAxis o7planning.org
  • AsyncBoxView.getMinorAxis()


getMinorOffset

getMinorOffset o7planning.org
  • AsyncBoxView.ChildState.getMinorOffset()


getMinorSpan

getMinorSpan o7planning.org
  • AsyncBoxView.ChildState.getMinorSpan()


getMinorStatus

getMinorStatus o7planning.org
  • MessageProp.getMinorStatus()


getMinorString

getMinorString o7planning.org
  • GSSException.getMinorString()
  • MessageProp.getMinorString()


getMinorTickSpacing

getMinorTickSpacing o7planning.org
  • JSlider.getMinorTickSpacing()


getMinorVersion

getMinorVersion o7planning.org
  • Driver.getMinorVersion()
  • ICC_Profile.getMinorVersion()


getMinPage

getMinPage o7planning.org
  • JobAttributes.getMinPage()


getMinSelectionIndex

getMinSelectionIndex o7planning.org
  • DefaultListSelectionModel.getMinSelectionIndex()
  • JList.getMinSelectionIndex()
  • ListSelectionModel.getMinSelectionIndex()


getMinSelectionRow

getMinSelectionRow o7planning.org
  • DefaultTreeSelectionModel.getMinSelectionRow()
  • JTree.getMinSelectionRow()
  • TreeSelectionModel.getMinSelectionRow()


getMinSize

getMinSize o7planning.org
  • GridBagLayout.getMinSize(Container, GridBagLayoutInfo)


GetMinSize

GetMinSize o7planning.org
  • GridBagLayout.GetMinSize(Container, GridBagLayoutInfo)


getMinTileX

getMinTileX o7planning.org
  • BufferedImage.getMinTileX()
  • RenderedImage.getMinTileX()


getMinTileY

getMinTileY o7planning.org
  • BufferedImage.getMinTileY()
  • RenderedImage.getMinTileY()


getMinusSign

getMinusSign o7planning.org
  • DecimalFormatSymbols.getMinusSign()


getMinute

getMinute o7planning.org
  • LocalDateTime.getMinute()
  • LocalTime.getMinute()
  • OffsetDateTime.getMinute()
  • OffsetTime.getMinute()
  • XMLGregorianCalendar.getMinute()
  • ZonedDateTime.getMinute()


getMinutes

getMinutes o7planning.org
  • Date.getMinutes()
  • Date.getMinutes()
  • Duration.getMinutes()


getMinValue

getMinValue o7planning.org
  • ColorSpace.getMinValue(int)
  • ICC_ColorSpace.getMinValue(int)
  • OpenMBeanAttributeInfoSupport.getMinValue()
  • OpenMBeanParameterInfo.getMinValue()
  • OpenMBeanParameterInfoSupport.getMinValue()


getMinWidth

getMinWidth o7planning.org
  • TableColumn.getMinWidth()


getMinX

getMinX o7planning.org
  • BufferedImage.getMinX()
  • Raster.getMinX()
  • RectangularShape.getMinX()
  • RenderableImage.getMinX()
  • RenderableImageOp.getMinX()
  • RenderedImage.getMinX()


getMinY

getMinY o7planning.org
  • BufferedImage.getMinY()
  • Raster.getMinY()
  • RectangularShape.getMinY()
  • RenderableImage.getMinY()
  • RenderableImageOp.getMinY()
  • RenderedImage.getMinY()


getMissingGlyphCode

getMissingGlyphCode o7planning.org
  • Font.getMissingGlyphCode()


getMiterLimit

getMiterLimit o7planning.org
  • BasicStroke.getMiterLimit()


getMixer

getMixer o7planning.org
  • AudioSystem.getMixer(Mixer.Info)
  • MixerProvider.getMixer(Mixer.Info)


getMixerInfo

getMixerInfo o7planning.org
  • AudioSystem.getMixerInfo()
  • Mixer.getMixerInfo()
  • MixerProvider.getMixerInfo()


getMnemonic

getMnemonic o7planning.org
  • AbstractButton.getMnemonic()
  • AbstractColorChooserPanel.getMnemonic()
  • ButtonModel.getMnemonic()
  • DefaultButtonModel.getMnemonic()


getMnemonicAt

getMnemonicAt o7planning.org
  • JTabbedPane.getMnemonicAt(int)


getModalExclusionType

getModalExclusionType o7planning.org
  • Window.getModalExclusionType()


getModalityType

getModalityType o7planning.org
  • Dialog.getModalityType()


getMode

getMode o7planning.org
  • FileDialog.getMode()


getModel

getModel o7planning.org
  • AbstractButton.getModel()
  • AbstractLayoutCache.getModel()
  • BasicFileChooserUI.getModel()
  • BasicTreeUI.getModel()
  • DefaultRowSorter.getModel()
  • DefaultRowSorter.ModelWrapper.getModel()
  • JComboBox.getModel()
  • JList.getModel()
  • JProgressBar.getModel()
  • JScrollBar.getModel()
  • JSlider.getModel()
  • JSpinner.getModel()
  • JSpinner.DateEditor.getModel()
  • JSpinner.ListEditor.getModel()
  • JSpinner.NumberEditor.getModel()
  • JTabbedPane.getModel()
  • JTable.getModel()
  • JTree.getModel()
  • RowFilter.Entry.getModel()
  • RowSorter.getModel()


getModelIndex

getModelIndex o7planning.org
  • TableColumn.getModelIndex()


getModelRowCount

getModelRowCount o7planning.org
  • DefaultRowSorter.getModelRowCount()
  • RowSorter.getModelRowCount()


getModelWrapper

getModelWrapper o7planning.org
  • DefaultRowSorter.getModelWrapper()


getModificationOp

getModificationOp o7planning.org
  • ModificationItem.getModificationOp()


getModifier

getModifier o7planning.org
  • AttributeList.getModifier()


getModifiers

getModifiers o7planning.org
  • AWTKeyStroke.getModifiers()
  • ActionEvent.getModifiers()
  • Class.getModifiers()
  • Constructor.getModifiers()
  • Element.getModifiers()
  • Executable.getModifiers()
  • Field.getModifiers()
  • InputEvent.getModifiers()
  • Member.getModifiers()
  • Method.getModifiers()
  • MethodHandleInfo.getModifiers()
  • Parameter.getModifiers()


getModifiersEx

getModifiersEx o7planning.org
  • InputEvent.getModifiersEx()
  • MouseEvent.getModifiersEx()


getModifiersExText

getModifiersExText o7planning.org
  • InputEvent.getModifiersExText(int)


getModulus

getModulus o7planning.org
  • CounterMonitor.getModulus()
  • CounterMonitorMBean.getModulus()
  • RSAKey.getModulus()
  • RSAPrivateKeySpec.getModulus()
  • RSAPublicKeySpec.getModulus()


getMonetaryDecimalSeparator

getMonetaryDecimalSeparator o7planning.org
  • DecimalFormatSymbols.getMonetaryDecimalSeparator()


getMono

getMono o7planning.org
  • MidiChannel.getMono()


getMonth

getMonth o7planning.org
  • Date.getMonth()
  • LocalDate.getMonth()
  • LocalDateTime.getMonth()
  • MonthDay.getMonth()
  • OffsetDateTime.getMonth()
  • Time.getMonth()
  • XMLGregorianCalendar.getMonth()
  • YearMonth.getMonth()
  • ZoneOffsetTransitionRule.getMonth()
  • ZonedDateTime.getMonth()


getMonths

getMonths o7planning.org
  • DateFormatSymbols.getMonths()
  • Duration.getMonths()
  • Period.getMonths()


getMonthValue

getMonthValue o7planning.org
  • LocalDate.getMonthValue()
  • LocalDateTime.getMonthValue()
  • MonthDay.getMonthValue()
  • OffsetDateTime.getMonthValue()
  • YearMonth.getMonthValue()
  • ZonedDateTime.getMonthValue()


getMoreResults

getMoreResults o7planning.org
  • Statement.getMoreResults(int)
  • Statement.getMoreResults()


getMostRecentEventTime

getMostRecentEventTime o7planning.org
  • EventQueue.getMostRecentEventTime()


getMostRecentFocusOwner

getMostRecentFocusOwner o7planning.org
  • JInternalFrame.getMostRecentFocusOwner()
  • Window.getMostRecentFocusOwner()


getMostSignificantBits

getMostSignificantBits o7planning.org
  • UUID.getMostSignificantBits()


getMouseInfoPeer

getMouseInfoPeer o7planning.org
  • Toolkit.getMouseInfoPeer()


getMouseListener

getMouseListener o7planning.org
  • BasicComboPopup.getMouseListener()
  • ComboPopup.getMouseListener()


getMouseListeners

getMouseListeners o7planning.org
  • Component.getMouseListeners()
  • TrayIcon.getMouseListeners()


getMouseModifiersText

getMouseModifiersText o7planning.org
  • MouseEvent.getMouseModifiersText(int)


getMouseMotionListener

getMouseMotionListener o7planning.org
  • BasicComboPopup.getMouseMotionListener()
  • ComboPopup.getMouseMotionListener()


getMouseMotionListeners

getMouseMotionListeners o7planning.org
  • Component.getMouseMotionListeners()
  • TrayIcon.getMouseMotionListeners()


getMousePosition

getMousePosition o7planning.org
  • Component.getMousePosition()
  • Container.getMousePosition(boolean)


getMouseWheelListeners

getMouseWheelListeners o7planning.org
  • Component.getMouseWheelListeners()


getMTU

getMTU o7planning.org
  • NetworkInterface.getMTU()


getMultiClickThreshhold

getMultiClickThreshhold o7planning.org
  • AbstractButton.getMultiClickThreshhold()


getMultiDocPrintServices

getMultiDocPrintServices o7planning.org
  • PrintServiceLookup.getMultiDocPrintServices(DocFlavor[], AttributeSet)


getMultipleDocumentHandling

getMultipleDocumentHandling o7planning.org
  • JobAttributes.getMultipleDocumentHandling()


getMultiplier

getMultiplier o7planning.org
  • DecimalFormat.getMultiplier()


getMustUnderstand

getMustUnderstand o7planning.org
  • SOAPHeaderElement.getMustUnderstand()


getMute

getMute o7planning.org
  • MidiChannel.getMute()


getMutualAuthState

getMutualAuthState o7planning.org
  • GSSContext.getMutualAuthState()


getName

getName o7planning.org
  • AbstractDocument.AbstractElement.getName()
  • AbstractDocument.BranchElement.getName()
  • AbstractDocument.LeafElement.getName()
  • Acl.getName()
  • Attr.getName()
  • Attribute.getName()
  • Attribute.getName()
  • Attribute.getName()
  • AttributeList.getName(int)
  • AttributeList.getName()
  • AttributeListImpl.getName(int)
  • AttributedCharacterIterator.Attribute.getName()
  • BasicFileChooserUI.BasicFileView.getName(File)
  • BufferPoolMXBean.getName()
  • Character.getName(int)
  • Chromaticity.getName()
  • Class.getName()
  • Clipboard.getName()
  • ColorSpace.getName(int)
  • ColorSupported.getName()
  • CompilationMXBean.getName()
  • Component.getName()
  • Compression.getName()
  • Constructor.getName()
  • Copies.getName()
  • CopiesSupported.getName()
  • Cursor.getName()
  • DTD.getName()
  • DataHandler.getName()
  • DataSource.getName()
  • DateTimeAtCompleted.getName()
  • DateTimeAtCreation.getName()
  • DateTimeAtProcessing.getName()
  • DefaultMetalTheme.getName()
  • DefaultStyledDocument.SectionElement.getName()
  • Destination.getName()
  • DialogTypeSelection.getName()
  • DocumentName.getName()
  • DocumentType.getName()
  • DocumentationTool.Location.getName()
  • ECGenParameterSpec.getName()
  • Element.getName()
  • Element.getName()
  • Elements.getName(CharSequence)
  • EndElement.getName()
  • Entity.getName()
  • EntityDeclaration.getName()
  • EntityReference.getName()
  • Executable.getName()
  • ExemptionMechanism.getName()
  • FeatureDescriptor.getName()
  • Fidelity.getName()
  • Field.getName()
  • File.getName()
  • FileDataSource.getName()
  • FileObject.getName()
  • FileView.getName(File)
  • Finishings.getName()
  • Font.getName()
  • ForwardingFileObject.getName()
  • GSSCredential.getName(Oid)
  • GSSCredential.getName()
  • HTMLDocument.BlockElement.getName()
  • HTMLDocument.RunElement.getName()
  • HttpCookie.getName()
  • Identity.getName()
  • JAXBElement.getName()
  • JDBCType.getName()
  • JFileChooser.getName(File)
  • JMXPrincipal.getName()
  • JavaFileManager.Location.getName()
  • JobHoldUntil.getName()
  • JobImpressions.getName()
  • JobImpressionsCompleted.getName()
  • JobImpressionsSupported.getName()
  • JobKOctets.getName()
  • JobKOctetsProcessed.getName()
  • JobKOctetsSupported.getName()
  • JobMediaSheets.getName()
  • JobMediaSheetsCompleted.getName()
  • JobMediaSheetsSupported.getName()
  • JobMessageFromOperator.getName()
  • JobName.getName()
  • JobOriginatingUserName.getName()
  • JobPriority.getName()
  • JobPrioritySupported.getName()
  • JobSheets.getName()
  • JobState.getName()
  • JobStateReason.getName()
  • JobStateReasons.getName()
  • KerberosPrincipal.getName()
  • KeyName.getName()
  • KeyStore.Entry.Attribute.getName()
  • Keymap.getName()
  • Level.getName()
  • Logger.getName()
  • LookAndFeel.getName()
  • MBeanFeatureInfo.getName()
  • MLetContent.getName()
  • Media.getName()
  • MediaPrintableArea.getName()
  • MediaSize.getName()
  • Member.getName()
  • MemoryManagerMXBean.getName()
  • MemoryPoolMXBean.getName()
  • MenuComponent.getName()
  • MetalLookAndFeel.getName()
  • MetalTheme.getName()
  • Method.getName()
  • MethodHandleInfo.getName()
  • MidiDevice.Info.getName()
  • MimeHeader.getName()
  • Mixer.Info.getName()
  • MultiLookAndFeel.getName()
  • MultipleDocumentHandling.getName()
  • NameCallback.getName()
  • NameClassPair.getName()
  • NameList.getName(int)
  • NetworkInterface.getName()
  • NimbusLookAndFeel.getName()
  • NotationDeclaration.getName()
  • NumberOfDocuments.getName()
  • NumberOfInterveningJobs.getName()
  • NumberUp.getName()
  • NumberUpSupported.getName()
  • ObjectStreamClass.getName()
  • ObjectStreamField.getName()
  • OceanTheme.getName()
  • OpenMBeanConstructorInfo.getName()
  • OpenMBeanOperationInfo.getName()
  • OpenMBeanParameterInfo.getName()
  • OperatingSystemMXBean.getName()
  • OrientationRequested.getName()
  • OutputDeviceAssigned.getName()
  • PDLOverrideSupported.getName()
  • PKCS12Attribute.getName()
  • Package.getName()
  • PageRanges.getName()
  • PagesPerMinute.getName()
  • PagesPerMinuteColor.getName()
  • Parameter.getName()
  • Path.getName(int)
  • Permission.getName()
  • Port.Info.getName()
  • PresentationDirection.getName()
  • Principal.getName()
  • PrintQuality.getName()
  • PrintService.getName()
  • PrinterInfo.getName()
  • PrinterIsAcceptingJobs.getName()
  • PrinterLocation.getName()
  • PrinterMakeAndModel.getName()
  • PrinterMessageFromOperator.getName()
  • PrinterMoreInfo.getName()
  • PrinterMoreInfoManufacturer.getName()
  • PrinterName.getName()
  • PrinterResolution.getName()
  • PrinterState.getName()
  • PrinterStateReason.getName()
  • PrinterStateReasons.getName()
  • PrinterURI.getName()
  • Provider.getName()
  • QueuedJobCount.getName()
  • ReferenceUriSchemesSupported.getName()
  • Region.getName()
  • RequestingUserName.getName()
  • ReverbType.getName()
  • RoleInfo.getName()
  • RuntimeMXBean.getName()
  • SQLType.getName()
  • SSLSessionBindingEvent.getName()
  • Severity.getName()
  • SheetCollate.getName()
  • Sides.getName()
  • SimpleJavaFileObject.getName()
  • Soundbank.getName()
  • SoundbankResource.getName()
  • StandardLocation.getName()
  • StartElement.getName()
  • StreamReaderDelegate.getName()
  • Style.getName()
  • StyleContext.NamedStyle.getName()
  • SynthLookAndFeel.getName()
  • Thread.getName()
  • ThreadGroup.getName()
  • TypeVariable.getName()
  • UIManager.LookAndFeelInfo.getName()
  • URLDataSource.getName()
  • UserPrincipalNotFoundException.getName()
  • X500Principal.getName(String, Map<String, String>)
  • X500Principal.getName(String)
  • X500Principal.getName()
  • XMLStreamReader.getName()
  • ZipEntry.getName()
  • ZipFile.getName()


getNameConstraints

getNameConstraints o7planning.org
  • TrustAnchor.getNameConstraints()
  • X509CertSelector.getNameConstraints()


getNameCount

getNameCount o7planning.org
  • Path.getNameCount()


getNamedItem

getNamedItem o7planning.org
  • NamedNodeMap.getNamedItem(String)


getNamedItemNS

getNamedItemNS o7planning.org
  • NamedNodeMap.getNamedItemNS(String, String)


getNameInNamespace

getNameInNamespace o7planning.org
  • Context.getNameInNamespace()
  • InitialContext.getNameInNamespace()
  • NameClassPair.getNameInNamespace()


getNameParser

getNameParser o7planning.org
  • Context.getNameParser(String)
  • Context.getNameParser(Name)
  • InitialContext.getNameParser(Name)
  • InitialContext.getNameParser(String)


getNames

getNames o7planning.org
  • MimeTypeParameterList.getNames()
  • ScriptEngineFactory.getNames()


getNamesForMech

getNamesForMech o7planning.org
  • GSSManager.getNamesForMech(Oid)


getNamespaceContext

getNamespaceContext o7planning.org
  • StartElement.getNamespaceContext()
  • StreamReaderDelegate.getNamespaceContext()
  • XMLEventWriter.getNamespaceContext()
  • XMLStreamReader.getNamespaceContext()
  • XMLStreamWriter.getNamespaceContext()
  • XPath.getNamespaceContext()


getNamespaceCount

getNamespaceCount o7planning.org
  • StreamReaderDelegate.getNamespaceCount()
  • XMLStreamReader.getNamespaceCount()


getNamespaceMap

getNamespaceMap o7planning.org
  • XPathFilterParameterSpec.getNamespaceMap()
  • XPathType.getNamespaceMap()


getNamespacePrefix

getNamespacePrefix o7planning.org
  • DOMCryptoContext.getNamespacePrefix(String, String)
  • StreamReaderDelegate.getNamespacePrefix(int)
  • XMLCryptoContext.getNamespacePrefix(String, String)
  • XMLStreamReader.getNamespacePrefix(int)


getNamespacePrefixes

getNamespacePrefixes o7planning.org
  • SOAPElement.getNamespacePrefixes()


getNamespaces

getNamespaces o7planning.org
  • EndElement.getNamespaces()
  • StartElement.getNamespaces()


getNamespaceURI

getNamespaceURI o7planning.org
  • IIOMetadataNode.getNamespaceURI()
  • NameList.getNamespaceURI(int)
  • Namespace.getNamespaceURI()
  • NamespaceContext.getNamespaceURI(String)
  • Node.getNamespaceURI()
  • QName.getNamespaceURI()
  • SOAPElement.getNamespaceURI(String)
  • StartElement.getNamespaceURI(String)
  • StreamReaderDelegate.getNamespaceURI()
  • StreamReaderDelegate.getNamespaceURI(int)
  • StreamReaderDelegate.getNamespaceURI(String)
  • XMLStreamReader.getNamespaceURI()
  • XMLStreamReader.getNamespaceURI(int)
  • XMLStreamReader.getNamespaceURI(String)


getNameType

getNameType o7planning.org
  • KerberosPrincipal.getNameType()


getNaN

getNaN o7planning.org
  • DecimalFormatSymbols.getNaN()


getNano

getNano o7planning.org
  • Duration.getNano()
  • Instant.getNano()
  • LocalDateTime.getNano()
  • LocalTime.getNano()
  • OffsetDateTime.getNano()
  • OffsetTime.getNano()
  • ZonedDateTime.getNano()


getNanos

getNanos o7planning.org
  • Timestamp.getNanos()


getNativeCommands

getNativeCommands o7planning.org
  • MailcapCommandMap.getNativeCommands(String)


getNativeContainer

getNativeContainer o7planning.org
  • Toolkit.getNativeContainer(Component)


getNativeImageMetadataFormatName

getNativeImageMetadataFormatName o7planning.org
  • ImageReaderWriterSpi.getNativeImageMetadataFormatName()


getNativeMetadataFormatName

getNativeMetadataFormatName o7planning.org
  • IIOMetadata.getNativeMetadataFormatName()


getNativesForFlavor

getNativesForFlavor o7planning.org
  • FlavorTable.getNativesForFlavor(DataFlavor)
  • SystemFlavorMap.getNativesForFlavor(DataFlavor)


getNativesForFlavors

getNativesForFlavors o7planning.org
  • FlavorMap.getNativesForFlavors(DataFlavor[])
  • SystemFlavorMap.getNativesForFlavors(DataFlavor[])


getNativeStreamMetadataFormatName

getNativeStreamMetadataFormatName o7planning.org
  • ImageReaderWriterSpi.getNativeStreamMetadataFormatName()


getNavigationFilter

getNavigationFilter o7planning.org
  • DefaultFormatter.getNavigationFilter()
  • JFormattedTextField.AbstractFormatter.getNavigationFilter()
  • JTextComponent.getNavigationFilter()


getNbNotifications

getNbNotifications o7planning.org
  • Timer.getNbNotifications()
  • TimerMBean.getNbNotifications()


getNbOccurences

getNbOccurences o7planning.org
  • Timer.getNbOccurences(Integer)
  • TimerMBean.getNbOccurences(Integer)


getNCharacterStream

getNCharacterStream o7planning.org
  • CallableStatement.getNCharacterStream(String)
  • CallableStatement.getNCharacterStream(int)
  • ResultSet.getNCharacterStream(String)
  • ResultSet.getNCharacterStream(int)


getNClob

getNClob o7planning.org
  • CallableStatement.getNClob(String)
  • CallableStatement.getNClob(int)
  • ResultSet.getNClob(String)
  • ResultSet.getNClob(int)


getNeedClientAuth

getNeedClientAuth o7planning.org
  • SSLEngine.getNeedClientAuth()
  • SSLParameters.getNeedClientAuth()
  • SSLServerSocket.getNeedClientAuth()
  • SSLSocket.getNeedClientAuth()
  • SslRMIServerSocketFactory.getNeedClientAuth()


getNeededLocation

getNeededLocation o7planning.org
  • BasicSplitPaneDivider.DragController.getNeededLocation(int, int)
  • BasicSplitPaneDivider.VerticalDragController.getNeededLocation(int, int)


getNegativePrefix

getNegativePrefix o7planning.org
  • DecimalFormat.getNegativePrefix()


getNegativeSign

getNegativeSign o7planning.org
  • DecimalStyle.getNegativeSign()


getNegativeSuffix

getNegativeSuffix o7planning.org
  • DecimalFormat.getNegativeSuffix()


getNegotiatedProperty

getNegotiatedProperty o7planning.org
  • SaslClient.getNegotiatedProperty(String)
  • SaslServer.getNegotiatedProperty(String)


getNestedException

getNestedException o7planning.org
  • XMLStreamException.getNestedException()


getNestingKind

getNestingKind o7planning.org
  • ForwardingJavaFileObject.getNestingKind()
  • JavaFileObject.getNestingKind()
  • SimpleJavaFileObject.getNestingKind()
  • TypeElement.getNestingKind()


getNetworkInterface

getNetworkInterface o7planning.org
  • MulticastSocket.getNetworkInterface()


getNetworkInterfaces

getNetworkInterfaces o7planning.org
  • NetworkInterface.getNetworkInterfaces()


getNetworkPrefixLength

getNetworkPrefixLength o7planning.org
  • InterfaceAddress.getNetworkPrefixLength()


getNetworkTimeout

getNetworkTimeout o7planning.org
  • Connection.getNetworkTimeout()


getNewBinding

getNewBinding o7planning.org
  • NamingEvent.getNewBinding()


getNewDocument

getNewDocument o7planning.org
  • LSLoadEvent.getNewDocument()


getNewFolderAction

getNewFolderAction o7planning.org
  • BasicFileChooserUI.getNewFolderAction()


getNewLeadSelectionPath

getNewLeadSelectionPath o7planning.org
  • TreeSelectionEvent.getNewLeadSelectionPath()


getNewLine

getNewLine o7planning.org
  • LSSerializer.getNewLine()


getNewRoleValue

getNewRoleValue o7planning.org
  • RelationNotification.getNewRoleValue()


getNewState

getNewState o7planning.org
  • WindowEvent.getNewState()


getNewValue

getNewValue o7planning.org
  • AttributeChangeNotification.getNewValue()
  • MutationEvent.getNewValue()
  • PreferenceChangeEvent.getNewValue()
  • PropertyChangeEvent.getNewValue()


getNext

getNext o7planning.org
  • AttributeList.getNext()


getNextEastWestVisualPositionFrom

getNextEastWestVisualPositionFrom o7planning.org
  • CompositeView.getNextEastWestVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])


getNextEntry

getNextEntry o7planning.org
  • JarInputStream.getNextEntry()
  • ZipInputStream.getNextEntry()


getNextEvent

getNextEvent o7planning.org
  • EventQueue.getNextEvent()


getNextException

getNextException o7planning.org
  • SQLException.getNextException()


getNextFocusableComponent

getNextFocusableComponent o7planning.org
  • JComponent.getNextFocusableComponent()


getNextJarEntry

getNextJarEntry o7planning.org
  • JarInputStream.getNextJarEntry()


getNextLeaf

getNextLeaf o7planning.org
  • DefaultMutableTreeNode.getNextLeaf()


getNextLeftHit

getNextLeftHit o7planning.org
  • TextLayout.getNextLeftHit(int)
  • TextLayout.getNextLeftHit(int, TextLayout.CaretPolicy)
  • TextLayout.getNextLeftHit(TextHitInfo)


getNextMatch

getNextMatch o7planning.org
  • JList.getNextMatch(String, int, Position.Bias)
  • JTree.getNextMatch(String, int, Position.Bias)


getNextNode

getNextNode o7planning.org
  • DefaultMutableTreeNode.getNextNode()


getNextNorthSouthVisualPositionFrom

getNextNorthSouthVisualPositionFrom o7planning.org
  • CompositeView.getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])
  • ParagraphView.getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])


getNextRightHit

getNextRightHit o7planning.org
  • TextLayout.getNextRightHit(int)
  • TextLayout.getNextRightHit(int, TextLayout.CaretPolicy)
  • TextLayout.getNextRightHit(TextHitInfo)


getNextSequenceNumber

getNextSequenceNumber o7planning.org
  • NotificationResult.getNextSequenceNumber()


getNextSibling

getNextSibling o7planning.org
  • DOMResult.getNextSibling()
  • DOMSignContext.getNextSibling()
  • DefaultMutableTreeNode.getNextSibling()
  • IIOMetadataNode.getNextSibling()
  • Node.getNextSibling()


getNextTabIndex

getNextTabIndex o7planning.org
  • BasicTabbedPaneUI.getNextTabIndex(int)


getNextTabIndexInRun

getNextTabIndexInRun o7planning.org
  • BasicTabbedPaneUI.getNextTabIndexInRun(int, int)


getNextTabRun

getNextTabRun o7planning.org
  • BasicTabbedPaneUI.getNextTabRun(int)


getNextUpdate

getNextUpdate o7planning.org
  • X509CRL.getNextUpdate()


getNextValue

getNextValue o7planning.org
  • JSpinner.getNextValue()
  • SpinnerDateModel.getNextValue()
  • SpinnerListModel.getNextValue()
  • SpinnerModel.getNextValue()
  • SpinnerNumberModel.getNextValue()


getNextVisualPositionFrom

getNextVisualPositionFrom o7planning.org
  • AsyncBoxView.getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])
  • BasicTextUI.getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[])
  • CompositeView.getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])
  • GlyphView.getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])
  • GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView, int, Position.Bias, Shape, int, Position.Bias[])
  • MultiTextUI.getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[])
  • NavigationFilter.getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[])
  • TextUI.getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[])
  • View.getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[])


getNextWarning

getNextWarning o7planning.org
  • RowSetWarning.getNextWarning()
  • SQLWarning.getNextWarning()


getNextWord

getNextWord o7planning.org
  • Utilities.getNextWord(JTextComponent, int)


getNode

getNode o7planning.org
  • AbstractMarshallerImpl.getNode(Object)
  • DOMResult.getNode()
  • DOMSource.getNode()
  • DOMStructure.getNode()
  • DOMValidateContext.getNode()
  • Marshaller.getNode(Object)
  • PreferenceChangeEvent.getNode()
  • ValidationEventLocator.getNode()
  • ValidationEventLocatorImpl.getNode()


getNodeDimensions

getNodeDimensions o7planning.org
  • AbstractLayoutCache.getNodeDimensions(Object, int, int, boolean, Rectangle)
  • AbstractLayoutCache.getNodeDimensions()
  • AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object, int, int, boolean, Rectangle)
  • BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object, int, int, boolean, Rectangle)


getNodeName

getNodeName o7planning.org
  • IIOMetadataNode.getNodeName()
  • Node.getNodeName()


getNodeType

getNodeType o7planning.org
  • IIOMetadataNode.getNodeType()
  • Node.getNodeType()


getNodeValue

getNodeValue o7planning.org
  • IIOMetadataNode.getNodeValue()
  • Node.getNodeValue()


getNoFallbackControl

getNoFallbackControl o7planning.org
  • ResourceBundle.Control.getNoFallbackControl(List<String>)


getNoImageIcon

getNoImageIcon o7planning.org
  • ImageView.getNoImageIcon()


getNonContinuousLayoutDivider

getNonContinuousLayoutDivider o7planning.org
  • BasicSplitPaneUI.getNonContinuousLayoutDivider()


getNonCriticalExtensionOIDs

getNonCriticalExtensionOIDs o7planning.org
  • X509Extension.getNonCriticalExtensionOIDs()


getNonHeapMemoryUsage

getNonHeapMemoryUsage o7planning.org
  • MemoryMXBean.getNonHeapMemoryUsage()


getNonMatchingHeaders

getNonMatchingHeaders o7planning.org
  • MimeHeaders.getNonMatchingHeaders(String[])


getNonMatchingMimeHeaders

getNonMatchingMimeHeaders o7planning.org
  • AttachmentPart.getNonMatchingMimeHeaders(String[])
  • SOAPPart.getNonMatchingMimeHeaders(String[])


getNonRolloverBorder

getNonRolloverBorder o7planning.org
  • BasicToolBarUI.getNonRolloverBorder(AbstractButton)


getNoNSSchemaLocation

getNoNSSchemaLocation o7planning.org
  • AbstractMarshallerImpl.getNoNSSchemaLocation()


getNormalBounds

getNormalBounds o7planning.org
  • JInternalFrame.getNormalBounds()


getNormalizedComponents

getNormalizedComponents o7planning.org
  • ColorModel.getNormalizedComponents(Object, float[], int)
  • ColorModel.getNormalizedComponents(int[], int, float[], int)
  • ComponentColorModel.getNormalizedComponents(Object, float[], int)
  • ComponentColorModel.getNormalizedComponents(int[], int, float[], int)


getNormalizingTransform

getNormalizingTransform o7planning.org
  • GraphicsConfiguration.getNormalizingTransform()


getNorthPane

getNorthPane o7planning.org
  • BasicInternalFrameUI.getNorthPane()


getNotAfter

getNotAfter o7planning.org
  • X509Certificate.getNotAfter()
  • X509Certificate.getNotAfter()


getNotationName

getNotationName o7planning.org
  • Entity.getNotationName()
  • EntityDeclaration.getNotationName()


getNotations

getNotations o7planning.org
  • DTD.getNotations()
  • DocumentType.getNotations()


getNotBefore

getNotBefore o7planning.org
  • X509Certificate.getNotBefore()
  • X509Certificate.getNotBefore()


getNote

getNote o7planning.org
  • ProgressMonitor.getNote()


getNotification

getNotification o7planning.org
  • ModelMBeanInfo.getNotification(String)
  • ModelMBeanInfoSupport.getNotification(String)
  • TargetedNotification.getNotification()
  • UnsolicitedNotificationEvent.getNotification()


getNotificationID

getNotificationID o7planning.org
  • TimerNotification.getNotificationID()


getNotificationIDs

getNotificationIDs o7planning.org
  • Timer.getNotificationIDs(String)
  • TimerMBean.getNotificationIDs(String)


getNotificationInfo

getNotificationInfo o7planning.org
  • CounterMonitor.getNotificationInfo()
  • GaugeMonitor.getNotificationInfo()
  • JMXConnectorServer.getNotificationInfo()
  • MBeanServerDelegate.getNotificationInfo()
  • NotificationBroadcaster.getNotificationInfo()
  • NotificationBroadcasterSupport.getNotificationInfo()
  • RelationService.getNotificationInfo()
  • RequiredModelMBean.getNotificationInfo()
  • StandardEmitterMBean.getNotificationInfo()
  • StringMonitor.getNotificationInfo()
  • Timer.getNotificationInfo()


getNotificationMessage

getNotificationMessage o7planning.org
  • Timer.getNotificationMessage(Integer)
  • TimerMBean.getNotificationMessage(Integer)


getNotifications

getNotifications o7planning.org
  • MBeanInfo.getNotifications()
  • ModelMBeanInfo.getNotifications()
  • OpenMBeanInfo.getNotifications()


getNotificationType

getNotificationType o7planning.org
  • Timer.getNotificationType(Integer)
  • TimerMBean.getNotificationType(Integer)


getNotificationUserData

getNotificationUserData o7planning.org
  • Timer.getNotificationUserData(Integer)
  • TimerMBean.getNotificationUserData(Integer)


getNotifTypes

getNotifTypes o7planning.org
  • MBeanNotificationInfo.getNotifTypes()


getNotify

getNotify o7planning.org
  • CounterMonitor.getNotify()
  • CounterMonitorMBean.getNotify()


getNotifyDiffer

getNotifyDiffer o7planning.org
  • StringMonitor.getNotifyDiffer()
  • StringMonitorMBean.getNotifyDiffer()


getNotifyHigh

getNotifyHigh o7planning.org
  • GaugeMonitor.getNotifyHigh()
  • GaugeMonitorMBean.getNotifyHigh()


getNotifyLow

getNotifyLow o7planning.org
  • GaugeMonitor.getNotifyLow()
  • GaugeMonitorMBean.getNotifyLow()


getNotifyMatch

getNotifyMatch o7planning.org
  • StringMonitor.getNotifyMatch()
  • StringMonitorMBean.getNotifyMatch()


getNoType

getNoType o7planning.org
  • Types.getNoType(TypeKind)


getNow

getNow o7planning.org
  • CompletableFuture.getNow(T)


getNString

getNString o7planning.org
  • CallableStatement.getNString(String)
  • CallableStatement.getNString(int)
  • ResultSet.getNString(String)
  • ResultSet.getNString(int)


getNullFormatter

getNullFormatter o7planning.org
  • DefaultFormatterFactory.getNullFormatter()


getNullType

getNullType o7planning.org
  • Types.getNullType()


getNumBands

getNumBands o7planning.org
  • ImageTypeSpecifier.getNumBands()
  • Raster.getNumBands()
  • SampleModel.getNumBands()


getNumBanks

getNumBanks o7planning.org
  • DataBuffer.getNumBanks()


getNumber

getNumber o7planning.org
  • SpinnerNumberModel.getNumber()


getNumberFormat

getNumberFormat o7planning.org
  • DateFormat.getNumberFormat()


getNumberInstance

getNumberInstance o7planning.org
  • NumberFormat.getNumberInstance(Locale)
  • NumberFormat.getNumberInstance()
  • NumberFormatProvider.getNumberInstance(Locale)


getNumberOfButtons

getNumberOfButtons o7planning.org
  • MouseInfo.getNumberOfButtons()


getNumberOfDependents

getNumberOfDependents o7planning.org
  • CompletableFuture.getNumberOfDependents()


getNumberOfPages

getNumberOfPages o7planning.org
  • Book.getNumberOfPages()
  • Pageable.getNumberOfPages()


getNumberWaiting

getNumberWaiting o7planning.org
  • CyclicBarrier.getNumberWaiting()


getNumChars

getNumChars o7planning.org
  • LineMetrics.getNumChars()


getNumColorComponents

getNumColorComponents o7planning.org
  • ColorModel.getNumColorComponents()


getNumComponents

getNumComponents o7planning.org
  • ColorModel.getNumComponents()
  • ColorSpace.getNumComponents()
  • ICC_Profile.getNumComponents()
  • ImageTypeSpecifier.getNumComponents()
  • LookupTable.getNumComponents()


getNumDataElements

getNumDataElements o7planning.org
  • ComponentSampleModel.getNumDataElements()
  • MultiPixelPackedSampleModel.getNumDataElements()
  • Raster.getNumDataElements()
  • SampleModel.getNumDataElements()
  • SinglePixelPackedSampleModel.getNumDataElements()


getNumDesignAxes

getNumDesignAxes o7planning.org
  • MultipleMaster.getNumDesignAxes()


getNumericCode

getNumericCode o7planning.org
  • Currency.getNumericCode()


getNumericFunctions

getNumericFunctions o7planning.org
  • DatabaseMetaData.getNumericFunctions()


getNumericValue

getNumericValue o7planning.org
  • Character.getNumericValue(int)
  • Character.getNumericValue(char)


getNumFactors

getNumFactors o7planning.org
  • RescaleOp.getNumFactors()


getNumGlyphs

getNumGlyphs o7planning.org
  • Font.getNumGlyphs()
  • GlyphVector.getNumGlyphs()


getNumImages

getNumImages o7planning.org
  • ImageReader.getNumImages(boolean)


getNumParameters

getNumParameters o7planning.org
  • ParameterBlock.getNumParameters()


getNumSources

getNumSources o7planning.org
  • ParameterBlock.getNumSources()


getNumThumbnails

getNumThumbnails o7planning.org
  • IIOImage.getNumThumbnails()
  • ImageReader.getNumThumbnails(int)


getNumThumbnailsSupported

getNumThumbnailsSupported o7planning.org
  • ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata)


getNumXTiles

getNumXTiles o7planning.org
  • BufferedImage.getNumXTiles()
  • RenderedImage.getNumXTiles()


getNumYTiles

getNumYTiles o7planning.org
  • BufferedImage.getNumYTiles()
  • RenderedImage.getNumYTiles()


getObject

getObject o7planning.org
  • Binding.getObject()
  • CallableStatement.getObject(String, Class<T>)
  • CallableStatement.getObject(int, Class<T>)
  • CallableStatement.getObject(String, Map<String, Class<?>>)
  • CallableStatement.getObject(String)
  • CallableStatement.getObject(int, Map<String, Class<?>>)
  • CallableStatement.getObject(int)
  • DirStateFactory.Result.getObject()
  • GuardedObject.getObject()
  • Ref.getObject()
  • Ref.getObject(Map<String, Class<?>>)
  • ResourceBundle.getObject(String)
  • ResultSet.getObject(String, Class<T>)
  • ResultSet.getObject(int, Class<T>)
  • ResultSet.getObject(String, Map<String, Class<?>>)
  • ResultSet.getObject(int, Map<String, Class<?>>)
  • ResultSet.getObject(String)
  • ResultSet.getObject(int)
  • SealedObject.getObject(Key, String)
  • SealedObject.getObject(Cipher)
  • SealedObject.getObject(Key)
  • SerialJavaObject.getObject()
  • SerialRef.getObject()
  • SerialRef.getObject(Map<String, Class<?>>)
  • SignedObject.getObject()
  • ValidationEventLocator.getObject()
  • ValidationEventLocatorImpl.getObject()


getObjectArrayMaxLength

getObjectArrayMaxLength o7planning.org
  • IIOMetadataFormat.getObjectArrayMaxLength(String)
  • IIOMetadataFormatImpl.getObjectArrayMaxLength(String)


getObjectArrayMinLength

getObjectArrayMinLength o7planning.org
  • IIOMetadataFormat.getObjectArrayMinLength(String)
  • IIOMetadataFormatImpl.getObjectArrayMinLength(String)


getObjectClass

getObjectClass o7planning.org
  • IIOMetadataFormat.getObjectClass(String)
  • IIOMetadataFormatImpl.getObjectClass(String)


getObjectDefaultValue

getObjectDefaultValue o7planning.org
  • IIOMetadataFormat.getObjectDefaultValue(String)
  • IIOMetadataFormatImpl.getObjectDefaultValue(String)


getObjectEnumerations

getObjectEnumerations o7planning.org
  • IIOMetadataFormat.getObjectEnumerations(String)
  • IIOMetadataFormatImpl.getObjectEnumerations(String)


getObjectForLayer

getObjectForLayer o7planning.org
  • JLayeredPane.getObjectForLayer(int)


getObjectInstance

getObjectInstance o7planning.org
  • DirObjectFactory.getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes)
  • DirectoryManager.getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes)
  • MBeanServer.getObjectInstance(ObjectName)
  • MBeanServerConnection.getObjectInstance(ObjectName)
  • NamingManager.getObjectInstance(Object, Name, Context, Hashtable<?, ?>)
  • ObjectFactory.getObjectInstance(Object, Name, Context, Hashtable<?, ?>)
  • RMIConnection.getObjectInstance(ObjectName, Subject)
  • RMIConnectionImpl.getObjectInstance(ObjectName, Subject)
  • RMIConnectionImpl_Stub.getObjectInstance(ObjectName, Subject)


getObjectMaxValue

getObjectMaxValue o7planning.org
  • IIOMetadataFormat.getObjectMaxValue(String)
  • IIOMetadataFormatImpl.getObjectMaxValue(String)


getObjectMinValue

getObjectMinValue o7planning.org
  • IIOMetadataFormat.getObjectMinValue(String)
  • IIOMetadataFormatImpl.getObjectMinValue(String)


getObjectName

getObjectName o7planning.org
  • MBeanServerInvocationHandler.getObjectName()
  • ObjectInstance.getObjectName()
  • PlatformManagedObject.getObjectName()
  • RelationNotification.getObjectName()


getObjectParameter

getObjectParameter o7planning.org
  • ParameterBlock.getObjectParameter(int)


getObjectPendingFinalizationCount

getObjectPendingFinalizationCount o7planning.org
  • MemoryMXBean.getObjectPendingFinalizationCount()


getObjects

getObjects o7planning.org
  • XMLSignature.getObjects()


getObjectSize

getObjectSize o7planning.org
  • Instrumentation.getObjectSize(Object)


getObjectStreamClass

getObjectStreamClass o7planning.org
  • ObjectInputStream.GetField.getObjectStreamClass()


getObjectValueType

getObjectValueType o7planning.org
  • IIOMetadataFormat.getObjectValueType(String)
  • IIOMetadataFormatImpl.getObjectValueType(String)


getObservedAttribute

getObservedAttribute o7planning.org
  • Monitor.getObservedAttribute()
  • MonitorMBean.getObservedAttribute()
  • MonitorNotification.getObservedAttribute()


getObservedObject

getObservedObject o7planning.org
  • Monitor.getObservedObject()
  • MonitorMBean.getObservedObject()
  • MonitorNotification.getObservedObject()


getObservedObjects

getObservedObjects o7planning.org
  • Monitor.getObservedObjects()
  • MonitorMBean.getObservedObjects()


getOcspExtensions

getOcspExtensions o7planning.org
  • PKIXRevocationChecker.getOcspExtensions()


getOcspResponder

getOcspResponder o7planning.org
  • PKIXRevocationChecker.getOcspResponder()


getOcspResponderCert

getOcspResponderCert o7planning.org
  • PKIXRevocationChecker.getOcspResponderCert()


getOcspResponses

getOcspResponses o7planning.org
  • PKIXRevocationChecker.getOcspResponses()


getOctetStream

getOctetStream o7planning.org
  • OctetStreamData.getOctetStream()


getOffendingNode

getOffendingNode o7planning.org
  • IIOInvalidTreeException.getOffendingNode()


getOffscreenBuffer

getOffscreenBuffer o7planning.org
  • RepaintManager.getOffscreenBuffer(Component, int, int)


getOffset

getOffset o7planning.org
  • AbstractDocument.DefaultDocumentEvent.getOffset()
  • BasicToolBarUI.DragWindow.getOffset()
  • BoxView.getOffset(int, int)
  • ChronoZonedDateTime.getOffset()
  • CollationElementIterator.getOffset()
  • ComponentSampleModel.getOffset(int, int, int)
  • ComponentSampleModel.getOffset(int, int)
  • CounterMonitor.getOffset()
  • CounterMonitorMBean.getOffset()
  • DataBuffer.getOffset()
  • DatagramPacket.getOffset()
  • DefaultStyledDocument.ElementSpec.getOffset()
  • DocumentEvent.getOffset()
  • EnumSyntax.getOffset()
  • Finishings.getOffset()
  • IIOByteBuffer.getOffset()
  • LookupTable.getOffset()
  • MultiPixelPackedSampleModel.getOffset(int, int)
  • ObjectStreamField.getOffset()
  • OffsetDateTime.getOffset()
  • OffsetTime.getOffset()
  • OrientationRequested.getOffset()
  • Position.getOffset()
  • PrintQuality.getOffset()
  • SimpleTimeZone.getOffset(int, int, int, int, int, int)
  • SimpleTimeZone.getOffset(long)
  • SinglePixelPackedSampleModel.getOffset(int, int)
  • TimeZone.getOffset(long)
  • TimeZone.getOffset(int, int, int, int, int, int)
  • ValidationEventLocator.getOffset()
  • ValidationEventLocatorImpl.getOffset()
  • ZoneRules.getOffset(LocalDateTime)
  • ZoneRules.getOffset(Instant)
  • ZonedDateTime.getOffset()


getOffsetAfter

getOffsetAfter o7planning.org
  • ZoneOffsetTransition.getOffsetAfter()
  • ZoneOffsetTransitionRule.getOffsetAfter()


getOffsetBefore

getOffsetBefore o7planning.org
  • ZoneOffsetTransition.getOffsetBefore()
  • ZoneOffsetTransitionRule.getOffsetBefore()


getOffsetHit

getOffsetHit o7planning.org
  • TextHitInfo.getOffsetHit(int)


getOffsets

getOffsets o7planning.org
  • DataBuffer.getOffsets()
  • RescaleOp.getOffsets(float[])


getOldBinding

getOldBinding o7planning.org
  • NamingEvent.getOldBinding()


getOldLeadSelectionPath

getOldLeadSelectionPath o7planning.org
  • TreeSelectionEvent.getOldLeadSelectionPath()


getOldRoleValue

getOldRoleValue o7planning.org
  • RelationNotification.getOldRoleValue()


getOldState

getOldState o7planning.org
  • WindowEvent.getOldState()


getOldValue

getOldValue o7planning.org
  • AttributeChangeNotification.getOldValue()
  • PropertyChangeEvent.getOldValue()


getOmni

getOmni o7planning.org
  • MidiChannel.getOmni()


getOOBInline

getOOBInline o7planning.org
  • Socket.getOOBInline()


getOpacity

getOpacity o7planning.org
  • Window.getOpacity()


getOpenIcon

getOpenIcon o7planning.org
  • DefaultTreeCellRenderer.getOpenIcon()


getOpenType

getOpenType o7planning.org
  • OpenMBeanAttributeInfoSupport.getOpenType()
  • OpenMBeanParameterInfo.getOpenType()
  • OpenMBeanParameterInfoSupport.getOpenType()


getOperatingSystemMXBean

getOperatingSystemMXBean o7planning.org
  • ManagementFactory.getOperatingSystemMXBean()


getOperation

getOperation o7planning.org
  • ModelMBeanInfo.getOperation(String)
  • ModelMBeanInfoSupport.getOperation(String)
  • Operation.getOperation()


getOperations

getOperations o7planning.org
  • MBeanInfo.getOperations()
  • ModelMBeanInfo.getOperations()
  • OpenMBeanInfo.getOperations()
  • Skeleton.getOperations()


getOppositeComponent

getOppositeComponent o7planning.org
  • FocusEvent.getOppositeComponent()


getOppositeWindow

getOppositeWindow o7planning.org
  • WindowEvent.getOppositeWindow()


getOptimizeHuffmanTables

getOptimizeHuffmanTables o7planning.org
  • JPEGImageWriteParam.getOptimizeHuffmanTables()


getOption

getOption o7planning.org
  • NetworkChannel.getOption(SocketOption<T>)
  • SocketOptions.getOption(int)


getOptions

getOptions o7planning.org
  • AppConfigurationEntry.getOptions()
  • ConfirmationCallback.getOptions()
  • JOptionPane.getOptions()
  • PKIXRevocationChecker.getOptions()
  • ProcessingEnvironment.getOptions()


getOptionType

getOptionType o7planning.org
  • ConfirmationCallback.getOptionType()
  • JOptionPane.getOptionType()


getOrDefault

getOrDefault o7planning.org
  • ConcurrentHashMap.getOrDefault(Object, V)
  • ConcurrentMap.getOrDefault(Object, V)
  • ConcurrentSkipListMap.getOrDefault(Object, V)
  • HashMap.getOrDefault(Object, V)
  • Hashtable.getOrDefault(Object, V)
  • LinkedHashMap.getOrDefault(Object, V)
  • Map.getOrDefault(Object, V)
  • Provider.getOrDefault(Object, Object)


getOrder

getOrder o7planning.org
  • ECParameterSpec.getOrder()


getOrientation

getOrientation o7planning.org
  • Adjustable.getOrientation()
  • BasicSplitPaneUI.getOrientation()
  • BasicToolBarUI.DragWindow.getOrientation()
  • ComponentOrientation.getOrientation(ResourceBundle)
  • ComponentOrientation.getOrientation(Locale)
  • JProgressBar.getOrientation()
  • JScrollBar.getOrientation()
  • JSeparator.getOrientation()
  • JSlider.getOrientation()
  • JSplitPane.getOrientation()
  • JToolBar.getOrientation()
  • PageFormat.getOrientation()
  • ScrollPaneAdjustable.getOrientation()
  • Scrollbar.getOrientation()


getOrientationRequested

getOrientationRequested o7planning.org
  • PageAttributes.getOrientationRequested()


getOrigin

getOrigin o7planning.org
  • PageAttributes.getOrigin()


getOriginal

getOriginal o7planning.org
  • CachedRowSet.getOriginal()
  • RowSetInternal.getOriginal()


getOriginalRow

getOriginalRow o7planning.org
  • CachedRowSet.getOriginalRow()
  • RowSetInternal.getOriginalRow()


getOriginatingNode

getOriginatingNode o7planning.org
  • DOMLocator.getOriginatingNode()


getOriginatingProvider

getOriginatingProvider o7planning.org
  • ImageReader.getOriginatingProvider()
  • ImageWriter.getOriginatingProvider()


getOtherFile

getOtherFile o7planning.org
  • FileSystemException.getOtherFile()


getOtherHit

getOtherHit o7planning.org
  • TextHitInfo.getOtherHit()


getOtherPrimeInfo

getOtherPrimeInfo o7planning.org
  • RSAMultiPrimePrivateCrtKey.getOtherPrimeInfo()
  • RSAMultiPrimePrivateCrtKeySpec.getOtherPrimeInfo()


getOutline

getOutline o7planning.org
  • GlyphVector.getOutline(float, float)
  • GlyphVector.getOutline()
  • GraphicAttribute.getOutline(AffineTransform)
  • ShapeGraphicAttribute.getOutline(AffineTransform)
  • TextLayout.getOutline(AffineTransform)


getOutput

getOutput o7planning.org
  • ImageWriter.getOutput()


getOutputClass

getOutputClass o7planning.org
  • ImageOutputStreamSpi.getOutputClass()


getOutputFormat

getOutputFormat o7planning.org
  • StreamPrintService.getOutputFormat()
  • StreamPrintServiceFactory.getOutputFormat()


getOutputLength

getOutputLength o7planning.org
  • HMACParameterSpec.getOutputLength()


getOutputProperties

getOutputProperties o7planning.org
  • Templates.getOutputProperties()
  • Transformer.getOutputProperties()


getOutputProperty

getOutputProperty o7planning.org
  • Transformer.getOutputProperty(String)


getOutputSize

getOutputSize o7planning.org
  • Cipher.getOutputSize(int)
  • ExemptionMechanism.getOutputSize(int)


getOutputStatement

getOutputStatement o7planning.org
  • ScriptEngineFactory.getOutputStatement(String)


getOutputStream

getOutputStream o7planning.org
  • DataHandler.getOutputStream()
  • DataSource.getOutputStream()
  • FileDataSource.getOutputStream()
  • LogStream.getOutputStream()
  • Process.getOutputStream()
  • RemoteCall.getOutputStream()
  • Socket.getOutputStream()
  • SocketImpl.getOutputStream()
  • StreamPrintService.getOutputStream()
  • StreamResult.getOutputStream()
  • URLConnection.getOutputStream()
  • URLDataSource.getOutputStream()


getOutputTypes

getOutputTypes o7planning.org
  • ImageWriterSpi.getOutputTypes()


getOutsideBorder

getOutsideBorder o7planning.org
  • CompoundBorder.getOutsideBorder()


getOverwriteMode

getOverwriteMode o7planning.org
  • DefaultFormatter.getOverwriteMode()


getOwnedWindows

getOwnedWindows o7planning.org
  • Window.getOwnedWindows()


getOwner

getOwner o7planning.org
  • FileOwnerAttributeView.getOwner()
  • Files.getOwner(Path, LinkOption...)
  • ReentrantLock.getOwner()
  • ReentrantReadWriteLock.getOwner()
  • Window.getOwner()
  • XMLDecoder.getOwner()
  • XMLEncoder.getOwner()


getOwnerDocument

getOwnerDocument o7planning.org
  • IIOMetadataNode.getOwnerDocument()
  • Node.getOwnerDocument()


getOwnerElement

getOwnerElement o7planning.org
  • Attr.getOwnerElement()


getOwnerlessWindows

getOwnerlessWindows o7planning.org
  • Window.getOwnerlessWindows()


getOwnerType

getOwnerType o7planning.org
  • ParameterizedType.getOwnerType()


getP1

getP1 o7planning.org
  • CubicCurve2D.getP1()
  • CubicCurve2D.Double.getP1()
  • CubicCurve2D.Float.getP1()
  • Line2D.getP1()
  • Line2D.Double.getP1()
  • Line2D.Float.getP1()
  • QuadCurve2D.getP1()
  • QuadCurve2D.Double.getP1()
  • QuadCurve2D.Float.getP1()


getP2

getP2 o7planning.org
  • CubicCurve2D.getP2()
  • CubicCurve2D.Double.getP2()
  • CubicCurve2D.Float.getP2()
  • Line2D.getP2()
  • Line2D.Double.getP2()
  • Line2D.Float.getP2()
  • QuadCurve2D.getP2()
  • QuadCurve2D.Double.getP2()
  • QuadCurve2D.Float.getP2()


getP

getP o7planning.org
  • DHParameterSpec.getP()
  • DHPrivateKeySpec.getP()
  • DHPublicKeySpec.getP()
  • DSAParameterSpec.getP()
  • DSAParams.getP()
  • DSAPrivateKeySpec.getP()
  • DSAPublicKeySpec.getP()
  • ECFieldFp.getP()


getPackage

getPackage o7planning.org
  • Class.getPackage()
  • ClassLoader.getPackage(String)
  • Package.getPackage(String)


getPackageElement

getPackageElement o7planning.org
  • Elements.getPackageElement(CharSequence)


getPackageOf

getPackageOf o7planning.org
  • Elements.getPackageOf(Element)


getPackages

getPackages o7planning.org
  • ClassLoader.getPackages()
  • Package.getPackages()


getPacketBufferSize

getPacketBufferSize o7planning.org
  • SSLSession.getPacketBufferSize()


getPadding

getPadding o7planning.org
  • BasicOptionPaneUI.ButtonAreaLayout.getPadding()


getPage

getPage o7planning.org
  • JEditorPane.getPage()


getPageDimension

getPageDimension o7planning.org
  • PrintJob.getPageDimension()


getPageFormat

getPageFormat o7planning.org
  • Book.getPageFormat(int)
  • Pageable.getPageFormat(int)
  • PrinterJob.getPageFormat(PrintRequestAttributeSet)


getPageIncrement

getPageIncrement o7planning.org
  • Scrollbar.getPageIncrement()


getPageRanges

getPageRanges o7planning.org
  • JobAttributes.getPageRanges()


getPageResolution

getPageResolution o7planning.org
  • PrintJob.getPageResolution()


getPageSize

getPageSize o7planning.org
  • CachedRowSet.getPageSize()


getPaint

getPaint o7planning.org
  • Graphics2D.getPaint()
  • StrokeBorder.getPaint()


getPaintContext

getPaintContext o7planning.org
  • AbstractRegionPainter.getPaintContext()


getPainter

getPainter o7planning.org
  • GlyphView.GlyphPainter.getPainter(GlyphView, int, int)
  • Highlighter.Highlight.getPainter()
  • NimbusStyle.getPainter(SynthContext)
  • SynthStyle.getPainter(SynthContext)


getPaintLabels

getPaintLabels o7planning.org
  • JSlider.getPaintLabels()


getPaintTicks

getPaintTicks o7planning.org
  • JSlider.getPaintTicks()


getPaintTrack

getPaintTrack o7planning.org
  • JSlider.getPaintTrack()


getPaper

getPaper o7planning.org
  • PageFormat.getPaper()


getParagraphAttributes

getParagraphAttributes o7planning.org
  • JTextPane.getParagraphAttributes()


getParagraphElement

getParagraphElement o7planning.org
  • AbstractDocument.getParagraphElement(int)
  • DefaultStyledDocument.getParagraphElement(int)
  • PlainDocument.getParagraphElement(int)
  • StyledDocument.getParagraphElement(int)
  • Utilities.getParagraphElement(JTextComponent, int)


getParallelism

getParallelism o7planning.org
  • ForkJoinPool.getParallelism()


getParamClasses

getParamClasses o7planning.org
  • ParameterBlock.getParamClasses()


getParameter

getParameter o7planning.org
  • Applet.getParameter(String)
  • AppletStub.getParameter(String)
  • DOMConfiguration.getParameter(String)
  • DataFlavor.getParameter(String)
  • DataTruncation.getParameter()
  • DocFlavor.getParameter(String)
  • MimeType.getParameter(String)
  • ScriptEngineFactory.getParameter(String)
  • Signature.getParameter(String)
  • Transformer.getParameter(String)


getParameterAnnotations

getParameterAnnotations o7planning.org
  • Constructor.getParameterAnnotations()
  • Executable.getParameterAnnotations()
  • Method.getParameterAnnotations()


getParameterBlock

getParameterBlock o7planning.org
  • RenderableImageOp.getParameterBlock()


getParameterClassName

getParameterClassName o7planning.org
  • ParameterMetaData.getParameterClassName(int)


getParameterCount

getParameterCount o7planning.org
  • Constructor.getParameterCount()
  • Executable.getParameterCount()
  • Method.getParameterCount()
  • ParameterMetaData.getParameterCount()


getParameterDescriptors

getParameterDescriptors o7planning.org
  • MethodDescriptor.getParameterDescriptors()


getParameterInfo

getParameterInfo o7planning.org
  • Applet.getParameterInfo()


getParameterizedType

getParameterizedType o7planning.org
  • Parameter.getParameterizedType()


getParameterMetaData

getParameterMetaData o7planning.org
  • PreparedStatement.getParameterMetaData()


getParameterMode

getParameterMode o7planning.org
  • ParameterMetaData.getParameterMode(int)


getParameterName

getParameterName o7planning.org
  • StandardMBean.getParameterName(MBeanOperationInfo, MBeanParameterInfo, int)
  • StandardMBean.getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int)


getParameterNames

getParameterNames o7planning.org
  • DOMConfiguration.getParameterNames()


getParameters

getParameters o7planning.org
  • CertPathTrustManagerParameters.getParameters()
  • Cipher.getParameters()
  • Configuration.getParameters()
  • Executable.getParameters()
  • ExecutableElement.getParameters()
  • KeyStoreBuilderParameters.getParameters()
  • LogRecord.getParameters()
  • MimeType.getParameters()
  • ParameterBlock.getParameters()
  • Policy.getParameters()
  • Signature.getParameters()


getParameterSpec

getParameterSpec o7planning.org
  • AlgorithmMethod.getParameterSpec()
  • AlgorithmParameters.getParameterSpec(Class<T>)
  • CanonicalizationMethod.getParameterSpec()
  • DigestMethod.getParameterSpec()
  • PBEParameterSpec.getParameterSpec()
  • SignatureMethod.getParameterSpec()
  • Transform.getParameterSpec()


getParameterType

getParameterType o7planning.org
  • ParameterMetaData.getParameterType(int)


getParameterTypeName

getParameterTypeName o7planning.org
  • ParameterMetaData.getParameterTypeName(int)


getParameterTypes

getParameterTypes o7planning.org
  • Constructor.getParameterTypes()
  • Executable.getParameterTypes()
  • ExecutableType.getParameterTypes()
  • MLetContent.getParameterTypes()
  • Method.getParameterTypes()


getParameterValues

getParameterValues o7planning.org
  • MLetContent.getParameterValues()


getParams

getParams o7planning.org
  • BaseRowSet.getParams()
  • DHKey.getParams()
  • DSAKey.getParams()
  • ECKey.getParams()
  • ECPrivateKeySpec.getParams()
  • ECPublicKeySpec.getParams()
  • RowSetInternal.getParams()


getParent

getParent o7planning.org
  • AbstractDocument.AbstractElement.getParent()
  • ActionMap.getParent()
  • ClassLoader.getParent()
  • Component.getParent()
  • DOMSignContext.getParent()
  • DefaultMutableTreeNode.getParent()
  • EventReaderDelegate.getParent()
  • File.getParent()
  • InputMap.getParent()
  • Logger.getParent()
  • MenuComponent.getParent()
  • NetworkInterface.getParent()
  • NodeChangeEvent.getParent()
  • Path.getParent()
  • Phaser.getParent()
  • PolicyNode.getParent()
  • PopupMenu.getParent()
  • Raster.getParent()
  • StreamReaderDelegate.getParent()
  • ThreadGroup.getParent()
  • TreeNode.getParent()
  • View.getParent()
  • XMLFilter.getParent()
  • XMLFilterImpl.getParent()


getParentDirectory

getParentDirectory o7planning.org
  • FileSystemView.getParentDirectory(File)


getParentElement

getParentElement o7planning.org
  • AbstractDocument.AbstractElement.getParentElement()
  • Element.getParentElement()
  • Node.getParentElement()


getParentFile

getParentFile o7planning.org
  • File.getParentFile()


getParentLogger

getParentLogger o7planning.org
  • CommonDataSource.getParentLogger()
  • Driver.getParentLogger()


getParentLoggerName

getParentLoggerName o7planning.org
  • LoggingMXBean.getParentLoggerName(String)
  • PlatformLoggingMXBean.getParentLoggerName(String)


getParentNode

getParentNode o7planning.org
  • IIOMetadataNode.getParentNode()
  • Node.getParentNode()


getParentPath

getParentPath o7planning.org
  • TreePath.getParentPath()


getParsedString

getParsedString o7planning.org
  • DateTimeParseException.getParsedString()


getParser

getParser o7planning.org
  • HTMLDocument.getParser()
  • HTMLEditorKit.getParser()
  • SAXParser.getParser()


getPartialSize

getPartialSize o7planning.org
  • ParagraphView.getPartialSize(int, int)


getPartialSpan

getPartialSpan o7planning.org
  • GlyphView.getPartialSpan(int, int)
  • TabableView.getPartialSpan(int, int)


getParties

getParties o7planning.org
  • CyclicBarrier.getParties()


getPassword

getPassword o7planning.org
  • BaseRowSet.getPassword()
  • JPasswordField.getPassword()
  • KeyStore.PasswordProtection.getPassword()
  • PBEKey.getPassword()
  • PBEKeySpec.getPassword()
  • PasswordAuthentication.getPassword()
  • PasswordCallback.getPassword()
  • RowSet.getPassword()


getPasswordAuthentication

getPasswordAuthentication o7planning.org
  • Authenticator.getPasswordAuthentication()


getPasteAction

getPasteAction o7planning.org
  • TransferHandler.getPasteAction()


getPatch

getPatch o7planning.org
  • Instrument.getPatch()


getPatchList

getPatchList o7planning.org
  • Sequence.getPatchList()


getPath

getPath o7planning.org
  • BasicMenuItemUI.getPath()
  • DefaultMutableTreeNode.getPath()
  • File.getPath()
  • FileSystem.getPath(String, String...)
  • FileSystemProvider.getPath(URI)
  • HttpContext.getPath()
  • HttpCookie.getPath()
  • JTree.DropLocation.getPath()
  • MenuDragMouseEvent.getPath()
  • MenuKeyEvent.getPath()
  • TreeExpansionEvent.getPath()
  • TreeModelEvent.getPath()
  • TreePath.getPath()
  • TreeSelectionEvent.getPath()
  • URI.getPath()
  • URL.getPath()


getPathBetweenRows

getPathBetweenRows o7planning.org
  • JTree.getPathBetweenRows(int, int)


getPathBounds

getPathBounds o7planning.org
  • BasicTreeUI.getPathBounds(JTree, TreePath)
  • JTree.getPathBounds(TreePath)
  • MultiTreeUI.getPathBounds(JTree, TreePath)
  • TreeUI.getPathBounds(JTree, TreePath)


getPathClosestTo

getPathClosestTo o7planning.org
  • AbstractLayoutCache.getPathClosestTo(int, int)
  • FixedHeightLayoutCache.getPathClosestTo(int, int)
  • VariableHeightLayoutCache.getPathClosestTo(int, int)


getPathComponent

getPathComponent o7planning.org
  • TreePath.getPathComponent(int)


getPathCount

getPathCount o7planning.org
  • TreePath.getPathCount()


getPathForLocation

getPathForLocation o7planning.org
  • JTree.getPathForLocation(int, int)


getPathForRow

getPathForRow o7planning.org
  • AbstractLayoutCache.getPathForRow(int)
  • BasicTreeUI.getPathForRow(JTree, int)
  • FixedHeightLayoutCache.getPathForRow(int)
  • JTree.getPathForRow(int)
  • MultiTreeUI.getPathForRow(JTree, int)
  • TreeUI.getPathForRow(JTree, int)
  • VariableHeightLayoutCache.getPathForRow(int)


getPathInfo

getPathInfo o7planning.org
  • HttpExchange.getPathInfo()


getPathIterator

getPathIterator o7planning.org
  • Arc2D.getPathIterator(AffineTransform)
  • Area.getPathIterator(AffineTransform, double)
  • Area.getPathIterator(AffineTransform)
  • CubicCurve2D.getPathIterator(AffineTransform, double)
  • CubicCurve2D.getPathIterator(AffineTransform)
  • Ellipse2D.getPathIterator(AffineTransform)
  • Line2D.getPathIterator(AffineTransform, double)
  • Line2D.getPathIterator(AffineTransform)
  • Path2D.getPathIterator(AffineTransform, double)
  • Path2D.Double.getPathIterator(AffineTransform)
  • Path2D.Float.getPathIterator(AffineTransform)
  • Polygon.getPathIterator(AffineTransform, double)
  • Polygon.getPathIterator(AffineTransform)
  • QuadCurve2D.getPathIterator(AffineTransform, double)
  • QuadCurve2D.getPathIterator(AffineTransform)
  • Rectangle2D.getPathIterator(AffineTransform, double)
  • Rectangle2D.getPathIterator(AffineTransform)
  • RectangularShape.getPathIterator(AffineTransform, double)
  • RoundRectangle2D.getPathIterator(AffineTransform)
  • Shape.getPathIterator(AffineTransform, double)
  • Shape.getPathIterator(AffineTransform)


getPathMatcher

getPathMatcher o7planning.org
  • FileSystem.getPathMatcher(String)


getPaths

getPaths o7planning.org
  • TreeSelectionEvent.getPaths()


getPathToNames

getPathToNames o7planning.org
  • X509CertSelector.getPathToNames()


getPathToRoot

getPathToRoot o7planning.org
  • DefaultMutableTreeNode.getPathToRoot(TreeNode, int)
  • DefaultTreeModel.getPathToRoot(TreeNode, int)
  • DefaultTreeModel.getPathToRoot(TreeNode)


getPattern

getPattern o7planning.org
  • PatternSyntaxException.getPattern()


getPatternSeparator

getPatternSeparator o7planning.org
  • DecimalFormatSymbols.getPatternSeparator()


getPayload

getPayload o7planning.org
  • LogicalMessage.getPayload(JAXBContext)
  • LogicalMessage.getPayload()


getPCSType

getPCSType o7planning.org
  • ICC_Profile.getPCSType()


getPeakThreadCount

getPeakThreadCount o7planning.org
  • ThreadMXBean.getPeakThreadCount()


getPeakUsage

getPeakUsage o7planning.org
  • MemoryPoolMXBean.getPeakUsage()


getPeer

getPeer o7planning.org
  • Component.getPeer()
  • Font.getPeer()
  • MenuComponent.getPeer()


getPeerCertificateChain

getPeerCertificateChain o7planning.org
  • HandshakeCompletedEvent.getPeerCertificateChain()
  • SSLSession.getPeerCertificateChain()


getPeerCertificates

getPeerCertificates o7planning.org
  • HandshakeCompletedEvent.getPeerCertificates()
  • SSLSession.getPeerCertificates()


getPeerHost

getPeerHost o7planning.org
  • SSLEngine.getPeerHost()
  • SSLSession.getPeerHost()


getPeerPort

getPeerPort o7planning.org
  • SSLEngine.getPeerPort()
  • SSLSession.getPeerPort()


getPeerPrincipal

getPeerPrincipal o7planning.org
  • HandshakeCompletedEvent.getPeerPrincipal()
  • HttpsURLConnection.getPeerPrincipal()
  • SSLSession.getPeerPrincipal()
  • SecureCacheResponse.getPeerPrincipal()


getPeerSupportedSignatureAlgorithms

getPeerSupportedSignatureAlgorithms o7planning.org
  • ExtendedSSLSession.getPeerSupportedSignatureAlgorithms()


getPendingCount

getPendingCount o7planning.org
  • CountedCompleter.getPendingCount()


getPercent

getPercent o7planning.org
  • DecimalFormatSymbols.getPercent()


getPercentComplete

getPercentComplete o7planning.org
  • JProgressBar.getPercentComplete()


getPercentInstance

getPercentInstance o7planning.org
  • NumberFormat.getPercentInstance(Locale)
  • NumberFormat.getPercentInstance()
  • NumberFormatProvider.getPercentInstance(Locale)


getPeriod

getPeriod o7planning.org
  • Timer.getPeriod(Integer)
  • TimerMBean.getPeriod(Integer)


getPermanentFocusOwner

getPermanentFocusOwner o7planning.org
  • KeyboardFocusManager.getPermanentFocusOwner()


getPerMill

getPerMill o7planning.org
  • DecimalFormatSymbols.getPerMill()


getPermission

getPermission o7planning.org
  • AccessControlException.getPermission()
  • HttpURLConnection.getPermission()
  • URLConnection.getPermission()


getPermissions

getPermissions o7planning.org
  • Acl.getPermissions(Principal)
  • Policy.getPermissions(Subject, CodeSource)
  • Policy.getPermissions(ProtectionDomain)
  • Policy.getPermissions(CodeSource)
  • ProtectionDomain.getPermissions()
  • SecureClassLoader.getPermissions(CodeSource)
  • URLClassLoader.getPermissions(CodeSource)


getPersistenceDelegate

getPersistenceDelegate o7planning.org
  • Encoder.getPersistenceDelegate(Class<?>)


getPhase

getPhase o7planning.org
  • Phaser.getPhase()


getPIData

getPIData o7planning.org
  • StreamReaderDelegate.getPIData()
  • XMLStreamReader.getPIData()


getPITarget

getPITarget o7planning.org
  • StreamReaderDelegate.getPITarget()
  • XMLStreamReader.getPITarget()


getPitchBend

getPitchBend o7planning.org
  • MidiChannel.getPitchBend()


getPixel

getPixel o7planning.org
  • BandedSampleModel.getPixel(int, int, int[], DataBuffer)
  • ComponentSampleModel.getPixel(int, int, int[], DataBuffer)
  • MultiPixelPackedSampleModel.getPixel(int, int, int[], DataBuffer)
  • Raster.getPixel(int, int, double[])
  • Raster.getPixel(int, int, float[])
  • Raster.getPixel(int, int, int[])
  • SampleModel.getPixel(int, int, double[], DataBuffer)
  • SampleModel.getPixel(int, int, float[], DataBuffer)
  • SampleModel.getPixel(int, int, int[], DataBuffer)
  • SinglePixelPackedSampleModel.getPixel(int, int, int[], DataBuffer)


getPixelBitStride

getPixelBitStride o7planning.org
  • MultiPixelPackedSampleModel.getPixelBitStride()


getPixelBounds

getPixelBounds o7planning.org
  • GlyphVector.getPixelBounds(FontRenderContext, float, float)
  • TextLayout.getPixelBounds(FontRenderContext, float, float)


getPixelColor

getPixelColor o7planning.org
  • Robot.getPixelColor(int, int)


getPixels

getPixels o7planning.org
  • BandedSampleModel.getPixels(int, int, int, int, int[], DataBuffer)
  • ComponentSampleModel.getPixels(int, int, int, int, int[], DataBuffer)
  • PixelGrabber.getPixels()
  • Raster.getPixels(int, int, int, int, double[])
  • Raster.getPixels(int, int, int, int, float[])
  • Raster.getPixels(int, int, int, int, int[])
  • SampleModel.getPixels(int, int, int, int, double[], DataBuffer)
  • SampleModel.getPixels(int, int, int, int, float[], DataBuffer)
  • SampleModel.getPixels(int, int, int, int, int[], DataBuffer)
  • SinglePixelPackedSampleModel.getPixels(int, int, int, int, int[], DataBuffer)


getPixelSize

getPixelSize o7planning.org
  • ColorModel.getPixelSize()


getPixelStride

getPixelStride o7planning.org
  • ComponentSampleModel.getPixelStride()


getPlaceholder

getPlaceholder o7planning.org
  • MaskFormatter.getPlaceholder()


getPlaceholderCharacter

getPlaceholderCharacter o7planning.org
  • MaskFormatter.getPlaceholderCharacter()


getPlatformManagementInterfaces

getPlatformManagementInterfaces o7planning.org
  • ManagementFactory.getPlatformManagementInterfaces()


getPlatformMBeanServer

getPlatformMBeanServer o7planning.org
  • ManagementFactory.getPlatformMBeanServer()


getPlatformMXBean

getPlatformMXBean o7planning.org
  • ManagementFactory.getPlatformMXBean(MBeanServerConnection, Class<T>)
  • ManagementFactory.getPlatformMXBean(Class<T>)


getPlatformMXBeans

getPlatformMXBeans o7planning.org
  • ManagementFactory.getPlatformMXBeans(MBeanServerConnection, Class<T>)
  • ManagementFactory.getPlatformMXBeans(Class<T>)


getPluginClassName

getPluginClassName o7planning.org
  • ImageReaderWriterSpi.getPluginClassName()


getPoint1

getPoint1 o7planning.org
  • GradientPaint.getPoint1()


getPoint2

getPoint2 o7planning.org
  • GradientPaint.getPoint2()


getPoint2D

getPoint2D o7planning.org
  • AffineTransformOp.getPoint2D(Point2D, Point2D)
  • BandCombineOp.getPoint2D(Point2D, Point2D)
  • BufferedImageOp.getPoint2D(Point2D, Point2D)
  • ColorConvertOp.getPoint2D(Point2D, Point2D)
  • ConvolveOp.getPoint2D(Point2D, Point2D)
  • LookupOp.getPoint2D(Point2D, Point2D)
  • RasterOp.getPoint2D(Point2D, Point2D)
  • RescaleOp.getPoint2D(Point2D, Point2D)


getPoint

getPoint o7planning.org
  • MouseEvent.getPoint()


getPointerInfo

getPointerInfo o7planning.org
  • MouseInfo.getPointerInfo()


getPointSize

getPointSize o7planning.org
  • StyleSheet.getPointSize(String)
  • StyleSheet.getPointSize(int)


getPolicy

getPolicy o7planning.org
  • Policy.getPolicy()
  • Policy.getPolicy()
  • X509CertSelector.getPolicy()


getPolicyQualifier

getPolicyQualifier o7planning.org
  • PolicyQualifierInfo.getPolicyQualifier()


getPolicyQualifierId

getPolicyQualifierId o7planning.org
  • PolicyQualifierInfo.getPolicyQualifierId()


getPolicyQualifiers

getPolicyQualifiers o7planning.org
  • PolicyNode.getPolicyQualifiers()


getPolicyQualifiersRejected

getPolicyQualifiersRejected o7planning.org
  • PKIXParameters.getPolicyQualifiersRejected()


getPolicyTree

getPolicyTree o7planning.org
  • PKIXCertPathValidatorResult.getPolicyTree()


getPolyPressure

getPolyPressure o7planning.org
  • MidiChannel.getPolyPressure(int)


getPool

getPool o7planning.org
  • ForkJoinTask.getPool()
  • ForkJoinWorkerThread.getPool()


getPooledConnection

getPooledConnection o7planning.org
  • ConnectionPoolDataSource.getPooledConnection(String, String)
  • ConnectionPoolDataSource.getPooledConnection()


getPoolIndex

getPoolIndex o7planning.org
  • ForkJoinWorkerThread.getPoolIndex()


getPoolName

getPoolName o7planning.org
  • MemoryNotificationInfo.getPoolName()


getPoolSize

getPoolSize o7planning.org
  • ForkJoinPool.getPoolSize()
  • ThreadPoolExecutor.getPoolSize()


getPopup

getPopup o7planning.org
  • MultiPopupMenuUI.getPopup(JPopupMenu, int, int)
  • PopupFactory.getPopup(Component, Component, int, int)
  • PopupMenuUI.getPopup(JPopupMenu, int, int)


getPopupHeightForRowCount

getPopupHeightForRowCount o7planning.org
  • BasicComboPopup.getPopupHeightForRowCount(int)


getPopupLocation

getPopupLocation o7planning.org
  • JComponent.getPopupLocation(MouseEvent)


getPopupMenu

getPopupMenu o7planning.org
  • JMenu.getPopupMenu()
  • TrayIcon.getPopupMenu()


getPopupMenuListeners

getPopupMenuListeners o7planning.org
  • JComboBox.getPopupMenuListeners()
  • JPopupMenu.getPopupMenuListeners()


getPopupMenuOrigin

getPopupMenuOrigin o7planning.org
  • JMenu.getPopupMenuOrigin()


getPort

getPort o7planning.org
  • DatagramPacket.getPort()
  • DatagramSocket.getPort()
  • EndpointReference.getPort(Class<T>, WebServiceFeature...)
  • InetSocketAddress.getPort()
  • JMXServiceURL.getPort()
  • LDAPCertStoreParameters.getPort()
  • Provider.getPort(EndpointReference, Class<T>, WebServiceFeature...)
  • Service.getPort(EndpointReference, Class<T>, WebServiceFeature...)
  • Service.getPort(Class<T>, WebServiceFeature...)
  • Service.getPort(Class<T>)
  • Service.getPort(QName, Class<T>, WebServiceFeature...)
  • Service.getPort(QName, Class<T>)
  • ServiceDelegate.getPort(Class<T>, WebServiceFeature...)
  • ServiceDelegate.getPort(Class<T>)
  • ServiceDelegate.getPort(EndpointReference, Class<T>, WebServiceFeature...)
  • ServiceDelegate.getPort(QName, Class<T>, WebServiceFeature...)
  • ServiceDelegate.getPort(QName, Class<T>)
  • Socket.getPort()
  • SocketImpl.getPort()
  • URI.getPort()
  • URL.getPort()


getPortlist

getPortlist o7planning.org
  • HttpCookie.getPortlist()


getPortName

getPortName o7planning.org
  • PortInfo.getPortName()


getPorts

getPorts o7planning.org
  • Service.getPorts()
  • ServiceDelegate.getPorts()


getPosition

getPosition o7planning.org
  • Diagnostic.getPosition()
  • JLayeredPane.getPosition(Component)
  • LSProgressEvent.getPosition()
  • LineBreakMeasurer.getPosition()
  • SizeSequence.getPosition(int)
  • TabStop.getPosition()


getPositionAbove

getPositionAbove o7planning.org
  • Utilities.getPositionAbove(JTextComponent, int, int)


getPositionBelow

getPositionBelow o7planning.org
  • Utilities.getPositionBelow(JTextComponent, int, int)


getPositionsInRange

getPositionsInRange o7planning.org
  • GapContent.getPositionsInRange(Vector, int, int)
  • StringContent.getPositionsInRange(Vector, int, int)


getPositivePrefix

getPositivePrefix o7planning.org
  • DecimalFormat.getPositivePrefix()


getPositiveSign

getPositiveSign o7planning.org
  • DecimalStyle.getPositiveSign()


getPositiveSuffix

getPositiveSuffix o7planning.org
  • DecimalFormat.getPositiveSuffix()


getPosixFilePermissions

getPosixFilePermissions o7planning.org
  • Files.getPosixFilePermissions(Path, LinkOption...)


getPreciseWheelRotation

getPreciseWheelRotation o7planning.org
  • MouseWheelEvent.getPreciseWheelRotation()


getPrecision

getPrecision o7planning.org
  • FloatControl.getPrecision()
  • IllegalFormatPrecisionException.getPrecision()
  • MathContext.getPrecision()
  • ParameterMetaData.getPrecision(int)
  • ResultSetMetaData.getPrecision(int)
  • RowSetMetaDataImpl.getPrecision(int)


getPredefinedCursor

getPredefinedCursor o7planning.org
  • Cursor.getPredefinedCursor(int)


getPreferredButtonSize

getPreferredButtonSize o7planning.org
  • BasicGraphicsUtils.getPreferredButtonSize(AbstractButton, int)


getPreferredCommands

getPreferredCommands o7planning.org
  • CommandMap.getPreferredCommands(String, DataSource)
  • CommandMap.getPreferredCommands(String)
  • DataHandler.getPreferredCommands()
  • MailcapCommandMap.getPreferredCommands(String)


getPreferredGap

getPreferredGap o7planning.org
  • LayoutStyle.getPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, Container)


getPreferredHeight

getPreferredHeight o7planning.org
  • AbstractLayoutCache.getPreferredHeight()
  • VariableHeightLayoutCache.getPreferredHeight()


getPreferredHorizontalSize

getPreferredHorizontalSize o7planning.org
  • BasicSliderUI.getPreferredHorizontalSize()


getPreferredInnerHorizontal

getPreferredInnerHorizontal o7planning.org
  • BasicProgressBarUI.getPreferredInnerHorizontal()


getPreferredInnerVertical

getPreferredInnerVertical o7planning.org
  • BasicProgressBarUI.getPreferredInnerVertical()


getPreferredMenuItemSize

getPreferredMenuItemSize o7planning.org
  • BasicMenuItemUI.getPreferredMenuItemSize(JComponent, Icon, Icon, int)
  • SynthMenuItemUI.getPreferredMenuItemSize(JComponent, Icon, Icon, int)
  • SynthMenuUI.getPreferredMenuItemSize(JComponent, Icon, Icon, int)


getPreferredMinSize

getPreferredMinSize o7planning.org
  • BasicTreeUI.getPreferredMinSize()


getPreferredScrollableViewportSize

getPreferredScrollableViewportSize o7planning.org
  • JLayer.getPreferredScrollableViewportSize()
  • JList.getPreferredScrollableViewportSize()
  • JTable.getPreferredScrollableViewportSize()
  • JTextArea.getPreferredScrollableViewportSize()
  • JTextComponent.getPreferredScrollableViewportSize()
  • JTree.getPreferredScrollableViewportSize()
  • Scrollable.getPreferredScrollableViewportSize()


getPreferredSize

getPreferredSize o7planning.org
  • BasicArrowButton.getPreferredSize()
  • BasicButtonUI.getPreferredSize(JComponent)
  • BasicComboBoxRenderer.getPreferredSize()
  • BasicComboBoxUI.getPreferredSize(JComponent)
  • BasicDesktopIconUI.getPreferredSize(JComponent)
  • BasicDesktopPaneUI.getPreferredSize(JComponent)
  • BasicInternalFrameUI.getPreferredSize(JComponent)
  • BasicLabelUI.getPreferredSize(JComponent)
  • BasicListUI.getPreferredSize(JComponent)
  • BasicMenuItemUI.getPreferredSize(JComponent)
  • BasicOptionPaneUI.getPreferredSize(JComponent)
  • BasicPopupMenuSeparatorUI.getPreferredSize(JComponent)
  • BasicProgressBarUI.getPreferredSize(JComponent)
  • BasicRadioButtonUI.getPreferredSize(JComponent)
  • BasicScrollBarUI.getPreferredSize(JComponent)
  • BasicSeparatorUI.getPreferredSize(JComponent)
  • BasicSliderUI.getPreferredSize(JComponent)
  • BasicSplitPaneDivider.getPreferredSize()
  • BasicSplitPaneUI.getPreferredSize(JComponent)
  • BasicTableHeaderUI.getPreferredSize(JComponent)
  • BasicTableUI.getPreferredSize(JComponent)
  • BasicTextAreaUI.getPreferredSize(JComponent)
  • BasicTextUI.getPreferredSize(JComponent)
  • BasicToolBarSeparatorUI.getPreferredSize(JComponent)
  • BasicToolTipUI.getPreferredSize(JComponent)
  • BasicTreeUI.getPreferredSize(JComponent, boolean)
  • BasicTreeUI.getPreferredSize(JComponent)
  • Component.getPreferredSize()
  • ComponentUI.getPreferredSize(JComponent)
  • Container.getPreferredSize()
  • DefaultTreeCellEditor.DefaultTextField.getPreferredSize()
  • DefaultTreeCellEditor.EditorContainer.getPreferredSize()
  • DefaultTreeCellRenderer.getPreferredSize()
  • JComponent.getPreferredSize()
  • JEditorPane.getPreferredSize()
  • JTextArea.getPreferredSize()
  • JTextField.getPreferredSize()
  • JToolBar.Separator.getPreferredSize()
  • LayerUI.getPreferredSize(JComponent)
  • List.getPreferredSize()
  • List.getPreferredSize(int)
  • MetalDesktopIconUI.getPreferredSize(JComponent)
  • MetalFileChooserUI.getPreferredSize(JComponent)
  • MetalPopupMenuSeparatorUI.getPreferredSize(JComponent)
  • MetalScrollBarUI.getPreferredSize(JComponent)
  • MetalScrollButton.getPreferredSize()
  • MetalSeparatorUI.getPreferredSize(JComponent)
  • MetalToolTipUI.getPreferredSize(JComponent)
  • MultiButtonUI.getPreferredSize(JComponent)
  • MultiColorChooserUI.getPreferredSize(JComponent)
  • MultiComboBoxUI.getPreferredSize(JComponent)
  • MultiDesktopIconUI.getPreferredSize(JComponent)
  • MultiDesktopPaneUI.getPreferredSize(JComponent)
  • MultiFileChooserUI.getPreferredSize(JComponent)
  • MultiInternalFrameUI.getPreferredSize(JComponent)
  • MultiLabelUI.getPreferredSize(JComponent)
  • MultiListUI.getPreferredSize(JComponent)
  • MultiMenuBarUI.getPreferredSize(JComponent)
  • MultiMenuItemUI.getPreferredSize(JComponent)
  • MultiOptionPaneUI.getPreferredSize(JComponent)
  • MultiPanelUI.getPreferredSize(JComponent)
  • MultiPopupMenuUI.getPreferredSize(JComponent)
  • MultiProgressBarUI.getPreferredSize(JComponent)
  • MultiRootPaneUI.getPreferredSize(JComponent)
  • MultiScrollBarUI.getPreferredSize(JComponent)
  • MultiScrollPaneUI.getPreferredSize(JComponent)
  • MultiSeparatorUI.getPreferredSize(JComponent)
  • MultiSliderUI.getPreferredSize(JComponent)
  • MultiSpinnerUI.getPreferredSize(JComponent)
  • MultiSplitPaneUI.getPreferredSize(JComponent)
  • MultiTabbedPaneUI.getPreferredSize(JComponent)
  • MultiTableHeaderUI.getPreferredSize(JComponent)
  • MultiTableUI.getPreferredSize(JComponent)
  • MultiTextUI.getPreferredSize(JComponent)
  • MultiToolBarUI.getPreferredSize(JComponent)
  • MultiToolTipUI.getPreferredSize(JComponent)
  • MultiTreeUI.getPreferredSize(JComponent)
  • MultiViewportUI.getPreferredSize(JComponent)
  • SynthButtonUI.getPreferredSize(JComponent)
  • SynthGraphicsUtils.getPreferredSize(SynthContext, Font, String, Icon, int, int, int, int, int, int)
  • SynthLabelUI.getPreferredSize(JComponent)
  • SynthProgressBarUI.getPreferredSize(JComponent)
  • SynthScrollBarUI.getPreferredSize(JComponent)
  • SynthSeparatorUI.getPreferredSize(JComponent)
  • SynthSliderUI.getPreferredSize(JComponent)
  • SynthToolTipUI.getPreferredSize(JComponent)
  • TextArea.getPreferredSize()
  • TextArea.getPreferredSize(int, int)
  • TextField.getPreferredSize()
  • TextField.getPreferredSize(int)


getPreferredSizeOfComponent

getPreferredSizeOfComponent o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getPreferredSizeOfComponent(Component)


getPreferredSpan

getPreferredSpan o7planning.org
  • AsyncBoxView.getPreferredSpan(int)
  • BlockView.getPreferredSpan(int)
  • BoxView.getPreferredSpan(int)
  • ComponentView.getPreferredSpan(int)
  • FieldView.getPreferredSpan(int)
  • GlyphView.getPreferredSpan(int)
  • IconView.getPreferredSpan(int)
  • ImageView.getPreferredSpan(int)
  • ParagraphView.getPreferredSpan(int)
  • PasswordView.getPreferredSpan(int)
  • PlainView.getPreferredSpan(int)
  • View.getPreferredSpan(int)
  • WrappedPlainView.getPreferredSpan(int)


getPreferredThumbnailSizes

getPreferredThumbnailSizes o7planning.org
  • ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata)


getPreferredTileSizes

getPreferredTileSizes o7planning.org
  • ImageWriteParam.getPreferredTileSizes()


getPreferredValue

getPreferredValue o7planning.org
  • Spring.getPreferredValue()


getPreferredVerticalSize

getPreferredVerticalSize o7planning.org
  • BasicSliderUI.getPreferredVerticalSize()


getPreferredWidth

getPreferredWidth o7planning.org
  • AbstractLayoutCache.getPreferredWidth(Rectangle)
  • TableColumn.getPreferredWidth()
  • VariableHeightLayoutCache.getPreferredWidth(Rectangle)


getPrefix

getPrefix o7planning.org
  • CompositeName.getPrefix(int)
  • CompoundName.getPrefix(int)
  • IIOMetadataNode.getPrefix()
  • LdapName.getPrefix(int)
  • Name.getPrefix()
  • Name.getPrefix(int)
  • Namespace.getPrefix()
  • NamespaceContext.getPrefix(String)
  • NamespaceSupport.getPrefix(String)
  • Node.getPrefix()
  • QName.getPrefix()
  • StreamReaderDelegate.getPrefix()
  • XMLEventWriter.getPrefix(String)
  • XMLStreamReader.getPrefix()
  • XMLStreamWriter.getPrefix(String)


getPrefixes

getPrefixes o7planning.org
  • NamespaceContext.getPrefixes(String)
  • NamespaceSupport.getPrefixes(String)
  • NamespaceSupport.getPrefixes()


getPrefixList

getPrefixList o7planning.org
  • ExcC14NParameterSpec.getPrefixList()


getPresentationName

getPresentationName o7planning.org
  • AbstractDocument.DefaultDocumentEvent.getPresentationName()
  • AbstractUndoableEdit.getPresentationName()
  • CompoundEdit.getPresentationName()
  • StateEdit.getPresentationName()
  • UndoableEdit.getPresentationName()


getPreservesUnknownTags

getPreservesUnknownTags o7planning.org
  • HTMLDocument.getPreservesUnknownTags()


getPressedIcon

getPressedIcon o7planning.org
  • AbstractButton.getPressedIcon()


getPreviewPanel

getPreviewPanel o7planning.org
  • ColorChooserComponentFactory.getPreviewPanel()
  • JColorChooser.getPreviewPanel()


getPreviousBounds

getPreviousBounds o7planning.org
  • DefaultDesktopManager.getPreviousBounds(JInternalFrame)


getPreviousLeaf

getPreviousLeaf o7planning.org
  • DefaultMutableTreeNode.getPreviousLeaf()


getPreviousNode

getPreviousNode o7planning.org
  • DefaultMutableTreeNode.getPreviousNode()


getPreviousRowCount

getPreviousRowCount o7planning.org
  • RowSorterEvent.getPreviousRowCount()


getPreviousSibling

getPreviousSibling o7planning.org
  • DefaultMutableTreeNode.getPreviousSibling()
  • IIOMetadataNode.getPreviousSibling()
  • Node.getPreviousSibling()


getPreviousTabIndex

getPreviousTabIndex o7planning.org
  • BasicTabbedPaneUI.getPreviousTabIndex(int)


getPreviousTabIndexInRun

getPreviousTabIndexInRun o7planning.org
  • BasicTabbedPaneUI.getPreviousTabIndexInRun(int, int)


getPreviousTabRun

getPreviousTabRun o7planning.org
  • BasicTabbedPaneUI.getPreviousTabRun(int)


getPreviousValue

getPreviousValue o7planning.org
  • JSpinner.getPreviousValue()
  • SpinnerDateModel.getPreviousValue()
  • SpinnerListModel.getPreviousValue()
  • SpinnerModel.getPreviousValue()
  • SpinnerNumberModel.getPreviousValue()


getPreviousWord

getPreviousWord o7planning.org
  • Utilities.getPreviousWord(JTextComponent, int)


getPrevValue

getPrevValue o7planning.org
  • MutationEvent.getPrevValue()


getPrimary1

getPrimary1 o7planning.org
  • DefaultMetalTheme.getPrimary1()
  • MetalTheme.getPrimary1()
  • OceanTheme.getPrimary1()


getPrimary2

getPrimary2 o7planning.org
  • DefaultMetalTheme.getPrimary2()
  • MetalTheme.getPrimary2()
  • OceanTheme.getPrimary2()


getPrimary3

getPrimary3 o7planning.org
  • DefaultMetalTheme.getPrimary3()
  • MetalTheme.getPrimary3()
  • OceanTheme.getPrimary3()


getPrimaryControl

getPrimaryControl o7planning.org
  • MetalLookAndFeel.getPrimaryControl()
  • MetalTheme.getPrimaryControl()


getPrimaryControlDarkShadow

getPrimaryControlDarkShadow o7planning.org
  • MetalLookAndFeel.getPrimaryControlDarkShadow()
  • MetalTheme.getPrimaryControlDarkShadow()


getPrimaryControlHighlight

getPrimaryControlHighlight o7planning.org
  • MetalLookAndFeel.getPrimaryControlHighlight()
  • MetalTheme.getPrimaryControlHighlight()


getPrimaryControlInfo

getPrimaryControlInfo o7planning.org
  • MetalLookAndFeel.getPrimaryControlInfo()
  • MetalTheme.getPrimaryControlInfo()


getPrimaryControlShadow

getPrimaryControlShadow o7planning.org
  • MetalLookAndFeel.getPrimaryControlShadow()
  • MetalTheme.getPrimaryControlShadow()


getPrimaryKeys

getPrimaryKeys o7planning.org
  • DatabaseMetaData.getPrimaryKeys(String, String, String)


getPrimaryType

getPrimaryType o7planning.org
  • DataFlavor.getPrimaryType()
  • MimeType.getPrimaryType()


getPrime

getPrime o7planning.org
  • RSAOtherPrimeInfo.getPrime()


getPrimeExponentP

getPrimeExponentP o7planning.org
  • RSAMultiPrimePrivateCrtKey.getPrimeExponentP()
  • RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentP()
  • RSAPrivateCrtKey.getPrimeExponentP()
  • RSAPrivateCrtKeySpec.getPrimeExponentP()


getPrimeExponentQ

getPrimeExponentQ o7planning.org
  • RSAMultiPrimePrivateCrtKey.getPrimeExponentQ()
  • RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentQ()
  • RSAPrivateCrtKey.getPrimeExponentQ()
  • RSAPrivateCrtKeySpec.getPrimeExponentQ()


getPrimeP

getPrimeP o7planning.org
  • RSAMultiPrimePrivateCrtKey.getPrimeP()
  • RSAMultiPrimePrivateCrtKeySpec.getPrimeP()
  • RSAPrivateCrtKey.getPrimeP()
  • RSAPrivateCrtKeySpec.getPrimeP()


getPrimePLength

getPrimePLength o7planning.org
  • DSAGenParameterSpec.getPrimePLength()


getPrimeQ

getPrimeQ o7planning.org
  • RSAMultiPrimePrivateCrtKey.getPrimeQ()
  • RSAMultiPrimePrivateCrtKeySpec.getPrimeQ()
  • RSAPrivateCrtKey.getPrimeQ()
  • RSAPrivateCrtKeySpec.getPrimeQ()


getPrimeSize

getPrimeSize o7planning.org
  • DHGenParameterSpec.getPrimeSize()


getPrimitiveArrayType

getPrimitiveArrayType o7planning.org
  • ArrayType.getPrimitiveArrayType(Class<T>)


getPrimitiveType

getPrimitiveType o7planning.org
  • Types.getPrimitiveType(TypeKind)


getPrincipal

getPrincipal o7planning.org
  • AclEntry.getPrincipal()
  • Certificate.getPrincipal()
  • KerberosKey.getPrincipal()
  • KeyTab.getPrincipal()


getPrincipals

getPrincipals o7planning.org
  • PrivateCredentialPermission.getPrincipals()
  • ProtectionDomain.getPrincipals()
  • Subject.getPrincipals(Class<T>)
  • Subject.getPrincipals()


getPrintable

getPrintable o7planning.org
  • Book.getPrintable(int)
  • JTable.getPrintable(JTable.PrintMode, MessageFormat, MessageFormat)
  • JTextComponent.getPrintable(MessageFormat, MessageFormat)
  • Pageable.getPrintable(int)


getPrintableArea

getPrintableArea o7planning.org
  • MediaPrintableArea.getPrintableArea(int)


getPrintData

getPrintData o7planning.org
  • Doc.getPrintData()
  • SimpleDoc.getPrintData()


getPrinter

getPrinter o7planning.org
  • JobAttributes.getPrinter()


getPrinterJob

getPrinterJob o7planning.org
  • PrinterGraphics.getPrinterJob()
  • PrinterJob.getPrinterJob()


getPrinterResolution

getPrinterResolution o7planning.org
  • PageAttributes.getPrinterResolution()


getPrintEventType

getPrintEventType o7planning.org
  • PrintJobEvent.getPrintEventType()


getPrintJob

getPrintJob o7planning.org
  • PrintGraphics.getPrintJob()
  • PrintJobAttributeEvent.getPrintJob()
  • PrintJobEvent.getPrintJob()
  • Toolkit.getPrintJob(Frame, String, JobAttributes, PageAttributes)
  • Toolkit.getPrintJob(Frame, String, Properties)


getPrintQuality

getPrintQuality o7planning.org
  • PageAttributes.getPrintQuality()


getPrintService

getPrintService o7planning.org
  • DocPrintJob.getPrintService()
  • PrintServiceAttributeEvent.getPrintService()
  • PrinterJob.getPrintService()
  • StreamPrintServiceFactory.getPrintService(OutputStream)


getPrintServices

getPrintServices o7planning.org
  • PrintServiceLookup.getPrintServices()
  • PrintServiceLookup.getPrintServices(DocFlavor, AttributeSet)


getPriority

getPriority o7planning.org
  • Thread.getPriority()


getPrivacy

getPrivacy o7planning.org
  • MessageProp.getPrivacy()


getPrivate

getPrivate o7planning.org
  • KeyPair.getPrivate()


getPrivateCredentials

getPrivateCredentials o7planning.org
  • Subject.getPrivateCredentials(Class<T>)
  • Subject.getPrivateCredentials()


getPrivateExponent

getPrivateExponent o7planning.org
  • RSAPrivateKey.getPrivateExponent()
  • RSAPrivateKeySpec.getPrivateExponent()


getPrivateKey

getPrivateKey o7planning.org
  • KeyStore.PrivateKeyEntry.getPrivateKey()
  • Signer.getPrivateKey()
  • X500PrivateCredential.getPrivateKey()
  • X509KeyManager.getPrivateKey(String)


getPrivateKeyValid

getPrivateKeyValid o7planning.org
  • X509CertSelector.getPrivateKeyValid()


getProblemType

getProblemType o7planning.org
  • RoleUnresolved.getProblemType()


getProcedureColumns

getProcedureColumns o7planning.org
  • DatabaseMetaData.getProcedureColumns(String, String, String, String)


getProcedures

getProcedures o7planning.org
  • DatabaseMetaData.getProcedures(String, String, String)


getProcedureTerm

getProcedureTerm o7planning.org
  • DatabaseMetaData.getProcedureTerm()


getProcessedDTD

getProcessedDTD o7planning.org
  • DTD.getProcessedDTD()


getProfile

getProfile o7planning.org
  • ICC_ColorSpace.getProfile()


getProfileClass

getProfileClass o7planning.org
  • ICC_Profile.getProfileClass()


getProgram

getProgram o7planning.org
  • MidiChannel.getProgram()
  • Patch.getProgram()
  • ScriptEngineFactory.getProgram(String...)


getProgress

getProgress o7planning.org
  • SwingWorker.getProgress()


getProgressBarBorder

getProgressBarBorder o7planning.org
  • BasicBorders.getProgressBarBorder()


getProgressiveMode

getProgressiveMode o7planning.org
  • ImageWriteParam.getProgressiveMode()


getProgressMonitor

getProgressMonitor o7planning.org
  • ProgressMonitorInputStream.getProgressMonitor()


getPrompt

getPrompt o7planning.org
  • ChoiceCallback.getPrompt()
  • ConfirmationCallback.getPrompt()
  • NameCallback.getPrompt()
  • PasswordCallback.getPrompt()
  • TextInputCallback.getPrompt()


getPropagatedFrom

getPropagatedFrom o7planning.org
  • BeanContextEvent.getPropagatedFrom()


getPropagationId

getPropagationId o7planning.org
  • PropertyChangeEvent.getPropagationId()


getProperties

getProperties o7planning.org
  • Endpoint.getProperties()
  • SignatureProperties.getProperties()
  • System.getProperties()


getProperty

getProperty o7planning.org
  • AbstractDocument.getProperty(Object)
  • AbstractMarshallerImpl.getProperty(String)
  • AbstractUnmarshallerImpl.getProperty(String)
  • AudioFileFormat.getProperty(String)
  • AudioFormat.getProperty(String)
  • Binder.getProperty(String)
  • BufferedImage.getProperty(String)
  • BufferedImage.getProperty(String, ImageObserver)
  • ContextualRenderedImageFactory.getProperty(ParameterBlock, String)
  • DOMCryptoContext.getProperty(String)
  • Document.getProperty(Object)
  • EventReaderDelegate.getProperty(String)
  • Image.getProperty(String, ImageObserver)
  • LogManager.getProperty(String)
  • Marshaller.getProperty(String)
  • MidiFileFormat.getProperty(String)
  • ParserAdapter.getProperty(String)
  • Properties.getProperty(String, String)
  • Properties.getProperty(String)
  • Provider.getProperty(String)
  • RenderableImage.getProperty(String)
  • RenderableImageOp.getProperty(String)
  • RenderedImage.getProperty(String)
  • SAXParser.getProperty(String)
  • SOAPMessage.getProperty(String)
  • SchemaFactory.getProperty(String)
  • Security.getProperty(String)
  • StreamReaderDelegate.getProperty(String)
  • System.getProperty(String, String)
  • System.getProperty(String)
  • Toolkit.getProperty(String, String)
  • Unmarshaller.getProperty(String)
  • Validator.getProperty(String)
  • Validator.getProperty(String)
  • ValidatorHandler.getProperty(String)
  • XMLCryptoContext.getProperty(String)
  • XMLEventReader.getProperty(String)
  • XMLFilterImpl.getProperty(String)
  • XMLInputFactory.getProperty(String)
  • XMLOutputFactory.getProperty(String)
  • XMLReader.getProperty(String)
  • XMLStreamReader.getProperty(String)
  • XMLStreamWriter.getProperty(String)


getPropertyChangeEvent

getPropertyChangeEvent o7planning.org
  • PropertyVetoException.getPropertyChangeEvent()


getPropertyChangeListeners

getPropertyChangeListeners o7planning.org
  • AbstractAction.getPropertyChangeListeners()
  • BasicDirectoryModel.getPropertyChangeListeners()
  • Component.getPropertyChangeListeners(String)
  • Component.getPropertyChangeListeners()
  • DefaultTreeSelectionModel.getPropertyChangeListeners()
  • KeyboardFocusManager.getPropertyChangeListeners(String)
  • KeyboardFocusManager.getPropertyChangeListeners()
  • LayerUI.getPropertyChangeListeners(String)
  • LayerUI.getPropertyChangeListeners()
  • PropertyChangeSupport.getPropertyChangeListeners(String)
  • PropertyChangeSupport.getPropertyChangeListeners()
  • SystemTray.getPropertyChangeListeners(String)
  • TableColumn.getPropertyChangeListeners()
  • Toolkit.getPropertyChangeListeners(String)
  • Toolkit.getPropertyChangeListeners()
  • UIDefaults.getPropertyChangeListeners()
  • UIManager.getPropertyChangeListeners()


getPropertyChangeSupport

getPropertyChangeSupport o7planning.org
  • SwingWorker.getPropertyChangeSupport()


getPropertyDescriptors

getPropertyDescriptors o7planning.org
  • BeanInfo.getPropertyDescriptors()
  • SimpleBeanInfo.getPropertyDescriptors()


getPropertyEditorClass

getPropertyEditorClass o7planning.org
  • PropertyDescriptor.getPropertyEditorClass()


getPropertyInfo

getPropertyInfo o7planning.org
  • Driver.getPropertyInfo(String, Properties)


getPropertyName

getPropertyName o7planning.org
  • PropertyChangeEvent.getPropertyName()
  • PropertyChangeListenerProxy.getPropertyName()
  • VetoableChangeListenerProxy.getPropertyName()


getPropertyNames

getPropertyNames o7planning.org
  • BufferedImage.getPropertyNames()
  • ContextualRenderedImageFactory.getPropertyNames()
  • RenderableImage.getPropertyNames()
  • RenderableImageOp.getPropertyNames()
  • RenderedImage.getPropertyNames()


getPropertyOverrides

getPropertyOverrides o7planning.org
  • ActivationGroupDesc.getPropertyOverrides()


getPropertyPrefix

getPropertyPrefix o7planning.org
  • BasicButtonUI.getPropertyPrefix()
  • BasicCheckBoxMenuItemUI.getPropertyPrefix()
  • BasicCheckBoxUI.getPropertyPrefix()
  • BasicEditorPaneUI.getPropertyPrefix()
  • BasicFormattedTextFieldUI.getPropertyPrefix()
  • BasicMenuItemUI.getPropertyPrefix()
  • BasicMenuUI.getPropertyPrefix()
  • BasicPasswordFieldUI.getPropertyPrefix()
  • BasicRadioButtonMenuItemUI.getPropertyPrefix()
  • BasicRadioButtonUI.getPropertyPrefix()
  • BasicTextAreaUI.getPropertyPrefix()
  • BasicTextFieldUI.getPropertyPrefix()
  • BasicTextPaneUI.getPropertyPrefix()
  • BasicTextUI.getPropertyPrefix()
  • BasicToggleButtonUI.getPropertyPrefix()
  • MetalCheckBoxUI.getPropertyPrefix()
  • SynthCheckBoxMenuItemUI.getPropertyPrefix()
  • SynthCheckBoxUI.getPropertyPrefix()
  • SynthFormattedTextFieldUI.getPropertyPrefix()
  • SynthPasswordFieldUI.getPropertyPrefix()
  • SynthRadioButtonMenuItemUI.getPropertyPrefix()
  • SynthRadioButtonUI.getPropertyPrefix()
  • SynthTextPaneUI.getPropertyPrefix()
  • SynthToggleButtonUI.getPropertyPrefix()


getPropertyType

getPropertyType o7planning.org
  • PropertyDescriptor.getPropertyType()


getProtectionAlgorithm

getProtectionAlgorithm o7planning.org
  • KeyStore.PasswordProtection.getProtectionAlgorithm()


getProtectionDomain

getProtectionDomain o7planning.org
  • Class.getProtectionDomain()


getProtectionParameter

getProtectionParameter o7planning.org
  • DomainLoadStoreParameter.getProtectionParameter()
  • KeyStore.Builder.getProtectionParameter(String)
  • KeyStore.LoadStoreParameter.getProtectionParameter()


getProtectionParameters

getProtectionParameters o7planning.org
  • KeyStore.PasswordProtection.getProtectionParameters()


getProtectionParams

getProtectionParams o7planning.org
  • DomainLoadStoreParameter.getProtectionParams()


getProtocol

getProtocol o7planning.org
  • HttpExchange.getProtocol()
  • JMXServiceURL.getProtocol()
  • RMIIIOPServerImpl.getProtocol()
  • RMIJRMPServerImpl.getProtocol()
  • RMIServerImpl.getProtocol()
  • SSLContext.getProtocol()
  • SSLSession.getProtocol()
  • URL.getProtocol()


getProtocols

getProtocols o7planning.org
  • SSLParameters.getProtocols()


getPrototypeCellValue

getPrototypeCellValue o7planning.org
  • JList.getPrototypeCellValue()


getPrototypeDisplayValue

getPrototypeDisplayValue o7planning.org
  • JComboBox.getPrototypeDisplayValue()


getProvider

getProvider o7planning.org
  • AlgorithmParameterGenerator.getProvider()
  • AlgorithmParameters.getProvider()
  • CertPathBuilder.getProvider()
  • CertPathValidator.getProvider()
  • CertStore.getProvider()
  • CertificateFactory.getProvider()
  • Cipher.getProvider()
  • Configuration.getProvider()
  • ExemptionMechanism.getProvider()
  • KeyAgreement.getProvider()
  • KeyFactory.getProvider()
  • KeyGenerator.getProvider()
  • KeyInfoFactory.getProvider()
  • KeyManagerFactory.getProvider()
  • KeyPairGenerator.getProvider()
  • KeyStore.getProvider()
  • Mac.getProvider()
  • MessageDigest.getProvider()
  • Policy.getProvider()
  • Provider.Service.getProvider()
  • SSLContext.getProvider()
  • SecretKeyFactory.getProvider()
  • SecureRandom.getProvider()
  • Security.getProvider(String)
  • Signature.getProvider()
  • TransformService.getProvider()
  • TrustManagerFactory.getProvider()
  • XMLSignatureFactory.getProvider()


getProviderGrade

getProviderGrade o7planning.org
  • SyncProvider.getProviderGrade()


getProviderID

getProviderID o7planning.org
  • SyncProvider.getProviderID()


getProviders

getProviders o7planning.org
  • Security.getProviders(Map<String, String>)
  • Security.getProviders(String)
  • Security.getProviders()


getProxyClass

getProxyClass o7planning.org
  • Proxy.getProxyClass(ClassLoader, Class<?>...)


getPseudoColumns

getPseudoColumns o7planning.org
  • DatabaseMetaData.getPseudoColumns(String, String, String, String)


getPSName

getPSName o7planning.org
  • Font.getPSName()


getPSource

getPSource o7planning.org
  • OAEPParameterSpec.getPSource()


getPublic

getPublic o7planning.org
  • KeyPair.getPublic()


getPublicCredentials

getPublicCredentials o7planning.org
  • Subject.getPublicCredentials(Class<T>)
  • Subject.getPublicCredentials()


getPublicExponent

getPublicExponent o7planning.org
  • RSAKeyGenParameterSpec.getPublicExponent()
  • RSAMultiPrimePrivateCrtKey.getPublicExponent()
  • RSAMultiPrimePrivateCrtKeySpec.getPublicExponent()
  • RSAPrivateCrtKey.getPublicExponent()
  • RSAPrivateCrtKeySpec.getPublicExponent()
  • RSAPublicKey.getPublicExponent()
  • RSAPublicKeySpec.getPublicExponent()


getPublicId

getPublicId o7planning.org
  • DocumentType.getPublicId()
  • Entity.getPublicId()
  • EntityDeclaration.getPublicId()
  • InputSource.getPublicId()
  • LSInput.getPublicId()
  • Location.getPublicId()
  • Locator.getPublicId()
  • LocatorImpl.getPublicId()
  • Notation.getPublicId()
  • NotationDeclaration.getPublicId()
  • SAXParseException.getPublicId()
  • SourceLocator.getPublicId()
  • StreamSource.getPublicId()


getPublicKey

getPublicKey o7planning.org
  • Certificate.getPublicKey()
  • Certificate.getPublicKey()
  • Certificate.getPublicKey()
  • Identity.getPublicKey()
  • KeyValue.getPublicKey()
  • PKIXCertPathValidatorResult.getPublicKey()


getPurgeFlag

getPurgeFlag o7planning.org
  • RelationService.getPurgeFlag()
  • RelationServiceMBean.getPurgeFlag()


getPushLevel

getPushLevel o7planning.org
  • MemoryHandler.getPushLevel()


getQ

getQ o7planning.org
  • DSAParameterSpec.getQ()
  • DSAParams.getQ()
  • DSAPrivateKeySpec.getQ()
  • DSAPublicKeySpec.getQ()


getQName

getQName o7planning.org
  • Attributes.getQName(int)
  • AttributesImpl.getQName(int)


getQOP

getQOP o7planning.org
  • MessageProp.getQOP()


getQTables

getQTables o7planning.org
  • JPEGImageReadParam.getQTables()
  • JPEGImageWriteParam.getQTables()


getQuadrantRotateInstance

getQuadrantRotateInstance o7planning.org
  • AffineTransform.getQuadrantRotateInstance(int, double, double)
  • AffineTransform.getQuadrantRotateInstance(int)


getQualifiedName

getQualifiedName o7planning.org
  • Name.getQualifiedName()
  • PackageElement.getQualifiedName()
  • QualifiedNameable.getQualifiedName()
  • TypeElement.getQualifiedName()


getQuery

getQuery o7planning.org
  • URI.getQuery()
  • URL.getQuery()


getQueryString

getQueryString o7planning.org
  • HttpExchange.getQueryString()


getQueryTimeout

getQueryTimeout o7planning.org
  • BaseRowSet.getQueryTimeout()
  • RowSet.getQueryTimeout()
  • Statement.getQueryTimeout()


getQueue

getQueue o7planning.org
  • ScheduledThreadPoolExecutor.getQueue()
  • ThreadPoolExecutor.getQueue()


getQueuedReaderThreads

getQueuedReaderThreads o7planning.org
  • ReentrantReadWriteLock.getQueuedReaderThreads()


getQueuedSubmissionCount

getQueuedSubmissionCount o7planning.org
  • ForkJoinPool.getQueuedSubmissionCount()


getQueuedTaskCount

getQueuedTaskCount o7planning.org
  • ForkJoinPool.getQueuedTaskCount()
  • ForkJoinTask.getQueuedTaskCount()


getQueuedThreads

getQueuedThreads o7planning.org
  • AbstractQueuedLongSynchronizer.getQueuedThreads()
  • AbstractQueuedSynchronizer.getQueuedThreads()
  • ReentrantLock.getQueuedThreads()
  • ReentrantReadWriteLock.getQueuedThreads()
  • Semaphore.getQueuedThreads()


getQueuedWriterThreads

getQueuedWriterThreads o7planning.org
  • ReentrantReadWriteLock.getQueuedWriterThreads()


getQueueLength

getQueueLength o7planning.org
  • AbstractQueuedLongSynchronizer.getQueueLength()
  • AbstractQueuedSynchronizer.getQueueLength()
  • ReentrantLock.getQueueLength()
  • ReentrantReadWriteLock.getQueueLength()
  • Semaphore.getQueueLength()


getRadioButtonBorder

getRadioButtonBorder o7planning.org
  • BasicBorders.getRadioButtonBorder()


getRadioButtonIcon

getRadioButtonIcon o7planning.org
  • BasicIconFactory.getRadioButtonIcon()
  • MetalIconFactory.getRadioButtonIcon()


getRadioButtonMenuItemIcon

getRadioButtonMenuItemIcon o7planning.org
  • BasicIconFactory.getRadioButtonMenuItemIcon()
  • MetalIconFactory.getRadioButtonMenuItemIcon()


getRadius

getRadius o7planning.org
  • RadialGradientPaint.getRadius()


getRaisedBevelBorderUIResource

getRaisedBevelBorderUIResource o7planning.org
  • BorderUIResource.getRaisedBevelBorderUIResource()


getRange

getRange o7planning.org
  • Locale.LanguageRange.getRange()


getRanges

getRanges o7planning.org
  • NumericShaper.getRanges()


getRangeSet

getRangeSet o7planning.org
  • NumericShaper.getRangeSet()


getRangeUnit

getRangeUnit o7planning.org
  • ChronoField.getRangeUnit()
  • TemporalField.getRangeUnit()


getRaster

getRaster o7planning.org
  • BufferedImage.getRaster()
  • IIOImage.getRaster()
  • PaintContext.getRaster(int, int, int, int)


getRawAuthority

getRawAuthority o7planning.org
  • URI.getRawAuthority()


getRawContent

getRawContent o7planning.org
  • AttachmentPart.getRawContent()


getRawContentBytes

getRawContentBytes o7planning.org
  • AttachmentPart.getRawContentBytes()


getRawFragment

getRawFragment o7planning.org
  • URI.getRawFragment()


getRawImageType

getRawImageType o7planning.org
  • ImageReader.getRawImageType(int)


getRawOffset

getRawOffset o7planning.org
  • SimpleTimeZone.getRawOffset()
  • TimeZone.getRawOffset()


getRawPath

getRawPath o7planning.org
  • URI.getRawPath()


getRawQuery

getRawQuery o7planning.org
  • URI.getRawQuery()


getRawResult

getRawResult o7planning.org
  • CountedCompleter.getRawResult()
  • ForkJoinTask.getRawResult()
  • RecursiveAction.getRawResult()
  • RecursiveTask.getRawResult()


getRawSchemeSpecificPart

getRawSchemeSpecificPart o7planning.org
  • URI.getRawSchemeSpecificPart()


getRawType

getRawType o7planning.org
  • ParameterizedType.getRawType()


getRawUserInfo

getRawUserInfo o7planning.org
  • URI.getRawUserInfo()


getRdn

getRdn o7planning.org
  • LdapName.getRdn(int)


getRdns

getRdns o7planning.org
  • LdapName.getRdns()


getRead

getRead o7planning.org
  • DataTruncation.getRead()


getReader

getReader o7planning.org
  • HTMLDocument.getReader(int, int, int, HTML.Tag)
  • HTMLDocument.getReader(int)
  • ScriptContext.getReader()
  • SimpleScriptContext.getReader()
  • StreamSource.getReader()


getReaderFileSuffixes

getReaderFileSuffixes o7planning.org
  • ImageIO.getReaderFileSuffixes()


getReaderFormatNames

getReaderFormatNames o7planning.org
  • ImageIO.getReaderFormatNames()


getReaderForText

getReaderForText o7planning.org
  • DataFlavor.getReaderForText(Transferable)
  • Doc.getReaderForText()
  • SimpleDoc.getReaderForText()


getReaderMIMETypes

getReaderMIMETypes o7planning.org
  • ImageIO.getReaderMIMETypes()


getReaderServiceProviderName

getReaderServiceProviderName o7planning.org
  • ImageTranscoderSpi.getReaderServiceProviderName()


getReadHoldCount

getReadHoldCount o7planning.org
  • ReentrantReadWriteLock.getReadHoldCount()


getReadLockCount

getReadLockCount o7planning.org
  • ReentrantReadWriteLock.getReadLockCount()
  • StampedLock.getReadLockCount()


getReadMethod

getReadMethod o7planning.org
  • PropertyDescriptor.getReadMethod()


getReadTimeout

getReadTimeout o7planning.org
  • URLConnection.getReadTimeout()


getRealm

getRealm o7planning.org
  • KerberosPrincipal.getRealm()


getReason

getReason o7planning.org
  • CertPathValidatorException.getReason()
  • FileSystemException.getReason()
  • HttpRetryException.getReason()
  • InvalidPathException.getReason()
  • URIException.getReason()
  • URISyntaxException.getReason()


getReceiveBufferSize

getReceiveBufferSize o7planning.org
  • DatagramSocket.getReceiveBufferSize()
  • ServerSocket.getReceiveBufferSize()
  • Socket.getReceiveBufferSize()


getReceiver

getReceiver o7planning.org
  • MidiDevice.getReceiver()
  • MidiSystem.getReceiver()
  • Transmitter.getReceiver()


getReceivers

getReceivers o7planning.org
  • MidiDevice.getReceivers()


getReceiverType

getReceiverType o7planning.org
  • ExecutableElement.getReceiverType()
  • ExecutableType.getReceiverType()


getRecursionLimit

getRecursionLimit o7planning.org
  • FlatteningPathIterator.getRecursionLimit()


getRed

getRed o7planning.org
  • Color.getRed()
  • ColorModel.getRed(Object)
  • ColorModel.getRed(int)
  • ComponentColorModel.getRed(Object)
  • ComponentColorModel.getRed(int)
  • DirectColorModel.getRed(Object)
  • DirectColorModel.getRed(int)
  • IndexColorModel.getRed(int)


getRedMask

getRedMask o7planning.org
  • DirectColorModel.getRedMask()


getRedoPresentationName

getRedoPresentationName o7planning.org
  • AbstractDocument.DefaultDocumentEvent.getRedoPresentationName()
  • AbstractUndoableEdit.getRedoPresentationName()
  • CompoundEdit.getRedoPresentationName()
  • UndoManager.getRedoPresentationName()
  • UndoableEdit.getRedoPresentationName()


getReds

getReds o7planning.org
  • IndexColorModel.getReds(byte[])


getReductionPolynomial

getReductionPolynomial o7planning.org
  • ECFieldF2m.getReductionPolynomial()


getRef

getRef o7planning.org
  • CallableStatement.getRef(String)
  • CallableStatement.getRef(int)
  • RemoteObject.getRef()
  • ResultSet.getRef(String)
  • ResultSet.getRef(int)
  • URL.getRef()


getRefClass

getRefClass o7planning.org
  • RemoteRef.getRefClass(ObjectOutput)


getReference

getReference o7planning.org
  • AtomicMarkableReference.getReference()
  • AtomicStampedReference.getReference()
  • Referenceable.getReference()


getReferencedMBeans

getReferencedMBeans o7planning.org
  • Relation.getReferencedMBeans()
  • RelationService.getReferencedMBeans(String)
  • RelationServiceMBean.getReferencedMBeans(String)
  • RelationSupport.getReferencedMBeans()


getReferenceKind

getReferenceKind o7planning.org
  • MethodHandleInfo.getReferenceKind()


getReferences

getReferences o7planning.org
  • Manifest.getReferences()
  • SignedInfo.getReferences()


getReferralContext

getReferralContext o7planning.org
  • LdapReferralException.getReferralContext(Hashtable<?, ?>, Control[])
  • LdapReferralException.getReferralContext(Hashtable<?, ?>)
  • LdapReferralException.getReferralContext()
  • ReferralException.getReferralContext(Hashtable<?, ?>)
  • ReferralException.getReferralContext()


getReferralInfo

getReferralInfo o7planning.org
  • ReferralException.getReferralInfo()


getReferrals

getReferrals o7planning.org
  • UnsolicitedNotification.getReferrals()


getRefMBeanClassName

getRefMBeanClassName o7planning.org
  • RoleInfo.getRefMBeanClassName()


getRefreshRate

getRefreshRate o7planning.org
  • DisplayMode.getRefreshRate()


getRegion

getRegion o7planning.org
  • SynthContext.getRegion()
  • SynthLookAndFeel.getRegion(JComponent)


getRegisteredKeyStrokes

getRegisteredKeyStrokes o7planning.org
  • JComponent.getRegisteredKeyStrokes()


getRegisteredParties

getRegisteredParties o7planning.org
  • Phaser.getRegisteredParties()


getRegisteredProviders

getRegisteredProviders o7planning.org
  • SyncFactory.getRegisteredProviders()


getRegistry

getRegistry o7planning.org
  • LocateRegistry.getRegistry(String, int, RMIClientSocketFactory)
  • LocateRegistry.getRegistry(String, int)
  • LocateRegistry.getRegistry(String)
  • LocateRegistry.getRegistry(int)
  • LocateRegistry.getRegistry()


getRejectedExecutionHandler

getRejectedExecutionHandler o7planning.org
  • ThreadPoolExecutor.getRejectedExecutionHandler()


getRelatedData

getRelatedData o7planning.org
  • DOMError.getRelatedData()


getRelatedException

getRelatedException o7planning.org
  • DOMError.getRelatedException()


getRelatedNode

getRelatedNode o7planning.org
  • DOMLocator.getRelatedNode()
  • MutationEvent.getRelatedNode()


getRelatedTarget

getRelatedTarget o7planning.org
  • MouseEvent.getRelatedTarget()


getRelationId

getRelationId o7planning.org
  • Relation.getRelationId()
  • RelationNotification.getRelationId()
  • RelationSupport.getRelationId()


getRelationServiceName

getRelationServiceName o7planning.org
  • Relation.getRelationServiceName()
  • RelationSupport.getRelationServiceName()


getRelationTypeName

getRelationTypeName o7planning.org
  • Relation.getRelationTypeName()
  • RelationNotification.getRelationTypeName()
  • RelationService.getRelationTypeName(String)
  • RelationServiceMBean.getRelationTypeName(String)
  • RelationSupport.getRelationTypeName()
  • RelationType.getRelationTypeName()
  • RelationTypeSupport.getRelationTypeName()


getRelay

getRelay o7planning.org
  • SOAPHeaderElement.getRelay()


getRemaining

getRemaining o7planning.org
  • Inflater.getRemaining()


getRemainingAcceptLifetime

getRemainingAcceptLifetime o7planning.org
  • GSSCredential.getRemainingAcceptLifetime(Oid)


getRemainingInitLifetime

getRemainingInitLifetime o7planning.org
  • GSSCredential.getRemainingInitLifetime(Oid)


getRemainingLifetime

getRemainingLifetime o7planning.org
  • GSSCredential.getRemainingLifetime()


getRemainingName

getRemainingName o7planning.org
  • NamingException.getRemainingName()
  • ResolveResult.getRemainingName()


getRemainingNewName

getRemainingNewName o7planning.org
  • CannotProceedException.getRemainingNewName()


getRemoteAddress

getRemoteAddress o7planning.org
  • AsynchronousSocketChannel.getRemoteAddress()
  • DatagramChannel.getRemoteAddress()
  • HttpExchange.getRemoteAddress()
  • SocketChannel.getRemoteAddress()


getRemoteSocketAddress

getRemoteSocketAddress o7planning.org
  • DatagramSocket.getRemoteSocketAddress()
  • Socket.getRemoteSocketAddress()


getRemoveListenerMethod

getRemoveListenerMethod o7planning.org
  • EventSetDescriptor.getRemoveListenerMethod()


getRemoveOnCancelPolicy

getRemoveOnCancelPolicy o7planning.org
  • ScheduledThreadPoolExecutor.getRemoveOnCancelPolicy()


getRenderableSource

getRenderableSource o7planning.org
  • ParameterBlock.getRenderableSource(int)


getRenderedImage

getRenderedImage o7planning.org
  • IIOImage.getRenderedImage()


getRenderedSource

getRenderedSource o7planning.org
  • ParameterBlock.getRenderedSource(int)


getRenderer

getRenderer o7planning.org
  • JComboBox.getRenderer()


getRenderingHint

getRenderingHint o7planning.org
  • Graphics2D.getRenderingHint(RenderingHints.Key)


getRenderingHints

getRenderingHints o7planning.org
  • AffineTransformOp.getRenderingHints()
  • BandCombineOp.getRenderingHints()
  • BufferedImageOp.getRenderingHints()
  • ColorConvertOp.getRenderingHints()
  • ConvolveOp.getRenderingHints()
  • Graphics2D.getRenderingHints()
  • LookupOp.getRenderingHints()
  • RasterOp.getRenderingHints()
  • RenderContext.getRenderingHints()
  • RescaleOp.getRenderingHints()


getRenewTill

getRenewTill o7planning.org
  • KerberosTicket.getRenewTill()


getReorderingAllowed

getReorderingAllowed o7planning.org
  • JTableHeader.getReorderingAllowed()


getReplacementText

getReplacementText o7planning.org
  • EntityDeclaration.getReplacementText()


getReplayDetState

getReplayDetState o7planning.org
  • GSSContext.getReplayDetState()


getRepresentationClass

getRepresentationClass o7planning.org
  • ActivationDataFlavor.getRepresentationClass()
  • DataFlavor.getRepresentationClass()


getRepresentationClassName

getRepresentationClassName o7planning.org
  • DocFlavor.getRepresentationClassName()


getRequestBody

getRequestBody o7planning.org
  • HttpExchange.getRequestBody()


getRequestContext

getRequestContext o7planning.org
  • BindingProvider.getRequestContext()


getRequestControls

getRequestControls o7planning.org
  • InitialLdapContext.getRequestControls()
  • LdapContext.getRequestControls()


getRequestedServerNames

getRequestedServerNames o7planning.org
  • ExtendedSSLSession.getRequestedServerNames()


getRequestHeader

getRequestHeader o7planning.org
  • HttpExchange.getRequestHeader(String)


getRequestHeaders

getRequestHeaders o7planning.org
  • HttpExchange.getRequestHeaders()


getRequestingHost

getRequestingHost o7planning.org
  • Authenticator.getRequestingHost()


getRequestingPort

getRequestingPort o7planning.org
  • Authenticator.getRequestingPort()


getRequestingPrompt

getRequestingPrompt o7planning.org
  • Authenticator.getRequestingPrompt()


getRequestingProtocol

getRequestingProtocol o7planning.org
  • Authenticator.getRequestingProtocol()


getRequestingScheme

getRequestingScheme o7planning.org
  • Authenticator.getRequestingScheme()


getRequestingSite

getRequestingSite o7planning.org
  • Authenticator.getRequestingSite()


getRequestingURL

getRequestingURL o7planning.org
  • Authenticator.getRequestingURL()


getRequestMethod

getRequestMethod o7planning.org
  • HttpExchange.getRequestMethod()
  • HttpURLConnection.getRequestMethod()


getRequestorType

getRequestorType o7planning.org
  • Authenticator.getRequestorType()


getRequestProperties

getRequestProperties o7planning.org
  • URLConnection.getRequestProperties()


getRequestProperty

getRequestProperty o7planning.org
  • URLConnection.getRequestProperty(String)


getRequestURI

getRequestURI o7planning.org
  • HttpExchange.getRequestURI()


getReshowDelay

getReshowDelay o7planning.org
  • ToolTipManager.getReshowDelay()


getResizable

getResizable o7planning.org
  • TableColumn.getResizable()


getResizeWeight

getResizeWeight o7planning.org
  • BlockView.getResizeWeight(int)
  • BoxView.getResizeWeight(int)
  • FieldView.getResizeWeight(int)
  • JSplitPane.getResizeWeight()
  • TableView.TableRow.getResizeWeight(int)
  • View.getResizeWeight(int)


getResizingAllowed

getResizingAllowed o7planning.org
  • JTableHeader.getResizingAllowed()


getResizingColumn

getResizingColumn o7planning.org
  • JTableHeader.getResizingColumn()


getResolution

getResolution o7planning.org
  • MidiFileFormat.getResolution()
  • ResolutionSyntax.getResolution(int)
  • Sequence.getResolution()


getResolvedName

getResolvedName o7planning.org
  • NamingException.getResolvedName()


getResolvedObj

getResolvedObj o7planning.org
  • NamingException.getResolvedObj()
  • ResolveResult.getResolvedObj()


getResolveParent

getResolveParent o7planning.org
  • AbstractDocument.AbstractElement.getResolveParent()
  • AttributeSet.getResolveParent()
  • HTMLDocument.BlockElement.getResolveParent()
  • HTMLDocument.RunElement.getResolveParent()
  • Keymap.getResolveParent()
  • SimpleAttributeSet.getResolveParent()
  • StyleContext.NamedStyle.getResolveParent()
  • StyleContext.SmallAttributeSet.getResolveParent()


getResolverFields

getResolverFields o7planning.org
  • DateTimeFormatter.getResolverFields()


getResolverStyle

getResolverStyle o7planning.org
  • DateTimeFormatter.getResolverStyle()


getResource

getResource o7planning.org
  • BeanContext.getResource(String, BeanContextChild)
  • BeanContextSupport.getResource(String, BeanContextChild)
  • Class.getResource(String)
  • ClassLoader.getResource(String)
  • Filer.getResource(JavaFileManager.Location, CharSequence, CharSequence)
  • MLetMBean.getResource(String)


getResourceAsStream

getResourceAsStream o7planning.org
  • BeanContext.getResourceAsStream(String, BeanContextChild)
  • BeanContextSupport.getResourceAsStream(String, BeanContextChild)
  • Class.getResourceAsStream(String)
  • ClassLoader.getResourceAsStream(String)
  • MLetMBean.getResourceAsStream(String)
  • URLClassLoader.getResourceAsStream(String)


getResourceBaseName

getResourceBaseName o7planning.org
  • IIOMetadataFormatImpl.getResourceBaseName()


getResourceBundle

getResourceBundle o7planning.org
  • LogRecord.getResourceBundle()
  • Logger.getResourceBundle()


getResourceBundleName

getResourceBundleName o7planning.org
  • Level.getResourceBundleName()
  • LogRecord.getResourceBundleName()
  • Logger.getResourceBundleName()


getResourceResolver

getResourceResolver o7planning.org
  • SchemaFactory.getResourceResolver()
  • Validator.getResourceResolver()
  • ValidatorHandler.getResourceResolver()


getResources

getResources o7planning.org
  • ClassLoader.getResources(String)
  • MLetMBean.getResources(String)
  • Soundbank.getResources()


getResponseBody

getResponseBody o7planning.org
  • HttpExchange.getResponseBody()


getResponseCode

getResponseCode o7planning.org
  • HttpURLConnection.getResponseCode()


getResponseContext

getResponseContext o7planning.org
  • BindingProvider.getResponseContext()


getResponseControls

getResponseControls o7planning.org
  • InitialLdapContext.getResponseControls()
  • LdapContext.getResponseControls()


getResponseHeaders

getResponseHeaders o7planning.org
  • HttpExchange.getResponseHeaders()


getResponseMessage

getResponseMessage o7planning.org
  • HttpURLConnection.getResponseMessage()


getResponses

getResponses o7planning.org
  • AddressingFeature.getResponses()


getRestartMode

getRestartMode o7planning.org
  • ActivationDesc.getRestartMode()


getResult

getResult o7planning.org
  • JAXBResult.getResult()
  • SAAJResult.getResult()
  • UnmarshallerHandler.getResult()


getResultCode

getResultCode o7planning.org
  • SortResponseControl.getResultCode()


getResultSet

getResultSet o7planning.org
  • Array.getResultSet(long, int, Map<String, Class<?>>)
  • Array.getResultSet(long, int)
  • Array.getResultSet(Map<String, Class<?>>)
  • Array.getResultSet()
  • SerialArray.getResultSet(long, int, Map<String, Class<?>>)
  • SerialArray.getResultSet()
  • SerialArray.getResultSet(Map<String, Class<?>>)
  • SerialArray.getResultSet(long, int)
  • Statement.getResultSet()


getResultSetConcurrency

getResultSetConcurrency o7planning.org
  • Statement.getResultSetConcurrency()


getResultSetHoldability

getResultSetHoldability o7planning.org
  • DatabaseMetaData.getResultSetHoldability()
  • Statement.getResultSetHoldability()


getResultSetType

getResultSetType o7planning.org
  • Statement.getResultSetType()


getResultSize

getResultSize o7planning.org
  • PagedResultsResponseControl.getResultSize()


getResultStream

getResultStream o7planning.org
  • RemoteCall.getResultStream(boolean)


getReturningAttributes

getReturningAttributes o7planning.org
  • SearchControls.getReturningAttributes()


getReturningObjFlag

getReturningObjFlag o7planning.org
  • SearchControls.getReturningObjFlag()


getReturnOpenType

getReturnOpenType o7planning.org
  • OpenMBeanOperationInfo.getReturnOpenType()
  • OpenMBeanOperationInfoSupport.getReturnOpenType()


getReturnType

getReturnType o7planning.org
  • ExecutableElement.getReturnType()
  • ExecutableType.getReturnType()
  • MBeanOperationInfo.getReturnType()
  • Method.getReturnType()
  • OpenMBeanOperationInfo.getReturnType()


getReuseAddress

getReuseAddress o7planning.org
  • DatagramSocket.getReuseAddress()
  • ServerSocket.getReuseAddress()
  • Socket.getReuseAddress()


getRevocationChecker

getRevocationChecker o7planning.org
  • CertPathBuilder.getRevocationChecker()
  • CertPathValidator.getRevocationChecker()


getRevocationDate

getRevocationDate o7planning.org
  • CertificateRevokedException.getRevocationDate()
  • X509CRLEntry.getRevocationDate()


getRevocationReason

getRevocationReason o7planning.org
  • CertificateRevokedException.getRevocationReason()
  • X509CRLEntry.getRevocationReason()


getRevokedCertificate

getRevokedCertificate o7planning.org
  • X509CRL.getRevokedCertificate(X509Certificate)
  • X509CRL.getRevokedCertificate(BigInteger)


getRevokedCertificates

getRevokedCertificates o7planning.org
  • X509CRL.getRevokedCertificates()


getRGB

getRGB o7planning.org
  • BufferedImage.getRGB(int, int, int, int, int[], int, int)
  • BufferedImage.getRGB(int, int)
  • Color.getRGB()
  • ColorModel.getRGB(Object)
  • ColorModel.getRGB(int)
  • ComponentColorModel.getRGB(Object)
  • ComponentColorModel.getRGB(int)
  • DirectColorModel.getRGB(Object)
  • DirectColorModel.getRGB(int)
  • IndexColorModel.getRGB(int)


getRGBColorComponents

getRGBColorComponents o7planning.org
  • Color.getRGBColorComponents(float[])


getRGBComponents

getRGBComponents o7planning.org
  • Color.getRGBComponents(float[])


getRGBdefault

getRGBdefault o7planning.org
  • ColorModel.getRGBdefault()


getRGBs

getRGBs o7planning.org
  • IndexColorModel.getRGBs(int[])


getRightChildIndent

getRightChildIndent o7planning.org
  • BasicTreeUI.getRightChildIndent()


getRightComponent

getRightComponent o7planning.org
  • JSplitPane.getRightComponent()


getRightIndent

getRightIndent o7planning.org
  • StyleConstants.getRightIndent(AttributeSet)


getRightInset

getRightInset o7planning.org
  • AsyncBoxView.getRightInset()
  • CompositeView.getRightInset()


getRMIRepositoryID

getRMIRepositoryID o7planning.org
  • ValueHandler.getRMIRepositoryID(Class)


getRole

getRole o7planning.org
  • Relation.getRole(String)
  • RelationService.getRole(String, String)
  • RelationServiceMBean.getRole(String, String)
  • RelationSupport.getRole(String)
  • SOAPHeaderElement.getRole()


getRoleCardinality

getRoleCardinality o7planning.org
  • Relation.getRoleCardinality(String)
  • RelationService.getRoleCardinality(String, String)
  • RelationServiceMBean.getRoleCardinality(String, String)
  • RelationSupport.getRoleCardinality(String)


getRoleInfo

getRoleInfo o7planning.org
  • RelationService.getRoleInfo(String, String)
  • RelationServiceMBean.getRoleInfo(String, String)
  • RelationType.getRoleInfo(String)
  • RelationTypeSupport.getRoleInfo(String)


getRoleInfos

getRoleInfos o7planning.org
  • RelationService.getRoleInfos(String)
  • RelationServiceMBean.getRoleInfos(String)
  • RelationType.getRoleInfos()
  • RelationTypeSupport.getRoleInfos()


getRoleName

getRoleName o7planning.org
  • RelationNotification.getRoleName()
  • Role.getRoleName()
  • RoleUnresolved.getRoleName()


getRoles

getRoles o7planning.org
  • Relation.getRoles(String[])
  • RelationService.getRoles(String, String[])
  • RelationServiceMBean.getRoles(String, String[])
  • RelationSupport.getRoles(String[])
  • RoleResult.getRoles()
  • SOAPBinding.getRoles()
  • SOAPMessageContext.getRoles()


getRolesUnresolved

getRolesUnresolved o7planning.org
  • RoleResult.getRolesUnresolved()


getRoleValue

getRoleValue o7planning.org
  • Role.getRoleValue()
  • RoleUnresolved.getRoleValue()


getRolloverBorder

getRolloverBorder o7planning.org
  • BasicToolBarUI.getRolloverBorder(AbstractButton)


getRolloverColumn

getRolloverColumn o7planning.org
  • BasicTableHeaderUI.getRolloverColumn()


getRolloverIcon

getRolloverIcon o7planning.org
  • AbstractButton.getRolloverIcon()


getRolloverSelectedIcon

getRolloverSelectedIcon o7planning.org
  • AbstractButton.getRolloverSelectedIcon()


getRolloverTab

getRolloverTab o7planning.org
  • BasicTabbedPaneUI.getRolloverTab()


getRoot

getRoot o7planning.org
  • CountedCompleter.getRoot()
  • DefaultMutableTreeNode.getRoot()
  • DefaultTreeModel.getRoot()
  • Path.getRoot()
  • Phaser.getRoot()
  • SwingUtilities.getRoot(Component)
  • TreeModel.getRoot()


getRootCause

getRootCause o7planning.org
  • NamingException.getRootCause()


getRootDirectories

getRootDirectories o7planning.org
  • FileSystem.getRootDirectories()


getRootElement

getRootElement o7planning.org
  • DefaultStyledDocument.ElementBuffer.getRootElement()


getRootElements

getRootElements o7planning.org
  • AbstractDocument.getRootElements()
  • Document.getRootElements()
  • RoundEnvironment.getRootElements()


getRootFrame

getRootFrame o7planning.org
  • JOptionPane.getRootFrame()


getRootName

getRootName o7planning.org
  • IIOMetadataFormat.getRootName()
  • IIOMetadataFormatImpl.getRootName()


getRootPane

getRootPane o7planning.org
  • JApplet.getRootPane()
  • JComponent.getRootPane()
  • JDialog.getRootPane()
  • JFrame.getRootPane()
  • JInternalFrame.getRootPane()
  • JWindow.getRootPane()
  • RootPaneContainer.getRootPane()
  • SwingUtilities.getRootPane(Component)


getRoots

getRoots o7planning.org
  • FileSystemView.getRoots()


getRootView

getRootView o7planning.org
  • BasicTextUI.getRootView(JTextComponent)
  • MultiTextUI.getRootView(JTextComponent)
  • TextUI.getRootView(JTextComponent)


getRotateInstance

getRotateInstance o7planning.org
  • AffineTransform.getRotateInstance(double, double, double, double)
  • AffineTransform.getRotateInstance(double, double)
  • AffineTransform.getRotateInstance(double, double, double)
  • AffineTransform.getRotateInstance(double)


getRoundedCorners

getRoundedCorners o7planning.org
  • LineBorder.getRoundedCorners()


getRoundingMode

getRoundingMode o7planning.org
  • DecimalFormat.getRoundingMode()
  • MathContext.getRoundingMode()
  • NumberFormat.getRoundingMode()


getRounds

getRounds o7planning.org
  • RC5ParameterSpec.getRounds()


getRow

getRow o7planning.org
  • JTable.DropLocation.getRow()
  • ResultSet.getRow()


getRowBounds

getRowBounds o7planning.org
  • JTree.getRowBounds(int)


getRowCount

getRowCount o7planning.org
  • AbstractLayoutCache.getRowCount()
  • BasicTreeUI.getRowCount(JTree)
  • DefaultRowSorter.ModelWrapper.getRowCount()
  • DefaultTableModel.getRowCount()
  • FixedHeightLayoutCache.getRowCount()
  • JTable.getRowCount()
  • JTree.getRowCount()
  • MultiTreeUI.getRowCount(JTree)
  • TableModel.getRowCount()
  • TableView.TableCell.getRowCount()
  • TreeUI.getRowCount(JTree)
  • VariableHeightLayoutCache.getRowCount()


getRowEnd

getRowEnd o7planning.org
  • Utilities.getRowEnd(JTextComponent, int)


getRowFilter

getRowFilter o7planning.org
  • DefaultRowSorter.getRowFilter()


getRowForLocation

getRowForLocation o7planning.org
  • JTree.getRowForLocation(int, int)


getRowForPath

getRowForPath o7planning.org
  • AbstractLayoutCache.getRowForPath(TreePath)
  • BasicTreeUI.getRowForPath(JTree, TreePath)
  • FixedHeightLayoutCache.getRowForPath(TreePath)
  • JTree.getRowForPath(TreePath)
  • MultiTreeUI.getRowForPath(JTree, TreePath)
  • TreeUI.getRowForPath(JTree, TreePath)
  • VariableHeightLayoutCache.getRowForPath(TreePath)


getRowHeader

getRowHeader o7planning.org
  • JScrollPane.getRowHeader()
  • ScrollPaneLayout.getRowHeader()


getRowHeight

getRowHeight o7planning.org
  • AbstractLayoutCache.getRowHeight()
  • BasicListUI.getRowHeight(int)
  • BasicTreeUI.getRowHeight()
  • JTable.getRowHeight(int)
  • JTable.getRowHeight()
  • JTextArea.getRowHeight()
  • JTree.getRowHeight()


getRowId

getRowId o7planning.org
  • CallableStatement.getRowId(String)
  • CallableStatement.getRowId(int)
  • ResultSet.getRowId(String)
  • ResultSet.getRowId(int)


getRowIdLifetime

getRowIdLifetime o7planning.org
  • DatabaseMetaData.getRowIdLifetime()


getRowMapper

getRowMapper o7planning.org
  • DefaultTreeSelectionModel.getRowMapper()
  • TreeSelectionModel.getRowMapper()


getRowMargin

getRowMargin o7planning.org
  • JTable.getRowMargin()


getRows

getRows o7planning.org
  • GridLayout.getRows()
  • JTextArea.getRows()
  • List.getRows()
  • TextArea.getRows()


getRowSelectionAllowed

getRowSelectionAllowed o7planning.org
  • JTable.getRowSelectionAllowed()


getRowSetNames

getRowSetNames o7planning.org
  • JoinRowSet.getRowSetNames()


getRowSetReader

getRowSetReader o7planning.org
  • SyncProvider.getRowSetReader()


getRowSets

getRowSets o7planning.org
  • JoinRowSet.getRowSets()


getRowSetWarnings

getRowSetWarnings o7planning.org
  • CachedRowSet.getRowSetWarnings()
  • JdbcRowSet.getRowSetWarnings()


getRowSetWriter

getRowSetWriter o7planning.org
  • SyncProvider.getRowSetWriter()


getRowsForPaths

getRowsForPaths o7planning.org
  • AbstractLayoutCache.getRowsForPaths(TreePath[])
  • RowMapper.getRowsForPaths(TreePath[])


getRowSorter

getRowSorter o7planning.org
  • JTable.getRowSorter()


getRowStart

getRowStart o7planning.org
  • Utilities.getRowStart(JTextComponent, int)


getRowType

getRowType o7planning.org
  • TabularType.getRowType()


getRowX

getRowX o7planning.org
  • BasicTreeUI.getRowX(int, int)
  • BasicTreeUI.NodeDimensionsHandler.getRowX(int, int)
  • SynthTreeUI.getRowX(int, int)


getRSB

getRSB o7planning.org
  • GlyphMetrics.getRSB()


getRule

getRule o7planning.org
  • AlphaComposite.getRule()
  • StyleSheet.getRule(String)
  • StyleSheet.getRule(HTML.Tag, Element)


getRules

getRules o7planning.org
  • RuleBasedCollator.getRules()
  • ZoneId.getRules()
  • ZoneOffset.getRules()
  • ZoneRulesProvider.getRules(String, boolean)


getRunCount

getRunCount o7planning.org
  • Bidi.getRunCount()


getRunForTab

getRunForTab o7planning.org
  • BasicTabbedPaneUI.getRunForTab(int, int)


getRunLevel

getRunLevel o7planning.org
  • Bidi.getRunLevel(int)


getRunLimit

getRunLimit o7planning.org
  • AttributedCharacterIterator.getRunLimit(Set<? extends AttributedCharacterIterator.Attribute>)
  • AttributedCharacterIterator.getRunLimit(AttributedCharacterIterator.Attribute)
  • AttributedCharacterIterator.getRunLimit()
  • Bidi.getRunLimit(int)


getRunningThreadCount

getRunningThreadCount o7planning.org
  • ForkJoinPool.getRunningThreadCount()


getRunStart

getRunStart o7planning.org
  • AttributedCharacterIterator.getRunStart(Set<? extends AttributedCharacterIterator.Attribute>)
  • AttributedCharacterIterator.getRunStart(AttributedCharacterIterator.Attribute)
  • AttributedCharacterIterator.getRunStart()
  • Bidi.getRunStart(int)


getRuntime

getRuntime o7planning.org
  • Runtime.getRuntime()


getRunTimeCodeBase

getRunTimeCodeBase o7planning.org
  • ValueHandler.getRunTimeCodeBase()


getRuntimeMXBean

getRuntimeMXBean o7planning.org
  • ManagementFactory.getRuntimeMXBean()


getS

getS o7planning.org
  • ECPrivateKey.getS()
  • ECPrivateKeySpec.getS()


getSalt

getSalt o7planning.org
  • PBEKey.getSalt()
  • PBEKeySpec.getSalt()
  • PBEParameterSpec.getSalt()


getSaltLength

getSaltLength o7planning.org
  • PSSParameterSpec.getSaltLength()


getSample

getSample o7planning.org
  • BandedSampleModel.getSample(int, int, int, DataBuffer)
  • ComponentSampleModel.getSample(int, int, int, DataBuffer)
  • MultiPixelPackedSampleModel.getSample(int, int, int, DataBuffer)
  • Raster.getSample(int, int, int)
  • SampleModel.getSample(int, int, int, DataBuffer)
  • SinglePixelPackedSampleModel.getSample(int, int, int, DataBuffer)


getSampleDouble

getSampleDouble o7planning.org
  • BandedSampleModel.getSampleDouble(int, int, int, DataBuffer)
  • ComponentSampleModel.getSampleDouble(int, int, int, DataBuffer)
  • Raster.getSampleDouble(int, int, int)
  • SampleModel.getSampleDouble(int, int, int, DataBuffer)


getSampleFloat

getSampleFloat o7planning.org
  • BandedSampleModel.getSampleFloat(int, int, int, DataBuffer)
  • ComponentSampleModel.getSampleFloat(int, int, int, DataBuffer)
  • Raster.getSampleFloat(int, int, int)
  • SampleModel.getSampleFloat(int, int, int, DataBuffer)


getSampleModel

getSampleModel o7planning.org
  • BufferedImage.getSampleModel()
  • ImageTypeSpecifier.getSampleModel(int, int)
  • ImageTypeSpecifier.getSampleModel()
  • Raster.getSampleModel()
  • RenderedImage.getSampleModel()


getSampleModelTranslateX

getSampleModelTranslateX o7planning.org
  • Raster.getSampleModelTranslateX()


getSampleModelTranslateY

getSampleModelTranslateY o7planning.org
  • Raster.getSampleModelTranslateY()


getSampleRate

getSampleRate o7planning.org
  • AudioFormat.getSampleRate()


getSamples

getSamples o7planning.org
  • BandedSampleModel.getSamples(int, int, int, int, int, int[], DataBuffer)
  • ComponentSampleModel.getSamples(int, int, int, int, int, int[], DataBuffer)
  • Raster.getSamples(int, int, int, int, int, double[])
  • Raster.getSamples(int, int, int, int, int, float[])
  • Raster.getSamples(int, int, int, int, int, int[])
  • SampleModel.getSamples(int, int, int, int, int, double[], DataBuffer)
  • SampleModel.getSamples(int, int, int, int, int, float[], DataBuffer)
  • SampleModel.getSamples(int, int, int, int, int, int[], DataBuffer)
  • SinglePixelPackedSampleModel.getSamples(int, int, int, int, int, int[], DataBuffer)


getSampleSize

getSampleSize o7planning.org
  • ComponentSampleModel.getSampleSize(int)
  • ComponentSampleModel.getSampleSize()
  • MultiPixelPackedSampleModel.getSampleSize(int)
  • MultiPixelPackedSampleModel.getSampleSize()
  • SampleModel.getSampleSize(int)
  • SampleModel.getSampleSize()
  • SinglePixelPackedSampleModel.getSampleSize(int)
  • SinglePixelPackedSampleModel.getSampleSize()


getSampleSizeInBits

getSampleSizeInBits o7planning.org
  • AudioFormat.getSampleSizeInBits()


getSaslClientFactories

getSaslClientFactories o7planning.org
  • Sasl.getSaslClientFactories()


getSaslServerFactories

getSaslServerFactories o7planning.org
  • Sasl.getSaslServerFactories()


getSavepointId

getSavepointId o7planning.org
  • Savepoint.getSavepointId()


getSavepointName

getSavepointName o7planning.org
  • Savepoint.getSavepointName()


getScale

getScale o7planning.org
  • ParameterMetaData.getScale(int)
  • ResultSetMetaData.getScale(int)
  • RowSetMetaDataImpl.getScale(int)


getScaledInstance

getScaledInstance o7planning.org
  • Image.getScaledInstance(int, int, int)
  • JPEGQTable.getScaledInstance(float, boolean)


getScaleFactors

getScaleFactors o7planning.org
  • RescaleOp.getScaleFactors(float[])


getScaleInstance

getScaleInstance o7planning.org
  • AffineTransform.getScaleInstance(double, double)


getScaleX

getScaleX o7planning.org
  • AffineTransform.getScaleX()


getScaleY

getScaleY o7planning.org
  • AffineTransform.getScaleY()


getScanlineStride

getScanlineStride o7planning.org
  • ComponentSampleModel.getScanlineStride()
  • MultiPixelPackedSampleModel.getScanlineStride()
  • SinglePixelPackedSampleModel.getScanlineStride()


getSchema

getSchema o7planning.org
  • AbstractMarshallerImpl.getSchema()
  • AbstractUnmarshallerImpl.getSchema()
  • Binder.getSchema()
  • Connection.getSchema()
  • DirContext.getSchema(String)
  • DirContext.getSchema(Name)
  • DocumentBuilder.getSchema()
  • DocumentBuilderFactory.getSchema()
  • InitialDirContext.getSchema(Name)
  • InitialDirContext.getSchema(String)
  • Marshaller.getSchema()
  • SAXParser.getSchema()
  • SAXParserFactory.getSchema()
  • Unmarshaller.getSchema()


getSchemaClassDefinition

getSchemaClassDefinition o7planning.org
  • DirContext.getSchemaClassDefinition(String)
  • DirContext.getSchemaClassDefinition(Name)
  • InitialDirContext.getSchemaClassDefinition(Name)
  • InitialDirContext.getSchemaClassDefinition(String)


getSchemaLocation

getSchemaLocation o7planning.org
  • AbstractMarshallerImpl.getSchemaLocation()


getSchemaName

getSchemaName o7planning.org
  • ResultSetMetaData.getSchemaName(int)
  • RowSetMetaDataImpl.getSchemaName(int)


getSchemas

getSchemas o7planning.org
  • DatabaseMetaData.getSchemas(String, String)
  • DatabaseMetaData.getSchemas()


getSchemaTerm

getSchemaTerm o7planning.org
  • DatabaseMetaData.getSchemaTerm()


getSchemaType

getSchemaType o7planning.org
  • XMLEvent.getSchemaType()


getSchemaTypeInfo

getSchemaTypeInfo o7planning.org
  • Attr.getSchemaTypeInfo()
  • Element.getSchemaTypeInfo()
  • IIOMetadataNode.getSchemaTypeInfo()


getScheme

getScheme o7planning.org
  • FileSystemProvider.getScheme()
  • HttpExchange.getScheme()
  • URI.getScheme()


getSchemeSpecificPart

getSchemeSpecificPart o7planning.org
  • URI.getSchemeSpecificPart()


getScope

getScope o7planning.org
  • Identity.getScope()
  • JAXBElement.getScope()
  • MessageContext.getScope(String)


getScopedInterface

getScopedInterface o7planning.org
  • Inet6Address.getScopedInterface()


getScopeId

getScopeId o7planning.org
  • Inet6Address.getScopeId()


getScopes

getScopes o7planning.org
  • ScriptContext.getScopes()
  • SimpleScriptContext.getScopes()


getScreenDevices

getScreenDevices o7planning.org
  • GraphicsEnvironment.getScreenDevices()


getScreenInsets

getScreenInsets o7planning.org
  • Toolkit.getScreenInsets(GraphicsConfiguration)


getScreenResolution

getScreenResolution o7planning.org
  • Toolkit.getScreenResolution()


getScreenSize

getScreenSize o7planning.org
  • Toolkit.getScreenSize()


getScreenX

getScreenX o7planning.org
  • MouseEvent.getScreenX()


getScreenY

getScreenY o7planning.org
  • MouseEvent.getScreenY()


getScript

getScript o7planning.org
  • Locale.getScript()


getScriptContext

getScriptContext o7planning.org
  • AbstractScriptEngine.getScriptContext(Bindings)


getScriptEngine

getScriptEngine o7planning.org
  • ScriptEngineFactory.getScriptEngine()


getScrollableBlockIncrement

getScrollableBlockIncrement o7planning.org
  • JLayer.getScrollableBlockIncrement(Rectangle, int, int)
  • JList.getScrollableBlockIncrement(Rectangle, int, int)
  • JTable.getScrollableBlockIncrement(Rectangle, int, int)
  • JTextComponent.getScrollableBlockIncrement(Rectangle, int, int)
  • JTree.getScrollableBlockIncrement(Rectangle, int, int)
  • Scrollable.getScrollableBlockIncrement(Rectangle, int, int)


getScrollableTracksViewportHeight

getScrollableTracksViewportHeight o7planning.org
  • JEditorPane.getScrollableTracksViewportHeight()
  • JLayer.getScrollableTracksViewportHeight()
  • JList.getScrollableTracksViewportHeight()
  • JTable.getScrollableTracksViewportHeight()
  • JTextComponent.getScrollableTracksViewportHeight()
  • JTree.getScrollableTracksViewportHeight()
  • Scrollable.getScrollableTracksViewportHeight()


getScrollableTracksViewportWidth

getScrollableTracksViewportWidth o7planning.org
  • JEditorPane.getScrollableTracksViewportWidth()
  • JLayer.getScrollableTracksViewportWidth()
  • JList.getScrollableTracksViewportWidth()
  • JTable.getScrollableTracksViewportWidth()
  • JTextArea.getScrollableTracksViewportWidth()
  • JTextComponent.getScrollableTracksViewportWidth()
  • JTree.getScrollableTracksViewportWidth()
  • Scrollable.getScrollableTracksViewportWidth()


getScrollableUnitIncrement

getScrollableUnitIncrement o7planning.org
  • JLayer.getScrollableUnitIncrement(Rectangle, int, int)
  • JList.getScrollableUnitIncrement(Rectangle, int, int)
  • JTable.getScrollableUnitIncrement(Rectangle, int, int)
  • JTextArea.getScrollableUnitIncrement(Rectangle, int, int)
  • JTextComponent.getScrollableUnitIncrement(Rectangle, int, int)
  • JTree.getScrollableUnitIncrement(Rectangle, int, int)
  • Scrollable.getScrollableUnitIncrement(Rectangle, int, int)


getScrollAmount

getScrollAmount o7planning.org
  • MouseWheelEvent.getScrollAmount()


getScrollbarDisplayPolicy

getScrollbarDisplayPolicy o7planning.org
  • ScrollPane.getScrollbarDisplayPolicy()


getScrollbarVisibility

getScrollbarVisibility o7planning.org
  • TextArea.getScrollbarVisibility()


getScrollMode

getScrollMode o7planning.org
  • JViewport.getScrollMode()


getScrollOffset

getScrollOffset o7planning.org
  • JTextField.getScrollOffset()


getScrollPane

getScrollPane o7planning.org
  • BasicTreeUI.ComponentHandler.getScrollPane()


getScrollPosition

getScrollPosition o7planning.org
  • ScrollPane.getScrollPosition()


getScrollsOnExpand

getScrollsOnExpand o7planning.org
  • JTree.getScrollsOnExpand()


getScrollType

getScrollType o7planning.org
  • MouseWheelEvent.getScrollType()


getSearchScope

getSearchScope o7planning.org
  • SearchControls.getSearchScope()


getSearchStringEscape

getSearchStringEscape o7planning.org
  • DatabaseMetaData.getSearchStringEscape()


getSecond

getSecond o7planning.org
  • LocalDateTime.getSecond()
  • LocalTime.getSecond()
  • OffsetDateTime.getSecond()
  • OffsetTime.getSecond()
  • XMLGregorianCalendar.getSecond()
  • ZonedDateTime.getSecond()


getSecondary1

getSecondary1 o7planning.org
  • DefaultMetalTheme.getSecondary1()
  • MetalTheme.getSecondary1()
  • OceanTheme.getSecondary1()


getSecondary2

getSecondary2 o7planning.org
  • DefaultMetalTheme.getSecondary2()
  • MetalTheme.getSecondary2()
  • OceanTheme.getSecondary2()


getSecondary3

getSecondary3 o7planning.org
  • DefaultMetalTheme.getSecondary3()
  • MetalTheme.getSecondary3()
  • OceanTheme.getSecondary3()


getSeconds

getSeconds o7planning.org
  • Date.getSeconds()
  • Date.getSeconds()
  • Duration.getSeconds()
  • Duration.getSeconds()


getSecretKey

getSecretKey o7planning.org
  • KeyStore.SecretKeyEntry.getSecretKey()


getSecure

getSecure o7planning.org
  • HttpCookie.getSecure()


getSecurityContext

getSecurityContext o7planning.org
  • LoaderHandler.getSecurityContext(ClassLoader)
  • RMIClassLoader.getSecurityContext(ClassLoader)
  • SecurityManager.getSecurityContext()


getSecurityManager

getSecurityManager o7planning.org
  • System.getSecurityManager()


getSeed

getSeed o7planning.org
  • EllipticCurve.getSeed()
  • SecureRandom.getSeed(int)


getSeedLength

getSeedLength o7planning.org
  • DSAGenParameterSpec.getSeedLength()


getSelectColor

getSelectColor o7planning.org
  • MetalButtonUI.getSelectColor()
  • MetalRadioButtonUI.getSelectColor()
  • MetalToggleButtonUI.getSelectColor()


getSelectedAccessibleColumns

getSelectedAccessibleColumns o7planning.org
  • AccessibleTable.getSelectedAccessibleColumns()
  • JTable.AccessibleJTable.getSelectedAccessibleColumns()


getSelectedAccessibleRows

getSelectedAccessibleRows o7planning.org
  • AccessibleTable.getSelectedAccessibleRows()
  • JTable.AccessibleJTable.getSelectedAccessibleRows()


getSelectedCheckbox

getSelectedCheckbox o7planning.org
  • CheckboxGroup.getSelectedCheckbox()


getSelectedColor

getSelectedColor o7planning.org
  • ColorSelectionModel.getSelectedColor()
  • DefaultColorSelectionModel.getSelectedColor()


getSelectedColumn

getSelectedColumn o7planning.org
  • JTable.getSelectedColumn()


getSelectedColumnCount

getSelectedColumnCount o7planning.org
  • DefaultTableColumnModel.getSelectedColumnCount()
  • JTable.getSelectedColumnCount()
  • TableColumnModel.getSelectedColumnCount()


getSelectedColumns

getSelectedColumns o7planning.org
  • DefaultTableColumnModel.getSelectedColumns()
  • JTable.getSelectedColumns()
  • TableColumnModel.getSelectedColumns()


getSelectedComponent

getSelectedComponent o7planning.org
  • JTabbedPane.getSelectedComponent()


getSelectedFile

getSelectedFile o7planning.org
  • JFileChooser.getSelectedFile()


getSelectedFiles

getSelectedFiles o7planning.org
  • JFileChooser.getSelectedFiles()


getSelectedFrame

getSelectedFrame o7planning.org
  • JDesktopPane.getSelectedFrame()


getSelectedIcon

getSelectedIcon o7planning.org
  • AbstractButton.getSelectedIcon()


getSelectedIndex

getSelectedIndex o7planning.org
  • Choice.getSelectedIndex()
  • ConfirmationCallback.getSelectedIndex()
  • DefaultSingleSelectionModel.getSelectedIndex()
  • JComboBox.getSelectedIndex()
  • JList.getSelectedIndex()
  • JTabbedPane.getSelectedIndex()
  • List.getSelectedIndex()
  • SingleSelectionModel.getSelectedIndex()


getSelectedIndexes

getSelectedIndexes o7planning.org
  • ChoiceCallback.getSelectedIndexes()
  • List.getSelectedIndexes()


getSelectedIndices

getSelectedIndices o7planning.org
  • JList.getSelectedIndices()


getSelectedItem

getSelectedItem o7planning.org
  • Choice.getSelectedItem()
  • ComboBoxModel.getSelectedItem()
  • DefaultComboBoxModel.getSelectedItem()
  • JComboBox.getSelectedItem()
  • List.getSelectedItem()
  • MetalFileChooserUI.DirectoryComboBoxModel.getSelectedItem()
  • MetalFileChooserUI.FilterComboBoxModel.getSelectedItem()


getSelectedItems

getSelectedItems o7planning.org
  • List.getSelectedItems()


getSelectedObjects

getSelectedObjects o7planning.org
  • AbstractButton.getSelectedObjects()
  • Checkbox.getSelectedObjects()
  • CheckboxMenuItem.getSelectedObjects()
  • Choice.getSelectedObjects()
  • DefaultButtonModel.getSelectedObjects()
  • ItemSelectable.getSelectedObjects()
  • JCheckBoxMenuItem.getSelectedObjects()
  • JComboBox.getSelectedObjects()
  • List.getSelectedObjects()


getSelectedPath

getSelectedPath o7planning.org
  • MenuSelectionManager.getSelectedPath()


getSelectedRow

getSelectedRow o7planning.org
  • JTable.getSelectedRow()


getSelectedRowCount

getSelectedRowCount o7planning.org
  • JTable.getSelectedRowCount()


getSelectedRows

getSelectedRows o7planning.org
  • JTable.getSelectedRows()


getSelectedTabPadInsets

getSelectedTabPadInsets o7planning.org
  • BasicTabbedPaneUI.getSelectedTabPadInsets(int)


getSelectedText

getSelectedText o7planning.org
  • AbstractButton.AccessibleAbstractButton.getSelectedText()
  • AccessibleText.getSelectedText()
  • InputMethodRequests.getSelectedText(AttributedCharacterIterator.Attribute[])
  • JLabel.AccessibleJLabel.getSelectedText()
  • JSpinner.AccessibleJSpinner.getSelectedText()
  • JTextComponent.getSelectedText()
  • JTextComponent.AccessibleJTextComponent.getSelectedText()
  • ProgressMonitor.AccessibleProgressMonitor.getSelectedText()
  • TextComponent.getSelectedText()
  • TextComponent.AccessibleAWTTextComponent.getSelectedText()


getSelectedTextColor

getSelectedTextColor o7planning.org
  • JTextComponent.getSelectedTextColor()


getSelectedValue

getSelectedValue o7planning.org
  • JList.getSelectedValue()


getSelectedValues

getSelectedValues o7planning.org
  • JList.getSelectedValues()


getSelectedValuesList

getSelectedValuesList o7planning.org
  • JList.getSelectedValuesList()


getSelection

getSelection o7planning.org
  • ButtonGroup.getSelection()


getSelectionBackground

getSelectionBackground o7planning.org
  • BasicProgressBarUI.getSelectionBackground()
  • JList.getSelectionBackground()
  • JTable.getSelectionBackground()


getSelectionColor

getSelectionColor o7planning.org
  • JTextComponent.getSelectionColor()


getSelectionCount

getSelectionCount o7planning.org
  • DefaultTreeSelectionModel.getSelectionCount()
  • JTree.getSelectionCount()
  • TreeSelectionModel.getSelectionCount()


getSelectionEnd

getSelectionEnd o7planning.org
  • AbstractButton.AccessibleAbstractButton.getSelectionEnd()
  • AccessibleText.getSelectionEnd()
  • JLabel.AccessibleJLabel.getSelectionEnd()
  • JSpinner.AccessibleJSpinner.getSelectionEnd()
  • JTextComponent.getSelectionEnd()
  • JTextComponent.AccessibleJTextComponent.getSelectionEnd()
  • ProgressMonitor.AccessibleProgressMonitor.getSelectionEnd()
  • TextComponent.getSelectionEnd()
  • TextComponent.AccessibleAWTTextComponent.getSelectionEnd()


getSelectionForeground

getSelectionForeground o7planning.org
  • BasicProgressBarUI.getSelectionForeground()
  • JList.getSelectionForeground()
  • JTable.getSelectionForeground()


getSelectionMode

getSelectionMode o7planning.org
  • DefaultListSelectionModel.getSelectionMode()
  • DefaultTreeSelectionModel.getSelectionMode()
  • JList.getSelectionMode()
  • ListSelectionModel.getSelectionMode()
  • TreeSelectionModel.getSelectionMode()


getSelectionModel

getSelectionModel o7planning.org
  • AbstractLayoutCache.getSelectionModel()
  • BasicTreeUI.getSelectionModel()
  • DefaultTableColumnModel.getSelectionModel()
  • JColorChooser.getSelectionModel()
  • JList.getSelectionModel()
  • JMenuBar.getSelectionModel()
  • JPopupMenu.getSelectionModel()
  • JTable.getSelectionModel()
  • JTree.getSelectionModel()
  • TableColumnModel.getSelectionModel()


getSelectionPainter

getSelectionPainter o7planning.org
  • DefaultCaret.getSelectionPainter()


getSelectionPath

getSelectionPath o7planning.org
  • DefaultTreeSelectionModel.getSelectionPath()
  • JTree.getSelectionPath()
  • TreeSelectionModel.getSelectionPath()


getSelectionPaths

getSelectionPaths o7planning.org
  • DefaultTreeSelectionModel.getSelectionPaths()
  • JTree.getSelectionPaths()
  • TreeSelectionModel.getSelectionPaths()


getSelectionRows

getSelectionRows o7planning.org
  • DefaultTreeSelectionModel.getSelectionRows()
  • JTree.getSelectionRows()
  • TreeSelectionModel.getSelectionRows()


getSelectionStart

getSelectionStart o7planning.org
  • AbstractButton.AccessibleAbstractButton.getSelectionStart()
  • AccessibleText.getSelectionStart()
  • JLabel.AccessibleJLabel.getSelectionStart()
  • JSpinner.AccessibleJSpinner.getSelectionStart()
  • JTextComponent.getSelectionStart()
  • JTextComponent.AccessibleJTextComponent.getSelectionStart()
  • ProgressMonitor.AccessibleProgressMonitor.getSelectionStart()
  • TextComponent.getSelectionStart()
  • TextComponent.AccessibleAWTTextComponent.getSelectionStart()


getSelectionValues

getSelectionValues o7planning.org
  • JOptionPane.getSelectionValues()


getSendBufferSize

getSendBufferSize o7planning.org
  • DatagramSocket.getSendBufferSize()
  • Socket.getSendBufferSize()


getSendPastNotifications

getSendPastNotifications o7planning.org
  • Timer.getSendPastNotifications()
  • TimerMBean.getSendPastNotifications()


getSentenceInstance

getSentenceInstance o7planning.org
  • BreakIterator.getSentenceInstance(Locale)
  • BreakIterator.getSentenceInstance()
  • BreakIteratorProvider.getSentenceInstance(Locale)


getSeparator

getSeparator o7planning.org
  • FileSystem.getSeparator()


getSeparatorBackground

getSeparatorBackground o7planning.org
  • MetalLookAndFeel.getSeparatorBackground()
  • MetalTheme.getSeparatorBackground()


getSeparatorForeground

getSeparatorForeground o7planning.org
  • MetalLookAndFeel.getSeparatorForeground()
  • MetalTheme.getSeparatorForeground()


getSeparatorSize

getSeparatorSize o7planning.org
  • JToolBar.Separator.getSeparatorSize()


getSequence

getSequence o7planning.org
  • MidiFileReader.getSequence(File)
  • MidiFileReader.getSequence(URL)
  • MidiFileReader.getSequence(InputStream)
  • MidiSystem.getSequence(File)
  • MidiSystem.getSequence(URL)
  • MidiSystem.getSequence(InputStream)
  • Sequencer.getSequence()


getSequenceDetState

getSequenceDetState o7planning.org
  • GSSContext.getSequenceDetState()


getSequenceNumber

getSequenceNumber o7planning.org
  • LogRecord.getSequenceNumber()
  • Notification.getSequenceNumber()


getSequencer

getSequencer o7planning.org
  • MidiSystem.getSequencer(boolean)
  • MidiSystem.getSequencer()


getSerializedObject

getSerializedObject o7planning.org
  • MLetContent.getSerializedObject()


getSerialNumber

getSerialNumber o7planning.org
  • X509CRLEntry.getSerialNumber()
  • X509CertSelector.getSerialNumber()
  • X509Certificate.getSerialNumber()
  • X509Certificate.getSerialNumber()
  • X509IssuerSerial.getSerialNumber()


getSerialVersionUID

getSerialVersionUID o7planning.org
  • ObjectStreamClass.getSerialVersionUID()


getServer

getServer o7planning.org
  • KerberosTicket.getServer()


getServerAliases

getServerAliases o7planning.org
  • X509KeyManager.getServerAliases(String, Principal[])


getServerCertificateChain

getServerCertificateChain o7planning.org
  • SecureCacheResponse.getServerCertificateChain()


getServerCertificates

getServerCertificates o7planning.org
  • HttpsURLConnection.getServerCertificates()


getServerName

getServerName o7planning.org
  • LDAPCertStoreParameters.getServerName()


getServerNames

getServerNames o7planning.org
  • SSLParameters.getServerNames()


getServerSessionContext

getServerSessionContext o7planning.org
  • SSLContext.getServerSessionContext()


getServerSocketFactory

getServerSocketFactory o7planning.org
  • SSLContext.getServerSocketFactory()


getService

getService o7planning.org
  • BeanContextServiceProvider.getService(BeanContextServices, Object, Class, Object)
  • BeanContextServices.getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener)
  • BeanContextServicesSupport.getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener)
  • BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices, Object, Class, Object)
  • Provider.getService(String, String)


getServiceClass

getServiceClass o7planning.org
  • BeanContextServiceAvailableEvent.getServiceClass()
  • BeanContextServiceRevokedEvent.getServiceClass()


getServiceName

getServiceName o7planning.org
  • PortInfo.getServiceName()
  • Service.getServiceName()
  • ServiceDelegate.getServiceName()


getServiceProvider

getServiceProvider o7planning.org
  • BeanContextServicesSupport.BCSSServiceProvider.getServiceProvider()


getServiceProviderByClass

getServiceProviderByClass o7planning.org
  • ServiceRegistry.getServiceProviderByClass(Class<T>)


getServiceProviders

getServiceProviders o7planning.org
  • ServiceRegistry.getServiceProviders(Class<T>, ServiceRegistry.Filter, boolean)
  • ServiceRegistry.getServiceProviders(Class<T>, boolean)


getServices

getServices o7planning.org
  • Provider.getServices()


getServicesBeanInfo

getServicesBeanInfo o7planning.org
  • BeanContextServiceProviderBeanInfo.getServicesBeanInfo()


getServiceUIFactory

getServiceUIFactory o7planning.org
  • PrintService.getServiceUIFactory()


getSession

getSession o7planning.org
  • HandshakeCompletedEvent.getSession()
  • SSLEngine.getSession()
  • SSLSessionBindingEvent.getSession()
  • SSLSessionContext.getSession(byte[])
  • SSLSocket.getSession()


getSessionCacheSize

getSessionCacheSize o7planning.org
  • SSLSessionContext.getSessionCacheSize()


getSessionContext

getSessionContext o7planning.org
  • SSLSession.getSessionContext()


getSessionKey

getSessionKey o7planning.org
  • KerberosTicket.getSessionKey()


getSessionKeyType

getSessionKeyType o7planning.org
  • KerberosTicket.getSessionKeyType()


getSessionTimeout

getSessionTimeout o7planning.org
  • SSLSessionContext.getSessionTimeout()


getSeverity

getSeverity o7planning.org
  • DOMError.getSeverity()
  • ValidationEvent.getSeverity()
  • ValidationEventImpl.getSeverity()


getShadowColor

getShadowColor o7planning.org
  • BasicSliderUI.getShadowColor()
  • EtchedBorder.getShadowColor()
  • EtchedBorder.getShadowColor(Component)


getShadowInnerColor

getShadowInnerColor o7planning.org
  • BevelBorder.getShadowInnerColor()
  • BevelBorder.getShadowInnerColor(Component)


getShadowOuterColor

getShadowOuterColor o7planning.org
  • BevelBorder.getShadowOuterColor()
  • BevelBorder.getShadowOuterColor(Component)


getShape

getShape o7planning.org
  • Window.getShape()


getShaper

getShaper o7planning.org
  • NumericShaper.getShaper(NumericShaper.Range)
  • NumericShaper.getShaper(int)


getSharedAncestor

getSharedAncestor o7planning.org
  • DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode)


getSharedInstance

getSharedInstance o7planning.org
  • PopupFactory.getSharedInstance()


getSharedQueuedThreads

getSharedQueuedThreads o7planning.org
  • AbstractQueuedLongSynchronizer.getSharedQueuedThreads()
  • AbstractQueuedSynchronizer.getSharedQueuedThreads()


getShearInstance

getShearInstance o7planning.org
  • AffineTransform.getShearInstance(double, double)


getShearX

getShearX o7planning.org
  • AffineTransform.getShearX()


getShearY

getShearY o7planning.org
  • AffineTransform.getShearY()


getShift

getShift o7planning.org
  • MetalIconFactory.FileIcon16.getShift()
  • MetalIconFactory.FolderIcon16.getShift()
  • MetalIconFactory.TreeFolderIcon.getShift()
  • MetalIconFactory.TreeLeafIcon.getShift()


getShiftKey

getShiftKey o7planning.org
  • MouseEvent.getShiftKey()


getShort

getShort o7planning.org
  • Array.getShort(Object, int)
  • ByteBuffer.getShort(int)
  • ByteBuffer.getShort()
  • CallableStatement.getShort(String)
  • CallableStatement.getShort(int)
  • Field.getShort(Object)
  • ResultSet.getShort(String)
  • ResultSet.getShort(int)


getShortcut

getShortcut o7planning.org
  • MenuItem.getShortcut()


getShortcutMenuItem

getShortcutMenuItem o7planning.org
  • MenuBar.getShortcutMenuItem(MenuShortcut)


getShortDescription

getShortDescription o7planning.org
  • FeatureDescriptor.getShortDescription()


getShortMonths

getShortMonths o7planning.org
  • DateFormatSymbols.getShortMonths()


getShortParameter

getShortParameter o7planning.org
  • ParameterBlock.getShortParameter(int)


getShortWeekdays

getShortWeekdays o7planning.org
  • DateFormatSymbols.getShortWeekdays()


getShowDeleted

getShowDeleted o7planning.org
  • BaseRowSet.getShowDeleted()
  • CachedRowSet.getShowDeleted()
  • JdbcRowSet.getShowDeleted()


getShowHorizontalLines

getShowHorizontalLines o7planning.org
  • JTable.getShowHorizontalLines()


getShowsRootHandles

getShowsRootHandles o7planning.org
  • BasicTreeUI.getShowsRootHandles()
  • JTree.getShowsRootHandles()


getShowVerticalLines

getShowVerticalLines o7planning.org
  • JTable.getShowVerticalLines()


getSiblingCount

getSiblingCount o7planning.org
  • DefaultMutableTreeNode.getSiblingCount()


getSides

getSides o7planning.org
  • JobAttributes.getSides()


getSigAlgName

getSigAlgName o7planning.org
  • X509CRL.getSigAlgName()
  • X509Certificate.getSigAlgName()
  • X509Certificate.getSigAlgName()


getSigAlgOID

getSigAlgOID o7planning.org
  • X509CRL.getSigAlgOID()
  • X509Certificate.getSigAlgOID()
  • X509Certificate.getSigAlgOID()


getSigAlgParams

getSigAlgParams o7planning.org
  • X509CRL.getSigAlgParams()
  • X509Certificate.getSigAlgParams()
  • X509Certificate.getSigAlgParams()


getSign

getSign o7planning.org
  • Duration.getSign()


getSignature

getSignature o7planning.org
  • MBeanConstructorInfo.getSignature()
  • MBeanOperationInfo.getSignature()
  • OpenMBeanConstructorInfo.getSignature()
  • OpenMBeanOperationInfo.getSignature()
  • SignedObject.getSignature()
  • X509CRL.getSignature()
  • X509Certificate.getSignature()


getSignatureMethod

getSignatureMethod o7planning.org
  • SignedInfo.getSignatureMethod()


getSignatureValue

getSignatureValue o7planning.org
  • XMLSignature.getSignatureValue()


getSignedInfo

getSignedInfo o7planning.org
  • XMLSignature.getSignedInfo()


getSignerCertPath

getSignerCertPath o7planning.org
  • CodeSigner.getSignerCertPath()
  • Timestamp.getSignerCertPath()


getSigners

getSigners o7planning.org
  • Class.getSigners()


getSigProvider

getSigProvider o7planning.org
  • PKIXParameters.getSigProvider()


getSimpleName

getSimpleName o7planning.org
  • Class.getSimpleName()
  • Element.getSimpleName()
  • ExecutableElement.getSimpleName()
  • PackageElement.getSimpleName()
  • TypeElement.getSimpleName()
  • VariableElement.getSimpleName()


getSize2D

getSize2D o7planning.org
  • Font.getSize2D()


getSize

getSize o7planning.org
  • AccessibleComponent.getSize()
  • AttachmentPart.getSize()
  • BasicDirectoryModel.getSize()
  • Component.getSize(Dimension)
  • Component.getSize()
  • Component.AccessibleAWTComponent.getSize()
  • DataBuffer.getSize()
  • DefaultComboBoxModel.getSize()
  • DefaultListModel.getSize()
  • Dimension.getSize()
  • Font.getSize()
  • JComponent.getSize(Dimension)
  • JList.AccessibleJList.AccessibleJListChild.getSize()
  • JTable.AccessibleJTable.AccessibleJTableCell.getSize()
  • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getSize()
  • JTree.AccessibleJTree.AccessibleJTreeNode.getSize()
  • List.AccessibleAWTList.AccessibleAWTListChild.getSize()
  • ListModel.getSize()
  • MenuComponent.AccessibleAWTMenuComponent.getSize()
  • MetalFileChooserUI.DirectoryComboBoxModel.getSize()
  • MetalFileChooserUI.FilterComboBoxModel.getSize()
  • Rectangle.getSize()
  • Size2DSyntax.getSize(int)
  • SizeSequence.getSize(int)
  • SplashScreen.getSize()
  • TrayIcon.getSize()
  • ZipEntry.getSize()


getSizeButtonsToSameWidth

getSizeButtonsToSameWidth o7planning.org
  • BasicOptionPaneUI.getSizeButtonsToSameWidth()
  • SynthOptionPaneUI.getSizeButtonsToSameWidth()


getSizeForComponent

getSizeForComponent o7planning.org
  • BasicComboBoxUI.getSizeForComponent(Component)


getSizeOfComponent

getSizeOfComponent o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getSizeOfComponent(Component)


getSizes

getSizes o7planning.org
  • BasicSplitPaneUI.BasicHorizontalLayoutManager.getSizes()
  • SizeSequence.getSizes()


getSizingIcon

getSizingIcon o7planning.org
  • SynthButtonUI.getSizingIcon(AbstractButton)
  • SynthRadioButtonUI.getSizingIcon(AbstractButton)


getSlaveSyncMode

getSlaveSyncMode o7planning.org
  • Sequencer.getSlaveSyncMode()


getSlaveSyncModes

getSlaveSyncModes o7planning.org
  • Sequencer.getSlaveSyncModes()


getSmallDisplayIcon

getSmallDisplayIcon o7planning.org
  • AbstractColorChooserPanel.getSmallDisplayIcon()


getSmallestMaximum

getSmallestMaximum o7planning.org
  • ValueRange.getSmallestMaximum()


getSnapshot

getSnapshot o7planning.org
  • VolatileImage.getSnapshot()


getSnapToTicks

getSnapToTicks o7planning.org
  • JSlider.getSnapToTicks()


getSNIMatchers

getSNIMatchers o7planning.org
  • SSLParameters.getSNIMatchers()


getSOAPBody

getSOAPBody o7planning.org
  • SOAPMessage.getSOAPBody()


getSOAPFactory

getSOAPFactory o7planning.org
  • SOAPBinding.getSOAPFactory()


getSOAPHeader

getSOAPHeader o7planning.org
  • SOAPMessage.getSOAPHeader()


getSOAPPart

getSOAPPart o7planning.org
  • SOAPMessage.getSOAPPart()


getSocket

getSocket o7planning.org
  • HandshakeCompletedEvent.getSocket()


getSocketAddress

getSocketAddress o7planning.org
  • DatagramPacket.getSocketAddress()


getSocketFactory

getSocketFactory o7planning.org
  • RMISocketFactory.getSocketFactory()
  • SSLContext.getSocketFactory()


getSoftFailExceptions

getSoftFailExceptions o7planning.org
  • PKIXRevocationChecker.getSoftFailExceptions()


getSoLinger

getSoLinger o7planning.org
  • Socket.getSoLinger()


getSolo

getSolo o7planning.org
  • MidiChannel.getSolo()


getSortKeys

getSortKeys o7planning.org
  • DefaultRowSorter.getSortKeys()
  • RowSorter.getSortKeys()


getSortOrder

getSortOrder o7planning.org
  • RowSorter.SortKey.getSortOrder()


getSortsOnUpdates

getSortsOnUpdates o7planning.org
  • DefaultRowSorter.getSortsOnUpdates()


getSoTimeout

getSoTimeout o7planning.org
  • DatagramSocket.getSoTimeout()
  • ServerSocket.getSoTimeout()
  • Socket.getSoTimeout()


getSoundbank

getSoundbank o7planning.org
  • MidiSystem.getSoundbank(File)
  • MidiSystem.getSoundbank(URL)
  • MidiSystem.getSoundbank(InputStream)
  • SoundbankReader.getSoundbank(File)
  • SoundbankReader.getSoundbank(InputStream)
  • SoundbankReader.getSoundbank(URL)
  • SoundbankResource.getSoundbank()


getSource

getSource o7planning.org
  • BufferedImage.getSource()
  • Diagnostic.getSource()
  • EventObject.getSource()
  • Image.getSource()
  • ParameterBlock.getSource(int)
  • PropertyEditorSupport.getSource()
  • RowSorterEvent.getSource()
  • SQLXML.getSource(Class<T>)
  • VolatileImage.getSource()


getSourceActions

getSourceActions o7planning.org
  • DragGestureRecognizer.getSourceActions()
  • DragSourceContext.getSourceActions()
  • DropTargetDragEvent.getSourceActions()
  • DropTargetDropEvent.getSourceActions()
  • TransferHandler.getSourceActions(JComponent)


getSourceAsBeanContextServices

getSourceAsBeanContextServices o7planning.org
  • BeanContextServiceAvailableEvent.getSourceAsBeanContextServices()
  • BeanContextServiceRevokedEvent.getSourceAsBeanContextServices()


getSourceAsDragGestureRecognizer

getSourceAsDragGestureRecognizer o7planning.org
  • DragGestureEvent.getSourceAsDragGestureRecognizer()


getSourceBands

getSourceBands o7planning.org
  • IIOParam.getSourceBands()


getSourceClassName

getSourceClassName o7planning.org
  • LogRecord.getSourceClassName()


getSourceDataLine

getSourceDataLine o7planning.org
  • AudioSystem.getSourceDataLine(AudioFormat, Mixer.Info)
  • AudioSystem.getSourceDataLine(AudioFormat)


getSourceDropActions

getSourceDropActions o7planning.org
  • TransferHandler.TransferSupport.getSourceDropActions()


getSourceElement

getSourceElement o7planning.org
  • HyperlinkEvent.getSourceElement()


getSourceEncodings

getSourceEncodings o7planning.org
  • FormatConversionProvider.getSourceEncodings()


getSourceLineInfo

getSourceLineInfo o7planning.org
  • AudioSystem.getSourceLineInfo(Line.Info)
  • Mixer.getSourceLineInfo(Line.Info)
  • Mixer.getSourceLineInfo()


getSourceLines

getSourceLines o7planning.org
  • Mixer.getSourceLines()


getSourceMaxProgressivePass

getSourceMaxProgressivePass o7planning.org
  • ImageReadParam.getSourceMaxProgressivePass()


getSourceMethodName

getSourceMethodName o7planning.org
  • LogRecord.getSourceMethodName()


getSourceMinProgressivePass

getSourceMinProgressivePass o7planning.org
  • ImageReadParam.getSourceMinProgressivePass()


getSourceNumProgressivePasses

getSourceNumProgressivePasses o7planning.org
  • ImageReadParam.getSourceNumProgressivePasses()


getSourceRegion

getSourceRegion o7planning.org
  • IIOParam.getSourceRegion()
  • ImageReader.getSourceRegion(ImageReadParam, int, int)


getSourceRenderSize

getSourceRenderSize o7planning.org
  • ImageReadParam.getSourceRenderSize()


getSources

getSources o7planning.org
  • BufferedImage.getSources()
  • ParameterBlock.getSources()
  • RenderableImage.getSources()
  • RenderableImageOp.getSources()
  • RenderedImage.getSources()


getSourceString

getSourceString o7planning.org
  • CollationKey.getSourceString()


getSourceVersion

getSourceVersion o7planning.org
  • ProcessingEnvironment.getSourceVersion()


getSourceVersions

getSourceVersions o7planning.org
  • Tool.getSourceVersions()


getSourceXSubsampling

getSourceXSubsampling o7planning.org
  • IIOParam.getSourceXSubsampling()


getSourceYSubsampling

getSourceYSubsampling o7planning.org
  • IIOParam.getSourceYSubsampling()


getSouthPane

getSouthPane o7planning.org
  • BasicInternalFrameUI.getSouthPane()


getSpaceAbove

getSpaceAbove o7planning.org
  • StyleConstants.getSpaceAbove(AttributeSet)


getSpaceBelow

getSpaceBelow o7planning.org
  • StyleConstants.getSpaceBelow(AttributeSet)


getSpan

getSpan o7planning.org
  • BoxView.getSpan(int, int)
  • GlyphView.GlyphPainter.getSpan(GlyphView, int, int, TabExpander, float)


getSpecificationName

getSpecificationName o7planning.org
  • MBeanServerDelegate.getSpecificationName()
  • MBeanServerDelegateMBean.getSpecificationName()


getSpecificationTitle

getSpecificationTitle o7planning.org
  • Package.getSpecificationTitle()


getSpecificationVendor

getSpecificationVendor o7planning.org
  • MBeanServerDelegate.getSpecificationVendor()
  • MBeanServerDelegateMBean.getSpecificationVendor()
  • Package.getSpecificationVendor()


getSpecificationVersion

getSpecificationVersion o7planning.org
  • MBeanServerDelegate.getSpecificationVersion()
  • MBeanServerDelegateMBean.getSpecificationVersion()
  • Package.getSpecificationVersion()


getSpecified

getSpecified o7planning.org
  • Attr.getSpecified()


getSpecName

getSpecName o7planning.org
  • RuntimeMXBean.getSpecName()


getSpecVendor

getSpecVendor o7planning.org
  • RuntimeMXBean.getSpecVendor()


getSpecVersion

getSpecVersion o7planning.org
  • RuntimeMXBean.getSpecVersion()


getSpi

getSpi o7planning.org
  • AbstractPreferences.getSpi(String)


getSpinner

getSpinner o7planning.org
  • JSpinner.DefaultEditor.getSpinner()


getSplashScreen

getSplashScreen o7planning.org
  • SplashScreen.getSplashScreen()


getSplitPane

getSplitPane o7planning.org
  • BasicSplitPaneUI.getSplitPane()


getSplitPaneBorder

getSplitPaneBorder o7planning.org
  • BasicBorders.getSplitPaneBorder()


getSplitPaneDividerBorder

getSplitPaneDividerBorder o7planning.org
  • BasicBorders.getSplitPaneDividerBorder()


getSQLException

getSQLException o7planning.org
  • ConnectionEvent.getSQLException()
  • StatementEvent.getSQLException()


getSQLKeywords

getSQLKeywords o7planning.org
  • DatabaseMetaData.getSQLKeywords()


getSQLState

getSQLState o7planning.org
  • SQLException.getSQLState()


getSQLStateType

getSQLStateType o7planning.org
  • DatabaseMetaData.getSQLStateType()


getSQLTypeName

getSQLTypeName o7planning.org
  • SQLData.getSQLTypeName()
  • SerialStruct.getSQLTypeName()
  • Struct.getSQLTypeName()


getSQLXML

getSQLXML o7planning.org
  • CallableStatement.getSQLXML(String)
  • CallableStatement.getSQLXML(int)
  • ResultSet.getSQLXML(String)
  • ResultSet.getSQLXML(int)


getSrcName

getSrcName o7planning.org
  • GSSContext.getSrcName()


getSSLParameters

getSSLParameters o7planning.org
  • SSLEngine.getSSLParameters()
  • SSLServerSocket.getSSLParameters()
  • SSLSocket.getSSLParameters()


getSSLSocketFactory

getSSLSocketFactory o7planning.org
  • HttpsURLConnection.getSSLSocketFactory()


getStackTrace

getStackTrace o7planning.org
  • Thread.getStackTrace()
  • ThreadInfo.getStackTrace()
  • Throwable.getStackTrace()


getStamp

getStamp o7planning.org
  • AtomicStampedReference.getStamp()


getStandardChromaNode

getStandardChromaNode o7planning.org
  • IIOMetadata.getStandardChromaNode()


getStandardCompressionNode

getStandardCompressionNode o7planning.org
  • IIOMetadata.getStandardCompressionNode()


getStandardDataNode

getStandardDataNode o7planning.org
  • IIOMetadata.getStandardDataNode()


getStandardDimensionNode

getStandardDimensionNode o7planning.org
  • IIOMetadata.getStandardDimensionNode()


getStandardDocumentNode

getStandardDocumentNode o7planning.org
  • IIOMetadata.getStandardDocumentNode()


getStandardFileManager

getStandardFileManager o7planning.org
  • DocumentationTool.getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset)
  • JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset)


getStandardFormatInstance

getStandardFormatInstance o7planning.org
  • IIOMetadataFormatImpl.getStandardFormatInstance()


getStandardOffset

getStandardOffset o7planning.org
  • ZoneOffsetTransitionRule.getStandardOffset()
  • ZoneRules.getStandardOffset(Instant)


getStandardTextNode

getStandardTextNode o7planning.org
  • IIOMetadata.getStandardTextNode()


getStandardTileNode

getStandardTileNode o7planning.org
  • IIOMetadata.getStandardTileNode()


getStandardTransparencyNode

getStandardTransparencyNode o7planning.org
  • IIOMetadata.getStandardTransparencyNode()


getStandardTree

getStandardTree o7planning.org
  • IIOMetadata.getStandardTree()


getStart

getStart o7planning.org
  • SpinnerDateModel.getStart()


getStartIndex

getStartIndex o7planning.org
  • AccessibleHyperlink.getStartIndex()
  • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getStartIndex()


getStartOffset

getStartOffset o7planning.org
  • AbstractDocument.AbstractElement.getStartOffset()
  • AbstractDocument.BranchElement.getStartOffset()
  • AbstractDocument.LeafElement.getStartOffset()
  • AbstractWriter.getStartOffset()
  • Element.getStartOffset()
  • GlyphView.getStartOffset()
  • HTMLDocument.Iterator.getStartOffset()
  • Highlighter.Highlight.getStartOffset()
  • View.getStartOffset()


getStartPoint

getStartPoint o7planning.org
  • Arc2D.getStartPoint()
  • LinearGradientPaint.getStartPoint()


getStartPosition

getStartPosition o7planning.org
  • AbstractDocument.getStartPosition()
  • Diagnostic.getStartPosition()
  • Document.getStartPosition()


getStartTime

getStartTime o7planning.org
  • KerberosTicket.getStartTime()
  • RuntimeMXBean.getStartTime()


getState

getState o7planning.org
  • AbstractQueuedLongSynchronizer.getState()
  • AbstractQueuedSynchronizer.getState()
  • Checkbox.getState()
  • CheckboxMenuItem.getState()
  • Frame.getState()
  • InputMethodHighlight.getState()
  • JCheckBoxMenuItem.getState()
  • SwingWorker.getState()
  • Thread.getState()


getStateChange

getStateChange o7planning.org
  • ItemEvent.getStateChange()


getStateLabel

getStateLabel o7planning.org
  • BooleanControl.getStateLabel(boolean)


getStatement

getStatement o7planning.org
  • ResultSet.getStatement()
  • StatementEvent.getStatement()


getStateToBind

getStateToBind o7planning.org
  • DirStateFactory.getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes)
  • DirectoryManager.getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes)
  • NamingManager.getStateToBind(Object, Name, Context, Hashtable<?, ?>)
  • StateFactory.getStateToBind(Object, Name, Context, Hashtable<?, ?>)


getStaticAttribute

getStaticAttribute o7planning.org
  • StyleContext.getStaticAttribute(Object)


getStaticAttributeKey

getStaticAttributeKey o7planning.org
  • StyleContext.getStaticAttributeKey(Object)


getStatus

getStatus o7planning.org
  • MidiMessage.getStatus()
  • PixelGrabber.getStatus()
  • SSLEngineResult.getStatus()
  • SyncResolver.getStatus()


getStatusCode

getStatusCode o7planning.org
  • HTTPException.getStatusCode()


getStealCount

getStealCount o7planning.org
  • ForkJoinPool.getStealCount()


getStepSize

getStepSize o7planning.org
  • SpinnerNumberModel.getStepSize()


getStream

getStream o7planning.org
  • AccessibleStreamable.getStream(DataFlavor)
  • AppletContext.getStream(String)
  • JEditorPane.getStream(URL)


getStreamForBytes

getStreamForBytes o7planning.org
  • Doc.getStreamForBytes()
  • SimpleDoc.getStreamForBytes()


getStreamKeys

getStreamKeys o7planning.org
  • AppletContext.getStreamKeys()


getStreamMetadata

getStreamMetadata o7planning.org
  • ImageReader.getStreamMetadata(String, Set<String>)
  • ImageReader.getStreamMetadata()


getStreamMetadataFormat

getStreamMetadataFormat o7planning.org
  • ImageReaderWriterSpi.getStreamMetadataFormat(String)


getStreamPosition

getStreamPosition o7planning.org
  • ImageInputStream.getStreamPosition()
  • ImageInputStreamImpl.getStreamPosition()


getStrength

getStrength o7planning.org
  • Collator.getStrength()


getStrictErrorChecking

getStrictErrorChecking o7planning.org
  • Document.getStrictErrorChecking()


getStrikethroughOffset

getStrikethroughOffset o7planning.org
  • LineMetrics.getStrikethroughOffset()


getStrikethroughThickness

getStrikethroughThickness o7planning.org
  • LineMetrics.getStrikethroughThickness()


getString

getString o7planning.org
  • AbstractDocument.Content.getString(int, int)
  • CallableStatement.getString(String)
  • CallableStatement.getString(int)
  • Entity.getString()
  • GapContent.getString(int, int)
  • JProgressBar.getString()
  • ResourceBundle.getString(String)
  • ResultSet.getString(String)
  • ResultSet.getString(int)
  • SQLXML.getString()
  • StringContent.getString(int, int)
  • SynthStyle.getString(SynthContext, Object, String)
  • UIDefaults.getString(Object, Locale)
  • UIDefaults.getString(Object)
  • UIManager.getString(Object, Locale)
  • UIManager.getString(Object)


getStringArray

getStringArray o7planning.org
  • ResourceBundle.getStringArray(String)


getStringBounds

getStringBounds o7planning.org
  • Font.getStringBounds(CharacterIterator, int, int, FontRenderContext)
  • Font.getStringBounds(char[], int, int, FontRenderContext)
  • Font.getStringBounds(String, int, int, FontRenderContext)
  • Font.getStringBounds(String, FontRenderContext)
  • FontMetrics.getStringBounds(CharacterIterator, int, int, Graphics)
  • FontMetrics.getStringBounds(char[], int, int, Graphics)
  • FontMetrics.getStringBounds(String, int, int, Graphics)
  • FontMetrics.getStringBounds(String, Graphics)


getStringConverter

getStringConverter o7planning.org
  • TableRowSorter.getStringConverter()


getStringData

getStringData o7planning.org
  • LSInput.getStringData()


getStringFunctions

getStringFunctions o7planning.org
  • DatabaseMetaData.getStringFunctions()


getStringNameType

getStringNameType o7planning.org
  • GSSName.getStringNameType()


getStringPlacement

getStringPlacement o7planning.org
  • BasicProgressBarUI.getStringPlacement(Graphics, String, int, int, int, int)


getStringTable

getStringTable o7planning.org
  • Chromaticity.getStringTable()
  • ColorSupported.getStringTable()
  • Compression.getStringTable()
  • DialogTypeSelection.getStringTable()
  • EnumSyntax.getStringTable()
  • Fidelity.getStringTable()
  • Finishings.getStringTable()
  • JobSheets.getStringTable()
  • JobState.getStringTable()
  • JobStateReason.getStringTable()
  • MediaName.getStringTable()
  • MediaSizeName.getStringTable()
  • MediaTray.getStringTable()
  • MultipleDocumentHandling.getStringTable()
  • OrientationRequested.getStringTable()
  • PDLOverrideSupported.getStringTable()
  • PresentationDirection.getStringTable()
  • PrintQuality.getStringTable()
  • PrinterIsAcceptingJobs.getStringTable()
  • PrinterState.getStringTable()
  • PrinterStateReason.getStringTable()
  • ReferenceUriSchemesSupported.getStringTable()
  • Severity.getStringTable()
  • SheetCollate.getStringTable()
  • Sides.getStringTable()


getStringToCompare

getStringToCompare o7planning.org
  • StringMonitor.getStringToCompare()
  • StringMonitorMBean.getStringToCompare()


getStringValue

getStringValue o7planning.org
  • RowFilter.Entry.getStringValue(int)


getStringValueAt

getStringValueAt o7planning.org
  • DefaultRowSorter.ModelWrapper.getStringValueAt(int, int)


getStroke

getStroke o7planning.org
  • Graphics2D.getStroke()
  • StrokeBorder.getStroke()


getStrongCaret

getStrongCaret o7planning.org
  • TextLayout.CaretPolicy.getStrongCaret(TextHitInfo, TextHitInfo, TextLayout)


getStyle

getStyle o7planning.org
  • DefaultStyledDocument.getStyle(String)
  • Font.getStyle()
  • InputMethodHighlight.getStyle()
  • JTextPane.getStyle(String)
  • NimbusLookAndFeel.getStyle(JComponent, Region)
  • StyleContext.getStyle(String)
  • StyledDocument.getStyle(String)
  • SynthContext.getStyle()
  • SynthLookAndFeel.getStyle(JComponent, Region)
  • SynthStyleFactory.getStyle(JComponent, Region)


getStyledDocument

getStyledDocument o7planning.org
  • JTextPane.getStyledDocument()
  • StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane)


getStyledEditorKit

getStyledEditorKit o7planning.org
  • JTextPane.getStyledEditorKit()
  • StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane)


getStyleFactory

getStyleFactory o7planning.org
  • SynthLookAndFeel.getStyleFactory()


getStyleNames

getStyleNames o7planning.org
  • DefaultStyledDocument.getStyleNames()
  • StyleContext.getStyleNames()


getStyleSheet

getStyleSheet o7planning.org
  • BlockView.getStyleSheet()
  • HTMLDocument.getStyleSheet()
  • HTMLEditorKit.getStyleSheet()
  • ImageView.getStyleSheet()
  • InlineView.getStyleSheet()
  • ParagraphView.getStyleSheet()


getStylesheet

getStylesheet o7planning.org
  • XSLTTransformParameterSpec.getStylesheet()


getStyleSheets

getStyleSheets o7planning.org
  • StyleSheet.getStyleSheets()


getSubElements

getSubElements o7planning.org
  • JMenu.getSubElements()
  • JMenuBar.getSubElements()
  • JMenuItem.getSubElements()
  • JPopupMenu.getSubElements()
  • MenuElement.getSubElements()


getSubimage

getSubimage o7planning.org
  • BufferedImage.getSubimage(int, int, int, int)


getSubInterfaces

getSubInterfaces o7planning.org
  • NetworkInterface.getSubInterfaces()


getSubject

getSubject o7planning.org
  • LoginContext.getSubject()
  • Subject.getSubject(AccessControlContext)
  • SubjectDomainCombiner.getSubject()
  • X509CertSelector.getSubject()


getSubjectAlternativeNames

getSubjectAlternativeNames o7planning.org
  • X509CertSelector.getSubjectAlternativeNames()
  • X509Certificate.getSubjectAlternativeNames()


getSubjectAsBytes

getSubjectAsBytes o7planning.org
  • X509CertSelector.getSubjectAsBytes()


getSubjectAsString

getSubjectAsString o7planning.org
  • X509CertSelector.getSubjectAsString()


getSubjectDN

getSubjectDN o7planning.org
  • X509Certificate.getSubjectDN()
  • X509Certificate.getSubjectDN()


getSubjectKeyIdentifier

getSubjectKeyIdentifier o7planning.org
  • X509CertSelector.getSubjectKeyIdentifier()


getSubjectPublicKey

getSubjectPublicKey o7planning.org
  • X509CertSelector.getSubjectPublicKey()


getSubjectPublicKeyAlgID

getSubjectPublicKeyAlgID o7planning.org
  • X509CertSelector.getSubjectPublicKeyAlgID()


getSubjectUniqueID

getSubjectUniqueID o7planning.org
  • X509Certificate.getSubjectUniqueID()


getSubjectX500Principal

getSubjectX500Principal o7planning.org
  • X509Certificate.getSubjectX500Principal()


getSubprimeQLength

getSubprimeQLength o7planning.org
  • DSAGenParameterSpec.getSubprimeQLength()


getSubsamplingXOffset

getSubsamplingXOffset o7planning.org
  • IIOParam.getSubsamplingXOffset()


getSubsamplingYOffset

getSubsamplingYOffset o7planning.org
  • IIOParam.getSubsamplingYOffset()


getSubString

getSubString o7planning.org
  • Clob.getSubString(long, int)
  • SerialClob.getSubString(long, int)


getSubTextFont

getSubTextFont o7planning.org
  • DefaultMetalTheme.getSubTextFont()
  • MetalLookAndFeel.getSubTextFont()
  • MetalTheme.getSubTextFont()


getSubType

getSubType o7planning.org
  • DataFlavor.getSubType()
  • MimeType.getSubType()


getSuffix

getSuffix o7planning.org
  • CompositeName.getSuffix(int)
  • CompoundName.getSuffix(int)
  • LdapName.getSuffix(int)
  • Name.getSuffix(int)


getSum

getSum o7planning.org
  • DoubleSummaryStatistics.getSum()
  • IntSummaryStatistics.getSum()
  • LongSummaryStatistics.getSum()


getSuperBound

getSuperBound o7planning.org
  • WildcardType.getSuperBound()


getSuperclass

getSuperclass o7planning.org
  • Class.getSuperclass()
  • TypeElement.getSuperclass()


getSuperTables

getSuperTables o7planning.org
  • DatabaseMetaData.getSuperTables(String, String, String)


getSuperTypes

getSuperTypes o7planning.org
  • DatabaseMetaData.getSuperTypes(String, String, String)


getSupportedAnnotationTypes

getSupportedAnnotationTypes o7planning.org
  • AbstractProcessor.getSupportedAnnotationTypes()
  • Processor.getSupportedAnnotationTypes()


getSupportedAttributeCategories

getSupportedAttributeCategories o7planning.org
  • PrintService.getSupportedAttributeCategories()


getSupportedAttributeValues

getSupportedAttributeValues o7planning.org
  • PrintService.getSupportedAttributeValues(Class<? extends Attribute>, DocFlavor, AttributeSet)


getSupportedCipherSuites

getSupportedCipherSuites o7planning.org
  • SSLEngine.getSupportedCipherSuites()
  • SSLServerSocket.getSupportedCipherSuites()
  • SSLServerSocketFactory.getSupportedCipherSuites()
  • SSLSocket.getSupportedCipherSuites()
  • SSLSocketFactory.getSupportedCipherSuites()


getSupportedDocFlavors

getSupportedDocFlavors o7planning.org
  • PrintService.getSupportedDocFlavors()
  • StreamPrintServiceFactory.getSupportedDocFlavors()


getSupportedExtensions

getSupportedExtensions o7planning.org
  • PKIXCertPathChecker.getSupportedExtensions()


getSupportedOptions

getSupportedOptions o7planning.org
  • AbstractProcessor.getSupportedOptions()
  • Processor.getSupportedOptions()


getSupportedProtocols

getSupportedProtocols o7planning.org
  • SSLEngine.getSupportedProtocols()
  • SSLServerSocket.getSupportedProtocols()
  • SSLSocket.getSupportedProtocols()


getSupportedSourceVersion

getSupportedSourceVersion o7planning.org
  • AbstractProcessor.getSupportedSourceVersion()
  • Processor.getSupportedSourceVersion()


getSupportedSSLParameters

getSupportedSSLParameters o7planning.org
  • SSLContext.getSupportedSSLParameters()


getSupportsAbsolutePositioning

getSupportsAbsolutePositioning o7planning.org
  • BasicScrollBarUI.getSupportsAbsolutePositioning()
  • SynthScrollBarUI.getSupportsAbsolutePositioning()


getSupportsWindowDecorations

getSupportsWindowDecorations o7planning.org
  • LookAndFeel.getSupportsWindowDecorations()
  • MetalLookAndFeel.getSupportsWindowDecorations()


getSuppressed

getSuppressed o7planning.org
  • Throwable.getSuppressed()


getSurplusQueuedTaskCount

getSurplusQueuedTaskCount o7planning.org
  • ForkJoinTask.getSurplusQueuedTaskCount()


getSurrendersFocusOnKeystroke

getSurrendersFocusOnKeystroke o7planning.org
  • JTable.getSurrendersFocusOnKeystroke()


getSymbol

getSymbol o7planning.org
  • Currency.getSymbol(Locale)
  • Currency.getSymbol()
  • CurrencyNameProvider.getSymbol(String, Locale)


getSyncAllWidths

getSyncAllWidths o7planning.org
  • BasicOptionPaneUI.ButtonAreaLayout.getSyncAllWidths()


getSyncFactory

getSyncFactory o7planning.org
  • SyncFactory.getSyncFactory()


getSyncProvider

getSyncProvider o7planning.org
  • CachedRowSet.getSyncProvider()


getSyncResolver

getSyncResolver o7planning.org
  • SyncProviderException.getSyncResolver()


getSynthesizer

getSynthesizer o7planning.org
  • MidiSystem.getSynthesizer()


getSystem

getSystem o7planning.org
  • ActivationGroup.getSystem()
  • ActivationGroupID.getSystem()


getSystemClassLoader

getSystemClassLoader o7planning.org
  • ClassLoader.getSystemClassLoader()


getSystemClipboard

getSystemClipboard o7planning.org
  • Toolkit.getSystemClipboard()


getSystemCustomCursor

getSystemCustomCursor o7planning.org
  • Cursor.getSystemCustomCursor(String)


getSystemDisplayName

getSystemDisplayName o7planning.org
  • FileSystemView.getSystemDisplayName(File)


getSystemDocumentationTool

getSystemDocumentationTool o7planning.org
  • ToolProvider.getSystemDocumentationTool()


getSystemEventQueue

getSystemEventQueue o7planning.org
  • Toolkit.getSystemEventQueue()


getSystemEventQueueImpl

getSystemEventQueueImpl o7planning.org
  • Toolkit.getSystemEventQueueImpl()


getSystemFunctions

getSystemFunctions o7planning.org
  • DatabaseMetaData.getSystemFunctions()


getSystemIcon

getSystemIcon o7planning.org
  • FileSystemView.getSystemIcon(File)


getSystemId

getSystemId o7planning.org
  • DOMResult.getSystemId()
  • DOMSource.getSystemId()
  • DocumentType.getSystemId()
  • Entity.getSystemId()
  • EntityDeclaration.getSystemId()
  • InputSource.getSystemId()
  • LSInput.getSystemId()
  • LSOutput.getSystemId()
  • Location.getSystemId()
  • Locator.getSystemId()
  • LocatorImpl.getSystemId()
  • Notation.getSystemId()
  • NotationDeclaration.getSystemId()
  • Result.getSystemId()
  • SAXParseException.getSystemId()
  • SAXResult.getSystemId()
  • SAXSource.getSystemId()
  • Source.getSystemId()
  • SourceLocator.getSystemId()
  • StAXResult.getSystemId()
  • StAXSource.getSystemId()
  • StartDocument.getSystemId()
  • StreamResult.getSystemId()
  • StreamSource.getSystemId()
  • TemplatesHandler.getSystemId()
  • TransformerHandler.getSystemId()


getSystemJavaCompiler

getSystemJavaCompiler o7planning.org
  • ToolProvider.getSystemJavaCompiler()


getSystemLoadAverage

getSystemLoadAverage o7planning.org
  • OperatingSystemMXBean.getSystemLoadAverage()


getSystemLookAndFeelClassName

getSystemLookAndFeelClassName o7planning.org
  • UIManager.getSystemLookAndFeelClassName()


getSystemProperties

getSystemProperties o7planning.org
  • RuntimeMXBean.getSystemProperties()


getSystemResource

getSystemResource o7planning.org
  • ClassLoader.getSystemResource(String)


getSystemResourceAsStream

getSystemResourceAsStream o7planning.org
  • ClassLoader.getSystemResourceAsStream(String)


getSystemResources

getSystemResources o7planning.org
  • ClassLoader.getSystemResources(String)


getSystemScope

getSystemScope o7planning.org
  • IdentityScope.getSystemScope()


getSystemSelection

getSystemSelection o7planning.org
  • Toolkit.getSystemSelection()


getSystemTextColor

getSystemTextColor o7planning.org
  • MetalLookAndFeel.getSystemTextColor()
  • MetalTheme.getSystemTextColor()


getSystemTextFont

getSystemTextFont o7planning.org
  • DefaultMetalTheme.getSystemTextFont()
  • MetalLookAndFeel.getSystemTextFont()
  • MetalTheme.getSystemTextFont()


getSystemToolClassLoader

getSystemToolClassLoader o7planning.org
  • ToolProvider.getSystemToolClassLoader()


getSystemTray

getSystemTray o7planning.org
  • SystemTray.getSystemTray()


getSystemTypeDescription

getSystemTypeDescription o7planning.org
  • FileSystemView.getSystemTypeDescription(File)


getTab

getTab o7planning.org
  • TabSet.getTab(int)


getTabAfter

getTabAfter o7planning.org
  • TabSet.getTabAfter(float)


getTabAreaInsets

getTabAreaInsets o7planning.org
  • BasicTabbedPaneUI.getTabAreaInsets(int)


getTabBase

getTabBase o7planning.org
  • ParagraphView.getTabBase()


getTabbedSpan

getTabbedSpan o7planning.org
  • GlyphView.getTabbedSpan(float, TabExpander)
  • TabableView.getTabbedSpan(float, TabExpander)


getTabbedTextOffset

getTabbedTextOffset o7planning.org
  • Utilities.getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean)
  • Utilities.getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int)


getTabbedTextWidth

getTabbedTextWidth o7planning.org
  • Utilities.getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int)


getTabBounds

getTabBounds o7planning.org
  • BasicTabbedPaneUI.getTabBounds(int, Rectangle)
  • BasicTabbedPaneUI.getTabBounds(JTabbedPane, int)
  • MultiTabbedPaneUI.getTabBounds(JTabbedPane, int)
  • TabbedPaneUI.getTabBounds(JTabbedPane, int)


getTabComponentAt

getTabComponentAt o7planning.org
  • JTabbedPane.getTabComponentAt(int)


getTabCount

getTabCount o7planning.org
  • JTabbedPane.getTabCount()
  • TabSet.getTabCount()


getTabExpander

getTabExpander o7planning.org
  • GlyphView.getTabExpander()


getTabIndex

getTabIndex o7planning.org
  • TabSet.getTabIndex(TabStop)


getTabIndexAfter

getTabIndexAfter o7planning.org
  • TabSet.getTabIndexAfter(float)


getTabInsets

getTabInsets o7planning.org
  • BasicTabbedPaneUI.getTabInsets(int, int)
  • SynthTabbedPaneUI.getTabInsets(int, int)


getTabLabelShiftX

getTabLabelShiftX o7planning.org
  • BasicTabbedPaneUI.getTabLabelShiftX(int, int, boolean)
  • MetalTabbedPaneUI.getTabLabelShiftX(int, int, boolean)
  • SynthTabbedPaneUI.getTabLabelShiftX(int, int, boolean)


getTabLabelShiftY

getTabLabelShiftY o7planning.org
  • BasicTabbedPaneUI.getTabLabelShiftY(int, int, boolean)
  • MetalTabbedPaneUI.getTabLabelShiftY(int, int, boolean)
  • SynthTabbedPaneUI.getTabLabelShiftY(int, int, boolean)


getTabLayoutPolicy

getTabLayoutPolicy o7planning.org
  • JTabbedPane.getTabLayoutPolicy()


getTable

getTable o7planning.org
  • ByteLookupTable.getTable()
  • JPEGQTable.getTable()
  • JTableHeader.getTable()
  • LookupOp.getTable()
  • ShortLookupTable.getTable()


getTableCellEditorComponent

getTableCellEditorComponent o7planning.org
  • DefaultCellEditor.getTableCellEditorComponent(JTable, Object, boolean, int, int)
  • TableCellEditor.getTableCellEditorComponent(JTable, Object, boolean, int, int)


getTableCellRendererComponent

getTableCellRendererComponent o7planning.org
  • DefaultTableCellRenderer.getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int)
  • TableCellRenderer.getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int)


getTableHeader

getTableHeader o7planning.org
  • JTable.getTableHeader()


getTableModelListeners

getTableModelListeners o7planning.org
  • AbstractTableModel.getTableModelListeners()


getTableName

getTableName o7planning.org
  • CachedRowSet.getTableName()
  • ResultSetMetaData.getTableName(int)
  • RowSetMetaDataImpl.getTableName(int)


getTablePrivileges

getTablePrivileges o7planning.org
  • DatabaseMetaData.getTablePrivileges(String, String, String)


getTables

getTables o7planning.org
  • DatabaseMetaData.getTables(String, String, String, String[])


getTableTypes

getTableTypes o7planning.org
  • DatabaseMetaData.getTableTypes()


getTabPlacement

getTabPlacement o7planning.org
  • JTabbedPane.getTabPlacement()


getTabRunCount

getTabRunCount o7planning.org
  • BasicTabbedPaneUI.getTabRunCount(JTabbedPane)
  • JTabbedPane.getTabRunCount()
  • MultiTabbedPaneUI.getTabRunCount(JTabbedPane)
  • TabbedPaneUI.getTabRunCount(JTabbedPane)


getTabRunIndent

getTabRunIndent o7planning.org
  • BasicTabbedPaneUI.getTabRunIndent(int, int)


getTabRunOffset

getTabRunOffset o7planning.org
  • BasicTabbedPaneUI.getTabRunOffset(int, int, int, boolean)


getTabRunOverlay

getTabRunOverlay o7planning.org
  • BasicTabbedPaneUI.getTabRunOverlay(int)
  • MetalTabbedPaneUI.getTabRunOverlay(int)


getTabSet

getTabSet o7planning.org
  • ParagraphView.getTabSet()
  • StyleConstants.getTabSet(AttributeSet)


getTabSize

getTabSize o7planning.org
  • JTextArea.getTabSize()
  • PlainView.getTabSize()
  • WrappedPlainView.getTabSize()


getTabularType

getTabularType o7planning.org
  • TabularData.getTabularType()
  • TabularDataSupport.getTabularType()


getTag

getTag o7planning.org
  • HTML.getTag(String)
  • HTMLDocument.Iterator.getTag()


getTagName

getTagName o7planning.org
  • Element.getTagName()
  • IIOMetadataNode.getTagName()


getTags

getTags o7planning.org
  • PropertyEditor.getTags()
  • PropertyEditorSupport.getTags()


getTail

getTail o7planning.org
  • Formatter.getTail(Handler)
  • XMLFormatter.getTail(Handler)


getTarget

getTarget o7planning.org
  • AccessibleRelation.getTarget()
  • BoxLayout.getTarget()
  • CallSite.getTarget()
  • ConstantCallSite.getTarget()
  • Event.getTarget()
  • EventHandler.getTarget()
  • HTMLFrameHyperlinkEvent.getTarget()
  • MutableCallSite.getTarget()
  • OverlayLayout.getTarget()
  • ProcessingInstruction.getTarget()
  • ProcessingInstruction.getTarget()
  • SignatureProperty.getTarget()
  • Statement.getTarget()
  • Tie.getTarget()
  • VolatileCallSite.getTarget()


getTargetActions

getTargetActions o7planning.org
  • DragSourceDragEvent.getTargetActions()
  • DropTargetContext.getTargetActions()


getTargetCertConstraints

getTargetCertConstraints o7planning.org
  • PKIXParameters.getTargetCertConstraints()


getTargetDataLine

getTargetDataLine o7planning.org
  • AudioSystem.getTargetDataLine(AudioFormat, Mixer.Info)
  • AudioSystem.getTargetDataLine(AudioFormat)


getTargetedNotifications

getTargetedNotifications o7planning.org
  • NotificationResult.getTargetedNotifications()


getTargetEncodings

getTargetEncodings o7planning.org
  • AudioSystem.getTargetEncodings(AudioFormat)
  • AudioSystem.getTargetEncodings(AudioFormat.Encoding)
  • FormatConversionProvider.getTargetEncodings(AudioFormat)
  • FormatConversionProvider.getTargetEncodings()


getTargetError

getTargetError o7planning.org
  • RuntimeErrorException.getTargetError()


getTargetException

getTargetException o7planning.org
  • InvocationTargetException.getTargetException()
  • MBeanException.getTargetException()
  • ReflectionException.getTargetException()
  • RuntimeMBeanException.getTargetException()
  • RuntimeOperationsException.getTargetException()


getTargetFormats

getTargetFormats o7planning.org
  • AudioSystem.getTargetFormats(AudioFormat.Encoding, AudioFormat)
  • FormatConversionProvider.getTargetFormats(AudioFormat.Encoding, AudioFormat)


getTargetLineInfo

getTargetLineInfo o7planning.org
  • AudioSystem.getTargetLineInfo(Line.Info)
  • Mixer.getTargetLineInfo(Line.Info)
  • Mixer.getTargetLineInfo()


getTargetLines

getTargetLines o7planning.org
  • Mixer.getTargetLines()


getTargName

getTargName o7planning.org
  • GSSContext.getTargName()


getTask

getTask o7planning.org
  • DocumentationTool.getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Class<?>, Iterable<String>, Iterable<? extends JavaFileObject>)
  • JavaCompiler.getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Iterable<String>, Iterable<String>, Iterable<? extends JavaFileObject>)


getTaskCount

getTaskCount o7planning.org
  • ThreadPoolExecutor.getTaskCount()


getTBSCertificate

getTBSCertificate o7planning.org
  • X509Certificate.getTBSCertificate()


getTBSCertList

getTBSCertList o7planning.org
  • X509CRL.getTBSCertList()


getTcpNoDelay

getTcpNoDelay o7planning.org
  • Socket.getTcpNoDelay()


getTemplates

getTemplates o7planning.org
  • TemplatesHandler.getTemplates()


getTempoFactor

getTempoFactor o7planning.org
  • Sequencer.getTempoFactor()


getTempoInBPM

getTempoInBPM o7planning.org
  • Sequencer.getTempoInBPM()


getTempoInMPQ

getTempoInMPQ o7planning.org
  • Sequencer.getTempoInMPQ()


getText

getText o7planning.org
  • AbstractButton.getText()
  • AbstractDocument.getText(int, int, Segment)
  • AbstractDocument.getText(int, int)
  • AbstractWriter.getText(Element)
  • BreakIterator.getText()
  • Comment.getText()
  • Document.getText(int, int, Segment)
  • Document.getText(int, int)
  • GlyphView.getText(int, int)
  • InputMethodEvent.getText()
  • JEditorPane.getText()
  • JLabel.getText()
  • JPasswordField.getText(int, int)
  • JPasswordField.getText()
  • JTextComponent.getText()
  • JTextComponent.getText(int, int)
  • Label.getText()
  • StreamReaderDelegate.getText()
  • TextComponent.getText()
  • TextInputCallback.getText()
  • XMLStreamReader.getText()


getTextBorder

getTextBorder o7planning.org
  • MetalBorders.getTextBorder()


getTextBounds

getTextBounds o7planning.org
  • AccessibleExtendedText.getTextBounds(int, int)
  • JTextComponent.AccessibleJTextComponent.getTextBounds(int, int)


getTextCharacters

getTextCharacters o7planning.org
  • StreamReaderDelegate.getTextCharacters()
  • StreamReaderDelegate.getTextCharacters(int, char[], int, int)
  • XMLStreamReader.getTextCharacters(int, char[], int, int)
  • XMLStreamReader.getTextCharacters()


getTextComponent

getTextComponent o7planning.org
  • TextAction.getTextComponent(ActionEvent)


getTextContent

getTextContent o7planning.org
  • IIOMetadataNode.getTextContent()
  • Node.getTextContent()


getTextField

getTextField o7planning.org
  • JSpinner.DefaultEditor.getTextField()


getTextFieldBorder

getTextFieldBorder o7planning.org
  • BasicBorders.getTextFieldBorder()
  • MetalBorders.getTextFieldBorder()


getTextHighlightColor

getTextHighlightColor o7planning.org
  • MetalLookAndFeel.getTextHighlightColor()
  • MetalTheme.getTextHighlightColor()


getTextLength

getTextLength o7planning.org
  • StreamReaderDelegate.getTextLength()
  • XMLStreamReader.getTextLength()


getTextListeners

getTextListeners o7planning.org
  • TextComponent.getTextListeners()


getTextLocation

getTextLocation o7planning.org
  • InputMethodRequests.getTextLocation(TextHitInfo)


getTextNonSelectionColor

getTextNonSelectionColor o7planning.org
  • DefaultTreeCellRenderer.getTextNonSelectionColor()


getTextPlainUnicodeFlavor

getTextPlainUnicodeFlavor o7planning.org
  • DataFlavor.getTextPlainUnicodeFlavor()


getTextRange

getTextRange o7planning.org
  • AccessibleEditableText.getTextRange(int, int)
  • AccessibleExtendedText.getTextRange(int, int)
  • JPasswordField.AccessibleJPasswordField.getTextRange(int, int)
  • JSpinner.AccessibleJSpinner.getTextRange(int, int)
  • JTextComponent.AccessibleJTextComponent.getTextRange(int, int)


getTextSelectionColor

getTextSelectionColor o7planning.org
  • DefaultTreeCellRenderer.getTextSelectionColor()


getTextSequenceAfter

getTextSequenceAfter o7planning.org
  • AccessibleExtendedText.getTextSequenceAfter(int, int)
  • JPasswordField.AccessibleJPasswordField.getTextSequenceAfter(int, int)
  • JTextComponent.AccessibleJTextComponent.getTextSequenceAfter(int, int)


getTextSequenceAt

getTextSequenceAt o7planning.org
  • AccessibleExtendedText.getTextSequenceAt(int, int)
  • JPasswordField.AccessibleJPasswordField.getTextSequenceAt(int, int)
  • JTextComponent.AccessibleJTextComponent.getTextSequenceAt(int, int)


getTextSequenceBefore

getTextSequenceBefore o7planning.org
  • AccessibleExtendedText.getTextSequenceBefore(int, int)
  • JPasswordField.AccessibleJPasswordField.getTextSequenceBefore(int, int)
  • JTextComponent.AccessibleJTextComponent.getTextSequenceBefore(int, int)


getTextShiftOffset

getTextShiftOffset o7planning.org
  • BasicButtonUI.getTextShiftOffset()
  • BasicToggleButtonUI.getTextShiftOffset()


getTextStart

getTextStart o7planning.org
  • StreamReaderDelegate.getTextStart()
  • XMLStreamReader.getTextStart()


getTextViewForTab

getTextViewForTab o7planning.org
  • BasicTabbedPaneUI.getTextViewForTab(int)


getThenReset

getThenReset o7planning.org
  • DoubleAccumulator.getThenReset()
  • LongAccumulator.getThenReset()


getThickness

getThickness o7planning.org
  • LineBorder.getThickness()


getThisUpdate

getThisUpdate o7planning.org
  • X509CRL.getThisUpdate()


getThreadCount

getThreadCount o7planning.org
  • ThreadMXBean.getThreadCount()


getThreadCpuTime

getThreadCpuTime o7planning.org
  • ThreadMXBean.getThreadCpuTime(long)


getThreadFactory

getThreadFactory o7planning.org
  • ThreadPoolExecutor.getThreadFactory()


getThreadGroup

getThreadGroup o7planning.org
  • SecurityManager.getThreadGroup()
  • Thread.getThreadGroup()


getThreadId

getThreadId o7planning.org
  • ThreadInfo.getThreadId()


getThreadID

getThreadID o7planning.org
  • LogRecord.getThreadID()


getThreadInfo

getThreadInfo o7planning.org
  • ThreadMXBean.getThreadInfo(long[], boolean, boolean)
  • ThreadMXBean.getThreadInfo(long[], int)
  • ThreadMXBean.getThreadInfo(long, int)
  • ThreadMXBean.getThreadInfo(long[])
  • ThreadMXBean.getThreadInfo(long)


getThreadMXBean

getThreadMXBean o7planning.org
  • ManagementFactory.getThreadMXBean()


getThreadName

getThreadName o7planning.org
  • ThreadInfo.getThreadName()


getThreadState

getThreadState o7planning.org
  • ThreadInfo.getThreadState()


getThreadUserTime

getThreadUserTime o7planning.org
  • ThreadMXBean.getThreadUserTime(long)


getThreshold

getThreshold o7planning.org
  • CounterMonitor.getThreshold()
  • CounterMonitor.getThreshold(ObjectName)
  • CounterMonitorMBean.getThreshold(ObjectName)
  • CounterMonitorMBean.getThreshold()
  • MTOMFeature.getThreshold()


getThrowable

getThrowable o7planning.org
  • InvocationEvent.getThrowable()


getThrown

getThrown o7planning.org
  • LogRecord.getThrown()


getThrownTypes

getThrownTypes o7planning.org
  • ExecutableElement.getThrownTypes()
  • ExecutableType.getThrownTypes()


getThumbBounds

getThumbBounds o7planning.org
  • BasicScrollBarUI.getThumbBounds()


getThumbnail

getThumbnail o7planning.org
  • IIOImage.getThumbnail(int)


getThumbnailHeight

getThumbnailHeight o7planning.org
  • ImageReader.getThumbnailHeight(int, int)


getThumbnails

getThumbnails o7planning.org
  • IIOImage.getThumbnails()


getThumbnailWidth

getThumbnailWidth o7planning.org
  • ImageReader.getThumbnailWidth(int, int)


getThumbOverhang

getThumbOverhang o7planning.org
  • MetalSliderUI.getThumbOverhang()


getThumbSize

getThumbSize o7planning.org
  • BasicSliderUI.getThumbSize()
  • MetalSliderUI.getThumbSize()
  • SynthSliderUI.getThumbSize()


getTick

getTick o7planning.org
  • MidiEvent.getTick()


getTickLength

getTickLength o7planning.org
  • BasicSliderUI.getTickLength()
  • MetalSliderUI.getTickLength()
  • Sequence.getTickLength()
  • Sequencer.getTickLength()


getTickPosition

getTickPosition o7planning.org
  • Sequencer.getTickPosition()


getTie

getTie o7planning.org
  • Util.getTie(Remote)
  • UtilDelegate.getTie(Remote)


getTile

getTile o7planning.org
  • BufferedImage.getTile(int, int)
  • RenderedImage.getTile(int, int)


getTiledSizeRequirements

getTiledSizeRequirements o7planning.org
  • SizeRequirements.getTiledSizeRequirements(SizeRequirements[])


getTileGridXOffset

getTileGridXOffset o7planning.org
  • BufferedImage.getTileGridXOffset()
  • ImageReader.getTileGridXOffset(int)
  • ImageWriteParam.getTileGridXOffset()
  • RenderedImage.getTileGridXOffset()


getTileGridYOffset

getTileGridYOffset o7planning.org
  • BufferedImage.getTileGridYOffset()
  • ImageReader.getTileGridYOffset(int)
  • ImageWriteParam.getTileGridYOffset()
  • RenderedImage.getTileGridYOffset()


getTileHeight

getTileHeight o7planning.org
  • BufferedImage.getTileHeight()
  • ImageReader.getTileHeight(int)
  • ImageWriteParam.getTileHeight()
  • RenderedImage.getTileHeight()


getTileIcon

getTileIcon o7planning.org
  • MatteBorder.getTileIcon()


getTileWidth

getTileWidth o7planning.org
  • BufferedImage.getTileWidth()
  • ImageReader.getTileWidth(int)
  • ImageWriteParam.getTileWidth()
  • RenderedImage.getTileWidth()


getTilingMode

getTilingMode o7planning.org
  • ImageWriteParam.getTilingMode()


getTime

getTime o7planning.org
  • Calendar.getTime()
  • CallableStatement.getTime(String, Calendar)
  • CallableStatement.getTime(String)
  • CallableStatement.getTime(int, Calendar)
  • CallableStatement.getTime(int)
  • Date.getTime()
  • ResultSet.getTime(String, Calendar)
  • ResultSet.getTime(int, Calendar)
  • ResultSet.getTime(String)
  • ResultSet.getTime(int)
  • Timestamp.getTime()
  • ZipEntry.getTime()


getTimeDateFunctions

getTimeDateFunctions o7planning.org
  • DatabaseMetaData.getTimeDateFunctions()


getTimeDefinition

getTimeDefinition o7planning.org
  • ZoneOffsetTransitionRule.getTimeDefinition()


getTimeInMillis

getTimeInMillis o7planning.org
  • Calendar.getTimeInMillis()
  • Duration.getTimeInMillis(Date)
  • Duration.getTimeInMillis(Calendar)


getTimeInstance

getTimeInstance o7planning.org
  • DateFormat.getTimeInstance(int, Locale)
  • DateFormat.getTimeInstance(int)
  • DateFormat.getTimeInstance()
  • DateFormatProvider.getTimeInstance(int, Locale)


getTimeLimit

getTimeLimit o7planning.org
  • SearchControls.getTimeLimit()


getTimestamp

getTimestamp o7planning.org
  • CallableStatement.getTimestamp(String, Calendar)
  • CallableStatement.getTimestamp(String)
  • CallableStatement.getTimestamp(int, Calendar)
  • CallableStatement.getTimestamp(int)
  • CodeSigner.getTimestamp()
  • ResultSet.getTimestamp(String, Calendar)
  • ResultSet.getTimestamp(int, Calendar)
  • ResultSet.getTimestamp(String)
  • ResultSet.getTimestamp(int)
  • Timestamp.getTimestamp()


getTimeStamp

getTimeStamp o7planning.org
  • Event.getTimeStamp()
  • Notification.getTimeStamp()


getTimeToLive

getTimeToLive o7planning.org
  • DatagramSocketImpl.getTimeToLive()
  • MulticastSocket.getTimeToLive()
  • ResourceBundle.Control.getTimeToLive(String, Locale)


getTimeZone

getTimeZone o7planning.org
  • XMLGregorianCalendar.getTimeZone(int)


getTimezone

getTimezone o7planning.org
  • XMLGregorianCalendar.getTimezone()


getTimezoneOffset

getTimezoneOffset o7planning.org
  • Date.getTimezoneOffset()


getTipText

getTipText o7planning.org
  • JToolTip.getTipText()


getTitle

getTitle o7planning.org
  • BasicInternalFrameTitlePane.getTitle(String, FontMetrics, int)
  • Dialog.getTitle()
  • Frame.getTitle()
  • JInternalFrame.getTitle()
  • TitledBorder.getTitle()


getTitleAt

getTitleAt o7planning.org
  • JTabbedPane.getTitleAt(int)


getTitleColor

getTitleColor o7planning.org
  • TitledBorder.getTitleColor()


getTitledBorderText

getTitledBorderText o7planning.org
  • AbstractButton.AccessibleAbstractButton.getTitledBorderText()
  • AccessibleExtendedComponent.getTitledBorderText()
  • JComponent.AccessibleJComponent.getTitledBorderText()
  • JLabel.AccessibleJLabel.getTitledBorderText()


getTitleFont

getTitleFont o7planning.org
  • TitledBorder.getTitleFont()


getTitleJustification

getTitleJustification o7planning.org
  • TitledBorder.getTitleJustification()


getTitlePosition

getTitlePosition o7planning.org
  • TitledBorder.getTitlePosition()


getTLen

getTLen o7planning.org
  • GCMParameterSpec.getTLen()


getToggleButtonBorder

getToggleButtonBorder o7planning.org
  • BasicBorders.getToggleButtonBorder()
  • MetalBorders.getToggleButtonBorder()


getToggleClickCount

getToggleClickCount o7planning.org
  • JTree.getToggleClickCount()


getToIndex

getToIndex o7planning.org
  • TableColumnModelEvent.getToIndex()


getTokenThreshold

getTokenThreshold o7planning.org
  • HTMLDocument.getTokenThreshold()


getToolkit

getToolkit o7planning.org
  • Component.getToolkit()
  • Window.getToolkit()


getToolTip

getToolTip o7planning.org
  • TrayIcon.getToolTip()


getToolTipLocation

getToolTipLocation o7planning.org
  • JComponent.getToolTipLocation(MouseEvent)


getToolTipText

getToolTipText o7planning.org
  • AbstractButton.AccessibleAbstractButton.getToolTipText()
  • AccessibleExtendedComponent.getToolTipText()
  • BasicTextUI.getToolTipText(JTextComponent, Point)
  • ImageView.getToolTipText(float, float, Shape)
  • JComponent.getToolTipText(MouseEvent)
  • JComponent.getToolTipText()
  • JComponent.AccessibleJComponent.getToolTipText()
  • JLabel.AccessibleJLabel.getToolTipText()
  • JList.getToolTipText(MouseEvent)
  • JTabbedPane.getToolTipText(MouseEvent)
  • JTable.getToolTipText(MouseEvent)
  • JTableHeader.getToolTipText(MouseEvent)
  • JTextComponent.getToolTipText(MouseEvent)
  • JTree.getToolTipText(MouseEvent)
  • MultiTextUI.getToolTipText(JTextComponent, Point)
  • TextUI.getToolTipText(JTextComponent, Point)
  • View.getToolTipText(float, float, Shape)


getToolTipTextAt

getToolTipTextAt o7planning.org
  • JTabbedPane.getToolTipTextAt(int)


getToPage

getToPage o7planning.org
  • JobAttributes.getToPage()


getTopComponent

getTopComponent o7planning.org
  • JSplitPane.getTopComponent()


getTopInset

getTopInset o7planning.org
  • AsyncBoxView.getTopInset()
  • CompositeView.getTopInset()


getTopLevelAncestor

getTopLevelAncestor o7planning.org
  • JComponent.getTopLevelAncestor()


getTotalCapacity

getTotalCapacity o7planning.org
  • BufferPoolMXBean.getTotalCapacity()


getTotalColumnWidth

getTotalColumnWidth o7planning.org
  • DefaultTableColumnModel.getTotalColumnWidth()
  • TableColumnModel.getTotalColumnWidth()


getTotalCompilationTime

getTotalCompilationTime o7planning.org
  • CompilationMXBean.getTotalCompilationTime()


getTotalIn

getTotalIn o7planning.org
  • Deflater.getTotalIn()
  • Inflater.getTotalIn()


getTotalLoadedClassCount

getTotalLoadedClassCount o7planning.org
  • ClassLoadingMXBean.getTotalLoadedClassCount()


getTotalOut

getTotalOut o7planning.org
  • Deflater.getTotalOut()
  • Inflater.getTotalOut()


getTotalSeconds

getTotalSeconds o7planning.org
  • ZoneOffset.getTotalSeconds()


getTotalSize

getTotalSize o7planning.org
  • LSProgressEvent.getTotalSize()


getTotalSpace

getTotalSpace o7planning.org
  • File.getTotalSpace()
  • FileStore.getTotalSpace()


getTotalStartedThreadCount

getTotalStartedThreadCount o7planning.org
  • ThreadMXBean.getTotalStartedThreadCount()


getTrackBounds

getTrackBounds o7planning.org
  • BasicScrollBarUI.getTrackBounds()


getTrackLength

getTrackLength o7planning.org
  • MetalSliderUI.getTrackLength()


getTrackMute

getTrackMute o7planning.org
  • Sequencer.getTrackMute(int)


getTracks

getTracks o7planning.org
  • Sequence.getTracks()


getTrackSolo

getTrackSolo o7planning.org
  • Sequencer.getTrackSolo(int)


getTrackWidth

getTrackWidth o7planning.org
  • MetalSliderUI.getTrackWidth()


getTrafficClass

getTrafficClass o7planning.org
  • DatagramSocket.getTrafficClass()
  • Socket.getTrafficClass()


getTrailerField

getTrailerField o7planning.org
  • PSSParameterSpec.getTrailerField()


getTransactionIsolation

getTransactionIsolation o7planning.org
  • BaseRowSet.getTransactionIsolation()
  • Connection.getTransactionIsolation()
  • RowSet.getTransactionIsolation()


getTransactionTimeout

getTransactionTimeout o7planning.org
  • XAResource.getTransactionTimeout()


getTransferable

getTransferable o7planning.org
  • DragSourceContext.getTransferable()
  • DropTargetContext.getTransferable()
  • DropTargetDragEvent.getTransferable()
  • DropTargetDropEvent.getTransferable()
  • TransferHandler.TransferSupport.getTransferable()


getTransferData

getTransferData o7planning.org
  • DataContentHandler.getTransferData(DataFlavor, DataSource)
  • DataHandler.getTransferData(DataFlavor)
  • DropTargetContext.TransferableProxy.getTransferData(DataFlavor)
  • StringSelection.getTransferData(DataFlavor)
  • Transferable.getTransferData(DataFlavor)


getTransferDataFlavors

getTransferDataFlavors o7planning.org
  • DataContentHandler.getTransferDataFlavors()
  • DataHandler.getTransferDataFlavors()
  • DropTargetContext.TransferableProxy.getTransferDataFlavors()
  • StringSelection.getTransferDataFlavors()
  • Transferable.getTransferDataFlavors()


getTransferHandler

getTransferHandler o7planning.org
  • JApplet.getTransferHandler()
  • JComponent.getTransferHandler()
  • JDialog.getTransferHandler()
  • JFrame.getTransferHandler()
  • JWindow.getTransferHandler()


getTransferSize

getTransferSize o7planning.org
  • DataTruncation.getTransferSize()


getTransferType

getTransferType o7planning.org
  • ColorModel.getTransferType()
  • MultiPixelPackedSampleModel.getTransferType()
  • Raster.getTransferType()
  • SampleModel.getTransferType()


getTransform

getTransform o7planning.org
  • AffineTransformOp.getTransform()
  • Font.getTransform()
  • FontRenderContext.getTransform()
  • Graphics2D.getTransform()
  • MultipleGradientPaint.getTransform()
  • RenderContext.getTransform()
  • TransformAttribute.getTransform()


getTransformer

getTransformer o7planning.org
  • TransformerHandler.getTransformer()


getTransforms

getTransforms o7planning.org
  • Reference.getTransforms()
  • RetrievalMethod.getTransforms()


getTransformType

getTransformType o7planning.org
  • FontRenderContext.getTransformType()


getTransition

getTransition o7planning.org
  • ZoneRules.getTransition(LocalDateTime)


getTransitionRules

getTransitionRules o7planning.org
  • ZoneRules.getTransitionRules()


getTransitions

getTransitions o7planning.org
  • ZoneRules.getTransitions()


getTranslateInstance

getTranslateInstance o7planning.org
  • AffineTransform.getTranslateInstance(double, double)


getTranslateX

getTranslateX o7planning.org
  • AffineTransform.getTranslateX()


getTranslateY

getTranslateY o7planning.org
  • AffineTransform.getTranslateY()


getTransmitter

getTransmitter o7planning.org
  • MidiDevice.getTransmitter()
  • MidiSystem.getTransmitter()


getTransmitters

getTransmitters o7planning.org
  • MidiDevice.getTransmitters()


getTransparency

getTransparency o7planning.org
  • BufferedImage.getTransparency()
  • Color.getTransparency()
  • ColorModel.getTransparency()
  • GradientPaint.getTransparency()
  • IndexColorModel.getTransparency()
  • MultipleGradientPaint.getTransparency()
  • TexturePaint.getTransparency()
  • Transparency.getTransparency()
  • VolatileImage.getTransparency()


getTransparentPixel

getTransparentPixel o7planning.org
  • IndexColorModel.getTransparentPixel()


getTrayIcons

getTrayIcons o7planning.org
  • SystemTray.getTrayIcons()


getTrayIconSize

getTrayIconSize o7planning.org
  • SystemTray.getTrayIconSize()


getTRC

getTRC o7planning.org
  • ICC_ProfileGray.getTRC()
  • ICC_ProfileRGB.getTRC(int)


getTreeCellEditorComponent

getTreeCellEditorComponent o7planning.org
  • DefaultCellEditor.getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int)
  • DefaultTreeCellEditor.getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int)
  • TreeCellEditor.getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int)


getTreeCellRendererComponent

getTreeCellRendererComponent o7planning.org
  • DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean)
  • TreeCellRenderer.getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean)


getTreeComputerIcon

getTreeComputerIcon o7planning.org
  • MetalIconFactory.getTreeComputerIcon()


getTreeControlIcon

getTreeControlIcon o7planning.org
  • MetalIconFactory.getTreeControlIcon(boolean)


getTreeExpansionListeners

getTreeExpansionListeners o7planning.org
  • JTree.getTreeExpansionListeners()


getTreeFloppyDriveIcon

getTreeFloppyDriveIcon o7planning.org
  • MetalIconFactory.getTreeFloppyDriveIcon()


getTreeFolderIcon

getTreeFolderIcon o7planning.org
  • MetalIconFactory.getTreeFolderIcon()


getTreeHardDriveIcon

getTreeHardDriveIcon o7planning.org
  • MetalIconFactory.getTreeHardDriveIcon()


getTreeLeafIcon

getTreeLeafIcon o7planning.org
  • MetalIconFactory.getTreeLeafIcon()


getTreeLock

getTreeLock o7planning.org
  • Component.getTreeLock()
  • MenuComponent.getTreeLock()


getTreeModelListeners

getTreeModelListeners o7planning.org
  • DefaultTreeModel.getTreeModelListeners()


getTreePath

getTreePath o7planning.org
  • TreeModelEvent.getTreePath()


getTreeSelectionListeners

getTreeSelectionListeners o7planning.org
  • DefaultTreeSelectionModel.getTreeSelectionListeners()
  • JTree.getTreeSelectionListeners()


getTreeWillExpandListeners

getTreeWillExpandListeners o7planning.org
  • JTree.getTreeWillExpandListeners()


getTrigger

getTrigger o7planning.org
  • DragSourceContext.getTrigger()
  • MonitorNotification.getTrigger()


getTriggerEvent

getTriggerEvent o7planning.org
  • DragGestureEvent.getTriggerEvent()
  • DragGestureRecognizer.getTriggerEvent()


getTrustAnchor

getTrustAnchor o7planning.org
  • PKIXCertPathValidatorResult.getTrustAnchor()


getTrustAnchors

getTrustAnchors o7planning.org
  • PKIXParameters.getTrustAnchors()


getTrustedCert

getTrustedCert o7planning.org
  • TrustAnchor.getTrustedCert()


getTrustedCertificate

getTrustedCertificate o7planning.org
  • KeyStore.TrustedCertificateEntry.getTrustedCertificate()


getTrustManagers

getTrustManagers o7planning.org
  • TrustManagerFactory.getTrustManagers()


getTTL

getTTL o7planning.org
  • DatagramSocketImpl.getTTL()
  • MulticastSocket.getTTL()


getType

getType o7planning.org
  • AbstractDocument.DefaultDocumentEvent.getType()
  • AccessibleTableModelChange.getType()
  • AffineTransform.getType()
  • AnnotatedType.getType()
  • AttributeList.getType(String)
  • AttributeList.getType(int)
  • AttributeList.getType()
  • AttributeListImpl.getType(String)
  • AttributeListImpl.getType(int)
  • Attributes.getType(String)
  • Attributes.getType(String, String)
  • Attributes.getType(int)
  • AttributesImpl.getType(String)
  • AttributesImpl.getType(String, String)
  • AttributesImpl.getType(int)
  • AudioFileFormat.getType()
  • BaseRowSet.getType()
  • BufferedImage.getType()
  • CRL.getType()
  • CertPath.getType()
  • CertStore.getType()
  • Certificate.getType()
  • CertificateFactory.getType()
  • Character.getType(int)
  • Character.getType(char)
  • ColorSpace.getType()
  • CompositeType.getType(String)
  • Configuration.getType()
  • Control.getType()
  • Cursor.getType()
  • DOMError.getType()
  • DefaultStyledDocument.ElementSpec.getType()
  • DocumentEvent.getType()
  • Element.getType()
  • Entity.getType()
  • Event.getType()
  • Field.getType()
  • GlyphMetrics.getType()
  • GraphicsDevice.getType()
  • JTable.AccessibleJTable.AccessibleJTableModelChange.getType()
  • KeyStore.getType()
  • LineEvent.getType()
  • ListDataEvent.getType()
  • MBeanAttributeInfo.getType()
  • MBeanParameterInfo.getType()
  • MemoryPoolMXBean.getType()
  • MetaMessage.getType()
  • MidiFileFormat.getType()
  • NamingEvent.getType()
  • Notification.getType()
  • ObjectStreamField.getType()
  • Parameter.getType()
  • Policy.getType()
  • Provider.Service.getType()
  • Rdn.getType()
  • RefAddr.getType()
  • ResultSet.getType()
  • RowSorterEvent.getType()
  • SNIMatcher.getType()
  • SNIServerName.getType()
  • TableModelEvent.getType()
  • URIReference.getType()
  • Window.getType()


getTypeArguments

getTypeArguments o7planning.org
  • DeclaredType.getTypeArguments()


getTypeCode

getTypeCode o7planning.org
  • ObjectStreamField.getTypeCode()


getTypeDescription

getTypeDescription o7planning.org
  • BasicFileChooserUI.BasicFileView.getTypeDescription(File)
  • FileView.getTypeDescription(File)
  • JFileChooser.getTypeDescription(File)


getTypeElement

getTypeElement o7planning.org
  • Elements.getTypeElement(CharSequence)


getTypeInfo

getTypeInfo o7planning.org
  • DatabaseMetaData.getTypeInfo()


getTypeInfoProvider

getTypeInfoProvider o7planning.org
  • ValidatorHandler.getTypeInfoProvider()


getTypeMap

getTypeMap o7planning.org
  • BaseRowSet.getTypeMap()
  • Connection.getTypeMap()
  • RowSet.getTypeMap()


getTypeMirror

getTypeMirror o7planning.org
  • MirroredTypeException.getTypeMirror()


getTypeMirrors

getTypeMirrors o7planning.org
  • MirroredTypesException.getTypeMirrors()


getTypeName

getTypeName o7planning.org
  • Class.getTypeName()
  • OpenType.getTypeName()
  • Type.getTypeName()
  • TypeInfo.getTypeName()


getTypeNamespace

getTypeNamespace o7planning.org
  • TypeInfo.getTypeNamespace()


getTypeParameters

getTypeParameters o7planning.org
  • Class.getTypeParameters()
  • Constructor.getTypeParameters()
  • Executable.getTypeParameters()
  • ExecutableElement.getTypeParameters()
  • GenericDeclaration.getTypeParameters()
  • Method.getTypeParameters()
  • Parameterizable.getTypeParameters()
  • TypeElement.getTypeParameters()


getTypeString

getTypeString o7planning.org
  • ObjectStreamField.getTypeString()


getTypeUtils

getTypeUtils o7planning.org
  • ProcessingEnvironment.getTypeUtils()


getTypeVariables

getTypeVariables o7planning.org
  • ExecutableType.getTypeVariables()


getUDTs

getUDTs o7planning.org
  • DatabaseMetaData.getUDTs(String, String, String, int[])


getUI

getUI o7planning.org
  • AbstractButton.getUI()
  • JColorChooser.getUI()
  • JComboBox.getUI()
  • JDesktopPane.getUI()
  • JFileChooser.getUI()
  • JInternalFrame.getUI()
  • JInternalFrame.JDesktopIcon.getUI()
  • JLabel.getUI()
  • JLayer.getUI()
  • JList.getUI()
  • JMenuBar.getUI()
  • JOptionPane.getUI()
  • JPanel.getUI()
  • JPopupMenu.getUI()
  • JProgressBar.getUI()
  • JRootPane.getUI()
  • JScrollBar.getUI()
  • JScrollPane.getUI()
  • JSeparator.getUI()
  • JSlider.getUI()
  • JSpinner.getUI()
  • JSplitPane.getUI()
  • JTabbedPane.getUI()
  • JTable.getUI()
  • JTableHeader.getUI()
  • JTextComponent.getUI()
  • JToolBar.getUI()
  • JToolTip.getUI()
  • JTree.getUI()
  • JViewport.getUI()
  • ServiceUIFactory.getUI(int, String)
  • UIDefaults.getUI(JComponent)
  • UIManager.getUI(JComponent)


getUIActionMap

getUIActionMap o7planning.org
  • SwingUtilities.getUIActionMap(JComponent)


getUIClass

getUIClass o7planning.org
  • UIDefaults.getUIClass(String)
  • UIDefaults.getUIClass(String, ClassLoader)


getUIClassID

getUIClassID o7planning.org
  • JButton.getUIClassID()
  • JCheckBox.getUIClassID()
  • JCheckBoxMenuItem.getUIClassID()
  • JColorChooser.getUIClassID()
  • JComboBox.getUIClassID()
  • JComponent.getUIClassID()
  • JDesktopPane.getUIClassID()
  • JEditorPane.getUIClassID()
  • JFileChooser.getUIClassID()
  • JFormattedTextField.getUIClassID()
  • JInternalFrame.getUIClassID()
  • JInternalFrame.JDesktopIcon.getUIClassID()
  • JLabel.getUIClassID()
  • JList.getUIClassID()
  • JMenu.getUIClassID()
  • JMenuBar.getUIClassID()
  • JMenuItem.getUIClassID()
  • JOptionPane.getUIClassID()
  • JPanel.getUIClassID()
  • JPasswordField.getUIClassID()
  • JPopupMenu.getUIClassID()
  • JPopupMenu.Separator.getUIClassID()
  • JProgressBar.getUIClassID()
  • JRadioButton.getUIClassID()
  • JRadioButtonMenuItem.getUIClassID()
  • JRootPane.getUIClassID()
  • JScrollBar.getUIClassID()
  • JScrollPane.getUIClassID()
  • JSeparator.getUIClassID()
  • JSlider.getUIClassID()
  • JSpinner.getUIClassID()
  • JSplitPane.getUIClassID()
  • JTabbedPane.getUIClassID()
  • JTable.getUIClassID()
  • JTableHeader.getUIClassID()
  • JTextArea.getUIClassID()
  • JTextField.getUIClassID()
  • JTextPane.getUIClassID()
  • JToggleButton.getUIClassID()
  • JToolBar.getUIClassID()
  • JToolBar.Separator.getUIClassID()
  • JToolTip.getUIClassID()
  • JTree.getUIClassID()
  • JViewport.getUIClassID()


getUIClassNamesForRole

getUIClassNamesForRole o7planning.org
  • ServiceUIFactory.getUIClassNamesForRole(int)


getUIError

getUIError o7planning.org
  • UIDefaults.getUIError(String)


getUIInputMap

getUIInputMap o7planning.org
  • SwingUtilities.getUIInputMap(JComponent, int)


getUIs

getUIs o7planning.org
  • MultiButtonUI.getUIs()
  • MultiColorChooserUI.getUIs()
  • MultiComboBoxUI.getUIs()
  • MultiDesktopIconUI.getUIs()
  • MultiDesktopPaneUI.getUIs()
  • MultiFileChooserUI.getUIs()
  • MultiInternalFrameUI.getUIs()
  • MultiLabelUI.getUIs()
  • MultiListUI.getUIs()
  • MultiMenuBarUI.getUIs()
  • MultiMenuItemUI.getUIs()
  • MultiOptionPaneUI.getUIs()
  • MultiPanelUI.getUIs()
  • MultiPopupMenuUI.getUIs()
  • MultiProgressBarUI.getUIs()
  • MultiRootPaneUI.getUIs()
  • MultiScrollBarUI.getUIs()
  • MultiScrollPaneUI.getUIs()
  • MultiSeparatorUI.getUIs()
  • MultiSliderUI.getUIs()
  • MultiSpinnerUI.getUIs()
  • MultiSplitPaneUI.getUIs()
  • MultiTabbedPaneUI.getUIs()
  • MultiTableHeaderUI.getUIs()
  • MultiTableUI.getUIs()
  • MultiTextUI.getUIs()
  • MultiToolBarUI.getUIs()
  • MultiToolTipUI.getUIs()
  • MultiTreeUI.getUIs()
  • MultiViewportUI.getUIs()


getUnallocatedSpace

getUnallocatedSpace o7planning.org
  • FileStore.getUnallocatedSpace()


getUnarrivedParties

getUnarrivedParties o7planning.org
  • Phaser.getUnarrivedParties()


getUnboundInstance

getUnboundInstance o7planning.org
  • KeyTab.getUnboundInstance()
  • KeyTab.getUnboundInstance(File)


getUncaughtExceptionHandler

getUncaughtExceptionHandler o7planning.org
  • ForkJoinPool.getUncaughtExceptionHandler()
  • Thread.getUncaughtExceptionHandler()


getUndeclaredThrowable

getUndeclaredThrowable o7planning.org
  • UndeclaredThrowableException.getUndeclaredThrowable()


getUnderlineOffset

getUnderlineOffset o7planning.org
  • LineMetrics.getUnderlineOffset()


getUnderlineThickness

getUnderlineThickness o7planning.org
  • LineMetrics.getUnderlineThickness()


getUndoableEditListeners

getUndoableEditListeners o7planning.org
  • AbstractDocument.getUndoableEditListeners()
  • UndoableEditSupport.getUndoableEditListeners()


getUndoOrRedoPresentationName

getUndoOrRedoPresentationName o7planning.org
  • UndoManager.getUndoOrRedoPresentationName()


getUndoPresentationName

getUndoPresentationName o7planning.org
  • AbstractDocument.DefaultDocumentEvent.getUndoPresentationName()
  • AbstractUndoableEdit.getUndoPresentationName()
  • CompoundEdit.getUndoPresentationName()
  • UndoManager.getUndoPresentationName()
  • UndoableEdit.getUndoPresentationName()


getUnexecutedModifications

getUnexecutedModifications o7planning.org
  • AttributeModificationException.getUnexecutedModifications()


getUnicodeLocaleAttributes

getUnicodeLocaleAttributes o7planning.org
  • Locale.getUnicodeLocaleAttributes()


getUnicodeLocaleKeys

getUnicodeLocaleKeys o7planning.org
  • Locale.getUnicodeLocaleKeys()


getUnicodeLocaleType

getUnicodeLocaleType o7planning.org
  • Locale.getUnicodeLocaleType(String)


getUnicodeStream

getUnicodeStream o7planning.org
  • ResultSet.getUnicodeStream(String)
  • ResultSet.getUnicodeStream(int)


getUnitIncrement

getUnitIncrement o7planning.org
  • Adjustable.getUnitIncrement()
  • JScrollBar.getUnitIncrement()
  • JScrollBar.getUnitIncrement(int)
  • JScrollPane.ScrollBar.getUnitIncrement(int)
  • ScrollPaneAdjustable.getUnitIncrement()
  • Scrollbar.getUnitIncrement()


getUnits

getUnits o7planning.org
  • ChronoPeriod.getUnits()
  • Duration.getUnits()
  • FloatControl.getUnits()
  • Period.getUnits()
  • TemporalAmount.getUnits()


getUnitsToScroll

getUnitsToScroll o7planning.org
  • MouseWheelEvent.getUnitsToScroll()


getUnknownAnnotationValue

getUnknownAnnotationValue o7planning.org
  • UnknownAnnotationValueException.getUnknownAnnotationValue()


getUnknownElement

getUnknownElement o7planning.org
  • UnknownElementException.getUnknownElement()


getUnknownType

getUnknownType o7planning.org
  • UnknownTypeException.getUnknownType()


getUnloadedClassCount

getUnloadedClassCount o7planning.org
  • ClassLoadingMXBean.getUnloadedClassCount()


getUnmarshallerHandler

getUnmarshallerHandler o7planning.org
  • Unmarshaller.getUnmarshallerHandler()


getUnnormalizedComponents

getUnnormalizedComponents o7planning.org
  • ColorModel.getUnnormalizedComponents(float[], int, int[], int)
  • ComponentColorModel.getUnnormalizedComponents(float[], int, int[], int)


getUnresolvedActions

getUnresolvedActions o7planning.org
  • UnresolvedPermission.getUnresolvedActions()


getUnresolvedCerts

getUnresolvedCerts o7planning.org
  • UnresolvedPermission.getUnresolvedCerts()


getUnresolvedName

getUnresolvedName o7planning.org
  • UnresolvedPermission.getUnresolvedName()


getUnresolvedType

getUnresolvedType o7planning.org
  • UnresolvedPermission.getUnresolvedType()


getUnsupportedAttributes

getUnsupportedAttributes o7planning.org
  • AttributeException.getUnsupportedAttributes()
  • PrintService.getUnsupportedAttributes(DocFlavor, AttributeSet)


getUnsupportedFlavors

getUnsupportedFlavors o7planning.org
  • FlavorException.getUnsupportedFlavors()


getUnsupportedURI

getUnsupportedURI o7planning.org
  • URIException.getUnsupportedURI()


getUnsupportedValues

getUnsupportedValues o7planning.org
  • AttributeException.getUnsupportedValues()


getUnwrappedParent

getUnwrappedParent o7planning.org
  • SwingUtilities.getUnwrappedParent(Component)


getUnwrappedView

getUnwrappedView o7planning.org
  • SwingUtilities.getUnwrappedView(JViewport)


getUpdateAction

getUpdateAction o7planning.org
  • BasicFileChooserUI.getUpdateAction()


getUpdateCount

getUpdateCount o7planning.org
  • Statement.getUpdateCount()


getUpdateCounts

getUpdateCounts o7planning.org
  • BatchUpdateException.getUpdateCounts()


getUpdateLevel

getUpdateLevel o7planning.org
  • UndoableEditSupport.getUpdateLevel()


getUpdatePeriod

getUpdatePeriod o7planning.org
  • FloatControl.getUpdatePeriod()


getUpdatePolicy

getUpdatePolicy o7planning.org
  • DefaultCaret.getUpdatePolicy()


getUpdateRect

getUpdateRect o7planning.org
  • PaintEvent.getUpdateRect()


getUpdateSelectionOnSort

getUpdateSelectionOnSort o7planning.org
  • JTable.getUpdateSelectionOnSort()


getUpdateTableInRealTime

getUpdateTableInRealTime o7planning.org
  • JTableHeader.getUpdateTableInRealTime()


getUpperBound

getUpperBound o7planning.org
  • TypeVariable.getUpperBound()


getUpperBounds

getUpperBounds o7planning.org
  • WildcardType.getUpperBounds()


getUptime

getUptime o7planning.org
  • RuntimeMXBean.getUptime()


getURI

getURI o7planning.org
  • Attributes.getURI(int)
  • AttributesImpl.getURI(int)
  • NamespaceSupport.getURI(String)


getUri

getUri o7planning.org
  • DOMLocator.getUri()


getURIDereferencer

getURIDereferencer o7planning.org
  • DOMCryptoContext.getURIDereferencer()
  • KeyInfoFactory.getURIDereferencer()
  • XMLCryptoContext.getURIDereferencer()
  • XMLSignatureFactory.getURIDereferencer()


getURIReference

getURIReference o7planning.org
  • URIReferenceException.getURIReference()


getURIResolver

getURIResolver o7planning.org
  • Transformer.getURIResolver()
  • TransformerFactory.getURIResolver()


getURIs

getURIs o7planning.org
  • CookieStore.getURIs()


getURL

getURL o7planning.org
  • HyperlinkEvent.getURL()
  • ValidationEventLocator.getURL()
  • ValidationEventLocatorImpl.getURL()


getUrl

getUrl o7planning.org
  • BaseRowSet.getUrl()
  • RowSet.getUrl()


getURLContext

getURLContext o7planning.org
  • NamingManager.getURLContext(String, Hashtable<?, ?>)


getUrlDecoder

getUrlDecoder o7planning.org
  • Base64.getUrlDecoder()


getUrlEncoder

getUrlEncoder o7planning.org
  • Base64.getUrlEncoder()


getURLOrDefaultInitCtx

getURLOrDefaultInitCtx o7planning.org
  • InitialContext.getURLOrDefaultInitCtx(Name)
  • InitialContext.getURLOrDefaultInitCtx(String)


getURLPath

getURLPath o7planning.org
  • JMXServiceURL.getURLPath()


getURLs

getURLs o7planning.org
  • MLet.getURLs()
  • MLetMBean.getURLs()
  • URLClassLoader.getURLs()


getUsableSpace

getUsableSpace o7planning.org
  • File.getUsableSpace()
  • FileStore.getUsableSpace()


getUsage

getUsage o7planning.org
  • GSSCredential.getUsage(Oid)
  • GSSCredential.getUsage()
  • MemoryNotificationInfo.getUsage()
  • MemoryPoolMXBean.getUsage()


getUsageThreshold

getUsageThreshold o7planning.org
  • MemoryPoolMXBean.getUsageThreshold()


getUsageThresholdCount

getUsageThresholdCount o7planning.org
  • MemoryPoolMXBean.getUsageThresholdCount()


getUseCache

getUseCache o7planning.org
  • ImageIO.getUseCache()


getUseCaches

getUseCaches o7planning.org
  • URLConnection.getUseCaches()


getUseCipherSuitesOrder

getUseCipherSuitesOrder o7planning.org
  • SSLParameters.getUseCipherSuitesOrder()


getUseClientMode

getUseClientMode o7planning.org
  • SSLEngine.getUseClientMode()
  • SSLServerSocket.getUseClientMode()
  • SSLSocket.getUseClientMode()


getUsed

getUsed o7planning.org
  • MemoryUsage.getUsed()


getUseParentHandlers

getUseParentHandlers o7planning.org
  • Logger.getUseParentHandlers()


getUserAction

getUserAction o7planning.org
  • DragSourceDragEvent.getUserAction()


getUserData

getUserData o7planning.org
  • IIOMetadataNode.getUserData(String)
  • Node.getUserData(String)
  • Notification.getUserData()


getUserDropAction

getUserDropAction o7planning.org
  • TransferHandler.TransferSupport.getUserDropAction()


getUserInfo

getUserInfo o7planning.org
  • URI.getUserInfo()
  • URL.getUserInfo()


getUserName

getUserName o7planning.org
  • DatabaseMetaData.getUserName()
  • PasswordAuthentication.getUserName()
  • PrinterJob.getUserName()


getUsername

getUsername o7planning.org
  • BaseRowSet.getUsername()
  • RowSet.getUsername()


getUserObject

getUserObject o7planning.org
  • DefaultMutableTreeNode.getUserObject()
  • IIOMetadataNode.getUserObject()


getUserObjectPath

getUserObjectPath o7planning.org
  • DefaultMutableTreeNode.getUserObjectPath()


getUserPrincipal

getUserPrincipal o7planning.org
  • HttpExchange.getUserPrincipal()
  • WebServiceContext.getUserPrincipal()


getUserPrincipalLookupService

getUserPrincipalLookupService o7planning.org
  • FileSystem.getUserPrincipalLookupService()


getUserTextColor

getUserTextColor o7planning.org
  • MetalLookAndFeel.getUserTextColor()
  • MetalTheme.getUserTextColor()


getUserTextFont

getUserTextFont o7planning.org
  • DefaultMetalTheme.getUserTextFont()
  • MetalLookAndFeel.getUserTextFont()
  • MetalTheme.getUserTextFont()


getUtf16Offset

getUtf16Offset o7planning.org
  • DOMLocator.getUtf16Offset()


getVAdjustable

getVAdjustable o7planning.org
  • ScrollPane.getVAdjustable()


getValidCharacters

getValidCharacters o7planning.org
  • MaskFormatter.getValidCharacters()


getValidOffsets

getValidOffsets o7planning.org
  • ZoneRules.getValidOffsets(LocalDateTime)


getValidPixels

getValidPixels o7planning.org
  • IndexColorModel.getValidPixels()


getValidPolicy

getValidPolicy o7planning.org
  • PolicyNode.getValidPolicy()


getValue

getValue o7planning.org
  • AbstractAction.getValue(String)
  • AbstractMap.SimpleEntry.getValue()
  • AbstractMap.SimpleImmutableEntry.getValue()
  • Action.getValue(String)
  • Adjustable.getValue()
  • AdjustmentEvent.getValue()
  • Adler32.getValue()
  • Annotation.getValue()
  • AnnotationValue.getValue()
  • Attr.getValue()
  • Attribute.getValue()
  • Attribute.getValue()
  • AttributeList.getValue(String)
  • AttributeList.getValue(int)
  • AttributeList.getValue()
  • AttributeListImpl.getValue(String)
  • AttributeListImpl.getValue(int)
  • Attributes.getValue(String)
  • Attributes.getValue(String, String)
  • Attributes.getValue(int)
  • Attributes.getValue(Attributes.Name)
  • Attributes.getValue(String)
  • AttributesImpl.getValue(String)
  • AttributesImpl.getValue(String, String)
  • AttributesImpl.getValue(int)
  • BooleanControl.getValue()
  • BoundedRangeModel.getValue()
  • CRC32.getValue()
  • Checksum.getValue()
  • Completion.getValue()
  • DateTimeSyntax.getValue()
  • DayOfWeek.getValue()
  • DefaultBoundedRangeModel.getValue()
  • EnumControl.getValue()
  • EnumSyntax.getValue()
  • Era.getValue()
  • Expression.getValue()
  • Extension.getValue()
  • FeatureDescriptor.getValue(String)
  • FloatControl.getValue()
  • HijrahEra.getValue()
  • HttpCookie.getValue()
  • IntegerSyntax.getValue()
  • IsoEra.getValue()
  • JAXBElement.getValue()
  • JAXBIntrospector.getValue(Object)
  • JFormattedTextField.getValue()
  • JOptionPane.getValue()
  • JProgressBar.getValue()
  • JScrollBar.getValue()
  • JSlider.getValue()
  • JSpinner.getValue()
  • JapaneseEra.getValue()
  • KeyStore.Entry.Attribute.getValue()
  • Lease.getValue()
  • Map.Entry.getValue()
  • MimeHeader.getValue()
  • MinguoEra.getValue()
  • Month.getValue()
  • Node.getValue()
  • Option.getValue()
  • PKCS12Attribute.getValue()
  • PSource.PSpecified.getValue()
  • PropertyEditor.getValue()
  • PropertyEditorSupport.getValue()
  • Rdn.getValue()
  • RowFilter.Entry.getValue(int)
  • SSLSession.getValue(String)
  • ScrollPaneAdjustable.getValue()
  • Scrollbar.getValue()
  • SpinnerDateModel.getValue()
  • SpinnerListModel.getValue()
  • SpinnerModel.getValue()
  • SpinnerNumberModel.getValue()
  • Spring.getValue()
  • StringValueExp.getValue()
  • TextSyntax.getValue()
  • ThaiBuddhistEra.getValue()
  • XMLSignature.SignatureValue.getValue()
  • Year.getValue()


getValueAt

getValueAt o7planning.org
  • DefaultRowSorter.ModelWrapper.getValueAt(int, int)
  • DefaultTableModel.getValueAt(int, int)
  • JTable.getValueAt(int, int)
  • TableModel.getValueAt(int, int)


getValueClass

getValueClass o7planning.org
  • DefaultFormatter.getValueClass()


getValueContainsLiteralCharacters

getValueContainsLiteralCharacters o7planning.org
  • MaskFormatter.getValueContainsLiteralCharacters()


getValueCount

getValueCount o7planning.org
  • RowFilter.Entry.getValueCount()


getValueIsAdjusting

getValueIsAdjusting o7planning.org
  • AdjustmentEvent.getValueIsAdjusting()
  • BoundedRangeModel.getValueIsAdjusting()
  • DefaultBoundedRangeModel.getValueIsAdjusting()
  • DefaultListSelectionModel.getValueIsAdjusting()
  • JList.getValueIsAdjusting()
  • JScrollBar.getValueIsAdjusting()
  • JSlider.getValueIsAdjusting()
  • ListSelectionEvent.getValueIsAdjusting()
  • ListSelectionModel.getValueIsAdjusting()
  • ScrollPaneAdjustable.getValueIsAdjusting()
  • Scrollbar.getValueIsAdjusting()


getValueNames

getValueNames o7planning.org
  • SSLSession.getValueNames()


getValues

getValues o7planning.org
  • AttributeList.getValues()
  • EnumControl.getValues()
  • JPEGHuffmanTable.getValues()


getVariant

getVariant o7planning.org
  • Locale.getVariant()


getVariation

getVariation o7planning.org
  • InputMethodHighlight.getVariation()


getVendor

getVendor o7planning.org
  • JDBCType.getVendor()
  • MidiDevice.Info.getVendor()
  • Mixer.Info.getVendor()
  • SQLType.getVendor()
  • Soundbank.getVendor()
  • SyncProvider.getVendor()


getVendorName

getVendorName o7planning.org
  • IIOServiceProvider.getVendorName()


getVendorTypeNumber

getVendorTypeNumber o7planning.org
  • JDBCType.getVendorTypeNumber()
  • SQLType.getVendorTypeNumber()


getVerifyInputWhenFocusTarget

getVerifyInputWhenFocusTarget o7planning.org
  • JComponent.getVerifyInputWhenFocusTarget()


getVersion

getVersion o7planning.org
  • HttpCookie.getVersion()
  • IIOServiceProvider.getVersion()
  • MLetContent.getVersion()
  • MidiDevice.Info.getVersion()
  • Mixer.Info.getVersion()
  • OpenType.getVersion()
  • OperatingSystemMXBean.getVersion()
  • Provider.getVersion()
  • RC5ParameterSpec.getVersion()
  • RMIServer.getVersion()
  • RMIServerImpl.getVersion()
  • RMIServerImpl_Stub.getVersion()
  • Soundbank.getVersion()
  • StartDocument.getVersion()
  • StreamReaderDelegate.getVersion()
  • SyncProvider.getVersion()
  • X509CRL.getVersion()
  • X509Certificate.getVersion()
  • X509Certificate.getVersion()
  • XMLStreamReader.getVersion()


getVersionColumns

getVersionColumns o7planning.org
  • DatabaseMetaData.getVersionColumns(String, String, String)


getVersionNumber

getVersionNumber o7planning.org
  • KerberosKey.getVersionNumber()


getVersions

getVersions o7planning.org
  • ZoneRulesProvider.getVersions(String)


getVerticalAlignment

getVerticalAlignment o7planning.org
  • AbstractButton.getVerticalAlignment()
  • JLabel.getVerticalAlignment()


getVerticalLegBuffer

getVerticalLegBuffer o7planning.org
  • BasicTreeUI.getVerticalLegBuffer()


getVerticalScrollBar

getVerticalScrollBar o7planning.org
  • JScrollPane.getVerticalScrollBar()
  • ScrollPaneLayout.getVerticalScrollBar()


getVerticalScrollBarPolicy

getVerticalScrollBarPolicy o7planning.org
  • JScrollPane.getVerticalScrollBarPolicy()
  • ScrollPaneLayout.getVerticalScrollBarPolicy()


getVerticalSliderThumbIcon

getVerticalSliderThumbIcon o7planning.org
  • MetalIconFactory.getVerticalSliderThumbIcon()


getVerticalTextPosition

getVerticalTextPosition o7planning.org
  • AbstractButton.getVerticalTextPosition()
  • JLabel.getVerticalTextPosition()


getVetoableChangeListeners

getVetoableChangeListeners o7planning.org
  • JComponent.getVetoableChangeListeners()
  • KeyboardFocusManager.getVetoableChangeListeners(String)
  • KeyboardFocusManager.getVetoableChangeListeners()
  • VetoableChangeSupport.getVetoableChangeListeners(String)
  • VetoableChangeSupport.getVetoableChangeListeners()


getVgap

getVgap o7planning.org
  • BorderLayout.getVgap()
  • CardLayout.getVgap()
  • FlowLayout.getVgap()
  • GridLayout.getVgap()


getView

getView o7planning.org
  • AsyncBoxView.getView(int)
  • CompositeView.getView(int)
  • JLayer.getView()
  • JViewport.getView()
  • UIEvent.getView()
  • View.getView(int)


getViewAtPoint

getViewAtPoint o7planning.org
  • BoxView.getViewAtPoint(int, int, Rectangle)
  • CompositeView.getViewAtPoint(int, int, Rectangle)


getViewAtPosition

getViewAtPosition o7planning.org
  • CompositeView.getViewAtPosition(int, Rectangle)
  • TableView.getViewAtPosition(int, Rectangle)
  • TableView.TableRow.getViewAtPosition(int, Rectangle)


getViewAttributes

getViewAttributes o7planning.org
  • StyleSheet.getViewAttributes(View)


getViewCount

getViewCount o7planning.org
  • AsyncBoxView.getViewCount()
  • CompositeView.getViewCount()
  • View.getViewCount()


getViewFactory

getViewFactory o7planning.org
  • DefaultEditorKit.getViewFactory()
  • EditorKit.getViewFactory()
  • HTMLEditorKit.getViewFactory()
  • StyledEditorKit.getViewFactory()
  • View.getViewFactory()


getViewIndex

getViewIndex o7planning.org
  • AsyncBoxView.getViewIndex(int, Position.Bias)
  • CompositeView.getViewIndex(int, Position.Bias)
  • View.getViewIndex(float, float, Shape)
  • View.getViewIndex(int, Position.Bias)


getViewIndexAtPoint

getViewIndexAtPoint o7planning.org
  • AsyncBoxView.ChildLocator.getViewIndexAtPoint(float, float, Shape)


getViewIndexAtPosition

getViewIndexAtPosition o7planning.org
  • AsyncBoxView.getViewIndexAtPosition(int, Position.Bias)
  • CompositeView.getViewIndexAtPosition(int)
  • FlowView.getViewIndexAtPosition(int)
  • ZoneView.getViewIndexAtPosition(int)


getViewIndexAtVisualOffset

getViewIndexAtVisualOffset o7planning.org
  • AsyncBoxView.ChildLocator.getViewIndexAtVisualOffset(float)


getViewport

getViewport o7planning.org
  • JScrollPane.getViewport()
  • ScrollPaneLayout.getViewport()


getViewportBorder

getViewportBorder o7planning.org
  • JScrollPane.getViewportBorder()


getViewportBorderBounds

getViewportBorderBounds o7planning.org
  • JScrollPane.getViewportBorderBounds()
  • ScrollPaneLayout.getViewportBorderBounds(JScrollPane)


getViewportSize

getViewportSize o7planning.org
  • ScrollPane.getViewportSize()


getViewPosition

getViewPosition o7planning.org
  • JViewport.getViewPosition()


getViewRect

getViewRect o7planning.org
  • JViewport.getViewRect()


getViewRowCount

getViewRowCount o7planning.org
  • DefaultRowSorter.getViewRowCount()
  • RowSorter.getViewRowCount()


getViewSize

getViewSize o7planning.org
  • JViewport.getViewSize()


getVisible

getVisible o7planning.org
  • Scrollbar.getVisible()


getVisibleAdvance

getVisibleAdvance o7planning.org
  • TextLayout.getVisibleAdvance()


getVisibleAmount

getVisibleAmount o7planning.org
  • Adjustable.getVisibleAmount()
  • JScrollBar.getVisibleAmount()
  • ScrollPaneAdjustable.getVisibleAmount()
  • Scrollbar.getVisibleAmount()


getVisibleChildCount

getVisibleChildCount o7planning.org
  • AbstractLayoutCache.getVisibleChildCount(TreePath)
  • FixedHeightLayoutCache.getVisibleChildCount(TreePath)
  • VariableHeightLayoutCache.getVisibleChildCount(TreePath)


getVisibleComponent

getVisibleComponent o7planning.org
  • BasicTabbedPaneUI.getVisibleComponent()


getVisibleEditorRect

getVisibleEditorRect o7planning.org
  • BasicTextUI.getVisibleEditorRect()


getVisibleIndex

getVisibleIndex o7planning.org
  • List.getVisibleIndex()


getVisibleNamespacePrefixes

getVisibleNamespacePrefixes o7planning.org
  • SOAPElement.getVisibleNamespacePrefixes()


getVisiblePathsFrom

getVisiblePathsFrom o7planning.org
  • AbstractLayoutCache.getVisiblePathsFrom(TreePath)
  • FixedHeightLayoutCache.getVisiblePathsFrom(TreePath)
  • VariableHeightLayoutCache.getVisiblePathsFrom(TreePath)


getVisiblePosition

getVisiblePosition o7planning.org
  • InputMethodEvent.getVisiblePosition()


getVisibleRect

getVisibleRect o7planning.org
  • JComponent.getVisibleRect()


getVisibleRowCount

getVisibleRowCount o7planning.org
  • JList.getVisibleRowCount()
  • JTree.getVisibleRowCount()


getVisualBounds

getVisualBounds o7planning.org
  • GlyphVector.getVisualBounds()


getVisualHighlightShape

getVisualHighlightShape o7planning.org
  • TextLayout.getVisualHighlightShape(TextHitInfo, TextHitInfo)
  • TextLayout.getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D)


getVisualOtherHit

getVisualOtherHit o7planning.org
  • TextLayout.getVisualOtherHit(TextHitInfo)


getVisualRepresentation

getVisualRepresentation o7planning.org
  • TransferHandler.getVisualRepresentation(Transferable)


getVMID

getVMID o7planning.org
  • Lease.getVMID()


getVmName

getVmName o7planning.org
  • RuntimeMXBean.getVmName()


getVmVendor

getVmVendor o7planning.org
  • RuntimeMXBean.getVmVendor()


getVmVersion

getVmVersion o7planning.org
  • RuntimeMXBean.getVmVersion()


getVoiceStatus

getVoiceStatus o7planning.org
  • Synthesizer.getVoiceStatus()


getVolatileOffscreenBuffer

getVolatileOffscreenBuffer o7planning.org
  • RepaintManager.getVolatileOffscreenBuffer(Component, int, int)


getVScrollbarWidth

getVScrollbarWidth o7planning.org
  • ScrollPane.getVScrollbarWidth()


getW

getW o7planning.org
  • ECPublicKey.getW()
  • ECPublicKeySpec.getW()


getWaitedCount

getWaitedCount o7planning.org
  • ThreadInfo.getWaitedCount()


getWaitedTime

getWaitedTime o7planning.org
  • ThreadInfo.getWaitedTime()


getWaitingConsumerCount

getWaitingConsumerCount o7planning.org
  • LinkedTransferQueue.getWaitingConsumerCount()
  • TransferQueue.getWaitingConsumerCount()


getWaitingThreads

getWaitingThreads o7planning.org
  • AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject)
  • AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads()
  • AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject)
  • AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads()
  • ReentrantLock.getWaitingThreads(Condition)
  • ReentrantReadWriteLock.getWaitingThreads(Condition)


getWaitQueueLength

getWaitQueueLength o7planning.org
  • AbstractQueuedLongSynchronizer.getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject)
  • AbstractQueuedLongSynchronizer.ConditionObject.getWaitQueueLength()
  • AbstractQueuedSynchronizer.getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject)
  • AbstractQueuedSynchronizer.ConditionObject.getWaitQueueLength()
  • ReentrantLock.getWaitQueueLength(Condition)
  • ReentrantReadWriteLock.getWaitQueueLength(Condition)


getWantClientAuth

getWantClientAuth o7planning.org
  • SSLEngine.getWantClientAuth()
  • SSLParameters.getWantClientAuth()
  • SSLServerSocket.getWantClientAuth()
  • SSLSocket.getWantClientAuth()


getWantsInput

getWantsInput o7planning.org
  • JOptionPane.getWantsInput()


getWarnings

getWarnings o7planning.org
  • Connection.getWarnings()
  • ResultSet.getWarnings()
  • Statement.getWarnings()


getWarningString

getWarningString o7planning.org
  • JInternalFrame.getWarningString()
  • Window.getWarningString()


getWeekdays

getWeekdays o7planning.org
  • DateFormatSymbols.getWeekdays()


getWeeksInWeekYear

getWeeksInWeekYear o7planning.org
  • Calendar.getWeeksInWeekYear()
  • GregorianCalendar.getWeeksInWeekYear()


getWeekYear

getWeekYear o7planning.org
  • Calendar.getWeekYear()
  • GregorianCalendar.getWeekYear()


getWeight

getWeight o7planning.org
  • Locale.LanguageRange.getWeight()


getWestPane

getWestPane o7planning.org
  • BasicInternalFrameUI.getWestPane()


getWhatToShow

getWhatToShow o7planning.org
  • LSParserFilter.getWhatToShow()
  • LSSerializerFilter.getWhatToShow()


getWheelRotation

getWheelRotation o7planning.org
  • MouseWheelEvent.getWheelRotation()


getWhen

getWhen o7planning.org
  • ActionEvent.getWhen()
  • InputEvent.getWhen()
  • InputMethodEvent.getWhen()
  • InvocationEvent.getWhen()


getWhereClause

getWhereClause o7planning.org
  • JoinRowSet.getWhereClause()


getWhite

getWhite o7planning.org
  • MetalLookAndFeel.getWhite()
  • MetalTheme.getWhite()


getWholeText

getWholeText o7planning.org
  • Text.getWholeText()


getWidth

getWidth o7planning.org
  • Arc2D.Double.getWidth()
  • Arc2D.Float.getWidth()
  • BoxView.getWidth()
  • BufferedImage.getWidth(ImageObserver)
  • BufferedImage.getWidth()
  • Component.getWidth()
  • Dimension.getWidth()
  • Dimension2D.getWidth()
  • DisplayMode.getWidth()
  • Ellipse2D.Double.getWidth()
  • Ellipse2D.Float.getWidth()
  • IllegalFormatWidthException.getWidth()
  • Image.getWidth(ImageObserver)
  • ImageReader.getWidth(int)
  • JComponent.getWidth()
  • Kernel.getWidth()
  • MediaPrintableArea.getWidth(int)
  • PageFormat.getWidth()
  • Paper.getWidth()
  • PixelGrabber.getWidth()
  • Raster.getWidth()
  • Rectangle.getWidth()
  • Rectangle2D.Double.getWidth()
  • Rectangle2D.Float.getWidth()
  • RectangularShape.getWidth()
  • RenderableImage.getWidth()
  • RenderableImageOp.getWidth()
  • RenderedImage.getWidth()
  • RoundRectangle2D.Double.getWidth()
  • RoundRectangle2D.Float.getWidth()
  • SampleModel.getWidth()
  • SpringLayout.Constraints.getWidth()
  • TableColumn.getWidth()
  • VolatileImage.getWidth()


getWidthOfHighValueLabel

getWidthOfHighValueLabel o7planning.org
  • BasicSliderUI.getWidthOfHighValueLabel()


getWidthOfLowValueLabel

getWidthOfLowValueLabel o7planning.org
  • BasicSliderUI.getWidthOfLowValueLabel()


getWidthOfWidestLabel

getWidthOfWidestLabel o7planning.org
  • BasicSliderUI.getWidthOfWidestLabel()


getWidths

getWidths o7planning.org
  • FontMetrics.getWidths()


getWildcardType

getWildcardType o7planning.org
  • Types.getWildcardType(TypeMirror, TypeMirror)


getWindingRule

getWindingRule o7planning.org
  • FlatteningPathIterator.getWindingRule()
  • Path2D.getWindingRule()
  • PathIterator.getWindingRule()


getWindow

getWindow o7planning.org
  • WindowEvent.getWindow()


getWindowAncestor

getWindowAncestor o7planning.org
  • SwingUtilities.getWindowAncestor(Component)


getWindowBackground

getWindowBackground o7planning.org
  • MetalLookAndFeel.getWindowBackground()
  • MetalTheme.getWindowBackground()


getWindowDecorationStyle

getWindowDecorationStyle o7planning.org
  • JRootPane.getWindowDecorationStyle()


getWindowFocusListeners

getWindowFocusListeners o7planning.org
  • Window.getWindowFocusListeners()


getWindowListeners

getWindowListeners o7planning.org
  • Window.getWindowListeners()


getWindows

getWindows o7planning.org
  • Window.getWindows()


getWindowStateListeners

getWindowStateListeners o7planning.org
  • Window.getWindowStateListeners()


getWindowTitleBackground

getWindowTitleBackground o7planning.org
  • MetalLookAndFeel.getWindowTitleBackground()
  • MetalTheme.getWindowTitleBackground()


getWindowTitleFont

getWindowTitleFont o7planning.org
  • DefaultMetalTheme.getWindowTitleFont()
  • MetalLookAndFeel.getWindowTitleFont()
  • MetalTheme.getWindowTitleFont()


getWindowTitleForeground

getWindowTitleForeground o7planning.org
  • MetalLookAndFeel.getWindowTitleForeground()
  • MetalTheme.getWindowTitleForeground()


getWindowTitleInactiveBackground

getWindowTitleInactiveBackground o7planning.org
  • MetalLookAndFeel.getWindowTitleInactiveBackground()
  • MetalTheme.getWindowTitleInactiveBackground()


getWindowTitleInactiveForeground

getWindowTitleInactiveForeground o7planning.org
  • MetalLookAndFeel.getWindowTitleInactiveForeground()
  • MetalTheme.getWindowTitleInactiveForeground()


getWordEnd

getWordEnd o7planning.org
  • Utilities.getWordEnd(JTextComponent, int)


getWordInstance

getWordInstance o7planning.org
  • BreakIterator.getWordInstance(Locale)
  • BreakIterator.getWordInstance()
  • BreakIteratorProvider.getWordInstance(Locale)


getWordSize

getWordSize o7planning.org
  • RC5ParameterSpec.getWordSize()


getWordStart

getWordStart o7planning.org
  • Utilities.getWordStart(JTextComponent, int)


getWrapSizeLimit

getWrapSizeLimit o7planning.org
  • GSSContext.getWrapSizeLimit(int, boolean, int)


getWrapStyleWord

getWrapStyleWord o7planning.org
  • JTextArea.getWrapStyleWord()


getWritableParent

getWritableParent o7planning.org
  • WritableRaster.getWritableParent()


getWritableTile

getWritableTile o7planning.org
  • BufferedImage.getWritableTile(int, int)
  • WritableRenderedImage.getWritableTile(int, int)


getWritableTileIndices

getWritableTileIndices o7planning.org
  • BufferedImage.getWritableTileIndices()
  • WritableRenderedImage.getWritableTileIndices()


getWriteHoldCount

getWriteHoldCount o7planning.org
  • ReentrantReadWriteLock.getWriteHoldCount()


getWriteMethod

getWriteMethod o7planning.org
  • PropertyDescriptor.getWriteMethod()


getWriter

getWriter o7planning.org
  • AbstractWriter.getWriter()
  • ScriptContext.getWriter()
  • SimpleScriptContext.getWriter()
  • StreamResult.getWriter()


getWriterFileSuffixes

getWriterFileSuffixes o7planning.org
  • ImageIO.getWriterFileSuffixes()


getWriterFormatNames

getWriterFormatNames o7planning.org
  • ImageIO.getWriterFormatNames()


getWriterMIMETypes

getWriterMIMETypes o7planning.org
  • ImageIO.getWriterMIMETypes()


getWriterServiceProviderName

getWriterServiceProviderName o7planning.org
  • ImageTranscoderSpi.getWriterServiceProviderName()


getWSDLDocumentLocation

getWSDLDocumentLocation o7planning.org
  • Service.getWSDLDocumentLocation()
  • ServiceDelegate.getWSDLDocumentLocation()


getX1

getX1 o7planning.org
  • CubicCurve2D.getX1()
  • CubicCurve2D.Double.getX1()
  • CubicCurve2D.Float.getX1()
  • Line2D.getX1()
  • Line2D.Double.getX1()
  • Line2D.Float.getX1()
  • QuadCurve2D.getX1()
  • QuadCurve2D.Double.getX1()
  • QuadCurve2D.Float.getX1()


getX2

getX2 o7planning.org
  • CubicCurve2D.getX2()
  • CubicCurve2D.Double.getX2()
  • CubicCurve2D.Float.getX2()
  • Line2D.getX2()
  • Line2D.Double.getX2()
  • Line2D.Float.getX2()
  • QuadCurve2D.getX2()
  • QuadCurve2D.Double.getX2()
  • QuadCurve2D.Float.getX2()


getX

getX o7planning.org
  • Arc2D.Double.getX()
  • Arc2D.Float.getX()
  • Component.getX()
  • DHPrivateKey.getX()
  • DHPrivateKeySpec.getX()
  • DSAPrivateKey.getX()
  • DSAPrivateKeySpec.getX()
  • DragSourceEvent.getX()
  • Ellipse2D.Double.getX()
  • Ellipse2D.Float.getX()
  • JComponent.getX()
  • MediaPrintableArea.getX(int)
  • MouseEvent.getX()
  • Point.getX()
  • Point2D.getX()
  • Point2D.Double.getX()
  • Point2D.Float.getX()
  • Rectangle.getX()
  • Rectangle2D.Double.getX()
  • Rectangle2D.Float.getX()
  • RectangularShape.getX()
  • RoundRectangle2D.Double.getX()
  • RoundRectangle2D.Float.getX()
  • Size2DSyntax.getX(int)
  • SpringLayout.Constraints.getX()


getXAConnection

getXAConnection o7planning.org
  • XADataSource.getXAConnection(String, String)
  • XADataSource.getXAConnection()


getXAResource

getXAResource o7planning.org
  • XAConnection.getXAResource()


getXMicrometers

getXMicrometers o7planning.org
  • Size2DSyntax.getXMicrometers()


getXmlEncoding

getXmlEncoding o7planning.org
  • Document.getXmlEncoding()
  • Entity.getXmlEncoding()


getXMLEventReader

getXMLEventReader o7planning.org
  • StAXSource.getXMLEventReader()


getXMLEventWriter

getXMLEventWriter o7planning.org
  • StAXResult.getXMLEventWriter()


getXMLNode

getXMLNode o7planning.org
  • Binder.getXMLNode(Object)


getXMLReader

getXMLReader o7planning.org
  • AbstractUnmarshallerImpl.getXMLReader()
  • SAXParser.getXMLReader()
  • SAXSource.getXMLReader()


getXMLReporter

getXMLReporter o7planning.org
  • XMLInputFactory.getXMLReporter()


getXMLResolver

getXMLResolver o7planning.org
  • XMLInputFactory.getXMLResolver()


getXMLSchemaType

getXMLSchemaType o7planning.org
  • Duration.getXMLSchemaType()
  • XMLGregorianCalendar.getXMLSchemaType()


getXmlStandalone

getXmlStandalone o7planning.org
  • Document.getXmlStandalone()


getXMLStreamReader

getXMLStreamReader o7planning.org
  • StAXSource.getXMLStreamReader()


getXMLStreamWriter

getXMLStreamWriter o7planning.org
  • StAXResult.getXMLStreamWriter()


getXmlVersion

getXmlVersion o7planning.org
  • Document.getXmlVersion()
  • Entity.getXmlVersion()


getXMLVersion

getXMLVersion o7planning.org
  • Locator2.getXMLVersion()
  • Locator2Impl.getXMLVersion()


getXOnScreen

getXOnScreen o7planning.org
  • MouseEvent.getXOnScreen()


getXOrigin

getXOrigin o7planning.org
  • Kernel.getXOrigin()


getXPath

getXPath o7planning.org
  • XPathFilterParameterSpec.getXPath()


getXPathFunctionResolver

getXPathFunctionResolver o7planning.org
  • XPath.getXPathFunctionResolver()


getXPathList

getXPathList o7planning.org
  • XPathFilter2ParameterSpec.getXPathList()


getXPathVariableResolver

getXPathVariableResolver o7planning.org
  • XPath.getXPathVariableResolver()


getY1

getY1 o7planning.org
  • CubicCurve2D.getY1()
  • CubicCurve2D.Double.getY1()
  • CubicCurve2D.Float.getY1()
  • Line2D.getY1()
  • Line2D.Double.getY1()
  • Line2D.Float.getY1()
  • QuadCurve2D.getY1()
  • QuadCurve2D.Double.getY1()
  • QuadCurve2D.Float.getY1()


getY2

getY2 o7planning.org
  • CubicCurve2D.getY2()
  • CubicCurve2D.Double.getY2()
  • CubicCurve2D.Float.getY2()
  • Line2D.getY2()
  • Line2D.Double.getY2()
  • Line2D.Float.getY2()
  • QuadCurve2D.getY2()
  • QuadCurve2D.Double.getY2()
  • QuadCurve2D.Float.getY2()


getY

getY o7planning.org
  • Arc2D.Double.getY()
  • Arc2D.Float.getY()
  • Component.getY()
  • DHPublicKey.getY()
  • DHPublicKeySpec.getY()
  • DSAPublicKey.getY()
  • DSAPublicKeySpec.getY()
  • DragSourceEvent.getY()
  • Ellipse2D.Double.getY()
  • Ellipse2D.Float.getY()
  • JComponent.getY()
  • MediaPrintableArea.getY(int)
  • MouseEvent.getY()
  • Point.getY()
  • Point2D.getY()
  • Point2D.Double.getY()
  • Point2D.Float.getY()
  • Rectangle.getY()
  • Rectangle2D.Double.getY()
  • Rectangle2D.Float.getY()
  • RectangularShape.getY()
  • RoundRectangle2D.Double.getY()
  • RoundRectangle2D.Float.getY()
  • Size2DSyntax.getY(int)
  • SpringLayout.Constraints.getY()


getYear

getYear o7planning.org
  • Date.getYear()
  • LocalDate.getYear()
  • LocalDateTime.getYear()
  • OffsetDateTime.getYear()
  • Time.getYear()
  • XMLGregorianCalendar.getYear()
  • YearMonth.getYear()
  • ZonedDateTime.getYear()


getYears

getYears o7planning.org
  • Duration.getYears()
  • Period.getYears()


getYMicrometers

getYMicrometers o7planning.org
  • Size2DSyntax.getYMicrometers()


getYOnScreen

getYOnScreen o7planning.org
  • MouseEvent.getYOnScreen()


getYOrigin

getYOrigin o7planning.org
  • Kernel.getYOrigin()


getZeroDigit

getZeroDigit o7planning.org
  • DecimalFormatSymbols.getZeroDigit()
  • DecimalStyle.getZeroDigit()


getZone

getZone o7planning.org
  • ChronoZonedDateTime.getZone()
  • Clock.getZone()
  • DateTimeFormatter.getZone()
  • ZonedDateTime.getZone()


getZoneStrings

getZoneStrings o7planning.org
  • DateFormatSymbols.getZoneStrings()


GIF

GIF o7planning.org
  • DocFlavor.BYTE_ARRAY.GIF
  • DocFlavor.INPUT_STREAM.GIF
  • DocFlavor.URL.GIF


GLAGOLITIC

GLAGOLITIC o7planning.org
  • Character.UnicodeBlock.GLAGOLITIC


GLASS_PANE

GLASS_PANE o7planning.org
  • AccessibleRole.GLASS_PANE


GLASS_PANE_PROPERTY

GLASS_PANE_PROPERTY o7planning.org
  • JInternalFrame.GLASS_PANE_PROPERTY


glassPane

glassPane o7planning.org
  • JRootPane.glassPane


glassPaneDispatcher

glassPaneDispatcher o7planning.org
  • BasicInternalFrameUI.glassPaneDispatcher


GlassPaneDispatcher

GlassPaneDispatcher o7planning.org
  • BasicInternalFrameUI.GlassPaneDispatcher.GlassPaneDispatcher()


global

global o7planning.org
  • Logger.global


GLOBAL

GLOBAL o7planning.org
  • XmlElementDecl.GLOBAL.GLOBAL()


GLOBAL_LOGGER_NAME

GLOBAL_LOGGER_NAME o7planning.org
  • Logger.GLOBAL_LOGGER_NAME


GLOBAL_SCOPE

GLOBAL_SCOPE o7planning.org
  • ScriptContext.GLOBAL_SCOPE


globalHierarchyLock

globalHierarchyLock o7planning.org
  • BeanContext.globalHierarchyLock


globalScope

globalScope o7planning.org
  • SimpleScriptContext.globalScope


GlobalScope

GlobalScope o7planning.org
  • JAXBElement.GlobalScope.GlobalScope()


GlyphJustificationInfo

GlyphJustificationInfo o7planning.org
  • GlyphJustificationInfo.GlyphJustificationInfo(float, boolean, int, float, float, boolean, int, float, float)


GlyphMetrics

GlyphMetrics o7planning.org
  • GlyphMetrics.GlyphMetrics(boolean, float, float, Rectangle2D, byte)
  • GlyphMetrics.GlyphMetrics(float, Rectangle2D, byte)


GlyphPainter

GlyphPainter o7planning.org
  • GlyphView.GlyphPainter.GlyphPainter()


GlyphVector

GlyphVector o7planning.org
  • GlyphVector.GlyphVector()


GlyphView

GlyphView o7planning.org
  • GlyphView.GlyphView(Element)


GMONTH

GMONTH o7planning.org
  • DatatypeConstants.GMONTH


GMONTHDAY

GMONTHDAY o7planning.org
  • DatatypeConstants.GMONTHDAY


GoHomeAction

GoHomeAction o7planning.org
  • BasicFileChooserUI.GoHomeAction.GoHomeAction()


GoodBreakWeight

GoodBreakWeight o7planning.org
  • View.GoodBreakWeight


GOPHER

GOPHER o7planning.org
  • ReferenceUriSchemesSupported.GOPHER


GOT_FOCUS

GOT_FOCUS o7planning.org
  • Event.GOT_FOCUS


gotDefault

gotDefault o7planning.org
  • InitialContext.gotDefault


gotFocus

gotFocus o7planning.org
  • Component.gotFocus(Event, Object)


GOTHIC

GOTHIC o7planning.org
  • Character.UnicodeBlock.GOTHIC


grabFocus

grabFocus o7planning.org
  • JComponent.grabFocus()


grabPixels

grabPixels o7planning.org
  • PixelGrabber.grabPixels(long)
  • PixelGrabber.grabPixels()


GRADE_CHECK_ALL_AT_COMMIT

GRADE_CHECK_ALL_AT_COMMIT o7planning.org
  • SyncProvider.GRADE_CHECK_ALL_AT_COMMIT


GRADE_CHECK_MODIFIED_AT_COMMIT

GRADE_CHECK_MODIFIED_AT_COMMIT o7planning.org
  • SyncProvider.GRADE_CHECK_MODIFIED_AT_COMMIT


GRADE_LOCK_WHEN_LOADED

GRADE_LOCK_WHEN_LOADED o7planning.org
  • SyncProvider.GRADE_LOCK_WHEN_LOADED


GRADE_LOCK_WHEN_MODIFIED

GRADE_LOCK_WHEN_MODIFIED o7planning.org
  • SyncProvider.GRADE_LOCK_WHEN_MODIFIED


GRADE_NONE

GRADE_NONE o7planning.org
  • SyncProvider.GRADE_NONE


GradientPaint

GradientPaint o7planning.org
  • GradientPaint.GradientPaint(Point2D, Color, Point2D, Color, boolean)
  • GradientPaint.GradientPaint(float, float, Color, float, float, Color, boolean)
  • GradientPaint.GradientPaint(Point2D, Color, Point2D, Color)
  • GradientPaint.GradientPaint(float, float, Color, float, float, Color)


GraphicAttribute

GraphicAttribute o7planning.org
  • GraphicAttribute.GraphicAttribute(int)


Graphics2D

Graphics2D o7planning.org
  • Graphics2D.Graphics2D()


Graphics

Graphics o7planning.org
  • Graphics.Graphics()


GraphicsConfigTemplate

GraphicsConfigTemplate o7planning.org
  • GraphicsConfigTemplate.GraphicsConfigTemplate()


GraphicsConfiguration

GraphicsConfiguration o7planning.org
  • GraphicsConfiguration.GraphicsConfiguration()


GraphicsDevice

GraphicsDevice o7planning.org
  • GraphicsDevice.GraphicsDevice()


GraphicsEnvironment

GraphicsEnvironment o7planning.org
  • GraphicsEnvironment.GraphicsEnvironment()


gray

gray o7planning.org
  • Color.gray


GRAY

GRAY o7planning.org
  • Color.GRAY


GrayFilter

GrayFilter o7planning.org
  • GrayFilter.GrayFilter(boolean, int)


GREATER

GREATER o7planning.org
  • DatatypeConstants.GREATER


GREEK

GREEK o7planning.org
  • Character.UnicodeBlock.GREEK


GREEK_EXTENDED

GREEK_EXTENDED o7planning.org
  • Character.UnicodeBlock.GREEK_EXTENDED


green

green o7planning.org
  • Color.green


GREEN

GREEN o7planning.org
  • Color.GREEN


GREENCOMPONENT

GREENCOMPONENT o7planning.org
  • ICC_ProfileRGB.GREENCOMPONENT


GregorianCalendar

GregorianCalendar o7planning.org
  • GregorianCalendar.GregorianCalendar(int, int, int, int, int, int)
  • GregorianCalendar.GregorianCalendar(int, int, int, int, int)
  • GregorianCalendar.GregorianCalendar(int, int, int)
  • GregorianCalendar.GregorianCalendar(TimeZone, Locale)
  • GregorianCalendar.GregorianCalendar(Locale)
  • GregorianCalendar.GregorianCalendar(TimeZone)
  • GregorianCalendar.GregorianCalendar()


GridBagConstraints

GridBagConstraints o7planning.org
  • GridBagConstraints.GridBagConstraints(int, int, int, int, double, double, int, int, Insets, int, int)
  • GridBagConstraints.GridBagConstraints()


GridBagLayout

GridBagLayout o7planning.org
  • GridBagLayout.GridBagLayout()


gridColor

gridColor o7planning.org
  • JTable.gridColor


gridheight

gridheight o7planning.org
  • GridBagConstraints.gridheight


GridLayout

GridLayout o7planning.org
  • GridLayout.GridLayout(int, int, int, int)
  • GridLayout.GridLayout(int, int)
  • GridLayout.GridLayout()


gridwidth

gridwidth o7planning.org
  • GridBagConstraints.gridwidth


gridx

gridx o7planning.org
  • GridBagConstraints.gridx


gridy

gridy o7planning.org
  • GridBagConstraints.gridy


group

group o7planning.org
  • DefaultButtonModel.group
  • MatchResult.group(int)
  • MatchResult.group()
  • Matcher.group(String)
  • Matcher.group(int)
  • Matcher.group()
  • MembershipKey.group()
  • PosixFileAttributes.group()


GROUP_BOX

GROUP_BOX o7planning.org
  • AccessibleRole.GROUP_BOX


groupCount

groupCount o7planning.org
  • MatchResult.groupCount()
  • Matcher.groupCount()


GROUPING_SEPARATOR

GROUPING_SEPARATOR o7planning.org
  • NumberFormat.Field.GROUPING_SEPARATOR


groupingBy

groupingBy o7planning.org
  • Collectors.groupingBy(Function<? super T, ? extends K>, Supplier<M>, Collector<? super T, A, D>)
  • Collectors.groupingBy(Function<? super T, ? extends K>, Collector<? super T, A, D>)
  • Collectors.groupingBy(Function<? super T, ? extends K>)


groupingByConcurrent

groupingByConcurrent o7planning.org
  • Collectors.groupingByConcurrent(Function<? super T, ? extends K>, Supplier<M>, Collector<? super T, A, D>)
  • Collectors.groupingByConcurrent(Function<? super T, ? extends K>, Collector<? super T, A, D>)
  • Collectors.groupingByConcurrent(Function<? super T, ? extends K>)


GroupLayout

GroupLayout o7planning.org
  • GroupLayout.GroupLayout(Container)


grow

grow o7planning.org
  • Rectangle.grow(int, int)


growAbsorb

growAbsorb o7planning.org
  • GlyphJustificationInfo.growAbsorb


growLeftLimit

growLeftLimit o7planning.org
  • GlyphJustificationInfo.growLeftLimit


growPriority

growPriority o7planning.org
  • GlyphJustificationInfo.growPriority


growRightLimit

growRightLimit o7planning.org
  • GlyphJustificationInfo.growRightLimit


GSSException

GSSException o7planning.org
  • GSSException.GSSException(int, int, String)
  • GSSException.GSSException(int)


GSSManager

GSSManager o7planning.org
  • GSSManager.GSSManager()


GT

GT o7planning.org
  • Query.GT


gt

gt o7planning.org
  • Query.gt(ValueExp, ValueExp)


GuardedObject

GuardedObject o7planning.org
  • GuardedObject.GuardedObject(Object, Guard)


guardWithTest

guardWithTest o7planning.org
  • MethodHandles.guardWithTest(MethodHandle, MethodHandle, MethodHandle)
  • SwitchPoint.guardWithTest(MethodHandle, MethodHandle)


guessContentTypeFromName

guessContentTypeFromName o7planning.org
  • URLConnection.guessContentTypeFromName(String)


guessContentTypeFromStream

guessContentTypeFromStream o7planning.org
  • URLConnection.guessContentTypeFromStream(InputStream)


GUJARATI

GUJARATI o7planning.org
  • Character.UnicodeBlock.GUJARATI
  • NumericShaper.GUJARATI


GURMUKHI

GURMUKHI o7planning.org
  • Character.UnicodeBlock.GURMUKHI
  • NumericShaper.GURMUKHI


GYEAR

GYEAR o7planning.org
  • DatatypeConstants.GYEAR


GYEARMONTH

GYEARMONTH o7planning.org
  • DatatypeConstants.GYEARMONTH


GZIP

GZIP o7planning.org
  • Compression.GZIP


GZIP_MAGIC

GZIP_MAGIC o7planning.org
  • GZIPInputStream.GZIP_MAGIC


GZIPInputStream

GZIPInputStream o7planning.org
  • GZIPInputStream.GZIPInputStream(InputStream)
  • GZIPInputStream.GZIPInputStream(InputStream, int)


GZIPOutputStream

GZIPOutputStream o7planning.org
  • GZIPOutputStream.GZIPOutputStream(OutputStream, boolean)
  • GZIPOutputStream.GZIPOutputStream(OutputStream)
  • GZIPOutputStream.GZIPOutputStream(OutputStream, int, boolean)
  • GZIPOutputStream.GZIPOutputStream(OutputStream, int)


H1

H1 o7planning.org
  • HTML.Tag.H1


H2

H2 o7planning.org
  • HTML.Tag.H2


H3

H3 o7planning.org
  • HTML.Tag.H3


H4

H4 o7planning.org
  • HTML.Tag.H4


H5

H5 o7planning.org
  • HTML.Tag.H5


H6

H6 o7planning.org
  • HTML.Tag.H6


h

h o7planning.org
  • Proxy.h


HALFWIDTH_AND_FULLWIDTH_FORMS

HALFWIDTH_AND_FULLWIDTH_FORMS o7planning.org
  • Character.UnicodeBlock.HALFWIDTH_AND_FULLWIDTH_FORMS


HALFWIDTH_KATAKANA

HALFWIDTH_KATAKANA o7planning.org
  • InputSubset.HALFWIDTH_KATAKANA


HALIGN

HALIGN o7planning.org
  • HTML.Attribute.HALIGN


halt

halt o7planning.org
  • Runtime.halt(int)


HAND_CURSOR

HAND_CURSOR o7planning.org
  • Cursor.HAND_CURSOR
  • Frame.HAND_CURSOR


handle

handle o7planning.org
  • CallbackHandler.handle(Callback[])
  • CompletableFuture.handle(BiFunction<? super T, Throwable, ? extends U>)
  • CompletionStage.handle(BiFunction<? super T, Throwable, ? extends U>)
  • HttpHandler.handle(HttpExchange)
  • UserDataHandler.handle(short, String, Object, Node, Node)


handleAsync

handleAsync o7planning.org
  • CompletableFuture.handleAsync(BiFunction<? super T, Throwable, ? extends U>, Executor)
  • CompletableFuture.handleAsync(BiFunction<? super T, Throwable, ? extends U>)
  • CompletionStage.handleAsync(BiFunction<? super T, Throwable, ? extends U>, Executor)
  • CompletionStage.handleAsync(BiFunction<? super T, Throwable, ? extends U>)


handleComment

handleComment o7planning.org
  • DocumentParser.handleComment(char[])
  • HTMLDocument.HTMLReader.handleComment(char[], int)
  • HTMLEditorKit.ParserCallback.handleComment(char[], int)
  • Parser.handleComment(char[])


handleEmptyTag

handleEmptyTag o7planning.org
  • DocumentParser.handleEmptyTag(TagElement)
  • Parser.handleEmptyTag(TagElement)


handleEndOfLineString

handleEndOfLineString o7planning.org
  • HTMLDocument.HTMLReader.handleEndOfLineString(String)
  • HTMLEditorKit.ParserCallback.handleEndOfLineString(String)


handleEndTag

handleEndTag o7planning.org
  • DocumentParser.handleEndTag(TagElement)
  • HTMLDocument.HTMLReader.handleEndTag(HTML.Tag, int)
  • HTMLEditorKit.ParserCallback.handleEndTag(HTML.Tag, int)
  • Parser.handleEndTag(TagElement)


handleEOFInComment

handleEOFInComment o7planning.org
  • Parser.handleEOFInComment()


handleError

handleError o7planning.org
  • DOMErrorHandler.handleError(DOMError)
  • DocumentParser.handleError(int, String)
  • HTMLEditorKit.ParserCallback.handleError(String, int)
  • Parser.handleError(int, String)


handleEvent

handleEvent o7planning.org
  • Component.handleEvent(Event)
  • DefaultValidationEventHandler.handleEvent(ValidationEvent)
  • EventListener.handleEvent(Event)
  • ValidationEventCollector.handleEvent(ValidationEvent)
  • ValidationEventHandler.handleEvent(ValidationEvent)


handleExpandControlClick

handleExpandControlClick o7planning.org
  • BasicTreeUI.handleExpandControlClick(TreePath, int, int)


handleFault

handleFault o7planning.org
  • Handler.handleFault(C)


handleGetObject

handleGetObject o7planning.org
  • ListResourceBundle.handleGetObject(String)
  • PropertyResourceBundle.handleGetObject(String)
  • ResourceBundle.handleGetObject(String)


handleJustify

handleJustify o7planning.org
  • TextLayout.handleJustify(float)


handleKeySet

handleKeySet o7planning.org
  • ListResourceBundle.handleKeySet()
  • PropertyResourceBundle.handleKeySet()
  • ResourceBundle.handleKeySet()


handleMBeanUnregistration

handleMBeanUnregistration o7planning.org
  • Relation.handleMBeanUnregistration(ObjectName, String)
  • RelationSupport.handleMBeanUnregistration(ObjectName, String)


handleMessage

handleMessage o7planning.org
  • Handler.handleMessage(C)


handleNotification

handleNotification o7planning.org
  • NotificationBroadcasterSupport.handleNotification(NotificationListener, Notification, Object)
  • NotificationListener.handleNotification(Notification, Object)
  • RelationService.handleNotification(Notification, Object)


handleOption

handleOption o7planning.org
  • ForwardingJavaFileManager.handleOption(String, Iterator<String>)
  • JavaFileManager.handleOption(String, Iterator<String>)


Handler

Handler o7planning.org
  • Handler.Handler()


handler

handler o7planning.org
  • HttpContext.handler


HandlerBase

HandlerBase o7planning.org
  • HandlerBase.HandlerBase()


handleResponse

handleResponse o7planning.org
  • AsyncHandler.handleResponse(Response<T>)


handleSimpleTag

handleSimpleTag o7planning.org
  • HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag, MutableAttributeSet, int)
  • HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag, MutableAttributeSet, int)


handleStartTag

handleStartTag o7planning.org
  • DocumentParser.handleStartTag(TagElement)
  • HTMLDocument.HTMLReader.handleStartTag(HTML.Tag, MutableAttributeSet, int)
  • HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag, MutableAttributeSet, int)
  • Parser.handleStartTag(TagElement)


handleText

handleText o7planning.org
  • DocumentParser.handleText(char[])
  • HTMLDocument.HTMLReader.handleText(char[], int)
  • HTMLEditorKit.ParserCallback.handleText(char[], int)
  • Parser.handleText(char[])


handleTitle

handleTitle o7planning.org
  • Parser.handleTitle(char[])


handshakeCompleted

handshakeCompleted o7planning.org
  • HandshakeCompletedListener.handshakeCompleted(HandshakeCompletedEvent)


HandshakeCompletedEvent

HandshakeCompletedEvent o7planning.org
  • HandshakeCompletedEvent.HandshakeCompletedEvent(SSLSocket, SSLSession)


HANGING_BASELINE

HANGING_BASELINE o7planning.org
  • Font.HANGING_BASELINE
  • GraphicAttribute.HANGING_BASELINE


HANGUL_COMPATIBILITY_JAMO

HANGUL_COMPATIBILITY_JAMO o7planning.org
  • Character.UnicodeBlock.HANGUL_COMPATIBILITY_JAMO


HANGUL_JAMO

HANGUL_JAMO o7planning.org
  • Character.UnicodeBlock.HANGUL_JAMO


HANGUL_JAMO_EXTENDED_A

HANGUL_JAMO_EXTENDED_A o7planning.org
  • Character.UnicodeBlock.HANGUL_JAMO_EXTENDED_A


HANGUL_JAMO_EXTENDED_B

HANGUL_JAMO_EXTENDED_B o7planning.org
  • Character.UnicodeBlock.HANGUL_JAMO_EXTENDED_B


HANGUL_SYLLABLES

HANGUL_SYLLABLES o7planning.org
  • Character.UnicodeBlock.HANGUL_SYLLABLES


HANJA

HANJA o7planning.org
  • InputSubset.HANJA


HANUNOO

HANUNOO o7planning.org
  • Character.UnicodeBlock.HANUNOO


hardDriveIcon

hardDriveIcon o7planning.org
  • BasicFileChooserUI.hardDriveIcon


has_no_active_member

has_no_active_member o7planning.org
  • DynUnionOperations.has_no_active_member()
  • _DynUnionStub.has_no_active_member()


hasAlpha

hasAlpha o7planning.org
  • ColorModel.hasAlpha()


hasAnchoringBounds

hasAnchoringBounds o7planning.org
  • Matcher.hasAnchoringBounds()


hasArray

hasArray o7planning.org
  • Buffer.hasArray()
  • ByteBuffer.hasArray()
  • CharBuffer.hasArray()
  • DoubleBuffer.hasArray()
  • FloatBuffer.hasArray()
  • IntBuffer.hasArray()
  • LongBuffer.hasArray()
  • ShortBuffer.hasArray()


hasAttribute

hasAttribute o7planning.org
  • Element.hasAttribute(String)
  • IIOMetadataNode.hasAttribute(String)


hasAttributeNS

hasAttributeNS o7planning.org
  • Element.hasAttributeNS(String, String)
  • IIOMetadataNode.hasAttributeNS(String, String)


hasAttributes

hasAttributes o7planning.org
  • IIOMetadataNode.hasAttributes()
  • Node.hasAttributes()


hasBeenExpanded

hasBeenExpanded o7planning.org
  • JTree.hasBeenExpanded(TreePath)


hasBeenInvalidated

hasBeenInvalidated o7planning.org
  • SwitchPoint.hasBeenInvalidated()


hasChanged

hasChanged o7planning.org
  • Observable.hasChanged()


hasCharacteristics

hasCharacteristics o7planning.org
  • Spliterator.hasCharacteristics(int)


hasChildNodes

hasChildNodes o7planning.org
  • IIOMetadataNode.hasChildNodes()
  • Node.hasChildNodes()


hasChildren

hasChildren o7planning.org
  • JTree.DynamicUtilTreeNode.hasChildren


hasContended

hasContended o7planning.org
  • AbstractQueuedLongSynchronizer.hasContended()
  • AbstractQueuedSynchronizer.hasContended()


hasController

hasController o7planning.org
  • IIOMetadata.hasController()
  • IIOParam.hasController()


hasCustomComponents

hasCustomComponents o7planning.org
  • BasicOptionPaneUI.hasCustomComponents


hasDefaultValue

hasDefaultValue o7planning.org
  • OpenMBeanAttributeInfoSupport.hasDefaultValue()
  • OpenMBeanParameterInfo.hasDefaultValue()
  • OpenMBeanParameterInfoSupport.hasDefaultValue()


hasDetail

hasDetail o7planning.org
  • SOAPFault.hasDetail()


hasDynamicLocaleList

hasDynamicLocaleList o7planning.org
  • InputMethodDescriptor.hasDynamicLocaleList()


hasEntered

hasEntered o7planning.org
  • BasicComboPopup.hasEntered


hasEvents

hasEvents o7planning.org
  • ValidationEventCollector.hasEvents()


hasExpired

hasExpired o7planning.org
  • HttpCookie.hasExpired()


hasExtensions

hasExtensions o7planning.org
  • Locale.hasExtensions()
  • X509CRLEntry.hasExtensions()


hasFault

hasFault o7planning.org
  • SOAPBody.hasFault()


hasFeature

hasFeature o7planning.org
  • DOMImplementation.hasFeature(String, String)


hasFocus

hasFocus o7planning.org
  • BasicComboBoxUI.hasFocus
  • Component.hasFocus()
  • DefaultTreeCellRenderer.hasFocus


hash

hash o7planning.org
  • Delegate.hash(Object, int)
  • Objects.hash(Object...)


HashAttributeSet

HashAttributeSet o7planning.org
  • HashAttributeSet.HashAttributeSet(AttributeSet, Class<?>)
  • HashAttributeSet.HashAttributeSet(Attribute[], Class<?>)
  • HashAttributeSet.HashAttributeSet(Attribute, Class<?>)
  • HashAttributeSet.HashAttributeSet(Class<?>)
  • HashAttributeSet.HashAttributeSet(AttributeSet)
  • HashAttributeSet.HashAttributeSet(Attribute[])
  • HashAttributeSet.HashAttributeSet(Attribute)
  • HashAttributeSet.HashAttributeSet()


hashCode

hashCode o7planning.org
  • AWTKeyStroke.hashCode()
  • AbstractChronology.hashCode()
  • AbstractList.hashCode()
  • AbstractMap.hashCode()
  • AbstractMap.SimpleEntry.hashCode()
  • AbstractMap.SimpleImmutableEntry.hashCode()
  • AbstractSet.hashCode()
  • AccessControlContext.hashCode()
  • AclEntry.hashCode()
  • ActivationDesc.hashCode()
  • ActivationGroupDesc.hashCode()
  • ActivationGroupDesc.CommandEnvironment.hashCode()
  • ActivationGroupID.hashCode()
  • ActivationID.hashCode()
  • AffineTransform.hashCode()
  • AllPermission.hashCode()
  • AlphaComposite.hashCode()
  • Annotation.hashCode()
  • Arc2D.hashCode()
  • ArrayType.hashCode()
  • Arrays.hashCode(Object[])
  • Arrays.hashCode(double[])
  • Arrays.hashCode(float[])
  • Arrays.hashCode(boolean[])
  • Arrays.hashCode(byte[])
  • Arrays.hashCode(char[])
  • Arrays.hashCode(short[])
  • Arrays.hashCode(int[])
  • Arrays.hashCode(long[])
  • Attribute.hashCode()
  • AttributeSet.hashCode()
  • AttributedCharacterIterator.Attribute.hashCode()
  • Attributes.hashCode()
  • Attributes.Name.hashCode()
  • AudioFileFormat.Type.hashCode()
  • AudioFormat.Encoding.hashCode()
  • BandedSampleModel.hashCode()
  • BasicAttribute.hashCode()
  • BasicAttributes.hashCode()
  • BasicPermission.hashCode()
  • BasicStroke.hashCode()
  • BigDecimal.hashCode()
  • BigInteger.hashCode()
  • BinaryRefAddr.hashCode()
  • BitSet.hashCode()
  • Boolean.hashCode(boolean)
  • Boolean.hashCode()
  • Byte.hashCode(byte)
  • Byte.hashCode()
  • ByteBuffer.hashCode()
  • Calendar.hashCode()
  • CertPath.hashCode()
  • Certificate.hashCode()
  • Certificate.hashCode()
  • ChannelBinding.hashCode()
  • CharBuffer.hashCode()
  • Character.hashCode(char)
  • Character.hashCode()
  • Character.Subset.hashCode()
  • Charset.hashCode()
  • ChoiceFormat.hashCode()
  • ChronoLocalDate.hashCode()
  • ChronoLocalDateTime.hashCode()
  • ChronoPeriod.hashCode()
  • ChronoZonedDateTime.hashCode()
  • Chronology.hashCode()
  • Clock.hashCode()
  • CodeSigner.hashCode()
  • CodeSource.hashCode()
  • Collator.hashCode()
  • Collection.hashCode()
  • Color.hashCode()
  • ColorModel.hashCode()
  • ComponentSampleModel.hashCode()
  • CompositeData.hashCode()
  • CompositeDataSupport.hashCode()
  • CompositeName.hashCode()
  • CompositeType.hashCode()
  • CompoundName.hashCode()
  • ConcurrentHashMap.hashCode()
  • ConcurrentHashMap.KeySetView.hashCode()
  • Constructor.hashCode()
  • Control.Type.hashCode()
  • CopyOnWriteArrayList.hashCode()
  • DataFlavor.hashCode()
  • Date.hashCode()
  • DateFormat.hashCode()
  • DateFormatSymbols.hashCode()
  • DateTimeSyntax.hashCode()
  • DecimalFormat.hashCode()
  • DecimalFormatSymbols.hashCode()
  • DecimalStyle.hashCode()
  • Delegate.hashCode(Object)
  • DelegationPermission.hashCode()
  • Descriptor.hashCode()
  • DescriptorSupport.hashCode()
  • Dimension.hashCode()
  • DisplayMode.hashCode()
  • DocFlavor.hashCode()
  • Double.hashCode(double)
  • Double.hashCode()
  • DoubleBuffer.hashCode()
  • Duration.hashCode()
  • Duration.hashCode()
  • ECFieldF2m.hashCode()
  • ECFieldFp.hashCode()
  • ECPoint.hashCode()
  • Element.hashCode()
  • Ellipse2D.hashCode()
  • EllipticCurve.hashCode()
  • Enum.hashCode()
  • EnumMap.hashCode()
  • EnumSyntax.hashCode()
  • Field.hashCode()
  • FieldPosition.hashCode()
  • File.hashCode()
  • FilePermission.hashCode()
  • FileTime.hashCode()
  • Float.hashCode(float)
  • Float.hashCode()
  • FloatBuffer.hashCode()
  • Font.hashCode()
  • FontRenderContext.hashCode()
  • GSSCredential.hashCode()
  • GSSName.hashCode()
  • GregorianCalendar.hashCode()
  • HTML.UnknownTag.hashCode()
  • HashAttributeSet.hashCode()
  • Hashtable.hashCode()
  • HijrahDate.hashCode()
  • HttpCookie.hashCode()
  • Identity.hashCode()
  • IdentityHashMap.hashCode()
  • ImageGraphicAttribute.hashCode()
  • ImageTypeSpecifier.hashCode()
  • ImmutableDescriptor.hashCode()
  • IndexedPropertyDescriptor.hashCode()
  • Inet4Address.hashCode()
  • Inet6Address.hashCode()
  • InetAddress.hashCode()
  • InetSocketAddress.hashCode()
  • Insets.hashCode()
  • Instant.hashCode()
  • IntBuffer.hashCode()
  • Integer.hashCode(int)
  • Integer.hashCode()
  • IntegerSyntax.hashCode()
  • InterfaceAddress.hashCode()
  • JMXPrincipal.hashCode()
  • JMXServiceURL.hashCode()
  • JapaneseDate.hashCode()
  • JobAttributes.hashCode()
  • KerberosKey.hashCode()
  • KerberosPrincipal.hashCode()
  • KerberosTicket.hashCode()
  • KeyTab.hashCode()
  • LdapName.hashCode()
  • Level.hashCode()
  • LineEvent.Type.hashCode()
  • List.hashCode()
  • LocalDate.hashCode()
  • LocalDateTime.hashCode()
  • LocalTime.hashCode()
  • Locale.hashCode()
  • Locale.LanguageRange.hashCode()
  • Long.hashCode(long)
  • Long.hashCode()
  • LongBuffer.hashCode()
  • MBeanAttributeInfo.hashCode()
  • MBeanConstructorInfo.hashCode()
  • MBeanFeatureInfo.hashCode()
  • MBeanInfo.hashCode()
  • MBeanNotificationInfo.hashCode()
  • MBeanOperationInfo.hashCode()
  • MBeanParameterInfo.hashCode()
  • MBeanPermission.hashCode()
  • MBeanServerPermission.hashCode()
  • Manifest.hashCode()
  • Map.hashCode()
  • Map.Entry.hashCode()
  • MarshalledObject.hashCode()
  • MathContext.hashCode()
  • MediaPrintableArea.hashCode()
  • MenuShortcut.hashCode()
  • MessageFormat.hashCode()
  • Method.hashCode()
  • MethodType.hashCode()
  • MidiDevice.Info.hashCode()
  • MinguoDate.hashCode()
  • Mixer.Info.hashCode()
  • MonthDay.hashCode()
  • MultiPixelPackedSampleModel.hashCode()
  • Name.hashCode()
  • NetworkInterface.hashCode()
  • NumberFormat.hashCode()
  • NumericShaper.hashCode()
  • ObjID.hashCode()
  • Object.hashCode()
  • ObjectImpl.hashCode()
  • ObjectInstance.hashCode()
  • ObjectName.hashCode()
  • Objects.hashCode(Object)
  • OffsetDateTime.hashCode()
  • OffsetTime.hashCode()
  • Oid.hashCode()
  • OpenMBeanAttributeInfo.hashCode()
  • OpenMBeanAttributeInfoSupport.hashCode()
  • OpenMBeanConstructorInfo.hashCode()
  • OpenMBeanConstructorInfoSupport.hashCode()
  • OpenMBeanInfo.hashCode()
  • OpenMBeanInfoSupport.hashCode()
  • OpenMBeanOperationInfo.hashCode()
  • OpenMBeanOperationInfoSupport.hashCode()
  • OpenMBeanParameterInfo.hashCode()
  • OpenMBeanParameterInfoSupport.hashCode()
  • OpenType.hashCode()
  • Optional.hashCode()
  • OptionalDouble.hashCode()
  • OptionalInt.hashCode()
  • OptionalLong.hashCode()
  • PKCS12Attribute.hashCode()
  • Package.hashCode()
  • PageAttributes.hashCode()
  • Parameter.hashCode()
  • ParsePosition.hashCode()
  • Path.hashCode()
  • Period.hashCode()
  • Permission.hashCode()
  • PixelInterleavedSampleModel.hashCode()
  • Point2D.hashCode()
  • Port.Info.hashCode()
  • Principal.hashCode()
  • PrintService.hashCode()
  • PrivateCredentialPermission.hashCode()
  • ProcessBuilder.Redirect.hashCode()
  • PropertyDescriptor.hashCode()
  • PropertyPermission.hashCode()
  • Proxy.hashCode()
  • QName.hashCode()
  • RC2ParameterSpec.hashCode()
  • RC5ParameterSpec.hashCode()
  • Rdn.hashCode()
  • Rectangle2D.hashCode()
  • RefAddr.hashCode()
  • Reference.hashCode()
  • RemoteObject.hashCode()
  • RenderingHints.hashCode()
  • RenderingHints.Key.hashCode()
  • ResolutionSyntax.hashCode()
  • ReverbType.hashCode()
  • RoundRectangle2D.hashCode()
  • RowId.hashCode()
  • RowSorter.SortKey.hashCode()
  • RuleBasedCollator.hashCode()
  • SNIHostName.hashCode()
  • SNIServerName.hashCode()
  • SecretKeySpec.hashCode()
  • Sequencer.SyncMode.hashCode()
  • SerialArray.hashCode()
  • SerialBlob.hashCode()
  • SerialClob.hashCode()
  • SerialDatalink.hashCode()
  • SerialJavaObject.hashCode()
  • SerialRef.hashCode()
  • SerialStruct.hashCode()
  • ServicePermission.hashCode()
  • Set.hashCode()
  • SetOfIntegerSyntax.hashCode()
  • ShapeGraphicAttribute.hashCode()
  • Short.hashCode(short)
  • Short.hashCode()
  • ShortBuffer.hashCode()
  • SimpleAttributeSet.hashCode()
  • SimpleDateFormat.hashCode()
  • SimpleTimeZone.hashCode()
  • SimpleType.hashCode()
  • SinglePixelPackedSampleModel.hashCode()
  • Size2DSyntax.hashCode()
  • SocketPermission.hashCode()
  • SslRMIClientSocketFactory.hashCode()
  • SslRMIServerSocketFactory.hashCode()
  • StackTraceElement.hashCode()
  • String.hashCode()
  • StringCharacterIterator.hashCode()
  • Stub.hashCode()
  • StubDelegate.hashCode(Stub)
  • StyleContext.SmallAttributeSet.hashCode()
  • Subject.hashCode()
  • TabSet.hashCode()
  • TabStop.hashCode()
  • TabularData.hashCode()
  • TabularDataSupport.hashCode()
  • TabularType.hashCode()
  • TextHitInfo.hashCode()
  • TextLayout.hashCode()
  • TextSyntax.hashCode()
  • ThaiBuddhistDate.hashCode()
  • Timestamp.hashCode()
  • Timestamp.hashCode()
  • TransformAttribute.hashCode()
  • TreePath.hashCode()
  • TypeMirror.hashCode()
  • UID.hashCode()
  • URI.hashCode()
  • URISyntax.hashCode()
  • URL.hashCode()
  • URLPermission.hashCode()
  • URLStreamHandler.hashCode(URL)
  • UUID.hashCode()
  • UnresolvedPermission.hashCode()
  • VMID.hashCode()
  • ValueRange.hashCode()
  • Vector.hashCode()
  • WeekFields.hashCode()
  • X500Principal.hashCode()
  • X509CRL.hashCode()
  • X509CRLEntry.hashCode()
  • XMLGregorianCalendar.hashCode()
  • Year.hashCode()
  • YearMonth.hashCode()
  • ZipEntry.hashCode()
  • ZoneId.hashCode()
  • ZoneOffset.hashCode()
  • ZoneOffsetTransition.hashCode()
  • ZoneOffsetTransitionRule.hashCode()
  • ZoneRules.hashCode()
  • ZonedDateTime.hashCode()


HashDocAttributeSet

HashDocAttributeSet o7planning.org
  • HashDocAttributeSet.HashDocAttributeSet(DocAttributeSet)
  • HashDocAttributeSet.HashDocAttributeSet(DocAttribute[])
  • HashDocAttributeSet.HashDocAttributeSet(DocAttribute)
  • HashDocAttributeSet.HashDocAttributeSet()


HashMap

HashMap o7planning.org
  • HashMap.HashMap(Map<? extends K, ? extends V>)
  • HashMap.HashMap()
  • HashMap.HashMap(int)
  • HashMap.HashMap(int, float)


HashPrintJobAttributeSet

HashPrintJobAttributeSet o7planning.org
  • HashPrintJobAttributeSet.HashPrintJobAttributeSet(PrintJobAttributeSet)
  • HashPrintJobAttributeSet.HashPrintJobAttributeSet(PrintJobAttribute[])
  • HashPrintJobAttributeSet.HashPrintJobAttributeSet(PrintJobAttribute)
  • HashPrintJobAttributeSet.HashPrintJobAttributeSet()


HashPrintRequestAttributeSet

HashPrintRequestAttributeSet o7planning.org
  • HashPrintRequestAttributeSet.HashPrintRequestAttributeSet(PrintRequestAttributeSet)
  • HashPrintRequestAttributeSet.HashPrintRequestAttributeSet(PrintRequestAttribute[])
  • HashPrintRequestAttributeSet.HashPrintRequestAttributeSet(PrintRequestAttribute)
  • HashPrintRequestAttributeSet.HashPrintRequestAttributeSet()


HashPrintServiceAttributeSet

HashPrintServiceAttributeSet o7planning.org
  • HashPrintServiceAttributeSet.HashPrintServiceAttributeSet(PrintServiceAttributeSet)
  • HashPrintServiceAttributeSet.HashPrintServiceAttributeSet(PrintServiceAttribute[])
  • HashPrintServiceAttributeSet.HashPrintServiceAttributeSet(PrintServiceAttribute)
  • HashPrintServiceAttributeSet.HashPrintServiceAttributeSet()


HashSet

HashSet o7planning.org
  • HashSet.HashSet(int)
  • HashSet.HashSet(int, float)
  • HashSet.HashSet(Collection<? extends E>)
  • HashSet.HashSet()


Hashtable

Hashtable o7planning.org
  • Hashtable.Hashtable(Map<? extends K, ? extends V>)
  • Hashtable.Hashtable()
  • Hashtable.Hashtable(int)
  • Hashtable.Hashtable(int, float)


hasInitialContextFactoryBuilder

hasInitialContextFactoryBuilder o7planning.org
  • NamingManager.hasInitialContextFactoryBuilder()


hasInitialResponse

hasInitialResponse o7planning.org
  • SaslClient.hasInitialResponse()


hasLayoutAttributes

hasLayoutAttributes o7planning.org
  • Font.hasLayoutAttributes()


hasLegalValues

hasLegalValues o7planning.org
  • OpenMBeanAttributeInfoSupport.hasLegalValues()
  • OpenMBeanParameterInfo.hasLegalValues()
  • OpenMBeanParameterInfoSupport.hasLegalValues()


hasListeners

hasListeners o7planning.org
  • PropertyChangeSupport.hasListeners(String)
  • VetoableChangeSupport.hasListeners(String)


hasLocation

hasLocation o7planning.org
  • ForwardingJavaFileManager.hasLocation(JavaFileManager.Location)
  • JavaFileManager.hasLocation(JavaFileManager.Location)


hasMaxValue

hasMaxValue o7planning.org
  • OpenMBeanAttributeInfoSupport.hasMaxValue()
  • OpenMBeanParameterInfo.hasMaxValue()
  • OpenMBeanParameterInfoSupport.hasMaxValue()


hasMinValue

hasMinValue o7planning.org
  • OpenMBeanAttributeInfoSupport.hasMinValue()
  • OpenMBeanParameterInfo.hasMinValue()
  • OpenMBeanParameterInfoSupport.hasMinValue()


hasMore

hasMore o7planning.org
  • NamingEnumeration.hasMore()


hasMoreElements

hasMoreElements o7planning.org
  • Enumeration.hasMoreElements()
  • StringTokenizer.hasMoreElements()


hasMoreTokens

hasMoreTokens o7planning.org
  • StringTokenizer.hasMoreTokens()


hasName

hasName o7planning.org
  • StreamReaderDelegate.hasName()
  • XMLStreamReader.hasName()


hasNext

hasNext o7planning.org
  • BeanContextSupport.BCSIterator.hasNext()
  • EventReaderDelegate.hasNext()
  • Iterator.hasNext()
  • ListIterator.hasNext()
  • Scanner.hasNext(Pattern)
  • Scanner.hasNext(String)
  • Scanner.hasNext()
  • StreamReaderDelegate.hasNext()
  • XMLEventReader.hasNext()
  • XMLStreamReader.hasNext()


hasNextBigDecimal

hasNextBigDecimal o7planning.org
  • Scanner.hasNextBigDecimal()


hasNextBigInteger

hasNextBigInteger o7planning.org
  • Scanner.hasNextBigInteger(int)
  • Scanner.hasNextBigInteger()


hasNextBoolean

hasNextBoolean o7planning.org
  • Scanner.hasNextBoolean()


hasNextByte

hasNextByte o7planning.org
  • Scanner.hasNextByte(int)
  • Scanner.hasNextByte()


hasNextDouble

hasNextDouble o7planning.org
  • Scanner.hasNextDouble()


hasNextFloat

hasNextFloat o7planning.org
  • Scanner.hasNextFloat()


hasNextInt

hasNextInt o7planning.org
  • Scanner.hasNextInt(int)
  • Scanner.hasNextInt()


hasNextLine

hasNextLine o7planning.org
  • Scanner.hasNextLine()


hasNextLong

hasNextLong o7planning.org
  • Scanner.hasNextLong(int)
  • Scanner.hasNextLong()


hasNextShort

hasNextShort o7planning.org
  • Scanner.hasNextShort(int)
  • Scanner.hasNextShort()


hasPrevious

hasPrevious o7planning.org
  • ListIterator.hasPrevious()


hasPrimitives

hasPrimitives o7planning.org
  • MethodType.hasPrimitives()


hasQueuedPredecessors

hasQueuedPredecessors o7planning.org
  • AbstractQueuedLongSynchronizer.hasQueuedPredecessors()
  • AbstractQueuedSynchronizer.hasQueuedPredecessors()


hasQueuedSubmissions

hasQueuedSubmissions o7planning.org
  • ForkJoinPool.hasQueuedSubmissions()


hasQueuedThread

hasQueuedThread o7planning.org
  • ReentrantLock.hasQueuedThread(Thread)
  • ReentrantReadWriteLock.hasQueuedThread(Thread)


hasQueuedThreads

hasQueuedThreads o7planning.org
  • AbstractQueuedLongSynchronizer.hasQueuedThreads()
  • AbstractQueuedSynchronizer.hasQueuedThreads()
  • ReentrantLock.hasQueuedThreads()
  • ReentrantReadWriteLock.hasQueuedThreads()
  • Semaphore.hasQueuedThreads()


hasRaster

hasRaster o7planning.org
  • IIOImage.hasRaster()


hasRelation

hasRelation o7planning.org
  • RelationService.hasRelation(String)
  • RelationServiceMBean.hasRelation(String)


hasRemaining

hasRemaining o7planning.org
  • Buffer.hasRemaining()


hasSameRules

hasSameRules o7planning.org
  • SimpleTimeZone.hasSameRules(TimeZone)
  • TimeZone.hasSameRules(TimeZone)


hasService

hasService o7planning.org
  • BeanContextServices.hasService(Class)
  • BeanContextServicesSupport.hasService(Class)


hasText

hasText o7planning.org
  • StreamReaderDelegate.hasText()
  • XMLStreamReader.hasText()


hasThumbnails

hasThumbnails o7planning.org
  • ImageReader.hasThumbnails(int)


hasTileWriters

hasTileWriters o7planning.org
  • BufferedImage.hasTileWriters()
  • WritableRenderedImage.hasTileWriters()


hasTransparentBounds

hasTransparentBounds o7planning.org
  • Matcher.hasTransparentBounds()


hasUniformLineMetrics

hasUniformLineMetrics o7planning.org
  • Font.hasUniformLineMetrics()
  • FontMetrics.hasUniformLineMetrics()


hasUnsupportedCriticalExtension

hasUnsupportedCriticalExtension o7planning.org
  • X509Extension.hasUnsupportedCriticalExtension()


hasWaiters

hasWaiters o7planning.org
  • AbstractQueuedLongSynchronizer.hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject)
  • AbstractQueuedLongSynchronizer.ConditionObject.hasWaiters()
  • AbstractQueuedSynchronizer.hasWaiters(AbstractQueuedSynchronizer.ConditionObject)
  • AbstractQueuedSynchronizer.ConditionObject.hasWaiters()
  • ReentrantLock.hasWaiters(Condition)
  • ReentrantReadWriteLock.hasWaiters(Condition)


hasWaitingConsumer

hasWaitingConsumer o7planning.org
  • LinkedTransferQueue.hasWaitingConsumer()
  • TransferQueue.hasWaitingConsumer()


hasWrappers

hasWrappers o7planning.org
  • MethodType.hasWrappers()


HEAD

HEAD o7planning.org
  • HTML.Tag.HEAD


head

head o7planning.org
  • DTD.head


HEADER

HEADER o7planning.org
  • AccessibleRole.HEADER


header

header o7planning.org
  • BasicTableHeaderUI.header


HEADER_RENDERER_PROPERTY

HEADER_RENDERER_PROPERTY o7planning.org
  • TableColumn.HEADER_RENDERER_PROPERTY


HEADER_ROW

HEADER_ROW o7planning.org
  • TableModelEvent.HEADER_ROW


HEADER_VALUE_PROPERTY

HEADER_VALUE_PROPERTY o7planning.org
  • TableColumn.HEADER_VALUE_PROPERTY


headerRenderer

headerRenderer o7planning.org
  • TableColumn.headerRenderer


headerValue

headerValue o7planning.org
  • TableColumn.headerValue


HeadlessException

HeadlessException o7planning.org
  • HeadlessException.HeadlessException(String)
  • HeadlessException.HeadlessException()


headMap

headMap o7planning.org
  • ConcurrentNavigableMap.headMap(K)
  • ConcurrentNavigableMap.headMap(K, boolean)
  • ConcurrentSkipListMap.headMap(K)
  • ConcurrentSkipListMap.headMap(K, boolean)
  • NavigableMap.headMap(K)
  • NavigableMap.headMap(K, boolean)
  • SortedMap.headMap(K)
  • TreeMap.headMap(K)
  • TreeMap.headMap(K, boolean)


HEADPHONE

HEADPHONE o7planning.org
  • Port.Info.HEADPHONE


headSet

headSet o7planning.org
  • ConcurrentSkipListSet.headSet(E)
  • ConcurrentSkipListSet.headSet(E, boolean)
  • NavigableSet.headSet(E)
  • NavigableSet.headSet(E, boolean)
  • SortedSet.headSet(E)
  • TreeSet.headSet(E)
  • TreeSet.headSet(E, boolean)


heavyWeightPopupEnabled

heavyWeightPopupEnabled o7planning.org
  • ToolTipManager.heavyWeightPopupEnabled


HEBREW

HEBREW o7planning.org
  • Character.UnicodeBlock.HEBREW


height

height o7planning.org
  • Raster.height
  • Rectangle.height
  • SampleModel.height
  • Spring.height(Component)


HEIGHT

HEIGHT o7planning.org
  • CSS.Attribute.HEIGHT
  • HTML.Attribute.HEIGHT
  • SpringLayout.HEIGHT


HEISEI

HEISEI o7planning.org
  • JapaneseEra.HEISEI


helpButtonMnemonic

helpButtonMnemonic o7planning.org
  • BasicFileChooserUI.helpButtonMnemonic


helpButtonText

helpButtonText o7planning.org
  • BasicFileChooserUI.helpButtonText


helpButtonToolTipText

helpButtonToolTipText o7planning.org
  • BasicFileChooserUI.helpButtonToolTipText


helpComplete

helpComplete o7planning.org
  • CountedCompleter.helpComplete(int)


helpQuiesce

helpQuiesce o7planning.org
  • ForkJoinTask.helpQuiesce()


HexBinaryAdapter

HexBinaryAdapter o7planning.org
  • HexBinaryAdapter.HexBinaryAdapter()


HiddenAction

HiddenAction o7planning.org
  • HTMLDocument.HTMLReader.HiddenAction.HiddenAction()


hiddenDivider

hiddenDivider o7planning.org
  • BasicSplitPaneDivider.hiddenDivider


hide

hide o7planning.org
  • BasicComboPopup.hide()
  • ComboPopup.hide()
  • Component.hide()
  • Dialog.hide()
  • JComponent.hide()
  • JInternalFrame.hide()
  • Popup.hide()
  • Window.hide()


HIDE_ON_CLOSE

HIDE_ON_CLOSE o7planning.org
  • WindowConstants.HIDE_ON_CLOSE


hidePopup

hidePopup o7planning.org
  • JComboBox.hidePopup()


hides

hides o7planning.org
  • Elements.hides(Element, Element)


hideWindows

hideWindows o7planning.org
  • InputMethod.hideWindows()


HIERARCHY_BOUNDS_EVENT_MASK

HIERARCHY_BOUNDS_EVENT_MASK o7planning.org
  • AWTEvent.HIERARCHY_BOUNDS_EVENT_MASK


HIERARCHY_CHANGED

HIERARCHY_CHANGED o7planning.org
  • HierarchyEvent.HIERARCHY_CHANGED


HIERARCHY_EVENT_MASK

HIERARCHY_EVENT_MASK o7planning.org
  • AWTEvent.HIERARCHY_EVENT_MASK


HIERARCHY_FIRST

HIERARCHY_FIRST o7planning.org
  • HierarchyEvent.HIERARCHY_FIRST


HIERARCHY_LAST

HIERARCHY_LAST o7planning.org
  • HierarchyEvent.HIERARCHY_LAST


HIERARCHY_REQUEST_ERR

HIERARCHY_REQUEST_ERR o7planning.org
  • DOMException.HIERARCHY_REQUEST_ERR


HierarchyBoundsAdapter

HierarchyBoundsAdapter o7planning.org
  • HierarchyBoundsAdapter.HierarchyBoundsAdapter()


hierarchyChanged

hierarchyChanged o7planning.org
  • AWTEventMulticaster.hierarchyChanged(HierarchyEvent)
  • HierarchyListener.hierarchyChanged(HierarchyEvent)


HierarchyEvent

HierarchyEvent o7planning.org
  • HierarchyEvent.HierarchyEvent(Component, int, Component, Container, long)
  • HierarchyEvent.HierarchyEvent(Component, int, Component, Container)


HIGH

HIGH o7planning.org
  • PageAttributes.PrintQualityType.HIGH
  • PrintQuality.HIGH


HIGH_PRIVATE_USE_SURROGATES

HIGH_PRIVATE_USE_SURROGATES o7planning.org
  • Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES


HIGH_SURROGATES

HIGH_SURROGATES o7planning.org
  • Character.UnicodeBlock.HIGH_SURROGATES


higher

higher o7planning.org
  • ConcurrentSkipListSet.higher(E)
  • NavigableSet.higher(E)
  • TreeSet.higher(E)


higherEntry

higherEntry o7planning.org
  • ConcurrentSkipListMap.higherEntry(K)
  • NavigableMap.higherEntry(K)
  • TreeMap.higherEntry(K)


higherKey

higherKey o7planning.org
  • ConcurrentSkipListMap.higherKey(K)
  • NavigableMap.higherKey(K)
  • TreeMap.higherKey(K)


highestLayer

highestLayer o7planning.org
  • JLayeredPane.highestLayer()


highestOneBit

highestOneBit o7planning.org
  • Integer.highestOneBit(int)
  • Long.highestOneBit(long)


highlight

highlight o7planning.org
  • BasicBorders.ButtonBorder.highlight
  • BasicBorders.FieldBorder.highlight
  • BasicBorders.SplitPaneBorder.highlight
  • BasicSeparatorUI.highlight
  • BasicTabbedPaneUI.highlight
  • EtchedBorder.highlight


highlightColor

highlightColor o7planning.org
  • MetalSliderUI.highlightColor


highlightInner

highlightInner o7planning.org
  • BevelBorder.highlightInner


highlightOuter

highlightOuter o7planning.org
  • BevelBorder.highlightOuter


highSurrogate

highSurrogate o7planning.org
  • Character.highSurrogate(int)


HINTS_OBSERVED

HINTS_OBSERVED o7planning.org
  • RenderableImage.HINTS_OBSERVED


HIRAGANA

HIRAGANA o7planning.org
  • Character.UnicodeBlock.HIRAGANA


hit

hit o7planning.org
  • Graphics2D.hit(Rectangle, Shape, boolean)


hitClip

hitClip o7planning.org
  • Graphics.hitClip(int, int, int, int)


hitEnd

hitEnd o7planning.org
  • Matcher.hitEnd()


hitTestChar

hitTestChar o7planning.org
  • TextLayout.hitTestChar(float, float)
  • TextLayout.hitTestChar(float, float, Rectangle2D)


hitToPoint

hitToPoint o7planning.org
  • TextLayout.hitToPoint(TextHitInfo, Point2D)


HMAC_SHA1

HMAC_SHA1 o7planning.org
  • SignatureMethod.HMAC_SHA1


HMACParameterSpec

HMACParameterSpec o7planning.org
  • HMACParameterSpec.HMACParameterSpec(int)


HOLD_CURSORS_OVER_COMMIT

HOLD_CURSORS_OVER_COMMIT o7planning.org
  • ResultSet.HOLD_CURSORS_OVER_COMMIT


hold_requests

hold_requests o7planning.org
  • POAManagerOperations.hold_requests(boolean)


Holder

Holder o7planning.org
  • Holder.Holder(T)
  • Holder.Holder()


HOLDING

HOLDING o7planning.org
  • State.HOLDING


holdsLock

holdsLock o7planning.org
  • Thread.holdsLock(Object)


HOME

HOME o7planning.org
  • Event.HOME


homeFolderIcon

homeFolderIcon o7planning.org
  • BasicFileChooserUI.homeFolderIcon


homeKey

homeKey o7planning.org
  • BasicSplitPaneUI.homeKey


HONOR_DISPLAY_PROPERTIES

HONOR_DISPLAY_PROPERTIES o7planning.org
  • JEditorPane.HONOR_DISPLAY_PROPERTIES


HORIZONTAL

HORIZONTAL o7planning.org
  • AccessibleState.HORIZONTAL
  • Adjustable.HORIZONTAL
  • GridBagConstraints.HORIZONTAL
  • Scrollbar.HORIZONTAL
  • SwingConstants.HORIZONTAL


HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY

HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY o7planning.org
  • AbstractButton.HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY


HORIZONTAL_CENTER

HORIZONTAL_CENTER o7planning.org
  • SpringLayout.HORIZONTAL_CENTER


HORIZONTAL_SCROLLBAR

HORIZONTAL_SCROLLBAR o7planning.org
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR


HORIZONTAL_SCROLLBAR_ALWAYS

HORIZONTAL_SCROLLBAR_ALWAYS o7planning.org
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_ALWAYS


HORIZONTAL_SCROLLBAR_AS_NEEDED

HORIZONTAL_SCROLLBAR_AS_NEEDED o7planning.org
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED


HORIZONTAL_SCROLLBAR_NEVER

HORIZONTAL_SCROLLBAR_NEVER o7planning.org
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_NEVER